EDOKAApp Reference

EDOKAApp

2006 by Zubler & Partner AG


EDOKAApp Namespace

Namespace EDOKAApp

Classes

class ApplicationFileWatcher |
class DocMgmt |
class EDOKAMain |
class EdokaUpd |
class FolderSelect |
class FrmDomainDokumentart |
class FrmDomainOfficeVorlageDatei |
class FrmFunktionsgruppe_Reportgruppe |
class FrmIndexMutation |
class FrmPartnersuche |
class FrmPasswortWechsel |
class FrmRestore |
class FrmSysadminMenu |
class GenericList |
class HHctrlapi |
class ImageComboBox |
class ImageLibrary |
class ImgGenericList |
class KopiefrmInteressent |
class MultiComboBox |
class OwnerMenu |
class RichTextBoxEx |
class RichTextBoxHS |
class Selektion_Mandant |
class Splash |
class Statushandling |
class WebOCHostCtrl |
class Win32 |
class Win32API |
class WindowPositions |
class WordLib |
class clsBalloon |
class clsEmpfaengerdata |
class clsListViewItemComparer |
class clsMehrfachdruck_Data |
class clsPDF_print_show |
class clsPerformance |
class clsSpooler_Data |
class clsXTimer |
class frmAMSOfficeVorlage |
class frmAbout |
class frmAdminMitarbeiter |
class frmAdminMitarbeiterEdit |
class frmApplication |
class frmAuswertungsgruppeReports |
class frmBLAuslieferungen |
class frmBLDatumab |
class frmBLDossier |
class frmBLDossierzuweisen |
class frmBLDruck | Aktiviert oder deaktiviert die Datumselektionen je Checkbox
class frmBLKunde |
class frmBLKundeVIP |
class frmBLParameter |
class frmBanklagerndverarbeitung |
class frmBarcodeKleber |
class frmBerechtigungen |
class frmCalendar |
class frmCalendar_SP |
class frmDataselect |
class frmDatenbankauswahl |
class frmDatumSelect |
class frmDefekteDokumente |
class frmDescription |
class frmDieFrage |
class frmDoaminStellvertretung |
class frmDokumentAufbereitung |
class frmDokumentInBearbeitung |
class frmDokumentInfoEdit |
class frmDokumentKopieren |
class frmDokumentStatistik |
class frmDokumentbearbeitung |
class frmDokumentbearbeitungBC |
class frmDokumentbearbeitungED |
class frmDokumentberechtigung |
class frmDokumentinformationen |
class frmDokumentpaket |
class frmDokumentpaketInfo |
class frmDokumentpaketdefinition |
class frmDokumentpaketuebersicht |
class frmDokumenttypInfo |
class frmDokumenttypOptions |
class frmDokumenttypbeschreibung |
class frmDokumentvorlage |
class frmDokumentwerte |
class frmDomainAnwendung |
class frmDomainAuswertungen |
class frmDomainAuswertungsgruppe |
class frmDomainBankinformation |
class frmDomainBerechtigung |
class frmDomainColdFolder |
class frmDomainColdIndexFeld |
class frmDomainDokumentartDaten |
class frmDomainDokumenttyp |
class frmDomainDokumenttypDetail |
class frmDomainEditor |
class frmDomainFAAppl |
class frmDomainFADokumenttyp |
class frmDomainFeldtyp |
class frmDomainFunktion |
class frmDomainFunktionsgruppe |
class frmDomainGrund |
class frmDomainIDVMakros |
class frmDomainKeyTabelle |
class frmDomainMailtexte |
class frmDomainMandant |
class frmDomainMarktbereich |
class frmDomainMeldungstexte |
class frmDomainMitarbeiter |
class frmDomainNiederlassung |
class frmDomainObjektbezeichnung |
class frmDomainOfficeVorlage |
class frmDomainPhsischesArchiv |
class frmDomainProzess |
class frmDomainReportfeldregel |
class frmDomainRolle |
class frmDomainSQLQueries |
class frmDomainSpalten |
class frmDomainStatusBezeichnung |
class frmDomainStatusTyp |
class frmDomainSteuerbefehl |
class frmDomainSysadminfuntkion |
class frmDomainTeam |
class frmDomainTipTexte |
class frmDomainVorlagenfeldregel |
class frmDomainZuordnungen |
class frmDruckMessage |
class frmDruckabschluss |
class frmEDOKA_Import |
class frmEdokaAdresse |
class frmEdoka_Import_TextEditor |
class frmFAQ |
class frmFavoritenZuordnung |
class frmFunktionsgruppeRolle |
class frmGeburtstag |
class frmHinweismeldung |
class frmHinweismeldung1 |
class frmHinweismeldung2 |
class frmHostTransfer |
class frmIDVMakroOfficeVorlage |
class frmIconSelector |
class frmInformationsEmpfaenger |
class frmInteressent |
class frmKostenstelle |
class frmLoeschgrund |
class frmLog |
class frmLogin |
class frmMassenMail |
class frmMehrfachdruck |
class frmMeldungen |
class frmMessageWeiterleitung |
class frmMetaDatenSelector |
class frmMitarbeiterFunktionsgruppe |
class frmMitarbeiterRolle |
class frmMitarbeiterSelektion |
class frmMitarbeitereinstellungen |
class frmNLDokumente |
class frmNewNote |
class frmNoteDetail |
class frmNotes |
class frmNotfallDataGenerate |
class frmNotfallimport |
class frmNotizen |
class frmOffeneDPInstanzen |
class frmOfficeBearbeitung |
class frmOfficePreview |
class frmPDFPrinter |
class frmPDF_Printer |
class frmParameterSetName |
class frmPartnerCold |
class frmPartnerDetails |
class frmPartnerHost |
class frmPartnerInfo |
class frmPartnerlisteLaden |
class frmPartnerlisteSpeichern |
class frmPartnerlisteVerwalten |
class frmPartnersucheInfo |
class frmPartnerzusammenlegung |
class frmPasswort |
class frmProfil |
class frmProfilDokAuswertung |
class frmProfilinfo |
class frmProgress |
class frmQuery |
class frmReaktivierungsgrund |
class frmReleaseNotes |
class frmReportFelder |
class frmReportSelection |
class frmReportViewer |
class frmReport_reportfeldregel |
class frmReportgruppe_Report |
class frmReporting |
class frmRestorJournal |
class frmRevision |
class frmRolleBerechtigung |
class frmRolleDokumentHierarchie |
class frmRolleDokumentTyp |
class frmRolleReportGruppe |
class frmRolle_Sysadminfunktion |
class frmSBPDFPrinter |
class frmSBSpaltenDarstellung |
class frmSearchDoc |
class frmSelectStatus |
class frmSerienbriefe |
class frmSerienbriefe_Load |
class frmSetDokVerantwortlicher |
class frmSicherungsjournal |
class frmSortSelect |
class frmSpaltenDarstellung |
class frmStatusSetzen |
class frmStatustypStatusbezeichnung |
class frmStatuswechsel |
class frmStellvertreterAdd |
class frmSuchFormular |
class frmSysadminTableSelector |
class frmTrefferliste |
class frmTrefferlistex |
class frmValueSelect |
class frmValueSelector |
class frmVorlagenauswahl |
class frmVorlagenauswahl_Serienbriefe |
class frmVorlagenfelddetail |
class frmWaitforClosing |
class frmWatchJob |
class frmWordViewer |
class frmbcquestion |
class frmblkundeMA |
class frmblkundenparameter |
class frmcoldindx |
class frmcoldview |
class frmcoldviewer |
class frmdomainloeschgrund |
class frmedokaUpdate |
class frmpartnermavip |
class frmpersvorlageladen |
class frmsbdruck |
class frmsbpartnerdetail |
class frmtes |
class frmtextmarken |
class frmtxtBemerkung |
class ucProgress |
class ucedit |
class ucnoedit |
class xfrmDomainMitarbeiter |


EDOKAApp Members

EDOKAApp overview

Classes

class ApplicationFileWatcher |
class DocMgmt |
class EDOKAMain |
class EdokaUpd |
class FolderSelect |
class FrmDomainDokumentart |
class FrmDomainOfficeVorlageDatei |
class FrmFunktionsgruppe_Reportgruppe |
class FrmIndexMutation |
class FrmPartnersuche |
class FrmPasswortWechsel |
class FrmRestore |
class FrmSysadminMenu |
class GenericList |
class HHctrlapi |
class ImageComboBox |
class ImageLibrary |
class ImgGenericList |
class KopiefrmInteressent |
class MultiComboBox |
class OwnerMenu |
class RichTextBoxEx |
class RichTextBoxHS |
class Selektion_Mandant |
class Splash |
class Statushandling |
class WebOCHostCtrl |
class Win32 |
class Win32API |
class WindowPositions |
class WordLib |
class clsBalloon |
class clsEmpfaengerdata |
class clsListViewItemComparer |
class clsMehrfachdruck_Data |
class clsPDF_print_show |
class clsPerformance |
class clsSpooler_Data |
class clsXTimer |
class frmAMSOfficeVorlage |
class frmAbout |
class frmAdminMitarbeiter |
class frmAdminMitarbeiterEdit |
class frmApplication |
class frmAuswertungsgruppeReports |
class frmBLAuslieferungen |
class frmBLDatumab |
class frmBLDossier |
class frmBLDossierzuweisen |
class frmBLDruck | Aktiviert oder deaktiviert die Datumselektionen je Checkbox
class frmBLKunde |
class frmBLKundeVIP |
class frmBLParameter |
class frmBanklagerndverarbeitung |
class frmBarcodeKleber |
class frmBerechtigungen |
class frmCalendar |
class frmCalendar_SP |
class frmDataselect |
class frmDatenbankauswahl |
class frmDatumSelect |
class frmDefekteDokumente |
class frmDescription |
class frmDieFrage |
class frmDoaminStellvertretung |
class frmDokumentAufbereitung |
class frmDokumentInBearbeitung |
class frmDokumentInfoEdit |
class frmDokumentKopieren |
class frmDokumentStatistik |
class frmDokumentbearbeitung |
class frmDokumentbearbeitungBC |
class frmDokumentbearbeitungED |
class frmDokumentberechtigung |
class frmDokumentinformationen |
class frmDokumentpaket |
class frmDokumentpaketInfo |
class frmDokumentpaketdefinition |
class frmDokumentpaketuebersicht |
class frmDokumenttypInfo |
class frmDokumenttypOptions |
class frmDokumenttypbeschreibung |
class frmDokumentvorlage |
class frmDokumentwerte |
class frmDomainAnwendung |
class frmDomainAuswertungen |
class frmDomainAuswertungsgruppe |
class frmDomainBankinformation |
class frmDomainBerechtigung |
class frmDomainColdFolder |
class frmDomainColdIndexFeld |
class frmDomainDokumentartDaten |
class frmDomainDokumenttyp |
class frmDomainDokumenttypDetail |
class frmDomainEditor |
class frmDomainFAAppl |
class frmDomainFADokumenttyp |
class frmDomainFeldtyp |
class frmDomainFunktion |
class frmDomainFunktionsgruppe |
class frmDomainGrund |
class frmDomainIDVMakros |
class frmDomainKeyTabelle |
class frmDomainMailtexte |
class frmDomainMandant |
class frmDomainMarktbereich |
class frmDomainMeldungstexte |
class frmDomainMitarbeiter |
class frmDomainNiederlassung |
class frmDomainObjektbezeichnung |
class frmDomainOfficeVorlage |
class frmDomainPhsischesArchiv |
class frmDomainProzess |
class frmDomainReportfeldregel |
class frmDomainRolle |
class frmDomainSQLQueries |
class frmDomainSpalten |
class frmDomainStatusBezeichnung |
class frmDomainStatusTyp |
class frmDomainSteuerbefehl |
class frmDomainSysadminfuntkion |
class frmDomainTeam |
class frmDomainTipTexte |
class frmDomainVorlagenfeldregel |
class frmDomainZuordnungen |
class frmDruckMessage |
class frmDruckabschluss |
class frmEDOKA_Import |
class frmEdokaAdresse |
class frmEdoka_Import_TextEditor |
class frmFAQ |
class frmFavoritenZuordnung |
class frmFunktionsgruppeRolle |
class frmGeburtstag |
class frmHinweismeldung |
class frmHinweismeldung1 |
class frmHinweismeldung2 |
class frmHostTransfer |
class frmIDVMakroOfficeVorlage |
class frmIconSelector |
class frmInformationsEmpfaenger |
class frmInteressent |
class frmKostenstelle |
class frmLoeschgrund |
class frmLog |
class frmLogin |
class frmMassenMail |
class frmMehrfachdruck |
class frmMeldungen |
class frmMessageWeiterleitung |
class frmMetaDatenSelector |
class frmMitarbeiterFunktionsgruppe |
class frmMitarbeiterRolle |
class frmMitarbeiterSelektion |
class frmMitarbeitereinstellungen |
class frmNLDokumente |
class frmNewNote |
class frmNoteDetail |
class frmNotes |
class frmNotfallDataGenerate |
class frmNotfallimport |
class frmNotizen |
class frmOffeneDPInstanzen |
class frmOfficeBearbeitung |
class frmOfficePreview |
class frmPDFPrinter |
class frmPDF_Printer |
class frmParameterSetName |
class frmPartnerCold |
class frmPartnerDetails |
class frmPartnerHost |
class frmPartnerInfo |
class frmPartnerlisteLaden |
class frmPartnerlisteSpeichern |
class frmPartnerlisteVerwalten |
class frmPartnersucheInfo |
class frmPartnerzusammenlegung |
class frmPasswort |
class frmProfil |
class frmProfilDokAuswertung |
class frmProfilinfo |
class frmProgress |
class frmQuery |
class frmReaktivierungsgrund |
class frmReleaseNotes |
class frmReportFelder |
class frmReportSelection |
class frmReportViewer |
class frmReport_reportfeldregel |
class frmReportgruppe_Report |
class frmReporting |
class frmRestorJournal |
class frmRevision |
class frmRolleBerechtigung |
class frmRolleDokumentHierarchie |
class frmRolleDokumentTyp |
class frmRolleReportGruppe |
class frmRolle_Sysadminfunktion |
class frmSBPDFPrinter |
class frmSBSpaltenDarstellung |
class frmSearchDoc |
class frmSelectStatus |
class frmSerienbriefe |
class frmSerienbriefe_Load |
class frmSetDokVerantwortlicher |
class frmSicherungsjournal |
class frmSortSelect |
class frmSpaltenDarstellung |
class frmStatusSetzen |
class frmStatustypStatusbezeichnung |
class frmStatuswechsel |
class frmStellvertreterAdd |
class frmSuchFormular |
class frmSysadminTableSelector |
class frmTrefferliste |
class frmTrefferlistex |
class frmValueSelect |
class frmValueSelector |
class frmVorlagenauswahl |
class frmVorlagenauswahl_Serienbriefe |
class frmVorlagenfelddetail |
class frmWaitforClosing |
class frmWatchJob |
class frmWordViewer |
class frmbcquestion |
class frmblkundeMA |
class frmblkundenparameter |
class frmcoldindx |
class frmcoldview |
class frmcoldviewer |
class frmdomainloeschgrund |
class frmedokaUpdate |
class frmpartnermavip |
class frmpersvorlageladen |
class frmsbdruck |
class frmsbpartnerdetail |
class frmtes |
class frmtextmarken |
class frmtxtBemerkung |
class ucProgress |
class ucedit |
class ucnoedit |
class xfrmDomainMitarbeiter |

See Also

EDOKAApp Namespace


ApplicationFileWatcher Class

For a list of all members of this type, see ApplicationFileWatcher Members.

System.Object
EDOKAApp.ApplicationFileWatcher

Public Class ApplicationFileWatcher

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ApplicationFileWatcher Members


ApplicationFileWatcher Members

ApplicationFileWatcher overview

Constructors

constructor ApplicationFileWatcher Constructor (Overloaded)

Properties

property ApplicationType
property Appname
property Filename
property WindowName
property WindowNameDC
property WindowNamePreview

Methods

method BringWindowToTop
method Dispose
method FillActiveWindowsList
method ProcessIsActiveWindow
method Search_List
method SetWindowName
method Start
method Stopp
method TimerFired
method doc_is_active

Events

event DocumentClosed

Fields

field MyTimer
field WindowArray
field m_ApplicationType
field m_Applicationname
field m_Filename
field m_WindowName
field m_WindowNameDC
field m_WindowNamePreview
field m_isActive

See Also

ApplicationFileWatcher Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal typ As Integer, ByVal DocFileName As String)

See Also

ApplicationFileWatcher | EDOKAApp


ApplicationFileWatcher Properties

ApplicationFileWatcher overview

Properties

property ApplicationType
property Appname
property Filename
property WindowName
property WindowNameDC
property WindowNamePreview

See Also

ApplicationFileWatcher Class


ApplicationFileWatcher.ApplicationType Property

Property ApplicationType()

Source code

[Visual Basic]
    Property ApplicationType()
        Get
            Return m_ApplicationType
        End Get
        Set(ByVal Value)
            m_ApplicationType = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Appname Property

Property Appname() As String

Source code

[Visual Basic]
    Property Appname() As String
        Get
            Return m_Applicationname
        End Get
        Set(ByVal Value As String)
            m_Applicationname = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Filename Property

Property Filename() As String

Source code

[Visual Basic]
    Property Filename() As String
        Get
            Return m_Filename
        End Get
        Set(ByVal Value As String)
            m_Filename = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.WindowName Property

Property WindowName() As String

Source code

[Visual Basic]
    Property WindowName() As String
        Get
            Return m_WindowName
        End Get
        Set(ByVal Value As String)
            m_WindowName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.WindowNameDC Property

Property WindowNameDC() As String

Source code

[Visual Basic]
    Property WindowNameDC() As String
        Get
            Return m_WindowNameDC
        End Get
        Set(ByVal Value As String)
            m_WindowNameDC = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.WindowNamePreview Property

Property WindowNamePreview() As String

Source code

[Visual Basic]
    Property WindowNamePreview() As String
        Get
            Return m_WindowNamePreview
        End Get
        Set(ByVal Value As String)
            m_WindowNamePreview = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher Methods

ApplicationFileWatcher overview

Methods

method BringWindowToTop
method Dispose
method FillActiveWindowsList
method ProcessIsActiveWindow
method Search_List
method SetWindowName
method Start
method Stopp
method TimerFired
method doc_is_active

See Also

ApplicationFileWatcher Class


ApplicationFileWatcher.BringWindowToTop Method

Public Sub BringWindowToTop()

Source code

[Visual Basic]
    Public Sub BringWindowToTop()
        Dim i As Integer
        SetWindowName()
        i = Win32API.FindWindow(vbNullString, Me.WindowName)
        If i <> 0 Then
            'i = Win32API.SetForegroundWindow(i)
            i = Win32API.ShowWindow(i, Win32API.SW_RESTORE)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Dispose Method

Public Sub Dispose()

Source code

[Visual Basic]
    Public Sub Dispose()
        Me.WindowArray = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.FillActiveWindowsList Method

Function FillActiveWindowsList( _
   ByVal hWnd As Integer, _
   ByVal lParam As Integer _
) As Boolean

Parameters

hWnd
Required.
lParam
Required.

Source code

[Visual Basic]
    Function FillActiveWindowsList(ByVal hWnd As Integer, ByVal lParam As Integer) As Boolean
        Dim windowText As New StringBuilder(STRING_BUFFER_LENGTH)
        Win32API.GetWindowText(hWnd, windowText, STRING_BUFFER_LENGTH)
        If ProcessIsActiveWindow(hWnd) Then
            Me.WindowArray.Add(windowText.ToString)
        End If
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.ProcessIsActiveWindow Method

Function ProcessIsActiveWindow( _
   ByVal hWnd As Integer _
) As Boolean

Parameters

hWnd
Required.

Source code

[Visual Basic]
    Function ProcessIsActiveWindow(ByVal hWnd As Integer) As Boolean
        Dim windowText As New StringBuilder(STRING_BUFFER_LENGTH)
        Dim windowIsOwned As Boolean
        Dim windowStyle As Integer
        Win32API.GetWindowText(hWnd, windowText, STRING_BUFFER_LENGTH)
        windowIsOwned = Win32API.GetWindow(hWnd, Win32API.GW_OWNER) <> 0
        windowStyle = Win32API.GetWindowLong(hWnd, Win32API.GWL_EXSTYLE)
        Return True

        If Not Win32API.IsWindowVisible(hWnd) Then
            Return False
        End If
        If windowText.ToString.Equals("") Then
            Return False
        End If
        If Win32API.GetParent(hWnd) <> 0 Then
            Return False
        End If
        If (windowStyle And Win32API.WS_EX_TOOLWINDOW) <> 0 And Not windowIsOwned Then
            Return False
        End If
        If (windowStyle And Win32API.WS_EX_APPWINDOW) = 0 And windowIsOwned Then
            Return False
        End If
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Search_List Method

Private Sub Search_List()

Source code

[Visual Basic]
    Private Sub Search_List()
        Win32API.EnumWindowsDllImport(New Win32API.EnumWindowsCallback(AddressOf _
            FillActiveWindowsList), 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.SetWindowName Method

Public Sub SetWindowName()

Source code

[Visual Basic]
    Public Sub SetWindowName()
        Select Case Me.ApplicationType
            Case 1 'Word
                Me.WindowName = Me.Filename + " - Microsoft Word"
                Me.WindowNamePreview = Me.Filename + " (Seitenansicht) - Microsoft Word"
                Me.WindowNameDC = Me.Filename + " - DC"
            Case 2 'Excel
                Me.WindowName = "Microsoft Excel - " & Me.Filename
                Me.WindowNamePreview = "Microsoft Excel - " & Me.Filename
                Me.WindowNameDC = Me.Filename + ""
            Case 3
                Me.WindowName = Me.Appname & Me.Filename
                Me.WindowNamePreview = Me.Appname & Me.Filename
                Me.WindowNameDC = Me.Filename + ""
            Case 4
                Me.WindowName = Me.WindowName
                Me.WindowNamePreview = Me.WindowNamePreview
                Me.WindowNameDC = Me.Filename + ""
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Start Method

Public Sub Start()

Source code

[Visual Basic]
    Public Sub Start()
        AddHandler MyTimer.Elapsed, AddressOf TimerFired
        SetWindowName()
        MyTimer.Start()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.Stopp Method

Public Sub Stopp()

Source code

[Visual Basic]
    Public Sub Stopp()
        Me.MyTimer.Stop()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.TimerFired Method

Public Sub TimerFired( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles MyTimer.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub TimerFired(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles MyTimer.Elapsed
        MyTimer.Stop()
        '        Dim sW As New StreamWriter("C:\TRACE.LOG", True)
        '       sW.WriteLine(Now)
        Dim DocFound As Boolean = False
        Dim i As Integer
        Dim zz As Integer = 0
        'While zz < 3 And DocFound = False
        Me.WindowArray.Clear()
        Search_List()
        For i = 0 To Me.WindowArray.Count - 1
            '          sW.WriteLine(Me.WindowName + ":" + Me.WindowArray.Item(i))
            'If Me.WindowArray.Item(i) = Me.WindowName Then MsgBox("Ist aktiv")
            If Me.WindowArray.Item(i) = Me.WindowName Then DocFound = True
            If Me.WindowArray.Item(i) = Me.WindowNamePreview Then DocFound = True
            If Me.WindowArray.Item(i) = Me.WindowNameDC Then DocFound = True
        Next
        'zz = zz + 1
        '     System.Threading.Thread.CurrentThread.Sleep(300)
        '    'End While
        '   System.Threading.Thread.CurrentThread.Sleep(300)
        If Not DocFound Then
            Dim fn As String = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "~$" + Microsoft.VisualBasic.Right(Me.Filename, Len(Me.Filename) - 2)
            Dim fc As New FileInfo(fn)
            If fc.Exists Then DocFound = True
            If Not DocFound Then
                '          sW.WriteLine("Stop:" + Me.WindowName)
                MyTimer.Stop()
                RaiseEvent DocumentClosed()
            Else
                MyTimer.Start()
            End If
        Else
            MyTimer.Start()
        End If
        DocFound = Nothing
        'sW.WriteLine(Now)
        'sW.Flush()
        'sW.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher.doc_is_active Method

Public Function doc_is_active() As Boolean

Source code

[Visual Basic]
    Public Function doc_is_active() As Boolean
        Dim I As Integer
        Search_List()
        For I = 0 To Me.WindowArray.Count - 1
            If Me.WindowArray.Item(I) = Me.WindowName Then doc_is_active = True
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher Events

ApplicationFileWatcher overview

Events

event DocumentClosed

See Also

ApplicationFileWatcher Class


DocumentClosed Event

Public Event DocumentClosed()

Source code

[Visual Basic]
    Public Event DocumentClosed()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


ApplicationFileWatcher Fields

ApplicationFileWatcher overview

Fields

field MyTimer
field WindowArray
field m_ApplicationType
field m_Applicationname
field m_Filename
field m_WindowName
field m_WindowNameDC
field m_WindowNamePreview
field m_isActive

See Also

ApplicationFileWatcher Class


MyTimer Variable

Dim WithEvents MyTimer As New System.Timers.Timer( _
   1000 _
)

Source code

[Visual Basic]
    Dim WithEvents MyTimer As New System.Timers.Timer(1000)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


WindowArray Variable

Dim WindowArray As New ArrayList()

Source code

[Visual Basic]
    Dim WindowArray As New ArrayList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_ApplicationType Variable

Private m_ApplicationType As Integer

Source code

[Visual Basic]
    Private m_ApplicationType As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_Applicationname Variable

Private m_Applicationname As String

Source code

[Visual Basic]
    Private m_Applicationname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_Filename Variable

Private m_Filename As String

Source code

[Visual Basic]
    Private m_Filename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_WindowName Variable

Private m_WindowName As String

Source code

[Visual Basic]
    Private m_WindowName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_WindowNameDC Variable

Private m_WindowNameDC As String

Source code

[Visual Basic]
    Private m_WindowNameDC As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_WindowNamePreview Variable

Private m_WindowNamePreview As String

Source code

[Visual Basic]
    Private m_WindowNamePreview As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_isActive Variable

Private m_isActive As Boolean

Source code

[Visual Basic]
    Private m_isActive As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


DocMgmt Class

For a list of all members of this type, see DocMgmt Members.

System.Object
EDOKAApp.DocMgmt

Public Class DocMgmt

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

DocMgmt Members


DocMgmt Members

DocMgmt overview

Properties

property DokumentID
property Dokumentname

Methods

method Get_From_DB
method Get_layout_from_DB
method Get_suchlayout_from_DB
method Save_Layout_DB
method Save_SuchLayout_DB
method Save_To_DB
method check_doc

Fields

field m_dokumentid
field m_dokumentname

See Also

DocMgmt Class


DocMgmt Properties

DocMgmt overview

Properties

property DokumentID
property Dokumentname

See Also

DocMgmt Class


DocMgmt.DokumentID Property

Property DokumentID() As String

Source code

[Visual Basic]
    Property DokumentID() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Dokumentname Property

Property Dokumentname() As String

Source code

[Visual Basic]
    Property Dokumentname() As String
        Get
            Return m_dokumentname
        End Get
        Set(ByVal Value As String)
            m_dokumentname = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt Methods

DocMgmt overview

Methods

method Get_From_DB
method Get_layout_from_DB
method Get_suchlayout_from_DB
method Save_Layout_DB
method Save_SuchLayout_DB
method Save_To_DB
method check_doc

See Also

DocMgmt Class


DocMgmt.Get_From_DB Method

Public Function Get_From_DB( _
   ByVal sDokumentID As String, _
   ByVal sDokumentName As String _
) As Boolean

Parameters

sDokumentID
Required.
sDokumentName
Required.

Source code

[Visual Basic]
    Public Function Get_From_DB(ByVal sDokumentID As String, ByVal sDokumentName As String) As Boolean
        Me.DokumentID = sDokumentID
        Me.Dokumentname = sDokumentName

        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From doks where DokumentID='" + Me.DokumentID + "'", connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()

        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")

            'Versuchen, ob es sich um ein EDKIMP-Dokument handelt - Rel. 3.73 SHU
            If ds.Tables(0).Rows.Count = 0 Then
                da.SelectCommand.CommandText = "Select * from doks where dokumentid='" + "EDKIMP" + Microsoft.VisualBasic.Right(Me.DokumentID, Len(Me.DokumentID) - 6) + "'"
                da.Fill(ds, "Docs")
            End If

            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(1)
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(sDokumentName, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
        Catch ex As Exception
            If Not DivFnkt.isbck(Me.DokumentID) And Not DivFnkt.BDR_Dokument(Me.DokumentID) Then
                MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
            End If
            Return False
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Get_layout_from_DB Method

Public Function Get_layout_from_DB( _
   ByVal profilnr As Integer, _
   ByVal sdokumentname As String _
) As String

Parameters

profilnr
Required.
sdokumentname
Required.

Source code

[Visual Basic]
    Public Function Get_layout_from_DB(ByVal profilnr As Integer, ByVal sdokumentname As String) As String
        Me.Dokumentname = LTrim(Str(profilnr)) + ".lyt"
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From profillayout where profilnr=" + Str(profilnr), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            '***********************************
            'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
            '29.7.2004 / SHU
            '***********************************
            Select Case UCase(Right(sdokumentname, 5))
                Case "T.LYT"
                    MyData = myRow.Item(2)
                Case "M.LYT"
                    MyData = myRow.Item(3)
                Case "V.LYT"
                    MyData = myRow.Item(4)
                Case Else
                    MyData = myRow.Item(1)
            End Select

            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(sdokumentname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
        Catch ex As Exception
            Return False
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Get_suchlayout_from_DB Method

Public Function Get_suchlayout_from_DB( _
   ByVal profilnr As Integer, _
   ByVal sdokumentname As String _
) As String

Parameters

profilnr
Required.
sdokumentname
Required.

Source code

[Visual Basic]
    Public Function Get_suchlayout_from_DB(ByVal profilnr As Integer, ByVal sdokumentname As String) As String
        Me.Dokumentname = LTrim(Str(profilnr)) + ".lyt"
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From suchprofillayout where suchprofilnr=" + Str(profilnr), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            '***********************************
            'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
            '29.7.2004 / SHU
            '***********************************
            Select Case UCase(Right(sdokumentname, 6))
                Case "TS.LYT"
                    MyData = myRow.Item(2)
                Case "MS.LYT"
                    MyData = myRow.Item(3)
                Case "VS.LYT"
                    MyData = myRow.Item(4)
                Case Else
                    MyData = myRow.Item(1)
            End Select

            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(sdokumentname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
        Catch ex As Exception
            Return False
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Save_Layout_DB Method

Public Function Save_Layout_DB( _
   ByVal profilnr As Integer, _
   ByVal sDokumentName As String _
) As Boolean

Parameters

profilnr
Required.
sDokumentName
Required.

Source code

[Visual Basic]
    Public Function Save_Layout_DB(ByVal profilnr As Integer, ByVal sDokumentName As String) As Boolean
        Dim Connection As New SqlConnection()
        Dim DA As New SqlDataAdapter("select * from profillayout where profilnr=" + Str(profilnr), Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
        Dim ds As New DataSet()
        Dim fs As New FileStream(sDokumentName, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        fs.Read(mydata, 0, fs.Length)
        fs.Close()
        Try
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            DA.Fill(ds, "profil")
            Dim myRow As DataRow
            If ds.Tables(0).Rows.Count = 0 Then
                ' Neues Dokument speichern
                myRow = ds.Tables(0).NewRow
                myRow.Item(0) = profilnr
                '***********************************
                'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
                '29.7.2004 / SHU
                '***********************************
                Select Case UCase(Right(sDokumentName, 5))
                    Case "T.LYT"
                        myRow.Item(2) = mydata
                    Case "M.LYT"
                        myRow.Item(3) = mydata
                    Case "V.LYT"
                        myRow.Item(4) = mydata
                    Case Else
                        myRow.Item(1) = mydata
                End Select
                ds.Tables(0).Rows.Add(myRow)
                DA.Update(ds, "profil")
            Else
                'Bestehendes Dokument sichern
                myRow = ds.Tables(0).Rows(0)
                '***********************************
                'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
                '29.7.2004 / SHU
                '***********************************
                Select Case UCase(Right(sDokumentName, 5))
                    Case "T.LYT"
                        myRow.Item(2) = mydata
                    Case "M.LYT"
                        myRow.Item(3) = mydata
                    Case "V.LYT"
                        myRow.Item(4) = mydata
                    Case Else
                        myRow.Item(1) = mydata
                End Select
                DA.Update(ds, "profil")
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
            Return False
        End Try
        fs = Nothing
        cb = Nothing
        ds = Nothing
        DA = Nothing

        Connection.Close()
        Connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Save_SuchLayout_DB Method

Public Function Save_SuchLayout_DB( _
   ByVal profilnr As Integer, _
   ByVal sDokumentName As String _
) As Boolean

Parameters

profilnr
Required.
sDokumentName
Required.

Source code

[Visual Basic]
    Public Function Save_SuchLayout_DB(ByVal profilnr As Integer, ByVal sDokumentName As String) As Boolean
        Dim Connection As New SqlConnection()
        Dim DA As New SqlDataAdapter("select * from suchprofillayout where suchprofilnr=" + Str(profilnr), Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
        Dim ds As New DataSet()
        Dim fs As New FileStream(sDokumentName, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        fs.Read(mydata, 0, fs.Length)
        fs.Close()
        Try
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            DA.Fill(ds, "profil")
            Dim myRow As DataRow
            If ds.Tables(0).Rows.Count = 0 Then
                ' Neues Dokument speichern
                myRow = ds.Tables(0).NewRow
                myRow.Item(0) = profilnr
                '***********************************
                'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
                '29.7.2004 / SHU
                '***********************************
                Select Case UCase(Right(sDokumentName, 6))
                    Case "TS.LYT"
                        myRow.Item(2) = mydata
                    Case "MS.LYT"
                        myRow.Item(3) = mydata
                    Case "VS.LYT"
                        myRow.Item(4) = mydata
                    Case Else
                        myRow.Item(1) = mydata
                End Select
                ds.Tables(0).Rows.Add(myRow)
                DA.Update(ds, "profil")
            Else
                'Bestehendes Dokument sichern
                myRow = ds.Tables(0).Rows(0)
                '***********************************
                'Je nach Layoutfile, Daten aus entsprechendem Feld lesen
                '29.7.2004 / SHU
                '***********************************
                Select Case UCase(Right(sDokumentName, 6))
                    Case "TS.LYT"
                        myRow.Item(2) = mydata
                    Case "MS.LYT"
                        myRow.Item(3) = mydata
                    Case "VS.LYT"
                        myRow.Item(4) = mydata
                    Case Else
                        myRow.Item(1) = mydata
                End Select
                DA.Update(ds, "profil")
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
            Return False
        End Try
        fs = Nothing
        cb = Nothing
        ds = Nothing
        DA = Nothing

        Connection.Close()
        Connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.Save_To_DB Method

Public Function Save_To_DB( _
   ByVal sDokumentID As String, _
   ByVal sDokumentName As String _
) As Boolean

Parameters

sDokumentID
Required.
sDokumentName
Required.

Source code

[Visual Basic]
    Public Function Save_To_DB(ByVal sDokumentID As String, ByVal sDokumentName As String) As Boolean
        Try
            Me.DokumentID = sDokumentID
            Me.Dokumentname = sDokumentName

            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from doks where dokumentid='" + Me.DokumentID + "'", Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(Me.Dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Dokument von Filesystem lesen")
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "docs")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Dokument speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Me.DokumentID
                    myRow.Item(1) = mydata
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "docs")
                    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Neues Dokument gespeichert")
                Else
                    'Bestehendes Dokument sichenr
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(1) = mydata
                    DA.Update(ds, "docs")
                    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Bestehendes Dokument ersetzt")
                End If
            Catch ex As Exception
                Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Fehler bei der Dokumentspeicherung")
                MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Fehler bei der Dokumentspeicherung")
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt.check_doc Method

Public Function check_doc( _
   ByVal fnkt As Integer _
) As DataTable

Parameters

fnkt
Required.

Source code

[Visual Basic]
    Public Function check_doc(ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_dok"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@stationsname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Environ("Computername")))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Check_Doc::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


DocMgmt Fields

DocMgmt overview

Fields

field m_dokumentid
field m_dokumentname

See Also

DocMgmt Class


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


m_dokumentname Variable

Dim m_dokumentname As String

Source code

[Visual Basic]
    Dim m_dokumentname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DocMgmt


EDOKAMain Class

For a list of all members of this type, see EDOKAMain Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKAMain

Public Class EDOKAMain
   Inherits System.Windows.Forms.Form
   Implements mMain.SingleInstance.ISingleInstanceForm

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

EDOKAMain Members


EDOKAMain Members

EDOKAMain overview

Constructors

constructor EDOKAMain Constructor

Properties

property hWnd

Methods

method Check_Geburtstag
method Check_offene_dp_instanzen
method Check_show_sb
method Delete_Old_Files
method Dispose
method EDOKAMain_Closing
method EDOKAMain_Load (Overloaded)
method HandleCommand (Overloaded)
method InitializeComponent
method MenuItem11_Click
method MenuItem12_Click
method MenuItem12_Click_1
method MenuItem12_Click_2
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem20_Click
method MenuItem21_Popup
method MenuItem22_Click
method MenuItem23_Click
method MenuItem24_Click
method MenuItem25_Click
method MenuItem26_Click
method MenuItem27_Click
method MenuItem28_Click
method MenuItem29_Click
method MenuItem2_Click
method MenuItem2_Popup
method MenuItem2_Select
method MenuItem30_Click
method MenuItem31_Click
method MenuItem33_Click
method MenuItem34_Click
method MenuItem35_Click
method MenuItem36_Click
method MenuItem37_Click
method MenuItem39_Click
method MenuItem39_DrawItem
method MenuItem3_Click
method MenuItem40_Click
method MenuItem42_Click
method MenuItem43_Click
method MenuItem44_Click
method MenuItem45_Popup
method MenuItem46_Click
method MenuItem47_Click
method MenuItem48_Click
method MenuItem49_Click
method MenuItem50_Click
method MenuItem51_Click
method MenuItem52_Click
method MenuItem53_Click
method MenuItem54_Click
method MenuItem55_Click
method MenuItem56_Click
method MenuItem58_Click
method MenuItem5_Click
method MenuItem60_Click
method MenuItem61_Click
method MenuItem61_Click_1
method MenuItem62_PopUp
method MenuItem63_Click
method MenuItem6_Click
method MnuSystemadministration_Click
method Office_Freigeben
method SetLocalSystemTime
method StatusBar1_DoubleClick
method StatusBar1_TextChanged
method Timer1_Elapsed
method Timer2_Elapsed
method Timer3_Elapsed
method TimerFired
method WndProc
method check_doc
method check_doc_abschluss
method check_version
method close_all_childs
method edokamain_resize
method get_profile
method init_system
method mnuPartnerlisten_Click
method mnuauslieferungen_Click
method mnudpinstanz_Click
method mnuserienbriefe_Click
method open_suchprofil
method open_trefferliste
method refresh_menu_trefferliste

Events

event WndProc2

Fields

field DataSet1
field Edoka_Gestartet
field HelpProvider1
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem54
field MenuItem55
field MenuItem56
field MenuItem57
field MenuItem58
field MenuItem59
field MenuItem6
field MenuItem60
field MenuItem61
field MenuItem62
field MenuItem63
field MenuItem64
field MenuItem65
field MenuItem66
field MenuItem7
field MenuItem8
field MenuItem9
field MnuNewLogin
field MnuSystemadministration
field MyTimer
field Panel1
field Parameters
field ShowDefekteDokumente
field ShowGeburtstag
field SqlConnection1
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field StatusBar1
field Timer1
field Timer2
field Timer3
field components
field f1
field fcheckdoc
field forceexit
field frmpartnerzusammenlegung
field mnuPartnerlisten
field mnuauslieferungen
field mnucollection
field mnudp1
field mnudp10
field mnudp2
field mnudp3
field mnudp4
field mnudp5
field mnudp6
field mnudp7
field mnudp8
field mnudp9
field mnuserienbriefe
field mytimerstopped
field on_Create
field pnr
field shellparams
field spnr

See Also

EDOKAMain Class


EDOKAMain Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain Properties

EDOKAMain overview

Properties

property hWnd

See Also

EDOKAMain Class


EDOKAMain.hWnd Property

Public ReadOnly Property hWnd() As System.IntPtr Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.Handle

Source code

[Visual Basic]
    Public ReadOnly Property hWnd() As System.IntPtr Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.Handle
        Get
            Return Handle
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain Methods

EDOKAMain overview

Methods

method Check_Geburtstag
method Check_offene_dp_instanzen
method Check_show_sb
method Delete_Old_Files
method Dispose
method EDOKAMain_Closing
method EDOKAMain_Load (Overloaded)
method HandleCommand (Overloaded)
method InitializeComponent
method MenuItem11_Click
method MenuItem12_Click
method MenuItem12_Click_1
method MenuItem12_Click_2
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem20_Click
method MenuItem21_Popup
method MenuItem22_Click
method MenuItem23_Click
method MenuItem24_Click
method MenuItem25_Click
method MenuItem26_Click
method MenuItem27_Click
method MenuItem28_Click
method MenuItem29_Click
method MenuItem2_Click
method MenuItem2_Popup
method MenuItem2_Select
method MenuItem30_Click
method MenuItem31_Click
method MenuItem33_Click
method MenuItem34_Click
method MenuItem35_Click
method MenuItem36_Click
method MenuItem37_Click
method MenuItem39_Click
method MenuItem39_DrawItem
method MenuItem3_Click
method MenuItem40_Click
method MenuItem42_Click
method MenuItem43_Click
method MenuItem44_Click
method MenuItem45_Popup
method MenuItem46_Click
method MenuItem47_Click
method MenuItem48_Click
method MenuItem49_Click
method MenuItem50_Click
method MenuItem51_Click
method MenuItem52_Click
method MenuItem53_Click
method MenuItem54_Click
method MenuItem55_Click
method MenuItem56_Click
method MenuItem58_Click
method MenuItem5_Click
method MenuItem60_Click
method MenuItem61_Click
method MenuItem61_Click_1
method MenuItem62_PopUp
method MenuItem63_Click
method MenuItem6_Click
method MnuSystemadministration_Click
method Office_Freigeben
method SetLocalSystemTime
method StatusBar1_DoubleClick
method StatusBar1_TextChanged
method Timer1_Elapsed
method Timer2_Elapsed
method Timer3_Elapsed
method TimerFired
method WndProc
method check_doc
method check_doc_abschluss
method check_version
method close_all_childs
method edokamain_resize
method get_profile
method init_system
method mnuPartnerlisten_Click
method mnuauslieferungen_Click
method mnudpinstanz_Click
method mnuserienbriefe_Click
method open_suchprofil
method open_trefferliste
method refresh_menu_trefferliste

See Also

EDOKAMain Class


EDOKAMain.Check_Geburtstag Method

Private Function Check_Geburtstag( _
   ByVal iMitarbeiterNr As Integer _
) As Integer

Parameters

iMitarbeiterNr
Required.

Source code

[Visual Basic]
    Private Function Check_Geburtstag(ByVal iMitarbeiterNr As Integer) As Integer
        Check_Geburtstag = 0
        Try
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim s As String
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_geburtstag"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMANR", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iMitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReturn", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                Check_Geburtstag = scmCmdToExecute.Parameters.Item("@iReturn").Value
            Catch ex As Exception

                Throw New Exception("::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        Catch

        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Check_offene_dp_instanzen Method

Private Function Check_offene_dp_instanzen() As Boolean

Source code

[Visual Basic]
    Private Function Check_offene_dp_instanzen() As Boolean
        Dim f As New frmOffeneDPInstanzen()
        Dim d As DataTable
        d = f.Generic_Select(1)
        If d.Rows.Count > 0 Then
            f.Show()
            f.Left = Me.Width - f.Width - 10
            f.MdiParent = Me
            Return True
        Else
            f.Dispose()
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Check_show_sb Method

Private Function Check_show_sb() As Boolean

Source code

[Visual Basic]
    Private Function Check_show_sb() As Boolean
        Try
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim s As String
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_edex_sb_showmenu"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@show", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@show").Value = 0 Then
                    Return False
                Else
                    Return True
                End If
            Catch ex As Exception
                Throw New Exception("::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        Catch

        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Delete_Old_Files Method

Private Sub Delete_Old_Files()

Source code

[Visual Basic]
    Private Sub Delete_Old_Files()
        Dim di As New IO.DirectoryInfo(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
        Dim diar1 As IO.FileInfo() = di.GetFiles()
        Dim dra As IO.FileInfo

        Dim d1 As DateTime = Now
        Dim d2 As DateTime
        For Each dra In diar1
            If DateDiff(DateInterval.Day, dra.CreationTime, Now) > 5 Or Microsoft.VisualBasic.Left(dra.Name, 4) = "View" Then
                Try
                    dra.Delete()
                Catch
                End Try
            Else
                Try
                    'Auch alle Lyt Files löschen
                    If InStr(dra.Name, ".lyt") > 0 Then
                        dra.Delete()
                    End If
                Catch
                End Try
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.EDOKAMain_Closing Method

Private Sub EDOKAMain_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub EDOKAMain_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim nBeenden As Boolean
        Dim lcnt As Integer
        nBeenden = False
        If Globals.Bearbeitung_Problemdokumente = True Then
            Globals.Global_ForceExit = True
            Exit Sub
        End If
        If Not Me.forceexit Then
            If Globals.Words.Count > 0 Then
                nBeenden = True
                If MyMsg.Show_MessageYesNo(21) <> MsgBoxResult.No Then
                    e.Cancel = True
                    Exit Sub
                Else
                    Try
                        'Rel 3.2 bud
                        'Offene Dokumente schliessen und Word beenden.
                        Dim tempWordLib As New WordLib()
                        For lcnt = 1 To Globals.Words.Count
                            tempWordLib = Globals.Words(lcnt)
                            tempWordLib.CloseDocAndWord()
                            'Globals.Words.Remove(lcnt)
                        Next lcnt

                        fcheckdoc.Hide()
                        fcheckdoc.fnkt = 2
                        fcheckdoc.refresh_list()
                        If fcheckdoc.t.Rows.Count > 0 Then
                            If MyMsg.Show_MessageYesNo(119) = MsgBoxResult.No Then
                                Office_Freigeben()
                                Exit Sub
                            Else
                                e.Cancel = True
                                Me.fcheckdoc.Visible = True
                                Exit Sub
                            End If
                        End If
                    Catch
                    End Try
                End If
            End If
            Try
                fcheckdoc.Hide()
                fcheckdoc.fnkt = 2
                fcheckdoc.refresh_list()
                If fcheckdoc.t.Rows.Count > 0 Then
                    If MyMsg.Show_MessageYesNo(119) = MsgBoxResult.No Then
                        Office_Freigeben()
                        Exit Sub
                    Else
                        e.Cancel = True
                        Me.fcheckdoc.Visible = True
                        Exit Sub
                    End If
                End If
                'If nBeenden = False Then
                If MyMsg.Show_MessageYesNo(1) = MsgBoxResult.No Then e.Cancel = True
                'Else

                'lcnt = 0
                'While lcnt < 1000
                'System.Threading.Thread.CurrentThread.Sleep(100)
                'End While
                'End If
            Catch
            End Try
        Else
            Dim i As Integer
        End If
        If Not e.Cancel Then Office_Freigeben()

        'If fcheckdoc.fnkt = 2 Then Exit Sub
        'If check_doc_abschluss() = True Then
        '    e.Cancel = True
        'End If
        'If Not Me.forceexit Then
        '    If Globals.Words.Count > 0 Then
        '        If MyMsg.Show_MessageYesNo(21) <> MsgBoxResult.No Then e.Cancel = True
        '        '                MyMsg.show_standardmessage(21, MsgBoxStyle.Critical)
        '        '               e.Cancel = True
        '        Exit Sub
        '    End If
        '    If MyMsg.Show_MessageYesNo(1) <> MsgBoxResult.Yes Then e.Cancel = True
        'Else
        '    Dim i As Integer
        '    'i = Shell(shellparams, AppWinStyle.NormalFocus)
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain_Load Method

Overload List

[Visual Basic] Private Overloads Sub EDOKAMain_Load()

[Visual Basic] Private Overloads Sub EDOKAMain_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

See Also

EDOKAMain | EDOKAApp


HandleCommand Method

Overload List

[Visual Basic] Public Sub HandleCommand(ByVal strArgs() As String)

[Visual Basic] Public Sub HandleCommand(ByVal strCmd As String) Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.HandleCommand

See Also

EDOKAMain | EDOKAApp


EDOKAMain.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(EDOKAMain))
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.MenuItem23 = New System.Windows.Forms.MenuItem()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.MenuItem28 = New System.Windows.Forms.MenuItem()
        Me.MenuItem29 = New System.Windows.Forms.MenuItem()
        Me.MenuItem30 = New System.Windows.Forms.MenuItem()
        Me.MenuItem31 = New System.Windows.Forms.MenuItem()
        Me.MenuItem45 = New System.Windows.Forms.MenuItem()
        Me.MenuItem43 = New System.Windows.Forms.MenuItem()
        Me.MenuItem56 = New System.Windows.Forms.MenuItem()
        Me.MenuItem57 = New System.Windows.Forms.MenuItem()
        Me.MenuItem46 = New System.Windows.Forms.MenuItem()
        Me.MenuItem47 = New System.Windows.Forms.MenuItem()
        Me.MenuItem48 = New System.Windows.Forms.MenuItem()
        Me.MenuItem49 = New System.Windows.Forms.MenuItem()
        Me.MenuItem50 = New System.Windows.Forms.MenuItem()
        Me.MenuItem51 = New System.Windows.Forms.MenuItem()
        Me.MenuItem52 = New System.Windows.Forms.MenuItem()
        Me.MenuItem53 = New System.Windows.Forms.MenuItem()
        Me.MenuItem54 = New System.Windows.Forms.MenuItem()
        Me.MenuItem55 = New System.Windows.Forms.MenuItem()
        Me.MenuItem62 = New System.Windows.Forms.MenuItem()
        Me.MenuItem63 = New System.Windows.Forms.MenuItem()
        Me.MenuItem64 = New System.Windows.Forms.MenuItem()
        Me.mnudp1 = New System.Windows.Forms.MenuItem()
        Me.mnudp2 = New System.Windows.Forms.MenuItem()
        Me.mnudp3 = New System.Windows.Forms.MenuItem()
        Me.mnudp4 = New System.Windows.Forms.MenuItem()
        Me.mnudp5 = New System.Windows.Forms.MenuItem()
        Me.mnudp6 = New System.Windows.Forms.MenuItem()
        Me.mnudp7 = New System.Windows.Forms.MenuItem()
        Me.mnudp8 = New System.Windows.Forms.MenuItem()
        Me.mnudp9 = New System.Windows.Forms.MenuItem()
        Me.mnudp10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MnuNewLogin = New System.Windows.Forms.MenuItem()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MnuSystemadministration = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem32 = New System.Windows.Forms.MenuItem()
        Me.MenuItem33 = New System.Windows.Forms.MenuItem()
        Me.MenuItem44 = New System.Windows.Forms.MenuItem()
        Me.MenuItem36 = New System.Windows.Forms.MenuItem()
        Me.MenuItem40 = New System.Windows.Forms.MenuItem()
        Me.MenuItem41 = New System.Windows.Forms.MenuItem()
        Me.MenuItem42 = New System.Windows.Forms.MenuItem()
        Me.MenuItem65 = New System.Windows.Forms.MenuItem()
        Me.mnuauslieferungen = New System.Windows.Forms.MenuItem()
        Me.MenuItem66 = New System.Windows.Forms.MenuItem()
        Me.mnuserienbriefe = New System.Windows.Forms.MenuItem()
        Me.mnuPartnerlisten = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.MenuItem34 = New System.Windows.Forms.MenuItem()
        Me.MenuItem58 = New System.Windows.Forms.MenuItem()
        Me.MenuItem60 = New System.Windows.Forms.MenuItem()
        Me.MenuItem59 = New System.Windows.Forms.MenuItem()
        Me.MenuItem37 = New System.Windows.Forms.MenuItem()
        Me.MenuItem35 = New System.Windows.Forms.MenuItem()
        Me.MenuItem61 = New System.Windows.Forms.MenuItem()
        Me.MenuItem38 = New System.Windows.Forms.MenuItem()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.MenuItem39 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Timer1 = New System.Timers.Timer()
        Me.Timer2 = New System.Timers.Timer()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Timer3 = New System.Timers.Timer()
        Me.HelpProvider1 = New System.Windows.Forms.HelpProvider()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Timer2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        CType(Me.Timer3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'StatusBar1
        '
        Me.StatusBar1.AccessibleDescription = CType(resources.GetObject("StatusBar1.AccessibleDescription"), String)
        Me.StatusBar1.AccessibleName = CType(resources.GetObject("StatusBar1.AccessibleName"), String)
        Me.StatusBar1.Anchor = CType(resources.GetObject("StatusBar1.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.StatusBar1.BackgroundImage = CType(resources.GetObject("StatusBar1.BackgroundImage"), System.Drawing.Image)
        Me.StatusBar1.Dock = CType(resources.GetObject("StatusBar1.Dock"), System.Windows.Forms.DockStyle)
        Me.StatusBar1.Enabled = CType(resources.GetObject("StatusBar1.Enabled"), Boolean)
        Me.StatusBar1.Font = CType(resources.GetObject("StatusBar1.Font"), System.Drawing.Font)
        Me.HelpProvider1.SetHelpKeyword(Me.StatusBar1, resources.GetObject("StatusBar1.HelpKeyword"))
        Me.HelpProvider1.SetHelpNavigator(Me.StatusBar1, CType(resources.GetObject("StatusBar1.HelpNavigator"), System.Windows.Forms.HelpNavigator))
        Me.HelpProvider1.SetHelpString(Me.StatusBar1, resources.GetObject("StatusBar1.HelpString"))
        Me.StatusBar1.ImeMode = CType(resources.GetObject("StatusBar1.ImeMode"), System.Windows.Forms.ImeMode)
        Me.StatusBar1.Location = CType(resources.GetObject("StatusBar1.Location"), System.Drawing.Point)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.RightToLeft = CType(resources.GetObject("StatusBar1.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.HelpProvider1.SetShowHelp(Me.StatusBar1, CType(resources.GetObject("StatusBar1.ShowHelp"), Boolean))
        Me.StatusBar1.Size = CType(resources.GetObject("StatusBar1.Size"), System.Drawing.Size)
        Me.StatusBar1.TabIndex = CType(resources.GetObject("StatusBar1.TabIndex"), Integer)
        Me.StatusBar1.Text = resources.GetString("StatusBar1.Text")
        Me.StatusBar1.Visible = CType(resources.GetObject("StatusBar1.Visible"), Boolean)
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = CType(resources.GetObject("ImageList1.ImageSize"), System.Drawing.Size)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem17, Me.MnuSystemadministration, Me.MenuItem16, Me.MenuItem21, Me.MenuItem10, Me.MenuItem19, Me.MenuItem39})
        Me.MainMenu1.RightToLeft = CType(resources.GetObject("MainMenu1.RightToLeft"), System.Windows.Forms.RightToLeft)
        '
        'MenuItem1
        '
        Me.MenuItem1.Enabled = CType(resources.GetObject("MenuItem1.Enabled"), Boolean)
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2, Me.MenuItem45, Me.MenuItem62, Me.MenuItem7, Me.MenuItem4, Me.MenuItem8, Me.MenuItem9, Me.MenuItem6, Me.MnuNewLogin})
        Me.MenuItem1.Shortcut = CType(resources.GetObject("MenuItem1.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem1.ShowShortcut = CType(resources.GetObject("MenuItem1.ShowShortcut"), Boolean)
        Me.MenuItem1.Text = resources.GetString("MenuItem1.Text")
        Me.MenuItem1.Visible = CType(resources.GetObject("MenuItem1.Visible"), Boolean)
        '
        'MenuItem2
        '
        Me.MenuItem2.Enabled = CType(resources.GetObject("MenuItem2.Enabled"), Boolean)
        Me.MenuItem2.Index = 0
        Me.MenuItem2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem22, Me.MenuItem23, Me.MenuItem24, Me.MenuItem25, Me.MenuItem26, Me.MenuItem27, Me.MenuItem28, Me.MenuItem29, Me.MenuItem30, Me.MenuItem31})
        Me.MenuItem2.Shortcut = CType(resources.GetObject("MenuItem2.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem2.ShowShortcut = CType(resources.GetObject("MenuItem2.ShowShortcut"), Boolean)
        Me.MenuItem2.Text = resources.GetString("MenuItem2.Text")
        Me.MenuItem2.Visible = CType(resources.GetObject("MenuItem2.Visible"), Boolean)
        '
        'MenuItem22
        '
        Me.MenuItem22.Enabled = CType(resources.GetObject("MenuItem22.Enabled"), Boolean)
        Me.MenuItem22.Index = 0
        Me.MenuItem22.Shortcut = CType(resources.GetObject("MenuItem22.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem22.ShowShortcut = CType(resources.GetObject("MenuItem22.ShowShortcut"), Boolean)
        Me.MenuItem22.Text = resources.GetString("MenuItem22.Text")
        Me.MenuItem22.Visible = CType(resources.GetObject("MenuItem22.Visible"), Boolean)
        '
        'MenuItem23
        '
        Me.MenuItem23.Enabled = CType(resources.GetObject("MenuItem23.Enabled"), Boolean)
        Me.MenuItem23.Index = 1
        Me.MenuItem23.Shortcut = CType(resources.GetObject("MenuItem23.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem23.ShowShortcut = CType(resources.GetObject("MenuItem23.ShowShortcut"), Boolean)
        Me.MenuItem23.Text = resources.GetString("MenuItem23.Text")
        Me.MenuItem23.Visible = CType(resources.GetObject("MenuItem23.Visible"), Boolean)
        '
        'MenuItem24
        '
        Me.MenuItem24.Enabled = CType(resources.GetObject("MenuItem24.Enabled"), Boolean)
        Me.MenuItem24.Index = 2
        Me.MenuItem24.Shortcut = CType(resources.GetObject("MenuItem24.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem24.ShowShortcut = CType(resources.GetObject("MenuItem24.ShowShortcut"), Boolean)
        Me.MenuItem24.Text = resources.GetString("MenuItem24.Text")
        Me.MenuItem24.Visible = CType(resources.GetObject("MenuItem24.Visible"), Boolean)
        '
        'MenuItem25
        '
        Me.MenuItem25.Enabled = CType(resources.GetObject("MenuItem25.Enabled"), Boolean)
        Me.MenuItem25.Index = 3
        Me.MenuItem25.Shortcut = CType(resources.GetObject("MenuItem25.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem25.ShowShortcut = CType(resources.GetObject("MenuItem25.ShowShortcut"), Boolean)
        Me.MenuItem25.Text = resources.GetString("MenuItem25.Text")
        Me.MenuItem25.Visible = CType(resources.GetObject("MenuItem25.Visible"), Boolean)
        '
        'MenuItem26
        '
        Me.MenuItem26.Enabled = CType(resources.GetObject("MenuItem26.Enabled"), Boolean)
        Me.MenuItem26.Index = 4
        Me.MenuItem26.Shortcut = CType(resources.GetObject("MenuItem26.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem26.ShowShortcut = CType(resources.GetObject("MenuItem26.ShowShortcut"), Boolean)
        Me.MenuItem26.Text = resources.GetString("MenuItem26.Text")
        Me.MenuItem26.Visible = CType(resources.GetObject("MenuItem26.Visible"), Boolean)
        '
        'MenuItem27
        '
        Me.MenuItem27.Enabled = CType(resources.GetObject("MenuItem27.Enabled"), Boolean)
        Me.MenuItem27.Index = 5
        Me.MenuItem27.Shortcut = CType(resources.GetObject("MenuItem27.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem27.ShowShortcut = CType(resources.GetObject("MenuItem27.ShowShortcut"), Boolean)
        Me.MenuItem27.Text = resources.GetString("MenuItem27.Text")
        Me.MenuItem27.Visible = CType(resources.GetObject("MenuItem27.Visible"), Boolean)
        '
        'MenuItem28
        '
        Me.MenuItem28.Enabled = CType(resources.GetObject("MenuItem28.Enabled"), Boolean)
        Me.MenuItem28.Index = 6
        Me.MenuItem28.Shortcut = CType(resources.GetObject("MenuItem28.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem28.ShowShortcut = CType(resources.GetObject("MenuItem28.ShowShortcut"), Boolean)
        Me.MenuItem28.Text = resources.GetString("MenuItem28.Text")
        Me.MenuItem28.Visible = CType(resources.GetObject("MenuItem28.Visible"), Boolean)
        '
        'MenuItem29
        '
        Me.MenuItem29.Enabled = CType(resources.GetObject("MenuItem29.Enabled"), Boolean)
        Me.MenuItem29.Index = 7
        Me.MenuItem29.Shortcut = CType(resources.GetObject("MenuItem29.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem29.ShowShortcut = CType(resources.GetObject("MenuItem29.ShowShortcut"), Boolean)
        Me.MenuItem29.Text = resources.GetString("MenuItem29.Text")
        Me.MenuItem29.Visible = CType(resources.GetObject("MenuItem29.Visible"), Boolean)
        '
        'MenuItem30
        '
        Me.MenuItem30.Enabled = CType(resources.GetObject("MenuItem30.Enabled"), Boolean)
        Me.MenuItem30.Index = 8
        Me.MenuItem30.Shortcut = CType(resources.GetObject("MenuItem30.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem30.ShowShortcut = CType(resources.GetObject("MenuItem30.ShowShortcut"), Boolean)
        Me.MenuItem30.Text = resources.GetString("MenuItem30.Text")
        Me.MenuItem30.Visible = CType(resources.GetObject("MenuItem30.Visible"), Boolean)
        '
        'MenuItem31
        '
        Me.MenuItem31.Enabled = CType(resources.GetObject("MenuItem31.Enabled"), Boolean)
        Me.MenuItem31.Index = 9
        Me.MenuItem31.Shortcut = CType(resources.GetObject("MenuItem31.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem31.ShowShortcut = CType(resources.GetObject("MenuItem31.ShowShortcut"), Boolean)
        Me.MenuItem31.Text = resources.GetString("MenuItem31.Text")
        Me.MenuItem31.Visible = CType(resources.GetObject("MenuItem31.Visible"), Boolean)
        '
        'MenuItem45
        '
        Me.MenuItem45.Enabled = CType(resources.GetObject("MenuItem45.Enabled"), Boolean)
        Me.MenuItem45.Index = 1
        Me.MenuItem45.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem43, Me.MenuItem56, Me.MenuItem57, Me.MenuItem46, Me.MenuItem47, Me.MenuItem48, Me.MenuItem49, Me.MenuItem50, Me.MenuItem51, Me.MenuItem52, Me.MenuItem53, Me.MenuItem54, Me.MenuItem55})
        Me.MenuItem45.Shortcut = CType(resources.GetObject("MenuItem45.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem45.ShowShortcut = CType(resources.GetObject("MenuItem45.ShowShortcut"), Boolean)
        Me.MenuItem45.Text = resources.GetString("MenuItem45.Text")
        Me.MenuItem45.Visible = CType(resources.GetObject("MenuItem45.Visible"), Boolean)
        '
        'MenuItem43
        '
        Me.MenuItem43.Enabled = CType(resources.GetObject("MenuItem43.Enabled"), Boolean)
        Me.MenuItem43.Index = 0
        Me.MenuItem43.Shortcut = CType(resources.GetObject("MenuItem43.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem43.ShowShortcut = CType(resources.GetObject("MenuItem43.ShowShortcut"), Boolean)
        Me.MenuItem43.Text = resources.GetString("MenuItem43.Text")
        Me.MenuItem43.Visible = CType(resources.GetObject("MenuItem43.Visible"), Boolean)
        '
        'MenuItem56
        '
        Me.MenuItem56.Enabled = CType(resources.GetObject("MenuItem56.Enabled"), Boolean)
        Me.MenuItem56.Index = 1
        Me.MenuItem56.Shortcut = CType(resources.GetObject("MenuItem56.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem56.ShowShortcut = CType(resources.GetObject("MenuItem56.ShowShortcut"), Boolean)
        Me.MenuItem56.Text = resources.GetString("MenuItem56.Text")
        Me.MenuItem56.Visible = CType(resources.GetObject("MenuItem56.Visible"), Boolean)
        '
        'MenuItem57
        '
        Me.MenuItem57.Enabled = CType(resources.GetObject("MenuItem57.Enabled"), Boolean)
        Me.MenuItem57.Index = 2
        Me.MenuItem57.Shortcut = CType(resources.GetObject("MenuItem57.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem57.ShowShortcut = CType(resources.GetObject("MenuItem57.ShowShortcut"), Boolean)
        Me.MenuItem57.Text = resources.GetString("MenuItem57.Text")
        Me.MenuItem57.Visible = CType(resources.GetObject("MenuItem57.Visible"), Boolean)
        '
        'MenuItem46
        '
        Me.MenuItem46.Enabled = CType(resources.GetObject("MenuItem46.Enabled"), Boolean)
        Me.MenuItem46.Index = 3
        Me.MenuItem46.Shortcut = CType(resources.GetObject("MenuItem46.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem46.ShowShortcut = CType(resources.GetObject("MenuItem46.ShowShortcut"), Boolean)
        Me.MenuItem46.Text = resources.GetString("MenuItem46.Text")
        Me.MenuItem46.Visible = CType(resources.GetObject("MenuItem46.Visible"), Boolean)
        '
        'MenuItem47
        '
        Me.MenuItem47.Enabled = CType(resources.GetObject("MenuItem47.Enabled"), Boolean)
        Me.MenuItem47.Index = 4
        Me.MenuItem47.Shortcut = CType(resources.GetObject("MenuItem47.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem47.ShowShortcut = CType(resources.GetObject("MenuItem47.ShowShortcut"), Boolean)
        Me.MenuItem47.Text = resources.GetString("MenuItem47.Text")
        Me.MenuItem47.Visible = CType(resources.GetObject("MenuItem47.Visible"), Boolean)
        '
        'MenuItem48
        '
        Me.MenuItem48.Enabled = CType(resources.GetObject("MenuItem48.Enabled"), Boolean)
        Me.MenuItem48.Index = 5
        Me.MenuItem48.Shortcut = CType(resources.GetObject("MenuItem48.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem48.ShowShortcut = CType(resources.GetObject("MenuItem48.ShowShortcut"), Boolean)
        Me.MenuItem48.Text = resources.GetString("MenuItem48.Text")
        Me.MenuItem48.Visible = CType(resources.GetObject("MenuItem48.Visible"), Boolean)
        '
        'MenuItem49
        '
        Me.MenuItem49.Enabled = CType(resources.GetObject("MenuItem49.Enabled"), Boolean)
        Me.MenuItem49.Index = 6
        Me.MenuItem49.Shortcut = CType(resources.GetObject("MenuItem49.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem49.ShowShortcut = CType(resources.GetObject("MenuItem49.ShowShortcut"), Boolean)
        Me.MenuItem49.Text = resources.GetString("MenuItem49.Text")
        Me.MenuItem49.Visible = CType(resources.GetObject("MenuItem49.Visible"), Boolean)
        '
        'MenuItem50
        '
        Me.MenuItem50.Enabled = CType(resources.GetObject("MenuItem50.Enabled"), Boolean)
        Me.MenuItem50.Index = 7
        Me.MenuItem50.Shortcut = CType(resources.GetObject("MenuItem50.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem50.ShowShortcut = CType(resources.GetObject("MenuItem50.ShowShortcut"), Boolean)
        Me.MenuItem50.Text = resources.GetString("MenuItem50.Text")
        Me.MenuItem50.Visible = CType(resources.GetObject("MenuItem50.Visible"), Boolean)
        '
        'MenuItem51
        '
        Me.MenuItem51.Enabled = CType(resources.GetObject("MenuItem51.Enabled"), Boolean)
        Me.MenuItem51.Index = 8
        Me.MenuItem51.Shortcut = CType(resources.GetObject("MenuItem51.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem51.ShowShortcut = CType(resources.GetObject("MenuItem51.ShowShortcut"), Boolean)
        Me.MenuItem51.Text = resources.GetString("MenuItem51.Text")
        Me.MenuItem51.Visible = CType(resources.GetObject("MenuItem51.Visible"), Boolean)
        '
        'MenuItem52
        '
        Me.MenuItem52.Enabled = CType(resources.GetObject("MenuItem52.Enabled"), Boolean)
        Me.MenuItem52.Index = 9
        Me.MenuItem52.Shortcut = CType(resources.GetObject("MenuItem52.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem52.ShowShortcut = CType(resources.GetObject("MenuItem52.ShowShortcut"), Boolean)
        Me.MenuItem52.Text = resources.GetString("MenuItem52.Text")
        Me.MenuItem52.Visible = CType(resources.GetObject("MenuItem52.Visible"), Boolean)
        '
        'MenuItem53
        '
        Me.MenuItem53.Enabled = CType(resources.GetObject("MenuItem53.Enabled"), Boolean)
        Me.MenuItem53.Index = 10
        Me.MenuItem53.Shortcut = CType(resources.GetObject("MenuItem53.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem53.ShowShortcut = CType(resources.GetObject("MenuItem53.ShowShortcut"), Boolean)
        Me.MenuItem53.Text = resources.GetString("MenuItem53.Text")
        Me.MenuItem53.Visible = CType(resources.GetObject("MenuItem53.Visible"), Boolean)
        '
        'MenuItem54
        '
        Me.MenuItem54.Enabled = CType(resources.GetObject("MenuItem54.Enabled"), Boolean)
        Me.MenuItem54.Index = 11
        Me.MenuItem54.Shortcut = CType(resources.GetObject("MenuItem54.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem54.ShowShortcut = CType(resources.GetObject("MenuItem54.ShowShortcut"), Boolean)
        Me.MenuItem54.Text = resources.GetString("MenuItem54.Text")
        Me.MenuItem54.Visible = CType(resources.GetObject("MenuItem54.Visible"), Boolean)
        '
        'MenuItem55
        '
        Me.MenuItem55.Enabled = CType(resources.GetObject("MenuItem55.Enabled"), Boolean)
        Me.MenuItem55.Index = 12
        Me.MenuItem55.Shortcut = CType(resources.GetObject("MenuItem55.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem55.ShowShortcut = CType(resources.GetObject("MenuItem55.ShowShortcut"), Boolean)
        Me.MenuItem55.Text = resources.GetString("MenuItem55.Text")
        Me.MenuItem55.Visible = CType(resources.GetObject("MenuItem55.Visible"), Boolean)
        '
        'MenuItem62
        '
        Me.MenuItem62.Enabled = CType(resources.GetObject("MenuItem62.Enabled"), Boolean)
        Me.MenuItem62.Index = 2
        Me.MenuItem62.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem63, Me.MenuItem64, Me.mnudp1, Me.mnudp2, Me.mnudp3, Me.mnudp4, Me.mnudp5, Me.mnudp6, Me.mnudp7, Me.mnudp8, Me.mnudp9, Me.mnudp10})
        Me.MenuItem62.Shortcut = CType(resources.GetObject("MenuItem62.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem62.ShowShortcut = CType(resources.GetObject("MenuItem62.ShowShortcut"), Boolean)
        Me.MenuItem62.Text = resources.GetString("MenuItem62.Text")
        Me.MenuItem62.Visible = CType(resources.GetObject("MenuItem62.Visible"), Boolean)
        '
        'MenuItem63
        '
        Me.MenuItem63.Enabled = CType(resources.GetObject("MenuItem63.Enabled"), Boolean)
        Me.MenuItem63.Index = 0
        Me.MenuItem63.Shortcut = CType(resources.GetObject("MenuItem63.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem63.ShowShortcut = CType(resources.GetObject("MenuItem63.ShowShortcut"), Boolean)
        Me.MenuItem63.Text = resources.GetString("MenuItem63.Text")
        Me.MenuItem63.Visible = CType(resources.GetObject("MenuItem63.Visible"), Boolean)
        '
        'MenuItem64
        '
        Me.MenuItem64.Enabled = CType(resources.GetObject("MenuItem64.Enabled"), Boolean)
        Me.MenuItem64.Index = 1
        Me.MenuItem64.Shortcut = CType(resources.GetObject("MenuItem64.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem64.ShowShortcut = CType(resources.GetObject("MenuItem64.ShowShortcut"), Boolean)
        Me.MenuItem64.Text = resources.GetString("MenuItem64.Text")
        Me.MenuItem64.Visible = CType(resources.GetObject("MenuItem64.Visible"), Boolean)
        '
        'mnudp1
        '
        Me.mnudp1.Enabled = CType(resources.GetObject("mnudp1.Enabled"), Boolean)
        Me.mnudp1.Index = 2
        Me.mnudp1.Shortcut = CType(resources.GetObject("mnudp1.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp1.ShowShortcut = CType(resources.GetObject("mnudp1.ShowShortcut"), Boolean)
        Me.mnudp1.Text = resources.GetString("mnudp1.Text")
        Me.mnudp1.Visible = CType(resources.GetObject("mnudp1.Visible"), Boolean)
        '
        'mnudp2
        '
        Me.mnudp2.Enabled = CType(resources.GetObject("mnudp2.Enabled"), Boolean)
        Me.mnudp2.Index = 3
        Me.mnudp2.Shortcut = CType(resources.GetObject("mnudp2.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp2.ShowShortcut = CType(resources.GetObject("mnudp2.ShowShortcut"), Boolean)
        Me.mnudp2.Text = resources.GetString("mnudp2.Text")
        Me.mnudp2.Visible = CType(resources.GetObject("mnudp2.Visible"), Boolean)
        '
        'mnudp3
        '
        Me.mnudp3.Enabled = CType(resources.GetObject("mnudp3.Enabled"), Boolean)
        Me.mnudp3.Index = 4
        Me.mnudp3.Shortcut = CType(resources.GetObject("mnudp3.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp3.ShowShortcut = CType(resources.GetObject("mnudp3.ShowShortcut"), Boolean)
        Me.mnudp3.Text = resources.GetString("mnudp3.Text")
        Me.mnudp3.Visible = CType(resources.GetObject("mnudp3.Visible"), Boolean)
        '
        'mnudp4
        '
        Me.mnudp4.Enabled = CType(resources.GetObject("mnudp4.Enabled"), Boolean)
        Me.mnudp4.Index = 5
        Me.mnudp4.Shortcut = CType(resources.GetObject("mnudp4.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp4.ShowShortcut = CType(resources.GetObject("mnudp4.ShowShortcut"), Boolean)
        Me.mnudp4.Text = resources.GetString("mnudp4.Text")
        Me.mnudp4.Visible = CType(resources.GetObject("mnudp4.Visible"), Boolean)
        '
        'mnudp5
        '
        Me.mnudp5.Enabled = CType(resources.GetObject("mnudp5.Enabled"), Boolean)
        Me.mnudp5.Index = 6
        Me.mnudp5.Shortcut = CType(resources.GetObject("mnudp5.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp5.ShowShortcut = CType(resources.GetObject("mnudp5.ShowShortcut"), Boolean)
        Me.mnudp5.Text = resources.GetString("mnudp5.Text")
        Me.mnudp5.Visible = CType(resources.GetObject("mnudp5.Visible"), Boolean)
        '
        'mnudp6
        '
        Me.mnudp6.Enabled = CType(resources.GetObject("mnudp6.Enabled"), Boolean)
        Me.mnudp6.Index = 7
        Me.mnudp6.Shortcut = CType(resources.GetObject("mnudp6.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp6.ShowShortcut = CType(resources.GetObject("mnudp6.ShowShortcut"), Boolean)
        Me.mnudp6.Text = resources.GetString("mnudp6.Text")
        Me.mnudp6.Visible = CType(resources.GetObject("mnudp6.Visible"), Boolean)
        '
        'mnudp7
        '
        Me.mnudp7.Enabled = CType(resources.GetObject("mnudp7.Enabled"), Boolean)
        Me.mnudp7.Index = 8
        Me.mnudp7.Shortcut = CType(resources.GetObject("mnudp7.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp7.ShowShortcut = CType(resources.GetObject("mnudp7.ShowShortcut"), Boolean)
        Me.mnudp7.Text = resources.GetString("mnudp7.Text")
        Me.mnudp7.Visible = CType(resources.GetObject("mnudp7.Visible"), Boolean)
        '
        'mnudp8
        '
        Me.mnudp8.Enabled = CType(resources.GetObject("mnudp8.Enabled"), Boolean)
        Me.mnudp8.Index = 9
        Me.mnudp8.Shortcut = CType(resources.GetObject("mnudp8.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp8.ShowShortcut = CType(resources.GetObject("mnudp8.ShowShortcut"), Boolean)
        Me.mnudp8.Text = resources.GetString("mnudp8.Text")
        Me.mnudp8.Visible = CType(resources.GetObject("mnudp8.Visible"), Boolean)
        '
        'mnudp9
        '
        Me.mnudp9.Enabled = CType(resources.GetObject("mnudp9.Enabled"), Boolean)
        Me.mnudp9.Index = 10
        Me.mnudp9.Shortcut = CType(resources.GetObject("mnudp9.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp9.ShowShortcut = CType(resources.GetObject("mnudp9.ShowShortcut"), Boolean)
        Me.mnudp9.Text = resources.GetString("mnudp9.Text")
        Me.mnudp9.Visible = CType(resources.GetObject("mnudp9.Visible"), Boolean)
        '
        'mnudp10
        '
        Me.mnudp10.Enabled = CType(resources.GetObject("mnudp10.Enabled"), Boolean)
        Me.mnudp10.Index = 11
        Me.mnudp10.Shortcut = CType(resources.GetObject("mnudp10.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnudp10.ShowShortcut = CType(resources.GetObject("mnudp10.ShowShortcut"), Boolean)
        Me.mnudp10.Text = resources.GetString("mnudp10.Text")
        Me.mnudp10.Visible = CType(resources.GetObject("mnudp10.Visible"), Boolean)
        '
        'MenuItem7
        '
        Me.MenuItem7.Enabled = CType(resources.GetObject("MenuItem7.Enabled"), Boolean)
        Me.MenuItem7.Index = 3
        Me.MenuItem7.Shortcut = CType(resources.GetObject("MenuItem7.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem7.ShowShortcut = CType(resources.GetObject("MenuItem7.ShowShortcut"), Boolean)
        Me.MenuItem7.Text = resources.GetString("MenuItem7.Text")
        Me.MenuItem7.Visible = CType(resources.GetObject("MenuItem7.Visible"), Boolean)
        '
        'MenuItem4
        '
        Me.MenuItem4.Enabled = CType(resources.GetObject("MenuItem4.Enabled"), Boolean)
        Me.MenuItem4.Index = 4
        Me.MenuItem4.Shortcut = CType(resources.GetObject("MenuItem4.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem4.ShowShortcut = CType(resources.GetObject("MenuItem4.ShowShortcut"), Boolean)
        Me.MenuItem4.Text = resources.GetString("MenuItem4.Text")
        Me.MenuItem4.Visible = CType(resources.GetObject("MenuItem4.Visible"), Boolean)
        '
        'MenuItem8
        '
        Me.MenuItem8.Enabled = CType(resources.GetObject("MenuItem8.Enabled"), Boolean)
        Me.MenuItem8.Index = 5
        Me.MenuItem8.Shortcut = CType(resources.GetObject("MenuItem8.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem8.ShowShortcut = CType(resources.GetObject("MenuItem8.ShowShortcut"), Boolean)
        Me.MenuItem8.Text = resources.GetString("MenuItem8.Text")
        Me.MenuItem8.Visible = CType(resources.GetObject("MenuItem8.Visible"), Boolean)
        '
        'MenuItem9
        '
        Me.MenuItem9.Enabled = CType(resources.GetObject("MenuItem9.Enabled"), Boolean)
        Me.MenuItem9.Index = 6
        Me.MenuItem9.Shortcut = CType(resources.GetObject("MenuItem9.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem9.ShowShortcut = CType(resources.GetObject("MenuItem9.ShowShortcut"), Boolean)
        Me.MenuItem9.Text = resources.GetString("MenuItem9.Text")
        Me.MenuItem9.Visible = CType(resources.GetObject("MenuItem9.Visible"), Boolean)
        '
        'MenuItem6
        '
        Me.MenuItem6.Enabled = CType(resources.GetObject("MenuItem6.Enabled"), Boolean)
        Me.MenuItem6.Index = 7
        Me.MenuItem6.Shortcut = CType(resources.GetObject("MenuItem6.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem6.ShowShortcut = CType(resources.GetObject("MenuItem6.ShowShortcut"), Boolean)
        Me.MenuItem6.Text = resources.GetString("MenuItem6.Text")
        Me.MenuItem6.Visible = CType(resources.GetObject("MenuItem6.Visible"), Boolean)
        '
        'MnuNewLogin
        '
        Me.MnuNewLogin.Enabled = CType(resources.GetObject("MnuNewLogin.Enabled"), Boolean)
        Me.MnuNewLogin.Index = 8
        Me.MnuNewLogin.Shortcut = CType(resources.GetObject("MnuNewLogin.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuNewLogin.ShowShortcut = CType(resources.GetObject("MnuNewLogin.ShowShortcut"), Boolean)
        Me.MnuNewLogin.Text = resources.GetString("MnuNewLogin.Text")
        Me.MnuNewLogin.Visible = CType(resources.GetObject("MnuNewLogin.Visible"), Boolean)
        '
        'MenuItem17
        '
        Me.MenuItem17.Enabled = CType(resources.GetObject("MenuItem17.Enabled"), Boolean)
        Me.MenuItem17.Index = 1
        Me.MenuItem17.MergeOrder = 96
        Me.MenuItem17.Shortcut = CType(resources.GetObject("MenuItem17.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem17.ShowShortcut = CType(resources.GetObject("MenuItem17.ShowShortcut"), Boolean)
        Me.MenuItem17.Text = resources.GetString("MenuItem17.Text")
        Me.MenuItem17.Visible = CType(resources.GetObject("MenuItem17.Visible"), Boolean)
        '
        'MnuSystemadministration
        '
        Me.MnuSystemadministration.Enabled = CType(resources.GetObject("MnuSystemadministration.Enabled"), Boolean)
        Me.MnuSystemadministration.Index = 2
        Me.MnuSystemadministration.MergeOrder = 97
        Me.MnuSystemadministration.Shortcut = CType(resources.GetObject("MnuSystemadministration.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuSystemadministration.ShowShortcut = CType(resources.GetObject("MnuSystemadministration.ShowShortcut"), Boolean)
        Me.MnuSystemadministration.Text = resources.GetString("MnuSystemadministration.Text")
        Me.MnuSystemadministration.Visible = CType(resources.GetObject("MnuSystemadministration.Visible"), Boolean)
        '
        'MenuItem16
        '
        Me.MenuItem16.Enabled = CType(resources.GetObject("MenuItem16.Enabled"), Boolean)
        Me.MenuItem16.Index = 3
        Me.MenuItem16.Shortcut = CType(resources.GetObject("MenuItem16.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem16.ShowShortcut = CType(resources.GetObject("MenuItem16.ShowShortcut"), Boolean)
        Me.MenuItem16.Text = resources.GetString("MenuItem16.Text")
        Me.MenuItem16.Visible = CType(resources.GetObject("MenuItem16.Visible"), Boolean)
        '
        'MenuItem21
        '
        Me.MenuItem21.Enabled = CType(resources.GetObject("MenuItem21.Enabled"), Boolean)
        Me.MenuItem21.Index = 4
        Me.MenuItem21.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem18, Me.MenuItem11, Me.MenuItem3, Me.MenuItem5, Me.MenuItem32, Me.MenuItem33, Me.MenuItem44, Me.MenuItem36, Me.MenuItem40, Me.MenuItem41, Me.MenuItem42, Me.MenuItem65, Me.mnuauslieferungen, Me.MenuItem66, Me.mnuserienbriefe, Me.mnuPartnerlisten})
        Me.MenuItem21.MergeOrder = 98
        Me.MenuItem21.Shortcut = CType(resources.GetObject("MenuItem21.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem21.ShowShortcut = CType(resources.GetObject("MenuItem21.ShowShortcut"), Boolean)
        Me.MenuItem21.Text = resources.GetString("MenuItem21.Text")
        Me.MenuItem21.Visible = CType(resources.GetObject("MenuItem21.Visible"), Boolean)
        '
        'MenuItem18
        '
        Me.MenuItem18.Enabled = CType(resources.GetObject("MenuItem18.Enabled"), Boolean)
        Me.MenuItem18.Index = 0
        Me.MenuItem18.Shortcut = CType(resources.GetObject("MenuItem18.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem18.ShowShortcut = CType(resources.GetObject("MenuItem18.ShowShortcut"), Boolean)
        Me.MenuItem18.Text = resources.GetString("MenuItem18.Text")
        Me.MenuItem18.Visible = CType(resources.GetObject("MenuItem18.Visible"), Boolean)
        '
        'MenuItem11
        '
        Me.MenuItem11.Enabled = CType(resources.GetObject("MenuItem11.Enabled"), Boolean)
        Me.MenuItem11.Index = 1
        Me.MenuItem11.Shortcut = CType(resources.GetObject("MenuItem11.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem11.ShowShortcut = CType(resources.GetObject("MenuItem11.ShowShortcut"), Boolean)
        Me.MenuItem11.Text = resources.GetString("MenuItem11.Text")
        Me.MenuItem11.Visible = CType(resources.GetObject("MenuItem11.Visible"), Boolean)
        '
        'MenuItem3
        '
        Me.MenuItem3.Enabled = CType(resources.GetObject("MenuItem3.Enabled"), Boolean)
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Shortcut = CType(resources.GetObject("MenuItem3.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem3.ShowShortcut = CType(resources.GetObject("MenuItem3.ShowShortcut"), Boolean)
        Me.MenuItem3.Text = resources.GetString("MenuItem3.Text")
        Me.MenuItem3.Visible = CType(resources.GetObject("MenuItem3.Visible"), Boolean)
        '
        'MenuItem5
        '
        Me.MenuItem5.Enabled = CType(resources.GetObject("MenuItem5.Enabled"), Boolean)
        Me.MenuItem5.Index = 3
        Me.MenuItem5.Shortcut = CType(resources.GetObject("MenuItem5.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem5.ShowShortcut = CType(resources.GetObject("MenuItem5.ShowShortcut"), Boolean)
        Me.MenuItem5.Text = resources.GetString("MenuItem5.Text")
        Me.MenuItem5.Visible = CType(resources.GetObject("MenuItem5.Visible"), Boolean)
        '
        'MenuItem32
        '
        Me.MenuItem32.Enabled = CType(resources.GetObject("MenuItem32.Enabled"), Boolean)
        Me.MenuItem32.Index = 4
        Me.MenuItem32.Shortcut = CType(resources.GetObject("MenuItem32.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem32.ShowShortcut = CType(resources.GetObject("MenuItem32.ShowShortcut"), Boolean)
        Me.MenuItem32.Text = resources.GetString("MenuItem32.Text")
        Me.MenuItem32.Visible = CType(resources.GetObject("MenuItem32.Visible"), Boolean)
        '
        'MenuItem33
        '
        Me.MenuItem33.Enabled = CType(resources.GetObject("MenuItem33.Enabled"), Boolean)
        Me.MenuItem33.Index = 5
        Me.MenuItem33.Shortcut = CType(resources.GetObject("MenuItem33.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem33.ShowShortcut = CType(resources.GetObject("MenuItem33.ShowShortcut"), Boolean)
        Me.MenuItem33.Text = resources.GetString("MenuItem33.Text")
        Me.MenuItem33.Visible = CType(resources.GetObject("MenuItem33.Visible"), Boolean)
        '
        'MenuItem44
        '
        Me.MenuItem44.Enabled = CType(resources.GetObject("MenuItem44.Enabled"), Boolean)
        Me.MenuItem44.Index = 6
        Me.MenuItem44.Shortcut = CType(resources.GetObject("MenuItem44.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem44.ShowShortcut = CType(resources.GetObject("MenuItem44.ShowShortcut"), Boolean)
        Me.MenuItem44.Text = resources.GetString("MenuItem44.Text")
        Me.MenuItem44.Visible = CType(resources.GetObject("MenuItem44.Visible"), Boolean)
        '
        'MenuItem36
        '
        Me.MenuItem36.Enabled = CType(resources.GetObject("MenuItem36.Enabled"), Boolean)
        Me.MenuItem36.Index = 7
        Me.MenuItem36.Shortcut = CType(resources.GetObject("MenuItem36.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem36.ShowShortcut = CType(resources.GetObject("MenuItem36.ShowShortcut"), Boolean)
        Me.MenuItem36.Text = resources.GetString("MenuItem36.Text")
        Me.MenuItem36.Visible = CType(resources.GetObject("MenuItem36.Visible"), Boolean)
        '
        'MenuItem40
        '
        Me.MenuItem40.Enabled = CType(resources.GetObject("MenuItem40.Enabled"), Boolean)
        Me.MenuItem40.Index = 8
        Me.MenuItem40.Shortcut = CType(resources.GetObject("MenuItem40.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem40.ShowShortcut = CType(resources.GetObject("MenuItem40.ShowShortcut"), Boolean)
        Me.MenuItem40.Text = resources.GetString("MenuItem40.Text")
        Me.MenuItem40.Visible = CType(resources.GetObject("MenuItem40.Visible"), Boolean)
        '
        'MenuItem41
        '
        Me.MenuItem41.Enabled = CType(resources.GetObject("MenuItem41.Enabled"), Boolean)
        Me.MenuItem41.Index = 9
        Me.MenuItem41.Shortcut = CType(resources.GetObject("MenuItem41.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem41.ShowShortcut = CType(resources.GetObject("MenuItem41.ShowShortcut"), Boolean)
        Me.MenuItem41.Text = resources.GetString("MenuItem41.Text")
        Me.MenuItem41.Visible = CType(resources.GetObject("MenuItem41.Visible"), Boolean)
        '
        'MenuItem42
        '
        Me.MenuItem42.Enabled = CType(resources.GetObject("MenuItem42.Enabled"), Boolean)
        Me.MenuItem42.Index = 10
        Me.MenuItem42.Shortcut = CType(resources.GetObject("MenuItem42.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem42.ShowShortcut = CType(resources.GetObject("MenuItem42.ShowShortcut"), Boolean)
        Me.MenuItem42.Text = resources.GetString("MenuItem42.Text")
        Me.MenuItem42.Visible = CType(resources.GetObject("MenuItem42.Visible"), Boolean)
        '
        'MenuItem65
        '
        Me.MenuItem65.Enabled = CType(resources.GetObject("MenuItem65.Enabled"), Boolean)
        Me.MenuItem65.Index = 11
        Me.MenuItem65.Shortcut = CType(resources.GetObject("MenuItem65.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem65.ShowShortcut = CType(resources.GetObject("MenuItem65.ShowShortcut"), Boolean)
        Me.MenuItem65.Text = resources.GetString("MenuItem65.Text")
        Me.MenuItem65.Visible = CType(resources.GetObject("MenuItem65.Visible"), Boolean)
        '
        'mnuauslieferungen
        '
        Me.mnuauslieferungen.Enabled = CType(resources.GetObject("mnuauslieferungen.Enabled"), Boolean)
        Me.mnuauslieferungen.Index = 12
        Me.mnuauslieferungen.Shortcut = CType(resources.GetObject("mnuauslieferungen.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnuauslieferungen.ShowShortcut = CType(resources.GetObject("mnuauslieferungen.ShowShortcut"), Boolean)
        Me.mnuauslieferungen.Text = resources.GetString("mnuauslieferungen.Text")
        Me.mnuauslieferungen.Visible = CType(resources.GetObject("mnuauslieferungen.Visible"), Boolean)
        '
        'MenuItem66
        '
        Me.MenuItem66.Enabled = CType(resources.GetObject("MenuItem66.Enabled"), Boolean)
        Me.MenuItem66.Index = 13
        Me.MenuItem66.Shortcut = CType(resources.GetObject("MenuItem66.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem66.ShowShortcut = CType(resources.GetObject("MenuItem66.ShowShortcut"), Boolean)
        Me.MenuItem66.Text = resources.GetString("MenuItem66.Text")
        Me.MenuItem66.Visible = CType(resources.GetObject("MenuItem66.Visible"), Boolean)
        '
        'mnuserienbriefe
        '
        Me.mnuserienbriefe.Enabled = CType(resources.GetObject("mnuserienbriefe.Enabled"), Boolean)
        Me.mnuserienbriefe.Index = 14
        Me.mnuserienbriefe.Shortcut = CType(resources.GetObject("mnuserienbriefe.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnuserienbriefe.ShowShortcut = CType(resources.GetObject("mnuserienbriefe.ShowShortcut"), Boolean)
        Me.mnuserienbriefe.Text = resources.GetString("mnuserienbriefe.Text")
        Me.mnuserienbriefe.Visible = CType(resources.GetObject("mnuserienbriefe.Visible"), Boolean)
        '
        'mnuPartnerlisten
        '
        Me.mnuPartnerlisten.Enabled = CType(resources.GetObject("mnuPartnerlisten.Enabled"), Boolean)
        Me.mnuPartnerlisten.Index = 15
        Me.mnuPartnerlisten.Shortcut = CType(resources.GetObject("mnuPartnerlisten.Shortcut"), System.Windows.Forms.Shortcut)
        Me.mnuPartnerlisten.ShowShortcut = CType(resources.GetObject("mnuPartnerlisten.ShowShortcut"), Boolean)
        Me.mnuPartnerlisten.Text = resources.GetString("mnuPartnerlisten.Text")
        Me.mnuPartnerlisten.Visible = CType(resources.GetObject("mnuPartnerlisten.Visible"), Boolean)
        '
        'MenuItem10
        '
        Me.MenuItem10.Enabled = CType(resources.GetObject("MenuItem10.Enabled"), Boolean)
        Me.MenuItem10.Index = 5
        Me.MenuItem10.MdiList = True
        Me.MenuItem10.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem12, Me.MenuItem13, Me.MenuItem14, Me.MenuItem15})
        Me.MenuItem10.MergeOrder = 99
        Me.MenuItem10.Shortcut = CType(resources.GetObject("MenuItem10.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem10.ShowShortcut = CType(resources.GetObject("MenuItem10.ShowShortcut"), Boolean)
        Me.MenuItem10.Text = resources.GetString("MenuItem10.Text")
        Me.MenuItem10.Visible = CType(resources.GetObject("MenuItem10.Visible"), Boolean)
        '
        'MenuItem12
        '
        Me.MenuItem12.Enabled = CType(resources.GetObject("MenuItem12.Enabled"), Boolean)
        Me.MenuItem12.Index = 0
        Me.MenuItem12.Shortcut = CType(resources.GetObject("MenuItem12.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem12.ShowShortcut = CType(resources.GetObject("MenuItem12.ShowShortcut"), Boolean)
        Me.MenuItem12.Text = resources.GetString("MenuItem12.Text")
        Me.MenuItem12.Visible = CType(resources.GetObject("MenuItem12.Visible"), Boolean)
        '
        'MenuItem13
        '
        Me.MenuItem13.Enabled = CType(resources.GetObject("MenuItem13.Enabled"), Boolean)
        Me.MenuItem13.Index = 1
        Me.MenuItem13.Shortcut = CType(resources.GetObject("MenuItem13.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem13.ShowShortcut = CType(resources.GetObject("MenuItem13.ShowShortcut"), Boolean)
        Me.MenuItem13.Text = resources.GetString("MenuItem13.Text")
        Me.MenuItem13.Visible = CType(resources.GetObject("MenuItem13.Visible"), Boolean)
        '
        'MenuItem14
        '
        Me.MenuItem14.Enabled = CType(resources.GetObject("MenuItem14.Enabled"), Boolean)
        Me.MenuItem14.Index = 2
        Me.MenuItem14.Shortcut = CType(resources.GetObject("MenuItem14.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem14.ShowShortcut = CType(resources.GetObject("MenuItem14.ShowShortcut"), Boolean)
        Me.MenuItem14.Text = resources.GetString("MenuItem14.Text")
        Me.MenuItem14.Visible = CType(resources.GetObject("MenuItem14.Visible"), Boolean)
        '
        'MenuItem15
        '
        Me.MenuItem15.Enabled = CType(resources.GetObject("MenuItem15.Enabled"), Boolean)
        Me.MenuItem15.Index = 3
        Me.MenuItem15.Shortcut = CType(resources.GetObject("MenuItem15.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem15.ShowShortcut = CType(resources.GetObject("MenuItem15.ShowShortcut"), Boolean)
        Me.MenuItem15.Text = resources.GetString("MenuItem15.Text")
        Me.MenuItem15.Visible = CType(resources.GetObject("MenuItem15.Visible"), Boolean)
        '
        'MenuItem19
        '
        Me.MenuItem19.Enabled = CType(resources.GetObject("MenuItem19.Enabled"), Boolean)
        Me.MenuItem19.Index = 6
        Me.MenuItem19.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem34, Me.MenuItem58, Me.MenuItem60, Me.MenuItem59, Me.MenuItem37, Me.MenuItem35, Me.MenuItem61, Me.MenuItem38, Me.MenuItem20})
        Me.MenuItem19.MergeOrder = 100
        Me.MenuItem19.Shortcut = CType(resources.GetObject("MenuItem19.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem19.ShowShortcut = CType(resources.GetObject("MenuItem19.ShowShortcut"), Boolean)
        Me.MenuItem19.Text = resources.GetString("MenuItem19.Text")
        Me.MenuItem19.Visible = CType(resources.GetObject("MenuItem19.Visible"), Boolean)
        '
        'MenuItem34
        '
        Me.MenuItem34.Enabled = CType(resources.GetObject("MenuItem34.Enabled"), Boolean)
        Me.MenuItem34.Index = 0
        Me.MenuItem34.Shortcut = CType(resources.GetObject("MenuItem34.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem34.ShowShortcut = CType(resources.GetObject("MenuItem34.ShowShortcut"), Boolean)
        Me.MenuItem34.Text = resources.GetString("MenuItem34.Text")
        Me.MenuItem34.Visible = CType(resources.GetObject("MenuItem34.Visible"), Boolean)
        '
        'MenuItem58
        '
        Me.MenuItem58.Enabled = CType(resources.GetObject("MenuItem58.Enabled"), Boolean)
        Me.MenuItem58.Index = 1
        Me.MenuItem58.Shortcut = CType(resources.GetObject("MenuItem58.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem58.ShowShortcut = CType(resources.GetObject("MenuItem58.ShowShortcut"), Boolean)
        Me.MenuItem58.Text = resources.GetString("MenuItem58.Text")
        Me.MenuItem58.Visible = CType(resources.GetObject("MenuItem58.Visible"), Boolean)
        '
        'MenuItem60
        '
        Me.MenuItem60.Enabled = CType(resources.GetObject("MenuItem60.Enabled"), Boolean)
        Me.MenuItem60.Index = 2
        Me.MenuItem60.Shortcut = CType(resources.GetObject("MenuItem60.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem60.ShowShortcut = CType(resources.GetObject("MenuItem60.ShowShortcut"), Boolean)
        Me.MenuItem60.Text = resources.GetString("MenuItem60.Text")
        Me.MenuItem60.Visible = CType(resources.GetObject("MenuItem60.Visible"), Boolean)
        '
        'MenuItem59
        '
        Me.MenuItem59.Enabled = CType(resources.GetObject("MenuItem59.Enabled"), Boolean)
        Me.MenuItem59.Index = 3
        Me.MenuItem59.Shortcut = CType(resources.GetObject("MenuItem59.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem59.ShowShortcut = CType(resources.GetObject("MenuItem59.ShowShortcut"), Boolean)
        Me.MenuItem59.Text = resources.GetString("MenuItem59.Text")
        Me.MenuItem59.Visible = CType(resources.GetObject("MenuItem59.Visible"), Boolean)
        '
        'MenuItem37
        '
        Me.MenuItem37.Enabled = CType(resources.GetObject("MenuItem37.Enabled"), Boolean)
        Me.MenuItem37.Index = 4
        Me.MenuItem37.Shortcut = CType(resources.GetObject("MenuItem37.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem37.ShowShortcut = CType(resources.GetObject("MenuItem37.ShowShortcut"), Boolean)
        Me.MenuItem37.Text = resources.GetString("MenuItem37.Text")
        Me.MenuItem37.Visible = CType(resources.GetObject("MenuItem37.Visible"), Boolean)
        '
        'MenuItem35
        '
        Me.MenuItem35.Enabled = CType(resources.GetObject("MenuItem35.Enabled"), Boolean)
        Me.MenuItem35.Index = 5
        Me.MenuItem35.Shortcut = CType(resources.GetObject("MenuItem35.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem35.ShowShortcut = CType(resources.GetObject("MenuItem35.ShowShortcut"), Boolean)
        Me.MenuItem35.Text = resources.GetString("MenuItem35.Text")
        Me.MenuItem35.Visible = CType(resources.GetObject("MenuItem35.Visible"), Boolean)
        '
        'MenuItem61
        '
        Me.MenuItem61.Enabled = CType(resources.GetObject("MenuItem61.Enabled"), Boolean)
        Me.MenuItem61.Index = 6
        Me.MenuItem61.Shortcut = CType(resources.GetObject("MenuItem61.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem61.ShowShortcut = CType(resources.GetObject("MenuItem61.ShowShortcut"), Boolean)
        Me.MenuItem61.Text = resources.GetString("MenuItem61.Text")
        Me.MenuItem61.Visible = CType(resources.GetObject("MenuItem61.Visible"), Boolean)
        '
        'MenuItem38
        '
        Me.MenuItem38.Enabled = CType(resources.GetObject("MenuItem38.Enabled"), Boolean)
        Me.MenuItem38.Index = 7
        Me.MenuItem38.Shortcut = CType(resources.GetObject("MenuItem38.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem38.ShowShortcut = CType(resources.GetObject("MenuItem38.ShowShortcut"), Boolean)
        Me.MenuItem38.Text = resources.GetString("MenuItem38.Text")
        Me.MenuItem38.Visible = CType(resources.GetObject("MenuItem38.Visible"), Boolean)
        '
        'MenuItem20
        '
        Me.MenuItem20.Enabled = CType(resources.GetObject("MenuItem20.Enabled"), Boolean)
        Me.MenuItem20.Index = 8
        Me.MenuItem20.Shortcut = CType(resources.GetObject("MenuItem20.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem20.ShowShortcut = CType(resources.GetObject("MenuItem20.ShowShortcut"), Boolean)
        Me.MenuItem20.Text = resources.GetString("MenuItem20.Text")
        Me.MenuItem20.Visible = CType(resources.GetObject("MenuItem20.Visible"), Boolean)
        '
        'MenuItem39
        '
        Me.MenuItem39.Enabled = CType(resources.GetObject("MenuItem39.Enabled"), Boolean)
        Me.MenuItem39.Index = 7
        Me.MenuItem39.MergeOrder = 101
        Me.MenuItem39.OwnerDraw = True
        Me.MenuItem39.Shortcut = CType(resources.GetObject("MenuItem39.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem39.ShowShortcut = CType(resources.GetObject("MenuItem39.ShowShortcut"), Boolean)
        Me.MenuItem39.Text = resources.GetString("MenuItem39.Text")
        Me.MenuItem39.Visible = CType(resources.GetObject("MenuItem39.Visible"), Boolean)
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "profil", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_profil_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_profil_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Timer1
        '
        Me.Timer1.Enabled = True
        Me.Timer1.Interval = 900000
        Me.Timer1.SynchronizingObject = Me
        '
        'Timer2
        '
        Me.Timer2.Enabled = True
        Me.Timer2.Interval = 5000
        Me.Timer2.SynchronizingObject = Me
        '
        'Panel1
        '
        Me.Panel1.AccessibleDescription = CType(resources.GetObject("Panel1.AccessibleDescription"), String)
        Me.Panel1.AccessibleName = CType(resources.GetObject("Panel1.AccessibleName"), String)
        Me.Panel1.Anchor = CType(resources.GetObject("Panel1.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.Panel1.AutoScroll = CType(resources.GetObject("Panel1.AutoScroll"), Boolean)
        Me.Panel1.AutoScrollMargin = CType(resources.GetObject("Panel1.AutoScrollMargin"), System.Drawing.Size)
        Me.Panel1.AutoScrollMinSize = CType(resources.GetObject("Panel1.AutoScrollMinSize"), System.Drawing.Size)
        Me.Panel1.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.Panel1.BackgroundImage = CType(resources.GetObject("Panel1.BackgroundImage"), System.Drawing.Image)
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1})
        Me.Panel1.Dock = CType(resources.GetObject("Panel1.Dock"), System.Windows.Forms.DockStyle)
        Me.Panel1.Enabled = CType(resources.GetObject("Panel1.Enabled"), Boolean)
        Me.Panel1.Font = CType(resources.GetObject("Panel1.Font"), System.Drawing.Font)
        Me.HelpProvider1.SetHelpKeyword(Me.Panel1, resources.GetObject("Panel1.HelpKeyword"))
        Me.HelpProvider1.SetHelpNavigator(Me.Panel1, CType(resources.GetObject("Panel1.HelpNavigator"), System.Windows.Forms.HelpNavigator))
        Me.HelpProvider1.SetHelpString(Me.Panel1, resources.GetObject("Panel1.HelpString"))
        Me.Panel1.ImeMode = CType(resources.GetObject("Panel1.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Panel1.Location = CType(resources.GetObject("Panel1.Location"), System.Drawing.Point)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.RightToLeft = CType(resources.GetObject("Panel1.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.HelpProvider1.SetShowHelp(Me.Panel1, CType(resources.GetObject("Panel1.ShowHelp"), Boolean))
        Me.Panel1.Size = CType(resources.GetObject("Panel1.Size"), System.Drawing.Size)
        Me.Panel1.TabIndex = CType(resources.GetObject("Panel1.TabIndex"), Integer)
        Me.Panel1.Text = resources.GetString("Panel1.Text")
        Me.Panel1.Visible = CType(resources.GetObject("Panel1.Visible"), Boolean)
        '
        'Label1
        '
        Me.Label1.AccessibleDescription = CType(resources.GetObject("Label1.AccessibleDescription"), String)
        Me.Label1.AccessibleName = CType(resources.GetObject("Label1.AccessibleName"), String)
        Me.Label1.Anchor = CType(resources.GetObject("Label1.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.Label1.AutoSize = CType(resources.GetObject("Label1.AutoSize"), Boolean)
        Me.Label1.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.Label1.Dock = CType(resources.GetObject("Label1.Dock"), System.Windows.Forms.DockStyle)
        Me.Label1.Enabled = CType(resources.GetObject("Label1.Enabled"), Boolean)
        Me.Label1.Font = CType(resources.GetObject("Label1.Font"), System.Drawing.Font)
        Me.Label1.ForeColor = System.Drawing.Color.Red
        Me.HelpProvider1.SetHelpKeyword(Me.Label1, resources.GetObject("Label1.HelpKeyword"))
        Me.HelpProvider1.SetHelpNavigator(Me.Label1, CType(resources.GetObject("Label1.HelpNavigator"), System.Windows.Forms.HelpNavigator))
        Me.HelpProvider1.SetHelpString(Me.Label1, resources.GetObject("Label1.HelpString"))
        Me.Label1.Image = CType(resources.GetObject("Label1.Image"), System.Drawing.Image)
        Me.Label1.ImageAlign = CType(resources.GetObject("Label1.ImageAlign"), System.Drawing.ContentAlignment)
        Me.Label1.ImageIndex = CType(resources.GetObject("Label1.ImageIndex"), Integer)
        Me.Label1.ImeMode = CType(resources.GetObject("Label1.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Label1.Location = CType(resources.GetObject("Label1.Location"), System.Drawing.Point)
        Me.Label1.Name = "Label1"
        Me.Label1.RightToLeft = CType(resources.GetObject("Label1.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.HelpProvider1.SetShowHelp(Me.Label1, CType(resources.GetObject("Label1.ShowHelp"), Boolean))
        Me.Label1.Size = CType(resources.GetObject("Label1.Size"), System.Drawing.Size)
        Me.Label1.TabIndex = CType(resources.GetObject("Label1.TabIndex"), Integer)
        Me.Label1.Text = resources.GetString("Label1.Text")
        Me.Label1.TextAlign = CType(resources.GetObject("Label1.TextAlign"), System.Drawing.ContentAlignment)
        Me.Label1.Visible = CType(resources.GetObject("Label1.Visible"), Boolean)
        '
        'Timer3
        '
        Me.Timer3.Interval = 750
        Me.Timer3.SynchronizingObject = Me
        '
        'HelpProvider1
        '
        Me.HelpProvider1.HelpNamespace = CType(resources.GetObject("HelpProvider1.HelpNamespace"), String)
        '
        'EDOKAMain
        '
        Me.AccessibleDescription = CType(resources.GetObject("$this.AccessibleDescription"), String)
        Me.AccessibleName = CType(resources.GetObject("$this.AccessibleName"), String)
        Me.Anchor = CType(resources.GetObject("$this.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.AutoScaleBaseSize = CType(resources.GetObject("$this.AutoScaleBaseSize"), System.Drawing.Size)
        Me.AutoScroll = CType(resources.GetObject("$this.AutoScroll"), Boolean)
        Me.AutoScrollMargin = CType(resources.GetObject("$this.AutoScrollMargin"), System.Drawing.Size)
        Me.AutoScrollMinSize = CType(resources.GetObject("$this.AutoScrollMinSize"), System.Drawing.Size)
        Me.BackgroundImage = CType(resources.GetObject("$this.BackgroundImage"), System.Drawing.Image)
        Me.ClientSize = CType(resources.GetObject("$this.ClientSize"), System.Drawing.Size)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.StatusBar1})
        Me.Dock = CType(resources.GetObject("$this.Dock"), System.Windows.Forms.DockStyle)
        Me.Enabled = CType(resources.GetObject("$this.Enabled"), Boolean)
        Me.Font = CType(resources.GetObject("$this.Font"), System.Drawing.Font)
        Me.HelpProvider1.SetHelpKeyword(Me, resources.GetObject("$this.HelpKeyword"))
        Me.HelpProvider1.SetHelpNavigator(Me, CType(resources.GetObject("$this.HelpNavigator"), System.Windows.Forms.HelpNavigator))
        Me.HelpProvider1.SetHelpString(Me, resources.GetObject("$this.HelpString"))
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.ImeMode = CType(resources.GetObject("$this.ImeMode"), System.Windows.Forms.ImeMode)
        Me.IsMdiContainer = True
        Me.Location = CType(resources.GetObject("$this.Location"), System.Drawing.Point)
        Me.MaximumSize = CType(resources.GetObject("$this.MaximumSize"), System.Drawing.Size)
        Me.Menu = Me.MainMenu1
        Me.MinimumSize = CType(resources.GetObject("$this.MinimumSize"), System.Drawing.Size)
        Me.Name = "EDOKAMain"
        Me.RightToLeft = CType(resources.GetObject("$this.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.HelpProvider1.SetShowHelp(Me, CType(resources.GetObject("$this.ShowHelp"), Boolean))
        Me.StartPosition = CType(resources.GetObject("$this.StartPosition"), System.Windows.Forms.FormStartPosition)
        Me.Text = resources.GetString("$this.Text")
        Me.Visible = CType(resources.GetObject("$this.Visible"), Boolean)
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Timer2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        CType(Me.Timer3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        Dim w As New WordLib()
        w.Create_Labels()
        w = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem12_Click Method

Private Sub MenuItem12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem12_Click_1 Method

Private Sub MenuItem12_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNewLogin.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNewLogin.Click
        init_system()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem12_Click_2 Method

Private Sub MenuItem12_Click_2( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click_2(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem12.Click
        Me.LayoutMdi(System.Windows.Forms.MdiLayout.TileHorizontal)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem13_Click Method

Private Sub MenuItem13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Me.LayoutMdi(System.Windows.Forms.MdiLayout.TileVertical)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem14_Click Method

Private Sub MenuItem14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Me.LayoutMdi(System.Windows.Forms.MdiLayout.Cascade)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        close_all_childs()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        Dim f As New frmPartnerHost()
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem17_Click Method

Private Sub MenuItem17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        ' ' Koe und shu - 2004-08-01
        Dim f As New frmReportSelection()
        f.Text = Replace(MenuItem17.Text, "&", "")
        Me.Cursor = Cursors.WaitCursor
        f.MdiParent = Me
        Try
            f.Show()
        Catch ex As Exception
            Me.Cursor = Cursors.Default
            MsgBox(ex.Message)
        End Try
        Me.Cursor = Cursors.Default

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem18_Click Method

Private Sub MenuItem18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim f As New frmMitarbeitereinstellungen()
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem20_Click Method

Private Sub MenuItem20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem20.Click
        Dim f As New frmAbout()
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem21_Popup Method

Private Sub MenuItem21_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem21_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem21.Popup
        If Globals.Words.Count > 0 Then
            Me.MenuItem36.Enabled = False
            Me.MenuItem40.Enabled = False
        Else
            Me.MenuItem36.Enabled = True
            Me.MenuItem40.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem22_Click Method

Private Sub MenuItem22_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem22.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem22_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem22.Click
        open_trefferliste(pnr(0))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem23_Click Method

Private Sub MenuItem23_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem23.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem23_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem23.Click
        open_trefferliste(pnr(1))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem24_Click Method

Private Sub MenuItem24_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem24.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem24_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem24.Click
        open_trefferliste(pnr(2))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem25_Click Method

Private Sub MenuItem25_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem25.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem25_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem25.Click
        open_trefferliste(pnr(3))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem26_Click Method

Private Sub MenuItem26_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem26.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem26_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem26.Click
        open_trefferliste(pnr(4))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem27_Click Method

Private Sub MenuItem27_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem27.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem27_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem27.Click
        open_trefferliste(pnr(5))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem28_Click Method

Private Sub MenuItem28_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem28.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem28_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem28.Click
        open_trefferliste(pnr(6))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem29_Click Method

Private Sub MenuItem29_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem29.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem29_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem29.Click
        open_trefferliste(pnr(7))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim f As New frmTrefferliste()
        f.MdiParent = Me
        f.Show()
        f.refresh_list()
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem2_Popup Method

Private Sub MenuItem2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem2.Popup
        If Globals.Bearbeitung_Problemdokumente = True Then Me.MenuItem2.Enabled = False Else Me.MenuItem2.Enabled = True
        refresh_menu_trefferliste()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem2_Select Method

Private Sub MenuItem2_Select( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Select

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Select(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem2.Select
        If Globals.Bearbeitung_Problemdokumente = True Then Me.MenuItem2.Enabled = False Else Me.MenuItem2.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem30_Click Method

Private Sub MenuItem30_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem30.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem30_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem30.Click
        open_trefferliste(pnr(8))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem31_Click Method

Private Sub MenuItem31_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem31.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem31_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem31.Click
        open_trefferliste(pnr(9))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem33_Click Method

Private Sub MenuItem33_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem33.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem33_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem33.Click
        Dim f As New frmSearchDoc()
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem34_Click Method

Private Sub MenuItem34_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem34.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem34_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem34.Click
        Globals.HTMLHelp.ShowHelpTopic()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem35_Click Method

Private Sub MenuItem35_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem35.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem35_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem35.Click

        Dim f As New frmWordViewer()
        f.addressBar.Text = Application.StartupPath + "\relnotes.doc"
        f.Text = "Release-Informationen"
        f.ShowDialog()
        f.Dispose()
        ''f.MdiParent = formx
        'Dim f As New frmReleaseNotes()
        'f.ShowDialog()
        'f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem36_Click Method

Private Sub MenuItem36_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem36.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem36_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem36.Click
        Dim w As New WordLib()
        Me.Cursor = Cursors.WaitCursor
        w.ResetFunctions()
        w = Nothing
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem37_Click Method

Private Sub MenuItem37_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem37.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem37_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem37.Click
        Dim F As New frmFAQ()
        F.MdiParent = Me
        F.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem39_Click Method

Private Sub MenuItem39_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem39.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem39_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem39.Click
        MenuItem3_Click(sender, e)
        Me.MenuItem39.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem39_DrawItem Method

Private Sub MenuItem39_DrawItem( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DrawItemEventArgs _
) Handles MenuItem39.DrawItem

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem39_DrawItem(ByVal sender As Object, ByVal e As System.Windows.Forms.DrawItemEventArgs) Handles MenuItem39.DrawItem
        Try
            Dim r As Rectangle = e.Bounds
            r.Width = r.Width * 1.5
            r.Height = r.Height * 0.9
            e.Graphics.DrawImage(Me.ImageList1.Images(6), r)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmMeldungen()
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem40_Click Method

Private Sub MenuItem40_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem40.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem40_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem40.Click
        Dim w As New WordLib()
        Me.Cursor = Cursors.WaitCursor
        w.ResetFunctions_Excel()
        w = Nothing
        Me.Cursor = Cursors.Default

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem42_Click Method

Private Sub MenuItem42_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem42.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem42_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem42.Click
        Me.Cursor = Cursors.WaitCursor
        Me.frmpartnerzusammenlegung.MdiParent = Me
        Me.frmpartnerzusammenlegung.Refresh_All()
        If Me.frmpartnerzusammenlegung.ListBox1.Items.Count > 0 Then
            Me.frmpartnerzusammenlegung.Show()
        End If
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem43_Click Method

Private Sub MenuItem43_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem43.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem43_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem43.Click
        Dim f As New frmSuchFormular(True)
        f.show_checkmessage = True
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem44_Click Method

Private Sub MenuItem44_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem44.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem44_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem44.Click
        Dim f As New frmSuchFormular()
        f.show_checkmessage = True
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem45_Popup Method

Private Sub MenuItem45_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem45.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem45_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem45.Popup
        If Globals.Bearbeitung_Problemdokumente = True Then Me.MenuItem45.Enabled = False Else Me.MenuItem45.Enabled = True
        refresh_menu_trefferliste()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem46_Click Method

Private Sub MenuItem46_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem46.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem46_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem46.Click
        open_suchprofil(spnr(0))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem47_Click Method

Private Sub MenuItem47_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem47.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem47_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem47.Click
        open_suchprofil(spnr(1))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem48_Click Method

Private Sub MenuItem48_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem48.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem48_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem48.Click
        open_suchprofil(spnr(2))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem49_Click Method

Private Sub MenuItem49_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem49.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem49_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem49.Click
        open_suchprofil(spnr(3))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem50_Click Method

Private Sub MenuItem50_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem50.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem50_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem50.Click
        open_suchprofil(spnr(4))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem51_Click Method

Private Sub MenuItem51_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem51.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem51_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem51.Click
        open_suchprofil(spnr(5))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem52_Click Method

Private Sub MenuItem52_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem52.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem52_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem52.Click
        open_suchprofil(spnr(6))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem53_Click Method

Private Sub MenuItem53_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem53.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem53_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem53.Click
        open_suchprofil(spnr(7))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem54_Click Method

Private Sub MenuItem54_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem54.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem54_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem54.Click
        open_suchprofil(spnr(8))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem55_Click Method

Private Sub MenuItem55_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem55.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem55_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem55.Click
        open_suchprofil(spnr(9))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem56_Click Method

Private Sub MenuItem56_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem56.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem56_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem56.Click
        Dim f As New frmSearchDoc()
        f.MdiParent = Me
        f.Show()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem58_Click Method

Private Sub MenuItem58_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem58.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem58_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem58.Click
        Globals.HTMLHelp.ShowHelpIndex()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Dim f As New frmRevision()
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem60_Click Method

Private Sub MenuItem60_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem60.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem60_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem60.Click
        Globals.HTMLHelp.ShowSearch()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem61_Click Method

Private Sub MenuItem61_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem61_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        'Hutter 2005-01-04
        'EDEX_Dokumentpakete
        Dim f As New frmDokumentpaket(1)
        f.Show()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem61_Click_1 Method

Private Sub MenuItem61_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem61.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem61_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem61.Click
        Try
            Dim p As New Process()
            p.Start(Globals.Applikationsdaten.Rows(0).Item("videomenu"))
            p.Dispose()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem62_PopUp Method

Private Sub MenuItem62_PopUp( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem62.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem62_PopUp(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem62.Popup
        Dim i As Integer
        Dim mnuitem As Integer
        Try
            While mnucollection.Count > 0
                Me.mnucollection.Remove(1)

            End While
        Catch
        End Try

        For i = 2 To Me.MenuItem62.MenuItems.Count - 1
            Me.MenuItem62.MenuItems.Item(i).Visible = False
        Next
        mnuitem = 2
        Dim f As New frmOffeneDPInstanzen()
        f.Load_Data()
        i = 0
        If f.dpdaten.Rows.Count = 0 Then
            Me.MenuItem63.Enabled = False
        Else
            Me.MenuItem63.Enabled = True
        End If
        For i = 0 To f.dpdaten.Rows.Count - 1
            If i < 10 Then
                Me.MenuItem62.MenuItems.Item(mnuitem).Text = f.dpdaten.Rows(i).Item("Bezeichnung") + " (" + LTrim(Str(f.dpdaten.Rows(i).Item("nrpar00"))) + ")"
                Me.MenuItem62.MenuItems.Item(mnuitem).Visible = True
                Me.mnucollection.Add(f.dpdaten.Rows(i).Item("nreintrag"))
                mnuitem = mnuitem + 1
            End If
        Next
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem63_Click Method

Private Sub MenuItem63_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem63.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem63_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem63.Click
        Dim f As New frmOffeneDPInstanzen()
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        If Globals.Bearbeitung_Problemdokumente Then Globals.Global_ForceExit = True
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.MnuSystemadministration_Click Method

Private Sub MnuSystemadministration_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSystemadministration.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSystemadministration_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSystemadministration.Click
        Dim f As New FrmSysadminMenu()
        Dim x As Form
        Dim isactive As Boolean
        isactive = False
        For Each x In Me.MdiChildren
            If x.Name = f.Name And x.Visible = True Then
                f.Dispose()
                x.BringToFront()
                isactive = True
            End If
        Next
        If Not isactive Then
            f.MdiParent = Me
            f.Show()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Office_Freigeben Method

Private Sub Office_Freigeben()

Source code

[Visual Basic]
    Private Sub Office_Freigeben()
        Me.Cursor = Cursors.WaitCursor
        Me.close_all_childs()
        Dim f As New frmWaitforClosing()
        f.ProgressBar1.Maximum = 100
        f.ProgressBar1.Minimum = 0
        f.ProgressBar1.Value = 10
        f.Show()
        Dim w As New WordLib()
        w.Office_Freigeben(f)
        w = Nothing
        f.ProgressBar1.Value = 100
        f.Hide()
        f.Dispose()

        'Dim fc As New frmWaitforClosing()
        'fc.ProgressBar1.Maximum = 100
        'fc.ProgressBar1.Minimum = 0
        'Me.close_all_childs()
        'fc.ProgressBar1.Value = 10
        'fc.Show()

        'Dim w As New WordLib()
        'Me.Cursor = Cursors.WaitCursor
        'w.ResetFunctions()
        'fc.ProgressBar1.Value = 55
        'w.ResetFunctions_Excel()
        'fc.ProgressBar1.Value = 100
        'Me.Cursor = Cursors.Default
        'w = Nothing
        'fc.Hide()
        'fc.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.SetLocalSystemTime Method

Private Function SetLocalSystemTime()

Source code

[Visual Basic]
    Private Function SetLocalSystemTime()
        'Rel 3.2 bud - Set System Time
        'Ruft den Befehl NET TIME auf. Somit wird die Lokale System Zeit mit dem Server abgeglichen.
        '
        Try
            Dim aa
            aa = Shell("cmd.exe /C" & " NET TIME  /SET /YES", AppWinStyle.Hide, False)
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.StatusBar1_DoubleClick Method

Private Sub StatusBar1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles StatusBar1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub StatusBar1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles StatusBar1.DoubleClick
        If Me.StatusBar1.Text <> "" Then
            Dim f As New frmMeldungen()
            f.MdiParent = Me
            f.ShowDialog()
            Me.StatusBar1.Text = ""
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.StatusBar1_TextChanged Method

Private Sub StatusBar1_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles StatusBar1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub StatusBar1_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles StatusBar1.TextChanged
        If Me.StatusBar1.Text <> "" Then
            Me.Timer2.Start()
        Else
            Me.Timer2.Stop()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Timer1_Elapsed Method

Private Sub Timer1_Elapsed( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles Timer1.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles Timer1.Elapsed
        Dim i As Integer
        i = DivFnkt.Check_MessageTimer
        If i > 0 Then
            Me.MenuItem39.Visible = True
        End If
        If Not Globals.In_Bearbeitung Then check_doc()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Timer2_Elapsed Method

Private Sub Timer2_Elapsed( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles Timer2.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer2_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles Timer2.Elapsed
        Me.StatusBar1.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.Timer3_Elapsed Method

Private Sub Timer3_Elapsed( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles Timer3.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer3_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles Timer3.Elapsed
        If on_Create Then Exit Sub
        Me.Timer3.Enabled = False
        on_Create = True
        Dim f As New frmTrefferliste()
        f.MdiParent = Me
        f.Show()
        f.Partner_Eingegeben = True
        f.txtnrpar00.Text = Parameters(1)
        f.refresh_list()
        f.Partnernr = Parameters(1)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.Apphandle = Me.Handle.ToInt32
        Win32API.SetForegroundWindow(Me.Handle.ToInt32)
        Win32API.ShowWindow(Me.Handle.ToInt32, Win32API.SW_RESTORE)
        f.Create_Dokument(True, False)
        on_Create = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.TimerFired Method

Public Sub TimerFired( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles MyTimer.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub TimerFired(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles MyTimer.Elapsed
        If mytimerstopped = True Then Exit Sub
        mytimerstopped = True
        MyTimer.Stop()
        Dim i As Integer
        i = DivFnkt.Check_MessageTimer
        If i > 0 Then
            Me.MenuItem39.Visible = True
            '            Me.StatusBar1.Text = "Sie haben " & Str(i) & " ungelesene EDOKA-Meldunge(n)."
        End If
        If Not Globals.In_Bearbeitung Then check_doc()
        If Not Globals.In_Bearbeitung Then DivFnkt.check_doc2()
        MyTimer.Start()
        mytimerstopped = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.WndProc Method

Protected Overrides Sub WndProc( _
   ByRef m As System.Windows.Forms.Message _
)

Parameters

m
Required.

Source code

[Visual Basic]
    Protected Overrides Sub WndProc(ByRef m As System.Windows.Forms.Message)
        Dim bCancel As Boolean = False
        RaiseEvent WndProc2(m, bCancel)
        If Not bCancel Then MyBase.WndProc(m)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.check_doc Method

Private Sub check_doc()

Source code

[Visual Basic]
    Private Sub check_doc()  'check Dok'
        If Me.fcheckdoc.fnkt = 2 Then Exit Sub
        If Not Globals.In_Bearbeitung Then
            fcheckdoc.refresh_list()
            If fcheckdoc.t.Rows.Count > 0 Then
                fcheckdoc.Visible = True
                fcheckdoc.Activate()
            End If
            '            Dim t As DataTable
            '           Dim d As New DocMgmt()
            '          t = d.check_doc
            '         If t.Rows.Count > 0 Then
            '            Dim f As New frmDefekteDokumente()
            '           f.C1TrueDBGrid1.DataSource = t
            '          f.C1TrueDBGrid1.DataMember = t.TableName
            '         f.MdiParent = Me
            '        f.Show()
            '       ' f.Dispose()
            '  End If
            ' 't.Dispose()
            'd = Nothing
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.check_doc_abschluss Method

Private Function check_doc_abschluss( _
   ByVal START As Boolean _
) As Boolean

Parameters

START
Required.

Source code

[Visual Basic]
    Private Function check_doc_abschluss(ByVal START As Boolean) As Boolean
        fcheckdoc.Hide()
        fcheckdoc.fnkt = 2
        fcheckdoc.refresh_list()
        If fcheckdoc.t.Rows.Count > 0 Then
            If START Then
                fcheckdoc.Start = True
                Me.ShowDefekteDokumente = True
                fcheckdoc.TopMost = True
                fcheckdoc.Show()
                Return True
                Exit Function
            End If
        Else
            fcheckdoc.fnkt = 1
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.check_version Method

Private Function check_version() As Integer

Source code

[Visual Basic]
    Private Function check_version() As Integer
        Try
            ChDir(DivFnkt.Get_Filename("", ""))
        Catch
            MkDir(DivFnkt.Get_Filename("", ""))
        End Try

        Try
            If Globals.Applikationsdaten.Rows(0).Item("version") <> Globals.Version Then
                MyMsg.show_standardmessage(42, MsgBoxStyle.Critical)
                Application.Exit()
                Globals.Force_Exit = True
                Me.forceexit = True
                Exit Function
                Dim p As New EdokaUpd()
                p.PrepareUpdate()
                p = Nothing
                Dim StartInfo As New ProcessStartInfo()
                Dim S As String
                Dim i As Integer
                S = DivFnkt.Get_Filename("UpdateEdoka.cmd", "")
                Me.shellparams = S
                Me.forceexit = True
            End If
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.close_all_childs Method

Sub close_all_childs()

Source code

[Visual Basic]
    Sub close_all_childs()
        Dim c As Form
        For Each c In Me.MdiChildren
            c.Close()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.edokamain_resize Method

Private Sub edokamain_resize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub edokamain_resize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        'Me.MandantRolle.Left = Me.Right - Me.MandantRolle.Width
        Globals.EDOKAMAIN_WindowHeight = Me.Height
        Globals.EDOKAMAIN_WindowWidth = Me.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.get_profile Method

Private Function get_profile() As DataTable

Source code

[Visual Basic]
    Private Function get_profile() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofildaten_get_profile"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            '           Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.init_system Method

Private Sub init_system()

Source code

[Visual Basic]
    Private Sub init_system()
        'initialisierung
        ' Datenbank Connection initialisieren
        Dim db_conn As New EDOKA.DB_Connection()
        Globals.conn.sConnectionString = Globals.sConnectionString
        Globals.EDOKAMAIN_Statusbar = Me.StatusBar1

        'Benutzer auslesen
        If Not Globals.Mitarbeiter.Get_Mitarbeiter Then
            MyMsg.show_standardmessage(900, MsgBoxStyle.Critical)
            End
        End If

        'aktuellerBenutzer für EdokaLib setzen
        Dim aktuellerBenutzer As New EDOKALib.BusinessFacade.AktuellerBenutzer(Globals.MitarbeiterNr)

        'initialisierung von logging by uwe 2006-10-16
        Try
#If Debug Then
            Dim c As New TKBLib.Errorhandling.Config(True) 'throw exceptions in errorhandling classes
#End If
#If Not Debug Then
            Dim c As New TKBLib.Errorhandling.Config(False)'do NOT throw exceptions in errorhandling classes
#End If

            Dim paramLogLevel As EDOKALib.BusinessFacade.Parameter
            Dim paramLogLevelUserJournal As EDOKALib.BusinessFacade.Parameter
            Dim paramLogToFile As EDOKALib.BusinessFacade.Parameter
            Dim paramLogFilePath As EDOKALib.BusinessFacade.Parameter

            paramLogLevel = EDOKALib.BusinessFacade.Config.GetParameter("LogLevel")
            paramLogLevelUserJournal = EDOKALib.BusinessFacade.Config.GetParameter("LogLevelUserJournal")
            paramLogToFile = EDOKALib.BusinessFacade.Config.GetParameter("LogToFile")
            paramLogFilePath = EDOKALib.BusinessFacade.Config.GetParameter("LogFilePath")

            Dim tl As System.Diagnostics.TraceLevel
            Dim th As TKBLib.Errorhandling.TraceHelper
            Dim t As New TKBLib.Errorhandling.Tracer()

            If aktuellerBenutzer.Journalisierung Then
                tl = CType(paramLogLevelUserJournal.Wert, System.Diagnostics.TraceLevel)

                If CBool(paramLogToFile.Wert) = True And paramLogFilePath.Wert.Trim.Length > 0 Then
                    TKBLib.Errorhandling.Tracer.StartLoggingToTextFile(paramLogFilePath.Wert, True)
                End If
            Else
                tl = CType(paramLogLevel.Wert, System.Diagnostics.TraceLevel)
            End If
            th = New TKBLib.Errorhandling.TraceHelper(tl)
            TKBLib.Errorhandling.Tracer.StartLoggingToDatabase(Globals.sConnectionString, aktuellerBenutzer.MitarbeiterNr.ToString())
            TKBLib.Errorhandling.TraceHelper.Msg("Edoka.edokamain.init_sys", "logging started", TraceLevel.Info)

        Catch ex As Exception
            Console.WriteLine(ex.Message + " " + ex.StackTrace)
        End Try

        'Rel 3.2 bud - Lokale Systemzeit setzen
        SetLocalSystemTime()

        'System Prüfung / Vista / BUD Rel. 3.7
        Dim AppRowID As Integer
        If DivFnkt.FolderExist("C:\OS") Then
            AppRowID = 2
        Else
            AppRowID = 1
        End If

        'Applikationsdaten laden
        Dim Applikation As New edokaDB.clsApplikation()
        Dim i As Integer
        Applikation.cpMainConnectionProvider = Globals.conn
        Applikation.iApplikationsnr = New SqlInt32(CType(AppRowID, Int32))
        Globals.Applikationsdaten = Applikation.SelectOne
        'Globals.Applikationsdaten = Applikation.SelectAll
        If check_version() = False Then
            If Me.forceexit Then Exit Sub
        End If

        For i = 0 To Globals.Applikationsdaten.Rows.Count - 1
            If Globals.Applikationsdaten.Rows(i).Item("mandantnr") = Globals.MandantNr Then
                Globals.AppldataRow = i
            End If
        Next

        If Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("showlogin") = True Then
            Dim frm As New frmLogin()
            frm.ComboBox1.Select()
            frm.ShowDialog()
            If frm.Mitarbeiternr = -99999 Then
                Close()
                Exit Sub
            End If
        End If

        If Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("showlogin") = False Then
            '            Me.mnuLoginSplit.Visible = False
            Me.MnuNewLogin.Visible = False
            Me.Panel1.Visible = False
            Me.Label1.Visible = False
        Else
            Me.MnuNewLogin.Visible = True
            Me.Label1.Visible = True
            Me.Panel1.Visible = True
            Me.Label1.Text = "Test-/Schulungsumgebung Datenbank: [" + Globals.conn.scoDBConnection.DataSource.ToString + "." + Globals.conn.scoDBConnection.Database.ToString + "]"
        End If

        'Menu Partnerzusammenlegung'
        'If DivFnkt.check_partnerzusammenlegung = False Then
        '    Me.MenuItem41.Visible = False
        '    Me.MenuItem42.Visible = False
        'Else
        '    Me.MenuItem41.Visible = True
        '    Me.MenuItem42.Visible = True
        'End If

        'Rel 3.73 / BUD
        fMehrfachdruck = New frmMehrfachdruck()
        fMehrfachdruck.MdiParent = Me
        fMehrfachdruck.Visible = False
        fMehrfachdruck.Hide()
        fMehrfachdruck.InitForm()

        If DivFnkt.BarcodeEtiketten_Berechtigt = False Then
            Me.MenuItem11.Enabled = False
        Else
            Me.MenuItem11.Enabled = True
        End If
        refresh_menu_trefferliste()
        Delete_Old_Files()
        MyTimer.Interval = Globals.Applikationsdaten.Rows(0).Item("Zeitintervall_in_minuten") * 60 * 1000
        AddHandler MyTimer.Elapsed, AddressOf TimerFired
        'MyTimer.Start()
        mytimerstopped = False
        Me.fcheckdoc.MdiParent = Me
        Me.fcheckdoc.fnkt = 1
        check_doc_abschluss(True)

        Dim ma As New edokaDB.clsMitarbeiter()
        ma.cpMainConnectionProvider = Globals.conn
        ma.iMitarbeiternr = New SqlTypes.SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ma.SelectOne()
        Globals.show_releasenotes = ma.bShowtip.Value = True
        ma.bShowtip = New SqlTypes.SqlBoolean(CType(False, Boolean))
        conn.OpenConnection()
        ma.Update()
        conn.CloseConnection(True)
        ma.Dispose()
        Try
            Me.HelpProvider1.HelpNamespace = Application.StartupPath + "\benudok.chm"
        Catch
        End Try
        Try
            DivFnkt.Gesperrte_Dokumente_Loeschen()
        Catch
        End Try

        'Rel 3.5 / BUD
        'Prüfen ob der angemeldete User Geburstag hat.
        If Check_Geburtstag(Globals.MitarbeiterNr) = 1 Then
            Dim frm As New frmGeburtstag()
            frm.MdiParent = Me
            frm.StartPosition = FormStartPosition.CenterScreen
            frm.TopMost = True
            frm.Show()
            Me.ShowGeburtstag = True
        End If

        'REL 3.7 / SHU
        'Ein bzw. Ausblenden der Serienbrief-Funktionalitäten
        If Me.Check_show_sb = False Then
            Me.mnuserienbriefe.Visible = False
            Me.mnuPartnerlisten.Visible = False
            Me.MenuItem66.Visible = False
        Else
            Me.mnuserienbriefe.Visible = True
            Me.mnuPartnerlisten.Visible = True
            Me.MenuItem66.Visible = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.mnuPartnerlisten_Click Method

Private Sub mnuPartnerlisten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuPartnerlisten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuPartnerlisten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPartnerlisten.Click
        Dim f As New frmPartnerlisteVerwalten()
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.mnuauslieferungen_Click Method

Private Sub mnuauslieferungen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuauslieferungen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuauslieferungen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuauslieferungen.Click
        Dim frm As Windows.Forms.Form
        For Each frm In Me.MdiChildren
            If frm.Name = "frmBLAuslieferungen" Then
                frm.BringToFront()
                Exit Sub
            End If
        Next
        Dim f As New frmBLAuslieferungen()
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.mnudpinstanz_Click Method

Private Sub mnudpinstanz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnudp1.Click, _
   mnudp2.Click, _
   mnudp3.Click, _
   mnudp4.Click, _
   mnudp5.Click, _
   mnudp6.Click, _
   mnudp7.Click, _
   mnudp8.Click, _
   mnudp9.Click, _
   mnudp10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnudpinstanz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnudp1.Click, mnudp2.Click, mnudp3.Click, mnudp4.Click, mnudp5.Click, mnudp6.Click, mnudp7.Click, mnudp8.Click, mnudp9.Click, mnudp10.Click
        Dim mnuitem As New MenuItem()
        mnuitem = sender
        Dim f As New frmDokumentpaket(mnucollection(mnuitem.Index - 1))
        f.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.mnuserienbriefe_Click Method

Private Sub mnuserienbriefe_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuserienbriefe.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuserienbriefe_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuserienbriefe.Click
        Dim f As New frmSerienbriefe()
        f.MdiParent = Me
        f.Show()
        Dim f1 As New frmDruckMessage()
        f1.MdiParent = Me
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.open_suchprofil Method

Private Sub open_suchprofil( _
   ByVal spnr As Integer _
)

Parameters

spnr
Required.

Source code

[Visual Basic]
    Private Sub open_suchprofil(ByVal spnr As Integer)
        Dim f As New frmSuchFormular(False)
        f.MdiParent = Me
        f.show_checkmessage = False
        f.Show()
        f.show_checkmessage = True
        f.cbProfile.SelectedValue = spnr
        f.Update_Profildaten()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.open_trefferliste Method

Private Sub open_trefferliste( _
   ByVal profilnr As Integer _
)

Parameters

profilnr
Required.

Source code

[Visual Basic]
    Private Sub open_trefferliste(ByVal profilnr As Integer)
        Dim i As Integer
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Globals.profilnr = profilnr
        Dim f As New frmTrefferliste()
        f.MdiParent = Me
        f.Show()
        f.Partner_Eingegeben = False
        '        f.refresh_list()
        '       f.Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.refresh_menu_trefferliste Method

Private Sub refresh_menu_trefferliste()

Source code

[Visual Basic]
    Private Sub refresh_menu_trefferliste()
        Me.DataSet1.Clear()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Dim i As Integer

        For i = 0 To Me.MenuItem2.MenuItems.Count - 1
            Me.MenuItem2.MenuItems(i).Visible = False
            Me.MenuItem45.MenuItems(i + 3).Visible = False
        Next
        Try
            For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
                If i < 10 Then
                    Me.MenuItem2.MenuItems(i).Text = Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung")
                    pnr(i) = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                    Me.MenuItem2.MenuItems(i).Visible = True
                End If
            Next
        Catch
        End Try

        Dim d As New DataTable()
        Try
            d = Me.get_profile
            For i = 0 To d.Rows.Count - 1
                If i < 10 Then
                    Me.MenuItem45.MenuItems(i + 3).Text = d.Rows(i).Item("profilname")
                    Me.MenuItem45.MenuItems(i + 3).Visible = True
                    spnr(i) = d.Rows(i).Item("suchprofilnr")
                End If
            Next
        Catch
        Finally
            d.Dispose()
        End Try
        Dim c As Integer = 0
        For i = 3 To Me.MenuItem45.MenuItems.Count - 1
            If Me.MenuItem45.MenuItems(i).Visible = True Then c = c + 1
        Next
        If c = 0 Then Me.MenuItem57.Visible = False Else Me.MenuItem57.Visible = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain Events

EDOKAMain overview

Events

event WndProc2

See Also

EDOKAMain Class


WndProc2 Event

Public Event WndProc2( _
   ByVal m As System.Windows.Forms.Message, _
   ByRef Cancel As Boolean _
) Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.WndProc

Parameters

m
Required.
Cancel
Required.

Source code

[Visual Basic]
    Public Event WndProc2(ByVal m As System.Windows.Forms.Message, ByRef Cancel As Boolean) Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.WndProc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain Fields

EDOKAMain overview

Fields

field DataSet1
field Edoka_Gestartet
field HelpProvider1
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem54
field MenuItem55
field MenuItem56
field MenuItem57
field MenuItem58
field MenuItem59
field MenuItem6
field MenuItem60
field MenuItem61
field MenuItem62
field MenuItem63
field MenuItem64
field MenuItem65
field MenuItem66
field MenuItem7
field MenuItem8
field MenuItem9
field MnuNewLogin
field MnuSystemadministration
field MyTimer
field Panel1
field Parameters
field ShowDefekteDokumente
field ShowGeburtstag
field SqlConnection1
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field StatusBar1
field Timer1
field Timer2
field Timer3
field components
field f1
field fcheckdoc
field forceexit
field frmpartnerzusammenlegung
field mnuPartnerlisten
field mnuauslieferungen
field mnucollection
field mnudp1
field mnudp10
field mnudp2
field mnudp3
field mnudp4
field mnudp5
field mnudp6
field mnudp7
field mnudp8
field mnudp9
field mnuserienbriefe
field mytimerstopped
field on_Create
field pnr
field shellparams
field spnr

See Also

EDOKAMain Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Edoka_Gestartet Variable

Private Edoka_Gestartet As Boolean = False

Source code

[Visual Basic]
    Private Edoka_Gestartet As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


HelpProvider1 Variable

Friend WithEvents HelpProvider1 As System.Windows.Forms.HelpProvider

Source code

[Visual Basic]
    Friend WithEvents HelpProvider1 As System.Windows.Forms.HelpProvider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem23 Variable

Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem28 Variable

Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem29 Variable

Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem30 Variable

Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem31 Variable

Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem32 Variable

Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem33 Variable

Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem34 Variable

Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem35 Variable

Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem36 Variable

Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem37 Variable

Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem38 Variable

Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem39 Variable

Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem40 Variable

Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem41 Variable

Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem42 Variable

Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem43 Variable

Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem44 Variable

Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem45 Variable

Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem46 Variable

Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem47 Variable

Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem48 Variable

Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem49 Variable

Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem50 Variable

Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem51 Variable

Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem52 Variable

Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem53 Variable

Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem54 Variable

Friend WithEvents MenuItem54 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem54 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem55 Variable

Friend WithEvents MenuItem55 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem55 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem56 Variable

Friend WithEvents MenuItem56 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem56 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem57 Variable

Friend WithEvents MenuItem57 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem57 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem58 Variable

Friend WithEvents MenuItem58 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem58 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem59 Variable

Friend WithEvents MenuItem59 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem59 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem60 Variable

Friend WithEvents MenuItem60 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem60 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem61 Variable

Friend WithEvents MenuItem61 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem61 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem62 Variable

Friend WithEvents MenuItem62 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem62 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem63 Variable

Friend WithEvents MenuItem63 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem63 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem64 Variable

Friend WithEvents MenuItem64 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem64 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem65 Variable

Friend WithEvents MenuItem65 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem65 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem66 Variable

Friend WithEvents MenuItem66 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem66 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MnuNewLogin Variable

Friend WithEvents MnuNewLogin As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNewLogin As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MnuSystemadministration Variable

Friend WithEvents MnuSystemadministration As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSystemadministration As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MyTimer Variable

Dim WithEvents MyTimer As New System.Timers.Timer( _
   900000 _
)

Source code

[Visual Basic]
    Dim WithEvents MyTimer As New System.Timers.Timer(900000)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Parameters Variable

Dim Parameters() As String

Source code

[Visual Basic]
    Dim Parameters() As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


ShowDefekteDokumente Variable

Dim ShowDefekteDokumente As Boolean = False

Source code

[Visual Basic]
    Dim ShowDefekteDokumente As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


ShowGeburtstag Variable

Dim ShowGeburtstag As Boolean = False

Source code

[Visual Basic]
    Dim ShowGeburtstag As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Timer1 Variable

Friend WithEvents Timer1 As System.Timers.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Timers.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Timer2 Variable

Friend WithEvents Timer2 As System.Timers.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer2 As System.Timers.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


Timer3 Variable

Friend WithEvents Timer3 As System.Timers.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer3 As System.Timers.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


f1 Variable

Dim WithEvents f1 As New frmMeldungen()

Source code

[Visual Basic]
    Dim WithEvents f1 As New frmMeldungen()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


fcheckdoc Variable

Dim fcheckdoc As New frmDefekteDokumente()

Source code

[Visual Basic]
    Dim fcheckdoc As New frmDefekteDokumente()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


forceexit Variable

Dim forceexit As Boolean = False

Source code

[Visual Basic]
    Dim forceexit As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


frmpartnerzusammenlegung Variable

Dim frmpartnerzusammenlegung As New frmpartnerzusammenlegung()

Source code

[Visual Basic]
    Dim frmpartnerzusammenlegung As New frmpartnerzusammenlegung()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnuPartnerlisten Variable

Friend WithEvents mnuPartnerlisten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuPartnerlisten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnuauslieferungen Variable

Friend WithEvents mnuauslieferungen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuauslieferungen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnucollection Variable

Dim mnucollection As New Collection()

Source code

[Visual Basic]
    Dim mnucollection As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp1 Variable

Friend WithEvents mnudp1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp10 Variable

Friend WithEvents mnudp10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp2 Variable

Friend WithEvents mnudp2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp3 Variable

Friend WithEvents mnudp3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp4 Variable

Friend WithEvents mnudp4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp5 Variable

Friend WithEvents mnudp5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp6 Variable

Friend WithEvents mnudp6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp7 Variable

Friend WithEvents mnudp7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp8 Variable

Friend WithEvents mnudp8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnudp9 Variable

Friend WithEvents mnudp9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudp9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mnuserienbriefe Variable

Friend WithEvents mnuserienbriefe As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuserienbriefe As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


mytimerstopped Variable

Dim mytimerstopped As Boolean

Source code

[Visual Basic]
    Dim mytimerstopped As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


on_Create Variable

Dim on_Create As Boolean = False

Source code

[Visual Basic]
    Dim on_Create As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


pnr Variable

Dim pnr( _
   10 _
) As Integer

Source code

[Visual Basic]
    Dim pnr(10) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


shellparams Variable

Dim shellparams As String

Source code

[Visual Basic]
    Dim shellparams As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


spnr Variable

Dim spnr( _
   10 _
) As Integer

Source code

[Visual Basic]
    Dim spnr(10) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EdokaUpd Class

For a list of all members of this type, see EdokaUpd Members.

System.Object
EDOKAApp.EdokaUpd

Public Class EdokaUpd

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

EdokaUpd Members


EdokaUpd Members

EdokaUpd overview

Properties

property File1
property FileToRun
property m_file2

Methods

method Get_From_DB
method PrepareUpdate
method Save_To_DB

Fields

field m_FileToRun
field m_file1

See Also

EdokaUpd Class


EdokaUpd Properties

EdokaUpd overview

Properties

property File1
property FileToRun
property m_file2

See Also

EdokaUpd Class


EdokaUpd.File1 Property

Property File1() As String

Source code

[Visual Basic]
    Property File1() As String
        Get
            Return m_file1
        End Get
        Set(ByVal Value As String)
            m_file1 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd.FileToRun Property

Property FileToRun()

Source code

[Visual Basic]
    Property FileToRun()
        Get
            Return m_FileToRun
        End Get
        Set(ByVal Value)
            m_FileToRun = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd.m_file2 Property

Property m_file2() As String

Source code

[Visual Basic]
    Property m_file2() As String
        Get
            Return m_file2
        End Get
        Set(ByVal Value As String)
            m_file2 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd Methods

EdokaUpd overview

Methods

method Get_From_DB
method PrepareUpdate
method Save_To_DB

See Also

EdokaUpd Class


EdokaUpd.Get_From_DB Method

Public Function Get_From_DB( _
   ByVal filename1 As String, _
   ByVal filename2 As String, _
   ByVal filetorun As String _
) As String

Parameters

filename1
Required.
filename2
Required.
filetorun
Required.

Source code

[Visual Basic]
    Public Function Get_From_DB(ByVal filename1 As String, ByVal filename2 As String, ByVal filetorun As String) As String
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From edokaupdate", connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Get_From_DB = ""
        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "edokaupdate")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(0)
            Dim MyData1() As Byte
            MyData1 = myRow.Item(1)
            Dim K As Long
            Dim k1 As Long
            K = UBound(MyData)
            k1 = UBound(MyData1)

            Dim fs1 As New FileStream(filename1, FileMode.OpenOrCreate, FileAccess.Write)
            fs1.Write(MyData, 0, K)
            fs1.Close()
            fs1 = Nothing

            Dim fs2 As New FileStream(filename2, FileMode.OpenOrCreate, FileAccess.Write)
            fs2.Write(MyData1, 0, k1)
            fs2.Close()
            fs2 = Nothing

            Me.FileToRun = myRow.Item(2)
            Return Me.FileToRun
        Catch ex As Exception
            Return False
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd.PrepareUpdate Method

Public Function PrepareUpdate() As String

Source code

[Visual Basic]
    Public Function PrepareUpdate() As String
        Dim file1 As String
        Dim file2 As String
        Dim filetorun As String
        Me.Get_From_DB(DivFnkt.Get_Filename("EdokaUpdate.dat", ""), DivFnkt.Get_Filename("UpdateEdoka.cmd", ""), filetorun)
        Return Me.FileToRun
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd.Save_To_DB Method

Public Function Save_To_DB( _
   ByVal filename1 As String, _
   ByVal filename2 As String, _
   ByVal filetorun As String _
)

Parameters

filename1
Required.
filename2
Required.
filetorun
Required.

Source code

[Visual Basic]
    Public Function Save_To_DB(ByVal filename1 As String, ByVal filename2 As String, ByVal filetorun As String)

        Dim Connection As New SqlConnection()
        Dim DA As New SqlDataAdapter("select * from edokaupdate", Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
        Dim ds As New DataSet()
        Dim fs1 As New FileStream(filename1, FileMode.OpenOrCreate, FileAccess.Read)
        Dim fs2 As New FileStream(filename2, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs1.Length) As Byte
        Dim mydata1(fs2.Length) As Byte

        fs1.Read(mydata, 0, fs1.Length)
        fs1.Close()

        fs2.Read(mydata1, 0, fs2.Length)
        fs2.Close()
        Try
            'Connectionstring zur Datenbank
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            DA.Fill(ds, "edokaupdate")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            myRow.Item(0) = mydata
            myRow.Item(1) = mydata1
            myRow.Item(2) = filetorun
            DA.Update(ds, "edokaupdate")
        Catch ex As Exception
            MsgBox("Automatischer Update von EDOKA kann nicht ausgeführt werden." & vbCrLf & ex.Message)
            Return False
        End Try
        fs1 = Nothing
        fs2 = Nothing
        cb = Nothing
        ds = Nothing
        DA = Nothing

        Connection.Close()
        Connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


EdokaUpd Fields

EdokaUpd overview

Fields

field m_FileToRun
field m_file1

See Also

EdokaUpd Class


m_FileToRun Variable

Dim m_FileToRun

Source code

[Visual Basic]
    Dim m_FileToRun

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


m_file1 Variable

Dim m_file1 As String

Source code

[Visual Basic]
    Dim m_file1 As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EdokaUpd


FolderSelect Class

For a list of all members of this type, see FolderSelect Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FolderSelect

Public Class FolderSelect
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FolderSelect Members


FolderSelect Members

FolderSelect overview

Constructors

constructor FolderSelect Constructor

Properties

property InitialDirectory
property InitialDirectoryExpanded
property ShowHiddenDirectory
property ShowSystemDirectory
property foldername
property fullPath
property info

Methods

method Dispose
method FolderSelect_KeyDown
method FolderSelect_Load
method GetInitialNode
method InitializeComponent
method TreeView1_BeforeCollapse
method TreeView1_BeforeExpand
method TreeView1_BeforeSelect
method btnCancel_Click
method btnSelect_Click
method fillTree
method fixPath
method getSubDirs

Fields

field ImageList1
field Panel2
field Panel3
field SelectedNodeAlreadyCollapsed
field SelectedNodeAlreadyExpanded
field TreeView1
field bInitialDirectoryExpanded
field bShowHiddenDirectory
field bShowSystemDirectory
field btnCancel
field btnSelect
field components
field driveLetters
field folder
field sInitialDirectory

See Also

FolderSelect Class


FolderSelect Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

        'Add any initialization after the InitializeComponent() call

        ' initialize the treeView
        'fillTree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect Properties

FolderSelect overview

Properties

property InitialDirectory
property InitialDirectoryExpanded
property ShowHiddenDirectory
property ShowSystemDirectory
property foldername
property fullPath
property info

See Also

FolderSelect Class


FolderSelect.InitialDirectory Property

Public Property InitialDirectory() As String

Source code

[Visual Basic]
    Public Property InitialDirectory() As String
        Get
            Return sInitialDirectory
        End Get
        Set(ByVal Value As String)
            If Directory.Exists(Value) Then
                sInitialDirectory = Value.Trim
            End If
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.InitialDirectoryExpanded Property

Public Property InitialDirectoryExpanded() As Boolean

Source code

[Visual Basic]
    Public Property InitialDirectoryExpanded() As Boolean
        Get
            Return bInitialDirectoryExpanded
        End Get
        Set(ByVal Value As Boolean)
            bInitialDirectoryExpanded = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.ShowHiddenDirectory Property

Public Property ShowHiddenDirectory() As Boolean

Source code

[Visual Basic]
    Public Property ShowHiddenDirectory() As Boolean
        Get
            Return bShowHiddenDirectory
        End Get
        Set(ByVal Value As Boolean)
            bShowHiddenDirectory = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.ShowSystemDirectory Property

Public Property ShowSystemDirectory() As Boolean

Source code

[Visual Basic]
    Public Property ShowSystemDirectory() As Boolean
        Get
            Return bShowSystemDirectory
        End Get
        Set(ByVal Value As Boolean)
            bShowSystemDirectory = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.foldername Property

Public ReadOnly Property foldername() As String

Source code

[Visual Basic]
    Public ReadOnly Property foldername() As String
        Get
            If Not IsNothing(folder) And folder.Exists Then
                Dim FullPath As String = fixPath(TreeView1.SelectedNode)
                Dim index As Integer = FullPath.LastIndexOf("\")
                Return FullPath.Substring(index + 1)
            Else
                Return Nothing
            End If
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.fullPath Property

Public ReadOnly Property fullPath() As String

Source code

[Visual Basic]
    Public ReadOnly Property fullPath() As String
        Get
            If Not IsNothing(folder) And folder.Exists And Not IsNothing(TreeView1.SelectedNode) Then
                Return fixPath(TreeView1.SelectedNode)
            Else
                Return Nothing
            End If
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.info Property

Public ReadOnly Property info() As DirectoryInfo

Source code

[Visual Basic]
    Public ReadOnly Property info() As DirectoryInfo
        Get
            If Not IsNothing(folder) And folder.Exists Then
                Return folder
            Else
                Return Nothing
            End If
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect Methods

FolderSelect overview

Methods

method Dispose
method FolderSelect_KeyDown
method FolderSelect_Load
method GetInitialNode
method InitializeComponent
method TreeView1_BeforeCollapse
method TreeView1_BeforeExpand
method TreeView1_BeforeSelect
method btnCancel_Click
method btnSelect_Click
method fillTree
method fixPath
method getSubDirs

See Also

FolderSelect Class


FolderSelect.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.FolderSelect_KeyDown Method

Private Sub FolderSelect_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As KeyEventArgs _
) Handles MyBase.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FolderSelect_KeyDown(ByVal sender As System.Object, ByVal e As KeyEventArgs) Handles MyBase.KeyDown
        'MsgBox(e.KeyCode)
        Select Case e.KeyCode
            Case Keys.Add
                'MsgBox("Add")
                SelectedNodeAlreadyExpanded = TreeView1.SelectedNode.IsExpanded
                SelectedNodeAlreadyCollapsed = False
            Case Keys.KeyCode.Subtract
                'MsgBox("Subtract")
                SelectedNodeAlreadyExpanded = False
                SelectedNodeAlreadyCollapsed = Not TreeView1.SelectedNode.IsExpanded
            Case Keys.Left
                SelectedNodeAlreadyExpanded = False
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.FolderSelect_Load Method

Private Sub FolderSelect_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FolderSelect_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            ' initialize the treeView
            fillTree()

            Me.Activate()

            TreeView1.Select()

            If sInitialDirectory <> "" Then
                TreeView1.SelectedNode = GetInitialNode()
            End If

            If bInitialDirectoryExpanded Then
                TreeView1.SelectedNode.Expand()
            End If
        Catch doh As Exception
            Console.WriteLine(doh.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.GetInitialNode Method

Private Function GetInitialNode() As TreeNode

Source code

[Visual Basic]
    Private Function GetInitialNode() As TreeNode
        Dim path As String = sInitialDirectory
        If Not path.EndsWith("\") Then
            path += "\"
        End If
        Dim node, subnode As TreeNode
        Dim index As Integer
        Dim label As String
        ' Get the drive
        index = path.IndexOf("\")
        label = path.Substring(0, index + 1)
        ' Search the nodes for the drive
        For Each node In TreeView1.Nodes
            If node.Text.ToLower = label.ToLower Then

                path = path.Remove(0, index + 1)
                Do While path <> ""
                    node.Expand()
                    'MsgBox(path)
                    index = path.IndexOf("\")
                    label = path.Substring(0, index)
                    'MsgBox(label)

                    ' Search the nodes for the sub-directory
                    For Each subnode In node.Nodes
                        If subnode.Text.ToLower = label.ToLower Then
                            node = subnode
                            Exit For
                        End If
                    Next

                    path = path.Remove(0, index + 1)
                Loop
                Exit For
            End If
        Next

        Return node
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FolderSelect))
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.btnSelect = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel2.SuspendLayout()
        Me.Panel3.SuspendLayout()
        Me.SuspendLayout()
        '
        'Panel2
        '
        Me.Panel2.AutoScroll = True
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnSelect, Me.btnCancel})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel2.DockPadding.All = 10
        Me.Panel2.Location = New System.Drawing.Point(6, 222)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(280, 45)
        Me.Panel2.TabIndex = 1
        '
        'btnSelect
        '
        Me.btnSelect.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnSelect.Dock = System.Windows.Forms.DockStyle.Left
        Me.btnSelect.Location = New System.Drawing.Point(10, 10)
        Me.btnSelect.Name = "btnSelect"
        Me.btnSelect.Size = New System.Drawing.Size(75, 25)
        Me.btnSelect.TabIndex = 1
        Me.btnSelect.Text = "&OK"
        '
        'btnCancel
        '
        Me.btnCancel.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.btnCancel.Dock = System.Windows.Forms.DockStyle.Right
        Me.btnCancel.Location = New System.Drawing.Point(198, 10)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(72, 25)
        Me.btnCancel.TabIndex = 2
        Me.btnCancel.Text = "&Cancel"
        '
        'Panel3
        '
        Me.Panel3.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeView1})
        Me.Panel3.DockPadding.All = 10
        Me.Panel3.Location = New System.Drawing.Point(6, 0)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(280, 224)
        Me.Panel3.TabIndex = 5
        '
        'TreeView1
        '
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeView1.ImageList = Me.ImageList1
        Me.TreeView1.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.TreeView1.Location = New System.Drawing.Point(10, 10)
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Size = New System.Drawing.Size(260, 204)
        Me.TreeView1.TabIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'FolderSelect
        '
        Me.AcceptButton = Me.btnSelect
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.CancelButton = Me.btnCancel
        Me.ClientSize = New System.Drawing.Size(292, 273)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.Panel2})
        Me.DockPadding.All = 6
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.KeyPreview = True
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.MinimumSize = New System.Drawing.Size(230, 300)
        Me.Name = "FolderSelect"
        Me.ShowInTaskbar = False
        Me.SizeGripStyle = System.Windows.Forms.SizeGripStyle.Show
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterParent
        Me.Text = "Verzeichnis auswählen"
        Me.Panel2.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.TreeView1_BeforeCollapse Method

Private Sub TreeView1_BeforeCollapse( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeView1.BeforeCollapse

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_BeforeCollapse(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView1.BeforeCollapse
        If e.Node Is TreeView1.SelectedNode Then
            If SelectedNodeAlreadyExpanded Then
                e.Cancel = True
                Exit Sub
            End If
        End If

        ' change the image of the collapsed node back to a closed folder icon
        e.Node.ImageIndex = 0
        e.Node.SelectedImageIndex = 2
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.TreeView1_BeforeExpand Method

Private Sub TreeView1_BeforeExpand( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeView1.BeforeExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_BeforeExpand(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView1.BeforeExpand
        If e.Node Is TreeView1.SelectedNode Then
            If SelectedNodeAlreadyCollapsed Then
                e.Cancel = True
                Exit Sub
            End If
        End If

        getSubDirs(e.Node)                  ' get the sub-folders for the selected node.
        'TextBox1.Text = fixPath(e.Node)     ' update the user selection text box.
        'folder = New DirectoryInfo(e.Node.FullPath)     ' get it's Directory info.

        ' change the image of the expanded node to an opened folder icon
        e.Node.ImageIndex = 1
        e.Node.SelectedImageIndex = 3
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.TreeView1_BeforeSelect Method

Private Sub TreeView1_BeforeSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeView1.BeforeSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_BeforeSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView1.BeforeSelect
        getSubDirs(e.Node)                  ' get the sub-folders for the selected node.
        '        TextBox1.Text = fixPath(e.Node)     ' update the user selection text box.
        folder = New DirectoryInfo(e.Node.FullPath)     ' get it's Directory info.

        ' change the image of the selected node to a selected folder icon
        If e.Node.IsExpanded Then
            e.Node.ImageIndex = 1
            e.Node.SelectedImageIndex = 3
        Else
            e.Node.ImageIndex = 0
            e.Node.SelectedImageIndex = 2
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        folder = Nothing
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.btnSelect_Click Method

Private Sub btnSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelect.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.fillTree Method

Private Sub fillTree()

Source code

[Visual Basic]
    Private Sub fillTree()
        Dim directory As DirectoryInfo
        Dim sCurPath As String = ""

        ' clear out the old values
        TreeView1.Nodes.Clear()

        Dim c As Char
        ' loop through the drive letters and find the available drives.
        For Each c In driveLetters
            sCurPath = c + ":\"
            Try
                ' get the directory informaiton for this path.
                directory = New DirectoryInfo(sCurPath)

                ' if the retrieved directory information points to a valid
                ' directory or drive in this case, add it to the root of the
                ' treeView.
                If directory.Exists Then
                    'MsgBox(sCurPath & " directory.Exists")
                    Dim newNode As TreeNode = New TreeNode(directory.FullName)
                    TreeView1.Nodes.Add(newNode)    ' add the new node to the root level.
                    ' NEW TEEEEEEST
                    If sInitialDirectory = sCurPath Then
                        ' NEW TEEEEEEST

                        getSubDirs(newNode)          ' scan for any sub folders on this drive.

                        ' NEW TEEEEEEST
                    End If
                    ' NEW TEEEEEEST
                End If
            Catch doh As Exception
                Console.WriteLine(doh.Message)
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.fixPath Method

Private Function fixPath( _
   ByVal node As TreeNode _
) As String

Parameters

node
Required.

Source code

[Visual Basic]
    Private Function fixPath(ByVal node As TreeNode) As String
        Dim sRet As String = ""
        Try
            sRet = node.FullPath
            Dim index As Integer = sRet.IndexOf("\\")
            If index > 1 Then
                sRet = node.FullPath.Remove(index, 1)
            End If
        Catch doh As Exception
            Console.WriteLine(doh.Message)
        End Try
        Return sRet
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect.getSubDirs Method

Private Sub getSubDirs( _
   ByVal parent As TreeNode _
)

Parameters

parent
Required.

Source code

[Visual Basic]
    Private Sub getSubDirs(ByVal parent As TreeNode)
        Dim directory As DirectoryInfo
        Try
            ' if we have not scanned this folder before
            If parent.Nodes.Count = 0 Then
                directory = New DirectoryInfo(parent.FullPath)
                Dim dir As DirectoryInfo
                Dim IsHidden, IsSystem As Boolean
                Dim Skip As Boolean

                For Each dir In directory.GetDirectories()
                    ' Determine whether to show directory
                    IsHidden = False
                    IsSystem = False
                    Skip = False
                    'MsgBox(dir.FullName)
                    If (GetAttr(dir.FullName) And FileAttribute.Hidden) = FileAttributes.Hidden Then
                        'MsgBox(dir.FullName & " is a hidden directory")
                        IsHidden = True
                        Skip = True
                    End If
                    If (GetAttr(dir.FullName) And FileAttribute.System) = FileAttributes.System Then
                        'MsgBox(dir.FullName & " is a system directory")
                        IsSystem = True
                        Skip = True
                    End If
                    If IsHidden And bShowHiddenDirectory Then
                        Skip = False
                    End If
                    If IsSystem And bShowSystemDirectory Then
                        Skip = False
                    End If

                    If Not Skip Then
                        Dim newNode As TreeNode = New TreeNode(dir.Name)
                        parent.Nodes.Add(newNode)
                    End If
                Next
            End If

            ' now that we have the children of the parent, see if they
            ' have any child members that need to be scanned.  Scanning
            ' the first level of sub folders insures that you properly
            ' see the '+' or '-' expanding controls on each node that represents
            ' a sub folder with it's own children.
            Dim node As TreeNode
            For Each node In parent.Nodes
                'MsgBox(node.Text & " has " & node.Nodes.Count)
                ' if we have not scanned this node before.
                If node.Nodes.Count = 0 Then
                    ' get the folder information for the specified path.
                    directory = New DirectoryInfo(node.FullPath)

                    ' check this folder for any possible sub-folders
                    Dim dir As DirectoryInfo
                    Try
                        For Each dir In directory.GetDirectories()
                            ' make a new TreeNode and add it to the treeView.
                            Dim newNode As TreeNode = New TreeNode(dir.Name)
                            node.Nodes.Add(newNode)
                        Next
                    Catch
                    End Try
                End If
            Next
        Catch doh As Exception
            Console.WriteLine(doh.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FolderSelect Fields

FolderSelect overview

Fields

field ImageList1
field Panel2
field Panel3
field SelectedNodeAlreadyCollapsed
field SelectedNodeAlreadyExpanded
field TreeView1
field bInitialDirectoryExpanded
field bShowHiddenDirectory
field bShowSystemDirectory
field btnCancel
field btnSelect
field components
field driveLetters
field folder
field sInitialDirectory

See Also

FolderSelect Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


SelectedNodeAlreadyCollapsed Variable

Private SelectedNodeAlreadyCollapsed As Boolean

Source code

[Visual Basic]
    Private SelectedNodeAlreadyCollapsed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


SelectedNodeAlreadyExpanded Variable

Private SelectedNodeAlreadyExpanded As Boolean

Source code

[Visual Basic]
    Private SelectedNodeAlreadyExpanded As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


bInitialDirectoryExpanded Variable

Private bInitialDirectoryExpanded As Boolean

Source code

[Visual Basic]
    Private bInitialDirectoryExpanded As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


bShowHiddenDirectory Variable

Private bShowHiddenDirectory As Boolean

Source code

[Visual Basic]
    Private bShowHiddenDirectory As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


bShowSystemDirectory Variable

Private bShowSystemDirectory As Boolean

Source code

[Visual Basic]
    Private bShowSystemDirectory As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


btnSelect Variable

Friend WithEvents btnSelect As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


driveLetters Variable

Private driveLetters As String = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"

Source code

[Visual Basic]
    Private driveLetters As String = "ABCDEFGHIJKLMNOPQRSTUVWXYZ"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


folder Variable

Private folder As DirectoryInfo

Source code

[Visual Basic]
    Private folder As DirectoryInfo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


sInitialDirectory Variable

Private sInitialDirectory As String

Source code

[Visual Basic]
    Private sInitialDirectory As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FolderSelect


FrmDomainDokumentart Class

For a list of all members of this type, see FrmDomainDokumentart Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmDomainDokumentart

Public Class FrmDomainDokumentart
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmDomainDokumentart Members


FrmDomainDokumentart Members

FrmDomainDokumentart overview

Constructors

constructor FrmDomainDokumentart Constructor

Properties

property ToSelect
property Transferkey
property showlevel

Methods

method Dispose
method FrmSysadminMenu_Load
method InitializeComponent
method ListNodeCollectionRecursive
method ListNodeSave
method MenuItem2_Click
method MenuItem5_Click
method MenuItem7_Click
method MnuKnotenLoeschen_Click
method MnuNeuerKnoten_Click
method MnuSave_Click
method MnuSchliessen_Click
method Toolbtn_Schliessen_ButtonClick
method TreeView_DblClick
method TreeView_DragDrop
method TreeView_DragEnter
method TreeView_ItemDrag
method insert_dokumenttyp

Fields

field ContextMenu1
field ImageList1
field ImageList2
field ImageList3
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MnuKnotenLoeschen
field MnuNeuerKnoten
field MnuSave
field MnuSchliessen
field OpenFileDialog1
field SysMenu
field ToolBarButton1
field Toolbtn_Schliessen
field components
field dokumentart
field eintrag
field itodelete
field m_ShowLevel
field m_ToSelect
field m_TransferKey
field ssort
field todelete

See Also

FrmDomainDokumentart Class


FrmDomainDokumentart Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart Properties

FrmDomainDokumentart overview

Properties

property ToSelect
property Transferkey
property showlevel

See Also

FrmDomainDokumentart Class


FrmDomainDokumentart.ToSelect Property

Property ToSelect() As Boolean

Source code

[Visual Basic]
    Property ToSelect() As Boolean
        Get
            Return m_ToSelect
        End Get
        Set(ByVal Value As Boolean)
            m_ToSelect = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.Transferkey Property

Property Transferkey()

Source code

[Visual Basic]
    Property Transferkey()
        Get
            Return m_TransferKey
        End Get
        Set(ByVal Value)
            m_TransferKey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.showlevel Property

Property showlevel() As Integer

Source code

[Visual Basic]
    Property showlevel() As Integer
        Get
            Return m_ShowLevel
        End Get
        Set(ByVal Value As Integer)
            m_ShowLevel = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart Methods

FrmDomainDokumentart overview

Methods

method Dispose
method FrmSysadminMenu_Load
method InitializeComponent
method ListNodeCollectionRecursive
method ListNodeSave
method MenuItem2_Click
method MenuItem5_Click
method MenuItem7_Click
method MnuKnotenLoeschen_Click
method MnuNeuerKnoten_Click
method MnuSave_Click
method MnuSchliessen_Click
method Toolbtn_Schliessen_ButtonClick
method TreeView_DblClick
method TreeView_DragDrop
method TreeView_DragEnter
method TreeView_ItemDrag
method insert_dokumenttyp

See Also

FrmDomainDokumentart Class


FrmDomainDokumentart.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.FrmSysadminMenu_Load Method

Private Sub FrmSysadminMenu_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmSysadminMenu_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SysMenu.ImageList = Globals.DokumentartenImages
        If ToSelect Then
            dokumentart.LoadTreeMenu(SysMenu, Me.showlevel)
            Me.SysMenu.ContextMenu = Nothing
            Me.AllowDrop = False
        Else
            dokumentart.LoadTreeMenu(SysMenu, 0)
        End If
        SysMenu.ExpandAll()
        itodelete = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmDomainDokumentart))
        Me.Toolbtn_Schliessen = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuSchliessen = New System.Windows.Forms.MenuItem()
        Me.SysMenu = New System.Windows.Forms.TreeView()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeuerKnoten = New System.Windows.Forms.MenuItem()
        Me.MnuKnotenLoeschen = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MnuSave = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.SuspendLayout()
        '
        'Toolbtn_Schliessen
        '
        Me.Toolbtn_Schliessen.AccessibleDescription = CType(resources.GetObject("Toolbtn_Schliessen.AccessibleDescription"), String)
        Me.Toolbtn_Schliessen.AccessibleName = CType(resources.GetObject("Toolbtn_Schliessen.AccessibleName"), String)
        Me.Toolbtn_Schliessen.Anchor = CType(resources.GetObject("Toolbtn_Schliessen.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.Toolbtn_Schliessen.Appearance = CType(resources.GetObject("Toolbtn_Schliessen.Appearance"), System.Windows.Forms.ToolBarAppearance)
        Me.Toolbtn_Schliessen.AutoSize = CType(resources.GetObject("Toolbtn_Schliessen.AutoSize"), Boolean)
        Me.Toolbtn_Schliessen.BackgroundImage = CType(resources.GetObject("Toolbtn_Schliessen.BackgroundImage"), System.Drawing.Image)
        Me.Toolbtn_Schliessen.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.Toolbtn_Schliessen.ButtonSize = CType(resources.GetObject("Toolbtn_Schliessen.ButtonSize"), System.Drawing.Size)
        Me.Toolbtn_Schliessen.Dock = CType(resources.GetObject("Toolbtn_Schliessen.Dock"), System.Windows.Forms.DockStyle)
        Me.Toolbtn_Schliessen.DropDownArrows = CType(resources.GetObject("Toolbtn_Schliessen.DropDownArrows"), Boolean)
        Me.Toolbtn_Schliessen.Enabled = CType(resources.GetObject("Toolbtn_Schliessen.Enabled"), Boolean)
        Me.Toolbtn_Schliessen.Font = CType(resources.GetObject("Toolbtn_Schliessen.Font"), System.Drawing.Font)
        Me.Toolbtn_Schliessen.ImageList = Me.ImageList1
        Me.Toolbtn_Schliessen.ImeMode = CType(resources.GetObject("Toolbtn_Schliessen.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Toolbtn_Schliessen.Location = CType(resources.GetObject("Toolbtn_Schliessen.Location"), System.Drawing.Point)
        Me.Toolbtn_Schliessen.Name = "Toolbtn_Schliessen"
        Me.Toolbtn_Schliessen.RightToLeft = CType(resources.GetObject("Toolbtn_Schliessen.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.Toolbtn_Schliessen.ShowToolTips = CType(resources.GetObject("Toolbtn_Schliessen.ShowToolTips"), Boolean)
        Me.Toolbtn_Schliessen.Size = CType(resources.GetObject("Toolbtn_Schliessen.Size"), System.Drawing.Size)
        Me.Toolbtn_Schliessen.TabIndex = CType(resources.GetObject("Toolbtn_Schliessen.TabIndex"), Integer)
        Me.Toolbtn_Schliessen.TextAlign = CType(resources.GetObject("Toolbtn_Schliessen.TextAlign"), System.Windows.Forms.ToolBarTextAlign)
        Me.Toolbtn_Schliessen.Visible = CType(resources.GetObject("Toolbtn_Schliessen.Visible"), Boolean)
        Me.Toolbtn_Schliessen.Wrappable = CType(resources.GetObject("Toolbtn_Schliessen.Wrappable"), Boolean)
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.Enabled = CType(resources.GetObject("ToolBarButton1.Enabled"), Boolean)
        Me.ToolBarButton1.ImageIndex = CType(resources.GetObject("ToolBarButton1.ImageIndex"), Integer)
        Me.ToolBarButton1.Text = resources.GetString("ToolBarButton1.Text")
        Me.ToolBarButton1.ToolTipText = resources.GetString("ToolBarButton1.ToolTipText")
        Me.ToolBarButton1.Visible = CType(resources.GetObject("ToolBarButton1.Visible"), Boolean)
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = CType(resources.GetObject("ImageList1.ImageSize"), System.Drawing.Size)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        Me.MainMenu1.RightToLeft = CType(resources.GetObject("MainMenu1.RightToLeft"), System.Windows.Forms.RightToLeft)
        '
        'MenuItem1
        '
        Me.MenuItem1.Enabled = CType(resources.GetObject("MenuItem1.Enabled"), Boolean)
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuSchliessen})
        Me.MenuItem1.Shortcut = CType(resources.GetObject("MenuItem1.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem1.ShowShortcut = CType(resources.GetObject("MenuItem1.ShowShortcut"), Boolean)
        Me.MenuItem1.Text = resources.GetString("MenuItem1.Text")
        Me.MenuItem1.Visible = CType(resources.GetObject("MenuItem1.Visible"), Boolean)
        '
        'MnuSchliessen
        '
        Me.MnuSchliessen.Enabled = CType(resources.GetObject("MnuSchliessen.Enabled"), Boolean)
        Me.MnuSchliessen.Index = 0
        Me.MnuSchliessen.Shortcut = CType(resources.GetObject("MnuSchliessen.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuSchliessen.ShowShortcut = CType(resources.GetObject("MnuSchliessen.ShowShortcut"), Boolean)
        Me.MnuSchliessen.Text = resources.GetString("MnuSchliessen.Text")
        Me.MnuSchliessen.Visible = CType(resources.GetObject("MnuSchliessen.Visible"), Boolean)
        '
        'SysMenu
        '
        Me.SysMenu.AccessibleDescription = CType(resources.GetObject("SysMenu.AccessibleDescription"), String)
        Me.SysMenu.AccessibleName = CType(resources.GetObject("SysMenu.AccessibleName"), String)
        Me.SysMenu.AllowDrop = True
        Me.SysMenu.Anchor = CType(resources.GetObject("SysMenu.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.SysMenu.BackgroundImage = CType(resources.GetObject("SysMenu.BackgroundImage"), System.Drawing.Image)
        Me.SysMenu.ContextMenu = Me.ContextMenu1
        Me.SysMenu.Dock = CType(resources.GetObject("SysMenu.Dock"), System.Windows.Forms.DockStyle)
        Me.SysMenu.Enabled = CType(resources.GetObject("SysMenu.Enabled"), Boolean)
        Me.SysMenu.Font = CType(resources.GetObject("SysMenu.Font"), System.Drawing.Font)
        Me.SysMenu.ImageIndex = CType(resources.GetObject("SysMenu.ImageIndex"), Integer)
        Me.SysMenu.ImageList = Me.ImageList3
        Me.SysMenu.ImeMode = CType(resources.GetObject("SysMenu.ImeMode"), System.Windows.Forms.ImeMode)
        Me.SysMenu.Indent = CType(resources.GetObject("SysMenu.Indent"), Integer)
        Me.SysMenu.ItemHeight = CType(resources.GetObject("SysMenu.ItemHeight"), Integer)
        Me.SysMenu.Location = CType(resources.GetObject("SysMenu.Location"), System.Drawing.Point)
        Me.SysMenu.Name = "SysMenu"
        Me.SysMenu.RightToLeft = CType(resources.GetObject("SysMenu.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.SysMenu.SelectedImageIndex = CType(resources.GetObject("SysMenu.SelectedImageIndex"), Integer)
        Me.SysMenu.ShowRootLines = False
        Me.SysMenu.Size = CType(resources.GetObject("SysMenu.Size"), System.Drawing.Size)
        Me.SysMenu.TabIndex = CType(resources.GetObject("SysMenu.TabIndex"), Integer)
        Me.SysMenu.Text = resources.GetString("SysMenu.Text")
        Me.SysMenu.Visible = CType(resources.GetObject("SysMenu.Visible"), Boolean)
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeuerKnoten, Me.MnuKnotenLoeschen, Me.MenuItem2, Me.MenuItem4, Me.MnuSave, Me.MenuItem3, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7})
        Me.ContextMenu1.RightToLeft = CType(resources.GetObject("ContextMenu1.RightToLeft"), System.Windows.Forms.RightToLeft)
        '
        'MnuNeuerKnoten
        '
        Me.MnuNeuerKnoten.Enabled = CType(resources.GetObject("MnuNeuerKnoten.Enabled"), Boolean)
        Me.MnuNeuerKnoten.Index = 0
        Me.MnuNeuerKnoten.Shortcut = CType(resources.GetObject("MnuNeuerKnoten.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuNeuerKnoten.ShowShortcut = CType(resources.GetObject("MnuNeuerKnoten.ShowShortcut"), Boolean)
        Me.MnuNeuerKnoten.Text = resources.GetString("MnuNeuerKnoten.Text")
        Me.MnuNeuerKnoten.Visible = CType(resources.GetObject("MnuNeuerKnoten.Visible"), Boolean)
        '
        'MnuKnotenLoeschen
        '
        Me.MnuKnotenLoeschen.Enabled = CType(resources.GetObject("MnuKnotenLoeschen.Enabled"), Boolean)
        Me.MnuKnotenLoeschen.Index = 1
        Me.MnuKnotenLoeschen.Shortcut = CType(resources.GetObject("MnuKnotenLoeschen.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuKnotenLoeschen.ShowShortcut = CType(resources.GetObject("MnuKnotenLoeschen.ShowShortcut"), Boolean)
        Me.MnuKnotenLoeschen.Text = resources.GetString("MnuKnotenLoeschen.Text")
        Me.MnuKnotenLoeschen.Visible = CType(resources.GetObject("MnuKnotenLoeschen.Visible"), Boolean)
        '
        'MenuItem2
        '
        Me.MenuItem2.Enabled = CType(resources.GetObject("MenuItem2.Enabled"), Boolean)
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Shortcut = CType(resources.GetObject("MenuItem2.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem2.ShowShortcut = CType(resources.GetObject("MenuItem2.ShowShortcut"), Boolean)
        Me.MenuItem2.Text = resources.GetString("MenuItem2.Text")
        Me.MenuItem2.Visible = CType(resources.GetObject("MenuItem2.Visible"), Boolean)
        '
        'MenuItem4
        '
        Me.MenuItem4.Enabled = CType(resources.GetObject("MenuItem4.Enabled"), Boolean)
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Shortcut = CType(resources.GetObject("MenuItem4.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem4.ShowShortcut = CType(resources.GetObject("MenuItem4.ShowShortcut"), Boolean)
        Me.MenuItem4.Text = resources.GetString("MenuItem4.Text")
        Me.MenuItem4.Visible = CType(resources.GetObject("MenuItem4.Visible"), Boolean)
        '
        'MnuSave
        '
        Me.MnuSave.Enabled = CType(resources.GetObject("MnuSave.Enabled"), Boolean)
        Me.MnuSave.Index = 4
        Me.MnuSave.Shortcut = CType(resources.GetObject("MnuSave.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuSave.ShowShortcut = CType(resources.GetObject("MnuSave.ShowShortcut"), Boolean)
        Me.MnuSave.Text = resources.GetString("MnuSave.Text")
        Me.MnuSave.Visible = CType(resources.GetObject("MnuSave.Visible"), Boolean)
        '
        'MenuItem3
        '
        Me.MenuItem3.Enabled = CType(resources.GetObject("MenuItem3.Enabled"), Boolean)
        Me.MenuItem3.Index = 5
        Me.MenuItem3.Shortcut = CType(resources.GetObject("MenuItem3.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem3.ShowShortcut = CType(resources.GetObject("MenuItem3.ShowShortcut"), Boolean)
        Me.MenuItem3.Text = resources.GetString("MenuItem3.Text")
        Me.MenuItem3.Visible = CType(resources.GetObject("MenuItem3.Visible"), Boolean)
        '
        'MenuItem5
        '
        Me.MenuItem5.Enabled = CType(resources.GetObject("MenuItem5.Enabled"), Boolean)
        Me.MenuItem5.Index = 6
        Me.MenuItem5.Shortcut = CType(resources.GetObject("MenuItem5.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem5.ShowShortcut = CType(resources.GetObject("MenuItem5.ShowShortcut"), Boolean)
        Me.MenuItem5.Text = resources.GetString("MenuItem5.Text")
        Me.MenuItem5.Visible = CType(resources.GetObject("MenuItem5.Visible"), Boolean)
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = CType(resources.GetObject("ImageList3.ImageSize"), System.Drawing.Size)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.Filter = resources.GetString("OpenFileDialog1.Filter")
        Me.OpenFileDialog1.Title = resources.GetString("OpenFileDialog1.Title")
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = CType(resources.GetObject("ImageList2.ImageSize"), System.Drawing.Size)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'MenuItem6
        '
        Me.MenuItem6.Enabled = CType(resources.GetObject("MenuItem6.Enabled"), Boolean)
        Me.MenuItem6.Index = 7
        Me.MenuItem6.Shortcut = CType(resources.GetObject("MenuItem6.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem6.ShowShortcut = CType(resources.GetObject("MenuItem6.ShowShortcut"), Boolean)
        Me.MenuItem6.Text = resources.GetString("MenuItem6.Text")
        Me.MenuItem6.Visible = CType(resources.GetObject("MenuItem6.Visible"), Boolean)
        '
        'MenuItem7
        '
        Me.MenuItem7.Enabled = CType(resources.GetObject("MenuItem7.Enabled"), Boolean)
        Me.MenuItem7.Index = 8
        Me.MenuItem7.Shortcut = CType(resources.GetObject("MenuItem7.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem7.ShowShortcut = CType(resources.GetObject("MenuItem7.ShowShortcut"), Boolean)
        Me.MenuItem7.Text = resources.GetString("MenuItem7.Text")
        Me.MenuItem7.Visible = CType(resources.GetObject("MenuItem7.Visible"), Boolean)
        '
        'FrmDomainDokumentart
        '
        Me.AccessibleDescription = CType(resources.GetObject("$this.AccessibleDescription"), String)
        Me.AccessibleName = CType(resources.GetObject("$this.AccessibleName"), String)
        Me.Anchor = CType(resources.GetObject("$this.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.AutoScale = False
        Me.AutoScaleBaseSize = CType(resources.GetObject("$this.AutoScaleBaseSize"), System.Drawing.Size)
        Me.AutoScroll = CType(resources.GetObject("$this.AutoScroll"), Boolean)
        Me.AutoScrollMargin = CType(resources.GetObject("$this.AutoScrollMargin"), System.Drawing.Size)
        Me.AutoScrollMinSize = CType(resources.GetObject("$this.AutoScrollMinSize"), System.Drawing.Size)
        Me.BackgroundImage = CType(resources.GetObject("$this.BackgroundImage"), System.Drawing.Image)
        Me.ClientSize = CType(resources.GetObject("$this.ClientSize"), System.Drawing.Size)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.SysMenu, Me.Toolbtn_Schliessen})
        Me.Dock = CType(resources.GetObject("$this.Dock"), System.Windows.Forms.DockStyle)
        Me.Enabled = CType(resources.GetObject("$this.Enabled"), Boolean)
        Me.Font = CType(resources.GetObject("$this.Font"), System.Drawing.Font)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.ImeMode = CType(resources.GetObject("$this.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Location = CType(resources.GetObject("$this.Location"), System.Drawing.Point)
        Me.MaximizeBox = False
        Me.MaximumSize = CType(resources.GetObject("$this.MaximumSize"), System.Drawing.Size)
        Me.Menu = Me.MainMenu1
        Me.MinimizeBox = False
        Me.MinimumSize = CType(resources.GetObject("$this.MinimumSize"), System.Drawing.Size)
        Me.Name = "FrmDomainDokumentart"
        Me.RightToLeft = CType(resources.GetObject("$this.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.ShowInTaskbar = False
        Me.StartPosition = CType(resources.GetObject("$this.StartPosition"), System.Windows.Forms.FormStartPosition)
        Me.Text = resources.GetString("$this.Text")
        Me.Visible = CType(resources.GetObject("$this.Visible"), Boolean)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.ListNodeCollectionRecursive Method

Private Sub ListNodeCollectionRecursive( _
   ByVal tnParent As TreeNode, _
   ByRef iSort As Integer _
)

Parameters

tnParent
Required.
iSort
Required.

Source code

[Visual Basic]
    Private Sub ListNodeCollectionRecursive(ByVal tnParent As TreeNode, ByRef iSort As Integer)
        Dim tn As TreeNode
        If tnParent.GetNodeCount(False) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        ssort = 0
        Do Until tn Is Nothing
            iSort = iSort + 1
            ListNodeSave(tn, iSort)
            If tn.GetNodeCount(False) > 0 Then
                Call ListNodeCollectionRecursive(tn, iSort)
            End If
            tn = tn.NextNode
        Loop
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.ListNodeSave Method

Private Sub ListNodeSave( _
   ByVal tn As TreeNode, _
   ByRef isort As Integer _
)

Parameters

tn
Required.
isort
Required.

Source code

[Visual Basic]
    Private Sub ListNodeSave(ByVal tn As TreeNode, ByRef isort As Integer)
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim t As DataTable
        Dim key As Long
        Dim i As Integer
        Dim dokumentart As New edokadb.clsMyDokumentart()
        dbkey.cpMainConnectionProvider = conn
        dokumentart.cpMainConnectionProvider = conn

        If tn.Tag <> 0 Then
            dokumentart.iDokumentartnr = New SqlInt32(CType(tn.Tag, Int32))
            dokumentart.SelectOne()
        End If

        dokumentart.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        dokumentart.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        dokumentart.sBezeichnung = New SqlString(CType(tn.Text, String))
        dokumentart.sBeschreibung = New SqlString(CType("", String))
        dokumentart.iParentid = New SqlInt32(CType(tn.Parent.Tag, Int32))
        dokumentart.iImageindex = New SqlInt32(CType(tn.ImageIndex, Int32))
        dokumentart.iImageindexopen = New SqlInt32(CType(tn.SelectedImageIndex, Int32))
        dokumentart.iSort = New SqlInt32(CType(isort, Int32))
        dokumentart.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        dokumentart.bAktiv = New SqlBoolean(CType(True, Boolean))
        dokumentart.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        dokumentart.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        If tn.Tag <> 0 Then
            dokumentart.iDokumentartnr = New SqlInt32(CType(tn.Tag, Int32))
            dokumentart.Update()
        Else
            key = dbkey.get_dbkey("dokumentart")
            conn.OpenConnection()
            dokumentart.iDokumentartnr = New SqlInt32(CType(key, Int32))
            dokumentart.Insert()
            tn.Tag = key
        End If

        For i = 1 To itodelete
            dokumentart.iDokumentartnr = New SqlInt32(CType(todelete(i), Int32))
            t = dokumentart.SelectOne
            If t.Rows.Count > 0 Then
                dokumentart.Delete()
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.SysMenu.SelectedNode.Text = a
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Dim s As String
        Dim split
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName = "" Then Exit Sub
        FileOpen(1, Me.OpenFileDialog1.FileName, OpenMode.Input)
        Do While Not EOF(1)
            s = LineInput(1)
            insert_dokumenttyp(s)
        Loop
        FileClose(1)
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim f As New frmIconSelector()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.SysMenu.SelectedNode.SelectedImageIndex = f.SelectedImage
            Me.SysMenu.SelectedNode.ImageIndex = f.SelectedImage
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MnuKnotenLoeschen_Click Method

Private Sub MnuKnotenLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuKnotenLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuKnotenLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuKnotenLoeschen.Click
        Dim tn As New TreeNode()
        Dim tnp As New TreeNode()
        Dim i As Integer
        tn = Me.SysMenu.SelectedNode
        tnp = tn.Parent
        If tn.ImageIndex = 5 Or tn.ImageIndex = 6 Then
            MyMsg.show_standardmessage(5, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Not (Me.SysMenu.SelectedNode Is Nothing) Then
            itodelete = itodelete + 1
            todelete(itodelete) = tn.Tag
            If Globals.MyMsg.Show_MessageYesNo(3) = MsgBoxResult.Yes Then
                tn.Remove()
            End If
            If tnp.GetNodeCount(True) = 0 Then
                If tnp.ImageIndex <> 5 And tnp.ImageIndex <> 6 Then
                    tnp.ImageIndex = 1
                    tnp.SelectedImageIndex = 2
                End If
            End If
            Me.SysMenu.Refresh()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MnuNeuerKnoten_Click Method

Private Sub MnuNeuerKnoten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeuerKnoten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeuerKnoten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuerKnoten.Click
        Dim a As String
        Dim tn As New TreeNode()
        Dim tnnew As New TreeNode()
        a = InputBox(Globals.MyMsg.Get_Meldungstext(500))
        If a = "" Then Exit Sub
        tn = Me.SysMenu.SelectedNode
        tnnew = tn.Nodes.Add(a)
        With tnnew
            .Tag() = 0
            .ImageIndex() = 1
            .SelectedImageIndex() = 2
        End With
        If tn.ImageIndex <> 5 And tn.ImageIndex <> 6 Then
            tn.ImageIndex = 1
            tn.SelectedImageIndex = 2
        End If
        If tn.GetNodeCount(True) > 0 Then
            If tn.ImageIndex <> 5 And tn.ImageIndex <> 6 Then
                tn.ImageIndex = 1
                tn.SelectedImageIndex = 2
            End If
        End If
        Me.SysMenu.Refresh()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MnuSave_Click Method

Private Sub MnuSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSave.Click
        Dim i As Integer
        conn.OpenConnection()
        ListNodeCollectionRecursive(Me.SysMenu.Nodes(0), 0)
        i = conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.MnuSchliessen_Click Method

Private Sub MnuSchliessen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSchliessen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSchliessen.Click
        Toolbtn_Schliessen_ButtonClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.Toolbtn_Schliessen_ButtonClick Method

Private Sub Toolbtn_Schliessen_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles Toolbtn_Schliessen.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Toolbtn_Schliessen_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles Toolbtn_Schliessen.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.TreeView_DblClick Method

Private Sub TreeView_DblClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles SysMenu.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_DblClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SysMenu.DoubleClick
        If ToSelect Then
            Me.Transferkey = Me.SysMenu.SelectedNode.Tag
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.TreeView_DragDrop Method

Private Sub TreeView_DragDrop( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles SysMenu.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_DragDrop(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenu.DragDrop
        Dim OriginationNode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        If OriginationNode.ImageIndex = 5 Or OriginationNode.ImageIndex = 6 Then
            MyMsg.show_standardmessage(6, MsgBoxStyle.Critical)
            Exit Sub
        End If

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", False) Then
            Dim pt As Point
            Dim DestinationNode As TreeNode
            pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
            DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
            DestinationNode.Nodes.Add(CType(OriginationNode.Clone, TreeNode))
            DestinationNode.Expand()
            If (e.KeyState And CtrlMask) <> CtrlMask Then
                OriginationNode.Remove()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.TreeView_DragEnter Method

Private Sub TreeView_DragEnter( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles SysMenu.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_DragEnter(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenu.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            If (e.KeyState And CtrlMask) = CtrlMask Then
                e.Effect = DragDropEffects.Copy
            Else
                e.Effect = DragDropEffects.Move
            End If
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.TreeView_ItemDrag Method

Private Sub TreeView_ItemDrag( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles SysMenu.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles SysMenu.ItemDrag
        If e.Button = MouseButtons.Left Then
            DoDragDrop(e.Item, DragDropEffects.Move Or DragDropEffects.Copy)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart.insert_dokumenttyp Method

Private Sub insert_dokumenttyp( _
   ByVal s As String _
)

Parameters

s
Required.

Source code

[Visual Basic]
    Private Sub insert_dokumenttyp(ByVal s As String)
        Dim splits
        Dim dt As New edokadb.clsDokumenttyp()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long

        dt.cpMainConnectionProvider = conn
        conn.OpenConnection()
        dt.iDokumenttypnr = New SqlInt32(CType(13, Int32))
        dt.SelectOne()

        splits = Split(s, " ")
        dt.iOffice_vorlagenr = New SqlInt32(CType(2, Int32))
        dt.bHostdokument = New SqlBoolean(CType(True, Boolean))
        dt.sHostdokumenttyp = New SqlString(CType(splits(1), String))
        dt.sBezeichnung = New SqlString(CType(splits(2) + " " + splits(3), String))
        dt.iDokumentart_host = New SqlInt32(CType(splits(0), Int32))
        dt.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        dt.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        dt.iMutierer = New SqlInt32(CType(-1, Int32))

        dbkey.cpMainConnectionProvider = conn
        key = dbkey.get_dbkey("dokumenttyp")
        conn.OpenConnection()
        dt.iDokumenttypnr = New SqlInt32(CType(key, Int32))
        dt.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        dt.Insert()
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainDokumentart Fields

FrmDomainDokumentart overview

Fields

field ContextMenu1
field ImageList1
field ImageList2
field ImageList3
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MnuKnotenLoeschen
field MnuNeuerKnoten
field MnuSave
field MnuSchliessen
field OpenFileDialog1
field SysMenu
field ToolBarButton1
field Toolbtn_Schliessen
field components
field dokumentart
field eintrag
field itodelete
field m_ShowLevel
field m_ToSelect
field m_TransferKey
field ssort
field todelete

See Also

FrmDomainDokumentart Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MnuKnotenLoeschen Variable

Friend WithEvents MnuKnotenLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuKnotenLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MnuNeuerKnoten Variable

Friend WithEvents MnuNeuerKnoten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeuerKnoten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MnuSave Variable

Friend WithEvents MnuSave As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSave As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


MnuSchliessen Variable

Friend WithEvents MnuSchliessen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSchliessen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


SysMenu Variable

Friend WithEvents SysMenu As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents SysMenu As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


Toolbtn_Schliessen Variable

Friend WithEvents Toolbtn_Schliessen As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents Toolbtn_Schliessen As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


eintrag Variable

Dim eintrag As String

Source code

[Visual Basic]
    Dim eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


itodelete Variable

Dim itodelete As Integer

Source code

[Visual Basic]
    Dim itodelete As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


m_ShowLevel Variable

Dim m_ShowLevel As Integer

Source code

[Visual Basic]
    Dim m_ShowLevel As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


m_ToSelect Variable

Dim m_ToSelect As Boolean

Source code

[Visual Basic]
    Dim m_ToSelect As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


m_TransferKey Variable

Dim m_TransferKey As Integer

Source code

[Visual Basic]
    Dim m_TransferKey As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


ssort Variable

Dim ssort As Integer

Source code

[Visual Basic]
    Dim ssort As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


todelete Variable

Dim todelete( _
   50 _
) As Integer

Source code

[Visual Basic]
    Dim todelete(50) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainDokumentart


FrmDomainOfficeVorlageDatei Class

For a list of all members of this type, see FrmDomainOfficeVorlageDatei Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.FrmDomainOfficeVorlageDatei

Public Class FrmDomainOfficeVorlageDatei
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmDomainOfficeVorlageDatei Members


FrmDomainOfficeVorlageDatei Members

FrmDomainOfficeVorlageDatei overview

Constructors

constructor FrmDomainOfficeVorlageDatei Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Sysadmin
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property vorlagenr

Methods

method C1TrueDBGrid1_FetchRowStyle
method Check_Import_Vorlagen
method Check_Vorlagen
method ContextMenu1_Popup
method Dispose
method Export_Vorlagen
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method FrmDomainOfficeVorlageDatei_Load
method Get_From_DB
method Import_Vorlage
method Import_Vorlagen
method InitializeComponent
method MenuItem1_Click
method MenuItem5_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem8_Click
method Mitarbeiter_lesen
method MnuImport_Click
method Refresh_Data
method Save_Vorlage_To_Db
method Save_Vorlage_To_Db_Import
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method aufhebung
method check_passwort
method dogenerate
method freigabe
method mnuGenerate_Click

Fields

field Bookmark
field C1TrueDBGrid1
field ContextMenu1
field DataSet3
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field M_NR
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem10
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemVorlage
field MnuImport
field OpenFileDialog1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field m_sysadmin
field mnuGenerate

See Also

FrmDomainOfficeVorlageDatei Class


FrmDomainOfficeVorlageDatei Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei Properties

FrmDomainOfficeVorlageDatei overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Sysadmin
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property vorlagenr

See Also

FrmDomainOfficeVorlageDatei Class


frmDomainEditor.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
    Property Eintrag() As String
        Get
            Return m_Eintrag
        End Get
        Set(ByVal Value As String)
            m_Eintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
    Property Eintragnr() As Long
        Get
            Return m_Eintragnr
        End Get
        Set(ByVal Value As Long)
            m_Eintragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.FormMaximize Property

Property FormMaximize() As Boolean

Source code

[Visual Basic]
    Property FormMaximize() As Boolean
        Get
            Return m_Maximize
        End Get
        Set(ByVal Value As Boolean)
            m_Maximize = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.Inaktive Property

Property Inaktive() As Boolean

Source code

[Visual Basic]
    Property Inaktive() As Boolean
        Get
            Return m_Inaktive
        End Get
        Set(ByVal Value As Boolean)
            m_Inaktive = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


FrmDomainOfficeVorlageDatei.Sysadmin Property

Property Sysadmin() As Boolean

Source code

[Visual Basic]
    Property Sysadmin() As Boolean
        Get
            Return m_sysadmin
        End Get
        Set(ByVal Value As Boolean)
            m_sysadmin = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


frmDomainEditor.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_TableName
        End Get
        Set(ByVal Value As String)
            m_TableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.ToSelect Property

Property ToSelect() As Boolean

Source code

[Visual Basic]
    Property ToSelect() As Boolean
        Get
            Return m_ToSelect
        End Get
        Set(ByVal Value As Boolean)
            m_ToSelect = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.TransferKey Property

Property TransferKey() As Long

Source code

[Visual Basic]
    Property TransferKey() As Long
        Get
            Return m_TransferKey
        End Get
        Set(ByVal Value As Long)
            m_TransferKey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


FrmDomainOfficeVorlageDatei.vorlagenr Property

Property vorlagenr() As Integer

Source code

[Visual Basic]
    Property vorlagenr() As Integer
        Get
            Return M_NR
        End Get
        Set(ByVal Value As Integer)
            M_NR = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei Methods

FrmDomainOfficeVorlageDatei overview

Methods

method C1TrueDBGrid1_FetchRowStyle
method Check_Import_Vorlagen
method Check_Vorlagen
method ContextMenu1_Popup
method Dispose
method Export_Vorlagen
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method FrmDomainOfficeVorlageDatei_Load
method Get_From_DB
method Import_Vorlage
method Import_Vorlagen
method InitializeComponent
method MenuItem1_Click
method MenuItem5_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem8_Click
method Mitarbeiter_lesen
method MnuImport_Click
method Refresh_Data
method Save_Vorlage_To_Db
method Save_Vorlage_To_Db_Import
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method aufhebung
method check_passwort
method dogenerate
method freigabe
method mnuGenerate_Click

See Also

FrmDomainOfficeVorlageDatei Class


FrmDomainOfficeVorlageDatei.C1TrueDBGrid1_FetchRowStyle Method

Private Sub C1TrueDBGrid1_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles C1TrueDBGrid1.FetchRowStyle, _
   DomainList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1TrueDBGrid1.FetchRowStyle, DomainList.FetchRowStyle
        If Me.C1TrueDBGrid1.Columns("Uebernehmen").CellValue(e.Row) = 1 Then
            e.CellStyle.ForeColor = System.Drawing.Color.Red
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Check_Import_Vorlagen Method

Private Function Check_Import_Vorlagen( _
   ByVal vorlagenverzeichnis As String _
)

Parameters

vorlagenverzeichnis
Required.

Source code

[Visual Basic]
    Private Function Check_Import_Vorlagen(ByVal vorlagenverzeichnis As String)
        Dim s As String
        Dim Fehler As String = ""
        Dim Splitter
        Dim da As DataTable
        Dim ov As New edokadb.clsOffice_vorlage()
        ov.cpMainConnectionProvider = conn
        FileOpen(1, vorlagenverzeichnis + "\uebernahme.txt", OpenMode.Input)
        Input(1, s)
        While Not EOF(1)
            Input(1, s)
            Splitter = Microsoft.VisualBasic.Split(s, "|")
            ov.iOffice_vorlagenr = New SqlInt32(CType(Splitter(0), Int32))
            da = ov.SelectOne()
            If da.Rows.Count = 0 Then
                If Fehler <> "" Then Fehler = Fehler + ", "
                Fehler = Fehler + Trim(Splitter(0))
            End If
        End While
        ov.Dispose()
        FileClose(1)
        If Len(Fehler) > 0 Then
            MsgBox("Folgende Office-Vorlagen sind nicht vorhanden: " + Fehler)
            Return False
        Else
            Return True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Check_Vorlagen Method

Private Function Check_Vorlagen() As Boolean

Source code

[Visual Basic]
    Private Function Check_Vorlagen() As Boolean
        Dim s As String
        s = ""
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        colRows = Me.DomainList.SelectedRows
        Dim i As Integer
        For i = 0 To colRows.Count - 1
            If Me.DomainList.Columns("Nr").CellValue(colRows(i)) = 0 Then
                If Len(s) > 0 Then s = s + ", "
                s = s + Me.DomainList.Columns("Dateinr").CellText(colRows(i).ToString)
            End If
        Next
        If s <> "" Then
            MsgBox("Folgende Einträge habe keine Office_VorlageNr: " + s, MsgBoxStyle.Critical, "Export")
            Return False
        Else
            Return True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Dim i1 As Integer
        If Not DivFnkt.Check_Sysadmin_Stellvertreter(Me.DomainList.Columns("ownernr").Value) Then
            For i1 = 0 To Me.ContextMenu1.MenuItems.Count - 1
                Me.ContextMenu1.MenuItems(i1).Enabled = False
            Next
            Exit Sub
        Else
            For i1 = 0 To Me.ContextMenu1.MenuItems.Count - 1
                Me.ContextMenu1.MenuItems(i1).Enabled = True
            Next
        End If
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        colRows = Me.DomainList.SelectedRows
        Dim sel1 As Boolean = False
        Dim sel2 As Boolean = False
        Dim i As Integer
        Try
            For i = 0 To colRows.Count - 1
                If Me.DomainList.Columns("freigegeben").CellValue(colRows(i)) = True Then sel1 = True
                If Me.DomainList.Columns("freigegeben").CellValue(colRows(i)) = False Then sel2 = True
            Next
        Catch
        End Try
        If Me.DomainList.SelectedRows.Count = 0 Then
            If Me.DomainList.Columns("ownernr").Value = Globals.MitarbeiterNr Or Sysadmin Then
            Else
                Me.mnuGenerate.Enabled = False
                Me.MnuImport.Enabled = False
                Me.MenuItem7.Enabled = False
                Me.MenuItem8.Enabled = False
            End If
        End If

        If Globals.Applikationsdaten.Rows(0).Item("showlogin") = False Then
            Me.mnuGenerate.Enabled = False
            Me.MnuImport.Enabled = False
            Me.MenuItem7.Enabled = False
            Me.MenuItem8.Enabled = False
            If Sysadmin Then Me.MnuImport.Enabled = True
            Exit Sub
        End If
        If Me.DomainList.Columns("dateiname").Text = "" Then
            Me.MenuItem7.Enabled = False
            Me.MenuItem8.Enabled = False
        Else
            If Me.DomainList.Columns("freigegeben").Value = True Then
                Me.MenuItem7.Enabled = False
                Me.MenuItem8.Enabled = True
            Else
                Me.MenuItem7.Enabled = True
                Me.MenuItem8.Enabled = False
            End If
        End If
        If sel1 = True And sel2 = True Then
            Me.MenuItem7.Enabled = False
            Me.MenuItem8.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Export_Vorlagen Method

Private Sub Export_Vorlagen( _
   ByVal vorlagenverzeichnis As String _
)

Parameters

vorlagenverzeichnis
Required.

Source code

[Visual Basic]
    Private Sub Export_Vorlagen(ByVal vorlagenverzeichnis As String)
        Dim i As Integer
        Dim x As Integer
        Dim da As New DataTable()
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
        Dim s As String
        Dim counter As Integer
        ovd.cpMainConnectionProvider = Globals.conn
        colRows = Me.DomainList.SelectedRows

        Dim pg As New frmProgress()
        Dim aa As Integer
        Try
            If colRows.Count > 1 Then
                aa = 100 / colRows.Count
                pg.Bar1.Maximum = colRows.Count
            Else
                aa = 1
                pg.Bar1.Maximum = 1
            End If
        Catch
        End Try
        pg.Info.Text = "Vorlagen exportieren"
        pg.TopMost = True
        pg.Bar1.Minimum = 0
        pg.Bar1.Value = 0
        pg.Show()

        FileOpen(1, vorlagenverzeichnis + "\uebernahme.txt", OpenMode.Output)
        PrintLine(1, "Vorlagenübernahme Produktion: " + Now)
        counter = 0
        For i = 0 To colRows.Count - 1
            ovd.iOffice_vorlage_dateinr = New SqlInt32(CType(Me.DomainList.Columns("dateinr").CellValue(colRows(i)), Int32))
            da = ovd.SelectOne()
            If da.Rows.Count > 0 Then
                If ovd.bFreigegeben.Value = True Then
                    Dim xx
                    s = Get_From_DB(Me.DomainList.Columns("dateinr").CellValue(colRows(i)), vorlagenverzeichnis + "\")
                    x = s.LastIndexOf("\")
                    s = Microsoft.VisualBasic.Right(s, Len(s) - (x + 1))
                    ovd.daUebernahme_produktion = New SqlDateTime(CType(Now, DateTime))
                    Globals.conn.OpenConnection()
                    ovd.Update()
                    Globals.conn.CloseConnection(True)
                    s = ovd.daFragabe_am.ToString + "|" + ovd.iFreigabe_durch.ToString + "|" + ovd.iMutierer.ToString + "|" + ovd.daMutiert_am.ToString + "|" + s
                    PrintLine(1, Trim(Str(Me.DomainList.Columns("nr").CellValue(colRows(i))) + "|" + s))
                End If
            End If
            counter = counter + 1
            pg.Bar1.Value = pg.Bar1.Value + 1
            System.Windows.Forms.Application.DoEvents()
        Next
        pg.Close()
        pg.Dispose()
        FileClose(1)
        ovd.Dispose()
        Refresh_Data()
        MsgBox("Anzahl exportierte Vorlagen: " + Trim(Str(counter)), MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


frmDomainEditor.FormSize Method

Public Sub FormSize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub FormSize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If g_bRun Then
            Me.SuspendLayout()
            Dim ds As New edokadb.clsSysadminfunktion()
            Try
                ds.cpMainConnectionProvider = conn
                ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
                ds.SelectOne()
                If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
                If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
                If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
                If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
                Me.MenuItem1.Text = Me.Eintrag
            Catch
                'MsgBox("Error Resizing Form")
            Finally
            End Try
            ds.Dispose()
            Me.ResumeLayout()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


FrmDomainOfficeVorlageDatei.FrmDomainOfficeVorlageDatei_Load Method

Private Sub FrmDomainOfficeVorlageDatei_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmDomainOfficeVorlageDatei_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim I As Integer
        Me.DomainList.FetchRowStyles = True
        Me.ToolBar1.Buttons(1).Visible = False
        Me.DomainList.AllowAddNew = False
        Me.DomainList.AllowDelete = False
        Me.DomainList.AllowUpdate = False
        Me.Text = "Office-Vorlage-Dateien"
        Me.DomainList.ContextMenu = Me.ContextMenu1
        Me.DomainList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.NoCellTips
        Me.MenuItem3.Visible = False
        Me.MenuItem3.Enabled = False
        If Not DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) And Not Sysadmin Then
            Me.MenuItem4.Visible = False
            Me.MenuItem10.Visible = False
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
        Else
            Sysadmin = True
            Me.MenuItem4.Visible = True
            Me.MenuItem10.Visible = True
            If Globals.Applikationsdaten.Rows(0).Item("showlogin") = False Then
                Me.MenuItem6.Enabled = True
                Me.MenuItem5.Enabled = False
            End If
        End If
        Refresh_Data()
        If Me.vorlagenr <> 0 Then
            For I = 0 To Me.DomainList.Splits(0).Rows.Count - 1
                If Me.DomainList.Columns("Dateinr").CellValue(I) = Me.vorlagenr Then
                    Me.DomainList.Bookmark = I
                    Exit Sub
                End If
            Next
        End If
        Try
            Me.DomainList.Splits(0).DisplayColumns("ownernr").Width = 0
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Get_From_DB Method

Public Function Get_From_DB( _
   ByVal office_vorlagenr As Integer, _
   ByVal pfad As String _
) As String

Parameters

office_vorlagenr
Required.
pfad
Required.

Source code

[Visual Basic]
    Public Function Get_From_DB(ByVal office_vorlagenr As Integer, ByVal pfad As String) As String

        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From office_vorlage_datei where office_vorlage_Dateinr=" + Trim(Str(office_vorlagenr)), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Try
            Dim filename As String
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(2)
            Dim K As Long
            K = UBound(MyData)
            filename = pfad + "" + myRow.Item(10)
            Dim fs As New FileStream(filename, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return filename
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Import_Vorlage Method

Private Sub Import_Vorlage( _
   ByVal Dokumentname As String _
)

Parameters

Dokumentname
Required.

Source code

[Visual Basic]
    Private Sub Import_Vorlage(ByVal Dokumentname As String)
        If Save_Vorlage_To_Db(Dokumentname) Then
            Dim ov As New edokadb.clsOffice_vorlage()
            ov.cpMainConnectionProvider = Globals.conn
            ov.iOffice_vorlagenr = New SqlInt32(CType(Me.DomainList.Columns("Dateinr").Text, Int32))
            ov.SelectOne()
            ov.bIdv_vorlage = New SqlBoolean(CType(False, Boolean))
            ov.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            ov.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            Globals.conn.OpenConnection()
            ov.Update()
            Globals.conn.CloseConnection(True)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Import_Vorlagen Method

Private Sub Import_Vorlagen( _
   ByVal vorlagenverzeichnis As String _
)

Parameters

vorlagenverzeichnis
Required.

Source code

[Visual Basic]
    Private Sub Import_Vorlagen(ByVal vorlagenverzeichnis As String)
        Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
        Dim da As New DataTable()
        Dim s As String
        Dim splitter
        Dim counter As Integer
        ovd.cpMainConnectionProvider = Globals.conn
        counter = 0
        FileOpen(1, vorlagenverzeichnis + "\uebernahme.txt", OpenMode.Input)
        Input(1, s)
        While Not EOF(1)
            Input(1, s)
            splitter = Microsoft.VisualBasic.Split(s, "|")
            ovd.iOffice_vorlage_dateinr = New SqlInt32(CType(splitter(0), Int32))
            da = ovd.SelectOne

            If da.Rows.Count = 0 Then
                ovd.iOffice_vorlage_dateinr = New SqlInt32(CType(splitter(0), Int32))
                ovd.bAktiv = New SqlBoolean(CType(True, Boolean))
                ovd.bFreigegeben = New SqlBoolean(CType(True, Boolean))
                ovd.daFragabe_am = New SqlDateTime(CType(splitter(1), DateTime))
                ovd.daMutiert_am = New SqlDateTime(CType(splitter(4), DateTime))
                ovd.daUebernahme_produktion = New SqlDateTime(CType(Now, DateTime))
                ovd.iFreigabe_durch = New SqlInt32(CType(splitter(2), Int32))
                ovd.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                ovd.iOffice_vorlagenr = ovd.iOffice_vorlage_dateinr
                ovd.sDateiname = New SqlString(CType(splitter(5), String))
                Globals.conn.OpenConnection()
                ovd.Insert()
                Globals.conn.CloseConnection(True)
            Else
                ovd.bAktiv = New SqlBoolean(CType(True, Boolean))
                ovd.bFreigegeben = New SqlBoolean(CType(True, Boolean))
                ovd.daFragabe_am = New SqlDateTime(CType(splitter(1), DateTime))
                ovd.daMutiert_am = New SqlDateTime(CType(splitter(4), DateTime))
                ovd.daUebernahme_produktion = New SqlDateTime(CType(Now, DateTime))
                ovd.iFreigabe_durch = New SqlInt32(CType(splitter(2), Int32))
                ovd.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                ovd.iOffice_vorlagenr = ovd.iOffice_vorlage_dateinr
                ovd.sDateiname = New SqlString(CType(splitter(3), String))
                Globals.conn.OpenConnection()
                ovd.Update()
                Globals.conn.CloseConnection(True)
            End If
            If Save_Vorlage_To_Db_Import(vorlagenverzeichnis + "\" + splitter(5), ovd.iOffice_vorlage_dateinr.Value) Then counter = counter + 1
        End While
        da.Dispose()
        ovd.Dispose()
        FileClose(1)
        Me.Refresh_Data()
        MsgBox("Anzahl importierte Vorlagen:" + Str(counter))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmDomainOfficeVorlageDatei))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuGenerate = New System.Windows.Forms.MenuItem()
        Me.MnuImport = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItemVorlage = New System.Windows.Forms.MenuItem()
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.DataSet3 = New System.Data.DataSet()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuGenerate, Me.MnuImport, Me.MenuItem9, Me.MenuItem7, Me.MenuItem8, Me.MenuItem4, Me.MenuItem10, Me.MenuItemVorlage})
        '
        'mnuGenerate
        '
        Me.mnuGenerate.Index = 0
        Me.mnuGenerate.Text = "IDV-Dokument generieren und importieren"
        '
        'MnuImport
        '
        Me.MnuImport.Index = 1
        Me.MnuImport.Text = "Dokumentvorlage importieren"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 2
        Me.MenuItem9.Text = "-"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 3
        Me.MenuItem7.Text = "Vorlage für Übernahme freigeben"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 4
        Me.MenuItem8.Text = "Freigabe der Vorlage aufheben"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 5
        Me.MenuItem4.Text = "-"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 6
        Me.MenuItem10.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5, Me.MenuItem6})
        Me.MenuItem10.Text = "Export/Import"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "Vorlagen für Übernahme exportieren"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "&Vorlagen importieren"
        '
        'MenuItemVorlage
        '
        Me.MenuItemVorlage.Index = 7
        Me.MenuItemVorlage.Text = "&Office-Vorlagenr Produktion vergeben"
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(75, 23)
        Me.C1TrueDBGrid1.TabIndex = 8
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.Visible = False
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" Co" & _
        "lumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyl" & _
        "e=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScroll" & _
        "Group=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 71, 19</ClientRect><Border" & _
        "Side>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle par" & _
        "ent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterB" & _
        "arStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style" & _
        "3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me" & _
        "=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyl" & _
        "e parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><Re" & _
        "cordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""" & _
        "Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGr" & _
        "id.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=" & _
        """Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Hea" & _
        "ding"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Norm" & _
        "al"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" " & _
        "me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal""" & _
        " me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Norm" & _
        "al"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSpl" & _
        "its>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelW" & _
        "idth>16</DefaultRecSelWidth><ClientArea>0, 0, 71, 19</ClientArea></Blob>"
        '
        'FrmDomainOfficeVorlageDatei
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(952, 465)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.Name = "FrmDomainOfficeVorlageDatei"
        Me.Text = "FrmDomainOfficeVorlageDatei"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemVorlage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemVorlage.Click
        Dim s As String
        s = InputBox("Office-Vorlagenr Produktion", "Office-Vorlagenr Produktion erfassen")
        If Len(s) > 0 Then
            Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
            ovd.cpMainConnectionProvider = conn
            ovd.iOffice_vorlage_dateinr = New SqlInt32(CType(Me.DomainList.Columns("dateinr").Value, Integer))
            ovd.SelectOne()
            Dim Splitter = Microsoft.VisualBasic.Split(ovd.sDateiname.Value.ToString, ".")

            ovd.iOffice_vorlagenr = New SqlInt32(CType(s, Integer))
            ovd.sDateiname = New SqlString(CType(Trim(s) + "." + Splitter(1), String))
            conn.OpenConnection()
            ovd.Update()
            conn.CloseConnection(True)
            ovd.Dispose()
            Refresh_Data()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        If check_passwort() = False Then Exit Sub
        If Check_Vorlagen() = False Then Exit Sub
        Dim f As New FolderSelect()
        f.InitialDirectory = "C:\"
        f.InitialDirectoryExpanded = True
        Me.Cursor = Cursors.WaitCursor
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Cursor = Cursors.WaitCursor
            Export_Vorlagen(f.fullPath)
        End If
        f.Dispose()
        Me.Refresh_Data()
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        If check_passwort() = False Then Exit Sub
        Dim f As New FolderSelect()
        f.InitialDirectory = "C:\"
        f.InitialDirectoryExpanded = True
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Cursor = Cursors.WaitCursor
            If Check_Import_Vorlagen(f.fullPath) Then Import_Vorlagen(f.fullPath)
        End If
        Me.Refresh_Data()
        Me.Cursor = Cursors.Default
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim i As Integer
        Dim x As Integer
        Dim a As Integer
        Dim bm As Integer = Me.DomainList.Bookmark
        Dim da As New DataTable()
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
        Dim s As String
        Dim counter As Integer
        ovd.cpMainConnectionProvider = Globals.conn
        colRows = Me.DomainList.SelectedRows
        counter = 0
        Me.Cursor = Cursors.WaitCursor
        Dim pg As New frmProgress()
        Dim aa As Integer
        Try
            If colRows.Count > 1 Then
                aa = 100 / colRows.Count
                pg.Bar1.Maximum = colRows.Count
            Else
                aa = 1
                pg.Bar1.Maximum = 1
            End If
        Catch
        End Try
        pg.Info.Text = "Vorlagen exportieren"
        pg.TopMost = True
        pg.Bar1.Minimum = 0
        pg.Bar1.Value = 0
        pg.Show()

        For i = 0 To colRows.Count - 1
            For x = 0 To Me.DomainList.Splits(0).Rows.Count - 1
                If Me.DomainList.Columns("Dateinr").CellValue(x) = Me.DomainList.Columns("dateinr").CellValue(colRows(i)) Then
                    Me.DomainList.Bookmark = x
                    If Me.DomainList.Columns("ownernr").Value = Globals.MitarbeiterNr Or Sysadmin Then
                        If freigabe() Then counter = counter + 1
                        Exit For
                    End If
                End If
            Next
            pg.Bar1.Value = pg.Bar1.Value + 1
            Windows.Forms.Application.DoEvents()
        Next
        Me.Refresh_Data()
        Me.DomainList.Bookmark = bm
        Me.Cursor = Cursors.Default
        pg.Close()
        pg.Dispose()
        MsgBox("Anzahl freigegebene Vorlagen: " + Trim(Str(counter)), MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Dim i As Integer
        Dim x As Integer
        Dim a As Integer
        Dim bm As Integer = Me.DomainList.Bookmark
        Dim da As New DataTable()
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
        Dim s As String
        Dim counter As Integer
        ovd.cpMainConnectionProvider = Globals.conn
        colRows = Me.DomainList.SelectedRows
        counter = 0
        Dim pg As New frmProgress()
        Dim aa As Integer
        Try
            If colRows.Count > 1 Then
                aa = 100 / colRows.Count
                pg.Bar1.Maximum = colRows.Count
            Else
                aa = 1
                pg.Bar1.Maximum = 1
            End If
        Catch
        End Try
        pg.Info.Text = "Vorlagen exportieren"
        pg.TopMost = True
        pg.Bar1.Minimum = 0
        pg.Bar1.Value = 0
        pg.Show()

        Me.Cursor = Cursors.WaitCursor
        For i = 0 To colRows.Count - 1
            For x = 0 To Me.DomainList.Splits(0).Rows.Count - 1
                If Me.DomainList.Columns("dateinr").CellValue(x) = Me.DomainList.Columns("dateinr").CellValue(colRows(i)) Then
                    Me.DomainList.Bookmark = x
                    If Me.DomainList.Columns("ownernr").Value = Globals.MitarbeiterNr Or Sysadmin Then
                        aufhebung()
                        counter = counter + 1
                        Exit For
                    End If
                End If
            Next
            pg.Bar1.Value = pg.Bar1.Value + 1
            System.Windows.Forms.Application.DoEvents()
        Next
        Me.Refresh_Data()
        Me.DomainList.Bookmark = bm
        Me.Cursor = Cursors.Default
        pg.Close()
        pg.Dispose()
        MsgBox("Anzahl aufgehobene Vorlagen: " + Trim(Str(counter)), MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Mitarbeiter_lesen Method

Public Function Mitarbeiter_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Mitarbeiter_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_mitarbeiter_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.MnuImport_Click Method

Private Sub MnuImport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuImport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuImport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuImport.Click
        Me.Cursor = Cursors.WaitCursor
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then
            Me.Cursor = Cursors.WaitCursor
            Me.Bookmark = Me.DomainList.Bookmark
            Import_Vorlage(Me.OpenFileDialog1.FileName)
            Me.Refresh_Data()
            Me.DomainList.Bookmark = Me.Bookmark
            Me.Cursor = Cursors.Default
        End If
        Me.Refresh()
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Refresh_Data Method

Private Sub Refresh_Data()

Source code

[Visual Basic]
    Private Sub Refresh_Data()
        Dim i As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.CommandText = "dbo.SP_Office_Vorlage_Datei"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
            Me.C1TrueDBGrid1.DataSource = dtToReturn
            Me.C1TrueDBGrid1.DataMember = dtToReturn.TableName
            Try
                For i = 0 To Me.DomainList.Columns.Count - 1
                    Me.C1TrueDBGrid1.Columns(i).FilterText = Me.DomainList.Columns(i).FilterText
                Next
            Catch
            End Try
            Me.DomainList.DataSource = dtToReturn
            Me.DomainList.DataMember = dtToReturn.TableName
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            '            DivFnkt.SpaltenTitel_Aktualisieren(Me.DomainList, dtToReturn, "OfficeVorlageDatei")
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            Me.DomainList.Columns("freigegeben").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            Me.DomainList.Columns("Uebernehmen").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            Me.DomainList.Columns("Aktiv").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            For i = 0 To Me.DomainList.Splits(0).DisplayColumns.Count - 1
                Me.DomainList.Splits(0).DisplayColumns(i).AutoSize()
            Next i
            Try
                For i = 0 To Me.DomainList.Columns.Count - 1
                    Me.DomainList.Columns(i).FilterText = Me.C1TrueDBGrid1.Columns(i).FilterText
                Next
            Catch
            End Try

        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Save_Vorlage_To_Db Method

Private Function Save_Vorlage_To_Db( _
   ByVal dokumentname As String _
) As Boolean

Parameters

dokumentname
Required.

Source code

[Visual Basic]
    Private Function Save_Vorlage_To_Db(ByVal dokumentname As String) As Boolean
        Try
            Dim IntFilename As String
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from office_vorlage_datei where office_vorlage_dateinr = " + Trim(Me.DomainList.Columns("DateiNr").Text), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Dim fi As New IO.FileInfo(dokumentname)
            IntFilename = (fi.Name)
            Try
                fs.Read(mydata, 0, fs.Length)
                If fs.Length = 0 Then
                    MsgBox("Fehler bei der Datei Nr: " + Trim(Me.DomainList.Columns("DateiNr").Text) + ", " + dokumentname)
                    fs.Close()
                    Return False
                End If
                fs.Close()

                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "docs")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    ' Neues Dokument speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Me.DomainList.Columns("Dateinr").Text
                    myRow.Item(1) = 0
                    myRow.Item(2) = mydata
                    myRow.Item(3) = 1
                    myRow.Item(4) = Now
                    myRow.Item(5) = Globals.MitarbeiterNr
                    myRow.Item(6) = 0
                    myRow.Item(7) = System.DBNull.Value
                    myRow.Item(8) = 0
                    myRow.Item(10) = IntFilename
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "docs")
                Else
                    'Bestehendes Dokument sichenr
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(2) = mydata
                    myRow.Item(3) = 1
                    myRow.Item(4) = Now
                    myRow.Item(5) = Globals.MitarbeiterNr
                    myRow.Item(6) = 0
                    myRow.Item(7) = System.DBNull.Value
                    myRow.Item(8) = 0

                    myRow.Item(10) = IntFilename
                    DA.Update(ds, "docs")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
                MsgBox(ex.Message)
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.Save_Vorlage_To_Db_Import Method

Private Function Save_Vorlage_To_Db_Import( _
   ByVal dokumentname As String, _
   ByVal nr As Integer _
) As Boolean

Parameters

dokumentname
Required.
nr
Required.

Source code

[Visual Basic]
    Private Function Save_Vorlage_To_Db_Import(ByVal dokumentname As String, ByVal nr As Integer) As Boolean
        Try
            Dim IntFilename As String
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from office_vorlage_datei where office_vorlagenr = " + Trim(Str(nr)), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Dim fi As New IO.FileInfo(dokumentname)
            IntFilename = (fi.Name)
            Try
                fs.Read(mydata, 0, fs.Length)
                If fs.Length = 0 Then
                    MsgBox("Fehler bei der Datei Nr: " + Trim(nr) + ", " + dokumentname)
                    fs.Close()
                    Return False
                End If
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "docs")
                Dim myRow As DataRow

                myRow = ds.Tables(0).Rows(0)
                myRow.Item(2) = mydata
                myRow.Item(10) = IntFilename
                DA.Update(ds, "docs")
                Return True
            Catch ex As Exception
                MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
        Catch
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


frmDomainEditor.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet)
        'Spaltentitel setzen
        If g_bRun Then
            Dim titel As New EDOKA.MySpaltenTitel()
            Dim anzcols As Integer
            Dim cols(Me.DomainList.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
            Dim ts As New EDOKA.Tabellenspalte()
            Dim i As Integer
            Dim t As New DataTable()
            Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
            Dim s As String
            anzcols = Me.DomainList.Splits(0).DisplayColumns.Count
            t = ds.Tables(0)
            ts.Tabelle = Me.TableName
            For i = 0 To Me.DomainList.Columns.Count - 1
                s = Me.DomainList.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.DomainList.Columns(i).Caption = ts.spaltenname

                If ts.ColWith = 0 Then
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                    Me.DomainList.Splits(0).DisplayColumns(i).Visible = False
                Else
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If

                '            If Me.DomainList.Columns(i).Caption = "" Then
                '                Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                '            Else
                '                Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                '            End If
                '            If Me.DomainList.Columns(i).Caption = "" Then Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                If ts.locked Then
                    Me.DomainList.Splits(0).DisplayColumns(i).Locked = True
                End If

                If ts.AlsHacken Then
                    Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.DomainList.Columns(i).DataField = "aktiv" Then
                    Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.DomainList.Columns(i).ValueItems.DefaultItem = True
                    Me.DomainList.Columns(i).DefaultValue = True
                    Me.DomainList.Columns(i).FilterText = True
                End If
                If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
                    Me.DomainList.Columns(i).DefaultValue = Now
                End If
                'Me.DomainList.Splits(0).DisplayColumns.Insert(ts.Order, Me.DomainList.Splits(0).DisplayColumns(i))
                'me.DomainList.Splits(0).DisplayColumns.RemoveAt(i)
                '            cols(ts.Order) = Me.DomainList.Splits(0).DisplayColumns(i)
            Next
            '       For i = 0 To Me.DomainList.Splits(0).DisplayColumns.Count - 1
            '          Me.DomainList.Splits(0).DisplayColumns.RemoveAt(0)
            '     Next
            '    For i = anzcols To 0 Step -1
            '       Me.DomainList.Splits(0).DisplayColumns.Insert(0, cols(i))
            '  Next
            ' cols = Nothing
            '
            Form_As_SelectForm()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


FrmDomainOfficeVorlageDatei.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.aufhebung Method

Private Sub aufhebung()

Source code

[Visual Basic]
    Private Sub aufhebung()
        Me.Bookmark = Me.DomainList.Bookmark
        Try
            Dim ov As New edokadb.clsOffice_Vorlage_Datei()
            Dim da As New DataTable()
            ov.cpMainConnectionProvider = Globals.conn
            ov.iOffice_vorlage_dateinr = New SqlInt32(CType(Me.DomainList.Columns("dateinr").Text, Int32))
            da = ov.SelectOne()
            ov.bFreigegeben = New SqlBoolean(CType(False, Boolean))
            ov.iFreigabe_durch = New SqlInt32(CType(0, Int32))
            ov.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            ov.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            Globals.conn.OpenConnection()
            ov.Update()
            Globals.conn.CloseConnection(True)
            Dim Connection As New SqlConnection()
            Dim DAA As New SqlDataAdapter("select * from office_vorlage_datei where office_vorlage_dateinr = " + Trim(Me.DomainList.Columns("DateiNr").Text), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DAA)
            Dim ds As New DataSet()
            Dim myRow As DataRow
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            DAA.Fill(ds, "Docs")
            myRow = ds.Tables(0).Rows(0)
            myRow.Item(7) = System.DBNull.Value
            DAA.Update(ds, "docs")
            cb = Nothing
            ds = Nothing
            DAA = Nothing
            Connection.Close()
            Connection = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.check_passwort Method

Private Function check_passwort() As Boolean

Source code

[Visual Basic]
    Private Function check_passwort() As Boolean
        Dim pw As New frmPasswort()
        pw.ShowDialog()
        If pw.DialogResult = DialogResult.Abort Then
            pw.Dispose()
            Return False
            Exit Function
        End If
        If UCase(pw.PasswortText.Text) <> UCase(Globals.Applikationsdaten.Rows(0).Item("passwort_vorlagenverwaltung")) Then
            pw.Dispose()
            Return False
            Exit Function
        End If
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.dogenerate Method

Public Function dogenerate() As Boolean

Source code

[Visual Basic]
    Public Function dogenerate() As Boolean
        Dim i As Integer
        Dim w As New WordLib()
        Dim ov As New edokadb.clsOffice_vorlage()
        ov.cpMainConnectionProvider = Globals.conn
        ov.iOffice_vorlagenr = New SqlInt32(CType(Me.DomainList.Columns("Dateinr").Text, Int32))
        ov.SelectOne()
        Dim filename As String
        If ov.iOwner.Value <> Globals.MitarbeiterNr And Not Me.Sysadmin Then
            ov.Dispose()
            Return False
            Exit Function
        End If
        Try
            i = ov.iAnwendungnr.Value
            If i = 2 Then
                filename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "" + Me.DomainList.Columns("dateinr").Text + ".xls"
            Else
                filename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "" + Me.DomainList.Columns("dateinr").Text + ".doc"
            End If
            If Not ov.sIdv_id.Value Is System.DBNull.Value And Not ov.sIdv_id.Value = "" Then

                i = Val(ov.sIdv_id.Value)
                If i > 0 Then
                    i = Val(Me.DomainList.Columns("dateinr").Text)
                    If w.Create_Empty_Doc_and_Save(i, filename) = True Then
                        Import_Vorlage(filename)
                    Else
                        'BUD - 07.11.2006 - Korrekture mit Return False im else Fall
                        Return False
                    End If
                End If
            End If
            Return True
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("FrmDomainOfficeVorlageDatei.dogenerate.", ex.Message + " " + ex.StackTrace, TraceLevel.Warning)
        Finally
            ov = Nothing
            w = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.freigabe Method

Public Function freigabe() As Boolean

Source code

[Visual Basic]
    Public Function freigabe() As Boolean
        Dim ov As New edokadb.clsOffice_Vorlage_Datei()
        Dim da As New DataTable()
        Me.Bookmark = Me.DomainList.Bookmark
        ov.cpMainConnectionProvider = Globals.conn
        ov.iOffice_vorlage_dateinr = New SqlInt32(CType(Me.DomainList.Columns("dateinr").Text, Int32))
        da = ov.SelectOne()
        ov.bFreigegeben = New SqlBoolean(CType(True, Boolean))
        ov.iFreigabe_durch = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ov.daFragabe_am = New SqlDateTime(CType(Now, DateTime))
        ov.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        ov.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        Globals.conn.OpenConnection()
        ov.Update()
        Globals.conn.CloseConnection(True)
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei.mnuGenerate_Click Method

Private Sub mnuGenerate_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuGenerate.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuGenerate_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuGenerate.Click
        Dim i As Integer
        Dim x As Integer
        Dim a As Integer
        Dim da As New DataTable()
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ovd As New edokadb.clsOffice_Vorlage_Datei()
        Dim s As String
        Dim counter As Integer
        ovd.cpMainConnectionProvider = Globals.conn
        colRows = Me.DomainList.SelectedRows
        counter = 0
        Dim pg As New frmProgress()
        Dim aa As Integer
        Try
            If colRows.Count > 1 Then
                aa = 100 / colRows.Count
                pg.Bar1.Maximum = colRows.Count
            Else
                aa = 1
                pg.Bar1.Maximum = 1
            End If
        Catch
        End Try
        pg.Info.Text = "Vorlagen exportieren"
        pg.TopMost = True
        pg.Bar1.Minimum = 0
        pg.Bar1.Value = 0
        pg.Show()

        For i = 0 To colRows.Count - 1
            For x = 0 To Me.DomainList.Splits(0).Rows.Count - 1
                If Me.DomainList.Columns("Dateinr").CellValue(x) = Me.DomainList.Columns("Dateinr").CellValue(colRows(i)) Then
                    Me.DomainList.Bookmark = x
                    If Me.DomainList.Columns("ownernr").Value = Globals.MitarbeiterNr Or Sysadmin Then
                        If dogenerate() Then counter = counter + 1
                        Exit For
                    End If
                End If
            Next
            pg.Bar1.Value = pg.Bar1.Value + 1
            System.Windows.Forms.Application.DoEvents()

        Next
        pg.Close()
        pg.Dispose()
        Me.Refresh_Data()
        MsgBox("Anzahl generierte Vorlagen: " + Trim(Str(counter)), MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmDomainOfficeVorlageDatei Fields

FrmDomainOfficeVorlageDatei overview

Fields

field Bookmark
field C1TrueDBGrid1
field ContextMenu1
field DataSet3
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field M_NR
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem10
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemVorlage
field MnuImport
field OpenFileDialog1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field m_sysadmin
field mnuGenerate

See Also

FrmDomainOfficeVorlageDatei Class


Bookmark Variable

Dim Bookmark As Long

Source code

[Visual Basic]
    Dim Bookmark As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


M_NR Variable

Dim M_NR As Integer = 0

Source code

[Visual Basic]
    Dim M_NR As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MenuItemVorlage Variable

Friend WithEvents MenuItemVorlage As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemVorlage As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


MnuImport Variable

Friend WithEvents MnuImport As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuImport As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


ToolBtnSave Variable

Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


m_sysadmin Variable

Dim m_sysadmin As Boolean = False

Source code

[Visual Basic]
    Dim m_sysadmin As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


mnuGenerate Variable

Friend WithEvents mnuGenerate As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuGenerate As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmDomainOfficeVorlageDatei


FrmFunktionsgruppe_Reportgruppe Class

For a list of all members of this type, see FrmFunktionsgruppe_Reportgruppe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.FrmFunktionsgruppe_Reportgruppe

Public Class FrmFunktionsgruppe_Reportgruppe
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmFunktionsgruppe_Reportgruppe Members


FrmFunktionsgruppe_Reportgruppe Members

FrmFunktionsgruppe_Reportgruppe overview

Constructors

constructor FrmFunktionsgruppe_Reportgruppe Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method FrmFunktionsgruppe_Reportgruppe_Load
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

FrmFunktionsgruppe_Reportgruppe Class


FrmFunktionsgruppe_Reportgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe Properties

FrmFunktionsgruppe_Reportgruppe overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

FrmFunktionsgruppe_Reportgruppe Class


frmRelEditor.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
        Property Eintrag() As String
            Get
                Return m_Eintrag
            End Get
            Set(ByVal Value As String)
                m_Eintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
        Property Eintragnr() As Long
            Get
                Return m_Eintragnr
            End Get
            Set(ByVal Value As Long)
                m_Eintragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.KeyLeft Property

Property KeyLeft() As Long

Source code

[Visual Basic]
        Property KeyLeft() As Long
            Get
                Return m_KeyLeft
            End Get
            Set(ByVal Value As Long)
                m_KeyLeft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.KeyRight Property

Property KeyRight() As Long

Source code

[Visual Basic]
        Property KeyRight() As Long
            Get
                Return m_KeyRight
            End Get
            Set(ByVal Value As Long)
                m_KeyRight = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TableNameBottom Property

Property TableNameBottom() As String

Source code

[Visual Basic]
        Property TableNameBottom() As String
            Get
                Return m_TableNameBottom
            End Get
            Set(ByVal Value As String)
                m_TableNameBottom = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TableNameLeft Property

Property TableNameLeft() As String

Source code

[Visual Basic]
        Property TableNameLeft() As String
            Get
                Return m_TableNameLeft
            End Get
            Set(ByVal Value As String)
                m_TableNameLeft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TableNameRight Property

Property TableNameRight() As String

Source code

[Visual Basic]
        Property TableNameRight() As String
            Get
                Return m_TableNameRight
            End Get
            Set(ByVal Value As String)
                m_TableNameRight = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


FrmFunktionsgruppe_Reportgruppe Methods

FrmFunktionsgruppe_Reportgruppe overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method FrmFunktionsgruppe_Reportgruppe_Load
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose

See Also

FrmFunktionsgruppe_Reportgruppe Class


FrmFunktionsgruppe_Reportgruppe.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


frmRelEditor.FormSize Method

Public Sub FormSize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Public Sub FormSize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
            Dim ds As New edokadb.clsSysadminfunktion()
            If g_bRun Then

                Try
                    ds.cpMainConnectionProvider = conn
                    ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
                    ds.SelectOne()
                    If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
                    If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
                    If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
                    If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
                    Me.MenuItem1.Text = Me.Eintrag
                Catch
                    '    MsgBox("Error Resizing Form")
                Finally
                End Try
                ds.Dispose()
                Me.Text = Me.Eintrag
                Try
                    Globals.WinPos.Get_Position(Me)
                Catch
                Finally
                End Try
            End If

        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


FrmFunktionsgruppe_Reportgruppe.FrmFunktionsgruppe_Reportgruppe_Load Method

Private Sub FrmFunktionsgruppe_Reportgruppe_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmFunktionsgruppe_Reportgruppe_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "funktionsgruppe"
        Me.TableNameRight = "reportgruppe"
        Me.TableNameBottom = "funktionsgruppe_reportgruppe"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("reportfile", "reportfile"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_funktionsgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodeetiketten", System.Data.SqlDbType.Bit, 1))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edokapartner", System.Data.SqlDbType.Bit, 1))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionszuweisung", System.Data.SqlDbType.Bit, 1))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_report_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfile", System.Data.SqlDbType.VarBinary, 2147483647, "reportfile"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_report_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfile", System.Data.SqlDbType.VarBinary, 2147483647, "reportfile"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeldregelNr", "reportfeldregelNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtypNr", "feldtypNr"), New System.Data.Common.DataColumnMapping("feldsteuerungNr", "feldsteuerungNr"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_reportfeldregel_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_reportfeldregel_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_reportgruppe_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_reportfeldregel_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe_reportgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("FunktionsgruppeReportgruppeNr", "FunktionsgruppeReportgruppeNr"), New System.Data.Common.DataColumnMapping("funktionsgruppeNr", "funktionsgruppeNr"), New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_Funktionsgruppe_Reportgruppe_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_Funktionsgruppe_Reportgruppe_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@FunktionsgruppeReportgruppeNr", System.Data.SqlDbType.Int, 4, "FunktionsgruppeReportgruppeNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppeNr", System.Data.SqlDbType.Int, 4, "funktionsgruppeNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_Funktionsgruppe_Reportgruppe_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@FunktionsgruppeReportgruppeNr", System.Data.SqlDbType.Int, 4, "FunktionsgruppeReportgruppeNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppeNr", System.Data.SqlDbType.Int, 4, "funktionsgruppeNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_FunktionsgruppeReportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "FunktionsgruppeReportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_Funktionsgruppe_Reportgruppe_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_FunktionsgruppeReportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "FunktionsgruppeReportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'FrmFunktionsgruppe_Reportgruppe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, -20)
        Me.Name = "FrmFunktionsgruppe_Reportgruppe"
        Me.Text = ""
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsFunktionsgruppe_reportgruppe()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                'vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                vdata.iFunktionsgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    'vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                    vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    'vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                    vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    'vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                    vdata.iFunktionsgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    'vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                    vdata.iFunktionsgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                'vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            'vdata.iReihenfolge = New SqlInt32(CType(1, Int32))
            'vdata.iReihenfolge = New SqlInt32(CType(1, Int32))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("funktionsgruppe_reportgruppe")
            'vdata.iReportfeld_nr = New SqlInt32(CType(key, Int32))
            vdata.iFunktionsgruppeReportgruppeNr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable
        Try
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlConnection1.Open()
            ' Nur für den aktuell gewählten Mandanten die Daten auslesen
            Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
            Me.SqlDataAdapter1.Fill(Me.DataSet1)
            Me.TBLeft.DataSource = Me.DataSet1
            Me.TBLeft.DataMember = Me.DataSet1.Tables(0).TableName
            Me.TBLeft.DataSource = Me.DataSet1

            ' Nur für den aktuell gewählten Mandanten die Daten auslesen
            Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
            Me.SqlDataAdapter2.Fill(Me.DataSet2)
            Me.TBRight.DataSource = Me.DataSet2
            Me.TBRight.DataMember = Me.DataSet2.Tables(0).TableName
            SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
            SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)

            UpdateGrpText(5035, 5027, 5049)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If

        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.DataSet3.Tables(0).TableName

        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


frmRelEditor.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tblnr As Integer, _
   ByVal tblname As String, _
   ByVal ds As DataSet _
)

Parameters

tblnr
Required.
tblname
Required.
ds
Required.

Source code

[Visual Basic]
        Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)
            'Spaltentitel setzen
            Dim titel As New EDOKA.MySpaltenTitel()
            Dim ts As New EDOKA.Tabellenspalte()
            Dim i As Integer
            Dim t As New DataTable()
            t = ds.Tables(0)
            If tblnr = 1 Then
                ts.Tabelle = tblname
                For i = 0 To Me.TBLeft.Columns.Count - 1
                    Dim s As String
                    s = Me.TBLeft.Columns(i).DataField
                    ts.Feld = s
                    ts.getspalte()
                    If ts.spaltenname <> "" Then
                        Me.TBLeft.Columns(i).Caption = ts.spaltenname

                        If ts.ColWith = 0 Then
                            Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                            Me.TBLeft.Splits(0).DisplayColumns(i).Visible = False
                        Else
                            Me.TBLeft.Splits(0).DisplayColumns(i).Width = ts.ColWith
                        End If

                        'If Me.TBLeft.Columns(i).Caption = "" Then
                        '    Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                        'Else
                        '    Me.TBLeft.Splits(0).DisplayColumns(i).Width = ts.ColWith
                        'End If
                        If ts.locked Then
                            Me.TBLeft.Splits(0).DisplayColumns(i).Locked = True
                        End If
                        If ts.AlsHacken Then
                            Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        End If
                        'Präsentation von aktiv
                        If Me.TBLeft.Columns(i).DataField = "aktiv" Then
                            Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                            Me.TBLeft.Columns(i).ValueItems.DefaultItem = True
                            Me.TBLeft.Columns(i).DefaultValue = True
                            Me.TBLeft.Columns(i).FilterText = True
                        End If
                        If Me.TBLeft.Columns(i).DataField = "erstellt_am" Then
                            Me.TBLeft.Columns(i).DefaultValue = Now
                        End If
                    Else
                        Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                    End If
                Next
            End If
            If tblnr = 2 Then
                ts.Tabelle = tblname
                For i = 0 To Me.TBRight.Columns.Count - 1
                    Dim s As String
                    s = Me.TBRight.Columns(i).DataField
                    ts.Feld = s
                    ts.getspalte()
                    Me.TBRight.Columns(i).Caption = ts.spaltenname
                    If ts.ColWith = 0 Then
                        Me.TBRight.Splits(0).DisplayColumns(i).Width = 0
                        Me.TBRight.Splits(0).DisplayColumns(i).Visible = False
                    Else
                        Me.TBRight.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If

                    'If Me.TBRight.Columns(i).Caption = "" Then
                    '    Me.TBRight.Splits(0).DisplayColumns(i).Width = 0
                    'Else
                    '    Me.TBRight.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    'End If
                    If ts.locked Then
                        Me.TBRight.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If

                    'Präsentation von aktiv
                    If Me.TBRight.Columns(i).DataField = "aktiv" Then
                        Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.TBRight.Columns(i).ValueItems.DefaultItem = True
                        Me.TBRight.Columns(i).DefaultValue = True
                        Me.TBRight.Columns(i).FilterText = True
                    End If
                    If Me.TBRight.Columns(i).DataField = "erstellt_am" Then
                        Me.TBRight.Columns(i).DefaultValue = Now
                    End If
                Next
            End If
            If tblnr = 3 Then
                ts.Tabelle = tblname
                For i = 0 To Me.TBBottom.Columns.Count - 1
                    Dim s As String
                    s = Me.TBBottom.Columns(i).DataField
                    ts.Feld = s
                    ts.getspalte()
                    Me.TBBottom.Columns(i).Caption = ts.spaltenname

                    If ts.ColWith = 0 Then
                        Me.TBBottom.Splits(0).DisplayColumns(i).Width = 0
                        Me.TBBottom.Splits(0).DisplayColumns(i).Visible = False
                    Else
                        Me.TBBottom.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If
                    'If Me.TBBottom.Columns(i).Caption = "" Then
                    '    Me.TBBottom.Splits(0).DisplayColumns(i).Width = 0
                    'Else
                    '    Me.TBBottom.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    'End If
                    If ts.locked Then
                        Me.TBBottom.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If

                    'Präsentation von aktiv
                    If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                        Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                        Me.TBBottom.Columns(i).DefaultValue = True
                        Me.TBBottom.Columns(i).FilterText = True
                    End If
                    If Me.TBBottom.Columns(i).DataField = "erstellt_am" Then
                        Me.TBBottom.Columns(i).DefaultValue = Now
                    End If
                Next
            End If
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TBBottom_Format Method

Public Sub TBBottom_Format()

Source code

[Visual Basic]
        Public Sub TBBottom_Format()
            Dim i As Integer
            For i = 0 To Me.TBBottom.Columns.Count - 1
                'Präsentation von aktiv
                If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBBottom.Columns(i).DefaultValue = True
                    Me.TBBottom.Splits(0).DisplayColumns(i).Locked = False
                End If
                If Me.TBBottom.Columns(i).DataField = "zwingend" Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                    Me.TBBottom.Columns(i).DefaultValue = True
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


FrmFunktionsgruppe_Reportgruppe.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


frmRelEditor.UpdateGrpText Method

Public Sub UpdateGrpText( _
   ByVal w1 As Integer, _
   ByVal w2 As Integer, _
   ByVal w3 As Integer _
)

Parameters

w1
Required.
w2
Required.
w3
Required.

Source code

[Visual Basic]
        Public Sub UpdateGrpText(ByVal w1 As Integer, ByVal w2 As Integer, ByVal w3 As Integer)
            Me.GrpLeft.Text = Globals.MyTxt.gettext(w1)
            Me.GrpRight.Text = Globals.MyTxt.gettext(w2)
            Me.GrpBottom.Text = Globals.MyTxt.gettext(w3)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


FrmFunktionsgruppe_Reportgruppe.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmFunktionsgruppe_Reportgruppe Fields

FrmFunktionsgruppe_Reportgruppe overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

FrmFunktionsgruppe_Reportgruppe Class


BtnConnect Variable

Friend WithEvents BtnConnect As System.Windows.Forms.Button

Source code

[Visual Basic]
        Friend WithEvents BtnConnect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FokusLeft Variable

Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
        Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


FokusRight Variable

Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
        Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


GrpBottom Variable

Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
        Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


GrpFocus Variable

Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
        Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


GrpLeft Variable

Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
        Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


GrpRight Variable

Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
        Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
        Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
        Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
        Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
        Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
        Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
        Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
        Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
        Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
        Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
        Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Panel5 Variable

Friend WithEvents Panel5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
        Friend WithEvents Panel5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
        Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
        Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


TBBottom Variable

Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
        Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


TBLeft Variable

Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
        Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


TBRight Variable

Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
        Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
        Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


ToolBarBtnSave Variable

Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
        Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
        Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmFunktionsgruppe_Reportgruppe


FrmIndexMutation Class

For a list of all members of this type, see FrmIndexMutation Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmIndexMutation

Public Class FrmIndexMutation
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmIndexMutation Members


FrmIndexMutation Members

FrmIndexMutation overview

Constructors

constructor FrmIndexMutation Constructor

Properties

property Dokumentid

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method Form1_Load
method InitializeComponent
method Insert_ColdUpdate
method Insert_ColdUpdate_Datum
method Update_DokumentColdIndexwert
method Update_Partnernr
method Update_Status
method Update_datum
method Update_gf
method Update_gu
method Update_vvnr
method get_data
method get_dokumentdaten
method get_dokumente
method get_indextyp

Fields

field Button1
field Button2
field Button3
field Button4
field DateTimePicker1
field Label1
field Label2
field Label3
field Label4
field Label5
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field components
field daten
field datum
field dokumente
field gf
field gu
field m_dokumentid
field partnernr
field vvnr

See Also

FrmIndexMutation Class


FrmIndexMutation Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation Properties

FrmIndexMutation overview

Properties

property Dokumentid

See Also

FrmIndexMutation Class


FrmIndexMutation.Dokumentid Property

Property Dokumentid() As String

Source code

[Visual Basic]
    Property Dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation Methods

FrmIndexMutation overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method Form1_Load
method InitializeComponent
method Insert_ColdUpdate
method Insert_ColdUpdate_Datum
method Update_DokumentColdIndexwert
method Update_Partnernr
method Update_Status
method Update_datum
method Update_gf
method Update_gu
method Update_vvnr
method get_data
method get_dokumentdaten
method get_dokumente
method get_indextyp

See Also

FrmIndexMutation Class


FrmIndexMutation.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = True
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Cursor = Cursors.WaitCursor
            Me.TextBox1.Text = f.PartnerNr
            Me.Cursor = Cursors.Default
            MyMsg.show_standardmessage(94, MsgBoxStyle.Information)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New frmValueSelector()
        f.Text = "Auswahl VV-Nummer"
        f.Datenherkunft = "&VVdesPartners&"
        f.Datenherkunft = "&VVunformatiert&"
        f.Partnernr = Me.TextBox1.Text
        f.LoadData()
        If f.Datenvorhanden = True Then
            f.ShowDialog()
            If f.DialogResult = DialogResult.OK Then Me.TextBox4.Text = f.SelWert
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        If Me.partnernr <> Me.TextBox1.Text Then
            Update_Partnernr(Me.Dokumentid, Me.TextBox1.Text)
        End If
        If Me.vvnr <> Me.TextBox4.Text Then
            Update_vvnr(Dokumentid, Me.TextBox4.Text)
        End If
        If Me.gu <> Me.TextBox3.Text Then
            Update_gu(Dokumentid, Me.TextBox3.Text)
        End If
        If Me.gf <> Me.TextBox2.Text Then
            Update_gf(Me.Dokumentid, Me.TextBox2.Text)
        End If
        If Me.datum <> Me.DateTimePicker1.Value Then
            Update_datum(Dokumentid, Me.datum, Me.DateTimePicker1.Value)
        End If
        MyMsg.show_standardmessage(95, MsgBoxStyle.Information)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Dim s As String
        daten = get_dokumentdaten()
        dokumente = get_dokumente
        Me.TextBox1.Text = Me.partnernr
        For i = 0 To daten.Rows.Count - 1
            Select Case daten.Rows(i).Item("cold_indexfeldnr")
                Case 1
                    Me.TextBox1.Text = RTrim(daten.Rows(i).Item("wert"))
                    partnernr = Me.TextBox1.Text
                Case 3
                    Me.TextBox4.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.vvnr = Me.TextBox4.Text
                Case 5
                    s = daten.Rows(i).Item("wert")
                    If Microsoft.VisualBasic.InStr(s, ".") > 0 Then
                        datum = s
                    Else
                        datum = Microsoft.VisualBasic.Right(s, 2) + "." + Mid(s, 5, 2) + "." + Microsoft.VisualBasic.Left(s, 4)
                    End If
                    Me.DateTimePicker1.Value = datum
                Case 14
                    Me.TextBox2.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gf = Me.TextBox2.Text
                Case 12
                    Me.TextBox2.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gf = Me.TextBox2.Text
                Case 17
                    Me.TextBox3.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gu = Me.TextBox3.Text
            End Select
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmIndexMutation))
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(160, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(120, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(64, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Partner-Nr."
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(160, 64)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(120, 20)
        Me.DateTimePicker1.TabIndex = 2
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 64)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(80, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Archiv-Datum"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 88)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Geschäftsfall"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(16, 112)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(136, 23)
        Me.Label4.TabIndex = 5
        Me.Label4.Text = "Grundstück-Bezeichnung"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(160, 88)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(120, 20)
        Me.TextBox2.TabIndex = 6
        Me.TextBox2.Text = ""
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(160, 112)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(120, 20)
        Me.TextBox3.TabIndex = 7
        Me.TextBox3.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 40)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(88, 23)
        Me.Label5.TabIndex = 9
        Me.Label5.Text = "VV-Nummer"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(160, 40)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(120, 20)
        Me.TextBox4.TabIndex = 8
        Me.TextBox4.Text = ""
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(280, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 15
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(280, 40)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 16
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(280, 152)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 17
        Me.Button3.Text = "OK"
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(16, 152)
        Me.Button4.Name = "Button4"
        Me.Button4.TabIndex = 18
        Me.Button4.Text = "&Abbruch"
        '
        'FrmIndexMutation
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(360, 183)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button4, Me.Button3, Me.Button2, Me.Button1, Me.Label5, Me.TextBox4, Me.TextBox3, Me.TextBox2, Me.Label4, Me.Label3, Me.Label2, Me.DateTimePicker1, Me.Label1, Me.TextBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "FrmIndexMutation"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Indexmutation"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Insert_ColdUpdate Method

Public Function Insert_ColdUpdate( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal indextyp As Integer, _
   ByVal feldnr As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
indextyp
Required.
feldnr
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Insert_ColdUpdate(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal indextyp As Integer, ByVal feldnr As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_insert_coldupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@feldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, feldnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Insert_ColdUpdate_Datum Method

Public Function Insert_ColdUpdate_Datum( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal alterwert As String, _
   ByVal neuerwert As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
alterwert
Required.
neuerwert
Required.

Source code

[Visual Basic]
    Public Function Insert_ColdUpdate_Datum(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal alterwert As String, ByVal neuerwert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_insert_datumupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@alterwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alterwert))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, neuerwert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_DokumentColdIndexwert Method

Public Function Update_DokumentColdIndexwert( _
   ByVal dokumentid As String, _
   ByVal Indextyp As Integer, _
   ByVal indexfeld As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
Indextyp
Required.
indexfeld
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Update_DokumentColdIndexwert(ByVal dokumentid As String, ByVal Indextyp As Integer, ByVal indexfeld As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_Update_DokumentColdIndexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexfeld))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@wert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_Partnernr Method

Public Sub Update_Partnernr( _
   ByVal dokumentid As String, _
   ByVal partnernr As String _
)

Parameters

dokumentid
Required.
partnernr
Required.

Source code

[Visual Basic]
    Public Sub Update_Partnernr(ByVal dokumentid As String, ByVal partnernr As String)
        Dim d As New edokadb.clsDokument()
        Dim kurzname As String
        Dim ort As String
        d.cpMainConnectionProvider = Globals.conn
        d.sDokumentid = New SqlString(CType(dokumentid, String))
        d.SelectOne()
        d.iNrpar00 = New SqlInt32(CType(partnernr, Int32))
        conn.OpenConnection()
        d.Update()
        conn.CloseConnection(True)
        d.Dispose()
        kurzname = get_data("&PartnerKurzname&")
        ort = get_data("&PartnerInhaberOrt&")
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 1, partnernr)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 1, Me.TextBox1.Text)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 8, ort)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 8, ort)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_Status Method

Public Sub Update_Status( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal indextyp As Integer, _
   ByVal status As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
indextyp
Required.
status
Required.

Source code

[Visual Basic]
    Public Sub Update_Status(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal indextyp As Integer, ByVal status As String)
        Dim ityp As Integer
        If indextyp = 0 Then
            ityp = get_indextyp(dokumentid, colddokumentid)
        Else
            ityp = indextyp
        End If
        Insert_ColdUpdate(dokumentid, colddokumentid, ityp, 7, status)
        Update_DokumentColdIndexwert(dokumentid, ityp, 7, status)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_datum Method

Public Sub Update_datum( _
   ByVal dokumentid As String, _
   ByVal datuma As DateTime, _
   ByVal datum As DateTime _
)

Parameters

dokumentid
Required.
datuma
Required.
datum
Required.

Source code

[Visual Basic]
    Public Sub Update_datum(ByVal dokumentid As String, ByVal datuma As DateTime, ByVal datum As DateTime)
        Dim i As Integer
        Dim alterwert As String
        Dim neuerwert As String
        Dim s As String
        alterwert = LTrim(Str(Year(datuma)))
        s = LTrim(Str(Month(datuma)))
        While Len(s) < 2
            s = "0" + s
        End While
        alterwert = alterwert + s
        s = LTrim(Str(Microsoft.VisualBasic.Day(datuma)))
        While Len(s) < 2
            s = "0" + s
        End While
        alterwert = alterwert + s

        neuerwert = LTrim(Str(Year(datum)))
        s = LTrim(Str(Month(datum)))
        While Len(s) < 2
            s = "0" + s
        End While
        neuerwert = neuerwert + s
        s = LTrim(Str(Microsoft.VisualBasic.Day(datum)))
        While Len(s) < 2
            s = "0" + s
        End While
        neuerwert = neuerwert + s
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate_Datum(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), alterwert, neuerwert)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 5, neuerwert)
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_gf Method

Public Sub Update_gf( _
   ByVal dokumentid As String, _
   ByVal gf As String _
)

Parameters

dokumentid
Required.
gf
Required.

Source code

[Visual Basic]
    Public Sub Update_gf(ByVal dokumentid As String, ByVal gf As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 14, gf)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 14, gf)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 12, gf)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_gu Method

Public Sub Update_gu( _
   ByVal dokumentid As String, _
   ByVal gu As String _
)

Parameters

dokumentid
Required.
gu
Required.

Source code

[Visual Basic]
    Public Sub Update_gu(ByVal dokumentid As String, ByVal gu As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 17, gu)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 17, gu)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.Update_vvnr Method

Public Sub Update_vvnr( _
   ByVal dokumentid As String, _
   ByVal vvnr As String _
)

Parameters

dokumentid
Required.
vvnr
Required.

Source code

[Visual Basic]
    Public Sub Update_vvnr(ByVal dokumentid As String, ByVal vvnr As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 3, vvnr)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 3, vvnr)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.get_data Method

Private Function get_data( _
   ByVal datenherkunft As String _
) As String

Parameters

datenherkunft
Required.

Source code

[Visual Basic]
    Private Function get_data(ByVal datenherkunft As String) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentwerte_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, datenherkunft))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@value").Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.get_dokumentdaten Method

Private Function get_dokumentdaten() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumentdaten() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getdokinfo"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.get_dokumente Method

Private Function get_dokumente() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumente() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getdokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation.get_indextyp Method

Private Function get_indextyp( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String _
) As Integer

Parameters

dokumentid
Required.
colddokumentid
Required.

Source code

[Visual Basic]
    Private Function get_indextyp(ByVal dokumentid As String, ByVal colddokumentid As String) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getindextyp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@indextyp").Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmIndexMutation Fields

FrmIndexMutation overview

Fields

field Button1
field Button2
field Button3
field Button4
field DateTimePicker1
field Label1
field Label2
field Label3
field Label4
field Label5
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field components
field daten
field datum
field dokumente
field gf
field gu
field m_dokumentid
field partnernr
field vvnr

See Also

FrmIndexMutation Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


daten Variable

Dim daten As New DataTable()

Source code

[Visual Basic]
    Dim daten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


datum Variable

Dim datum As DateTime

Source code

[Visual Basic]
    Dim datum As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


dokumente Variable

Dim dokumente As New DataTable()

Source code

[Visual Basic]
    Dim dokumente As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


gf Variable

Dim gf As String

Source code

[Visual Basic]
    Dim gf As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


gu Variable

Dim gu As String

Source code

[Visual Basic]
    Dim gu As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


partnernr Variable

Dim partnernr As String

Source code

[Visual Basic]
    Dim partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


vvnr Variable

Dim vvnr As String

Source code

[Visual Basic]
    Dim vvnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmIndexMutation


FrmPartnersuche Class

For a list of all members of this type, see FrmPartnersuche Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmPartnersuche

Public Class FrmPartnersuche
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmPartnersuche Members


FrmPartnersuche Members

FrmPartnersuche overview

Constructors

constructor FrmPartnersuche Constructor

Properties

property Anrede
property AusPartnererfassung
property Dokumenterstellen
property Dokumenttypnrnr
property Meldung_Doppelter_Partner
property NoClose
property NurAbfrage
property PartnerKurzbezeichnnung
property PartnerNr
property VIBeachten
property profilnr
property zustelladresse

Methods

method BUtton3_Click
method BtnHelp_Click
method Buton1_Click
method Button2_Click
method Button4_Click
method Button5_Click
method Button6_Click
method CheckBox1_CheckedChanged
method ContextMenu1_Popup
method Dispose
method Doppelte_Partner
method FrmPartnersuche_Closing
method FrmPartnersuche_Load
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method PartnerList_DoubleClick
method PartnerList_FetchRowStyle
method PartnerList_KeyDown
method Partner_Suche
method SpaltenTitel_Aktualisieren
method TextBox1_KeyDown
method Timer1_Tick

Events

event partner_selected

Fields

field BUtton3
field BtnHelp
field Button1
field Button2
field Button4
field Button5
field Button6
field CheckBox1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field Partner
field PartnerList
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field Timer1
field components
field m_PartnerKurzbezeichnung
field m_anrede
field m_dokumenterstellen
field m_dokumenttypnr
field m_erfassung
field m_meldung_doppelter_partner
field m_noclose
field m_partnernr
field m_profilnr
field m_retrieval
field m_vibeachten
field m_zustelladresse
field mypartner

See Also

FrmPartnersuche Class


FrmPartnersuche Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche Properties

FrmPartnersuche overview

Properties

property Anrede
property AusPartnererfassung
property Dokumenterstellen
property Dokumenttypnrnr
property Meldung_Doppelter_Partner
property NoClose
property NurAbfrage
property PartnerKurzbezeichnnung
property PartnerNr
property VIBeachten
property profilnr
property zustelladresse

See Also

FrmPartnersuche Class


FrmPartnersuche.Anrede Property

Property Anrede() As String

Source code

[Visual Basic]
    Property Anrede() As String
        Get
            Return m_anrede
        End Get
        Set(ByVal Value As String)
            m_anrede = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.AusPartnererfassung Property

Property AusPartnererfassung() As Boolean

Source code

[Visual Basic]
    Property AusPartnererfassung() As Boolean
        Get
            Return m_erfassung
        End Get
        Set(ByVal Value As Boolean)
            m_erfassung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Dokumenterstellen Property

Property Dokumenterstellen() As Boolean

Source code

[Visual Basic]
    Property Dokumenterstellen() As Boolean
        Get
            Return m_dokumenterstellen
        End Get
        Set(ByVal Value As Boolean)
            m_dokumenterstellen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Dokumenttypnrnr Property

Property Dokumenttypnrnr() As Integer

Source code

[Visual Basic]
    Property Dokumenttypnrnr() As Integer
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Meldung_Doppelter_Partner Property

Property Meldung_Doppelter_Partner() As Boolean

Source code

[Visual Basic]
    Property Meldung_Doppelter_Partner() As Boolean
        Get
            Return m_meldung_doppelter_partner
        End Get
        Set(ByVal Value As Boolean)
            m_meldung_doppelter_partner = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.NoClose Property

Property NoClose() As Boolean

Source code

[Visual Basic]
    Property NoClose() As Boolean
        Get
            Return m_noclose
        End Get
        Set(ByVal Value As Boolean)
            m_noclose = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.NurAbfrage Property

Property NurAbfrage() As Boolean

Source code

[Visual Basic]
    Property NurAbfrage() As Boolean
        Get
            Return m_retrieval
        End Get
        Set(ByVal Value As Boolean)
            m_retrieval = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.PartnerKurzbezeichnnung Property

Property PartnerKurzbezeichnnung() As String

Source code

[Visual Basic]
    Property PartnerKurzbezeichnnung() As String
        Get
            Return m_PartnerKurzbezeichnung
        End Get
        Set(ByVal Value As String)
            m_PartnerKurzbezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.PartnerNr Property

Property PartnerNr() As Long

Source code

[Visual Basic]
    Property PartnerNr() As Long
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Long)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.VIBeachten Property

Property VIBeachten() As Boolean

Source code

[Visual Basic]
    Property VIBeachten() As Boolean
        Get
            Return m_vibeachten
        End Get
        Set(ByVal Value As Boolean)
            m_vibeachten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.profilnr Property

Property profilnr() As Integer

Source code

[Visual Basic]
    Property profilnr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.zustelladresse Property

Property zustelladresse() As String

Source code

[Visual Basic]
    Property zustelladresse() As String
        Get
            Return m_zustelladresse
        End Get
        Set(ByVal Value As String)
            m_zustelladresse = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche Methods

FrmPartnersuche overview

Methods

method BUtton3_Click
method BtnHelp_Click
method Buton1_Click
method Button2_Click
method Button4_Click
method Button5_Click
method Button6_Click
method CheckBox1_CheckedChanged
method ContextMenu1_Popup
method Dispose
method Doppelte_Partner
method FrmPartnersuche_Closing
method FrmPartnersuche_Load
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method PartnerList_DoubleClick
method PartnerList_FetchRowStyle
method PartnerList_KeyDown
method Partner_Suche
method SpaltenTitel_Aktualisieren
method TextBox1_KeyDown
method Timer1_Tick

See Also

FrmPartnersuche Class


FrmPartnersuche.BUtton3_Click Method

Private Sub BUtton3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BUtton3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BUtton3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BUtton3.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("partnersuche")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Buton1_Click Method

Private Sub Buton1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Buton1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.PartnerList.DataSource = Nothing
        Me.PartnerList.DataMember = Nothing
        Dim iii As Double
        If Me.TextBox1.Text <> "" Then
            Try
                Dim d As Double
                d = Val(Me.TextBox1.Text)
                If d = 0 Then
                    MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                    Me.TextBox1.Focus()
                    Exit Sub
                End If
                Me.Cursor = Cursors.WaitCursor
                Partner = mypartner.search_partner(d, Me.TextBox4.Text, 0)
                Me.Cursor = Cursors.Default
            Catch
                MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                Me.TextBox1.Focus()
                Exit Sub
            End Try
        Else
            If Me.TextBox2.Text <> "" Then
                Me.Cursor = Cursors.WaitCursor
                Partner = mypartner.search_partner(Me.TextBox2.Text, Me.TextBox4.Text, 1)
                Me.Cursor = Cursors.Default
            Else
                If Me.TextBox3.Text <> "" Then
                    Me.Cursor = Cursors.WaitCursor
                    Partner = mypartner.search_partner(Me.TextBox3.Text, Me.TextBox4.Text, 2)
                    Me.Cursor = Cursors.Default
                Else
                    Me.Cursor = Cursors.WaitCursor
                    Partner = mypartner.search_partner(Me.TextBox5.Text, Me.TextBox4.Text, 3)
                    Me.Cursor = Cursors.Default
                End If
            End If
        End If
        If Partner.Rows.Count = 0 Then
            MyMsg.show_standardmessage(204, MsgBoxStyle.Exclamation)
        Else
            Globals.Save_Partnersuche = Partner
            Me.PartnerList.DataSource = Partner
            Me.PartnerList.DataMember = "Partner"
            SpaltenTitel_Aktualisieren()
            Dim i As Long
            Dim ii As Long
            If Me.PartnerList.Splits(0).Rows.Count = 1 And Me.CheckBox1.Checked <> True Then
                If Me.NoClose Then
                    Me.Timer1.Enabled = True
                    Me.Label7.Visible = True
                End If
                Button2_Click(sender, e)
            End If
            End If
        If Me.PartnerList.Splits(0).Rows.Count > 0 Then
            Me.Button2.Enabled = True
            Me.PartnerList.Focus()
        Else
            Me.Button2.Enabled = False
            Me.TextBox1.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Partner_Suche(Me.PartnerList.Columns(0).Value)
        If Me.NoClose Then
            RaiseEvent partner_selected()
            Me.Timer1.Enabled = True
            Me.Label7.Visible = True
            Exit Sub
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Dim f As New frmInteressent()
        f.Profilnr = Me.profilnr
        f.Display = False
        Try
            f.Partnernr = 0
            f.ShowDialog()
        Catch
            f.Partnernr = 0
            f.ShowDialog()
        Finally
            Me.TextBox1.Text = f.Partnernr
            f.Dispose()
            Buton1_Click(sender, e)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Dim nrpar00 As Integer
        Dim host As New frmHostTransfer()
        If Me.TextBox1.Text <> "" Then
            Try
                Dim d As Double
                d = Val(Me.TextBox1.Text)
                If d = 0 Then
                    MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                    Me.TextBox1.Focus()
                    Exit Sub
                End If
                host.Nrpar00 = d
                Me.Hide()
                host.ShowDialog()
                If host.DialogResult = DialogResult.Abort Then
                    Me.Show()
                Else
                    Me.TextBox1.Text = host.Nrpar00
                    Me.Buton1_Click(sender, e)
                    Me.Show()
                End If
                host.Dispose()
            Catch
                MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                Me.TextBox1.Focus()
            End Try
        Else
            MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
            Me.TextBox1.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Button6_Click Method

Private Sub Button6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button6.Click
        Dim f As New frmPartnersucheInfo()
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.CheckBox1_CheckedChanged Method

Private Sub CheckBox1_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles CheckBox1.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckBox1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles CheckBox1.CheckedChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try
            If Me.PartnerList.Columns(0).Value < 91000000 Then
                Me.MenuItem3.Visible = False
                Me.MenuItem4.Visible = False
            Else
                Me.MenuItem3.Visible = True
                Me.MenuItem4.Visible = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Doppelte_Partner Method

Public Sub Doppelte_Partner( _
   ByVal name As String, _
   ByVal ort As String _
)

Parameters

name
Required.
ort
Required.

Source code

[Visual Basic]
    Public Sub Doppelte_Partner(ByVal name As String, ByVal ort As String)
        Partner = mypartner.search_doppelte_partner(name, ort, 4)
        If Partner.Rows.Count = 0 Then
            MyMsg.show_standardmessage(204, MsgBoxStyle.Exclamation)
        Else
            Me.PartnerList.DataSource = Partner
            Me.PartnerList.DataMember = "Partner"
            SpaltenTitel_Aktualisieren()
            If Meldung_Doppelter_Partner Then MyMsg.show_standardmessage(25, MsgBoxStyle.Information)
            Me.Meldung_Doppelter_Partner = False
            Dim i As Long
            Dim ii As Long
        End If
        If Me.PartnerList.Splits(0).Rows.Count > 0 Then
            Me.Button2.Enabled = True
            Me.PartnerList.Focus()
        Else
            Me.Button2.Enabled = False
            Me.TextBox1.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.FrmPartnersuche_Closing Method

Private Sub FrmPartnersuche_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmPartnersuche_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Me.NoClose = True Then
            e.Cancel = True
            Me.Hide()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.FrmPartnersuche_Load Method

Private Sub FrmPartnersuche_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmPartnersuche_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Me.NurAbfrage Then
            Me.Button4.Visible = False
            Me.Button5.Visible = False
        Else
            Me.Button4.Visible = True
            Me.Button5.Visible = True
            If DivFnkt.EDOKA_Partner_Berechtigt = False Then Me.Button4.Enabled = False Else Me.Button4.Enabled = True
            If DivFnkt.EDOKA_Partner_Dokument(3, Me.Dokumenttypnrnr) = True Then Me.Button4.Enabled = True Else Me.Button4.Enabled = False
        End If
        Me.TextBox1.Focus()
        Me.TextBox1.Select()
        If Globals.Save_Partnersuche.Rows.Count > 0 And Not Me.AusPartnererfassung Then
            Me.PartnerList.DataSource = Globals.Save_Partnersuche
            Me.PartnerList.DataMember = Globals.Save_Partnersuche.TableName
            Me.Button2.Enabled = True
            SpaltenTitel_Aktualisieren()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmPartnersuche))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.BUtton3 = New System.Windows.Forms.Button()
        Me.PartnerList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.Label8 = New System.Windows.Forms.Label()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(96, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(176, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Partner-Nr."
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Kurzname"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(96, 40)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(176, 20)
        Me.TextBox2.TabIndex = 2
        Me.TextBox2.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 5
        Me.Label3.Text = "Freitext"
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(96, 64)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(176, 20)
        Me.TextBox3.TabIndex = 4
        Me.TextBox3.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(424, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(80, 40)
        Me.Label4.TabIndex = 7
        Me.Label4.Text = "Maximale Anzahl Treffer"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(520, 16)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.Size = New System.Drawing.Size(64, 20)
        Me.TextBox4.TabIndex = 6
        Me.TextBox4.Text = "50"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.Button1.Location = New System.Drawing.Point(280, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(88, 24)
        Me.Button1.TabIndex = 9
        Me.Button1.Text = "&Suchen"
        Me.Button1.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Button2
        '
        Me.Button2.Enabled = False
        Me.Button2.Location = New System.Drawing.Point(496, 336)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(88, 23)
        Me.Button2.TabIndex = 11
        Me.Button2.Text = "Übernehmen"
        '
        'BUtton3
        '
        Me.BUtton3.Location = New System.Drawing.Point(48, 336)
        Me.BUtton3.Name = "BUtton3"
        Me.BUtton3.Size = New System.Drawing.Size(80, 24)
        Me.BUtton3.TabIndex = 10
        Me.BUtton3.Text = "Schliessen"
        '
        'PartnerList
        '
        Me.PartnerList.AllowFilter = True
        Me.PartnerList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.PartnerList.AllowSort = True
        Me.PartnerList.AllowUpdate = False
        Me.PartnerList.AllowUpdateOnBlur = False
        Me.PartnerList.AlternatingRows = True
        Me.PartnerList.CaptionHeight = 17
        Me.PartnerList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.PartnerList.CollapseColor = System.Drawing.Color.Black
        Me.PartnerList.ContextMenu = Me.ContextMenu1
        Me.PartnerList.DataChanged = False
        Me.PartnerList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.PartnerList.ExpandColor = System.Drawing.Color.Black
        Me.PartnerList.FetchRowStyles = True
        Me.PartnerList.FilterBar = True
        Me.PartnerList.GroupByCaption = "Drag a column header here to group by that column"
        Me.PartnerList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.PartnerList.Location = New System.Drawing.Point(16, 112)
        Me.PartnerList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.PartnerList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.PartnerList.Name = "PartnerList"
        Me.PartnerList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.PartnerList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.PartnerList.PreviewInfo.ZoomFactor = 75
        Me.PartnerList.PrintInfo.ShowOptionsDialog = False
        Me.PartnerList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.PartnerList.RowDivider = GridLines1
        Me.PartnerList.RowHeight = 15
        Me.PartnerList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.PartnerList.ScrollTips = True
        Me.PartnerList.Size = New System.Drawing.Size(568, 216)
        Me.PartnerList.TabIndex = 13
        Me.PartnerList.Text = "C1TrueDBGrid1"
        Me.PartnerList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellB" & _
        "order"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" Hori" & _
        "zontalScrollGroup=""1""><ClientRect>0, 0, 564, 212</ClientRect><BorderSide>0</Bord" & _
        "erSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor""" & _
        " me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle pare" & _
        "nt=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupS" & _
        "tyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" />" & _
        "<HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""In" & _
        "active"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelector" & _
        "Style parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me" & _
        "=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView" & _
        "></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=" & _
        """Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Ca" & _
        "ption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Sele" & _
        "cted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highligh" & _
        "tRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow""" & _
        " /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filt" & _
        "erBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertS" & _
        "plits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Def" & _
        "aultRecSelWidth><ClientArea>0, 0, 564, 212</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Partner übernehmen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Detailinformationen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "Partner erfassen / bearbeiten"
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(280, 40)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(88, 24)
        Me.Button4.TabIndex = 14
        Me.Button4.Text = "Neuer Partner"
        '
        'Button5
        '
        Me.Button5.Location = New System.Drawing.Point(280, 64)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(88, 24)
        Me.Button5.TabIndex = 15
        Me.Button5.Text = "HOST-Partner"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 88)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(72, 23)
        Me.Label5.TabIndex = 17
        Me.Label5.Text = "VV-Suche"
        '
        'TextBox5
        '
        Me.TextBox5.Location = New System.Drawing.Point(96, 88)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.Size = New System.Drawing.Size(176, 20)
        Me.TextBox5.TabIndex = 16
        Me.TextBox5.Text = ""
        '
        'CheckBox1
        '
        Me.CheckBox1.CheckAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.CheckBox1.Location = New System.Drawing.Point(568, 56)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(16, 16)
        Me.CheckBox1.TabIndex = 18
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(424, 56)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(152, 32)
        Me.Label6.TabIndex = 19
        Me.Label6.Text = "Trefferliste immer anzeigen"
        '
        'Button6
        '
        Me.Button6.Image = CType(resources.GetObject("Button6.Image"), System.Drawing.Bitmap)
        Me.Button6.Location = New System.Drawing.Point(368, 16)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(24, 24)
        Me.Button6.TabIndex = 20
        '
        'Label7
        '
        Me.Label7.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label7.ForeColor = System.Drawing.Color.Red
        Me.Label7.Location = New System.Drawing.Point(136, 336)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(344, 32)
        Me.Label7.TabIndex = 21
        Me.Label7.Text = "Partner wurde direkt übernommen"
        Me.Label7.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.Label7.Visible = False
        '
        'Timer1
        '
        Me.Timer1.Interval = 2000
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(408, 72)
        Me.Label8.Name = "Label8"
        Me.Label8.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.Label8.Size = New System.Drawing.Size(184, 16)
        Me.Label8.TabIndex = 22
        Me.Label8.Text = "(z.B. für EDOKA-Partner-Mutation)"
        Me.Label8.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(16, 336)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 61
        '
        'FrmPartnersuche
        '
        Me.AcceptButton = Me.Button1
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 373)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.Label8, Me.Label7, Me.Button6, Me.CheckBox1, Me.Label5, Me.TextBox5, Me.Button5, Me.Button4, Me.PartnerList, Me.BUtton3, Me.Button2, Me.Button1, Me.Label4, Me.TextBox4, Me.Label3, Me.TextBox3, Me.Label2, Me.TextBox2, Me.Label1, Me.TextBox1, Me.Label6})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "FrmPartnersuche"
        Me.ShowInTaskbar = False
        Me.Text = "Partnersuche"
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Button2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Try
            If Me.PartnerList.Columns(0).Value > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim f As New frmInteressent()
        f.Display = False
        Try
            If Me.PartnerList.Columns(0).Value > 91000000 Then
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.ShowDialog()
            Else
                f.Partnernr = 0
                f.ShowDialog()
            End If
        Catch
            f.Partnernr = 0
            f.ShowDialog()
        Finally
            Me.TextBox1.Text = f.Partnernr
            f.Dispose()
            Buton1_Click(sender, e)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.PartnerList_DoubleClick Method

Private Sub PartnerList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles PartnerList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles PartnerList.DoubleClick
        Button2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.PartnerList_FetchRowStyle Method

Private Sub PartnerList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles PartnerList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles PartnerList.FetchRowStyle
        If Microsoft.VisualBasic.Left(Me.PartnerList.Columns(0).CellValue(e.Row), 1) = "9" Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.PartnerList_KeyDown Method

Private Sub PartnerList_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles PartnerList.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles PartnerList.KeyDown
        If e.KeyCode = Keys.Enter Then
            If Me.PartnerList.Splits(0).Rows.Count > 0 Then
                Try
                    Partner_Suche(Me.PartnerList.Columns(0).Value)
                Catch
                End Try
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Partner_Suche Method

Public Sub Partner_Suche( _
   ByVal nrpar00 As String _
)

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Public Sub Partner_Suche(ByVal nrpar00 As String)
        Dim p As New edokadb.clsPartner()
        Dim ph As New edokadb.clsPartner_Hauptadresse()
        p.sConnectionString = Globals.sConnectionString
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        ph.sConnectionString = Globals.sConnectionString
        ph.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        ph.SelectOne()

        Dim s As String
        s = ""
        Try
            If p.sCDVIG00.Value = "Y" Or p.iAZEPL00.Value > 1 Or p.bCDVSA00.Value = True Then Me.VIBeachten = True Else Me.VIBeachten = False
            If p.sTXADZ011.Value <> "" Then s = s + p.sTXADZ011.Value + vbCrLf
            If p.sTXADZ021.Value <> "" Then s = s + p.sTXADZ021.Value + vbCrLf
            If p.sTXADZ031.Value <> "" Then s = s + p.sTXADZ031.Value + vbCrLf
            If p.sTXADZ041.Value <> "" Then s = s + p.sTXADZ041.Value + vbCrLf
            If p.sTXADZ051.Value <> "" Then s = s + p.sTXADZ051.Value + vbCrLf
            If p.sTXADZ061.Value <> "" Then s = s + p.sTXADZ061.Value + vbCrLf
            If p.sTXADZ071.Value <> "" Then s = s + p.sTXADZ071.Value + vbCrLf
            Me.zustelladresse = s
            If p.iNRPAR00.Value > 91000000 Then
                Me.Anrede = p.sBEBAN011.Value
            Else
                Me.Anrede = ph.sBEBAN01.Value
            End If
            Me.PartnerNr = nrpar00
            Me.PartnerKurzbezeichnnung = p.sBKPAR00.Value
            If Me.NoClose = True Then
                Exit Sub
            End If
            Try
                Me.Partner.Dispose()
            Catch
            End Try
            Try
                Me.Close()
            Catch
            End Try
            Me.mypartner = Nothing
        Catch ex As Exception
            '            MsgBox(ex.Message)
        Finally
            Try
                p.Dispose()
                ph.Dispose()
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        t = Partner
        ts.Tabelle = "Partner"
        For i = 0 To Me.PartnerList.Columns.Count - 1
            s = Me.PartnerList.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.PartnerList.Columns(i).Caption = ts.spaltenname
            If Me.PartnerList.Columns(i).Caption = "" Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            '            If Me.PartnerList.Columns(i).Caption = "" Then Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            If ts.locked Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.PartnerList.Columns(i).DataField = "aktiv" Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.PartnerList.Columns(i).ValueItems.DefaultItem = True
                Me.PartnerList.Columns(i).DefaultValue = True
                Me.PartnerList.Columns(i).FilterText = True
            End If
            If Me.PartnerList.Columns(i).DataField = "erstellt_am" Then
                Me.PartnerList.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox1.KeyDown, _
   TextBox2.KeyDown, _
   TextBox3.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox1.KeyDown, TextBox2.KeyDown, TextBox3.KeyDown
        If e.KeyCode = Keys.Return Then Buton1_Click(sender, e)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche.Timer1_Tick Method

Private Sub Timer1_Tick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Timer1.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Timer1.Tick
        Me.Label7.Visible = False
        Me.Timer1.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche Events

FrmPartnersuche overview

Events

event partner_selected

See Also

FrmPartnersuche Class


partner_selected Event

Public Event partner_selected()

Source code

[Visual Basic]
    Public Event partner_selected()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPartnersuche Fields

FrmPartnersuche overview

Fields

field BUtton3
field BtnHelp
field Button1
field Button2
field Button4
field Button5
field Button6
field CheckBox1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field Partner
field PartnerList
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field Timer1
field components
field m_PartnerKurzbezeichnung
field m_anrede
field m_dokumenterstellen
field m_dokumenttypnr
field m_erfassung
field m_meldung_doppelter_partner
field m_noclose
field m_partnernr
field m_profilnr
field m_retrieval
field m_vibeachten
field m_zustelladresse
field mypartner

See Also

FrmPartnersuche Class


BUtton3 Variable

Friend WithEvents BUtton3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BUtton3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Partner Variable

Dim Partner As DataTable

Source code

[Visual Basic]
    Dim Partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


PartnerList Variable

Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


Timer1 Variable

Friend WithEvents Timer1 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_PartnerKurzbezeichnung Variable

Dim m_PartnerKurzbezeichnung As String

Source code

[Visual Basic]
    Dim m_PartnerKurzbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_anrede Variable

Dim m_anrede As String

Source code

[Visual Basic]
    Dim m_anrede As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_dokumenterstellen Variable

Dim m_dokumenterstellen As Boolean = False

Source code

[Visual Basic]
    Dim m_dokumenterstellen As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Integer = 0

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_erfassung Variable

Dim m_erfassung As Boolean = False

Source code

[Visual Basic]
    Dim m_erfassung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_meldung_doppelter_partner Variable

Dim m_meldung_doppelter_partner As Boolean = False

Source code

[Visual Basic]
    Dim m_meldung_doppelter_partner As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_noclose Variable

Dim m_noclose As Boolean = False

Source code

[Visual Basic]
    Dim m_noclose As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_partnernr Variable

Dim m_partnernr As Long

Source code

[Visual Basic]
    Dim m_partnernr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_retrieval Variable

Dim m_retrieval As Boolean

Source code

[Visual Basic]
    Dim m_retrieval As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_vibeachten Variable

Dim m_vibeachten As Boolean

Source code

[Visual Basic]
    Dim m_vibeachten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


m_zustelladresse Variable

Dim m_zustelladresse As String

Source code

[Visual Basic]
    Dim m_zustelladresse As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


mypartner Variable

Dim mypartner As New edokadb.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokadb.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPartnersuche


FrmPasswortWechsel Class

For a list of all members of this type, see FrmPasswortWechsel Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmPasswortWechsel

Public Class FrmPasswortWechsel
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmPasswortWechsel Members


FrmPasswortWechsel Members

FrmPasswortWechsel overview

Constructors

constructor FrmPasswortWechsel Constructor

Properties

property Passwort

Methods

method Dispose
method FrmPasswortWechsel_Load
method InitializeComponent
method btnAbbruch_Click
method btnOK_Click

Fields

field Label1
field Label2
field Label3
field TextBox1
field TextBox2
field TextBox3
field btnAbbruch
field btnOK
field components
field m_passwort

See Also

FrmPasswortWechsel Class


FrmPasswortWechsel Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel Properties

FrmPasswortWechsel overview

Properties

property Passwort

See Also

FrmPasswortWechsel Class


FrmPasswortWechsel.Passwort Property

Property Passwort() As String

Source code

[Visual Basic]
    Property Passwort() As String
        Get
            Return m_passwort
        End Get
        Set(ByVal Value As String)
            m_passwort = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel Methods

FrmPasswortWechsel overview

Methods

method Dispose
method FrmPasswortWechsel_Load
method InitializeComponent
method btnAbbruch_Click
method btnOK_Click

See Also

FrmPasswortWechsel Class


FrmPasswortWechsel.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel.FrmPasswortWechsel_Load Method

Private Sub FrmPasswortWechsel_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmPasswortWechsel_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TextBox1.Text = ""
        Me.TextBox2.Text = ""
        Me.TextBox3.Text = ""
        Me.TextBox1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmPasswortWechsel))
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnOK = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(112, 24)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.PasswordChar = Microsoft.VisualBasic.ChrW(42)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "TextBox1"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(112, 56)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.PasswordChar = Microsoft.VisualBasic.ChrW(42)
        Me.TextBox2.TabIndex = 1
        Me.TextBox2.Text = "TextBox2"
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(112, 88)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.PasswordChar = Microsoft.VisualBasic.ChrW(42)
        Me.TextBox3.TabIndex = 2
        Me.TextBox3.Text = "TextBox3"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 3
        Me.Label1.Text = "Altes Kennwort"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 56)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Neues Kennwort"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 88)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(100, 32)
        Me.Label3.TabIndex = 5
        Me.Label3.Text = "Kennwort-Bestätigung"
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(8, 136)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 6
        Me.btnAbbruch.Text = "&Abbruch"
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(136, 136)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.TabIndex = 7
        Me.btnOK.Text = "&OK"
        '
        'FrmPasswortWechsel
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(224, 165)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnOK, Me.btnAbbruch, Me.Label3, Me.Label2, Me.Label1, Me.TextBox3, Me.TextBox2, Me.TextBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "FrmPasswortWechsel"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "FrmPasswortWechsel"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel.btnOK_Click Method

Private Sub btnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOK.Click
        If Me.TextBox1.Text <> Me.Passwort Then
            MsgBox("Das alte Kennwort ist nicht korrekt.", MsgBoxStyle.Critical)
            Me.TextBox1.Text = ""
            Me.TextBox1.Focus()
            Exit Sub
        End If
        If Me.TextBox2.Text <> Me.TextBox3.Text Then
            MsgBox("Das neue Kennwort und die Kennwortbestätigung stimmen nicht überein.", MsgBoxStyle.Critical)
            Me.TextBox1.Text = ""
            Me.TextBox2.Text = ""
            Me.TextBox3.Text = ""
            Me.TextBox1.Focus()
            Exit Sub
        End If
        If Me.TextBox2.Text.Length < 4 Then
            MsgBox("Das neue Kennwort muss mind. 4 Zeichen lang sein.", MsgBoxStyle.Critical)
            Me.TextBox1.Text = ""
            Me.TextBox2.Text = ""
            Me.TextBox3.Text = ""
            Me.TextBox1.Focus()
            Exit Sub
        End If
        Me.DialogResult = DialogResult.OK
        Me.Passwort = Me.TextBox2.Text
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmPasswortWechsel Fields

FrmPasswortWechsel overview

Fields

field Label1
field Label2
field Label3
field TextBox1
field TextBox2
field TextBox3
field btnAbbruch
field btnOK
field components
field m_passwort

See Also

FrmPasswortWechsel Class


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


btnOK Variable

Friend WithEvents btnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


m_passwort Variable

Dim m_passwort As String

Source code

[Visual Basic]
    Dim m_passwort As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmPasswortWechsel


FrmRestore Class

For a list of all members of this type, see FrmRestore Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmRestore

Public Class FrmRestore
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmRestore Members


FrmRestore Members

FrmRestore overview

Constructors

constructor FrmRestore Constructor

Properties

property DokumentID
property NeuesDokument
property SaveDocument

Methods

method Button1_Click
method Dispose
method FrmRestore_Load
method InitializeComponent
method Restore_Dokument

Fields

field Button1
field DataSet1
field Label1
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field m_create
field m_dokumentid

See Also

FrmRestore Class


FrmRestore Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore Properties

FrmRestore overview

Properties

property DokumentID
property NeuesDokument
property SaveDocument

See Also

FrmRestore Class


FrmRestore.DokumentID Property

Property DokumentID() As String

Source code

[Visual Basic]
    Property DokumentID() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore.NeuesDokument Property

Property NeuesDokument() As Boolean

Source code

[Visual Basic]
    Property NeuesDokument() As Boolean
        Get
            Return m_create
        End Get
        Set(ByVal Value As Boolean)
            m_create = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SaveDocument Property

Public SaveDocument As New DataTable()

Source code

[Visual Basic]
    Public SaveDocument As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore Methods

FrmRestore overview

Methods

method Button1_Click
method Dispose
method FrmRestore_Load
method InitializeComponent
method Restore_Dokument

See Also

FrmRestore Class


FrmRestore.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore.FrmRestore_Load Method

Private Sub FrmRestore_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmRestore_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Button1 = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(24, 32)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(432, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Bitte warten Sie, bis die Änderungen auf der Datenbank rückgängig gemacht wurden." & _
        ""
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokument", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumentid", "dokumentid"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("mitarbeiternr1", "mitarbeiternr1"), New System.Data.Common.DataColumnMapping("nrpar00", "nrpar00"), New System.Data.Common.DataColumnMapping("dokumentidn", "dokumentidn"), New System.Data.Common.DataColumnMapping("dokumentname", "dokumentname"), New System.Data.Common.DataColumnMapping("ersteller", "ersteller"), New System.Data.Common.DataColumnMapping("erstellerteam", "erstellerteam"), New System.Data.Common.DataColumnMapping("erstelltam", "erstelltam"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mutierertieam", "mutierertieam"), New System.Data.Common.DataColumnMapping("mutiertam", "mutiertam"), New System.Data.Common.DataColumnMapping("speicherort", "speicherort"), New System.Data.Common.DataColumnMapping("gesperrt", "gesperrt"), New System.Data.Common.DataColumnMapping("gesperrt_durch", "gesperrt_durch"), New System.Data.Common.DataColumnMapping("gesperrtam", "gesperrtam"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("bemerkung", "bemerkung"), New System.Data.Common.DataColumnMapping("auserstuebernahme", "auserstuebernahme"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("unvollstaendig", "unvollstaendig"), New System.Data.Common.DataColumnMapping("bemerkunguvm", "bemerkunguvm"), New System.Data.Common.DataColumnMapping("bereit_zur_archivierung", "bereit_zur_archivierung"), New System.Data.Common.DataColumnMapping("ausgangsarchiviert", "ausgangsarchiviert"), New System.Data.Common.DataColumnMapping("datum_ausgangsarchivierung", "datum_ausgangsarchivierung"), New System.Data.Common.DataColumnMapping("ma_ausgangsarchivierung", "ma_ausgangsarchivierung"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingangsarchiviert", "eingangsarchiviert"), New System.Data.Common.DataColumnMapping("datum_eingangsarchivierung", "datum_eingangsarchivierung"), New System.Data.Common.DataColumnMapping("ma_eingangsarchivierung", "ma_eingangsarchivierung"), New System.Data.Common.DataColumnMapping("status_edoka_batch_ausgang", "status_edoka_batch_ausgang"), New System.Data.Common.DataColumnMapping("status_edoka_batch_eingang", "status_edoka_batch_eingang"), New System.Data.Common.DataColumnMapping("loeschgrund", "loeschgrund"), New System.Data.Common.DataColumnMapping("coldstatus", "coldstatus"), New System.Data.Common.DataColumnMapping("versandadresse", "versandadresse"), New System.Data.Common.DataColumnMapping("barcodenr", "barcodenr"), New System.Data.Common.DataColumnMapping("colddokumentid", "colddokumentid"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("verantwortlich", "verantwortlich"), New System.Data.Common.DataColumnMapping("zustaendiger", "zustaendiger"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("postzustellung", "postzustellung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("statusnr", "statusnr"), New System.Data.Common.DataColumnMapping("zustaendig_kube", "zustaendig_kube"), New System.Data.Common.DataColumnMapping("zustelladresse", "zustelladresse"), New System.Data.Common.DataColumnMapping("vertraulich", "vertraulich"), New System.Data.Common.DataColumnMapping("erstellungsdatum", "erstellungsdatum"), New System.Data.Common.DataColumnMapping("archivierungsdatum", "archivierungsdatum"), New System.Data.Common.DataColumnMapping("termin", "termin"), New System.Data.Common.DataColumnMapping("mutiererteam", "mutiererteam"), New System.Data.Common.DataColumnMapping("anredezustelladresse", "anredezustelladresse")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_dokument_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentid", System.Data.SqlDbType.VarChar, 22, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anredezustelladresse", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anredezustelladresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_archivierungsdatum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "archivierungsdatum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_auserstuebernahme", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "auserstuebernahme", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausgangsarchiviert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausgangsarchiviert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bemerkung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bemerkung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bemerkunguvm", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bemerkunguvm", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bereit_zur_archivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bereit_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_colddokumentid", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "colddokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum_ausgangsarchivierung", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum_ausgangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum_eingangsarchivierung", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum_eingangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentidn", System.Data.SqlDbType.VarChar, 20, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentidn", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingangsarchiviert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingangsarchiviert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ersteller", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellerteam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellerteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstelltam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstelltam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellungsdatum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellungsdatum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrt_durch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrt_durch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrtam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrtam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschgrund", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschgrund", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ma_ausgangsarchivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ma_ausgangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ma_eingangsarchivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ma_eingangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiererteam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiererteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierertieam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierertieam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiertam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiertam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nrpar00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nrpar00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_postzustellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "postzustellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_speicherort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "speicherort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_edoka_batch_ausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_edoka_batch_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_edoka_batch_eingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_edoka_batch_eingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_termin", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "termin", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unvollstaendig", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unvollstaendig", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_verantwortlich", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "verantwortlich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_versandadresse", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "versandadresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustaendig_kube", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustaendig_kube", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustaendiger", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustaendiger", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustelladresse", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustelladresse", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_dokument_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentid", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr1", System.Data.SqlDbType.Int, 4, "mitarbeiternr1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nrpar00", System.Data.SqlDbType.Int, 4, "nrpar00"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentidn", System.Data.SqlDbType.VarChar, 20, "dokumentidn"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentname", System.Data.SqlDbType.VarChar, 255, "dokumentname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ersteller", System.Data.SqlDbType.Int, 4, "ersteller"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellerteam", System.Data.SqlDbType.Int, 4, "erstellerteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstelltam", System.Data.SqlDbType.DateTime, 8, "erstelltam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierertieam", System.Data.SqlDbType.Int, 4, "mutierertieam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiertam", System.Data.SqlDbType.DateTime, 8, "mutiertam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@speicherort", System.Data.SqlDbType.VarChar, 255, "speicherort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrt", System.Data.SqlDbType.Bit, 1, "gesperrt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrt_durch", System.Data.SqlDbType.Int, 4, "gesperrt_durch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrtam", System.Data.SqlDbType.DateTime, 8, "gesperrtam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bemerkung", System.Data.SqlDbType.VarChar, 255, "bemerkung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@auserstuebernahme", System.Data.SqlDbType.Bit, 1, "auserstuebernahme"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unvollstaendig", System.Data.SqlDbType.Bit, 1, "unvollstaendig"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bemerkunguvm", System.Data.SqlDbType.VarChar, 255, "bemerkunguvm"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bereit_zur_archivierung", System.Data.SqlDbType.Bit, 1, "bereit_zur_archivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausgangsarchiviert", System.Data.SqlDbType.Bit, 1, "ausgangsarchiviert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum_ausgangsarchivierung", System.Data.SqlDbType.DateTime, 8, "datum_ausgangsarchivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ma_ausgangsarchivierung", System.Data.SqlDbType.Int, 4, "ma_ausgangsarchivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingangsarchiviert", System.Data.SqlDbType.Bit, 1, "eingangsarchiviert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum_eingangsarchivierung", System.Data.SqlDbType.DateTime, 8, "datum_eingangsarchivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ma_eingangsarchivierung", System.Data.SqlDbType.Int, 4, "ma_eingangsarchivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_edoka_batch_ausgang", System.Data.SqlDbType.Int, 4, "status_edoka_batch_ausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_edoka_batch_eingang", System.Data.SqlDbType.Int, 4, "status_edoka_batch_eingang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschgrund", System.Data.SqlDbType.VarChar, 255, "loeschgrund"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldstatus", System.Data.SqlDbType.Int, 4, "coldstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@versandadresse", System.Data.SqlDbType.VarChar, 1024, "versandadresse"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodenr", System.Data.SqlDbType.Int, 4, "barcodenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@colddokumentid", System.Data.SqlDbType.VarChar, 255, "colddokumentid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@verantwortlich", System.Data.SqlDbType.Int, 4, "verantwortlich"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustaendiger", System.Data.SqlDbType.Int, 4, "zustaendiger"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@postzustellung", System.Data.SqlDbType.Int, 4, "postzustellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statusnr", System.Data.SqlDbType.Int, 4, "statusnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustaendig_kube", System.Data.SqlDbType.Bit, 1, "zustaendig_kube"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustelladresse", System.Data.SqlDbType.VarChar, 255, "zustelladresse"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich", System.Data.SqlDbType.Bit, 1, "vertraulich"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellungsdatum", System.Data.SqlDbType.DateTime, 8, "erstellungsdatum"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@archivierungsdatum", System.Data.SqlDbType.DateTime, 8, "archivierungsdatum"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@termin", System.Data.SqlDbType.DateTime, 8, "termin"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiererteam", System.Data.SqlDbType.Int, 4, "mutiererteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anredezustelladresse", System.Data.SqlDbType.VarChar, 255, "anredezustelladresse"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_dokument_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentid", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_dokument_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr1", System.Data.SqlDbType.Int, 4, "mitarbeiternr1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nrpar00", System.Data.SqlDbType.Int, 4, "nrpar00"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentidn", System.Data.SqlDbType.VarChar, 20, "dokumentidn"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentname", System.Data.SqlDbType.VarChar, 255, "dokumentname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ersteller", System.Data.SqlDbType.Int, 4, "ersteller"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellerteam", System.Data.SqlDbType.Int, 4, "erstellerteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstelltam", System.Data.SqlDbType.DateTime, 8, "erstelltam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierertieam", System.Data.SqlDbType.Int, 4, "mutierertieam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiertam", System.Data.SqlDbType.DateTime, 8, "mutiertam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@speicherort", System.Data.SqlDbType.VarChar, 255, "speicherort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrt", System.Data.SqlDbType.Bit, 1, "gesperrt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrt_durch", System.Data.SqlDbType.Int, 4, "gesperrt_durch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@gesperrtam", System.Data.SqlDbType.DateTime, 8, "gesperrtam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bemerkung", System.Data.SqlDbType.VarChar, 255, "bemerkung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@auserstuebernahme", System.Data.SqlDbType.Bit, 1, "auserstuebernahme"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unvollstaendig", System.Data.SqlDbType.Bit, 1, "unvollstaendig"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bemerkunguvm", System.Data.SqlDbType.VarChar, 255, "bemerkunguvm"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bereit_zur_archivierung", System.Data.SqlDbType.Bit, 1, "bereit_zur_archivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausgangsarchiviert", System.Data.SqlDbType.Bit, 1, "ausgangsarchiviert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum_ausgangsarchivierung", System.Data.SqlDbType.DateTime, 8, "datum_ausgangsarchivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ma_ausgangsarchivierung", System.Data.SqlDbType.Int, 4, "ma_ausgangsarchivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingangsarchiviert", System.Data.SqlDbType.Bit, 1, "eingangsarchiviert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum_eingangsarchivierung", System.Data.SqlDbType.DateTime, 8, "datum_eingangsarchivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ma_eingangsarchivierung", System.Data.SqlDbType.Int, 4, "ma_eingangsarchivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_edoka_batch_ausgang", System.Data.SqlDbType.Int, 4, "status_edoka_batch_ausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_edoka_batch_eingang", System.Data.SqlDbType.Int, 4, "status_edoka_batch_eingang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschgrund", System.Data.SqlDbType.VarChar, 255, "loeschgrund"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldstatus", System.Data.SqlDbType.Int, 4, "coldstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@versandadresse", System.Data.SqlDbType.VarChar, 1024, "versandadresse"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodenr", System.Data.SqlDbType.Int, 4, "barcodenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@colddokumentid", System.Data.SqlDbType.VarChar, 255, "colddokumentid"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@verantwortlich", System.Data.SqlDbType.Int, 4, "verantwortlich"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustaendiger", System.Data.SqlDbType.Int, 4, "zustaendiger"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@postzustellung", System.Data.SqlDbType.Int, 4, "postzustellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statusnr", System.Data.SqlDbType.Int, 4, "statusnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustaendig_kube", System.Data.SqlDbType.Bit, 1, "zustaendig_kube"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zustelladresse", System.Data.SqlDbType.VarChar, 255, "zustelladresse"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich", System.Data.SqlDbType.Bit, 1, "vertraulich"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellungsdatum", System.Data.SqlDbType.DateTime, 8, "erstellungsdatum"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@archivierungsdatum", System.Data.SqlDbType.DateTime, 8, "archivierungsdatum"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@termin", System.Data.SqlDbType.DateTime, 8, "termin"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiererteam", System.Data.SqlDbType.Int, 4, "mutiererteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anredezustelladresse", System.Data.SqlDbType.VarChar, 255, "anredezustelladresse"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentid", System.Data.SqlDbType.VarChar, 22, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anredezustelladresse", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anredezustelladresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_archivierungsdatum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "archivierungsdatum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_auserstuebernahme", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "auserstuebernahme", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausgangsarchiviert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausgangsarchiviert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bemerkung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bemerkung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bemerkunguvm", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bemerkunguvm", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bereit_zur_archivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bereit_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_colddokumentid", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "colddokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum_ausgangsarchivierung", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum_ausgangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum_eingangsarchivierung", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum_eingangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentidn", System.Data.SqlDbType.VarChar, 20, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentidn", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingangsarchiviert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingangsarchiviert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ersteller", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellerteam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellerteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstelltam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstelltam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellungsdatum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellungsdatum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrt_durch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrt_durch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_gesperrtam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "gesperrtam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschgrund", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschgrund", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ma_ausgangsarchivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ma_ausgangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ma_eingangsarchivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ma_eingangsarchivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiererteam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiererteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierertieam", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierertieam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiertam", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiertam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nrpar00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nrpar00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_postzustellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "postzustellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_speicherort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "speicherort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_edoka_batch_ausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_edoka_batch_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_edoka_batch_eingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_edoka_batch_eingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_termin", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "termin", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unvollstaendig", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unvollstaendig", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_verantwortlich", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "verantwortlich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_versandadresse", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "versandadresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustaendig_kube", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustaendig_kube", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustaendiger", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustaendiger", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zustelladresse", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zustelladresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentid", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(168, 80)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(112, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&Fenster schliessen"
        '
        'FrmRestore
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(480, 117)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Label1})
        Me.Name = "FrmRestore"
        Me.Text = "FrmRestore"
        Me.WindowState = System.Windows.Forms.FormWindowState.Minimized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore.Restore_Dokument Method

Public Function Restore_Dokument()

Source code

[Visual Basic]
    Public Function Restore_Dokument()

        Me.Refresh()
        If NeuesDokument Then
            Dim d As New edokadb.clsDokument()
            d.cpMainConnectionProvider = conn
            conn.OpenConnection()
            d.sDokumentid = New SqlString(CType(Me.DokumentID, String))
            d.Delete()
            conn.CloseConnection(True)
            d.Dispose()
            Exit Function
        End If
        Dim i As Integer
        Me.DataSet1.Clear()
        Me.DataSet1.Tables.Clear()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlSelectCommand1.Parameters("@dokumentid").Value = Me.DokumentID
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        For i = 0 To Me.DataSet1.Tables(0).Rows(0).ItemArray.Length - 1
            Me.DataSet1.Tables(0).Rows(0).Item(i) = Me.SaveDocument.Rows(0).Item(i)
        Next
        Me.SqlDataAdapter1.Update(Me.DataSet1)

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmRestore Fields

FrmRestore overview

Fields

field Button1
field DataSet1
field Label1
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field m_create
field m_dokumentid

See Also

FrmRestore Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


m_create Variable

Dim m_create As Boolean

Source code

[Visual Basic]
    Dim m_create As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmRestore


FrmSysadminMenu Class

For a list of all members of this type, see FrmSysadminMenu Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.FrmSysadminMenu

Public Class FrmSysadminMenu
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

FrmSysadminMenu Members


FrmSysadminMenu Members

FrmSysadminMenu overview

Constructors

constructor FrmSysadminMenu Constructor

Methods

method Dispose
method FrmSysadminMenu_Load
method InitializeComponent
method ListNodeCollectionRecursive
method ListNodeSave
method MenuItem2_Click
method MnuKnotenLoeschen_Click
method MnuNeuerKnoten_Click
method MnuNodeUp_Click
method MnuSave_Click
method SysMenu_AfterSelect
method SysMenu_DblClick
method Toolbtn_Schliessen_ButtonClick
method TreeView_DragDrop
method TreeView_DragEnter
method TreeView_ItemDrag

Fields

field ContextMenu1
field ImageList1
field MenuItem2
field MenuItem4
field MnuKnotenLoeschen
field MnuNeuerKnoten
field MnuSave
field SysMenu
field ToolBarButton1
field Toolbtn_Schliessen
field components
field itodelete
field ssort
field todelete

See Also

FrmSysadminMenu Class


FrmSysadminMenu Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu Methods

FrmSysadminMenu overview

Methods

method Dispose
method FrmSysadminMenu_Load
method InitializeComponent
method ListNodeCollectionRecursive
method ListNodeSave
method MenuItem2_Click
method MnuKnotenLoeschen_Click
method MnuNeuerKnoten_Click
method MnuNodeUp_Click
method MnuSave_Click
method SysMenu_AfterSelect
method SysMenu_DblClick
method Toolbtn_Schliessen_ButtonClick
method TreeView_DragDrop
method TreeView_DragEnter
method TreeView_ItemDrag

See Also

FrmSysadminMenu Class


FrmSysadminMenu.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.FrmSysadminMenu_Load Method

Private Sub FrmSysadminMenu_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FrmSysadminMenu_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim menu As New edokadb.clsMySysadminfunkion()
        menu.LoadTreeMenu(SysMenu)
        SysMenu.ExpandAll()
        itodelete = 0
        DivFnkt.Searchnode(Me.SysMenu, 11, 0)
        If DivFnkt.found Then
            Me.ContextMenu1.MenuItems(4).Enabled = True
        Else
            Me.ContextMenu1.MenuItems(4).Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(FrmSysadminMenu))
        Me.Toolbtn_Schliessen = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.SysMenu = New System.Windows.Forms.TreeView()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeuerKnoten = New System.Windows.Forms.MenuItem()
        Me.MnuKnotenLoeschen = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MnuSave = New System.Windows.Forms.MenuItem()
        Me.SuspendLayout()
        '
        'Toolbtn_Schliessen
        '
        Me.Toolbtn_Schliessen.AccessibleDescription = CType(resources.GetObject("Toolbtn_Schliessen.AccessibleDescription"), String)
        Me.Toolbtn_Schliessen.AccessibleName = CType(resources.GetObject("Toolbtn_Schliessen.AccessibleName"), String)
        Me.Toolbtn_Schliessen.Anchor = CType(resources.GetObject("Toolbtn_Schliessen.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.Toolbtn_Schliessen.Appearance = CType(resources.GetObject("Toolbtn_Schliessen.Appearance"), System.Windows.Forms.ToolBarAppearance)
        Me.Toolbtn_Schliessen.AutoSize = CType(resources.GetObject("Toolbtn_Schliessen.AutoSize"), Boolean)
        Me.Toolbtn_Schliessen.BackgroundImage = CType(resources.GetObject("Toolbtn_Schliessen.BackgroundImage"), System.Drawing.Image)
        Me.Toolbtn_Schliessen.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.Toolbtn_Schliessen.ButtonSize = CType(resources.GetObject("Toolbtn_Schliessen.ButtonSize"), System.Drawing.Size)
        Me.Toolbtn_Schliessen.Dock = CType(resources.GetObject("Toolbtn_Schliessen.Dock"), System.Windows.Forms.DockStyle)
        Me.Toolbtn_Schliessen.DropDownArrows = CType(resources.GetObject("Toolbtn_Schliessen.DropDownArrows"), Boolean)
        Me.Toolbtn_Schliessen.Enabled = CType(resources.GetObject("Toolbtn_Schliessen.Enabled"), Boolean)
        Me.Toolbtn_Schliessen.Font = CType(resources.GetObject("Toolbtn_Schliessen.Font"), System.Drawing.Font)
        Me.Toolbtn_Schliessen.ImageList = Me.ImageList1
        Me.Toolbtn_Schliessen.ImeMode = CType(resources.GetObject("Toolbtn_Schliessen.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Toolbtn_Schliessen.Location = CType(resources.GetObject("Toolbtn_Schliessen.Location"), System.Drawing.Point)
        Me.Toolbtn_Schliessen.Name = "Toolbtn_Schliessen"
        Me.Toolbtn_Schliessen.RightToLeft = CType(resources.GetObject("Toolbtn_Schliessen.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.Toolbtn_Schliessen.ShowToolTips = CType(resources.GetObject("Toolbtn_Schliessen.ShowToolTips"), Boolean)
        Me.Toolbtn_Schliessen.Size = CType(resources.GetObject("Toolbtn_Schliessen.Size"), System.Drawing.Size)
        Me.Toolbtn_Schliessen.TabIndex = CType(resources.GetObject("Toolbtn_Schliessen.TabIndex"), Integer)
        Me.Toolbtn_Schliessen.TextAlign = CType(resources.GetObject("Toolbtn_Schliessen.TextAlign"), System.Windows.Forms.ToolBarTextAlign)
        Me.Toolbtn_Schliessen.Visible = CType(resources.GetObject("Toolbtn_Schliessen.Visible"), Boolean)
        Me.Toolbtn_Schliessen.Wrappable = CType(resources.GetObject("Toolbtn_Schliessen.Wrappable"), Boolean)
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.Enabled = CType(resources.GetObject("ToolBarButton1.Enabled"), Boolean)
        Me.ToolBarButton1.ImageIndex = CType(resources.GetObject("ToolBarButton1.ImageIndex"), Integer)
        Me.ToolBarButton1.Text = resources.GetString("ToolBarButton1.Text")
        Me.ToolBarButton1.ToolTipText = resources.GetString("ToolBarButton1.ToolTipText")
        Me.ToolBarButton1.Visible = CType(resources.GetObject("ToolBarButton1.Visible"), Boolean)
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = CType(resources.GetObject("ImageList1.ImageSize"), System.Drawing.Size)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'SysMenu
        '
        Me.SysMenu.AccessibleDescription = CType(resources.GetObject("SysMenu.AccessibleDescription"), String)
        Me.SysMenu.AccessibleName = CType(resources.GetObject("SysMenu.AccessibleName"), String)
        Me.SysMenu.AllowDrop = True
        Me.SysMenu.Anchor = CType(resources.GetObject("SysMenu.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.SysMenu.BackgroundImage = CType(resources.GetObject("SysMenu.BackgroundImage"), System.Drawing.Image)
        Me.SysMenu.ContextMenu = Me.ContextMenu1
        Me.SysMenu.Dock = CType(resources.GetObject("SysMenu.Dock"), System.Windows.Forms.DockStyle)
        Me.SysMenu.Enabled = CType(resources.GetObject("SysMenu.Enabled"), Boolean)
        Me.SysMenu.Font = CType(resources.GetObject("SysMenu.Font"), System.Drawing.Font)
        Me.SysMenu.ImageIndex = CType(resources.GetObject("SysMenu.ImageIndex"), Integer)
        Me.SysMenu.ImageList = Me.ImageList1
        Me.SysMenu.ImeMode = CType(resources.GetObject("SysMenu.ImeMode"), System.Windows.Forms.ImeMode)
        Me.SysMenu.Indent = CType(resources.GetObject("SysMenu.Indent"), Integer)
        Me.SysMenu.ItemHeight = CType(resources.GetObject("SysMenu.ItemHeight"), Integer)
        Me.SysMenu.Location = CType(resources.GetObject("SysMenu.Location"), System.Drawing.Point)
        Me.SysMenu.Name = "SysMenu"
        Me.SysMenu.RightToLeft = CType(resources.GetObject("SysMenu.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.SysMenu.SelectedImageIndex = CType(resources.GetObject("SysMenu.SelectedImageIndex"), Integer)
        Me.SysMenu.Size = CType(resources.GetObject("SysMenu.Size"), System.Drawing.Size)
        Me.SysMenu.TabIndex = CType(resources.GetObject("SysMenu.TabIndex"), Integer)
        Me.SysMenu.Text = resources.GetString("SysMenu.Text")
        Me.SysMenu.Visible = CType(resources.GetObject("SysMenu.Visible"), Boolean)
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeuerKnoten, Me.MnuKnotenLoeschen, Me.MenuItem2, Me.MenuItem4, Me.MnuSave})
        Me.ContextMenu1.RightToLeft = CType(resources.GetObject("ContextMenu1.RightToLeft"), System.Windows.Forms.RightToLeft)
        '
        'MnuNeuerKnoten
        '
        Me.MnuNeuerKnoten.Enabled = CType(resources.GetObject("MnuNeuerKnoten.Enabled"), Boolean)
        Me.MnuNeuerKnoten.Index = 0
        Me.MnuNeuerKnoten.Shortcut = CType(resources.GetObject("MnuNeuerKnoten.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuNeuerKnoten.ShowShortcut = CType(resources.GetObject("MnuNeuerKnoten.ShowShortcut"), Boolean)
        Me.MnuNeuerKnoten.Text = resources.GetString("MnuNeuerKnoten.Text")
        Me.MnuNeuerKnoten.Visible = CType(resources.GetObject("MnuNeuerKnoten.Visible"), Boolean)
        '
        'MnuKnotenLoeschen
        '
        Me.MnuKnotenLoeschen.Enabled = CType(resources.GetObject("MnuKnotenLoeschen.Enabled"), Boolean)
        Me.MnuKnotenLoeschen.Index = 1
        Me.MnuKnotenLoeschen.Shortcut = CType(resources.GetObject("MnuKnotenLoeschen.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuKnotenLoeschen.ShowShortcut = CType(resources.GetObject("MnuKnotenLoeschen.ShowShortcut"), Boolean)
        Me.MnuKnotenLoeschen.Text = resources.GetString("MnuKnotenLoeschen.Text")
        Me.MnuKnotenLoeschen.Visible = CType(resources.GetObject("MnuKnotenLoeschen.Visible"), Boolean)
        '
        'MenuItem2
        '
        Me.MenuItem2.Enabled = CType(resources.GetObject("MenuItem2.Enabled"), Boolean)
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Shortcut = CType(resources.GetObject("MenuItem2.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem2.ShowShortcut = CType(resources.GetObject("MenuItem2.ShowShortcut"), Boolean)
        Me.MenuItem2.Text = resources.GetString("MenuItem2.Text")
        Me.MenuItem2.Visible = CType(resources.GetObject("MenuItem2.Visible"), Boolean)
        '
        'MenuItem4
        '
        Me.MenuItem4.Enabled = CType(resources.GetObject("MenuItem4.Enabled"), Boolean)
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Shortcut = CType(resources.GetObject("MenuItem4.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MenuItem4.ShowShortcut = CType(resources.GetObject("MenuItem4.ShowShortcut"), Boolean)
        Me.MenuItem4.Text = resources.GetString("MenuItem4.Text")
        Me.MenuItem4.Visible = CType(resources.GetObject("MenuItem4.Visible"), Boolean)
        '
        'MnuSave
        '
        Me.MnuSave.Enabled = CType(resources.GetObject("MnuSave.Enabled"), Boolean)
        Me.MnuSave.Index = 4
        Me.MnuSave.Shortcut = CType(resources.GetObject("MnuSave.Shortcut"), System.Windows.Forms.Shortcut)
        Me.MnuSave.ShowShortcut = CType(resources.GetObject("MnuSave.ShowShortcut"), Boolean)
        Me.MnuSave.Text = resources.GetString("MnuSave.Text")
        Me.MnuSave.Visible = CType(resources.GetObject("MnuSave.Visible"), Boolean)
        '
        'FrmSysadminMenu
        '
        Me.AccessibleDescription = CType(resources.GetObject("$this.AccessibleDescription"), String)
        Me.AccessibleName = CType(resources.GetObject("$this.AccessibleName"), String)
        Me.Anchor = CType(resources.GetObject("$this.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.AutoScale = False
        Me.AutoScaleBaseSize = CType(resources.GetObject("$this.AutoScaleBaseSize"), System.Drawing.Size)
        Me.AutoScroll = CType(resources.GetObject("$this.AutoScroll"), Boolean)
        Me.AutoScrollMargin = CType(resources.GetObject("$this.AutoScrollMargin"), System.Drawing.Size)
        Me.AutoScrollMinSize = CType(resources.GetObject("$this.AutoScrollMinSize"), System.Drawing.Size)
        Me.BackgroundImage = CType(resources.GetObject("$this.BackgroundImage"), System.Drawing.Image)
        Me.ClientSize = CType(resources.GetObject("$this.ClientSize"), System.Drawing.Size)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.SysMenu, Me.Toolbtn_Schliessen})
        Me.Dock = CType(resources.GetObject("$this.Dock"), System.Windows.Forms.DockStyle)
        Me.Enabled = CType(resources.GetObject("$this.Enabled"), Boolean)
        Me.Font = CType(resources.GetObject("$this.Font"), System.Drawing.Font)
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.ImeMode = CType(resources.GetObject("$this.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Location = CType(resources.GetObject("$this.Location"), System.Drawing.Point)
        Me.MaximizeBox = False
        Me.MaximumSize = CType(resources.GetObject("$this.MaximumSize"), System.Drawing.Size)
        Me.MinimizeBox = False
        Me.MinimumSize = CType(resources.GetObject("$this.MinimumSize"), System.Drawing.Size)
        Me.Name = "FrmSysadminMenu"
        Me.RightToLeft = CType(resources.GetObject("$this.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.ShowInTaskbar = False
        Me.StartPosition = CType(resources.GetObject("$this.StartPosition"), System.Windows.Forms.FormStartPosition)
        Me.Text = resources.GetString("$this.Text")
        Me.Visible = CType(resources.GetObject("$this.Visible"), Boolean)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.ListNodeCollectionRecursive Method

Private Sub ListNodeCollectionRecursive( _
   ByVal tnParent As TreeNode, _
   ByRef iSort As Integer _
)

Parameters

tnParent
Required.
iSort
Required.

Source code

[Visual Basic]
    Private Sub ListNodeCollectionRecursive(ByVal tnParent As TreeNode, ByRef iSort As Integer)
        Dim tn As TreeNode
        If tnParent.GetNodeCount(False) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        ssort = 0
        Do Until tn Is Nothing
            iSort = iSort + 1
            ListNodeSave(tn, iSort)
            If tn.GetNodeCount(False) > 0 Then
                Call ListNodeCollectionRecursive(tn, iSort)
            End If
            tn = tn.NextNode
        Loop
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.ListNodeSave Method

Private Sub ListNodeSave( _
   ByVal tn As TreeNode, _
   ByRef isort As Integer _
)

Parameters

tn
Required.
isort
Required.

Source code

[Visual Basic]
    Private Sub ListNodeSave(ByVal tn As TreeNode, ByRef isort As Integer)
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim t As DataTable
        Dim key As Long
        Dim i As Integer
        Dim ftop, fleft, fheight, fwidth As Integer
        Dim sysadmfnkt As New edokadb.clsMySysadminfunkion()
        dbkey.cpMainConnectionProvider = conn
        sysadmfnkt.cpMainConnectionProvider = conn

        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.SelectOne()
            ftop = sysadmfnkt.iFtop.Value
            fleft = sysadmfnkt.iFleft.Value
            fwidth = sysadmfnkt.iFwidth.Value
            fheight = sysadmfnkt.iFheight.Value
        End If
        sysadmfnkt.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        sysadmfnkt.sBezeichnung = New SqlString(CType(tn.Text, String))
        sysadmfnkt.sBeschreibung = New SqlString(CType("", String))
        sysadmfnkt.iParentID = New SqlInt32(CType(tn.Parent.Tag, Int32))
        sysadmfnkt.iImageIndex = New SqlInt32(CType(tn.ImageIndex, Int32))
        sysadmfnkt.iImageIndexOpen = New SqlInt32(CType(tn.SelectedImageIndex, Int32))
        sysadmfnkt.iSort = New SqlInt32(CType(isort, Int32))
        sysadmfnkt.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        sysadmfnkt.bAktiv = New SqlBoolean(CType(True, Boolean))
        sysadmfnkt.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        sysadmfnkt.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        sysadmfnkt.iFtop = New SqlInt32(CType(ftop, Int32))
        sysadmfnkt.iFleft = New SqlInt32(CType(fleft, Int32))
        sysadmfnkt.iFwidth = New SqlInt32(CType(fwidth, Int32))
        sysadmfnkt.iFheight = New SqlInt32(CType(fheight, Int32))

        If tn.Tag <> 0 Then
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(tn.Tag, Int32))
            sysadmfnkt.Update()
        Else
            key = dbkey.get_dbkey("sysadminfunktion")
            conn.OpenConnection()
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(key, Int32))
            sysadmfnkt.Insert()
            tn.Tag = key
        End If

        For i = 1 To itodelete
            sysadmfnkt.iSysadminfnktnr = New SqlInt32(CType(todelete(i), Int32))
            t = sysadmfnkt.SelectOne
            If t.Rows.Count > 0 Then
                sysadmfnkt.Delete()
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.SysMenu.SelectedNode.Text = a
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.MnuKnotenLoeschen_Click Method

Private Sub MnuKnotenLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuKnotenLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuKnotenLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuKnotenLoeschen.Click
        Dim tn As New TreeNode()
        Dim tnp As New TreeNode()
        Dim i As Integer
        tn = Me.SysMenu.SelectedNode
        tnp = tn.Parent
        If Not (Me.SysMenu.SelectedNode Is Nothing) Then
            itodelete = itodelete + 1
            todelete(itodelete) = tn.Tag
            If Globals.MyMsg.Show_MessageYesNo(3) = MsgBoxResult.Yes Then
                tn.Remove()
            End If
            If tnp.GetNodeCount(True) = 0 Then
                tnp.ImageIndex = 3
                tnp.SelectedImageIndex = 3
            End If
            Me.SysMenu.Refresh()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.MnuNeuerKnoten_Click Method

Private Sub MnuNeuerKnoten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeuerKnoten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeuerKnoten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuerKnoten.Click
        Dim a As String
        Dim tn As New TreeNode()
        Dim tnnew As New TreeNode()
        a = InputBox(Globals.MyMsg.Get_Meldungstext(500))
        If a = "" Then Exit Sub
        tn = Me.SysMenu.SelectedNode
        tnnew = tn.Nodes.Add(a)
        With tnnew
            .Tag() = 0
            .ImageIndex() = 3
            .SelectedImageIndex() = 3
        End With
        tn.ImageIndex = 1
        tn.SelectedImageIndex = 2
        If tn.GetNodeCount(True) > 0 Then
            tn.ImageIndex = 1
            tn.SelectedImageIndex = 2
        End If
        Me.SysMenu.Refresh()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.MnuNodeUp_Click Method

Private Sub MnuNodeUp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNodeUp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.MnuSave_Click Method

Private Sub MnuSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSave.Click
        Dim i As Integer
        conn.OpenConnection()
        ListNodeCollectionRecursive(Me.SysMenu.Nodes(0), 0)
        i = conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.SysMenu_AfterSelect Method

Private Sub SysMenu_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles SysMenu.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub SysMenu_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles SysMenu.AfterSelect

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.SysMenu_DblClick Method

Private Sub SysMenu_DblClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles SysMenu.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub SysMenu_DblClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles SysMenu.DoubleClick
        Dim Eintrag As Long
        Eintrag = Me.SysMenu.SelectedNode.Tag
        Select Case Eintrag
            Case 2
                Dim frm As New frmApplication()
                frm.Text = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 3
                Dim frm As New frmDomainMandant()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 5
                Dim frm As New frmDomainMeldungstexte()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 6
                Dim frm As New frmDomainTipTexte()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 7
                Dim frm As New frmDomainSpalten()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 11
                Dim frm As New frmDomainSysadminfuntkion()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 12
                Dim frm As New frmDomainStatusBezeichnung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 27
                Dim frm As New frmDomainFunktion()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 32
                Dim frm As New frmStatustypStatusbezeichnung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 33
                Dim frm As New frmDomainStatusTyp()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 35
                Dim frm As New FrmDomainDokumentart()
                DivFnkt.Searchnode(Me.SysMenu, 76, 0)
                If DivFnkt.found Then
                    frm.ContextMenu1.MenuItems(4).Enabled = True
                    frm.ContextMenu1.MenuItems(6).Enabled = True
                Else
                    frm.ContextMenu1.MenuItems(4).Enabled = False
                    frm.ContextMenu1.MenuItems(6).Enabled = False
                End If
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 36
                Dim frm As New frmDomainOfficeVorlage()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 37
                Try
                    Dim frm As New frmDomainDokumenttyp()
                    frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                    frm.Eintrag = SysMenu.SelectedNode.Text
                    frm.MdiParent = Me.ParentForm
                    frm.Show()
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try
            Case 38
                Dim frm As New frmDomainVorlagenfeldregel()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 40
                Dim frm As New frmDomainIDVMakros()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 41
                Dim frm As New frmIDVMakroOfficeVorlage()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 42
                Dim frm As New frmDomainPhsischesArchiv()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 45
                Dim frm As New frmDomainRolle()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 47
                Dim frm As New frmRolle_Sysadminfunktion()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 49		  'alt
                'alt, nur noch für überprüfung, wird gelöscht
                Dim frm As New frmDomainMitarbeiter()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 118
                Dim frm As New frmAdminMitarbeiter()
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 50
                Dim frm As New frmDomainTeam()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 52
                Dim frm As New frmDomainMarktbereich()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 53
                Dim frm As New frmKostenstelle()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 54
                Dim frm As New frmDomainNiederlassung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 56
                Dim frm As New frmDomainColdFolder()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 57
                Dim frm As New frmDomainColdIndexFeld()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 58
                Dim frm As New frmcoldindx()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 59
                Dim frm As New frmDomainAnwendung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 62
                Dim frm As New frmDomainAuswertungen()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 63
                ' Koe und shu - 2004-08-01
                Dim frm As New frmReport_reportfeldregel()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 64
                Dim frm As New frmDomainReportfeldregel()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 65
                Dim frm As New frmDomainAuswertungsgruppe()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()

            Case 66
                Dim frm As New frmDomainKeyTabelle()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 68
                Dim frm As New frmDomainBankinformation()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 69
                ' Koe und shu - 2004-08-01
                Dim frm As New frmReportgruppe_Report()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 70
                Dim frm As New frmDomainMailtexte()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 71
                Dim frm As New frmMitarbeiterRolle()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 72
                Dim frm As New frmRolleReportGruppe()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 73
                Dim frm As New frmRolleDokumentHierarchie()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 74
                Dim frm As New frmRolleDokumentTyp()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 75
                Dim frm As New frmDomainBerechtigung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 76
                Dim frm As New frmDomainDokumentartDaten()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 78
                Dim frm As New frmDomainProzess()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 79
                Dim frm As New frmRolleBerechtigung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 81
                Dim frm As New frmDomainFunktionsgruppe()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 83
                Dim frm As New frmFunktionsgruppeRolle()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 84
                Dim frm As New frmMitarbeiterFunktionsgruppe()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 86
                Dim frm As New frmDokumentInBearbeitung()
                frm.Show()
                frm.MdiParent = Me.ParentForm
            Case 87
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                Dim t As New TreeView()
                Dim da As New edokadb.clsMyDokumentart()
                da.Refresh = True
                da.Load_Neue_Dokumente(t, "", False, 0)
                da.Dispose()
                t.Dispose()
                Me.Cursor = System.Windows.Forms.Cursors.Default
            Case 88
                If MsgBox("Berechtigungen wirklich neu generieren?", MsgBoxStyle.YesNo) = MsgBoxResult.Yes Then
                    Me.Cursor = Cursors.WaitCursor
                    DivFnkt.Generate_Berechtigungen()
                    Me.Cursor = Cursors.Default
                    MsgBox("Berechtigungen wurden generiert.", MsgBoxStyle.Information)
                End If
            Case 89
                Dim w As New WordLib()
                w.Create_Labels()
            Case 90
                Dim frm As New frmDomainObjektbezeichnung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 91
                Dim frm As New frmedokaUpdate()
                frm.ShowDialog()
            Case 92
                Dim frm As New frmDomainZuordnungen()
                frm.ShowDialog()
            Case 93
                Dim frm As New frmSetDokVerantwortlicher()
                frm.ShowDialog()
            Case 94
                Dim frm As New frmDokumentStatistik()
                frm.Show()
            Case 95
                Dim frm As New frmLog()
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 96
                Dim frm As New frmRestorJournal()
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 97
                Dim frm As New frmNLDokumente()
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 98
                Dim frm As New frmDokumenttypbeschreibung()
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 99
                'Koe und shu - 2004-08-01
                Dim frm As New FrmFunktionsgruppe_Reportgruppe()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 100
                'Koe und shu - 2004-08-01
                Dim frm As New frmDomainFeldtyp()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 101
                'Koe und shu - 2004-08-01
                Dim frm As New frmDomainSteuerbefehl()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 102
                'Koe und shu - 2004-08-01
                Dim frm As New frmQuery()
                frm.Text = "EDOKA-Queryanalyzer"
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 103
                Dim f As New frmReportSelection()
                f.Text = "Auswertungen"
                Me.Cursor = Cursors.WaitCursor
                f.MdiParent = Me.ParentForm
                Try
                    f.Show()
                Catch ex As Exception
                    Me.Cursor = Cursors.Default
                    MsgBox(ex.Message)
                End Try
                Me.Cursor = Cursors.Default
            Case 104
                Dim frm As New frmDomainGrund()
                frm.Text = "Lösch-/Reaktivierungsgründe"
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 105
                'Koe 0
                Dim frm As New frmDoaminStellvertretung()
                frm.Eintragnr = Me.SysMenu.SelectedNode.Tag
                frm.Eintrag = SysMenu.SelectedNode.Text
                frm.MdiParent = Me.ParentForm
                frm.Show()
            Case 106
                'Bud
                Dim frm As New frmNotfallDataGenerate()
                frm.ShowDialog()
            Case 107
                'SHU
                Dim frm As New frmSicherungsjournal()
                frm.ShowDialog()
            Case 108
                Dim f As New frmNotfallimport()
                f.ShowDialog()
            Case 110
                'Hutter 2005-01-04
                'EDEX_Dokumentpakete
                Dim f As New frmDokumentpaketuebersicht(0)
                f.Text = "Lösch-/Reaktivierungsgründe"
                f.MdiParent = Me.ParentForm
                f.show()
            Case 108
                Dim f As New frmNotfallimport()
                f.ShowDialog()
            Case 111
                Dim f As New frmDomainFAAppl()
                f.Text = "EDOKA-Import - Fremdanwendungen"
                f.MdiParent = Me.ParentForm
                f.Show()
            Case 112
                Dim f As New frmDomainFADokumenttyp()
                f.Text = "EDOKA-Import - Zuweisung FA-Dokumenttyp zu EDOKA-Dokumenttyp"
                f.MdiParent = Me.ParentForm
                f.Show()
            Case 113
                Dim f As New frmEDOKA_Import()
                f.Text = "EDOKA-Import - Journale"
                f.MdiParent = Me.ParentForm
                f.Show()
            Case 115
                Dim f As New frmBLParameter()
                f.Text = "Banklagernd Parameter"
                f.MdiParent = Me.ParentForm
                f.Show()
            Case 116
                Dim f As New frmpartnermavip()
                f.Text = "Partner als Mitarbeiter/VIP"
                f.MdiParent = Me.ParentForm
                f.Show()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.Toolbtn_Schliessen_ButtonClick Method

Private Sub Toolbtn_Schliessen_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles Toolbtn_Schliessen.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Toolbtn_Schliessen_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles Toolbtn_Schliessen.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.TreeView_DragDrop Method

Private Sub TreeView_DragDrop( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles SysMenu.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_DragDrop(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenu.DragDrop
        Dim OriginationNode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", False) Then
            Dim pt As Point
            Dim DestinationNode As TreeNode
            pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
            DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
            DestinationNode.Nodes.Add(CType(OriginationNode.Clone, TreeNode))
            DestinationNode.Expand()
            If (e.KeyState And CtrlMask) <> CtrlMask Then
                OriginationNode.Remove()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.TreeView_DragEnter Method

Private Sub TreeView_DragEnter( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles SysMenu.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_DragEnter(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles SysMenu.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            If (e.KeyState And CtrlMask) = CtrlMask Then
                e.Effect = DragDropEffects.Copy
            Else
                e.Effect = DragDropEffects.Move
            End If
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu.TreeView_ItemDrag Method

Private Sub TreeView_ItemDrag( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles SysMenu.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles SysMenu.ItemDrag
        If e.Button = MouseButtons.Left Then
            DoDragDrop(e.Item, DragDropEffects.Move Or DragDropEffects.Copy)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


FrmSysadminMenu Fields

FrmSysadminMenu overview

Fields

field ContextMenu1
field ImageList1
field MenuItem2
field MenuItem4
field MnuKnotenLoeschen
field MnuNeuerKnoten
field MnuSave
field SysMenu
field ToolBarButton1
field Toolbtn_Schliessen
field components
field itodelete
field ssort
field todelete

See Also

FrmSysadminMenu Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


MnuKnotenLoeschen Variable

Friend WithEvents MnuKnotenLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuKnotenLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


MnuNeuerKnoten Variable

Friend WithEvents MnuNeuerKnoten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeuerKnoten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


MnuSave Variable

Friend WithEvents MnuSave As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSave As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


SysMenu Variable

Friend WithEvents SysMenu As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents SysMenu As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


Toolbtn_Schliessen Variable

Friend WithEvents Toolbtn_Schliessen As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents Toolbtn_Schliessen As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


itodelete Variable

Dim itodelete As Integer

Source code

[Visual Basic]
    Dim itodelete As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


ssort Variable

Dim ssort As Integer

Source code

[Visual Basic]
    Dim ssort As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


todelete Variable

Dim todelete( _
   50 _
) As Integer

Source code

[Visual Basic]
    Dim todelete(50) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

FrmSysadminMenu


GenericList Class

For a list of all members of this type, see GenericList Members.

System.Object
EDOKAApp.GenericList

Public Class GenericList

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

GenericList Members


GenericList Members

GenericList overview

Constructors

constructor GenericList Constructor (Overloaded)

Properties

property AlternateDisplay
property Display
property ID
property Index

Fields

field _AlternateDisplay
field _Display
field _ID
field _Index

See Also

GenericList Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal display As String, ByVal altdisplay As String, ByVal id As Integer)

[Visual Basic] Public Sub New(ByVal display As String, ByVal altdisplay As String, ByVal id As Integer, ByVal index As Integer)

[Visual Basic] Public Sub New(ByVal display As String, ByVal id As Integer)

[Visual Basic] Public Sub New(ByVal display As String, ByVal id As Integer, ByVal index As Integer)

See Also

GenericList | EDOKAApp


GenericList Properties

GenericList overview

Properties

property AlternateDisplay
property Display
property ID
property Index

See Also

GenericList Class


GenericList.AlternateDisplay Property

Public Property AlternateDisplay() As String

Source code

[Visual Basic]
    Public Property AlternateDisplay() As String
        Get
            Return _AlternateDisplay
        End Get
        Set(ByVal Value As String)
            _AlternateDisplay = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList.Display Property

Public Property Display() As String

Source code

[Visual Basic]
    Public Property Display() As String
        Get
            Return _Display
        End Get
        Set(ByVal Value As String)
            _Display = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList.ID Property

Public Property ID() As Integer

Source code

[Visual Basic]
    Public Property ID() As Integer
        Get
            Return _ID
        End Get
        Set(ByVal Value As Integer)
            _ID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList.Index Property

Public Property Index() As Integer

Source code

[Visual Basic]
    Public Property Index() As Integer
        Get
            Return _Index
        End Get
        Set(ByVal Value As Integer)
            _Index = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList Fields

GenericList overview

Fields

field _AlternateDisplay
field _Display
field _ID
field _Index

See Also

GenericList Class


_AlternateDisplay Variable

Private _AlternateDisplay As String

Source code

[Visual Basic]
    Private _AlternateDisplay As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


_Display Variable

Private _Display As String

Source code

[Visual Basic]
    Private _Display As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


_ID Variable

Private _ID As Integer

Source code

[Visual Basic]
    Private _ID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


_Index Variable

Private _Index As Integer = -1

Source code

[Visual Basic]
    Private _Index As Integer = -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


HHctrlapi Class

For a list of all members of this type, see HHctrlapi Members.

System.Object
EDOKAApp.HHctrlapi

Public Class HHctrlapi

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

HHctrlapi Members


HHctrlapi Members

HHctrlapi overview

Constructors

constructor HHctrlapi Constructor

Methods

method ShowHelpIndex
method ShowHelpToc
method ShowHelpTopic
method ShowSearch
method ShowWindow

Fields

field DummyControl
field MyHelpProvider

See Also

HHctrlapi Class


HHctrlapi Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyHelpProvider.HelpNamespace = Application.StartupPath + "\EDOKA-Hilfe.chm"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi Methods

HHctrlapi overview

Methods

method ShowHelpIndex
method ShowHelpToc
method ShowHelpTopic
method ShowSearch
method ShowWindow

See Also

HHctrlapi Class


HHctrlapi.ShowHelpIndex Method

Public Function ShowHelpIndex()

Source code

[Visual Basic]
    Public Function ShowHelpIndex()
        Help.ShowHelpIndex(DummyControl, MyHelpProvider.HelpNamespace)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi.ShowHelpToc Method

Public Function ShowHelpToc( _
   ByVal context As String _
)

Parameters

context
Required.

Source code

[Visual Basic]
    Public Function ShowHelpToc(ByVal context As String)
        Help.ShowHelp(DummyControl, MyHelpProvider.HelpNamespace, context + ".htm")
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi.ShowHelpTopic Method

Public Function ShowHelpTopic()

Source code

[Visual Basic]
    Public Function ShowHelpTopic()
        Help.ShowHelp(DummyControl, MyHelpProvider.HelpNamespace)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi.ShowSearch Method

Public Function ShowSearch()

Source code

[Visual Basic]
    Public Function ShowSearch()
        Help.ShowHelp(DummyControl, MyHelpProvider.HelpNamespace, HelpNavigator.Find, "")
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi.ShowWindow Method

Declare Function ShowWindow Lib "user32.dll" ( _
   ByVal hwnd As Int32, _
   ByVal ByValnCmdShow As Int32 _
) As Int32

Parameters

hwnd
Required.
ByValnCmdShow
Required.

Source code

[Visual Basic]
    Declare Function ShowWindow Lib "user32.dll" (ByVal hwnd As Int32, ByVal ByValnCmdShow As Int32) As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


HHctrlapi Fields

HHctrlapi overview

Fields

field DummyControl
field MyHelpProvider

See Also

HHctrlapi Class


DummyControl Variable

Dim DummyControl As New Control()

Source code

[Visual Basic]
    Dim DummyControl As New Control()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


MyHelpProvider Variable

Dim MyHelpProvider As New HelpProvider()

Source code

[Visual Basic]
    Dim MyHelpProvider As New HelpProvider()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

HHctrlapi


ImageComboBox Class

For a list of all members of this type, see ImageComboBox Members.

System.Object
System.Windows.Forms.ComboBox
EDOKAApp.ImageComboBox

Public Class ImageComboBox
   Inherits ComboBox

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ImageComboBox Members


ImageComboBox Members

ImageComboBox overview

Constructors

constructor ImageComboBox Constructor (Overloaded)

Properties

property ImageIndexMember
property ImageList

Methods

method OnDrawItem

Fields

field _imageList
field _imageindexmember

See Also

ImageComboBox Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByRef cbo As ComboBox)

See Also

ImageComboBox | EDOKAApp


ImageComboBox Properties

ImageComboBox overview

Properties

property ImageIndexMember
property ImageList

See Also

ImageComboBox Class


ImageComboBox.ImageIndexMember Property

Public Property ImageIndexMember() As String

Source code

[Visual Basic]
    Public Property ImageIndexMember() As String
        Get
            Return _imageindexmember
        End Get
        Set(ByVal value As String)
            _imageindexmember = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


ImageComboBox.ImageList Property

Public Property ImageList() As ImageList

Source code

[Visual Basic]
    Public Property ImageList() As ImageList
        Get
            Return _imageList
        End Get
        Set(ByVal value As ImageList)
            _imageList = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


ImageComboBox Methods

ImageComboBox overview

Methods

method OnDrawItem

See Also

ImageComboBox Class


ImageComboBox.OnDrawItem Method

Protected Overrides Sub OnDrawItem( _
   ByVal ea As DrawItemEventArgs _
)

Parameters

ea
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnDrawItem(ByVal ea As DrawItemEventArgs)
        'this replaces the normal drawing of the dropdown list
        ea.DrawBackground()
        ea.DrawFocusRectangle()

        Dim imageSize As Size = ImageList.ImageSize
        Dim bounds As Rectangle = ea.Bounds

        Try
            Dim imageindex As Integer
            Dim display As String
            If Items(ea.Index).GetType Is GetType(Data.DataRowView) Then
                'handle if datarow
                Dim d As Data.DataRowView = CType(Items(ea.Index), Data.DataRowView)
                imageindex = CType(d.Item(Me.ImageIndexMember), Integer)
                display = CType(d.Item(Me.DisplayMember), String)
            Else
                'get the imageindex member from the item object
                imageindex = Items(ea.Index).GetType.GetProperty(Me.ImageIndexMember).GetValue(Items(ea.Index), Nothing)
                'get the display member from the item object
                display = Items(ea.Index).GetType.GetProperty(Me.DisplayMember).GetValue(Items(ea.Index), Nothing)
            End If

            If imageindex <> -1 Then
                'if the imageindex is set then draw the image
                ImageList.Draw(ea.Graphics, bounds.Left, bounds.Top, imageindex)
                ea.Graphics.DrawString(display, ea.Font, New SolidBrush(ea.ForeColor), bounds.Left + imageSize.Width, bounds.Top)
            Else
                'no image just do the text
                ea.Graphics.DrawString(display, ea.Font, New SolidBrush(ea.ForeColor), bounds.Left, bounds.Top)
            End If
        Catch e As Exception
            'handle things like the normal combo and don't use the display or imageindex member properties
            If ea.Index <> -1 Then
                ea.Graphics.DrawString(Items(ea.Index).ToString(), ea.Font, New SolidBrush(ea.ForeColor), bounds.Left, bounds.Top)
            Else
                ea.Graphics.DrawString(Me.Text, ea.Font, New SolidBrush(ea.ForeColor), bounds.Left, bounds.Top)
            End If
        Finally

            MyBase.OnDrawItem(ea)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


ImageComboBox Fields

ImageComboBox overview

Fields

field _imageList
field _imageindexmember

See Also

ImageComboBox Class


_imageList Variable

Private _imageList As ImageList

Source code

[Visual Basic]
    Private _imageList As ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


_imageindexmember Variable

Private _imageindexmember As String

Source code

[Visual Basic]
    Private _imageindexmember As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


ImageLibrary Class

For a list of all members of this type, see ImageLibrary Members.

System.Object
EDOKAApp.ImageLibrary

Public Class ImageLibrary

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ImageLibrary Members


ImageLibrary Members

ImageLibrary overview

Methods

method LoadFromFile

See Also

ImageLibrary Class


ImageLibrary Methods

ImageLibrary overview

Methods

method LoadFromFile

See Also

ImageLibrary Class


ImageLibrary.LoadFromFile Method

Public Function LoadFromFile()

Source code

[Visual Basic]
    Public Function LoadFromFile()
        Globals.DokumentartenImages.Images.Item(1).FromFile("c:\edoka\images\tb.ico")
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageLibrary


ImgGenericList Class

For a list of all members of this type, see ImgGenericList Members.

System.Object
EDOKAApp.ImgGenericList

Public Class ImgGenericList

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ImgGenericList Members


ImgGenericList Members

ImgGenericList overview

Constructors

constructor ImgGenericList Constructor (Overloaded)

Properties

property Display
property ID
property Index

Fields

field _Display
field _ID
field _Index

See Also

ImgGenericList Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal display As String, ByVal id As Integer)

[Visual Basic] Public Sub New(ByVal display As String, ByVal id As Integer, ByVal index As Integer)

See Also

ImgGenericList | EDOKAApp


ImgGenericList Properties

ImgGenericList overview

Properties

property Display
property ID
property Index

See Also

ImgGenericList Class


ImgGenericList.Display Property

Public Property Display() As String

Source code

[Visual Basic]
    Public Property Display() As String
        Get
            Return _Display
        End Get
        Set(ByVal Value As String)
            _Display = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


ImgGenericList.ID Property

Public Property ID() As Integer

Source code

[Visual Basic]
    Public Property ID() As Integer
        Get
            Return _ID
        End Get
        Set(ByVal Value As Integer)
            _ID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


ImgGenericList.Index Property

Public Property Index() As Integer

Source code

[Visual Basic]
    Public Property Index() As Integer
        Get
            Return _Index
        End Get
        Set(ByVal Value As Integer)
            _Index = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


ImgGenericList Fields

ImgGenericList overview

Fields

field _Display
field _ID
field _Index

See Also

ImgGenericList Class


_Display Variable

Private _Display As String

Source code

[Visual Basic]
    Private _Display As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


_ID Variable

Private _ID As Integer

Source code

[Visual Basic]
    Private _ID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


_Index Variable

Private _Index As Integer = -1

Source code

[Visual Basic]
    Private _Index As Integer = -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


KopiefrmInteressent Class

For a list of all members of this type, see KopiefrmInteressent Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.KopiefrmInteressent

Public Class KopiefrmInteressent
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

KopiefrmInteressent Members


KopiefrmInteressent Members

KopiefrmInteressent overview

Constructors

constructor KopiefrmInteressent Constructor

Properties

property Display
property Partnernr

Methods

method Dispose
method InitializeComponent
method Interessent_Load
method btnCancel_Click
method btnClose_Click
method btnSave_Click
method frmInteressent_Closing

Fields

field GroupBox1
field Label1
field Label10
field Label11
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field btnCancel
field btnClose
field btnSave
field components
field m_display
field m_partnernr
field partner
field txtAdresse1
field txtAdresse2
field txtAdresse3
field txtAdresse4
field txtAdresse5
field txtAdresse6
field txtAdresse7
field txtKurzbezeichnung
field txtName
field txtOrt
field txtVorname

See Also

KopiefrmInteressent Class


KopiefrmInteressent Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent Properties

KopiefrmInteressent overview

Properties

property Display
property Partnernr

See Also

KopiefrmInteressent Class


KopiefrmInteressent.Display Property

Property Display() As Boolean

Source code

[Visual Basic]
    Property Display() As Boolean
        Get
            Return m_display
        End Get
        Set(ByVal Value As Boolean)
            m_display = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.Partnernr Property

Property Partnernr() As Long

Source code

[Visual Basic]
    Property Partnernr() As Long
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Long)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent Methods

KopiefrmInteressent overview

Methods

method Dispose
method InitializeComponent
method Interessent_Load
method btnCancel_Click
method btnClose_Click
method btnSave_Click
method frmInteressent_Closing

See Also

KopiefrmInteressent Class


KopiefrmInteressent.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmInteressent))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtName = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtOrt = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.txtKurzbezeichnung = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.txtAdresse7 = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtAdresse6 = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtAdresse5 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.txtAdresse4 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.txtAdresse3 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.txtAdresse2 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.txtAdresse1 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.btnSave = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.txtVorname = New System.Windows.Forms.TextBox()
        Me.btnClose = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(32, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Name / Firma1 "
        '
        'txtName
        '
        Me.txtName.Location = New System.Drawing.Point(136, 24)
        Me.txtName.Name = "txtName"
        Me.txtName.Size = New System.Drawing.Size(160, 20)
        Me.txtName.TabIndex = 1
        Me.txtName.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(32, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(104, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Vorname / Firma 2"
        '
        'txtOrt
        '
        Me.txtOrt.Location = New System.Drawing.Point(136, 72)
        Me.txtOrt.Name = "txtOrt"
        Me.txtOrt.Size = New System.Drawing.Size(160, 20)
        Me.txtOrt.TabIndex = 5
        Me.txtOrt.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(32, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Ort"
        '
        'txtKurzbezeichnung
        '
        Me.txtKurzbezeichnung.Location = New System.Drawing.Point(136, 96)
        Me.txtKurzbezeichnung.Name = "txtKurzbezeichnung"
        Me.txtKurzbezeichnung.Size = New System.Drawing.Size(224, 20)
        Me.txtKurzbezeichnung.TabIndex = 7
        Me.txtKurzbezeichnung.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(32, 96)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(96, 23)
        Me.Label4.TabIndex = 6
        Me.Label4.Text = "Kurzname"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtAdresse7, Me.Label11, Me.txtAdresse6, Me.Label10, Me.txtAdresse5, Me.Label9, Me.txtAdresse4, Me.Label8, Me.txtAdresse3, Me.Label7, Me.txtAdresse2, Me.Label6, Me.txtAdresse1, Me.Label5})
        Me.GroupBox1.Location = New System.Drawing.Point(16, 128)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(344, 192)
        Me.GroupBox1.TabIndex = 8
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zustelladresse"
        '
        'txtAdresse7
        '
        Me.txtAdresse7.Location = New System.Drawing.Point(120, 160)
        Me.txtAdresse7.Name = "txtAdresse7"
        Me.txtAdresse7.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse7.TabIndex = 35
        Me.txtAdresse7.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(16, 160)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 23)
        Me.Label11.TabIndex = 34
        Me.Label11.Text = "Zeile 7"
        '
        'txtAdresse6
        '
        Me.txtAdresse6.Location = New System.Drawing.Point(120, 136)
        Me.txtAdresse6.Name = "txtAdresse6"
        Me.txtAdresse6.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse6.TabIndex = 33
        Me.txtAdresse6.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(16, 136)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(96, 23)
        Me.Label10.TabIndex = 32
        Me.Label10.Text = "Zeile 6"
        '
        'txtAdresse5
        '
        Me.txtAdresse5.Location = New System.Drawing.Point(120, 112)
        Me.txtAdresse5.Name = "txtAdresse5"
        Me.txtAdresse5.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse5.TabIndex = 31
        Me.txtAdresse5.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 112)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(96, 23)
        Me.Label9.TabIndex = 30
        Me.Label9.Text = "Zeile 5"
        '
        'txtAdresse4
        '
        Me.txtAdresse4.Location = New System.Drawing.Point(120, 88)
        Me.txtAdresse4.Name = "txtAdresse4"
        Me.txtAdresse4.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse4.TabIndex = 29
        Me.txtAdresse4.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(16, 88)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 28
        Me.Label8.Text = "Zeile 4"
        '
        'txtAdresse3
        '
        Me.txtAdresse3.Location = New System.Drawing.Point(120, 64)
        Me.txtAdresse3.Name = "txtAdresse3"
        Me.txtAdresse3.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse3.TabIndex = 27
        Me.txtAdresse3.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(16, 64)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 26
        Me.Label7.Text = "Zeile 3"
        '
        'txtAdresse2
        '
        Me.txtAdresse2.Location = New System.Drawing.Point(120, 40)
        Me.txtAdresse2.Name = "txtAdresse2"
        Me.txtAdresse2.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse2.TabIndex = 25
        Me.txtAdresse2.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(16, 40)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(96, 23)
        Me.Label6.TabIndex = 24
        Me.Label6.Text = "Zeile 2"
        '
        'txtAdresse1
        '
        Me.txtAdresse1.Location = New System.Drawing.Point(120, 16)
        Me.txtAdresse1.Name = "txtAdresse1"
        Me.txtAdresse1.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse1.TabIndex = 23
        Me.txtAdresse1.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 16)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(96, 23)
        Me.Label5.TabIndex = 22
        Me.Label5.Text = "Zeile 1"
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(104, 336)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.TabIndex = 9
        Me.btnSave.Text = "&Speichern"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(192, 336)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.TabIndex = 10
        Me.btnCancel.Text = "&Abbruch"
        '
        'txtVorname
        '
        Me.txtVorname.Location = New System.Drawing.Point(136, 48)
        Me.txtVorname.Name = "txtVorname"
        Me.txtVorname.Size = New System.Drawing.Size(160, 20)
        Me.txtVorname.TabIndex = 3
        Me.txtVorname.Text = ""
        '
        'btnClose
        '
        Me.btnClose.Location = New System.Drawing.Point(144, 336)
        Me.btnClose.Name = "btnClose"
        Me.btnClose.TabIndex = 11
        Me.btnClose.Text = "&Schliessen"
        '
        'frmInteressent
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(376, 373)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnClose, Me.btnCancel, Me.btnSave, Me.GroupBox1, Me.txtKurzbezeichnung, Me.Label4, Me.txtOrt, Me.Label3, Me.txtVorname, Me.Label2, Me.txtName, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmInteressent"
        Me.Text = "Partner eröffnen / bearbeiten"
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.Interessent_Load Method

Private Sub Interessent_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Interessent_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim partner As New edokadb.clsPartner()
        If Me.Partnernr > 0 Then
            partner.cpMainConnectionProvider = conn
            partner.iNRPAR00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.SelectOne()
            Me.txtName.Text = partner.sTXADZ011.Value
            Me.txtVorname.Text = partner.sTXADZ021.Value
            Me.txtOrt.Text = partner.sTXADZ031.Value
            Me.txtAdresse1.Text = partner.sTXADZ012.Value
            Me.txtAdresse2.Text = partner.sTXADZ022.Value
            Me.txtAdresse3.Text = partner.sTXADZ032.Value
            Me.txtAdresse4.Text = partner.sTXADZ042.Value
            Me.txtAdresse5.Text = partner.sTXADZ052.Value
            Me.txtAdresse6.Text = partner.sTXADZ062.Value
            Me.txtAdresse7.Text = partner.sTXADZ072.Value
            Me.txtKurzbezeichnung.Text = partner.sBKPAR00.Value
        End If
        If Me.Display = True Then
            Me.btnCancel.Visible = False
            Me.btnSave.Visible = False
            Me.btnClose.Visible = True
        Else
            Me.btnCancel.Visible = True
            Me.btnSave.Visible = True
            Me.btnClose.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.btnClose_Click Method

Private Sub btnClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.btnSave_Click Method

Private Sub btnSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        partner.cpMainConnectionProvider = conn
        If Me.Partnernr = 0 Then
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("Interessent")

        Else
            partner.iNRPAR00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.SelectOne()
        End If
        conn.OpenConnection()
        partner.sBKPAR00 = New SqlString(CType(Me.txtKurzbezeichnung.Text, String))
        partner.sTXADZ011 = New SqlString(CType(Me.txtAdresse1.Text, String))
        partner.sTXADZ021 = New SqlString(CType(Me.txtAdresse2.Text, String))
        partner.sTXADZ031 = New SqlString(CType(Me.txtAdresse3.Text, String))
        partner.sTXADZ041 = New SqlString(CType(Me.txtAdresse4.Text, String))
        partner.sTXADZ051 = New SqlString(CType(Me.txtAdresse5.Text, String))
        partner.sTXADZ061 = New SqlString(CType(Me.txtAdresse6.Text, String))
        partner.sTXADZ071 = New SqlString(CType(Me.txtAdresse7.Text, String))
        partner.sTXADZ012 = New SqlString(CType(Me.txtName.Text, String))
        partner.sTXADZ022 = New SqlString(CType(Me.txtVorname.Text, String))
        partner.sTXADZ032 = New SqlString(CType(Me.txtOrt.Text, String))
        partner.sNRADR00 = New SqlString(CType("", String))
        If Me.Partnernr = 0 Then
            partner.iNRPAR00 = New SqlInt32(CType(key, Int32))
            partner.Insert()
            Me.Partnernr = key
        Else
            partner.Update()
        End If
        conn.CloseConnection(True)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent.frmInteressent_Closing Method

Private Sub frmInteressent_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmInteressent_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        partner.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


KopiefrmInteressent Fields

KopiefrmInteressent overview

Fields

field GroupBox1
field Label1
field Label10
field Label11
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field btnCancel
field btnClose
field btnSave
field components
field m_display
field m_partnernr
field partner
field txtAdresse1
field txtAdresse2
field txtAdresse3
field txtAdresse4
field txtAdresse5
field txtAdresse6
field txtAdresse7
field txtKurzbezeichnung
field txtName
field txtOrt
field txtVorname

See Also

KopiefrmInteressent Class


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


m_display Variable

Dim m_display As Boolean

Source code

[Visual Basic]
    Dim m_display As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


m_partnernr Variable

Dim m_partnernr As Long

Source code

[Visual Basic]
    Dim m_partnernr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


partner Variable

Dim partner As New edokadb.clsPartner()

Source code

[Visual Basic]
    Dim partner As New edokadb.clsPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse1 Variable

Friend WithEvents txtAdresse1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse2 Variable

Friend WithEvents txtAdresse2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse3 Variable

Friend WithEvents txtAdresse3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse4 Variable

Friend WithEvents txtAdresse4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse5 Variable

Friend WithEvents txtAdresse5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse6 Variable

Friend WithEvents txtAdresse6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtAdresse7 Variable

Friend WithEvents txtAdresse7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtKurzbezeichnung Variable

Friend WithEvents txtKurzbezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtKurzbezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtName Variable

Friend WithEvents txtName As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtName As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtOrt Variable

Friend WithEvents txtOrt As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtOrt As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


txtVorname Variable

Friend WithEvents txtVorname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtVorname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

KopiefrmInteressent


MultiComboBox Class

For a list of all members of this type, see MultiComboBox Members.

System.Object
System.Windows.Forms.ComboBox
EDOKAApp.MultiComboBox

Public Class MultiComboBox
   Inherits Windows.Forms.ComboBox

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

MultiComboBox Members


MultiComboBox Members

MultiComboBox overview

Constructors

constructor MultiComboBox Constructor (Overloaded)

Properties

property CheckNullValue
property Columns
property DisplayColumnName
property ImageIndexMember
property ImageList
property NoValue
property NullValueMessage
property ShowColumnHeader
property ShowColumns
property ValueColumnName

Methods

method AutoCompleteCombo_Leave
method ComboBoxAutoComplete
method Fill_Data (Overloaded)
method Me_KeyPress
method MultiComboBox_Leave
method MultiComboBox_TextChanged
method OnDrawItem
method OnKeyDown
method OnKeyPress
method OnKeyUp
method OnLeave
method OnLostFocus

Classes

class Column
class ColumnCollection

Fields

field _CheckNullValue
field _DisplayColumnName
field _NoValue
field _NulLValueMessage
field _ValueColumnName
field _columns
field _imageList
field _imageindexmember
field _showColumnHeaders
field _showColumns
field pressedkey

See Also

MultiComboBox Class


Column Class

For a list of all members of this type, see Column Members.

System.Object
EDOKAApp.MultiComboBox.Column

Public Class Column

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Column Members | MultiComboBox


Column Members

Column overview

Constructors

constructor Column Constructor (Overloaded)

Properties

property ColumnMember
property Header
property Width

Fields

field _ColumnMember
field _Header
field _Width

See Also

Column Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal width As Integer, ByVal columnmember As String)

[Visual Basic] Public Sub New(ByVal width As Integer, ByVal columnmember As String, ByVal header As String)

See Also

Column | EDOKAApp


Column Properties

Column overview

Properties

property ColumnMember
property Header
property Width

See Also

Column Class


Column.ColumnMember Property

Public Property ColumnMember() As String

Source code

[Visual Basic]
        Public Property ColumnMember() As String
            Get
                Return _ColumnMember
            End Get
            Set(ByVal Value As String)
                _ColumnMember = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


Column.Header Property

Public Property Header() As String

Source code

[Visual Basic]
        Public Property Header() As String
            Get
                Return _Header
            End Get
            Set(ByVal Value As String)
                _Header = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


Column.Width Property

Public Property Width() As Integer

Source code

[Visual Basic]
        Public Property Width() As Integer
            Get
                Return _Width
            End Get
            Set(ByVal Value As Integer)
                _Width = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


Column Fields

Column overview

Fields

field _ColumnMember
field _Header
field _Width

See Also

Column Class


_ColumnMember Variable

Private _ColumnMember As String

Source code

[Visual Basic]
        Private _ColumnMember As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


_Header Variable

Private _Header As String

Source code

[Visual Basic]
        Private _Header As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


_Width Variable

Private _Width As Integer

Source code

[Visual Basic]
        Private _Width As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


ColumnCollection Class

For a list of all members of this type, see ColumnCollection Members.

System.Object
EDOKAApp.MultiComboBox.ColumnCollection

Public Class ColumnCollection
   Implements IEnumerable

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ColumnCollection Members | MultiComboBox


ColumnCollection Members

ColumnCollection overview

Constructors

constructor ColumnCollection Constructor

Properties

property Count
property Item (Overloaded)

Methods

method Add
method Clear
method Contains
method GetEnumerator
method Remove (Overloaded)

Fields

field _Col

See Also

ColumnCollection Class


ColumnCollection Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            MyBase.new()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection Properties

ColumnCollection overview

Properties

property Count
property Item (Overloaded)

See Also

ColumnCollection Class


ColumnCollection.Count Property

Public ReadOnly Property Count() As Integer

Source code

[Visual Basic]
        Public ReadOnly Property Count() As Integer
            Get
                Return _Col.Count
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


Item Property

Overload List

[Visual Basic] Default Public ReadOnly Property Item(ByVal Index As Integer) As Column

[Visual Basic] Default Public ReadOnly Property Item(ByVal Key As String) As Column

See Also

ColumnCollection | EDOKAApp


ColumnCollection Methods

ColumnCollection overview

Methods

method Add
method Clear
method Contains
method GetEnumerator
method Remove (Overloaded)

See Also

ColumnCollection Class


ColumnCollection.Add Method

Public Function Add( _
   ByVal NewItem As Column, _
   Optional ByVal Key As String = Nothing _
) As Column

Parameters

NewItem
Required.
Key
Optional. Default value is Nothing.

Source code

[Visual Basic]
        Public Function Add(ByVal NewItem As Column, Optional ByVal Key As String = Nothing) As Column
            If Key Is Nothing Then
                _Col.Add(NewItem)
            Else
                _Col.Add(NewItem, Key)
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection.Clear Method

Public Sub Clear()

Source code

[Visual Basic]
        Public Sub Clear()
            Dim cnt As Integer
            Dim cntMax As Integer

            cntMax = _Col.Count
            For cnt = cntMax To 1 Step -1
                _Col.Remove(cnt)
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection.Contains Method

Public Function Contains( _
   ByVal Key As String _
) As Boolean

Parameters

Key
Required.

Source code

[Visual Basic]
        Public Function Contains(ByVal Key As String) As Boolean
            Try
                Dim obj As Object = _Col(Key)
                Return True
            Catch ex As Exception
                Return False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection.GetEnumerator Method

Public Function GetEnumerator() As System.Collections.IEnumerator Implements System.Collections.IEnumerable.GetEnumerator

Source code

[Visual Basic]
        Public Function GetEnumerator() As System.Collections.IEnumerator Implements System.Collections.IEnumerable.GetEnumerator
            Return _Col.GetEnumerator
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


Remove Method

Overload List

[Visual Basic] Public Sub Remove(ByVal Index As Integer)

[Visual Basic] Public Sub Remove(ByVal Key As String)

See Also

ColumnCollection | EDOKAApp


ColumnCollection Fields

ColumnCollection overview

Fields

field _Col

See Also

ColumnCollection Class


_Col Variable

Private _Col As New Collection()

Source code

[Visual Basic]
        Private _Col As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByRef cbo As ComboBox)

See Also

MultiComboBox | EDOKAApp


MultiComboBox Properties

MultiComboBox overview

Properties

property CheckNullValue
property Columns
property DisplayColumnName
property ImageIndexMember
property ImageList
property NoValue
property NullValueMessage
property ShowColumnHeader
property ShowColumns
property ValueColumnName

See Also

MultiComboBox Class


MultiComboBox.CheckNullValue Property

Public Property CheckNullValue() As Boolean

Source code

[Visual Basic]
    Public Property CheckNullValue() As Boolean
        Get
            Return _CheckNullValue
        End Get
        Set(ByVal Value As Boolean)
            _CheckNullValue = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.Columns Property

Public ReadOnly Property Columns() As ColumnCollection

Source code

[Visual Basic]
    Public ReadOnly Property Columns() As ColumnCollection
        Get
            Return _columns
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.DisplayColumnName Property

Property DisplayColumnName() As String

Source code

[Visual Basic]
    Property DisplayColumnName() As String
        Get
            Return _DisplayColumnName
        End Get
        Set(ByVal Value As String)
            _DisplayColumnName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ImageIndexMember Property

Public Property ImageIndexMember() As String

Source code

[Visual Basic]
    Public Property ImageIndexMember() As String
        Get
            Return _imageindexmember
        End Get
        Set(ByVal value As String)
            _imageindexmember = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ImageList Property

Public Property ImageList() As ImageList

Source code

[Visual Basic]
    Public Property ImageList() As ImageList
        Get
            Return _imageList
        End Get
        Set(ByVal value As ImageList)
            _imageList = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.NoValue Property

Property NoValue() As Boolean

Source code

[Visual Basic]
    Property NoValue() As Boolean
        Get
            Return _NoValue
        End Get
        Set(ByVal Value As Boolean)
            _NoValue = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.NullValueMessage Property

Public Property NullValueMessage() As String

Source code

[Visual Basic]
    Public Property NullValueMessage() As String
        Get
            Return _NulLValueMessage
        End Get
        Set(ByVal Value As String)
            _NulLValueMessage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ShowColumnHeader Property

Public Property ShowColumnHeader() As Boolean

Source code

[Visual Basic]
    Public Property ShowColumnHeader() As Boolean
        Get
            Return _showColumnHeaders
        End Get
        Set(ByVal value As Boolean)
            _showColumnHeaders = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ShowColumns Property

Public Property ShowColumns() As Boolean

Source code

[Visual Basic]
    Public Property ShowColumns() As Boolean
        Get
            Return _showColumns
        End Get
        Set(ByVal value As Boolean)
            _showColumns = value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ValueColumnName Property

Property ValueColumnName() As String

Source code

[Visual Basic]
    Property ValueColumnName() As String
        Get
            Return _ValueColumnName
        End Get
        Set(ByVal Value As String)
            _ValueColumnName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox Methods

MultiComboBox overview

Methods

method AutoCompleteCombo_Leave
method ComboBoxAutoComplete
method Fill_Data (Overloaded)
method Me_KeyPress
method MultiComboBox_Leave
method MultiComboBox_TextChanged
method OnDrawItem
method OnKeyDown
method OnKeyPress
method OnKeyUp
method OnLeave
method OnLostFocus

See Also

MultiComboBox Class


MultiComboBox.AutoCompleteCombo_Leave Method

Public Sub AutoCompleteCombo_Leave( _
   ByVal cbo As ComboBox _
)

Parameters

cbo
Required.

Source code

[Visual Basic]
    Public Sub AutoCompleteCombo_Leave(ByVal cbo As ComboBox)
        Dim iFoundIndex As Integer
        iFoundIndex = cbo.FindStringExact(cbo.Text)
        cbo.SelectedIndex = iFoundIndex
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.ComboBoxAutoComplete Method

Private Sub ComboBoxAutoComplete( _
   ByVal combo As ComboBox, _
   ByVal str As String _
)

Parameters

combo
Required.
str
Required.

Source code

[Visual Basic]
    Private Sub ComboBoxAutoComplete(ByVal combo As ComboBox, ByVal str As String)
        Dim index As Integer
        If str.Length = 0 Then
            combo.SelectedIndex = -1
            combo.Text = ""
        Else
            index = combo.FindString(str)
            If index <> -1 Then
                combo.SelectedIndex = index
                combo.SelectionStart = str.Length
                combo.SelectionLength = combo.Text.Length - combo.SelectionStart
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


Fill_Data Method

Overload List

[Visual Basic] Public Sub Fill_Data(ByVal da As DataTable, ByVal addblankrow As Boolean)

[Visual Basic] Public Sub Fill_Data(ByVal da As DataTable, ByVal addblankrow As Boolean, ByVal blankrowtext As String)

See Also

MultiComboBox | EDOKAApp


MultiComboBox.Me_KeyPress Method

Private Sub Me_KeyPress( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles MyBase.KeyUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Me_KeyPress(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles MyBase.KeyUp

        'Dim FindString As String
        'Dim ipos As Integer = Me.SelectionStart
        'If e.KeyCode.ToString.Length > 1 And e.KeyCode <> Keys.Escape And e.KeyCode <> Keys.Back Then
        '    e.Handled = True
        '    Exit Sub
        'End If

        'If e.KeyCode = Keys.Escape Then
        '    Me.SelectedIndex = -1
        '    Me.Text = ""
        'ElseIf e.KeyCode = Keys.Back Then
        '    Me.SelectedIndex = -1
        '    Me.Text = ""
        'Else
        '    ComboBoxAutoComplete(Me, Me.Text.Substring(0, ipos))
        'End If
        'e.Handled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.MultiComboBox_Leave Method

Public Sub MultiComboBox_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub MultiComboBox_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Leave
        Dim swert As String
        swert = Me.SelectedValue
        If Me.CheckNullValue = True Then
            If swert = "" Or swert Is System.DBNull.Value Then
                MsgBox(Me.NullValueMessage, MsgBoxStyle.Exclamation)
                Me.Focus()
                Me.NoValue = True
                Exit Sub
            End If
        End If
        Me.NoValue = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.MultiComboBox_TextChanged Method

Private Sub MultiComboBox_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MultiComboBox_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.TextChanged
        'Selecting the item which text is showed in the text area of the ComboBox
        Dim iFoundIndex As Integer
        'The Me.AccessibilityObject.Value is used instead of Me.Text to manage
        'the event when you write in the combobox text and the DropDownList
        'is open. In this case, if you click outside the combo, Me.Text mantains
        'the old value and not the current one
        iFoundIndex = Me.FindStringExact(Me.Text)
        Me.SelectedIndex = iFoundIndex

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnDrawItem Method

Protected Overrides Sub OnDrawItem( _
   ByVal ea As DrawItemEventArgs _
)

Parameters

ea
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnDrawItem(ByVal ea As DrawItemEventArgs)
        ea.DrawBackground()
        ea.DrawFocusRectangle()

        Dim iwidth As Integer = 0

        Try
            Dim imageindex As Integer = -1
            Dim imageSize As Size = ImageList.ImageSize
            imageindex = Items(ea.Index).GetType.GetProperty(Me.ImageIndexMember).GetValue(Items(ea.Index), Nothing)
            ImageList.Draw(ea.Graphics, ea.Bounds.Left, ea.Bounds.Top, imageindex)
            iwidth = imageSize.Width
        Catch exi As Exception
        End Try

        Try
            If ea.Index <> -1 Then
                If _showColumns Then
                    Dim col As Column
                    Dim cnt As Integer
                    For Each col In Me.Columns
                        cnt += 1

                        Static prevWidth As Integer
                        If cnt = 1 Then prevWidth = ea.Bounds.X
                        Dim useX As Integer = ea.Bounds.X + col.Width
                        Dim useY As Integer = ea.Bounds.Y + ea.Bounds.Height
                        Dim display As String
                        Try
                            If Items(ea.Index).GetType Is GetType(Data.DataRowView) Then
                                Dim d As Data.DataRowView = CType(Items(ea.Index), Data.DataRowView)
                                display = CType(d.Item(col.ColumnMember), String)
                            Else
                                display = CType(Items(ea.Index).GetType.GetProperty(col.ColumnMember).GetValue(Items(ea.Index), Nothing), String)
                            End If
                        Catch ext As Exception
                            display = Items(ea.Index).ToString()
                        End Try
                        Dim rectf As New RectangleF((ea.Bounds.X + prevWidth) + iwidth, ea.Bounds.Y, useX, ea.Bounds.Height)
                        ea.Graphics.DrawString(display, ea.Font, New SolidBrush(ea.ForeColor), rectf)
                        If cnt > 1 Then
                            ea.Graphics.DrawLine(System.Drawing.Pens.LightGray, prevWidth + iwidth, ea.Bounds.Y, prevWidth + iwidth, useY)
                        End If
                        prevWidth += col.Width
                    Next
                Else
                    Dim display As String
                    Try
                        display = CType(Items(ea.Index).GetType.GetProperty(Me.DisplayMember).GetValue(Items(ea.Index), Nothing), String)
                    Catch ext As Exception
                        display = Items(ea.Index).ToString()
                    End Try
                    ea.Graphics.DrawString(display, ea.Font, New SolidBrush(ea.ForeColor), ea.Bounds.Left + iwidth, ea.Bounds.Top)
                End If
            Else
                ea.Graphics.DrawString(Me.Text, ea.Font, New SolidBrush(ea.ForeColor), Bounds.Left, Bounds.Top)
            End If
        Catch ex As Exception
            ea.Graphics.DrawString(Me.Text, ea.Font, New SolidBrush(ea.ForeColor), Bounds.Left, Bounds.Top)
        End Try

        MyBase.OnDrawItem(ea)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnKeyDown Method

Protected Overrides Sub OnKeyDown( _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnKeyDown(ByVal e As System.Windows.Forms.KeyEventArgs)
        If Me.DropDownStyle = ComboBoxStyle.DropDownList AndAlso e.KeyCode = Keys.Delete Then
            If Me.Text <> Me.SelectedText Then
                e.Handled = True
            End If
        End If

        MyBase.OnKeyDown(e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnKeyPress Method

Protected Overrides Sub OnKeyPress( _
   ByVal e As System.Windows.Forms.KeyPressEventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnKeyPress(ByVal e As System.Windows.Forms.KeyPressEventArgs)
        'AUTOCOMPLETE: we have to know when a key has been really pressed

        If Me.DropDownStyle = ComboBoxStyle.DropDown Then
            pressedkey = True
        Else
            'ReadOnly AutoComplete Management
            Dim sTypedText As String
            Dim iFoundIndex As Integer
            Dim currentText As String
            Dim Start, selLength As Integer

            If Asc(e.KeyChar) = 8 Then
                If Me.SelectedText = Me.Text Then
                    pressedkey = True
                    Exit Sub
                End If
            End If
            If Me.SelectionLength > 0 Then
                Start = Me.SelectionStart
                selLength = Me.SelectionLength

                'This is equivalent to Me.Text, but sometimes using Me.Text it doesn't work
                currentText = Me.Text

                currentText = currentText.Remove(Start, selLength)
                currentText = currentText.Insert(Start, e.KeyChar)
                sTypedText = currentText
            Else
                Start = Me.SelectionStart
                sTypedText = Me.Text.Insert(Start, e.KeyChar)
            End If
            iFoundIndex = Me.FindString(sTypedText)
            If (iFoundIndex >= 0) Then
                pressedkey = True
            Else
                e.Handled = True
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnKeyUp Method

Protected Overrides Sub OnKeyUp( _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnKeyUp(ByVal e As System.Windows.Forms.KeyEventArgs)
        'AUTOCOMPLETING

        'WARNING: With VB.Net 2003 there is a strange behaviour. This event is raised not just when any key is pressed
        'but also when the Me.Text property changes. Particularly, it happens when you write in a fast way (for example you
        'you press 2 keys and the event is raised 3 times). To manage this we have added a boolean variable PressedKey that
        'is set to true in the OnKeyPress Event

        Dim sTypedText As String
        Dim iFoundIndex As Integer
        Dim oFoundItem As Object
        Dim sFoundText As String
        Dim sAppendText As String

        If PressedKey Then
            'Ignoring alphanumeric chars
            Select Case e.KeyCode
                Case Keys.Back, Keys.Left, Keys.Right, Keys.Up, Keys.Delete, Keys.Down, Keys.End, Keys.Home
                    Return
            End Select

            'Get the Typed Text and Find it in the list
            sTypedText = Me.Text
            iFoundIndex = Me.FindString(sTypedText)

            'If we found the Typed Text in the list then Autocomplete
            If iFoundIndex >= 0 Then

                'Get the Item from the list (Return Type depends if Datasource was bound
                ' or List Created)
                oFoundItem = Me.Items(iFoundIndex)

                'Use the ListControl.GetItemText to resolve the Name in case the Combo
                ' was Data bound
                sFoundText = Me.GetItemText(oFoundItem)

                'Append then found text to the typed text to preserve case
                sAppendText = sFoundText.Substring(sTypedText.Length)
                Me.Text = sTypedText & sAppendText

                'Select the Appended Text
                Me.SelectionStart = sTypedText.Length
                Me.SelectionLength = sAppendText.Length

                If e.KeyCode = Keys.Enter Then
                    iFoundIndex = Me.FindStringExact(Me.Text)
                    Me.SelectedIndex = iFoundIndex
                    SendKeys.Send(vbTab)
                    e.Handled = True
                End If
            End If

        End If
        pressedkey = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnLeave Method

Protected Overrides Sub OnLeave( _
   ByVal e As System.EventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnLeave(ByVal e As System.EventArgs)
        'Selecting the item which text is showed in the text area of the ComboBox
        Dim iFoundIndex As Integer
        'The Me.AccessibilityObject.Value is used instead of Me.Text to manage
        'the event when you write in the combobox text and the DropDownList
        'is open. In this case, if you click outside the combo, Me.Text mantains
        'the old value and not the current one
        iFoundIndex = Me.FindStringExact(Me.Text)
        Me.SelectedIndex = iFoundIndex
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.OnLostFocus Method

Protected Overrides Sub OnLostFocus( _
   ByVal e As System.EventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnLostFocus(ByVal e As System.EventArgs)
        'Selecting the item which text is showed in the text area of the ComboBox
        Dim iFoundIndex As Integer
        'The Me.AccessibilityObject.Value is used instead of Me.Text to manage
        'the event when you write in the combobox text and the DropDownList
        'is open. In this case, if you click outside the combo, Me.Text mantains
        'the old value and not the current one
        iFoundIndex = Me.FindStringExact(Me.Text)
        Me.SelectedIndex = iFoundIndex

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox Fields

MultiComboBox overview

Fields

field _CheckNullValue
field _DisplayColumnName
field _NoValue
field _NulLValueMessage
field _ValueColumnName
field _columns
field _imageList
field _imageindexmember
field _showColumnHeaders
field _showColumns
field pressedkey

See Also

MultiComboBox Class


_CheckNullValue Variable

Private _CheckNullValue As Boolean = False

Source code

[Visual Basic]
    Private _CheckNullValue As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_DisplayColumnName Variable

Private _DisplayColumnName As String

Source code

[Visual Basic]
    Private _DisplayColumnName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_NoValue Variable

Private _NoValue As Boolean

Source code

[Visual Basic]
    Private _NoValue As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_NulLValueMessage Variable

Private _NulLValueMessage As String = ""

Source code

[Visual Basic]
    Private _NulLValueMessage As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_ValueColumnName Variable

Private _ValueColumnName As String

Source code

[Visual Basic]
    Private _ValueColumnName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_columns Variable

Private _columns As New ColumnCollection()

Source code

[Visual Basic]
    Private _columns As New ColumnCollection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_imageList Variable

Private _imageList As ImageList

Source code

[Visual Basic]
    Private _imageList As ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_imageindexmember Variable

Private _imageindexmember As String

Source code

[Visual Basic]
    Private _imageindexmember As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_showColumnHeaders Variable

Private _showColumnHeaders As Boolean = False

Source code

[Visual Basic]
    Private _showColumnHeaders As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


_showColumns Variable

Private _showColumns As Boolean = False

Source code

[Visual Basic]
    Private _showColumns As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


pressedkey Variable

Dim pressedkey As Boolean = False

Source code

[Visual Basic]
    Dim pressedkey As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


OwnerMenu Class

For a list of all members of this type, see OwnerMenu Members.

System.Object
EDOKAApp.OwnerMenu

Public Class OwnerMenu

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

OwnerMenu Members


OwnerMenu Members

OwnerMenu overview

Constructors

constructor OwnerMenu Constructor (Overloaded)

Methods

method Add (Overloaded)
method DoDraw
method DoMeasure
method DrawItemHandler
method MesaureItemHandler

Fields

field _Font
field _MenuItems
field _TextColor

See Also

OwnerMenu Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal Font As System.Drawing.Font)

[Visual Basic] Public Sub New(ByVal Font As System.Drawing.Font, ByVal TextColor As System.Drawing.Color)

[Visual Basic] Public Sub New(ByVal TextColor As System.Drawing.Color)

See Also

OwnerMenu | EDOKAApp


OwnerMenu Methods

OwnerMenu overview

Methods

method Add (Overloaded)
method DoDraw
method DoMeasure
method DrawItemHandler
method MesaureItemHandler

See Also

OwnerMenu Class


Add Method

Overload List

[Visual Basic] Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, ByVal Bitmap As System.Drawing.Bitmap, ByVal MenuItemNumber As Integer, ByVal IsSeperator As Boolean)

[Visual Basic] Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, ByVal Icon As System.Drawing.Icon, ByVal MenuItemNumber As Integer, ByVal IsSeperator As Boolean)

[Visual Basic] Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, ByVal Icon As System.Drawing.Icon, ByVal MenuItemNumber As Integer, ByVal IsSeperator As Boolean, ByVal Font As System.Drawing.Font)

[Visual Basic] Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, ByVal Icon As System.Drawing.Icon, ByVal MenuItemNumber As Integer, ByVal IsSeperator As Boolean, ByVal Font As System.Drawing.Font, ByVal TextColor As System.Drawing.Color)

See Also

OwnerMenu | EDOKAApp


OwnerMenu.DoDraw Method

Private Sub DoDraw( _
   ByVal LI As LocalMenuItem, _
   ByRef e As System.Windows.Forms.DrawItemEventArgs _
)

Parameters

LI
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DoDraw(ByVal LI As LocalMenuItem, _
      ByRef e As System.Windows.Forms.DrawItemEventArgs)
        e.DrawBackground()
        Const LastLeftPosition As Integer = 2
        Const ICONWIDTH As Integer = ICONSIZE16
        Dim ThisMenuItem As MenuItem = LI.MenuItem
        Dim MenuItemGraphics As Graphics = e.Graphics
        Dim bBypassString As Boolean
        'set size and textpoint for our text
        Dim SizeF As SizeF = e.Graphics.MeasureString(LI.MenuItem.Text, _Font)
        Dim TextPoint As PointF = New PointF(LI.TextLeft, _
        LI.TextTopPosition + ((NORMALITEMHEIGHT - SizeF.Height) / 2))
        Dim RectHeight As Integer = SizeF.Height
        If Not LI.Icon Is Nothing Then
            'draw the icon
            MenuItemGraphics.DrawIcon(New Icon(LI.Icon, _
          ICONSIZE16, ICONSIZE16), LI.IconRectangle)
        ElseIf LI.IsSeperator Then
            'draw the separator
            MenuItemGraphics.DrawLine(New Pen(LI.TextColor, 1), _
          TextPoint.X, TextPoint.Y + 11, _
          TextPoint.X + LI.Width + EXTRAWIDTH, TextPoint.Y + 11)
            bBypassString = True
        End If
        If Not bBypassString Then
            'bypass string if separator
            'draw differently if enabled/dsabled
            If LI.MenuItem.Enabled Then
                MenuItemGraphics.DrawString(Replace(LI.MenuItem.Text, "&", ""), _
          LI.Font, New SolidBrush(LI.TextColor), TextPoint)
            Else
                MenuItemGraphics.DrawString(Replace(LI.MenuItem.Text, "&", ""), _
          LI.Font, New SolidBrush(Drawing.SystemColors.GrayText), TextPoint)
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.DoMeasure Method

Private Sub DoMeasure( _
   ByVal LI As LocalMenuItem, _
   ByRef e As System.Windows.Forms.MeasureItemEventArgs _
)

Parameters

LI
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DoMeasure(ByVal LI As LocalMenuItem, _
      ByRef e As System.Windows.Forms.MeasureItemEventArgs)
        'calculate the size of the drawing area
        Dim ThisMenuItem_Strings As String() = LI.MenuItem.Text.Split(",")
        Dim TextSize As SizeF = e.Graphics.MeasureString( _
        ThisMenuItem_Strings(0).Replace("&", ""), LI.Font)
        e.ItemWidth = TextSize.Width + EXTRAWIDTH
        If LI.MenuItem.Text = "-" Then
            e.ItemHeight = SEPITEMHEIGHT
        Else
            e.ItemHeight = NORMALITEMHEIGHT
        End If
        LI.Height = e.ItemHeight
        LI.Width = e.ItemWidth
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.DrawItemHandler Method

Public Sub DrawItemHandler( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DrawItemEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub DrawItemHandler(ByVal sender As Object, _
      ByVal e As System.Windows.Forms.DrawItemEventArgs)
        'look through the items and find out which one we are drawing
        Dim li As LocalMenuItem
        For Each li In _MenuItems
            If li.MenuItem Is sender Then
                DoDraw(li, e)
                Exit For
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.MesaureItemHandler Method

Public Sub MesaureItemHandler( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MeasureItemEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub MesaureItemHandler(ByVal sender As Object, _
      ByVal e As System.Windows.Forms.MeasureItemEventArgs)
        'look through the items and find out which one we are measuring
        Dim li As LocalMenuItem
        For Each li In _MenuItems
            If li.MenuItem Is sender Then
                DoMeasure(li, e)
                Exit For
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu Fields

OwnerMenu overview

Fields

field _Font
field _MenuItems
field _TextColor

See Also

OwnerMenu Class


_Font Variable

Private _Font As Font = SystemInformation.MenuFont

Source code

[Visual Basic]
        Private _Font As Font = SystemInformation.MenuFont

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


_MenuItems Variable

Private _MenuItems As New ArrayList()

Source code

[Visual Basic]
    Private _MenuItems As New ArrayList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


_TextColor Variable

Private _TextColor As Color = System.Drawing.SystemColors.MenuText

Source code

[Visual Basic]
        Private _TextColor As Color = System.Drawing.SystemColors.MenuText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


RichTextBoxEx Class

For a list of all members of this type, see RichTextBoxEx Members.

System.Object
System.Windows.Forms.RichTextBox
EDOKAApp.RichTextBoxEx

Public Class RichTextBoxEx
   Inherits RichTextBox

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

RichTextBoxEx Members


RichTextBoxEx Members

RichTextBoxEx overview

Constructors

constructor RichTextBoxEx Constructor

Methods

method FormatRange
method FormatRangeDone
method HundredthInchToTwips
method SendMessage
method SetSelectionBold
method SetSelectionFont
method SetSelectionItalic
method SetSelectionSize
method SetSelectionStyle
method SetSelectionUnderlined

Fields

field SCF_ALL
field SCF_SELECTION
field SCF_WORD

See Also

RichTextBoxEx Class


RichTextBoxEx Constructor

Public Sub New( _
   ByRef cbo As RichTextBox _
)

Parameters

cbo
Required.

Source code

[Visual Basic]
    Public Sub New(ByRef cbo As RichTextBox)
        Me.Anchor = cbo.Anchor
        Me.BackColor = cbo.BackColor
        Me.BackgroundImage = cbo.BackgroundImage
        Me.CausesValidation = cbo.CausesValidation
        Me.ContextMenu = cbo.ContextMenu
        Me.Dock = cbo.Dock
        Me.Enabled = cbo.Enabled
        Me.Font = cbo.Font
        Me.ForeColor = cbo.ForeColor
        Me.MaxLength = cbo.MaxLength
        Me.Text = cbo.Text
        Me.TabStop = cbo.TabStop
        Me.Visible = cbo.Visible
        Me.Location = cbo.Location
        Me.Size = cbo.Size
        Me.TabIndex = cbo.TabIndex
        Dim parent As Object = cbo.Parent
        parent.Controls.Remove(cbo)
        parent.Controls.Add(Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx Methods

RichTextBoxEx overview

Methods

method FormatRange
method FormatRangeDone
method HundredthInchToTwips
method SendMessage
method SetSelectionBold
method SetSelectionFont
method SetSelectionItalic
method SetSelectionSize
method SetSelectionStyle
method SetSelectionUnderlined

See Also

RichTextBoxEx Class


RichTextBoxEx.FormatRange Method

Public Function FormatRange( _
   ByVal measureOnly As Boolean, _
   ByVal e As PrintPageEventArgs, _
   ByVal charFrom As Integer, _
   ByVal charTo As Integer _
) As Integer

Parameters

measureOnly
Required.
e
Required.
charFrom
Required.
charTo
Required.

Source code

[Visual Basic]
    Public Function FormatRange(ByVal measureOnly As Boolean, _
                                ByVal e As PrintPageEventArgs, _
                                ByVal charFrom As Integer, _
                                ByVal charTo As Integer) As Integer
        ' Specify which characters to print
        Dim cr As STRUCT_CHARRANGE
        cr.cpMin = charFrom
        cr.cpMax = charTo

        ' Specify the area inside page margins
        Dim rc As STRUCT_RECT
        rc.top = HundredthInchToTwips(e.MarginBounds.Top)
        rc.bottom = HundredthInchToTwips(e.MarginBounds.Bottom)
        rc.left = HundredthInchToTwips(e.MarginBounds.Left)
        rc.right = HundredthInchToTwips(e.MarginBounds.Right)

        ' Specify the page area
        Dim rcPage As STRUCT_RECT
        rcPage.top = HundredthInchToTwips(e.PageBounds.Top)
        rcPage.bottom = HundredthInchToTwips(e.PageBounds.Bottom)
        rcPage.left = HundredthInchToTwips(e.PageBounds.Left)
        rcPage.right = HundredthInchToTwips(e.PageBounds.Right)

        ' Get device context of output device
        Dim hdc As IntPtr
        hdc = e.Graphics.GetHdc()

        ' Fill in the FORMATRANGE structure
        Dim fr As STRUCT_FORMATRANGE
        fr.chrg = cr
        fr.hdc = hdc
        fr.hdcTarget = hdc
        fr.rc = rc
        fr.rcPage = rcPage

        ' Non-Zero wParam means render, Zero means measure
        Dim wParam As Int32
        If measureOnly Then
            wParam = 0
        Else
            wParam = 1
        End If

        ' Allocate memory for the FORMATRANGE struct and
        ' copy the contents of our struct to this memory
        Dim lParam As IntPtr
        lParam = Marshal.AllocCoTaskMem(Marshal.SizeOf(fr))
        Marshal.StructureToPtr(fr, lParam, False)

        ' Send the actual Win32 message
        Dim res As Integer
        res = SendMessage(Handle, EM_FORMATRANGE, wParam, lParam)

        ' Free allocated memory
        Marshal.FreeCoTaskMem(lParam)

        ' and release the device context
        e.Graphics.ReleaseHdc(hdc)

        Return res
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.FormatRangeDone Method

Public Sub FormatRangeDone()

Source code

[Visual Basic]
    Public Sub FormatRangeDone()
        Dim lParam As New IntPtr(0)
        SendMessage(Handle, EM_FORMATRANGE, 0, lParam)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.HundredthInchToTwips Method

Private Function HundredthInchToTwips( _
   ByVal n As Integer _
) As Int32

Parameters

n
Required.

Source code

[Visual Basic]
    Private Function HundredthInchToTwips(ByVal n As Integer) As Int32
        Return Convert.ToInt32(n * 14.4)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SendMessage Method

<DllImport("user32.dll")> _
Private Shared Function SendMessage( _
   ByVal hWnd As IntPtr, _
   ByVal msg As Int32, _
   ByVal wParam As Int32, _
   ByVal lParam As IntPtr _
) As Int32

Parameters

hWnd
Required.
msg
Required.
wParam
Required.
lParam
Required.

Source code

[Visual Basic]
    <DllImport("user32.dll")> _
    Private Shared Function SendMessage(ByVal hWnd As IntPtr, _
                                        ByVal msg As Int32, _
                                        ByVal wParam As Int32, _
                                        ByVal lParam As IntPtr) As Int32
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionBold Method

Public Function SetSelectionBold( _
   ByVal bold As Boolean _
) As Boolean

Parameters

bold
Required.

Source code

[Visual Basic]
    Public Function SetSelectionBold(ByVal bold As Boolean) As Boolean
        If (bold) Then
            Return SetSelectionStyle(CFM_BOLD, CFE_BOLD)
        Else
            Return SetSelectionStyle(CFM_BOLD, 0)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionFont Method

Public Function SetSelectionFont( _
   ByVal face as String _
) As Boolean

Parameters

face
Required.

Source code

[Visual Basic]
    Public Function SetSelectionFont(ByVal face as String) As Boolean
        Dim cf As New STRUCT_CHARFORMAT()
        cf.cbSize = Marshal.SizeOf(cf)
        cf.dwMask = Convert.ToUInt32(CFM_FACE)

        ' ReDim face name to relevant size
        ReDim cf.szFaceName(32)
        face.CopyTo(0, cf.szFaceName, 0, Math.Min(31, face.Length))

        Dim lParam As IntPtr
        lParam = Marshal.AllocCoTaskMem(Marshal.SizeOf(cf))
        Marshal.StructureToPtr(cf, lParam, False)

        Dim res As Integer
        res = SendMessage(Handle, EM_SETCHARFORMAT, SCF_SELECTION, lParam)
        If (res = 0) Then
            Return True
        Else
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionItalic Method

Public Function SetSelectionItalic( _
   ByVal italic As Boolean _
) As Boolean

Parameters

italic
Required.

Source code

[Visual Basic]
    Public Function SetSelectionItalic(ByVal italic As Boolean) As Boolean
        If (italic) Then
            Return SetSelectionStyle(CFM_ITALIC, CFE_ITALIC)
        Else
            Return SetSelectionStyle(CFM_ITALIC, 0)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionSize Method

Public Function SetSelectionSize( _
   ByVal size As Integer _
) As Boolean

Parameters

size
Required.

Source code

[Visual Basic]
    Public Function SetSelectionSize(ByVal size As Integer) As Boolean
        Dim cf As New STRUCT_CHARFORMAT()
        cf.cbSize = Marshal.SizeOf(cf)
        cf.dwMask = Convert.ToUInt32(CFM_SIZE)
        ' yHeight is in 1/20 pt
        cf.yHeight = size * 20

        Dim lParam As IntPtr
        lParam = Marshal.AllocCoTaskMem(Marshal.SizeOf(cf))
        Marshal.StructureToPtr(cf, lParam, False)

        Dim res As Integer
        res = SendMessage(Handle, EM_SETCHARFORMAT, SCF_SELECTION, lParam)
        If (res = 0) Then
            Return True
        Else
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionStyle Method

Private Function SetSelectionStyle( _
   ByVal mask As Int32, _
   ByVal effect As Int32 _
) As Boolean

Parameters

mask
Required.
effect
Required.

Source code

[Visual Basic]
    Private Function SetSelectionStyle(ByVal mask As Int32, ByVal effect As Int32) As Boolean
        Dim cf As New STRUCT_CHARFORMAT()
        cf.cbSize = Marshal.SizeOf(cf)
        cf.dwMask = Convert.ToUInt32(mask)
        cf.dwEffects = Convert.ToUInt32(effect)

        Dim lParam As IntPtr
        lParam = Marshal.AllocCoTaskMem(Marshal.SizeOf(cf))
        Marshal.StructureToPtr(cf, lParam, False)

        Dim res As Integer
        res = SendMessage(Handle, EM_SETCHARFORMAT, SCF_SELECTION, lParam)
        If (res = 0) Then
            Return True
        Else
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx.SetSelectionUnderlined Method

Public Function SetSelectionUnderlined( _
   ByVal underlined As Boolean _
) As Boolean

Parameters

underlined
Required.

Source code

[Visual Basic]
    Public Function SetSelectionUnderlined(ByVal underlined As Boolean) As Boolean
        If (underlined) Then
            Return SetSelectionStyle(CFM_UNDERLINE, CFE_UNDERLINE)
        Else
            Return SetSelectionStyle(CFM_UNDERLINE, 0)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxEx Fields

RichTextBoxEx overview

Fields

field SCF_ALL
field SCF_SELECTION
field SCF_WORD

See Also

RichTextBoxEx Class


SCF_ALL Variable

Private SCF_ALL As Int32 = &H4&

Source code

[Visual Basic]
    Private SCF_ALL As Int32 = &H4&

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


SCF_SELECTION Variable

Private SCF_SELECTION As Int32 = &H1&

Source code

[Visual Basic]
    Private SCF_SELECTION As Int32 = &H1&

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


SCF_WORD Variable

Private SCF_WORD As Int32 = &H2&

Source code

[Visual Basic]
    Private SCF_WORD As Int32 = &H2&

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxEx


RichTextBoxHS Class

For a list of all members of this type, see RichTextBoxHS Members.

System.Object
System.Windows.Forms.RichTextBox
EDOKAApp.RichTextBoxHS

Public Class RichTextBoxHS
   Inherits Windows.Forms.RichTextBox

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

RichTextBoxHS Members


RichTextBoxHS Members

RichTextBoxHS overview

Constructors

constructor RichTextBoxHS Constructor

Properties

property SelectionBackColor

Methods

method BackColorSetWhole
method Dispose
method FindHighlight
method InitializeComponent

Fields

field components

See Also

RichTextBoxHS Class


RichTextBoxHS Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

        'Add any initialization after the InitializeComponent() call

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS Properties

RichTextBoxHS overview

Properties

property SelectionBackColor

See Also

RichTextBoxHS Class


RichTextBoxHS.SelectionBackColor Property

Public WriteOnly Property SelectionBackColor() As Color

Source code

[Visual Basic]
    Public WriteOnly Property SelectionBackColor() As Color
        Set(ByVal Value As Color)
            'First, test SelectedText property NOT SelectedRTF property because
            '...SelectedRTF will never be nothing, it will always have at least
            '...the current default Font table
            If Me.SelectedText Is Nothing Then Exit Property
            Dim sb As New StringBuilder()           'use StringBuilder for speed and cleanliness
            Dim SelText As String = Me.SelectedRtf  'move to local string for speed
            Dim strTemp As String                   'used twice for ease of calculating internal coordinates
            Dim FontTableEnds As Integer            'end character of the rtf font table
            Dim ColorTableBegins As Integer         'beginning of the rtf color table
            Dim ColorTableEnds As Integer           'end of the rtf color table
            Dim StartLooking As Integer             'used to walk a string appending chunks
            Dim HighlightBlockStart As Integer      'used to find "\highlight#" block for stripping
            Dim HighlightBlockEnd As Integer        'used to find "\highlight#" block for stripping
            Dim cycl As Integer                     'used in For/Next loops
            Dim NewColorIndex As Integer = 0        'new color table index for incoming color
            'find the end of the font table
            FontTableEnds = InStr(1, SelText, "}}")
            'add the header and font table to the string accumulator
            sb.Append(Mid(SelText, 1, FontTableEnds + 1))
            'find the color table start
            ColorTableBegins = InStr(FontTableEnds, SelText, "{\colortbl")
            If ColorTableBegins = 0 Then 'no color table exists
                'add a color table header
                sb.Append("{\colortbl ;")
                'no color table so for later use make the ColorTableEnd the same as FontTableEnds
                ColorTableEnds = FontTableEnds
                'default our new color table index to 1 since it will be the only one
                'remember Color table index 0 is reserved
                NewColorIndex = 1
            Else 'a color table already exists
                'find the end of the color table
                ColorTableEnds = InStr(ColorTableBegins, SelText, "}")
                'backup one character so as to exclude the brace
                ColorTableEnds -= 1
                'need to count the quantity of semi;colons which will
                '... determine what color table index number our new color will be
                strTemp = Mid(SelText, FontTableEnds + 2, (ColorTableEnds - FontTableEnds) - 1)
                For cycl = 1 To strTemp.Length
                    If Mid(strTemp, cycl, 1) = ";" Then NewColorIndex += 1
                Next
                'append the color table without end brace
                sb.Append(strTemp)
            End If
            'append the color table entry for the highlight color
            sb.Append("\red" & Trim(Value.R.ToString))
            sb.Append("\green" & Trim(Value.G.ToString))
            sb.Append("\blue" & Trim(Value.B.ToString))
            'append the table entry terminator semi;colon
            sb.Append(";")
            'append the color table terminating brace
            sb.Append("}")
            'append the new highlight tag
            sb.Append("\highlight" & Trim(NewColorIndex.ToString))
            'Drop into a single string for easier manipulation
            strTemp = Mid(SelText, ColorTableEnds + 2, (SelText.Length - ColorTableEnds) - 1)
            'begin at first character
            StartLooking = 1
            'append everything remaining, but strip all remaing highlight tags
            Do
                'find a "\highlight" block
                HighlightBlockStart = InStr(StartLooking, strTemp, "\highlight")
                'if no "\highlight" block found
                If HighlightBlockStart = 0 Then
                    'append everything remaining
                    sb.Append(Mid(strTemp, StartLooking, strTemp.Length - StartLooking))
                    'we done appending
                    Exit Do
                End If
                'calculate the end of the word "highlight"
                HighlightBlockEnd = HighlightBlockStart + 9
                'accomodate color tables with over 9 colors and thus multi-digit color indexes
                'Plus, watch for (and discard) ONE space if it immediately follows the last digit
                Do
                    'keep stepping past end
                    HighlightBlockEnd += 1
                    'watch for (and discard) ONE space if it immediately follows the last digit
                    If Mid(strTemp, HighlightBlockEnd + 1, 1) = " " Then
                        HighlightBlockEnd += 1
                        Exit Do
                    End If
                    'looking for the first non-numeric character
                Loop While InStr(1, "0123456789", Mid(strTemp, HighlightBlockEnd + 1, 1))
                'append this block
                sb.Append(Mid(strTemp, StartLooking, (HighlightBlockStart - StartLooking)))
                'move the start forward past the last "\highlight#" block
                StartLooking = HighlightBlockEnd + 1
            Loop
            Me.SelectedRtf = sb.ToString
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS Methods

RichTextBoxHS overview

Methods

method BackColorSetWhole
method Dispose
method FindHighlight
method InitializeComponent

See Also

RichTextBoxHS Class


RichTextBoxHS.BackColorSetWhole Method

Public Sub BackColorSetWhole( _
   ByVal BackColorDefault As Color _
)

Parameters

BackColorDefault
Required.

Source code

[Visual Basic]
    Public Sub BackColorSetWhole(ByVal BackColorDefault As Color)
        Me.SelectAll()
        Me.SelectionBackColor = BackColorDefault
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS.FindHighlight Method

Public Sub FindHighlight( _
   ByVal SearchText As String, _
   ByVal HighlightColor As Color, _
   ByVal MatchCase As Boolean, _
   ByVal WholeWords As Boolean _
)

Parameters

SearchText
Required.
HighlightColor
Required.
MatchCase
Required.
WholeWords
Required.

Source code

[Visual Basic]
    Public Sub FindHighlight(ByVal SearchText As String, ByVal HighlightColor As Color, ByVal MatchCase As Boolean, ByVal WholeWords As Boolean)
        Me.SuspendLayout()
        Dim StartLooking As Integer = 0
        Dim FoundAt As Integer
        Dim SearchLength As Integer
        Dim RTBfinds As RichTextBoxFinds
        If SearchText Is Nothing Then Exit Sub
        Select Case True
            Case MatchCase And WholeWords
                RTBfinds = RichTextBoxFinds.MatchCase Or RichTextBoxFinds.WholeWord
            Case MatchCase
                RTBfinds = RichTextBoxFinds.MatchCase
            Case WholeWords
                RTBfinds = RichTextBoxFinds.WholeWord
            Case Else
                RTBfinds = RichTextBoxFinds.None
        End Select
        SearchLength = SearchText.Length
        Do
            FoundAt = Me.Find(SearchText, StartLooking, RTBfinds)
            If FoundAt > -1 Then Me.SelectionBackColor = HighlightColor
            StartLooking = StartLooking + SearchLength
        Loop While FoundAt > -1
        Me.ResumeLayout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        components = New System.ComponentModel.Container()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


RichTextBoxHS Fields

RichTextBoxHS overview

Fields

field components

See Also

RichTextBoxHS Class


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

RichTextBoxHS


Selektion_Mandant Class

For a list of all members of this type, see Selektion_Mandant Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.Selektion_Mandant

Public Class Selektion_Mandant
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Selektion_Mandant Members


Selektion_Mandant Members

Selektion_Mandant overview

Constructors

constructor Selektion_Mandant Constructor

Properties

property mandant
property mandantnr

Methods

method BtnAbbruch_Click
method BtnOK_Click
method Dispose
method Form1_Load
method InitializeComponent
method MandantList_Doubleclick

Fields

field BtnAbbruch
field BtnOK
field Label1
field MandantList
field _mandant
field _mandantnr
field components

See Also

Selektion_Mandant Class


Selektion_Mandant Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant Properties

Selektion_Mandant overview

Properties

property mandant
property mandantnr

See Also

Selektion_Mandant Class


Selektion_Mandant.mandant Property

Property mandant() As String

Source code

[Visual Basic]
    Property mandant() As String
        Get
            Return _mandant
        End Get
        Set(ByVal Value As String)
            _mandant = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.mandantnr Property

Property mandantnr() As Long

Source code

[Visual Basic]
    Property mandantnr() As Long
        Get
            Return _mandantnr
        End Get
        Set(ByVal Value As Long)
            _mandantnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant Methods

Selektion_Mandant overview

Methods

method BtnAbbruch_Click
method BtnOK_Click
method Dispose
method Form1_Load
method InitializeComponent
method MandantList_Doubleclick

See Also

Selektion_Mandant Class


Selektion_Mandant.BtnAbbruch_Click Method

Private Sub BtnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnAbbruch.Click
        If MyMsg.Show_MessageYesNo(1) = MsgBoxResult.Yes Then
            End
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.BtnOK_Click Method

Private Sub BtnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnOK.Click
        If Me.MandantList.GetItemText(Me.MandantList.SelectedIndex, 0) = "" Then
            MyMsg.show_standardmessage(1, MsgBoxStyle.Question)
        Else
            mandantnr = Me.MandantList.GetItemText(Me.MandantList.SelectedIndex, 0)
            mandant = Me.MandantList.GetItemText(Me.MandantList.SelectedIndex, 1)
            Globals.MandantNr = mandantnr
            Globals.MandantText = mandant
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ts As New EDOKA.Tabellenspalte()
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim mandanten As New edokadb.clsMyMandat()
        Dim i As Integer
        mandantnr = 0
        mandant = ""
        mandanten.cpMainConnectionProvider = conn
        ' Lesen der vorhandenen Daten
        ' Aufbereitung im Datagrid Mandantlist
        Me.MandantList.DataSource = mandanten.SelectAll
        Me.MandantList.Caption = ""
        Me.MandantList.SelectedIndex = 0
        For i = 0 To Me.MandantList.Columns.Count - 1
            ts.Tabelle = "Mandant"
            ts.Feld = Me.MandantList.Columns(i).Caption
            ts.getspalte()
            Me.MandantList.Columns(i).Caption = ts.spaltenname
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(Selektion_Mandant))
        Me.MandantList = New C1.Win.C1List.C1List()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.BtnOK = New System.Windows.Forms.Button()
        Me.BtnAbbruch = New System.Windows.Forms.Button()
        CType(Me.MandantList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MandantList
        '
        Me.MandantList.AccessibleDescription = CType(resources.GetObject("MandantList.AccessibleDescription"), String)
        Me.MandantList.AccessibleName = CType(resources.GetObject("MandantList.AccessibleName"), String)
        Me.MandantList.AddItemCols = 0
        Me.MandantList.AddItemSeparator = Microsoft.VisualBasic.ChrW(59)
        Me.MandantList.AllowSort = True
        Me.MandantList.AlternatingRows = True
        Me.MandantList.Anchor = CType(resources.GetObject("MandantList.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.MandantList.BackgroundImage = CType(resources.GetObject("MandantList.BackgroundImage"), System.Drawing.Image)
        Me.MandantList.Caption = "C1List .Net"
        Me.MandantList.CaptionHeight = 17
        Me.MandantList.ColumnCaptionHeight = 17
        Me.MandantList.ColumnFooterHeight = 17
        Me.MandantList.ColumnHeaders = False
        Me.MandantList.DataMode = C1.Win.C1List.DataModeEnum.Normal
        Me.MandantList.DeadAreaBackColor = System.Drawing.SystemColors.ControlDark
        Me.MandantList.Dock = CType(resources.GetObject("MandantList.Dock"), System.Windows.Forms.DockStyle)
        Me.MandantList.Enabled = CType(resources.GetObject("MandantList.Enabled"), Boolean)
        Me.MandantList.FetchRowStyles = True
        Me.MandantList.Font = CType(resources.GetObject("MandantList.Font"), System.Drawing.Font)
        Me.MandantList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.MandantList.ImeMode = CType(resources.GetObject("MandantList.ImeMode"), System.Windows.Forms.ImeMode)
        Me.MandantList.ItemHeight = 15
        Me.MandantList.Location = CType(resources.GetObject("MandantList.Location"), System.Drawing.Point)
        Me.MandantList.MatchCol = C1.Win.C1List.MatchColEnum.CurrentMousePos
        Me.MandantList.MatchCompare = C1.Win.C1List.MatchCompareEnum.PartiallyEqual
        Me.MandantList.MatchEntry = C1.Win.C1List.MatchEntryEnum.None
        Me.MandantList.MatchEntryTimeout = CType(2000, Long)
        Me.MandantList.Name = "MandantList"
        Me.MandantList.RightToLeft = CType(resources.GetObject("MandantList.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.MandantList.RowDivider.Color = System.Drawing.Color.DarkGray
        Me.MandantList.RowDivider.Style = C1.Win.C1List.LineStyleEnum.None
        Me.MandantList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.MandantList.ScrollTips = False
        Me.MandantList.Size = CType(resources.GetObject("MandantList.Size"), System.Drawing.Size)
        Me.MandantList.TabIndex = CType(resources.GetObject("MandantList.TabIndex"), Integer)
        Me.MandantList.Text = resources.GetString("MandantList.Text")
        Me.MandantList.Visible = CType(resources.GetObject("MandantList.Visible"), Boolean)
        Me.MandantList.PropBag = CType(resources.GetObject("MandantList.PropBag"), String)
        '
        'Label1
        '
        Me.Label1.AccessibleDescription = CType(resources.GetObject("Label1.AccessibleDescription"), String)
        Me.Label1.AccessibleName = CType(resources.GetObject("Label1.AccessibleName"), String)
        Me.Label1.Anchor = CType(resources.GetObject("Label1.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.Label1.AutoSize = CType(resources.GetObject("Label1.AutoSize"), Boolean)
        Me.Label1.Dock = CType(resources.GetObject("Label1.Dock"), System.Windows.Forms.DockStyle)
        Me.Label1.Enabled = CType(resources.GetObject("Label1.Enabled"), Boolean)
        Me.Label1.Font = CType(resources.GetObject("Label1.Font"), System.Drawing.Font)
        Me.Label1.Image = CType(resources.GetObject("Label1.Image"), System.Drawing.Image)
        Me.Label1.ImageAlign = CType(resources.GetObject("Label1.ImageAlign"), System.Drawing.ContentAlignment)
        Me.Label1.ImageIndex = CType(resources.GetObject("Label1.ImageIndex"), Integer)
        Me.Label1.ImeMode = CType(resources.GetObject("Label1.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Label1.Location = CType(resources.GetObject("Label1.Location"), System.Drawing.Point)
        Me.Label1.Name = "Label1"
        Me.Label1.RightToLeft = CType(resources.GetObject("Label1.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.Label1.Size = CType(resources.GetObject("Label1.Size"), System.Drawing.Size)
        Me.Label1.TabIndex = CType(resources.GetObject("Label1.TabIndex"), Integer)
        Me.Label1.Text = resources.GetString("Label1.Text")
        Me.Label1.TextAlign = CType(resources.GetObject("Label1.TextAlign"), System.Drawing.ContentAlignment)
        Me.Label1.Visible = CType(resources.GetObject("Label1.Visible"), Boolean)
        '
        'BtnOK
        '
        Me.BtnOK.AccessibleDescription = CType(resources.GetObject("BtnOK.AccessibleDescription"), String)
        Me.BtnOK.AccessibleName = CType(resources.GetObject("BtnOK.AccessibleName"), String)
        Me.BtnOK.Anchor = CType(resources.GetObject("BtnOK.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.BtnOK.BackgroundImage = CType(resources.GetObject("BtnOK.BackgroundImage"), System.Drawing.Image)
        Me.BtnOK.Dock = CType(resources.GetObject("BtnOK.Dock"), System.Windows.Forms.DockStyle)
        Me.BtnOK.Enabled = CType(resources.GetObject("BtnOK.Enabled"), Boolean)
        Me.BtnOK.FlatStyle = CType(resources.GetObject("BtnOK.FlatStyle"), System.Windows.Forms.FlatStyle)
        Me.BtnOK.Font = CType(resources.GetObject("BtnOK.Font"), System.Drawing.Font)
        Me.BtnOK.Image = CType(resources.GetObject("BtnOK.Image"), System.Drawing.Image)
        Me.BtnOK.ImageAlign = CType(resources.GetObject("BtnOK.ImageAlign"), System.Drawing.ContentAlignment)
        Me.BtnOK.ImageIndex = CType(resources.GetObject("BtnOK.ImageIndex"), Integer)
        Me.BtnOK.ImeMode = CType(resources.GetObject("BtnOK.ImeMode"), System.Windows.Forms.ImeMode)
        Me.BtnOK.Location = CType(resources.GetObject("BtnOK.Location"), System.Drawing.Point)
        Me.BtnOK.Name = "BtnOK"
        Me.BtnOK.RightToLeft = CType(resources.GetObject("BtnOK.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.BtnOK.Size = CType(resources.GetObject("BtnOK.Size"), System.Drawing.Size)
        Me.BtnOK.TabIndex = CType(resources.GetObject("BtnOK.TabIndex"), Integer)
        Me.BtnOK.Text = resources.GetString("BtnOK.Text")
        Me.BtnOK.TextAlign = CType(resources.GetObject("BtnOK.TextAlign"), System.Drawing.ContentAlignment)
        Me.BtnOK.Visible = CType(resources.GetObject("BtnOK.Visible"), Boolean)
        '
        'BtnAbbruch
        '
        Me.BtnAbbruch.AccessibleDescription = CType(resources.GetObject("BtnAbbruch.AccessibleDescription"), String)
        Me.BtnAbbruch.AccessibleName = CType(resources.GetObject("BtnAbbruch.AccessibleName"), String)
        Me.BtnAbbruch.Anchor = CType(resources.GetObject("BtnAbbruch.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.BtnAbbruch.BackgroundImage = CType(resources.GetObject("BtnAbbruch.BackgroundImage"), System.Drawing.Image)
        Me.BtnAbbruch.Dock = CType(resources.GetObject("BtnAbbruch.Dock"), System.Windows.Forms.DockStyle)
        Me.BtnAbbruch.Enabled = CType(resources.GetObject("BtnAbbruch.Enabled"), Boolean)
        Me.BtnAbbruch.FlatStyle = CType(resources.GetObject("BtnAbbruch.FlatStyle"), System.Windows.Forms.FlatStyle)
        Me.BtnAbbruch.Font = CType(resources.GetObject("BtnAbbruch.Font"), System.Drawing.Font)
        Me.BtnAbbruch.Image = CType(resources.GetObject("BtnAbbruch.Image"), System.Drawing.Image)
        Me.BtnAbbruch.ImageAlign = CType(resources.GetObject("BtnAbbruch.ImageAlign"), System.Drawing.ContentAlignment)
        Me.BtnAbbruch.ImageIndex = CType(resources.GetObject("BtnAbbruch.ImageIndex"), Integer)
        Me.BtnAbbruch.ImeMode = CType(resources.GetObject("BtnAbbruch.ImeMode"), System.Windows.Forms.ImeMode)
        Me.BtnAbbruch.Location = CType(resources.GetObject("BtnAbbruch.Location"), System.Drawing.Point)
        Me.BtnAbbruch.Name = "BtnAbbruch"
        Me.BtnAbbruch.RightToLeft = CType(resources.GetObject("BtnAbbruch.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.BtnAbbruch.Size = CType(resources.GetObject("BtnAbbruch.Size"), System.Drawing.Size)
        Me.BtnAbbruch.TabIndex = CType(resources.GetObject("BtnAbbruch.TabIndex"), Integer)
        Me.BtnAbbruch.Text = resources.GetString("BtnAbbruch.Text")
        Me.BtnAbbruch.TextAlign = CType(resources.GetObject("BtnAbbruch.TextAlign"), System.Drawing.ContentAlignment)
        Me.BtnAbbruch.Visible = CType(resources.GetObject("BtnAbbruch.Visible"), Boolean)
        '
        'Selektion_Mandant
        '
        Me.AccessibleDescription = CType(resources.GetObject("$this.AccessibleDescription"), String)
        Me.AccessibleName = CType(resources.GetObject("$this.AccessibleName"), String)
        Me.Anchor = CType(resources.GetObject("$this.Anchor"), System.Windows.Forms.AnchorStyles)
        Me.AutoScaleBaseSize = CType(resources.GetObject("$this.AutoScaleBaseSize"), System.Drawing.Size)
        Me.AutoScroll = CType(resources.GetObject("$this.AutoScroll"), Boolean)
        Me.AutoScrollMargin = CType(resources.GetObject("$this.AutoScrollMargin"), System.Drawing.Size)
        Me.AutoScrollMinSize = CType(resources.GetObject("$this.AutoScrollMinSize"), System.Drawing.Size)
        Me.BackgroundImage = CType(resources.GetObject("$this.BackgroundImage"), System.Drawing.Image)
        Me.ClientSize = CType(resources.GetObject("$this.ClientSize"), System.Drawing.Size)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnAbbruch, Me.BtnOK, Me.Label1, Me.MandantList})
        Me.Dock = CType(resources.GetObject("$this.Dock"), System.Windows.Forms.DockStyle)
        Me.Enabled = CType(resources.GetObject("$this.Enabled"), Boolean)
        Me.Font = CType(resources.GetObject("$this.Font"), System.Drawing.Font)
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.ImeMode = CType(resources.GetObject("$this.ImeMode"), System.Windows.Forms.ImeMode)
        Me.Location = CType(resources.GetObject("$this.Location"), System.Drawing.Point)
        Me.MaximumSize = CType(resources.GetObject("$this.MaximumSize"), System.Drawing.Size)
        Me.MinimumSize = CType(resources.GetObject("$this.MinimumSize"), System.Drawing.Size)
        Me.Name = "Selektion_Mandant"
        Me.RightToLeft = CType(resources.GetObject("$this.RightToLeft"), System.Windows.Forms.RightToLeft)
        Me.ShowInTaskbar = False
        Me.StartPosition = CType(resources.GetObject("$this.StartPosition"), System.Windows.Forms.FormStartPosition)
        Me.Text = resources.GetString("$this.Text")
        Me.Visible = CType(resources.GetObject("$this.Visible"), Boolean)
        CType(Me.MandantList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant.MandantList_Doubleclick Method

Private Sub MandantList_Doubleclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MandantList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MandantList_Doubleclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MandantList.DoubleClick
        BtnOK_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Selektion_Mandant Fields

Selektion_Mandant overview

Fields

field BtnAbbruch
field BtnOK
field Label1
field MandantList
field _mandant
field _mandantnr
field components

See Also

Selektion_Mandant Class


BtnAbbruch Variable

Friend WithEvents BtnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


BtnOK Variable

Friend WithEvents BtnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


MandantList Variable

Friend WithEvents MandantList As C1.Win.C1List.C1List

Source code

[Visual Basic]
    Friend WithEvents MandantList As C1.Win.C1List.C1List

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


_mandant Variable

Private _mandant As String

Source code

[Visual Basic]
    Private _mandant As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


_mandantnr Variable

Private _mandantnr As Long

Source code

[Visual Basic]
    Private _mandantnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Selektion_Mandant


Splash Class

For a list of all members of this type, see Splash Members.

System.Object
ALLGEMEIN.UI.SplashScreen
EDOKAApp.Splash

Public Class Splash
   Inherits ALLGEMEIN.UI.SplashScreen

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Splash Members


Splash Members

Splash overview

Constructors

constructor Splash Constructor

Methods

method Dispose
method InitializeComponent
method PictureBox1_Click
method Splash_Load

Fields

field Label1
field Label2
field Label3
field PictureBox1
field components

See Also

Splash Class


Splash Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Splash Methods

Splash overview

Methods

method Dispose
method InitializeComponent
method PictureBox1_Click
method Splash_Load

See Also

Splash Class


Splash.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Splash.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(Splash))
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'PictureBox1
        '
        Me.PictureBox1.BackColor = System.Drawing.SystemColors.ControlText
        Me.PictureBox1.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(528, 320)
        Me.PictureBox1.TabIndex = 0
        Me.PictureBox1.TabStop = False
        '
        'Label3
        '
        Me.Label3.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label3.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label3.Location = New System.Drawing.Point(88, 176)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(160, 24)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "6. Oktober 2003"
        Me.Label3.TextAlign = System.Drawing.ContentAlignment.TopCenter
        '
        'Label2
        '
        Me.Label2.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label2.Location = New System.Drawing.Point(104, 216)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(136, 16)
        Me.Label2.TabIndex = 12
        Me.Label2.Text = "© 2003 - TKB Weinfelden"
        '
        'Label1
        '
        Me.Label1.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label1.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label1.Location = New System.Drawing.Point(88, 152)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(160, 24)
        Me.Label1.TabIndex = 11
        Me.Label1.Text = "Version 1.2"
        Me.Label1.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'Splash
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(528, 320)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.Label2, Me.Label1, Me.PictureBox1})
        Me.MaximizeBox = False
        Me.Name = "Splash"
        Me.ShowInTaskbar = False
        Me.Text = "EDOKA"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Splash.PictureBox1_Click Method

Private Sub PictureBox1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles PictureBox1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PictureBox1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PictureBox1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Splash.Splash_Load Method

Private Sub Splash_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splash_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Label1.Text = "Version " & Globals.Version
        Label3.Text = Globals.versionsdatum
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Splash Fields

Splash overview

Fields

field Label1
field Label2
field Label3
field PictureBox1
field components

See Also

Splash Class


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Splash


Statushandling Class

For a list of all members of this type, see Statushandling Members.

System.Object
EDOKAApp.Statushandling

Public Class Statushandling

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Statushandling Members


Statushandling Members

Statushandling overview

Properties

property Ablgeschossen
property AktullerStatus
property Ausgangsarchivierung
property BemerkungVerantwortlicher
property Dokumentid
property Eingangsarchivierung
property Folgestatus
property NeuerStatus

Methods

method Alle_Status
method Check_Neuer_Status
method Dispose
method Dokument_Abschliessen
method Generic_Select
method GetDokumentwerte
method Insert_Note
method Meldung_Aufhebung
method Meldung_Status
method Meldung_Verantwortlicher
method Meldungstext_aufbereiten
method Set_Ausgangsarchiviert
method Set_Eingangsarchiviert
method Status_Erstellen
method check_abschluss
method get_coldindex_and_statusnr
method insert_Message
method insert_history_status
method insert_history_status_abschluss
method loeschart
method parstext
method set_aufgehoben
method set_geloescht

Fields

field dokumentwerte
field ds
field m_abgeschlossen
field m_aktuellerstatus
field m_ausgangsarchivierung
field m_bemerkungverantwortlicher
field m_dokumentid
field m_eingangsarchivierung
field m_folgestatus
field m_neuerstatus

See Also

Statushandling Class


Statushandling Properties

Statushandling overview

Properties

property Ablgeschossen
property AktullerStatus
property Ausgangsarchivierung
property BemerkungVerantwortlicher
property Dokumentid
property Eingangsarchivierung
property Folgestatus
property NeuerStatus

See Also

Statushandling Class


Statushandling.Ablgeschossen Property

Property Ablgeschossen() As Boolean

Source code

[Visual Basic]
    Property Ablgeschossen() As Boolean
        Get
            Return m_abgeschlossen
        End Get
        Set(ByVal Value As Boolean)
            m_abgeschlossen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.AktullerStatus Property

Property AktullerStatus() As Integer

Source code

[Visual Basic]
    Property AktullerStatus() As Integer
        Get
            Return m_aktuellerstatus
        End Get
        Set(ByVal Value As Integer)
            m_aktuellerstatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Ausgangsarchivierung Property

Property Ausgangsarchivierung() As Boolean

Source code

[Visual Basic]
    Property Ausgangsarchivierung() As Boolean
        Get
            Return m_ausgangsarchivierung
        End Get
        Set(ByVal Value As Boolean)
            m_ausgangsarchivierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.BemerkungVerantwortlicher Property

Property BemerkungVerantwortlicher() As String

Source code

[Visual Basic]
    Property BemerkungVerantwortlicher() As String
        Get
            Return m_bemerkungverantwortlicher
        End Get
        Set(ByVal Value As String)
            m_bemerkungverantwortlicher = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Dokumentid Property

Property Dokumentid() As String

Source code

[Visual Basic]
    Property Dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Eingangsarchivierung Property

Property Eingangsarchivierung() As Boolean

Source code

[Visual Basic]
    Property Eingangsarchivierung() As Boolean
        Get
            Return m_eingangsarchivierung
        End Get
        Set(ByVal Value As Boolean)
            m_eingangsarchivierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Folgestatus Property

Property Folgestatus() As Boolean

Source code

[Visual Basic]
    Property Folgestatus() As Boolean
        Get
            Return m_folgestatus
        End Get
        Set(ByVal Value As Boolean)
            m_folgestatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.NeuerStatus Property

Property NeuerStatus() As Integer

Source code

[Visual Basic]
    Property NeuerStatus() As Integer
        Get
            Return m_neuerstatus
        End Get
        Set(ByVal Value As Integer)
            m_neuerstatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling Methods

Statushandling overview

Methods

method Alle_Status
method Check_Neuer_Status
method Dispose
method Dokument_Abschliessen
method Generic_Select
method GetDokumentwerte
method Insert_Note
method Meldung_Aufhebung
method Meldung_Status
method Meldung_Verantwortlicher
method Meldungstext_aufbereiten
method Set_Ausgangsarchiviert
method Set_Eingangsarchiviert
method Status_Erstellen
method check_abschluss
method get_coldindex_and_statusnr
method insert_Message
method insert_history_status
method insert_history_status_abschluss
method loeschart
method parstext
method set_aufgehoben
method set_geloescht

See Also

Statushandling Class


Statushandling.Alle_Status Method

Public Function Alle_Status( _
   ByVal Dokumentid As String _
) As DataTable

Parameters

Dokumentid
Required.

Source code

[Visual Basic]
    Public Function Alle_Status(ByVal Dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Check_Neuer_Status Method

Public Function Check_Neuer_Status()

Source code

[Visual Basic]
    Public Function Check_Neuer_Status()
        ds.cpMainConnectionProvider = conn
        ds.iDokument_statusnr = New SqlInt32(CType(Me.NeuerStatus, Int32))
        ds.SelectOne()

        If ds.bFolgestatus_durch_anderen_verantwortlichen.Value = True Then
            Me.Folgestatus = True
        End If
        Me.Ausgangsarchivierung = False
        If ds.iStatus_bezeichnungnr.Value = 3 Or ds.bDokument_ausgangsarchivierung.Value = True Then
            Me.Ausgangsarchivierung = True
        End If
        If ds.bDokument_bearbeitung_abgeschlossen.Value = True Then
            Me.Ablgeschossen = True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Dispose Method

Public Sub Dispose()

Source code

[Visual Basic]
    Public Sub Dispose()
        ds.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Dokument_Abschliessen Method

Public Function Dokument_Abschliessen( _
   ByVal dokumentid As String, _
   ByVal status As Integer _
)

Parameters

dokumentid
Required.
status
Required.

Source code

[Visual Basic]
    Public Function Dokument_Abschliessen(ByVal dokumentid As String, ByVal status As Integer)
        Dim dok As New edokadb.clsDokument()
        Dim dt As New edokadb.clsDokumenttyp()
        Dim par As New edokadb.clsPartner()
        Dim loeschung As Boolean = False

        dok.cpMainConnectionProvider = conn
        par.cpMainConnectionProvider = conn
        dt.cpMainConnectionProvider = conn

        dok.sDokumentid = New SqlString(CType(dokumentid, String))
        Try

            dok.SelectOne()
            conn.OpenConnection()

            'Prüfung auf saldierten Partner und ggf. Dokument löschen bzw. aufheben
            par.iNRPAR00 = New SqlInt32(CType(dok.iNrpar00.Value, Int32))
            par.SelectOne()
            If par.bSaldiert.Value = True Then
                loeschung = True
            End If
            dok.iStatusnr = New SqlInt32(CType(status, Integer))
            dok.iVerantwortlich = New SqlInt32(CType(9998, Integer))
            dok.Update()
            conn.CloseConnection(True)
            Meldung_Status(dokumentid, status)

            dt.iDokumenttypnr = New SqlInt32(CType(dok.iDokumenttypnr.Value, Int32))
            dt.SelectOne()
            If dt.bVertrag.Value = True Then
                If loeschung Then
                    If loeschart(dok.sDokumentid.Value) = 1 Then
                        MyMsg.show_standardmessage(232, MsgBoxStyle.Information)
                        Insert_Note(dok.sDokumentid.Value, MyTxt.gettext(237))
                        set_aufgehoben(dok.sDokumentid.Value)
                    Else
                        MyMsg.show_standardmessage(231, MsgBoxStyle.Information)
                        Insert_Note(dok.sDokumentid.Value, MyTxt.gettext(236))
                        set_geloescht(dok.sDokumentid.Value)
                    End If
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentstatus_statushandling_Select"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.GetDokumentwerte Method

Public Function GetDokumentwerte( _
   ByVal Dokumentid As String, _
   ByVal typ As Integer, _
   ByVal status As Integer _
) As DataTable

Parameters

Dokumentid
Required.
typ
Required.
status
Required.

Source code

[Visual Basic]
    Public Function GetDokumentwerte(ByVal Dokumentid As String, ByVal typ As Integer, ByVal status As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_message_getdokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, typ))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Insert_Note Method

Private Sub Insert_Note( _
   ByVal dokumentid As String, _
   ByVal meldung As String _
)

Parameters

dokumentid
Required.
meldung
Required.

Source code

[Visual Basic]
    Private Sub Insert_Note(ByVal dokumentid As String, ByVal meldung As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldung))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldung))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            'MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Meldung_Aufhebung Method

Public Function Meldung_Aufhebung( _
   ByVal dokumentid As String, _
   ByVal verantwortlicher As Integer _
)

Parameters

dokumentid
Required.
verantwortlicher
Required.

Source code

[Visual Basic]
    Public Function Meldung_Aufhebung(ByVal dokumentid As String, ByVal verantwortlicher As Integer)
        dokumentwerte = GetDokumentwerte(dokumentid, 110, 0)
        insert_Message(0, dokumentid, Meldungstext_aufbereiten, parstext(dokumentwerte.Rows(0).Item("betreff")), Globals.MitarbeiterNr, 0, 0)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Meldung_Status Method

Public Function Meldung_Status( _
   ByVal dokumentid As String, _
   ByVal status As String _
)

Parameters

dokumentid
Required.
status
Required.

Source code

[Visual Basic]
    Public Function Meldung_Status(ByVal dokumentid As String, ByVal status As String)
        Try
            dokumentwerte = GetDokumentwerte(dokumentid, 102, status)
            insert_Message(0, dokumentid, Meldungstext_aufbereiten, parstext(dokumentwerte.Rows(0).Item("betreff")), Globals.MitarbeiterNr, 0, status)
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Meldung_Verantwortlicher Method

Public Function Meldung_Verantwortlicher( _
   ByVal dokumentid As String, _
   ByVal verantwortlicher As Integer _
)

Parameters

dokumentid
Required.
verantwortlicher
Required.

Source code

[Visual Basic]
    Public Function Meldung_Verantwortlicher(ByVal dokumentid As String, ByVal verantwortlicher As Integer)
        Try
            dokumentwerte = GetDokumentwerte(dokumentid, 100, 0)
            insert_Message(1, dokumentid, Meldungstext_aufbereiten, parstext(dokumentwerte.Rows(0).Item("betreff")), Globals.MitarbeiterNr, verantwortlicher, 0)
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Meldungstext_aufbereiten Method

Public Function Meldungstext_aufbereiten() As String

Source code

[Visual Basic]
    Public Function Meldungstext_aufbereiten() As String
        Dim s As String
        s = ""
        Try
            s = dokumentwerte.Rows(0).Item("meldung") + vbCrLf + dokumentwerte.Rows(0).Item("idvmeldung") + vbCrLf + dokumentwerte.Rows(0).Item("footer")
            If Me.BemerkungVerantwortlicher <> "" Then
                s = Me.BemerkungVerantwortlicher + vbCrLf + "------------------------" + vbCrLf + s
                '                s = s + vbCrLf + vbCrLf + Me.BemerkungVerantwortlicher
                Me.BemerkungVerantwortlicher = ""
            End If
            s = parstext(s)
        Catch
        End Try
        Meldungstext_aufbereiten = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Set_Ausgangsarchiviert Method

Public Function Set_Ausgangsarchiviert( _
   ByVal dokumentid As String _
) As Integer

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function Set_Ausgangsarchiviert(ByVal dokumentid As String) As Integer
        Dim da As DataTable
        Dim currentstatus As Integer
        Dim i, i1 As Integer
        Me.Dokumentid = dokumentid
        da = Generic_Select(1)
        currentstatus = da.Rows(0).Item("dokument_statusnr")
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item("status_bezeichnungnr") = 3 Then
                For i1 = 0 To da.Rows.Count - 1
                    If da.Rows(i1).Item("status_bezeichnungnr") = 4 Or _
                       da.Rows(i1).Item("status_bezeichnungnr") = 5 Then
                        Me.insert_history_status(da.Rows(i1).Item("dokument_statusnr"), dokumentid, Globals.MitarbeiterNr)
                        Return da.Rows(i1).Item("dokument_statusnr")
                    End If
                Next
            End If
        Next
        da.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Set_Eingangsarchiviert Method

Public Function Set_Eingangsarchiviert( _
   ByVal dokumentid As String _
) As Integer

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function Set_Eingangsarchiviert(ByVal dokumentid As String) As Integer
        Dim da As DataTable
        Dim currentstatus As Integer
        Dim i, i1 As Integer
        Me.Dokumentid = dokumentid
        da = Generic_Select(1)
        currentstatus = da.Rows(0).Item("dokument_statusnr")
        For i1 = 0 To da.Rows.Count - 1
            If da.Rows(i1).Item("status_bezeichnungnr") = 6 Or _
            da.Rows(i1).Item("status_bezeichnungnr") = 7 Or _
               da.Rows(i1).Item("status_bezeichnungnr") = 11 Then
                Me.insert_history_status(da.Rows(i1).Item("dokument_statusnr"), dokumentid, Globals.MitarbeiterNr)
                MsgBox(da.Rows(i1).Item("dokument_statusnr"))
                Return da.Rows(i1).Item("dokument_statusnr")
            End If
        Next
        da.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.Status_Erstellen Method

Public Function Status_Erstellen( _
   ByVal dokumentid As String, _
   ByVal blsequenz As Boolean _
)

Parameters

dokumentid
Required.
blsequenz
Required.

Source code

[Visual Basic]
    Public Function Status_Erstellen(ByVal dokumentid As String, ByVal blsequenz As Boolean)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentberabeigung_status_erstellen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            If Globals.bckdokument = False Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            End If
            If blsequenz = False Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blsequenz", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blsequenz", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            End If

            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.check_abschluss Method

Public Function check_abschluss( _
   ByVal dokumentid As String, _
   ByVal mitarbeiternr As Integer _
)

Parameters

dokumentid
Required.
mitarbeiternr
Required.

Source code

[Visual Basic]
    Public Function check_abschluss(ByVal dokumentid As String, ByVal mitarbeiternr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentberarbeitung_abschluss"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@abschlussstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@abschlussstatus").Value
            If i <> 0 Then
                insert_history_status_abschluss(i, dokumentid, 9998)
                Dokument_Abschliessen(dokumentid, i)
            End If

            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.get_coldindex_and_statusnr Method

Public Function get_coldindex_and_statusnr( _
   ByVal dokumentid As String, _
   ByVal aufheben As Boolean, _
   ByVal reaktivieren As Boolean _
) As DataTable

Parameters

dokumentid
Required.
aufheben
Required.
reaktivieren
Required.

Source code

[Visual Basic]
    Public Function get_coldindex_and_statusnr(ByVal dokumentid As String, ByVal aufheben As Boolean, ByVal reaktivieren As Boolean) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_coldindex_and_aufhebungsstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@reaktivieren", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, reaktivieren))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aufhebungsstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@aufhebungsstatus").Value
            If (i <> 0 And aufheben) Or (i <> 0 And reaktivieren) Then
                insert_history_status(i, dokumentid, MitarbeiterNr)
                Dim d As New edokadb.clsDokument()
                d.cpMainConnectionProvider = conn
                d.sDokumentid = New SqlString(CType(dokumentid, String))
                d.SelectOne()
                d.iStatusnr = New SqlInt32(CType(i, Int32))
                'Rel. 3.6
                d.daMutiertam = New SqlDateTime(CType(Now(), DateTime))
                d.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))

                conn.OpenConnection()
                d.Update()
                conn.CloseConnection(True)
                d.Dispose()
            End If
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.insert_Message Method

Public Function insert_Message( _
   ByVal typ As Integer, _
   ByVal Dokumentid As String, _
   ByVal message As String, _
   ByVal betreff As String, _
   ByVal absender As Integer, _
   ByVal empfaenger As Integer, _
   ByVal status As Integer _
)

Parameters

typ
Required.
Dokumentid
Required.
message
Required.
betreff
Required.
absender
Required.
empfaenger
Required.
status
Required.

Source code

[Visual Basic]
    Public Function insert_Message(ByVal typ As Integer, ByVal Dokumentid As String, ByVal message As String, ByVal betreff As String, _
                                   ByVal absender As Integer, ByVal empfaenger As Integer, ByVal status As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_message_insert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@absender", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, absender))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, empfaenger))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, betreff))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, message))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@weiterleiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, typ))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.insert_history_status Method

Public Function insert_history_status( _
   ByVal statusnr As Integer, _
   ByVal dokumentid As String, _
   ByVal Verantwortlicher As Integer _
)

Parameters

statusnr
Required.
dokumentid
Required.
Verantwortlicher
Required.

Source code

[Visual Basic]
    Public Function insert_history_status(ByVal statusnr As Integer, ByVal dokumentid As String, ByVal Verantwortlicher As Integer)
        Dim sh As New edokadb.clsStatushistory()
        sh.cpMainConnectionProvider = conn
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        conn.OpenConnection()
        key = dbkey.get_dbkey("statushistory")
        sh.iStatushistorynr = New SqlInt32(CType(key, Int32))
        sh.iStatus = New SqlInt32(CType(statusnr, Int32))
        sh.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        sh.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        sh.bAktiv = New SqlBoolean(True)
        sh.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        sh.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        sh.sDokumentid = New SqlString(CType(dokumentid, String))
        sh.iVerantwortlich = New SqlInt32(CType(Verantwortlicher, Int32))
        conn.OpenConnection()
        sh.Insert()
        conn.CloseConnection(True)
        dbkey.Dispose()
        sh.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.insert_history_status_abschluss Method

Public Function insert_history_status_abschluss( _
   ByVal statusnr As Integer, _
   ByVal dokumentid As String, _
   ByVal Verantwortlicher As Integer _
)

Parameters

statusnr
Required.
dokumentid
Required.
Verantwortlicher
Required.

Source code

[Visual Basic]
    Public Function insert_history_status_abschluss(ByVal statusnr As Integer, ByVal dokumentid As String, ByVal Verantwortlicher As Integer)
        Dim sh As New edokadb.clsStatushistory()
        sh.cpMainConnectionProvider = conn
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        conn.OpenConnection()
        key = dbkey.get_dbkey("statushistory")
        sh.iStatushistorynr = New SqlInt32(CType(key, Int32))
        sh.iStatus = New SqlInt32(CType(statusnr, Int32))
        sh.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        sh.iMutierer = New SqlInt32(CType(9998, Int32))
        sh.bAktiv = New SqlBoolean(True)
        sh.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        sh.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        sh.sDokumentid = New SqlString(CType(dokumentid, String))
        sh.iVerantwortlich = New SqlInt32(CType(Verantwortlicher, Int32))
        conn.OpenConnection()
        sh.Insert()
        conn.CloseConnection(True)
        dbkey.Dispose()
        sh.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.loeschart Method

Private Function loeschart( _
   ByVal dokid As String _
)

Parameters

dokid
Required.

Source code

[Visual Basic]
    Private Function loeschart(ByVal dokid As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_check_aufhebung_loeschung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@res", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.ExecuteNonQuery()
            Return scmCmdToExecute.Parameters("@res").Value
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.parstext Method

Public Function parstext( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Public Function parstext(ByVal s As String) As String
        s = s.Replace("&dokumentid&", dokumentwerte.Rows(0).Item("dokumentid"))
        s = s.Replace("&nrpar00&", dokumentwerte.Rows(0).Item("nrpar00"))
        s = s.Replace("&bkpar00&", dokumentwerte.Rows(0).Item("bkpar00"))
        s = s.Replace("&dokumenttyp&", dokumentwerte.Rows(0).Item("bezeichnung"))
        s = s.Replace("&status&", dokumentwerte.Rows(0).Item("status"))
        s = s.Replace("&statusdatum&", Today)
        s = s.Replace("&verantwortlich&", dokumentwerte.Rows(0).Item("verantwortlich"))
        s = s.Replace("&absender&", dokumentwerte.Rows(0).Item("absender"))
        s = s.Replace("&empfaenger&", dokumentwerte.Rows(0).Item("empfaenger"))
        Return s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.set_aufgehoben Method

Public Function set_aufgehoben( _
   ByVal dokumentid As String _
)

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function set_aufgehoben(ByVal dokumentid As String)
        Dim dt As DataTable
        dt = get_coldindex_and_statusnr(dokumentid, True, False)
        Archivfnkt.insert_coldupdate_status(dt, dokumentid, "Alt")
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling.set_geloescht Method

Private Sub set_geloescht( _
   ByVal dokid As String _
)

Parameters

dokid
Required.

Source code

[Visual Basic]
    Private Sub set_geloescht(ByVal dokid As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_delete"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschgrund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "Gelöscht, da Partner saldiert ist"))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            Dim dt As DataTable
            dt = get_coldindex_and_statusnr(dokid, False, False)
            Archivfnkt.insert_coldupdate_status(dt, dokid, "Alt")
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


Statushandling Fields

Statushandling overview

Fields

field dokumentwerte
field ds
field m_abgeschlossen
field m_aktuellerstatus
field m_ausgangsarchivierung
field m_bemerkungverantwortlicher
field m_dokumentid
field m_eingangsarchivierung
field m_folgestatus
field m_neuerstatus

See Also

Statushandling Class


dokumentwerte Variable

Dim dokumentwerte As DataTable

Source code

[Visual Basic]
    Dim dokumentwerte As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


ds Variable

Dim ds As New edokadb.clsDokument_status()

Source code

[Visual Basic]
    Dim ds As New edokadb.clsDokument_status()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_abgeschlossen Variable

Dim m_abgeschlossen As Boolean

Source code

[Visual Basic]
    Dim m_abgeschlossen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_aktuellerstatus Variable

Dim m_aktuellerstatus As Integer

Source code

[Visual Basic]
    Dim m_aktuellerstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_ausgangsarchivierung Variable

Dim m_ausgangsarchivierung As Boolean

Source code

[Visual Basic]
    Dim m_ausgangsarchivierung As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_bemerkungverantwortlicher Variable

Dim m_bemerkungverantwortlicher As String

Source code

[Visual Basic]
    Dim m_bemerkungverantwortlicher As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_eingangsarchivierung Variable

Dim m_eingangsarchivierung As Boolean

Source code

[Visual Basic]
    Dim m_eingangsarchivierung As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_folgestatus Variable

Dim m_folgestatus As Boolean

Source code

[Visual Basic]
    Dim m_folgestatus As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


m_neuerstatus Variable

Dim m_neuerstatus As Integer

Source code

[Visual Basic]
    Dim m_neuerstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Statushandling


WebOCHostCtrl Class

For a list of all members of this type, see WebOCHostCtrl Members.

System.Object
System.Windows.Forms.UserControl
EDOKAApp.WebOCHostCtrl

Public Class WebOCHostCtrl
   Inherits System.Windows.Forms.UserControl

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

WebOCHostCtrl Members


WebOCHostCtrl Members

WebOCHostCtrl overview

Constructors

constructor WebOCHostCtrl Constructor

Properties

property BrowserContextMenu
property HtmlDocument

Methods

method Copy
method Cut
method DisableContextMenu
method Dispose
method EnableContextMenu
method Find
method GoBack
method GoForward
method GoHome
method InitializeComponent
method InternetOptions
method IsCopyEnabled
method IsCutEnabled
method IsPasteEnabled
method Navigate (Overloaded)
method Paste
method Print
method PrintFormatted
method ViewSource
method webBrowser_CommandStateChange
method webBrowser_DocumentComplete
method webBrowser_StatusTextChange
method webBrowser_TopLevelNavigateComplete2

Events

event CommandStateChange
event DisableBack
event DisableForward
event DocumentComplete
event EnableBack
event EnableForward
event StatusTextChange
event TopLevelNavigateComplete2

Fields

field components
field doc
field enableCtxMenu
field rm
field webBrowser

See Also

WebOCHostCtrl Class


WebOCHostCtrl Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

        'Add any initialization after the InitializeComponent() call

        ' Load resources.
        rm = New ResourceManager("WebOCHostCtrl", System.Reflection.Assembly.GetExecutingAssembly())
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl Properties

WebOCHostCtrl overview

Properties

property BrowserContextMenu
property HtmlDocument

See Also

WebOCHostCtrl Class


WebOCHostCtrl.BrowserContextMenu Property

Public Property BrowserContextMenu() As Boolean

Source code

[Visual Basic]
    Public Property BrowserContextMenu() As Boolean
        Get
            BrowserContextMenu = enableCtxMenu
        End Get
        Set(ByVal Value As Boolean)
            ' Disable it. Note that we'll need to do this for each
            ' page navigation, as the event sink is specific to an
            ' instance of MSHTML.
            If (True = Value) Then
                DisableContextMenu()
            Else
                EnableContextMenu()
            End If

            enableCtxMenu = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.HtmlDocument Property

Public ReadOnly Property HtmlDocument() As mshtml.HTMLDocument

Source code

[Visual Basic]
    Public ReadOnly Property HtmlDocument() As mshtml.HTMLDocument
        Get
            Dim doc As HTMLDocument
            Try
                doc = CType(webBrowser.Document, mshtml.HTMLDocument)
            Catch
                Throw (New Exception(rm.GetString("Err_HtmlDocumentNotReady")))
            End Try

            HtmlDocument = doc
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl Methods

WebOCHostCtrl overview

Methods

method Copy
method Cut
method DisableContextMenu
method Dispose
method EnableContextMenu
method Find
method GoBack
method GoForward
method GoHome
method InitializeComponent
method InternetOptions
method IsCopyEnabled
method IsCutEnabled
method IsPasteEnabled
method Navigate (Overloaded)
method Paste
method Print
method PrintFormatted
method ViewSource
method webBrowser_CommandStateChange
method webBrowser_DocumentComplete
method webBrowser_StatusTextChange
method webBrowser_TopLevelNavigateComplete2

See Also

WebOCHostCtrl Class


WebOCHostCtrl.Copy Method

Public Sub Copy()

Source code

[Visual Basic]
    Public Sub Copy()
        webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_COPY, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DONTPROMPTUSER)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.Cut Method

Public Sub Cut()

Source code

[Visual Basic]
    Public Sub Cut()
        webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_CUT, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DONTPROMPTUSER)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.DisableContextMenu Method

Public Sub DisableContextMenu()

Source code

[Visual Basic]
    Public Sub DisableContextMenu()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If

            rm = Nothing
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.EnableContextMenu Method

Public Sub EnableContextMenu()

Source code

[Visual Basic]
    Public Sub EnableContextMenu()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.Find Method

Public Sub Find()

Source code

[Visual Basic]
    Public Sub Find()
        Dim cmdt As IOleCommandTarget
        Dim o As Object

        ' If the doc object isn't set to anything, or there's
        ' some bizarre error in accessing IOleCommandTarget,
        ' exit gracefully.
        Try
            cmdt = CType(doc, IOleCommandTarget)
            'cmdt.Exec(cmdGUID, MiscCommandTarget.Find, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DODEFAULT, o, o)
        Catch
            Throw (New Exception(Err.GetException().Message))
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.GoBack Method

Public Sub GoBack()

Source code

[Visual Basic]
    Public Sub GoBack()
        webBrowser.GoBack()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.GoForward Method

Public Sub GoForward()

Source code

[Visual Basic]
    Public Sub GoForward()
        webBrowser.GoForward()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.GoHome Method

Public Sub GoHome()

Source code

[Visual Basic]
    Public Sub GoHome()
        webBrowser.GoHome()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(WebOCHostCtrl))
        Me.webBrowser = New AxSHDocVw.AxWebBrowser()
        CType(Me.webBrowser, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'webBrowser
        '
        Me.webBrowser.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.webBrowser.Enabled = True
        Me.webBrowser.OcxState = CType(resources.GetObject("webBrowser.OcxState"), System.Windows.Forms.AxHost.State)
        Me.webBrowser.Size = New System.Drawing.Size(616, 320)
        Me.webBrowser.TabIndex = 0
        '
        'WebOCHostCtrl
        '
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.webBrowser})
        Me.Name = "WebOCHostCtrl"
        Me.Size = New System.Drawing.Size(616, 320)
        CType(Me.webBrowser, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.InternetOptions Method

Public Sub InternetOptions()

Source code

[Visual Basic]
    Public Sub InternetOptions()
        Dim cmdt As IOleCommandTarget
        Dim o As Object

        ' If the doc object isn't set to anything, or there's
        ' some bizarre error in accessing IOleCommandTarget,
        ' exit gracefully.
        Try
            cmdt = CType(doc, IOleCommandTarget)
            'cmdt.Exec(cmdGUID, MiscCommandTarget.Options, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DODEFAULT, o, o)
        Catch
            ' Throw (New Exception(Err.GetException().Message))
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.IsCopyEnabled Method

Public Function IsCopyEnabled() As Boolean

Source code

[Visual Basic]
    Public Function IsCopyEnabled() As Boolean
        Dim res As SHDocVw.OLECMDF = webBrowser.QueryStatusWB(SHDocVw.OLECMDID.OLECMDID_COPY)
        If (res And SHDocVw.OLECMDF.OLECMDF_ENABLED) = SHDocVw.OLECMDF.OLECMDF_ENABLED Then
            IsCopyEnabled = True
        Else
            IsCopyEnabled = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.IsCutEnabled Method

Public Function IsCutEnabled() As Boolean

Source code

[Visual Basic]
    Public Function IsCutEnabled() As Boolean
        Dim res As SHDocVw.OLECMDF = webBrowser.QueryStatusWB(SHDocVw.OLECMDID.OLECMDID_CUT)
        If (res And SHDocVw.OLECMDF.OLECMDF_ENABLED) = SHDocVw.OLECMDF.OLECMDF_ENABLED Then
            IsCutEnabled = True
        Else
            IsCutEnabled = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.IsPasteEnabled Method

Public Function IsPasteEnabled() As Boolean

Source code

[Visual Basic]
    Public Function IsPasteEnabled() As Boolean
        Dim qVal As SHDocVw.OLECMDF = webBrowser.QueryStatusWB(SHDocVw.OLECMDID.OLECMDID_PASTE)
        Dim i As Integer
        If (qVal And SHDocVw.OLECMDF.OLECMDF_ENABLED) = SHDocVw.OLECMDF.OLECMDF_ENABLED Then
            IsPasteEnabled = True
        Else
            IsPasteEnabled = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


Navigate Method

Overload List

[Visual Basic] Public Overloads Sub Navigate(ByVal url As String)

[Visual Basic] Public Overloads Sub Navigate(ByVal url As String, ByVal o As Object)

See Also

WebOCHostCtrl | EDOKAApp


WebOCHostCtrl.Paste Method

Public Sub Paste()

Source code

[Visual Basic]
    Public Sub Paste()
        webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_PASTE, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DONTPROMPTUSER)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.Print Method

Public Sub Print( _
   ByVal doUI As Boolean _
)

Parameters

doUI
Required.

Source code

[Visual Basic]
    Public Sub Print(ByVal doUI As Boolean)
        Dim doOpt As SHDocVw.OLECMDEXECOPT

        If doUI Then
            doOpt = SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_PROMPTUSER
        Else
            doOpt = SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_PROMPTUSER
        End If

        webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_PRINT, doOpt)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.PrintFormatted Method

Public Sub PrintFormatted( _
   ByVal tmplPath As String _
)

Parameters

tmplPath
Required.

Source code

[Visual Basic]
    Public Sub PrintFormatted(ByVal tmplPath As String)
        Dim o As New Object()

        webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_PRINT, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DONTPROMPTUSER, CType(tmplPath, Object), o)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.ViewSource Method

Public Sub ViewSource()

Source code

[Visual Basic]
    Public Sub ViewSource()
        Dim cmdt As IOleCommandTarget
        Dim o As Object

        ' If the doc object isn't set to anything, or there's
        ' some bizarre error in accessing IOleCommandTarget,
        ' exit gracefully.
        Try
            cmdt = CType(doc, IOleCommandTarget)
            'cmdt.Exec(cmdGUID, MiscCommandTarget.ViewSource, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DODEFAULT, o, o)
        Catch
            Throw (New Exception(Err.GetException().Message))
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.webBrowser_CommandStateChange Method

Private Sub webBrowser_CommandStateChange( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_CommandStateChangeEvent _
) Handles webBrowser.CommandStateChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webBrowser_CommandStateChange(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_CommandStateChangeEvent) Handles webBrowser.CommandStateChange
        If CommandState.Back = e.command Then
            If True = e.enable Then
                RaiseEvent EnableBack(sender, New System.EventArgs())
            Else
                RaiseEvent DisableBack(sender, New System.EventArgs())
            End If
        ElseIf CommandState.Forward = e.command Then
            If True = e.enable Then
                RaiseEvent EnableForward(sender, New System.EventArgs())
            Else
                RaiseEvent DisableForward(sender, New System.EventArgs())
            End If
        Else
            RaiseEvent CommandStateChange(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.webBrowser_DocumentComplete Method

Private Sub webBrowser_DocumentComplete( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_DocumentCompleteEvent _
) Handles webBrowser.DocumentComplete

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webBrowser_DocumentComplete(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_DocumentCompleteEvent) Handles webBrowser.DocumentComplete
        Try
            doc = CType(webBrowser.Document, mshtml.HTMLDocument)
        Catch
            ' Not a fatal error - we might be hosting a Word doc in-place,
            ' e.g.
        End Try

        ' Bubble up to our host.
        RaiseEvent DocumentComplete(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.webBrowser_StatusTextChange Method

Private Sub webBrowser_StatusTextChange( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent _
) Handles webBrowser.StatusTextChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webBrowser_StatusTextChange(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent) Handles webBrowser.StatusTextChange
        RaiseEvent StatusTextChange(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.webBrowser_TopLevelNavigateComplete2 Method

Private Sub webBrowser_TopLevelNavigateComplete2( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event _
) Handles webBrowser.NavigateComplete2

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webBrowser_TopLevelNavigateComplete2(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event) Handles webBrowser.NavigateComplete2
        If (webBrowser.LocationURL).Equals(Convert.ToString(e.uRL)) Then
            RaiseEvent TopLevelNavigateComplete2(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl Events

WebOCHostCtrl overview

Events

event CommandStateChange
event DisableBack
event DisableForward
event DocumentComplete
event EnableBack
event EnableForward
event StatusTextChange
event TopLevelNavigateComplete2

See Also

WebOCHostCtrl Class


CommandStateChange Event

Public Event CommandStateChange( _
   ByVal Sender As Object, _
   ByVal E As AxSHDocVw.DWebBrowserEvents2_CommandStateChangeEvent _
)

Parameters

Sender
Required.
E
Required.

Source code

[Visual Basic]
    Public Event CommandStateChange(ByVal Sender As Object, ByVal E As AxSHDocVw.DWebBrowserEvents2_CommandStateChangeEvent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


DisableBack Event

Public Event DisableBack( _
   ByVal Sender As Object, _
   ByVal E As System.EventArgs _
)

Parameters

Sender
Required.
E
Required.

Source code

[Visual Basic]
    Public Event DisableBack(ByVal Sender As Object, ByVal E As System.EventArgs)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


DisableForward Event

Public Event DisableForward( _
   ByVal Sender As Object, _
   ByVal E As System.EventArgs _
)

Parameters

Sender
Required.
E
Required.

Source code

[Visual Basic]
    Public Event DisableForward(ByVal Sender As Object, ByVal E As System.EventArgs)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


DocumentComplete Event

Public Event DocumentComplete( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_DocumentCompleteEvent _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Event DocumentComplete(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_DocumentCompleteEvent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


EnableBack Event

Public Event EnableBack( _
   ByVal Sender As Object, _
   ByVal E As System.EventArgs _
)

Parameters

Sender
Required.
E
Required.

Source code

[Visual Basic]
    Public Event EnableBack(ByVal Sender As Object, ByVal E As System.EventArgs)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


EnableForward Event

Public Event EnableForward( _
   ByVal Sender As Object, _
   ByVal E As System.EventArgs _
)

Parameters

Sender
Required.
E
Required.

Source code

[Visual Basic]
    Public Event EnableForward(ByVal Sender As Object, ByVal E As System.EventArgs)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


StatusTextChange Event

Public Event StatusTextChange( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Event StatusTextChange(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


TopLevelNavigateComplete2 Event

Public Event TopLevelNavigateComplete2( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Event TopLevelNavigateComplete2(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl Fields

WebOCHostCtrl overview

Fields

field components
field doc
field enableCtxMenu
field rm
field webBrowser

See Also

WebOCHostCtrl Class


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


doc Variable

Private WithEvents doc As HtmlDocument

Source code

[Visual Basic]
    Private WithEvents doc As HtmlDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


enableCtxMenu Variable

Private enableCtxMenu As Boolean

Source code

[Visual Basic]
    Private enableCtxMenu As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


rm Variable

Private rm As ResourceManager

Source code

[Visual Basic]
    Private rm As ResourceManager

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


webBrowser Variable

Friend WithEvents webBrowser As AxSHDocVw.AxWebBrowser

Source code

[Visual Basic]
    Friend WithEvents webBrowser As AxSHDocVw.AxWebBrowser

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


Win32 Class

For a list of all members of this type, see Win32 Members.

System.Object
EDOKAApp.Win32

Public Class Win32

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Win32 Members


Win32 Members

Win32 overview

Methods

method GetWindowLong
method SendMessage
method SetToolColors
method SetWindowLong

See Also

Win32 Class


Win32 Methods

Win32 overview

Methods

method GetWindowLong
method SendMessage
method SetToolColors
method SetWindowLong

See Also

Win32 Class


Win32.GetWindowLong Method

Public Declare Function GetWindowLong Lib "user32" Alias "GetWindowLongA" ( _
   ByVal hwnd As IntPtr, _
   ByVal nIndex As Integer _
) As Integer

Parameters

hwnd
Required.
nIndex
Required.

Source code

[Visual Basic]
    Public Declare Function GetWindowLong Lib "user32" Alias "GetWindowLongA" (ByVal hwnd As IntPtr, ByVal nIndex As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32


Win32.SendMessage Method

Public Declare Function SendMessage Lib "user32.dll" Alias "SendMessageA" ( _
   ByVal hwnd As IntPtr, _
   ByVal wMsg As Integer, _
   ByVal wParam As Integer, _
   ByVal lParam As String _
) As Integer

Parameters

hwnd
Required.
wMsg
Required.
wParam
Required.
lParam
Required.

Source code

[Visual Basic]
    Public Declare Function SendMessage Lib "user32.dll" Alias "SendMessageA" (ByVal hwnd As IntPtr, ByVal wMsg As Integer, ByVal wParam As Integer, ByVal lParam As String) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32


Win32.SetToolColors Method

Public Declare Function SetToolColors Lib "user32.dll" Alias "SendMessageA" ( _
   ByVal hwnd As IntPtr, _
   ByVal wMsg As Integer, _
   ByVal wParam As Integer, _
   ByVal lParam As Integer _
) As Integer

Parameters

hwnd
Required.
wMsg
Required.
wParam
Required.
lParam
Required.

Source code

[Visual Basic]
    Public Declare Function SetToolColors Lib "user32.dll" Alias "SendMessageA" (ByVal hwnd As IntPtr, ByVal wMsg As Integer, ByVal wParam As Integer, ByVal lParam As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32


Win32.SetWindowLong Method

Public Declare Function SetWindowLong Lib "user32" Alias "SetWindowLongA" ( _
   ByVal hwnd As IntPtr, _
   ByVal nIndex As Integer, _
   ByVal dwNewLong As Integer _
) As Integer

Parameters

hwnd
Required.
nIndex
Required.
dwNewLong
Required.

Source code

[Visual Basic]
    Public Declare Function SetWindowLong Lib "user32" Alias "SetWindowLongA" (ByVal hwnd As IntPtr, ByVal nIndex As Integer, ByVal dwNewLong As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32


Win32API Class

For a list of all members of this type, see Win32API Members.

System.Object
EDOKAApp.Win32API

Public Class Win32API

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Win32API Members


Win32API Members

Win32API overview

Methods

method BringWindowToTop
method CreateDirectory
method EnumWindows
method EnumWindowsDllImport
method FindWindow
method FindWindowAny
method FindWindowNullClassName
method FindWindowNullWindowCaption
method GetClassName
method GetDiskFreeSpace
method GetDiskFreeSpaceEx
method GetDriveType
method GetParent
method GetVersionEx
method GetWindow
method GetWindowLong
method GetWindowText
method IsIconic
method IsPwrHibernateAllowed
method IsWindowVisible
method SetActiveWindow
method SetForegroundWindow
method SetSuspendState
method ShowWindow
method SwapMouseButton

See Also

Win32API Class


Win32API Methods

Win32API overview

Methods

method BringWindowToTop
method CreateDirectory
method EnumWindows
method EnumWindowsDllImport
method FindWindow
method FindWindowAny
method FindWindowNullClassName
method FindWindowNullWindowCaption
method GetClassName
method GetDiskFreeSpace
method GetDiskFreeSpaceEx
method GetDriveType
method GetParent
method GetVersionEx
method GetWindow
method GetWindowLong
method GetWindowText
method IsIconic
method IsPwrHibernateAllowed
method IsWindowVisible
method SetActiveWindow
method SetForegroundWindow
method SetSuspendState
method ShowWindow
method SwapMouseButton

See Also

Win32API Class


Win32API.BringWindowToTop Method

Public Declare Function BringWindowToTop Lib "user32" Alias "BringWindowToTop" ( _
   ByVal hwnd As Long _
) As Long

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function BringWindowToTop Lib "user32" Alias "BringWindowToTop" (ByVal hwnd As Long) As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.CreateDirectory Method

Public Declare Function CreateDirectory Lib "kernel32" Alias "CreateDirectoryA" ( _
   ByVal lpPathName As String, _
   ByVal lpSecurityAttributes As SECURITY_ATTRIBUTES _
) As Boolean

Parameters

lpPathName
Required.
lpSecurityAttributes
Required.

Source code

[Visual Basic]
    Public Declare Function CreateDirectory Lib "kernel32" _
       Alias "CreateDirectoryA" (ByVal lpPathName As String, _
                                 ByVal lpSecurityAttributes _
                                     As SECURITY_ATTRIBUTES) As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.EnumWindows Method

Public Declare Function EnumWindows Lib "user32.dll" Alias "EnumWindows" ( _
   ByVal callback As EnumWindowsCallback, _
   ByVal lParam As Integer _
) As Integer

Parameters

callback
Required.
lParam
Required.

Source code

[Visual Basic]
    Public Declare Function EnumWindows Lib "user32.dll" _
        Alias "EnumWindows" (ByVal callback As EnumWindowsCallback, _
                             ByVal lParam As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.EnumWindowsDllImport Method

<DllImport("user32.dll", EntryPoint:="EnumWindows", SetLastError:=True, CharSet:=CharSet.Ansi, ExactSpelling:=True, CallingConvention:=CallingConvention.StdCall)> _
Public Shared Function EnumWindowsDllImport( _
   ByVal callback As EnumWindowsCallback, _
   ByVal lParam As Integer _
) As Integer

Parameters

callback
Required.
lParam
Required.

Source code

[Visual Basic]
    <DllImport("user32.dll", EntryPoint:="EnumWindows", SetLastError:=True, _
    CharSet:=CharSet.Ansi, ExactSpelling:=True, _
    CallingConvention:=CallingConvention.StdCall)> _
    Public Shared Function EnumWindowsDllImport(ByVal callback As EnumWindowsCallback, _
                                                ByVal lParam As Integer) As Integer
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.FindWindow Method

Public Declare Auto Function FindWindow Lib "user32.dll" Alias "FindWindow" ( _
   ByVal lpClassName As String, _
   ByVal lpWindowName As String _
) As Integer

Parameters

lpClassName
Required.
lpWindowName
Required.

Source code

[Visual Basic]
    Public Declare Auto Function FindWindow Lib "user32.dll" _
        Alias "FindWindow" (ByVal lpClassName As String, _
                            ByVal lpWindowName As String) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.FindWindowAny Method

Public Declare Auto Function FindWindowAny Lib "user32.dll" Alias "FindWindow" ( _
   ByVal lpClassName As Integer, _
   ByVal lpWindowName As Integer _
) As Integer

Parameters

lpClassName
Required.
lpWindowName
Required.

Source code

[Visual Basic]
    Public Declare Auto Function FindWindowAny Lib "user32.dll" _
    Alias "FindWindow" (ByVal lpClassName As Integer, _
                        ByVal lpWindowName As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.FindWindowNullClassName Method

Public Declare Auto Function FindWindowNullClassName Lib "user32.dll" Alias "FindWindow" ( _
   ByVal lpClassName As Integer, _
   ByVal lpWindowName As String _
) As Integer

Parameters

lpClassName
Required.
lpWindowName
Required.

Source code

[Visual Basic]
    Public Declare Auto Function FindWindowNullClassName Lib "user32.dll" _
        Alias "FindWindow" (ByVal lpClassName As Integer, _
                            ByVal lpWindowName As String) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.FindWindowNullWindowCaption Method

Public Declare Auto Function FindWindowNullWindowCaption Lib "user32.dll" Alias "FindWindow" ( _
   ByVal lpClassName As String, _
   ByVal lpWindowName As Integer _
) As Integer

Parameters

lpClassName
Required.
lpWindowName
Required.

Source code

[Visual Basic]
    Public Declare Auto Function FindWindowNullWindowCaption Lib "user32.dll" _
       Alias "FindWindow" (ByVal lpClassName As String, _
                           ByVal lpWindowName As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetClassName Method

Public Declare Function GetClassName Lib "user32.dll" Alias "GetClassNameA" ( _
   ByVal hwnd As Integer, _
   ByVal lpClassName As StringBuilder, _
   ByVal cch As Integer _
) As Integer

Parameters

hwnd
Required.
lpClassName
Required.
cch
Required.

Source code

[Visual Basic]
    Public Declare Function GetClassName Lib "user32.dll" _
       Alias "GetClassNameA" (ByVal hwnd As Integer, _
                              ByVal lpClassName As StringBuilder, _
                              ByVal cch As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetDiskFreeSpace Method

Public Declare Function GetDiskFreeSpace Lib "kernel32" Alias "GetDiskFreeSpaceA" ( _
   ByVal lpRootPathName As String, _
   ByRef lpSectorsPerCluster As Integer, _
   ByRef lpBytesPerSector As Integer, _
   ByRef lpNumberOfFreeClusters As Integer, _
   ByRef lpTotalNumberOfClusters As Integer _
) As Integer

Parameters

lpRootPathName
Required.
lpSectorsPerCluster
Required.
lpBytesPerSector
Required.
lpNumberOfFreeClusters
Required.
lpTotalNumberOfClusters
Required.

Source code

[Visual Basic]
    Public Declare Function GetDiskFreeSpace Lib "kernel32" _
        Alias "GetDiskFreeSpaceA" (ByVal lpRootPathName As String, _
                                   ByRef lpSectorsPerCluster As Integer, _
                                   ByRef lpBytesPerSector As Integer, _
                                   ByRef lpNumberOfFreeClusters As Integer, _
                                   ByRef lpTotalNumberOfClusters As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetDiskFreeSpaceEx Method

Public Declare Function GetDiskFreeSpaceEx Lib "kernel32" Alias "GetDiskFreeSpaceExA" ( _
   ByVal lpRootPathName As String, _
   ByRef lpFreeBytesAvailableToCaller As Integer, _
   ByRef lpTotalNumberOfBytes As Integer, _
   ByRef lpTotalNumberOfFreeBytes As UInt32 _
) As Integer

Parameters

lpRootPathName
Required.
lpFreeBytesAvailableToCaller
Required.
lpTotalNumberOfBytes
Required.
lpTotalNumberOfFreeBytes
Required.

Source code

[Visual Basic]
    Public Declare Function GetDiskFreeSpaceEx Lib "kernel32" _
        Alias "GetDiskFreeSpaceExA" (ByVal lpRootPathName As String, _
                                     ByRef lpFreeBytesAvailableToCaller As Integer, _
                                     ByRef lpTotalNumberOfBytes As Integer, _
                                     ByRef lpTotalNumberOfFreeBytes As UInt32) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetDriveType Method

Public Declare Function GetDriveType Lib "kernel32" Alias "GetDriveTypeA" ( _
   ByVal nDrive As String _
) As Integer

Parameters

nDrive
Required.

Source code

[Visual Basic]
    Public Declare Function GetDriveType Lib "kernel32" _
        Alias "GetDriveTypeA" (ByVal nDrive As String) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetParent Method

Public Declare Function GetParent Lib "user32.dll" Alias "GetParent" ( _
   ByVal hwnd As Integer _
) As Integer

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function GetParent Lib "user32.dll" _
        Alias "GetParent" (ByVal hwnd As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetVersionEx Method

Declare Ansi Function GetVersionEx Lib "kernel32.dll" Alias "GetVersionExA" ( _
   ByRef osvi As OSVersionInfo _
) As Boolean

Parameters

osvi
Required.

Source code

[Visual Basic]
    Declare Ansi Function GetVersionEx Lib "kernel32.dll" _
        Alias "GetVersionExA" (ByRef osvi As OSVersionInfo) As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetWindow Method

Public Declare Function GetWindow Lib "user32.dll" Alias "GetWindow" ( _
   ByVal hwnd As Integer, _
   ByVal wCmd As Integer _
) As Integer

Parameters

hwnd
Required.
wCmd
Required.

Source code

[Visual Basic]
    Public Declare Function GetWindow Lib "user32.dll" _
        Alias "GetWindow" (ByVal hwnd As Integer, _
                           ByVal wCmd As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetWindowLong Method

Public Declare Function GetWindowLong Lib "user32.dll" Alias "GetWindowLongA" ( _
   ByVal hwnd As Integer, _
   ByVal nIndex As Integer _
) As Integer

Parameters

hwnd
Required.
nIndex
Required.

Source code

[Visual Basic]
    Public Declare Function GetWindowLong Lib "user32.dll" _
        Alias "GetWindowLongA" (ByVal hwnd As Integer, _
                                ByVal nIndex As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.GetWindowText Method

Public Declare Sub GetWindowText Lib "user32.dll" Alias "GetWindowTextA" ( _
   ByVal hWnd As Integer, _
   ByVal lpString As StringBuilder, _
   ByVal nMaxCount As Integer _
)

Parameters

hWnd
Required.
lpString
Required.
nMaxCount
Required.

Source code

[Visual Basic]
    Public Declare Sub GetWindowText Lib "user32.dll" _
        Alias "GetWindowTextA" (ByVal hWnd As Integer, _
                                ByVal lpString As StringBuilder, _
                                ByVal nMaxCount As Integer)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.IsIconic Method

Public Declare Function IsIconic Lib "user32.dll" Alias "IsIconic" ( _
   ByVal hwnd As Integer _
) As Boolean

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function IsIconic Lib "user32.dll" _
        Alias "IsIconic" (ByVal hwnd As Integer) As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.IsPwrHibernateAllowed Method

Public Declare Function IsPwrHibernateAllowed Lib "Powrprof.dll" Alias "IsPwrHibernateAllowed" () As Integer

Source code

[Visual Basic]
    Public Declare Function IsPwrHibernateAllowed Lib "Powrprof.dll" _
        Alias "IsPwrHibernateAllowed" () As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.IsWindowVisible Method

Public Declare Function IsWindowVisible Lib "user32.dll" Alias "IsWindowVisible" ( _
   ByVal hwnd As Integer _
) As Boolean

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function IsWindowVisible Lib "user32.dll" _
        Alias "IsWindowVisible" (ByVal hwnd As Integer) As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.SetActiveWindow Method

Public Declare Function SetActiveWindow Lib "user32.dll" Alias "SetActive" ( _
   ByVal hwnd As Integer _
) As Integer

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function SetActiveWindow Lib "user32.dll" _
        Alias "SetActive" (ByVal hwnd As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.SetForegroundWindow Method

Public Declare Function SetForegroundWindow Lib "user32.dll" Alias "SetForegroundWindow" ( _
   ByVal hwnd As Integer _
) As Integer

Parameters

hwnd
Required.

Source code

[Visual Basic]
    Public Declare Function SetForegroundWindow Lib "user32.dll" _
        Alias "SetForegroundWindow" (ByVal hwnd As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.SetSuspendState Method

Public Declare Function SetSuspendState Lib "Powrprof.dll" Alias "SetSuspendState" ( _
   ByVal Hibernate As Integer, _
   ByVal ForceCritical As Integer, _
   ByVal DisableWakeEvent As Integer _
) As Integer

Parameters

Hibernate
Required.
ForceCritical
Required.
DisableWakeEvent
Required.

Source code

[Visual Basic]
    Public Declare Function SetSuspendState Lib "Powrprof.dll" _
        Alias "SetSuspendState" (ByVal Hibernate As Integer, _
                                 ByVal ForceCritical As Integer, _
                                 ByVal DisableWakeEvent As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.ShowWindow Method

Public Declare Function ShowWindow Lib "user32.dll" Alias "ShowWindow" ( _
   ByVal hwnd As Integer, _
   ByVal nCmdShow As Integer _
) As Integer

Parameters

hwnd
Required.
nCmdShow
Required.

Source code

[Visual Basic]
    Public Declare Function ShowWindow Lib "user32.dll" _
        Alias "ShowWindow" (ByVal hwnd As Integer, ByVal nCmdShow As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


Win32API.SwapMouseButton Method

Declare Function SwapMouseButton Lib "user32.dll" Alias "SwapMouseButton" ( _
   ByVal bSwap As Integer _
) As Integer

Parameters

bSwap
Required.

Source code

[Visual Basic]
    Declare Function SwapMouseButton Lib "user32.dll" _
        Alias "SwapMouseButton" (ByVal bSwap As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Win32API


WindowPositions Class

For a list of all members of this type, see WindowPositions Members.

System.Object
EDOKAApp.WindowPositions

Public Class WindowPositions

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

WindowPositions Members


WindowPositions Members

WindowPositions overview

Properties

property Height
property Left
property Mitarbeiternr
property Top
property Width
property Window

Methods

method Get_Position
method Set_Position

Fields

field m_height
field m_left
field m_mitarbeiternr
field m_top
field m_width
field m_window

See Also

WindowPositions Class


WindowPositions Properties

WindowPositions overview

Properties

property Height
property Left
property Mitarbeiternr
property Top
property Width
property Window

See Also

WindowPositions Class


WindowPositions.Height Property

Property Height() As Long

Source code

[Visual Basic]
    Property Height() As Long
        Get
            Return m_height
        End Get
        Set(ByVal Value As Long)
            m_height = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Left Property

Property Left() As Long

Source code

[Visual Basic]
    Property Left() As Long
        Get
            Return m_left
        End Get
        Set(ByVal Value As Long)
            m_left = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Mitarbeiternr Property

Property Mitarbeiternr() As Integer

Source code

[Visual Basic]
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Integer)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Top Property

Property Top() As Long

Source code

[Visual Basic]
    Property Top() As Long
        Get
            Return m_top
        End Get
        Set(ByVal Value As Long)
            m_top = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Width Property

Property Width() As Long

Source code

[Visual Basic]
    Property Width() As Long
        Get
            Return m_width
        End Get
        Set(ByVal Value As Long)
            m_width = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Window Property

Property Window()

Source code

[Visual Basic]
    Property Window()
        Get
            Return m_window
        End Get
        Set(ByVal Value)
            m_window = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions Methods

WindowPositions overview

Methods

method Get_Position
method Set_Position

See Also

WindowPositions Class


WindowPositions.Get_Position Method

Public Sub Get_Position( _
   ByVal Frm As Form _
)

Parameters

Frm
Required.

Source code

[Visual Basic]
    Public Sub Get_Position(ByVal Frm As Form)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable("coldindex")
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.[sp_windowpositions]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            conn.OpenConnection()
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Formular", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Frm.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@top", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Frm.Top))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@left", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Frm.Left))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@width", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Frm.Width))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@height", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Frm.Height))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
        If dtToReturn.Rows.Count > 0 Then
            Frm.Top = dtToReturn.Rows(0).Item("top")
            Frm.Left = dtToReturn.Rows(0).Item("left")
            Frm.Width = dtToReturn.Rows(0).Item("width")
            Frm.Height = dtToReturn.Rows(0).Item("height")
        End If
        dtToReturn.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions.Set_Position Method

Public Sub Set_Position( _
   ByVal frm As Form _
)

Parameters

frm
Required.

Source code

[Visual Basic]
    Public Sub Set_Position(ByVal frm As Form)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable("coldindex")
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.[sp_windowpositions]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            conn.OpenConnection()
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Formular", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, frm.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@top", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, frm.Top))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@left", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, frm.Left))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@width", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, frm.Width))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@height", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, frm.Height))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
        If dtToReturn.Rows.Count > 0 Then
            frm.Top = dtToReturn.Rows(0).Item("top")
            frm.Left = dtToReturn.Rows(0).Item("left")
            frm.Width = dtToReturn.Rows(0).Item("width")
            frm.Height = dtToReturn.Rows(0).Item("height")
        End If
        dtToReturn.Dispose()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WindowPositions Fields

WindowPositions overview

Fields

field m_height
field m_left
field m_mitarbeiternr
field m_top
field m_width
field m_window

See Also

WindowPositions Class


m_height Variable

Dim m_height As Long

Source code

[Visual Basic]
    Dim m_height As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


m_left Variable

Dim m_left As Long

Source code

[Visual Basic]
    Dim m_left As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Integer

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


m_top Variable

Dim m_top As Long

Source code

[Visual Basic]
    Dim m_top As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


m_width Variable

Dim m_width As Long

Source code

[Visual Basic]
    Dim m_width As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


m_window Variable

Dim m_window As String

Source code

[Visual Basic]
    Dim m_window As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WindowPositions


WordLib Class

For a list of all members of this type, see WordLib Members.

System.Object
EDOKAApp.WordLib

Public Class WordLib

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

WordLib Members


WordLib Members

WordLib overview

Properties

property BLAdresse1
property BLAdresse2
property BLDel2Page
property BLQuittungstext
property BLUnterschrift1
property BLUnterschrift2
property CreateDoc
property DokumentDatum
property DokumentID
property DokumentName
property Dokument_Saved
property Dokumentcoldindex_Changed
property Dokumentcoldindex_changedbr
property Dokumentfilename
property Dokumentidbr
property Dokumenttypnr
property Errormessage
property Ersetzte_Dokumente_Reaktivieren
property Ersetzte_Dokumente_Reaktivierenbr
property ProgressBar
property SaveBLDossier
property Save_ColdIndex
property Save_ColdIndexbr
property Save_Dokument
property Save_DokumentFunktionen
property Save_DokumentFunktionenbr
property Save_Dokumentbr
property Save_Dokumentinfomeldungen
property Save_Dokumentinfomeldungenbr
property Save_Dokumentwerte
property Save_Dokumentwertebr
property Save_Dokumentzuordnungen
property Save_Dokumentzuordnungenbr
property Save_Notizen
property Save_Notizenbr
property bldelquittungkube
property bldokument
property dokumentcoldindex_status
property dokumentcoldindex_statusbr
property dokumentid_changed
property dokumentid_changedbr
property dokumentidalt
property dokumentidaltbr
property save_dokumentcoldindex
property save_dokumentcoldindexbr
property save_dokumentersetzen
property save_dokumentersetzenbr
property save_historystatus
property save_historystatusbr
property save_stv
property save_verantwortlicher
property send_statusmessage
property txtBemerkung_Verantwortlicher
property txtDokumenttyp
property txtPartner

Methods

method ActivateWord
method Bar25I
method Bar25Ics
method Cancel_IDVPortfeuille
method Cancel_IDVPortfeuille_BackGround
method Change_Docname
method Change_Dokumentstatus
method Check_Doks
method CloseDoc
method CloseDocAndWord
method Close_And_Destroy
method Close_And_Destroy_excel
method Control_Word
method Control_Word_readonly
method Create_Dokument
method Create_Dokument_Before_Fill
method Create_Empty_Doc
method Create_Empty_Doc_and_Save
method Create_Excel_Before_Fill
method Create_Excel_Doc
method Create_IDVDokument
method Create_IDV_Doc
method Create_Labels
method Delete_File
method Disable_Enable_FKeys
method Disable_Enable_MenuFunctions
method Disable_Enable_MenuFunctions_Excel
method Dokument_Vervollstaendigen
method Dokumente_Reaktivieren
method Dokumentwerte_Uebertragen
method Excel_Vervollstaendigen
method Excel_Werte_Auslesen
method FeldMakros
method FileWatcher
method Fill_Dokument
method Finishing
method Generate_Barcodes
method Get_Docvars
method HeaderFooterAnzeigen
method IDV_makros_bearbeiten
method Init_IDV_Variablen
method Init_ObjWatcher
method Insert_Kopfzeile
method Insert_TextFelder
method Office_Freigeben
method Open_Document
method Open_Excel
method Pruefziffer
method ResetFunctions
method ResetFunctions_Excel
method Restore
method Restore_Coldindex
method Restore_Data
method Restore_Datasets
method Restore_Dokumentersetzen
method Restore_Dokumentfunktionen
method Restore_Dokumentwerte
method Restore_InfoEmpfaenger
method Restore_Notizen
method Restore_Statushistory
method Restore_dokumentzuordnungen
method Save_Data
method Save_Doc
method Save_Doc_Temp
method ShowDoc
method StartExcel
method StartIDVP
method StartWord
method StartWord_New_Instance
method Update_Dokumentdetails
method WATCHFILE
method Word_Werte_Auslesen
method check_word
method convert
method convert_excel
method convert_wordfelder
method delete_Textfelder
method delete_dokumentstatus
method filechange
method get_dokumentdaten
method ins_Barcode
method insert_Barcode
method insert_Barcode_Excel
method insert_Textfield
method insert_wordart
method logchange
method objWord_DocumentBeforeSave
method set_headerbookmark

Events

event OfficeFinished

Fields

field BarTextIn
field BarTextOut
field CharValue
field CheckDokumentname
field CheckSum
field Cursor_Positionieren
field DoCheckSum
field DocReadonly
field DokumenTtyp
field Dokument_Temp
field Dokument_To_Create
field Dokument_To_Save
field Dokumentdaten
field Excel_Dokument
field Finished
field II
field IsProtected
field M_Errormessage
field Office_Vorlage
field OhneIDV
field Save_DateTime
field Sum
field TempString
field Textboxes
field Textboxesi
field WordWatch
field Word_Active
field WordnewInstance
field barcodeout
field dc
field dcMTBS
field dcinvisible
field dckein
field docExcel
field docWord
field dokudata
field idvdll
field inEditMode
field isactiv
field m_CreateDoc
field m_DokumentDatum
field m_DokumentFilename
field m_DokumentID
field m_DokumentTypnr
field m_Dokumentname
field m_amsdokument
field m_document_saved
field m_dokumentidbr
field m_objdc
field m_sKopyDokID
field m_txtdokumenttyp
field m_txtpartner
field objExcel
field objResult
field objWatcher
field objWord
field ofile
field oread
field savecount
field timerloop
field xx

See Also

WordLib Class


WordLib Properties

WordLib overview

Properties

property BLAdresse1
property BLAdresse2
property BLDel2Page
property BLQuittungstext
property BLUnterschrift1
property BLUnterschrift2
property CreateDoc
property DokumentDatum
property DokumentID
property DokumentName
property Dokument_Saved
property Dokumentcoldindex_Changed
property Dokumentcoldindex_changedbr
property Dokumentfilename
property Dokumentidbr
property Dokumenttypnr
property Errormessage
property Ersetzte_Dokumente_Reaktivieren
property Ersetzte_Dokumente_Reaktivierenbr
property ProgressBar
property SaveBLDossier
property Save_ColdIndex
property Save_ColdIndexbr
property Save_Dokument
property Save_DokumentFunktionen
property Save_DokumentFunktionenbr
property Save_Dokumentbr
property Save_Dokumentinfomeldungen
property Save_Dokumentinfomeldungenbr
property Save_Dokumentwerte
property Save_Dokumentwertebr
property Save_Dokumentzuordnungen
property Save_Dokumentzuordnungenbr
property Save_Notizen
property Save_Notizenbr
property bldelquittungkube
property bldokument
property dokumentcoldindex_status
property dokumentcoldindex_statusbr
property dokumentid_changed
property dokumentid_changedbr
property dokumentidalt
property dokumentidaltbr
property save_dokumentcoldindex
property save_dokumentcoldindexbr
property save_dokumentersetzen
property save_dokumentersetzenbr
property save_historystatus
property save_historystatusbr
property save_stv
property save_verantwortlicher
property send_statusmessage
property txtBemerkung_Verantwortlicher
property txtDokumenttyp
property txtPartner

See Also

WordLib Class


BLAdresse1 Property

Public BLAdresse1 As String = ""

Source code

[Visual Basic]
    Public BLAdresse1 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BLAdresse2 Property

Public BLAdresse2 As String = ""

Source code

[Visual Basic]
    Public BLAdresse2 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BLDel2Page Property

Public BLDel2Page As Boolean = False

Source code

[Visual Basic]
    Public BLDel2Page As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BLQuittungstext Property

Public BLQuittungstext As String = ""

Source code

[Visual Basic]
    Public BLQuittungstext As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BLUnterschrift1 Property

Public BLUnterschrift1 As String = ""

Source code

[Visual Basic]
    Public BLUnterschrift1 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BLUnterschrift2 Property

Public BLUnterschrift2 As String = ""

Source code

[Visual Basic]
    Public BLUnterschrift2 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.CreateDoc Property

Property CreateDoc() As Boolean

Source code

[Visual Basic]
    Property CreateDoc() As Boolean
        Get
            Return m_CreateDoc
        End Get
        Set(ByVal Value As Boolean)
            m_CreateDoc = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.DokumentDatum Property

Property DokumentDatum() As DateTime

Source code

[Visual Basic]
    Property DokumentDatum() As DateTime
        Get
            Return m_DokumentDatum
        End Get
        Set(ByVal Value As DateTime)
            m_DokumentDatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.DokumentID Property

Property DokumentID() As String

Source code

[Visual Basic]
    Property DokumentID() As String
        Get
            Return m_DokumentID
        End Get
        Set(ByVal Value As String)
            m_DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.DokumentName Property

Property DokumentName() As String

Source code

[Visual Basic]
    Property DokumentName() As String
        Get
            Return m_Dokumentname
        End Get
        Set(ByVal Value As String)
            m_Dokumentname = Value

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokument_Saved Property

Property Dokument_Saved() As Boolean

Source code

[Visual Basic]
    Property Dokument_Saved() As Boolean
        Get
            Return m_document_saved
        End Get
        Set(ByVal Value As Boolean)
            m_document_saved = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokumentcoldindex_Changed Property

Public Dokumentcoldindex_Changed As Boolean

Source code

[Visual Basic]
    Public Dokumentcoldindex_Changed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokumentcoldindex_changedbr Property

Public Dokumentcoldindex_changedbr As Boolean

Source code

[Visual Basic]
    Public Dokumentcoldindex_changedbr As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokumentfilename Property

Property Dokumentfilename() As String

Source code

[Visual Basic]
    Property Dokumentfilename() As String
        Get
            Return m_DokumentFilename
        End Get
        Set(ByVal Value As String)
            m_DokumentFilename = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokumentidbr Property

Property Dokumentidbr() As String

Source code

[Visual Basic]
    Property Dokumentidbr() As String
        Get
            Return m_dokumentidbr
        End Get
        Set(ByVal Value As String)
            m_dokumentidbr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_DokumentTypnr
        End Get
        Set(ByVal Value As Long)
            m_DokumentTypnr = Value

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Errormessage Property

Property Errormessage() As String

Source code

[Visual Basic]
    Property Errormessage() As String
        Get
            Return M_Errormessage
        End Get
        Set(ByVal Value As String)
            M_Errormessage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Ersetzte_Dokumente_Reaktivieren Property

Public Ersetzte_Dokumente_Reaktivieren As Boolean

Source code

[Visual Basic]
    Public Ersetzte_Dokumente_Reaktivieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Ersetzte_Dokumente_Reaktivierenbr Property

Public Ersetzte_Dokumente_Reaktivierenbr As Boolean

Source code

[Visual Basic]
    Public Ersetzte_Dokumente_Reaktivierenbr As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


ProgressBar Property

Public ProgressBar As New frmProgress( _
   True _
)

Source code

[Visual Basic]
    Public ProgressBar As New frmProgress(True)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


SaveBLDossier Property

Public SaveBLDossier As Boolean = False

Source code

[Visual Basic]
    Public SaveBLDossier As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_ColdIndex Property

Public Save_ColdIndex As DataTable

Source code

[Visual Basic]
    Public Save_ColdIndex As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_ColdIndexbr Property

Public Save_ColdIndexbr As DataTable

Source code

[Visual Basic]
    Public Save_ColdIndexbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokument Property

Public Save_Dokument As New DataTable()

Source code

[Visual Basic]
    Public Save_Dokument As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_DokumentFunktionen Property

Public Save_DokumentFunktionen As DataTable

Source code

[Visual Basic]
    Public Save_DokumentFunktionen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_DokumentFunktionenbr Property

Public Save_DokumentFunktionenbr As DataTable

Source code

[Visual Basic]
    Public Save_DokumentFunktionenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentbr Property

Public Save_Dokumentbr As New DataTable()

Source code

[Visual Basic]
    Public Save_Dokumentbr As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentinfomeldungen Property

Public Save_Dokumentinfomeldungen As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentinfomeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentinfomeldungenbr Property

Public Save_Dokumentinfomeldungenbr As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentinfomeldungenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentwerte Property

Public Save_Dokumentwerte As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentwerte As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentwertebr Property

Public Save_Dokumentwertebr As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentwertebr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentzuordnungen Property

Public Save_Dokumentzuordnungen As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentzuordnungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Dokumentzuordnungenbr Property

Public Save_Dokumentzuordnungenbr As DataTable

Source code

[Visual Basic]
    Public Save_Dokumentzuordnungenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Notizen Property

Public Save_Notizen As New DataTable()

Source code

[Visual Basic]
    Public Save_Notizen As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_Notizenbr Property

Public Save_Notizenbr As New DataTable()

Source code

[Visual Basic]
    Public Save_Notizenbr As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


bldelquittungkube Property

Public bldelquittungkube As Boolean = False

Source code

[Visual Basic]
    Public bldelquittungkube As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


bldokument Property

Public bldokument As Boolean = False

Source code

[Visual Basic]
    Public bldokument As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentcoldindex_status Property

Public dokumentcoldindex_status As String

Source code

[Visual Basic]
    Public dokumentcoldindex_status As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentcoldindex_statusbr Property

Public dokumentcoldindex_statusbr As String

Source code

[Visual Basic]
    Public dokumentcoldindex_statusbr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentid_changed Property

Public dokumentid_changed As Boolean

Source code

[Visual Basic]
    Public dokumentid_changed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentid_changedbr Property

Public dokumentid_changedbr As Boolean

Source code

[Visual Basic]
    Public dokumentid_changedbr As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentidalt Property

Public dokumentidalt As String

Source code

[Visual Basic]
    Public dokumentidalt As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokumentidaltbr Property

Public dokumentidaltbr As String

Source code

[Visual Basic]
    Public dokumentidaltbr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_dokumentcoldindex Property

Public save_dokumentcoldindex As DataTable

Source code

[Visual Basic]
    Public save_dokumentcoldindex As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_dokumentcoldindexbr Property

Public save_dokumentcoldindexbr As DataTable

Source code

[Visual Basic]
    Public save_dokumentcoldindexbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_dokumentersetzen Property

Public save_dokumentersetzen As DataTable

Source code

[Visual Basic]
    Public save_dokumentersetzen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_dokumentersetzenbr Property

Public save_dokumentersetzenbr As DataTable

Source code

[Visual Basic]
    Public save_dokumentersetzenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_historystatus Property

Public save_historystatus As Integer

Source code

[Visual Basic]
    Public save_historystatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_historystatusbr Property

Public save_historystatusbr As Integer

Source code

[Visual Basic]
    Public save_historystatusbr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_stv Property

Public save_stv As Integer

Source code

[Visual Basic]
    Public save_stv As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


save_verantwortlicher Property

Public save_verantwortlicher As Integer

Source code

[Visual Basic]
    Public save_verantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


send_statusmessage Property

Public send_statusmessage As Boolean

Source code

[Visual Basic]
    Public send_statusmessage As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


txtBemerkung_Verantwortlicher Property

Public txtBemerkung_Verantwortlicher As String

Source code

[Visual Basic]
    Public txtBemerkung_Verantwortlicher As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.txtDokumenttyp Property

Property txtDokumenttyp() As String

Source code

[Visual Basic]
    Property txtDokumenttyp() As String
        Get
            Return m_txtdokumenttyp
        End Get
        Set(ByVal Value As String)
            m_txtdokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.txtPartner Property

Property txtPartner() As String

Source code

[Visual Basic]
    Property txtPartner() As String
        Get
            Return m_txtpartner
        End Get
        Set(ByVal Value As String)
            m_txtpartner = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib Methods

WordLib overview

Methods

method ActivateWord
method Bar25I
method Bar25Ics
method Cancel_IDVPortfeuille
method Cancel_IDVPortfeuille_BackGround
method Change_Docname
method Change_Dokumentstatus
method Check_Doks
method CloseDoc
method CloseDocAndWord
method Close_And_Destroy
method Close_And_Destroy_excel
method Control_Word
method Control_Word_readonly
method Create_Dokument
method Create_Dokument_Before_Fill
method Create_Empty_Doc
method Create_Empty_Doc_and_Save
method Create_Excel_Before_Fill
method Create_Excel_Doc
method Create_IDVDokument
method Create_IDV_Doc
method Create_Labels
method Delete_File
method Disable_Enable_FKeys
method Disable_Enable_MenuFunctions
method Disable_Enable_MenuFunctions_Excel
method Dokument_Vervollstaendigen
method Dokumente_Reaktivieren
method Dokumentwerte_Uebertragen
method Excel_Vervollstaendigen
method Excel_Werte_Auslesen
method FeldMakros
method FileWatcher
method Fill_Dokument
method Finishing
method Generate_Barcodes
method Get_Docvars
method HeaderFooterAnzeigen
method IDV_makros_bearbeiten
method Init_IDV_Variablen
method Init_ObjWatcher
method Insert_Kopfzeile
method Insert_TextFelder
method Office_Freigeben
method Open_Document
method Open_Excel
method Pruefziffer
method ResetFunctions
method ResetFunctions_Excel
method Restore
method Restore_Coldindex
method Restore_Data
method Restore_Datasets
method Restore_Dokumentersetzen
method Restore_Dokumentfunktionen
method Restore_Dokumentwerte
method Restore_InfoEmpfaenger
method Restore_Notizen
method Restore_Statushistory
method Restore_dokumentzuordnungen
method Save_Data
method Save_Doc
method Save_Doc_Temp
method ShowDoc
method StartExcel
method StartIDVP
method StartWord
method StartWord_New_Instance
method Update_Dokumentdetails
method WATCHFILE
method Word_Werte_Auslesen
method check_word
method convert
method convert_excel
method convert_wordfelder
method delete_Textfelder
method delete_dokumentstatus
method filechange
method get_dokumentdaten
method ins_Barcode
method insert_Barcode
method insert_Barcode_Excel
method insert_Textfield
method insert_wordart
method logchange
method objWord_DocumentBeforeSave
method set_headerbookmark

See Also

WordLib Class


WordLib.ActivateWord Method

Public Sub ActivateWord()

Source code

[Visual Basic]
    Public Sub ActivateWord()
        'Rel 3.2 bud
        Me.Errormessage = "92"

        docWord.Activate()
        Me.Errormessage = "93"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Bar25I Method

Public Function Bar25I( _
   ByVal BarTextIn As String _
) As String

Parameters

BarTextIn
Required.

Source code

[Visual Basic]
    Public Function Bar25I(ByVal BarTextIn As String) As String
        Me.Errormessage = "208"

        ' Initialize input and output strings
        BarTextOut = ""
        BarTextIn = RTrim(LTrim(BarTextIn))

        ' Throw away non-numeric data
        TempString = ""
        For II = 1 To Len(BarTextIn)
            If IsNumeric(Mid(BarTextIn, II, 1)) Then
                TempString = TempString & Mid(BarTextIn, II, 1)
            End If
        Next II

        ' If not an even number of digits, add a leading 0
        If (Len(TempString) Mod 2) = 1 Then
            TempString = "0" & TempString
        End If

        ' Break digit pairs up and convert to characters- build output string
        For II = 1 To Len(TempString) Step 2
            'Break string into pairs of digits and get value
            CharValue = Mid(TempString, II, 2)
            'translate value to ASCII and save in BarTextOut
            If CharValue < 90 Then
                BarTextOut = BarTextOut & Chr(CharValue + 33)
            Else
                BarTextOut = BarTextOut & Chr(CharValue + 71)
            End If
        Next II

        'Build ouput string, trailing space for Windows rasterization bug
        barcodeout = "{" & BarTextOut & "} "

        'Return the string
        Bar25I = barcodeout
        Me.Errormessage = "209"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Bar25Ics Method

Public Function Bar25Ics( _
   ByVal BarTextIn As String _
) As String

Parameters

BarTextIn
Required.

Source code

[Visual Basic]
    Public Function Bar25Ics(ByVal BarTextIn As String) As String
        Me.Errormessage = "210"

        ' Initialize input and output strings
        BarTextOut = ""
        BarTextIn = RTrim(LTrim(BarTextIn))

        ' Throw away non-numeric data
        TempString = ""
        For II = 1 To Len(BarTextIn)
            If IsNumeric(Mid(BarTextIn, II, 1)) Then
                TempString = TempString & Mid(BarTextIn, II, 1)
            End If
        Next II

        ' If not an odd number of digits, add a leading 0
        If (Len(TempString) Mod 2) = 0 Then
            TempString = "0" & TempString
        End If

        ' Figure out the checksum digit
        Sum = 0
        For II = 1 To Len(TempString)
            CharValue = Mid(TempString, II, 1)
            If (II Mod 2) = 1 Then
                Sum = Sum + (3 * CharValue)
            Else
                Sum = Sum + CharValue
            End If
        Next II

        ' Figure checksum, add it as last digit
        CheckSum = 10 - (Sum Mod 10)
        If CheckSum = 10 Then CheckSum = 0
        TempString = TempString & Chr(48 + CheckSum)

        ' Break digit pairs up and convert to characters- build output string
        For II = 1 To Len(TempString) Step 2
            'Break string into pairs of digits and get value
            CharValue = Mid(TempString, II, 2)
            'translate value to ASCII and save in BarTextOut
            If CharValue < 90 Then
                BarTextOut = BarTextOut & Chr(CharValue + 33)
            Else
                BarTextOut = BarTextOut & Chr(CharValue + 71)
            End If
        Next II

        'Build ouput string, trailing space for Windows rasterization bug
        barcodeout = "{" & BarTextOut & "} "

        'Return the string
        Bar25Ics = barcodeout
        Me.Errormessage = "211"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Cancel_IDVPortfeuille Method

Public Sub Cancel_IDVPortfeuille()

Source code

[Visual Basic]
    Public Sub Cancel_IDVPortfeuille()
        Me.Errormessage = "207"

        Dim hwnd As Long
        Me.Errormessage = "1"
        hwnd = Win32API.FindWindow(vbNullString, "DC")
        While hwnd <> 0
            Dim s As String
            s = MyTxt.gettext(87)
            Dim f As New frmHinweismeldung1()
            f.Label1.Text = s
            f.MsgBoxStyle = 1
            f.ShowDialog()
            f.Dispose()

            Dim myProcess() As Process
            'Dim id As System.Diagnostics.Process
            'Dim xxx As Long
            Try
                myProcess = Process.GetProcessesByName("DC")
                'BUD - 2006-05-08 Fehler in Vista, IDVP kann nicht gekillt werden
                'myProcess(0).Kill()
                If myProcess(0).HasExited = False Then
                    If myProcess(0).CloseMainWindow() = False Then
                        Try
                            myProcess(0).Kill()
                        Catch
                        End Try
                    End If
                End If
                System.Threading.Thread.CurrentThread.Sleep(500)
            Catch
            Finally
                hwnd = Win32API.FindWindow(vbNullString, "DC")
            End Try

        End While
        '        'Exit Sub
        '       Try
        '          xx = CreateObject("DC.APPLICATION")
        '         xx.Quit()
        '    Catch
        '   End Try
        Me.Errormessage = "2"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Cancel_IDVPortfeuille_BackGround Method

Public Sub Cancel_IDVPortfeuille_BackGround()

Source code

[Visual Basic]
    Public Sub Cancel_IDVPortfeuille_BackGround()
        Me.Errormessage = "205"
        Dim hwnd As Long
        hwnd = Win32API.FindWindow(vbNullString, "DC")
        While hwnd <> 0
            Dim myProcess() As Process
            'Dim id As System.Diagnostics.Process
            'Dim xxx As Long
            Try
                myProcess = Process.GetProcessesByName("DC")
                'BUD - 2006-05-08 Fehler in Vista, IDVP kann nicht gekillt werden
                'myProcess(0).Kill()
                If myProcess(0).HasExited = False Then
                    If myProcess(0).CloseMainWindow() = False Then
                        Try
                            myProcess(0).Kill()
                        Catch
                        End Try
                    End If
                End If
                System.Threading.Thread.CurrentThread.Sleep(500)
            Catch
            Finally
                hwnd = Win32API.FindWindow(vbNullString, "DC")
            End Try
        End While
        Me.Errormessage = "206"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Change_Docname Method

Public Function Change_Docname( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Public Function Change_Docname(ByVal s As String) As String
        Me.Errormessage = "112"
        Dim splitt
        Dim t As String
        splitt = Split(s, ".")
        t = splitt(0) + splitt(1) + splitt(2)
        splitt = Split(t, ":")
        t = splitt(0) + splitt(1) + splitt(2)
        Change_Docname = t
        Me.Errormessage = "113"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Change_Dokumentstatus Method

Private Sub Change_Dokumentstatus()

Source code

[Visual Basic]
    Private Sub Change_Dokumentstatus()
        Me.Errormessage = "144"

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_archiv_changedokumentstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.StatusChanges_Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.StatusChanges_Status))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "145"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Check_Doks Method

Public Sub Check_Doks()

Source code

[Visual Basic]
    Public Sub Check_Doks()
        oread = ofile.CreateText("c:\tm.txt")
        Dim dokt As New edokadb.clsDokumenttyp()
        dokt.cpMainConnectionProvider = conn
        'conn.OpenConnection()
        Dim da As DataTable
        da = dokt.SelectAll()
        Dim a As Long
        a = InputBox("Ab Dokumenttypnr")
        Dim i As Integer
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item("aktiv") = True And da.Rows(i).Item("dokumenttypnr") > a And da.Rows(i).Item("Dokument_wird_erstellt") = True Then
                Me.Dokumenttypnr = da.Rows(i).Item("dokumenttypnr")
                oread.WriteLine("------->" + Str(da.Rows(i).Item("dokumenttypnr")) + " " + da.Rows(i).Item("bezeichnung"))
                oread.Flush()
                check_word()
            End If
        Next
        oread.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.CloseDoc Method

Public Sub CloseDoc()

Source code

[Visual Basic]
    Public Sub CloseDoc()
        Me.Errormessage = "88"

        docWord.Close(False)
        docWord = Nothing
        objWord = Nothing
        Me.Errormessage = "89"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.CloseDocAndWord Method

Public Sub CloseDocAndWord()

Source code

[Visual Basic]
    Public Sub CloseDocAndWord()
        Me.Errormessage = "90"

        'Rel 3.2 bud
        docWord.Close(False)
        docWord = Nothing
        'objWord.Quit()

        objWord = Nothing
        Me.Errormessage = "91"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Close_And_Destroy Method

Public Sub Close_And_Destroy()

Source code

[Visual Basic]
    Public Sub Close_And_Destroy()
        If Me.Excel_Dokument = True Then
            Me.Close_And_Destroy_excel()
            Exit Sub
        End If
        Try
            docWord.Close(False)
            docWord = Nothing
        Catch
        End Try
        Try
            objWord.Quit(False)
            objWord = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Close_And_Destroy_excel Method

Public Sub Close_And_Destroy_excel()

Source code

[Visual Basic]
    Public Sub Close_And_Destroy_excel()
        Try
            docExcel.Close(False)
            docExcel = Nothing
        Catch
        End Try
        Try
            objExcel.Quit()
            objExcel = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Control_Word Method

Private Sub Control_Word()

Source code

[Visual Basic]
    Private Sub Control_Word()
        Me.Errormessage = "120"

        If Me.DokumenTtyp.bNurnative.Value = True Then
            Restore(1)
            If Me.Excel_Dokument Then
                objExcel.Visible = True
                Try
                    Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Minimze)
                Catch
                End Try
                Exit Sub
            End If
            objWord.Visible = True
            Try
                Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Minimze)
            Catch
            End Try
            Exit Sub
        End If
        Me.Errormessage = "121"

        Me.DocReadonly = False
        Me.Dokument_Saved = False
        'FileWatcher()
        '        Init_ObjWatcher()
        Me.Errormessage = "122"
        WATCHFILE()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Control_Word_readonly Method

Private Sub Control_Word_readonly()

Source code

[Visual Basic]
    Private Sub Control_Word_readonly()
        Me.Errormessage = "129"

        Me.DocReadonly = True
        Me.Dokument_Saved = False
        WATCHFILE()
        Me.Errormessage = "130"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Dokument Method

Public Sub Create_Dokument( _
   ByVal DokTypeNr As Long, _
   ByVal ShowReport As Boolean _
)

Parameters

DokTypeNr
Required.
ShowReport
Required.

Source code

[Visual Basic]
    Public Sub Create_Dokument(ByVal DokTypeNr As Long, ByVal ShowReport As Boolean)
        Me.Errormessage = "77"

        'Office-Vorlage auslesen
        Me.inEditMode = False
        Me.Dokumenttypnr = DokTypeNr
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()

        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        'Temporär-Datei
        Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")
        Dokument_Temp = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + Change_Docname(Now) + ".doc"
        Dokumentfilename = Dokument_Temp

        'Nativ-Dokumentvorlage
        If Not Office_Vorlage.bIdv_vorlage.Value = True Then
            Dokument_To_Create = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_word_vorlagen") + Office_Vorlage.sOffice_vorlage.Value
            StartWord()
            objWord.Documents.Add(Template:=Dokument_To_Create)
            objWord.ActiveDocument.SaveAs(filename:=Dokumentfilename)
            docWord = objWord.ActiveDocument
        Else
            Create_IDVDokument(Office_Vorlage.sIdv_id.Value)
        End If
        Me.Errormessage = "78"
        IsProtected = False
        If docWord.ProtectionType <> WdProtectionType.wdNoProtection Then
            docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            IsProtected = True
        End If
        'Dokument ggf. entsperren, Daten übertragen, Dokument ggf. schützen
        '        If Office_Vorlage.bDokument_geschuetzt.Value = True Then
        '       docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
        '      End If
        Me.Errormessage = "79"
        Fill_Dokument(True)

        'EDEX Banklagernd
        If DokumenTtyp.bZu_retournieren.Value = True Or DokumenTtyp.iDoktypbedingteretournierung.Value > 0 Or Me.SaveBLDossier = True Then
            Me.Errormessage = "80"
            Generate_Barcodes()
        Else
            Try
                objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
            Catch
            End Try
        End If
        '        Me.ProgressBar.Close()

        If IsProtected Then
            Try
                docWord.Protect(Type:=WdProtectionType.wdAllowOnlyFormFields, noreset:=True, password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            Catch
            End Try
        End If

        Me.Errormessage = "81"
        FeldMakros()
        If objWord.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone Then
            objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
        Else
            objWord.ActiveWindow.View.Type = WdViewType.wdPrintView
        End If
        Me.Errormessage = "82"
        objWord.Visible = True
        IDV_makros_bearbeiten()
        If Cursor_Positionieren Then
            Try
                docWord.Bookmarks.Item("TGEDKCursor").Select()
                docWord.Bookmarks.Item("TGEDKCursorB").Select()
            Catch
            End Try
        End If

        Me.Errormessage = "83"
        objWord.Visible = True
        Office_Vorlage.Dispose()
        DokumenTtyp.Dispose()
        If Not ShowReport Then
            docWord = Nothing
            objWord = Nothing
        Else
            Get_Docvars(DokTypeNr)

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Dokument_Before_Fill Method

Public Function Create_Dokument_Before_Fill( _
   ByVal DokTypeNr As Long, _
   ByVal xdata As DataTable, _
   ByVal fname As String, _
   Optional ByVal sKopyDokID As String = "" _
) As Boolean

Parameters

DokTypeNr
Required.
xdata
Required.
fname
Required.
sKopyDokID
Optional. Default value is "".

Source code

[Visual Basic]
    Public Function Create_Dokument_Before_Fill(ByVal DokTypeNr As Long, ByVal xdata As DataTable, ByVal fname As String, Optional ByVal sKopyDokID As String = "") As Boolean
        Me.Errormessage = "55"
        'Office-Vorlage auslesen
        Me.inEditMode = False
        Me.Excel_Dokument = False
        Me.Dokumenttypnr = DokTypeNr
        m_sKopyDokID = sKopyDokID
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()

        Me.ProgressBar.Bar1.Value = 26
        Me.ProgressBar.Info.Text = "Office-Dokument erstellen"
        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        If Office_Vorlage.iAnwendungnr.Value = 2 Then
            If Not Create_Excel_Before_Fill(DokTypeNr, xdata, fname, sKopyDokID) Then
                Return False
            Else
                Return True
            End If
            Exit Function
        End If
        DivFnkt.TraceLog("--- Vor Temporäre Datei erstellen")
        'Temporär-Datei
        Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")
        CheckDokumentname = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + ".doc"
        Dokument_Temp = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + ".doc"
        DivFnkt.TraceLog("--- Ende Temporäre Datei erstellen")

        Me.ProgressBar.Bar1.Value = 31
        'Nativ-Dokumentvorlage
        Me.Errormessage = "56"
        If Not Office_Vorlage.bIdv_vorlage.Value = True Then
            Dim LoopCnt As Integer = 0
            Dim DokumentGeladen As Boolean = False
            While DokumentGeladen = False And LoopCnt < 4
                Try
                    LoopCnt = LoopCnt + 1

                    'Rel 3.5 / BUD / 13.01.2005
                    If sKopyDokID = "" Then
                        Dim x As New FrmDomainOfficeVorlageDatei()
                        Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
                        x.Dispose()
                    Else
                        Dim objDocMgmt As New DocMgmt()
                        Dokument_To_Create = fname
                        objDocMgmt.Get_From_DB(sKopyDokID, Dokument_To_Create)
                        objDocMgmt = Nothing
                    End If

                    FileSystem.Rename(Dokument_To_Create, fname)
                    StartWord()
                    Dokumentfilename = fname
                    objWord.Documents.Open(fname)
                    docWord = objWord.ActiveDocument
                    objWord.NormalTemplate.Saved = True
                    DokumentGeladen = True
                Catch
                    DokumentGeladen = False
                    Try
                        Close_And_Destroy()
                    Catch
                    End Try
                    Try
                        File.Delete(fname)
                    Catch
                    End Try
                Catch
                End Try
            End While
            Me.Errormessage = "57"
            If DokumentGeladen = False Then
                MyMsg.show_standardmessage(137, MsgBoxStyle.Exclamation)
                Me.ProgressBar.Visible = False
                Try
                    objWord.Visible = True
                Catch
                    StartWord()
                    objWord.Visible = True
                End Try
                Try
                Catch
                    objWord.WindowState = WdWindowState.wdWindowStateMinimize
                End Try
                Try
                    Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
                Catch
                End Try
                Return False
            End If
            Me.Errormessage = "58"
        Else
            Me.Errormessage = "59"
            Dokumentfilename = fname
            If Not OhneIDV Then
                DivFnkt.TraceLog("--- Vor IDV-Erstellung")
                Create_IDVDokument(Office_Vorlage.sIdv_id.Value)
                DivFnkt.TraceLog("--- Nach IDV-Erstellung")
                Me.Errormessage = "60"
            Else
                Me.Errormessage = "61"
                Dokument_To_Create = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_word_vorlagen") + Office_Vorlage.sIdv_id.Value + ".doc"
                StartWord()
                Dokumentfilename = fname
                objWord.Documents.Add(Template:=Dokument_To_Create)
                objWord.ActiveDocument.SaveAs(filename:=fname)
                docWord = objWord.ActiveDocument
                Me.Errormessage = "62"
            End If
        End If
        DivFnkt.TraceLog("----- Ende Dokumenterstellung IDV/Word")

        Me.Errormessage = "63"
        Me.ProgressBar.Bar1.Value = 36
        Me.ProgressBar.Bar1.Refresh()
        IsProtected = False
        If docWord.ProtectionType <> WdProtectionType.wdNoProtection Then
            docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            IsProtected = True
        End If

        'Dokument ggf. entsperren, Daten übertragen, Dokument ggf. schützen
        '        If Office_Vorlage.bDokument_geschuetzt.Value = True Then
        '       docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
        '      End If

        objWord.Visible = False
        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Vorhandene Werte aus dem Dokument auslesen"
        Word_Werte_Auslesen(xdata)
        Me.ProgressBar.Bar1.Value = 51
        Me.ProgressBar.Info.Text = "Neue und Bestehende Werte zusammenstellen"
        Me.Errormessage = "64"
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Empty_Doc Method

Public Sub Create_Empty_Doc( _
   ByVal dokumenttypnr As Integer _
)

Parameters

dokumenttypnr
Required.

Source code

[Visual Basic]
    Public Sub Create_Empty_Doc(ByVal dokumenttypnr As Integer)
        Me.Errormessage = "197"

        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()
        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        If Office_Vorlage.iAnwendungnr.Value = 2 Then
            Create_Excel_Doc(False, "")
            Exit Sub
        End If
        'Nativ-Dokumentvorlage
        If Not Office_Vorlage.bIdv_vorlage.Value = True Then
            'Dokumenterstellung ab Datenbank
            'SHU 20040301
            Dim x As New FrmDomainOfficeVorlageDatei()
            Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
            StartWord()
            Try
                objWord.Documents.Add(Template:=Dokument_To_Create)
            Catch ex As Exception
            End Try
            docWord = objWord.ActiveDocument
            Try
                objWord.NormalTemplate.Saved = True
            Catch
            End Try
            x.Dispose()
            objWord.Visible = True
            docWord = objWord.ActiveDocument
            docWord = Nothing
            objWord = Nothing
        Else
            If Not OhneIDV Then
                Create_IDV_Doc()
            Else
                StartWord()
                objWord.Documents.Add(Template:=Dokument_To_Create)
                docWord = objWord.ActiveDocument
                docWord = Nothing
                objWord = Nothing
            End If
        End If
        Me.Errormessage = "198"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Empty_Doc_and_Save Method

Public Function Create_Empty_Doc_and_Save( _
   ByVal dokumenttypnr As Integer, _
   ByVal Filename As String _
) As Boolean

Parameters

dokumenttypnr
Required.
Filename
Required.

Source code

[Visual Basic]
    Public Function Create_Empty_Doc_and_Save(ByVal dokumenttypnr As Integer, ByVal Filename As String) As Boolean
        Me.Errormessage = "199"
        Try
            Office_Vorlage.cpMainConnectionProvider = conn
            Office_Vorlage.iOffice_vorlagenr = New SqlInt32(CType(dokumenttypnr, Int32))
            Office_Vorlage.SelectOne()

            If Office_Vorlage.iAnwendungnr.Value = 2 Then
                DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(dokumenttypnr, Int32))
                DokumenTtyp.cpMainConnectionProvider = conn
                DokumenTtyp.SelectOne()
                Create_Excel_Doc(True, Filename)
                Exit Function
            End If
            StartWord()
            Create_IDV_Doc()
            docWord = objWord.ActiveDocument
            docWord.SaveAs(Filename)
            docWord.Close()
            docWord = Nothing
            objWord.Quit()
            objWord = Nothing
            Create_Empty_Doc_and_Save = True
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("WordLib.Create_Empty_Doc_and_Save.", ex.Message + " " + ex.StackTrace, TraceLevel.Warning)
            MsgBox("Bei der Generierung des Dokumentes ist ein Fehler aufgetreten. Das Dokument wird nicht generiert." + vbNewLine + vbNewLine + ex.Message + ex.StackTrace, MsgBoxStyle.Critical)
            Create_Empty_Doc_and_Save = False
        Finally
            Try
                objWord.Quit()
                objWord = Nothing
            Catch
            End Try
            Me.Cancel_IDVPortfeuille_BackGround()
        End Try

        ''Nativ-Dokumentvorlage
        'If Not Office_Vorlage.bIdv_vorlage.Value = True Then
        '    StartWord()
        '    Dim x As New EDOKAApp.frmDomainOfficeVorlage()
        '    'objWord.Documents.Add(x.Get_From_DB(Office_Vorlage.iOffice_vorlagenr.Value))
        '    docWord = objWord.ActiveDocument
        '    docWord.SaveAs(Filename)
        '    docWord.Close()
        '    docWord = Nothing
        '    objWord.Quit()
        '    objWord = Nothing
        'Else
        '    If Not OhneIDV Then
        '        StartWord()
        '        Create_IDV_Doc()
        '        docWord = objWord.ActiveDocument
        '        docWord.SaveAs(Filename)
        '        docWord.Close()
        '        docWord = Nothing
        '        objWord.Quit()
        '        objWord = Nothing
        '    Else
        '        StartWord()
        '        objWord.Documents.Add(Template:=Dokument_To_Create)
        '        docWord = objWord.ActiveDocument
        '        docWord = Nothing
        '        objWord = Nothing
        '    End If
        'End If
        Me.Errormessage = "200"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Excel_Before_Fill Method

Public Function Create_Excel_Before_Fill( _
   ByVal DokTypeNr As Long, _
   ByVal xdata As DataTable, _
   ByVal fname As String, _
   Optional ByVal sKopyDokID As String = "" _
) As Boolean

Parameters

DokTypeNr
Required.
xdata
Required.
fname
Required.
sKopyDokID
Optional. Default value is "".

Source code

[Visual Basic]
    Public Function Create_Excel_Before_Fill(ByVal DokTypeNr As Long, ByVal xdata As DataTable, ByVal fname As String, Optional ByVal sKopyDokID As String = "") As Boolean
        Dim i As Integer
        Me.inEditMode = False
        Me.Excel_Dokument = True
        Me.Dokumenttypnr = DokTypeNr
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()

        Me.ProgressBar.Bar1.Value = 31
        Me.ProgressBar.Info.Text = "Office-Dokument erstellen"
        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        'Temporär-Datei
        Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")
        Dokument_Temp = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + ".doc"

        'Nativ-Dokumentvorlage
        If Not Office_Vorlage.bIdv_vorlage.Value = True Then
            Dim abdatei As Boolean = False
            If Office_Vorlage.sOffice_vorlage.Value Is System.DBNull.Value Then
                abdatei = True
            Else
                If Office_Vorlage.sOffice_vorlage.Value = "" Then abdatei = True
            End If
            If abdatei Then

                Me.Errormessage = "96"

                Dim LoopCnt As Integer = 0
                Dim DokumentGeladen As Boolean = False
                While DokumentGeladen = False And LoopCnt < 4
                    Try
                        LoopCnt = LoopCnt + 1
                        'Rel 3.5 / BUD / 13.01.2005
                        If sKopyDokID = "" Then
                            Dim x As New FrmDomainOfficeVorlageDatei()
                            Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
                            x.Dispose()
                        Else
                            Dim objDocMgmt As New DocMgmt()
                            Dokument_To_Create = fname
                            objDocMgmt.Get_From_DB(sKopyDokID, Dokument_To_Create)
                            objDocMgmt = Nothing
                        End If

                        StartExcel()
                        Try
                            objExcel.Workbooks.Add(Template:=Dokument_To_Create)
                        Catch ex As Exception
                        End Try
                        objExcel.ActiveWorkbook.SaveAs(filename:=fname)
                        Me.Dokumentfilename = fname
                        docExcel = objExcel.ActiveWorkbook

                        'FileSystem.Rename(Dokument_To_Create, fname)
                        'StartExcel()
                        'Dokumentfilename = fname
                        'objExcel.Workbooks.Open(fname)
                        'docExcel = objExcel.ActiveWorkbook
                        DokumentGeladen = True
                    Catch
                        Me.Errormessage = "97"

                        DokumentGeladen = False
                        Try
                            Close_And_Destroy_excel()
                        Catch
                        End Try
                        Try
                            File.Delete(fname)
                        Catch
                        End Try
                    Catch
                    End Try
                End While
                Me.Errormessage = "98"
                If DokumentGeladen = False Then
                    Me.Errormessage = "99"
                    MyMsg.show_standardmessage(137, MsgBoxStyle.Exclamation)
                    Me.ProgressBar.Visible = False
                    Try
                        objExcel.Visible = True
                    Catch
                        Me.Errormessage = "100"
                        StartExcel()
                        objExcel.Visible = True

                    End Try
                    Try
                    Catch
                        objExcel.WindowState = Excel.XlWindowState.xlMinimized
                    End Try
                    Try
                        Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
                    Catch
                    End Try

                    Return False
                End If
                'Dim x As New FrmDomainOfficeVorlageDatei()
                'Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
                'StartExcel()
                'Try
                '    objExcel.Workbooks.Add(Template:=Dokument_To_Create)
                'Catch ex As Exception
                'End Try
                'objExcel.ActiveWorkbook.SaveAs(filename:=fname)
                'Me.Dokumentfilename = fname
                'docExcel = objExcel.ActiveWorkbook
                'x.Dispose()
            Else
                Dokument_To_Create = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_excel_vorlagen") + Office_Vorlage.sOffice_vorlage.Value
                StartExcel()
                Dokumentfilename = fname
                objExcel.Workbooks.Add(Template:=Dokument_To_Create)
                objExcel.ActiveWorkbook.SaveAs(filename:=fname)
                docExcel = objExcel.ActiveWorkbook
            End If
        End If

        IsProtected = False
        'For i = 1 To docExcel.Sheets.Count
        '    docExcel.Sheets(i).activate()
        '    sheetExcel = docExcel.ActiveSheet
        '    sheetExcel.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_excelvorlagen"))
        '    IsProtected = True
        'Next i
        objExcel.Visible = False
        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Vorhandene Werte aus dem Dokument auslesen"
        Excel_Werte_Auslesen(xdata)
        Me.ProgressBar.Bar1.Value = 51
        Me.ProgressBar.Info.Text = "Neue und Bestehende Werte zusammenstellen"

        'Me.Errormessage = "94"
        'Dim i As Integer
        'Me.inEditMode = False
        'Me.Excel_Dokument = True
        'Me.Dokumenttypnr = DokTypeNr
        'DokumenTtyp.cpMainConnectionProvider = conn
        'DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        'DokumenTtyp.SelectOne()

        'Me.ProgressBar.Bar1.Value = 31
        'Me.ProgressBar.Info.Text = "Office-Dokument erstellen"
        'Office_Vorlage.cpMainConnectionProvider = conn
        'Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        'Office_Vorlage.SelectOne()

        ''Temporär-Datei
        'Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")
        'Dokument_Temp = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + ".doc"

        ''Nativ-Dokumentvorlage
        'If Not Office_Vorlage.bIdv_vorlage.Value = True Then
        '    Me.Errormessage = "95"

        '    Dim abdatei As Boolean = False
        '    If Office_Vorlage.sOffice_vorlage.Value Is System.DBNull.Value Then
        '        abdatei = True
        '    Else
        '        If Office_Vorlage.sOffice_vorlage.Value = "" Then abdatei = True
        '    End If
        '    If abdatei Then
        '        Me.Errormessage = "96"

        '        Dim LoopCnt As Integer = 0
        '        Dim DokumentGeladen As Boolean = False
        '        While DokumentGeladen = False And LoopCnt < 4
        '            Try
        '                LoopCnt = LoopCnt + 1
        '                Dim x As New FrmDomainOfficeVorlageDatei()
        '                Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
        '                x.Dispose()
        '                FileSystem.Rename(Dokument_To_Create, fname)
        '                StartExcel()
        '                Dokumentfilename = fname
        '                objExcel.Workbooks.Open(fname)
        '                docExcel = objExcel.ActiveWorkbook
        '                DokumentGeladen = True
        '            Catch
        '                Me.Errormessage = "97"

        '                DokumentGeladen = False
        '                Try
        '                    Close_And_Destroy_excel()
        '                Catch
        '                End Try
        '                Try
        '                    File.Delete(fname)
        '                Catch
        '                End Try
        '            Catch
        '            End Try
        '        End While
        '        Me.Errormessage = "98"
        '        If DokumentGeladen = False Then
        '            Me.Errormessage = "99"

        '            MyMsg.show_standardmessage(137, MsgBoxStyle.Exclamation)
        '            Me.ProgressBar.Visible = False
        '            Try
        '                objExcel.Visible = True
        '            Catch
        '                Me.Errormessage = "100"
        '                StartExcel()
        '                objExcel.Visible = True

        '            End Try
        '            Return False
        '        End If

        '        'Dim x As New FrmDomainOfficeVorlageDatei()
        '        'Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
        '        'StartExcel()
        '        'Try
        '        '    objExcel.Workbooks.Add(Template:=Dokument_To_Create)
        '        'Catch ex As Exception
        '        'End Try
        '        'objExcel.ActiveWorkbook.SaveAs(filename:=fname)
        '        'Me.Dokumentfilename = fname
        '        'docExcel = objExcel.ActiveWorkbook
        '        'x.Dispose()

        '    Else
        '        Me.Errormessage = "101"
        '        Dokument_To_Create = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_excel_vorlagen") + Office_Vorlage.sOffice_vorlage.Value
        '        StartExcel()
        '        Dokumentfilename = fname
        '        objExcel.Workbooks.Add(Template:=Dokument_To_Create)
        '        objExcel.ActiveWorkbook.SaveAs(filename:=fname)
        '        docExcel = objExcel.ActiveWorkbook
        '    End If
        '    Me.Errormessage = "102"
        '    Return True
        'End If

        'IsProtected = False
        ''For i = 1 To docExcel.Sheets.Count
        ''    docExcel.Sheets(i).activate()
        ''    sheetExcel = docExcel.ActiveSheet
        ''    sheetExcel.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_excelvorlagen"))
        ''    IsProtected = True
        ''Next i
        'objExcel.Visible = False
        'Me.ProgressBar.Bar1.Value = 41
        'Me.ProgressBar.Info.Text = "Vorhandene Werte aus dem Dokument auslesen"
        'Excel_Werte_Auslesen(xdata)
        'Me.ProgressBar.Bar1.Value = 51
        'Me.ProgressBar.Info.Text = "Neue und Bestehende Werte zusammenstellen"
        'Me.Errormessage = "103"
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Excel_Doc Method

Private Sub Create_Excel_Doc( _
   ByVal save As Boolean, _
   ByVal filename As String _
)

Parameters

save
Required.
filename
Required.

Source code

[Visual Basic]
    Private Sub Create_Excel_Doc(ByVal save As Boolean, ByVal filename As String)
        Me.Errormessage = "203"

        Dim i As Integer
        Me.inEditMode = False
        Me.Excel_Dokument = True

        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        'Nativ-Dokumentvorlage

        Dim abdatei As Boolean = False
        If Office_Vorlage.sOffice_vorlage.Value Is System.DBNull.Value Then
            abdatei = True
        Else
            If Office_Vorlage.sOffice_vorlage.Value = "" Then abdatei = True
        End If
        If abdatei Then
            Dim x As New FrmDomainOfficeVorlageDatei()
            Dokument_To_Create = x.Get_From_DB(Me.Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
            StartExcel()
            Try
                objExcel.Workbooks.Add(Template:=Dokument_To_Create)
            Catch ex As Exception
            End Try
            docExcel = objExcel.ActiveWorkbook
            x.Dispose()
        Else
            Dokument_To_Create = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_excel_vorlagen") + Office_Vorlage.sOffice_vorlage.Value
            StartExcel()
            objExcel.Workbooks.Add(Template:=Dokument_To_Create)
            If save Then
                objExcel.ActiveWorkbook.SaveAs(filename)
                objExcel.ActiveWorkbook.Close()
                objExcel.Quit()
            Else
                objExcel.Visible = True
            End If
            objExcel = Nothing
        End If
        Me.Errormessage = "204"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_IDVDokument Method

Private Sub Create_IDVDokument( _
   ByVal idvid As String _
)

Parameters

idvid
Required.

Source code

[Visual Basic]
    Private Sub Create_IDVDokument(ByVal idvid As String)
        Me.Errormessage = "5"

        DivFnkt.TraceLog("----- Vor IDV-Kill")
        Cancel_IDVPortfeuille()
        DivFnkt.TraceLog("----- Nach IDV-Kill")

        DivFnkt.TraceLog("----- Word starten")

        StartWord()
        DivFnkt.TraceLog("----- Ende Word starten")
        '22.07.2003 Visible=False
        objWord.Visible = False

        DivFnkt.TraceLog("----- Vor DC-Create Object")
        m_objdc = CreateObject("DC.Application")
        DivFnkt.TraceLog("----- Nach DC-Create Object")
        m_objdc.WindowState = dc.dcWindowState.dcInvisible
        m_objdc.WindowState = 0
        System.Threading.Thread.CurrentThread.Sleep(10)
        DivFnkt.TraceLog("----- Vor Init IDV-Vars")
        Init_IDV_Variablen()
        DivFnkt.TraceLog("----- Nach Init IDV-Vars")
        m_objdc.WindowState = dc.dcWindowState.dcInvisible
        'Call Get_IDV_Values()
        DivFnkt.TraceLog("----- Vor DC-Parameter")
        Me.Errormessage = "6"
        If Not Office_Vorlage.bIdv_nativ.Value = True Then
            m_objdc.WindowState = 0
            m_objdc.WordPlusDialog = dc.dcWordPlusDialogs.dcKein
            m_objdc.DisableStandardMacros()
            DivFnkt.TraceLog("----- Nach DC-Parameter")
        End If
        Me.Errormessage = "7"
        If Office_Vorlage.bIdv_nativ.Value = True Then
            m_objdc.CreateDocument(dc.dcModus.dcMTBS, CType(Office_Vorlage.sIdv_id.Value, Integer))
            StartWord()
            docWord = objWord.ActiveDocument
            objWord.Visible = False
            m_objdc = Nothing
            Me.Errormessage = "8"
            Exit Sub
        Else
            Me.Errormessage = "9"
            DivFnkt.TraceLog("----- Vor IDV-Erstellung  ")
            m_objdc.CreateDocument(dc.dcModus.dcMTBS, CType(Office_Vorlage.sIdv_id.Value, Integer))
            DivFnkt.TraceLog("Dokument gespeichern: " & Dokumentfilename)
            m_objdc.SaveDoc(Dokumentfilename)
            DivFnkt.TraceLog("Dokument gespeichert: " & Dokumentfilename)
            m_objdc.Quit()
            m_objdc = Nothing
            DivFnkt.TraceLog("----- Nach IDV-Erstellung ( DC geschlossen)  ")
            '            m_objdc = Nothing
            '           StartWord()
            '22.07.2003 Visible=False
            DivFnkt.TraceLog("----- Word unsichtbar")
            objWord.Visible = False
            DivFnkt.TraceLog("----- Word nicht sichtbar")
            Try
                docWord = objWord.ActiveDocument
            Catch ex As Exception
                Try
                    DivFnkt.TraceLog("---------- " + ex.Message)
                    StartWord()
                    objWord.Documents.Open(Dokumentfilename)
                    docWord = objWord.ActiveDocument
                    'SHU
                    objWord.NormalTemplate.Saved = True
                Catch
                    DivFnkt.TraceLog("-------------- Dokument laden fehlgeschlagen")

                End Try
            End Try
            DivFnkt.TraceLog("----- Aktives Dokument zugewiesen")

            DivFnkt.TraceLog("----- Check_Dokname")
            If docWord.Name <> DivFnkt.ExtractFilename(Dokumentfilename) Then
                docWord.Close()
                docWord = objWord.ActiveDocument
            End If
            DivFnkt.TraceLog("----- Ende_Dokname")
        End If
        m_objdc = Nothing
        Me.Errormessage = "10"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_IDV_Doc Method

Private Sub Create_IDV_Doc()

Source code

[Visual Basic]
    Private Sub Create_IDV_Doc()
        Me.Errormessage = "201"
        Cancel_IDVPortfeuille()
        m_objdc = CreateObject("DC.Application")
        m_objdc.WindowState = dc.dcWindowState.dcActivated
        System.Threading.Thread.CurrentThread.Sleep(10)
        Init_IDV_Variablen()
        m_objdc.WindowState = dc.dcWindowState.dcActivated

        If Not Office_Vorlage.bIdv_nativ.Value = True Then
            m_objdc.WindowState = dc.dcWindowState.dcActivated
            m_objdc.WordPlusDialog = dc.dcWordPlusDialogs.dcKein
            m_objdc.DisableStandardMacros()
        End If
        If Office_Vorlage.bIdv_nativ.Value = True Then
            m_objdc.CreateDocument(dc.dcModus.dcMTBS, CType(Office_Vorlage.sIdv_id.Value, Integer))
        Else
            m_objdc.CreateDocument(dc.dcModus.dcMTBS, CType(Office_Vorlage.sIdv_id.Value, Integer))
        End If
        m_objdc = Nothing
        Me.Errormessage = "202"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Create_Labels Method

Public Function Create_Labels()

Source code

[Visual Basic]
    Public Function Create_Labels()
        StartWord()
        docWord = objWord.Documents.Add
        objWord.MailingLabel.DefaultPrintBarCode = False
        objWord.MailingLabel.CreateNewDocument(Name:="Herma 4611", Address:="", AutoText:="")
        objWord.Visible = True
        docWord = Nothing
        docWord = objWord.ActiveDocument
        Dim bc As New edokadb.clsBarcodeetikette()
        Dim i As Integer
        Dim i1 As Integer
        Dim keys As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        Dim defkey As String
        Dim yy As String
        i1 = 0
        bc.cpMainConnectionProvider = conn
        For i = 0 To 50
            keys.cpMainConnectionProvider = conn
            key = keys.get_dbkey("barcodeetikette")
            defkey = LTrim(key)
            While Len(defkey) < 7
                defkey = "0" + defkey
            End While
            yy = LTrim(Str(Year(Now)))
            yy = Right(yy, 2)

            defkey = yy + defkey
            defkey = defkey + LTrim(Pruefziffer(defkey))
            bc.iBarcodenr = New SqlInt32(CType(defkey, Int32))
            bc.sDokumentid = New SqlString(CType("", String))
            bc.bAktiv = New SqlBoolean(CType(True, Boolean))
            bc.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            bc.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            conn.OpenConnection()
            bc.Insert()
            conn.CloseConnection(True)
            defkey = Bar25I(defkey)
            objWord.Selection.TypeText(defkey)
            objWord.Selection.HomeKey(unit:=Word.WdUnits.wdLine, extend:=Word.WdMovementType.wdExtend)
            objWord.Selection.Font.Name = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("barcode_font")
            objWord.Selection.Font.Size = 38
            objWord.Selection.MoveRight(Unit:=Word.WdUnits.wdCharacter, Count:=1)
            i1 = i1 + 1
            If i1 = 3 Then
                If i < 49 Then
                    objWord.Selection.MoveDown(unit:=Word.WdUnits.wdLine, count:=1)
                    objWord.Selection.MoveLeft(unit:=Word.WdUnits.wdCharacter, count:=2)
                    i1 = 0
                End If
            Else
                objWord.Selection.MoveRight(Unit:=Word.WdUnits.wdCharacter, Count:=1)
            End If

        Next
        objWord.Selection.PageSetup.TopMargin = 0
        objWord.Selection.PageSetup.LeftMargin = 10
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Delete_File Method

Public Function Delete_File()

Source code

[Visual Basic]
    Public Function Delete_File()
        Me.Errormessage = "157"

        Globals.PerfMon.insert_entry(Me.DokumentID + " Start physisches Dokument löschen")
        Try
            File.Delete(Me.Dokumentfilename)
        Catch
        End Try
        '        RaiseEvent OfficeFinished()
        Globals.PerfMon.insert_entry(Me.DokumentID + " Ende physisches Dokument löschen")
        Me.Errormessage = "158"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Disable_Enable_FKeys Method

Private Sub Disable_Enable_FKeys( _
   ByVal Enable As Boolean _
)

Parameters

Enable
Required.

Source code

[Visual Basic]
    Private Sub Disable_Enable_FKeys(ByVal Enable As Boolean)
        Try
            'Rel(3.7 / BUD)
            If Enable = False Then
                'Org aus VB -> FindKey(BuildKeyCode(wdKeyF12)).Disable
                Call objWord.FindKey(objWord.BuildKeyCode(WdKey.wdKeyF12)).Disable()
                Dim cmdctrl As Object
                Dim i As Integer
                For i = 1 To objWord.KeyBindings.Count()  'objWord.CommandBars.FindControls("FileSaveAs")
                    Debug.Write(objWord.KeyBindings.Item(i).KeyCode())
                    Debug.Write(objWord.KeyBindings.Item(i).Command())
                    If objWord.KeyBindings.Item(i).Command = "FileSaveAs" Then
                        Call objWord.FindKey(objWord.KeyBindings.Item(i).KeyCode).Disable()
                    End If
                Next
            Else
                'Org aus VB -> KeyBindings.Add KeyCode:=BuildKeyCode(wdKeyF12), KeyCategory:=wdKeyCategoryCommand, Command:="FileSaveAs"
                Call objWord.KeyBindings.Add(WdKeyCategory.wdKeyCategoryCommand, "FileSaveAs", objWord.BuildKeyCode(WdKey.wdKeyF12))
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Disable_Enable_MenuFunctions Method

Public Sub Disable_Enable_MenuFunctions( _
   ByVal Enable As Boolean _
)

Parameters

Enable
Required.

Source code

[Visual Basic]
    Public Sub Disable_Enable_MenuFunctions(ByVal Enable As Boolean)
        Me.Errormessage = "189"

        On Error Resume Next
        Dim cmdctrl As Object
        Dim i As Integer
        On Error Resume Next

        'Disable_Enable_FKeys(Enable)

        ' Rücksetzen aller Commandbars aus Performancegründen deaktivieren
        ' SHU
        ' 2004-11-16
        '        For i = 1 To objWord.CommandBars.Count
        '            objWord.CommandBars(i).Reset()
        '        Next

        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=18)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=23)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=748)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=3823)
            cmdctrl.enabled = Enable
        Next cmdctrl
        'senden an zulassen
        If Me.DokumenTtyp.bEmail_versand.Value = True Then
            For Each cmdctrl In objWord.CommandBars.FindControls(ID:=30095)
                cmdctrl.enabled = True
            Next cmdctrl
        Else
            For Each cmdctrl In objWord.CommandBars.FindControls(ID:=30095)
                cmdctrl.enabled = Enable
            Next cmdctrl
        End If
        '        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=30095)
        '       cmdctrl.enabled = Enable
        '      Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=797)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=777)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=30017)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objWord.CommandBars.FindControls(ID:=30045)
            cmdctrl.enabled = Enable
        Next cmdctrl
        '        objWord.NormalTempslate.Saved = True

        Me.Errormessage = "190"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Disable_Enable_MenuFunctions_Excel Method

Public Sub Disable_Enable_MenuFunctions_Excel( _
   ByVal Enable As Boolean _
)

Parameters

Enable
Required.

Source code

[Visual Basic]
    Public Sub Disable_Enable_MenuFunctions_Excel(ByVal Enable As Boolean)
        Me.Errormessage = "193"

        On Error Resume Next
        Dim cmdctrl As Object
        Dim i As Integer
        On Error Resume Next
        For i = 1 To objExcel.CommandBars.Count
            objExcel.CommandBars(i).Reset()
        Next

        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=18)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=23)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=748)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=3823)
            cmdctrl.enabled = Enable
        Next cmdctrl
        'senden an zulassen
        If Me.DokumenTtyp.bEmail_versand.Value = True Then
            For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=30095)
                cmdctrl.enabled = True
            Next cmdctrl
        Else
            For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=30095)
                cmdctrl.enabled = Enable
            Next cmdctrl
        End If
        '        For Each cmdctrl In objexcel.CommandBars.FindControls(ID:=30095)
        '       cmdctrl.enabled = Enable
        '      Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=797)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=777)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=30017)
            cmdctrl.enabled = Enable
        Next cmdctrl
        For Each cmdctrl In objExcel.CommandBars.FindControls(ID:=30045)
            cmdctrl.enabled = Enable
        Next cmdctrl
        'objExcel.NormalTemplate.Saved = True
        Me.Errormessage = "194"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokument_Vervollstaendigen Method

Public Sub Dokument_Vervollstaendigen( _
   ByVal xdata As DataTable _
)

Parameters

xdata
Required.

Source code

[Visual Basic]
    Public Sub Dokument_Vervollstaendigen(ByVal xdata As DataTable)
        Me.Errormessage = "68"

        If Me.Excel_Dokument = True Then
            Excel_Vervollstaendigen(xdata)
            Exit Sub
        End If
        Me.ProgressBar.Bar1.Value = 61
        Me.ProgressBar.Info.Text = "Dokumentwerte übertragen"
        If docWord.ProtectionType <> WdProtectionType.wdNoProtection Then
            docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            IsProtected = True
        End If

        DivFnkt.TraceLog("Word Visible = false")

        objWord.Visible = False
        DivFnkt.TraceLog("Windowstate")
        objWord.WindowState = WdWindowState.wdWindowStateMinimize
        DivFnkt.TraceLog("Doevents")
        System.Windows.Forms.Application.DoEvents()
        DivFnkt.TraceLog("FillDok Start")
        Fill_Dokument(False, xdata)
        DivFnkt.TraceLog("FillDok")
        Me.Errormessage = "69"

        'EDEX-Banklagernd
        If DokumenTtyp.bZu_retournieren.Value = True Or DokumenTtyp.iDoktypbedingteretournierung.Value > 0 Or Me.SaveBLDossier = True Then
            DivFnkt.TraceLog("Barcodes Start")
            Generate_Barcodes()
            DivFnkt.TraceLog("Barcodes Ende")
        Else
            Try
                DivFnkt.TraceLog("Active Win  start")
                objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
                DivFnkt.TraceLog("Active Win  ende")
            Catch
            End Try
        End If
        DivFnkt.TraceLog("Screenupdating true   ")
        objWord.ScreenUpdating = True
        DivFnkt.TraceLog("Active Win  end")
        Me.ProgressBar.Hide()
        DivFnkt.TraceLog("Progress Close")
        Me.Errormessage = "70"
        If IsProtected Then
            Try
                docWord.Protect(Type:=WdProtectionType.wdAllowOnlyFormFields, noreset:=True, password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            Catch
            End Try
        End If
        DivFnkt.TraceLog("Ende schützen")
        Dim A As Integer
        A = 0
        Me.Errormessage = "71"

        While A < 2
            Try
                objWord.Visible = True
                DivFnkt.TraceLog("Word Activate")
                objWord.Activate()
                DivFnkt.TraceLog("Word Activate Ende")
                A = 2
            Catch
                Try
                    System.Threading.Thread.CurrentThread.Sleep(500)
                    DivFnkt.TraceLog("Word Activate")
                    objWord.Visible = True
                    objWord.Activate()
                    DivFnkt.TraceLog("Word Activate ENde")
                    A = 2
                Catch
                    If MyMsg.Show_MessageYesNo(107) = MsgBoxResult.Yes Then
                        A = 1
                    Else
                        docWord.Close(False)
                        docWord = Nothing
                        objWord = Nothing
                        A = 3
                        Throw New Exception(MyTxt.gettext(111))
                    End If
                End Try
            End Try
        End While

        Me.Errormessage = "72"
        objWord.WindowState = WdWindowState.wdWindowStateMaximize
        FeldMakros()
        If objWord.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone Then
            objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
        Else
            objWord.ActiveWindow.View.Type = WdViewType.wdPrintView
        End If
        objWord.Visible = True

        Try
            Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Minimze)
        Catch
        End Try
        'Rel 3.5 / BUD / 13.01.2005 (IF / END IF)
        If m_sKopyDokID = "" Then
            If Me.CreateDoc = True Then IDV_makros_bearbeiten()
        End If

        If Me.CreateDoc Then
            Dim dn As String = objWord.ActiveDocument.FullName
            docWord.Save()
            docWord.Close()
            objWord.Documents.Open(dn)
            'SHU
            objWord.NormalTemplate.Saved = True
            docWord = objWord.ActiveDocument

            'EDEX Banklagernd
            If Me.bldokument = True Then
                If Me.BLDel2Page Then
                    Try
                        docWord.Bookmarks.Item("TGEDKZweiteSeite").Select()
                        objWord.Selection.Delete()

                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try

                    docWord.Save()
                    docWord.Close()
                    objWord.Documents.Open(dn)
                    'SHU
                    objWord.NormalTemplate.Saved = True
                    docWord = objWord.ActiveDocument

                End If
            End If

        End If
        docWord.Saved = False
        Me.Errormessage = "73"

        If Cursor_Positionieren Then
            Try
                docWord.Bookmarks.Item("TGEDKCursor").Select()
            Catch
                Try
                    docWord.Bookmarks.Item("TGEDKCursorB").Select()
                Catch
                End Try
            End Try
        End If
        Me.Dokument_Saved = False
        If objWord.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone Then
            objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
        Else
            objWord.ActiveWindow.View.Type = WdViewType.wdPrintView
        End If
        Me.Errormessage = "74"

        If Not Me.bldokument Then
            objWord.Visible = False
            objWord.Visible = True
        Else
            objWord.Visible = False
        End If

        Office_Vorlage.Dispose()
        DokumenTtyp.Dispose()
        'EDEX-Banklagernd
        If Me.bldokument Then
            '            Me.Save_DateTime = Me.Save_DateTime.AddSeconds(-3)
            ' Me.docWord.Save()
            Me.docWord.Close(savechanges:=True)
            'rel 372
            If objWord.Documents.Count = 0 Then
                objWord.Quit(savechanges:=False)
                objWord = Nothing
            End If
            Finishing()

            'rel 372 EDOKA nach vorne bringen
            Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
            Thread.CurrentThread.Sleep(100)

            Exit Sub
        End If
        Control_Word()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokumente_Reaktivieren Method

Public Function Dokumente_Reaktivieren( _
   ByVal dokumentid As String _
)

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function Dokumente_Reaktivieren(ByVal dokumentid As String)
        Me.Errormessage = "153"

        Dim da As New SqlDataAdapter("Select * from dokumentersetzen where hauptdokumentid='" & dokumentid & "'", Globals.sConnectionString)
        Dim ds As New DataSet()
        Dim i As Integer
        da.Fill(ds, "Ersetzen")
        For i = 0 To ds.Tables(0).Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_reaktivieren"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ds.Tables(0).Rows(i).Item(2)))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)
                Dim dt As DataTable
                Dim sth As New Statushandling()
                dt = sth.get_coldindex_and_statusnr(ds.Tables(0).Rows(i).Item(2), False, True)
                Archivfnkt.insert_coldupdate_reaktivieren(dt, ds.Tables(0).Rows(i).Item(2), "Aktuell")
                sth.Dispose()
            End Try
        Next
        da.Dispose()
        ds.Dispose()
        Me.Errormessage = "154"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Dokumentwerte_Uebertragen Method

Private Sub Dokumentwerte_Uebertragen( _
   ByVal AusParametrisierung As Boolean _
)

Parameters

AusParametrisierung
Required.

Source code

[Visual Basic]
    Private Sub Dokumentwerte_Uebertragen(ByVal AusParametrisierung As Boolean)
        Me.Errormessage = "28"
        Dim i As Long
        Dim pos As Long
        Dim pos2 As Long
        Dim Fieldlen As Long
        For i = 0 To Dokumentdaten.Rows.Count - 1
            'Beginn-Textmarke
            If Dokumentdaten.Rows(i).Item("aktiv") = True Then
                If Dokumentdaten.Rows(i).Item("beginntextmarke") Is System.DBNull.Value Then
                    Dokumentdaten.Rows(i).Item("beginntextmarke") = ""
                End If
                If Dokumentdaten.Rows(i).Item("endetextmarke") Is System.DBNull.Value Then
                    Dokumentdaten.Rows(i).Item("endetextmarke") = ""
                End If
                If Dokumentdaten.Rows(i).Item("feldname") Is System.DBNull.Value Then
                    Dokumentdaten.Rows(i).Item("feldname") = ""
                End If

                If Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKCursor" Or _
                Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKCursorB" Or _
                Dokumentdaten.Rows(i).Item("feldname") = "TGEDKCursorB" Or _
                Dokumentdaten.Rows(i).Item("feldname") = "TGEDKCursor" Then
                    Cursor_Positionieren = True
                Else

                    If Dokumentdaten.Rows(i).Item("beginntextmarke") <> "" And _
                       Dokumentdaten.Rows(i).Item("endetextmarke") = "" Then
                        Try
                            docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Select()
                            pos = docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Start
                            If AusParametrisierung Then
                                objWord.Selection.Text = Dokumentdaten.Rows(i).Item("testdaten")
                            Else
                                If Dokumentdaten.Rows(i).Item("used") = 1 Then
                                    'If Dokumentdaten.Rows(i).Item("xvalue") <> "" Then
                                    '        If Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "TGEDKDirektTelefonB" Or _
                                    '           Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "TGEDKDirektTelefonZ" Then
                                    '          objWord.Visible = True
                                    '         objWord.Selection.Text = Dokumentdaten.Rows(i).Item("xvalue") + " "
                                    '    Else
                                    objWord.Selection.Text = Dokumentdaten.Rows(i).Item("xvalue")
                                    '   End If
                                End If
                            End If
                            pos2 = objWord.Selection.End
                            If Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "XTGEDKDirektTelefonB" Or _
                               Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 23) = "XTGEDKVornameNameBetreue" Or _
                               Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "XTGEDKDirektTelefonZ" Then
                                objWord.Selection.MoveLeft(Unit:=Word.WdUnits.wdCharacter, Count:=1)
                                'hutter
                                If Me.CreateDoc Then objWord.Selection.TypeText(text:=" ")
                                objWord.Selection.SetRange(Start:=pos + 1, End:=pos2 + 1)
                                With docWord.Bookmarks
                                    .Add(Range:=objWord.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
                                    .DefaultSorting = WdBookmarkSortBy.wdSortByName
                                    .ShowHidden = False
                                End With
                            Else
                                If Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 22) = "XTGEDKDirektTelefonDokZ" Or _
                                Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 20) = "XTGEDKVornameNameDokZ" Then
                                    objWord.Selection.Text = Dokumentdaten.Rows(i).Item("xvalue")
                                    objWord.Selection.MoveLeft(Unit:=Word.WdUnits.wdCharacter, Count:=1)
                                    objWord.Selection.TypeText(text:=" ")
                                    objWord.Selection.SetRange(Start:=pos + 1, End:=pos2 + 1)
                                    With docWord.Bookmarks
                                        .Add(Range:=objWord.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
                                        .DefaultSorting = WdBookmarkSortBy.wdSortByName
                                        .ShowHidden = False
                                    End With
                                Else
                                    objWord.Visible = True
                                    objWord.Selection.SetRange(Start:=pos, End:=pos2)
                                    With docWord.Bookmarks
                                        .Add(Range:=objWord.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
                                        .DefaultSorting = WdBookmarkSortBy.wdSortByName
                                        .ShowHidden = False
                                    End With
                                End If
                            End If
                            objWord.Selection.MoveLeft(Unit:=Word.WdUnits.wdCharacter, Count:=1)
                            objWord.Selection.MoveLeft(Unit:=Word.WdUnits.wdCharacter, Count:=2, Extend:=Word.WdMovementType.wdExtend)
                            If objWord.Selection.Text = "  " Then
                                objWord.Selection.MoveRight(Unit:=Word.WdUnits.wdCharacter, Count:=1)
                                objWord.Selection.MoveLeft(Unit:=Word.WdUnits.wdCharacter, Count:=1, Extend:=Word.WdMovementType.wdExtend)
                                objWord.Selection.Delete(Unit:=Word.WdUnits.wdCharacter, Count:=1)
                            End If

                        Catch
                        End Try
                        'EDEX Banklagernd
                        If Me.bldokument = True Then
                            If Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKBLGrundlage" Then
                                If Dokumentdaten.Rows(i).Item("xvalue") = "" Then
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELGrund1").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELGrund2").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                End If
                            End If
                            If Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKBLBemerkungen" Then
                                If Dokumentdaten.Rows(i).Item("xvalue") = "" Then
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELBemerkung1").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELBemerkung2").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                End If
                            End If
                            If Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKBLBeilagezurQuittung" Then
                                If Dokumentdaten.Rows(i).Item("xvalue") = "" Then
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELBeilage1").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                    Try
                                        docWord.Bookmarks.Item("TGEDKDELBeilage2").Select()
                                        objWord.Selection.Rows.Delete()
                                    Catch
                                    End Try
                                End If
                            End If
                        End If

                    End If

                    'Beginn- und Ende-Textmarke
                    If Dokumentdaten.Rows(i).Item("beginntextmarke") <> "" And _
                       Dokumentdaten.Rows(i).Item("endetextmarke") <> "" Then
                        Try
                            docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Select()
                            pos = docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Start
                            docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("endetextmarke")).Select()
                            pos2 = docWord.Bookmarks.Item(Dokumentdaten.Rows(i).Item("endetextmarke")).Start
                            objWord.Selection.SetRange(Start:=pos, End:=pos2)
                            If AusParametrisierung Then
                                objWord.Selection.TypeText(text:=Dokumentdaten.Rows(i).Item("testdaten"))
                            Else
                                If Dokumentdaten.Rows(i).Item("used") = 1 Then
                                    '    If Dokumentdaten.Rows(i).Item("xvalue") <> "" Then
                                    objWord.Selection.TypeText(text:=Dokumentdaten.Rows(i).Item("xvalue"))
                                End If
                            End If
                            With docWord.Bookmarks
                                .Add(Range:=objWord.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
                                .DefaultSorting = WdBookmarkSortBy.wdSortByName
                                .ShowHidden = False
                            End With
                        Catch
                        End Try
                    End If
                    'Felder
                    If Dokumentdaten.Rows(i).Item("feldname") <> "" Then
                        Try
                            If docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width <> 0 Then
                                Fieldlen = docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width
                                docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width = Fieldlen + 5
                            End If
                            If AusParametrisierung Then
                                docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).Result = convert_wordfelder(Dokumentdaten.Rows(i).Item("testdaten"))
                            Else
                                If Dokumentdaten.Rows(i).Item("used") = 1 Then
                                    '    If Dokumentdaten.Rows(i).Item("xvalue") <> "" Then
                                    docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).Result = convert_wordfelder(Dokumentdaten.Rows(i).Item("xvalue"))
                                End If
                            End If
                        Catch
                        End Try
                    End If
                End If
            End If
        Next

        'EDEX Banklagernd
        If Me.bldokument = True Then
            If Me.BLUnterschrift1 <> "" Then
                docWord.Bookmarks.Item("TGEDKBLUnterschrift1").Select()
                pos = docWord.Bookmarks.Item("TGEDKBLUnterschrift1").Start
                objWord.Selection.Text = Me.BLUnterschrift1
                pos2 = objWord.Selection.End
                With docWord.Bookmarks
                    .Add(Range:=objWord.Selection.Range, Name:="TGEDKBLUnterschrift1")
                    .DefaultSorting = WdBookmarkSortBy.wdSortByName
                    .ShowHidden = False
                End With
            End If
            If Me.BLUnterschrift2 <> "" Then
                docWord.Bookmarks.Item("TGEDKBLUnterschrift2").Select()
                pos = docWord.Bookmarks.Item("TGEDKBLUnterschrift2").Start
                objWord.Selection.Text = Me.BLUnterschrift2
                pos2 = objWord.Selection.End
                With docWord.Bookmarks
                    .Add(Range:=objWord.Selection.Range, Name:="TGEDKBLUnterschrift2")
                    .DefaultSorting = WdBookmarkSortBy.wdSortByName
                    .ShowHidden = False
                End With
            End If
            Try
                docWord.Bookmarks.Item("TGEDKBLQuittungtext").Select()
                objWord.Selection.Text = Me.BLQuittungstext
            Catch
            End Try

            If bldelquittungkube = True Then
                docWord.Bookmarks.Item("TGEDKQuittungKubeB").Select()
                pos = docWord.Bookmarks.Item("TGEDKQuittungKubeB").Start
                docWord.Bookmarks.Item("TGEDKQuittungKubeE").Select()
                pos2 = docWord.Bookmarks.Item("TGEDKQuittungKubeE").Start
                objWord.Selection.SetRange(Start:=pos, End:=pos2)
                objWord.Selection.TypeText(" ")
            End If
        End If
        Me.Errormessage = "29"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Excel_Vervollstaendigen Method

Public Sub Excel_Vervollstaendigen( _
   ByVal xdata As DataTable _
)

Parameters

xdata
Required.

Source code

[Visual Basic]
    Public Sub Excel_Vervollstaendigen(ByVal xdata As DataTable)
        Me.Errormessage = "108"

        Dim Sheetnr_fuer_Cursor As Integer
        Me.ProgressBar.Bar1.Value = 61
        Me.ProgressBar.Info.Text = "Dokumentwerte übertragen"

        Dim i As Integer
        Dim i1 As Integer
        Dim sheets As Integer
        sheets = docExcel.Sheets.Count
        Sheetnr_fuer_Cursor = 0
        For i = 1 To sheets
            docExcel.Sheets(i).activate()
            For i1 = 0 To xdata.Rows.Count - 1
                Try
                    If xdata.Rows(i1).Item("beginntextmarke") = "TGEDKCursor" Or _
                    xdata.Rows(i1).Item("beginntextmarke") = "TGEDKCursorB" Or _
                    xdata.Rows(i1).Item("feldname") = "TGEDKCursorB" Or _
                    xdata.Rows(i1).Item("feldname") = "TGEDKCursor" Then
                        Try
                            objExcel.Range(docExcel.Names.Item(xdata.Rows(i1).Item("feldname")).NameLocal).Select()
                            Cursor_Positionieren = True
                            Sheetnr_fuer_Cursor = i
                        Catch
                        End Try
                    Else
                        objExcel.Range(docExcel.Names.Item(xdata.Rows(i1).Item("feldname")).NameLocal).Select()
                        objExcel.ActiveCell.FormulaR1C1 = convert_excel(xdata.Rows(i1).Item("xvalue"))
                    End If
                Catch
                End Try
            Next
            'docExcel.Sheets(i).largescroll(down:=-10)
        Next
        Me.Errormessage = "109"
        'EDEX Banklagernd
        If DokumenTtyp.bZu_retournieren.Value = True Or DokumenTtyp.iDoktypbedingteretournierung.Value > 0 Or Me.SaveBLDossier = True Then
            Generate_Barcodes()
        End If
        'If IsProtected Then
        '    For i = 1 To docExcel.Sheets.Count
        'docExcel.Sheets(i).activate()
        'sheetExcel = docExcel.ActiveSheet
        'sheetExcel.Protect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_excelvorlagen"))
        'IsProtected = True
        '    Next i
        'End If
        Me.Errormessage = "110"
        objExcel.Sheets(1).activate()
        If Cursor_Positionieren Then
            Try
                docExcel.Sheets(Sheetnr_fuer_Cursor).activate()
                objExcel.Range(docExcel.Names.Item("TGEDKCursor").NameLocal).Select()
            Catch
                Try
                    docExcel.Sheets(Sheetnr_fuer_Cursor).activate()
                    objExcel.Range(docExcel.Names.Item("TGEDKCursorB").NameLocal).Select()
                Catch
                End Try
            End Try
        Else
            objExcel.Sheets(1).activate()
        End If
        Me.ProgressBar.Hide()
        Me.Errormessage = "111"
        Control_Word()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Excel_Werte_Auslesen Method

Public Sub Excel_Werte_Auslesen( _
   ByVal xdata As DataTable _
)

Parameters

xdata
Required.

Source code

[Visual Basic]
    Public Sub Excel_Werte_Auslesen(ByVal xdata As DataTable)
        Me.Errormessage = "106"

        Dim i As Integer
        Dim i1 As Integer
        Dim sheets As Integer
        sheets = docExcel.Sheets.Count
        For i = 1 To sheets
            docExcel.Sheets(i).activate()
            For i1 = 0 To xdata.Rows.Count - 1
                Try
                    objExcel.Range(docExcel.Names.Item(xdata.Rows(i1).Item("feldname")).NameLocal).Select()
                    xdata.Rows(i1).Item("oldvalue") = objExcel.Selection.text
                    xdata.Rows(i1).Item("used") = 1
                Catch
                End Try
            Next
        Next
        Me.Errormessage = "107"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.FeldMakros Method

Private Sub FeldMakros()

Source code

[Visual Basic]
    Private Sub FeldMakros()
        Me.Errormessage = "30"
        Dim i As Integer
        For i = 0 To Dokumentdaten.Rows.Count - 1
            If Dokumentdaten.Rows(i).Item("feldname") <> "" Then
                If Dokumentdaten.Rows(i).Item("einstiegsmakro") = True Then
                    objWord.Run(docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).EntryMacro)
                End If
                If Dokumentdaten.Rows(i).Item("ausstiegsmakro") = True Then
                    objWord.Run(docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).ExitMacro)
                End If
            End If
        Next
        Me.Errormessage = "31"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.FileWatcher Method

Public Function FileWatcher()

Source code

[Visual Basic]
    Public Function FileWatcher()
        Me.Errormessage = "140"

        Save_DateTime = File.GetLastWriteTime(Me.Dokumentfilename)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Fill_Dokument Method

Private Sub Fill_Dokument( _
   ByVal AusParametrisierung As Boolean, _
   Optional ByVal xdata As DataTable = Nothing _
)

Parameters

AusParametrisierung
Required.
xdata
Optional. Default value is Nothing.

Source code

[Visual Basic]
    Private Sub Fill_Dokument(ByVal AusParametrisierung As Boolean, Optional ByVal xdata As DataTable = Nothing)
        Me.Errormessage = "24"
        If Office_Vorlage.bKopfzeile_generieren.Value = True Then
            Me.Errormessage = "25"
            Insert_Kopfzeile()
        End If
        If AusParametrisierung Then
            Me.Errormessage = "26"
            get_dokumentdaten()
            Dokumentwerte_Uebertragen(AusParametrisierung)
        Else
            Me.Errormessage = "27"
            Dokumentdaten = xdata
            Dokumentwerte_Uebertragen(AusParametrisierung)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Finishing Method

Private Sub Finishing() Handles WordWatch.DocumentClosed

Source code

[Visual Basic]
    Private Sub Finishing() Handles WordWatch.DocumentClosed
        Me.Errormessage = "134"

        If Finished Then Exit Sub
        objWatcher.EnableRaisingEvents = False
        Finished = True

        System.Threading.Thread.CurrentThread.Sleep(100)
        If WordWatch.doc_is_active Then Exit Sub
        WordWatch.Stopp()
        Globals.PerfMon.insert_entry(Me.DokumentID + " Stop Überwachung")

        Dim i As Integer

        If Not Me.Excel_Dokument Then
            If Globals.Words.Count = 0 Then Disable_Enable_MenuFunctions(True)
        Else
            If Globals.Words.Count = 0 Then Disable_Enable_MenuFunctions_Excel(True)
        End If

        If Me.DocReadonly Then
            Delete_File()
            Exit Sub
        End If
        Me.Errormessage = "135"

        Dim xtime As DateTime
        xtime = File.GetLastWriteTime(Me.Dokumentfilename)
        Dim cxtime As String = xtime.ToString
        Dim csavetime As String = Save_DateTime.ToString
        Dim diff As Integer = DateDiff(DateInterval.Second, Save_DateTime, xtime)

        'Sofern das Dokument über eine Dokumentpaket erstellt wurde, dieses aus der DP_Collection löschen
        Try
            Try
                Dim i2 As Integer
                For i2 = 1 To Globals.DP_Collection.Count
                    If Globals.DP_Collection.Item(i2) = Me.DokumentID Then
                        Globals.DP_Collection.Remove(i2)
                    End If
                    Exit For
                Next
            Catch
            End Try
        Catch
        End Try

        If diff > 2 Then
            '            If cxtime <> csavetime Then
            '            If xtime <> Save_DateTime Then

            '            If File.GetLastWriteTime(Me.Dokumentfilename) <> Save_DateTime Then
            Globals.PerfMon.insert_entry(Me.DokumentID + " Start Datensichern")
            Save_Data()
            Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Datensichern")
        Else
            Globals.PerfMon.insert_entry(Me.DokumentID + " Start Restore")
            Restore_Data()
            Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Restore")
        End If
        Me.Errormessage = "136"

        If Me.Excel_Dokument = True Then
            Try
                Try
                    objExcel.Visible = True
                    objExcel.Workbooks.Close()
                    objExcel.Application.Quit()
                    docWord = Nothing
                    objWord = Nothing
                Catch
                End Try
                docExcel = Nothing
                objExcel = Nothing
            Catch
            End Try
        Else
            Me.Errormessage = "137"

            Try
                objWord = Nothing
                docWord = Nothing
            Catch
            End Try
        End If
        Me.Errormessage = "138"

        Try
            Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Wordbearbeitung")
            Words.Remove(Me.DokumentName)
            If Me.Excel_Dokument = True Then
                If Globals.Words.Count = 0 Then
                    Me.StartExcel()
                    objExcel.Visible = False
                    Disable_Enable_MenuFunctions_Excel(True)
                    objExcel.Quit()
                    objExcel = Nothing
                End If
            Else
                If Globals.Words.Count = 0 Then
                    StartWord()
                    objWord.NormalTemplate.Saved = True
                    objWord.Visible = False
                    Disable_Enable_MenuFunctions(True)
                    If Me.WordnewInstance = True Then
                        objWord.Quit()
                    Else
                        objWord.Visible = True
                    End If
                    objWord = Nothing
                End If
            End If
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
        Catch
        Finally
            Try
                Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
            Catch
            End Try
        End Try
        Me.Errormessage = "139"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Generate_Barcodes Method

Private Sub Generate_Barcodes()

Source code

[Visual Basic]
    Private Sub Generate_Barcodes()
        If Me.Excel_Dokument Then
            insert_Barcode_Excel()
            Exit Sub
        End If
        Me.Errormessage = "36"
        Me.ProgressBar.Bar1.Value = 71
        Me.ProgressBar.Info.Text = "Bestehende Barcodes löschen"
        delete_Textfelder()
        Me.ProgressBar.Bar1.Value = 81
        Me.ProgressBar.Info.Text = "Positionen für Barcodes ermitteln"
        Insert_TextFelder()
        Me.ProgressBar.Bar1.Value = 91
        Me.ProgressBar.Info.Text = "Barcodes erstellen"
        ins_Barcode()
        Me.ProgressBar.Bar1.Value = 100
        Me.ProgressBar.Info.Text = "Dokumentgenerierung abgeschlossen"
        Me.Errormessage = "37"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Get_Docvars Method

Public Sub Get_Docvars( _
   ByVal DokTypeNr As Long _
)

Parameters

DokTypeNr
Required.

Source code

[Visual Basic]
    Public Sub Get_Docvars(ByVal DokTypeNr As Long)
        Dim id As String
        Dim rec As New edokadb.clsReporting_Dokumenttyp()
        rec.cpMainConnectionProvider = conn
        conn.OpenConnection()
        id = Now
        Dim i As Short
        For i = 1 To docWord.Bookmarks.Count
            Try
                If Left(UCase(docWord.Bookmarks.Item(i).Name), 2) <> "BK" And Left(UCase(docWord.Bookmarks.Item(i).Name), 4) <> "TGAM" Then
                    rec.sID = New SqlString(CType(id, String))
                    rec.sOFBM = New SqlString(CType(docWord.Bookmarks.Item(i).Name, String))
                    rec.Insert()
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        Next
        For i = 1 To docWord.FormFields.Count
            rec.sID = New SqlString(CType(id, String))
            rec.sOFFeld = New SqlString(CType(docWord.FormFields.Item(i).Name, String))
            rec.Insert()
        Next
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.[sp_reporting_dokumenttyp]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure

        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@id", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, id))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokTypeNr))
            If Globals.MyMsg.Show_MessageYesNo(15) = MsgBoxResult.Yes Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@VFInaktivieren", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@VFInaktivieren", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
        End Try
        Dim f As New frmReporting()
        f.show_report_dokumenttypVFelder(Dokumenttypnr, id)
        f.Show()

        scmCmdToExecute.Dispose()
        scmCmdToExecute = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.[sp_reporting_dokumenttyp]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.CommandText = "dbo.[sp_reporting_dokumenttyp_delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@id", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, id))
            scmCmdToExecute.ExecuteNonQuery()
        Catch es As Exception
            MsgBox(es.Message)
        End Try
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.HeaderFooterAnzeigen Method

Private Sub HeaderFooterAnzeigen()

Source code

[Visual Basic]
    Private Sub HeaderFooterAnzeigen()
        Me.Errormessage = "46"
        If objWord.ActiveWindow.View.SplitSpecial <> WdSpecialPane.wdPaneNone Then
            objWord.ActiveWindow.Panes.Item(2).Close()
        End If
        If objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdNormalView Or objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdOutlineView Then
            objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
        End If
        objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageHeader
        If objWord.Selection.HeaderFooter.IsHeader = True Then
            objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageFooter
        Else
            objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageHeader
        End If
        Me.Errormessage = "47"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.IDV_makros_bearbeiten Method

Public Function IDV_makros_bearbeiten() As Boolean

Source code

[Visual Basic]
    Public Function IDV_makros_bearbeiten() As Boolean
        Me.Errormessage = "11"
        Dim idvmakros As New edokadb.clsMyDokumentDaten()
        Dim makros As DataTable
        Dim i As Long

        idvmakros.cpMainConnectionProvider = conn
        makros = idvmakros.Select_IDVMakros(Me.Dokumenttypnr)

        Me.Errormessage = "12"
        For i = 0 To makros.Rows.Count - 1
            Try
                If makros.Rows(i).Item("ist_in_dll") = True Then
                    'SetForegroundWindow(...)
                    Try
                        objWord.Activate()
                    Catch
                        System.Threading.Thread.CurrentThread.Sleep(100)
                        objWord.Activate()
                    End Try
                    System.Windows.Forms.Application.DoEvents()
                    idvdll = CreateObject("IDVMakros.Application")
                    Call idvdll.CallSub(objWord, makros.Rows(i).Item("makro"))
                    System.Windows.Forms.Application.DoEvents()
                    objWord.Visible = True
                    Try
                        '                        objWord.Activate()
                    Catch
                        '                       System.Threading.Thread.CurrentThread.Sleep(100)
                        '                      objWord.Activate()
                    End Try
                Else
                    System.Windows.Forms.Application.DoEvents()
                    objWord.Run(makros.Rows(i).Item("makro"))
                    System.Windows.Forms.Application.DoEvents()
                End If
            Catch ex As Exception
                MsgBox("Fehler beim Makro-Aufruf - Makro: " + makros.Rows(i).Item("makro") + vbCrLf + vbCrLf + ex.Message)
            End Try
        Next i
        Me.Errormessage = "13"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Init_IDV_Variablen Method

Private Sub Init_IDV_Variablen()

Source code

[Visual Basic]
    Private Sub Init_IDV_Variablen()
        Me.Errormessage = "3"

        On Error Resume Next

        'Diverse Felder
        'm_objdc.DokVarClear("VarHerkunft")
        m_objdc.DokVarAdd("VarHerkunft", "EDOKA")
        m_objdc.DokVarAdd("VarSchuldner", " ")
        m_objdc.DokVarAdd("VarAdresseVorname", " ")

        'Bankangaben
        m_objdc.DokVarAdd("VarCompanyName", " ")
        m_objdc.DokVarAdd("VarCompanyBankname", " ")
        m_objdc.DokVarAdd("VarCompanyAdresse1", " ")
        m_objdc.DokVarAdd("VarCompanyAdresse2", " ")
        m_objdc.DokVarAdd("VarCompanyAdresse3", " ")
        m_objdc.DokVarAdd("VarCompanyBankbetriebseinheit", " ")
        m_objdc.DokVarAdd("VarCompanyBBENr", " ")
        m_objdc.DokVarAdd("VarCompanyBBEOrt", " ")
        m_objdc.DokVarAdd("VarCompanyBBEEMail", " ")
        m_objdc.DokVarAdd("VarCompanyBBETelefon", " ")
        m_objdc.DokVarAdd("VarCompanyBBETelefax", " ")
        m_objdc.DokVarAdd("VarCompanyBBEZusatzVordruck", " ")
        m_objdc.DokVarAdd("VarCompanyBBEZusatzInhalt", " ")
        m_objdc.DokVarAdd("VarCompanyInternet", " ")
        m_objdc.DokVarAdd("VarCompanyMWStNr", " ")
        m_objdc.DokVarAdd("VarCompanyGerichtsstand", " ")
        m_objdc.DokVarAdd("VarCompanyCantophone", " ")
        m_objdc.DokVarAdd("VarCompanyHotlineInfoline", " ")

        'Temporäre Variablen
        m_objdc.DokVarAdd("VarTempGeschaeftNr", " ")
        m_objdc.DokVarAdd("VarTempProduktebezeichnung", " ")
        m_objdc.DokVarAdd("VarTempGeburtsGruendungsdatum", " ")
        m_objdc.DokVarAdd("VarTempNationalitaetencode", " ")
        m_objdc.DokVarAdd("VarTempMarktsegment", " ")
        m_objdc.DokVarAdd("VarTempBranche", " ")
        m_objdc.DokVarAdd("VarTempGesamtbetrag", " ")
        m_objdc.DokVarAdd("VarTempBetrag1", " ")
        m_objdc.DokVarAdd("VarTempBetrag2", " ")
        m_objdc.DokVarAdd("VarTempWaehrung", " ")
        m_objdc.DokVarAdd("VarTempZinssatz1", " ")
        m_objdc.DokVarAdd("VarTempZinssatz2", " ")
        m_objdc.DokVarAdd("VarTempObjekt", " ")
        m_objdc.DokVarAdd("VarTempSchaetzungswert", " ")
        m_objdc.DokVarAdd("VarTempKostenstelle", " ")

        'Adressdaten
        m_objdc.DokVarAdd("VarAdresse", " ")
        m_objdc.DokVarAdd("VarVerteiler", " ")
        m_objdc.DokVarAdd("VarAdressePostzustellung", " ")
        m_objdc.DokVarAdd("VarAdresseAnrede", " ")
        m_objdc.DokVarAdd("VarAdresseNameFirma", " ")
        m_objdc.DokVarAdd("VarAdressezHd", " ")
        m_objdc.DokVarAdd("VarAdresseAdresszeile1", " ")
        m_objdc.DokVarAdd("VarAdresseAdresszeile2", " ")
        m_objdc.DokVarAdd("VarAdressePLZ", " ")
        m_objdc.DokVarAdd("VarAdresseOrt", " ")
        m_objdc.DokVarAdd("VarPartnernr", " ")

        'Formular Variablen
        'm_objdc.DokVarAdd "VarFormularNr", " "
        'm_objdc.DokVarAdd "VarFormularTitel", " "
        'm_objdc.DokVarAdd "VarVersion", " "

        ' Sachbearbeiter
        m_objdc.DokVarAdd("VarKennung", "")
        m_objdc.DokVarAdd("VarKurzzeichen", " ")
        m_objdc.DokVarAdd("VarName", " ")
        m_objdc.DokVarAdd("VarVorname", " ")
        m_objdc.DokVarAdd("VarTitel", " ")
        m_objdc.DokVarAdd("VarBereich", " ")
        m_objdc.DokVarAdd("VarOrganisationseinheit", " ")
        m_objdc.DokVarAdd("VarAbkuerzung", " ")
        m_objdc.DokVarAdd("VarBueroNr", " ")
        m_objdc.DokVarAdd("VarRang", " ")
        m_objdc.DokVarAdd("VarFunktion", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefon", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefax", " ")
        m_objdc.DokVarAdd("VarEMail", " ")
        m_objdc.DokVarAdd("VarBenutzerID", " ")

        'Dokumentersteller
        m_objdc.DokVarAdd("VarKennungDokSchreiber", " ")
        m_objdc.DokVarAdd("VarKurzzeichenDokschreiber", " ")
        m_objdc.DokVarAdd("VarNameDokSchreiber", " ")
        m_objdc.DokVarAdd("VarVornameDokSchreiber", " ")
        m_objdc.DokVarAdd("VarTitelDokSchreiber", " ")
        m_objdc.DokVarAdd("VarBereichDokSchreiber", " ")
        m_objdc.DokVarAdd("VarOrganisationseinheitDokSchreiber", " ")
        m_objdc.DokVarAdd("VarAbkuerzungDokSchreiber", " ")
        m_objdc.DokVarAdd("VarBueroNrDokSchreiber", " ")
        m_objdc.DokVarAdd("VarRangDokSchreiber", " ")
        m_objdc.DokVarAdd("VarFunktionDokSchreiber", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefonDokSchreiber", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefaxDokSchreiber", " ")
        m_objdc.DokVarAdd("VarEMailDokschreiber", " ")
        m_objdc.DokVarAdd("VarBenutzerIDWahlTelefaxDokSchreiber", " ")

        'Linksunterzeichnenden
        m_objdc.DokVarAdd("VarKennungLinks", " ")
        m_objdc.DokVarAdd("VarKurzzeichenLinks", " ")
        m_objdc.DokVarAdd("VarNameLinks", " ")
        m_objdc.DokVarAdd("VarVornameLinks", " ")
        m_objdc.DokVarAdd("VarTitelLinks", " ")
        m_objdc.DokVarAdd("VarBereichLinks", " ")
        m_objdc.DokVarAdd("VarOrganisationseinheitLinks", " ")
        m_objdc.DokVarAdd("VarAbkuerzungLinks", " ")
        m_objdc.DokVarAdd("VarBueroNrLinks", " ")
        m_objdc.DokVarAdd("VarRangLinks", " ")
        m_objdc.DokVarAdd("VarFunktionLinks", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefonLinks", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefaxLinks", " ")
        m_objdc.DokVarAdd("VarEMailTelefaxLinks", " ")
        m_objdc.DokVarAdd("VarBenutzerIDWahlTelefaxLinks", " ")

        'Rechtsunterzeichnenden
        m_objdc.DokVarAdd("VarKennungRechts", " ")
        m_objdc.DokVarAdd("VarKurzzeichenRechts", " ")
        m_objdc.DokVarAdd("VarNameRechts", " ")
        m_objdc.DokVarAdd("VarVornameRechts", " ")
        m_objdc.DokVarAdd("VarTitelRechts", " ")
        m_objdc.DokVarAdd("VarBereichRechts", " ")
        m_objdc.DokVarAdd("VarOrganisationseinheitRechts", " ")
        m_objdc.DokVarAdd("VarAbkuerzungRechts", " ")
        m_objdc.DokVarAdd("VarBueroNrRechts", " ")
        m_objdc.DokVarAdd("VarRangRechts", " ")
        m_objdc.DokVarAdd("VarFunktionRechts", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefonRechts", " ")
        m_objdc.DokVarAdd("VarDirektWahlTelefaxRechts", " ")
        m_objdc.DokVarAdd("VarEMailTelefaxRechts", " ")
        m_objdc.DokVarAdd("VarBenutzerIDWahlTelefaxRechts", " ")
        Me.Errormessage = "4"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Init_ObjWatcher Method

Private Sub Init_ObjWatcher()

Source code

[Visual Basic]
    Private Sub Init_ObjWatcher()
        Me.Errormessage = "123"

        Me.objWatcher.Path = "c:\edokatemp"
        AddHandler objWatcher.Changed, AddressOf logchange
        Me.objWatcher.Filter = Me.DokumentName
        Me.objWatcher.EnableRaisingEvents = True
        Me.Errormessage = "124"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Insert_Kopfzeile Method

Private Sub Insert_Kopfzeile()

Source code

[Visual Basic]
    Private Sub Insert_Kopfzeile()
        Me.Errormessage = "20"
        On Error Resume Next
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        If objWord.ActiveWindow.View.SplitSpecial <> WdSpecialPane.wdPaneNone Then
            objWord.ActiveWindow.Panes.Item(2).Close()
        End If
        If objWord.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdNormalView Or objWord.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdOutlineView Then
            objWord.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdPrintView
        End If
        objWord.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekCurrentPageHeader
        Me.Errormessage = "21"
        set_headerbookmark()
        objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Insert_TextFelder Method

Private Sub Insert_TextFelder()

Source code

[Visual Basic]
    Private Sub Insert_TextFelder()
        Me.Errormessage = "41"
        Dim xname As String
        Dim i As Integer
        Dim pages As Long
        Dim prop As Object
        For Each prop In objWord.ActiveDocument.BuiltInDocumentProperties
            If UCase(prop.Name) = "NUMBER OF PAGES" Then
                pages = prop.value
            End If
        Next
        Textboxesi = 1
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        For i = 1 To pages
            xname = Str(i)
            If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
            objWord.Selection.GoTo(what:=Word.WdGoToItem.wdGoToPage, Name:=xname)
            insert_Textfield()
            objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
        Next i
        Me.Errormessage = "42"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Office_Freigeben Method

Public Sub Office_Freigeben( _
   ByVal f As frmWaitforClosing _
)

Parameters

f
Required.

Source code

[Visual Basic]
    Public Sub Office_Freigeben(ByVal f As frmWaitforClosing)
        Me.Errormessage = "186"
        Try
            'Me.StartWord()
            Me.StartWord_New_Instance()
            f.ProgressBar1.Value = 20
            Disable_Enable_MenuFunctions(True)
            f.ProgressBar1.Value = 30
            'Rel 3.72
            objWord.Application.Options.SaveInterval = 10
            objWord.NormalTemplate.Saved = True
            'objWord.Quit()
            'objWord.Visible = True
            f.ProgressBar1.Value = 40
            objWord.Quit()
            objWord = Nothing
        Catch
        End Try
        Me.Errormessage = "187"
        Try
            f.ProgressBar1.Value = 50
            StartExcel()
            f.ProgressBar1.Value = 60
            Disable_Enable_MenuFunctions_Excel(True)
            f.ProgressBar1.Value = 70
            'objExcel.Visible = True
            f.ProgressBar1.Value = 80
            'objExcel.Quit()
            f.ProgressBar1.Value = 90
            objExcel = Nothing
        Catch
        End Try
        Me.Errormessage = "188"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Open_Document Method

Public Sub Open_Document( _
   ByVal fname As String, _
   ByVal xdata As DataTable, _
   ByVal doktypeNr As Long _
)

Parameters

fname
Required.
xdata
Required.
doktypeNr
Required.

Source code

[Visual Basic]
    Public Sub Open_Document(ByVal fname As String, ByVal xdata As DataTable, ByVal doktypeNr As Long)
        Me.Errormessage = "65"
        Me.Dokumenttypnr = doktypeNr
        Me.inEditMode = True
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()
        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Office-Dokument öffnen"
        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()
        If Office_Vorlage.iAnwendungnr.Value = 2 Then
            Open_Excel(fname, xdata, doktypeNr)
            Exit Sub
        End If
        Me.Errormessage = "66"
        StartWord()
        Dokumentfilename = fname
        objWord.Documents.Open(fname)
        docWord = objWord.ActiveDocument
        objWord.Visible = False
        'SHU
        objWord.NormalTemplate.Saved = True
        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Vorhandene Werte aus dem Dokument auslesen"
        If docWord.ProtectionType <> WdProtectionType.wdNoProtection Then
            docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            IsProtected = True
        End If
        Word_Werte_Auslesen(xdata)
        Me.ProgressBar.Bar1.Value = 51
        Me.ProgressBar.Info.Text = "Neue und Bestehende Werte zusammenstellen"
        Me.Errormessage = "67"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Open_Excel Method

Public Sub Open_Excel( _
   ByVal fname As String, _
   ByVal xdata As DataTable, _
   ByVal doktypeNr As Long _
)

Parameters

fname
Required.
xdata
Required.
doktypeNr
Required.

Source code

[Visual Basic]
    Public Sub Open_Excel(ByVal fname As String, ByVal xdata As DataTable, ByVal doktypeNr As Long)
        Me.Errormessage = "104"
        Dim i As Integer
        Me.Dokumenttypnr = doktypeNr
        Me.inEditMode = True
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()
        Me.Excel_Dokument = True

        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Office-Dokument öffnen"

        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()
        StartExcel()
        Dokumentfilename = fname
        objExcel.Workbooks.Open(fname)
        docExcel = objExcel.ActiveWorkbook
        objExcel.Visible = False
        Me.ProgressBar.Bar1.Value = 41
        Me.ProgressBar.Info.Text = "Vorhandene Werte aus dem Dokument auslesen"
        'For i = 1 To docExcel.Sheets.Count
        'docExcel.Sheets(i).activate()
        'sheetExcel = docExcel.ActiveSheet
        'sheetExcel.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_excelvorlagen"))
        'IsProtected = True
        'Next i
        Excel_Werte_Auslesen(xdata)
        Me.ProgressBar.Bar1.Value = 51
        Me.ProgressBar.Info.Text = "Neue und Bestehende Werte zusammenstellen"
        Me.Errormessage = "105"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Pruefziffer Method

Public Function Pruefziffer( _
   ByVal zahl As String _
) As String

Parameters

zahl
Required.

Source code

[Visual Basic]
    Public Function Pruefziffer(ByVal zahl As String) As String
        Dim ptab(9, 9) As Integer
        Dim pz(9) As Integer
        Dim s1, s2, s3 As String

        Dim i1, i2 As Long

        s1 = "0,9,4,6,8,2,7,1,3,5"
        s2 = s1
        For i1 = 0 To 9
            For i2 = 0 To 9
                ptab(i1, i2) = Mid(s2, (i2 * 2) + 1, 1)
            Next
            s3 = Microsoft.VisualBasic.Left(s1, 1)
            s1 = Microsoft.VisualBasic.Right(s1, Len(s1) - 2)
            s1 = s1 + "," + s3
            s2 = s1
        Next
        pz(0) = 0
        pz(1) = 9
        pz(2) = 8
        pz(3) = 7
        pz(4) = 6
        pz(5) = 5
        pz(6) = 4
        pz(7) = 3
        pz(8) = 2
        pz(9) = 1

        Dim i, x, y, z, e As Integer
        Dim xx As String
        y = 0
        For i = 1 To Len(zahl)
            x = Val(Mid(zahl, i, 1))
            y = ptab(x, y)
        Next
        Pruefziffer = Str(pz(y))
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.ResetFunctions Method

Public Function ResetFunctions()

Source code

[Visual Basic]
    Public Function ResetFunctions()
        Me.Errormessage = "191"
        StartWord()
        Disable_Enable_MenuFunctions(True)
        objWord.NormalTemplate.Saved = True
        objWord.Visible = True
        Me.Errormessage = "192"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.ResetFunctions_Excel Method

Public Function ResetFunctions_Excel()

Source code

[Visual Basic]
    Public Function ResetFunctions_Excel()
        Me.Errormessage = "195"

        StartExcel()
        Disable_Enable_MenuFunctions_Excel(True)
        objExcel.Visible = True
        Me.Errormessage = "196"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore Method

Public Function Restore( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Public Function Restore(ByVal typ As Integer)
        Me.Errormessage = "148"

        Restore_Datasets()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Coldindex Method

Private Sub Restore_Coldindex( _
   ByVal save_coldindex As DataTable, _
   ByVal dokumentid As String _
)

Parameters

save_coldindex
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Coldindex(ByVal save_coldindex As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "164"

        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_ColdIndex"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()

        If Me.CreateDoc = True Then
            'Coldindexwerte bei neuem Dokument löschen
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@IndexFeldNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Restore Coldindex - Delete::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
            Exit Sub
        End If
        Me.Errormessage = "165"

        'Restore der alten Indexwerte
        For i = 0 To save_coldindex.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("coldindexwertnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@IndexFeldNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("cold_indexfeldnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("wert")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_coldindex.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Restore Coldindex::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "166"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Data Method

Public Function Restore_Data()

Source code

[Visual Basic]
    Public Function Restore_Data()
        Me.Errormessage = "146"

        WordWatch.Stopp()
        If Me.CreateDoc = True Then
            Restore(1)
            Try
                Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
            Catch
            End Try
            Dim s As String
            s = MyTxt.Get_Meldungstext(80) + vbCrLf + vbCrLf + "Partner: " + Me.txtPartner + vbCrLf + "Dokument: " & Me.txtDokumenttyp
            Dim f As New frmHinweismeldung1()
            Globals.PerfMon.insert_entry(Me.DokumentID + " Dokumentbearbeitung abgebrochen: Partner " + Me.txtPartner)
            f.MsgBoxStyle = 1
            f.Label1.Text = s
            If Not Me.DokumenTtyp.bNurnative.Value = True Then
                f.ShowDialog()
            End If
            '            MsgBox(s, MsgBoxStyle.Critical)
        Else
            Restore(2)
        End If
        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
        Me.Errormessage = "147"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Datasets Method

Public Sub Restore_Datasets()

Source code

[Visual Basic]
    Public Sub Restore_Datasets()
        Me.Errormessage = "159"

        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Restore Details")
        Dim f As New FrmRestore()
        f.Visible = False
        f.Width = 1
        f.Height = 1
        f.Show()
        f.Refresh()
        Try
            Restore_Coldindex(Me.Save_ColdIndex, Me.DokumentID)
            Restore_Dokumentwerte(Me.Save_Dokumentwerte, Me.DokumentID)
            Restore_Notizen(Me.Save_Notizen, Me.DokumentID)
            Restore_InfoEmpfaenger(Me.Save_Dokumentinfomeldungen, Me.DokumentID)
            Restore_dokumentzuordnungen(Me.Save_Dokumentzuordnungen, Me.DokumentID)
            Restore_Dokumentfunktionen(Me.Save_DokumentFunktionen, Me.DokumentID)
            Restore_Statushistory(Me.save_historystatus, Me.DokumentID)
            Restore_Dokumentersetzen(Me.save_dokumentersetzen, Me.DokumentID)
            If Me.CreateDoc = True Then
                delete_dokumentstatus(Me.DokumentID)
            End If
            If Me.DokumenTtyp.bNurnative.Value <> True Then Delete_File()
            f.DokumentID = Me.DokumentID
            f.SaveDocument = Me.Save_Dokument
            f.NeuesDokument = Me.CreateDoc
            f.Restore_Dokument()

            Dim dorestorebr As Boolean = False
            'Bedingte Retournierung
            If Me.Dokumentidbr <> "" And Me.CreateDoc Then dorestorebr = True
            If Me.Save_Dokumentbr.Rows.Count > 0 Then
                dorestorebr = True
            End If

            'Verweis-Dokument im Auslöser bei Bedingter Retournierung richtig stellen
            If dorestorebr And Not Me.CreateDoc Then
                Dim dok As New edokadb.clsDokument()
                dok.cpMainConnectionProvider = conn
                dok.sDokumentid = New SqlString(CType(Me.DokumentID, String))
                dok.SelectOne()
                dok.sBedRDokumentid = New SqlString(CType(Me.dokumentidaltbr, String))
                conn.OpenConnection()
                dok.Update()
                conn.CloseConnection(True)
                dok.Dispose()
            End If
            If Me.Dokumentcoldindex_Changed = True Then Archivfnkt.Restore_Coldindex(Me.save_dokumentcoldindex, Me.DokumentID)
            If Me.dokumentid_changed Then Archivfnkt.change_dokumentid(Me.DokumentID, Me.dokumentidalt)

            If dorestorebr = True Then
                Restore_Coldindex(Me.Save_ColdIndexbr, Me.Dokumentidbr)
                Restore_Dokumentwerte(Me.Save_Dokumentwertebr, Me.Dokumentidbr)
                Restore_Notizen(Me.Save_Notizenbr, Me.Dokumentidbr)
                Restore_InfoEmpfaenger(Me.Save_Dokumentinfomeldungenbr, Me.Dokumentidbr)
                Restore_dokumentzuordnungen(Me.Save_Dokumentzuordnungenbr, Me.Dokumentidbr)
                Restore_Dokumentfunktionen(Me.Save_DokumentFunktionenbr, Me.Dokumentidbr)
                Restore_Statushistory(Me.save_historystatusbr, Me.Dokumentidbr)
                Restore_Dokumentersetzen(Me.save_dokumentersetzenbr, Me.Dokumentidbr)
                If Me.CreateDoc = True Then
                    delete_dokumentstatus(Me.Dokumentidbr)
                End If
                '                If me.CreateDoc=False Me.Save_Dokumentbr.Rows.Count > 0 Then
                f.DokumentID = Me.Dokumentidbr
                f.SaveDocument = Me.Save_Dokumentbr
                f.NeuesDokument = Me.CreateDoc
                f.Restore_Dokument()
                If Me.Dokumentcoldindex_changedbr = True Then Archivfnkt.Restore_Coldindex(Me.save_dokumentcoldindexbr, Me.Dokumentidbr)
                If Me.dokumentid_changedbr Then Archivfnkt.change_dokumentid(Me.Dokumentidbr, Me.dokumentidaltbr)
                '           End If
            End If
            f.Close()
            f.Dispose()
        Catch ex As Exception
            MsgBox(ex.Message)
            f.Close()
            f.Dispose()
            Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Maximize)
            Dim s As String
            s = MyTxt.Get_Meldungstext(84) + vbCrLf + vbCrLf + "Partner: " + Me.txtPartner + vbCrLf + "Dokument: " & Me.txtDokumenttyp
            Dim f1 As New frmHinweismeldung1()
            f1.MsgBoxStyle = 1
            Globals.PerfMon.insert_entry(Me.DokumentID + " Dokument zurücksetzen fehlgeschlagen: Partner: " + Me.txtPartner)
            f1.Label1.Text = s
            f1.ShowDialog()
            f1.Dispose()
        End Try
        Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Restore Details")
        Me.Errormessage = "160"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Dokumentersetzen Method

Private Sub Restore_Dokumentersetzen( _
   ByVal save_dokumentersetzen As DataTable, _
   ByVal dokumentid As String _
)

Parameters

save_dokumentersetzen
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Dokumentersetzen(ByVal save_dokumentersetzen As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "183"

        'Sofern keine dokumentfunktionen vorhanden sind, Sub verlassen
        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_Dokumentersetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        'Restore der alten dokumentfunktionen
        For i = 0 To save_dokumentersetzen.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_dokumentersetzen.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_dokumentersetzen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        Me.Errormessage = "184"

        'Löschen der neuen dokumentfunktionen
        nnr = 0
        For i = 0 To save_dokumentersetzen.Rows.Count - 1
            If save_dokumentersetzen.Rows(i).Item("dokumentersetzennr") > nnr Then nnr = save_dokumentersetzen.Rows(i).Item("dokumentersetzennr")
        Next
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "185"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Dokumentfunktionen Method

Private Sub Restore_Dokumentfunktionen( _
   ByVal Save_DokumentFunktionen As DataTable, _
   ByVal dokumentid As String _
)

Parameters

Save_DokumentFunktionen
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Dokumentfunktionen(ByVal Save_DokumentFunktionen As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "176"

        'Sofern keine dokumentfunktionen vorhanden sind, Sub verlassen
        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_Dokumentfunktionen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        'Restore der alten dokumentfunktionen
        For i = 0 To Save_DokumentFunktionen.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_DokumentFunktionen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_DokumentFunktionen.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_DokumentFunktionen.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_DokumentFunktionen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        Me.Errormessage = "177"

        'Löschen der neuen dokumentfunktionen
        nnr = 0
        For i = 0 To Save_DokumentFunktionen.Rows.Count - 1
            If Save_DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr") > nnr Then nnr = Save_DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")
        Next
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Microsoft.VisualBasic.Now))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "178"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Dokumentwerte Method

Private Sub Restore_Dokumentwerte( _
   ByVal SAVE_DOKUMENTWERTE As DataTable, _
   ByVal dokumentid As String _
)

Parameters

SAVE_DOKUMENTWERTE
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Dokumentwerte(ByVal SAVE_DOKUMENTWERTE As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "167"
        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()

        If Me.CreateDoc = True Then
            'Coldindexwerte bei neuem Dokument löschen
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Restore Coldindex - Delete::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
            Exit Sub
        End If
        Me.Errormessage = "168"

        'Restore der alten Indexwerte
        For i = 0 To SAVE_DOKUMENTWERTE.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("dokumentinfonr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("inhalt")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, SAVE_DOKUMENTWERTE.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Restore Coldindex::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "169"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_InfoEmpfaenger Method

Private Sub Restore_InfoEmpfaenger( _
   ByVal Save_Dokumentinfomeldungen As DataTable, _
   ByVal dokumentid As String _
)

Parameters

Save_Dokumentinfomeldungen
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_InfoEmpfaenger(ByVal Save_Dokumentinfomeldungen As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "167"

        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_DokumentInfoEmpfaenger"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()

        For i = 0 To Save_Dokumentinfomeldungen.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("inhalt")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentinfomeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Restore Coldindex - Delete::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next i
        Me.Errormessage = "171"

        'Löschen der neuen InfoEmpfänger
        Dim nn As Integer
        nnr = 0
        For i = 0 To Save_Dokumentinfomeldungen.Rows.Count - 1
            If Save_Dokumentinfomeldungen.Rows(i).Item("dokumentinfomeldungnr") > nnr Then nnr = Save_Dokumentinfomeldungen.Rows(i).Item("dokumentinfomeldungnr")
        Next
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Infoempfänger::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "172"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Notizen Method

Private Sub Restore_Notizen( _
   ByVal Save_Notizen As DataTable, _
   ByVal Dokumentid As String _
)

Parameters

Save_Notizen
Required.
Dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Notizen(ByVal Save_Notizen As DataTable, ByVal Dokumentid As String)
        Me.Errormessage = "161"
        'Sofern keine Notizen vorhanden sind, Sub verlassen
        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_Notizen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        'Restore der alten notizen
        For i = 0 To Save_Notizen.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Notizen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        Me.Errormessage = "162"

        'Löschen der neuen Notizen
        nnr = 0
        For i = 0 To Save_Notizen.Rows.Count - 1
            If Save_Notizen.Rows(i).Item("notiznr") > nnr Then nnr = Save_Notizen.Rows(i).Item("notiznr")
        Next
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Microsoft.VisualBasic.Now))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "163"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_Statushistory Method

Private Sub Restore_Statushistory( _
   ByVal save_historystatus As Integer, _
   ByVal dokumentid As String _
)

Parameters

save_historystatus
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_Statushistory(ByVal save_historystatus As Integer, ByVal dokumentid As String)
        Me.Errormessage = "179"

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_statushistory"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, save_historystatus))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Restore Coldindex - Delete::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
        End Try
        Me.Errormessage = "180"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Restore_dokumentzuordnungen Method

Private Sub Restore_dokumentzuordnungen( _
   ByVal Save_Dokumentzuordnungen As DataTable, _
   ByVal dokumentid As String _
)

Parameters

Save_Dokumentzuordnungen
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Sub Restore_dokumentzuordnungen(ByVal Save_Dokumentzuordnungen As DataTable, ByVal dokumentid As String)
        Me.Errormessage = "173"

        'Sofern keine Notizen vorhanden sind, Sub verlassen
        Dim i As Integer
        Dim nnr As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_Dokumentzuordnungen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        'Restore der alten notizen
        For i = 0 To Save_Dokumentzuordnungen.Rows.Count - 1
            Try
                scmCmdToExecute.Parameters.Clear()
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid1", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("dokumentid1")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("dokumentid2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("nreintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("mutiert_am")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("mutierer")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Save_Dokumentzuordnungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
            End Try
        Next
        Me.Errormessage = "174"

        'Löschen der neuen Notizen
        nnr = 0
        For i = 0 To Save_Dokumentzuordnungen.Rows.Count - 1
            If Save_Dokumentzuordnungen.Rows(i).Item("nreintrag") > nnr Then nnr = Save_Dokumentzuordnungen.Rows(i).Item("nreintrag")
        Next
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid1", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
        End Try
        scmCmdToExecute.Connection.Close()
        scmCmdToExecute.Dispose()
        Me.Errormessage = "175"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Save_Data Method

Public Function Save_Data()

Source code

[Visual Basic]
    Public Function Save_Data()
        Me.Errormessage = "142"

        WordWatch.Stopp()
        Save_Doc()
        Update_Dokumentdetails()
        Dim statush As New Statushandling()
        statush.check_abschluss(Me.DokumentID, Globals.MitarbeiterNr)
        Me.Errormessage = "143"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Save_Doc Method

Public Function Save_Doc()

Source code

[Visual Basic]
    Public Function Save_Doc()
        Me.Errormessage = "149"

        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokument sichern")
        Dim docsave As New DocMgmt()
        Globals.PerfMon.insert_entry(Me.DokumentID + "'-- Start Dokument auf DB sichern")
        docsave.Save_To_DB(Me.DokumentID, Me.Dokumentfilename)
        docsave = Nothing
        Globals.PerfMon.insert_entry(Me.DokumentID + "'-- Ende Dokument auf DB sichern")
        If Me.Dokumentcoldindex_Changed Then
            Archivfnkt.insert_coldupdate_status(Me.save_dokumentcoldindex, Me.DokumentID, Me.dokumentcoldindex_status)
        End If
        If Me.Ersetzte_Dokumente_Reaktivieren = True Then
            Dokumente_Reaktivieren(Me.DokumentID)
        End If
        'huttu

        Dim doarchivfnkt As Boolean
        If Me.Dokumentidbr <> "" And Me.CreateDoc Then doarchivfnkt = True
        If Me.Save_Dokumentbr.Rows.Count > 0 Then
            doarchivfnkt = True
        End If
        If doarchivfnkt Then
            If Me.Dokumentcoldindex_changedbr Then
                Archivfnkt.insert_coldupdate_status(Me.save_dokumentcoldindexbr, Me.Dokumentidbr, Me.dokumentcoldindex_statusbr)
            End If
            If Me.Ersetzte_Dokumente_Reaktivierenbr = True Then
                Dokumente_Reaktivieren(Me.Dokumentidbr)
            End If
            DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentidbr, False, "")
        End If
        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
        Delete_File()
        Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Dokument sichern")
        Me.Errormessage = "150"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Save_Doc_Temp Method

Public Function Save_Doc_Temp( _
   ByVal Dokumentfile As String _
)

Parameters

Dokumentfile
Required.

Source code

[Visual Basic]
    Public Function Save_Doc_Temp(ByVal Dokumentfile As String)
        Me.Errormessage = "151"

        Dim docsave As New DocMgmt()
        docsave.Save_To_DB(Me.DokumentID, Dokumentfile)
        docsave = Nothing
        File.Delete(Dokumentfile)
        Me.Errormessage = "152"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.ShowDoc Method

Public Sub ShowDoc( _
   ByVal s As String _
)

Parameters

s
Required.

Source code

[Visual Basic]
    Public Sub ShowDoc(ByVal s As String)
        Me.Errormessage = "84"

        If UCase(Right(s, 3)) = "XLS" Then
            StartExcel()
            objExcel.Workbooks.Open(s)
            objExcel.Visible = True
            Me.Excel_Dokument = True
        End If
        If UCase(Right(s, 3)) = "DOC" Then
            StartWord()
            Me.Excel_Dokument = False
            objWord.Run("Autoexec")
            objWord.Documents.Open(s)
            docWord = objWord.ActiveDocument
            'SHU
            objWord.NormalTemplate.Saved = True
            Try
                docWord.Application.Visible = True
                docWord.Activate()
            Catch
                System.Threading.Thread.CurrentThread.Sleep(100)
                docWord.Application.Visible = True
                docWord.Activate()
            End Try
            insert_wordart()
            objWord.Visible = True
            Try
                objWord.Activate()
            Catch
                System.Threading.Thread.CurrentThread.Sleep(100)
                objWord.Activate()
            End Try
            objWord.NormalTemplate.Saved = True
        End If
        Me.DokumentName = DivFnkt.ExtractFilename(s)
        Control_Word_readonly()
        Me.Errormessage = "85"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.StartExcel Method

Private Function StartExcel()

Source code

[Visual Basic]
    Private Function StartExcel()
        'Me.Errormessage = "32"

        Try
            objExcel = CreateObject("Excel.application")
        Catch ex As Exception
            'MsgBox(ex.Message)
            Exit Function
        End Try
        objExcel.Visible = False
        'Me.Errormessage = "33"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.StartIDVP Method

Private Function StartIDVP()

Source code

[Visual Basic]
    Private Function StartIDVP()
        Me.Errormessage = "18"

        Try
            m_objdc = GetObject("dc.application")
        Catch
            Try
                m_objdc = CreateObject("dc.application")
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End Try
        Me.Errormessage = "19"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.StartWord Method

Private Function StartWord()

Source code

[Visual Basic]
    Private Function StartWord()
        '        StartWord_New_Instance()
        '       Exit Function
        'Me.Errormessage = "14"
        Try
            DivFnkt.TraceLog("-----------Start Word GetObject")
            objWord = GetObject(, "Word.application")
            objWord.Application.Options.SaveInterval = 0
            Me.WordnewInstance = False
        Catch
            Try
                DivFnkt.TraceLog("-----------Start Word CreateObject")
                objWord = CreateObject("Word.application")
                objWord.Application.Options.SaveInterval = 0
                Me.WordnewInstance = True
            Catch ex As Exception
                'MsgBox(ex.Message)
            End Try
        Finally
            DivFnkt.TraceLog("-----------Start Word nicht sichtbar")
            objWord.Visible = False
        End Try
        Try
            objWord.Run("Autoexec")
        Catch
        End Try
        'Me.Errormessage = "15"
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.StartWord_New_Instance Method

Private Function StartWord_New_Instance()

Source code

[Visual Basic]
    Private Function StartWord_New_Instance()
        Me.Errormessage = "16"
        Try
            objWord = CreateObject("Word.application")
        Catch ex As Exception
            MsgBox(ex.Message)
            Exit Function
        End Try
        objWord.Visible = False
        Me.Errormessage = "17"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Update_Dokumentdetails Method

Public Function Update_Dokumentdetails()

Source code

[Visual Basic]
    Public Function Update_Dokumentdetails()
        Me.Errormessage = "155"

        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokumentdetails sichern")
        Dim doc As New edokadb.clsDokument()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.DokumentID, String))
        doc.SelectOne()
        doc.daMutiertam = New SqlDateTime(CType(Microsoft.VisualBasic.Now, DateTime))
        doc.Update()
        Dim statush As New Statushandling()
        If (doc.iVerantwortlich.Value <> Globals.MitarbeiterNr) Then
            If Me.save_stv = 1 Then
                If doc.iVerantwortlich.Value <> Me.save_verantwortlicher Then
                    If Me.txtBemerkung_Verantwortlicher <> "" Then
                        statush.BemerkungVerantwortlicher = Me.txtBemerkung_Verantwortlicher
                    End If
                    statush.Meldung_Verantwortlicher(Me.DokumentID, doc.iVerantwortlich.Value)
                End If
            Else
                If Me.txtBemerkung_Verantwortlicher <> "" Then
                    statush.BemerkungVerantwortlicher = Me.txtBemerkung_Verantwortlicher
                End If
                statush.Meldung_Verantwortlicher(Me.DokumentID, doc.iVerantwortlich.Value)

            End If
        End If
        If Me.send_statusmessage = True Then
            statush.Meldung_Status(Me.DokumentID, doc.iStatusnr.Value)
        End If
        statush.Dispose()
        doc.Dispose()
        conn.CloseConnection(True)
        Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Dokumentdetails sichern")
        Me.Errormessage = "156"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.WATCHFILE Method

Private Function WATCHFILE()

Source code

[Visual Basic]
    Private Function WATCHFILE()
        Me.Errormessage = "131"

        'Wordwatch - Überprüfung auf geöffnete
        If Not Me.DocReadonly Then Save_DateTime = File.GetLastWriteTime(Me.Dokumentfilename)
        WordWatch.Filename = Me.DokumentName
        If Me.Excel_Dokument Then
            WordWatch.ApplicationType = 2
            objExcel.ActiveWindow.WindowState = Excel.XlWindowState.xlMaximized
            objExcel.Visible = True
            Disable_Enable_MenuFunctions_Excel(False)
        Else
            WordWatch.ApplicationType = 1
            Disable_Enable_MenuFunctions(False)
            objWord.Visible = True
            objWord.Activate()
        End If
        Me.Errormessage = "132"

        Word_Active = True
        Try
            Win32API.ShowWindow(Globals.Apphandle, Win32API.SW_Minimze)
        Catch
        End Try
        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Überwachung")
        WordWatch.Start()
        Dim hnd As Long
        Me.Errormessage = "133"

        Try
            hnd = Win32API.FindWindow(vbNullString, WordWatch.WindowName)
            Win32API.ShowWindow(hnd, Win32API.SW_Maximize)
            Win32API.BringWindowToTop(hnd)
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.Word_Werte_Auslesen Method

Public Sub Word_Werte_Auslesen( _
   ByVal xdata As DataTable _
)

Parameters

xdata
Required.

Source code

[Visual Basic]
    Public Sub Word_Werte_Auslesen(ByVal xdata As DataTable)
        Me.Errormessage = "75"

        Dim i As Integer
        Dim pos, pos2 As Integer
        For i = 0 To xdata.Rows.Count - 1
            xdata.Rows(i).Item("used") = 0
            If xdata.Rows(i).Item("beginntextmarke") <> "" And xdata.Rows(i).Item("endetextmarke") = "" Then
                Try
                    docWord.Bookmarks.Item(xdata.Rows(i).Item("beginntextmarke")).Select()
                    xdata.Rows(i).Item("oldvalue") = convert(objWord.Selection.Text)
                    xdata.Rows(i).Item("used") = 1
                Catch
                End Try
                If xdata.Rows(i).Item("beginntextmarke") = "TGEDKCompanyBBEB99" Then xdata.Rows(i).Item("used") = 1
            End If
            If xdata.Rows(i).Item("beginntextmarke") <> "" And xdata.Rows(i).Item("endetextmarke") <> "" Then
                Try
                    docWord.Bookmarks.Item(xdata.Rows(i).Item("beginntextmarke")).Select()
                    pos = objWord.Selection.Start
                    docWord.Bookmarks.Item(xdata.Rows(i).Item("endetextmarke")).Select()
                    pos2 = objWord.Selection.Start
                    objWord.Selection.SetRange(Start:=pos, End:=pos2)
                    xdata.Rows(i).Item("oldvalue") = convert(objWord.Selection.Text)
                    xdata.Rows(i).Item("used") = 1
                Catch
                End Try
            End If
            Try
                If xdata.Rows(i).Item("feldname") <> "" Then
                    Try
                        xdata.Rows(i).Item("oldvalue") = convert(docWord.FormFields.Item(xdata.Rows(i).Item("feldname")).Result)
                        xdata.Rows(i).Item("used") = 1
                    Catch
                    End Try
                End If
            Catch
            End Try
        Next
        Me.Errormessage = "76"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.check_word Method

Public Sub check_word()

Source code

[Visual Basic]
    Public Sub check_word()
        'Office-Vorlage auslesen
        DokumenTtyp.cpMainConnectionProvider = conn
        DokumenTtyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        DokumenTtyp.SelectOne()
        Office_Vorlage.cpMainConnectionProvider = conn
        Office_Vorlage.iOffice_vorlagenr = DokumenTtyp.iOffice_vorlagenr
        Office_Vorlage.SelectOne()

        If Office_Vorlage.iAnwendungnr.Value = 2 Then
            Exit Sub
        End If

        'Temporär-Datei
        Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")
        Dokument_Temp = Dokument_Temp + Office_Vorlage.sPrefix_dokumentname.Value + ".doc"

        'Nativ-Dokumentvorlage
        If Not Office_Vorlage.bIdv_vorlage.Value = True Then
        Else
            Dokumentfilename = "c:\edokatemp\wordcheck.doc"
            Create_IDVDokument(Office_Vorlage.sIdv_id.Value)
        End If

        IsProtected = False
        If docWord.ProtectionType <> WdProtectionType.wdNoProtection Then
            docWord.Unprotect(password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
            IsProtected = True
        End If
        Dim i As Integer
        For i = 1 To docWord.Bookmarks.Count
            If InStr(docWord.Bookmarks.Item(i).Name, "Betreuer") > 0 Then
                oread.WriteLine(DokumenTtyp.sBezeichnung.Value + " - " + docWord.Bookmarks.Item(i).Name)
            End If
        Next
        docWord.Close()
        objWord.Quit()
        docWord = Nothing
        objWord = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.convert Method

Function convert( _
   ByVal x As String _
) As String

Parameters

x
Required.

Source code

[Visual Basic]
    Function convert(ByVal x As String) As String
        Me.Errormessage = "87"
        Dim s As String
        Dim s1 As String
        Dim i As Integer
        s = x
        i = InStr(s, Chr(13))
        While i > 0
            s = Left(s, i - 1) & "#" & Right(s, Len(s) - (i))
            If Mid(s, i + 1, 1) = Chr(10) Then
                s = Left(s, i) & Right(s, Len(s) - (i + 1))
            End If
            i = InStr(s, Chr(13))
        End While
        i = InStr(s, "#")
        While i > 0
            s = Left(s, i - 1) & vbCrLf & Right(s, Len(s) - (i))
            i = InStr(s, "#")
        End While
        convert = s
        Me.Errormessage = "88"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.convert_excel Method

Function convert_excel( _
   ByVal x As String _
) As String

Parameters

x
Required.

Source code

[Visual Basic]
    Function convert_excel(ByVal x As String) As String
        Me.Errormessage = "91"
        Dim s As String
        Dim s1 As String
        Dim i As Integer
        s = x
        i = InStr(s, Chr(13))
        While i > 0
            s = Left(s, i - 1) & "#" & Right(s, Len(s) - (i))
            If Mid(s, i + 1, 1) = Chr(10) Then
                s = Left(s, i) & Right(s, Len(s) - (i + 1))
            End If
            i = InStr(s, Chr(13))
        End While
        i = InStr(s, "#")
        While i > 0
            s = Left(s, i - 1) & Chr(10) & Right(s, Len(s) - (i))
            i = InStr(s, "#")
        End While
        convert_excel = s
        Me.Errormessage = "92"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.convert_wordfelder Method

Function convert_wordfelder( _
   ByVal x As String _
) As String

Parameters

x
Required.

Source code

[Visual Basic]
    Function convert_wordfelder(ByVal x As String) As String
        Me.Errormessage = "89"

        Dim s As String
        Dim s1 As String
        Dim i As Integer
        s = x
        i = InStr(s, Chr(13))
        While i > 0
            s = Left(s, i - 1) & "#" & Right(s, Len(s) - (i))
            If Mid(s, i + 1, 1) = Chr(10) Then
                s = Left(s, i) & Right(s, Len(s) - (i + 1))
            End If
            i = InStr(s, Chr(13))
        End While
        i = InStr(s, "#")
        While i > 0
            s = Left(s, i - 1) & Chr(11) & Right(s, Len(s) - (i))
            i = InStr(s, "#")
        End While
        convert_wordfelder = s
        Me.Errormessage = "90"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.delete_Textfelder Method

Private Sub delete_Textfelder()

Source code

[Visual Basic]
    Private Sub delete_Textfelder()
        Me.Errormessage = "38"
        Dim xname As String
        Dim i As Integer
        Dim i1 As Integer
        Dim pages As Long
        Dim Prop As Object
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)

        For Each Prop In objWord.ActiveDocument.BuiltInDocumentProperties
            If UCase(Prop.Name) = "NUMBER OF PAGES" Then
                pages = Prop.value
            End If
        Next
        For i = 1 To pages
            xname = Str(i)
            If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
            objWord.Selection.GoTo(what:=Word.WdGoToItem.wdGoToPage, Name:=xname)
            HeaderFooterAnzeigen()
            While objWord.Selection.HeaderFooter.Shapes.Count > 0
                objWord.Selection.HeaderFooter.Shapes.Item(1).Delete()
            End While
            '            On Error GoTo eh
            '           '            Resume Next
            '          For i1 = 1 To objWord.Selection.HeaderFooter.Shapes.Count
            '             objWord.Selection.HeaderFooter.Shapes.Item(i1).Delete()
            '        Next i1
            '       On Error GoTo 0
            objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
        Next i
        Me.Errormessage = "39"
        Exit Sub
eh:
        Me.Errormessage = "40"
        'MsgBox(Err.Description)
        Resume Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.delete_dokumentstatus Method

Private Sub delete_dokumentstatus( _
   ByVal dokumentid As String _
)

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Sub delete_dokumentstatus(ByVal dokumentid As String)
        Me.Errormessage = "181"

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Restore_delete_dokumentstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Restore Coldindex - Delete::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
        End Try
        Me.Errormessage = "182"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.filechange Method

Private Sub filechange( _
   ByVal source As Object, _
   ByVal e As System.IO.FileSystemEventArgs _
)

Parameters

source
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub filechange(ByVal source As Object, ByVal e As System.IO.FileSystemEventArgs)
        Me.Errormessage = "141"
        If e.ChangeType = IO.WatcherChangeTypes.Changed Then
            MsgBox(e.FullPath & " " & e.Name)
            Me.Dokument_Saved = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.get_dokumentdaten Method

Private Sub get_dokumentdaten()

Source code

[Visual Basic]
    Private Sub get_dokumentdaten()
        Me.Errormessage = "34"
        dokudata.cpMainConnectionProvider = conn
        Dokumentdaten = dokudata.SelectTestdata(Me.Dokumenttypnr)
        dokudata.Dispose()
        Me.Errormessage = "35"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.ins_Barcode Method

Private Sub ins_Barcode()

Source code

[Visual Basic]
    Private Sub ins_Barcode()

        Me.Errormessage = "43"
        Dim xname As String
        Dim i As Integer
        Dim pages As Long
        Dim prop As Object
        For Each prop In objWord.ActiveDocument.BuiltInDocumentProperties
            If UCase(prop.Name) = "NUMBER OF PAGES" Then
                pages = prop.value
            End If
        Next

        Me.Errormessage = "44"

        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        Textboxesi = 1
        For i = 1 To pages
            xname = Str(i)
            If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
            objWord.Selection.GoTo(what:=Word.WdGoToItem.wdGoToPage, Name:=xname)
            HeaderFooterAnzeigen()
            insert_Barcode(i)
            Textboxesi = Textboxesi + 1
            objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
        Next i
        Me.Errormessage = "45"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.insert_Barcode Method

Private Sub insert_Barcode( _
   ByVal x As Integer _
)

Parameters

x
Required.

Source code

[Visual Basic]
    Private Sub insert_Barcode(ByVal x As Integer)

        Dim Form
        Dim strsel As String
        Dim strresult
        Dim s As String
        ' Selection.ShapeRange.Select
        Me.Errormessage = "52"

        If DokumenTtyp.bZu_retournieren.Value = True Or Me.Dokumentidbr <> "" Or Me.SaveBLDossier = True Then
            Try
                Form = objWord.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
                Form.Select()
                Form = objWord.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
                Form.Select()
                If Office_Vorlage.bBchorizontal.Value = False Then
                    objWord.ActiveDocument.Tables.Add(Range:=objWord.Selection.Range, NumRows:=1, NumColumns:=1)
                    With objWord.Selection.Tables.Item(1)
                        .Borders.Item(WdBorderType.wdBorderLeft).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Item(WdBorderType.wdBorderRight).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Item(WdBorderType.wdBorderTop).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Item(WdBorderType.wdBorderBottom).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Item(WdBorderType.wdBorderDiagonalDown).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Item(WdBorderType.wdBorderDiagonalUp).LineStyle = WdLineStyle.wdLineStyleNone
                        .Borders.Shadow = False
                    End With
                    objWord.Selection.Orientation = Word.WdTextOrientation.wdTextOrientationUpward
                    objWord.Selection.Tables.Item(1).Rows.HeightRule = Word.WdRowHeightRule.wdRowHeightAtLeast
                    objWord.Selection.Tables.Item(1).Rows.Height = Form.height
                End If
                'gaga'
                Dim id As String
                If Me.Dokumentidbr <> "" Then id = Me.Dokumentidbr Else id = Me.DokumentID
                s = Bar25I(Microsoft.VisualBasic.Right(Right(id, Len(id) - 6), 16))
                '                s = Bar25I(Microsoft.VisualBasic.Right(Right(m_DokumentID, Len(m_DokumentID) - 6), 16))
                's = Bar25I("0012002123456789")
                objWord.Selection.TypeText(text:=s)
                objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdLine, Extend:=Word.WdMovementType.wdExtend)
                objWord.Selection.Font.Name = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("barcode_font")
                objWord.Selection.Font.Size = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("bcfont_groesse")
                objWord.Selection.ParagraphFormat.Alignment = WdParagraphAlignment.wdAlignParagraphRight
                objWord.Selection.EndKey(Unit:=Word.WdUnits.wdLine)
                objWord.Selection.Font.Name = "Arial"
                objWord.Selection.Font.Size = 8

                Dim Zeichen As String
                If Me.Dokumentidbr <> "" Then
                    Dim dok As New edokadb.clsDokument()
                    dok.cpMainConnectionProvider = conn
                    dok.sDokumentid = New SqlString(CType(Me.Dokumentidbr, String))
                    dok.SelectOne()
                    Dim doktypbr As New edokadb.clsDokumenttyp()
                    doktypbr.cpMainConnectionProvider = conn
                    doktypbr.iDokumenttypnr = New SqlInt32(CType(dok.iDokumenttypnr.Value, Int32))
                    doktypbr.SelectOne()
                    Select Case doktypbr.iPhysisches_archiv.Value
                        Case 0
                        Case 1
                            Zeichen = " U"
                            'objWord.Selection.TypeText(" U")
                        Case 2
                            Zeichen = " F"
                            'objWord.Selection.TypeText(" F")
                    End Select
                    dok.Dispose()
                    doktypbr.Dispose()
                Else
                    Select Case DokumenTtyp.iPhysisches_archiv.Value
                        Case 0
                        Case 1
                            Zeichen = " U"
                            'objWord.Selection.TypeText(" U")
                        Case 2
                            Zeichen = " F"
                            'objWord.Selection.TypeText(" F")
                    End Select
                End If
                If Me.SaveBLDossier = True Then
                    Zeichen = Zeichen + "/B"
                End If
                objWord.Selection.TypeText(Zeichen)
                Form = Nothing
            Catch ex As Exception
                Me.Errormessage = "53"
            End Try
        End If
        Me.Errormessage = "54"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.insert_Barcode_Excel Method

Private Sub insert_Barcode_Excel()

Source code

[Visual Basic]
    Private Sub insert_Barcode_Excel()
        Me.Errormessage = "50"

        Dim i As Integer
        Dim i1 As Integer
        Dim s As String
        Dim na As String
        Dim xx As Integer
        Me.ProgressBar.Bar1.Value = 81
        Me.ProgressBar.Info.Text = "Barcodes generieren"

        'Rel 3.21 BUD/SHU
        Dim id As String
        If Me.Dokumentidbr <> "" Then id = Me.Dokumentidbr Else id = Me.DokumentID
        s = Bar25I(Microsoft.VisualBasic.Right(Right(id, Len(id) - 6), 16))

        For i = 1 To docExcel.Sheets.Count
            docExcel.Sheets(i).activate()
            For i1 = 1 To docExcel.Names.Count
                Try
                    na = docExcel.Names.Item(i1).NameLocal
                    If Left(na, 7) = "TGEDKBC" Then
                        objExcel.Range(objExcel.Names.Item(na).NameLocal).Select()
                        objExcel.ActiveCell.FormulaR1C1 = s
                        With objExcel.Selection.Characters.Font
                            .Name = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("barcode_font")
                            '.Size = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("bcfont_groesse")
                        End With
                        'objExcel.Selection.HorizontalAlignment = Excel.XlHAlign.xlHAlignRight
                    End If
                    Dim ZEICHEN As String = ""

                    If Left(na, 7) = "TGEDKAR" Then
                        objExcel.Range(objExcel.Names.Item(na).NameLocal).Select()
                        'edex Banklagernd
                        Select Case DokumenTtyp.iPhysisches_archiv.Value
                            Case 0
                            Case 1
                                ZEICHEN = "U"
                            Case 2
                                ZEICHEN = "F"
                        End Select
                        If Me.SaveBLDossier = True Then
                            ZEICHEN = ZEICHEN + "/B"
                        End If
                        objExcel.ActiveCell.FormulaR1C1 = convert_excel(ZEICHEN)

                        'If DokumenTtyp.iPhysisches_archiv.Value = 2 Then
                        '    ZEICHEN = "F"
                        '    'objExcel.ActiveCell.FormulaR1C1 = convert_excel("F")
                        'Else
                        '    ZEICHEN = "U"
                        '    'objExcel.ActiveCell.FormulaR1C1 = convert_excel("U")
                        'End If
                    End If
                Catch ex As Exception
                End Try
            Next
        Next
        Me.Errormessage = "51"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.insert_Textfield Method

Private Sub insert_Textfield()

Source code

[Visual Basic]
    Private Sub insert_Textfield()
        Me.Errormessage = "48"
        Dim Public_barcodeleft
        Dim Public_barcodetop
        Dim Public_barcodewidth#
        Dim Public_barcodeheight
        Try
            Public_barcodeleft = Office_Vorlage.iBcpl.Value
            Public_barcodetop = Office_Vorlage.iBcpt.Value
            Public_barcodewidth = Office_Vorlage.iBcw.Value
            Public_barcodeheight = Office_Vorlage.iBch.Value

            HeaderFooterAnzeigen()
            objWord.Selection.HeaderFooter.Shapes.AddTextbox(1, Public_barcodeleft, Public_barcodetop, _
                Public_barcodewidth#, Public_barcodeheight).Select()
            '  objWord.Selection.ShapeRange.TextFrame.TextRange.Select
            objWord.Selection.ShapeRange.Line.Visible = Office.MsoTriState.msoFalse
            'objWord.Selection.ShapeRange.Line.Visible = Microsoft.Office.Core.MsoTriState.msoFalse 'RS:2006-08-22
            objWord.Selection.ShapeRange.TextFrame.MarginLeft = 0.0#
            objWord.Selection.ShapeRange.TextFrame.MarginRight = 0.0#
            objWord.Selection.ShapeRange.TextFrame.MarginTop = 0.0#
            objWord.Selection.ShapeRange.TextFrame.MarginBottom = 0.0#
            objWord.Selection.Collapse()
            Textboxes(Textboxesi) = objWord.Selection.HeaderFooter.Shapes.Item(Textboxesi).Name
            Textboxesi = Textboxesi + 1
            System.Windows.Forms.Application.DoEvents()
            Exit Sub

        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
        Me.Errormessage = "49"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.insert_wordart Method

Public Function insert_wordart()

Source code

[Visual Basic]
    Public Function insert_wordart()
        Me.Errormessage = "86"
        objWord.ActiveWindow.ActivePane.NewFrameset()
        objWord.ActiveWindow.ActivePane.Frameset.AddNewFrame(Word.WdFramesetNewFrameLocation.wdFramesetNewFrameAbove)
        With objWord.ActiveWindow.Document.Frameset.ChildFramesetItem(1)
            .HeightType = Word.WdFramesetSizeType.wdFramesetSizeTypeFixed
            '        .HeightType = wdFramesetSizeTypePercent
            .Height = 35
        End With
        objWord.Selection.TypeText(text:="*** Dokument im Anzeigemodus geöffnet ***")
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdLine, Extend:=Word.WdMovementType.wdExtend)
        objWord.Selection.Font.Color = Word.WdColor.wdColorRed
        objWord.Selection.Font.Size = 12
        objWord.Selection.EndKey(Unit:=Word.WdUnits.wdLine)
        objWord.Selection.ParagraphFormat.Alignment = WdParagraphAlignment.wdAlignParagraphCenter
        objWord.Selection.Font.Color = WdColor.wdColorBlack
        objWord.Selection.TypeParagraph()
        objWord.Selection.Font.Size = 9
        objWord.Selection.TypeText(text:="Änderungen im Dokument werden in EDOKA nicht berücksichtigt, auch dann nicht, wenn Sie das Dokument abspeichern.")
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdLine, Extend:=Word.WdMovementType.wdExtend)
        objWord.Selection.Font.Color = WdColor.wdColorBlack
        objWord.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)

        objWord.ActiveWindow.Panes.Item(1).Activate()
        If objWord.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone = True Then
            objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintPreview
        Else
            objWord.ActiveWindow.View.Type = WdViewType.wdPrintPreview
        End If
        objWord.CommandBars("Frames").Visible = False
        Me.Errormessage = "87"

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.logchange Method

Private Sub logchange( _
   ByVal source As Object, _
   ByVal e As System.IO.FileSystemEventArgs _
)

Parameters

source
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub logchange(ByVal source As Object, ByVal e As _
                      System.IO.FileSystemEventArgs)

        Me.Errormessage = "125"
        If e.ChangeType = IO.WatcherChangeTypes.Changed Then
            If UCase(e.FullPath) = UCase(Me.objWatcher.Path + "\" + Me.DokumentName) Then
                Dim xtime As DateTime
                xtime = File.GetLastWriteTime(Me.Dokumentfilename)
                Dim cxtime As String = xtime.ToString
                Dim csavetime As String = Save_DateTime.ToString
                Dim diff As Integer = DateDiff(DateInterval.Second, Save_DateTime, xtime)
                If diff > 2 Then
                    Save_DateTime = File.GetLastWriteTime(Me.Dokumentfilename)
                    Me.objWatcher.EnableRaisingEvents = False
                    Dim fn As String
                    fn = objWatcher.Path + "\" + Format(Now, "yyyyMMdd").ToString + "_" + Me.DokumentName
                    FileCopy(objWatcher.Path + "\" + Me.DokumentName, fn)
                    Save_Doc_Temp(fn)
                    File.Delete(fn)
                    'MsgBox("Das Dokument wurde gespeichert.")
                    Me.objWatcher.EnableRaisingEvents = True
                End If
            End If
        End If
        Me.Errormessage = "126"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.objWord_DocumentBeforeSave Method

Private Sub objWord_DocumentBeforeSave( _
   ByVal Doc As Word.Document, _
   ByRef SaveAsUI As Boolean, _
   ByRef Cancel As Boolean _
) Handles objWord.DocumentBeforeSave

Parameters

Doc
Required.
SaveAsUI
Required.
Cancel
Required.

Source code

[Visual Basic]
    Private Sub objWord_DocumentBeforeSave(ByVal Doc As Word.Document, ByRef SaveAsUI As Boolean, ByRef Cancel As Boolean) Handles objWord.DocumentBeforeSave
        Me.Errormessage = "127"

        If Me.DokumenTtyp.bNurnative.Value = True Then
            Exit Sub
        End If
        If Doc.Name = Me.DokumentName Then
            If savecount <> 0 Then Exit Sub
            Dim fn As String
            Dim fn1 As String
            savecount = 1
            System.Threading.Thread.CurrentThread.Sleep(800)
            docWord.Save()
            System.Threading.Thread.CurrentThread.Sleep(800)
            fn = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.DokumentName
            fn1 = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Format(Now, "yyyMMddhhmmss" + "_" + Me.DokumentName)
            FileCopy(fn, fn1)
            Save_Doc_Temp(fn1)
            File.Delete(fn1)
            savecount = 0
        End If
        Me.Errormessage = "128"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib.set_headerbookmark Method

Private Sub set_headerbookmark()

Source code

[Visual Basic]
    Private Sub set_headerbookmark()
        Me.Errormessage = "22"
        Try
            docWord.Bookmarks.Item("TGEDKCompanyBBEB99").Select()
        Catch
            objWord.Selection.MoveDown(Unit:=Word.WdUnits.wdLine, Count:=1)
            With objWord.ActiveDocument.Bookmarks
                .Add(Range:=objWord.Selection.Range, Name:="TGEDKCompanyBBEB99")
                .DefaultSorting = WdBookmarkSortBy.wdSortByName
                .ShowHidden = False
            End With
        End Try
        Me.Errormessage = "23"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib Events

WordLib overview

Events

event OfficeFinished

See Also

WordLib Class


OfficeFinished Event

Public Event OfficeFinished()

Source code

[Visual Basic]
    Public Event OfficeFinished()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordLib Fields

WordLib overview

Fields

field BarTextIn
field BarTextOut
field CharValue
field CheckDokumentname
field CheckSum
field Cursor_Positionieren
field DoCheckSum
field DocReadonly
field DokumenTtyp
field Dokument_Temp
field Dokument_To_Create
field Dokument_To_Save
field Dokumentdaten
field Excel_Dokument
field Finished
field II
field IsProtected
field M_Errormessage
field Office_Vorlage
field OhneIDV
field Save_DateTime
field Sum
field TempString
field Textboxes
field Textboxesi
field WordWatch
field Word_Active
field WordnewInstance
field barcodeout
field dc
field dcMTBS
field dcinvisible
field dckein
field docExcel
field docWord
field dokudata
field idvdll
field inEditMode
field isactiv
field m_CreateDoc
field m_DokumentDatum
field m_DokumentFilename
field m_DokumentID
field m_DokumentTypnr
field m_Dokumentname
field m_amsdokument
field m_document_saved
field m_dokumentidbr
field m_objdc
field m_sKopyDokID
field m_txtdokumenttyp
field m_txtpartner
field objExcel
field objResult
field objWatcher
field objWord
field ofile
field oread
field savecount
field timerloop
field xx

See Also

WordLib Class


BarTextIn Variable

Private BarTextIn As String

Source code

[Visual Basic]
    Private BarTextIn As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


BarTextOut Variable

Private BarTextOut As String

Source code

[Visual Basic]
    Private BarTextOut As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


CharValue Variable

Private CharValue As Long

Source code

[Visual Basic]
    Private CharValue As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


CheckDokumentname Variable

Dim CheckDokumentname As String

Source code

[Visual Basic]
    Dim CheckDokumentname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


CheckSum Variable

Private CheckSum As Integer

Source code

[Visual Basic]
    Private CheckSum As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Cursor_Positionieren Variable

Dim Cursor_Positionieren As Boolean

Source code

[Visual Basic]
    Dim Cursor_Positionieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


DoCheckSum Variable

Private DoCheckSum As Integer

Source code

[Visual Basic]
    Private DoCheckSum As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


DocReadonly Variable

Dim DocReadonly As Boolean

Source code

[Visual Basic]
    Dim DocReadonly As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


DokumenTtyp Variable

Dim DokumenTtyp As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim DokumenTtyp As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokument_Temp Variable

Dim Dokument_Temp As String

Source code

[Visual Basic]
    Dim Dokument_Temp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokument_To_Create Variable

Dim Dokument_To_Create As String

Source code

[Visual Basic]
    Dim Dokument_To_Create As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokument_To_Save Variable

Dim Dokument_To_Save As String

Source code

[Visual Basic]
    Dim Dokument_To_Save As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Dokumentdaten Variable

Dim Dokumentdaten As DataTable

Source code

[Visual Basic]
    Dim Dokumentdaten As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Excel_Dokument Variable

Dim Excel_Dokument As Boolean

Source code

[Visual Basic]
    Dim Excel_Dokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Finished Variable

Dim Finished As Boolean = False

Source code

[Visual Basic]
    Dim Finished As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


II Variable

Private II As Integer

Source code

[Visual Basic]
    Private II As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


IsProtected Variable

Dim IsProtected As Boolean

Source code

[Visual Basic]
    Dim IsProtected As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


M_Errormessage Variable

Dim M_Errormessage As String

Source code

[Visual Basic]
    Dim M_Errormessage As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Office_Vorlage Variable

Dim Office_Vorlage As New edokadb.clsOffice_vorlage()

Source code

[Visual Basic]
    Dim Office_Vorlage As New edokadb.clsOffice_vorlage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


OhneIDV Variable

Dim OhneIDV As Boolean = True

Source code

[Visual Basic]
    Dim OhneIDV As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Save_DateTime Variable

Dim Save_DateTime As DateTime

Source code

[Visual Basic]
    Dim Save_DateTime As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Sum Variable

Private Sum As Long

Source code

[Visual Basic]
    Private Sum As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


TempString Variable

Private TempString As String

Source code

[Visual Basic]
    Private TempString As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Textboxes Variable

Dim Textboxes( _
   100 _
) As String

Source code

[Visual Basic]
    Dim Textboxes(100) As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Textboxesi Variable

Dim Textboxesi As Integer

Source code

[Visual Basic]
    Dim Textboxesi As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordWatch Variable

Private WithEvents WordWatch As New ApplicationFileWatcher()

Source code

[Visual Basic]
    Private WithEvents WordWatch As New ApplicationFileWatcher()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


Word_Active Variable

Dim Word_Active As Boolean

Source code

[Visual Basic]
    Dim Word_Active As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


WordnewInstance Variable

Dim WordnewInstance As Boolean

Source code

[Visual Basic]
    Dim WordnewInstance As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


barcodeout Variable

Private barcodeout

Source code

[Visual Basic]
    Private barcodeout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dc Variable

Dim dc As Object

Source code

[Visual Basic]
    Dim dc As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dcMTBS Variable

Private dcMTBS As Long

Source code

[Visual Basic]
    Private dcMTBS As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dcinvisible Variable

Private dcinvisible As Integer

Source code

[Visual Basic]
    Private dcinvisible As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dckein Variable

Private dckein As Integer

Source code

[Visual Basic]
    Private dckein As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


docExcel Variable

Private WithEvents docExcel As Excel.WorkbookClass

Source code

[Visual Basic]
    Private WithEvents docExcel As Excel.WorkbookClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


docWord Variable

Private WithEvents docWord As Word.DocumentClass

Source code

[Visual Basic]
    Private WithEvents docWord As Word.DocumentClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


dokudata Variable

Dim dokudata As New edokadb.clsMyDokumentDaten()

Source code

[Visual Basic]
    Dim dokudata As New edokadb.clsMyDokumentDaten()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


idvdll Variable

Dim idvdll As Object

Source code

[Visual Basic]
    Dim idvdll As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


inEditMode Variable

Dim inEditMode As Boolean

Source code

[Visual Basic]
    Dim inEditMode As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


isactiv Variable

Dim isactiv As Boolean

Source code

[Visual Basic]
    Dim isactiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_CreateDoc Variable

Dim m_CreateDoc As Boolean

Source code

[Visual Basic]
    Dim m_CreateDoc As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_DokumentDatum Variable

Dim m_DokumentDatum As DateTime

Source code

[Visual Basic]
    Dim m_DokumentDatum As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_DokumentFilename Variable

Dim m_DokumentFilename As String

Source code

[Visual Basic]
    Dim m_DokumentFilename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_DokumentID Variable

Dim m_DokumentID As String

Source code

[Visual Basic]
    Dim m_DokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_DokumentTypnr Variable

Dim m_DokumentTypnr As Long

Source code

[Visual Basic]
    Dim m_DokumentTypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_Dokumentname Variable

Dim m_Dokumentname As String

Source code

[Visual Basic]
    Dim m_Dokumentname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_amsdokument Variable

Dim m_amsdokument As Bookmark

Source code

[Visual Basic]
    Dim m_amsdokument As Bookmark

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_document_saved Variable

Dim m_document_saved As Boolean

Source code

[Visual Basic]
    Dim m_document_saved As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_dokumentidbr Variable

Dim m_dokumentidbr As String

Source code

[Visual Basic]
    Dim m_dokumentidbr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_objdc Variable

Dim m_objdc As Object

Source code

[Visual Basic]
    Dim m_objdc As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_sKopyDokID Variable

Dim m_sKopyDokID As String = ""

Source code

[Visual Basic]
    Dim m_sKopyDokID As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_txtdokumenttyp Variable

Dim m_txtdokumenttyp As String

Source code

[Visual Basic]
    Dim m_txtdokumenttyp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


m_txtpartner Variable

Dim m_txtpartner As String

Source code

[Visual Basic]
    Dim m_txtpartner As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


objExcel Variable

Private WithEvents objExcel As Excel.ApplicationClass

Source code

[Visual Basic]
    Private WithEvents objExcel As Excel.ApplicationClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


objResult Variable

Dim objResult As System.IO.WaitForChangedResult

Source code

[Visual Basic]
    Dim objResult As System.IO.WaitForChangedResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


objWatcher Variable

Dim objWatcher As New System.IO.FileSystemWatcher()

Source code

[Visual Basic]
    Dim objWatcher As New System.IO.FileSystemWatcher()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


objWord Variable

Private WithEvents objWord As Word.ApplicationClass

Source code

[Visual Basic]
    Private WithEvents objWord As Word.ApplicationClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


ofile Variable

Dim ofile As System.IO.File

Source code

[Visual Basic]
    Dim ofile As System.IO.File

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


oread Variable

Dim oread As System.IO.TextWriter

Source code

[Visual Basic]
    Dim oread As System.IO.TextWriter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


savecount Variable

Dim savecount As Integer = 0

Source code

[Visual Basic]
    Dim savecount As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


timerloop Variable

Dim timerloop As Integer

Source code

[Visual Basic]
    Dim timerloop As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


xx Variable

Dim xx As Object

Source code

[Visual Basic]
    Dim xx As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WordLib


clsBalloon Class

For a list of all members of this type, see clsBalloon Members.

System.Object
EDOKAApp.clsBalloon

Public Class clsBalloon

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsBalloon Members


clsBalloon Members

clsBalloon overview

Methods

method CustomBalloon
method SetToolTipBackColor
method SetToolTipCaption
method SetToolTipForeColor

See Also

clsBalloon Class


clsBalloon Methods

clsBalloon overview

Methods

method CustomBalloon
method SetToolTipBackColor
method SetToolTipCaption
method SetToolTipForeColor

See Also

clsBalloon Class


clsBalloon.CustomBalloon Method

Public Sub CustomBalloon( _
   ByVal tip As ToolTip, _
   Optional ByVal style As Integer = 0 _
)

Parameters

tip
Required.
style
Optional. Default value is 0.

Source code

[Visual Basic]
    Public Sub CustomBalloon(ByVal tip As ToolTip, Optional ByVal style As Integer = 0)
        '/// the first 5 lines are from Divil's Balloon tip example
        '/// i've marked them with a * at the end.
        '/// start of *
        Dim hwnd As NativeWindow = DirectCast(GetType(ToolTip).GetField("window", Reflection.BindingFlags.NonPublic Or Reflection.BindingFlags.Instance).GetValue(tip), NativeWindow) '/// *
        style = Win32.GetWindowLong(hwnd.Handle, Win32.GWL_STYLE) '/// *
        style = style Xor ToolTipStyle.WS_BORDER '/// *
        style = style Or ToolTipStyle.TTS_BALLOON Or ToolTipStyle.TTS_NOPREFIX '/// *
        Win32.SetWindowLong(hwnd.Handle, Win32.GWL_STYLE, style) '/// *
        '/// end of *
        '/// the remaining code , for colors / caption / icon is all by me ( Dynamic Sysop )
        '/// no to set the caption / icon & colors up...
        SetToolTipCaption(hwnd, "HOT-Keys")
        SetToolTipBackColor(hwnd, Color.LemonChiffon)
        SetToolTipForeColor(hwnd, Color.Black)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBalloon


clsBalloon.SetToolTipBackColor Method

Private Sub SetToolTipBackColor( _
   ByVal tip As NativeWindow, _
   ByVal c As Color _
)

Parameters

tip
Required.
c
Required.

Source code

[Visual Basic]
    Private Sub SetToolTipBackColor(ByVal tip As NativeWindow, ByVal c As Color)
        '/// set the back color of the tooltip
        Dim Col As Integer = ColorTranslator.ToWin32(Color.FromArgb(Convert.ToInt32(c.R), Convert.ToInt32(c.G), Convert.ToInt32(c.B)))
        Win32.SetToolColors(tip.Handle, ToolTipStyle.TTM_SETTIPBKCOLOR, Col, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBalloon


clsBalloon.SetToolTipCaption Method

Private Sub SetToolTipCaption( _
   ByVal tip As NativeWindow, _
   ByVal Caption As String _
)

Parameters

tip
Required.
Caption
Required.

Source code

[Visual Basic]
    Private Sub SetToolTipCaption(ByVal tip As NativeWindow, ByVal Caption As String)
        Win32.SendMessage(tip.Handle, ToolTipStyle.TTM_SETTITLE, ToolTipIcon.TTI_INFO, Caption)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBalloon


clsBalloon.SetToolTipForeColor Method

Private Sub SetToolTipForeColor( _
   ByVal tip As NativeWindow, _
   ByVal c As Color _
)

Parameters

tip
Required.
c
Required.

Source code

[Visual Basic]
    Private Sub SetToolTipForeColor(ByVal tip As NativeWindow, ByVal c As Color)
        '/// set the back color of the tooltip
        Dim Col As Integer = ColorTranslator.ToWin32(Color.FromArgb(Convert.ToInt32(c.R), Convert.ToInt32(c.G), Convert.ToInt32(c.B)))
        Win32.SetToolColors(tip.Handle, ToolTipStyle.TTM_SETTIPTEXTCOLOR, Col, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBalloon


clsEmpfaengerdata Class

For a list of all members of this type, see clsEmpfaengerdata Members.

System.Object
EDOKAApp.clsEmpfaengerdata

Public Class clsEmpfaengerdata

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEmpfaengerdata Members


clsEmpfaengerdata Members

clsEmpfaengerdata overview

Constructors

constructor clsEmpfaengerdata Constructor

Methods

method Create_SQL_Server_Table
method Datentabelle_Generieren
method Fill_And_Get_Data
method Generate_Key
method Get_Empfaenger
method Insert_DT_Column
method Load_Empfaenger
method Pruefziffer
method Save_Data_To_Temptable
method Vorlagendaten_aufbreiten
method hascoltodelete

Fields

field Dokid
field Serienbriefnr
field dsempfaenger
field reservedwords

See Also

clsEmpfaengerdata Class


clsEmpfaengerdata Constructor

Public Sub New( _
   ByRef DsEmpfaenger As DataSet, _
   ByVal Serienbriefnr As Integer _
)

Parameters

DsEmpfaenger
Required.
Serienbriefnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByRef DsEmpfaenger As DataSet, ByVal Serienbriefnr As Integer)
        Me.dsempfaenger = DsEmpfaenger
        Me.Serienbriefnr = Serienbriefnr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata Methods

clsEmpfaengerdata overview

Methods

method Create_SQL_Server_Table
method Datentabelle_Generieren
method Fill_And_Get_Data
method Generate_Key
method Get_Empfaenger
method Insert_DT_Column
method Load_Empfaenger
method Pruefziffer
method Save_Data_To_Temptable
method Vorlagendaten_aufbreiten
method hascoltodelete

See Also

clsEmpfaengerdata Class


clsEmpfaengerdata.Create_SQL_Server_Table Method

Private Sub Create_SQL_Server_Table( _
   ByRef dt As DataTable _
)

Parameters

dt
Required.

Source code

[Visual Basic]
    Private Sub Create_SQL_Server_Table(ByRef dt As DataTable)
        Dim s As String
        Dim s1 As String
        Dim i As Integer
        'dt.Columns.Add("NRPAR00")
        'dt.Columns.Add("IntEintragNr")

        s1 = "Drop Table DBO.EDKB09_" + Me.Serienbriefnr.ToString

        's = "Create Table EDKB09_" + Me.Serienbriefnr.ToString + "( NRPAR00 int, intEintragNr int,"
        s = "Create Table DBO.EDKB09_" + Me.Serienbriefnr.ToString + "( NRPAR00 varchar(11),"
        For i = 1 To dt.Columns.Count - 1
            s = s + dt.Columns(i).ColumnName + " varchar(255),"
        Next
        s = Left(s, Len(s) - 1)
        s = s + ")"
        Dim conn As New SqlConnection()
        conn.ConnectionString = Globals.sConnectionString
        conn.Open()
        Dim sqlcmd0 As New SqlCommand(s1, conn)
        Try
            sqlcmd0.ExecuteNonQuery()
        Catch
        End Try

        Dim sqlcmd As New SqlCommand(s, conn)
        sqlcmd.ExecuteNonQuery()
        conn.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Datentabelle_Generieren Method

Private Function Datentabelle_Generieren() As DataTable

Source code

[Visual Basic]
    Private Function Datentabelle_Generieren() As DataTable
        Dim dt As New DataTable()
        Dim dn As DataRow
        Dim i As Integer

        Dim aPrimaryKey(0) As DataColumn
        Dim oDatacolumn As DataColumn

        Me.dsempfaenger.Tables(0).Columns.Add("IntEintragnr")
        For i = 0 To Me.dsempfaenger.Tables(0).Rows.Count - 1
            Me.dsempfaenger.Tables(0).Rows(i).Item("IntEintragNr") = i
        Next
        oDatacolumn = Me.dsempfaenger.Tables(0).Columns("IntEintragnr")
        aPrimaryKey(0) = oDatacolumn
        Me.dsempfaenger.Tables(0).PrimaryKey = aPrimaryKey

        dt.TableName = "EDKB09_" + Me.Serienbriefnr.ToString
        For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
            dt.Columns.Add(Me.dsempfaenger.Tables(0).Columns(i).ColumnName)
        Next
        Dim dv As DataRow()
        Dim dr As DataRow
        dv = Me.dsempfaenger.Tables(0).Select("Dokumentid='' or dokumentid<>''")
        For Each dr In dv
            dt.ImportRow(dr)
        Next
        '        dt = Me.dsempfaenger.Tables(0).Copy

        'Dim dc As DataColumn
        'For Each dc In dt.Columns
        '    dc.ColumnName = dc.ColumnName.Replace(" ", "_")
        '    dc.ColumnName = dc.ColumnName.Replace(" ", "_")
        '    dc.ColumnName = dc.ColumnName.Replace("ö", "oe")
        '    dc.ColumnName = dc.ColumnName.Replace("Ö", "OE")
        '    dc.ColumnName = dc.ColumnName.Replace("ü", "ue")
        '    dc.ColumnName = dc.ColumnName.Replace("Ü", "UE")
        '    dc.ColumnName = dc.ColumnName.Replace("ä", "ae")
        '    dc.ColumnName = dc.ColumnName.Replace("Ä", "AE")
        '    dc.ColumnName = dc.ColumnName.Replace("-", "_")
        '    dc.ColumnName = dc.ColumnName.Replace("/", "_")
        '    dc.ColumnName = dc.ColumnName.Replace("\", "_")
        '    dc.ColumnName = dc.ColumnName.Replace(".", "_")
        '    dc.ColumnName = dc.ColumnName.Replace(":", "_")
        '    dc.ColumnName = dc.ColumnName.Replace(",", "_")

        '    Select Case Left(dc.ColumnName, 1)
        '        Case "1", "2", "3", "4", "5", "6", "7", "8", "9", "0"
        '            dc.ColumnName = "N" + dc.ColumnName
        '    End Select
        '    If resword(dc.ColumnName) Then
        '        dc.ColumnName = dc.ColumnName + "_"
        '    End If
        'Next

        Dim tmkopfzeile As Boolean = False
        Me.dsempfaenger.Tables("UsedFelder").AcceptChanges()
        Try
            For i = 0 To Me.dsempfaenger.Tables("UsedFelder").Rows.Count - 1
                If Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Nr") = 33 Then
                    tmkopfzeile = True
                End If
            Next
        Catch ex As Exception
            Dim a
            a = 1
        End Try

        If tmkopfzeile = False Then
            dn = Me.dsempfaenger.Tables("UsedFelder").NewRow
            dn.Item(0) = 33
            dn.Item(1) = "TGEDKCompanyBBEB99"
            dn.Item(2) = ""
            dn.Item(3) = "TGEDKCompanyBBEB99"
            dn.Item(4) = ""
            Me.dsempfaenger.Tables("UsedFelder").Rows.Add(dn)
        End If

        Me.dsempfaenger.Tables("UsedFelder").Columns.Add("TempFeldname")
        Me.dsempfaenger.Tables("UsedFelder").Columns.Add("Fnkt")
        Dim s As String
        For i = 0 To Me.dsempfaenger.Tables("UsedFelder").Rows.Count - 1
            If Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Nr") <> 0 Then
                s = "F_09_" + Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Nr").ToString
                Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("fnkt") = s
                s = Insert_DT_Column(dt, s)
                Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Tempfeldname") = s
            Else
                s = "I_09_" + Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Beginntextmarke")
                Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("fnkt") = s
                s = Insert_DT_Column(dt, s)
                Me.dsempfaenger.Tables("UsedFelder").Rows(i).Item("Tempfeldname") = s
            End If
        Next
        Create_SQL_Server_Table(dt)
        Save_Data_To_Temptable(dt)
        Return Fill_And_Get_Data()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Fill_And_Get_Data Method

Private Function Fill_And_Get_Data() As DataTable

Source code

[Visual Basic]
    Private Function Fill_And_Get_Data() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_fill_sbdata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@serienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Serienbriefnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@ROWCOUNT", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bedr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@preview", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
            Dokid = scmCmdToExecute.Parameters("@dokumentid").Value
            For i = 0 To dtToReturn.Rows.Count - 1
                dtToReturn.Rows(i).Item("Dokumentid") = Generate_Key(Dokid)
                Dokid = Dokid + 1
                If scmCmdToExecute.Parameters("@bedr").Value = 1 Then
                    dtToReturn.Rows(i).Item("dokumentidbdr") = Generate_Key(Dokid)
                    Dokid = Dokid + 1
                End If
            Next
            Return dtToReturn

        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Generate_Key Method

Public Function Generate_Key( _
   ByVal key As Long _
) As String

Parameters

key
Required.

Source code

[Visual Basic]
    Public Function Generate_Key(ByVal key As Long) As String
        Dim skey As String
        Dim s As String
        skey = "OFFEDK000"

        s = Str(Year(Now))
        While Microsoft.VisualBasic.Left(s, 1) = " "
            s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
        End While
        skey = skey + s

        s = Str(key)
        While Microsoft.VisualBasic.Left(s, 1) = " "
            s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
        End While

        While Len(s) < 8
            s = "0" + s
        End While
        skey = skey + s

        s = Pruefziffer(Microsoft.VisualBasic.Right(skey, 15))
        While Microsoft.VisualBasic.Left(s, 1) = " "
            s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
        End While
        skey = skey + s
        Generate_Key = skey
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Get_Empfaenger Method

Public Function Get_Empfaenger()

Source code

[Visual Basic]
    Public Function Get_Empfaenger()
        Load_Empfaenger()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Insert_DT_Column Method

Private Function Insert_DT_Column( _
   ByRef dt As DataTable, _
   ByVal colname As String _
) As String

Parameters

dt
Required.
colname
Required.

Source code

[Visual Basic]
    Private Function Insert_DT_Column(ByRef dt As DataTable, ByVal colname As String) As String
        Dim i As Integer = 0
        Dim dc As DataColumn
        For Each dc In dt.Columns
            If UCase(Microsoft.VisualBasic.Left(dc.ColumnName, Len(colname))) = UCase(colname) Then
                i = i + 1
            End If
        Next
        If i > 0 Then colname = colname + "_" + i.ToString
        dt.Columns.Add(colname)
        Return colname
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Load_Empfaenger Method

Private Sub Load_Empfaenger()

Source code

[Visual Basic]
    Private Sub Load_Empfaenger()
        'Dim dokumentname = Globals.Params.Pfad_Serienbrief_Daten + Me.Serienbriefnr.ToString + "_empfaenger.xml"
        'Try
        '    Me.dsempfaenger.Tables.Clear()
        '    Dim Connection As New SqlConnection()
        '    Dim DA As New SqlDataAdapter("select * from edex_sb_empfaenger where serienbriefnr=" + Str(Me.Serienbriefnr), Connection)
        '    Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
        '    Dim ds As New DataSet()
        '    Try
        '        Connection.ConnectionString = Globals.sConnectionString
        '        Connection.Open()
        '        DA.Fill(ds, "empf")
        '        Dim myRow As DataRow
        '        If ds.Tables(0).Rows.Count = 0 Then
        '            MsgBox("Empfänger konnten nicht geladen werden.")
        '        Else
        '            myRow = ds.Tables(0).Rows(0)
        '            Dim MyData() As Byte
        '            MyData = myRow.Item(2)
        '            Dim K As Long
        '            K = UBound(MyData)
        '            Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
        '            fs.Write(MyData, 0, K)
        '            fs.Close()
        '            fs = Nothing
        '            Me.dsempfaenger.ReadXml(dokumentname)
        '        End If
        '    Catch ex As Exception
        '    End Try
        '    cb = Nothing
        '    ds = Nothing
        '    DA = Nothing

        '    Connection.Close()
        '    Connection = Nothing
        'Catch EX As Exception
        'Finally
        '    Try
        '        File.Delete(dokumentname)
        '    Catch

        '    End Try
        'End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Pruefziffer Method

Public Function Pruefziffer( _
   ByVal zahl As String _
) As String

Parameters

zahl
Required.

Source code

[Visual Basic]
    Public Function Pruefziffer(ByVal zahl As String) As String
        Dim ptab(9, 9) As Integer
        Dim pz(9) As Integer
        Dim s1, s2, s3 As String

        Dim i1, i2 As Long

        s1 = "0,9,4,6,8,2,7,1,3,5"
        s2 = s1
        For i1 = 0 To 9
            For i2 = 0 To 9
                ptab(i1, i2) = Mid(s2, (i2 * 2) + 1, 1)
            Next
            s3 = Microsoft.VisualBasic.Left(s1, 1)
            s1 = Microsoft.VisualBasic.Right(s1, Len(s1) - 2)
            s1 = s1 + "," + s3
            s2 = s1
        Next
        pz(0) = 0
        pz(1) = 9
        pz(2) = 8
        pz(3) = 7
        pz(4) = 6
        pz(5) = 5
        pz(6) = 4
        pz(7) = 3
        pz(8) = 2
        pz(9) = 1

        Dim i, x, y, z, e As Integer
        Dim xx As String
        y = 0
        For i = 1 To Len(zahl)
            x = Val(Mid(zahl, i, 1))
            y = ptab(x, y)
        Next
        Pruefziffer = Str(pz(y))
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Save_Data_To_Temptable Method

Private Sub Save_Data_To_Temptable( _
   ByRef dt As DataTable _
)

Parameters

dt
Required.

Source code

[Visual Basic]
    Private Sub Save_Data_To_Temptable(ByRef dt As DataTable)
        Dim tdt As New DataTable("EDKB09_" + Me.Serienbriefnr.ToString)
        Dim tdr As DataRow
        Dim i As Integer
        Dim ii As Integer
        tdt = dt.Copy
        tdt.Columns(0).ColumnName = "NRPAR00"
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * from EDKB09_" + Me.Serienbriefnr.ToString, connection)
        Dim cb As New SqlCommandBuilder(da)
        connection.ConnectionString = Globals.sConnectionString
        connection.Open()
        da.Update(tdt)
        connection.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.Vorlagendaten_aufbreiten Method

Public Function Vorlagendaten_aufbreiten() As DataTable

Source code

[Visual Basic]
    Public Function Vorlagendaten_aufbreiten() As DataTable
        Return Datentabelle_Generieren()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata.hascoltodelete Method

Private Function hascoltodelete( _
   ByRef edata As DataTable, _
   ByVal Prefix As String _
) As Boolean

Parameters

edata
Required.
Prefix
Required.

Source code

[Visual Basic]
    Private Function hascoltodelete(ByRef edata As DataTable, ByVal Prefix As String) As Boolean
        Dim i As Integer
        Dim s As String = ""
        For i = 0 To edata.Columns.Count - 1
            If Left(edata.Columns(i).ColumnName, 2) = Prefix Then
                s = edata.Columns(i).ColumnName
                Exit For
            End If
        Next
        If s <> "" Then
            edata.Columns.Remove(s)
            Return True
        End If
        Return False
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsEmpfaengerdata Fields

clsEmpfaengerdata overview

Fields

field Dokid
field Serienbriefnr
field dsempfaenger
field reservedwords

See Also

clsEmpfaengerdata Class


Dokid Variable

Dim Dokid As Integer

Source code

[Visual Basic]
    Dim Dokid As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


Serienbriefnr Variable

Dim Serienbriefnr As Integer

Source code

[Visual Basic]
    Dim Serienbriefnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


dsempfaenger Variable

Dim dsempfaenger As DataSet

Source code

[Visual Basic]
    Dim dsempfaenger As DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


reservedwords Variable

Dim reservedwords As Collection()

Source code

[Visual Basic]
    Dim reservedwords As Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEmpfaengerdata


clsListViewItemComparer Class

For a list of all members of this type, see clsListViewItemComparer Members.

System.Object
EDOKAApp.clsListViewItemComparer

Public Class clsListViewItemComparer
   Implements IComparer

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsListViewItemComparer Members


clsListViewItemComparer Members

clsListViewItemComparer overview

Constructors

constructor clsListViewItemComparer Constructor

Properties

property Column
property Numeric

Methods

method Compare

Fields

field _Column
field _Numeric

See Also

clsListViewItemComparer Class


clsListViewItemComparer Constructor

Public Sub New( _
   ByVal ColumnIndex As Integer _
)

Parameters

ColumnIndex
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal ColumnIndex As Integer)
        Column = ColumnIndex
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


clsListViewItemComparer Properties

clsListViewItemComparer overview

Properties

property Column
property Numeric

See Also

clsListViewItemComparer Class


clsListViewItemComparer.Column Property

Public Property Column() As Integer

Source code

[Visual Basic]
    Public Property Column() As Integer
        Get
            Return _Column
        End Get
        Set(ByVal Value As Integer)
            _Column = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


clsListViewItemComparer.Numeric Property

Public Property Numeric() As Boolean

Source code

[Visual Basic]
    Public Property Numeric() As Boolean
        Get
            Return _Numeric
        End Get
        Set(ByVal Value As Boolean)
            _Numeric = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


clsListViewItemComparer Methods

clsListViewItemComparer overview

Methods

method Compare

See Also

clsListViewItemComparer Class


clsListViewItemComparer.Compare Method

Public Function Compare( _
   ByVal x As Object, _
   ByVal y As Object _
) As Integer Implements System.Collections.IComparer.Compare

Parameters

x
Required.
y
Required.

Source code

[Visual Basic]
    Public Function Compare(ByVal x As Object, ByVal y As Object) As Integer _
                Implements System.Collections.IComparer.Compare
        Dim ListX As ListViewItem = CType(x, ListViewItem)
        Dim ListY As ListViewItem = CType(y, ListViewItem)
        If Numeric Then
            Dim ListXVal, ListYVal As Decimal
            Try
                ListXVal = Decimal.Parse(ListX.SubItems(Column).Text)
            Catch
                ListXVal = 0
            End Try
            Try
                ListYVal = Decimal.Parse(ListY.SubItems(Column).Text)
            Catch
                ListYVal = 0
            End Try

            Return Decimal.Compare(ListXVal, ListYVal)
        Else
            Dim ListXText As String = ListX.SubItems(Column).Text
            Dim ListYText As String = ListY.SubItems(Column).Text

            Return String.Compare(ListXText, ListYText)
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


clsListViewItemComparer Fields

clsListViewItemComparer overview

Fields

field _Column
field _Numeric

See Also

clsListViewItemComparer Class


_Column Variable

Private _Column As Integer

Source code

[Visual Basic]
    Private _Column As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


_Numeric Variable

Private _Numeric As Boolean = False

Source code

[Visual Basic]
    Private _Numeric As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsListViewItemComparer


clsMehrfachdruck_Data Class

For a list of all members of this type, see clsMehrfachdruck_Data Members.

System.Object
EDOKAApp.clsMehrfachdruck_Data

Public Class clsMehrfachdruck_Data

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMehrfachdruck_Data Members


clsMehrfachdruck_Data Members

clsMehrfachdruck_Data overview

Constructors

constructor clsMehrfachdruck_Data Constructor

Properties

property Auftragnr
property DokumentId
property DokumentTyp
property Erstellungsdatum
property OfficeDokument
property PartnerName
property PartnerNr
property Typ

Fields

field m_Auftragnr
field m_DokumentId
field m_DokumentTyp
field m_Erstellungsdatum
field m_OfficeDokument
field m_PartnerName
field m_PartnerNr
field m_Typ

See Also

clsMehrfachdruck_Data Class


clsMehrfachdruck_Data Constructor

Public Sub New( _
   ByVal DokID As String, _
   ByVal iPartnerNr As Integer, _
   ByVal sTyp As Enum_Typ, _
   ByVal bOfficeDokument As Boolean, _
   ByVal sDokTyp As String, _
   ByVal sAuftragnr As String, _
   ByVal sPartnerName As String, _
   ByVal sErstellungsdatum As String _
)

Parameters

DokID
Required.
iPartnerNr
Required.
sTyp
Required.
bOfficeDokument
Required.
sDokTyp
Required.
sAuftragnr
Required.
sPartnerName
Required.
sErstellungsdatum
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal DokID As String, ByVal iPartnerNr As Integer, ByVal sTyp As Enum_Typ, _
    ByVal bOfficeDokument As Boolean, ByVal sDokTyp As String, ByVal sAuftragnr As String, ByVal sPartnerName As String, _
    ByVal sErstellungsdatum As String)

        m_DokumentId = DokID
        m_PartnerNr = iPartnerNr
        m_Typ = sTyp
        m_OfficeDokument = bOfficeDokument
        m_DokumentTyp = sDokTyp
        m_Auftragnr = sAuftragnr
        m_PartnerName = sPartnerName
        m_Erstellungsdatum = sErstellungsdatum

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data Properties

clsMehrfachdruck_Data overview

Properties

property Auftragnr
property DokumentId
property DokumentTyp
property Erstellungsdatum
property OfficeDokument
property PartnerName
property PartnerNr
property Typ

See Also

clsMehrfachdruck_Data Class


clsMehrfachdruck_Data.Auftragnr Property

Property Auftragnr() As String

Source code

[Visual Basic]
    Property Auftragnr() As String
        Get
            Return m_Auftragnr
        End Get
        Set(ByVal Value As String)
            m_Auftragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.DokumentId Property

Property DokumentId() As String

Source code

[Visual Basic]
    Property DokumentId() As String
        Get
            Return m_DokumentId
        End Get
        Set(ByVal Value As String)
            m_DokumentId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.DokumentTyp Property

Property DokumentTyp() As String

Source code

[Visual Basic]
    Property DokumentTyp() As String
        Get
            Return m_DokumentTyp
        End Get
        Set(ByVal Value As String)
            m_DokumentTyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.Erstellungsdatum Property

Property Erstellungsdatum() As String

Source code

[Visual Basic]
    Property Erstellungsdatum() As String
        Get
            Return m_Erstellungsdatum
        End Get
        Set(ByVal Value As String)
            m_Erstellungsdatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.OfficeDokument Property

Property OfficeDokument() As Boolean

Source code

[Visual Basic]
    Property OfficeDokument() As Boolean
        Get
            Return m_OfficeDokument
        End Get
        Set(ByVal Value As Boolean)
            m_OfficeDokument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.PartnerName Property

Property PartnerName() As String

Source code

[Visual Basic]
    Property PartnerName() As String
        Get
            Return m_PartnerName
        End Get
        Set(ByVal Value As String)
            m_PartnerName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.PartnerNr Property

Property PartnerNr() As Integer

Source code

[Visual Basic]
    Property PartnerNr() As Integer
        Get
            Return m_PartnerNr
        End Get
        Set(ByVal Value As Integer)
            m_PartnerNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data.Typ Property

Property Typ() As Enum_Typ

Source code

[Visual Basic]
    Property Typ() As Enum_Typ
        Get
            Return m_Typ
        End Get
        Set(ByVal Value As Enum_Typ)
            m_Typ = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsMehrfachdruck_Data Fields

clsMehrfachdruck_Data overview

Fields

field m_Auftragnr
field m_DokumentId
field m_DokumentTyp
field m_Erstellungsdatum
field m_OfficeDokument
field m_PartnerName
field m_PartnerNr
field m_Typ

See Also

clsMehrfachdruck_Data Class


m_Auftragnr Variable

Dim m_Auftragnr As String

Source code

[Visual Basic]
    Dim m_Auftragnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_DokumentId Variable

Dim m_DokumentId As String

Source code

[Visual Basic]
    Dim m_DokumentId As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_DokumentTyp Variable

Dim m_DokumentTyp As String

Source code

[Visual Basic]
    Dim m_DokumentTyp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_Erstellungsdatum Variable

Dim m_Erstellungsdatum As String

Source code

[Visual Basic]
    Dim m_Erstellungsdatum As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_OfficeDokument Variable

Dim m_OfficeDokument As Boolean

Source code

[Visual Basic]
    Dim m_OfficeDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_PartnerName Variable

Dim m_PartnerName As String

Source code

[Visual Basic]
    Dim m_PartnerName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_PartnerNr Variable

Dim m_PartnerNr As Integer

Source code

[Visual Basic]
    Dim m_PartnerNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


m_Typ Variable

Dim m_Typ As Enum_Typ

Source code

[Visual Basic]
    Dim m_Typ As Enum_Typ

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMehrfachdruck_Data


clsPDF_print_show Class

For a list of all members of this type, see clsPDF_print_show Members.

System.Object
EDOKAApp.clsPDF_print_show

Public Class clsPDF_print_show

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsPDF_print_show Members


clsPDF_print_show Members

clsPDF_print_show overview

Methods

method PrintPDF

See Also

clsPDF_print_show Class


clsPDF_print_show Methods

clsPDF_print_show overview

Methods

method PrintPDF

See Also

clsPDF_print_show Class


clsPDF_print_show.PrintPDF Method

Public Function PrintPDF( _
   ByVal sFilename As String, _
   ByVal Art As Enum_Art _
) As Boolean

Parameters

sFilename
Required.
Art
Required.

Source code

[Visual Basic]
    Public Function PrintPDF(ByVal sFilename As String, ByVal Art As Enum_Art) As Boolean
        PrintPDF = True
        Dim myProcess As New Process()
        Try
            'Point the process to our Acrobat file
            myProcess.StartInfo.FileName = sFilename
            myProcess.StartInfo.WorkingDirectory = New IO.FileInfo(sFilename).DirectoryName

            'Since we don't want to see Acrobat's UI (we just want the report printed)
            'then suppress the UI and pass the "Print" verb to force Acrobat to only print
            myProcess.StartInfo.CreateNoWindow = True

            If Art = Enum_Art.Anzeigen Then
                myProcess.StartInfo.Verb = "Open"
                myProcess.StartInfo.WindowStyle = ProcessWindowStyle.Normal
            Else
                myProcess.StartInfo.WindowStyle = ProcessWindowStyle.Hidden
                myProcess.StartInfo.Verb = "Print"
            End If
            myProcess.Start()

            'Wait until Acrobat has finished heavy processing,  or 10 seconds whichever comes first
            If Not myProcess.HasExited Then myProcess.WaitForInputIdle(10000)
            'Attempt to close Acrobat so it's UI doesn't sit on the user's task bar
            'loop until we suceed or until we timeout. If we timeout, kill Adobe
            Dim i As Integer = 1
            Dim lbRunning As Boolean = True
            'Da keine Kill Rechte auf den Vista Maschinen vorhanden sind, wird der Prozess nicht gekillt.
            lbRunning = False
            'While lbRunning And i <= 20
            '    'sleep for 1/2 of a second
            '    System.Threading.Thread.Sleep(500)

            '    'See if the Adobe will exit gracefully
            '    Select Case myProcess.HasExited
            '        Case True : lbRunning = False
            '        Case False : lbRunning = Not myProcess.CloseMainWindow
            '    End Select

            '    i += 1
            'End While

            'If it never closed gracefuly, force it out of memory
            If lbRunning AndAlso Not myProcess.HasExited Then myProcess.Kill()
            myProcess.Dispose()

        Catch ex As System.ComponentModel.Win32Exception
            PrintPDF = False
        Catch ex As Exception
            PrintPDF = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPDF_print_show


clsPerformance Class

For a list of all members of this type, see clsPerformance Members.

System.Object
EDOKAApp.clsPerformance

Public Class clsPerformance

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsPerformance Members


clsPerformance Members

clsPerformance overview

Methods

method Insert_DocRestore
method force_insert_entry
method insert_entry

See Also

clsPerformance Class


clsPerformance Methods

clsPerformance overview

Methods

method Insert_DocRestore
method force_insert_entry
method insert_entry

See Also

clsPerformance Class


clsPerformance.Insert_DocRestore Method

Public Sub Insert_DocRestore( _
   ByVal msg As String _
)

Parameters

msg
Required.

Source code

[Visual Basic]
    Public Sub Insert_DocRestore(ByVal msg As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentrestore"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, msg))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPerformance


clsPerformance.force_insert_entry Method

Public Sub force_insert_entry( _
   ByVal msg As String _
)

Parameters

msg
Required.

Source code

[Visual Basic]
    Public Sub force_insert_entry(ByVal msg As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_performance"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, msg))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@zeit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPerformance


clsPerformance.insert_entry Method

Public Sub insert_entry( _
   ByVal msg As String _
)

Parameters

msg
Required.

Source code

[Visual Basic]
    Public Sub insert_entry(ByVal msg As String)
        If Globals.DoLog = False Then Exit Sub
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_performance"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, msg))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@zeit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Now))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPerformance


clsSpooler_Data Class

For a list of all members of this type, see clsSpooler_Data Members.

System.Object
EDOKAApp.clsSpooler_Data

Public Class clsSpooler_Data

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsSpooler_Data Members


clsSpooler_Data Members

clsSpooler_Data overview

Constructors

constructor clsSpooler_Data Constructor

Properties

property Anzahl
property AuftragNr
property Data
property DateiName
property ErstelltAm
property JobID
property Status
property StatusID
property Typ

Fields

field m_Anzahl
field m_AuftragNR
field m_Data
field m_DateiName
field m_ErstelltAm
field m_JobID
field m_Status
field m_StatusID
field m_Typ

See Also

clsSpooler_Data Class


clsSpooler_Data Constructor

Public Sub New( _
   ByVal JobID As Integer, _
   ByVal sAuftragNr As String, _
   ByVal sTyp As String, _
   ByVal sStatus As String, _
   ByVal sAnzahl As String, _
   ByVal sData As Collection, _
   ByVal sErstellungsdatum As String, _
   ByVal iStatusID As Integer, _
   ByVal sDateiName As String _
)

Parameters

JobID
Required.
sAuftragNr
Required.
sTyp
Required.
sStatus
Required.
sAnzahl
Required.
sData
Required.
sErstellungsdatum
Required.
iStatusID
Required.
sDateiName
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal JobID As Integer, ByVal sAuftragNr As String, ByVal sTyp As String, _
    ByVal sStatus As String, ByVal sAnzahl As String, ByVal sData As Collection, _
    ByVal sErstellungsdatum As String, ByVal iStatusID As Integer, ByVal sDateiName As String)

        m_JobID = JobID
        m_AuftragNR = sAuftragNr
        m_Typ = sTyp
        m_Status = sStatus
        m_Anzahl = sAnzahl
        m_Data = sData
        m_ErstelltAm = sErstellungsdatum
        m_StatusID = iStatusID
        m_DateiName = sDateiName

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data Properties

clsSpooler_Data overview

Properties

property Anzahl
property AuftragNr
property Data
property DateiName
property ErstelltAm
property JobID
property Status
property StatusID
property Typ

See Also

clsSpooler_Data Class


clsSpooler_Data.Anzahl Property

Property Anzahl() As String

Source code

[Visual Basic]
    Property Anzahl() As String
        Get
            Return m_Anzahl
        End Get
        Set(ByVal Value As String)
            m_Anzahl = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.AuftragNr Property

Property AuftragNr() As String

Source code

[Visual Basic]
    Property AuftragNr() As String
        Get
            Return m_AuftragNR
        End Get
        Set(ByVal Value As String)
            m_AuftragNR = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.Data Property

Property Data() As Collection

Source code

[Visual Basic]
    Property Data() As Collection
        Get
            Return m_Data
        End Get
        Set(ByVal Value As Collection)
            m_Data = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.DateiName Property

Property DateiName() As String

Source code

[Visual Basic]
    Property DateiName() As String
        Get
            Return m_DateiName
        End Get
        Set(ByVal Value As String)
            m_DateiName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.ErstelltAm Property

Property ErstelltAm() As Date

Source code

[Visual Basic]
    Property ErstelltAm() As Date
        Get
            Return m_ErstelltAm
        End Get
        Set(ByVal Value As Date)
            m_ErstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.JobID Property

Property JobID() As Integer

Source code

[Visual Basic]
    Property JobID() As Integer
        Get
            Return m_JobID
        End Get
        Set(ByVal Value As Integer)
            m_JobID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.Status Property

Property Status() As String

Source code

[Visual Basic]
    Property Status() As String
        Get
            Return m_Status
        End Get
        Set(ByVal Value As String)
            m_Status = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.StatusID Property

Property StatusID() As Integer

Source code

[Visual Basic]
    Property StatusID() As Integer
        Get
            Return m_StatusID
        End Get
        Set(ByVal Value As Integer)
            m_StatusID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data.Typ Property

Property Typ() As String

Source code

[Visual Basic]
    Property Typ() As String
        Get
            Return m_Typ
        End Get
        Set(ByVal Value As String)
            m_Typ = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsSpooler_Data Fields

clsSpooler_Data overview

Fields

field m_Anzahl
field m_AuftragNR
field m_Data
field m_DateiName
field m_ErstelltAm
field m_JobID
field m_Status
field m_StatusID
field m_Typ

See Also

clsSpooler_Data Class


m_Anzahl Variable

Dim m_Anzahl As String

Source code

[Visual Basic]
    Dim m_Anzahl As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_AuftragNR Variable

Dim m_AuftragNR As String

Source code

[Visual Basic]
    Dim m_AuftragNR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_Data Variable

Dim m_Data As Collection

Source code

[Visual Basic]
    Dim m_Data As Collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_DateiName Variable

Dim m_DateiName As String

Source code

[Visual Basic]
    Dim m_DateiName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_ErstelltAm Variable

Dim m_ErstelltAm As Date

Source code

[Visual Basic]
    Dim m_ErstelltAm As Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_JobID Variable

Dim m_JobID As Integer

Source code

[Visual Basic]
    Dim m_JobID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_Status Variable

Dim m_Status As String

Source code

[Visual Basic]
    Dim m_Status As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_StatusID Variable

Dim m_StatusID As Integer

Source code

[Visual Basic]
    Dim m_StatusID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


m_Typ Variable

Dim m_Typ As String

Source code

[Visual Basic]
    Dim m_Typ As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpooler_Data


clsXTimer Class

For a list of all members of this type, see clsXTimer Members.

System.Object
EDOKAApp.clsXTimer

Friend Class clsXTimer

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsXTimer Members


clsXTimer Members

clsXTimer overview

Constructors

constructor clsXTimer Constructor

Properties

property RunTime

Methods

method CODFORCOPY_PAST
method Calibr
method Calibrate
method Class_Initialize_Renamed
method QueryPerformanceCounter
method QueryPerformanceFrequency
method StartTimer
method StopTimer
method Stop_nd_GetTime

Fields

field m_dblCalibr
field m_liEnd
field m_liFreq
field m_liStart

See Also

clsXTimer Class


clsXTimer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()
        Class_Initialize_Renamed()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer Properties

clsXTimer overview

Properties

property RunTime

See Also

clsXTimer Class


clsXTimer.RunTime Property

Public ReadOnly Property RunTime() As Object

Source code

[Visual Basic]
    Public ReadOnly Property RunTime() As Object
        Get ' ms
            RunTime = Math.Abs((Calibr(m_liEnd) - Calibr(m_liStart)) / Calibr(m_liFreq) * 1000 - m_dblCalibr)
            If RunTime < 0 Then RunTime = 0
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer Methods

clsXTimer overview

Methods

method CODFORCOPY_PAST
method Calibr
method Calibrate
method Class_Initialize_Renamed
method QueryPerformanceCounter
method QueryPerformanceFrequency
method StartTimer
method StopTimer
method Stop_nd_GetTime

See Also

clsXTimer Class


clsXTimer.CODFORCOPY_PAST Method

Private Sub CODFORCOPY_PAST()

Source code

[Visual Basic]
    Private Sub CODFORCOPY_PAST()
        '===============================================================================
        'Dieser Codteil wird für die Messung gebraucht
        '===============================================================================
        Dim m_clsXTime As New clsXTimer()
        m_clsXTime.Calibrate()
        m_clsXTime.StartTimer()
        'Zu messender Code go's here
        m_clsXTime.StopTimer()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.Calibr Method

Private Function Calibr( _
   ByRef liX As clsXTimer.LARGE_INTEGER _
) As Double

Parameters

liX
Required.

Source code

[Visual Basic]
    Private Function Calibr(ByRef liX As clsXTimer.LARGE_INTEGER) As Double
        Calibr = liX.lowpart + liX.highpart * 4294967296.0#
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.Calibrate Method

Public Sub Calibrate()

Source code

[Visual Basic]
    Public Sub Calibrate()
        Call QueryPerformanceCounter(m_liStart)
        Call QueryPerformanceCounter(m_liEnd)
        m_dblCalibr = (Calibr(m_liEnd) - Calibr(m_liStart)) / Calibr(m_liFreq) * 1000 ' Millisekunden.
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.Class_Initialize_Renamed Method

Private Sub Class_Initialize_Renamed()

Source code

[Visual Basic]
    Private Sub Class_Initialize_Renamed()
        Call QueryPerformanceFrequency(m_liFreq)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.QueryPerformanceCounter Method

Private Declare Function QueryPerformanceCounter Lib "kernel32" ( _
   ByRef lpPerformanceCount As clsXTimer.LARGE_INTEGER _
) As Integer

Parameters

lpPerformanceCount
Required.

Source code

[Visual Basic]
    Private Declare Function QueryPerformanceCounter Lib "kernel32" (ByRef lpPerformanceCount As clsXTimer.LARGE_INTEGER) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.QueryPerformanceFrequency Method

Private Declare Function QueryPerformanceFrequency Lib "kernel32" ( _
   ByRef lpFrequency As clsXTimer.LARGE_INTEGER _
) As Integer

Parameters

lpFrequency
Required.

Source code

[Visual Basic]
    Private Declare Function QueryPerformanceFrequency Lib "kernel32" (ByRef lpFrequency As clsXTimer.LARGE_INTEGER) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.StartTimer Method

Public Sub StartTimer()

Source code

[Visual Basic]
    Public Sub StartTimer()
        Call QueryPerformanceCounter(m_liStart)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.StopTimer Method

Public Sub StopTimer()

Source code

[Visual Basic]
    Public Sub StopTimer()
        Call QueryPerformanceCounter(m_liEnd)
        MsgBox("Verstichene Zeit=" & Format(RunTime, "0.00 ms"))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer.Stop_nd_GetTime Method

Public Function Stop_nd_GetTime() As String

Source code

[Visual Basic]
    Public Function Stop_nd_GetTime() As String
        Call QueryPerformanceCounter(m_liEnd)
        Return Format(RunTime, "0.00 ms")
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


clsXTimer Fields

clsXTimer overview

Fields

field m_dblCalibr
field m_liEnd
field m_liFreq
field m_liStart

See Also

clsXTimer Class


m_dblCalibr Variable

Private m_dblCalibr As Double

Source code

[Visual Basic]
    Private m_dblCalibr As Double

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


m_liEnd Variable

Private m_liEnd As clsXTimer.LARGE_INTEGER

Source code

[Visual Basic]
    Private m_liEnd As clsXTimer.LARGE_INTEGER

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


m_liFreq Variable

Private m_liFreq As clsXTimer.LARGE_INTEGER

Source code

[Visual Basic]
    Private m_liFreq As clsXTimer.LARGE_INTEGER

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


m_liStart Variable

Private m_liStart As clsXTimer.LARGE_INTEGER

Source code

[Visual Basic]
    Private m_liStart As clsXTimer.LARGE_INTEGER

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsXTimer


frmAMSOfficeVorlage Class

For a list of all members of this type, see frmAMSOfficeVorlage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmAMSOfficeVorlage

Public Class frmAMSOfficeVorlage
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmAMSOfficeVorlage Members


frmAMSOfficeVorlage Members

frmAMSOfficeVorlage overview

Constructors

constructor frmAMSOfficeVorlage Constructor

Properties

property Dokumenttypnr
property Vorlagenfleder

Methods

method Button1_Click
method Dispose
method Generic_Select
method InitializeComponent
method Inser_Vorlagenfelder
method btnAbbruch_Click
method btnImport_Click
method frmAMSOfficeVorlage_Load

Fields

field Button1
field ComboBox1
field Dokumentvorlagen
field Label1
field amsvorlagenr
field btnAbbruch
field btnImport
field components
field doktyp
field doktypnr
field m_dokumenttypnr
field m_vorlagenfelder
field mcbvorlagen

See Also

frmAMSOfficeVorlage Class


frmAMSOfficeVorlage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage Properties

frmAMSOfficeVorlage overview

Properties

property Dokumenttypnr
property Vorlagenfleder

See Also

frmAMSOfficeVorlage Class


frmAMSOfficeVorlage.Dokumenttypnr Property

Property Dokumenttypnr() As Integer

Source code

[Visual Basic]
    Property Dokumenttypnr() As Integer
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.Vorlagenfleder Property

Property Vorlagenfleder() As DataTable

Source code

[Visual Basic]
    Property Vorlagenfleder() As DataTable
        Get
            Return m_vorlagenfelder
        End Get
        Set(ByVal Value As DataTable)
            m_vorlagenfelder = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage Methods

frmAMSOfficeVorlage overview

Methods

method Button1_Click
method Dispose
method Generic_Select
method InitializeComponent
method Inser_Vorlagenfelder
method btnAbbruch_Click
method btnImport_Click
method frmAMSOfficeVorlage_Load

See Also

frmAMSOfficeVorlage Class


frmAMSOfficeVorlage.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

        Dim i As Integer
        Dim zwdata As DataTable
        Dokumentvorlagen = Generic_Select(4)
        doktyp.cpMainConnectionProvider = conn
        For i = 0 To Dokumentvorlagen.Rows.Count - 1
            doktyp.iDokumenttypnr = New SqlInt32(CType(Dokumentvorlagen.Rows(i).Item("edoka_dokumenttypnr"), Int32))
            zwdata = doktyp.SelectOne
            If zwdata.Rows.Count = 0 Then
                MsgBox("Kein EDOKA-Dokumenttyp für AMS_Office_Vorlage:" + Str(Dokumentvorlagen.Rows(i).Item("AMS_Vorlagenr")))
            Else
                Me.amsvorlagenr = Dokumentvorlagen.Rows(i).Item("ams_vorlagenr")
                Me.doktypnr = doktyp.iDokumenttypnr.Value
                Inser_Vorlagenfelder()

            End If
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_AMS_OfficeVorlage"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_AMS_OfficeVorlage"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_AMS_Vorlagenfelder"
            Case 4
                scmCmdToExecute.CommandText = "dbo.sp_ams_edoka"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Select Case typ
            Case 1
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Case 2
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@officevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbvorlagen.SelectedValue))
            Case 3
                scmCmdToExecute.Parameters.Add(New SqlParameter("@officevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.amsvorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.doktypnr))
            Case Else
        End Select

        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("SP_AMS_OfficeVoralgen::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnImport = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(112, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "AMS-Officevorlagen"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(120, 24)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(328, 21)
        Me.ComboBox1.TabIndex = 1
        Me.ComboBox1.Text = "ComboBox1"
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(8, 80)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 2
        Me.btnAbbruch.Text = "Abbruch"
        '
        'btnImport
        '
        Me.btnImport.Location = New System.Drawing.Point(296, 80)
        Me.btnImport.Name = "btnImport"
        Me.btnImport.Size = New System.Drawing.Size(152, 23)
        Me.btnImport.TabIndex = 3
        Me.btnImport.Text = "Vorlagenfelder improtieren"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(136, 80)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 4
        Me.Button1.Text = "Alle AMS-Vorlagen generieren"
        '
        'frmAMSOfficeVorlage
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(472, 109)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.btnImport, Me.btnAbbruch, Me.ComboBox1, Me.Label1})
        Me.Name = "frmAMSOfficeVorlage"
        Me.Text = "frmAMSOfficeVorlage"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.Inser_Vorlagenfelder Method

Private Sub Inser_Vorlagenfelder()

Source code

[Visual Basic]
    Private Sub Inser_Vorlagenfelder()
        Dim data As DataTable
        Dim vr As New edokadb.clsVorlagenfeld()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        Dim i As Integer
        data = Generic_Select(3)
        dbkey.cpMainConnectionProvider = conn
        Try
            For i = 0 To data.Rows.Count - 1
                key = dbkey.get_dbkey("vorlagenfeld")
                vr.iVorlagenfeldnr = New SqlInt32(CType(key, Int32))
                vr.iDokumenttypnr = New SqlInt32(CType(Me.doktypnr, Int32))
                vr.iVorlagenfeldregelnr = New SqlInt32(CType(data.Rows(i).Item("edoka_vorlagenfeldregelnr"), Int32))
                vr.sFeldname = New SqlString(CType(data.Rows(i).Item("office_feld"), String))
                vr.sBeginntextmarke = New SqlString(CType(data.Rows(i).Item("beginntextmarke"), String))
                vr.sEndetextmarke = New SqlString(CType(data.Rows(i).Item("endetextmarke"), String))
                vr.bAusstiegsmakro = New SqlBoolean(CType(data.Rows(i).Item("ausstiegsmakro"), Boolean))
                vr.bEinstiegsmakro = New SqlBoolean(CType(data.Rows(i).Item("einstiegsmakro"), Boolean))
                vr.bAktiv = New SqlBoolean(CType(data.Rows(i).Item("aktiv"), Boolean))
                vr.sTestdaten = New SqlString(CType("", String))
                vr.iMandantnr = New SqlInt32(CType(1, Int32))
                vr.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                vr.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
                vr.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
                vr.cpMainConnectionProvider = conn
                conn.OpenConnection()
                Try
                    vr.Insert()
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try
                conn.CloseConnection(True)
            Next
            vr.Dispose()
            data.Dispose()
            dbkey.Dispose()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

        Me.Close()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.DialogResult = DialogResult.Cancel
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.btnImport_Click Method

Private Sub btnImport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnImport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnImport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnImport.Click
        Me.doktypnr = Me.Dokumenttypnr
        Me.amsvorlagenr = Me.mcbvorlagen.SelectedValue
        Inser_Vorlagenfelder()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage.frmAMSOfficeVorlage_Load Method

Private Sub frmAMSOfficeVorlage_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmAMSOfficeVorlage_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbvorlagen = New MultiComboBox(Me.ComboBox1)
        mcbvorlagen.DisplayColumnName = "bezeichnung"
        mcbvorlagen.ValueColumnName = "officevorlagenr"
        mcbvorlagen.Fill_Data(Generic_Select(1), False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAMSOfficeVorlage Fields

frmAMSOfficeVorlage overview

Fields

field Button1
field ComboBox1
field Dokumentvorlagen
field Label1
field amsvorlagenr
field btnAbbruch
field btnImport
field components
field doktyp
field doktypnr
field m_dokumenttypnr
field m_vorlagenfelder
field mcbvorlagen

See Also

frmAMSOfficeVorlage Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


Dokumentvorlagen Variable

Dim Dokumentvorlagen As New DataTable()

Source code

[Visual Basic]
    Dim Dokumentvorlagen As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


amsvorlagenr Variable

Dim amsvorlagenr As Integer = 0

Source code

[Visual Basic]
    Dim amsvorlagenr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


btnImport Variable

Friend WithEvents btnImport As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnImport As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


doktyp Variable

Dim doktyp As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim doktyp As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


doktypnr Variable

Dim doktypnr As Integer = 0

Source code

[Visual Basic]
    Dim doktypnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Integer

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


m_vorlagenfelder Variable

Dim m_vorlagenfelder As DataTable

Source code

[Visual Basic]
    Dim m_vorlagenfelder As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


mcbvorlagen Variable

Dim mcbvorlagen As New MultiComboBox()

Source code

[Visual Basic]
    Dim mcbvorlagen As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAMSOfficeVorlage


frmAbout Class

For a list of all members of this type, see frmAbout Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmAbout

Public Class frmAbout
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmAbout Members


frmAbout Members

frmAbout overview

Constructors

constructor frmAbout Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method frmAbout_Load

Fields

field Button1
field Label1
field Label2
field Label3
field PictureBox1
field components

See Also

frmAbout Class


frmAbout Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAbout Methods

frmAbout overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method frmAbout_Load

See Also

frmAbout Class


frmAbout.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAbout.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAbout.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmAbout))
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Label2
        '
        Me.Label2.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label2.Location = New System.Drawing.Point(104, 220)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(136, 16)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "© 2003 - TKB Weinfelden"
        '
        'Label1
        '
        Me.Label1.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label1.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label1.Location = New System.Drawing.Point(88, 153)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(160, 24)
        Me.Label1.TabIndex = 4
        Me.Label1.Text = "Version 1.2"
        Me.Label1.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'PictureBox1
        '
        Me.PictureBox1.BackColor = System.Drawing.SystemColors.ControlText
        Me.PictureBox1.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(528, 320)
        Me.PictureBox1.TabIndex = 3
        Me.PictureBox1.TabStop = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(232, 336)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(88, 24)
        Me.Button1.TabIndex = 6
        Me.Button1.Text = "&Schliessen"
        '
        'Label3
        '
        Me.Label3.BackColor = System.Drawing.SystemColors.ActiveCaptionText
        Me.Label3.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label3.Location = New System.Drawing.Point(88, 176)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(160, 24)
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "6. Oktober 2003"
        Me.Label3.TextAlign = System.Drawing.ContentAlignment.TopCenter
        '
        'frmAbout
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(528, 365)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.Button1, Me.Label2, Me.Label1, Me.PictureBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmAbout"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Über EDOKA"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAbout.frmAbout_Load Method

Private Sub frmAbout_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmAbout_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Label1.Text = "Version " & Globals.Version
        Label3.Text = Globals.versionsdatum
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAbout Fields

frmAbout overview

Fields

field Button1
field Label1
field Label2
field Label3
field PictureBox1
field components

See Also

frmAbout Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAbout


frmAdminMitarbeiter Class

For a list of all members of this type, see frmAdminMitarbeiter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmAdminMitarbeiter

Public Class frmAdminMitarbeiter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmAdminMitarbeiter Members


frmAdminMitarbeiter Members

frmAdminMitarbeiter overview

Constructors

constructor frmAdminMitarbeiter Constructor

Methods

method Dispose |
method FunktionsGruppenSelectedChanged | Lädt alle Mitarbeiter zu der ausgewählten FunktionsGruppe
method InitializeComponent |
method TeamSelectedChanged | Lädt alle Mitarbeiter zum ausgewählten Team
method cmdAlleAnzeigen_Click |
method cmdEdit_Click |
method cmdNew_Click |
method frmAdminMitarbeiter_Load |
method grdFunktionsgruppen_Click |
method grdFunktionsgruppen_RowColChange |
method grdMitarbeiter_DoubleClick |
method grdMitarbeiter_RowColChange |
method grdTeams_Click |
method grdTeams_RowColChange |
method tbMenu_ButtonClick |

Fields

field ImageList1
field Label1
field Label2
field Label3
field Label4
field cmdAlleAnzeigen
field cmdClose
field cmdEdit
field cmdNew
field components
field grdFunktionsgruppen
field grdMitarbeiter
field grdTeams
field pnlBottom
field pnlLeft
field pnlRight
field pnlTop
field sptHorizontal
field sptVertikal
field tbMenu

See Also

frmAdminMitarbeiter Class


frmAdminMitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter Methods

frmAdminMitarbeiter overview

Methods

method Dispose |
method FunktionsGruppenSelectedChanged | Lädt alle Mitarbeiter zu der ausgewählten FunktionsGruppe
method InitializeComponent |
method TeamSelectedChanged | Lädt alle Mitarbeiter zum ausgewählten Team
method cmdAlleAnzeigen_Click |
method cmdEdit_Click |
method cmdNew_Click |
method frmAdminMitarbeiter_Load |
method grdFunktionsgruppen_Click |
method grdFunktionsgruppen_RowColChange |
method grdMitarbeiter_DoubleClick |
method grdMitarbeiter_RowColChange |
method grdTeams_Click |
method grdTeams_RowColChange |
method tbMenu_ButtonClick |

See Also

frmAdminMitarbeiter Class


frmAdminMitarbeiter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.FunktionsGruppenSelectedChanged Method

Lädt alle Mitarbeiter zu der ausgewählten FunktionsGruppe

Private Function FunktionsGruppenSelectedChanged()

Source code

[Visual Basic]
    Private Function FunktionsGruppenSelectedChanged()
        Try
            If grdFunktionsgruppen.Splits(0).Rows.Count = 0 Then
                Return 1
            End If

            'alle teams zu selektiertem mitarbeiter laden
            Dim itemNr As Integer
            itemNr = grdFunktionsgruppen.Columns("funktionsgruppenr").Value

            Dim ds As New DataSet()
            BusinessFacade.Mitarbeiter.GetListeByFunktionsGruppeNr(itemNr, ds)
            grdMitarbeiter.DataSource = ds.Tables(0)
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter", grdMitarbeiter)

            'keine teams anzeigen
            grdTeams.DataSource = Nothing
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmAdminMitarbeiter))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.sptHorizontal = New System.Windows.Forms.Splitter()
        Me.pnlTop = New System.Windows.Forms.Panel()
        Me.cmdAlleAnzeigen = New System.Windows.Forms.Button()
        Me.cmdNew = New System.Windows.Forms.Button()
        Me.cmdEdit = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.grdMitarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.pnlBottom = New System.Windows.Forms.Panel()
        Me.pnlRight = New System.Windows.Forms.Panel()
        Me.grdFunktionsgruppen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.sptVertikal = New System.Windows.Forms.Splitter()
        Me.pnlLeft = New System.Windows.Forms.Panel()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.grdTeams = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.tbMenu = New System.Windows.Forms.ToolBar()
        Me.cmdClose = New System.Windows.Forms.ToolBarButton()
        Me.pnlTop.SuspendLayout()
        CType(Me.grdMitarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlBottom.SuspendLayout()
        Me.pnlRight.SuspendLayout()
        CType(Me.grdFunktionsgruppen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlLeft.SuspendLayout()
        CType(Me.grdTeams, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'sptHorizontal
        '
        Me.sptHorizontal.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.sptHorizontal.Cursor = System.Windows.Forms.Cursors.HSplit
        Me.sptHorizontal.Dock = System.Windows.Forms.DockStyle.Top
        Me.sptHorizontal.Location = New System.Drawing.Point(0, 472)
        Me.sptHorizontal.Name = "sptHorizontal"
        Me.sptHorizontal.Size = New System.Drawing.Size(656, 3)
        Me.sptHorizontal.TabIndex = 10
        Me.sptHorizontal.TabStop = False
        '
        'pnlTop
        '
        Me.pnlTop.Controls.AddRange(New System.Windows.Forms.Control() {Me.tbMenu, Me.cmdAlleAnzeigen, Me.cmdNew, Me.cmdEdit, Me.Label1, Me.grdMitarbeiter, Me.Label2})
        Me.pnlTop.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlTop.Name = "pnlTop"
        Me.pnlTop.Size = New System.Drawing.Size(656, 472)
        Me.pnlTop.TabIndex = 13
        '
        'cmdAlleAnzeigen
        '
        Me.cmdAlleAnzeigen.Anchor = (System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Left)
        Me.cmdAlleAnzeigen.Location = New System.Drawing.Point(24, 440)
        Me.cmdAlleAnzeigen.Name = "cmdAlleAnzeigen"
        Me.cmdAlleAnzeigen.Size = New System.Drawing.Size(152, 23)
        Me.cmdAlleAnzeigen.TabIndex = 5
        Me.cmdAlleAnzeigen.Text = "Alle Mitarbeiter anzeigen"
        '
        'cmdNew
        '
        Me.cmdNew.Anchor = (System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Right)
        Me.cmdNew.Location = New System.Drawing.Point(552, 440)
        Me.cmdNew.Name = "cmdNew"
        Me.cmdNew.Size = New System.Drawing.Size(88, 23)
        Me.cmdNew.TabIndex = 3
        Me.cmdNew.Text = "&Neu..."
        '
        'cmdEdit
        '
        Me.cmdEdit.Anchor = (System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Right)
        Me.cmdEdit.Location = New System.Drawing.Point(456, 440)
        Me.cmdEdit.Name = "cmdEdit"
        Me.cmdEdit.Size = New System.Drawing.Size(88, 23)
        Me.cmdEdit.TabIndex = 2
        Me.cmdEdit.Text = "&Bearbeiten..."
        '
        'Label1
        '
        Me.Label1.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(248, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Mitarbeiterverwaltung"
        '
        'grdMitarbeiter
        '
        Me.grdMitarbeiter.AllowFilter = True
        Me.grdMitarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdMitarbeiter.AllowSort = True
        Me.grdMitarbeiter.AllowUpdate = False
        Me.grdMitarbeiter.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdMitarbeiter.CaptionHeight = 17
        Me.grdMitarbeiter.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdMitarbeiter.CollapseColor = System.Drawing.Color.Black
        Me.grdMitarbeiter.DataChanged = False
        Me.grdMitarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdMitarbeiter.ExpandColor = System.Drawing.Color.Black
        Me.grdMitarbeiter.FilterBar = True
        Me.grdMitarbeiter.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdMitarbeiter.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.grdMitarbeiter.Location = New System.Drawing.Point(24, 104)
        Me.grdMitarbeiter.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdMitarbeiter.Name = "grdMitarbeiter"
        Me.grdMitarbeiter.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdMitarbeiter.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdMitarbeiter.PreviewInfo.ZoomFactor = 75
        Me.grdMitarbeiter.PrintInfo.ShowOptionsDialog = False
        Me.grdMitarbeiter.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdMitarbeiter.RowDivider = GridLines1
        Me.grdMitarbeiter.RowHeight = 15
        Me.grdMitarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdMitarbeiter.ScrollTips = False
        Me.grdMitarbeiter.Size = New System.Drawing.Size(616, 328)
        Me.grdMitarbeiter.TabIndex = 0
        Me.grdMitarbeiter.Text = "C1TrueDBGrid1"
        Me.grdMitarbeiter.WrapCellPointer = True
        Me.grdMitarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:Co" & _
        "ntrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 612, 324</Cl" & _
        "ientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" />" & _
        "<EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""St" & _
        "yle8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""F" & _
        "ooter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle par" & _
        "ent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7""" & _
        " /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" m" & _
        "e=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Select" & _
        "edStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C" & _
        "1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" " & _
        "/><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><S" & _
        "tyle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><St" & _
        "yle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style " & _
        "parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style" & _
        " parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><St" & _
        "yle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Name" & _
        "dStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout" & _
        "><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 612, 324</ClientAr" & _
        "ea></Blob>"
        '
        'Label2
        '
        Me.Label2.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.Label2.Location = New System.Drawing.Point(24, 64)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(608, 32)
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Auf dieser Übersicht sind alle Mitarbeiter zu sehen. Über die Schaltflächen ""Neu." & _
        "."" und ""Bearbeiten..."" können Sie neue Benutzer erfassen, bzw bestehende editier" & _
        "en."
        '
        'pnlBottom
        '
        Me.pnlBottom.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlRight, Me.sptVertikal, Me.pnlLeft})
        Me.pnlBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlBottom.Location = New System.Drawing.Point(0, 472)
        Me.pnlBottom.Name = "pnlBottom"
        Me.pnlBottom.Size = New System.Drawing.Size(656, 110)
        Me.pnlBottom.TabIndex = 14
        '
        'pnlRight
        '
        Me.pnlRight.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdFunktionsgruppen, Me.Label4})
        Me.pnlRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlRight.Location = New System.Drawing.Point(491, 0)
        Me.pnlRight.Name = "pnlRight"
        Me.pnlRight.Size = New System.Drawing.Size(165, 110)
        Me.pnlRight.TabIndex = 2
        '
        'grdFunktionsgruppen
        '
        Me.grdFunktionsgruppen.AllowFilter = True
        Me.grdFunktionsgruppen.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdFunktionsgruppen.AllowSort = True
        Me.grdFunktionsgruppen.AllowUpdate = False
        Me.grdFunktionsgruppen.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdFunktionsgruppen.CaptionHeight = 17
        Me.grdFunktionsgruppen.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdFunktionsgruppen.CollapseColor = System.Drawing.Color.Black
        Me.grdFunktionsgruppen.DataChanged = False
        Me.grdFunktionsgruppen.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdFunktionsgruppen.ExpandColor = System.Drawing.Color.Black
        Me.grdFunktionsgruppen.FilterBar = True
        Me.grdFunktionsgruppen.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdFunktionsgruppen.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.grdFunktionsgruppen.Location = New System.Drawing.Point(8, 40)
        Me.grdFunktionsgruppen.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdFunktionsgruppen.Name = "grdFunktionsgruppen"
        Me.grdFunktionsgruppen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdFunktionsgruppen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdFunktionsgruppen.PreviewInfo.ZoomFactor = 75
        Me.grdFunktionsgruppen.PrintInfo.ShowOptionsDialog = False
        Me.grdFunktionsgruppen.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdFunktionsgruppen.RowDivider = GridLines2
        Me.grdFunktionsgruppen.RowHeight = 15
        Me.grdFunktionsgruppen.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdFunktionsgruppen.ScrollTips = False
        Me.grdFunktionsgruppen.Size = New System.Drawing.Size(149, 54)
        Me.grdFunktionsgruppen.TabIndex = 4
        Me.grdFunktionsgruppen.Text = "C1TrueDBGrid1"
        Me.grdFunktionsgruppen.WrapCellPointer = True
        Me.grdFunktionsgruppen.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:Co" & _
        "ntrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 145, 50</Cli" & _
        "entRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><" & _
        "EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Sty" & _
        "le8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Fo" & _
        "oter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle pare" & _
        "nt=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" " & _
        "/><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me" & _
        "=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selecte" & _
        "dStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1" & _
        ".Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /" & _
        "><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><St" & _
        "yle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Sty" & _
        "le parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style p" & _
        "arent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style " & _
        "parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Sty" & _
        "le parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Named" & _
        "Styles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout>" & _
        "<DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 145, 50</ClientArea" & _
        "></Blob>"
        '
        'Label4
        '
        Me.Label4.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label4.Location = New System.Drawing.Point(8, 8)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(280, 23)
        Me.Label4.TabIndex = 3
        Me.Label4.Text = "Zugewiesene Funktionsgruppen"
        '
        'sptVertikal
        '
        Me.sptVertikal.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.sptVertikal.Location = New System.Drawing.Point(488, 0)
        Me.sptVertikal.Name = "sptVertikal"
        Me.sptVertikal.Size = New System.Drawing.Size(3, 110)
        Me.sptVertikal.TabIndex = 1
        Me.sptVertikal.TabStop = False
        '
        'pnlLeft
        '
        Me.pnlLeft.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.grdTeams})
        Me.pnlLeft.Dock = System.Windows.Forms.DockStyle.Left
        Me.pnlLeft.Name = "pnlLeft"
        Me.pnlLeft.Size = New System.Drawing.Size(488, 110)
        Me.pnlLeft.TabIndex = 0
        '
        'Label3
        '
        Me.Label3.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label3.Location = New System.Drawing.Point(8, 8)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(248, 23)
        Me.Label3.TabIndex = 2
        Me.Label3.Text = "Zugewiesene Teams"
        '
        'grdTeams
        '
        Me.grdTeams.AllowFilter = True
        Me.grdTeams.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdTeams.AllowSort = True
        Me.grdTeams.AllowUpdate = False
        Me.grdTeams.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdTeams.CaptionHeight = 17
        Me.grdTeams.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdTeams.CollapseColor = System.Drawing.Color.Black
        Me.grdTeams.DataChanged = False
        Me.grdTeams.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdTeams.ExpandColor = System.Drawing.Color.Black
        Me.grdTeams.FilterBar = True
        Me.grdTeams.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdTeams.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.grdTeams.Location = New System.Drawing.Point(24, 40)
        Me.grdTeams.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdTeams.Name = "grdTeams"
        Me.grdTeams.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdTeams.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdTeams.PreviewInfo.ZoomFactor = 75
        Me.grdTeams.PrintInfo.ShowOptionsDialog = False
        Me.grdTeams.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdTeams.RowDivider = GridLines3
        Me.grdTeams.RowHeight = 15
        Me.grdTeams.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdTeams.ScrollTips = False
        Me.grdTeams.Size = New System.Drawing.Size(448, 54)
        Me.grdTeams.TabIndex = 1
        Me.grdTeams.Text = "C1TrueDBGrid1"
        Me.grdTeams.WrapCellPointer = True
        Me.grdTeams.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 444, 50</Cli" & _
        "entRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><" & _
        "EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Sty" & _
        "le8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Fo" & _
        "oter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle pare" & _
        "nt=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" " & _
        "/><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me" & _
        "=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selecte" & _
        "dStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1" & _
        ".Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /" & _
        "><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><St" & _
        "yle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Sty" & _
        "le parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style p" & _
        "arent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style " & _
        "parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Sty" & _
        "le parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Named" & _
        "Styles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout>" & _
        "<DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 444, 50</ClientArea" & _
        "></Blob>"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'tbMenu
        '
        Me.tbMenu.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.tbMenu.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.cmdClose})
        Me.tbMenu.Dock = System.Windows.Forms.DockStyle.None
        Me.tbMenu.DropDownArrows = True
        Me.tbMenu.ImageList = Me.ImageList1
        Me.tbMenu.Name = "tbMenu"
        Me.tbMenu.ShowToolTips = True
        Me.tbMenu.Size = New System.Drawing.Size(648, 25)
        Me.tbMenu.TabIndex = 15
        '
        'cmdClose
        '
        Me.cmdClose.ImageIndex = 0
        Me.cmdClose.Tag = "close"
        '
        'frmAdminMitarbeiter
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(656, 582)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.sptHorizontal, Me.pnlBottom, Me.pnlTop})
        Me.Name = "frmAdminMitarbeiter"
        Me.Text = "frmAdminMitarbeiter"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        Me.pnlTop.ResumeLayout(False)
        CType(Me.grdMitarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlBottom.ResumeLayout(False)
        Me.pnlRight.ResumeLayout(False)
        CType(Me.grdFunktionsgruppen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlLeft.ResumeLayout(False)
        CType(Me.grdTeams, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.TeamSelectedChanged Method

Lädt alle Mitarbeiter zum ausgewählten Team

Private Function TeamSelectedChanged()

Source code

[Visual Basic]
    Private Function TeamSelectedChanged()
        Try
            If grdTeams.Splits(0).Rows.Count = 0 Then
                Return 1
            End If

            'alle teams zu selektiertem mitarbeiter laden
            Dim itemNr As Integer
            itemNr = grdTeams.Columns("teamnr").Value

            Dim ds As New DataSet()
            BusinessFacade.Mitarbeiter.GetListeByTeamNr(itemNr, ds)
            grdMitarbeiter.DataSource = ds.Tables(0)
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter", grdMitarbeiter)

            'keine funktionsgruppe anzeigen
            grdFunktionsgruppen.DataSource = Nothing
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.cmdAlleAnzeigen_Click Method

Private Sub cmdAlleAnzeigen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdAlleAnzeigen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdAlleAnzeigen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdAlleAnzeigen.Click
        Try
            'wieder alle mitarbeiter anzeigen
            Dim ds As New DataSet()
            BusinessFacade.Mitarbeiter.GetListe(ds)
            grdMitarbeiter.DataSource = ds.Tables(0)

            'Spalten Definitionen laden
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter", grdMitarbeiter)

            grdMitarbeiter.Columns("aktiv").FilterText = "True"
            grdMitarbeiter.FilterActive = True
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.cmdAlleAnzeigen_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.cmdEdit_Click Method

Private Sub cmdEdit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdEdit.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdEdit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdEdit.Click
        Try
            If grdMitarbeiter.Splits(0).Rows.Count = 0 Then
                Return
            End If

            Dim mitarbeiterNr As Integer
            mitarbeiterNr = grdMitarbeiter.Columns("mitarbeiternr").Value

            Dim mitarbeiterEditWindow As New frmAdminMitarbeiterEdit(mitarbeiterNr)

            mitarbeiterEditWindow.MdiParent = Me.ParentForm
            mitarbeiterEditWindow.WindowState = FormWindowState.Normal
            mitarbeiterEditWindow.Show()

            cmdAlleAnzeigen_Click(Nothing, Nothing)
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(304), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.cmdEdit_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.cmdNew_Click Method

Private Sub cmdNew_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdNew.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdNew.Click
        Try
            Dim mitarbeiterEditWindow As New frmAdminMitarbeiterEdit()

            mitarbeiterEditWindow.MdiParent = Me.ParentForm
            mitarbeiterEditWindow.WindowState = FormWindowState.Normal
            mitarbeiterEditWindow.Show()

            cmdAlleAnzeigen_Click(Nothing, Nothing)

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(304), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.cmdNew_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.frmAdminMitarbeiter_Load Method

Private Sub frmAdminMitarbeiter_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmAdminMitarbeiter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try

            'Alle Mitarbeiter laden
            Dim dsMitarbeiter As New DataSet()
            BusinessFacade.Mitarbeiter.GetListe(dsMitarbeiter)
            grdMitarbeiter.DataSource = dsMitarbeiter.Tables(0)

            cmdAlleAnzeigen_Click(Nothing, Nothing)

            'Spalten Definitionen laden
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter", grdMitarbeiter)
            BusinessFacade.Spalten.FillGridColumns("teammitarbeiter", grdTeams)
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter_funktionsgruppe", grdFunktionsgruppen)

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(300), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.frmAdminMitarbeiter_Load: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdFunktionsgruppen_Click Method

Private Sub grdFunktionsgruppen_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles grdFunktionsgruppen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdFunktionsgruppen_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles grdFunktionsgruppen.Click
        Try
            FunktionsGruppenSelectedChanged()
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdFunktionsgruppen_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdFunktionsgruppen_RowColChange Method

Private Sub grdFunktionsgruppen_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdFunktionsgruppen.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdFunktionsgruppen_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdFunktionsgruppen.RowColChange
        Try
            'nur ausführen wenn die row geändert wird
            If e.LastRow <> grdFunktionsgruppen.Bookmark Then
                FunktionsGruppenSelectedChanged()
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdFunktionsgruppen_RowColChange: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdMitarbeiter_DoubleClick Method

Private Sub grdMitarbeiter_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles grdMitarbeiter.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdMitarbeiter_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles grdMitarbeiter.DoubleClick
        Try
            cmdEdit_Click(Nothing, Nothing)
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(304), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdMitarbeiter_DoubleClick: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdMitarbeiter_RowColChange Method

Private Sub grdMitarbeiter_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdMitarbeiter.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdMitarbeiter_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdMitarbeiter.RowColChange
        Try
            'nur ausführen wenn die row geändert wird
            If e.LastRow <> grdMitarbeiter.Bookmark Then
                If grdMitarbeiter.Splits(0).Rows.Count = 0 Then
                    Return
                End If

                'alle teams zu selektiertem mitarbeiter laden
                Dim itemNr As Integer
                itemNr = grdMitarbeiter.Columns("mitarbeiternr").Value

                'gefilterte teams anzeigen
                Dim dsTeams As New DataSet()
                BusinessFacade.TeamMitarbeiter.GetListe(itemNr, dsTeams)
                grdTeams.DataSource = dsTeams.Tables(0)
                BusinessFacade.Spalten.FillGridColumns("teammitarbeiter", grdTeams)

                'gefilterte funktionsgruppen anzeigen
                Dim dsFunktionsGruppen As New DataSet()
                BusinessFacade.MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr(itemNr, dsFunktionsGruppen)
                grdFunktionsgruppen.DataSource = dsFunktionsGruppen.Tables(0)
                BusinessFacade.Spalten.FillGridColumns("mitarbeiter_funktionsgruppe", grdFunktionsgruppen)

            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdMitarbeiter_RowColChange: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdTeams_Click Method

Private Sub grdTeams_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles grdTeams.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdTeams_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles grdTeams.Click
        Try
            TeamSelectedChanged()
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdTeams_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.grdTeams_RowColChange Method

Private Sub grdTeams_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdTeams.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdTeams_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdTeams.RowColChange
        Try
            'nur ausführen wenn die row geändert wird
            If e.LastRow <> grdTeams.Bookmark Then
                TeamSelectedChanged()
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.grdTeams_RowColChange: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter.tbMenu_ButtonClick Method

Private Sub tbMenu_ButtonClick( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles tbMenu.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tbMenu_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbMenu.ButtonClick
        Try
            Close()
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(300), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiter.tbMenu_ButtonClick: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiter Fields

frmAdminMitarbeiter overview

Fields

field ImageList1
field Label1
field Label2
field Label3
field Label4
field cmdAlleAnzeigen
field cmdClose
field cmdEdit
field cmdNew
field components
field grdFunktionsgruppen
field grdMitarbeiter
field grdTeams
field pnlBottom
field pnlLeft
field pnlRight
field pnlTop
field sptHorizontal
field sptVertikal
field tbMenu

See Also

frmAdminMitarbeiter Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


cmdAlleAnzeigen Variable

Friend WithEvents cmdAlleAnzeigen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdAlleAnzeigen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


cmdClose Variable

Friend WithEvents cmdClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents cmdClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


cmdEdit Variable

Friend WithEvents cmdEdit As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdEdit As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


cmdNew Variable

Friend WithEvents cmdNew As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdNew As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


grdFunktionsgruppen Variable

Friend WithEvents grdFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


grdMitarbeiter Variable

Friend WithEvents grdMitarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdMitarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


grdTeams Variable

Friend WithEvents grdTeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdTeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


pnlBottom Variable

Friend WithEvents pnlBottom As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlBottom As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


pnlLeft Variable

Friend WithEvents pnlLeft As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlLeft As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


pnlRight Variable

Friend WithEvents pnlRight As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlRight As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


pnlTop Variable

Friend WithEvents pnlTop As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlTop As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


sptHorizontal Variable

Friend WithEvents sptHorizontal As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents sptHorizontal As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


sptVertikal Variable

Friend WithEvents sptVertikal As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents sptVertikal As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


tbMenu Variable

Friend WithEvents tbMenu As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents tbMenu As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiter


frmAdminMitarbeiterEdit Class

For a list of all members of this type, see frmAdminMitarbeiterEdit Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmAdminMitarbeiterEdit

Public Class frmAdminMitarbeiterEdit
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmAdminMitarbeiterEdit Members


frmAdminMitarbeiterEdit Members

frmAdminMitarbeiterEdit overview

Constructors

constructor frmAdminMitarbeiterEdit Constructor (Overloaded) Ertellt eine Formularinstanz um einen neuen Mitarbeiter zu erfassen

Methods

method Dispose |
method GetFunktionsGruppeItemIndex | Gibt den Index einer Mitarbeiter-Funktionsgruppen Zuordnung aus dem grid zurück
method GetTeamItemIndex | Gibt den Index einer Mitarbeiter-Team zuordnung aus dem grid zurück
method InitializeComponent |
method LoadDetail | Lädt allle Infos zu einem Mitarbeiter
method OnClosing |
method OnKeyDown |
method SaveData | Speichert allle Infos zu einem Mitarbeiter
method cboKlassifizierung_SelectedValueChanged |
method cmdCreateStandardProfil_Click |
method cmdEntfernenFunktionsgruppen_Click |
method cmdSaveTeamMitarbeiter_Click |
method cmdTeamConnect_Click |
method cmdTeamDisconnect_Click |
method cmdZuordnenFunktionsgruppen_Click |
method ctxAktivSetzen_Popup |
method frmAdminMitarbeiterEdit_Load |
method grdMAFunktionsgruppen_MouseDown |
method grdMATeams_MouseDown |
method grdMATeams_RowColChange |
method mnuAktivieren_Click |
method mnuDeaktivieren_Click |
method tbMenu_ButtonClick |
method tcMenu_SelectedIndexChanged |

Fields

field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label29
field Label3
field Label30
field Label31
field Label34
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field _currentGridName
field _dataChanged
field _dsMaFunktionsgruppen
field _dsMaTeams
field _mitarbeiter
field _tmpTeamNr
field cboFuerMandant
field cboKlassifizierung
field cboMandant
field cboSprache
field chkEdokaMail
field chkEdokaMessage
field chkGebMeldung
field chkIsActive
field chkJournalisierung
field chkMailDirektVersenden
field chkMailDokumentRueckgang
field chkMailEmpfang
field chkShowToolTip
field cmdClose
field cmdCreateStandardProfil
field cmdSave
field cmdSaveTeamMitarbeiter
field cmdTeamConnect
field cmdZuordnenFunktionsgruppen
field components
field ctxAktivSetzen
field grdAlleFunktionsgruppen
field grdAlleTeams
field grdMAFunktionsgruppen
field grdMATeams
field lblBearbeitet
field lblErstellt
field lblMitarbeiterNr
field lblTeamName
field mnuAktivieren
field mnuDeaktivieren
field tabAllgemein
field tabErweitert
field tabFunktionen
field tabTeams
field tbMenu
field tcMenu
field txtAnrede
field txtAnteil
field txtFax
field txtFunktion
field txtKurzzeichen
field txtMail1
field txtNachname
field txtPartnerNr
field txtRang
field txtTGNummer
field txtTelefon
field txtUnterschriftText
field txtVorname
field txteMail

See Also

frmAdminMitarbeiterEdit Class


New

Overload List

Ertellt eine Formularinstanz um einen neuen Mitarbeiter zu erfassen

[Visual Basic] Public Sub New()

Erstellt eine Formularinstanz um einen bestehenden Mitarbeiter zu bearbeiten

[Visual Basic] Public Sub New(ByVal mitarbeiterNr As Integer)

See Also

frmAdminMitarbeiterEdit | EDOKAApp


frmAdminMitarbeiterEdit Methods

frmAdminMitarbeiterEdit overview

Methods

method Dispose |
method GetFunktionsGruppeItemIndex | Gibt den Index einer Mitarbeiter-Funktionsgruppen Zuordnung aus dem grid zurück
method GetTeamItemIndex | Gibt den Index einer Mitarbeiter-Team zuordnung aus dem grid zurück
method InitializeComponent |
method LoadDetail | Lädt allle Infos zu einem Mitarbeiter
method OnClosing |
method OnKeyDown |
method SaveData | Speichert allle Infos zu einem Mitarbeiter
method cboKlassifizierung_SelectedValueChanged |
method cmdCreateStandardProfil_Click |
method cmdEntfernenFunktionsgruppen_Click |
method cmdSaveTeamMitarbeiter_Click |
method cmdTeamConnect_Click |
method cmdTeamDisconnect_Click |
method cmdZuordnenFunktionsgruppen_Click |
method ctxAktivSetzen_Popup |
method frmAdminMitarbeiterEdit_Load |
method grdMAFunktionsgruppen_MouseDown |
method grdMATeams_MouseDown |
method grdMATeams_RowColChange |
method mnuAktivieren_Click |
method mnuDeaktivieren_Click |
method tbMenu_ButtonClick |
method tcMenu_SelectedIndexChanged |

See Also

frmAdminMitarbeiterEdit Class


frmAdminMitarbeiterEdit.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.GetFunktionsGruppeItemIndex Method

Gibt den Index einer Mitarbeiter-Funktionsgruppen Zuordnung aus dem grid zurück

Private Function GetFunktionsGruppeItemIndex( _
   ByVal funktionsGruppeNr As Integer _
) As Integer

Parameters

funktionsGruppeNr
Required. Zu suchendee Funktionsgruppen

Returns

Der Index des zutreffenden Eintrags oder -1 wenn kein Eintrag gefunden wurde

Source code

[Visual Basic]
    Private Function GetFunktionsGruppeItemIndex(ByVal funktionsGruppeNr As Integer) As Integer
        Try
            Dim row As DataRow
            Dim index As Integer = 0
            Dim rowVersion As DataRowVersion

            If IsNothing(_dsMaFunktionsgruppen) Then
                'es ist noch gar kein item im dataset
                Return -1
            End If

            For Each row In _dsMaFunktionsgruppen.Tables(0).Rows
                If Not row.RowState = DataRowState.Deleted Then
                    If Convert.ToInt32(row("funktionsgruppenr")) = funktionsGruppeNr Then
                        Return index
                    End If
                End If
                index += 1
            Next

            'eintrag wurde nicht gefunden
            Return -1
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.GetTeamItemIndex Method

Gibt den Index einer Mitarbeiter-Team zuordnung aus dem grid zurück

Private Function GetTeamItemIndex( _
   ByVal teamNr As Integer _
) As Integer

Parameters

teamNr
Required. Zu suchendes Team

Returns

Der Index des zutreffenden Eintrags oder -1 wenn kein Eintrag gefunden wurde

Source code

[Visual Basic]
    Private Function GetTeamItemIndex(ByVal teamNr As Integer) As Integer
        Try
            Dim row As DataRow
            Dim index As Integer = 0
            Dim rowVersion As DataRowVersion

            If IsNothing(_dsMaTeams) Then
                'es ist noch gar kein item im dataset
                Return -1
            End If

            For Each row In _dsMaTeams.Tables(0).Rows
                If Not row.RowState = DataRowState.Deleted Then
                    If Convert.ToInt32(row("teamnr")) = teamNr Then
                        Return index
                    End If
                End If
                index += 1
            Next

            'eintrag wurde nicht gefunden
            Return -1
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmAdminMitarbeiterEdit))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.tcMenu = New System.Windows.Forms.TabControl()
        Me.tabAllgemein = New System.Windows.Forms.TabPage()
        Me.txtFunktion = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.lblBearbeitet = New System.Windows.Forms.Label()
        Me.lblErstellt = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.chkIsActive = New System.Windows.Forms.CheckBox()
        Me.txtUnterschriftText = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.txtTelefon = New System.Windows.Forms.TextBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtFax = New System.Windows.Forms.TextBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.txteMail = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtTGNummer = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtAnrede = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.txtKurzzeichen = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.txtNachname = New System.Windows.Forms.TextBox()
        Me.txtVorname = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.lblMitarbeiterNr = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.tabErweitert = New System.Windows.Forms.TabPage()
        Me.cmdCreateStandardProfil = New System.Windows.Forms.Button()
        Me.cboKlassifizierung = New System.Windows.Forms.ComboBox()
        Me.cboFuerMandant = New System.Windows.Forms.ComboBox()
        Me.cboSprache = New System.Windows.Forms.ComboBox()
        Me.cboMandant = New System.Windows.Forms.ComboBox()
        Me.chkGebMeldung = New System.Windows.Forms.CheckBox()
        Me.chkMailDirektVersenden = New System.Windows.Forms.CheckBox()
        Me.chkJournalisierung = New System.Windows.Forms.CheckBox()
        Me.chkEdokaMail = New System.Windows.Forms.CheckBox()
        Me.chkMailDokumentRueckgang = New System.Windows.Forms.CheckBox()
        Me.chkEdokaMessage = New System.Windows.Forms.CheckBox()
        Me.chkMailEmpfang = New System.Windows.Forms.CheckBox()
        Me.chkShowToolTip = New System.Windows.Forms.CheckBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.txtMail1 = New System.Windows.Forms.TextBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.txtRang = New System.Windows.Forms.TextBox()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.txtPartnerNr = New System.Windows.Forms.TextBox()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.tabTeams = New System.Windows.Forms.TabPage()
        Me.grdMATeams = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ctxAktivSetzen = New System.Windows.Forms.ContextMenu()
        Me.mnuAktivieren = New System.Windows.Forms.MenuItem()
        Me.mnuDeaktivieren = New System.Windows.Forms.MenuItem()
        Me.txtAnteil = New System.Windows.Forms.TextBox()
        Me.cmdSaveTeamMitarbeiter = New System.Windows.Forms.Button()
        Me.lblTeamName = New System.Windows.Forms.Label()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.cmdTeamConnect = New System.Windows.Forms.Button()
        Me.grdAlleTeams = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.tabFunktionen = New System.Windows.Forms.TabPage()
        Me.grdAlleFunktionsgruppen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.grdMAFunktionsgruppen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.cmdZuordnenFunktionsgruppen = New System.Windows.Forms.Button()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.tbMenu = New System.Windows.Forms.ToolBar()
        Me.cmdClose = New System.Windows.Forms.ToolBarButton()
        Me.cmdSave = New System.Windows.Forms.ToolBarButton()
        Me.tcMenu.SuspendLayout()
        Me.tabAllgemein.SuspendLayout()
        Me.tabErweitert.SuspendLayout()
        Me.tabTeams.SuspendLayout()
        CType(Me.grdMATeams, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.grdAlleTeams, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.tabFunktionen.SuspendLayout()
        CType(Me.grdAlleFunktionsgruppen, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.grdMAFunktionsgruppen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'tcMenu
        '
        Me.tcMenu.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.tcMenu.Controls.AddRange(New System.Windows.Forms.Control() {Me.tabAllgemein, Me.tabErweitert, Me.tabTeams, Me.tabFunktionen})
        Me.tcMenu.Location = New System.Drawing.Point(8, 40)
        Me.tcMenu.Name = "tcMenu"
        Me.tcMenu.SelectedIndex = 0
        Me.tcMenu.Size = New System.Drawing.Size(674, 496)
        Me.tcMenu.TabIndex = 0
        '
        'tabAllgemein
        '
        Me.tabAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtFunktion, Me.Label18, Me.Label16, Me.Label17, Me.lblBearbeitet, Me.lblErstellt, Me.Label15, Me.chkIsActive, Me.txtUnterschriftText, Me.Label14, Me.txtTelefon, Me.Label13, Me.txtFax, Me.Label12, Me.txteMail, Me.Label11, Me.txtTGNummer, Me.Label10, Me.txtAnrede, Me.Label9, Me.txtKurzzeichen, Me.Label8, Me.txtNachname, Me.txtVorname, Me.Label7, Me.Label6, Me.lblMitarbeiterNr, Me.Label5, Me.Label1})
        Me.tabAllgemein.Location = New System.Drawing.Point(4, 22)
        Me.tabAllgemein.Name = "tabAllgemein"
        Me.tabAllgemein.Size = New System.Drawing.Size(666, 470)
        Me.tabAllgemein.TabIndex = 0
        Me.tabAllgemein.Tag = "tabAllgemein"
        Me.tabAllgemein.Text = "Allgemein"
        '
        'txtFunktion
        '
        Me.txtFunktion.Location = New System.Drawing.Point(128, 176)
        Me.txtFunktion.MaxLength = 50
        Me.txtFunktion.Name = "txtFunktion"
        Me.txtFunktion.Size = New System.Drawing.Size(200, 20)
        Me.txtFunktion.TabIndex = 14
        Me.txtFunktion.Text = ""
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(24, 176)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(100, 16)
        Me.Label18.TabIndex = 13
        Me.Label18.Text = "Funktion:"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(24, 400)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(88, 16)
        Me.Label16.TabIndex = 27
        Me.Label16.Text = "Bearbeitet:"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(24, 384)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(88, 16)
        Me.Label17.TabIndex = 25
        Me.Label17.Text = "Erstellt:"
        '
        'lblBearbeitet
        '
        Me.lblBearbeitet.Location = New System.Drawing.Point(128, 400)
        Me.lblBearbeitet.Name = "lblBearbeitet"
        Me.lblBearbeitet.Size = New System.Drawing.Size(376, 16)
        Me.lblBearbeitet.TabIndex = 28
        Me.lblBearbeitet.Text = "lblBearbeitet"
        '
        'lblErstellt
        '
        Me.lblErstellt.Location = New System.Drawing.Point(128, 384)
        Me.lblErstellt.Name = "lblErstellt"
        Me.lblErstellt.Size = New System.Drawing.Size(376, 16)
        Me.lblErstellt.TabIndex = 26
        Me.lblErstellt.Text = "lblErstellt"
        '
        'Label15
        '
        Me.Label15.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label15.Location = New System.Drawing.Point(8, 352)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(328, 23)
        Me.Label15.TabIndex = 24
        Me.Label15.Text = "Änderungen"
        '
        'chkIsActive
        '
        Me.chkIsActive.Location = New System.Drawing.Point(32, 312)
        Me.chkIsActive.Name = "chkIsActive"
        Me.chkIsActive.Size = New System.Drawing.Size(304, 24)
        Me.chkIsActive.TabIndex = 23
        Me.chkIsActive.Text = "Aktiver Benutzer"
        '
        'txtUnterschriftText
        '
        Me.txtUnterschriftText.Location = New System.Drawing.Point(128, 288)
        Me.txtUnterschriftText.MaxLength = 50
        Me.txtUnterschriftText.Name = "txtUnterschriftText"
        Me.txtUnterschriftText.Size = New System.Drawing.Size(200, 20)
        Me.txtUnterschriftText.TabIndex = 22
        Me.txtUnterschriftText.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(24, 288)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(100, 16)
        Me.Label14.TabIndex = 21
        Me.Label14.Text = "Unterschrift:"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(128, 248)
        Me.txtTelefon.MaxLength = 50
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(200, 20)
        Me.txtTelefon.TabIndex = 20
        Me.txtTelefon.Text = ""
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(24, 248)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(100, 16)
        Me.Label13.TabIndex = 19
        Me.Label13.Text = "Telefon:"
        '
        'txtFax
        '
        Me.txtFax.Location = New System.Drawing.Point(128, 224)
        Me.txtFax.MaxLength = 50
        Me.txtFax.Name = "txtFax"
        Me.txtFax.Size = New System.Drawing.Size(200, 20)
        Me.txtFax.TabIndex = 18
        Me.txtFax.Text = ""
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(24, 224)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(100, 16)
        Me.Label12.TabIndex = 17
        Me.Label12.Text = "Fax:"
        '
        'txteMail
        '
        Me.txteMail.Location = New System.Drawing.Point(128, 200)
        Me.txteMail.MaxLength = 50
        Me.txteMail.Name = "txteMail"
        Me.txteMail.Size = New System.Drawing.Size(200, 20)
        Me.txteMail.TabIndex = 16
        Me.txteMail.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(24, 200)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(100, 16)
        Me.Label11.TabIndex = 15
        Me.Label11.Text = "eMail:"
        '
        'txtTGNummer
        '
        Me.txtTGNummer.Location = New System.Drawing.Point(128, 136)
        Me.txtTGNummer.MaxLength = 50
        Me.txtTGNummer.Name = "txtTGNummer"
        Me.txtTGNummer.Size = New System.Drawing.Size(200, 20)
        Me.txtTGNummer.TabIndex = 12
        Me.txtTGNummer.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(24, 136)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(100, 16)
        Me.Label10.TabIndex = 11
        Me.Label10.Text = "TG-Nummer:"
        '
        'txtAnrede
        '
        Me.txtAnrede.Location = New System.Drawing.Point(128, 64)
        Me.txtAnrede.MaxLength = 50
        Me.txtAnrede.Name = "txtAnrede"
        Me.txtAnrede.Size = New System.Drawing.Size(128, 20)
        Me.txtAnrede.TabIndex = 4
        Me.txtAnrede.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(24, 64)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(100, 16)
        Me.Label9.TabIndex = 3
        Me.Label9.Text = "Anrede:"
        '
        'txtKurzzeichen
        '
        Me.txtKurzzeichen.Location = New System.Drawing.Point(456, 88)
        Me.txtKurzzeichen.MaxLength = 10
        Me.txtKurzzeichen.Name = "txtKurzzeichen"
        Me.txtKurzzeichen.Size = New System.Drawing.Size(80, 20)
        Me.txtKurzzeichen.TabIndex = 8
        Me.txtKurzzeichen.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(352, 88)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(100, 16)
        Me.Label8.TabIndex = 7
        Me.Label8.Text = "Kurzzeichen:"
        '
        'txtNachname
        '
        Me.txtNachname.Location = New System.Drawing.Point(128, 112)
        Me.txtNachname.MaxLength = 50
        Me.txtNachname.Name = "txtNachname"
        Me.txtNachname.Size = New System.Drawing.Size(200, 20)
        Me.txtNachname.TabIndex = 10
        Me.txtNachname.Text = ""
        '
        'txtVorname
        '
        Me.txtVorname.Location = New System.Drawing.Point(128, 88)
        Me.txtVorname.MaxLength = 50
        Me.txtVorname.Name = "txtVorname"
        Me.txtVorname.Size = New System.Drawing.Size(200, 20)
        Me.txtVorname.TabIndex = 6
        Me.txtVorname.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(24, 112)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(100, 16)
        Me.Label7.TabIndex = 9
        Me.Label7.Text = "Nachname:"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(24, 88)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(100, 16)
        Me.Label6.TabIndex = 5
        Me.Label6.Text = "Vorname:"
        '
        'lblMitarbeiterNr
        '
        Me.lblMitarbeiterNr.Location = New System.Drawing.Point(128, 40)
        Me.lblMitarbeiterNr.Name = "lblMitarbeiterNr"
        Me.lblMitarbeiterNr.Size = New System.Drawing.Size(216, 16)
        Me.lblMitarbeiterNr.TabIndex = 2
        Me.lblMitarbeiterNr.Text = "mitarbeiterNr"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(24, 40)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(100, 16)
        Me.Label5.TabIndex = 1
        Me.Label5.Text = "MitarbeiterNr:"
        '
        'Label1
        '
        Me.Label1.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(328, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Allgemeine Angaben"
        '
        'tabErweitert
        '
        Me.tabErweitert.Controls.AddRange(New System.Windows.Forms.Control() {Me.cmdCreateStandardProfil, Me.cboKlassifizierung, Me.cboFuerMandant, Me.cboSprache, Me.cboMandant, Me.chkGebMeldung, Me.chkMailDirektVersenden, Me.chkJournalisierung, Me.chkEdokaMail, Me.chkMailDokumentRueckgang, Me.chkEdokaMessage, Me.chkMailEmpfang, Me.chkShowToolTip, Me.Label21, Me.txtMail1, Me.Label31, Me.txtRang, Me.Label34, Me.Label29, Me.Label30, Me.txtPartnerNr, Me.Label22, Me.Label20, Me.Label19, Me.Label2})
        Me.tabErweitert.Location = New System.Drawing.Point(4, 22)
        Me.tabErweitert.Name = "tabErweitert"
        Me.tabErweitert.Size = New System.Drawing.Size(666, 470)
        Me.tabErweitert.TabIndex = 1
        Me.tabErweitert.Tag = "tabErweitert"
        Me.tabErweitert.Text = "Erweitert"
        '
        'cmdCreateStandardProfil
        '
        Me.cmdCreateStandardProfil.Location = New System.Drawing.Point(208, 368)
        Me.cmdCreateStandardProfil.Name = "cmdCreateStandardProfil"
        Me.cmdCreateStandardProfil.Size = New System.Drawing.Size(168, 23)
        Me.cmdCreateStandardProfil.TabIndex = 24
        Me.cmdCreateStandardProfil.Text = "Standard Profil neu erstellen"
        '
        'cboKlassifizierung
        '
        Me.cboKlassifizierung.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cboKlassifizierung.Location = New System.Drawing.Point(128, 160)
        Me.cboKlassifizierung.Name = "cboKlassifizierung"
        Me.cboKlassifizierung.Size = New System.Drawing.Size(144, 21)
        Me.cboKlassifizierung.TabIndex = 12
        '
        'cboFuerMandant
        '
        Me.cboFuerMandant.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cboFuerMandant.Items.AddRange(New Object() {"Edoka"})
        Me.cboFuerMandant.Location = New System.Drawing.Point(128, 112)
        Me.cboFuerMandant.Name = "cboFuerMandant"
        Me.cboFuerMandant.Size = New System.Drawing.Size(144, 21)
        Me.cboFuerMandant.TabIndex = 8
        '
        'cboSprache
        '
        Me.cboSprache.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cboSprache.Items.AddRange(New Object() {"Deutsch"})
        Me.cboSprache.Location = New System.Drawing.Point(128, 136)
        Me.cboSprache.Name = "cboSprache"
        Me.cboSprache.Size = New System.Drawing.Size(144, 21)
        Me.cboSprache.TabIndex = 10
        '
        'cboMandant
        '
        Me.cboMandant.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cboMandant.Items.AddRange(New Object() {"Edoka"})
        Me.cboMandant.Location = New System.Drawing.Point(128, 88)
        Me.cboMandant.Name = "cboMandant"
        Me.cboMandant.Size = New System.Drawing.Size(144, 21)
        Me.cboMandant.TabIndex = 6
        '
        'chkGebMeldung
        '
        Me.chkGebMeldung.Location = New System.Drawing.Point(208, 272)
        Me.chkGebMeldung.Name = "chkGebMeldung"
        Me.chkGebMeldung.Size = New System.Drawing.Size(192, 24)
        Me.chkGebMeldung.TabIndex = 23
        Me.chkGebMeldung.Text = "Geburtstags Meldung anzeigen"
        '
        'chkMailDirektVersenden
        '
        Me.chkMailDirektVersenden.Location = New System.Drawing.Point(208, 248)
        Me.chkMailDirektVersenden.Name = "chkMailDirektVersenden"
        Me.chkMailDirektVersenden.Size = New System.Drawing.Size(192, 24)
        Me.chkMailDirektVersenden.TabIndex = 22
        Me.chkMailDirektVersenden.Text = "<MailDirektVersenden>"
        '
        'chkJournalisierung
        '
        Me.chkJournalisierung.Location = New System.Drawing.Point(24, 368)
        Me.chkJournalisierung.Name = "chkJournalisierung"
        Me.chkJournalisierung.Size = New System.Drawing.Size(176, 24)
        Me.chkJournalisierung.TabIndex = 21
        Me.chkJournalisierung.Text = "<Journalisierung>"
        '
        'chkEdokaMail
        '
        Me.chkEdokaMail.Location = New System.Drawing.Point(24, 344)
        Me.chkEdokaMail.Name = "chkEdokaMail"
        Me.chkEdokaMail.Size = New System.Drawing.Size(176, 24)
        Me.chkEdokaMail.TabIndex = 20
        Me.chkEdokaMail.Text = "<edokaMail>"
        '
        'chkMailDokumentRueckgang
        '
        Me.chkMailDokumentRueckgang.Location = New System.Drawing.Point(24, 320)
        Me.chkMailDokumentRueckgang.Name = "chkMailDokumentRueckgang"
        Me.chkMailDokumentRueckgang.Size = New System.Drawing.Size(176, 24)
        Me.chkMailDokumentRueckgang.TabIndex = 19
        Me.chkMailDokumentRueckgang.Text = "<MailDokumentRueckgang>"
        '
        'chkEdokaMessage
        '
        Me.chkEdokaMessage.Location = New System.Drawing.Point(24, 296)
        Me.chkEdokaMessage.Name = "chkEdokaMessage"
        Me.chkEdokaMessage.Size = New System.Drawing.Size(176, 24)
        Me.chkEdokaMessage.TabIndex = 18
        Me.chkEdokaMessage.Text = "<EdokaMessage>"
        '
        'chkMailEmpfang
        '
        Me.chkMailEmpfang.Location = New System.Drawing.Point(24, 272)
        Me.chkMailEmpfang.Name = "chkMailEmpfang"
        Me.chkMailEmpfang.Size = New System.Drawing.Size(176, 24)
        Me.chkMailEmpfang.TabIndex = 17
        Me.chkMailEmpfang.Text = "<MailEmpfang>"
        '
        'chkShowToolTip
        '
        Me.chkShowToolTip.Location = New System.Drawing.Point(24, 248)
        Me.chkShowToolTip.Name = "chkShowToolTip"
        Me.chkShowToolTip.Size = New System.Drawing.Size(176, 24)
        Me.chkShowToolTip.TabIndex = 16
        Me.chkShowToolTip.Text = "ToolTipps anzeigen"
        '
        'Label21
        '
        Me.Label21.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label21.Location = New System.Drawing.Point(8, 216)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(328, 23)
        Me.Label21.TabIndex = 15
        Me.Label21.Text = "Einstellungen"
        '
        'txtMail1
        '
        Me.txtMail1.Location = New System.Drawing.Point(128, 184)
        Me.txtMail1.MaxLength = 50
        Me.txtMail1.Name = "txtMail1"
        Me.txtMail1.ReadOnly = True
        Me.txtMail1.Size = New System.Drawing.Size(144, 20)
        Me.txtMail1.TabIndex = 14
        Me.txtMail1.Text = ""
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(24, 184)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(100, 16)
        Me.Label31.TabIndex = 13
        Me.Label31.Text = "Team-Mail:"
        '
        'txtRang
        '
        Me.txtRang.Location = New System.Drawing.Point(128, 40)
        Me.txtRang.MaxLength = 50
        Me.txtRang.Name = "txtRang"
        Me.txtRang.Size = New System.Drawing.Size(144, 20)
        Me.txtRang.TabIndex = 2
        Me.txtRang.Text = ""
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(24, 40)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(100, 16)
        Me.Label34.TabIndex = 1
        Me.Label34.Text = "Rang:"
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(24, 160)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(100, 16)
        Me.Label29.TabIndex = 11
        Me.Label29.Text = "Klassifizierung:"
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(24, 136)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(100, 16)
        Me.Label30.TabIndex = 9
        Me.Label30.Text = "Sprache in Edoka:"
        '
        'txtPartnerNr
        '
        Me.txtPartnerNr.Location = New System.Drawing.Point(128, 64)
        Me.txtPartnerNr.MaxLength = 50
        Me.txtPartnerNr.Name = "txtPartnerNr"
        Me.txtPartnerNr.Size = New System.Drawing.Size(144, 20)
        Me.txtPartnerNr.TabIndex = 4
        Me.txtPartnerNr.Text = ""
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(24, 64)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(100, 16)
        Me.Label22.TabIndex = 3
        Me.Label22.Text = "Partner Nr:"
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(24, 112)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(100, 16)
        Me.Label20.TabIndex = 7
        Me.Label20.Text = "Für Mandant:"
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(24, 88)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(100, 16)
        Me.Label19.TabIndex = 5
        Me.Label19.Text = "Mandant:"
        '
        'Label2
        '
        Me.Label2.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label2.Location = New System.Drawing.Point(8, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(328, 23)
        Me.Label2.TabIndex = 0
        Me.Label2.Text = "Erweiterte Informationen"
        '
        'tabTeams
        '
        Me.tabTeams.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdMATeams, Me.txtAnteil, Me.cmdSaveTeamMitarbeiter, Me.lblTeamName, Me.Label27, Me.Label26, Me.Label25, Me.cmdTeamConnect, Me.grdAlleTeams, Me.Label24, Me.Label3})
        Me.tabTeams.Location = New System.Drawing.Point(4, 22)
        Me.tabTeams.Name = "tabTeams"
        Me.tabTeams.Size = New System.Drawing.Size(666, 470)
        Me.tabTeams.TabIndex = 2
        Me.tabTeams.Tag = "tabTeams"
        Me.tabTeams.Text = "Teams"
        '
        'grdMATeams
        '
        Me.grdMATeams.AllowFilter = True
        Me.grdMATeams.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdMATeams.AllowSort = True
        Me.grdMATeams.AllowUpdate = False
        Me.grdMATeams.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdMATeams.CaptionHeight = 17
        Me.grdMATeams.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdMATeams.CollapseColor = System.Drawing.Color.Black
        Me.grdMATeams.ContextMenu = Me.ctxAktivSetzen
        Me.grdMATeams.DataChanged = False
        Me.grdMATeams.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdMATeams.ExpandColor = System.Drawing.Color.Black
        Me.grdMATeams.FilterBar = True
        Me.grdMATeams.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdMATeams.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.grdMATeams.Location = New System.Drawing.Point(24, 184)
        Me.grdMATeams.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdMATeams.Name = "grdMATeams"
        Me.grdMATeams.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdMATeams.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdMATeams.PreviewInfo.ZoomFactor = 75
        Me.grdMATeams.PrintInfo.ShowOptionsDialog = False
        Me.grdMATeams.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdMATeams.RowDivider = GridLines1
        Me.grdMATeams.RowHeight = 15
        Me.grdMATeams.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdMATeams.ScrollTips = False
        Me.grdMATeams.Size = New System.Drawing.Size(264, 270)
        Me.grdMATeams.TabIndex = 8
        Me.grdMATeams.Text = "C1TrueDBGrid1"
        Me.grdMATeams.WrapCellPointer = True
        Me.grdMATeams.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:Co" & _
        "ntrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 260, 266</Cl" & _
        "ientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" />" & _
        "<EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""St" & _
        "yle8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""F" & _
        "ooter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle par" & _
        "ent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7""" & _
        " /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" m" & _
        "e=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Select" & _
        "edStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C" & _
        "1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" " & _
        "/><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><S" & _
        "tyle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><St" & _
        "yle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style " & _
        "parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style" & _
        " parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><St" & _
        "yle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Name" & _
        "dStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout" & _
        "><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 260, 266</ClientAr" & _
        "ea></Blob>"
        '
        'ctxAktivSetzen
        '
        Me.ctxAktivSetzen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuAktivieren, Me.mnuDeaktivieren})
        '
        'mnuAktivieren
        '
        Me.mnuAktivieren.Enabled = False
        Me.mnuAktivieren.Index = 0
        Me.mnuAktivieren.Text = "&Aktivieren"
        '
        'mnuDeaktivieren
        '
        Me.mnuDeaktivieren.Enabled = False
        Me.mnuDeaktivieren.Index = 1
        Me.mnuDeaktivieren.Text = "&Deaktivieren"
        '
        'txtAnteil
        '
        Me.txtAnteil.Location = New System.Drawing.Point(88, 104)
        Me.txtAnteil.MaxLength = 3
        Me.txtAnteil.Name = "txtAnteil"
        Me.txtAnteil.Size = New System.Drawing.Size(72, 20)
        Me.txtAnteil.TabIndex = 5
        Me.txtAnteil.Text = ""
        Me.txtAnteil.TextAlign = System.Windows.Forms.HorizontalAlignment.Right
        '
        'cmdSaveTeamMitarbeiter
        '
        Me.cmdSaveTeamMitarbeiter.Location = New System.Drawing.Point(168, 104)
        Me.cmdSaveTeamMitarbeiter.Name = "cmdSaveTeamMitarbeiter"
        Me.cmdSaveTeamMitarbeiter.Size = New System.Drawing.Size(88, 23)
        Me.cmdSaveTeamMitarbeiter.TabIndex = 6
        Me.cmdSaveTeamMitarbeiter.Text = "&Setzen"
        '
        'lblTeamName
        '
        Me.lblTeamName.Location = New System.Drawing.Point(96, 80)
        Me.lblTeamName.Name = "lblTeamName"
        Me.lblTeamName.Size = New System.Drawing.Size(376, 16)
        Me.lblTeamName.TabIndex = 3
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(24, 106)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(56, 16)
        Me.Label27.TabIndex = 4
        Me.Label27.Text = "%-Anteil:"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(24, 80)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(56, 16)
        Me.Label26.TabIndex = 2
        Me.Label26.Text = "Team:"
        '
        'Label25
        '
        Me.Label25.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label25.Location = New System.Drawing.Point(8, 152)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(328, 23)
        Me.Label25.TabIndex = 7
        Me.Label25.Text = "Bestehende Verbindungen"
        '
        'cmdTeamConnect
        '
        Me.cmdTeamConnect.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.cmdTeamConnect.Location = New System.Drawing.Point(296, 272)
        Me.cmdTeamConnect.Name = "cmdTeamConnect"
        Me.cmdTeamConnect.Size = New System.Drawing.Size(88, 23)
        Me.cmdTeamConnect.TabIndex = 9
        Me.cmdTeamConnect.Text = "< &Zuordnen"
        '
        'grdAlleTeams
        '
        Me.grdAlleTeams.AllowFilter = True
        Me.grdAlleTeams.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdAlleTeams.AllowSort = True
        Me.grdAlleTeams.AllowUpdate = False
        Me.grdAlleTeams.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdAlleTeams.CaptionHeight = 17
        Me.grdAlleTeams.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdAlleTeams.CollapseColor = System.Drawing.Color.Black
        Me.grdAlleTeams.DataChanged = False
        Me.grdAlleTeams.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdAlleTeams.ExpandColor = System.Drawing.Color.Black
        Me.grdAlleTeams.FilterBar = True
        Me.grdAlleTeams.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdAlleTeams.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.grdAlleTeams.Location = New System.Drawing.Point(392, 184)
        Me.grdAlleTeams.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdAlleTeams.Name = "grdAlleTeams"
        Me.grdAlleTeams.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdAlleTeams.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdAlleTeams.PreviewInfo.ZoomFactor = 75
        Me.grdAlleTeams.PrintInfo.ShowOptionsDialog = False
        Me.grdAlleTeams.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdAlleTeams.RowDivider = GridLines2
        Me.grdAlleTeams.RowHeight = 15
        Me.grdAlleTeams.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdAlleTeams.ScrollTips = False
        Me.grdAlleTeams.Size = New System.Drawing.Size(264, 270)
        Me.grdAlleTeams.TabIndex = 11
        Me.grdAlleTeams.Text = "C1TrueDBGrid1"
        Me.grdAlleTeams.WrapCellPointer = True
        Me.grdAlleTeams.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 260, 266</Cl" & _
        "ientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" />" & _
        "<EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""St" & _
        "yle8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""F" & _
        "ooter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle par" & _
        "ent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7""" & _
        " /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" m" & _
        "e=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Select" & _
        "edStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C" & _
        "1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" " & _
        "/><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><S" & _
        "tyle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><St" & _
        "yle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style " & _
        "parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style" & _
        " parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><St" & _
        "yle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Name" & _
        "dStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout" & _
        "><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 260, 266</ClientAr" & _
        "ea></Blob>"
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(24, 40)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(552, 32)
        Me.Label24.TabIndex = 1
        Me.Label24.Text = "Ordnen Sie hier den Mitarbeiter zu seinen Teams hinzu. Wenn ein Eintrag bei den b" & _
        "ereits zugeordneten Teams ausgewählt wird, können die Details angepasst werden."
        '
        'Label3
        '
        Me.Label3.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label3.Location = New System.Drawing.Point(8, 8)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(328, 23)
        Me.Label3.TabIndex = 0
        Me.Label3.Text = "Teams zuordnen"
        '
        'tabFunktionen
        '
        Me.tabFunktionen.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdAlleFunktionsgruppen, Me.grdMAFunktionsgruppen, Me.Label23, Me.cmdZuordnenFunktionsgruppen, Me.Label4})
        Me.tabFunktionen.Location = New System.Drawing.Point(4, 22)
        Me.tabFunktionen.Name = "tabFunktionen"
        Me.tabFunktionen.Size = New System.Drawing.Size(666, 470)
        Me.tabFunktionen.TabIndex = 3
        Me.tabFunktionen.Tag = "tabFunktionen"
        Me.tabFunktionen.Text = "Funktionen"
        '
        'grdAlleFunktionsgruppen
        '
        Me.grdAlleFunktionsgruppen.AllowFilter = True
        Me.grdAlleFunktionsgruppen.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdAlleFunktionsgruppen.AllowSort = True
        Me.grdAlleFunktionsgruppen.AllowUpdate = False
        Me.grdAlleFunktionsgruppen.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdAlleFunktionsgruppen.CaptionHeight = 17
        Me.grdAlleFunktionsgruppen.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdAlleFunktionsgruppen.CollapseColor = System.Drawing.Color.Black
        Me.grdAlleFunktionsgruppen.DataChanged = False
        Me.grdAlleFunktionsgruppen.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdAlleFunktionsgruppen.ExpandColor = System.Drawing.Color.Black
        Me.grdAlleFunktionsgruppen.FilterBar = True
        Me.grdAlleFunktionsgruppen.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdAlleFunktionsgruppen.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.grdAlleFunktionsgruppen.Location = New System.Drawing.Point(392, 80)
        Me.grdAlleFunktionsgruppen.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdAlleFunktionsgruppen.Name = "grdAlleFunktionsgruppen"
        Me.grdAlleFunktionsgruppen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdAlleFunktionsgruppen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdAlleFunktionsgruppen.PreviewInfo.ZoomFactor = 75
        Me.grdAlleFunktionsgruppen.PrintInfo.ShowOptionsDialog = False
        Me.grdAlleFunktionsgruppen.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdAlleFunktionsgruppen.RowDivider = GridLines3
        Me.grdAlleFunktionsgruppen.RowHeight = 15
        Me.grdAlleFunktionsgruppen.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdAlleFunktionsgruppen.ScrollTips = False
        Me.grdAlleFunktionsgruppen.Size = New System.Drawing.Size(264, 374)
        Me.grdAlleFunktionsgruppen.TabIndex = 5
        Me.grdAlleFunktionsgruppen.Text = "C1TrueDBGrid1"
        Me.grdAlleFunktionsgruppen.WrapCellPointer = True
        Me.grdAlleFunktionsgruppen.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:Co" & _
        "ntrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 260, 370</Cl" & _
        "ientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" />" & _
        "<EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""St" & _
        "yle8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""F" & _
        "ooter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle par" & _
        "ent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7""" & _
        " /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" m" & _
        "e=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Select" & _
        "edStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C" & _
        "1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" " & _
        "/><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><S" & _
        "tyle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><St" & _
        "yle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style " & _
        "parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style" & _
        " parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><St" & _
        "yle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Name" & _
        "dStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout" & _
        "><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 260, 370</ClientAr" & _
        "ea></Blob>"
        '
        'grdMAFunktionsgruppen
        '
        Me.grdMAFunktionsgruppen.AllowFilter = True
        Me.grdMAFunktionsgruppen.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdMAFunktionsgruppen.AllowSort = True
        Me.grdMAFunktionsgruppen.AllowUpdate = False
        Me.grdMAFunktionsgruppen.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.grdMAFunktionsgruppen.CaptionHeight = 17
        Me.grdMAFunktionsgruppen.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.grdMAFunktionsgruppen.CollapseColor = System.Drawing.Color.Black
        Me.grdMAFunktionsgruppen.ContextMenu = Me.ctxAktivSetzen
        Me.grdMAFunktionsgruppen.DataChanged = False
        Me.grdMAFunktionsgruppen.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdMAFunktionsgruppen.ExpandColor = System.Drawing.Color.Black
        Me.grdMAFunktionsgruppen.FilterBar = True
        Me.grdMAFunktionsgruppen.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdMAFunktionsgruppen.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.grdMAFunktionsgruppen.Location = New System.Drawing.Point(24, 80)
        Me.grdMAFunktionsgruppen.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.grdMAFunktionsgruppen.Name = "grdMAFunktionsgruppen"
        Me.grdMAFunktionsgruppen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdMAFunktionsgruppen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdMAFunktionsgruppen.PreviewInfo.ZoomFactor = 75
        Me.grdMAFunktionsgruppen.PrintInfo.ShowOptionsDialog = False
        Me.grdMAFunktionsgruppen.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdMAFunktionsgruppen.RowDivider = GridLines4
        Me.grdMAFunktionsgruppen.RowHeight = 15
        Me.grdMAFunktionsgruppen.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdMAFunktionsgruppen.ScrollTips = False
        Me.grdMAFunktionsgruppen.Size = New System.Drawing.Size(264, 374)
        Me.grdMAFunktionsgruppen.TabIndex = 2
        Me.grdMAFunktionsgruppen.Text = "C1TrueDBGrid1"
        Me.grdMAFunktionsgruppen.WrapCellPointer = True
        Me.grdMAFunktionsgruppen.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:C" & _
        "enter;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}S" & _
        "tyle13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" C" & _
        "aptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FilterBar=""Tr" & _
        "ue"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" " & _
        "VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 260, 370</Cl" & _
        "ientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" />" & _
        "<EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""St" & _
        "yle8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""F" & _
        "ooter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle par" & _
        "ent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7""" & _
        " /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" m" & _
        "e=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Select" & _
        "edStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C" & _
        "1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" " & _
        "/><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><S" & _
        "tyle parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><St" & _
        "yle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style " & _
        "parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style" & _
        " parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><St" & _
        "yle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Name" & _
        "dStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout" & _
        "><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 260, 370</ClientAr" & _
        "ea></Blob>"
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(24, 40)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(552, 32)
        Me.Label23.TabIndex = 1
        Me.Label23.Text = "Ordnen Sie hier den Mitarbeiten den gewünschten Funktionsgruppen hinzu. Über ""Ent" & _
        "fernen"" kann eine bestehende Zuordnung aufgelöst werden."
        '
        'cmdZuordnenFunktionsgruppen
        '
        Me.cmdZuordnenFunktionsgruppen.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.cmdZuordnenFunktionsgruppen.Location = New System.Drawing.Point(296, 168)
        Me.cmdZuordnenFunktionsgruppen.Name = "cmdZuordnenFunktionsgruppen"
        Me.cmdZuordnenFunktionsgruppen.Size = New System.Drawing.Size(88, 23)
        Me.cmdZuordnenFunktionsgruppen.TabIndex = 3
        Me.cmdZuordnenFunktionsgruppen.Text = "< &Zuordnen"
        '
        'Label4
        '
        Me.Label4.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label4.Location = New System.Drawing.Point(8, 8)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(328, 23)
        Me.Label4.TabIndex = 0
        Me.Label4.Text = "Funktionsgruppen zuordnen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'tbMenu
        '
        Me.tbMenu.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.cmdClose, Me.cmdSave})
        Me.tbMenu.DropDownArrows = True
        Me.tbMenu.ImageList = Me.ImageList1
        Me.tbMenu.Name = "tbMenu"
        Me.tbMenu.ShowToolTips = True
        Me.tbMenu.Size = New System.Drawing.Size(690, 25)
        Me.tbMenu.TabIndex = 3
        '
        'cmdClose
        '
        Me.cmdClose.ImageIndex = 0
        Me.cmdClose.Tag = "close"
        '
        'cmdSave
        '
        Me.cmdSave.ImageIndex = 1
        Me.cmdSave.Tag = "save"
        '
        'frmAdminMitarbeiterEdit
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(690, 543)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.tbMenu, Me.tcMenu})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.KeyPreview = True
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmAdminMitarbeiterEdit"
        Me.ShowInTaskbar = False
        Me.Text = "Mitarbeiter erfassen / bearbeiten"
        Me.tcMenu.ResumeLayout(False)
        Me.tabAllgemein.ResumeLayout(False)
        Me.tabErweitert.ResumeLayout(False)
        Me.tabTeams.ResumeLayout(False)
        CType(Me.grdMATeams, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.grdAlleTeams, System.ComponentModel.ISupportInitialize).EndInit()
        Me.tabFunktionen.ResumeLayout(False)
        CType(Me.grdAlleFunktionsgruppen, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.grdMAFunktionsgruppen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.LoadDetail Method

Lädt allle Infos zu einem Mitarbeiter

Private Function LoadDetail()

Source code

[Visual Basic]
    Private Function LoadDetail()
        Try
            lblMitarbeiterNr.Text = _mitarbeiter.MitarbeiterNr.ToString()
            txtAnrede.Text = _mitarbeiter.Anrede
            txtVorname.Text = _mitarbeiter.Vorname
            txtKurzzeichen.Text = _mitarbeiter.KurzZeichen
            txtNachname.Text = _mitarbeiter.Nachname
            txtTGNummer.Text = _mitarbeiter.TGNummer
            txtFunktion.Text = _mitarbeiter.Funktion
            txteMail.Text = _mitarbeiter.EMail
            txtFax.Text = _mitarbeiter.Fax
            txtTelefon.Text = _mitarbeiter.Telefon
            txtUnterschriftText.Text = _mitarbeiter.UnterschritText

            chkIsActive.Checked = _mitarbeiter.IsAktiv

            lblErstellt.Text = _mitarbeiter.ErstelltAm.ToShortDateString()
            Dim mutierer As New BusinessFacade.Mitarbeiter(_mitarbeiter.MutiererMitarbeiterNr)
            lblBearbeitet.Text = _mitarbeiter.MutiertAm.ToShortDateString() + " von " + mutierer.AnzeigeName

            txtRang.Text = _mitarbeiter.Rang
            txtPartnerNr.Text = _mitarbeiter.PartnerNr
            cboMandant.SelectedValue = _mitarbeiter.MandantNr
            cboFuerMandant.SelectedValue = _mitarbeiter.FuerMandantNr
            cboSprache.SelectedValue = _mitarbeiter.SpracheNr
            cboKlassifizierung.SelectedValue = _mitarbeiter.KlassifizierungNr
            txtMail1.Text = _mitarbeiter.Mail1

            If _mitarbeiter.KlassifizierungNr <> 1 Then
                'wenn klassifizierung nicht mitarbeiter tkb ist...
                txtMail1.ReadOnly = False
            Else
                txtMail1.ReadOnly = True
            End If

            chkShowToolTip.Checked = _mitarbeiter.ShowTipp
            chkMailEmpfang.Checked = _mitarbeiter.IsMailEmpfang
            chkEdokaMessage.Checked = _mitarbeiter.IsEdokaMessage
            chkMailDokumentRueckgang.Checked = _mitarbeiter.IsMailDokumentRueckgang
            chkEdokaMail.Checked = _mitarbeiter.IsEdokaMail
            chkJournalisierung.Checked = _mitarbeiter.Journalisierung
            chkMailDirektVersenden.Checked = _mitarbeiter.IsMailDirektVersenden
            chkGebMeldung.Checked = _mitarbeiter.IsGebMeldung

            'Zuordnung von MA zu teams laden
            _dsMaTeams = New DataSet()
            BusinessFacade.Team.GetListeByMitarbeiterNr(_mitarbeiter.MitarbeiterNr, _dsMaTeams)
            grdMATeams.DataSource = _dsMaTeams.Tables(0)

            'Zuordnung von MA zu funktionsgruppen laden
            _dsMaFunktionsgruppen = New DataSet()
            BusinessFacade.MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr(_mitarbeiter.MitarbeiterNr, _dsMaFunktionsgruppen)
            grdMAFunktionsgruppen.DataSource = _dsMaFunktionsgruppen.Tables(0)

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.LoadDetail: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.OnClosing Method

Protected Overrides Sub OnClosing( _
   ByVal e As System.ComponentModel.CancelEventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnClosing(ByVal e As System.ComponentModel.CancelEventArgs)
        Try
            If _dataChanged Then
                'froge öb speichere wenn data changed
                Dim ret As DialogResult
                ret = MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(316), Common.Consts.INFO, MessageBoxButtons.YesNo, MessageBoxIcon.Question)

                If ret = DialogResult.Yes Then
                    Dim saveRet As Integer = SaveData()

                    If saveRet <> 0 Then
                        'ein fehler ist beim speichern aufgetreten -> cancel close
                        e.Cancel = True
                    End If
                End If

            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.OnClosing: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.OnKeyDown Method

Protected Overrides Sub OnKeyDown( _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)

Parameters

e
Required.

Source code

[Visual Basic]
    Protected Overrides Sub OnKeyDown(ByVal e As System.Windows.Forms.KeyEventArgs)
        _dataChanged = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.SaveData Method

Speichert allle Infos zu einem Mitarbeiter

Private Function SaveData() As Integer

Returns

0 wenn alles erfolgreich war, 1 wenn ein fehler aufgetreten ist

Source code

[Visual Basic]
    Private Function SaveData() As Integer
        Try
            'input validierungen
            If IsNothing(cboKlassifizierung.SelectedValue) Then
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "Klassifizierung"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            If Not IsNumeric(txtPartnerNr.Text) Then
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "Partner Nr."), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            If txtNachname.Text.Trim = "" Then
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "Nachname"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            If txtVorname.Text.Trim = "" And cboKlassifizierung.SelectedValue = 1 Then
                'wenn klasse ma tkb
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "Vorname"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            If txtTGNummer.Text.Trim = "" And cboKlassifizierung.SelectedValue = 1 Then
                'wenn klasse ma tkb
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "TG-Nummer"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            If txteMail.Text.Trim = "" And cboKlassifizierung.SelectedValue = 1 Then
                'wenn klasse ma tkb
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "eMail"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                Return 1
            End If

            Dim isNeuerMitarbeiter = False
            'properties neu setzen und speichern
            If _mitarbeiter Is Nothing Then
                _mitarbeiter = New BusinessFacade.Mitarbeiter()
                isNeuerMitarbeiter = True
            End If

            _mitarbeiter.Anrede = txtAnrede.Text
            _mitarbeiter.EMail = txteMail.Text
            _mitarbeiter.Fax = txtFax.Text
            _mitarbeiter.FuerMandantNr = 1			'cboFuerMandant.SelectedValue
            _mitarbeiter.Funktion = txtFunktion.Text
            _mitarbeiter.IsAktiv = chkIsActive.Checked
            _mitarbeiter.IsEdokaMail = chkEdokaMail.Checked
            _mitarbeiter.IsEdokaMessage = chkEdokaMessage.Checked
            _mitarbeiter.IsGebMeldung = chkGebMeldung.Checked
            _mitarbeiter.IsMailDirektVersenden = chkMailDirektVersenden.Checked
            _mitarbeiter.IsMailDokumentRueckgang = chkMailDokumentRueckgang.Checked
            _mitarbeiter.IsMailEmpfang = chkMailEmpfang.Checked
            _mitarbeiter.Journalisierung = chkJournalisierung.Checked
            _mitarbeiter.KlassifizierungNr = cboKlassifizierung.SelectedValue
            _mitarbeiter.KurzZeichen = txtKurzzeichen.Text
            _mitarbeiter.Mail1 = txtMail1.Text
            _mitarbeiter.MandantNr = 1			'cboMandant.SelectedValue
            _mitarbeiter.Nachname = txtNachname.Text
            _mitarbeiter.PartnerNr = Convert.ToInt32(txtPartnerNr.Text)
            _mitarbeiter.Rang = txtRang.Text
            _mitarbeiter.ShowTipp = chkShowToolTip.Checked
            _mitarbeiter.SpracheNr = 1			'cboSprache.SelectedValue
            _mitarbeiter.Telefon = txtTelefon.Text
            _mitarbeiter.TGNummer = txtTGNummer.Text
            _mitarbeiter.UnterschritText = txtUnterschriftText.Text
            _mitarbeiter.Vorname = txtVorname.Text

            'mitarbeiter und zuordnung speichern
            _mitarbeiter.Save(_dsMaTeams, _dsMaFunktionsgruppen, Globals.MitarbeiterNr)

            If isNeuerMitarbeiter Then
                'neues standard profil erzeugen
                _mitarbeiter.CreateNewStandardProfil(BusinessFacade.AktuellerBenutzer.MitarbeiterNr)
            End If

            'reset flag
            _dataChanged = False

            Return 0
        Catch exMa As BusinessFacade.MitarbeiterException
            MessageBox.Show(exMa.Message, "Daten nicht gespeichert", MessageBoxButtons.OK, MessageBoxIcon.Information)
            Return 1
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cboKlassifizierung_SelectedValueChanged Method

Private Sub cboKlassifizierung_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cboKlassifizierung.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboKlassifizierung_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cboKlassifizierung.SelectedValueChanged
        Try
            If Not IsNothing(cboKlassifizierung.SelectedItem) Then
                'If Not IsNothing(cboKlassifizierung.SelectedItem("KlassenId")) Then
                If Convert.ToInt32(cboKlassifizierung.SelectedItem("KlassenId")) = 1 Then
                    'mitarbeiter tkb hat kein teammail
                    txtMail1.ReadOnly = True
                Else
                    txtMail1.ReadOnly = False
                End If
                'End If
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cboKlassifizierung_SelectedValueChanged: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdCreateStandardProfil_Click Method

Private Sub cmdCreateStandardProfil_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdCreateStandardProfil.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdCreateStandardProfil_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdCreateStandardProfil.Click
        Try
            'user forge öber wörkli wott am mitarbeiter sis default profil öberchrezzle...
            Dim ret As DialogResult = MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(313), _mitarbeiter.AnzeigeName), Common.Consts.INFO, MessageBoxButtons.YesNo, MessageBoxIcon.Question)

            If ret = DialogResult.Yes Then
                'neues standard profil erzeugen
                _mitarbeiter.CreateNewStandardProfil(BusinessFacade.AktuellerBenutzer.MitarbeiterNr)

                'ok meldung anzeigen
                MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(315), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(312), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdCreateStandardProfil_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdEntfernenFunktionsgruppen_Click Method

Private Sub cmdEntfernenFunktionsgruppen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdEntfernenFunktionsgruppen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            If grdMAFunktionsgruppen.Splits(0).Rows.Count > 0 Then
                Dim funktionsgruppeNr = grdMAFunktionsgruppen.Columns("funktionsgruppenr").Value

                '_dsMaFunktionsgruppen.Tables(0).Rows(GetFunktionsGruppeItemIndex(funktionsgruppeNr)).Delete()
                _dsMaFunktionsgruppen.Tables(0).Rows(GetFunktionsGruppeItemIndex(funktionsgruppeNr))("aktiv") = 0

                'neues ds an grid binden
                grdMAFunktionsgruppen.DataSource = _dsMaFunktionsgruppen.Tables(0)

                _dataChanged = True

            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(306), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdEntfernenFunktionsgruppen_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdSaveTeamMitarbeiter_Click Method

Private Sub cmdSaveTeamMitarbeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdSaveTeamMitarbeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdSaveTeamMitarbeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdSaveTeamMitarbeiter.Click
        Try
            If IsNumeric(txtAnteil.Text) Then
                _dsMaTeams.Tables(0).Rows(GetTeamItemIndex(_tmpTeamNr))("anteil") = Convert.ToInt32(txtAnteil.Text)

                grdMATeams.DataSource = _dsMaTeams.Tables(0)
            Else
                MessageBox.Show(String.Format(BusinessFacade.Meldungstext.GetInhaltById(309), "%-Anteil"), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(302), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdSaveTeamMitarbeiter_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdTeamConnect_Click Method

Private Sub cmdTeamConnect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdTeamConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdTeamConnect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdTeamConnect.Click
        Try
            If grdAlleTeams.Splits(0).Rows.Count > 0 Then
                Dim teamNr As Integer = grdAlleTeams.Columns("teamnr").Value
                If GetTeamItemIndex(teamNr) < 0 Then
                    'eintrag existiert noch nicht -> neue row mit daten hinzufügen

                    Dim newRow As DataRow
                    newRow = _dsMaTeams.Tables(0).NewRow()
                    newRow("teammitarbeiternr") = -1
                    newRow("teamnr") = teamNr
                    newRow("team") = grdAlleTeams.Columns("bezeichnung").Value
                    newRow("mandantnr") = grdAlleTeams.Columns("mandantnr").Value
                    newRow("mitarbeiternr") = _mitarbeiter.MitarbeiterNr
                    newRow("aktiv") = 1
                    newRow("anteil") = 100

                    'newRow.RowState = DataRowState.Added
                    _dsMaTeams.Tables(0).Rows.Add(newRow)

                    'neues ds an grid binden
                    grdMATeams.DataSource = _dsMaTeams.Tables(0)
                Else
                    MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(308), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                End If

                'grid spalten für teams laden
                BusinessFacade.Spalten.FillGridColumns("teammitarbeiter", grdMATeams)

                _dataChanged = True

            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(307), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdTeamConnect_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdTeamDisconnect_Click Method

Private Sub cmdTeamDisconnect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdTeamDisconnect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            If grdMATeams.Splits(0).Rows.Count > 0 Then
                Dim teamNr = grdMATeams.Columns("teamnr").Value

                'als gelöscht markieren
                '_dsMaTeams.Tables(0).Rows(GetTeamItemIndex(teamNr)).Delete()
                _dsMaTeams.Tables(0).Rows(GetTeamItemIndex(teamNr))("aktiv") = 0

                'neues ds an grid binden
                grdMATeams.DataSource = _dsMaTeams.Tables(0)

                If grdMATeams.Splits(0).Rows.Count = 0 Then
                    'wenn keine teams mehr vorhanden sind, kann auch keine %-anteil gesetzt werden
                    lblTeamName.Text = ""
                    txtAnrede.Text = ""
                    txtAnrede.Enabled = False
                    cmdSaveTeamMitarbeiter.Enabled = False
                End If
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(306), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdTeamDisconnect_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.cmdZuordnenFunktionsgruppen_Click Method

Private Sub cmdZuordnenFunktionsgruppen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdZuordnenFunktionsgruppen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdZuordnenFunktionsgruppen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdZuordnenFunktionsgruppen.Click
        Try
            If grdAlleFunktionsgruppen.Splits(0).Rows.Count > 0 Then
                Dim funktionsgruppeNr As Integer = grdAlleFunktionsgruppen.Columns("funktionsgruppenr").Value
                If GetFunktionsGruppeItemIndex(funktionsgruppeNr) < 0 Then
                    'eintrag existiert noch nicht -> neue row mit daten hinzufügen

                    Dim newRow As DataRow
                    newRow = _dsMaFunktionsgruppen.Tables(0).NewRow()
                    newRow("mitarbeiter_funktionsgruppenr") = -1
                    newRow("funktionsgruppenr") = funktionsgruppeNr
                    newRow("mitarbeiternr") = _mitarbeiter.MitarbeiterNr
                    newRow("funktionsgruppe") = grdAlleFunktionsgruppen.Columns("bezeichnung").Value
                    newRow("aktiv") = 1
                    _dsMaFunktionsgruppen.Tables(0).Rows.Add(newRow)

                    'neues ds an grid binden
                    grdMAFunktionsgruppen.DataSource = _dsMaFunktionsgruppen.Tables(0)
                Else
                    MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(308), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                End If

                'grid spalten für funktionsgruppen laden
                BusinessFacade.Spalten.FillGridColumns("mitarbeiter_funktionsgruppe", grdMAFunktionsgruppen)

                _dataChanged = True

            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(307), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.cmdZuordnenFunktionsgruppen_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.ctxAktivSetzen_Popup Method

Private Sub ctxAktivSetzen_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctxAktivSetzen.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctxAktivSetzen_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctxAktivSetzen.Popup
        Try
            Dim isAktive = False

            Select Case sender.SourceControl.Name
                Case grdMATeams.Name				'mitarbetier team
                    If grdMATeams.Splits(0).Rows.Count > 0 Then
                        isAktive = Convert.ToBoolean(grdMATeams.Columns("aktiv").Value)
                    End If
                Case grdMAFunktionsgruppen.Name				'mitarbeiter funktionsgruppe
                    If grdMAFunktionsgruppen.Splits(0).Rows.Count > 0 Then
                        isAktive = Convert.ToBoolean(grdMAFunktionsgruppen.Columns("aktiv").Value)
                    End If
            End Select

            mnuAktivieren.Enabled = Not isAktive
            mnuDeaktivieren.Enabled = isAktive

            _currentGridName = sender.SourceControl.Name
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.ctxAktivSetzen_Popup: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.frmAdminMitarbeiterEdit_Load Method

Private Sub frmAdminMitarbeiterEdit_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmAdminMitarbeiterEdit_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            'Alle Teams laden
            Dim dsAlleTeams As New DataSet()
            BusinessFacade.Team.GetListe(dsAlleTeams)
            grdAlleTeams.DataSource = dsAlleTeams.Tables(0)

            'Alle Funktionsgruppen laden
            Dim dsAlleFunktionsGruppen As New DataSet()
            BusinessFacade.Funktionsgruppe.GetListe(dsAlleFunktionsGruppen)
            grdAlleFunktionsgruppen.DataSource = dsAlleFunktionsGruppen.Tables(0)

            'grid spalten für teams laden
            BusinessFacade.Spalten.FillGridColumns("teammitarbeiter", grdMATeams)
            BusinessFacade.Spalten.FillGridColumns("team", grdAlleTeams)

            'grid spalten für funktionsgruppen laden
            BusinessFacade.Spalten.FillGridColumns("mitarbeiter_funktionsgruppe", grdMAFunktionsgruppen)
            BusinessFacade.Spalten.FillGridColumns("funktionsgruppe", grdAlleFunktionsgruppen)

            'Alle Klassifizierungen laden
            Dim dsKlassifizierung As New DataSet()
            BusinessFacade.Klassifizierung.GetListe(dsKlassifizierung)
            cboKlassifizierung.DataSource = dsKlassifizierung.Tables(0)
            cboKlassifizierung.ValueMember = "klassenID"
            cboKlassifizierung.DisplayMember = "bezeichnung"

            'default setzen
            cboMandant.SelectedIndex = 0
            cboFuerMandant.SelectedIndex = 0
            cboSprache.SelectedIndex = 0

            If Not IsNothing(_mitarbeiter) Then
                'bestehender ma
                cboKlassifizierung.SelectedValue = _mitarbeiter.KlassifizierungNr
            Else
                'neuer mitarbeiter -> load grid structur

                'leere datasets holen (struktur der ds autom erstellen lassen)
                _dsMaTeams = New DataSet()
                BusinessFacade.Team.GetListeByMitarbeiterNr(-1, _dsMaTeams)
                _dsMaFunktionsgruppen = New DataSet()
                BusinessFacade.MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr(-1, _dsMaFunktionsgruppen)
            End If

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.frmAdminMitarbeiterEdit_Load: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.grdMAFunktionsgruppen_MouseDown Method

Private Sub grdMAFunktionsgruppen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles grdMAFunktionsgruppen.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdMAFunktionsgruppen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles grdMAFunktionsgruppen.MouseDown
        Try
            grdMAFunktionsgruppen.Bookmark = Me.grdMAFunktionsgruppen.RowContaining(e.Y)
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.grdMAFunktionsgruppen_MouseDown: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.grdMATeams_MouseDown Method

Private Sub grdMATeams_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles grdMATeams.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdMATeams_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles grdMATeams.MouseDown
        Try
            grdMATeams.Bookmark = Me.grdMATeams.RowContaining(e.Y)
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.grdMATeams_MouseDown: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.grdMATeams_RowColChange Method

Private Sub grdMATeams_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdMATeams.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdMATeams_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdMATeams.RowColChange
        Try
            If grdMATeams.Splits(0).Rows.Count = 0 Then
                Exit Sub
            End If

            'nur wenn row geändert wird, ODER nur ein eintrag da ist(dann ändert die row nöd >< )
            If e.LastRow <> grdMATeams.Bookmark Or grdMATeams.Splits(0).Rows.Count = 1 Then

                'anteil ond save button enable
                txtAnrede.Enabled = True
                cmdSaveTeamMitarbeiter.Enabled = True

                'nur ausführen wenn die row geändert wird
                lblTeamName.Text = grdMATeams.Columns("team").Value
                txtAnteil.Text = grdMATeams.Columns("anteil").Value
                _tmpTeamNr = grdMATeams.Columns("teamnr").Value
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.grdMATeams_RowColChange: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.mnuAktivieren_Click Method

Private Sub mnuAktivieren_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mnuAktivieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuAktivieren_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles mnuAktivieren.Click
        Try
            Select Case _currentGridName
                Case grdMATeams.Name				'mitarbetier team
                    If grdMATeams.Splits(0).Rows.Count > 0 Then
                        grdMATeams.Columns("aktiv").Value = True
                        tcMenu.Focus()
                        grdMATeams.Focus()
                    End If
                Case grdMAFunktionsgruppen.Name				'mitarbeiter funktionsgruppe
                    If grdMAFunktionsgruppen.Splits(0).Rows.Count > 0 Then
                        grdMAFunktionsgruppen.Columns("aktiv").Value = True
                        tcMenu.Focus()
                        grdMAFunktionsgruppen.Focus()
                    End If
            End Select

            _dataChanged = True

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.mnuAktivieren_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.mnuDeaktivieren_Click Method

Private Sub mnuDeaktivieren_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mnuDeaktivieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDeaktivieren_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles mnuDeaktivieren.Click
        Try
            Select Case _currentGridName
                Case grdMATeams.Name				'mitarbetier team
                    If grdMATeams.Splits(0).Rows.Count > 0 Then
                        grdMATeams.Columns("aktiv").Value = False
                        tcMenu.Focus()
                        grdMATeams.Focus()
                    End If
                Case grdMAFunktionsgruppen.Name				'mitarbeiter funktionsgruppe
                    If grdMAFunktionsgruppen.Splits(0).Rows.Count > 0 Then
                        grdMAFunktionsgruppen.Columns("aktiv").Value = False
                        tcMenu.Focus()
                        grdMAFunktionsgruppen.Focus()
                    End If
            End Select

            _dataChanged = True

        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.mnuDeaktivieren_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.tbMenu_ButtonClick Method

Private Sub tbMenu_ButtonClick( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles tbMenu.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tbMenu_ButtonClick(ByVal sender As Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tbMenu.ButtonClick
        Try
            Select Case e.Button.Tag.ToString().ToLower()
                Case "close"
                    Close()
                Case "save"
                    Dim saveRet As Integer = SaveData()
            End Select
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(302), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.tbMenu_ButtonClick: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit.tcMenu_SelectedIndexChanged Method

Private Sub tcMenu_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles tcMenu.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tcMenu_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles tcMenu.SelectedIndexChanged
        Try
            If IsNothing(_mitarbeiter) Then
                'wenn ein neuer mitarbeiter erfasst wird, muss dieser erst gespeichert werden
                'before team und funktionsgruppen erstellt werden können, weil sosch vell onsennige check stuff
                If tcMenu.SelectedIndex = 2 Or tcMenu.SelectedIndex = 3 Then				'team zuordnung or funktionsgruppen
                    MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(314), Common.Consts.INFO, MessageBoxButtons.OK, MessageBoxIcon.Information)
                    tcMenu.SelectedIndex = 1
                End If
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.tcMenu_SelectedIndexChanged: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit Fields

frmAdminMitarbeiterEdit overview

Fields

field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label29
field Label3
field Label30
field Label31
field Label34
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field _currentGridName
field _dataChanged
field _dsMaFunktionsgruppen
field _dsMaTeams
field _mitarbeiter
field _tmpTeamNr
field cboFuerMandant
field cboKlassifizierung
field cboMandant
field cboSprache
field chkEdokaMail
field chkEdokaMessage
field chkGebMeldung
field chkIsActive
field chkJournalisierung
field chkMailDirektVersenden
field chkMailDokumentRueckgang
field chkMailEmpfang
field chkShowToolTip
field cmdClose
field cmdCreateStandardProfil
field cmdSave
field cmdSaveTeamMitarbeiter
field cmdTeamConnect
field cmdZuordnenFunktionsgruppen
field components
field ctxAktivSetzen
field grdAlleFunktionsgruppen
field grdAlleTeams
field grdMAFunktionsgruppen
field grdMATeams
field lblBearbeitet
field lblErstellt
field lblMitarbeiterNr
field lblTeamName
field mnuAktivieren
field mnuDeaktivieren
field tabAllgemein
field tabErweitert
field tabFunktionen
field tabTeams
field tbMenu
field tcMenu
field txtAnrede
field txtAnteil
field txtFax
field txtFunktion
field txtKurzzeichen
field txtMail1
field txtNachname
field txtPartnerNr
field txtRang
field txtTGNummer
field txtTelefon
field txtUnterschriftText
field txtVorname
field txteMail

See Also

frmAdminMitarbeiterEdit Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_currentGridName Variable

Dim _currentGridName As String = ""

Source code

[Visual Basic]
    Dim _currentGridName As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_dataChanged Variable

Dim _dataChanged As Boolean = False

Source code

[Visual Basic]
    Dim _dataChanged As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_dsMaFunktionsgruppen Variable

Dim _dsMaFunktionsgruppen As DataSet

Source code

[Visual Basic]
    Dim _dsMaFunktionsgruppen As DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_dsMaTeams Variable

Dim _dsMaTeams As DataSet

Source code

[Visual Basic]
    Dim _dsMaTeams As DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_mitarbeiter Variable

Dim _mitarbeiter As BusinessFacade.Mitarbeiter

Source code

[Visual Basic]
    Dim _mitarbeiter As BusinessFacade.Mitarbeiter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


_tmpTeamNr Variable

Dim _tmpTeamNr As Integer

Source code

[Visual Basic]
    Dim _tmpTeamNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cboFuerMandant Variable

Friend WithEvents cboFuerMandant As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboFuerMandant As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cboKlassifizierung Variable

Friend WithEvents cboKlassifizierung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboKlassifizierung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cboMandant Variable

Friend WithEvents cboMandant As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboMandant As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cboSprache Variable

Friend WithEvents cboSprache As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboSprache As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkEdokaMail Variable

Friend WithEvents chkEdokaMail As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkEdokaMail As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkEdokaMessage Variable

Friend WithEvents chkEdokaMessage As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkEdokaMessage As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkGebMeldung Variable

Friend WithEvents chkGebMeldung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkGebMeldung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkIsActive Variable

Friend WithEvents chkIsActive As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkIsActive As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkJournalisierung Variable

Friend WithEvents chkJournalisierung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkJournalisierung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkMailDirektVersenden Variable

Friend WithEvents chkMailDirektVersenden As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkMailDirektVersenden As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkMailDokumentRueckgang Variable

Friend WithEvents chkMailDokumentRueckgang As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkMailDokumentRueckgang As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkMailEmpfang Variable

Friend WithEvents chkMailEmpfang As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkMailEmpfang As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


chkShowToolTip Variable

Friend WithEvents chkShowToolTip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents chkShowToolTip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdClose Variable

Friend WithEvents cmdClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents cmdClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdCreateStandardProfil Variable

Friend WithEvents cmdCreateStandardProfil As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdCreateStandardProfil As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdSave Variable

Friend WithEvents cmdSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents cmdSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdSaveTeamMitarbeiter Variable

Friend WithEvents cmdSaveTeamMitarbeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdSaveTeamMitarbeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdTeamConnect Variable

Friend WithEvents cmdTeamConnect As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdTeamConnect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


cmdZuordnenFunktionsgruppen Variable

Friend WithEvents cmdZuordnenFunktionsgruppen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdZuordnenFunktionsgruppen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


ctxAktivSetzen Variable

Friend WithEvents ctxAktivSetzen As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctxAktivSetzen As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


grdAlleFunktionsgruppen Variable

Friend WithEvents grdAlleFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdAlleFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


grdAlleTeams Variable

Friend WithEvents grdAlleTeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdAlleTeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


grdMAFunktionsgruppen Variable

Friend WithEvents grdMAFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdMAFunktionsgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


grdMATeams Variable

Friend WithEvents grdMATeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdMATeams As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


lblBearbeitet Variable

Friend WithEvents lblBearbeitet As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBearbeitet As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


lblErstellt Variable

Friend WithEvents lblErstellt As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblErstellt As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


lblMitarbeiterNr Variable

Friend WithEvents lblMitarbeiterNr As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblMitarbeiterNr As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


lblTeamName Variable

Friend WithEvents lblTeamName As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblTeamName As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


mnuAktivieren Variable

Friend WithEvents mnuAktivieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAktivieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


mnuDeaktivieren Variable

Friend WithEvents mnuDeaktivieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDeaktivieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tabAllgemein Variable

Friend WithEvents tabAllgemein As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents tabAllgemein As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tabErweitert Variable

Friend WithEvents tabErweitert As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents tabErweitert As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tabFunktionen Variable

Friend WithEvents tabFunktionen As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents tabFunktionen As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tabTeams Variable

Friend WithEvents tabTeams As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents tabTeams As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tbMenu Variable

Friend WithEvents tbMenu As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents tbMenu As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


tcMenu Variable

Friend WithEvents tcMenu As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents tcMenu As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtAnrede Variable

Friend WithEvents txtAnrede As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnrede As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtAnteil Variable

Friend WithEvents txtAnteil As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnteil As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtFax Variable

Friend WithEvents txtFax As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtFax As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtFunktion Variable

Friend WithEvents txtFunktion As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtFunktion As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtKurzzeichen Variable

Friend WithEvents txtKurzzeichen As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtKurzzeichen As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtMail1 Variable

Friend WithEvents txtMail1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtMail1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtNachname Variable

Friend WithEvents txtNachname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtNachname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtPartnerNr Variable

Friend WithEvents txtPartnerNr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerNr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtRang Variable

Friend WithEvents txtRang As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtRang As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtTGNummer Variable

Friend WithEvents txtTGNummer As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTGNummer As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtTelefon Variable

Friend WithEvents txtTelefon As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTelefon As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtUnterschriftText Variable

Friend WithEvents txtUnterschriftText As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtUnterschriftText As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txtVorname Variable

Friend WithEvents txtVorname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtVorname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


txteMail Variable

Friend WithEvents txteMail As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txteMail As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmApplication Class

For a list of all members of this type, see frmApplication Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmApplication

Public Class frmApplication
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmApplication Members


frmApplication Members

frmApplication overview

Constructors

constructor frmApplication Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmApplication_Load
method save_data

Fields

field Button1
field DataSet1
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Passwort
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TXTHost
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field ToolBar1
field ToolBtnClose
field ToolBtnSave
field cBCSize
field cLogin
field cNetUse
field cbAMS
field cbColdbatch
field cbHOST
field cbRDM
field components
field dapp
field tapp
field txtAMS
field txtAlertMail
field txtApplikationsnr
field txtBCFont
field txtColdbatch
field txtDokumentpfad
field txtDokumentserver
field txtExcelPasswort
field txtExcelVerzeichnis
field txtLogischesLaufwerk
field txtRDM
field txtRPTPfad
field txtReportDB
field txtReportPasswort
field txtReportServer
field txtReportUser
field txtServerPasswort
field txtServerUser
field txtTempVerz
field txtVersion
field txtWordPasswort
field txtWordVerzeichnis
field txtcoldpassword
field txtcoldsystem
field txtcoldusesr

See Also

frmApplication Class


frmApplication Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication Methods

frmApplication overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmApplication_Load
method save_data

See Also

frmApplication Class


frmApplication.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim F As New FrmPasswortWechsel()
        F.Passwort = Me.Passwort.Text
        F.ShowDialog()
        If F.DialogResult = DialogResult.OK Then
            Me.Passwort.Text = F.Passwort
        End If
        F.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmApplication))
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnClose = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.txtApplikationsnr = New System.Windows.Forms.TextBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.txtAlertMail = New System.Windows.Forms.TextBox()
        Me.cbHOST = New System.Windows.Forms.ComboBox()
        Me.TXTHost = New System.Windows.Forms.TextBox()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.cbAMS = New System.Windows.Forms.ComboBox()
        Me.txtAMS = New System.Windows.Forms.TextBox()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.cbRDM = New System.Windows.Forms.ComboBox()
        Me.txtRDM = New System.Windows.Forms.TextBox()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.cbColdbatch = New System.Windows.Forms.ComboBox()
        Me.txtColdbatch = New System.Windows.Forms.TextBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.cLogin = New System.Windows.Forms.CheckBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.txtVersion = New System.Windows.Forms.TextBox()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.cBCSize = New System.Windows.Forms.ComboBox()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.txtBCFont = New System.Windows.Forms.TextBox()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.txtTempVerz = New System.Windows.Forms.TextBox()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Passwort = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.txtExcelPasswort = New System.Windows.Forms.TextBox()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.txtWordPasswort = New System.Windows.Forms.TextBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.txtExcelVerzeichnis = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.txtWordVerzeichnis = New System.Windows.Forms.TextBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.cNetUse = New System.Windows.Forms.CheckBox()
        Me.txtServerPasswort = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.txtServerUser = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtDokumentpfad = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.txtDokumentserver = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtLogischesLaufwerk = New System.Windows.Forms.TextBox()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.txtReportPasswort = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.txtReportUser = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.txtRPTPfad = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtReportServer = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.txtReportDB = New System.Windows.Forms.TextBox()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.Label38 = New System.Windows.Forms.Label()
        Me.txtcoldpassword = New System.Windows.Forms.TextBox()
        Me.Label35 = New System.Windows.Forms.Label()
        Me.txtcoldusesr = New System.Windows.Forms.TextBox()
        Me.Label36 = New System.Windows.Forms.Label()
        Me.Label37 = New System.Windows.Forms.Label()
        Me.txtcoldsystem = New System.Windows.Forms.TextBox()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.Label39 = New System.Windows.Forms.Label()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.TabPage4.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnClose, Me.ToolBtnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(408, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBtnClose
        '
        Me.ToolBtnClose.ImageIndex = 0
        '
        'ToolBtnSave
        '
        Me.ToolBtnSave.ImageIndex = 1
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2, Me.TabPage3, Me.TabPage4})
        Me.TabControl1.Location = New System.Drawing.Point(8, 40)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(392, 464)
        Me.TabControl1.TabIndex = 3
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtApplikationsnr, Me.GroupBox2, Me.Label17, Me.cLogin, Me.Label7, Me.txtVersion})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(384, 438)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Applikation"
        '
        'txtApplikationsnr
        '
        Me.txtApplikationsnr.Location = New System.Drawing.Point(224, 16)
        Me.txtApplikationsnr.Name = "txtApplikationsnr"
        Me.txtApplikationsnr.Size = New System.Drawing.Size(72, 20)
        Me.txtApplikationsnr.TabIndex = 27
        Me.txtApplikationsnr.Text = "TextBox1"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox8, Me.Label39, Me.Label25, Me.txtAlertMail, Me.cbHOST, Me.TXTHost, Me.Label24, Me.cbAMS, Me.txtAMS, Me.Label23, Me.cbRDM, Me.txtRDM, Me.Label22, Me.cbColdbatch, Me.txtColdbatch, Me.Label21, Me.Label20, Me.Label19, Me.Label18})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 72)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 360)
        Me.GroupBox2.TabIndex = 26
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Batchverarbeitung"
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(16, 168)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(72, 24)
        Me.Label25.TabIndex = 16
        Me.Label25.Text = "Alert-Mailadresse"
        '
        'txtAlertMail
        '
        Me.txtAlertMail.Location = New System.Drawing.Point(96, 172)
        Me.txtAlertMail.Name = "txtAlertMail"
        Me.txtAlertMail.Size = New System.Drawing.Size(248, 20)
        Me.txtAlertMail.TabIndex = 15
        Me.txtAlertMail.Text = "TextBox19"
        '
        'cbHOST
        '
        Me.cbHOST.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbHOST.Items.AddRange(New Object() {"1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "24", "48", "72"})
        Me.cbHOST.Location = New System.Drawing.Point(224, 128)
        Me.cbHOST.Name = "cbHOST"
        Me.cbHOST.Size = New System.Drawing.Size(56, 21)
        Me.cbHOST.TabIndex = 14
        '
        'TXTHost
        '
        Me.TXTHost.Enabled = False
        Me.TXTHost.Location = New System.Drawing.Point(96, 128)
        Me.TXTHost.Name = "TXTHost"
        Me.TXTHost.Size = New System.Drawing.Size(120, 20)
        Me.TXTHost.TabIndex = 13
        Me.TXTHost.Text = "TextBox18"
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(16, 128)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(72, 23)
        Me.Label24.TabIndex = 12
        Me.Label24.Text = "HOST-Abgl."
        '
        'cbAMS
        '
        Me.cbAMS.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbAMS.Items.AddRange(New Object() {"1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "24", "48", "72"})
        Me.cbAMS.Location = New System.Drawing.Point(224, 104)
        Me.cbAMS.Name = "cbAMS"
        Me.cbAMS.Size = New System.Drawing.Size(56, 21)
        Me.cbAMS.TabIndex = 11
        '
        'txtAMS
        '
        Me.txtAMS.Enabled = False
        Me.txtAMS.Location = New System.Drawing.Point(96, 104)
        Me.txtAMS.Name = "txtAMS"
        Me.txtAMS.Size = New System.Drawing.Size(120, 20)
        Me.txtAMS.TabIndex = 10
        Me.txtAMS.Text = "TextBox17"
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(16, 104)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(72, 23)
        Me.Label23.TabIndex = 9
        Me.Label23.Text = "AMS-Abgl."
        '
        'cbRDM
        '
        Me.cbRDM.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbRDM.Items.AddRange(New Object() {"1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "24", "48", "72"})
        Me.cbRDM.Location = New System.Drawing.Point(224, 80)
        Me.cbRDM.Name = "cbRDM"
        Me.cbRDM.Size = New System.Drawing.Size(56, 21)
        Me.cbRDM.TabIndex = 8
        '
        'txtRDM
        '
        Me.txtRDM.Enabled = False
        Me.txtRDM.Location = New System.Drawing.Point(96, 80)
        Me.txtRDM.Name = "txtRDM"
        Me.txtRDM.Size = New System.Drawing.Size(120, 20)
        Me.txtRDM.TabIndex = 7
        Me.txtRDM.Text = "TextBox16"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(16, 80)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(72, 23)
        Me.Label22.TabIndex = 6
        Me.Label22.Text = "RDM"
        '
        'cbColdbatch
        '
        Me.cbColdbatch.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbColdbatch.Items.AddRange(New Object() {"1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "24", "48", "72"})
        Me.cbColdbatch.Location = New System.Drawing.Point(224, 56)
        Me.cbColdbatch.Name = "cbColdbatch"
        Me.cbColdbatch.Size = New System.Drawing.Size(56, 21)
        Me.cbColdbatch.TabIndex = 5
        '
        'txtColdbatch
        '
        Me.txtColdbatch.Enabled = False
        Me.txtColdbatch.Location = New System.Drawing.Point(96, 56)
        Me.txtColdbatch.Name = "txtColdbatch"
        Me.txtColdbatch.Size = New System.Drawing.Size(120, 20)
        Me.txtColdbatch.TabIndex = 4
        Me.txtColdbatch.Text = "TextBox15"
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(16, 56)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(72, 23)
        Me.Label21.TabIndex = 3
        Me.Label21.Text = "COLD-Batch"
        '
        'Label20
        '
        Me.Label20.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label20.Location = New System.Drawing.Point(224, 32)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(136, 23)
        Me.Label20.TabIndex = 2
        Me.Label20.Text = "Alert-Mail nach Anz. Std."
        '
        'Label19
        '
        Me.Label19.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label19.Location = New System.Drawing.Point(96, 32)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(104, 23)
        Me.Label19.TabIndex = 1
        Me.Label19.Text = "Letzte durchführen"
        '
        'Label18
        '
        Me.Label18.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label18.Location = New System.Drawing.Point(16, 32)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(80, 23)
        Me.Label18.TabIndex = 0
        Me.Label18.Text = "Applikation"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(16, 40)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(104, 23)
        Me.Label17.TabIndex = 25
        Me.Label17.Text = "Login anzeigen"
        '
        'cLogin
        '
        Me.cLogin.Location = New System.Drawing.Point(120, 40)
        Me.cLogin.Name = "cLogin"
        Me.cLogin.Size = New System.Drawing.Size(16, 24)
        Me.cLogin.TabIndex = 24
        Me.cLogin.Text = "CheckBox2"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(16, 16)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(104, 23)
        Me.Label7.TabIndex = 15
        Me.Label7.Text = "EDOKA-Version"
        '
        'txtVersion
        '
        Me.txtVersion.Location = New System.Drawing.Point(120, 16)
        Me.txtVersion.Name = "txtVersion"
        Me.txtVersion.Size = New System.Drawing.Size(72, 20)
        Me.txtVersion.TabIndex = 14
        Me.txtVersion.Text = "TextBox1"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox4, Me.GroupBox3, Me.GroupBox1, Me.Label6, Me.cNetUse, Me.txtServerPasswort, Me.Label5, Me.txtServerUser, Me.Label4, Me.txtDokumentpfad, Me.Label3, Me.txtDokumentserver, Me.Label2, Me.Label1, Me.txtLogischesLaufwerk})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(384, 438)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Dokumente"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.cBCSize, Me.Label34, Me.TextBox4, Me.Label30, Me.TextBox5, Me.Label31, Me.TextBox6, Me.Label32, Me.txtBCFont, Me.Label33})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 328)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox4.TabIndex = 26
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Barcode"
        '
        'cBCSize
        '
        Me.cBCSize.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cBCSize.Items.AddRange(New Object() {"10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40"})
        Me.cBCSize.Location = New System.Drawing.Point(280, 16)
        Me.cBCSize.Name = "cBCSize"
        Me.cBCSize.Size = New System.Drawing.Size(56, 21)
        Me.cBCSize.TabIndex = 27
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(223, 17)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(56, 16)
        Me.Label34.TabIndex = 26
        Me.Label34.Text = "Grösse"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(120, 120)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.Size = New System.Drawing.Size(192, 20)
        Me.TextBox4.TabIndex = 25
        Me.TextBox4.Text = ""
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(16, 116)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(104, 27)
        Me.Label30.TabIndex = 24
        '
        'TextBox5
        '
        Me.TextBox5.Location = New System.Drawing.Point(120, 88)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.Size = New System.Drawing.Size(192, 20)
        Me.TextBox5.TabIndex = 23
        Me.TextBox5.Text = ""
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(16, 85)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(104, 27)
        Me.Label31.TabIndex = 22
        '
        'TextBox6
        '
        Me.TextBox6.Location = New System.Drawing.Point(120, 48)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.Size = New System.Drawing.Size(192, 20)
        Me.TextBox6.TabIndex = 21
        Me.TextBox6.Text = ""
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(16, 48)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(104, 23)
        Me.Label32.TabIndex = 20
        '
        'txtBCFont
        '
        Me.txtBCFont.Location = New System.Drawing.Point(72, 17)
        Me.txtBCFont.Name = "txtBCFont"
        Me.txtBCFont.Size = New System.Drawing.Size(136, 20)
        Me.txtBCFont.TabIndex = 19
        Me.txtBCFont.Text = ""
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(16, 20)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(56, 16)
        Me.Label33.TabIndex = 18
        Me.Label33.Text = "Schriftart"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox1, Me.Label26, Me.TextBox2, Me.Label27, Me.TextBox3, Me.Label28, Me.txtTempVerz, Me.Label29})
        Me.GroupBox3.Location = New System.Drawing.Point(0, 384)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(376, 48)
        Me.GroupBox3.TabIndex = 25
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Temporäre Verzeichnisse"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(120, 120)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(192, 20)
        Me.TextBox1.TabIndex = 25
        Me.TextBox1.Text = ""
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(16, 116)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(104, 27)
        Me.Label26.TabIndex = 24
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(120, 88)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(192, 20)
        Me.TextBox2.TabIndex = 23
        Me.TextBox2.Text = ""
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(16, 85)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(104, 27)
        Me.Label27.TabIndex = 22
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(120, 48)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(192, 20)
        Me.TextBox3.TabIndex = 21
        Me.TextBox3.Text = ""
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(16, 48)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(104, 23)
        Me.Label28.TabIndex = 20
        '
        'txtTempVerz
        '
        Me.txtTempVerz.Location = New System.Drawing.Point(120, 21)
        Me.txtTempVerz.Name = "txtTempVerz"
        Me.txtTempVerz.Size = New System.Drawing.Size(192, 20)
        Me.txtTempVerz.TabIndex = 19
        Me.txtTempVerz.Text = ""
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(16, 24)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(104, 16)
        Me.Label29.TabIndex = 18
        Me.Label29.Text = "Temp. User-Verz."
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Passwort, Me.Button1, Me.txtExcelPasswort, Me.Label16, Me.txtWordPasswort, Me.Label15, Me.txtExcelVerzeichnis, Me.Label14, Me.txtWordVerzeichnis, Me.Label13})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 152)
        Me.GroupBox1.TabIndex = 24
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Office-Vorlagen"
        '
        'Passwort
        '
        Me.Passwort.Location = New System.Drawing.Point(176, 24)
        Me.Passwort.Name = "Passwort"
        Me.Passwort.TabIndex = 27
        Me.Passwort.Text = "TextBox7"
        Me.Passwort.Visible = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(16, 24)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(136, 23)
        Me.Button1.TabIndex = 26
        Me.Button1.Text = "Passwort Vorlagenverwaltung"
        '
        'txtExcelPasswort
        '
        Me.txtExcelPasswort.Location = New System.Drawing.Point(120, 120)
        Me.txtExcelPasswort.Name = "txtExcelPasswort"
        Me.txtExcelPasswort.Size = New System.Drawing.Size(192, 20)
        Me.txtExcelPasswort.TabIndex = 25
        Me.txtExcelPasswort.Text = "TextBox13"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(16, 116)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(104, 27)
        Me.Label16.TabIndex = 24
        Me.Label16.Text = "Vorlage Password Excel"
        '
        'txtWordPasswort
        '
        Me.txtWordPasswort.Location = New System.Drawing.Point(120, 88)
        Me.txtWordPasswort.Name = "txtWordPasswort"
        Me.txtWordPasswort.Size = New System.Drawing.Size(192, 20)
        Me.txtWordPasswort.TabIndex = 23
        Me.txtWordPasswort.Text = "TextBox12"
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(16, 85)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(104, 27)
        Me.Label15.TabIndex = 22
        Me.Label15.Text = "Vorlage Password Word"
        '
        'txtExcelVerzeichnis
        '
        Me.txtExcelVerzeichnis.Location = New System.Drawing.Point(120, 56)
        Me.txtExcelVerzeichnis.Name = "txtExcelVerzeichnis"
        Me.txtExcelVerzeichnis.Size = New System.Drawing.Size(160, 20)
        Me.txtExcelVerzeichnis.TabIndex = 21
        Me.txtExcelVerzeichnis.Text = "TextBox11"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(16, 56)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(120, 24)
        Me.Label14.TabIndex = 20
        Me.Label14.Text = "Verzeichnis Excel"
        '
        'txtWordVerzeichnis
        '
        Me.txtWordVerzeichnis.Location = New System.Drawing.Point(120, 24)
        Me.txtWordVerzeichnis.Name = "txtWordVerzeichnis"
        Me.txtWordVerzeichnis.Size = New System.Drawing.Size(24, 20)
        Me.txtWordVerzeichnis.TabIndex = 19
        Me.txtWordVerzeichnis.Text = "TextBox10"
        Me.txtWordVerzeichnis.Visible = False
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(16, 24)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(16, 23)
        Me.Label13.TabIndex = 18
        Me.Label13.Text = "Verzeichnis Word"
        Me.Label13.Visible = False
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 140)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(104, 23)
        Me.Label6.TabIndex = 23
        Me.Label6.Text = "Net-Use verwenden"
        '
        'cNetUse
        '
        Me.cNetUse.Location = New System.Drawing.Point(112, 136)
        Me.cNetUse.Name = "cNetUse"
        Me.cNetUse.Size = New System.Drawing.Size(16, 24)
        Me.cNetUse.TabIndex = 22
        Me.cNetUse.Text = "CheckBox1"
        '
        'txtServerPasswort
        '
        Me.txtServerPasswort.Location = New System.Drawing.Point(112, 112)
        Me.txtServerPasswort.Name = "txtServerPasswort"
        Me.txtServerPasswort.Size = New System.Drawing.Size(80, 20)
        Me.txtServerPasswort.TabIndex = 21
        Me.txtServerPasswort.Text = "TextBox4"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 112)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(104, 23)
        Me.Label5.TabIndex = 20
        Me.Label5.Text = "Passwort"
        '
        'txtServerUser
        '
        Me.txtServerUser.Location = New System.Drawing.Point(112, 88)
        Me.txtServerUser.Name = "txtServerUser"
        Me.txtServerUser.Size = New System.Drawing.Size(80, 20)
        Me.txtServerUser.TabIndex = 19
        Me.txtServerUser.Text = "TextBox3"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 88)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(104, 23)
        Me.Label4.TabIndex = 18
        Me.Label4.Text = "Benutzer-ID"
        '
        'txtDokumentpfad
        '
        Me.txtDokumentpfad.Location = New System.Drawing.Point(112, 64)
        Me.txtDokumentpfad.Name = "txtDokumentpfad"
        Me.txtDokumentpfad.Size = New System.Drawing.Size(192, 20)
        Me.txtDokumentpfad.TabIndex = 17
        Me.txtDokumentpfad.Text = "TextBox2"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(104, 23)
        Me.Label3.TabIndex = 16
        Me.Label3.Text = "Dokumentpfad"
        '
        'txtDokumentserver
        '
        Me.txtDokumentserver.Location = New System.Drawing.Point(112, 40)
        Me.txtDokumentserver.Name = "txtDokumentserver"
        Me.txtDokumentserver.Size = New System.Drawing.Size(192, 20)
        Me.txtDokumentserver.TabIndex = 15
        Me.txtDokumentserver.Text = "TextBox1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(104, 23)
        Me.Label2.TabIndex = 14
        Me.Label2.Text = "Dokumentserver"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(104, 23)
        Me.Label1.TabIndex = 13
        Me.Label1.Text = "Logisches Laufwerk"
        '
        'txtLogischesLaufwerk
        '
        Me.txtLogischesLaufwerk.Location = New System.Drawing.Point(112, 16)
        Me.txtLogischesLaufwerk.Name = "txtLogischesLaufwerk"
        Me.txtLogischesLaufwerk.Size = New System.Drawing.Size(32, 20)
        Me.txtLogischesLaufwerk.TabIndex = 12
        Me.txtLogischesLaufwerk.Text = "TextBox1"
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtReportPasswort, Me.Label8, Me.txtReportUser, Me.Label9, Me.txtRPTPfad, Me.Label10, Me.txtReportServer, Me.Label11, Me.Label12, Me.txtReportDB})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(384, 438)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Auswertungen"
        '
        'txtReportPasswort
        '
        Me.txtReportPasswort.Location = New System.Drawing.Point(120, 112)
        Me.txtReportPasswort.Name = "txtReportPasswort"
        Me.txtReportPasswort.Size = New System.Drawing.Size(80, 20)
        Me.txtReportPasswort.TabIndex = 21
        Me.txtReportPasswort.Text = "TextBox4"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(16, 112)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(104, 23)
        Me.Label8.TabIndex = 20
        Me.Label8.Text = "Passwort"
        '
        'txtReportUser
        '
        Me.txtReportUser.Location = New System.Drawing.Point(120, 88)
        Me.txtReportUser.Name = "txtReportUser"
        Me.txtReportUser.Size = New System.Drawing.Size(80, 20)
        Me.txtReportUser.TabIndex = 19
        Me.txtReportUser.Text = "TextBox3"
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 88)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(104, 23)
        Me.Label9.TabIndex = 18
        Me.Label9.Text = "Benutzer-ID"
        '
        'txtRPTPfad
        '
        Me.txtRPTPfad.Location = New System.Drawing.Point(120, 64)
        Me.txtRPTPfad.Name = "txtRPTPfad"
        Me.txtRPTPfad.Size = New System.Drawing.Size(192, 20)
        Me.txtRPTPfad.TabIndex = 17
        Me.txtRPTPfad.Text = "TextBox2"
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(16, 64)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(104, 23)
        Me.Label10.TabIndex = 16
        Me.Label10.Text = "Pfad RPT-Dateien"
        '
        'txtReportServer
        '
        Me.txtReportServer.Location = New System.Drawing.Point(120, 40)
        Me.txtReportServer.Name = "txtReportServer"
        Me.txtReportServer.Size = New System.Drawing.Size(192, 20)
        Me.txtReportServer.TabIndex = 15
        Me.txtReportServer.Text = "TextBox1"
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(16, 40)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(104, 23)
        Me.Label11.TabIndex = 14
        Me.Label11.Text = "Server"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(16, 16)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(104, 23)
        Me.Label12.TabIndex = 13
        Me.Label12.Text = "Datenbank"
        '
        'txtReportDB
        '
        Me.txtReportDB.Location = New System.Drawing.Point(120, 16)
        Me.txtReportDB.Name = "txtReportDB"
        Me.txtReportDB.Size = New System.Drawing.Size(80, 20)
        Me.txtReportDB.TabIndex = 12
        Me.txtReportDB.Text = "TextBox1"
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox7, Me.Label38, Me.txtcoldpassword, Me.Label35, Me.txtcoldusesr, Me.Label36, Me.Label37, Me.txtcoldsystem})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(384, 438)
        Me.TabPage4.TabIndex = 3
        Me.TabPage4.Text = "COLD"
        '
        'TextBox7
        '
        Me.TextBox7.Location = New System.Drawing.Point(120, 88)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.Size = New System.Drawing.Size(192, 20)
        Me.TextBox7.TabIndex = 25
        Me.TextBox7.Text = "TextBox2"
        '
        'Label38
        '
        Me.Label38.Location = New System.Drawing.Point(16, 88)
        Me.Label38.Name = "Label38"
        Me.Label38.Size = New System.Drawing.Size(104, 23)
        Me.Label38.TabIndex = 24
        Me.Label38.Text = "Anzahl Anfragen"
        '
        'txtcoldpassword
        '
        Me.txtcoldpassword.Location = New System.Drawing.Point(120, 64)
        Me.txtcoldpassword.Name = "txtcoldpassword"
        Me.txtcoldpassword.Size = New System.Drawing.Size(192, 20)
        Me.txtcoldpassword.TabIndex = 23
        Me.txtcoldpassword.Text = "TextBox2"
        '
        'Label35
        '
        Me.Label35.Location = New System.Drawing.Point(16, 64)
        Me.Label35.Name = "Label35"
        Me.Label35.Size = New System.Drawing.Size(104, 23)
        Me.Label35.TabIndex = 22
        Me.Label35.Text = "Passwort"
        '
        'txtcoldusesr
        '
        Me.txtcoldusesr.Location = New System.Drawing.Point(120, 40)
        Me.txtcoldusesr.Name = "txtcoldusesr"
        Me.txtcoldusesr.Size = New System.Drawing.Size(192, 20)
        Me.txtcoldusesr.TabIndex = 21
        Me.txtcoldusesr.Text = "TextBox1"
        '
        'Label36
        '
        Me.Label36.Location = New System.Drawing.Point(16, 40)
        Me.Label36.Name = "Label36"
        Me.Label36.Size = New System.Drawing.Size(104, 23)
        Me.Label36.TabIndex = 20
        Me.Label36.Text = "Benutzer"
        '
        'Label37
        '
        Me.Label37.Location = New System.Drawing.Point(16, 16)
        Me.Label37.Name = "Label37"
        Me.Label37.Size = New System.Drawing.Size(104, 23)
        Me.Label37.TabIndex = 19
        Me.Label37.Text = "System"
        '
        'txtcoldsystem
        '
        Me.txtcoldsystem.Location = New System.Drawing.Point(120, 16)
        Me.txtcoldsystem.Name = "txtcoldsystem"
        Me.txtcoldsystem.Size = New System.Drawing.Size(192, 20)
        Me.txtcoldsystem.TabIndex = 18
        Me.txtcoldsystem.Text = "TextBox1"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "applikation", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("applikationsnr", "applikationsnr"), New System.Data.Common.DataColumnMapping("version", "version"), New System.Data.Common.DataColumnMapping("dokument_server", "dokument_server"), New System.Data.Common.DataColumnMapping("net_use", "net_use"), New System.Data.Common.DataColumnMapping("logisches_laufwerk", "logisches_laufwerk"), New System.Data.Common.DataColumnMapping("pfad_dokumente", "pfad_dokumente"), New System.Data.Common.DataColumnMapping("pfad_word_vorlagen", "pfad_word_vorlagen"), New System.Data.Common.DataColumnMapping("pfad_excel_vorlagen", "pfad_excel_vorlagen"), New System.Data.Common.DataColumnMapping("pfad_temporaer_dokumente", "pfad_temporaer_dokumente"), New System.Data.Common.DataColumnMapping("user_fileserver", "user_fileserver"), New System.Data.Common.DataColumnMapping("passwort_fileserver", "passwort_fileserver"), New System.Data.Common.DataColumnMapping("passwort_wordvorlagen", "passwort_wordvorlagen"), New System.Data.Common.DataColumnMapping("passwort_excelvorlagen", "passwort_excelvorlagen"), New System.Data.Common.DataColumnMapping("report_db", "report_db"), New System.Data.Common.DataColumnMapping("report_server", "report_server"), New System.Data.Common.DataColumnMapping("pfad_reportdateien", "pfad_reportdateien"), New System.Data.Common.DataColumnMapping("user_report", "user_report"), New System.Data.Common.DataColumnMapping("passwort_report", "passwort_report"), New System.Data.Common.DataColumnMapping("barcode_font", "barcode_font"), New System.Data.Common.DataColumnMapping("bcfont_groesse", "bcfont_groesse"), New System.Data.Common.DataColumnMapping("mailadresse", "mailadresse"), New System.Data.Common.DataColumnMapping("showlogin", "showlogin"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("letzter_cold_run", "letzter_cold_run"), New System.Data.Common.DataColumnMapping("letzer_ams_run", "letzer_ams_run"), New System.Data.Common.DataColumnMapping("letzter_rdm_run", "letzter_rdm_run"), New System.Data.Common.DataColumnMapping("letzter_host_run", "letzter_host_run"), New System.Data.Common.DataColumnMapping("rdmstunden", "rdmstunden"), New System.Data.Common.DataColumnMapping("coldstunden", "coldstunden"), New System.Data.Common.DataColumnMapping("amsstunden", "amsstunden"), New System.Data.Common.DataColumnMapping("hoststunden", "hoststunden"), New System.Data.Common.DataColumnMapping("coldsystem", "coldsystem"), New System.Data.Common.DataColumnMapping("colduser", "colduser"), New System.Data.Common.DataColumnMapping("coldpassword", "coldpassword")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_applikation_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_applikationsnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "applikationsnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcode_font", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcode_font", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcfont_groesse", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcfont_groesse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldpassword", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldpassword", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldsystem", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldsystem", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_colduser", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "colduser", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_server", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_server", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hoststunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hoststunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzer_ams_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzer_ams_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_cold_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_cold_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_host_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_host_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_rdm_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_rdm_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_logisches_laufwerk", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "logisches_laufwerk", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mailadresse", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mailadresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_net_use", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "net_use", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_excelvorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_excelvorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_fileserver", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_fileserver", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_report", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_report", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_wordvorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_wordvorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_dokumente", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_dokumente", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_excel_vorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_excel_vorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_reportdateien", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_reportdateien", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_temporaer_dokumente", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_temporaer_dokumente", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_word_vorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_word_vorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rdmstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rdmstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_db", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_db", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_server", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_server", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showlogin", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showlogin", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_user_fileserver", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "user_fileserver", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_user_report", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "user_report", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_version", System.Data.SqlDbType.VarChar, 3, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "version", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tg339012;initial catalog=edoka_parameter;integrated security=SSPI;per" & _
        "sist security info=False;user id=dbedoka11;workstation id=TG602655;packet size=4" & _
        "096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_applikation_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection2
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@applikationsnr", System.Data.SqlDbType.Int, 4, "applikationsnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@version", System.Data.SqlDbType.VarChar, 3, "version"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_server", System.Data.SqlDbType.VarChar, 50, "dokument_server"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@net_use", System.Data.SqlDbType.Bit, 1, "net_use"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@logisches_laufwerk", System.Data.SqlDbType.VarChar, 10, "logisches_laufwerk"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_dokumente", System.Data.SqlDbType.VarChar, 50, "pfad_dokumente"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_word_vorlagen", System.Data.SqlDbType.VarChar, 50, "pfad_word_vorlagen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_excel_vorlagen", System.Data.SqlDbType.VarChar, 50, "pfad_excel_vorlagen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_temporaer_dokumente", System.Data.SqlDbType.VarChar, 50, "pfad_temporaer_dokumente"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@user_fileserver", System.Data.SqlDbType.VarChar, 50, "user_fileserver"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_fileserver", System.Data.SqlDbType.VarChar, 50, "passwort_fileserver"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_wordvorlagen", System.Data.SqlDbType.VarChar, 50, "passwort_wordvorlagen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_excelvorlagen", System.Data.SqlDbType.VarChar, 50, "passwort_excelvorlagen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_db", System.Data.SqlDbType.VarChar, 50, "report_db"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_server", System.Data.SqlDbType.VarChar, 50, "report_server"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_reportdateien", System.Data.SqlDbType.VarChar, 50, "pfad_reportdateien"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@user_report", System.Data.SqlDbType.VarChar, 50, "user_report"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_report", System.Data.SqlDbType.VarChar, 50, "passwort_report"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcode_font", System.Data.SqlDbType.VarChar, 50, "barcode_font"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcfont_groesse", System.Data.SqlDbType.Int, 4, "bcfont_groesse"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mailadresse", System.Data.SqlDbType.VarChar, 50, "mailadresse"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showlogin", System.Data.SqlDbType.Bit, 1, "showlogin"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_cold_run", System.Data.SqlDbType.DateTime, 8, "letzter_cold_run"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzer_ams_run", System.Data.SqlDbType.DateTime, 8, "letzer_ams_run"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_rdm_run", System.Data.SqlDbType.DateTime, 8, "letzter_rdm_run"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_host_run", System.Data.SqlDbType.DateTime, 8, "letzter_host_run"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rdmstunden", System.Data.SqlDbType.Int, 4, "rdmstunden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldstunden", System.Data.SqlDbType.Int, 4, "coldstunden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsstunden", System.Data.SqlDbType.Int, 4, "amsstunden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hoststunden", System.Data.SqlDbType.Int, 4, "hoststunden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldsystem", System.Data.SqlDbType.VarChar, 50, "coldsystem"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@colduser", System.Data.SqlDbType.VarChar, 50, "colduser"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldpassword", System.Data.SqlDbType.VarChar, 50, "coldpassword"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_applikation_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection2
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_applikation_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@applikationsnr", System.Data.SqlDbType.Int, 4, "applikationsnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@version", System.Data.SqlDbType.VarChar, 3, "version"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_server", System.Data.SqlDbType.VarChar, 50, "dokument_server"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@net_use", System.Data.SqlDbType.Bit, 1, "net_use"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@logisches_laufwerk", System.Data.SqlDbType.VarChar, 10, "logisches_laufwerk"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_dokumente", System.Data.SqlDbType.VarChar, 50, "pfad_dokumente"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_word_vorlagen", System.Data.SqlDbType.VarChar, 50, "pfad_word_vorlagen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_excel_vorlagen", System.Data.SqlDbType.VarChar, 50, "pfad_excel_vorlagen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_temporaer_dokumente", System.Data.SqlDbType.VarChar, 50, "pfad_temporaer_dokumente"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@user_fileserver", System.Data.SqlDbType.VarChar, 50, "user_fileserver"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_fileserver", System.Data.SqlDbType.VarChar, 50, "passwort_fileserver"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_wordvorlagen", System.Data.SqlDbType.VarChar, 50, "passwort_wordvorlagen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_excelvorlagen", System.Data.SqlDbType.VarChar, 50, "passwort_excelvorlagen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_db", System.Data.SqlDbType.VarChar, 50, "report_db"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_server", System.Data.SqlDbType.VarChar, 50, "report_server"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@pfad_reportdateien", System.Data.SqlDbType.VarChar, 50, "pfad_reportdateien"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@user_report", System.Data.SqlDbType.VarChar, 50, "user_report"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@passwort_report", System.Data.SqlDbType.VarChar, 50, "passwort_report"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcode_font", System.Data.SqlDbType.VarChar, 50, "barcode_font"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcfont_groesse", System.Data.SqlDbType.Int, 4, "bcfont_groesse"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mailadresse", System.Data.SqlDbType.VarChar, 50, "mailadresse"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showlogin", System.Data.SqlDbType.Bit, 1, "showlogin"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_cold_run", System.Data.SqlDbType.DateTime, 8, "letzter_cold_run"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzer_ams_run", System.Data.SqlDbType.DateTime, 8, "letzer_ams_run"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_rdm_run", System.Data.SqlDbType.DateTime, 8, "letzter_rdm_run"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@letzter_host_run", System.Data.SqlDbType.DateTime, 8, "letzter_host_run"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rdmstunden", System.Data.SqlDbType.Int, 4, "rdmstunden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldstunden", System.Data.SqlDbType.Int, 4, "coldstunden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsstunden", System.Data.SqlDbType.Int, 4, "amsstunden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hoststunden", System.Data.SqlDbType.Int, 4, "hoststunden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldsystem", System.Data.SqlDbType.VarChar, 50, "coldsystem"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@colduser", System.Data.SqlDbType.VarChar, 50, "colduser"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldpassword", System.Data.SqlDbType.VarChar, 50, "coldpassword"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_applikationsnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "applikationsnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcode_font", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcode_font", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcfont_groesse", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcfont_groesse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldpassword", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldpassword", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldsystem", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldsystem", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_colduser", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "colduser", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_server", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_server", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hoststunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hoststunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzer_ams_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzer_ams_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_cold_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_cold_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_host_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_host_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_letzter_rdm_run", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "letzter_rdm_run", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_logisches_laufwerk", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "logisches_laufwerk", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mailadresse", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mailadresse", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_net_use", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "net_use", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_excelvorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_excelvorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_fileserver", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_fileserver", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_report", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_report", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_passwort_wordvorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "passwort_wordvorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_dokumente", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_dokumente", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_excel_vorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_excel_vorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_reportdateien", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_reportdateien", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_temporaer_dokumente", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_temporaer_dokumente", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_pfad_word_vorlagen", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "pfad_word_vorlagen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rdmstunden", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rdmstunden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_db", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_db", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_server", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_server", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showlogin", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showlogin", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_user_fileserver", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "user_fileserver", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_user_report", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "user_report", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_version", System.Data.SqlDbType.VarChar, 3, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "version", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'TextBox8
        '
        Me.TextBox8.Location = New System.Drawing.Point(192, 208)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.Size = New System.Drawing.Size(64, 20)
        Me.TextBox8.TabIndex = 18
        Me.TextBox8.Text = "TextBox18"
        '
        'Label39
        '
        Me.Label39.Location = New System.Drawing.Point(16, 208)
        Me.Label39.Name = "Label39"
        Me.Label39.Size = New System.Drawing.Size(192, 23)
        Me.Label39.TabIndex = 17
        Me.Label39.Text = "Zeitintervall Mail/Dokument-Check"
        '
        'frmApplication
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(408, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmApplication"
        Me.Text = "frmApplication"
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.TabPage4.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 1
                save_data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication.frmApplication_Load Method

Private Sub frmApplication_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmApplication_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Long
        dapp.cpMainConnectionProvider = conn
        tapp = dapp.SelectAll
        For i = 0 To tapp.Rows.Count - 1
            If tapp.Rows(i).Item("mandantnr") = Globals.MandantNr Then
                dapp.iApplikationsnr = New SqlInt32(CType(tapp.Rows(i).Item("applikationsnr"), Int32))
                dapp.SelectOne()
            End If
        Next
        Me.txtcoldsystem.Text = dapp.sColdsystem.Value
        Me.txtcoldusesr.Text = dapp.sColduser.Value
        Me.txtcoldpassword.Text = dapp.sColdpassword.Value
        Me.txtApplikationsnr.Text = dapp.iApplikationsnr.Value
        Me.txtVersion.Text = dapp.sVersion.Value
        Me.txtDokumentserver.Text = dapp.sDokument_server.Value
        Me.cNetUse.Checked = dapp.bNet_use.Value = True
        Me.txtLogischesLaufwerk.Text = dapp.sLogisches_laufwerk.Value
        Me.txtDokumentpfad.Text = dapp.sPfad_dokumente.Value
        Me.txtWordVerzeichnis.Text = dapp.sPfad_word_vorlagen.Value
        Me.txtExcelVerzeichnis.Text = dapp.sPfad_excel_vorlagen.Value
        Me.txtTempVerz.Text = dapp.sPfad_temporaer_dokumente.Value
        Me.txtServerUser.Text = dapp.sUser_fileserver.Value
        Me.txtServerPasswort.Text = dapp.sPasswort_fileserver.Value
        Me.txtWordPasswort.Text = dapp.sPasswort_wordvorlagen.Value
        Me.txtExcelPasswort.Text = dapp.sPasswort_excelvorlagen.Value

        Me.txtReportDB.Text = dapp.sReport_db.Value
        Me.txtReportServer.Text = dapp.sReport_server.Value
        Me.txtRPTPfad.Text = dapp.sPfad_reportdateien.Value
        Me.txtReportUser.Text = dapp.sUser_report.Value
        Me.txtReportPasswort.Text = dapp.sPasswort_report.Value

        Me.txtAlertMail.Text = dapp.sMailadresse.Value
        Me.cLogin.Checked = dapp.bShowlogin.Value = True
        Me.txtColdbatch.Text = dapp.daLetzter_cold_run.Value
        Me.txtAMS.Text = dapp.daLetzer_ams_run.Value
        Me.txtRDM.Text = dapp.daLetzter_rdm_run.Value
        Me.TXTHost.Text = dapp.daLetzter_host_run.Value
        Me.cbRDM.Text = dapp.iRdmstunden.Value
        Me.cbAMS.Text = dapp.iAmsstunden.Value
        Me.cbColdbatch.Text = dapp.iColdstunden.Value
        Me.cbHOST.Text = dapp.iHoststunden.Value
        Me.TextBox7.Text = dapp.iAnzahl_cold_viewer.Value.ToString
        Me.TextBox8.Text = dapp.iZeitintervall_in_Minuten.Value.ToString
        Me.txtBCFont.Text = dapp.sBarcode_font.Value
        Me.cBCSize.Text = dapp.iBcfont_groesse.Value
        Me.Passwort.Text = dapp.sPasswort_vorlagenverwaltung.Value

        tapp.Dispose()
        dapp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication.save_data Method

Public Sub save_data()

Source code

[Visual Basic]
    Public Sub save_data()
        Dim i As Long
        dapp.cpMainConnectionProvider = conn
        dapp.iApplikationsnr = New SqlInt32(CType(Me.txtApplikationsnr.Text, Int32))
        dapp.SelectOne()
        dapp.sVersion = New SqlString(CType(Me.txtVersion.Text, String))
        dapp.sDokument_server = New SqlString(CType(Me.txtDokumentserver.Text, String))
        If Me.cNetUse.Checked Then dapp.bNet_use = New SqlBoolean(CType(1, Boolean)) Else dapp.bNet_use = New SqlBoolean(CType(0, Boolean))
        dapp.sLogisches_laufwerk = New SqlString(CType(Me.txtLogischesLaufwerk.Text, String))
        dapp.sPfad_dokumente = New SqlString(CType(Me.txtDokumentpfad.Text, String))
        dapp.sPfad_word_vorlagen = New SqlString(CType(Me.txtWordVerzeichnis.Text, String))
        dapp.sPfad_excel_vorlagen = New SqlString(CType(Me.txtExcelVerzeichnis.Text, String))
        dapp.sPasswort_wordvorlagen = New SqlString(CType(Me.txtWordPasswort.Text, String))
        dapp.sPasswort_excelvorlagen = New SqlString(CType(Me.txtExcelPasswort.Text, String))
        dapp.sPfad_temporaer_dokumente = New SqlString(CType(Me.txtTempVerz.Text, String))
        dapp.sPasswort_fileserver = New SqlString(CType(Me.txtServerPasswort.Text, String))
        dapp.sUser_fileserver = New SqlString(CType(Me.txtServerUser.Text, String))

        dapp.sColdsystem = New SqlString(CType(Me.txtcoldsystem.Text, String))
        dapp.sColduser = New SqlString(CType(Me.txtcoldusesr.Text, String))
        dapp.sColdpassword = New SqlString(CType(Me.txtcoldpassword.Text, String))

        dapp.sReport_db = New SqlString(CType(Me.txtReportDB.Text, String))
        dapp.sReport_server = New SqlString(CType(Me.txtReportServer.Text, String))
        dapp.sPfad_reportdateien = New SqlString(CType(Me.txtRPTPfad.Text, String))
        dapp.sUser_report = New SqlString(CType(Me.txtReportUser.Text, String))
        dapp.sPasswort_report = New SqlString(CType(Me.txtReportPasswort.Text, String))

        dapp.sMailadresse = New SqlString(CType(Me.txtAlertMail.Text, String))
        If Me.cLogin.Checked Then dapp.bShowlogin = New SqlBoolean(CType(1, Boolean)) Else dapp.bShowlogin = New SqlBoolean(CType(0, Boolean))
        dapp.iRdmstunden = New SqlInt32(CType(Me.cbRDM.Text, Int32))
        dapp.iAmsstunden = New SqlInt32(CType(Me.cbAMS.Text, Int32))
        dapp.iHoststunden = New SqlInt32(CType(Me.cbHOST.Text, Int32))
        dapp.iColdstunden = New SqlInt32(CType(Me.cbColdbatch.Text, Int32))
        dapp.sBarcode_font = New SqlString(CType(Me.txtBCFont.Text, String))
        dapp.iBcfont_groesse = New SqlInt32(CType(Me.cBCSize.Text, Int32))
        dapp.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        dapp.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        dapp.sPasswort_vorlagenverwaltung = New SqlString(CType(Me.Passwort.Text, String))
        dapp.iAnzahl_Cold_Viewer = New SqlInt32(CType(Val(Me.TextBox7.Text), String))
        dapp.iZeitintervall_in_Minuten = New SqlInt32(CType(Val(Me.TextBox8.Text), Int32))
        'conn.OpenConnection()
        dapp.Update()
        'conn.CloseConnection(False)
        tapp.Dispose()
        dapp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmApplication Fields

frmApplication overview

Fields

field Button1
field DataSet1
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Passwort
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TXTHost
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field ToolBar1
field ToolBtnClose
field ToolBtnSave
field cBCSize
field cLogin
field cNetUse
field cbAMS
field cbColdbatch
field cbHOST
field cbRDM
field components
field dapp
field tapp
field txtAMS
field txtAlertMail
field txtApplikationsnr
field txtBCFont
field txtColdbatch
field txtDokumentpfad
field txtDokumentserver
field txtExcelPasswort
field txtExcelVerzeichnis
field txtLogischesLaufwerk
field txtRDM
field txtRPTPfad
field txtReportDB
field txtReportPasswort
field txtReportServer
field txtReportUser
field txtServerPasswort
field txtServerUser
field txtTempVerz
field txtVersion
field txtWordPasswort
field txtWordVerzeichnis
field txtcoldpassword
field txtcoldsystem
field txtcoldusesr

See Also

frmApplication Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label35 Variable

Friend WithEvents Label35 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label35 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label36 Variable

Friend WithEvents Label36 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label36 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label37 Variable

Friend WithEvents Label37 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label37 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label38 Variable

Friend WithEvents Label38 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label38 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label39 Variable

Friend WithEvents Label39 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label39 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


Passwort Variable

Friend WithEvents Passwort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents Passwort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TXTHost Variable

Friend WithEvents TXTHost As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TXTHost As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


ToolBtnClose Variable

Friend WithEvents ToolBtnClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


ToolBtnSave Variable

Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cBCSize Variable

Friend WithEvents cBCSize As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cBCSize As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cLogin Variable

Friend WithEvents cLogin As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cLogin As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cNetUse Variable

Friend WithEvents cNetUse As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cNetUse As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cbAMS Variable

Friend WithEvents cbAMS As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbAMS As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cbColdbatch Variable

Friend WithEvents cbColdbatch As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbColdbatch As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cbHOST Variable

Friend WithEvents cbHOST As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbHOST As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


cbRDM Variable

Friend WithEvents cbRDM As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbRDM As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


dapp Variable

Dim dapp As New edokadb.clsApplikation()

Source code

[Visual Basic]
    Dim dapp As New edokadb.clsApplikation()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


tapp Variable

Dim tapp As DataTable

Source code

[Visual Basic]
    Dim tapp As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtAMS Variable

Friend WithEvents txtAMS As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAMS As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtAlertMail Variable

Friend WithEvents txtAlertMail As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAlertMail As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtApplikationsnr Variable

Friend WithEvents txtApplikationsnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtApplikationsnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtBCFont Variable

Friend WithEvents txtBCFont As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBCFont As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtColdbatch Variable

Friend WithEvents txtColdbatch As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtColdbatch As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtDokumentpfad Variable

Friend WithEvents txtDokumentpfad As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentpfad As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtDokumentserver Variable

Friend WithEvents txtDokumentserver As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentserver As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtExcelPasswort Variable

Friend WithEvents txtExcelPasswort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtExcelPasswort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtExcelVerzeichnis Variable

Friend WithEvents txtExcelVerzeichnis As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtExcelVerzeichnis As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtLogischesLaufwerk Variable

Friend WithEvents txtLogischesLaufwerk As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtLogischesLaufwerk As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtRDM Variable

Friend WithEvents txtRDM As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtRDM As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtRPTPfad Variable

Friend WithEvents txtRPTPfad As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtRPTPfad As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtReportDB Variable

Friend WithEvents txtReportDB As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReportDB As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtReportPasswort Variable

Friend WithEvents txtReportPasswort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReportPasswort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtReportServer Variable

Friend WithEvents txtReportServer As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReportServer As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtReportUser Variable

Friend WithEvents txtReportUser As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReportUser As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtServerPasswort Variable

Friend WithEvents txtServerPasswort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtServerPasswort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtServerUser Variable

Friend WithEvents txtServerUser As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtServerUser As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtTempVerz Variable

Friend WithEvents txtTempVerz As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTempVerz As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtVersion Variable

Friend WithEvents txtVersion As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtVersion As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtWordPasswort Variable

Friend WithEvents txtWordPasswort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtWordPasswort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtWordVerzeichnis Variable

Friend WithEvents txtWordVerzeichnis As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtWordVerzeichnis As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtcoldpassword Variable

Friend WithEvents txtcoldpassword As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtcoldpassword As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtcoldsystem Variable

Friend WithEvents txtcoldsystem As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtcoldsystem As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


txtcoldusesr Variable

Friend WithEvents txtcoldusesr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtcoldusesr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmApplication


frmAuswertungsgruppeReports Class

For a list of all members of this type, see frmAuswertungsgruppeReports Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmAuswertungsgruppeReports

Public Class frmAuswertungsgruppeReports
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmAuswertungsgruppeReports Members


frmAuswertungsgruppeReports Members

frmAuswertungsgruppeReports overview

Constructors

constructor frmAuswertungsgruppeReports Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmAuswertungsgruppeReports_Load
method frmClose

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmAuswertungsgruppeReports Class


frmAuswertungsgruppeReports Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports Properties

frmAuswertungsgruppeReports overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmAuswertungsgruppeReports Class


frmAuswertungsgruppeReports Methods

frmAuswertungsgruppeReports overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmAuswertungsgruppeReports_Load
method frmClose

See Also

frmAuswertungsgruppeReports Class


frmAuswertungsgruppeReports.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=pc120;initial catalog=edoka;password=sqlsa;persist security info=True" & _
        ";user id=sa;workstation id=PC120;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportnr", "reportnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("dateiname", "dateiname"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("odbc", "odbc"), New System.Data.Common.DataColumnMapping("oledb", "oledb"), New System.Data.Common.DataColumnMapping("sqlclient", "sqlclient")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_report_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_odbc", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "odbc", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_oledb", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "oledb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sqlclient", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sqlclient", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_report_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 255, "dateiname"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@odbc", System.Data.SqlDbType.Bit, 1, "odbc"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@oledb", System.Data.SqlDbType.Bit, 1, "oledb"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sqlclient", System.Data.SqlDbType.Bit, 1, "sqlclient"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_report_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_report_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 255, "dateiname"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@odbc", System.Data.SqlDbType.Bit, 1, "odbc"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@oledb", System.Data.SqlDbType.Bit, 1, "oledb"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sqlclient", System.Data.SqlDbType.Bit, 1, "sqlclient"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_odbc", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "odbc", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_oledb", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "oledb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sqlclient", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sqlclient", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report_reportgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("report_reportgruppenr", "report_reportgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("reportnr", "reportnr"), New System.Data.Common.DataColumnMapping("report_gruppenr", "report_gruppenr")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_reprt_reportgruppe_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_reportgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_reportgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_report_reportgruppe_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_reportgruppenr", System.Data.SqlDbType.Int, 4, "report_reportgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_reportgruppe_report_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_report_reportgruppe_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_reportgruppenr", System.Data.SqlDbType.Int, 4, "report_reportgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_reportgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_reportgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_report_gruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_report_gruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_report_gruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_report_gruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmAuswertungsgruppeReports
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, 0)
        Me.Name = "frmAuswertungsgruppeReports"
        Me.Text = ""
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsReport_reportgruppe()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iReport_gruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iReportnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iReportnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iReport_gruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iReport_gruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iReportnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.sBeschreibung = New SqlString(CType("", String))
            vdata.sBeschreibung = New SqlString(CType("", String))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("reportgruppe_report")
            vdata.iReport_reportgruppenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        'SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        'SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5017, 5018, 5019)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.frmAuswertungsgruppeReports_Load Method

Private Sub frmAuswertungsgruppeReports_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmAuswertungsgruppeReports_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            Cursor.Current = Cursors.WaitCursor
            Me.TableNameLeft = "reportgruppe"
            Me.TableNameRight = "report"
            Me.TableNameBottom = "report_reportgruppe"
            LoadData()
            Cursor.Current = Cursors.Default
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmAuswertungsgruppeReports Fields

frmAuswertungsgruppeReports overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmAuswertungsgruppeReports Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAuswertungsgruppeReports


frmBLAuslieferungen Class

For a list of all members of this type, see frmBLAuslieferungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLAuslieferungen

Public Class frmBLAuslieferungen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLAuslieferungen Members


frmBLAuslieferungen Members

frmBLAuslieferungen overview

Constructors

constructor frmBLAuslieferungen Constructor

Methods

method Aushaendigungsstatus_zuruecksetzen
method BtnHelp_Click
method ContextMenu1_Popup
method Create_Druckjob
method Create_PrintJob
method Delete_Aushaendigung
method Delete_Druckjob
method Dispose
method DokList_Click
method DokList_FetchRowStyle
method DokList_MouseDown
method EditDok
method Get_Auslieferungstatus
method Get_Auslierferungen
method Get_nldata
method InitializeComponent
method Load_Auslieferungen
method MenuItem2_Click
method MnuStatusZurueck_Click
method Mutationsberechtigung
method PrintDocs
method PrintQuittung
method Print_And_Arch
method ShowDoc
method Start_Druckjob
method TVStatus_AfterSelect
method Timer1_Elapsed
method ToolBar1_ButtonClick
method Update_TVStatus
method cbnl_SelectedIndexChanged
method delete_aushaendigungsquittung
method frmBLAuslieferungen_Closing
method frmBLAuslieferungen_Load
method get_bldokumente
method get_druckjob
method get_druckjob_parts
method get_druckjobstatus
method get_parts
method get_pdf
method handlemenu
method handlemenunok
method handlemenuok
method isstv
method mnuBLDossier_Click
method mnuDelete_Click
method mnuDruckAbbruch_Click
method mnuDruckArchiv_Click
method mnuEdit_Click
method mnuPrintOK_Click
method mnuShowDoc_Click
method mnuiAgain_Click
method mnuprintall_Click
method mnuprintquittung_Click
method neuer_druckauftrag
method print_pdf
method set_PrintNOK
method set_PrintOK
method set_druckjobstatus
method set_druckjobstatus_part
method set_quittung_bereit_zur_archivierung
method startdruckjob
method stop_druckauftrag
method update_aushaendigungsquittung_status
method update_bldokument

Events

event evDossierAenderungen_Erfolgt

Fields

field BtnHelp
field ContextMenu1
field DokList
field Dokumentfilename
field DruckThread
field GroupBox1
field ImageList1
field ImgListSteuerung
field MenuItem1
field MenuItem3
field MenuItem6
field MenuItem9
field MnuDruck
field MnuPrintBestaetigen
field MnuStatusZurueck
field NLFilter
field Panel1
field TVStatus
field Timer1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field alstatus
field cbnl
field components
field dtnl
field intAushaendigungnr
field intDruckjobnr
field intNeuerDruckauftrag
field mcbnl
field mnuAgain
field mnuAuslieferungen
field mnuBLDossier
field mnuDelete
field mnuDruckAbbruch
field mnuDruckArchiv
field mnuEdit
field mnuPrintNOK
field mnuPrintOK
field mnuShowDoc
field mnuprintall
field mnuprintaq
field on_load
field pnlNiederlassung

See Also

frmBLAuslieferungen Class


frmBLAuslieferungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen Methods

frmBLAuslieferungen overview

Methods

method Aushaendigungsstatus_zuruecksetzen
method BtnHelp_Click
method ContextMenu1_Popup
method Create_Druckjob
method Create_PrintJob
method Delete_Aushaendigung
method Delete_Druckjob
method Dispose
method DokList_Click
method DokList_FetchRowStyle
method DokList_MouseDown
method EditDok
method Get_Auslieferungstatus
method Get_Auslierferungen
method Get_nldata
method InitializeComponent
method Load_Auslieferungen
method MenuItem2_Click
method MnuStatusZurueck_Click
method Mutationsberechtigung
method PrintDocs
method PrintQuittung
method Print_And_Arch
method ShowDoc
method Start_Druckjob
method TVStatus_AfterSelect
method Timer1_Elapsed
method ToolBar1_ButtonClick
method Update_TVStatus
method cbnl_SelectedIndexChanged
method delete_aushaendigungsquittung
method frmBLAuslieferungen_Closing
method frmBLAuslieferungen_Load
method get_bldokumente
method get_druckjob
method get_druckjob_parts
method get_druckjobstatus
method get_parts
method get_pdf
method handlemenu
method handlemenunok
method handlemenuok
method isstv
method mnuBLDossier_Click
method mnuDelete_Click
method mnuDruckAbbruch_Click
method mnuDruckArchiv_Click
method mnuEdit_Click
method mnuPrintOK_Click
method mnuShowDoc_Click
method mnuiAgain_Click
method mnuprintall_Click
method mnuprintquittung_Click
method neuer_druckauftrag
method print_pdf
method set_PrintNOK
method set_PrintOK
method set_druckjobstatus
method set_druckjobstatus_part
method set_quittung_bereit_zur_archivierung
method startdruckjob
method stop_druckauftrag
method update_aushaendigungsquittung_status
method update_bldokument

See Also

frmBLAuslieferungen Class


frmBLAuslieferungen.Aushaendigungsstatus_zuruecksetzen Method

Public Function Aushaendigungsstatus_zuruecksetzen( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function Aushaendigungsstatus_zuruecksetzen(ByVal alnr As Integer)
        Me.update_aushaendigungsquittung_status(alnr, 2)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("aushndigungenverwalten")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Dim tmpdata As New DataTable()

        Dim m As MenuItem
        For Each m In Me.ContextMenu1.MenuItems
            m.Enabled = False
        Next
        Me.mnuBLDossier.Enabled = True
        Me.mnuprintall.Enabled = True
        Me.mnuprintaq.Enabled = True
        Me.mnuPrintOK.Enabled = True
        Me.mnuPrintNOK.Enabled = True
        Me.mnuAuslieferungen.Enabled = True
        Me.mnuDelete.Enabled = True
        Try
            If Me.Mutationsberechtigung(DokList.Columns("nrpar00").Value, DokList.Columns("dokumentid_quittung").Value) = False Then
                Me.mnuEdit.Enabled = False
                Me.mnuDruckArchiv.Enabled = False
                Me.mnuAgain.Enabled = False
                Me.mnuDelete.Enabled = False
                Me.mnuAuslieferungen.Enabled = True
                Exit Sub
            End If
        Catch
            Me.mnuEdit.Enabled = False
            Me.mnuDruckArchiv.Enabled = False
            Me.mnuAgain.Enabled = False
            Me.mnuDelete.Enabled = False
            Me.mnuAuslieferungen.Enabled = False
            Exit Sub
        End Try

        Try
            Select Case Me.DokList.Columns("status").Value
                Case 0
                    Me.mnuAgain.Enabled = True
                Case 1
                    Me.mnuDruckAbbruch.Enabled = True
                Case 2
                    Me.MnuDruck.Enabled = True
                Case 3
                    Me.MnuPrintBestaetigen.Enabled = True
                Case 4
                    If Me.get_druckjobstatus(Me.DokList.Columns(0).Value) < 4 Then
                        Me.MnuStatusZurueck.Enabled = True
                    End If
                Case 5
                    Me.mnuDelete.Enabled = False
                Case Else
            End Select

        Catch
        End Try

        Me.mnuprintall.MenuItems.Clear()
        Me.mnuPrintOK.MenuItems.Clear()
        Me.mnuPrintNOK.MenuItems.Clear()
        If Me.MnuStatusZurueck.Enabled = True Then Exit Sub
        If Me.get_parts(Me.DokList.Columns(0).Value) > 0 Then
            'Druckmenu
            Dim i As Integer
            Dim a As Integer = 0
            Dim b As Integer = 0
            Dim c As Integer = 0
            tmpdata = get_druckjob_parts()
            For i = 0 To tmpdata.Rows.Count - 1
                Select Case tmpdata.Rows(i).Item("status")
                    Case 2
                        a = 1
                    Case 3
                        b = 1
                    Case 4
                        c = 1
                End Select
            Next
            If b = 0 And c = 0 And Me.MnuPrintBestaetigen.Enabled = True Then Exit Sub
            If a = 1 Then
                Me.MnuDruck.Enabled = True
            End If
            If b = 1 Then
                Me.MnuPrintBestaetigen.Enabled = True
            End If

            If tmpdata.Rows.Count > 1 Then
                Dim s As String
                For i = 0 To tmpdata.Rows.Count - 1
                    s = "Teil " + LTrim(Str(i + 1)) + " von " + LTrim(Str(tmpdata.Rows(i).Item("totalparts")))
                    If i = 0 Then s = s + " inkl. Quittung"
                    If tmpdata.Rows(i).Item("status") = 2 Then s = s + " (nicht gedruckt)"
                    If tmpdata.Rows(i).Item("status") = 3 Then s = s + " (gedruckt nicht bestätigt)"
                    If tmpdata.Rows(i).Item("status") = 4 Then s = s + " (erfolgreich gedruckt)"
                    m = Me.mnuprintall.MenuItems.Add(s, New EventHandler(AddressOf handlemenu))
                    If tmpdata.Rows(i).Item("status") = 4 Or tmpdata.Rows(i).Item("status") = 3 Then m.Enabled = False
                    If a > 0 Or b > 0 Or c > 0 Then
                        m = Me.mnuPrintOK.MenuItems.Add(s, New EventHandler(AddressOf handlemenuok))
                        If tmpdata.Rows(i).Item("status") = 2 Or tmpdata.Rows(i).Item("status") = 4 Then m.Enabled = False

                        m = Me.mnuPrintNOK.MenuItems.Add(s, New EventHandler(AddressOf handlemenunok))
                        If tmpdata.Rows(i).Item("status") = 4 Or tmpdata.Rows(i).Item("status") = 2 Then m.Enabled = False
                    End If
                Next
            End If

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Create_Druckjob Method

Private Function Create_Druckjob( _
   ByVal auslieferungnr As Integer, _
   ByVal bldossier As DataTable, _
   ByVal anzahl As Integer _
) As Integer

Parameters

auslieferungnr
Required.
bldossier
Required.
anzahl
Required.

Source code

[Visual Basic]
    Private Function Create_Druckjob(ByVal auslieferungnr As Integer, ByVal bldossier As DataTable, ByVal anzahl As Integer) As Integer
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Integer
        dbkey.cpMainConnectionProvider = conn
        conn.OpenConnection()
        key = dbkey.get_dbkey("Druckjob")
        conn.CloseConnection(False)

        Dim druckjob As New edokadb.clsEDEX_BL_Druckjob()
        druckjob.cpMainConnectionProvider = conn
        druckjob.iDruckjobnr = New SqlInt32(CType(key, Int32))
        druckjob.iAuslieferungnr = New SqlInt32(CType(auslieferungnr, Int32))

        'Schulung Rel. 3.7
        If Microsoft.VisualBasic.Left(Globals.TGNummer, 2) = "AK" Then
            druckjob.sTgnummer = New SqlString(CType("TG" + Globals.TGNummer, String))
        Else
            druckjob.sTgnummer = New SqlString(CType(Globals.TGNummer, String))
        End If
        druckjob.iAnzahl_dokument = New SqlInt32(CType(anzahl, Int32))
        druckjob.daAufbereitet_am = New SqlDateTime(CType(Now, DateTime))
        druckjob.iStatus = New SqlInt32(CType(0, Int32))
        druckjob.sBemerkung = New SqlString(CType("", String))
        druckjob.bAktiv = New SqlBoolean(CType(True, Boolean))
        druckjob.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        druckjob.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        druckjob.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        druckjob.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        conn.OpenConnection()
        druckjob.Insert()
        conn.CloseConnection(True)
        Return key
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Create_PrintJob Method

Public Sub Create_PrintJob( _
   ByVal Aushaendigungnr As Integer, _
   ByVal bldossier As DataTable _
)

Parameters

Aushaendigungnr
Required.
bldossier
Required.

Source code

[Visual Basic]
    Public Sub Create_PrintJob(ByVal Aushaendigungnr As Integer, ByVal bldossier As DataTable)
        Dim i As Integer
        Dim updateit As Boolean = False
        Dim Anzahl As Integer
        For i = 0 To bldossier.Rows.Count - 1
            updateit = False
            Try
                If bldossier.Rows(i).Item("auslieferungnr") = 0 Then
                    updateit = True
                Else
                    updateit = False
                End If
            Catch
                updateit = True
            End Try
            If updateit = True Then
                Anzahl = Anzahl + 1
                Select Case Microsoft.VisualBasic.Left(bldossier.Rows(i).Item("dokumentart"), 4)
                    Case "HOST"
                        update_bldokument(1, bldossier.Rows(i).Item("dokumentid"), Aushaendigungnr)
                    Case Else
                        update_bldokument(2, bldossier.Rows(i).Item("dokumentid"), Aushaendigungnr)
                End Select
            End If
        Next
        If Anzahl = 0 Then
            update_aushaendigungsquittung_status(Aushaendigungnr, 2)
            Try
                Dim xdruckjobnr As Integer
                xdruckjobnr = Me.get_druckjob(Aushaendigungnr)
                Dim f As New frmWatchJob(xdruckjobnr)
                f.Timer1.Enabled = False
                f.Timer1.Interval = 5000
                f.Timer1.Enabled = True
                f.Visible = False
                f.Hide()
                f.Show()
                f.Hide()
                Application.DoEvents()
            Catch
            End Try
            Exit Sub
        End If
        Dim Druckjobnr As Integer = Create_Druckjob(Aushaendigungnr, bldossier, Anzahl)
        intDruckjobnr = Druckjobnr
        intAushaendigungnr = Aushaendigungnr
        intNeuerDruckauftrag = False
        DruckThread = New Thread(AddressOf startdruckjob)
        DruckThread.Start()
        Thread.CurrentThread.Sleep(1000)
        Try
            Dim f As New frmWatchJob(intDruckjobnr)
            f.Visible = False
            f.Hide()
            f.Show()
            f.Hide()
        Catch
        End Try
        update_aushaendigungsquittung_status(Aushaendigungnr, 1)
        RaiseEvent evDossierAenderungen_Erfolgt()
        'If Start_Druckjob(Druckjobnr) = True Then
        '    update_aushaendigungsquittung_status(Aushaendigungnr, 1)
        '    RaiseEvent evDossierAenderungen_Erfolgt()
        'Else
        '    Delete_Druckjob(Druckjobnr)
        '    update_aushaendigungsquittung_status(Aushaendigungnr, 0)
        '    Try
        '        RaiseEvent evDossierAenderungen_Erfolgt()
        '    Catch
        '    End Try
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Delete_Aushaendigung Method

Public Function Delete_Aushaendigung( _
   ByVal alnr As Integer _
) As Boolean

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function Delete_Aushaendigung(ByVal alnr As Integer) As Boolean
        If MyMsg.Show_MessageYesNo(611) = MsgBoxResult.Yes Then
            delete_aushaendigungsquittung(alnr)
            Return True
        Else
            Return False
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Delete_Druckjob Method

Private Function Delete_Druckjob( _
   ByVal druckjobnr As Integer _
)

Parameters

druckjobnr
Required.

Source code

[Visual Basic]
    Private Function Delete_Druckjob(ByVal druckjobnr As Integer)
        Dim druckjob As New edokadb.clsEDEX_BL_Druckjob()
        druckjob.cpMainConnectionProvider = conn
        druckjob.iDruckjobnr = New SqlInt32(CType(druckjobnr, Int32))
        druckjob.SelectOne()
        conn.OpenConnection()
        druckjob.Delete()
        conn.CloseConnection(True)
        druckjob.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.DokList_Click Method

Private Sub DokList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.DokList_FetchRowStyle Method

Private Sub DokList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.EditDok Method

Public Sub EditDok( _
   ByVal Alnr As Integer _
)

Parameters

Alnr
Required.

Source code

[Visual Basic]
    Public Sub EditDok(ByVal Alnr As Integer)
        Dim f As New frmBLDruck(Alnr)
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Get_Auslieferungstatus Method

Private Function Get_Auslieferungstatus() As DataTable

Source code

[Visual Basic]
    Private Function Get_Auslieferungstatus() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_auslieferungstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Get_Auslierferungen Method

Private Function Get_Auslierferungen() As DataTable

Source code

[Visual Basic]
    Private Function Get_Auslierferungen() As DataTable
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_auslieferungen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbnl.SelectedValue))
            sdaAdapter.Fill(dtToReturn)
            '            Me.NLFilter = scmCmdToExecute.Parameters("@nl").Value
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Get_nldata Method

Private Function Get_nldata() As DataTable

Source code

[Visual Basic]
    Private Function Get_nldata() As DataTable
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_getnl"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nlnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Me.NLFilter = scmCmdToExecute.Parameters("@nlnr").Value
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()

            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBLAuslieferungen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDruck = New System.Windows.Forms.MenuItem()
        Me.mnuprintall = New System.Windows.Forms.MenuItem()
        Me.mnuprintaq = New System.Windows.Forms.MenuItem()
        Me.MnuPrintBestaetigen = New System.Windows.Forms.MenuItem()
        Me.mnuPrintOK = New System.Windows.Forms.MenuItem()
        Me.mnuPrintNOK = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.mnuAgain = New System.Windows.Forms.MenuItem()
        Me.mnuDruckAbbruch = New System.Windows.Forms.MenuItem()
        Me.MnuStatusZurueck = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.mnuAuslieferungen = New System.Windows.Forms.MenuItem()
        Me.mnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.mnuEdit = New System.Windows.Forms.MenuItem()
        Me.mnuDruckArchiv = New System.Windows.Forms.MenuItem()
        Me.mnuDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.mnuBLDossier = New System.Windows.Forms.MenuItem()
        Me.Timer1 = New System.Timers.Timer()
        Me.TVStatus = New System.Windows.Forms.TreeView()
        Me.ImgListSteuerung = New System.Windows.Forms.ImageList(Me.components)
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.pnlNiederlassung = New System.Windows.Forms.GroupBox()
        Me.cbnl = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlNiederlassung.SuspendLayout()
        Me.Panel1.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(840, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 11
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 10
        Me.ToolBarButton3.Style = System.Windows.Forms.ToolBarButtonStyle.ToggleButton
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(256, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(584, 308)
        Me.DokList.TabIndex = 27
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 580," & _
        " 304</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 580, " & _
        "304</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDruck, Me.MnuPrintBestaetigen, Me.MenuItem3, Me.mnuAgain, Me.mnuDruckAbbruch, Me.MnuStatusZurueck, Me.MenuItem9, Me.mnuAuslieferungen, Me.mnuDelete, Me.MenuItem6, Me.MenuItem1, Me.mnuBLDossier})
        '
        'MnuDruck
        '
        Me.MnuDruck.Index = 0
        Me.MnuDruck.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuprintall, Me.mnuprintaq})
        Me.MnuDruck.Text = "Dokumente ausdrucken"
        '
        'mnuprintall
        '
        Me.mnuprintall.Index = 0
        Me.mnuprintall.Text = "Aushändigungs-Quittung und Dokumente"
        '
        'mnuprintaq
        '
        Me.mnuprintaq.Index = 1
        Me.mnuprintaq.Text = "Nur Aushändigungs-Quittung"
        '
        'MnuPrintBestaetigen
        '
        Me.MnuPrintBestaetigen.Index = 1
        Me.MnuPrintBestaetigen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuPrintOK, Me.mnuPrintNOK})
        Me.MnuPrintBestaetigen.Text = "Ausdruck bestätigen"
        '
        'mnuPrintOK
        '
        Me.mnuPrintOK.Index = 0
        Me.mnuPrintOK.Text = "Erfolgreich"
        '
        'mnuPrintNOK
        '
        Me.mnuPrintNOK.Index = 1
        Me.mnuPrintNOK.Text = "Nicht erfolgreich"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'mnuAgain
        '
        Me.mnuAgain.Index = 3
        Me.mnuAgain.Text = "Dokumente neu aufbereiten"
        '
        'mnuDruckAbbruch
        '
        Me.mnuDruckAbbruch.Index = 4
        Me.mnuDruckAbbruch.Text = "Druck&auftrag abbrechen"
        '
        'MnuStatusZurueck
        '
        Me.MnuStatusZurueck.Index = 5
        Me.MnuStatusZurueck.Text = "Aushändigungsstatus zurücksetzen"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 6
        Me.MenuItem9.Text = "-"
        '
        'mnuAuslieferungen
        '
        Me.mnuAuslieferungen.Index = 7
        Me.mnuAuslieferungen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuShowDoc, Me.mnuEdit, Me.mnuDruckArchiv})
        Me.mnuAuslieferungen.Text = "Aushändigungs-Quittung"
        '
        'mnuShowDoc
        '
        Me.mnuShowDoc.Index = 0
        Me.mnuShowDoc.Text = "Anzeigen"
        '
        'mnuEdit
        '
        Me.mnuEdit.Index = 1
        Me.mnuEdit.Text = "Bearbeiten"
        '
        'mnuDruckArchiv
        '
        Me.mnuDruckArchiv.Index = 2
        Me.mnuDruckArchiv.Text = "Drucken"
        '
        'mnuDelete
        '
        Me.mnuDelete.Index = 8
        Me.mnuDelete.Text = "Aushändigung löschen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 9
        Me.MenuItem6.Text = "-"
        Me.MenuItem6.Visible = False
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 10
        Me.MenuItem1.Text = "-"
        '
        'mnuBLDossier
        '
        Me.mnuBLDossier.Index = 11
        Me.mnuBLDossier.Text = "Banklagernd-Dossier anzeigen"
        '
        'Timer1
        '
        Me.Timer1.Interval = 10000
        Me.Timer1.SynchronizingObject = Me
        '
        'TVStatus
        '
        Me.TVStatus.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.TVStatus.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVStatus.ImageList = Me.ImgListSteuerung
        Me.TVStatus.Location = New System.Drawing.Point(3, 16)
        Me.TVStatus.Name = "TVStatus"
        Me.TVStatus.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Auslieferungstatus (alle)", 0, 4)})
        Me.TVStatus.Size = New System.Drawing.Size(250, 249)
        Me.TVStatus.TabIndex = 28
        '
        'ImgListSteuerung
        '
        Me.ImgListSteuerung.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImgListSteuerung.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImgListSteuerung.ImageStream = CType(resources.GetObject("ImgListSteuerung.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListSteuerung.TransparentColor = System.Drawing.Color.Transparent
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(816, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 69
        '
        'pnlNiederlassung
        '
        Me.pnlNiederlassung.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbnl})
        Me.pnlNiederlassung.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlNiederlassung.Name = "pnlNiederlassung"
        Me.pnlNiederlassung.Size = New System.Drawing.Size(256, 40)
        Me.pnlNiederlassung.TabIndex = 70
        Me.pnlNiederlassung.TabStop = False
        Me.pnlNiederlassung.Text = "Niederlassung"
        '
        'cbnl
        '
        Me.cbnl.Location = New System.Drawing.Point(8, 16)
        Me.cbnl.Name = "cbnl"
        Me.cbnl.Size = New System.Drawing.Size(244, 21)
        Me.cbnl.TabIndex = 0
        Me.cbnl.Text = "ComboBox1"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.pnlNiederlassung})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(256, 308)
        Me.Panel1.TabIndex = 71
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVStatus})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox1.Location = New System.Drawing.Point(0, 40)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(256, 268)
        Me.GroupBox1.TabIndex = 71
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Aushändigungen"
        '
        'frmBLAuslieferungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(840, 333)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokList, Me.Panel1, Me.BtnHelp, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmBLAuslieferungen"
        Me.ShowInTaskbar = False
        Me.Text = "Aushändigungen"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlNiederlassung.ResumeLayout(False)
        Me.Panel1.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Load_Auslieferungen Method

Private Function Load_Auslieferungen()

Source code

[Visual Basic]
    Private Function Load_Auslieferungen()
        Dim savenode As New TreeNode()
        Try
            savenode = TVStatus.SelectedNode
        Catch
        End Try
        Me.DokList.Enabled = False
        Me.DokList.BeginInit()
        Dim dt As New DataTable()
        Me.DokList.DataSource = Nothing
        dt = Get_Auslierferungen()
        Me.DokList.DataSource = dt
        Me.DokList.DataMember = dt.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, dt, "auslieferung")

        Update_TVStatus()
        Me.DokList.EndInit()
        Me.DokList.Enabled = True
        Try
            DivFnkt.Searchnode(Me.TVStatus, savenode.Tag, 4)
            If DivFnkt.found = True Then Me.TVStatus.SelectedNode = DivFnkt.FoundNode
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuPrintNOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPrintNOK.Click
        Me.set_PrintNOK(Me.DokList.Columns(0).Value, -1)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.MnuStatusZurueck_Click Method

Private Sub MnuStatusZurueck_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuStatusZurueck.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuStatusZurueck_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuStatusZurueck.Click
        Aushaendigungsstatus_zuruecksetzen(Me.DokList.Columns(0).Value)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Mutationsberechtigung Method

Public Function Mutationsberechtigung( _
   ByVal nrpar00 As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

nrpar00
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function Mutationsberechtigung(ByVal nrpar00 As Integer, ByVal dokumentid As String) As Boolean
        Dim d As New DataTable()
        Dim dok As New edokadb.clsDokument()
        dok.cpMainConnectionProvider = Globals.conn
        dok.sDokumentid = New SqlString(CType(dokumentid, String))
        dok.SelectOne()

        Try
            'd = DivFnkt.Berechtigte_Mitarbeiter(dok.iDokumenttypnr.Value, Globals.MitarbeiterNr, nrpar00, dokumentid, 0, 0, 0, 0, "")
            If dok.iVerantwortlich.Value <> Globals.MitarbeiterNr And Globals.stv = 0 Then
                If Not isstv(Globals.MitarbeiterNr, nrpar00, dokumentid) Then
                    Return False
                Else
                    Return True
                End If
            Else
                Return True
            End If
        Catch
            Return False
        Finally
            d.Dispose()
            dok.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.PrintDocs Method

Public Function PrintDocs( _
   ByVal Officedokumentid As String, _
   ByVal parentform As Form, _
   ByVal alnr As Integer, _
   ByVal part As Integer _
)

Parameters

Officedokumentid
Required.
parentform
Required.
alnr
Required.
part
Required.

Source code

[Visual Basic]
    Public Function PrintDocs(ByVal Officedokumentid As String, ByVal parentform As Form, ByVal alnr As Integer, ByVal part As Integer)
        Dim f As New frmDokumentAufbereitung(alnr, part)
        'f.MdiParent = Me.MdiParent
        f.Show()
        f.StartDruckaufbereituung()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.PrintQuittung Method

Public Function PrintQuittung( _
   ByVal Officedokumentid As String, _
   ByVal parentform As Form, _
   ByVal alnr As Integer _
)

Parameters

Officedokumentid
Required.
parentform
Required.
alnr
Required.

Source code

[Visual Basic]
    Public Function PrintQuittung(ByVal Officedokumentid As String, ByVal parentform As Form, ByVal alnr As Integer)
        Me.Cursor = Cursors.WaitCursor
        Dim i As Integer
        DivFnkt.print_office(Officedokumentid, parentform, False)
        Me.update_aushaendigungsquittung_status(alnr, 3)
        Me.Dokumentfilename = ""
        Dim f As New frmPDFPrinter(False)
        f.Button1.Enabled = True
        f.alnr = alnr
        f.Show()
        Me.Cursor = Cursors.Default
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Print_And_Arch Method

Public Sub Print_And_Arch( _
   ByVal officedokumentid As String, _
   ByVal parentform As Form, _
   ByVal alnr As Integer _
)

Parameters

officedokumentid
Required.
parentform
Required.
alnr
Required.

Source code

[Visual Basic]
    Public Sub Print_And_Arch(ByVal officedokumentid As String, ByVal parentform As Form, ByVal alnr As Integer)
        DivFnkt.print_office(officedokumentid, parentform)
        Me.set_quittung_bereit_zur_archivierung(alnr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.ShowDoc Method

Public Sub ShowDoc( _
   ByVal Officedokumentid As String, _
   ByVal Parentform As Form _
)

Parameters

Officedokumentid
Required.
Parentform
Required.

Source code

[Visual Basic]
    Public Sub ShowDoc(ByVal Officedokumentid As String, ByVal Parentform As Form)
        DivFnkt.show_office(Officedokumentid, Parentform)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Start_Druckjob Method

Private Function Start_Druckjob( _
   ByVal Druckjobnr As Integer _
) As Boolean

Parameters

Druckjobnr
Required.

Source code

[Visual Basic]
    Private Function Start_Druckjob(ByVal Druckjobnr As Integer) As Boolean
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim remoteObj As EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07
            Dim Obj As Object
            Obj = Activator.GetObject( _
                        GetType(EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07), _
                        System.Configuration.ConfigurationSettings.AppSettings("RemoteObjUrl"))

            ' Auf das Remote-Objekt durch die Schnittstelle zugreifen.
            remoteObj = CType(Obj, EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07)
            remoteObj.GetDocBLPDF(Druckjobnr)
            Return True
        Catch ex As Exception
            MsgBox("Aufgrund des folgenden Fehlers konnte der Druckjob nicht gestartet werden:" + vbCrLf + vbCrLf + ex.Message, MsgBoxStyle.Critical)
            Return False
        Finally
            Me.Cursor = Cursors.Default
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.TVStatus_AfterSelect Method

Private Sub TVStatus_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TVStatus.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStatus_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TVStatus.AfterSelect
        Try
            Me.DokList.Columns("status").FilterText = Me.TVStatus.SelectedNode.Tag
        Catch ex As Exception

        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Timer1_Elapsed Method

Private Sub Timer1_Elapsed( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles Timer1.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles Timer1.Elapsed
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.Close()
            Case 1
                Me.Load_Auslieferungen()
            Case 2
                If Me.ToolBar1.Buttons(2).Pushed Then
                    Me.Timer1.Enabled = True
                Else
                    Me.Timer1.Enabled = False
                End If
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.Update_TVStatus Method

Private Sub Update_TVStatus()

Source code

[Visual Basic]
    Private Sub Update_TVStatus()
        Dim i As Integer
        Dim tn1 As New TreeNode()
        Dim tn As New TreeNode()
        Dim x As IList

        Dim TMPDT As New DataTable()
        Dim i1 As Integer
        TMPDT = Me.DokList.DataSource

        tn = Me.TVStatus.Nodes(0)
        tn.Tag = -1
        Me.TVStatus.Nodes.Clear()

        Dim totalvorbereitung As Integer
        Dim totalnachbearbeitung As Integer
        For i = 0 To TMPDT.Rows.Count - 1
            If TMPDT.Rows(i).Item("status") < 4 Then
                totalvorbereitung = totalvorbereitung + 1
            Else
                totalnachbearbeitung = totalnachbearbeitung + 1
            End If
        Next
        tn = Me.TVStatus.Nodes.Add("Alle Aushändigungen (" + LTrim(Str(totalvorbereitung + totalnachbearbeitung)) + ")")
        tn.Tag = ""
        tn = Me.TVStatus.Nodes.Add("Vorbereitung" + " (" + LTrim(Str(totalvorbereitung)) + ")")
        'tn.NodeFont = New System.Drawing.Font(Me.TVStatus.Font.FontFamily, Me.TVStatus.Font.Size, FontStyle.Bold)
        tn.Tag = -1
        For i = 0 To alstatus.Rows.Count - 1
            Dim tmpz As Integer = 0
            tmpz = 0
            For i1 = 0 To TMPDT.Rows.Count - 1
                If TMPDT.Rows(i1).Item("status") = alstatus.Rows(i).Item("auslieferungstatusnr") Then
                    tmpz = tmpz + 1
                End If
            Next
            If alstatus.Rows(i).Item("auslieferungstatusnr") = 4 Then
                tn = Me.TVStatus.Nodes.Add("Nachbereitung (" + LTrim(Str(totalnachbearbeitung)) + ")")
                '                If totalnachbearbeitung > 0 Then tn.NodeFont = New System.Drawing.Font(Me.TVStatus.Font.FontFamily, Me.TVStatus.Font.Size, FontStyle.Bold)
                tn.Tag = -1
            End If
            tn1 = tn.Nodes.Add(alstatus.Rows(i).Item("bezeichnung"))
            If tmpz > 0 Then
                tn1.Text = tn1.Text + " (" + LTrim(Str(tmpz)) + ")"
            End If
            tn1.SelectedImageIndex = 4
            tn1.ImageIndex = 0
            tn1.Tag = alstatus.Rows(i).Item("auslieferungstatusnr")
        Next
        Me.TVStatus.ExpandAll()
        Me.TVStatus.SelectedNode = Me.TVStatus.Nodes(0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.cbnl_SelectedIndexChanged Method

Private Sub cbnl_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbnl.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbnl_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbnl.SelectedIndexChanged
        If on_load = True Then Exit Sub
        Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.delete_aushaendigungsquittung Method

Private Function delete_aushaendigungsquittung( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Function delete_aushaendigungsquittung(ByVal alnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_delete_aushaendigungsquittung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.frmBLAuslieferungen_Closing Method

Private Sub frmBLAuslieferungen_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLAuslieferungen_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        '        Me.Hide()
        '        e.Cancel = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.frmBLAuslieferungen_Load Method

Private Sub frmBLAuslieferungen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLAuslieferungen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DokList.FetchRowStyles = True
        Me.DokList.FetchRowStyles = True

        Me.mcbnl = New MultiComboBox(Me.cbnl)
        Me.mcbnl.CheckNullValue = True
        Me.mcbnl.NullValueMessage = MyTxt.gettext(18)
        Me.mcbnl.DisplayColumnName = "nl"
        Me.mcbnl.ValueColumnName = "nlnr"
        Me.mcbnl.Fill_Data(Me.Get_nldata, False)

        Dim i As Integer
        Dim ii As Integer
        For i = 0 To mcbnl.Items.Count - 1
            mcbnl.SelectedIndex = i
            If mcbnl.SelectedValue = Me.NLFilter Then Exit For
        Next

        Load_Auslieferungen()
        Me.ToolBar1.Buttons(2).Pushed = False
        Me.Timer1.Enabled = False
        alstatus = Get_Auslieferungstatus()
        on_load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_bldokumente Method

Private Function get_bldokumente( _
   ByVal auslieferungnr As Integer _
) As DataTable

Parameters

auslieferungnr
Required.

Source code

[Visual Basic]
    Private Function get_bldokumente(ByVal auslieferungnr As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_get_dossierdokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_druckjob Method

Private Function get_druckjob( _
   ByVal auslieferungnr As Integer _
) As Integer

Parameters

auslieferungnr
Required.

Source code

[Visual Basic]
    Private Function get_druckjob(ByVal auslieferungnr As Integer) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_druckjob"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@druckjobnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@druckjobnr").Value
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_druckjob_parts Method

Private Function get_druckjob_parts() As DataTable

Source code

[Visual Basic]
    Private Function get_druckjob_parts() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_druckjobparts"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@alnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns(0).Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_druckjobstatus Method

Public Function get_druckjobstatus( _
   ByVal alnr As Integer _
) As Integer

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function get_druckjobstatus(ByVal alnr As Integer) As Integer
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_druckjobstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@status").Value
        Catch ex As Exception
            Return -1
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_parts Method

Public Function get_parts( _
   ByVal alnr As Integer _
) As Integer

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function get_parts(ByVal alnr As Integer) As Integer
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_druckjobparts_count"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@parts", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@parts").Value
        Catch ex As Exception
            Return -1
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.get_pdf Method

Private Function get_pdf( _
   ByVal alnr As Integer _
) As Boolean

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Function get_pdf(ByVal alnr As Integer) As Boolean
        'PDF-Dokument aus der Datenbank auslesen
        Me.Cursor = Cursors.WaitCursor
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * from edex_bl_druckjob where status=2 and auslieferungnr=" + LTrim(Str(alnr)), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)

            Dim MyData() As Byte
            MyData = myRow.Item("pdfdokument_aufbereitet")
            Dokumentfilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + LTrim(Str(myRow.Item(0))) + "_" + Format(Now, "yyyyMMddHHmmss" + ".PDF")
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(Dokumentfilename, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return True
        Catch ex As Exception
            Return False
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Me.Cursor = Cursors.Default
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.handlemenu Method

Private Sub handlemenu( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenu(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        PrintDocs(Me.DokList.Columns("dokumentid_quittung").Value, Me, Me.DokList.Columns(0).Value, part)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.handlemenunok Method

Private Sub handlemenunok( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenunok(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        Me.set_PrintNOK(Me.DokList.Columns(0).Value, part)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.handlemenuok Method

Private Sub handlemenuok( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenuok(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        Me.set_PrintOK(Me.DokList.Columns(0).Value, part)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.isstv Method

Public Function isstv( _
   ByVal manr As Integer, _
   ByVal partnernr As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

manr
Required.
partnernr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function isstv(ByVal manr As Integer, ByVal partnernr As Integer, ByVal dokumentid As String) As Boolean
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_isstv"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, manr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isstv", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@isstv").Value = 1 Then
                Return True
            Else
                Return False
            End If
        Catch ex As Exception
            Return -1
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuBLDossier_Click Method

Private Sub mnuBLDossier_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuBLDossier.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuBLDossier_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuBLDossier.Click
        Dim f As New frmBLDossier()
        f.NRPar00 = Me.DokList.Columns("NRPAR00").Value
        f.MdiParent = Me.MdiParent
        f.Profilnr = 0
        f.Auslieferungnr = Me.DokList.Columns(0).Value
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuDelete_Click Method

Private Sub mnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDelete.Click
        If Delete_Aushaendigung(Me.DokList.Columns(0).Value) Then
            Load_Auslieferungen()
            RaiseEvent evDossierAenderungen_Erfolgt()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuDruckAbbruch_Click Method

Private Sub mnuDruckAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckAbbruch.Click
        If stop_druckauftrag(Me.DokList.Columns(0).Value) Then Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuDruckArchiv_Click Method

Private Sub mnuDruckArchiv_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckArchiv.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckArchiv_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckArchiv.Click
        Print_And_Arch(Me.DokList.Columns("dokumentid_quittung").Value, Me, Me.DokList.Columns(0).Value)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuEdit_Click Method

Private Sub mnuEdit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuEdit.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuEdit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuEdit.Click
        EditDok(Me.DokList.Columns(0).Value)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuPrintOK_Click Method

Private Sub mnuPrintOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuPrintOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuPrintOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPrintOK.Click
        set_PrintOK(Me.DokList.Columns(0).Value, -1)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuShowDoc_Click Method

Private Sub mnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuShowDoc.Click
        ShowDoc(Me.DokList.Columns("dokumentid_quittung").Value, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuiAgain_Click Method

Private Sub mnuiAgain_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuAgain.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuiAgain_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuAgain.Click
        neuer_druckauftrag(Me.DokList.Columns(0).Value)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuprintall_Click Method

Private Sub mnuprintall_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuprintall.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuprintall_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuprintall.Click
        PrintDocs(Me.DokList.Columns("dokumentid_quittung").Value, Me, Me.DokList.Columns(0).Value, 0)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.mnuprintquittung_Click Method

Private Sub mnuprintquittung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuprintaq.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuprintquittung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuprintaq.Click
        PrintQuittung(Me.DokList.Columns("dokumentid_quittung").Value, Me, Me.DokList.Columns(0).Value)
        Me.Load_Auslieferungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.neuer_druckauftrag Method

Public Sub neuer_druckauftrag( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Sub neuer_druckauftrag(ByVal alnr As Integer)
        DruckThread = New Thread(AddressOf startdruckjob)
        Dim dt As New DataTable()
        dt = get_bldokumente(alnr)
        Dim druckjobnr As Integer = Create_Druckjob(alnr, dt, dt.Rows.Count)
        If druckjobnr > 0 Then
            intAushaendigungnr = alnr
            intDruckjobnr = druckjobnr
            intNeuerDruckauftrag = True
            Try
                If DruckThread.IsAlive Then
                    DruckThread.CurrentThread.Abort()
                End If
                DruckThread.Start()
                Thread.CurrentThread.Sleep(1000)
                Try
                    Dim f As New frmWatchJob(intDruckjobnr)
                    f.Visible = False
                    f.Hide()
                    f.Show()
                    f.Hide()
                Catch
                End Try
            Catch ex As Exception
                DruckThread.ResetAbort()
                DruckThread.Start()
                Thread.CurrentThread.Sleep(1000)
                Try
                    Dim f As New frmWatchJob(intDruckjobnr)
                    f.Visible = False
                    f.Hide()
                    f.Show()
                    f.Hide()
                Catch
                End Try
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.print_pdf Method

Private Sub print_pdf( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Sub print_pdf(ByVal alnr As Integer)
        Try
            Dim f As New frmPDFPrinter(True)
            f.addressBar.Text = Dokumentfilename
            f.alnr = alnr
            f.Show()
            Application.DoEvents()
            f.PrintPDF()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.set_PrintNOK Method

Public Sub set_PrintNOK( _
   ByVal alnr As Integer, _
   ByVal part As Integer _
)

Parameters

alnr
Required.
part
Required.

Source code

[Visual Basic]
    Public Sub set_PrintNOK(ByVal alnr As Integer, ByVal part As Integer)
        If get_parts(alnr) = 0 Or part = -1 Then
            Me.update_aushaendigungsquittung_status(alnr, 2)
            Me.set_druckjobstatus(alnr, 2)
        Else
            Me.set_druckjobstatus_part(alnr, part, 2)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.set_PrintOK Method

Public Sub set_PrintOK( _
   ByVal alnr As Integer, _
   ByVal part As Integer _
)

Parameters

alnr
Required.
part
Required.

Source code

[Visual Basic]
    Public Sub set_PrintOK(ByVal alnr As Integer, ByVal part As Integer)
        If get_parts(alnr) = 0 Or part = -1 Then
            Me.update_aushaendigungsquittung_status(alnr, 4)
            Me.set_druckjobstatus(alnr, 4)
            Me.set_quittung_bereit_zur_archivierung(alnr)
        Else
            If Me.set_druckjobstatus_part(alnr, part, 4) = 1 Then
                Me.update_aushaendigungsquittung_status(alnr, 4)
                Me.set_druckjobstatus(alnr, 4)
                Me.set_quittung_bereit_zur_archivierung(alnr)
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.set_druckjobstatus Method

Private Function set_druckjobstatus( _
   ByVal alnr As Integer, _
   ByVal status As Integer _
)

Parameters

alnr
Required.
status
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus(ByVal alnr As Integer, ByVal status As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_set_druckjobstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.set_druckjobstatus_part Method

Private Function set_druckjobstatus_part( _
   ByVal alnr As Integer, _
   ByVal part As Integer, _
   ByVal status As Integer _
) As Integer

Parameters

alnr
Required.
part
Required.
status
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus_part(ByVal alnr As Integer, ByVal part As Integer, ByVal status As Integer) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_set_druckjobstatus_part"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@part", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, part))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@return", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@return").Value
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.set_quittung_bereit_zur_archivierung Method

Private Function set_quittung_bereit_zur_archivierung( _
   ByVal auslieferungnr As Integer _
)

Parameters

auslieferungnr
Required.

Source code

[Visual Basic]
    Private Function set_quittung_bereit_zur_archivierung(ByVal auslieferungnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_quittung_bza"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.startdruckjob Method

Private Sub startdruckjob()

Source code

[Visual Basic]
    Private Sub startdruckjob()
        If Start_Druckjob(intDruckjobnr) = True Then
            update_aushaendigungsquittung_status(intAushaendigungnr, 1)
            RaiseEvent evDossierAenderungen_Erfolgt()
        Else
            If intNeuerDruckauftrag = False Then
                Delete_Druckjob(intDruckjobnr)
                update_aushaendigungsquittung_status(intAushaendigungnr, 0)
                Try
                    RaiseEvent evDossierAenderungen_Erfolgt()
                Catch
                End Try
            End If
        End If
        Try
            DruckThread.Abort()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.stop_druckauftrag Method

Public Function stop_druckauftrag( _
   ByVal alnr As Integer _
) As Boolean

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function stop_druckauftrag(ByVal alnr As Integer) As Boolean
        Try
            Try
                If Me.DruckThread.IsAlive Then
                    Me.DruckThread.Abort()
                End If
            Catch
            End Try
            Dim druckjobnr As Integer
            druckjobnr = get_druckjob(alnr)
            Me.Delete_Druckjob(druckjobnr)
            update_aushaendigungsquittung_status(alnr, 0)
            Return True
        Catch
                Return False
            End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.update_aushaendigungsquittung_status Method

Private Function update_aushaendigungsquittung_status( _
   ByVal auslieferungnr As Integer, _
   ByVal status As Integer _
)

Parameters

auslieferungnr
Required.
status
Required.

Source code

[Visual Basic]
    Private Function update_aushaendigungsquittung_status(ByVal auslieferungnr As Integer, ByVal status As Integer)

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_aushaendigungsquittung_update_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen.update_bldokument Method

Private Function update_bldokument( _
   ByVal art As Integer, _
   ByVal dokumentid As String, _
   ByVal auslieferungnr As Integer _
)

Parameters

art
Required.
dokumentid
Required.
auslieferungnr
Required.

Source code

[Visual Basic]
    Private Function update_bldokument(ByVal art As Integer, ByVal dokumentid As String, ByVal auslieferungnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_update_auslieferungnr"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@art", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, art))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen Events

frmBLAuslieferungen overview

Events

event evDossierAenderungen_Erfolgt

See Also

frmBLAuslieferungen Class


evDossierAenderungen_Erfolgt Event

Public Event evDossierAenderungen_Erfolgt()

Source code

[Visual Basic]
    Public Event evDossierAenderungen_Erfolgt()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLAuslieferungen Fields

frmBLAuslieferungen overview

Fields

field BtnHelp
field ContextMenu1
field DokList
field Dokumentfilename
field DruckThread
field GroupBox1
field ImageList1
field ImgListSteuerung
field MenuItem1
field MenuItem3
field MenuItem6
field MenuItem9
field MnuDruck
field MnuPrintBestaetigen
field MnuStatusZurueck
field NLFilter
field Panel1
field TVStatus
field Timer1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field alstatus
field cbnl
field components
field dtnl
field intAushaendigungnr
field intDruckjobnr
field intNeuerDruckauftrag
field mcbnl
field mnuAgain
field mnuAuslieferungen
field mnuBLDossier
field mnuDelete
field mnuDruckAbbruch
field mnuDruckArchiv
field mnuEdit
field mnuPrintNOK
field mnuPrintOK
field mnuShowDoc
field mnuprintall
field mnuprintaq
field on_load
field pnlNiederlassung

See Also

frmBLAuslieferungen Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


Dokumentfilename Variable

Dim Dokumentfilename As String = ""

Source code

[Visual Basic]
    Dim Dokumentfilename As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


DruckThread Variable

Dim DruckThread As Thread

Source code

[Visual Basic]
    Dim DruckThread As Thread

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ImgListSteuerung Variable

Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MnuDruck Variable

Friend WithEvents MnuDruck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDruck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MnuPrintBestaetigen Variable

Friend WithEvents MnuPrintBestaetigen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintBestaetigen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


MnuStatusZurueck Variable

Friend WithEvents MnuStatusZurueck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuStatusZurueck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


NLFilter Variable

Dim NLFilter As Integer

Source code

[Visual Basic]
    Dim NLFilter As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


TVStatus Variable

Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


Timer1 Variable

Friend WithEvents Timer1 As System.Timers.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Timers.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


alstatus Variable

Dim alstatus As New DataTable()

Source code

[Visual Basic]
    Dim alstatus As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


cbnl Variable

Friend WithEvents cbnl As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbnl As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


dtnl Variable

Dim dtnl As New DataTable()

Source code

[Visual Basic]
    Dim dtnl As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


intAushaendigungnr Variable

Dim intAushaendigungnr As Integer

Source code

[Visual Basic]
    Dim intAushaendigungnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


intDruckjobnr Variable

Dim intDruckjobnr As Integer = 0

Source code

[Visual Basic]
    Dim intDruckjobnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


intNeuerDruckauftrag Variable

Dim intNeuerDruckauftrag As Boolean = False

Source code

[Visual Basic]
    Dim intNeuerDruckauftrag As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mcbnl Variable

Dim WithEvents mcbnl As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbnl As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuAgain Variable

Friend WithEvents mnuAgain As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAgain As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuAuslieferungen Variable

Friend WithEvents mnuAuslieferungen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAuslieferungen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuBLDossier Variable

Friend WithEvents mnuBLDossier As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuBLDossier As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuDelete Variable

Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuDruckAbbruch Variable

Friend WithEvents mnuDruckAbbruch As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckAbbruch As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuDruckArchiv Variable

Friend WithEvents mnuDruckArchiv As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckArchiv As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuEdit Variable

Friend WithEvents mnuEdit As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuEdit As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuPrintNOK Variable

Friend WithEvents mnuPrintNOK As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuPrintNOK As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuPrintOK Variable

Friend WithEvents mnuPrintOK As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuPrintOK As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuShowDoc Variable

Friend WithEvents mnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuprintall Variable

Friend WithEvents mnuprintall As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuprintall As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


mnuprintaq Variable

Friend WithEvents mnuprintaq As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuprintaq As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


on_load Variable

Dim on_load As Boolean = True

Source code

[Visual Basic]
    Dim on_load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


pnlNiederlassung Variable

Friend WithEvents pnlNiederlassung As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlNiederlassung As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLAuslieferungen


frmBLDatumab Class

For a list of all members of this type, see frmBLDatumab Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLDatumab

Public Class frmBLDatumab
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLDatumab Members


frmBLDatumab Members

frmBLDatumab overview

Constructors

constructor frmBLDatumab Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent

Fields

field Button1
field Button2
field DateTimePicker1
field Label1
field Label2
field components

See Also

frmBLDatumab Class


frmBLDatumab Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDatumab Methods

frmBLDatumab overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent

See Also

frmBLDatumab Class


frmBLDatumab.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDatumab.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDatumab.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDatumab.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBLDatumab))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(280, 48)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Der Kunde hatte bis jetzt noch keine Auslieferung, welche mittels EDOKA-Funktiona" & _
        "lität durchgeführt wurde."
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(6, 56)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(280, 48)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Geben Sie bitte das Ab-Datum ein"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(192, 56)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker1.TabIndex = 2
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(216, 112)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "OK"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(8, 112)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'frmBLDatumab
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(292, 141)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.DateTimePicker1, Me.Label2, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmBLDatumab"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Banklagernd-Dokumente ab"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDatumab Fields

frmBLDatumab overview

Fields

field Button1
field Button2
field DateTimePicker1
field Label1
field Label2
field components

See Also

frmBLDatumab Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDatumab


frmBLDossier Class

For a list of all members of this type, see frmBLDossier Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLDossier

Public Class frmBLDossier
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLDossier Members


frmBLDossier Members

frmBLDossier overview

Constructors

constructor frmBLDossier Constructor

Properties

property Auslieferungnr |
property NRPar00 | Property NRPAR00 - enthält die Partnernr
property Partnerkurzbezeichnung |
property Profilnr |

Methods

method BLDossier_Load
method BtnHelp_Click
method ContextMenu1_Popup
method Dispose
method DokList_FetchRowStyle
method DokList_MouseDown
method Generic_Select
method InitializeComponent
method Load_Data
method MNUStatuszurueck_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem6_Click
method MnuIndexInfo_Click
method MnuPartnerdossier_Click
method MnuPrintNOK_Click
method MnuShow_Click
method MnuZuweisung_Click
method Searchnode1
method TDokart_AfterSelect
method TDokart_MouseUp
method ToolBar1_ButtonClick
method TranverseNodes1
method check_blv
method ctmenuTVDossier_Popup
method frmBLDossier_Resize
method get_Dokumente
method get_auslieferungen_des_partners
method get_druckjob_parts
method get_nodedata
method get_partnerkurzebezeichnung
method get_standardprofil
method handlemenu
method handlemenunok
method handlemenuok
method mnuAgain_Click
method mnuDelete_Click
method mnuDruckAbbruch_Click
method mnuDruckArchiv_Click
method mnuEdit_Click
method mnuPrintOK_Click
method mnuPrint_Click
method mnuShowDoc_Click
method mnu_mfDruck_Click
method tvdossier_AfterSelect
method tvdossier_MouseDown
method tvdossier_MouseUp

Fields

field BtnHelp |
field ContextMenu1 |
field DokList |
field GrpDossier |
field ImageList1 |
field ImgListSteuerung |
field IntDT | Interne Datatable
field MNUStatuszurueck |
field M_Nrpar00 | Variable für das Property NRPAR00
field MenuItem3 |
field MenuItem4 |
field MenuItem7 |
field MenuItem9 |
field MnuDruck |
field MnuIndexInfo |
field MnuPartnerdossier |
field MnuPrintAQ |
field MnuPrintAll |
field MnuPrintBestaetigen |
field MnuPrintNOK |
field MnuPrintOK |
field MnuShow |
field MnuZuweisung |
field TDokart |
field ToolBar1 |
field btnDruck |
field btnblkparameter |
field btnblvzuweisung |
field btnexit |
field btnfilter |
field btnrefresh |
field components |
field ctmenuTVDossier |
field doupdate |
field doupdate1 |
field found |
field foundnode |
field frmbla |
field m_Partnerkurzbezeichnung |
field m_Profilnr |
field m_auslieferungnr |
field mnuAgain |
field mnuAuslieferungen |
field mnuDelete |
field mnuDruckAbbruch |
field mnuDruckArchiv |
field mnuEdit |
field mnuPrint |
field mnuShowDoc |
field mnu_mfDruck |
field pnlleft |
field pnltree |
field savetag |
field selectPoint |
field tnalnr |
field tndokid |
field tnstatus |
field tvdossier |

See Also

frmBLDossier Class


frmBLDossier Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier Properties

frmBLDossier overview

Properties

property Auslieferungnr |
property NRPar00 | Property NRPAR00 - enthält die Partnernr
property Partnerkurzbezeichnung |
property Profilnr |

See Also

frmBLDossier Class


frmBLDossier.Auslieferungnr Property

Property Auslieferungnr() As Integer

Source code

[Visual Basic]
    Property Auslieferungnr() As Integer
        Get
            Return m_auslieferungnr
        End Get
        Set(ByVal Value As Integer)
            m_auslieferungnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.NRPar00 Property

Property NRPAR00 - enthält die Partnernr

Property NRPar00() As Integer

Source code

[Visual Basic]
    Property NRPar00() As Integer
        Get
            Return M_Nrpar00
        End Get
        Set(ByVal Value As Integer)
            M_Nrpar00 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Partnerkurzbezeichnung Property

Property Partnerkurzbezeichnung() As String

Source code

[Visual Basic]
    Property Partnerkurzbezeichnung() As String
        Get
            Return m_Partnerkurzbezeichnung
        End Get
        Set(ByVal Value As String)
            m_Partnerkurzbezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Profilnr Property

Property Profilnr() As Integer

Source code

[Visual Basic]
    Property Profilnr() As Integer
        Get
            Return m_Profilnr
        End Get
        Set(ByVal Value As Integer)
            m_Profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier Methods

frmBLDossier overview

Methods

method BLDossier_Load
method BtnHelp_Click
method ContextMenu1_Popup
method Dispose
method DokList_FetchRowStyle
method DokList_MouseDown
method Generic_Select
method InitializeComponent
method Load_Data
method MNUStatuszurueck_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem6_Click
method MnuIndexInfo_Click
method MnuPartnerdossier_Click
method MnuPrintNOK_Click
method MnuShow_Click
method MnuZuweisung_Click
method Searchnode1
method TDokart_AfterSelect
method TDokart_MouseUp
method ToolBar1_ButtonClick
method TranverseNodes1
method check_blv
method ctmenuTVDossier_Popup
method frmBLDossier_Resize
method get_Dokumente
method get_auslieferungen_des_partners
method get_druckjob_parts
method get_nodedata
method get_partnerkurzebezeichnung
method get_standardprofil
method handlemenu
method handlemenunok
method handlemenuok
method mnuAgain_Click
method mnuDelete_Click
method mnuDruckAbbruch_Click
method mnuDruckArchiv_Click
method mnuEdit_Click
method mnuPrintOK_Click
method mnuPrint_Click
method mnuShowDoc_Click
method mnu_mfDruck_Click
method tvdossier_AfterSelect
method tvdossier_MouseDown
method tvdossier_MouseUp

See Also

frmBLDossier Class


frmBLDossier.BLDossier_Load Method

Private Sub BLDossier_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BLDossier_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Me.Profilnr = 0 Then
            Me.Profilnr = get_standardprofil()
        End If
        Me.Text = Me.Text + Me.get_partnerkurzebezeichnung
        Me.TDokart.ExpandAll()
        Load_Data()
        Dim x As New TreeNode()
        If Me.Auslieferungnr <> 0 Then
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            Me.Searchnode1(Me.tvdossier, Me.Auslieferungnr, 0)
            If Me.found = True Then Me.tvdossier.SelectedNode = Me.foundnode
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("banklagernddossier")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try
            If Me.btnDruck.Visible = False Then
                mnuPrint.Enabled = False
                MenuItem7.Enabled = False
            Else
                mnuPrint.Enabled = True
                MenuItem7.Enabled = True
            End If
            If Me.DokList.Splits(0).Rows.Count = 0 Then
                Me.MnuShow.Enabled = False
                Me.MnuPartnerdossier.Enabled = False
                Me.MnuIndexInfo.Enabled = False
            Else
                Me.MnuShow.Enabled = True
                Me.MnuPartnerdossier.Enabled = True
                Me.MnuIndexInfo.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.DokList_FetchRowStyle Method

Private Sub DokList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle
        Try
            If Me.DokList.Columns("auslieferungnr").CellValue(e.Row) > 0 Then
                e.CellStyle.ForeColor = System.Drawing.Color.Blue
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_suchprofil_get_partner"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "EDOKA"))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))

                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "HOST"))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("NRPAR00").Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))

                Case Else
            End Select
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBLDossier))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnexit = New System.Windows.Forms.ToolBarButton()
        Me.btnDruck = New System.Windows.Forms.ToolBarButton()
        Me.btnblkparameter = New System.Windows.Forms.ToolBarButton()
        Me.btnblvzuweisung = New System.Windows.Forms.ToolBarButton()
        Me.btnrefresh = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuShow = New System.Windows.Forms.MenuItem()
        Me.MnuPartnerdossier = New System.Windows.Forms.MenuItem()
        Me.MnuIndexInfo = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.mnuPrint = New System.Windows.Forms.MenuItem()
        Me.MnuZuweisung = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.mnu_mfDruck = New System.Windows.Forms.MenuItem()
        Me.pnlleft = New System.Windows.Forms.Panel()
        Me.GrpDossier = New System.Windows.Forms.GroupBox()
        Me.tvdossier = New System.Windows.Forms.TreeView()
        Me.ctmenuTVDossier = New System.Windows.Forms.ContextMenu()
        Me.MnuDruck = New System.Windows.Forms.MenuItem()
        Me.MnuPrintAll = New System.Windows.Forms.MenuItem()
        Me.MnuPrintAQ = New System.Windows.Forms.MenuItem()
        Me.MnuPrintBestaetigen = New System.Windows.Forms.MenuItem()
        Me.MnuPrintOK = New System.Windows.Forms.MenuItem()
        Me.MnuPrintNOK = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.mnuAgain = New System.Windows.Forms.MenuItem()
        Me.mnuDruckAbbruch = New System.Windows.Forms.MenuItem()
        Me.MNUStatuszurueck = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.mnuAuslieferungen = New System.Windows.Forms.MenuItem()
        Me.mnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.mnuEdit = New System.Windows.Forms.MenuItem()
        Me.mnuDruckArchiv = New System.Windows.Forms.MenuItem()
        Me.mnuDelete = New System.Windows.Forms.MenuItem()
        Me.ImgListSteuerung = New System.Windows.Forms.ImageList(Me.components)
        Me.pnltree = New System.Windows.Forms.Panel()
        Me.TDokart = New System.Windows.Forms.TreeView()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.btnfilter = New System.Windows.Forms.Button()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlleft.SuspendLayout()
        Me.GrpDossier.SuspendLayout()
        Me.pnltree.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnexit, Me.btnDruck, Me.btnblkparameter, Me.btnblvzuweisung, Me.btnrefresh})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(960, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnexit
        '
        Me.btnexit.ImageIndex = 0
        '
        'btnDruck
        '
        Me.btnDruck.ImageIndex = 11
        Me.btnDruck.ToolTipText = "Aushändigung erstellen"
        '
        'btnblkparameter
        '
        Me.btnblkparameter.ImageIndex = 12
        Me.btnblkparameter.ToolTipText = "Periodische Aushändigung verwalten"
        '
        'btnblvzuweisung
        '
        Me.btnblvzuweisung.ImageIndex = 1
        '
        'btnrefresh
        '
        Me.btnrefresh.ImageIndex = 10
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(230, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(730, 484)
        Me.DokList.TabIndex = 26
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" DefRecSelWid" & _
        "th=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 726," & _
        " 480</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 726, " & _
        "480</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuShow, Me.MnuPartnerdossier, Me.MnuIndexInfo, Me.MenuItem4, Me.mnuPrint, Me.MnuZuweisung, Me.MenuItem7, Me.mnu_mfDruck})
        '
        'MnuShow
        '
        Me.MnuShow.Index = 0
        Me.MnuShow.Text = "&Dokument aus Partnerdossier anzeigen"
        '
        'MnuPartnerdossier
        '
        Me.MnuPartnerdossier.Index = 1
        Me.MnuPartnerdossier.Text = "&Partnerdossier öffnen"
        '
        'MnuIndexInfo
        '
        Me.MnuIndexInfo.Index = 2
        Me.MnuIndexInfo.Text = "Dokumentinformationen anzeigen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "-"
        '
        'mnuPrint
        '
        Me.mnuPrint.Index = 4
        Me.mnuPrint.Text = "&Banklagernd-Dossier ausdrucken"
        '
        'MnuZuweisung
        '
        Me.MnuZuweisung.Index = 5
        Me.MnuZuweisung.Text = "Dossier an BLV &zusweisen"
        Me.MnuZuweisung.Visible = False
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 6
        Me.MenuItem7.Text = "&Aushändigung löschen"
        Me.MenuItem7.Visible = False
        '
        'mnu_mfDruck
        '
        Me.mnu_mfDruck.Index = 7
        Me.mnu_mfDruck.Text = "&Dokument(e) drucken"
        '
        'pnlleft
        '
        Me.pnlleft.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpDossier, Me.pnltree})
        Me.pnlleft.Dock = System.Windows.Forms.DockStyle.Left
        Me.pnlleft.Location = New System.Drawing.Point(0, 25)
        Me.pnlleft.Name = "pnlleft"
        Me.pnlleft.Size = New System.Drawing.Size(230, 484)
        Me.pnlleft.TabIndex = 27
        '
        'GrpDossier
        '
        Me.GrpDossier.Controls.AddRange(New System.Windows.Forms.Control() {Me.tvdossier})
        Me.GrpDossier.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpDossier.Location = New System.Drawing.Point(0, 216)
        Me.GrpDossier.Name = "GrpDossier"
        Me.GrpDossier.Size = New System.Drawing.Size(230, 268)
        Me.GrpDossier.TabIndex = 1
        Me.GrpDossier.TabStop = False
        Me.GrpDossier.Text = "Aushändigungen"
        '
        'tvdossier
        '
        Me.tvdossier.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.tvdossier.ContextMenu = Me.ctmenuTVDossier
        Me.tvdossier.Dock = System.Windows.Forms.DockStyle.Fill
        Me.tvdossier.ImageList = Me.ImgListSteuerung
        Me.tvdossier.Location = New System.Drawing.Point(3, 16)
        Me.tvdossier.Name = "tvdossier"
        Me.tvdossier.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Vollständiges Dossier", 0, 4, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Dokumente ohne Aushändigung", 0, 4), New System.Windows.Forms.TreeNode("Dokumente mit Aushändigung", 0, 4)})})
        Me.tvdossier.Size = New System.Drawing.Size(224, 249)
        Me.tvdossier.TabIndex = 0
        '
        'ctmenuTVDossier
        '
        Me.ctmenuTVDossier.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDruck, Me.MnuPrintBestaetigen, Me.MenuItem3, Me.mnuAgain, Me.mnuDruckAbbruch, Me.MNUStatuszurueck, Me.MenuItem9, Me.mnuAuslieferungen, Me.mnuDelete})
        '
        'MnuDruck
        '
        Me.MnuDruck.Index = 0
        Me.MnuDruck.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuPrintAll, Me.MnuPrintAQ})
        Me.MnuDruck.Text = "Dokumente ausdrucken"
        '
        'MnuPrintAll
        '
        Me.MnuPrintAll.Index = 0
        Me.MnuPrintAll.Text = "Aushändigungs-Quittung und Dokumente"
        '
        'MnuPrintAQ
        '
        Me.MnuPrintAQ.Index = 1
        Me.MnuPrintAQ.Text = "Nur Aushändigungs-Quittung"
        '
        'MnuPrintBestaetigen
        '
        Me.MnuPrintBestaetigen.Index = 1
        Me.MnuPrintBestaetigen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuPrintOK, Me.MnuPrintNOK})
        Me.MnuPrintBestaetigen.Text = "Ausdruck bestätigen"
        '
        'MnuPrintOK
        '
        Me.MnuPrintOK.Index = 0
        Me.MnuPrintOK.Text = "Erfolgreich"
        '
        'MnuPrintNOK
        '
        Me.MnuPrintNOK.Index = 1
        Me.MnuPrintNOK.Text = "Nicht erfolgreich"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'mnuAgain
        '
        Me.mnuAgain.Index = 3
        Me.mnuAgain.Text = "Dokumente neu aufbereiten"
        '
        'mnuDruckAbbruch
        '
        Me.mnuDruckAbbruch.Index = 4
        Me.mnuDruckAbbruch.Text = "Druck&auftrag abbrechen"
        '
        'MNUStatuszurueck
        '
        Me.MNUStatuszurueck.Index = 5
        Me.MNUStatuszurueck.Text = "Aushändigungsstatus zurücksetzen"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 6
        Me.MenuItem9.Text = "-"
        '
        'mnuAuslieferungen
        '
        Me.mnuAuslieferungen.Index = 7
        Me.mnuAuslieferungen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuShowDoc, Me.mnuEdit, Me.mnuDruckArchiv})
        Me.mnuAuslieferungen.Text = "Aushändigungs-Quittung"
        '
        'mnuShowDoc
        '
        Me.mnuShowDoc.Index = 0
        Me.mnuShowDoc.Text = "Anzeigen"
        '
        'mnuEdit
        '
        Me.mnuEdit.Index = 1
        Me.mnuEdit.Text = "Bearbeiten"
        '
        'mnuDruckArchiv
        '
        Me.mnuDruckArchiv.Index = 2
        Me.mnuDruckArchiv.Text = "Drucken"
        '
        'mnuDelete
        '
        Me.mnuDelete.Index = 8
        Me.mnuDelete.Text = "Aushändigung löschen"
        '
        'ImgListSteuerung
        '
        Me.ImgListSteuerung.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImgListSteuerung.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImgListSteuerung.ImageStream = CType(resources.GetObject("ImgListSteuerung.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListSteuerung.TransparentColor = System.Drawing.Color.Transparent
        '
        'pnltree
        '
        Me.pnltree.Controls.AddRange(New System.Windows.Forms.Control() {Me.TDokart})
        Me.pnltree.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnltree.Name = "pnltree"
        Me.pnltree.Size = New System.Drawing.Size(230, 216)
        Me.pnltree.TabIndex = 0
        '
        'TDokart
        '
        Me.TDokart.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.TDokart.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TDokart.ImageList = Me.ImgListSteuerung
        Me.TDokart.Name = "TDokart"
        Me.TDokart.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Banklagernd-Dossier", 0, 4, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("EDOKA-Verträge", 0, 4), New System.Windows.Forms.TreeNode("EDOKA-BCK-Dokumente", 0, 4), New System.Windows.Forms.TreeNode("EDOKA-Korrespondenz", 0, 4), New System.Windows.Forms.TreeNode("HOST-Dokumente", 0, 4)})})
        Me.TDokart.Size = New System.Drawing.Size(230, 216)
        Me.TDokart.TabIndex = 2
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(936, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 68
        '
        'btnfilter
        '
        Me.btnfilter.FlatStyle = System.Windows.Forms.FlatStyle.Flat
        Me.btnfilter.ForeColor = System.Drawing.SystemColors.Control
        Me.btnfilter.Image = CType(resources.GetObject("btnfilter.Image"), System.Drawing.Bitmap)
        Me.btnfilter.Location = New System.Drawing.Point(908, 2)
        Me.btnfilter.Name = "btnfilter"
        Me.btnfilter.Size = New System.Drawing.Size(24, 23)
        Me.btnfilter.TabIndex = 69
        '
        'frmBLDossier
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(960, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnfilter, Me.BtnHelp, Me.DokList, Me.pnlleft, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmBLDossier"
        Me.Text = "Banklagernd-Dossier: "
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlleft.ResumeLayout(False)
        Me.GrpDossier.ResumeLayout(False)
        Me.pnltree.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Load_Data Method

Private Sub Load_Data()

Source code

[Visual Basic]
    Private Sub Load_Data()
        Me.DokList.Enabled = False
        IntDT = get_Dokumente()
        Me.DokList.DataSource = IntDT
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")

        'Check, ob der angemeldete Benutzer Banklagernd-Verantwortlicher ist und den Kunden bearbeiten darf
        Select Case check_blv()
            Case 0
                Me.ToolBar1.Buttons(1).Visible = False
                Me.ToolBar1.Buttons(2).Visible = False
                Me.ToolBar1.Buttons(3).Visible = False
            Case 1
                Me.ToolBar1.Buttons(1).Visible = True
                Me.ToolBar1.Buttons(2).Visible = True
                Me.ToolBar1.Buttons(3).Visible = False
            Case 2
                Me.ToolBar1.Buttons(1).Visible = False
                Me.ToolBar1.Buttons(2).Visible = False
                Me.ToolBar1.Buttons(3).Visible = True
        End Select
        Me.TDokart.SelectedNode = Me.TDokart.Nodes(0)

        Me.tvdossier.BeginUpdate()
        Me.tvdossier.Nodes.Clear()

        'Auslieferungen des Kunden auslesen
        Dim al As New DataTable()
        Dim tn As New TreeNode()
        Dim tn1 As New TreeNode()
        tn = Me.tvdossier.Nodes.Add("Vollständiges Dossier")
        tn.Tag = "System : -1"
        tn.SelectedImageIndex = 4
        tn.ImageIndex = 0
        tn1 = tn.Nodes.Add("nicht ausgehändigt")
        tn1.Tag = "System : -2"
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 0
        tn1 = tn.Nodes.Add("Aushändigungen")
        tn1.Tag = "System : -3"
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 0
        al = get_auslieferungen_des_partners()
        Dim dt As New DateTime()
        Dim i As Integer
        Dim s As String
        For i = 0 To al.Rows.Count - 1
            dt = al.Rows(i).Item("mutiert_am")
            tn = tn1.Nodes.Add(Format(dt, "dd.MM.yy") + " " + al.Rows(i).Item("Statusbezeichnung") + " (" + al.Rows(i).Item("blv") + ")")
            '            tn = tn1.Nodes.Add(dt.ToShortDateString + " " + al.Rows(i).Item("Statusbezeichnung"))
            tn.Tag = LTrim(Str(al.Rows(i).Item("AUSLIEFERUNGNR"))) + ":" + LTrim(Str(al.Rows(i).Item("status")) + ":" + al.Rows(i).Item("dokumentid_quittung"))
            tn.ImageIndex = 0
            tn.SelectedImageIndex = 4
        Next
        Try
            Me.tvdossier.SelectedNode = Me.tvdossier.Nodes(0)
        Catch
        End Try
        Me.tvdossier.ExpandAll()
        DivFnkt.Searchnode(Me.tvdossier, Me.savetag, 4)
        If DivFnkt.found Then
            Try
                Me.tvdossier.SelectedNode = DivFnkt.FoundNode
                Me.tvdossier.SelectedNode.ExpandAll()
            Catch
            End Try

        End If
        Me.DokList.Enabled = True
        Me.tvdossier.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MNUStatuszurueck_Click Method

Private Sub MNUStatuszurueck_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MNUStatuszurueck.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MNUStatuszurueck_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MNUStatuszurueck.Click
        frmbla.Aushaendigungsstatus_zuruecksetzen(Me.tnalnr)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDruck.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDruck.Click
        '        frmbla.PrintDocs(Me.tndokid, Me, Me.tnalnr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuPrintAll.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuPrintAll.Click
        frmbla.PrintDocs(Me.tndokid, Me, Me.tnalnr, 0)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuPrintAQ.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuPrintAQ.Click
        frmbla.PrintQuittung(Me.tndokid, Me, Me.tnalnr)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MnuIndexInfo_Click Method

Private Sub MnuIndexInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuIndexInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuIndexInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuIndexInfo.Click
        If Microsoft.VisualBasic.Left(Me.DokList.Columns("dokumentid").Value, 6) = "OFFEDK" Then
            Dim f As New frmDokumentinformationen(Me.DokList.Columns("dokumentid").Value, 0)
            f.ShowDialog()
        Else
            Dim f As New frmDokumentinformationen(Me.DokList.Columns("dokumentid").Value, 1)
            f.ShowDialog()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MnuPartnerdossier_Click Method

Private Sub MnuPartnerdossier_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuPartnerdossier.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuPartnerdossier_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuPartnerdossier.Click
        Try
            Dim ityp As Integer
            If Me.DokList.Columns("dokumentid").Text.Substring(0, 6) = "OFFEDK" Then
                ityp = 1
            Else
                ityp = 2
            End If
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim dokumentid As String = ""
            Dim t As DataTable
            dokumentid = Me.DokList.Columns("dokumentid").Text
            t = Generic_Select(ityp)
            If t.Rows.Count > 0 Then
                Globals.profilnr = 0
                Dim f As New frmTrefferliste()
                f.MdiParent = Me.MdiParent
                f.Show()
                f.Partner_Eingegeben = True
                f.txtnrpar00.Text = (t.Rows(0).Item("NRPAR00"))
                f.refresh_list()
                If ityp = 2 Then
                    f.Refresh_All(True)
                    DivFnkt.Searchnode(f.tvstruktur, " " + f.txtnrpar00.Text + "-" + Str(998), 99)
                    If DivFnkt.found Then
                        f.tvstruktur.SelectedNode = DivFnkt.FoundNode
                        f.Update_Partnerstruktur()
                        f.tvstruktur.SelectedNode.ExpandAll()
                    End If
                End If
                f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))
                Me.Cursor = System.Windows.Forms.Cursors.Default
                Exit Sub
            End If
        Catch ex As Exception
            MsgBox("Das Anzeigen des Partnerdossiers ist fehlgeschlagen.")
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MnuPrintNOK_Click Method

Private Sub MnuPrintNOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuPrintNOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuPrintNOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuPrintNOK.Click
        Me.frmbla.set_PrintNOK(Me.tnalnr, 0)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MnuShow_Click Method

Private Sub MnuShow_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShow.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShow_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShow.Click
        If UCase(Microsoft.VisualBasic.Left(Me.DokList.Columns("dokumentid").Value, 6)) = "OFFEDK" Then
            DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me)
        Else
            Dim s As String
            s = Me.DokList.Columns("nrpar00").Text
            While Len(s) < 9
                s = "0" + s
            End While
            DivFnkt.Erstellungsdatum = Me.DokList.Columns("Erstelltam").Text
            DivFnkt.Belegart = "HOST"
            DivFnkt.ShowColdDocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, s, _
            s, Me.DokList.Columns("dokumenttyp").Text)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.MnuZuweisung_Click Method

Private Sub MnuZuweisung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuZuweisung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuZuweisung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuZuweisung.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.Searchnode1 Method

Public Function Searchnode1( _
   ByVal tv As TreeView, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
    Public Function Searchnode1(ByVal tv As TreeView, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
        Searchnode1 = False
        found = False
        Dim nodeX As TreeNode
        For Each nodeX In tv.Nodes
            If TranverseNodes1(tv, nodeX, SearchObject, imageindex) Then
                Exit Function
            End If
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.TDokart_AfterSelect Method

Private Sub TDokart_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TDokart.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TDokart_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TDokart.AfterSelect
        Try
            Select Case Me.TDokart.SelectedNode.Text
                Case "Banklagernd-Dossier"
                    Me.DokList.Columns("dokumentart").FilterText = ""
                Case "EDOKA-Verträge"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-Verträge"
                Case "EDOKA-BCK-Dokumente"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-BCK-Dokumente"
                Case "EDOKA-Korrespondenz"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-Korrespondenz"
                Case "HOST-Dokumente"
                    Me.DokList.Columns("dokumentart").FilterText = "HOST-Dokumente"
            End Select
            doupdate = False
            If Me.doupdate1 = True Then Me.tvdossier.SelectedNode = Me.tvdossier.Nodes(0)
            doupdate = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.TDokart_MouseUp Method

Private Sub TDokart_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TDokart.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TDokart_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TDokart.MouseUp
        Try
            Select Case Me.TDokart.SelectedNode.Text
                Case "Banklagernd-Dossier"
                    Me.DokList.Columns("dokumentart").FilterText = ""
                Case "EDOKA-Verträge"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-Verträge"
                Case "EDOKA-BCK-Dokumente"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-BCK-Dokumente"
                Case "EDOKA-Korrespondenz"
                    Me.DokList.Columns("dokumentart").FilterText = "EDOKA-Korrespondenz"
                Case "HOST-Dokumente"
                    Me.DokList.Columns("dokumentart").FilterText = "HOST-Dokumente"
            End Select
            doupdate = False
            If Me.doupdate1 = True Then Me.tvdossier.SelectedNode = Me.tvdossier.Nodes(0)
            doupdate = True
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.Close()
            Case 1
                Me.mnuPrint_Click(sender, e)
            Case 2
                Dim f As New frmblkundenparameter()
                f.txtPartner.Text = Me.Partnerkurzbezeichnung
                f.NRPar00 = Me.NRPar00
                f.ShowDialog()
            Case 3
                Dim f As New frmBLDossierzuweisen()
                f.ShowDialog()
                f.Dispose()
            Case 4
                Load_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.TranverseNodes1 Method

Private Function TranverseNodes1( _
   ByVal tv As TreeView, _
   ByVal selectedNode As TreeNode, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
selectedNode
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
    Private Function TranverseNodes1(ByVal tv As TreeView, ByVal selectedNode As TreeNode, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
        Dim nodeX As TreeNode
        Dim s As String
        For Each nodeX In selectedNode.Nodes
            Try
                If Microsoft.VisualBasic.Left(nodeX.Tag, Len(SearchObject.ToString)) = SearchObject Then
                    nodeX.Expand()
                    Me.foundnode = nodeX
                    found = True
                    TranverseNodes1 = True
                    Exit Function
                Else
                    TranverseNodes1(tv, nodeX, SearchObject, imageindex)
                End If
            Catch
                If nodeX.Text = Trim(Str(SearchObject)) Then
                    nodeX.Expand()
                    Me.foundnode = nodeX
                    found = True
                    TranverseNodes1 = True
                    Exit Function
                Else
                    TranverseNodes1(tv, nodeX, SearchObject, imageindex)
                End If
            End Try
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.check_blv Method

Private Function check_blv() As Integer

Source code

[Visual Basic]
    Private Function check_blv() As Integer
        'BLV-Funktion: 125
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_check_blv"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@istblv", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@istkube", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@istblv").Value = 0 And scmCmdToExecute.Parameters("@istkube").Value = 0 Then Return 0
            If scmCmdToExecute.Parameters("@istblv").Value = 1 Then Return 1
            If scmCmdToExecute.Parameters("@istkube").Value = 1 Then Return 2
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.ctmenuTVDossier_Popup Method

Private Sub ctmenuTVDossier_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenuTVDossier.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmenuTVDossier_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenuTVDossier.Popup
        Try
            Dim s As String
            Try
                Me.savetag = Me.tvdossier.SelectedNode.Tag
            Catch ex As Exception
                Throw ex
            Finally
                '2006-10-23 rs: wörkli sorry, aber es god nöd andersch ><
                Dim i As Integer
                For i = 0 To Me.ctmenuTVDossier.MenuItems.Count - 1
                    Me.ctmenuTVDossier.MenuItems(i).Enabled = False
                Next
            End Try

            get_nodedata()

            Dim tmpdata As New DataTable()

            Dim m As MenuItem

            If Me.MNUStatuszurueck.Enabled = True Then Exit Sub
            If frmbla.get_parts(Me.tnalnr) > 0 Then
                'Druckmenu
                Me.MnuPrintAll.MenuItems.Clear()
                Me.MnuPrintOK.MenuItems.Clear()
                Me.MnuPrintNOK.MenuItems.Clear()
                Dim i As Integer
                Dim a As Integer = 0
                Dim b As Integer = 0
                Dim c As Integer = 0
                tmpdata = get_druckjob_parts()
                For i = 0 To tmpdata.Rows.Count - 1
                    Select Case tmpdata.Rows(i).Item("status")
                        Case 2
                            a = 1
                        Case 3
                            b = 1
                        Case 4
                            c = 1
                    End Select
                Next
                If b = 0 And c = 0 And Me.MnuPrintBestaetigen.Enabled = True Then Exit Sub
                If a = 1 Then
                    Me.MnuDruck.Enabled = True
                End If
                If b = 1 Then
                    Me.MnuPrintBestaetigen.Enabled = True
                End If

                If tmpdata.Rows.Count > 1 Then

                    For i = 0 To tmpdata.Rows.Count - 1
                        s = "Teil " + LTrim(Str(i + 1)) + " von " + LTrim(Str(tmpdata.Rows(i).Item("totalparts")))
                        If i = 0 Then s = s + " inkl. Quittung"
                        If tmpdata.Rows(i).Item("status") = 2 Then s = s + " (nicht gedruckt)"
                        If tmpdata.Rows(i).Item("status") = 3 Then s = s + " (gedruckt nicht bestätigt)"
                        If tmpdata.Rows(i).Item("status") = 4 Then s = s + " (erfolgreich gedruckt)"
                        m = Me.MnuPrintAll.MenuItems.Add(s, New EventHandler(AddressOf handlemenu))
                        If tmpdata.Rows(i).Item("status") = 4 Or tmpdata.Rows(i).Item("status") = 3 Then m.Enabled = False
                        If a > 0 Or c > 0 Then
                            m = Me.MnuPrintOK.MenuItems.Add(s, New EventHandler(AddressOf handlemenuok))
                            If tmpdata.Rows(i).Item("status") = 2 Or tmpdata.Rows(i).Item("status") = 4 Then m.Enabled = False

                            m = Me.MnuPrintNOK.MenuItems.Add(s, New EventHandler(AddressOf handlemenunok))
                            If tmpdata.Rows(i).Item("status") = 4 Or tmpdata.Rows(i).Item("status") = 2 Then m.Enabled = False
                        End If
                    Next
                End If

            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.EdokaApp.frmBLDossier.ctmenuTVDossier_Popup", ex.Message + " " + ex.StackTrace, TraceLevel.Info)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.frmBLDossier_Resize Method

Private Sub frmBLDossier_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLDossier_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.btnfilter.Left = Me.BtnHelp.Left - Me.btnfilter.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_Dokumente Method

Private Function get_Dokumente() As DataTable

Source code

[Visual Basic]
    Private Function get_Dokumente() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_dossier"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@filter", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@filter").Value = 0 Then
                Me.btnfilter.Visible = False
            Else
                Me.btnfilter.Visible = True
            End If
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_auslieferungen_des_partners Method

Private Function get_auslieferungen_des_partners() As DataTable

Source code

[Visual Basic]
    Private Function get_auslieferungen_des_partners() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_auslieferungen_des_partners"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPar00))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_druckjob_parts Method

Private Function get_druckjob_parts() As DataTable

Source code

[Visual Basic]
    Private Function get_druckjob_parts() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_druckjobparts"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@alnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.tnalnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.EdokaApp.frmBLDossier.get_druckjob_parts", ex.Message + " " + ex.StackTrace, TraceLevel.Info)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_nodedata Method

Private Sub get_nodedata()

Source code

[Visual Basic]
    Private Sub get_nodedata()
        Try
            Me.DokList.Enabled = False
            Dim i As Integer
            Dim tn As New TreeNode()
            Dim tntag As String
            Dim split
            Dim s As String
            For i = 0 To Me.ctmenuTVDossier.MenuItems.Count - 1
                Me.ctmenuTVDossier.MenuItems(i).Enabled = False
            Next

            s = Me.tvdossier.SelectedNode.Tag
            Me.tnalnr = 0
            Select Case s
                Case "System : -1"
                    Me.DokList.Columns("auslieferungnr").FilterText = ""
                    Me.DokList.DataSource = Nothing
                    Me.DokList.DataSource = Me.IntDT
                    DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")
                Case "System : -2"
                    Dim dview As New DataView(Me.IntDT, "auslieferungnr is null", "", DataViewRowState.CurrentRows)
                    Me.DokList.DataSource = Nothing
                    Me.DokList.DataSource = dview
                    DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")
                Case "System : -3"
                    Dim dview As New DataView(Me.IntDT, "auslieferungnr>0", "", DataViewRowState.CurrentRows)
                    Me.DokList.DataSource = Nothing
                    Me.DokList.DataSource = dview
                    DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")
                Case Else
                    Me.MnuPrintAll.Enabled = True
                    Me.MnuPrintAQ.Enabled = True
                    Me.MnuPrintOK.Enabled = True
                    Me.MnuPrintNOK.Enabled = True
                    Me.mnuAuslieferungen.Enabled = True
                    Me.mnuDelete.Enabled = True

                    Me.DokList.DataSource = Nothing
                    Me.DokList.DataSource = Me.IntDT
                    DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")
                    If Microsoft.VisualBasic.InStr(s, ":") > 0 Then
                        If Microsoft.VisualBasic.Left(s, 6) <> "System" Then
                            tn = Me.tvdossier.SelectedNode
                            s = tn.Tag
                            split = s.Split(":", 3)
                            tnalnr = split(0)
                            tnstatus = split(1)
                            tndokid = split(2)
                        End If
                        tn = Nothing
                        Dim dview As New DataView(Me.IntDT, "auslieferungnr=" + LTrim(Str(Me.tnalnr)), "", DataViewRowState.CurrentRows)
                        Me.DokList.DataSource = Nothing
                        Me.DokList.DataSource = dview
                        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, IntDT, "bldossier")
                    Else
                        Me.DokList.Enabled = True
                        Exit Sub
                    End If
                    Try
                        If frmbla.Mutationsberechtigung(Me.NRPar00, Me.tndokid) = False Then
                            Me.mnuEdit.Enabled = False
                            Me.mnuDruckArchiv.Enabled = False
                            Me.mnuAgain.Enabled = False
                            Me.mnuDelete.Enabled = False

                        End If
                    Catch
                        Me.MnuPrintAll.Enabled = False
                        Me.MnuPrintAQ.Enabled = False
                        Me.MnuPrintOK.Enabled = False
                        Me.MnuPrintNOK.Enabled = False
                        Me.mnuAuslieferungen.Enabled = False
                        Me.mnuDelete.Enabled = False
                    End Try

                    If Me.btnDruck.Visible = False Then
                        Me.DokList.Enabled = True
                        Exit Sub
                    End If

                    Select Case tnstatus
                        Case 0
                            Me.mnuAgain.Enabled = True
                        Case 1
                            Me.mnuDruckAbbruch.Enabled = True
                        Case 2
                            Me.MnuDruck.Enabled = True
                        Case 3
                            Me.MnuPrintBestaetigen.Enabled = True
                        Case 4
                            If frmbla.get_druckjobstatus(Me.tnalnr) < 4 Then
                                Me.MNUStatuszurueck.Enabled = True
                            End If
                        Case 5
                            Me.mnuDelete.Enabled = False
                        Case Else
                    End Select
            End Select
            Me.DokList.Enabled = True
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmBLDossier.get_nodedata: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Info)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_partnerkurzebezeichnung Method

Private Function get_partnerkurzebezeichnung() As String

Source code

[Visual Basic]
    Private Function get_partnerkurzebezeichnung() As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_bkpar00"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bkpar00", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Me.Partnerkurzbezeichnung = scmCmdToExecute.Parameters("@bkpar00").Value
            Return Me.Partnerkurzbezeichnung
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.get_standardprofil Method

Private Function get_standardprofil() As Integer

Source code

[Visual Basic]
    Private Function get_standardprofil() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_standardprofil"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@profilnr").Value
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.handlemenu Method

Private Sub handlemenu( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenu(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        frmbla.PrintDocs(tndokid, Me, Me.tnalnr, part)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.handlemenunok Method

Private Sub handlemenunok( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenunok(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        frmbla.set_PrintNOK(Me.tnalnr, part)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.handlemenuok Method

Private Sub handlemenuok( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub handlemenuok(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim m As New MenuItem()
        m = sender
        Dim s As String
        s = Mid(m.Text, 6, 2)
        Dim part = Val(s) - 1
        frmbla.set_PrintOK(Me.tnalnr, part)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuAgain_Click Method

Private Sub mnuAgain_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuAgain.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuAgain_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuAgain.Click
        frmbla.neuer_druckauftrag(Me.tnalnr)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuDelete_Click Method

Private Sub mnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDelete.Click
        If frmbla.Delete_Aushaendigung(Me.tnalnr) = True Then
            Me.Load_Data()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuDruckAbbruch_Click Method

Private Sub mnuDruckAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckAbbruch.Click
        frmbla.stop_druckauftrag(Me.tnalnr)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuDruckArchiv_Click Method

Private Sub mnuDruckArchiv_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckArchiv.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckArchiv_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckArchiv.Click
        frmbla.Print_And_Arch(Me.tndokid, Me, Me.tnalnr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuEdit_Click Method

Private Sub mnuEdit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuEdit.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuEdit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuEdit.Click
        frmbla.EditDok(Me.tnalnr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuPrintOK_Click Method

Private Sub mnuPrintOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuPrintOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuPrintOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuPrintOK.Click
        frmbla.set_PrintOK(Me.tnalnr, 0)
        Me.Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuPrint_Click Method

Private Sub mnuPrint_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuPrint.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuPrint_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuPrint.Click
        Try
            Dim formbldruck = New frmBLDruck()
            formbldruck = New frmBLDruck()
            formbldruck.NRPAR00 = Me.NRPar00
            formbldruck.BKPAR00 = Me.Partnerkurzbezeichnung
            formbldruck.Profilnr = Me.Profilnr
            formbldruck.BLDossier = Me.IntDT
            formbldruck.ShowDialog()
            Load_Data()
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmBLDossier.mnuPrint_Click: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(304), EDOKALib.Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnuShowDoc_Click Method

Private Sub mnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuShowDoc.Click
        frmbla.ShowDoc(Me.tndokid, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.mnu_mfDruck_Click Method

Private Sub mnu_mfDruck_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnu_mfDruck.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnu_mfDruck_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnu_mfDruck.Click

        'Dim tmpDokumente As New Collection()
        Dim gendokCold As New Collection()
        Dim gendokOffice As New Collection()

        If Me.DokList.SelectedRows.Count = 0 Then
            Try
                If Microsoft.VisualBasic.Left(Me.DokList.Columns("dokumentid").Value, 6) = "OFFEDK" Then
                    'Office
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    Dim dtToReturn As DataTable = New DataTable()
                    Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                    Try
                        scmCmdToExecute.Connection = conn.scoDBConnection
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        sdaAdapter.Fill(dtToReturn)

                        'Zuerst prüfen ob das Cold Bild vorhanden ist.
                        If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                            gendokCold.Add(New clsMehrfachdruck_Data(DivFnkt.get_colddokumentid(Me.DokList.Columns("dokumentid").Value, 0), Me.DokList.Columns("partnernr").Value, clsMehrfachdruck_Data.Enum_Typ.EDOKA, False, "", "", "", ""))
                            fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                        Else
                            If scmCmdToExecute.Parameters("@office").Value > 0 Then
                                DivFnkt.print_office(Me.DokList.Columns("dokumentid").Value, Me)
                            End If
                        End If
                    Catch
                    End Try
                Else
                    'HOST
                    'Host Daten abfüllen
                    gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr").Text, _
                    clsMehrfachdruck_Data.Enum_Typ.HOST, False, Me.DokList.Columns("dokumenttypnr").Text, "", Me.get_partnerkurzebezeichnung, Me.DokList.Columns("erstelltam").Text))
                    fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                    Exit Sub
                End If
            Catch ex As Exception
            End Try
        Else
            'Mehrere Dokumente gewählt
            Dim i As Integer
            Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
            colRows = Me.DokList.SelectedRows

            'Wenn mehr als ein Dokument selektiert ist dann Meldung zum Fragen anzeigen
            If colRows.Count > 1 Then
                If MsgBox("Alle markierten Dokumente (" + LTrim(Str(colRows.Count)) + ") drucken?", MsgBoxStyle.YesNo) = MsgBoxResult.No Then
                    Exit Sub
                End If
            End If

            Me.Cursor = Cursors.WaitCursor

            'Loop über die Selektierten Dokumente und die Werte je nach Typ in eine Collection abspeichern
            For i = 0 To colRows.Count - 1
                Try
                    If Microsoft.VisualBasic.Left(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), 6) = "OFFEDK" Then
                        'Office
                        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                        scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
                        scmCmdToExecute.CommandType = CommandType.StoredProcedure
                        Dim dtToReturn As DataTable = New DataTable()
                        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                        Try
                            scmCmdToExecute.Connection = conn.scoDBConnection
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").CellValue(colRows(i))))
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                            sdaAdapter.Fill(dtToReturn)

                            'Zuerst prüfen ob das Cold Dokument vorhanden ist.
                            If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                                gendokCold.Add(New clsMehrfachdruck_Data(DivFnkt.get_colddokumentid(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), 0), Me.DokList.Columns("partnernr").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.EDOKA, False, "", "", "", ""))
                            Else
                                If scmCmdToExecute.Parameters("@office").Value > 0 Then
                                    gendokOffice.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), Me.DokList.Columns("partnernr").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.EDOKA, True, "", "", "", ""))
                                End If
                            End If

                        Catch
                        End Try
                    Else
                        'HOST
                        'Host Daten abfüllen
                        gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), _
                        Me.DokList.Columns("partnernr").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.HOST, False, _
                        Me.DokList.Columns("dokumenttypnr").CellValue(colRows(i)), "", _
                        Me.get_partnerkurzebezeichnung, _
                        Me.DokList.Columns("erstelltam").CellValue(colRows(i))))
                        Exit Try
                    End If
                Catch
                End Try
            Next

            Try
                fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
            Catch ex As Exception
            Finally
                Me.Cursor = Cursors.Default
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.tvdossier_AfterSelect Method

Private Sub tvdossier_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles tvdossier.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvdossier_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles tvdossier.AfterSelect
        Me.Cursor = Cursors.WaitCursor
        '    Me.TDokart.Enabled = False
        '   Me.tvdossier.Enabled = False
        '  Me.DokList.Enabled = False
        If Me.doupdate Then
            Me.doupdate1 = False
            Me.TDokart.SelectedNode = Me.TDokart.Nodes(0)
            Me.doupdate1 = True
            get_nodedata()
        End If
        '        If Me.tnalnr <> 0 Then
        '        Me.DokList.Columns(0).FilterText = Me.tnalnr
        '        End If
        ' Me.TDokart.Enabled = True
        ' Me.tvdossier.Enabled = True
        ' Me.DokList.Enabled = True
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.tvdossier_MouseDown Method

Private Sub tvdossier_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvdossier.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvdossier_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvdossier.MouseDown
        Try
            'RS 2006-10-05: replce whole code cauze it wasn't really nice
            'If Not IsNothing(tvdossier.SelectedNode) Then
            'If tvdossier.SelectedNode.GetNodeCount(True) > 0 Then
            'savetag = tvdossier.SelectedNode.Tag
            'End If
            'End If

            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            tvdossier.SelectedNode = tvdossier.GetNodeAt(selectPoint)
            If Not IsNothing(tvdossier.SelectedNode) Then
                Me.savetag = tvdossier.SelectedNode.Tag
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmBLDossier.tvdossier_MouseDown: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Info)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier.tvdossier_MouseUp Method

Private Sub tvdossier_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvdossier.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvdossier_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvdossier.MouseUp
        Me.Cursor = Cursors.WaitCursor
        '    Me.TDokart.Enabled = False
        '   Me.tvdossier.Enabled = False
        '  Me.DokList.Enabled = False
        If Me.doupdate Then
            Me.doupdate1 = False
            Me.TDokart.SelectedNode = Me.TDokart.Nodes(0)
            Me.doupdate1 = True
            get_nodedata()
        End If
        '        If Me.tnalnr <> 0 Then
        '        Me.DokList.Columns(0).FilterText = Me.tnalnr
        '        End If
        ' Me.TDokart.Enabled = True
        ' Me.tvdossier.Enabled = True
        ' Me.DokList.Enabled = True
        Me.Cursor = Cursors.Default

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossier Fields

frmBLDossier overview

Fields

field BtnHelp |
field ContextMenu1 |
field DokList |
field GrpDossier |
field ImageList1 |
field ImgListSteuerung |
field IntDT | Interne Datatable
field MNUStatuszurueck |
field M_Nrpar00 | Variable für das Property NRPAR00
field MenuItem3 |
field MenuItem4 |
field MenuItem7 |
field MenuItem9 |
field MnuDruck |
field MnuIndexInfo |
field MnuPartnerdossier |
field MnuPrintAQ |
field MnuPrintAll |
field MnuPrintBestaetigen |
field MnuPrintNOK |
field MnuPrintOK |
field MnuShow |
field MnuZuweisung |
field TDokart |
field ToolBar1 |
field btnDruck |
field btnblkparameter |
field btnblvzuweisung |
field btnexit |
field btnfilter |
field btnrefresh |
field components |
field ctmenuTVDossier |
field doupdate |
field doupdate1 |
field found |
field foundnode |
field frmbla |
field m_Partnerkurzbezeichnung |
field m_Profilnr |
field m_auslieferungnr |
field mnuAgain |
field mnuAuslieferungen |
field mnuDelete |
field mnuDruckAbbruch |
field mnuDruckArchiv |
field mnuEdit |
field mnuPrint |
field mnuShowDoc |
field mnu_mfDruck |
field pnlleft |
field pnltree |
field savetag |
field selectPoint |
field tnalnr |
field tndokid |
field tnstatus |
field tvdossier |

See Also

frmBLDossier Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


GrpDossier Variable

Friend WithEvents GrpDossier As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpDossier As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


ImgListSteuerung Variable

Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


IntDT Variable

Interne Datatable

Dim IntDT As New DataTable()

Source code

[Visual Basic]
    Dim IntDT As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MNUStatuszurueck Variable

Friend WithEvents MNUStatuszurueck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MNUStatuszurueck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


M_Nrpar00 Variable

Variable für das Property NRPAR00

Dim M_Nrpar00 As Integer

Source code

[Visual Basic]
    Dim M_Nrpar00 As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuDruck Variable

Friend WithEvents MnuDruck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDruck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuIndexInfo Variable

Friend WithEvents MnuIndexInfo As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuIndexInfo As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPartnerdossier Variable

Friend WithEvents MnuPartnerdossier As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPartnerdossier As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPrintAQ Variable

Friend WithEvents MnuPrintAQ As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintAQ As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPrintAll Variable

Friend WithEvents MnuPrintAll As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintAll As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPrintBestaetigen Variable

Friend WithEvents MnuPrintBestaetigen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintBestaetigen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPrintNOK Variable

Friend WithEvents MnuPrintNOK As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintNOK As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuPrintOK Variable

Friend WithEvents MnuPrintOK As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPrintOK As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuShow Variable

Friend WithEvents MnuShow As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShow As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


MnuZuweisung Variable

Friend WithEvents MnuZuweisung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuZuweisung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


TDokart Variable

Friend WithEvents TDokart As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TDokart As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnDruck Variable

Friend WithEvents btnDruck As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnDruck As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnblkparameter Variable

Friend WithEvents btnblkparameter As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnblkparameter As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnblvzuweisung Variable

Friend WithEvents btnblvzuweisung As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnblvzuweisung As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnexit Variable

Friend WithEvents btnexit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnexit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnfilter Variable

Friend WithEvents btnfilter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnfilter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


btnrefresh Variable

Friend WithEvents btnrefresh As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnrefresh As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


ctmenuTVDossier Variable

Friend WithEvents ctmenuTVDossier As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenuTVDossier As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


doupdate Variable

Dim doupdate As Boolean = True

Source code

[Visual Basic]
    Dim doupdate As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


doupdate1 Variable

Dim doupdate1 As Boolean = True

Source code

[Visual Basic]
    Dim doupdate1 As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


found Variable

Dim found As Boolean

Source code

[Visual Basic]
    Dim found As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


foundnode Variable

Dim foundnode As TreeNode

Source code

[Visual Basic]
    Dim foundnode As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmbla Variable

Dim frmbla As New frmBLAuslieferungen()

Source code

[Visual Basic]
    Dim frmbla As New frmBLAuslieferungen()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


m_Partnerkurzbezeichnung Variable

Dim m_Partnerkurzbezeichnung As String

Source code

[Visual Basic]
    Dim m_Partnerkurzbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


m_Profilnr Variable

Dim m_Profilnr As Integer

Source code

[Visual Basic]
    Dim m_Profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


m_auslieferungnr Variable

Dim m_auslieferungnr As Integer = 0

Source code

[Visual Basic]
    Dim m_auslieferungnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuAgain Variable

Friend WithEvents mnuAgain As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAgain As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuAuslieferungen Variable

Friend WithEvents mnuAuslieferungen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAuslieferungen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuDelete Variable

Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuDruckAbbruch Variable

Friend WithEvents mnuDruckAbbruch As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckAbbruch As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuDruckArchiv Variable

Friend WithEvents mnuDruckArchiv As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckArchiv As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuEdit Variable

Friend WithEvents mnuEdit As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuEdit As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuPrint Variable

Friend WithEvents mnuPrint As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuPrint As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnuShowDoc Variable

Friend WithEvents mnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


mnu_mfDruck Variable

Friend WithEvents mnu_mfDruck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnu_mfDruck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


pnlleft Variable

Friend WithEvents pnlleft As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlleft As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


pnltree Variable

Friend WithEvents pnltree As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnltree As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


savetag Variable

Dim savetag As String

Source code

[Visual Basic]
    Dim savetag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


tnalnr Variable

Dim tnalnr As Integer

Source code

[Visual Basic]
    Dim tnalnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


tndokid Variable

Dim tndokid As String

Source code

[Visual Basic]
    Dim tndokid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


tnstatus Variable

Dim tnstatus As Integer = -1

Source code

[Visual Basic]
    Dim tnstatus As Integer = -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


tvdossier Variable

Friend WithEvents tvdossier As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents tvdossier As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossier


frmBLDossierzuweisen Class

For a list of all members of this type, see frmBLDossierzuweisen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLDossierzuweisen

Public Class frmBLDossierzuweisen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLDossierzuweisen Members


frmBLDossierzuweisen Members

frmBLDossierzuweisen overview

Constructors

constructor frmBLDossierzuweisen Constructor

Methods

method Dispose
method Get_Niederlassung
method Get_blv
method InitializeComponent
method cbNiederlassung_SelectedIndexChanged
method frmBLDossierzuweisen_Load

Fields

field btnAbbruch
field btnzuweisen
field cbNiederlassung
field cbblv
field components
field lblBLV
field lblNiederlassung
field mcbblv
field mcbniederlassung
field on_load

See Also

frmBLDossierzuweisen Class


frmBLDossierzuweisen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen Methods

frmBLDossierzuweisen overview

Methods

method Dispose
method Get_Niederlassung
method Get_blv
method InitializeComponent
method cbNiederlassung_SelectedIndexChanged
method frmBLDossierzuweisen_Load

See Also

frmBLDossierzuweisen Class


frmBLDossierzuweisen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen.Get_Niederlassung Method

Private Function Get_Niederlassung() As DataTable

Source code

[Visual Basic]
    Private Function Get_Niederlassung() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_niederlassung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen.Get_blv Method

Private Function Get_blv() As DataTable

Source code

[Visual Basic]
    Private Function Get_blv() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_blvnl"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@niederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbniederlassung.SelectedValue))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.cbNiederlassung = New System.Windows.Forms.ComboBox()
        Me.lblNiederlassung = New System.Windows.Forms.Label()
        Me.lblBLV = New System.Windows.Forms.Label()
        Me.cbblv = New System.Windows.Forms.ComboBox()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnzuweisen = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'cbNiederlassung
        '
        Me.cbNiederlassung.Location = New System.Drawing.Point(112, 32)
        Me.cbNiederlassung.Name = "cbNiederlassung"
        Me.cbNiederlassung.Size = New System.Drawing.Size(184, 21)
        Me.cbNiederlassung.TabIndex = 0
        Me.cbNiederlassung.Text = "ComboBox1"
        '
        'lblNiederlassung
        '
        Me.lblNiederlassung.Location = New System.Drawing.Point(8, 32)
        Me.lblNiederlassung.Name = "lblNiederlassung"
        Me.lblNiederlassung.TabIndex = 1
        Me.lblNiederlassung.Text = "Niederlassung"
        '
        'lblBLV
        '
        Me.lblBLV.Location = New System.Drawing.Point(8, 64)
        Me.lblBLV.Name = "lblBLV"
        Me.lblBLV.Size = New System.Drawing.Size(100, 32)
        Me.lblBLV.TabIndex = 3
        Me.lblBLV.Text = "Banklagernd-Verantwortlicher"
        '
        'cbblv
        '
        Me.cbblv.Location = New System.Drawing.Point(112, 64)
        Me.cbblv.Name = "cbblv"
        Me.cbblv.Size = New System.Drawing.Size(184, 21)
        Me.cbblv.TabIndex = 2
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(8, 112)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 4
        Me.btnAbbruch.Text = "Abbruch"
        '
        'btnzuweisen
        '
        Me.btnzuweisen.Location = New System.Drawing.Point(224, 112)
        Me.btnzuweisen.Name = "btnzuweisen"
        Me.btnzuweisen.TabIndex = 5
        Me.btnzuweisen.Text = "&Zuweisen"
        '
        'frmBLDossierzuweisen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(312, 149)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnzuweisen, Me.btnAbbruch, Me.lblBLV, Me.cbblv, Me.lblNiederlassung, Me.cbNiederlassung})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Name = "frmBLDossierzuweisen"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dossier einem Banklagernd-Verantwortlichen zuweisen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen.cbNiederlassung_SelectedIndexChanged Method

Private Sub cbNiederlassung_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbniederlassung.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbNiederlassung_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbniederlassung.SelectedIndexChanged
        If Me.On_Load Then Exit Sub
        Dim dt As New DataTable()
        dt = Get_blv()
        Me.mcbblv.CheckNullValue = True
        Me.mcbblv.NullValueMessage = MyTxt.gettext(83)
        Me.mcbblv.DisplayColumnName = "mitarbeiter"
        Me.mcbblv.ValueColumnName = "mitarbeiternr"
        Me.mcbblv.Fill_Data(dt, False)
        If dt.Rows.Count = 0 Then
            Me.mcbblv.Enabled = False
            Me.cbblv.Enabled = False
            Me.btnzuweisen.Enabled = False
        Else
            Me.mcbblv.Enabled = True
            Me.cbblv.Enabled = True
            Me.btnzuweisen.Enabled = True
            Me.mcbblv.SelectedValue = dt.Rows(0).Item(0)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen.frmBLDossierzuweisen_Load Method

Private Sub frmBLDossierzuweisen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLDossierzuweisen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim dt As New DataTable()
        dt = get_niederlassung
        Me.mcbniederlassung = New MultiComboBox(Me.cbNiederlassung)
        Me.mcbblv = New MultiComboBox(Me.cbblv)
        Me.mcbniederlassung.CheckNullValue = True
        Me.mcbniederlassung.NullValueMessage = MyTxt.gettext(83)
        Me.mcbniederlassung.DisplayColumnName = "niederlassung"
        Me.mcbniederlassung.ValueColumnName = "niederlassungnr"
        Me.mcbniederlassung.Fill_Data(dt, False)
        Me.on_load = False
        Me.mcbniederlassung.SelectedValue = dt.Rows(0).Item(0)
        Me.cbNiederlassung_SelectedIndexChanged(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDossierzuweisen Fields

frmBLDossierzuweisen overview

Fields

field btnAbbruch
field btnzuweisen
field cbNiederlassung
field cbblv
field components
field lblBLV
field lblNiederlassung
field mcbblv
field mcbniederlassung
field on_load

See Also

frmBLDossierzuweisen Class


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


btnzuweisen Variable

Friend WithEvents btnzuweisen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzuweisen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


cbNiederlassung Variable

Friend WithEvents cbNiederlassung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbNiederlassung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


cbblv Variable

Friend WithEvents cbblv As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbblv As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


lblBLV Variable

Friend WithEvents lblBLV As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBLV As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


lblNiederlassung Variable

Friend WithEvents lblNiederlassung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblNiederlassung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


mcbblv Variable

Dim WithEvents mcbblv As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbblv As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


mcbniederlassung Variable

Dim WithEvents mcbniederlassung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbniederlassung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


on_load Variable

Dim on_load As Boolean = True

Source code

[Visual Basic]
    Dim on_load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDossierzuweisen


frmBLDruck Class

Aktiviert oder deaktiviert die Datumselektionen je Checkbox

For a list of all members of this type, see frmBLDruck Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLDruck

Public Class frmBLDruck
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLDruck Members


frmBLDruck Members

frmBLDruck overview

Constructors

constructor frmBLDruck Constructor (Overloaded)

Properties

property BKPAR00
property BLDossier
property NRPAR00
property Profilnr

Methods

method Bearbeitungsstatus |
method BtnHelp_Click |
method COLD_Index_Sichern |
method Cold_Index_Bearbeiten |
method Dispose |
method Dokument_Bearbeiten |
method Dokumentwerte |
method Dokumentwerte_Sichern |
method FillMcbVerantwortlich |
method Generic_Select |
method Get_Dokumentwerte |
method Get_Mitarbeiter |
method Get_blvs |
method Get_kubes |
method InitializeComponent |
method Load_Defaults |
method Load_EditDok |
method Load_Notizen |
method Load_Partnerdata |
method MnuDeleteNotiz_Click |
method MnuEditNotiz_Click |
method MnuNeueNotiz_Click |
method Notizen_Laden |
method Notizlist_DoubleClick |
method Save_Aushaendigungsquittung |
method Set_Dokumentwerte |
method Set_Zustaendiger |
method Status_History |
method btnAbbruch_Click |
method btnWeiter_Click |
method cbDel2Page_CheckedChanged |
method cbbeilage3_CheckedChanged |
method cbgrundlage_CheckedChanged | Akiviert oder deaktiviert die Datumsselektionsfelder je Checkbox
method cbkube_SelectedIndexChanged |
method cbzustaendiger_SelectedIndexChanged |
method frmBLDruck_Load |
method get_bldokumenttyp |
method get_current_Status |
method get_name_aushaendigung |
method get_partnerkurzebezeichnung |
method get_peridata |
method get_zustaendiger_kube |
method letzte_auslieferung |
method load_Mitarbeiter |
method rbAushaendigungBLV_CheckedChanged |
method rbAushaendigungKube_CheckedChanged |
method rbpersoenlich_CheckedChanged |
method rbzustellungpost_CheckedChanged |
method rbzustellungpost_CheckedChanged_1 |
method refresh_team |

Fields

field Aushaendigungnr
field BtnHelp
field Button2
field ContextMenu1
field CreateDocument
field CreateNew
field DataSet1
field DateTimePicker1
field Dokumentid
field Dokumenttyp
field Dokumenttypnr
field EditDoc
field EditDok
field Editmode
field FirstStatus
field GroupBox1
field GroupBox10
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field ImageList1
field Label1
field Label13
field Label2
field Label3
field Label4
field MnuDeleteNotiz
field MnuEditNotiz
field MnuNeueNotiz
field Notizen
field Notizlist
field SaveStatus
field SaveVerantwortlicher
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TabControl1
field TabPage1
field TabPage2
field TeamZustaendig
field auslieferungnr
field btnAbbruch
field btnWeiter
field cbDel2Page
field cbUnterschriftrechts
field cbbeilage1
field cbbeilage2
field cbbeilage3
field cbblv
field cbdokumentstatus
field cbgrundlage1
field cbgrundlage2
field cbgrundlage3
field cbgrundlage4
field cbkube
field cbteam
field cbverantwortlich
field cbzustaendiger
field components
field doc
field dokumenteab
field dokumentebis
field drpMiatarbeiter
field dtgrundlage1
field dtgrundlage2
field dtgrundlage3
field dtgrundlage3overlay
field dtgrundlage4
field i
field lblUnterschrift1
field m_Bldossier
field m_bkpar00
field m_nrpar00
field m_onload
field m_profilnr
field mcbblv
field mcbkube
field mcbstatus
field mcbteam
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field rbAushaendigungBLV
field rbAushaendigungKube
field rbnichtverschlossen
field rbpersoenlich
field rbverschlossen
field rbzustellungpost
field tblblkunde
field tbldokumentwerte
field tblperi
field txtAnredeZusteller
field txtBeilage
field txtZustelladresse
field txtbemerkung
field w

See Also

frmBLDruck Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal Auslieferungnr As Integer)

[Visual Basic] Public Sub New(ByVal bkpar00 As String, ByVal nrpar00 As Integer, ByVal profilnr As Integer, ByVal createnew As Boolean)

See Also

frmBLDruck | EDOKAApp


frmBLDruck Properties

frmBLDruck overview

Properties

property BKPAR00
property BLDossier
property NRPAR00
property Profilnr

See Also

frmBLDruck Class


frmBLDruck.BKPAR00 Property

Property BKPAR00() As String

Source code

[Visual Basic]
    Property BKPAR00() As String
        Get
            Return m_bkpar00
        End Get
        Set(ByVal Value As String)
            m_bkpar00 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.BLDossier Property

Property BLDossier() As DataTable

Source code

[Visual Basic]
    Property BLDossier() As DataTable
        Get
            Return m_Bldossier
        End Get
        Set(ByVal Value As DataTable)
            m_Bldossier = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.NRPAR00 Property

Property NRPAR00() As Integer

Source code

[Visual Basic]
    Property NRPAR00() As Integer
        Get
            Return m_nrpar00
        End Get
        Set(ByVal Value As Integer)
            m_nrpar00 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Profilnr Property

Property Profilnr() As Integer

Source code

[Visual Basic]
    Property Profilnr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck Methods

frmBLDruck overview

Methods

method Bearbeitungsstatus |
method BtnHelp_Click |
method COLD_Index_Sichern |
method Cold_Index_Bearbeiten |
method Dispose |
method Dokument_Bearbeiten |
method Dokumentwerte |
method Dokumentwerte_Sichern |
method FillMcbVerantwortlich |
method Generic_Select |
method Get_Dokumentwerte |
method Get_Mitarbeiter |
method Get_blvs |
method Get_kubes |
method InitializeComponent |
method Load_Defaults |
method Load_EditDok |
method Load_Notizen |
method Load_Partnerdata |
method MnuDeleteNotiz_Click |
method MnuEditNotiz_Click |
method MnuNeueNotiz_Click |
method Notizen_Laden |
method Notizlist_DoubleClick |
method Save_Aushaendigungsquittung |
method Set_Dokumentwerte |
method Set_Zustaendiger |
method Status_History |
method btnAbbruch_Click |
method btnWeiter_Click |
method cbDel2Page_CheckedChanged |
method cbbeilage3_CheckedChanged |
method cbgrundlage_CheckedChanged | Akiviert oder deaktiviert die Datumsselektionsfelder je Checkbox
method cbkube_SelectedIndexChanged |
method cbzustaendiger_SelectedIndexChanged |
method frmBLDruck_Load |
method get_bldokumenttyp |
method get_current_Status |
method get_name_aushaendigung |
method get_partnerkurzebezeichnung |
method get_peridata |
method get_zustaendiger_kube |
method letzte_auslieferung |
method load_Mitarbeiter |
method rbAushaendigungBLV_CheckedChanged |
method rbAushaendigungKube_CheckedChanged |
method rbpersoenlich_CheckedChanged |
method rbzustellungpost_CheckedChanged |
method rbzustellungpost_CheckedChanged_1 |
method refresh_team |

See Also

frmBLDruck Class


frmBLDruck.Bearbeitungsstatus Method

Private Function Bearbeitungsstatus( _
   ByVal dokumentid As String _
) As Integer

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Bearbeitungsstatus(ByVal dokumentid As String) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_bearbeitungsstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statusnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            Try
                conn.CloseConnection(True)
            Catch
            End Try
            conn.OpenConnection()
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters.Item("@statusnr").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("SP_edex_bl_get_bearbeitungsstatus::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("definierenderaushndigungsquittung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.COLD_Index_Sichern Method

Public Function COLD_Index_Sichern( _
   ByVal indextyp As Integer, _
   ByVal dokumentid As String _
) As DataTable

Parameters

indextyp
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function COLD_Index_Sichern(ByVal indextyp As Integer, ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Cold_Index_Bearbeiten Method

Public Sub Cold_Index_Bearbeiten( _
   ByVal indextyp As Integer, _
   ByVal dokumentid As String _
)

Parameters

indextyp
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten(ByVal indextyp As Integer, ByVal dokumentid As String)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp, dokumentid)
        xdata = Me.tbldokumentwerte
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Dokument_Bearbeiten Method

Private Sub Dokument_Bearbeiten( _
   ByVal neu As Boolean _
)

Parameters

neu
Required.

Source code

[Visual Basic]
    Private Sub Dokument_Bearbeiten(ByVal neu As Boolean)
        Try
            w.txtPartner = Me.BKPAR00
            w.txtDokumenttyp = ""
            w.ProgressBar.Show()
            w.ProgressBar.Bar1.Value = 5
            w.ProgressBar.Info.Text = "Dokumentdaten speichern"
            'w.txtBemerkung_Verantwortlicher = Me.txtBemerkungVerantwortlicher

            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim docvor As New edokadb.clsOffice_vorlage()

            'OfficeVorlage laden
            docvor.cpMainConnectionProvider = conn
            docvor.iOffice_vorlagenr = New SqlInt32(CType(Dokumenttyp.iOffice_vorlagenr.Value, Int32))
            docvor.SelectOne()

            doc.cpMainConnectionProvider = conn
            If Me.CreateDocument Then
                doc.sDokumentid = New SqlString(CType(Dokumentid, String))
                DivFnkt.Status_Dokumentbearbeitung(1, doc.sDokumentid.Value, True, "")
            Else
                'shu 20050505
                doc.sDokumentid = New SqlString(CType(Dokumentid, String))
                doc.SelectOne()
            End If

            doc.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
            doc.iNrpar00 = New SqlInt32(CType(Me.NRPAR00, Int32))
            doc.bAktiv = New SqlBoolean(True)
            doc.bAmsdokument = New SqlBoolean(CType(False, Boolean))
            doc.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
            doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.daArchivierungsdatum = New SqlDateTime(CType(Now.ToShortDateString, DateTime))
            doc.iStatus_edoka_batch_ausgang = Nothing

            doc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))

            doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
            'Hutter - anpassungen
            If Me.mcbstatus.Text = "Bereit für Ausgangsarchivierung" Then
                doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
            End If
            doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.bGesperrt = New SqlBoolean(CType(False, Boolean))
            doc.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
            doc.bZu_retournieren = New SqlBoolean(CType(Me.Dokumenttyp.bZu_retournieren.Value, Boolean))
            doc.iColdstatus = New SqlInt32(CType(0, Int32))
            doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            If neu = True Then
                doc.iErsteller = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iErstellerteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daErstelltam = New SqlDateTime(CType(Now, DateTime))
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutiererteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
                If Globals.bckdokument Then
                    doc.iBck = New SqlInt32(CType(1, Int32))
                Else
                    doc.iBck = New SqlInt32(CType(1, Int32))
                End If
                doc.iAufbewahrung_elektronisch = New SqlInt32(CType(Me.Dokumenttyp.iAufbewahrungsfrist_elektronisch.Value, Int32))
                doc.iAufbewahrung_phaysisch = New SqlInt32(CType(Me.Dokumenttyp.iAufbewahrungsfrist_physisch.Value, Int32))
                doc.iBearbeitung_nach_abschluss = New SqlInt32(CType(Me.Dokumenttyp.iTage_mutation.Value, Int32))
                doc.iBearbeitungszeit_in_minuten = New SqlInt32(CType(Me.Dokumenttyp.iDbearbeitungszeit.Value, Int32))
                doc.iMonierung_in_tagen = New SqlInt32(CType(Me.Dokumenttyp.iAnzahl_tage.Value, Int32))
            Else
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
            End If

            doc.iUnterschriftlinks = New SqlInt32(CType(0, Int32))
            If Me.cbDel2Page.Checked = True Then
                doc.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
            Else
                doc.iUnterschriftrechts = New SqlInt32(CType(0, Int32))
            End If

            doc.iVerantwortlich = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            'doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
            'doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
            doc.bVertraulich = New SqlBoolean(CType(False, Boolean))
            doc.sZustelladresse = New SqlString(CType(Me.txtZustelladresse.Text, String))
            doc.sAnredezustelladresse = New SqlString(CType(Me.txtAnredeZusteller.Text, String))

            'If Me.rbAushaendigungKube.Checked Then
            doc.iZustaendiger = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
            'Else

            'doc.iZustaendiger = New SqlInt32(CType(Me.mcbblv.SelectedValue, Int32))
            'nd If

            doc.iPostzustellung = New SqlInt32(CType(0, Int32))
            doc.bZustaendig_kube = New SqlBoolean(CType(True, Boolean))
            doc.iGesperrt_durch = New SqlInt32(CType(0, Int32))
            doc.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.sBemerkung = New SqlString(CType(Me.txtbemerkung.Text, String))
            doc.sColddokumentid = New SqlString(CType("", String))

            doc.sBezeichnung = New SqlString(CType(Me.Dokumenttyp.sBezeichnung.Value, String))

            If Not Me.CreateDocument Then
                doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
            End If

            doc.daErstellungsdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))

            If docvor.iAnwendungnr.Value = 1 Then
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".doc", String))
            Else
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".xls", String))
            End If

            If Me.CreateDocument Then doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
                Dim tx As DataTable
                tx = Generic_Select(13)
                If tx.Rows(0).Item(0) = 1 Then
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
                Else
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
                End If
                tx.Dispose()
            End If

            Dim s As String

            s = DivFnkt.Get_Filename(doc.sDokumentname.Value, Me.NRPAR00.ToString)
            conn.OpenConnection()
            If Me.CreateDocument Then
                Dim t As DataTable
                t = Generic_Select(14)
                doc.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
                doc.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
                doc.iAnzeigeStatus = New SqlInt32(CType(0, Int32))
                Try
                    doc.Insert()
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try

                t.Dispose()
                Dim statush As New Statushandling()
                statush.Status_Erstellen(doc.sDokumentid.Value, 0)
                statush.Dispose()
                doc.iStatusnr = New SqlInt32(CType(get_current_Status(doc.sDokumentid.Value), Int32))
                doc.sBedRDokumentid = New SqlString(CType("", String))
            Else
                Dim statush As New Statushandling()
                Dim statusnr As Integer
                statusnr = Bearbeitungsstatus(doc.sDokumentid.Value)
                statush.insert_history_status(statusnr, Dokumentid, Me.mcbverantwortlich.SelectedValue)
                statush.Dispose()
                doc.iStatusnr = New SqlInt32(CType(statusnr, Int32))
                conn.OpenConnection()
            End If
            doc.sBedRDokumentid = New SqlString(CType("", String))
            doc.bBedRRetourniert = New SqlBoolean(CType(False, Boolean))
            doc.Update()
            DivFnkt.Journal_Dokumentzugriff(Me.Dokumentid, "Bearbeiten", 0, 0, "", "")
            conn.CloseConnection(True)

            Dokumentid = doc.sDokumentid.Value
            Cold_Index_Bearbeiten(1, Dokumentid)
            If Dokumenttyp.bZu_retournieren.Value = True Then
                Cold_Index_Bearbeiten(2, Dokumentid)
            End If
            Globals.PerfMon.insert_entry("'-- Begin Dokumentdaten sichern")
            Dokumentid = doc.sDokumentid.Value
            Dokumentwerte_Sichern()
            w.ProgressBar.Bar1.Value = 7
            w.ProgressBar.Info.Text = "Dokumentdaten speichern "
            w.ProgressBar.Bar1.Value = 9
            w.ProgressBar.Info.Text = "Dokumentdaten speichern "
            Status_History(doc.iStatusnr.Value, Dokumentid)
            Globals.PerfMon.insert_entry("'-- Ende Dokumentdaten sichern")
            w.ProgressBar.Show()
            w.ProgressBar.Bar1.Value = 11
            w.ProgressBar.Info.Text = "Dokumentwerte zusammenstellen"
            Globals.PerfMon.insert_entry("'-- Begin Dokumentwerte zusammenstellen")
            Dim xdata As DataTable
            xdata = Dokumentwerte(doc.sDokumentid.Value)
            Globals.PerfMon.insert_entry("'--Ende Dokumentwerte zusammenstellen")
            Dokumentid = doc.sDokumentid.Value

            'Dokument erstellen bzw. öffnen
            w.DokumentID = doc.sDokumentid.Value
            w.DokumentName = doc.sDokumentname.Value
            If Me.CreateDocument Or Me.Editmode Then
                DivFnkt.TraceLog("Vor Dokumenterstellung")
                w.CreateDoc = True
                If w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s, "") = False Then
                    w.ProgressBar.Visible = False
                    w.Restore(1)
                    Me.Cursor = Cursors.Default
                    Me.btnWeiter.Enabled = True
                    DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
                    Exit Sub
                End If
            Else
                w.CreateDoc = False
                Dim docrestore As New DocMgmt()
                docrestore.Get_From_DB(Dokumentid, s)
                w.Open_Document(s, xdata, doc.iDokumenttypnr.Value)
            End If
            Me.Hide()

            If Globals.Dokumentcoldindex_Changed Then
                w.dokumentidalt = Globals.Dokumentidalt
                w.save_dokumentcoldindex = Globals.general_ds.Tables(Globals.general_ds.Tables.Count - 1).Copy
                w.Dokumentcoldindex_Changed = Globals.Dokumentcoldindex_Changed
                w.dokumentid_changed = Globals.dokumentid_changed
                w.dokumentcoldindex_status = Globals.dokumentcoldindex_status
                w.Ersetzte_Dokumente_Reaktivieren = Globals.Ersetzte_Dokumente_Reaktivieren
            End If

            'Anzeigen der Dokumentwerte, sofern die Checkbox markiert war
            DivFnkt.TraceLog("Vor Dokument vervollständigen")
            w.Dokument_Vervollstaendigen(xdata)
            Globals.PerfMon.insert_entry(Me.Dokumentid + " Start Dokumentbearbeitung")
            Words.Add(w, w.DokumentName)
            xdata.Dispose()
            doc.Dispose()
            Globals.PerfMon.insert_entry(Me.Dokumentid + " Ende Dokumenterstellung")
            Words.Remove(w.DokumentName)
            Try
                w.ProgressBar.Close()
                w.ProgressBar.Dispose()
            Catch
            End Try
            Dim f As New frmBLAuslieferungen()
            f.MdiParent = Me.ParentForm
            If Me.Editmode = False Then
                f.Create_PrintJob(Me.Aushaendigungnr, Me.BLDossier)
            End If
            DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
        Catch ex As Exception
            If Me.CreateDocument = True Then
                Dim q As New edokadb.clsEDEX_BL_Auslieferung()
                q.cpMainConnectionProvider = conn
                q.iAuslieferungnr = New SqlInt32(CType(Me.Aushaendigungnr, Int32))
                q.SelectOne()
                q.Delete()
                q.Dispose()
            End If
            w.Close_And_Destroy()
            Dim s As String
            Globals.In_Bearbeitung = False
            DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, True, w.DokumentName)
            s = Globals.MyTxt.gettext(98)
            s = s + vbCrLf + vbCrLf + ex.Message
            MsgBox(s, MsgBoxStyle.Critical)
            PerfMon.force_insert_entry("Dok (N): " + ex.Message + "-" + " " + Me.Dokumenttypnr.ToString + " " + Me.Dokumenttyp.sBezeichnung.Value + " " + Me.BKPAR00 + ": ")
            PerfMon.force_insert_entry("Dok (N): Wordlib Errormessage: " + w.Errormessage)
            w.ProgressBar.Visible = False
            Me.Cursor = Cursors.Default
            If Me.CreateDocument Then w.Restore(1) Else w.Restore(2)
            DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
            Me.Cursor = Cursors.Default
            Me.btnWeiter.Enabled = True
            Me.Visible = True
            Try
                conn.CloseConnection(True)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Dokumentwerte Method

Private Function Dokumentwerte( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentwerte(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Dokumentwerte_Sichern Method

Public Sub Dokumentwerte_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern()
        Dim xdata As DataTable
        xdata = Me.tbldokumentwerte
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()
        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String = ""
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.NRPAR00, "", 3, 0, 0, 0, s)
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch ex As Exception
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 2 'benötigt
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
            Case 3 'Benötigt
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Notizen"
            Case 5
                scmCmdToExecute.CommandText = "sp_funktion_zuweisung_gestattet"
            Case 7 'Benötigt
                'scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
                scmCmdToExecute.CommandText = "dbo.SP_edex_bl_team"
            Case 8
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_kube"
            Case 9
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 10
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 11
                scmCmdToExecute.CommandText = "sp_dokument_als_bcdokument"
            Case 12
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 13
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case 14
                scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case 15
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 16
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    If Me.Dokumentid = Nothing Then Me.Dokumentid = ""
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    If Me.CreateDocument = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    If Globals.bckdokument = False Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    End If
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 7
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
                    'If Me.TeamZustaendig = Globals.MitarbeiterNr Then
                    '    scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    '    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TeamZustaendig))

                    '    '                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Profilnr))
                    '    '                       scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    'Else
                    '    scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    '    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TeamZustaendig))
                    'End If
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
                Case 9
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 16
                    'scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    'scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    'scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 17
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Get_Dokumentwerte Method

Private Function Get_Dokumentwerte( _
   ByVal CreateNew As Integer _
) As DataTable

Parameters

CreateNew
Required.

Source code

[Visual Basic]
    Private Function Get_Dokumentwerte(ByVal CreateNew As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttyp.iDokumenttypnr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@createnew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, CreateNew))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Get_Mitarbeiter Method

Private Function Get_Mitarbeiter() As DataTable

Source code

[Visual Basic]
    Private Function Get_Mitarbeiter() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_Mitarbeiter"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Get_blvs Method

Private Function Get_blvs() As DataTable

Source code

[Visual Basic]
    Private Function Get_blvs() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_blv"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Get_kubes Method

Private Function Get_kubes() As DataTable

Source code

[Visual Basic]
    Private Function Get_kubes() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_kube"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBLDruck))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.cbverantwortlich = New System.Windows.Forms.ComboBox()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.dtgrundlage3overlay = New System.Windows.Forms.TextBox()
        Me.cbgrundlage4 = New System.Windows.Forms.CheckBox()
        Me.dtgrundlage4 = New System.Windows.Forms.DateTimePicker()
        Me.dtgrundlage3 = New System.Windows.Forms.DateTimePicker()
        Me.cbgrundlage3 = New System.Windows.Forms.CheckBox()
        Me.cbgrundlage2 = New System.Windows.Forms.CheckBox()
        Me.dtgrundlage2 = New System.Windows.Forms.DateTimePicker()
        Me.cbgrundlage1 = New System.Windows.Forms.CheckBox()
        Me.dtgrundlage1 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.txtBeilage = New System.Windows.Forms.TextBox()
        Me.cbbeilage3 = New System.Windows.Forms.CheckBox()
        Me.cbbeilage2 = New System.Windows.Forms.CheckBox()
        Me.cbbeilage1 = New System.Windows.Forms.CheckBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.rbverschlossen = New System.Windows.Forms.RadioButton()
        Me.rbnichtverschlossen = New System.Windows.Forms.RadioButton()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.rbzustellungpost = New System.Windows.Forms.RadioButton()
        Me.rbpersoenlich = New System.Windows.Forms.RadioButton()
        Me.txtbemerkung = New System.Windows.Forms.TextBox()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.cbblv = New System.Windows.Forms.ComboBox()
        Me.rbAushaendigungKube = New System.Windows.Forms.RadioButton()
        Me.rbAushaendigungBLV = New System.Windows.Forms.RadioButton()
        Me.cbkube = New System.Windows.Forms.ComboBox()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtAnredeZusteller = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.lblUnterschrift1 = New System.Windows.Forms.Label()
        Me.cbDel2Page = New System.Windows.Forms.CheckBox()
        Me.txtZustelladresse = New System.Windows.Forms.TextBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.cbzustaendiger = New System.Windows.Forms.ComboBox()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.GroupBox7.SuspendLayout()
        Me.GroupBox9.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox8.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.SuspendLayout()
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(8, 400)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(88, 23)
        Me.btnAbbruch.TabIndex = 3
        Me.btnAbbruch.Text = "Abbruch"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(600, 400)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(128, 23)
        Me.btnWeiter.TabIndex = 4
        Me.btnWeiter.Text = "Weiter >>"
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.Location = New System.Drawing.Point(104, 400)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(112, 21)
        Me.cbdokumentstatus.TabIndex = 5
        Me.cbdokumentstatus.Text = "cbdokumentstatus"
        Me.cbdokumentstatus.Visible = False
        '
        'cbverantwortlich
        '
        Me.cbverantwortlich.Location = New System.Drawing.Point(224, 400)
        Me.cbverantwortlich.Name = "cbverantwortlich"
        Me.cbverantwortlich.Size = New System.Drawing.Size(168, 21)
        Me.cbverantwortlich.TabIndex = 7
        Me.cbverantwortlich.Text = "cbverantwortlich"
        Me.cbverantwortlich.Visible = False
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "SP_Dokumentbearbeitung_Dokumentwerte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("Feldwert", "Feldwert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[SP_Dokumentbearbeitung_Dokumentwerte]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentid", System.Data.SqlDbType.VarChar, 20))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@CreateNew", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(152, 24)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(112, 20)
        Me.DateTimePicker1.TabIndex = 6
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 24)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(104, 23)
        Me.Label3.TabIndex = 0
        Me.Label3.Text = "Dokumentdatum"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.dtgrundlage3overlay, Me.cbgrundlage4, Me.dtgrundlage4, Me.dtgrundlage3, Me.cbgrundlage3, Me.cbgrundlage2, Me.dtgrundlage2})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(352, 96)
        Me.GroupBox4.TabIndex = 29
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Grundlage"
        '
        'dtgrundlage3overlay
        '
        Me.dtgrundlage3overlay.Enabled = False
        Me.dtgrundlage3overlay.Location = New System.Drawing.Point(248, 64)
        Me.dtgrundlage3overlay.Name = "dtgrundlage3overlay"
        Me.dtgrundlage3overlay.Size = New System.Drawing.Size(80, 20)
        Me.dtgrundlage3overlay.TabIndex = 11
        Me.dtgrundlage3overlay.Text = ""
        Me.dtgrundlage3overlay.Visible = False
        '
        'cbgrundlage4
        '
        Me.cbgrundlage4.Location = New System.Drawing.Point(16, 40)
        Me.cbgrundlage4.Name = "cbgrundlage4"
        Me.cbgrundlage4.Size = New System.Drawing.Size(208, 24)
        Me.cbgrundlage4.TabIndex = 10
        Me.cbgrundlage4.Text = "Einmalig telefonischer Auftrag vom"
        '
        'dtgrundlage4
        '
        Me.dtgrundlage4.Enabled = False
        Me.dtgrundlage4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtgrundlage4.Location = New System.Drawing.Point(248, 40)
        Me.dtgrundlage4.Name = "dtgrundlage4"
        Me.dtgrundlage4.Size = New System.Drawing.Size(96, 20)
        Me.dtgrundlage4.TabIndex = 9
        '
        'dtgrundlage3
        '
        Me.dtgrundlage3.Enabled = False
        Me.dtgrundlage3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtgrundlage3.Location = New System.Drawing.Point(248, 64)
        Me.dtgrundlage3.Name = "dtgrundlage3"
        Me.dtgrundlage3.Size = New System.Drawing.Size(96, 20)
        Me.dtgrundlage3.TabIndex = 5
        '
        'cbgrundlage3
        '
        Me.cbgrundlage3.Location = New System.Drawing.Point(16, 64)
        Me.cbgrundlage3.Name = "cbgrundlage3"
        Me.cbgrundlage3.Size = New System.Drawing.Size(232, 24)
        Me.cbgrundlage3.TabIndex = 8
        Me.cbgrundlage3.Text = "Periodische Zustellung gem. Auftrag vom"
        '
        'cbgrundlage2
        '
        Me.cbgrundlage2.Location = New System.Drawing.Point(16, 16)
        Me.cbgrundlage2.Name = "cbgrundlage2"
        Me.cbgrundlage2.Size = New System.Drawing.Size(192, 24)
        Me.cbgrundlage2.TabIndex = 7
        Me.cbgrundlage2.Text = "Einmalig schriftlicher Auftrag vom"
        '
        'dtgrundlage2
        '
        Me.dtgrundlage2.Enabled = False
        Me.dtgrundlage2.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtgrundlage2.Location = New System.Drawing.Point(248, 16)
        Me.dtgrundlage2.Name = "dtgrundlage2"
        Me.dtgrundlage2.Size = New System.Drawing.Size(96, 20)
        Me.dtgrundlage2.TabIndex = 4
        '
        'cbgrundlage1
        '
        Me.cbgrundlage1.Location = New System.Drawing.Point(168, 400)
        Me.cbgrundlage1.Name = "cbgrundlage1"
        Me.cbgrundlage1.Size = New System.Drawing.Size(192, 24)
        Me.cbgrundlage1.TabIndex = 6
        Me.cbgrundlage1.Text = "Banklagernd-Erklärung vom"
        Me.cbgrundlage1.Visible = False
        '
        'dtgrundlage1
        '
        Me.dtgrundlage1.Enabled = False
        Me.dtgrundlage1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtgrundlage1.Location = New System.Drawing.Point(376, 400)
        Me.dtgrundlage1.Name = "dtgrundlage1"
        Me.dtgrundlage1.Size = New System.Drawing.Size(96, 20)
        Me.dtgrundlage1.TabIndex = 3
        Me.dtgrundlage1.Visible = False
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBeilage, Me.cbbeilage3, Me.cbbeilage2, Me.cbbeilage1})
        Me.GroupBox3.FlatStyle = System.Windows.Forms.FlatStyle.Flat
        Me.GroupBox3.Location = New System.Drawing.Point(368, 8)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(352, 80)
        Me.GroupBox3.TabIndex = 28
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Beilage zur Quittung"
        '
        'txtBeilage
        '
        Me.txtBeilage.Enabled = False
        Me.txtBeilage.Location = New System.Drawing.Point(16, 56)
        Me.txtBeilage.Name = "txtBeilage"
        Me.txtBeilage.Size = New System.Drawing.Size(328, 20)
        Me.txtBeilage.TabIndex = 3
        Me.txtBeilage.Text = ""
        '
        'cbbeilage3
        '
        Me.cbbeilage3.Location = New System.Drawing.Point(16, 32)
        Me.cbbeilage3.Name = "cbbeilage3"
        Me.cbbeilage3.TabIndex = 2
        Me.cbbeilage3.Text = "Andere"
        '
        'cbbeilage2
        '
        Me.cbbeilage2.Location = New System.Drawing.Point(16, 16)
        Me.cbbeilage2.Name = "cbbeilage2"
        Me.cbbeilage2.Size = New System.Drawing.Size(136, 16)
        Me.cbbeilage2.TabIndex = 1
        Me.cbbeilage2.Text = "Kopie des Auftrages"
        '
        'cbbeilage1
        '
        Me.cbbeilage1.Location = New System.Drawing.Point(296, 16)
        Me.cbbeilage1.Name = "cbbeilage1"
        Me.cbbeilage1.Size = New System.Drawing.Size(48, 16)
        Me.cbbeilage1.TabIndex = 0
        Me.cbbeilage1.Text = "Einschreiben-Beleg"
        Me.cbbeilage1.Visible = False
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbverschlossen, Me.rbnichtverschlossen})
        Me.GroupBox2.FlatStyle = System.Windows.Forms.FlatStyle.Flat
        Me.GroupBox2.Location = New System.Drawing.Point(8, 288)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(352, 64)
        Me.GroupBox2.TabIndex = 27
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Form der Aushändigung"
        '
        'rbverschlossen
        '
        Me.rbverschlossen.Location = New System.Drawing.Point(16, 32)
        Me.rbverschlossen.Name = "rbverschlossen"
        Me.rbverschlossen.Size = New System.Drawing.Size(200, 24)
        Me.rbverschlossen.TabIndex = 11
        Me.rbverschlossen.Text = "In verschlossenem Umschlag"
        '
        'rbnichtverschlossen
        '
        Me.rbnichtverschlossen.Location = New System.Drawing.Point(16, 16)
        Me.rbnichtverschlossen.Name = "rbnichtverschlossen"
        Me.rbnichtverschlossen.Size = New System.Drawing.Size(184, 24)
        Me.rbnichtverschlossen.TabIndex = 12
        Me.rbnichtverschlossen.Text = "Nicht verschlossen"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbzustellungpost, Me.rbpersoenlich})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 216)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(352, 64)
        Me.GroupBox1.TabIndex = 26
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Art der Aushändigung"
        '
        'rbzustellungpost
        '
        Me.rbzustellungpost.Location = New System.Drawing.Point(16, 37)
        Me.rbzustellungpost.Name = "rbzustellungpost"
        Me.rbzustellungpost.Size = New System.Drawing.Size(120, 16)
        Me.rbzustellungpost.TabIndex = 9
        Me.rbzustellungpost.Text = "Zustellung per Post"
        '
        'rbpersoenlich
        '
        Me.rbpersoenlich.Location = New System.Drawing.Point(16, 16)
        Me.rbpersoenlich.Name = "rbpersoenlich"
        Me.rbpersoenlich.TabIndex = 8
        Me.rbpersoenlich.Text = "Persönlich"
        '
        'txtbemerkung
        '
        Me.txtbemerkung.Location = New System.Drawing.Point(8, 16)
        Me.txtbemerkung.Multiline = True
        Me.txtbemerkung.Name = "txtbemerkung"
        Me.txtbemerkung.Size = New System.Drawing.Size(256, 256)
        Me.txtbemerkung.TabIndex = 25
        Me.txtbemerkung.Text = ""
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbblv, Me.rbAushaendigungKube, Me.rbAushaendigungBLV, Me.cbkube})
        Me.GroupBox5.Location = New System.Drawing.Point(8, 112)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(352, 96)
        Me.GroupBox5.TabIndex = 30
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Aushändigung durch"
        '
        'cbblv
        '
        Me.cbblv.Location = New System.Drawing.Point(136, 30)
        Me.cbblv.Name = "cbblv"
        Me.cbblv.Size = New System.Drawing.Size(208, 21)
        Me.cbblv.TabIndex = 12
        '
        'rbAushaendigungKube
        '
        Me.rbAushaendigungKube.Location = New System.Drawing.Point(16, 64)
        Me.rbAushaendigungKube.Name = "rbAushaendigungKube"
        Me.rbAushaendigungKube.Size = New System.Drawing.Size(112, 24)
        Me.rbAushaendigungKube.TabIndex = 11
        Me.rbAushaendigungKube.Text = "Kundenberater"
        '
        'rbAushaendigungBLV
        '
        Me.rbAushaendigungBLV.Location = New System.Drawing.Point(16, 24)
        Me.rbAushaendigungBLV.Name = "rbAushaendigungBLV"
        Me.rbAushaendigungBLV.Size = New System.Drawing.Size(104, 32)
        Me.rbAushaendigungBLV.TabIndex = 10
        Me.rbAushaendigungBLV.Text = "Banklagernd-Verantwortlicher"
        '
        'cbkube
        '
        Me.cbkube.Location = New System.Drawing.Point(136, 64)
        Me.cbkube.Name = "cbkube"
        Me.cbkube.Size = New System.Drawing.Size(208, 21)
        Me.cbkube.TabIndex = 9
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2})
        Me.TabControl1.Location = New System.Drawing.Point(0, 8)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(736, 384)
        Me.TabControl1.TabIndex = 32
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox10, Me.GroupBox4, Me.GroupBox1, Me.GroupBox3, Me.GroupBox5, Me.GroupBox2})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(728, 358)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Einstellungen Aushändigungsquittung"
        '
        'GroupBox10
        '
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label4, Me.txtAnredeZusteller, Me.Label2, Me.Label1, Me.cbUnterschriftrechts, Me.lblUnterschrift1, Me.cbDel2Page, Me.txtZustelladresse, Me.Label13, Me.Button2})
        Me.GroupBox10.Location = New System.Drawing.Point(368, 96)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(352, 256)
        Me.GroupBox10.TabIndex = 35
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Kunden-Kopie"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(96, 32)
        Me.Label4.TabIndex = 37
        Me.Label4.Text = "Kopie für den Kunden drucken"
        '
        'txtAnredeZusteller
        '
        Me.txtAnredeZusteller.Location = New System.Drawing.Point(104, 216)
        Me.txtAnredeZusteller.Name = "txtAnredeZusteller"
        Me.txtAnredeZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtAnredeZusteller.TabIndex = 1
        Me.txtAnredeZusteller.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 232)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(100, 16)
        Me.Label2.TabIndex = 36
        Me.Label2.Text = "(z.B.: Herr Muster)"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 64)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(96, 16)
        Me.Label1.TabIndex = 35
        Me.Label1.Text = "Zustelladresse"
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(104, 112)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(240, 21)
        Me.cbUnterschriftrechts.TabIndex = 33
        Me.cbUnterschriftrechts.Visible = False
        '
        'lblUnterschrift1
        '
        Me.lblUnterschrift1.Location = New System.Drawing.Point(8, 112)
        Me.lblUnterschrift1.Name = "lblUnterschrift1"
        Me.lblUnterschrift1.Size = New System.Drawing.Size(96, 16)
        Me.lblUnterschrift1.TabIndex = 34
        Me.lblUnterschrift1.Text = "Unterschrift rechts"
        Me.lblUnterschrift1.Visible = False
        '
        'cbDel2Page
        '
        Me.cbDel2Page.Location = New System.Drawing.Point(104, 24)
        Me.cbDel2Page.Name = "cbDel2Page"
        Me.cbDel2Page.Size = New System.Drawing.Size(168, 24)
        Me.cbDel2Page.TabIndex = 32
        '
        'txtZustelladresse
        '
        Me.txtZustelladresse.Location = New System.Drawing.Point(104, 64)
        Me.txtZustelladresse.Multiline = True
        Me.txtZustelladresse.Name = "txtZustelladresse"
        Me.txtZustelladresse.Size = New System.Drawing.Size(240, 144)
        Me.txtZustelladresse.TabIndex = 0
        Me.txtZustelladresse.Text = ""
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 216)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(96, 16)
        Me.Label13.TabIndex = 2
        Me.Label13.Text = "Anrede"
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(8, 80)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 2
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox7, Me.GroupBox9, Me.GroupBox8, Me.GroupBox6})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(728, 358)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Dokument-Angaben"
        '
        'GroupBox7
        '
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox7.Location = New System.Drawing.Point(288, 8)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(432, 56)
        Me.GroupBox7.TabIndex = 9
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Teamzuordnung"
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(8, 24)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(248, 21)
        Me.cbteam.TabIndex = 10
        Me.cbteam.Text = "cbteam"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox9.Location = New System.Drawing.Point(288, 72)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(432, 280)
        Me.GroupBox9.TabIndex = 8
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Notizen"
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(196, 80)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines1
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 4
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu1
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(3, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines2
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(426, 261)
        Me.Notizlist.TabIndex = 1
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 422, 257</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 422, " & _
        "257</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.DateTimePicker1})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(272, 56)
        Me.GroupBox8.TabIndex = 7
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Datumsangaben"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtbemerkung})
        Me.GroupBox6.Location = New System.Drawing.Point(8, 72)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(272, 280)
        Me.GroupBox6.TabIndex = 31
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Bemerkungen"
        '
        'cbzustaendiger
        '
        Me.cbzustaendiger.Location = New System.Drawing.Point(400, 400)
        Me.cbzustaendiger.Name = "cbzustaendiger"
        Me.cbzustaendiger.Size = New System.Drawing.Size(192, 21)
        Me.cbzustaendiger.TabIndex = 33
        Me.cbzustaendiger.Text = "cbzustaendiger"
        Me.cbzustaendiger.Visible = False
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(711, 1)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 69
        '
        'frmBLDruck
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(738, 431)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.cbzustaendiger, Me.TabControl1, Me.cbverantwortlich, Me.btnWeiter, Me.btnAbbruch, Me.cbdokumentstatus, Me.cbgrundlage1, Me.dtgrundlage1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmBLDruck"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Druck BL-Dossier: "
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.GroupBox7.ResumeLayout(False)
        Me.GroupBox9.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox8.ResumeLayout(False)
        Me.GroupBox6.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Load_Defaults Method

Private Sub Load_Defaults()

Source code

[Visual Basic]
    Private Sub Load_Defaults()
        'Partner auslesen
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(Me.NRPAR00, Int32))
        p.SelectOne()

        'Dokumenttyp auslesen
        Dokumenttyp.cpMainConnectionProvider = conn
        Me.Dokumenttypnr = get_bldokumenttyp()
        Dokumenttyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        Dokumenttyp.SelectOne()

        'Auslieferung erstellen
        Dim auslieferung As New edokadb.clsEDEX_BL_Auslieferung()
        auslieferung.cpMainConnectionProvider = conn
        auslieferung.bAktiv = New SqlBoolean(CType(True, Boolean))
        auslieferung.iNrpar00 = New SqlInt32(CType(Me.NRPAR00, Int32))

        'Dokumentwerte zusammenstellen
        tbldokumentwerte = Get_Dokumentwerte(1)

        'Intere Statustabelle erstellen und Status auf "In Bearbeitung setzen"
        Me.mcbstatus = New MultiComboBox(Me.cbdokumentstatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)
        Me.mcbstatus.SelectedIndex = 0

        'Interne ZuständigerTabelle
        Dim ii As Integer = 0
        mcbzust = New MultiComboBox(Me.cbzustaendiger)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii
        Me.TeamZustaendig = Globals.MitarbeiterNr

        'Interne Liste mit Verantwortlichen
        Me.mcbverantwortlich = New MultiComboBox(cbverantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        FillMcbVerantwortlich()

        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.Visible = True
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        refresh_team()

        Me.mcbstatus.SelectedIndex = 0
        Me.SaveStatus = Me.mcbstatus.SelectedValue
        Me.FirstStatus = Me.SaveStatus
        Me.SaveVerantwortlicher = Globals.MitarbeiterNr

        Me.mcbblv = New MultiComboBox(Me.cbblv)
        Me.mcbblv.CheckNullValue = True
        Me.mcbblv.NullValueMessage = MyTxt.gettext(18)
        Me.mcbblv.DisplayColumnName = "mitarbeiter"
        Me.mcbblv.ValueColumnName = "mitarbeiternr"
        Me.mcbblv.Fill_Data(Get_blvs, False)
        Dim i As Integer
        i = Globals.MitarbeiterNr
        Me.mcbblv.SelectedValue = i

        Me.mcbkube = New MultiComboBox(Me.cbkube)
        Me.mcbkube.CheckNullValue = True
        Me.mcbkube.NullValueMessage = MyTxt.gettext(18)
        Me.mcbkube.DisplayColumnName = "mitarbeiter"
        Me.mcbkube.ValueColumnName = "mitarbeiternr"
        Me.mcbkube.Fill_Data(Get_kubes, False)

        Me.rbAushaendigungBLV.Checked = True

        Dim zkube As Integer = Me.get_zustaendiger_kube
        Me.mcbzust.SelectedValue = zkube

        'KUBE Positionieren, sofern er auch in der Liste ist
        Try
            Me.mcbkube.SelectedValue = zkube
        Catch

        End Try

        Me.mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
        Me.mcbunterschriftrechts.CheckNullValue = True
        Me.mcbunterschriftrechts.NullValueMessage = MyTxt.gettext(18)
        Me.mcbunterschriftrechts.DisplayColumnName = "mitarbeiter"
        Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
        Me.mcbunterschriftrechts.Fill_Data(Me.Get_Mitarbeiter, True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Load_EditDok Method

Private Sub Load_EditDok()

Source code

[Visual Basic]
    Private Sub Load_EditDok()
        EditDok.cpMainConnectionProvider = conn
        EditDok.iAuslieferungnr = New SqlInt32(CType(Me.auslieferungnr, Int32))
        EditDok.SelectOne()

        Me.cbgrundlage1.Checked = EditDok.bGrundlage1.Value = True
        Me.cbgrundlage2.Checked = EditDok.bGrundlage2.Value = True
        Me.cbgrundlage3.Checked = EditDok.bGrundlage3.Value = True
        Me.cbgrundlage4.Checked = EditDok.bGrundlage4.Value = True

        Me.dtgrundlage1.Value = EditDok.daGrundlage1_Datum.Value
        Me.dtgrundlage2.Value = EditDok.daGrundlage2_Datum.Value
        Me.dtgrundlage3.Value = EditDok.daGrundlage3_Datum.Value
        Me.dtgrundlage4.Value = EditDok.daGrundlage4_Datum.Value

        Me.rbAushaendigungBLV.Checked = EditDok.bAushaendigung_blv.Value = True
        Me.rbAushaendigungKube.Checked = EditDok.bAushaendigung_kube.Value = True
        Me.mcbblv.SelectedValue = EditDok.iBlv.Value
        Me.mcbkube.SelectedValue = EditDok.iKube.Value
        Me.rbpersoenlich.Checked = EditDok.bAushaendigungsart_persoenlich.Value = True
        Me.rbzustellungpost.Checked = EditDok.bAushaendigungsart_post.Value = True
        Me.cbDel2Page.Checked = EditDok.bBeilage_zur_Quittung1.Value = True
        Me.rbverschlossen.Checked = EditDok.bAushaendigung_verschlossen.Value = True
        Me.rbnichtverschlossen.Checked = EditDok.bAushaendigung_nicht_verschlossen.Value = True

        'Me.cbbeilage1.Checked = EditDok.bBeilage_zur_Quittung1.Value = True
        Me.cbbeilage2.Checked = EditDok.bBeilage_zur_Quittung2.Value = True
        Me.cbbeilage3.Checked = EditDok.bBeilage_zur_Quittung3.Value = True
        Me.txtBeilage.Text = EditDok.sBeilage_zur_Quittung_text.Value
        Me.txtbemerkung.Text = EditDok.sBemerkung.Value

        Me.EditDoc.cpMainConnectionProvider = conn
        EditDoc.sDokumentid = New SqlString(CType(Me.EditDok.sDokumentid_quittung.Value, String))
        EditDoc.SelectOne()

        Me.DateTimePicker1.Value = Me.EditDoc.daErstelltam.Value
        Me.txtZustelladresse.Text = Me.EditDoc.sZustelladresse.Value
        Me.txtAnredeZusteller.Text = Me.EditDoc.sAnredezustelladresse.Value
        Dim ii As Integer
        ii = EditDoc.iUnterschriftrechts.Value
        Me.mcbunterschriftrechts.SelectedValue = ii

        'If Me.cbDel2Page.Checked = False Then
        '    Me.txtZustelladresse.Enabled = False
        '    Me.txtAnredeZusteller.Enabled = False
        '    Me.grpZustelladresse.Enabled = False
        '    Me.txtZustelladresse.Text = ""
        '    Me.txtAnredeZusteller.Text = ""
        '    Me.lblUnterschrift1.Visible = False
        '    Me.cbUnterschriftrechts.Visible = False
        '    Me.mcbunterschriftrechts.Visible = False
        'Else
        '    Me.grpZustelladresse.Enabled = True
        '    Me.txtZustelladresse.Enabled = True
        '    Me.txtAnredeZusteller.Enabled = True
        '    Me.lblUnterschrift1.Visible = True
        '    Me.cbUnterschriftrechts.Visible = True
        '    Me.mcbunterschriftrechts.Visible = True
        'End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Load_Notizen Method

Private Sub Load_Notizen()

Source code

[Visual Basic]
    Private Sub Load_Notizen()
        Me.Notizen = Notizen_Laden(Me.Dokumentid)
        w.Save_Notizen = Me.Notizen
        '        w.Save_Notizen = Notizen_Laden(Me.DokumentID)
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Load_Partnerdata Method

Private Sub Load_Partnerdata()

Source code

[Visual Basic]
    Private Sub Load_Partnerdata()
        Me.tblperi = get_peridata()
        Me.cbgrundlage1.Checked = False
        If Me.tblperi.Rows.Count > 0 Then
            Me.cbgrundlage3.Checked = True
            Me.dtgrundlage3.Value = Me.tblperi.Rows(0).Item("auftragsdatum")
        Else
            Me.cbgrundlage3.Enabled = False
            Me.dtgrundlage3overlay.Visible = True

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Try
            Me.Notizlist.Columns(5).Value = False
            Me.Notizlist.Refresh()
            Me.Notizlist.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlist.Columns("betreff").Value = f.Betreff
            Me.Notizlist.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlist.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim f As New frmNotizen()
        f.Mutierer = Globals.MitarbeiterNr.ToString
        f.Notiz = ""
        f.Betreff = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizen.Rows
            Dim rowvals(Me.Notizen.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer

            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizen
            load_Mitarbeiter()

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Notizen_Laden Method

Private Function Notizen_Laden( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Notizen_Laden(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Notizlist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Notizlist.DoubleClick
        MnuEditNotiz_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Save_Aushaendigungsquittung Method

Private Function Save_Aushaendigungsquittung() As Boolean

Source code

[Visual Basic]
    Private Function Save_Aushaendigungsquittung() As Boolean
        If Me.Editmode = False Then
            Me.dokumentebis = Now
            If letzte_auslieferung() = False Then
                Dim f As New frmBLDatumab()
                f.ShowDialog()
                If f.DialogResult = DialogResult.Abort Then Return False
                Me.dokumenteab = f.DateTimePicker1.Value
            Else
            End If
        Else
        End If

        Dim Quittung As New edokadb.clsEDEX_BL_Auslieferung()
        Quittung.cpMainConnectionProvider = conn
        If Me.Editmode = True Then
            Quittung.iAuslieferungnr = New SqlInt32(CType(Me.auslieferungnr, Int32))
            Quittung.SelectOne()
            Me.dokumentebis = Quittung.daDokumentebis.Value
            Me.dokumenteab = Quittung.daDokumenteab.Value
        End If
        Quittung.sBezeichnung = New SqlString(CType("", String))
        Quittung.sDokumentid_quittung = New SqlString(CType(Me.Dokumentid, String))
        Quittung.sQuittungsflag = New SqlString(CType("", String))
        Quittung.iNrpar00 = New SqlInt32(CType(Me.NRPAR00, Int32))
        If Me.Editmode = False Then
            Quittung.iStatus = New SqlInt32(CType(0, Int32))
            Quittung.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        End If
        Quittung.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        Quittung.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        Quittung.bAktiv = New SqlBoolean(CType(True, Boolean))
        Quittung.bGrundlage1 = New SqlBoolean(CType(Me.cbgrundlage1.Checked, Boolean))
        Quittung.bGrundlage2 = New SqlBoolean(CType(Me.cbgrundlage2.Checked, Boolean))
        Quittung.bGrundlage3 = New SqlBoolean(CType(Me.cbgrundlage3.Checked, Boolean))
        Quittung.bGrundlage4 = New SqlBoolean(CType(Me.cbgrundlage4.Checked, Boolean))
        Quittung.daGrundlage1_Datum = New SqlDateTime(CType(Me.dtgrundlage1.Value, DateTime))
        Quittung.daGrundlage2_Datum = New SqlDateTime(CType(Me.dtgrundlage2.Value, DateTime))
        Quittung.daGrundlage3_Datum = New SqlDateTime(CType(Me.dtgrundlage3.Value, DateTime))
        Quittung.daGrundlage4_Datum = New SqlDateTime(CType(Me.dtgrundlage4.Value, DateTime))
        Quittung.bAushaendigung_blv = New SqlBoolean(CType(Me.rbAushaendigungBLV.Checked, Boolean))
        Quittung.bAushaendigung_kube = New SqlBoolean(CType(Me.rbAushaendigungKube.Checked, Boolean))
        Quittung.bAushaendigungsart_persoenlich = New SqlBoolean(CType(Me.rbpersoenlich.Checked, Boolean))
        Quittung.bAushaendigungsart_post = New SqlBoolean(CType(Me.rbzustellungpost.Checked, Boolean))
        Quittung.bAushaendigung_verschlossen = New SqlBoolean(CType(Me.rbverschlossen.Checked, Boolean))
        Quittung.bAushaendigung_nicht_verschlossen = New SqlBoolean(CType(Me.rbnichtverschlossen.Checked, Boolean))

        'Quittung.bAushaendigung_verschlossen = New SqlBoolean(CType(False, Boolean))
        'Quittung.bAushaendigung_nicht_verschlossen = New SqlBoolean(CType(False, Boolean))

        Quittung.bBeilage_zur_Quittung1 = New SqlBoolean(CType(Me.cbbeilage1.Checked, Boolean))
        Quittung.bBeilage_zur_Quittung1 = New SqlBoolean(CType(Me.cbDel2Page.Checked, Boolean))
        Quittung.bBeilage_zur_Quittung2 = New SqlBoolean(CType(Me.cbbeilage2.Checked, Boolean))
        Quittung.bBeilage_zur_Quittung3 = New SqlBoolean(CType(Me.cbbeilage3.Checked, Boolean))
        Quittung.sBeilage_zur_Quittung_text = New SqlString(CType(Me.txtBeilage.Text, String))
        Quittung.sBemerkung = New SqlString(CType(Me.txtbemerkung.Text, String))
        Quittung.iBlv = New SqlInt32(CType(Me.mcbblv.SelectedValue, Int32))
        Quittung.iKube = New SqlInt32(CType(Me.mcbkube.SelectedValue, Int32))
        If Me.Editmode = False Then
            Quittung.daDokumenteab = New SqlDateTime(CType(Me.dokumenteab, DateTime))
            Quittung.daDokumentebis = New SqlDateTime(CType(Me.dokumentebis, DateTime))
            conn.OpenConnection()
            Quittung.Insert()
            conn.CloseConnection(True)
            Me.Aushaendigungnr = Quittung.iAuslieferungnr.Value
            Quittung.Dispose()
        Else
            conn.OpenConnection()
            Quittung.Update()
            conn.CloseConnection(True)
            Me.Aushaendigungnr = Quittung.iAuslieferungnr.Value
            Quittung.Dispose()

        End If
        Return True

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Set_Dokumentwerte Method

Private Sub Set_Dokumentwerte()

Source code

[Visual Basic]
    Private Sub Set_Dokumentwerte()
        Dim bldata As New edokadb.clsEdex_bl_parameter()
        bldata.cpMainConnectionProvider = conn
        bldata.iBlvparamnr = New SqlInt32(CType(1, Int32))
        bldata.SelectOne()

        w.bldokument = True
        If Me.rbAushaendigungBLV.Checked = True Then
            w.bldelquittungkube = True
            w.BLUnterschrift1 = ""
            w.BLUnterschrift2 = Me.get_name_aushaendigung(Me.mcbblv.SelectedValue)
            If Me.rbpersoenlich.Checked = False Then
                w.BLQuittungstext = bldata.sTxtQuittung2.Value
            Else
                w.BLQuittungstext = bldata.sTxtQuittung1.Value
                w.BLUnterschrift2 = DivFnkt.get_parnter_namevorname(Me.NRPAR00) + MyTxt.gettext(737)
            End If
        Else
            w.bldelquittungkube = False
            w.BLUnterschrift1 = Me.get_name_aushaendigung(Me.mcbkube.SelectedValue)
            w.BLUnterschrift2 = DivFnkt.get_parnter_namevorname(Me.NRPAR00) + MyTxt.gettext(737)
            w.BLQuittungstext = bldata.sTxtQuittung1.Value
        End If
        If Me.cbDel2Page.Checked = True Then
            w.BLDel2Page = False
        Else
            w.BLDel2Page = True
        End If
        '        w.BLDel2Page = Me.cbDel2Page.Checked = True

        Dim i As Integer
        For i = 0 To Me.tbldokumentwerte.Rows.Count - 1
            Select Case tbldokumentwerte.Rows(i).Item(6)
                Case "&BLBeilage&"
                    Dim S As String = ""
                    If Me.cbbeilage1.Checked Then
                        '                        If S <> "" Then S = S + vbCrLf
                        If S <> "" Then S = S + Chr(11)
                        S = S + bldata.sTxtbeilage1.Value
                    End If
                    If Me.cbbeilage2.Checked Then
                        If S <> "" Then S = S + Chr(11)
                        '                        If S <> "" Then S = S + vbCrLf
                        S = S + bldata.sTxtbeilage2.Value
                    End If
                    If Me.cbbeilage3.Checked Then
                        'If S <> "" Then S = S + vbCrLf
                        If S <> "" Then S = S + Chr(11)
                        S = S + Me.txtBeilage.Text
                    End If
                    tbldokumentwerte.Rows(i).Item(2) = s
                Case "&BLBemerkung&"
                    tbldokumentwerte.Rows(i).Item(2) = Me.txtbemerkung.Text
                Case "&BLArt&"
                    If Me.rbpersoenlich.Checked Then
                        tbldokumentwerte.Rows(i).Item(2) = bldata.sTxtArt1
                    Else
                        tbldokumentwerte.Rows(i).Item(2) = bldata.sTxtArt2
                    End If
                Case "&BLForm&"
                    If Me.rbnichtverschlossen.Checked Then
                        tbldokumentwerte.Rows(i).Item(2) = bldata.sTxtForm1.Value
                    Else
                        tbldokumentwerte.Rows(i).Item(2) = bldata.sTxtForm2.Value
                    End If
                Case "&BLAushaendigung&"
                    Dim s As String
                    If Me.rbAushaendigungBLV.Checked Then
                        tbldokumentwerte.Rows(i).Item(2) = Me.get_name_aushaendigung(Me.mcbblv.SelectedValue)
                    Else
                        tbldokumentwerte.Rows(i).Item(2) = Me.get_name_aushaendigung(Me.mcbkube.SelectedValue)
                    End If
                Case "&BLDokumenteAb&"
                    tbldokumentwerte.Rows(i).Item(2) = Me.dokumenteab.ToShortDateString
                Case "&BLDokumentebis&"
                    tbldokumentwerte.Rows(i).Item(2) = Me.dokumentebis.ToShortDateString
                Case "&BLGrund&"
                    Dim s As String = ""
                    If Me.cbgrundlage1.Checked = True Then
                        'If s <> "" Then s = s + vbCrLf
                        If s <> "" Then s = s + Chr(11)
                        s = s + bldata.sTxtGrundlage1.Value
                        s = s.Replace("#Datum#", Me.dtgrundlage1.Value.ToShortDateString)
                    End If
                    If Me.cbgrundlage2.Checked = True Then
                        '                        If s <> "" Then s = s + vbCrLf
                        If s <> "" Then s = s + Chr(11)
                        s = s + bldata.sTxtGrundlage2.Value
                        s = s.Replace("#Datum#", Me.dtgrundlage2.Value.ToShortDateString)
                    End If
                    If Me.cbgrundlage3.Checked = True Then
                        '                      If s <> "" Then s = s + vbCrLf
                        If s <> "" Then s = s + Chr(11)
                        s = s + bldata.sTxtGrundlage4.Value
                        s = s.Replace("#Datum#", Me.dtgrundlage3.Value.ToShortDateString)
                    End If
                    If Me.cbgrundlage4.Checked = True Then
                        '                        If s <> "" Then s = s + vbCrLf
                        If s <> "" Then s = s + Chr(11)
                        s = s + bldata.sTxtGrundlage3.Value
                        s = s.Replace("#Datum#", Me.dtgrundlage4.Value.ToShortDateString)
                    End If
                    tbldokumentwerte.Rows(i).Item(2) = s
                Case Else
            End Select
        Next
        bldata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Set_Zustaendiger Method

Private Sub Set_Zustaendiger()

Source code

[Visual Basic]
    Private Sub Set_Zustaendiger()
        Dim i As Integer
        i = get_zustaendiger_kube()
        Me.mcbzust.SelectedValue = i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.Status_History Method

Private Function Status_History( _
   ByVal statusnr As Long, _
   ByVal dokumentid As String _
)

Parameters

statusnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Status_History(ByVal statusnr As Long, ByVal dokumentid As String)
        Dim statush As New Statushandling()
        Dim i, i1 As Integer
        If Me.SaveVerantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.SaveStatus = Me.mcbstatus.SelectedValue And Not Me.CreateDocument And Me.mcbstatus.SelectedIndex = 0 Then
            If Globals.dokumentcoldindex_status = "" Then
                statush.Dispose()
                Exit Function
            End If
        End If
        If Me.CreateDocument Then
            i = Me.mcbstatus.SelectedValue
            Me.mcbstatus.SelectedIndex = 0
            statush.insert_history_status(get_current_Status(dokumentid), dokumentid, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(1000)
            Me.mcbstatus.SelectedValue = i
            If Me.mcbstatus.SelectedIndex <> 0 Or Me.mcbverantwortlich.SelectedValue <> Me.SaveVerantwortlicher Then
                statush.insert_history_status(get_current_Status(dokumentid), dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
            w.send_statusmessage = True
        Else
            If Me.mcbstatus.SelectedValue <> Me.SaveStatus Or Me.mcbstatus.SelectedIndex <> 0 Or Globals.dokumentcoldindex_status <> "" Then
                i = Me.mcbstatus.SelectedValue
                Me.mcbstatus.SelectedIndex = 0
                Me.SaveStatus = Me.mcbstatus.SelectedValue
                statush.insert_history_status(Me.mcbstatus.SelectedValue, dokumentid, Globals.MitarbeiterNr)
                w.send_statusmessage = True
                Me.mcbstatus.SelectedValue = i
                System.Threading.Thread.CurrentThread.Sleep(1000)
            End If
            If Me.mcbstatus.SelectedValue <> Me.SaveStatus Or Me.mcbverantwortlich.SelectedValue <> Me.SaveVerantwortlicher Then
                statush.insert_history_status(Me.mcbstatus.SelectedValue, dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
        End If

        statush.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.DialogResult = DialogResult.Cancel
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        'Dokument erstellen
        If Me.cbDel2Page.Checked = True And Trim(Me.txtZustelladresse.Text) = "" Then
            MyMsg.show_standardmessage(612, MsgBoxStyle.Critical)
            Exit Sub
        End If
        'If Me.cbDel2Page.Checked = True And Me.mcbunterschriftrechts.Text = "" Then
        '    MyMsg.show_standardmessage(616, MsgBoxStyle.Critical)
        '    Exit Sub
        'End If
        If Me.rbAushaendigungKube.Checked = True And Me.mcbkube.Text = "" Then
            MyMsg.show_standardmessage(617, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Me.CreateDocument = True Then
            Dokumentid = DivFnkt.Generate_Key()
        Else
            Dokumentid = EditDoc.sDokumentid.Value
        End If
        If Not Save_Aushaendigungsquittung() Then Exit Sub
        Set_Dokumentwerte()
        Set_Zustaendiger()
        Dokument_Bearbeiten(Me.CreateDocument)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.cbDel2Page_CheckedChanged Method

Private Sub cbDel2Page_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbDel2Page.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbDel2Page_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbDel2Page.CheckedChanged
        If Me.cbDel2Page.Checked = False Then
            Me.txtZustelladresse.Enabled = False
            Me.Button2.Enabled = False
            Me.txtAnredeZusteller.Enabled = False
            'Me.grpZustelladresse.Enabled = False
            Me.txtZustelladresse.Text = ""
            '            Me.txtAnredeZusteller.Text = ""
            '            Me.lblUnterschrift1.Visible = False
            '           Me.cbUnterschriftrechts.Enabled = False
            Me.mcbunterschriftrechts.Enabled = False
            Me.txtZustelladresse.Enabled = False
            Me.txtZustelladresse.Text = ""
            Me.txtAnredeZusteller.Enabled = False
            Me.Button2.Enabled = False
        Else
            'Me.grpZustelladresse.Enabled = True
            Me.txtZustelladresse.Enabled = True
            Me.Button2.Enabled = True
            Me.txtZustelladresse.Text = ""
            Me.txtAnredeZusteller.Enabled = True
            '          Me.lblUnterschrift1.Visible = True
            '         Me.cbUnterschriftrechts.Enabled = True
            Me.mcbunterschriftrechts.Enabled = True
            Me.txtZustelladresse.Enabled = True
            Me.Button2.Enabled = True
            Me.txtZustelladresse.Text = ""
            Me.txtAnredeZusteller.Enabled = True
            Me.Button2.Enabled = True
            If Me.rbpersoenlich.Checked = True Then Me.rbpersoenlich_CheckedChanged(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.cbbeilage3_CheckedChanged Method

Private Sub cbbeilage3_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbbeilage3.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbbeilage3_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbbeilage3.CheckedChanged
        If Me.cbbeilage3.Checked = True Then
            Me.txtBeilage.Enabled = True
        Else
            Me.txtBeilage.Text = ""
            Me.txtBeilage.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.cbgrundlage_CheckedChanged Method

Akiviert oder deaktiviert die Datumsselektionsfelder je Checkbox

Private Sub cbgrundlage_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbgrundlage1.CheckedChanged, _
   cbgrundlage2.CheckedChanged, _
   cbgrundlage3.CheckedChanged, _
   cbgrundlage4.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbgrundlage_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbgrundlage1.CheckedChanged, cbgrundlage2.CheckedChanged, cbgrundlage3.CheckedChanged, cbgrundlage4.CheckedChanged
        Dim tmpcheckbox As CheckBox
        tmpcheckbox = sender
        Select Case tmpcheckbox.Name
            Case "cbgrundlage1"
                If tmpcheckbox.Checked Then Me.dtgrundlage1.Enabled = False Else Me.dtgrundlage1.Enabled = False
            Case "cbgrundlage2"
                If tmpcheckbox.Checked Then Me.dtgrundlage2.Enabled = True Else Me.dtgrundlage2.Enabled = False
            Case "cbgrundlage3"
                If tmpcheckbox.Checked Then
                    Me.dtgrundlage3.Enabled = False
                Else
                    Me.dtgrundlage3.Enabled = False
                End If
            Case "cbgrundlage4"
                    If tmpcheckbox.Checked Then Me.dtgrundlage4.Enabled = True Else Me.dtgrundlage4.Enabled = False
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.cbkube_SelectedIndexChanged Method

Private Sub cbkube_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbkube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.SelectedIndexChanged
        If m_onload Then Exit Sub
        Dim i As Integer
        Dim i1
        If Me.mcbkube.Text <> "" Then
            i = Me.mcbkube.SelectedValue
        End If
        Me.mcbunterschriftrechts.SelectedValue = i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.cbzustaendiger_SelectedIndexChanged Method

Private Sub cbzustaendiger_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzustaendiger_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Me.TeamZustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.frmBLDruck_Load Method

Private Sub frmBLDruck_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLDruck_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Me.Editmode = True Then
            EditDok.cpMainConnectionProvider = conn
            EditDok.iAuslieferungnr = New SqlInt32(CType(Me.auslieferungnr, Int32))
            EditDok.SelectOne()
            Me.NRPAR00 = EditDok.iNrpar00.Value
            Me.BKPAR00 = Me.get_partnerkurzebezeichnung
        Else
            Me.txtAnredeZusteller.Text = DivFnkt.get_parnter_anrede(Me.NRPAR00)
        End If
        'BUD - 25.10.2006 - Setzten der Globals BCK auf False weil dies sonst komisch ist
        Globals.bckdokument = False

        Me.Text = Me.Text + Me.BKPAR00
        Load_Defaults()
        Load_Partnerdata()
        Load_Notizen()
        If Me.Editmode = True Then
            Load_EditDok()
        Else
            Me.cbDel2Page.Checked = True
            Dim i1
            If Me.mcbkube.Text <> "" Then
                i = Me.mcbkube.SelectedValue
            End If
            Me.mcbunterschriftrechts.SelectedValue = i
        End If
        Me.cbgrundlage1.Checked = False
        m_onload = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_bldokumenttyp Method

Private Function get_bldokumenttyp() As Integer

Source code

[Visual Basic]
    Private Function get_bldokumenttyp() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_dokumenttypnr"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@dokumenttypnr").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_current_Status Method

Private Function get_current_Status( _
   ByVal dokumentid As String _
) As Long

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function get_current_Status(ByVal dokumentid As String) As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_current_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statustext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            get_current_Status = scmCmdToExecute.Parameters.Item("@currentstatus").Value
            Return get_current_Status
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_name_aushaendigung Method

Private Function get_name_aushaendigung( _
   ByVal mitarbeiternr As Integer _
) As String

Parameters

mitarbeiternr
Required.

Source code

[Visual Basic]
    Private Function get_name_aushaendigung(ByVal mitarbeiternr As Integer) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_name_aushaendiger"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiternr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@name", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)

            Return scmCmdToExecute.Parameters.Item("@name").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("get_name_aushändiger::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_partnerkurzebezeichnung Method

Private Function get_partnerkurzebezeichnung() As String

Source code

[Visual Basic]
    Private Function get_partnerkurzebezeichnung() As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_bkpar00"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bkpar00", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)

            Return scmCmdToExecute.Parameters("@bkpar00").Value
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_peridata Method

Private Function get_peridata() As DataTable

Source code

[Visual Basic]
    Private Function get_peridata() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_peridata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@blkundenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.get_zustaendiger_kube Method

Private Function get_zustaendiger_kube() As Integer

Source code

[Visual Basic]
    Private Function get_zustaendiger_kube() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_kube_manr"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters.Item("@mitarbeiternr").Value
        Catch ex As Exception
            Return 0
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.letzte_auslieferung Method

Private Function letzte_auslieferung() As Boolean

Source code

[Visual Basic]
    Private Function letzte_auslieferung() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_letzte_auslieferung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPAR00))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@returncd", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@datum", SqlDbType.DateTime, 8, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, Now))
        Try
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@returncd").Value = -1 Then Return False
            Me.dokumenteab = scmCmdToExecute.Parameters("@datum").Value
            Return True
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.rbAushaendigungBLV_CheckedChanged Method

Private Sub rbAushaendigungBLV_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbAushaendigungBLV.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbAushaendigungBLV_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbAushaendigungBLV.CheckedChanged
        If Me.rbAushaendigungBLV.Checked = True Then
            Me.mcbblv.Enabled = True
            Me.mcbkube.Enabled = False

            Me.rbpersoenlich.Enabled = True
            Me.rbzustellungpost.Enabled = True
            Me.rbpersoenlich.Checked = True

            Me.rbnichtverschlossen.Enabled = True
            Me.rbverschlossen.Enabled = True
            Me.rbnichtverschlossen.Checked = True
            Me.rbverschlossen.Checked = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.rbAushaendigungKube_CheckedChanged Method

Private Sub rbAushaendigungKube_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbAushaendigungKube.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbAushaendigungKube_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbAushaendigungKube.CheckedChanged
        If Me.rbAushaendigungKube.Checked Then
            Me.mcbblv.Enabled = False
            Me.mcbkube.Enabled = True

            Me.rbpersoenlich.Checked = True
            Me.rbzustellungpost.Checked = False
            Me.rbzustellungpost.Enabled = False

            Me.rbnichtverschlossen.Enabled = False
            Me.rbnichtverschlossen.Checked = False
            Me.rbverschlossen.Enabled = True
            Me.rbverschlossen.Checked = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.rbpersoenlich_CheckedChanged Method

Private Sub rbpersoenlich_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbpersoenlich.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbpersoenlich_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbpersoenlich.CheckedChanged
        Me.rbnichtverschlossen.Enabled = True
        Me.rbnichtverschlossen.Checked = True
        Me.rbverschlossen.Enabled = True
        If Me.rbpersoenlich.Checked = True Then
            Me.txtZustelladresse.Text = DivFnkt.get_parnter_namevorname(Me.NRPAR00) + vbCrLf + "persönlich ausgehändigt"
            Me.txtZustelladresse.Enabled = False
            Me.Button2.Enabled = False
        Else
            Me.txtZustelladresse.Text = ""
            Me.Button2.Enabled = True
            Me.txtZustelladresse.Enabled = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.rbzustellungpost_CheckedChanged Method

Private Sub rbzustellungpost_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbzustellungpost_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        If Me.rbzustellungpost.Checked = True Then
            Me.rbnichtverschlossen.Checked = False
            Me.rbverschlossen.Checked = True
            Me.GroupBox2.Enabled = False
        Else
            Me.GroupBox2.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.rbzustellungpost_CheckedChanged_1 Method

Private Sub rbzustellungpost_CheckedChanged_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbzustellungpost.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbzustellungpost_CheckedChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbzustellungpost.CheckedChanged
        If Me.rbzustellungpost.Checked = True Then
            Me.rbnichtverschlossen.Enabled = False
            Me.rbverschlossen.Enabled = True
            Me.rbverschlossen.Checked = True
            Me.cbDel2Page.Checked = True
            Me.cbDel2Page.Enabled = False
            Me.cbkube.Enabled = False
            Me.rbAushaendigungKube.Enabled = False
        Else
            Me.cbDel2Page.Enabled = True
            Me.cbDel2Page.Checked = True
            Me.cbkube.Enabled = True
            Me.rbAushaendigungKube.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        If mcbteam.Items.Count <= 0 Then
            MessageBox.Show(EDOKALib.BusinessFacade.Meldungstext.GetInhaltById(385), EDOKALib.Common.Consts.WARNUNG, MessageBoxButtons.OK, MessageBoxIcon.Warning)
            btnWeiter.Enabled = False
        Else
            mcbteam.SelectedItem = 0
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck Fields

frmBLDruck overview

Fields

field Aushaendigungnr
field BtnHelp
field Button2
field ContextMenu1
field CreateDocument
field CreateNew
field DataSet1
field DateTimePicker1
field Dokumentid
field Dokumenttyp
field Dokumenttypnr
field EditDoc
field EditDok
field Editmode
field FirstStatus
field GroupBox1
field GroupBox10
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field ImageList1
field Label1
field Label13
field Label2
field Label3
field Label4
field MnuDeleteNotiz
field MnuEditNotiz
field MnuNeueNotiz
field Notizen
field Notizlist
field SaveStatus
field SaveVerantwortlicher
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TabControl1
field TabPage1
field TabPage2
field TeamZustaendig
field auslieferungnr
field btnAbbruch
field btnWeiter
field cbDel2Page
field cbUnterschriftrechts
field cbbeilage1
field cbbeilage2
field cbbeilage3
field cbblv
field cbdokumentstatus
field cbgrundlage1
field cbgrundlage2
field cbgrundlage3
field cbgrundlage4
field cbkube
field cbteam
field cbverantwortlich
field cbzustaendiger
field components
field doc
field dokumenteab
field dokumentebis
field drpMiatarbeiter
field dtgrundlage1
field dtgrundlage2
field dtgrundlage3
field dtgrundlage3overlay
field dtgrundlage4
field i
field lblUnterschrift1
field m_Bldossier
field m_bkpar00
field m_nrpar00
field m_onload
field m_profilnr
field mcbblv
field mcbkube
field mcbstatus
field mcbteam
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field rbAushaendigungBLV
field rbAushaendigungKube
field rbnichtverschlossen
field rbpersoenlich
field rbverschlossen
field rbzustellungpost
field tblblkunde
field tbldokumentwerte
field tblperi
field txtAnredeZusteller
field txtBeilage
field txtZustelladresse
field txtbemerkung
field w

See Also

frmBLDruck Class


Aushaendigungnr Variable

Dim Aushaendigungnr As Integer

Source code

[Visual Basic]
    Dim Aushaendigungnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


CreateDocument Variable

Dim CreateDocument As Boolean = True

Source code

[Visual Basic]
    Dim CreateDocument As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


CreateNew Variable

Dim CreateNew As Boolean

Source code

[Visual Basic]
    Dim CreateNew As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Dokumentid Variable

Dim Dokumentid As String = ""

Source code

[Visual Basic]
    Dim Dokumentid As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Dokumenttyp Variable

Dim Dokumenttyp As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim Dokumenttyp As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Dokumenttypnr Variable

Dim Dokumenttypnr As Integer = 469

Source code

[Visual Basic]
    Dim Dokumenttypnr As Integer = 469

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


EditDoc Variable

Dim EditDoc As New edokadb.clsDokument()

Source code

[Visual Basic]
    Dim EditDoc As New edokadb.clsDokument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


EditDok Variable

Dim EditDok As New edokadb.clsEDEX_BL_Auslieferung()

Source code

[Visual Basic]
    Dim EditDok As New edokadb.clsEDEX_BL_Auslieferung()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Editmode Variable

Dim Editmode As Boolean = False

Source code

[Visual Basic]
    Dim Editmode As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


FirstStatus Variable

Dim FirstStatus As Integer = 0

Source code

[Visual Basic]
    Dim FirstStatus As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Notizen Variable

Dim Notizen As New DataTable()

Source code

[Visual Basic]
    Dim Notizen As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SaveStatus Variable

Dim SaveStatus As Integer = 0

Source code

[Visual Basic]
    Dim SaveStatus As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SaveVerantwortlicher Variable

Dim SaveVerantwortlicher As Integer = 0

Source code

[Visual Basic]
    Dim SaveVerantwortlicher As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


TeamZustaendig Variable

Dim TeamZustaendig As Integer

Source code

[Visual Basic]
    Dim TeamZustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


auslieferungnr Variable

Dim auslieferungnr As Integer

Source code

[Visual Basic]
    Dim auslieferungnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbDel2Page Variable

Friend WithEvents cbDel2Page As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbDel2Page As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbbeilage1 Variable

Friend WithEvents cbbeilage1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbbeilage1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbbeilage2 Variable

Friend WithEvents cbbeilage2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbbeilage2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbbeilage3 Variable

Friend WithEvents cbbeilage3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbbeilage3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbblv Variable

Friend WithEvents cbblv As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbblv As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbgrundlage1 Variable

Friend WithEvents cbgrundlage1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbgrundlage1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbgrundlage2 Variable

Friend WithEvents cbgrundlage2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbgrundlage2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbgrundlage3 Variable

Friend WithEvents cbgrundlage3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbgrundlage3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbgrundlage4 Variable

Friend WithEvents cbgrundlage4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbgrundlage4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbkube Variable

Friend WithEvents cbkube As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbkube As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbverantwortlich Variable

Friend WithEvents cbverantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbverantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


cbzustaendiger Variable

Friend WithEvents cbzustaendiger As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzustaendiger As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


doc Variable

Dim doc As New edokadb.clsDokument()

Source code

[Visual Basic]
    Dim doc As New edokadb.clsDokument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dokumenteab Variable

Dim dokumenteab As DateTime

Source code

[Visual Basic]
    Dim dokumenteab As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dokumentebis Variable

Dim dokumentebis As DateTime

Source code

[Visual Basic]
    Dim dokumentebis As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dtgrundlage1 Variable

Friend WithEvents dtgrundlage1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtgrundlage1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dtgrundlage2 Variable

Friend WithEvents dtgrundlage2 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtgrundlage2 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dtgrundlage3 Variable

Friend WithEvents dtgrundlage3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtgrundlage3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dtgrundlage3overlay Variable

Friend WithEvents dtgrundlage3overlay As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents dtgrundlage3overlay As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


dtgrundlage4 Variable

Friend WithEvents dtgrundlage4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtgrundlage4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


lblUnterschrift1 Variable

Friend WithEvents lblUnterschrift1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblUnterschrift1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


m_Bldossier Variable

Dim m_Bldossier As DataTable

Source code

[Visual Basic]
    Dim m_Bldossier As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


m_bkpar00 Variable

Dim m_bkpar00 As String

Source code

[Visual Basic]
    Dim m_bkpar00 As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


m_nrpar00 Variable

Dim m_nrpar00 As Integer

Source code

[Visual Basic]
    Dim m_nrpar00 As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


m_onload Variable

Dim m_onload As Boolean = True

Source code

[Visual Basic]
    Dim m_onload As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbblv Variable

Dim WithEvents mcbblv As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbblv As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbkube Variable

Dim WithEvents mcbkube As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbkube As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbstatus Variable

Dim WithEvents mcbstatus As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbteam Variable

Dim mcbteam As MultiComboBox

Source code

[Visual Basic]
    Dim mcbteam As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


mcbzust Variable

Dim WithEvents mcbzust As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbzust As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbAushaendigungBLV Variable

Friend WithEvents rbAushaendigungBLV As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbAushaendigungBLV As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbAushaendigungKube Variable

Friend WithEvents rbAushaendigungKube As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbAushaendigungKube As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbnichtverschlossen Variable

Friend WithEvents rbnichtverschlossen As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbnichtverschlossen As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbpersoenlich Variable

Friend WithEvents rbpersoenlich As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbpersoenlich As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbverschlossen Variable

Friend WithEvents rbverschlossen As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbverschlossen As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


rbzustellungpost Variable

Friend WithEvents rbzustellungpost As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbzustellungpost As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


tblblkunde Variable

Dim tblblkunde As New DataTable()

Source code

[Visual Basic]
    Dim tblblkunde As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


tbldokumentwerte Variable

Dim tbldokumentwerte As New DataTable()

Source code

[Visual Basic]
    Dim tbldokumentwerte As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


tblperi Variable

Dim tblperi As New DataTable()

Source code

[Visual Basic]
    Dim tblperi As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


txtAnredeZusteller Variable

Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


txtBeilage Variable

Friend WithEvents txtBeilage As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBeilage As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


txtZustelladresse Variable

Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


txtbemerkung Variable

Friend WithEvents txtbemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


w Variable

Dim w As New WordLib()

Source code

[Visual Basic]
    Dim w As New WordLib()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLKunde Class

For a list of all members of this type, see frmBLKunde Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmBLKunde

Public Class frmBLKunde
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLKunde Members


frmBLKunde Members

frmBLKunde overview

Constructors

constructor frmBLKunde Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmBLKunde Class


frmBLKunde Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde Properties

frmBLKunde overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmBLKunde Class


frmBLKunde Methods

frmBLKunde overview

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

See Also

frmBLKunde Class


frmBLKunde.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then
                    Me.DomainList.Columns(i).Value = 1
                End If
                If Me.DomainList.Columns(i).DataField = "bl_periodische_auslieferung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
                If Me.DomainList.Columns(i).DataField = "banklagernd_erklaerung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
            Next
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "EDEX_BL_BLKunde", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("blkundenr", "blkundenr"), New System.Data.Common.DataColumnMapping("NRPAR00", "NRPAR00"), New System.Data.Common.DataColumnMapping("partnertyp", "partnertyp"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung", "banklagernd_erklaerung"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung_vom", "banklagernd_erklaerung_vom"), New System.Data.Common.DataColumnMapping("bl_periodische_auslieferung", "bl_periodische_auslieferung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_blkunde_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_blkunde_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_blkunde_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_blkunde_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shunb1;initial catalog=edoka;persist security info=False;user id=sa;w" & _
        "orkstation id=SHUMAIN;packet size=4096"
        '
        'frmBLKunde
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(840, 405)
        Me.Name = "frmBLKunde"
        Me.Text = "Banklagernd-Kunden"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
                If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then Me.DomainList.Columns(i).Value = 1
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                For i = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                        Me.DomainList.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.frmBLKunde_Load Method

Private Sub frmBLKunde_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLKunde_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DomainList.ScrollTips = True
        Me.tablename = "blkunde"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1.Tables(0)
        Me.DomainList.DataMember = Me.TableName

        Me.SpaltenTitel_Aktualisieren(Me.DataSet1)
        'DivFnkt.SpaltenTitel_Aktualisieren(Me.DomainList, Me.DataSet1.Tables(0), Me.tablename)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKunde Fields

frmBLKunde overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmBLKunde Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKunde


frmBLKundeVIP Class

For a list of all members of this type, see frmBLKundeVIP Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmBLKundeVIP

Public Class frmBLKundeVIP
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLKundeVIP Members


frmBLKundeVIP Members

frmBLKundeVIP overview

Constructors

constructor frmBLKundeVIP Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmBLKundeVIP Class


frmBLKundeVIP Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP Properties

frmBLKundeVIP overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmBLKundeVIP Class


frmBLKundeVIP Methods

frmBLKundeVIP overview

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

See Also

frmBLKundeVIP Class


frmBLKundeVIP.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then
                    Me.DomainList.Columns(i).Value = 1
                End If
                If Me.DomainList.Columns(i).DataField = "bl_periodische_auslieferung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
                If Me.DomainList.Columns(i).DataField = "banklagernd_erklaerung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
            Next
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "EDEX_BL_BLKunde", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("blkundenr", "blkundenr"), New System.Data.Common.DataColumnMapping("NRPAR00", "NRPAR00"), New System.Data.Common.DataColumnMapping("partnertyp", "partnertyp"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung", "banklagernd_erklaerung"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung_vom", "banklagernd_erklaerung_vom"), New System.Data.Common.DataColumnMapping("bl_periodische_auslieferung", "bl_periodische_auslieferung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_blkundevip_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_blkundevip_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_blkundevip_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_blkundevip_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shunb1;initial catalog=edoka;persist security info=False;user id=sa;w" & _
        "orkstation id=SHUMAIN;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmBLKundeVIP
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(840, 433)
        Me.Name = "frmBLKundeVIP"
        Me.Text = "VIP-Kunden verwalten"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
                If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then Me.DomainList.Columns(i).Value = 3
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                For i = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                        Me.DomainList.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.frmBLKunde_Load Method

Private Sub frmBLKunde_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLKunde_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DomainList.ScrollTips = True
        Me.TableName = "blkunde"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1.Tables(0)
        Me.DomainList.DataMember = Me.TableName

        Me.SpaltenTitel_Aktualisieren(Me.DataSet1)
        'DivFnkt.SpaltenTitel_Aktualisieren(Me.DomainList, Me.DataSet1.Tables(0), Me.tablename)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLKundeVIP Fields

frmBLKundeVIP overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmBLKundeVIP Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLKundeVIP


frmBLParameter Class

For a list of all members of this type, see frmBLParameter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBLParameter

Public Class frmBLParameter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBLParameter Members


frmBLParameter Members

frmBLParameter overview

Constructors

constructor frmBLParameter Constructor

Methods

method Dispose
method DomainList_MouseDown
method DomainList_doubleclick
method FnktList_Doubleclick
method FnktList_MouseDown
method Funktionen_Laden
method Get_Dokumenttyp
method Get_Parameterdata
method InitializeComponent
method Insert_Funktion
method KubeFunktionen_Laden
method Kube_Funktionen_Laden
method Save_Parameterdata
method TabControl1_SelectedIndexChanged
method ToolBar1_ButtonClick
method delete_Funktion
method fill_Doktyp
method frmBLParameter_Load
method mnuAdd_Click
method mnuDelete_Click

Fields

field ContextMenu1
field ContextMenu2
field DataSet1
field DomainList
field FnktList
field GroupBox1
field GroupBox2
field GroupBox3
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MainMenu1
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field TabControl1
field TabPage1
field TabPage2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field cbDokumenttyp
field components
field mcbdoktyp
field mnuAdd
field mnuDelete
field txtArt1
field txtArt2
field txtBeilagen1
field txtBeilagen2
field txtForm1
field txtForm2
field txtGrundlage1
field txtGrundlage2
field txtGrundlage3
field txtGrundlage4
field txtQuittung1
field txtQuittung2

See Also

frmBLParameter Class


frmBLParameter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter Methods

frmBLParameter overview

Methods

method Dispose
method DomainList_MouseDown
method DomainList_doubleclick
method FnktList_Doubleclick
method FnktList_MouseDown
method Funktionen_Laden
method Get_Dokumenttyp
method Get_Parameterdata
method InitializeComponent
method Insert_Funktion
method KubeFunktionen_Laden
method Kube_Funktionen_Laden
method Save_Parameterdata
method TabControl1_SelectedIndexChanged
method ToolBar1_ButtonClick
method delete_Funktion
method fill_Doktyp
method frmBLParameter_Load
method mnuAdd_Click
method mnuDelete_Click

See Also

frmBLParameter Class


frmBLParameter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.DomainList_MouseDown Method

Private Sub DomainList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DomainList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DomainList.MouseDown
        Me.DomainList.Bookmark = Me.DomainList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.DomainList_doubleclick Method

Private Sub DomainList_doubleclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_doubleclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        Insert_Funktion()
        Kube_Funktionen_Laden()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.FnktList_Doubleclick Method

Private Sub FnktList_Doubleclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles FnktList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FnktList_Doubleclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles FnktList.DoubleClick
        delete_Funktion()
        Kube_Funktionen_Laden()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.FnktList_MouseDown Method

Private Sub FnktList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles FnktList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FnktList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles FnktList.MouseDown
        Me.FnktList.Bookmark = Me.FnktList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Funktionen_Laden Method

Private Sub Funktionen_Laden()

Source code

[Visual Basic]
    Private Sub Funktionen_Laden()
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = "funktionsgruppe"

        DivFnkt.SpaltenTitel_Aktualisieren(Me.DomainList, Me.DataSet1.Tables(0), "funktionsgruppe")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Get_Dokumenttyp Method

Private Function Get_Dokumenttyp() As DataTable

Source code

[Visual Basic]
    Private Function Get_Dokumenttyp() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_dokumenttyp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Get_Parameterdata Method

Private Sub Get_Parameterdata()

Source code

[Visual Basic]
    Private Sub Get_Parameterdata()
        Dim blp As New edokadb.clsEdex_bl_parameter()
        blp.cpMainConnectionProvider = conn
        blp.iBlvparamnr = New SqlInt32(CType(1, Int32))
        blp.SelectOne()
        Me.txtGrundlage1.Text = blp.sTxtGrundlage1.Value
        Me.txtGrundlage2.Text = blp.sTxtGrundlage2.Value
        Me.txtGrundlage3.Text = blp.sTxtGrundlage3.Value
        Me.txtGrundlage4.Text = blp.sTxtGrundlage4.Value

        Me.txtArt1.Text = blp.sTxtArt1.Value
        Me.txtArt2.Text = blp.sTxtArt2.Value
        Me.txtForm1.Text = blp.sTxtForm1.Value
        Me.txtForm2.Text = blp.sTxtForm2.Value
        Me.txtBeilagen1.Text = blp.sTxtbeilage1.Value
        Me.txtBeilagen2.Text = blp.sTxtbeilage2.Value
        Me.txtQuittung1.Text = blp.sTxtQuittung1.Value
        Me.txtQuittung2.Text = blp.sTxtQuittung2.Value
        Dim I As Integer
        I = blp.iBlvdokumenttypnr.Value
        Me.mcbdoktyp.SelectedValue = I
        blp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBLParameter))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.txtQuittung2 = New System.Windows.Forms.TextBox()
        Me.txtQuittung1 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.txtBeilagen2 = New System.Windows.Forms.TextBox()
        Me.txtBeilagen1 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.txtForm2 = New System.Windows.Forms.TextBox()
        Me.txtForm1 = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtArt2 = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtArt1 = New System.Windows.Forms.TextBox()
        Me.txtGrundlage4 = New System.Windows.Forms.TextBox()
        Me.txtGrundlage3 = New System.Windows.Forms.TextBox()
        Me.txtGrundlage2 = New System.Windows.Forms.TextBox()
        Me.txtGrundlage1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbDokumenttyp = New System.Windows.Forms.ComboBox()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.FnktList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.mnuDelete = New System.Windows.Forms.MenuItem()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuAdd = New System.Windows.Forms.MenuItem()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        CType(Me.FnktList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox2.SuspendLayout()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(800, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Location = New System.Drawing.Point(0, 25)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(800, 380)
        Me.TabControl1.TabIndex = 3
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.Label1, Me.cbDokumenttyp})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(792, 354)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Dokumentvorlage"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtQuittung2, Me.txtQuittung1, Me.Label6, Me.txtBeilagen2, Me.txtBeilagen1, Me.Label5, Me.txtForm2, Me.txtForm1, Me.Label4, Me.txtArt2, Me.Label3, Me.Label2, Me.txtArt1, Me.txtGrundlage4, Me.txtGrundlage3, Me.txtGrundlage2, Me.txtGrundlage1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 56)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(784, 400)
        Me.GroupBox1.TabIndex = 6
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Dokumenttexte"
        '
        'txtQuittung2
        '
        Me.txtQuittung2.Location = New System.Drawing.Point(120, 264)
        Me.txtQuittung2.Name = "txtQuittung2"
        Me.txtQuittung2.Size = New System.Drawing.Size(648, 20)
        Me.txtQuittung2.TabIndex = 16
        Me.txtQuittung2.Text = ""
        '
        'txtQuittung1
        '
        Me.txtQuittung1.Location = New System.Drawing.Point(120, 240)
        Me.txtQuittung1.Name = "txtQuittung1"
        Me.txtQuittung1.Size = New System.Drawing.Size(648, 20)
        Me.txtQuittung1.TabIndex = 15
        Me.txtQuittung1.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 240)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(112, 23)
        Me.Label6.TabIndex = 14
        Me.Label6.Text = "Quittung"
        '
        'txtBeilagen2
        '
        Me.txtBeilagen2.Location = New System.Drawing.Point(120, 208)
        Me.txtBeilagen2.Name = "txtBeilagen2"
        Me.txtBeilagen2.Size = New System.Drawing.Size(648, 20)
        Me.txtBeilagen2.TabIndex = 13
        Me.txtBeilagen2.Text = ""
        '
        'txtBeilagen1
        '
        Me.txtBeilagen1.Location = New System.Drawing.Point(120, 184)
        Me.txtBeilagen1.Name = "txtBeilagen1"
        Me.txtBeilagen1.Size = New System.Drawing.Size(648, 20)
        Me.txtBeilagen1.TabIndex = 12
        Me.txtBeilagen1.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 184)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(112, 23)
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Beilagen"
        '
        'txtForm2
        '
        Me.txtForm2.Enabled = False
        Me.txtForm2.Location = New System.Drawing.Point(128, 400)
        Me.txtForm2.Name = "txtForm2"
        Me.txtForm2.Size = New System.Drawing.Size(648, 20)
        Me.txtForm2.TabIndex = 10
        Me.txtForm2.Text = ""
        Me.txtForm2.Visible = False
        '
        'txtForm1
        '
        Me.txtForm1.Enabled = False
        Me.txtForm1.Location = New System.Drawing.Point(128, 376)
        Me.txtForm1.Name = "txtForm1"
        Me.txtForm1.Size = New System.Drawing.Size(648, 20)
        Me.txtForm1.TabIndex = 9
        Me.txtForm1.Text = ""
        Me.txtForm1.Visible = False
        '
        'Label4
        '
        Me.Label4.Enabled = False
        Me.Label4.Location = New System.Drawing.Point(16, 376)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(112, 23)
        Me.Label4.TabIndex = 8
        Me.Label4.Text = "Aushändigungsform"
        Me.Label4.Visible = False
        '
        'txtArt2
        '
        Me.txtArt2.Location = New System.Drawing.Point(120, 152)
        Me.txtArt2.Name = "txtArt2"
        Me.txtArt2.Size = New System.Drawing.Size(648, 20)
        Me.txtArt2.TabIndex = 7
        Me.txtArt2.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 128)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 6
        Me.Label3.Text = "Aushändigungsart"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 24)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Grundlagen"
        '
        'txtArt1
        '
        Me.txtArt1.Location = New System.Drawing.Point(120, 128)
        Me.txtArt1.Name = "txtArt1"
        Me.txtArt1.Size = New System.Drawing.Size(648, 20)
        Me.txtArt1.TabIndex = 4
        Me.txtArt1.Text = ""
        '
        'txtGrundlage4
        '
        Me.txtGrundlage4.Location = New System.Drawing.Point(120, 96)
        Me.txtGrundlage4.Name = "txtGrundlage4"
        Me.txtGrundlage4.Size = New System.Drawing.Size(648, 20)
        Me.txtGrundlage4.TabIndex = 3
        Me.txtGrundlage4.Text = ""
        '
        'txtGrundlage3
        '
        Me.txtGrundlage3.Location = New System.Drawing.Point(120, 72)
        Me.txtGrundlage3.Name = "txtGrundlage3"
        Me.txtGrundlage3.Size = New System.Drawing.Size(648, 20)
        Me.txtGrundlage3.TabIndex = 2
        Me.txtGrundlage3.Text = ""
        '
        'txtGrundlage2
        '
        Me.txtGrundlage2.Location = New System.Drawing.Point(120, 48)
        Me.txtGrundlage2.Name = "txtGrundlage2"
        Me.txtGrundlage2.Size = New System.Drawing.Size(648, 20)
        Me.txtGrundlage2.TabIndex = 1
        Me.txtGrundlage2.Text = ""
        '
        'txtGrundlage1
        '
        Me.txtGrundlage1.Location = New System.Drawing.Point(120, 24)
        Me.txtGrundlage1.Name = "txtGrundlage1"
        Me.txtGrundlage1.Size = New System.Drawing.Size(648, 20)
        Me.txtGrundlage1.TabIndex = 0
        Me.txtGrundlage1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(120, 32)
        Me.Label1.TabIndex = 5
        Me.Label1.Text = "Dokumenttyp BL-Quittung"
        '
        'cbDokumenttyp
        '
        Me.cbDokumenttyp.Location = New System.Drawing.Point(128, 16)
        Me.cbDokumenttyp.Name = "cbDokumenttyp"
        Me.cbDokumenttyp.Size = New System.Drawing.Size(368, 21)
        Me.cbDokumenttyp.TabIndex = 4
        Me.cbDokumenttyp.Text = "ComboBox1"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox3, Me.GroupBox2})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(792, 442)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "KUBE-Funktionen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.FnktList})
        Me.GroupBox3.Location = New System.Drawing.Point(384, 16)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(400, 416)
        Me.GroupBox3.TabIndex = 1
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Funktionen 'KUBE'"
        '
        'FnktList
        '
        Me.FnktList.AllowFilter = True
        Me.FnktList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.FnktList.AllowSort = True
        Me.FnktList.AlternatingRows = True
        Me.FnktList.CaptionHeight = 17
        Me.FnktList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.FnktList.CollapseColor = System.Drawing.Color.Black
        Me.FnktList.ContextMenu = Me.ContextMenu2
        Me.FnktList.DataChanged = False
        Me.FnktList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.FnktList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.FnktList.ExpandColor = System.Drawing.Color.Black
        Me.FnktList.FilterBar = True
        Me.FnktList.GroupByCaption = "Drag a column header here to group by that column"
        Me.FnktList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.FnktList.Location = New System.Drawing.Point(3, 16)
        Me.FnktList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.FnktList.Name = "FnktList"
        Me.FnktList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.FnktList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.FnktList.PreviewInfo.ZoomFactor = 75
        Me.FnktList.PrintInfo.ShowOptionsDialog = False
        Me.FnktList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.FnktList.RowDivider = GridLines1
        Me.FnktList.RowHeight = 15
        Me.FnktList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.FnktList.ScrollTips = False
        Me.FnktList.Size = New System.Drawing.Size(394, 397)
        Me.FnktList.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.FnktList.TabIndex = 9
        Me.FnktList.Text = "C1TrueDBGrid1"
        Me.FnktList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{Wrap:True;BackColor:255, 255, " & _
        "192;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightT" & _
        "ext;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{" & _
        "AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;" & _
        "ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11" & _
        "{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeVi" & _
        "ew Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17" & _
        """ ColumnFooterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" Record" & _
        "SelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollG" & _
        "roup=""1""><ClientRect>0, 0, 390, 393</ClientRect><BorderSide>0</BorderSide><Capti" & _
        "onStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" " & _
        "/><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar" & _
        """ me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""" & _
        "Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRow" & _
        "Style parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""S" & _
        "tyle4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=" & _
        """RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><" & _
        "Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Na" & _
        "medStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><" & _
        "Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Sty" & _
        "le parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Styl" & _
        "e parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Styl" & _
        "e parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style par" & _
        "ent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Sty" & _
        "le parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSp" & _
        "lits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSe" & _
        "lWidth><ClientArea>0, 0, 390, 393</ClientArea></Blob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDelete})
        '
        'mnuDelete
        '
        Me.mnuDelete.Index = 0
        Me.mnuDelete.Text = "&Funktion löschen"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.DomainList})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(376, 416)
        Me.GroupBox2.TabIndex = 0
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Funktionen"
        '
        'DomainList
        '
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.ContextMenu = Me.ContextMenu1
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(3, 16)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines2
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = False
        Me.DomainList.Size = New System.Drawing.Size(370, 397)
        Me.DomainList.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.DomainList.TabIndex = 8
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{Wrap:True;BackColor:255, 255, " & _
        "192;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightT" & _
        "ext;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{" & _
        "AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1" & _
        ";ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11" & _
        "{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeVi" & _
        "ew Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17" & _
        """ ColumnFooterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" Record" & _
        "SelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollG" & _
        "roup=""1""><ClientRect>0, 0, 366, 393</ClientRect><BorderSide>0</BorderSide><Capti" & _
        "onStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" " & _
        "/><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar" & _
        """ me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""" & _
        "Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRow" & _
        "Style parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""S" & _
        "tyle4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=" & _
        """RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><" & _
        "Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Na" & _
        "medStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><" & _
        "Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Sty" & _
        "le parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Styl" & _
        "e parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Styl" & _
        "e parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style par" & _
        "ent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Sty" & _
        "le parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSp" & _
        "lits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSe" & _
        "lWidth><ClientArea>0, 0, 366, 393</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuAdd})
        '
        'mnuAdd
        '
        Me.mnuAdd.Index = 0
        Me.mnuAdd.Text = "&Funktion hinzufügen"
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("funktionszuweisung", "funktionszuweisung"), New System.Data.Common.DataColumnMapping("barcodeetiketten", "barcodeetiketten"), New System.Data.Common.DataColumnMapping("edokapartner", "edokapartner"), New System.Data.Common.DataColumnMapping("Dokumentreaktivierung", "Dokumentreaktivierung"), New System.Data.Common.DataColumnMapping("Partnerzusammenlegung", "Partnerzusammenlegung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_funktionsgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokumentreaktivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Partnerzusammenlegung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodeetiketten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodeetiketten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edokapartner", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edokapartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionszuweisung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionszuweisung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_funktionsgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionszuweisung", System.Data.SqlDbType.Bit, 1, "funktionszuweisung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodeetiketten", System.Data.SqlDbType.Bit, 1, "barcodeetiketten"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edokapartner", System.Data.SqlDbType.Bit, 1, "edokapartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, "Dokumentreaktivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, "Partnerzusammenlegung"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_funktionsgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionszuweisung", System.Data.SqlDbType.Bit, 1, "funktionszuweisung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodeetiketten", System.Data.SqlDbType.Bit, 1, "barcodeetiketten"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edokapartner", System.Data.SqlDbType.Bit, 1, "edokapartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, "Dokumentreaktivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, "Partnerzusammenlegung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokumentreaktivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Partnerzusammenlegung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodeetiketten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodeetiketten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edokapartner", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edokapartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionszuweisung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionszuweisung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'frmBLParameter
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(800, 405)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.ToolBar1})
        Me.Menu = Me.MainMenu1
        Me.Name = "frmBLParameter"
        Me.Text = "Banklagernd-Parameter "
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        CType(Me.FnktList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Insert_Funktion Method

Private Function Insert_Funktion()

Source code

[Visual Basic]
    Private Function Insert_Funktion()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_insert_kubefnkt"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DomainList.Columns(0).Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.KubeFunktionen_Laden Method

Private Function KubeFunktionen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function KubeFunktionen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_kubefnkt"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Kube_Funktionen_Laden Method

Private Sub Kube_Funktionen_Laden()

Source code

[Visual Basic]
    Private Sub Kube_Funktionen_Laden()
        Me.FnktList.DataSource = Nothing
        Me.FnktList.DataMember = Nothing

        Dim dt As DataTable
        dt = KubeFunktionen_Laden()
        Me.FnktList.DataSource = dt
        Me.FnktList.DataMember = "edex_bl_kubefnkt"
        DivFnkt.SpaltenTitel_Aktualisieren(Me.FnktList, Me.DataSet1.Tables(0), "edex_bl_kubefnkt")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.Save_Parameterdata Method

Private Sub Save_Parameterdata()

Source code

[Visual Basic]
    Private Sub Save_Parameterdata()
        Dim blp As New edokadb.clsEdex_bl_parameter()
        blp.cpMainConnectionProvider = conn
        blp.iBlvparamnr = New SqlInt32(CType(1, Integer))
        blp.SelectOne()
        blp.sTxtGrundlage1 = New SqlString(CType(Me.txtGrundlage1.Text, String))
        blp.sTxtGrundlage2 = New SqlString(CType(Me.txtGrundlage2.Text, String))
        blp.sTxtGrundlage3 = New SqlString(CType(Me.txtGrundlage3.Text, String))
        blp.sTxtGrundlage4 = New SqlString(CType(Me.txtGrundlage4.Text, String))
        blp.sTxtArt1 = New SqlString(CType(Me.txtArt1.Text, String))
        blp.sTxtArt2 = New SqlString(CType(Me.txtArt2.Text, String))
        blp.sTxtForm1 = New SqlString(CType(Me.txtForm1.Text, String))
        blp.sTxtForm2 = New SqlString(CType(Me.txtForm2.Text, String))
        blp.sTxtbeilage1 = New SqlString(CType(Me.txtBeilagen1.Text, String))
        blp.sTxtbeilage2 = New SqlString(CType(Me.txtBeilagen2.Text, String))
        blp.sTxtQuittung1 = New SqlString(CType(Me.txtQuittung1.Text, String))
        blp.sTxtQuittung2 = New SqlString(CType(Me.txtQuittung2.Text, String))
        blp.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        blp.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        blp.iBlvdokumenttypnr = New SqlInt32(CType(Me.mcbdoktyp.SelectedValue, Int32))
        conn.OpenConnection()
        blp.Update()
        conn.CloseConnection(True)
        blp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.TabControl1_SelectedIndexChanged Method

Private Sub TabControl1_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl1.SelectedIndexChanged
        If Me.TabControl1.SelectedIndex = 0 Then
            Me.ToolBar1.Buttons(1).Enabled = True
        Else
            Me.ToolBar1.Buttons(1).Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.Close()
            Case 1
                Me.Save_Parameterdata()
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.delete_Funktion Method

Private Function delete_Funktion()

Source code

[Visual Basic]
    Private Function delete_Funktion()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_delete_kubefnkt"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.FnktList.Columns(0).Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.fill_Doktyp Method

Private Sub fill_Doktyp()

Source code

[Visual Basic]
    Private Sub fill_Doktyp()
        Me.mcbdoktyp = New MultiComboBox(Me.cbDokumenttyp)
        Me.mcbdoktyp.CheckNullValue = True
        Me.mcbdoktyp.NullValueMessage = MyTxt.gettext(18)
        Me.mcbdoktyp.DisplayColumnName = "Bezeichnung"
        Me.mcbdoktyp.ValueColumnName = "Dokumenttypnr"
        Me.mcbdoktyp.Fill_Data(Get_Dokumenttyp, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.frmBLParameter_Load Method

Private Sub frmBLParameter_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLParameter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        fill_Doktyp()
        Get_Parameterdata()
        Funktionen_Laden()
        Kube_Funktionen_Laden()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.mnuAdd_Click Method

Private Sub mnuAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuAdd.Click
        Insert_Funktion()
        Kube_Funktionen_Laden()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter.mnuDelete_Click Method

Private Sub mnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDelete.Click
        delete_Funktion()
        Kube_Funktionen_Laden()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBLParameter Fields

frmBLParameter overview

Fields

field ContextMenu1
field ContextMenu2
field DataSet1
field DomainList
field FnktList
field GroupBox1
field GroupBox2
field GroupBox3
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MainMenu1
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field TabControl1
field TabPage1
field TabPage2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field cbDokumenttyp
field components
field mcbdoktyp
field mnuAdd
field mnuDelete
field txtArt1
field txtArt2
field txtBeilagen1
field txtBeilagen2
field txtForm1
field txtForm2
field txtGrundlage1
field txtGrundlage2
field txtGrundlage3
field txtGrundlage4
field txtQuittung1
field txtQuittung2

See Also

frmBLParameter Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


FnktList Variable

Friend WithEvents FnktList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents FnktList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


cbDokumenttyp Variable

Friend WithEvents cbDokumenttyp As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbDokumenttyp As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


mcbdoktyp Variable

Dim WithEvents mcbdoktyp As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbdoktyp As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


mnuAdd Variable

Friend WithEvents mnuAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


mnuDelete Variable

Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtArt1 Variable

Friend WithEvents txtArt1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtArt1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtArt2 Variable

Friend WithEvents txtArt2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtArt2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtBeilagen1 Variable

Friend WithEvents txtBeilagen1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBeilagen1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtBeilagen2 Variable

Friend WithEvents txtBeilagen2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBeilagen2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtForm1 Variable

Friend WithEvents txtForm1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtForm1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtForm2 Variable

Friend WithEvents txtForm2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtForm2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtGrundlage1 Variable

Friend WithEvents txtGrundlage1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtGrundlage1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtGrundlage2 Variable

Friend WithEvents txtGrundlage2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtGrundlage2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtGrundlage3 Variable

Friend WithEvents txtGrundlage3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtGrundlage3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtGrundlage4 Variable

Friend WithEvents txtGrundlage4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtGrundlage4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtQuittung1 Variable

Friend WithEvents txtQuittung1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtQuittung1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


txtQuittung2 Variable

Friend WithEvents txtQuittung2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtQuittung2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLParameter


frmBanklagerndverarbeitung Class

For a list of all members of this type, see frmBanklagerndverarbeitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBanklagerndverarbeitung

Public Class frmBanklagerndverarbeitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBanklagerndverarbeitung Members


frmBanklagerndverarbeitung Members

frmBanklagerndverarbeitung overview

Constructors

constructor frmBanklagerndverarbeitung Constructor (Overloaded)

Methods

method Button1_Click
method Dispose
method InitializeComponent
method RBPersönlich_CheckedChanged
method frmBanklagerndverarbeitung_Load
method rbDossier_CheckedChanged
method rbVersand_CheckedChanged
method rbbckbldossier_CheckedChanged
method rbbckversand_CheckedChanged
method rbeinzelbldossier_CheckedChanged
method rbeinzelblversand_CheckedChanged
method rbkeineUebergabe_CheckedChanged
method set_texte

Fields

field Button1
field GroupBox1
field GroupBox2
field Label1
field PictureBox1
field RBEinzelPersoenlich
field RBPersönlich
field components
field pnlbck
field pnleinzeldokument
field rbDossier
field rbVersand
field rbbckbldossier
field rbbckversand
field rbeinzelbldossier
field rbeinzelblversand
field rbkeineUebergabe
field txtWeitereVerarbeitung

See Also

frmBanklagerndverarbeitung Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal nrpar00 As Integer, ByVal bck As Boolean)

[Visual Basic] Public Sub New(ByVal nrpar00 As Integer, ByVal bck As Boolean, ByVal einzeldokument As Boolean)

See Also

frmBanklagerndverarbeitung | EDOKAApp


frmBanklagerndverarbeitung Methods

frmBanklagerndverarbeitung overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method RBPersönlich_CheckedChanged
method frmBanklagerndverarbeitung_Load
method rbDossier_CheckedChanged
method rbVersand_CheckedChanged
method rbbckbldossier_CheckedChanged
method rbbckversand_CheckedChanged
method rbeinzelbldossier_CheckedChanged
method rbeinzelblversand_CheckedChanged
method rbkeineUebergabe_CheckedChanged
method set_texte

See Also

frmBanklagerndverarbeitung Class


frmBanklagerndverarbeitung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBanklagerndverarbeitung))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.rbDossier = New System.Windows.Forms.RadioButton()
        Me.rbVersand = New System.Windows.Forms.RadioButton()
        Me.RBPersönlich = New System.Windows.Forms.RadioButton()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.txtWeitereVerarbeitung = New System.Windows.Forms.Label()
        Me.pnlbck = New System.Windows.Forms.Panel()
        Me.rbkeineUebergabe = New System.Windows.Forms.RadioButton()
        Me.rbbckversand = New System.Windows.Forms.RadioButton()
        Me.rbbckbldossier = New System.Windows.Forms.RadioButton()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.pnleinzeldokument = New System.Windows.Forms.Panel()
        Me.RBEinzelPersoenlich = New System.Windows.Forms.RadioButton()
        Me.rbeinzelblversand = New System.Windows.Forms.RadioButton()
        Me.rbeinzelbldossier = New System.Windows.Forms.RadioButton()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.pnlbck.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.pnleinzeldokument.SuspendLayout()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(312, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Sie erstellen ein Dokument für einen Banklagernd-Kunden."
        '
        'rbDossier
        '
        Me.rbDossier.Location = New System.Drawing.Point(8, 16)
        Me.rbDossier.Name = "rbDossier"
        Me.rbDossier.Size = New System.Drawing.Size(280, 24)
        Me.rbDossier.TabIndex = 1
        Me.rbDossier.Text = "Ablage im elektronischen Banklagernd-Dossier"
        '
        'rbVersand
        '
        Me.rbVersand.Location = New System.Drawing.Point(8, 40)
        Me.rbVersand.Name = "rbVersand"
        Me.rbVersand.Size = New System.Drawing.Size(192, 24)
        Me.rbVersand.TabIndex = 2
        Me.rbVersand.Text = "Versand an eine Zustelladresse"
        '
        'RBPersönlich
        '
        Me.RBPersönlich.Location = New System.Drawing.Point(8, 64)
        Me.RBPersönlich.Name = "RBPersönlich"
        Me.RBPersönlich.Size = New System.Drawing.Size(192, 24)
        Me.RBPersönlich.TabIndex = 3
        Me.RBPersönlich.Text = "Persönliche Aushändigung"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(160, 336)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 4
        Me.Button1.Text = "&OK"
        '
        'GroupBox1
        '
        Me.GroupBox1.Location = New System.Drawing.Point(400, 392)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(176, 56)
        Me.GroupBox1.TabIndex = 5
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Hinweis zur Dokumentbearbeitung"
        '
        'txtWeitereVerarbeitung
        '
        Me.txtWeitereVerarbeitung.Location = New System.Drawing.Point(56, 152)
        Me.txtWeitereVerarbeitung.Name = "txtWeitereVerarbeitung"
        Me.txtWeitereVerarbeitung.Size = New System.Drawing.Size(320, 168)
        Me.txtWeitereVerarbeitung.TabIndex = 0
        '
        'pnlbck
        '
        Me.pnlbck.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbkeineUebergabe, Me.rbbckversand, Me.rbbckbldossier})
        Me.pnlbck.Location = New System.Drawing.Point(16, 56)
        Me.pnlbck.Name = "pnlbck"
        Me.pnlbck.Size = New System.Drawing.Size(272, 80)
        Me.pnlbck.TabIndex = 6
        Me.pnlbck.Visible = False
        '
        'rbkeineUebergabe
        '
        Me.rbkeineUebergabe.Location = New System.Drawing.Point(8, 55)
        Me.rbkeineUebergabe.Name = "rbkeineUebergabe"
        Me.rbkeineUebergabe.Size = New System.Drawing.Size(256, 24)
        Me.rbkeineUebergabe.TabIndex = 2
        Me.rbkeineUebergabe.Text = "Keine Übergabe an den Kunden"
        '
        'rbbckversand
        '
        Me.rbbckversand.Location = New System.Drawing.Point(8, 30)
        Me.rbbckversand.Name = "rbbckversand"
        Me.rbbckversand.Size = New System.Drawing.Size(208, 24)
        Me.rbbckversand.TabIndex = 1
        Me.rbbckversand.Text = "Versand/persönliche Aushändigung"
        '
        'rbbckbldossier
        '
        Me.rbbckbldossier.Location = New System.Drawing.Point(8, 6)
        Me.rbbckbldossier.Name = "rbbckbldossier"
        Me.rbbckbldossier.Size = New System.Drawing.Size(264, 24)
        Me.rbbckbldossier.TabIndex = 0
        Me.rbbckbldossier.Text = "Ablage im elektronischen Banklagernd-Dossier"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbDossier, Me.rbVersand, Me.RBPersönlich})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 40)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 104)
        Me.GroupBox2.TabIndex = 7
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Weiterleitung"
        '
        'pnleinzeldokument
        '
        Me.pnleinzeldokument.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBEinzelPersoenlich, Me.rbeinzelblversand, Me.rbeinzelbldossier})
        Me.pnleinzeldokument.Location = New System.Drawing.Point(16, 56)
        Me.pnleinzeldokument.Name = "pnleinzeldokument"
        Me.pnleinzeldokument.Size = New System.Drawing.Size(272, 72)
        Me.pnleinzeldokument.TabIndex = 7
        Me.pnleinzeldokument.Visible = False
        '
        'RBEinzelPersoenlich
        '
        Me.RBEinzelPersoenlich.Location = New System.Drawing.Point(8, 51)
        Me.RBEinzelPersoenlich.Name = "RBEinzelPersoenlich"
        Me.RBEinzelPersoenlich.Size = New System.Drawing.Size(192, 24)
        Me.RBEinzelPersoenlich.TabIndex = 5
        Me.RBEinzelPersoenlich.Text = "Persönliche Aushändigung"
        '
        'rbeinzelblversand
        '
        Me.rbeinzelblversand.Location = New System.Drawing.Point(8, 27)
        Me.rbeinzelblversand.Name = "rbeinzelblversand"
        Me.rbeinzelblversand.Size = New System.Drawing.Size(208, 24)
        Me.rbeinzelblversand.TabIndex = 1
        Me.rbeinzelblversand.Text = "Versand an eine Zustelladresse"
        '
        'rbeinzelbldossier
        '
        Me.rbeinzelbldossier.Location = New System.Drawing.Point(8, 3)
        Me.rbeinzelbldossier.Name = "rbeinzelbldossier"
        Me.rbeinzelbldossier.Size = New System.Drawing.Size(264, 24)
        Me.rbeinzelbldossier.TabIndex = 0
        Me.rbeinzelbldossier.Text = "Ablage im physischen Banklagernd-Dossier"
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(8, 152)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(48, 48)
        Me.PictureBox1.TabIndex = 8
        Me.PictureBox1.TabStop = False
        '
        'frmBanklagerndverarbeitung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(386, 367)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtWeitereVerarbeitung, Me.pnlbck, Me.pnleinzeldokument, Me.GroupBox2, Me.GroupBox1, Me.Button1, Me.Label1, Me.PictureBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Name = "frmBanklagerndverarbeitung"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumenterstellung für Banklagernd-Kunde"
        Me.pnlbck.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.pnleinzeldokument.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.RBPersönlich_CheckedChanged Method

Private Sub RBPersönlich_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBPersönlich.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBPersönlich_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBPersönlich.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.frmBanklagerndverarbeitung_Load Method

Private Sub frmBanklagerndverarbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBanklagerndverarbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbDossier_CheckedChanged Method

Private Sub rbDossier_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbDossier.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbDossier_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbDossier.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbVersand_CheckedChanged Method

Private Sub rbVersand_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbVersand.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbVersand_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbVersand.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbbckbldossier_CheckedChanged Method

Private Sub rbbckbldossier_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbbckbldossier.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbbckbldossier_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbbckbldossier.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbbckversand_CheckedChanged Method

Private Sub rbbckversand_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbbckversand.CheckedChanged, _
   RBEinzelPersoenlich.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbbckversand_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbbckversand.CheckedChanged, RBEinzelPersoenlich.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbeinzelbldossier_CheckedChanged Method

Private Sub rbeinzelbldossier_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbeinzelbldossier.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbeinzelbldossier_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbeinzelbldossier.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbeinzelblversand_CheckedChanged Method

Private Sub rbeinzelblversand_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbeinzelblversand.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbeinzelblversand_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbeinzelblversand.CheckedChanged
        set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.rbkeineUebergabe_CheckedChanged Method

Private Sub rbkeineUebergabe_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbkeineUebergabe.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbkeineUebergabe_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbkeineUebergabe.CheckedChanged
        Me.set_texte()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung.set_texte Method

Private Sub set_texte()

Source code

[Visual Basic]
    Private Sub set_texte()
        Dim mdgnr As Integer = 0
        If Me.pnlbck.Visible = False And Me.pnleinzeldokument.Visible = False Then
            If Me.rbDossier.Checked = True Then mdgnr = 600
            If Me.rbVersand.Checked = True Then mdgnr = 601
            If Me.RBPersönlich.Checked = True Then mdgnr = 602
        End If
        If Me.pnlbck.Visible = True Then
            If Me.rbbckbldossier.Checked Then mdgnr = 603
            If Me.rbbckversand.Checked Then mdgnr = 604
            If Me.rbkeineUebergabe.Checked Then mdgnr = 608
        End If
        If Me.pnleinzeldokument.Visible = True Then
            If Me.rbeinzelbldossier.Checked Then mdgnr = 605
            If Me.rbeinzelblversand.Checked Then mdgnr = 606
            If Me.RBEinzelPersoenlich.Checked Then mdgnr = 607
        End If
        If mdgnr > 0 Then
            Me.txtWeitereVerarbeitung.Text = MyTxt.gettext(mdgnr)
        Else
            Me.txtWeitereVerarbeitung.Text = ""
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung Fields

frmBanklagerndverarbeitung overview

Fields

field Button1
field GroupBox1
field GroupBox2
field Label1
field PictureBox1
field RBEinzelPersoenlich
field RBPersönlich
field components
field pnlbck
field pnleinzeldokument
field rbDossier
field rbVersand
field rbbckbldossier
field rbbckversand
field rbeinzelbldossier
field rbeinzelblversand
field rbkeineUebergabe
field txtWeitereVerarbeitung

See Also

frmBanklagerndverarbeitung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


RBEinzelPersoenlich Variable

Friend WithEvents RBEinzelPersoenlich As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBEinzelPersoenlich As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


RBPersönlich Variable

Friend WithEvents RBPersönlich As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBPersönlich As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


pnlbck Variable

Friend WithEvents pnlbck As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlbck As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


pnleinzeldokument Variable

Friend WithEvents pnleinzeldokument As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnleinzeldokument As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbDossier Variable

Friend WithEvents rbDossier As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbDossier As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbVersand Variable

Friend WithEvents rbVersand As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbVersand As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbbckbldossier Variable

Friend WithEvents rbbckbldossier As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbbckbldossier As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbbckversand Variable

Friend WithEvents rbbckversand As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbbckversand As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbeinzelbldossier Variable

Friend WithEvents rbeinzelbldossier As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbeinzelbldossier As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbeinzelblversand Variable

Friend WithEvents rbeinzelblversand As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbeinzelblversand As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


rbkeineUebergabe Variable

Friend WithEvents rbkeineUebergabe As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbkeineUebergabe As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


txtWeitereVerarbeitung Variable

Friend WithEvents txtWeitereVerarbeitung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtWeitereVerarbeitung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBarcodeKleber Class

For a list of all members of this type, see frmBarcodeKleber Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBarcodeKleber

Public Class frmBarcodeKleber
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBarcodeKleber Members


frmBarcodeKleber Members

frmBarcodeKleber overview

Constructors

constructor frmBarcodeKleber Constructor

Properties

property BarcodeID

Methods

method Dispose
method InitializeComponent
method TextBox1_KeyDown
method brnAbbruch_Click
method btnOK_Click
method frmBarcodeKleber_Load

Fields

field Label1
field TextBox1
field brnAbbruch
field btnOK
field components
field m_barcodeid

See Also

frmBarcodeKleber Class


frmBarcodeKleber Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber Properties

frmBarcodeKleber overview

Properties

property BarcodeID

See Also

frmBarcodeKleber Class


frmBarcodeKleber.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber Methods

frmBarcodeKleber overview

Methods

method Dispose
method InitializeComponent
method TextBox1_KeyDown
method brnAbbruch_Click
method btnOK_Click
method frmBarcodeKleber_Load

See Also

frmBarcodeKleber Class


frmBarcodeKleber.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBarcodeKleber))
        Me.btnOK = New System.Windows.Forms.Button()
        Me.brnAbbruch = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(240, 112)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.TabIndex = 0
        Me.btnOK.Text = "&OK"
        '
        'brnAbbruch
        '
        Me.brnAbbruch.DialogResult = System.Windows.Forms.DialogResult.Abort
        Me.brnAbbruch.Location = New System.Drawing.Point(8, 112)
        Me.brnAbbruch.Name = "brnAbbruch"
        Me.brnAbbruch.TabIndex = 1
        Me.brnAbbruch.Text = "&Abbruch"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(304, 23)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Bitte geben Sie die Nummer auf dem Barcodekleber ein."
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(104, 56)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(120, 20)
        Me.TextBox1.TabIndex = 3
        Me.TextBox1.Text = ""
        '
        'frmBarcodeKleber
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(328, 141)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox1, Me.Label1, Me.brnAbbruch, Me.btnOK})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmBarcodeKleber"
        Me.ShowInTaskbar = False
        Me.Text = "Barcode-Dokument erstellen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox1.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox1.KeyDown
        If e.KeyCode = Keys.Enter Then
            btnOK_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber.brnAbbruch_Click Method

Private Sub brnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles brnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub brnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles brnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber.btnOK_Click Method

Private Sub btnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOK.Click
        Dim v As Long
        Try
            v = Val(LTrim(RTrim(Me.TextBox1.Text)))
        Catch
            MyMsg.show_standardmessage(36, MsgBoxStyle.Critical)
            Me.TextBox1.Select()
            Me.TextBox1.Focus()
            Exit Sub
        End Try
        Dim bc As New edokadb.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        Try
            bc.iBarcodenr = New SqlInt32(CType(Me.TextBox1.Text, String))
            bc.SelectOne()
            If bc.iBarcodenr.Value = v Then
                If bc.sDokumentid.Value Is System.DBNull.Value Then
                    bc.sDokumentid = New SqlString(CType("res", String))
                Else
                    If bc.sDokumentid.Value = "" Then
                        bc.sDokumentid = New SqlString(CType("res", String))
                    Else
                        MyMsg.show_standardmessage(37, MsgBoxStyle.Critical)
                        Me.TextBox1.Select()
                        Me.TextBox1.Focus()
                        Exit Sub
                    End If
                End If
            End If
            conn.OpenConnection()
            bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            bc.Update()
            Me.BarcodeID = LTrim(Str(v))
            conn.CloseConnection(True)
            Me.DialogResult = DialogResult.OK
            Me.Close()
        Catch
            MyMsg.show_standardmessage(38, MsgBoxStyle.Critical)
            Me.TextBox1.SelectAll()
            Me.TextBox1.Focus()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber.frmBarcodeKleber_Load Method

Private Sub frmBarcodeKleber_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBarcodeKleber_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TextBox1.Focus()
        Me.TextBox1.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBarcodeKleber Fields

frmBarcodeKleber overview

Fields

field Label1
field TextBox1
field brnAbbruch
field btnOK
field components
field m_barcodeid

See Also

frmBarcodeKleber Class


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


brnAbbruch Variable

Friend WithEvents brnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents brnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


btnOK Variable

Friend WithEvents btnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBarcodeKleber


frmBerechtigungen Class

For a list of all members of this type, see frmBerechtigungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmBerechtigungen

Public Class frmBerechtigungen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmBerechtigungen Members


frmBerechtigungen Members

frmBerechtigungen overview

Constructors

constructor frmBerechtigungen Constructor

Methods

method Berechtigunglist_FetchScrollTips
method Button1_Click
method Dispose
method Fill_Berechtigungen
method InitializeComponent
method frmBerechtigungen_Load

Fields

field Button1
field berechtigunglist
field components

See Also

frmBerechtigungen Class


frmBerechtigungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen Methods

frmBerechtigungen overview

Methods

method Berechtigunglist_FetchScrollTips
method Button1_Click
method Dispose
method Fill_Berechtigungen
method InitializeComponent
method frmBerechtigungen_Load

See Also

frmBerechtigungen Class


frmBerechtigungen.Berechtigunglist_FetchScrollTips Method

Private Sub Berechtigunglist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles berechtigunglist.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Berechtigunglist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles berechtigunglist.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.berechtigunglist.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen.Fill_Berechtigungen Method

Public Function Fill_Berechtigungen( _
   ByVal dokumenttyp As Integer, _
   ByVal partnernr As Integer, _
   ByVal vertraulich As Integer, _
   ByVal funktionslist As String _
)

Parameters

dokumenttyp
Required.
partnernr
Required.
vertraulich
Required.
funktionslist
Required.

Source code

[Visual Basic]
    Public Function Fill_Berechtigungen(ByVal dokumenttyp As Integer, ByVal partnernr As Integer, ByVal vertraulich As Integer, ByVal funktionslist As String)
        Dim d As New DataTable()
        d = DivFnkt.Berechtigte_Mitarbeiter(dokumenttyp, 0, partnernr, "", 0, 0, 0, vertraulich, funktionslist)
        Me.berechtigunglist.DataSource = d
        Me.berechtigunglist.DataMember = d.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.berechtigunglist, d, "berechtigungsliste")
        Me.berechtigunglist.Splits(0).DisplayColumns(1).Visible = False
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmBerechtigungen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.berechtigunglist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button1 = New System.Windows.Forms.Button()
        CType(Me.berechtigunglist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'berechtigunglist
        '
        Me.berechtigunglist.AllowFilter = True
        Me.berechtigunglist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.berechtigunglist.AllowSort = False
        Me.berechtigunglist.AlternatingRows = True
        Me.berechtigunglist.CaptionHeight = 17
        Me.berechtigunglist.CollapseColor = System.Drawing.Color.Black
        Me.berechtigunglist.DataChanged = False
        Me.berechtigunglist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.berechtigunglist.Dock = System.Windows.Forms.DockStyle.Top
        Me.berechtigunglist.ExpandColor = System.Drawing.Color.Black
        Me.berechtigunglist.FilterBar = True
        Me.berechtigunglist.GroupByCaption = "Drag a column header here to group by that column"
        Me.berechtigunglist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.berechtigunglist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.berechtigunglist.Name = "berechtigunglist"
        Me.berechtigunglist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.berechtigunglist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.berechtigunglist.PreviewInfo.ZoomFactor = 75
        Me.berechtigunglist.PrintInfo.ShowOptionsDialog = False
        Me.berechtigunglist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.berechtigunglist.RowDivider = GridLines1
        Me.berechtigunglist.RowHeight = 15
        Me.berechtigunglist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.berechtigunglist.ScrollTips = True
        Me.berechtigunglist.Size = New System.Drawing.Size(520, 400)
        Me.berechtigunglist.TabIndex = 15
        Me.berechtigunglist.Text = "berechtigunglist"
        Me.berechtigunglist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorW" & _
        "idth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1"">" & _
        "<ClientRect>0, 0, 516, 396</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><C" & _
        "lientArea>0, 0, 516, 396</ClientArea></Blob>"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(208, 408)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 16
        Me.Button1.Text = "&Schliessen"
        '
        'frmBerechtigungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(520, 437)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.berechtigunglist})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmBerechtigungen"
        Me.Text = "Berechtigungen"
        CType(Me.berechtigunglist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen.frmBerechtigungen_Load Method

Private Sub frmBerechtigungen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBerechtigungen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.berechtigunglist.ScrollTips = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmBerechtigungen Fields

frmBerechtigungen overview

Fields

field Button1
field berechtigunglist
field components

See Also

frmBerechtigungen Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


berechtigunglist Variable

Friend WithEvents berechtigunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents berechtigunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBerechtigungen


frmCalendar Class

For a list of all members of this type, see frmCalendar Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmCalendar

Public Class frmCalendar
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmCalendar Members


frmCalendar Members

frmCalendar overview

Constructors

constructor frmCalendar Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method btnAbbruch_Click

Fields

field Button1
field MonthCalendar1
field btnAbbruch
field components
field m_datum

See Also

frmCalendar Class


frmCalendar Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar Methods

frmCalendar overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method btnAbbruch_Click

See Also

frmCalendar Class


frmCalendar.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.MonthCalendar1 = New System.Windows.Forms.MonthCalendar()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'MonthCalendar1
        '
        Me.MonthCalendar1.Location = New System.Drawing.Point(48, 8)
        Me.MonthCalendar1.Name = "MonthCalendar1"
        Me.MonthCalendar1.ShowTodayCircle = False
        Me.MonthCalendar1.TabIndex = 0
        '
        'btnAbbruch
        '
        Me.btnAbbruch.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.btnAbbruch.Location = New System.Drawing.Point(16, 176)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 1
        Me.btnAbbruch.Text = "&Abbruch"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(200, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'frmCalendar
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(288, 205)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.btnAbbruch, Me.MonthCalendar1})
        Me.Name = "frmCalendar"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Datum auswählen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar Fields

frmCalendar overview

Fields

field Button1
field MonthCalendar1
field btnAbbruch
field components
field m_datum

See Also

frmCalendar Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


MonthCalendar1 Variable

Friend WithEvents MonthCalendar1 As System.Windows.Forms.MonthCalendar

Source code

[Visual Basic]
    Friend WithEvents MonthCalendar1 As System.Windows.Forms.MonthCalendar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


m_datum Variable

Dim m_datum As Date

Source code

[Visual Basic]
    Dim m_datum As Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar


frmCalendar_SP Class

For a list of all members of this type, see frmCalendar_SP Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmCalendar_SP

Public Class frmCalendar_SP
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmCalendar_SP Members


frmCalendar_SP Members

frmCalendar_SP overview

Constructors

constructor frmCalendar_SP Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method MonthCalendar1_DateChanged
method btnAbbruch_Click
method frmCalendar_SP_Load
method gaga

Fields

field Button1
field MonthCalendar1
field Panel1
field btnAbbruch
field components
field m_datum

See Also

frmCalendar_SP Class


frmCalendar_SP Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP Methods

frmCalendar_SP overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method MonthCalendar1_DateChanged
method btnAbbruch_Click
method frmCalendar_SP_Load
method gaga

See Also

frmCalendar_SP Class


frmCalendar_SP.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.MonthCalendar1 = New System.Windows.Forms.MonthCalendar()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MonthCalendar1
        '
        Me.MonthCalendar1.Location = New System.Drawing.Point(3, 0)
        Me.MonthCalendar1.Name = "MonthCalendar1"
        Me.MonthCalendar1.ShowTodayCircle = False
        Me.MonthCalendar1.TabIndex = 0
        '
        'btnAbbruch
        '
        Me.btnAbbruch.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.btnAbbruch.Location = New System.Drawing.Point(3, 160)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 1
        Me.btnAbbruch.Text = "&Abbruch"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(119, 160)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.MonthCalendar1, Me.btnAbbruch, Me.Button1})
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(200, 192)
        Me.Panel1.TabIndex = 3
        '
        'frmCalendar_SP
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(200, 192)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.None
        Me.Name = "frmCalendar_SP"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.Manual
        Me.Text = "Datum auswählen"
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.MonthCalendar1_DateChanged Method

Private Sub MonthCalendar1_DateChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DateRangeEventArgs _
) Handles MonthCalendar1.DateChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MonthCalendar1_DateChanged(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DateRangeEventArgs) Handles MonthCalendar1.DateChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.frmCalendar_SP_Load Method

Private Sub frmCalendar_SP_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmCalendar_SP_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Width = Me.MonthCalendar1.Width + 7
        Me.Height = Me.MonthCalendar1.Height + Me.Button1.Height + 10
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP.gaga Method

Private Sub gaga( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MonthCalendar1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub gaga(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MonthCalendar1.DoubleClick
        MsgBox("Hallo")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmCalendar_SP Fields

frmCalendar_SP overview

Fields

field Button1
field MonthCalendar1
field Panel1
field btnAbbruch
field components
field m_datum

See Also

frmCalendar_SP Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


MonthCalendar1 Variable

Friend WithEvents MonthCalendar1 As System.Windows.Forms.MonthCalendar

Source code

[Visual Basic]
    Friend WithEvents MonthCalendar1 As System.Windows.Forms.MonthCalendar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


m_datum Variable

Dim m_datum As Date

Source code

[Visual Basic]
    Dim m_datum As Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmCalendar_SP


frmDataselect Class

For a list of all members of this type, see frmDataselect Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDataselect

Public Class frmDataselect
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDataselect Members


frmDataselect Members

frmDataselect overview

Constructors

constructor frmDataselect Constructor

Methods

method C1TrueDBGrid1_DoubleClick
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method btnok_Click
method frmDataselect_Load

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field btnok
field components

See Also

frmDataselect Class


frmDataselect Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect Methods

frmDataselect overview

Methods

method C1TrueDBGrid1_DoubleClick
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method btnok_Click
method frmDataselect_Load

See Also

frmDataselect Class


frmDataselect.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.DoubleClick
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDataselect))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.btnok = New System.Windows.Forms.Button()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(376, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'btnok
        '
        Me.btnok.Location = New System.Drawing.Point(120, 480)
        Me.btnok.Name = "btnok"
        Me.btnok.Size = New System.Drawing.Size(120, 24)
        Me.btnok.TabIndex = 5
        Me.btnok.Text = "Daten übernehmen"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Top
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(0, 25)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(376, 447)
        Me.C1TrueDBGrid1.TabIndex = 6
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 19" & _
        "2;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightTex" & _
        "t;BackColor:Highlight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading" & _
        "{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;Ali" & _
        "gnVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9" & _
        "{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowS" & _
        "tyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" " & _
        "FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRec" & _
        "SelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0" & _
        ", 372, 443</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" m" & _
        "e=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""E" & _
        "venRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterS" & _
        "tyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><He" & _
        "adingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRo" & _
        "w"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle par" & _
        "ent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Styl" & _
        "e11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=" & _
        """Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""" & _
        """ me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me" & _
        "=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""I" & _
        "nactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edi" & _
        "tor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Eve" & _
        "nRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordS" & _
        "elector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""G" & _
        "roup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layou" & _
        "t>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 372," & _
        " 443</ClientArea></Blob>"
        '
        'frmDataselect
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(376, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1, Me.btnok, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDataselect"
        Me.Text = "Datenauswahl"
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.DialogResult = DialogResult.Abort
                Me.Close()
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect.btnok_Click Method

Private Sub btnok_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnok.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnok_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnok.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect.frmDataselect_Load Method

Private Sub frmDataselect_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDataselect_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Width = 0
        Try
            Me.C1TrueDBGrid1.Columns(2).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Catch
        End Try
        Try
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Width = (Me.C1TrueDBGrid1.Width / 6) * 3
        Catch
        End Try
        Try
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(2).Width = (Me.C1TrueDBGrid1.Width / 6) * 1
        Catch
        End Try
        Try
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(3).Width = (Me.C1TrueDBGrid1.Width / 6) * 2
        Catch
        End Try
        Try
            Me.C1TrueDBGrid1.Columns(1).FilterText = ""
            Me.C1TrueDBGrid1.Columns(2).FilterText = True
        Catch
        End Try

        Me.C1TrueDBGrid1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDataselect Fields

frmDataselect overview

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field btnok
field components

See Also

frmDataselect Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


btnok Variable

Friend WithEvents btnok As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnok As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDataselect


frmDatenbankauswahl Class

For a list of all members of this type, see frmDatenbankauswahl Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDatenbankauswahl

Public Class frmDatenbankauswahl
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDatenbankauswahl Members


frmDatenbankauswahl Members

frmDatenbankauswahl overview

Constructors

constructor frmDatenbankauswahl Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox1_KeyDown
method frmDatenbankauswahl_Load

Fields

field Button1
field ListBox1
field components

See Also

frmDatenbankauswahl Class


frmDatenbankauswahl Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl Methods

frmDatenbankauswahl overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox1_KeyDown
method frmDatenbankauswahl_Load

See Also

frmDatenbankauswahl Class


frmDatenbankauswahl.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(232, 95)
        Me.ListBox1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(88, 128)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&OK"
        '
        'frmDatenbankauswahl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(258, 165)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.ListBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Name = "frmDatenbankauswahl"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Datebbankauswahl"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl.ListBox1_DoubleClick Method

Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl.ListBox1_KeyDown Method

Private Sub ListBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles ListBox1.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles ListBox1.KeyDown
        If e.KeyCode = Keys.Enter Then Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl.frmDatenbankauswahl_Load Method

Private Sub frmDatenbankauswahl_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDatenbankauswahl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatenbankauswahl Fields

frmDatenbankauswahl overview

Fields

field Button1
field ListBox1
field components

See Also

frmDatenbankauswahl Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatenbankauswahl


frmDatumSelect Class

For a list of all members of this type, see frmDatumSelect Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDatumSelect

Public Class frmDatumSelect
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDatumSelect Members


frmDatumSelect Members

frmDatumSelect overview

Constructors

constructor frmDatumSelect Constructor

Properties

property Datumsbereich
property DislpayResult
property NavigationResult
property datenherkunft

Methods

method Dispose
method GetDatumBis
method GetDatumVon
method InitializeComponent
method ShowGroupBox
method ValidateComboInput
method cboAnzTageBis_Change
method cboAnzTageBis_Enter
method cboAnzTageBis_TextChanged
method cboAnzTageBis_Validated
method cboAnzTageBis_Validating
method cboAnzTageVon_Change
method cboAnzTageVon_Enter
method cboAnzTageVon_TextChanged
method cboAnzTageVon_Validated
method cboAnzTageVon_Validating
method cboDateRange_Change
method cboDateRange_Enter
method cmdCancel_Click
method cmdOK_Click
method dpBis_ValueChanged
method dpVon_ValueChanged
method fillCbo
method frmDatumSelect_Load
method getlastDayInMonth

Fields

field cboAnzTageBis
field cboAnzTageVon
field cboDateRange
field cmdCancel
field cmdOK
field components
field dpBis
field dpVon
field iCnt
field lbl
field lblAuswahlBis
field lblAuswahlVon
field lblBisDatum
field lblVonDatum
field m_dDatumBis
field m_dDatumVon
field m_iAnzahlTageBis
field m_iAnzahlTageVon
field m_iDatumberich
field m_iLastDayAktuellerMonat
field m_sDislpayResult
field m_sNavigationResult
field m_sResult
field m_sdatenherkunft

See Also

frmDatumSelect Class


frmDatumSelect Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect Properties

frmDatumSelect overview

Properties

property Datumsbereich
property DislpayResult
property NavigationResult
property datenherkunft

See Also

frmDatumSelect Class


frmDatumSelect.Datumsbereich Property

Public Property Datumsbereich()

Source code

[Visual Basic]
    Public Property Datumsbereich()
        Get
            Datumsbereich = m_iDatumberich
        End Get
        Set(ByVal Value)
            m_iDatumberich = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.DislpayResult Property

Property DislpayResult() As String

Source code

[Visual Basic]
    Property DislpayResult() As String
        Get
            m_sDislpayResult = Replace(m_sResult, "BETWEEN", "Zwischen")
            m_sDislpayResult = Replace(m_sDislpayResult, "AND", "und")
            Return m_sDislpayResult
        End Get
        Set(ByVal Value As String)
            m_sDislpayResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.NavigationResult Property

Property NavigationResult() As String

Source code

[Visual Basic]
    Property NavigationResult() As String
        ' Werte dienen für die Steuerung
        Get
            Return m_sResult
        End Get
        Set(ByVal Value As String)
            m_sResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.datenherkunft Property

Public Property datenherkunft()

Source code

[Visual Basic]
    Public Property datenherkunft()
        Get
            datenherkunft = m_sdatenherkunft
        End Get
        Set(ByVal Value)
            Dim aDatenherkunft() As String
            m_sdatenherkunft = Value
            aDatenherkunft = Split(m_sdatenherkunft, ";")
            m_iLastDayAktuellerMonat = getlastDayInMonth(Now())
            If UBound(aDatenherkunft) > 0 Then
                'Struktut des Array
                '0= Datumbereichtyp             0
                '1= Anzahl Tage oder Vondatum   1 oder 10.11.2003
                '2= Text Datumbereich           Datum_Bis_Heute
                '3= Anzahl Tage oderBisDatum    10 oder 10.11.2003
                m_iDatumberich = aDatenherkunft(0)
                Select Case m_iDatumberich
                    Case Enum_Datumbereich.Von_Bis
                        m_dDatumVon = aDatenherkunft(1)
                        m_dDatumBis = aDatenherkunft(3)

                    Case Enum_Datumbereich.Datum_Bis_Heute
                        m_dDatumVon = aDatenherkunft(1)
                        m_dDatumBis = Format(Now(), "dd.MM.yyyy")

                    Case Enum_Datumbereich.Tage_Bis_Heute
                        m_iAnzahlTageVon = aDatenherkunft(1)
                        m_dDatumBis = Format(Now(), "dd.MM.yyyy")

                    Case Enum_Datumbereich.Aktueller_Monat
                        m_iAnzahlTageVon = aDatenherkunft(1)
                        m_iAnzahlTageBis = aDatenherkunft(3)

                    Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                        m_iAnzahlTageVon = aDatenherkunft(1)
                        If aDatenherkunft(3) = "Letzter Tag" Then
                            m_iAnzahlTageBis = 31
                        End If
                        'm_iAnzahlTageBis = aDatenherkunft(3)
                        If m_iAnzahlTageBis > m_iLastDayAktuellerMonat Then
                            m_iAnzahlTageBis = m_iLastDayAktuellerMonat
                        End If
                End Select
            Else
                m_dDatumVon = Format(Now(), "dd.MM.yyyy")
                m_dDatumBis = Format(Now(), "dd.MM.yyyy")

            End If

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect Methods

frmDatumSelect overview

Methods

method Dispose
method GetDatumBis
method GetDatumVon
method InitializeComponent
method ShowGroupBox
method ValidateComboInput
method cboAnzTageBis_Change
method cboAnzTageBis_Enter
method cboAnzTageBis_TextChanged
method cboAnzTageBis_Validated
method cboAnzTageBis_Validating
method cboAnzTageVon_Change
method cboAnzTageVon_Enter
method cboAnzTageVon_TextChanged
method cboAnzTageVon_Validated
method cboAnzTageVon_Validating
method cboDateRange_Change
method cboDateRange_Enter
method cmdCancel_Click
method cmdOK_Click
method dpBis_ValueChanged
method dpVon_ValueChanged
method fillCbo
method frmDatumSelect_Load
method getlastDayInMonth

See Also

frmDatumSelect Class


frmDatumSelect.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.GetDatumBis Method

Private Sub GetDatumBis()

Source code

[Visual Basic]
    Private Sub GetDatumBis()
        Select Case cboDateRange.SelectedIndex
            Case Enum_Datumbereich.Von_Bis
                lblBisDatum.Text = m_dDatumBis

            Case Enum_Datumbereich.Datum_Bis_Heute
                lblBisDatum.Text = m_dDatumBis

            Case Enum_Datumbereich.Tage_Bis_Heute
                m_dDatumBis = Format(DateAdd(DateInterval.Day, 0, Now()), "dd.MM.yyyy")
                'If cboAnzTageBis.Text <> "" Then
                '    m_dDatumBis = Format(DateAdd(DateInterval.Day, -CType(cboAnzTageVon.Text, Integer), Now()), "dd.MM.yyyy")
                'Else
                '    m_dDatumBis = Format(DateAdd(DateInterval.Day, 0, Now()), "dd.MM.yyyy")
                'End If
                lblBisDatum.Text = m_dDatumBis

            Case Enum_Datumbereich.Aktueller_Monat

                lblBisDatum.Text = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), m_iLastDayAktuellerMonat), "dd.MM.yyyy")
            Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                Select Case cboAnzTageBis.SelectedIndex
                    Case 0      'Letzter Tag Monat
                        lblBisDatum.Text = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), m_iLastDayAktuellerMonat), "dd.MM.yyyy")
                    Case Else   '0-31
                        lblBisDatum.Text = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), cboAnzTageBis.SelectedIndex), "dd.MM.yyyy")
                End Select
        End Select
        dpBis.Text = lblBisDatum.Text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.GetDatumVon Method

Private Sub GetDatumVon()

Source code

[Visual Basic]
    Private Sub GetDatumVon()
        Try
            Select Case cboDateRange.SelectedIndex
                Case Enum_Datumbereich.Von_Bis
                    lblVonDatum.Text = m_dDatumVon

                Case Enum_Datumbereich.Datum_Bis_Heute
                    lblVonDatum.Text = m_dDatumVon

                Case Enum_Datumbereich.Tage_Bis_Heute
                    If (Not IsNumeric(cboAnzTageVon.Text) And Len(cboAnzTageVon.Text) > 0) Or Len(cboAnzTageVon.Text) > 4 Then
                        MessageBox.Show(MyTxt.gettext(18), "Eingabe von Datum", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                        Exit Sub
                    End If
                    If cboAnzTageVon.Text <> "" Then
                        m_dDatumVon = Format(DateAdd(DateInterval.Day, -CType(cboAnzTageVon.Text, Integer), Now()), "dd.MM.yyyy")
                    Else
                        m_dDatumVon = Format(DateAdd(DateInterval.Day, 0, Now()), "dd.MM.yyyy")
                    End If
                    lblVonDatum.Text = m_dDatumVon

                Case Enum_Datumbereich.Aktueller_Monat
                    lblVonDatum.Text = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), 1), "dd.MM.yyyy")
                Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                    If cboAnzTageVon.Text <> "" Then
                        m_dDatumVon = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), cboAnzTageVon.Text), "dd.MM.yyyy")
                    Else
                        m_dDatumVon = Format(DateAdd(DateInterval.Day, 0, Now()), "dd.MM.yyyy")
                    End If
                    lblVonDatum.Text = m_dDatumVon
            End Select
            dpVon.Text = lblVonDatum.Text
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.lbl = New System.Windows.Forms.Label()
        Me.cboAnzTageBis = New C1.Win.C1List.C1Combo()
        Me.cboAnzTageVon = New C1.Win.C1List.C1Combo()
        Me.cboDateRange = New C1.Win.C1List.C1Combo()
        Me.dpBis = New System.Windows.Forms.DateTimePicker()
        Me.dpVon = New System.Windows.Forms.DateTimePicker()
        Me.lblAuswahlVon = New System.Windows.Forms.Label()
        Me.lblAuswahlBis = New System.Windows.Forms.Label()
        Me.lblVonDatum = New System.Windows.Forms.Label()
        Me.lblBisDatum = New System.Windows.Forms.Label()
        Me.cmdCancel = New System.Windows.Forms.Button()
        Me.cmdOK = New System.Windows.Forms.Button()
        CType(Me.cboAnzTageBis, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.cboAnzTageVon, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.cboDateRange, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'lbl
        '
        Me.lbl.Location = New System.Drawing.Point(18, 11)
        Me.lbl.Name = "lbl"
        Me.lbl.Size = New System.Drawing.Size(80, 16)
        Me.lbl.TabIndex = 80
        Me.lbl.Text = "Datumbereich"
        Me.lbl.TextAlign = System.Drawing.ContentAlignment.MiddleLeft
        '
        'cboAnzTageBis
        '
        Me.cboAnzTageBis.AddItemCols = 0
        Me.cboAnzTageBis.AddItemSeparator = Microsoft.VisualBasic.ChrW(59)
        Me.cboAnzTageBis.AllowColMove = True
        Me.cboAnzTageBis.AllowRowSizing = C1.Win.C1List.RowSizingEnum.AllRows
        Me.cboAnzTageBis.AllowSort = True
        Me.cboAnzTageBis.AlternatingRows = False
        Me.cboAnzTageBis.BackColor = System.Drawing.SystemColors.HighlightText
        Me.cboAnzTageBis.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.cboAnzTageBis.Caption = ""
        Me.cboAnzTageBis.CaptionHeight = 17
        Me.cboAnzTageBis.CaptionVisible = False
        Me.cboAnzTageBis.CellTips = C1.Win.C1List.CellTipEnum.NoCellTips
        Me.cboAnzTageBis.CellTipsDelay = 500
        Me.cboAnzTageBis.CellTipsWidth = 0
        Me.cboAnzTageBis.ColumnCaptionHeight = 17
        Me.cboAnzTageBis.ColumnFooterHeight = 17
        Me.cboAnzTageBis.ColumnFooters = False
        Me.cboAnzTageBis.ColumnHeaders = False
        Me.cboAnzTageBis.ColumnWidth = -1
        Me.cboAnzTageBis.Cursor = System.Windows.Forms.Cursors.IBeam
        Me.cboAnzTageBis.DataMode = C1.Win.C1List.DataModeEnum.AddItem
        Me.cboAnzTageBis.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.cboAnzTageBis.DefColWidth = 0
        Me.cboAnzTageBis.DropdownWidth = 0
        Me.cboAnzTageBis.EditBackColor = System.Drawing.SystemColors.Window
        Me.cboAnzTageBis.EditFont = New System.Drawing.Font("Microsoft Sans Serif", 8.25!)
        Me.cboAnzTageBis.EditForeColor = System.Drawing.SystemColors.WindowText
        Me.cboAnzTageBis.EditorHeight = 21
        Me.cboAnzTageBis.EmptyRows = False
        Me.cboAnzTageBis.ExtendRightColumn = False
        Me.cboAnzTageBis.FetchRowStyles = False
        Me.cboAnzTageBis.GapHeight = 2.0!
        Me.cboAnzTageBis.IntegralHeight = False
        Me.cboAnzTageBis.ItemHeight = 15
        Me.cboAnzTageBis.Location = New System.Drawing.Point(296, 32)
        Me.cboAnzTageBis.MatchEntryTimeout = 100
        Me.cboAnzTageBis.MaxDropDownItems = CType(5, Short)
        Me.cboAnzTageBis.MaxLength = 32767
        Me.cboAnzTageBis.MouseCursor = System.Windows.Forms.Cursors.Default
        Me.cboAnzTageBis.Name = "cboAnzTageBis"
        Me.cboAnzTageBis.PartialRightColumn = True
        Me.cboAnzTageBis.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1List.Design.ContextWrapper""><Da" & _
        "ta>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style2{" & _
        "}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{ForeColor:High" & _
        "lightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:InactiveCaptionText;Ba" & _
        "ckColor:InactiveCaption;}Footer{}Caption{AlignHorz:Center;}Normal{BackColor:High" & _
        "lightText;}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{Alig" & _
        "nHorz:Near;}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVer" & _
        "t:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Styl" & _
        "e8{}Style10{}Style11{}Style1{}</Data></Styles><Splits><C1.Win.C1List.ListBoxView" & _
        " AllowColSelect=""False"" Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRec" & _
        "t>0, 0, 96, 198</ClientRect><CaptionStyle parent=""Style2"" me=""Style9"" /><EvenRow" & _
        "Style parent=""EvenRow"" me=""Style7"" /><FooterStyle parent=""Footer"" me=""Style3"" />" & _
        "<GroupStyle parent=""Group"" me=""Style11"" /><HeadingStyle parent=""Heading"" me=""Sty" & _
        "le2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style6"" /><InactiveStyle par" & _
        "ent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style8"" /><RecordS" & _
        "electorStyle parent=""RecordSelector"" me=""Style10"" /><SelectedStyle parent=""Selec" & _
        "ted"" me=""Style5"" /><Style parent="""" me=""Normal"" /></C1.Win.C1List.ListBoxView></" & _
        "Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""He" & _
        "ading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Capti" & _
        "on"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selecte" & _
        "d"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertS" & _
        "plits><horzSplits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16<" & _
        "/DefaultRecSelWidth></Blob>"
        Me.cboAnzTageBis.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.cboAnzTageBis.RowTracking = True
        Me.cboAnzTageBis.ScrollTips = False
        Me.cboAnzTageBis.ScrollTrack = True
        Me.cboAnzTageBis.SelectedText = ""
        Me.cboAnzTageBis.SelectionLength = 0
        Me.cboAnzTageBis.SelectionStart = 0
        Me.cboAnzTageBis.Size = New System.Drawing.Size(98, 21)
        Me.cboAnzTageBis.TabIndex = 5
        Me.cboAnzTageBis.TabStop = False
        Me.cboAnzTageBis.Text = "1"
        '
        'cboAnzTageVon
        '
        Me.cboAnzTageVon.AddItemCols = 0
        Me.cboAnzTageVon.AddItemSeparator = Microsoft.VisualBasic.ChrW(59)
        Me.cboAnzTageVon.AllowColMove = True
        Me.cboAnzTageVon.AllowRowSizing = C1.Win.C1List.RowSizingEnum.AllRows
        Me.cboAnzTageVon.AllowSort = True
        Me.cboAnzTageVon.AlternatingRows = False
        Me.cboAnzTageVon.BackColor = System.Drawing.SystemColors.HighlightText
        Me.cboAnzTageVon.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.cboAnzTageVon.Caption = ""
        Me.cboAnzTageVon.CaptionHeight = 17
        Me.cboAnzTageVon.CaptionVisible = False
        Me.cboAnzTageVon.CellTips = C1.Win.C1List.CellTipEnum.NoCellTips
        Me.cboAnzTageVon.CellTipsDelay = 500
        Me.cboAnzTageVon.CellTipsWidth = 0
        Me.cboAnzTageVon.ColumnCaptionHeight = 17
        Me.cboAnzTageVon.ColumnFooterHeight = 17
        Me.cboAnzTageVon.ColumnFooters = False
        Me.cboAnzTageVon.ColumnHeaders = False
        Me.cboAnzTageVon.ColumnWidth = -1
        Me.cboAnzTageVon.Cursor = System.Windows.Forms.Cursors.IBeam
        Me.cboAnzTageVon.DataMode = C1.Win.C1List.DataModeEnum.AddItem
        Me.cboAnzTageVon.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.cboAnzTageVon.DefColWidth = 0
        Me.cboAnzTageVon.DropdownWidth = 0
        Me.cboAnzTageVon.EditBackColor = System.Drawing.SystemColors.Window
        Me.cboAnzTageVon.EditFont = New System.Drawing.Font("Microsoft Sans Serif", 8.25!)
        Me.cboAnzTageVon.EditForeColor = System.Drawing.SystemColors.WindowText
        Me.cboAnzTageVon.EditorHeight = 21
        Me.cboAnzTageVon.EmptyRows = False
        Me.cboAnzTageVon.ExtendRightColumn = False
        Me.cboAnzTageVon.FetchRowStyles = False
        Me.cboAnzTageVon.GapHeight = 2.0!
        Me.cboAnzTageVon.IntegralHeight = False
        Me.cboAnzTageVon.ItemHeight = 15
        Me.cboAnzTageVon.Location = New System.Drawing.Point(296, 8)
        Me.cboAnzTageVon.MatchEntryTimeout = 100
        Me.cboAnzTageVon.MaxDropDownItems = CType(5, Short)
        Me.cboAnzTageVon.MaxLength = 32767
        Me.cboAnzTageVon.MouseCursor = System.Windows.Forms.Cursors.Default
        Me.cboAnzTageVon.Name = "cboAnzTageVon"
        Me.cboAnzTageVon.PartialRightColumn = True
        Me.cboAnzTageVon.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1List.Design.ContextWrapper""><Da" & _
        "ta>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}Style2{" & _
        "}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{ForeColor:High" & _
        "lightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:InactiveCaptionText;Ba" & _
        "ckColor:InactiveCaption;}Footer{}Caption{AlignHorz:Center;}Normal{BackColor:High" & _
        "lightText;}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Odd" & _
        "Row{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{}St" & _
        "yle11{}Style9{AlignHorz:Near;}</Data></Styles><Splits><C1.Win.C1List.ListBoxView" & _
        " AllowColSelect=""False"" Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRec" & _
        "t>0, 0, 96, 198</ClientRect><CaptionStyle parent=""Style2"" me=""Style9"" /><EvenRow" & _
        "Style parent=""EvenRow"" me=""Style7"" /><FooterStyle parent=""Footer"" me=""Style3"" />" & _
        "<GroupStyle parent=""Group"" me=""Style11"" /><HeadingStyle parent=""Heading"" me=""Sty" & _
        "le2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style6"" /><InactiveStyle par" & _
        "ent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style8"" /><RecordS" & _
        "electorStyle parent=""RecordSelector"" me=""Style10"" /><SelectedStyle parent=""Selec" & _
        "ted"" me=""Style5"" /><Style parent="""" me=""Normal"" /></C1.Win.C1List.ListBoxView></" & _
        "Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""He" & _
        "ading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Capti" & _
        "on"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selecte" & _
        "d"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertS" & _
        "plits><horzSplits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16<" & _
        "/DefaultRecSelWidth></Blob>"
        Me.cboAnzTageVon.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.cboAnzTageVon.RowTracking = True
        Me.cboAnzTageVon.ScrollTips = False
        Me.cboAnzTageVon.ScrollTrack = True
        Me.cboAnzTageVon.SelectedText = ""
        Me.cboAnzTageVon.SelectionLength = 0
        Me.cboAnzTageVon.SelectionStart = 0
        Me.cboAnzTageVon.Size = New System.Drawing.Size(98, 21)
        Me.cboAnzTageVon.TabIndex = 4
        Me.cboAnzTageVon.Text = "1"
        '
        'cboDateRange
        '
        Me.cboDateRange.AddItemCols = 1
        Me.cboDateRange.AddItemSeparator = Microsoft.VisualBasic.ChrW(59)
        Me.cboDateRange.AllowColMove = True
        Me.cboDateRange.AllowRowSizing = C1.Win.C1List.RowSizingEnum.AllRows
        Me.cboDateRange.AllowSort = True
        Me.cboDateRange.AlternatingRows = False
        Me.cboDateRange.AutoCompletion = True
        Me.cboDateRange.AutoDropDown = True
        Me.cboDateRange.BackColor = System.Drawing.SystemColors.HighlightText
        Me.cboDateRange.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.cboDateRange.Caption = ""
        Me.cboDateRange.CaptionHeight = 17
        Me.cboDateRange.CellTips = C1.Win.C1List.CellTipEnum.NoCellTips
        Me.cboDateRange.CellTipsDelay = 500
        Me.cboDateRange.CellTipsWidth = 0
        Me.cboDateRange.ColumnCaptionHeight = 17
        Me.cboDateRange.ColumnFooterHeight = 17
        Me.cboDateRange.ColumnFooters = False
        Me.cboDateRange.ColumnHeaders = False
        Me.cboDateRange.ColumnWidth = -1
        Me.cboDateRange.Cursor = System.Windows.Forms.Cursors.IBeam
        Me.cboDateRange.DataMode = C1.Win.C1List.DataModeEnum.AddItem
        Me.cboDateRange.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.cboDateRange.DefColWidth = 0
        Me.cboDateRange.DropdownWidth = 0
        Me.cboDateRange.EditBackColor = System.Drawing.SystemColors.Window
        Me.cboDateRange.EditFont = New System.Drawing.Font("Microsoft Sans Serif", 8.25!)
        Me.cboDateRange.EditForeColor = System.Drawing.SystemColors.WindowText
        Me.cboDateRange.EditorHeight = 21
        Me.cboDateRange.EmptyRows = False
        Me.cboDateRange.ExtendRightColumn = False
        Me.cboDateRange.FetchRowStyles = False
        Me.cboDateRange.GapHeight = 2.0!
        Me.cboDateRange.IntegralHeight = False
        Me.cboDateRange.ItemHeight = 15
        Me.cboDateRange.Location = New System.Drawing.Point(101, 8)
        Me.cboDateRange.MatchEntryTimeout = 100
        Me.cboDateRange.MaxDropDownItems = CType(5, Short)
        Me.cboDateRange.MaxLength = 32767
        Me.cboDateRange.MouseCursor = System.Windows.Forms.Cursors.Default
        Me.cboDateRange.Name = "cboDateRange"
        Me.cboDateRange.PartialRightColumn = True
        Me.cboDateRange.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1List.Design.ContextWrapper""><Da" & _
        "ta>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style2{" & _
        "}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{ForeColor:High" & _
        "lightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:InactiveCaptionText;Ba" & _
        "ckColor:InactiveCaption;}Footer{}Caption{AlignHorz:Center;}Normal{BackColor:High" & _
        "lightText;}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{Alig" & _
        "nHorz:Near;}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVer" & _
        "t:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Styl" & _
        "e8{}Style10{}Style11{}Style1{}</Data></Styles><Splits><C1.Win.C1List.ListBoxView" & _
        " AllowColSelect=""False"" Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRec" & _
        "t>0, 0, 165, 198</ClientRect><CaptionStyle parent=""Style2"" me=""Style9"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style7"" /><FooterStyle parent=""Footer"" me=""Style3"" /" & _
        "><GroupStyle parent=""Group"" me=""Style11"" /><HeadingStyle parent=""Heading"" me=""St" & _
        "yle2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style6"" /><InactiveStyle pa" & _
        "rent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style8"" /><Record" & _
        "SelectorStyle parent=""RecordSelector"" me=""Style10"" /><SelectedStyle parent=""Sele" & _
        "cted"" me=""Style5"" /><Style parent="""" me=""Normal"" /></C1.Win.C1List.ListBoxView><" & _
        "/Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""H" & _
        "eading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Capt" & _
        "ion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Select" & _
        "ed"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vert" & _
        "Splits><horzSplits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16" & _
        "</DefaultRecSelWidth></Blob>"
        Me.cboDateRange.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.cboDateRange.RowTracking = True
        Me.cboDateRange.ScrollTips = False
        Me.cboDateRange.ScrollTrack = True
        Me.cboDateRange.SelectedText = ""
        Me.cboDateRange.SelectionLength = 0
        Me.cboDateRange.SelectionStart = 0
        Me.cboDateRange.Size = New System.Drawing.Size(167, 21)
        Me.cboDateRange.TabIndex = 1
        Me.cboDateRange.Text = "Von_Bis"
        '
        'dpBis
        '
        Me.dpBis.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dpBis.Location = New System.Drawing.Point(101, 71)
        Me.dpBis.Name = "dpBis"
        Me.dpBis.Size = New System.Drawing.Size(168, 20)
        Me.dpBis.TabIndex = 3
        '
        'dpVon
        '
        Me.dpVon.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dpVon.Location = New System.Drawing.Point(101, 40)
        Me.dpVon.Name = "dpVon"
        Me.dpVon.Size = New System.Drawing.Size(168, 20)
        Me.dpVon.TabIndex = 2
        '
        'lblAuswahlVon
        '
        Me.lblAuswahlVon.Location = New System.Drawing.Point(18, 39)
        Me.lblAuswahlVon.Name = "lblAuswahlVon"
        Me.lblAuswahlVon.Size = New System.Drawing.Size(60, 16)
        Me.lblAuswahlVon.TabIndex = 75
        Me.lblAuswahlVon.Text = "Datum von"
        Me.lblAuswahlVon.TextAlign = System.Drawing.ContentAlignment.MiddleLeft
        '
        'lblAuswahlBis
        '
        Me.lblAuswahlBis.Location = New System.Drawing.Point(18, 72)
        Me.lblAuswahlBis.Name = "lblAuswahlBis"
        Me.lblAuswahlBis.Size = New System.Drawing.Size(63, 16)
        Me.lblAuswahlBis.TabIndex = 74
        Me.lblAuswahlBis.Text = "Datum bis"
        Me.lblAuswahlBis.TextAlign = System.Drawing.ContentAlignment.MiddleLeft
        '
        'lblVonDatum
        '
        Me.lblVonDatum.Location = New System.Drawing.Point(273, 43)
        Me.lblVonDatum.Name = "lblVonDatum"
        Me.lblVonDatum.Size = New System.Drawing.Size(63, 16)
        Me.lblVonDatum.TabIndex = 69
        Me.lblVonDatum.Text = "01.01.2003"
        Me.lblVonDatum.TextAlign = System.Drawing.ContentAlignment.MiddleLeft
        '
        'lblBisDatum
        '
        Me.lblBisDatum.Location = New System.Drawing.Point(274, 74)
        Me.lblBisDatum.Name = "lblBisDatum"
        Me.lblBisDatum.Size = New System.Drawing.Size(63, 16)
        Me.lblBisDatum.TabIndex = 68
        Me.lblBisDatum.Text = "31.12.2003"
        Me.lblBisDatum.TextAlign = System.Drawing.ContentAlignment.MiddleLeft
        '
        'cmdCancel
        '
        Me.cmdCancel.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.cmdCancel.Location = New System.Drawing.Point(101, 100)
        Me.cmdCancel.Name = "cmdCancel"
        Me.cmdCancel.Size = New System.Drawing.Size(67, 23)
        Me.cmdCancel.TabIndex = 7
        Me.cmdCancel.Text = "Abbrechen"
        '
        'cmdOK
        '
        Me.cmdOK.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.cmdOK.Location = New System.Drawing.Point(264, 100)
        Me.cmdOK.Name = "cmdOK"
        Me.cmdOK.Size = New System.Drawing.Size(67, 23)
        Me.cmdOK.TabIndex = 6
        Me.cmdOK.Text = "OK"
        '
        'frmDatumSelect
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(410, 138)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lbl, Me.cboAnzTageVon, Me.cboDateRange, Me.dpBis, Me.dpVon, Me.lblAuswahlVon, Me.lblAuswahlBis, Me.lblVonDatum, Me.lblBisDatum, Me.cmdCancel, Me.cmdOK, Me.cboAnzTageBis})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Name = "frmDatumSelect"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterParent
        Me.Text = "Datum Selektion"
        CType(Me.cboAnzTageBis, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.cboAnzTageVon, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.cboDateRange, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.ShowGroupBox Method

Private Sub ShowGroupBox( _
   ByVal Auswahltyp As Enum_Datumbereich _
)

Parameters

Auswahltyp
Required.

Source code

[Visual Basic]
    Private Sub ShowGroupBox(ByVal Auswahltyp As Enum_Datumbereich)
        '===============================================================================
        'Desc       : Je nach Berichswal werden die entsprechenden Controls angezeigt
        'Input 	    : Auswahlty
        'Kriterium  :
        'Updatewert :
        'Output	    :
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Try
            cboAnzTageVon.Visible = False
            cboAnzTageBis.Visible = False
            dpVon.Visible = False
            dpBis.Visible = False
            dpVon.Enabled = False
            dpBis.Enabled = False
            lblAuswahlBis.Visible = True
            lblAuswahlVon.Visible = True
            Select Case Auswahltyp
                Case Enum_Datumbereich.Von_Bis
                    dpVon.Visible = True
                    dpBis.Visible = True
                    dpVon.Enabled = True
                    dpBis.Enabled = True
                    'lblVonDatum.Text = dpVon.Text
                    'lblBisDatum.Text = dpBis.Text
                Case Enum_Datumbereich.Datum_Bis_Heute
                    fillCbo(cboAnzTageBis, Now(), Enum_Filltype.Heute, False)
                    dpVon.Visible = True
                    dpVon.Enabled = True
                    cboAnzTageBis.Visible = True
                    'lblVonDatum.Text = m_dDatumVon
                    'lblBisDatum.Text = m_dDatumBis

                Case Enum_Datumbereich.Tage_Bis_Heute
                    fillCbo(cboAnzTageVon, Now(), Enum_Filltype.Jahr, False)
                    fillCbo(cboAnzTageBis, Now(), Enum_Filltype.Heute, False)
                    cboAnzTageVon.Visible = True
                    cboAnzTageBis.Visible = True
                    'lblVonDatum.Text = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), DatePart(DateInterval.Day, DateAdd(DateInterval.Day, -cboAnzTageVon.Value, Now()))), "dd.MM.yyyy")
                    'lblBisDatum.Text = Format(Now(), "dd.MM.yyyy")

                Case Enum_Datumbereich.Aktueller_Monat
                    'lblVonDatum.Text = DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), 1)
                    'lblBisDatum.Text = DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), getlastDayInMonth(Now()))
                    fillCbo(cboAnzTageVon, Now(), Enum_Filltype.Heute, False)
                    fillCbo(cboAnzTageBis, Now(), Enum_Filltype.Heute, False)

                    dpVon.Visible = True
                    dpBis.Visible = True
                    'lblAuswahlBis.Visible = False
                    'lblAuswahlVon.Visible = False

                Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                    fillCbo(cboAnzTageVon, Now(), Enum_Filltype.Monat, False)
                    fillCbo(cboAnzTageBis, Now(), Enum_Filltype.Monat, True)
                    cboAnzTageVon.Visible = True
                    cboAnzTageBis.Visible = True
            End Select
            If cboAnzTageVon.Visible = True Then
                cboAnzTageVon.Splits(0).DisplayColumns(0).Width = cboAnzTageVon.Width - 20
            End If
            If cboAnzTageBis.Visible = True Then
                cboAnzTageBis.Splits(0).DisplayColumns(0).Width = cboAnzTageBis.Width - 20
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.ValidateComboInput Method

Private Function ValidateComboInput( _
   ByRef cbo As C1.Win.C1List.C1Combo _
) As Boolean

Parameters

cbo
Required.

Source code

[Visual Basic]
    Private Function ValidateComboInput(ByRef cbo As C1.Win.C1List.C1Combo) As Boolean
        Dim iFoundIndex As Integer
        iFoundIndex = cbo.FindStringExact(cbo.Text, 0, 0)
        If iFoundIndex > -1 Then
            ValidateComboInput = True
            Try
                cbo.SelectedIndex = iFoundIndex
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        Else
            ValidateComboInput = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageBis_Change Method

Private Sub cboAnzTageBis_Change( _
   ByVal sender As System.Object _
) Handles cboAnzTageBis.Change

Parameters

sender
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageBis_Change(ByVal sender As System.Object) Handles cboAnzTageBis.Change
        GetDatumBis()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageBis_Enter Method

Private Sub cboAnzTageBis_Enter( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageBis.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageBis_Enter(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageBis.Enter

        cboAnzTageBis.Columns(0).Caption = ""

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageBis_TextChanged Method

Private Sub cboAnzTageBis_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageBis.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageBis_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageBis.TextChanged
        GetDatumBis()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageBis_Validated Method

Private Sub cboAnzTageBis_Validated( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageBis.Validated

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageBis_Validated(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageBis.Validated
        GetDatumBis()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageBis_Validating Method

Private Sub cboAnzTageBis_Validating( _
   ByVal sender As System.Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles cboAnzTageBis.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageBis_Validating(ByVal sender As System.Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles cboAnzTageBis.Validating
        If ValidateComboInput(cboAnzTageBis) = False Then
            MessageBox.Show(MyTxt.gettext(18), "Eingabe bis Datum", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)

            '            MessageBox.Show("Kein Text der Liste", "Eingabe", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
            e.Cancel = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageVon_Change Method

Private Sub cboAnzTageVon_Change( _
   ByVal sender As System.Object _
) Handles cboAnzTageVon.Change

Parameters

sender
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageVon_Change(ByVal sender As System.Object) Handles cboAnzTageVon.Change
        GetDatumVon()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageVon_Enter Method

Private Sub cboAnzTageVon_Enter( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageVon.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageVon_Enter(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageVon.Enter
        cboAnzTageVon.Columns(0).Caption = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageVon_TextChanged Method

Private Sub cboAnzTageVon_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageVon.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageVon_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageVon.TextChanged
        GetDatumVon()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageVon_Validated Method

Private Sub cboAnzTageVon_Validated( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboAnzTageVon.Validated

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageVon_Validated(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboAnzTageVon.Validated
        GetDatumVon()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboAnzTageVon_Validating Method

Private Sub cboAnzTageVon_Validating( _
   ByVal sender As System.Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles cboAnzTageVon.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboAnzTageVon_Validating(ByVal sender As System.Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles cboAnzTageVon.Validating
        If ValidateComboInput(cboAnzTageVon) = False Then 'Eingabe prüfen
            MessageBox.Show(MyTxt.gettext(18), "Eingabe von Datum", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
            'MessageBox.Show("Kein Text der Liste", "Eingabe", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)

            e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboDateRange_Change Method

Private Sub cboDateRange_Change( _
   ByVal sender As System.Object _
) Handles cboDateRange.Change

Parameters

sender
Required.

Source code

[Visual Basic]
    Private Sub cboDateRange_Change(ByVal sender As System.Object) Handles cboDateRange.Change
        ShowGroupBox(cboDateRange.SelectedIndex)
        GetDatumVon()
        GetDatumBis()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cboDateRange_Enter Method

Private Sub cboDateRange_Enter( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cboDateRange.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboDateRange_Enter(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cboDateRange.Enter

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cmdCancel_Click Method

Private Sub cmdCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.cmdOK_Click Method

Private Sub cmdOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdOK.Click
        '===============================================================================
        'Desc       : Befüllen der Property & Form schliessen
        'Input 	    :
        'Kriterium  : Selected Datumrange
        'Updatewert :
        'Output	    :
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        m_iDatumberich = cboDateRange.SelectedIndex
        Select Case cboDateRange.SelectedIndex
            Case Enum_Datumbereich.Von_Bis
                m_sdatenherkunft = m_iDatumberich & ";" & dpVon.Text & ";Von_Bis;" & dpBis.Text

            Case Enum_Datumbereich.Datum_Bis_Heute
                m_sdatenherkunft = m_iDatumberich & ";" & dpVon.Text & ";Datum_Bis_Heute;Heute"

            Case Enum_Datumbereich.Tage_Bis_Heute
                m_sdatenherkunft = m_iDatumberich & ";" & cboAnzTageVon.Text & ";Tage_Bis_Heute;Heute"

            Case Enum_Datumbereich.Aktueller_Monat
                m_sdatenherkunft = m_iDatumberich & ";1;AktuellerMonat;0"        '0 = Letzer Tag

            Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                m_sdatenherkunft = m_iDatumberich & ";" & cboAnzTageVon.Text & ";AktuellerMonat;" & cboAnzTageBis.Text
        End Select

        'm_sResult = "BETWEEN CONVERT(DATETIME, ' " & Format(CDate(lblVonDatum.Text), "yyyy.MM.dd") & "', 102) And CONVERT(DATETIME, ' " & Format(CDate(lblBisDatum.Text), "yyyy.MM.dd 23:59:59") & "', 102) "

        m_sResult = "BETWEEN " & lblVonDatum.Text & " AND " & lblBisDatum.Text
        'WHERE     (mutiert_am BETWEEN CONVERT(DATETIME, '2004-03-01 00:00:00', 102) AND CONVERT(DATETIME, '2004-03-01 23:59:59', 102))
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.dpBis_ValueChanged Method

Private Sub dpBis_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles dpBis.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub dpBis_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dpBis.ValueChanged
        lblBisDatum.Text = dpBis.Text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.dpVon_ValueChanged Method

Private Sub dpVon_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles dpVon.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub dpVon_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dpVon.ValueChanged
        lblVonDatum.Text = dpVon.Text

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.fillCbo Method

Private Sub fillCbo( _
   ByRef cbo As C1.Win.C1List.C1Combo, _
   ByVal Datum As Date, _
   ByVal FillTyp As Enum_Filltype, _
   ByVal inklLetzterTag As Boolean _
)

Parameters

cbo
Required.
Datum
Required.
FillTyp
Required.
inklLetzterTag
Required.

Source code

[Visual Basic]
    Private Sub fillCbo(ByRef cbo As C1.Win.C1List.C1Combo, ByVal Datum As Date, ByVal FillTyp As Enum_Filltype, ByVal inklLetzterTag As Boolean)
        '===============================================================================
        'Desc       : Füllt das Combo für den aktuellen Filltyp
        'Input 	    : Combocontrol,Datum, Inkl. Letzter Tag
        'Kriterium  : Inkl. Letzter Tag = Bei einem Monat wird der letzte Tag des Monat gewählt
        'Updatewert :
        'Output	    :
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim iCnt As Integer     'Zaehler
        With cbo
            .ClearItems()
            If inklLetzterTag = True Then
                .AddItem("Letzter Tag")

            End If
            Select Case FillTyp
                Case Enum_Filltype.Heute
                    '============ Heute
                    .AddItem("Heute")
                    .SelectedIndex = 0

                Case Enum_Filltype.Jahr
                    '============ Jahr
                    Me.Cursor = Cursors.WaitCursor
                    For iCnt = 0 To 366
                        .AddItem(iCnt)
                    Next
                    .SelectedIndex = 0
                    Me.Cursor = Cursors.Default

                Case Enum_Filltype.Monat
                    '============ Monat
                    For iCnt = 1 To m_iLastDayAktuellerMonat
                        .AddItem(CType(iCnt, String))
                    Next
                    Try
                        .SelectedIndex = 0
                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try
            End Select
        End With

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.frmDatumSelect_Load Method

Private Sub frmDatumSelect_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDatumSelect_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        m_iLastDayAktuellerMonat = getlastDayInMonth(Now())
        cboAnzTageVon.Top = dpVon.Top
        cboAnzTageVon.Left = dpVon.Left
        cboAnzTageVon.ColumnHeaders = False

        cboAnzTageBis.Top = dpBis.Top
        cboAnzTageBis.Left = dpBis.Left
        cboAnzTageBis.ColumnHeaders = False

        cboDateRange.ColumnHeaders = False

        With cboDateRange
            .AddItem("Von Bis")                 'Von Bis
            .AddItem("Datum Bis Heute")         'vondatum bis Heute
            .AddItem("Tage Bis Heute")          'Anzahl Tage bis Heute
            .AddItem("Aktueller Monat")         'Aktueller Monat
            .AddItem("Aktueller Monat Von Bis") 'Aktueller Monat
            .SelectedIndex = m_iDatumberich
        End With
        ShowGroupBox(m_iDatumberich)
        Select Case m_iDatumberich
            Case Enum_Datumbereich.Von_Bis
            Case Enum_Datumbereich.Datum_Bis_Heute
                'dpVon.Text = m_dDatumVon
            Case Enum_Datumbereich.Tage_Bis_Heute
                cboAnzTageVon.SelectedIndex = m_iAnzahlTageVon
                dpBis.Text = m_dDatumBis
            Case Enum_Datumbereich.Aktueller_Monat
                cboAnzTageVon.SelectedIndex = m_iAnzahlTageVon - 1
                cboAnzTageBis.SelectedIndex = m_iAnzahlTageBis
            Case Enum_Datumbereich.Aktueller_MonatVon_Bis
                cboAnzTageVon.SelectedIndex = m_iAnzahlTageVon - 1
                cboAnzTageBis.SelectedIndex = m_iAnzahlTageBis
        End Select
        GetDatumBis()
        GetDatumVon()
        'lblVonDatum.Text = dpVon.Text
        'lblBisDatum.Text = dpBis.Text
        cboDateRange.Splits(0).DisplayColumns(0).Width = cboDateRange.Width - 20

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect.getlastDayInMonth Method

Private Function getlastDayInMonth( _
   ByVal Datum As Date _
) As Integer

Parameters

Datum
Required.

Source code

[Visual Basic]
    Private Function getlastDayInMonth(ByVal Datum As Date) As Integer
        '===============================================================================
        'Desc       : Ermittelt den letzten Tag des Monats
        'Input 	    : Datum
        'Kriterium  :
        'Updatewert :
        'Output	    : Letzter Tag des Monats
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim iLastDayNextMonat As Integer
        Dim iMonat As Integer
        Dim dDate As Date
        iMonat = DatePart(DateInterval.Month, Datum, FirstDayOfWeek.Monday)
        dDate = DateSerial(DatePart(DateInterval.Year, Datum, FirstDayOfWeek.Monday), iMonat + 1, 1)
        iLastDayNextMonat = DatePart(DateInterval.Day, DateAdd(DateInterval.Day, -1, dDate), FirstDayOfWeek.Monday)

        getlastDayInMonth = iLastDayNextMonat

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDatumSelect Fields

frmDatumSelect overview

Fields

field cboAnzTageBis
field cboAnzTageVon
field cboDateRange
field cmdCancel
field cmdOK
field components
field dpBis
field dpVon
field iCnt
field lbl
field lblAuswahlBis
field lblAuswahlVon
field lblBisDatum
field lblVonDatum
field m_dDatumBis
field m_dDatumVon
field m_iAnzahlTageBis
field m_iAnzahlTageVon
field m_iDatumberich
field m_iLastDayAktuellerMonat
field m_sDislpayResult
field m_sNavigationResult
field m_sResult
field m_sdatenherkunft

See Also

frmDatumSelect Class


cboAnzTageBis Variable

Friend WithEvents cboAnzTageBis As C1.Win.C1List.C1Combo

Source code

[Visual Basic]
    Friend WithEvents cboAnzTageBis As C1.Win.C1List.C1Combo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


cboAnzTageVon Variable

Friend WithEvents cboAnzTageVon As C1.Win.C1List.C1Combo

Source code

[Visual Basic]
    Friend WithEvents cboAnzTageVon As C1.Win.C1List.C1Combo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


cboDateRange Variable

Friend WithEvents cboDateRange As C1.Win.C1List.C1Combo

Source code

[Visual Basic]
    Friend WithEvents cboDateRange As C1.Win.C1List.C1Combo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


cmdCancel Variable

Friend WithEvents cmdCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


cmdOK Variable

Friend WithEvents cmdOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


dpBis Variable

Friend WithEvents dpBis As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dpBis As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


dpVon Variable

Friend WithEvents dpVon As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dpVon As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


iCnt Variable

Dim iCnt As Integer

Source code

[Visual Basic]
    Dim iCnt As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


lbl Variable

Friend WithEvents lbl As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lbl As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


lblAuswahlBis Variable

Friend WithEvents lblAuswahlBis As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblAuswahlBis As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


lblAuswahlVon Variable

Friend WithEvents lblAuswahlVon As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblAuswahlVon As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


lblBisDatum Variable

Friend WithEvents lblBisDatum As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBisDatum As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


lblVonDatum Variable

Friend WithEvents lblVonDatum As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblVonDatum As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_dDatumBis Variable

Private m_dDatumBis As Date

Source code

[Visual Basic]
    Private m_dDatumBis As Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_dDatumVon Variable

Private m_dDatumVon As Date

Source code

[Visual Basic]
    Private m_dDatumVon As Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_iAnzahlTageBis Variable

Private m_iAnzahlTageBis As Integer

Source code

[Visual Basic]
    Private m_iAnzahlTageBis As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_iAnzahlTageVon Variable

Private m_iAnzahlTageVon As Integer

Source code

[Visual Basic]
    Private m_iAnzahlTageVon As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_iDatumberich Variable

Private m_iDatumberich As Enum_Datumbereich

Source code

[Visual Basic]
    Private m_iDatumberich As Enum_Datumbereich

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_iLastDayAktuellerMonat Variable

Private m_iLastDayAktuellerMonat As Integer

Source code

[Visual Basic]
    Private m_iLastDayAktuellerMonat As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_sDislpayResult Variable

Dim m_sDislpayResult As String

Source code

[Visual Basic]
    Dim m_sDislpayResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_sNavigationResult Variable

Dim m_sNavigationResult As String

Source code

[Visual Basic]
    Dim m_sNavigationResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_sResult Variable

Private m_sResult As String

Source code

[Visual Basic]
    Private m_sResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


m_sdatenherkunft Variable

Private m_sdatenherkunft As String

Source code

[Visual Basic]
    Private m_sdatenherkunft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDatumSelect


frmDefekteDokumente Class

For a list of all members of this type, see frmDefekteDokumente Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDefekteDokumente

Public Class frmDefekteDokumente
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDefekteDokumente Members


frmDefekteDokumente Members

frmDefekteDokumente overview

Constructors

constructor frmDefekteDokumente Constructor

Properties

property Start
property fnkt
property t

Methods

method Button1_Click
method ContextMenu1_Popup
method Dispose
method InitializeComponent
method Label4_Click
method Label5_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method ToolBar1_ButtonClick
method frmDefekteDokumente_Activated
method frmDefekteDokumente_Closing
method frmDefekteDokumente_Load
method refresh_list

Fields

field C1TrueDBGrid1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field ToolBar1
field ToolBarButton1
field components
field hiddenbuttonpressed
field m_fnkt
field m_start
field mt

See Also

frmDefekteDokumente Class


frmDefekteDokumente Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente Properties

frmDefekteDokumente overview

Properties

property Start
property fnkt
property t

See Also

frmDefekteDokumente Class


frmDefekteDokumente.Start Property

Property Start() As Boolean

Source code

[Visual Basic]
    Property Start() As Boolean
        Get
            Return False
        End Get
        Set(ByVal Value As Boolean)
            m_start = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.fnkt Property

Property fnkt() As Integer

Source code

[Visual Basic]
    Property fnkt() As Integer
        Get
            Return m_fnkt
        End Get
        Set(ByVal Value As Integer)
            m_fnkt = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.t Property

Property t() As DataTable

Source code

[Visual Basic]
    Property t() As DataTable
        Get
            Return mt
        End Get
        Set(ByVal Value As DataTable)
            mt = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente Methods

frmDefekteDokumente overview

Methods

method Button1_Click
method ContextMenu1_Popup
method Dispose
method InitializeComponent
method Label4_Click
method Label5_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method ToolBar1_ButtonClick
method frmDefekteDokumente_Activated
method frmDefekteDokumente_Closing
method frmDefekteDokumente_Load
method refresh_list

See Also

frmDefekteDokumente Class


frmDefekteDokumente.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.hiddenbuttonpressed = True
        Globals.Bearbeitung_Problemdokumente = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.C1TrueDBGrid1.Splits(0).Rows.Count = 0 Then
            Me.MenuItem1.Enabled = False
            Me.MenuItem2.Enabled = False
            Me.MenuItem3.Enabled = False
            Me.MenuItem4.Enabled = False
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
            Me.MenuItem7.Enabled = False
        Else
            Me.MenuItem1.Enabled = True
            Me.MenuItem3.Enabled = True
            Me.MenuItem4.Enabled = True
            Me.MenuItem5.Enabled = True
            Me.MenuItem6.Enabled = True
            Me.MenuItem7.Enabled = True
        End If
        If System.IO.File.Exists(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + Me.C1TrueDBGrid1.Columns("Dokumentname").Text) Then
            Me.MenuItem1.Enabled = True
        Else
            Me.MenuItem1.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDefekteDokumente))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(664, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Label1.Location = New System.Drawing.Point(0, 25)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(664, 47)
        Me.Label1.TabIndex = 1
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Versuchen, Dokument auf der Datenbank zu sichern"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Eintrag löschen"
        Me.MenuItem2.Visible = False
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "Dokument anzeigen"
        Me.MenuItem3.Visible = False
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "Dokument löschen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 4
        Me.MenuItem5.Text = "Partner-Dossier anzeigen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 5
        Me.MenuItem6.Text = "-"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 6
        Me.MenuItem7.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem7.Text = "Liste aktualisieren"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AllowUpdate = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
        Me.C1TrueDBGrid1.Cursor = System.Windows.Forms.Cursors.Default
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(0, 72)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = True
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(664, 245)
        Me.C1TrueDBGrid1.TabIndex = 26
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" DefRecSelWid" & _
        "th=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 660," & _
        " 241</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 660, " & _
        "241</ClientArea></Blob>"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(272, 23)
        Me.Label2.TabIndex = 27
        Me.Label2.Text = "Bearbeiten Sie die Dokumente mittels Kontextmenü."
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 32)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(488, 23)
        Me.Label3.TabIndex = 28
        Me.Label3.Text = "Die unten aufgeführten Dokumente sind nicht ordnungsgemäss auf der Datenbank gesp" & _
        "eichert."
        '
        'Label4
        '
        Me.Label4.BackColor = System.Drawing.SystemColors.ActiveCaption
        Me.Label4.Location = New System.Drawing.Point(328, 48)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(16, 8)
        Me.Label4.TabIndex = 30
        '
        'Label5
        '
        Me.Label5.BackColor = System.Drawing.SystemColors.ActiveCaption
        Me.Label5.Location = New System.Drawing.Point(0, 32)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(4, 32)
        Me.Label5.TabIndex = 31
        '
        'frmDefekteDokumente
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(664, 317)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label5, Me.Label4, Me.Label2, Me.Label3, Me.C1TrueDBGrid1, Me.Label1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDefekteDokumente"
        Me.Text = "Problemdokumente"
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.Label4_Click Method

Private Sub Label4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Label4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Label4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Label4.Click
        Me.hiddenbuttonpressed = True
        Globals.Bearbeitung_Problemdokumente = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.Label5_Click Method

Private Sub Label5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Label5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Label5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Label5.Click
        '***********************
        'Release 3.3
        '08.11.2004 / BUD
        '***********************
        If Globals.Applikationsdaten.Rows(0).Item("showlogin") = True Then
            Me.hiddenbuttonpressed = True
            Globals.Bearbeitung_Problemdokumente = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim d As New DocMgmt()
        If d.Save_To_DB(Me.C1TrueDBGrid1.Columns(0).Text, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + Me.C1TrueDBGrid1.Columns("Dokumentname").Text) = True Then
            Globals.PerfMon.Insert_DocRestore("Dokument auf DB gespeichert: " + Me.C1TrueDBGrid1.Columns(0).Text)
            DivFnkt.Status_Dokumentbearbeitung(2, Me.C1TrueDBGrid1.Columns(0).Text, 0, "")
        Else
            MsgBox("Das Dokumente konnte nicht in der Datenbank gespeichert werden.")
        End If
        refresh_list()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        DivFnkt.Status_Dokumentbearbeitung(2, Me.C1TrueDBGrid1.Columns(0).Text, 0, "")
        Globals.PerfMon.Insert_DocRestore("Dokumenteintrag ohne Speicherversuch gelöscht: " + Me.C1TrueDBGrid1.Columns(0).Text)
        refresh_list()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        DivFnkt.ShowDoc(Me.C1TrueDBGrid1.Columns(0).Text, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim f As New frmLoeschgrund()
        f.txtLoeschgrund.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_delete"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                Dim loeschgrund As String
                If f.txtLoeschgrund.Text.Length > 254 Then			 'begrentzt durch dbo.dokument.loeschgrund
                    loeschgrund = f.txtLoeschgrund.Text.Substring(0, 254)
                Else
                    loeschgrund = f.txtLoeschgrund.Text
                End If

                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.C1TrueDBGrid1.Columns("dokumentid").Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                'scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschgrund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, loeschgrund))
                scmCmdToExecute.Parameters.Add("@loeschgrund", loeschgrund)
                scmCmdToExecute.ExecuteNonQuery()
                DivFnkt.Status_Dokumentbearbeitung(2, Me.C1TrueDBGrid1.Columns(0).Text, 0, "")
            Catch ex As Exception
                Throw New Exception("Dokument löschen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)
                'gelöschtes item aus der liste entfernen, ohne refresh
                'RST 2006-07-18
                'old: refresh_list()
                Dim dataRow As DataRow
                dataRow = t.Rows.Item(C1TrueDBGrid1.Row)
                t.Rows.Remove(dataRow)
                C1TrueDBGrid1.Rebind()
                Dim i As Integer
                For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
                    Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
                Next
            End Try
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        'DivFnkt.Status_Dokumentbearbeitung(2, Me.C1TrueDBGrid1.Columns(0).Text, 0, "")
        Dim f As New frmSearchDoc()
        f.txtbcknr.Text = Me.C1TrueDBGrid1.Columns("Dokumentid").Text
        f.Visible = False
        'f.Show()
        f.Visible = False
        f.MdiParent = Me.MdiParent
        f.Show_Doc()
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Me.refresh_list()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        'SHU&BUD - Closebutton ist aktiv, sofern das Programm in der Testumgebung löuft
        If Globals.Applikationsdaten.Rows(0).Item("showlogin") = True Then
            Me.hiddenbuttonpressed = True
            Globals.Bearbeitung_Problemdokumente = False
        End If

        If Me.hiddenbuttonpressed = True Then
            Globals.Bearbeitung_Problemdokumente = False
        End If
        If Globals.Bearbeitung_Problemdokumente = True And Me.C1TrueDBGrid1.Splits(0).Rows.Count > 0 Then
            MyMsg.show_standardmessage(230, MsgBoxStyle.Critical)
            Exit Sub
        Else
            Globals.Bearbeitung_Problemdokumente = False
            Me.Hide()
            Me.fnkt = 1
        End If
        'Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.frmDefekteDokumente_Activated Method

Private Sub frmDefekteDokumente_Activated( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Activated

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDefekteDokumente_Activated(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Activated
        If Globals.Applikationsdaten.Rows(0).Item("showlogin") = False Then
            Me.Label5.BackColor = Me.BackColor
        End If
        refresh_list()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.frmDefekteDokumente_Closing Method

Private Sub frmDefekteDokumente_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDefekteDokumente_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Globals.Global_ForceExit = True Then Exit Sub
        If Me.hiddenbuttonpressed = True Then
            Globals.Bearbeitung_Problemdokumente = False
            Exit Sub
        End If
        If Start And Me.C1TrueDBGrid1.Splits(0).Rows.Count < 1 Then
            Start = False
            e.Cancel = True
            Me.fnkt = 1
            Me.Hide()
            Exit Sub
        End If
        If Globals.Bearbeitung_Problemdokumente = True And Me.C1TrueDBGrid1.Splits(0).Rows.Count > 0 Then
            MyMsg.show_standardmessage(230, MsgBoxStyle.Critical)
            e.Cancel = True
            Exit Sub
        Else
            Globals.Bearbeitung_Problemdokumente = False
        End If
        e.Cancel = True
        Me.fnkt = 1
        Me.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.frmDefekteDokumente_Load Method

Private Sub frmDefekteDokumente_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDefekteDokumente_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Label4.BackColor = Me.BackColor
        '08.11.2004 BUD
        If Globals.Applikationsdaten.Rows(0).Item("showlogin") = False Then
            Me.Label5.BackColor = Me.BackColor
        End If

        Dim i As Integer
        For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("dokumentname").Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente.refresh_list Method

Public Sub refresh_list()

Source code

[Visual Basic]
    Public Sub refresh_list()
        Dim d As New DocMgmt()
        t = d.check_doc(fnkt)
        Me.C1TrueDBGrid1.DataSource = t
        Me.C1TrueDBGrid1.DataMember = t.TableName
        d = Nothing
        Dim i As Integer
        For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("dokumentname").Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDefekteDokumente Fields

frmDefekteDokumente overview

Fields

field C1TrueDBGrid1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field ToolBar1
field ToolBarButton1
field components
field hiddenbuttonpressed
field m_fnkt
field m_start
field mt

See Also

frmDefekteDokumente Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


hiddenbuttonpressed Variable

Dim hiddenbuttonpressed As Boolean = False

Source code

[Visual Basic]
    Dim hiddenbuttonpressed As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


m_fnkt Variable

Dim m_fnkt As Integer

Source code

[Visual Basic]
    Dim m_fnkt As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


m_start Variable

Dim m_start As Boolean

Source code

[Visual Basic]
    Dim m_start As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


mt Variable

Dim mt As DataTable

Source code

[Visual Basic]
    Dim mt As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDefekteDokumente


frmDescription Class

For a list of all members of this type, see frmDescription Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDescription

Public Class frmDescription
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDescription Members


frmDescription Members

frmDescription overview

Constructors

constructor frmDescription Constructor

Properties

property FormTitel
property Meldung
property Titel

Methods

method Dispose
method InitializeComponent
method cmdOk_Click
method frmDescription_Load

Fields

field Panel1
field PictureBox2
field cmdOk
field components
field lblMessage
field lblTitel
field m_sFormTitel
field m_sMeldung
field m_sTitel

See Also

frmDescription Class


frmDescription Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription Properties

frmDescription overview

Properties

property FormTitel
property Meldung
property Titel

See Also

frmDescription Class


frmDescription.FormTitel Property

Public Property FormTitel()

Source code

[Visual Basic]
    Public Property FormTitel()
        Get
            Return m_sFormTitel
        End Get
        Set(ByVal Value)
            m_sFormTitel = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription.Meldung Property

Public Property Meldung()

Source code

[Visual Basic]
    Public Property Meldung()
        Get
            Return m_sMeldung
        End Get
        Set(ByVal Value)
            m_sMeldung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription.Titel Property

Public Property Titel()

Source code

[Visual Basic]
    Public Property Titel()
        Get
            Return m_sTitel
        End Get
        Set(ByVal Value)
            m_sTitel = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription Methods

frmDescription overview

Methods

method Dispose
method InitializeComponent
method cmdOk_Click
method frmDescription_Load

See Also

frmDescription Class


frmDescription.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDescription))
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.lblMessage = New System.Windows.Forms.Label()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.cmdOk = New System.Windows.Forms.Button()
        Me.lblTitel = New System.Windows.Forms.Label()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(8, 8)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(34, 33)
        Me.PictureBox2.TabIndex = 7
        Me.PictureBox2.TabStop = False
        '
        'lblMessage
        '
        Me.lblMessage.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.lblMessage.BackColor = System.Drawing.SystemColors.Control
        Me.lblMessage.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.lblMessage.Location = New System.Drawing.Point(48, 40)
        Me.lblMessage.Name = "lblMessage"
        Me.lblMessage.Size = New System.Drawing.Size(536, 240)
        Me.lblMessage.TabIndex = 8
        Me.lblMessage.Text = "Label1"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.cmdOk})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(0, 285)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(584, 32)
        Me.Panel1.TabIndex = 9
        '
        'cmdOk
        '
        Me.cmdOk.Dock = System.Windows.Forms.DockStyle.Right
        Me.cmdOk.Location = New System.Drawing.Point(520, 0)
        Me.cmdOk.Name = "cmdOk"
        Me.cmdOk.Size = New System.Drawing.Size(64, 32)
        Me.cmdOk.TabIndex = 0
        Me.cmdOk.Text = "Ok"
        '
        'lblTitel
        '
        Me.lblTitel.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.lblTitel.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.lblTitel.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblTitel.Location = New System.Drawing.Point(48, 8)
        Me.lblTitel.Name = "lblTitel"
        Me.lblTitel.Size = New System.Drawing.Size(536, 24)
        Me.lblTitel.TabIndex = 10
        Me.lblTitel.Text = "Label2"
        '
        'frmDescription
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(584, 317)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblTitel, Me.Panel1, Me.lblMessage, Me.PictureBox2})
        Me.KeyPreview = True
        Me.Name = "frmDescription"
        Me.Text = "frmDescription"
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription.cmdOk_Click Method

Private Sub cmdOk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cmdOk.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdOk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cmdOk.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription.frmDescription_Load Method

Private Sub frmDescription_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDescription_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.lblMessage.Text = m_sMeldung
        Me.lblTitel.Text = m_sTitel
        Me.Text = m_sFormTitel
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDescription Fields

frmDescription overview

Fields

field Panel1
field PictureBox2
field cmdOk
field components
field lblMessage
field lblTitel
field m_sFormTitel
field m_sMeldung
field m_sTitel

See Also

frmDescription Class


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


cmdOk Variable

Friend WithEvents cmdOk As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents cmdOk As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


lblMessage Variable

Friend WithEvents lblMessage As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblMessage As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


lblTitel Variable

Friend WithEvents lblTitel As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblTitel As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


m_sFormTitel Variable

Private m_sFormTitel As String

Source code

[Visual Basic]
    Private m_sFormTitel As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


m_sMeldung Variable

Private m_sMeldung As String

Source code

[Visual Basic]
    Private m_sMeldung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


m_sTitel Variable

Private m_sTitel As String

Source code

[Visual Basic]
    Private m_sTitel As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDescription


frmDieFrage Class

For a list of all members of this type, see frmDieFrage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDieFrage

Public Class frmDieFrage
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDieFrage Members


frmDieFrage Members

frmDieFrage overview

Constructors

constructor frmDieFrage Constructor

Properties

property BestehendeVersion
property Deletefrage
property DokumentStatus
property Inkl_Bedingte_Retournierung
property Loeschung
property NeueVersion

Methods

method BtnInfo_Click
method Button1_Click
method Dispose
method InitializeComponent
method btnBestehendeVersion_Click
method btnNeueVersion_Click
method btndel_Click
method frmDieFrage_Load

Fields

field BtnInfo
field Button1
field Label2
field PictureBox2
field PictureBox3
field btnBestehendeVersion
field btnNeueVersion
field btndel
field components
field m_bestehendeversion
field m_delete
field m_dokumentstatus
field m_inkl_bedingte_retournierung
field m_loeschung
field m_neueversion

See Also

frmDieFrage Class


frmDieFrage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage Properties

frmDieFrage overview

Properties

property BestehendeVersion
property Deletefrage
property DokumentStatus
property Inkl_Bedingte_Retournierung
property Loeschung
property NeueVersion

See Also

frmDieFrage Class


frmDieFrage.BestehendeVersion Property

Property BestehendeVersion() As Boolean

Source code

[Visual Basic]
    Property BestehendeVersion() As Boolean
        Get
            Return m_bestehendeversion
        End Get
        Set(ByVal Value As Boolean)
            m_bestehendeversion = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.Deletefrage Property

Property Deletefrage() As Boolean

Source code

[Visual Basic]
    Property Deletefrage() As Boolean
        Get
            Return m_delete
        End Get
        Set(ByVal Value As Boolean)
            m_delete = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.DokumentStatus Property

Property DokumentStatus() As Integer

Source code

[Visual Basic]
    Property DokumentStatus() As Integer
        Get
            Return m_dokumentstatus
        End Get
        Set(ByVal Value As Integer)
            m_dokumentstatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.Inkl_Bedingte_Retournierung Property

Property Inkl_Bedingte_Retournierung() As Boolean

Source code

[Visual Basic]
    Property Inkl_Bedingte_Retournierung() As Boolean
        Get
            Return m_inkl_bedingte_retournierung
        End Get
        Set(ByVal Value As Boolean)
            m_inkl_bedingte_retournierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.Loeschung Property

Property Loeschung() As Boolean

Source code

[Visual Basic]
    Property Loeschung() As Boolean
        Get
            Return m_loeschung
        End Get
        Set(ByVal Value As Boolean)
            m_loeschung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.NeueVersion Property

Property NeueVersion() As Boolean

Source code

[Visual Basic]
    Property NeueVersion() As Boolean
        Get
            Return m_neueversion
        End Get
        Set(ByVal Value As Boolean)
            m_neueversion = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage Methods

frmDieFrage overview

Methods

method BtnInfo_Click
method Button1_Click
method Dispose
method InitializeComponent
method btnBestehendeVersion_Click
method btnNeueVersion_Click
method btndel_Click
method frmDieFrage_Load

See Also

frmDieFrage Class


frmDieFrage.BtnInfo_Click Method

Private Sub BtnInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnInfo.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDieFrage))
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.btnNeueVersion = New System.Windows.Forms.Button()
        Me.btnBestehendeVersion = New System.Windows.Forms.Button()
        Me.btndel = New System.Windows.Forms.Button()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.BtnInfo = New System.Windows.Forms.Button()
        Me.PictureBox3 = New System.Windows.Forms.PictureBox()
        Me.SuspendLayout()
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(56, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(480, 192)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Durch EDOKA werden die notwendigen Statusmutation im COLD auf 'alt' oder 'ungülti" & _
        "g' durchgeführt."
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(184, 208)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(112, 24)
        Me.Button1.TabIndex = 7
        Me.Button1.Text = "&Abbruch"
        '
        'btnNeueVersion
        '
        Me.btnNeueVersion.Location = New System.Drawing.Point(424, 208)
        Me.btnNeueVersion.Name = "btnNeueVersion"
        Me.btnNeueVersion.Size = New System.Drawing.Size(112, 24)
        Me.btnNeueVersion.TabIndex = 9
        Me.btnNeueVersion.Text = "Ja"
        '
        'btnBestehendeVersion
        '
        Me.btnBestehendeVersion.Location = New System.Drawing.Point(304, 208)
        Me.btnBestehendeVersion.Name = "btnBestehendeVersion"
        Me.btnBestehendeVersion.Size = New System.Drawing.Size(112, 24)
        Me.btnBestehendeVersion.TabIndex = 10
        Me.btnBestehendeVersion.Text = "Nein"
        '
        'btndel
        '
        Me.btndel.Location = New System.Drawing.Point(424, 208)
        Me.btndel.Name = "btndel"
        Me.btndel.Size = New System.Drawing.Size(112, 24)
        Me.btndel.TabIndex = 11
        Me.btndel.Text = "Dokument löschen"
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(8, 8)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 14
        Me.PictureBox2.TabStop = False
        '
        'BtnInfo
        '
        Me.BtnInfo.Location = New System.Drawing.Point(424, 208)
        Me.BtnInfo.Name = "BtnInfo"
        Me.BtnInfo.Size = New System.Drawing.Size(112, 24)
        Me.BtnInfo.TabIndex = 15
        Me.BtnInfo.Text = "&OK"
        Me.BtnInfo.Visible = False
        '
        'PictureBox3
        '
        Me.PictureBox3.Image = CType(resources.GetObject("PictureBox3.Image"), System.Drawing.Bitmap)
        Me.PictureBox3.Location = New System.Drawing.Point(0, 8)
        Me.PictureBox3.Name = "PictureBox3"
        Me.PictureBox3.Size = New System.Drawing.Size(48, 56)
        Me.PictureBox3.TabIndex = 16
        Me.PictureBox3.TabStop = False
        Me.PictureBox3.Visible = False
        '
        'frmDieFrage
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(546, 240)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox3, Me.BtnInfo, Me.PictureBox2, Me.btndel, Me.btnBestehendeVersion, Me.btnNeueVersion, Me.Button1, Me.Label2})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDieFrage"
        Me.Text = "Dokumentbearbeitung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.btnBestehendeVersion_Click Method

Private Sub btnBestehendeVersion_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnBestehendeVersion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnBestehendeVersion_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnBestehendeVersion.Click
        Me.Loeschung = False
        Me.NeueVersion = False
        Me.BestehendeVersion = True
        If Me.DokumentStatus = 2 Then
            Me.DialogResult = DialogResult.Abort
        Else
            Me.DialogResult = DialogResult.OK
        End If
        Me.Close()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.btnNeueVersion_Click Method

Private Sub btnNeueVersion_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnNeueVersion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnNeueVersion_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnNeueVersion.Click
        Me.Loeschung = False
        Me.NeueVersion = True
        Me.BestehendeVersion = False
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.btndel_Click Method

Private Sub btndel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btndel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btndel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btndel.Click
        Me.Loeschung = True
        Me.NeueVersion = False
        Me.BestehendeVersion = False
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage.frmDieFrage_Load Method

Private Sub frmDieFrage_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDieFrage_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.PictureBox3.Visible = False
        If Me.Deletefrage Then
            If Me.DokumentStatus = 1 Then
                Me.btndel.Visible = False
                Me.btnBestehendeVersion.Visible = True
                Me.btnNeueVersion.Visible = True
                Me.Label2.Text = MyTxt.gettext(82)
                Globals.DokAnKundeVersant = True
            Else
                Me.btndel.Visible = True
                Me.btnNeueVersion.Visible = False
                Me.btnBestehendeVersion.Visible = False
                Globals.DokAnKundeVersantPruefen = True
                Me.Label2.Text = MyTxt.gettext(117)
            End If
            Exit Sub
        End If
        'Dokument Ausgangsarchiviert
        If Me.DokumentStatus = 1 Then
            Me.btndel.Visible = False
            Me.btnBestehendeVersion.Visible = True
            Me.btnNeueVersion.Visible = True
            ME.BtnInfo.Visible=False
            'Bedingt retournierbares Dokument bereits eingescannt
            If Me.Inkl_Bedingte_Retournierung = True Then
                Me.btnBestehendeVersion.Visible = False
                Me.btndel.Visible = False
                Me.btnNeueVersion.Visible = False
                Me.BtnInfo.Visible = True
                Me.Button1.Visible = False
                Me.PictureBox3.Visible = True
                Me.Label2.Text = MyTxt.gettext(120)
            Else
                Me.Label2.Text = MyTxt.gettext(115)
            End If
            Exit Sub
        End If

        If Me.DokumentStatus = 2 Then
            Me.btndel.Visible = False
            Me.btnBestehendeVersion.Visible = False
            Me.btnNeueVersion.Visible = True
            Me.BtnInfo.Visible = False
            If Me.Inkl_Bedingte_Retournierung = True Then
                Me.btnBestehendeVersion.Visible = False
                Me.btndel.Visible = False
                Me.btnNeueVersion.Visible = False
                Me.BtnInfo.Visible = True
                Me.Button1.Visible = False
                Me.PictureBox3.Visible = True
                Me.Label2.Text = MyTxt.gettext(120)
            Else
                Me.Label2.Text = MyTxt.gettext(116)
            End If
            Exit Sub
        End If

        If Me.DokumentStatus = 0 And Me.Inkl_Bedingte_Retournierung = True Then
            Me.btndel.Visible = False
            Me.btnBestehendeVersion.Visible = False
            Me.btnNeueVersion.Visible = False
            Me.Button1.Visible = False
            Me.BtnInfo.Visible = True
            Me.PictureBox3.Visible = True
            Me.Label2.Text = MyTxt.gettext(120)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDieFrage Fields

frmDieFrage overview

Fields

field BtnInfo
field Button1
field Label2
field PictureBox2
field PictureBox3
field btnBestehendeVersion
field btnNeueVersion
field btndel
field components
field m_bestehendeversion
field m_delete
field m_dokumentstatus
field m_inkl_bedingte_retournierung
field m_loeschung
field m_neueversion

See Also

frmDieFrage Class


BtnInfo Variable

Friend WithEvents BtnInfo As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnInfo As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


PictureBox3 Variable

Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


btnBestehendeVersion Variable

Friend WithEvents btnBestehendeVersion As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnBestehendeVersion As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


btnNeueVersion Variable

Friend WithEvents btnNeueVersion As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnNeueVersion As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


btndel Variable

Friend WithEvents btndel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btndel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_bestehendeversion Variable

Dim m_bestehendeversion As Boolean

Source code

[Visual Basic]
    Dim m_bestehendeversion As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_delete Variable

Dim m_delete As Boolean

Source code

[Visual Basic]
    Dim m_delete As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_dokumentstatus Variable

Dim m_dokumentstatus As Integer

Source code

[Visual Basic]
    Dim m_dokumentstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_inkl_bedingte_retournierung Variable

Dim m_inkl_bedingte_retournierung As Boolean = False

Source code

[Visual Basic]
    Dim m_inkl_bedingte_retournierung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_loeschung Variable

Dim m_loeschung As Integer

Source code

[Visual Basic]
    Dim m_loeschung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


m_neueversion Variable

Dim m_neueversion As Boolean

Source code

[Visual Basic]
    Dim m_neueversion As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDieFrage


frmDoaminStellvertretung Class

For a list of all members of this type, see frmDoaminStellvertretung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDoaminStellvertretung

Public Class frmDoaminStellvertretung
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDoaminStellvertretung Members


frmDoaminStellvertretung Members

frmDoaminStellvertretung overview

Constructors

constructor frmDoaminStellvertretung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method DateTimePicker1_TextChanged
method Dispose
method DomainList_BeforeColUpdate
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generic_Select
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_RowColChange
method frmDoaminStellvertretung_Closing
method frmDoaminStellvertretung_Load
method load_Mitarbeiter
method mnuLoeschen_Click

Fields

field ContextMenu1
field DataSet1
field DateTimePicker1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field drpMiatarbeiter
field m_bIgnoreChange
field mnuLoeschen

See Also

frmDoaminStellvertretung Class


frmDoaminStellvertretung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung Properties

frmDoaminStellvertretung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDoaminStellvertretung Class


frmDoaminStellvertretung Methods

frmDoaminStellvertretung overview

Methods

method DateTimePicker1_TextChanged
method Dispose
method DomainList_BeforeColUpdate
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generic_Select
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_RowColChange
method frmDoaminStellvertretung_Closing
method frmDoaminStellvertretung_Load
method load_Mitarbeiter
method mnuLoeschen_Click

See Also

frmDoaminStellvertretung Class


frmDoaminStellvertretung.DateTimePicker1_TextChanged Method

Private Sub DateTimePicker1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.TextChanged
        Try

            If m_bIgnoreChange Then
                Exit Sub
            End If
            ' get the column
            Dim col As C1.Win.C1TrueDBGrid.C1DataColumn = Me.DomainList.Splits(0).DisplayColumns(Me.DomainList.Col).DataColumn
            ' update the the grid

            Select Case col.DataField
                Case "datumvon"
                    Me.DomainList.Columns("datumvon").Text = DateTimePicker1.Text
                Case "datumbis"
                    Me.DomainList.Columns("datumbis").Text = DateTimePicker1.Text
            End Select
            'col.Text = Me.DateTimePicker1.Text
            Dim i As Integer
            For i = 0 To Me.DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
                If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
            Next

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.DomainList_BeforeColUpdate Method

Private Sub DomainList_BeforeColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles DomainList.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles DomainList.BeforeColUpdate
        Try
            Dim col As C1.Win.C1TrueDBGrid.C1DataColumn = Me.DomainList.Splits(0).DisplayColumns(Me.DomainList.Col).DataColumn
            Select Case col.DataField
                Case "datumvon"
                    If Not IsDate(Me.DomainList.Columns("datumvon").Text) Then
                        e.Cancel = True
                        Me.DomainList.Columns("datumvon").Value = DateTimePicker1.Value
                    End If
                Case "datumbis"
                    If Not IsDate(Me.DomainList.Columns("datumbis").Text) Then
                        e.Cancel = True
                        Me.DomainList.Columns("datumbis").Text = DateTimePicker1.Value
                    End If
            End Select

            If Me.drpMiatarbeiter.Bookmark = 0 Then
                'wenn der Mitarbeiter nicht im Drp vorhanden ist(Handeingabe) wird das Feld nicht abgefuellt
                e.Cancel = True
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"

            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDoaminStellvertretung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuLoeschen = New System.Windows.Forms.MenuItem()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = False
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.ColumnHeaders = False
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(272, 120)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.None
        Me.drpMiatarbeiter.RowDivider = GridLines1
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(72, 216)
        Me.drpMiatarbeiter.TabIndex = 8
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" C" & _
        "olumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" " & _
        "RecordSelectorWidth=""16"" RecordSelectors=""False"" VerticalScrollGroup=""1"" Horizon" & _
        "talScrollGroup=""1""><ClientRect>0, 0, 68, 212</ClientRect><CaptionStyle parent=""S" & _
        "tyle2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle p" & _
        "arent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" />" & _
        "<FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style1" & _
        "2"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""Hig" & _
        "hlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowS" & _
        "tyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" " & _
        "me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Nor" & _
        "mal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Sty" & _
        "le parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""" & _
        "Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Hea" & _
        "ding"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Norm" & _
        "al"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Norm" & _
        "al"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" " & _
        "me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Cap" & _
        "tion"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSp" & _
        "lits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea" & _
        ">0, 0, 68, 212</ClientArea></Blob>"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(408, 238)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(88, 20)
        Me.DateTimePicker1.TabIndex = 10
        Me.DateTimePicker1.Visible = False
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "stellvertretungen", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nreintrag", "nreintrag"), New System.Data.Common.DataColumnMapping("vertretener", "vertretener"), New System.Data.Common.DataColumnMapping("vertrater", "vertrater"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("datumvon", "datumvon"), New System.Data.Common.DataColumnMapping("datumbis", "datumbis"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("Typ", "Typ")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_stellvertretungenDomain_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Typ", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Typ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datumbis", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datumbis", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datumvon", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datumvon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrater", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrater", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertretener", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertretener", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_stellvertretungenDomain_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertretener", System.Data.SqlDbType.Int, 4, "vertretener"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrater", System.Data.SqlDbType.Int, 4, "vertrater"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.VarChar, 10, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datumvon", System.Data.SqlDbType.DateTime, 8, "datumvon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datumbis", System.Data.SqlDbType.DateTime, 8, "datumbis"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Typ", System.Data.SqlDbType.Int, 4, "Typ"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_stellvertretungenDomain_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_stellvertretungenDomain_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertretener", System.Data.SqlDbType.Int, 4, "vertretener"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrater", System.Data.SqlDbType.Int, 4, "vertrater"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.VarChar, 10, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datumvon", System.Data.SqlDbType.DateTime, 8, "datumvon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datumbis", System.Data.SqlDbType.DateTime, 8, "datumbis"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Typ", System.Data.SqlDbType.Int, 4, "Typ"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Typ", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Typ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datumbis", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datumbis", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datumvon", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datumvon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrater", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrater", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertretener", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertretener", System.Data.DataRowVersion.Original, Nothing))
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = -1
        Me.MenuItem4.Text = "Löschen"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuLoeschen})
        '
        'mnuLoeschen
        '
        Me.mnuLoeschen.Index = 0
        Me.mnuLoeschen.Text = "Löschen"
        '
        'frmDoaminStellvertretung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(904, 497)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.DateTimePicker1})
        Me.Name = "frmDoaminStellvertretung"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Dim col As Integer
        Save_Data = True
        Try
            col = Me.DomainList.Col
            Me.DomainList.Col = 1
            SqlDataAdapter1.Update(Me.DataSet1, Me.TableName)
            Me.DomainList.Col = col
        Catch exsql As SqlException
            MsgBox(exsql.Message)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Try
            Select Case ToolBar1.Buttons.IndexOf(e.Button)
                Case 0 'close button
                    Me.Close()
                Case 1 'Speichern
                    Save_Data()
            End Select
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.domainlist_RowColChange Method

Private Sub domainlist_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DomainList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DomainList.RowColChange
        Try
            Me.ActiveControl = Me.ToolBar1
            Me.ActiveControl = Me.DomainList
            Me.DomainList.UpdateData()
            Dim col As C1.Win.C1TrueDBGrid.C1DataColumn = Me.DomainList.Splits(0).DisplayColumns(Me.DomainList.Col).DataColumn
            Select Case col.DataField
                Case "datumvon", "datumbis"
                    ' get the area of the cell
                    Dim r As Rectangle = Me.DomainList.Splits(0).GetCellBounds(Me.DomainList.Row, Me.DomainList.Col)
                    ' change to screen coordiantes
                    r = Me.DomainList.RectangleToScreen(r)
                    ' map the screen coordinates to the forms client coordinates
                    Me.DateTimePicker1.Location = Me.RectangleToClient(r).Location
                    ' size it to fit inside the cell
                    Me.DateTimePicker1.Size = r.Size
                    ' default the datetimepicker to the date in the cell
                    m_bIgnoreChange = True
                    If col.CellValue(Me.DomainList.Row) Is System.DBNull.Value Then
                        Me.DateTimePicker1.Value = Now
                    Else
                        If Not IsDate(col.CellValue(Me.DomainList.Row)) Then
                            Me.DateTimePicker1.Value = Now
                        Else
                            Me.DateTimePicker1.Value = col.CellValue(Me.DomainList.Row)

                        End If

                    End If
                    m_bIgnoreChange = False
                    ' display it
                    Me.DateTimePicker1.Visible = True

                    Me.DateTimePicker1.Show()
                    Me.DateTimePicker1.BringToFront()
                    Me.ActiveControl = Me.DateTimePicker1
                Case Else
                    Me.DateTimePicker1.Visible = False
            End Select

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.frmDoaminStellvertretung_Closing Method

Private Sub frmDoaminStellvertretung_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDoaminStellvertretung_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        Dim col As Integer
        col = Me.DomainList.Col
        Me.DomainList.Col = 1
        Me.DomainList.Col = col

        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.frmDoaminStellvertretung_Load Method

Private Sub frmDoaminStellvertretung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDoaminStellvertretung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            Me.TableName = "StellvertretungDomain"
            Dim dbconn As New EDOKA.DB_Connection()
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlConnection1.Open()

            Me.SqlDataAdapter1.Fill(Me.DataSet1, Me.TableName)
            Me.DomainList.DataSource = Me.DataSet1
            Me.DomainList.DataMember = Me.TableName

            Me.DomainList.ContextMenu = Me.ContextMenu1
            Me.DomainList.AllowDelete = True
            '===============================================================================
            'Grid Formatieren
            '===============================================================================
            SpaltenTitel_Aktualisieren(Me.DataSet1)
            load_Mitarbeiter()
            DivFnkt.GrdAlign(Me.DomainList, "vertretener", C1.Win.C1TrueDBGrid.AlignHorzEnum.Near)
            DivFnkt.GrdAlign(Me.DomainList, "vertrater", C1.Win.C1TrueDBGrid.AlignHorzEnum.Near)
            DivFnkt.GrdAlign(Me.DomainList, "mutierer", C1.Win.C1TrueDBGrid.AlignHorzEnum.Near)
            DomainList.Splits(0).DisplayColumns("mutierer").Button = False

            DomainList.Splits(0).DisplayColumns("vertretener").FilterButton = True
            DomainList.Splits(0).DisplayColumns("vertrater").FilterButton = True
            DomainList.Splits(0).DisplayColumns("mutierer").FilterButton = True

            DomainList.Splits(0).DisplayColumns("vertretener").AutoComplete = True
            DomainList.Splits(0).DisplayColumns("vertrater").AutoComplete = True
            DomainList.Splits(0).DisplayColumns("mutierer").AutoComplete = True
            DomainList.Columns("datumvon").DefaultValue = Now()
            DomainList.Columns("datumbis").DefaultValue = Now()

            '  DomainList.Columns("datumvon").NumberFormat = "dd.MM.yyyy"
            '  DomainList.Columns("datumbis").NumberFormat = "dd.MM.yyyy"
            '  DomainList.Columns("datumvon").EditMask = "99.99.9999"
            '  DomainList.Columns("datumbis").EditMask = "99.99.9999"
            Me.WindowState = FormWindowState.Maximized
            DomainList.RowHeight = Me.DateTimePicker1.Height

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        Dim iCount As Integer
        Try
            conn.OpenConnection()
            Dim t As DataTable
            '===============================================================================
            'DRP Daten
            '===============================================================================
            t = Generic_Select(17)

            Me.drpMiatarbeiter.DataSource = t
            Me.drpMiatarbeiter.ListField = "FullName"
            Me.drpMiatarbeiter.DataField = "mitarbeiternr"
            Me.drpMiatarbeiter.ValueTranslate = True
            Me.DomainList.Columns("mutierer").DropDown = Me.drpMiatarbeiter

            Me.DomainList.Columns("vertretener").DropDown = Me.drpMiatarbeiter
            Me.DomainList.Columns("vertrater").DropDown = Me.drpMiatarbeiter

            '===============================================================================
            'DRP Formatierungen
            '===============================================================================
            For iCount = 0 To Me.DomainList.Splits(0).DisplayColumns.Count - 1
                If Me.DomainList.Splits(0).DisplayColumns(iCount).DataColumn.DataField = "vertretener" Then
                    Me.drpMiatarbeiter.Width = Me.DomainList.Splits(0).DisplayColumns(iCount).Width
                    Exit For
                End If
            Next

            drpMiatarbeiter.DisplayColumns(0).Visible = False
            drpMiatarbeiter.DisplayColumns(1).Width = Me.drpMiatarbeiter.Width

            conn.CloseConnection(True)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung.mnuLoeschen_Click Method

Private Sub mnuLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoeschen.Click
        Dim Arr() As Integer
        Dim row As Long
        If Me.DomainList.Splits(0).Rows.Count > 0 Then
            Dim iCount As Integer
            Try
                '****** Aufbereiten der markierten Zeilen
                ReDim Arr(Me.DomainList.SelectedRows.Count)
                For Each row In DomainList.SelectedRows
                    Arr(iCount) = row
                    iCount += 1
                Next
                '****** Löschen der markierten Zeilen.
                '****** Letzte Zeile wird zuerst gelöscht
                For iCount = UBound(Arr) - 1 To 0 Step -1
                    DomainList.Bookmark = Arr(iCount)
                    DomainList.Delete()
                Next

            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDoaminStellvertretung Fields

frmDoaminStellvertretung overview

Fields

field ContextMenu1
field DataSet1
field DateTimePicker1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field drpMiatarbeiter
field m_bIgnoreChange
field mnuLoeschen

See Also

frmDoaminStellvertretung Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


m_bIgnoreChange Variable

Dim m_bIgnoreChange As Boolean = False

Source code

[Visual Basic]
    Dim m_bIgnoreChange As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


mnuLoeschen Variable

Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDoaminStellvertretung


frmDokumentAufbereitung Class

For a list of all members of this type, see frmDokumentAufbereitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentAufbereitung

Public Class frmDokumentAufbereitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentAufbereitung Members


frmDokumentAufbereitung Members

frmDokumentAufbereitung overview

Constructors

constructor frmDokumentAufbereitung Constructor (Overloaded)

Methods

method Button1_Click
method Dispose
method Druckaufbereitung
method InitializeComponent
method StartDruckaufbereituung
method btnWeiter_Click
method btnclose_Click
method get_partner
method get_parts
method get_pdf
method kill_acroreader
method print_pdf
method set_druckjobstatus
method set_druckjobstatus_part
method set_progress
method tf_Load
method tuesdrucken
method update_aushaendigungsquittung_status

Fields

field DruckThread
field Label1
field Label2
field M_Druchjobid
field ProgressBar1
field ProgressThread
field alnr
field btnWeiter
field btnabbruch
field btnclose
field components
field dokumentfilename
field lblpartner
field part
field printthread

See Also

frmDokumentAufbereitung Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal druckjobid As Integer, ByVal part As Integer)

See Also

frmDokumentAufbereitung | EDOKAApp


frmDokumentAufbereitung Methods

frmDokumentAufbereitung overview

Methods

method Button1_Click
method Dispose
method Druckaufbereitung
method InitializeComponent
method StartDruckaufbereituung
method btnWeiter_Click
method btnclose_Click
method get_partner
method get_parts
method get_pdf
method kill_acroreader
method print_pdf
method set_druckjobstatus
method set_druckjobstatus_part
method set_progress
method tf_Load
method tuesdrucken
method update_aushaendigungsquittung_status

See Also

frmDokumentAufbereitung Class


frmDokumentAufbereitung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnabbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnabbruch.Click
        Try
            ProgressThread.Abort()
        Catch
        End Try
        Try
            DruckThread.Abort()
        Catch
        End Try
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.Druckaufbereitung Method

Private Sub Druckaufbereitung()

Source code

[Visual Basic]
    Private Sub Druckaufbereitung()
        Try
            Dim remoteObj As EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07
            Dim Obj As Object
            Obj = Activator.GetObject( _
                        GetType(EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07), _
                        System.Configuration.ConfigurationSettings.AppSettings("RemoteObjUrl"))

            remoteObj = CType(Obj, EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07)

            remoteObj.PrintJobF(Me.M_Druchjobid, Me.part)
            Me.btnWeiter.Enabled = True
            Me.ProgressBar1.Value = 100
            Me.Refresh()
            Application.DoEvents()
            Me.Label1.Text = "Die EDOKA-Druckaufbereitung ist abgeschlossen."
            Me.Text = "Fertig - " + Me.Text
            Me.BringToFront()
        Catch ex As Exception
            MsgBox("Aufgrund des folgenden Fehlers konnte der Druckjob nicht gestartet werden:" + vbCrLf + vbCrLf + ex.Message, MsgBoxStyle.Critical)
        Finally
            Me.Cursor = Cursors.Default
            ProgressThread.Abort()
            DruckThread.Abort()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentAufbereitung))
        Me.btnabbruch = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ProgressBar1 = New System.Windows.Forms.ProgressBar()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.lblpartner = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.btnclose = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'btnabbruch
        '
        Me.btnabbruch.Location = New System.Drawing.Point(8, 104)
        Me.btnabbruch.Name = "btnabbruch"
        Me.btnabbruch.Size = New System.Drawing.Size(88, 32)
        Me.btnabbruch.TabIndex = 0
        Me.btnabbruch.Text = "Abbruch"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 32)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(352, 32)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Die auszudruckenden Dokumente werden zusammengestellt und aufbereitet."
        '
        'ProgressBar1
        '
        Me.ProgressBar1.Location = New System.Drawing.Point(8, 64)
        Me.ProgressBar1.Name = "ProgressBar1"
        Me.ProgressBar1.Size = New System.Drawing.Size(352, 23)
        Me.ProgressBar1.TabIndex = 2
        '
        'btnWeiter
        '
        Me.btnWeiter.Enabled = False
        Me.btnWeiter.Location = New System.Drawing.Point(232, 104)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(128, 32)
        Me.btnWeiter.TabIndex = 3
        Me.btnWeiter.Text = "Druckdialog anzeigen"
        '
        'lblpartner
        '
        Me.lblpartner.Location = New System.Drawing.Point(56, 8)
        Me.lblpartner.Name = "lblpartner"
        Me.lblpartner.Size = New System.Drawing.Size(336, 23)
        Me.lblpartner.TabIndex = 5
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 23)
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Partner:"
        '
        'btnclose
        '
        Me.btnclose.Location = New System.Drawing.Point(8, 104)
        Me.btnclose.Name = "btnclose"
        Me.btnclose.Size = New System.Drawing.Size(88, 32)
        Me.btnclose.TabIndex = 6
        Me.btnclose.Text = "Schliessen"
        Me.btnclose.Visible = False
        '
        'frmDokumentAufbereitung
        '
        Me.AutoScale = False
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(370, 141)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnclose, Me.lblpartner, Me.Label2, Me.btnWeiter, Me.ProgressBar1, Me.Label1, Me.btnabbruch})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MaximumSize = New System.Drawing.Size(366, 166)
        Me.MinimizeBox = False
        Me.Name = "frmDokumentAufbereitung"
        Me.Text = "Druckaufbereitung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.StartDruckaufbereituung Method

Public Sub StartDruckaufbereituung()

Source code

[Visual Basic]
    Public Sub StartDruckaufbereituung()
        ProgressThread.Start()
        DruckThread.Start()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        Try
            kill_acroreader()
        Catch
        End Try
        tuesdrucken()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.btnclose_Click Method

Private Sub btnclose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnclose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnclose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnclose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.get_partner Method

Private Function get_partner( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Function get_partner(ByVal alnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_partner"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@alnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bkpar00", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Me.lblpartner.Text = scmCmdToExecute.Parameters("@bkpar00").Value
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.get_parts Method

Public Function get_parts( _
   ByVal alnr As Integer _
) As Integer

Parameters

alnr
Required.

Source code

[Visual Basic]
    Public Function get_parts(ByVal alnr As Integer) As Integer
        Dim connect As New SqlConnection()
        connect.ConnectionString = Globals.sConnectionString

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_druckjobparts_count"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = connect
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@parts", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@parts").Value
        Catch ex As Exception
            Return -1
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            connect.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.get_pdf Method

Private Function get_pdf( _
   ByVal alnr As Integer, _
   ByVal part As Integer _
) As Boolean

Parameters

alnr
Required.
part
Required.

Source code

[Visual Basic]
    Private Function get_pdf(ByVal alnr As Integer, ByVal part As Integer) As Boolean
        If part = 0 Then
            'PDF-Dokument aus der Datenbank auslesen
            Me.Cursor = Cursors.WaitCursor
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * from edex_bl_druckjob where (status=2 or status=3) and auslieferungnr=" + LTrim(Str(alnr)), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                'Connectionstring zur Datenbank
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)

                Dim MyData() As Byte
                MyData = myRow.Item("pdfdokument_aufbereitet")
                dokumentfilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + LTrim(Str(myRow.Item(0))) + "_" + Format(Now, "yyyyMMddHHmmss" + ".PDF")
                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(dokumentfilename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
                Return True
            Catch ex As Exception
                Return False
            Finally
                CB = Nothing
                ds = Nothing
                da = Nothing
                connection.Close()
                connection = Nothing
                Me.Cursor = Cursors.Default
            End Try
        Else
            'PDF-Dokument aus der Datenbank auslesen
            Me.Cursor = Cursors.WaitCursor
            Dim connection As New SqlConnection()
            Dim s As String = "SELECT dbo.EDEX_BL_Druckjob_Part.* " & _
                              "FROM   dbo.EDEX_BL_Druckjob INNER JOIN " & _
                              "dbo.EDEX_BL_Druckjob_Part ON dbo.EDEX_BL_Druckjob.druckjobnr = dbo.EDEX_BL_Druckjob_Part.druckjobnr " & _
                              "where (dbo.edex_bl_druckjob_part.status=2 or dbo.edex_bl_druckjob_part.status=3) and dbo.edex_bl_druckjob.auslieferungnr=" + LTrim(Str(alnr)) & " " & _
                              "and dbo.edex_bl_druckjob_part.partno=" + LTrim(part)
            Dim da As New SqlDataAdapter(s, connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                'Connectionstring zur Datenbank
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)

                Dim MyData() As Byte
                MyData = myRow.Item("pdfdokument_aufbereitet")
                dokumentfilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + LTrim(Str(myRow.Item(0))) + "_" + Format(Now, "yyyyMMddHHmmss" + ".PDF")
                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(dokumentfilename, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
                Return True
            Catch ex As Exception
                Return False
            Finally
                CB = Nothing
                ds = Nothing
                da = Nothing
                connection.Close()
                connection = Nothing
                Me.Cursor = Cursors.Default
            End Try

        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.kill_acroreader Method

Private Sub kill_acroreader()

Source code

[Visual Basic]
    Private Sub kill_acroreader()
        Try
            Dim myprocess() As Process
            Dim mp As Process
            myprocess = Process.GetProcessesByName("acrord32")
            For Each mp In myprocess
                mp.Kill()
            Next
            System.Threading.Thread.CurrentThread.Sleep(100)
        Catch ex As Exception
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.print_pdf Method

Private Sub print_pdf( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Sub print_pdf(ByVal alnr As Integer)
        Try
            Dim f As New frmPDFPrinter(True)
            f.addressBar.Text = dokumentfilename
            f.MdiParent = Me.MdiParent
            f.alnr = alnr
            f.Part = Me.part
            f.Show()
            Application.DoEvents()
            f.PrintPDF()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.set_druckjobstatus Method

Private Function set_druckjobstatus( _
   ByVal alnr As Integer, _
   ByVal status As Integer _
)

Parameters

alnr
Required.
status
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus(ByVal alnr As Integer, ByVal status As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_set_druckjobstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.set_druckjobstatus_part Method

Private Function set_druckjobstatus_part( _
   ByVal alnr As Integer, _
   ByVal part As Integer, _
   ByVal status As Integer _
) As Integer

Parameters

alnr
Required.
part
Required.
status
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus_part(ByVal alnr As Integer, ByVal part As Integer, ByVal status As Integer) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_set_druckjobstatus_part"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@part", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, part))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@return", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@return").Value
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.set_progress Method

Private Sub set_progress()

Source code

[Visual Basic]
    Private Sub set_progress()
        Try
            Do While 1 = 1
                Me.ProgressBar1.Value = Me.ProgressBar1.Value + 1
                If Me.ProgressBar1.Value = 100 Then Me.ProgressBar1.Value = 0
                ProgressThread.Sleep(100)
            Loop
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.tf_Load Method

Private Sub tf_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tf_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.get_partner(alnr)
        Me.Text = "Dokumentaufbereitung: " + Me.lblpartner.Text
        Me.ProgressBar1.Value = 0
        Me.btnWeiter.Text = "Drucken"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.tuesdrucken Method

Private Sub tuesdrucken()

Source code

[Visual Basic]
    Private Sub tuesdrucken()
        Dim i As Integer
        Me.Cursor = Cursors.WaitCursor
        If get_pdf(alnr, Me.part) Then
            Me.btnclose.Visible = True
            Me.btnabbruch.Visible = False
            Me.btnWeiter.Text = "Ausdruck wiederholen"
            print_pdf(alnr)
            If get_parts(alnr) = 0 Then
                Me.update_aushaendigungsquittung_status(alnr, 3)
            End If
            If part = 0 Then
                set_druckjobstatus(alnr, 3)
            Else
                Me.set_druckjobstatus_part(alnr, part, 3)
            End If
        Else
            MsgBox("Das temporäre PDF-Dokumente konnte nicht erstellt werden.", MsgBoxStyle.Information)
        End If
        Me.Cursor = Cursors.Default
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung.update_aushaendigungsquittung_status Method

Private Function update_aushaendigungsquittung_status( _
   ByVal auslieferungnr As Integer, _
   ByVal status As Integer _
)

Parameters

auslieferungnr
Required.
status
Required.

Source code

[Visual Basic]
    Private Function update_aushaendigungsquittung_status(ByVal auslieferungnr As Integer, ByVal status As Integer)

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_aushaendigungsquittung_update_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@auslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, auslieferungnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung Fields

frmDokumentAufbereitung overview

Fields

field DruckThread
field Label1
field Label2
field M_Druchjobid
field ProgressBar1
field ProgressThread
field alnr
field btnWeiter
field btnabbruch
field btnclose
field components
field dokumentfilename
field lblpartner
field part
field printthread

See Also

frmDokumentAufbereitung Class


DruckThread Variable

Dim DruckThread As New Thread( _
   AddressOf Druckaufbereitung _
)

Source code

[Visual Basic]
    Dim DruckThread As New Thread(AddressOf Druckaufbereitung)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


M_Druchjobid Variable

Dim M_Druchjobid As Integer

Source code

[Visual Basic]
    Dim M_Druchjobid As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


ProgressBar1 Variable

Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Source code

[Visual Basic]
    Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


ProgressThread Variable

Dim ProgressThread As New Threading.Thread( _
   AddressOf set_progress _
)

Source code

[Visual Basic]
    Dim ProgressThread As New Threading.Thread(AddressOf set_progress)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


alnr Variable

Dim alnr As Integer

Source code

[Visual Basic]
    Dim alnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


btnabbruch Variable

Friend WithEvents btnabbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnabbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


btnclose Variable

Friend WithEvents btnclose As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnclose As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


dokumentfilename Variable

Dim dokumentfilename As String

Source code

[Visual Basic]
    Dim dokumentfilename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


lblpartner Variable

Friend WithEvents lblpartner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpartner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


part Variable

Dim part As Integer

Source code

[Visual Basic]
    Dim part As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


printthread Variable

Private printthread As Thread

Source code

[Visual Basic]
    Private printthread As Thread

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentInBearbeitung Class

For a list of all members of this type, see frmDokumentInBearbeitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentInBearbeitung

Public Class frmDokumentInBearbeitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentInBearbeitung Members


frmDokumentInBearbeitung Members

frmDokumentInBearbeitung overview

Constructors

constructor frmDokumentInBearbeitung Constructor

Methods

method Button1_Click
method ContextMenu1_Popup
method Dispose
method DokList_Click
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method TextBox1_MouseDown
method TextBox2_MouseDown
method ToolBar1_ButtonClick
method frmDokumentInBearbeitung_Load

Fields

field ContextMenu1
field DokList
field ImageList1
field ImageList2
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TextBox1
field TextBox2
field ToolBar1
field ToolBarButton1
field components
field da

See Also

frmDokumentInBearbeitung Class


frmDokumentInBearbeitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung Methods

frmDokumentInBearbeitung overview

Methods

method Button1_Click
method ContextMenu1_Popup
method Dispose
method DokList_Click
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method TextBox1_MouseDown
method TextBox2_MouseDown
method ToolBar1_ButtonClick
method frmDokumentInBearbeitung_Load

See Also

frmDokumentInBearbeitung Class


frmDokumentInBearbeitung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.DokList_Click Method

Private Sub DokList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_doksinbearbeitung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        If typ = 2 Then conn.OpenConnection()
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Text))
            End Select
            If typ = 2 Then
                scmCmdToExecute.ExecuteNonQuery()
                conn.CloseConnection(True)
            End If
            If typ = 1 Then
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentInBearbeitung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem4, Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Text = "&Dokument anzeigen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "-"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Shortcut = System.Windows.Forms.Shortcut.Del
        Me.MenuItem1.Text = "&Eintrag löschen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 3
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem2.Text = "&Aktualisieren"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokinbearbeitung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumentid", "dokumentid"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("datum", "datum"), New System.Data.Common.DataColumnMapping("erstellung", "erstellung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentid", System.Data.SqlDbType.VarChar, 22, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentid", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum", System.Data.SqlDbType.DateTime, 8, "datum"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellung", System.Data.SqlDbType.Bit, 1, "erstellung"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_docsinbearbeitung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentid", System.Data.SqlDbType.VarChar, 22, "dokumentid"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum", System.Data.SqlDbType.DateTime, 8, "datum"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellung", System.Data.SqlDbType.Bit, 1, "erstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentid", System.Data.SqlDbType.VarChar, 22, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(776, 25)
        Me.ToolBar1.TabIndex = 13
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdate = False
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(0, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = False
        Me.DokList.Size = New System.Drawing.Size(776, 391)
        Me.DokList.TabIndex = 14
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, " & _
        "1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True"" Marquee" & _
        "Style=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalSc" & _
        "rollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 772, 387</ClientRect><" & _
        "BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorSty" & _
        "le parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><F" & _
        "ilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=" & _
        """Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headi" & _
        "ng"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inacti" & _
        "veStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9""" & _
        " /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle pa" & _
        "rent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tr" & _
        "ueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style p" & _
        "arent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style paren" & _
        "t=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent" & _
        "=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""No" & _
        "rmal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""N" & _
        "ormal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent" & _
        "=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><v" & _
        "ertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultR" & _
        "ecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 772, 387</ClientArea></Blob>" & _
        ""
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(8, 424)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(760, 56)
        Me.TextBox1.TabIndex = 15
        Me.TextBox1.Text = "Dieses Dokument ist nicht korrekt im EDOKA gespeichert. Bitte gehen Sie wie folgt" & _
        " vor:"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(8, 488)
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(760, 56)
        Me.TextBox2.TabIndex = 16
        Me.TextBox2.Text = "TextBox2"
        '
        'frmDokumentInBearbeitung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(776, 558)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox2, Me.TextBox1, Me.DokList, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentInBearbeitung"
        Me.Text = "Dokumente in Bearbeitung"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim i As Integer
        If MyMsg.Show_MessageYesNo(33) = MsgBoxResult.Yes Then
            Generic_Select(2)
            Me.DokList.Refresh()
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, da, "dokumenteinbearbeitung")
            For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
            Next
            Me.MenuItem2_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim i As Integer
        Me.DokList.DataSource = Nothing
        da = Generic_Select(1)
        Me.DokList.DataSource = da
        Me.DokList.Refresh()
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, da, "dokumenteinbearbeitung")
        For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmSearchDoc()
        f.txtbcknr.Text = Me.DokList.Columns(0).Text
        f.Visible = False
        f.Show()
        f.MdiParent = Me.MdiParent
        f.Show_Doc()
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.TextBox1_MouseDown Method

Private Sub TextBox1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TextBox1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TextBox1.MouseDown
        Me.TextBox1.SelectAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.TextBox2_MouseDown Method

Private Sub TextBox2_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TextBox2.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox2_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TextBox2.MouseDown
        Me.TextBox2.SelectAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung.frmDokumentInBearbeitung_Load Method

Private Sub frmDokumentInBearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentInBearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        da = Generic_Select(1)
        Me.DokList.DataSource = da
        Me.DokList.DataMember = da.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, da, "dokumenteinbearbeitung")
        For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
        Next

        Me.TextBox1.Text = "Dieses Dokument ist nicht korrekt im EDOKA gespeichert. Bitte gehen Sie wie folgt vor:"
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + "- Lassen Sie sich das Dokument zur Überprüfung anzeigen."
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + "- Falls es sich nicht anzeigen lässt: Löschen Sie es!"
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + "- Erstellen Sie das Dokument mit demselben Datum ggf nochmals neu."
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + "- Der Versand erübrigt sich, da das ursprüngliche Dok. versendet sein dürfte."
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + vbCrLf + "Mit freundlichen Grüssen"
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + "EDOKA-Systemadministrator"

        Me.TextBox2.Text = "Das Partnereröffnungsformular ist nicht korrekt im EDOKA gespeichert. Bitte gehen Sie wie folgt vor:"
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "- Lassen Sie sich das Dokument zur Überprüfung anzeigen."
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "- Falls es sich nicht anzeigen lässt: Löschen Sie es!"
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "- Erstellen Sie das Partnereröffnungsformular mit demselben Datum nochmals neu."
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "- Drucken Sie das neue Partnereröffnungsformular aus."
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "- Da sich der Barcode des alten Partnereröffnungsformulars im Scanning nicht verarbeiten lässt, vernichten Sie das sich in Bearbeitung befindliche Dokument und ersetzen es durch das neue."

        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + vbCrLf + "Mit freundlichen Grüssen"
        Me.TextBox2.Text = Me.TextBox2.Text + vbCrLf + "EDOKA-Systemadministrator"

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInBearbeitung Fields

frmDokumentInBearbeitung overview

Fields

field ContextMenu1
field DokList
field ImageList1
field ImageList2
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TextBox1
field TextBox2
field ToolBar1
field ToolBarButton1
field components
field da

See Also

frmDokumentInBearbeitung Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


da Variable

Dim da As New DataTable()

Source code

[Visual Basic]
    Dim da As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInBearbeitung


frmDokumentInfoEdit Class

For a list of all members of this type, see frmDokumentInfoEdit Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentInfoEdit

Public Class frmDokumentInfoEdit
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentInfoEdit Members


frmDokumentInfoEdit Members

frmDokumentInfoEdit overview

Constructors

constructor frmDokumentInfoEdit Constructor

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentid
property Dokumentinfobearbeiten
property Dokumenttypnr
property EditDokumentid
property NurDokinfo
property Partnernr
property Profile
property Profilnr

Methods

method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Button4_Click
method Button6_Click
method Button7_Click
method Button8_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Insert_ColdUpdate
method Insert_ColdUpdate_Datum
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method Update_Bclabel
method Update_DokumentColdIndexwert
method Update_Partnernr
method Update_Status
method Update_datum
method Update_gf
method Update_gu
method Update_vvnr
method ZuordnungList_Click
method bereiche_sperren
method btnCancel_Click
method btnLoeschen_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_data
method get_dokumentdaten
method get_dokumente
method get_indextyp
method get_partnerzusteller
method load_Mitarbeiter
method load_indexmutation
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method set_abgeschlossen_menu
method settooltip
method txtZustelladresse_Leave

Fields

field Aktueller_Dokumentverantwortlicher
field BtnHelp
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateErinnerung
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label23
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPage5
field TabPage6
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field ToolTip1
field ZuordnungList
field btnCancel
field btnLoeschen
field btnPartnerInhaber
field btnWeiter
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field components
field cvertraulich
field daten
field datum
field dokumente
field drpMiatarbeiter
field funktionsliste
field gf
field gu
field i
field ii
field m_NurDokInfo
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentid
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field vvnr
field w
field zu_retournieren

See Also

frmDokumentInfoEdit Class


frmDokumentInfoEdit Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit Properties

frmDokumentInfoEdit overview

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentid
property Dokumentinfobearbeiten
property Dokumenttypnr
property EditDokumentid
property NurDokinfo
property Partnernr
property Profile
property Profilnr

See Also

frmDokumentInfoEdit Class


frmDokumentInfoEdit.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.CreateDocument Property

Property CreateDocument() As Boolean

Source code

[Visual Basic]
    Property CreateDocument() As Boolean
        Get
            Return m_createdocument
        End Get
        Set(ByVal Value As Boolean)
            m_createdocument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokument_Ist_Abgeschlossen Property

Property Dokument_Ist_Abgeschlossen() As Boolean

Source code

[Visual Basic]
    Property Dokument_Ist_Abgeschlossen() As Boolean
        Get
            Return m_dokument_ist_abgeschlossen
        End Get
        Set(ByVal Value As Boolean)
            m_dokument_ist_abgeschlossen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentid Property

Property Dokumentid() As String

Source code

[Visual Basic]
    Property Dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentinfobearbeiten Property

Property Dokumentinfobearbeiten() As Boolean

Source code

[Visual Basic]
    Property Dokumentinfobearbeiten() As Boolean
        Get
            Return m_dokumentinfobearbeiten
        End Get
        Set(ByVal Value As Boolean)
            m_dokumentinfobearbeiten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.EditDokumentid Property

Property EditDokumentid() As String

Source code

[Visual Basic]
    Property EditDokumentid() As String
        Get
            Return DokumentID
        End Get
        Set(ByVal Value As String)
            DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.NurDokinfo Property

Property NurDokinfo() As Boolean

Source code

[Visual Basic]
    Property NurDokinfo() As Boolean
        Get
            Return m_NurDokInfo
        End Get
        Set(ByVal Value As Boolean)
            m_NurDokInfo = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_Partnernr
        End Get
        Set(ByVal Value As String)
            m_Partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit Methods

frmDokumentInfoEdit overview

Methods

method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Button4_Click
method Button6_Click
method Button7_Click
method Button8_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Insert_ColdUpdate
method Insert_ColdUpdate_Datum
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method Update_Bclabel
method Update_DokumentColdIndexwert
method Update_Partnernr
method Update_Status
method Update_datum
method Update_gf
method Update_gu
method Update_vvnr
method ZuordnungList_Click
method bereiche_sperren
method btnCancel_Click
method btnLoeschen_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_data
method get_dokumentdaten
method get_dokumente
method get_indextyp
method get_partnerzusteller
method load_Mitarbeiter
method load_indexmutation
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method set_abgeschlossen_menu
method settooltip
method txtZustelladresse_Leave

See Also

frmDokumentInfoEdit Class


frmDokumentInfoEdit.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentinformationenbearbeiten")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            If Me.txtPartnerInhaberNr.Text > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New FrmPartnersuche()
        f.ShowDialog()

        If f.PartnerNr <> 0 Then
            Me.txtZustelladresse.Text = f.zustelladresse
            Me.txtAnredeZusteller.Text = f.Anrede
            Me.txtZustelladresse.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dokumentzuordnungen_Sichern()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        MenuItem2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.DokWertList.Columns("feldwert").Value = f.PartnerNr
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button6_Click Method

Private Sub Button6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button6.Click
        If Me.Partnernr <> Me.TextBox1.Text Then
            Update_Partnernr(Me.Dokumentid, Me.TextBox1.Text)
        End If
        If Me.vvnr <> Me.TextBox4.Text Then
            Update_vvnr(Dokumentid, Me.TextBox4.Text)
        End If
        If Me.gu <> Me.TextBox3.Text Then
            Update_gu(Dokumentid, Me.TextBox3.Text)
        End If
        If Me.gf <> Me.TextBox2.Text Then
            Update_gf(Me.Dokumentid, Me.TextBox2.Text)
        End If
        If Me.datum <> Me.DateTimePicker4.Value Then
            Update_datum(Dokumentid, Me.datum, Me.DateTimePicker4.Value.ToShortDateString)
        End If
        MyMsg.show_standardmessage(95, MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button7_Click Method

Private Sub Button7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button7.Click
        Dim f As New frmValueSelector()
        f.Text = "Auswahl VV-Nummer"
        f.Datenherkunft = "&VVdesPartners&"
        f.Datenherkunft = "&VVunformatiert&"
        f.Partnernr = Me.TextBox1.Text
        f.LoadData()
        If f.Datenvorhanden = True Then
            f.ShowDialog()
            If f.DialogResult = DialogResult.OK Then Me.TextBox4.Text = f.SelWert
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Button8_Click Method

Private Sub Button8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button8.Click
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = True
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Cursor = Cursors.WaitCursor
            Me.TextBox1.Text = f.PartnerNr
            Me.Cursor = Cursors.Default
            MyMsg.show_standardmessage(94, MsgBoxStyle.Information)
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.COLD_Index_Sichern Method

Public Function COLD_Index_Sichern( _
   ByVal indextyp As Integer _
) As DataTable

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Function COLD_Index_Sichern(ByVal indextyp As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Check_Dokumentersetzen Method

Private Function Check_Dokumentersetzen( _
   ByVal dokumenttypnr As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumenttypnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Check_Dokumentersetzen(ByVal dokumenttypnr As Integer, ByVal dokumentid As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentbearbeitung_chcek_dokumentersetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@errormessage", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            s = scmCmdToExecute.Parameters.Item("@errormessage").Value
            If s <> "" Then
                MyMsg.show_standardmessage(Val(s), MsgBoxStyle.Critical)
                Return False
            End If
            Return True
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Check_Dokumentfunktionen Method

Private Function Check_Dokumentfunktionen() As Boolean

Source code

[Visual Basic]
    Private Function Check_Dokumentfunktionen() As Boolean
        Dim i As Integer
        Dim zz As Integer
        Dim bearbeiten As Boolean
        Dim abschliessen As Boolean
        bearbeiten = False
        abschliessen = False
        Check_Dokumentfunktionen = True
        If Me.DokumentFunktionenList.Visible = False Then Exit Function
        zz = 0
        For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
            If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                If Me.DokumentFunktionen.Rows(i).Item("bearbeiten") = True Then bearbeiten = True
                If Me.DokumentFunktionen.Rows(i).Item("abschliessen") = True Then abschliessen = True
                zz = zz + 1
            End If
        Next

        If zz = 0 Then
            Check_Dokumentfunktionen = True
            Exit Function
        End If
        If bearbeiten = False Or abschliessen = False Then
            If bearbeiten = False Then
                MyMsg.show_standardmessage(34, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
            If abschliessen = False Then
                MyMsg.show_standardmessage(35, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Cold_Index_Bearbeiten Method

Public Sub Cold_Index_Bearbeiten( _
   ByVal indextyp As Integer _
)

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten(ByVal indextyp As Integer)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp)
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.Notizen.Rows.Count = 0 Then
            Me.ContextMenu1.MenuItems(1).Enabled = False
            Me.ContextMenu1.MenuItems(2).Enabled = False
        Else
            If Microsoft.VisualBasic.Left(Notizlist.Columns("betreff").Text, 3) = "***" Then
                Me.ContextMenu1.MenuItems(1).Enabled = False     'Notiz bearbeiten
                Me.ContextMenu1.MenuItems(2).Enabled = False     'Notiz &löschen
            Else
                'Bei Systemnotitzen werden die Menue Ausgeblendet
                Me.ContextMenu1.MenuItems(1).Enabled = True     'Notiz bearbeiten
                Me.ContextMenu1.MenuItems(2).Enabled = True     'Notiz &löschen
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        If Me.DokWertList.Columns("datenherkunft").Value = "" Then
            Me.MnuValueSelect.Enabled = False
        Else
            Me.MnuValueSelect.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        If Me.ZuordnungList.Splits(0).Rows.Count = 0 Then
            Me.MnuDokzuordnungDelete.Enabled = False
            Me.MnuShowDoc.Enabled = False
        Else
            Me.MnuDokzuordnungDelete.Enabled = True
            Me.MnuShowDoc.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ContextMenu4_Popup Method

Private Sub ContextMenu4_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu4.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu4_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu4.Popup
        Try
            If Me.InfoMeldungList.Columns("typ").Value = 1 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
            If Me.InfoMeldungList.Splits(0).Rows.Count = 0 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        Try
            If Me.ColdList.Splits(0).Rows.Count = 0 Then
                Me.MenuItem6.Enabled = False
            Else
                Me.MenuItem6.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        If Me.On_Load Then Exit Sub
        Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DateTimePicker2_KeyDown Method

Private Sub DateTimePicker2_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs)
        If e.KeyCode = Keys.Delete Then
            Me.DateTimePicker2.ResetText()
            Me.DateTimePicker2.Value = System.DBNull.Value
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Datumselect_ValueChanged Method

Private Sub Datumselect_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Datumselect_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Set_Feldwert()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DokWertList_AfterColEdit Method

Private Sub DokWertList_AfterColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DokWertList.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_AfterColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DokWertList.AfterColEdit
        Me.DokWertList.Update()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DokWertList_Click Method

Private Sub DokWertList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokWertList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokWertList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokument_Bearbeiten Method

Private Sub Dokument_Bearbeiten( _
   ByVal neu As Boolean _
)

Parameters

neu
Required.

Source code

[Visual Basic]
    Private Sub Dokument_Bearbeiten(ByVal neu As Boolean)
        If Me.Dokument_Ist_Abgeschlossen Or Me.NurDokinfo = True Then
            Try
                Dim xdoc As New edokadb.clsDokument()
                xdoc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
                xdoc.cpMainConnectionProvider = conn
                xdoc.SelectOne()
                xdoc.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
                xdoc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                If Me.DateTimePicker2.Value Is System.DBNull.Value Then
                    xdoc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
                Else
                    xdoc.daTermin = New SqlDateTime(CType(Me.DateTimePicker2.Value, DateTime))
                End If
                If Me.DateErinnerung.Value Is System.DBNull.Value Then
                    xdoc.daErinnerungam = New SqlDateTime(CType("01.01.1900", DateTime))
                Else
                    xdoc.daErinnerungam = New SqlDateTime(CType(Me.DateErinnerung.Value, DateTime))
                End If

                conn.OpenConnection()
                xdoc.Update()
                conn.CloseConnection(True)
                xdoc.Dispose()
                Notizen_Sichern()
                Dokumentzuordnungen_Sichern()
                Dokumentinfomeldungen_Sichern()
                DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
            Catch ex As Exception
                MsgBox(ex.Message)
            Finally
                Me.Close()
            End Try
            Exit Sub
        End If
        w.txtPartner = Me.txtPartnerInhaber.Text
        w.txtDokumenttyp = Me.txtBezeichnung.Text
        w.ProgressBar.Info.Text = "Dokument erstellen"
        w.ProgressBar.Bar1.Value = 10

        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim doc As New edokadb.clsDokument()
        Dim doctyp As New edokadb.clsDokumenttyp()
        Dim docvor As New edokadb.clsOffice_vorlage()

        'Dokumenttyp laden
        doctyp.cpMainConnectionProvider = conn
        doctyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doctyp.SelectOne()

        'OfficeVorlage laden
        docvor.cpMainConnectionProvider = conn
        docvor.iOffice_vorlagenr = New SqlInt32(CType(doctyp.iOffice_vorlagenr.Value, Int32))
        docvor.SelectOne()

        'Dokument erstellen
        doc.cpMainConnectionProvider = conn
        If Me.CreateDocument Then
            doc.sDokumentid = New SqlString(CType(NewDokumentID, String))
        Else
            doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
            doc.SelectOne()
        End If
        doc.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doc.iNrpar00 = New SqlInt32(CType(Me.txtPartnerInhaberNr.Text, Int32))
        doc.bAktiv = New SqlBoolean(True)
        doc.bAmsdokument = New SqlBoolean(CType(False, Boolean))
        doc.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
        doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
        doc.daArchivierungsdatum = New SqlDateTime(CType(Me.DateTimePicker3.Value, DateTime))

        If Me.DateTimePicker2.Value Is System.DBNull.Value Then
            doc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
        Else
            doc.daTermin = New SqlDateTime(CType(Me.DateTimePicker2.Value, DateTime))
        End If

        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
        'Hutter - anpassungen
        If Me.mcbstatus.Text = "Bereit für Ausgangsarchivierung" Then
            doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
        End If
        doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
        doc.bGesperrt = New SqlBoolean(CType(Me.cGesperrt.Checked, Boolean))
        If Me.cGesperrt.Checked Then
            doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
        End If
        doc.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
        doc.bZu_retournieren = New SqlBoolean(CType(doctyp.bZu_retournieren.Value, Boolean))
        doc.iColdstatus = New SqlInt32(CType(0, Int32))
        doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
        If neu = True Then
            doc.iErsteller = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iErstellerteam = New SqlInt32(CType(0, Int32))
            doc.daErstelltam = New SqlDateTime(CType(Now, DateTime))
            doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iMutiererteam = New SqlInt32(CType(0, Int32))
            doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
            If Globals.bckdokument Then
                doc.iBck = New SqlInt32(CType(1, Int32))
            Else
                doc.iBck = New SqlInt32(CType(1, Int32))
            End If
            doc.iAufbewahrung_elektronisch = New SqlInt32(CType(doctyp.iAufbewahrungsfrist_elektronisch.Value, Int32))
            doc.iAufbewahrung_phaysisch = New SqlInt32(CType(doctyp.iTage_mutation.Value, Int32))
            doc.iBearbeitung_nach_abschluss = New SqlInt32(CType(doctyp.iAnzahl_tage.Value, Int32))
            doc.iBearbeitungszeit_in_minuten = New SqlInt32(CType(doctyp.iDbearbeitungszeit.Value, Int32))
            doc.iMonierung_in_tagen = New SqlInt32(CType(doctyp.iAnzahl_tage.Value, Int32))
        Else
            doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
        End If

        doc.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
        doc.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
        doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
        doc.bVertraulich = New SqlBoolean(CType(Me.cvertraulich.Checked, Boolean))
        doc.sZustelladresse = New SqlString(CType(Me.txtZustelladresse.Text, String))
        doc.sAnredezustelladresse = New SqlString(CType(Me.txtAnredeZusteller.Text, String))

        If Me.rbZustaendigKube.Checked Then
            doc.iZustaendiger = New SqlInt32(CType(Me.mcbkube.SelectedValue, Int32))
        Else
            doc.iZustaendiger = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
        End If
        doc.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
        doc.bZustaendig_kube = New SqlBoolean(CType(Me.rbZustaendigKube.Checked, Boolean))
        If Me.cGesperrt.Checked Then
            doc.iGesperrt_durch = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
        Else
            doc.iGesperrt_durch = New SqlInt32(CType(0, Int32))
        End If
        doc.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
        doc.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
        doc.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        doc.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        doc.sColddokumentid = New SqlString(CType("", String))

        doc.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))

        If Not Me.CreateDocument Then
            doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
        End If

        doc.daErstellungsdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
        '        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))

        If docvor.iAnwendungnr.Value = 1 Then
            doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".doc", String))
        Else
            doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".xls", String))
        End If

        If Me.CreateDocument Then doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
        If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
            Dim tx As DataTable
            tx = Generic_Select(13)
            If tx.Rows(0).Item(0) = 1 Then
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
            Else
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            End If
            tx.Dispose()
        End If

        Dim s As String

        s = DivFnkt.Get_Filename(doc.sDokumentname.Value, Me.txtPartnerInhaberNr.Text)
        conn.OpenConnection()
        If Me.CreateDocument Then
            Dim t As DataTable
            t = Generic_Select(14)
            doc.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
            doc.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
            doc.Insert()
            t.Dispose()
            Dim statush As New Statushandling()
            statush.Status_Erstellen(doc.sDokumentid.Value, False)
            statush.Dispose()
            doc.iStatusnr = New SqlInt32(CType(get_current_Status(doc.sDokumentid.Value), Int32))
            doc.Update()
        Else
            doc.Update()
        End If
        conn.CloseConnection(True)

        Dokumentid = doc.sDokumentid.Value
        If Globals.bckdokument = True Then
            Cold_Index_Bearbeiten(2)
        Else
            Cold_Index_Bearbeiten(1)
            If Me.zu_retournieren Then
                Cold_Index_Bearbeiten(2)
            End If
        End If
        Dokumentid = doc.sDokumentid.Value
        Dokumentwerte_Sichern()
        Notizen_Sichern()
        Dokumentzuordnungen_Sichern()
        Dokumentersetzen_Sichern()
        Dokumentinfomeldungen_Sichern()
        Dokumentfunktionen_sichern()
        Status_History(doc.iStatusnr.Value)
        If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
            w.ProgressBar.Show()
            w.ProgressBar.Info.Text = "Dokumentwerte zusammenstellen"
            w.ProgressBar.Bar1.Value = 10
        End If
        Dim xdata As DataTable
        xdata = Dokumentwerte(doc.sDokumentid.Value)
        Dokumentid = doc.sDokumentid.Value

        'Dokument erstellen bzw. öffnen
        w.DokumentID = doc.sDokumentid.Value
        w.DokumentName = doc.sDokumentname.Value
        If Me.CreateDocument Then
            w.CreateDoc = True
            If Me.BarcodeID = "" Then w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s)
        Else
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.CreateDoc = False
                Dim docrestore As New DocMgmt()
                docrestore.Get_From_DB(Dokumentid, s)
                w.Open_Document(s, xdata, doc.iDokumenttypnr.Value)
            End If
        End If
        Me.Hide()

        If Globals.Dokumentcoldindex_Changed Then
            w.dokumentidalt = Globals.Dokumentidalt
            w.save_dokumentcoldindex = Globals.general_ds.Tables(0)
            w.Dokumentcoldindex_Changed = Globals.Dokumentcoldindex_Changed
            w.dokumentid_changed = Globals.dokumentid_changed
            w.dokumentcoldindex_status = Globals.dokumentcoldindex_status
            w.Ersetzte_Dokumente_Reaktivieren = Globals.Ersetzte_Dokumente_Reaktivieren
        End If

        'Anzeigen der Dokumentwerte, sofern die Checkbox markiert war
        If Me.cdokumentwerteanzeigen.Checked Then
            Dim f As New frmDokumentwerte()
            f.WordData = xdata
            f.isOk = True
            Me.Cursor = System.Windows.Forms.Cursors.Default
            f.ShowDialog()
            If f.isOk = 0 Then
                f.Dispose()
                w.CloseDoc()
                If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
            Else
                If f.isOk = 1 Then
                    f.Dispose()
                    w.Dokument_Vervollstaendigen(xdata)
                    Words.Add(w, w.DokumentName)
                Else
                    If f.isOk = 2 Then
                        f.Dispose()
                        If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
                        Me.CreateDocument = False
                        Me.btnWeiter.Enabled = True
                        Me.Show()
                    End If
                End If
            End If
        Else
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.Dokument_Vervollstaendigen(xdata)
                Words.Add(w, w.DokumentName)
            Else
                If Not Me.Dokumentinfobearbeiten = True Then
                    Update_Bclabel(1)
                End If
                DivFnkt.Status_Dokumentbearbeitung(2, Me.Dokumentid, False, "")
            End If
        End If
        xdata.Dispose()
        doc.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentersetzen_Laden Method

Private Function Dokumentersetzen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentersetzen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentersetzen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentersetzen_Sichern Method

Public Sub Dokumentersetzen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentersetzen_Sichern()
        For i = 0 To Me.Dokumentersetzen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentersetzen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("coldstatus")))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Ersetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentfunktionen_Aktivieren Method

Private Sub Dokumentfunktionen_Aktivieren()

Source code

[Visual Basic]
    Private Sub Dokumentfunktionen_Aktivieren()
        Dim t As DataTable
        t = Generic_Select(5)
        If t.Rows.Count > 0 Then
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlDataAdapter3.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            '            Me.Funktionsliste.DataSource = Me.DataSet3
            '           Me.Funktionsliste.DataMember = Me.DataSet3.Tables(0).TableName

            t.Clear()
            Me.DokumentFunktionen = Generic_Select(6)
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.DataSet4.Tables.Add(Me.DokumentFunktionen)
            Me.DokumentFunktionenList.DataSource = Me.DataSet4
            Me.DokumentFunktionenList.DataMember = Me.DataSet4.Tables(0).TableName
            Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
            Me.DokumentFunktionenList.FilterBar = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Me.DokumentFunktionen, "berechtigungseinschraenkung")

        Else
            Me.pnlBerechtigungen.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentfunktionen_sichern Method

Public Sub Dokumentfunktionen_sichern()

Source code

[Visual Basic]
    Public Sub Dokumentfunktionen_sichern()
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentfunktionen_Sichern"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@funktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("anzeigen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("bearbeiten")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("loeschen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("abschliessen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("aktiv")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentinfomeldungen_Sichern Method

Public Sub Dokumentinfomeldungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentinfomeldungen_Sichern()
        For i = 0 To Me.DokumentInfoMeldungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("typ")))

                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DokumentwertListe_laden Method

Private Function DokumentwertListe_laden() As DataTable

Source code

[Visual Basic]
    Private Function DokumentwertListe_laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentwerte Method

Private Function Dokumentwerte( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentwerte(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentwerte_Sichern Method

Public Sub Dokumentwerte_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern()
        Dim xdata As DataTable
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Dokumentzuordnungen_Sichern Method

Public Sub Dokumentzuordnungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentzuordnungen_Sichern()
        For i = 0 To Me.Dokumentzuorndungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("NrEintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("DOKUMENTID2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("AKTIV")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.DokwertList_RowColChange Method

Private Sub DokwertList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokWertList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokwertList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokWertList.RowColChange
        Try
            Me.DokWertList.Columns("feldwert").EditMask = Me.DokWertList.Columns("eingabeformat").Value
            Me.DokWertList.Columns("feldwert").EditMaskUpdate = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()
        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String
        s = ""
        Try
            For I = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(I).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(I).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            If Me.cvertraulich.Checked = True Then
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 1, s)
            Else
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 0, s)
            End If
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Formular_Laden_Create_Document Method

Private Sub Formular_Laden_Create_Document()

Source code

[Visual Basic]
    Private Sub Formular_Laden_Create_Document()
        NewDokumentID = DivFnkt.Generate_Key()
        Load_Defaults()
        w.save_historystatus = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Formular_laden_Edit_Document Method

Private Sub Formular_laden_Edit_Document()

Source code

[Visual Basic]
    Private Sub Formular_laden_Edit_Document()
        Dim doc As New edokadb.clsDokument()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        doc.SelectOne()
        doc.cpMainConnectionProvider = conn
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        NewDokumentID = Me.EditDokumentid
        Me.Partnernr = doc.iNrpar00.Value
        doc.SelectOne()
        w.Save_Dokument = doc.SelectOne
        Me.Dokumenttypnr = doc.iDokumenttypnr.Value
        Dokumentid = doc.sDokumentid.Value
        Me.Aktueller_Dokumentverantwortlicher = doc.iVerantwortlich.Value
        Load_Defaults()

        'Parnter laden
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = doc.iNrpar00
        p.SelectOne()
        Me.txtPartnerInhaber.Text = Str(p.iNRPAR00.Value) + " " + p.sBKPAR00.Value
        Me.txtPartnerInhaberNr.Text = p.iNRPAR00.Value
        Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(p.iNRPAR00.Value)

        p.Dispose()
        conn.CloseConnection(True)
        Try
            Me.txtBemerkung.Text = doc.sBemerkung.Value
        Catch
        End Try

        Try
            If doc.daTermin.Value = "01.01.1900" Then
                Me.DateTimePicker2.ResetText()
                Me.DateTimePicker2.Value = System.DBNull.Value
            Else
                Me.DateTimePicker2.Value = doc.daTermin.Value
            End If
        Catch
            Me.DateTimePicker2.Value = System.DBNull.Value
        End Try

        Try
            If doc.daErinnerungam.Value = "01.01.1900" Then
                Me.DateErinnerung.ResetText()
                Me.DateErinnerung.Value = System.DBNull.Value
            Else
                Me.DateErinnerung.Value = doc.daErinnerungam.Value
            End If
        Catch
            Me.DateErinnerung.Value = System.DBNull.Value
        End Try

        If Me.Dokument_Ist_Abgeschlossen Or Me.NurDokinfo Then Exit Sub

        ii = doc.iPostzustellung.Value
        Me.mcbpostzustellung.SelectedValue = ii
        If doc.bZustaendig_kube.Value = True Then
            ii = doc.iZustaendiger.Value
            Me.mcbkube.SelectedValue = ii
        Else
            ii = doc.iZustaendiger.Value
            Me.mcbzust.SelectedValue = ii
        End If
        ii = doc.iVerantwortlich.Value
        Me.mcbverantwortlich.SelectedValue = ii
        Me.saveverantwortlicher = ii

        Me.savestatus = doc.iStatusnr.Value

        ii = doc.iUnterschriftlinks.Value
        Me.mcbunterschriftlinks.SelectedValue = ii
        ii = doc.iUnterschriftrechts.Value
        Me.mcbunterschriftrechts.SelectedValue = ii
        Me.cGesperrt.Checked = doc.bGesperrt.Value = True
        Me.txtBemerkung.Text = doc.sBemerkung.Value
        Me.txtBezeichnung.Text = doc.sBezeichnung.Value
        Me.rbZustaendigKube.Checked = doc.bZustaendig_kube.Value = True
        Me.cvertraulich.Checked = doc.bVertraulich.Value = True
        Me.txtZustelladresse.Text = doc.sZustelladresse.Value
        Me.txtAnredeZusteller.Text = doc.sAnredezustelladresse.Value
        Me.RBZustaendigZustaendiger.Checked = doc.bZustaendig_kube.Value = False
        Me.teamzustaendig = doc.iZustaendiger.Value
        Me.refresh_team()
        Try
            Me.mcbteam.SelectedValue = doc.iMutierertieam.Value
        Catch
            Me.mcbteam.SelectedIndex = 0
        End Try
        Try
            Me.DateTimePicker1.Value = doc.daErstellungsdatum.Value
        Catch
            Me.DateTimePicker1.Value = Now
        End Try

        Try
            Me.DateTimePicker3.Value = doc.daArchivierungsdatum.Value
        Catch
            Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
        End Try

        doc.Dispose()

        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()

        Me.ColdList.DataSource = Me.Dokumentersetzen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")

        Me.Notizen = Notizen_Laden()

        w.Save_Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        w.Save_Dokumentwerte = Generic_Select(10)
        Me.DataSet1.Clear()
        Me.DataSet1.Tables.Clear()
        Me.DataSet1.Tables.Add(DokumentwertListe_laden)
        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 50
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160
        conn.CloseConnection(True)

        w.Save_ColdIndex = Generic_Select(9)
        Me.TabControl2.Enabled = True

        Dim tmp As DataTable
        tmp = Generic_Select(12)
        w.save_historystatus = tmp.Rows(0).Item(0)
        tmp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_DokWertList"
            Case 2
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Notizen"
            Case 5
                scmCmdToExecute.CommandText = "sp_funktion_zuweisung_gestattet"
            Case 6
                scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
            Case 7
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
            Case 8
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_kube"
            Case 9
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 10
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 11
                scmCmdToExecute.CommandText = "sp_dokument_als_bcdokument"
            Case 12
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 13
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case 14
                scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case 15
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 16
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"

            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@regel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokWertList.Columns("datenherkunft").Value))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    If Me.DokumentID = Nothing Then Me.DokumentID = ""
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    If Me.CreateDocument = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    If Globals.bckdokument = False Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    End If
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentID))
                Case 7
                    If Me.teamzustaendig = Globals.MitarbeiterNr Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.teamzustaendig))
                    End If
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                Case 9
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 16
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs)
        Try
            If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
                e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentInfoEdit))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet4 = New System.Data.DataSet()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.DokWertList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MnuValueSelect = New System.Windows.Forms.MenuItem()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RBZustaendigZustaendiger = New System.Windows.Forms.RadioButton()
        Me.rbZustaendigKube = New System.Windows.Forms.RadioButton()
        Me.cbzust = New System.Windows.Forms.ComboBox()
        Me.cbKube = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.cbPostzustellung = New System.Windows.Forms.ComboBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.TabPage5 = New System.Windows.Forms.TabPage()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.GroupBox11 = New System.Windows.Forms.GroupBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtAnredeZusteller = New System.Windows.Forms.TextBox()
        Me.txtZustelladresse = New System.Windows.Forms.TextBox()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.mnuInfoEmpfaengerAdd = New System.Windows.Forms.MenuItem()
        Me.mnuInfoEmpfaengerDelete = New System.Windows.Forms.MenuItem()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokZuordnungAdd = New System.Windows.Forms.MenuItem()
        Me.MnuDokzuordnungDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.txtPartnerInhaberNr = New System.Windows.Forms.TextBox()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cdokumentwerteanzeigen = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.cbsave = New System.Windows.Forms.ComboBox()
        Me.cbmoeglicheStati = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtstatus = New System.Windows.Forms.Label()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.GroupBox14 = New System.Windows.Forms.GroupBox()
        Me.DateErinnerung = New C1.Win.C1Input.C1DateEdit()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.DateTimePicker2 = New C1.Win.C1Input.C1DateEdit()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.ZuordnungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox13 = New System.Windows.Forms.GroupBox()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.TabPage6 = New System.Windows.Forms.TabPage()
        Me.GroupBox15 = New System.Windows.Forms.GroupBox()
        Me.btnLoeschen = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.pnlBerechtigungen = New System.Windows.Forms.GroupBox()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.cvertraulich = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.cGesperrt = New System.Windows.Forms.CheckBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.GroupBox12.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.TabPage4.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox11.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.GroupBox14.SuspendLayout()
        CType(Me.DateErinnerung, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox8.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox7.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox6.SuspendLayout()
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox13.SuspendLayout()
        Me.TabPage6.SuspendLayout()
        Me.GroupBox15.SuspendLayout()
        Me.pnlBerechtigungen.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox9.SuspendLayout()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(696, 496)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(104, 23)
        Me.btnWeiter.TabIndex = 7
        Me.btnWeiter.Text = "&Speichern"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(40, 496)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(104, 23)
        Me.btnCancel.TabIndex = 8
        Me.btnCancel.Text = "&Abbruch"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "SP_Dokumentbearbeitung_Dokumentwerte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("Feldwert", "Feldwert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[SP_Dokumentbearbeitung_Dokumentwerte]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentid", System.Data.SqlDbType.VarChar, 20))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@CreateNew", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Postzustellung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nreintrag", "nreintrag"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_postzustellung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_postzustellung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_postzustellung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_postzustellung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_funktionsgruppe_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_funktionsgruppe_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_funktionsgruppe_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_funktionsgruppe_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage3, Me.TabPage4, Me.TabPage5, Me.TabPage1})
        Me.TabControl2.Enabled = False
        Me.TabControl2.Location = New System.Drawing.Point(8, 552)
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(800, 232)
        Me.TabControl2.TabIndex = 27
        Me.TabControl2.Visible = False
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox12, Me.GroupBox10, Me.GroupBox3, Me.GroupBox1, Me.GroupBox2})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(792, 206)
        Me.TabPage3.TabIndex = 0
        Me.TabPage3.Text = "Dokumentinhalt"
        '
        'GroupBox12
        '
        Me.GroupBox12.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox12.Location = New System.Drawing.Point(8, 304)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(368, 16)
        Me.GroupBox12.TabIndex = 38
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Team"
        Me.GroupBox12.Visible = False
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(128, 16)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(232, 21)
        Me.cbteam.TabIndex = 14
        Me.cbteam.Visible = False
        '
        'GroupBox10
        '
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokWertList})
        Me.GroupBox10.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(400, 312)
        Me.GroupBox10.TabIndex = 37
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Dokumentspezifisch"
        '
        'DokWertList
        '
        Me.DokWertList.AllowFilter = False
        Me.DokWertList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokWertList.AllowSort = False
        Me.DokWertList.AlternatingRows = True
        Me.DokWertList.CaptionHeight = 17
        Me.DokWertList.CollapseColor = System.Drawing.Color.Black
        Me.DokWertList.ContextMenu = Me.ContextMenu2
        Me.DokWertList.DataChanged = False
        Me.DokWertList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokWertList.ExpandColor = System.Drawing.Color.Black
        Me.DokWertList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokWertList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokWertList.Location = New System.Drawing.Point(8, 16)
        Me.DokWertList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokWertList.Name = "DokWertList"
        Me.DokWertList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokWertList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokWertList.PreviewInfo.ZoomFactor = 75
        Me.DokWertList.PrintInfo.ShowOptionsDialog = False
        Me.DokWertList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokWertList.RowDivider = GridLines1
        Me.DokWertList.RowHeight = 15
        Me.DokWertList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokWertList.ScrollTips = False
        Me.DokWertList.Size = New System.Drawing.Size(384, 288)
        Me.DokWertList.TabIndex = 14
        Me.DokWertList.Text = "C1TrueDBGrid1"
        Me.DokWertList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 380, 284</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defau" & _
        "ltRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 380, 284</ClientArea></Bl" & _
        "ob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuValueSelect})
        '
        'MnuValueSelect
        '
        Me.MnuValueSelect.Index = 0
        Me.MnuValueSelect.Text = "&Wert auswählen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbUnterschriftrechts, Me.cbUnterschriftlinks, Me.Label8, Me.Label7})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 296)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(368, 24)
        Me.GroupBox3.TabIndex = 36
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Unterschrift"
        Me.GroupBox3.Visible = False
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(128, 43)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftrechts.TabIndex = 13
        Me.cbUnterschriftrechts.Visible = False
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(128, 19)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftlinks.TabIndex = 12
        Me.cbUnterschriftlinks.Visible = False
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 48)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Unterschrift rechts"
        Me.Label8.Visible = False
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 24)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 13
        Me.Label7.Text = "Unterschrift links"
        Me.Label7.Visible = False
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBZustaendigZustaendiger, Me.rbZustaendigKube, Me.cbzust, Me.cbKube})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 296)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 24)
        Me.GroupBox1.TabIndex = 35
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zuständigkeit"
        Me.GroupBox1.Visible = False
        '
        'RBZustaendigZustaendiger
        '
        Me.RBZustaendigZustaendiger.Location = New System.Drawing.Point(14, 42)
        Me.RBZustaendigZustaendiger.Name = "RBZustaendigZustaendiger"
        Me.RBZustaendigZustaendiger.Size = New System.Drawing.Size(98, 24)
        Me.RBZustaendigZustaendiger.TabIndex = 10
        Me.RBZustaendigZustaendiger.Text = "Zuständiger"
        Me.RBZustaendigZustaendiger.Visible = False
        '
        'rbZustaendigKube
        '
        Me.rbZustaendigKube.Location = New System.Drawing.Point(14, 18)
        Me.rbZustaendigKube.Name = "rbZustaendigKube"
        Me.rbZustaendigKube.Size = New System.Drawing.Size(106, 24)
        Me.rbZustaendigKube.TabIndex = 8
        Me.rbZustaendigKube.Text = "Kundenberater"
        Me.rbZustaendigKube.Visible = False
        '
        'cbzust
        '
        Me.cbzust.Location = New System.Drawing.Point(128, 47)
        Me.cbzust.Name = "cbzust"
        Me.cbzust.Size = New System.Drawing.Size(232, 21)
        Me.cbzust.TabIndex = 11
        Me.cbzust.Visible = False
        '
        'cbKube
        '
        Me.cbKube.Location = New System.Drawing.Point(128, 21)
        Me.cbKube.Name = "cbKube"
        Me.cbKube.Size = New System.Drawing.Size(232, 21)
        Me.cbKube.TabIndex = 9
        Me.cbKube.Visible = False
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker1, Me.cbPostzustellung, Me.Label5, Me.Label3})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 296)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 16)
        Me.GroupBox2.TabIndex = 6
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Allgemein"
        Me.GroupBox2.Visible = False
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 48)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(104, 20)
        Me.DateTimePicker1.TabIndex = 7
        Me.DateTimePicker1.Visible = False
        '
        'cbPostzustellung
        '
        Me.cbPostzustellung.Location = New System.Drawing.Point(128, 24)
        Me.cbPostzustellung.Name = "cbPostzustellung"
        Me.cbPostzustellung.Size = New System.Drawing.Size(232, 21)
        Me.cbPostzustellung.TabIndex = 6
        Me.cbPostzustellung.Visible = False
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 48)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Dokument-Datum"
        Me.Label5.Visible = False
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 24)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "Post-Zustellung"
        Me.Label3.Visible = False
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox5, Me.GroupBox4})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(792, 206)
        Me.TabPage4.TabIndex = 1
        Me.TabPage4.Text = "Zusammenhänge"
        Me.TabPage4.Visible = False
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.ColdList})
        Me.GroupBox5.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(400, 100)
        Me.GroupBox5.TabIndex = 1
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Dokumente ersetzen"
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.ContextMenu = Me.ContextMenu7
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(3, 16)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines2
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(394, 81)
        Me.ColdList.TabIndex = 0
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 77</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "7</ClientArea></Blob>"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Dokument auswählen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Dokument entfernen"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label20, Me.DateTimePicker3, Me.Label10})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(368, 200)
        Me.GroupBox4.TabIndex = 0
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Allgemein"
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 72)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 35
        Me.Label20.Text = "Bemerkung"
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker3.TabIndex = 18
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 34
        Me.Label10.Text = "Archiv-Datum"
        '
        'TabPage5
        '
        Me.TabPage5.Location = New System.Drawing.Point(4, 22)
        Me.TabPage5.Name = "TabPage5"
        Me.TabPage5.Size = New System.Drawing.Size(792, 206)
        Me.TabPage5.TabIndex = 2
        Me.TabPage5.Text = "Notizen / Rechte"
        Me.TabPage5.Visible = False
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.GroupBox11})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(792, 206)
        Me.TabPage1.TabIndex = 3
        Me.TabPage1.Text = "Zustelladresse"
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(312, 13)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 3
        '
        'GroupBox11
        '
        Me.GroupBox11.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label13, Me.txtAnredeZusteller, Me.txtZustelladresse})
        Me.GroupBox11.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox11.Name = "GroupBox11"
        Me.GroupBox11.Size = New System.Drawing.Size(296, 200)
        Me.GroupBox11.TabIndex = 0
        Me.GroupBox11.TabStop = False
        Me.GroupBox11.Text = "Zustelladresse"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 150)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(192, 16)
        Me.Label13.TabIndex = 2
        Me.Label13.Text = "Anrede (z.B.: Herr Muster)"
        '
        'txtAnredeZusteller
        '
        Me.txtAnredeZusteller.Location = New System.Drawing.Point(8, 168)
        Me.txtAnredeZusteller.Name = "txtAnredeZusteller"
        Me.txtAnredeZusteller.Size = New System.Drawing.Size(280, 20)
        Me.txtAnredeZusteller.TabIndex = 1
        Me.txtAnredeZusteller.Text = ""
        '
        'txtZustelladresse
        '
        Me.txtZustelladresse.Location = New System.Drawing.Point(8, 16)
        Me.txtZustelladresse.Multiline = True
        Me.txtZustelladresse.Name = "txtZustelladresse"
        Me.txtZustelladresse.Size = New System.Drawing.Size(280, 128)
        Me.txtZustelladresse.TabIndex = 0
        Me.txtZustelladresse.Text = "TextBox1"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuInfoEmpfaengerAdd, Me.mnuInfoEmpfaengerDelete})
        '
        'mnuInfoEmpfaengerAdd
        '
        Me.mnuInfoEmpfaengerAdd.Index = 0
        Me.mnuInfoEmpfaengerAdd.Text = "Neuer Info-Empfänger"
        '
        'mnuInfoEmpfaengerDelete
        '
        Me.mnuInfoEmpfaengerDelete.Index = 1
        Me.mnuInfoEmpfaengerDelete.Text = "Info-Empfänger löschen"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokZuordnungAdd, Me.MnuDokzuordnungDelete, Me.MenuItem1, Me.MnuShowDoc})
        '
        'MnuDokZuordnungAdd
        '
        Me.MnuDokZuordnungAdd.Index = 0
        Me.MnuDokZuordnungAdd.Text = "Dokument hinzufügen"
        '
        'MnuDokzuordnungDelete
        '
        Me.MnuDokzuordnungDelete.Index = 1
        Me.MnuDokzuordnungDelete.Text = "Dokument entfernen"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "-"
        '
        'MnuShowDoc
        '
        Me.MnuShowDoc.Index = 3
        Me.MnuShowDoc.Text = "Dokument anzeigen"
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem4})
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Text = "Berechtigungseinschränkung hinzufügen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "Berechtigungseinschränkung entfernen"
        '
        'cbVerantwortlich
        '
        Me.cbVerantwortlich.ContextMenu = Me.ContextMenu5
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(520, 64)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(240, 21)
        Me.cbVerantwortlich.TabIndex = 4
        Me.cbVerantwortlich.Visible = False
        '
        'ContextMenu5
        '
        Me.ContextMenu5.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Berechtigte Mitarbeiter"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(416, 64)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(88, 23)
        Me.Label17.TabIndex = 44
        Me.Label17.Text = "Verantwortlicher"
        Me.Label17.Visible = False
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(416, 40)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 43
        Me.Label16.Text = "Dokumentstatus"
        Me.Label16.Visible = False
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.ItemHeight = 13
        Me.cbdokumentstatus.Location = New System.Drawing.Point(520, 40)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(264, 21)
        Me.cbdokumentstatus.TabIndex = 4
        Me.cbdokumentstatus.Visible = False
        '
        'txtPartnerInhaberNr
        '
        Me.txtPartnerInhaberNr.Location = New System.Drawing.Point(16, 72)
        Me.txtPartnerInhaberNr.Name = "txtPartnerInhaberNr"
        Me.txtPartnerInhaberNr.ReadOnly = True
        Me.txtPartnerInhaberNr.Size = New System.Drawing.Size(176, 20)
        Me.txtPartnerInhaberNr.TabIndex = 42
        Me.txtPartnerInhaberNr.Text = ""
        Me.txtPartnerInhaberNr.Visible = False
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(520, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(264, 20)
        Me.txtBezeichnung.TabIndex = 3
        Me.txtBezeichnung.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(416, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.TabIndex = 38
        Me.Label4.Text = "Bezeichnung"
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(352, 64)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 2
        Me.btnPartnerInhaber.Visible = False
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(112, 40)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerZusteller.TabIndex = 1
        Me.txtPartnerZusteller.Text = ""
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(112, 16)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 0
        Me.txtPartnerInhaber.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 34
        Me.Label2.Text = "Partner-Zusteller"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 33
        Me.Label1.Text = "Partner-Inhaber"
        '
        'cdokumentwerteanzeigen
        '
        Me.cdokumentwerteanzeigen.Location = New System.Drawing.Point(528, 496)
        Me.cdokumentwerteanzeigen.Name = "cdokumentwerteanzeigen"
        Me.cdokumentwerteanzeigen.Size = New System.Drawing.Size(160, 32)
        Me.cdokumentwerteanzeigen.TabIndex = 6
        Me.cdokumentwerteanzeigen.Text = "Dokumentinhalte anzeigen"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(352, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 2
        Me.ToolTip1.SetToolTip(Me.Button1, "Partner Detailinformationen")
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(328, 64)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(24, 24)
        Me.Button4.TabIndex = 47
        Me.Button4.Visible = False
        '
        'cbsave
        '
        Me.cbsave.Enabled = False
        Me.cbsave.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbsave.Location = New System.Drawing.Point(764, 64)
        Me.cbsave.Name = "cbsave"
        Me.cbsave.Size = New System.Drawing.Size(21, 21)
        Me.cbsave.TabIndex = 49
        Me.cbsave.Text = "ComboBox1"
        Me.cbsave.Visible = False
        '
        'cbmoeglicheStati
        '
        Me.cbmoeglicheStati.Enabled = False
        Me.cbmoeglicheStati.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbmoeglicheStati.Location = New System.Drawing.Point(764, 64)
        Me.cbmoeglicheStati.Name = "cbmoeglicheStati"
        Me.cbmoeglicheStati.Size = New System.Drawing.Size(21, 21)
        Me.cbmoeglicheStati.TabIndex = 48
        Me.cbmoeglicheStati.Text = "ComboBox1"
        '
        'Panel1
        '
        Me.Panel1.Location = New System.Drawing.Point(784, 16)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(24, 100)
        Me.Panel1.TabIndex = 50
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(416, 80)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 32)
        Me.Label11.TabIndex = 52
        Me.Label11.Text = "Berechtigt für Folgestatus"
        Me.Label11.Visible = False
        '
        'txtstatus
        '
        Me.txtstatus.Location = New System.Drawing.Point(520, 88)
        Me.txtstatus.Name = "txtstatus"
        Me.txtstatus.Size = New System.Drawing.Size(224, 16)
        Me.txtstatus.TabIndex = 51
        Me.txtstatus.Text = "Label3"
        Me.txtstatus.Visible = False
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage2, Me.TabPage6})
        Me.TabControl1.Location = New System.Drawing.Point(8, 64)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(800, 424)
        Me.TabControl1.TabIndex = 5
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox14, Me.GroupBox8, Me.GroupBox7, Me.GroupBox6, Me.GroupBox13})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(792, 398)
        Me.TabPage2.TabIndex = 0
        Me.TabPage2.Text = "Allgemein"
        '
        'GroupBox14
        '
        Me.GroupBox14.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateErinnerung, Me.Label23, Me.DateTimePicker2, Me.Label6})
        Me.GroupBox14.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox14.Name = "GroupBox14"
        Me.GroupBox14.Size = New System.Drawing.Size(368, 40)
        Me.GroupBox14.TabIndex = 59
        Me.GroupBox14.TabStop = False
        '
        'DateErinnerung
        '
        Me.DateErinnerung.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.DateErinnerung.Location = New System.Drawing.Point(264, 13)
        Me.DateErinnerung.Name = "DateErinnerung"
        Me.DateErinnerung.ShowUpDownButtons = False
        Me.DateErinnerung.Size = New System.Drawing.Size(96, 20)
        Me.DateErinnerung.TabIndex = 1
        Me.DateErinnerung.Tag = Nothing
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(155, 15)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(120, 23)
        Me.Label23.TabIndex = 39
        Me.Label23.Text = "Überfällig-Meldung ab"
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.DateTimePicker2.Location = New System.Drawing.Point(50, 13)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.ShowUpDownButtons = False
        Me.DateTimePicker2.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker2.TabIndex = 0
        Me.DateTimePicker2.Tag = Nothing
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 14)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 37
        Me.Label6.Text = "Termin"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 272)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(776, 120)
        Me.GroupBox8.TabIndex = 58
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Notizen"
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(400, 32)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines3
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 2
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu1
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(8, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines4
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(760, 96)
        Me.Notizlist.TabIndex = 0
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 756, 92</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 756, 9" & _
        "2</ClientArea></Blob>"
        '
        'GroupBox7
        '
        Me.GroupBox7.BackColor = System.Drawing.SystemColors.Control
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.InfoMeldungList})
        Me.GroupBox7.Location = New System.Drawing.Point(8, 176)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(776, 96)
        Me.GroupBox7.TabIndex = 57
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Informationsmeldungen"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.ContextMenu = Me.ContextMenu4
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.InfoMeldungList.Location = New System.Drawing.Point(8, 16)
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines5
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(760, 72)
        Me.InfoMeldungList.TabIndex = 0
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1," & _
        " 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""" & _
        "><ClientRect>0, 0, 756, 68</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 756, 68</ClientArea></Blob>"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.ZuordnungList})
        Me.GroupBox6.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(400, 168)
        Me.GroupBox6.TabIndex = 56
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Dokument-Zuordnung"
        '
        'ZuordnungList
        '
        Me.ZuordnungList.AllowFilter = True
        Me.ZuordnungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ZuordnungList.AllowSort = True
        Me.ZuordnungList.AlternatingRows = True
        Me.ZuordnungList.CaptionHeight = 17
        Me.ZuordnungList.CollapseColor = System.Drawing.Color.Black
        Me.ZuordnungList.ContextMenu = Me.ContextMenu3
        Me.ZuordnungList.DataChanged = False
        Me.ZuordnungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ZuordnungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ZuordnungList.ExpandColor = System.Drawing.Color.Black
        Me.ZuordnungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ZuordnungList.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.ZuordnungList.Location = New System.Drawing.Point(3, 16)
        Me.ZuordnungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ZuordnungList.Name = "ZuordnungList"
        Me.ZuordnungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ZuordnungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ZuordnungList.PreviewInfo.ZoomFactor = 75
        Me.ZuordnungList.PrintInfo.ShowOptionsDialog = False
        Me.ZuordnungList.RecordSelectorWidth = 16
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ZuordnungList.RowDivider = GridLines6
        Me.ZuordnungList.RowHeight = 15
        Me.ZuordnungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ZuordnungList.ScrollTips = False
        Me.ZuordnungList.Size = New System.Drawing.Size(394, 149)
        Me.ZuordnungList.TabIndex = 0
        Me.ZuordnungList.Text = "C1TrueDBGrid1"
        Me.ZuordnungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 145</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, " & _
        "145</ClientArea></Blob>"
        '
        'GroupBox13
        '
        Me.GroupBox13.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBemerkung})
        Me.GroupBox13.Location = New System.Drawing.Point(8, 48)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(368, 128)
        Me.GroupBox13.TabIndex = 55
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Bemerkung"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(8, 16)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(352, 104)
        Me.txtBemerkung.TabIndex = 0
        Me.txtBemerkung.Text = ""
        '
        'TabPage6
        '
        Me.TabPage6.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox15})
        Me.TabPage6.Location = New System.Drawing.Point(4, 22)
        Me.TabPage6.Name = "TabPage6"
        Me.TabPage6.Size = New System.Drawing.Size(792, 398)
        Me.TabPage6.TabIndex = 1
        Me.TabPage6.Text = "COLD-Dokumentinformationen"
        '
        'GroupBox15
        '
        Me.GroupBox15.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnLoeschen, Me.Button5, Me.Button6, Me.Button7, Me.Button8, Me.Label12, Me.TextBox4, Me.TextBox3, Me.TextBox2, Me.Label14, Me.Label15, Me.Label19, Me.DateTimePicker4, Me.Label21, Me.TextBox1})
        Me.GroupBox15.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox15.Name = "GroupBox15"
        Me.GroupBox15.Size = New System.Drawing.Size(776, 384)
        Me.GroupBox15.TabIndex = 0
        Me.GroupBox15.TabStop = False
        '
        'btnLoeschen
        '
        Me.btnLoeschen.Image = CType(resources.GetObject("btnLoeschen.Image"), System.Drawing.Bitmap)
        Me.btnLoeschen.Location = New System.Drawing.Point(304, 48)
        Me.btnLoeschen.Name = "btnLoeschen"
        Me.btnLoeschen.Size = New System.Drawing.Size(24, 23)
        Me.btnLoeschen.TabIndex = 29
        Me.ToolTip1.SetToolTip(Me.btnLoeschen, "VV-Nummer löschen")
        '
        'Button5
        '
        Me.Button5.Location = New System.Drawing.Point(664, 352)
        Me.Button5.Name = "Button5"
        Me.Button5.TabIndex = 8
        Me.Button5.Text = "&Abbruch"
        Me.Button5.Visible = False
        '
        'Button6
        '
        Me.Button6.Location = New System.Drawing.Point(16, 152)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(264, 23)
        Me.Button6.TabIndex = 7
        Me.Button6.Text = "Indexmutation speichern"
        '
        'Button7
        '
        Me.Button7.Location = New System.Drawing.Point(280, 48)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(24, 23)
        Me.Button7.TabIndex = 3
        Me.Button7.Text = "..."
        Me.ToolTip1.SetToolTip(Me.Button7, "VV-Nummer wechseln")
        '
        'Button8
        '
        Me.Button8.Image = CType(resources.GetObject("Button8.Image"), System.Drawing.Bitmap)
        Me.Button8.Location = New System.Drawing.Point(280, 24)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(24, 23)
        Me.Button8.TabIndex = 1
        Me.ToolTip1.SetToolTip(Me.Button8, "Partner wechseln")
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(16, 48)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(88, 23)
        Me.Label12.TabIndex = 28
        Me.Label12.Text = "VV-Nummer"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(160, 48)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(120, 20)
        Me.TextBox4.TabIndex = 2
        Me.TextBox4.Text = ""
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(160, 120)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(120, 20)
        Me.TextBox3.TabIndex = 6
        Me.TextBox3.Text = ""
        Me.TextBox3.Visible = False
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(160, 96)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(120, 20)
        Me.TextBox2.TabIndex = 5
        Me.TextBox2.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(16, 120)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(136, 23)
        Me.Label14.TabIndex = 24
        Me.Label14.Text = "Grundstück-Bezeichnung"
        Me.Label14.Visible = False
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(16, 96)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(80, 23)
        Me.Label15.TabIndex = 23
        Me.Label15.Text = "Geschäftsfall"
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(16, 72)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(80, 23)
        Me.Label19.TabIndex = 22
        Me.Label19.Text = "Archiv-Datum"
        '
        'DateTimePicker4
        '
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(160, 72)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(120, 20)
        Me.DateTimePicker4.TabIndex = 4
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(16, 24)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(64, 23)
        Me.Label21.TabIndex = 20
        Me.Label21.Text = "Partner-Nr."
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(160, 24)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(120, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = ""
        '
        'pnlBerechtigungen
        '
        Me.pnlBerechtigungen.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.pnlBerechtigungen.Location = New System.Drawing.Point(80, 496)
        Me.pnlBerechtigungen.Name = "pnlBerechtigungen"
        Me.pnlBerechtigungen.Size = New System.Drawing.Size(616, 16)
        Me.pnlBerechtigungen.TabIndex = 65
        Me.pnlBerechtigungen.TabStop = False
        Me.pnlBerechtigungen.Text = "Berechtigungseinschränkung"
        Me.pnlBerechtigungen.Visible = False
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.ContextMenu = Me.ContextMenu6
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.Location = New System.Drawing.Point(8, 16)
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines7
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(600, 120)
        Me.DokumentFunktionenList.TabIndex = 0
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 596, 116</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "116</ClientArea></Blob>"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.cvertraulich, Me.Label18, Me.cGesperrt, Me.Label9})
        Me.GroupBox9.Location = New System.Drawing.Point(120, 496)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(152, 16)
        Me.GroupBox9.TabIndex = 64
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Schutz"
        Me.GroupBox9.Visible = False
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(16, 88)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(120, 48)
        Me.Button3.TabIndex = 19
        Me.Button3.Text = "Liste der berechtigten Mitarbeiter"
        '
        'cvertraulich
        '
        Me.cvertraulich.Location = New System.Drawing.Point(80, 46)
        Me.cvertraulich.Name = "cvertraulich"
        Me.cvertraulich.Size = New System.Drawing.Size(48, 24)
        Me.cvertraulich.TabIndex = 18
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(16, 48)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(64, 23)
        Me.Label18.TabIndex = 17
        '
        'cGesperrt
        '
        Me.cGesperrt.Enabled = False
        Me.cGesperrt.Location = New System.Drawing.Point(80, 24)
        Me.cGesperrt.Name = "cGesperrt"
        Me.cGesperrt.Size = New System.Drawing.Size(48, 24)
        Me.cGesperrt.TabIndex = 16
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 24)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(64, 23)
        Me.Label9.TabIndex = 15
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(8, 496)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 66
        '
        'frmDokumentInfoEdit
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(810, 527)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.pnlBerechtigungen, Me.GroupBox9, Me.TabControl1, Me.Label11, Me.txtstatus, Me.Panel1, Me.cbsave, Me.cbmoeglicheStati, Me.Button4, Me.Button1, Me.cdokumentwerteanzeigen, Me.cbVerantwortlich, Me.Label17, Me.Label16, Me.cbdokumentstatus, Me.txtPartnerInhaberNr, Me.txtBezeichnung, Me.Label4, Me.btnPartnerInhaber, Me.txtPartnerZusteller, Me.txtPartnerInhaber, Me.Label2, Me.Label1, Me.TabControl2, Me.btnCancel, Me.btnWeiter})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDokumentInfoEdit"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumentinformationen bearbeiten"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.GroupBox12.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.TabPage4.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox11.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.GroupBox14.ResumeLayout(False)
        CType(Me.DateErinnerung, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox7.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox6.ResumeLayout(False)
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox13.ResumeLayout(False)
        Me.TabPage6.ResumeLayout(False)
        Me.GroupBox15.ResumeLayout(False)
        Me.pnlBerechtigungen.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox9.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Insert_ColdUpdate Method

Public Function Insert_ColdUpdate( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal indextyp As Integer, _
   ByVal feldnr As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
indextyp
Required.
feldnr
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Insert_ColdUpdate(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal indextyp As Integer, ByVal feldnr As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_insert_coldupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@feldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, feldnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Insert_ColdUpdate_Datum Method

Public Function Insert_ColdUpdate_Datum( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal alterwert As String, _
   ByVal neuerwert As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
alterwert
Required.
neuerwert
Required.

Source code

[Visual Basic]
    Public Function Insert_ColdUpdate_Datum(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal alterwert As String, ByVal neuerwert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_insert_datumupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@alterwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alterwert))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, neuerwert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Load_Defaults Method

Private Sub Load_Defaults()

Source code

[Visual Basic]
    Private Sub Load_Defaults()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Dim doktyp As New edokadb.clsDokumenttyp()
        doktyp.cpMainConnectionProvider = conn
        doktyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doktyp.SelectOne()

        If doktyp.bFunktionen_zuweisen.Value = True Then
            Dokumentfunktionen_Aktivieren()
        Else
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.pnlBerechtigungen.Visible = False
        End If

        'Dokumenttyp-Daten
        If DivFnkt.Ist_Berechtigt(doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 0, 0, 0, 1) Then
            Me.cvertraulich.Visible = True
            Me.Label18.Visible = True
            Me.cvertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
        Else
            Me.cvertraulich.Checked = False
            Me.cvertraulich.Visible = False
            Me.Label18.Visible = False
        End If

        Me.txtBezeichnung.Text = doktyp.sBezeichnung.Value
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumentid").Value = ""
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumenttypnr").Value = Me.Dokumenttypnr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@CreateNew").Value = 1
        Me.SqlDataAdapter1.Fill(Me.DataSet1)

        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 50
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160

        Me.mcbstatus = New MultiComboBox(Me.cbdokumentstatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)

        Me.mcbkube = New MultiComboBox(Me.cbKube)
        Me.mcbkube.CheckNullValue = True
        Me.mcbkube.NullValueMessage = MyTxt.gettext(18)
        Me.mcbkube.DisplayColumnName = "name"
        Me.mcbkube.ValueColumnName = "mitarbeiternr"
        Me.mcbkube.Fill_Data(Generic_Select(8), False)

        'Postzustellung
        Me.SqlDataAdapter2.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter2.SelectCommand.Parameters("@sprache").Value = Globals.Sprache
        Me.SqlDataAdapter2.Fill(Me.DataSet2)

        mcbpostzustellung = New MultiComboBox(Me.cbPostzustellung)
        Me.mcbpostzustellung.DisplayColumnName = "bezeichnung"
        Me.mcbpostzustellung.ValueColumnName = "nreintrag"
        Dim d As DataTable
        d = Me.DataSet2.Tables(0)
        Me.mcbpostzustellung.Fill_Data(d, False)
        Me.mcbpostzustellung.Enabled = True

        mcbzust = New MultiComboBox(Me.cbzust)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii

        mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
        Me.mcbunterschriftlinks.DisplayColumnName = "name"
        Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftlinks")
        Me.mcbunterschriftlinks.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftlinks.SelectedValue = ii

        mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
        Me.mcbunterschriftrechts.DisplayColumnName = "name"
        Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftrechts")
        Me.mcbunterschriftrechts.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftrechts.SelectedValue = ii

        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        FillMcbVerantwortlich()

        Me.rbZustaendigKube.Checked = False
        Me.RBZustaendigZustaendiger.Checked = True
        Me.txtZustelladresse.Text = ""

        If doktyp.bUnterschrift_links.Value = False Then Me.mcbunterschriftlinks.Enabled = False
        If doktyp.bUnterschrift_rechts.Value = False Then Me.mcbunterschriftrechts.Enabled = False
        If doktyp.bUnterschrift_links.Value = True Then Me.mcbunterschriftlinks.Enabled = True
        If doktyp.bUnterschrift_rechts.Value = True Then Me.mcbunterschriftrechts.Enabled = True

        Me.zu_retournieren = doktyp.bZu_retournieren.Value

        doktyp.Dispose()

        'Dokument ersetzen
        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()
        Me.ColdList.DataSource = Me.Dokumentersetzen
        Me.ColdList.Columns("aktiv").FilterText = True
        Me.ColdList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")
        If doktyp.bCold_ersetzen.Value <> True Then Me.ColdList.Enabled = False Else Me.ColdList.Enabled = True

        'Notizen
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        'Dokumentzuordnungen
        Me.Dokumentzuorndungen = Dokumentzuordnungen_Laden()
        w.Save_Dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.ZuordnungList.DataSource = Me.Dokumentzuorndungen

        DivFnkt.SpaltenTitel_Aktualisieren(Me.ZuordnungList, Me.Dokumentzuorndungen, "dokumentzuordnungen")
        Me.ZuordnungList.Columns("aktiv").FilterText = True
        Me.ZuordnungList.FilterBar = False

        Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Translate = True
        Next

        'Dokumentinfomeldungen
        Me.InfoMeldungList.FetchRowStyles = True
        Me.DokumentInfoMeldungen = Dokumentinfomeldungen_laden()
        w.Save_Dokumentinfomeldungen = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = Me.DokumentInfoMeldungen
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, Me.DokumentInfoMeldungen, "Dokumentinfomeldung")

        'Team
        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        refresh_team()
        Me.mcbteam.SelectedIndex = 0

        Me.mcbstatus.SelectedIndex = 0
        Me.savestatus = Me.mcbstatus.SelectedValue
        Me.saveverantwortlicher = Globals.MitarbeiterNr

        Me.moeglichestati = Generic_Select(15)
        Me.cbmoeglicheStati.Items.Clear()
        Me.funktionsliste = ""
        '        Dim i As Integer
        settooltip()
        For i = 0 To Me.moeglichestati.Rows.Count - 1
            Me.cbmoeglicheStati.Items.Add(Me.moeglichestati.Rows(i).Item("bezeichnung"))
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim i As Integer
        Dim s As String
        s = ""
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

        Dim f As New frmBerechtigungen()
        If Me.cvertraulich.Checked Then
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 1, s)
        Else
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 0, s)
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmDokumentberechtigung()
        f.Dokumenttyp = Me.Dokumenttypnr
        f.Partnernr = Me.Partnernr
        f.Vertraulich = Me.cvertraulich.Checked
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = DokumentFunktionen.Rows
            Dim rowvals(Me.DokumentFunktionenList.Columns.Count - 1)
            rowvals(0) = System.DBNull.Value
            rowvals(1) = f.Funktionsgruppebezeichnung
            rowvals(2) = f.Funktionsgruppenr
            rowvals(3) = f.Anzeigen
            rowvals(4) = f.Bearbeiten
            rowvals(5) = f.Loeschen
            rowvals(6) = f.Abschliessen
            rowvals(7) = True
            rowvals(8) = Now
            rowvals(9) = Globals.MitarbeiterNr
            newrow = rc.Add(rowvals)
            Me.DokumentFunktionenList.Refresh()
            For i = 0 To Me.DokumentFunktionenList.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenList.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                    Me.DokumentFunktionenList.Bookmark = i
                End If
            Next
            Me.FillMcbVerantwortlich()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Me.DokumentFunktionenList.Columns(7).Value = False
        Me.DokumentFunktionenList.Refresh()
        Me.Button3.Focus()
        Me.DokumentFunktionenList.Focus()
        Me.FillMcbVerantwortlich()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                If Check_Dokumentersetzen(Me.Dokumenttypnr, fx.SelectedDokumentid) Then
                    Dim rc As DataRowCollection
                    Dim newrow As DataRow
                    rc = Dokumentersetzen.Rows
                    Dim rowvals(Me.Dokumentersetzen.Columns.Count - 1) As Object
                    rowvals(0) = System.DBNull.Value
                    rowvals(1) = ""
                    If Me.CreateDocument Then
                        rowvals(1) = ""
                    Else
                        rowvals(1) = Me.Dokumentid
                    End If
                    rowvals(2) = fx.SelectedDokumentid
                    rowvals(3) = True

                    rowvals(8) = fx.Dokumentbezeichnung
                    rowvals(9) = fx.dokumentdatum
                    newrow = rc.Add(rowvals)
                    Me.ColdList.Refresh()
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Me.ColdList.Columns("aktiv").Value = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Try
            Me.Notizlist.Columns(5).Value = False
            Me.Notizlist.Refresh()
            Me.TabControl2.Select()
            Me.Notizlist.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuDokZuordnungAdd_Click Method

Private Sub MnuDokZuordnungAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokZuordnungAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokZuordnungAdd.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                Dim rc As DataRowCollection
                Dim newrow As DataRow
                rc = Me.Dokumentzuorndungen.Rows
                Dim rowvals(Me.Dokumentzuorndungen.Columns.Count - 1) As Object
                rowvals(0) = 0
                rowvals(2) = 1
                rowvals(6) = 1
                rowvals(8) = fx.SelectedDokumentid
                rowvals(10) = fx.Dokumentbezeichnung

                newrow = rc.Add(rowvals)
                Me.ZuordnungList.Refresh()
                'For i = 0 To Me.ZuordnungList.Splits(0).Rows.Count - 1
                'If Me.ZuordnungList.Columns(0).CellText(i) = fx.SelectedDokumentid Then
                '    Me.ZuordnungList.Bookmark = i
                'End If
                'Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuDokzuordnungDelete_Click Method

Private Sub MnuDokzuordnungDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokzuordnungDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokzuordnungDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokzuordnungDelete.Click
        Me.ZuordnungList.Columns("aktiv").Value = False
        Me.ZuordnungList.Refresh()
        Me.TabControl2.Select()
        Me.ZuordnungList.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text          'koe 01092004 neu
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlist.Columns("betreff").Value = f.Betreff
            Me.Notizlist.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlist.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim f As New frmNotizen()
        Dim objMitarbeiter As New edokadb.clsMitarbeiter() 'koe 01092004 neu
        objMitarbeiter.cpMainConnectionProvider = conn
        objMitarbeiter.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        objMitarbeiter.SelectOne()

        f.Notiz = ""
        f.Betreff = ""
        f.Mutierer = objMitarbeiter.sName.ToString & " " & objMitarbeiter.sVorname.ToString & " , " & objMitarbeiter.sTgnummer.ToString
        objMitarbeiter.Dispose()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizen.Rows
            Dim rowvals(Me.Notizen.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer
            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizen
            load_Mitarbeiter()
            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuShowDoc_Click Method

Private Sub MnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowDoc.Click
        DivFnkt.ShowDoc(Me.ZuordnungList.Columns(8).Text, Me)
        'Dim doc As New edokadb.clsDokument()
        'Dim Dokument As String
        'Dim FileReader As New DocMgmt()
        'doc.cpMainConnectionProvider = conn
        'doc.sDokumentid = New SqlString(CType(Me.ZuordnungList.Columns(1).Value, String))
        'doc.SelectOne()
        'Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
        'FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument)
        'doc.Dispose()
        'FileReader = Nothing
        'Dim w As New WordLib()
        'w.ShowDoc(Dokument)
        'w = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.MnuValueSelect_Click Method

Private Sub MnuValueSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuValueSelect.Click, _
   DokWertList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuValueSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuValueSelect.Click, DokWertList.DoubleClick
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim s As String
        Select Case UCase(Me.DokWertList.Columns("feldtyp").Value)
            Case "DATUM"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "TEXT"
                If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 8) = "&Partner" Then
                    Dim f As New FrmPartnersuche()
                    f.ShowDialog()
                    If f.PartnerNr <> 0 Then
                        Me.DokWertList.Columns("feldwert").Value = Str(f.PartnerNr) + "-" + f.PartnerKurzbezeichnnung
                    End If
                    f.Dispose()
                Else
                    If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 1) = "&" Then
                        Dim f As New frmValueSelector()
                        f.Text = f.Text + Me.DokWertList.Columns(0).Value
                        f.Datenherkunft = Me.DokWertList.Columns("Datenherkunft").Value
                        f.partnernr = Me.txtPartnerInhaberNr.Text()
                        f.LoadData()
                        If f.Datenvorhanden = True Then
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then Me.DokWertList.Columns("feldwert").Value = f.SelWert
                        End If
                        f.Dispose()
                    End If
                End If
            Case Else
        End Select
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Notizen_Sichern Method

Public Sub Notizen_Sichern()

Source code

[Visual Basic]
    Public Sub Notizen_Sichern()
        For i = 0 To Me.Notizen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs)
        MnuEditNotiz_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Notizlist_MouseUp Method

Private Sub Notizlist_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs)

        Try

            If Me.Notizen.Rows.Count = 0 Then
                'Bei Systemnotitzen werden die Menue Ausgeblendet
                MnuEditNotiz.Enabled = False
                MnuDeleteNotiz.Enabled = False
                Notizlist.AllowUpdate = False
                Exit Sub

            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.RBZustaendigZustaendiger_CheckedChanged Method

Private Sub RBZustaendigZustaendiger_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBZustaendigZustaendiger.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBZustaendigZustaendiger_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBZustaendigZustaendiger.CheckedChanged
        Me.mcbkube.Enabled = False
        Me.mcbzust.Enabled = True
        Me.mcbzust.Focus()

        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            Me.refresh_team()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Set_Feldwert Method

Private Sub Set_Feldwert()

Source code

[Visual Basic]
    Private Sub Set_Feldwert()
        Try
            'Me.DokWertList.Columns("feldwert").Value = Me.ValueList.Columns(0).Value
            'Me.DokWertList.Columns("feldwert").Value = Me.Datumselect.Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Status_History Method

Private Function Status_History( _
   ByVal statusnr As Long _
)

Parameters

statusnr
Required.

Source code

[Visual Basic]
    Private Function Status_History(ByVal statusnr As Long)
        Dim statush As New Statushandling()
        Dim i, i1 As Integer
        If Me.saveverantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.savestatus = Me.mcbstatus.SelectedValue And Not Me.CreateDocument And Me.mcbstatus.SelectedIndex = 0 Then
            statush.Dispose()
            Exit Function
        End If
        If Me.CreateDocument Then
            i = Me.mcbstatus.SelectedValue
            Me.mcbstatus.SelectedIndex = 0
            statush.insert_history_status(get_current_Status(Me.Dokumentid), Me.Dokumentid, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(500)
            Me.mcbstatus.SelectedValue = i
            If Me.mcbstatus.SelectedIndex <> 0 Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(get_current_Status(Me.Dokumentid), Me.Dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
            w.send_statusmessage = True
        Else
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbstatus.SelectedIndex <> 0 Then
                i = Me.mcbstatus.SelectedValue
                Me.mcbstatus.SelectedIndex = 0
                Me.savestatus = Me.mcbstatus.SelectedValue
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.Dokumentid, Globals.MitarbeiterNr)
                w.send_statusmessage = True
                Me.mcbstatus.SelectedValue = i
                System.Threading.Thread.CurrentThread.Sleep(500)
            End If
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.Dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
        End If

        statush.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_Bclabel Method

Private Sub Update_Bclabel( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Sub Update_Bclabel(ByVal typ As Integer)
        If Me.BarcodeID = "" Then Exit Sub
        Dim bc As New edokadb.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        bc.iBarcodenr = New SqlInt32(CType(Me.BarcodeID, Int32))
        bc.SelectOne()
        conn.OpenConnection()
        If typ = 2 And Me.CreateDocument = True Then
            bc.sDokumentid = New SqlString(CType("", String))
        Else
            bc.sDokumentid = New SqlString(CType(Me.Dokumentid, String))
        End If
        bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        bc.Update()
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_DokumentColdIndexwert Method

Public Function Update_DokumentColdIndexwert( _
   ByVal dokumentid As String, _
   ByVal Indextyp As Integer, _
   ByVal indexfeld As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
Indextyp
Required.
indexfeld
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Update_DokumentColdIndexwert(ByVal dokumentid As String, ByVal Indextyp As Integer, ByVal indexfeld As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_Update_DokumentColdIndexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexfeld))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@wert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_Partnernr Method

Public Sub Update_Partnernr( _
   ByVal dokumentid As String, _
   ByVal partnernr As String _
)

Parameters

dokumentid
Required.
partnernr
Required.

Source code

[Visual Basic]
    Public Sub Update_Partnernr(ByVal dokumentid As String, ByVal partnernr As String)
        Dim d As New edokadb.clsDokument()
        Dim kurzname As String
        Dim ort As String
        d.cpMainConnectionProvider = Globals.conn
        d.sDokumentid = New SqlString(CType(dokumentid, String))
        d.SelectOne()
        d.iNrpar00 = New SqlInt32(CType(partnernr, Int32))
        conn.OpenConnection()
        d.Update()
        conn.CloseConnection(True)
        d.Dispose()
        kurzname = get_data("&PartnerKurzname&")
        ort = get_data("&PartnerInhaberOrt&")
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 1, partnernr)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 1, Me.TextBox1.Text)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 8, ort)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 8, ort)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_Status Method

Public Sub Update_Status( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal indextyp As Integer, _
   ByVal status As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
indextyp
Required.
status
Required.

Source code

[Visual Basic]
    Public Sub Update_Status(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal indextyp As Integer, ByVal status As String)
        Dim ityp As Integer
        If indextyp = 0 Then
            ityp = get_indextyp(dokumentid, colddokumentid)
        Else
            ityp = indextyp
        End If
        Insert_ColdUpdate(dokumentid, colddokumentid, ityp, 7, status)
        Update_DokumentColdIndexwert(dokumentid, ityp, 7, status)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_datum Method

Public Sub Update_datum( _
   ByVal dokumentid As String, _
   ByVal datuma As DateTime, _
   ByVal datum As DateTime _
)

Parameters

dokumentid
Required.
datuma
Required.
datum
Required.

Source code

[Visual Basic]
    Public Sub Update_datum(ByVal dokumentid As String, ByVal datuma As DateTime, ByVal datum As DateTime)
        Dim i As Integer
        Dim alterwert As String
        Dim neuerwert As String
        Dim s As String
        alterwert = LTrim(Str(Year(datuma)))
        s = LTrim(Str(Month(datuma)))
        While Len(s) < 2
            s = "0" + s
        End While
        alterwert = alterwert + s
        s = LTrim(Str(Microsoft.VisualBasic.Day(datuma)))
        While Len(s) < 2
            s = "0" + s
        End While
        alterwert = alterwert + s

        neuerwert = LTrim(Str(Year(datum)))
        s = LTrim(Str(Month(datum)))
        While Len(s) < 2
            s = "0" + s
        End While
        neuerwert = neuerwert + s
        s = LTrim(Str(Microsoft.VisualBasic.Day(datum)))
        While Len(s) < 2
            s = "0" + s
        End While
        neuerwert = neuerwert + s
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate_Datum(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), alterwert, neuerwert)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 5, Me.DateTimePicker4.Value.ToShortDateString)
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_gf Method

Public Sub Update_gf( _
   ByVal dokumentid As String, _
   ByVal gf As String _
)

Parameters

dokumentid
Required.
gf
Required.

Source code

[Visual Basic]
    Public Sub Update_gf(ByVal dokumentid As String, ByVal gf As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 14, gf)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 14, gf)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 12, gf)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_gu Method

Public Sub Update_gu( _
   ByVal dokumentid As String, _
   ByVal gu As String _
)

Parameters

dokumentid
Required.
gu
Required.

Source code

[Visual Basic]
    Public Sub Update_gu(ByVal dokumentid As String, ByVal gu As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 17, gu)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 17, gu)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.Update_vvnr Method

Public Sub Update_vvnr( _
   ByVal dokumentid As String, _
   ByVal vvnr As String _
)

Parameters

dokumentid
Required.
vvnr
Required.

Source code

[Visual Basic]
    Public Sub Update_vvnr(ByVal dokumentid As String, ByVal vvnr As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 3, vvnr)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 3, vvnr)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.ZuordnungList_Click Method

Private Sub ZuordnungList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ZuordnungList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ZuordnungList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ZuordnungList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.bereiche_sperren Method

Private Sub bereiche_sperren()

Source code

[Visual Basic]
    Private Sub bereiche_sperren()
        Me.btnPartnerInhaber.Enabled = False
        Me.GroupBox1.Enabled = False
        Me.GroupBox2.Enabled = False
        Me.GroupBox3.Enabled = False
        Me.GroupBox4.Enabled = False
        Me.GroupBox5.Enabled = False
        Me.GroupBox10.Enabled = False
        Me.GroupBox11.Enabled = False
        Me.GroupBox12.Enabled = False
        Me.GroupBox9.Enabled = False
        Me.Button2.Enabled = False
        Me.pnlBerechtigungen.Enabled = False
        Me.cbVerantwortlich.Enabled = False
        Me.mcbverantwortlich.Enabled = False
        Me.cbdokumentstatus.Enabled = False
        Me.mcbstatus.Enabled = False
        Me.DokWertList.Enabled = False
        Me.cdokumentwerteanzeigen.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        If Me.CreateDocument = False Then
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            If Globals.Dokumentcoldindex_Changed Then Archivfnkt.Restore_Coldindex(Globals.general_ds.Tables(0), Me.DokumentID)
            If Globals.dokumentid_changed Then Archivfnkt.change_dokumentid(DokumentID, Globals.Dokumentidalt)
        Else
            Update_Bclabel(2)
        End If

        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.btnLoeschen_Click Method

Private Sub btnLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnLoeschen.Click
        Me.TextBox4.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        Dim f As New FrmPartnersuche()
        f.profilnr = Me.Profilnr
        f.NurAbfrage = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, f.PartnerNr, "", 2, 0, 0, 0) Then
                If Me.txtPartnerInhaber.Text <> "" And Me.txtPartnerInhaber.Text <> Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung Then
                    MyMsg.show_standardmessage(73, MsgBoxStyle.Information)
                End If
                Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                Me.txtPartnerInhaberNr.Text = f.PartnerNr
                Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                Me.TabControl2.Enabled = True
                Me.RBZustaendigZustaendiger.Checked = True
                Me.mcbkube.DataSource = Nothing
                Me.mcbkube.Text = ""
                Me.mcbkube.Items.Clear()
                Me.Partnernr = f.PartnerNr
                FillMcbVerantwortlich()

            Else
                MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                Me.Close()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        '        Dim xdata As DataTable
        '       Dim s As String
        '      If Me.savestatus = Me.mcbstatus.SelectedValue Then
        '         If MyMsg.Show_HinweisMessage(Me.Profilnr, 2, 71, 2) = False Then
        '            Exit Sub
        '       End If
        '  End If
        ' If Me.txtPartnerInhaber.Text = "" Then
        '            MyMsg.show_standardmessage(205, MsgBoxStyle.Critical)
        '           Exit Sub
        '      End If
        '     If Me.mcbverantwortlich.Text = "" Then
        '        MyMsg.show_standardmessage(208, MsgBoxStyle.Critical)
        '       Exit Sub
        '  End If
        ' If Check_Dokumentfunktionen() = False Then Exit Sub
        '        xdata = Me.DataSet1.Tables(0)
        '       For i = 0 To xdata.Rows.Count - 1
        '          If xdata.Rows(i).Item("zwingend") Is System.DBNull.Value Then
        '         Else
        '            If xdata.Rows(i).Item("zwingend") = True Then
        '               If xdata.Rows(i).Item("feldwert") Is System.DBNull.Value Or xdata.Rows(i).Item("feldwert") = "" Then
        '                  MyMsg.show_standardmessage(206, MsgBoxStyle.Critical)
        '                 Me.DokWertList.Focus()
        '                xdata.Dispose()
        '               Exit Sub
        '          End If
        '     End If
        '    End If
        '        Next
        '       If Me.mcbteam.SelectedValue = 0 Then
        '          MyMsg.show_standardmessage(207, MsgBoxStyle.Critical)
        '         Me.mcbteam.Focus()
        '        Exit Sub
        '   End If
        '  xdata.Dispose()
        Me.btnWeiter.Enabled = False
        Dokument_Bearbeiten(Me.CreateDocument)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cbKube_SelectedIndexChanged Method

Private Sub cbKube_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbKube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.SelectedIndexChanged
        Try
            Me.teamzustaendig = Me.mcbkube.SelectedValue
        Catch
        End Try
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cbmoeglicheStati_DropDown Method

Private Sub cbmoeglicheStati_DropDown( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.DropDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.DropDown
        Me.cbmoeglicheStati.Width = 200
        Me.cbsave.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cbmoeglicheStati_Leave Method

Private Sub cbmoeglicheStati_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.Leave
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cbmoeglicheStati_SelectedValueChanged Method

Private Sub cbmoeglicheStati_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedValueChanged
        Dim i As Integer
        Dim DATA As DataTable
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
        Me.txtstatus.Text = Me.cbmoeglicheStati.Text
        Me.Label3.Visible = True
        Me.txtstatus.Visible = True
        If Me.txtstatus.Text = Me.mcbstatus.Text Then
            Me.Label3.Visible = False
            Me.txtstatus.Visible = False
            Me.funktionsliste = ""
            Me.selectedstatus = 0
        Else
            For i = 0 To Me.moeglichestati.Rows.Count - 1
                If Me.txtstatus.Text = Me.moeglichestati.Rows(i).Item("bezeichnung") Then
                    Me.selectedstatus = Me.moeglichestati.Rows(i).Item("nr")
                End If
            Next
        End If
        Me.funktionsliste = ""
        DATA = Generic_Select(16)
        For i = 0 To DATA.Rows.Count - 1
            If Me.funktionsliste <> "" Then Me.funktionsliste = Me.funktionsliste + ";"
            Me.funktionsliste = Me.funktionsliste + LTrim(DATA.Rows(i).Item("funktionnr"))
        Next
        fill_mcbmitarbeiter()
        Me.mcbverantwortlich.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cbzust_SelectedIndexChanged Method

Private Sub cbzust_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.SelectedIndexChanged
        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.check_banklagernd Method

Private Function check_banklagernd() As Boolean

Source code

[Visual Basic]
    Private Function check_banklagernd() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_banklagernd"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@banklagernd", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@banklagernd").Value
            If i <> 0 Then
                check_banklagernd = True
            Else
                check_banklagernd = False
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.cvertraulich_CheckedChanged Method

Private Sub cvertraulich_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cvertraulich_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            FillMcbVerantwortlich()
            Me.mcbverantwortlich.Focus()
            Me.mcbkube.SelectAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbverantwortlich.DataSource = Nothing
        Me.mcbverantwortlich.Items.Clear()
        Me.mcbverantwortlich.CheckNullValue = True
        Me.mcbverantwortlich.NullValueMessage = MyTxt.gettext(18)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        Me.mcbverantwortlich.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.Dokumentid, 3, 0, 0, 0, Me.funktionsliste), False)
        '        Me.mcbmitarbeiter.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.Dokumentid, 3, 0, 0, 0, Me.Funktionsliste), False)

        ' Me.mcbverantwortlich.SelectedValue = Me.mitarbeiternr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.frmDokumentbearbeitung_Load Method

Private Sub frmDokumentbearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentbearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        Me.Cursor = Cursors.WaitCursor
        Me.On_Load = True
        If Me.CreateDocument Then
            Formular_Laden_Create_Document()
            If Me.Partnernr <> "" Then
                If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, Me.Partnernr, "", 2, 0, 0, 0) Then
                    Dim f As New FrmPartnersuche()
                    f.Dokumenterstellen = True
                    f.Partner_Suche(Me.Partnernr)
                    Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                    Me.txtPartnerInhaberNr.Text = f.PartnerNr
                    Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                    Me.TabControl2.Enabled = True
                    f.Dispose()
                Else
                    MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                    Me.Close()
                End If
            Else
                btnPartnerInhaber_Click(sender, e)
            End If
            If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
                Me.cbKube.SelectedValue = Globals.MitarbeiterNr
            End If
        Else
            Formular_laden_Edit_Document()
            Dim bc As New DataTable()
            bc = Generic_Select(11)
            If bc.Rows.Count > 0 Then
                Me.BarcodeID = LTrim(Str(bc.Rows(0).Item(0)))
            End If
            bc.Dispose()
        End If
        If Me.BarcodeID <> "" Or Me.Dokumentinfobearbeiten = True Then
            Me.cdokumentwerteanzeigen.Visible = False
        Else
            Me.cdokumentwerteanzeigen.Visible = True
        End If

        Me.On_Load = False
        If Me.Dokument_Ist_Abgeschlossen Or Me.NurDokinfo Then bereiche_sperren()
        Me.Cursor = Cursors.Default

        load_indexmutation()
        load_Mitarbeiter()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_current_Status Method

Private Function get_current_Status( _
   ByVal dokumentid As String _
) As Long

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function get_current_Status(ByVal dokumentid As String) As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_current_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statustext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            get_current_Status = scmCmdToExecute.Parameters.Item("@currentstatus").Value
            Return get_current_Status
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_data Method

Private Function get_data( _
   ByVal datenherkunft As String _
) As String

Parameters

datenherkunft
Required.

Source code

[Visual Basic]
    Private Function get_data(ByVal datenherkunft As String) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentwerte_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, datenherkunft))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@value").Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_dokumentdaten Method

Private Function get_dokumentdaten() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumentdaten() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getdokinfo"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_dokumente Method

Private Function get_dokumente() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumente() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getdokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_indextyp Method

Private Function get_indextyp( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String _
) As Integer

Parameters

dokumentid
Required.
colddokumentid
Required.

Source code

[Visual Basic]
    Private Function get_indextyp(ByVal dokumentid As String, ByVal colddokumentid As String) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getindextyp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@indextyp").Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.get_partnerzusteller Method

Private Function get_partnerzusteller( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_partnerzusteller(ByVal nrpar00 As Integer) As String
        Dim p As New edokadb.clsPartner()
        Dim p1 As New edokadb.clsPartner()
        Dim s As String
        s = ""
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        If p.iNRPAR00.ToString <> p.sNRPARAD.ToString Then
            Try
                p1.cpMainConnectionProvider = conn
                p1.iNRPAR00 = New SqlInt32(CType(p.sNRPARAD.Value, Int32))
                p1.SelectOne()
                s = p1.sNRPARAD.ToString + " " + p1.sBKPAR00.Value
            Catch
                s = ""
            End Try
        End If
        p.Dispose()
        p1.Dispose()
        get_partnerzusteller = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.load_indexmutation Method

Public Function load_indexmutation()

Source code

[Visual Basic]
    Public Function load_indexmutation()
        Dim i As Integer
        Dim s As String
        Me.GroupBox15.Enabled = False
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            Me.GroupBox15.Enabled = True
        End If

        If Me.Dokument_Ist_Abgeschlossen = False Then
            If Me.Aktueller_Dokumentverantwortlicher = Globals.MitarbeiterNr Or DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                Me.GroupBox15.Enabled = True
            Else
                Me.GroupBox15.Enabled = False
            End If
        Else
            set_abgeschlossen_menu()
            If GroupBox15.Enabled = False And DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then Me.GroupBox15.Enabled = True
        End If

        If GroupBox15.Enabled = False Then Exit Function

        daten = get_dokumentdaten()
        dokumente = get_dokumente()
        Me.TextBox1.Text = Me.Partnernr
        For i = 0 To daten.Rows.Count - 1
            Select Case daten.Rows(i).Item("cold_indexfeldnr")
                Case 1
                    Me.TextBox1.Text = RTrim(daten.Rows(i).Item("wert"))
                    Partnernr = Me.TextBox1.Text
                Case 3
                    Me.TextBox4.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.vvnr = Me.TextBox4.Text
                Case 5
                    s = daten.Rows(i).Item("wert")
                    If Microsoft.VisualBasic.InStr(s, ".") > 0 Then
                        datum = s
                    Else
                        datum = Microsoft.VisualBasic.Right(s, 2) + "." + Mid(s, 5, 2) + "." + Microsoft.VisualBasic.Left(s, 4)
                    End If
                    Me.DateTimePicker4.Value = datum
                Case 14
                    Me.TextBox2.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gf = Me.TextBox2.Text
                Case 12
                    Me.TextBox2.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gf = Me.TextBox2.Text
                Case 17
                    Me.TextBox3.Text = RTrim(daten.Rows(i).Item("wert"))
                    Me.gu = Me.TextBox3.Text
            End Select
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.mcbkube_Leave Method

Private Sub mcbkube_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbkube_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbkube.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.mcbzust_Leave Method

Private Sub mcbzust_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbzust_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbzust.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.mnuInfoEmpfaengerAdd_Click Method

Private Sub mnuInfoEmpfaengerAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerAdd.Click
        Dim f As New frmInformationsEmpfaenger()
        f.Dokumenttypnr = Me.Dokumenttypnr
        If Me.CreateDocument = True Then
            f.fromDokumenttyp = True
        Else
            f.fromDokumenttyp = False
            f.dokumentid = Me.Dokumentid
        End If
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungen.Rows
            Dim rowvals(9) As Object
            rowvals(0) = 0
            rowvals(1) = 0
            rowvals(2) = f.Empfaenger
            rowvals(3) = f.Empaengertext
            rowvals(4) = f.Meldungsnr
            rowvals(5) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(6) = f.Bemerkung
            rowvals(7) = f.Statusnr
            rowvals(8) = f.Statustext
            rowvals(9) = 1
            newrow = rc.Add(rowvals)
            Me.InfoMeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.mnuInfoEmpfaengerDelete_Click Method

Private Sub mnuInfoEmpfaengerDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerDelete.Click
        Try
            Me.InfoMeldungList.Columns(9).Value = False
            Me.InfoMeldungList.Refresh()
            Me.TabControl2.Select()
            Me.InfoMeldungList.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.rbZustaendigKube_Click Method

Private Sub rbZustaendigKube_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbZustaendigKube.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbZustaendigKube_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbZustaendigKube.CheckedChanged
        Me.mcbzust.Enabled = False
        Me.mcbkube.Enabled = True
        If Me.rbZustaendigKube.Checked = True Then
            Me.mcbkube.DataSource = Nothing
            Me.mcbkube.Items.Clear()
            Me.mcbkube.Fill_Data(Generic_Select(8), False)
            If Me.mcbkube.Items.Count = 0 Then
                Me.mcbkube.Text = ""
                Me.rbZustaendigKube.Checked = False
                Me.RBZustaendigZustaendiger.Checked = True
                MyMsg.show_standardmessage(24, MsgBoxStyle.Information)
                RBZustaendigZustaendiger_CheckedChanged(sender, e)
                Exit Sub
            End If
        End If
        Try
            Me.mcbkube.Focus()
            Me.mcbkube.SelectedIndex = 0
            Try
                Me.teamzustaendig = Me.mcbkube.SelectedValue
                Me.refresh_team()
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.set_abgeschlossen_menu Method

Private Sub set_abgeschlossen_menu()

Source code

[Visual Basic]
    Private Sub set_abgeschlossen_menu()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_abgeschlossenes_dokument"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indexmutation", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aufhebung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@indexmutation").Value
            If i <> 0 Then
                Me.GroupBox15.Enabled = True
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.settooltip Method

Private Sub settooltip()

Source code

[Visual Basic]
    Private Sub settooltip()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbmoeglicheStati, Globals.MyTxt.gettext(22000))
        ttip.SetToolTip(Me.btnPartnerInhaber, Globals.MyTxt.gettext(22001))
        ttip.SetToolTip(Me.Button1, Globals.MyTxt.gettext(22002))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit.txtZustelladresse_Leave Method

Private Sub txtZustelladresse_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtZustelladresse.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtZustelladresse_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtZustelladresse.Leave
        If check_banklagernd() = True Then
            If MyMsg.Show_MessageYesNo(72) = MsgBoxResult.No Then
                Me.txtZustelladresse.Text = ""
                Me.txtAnredeZusteller.Text = ""
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentInfoEdit Fields

frmDokumentInfoEdit overview

Fields

field Aktueller_Dokumentverantwortlicher
field BtnHelp
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateErinnerung
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label23
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPage5
field TabPage6
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field ToolTip1
field ZuordnungList
field btnCancel
field btnLoeschen
field btnPartnerInhaber
field btnWeiter
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field components
field cvertraulich
field daten
field datum
field dokumente
field drpMiatarbeiter
field funktionsliste
field gf
field gu
field i
field ii
field m_NurDokInfo
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentid
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field vvnr
field w
field zu_retournieren

See Also

frmDokumentInfoEdit Class


Aktueller_Dokumentverantwortlicher Variable

Dim Aktueller_Dokumentverantwortlicher As Integer

Source code

[Visual Basic]
    Dim Aktueller_Dokumentverantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


CurrentProfil Variable

Dim CurrentProfil As Long

Source code

[Visual Basic]
    Dim CurrentProfil As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DateErinnerung Variable

Friend WithEvents DateErinnerung As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateErinnerung As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DokWertList Variable

Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DokumentFunktionen Variable

Dim DokumentFunktionen As DataTable

Source code

[Visual Basic]
    Dim DokumentFunktionen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


DokumentInfoMeldungen Variable

Dim DokumentInfoMeldungen As DataTable

Source code

[Visual Basic]
    Dim DokumentInfoMeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Dokumentersetzen Variable

Dim Dokumentersetzen As DataTable

Source code

[Visual Basic]
    Dim Dokumentersetzen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Dokumentzuorndungen Variable

Dim Dokumentzuorndungen As DataTable

Source code

[Visual Basic]
    Dim Dokumentzuorndungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox11 Variable

Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox13 Variable

Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox14 Variable

Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox15 Variable

Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuDokZuordnungAdd Variable

Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuDokzuordnungDelete Variable

Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuShowDoc Variable

Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


MnuValueSelect Variable

Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


NewDokumentID Variable

Dim NewDokumentID As String

Source code

[Visual Basic]
    Dim NewDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Notizen Variable

Dim Notizen As DataTable

Source code

[Visual Basic]
    Dim Notizen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


RBZustaendigZustaendiger Variable

Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage5 Variable

Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TabPage6 Variable

Friend WithEvents TabPage6 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage6 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ZuordnungList Variable

Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


btnLoeschen Variable

Friend WithEvents btnLoeschen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnLoeschen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cGesperrt Variable

Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbKube Variable

Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbPostzustellung Variable

Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbmoeglicheStati Variable

Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbsave Variable

Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cbzust Variable

Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cdokumentwerteanzeigen Variable

Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


cvertraulich Variable

Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


daten Variable

Dim daten As New DataTable()

Source code

[Visual Basic]
    Dim daten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


datum Variable

Dim datum As DateTime

Source code

[Visual Basic]
    Dim datum As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


dokumente Variable

Dim dokumente As New DataTable()

Source code

[Visual Basic]
    Dim dokumente As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


funktionsliste Variable

Dim funktionsliste As String

Source code

[Visual Basic]
    Dim funktionsliste As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


gf Variable

Dim gf As String

Source code

[Visual Basic]
    Dim gf As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


gu Variable

Dim gu As String

Source code

[Visual Basic]
    Dim gu As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


ii Variable

Dim ii As Integer

Source code

[Visual Basic]
    Dim ii As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_NurDokInfo Variable

Dim m_NurDokInfo As Boolean

Source code

[Visual Basic]
    Dim m_NurDokInfo As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_Partnernr Variable

Dim m_Partnernr As String

Source code

[Visual Basic]
    Dim m_Partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_createdocument Variable

Dim m_createdocument As Boolean

Source code

[Visual Basic]
    Dim m_createdocument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_dokument_ist_abgeschlossen Variable

Dim m_dokument_ist_abgeschlossen As Boolean

Source code

[Visual Basic]
    Dim m_dokument_ist_abgeschlossen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_dokumentinfobearbeiten Variable

Dim m_dokumentinfobearbeiten As Boolean

Source code

[Visual Basic]
    Dim m_dokumentinfobearbeiten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbkube Variable

Dim WithEvents mcbkube As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbkube As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbpostzustellung Variable

Dim WithEvents mcbpostzustellung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbpostzustellung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbstatus Variable

Dim WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbteam Variable

Dim WithEvents mcbteam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbteam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mcbzust Variable

Dim WithEvents mcbzust As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbzust As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mnuInfoEmpfaengerAdd Variable

Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


mnuInfoEmpfaengerDelete Variable

Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


moeglichestati Variable

Dim moeglichestati As DataTable

Source code

[Visual Basic]
    Dim moeglichestati As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


pnlBerechtigungen Variable

Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


rbZustaendigKube Variable

Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


savestatus Variable

Dim savestatus As Integer

Source code

[Visual Basic]
    Dim savestatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


saveverantwortlicher Variable

Dim saveverantwortlicher As Integer

Source code

[Visual Basic]
    Dim saveverantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


selectedstatus Variable

Dim selectedstatus As Integer

Source code

[Visual Basic]
    Dim selectedstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


teamzustaendig Variable

Dim teamzustaendig As Integer

Source code

[Visual Basic]
    Dim teamzustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtAnredeZusteller Variable

Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtPartnerInhaberNr Variable

Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtZustelladresse Variable

Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


txtstatus Variable

Friend WithEvents txtstatus As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtstatus As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


vvnr Variable

Dim vvnr As String

Source code

[Visual Basic]
    Dim vvnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


w Variable

Dim w As New WordLib()

Source code

[Visual Basic]
    Dim w As New WordLib()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


zu_retournieren Variable

Dim zu_retournieren As Boolean

Source code

[Visual Basic]
    Dim zu_retournieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentInfoEdit


frmDokumentKopieren Class

For a list of all members of this type, see frmDokumentKopieren Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentKopieren

Public Class frmDokumentKopieren
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentKopieren Members


frmDokumentKopieren Members

frmDokumentKopieren overview

Constructors

constructor frmDokumentKopieren Constructor (Overloaded)

Properties

property propDokumentBez
property propDokumentDatum
property propDokumentID
property propDokumentTyp
property propProfilDataTable
property propProfilNr

Methods

method Dispose
method InitializeComponent
method SetFunktionType
method btnAbbrechen_Click
method btnKopieren_Click
method btnPartnerInhaberInfo_Click
method btnPartnerInhaber_Click
method frmDokumentKopieren_Load
method genPartnerData

Fields

field Label1
field btnAbbrechen
field btnKopieren
field btnPartnerInhaber
field btnPartnerInhaberInfo
field cbxErsetzten
field components
field m_DokumentBez
field m_DokumentDatum
field m_dtProfil
field m_iAktiverPartner
field m_iDokumentTyp
field m_iFunktionType
field m_iPartner
field m_iProfilNr
field m_sDokumentID
field txtPartnerInhaber

See Also

frmDokumentKopieren Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal iAktuellerPartner As Integer)

See Also

frmDokumentKopieren | EDOKAApp


frmDokumentKopieren Properties

frmDokumentKopieren overview

Properties

property propDokumentBez
property propDokumentDatum
property propDokumentID
property propDokumentTyp
property propProfilDataTable
property propProfilNr

See Also

frmDokumentKopieren Class


frmDokumentKopieren.propDokumentBez Property

Property propDokumentBez() As String

Source code

[Visual Basic]
    Property propDokumentBez() As String
        Get
            Return m_DokumentBez
        End Get
        Set(ByVal Value As String)
            m_DokumentBez = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.propDokumentDatum Property

Property propDokumentDatum() As String

Source code

[Visual Basic]
    Property propDokumentDatum() As String
        Get
            Return m_DokumentDatum
        End Get
        Set(ByVal Value As String)
            m_DokumentDatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.propDokumentID Property

Property propDokumentID() As String

Source code

[Visual Basic]
    Property propDokumentID() As String
        Get
            Return m_sDokumentID
        End Get
        Set(ByVal Value As String)
            m_sDokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.propDokumentTyp Property

Property propDokumentTyp() As Integer

Source code

[Visual Basic]
    Property propDokumentTyp() As Integer
        Get
            Return m_iDokumentTyp
        End Get
        Set(ByVal Value As Integer)
            m_iDokumentTyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.propProfilDataTable Property

Property propProfilDataTable() As DataTable

Source code

[Visual Basic]
    Property propProfilDataTable() As DataTable
        Get
            Return m_dtProfil
        End Get
        Set(ByVal Value As DataTable)
            m_dtProfil = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.propProfilNr Property

Property propProfilNr() As Integer

Source code

[Visual Basic]
    Property propProfilNr() As Integer
        Get
            Return m_iProfilNr
        End Get
        Set(ByVal Value As Integer)
            m_iProfilNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren Methods

frmDokumentKopieren overview

Methods

method Dispose
method InitializeComponent
method SetFunktionType
method btnAbbrechen_Click
method btnKopieren_Click
method btnPartnerInhaberInfo_Click
method btnPartnerInhaber_Click
method frmDokumentKopieren_Load
method genPartnerData

See Also

frmDokumentKopieren Class


frmDokumentKopieren.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentKopieren))
        Me.btnPartnerInhaberInfo = New System.Windows.Forms.Button()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.btnKopieren = New System.Windows.Forms.Button()
        Me.btnAbbrechen = New System.Windows.Forms.Button()
        Me.cbxErsetzten = New System.Windows.Forms.CheckBox()
        Me.SuspendLayout()
        '
        'btnPartnerInhaberInfo
        '
        Me.btnPartnerInhaberInfo.Image = CType(resources.GetObject("btnPartnerInhaberInfo.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaberInfo.Location = New System.Drawing.Point(392, 32)
        Me.btnPartnerInhaberInfo.Name = "btnPartnerInhaberInfo"
        Me.btnPartnerInhaberInfo.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaberInfo.TabIndex = 36
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(368, 32)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 35
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(128, 32)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 34
        Me.txtPartnerInhaber.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(24, 32)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 37
        Me.Label1.Text = "Partner-Inhaber"
        '
        'btnKopieren
        '
        Me.btnKopieren.Location = New System.Drawing.Point(256, 112)
        Me.btnKopieren.Name = "btnKopieren"
        Me.btnKopieren.Size = New System.Drawing.Size(112, 24)
        Me.btnKopieren.TabIndex = 38
        Me.btnKopieren.Text = "Dokument kopieren"
        '
        'btnAbbrechen
        '
        Me.btnAbbrechen.Location = New System.Drawing.Point(128, 112)
        Me.btnAbbrechen.Name = "btnAbbrechen"
        Me.btnAbbrechen.Size = New System.Drawing.Size(112, 24)
        Me.btnAbbrechen.TabIndex = 39
        Me.btnAbbrechen.Text = "Abbrechen"
        '
        'cbxErsetzten
        '
        Me.cbxErsetzten.Location = New System.Drawing.Point(128, 64)
        Me.cbxErsetzten.Name = "cbxErsetzten"
        Me.cbxErsetzten.Size = New System.Drawing.Size(264, 24)
        Me.cbxErsetzten.TabIndex = 41
        Me.cbxErsetzten.Text = "Original Dokument ersetzen"
        '
        'frmDokumentKopieren
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(504, 158)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbxErsetzten, Me.btnAbbrechen, Me.btnKopieren, Me.btnPartnerInhaberInfo, Me.btnPartnerInhaber, Me.txtPartnerInhaber, Me.Label1})
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDokumentKopieren"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokument kopieren"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.SetFunktionType Method

Private Sub SetFunktionType()

Source code

[Visual Basic]
    Private Sub SetFunktionType()
        'Setzt je nach Funktion die Objekte Visible oder Unvisible
        Select Case m_iFunktionType
            Case EnumFunktionType.PartnerSuche
                cbxErsetzten.Enabled = False

            Case EnumFunktionType.PartnerAktuell
                Me.txtPartnerInhaber.Text = CStr(m_iPartner) & " " & genPartnerData(m_iPartner)
                cbxErsetzten.Enabled = True
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.btnAbbrechen_Click Method

Private Sub btnAbbrechen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbrechen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbrechen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbrechen.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.btnKopieren_Click Method

Private Sub btnKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnKopieren.Click
        Dim fI As New frmDokumentbearbeitung()
        Dim bErsetzenError As Boolean = False
        fI.Profilnr = m_iProfilNr
        fI.Profile = m_dtProfil

        If m_iPartner > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, m_iDokumentTyp) = False Then
            MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
            fI.Dispose()
            Me.Cursor = System.Windows.Forms.Cursors.Default
            Exit Sub
        End If
        fI.Partnernr = m_iPartner

        fI.Dokumenttypnr = m_iDokumentTyp
        fI.CreateDocument = True
        fI.PropKopyDokID = m_sDokumentID
        fI.BarcodeID = ""
        'Prüfen ob das Dokument erstzt werden kann.
        If cbxErsetzten.Checked = True Then
            If fI.Check_KopyDokumentZuErsetzten(m_iDokumentTyp, m_sDokumentID, m_DokumentBez, m_DokumentDatum) = False Then
                bErsetzenError = True
            End If
        End If
        If bErsetzenError = False Then
            Me.Cursor = Cursors.WaitCursor
            Me.Hide()
            Windows.Forms.Application.DoEvents()
            Me.Cursor = Cursors.WaitCursor
            fI.ShowDialog()
            fI.Hide()
            Windows.Forms.Application.DoEvents()
        Else
            fI.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.btnPartnerInhaberInfo_Click Method

Private Sub btnPartnerInhaberInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaberInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaberInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaberInfo.Click
        Try
            If m_iPartner > 0 Then
                If m_iPartner > 91000000 Then
                    Dim f As New frmInteressent()
                    f.Partnernr = m_iPartner
                    f.Display = True
                    f.ShowDialog()
                    f.Dispose()
                Else
                    Dim f As New frmPartnerDetails()
                    f.Partnernr = m_iPartner
                    f.ShowDialog()
                    f.Dispose()
                End If
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        'Oeffnet den Partnersuch Dialog
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = True
        Me.TopMost = False
        f.ShowDialog()
        Me.TopMost = True
        If f.PartnerNr <> 0 Then
            Me.Cursor = Cursors.WaitCursor
            m_iPartner = f.PartnerNr
            Me.Cursor = Cursors.Default
        End If
        Me.txtPartnerInhaber.Text = CStr(m_iPartner) & " " & genPartnerData(m_iPartner)
        If m_iAktiverPartner = m_iPartner Then
            cbxErsetzten.Enabled = True
        Else
            cbxErsetzten.Checked = False
            cbxErsetzten.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.frmDokumentKopieren_Load Method

Private Sub frmDokumentKopieren_Load( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentKopieren_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
        SetFunktionType()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren.genPartnerData Method

Private Function genPartnerData( _
   ByVal iPartnerNr As Integer _
) As String

Parameters

iPartnerNr
Required.

Source code

[Visual Basic]
    Private Function genPartnerData(ByVal iPartnerNr As Integer) As String
        Dim objPartner As New edokadb.clsPartner()
        Try
            objPartner.cpMainConnectionProvider = Globals.conn
            objPartner.iNRPAR00 = New SqlInt32(CType(iPartnerNr, Int32))
            objPartner.SelectOne()
            Return objPartner.sBKPAR00.Value
        Finally
            objPartner.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren Fields

frmDokumentKopieren overview

Fields

field Label1
field btnAbbrechen
field btnKopieren
field btnPartnerInhaber
field btnPartnerInhaberInfo
field cbxErsetzten
field components
field m_DokumentBez
field m_DokumentDatum
field m_dtProfil
field m_iAktiverPartner
field m_iDokumentTyp
field m_iFunktionType
field m_iPartner
field m_iProfilNr
field m_sDokumentID
field txtPartnerInhaber

See Also

frmDokumentKopieren Class


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


btnAbbrechen Variable

Friend WithEvents btnAbbrechen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbrechen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


btnKopieren Variable

Friend WithEvents btnKopieren As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnKopieren As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


btnPartnerInhaberInfo Variable

Friend WithEvents btnPartnerInhaberInfo As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaberInfo As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


cbxErsetzten Variable

Friend WithEvents cbxErsetzten As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxErsetzten As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_DokumentBez Variable

Dim m_DokumentBez As String

Source code

[Visual Basic]
    Dim m_DokumentBez As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_DokumentDatum Variable

Dim m_DokumentDatum As String

Source code

[Visual Basic]
    Dim m_DokumentDatum As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_dtProfil Variable

Dim m_dtProfil As DataTable

Source code

[Visual Basic]
    Dim m_dtProfil As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_iAktiverPartner Variable

Dim m_iAktiverPartner As Integer = 0

Source code

[Visual Basic]
    Dim m_iAktiverPartner As Integer = 0 'Partner von dem Dokument das kopiert werden soll.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_iDokumentTyp Variable

Dim m_iDokumentTyp As Integer

Source code

[Visual Basic]
    Dim m_iDokumentTyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_iFunktionType Variable

Dim m_iFunktionType As EnumFunktionType = EnumFunktionType.PartnerSuche

Source code

[Visual Basic]
    Dim m_iFunktionType As EnumFunktionType = EnumFunktionType.PartnerSuche

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_iPartner Variable

Dim m_iPartner As Integer = 0

Source code

[Visual Basic]
    Dim m_iPartner As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_iProfilNr Variable

Dim m_iProfilNr As Integer

Source code

[Visual Basic]
    Dim m_iProfilNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


m_sDokumentID Variable

Dim m_sDokumentID As String

Source code

[Visual Basic]
    Dim m_sDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentStatistik Class

For a list of all members of this type, see frmDokumentStatistik Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentStatistik

Public Class frmDokumentStatistik
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentStatistik Members


frmDokumentStatistik Members

frmDokumentStatistik overview

Constructors

constructor frmDokumentStatistik Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick

Fields

field Button1
field DateTimePicker1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field ToolBar1
field ToolBarButton1
field components

See Also

frmDokumentStatistik Class


frmDokumentStatistik Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentStatistik Methods

frmDokumentStatistik overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method ToolBar1_ButtonClick

See Also

frmDokumentStatistik Class


frmDokumentStatistik.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokument_statistik"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DateTimePicker1.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@scan", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dok", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Me.Label5.Text = scmCmdToExecute.Parameters("@scan").Value
            Me.Label6.Text = scmCmdToExecute.Parameters("@bck").Value
            Me.Label7.Text = scmCmdToExecute.Parameters("@dok").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentStatistik.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentStatistik.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentStatistik))
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.SuspendLayout()
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(96, 48)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker1.TabIndex = 0
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 48)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(80, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Dokumente ab"
        '
        'Button1
        '
        Me.Button1.AllowDrop = True
        Me.Button1.Location = New System.Drawing.Point(200, 48)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&Zählen"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 88)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Erstübernahme:"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 112)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Barcode-Kleber:"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 136)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(136, 23)
        Me.Label4.TabIndex = 5
        Me.Label4.Text = "Korrespondenz/Verträge:"
        '
        'Label5
        '
        Me.Label5.ImageAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.Label5.Location = New System.Drawing.Point(144, 88)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(64, 16)
        Me.Label5.TabIndex = 6
        Me.Label5.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label6
        '
        Me.Label6.ImageAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.Label6.Location = New System.Drawing.Point(144, 112)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(64, 16)
        Me.Label6.TabIndex = 7
        Me.Label6.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label7
        '
        Me.Label7.ImageAlign = System.Drawing.ContentAlignment.MiddleRight
        Me.Label7.Location = New System.Drawing.Point(144, 136)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(64, 16)
        Me.Label7.TabIndex = 8
        Me.Label7.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(288, 25)
        Me.ToolBar1.TabIndex = 9
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'frmDokumentStatistik
        '
        Me.AcceptButton = Me.Button1
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(288, 173)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label7, Me.Label6, Me.Label5, Me.ToolBar1, Me.Label4, Me.Label3, Me.Label2, Me.Button1, Me.Label1, Me.DateTimePicker1})
        Me.Name = "frmDokumentStatistik"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokument-Statistik"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentStatistik.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentStatistik Fields

frmDokumentStatistik overview

Fields

field Button1
field DateTimePicker1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field ToolBar1
field ToolBarButton1
field components

See Also

frmDokumentStatistik Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentStatistik


frmDokumentbearbeitung Class

For a list of all members of this type, see frmDokumentbearbeitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentbearbeitung

Public Class frmDokumentbearbeitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentbearbeitung Members


frmDokumentbearbeitung Members

frmDokumentbearbeitung overview

Constructors

constructor frmDokumentbearbeitung Constructor

Properties

property BarcodeID
property CreateDocument
property DokumentID
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property Edex_Folgestatus
property EditDokumentid
property EditDokumentidbr
property Partnernr
property Profile
property Profilnr
property PropKopyDokID
property w

Methods

method Banklagernd_Check
method Bedingte_Retournierung
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Check_KopyDokumentZuErsetzten
method Cold_Index_Bearbeiten
method Cold_Index_Bearbeiten_Bedingte_Retournierung
method ContextMenu10_Popup
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method Create_tmp_funktionen
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_AfterColUpdate
method DokWertList_BeforeColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method DokWertList_MouseDown
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentersetzen_Sichern_Bedingte_Retournierung
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_AktivierenBR
method Dokumentfunktionen_sichern
method Dokumentfunktionen_sichern_Bedingte_Retournierung
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_Sichern_Bedingte_Retournierung
method Dokumentinfomeldungen_laden
method Dokumentinfomeldungen_laden_Bedingte_Retournierung
method DokumentwertListe_laden
method DokumentwertListe_ladenbr
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentwerte_Sichern_Bedingte_Retournierung
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method Dokumentzuordnungen_Sichern_Bedingte_Retournierung
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Insert_Update_Bedingte_Retournierung
method Load_Create_Dokument_Bedingte_Retournierung
method Load_Defaults
method Load_Defaults_Bedingte_Retournierung
method Load_Edit_Document_Bedingte_Retournierung
method MenuItem2_Click
method MenuItem2_Click_Bedingte_Retournierung
method MenuItem3_Click
method MenuItem3_Click_Bedingte_Retournierung
method MenuItem4_Click
method MenuItem4_Click_Bedingte_Retournierung
method MenuItem5_Click
method MenuItem5_Click_Bedingte_Retournierung
method MenuItem6_Click
method MenuItem6_Click_Bedingte_Retournierung
method MnuDeleteNotiz_Click
method MnuDeleteNotiz_Click_Bedingte_Retournierung
method MnuDokZuordnungAdd_Click
method MnuDokZuordnungAdd_Click_Bedingte_Retournierung
method MnuDokzuordnungDelete_Click
method MnuDokzuordnungDelete_Click_Bedingte_Retournierung
method MnuEditNotiz_Click
method MnuEditNotiz_Click_Bedingte_Retournierung
method MnuNeueNotiz_Click
method MnuNeueNotiz_Click_Bedingte_Retournierung
method MnuShowDoc_Click
method MnuShowDoc_Click_Bedingte_Retournierung
method MnuValueSelect_Click
method MnuValueSelect_Click_Bedingte_Retournierung
method Notizen_Laden
method Notizen_Sichern
method Notizen_Sichern_Bedingte_Retournierung
method Notizlist_DoubleClick
method Notizlist_DoubleClick_Bedingte_Retournierung
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_DokumentZuErsetzen
method Set_Feldwert
method Status_History
method Status_History_Bedingte_Retournierung
method TMP_Funktion
method TabControl2_Click
method TabControl2_DrawItem
method TabControl2_SelectedIndexChanged
method Update_Bclabel
method Update_Bedingte_Retournierung
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method delete_tmp_funktionen
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerAdd_Click_Bedingte_Retournierung
method mnuInfoEmpfaengerDelete_Click
method mnuInfoEmpfaengerDelete_Click_Bedingte_Retournierung
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

Fields

field BedingteRetournierung
field BtnHelp
field Button1
field Button2
field Button3
field Button3Br
field Button4
field Check_Existing_Adresse
field ColdList
field ContextMenu1
field ContextMenu10
field ContextMenu11
field ContextMenu12
field ContextMenu13
field ContextMenu14
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field Dataset1BR
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DokTypBR
field DokWertList
field DokWertListBR
field Doktyp
field DokumentFunktionen
field DokumentFunktionenList
field DokumentFunktionenListBR
field DokumentFunktionenbr
field DokumentIDBR
field DokumentInfoMeldungen
field DokumentInfoMeldungenbr
field Dokumentersetzen
field Dokumentersetzenbr
field DokumenttypNrBr
field Dokumentzuorndungen
field Dokumentzuorndungenbr
field ErsetzenMoeglich
field ErsetzenMoeglichbr
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox16
field GroupBox17
field GroupBox18
field GroupBox19
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InFoMeldungListBR
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label18BR
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field NewDokumentIDBR
field Notizen
field Notizenbr
field Notizlist
field Notizlistbr
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SaveBM
field SaveStatusBR
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl1
field TabControl2
field TabPage1
field TabPage10
field TabPage3
field TabPage4
field TabPage5
field TabPage7
field TabPage8
field TabPage9
field Use_BL_Status
field VIBeachten
field ZuordnungList
field ZuordnunglistBR
field bemerkungbr
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cGesperrtBR
field cVertraulichBR
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field changeteam
field coldlistbr
field components
field cvertraulich
field doc
field docbr
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_KopyDokErsetzten
field m_KopyDokID
field m_KopyErsetzDokBez
field m_KopyErsetzDokDatum
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_edex_folgestatus
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field pnlBerechtigungenBR
field progress
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field tbp0
field tbp1
field tbp2
field tbp3
field tbp4
field tbp5
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtbezeichnungbr
field txtstatus
field validationerror
field zu_retournieren

See Also

frmDokumentbearbeitung Class


frmDokumentbearbeitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung Properties

frmDokumentbearbeitung overview

Properties

property BarcodeID
property CreateDocument
property DokumentID
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property Edex_Folgestatus
property EditDokumentid
property EditDokumentidbr
property Partnernr
property Profile
property Profilnr
property PropKopyDokID
property w

See Also

frmDokumentbearbeitung Class


frmDokumentbearbeitung.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.CreateDocument Property

Property CreateDocument() As Boolean

Source code

[Visual Basic]
    Property CreateDocument() As Boolean
        Get
            Return m_createdocument
        End Get
        Set(ByVal Value As Boolean)
            m_createdocument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentID Property

Public DokumentID As String

Source code

[Visual Basic]
    Public DokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokument_Ist_Abgeschlossen Property

Property Dokument_Ist_Abgeschlossen() As Boolean

Source code

[Visual Basic]
    Property Dokument_Ist_Abgeschlossen() As Boolean
        Get
            Return m_dokument_ist_abgeschlossen
        End Get
        Set(ByVal Value As Boolean)
            m_dokument_ist_abgeschlossen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentinfobearbeiten Property

Property Dokumentinfobearbeiten() As Boolean

Source code

[Visual Basic]
    Property Dokumentinfobearbeiten() As Boolean
        Get
            Return m_dokumentinfobearbeiten
        End Get
        Set(ByVal Value As Boolean)
            m_dokumentinfobearbeiten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Edex_Folgestatus Property

Property Edex_Folgestatus() As Integer

Source code

[Visual Basic]
    Property Edex_Folgestatus() As Integer
        Get
            Return m_edex_folgestatus
        End Get
        Set(ByVal Value As Integer)
            m_edex_folgestatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.EditDokumentid Property

Property EditDokumentid() As String

Source code

[Visual Basic]
    Property EditDokumentid() As String
        Get
            Return DokumentID
        End Get
        Set(ByVal Value As String)
            DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.EditDokumentidbr Property

Property EditDokumentidbr() As String

Source code

[Visual Basic]
    Property EditDokumentidbr() As String
        Get
            Return DokumentIDBR
        End Get
        Set(ByVal Value As String)
            DokumentIDBR = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_Partnernr
        End Get
        Set(ByVal Value As String)
            m_Partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.PropKopyDokID Property

Property PropKopyDokID() As String

Source code

[Visual Basic]
    Property PropKopyDokID() As String
        Get
            Return m_KopyDokID
        End Get
        Set(ByVal Value As String)
            m_KopyDokID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


w Property

Public w As New WordLib()

Source code

[Visual Basic]
    Public w As New WordLib()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung Methods

frmDokumentbearbeitung overview

Methods

method Banklagernd_Check
method Bedingte_Retournierung
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Check_KopyDokumentZuErsetzten
method Cold_Index_Bearbeiten
method Cold_Index_Bearbeiten_Bedingte_Retournierung
method ContextMenu10_Popup
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method Create_tmp_funktionen
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_AfterColUpdate
method DokWertList_BeforeColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method DokWertList_MouseDown
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentersetzen_Sichern_Bedingte_Retournierung
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_AktivierenBR
method Dokumentfunktionen_sichern
method Dokumentfunktionen_sichern_Bedingte_Retournierung
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_Sichern_Bedingte_Retournierung
method Dokumentinfomeldungen_laden
method Dokumentinfomeldungen_laden_Bedingte_Retournierung
method DokumentwertListe_laden
method DokumentwertListe_ladenbr
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentwerte_Sichern_Bedingte_Retournierung
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method Dokumentzuordnungen_Sichern_Bedingte_Retournierung
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Insert_Update_Bedingte_Retournierung
method Load_Create_Dokument_Bedingte_Retournierung
method Load_Defaults
method Load_Defaults_Bedingte_Retournierung
method Load_Edit_Document_Bedingte_Retournierung
method MenuItem2_Click
method MenuItem2_Click_Bedingte_Retournierung
method MenuItem3_Click
method MenuItem3_Click_Bedingte_Retournierung
method MenuItem4_Click
method MenuItem4_Click_Bedingte_Retournierung
method MenuItem5_Click
method MenuItem5_Click_Bedingte_Retournierung
method MenuItem6_Click
method MenuItem6_Click_Bedingte_Retournierung
method MnuDeleteNotiz_Click
method MnuDeleteNotiz_Click_Bedingte_Retournierung
method MnuDokZuordnungAdd_Click
method MnuDokZuordnungAdd_Click_Bedingte_Retournierung
method MnuDokzuordnungDelete_Click
method MnuDokzuordnungDelete_Click_Bedingte_Retournierung
method MnuEditNotiz_Click
method MnuEditNotiz_Click_Bedingte_Retournierung
method MnuNeueNotiz_Click
method MnuNeueNotiz_Click_Bedingte_Retournierung
method MnuShowDoc_Click
method MnuShowDoc_Click_Bedingte_Retournierung
method MnuValueSelect_Click
method MnuValueSelect_Click_Bedingte_Retournierung
method Notizen_Laden
method Notizen_Sichern
method Notizen_Sichern_Bedingte_Retournierung
method Notizlist_DoubleClick
method Notizlist_DoubleClick_Bedingte_Retournierung
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_DokumentZuErsetzen
method Set_Feldwert
method Status_History
method Status_History_Bedingte_Retournierung
method TMP_Funktion
method TabControl2_Click
method TabControl2_DrawItem
method TabControl2_SelectedIndexChanged
method Update_Bclabel
method Update_Bedingte_Retournierung
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method delete_tmp_funktionen
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerAdd_Click_Bedingte_Retournierung
method mnuInfoEmpfaengerDelete_Click
method mnuInfoEmpfaengerDelete_Click_Bedingte_Retournierung
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

See Also

frmDokumentbearbeitung Class


frmDokumentbearbeitung.Banklagernd_Check Method

Private Sub Banklagernd_Check()

Source code

[Visual Basic]
    Private Sub Banklagernd_Check()
        Dim i As Integer
        i = check_banklagernd()
        If i = 0 Then Exit Sub
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        dt.iDokumenttypnr = New SqlInt32(CType(Dokumenttypnr, Int32))
        dt.SelectOne()
        If dt.bKundenDokument.Value = False Then
            dt.Dispose()
            Exit Sub
        End If
        dt.Dispose()
        Try
            Select Case i
                Case 1
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, False)
                    Dim p As New edokadb.clsPartner()
                    p.cpMainConnectionProvider = conn
                    p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
                    p.SelectOne()
                    F.rbVersand.Enabled = True
                    f.RBPersönlich.Checked = False
                    If p.bSaldiert.Value = True Then
                        f.rbDossier.Enabled = False
                        f.rbVersand.Checked = True
                        f.RBPersönlich.Checked = True
                    Else
                        f.rbDossier.Checked = True
                        f.rbDossier.Enabled = True
                        f.rbVersand.Checked = False
                    End If
                    f.ShowDialog()
                    If f.RBPersönlich.Checked Then
                        Me.txtZustelladresse.Text = DivFnkt.get_parnter_namevorname(Me.Partnernr) + vbCrLf + "persönlich ausgehändigt"
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Check_Existing_Adresse = False
                    End If
                    If f.rbVersand.Checked = True Then
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = True
                        Me.Button2.Enabled = True
                        Check_Existing_Adresse = True
                    End If
                    If f.rbDossier.Checked = True Then
                        Me.Use_BL_Status = True
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Check_Existing_Adresse = False
                    End If
                    f.Dispose()
                    p.Dispose()
                Case 2
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, False)
                    f.rbDossier.Checked = True
                    f.rbVersand.Enabled = False
                    f.rbVersand.Checked = False
                    f.RBPersönlich.Checked = False

                    Dim p As New edokadb.clsPartner()
                    p.cpMainConnectionProvider = conn
                    p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
                    p.SelectOne()
                    If p.bSaldiert.Value = True Then
                        f.rbDossier.Enabled = False
                        f.RBPersönlich.Checked = True
                    Else
                        f.rbDossier.Checked = True
                        f.rbDossier.Enabled = True
                        f.rbVersand.Checked = False
                    End If
                    f.ShowDialog()
                    If f.RBPersönlich.Checked Then
                        Me.txtZustelladresse.Text = DivFnkt.get_parnter_namevorname(Me.Partnernr) + vbCrLf + "persönlich ausgehändigt"
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                    Else
                        Me.Use_BL_Status = True
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                    End If
                    f.Dispose()
                    p.Dispose()
            End Select
        Catch
        Finally
            Try
                Globals.conn.CloseConnection(True)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Bedingte_Retournierung Method

Private Sub Bedingte_Retournierung()

Source code

[Visual Basic]
    Private Sub Bedingte_Retournierung()
        If Me.CreateDocument = True Then
            DokTypBR.cpMainConnectionProvider = conn
            DokTypBR.iDokumenttypnr = New SqlInt32(CType(Doktyp.iDoktypbedingteretournierung.Value, Int32))
            DokTypBR.SelectOne()
            Me.DokumenttypNrBr = DokTypBR.iDokumenttypnr.Value
            Me.Load_Create_Dokument_Bedingte_Retournierung()

        Else
            docbr.cpMainConnectionProvider = conn
            docbr.sDokumentid = New SqlString(CType(doc.sBedRDokumentid.Value, String))
            docbr.SelectOne()
            DokTypBR.cpMainConnectionProvider = conn
            DokTypBR.iDokumenttypnr = New SqlInt32(CType(docbr.iDokumenttypnr.Value, Int32))
            DokTypBR.SelectOne()
            Me.Load_Edit_Document_Bedingte_Retournierung()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentbearbeitungsdialog")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            If Me.txtPartnerInhaberNr.Text > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()

        If f.PartnerNr <> 0 Then
            Me.txtZustelladresse.Text = f.zustelladresse
            Me.txtAnredeZusteller.Text = f.Anrede
            Me.txtZustelladresse.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        MenuItem2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.DokWertList.Columns("feldwert").Value = f.PartnerNr
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.COLD_Index_Sichern Method

Public Function COLD_Index_Sichern( _
   ByVal indextyp As Integer, _
   ByVal dokumentid As String _
) As DataTable

Parameters

indextyp
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function COLD_Index_Sichern(ByVal indextyp As Integer, ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Check_Dokumentersetzen Method

Private Function Check_Dokumentersetzen( _
   ByVal dokumenttypnr As Integer, _
   ByVal dokumentid As String, _
   Optional ByVal bOhneMSG As Boolean = False _
) As Boolean

Parameters

dokumenttypnr
Required.
dokumentid
Required.
bOhneMSG
Optional. Default value is False.

Source code

[Visual Basic]
    Private Function Check_Dokumentersetzen(ByVal dokumenttypnr As Integer, ByVal dokumentid As String, Optional ByVal bOhneMSG As Boolean = False) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentbearbeitung_chcek_dokumentersetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@errormessage", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            If bOhneMSG = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            End If
            sdaAdapter.Fill(dtToReturn)
            s = scmCmdToExecute.Parameters.Item("@errormessage").Value
            If s <> "" Then
                MyMsg.show_standardmessage(Val(s), MsgBoxStyle.Critical)
                Return False
            End If
            Return True
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Check_Dokumentfunktionen Method

Private Function Check_Dokumentfunktionen() As Boolean

Source code

[Visual Basic]
    Private Function Check_Dokumentfunktionen() As Boolean
        Dim i As Integer
        Dim zz As Integer
        Dim bearbeiten As Boolean
        Dim abschliessen As Boolean
        bearbeiten = False
        abschliessen = False
        Check_Dokumentfunktionen = True
        If Me.DokumentFunktionenList.Visible = False Then Exit Function
        zz = 0
        For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
            If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                If Me.DokumentFunktionen.Rows(i).Item("bearbeiten") = True Then bearbeiten = True
                If Me.DokumentFunktionen.Rows(i).Item("abschliessen") = True Then abschliessen = True
                zz = zz + 1
            End If
        Next

        If zz = 0 Then
            Check_Dokumentfunktionen = True
            Exit Function
        End If
        If bearbeiten = False Or abschliessen = False Then
            If bearbeiten = False Then
                MyMsg.show_standardmessage(34, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
            If abschliessen = False Then
                MyMsg.show_standardmessage(35, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Check_KopyDokumentZuErsetzten Method

Public Function Check_KopyDokumentZuErsetzten( _
   ByVal dokumenttypnr As Integer, _
   ByVal dokumentid As String, _
   ByVal sDokBez As String, _
   ByVal sDokErstelltAm As String _
) As Boolean

Parameters

dokumenttypnr
Required.
dokumentid
Required.
sDokBez
Required.
sDokErstelltAm
Required.

Source code

[Visual Basic]
    Public Function Check_KopyDokumentZuErsetzten(ByVal dokumenttypnr As Integer, ByVal dokumentid As String, ByVal sDokBez As String, ByVal sDokErstelltAm As String) As Boolean
        'Rel 3.5 / BUD
        If Check_Dokumentersetzen(dokumenttypnr, dokumentid, True) = True Then
            m_KopyDokErsetzten = True
            Check_KopyDokumentZuErsetzten = True
            m_KopyErsetzDokBez = sDokBez
            m_KopyErsetzDokDatum = sDokErstelltAm
        Else
            m_KopyDokErsetzten = False
            Check_KopyDokumentZuErsetzten = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Cold_Index_Bearbeiten Method

Public Sub Cold_Index_Bearbeiten( _
   ByVal indextyp As Integer, _
   ByVal dokumentid As String _
)

Parameters

indextyp
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten(ByVal indextyp As Integer, ByVal dokumentid As String)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp, dokumentid)
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Cold_Index_Bearbeiten_Bedingte_Retournierung Method

Public Sub Cold_Index_Bearbeiten_Bedingte_Retournierung( _
   ByVal indextyp As Integer, _
   ByVal dokumentid As String _
)

Parameters

indextyp
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten_Bedingte_Retournierung(ByVal indextyp As Integer, ByVal dokumentid As String)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp, dokumentid)
        xdata = Me.Dataset1BR.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu10_Popup Method

Private Sub ContextMenu10_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu10.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu10_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu10.Popup
        If Me.ErsetzenMoeglichbr = False Then
            Me.MenuItem11.Enabled = False
            Me.MenuItem12.Enabled = False
            Exit Sub
        End If
        Try
            If Me.coldlistbr.Splits(0).Rows.Count = 0 Then
                Me.MenuItem12.Enabled = False
            Else
                Me.MenuItem2.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.Notizen.Rows.Count = 0 Then
            Me.ContextMenu1.MenuItems(1).Enabled = False
            Me.ContextMenu1.MenuItems(2).Enabled = False
        Else
            Me.ContextMenu1.MenuItems(1).Enabled = True
            Me.ContextMenu1.MenuItems(2).Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        If Me.DokWertList.Columns("datenherkunft").Value = "" Then
            Me.MnuValueSelect.Enabled = False
        Else
            Me.MnuValueSelect.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        If Me.ZuordnungList.Splits(0).Rows.Count = 0 Then
            Me.MnuDokzuordnungDelete.Enabled = False
            Me.MnuShowDoc.Enabled = False
        Else
            Me.MnuDokzuordnungDelete.Enabled = True
            Me.MnuShowDoc.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu4_Popup Method

Private Sub ContextMenu4_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu4.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu4_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu4.Popup
        Try
            If Me.InfoMeldungList.Columns("typ").Value = 1 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
            If Me.InfoMeldungList.Splits(0).Rows.Count = 0 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        If Me.ErsetzenMoeglich = False Then
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
            Exit Sub
        End If
        Try
            If Me.ColdList.Splits(0).Rows.Count = 0 Then
                Me.MenuItem6.Enabled = False
            Else
                Me.MenuItem6.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Create_tmp_funktionen Method

Private Sub Create_tmp_funktionen()

Source code

[Visual Basic]
    Private Sub Create_tmp_funktionen()
        Dim i As Integer
        TMP_Funktion(1, 0, 0, 0, 0, 0)
        For i = 0 To Me.DataSet4.Tables(0).Rows.Count - 1
            TMP_Funktion(2, Me.DataSet4.Tables(0).Rows(i).Item(2), Me.DataSet4.Tables(0).Rows(i).Item(3), Me.DataSet4.Tables(0).Rows(i).Item(4), Me.DataSet4.Tables(0).Rows(i).Item(5), Me.DataSet4.Tables(0).Rows(i).Item(6))
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        If Me.On_Load Then Exit Sub
        Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DateTimePicker2_KeyDown Method

Private Sub DateTimePicker2_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles DateTimePicker2.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles DateTimePicker2.KeyDown
        If e.KeyCode = Keys.Delete Then
            Me.DateTimePicker2.ResetText()
            Me.DateTimePicker2.Value = System.DBNull.Value
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Datumselect_ValueChanged Method

Private Sub Datumselect_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Datumselect_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Set_Feldwert()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_AfterColEdit Method

Private Sub DokWertList_AfterColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DokWertList.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_AfterColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DokWertList.AfterColEdit
        'hutter 2005-01-28
        If Me.DokWertList.Columns("Validierungsregel").Text <> "" And Me.DokWertList.Col = 2 Then
            If Not DivFnkt.Check_Fieldvalue(Me.DokWertList.Columns("feldwert").Text, Me.DokWertList.Columns("Validierungsregel").Text) Then
                Me.validationerror = True
                Exit Sub
            End If
        End If
        Me.DokWertList.Update()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_AfterColUpdate Method

Private Sub DokWertList_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DokWertList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DokWertList.AfterColUpdate
        If Me.BedingteRetournierung = True Then
            For i = 0 To Me.DokWertListBR.Splits(0).Rows.Count - 1
                If Me.DokWertListBR.Columns("bezeichnung").CellText(i) = Me.DokWertList.Columns("Bezeichnung").Text Then
                    If Me.DokWertListBR.Columns("feldwert").CellText(i) = "" Or Me.DokWertList.Columns("Feldwert").Text = "" Then
                        Me.DokWertListBR.Bookmark = i
                        Me.DokWertListBR.Columns("feldwert").Text = Me.DokWertList.Columns("Feldwert").Text
                    End If
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_BeforeColEdit Method

Private Sub DokWertList_BeforeColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs _
) Handles DokWertList.BeforeColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_BeforeColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs) Handles DokWertList.BeforeColEdit
        Me.SaveBM = Me.DokWertList.Bookmark
        Me.validationerror = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_BeforeColUpdate Method

Private Sub DokWertList_BeforeColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles DokWertList.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_BeforeColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles DokWertList.BeforeColUpdate
        If InStr(Me.DokWertList.Columns("Datenherkunft").Text, "VV") > 0 Then
            If Len(Me.DokWertList.Columns("feldwert").Text) > 16 Then
                MyMsg.show_standardmessage(235, MsgBoxStyle.Critical)
                e.Cancel = True
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_Click Method

Private Sub DokWertList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokWertList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokWertList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokWertList_MouseDown Method

Private Sub DokWertList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokWertList.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokWertList.MouseUp
        '        Me.DokWertList.Bookmark = Me.DokWertList.RowContaining(e.Y)

        Select Case UCase(Me.DokWertList.Columns("feldtyp").Text)
            Case "JANEIN"
                Me.DokWertList.AllowUpdate = False
                If Me.DokWertList.Columns("Feldwert").Value = "Ja" Then
                    Me.DokWertList.Columns("Feldwert").Value = "Nein"
                Else
                    Me.DokWertList.Columns("Feldwert").Value = "Ja"
                End If
                If Me.DokWertList.Col < 3 Then Me.DokWertList.Col = 1
                'Me.DokWertList.Update()
            Case "01"
                Me.DokWertList.AllowUpdate = False
                If Me.DokWertList.Columns("Feldwert").Value = "1" Then
                    Me.DokWertList.Columns("Feldwert").Value = "0"
                Else
                    Me.DokWertList.Columns("Feldwert").Value = "1"
                End If
                'Me.DokWertList.Update()
            Case Else
                Me.DokWertList.AllowUpdate = True

        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokument_Bearbeiten Method

Private Sub Dokument_Bearbeiten( _
   ByVal neu As Boolean _
)

Parameters

neu
Required.

Source code

[Visual Basic]
    Private Sub Dokument_Bearbeiten(ByVal neu As Boolean)
        Try
            Globals.PerfMon.insert_entry("Start Dokumenterstellung/Bearbeitung")
            If Me.Dokument_Ist_Abgeschlossen Then
                Notizen_Sichern()
                Dokumentzuordnungen_Sichern()
                Dokumentinfomeldungen_Sichern()
                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                If Me.BedingteRetournierung = True Then
                    DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
                End If
                Me.Close()
                Globals.In_Bearbeitung = False
                Exit Sub
            End If
            'EDEX Banklagernd
            w.SaveBLDossier = Me.Use_BL_Status

            w.txtPartner = Me.txtPartnerInhaber.Text
            w.txtDokumenttyp = Me.txtBezeichnung.Text
            'w.ProgressBar.Info.Text = "Office-Dokument erstellen"
            w.ProgressBar.Show()
            w.ProgressBar.Bar1.Value = 5
            w.ProgressBar.Info.Text = "Dokumentdaten speichern"
            Application.DoEvents()
            w.txtBemerkung_Verantwortlicher = Me.txtBemerkungVerantwortlicher

            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim docvor As New edokadb.clsOffice_vorlage()

            'Dokumenttyp laden
            'OfficeVorlage laden
            docvor.cpMainConnectionProvider = conn
            docvor.iOffice_vorlagenr = New SqlInt32(CType(Doktyp.iOffice_vorlagenr.Value, Int32))
            docvor.SelectOne()

            'Dokument erstellen
            doc.cpMainConnectionProvider = conn
            If Me.CreateDocument Then
                doc.sDokumentid = New SqlString(CType(NewDokumentID, String))
                DivFnkt.Status_Dokumentbearbeitung(1, doc.sDokumentid.Value, True, "")
            Else
                doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
                doc.SelectOne()
                'DivFnkt.Status_Dokumentbearbeitung(1, doc.sDokumentid.Value, False, "")
            End If

            doc.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
            doc.iNrpar00 = New SqlInt32(CType(Me.txtPartnerInhaberNr.Text, Int32))
            doc.bAktiv = New SqlBoolean(True)
            doc.bAmsdokument = New SqlBoolean(CType(False, Boolean))
            doc.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
            doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.daArchivierungsdatum = New SqlDateTime(CType(Me.DateTimePicker3.Value, DateTime))
            doc.iStatus_edoka_batch_ausgang = Nothing

            If Me.DateTimePicker2.Value Is System.DBNull.Value Then
                doc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
            Else
                doc.daTermin = New SqlDateTime(CType(Me.DateTimePicker2.Value, DateTime))
            End If

            doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
            'Hutter - anpassungen
            If Me.mcbstatus.Text = "Bereit für Ausgangsarchivierung" Then
                doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
            End If
            doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.bGesperrt = New SqlBoolean(CType(Me.cGesperrt.Checked, Boolean))
            If Me.cGesperrt.Checked Then
                doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
            End If
            doc.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
            doc.bZu_retournieren = New SqlBoolean(CType(Doktyp.bZu_retournieren.Value, Boolean))
            doc.iColdstatus = New SqlInt32(CType(0, Int32))
            doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            If neu = True Then
                doc.iErsteller = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iErstellerteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daErstelltam = New SqlDateTime(CType(Now, DateTime))
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutiererteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
                If Globals.bckdokument Then
                    doc.iBck = New SqlInt32(CType(1, Int32))
                Else
                    doc.iBck = New SqlInt32(CType(1, Int32))
                End If
                doc.iAufbewahrung_elektronisch = New SqlInt32(CType(Doktyp.iAufbewahrungsfrist_elektronisch.Value, Int32))
                doc.iAufbewahrung_phaysisch = New SqlInt32(CType(Doktyp.iAufbewahrungsfrist_physisch.Value, Int32))
                doc.iBearbeitung_nach_abschluss = New SqlInt32(CType(Doktyp.iTage_mutation.Value, Int32))
                doc.iBearbeitungszeit_in_minuten = New SqlInt32(CType(Doktyp.iDbearbeitungszeit.Value, Int32))
                doc.iMonierung_in_tagen = New SqlInt32(CType(Doktyp.iAnzahl_tage.Value, Int32))
            Else
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
            End If

            doc.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
            doc.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
            doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
            doc.bVertraulich = New SqlBoolean(CType(Me.cvertraulich.Checked, Boolean))
            doc.sZustelladresse = New SqlString(CType(Me.txtZustelladresse.Text, String))
            doc.sAnredezustelladresse = New SqlString(CType(Me.txtAnredeZusteller.Text, String))

            If Me.rbZustaendigKube.Checked Then
                doc.iZustaendiger = New SqlInt32(CType(Me.mcbkube.SelectedValue, Int32))
            Else
                doc.iZustaendiger = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
            End If
            doc.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
            doc.bZustaendig_kube = New SqlBoolean(CType(Me.rbZustaendigKube.Checked, Boolean))
            If Me.cGesperrt.Checked Then
                doc.iGesperrt_durch = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
            Else
                doc.iGesperrt_durch = New SqlInt32(CType(0, Int32))
            End If
            doc.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            doc.sColddokumentid = New SqlString(CType("", String))
            doc.iAnzeigeStatus = New SqlInt32(CType(0, Int32))

            doc.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))

            If Not Me.CreateDocument Then
                doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
            End If

            doc.daErstellungsdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
            '        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))

            If docvor.iAnwendungnr.Value = 1 Then
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".doc", String))
            Else
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".xls", String))
            End If

            If Me.CreateDocument Then doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
                Dim tx As DataTable
                tx = Generic_Select(13)
                If tx.Rows(0).Item(0) = 1 Then
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
                Else
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
                End If
                tx.Dispose()
            End If

            Dim s As String

            s = DivFnkt.Get_Filename(doc.sDokumentname.Value, Me.txtPartnerInhaberNr.Text)
            conn.OpenConnection()
            If Me.CreateDocument Then
                Dim t As DataTable
                t = Generic_Select(14)
                doc.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
                doc.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
                Try
                    doc.Insert()
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try

                t.Dispose()
                Dim statush As New Statushandling()
                statush.Status_Erstellen(doc.sDokumentid.Value, Me.Use_BL_Status)
                statush.Dispose()
                doc.iStatusnr = New SqlInt32(CType(get_current_Status(doc.sDokumentid.Value), Int32))
                If Me.BedingteRetournierung = True Then
                    doc.sBedRDokumentid = New SqlString(CType(Me.DokumentIDBR, String))
                    doc.bBedRRetourniert = New SqlBoolean(CType(False, Boolean))
                Else
                    doc.sBedRDokumentid = New SqlString(CType("", String))
                    'doc.bBedRRetourniert = New SqlBoolean(CType(False, Boolean))
                End If

                'EDEX Banklagernd
                If Me.Use_BL_Status Then
                    doc.bBl_scan = New SqlBoolean(CType(True, Boolean))
                    doc.bBldossier = New SqlBoolean(CType(True, Boolean))
                Else
                    doc.bBl_scan = New SqlBoolean(CType(False, Boolean))
                    doc.bBldossier = New SqlBoolean(CType(False, Boolean))
                End If

                doc.Update()
                conn.CloseConnection(True)
                If Me.BedingteRetournierung = True Then Insert_Update_Bedingte_Retournierung(True)
            Else
                If Me.BedingteRetournierung = True Then
                    doc.sBedRDokumentid = New SqlString(CType(Me.DokumentIDBR, String))
                    doc.bBedRRetourniert = New SqlBoolean(CType(False, Boolean))
                Else
                    doc.sBedRDokumentid = New SqlString(CType("", String))
                    doc.bBedRRetourniert = New SqlBoolean(CType(False, Boolean))
                End If
                'EDEX Banklagernd
                If doc.bBldossier.Value = True Then
                    doc.bBl_scan = New SqlBoolean(CType(True, Boolean))
                    w.SaveBLDossier = True
                End If
                doc.Update()
                DivFnkt.Journal_Dokumentzugriff(Me.DokumentID, "Bearbeiten", 0, 0, "", "")
                conn.CloseConnection(True)
                If Me.BedingteRetournierung = True Then Insert_Update_Bedingte_Retournierung(False)
            End If
            'conn.CloseConnection(True)

            DokumentID = doc.sDokumentid.Value
            'If Globals.bckdokument = True Then
            '    Cold_Index_Bearbeiten(2, DokumentID)
            'Else
            '    If Not Me.Use_BL_Status = True Then
            '        Cold_Index_Bearbeiten(1, DokumentID)
            '        If Me.zu_retournieren Then
            '            Cold_Index_Bearbeiten(2, DokumentID)
            '        End If
            '    Else
            '        If Me.zu_retournieren = False Then
            '            Cold_Index_Bearbeiten(2, DokumentID)
            '        Else
            '            Cold_Index_Bearbeiten(1, DokumentID)
            '            Cold_Index_Bearbeiten(2, DokumentID)
            '        End If
            '    End If

            'End If
            If Globals.bckdokument = True Then
                Cold_Index_Bearbeiten(2, DokumentID)
            Else
                Cold_Index_Bearbeiten(1, DokumentID)
                If Me.zu_retournieren Then
                    Cold_Index_Bearbeiten(2, DokumentID)
                End If
            End If

            Globals.PerfMon.insert_entry("'-- Begin Dokumentdaten sichern")
            DokumentID = doc.sDokumentid.Value
            Dokumentwerte_Sichern()
            w.ProgressBar.Bar1.Value = 7
            w.ProgressBar.Info.Text = "Dokumentdaten speichern "
            Notizen_Sichern()
            Dokumentzuordnungen_Sichern()
            Dokumentersetzen_Sichern()
            Dokumentinfomeldungen_Sichern()
            w.ProgressBar.Bar1.Value = 9
            w.ProgressBar.Info.Text = "Dokumentdaten speichern "
            Dokumentfunktionen_sichern()
            Status_History(doc.iStatusnr.Value, DokumentID)
            Globals.PerfMon.insert_entry("'-- Ende Dokumentdaten sichern")
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.ProgressBar.Show()
                w.ProgressBar.Bar1.Value = 11
                w.ProgressBar.Info.Text = "Dokumentwerte zusammenstellen"
            End If
            Globals.PerfMon.insert_entry("'-- Begin Dokumentwerte zusammenstellen")
            Dim xdata As DataTable
            xdata = Dokumentwerte(doc.sDokumentid.Value)
            Globals.PerfMon.insert_entry("'--Ende Dokumentwerte zusammenstellen")
            DokumentID = doc.sDokumentid.Value

            'Dokument erstellen bzw. öffnen
            w.DokumentID = doc.sDokumentid.Value
            If Me.BedingteRetournierung = True Then w.Dokumentidbr = Me.DokumentIDBR Else w.Dokumentidbr = ""
            w.DokumentName = doc.sDokumentname.Value
            If Me.CreateDocument Then
                DivFnkt.TraceLog("Vor Dokumenterstellung")
                w.CreateDoc = True
                If Me.BarcodeID = "" Then
                    If w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s, m_KopyDokID) = False Then
                        w.ProgressBar.Visible = False
                        w.Restore(1)
                        Me.Cursor = Cursors.Default
                        Me.btnWeiter.Enabled = True
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                        If Me.BedingteRetournierung = True Then
                            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
                        End If
                        Exit Sub
                    End If
                End If
                DivFnkt.TraceLog("Nach Dokumenterstellung")
            Else
                If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                    w.CreateDoc = False
                    Dim docrestore As New DocMgmt()
                    docrestore.Get_From_DB(DokumentID, s)
                    w.Open_Document(s, xdata, doc.iDokumenttypnr.Value)
                End If
            End If
            Me.Hide()

            If Globals.Dokumentcoldindex_Changed Then
                w.dokumentidalt = Globals.Dokumentidalt
                w.save_dokumentcoldindex = Globals.general_ds.Tables(Globals.general_ds.Tables.Count - 1).Copy
                w.Dokumentcoldindex_Changed = Globals.Dokumentcoldindex_Changed
                w.dokumentid_changed = Globals.dokumentid_changed
                w.dokumentcoldindex_status = Globals.dokumentcoldindex_status
                w.Ersetzte_Dokumente_Reaktivieren = Globals.Ersetzte_Dokumente_Reaktivieren
            End If
            If Me.BedingteRetournierung = True Then
                If Globals.DokumentColdIndex_ChangedBR Then
                    w.dokumentidaltbr = Globals.Dokumentidaltbr
                    w.save_dokumentcoldindexbr = Globals.general_dsbr.Tables(Globals.general_dsbr.Tables.Count - 1).Copy
                    w.Dokumentcoldindex_changedbr = Globals.DokumentColdIndex_ChangedBR
                    w.dokumentid_changedbr = Globals.dokumentid_changedbr
                    w.dokumentcoldindex_statusbr = Globals.Dokumentcoldindex_statusbr
                    w.Ersetzte_Dokumente_Reaktivierenbr = Globals.ersetzte_dokumente_reaktivierenbr
                End If
            End If

            'Anzeigen der Dokumentwerte, sofern die Checkbox markiert war
            If Me.cdokumentwerteanzeigen.Checked Then
                Globals.PerfMon.insert_entry("'-- Begin Dokumentwerte anzeigen")
                Dim f As New frmDokumentwerte()
                f.WordData = xdata
                f.isOk = True
                Me.Cursor = System.Windows.Forms.Cursors.Default
                f.ShowDialog()
                Globals.PerfMon.insert_entry("'-- Ende Dokumentwerte anzeigen")
                If f.isOk = 0 Then
                    f.Dispose()
                    w.CloseDoc()
                    w.ProgressBar.Close()
                    If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                    DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                    If Me.BedingteRetournierung = True Then
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
                    End If
                    Dim objword As New Word.ApplicationClass()
                    Try
                        objword = GetObject(, "Word.application")
                        objword.Visible = True
                    Catch
                    End Try
                    objword = Nothing
                Else
                    If f.isOk = 1 Then
                        f.Dispose()
                        w.Dokument_Vervollstaendigen(xdata)
                        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokumentbearbeitung")
                        If Me.CreateDocument Then
                            'DivFnkt.Status_Dokumentbearbeitung(1, Me.DokumentID, True, w.DokumentName)
                        End If
                        Words.Add(w, w.DokumentName)
                    Else
                        If f.isOk = 2 Then
                            f.Dispose()
                            If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                            If Me.BedingteRetournierung = True Then
                                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
                            End If

                            Me.CreateDocument = False
                            Me.btnWeiter.Enabled = True
                            Me.Show()
                        End If
                    End If
                End If
            Else
                If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                    DivFnkt.TraceLog("Vor Dokument vervollständigen")
                    w.Dokument_Vervollstaendigen(xdata)
                    DivFnkt.TraceLog("Nach Dokument vervollständigen")
                    Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokumentbearbeitung")
                    If Me.CreateDocument Then
                        'DivFnkt.Status_Dokumentbearbeitung(1, Me.DokumentID, True, w.DokumentName)
                    End If
                    Words.Add(w, w.DokumentName)
                Else
                    If Not Me.Dokumentinfobearbeiten = True Then
                        Update_Bclabel(1)
                    End If
                    DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                    If Me.BedingteRetournierung = True Then
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
                    End If

                End If
            End If
            xdata.Dispose()
            doc.Dispose()
            Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Dokumenterstellung")
            Try
                w.ProgressBar.Close()
                w.ProgressBar.Dispose()
            Catch
            End Try
        Catch ex As Exception
            w.Close_And_Destroy()
            Dim s As String
            Globals.In_Bearbeitung = False
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, True, w.DokumentName)
            s = Globals.MyTxt.gettext(98)
            s = s + vbCrLf + vbCrLf + ex.Message
            MsgBox(s, MsgBoxStyle.Critical)
            PerfMon.force_insert_entry("Dok (N): " + ex.Message + "-" + " " + Me.Dokumenttypnr.ToString + " " + Me.txtBezeichnung.Text + " " + Me.txtPartnerInhaber.Text + ": ")
            PerfMon.force_insert_entry("Dok (N): Wordlib Errormessage: " + w.Errormessage)
            w.ProgressBar.Visible = False
            Me.Cursor = Cursors.Default
            If Me.CreateDocument Then w.Restore(1) Else w.Restore(2)
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            If Me.BedingteRetournierung = True Then
                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
            End If
            Me.Cursor = Cursors.Default
            Me.btnWeiter.Enabled = True
            Me.Visible = True
            Try
                conn.CloseConnection(True)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentersetzen_Laden Method

Private Function Dokumentersetzen_Laden( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentersetzen_Laden(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentersetzen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentersetzen_Sichern Method

Public Sub Dokumentersetzen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentersetzen_Sichern()
        For i = 0 To Me.Dokumentersetzen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentersetzen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("coldstatus")))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Ersetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentersetzen_Sichern_Bedingte_Retournierung Method

Public Sub Dokumentersetzen_Sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Dokumentersetzen_Sichern_Bedingte_Retournierung()
        For i = 0 To Me.Dokumentersetzenbr.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentersetzen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzenbr.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentIDBR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzenbr.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzenbr.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzenbr.Rows(i).Item("coldstatus")))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Ersetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentfunktionen_Aktivieren Method

Private Sub Dokumentfunktionen_Aktivieren()

Source code

[Visual Basic]
    Private Sub Dokumentfunktionen_Aktivieren()
        Dim t As DataTable
        t = Generic_Select(5)
        If t.Rows.Count > 0 Then
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlDataAdapter3.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            '            Me.Funktionsliste.DataSource = Me.DataSet3
            '           Me.Funktionsliste.DataMember = Me.DataSet3.Tables(0).TableName

            t.Clear()
            Me.DokumentFunktionen = Generic_Select(6)
            w.Save_DokumentFunktionen = Me.DokumentFunktionen
            'w.Save_DokumentFunktionen = Generic_Select(6)
            Me.DataSet4.Tables.Add(Me.DokumentFunktionen)
            Me.DokumentFunktionenList.DataSource = Me.DataSet4
            Me.DokumentFunktionenList.DataMember = Me.DataSet4.Tables(0).TableName
            Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
            Me.DokumentFunktionenList.FilterBar = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Me.DokumentFunktionen, "berechtigungseinschraenkung")

        Else
            Me.pnlBerechtigungen.Visible = False
            Me.pnlBerechtigungenBR.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentfunktionen_AktivierenBR Method

Private Sub Dokumentfunktionen_AktivierenBR()

Source code

[Visual Basic]
    Private Sub Dokumentfunktionen_AktivierenBR()
        Dim t As DataTable
        t = Generic_Select(5)
        If t.Rows.Count > 0 Then
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlDataAdapter3.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            '            Me.Funktionsliste.DataSource = Me.DataSet3
            '           Me.Funktionsliste.DataMember = Me.DataSet3.Tables(0).TableName

            t.Clear()
            Me.DokumentFunktionenbr = Generic_Select(106)
            w.Save_DokumentFunktionenbr = Me.DokumentFunktionenbr
            '            w.Save_DokumentFunktionenbr = Generic_Select(106)
            Me.DataSet5.Tables.Add(Me.DokumentFunktionenbr)
            Me.DokumentFunktionenListBR.DataSource = Me.DataSet5
            Me.DokumentFunktionenListBR.DataMember = Me.DataSet5.Tables(0).TableName
            Me.DokumentFunktionenListBR.Columns("aktiv").FilterText = True
            Me.DokumentFunktionenListBR.FilterBar = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenListBR, Me.DokumentFunktionenbr, "berechtigungseinschraenkung")
        Else
            Me.pnlBerechtigungen.Visible = False
            Me.pnlBerechtigungen.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentfunktionen_sichern Method

Public Sub Dokumentfunktionen_sichern()

Source code

[Visual Basic]
    Public Sub Dokumentfunktionen_sichern()
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentfunktionen_Sichern"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@funktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("anzeigen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("bearbeiten")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("loeschen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("abschliessen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("aktiv")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentfunktionen_sichern_Bedingte_Retournierung Method

Public Sub Dokumentfunktionen_sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Dokumentfunktionen_sichern_Bedingte_Retournierung()
        Try
            For i = 0 To Me.DokumentFunktionenbr.Rows.Count - 1
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentfunktionen_Sichern"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentIDBR))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("dokumentfunktiongruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@funktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("funktionsgruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("anzeigen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("bearbeiten")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("loeschen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("abschliessen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionenbr.Rows(i).Item("aktiv")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            Next
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentinfomeldungen_Sichern Method

Public Sub Dokumentinfomeldungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentinfomeldungen_Sichern()
        For i = 0 To Me.DokumentInfoMeldungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("typ")))

                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentinfomeldungen_Sichern_Bedingte_Retournierung Method

Public Sub Dokumentinfomeldungen_Sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Dokumentinfomeldungen_Sichern_Bedingte_Retournierung()
        For i = 0 To Me.DokumentInfoMeldungenbr.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungenbr.Rows(i).Item("typ")))

                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentinfomeldungen_laden_Bedingte_Retournierung Method

Private Function Dokumentinfomeldungen_laden_Bedingte_Retournierung( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden_Bedingte_Retournierung(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokTypBR.iDokumenttypnr.Value))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokumentwertListe_laden Method

Private Function DokumentwertListe_laden( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function DokumentwertListe_laden(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokumentwertListe_ladenbr Method

Private Function DokumentwertListe_ladenbr( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function DokumentwertListe_ladenbr(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokTypBR.iDokumenttypnr.Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentwerte Method

Private Function Dokumentwerte( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentwerte(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentwerte_Sichern Method

Public Sub Dokumentwerte_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern()
        Dim xdata As DataTable
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentwerte_Sichern_Bedingte_Retournierung Method

Public Sub Dokumentwerte_Sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern_Bedingte_Retournierung()
        Dim xdata As DataTable
        xdata = Me.Dataset1BR.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentIDBR))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden( _
   ByVal dokumentid As String _
)

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden(ByVal dokumentid As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentzuordnungen_Sichern Method

Public Sub Dokumentzuordnungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentzuordnungen_Sichern()
        For i = 0 To Me.Dokumentzuorndungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("NrEintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("DOKUMENTID2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("AKTIV")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Dokumentzuordnungen_Sichern_Bedingte_Retournierung Method

Public Sub Dokumentzuordnungen_Sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Dokumentzuordnungen_Sichern_Bedingte_Retournierung()
        For i = 0 To Me.Dokumentzuorndungenbr.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungenbr.Rows(i).Item("NrEintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungenbr.Rows(i).Item("DOKUMENTID2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungenbr.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungenbr.Rows(i).Item("AKTIV")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.DokwertList_RowColChange Method

Private Sub DokwertList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokWertList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokwertList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokWertList.RowColChange
        Try
            Me.DokWertList.Columns("feldwert").EditMask = Me.DokWertList.Columns("eingabeformat").Value
            Me.DokWertList.Columns("feldwert").EditMaskUpdate = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()
        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String
        s = ""
        Try
            For I = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(I).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(I).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            'hutter 29.10.2003
            If s <> "" Then Create_tmp_funktionen()
            If Me.cvertraulich.Checked = True Then
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 1, s)
            Else
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 0, s)
            End If
            If s <> "" Then delete_tmp_funktionen()
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch ex As Exception
            'MsgBox(ex.Message)
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Formular_Laden_Create_Document Method

Private Sub Formular_Laden_Create_Document()

Source code

[Visual Basic]
    Private Sub Formular_Laden_Create_Document()
        NewDokumentID = DivFnkt.Generate_Key()

        Load_Defaults()
        w.save_historystatus = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Formular_laden_Edit_Document Method

Private Sub Formular_laden_Edit_Document()

Source code

[Visual Basic]
    Private Sub Formular_laden_Edit_Document()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        doc.SelectOne()
        doc.cpMainConnectionProvider = conn
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        NewDokumentID = Me.EditDokumentid
        Me.Partnernr = doc.iNrpar00.Value
        doc.SelectOne()
        conn.CloseConnection(True)
        w.Save_Dokument = doc.SelectOne
        Me.Dokumenttypnr = doc.iDokumenttypnr.Value
        DokumentID = doc.sDokumentid.Value
        Load_Defaults()

        ' Bedingte Retournierung
        ' SHU 03.03.2004
        ' Bedingte Retournierung ausschalten, sofern beim auslöserdokument keine Dokumentid vorhanden ist
        Try
            If doc.sBedRDokumentid.Value Is System.DBNull.Value Then
            Else
                If Me.BedingteRetournierung = True And doc.sBedRDokumentid.Value = "" Then Me.BedingteRetournierung = False
            End If
        Catch
        End Try
        'Bedingte Retournierung Ende

        'Parnter laden
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = doc.iNrpar00
        p.SelectOne()
        Me.txtPartnerInhaber.Text = Str(p.iNRPAR00.Value) + " " + p.sBKPAR00.Value
        Me.txtPartnerInhaberNr.Text = p.iNRPAR00.Value
        Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(p.iNRPAR00.Value)
        If p.sCDVIG00.Value = "Y" Or p.iAZEPL00.Value > 1 Or p.bCDVSA00.Value = True Then Me.VIBeachten = True Else Me.VIBeachten = False
        p.Dispose()

        ii = doc.iPostzustellung.Value
        Me.mcbpostzustellung.SelectedValue = ii
        If doc.bZustaendig_kube.Value = True Then
            ii = doc.iZustaendiger.Value
            Me.mcbkube.SelectedValue = ii
        Else
            ii = doc.iZustaendiger.Value
            Me.mcbzust.SelectedValue = ii
        End If
        ii = doc.iVerantwortlich.Value
        'Prüfung, sofern akt. verantwortlicher = MA-Systemuser, dann aktueller Mitarbeiter setzen
        If ii > 9950 Then
            ii = Globals.MitarbeiterNr
        End If
        Me.mcbverantwortlich.SelectedValue = ii
        Me.saveverantwortlicher = ii
        w.save_verantwortlicher = ii

        Me.savestatus = doc.iStatusnr.Value

        ii = doc.iUnterschriftlinks.Value
        Me.mcbunterschriftlinks.SelectedValue = ii
        ii = doc.iUnterschriftrechts.Value
        Me.mcbunterschriftrechts.SelectedValue = ii

        Me.cGesperrt.Checked = doc.bGesperrt.Value = True
        Me.txtBemerkung.Text = doc.sBemerkung.Value
        Me.txtBezeichnung.Text = doc.sBezeichnung.Value
        Me.rbZustaendigKube.Checked = doc.bZustaendig_kube.Value = True
        Me.cvertraulich.Checked = doc.bVertraulich.Value = True
        Me.txtZustelladresse.Text = doc.sZustelladresse.Value
        Me.txtAnredeZusteller.Text = doc.sAnredezustelladresse.Value
        Me.RBZustaendigZustaendiger.Checked = doc.bZustaendig_kube.Value = False
        Me.teamzustaendig = doc.iZustaendiger.Value
        Me.refresh_team()
        Try
            Me.mcbteam.SelectedValue = doc.iMutierertieam.Value
        Catch
            Me.mcbteam.SelectedIndex = 0
        End Try
        Try
            Me.DateTimePicker1.Value = doc.daErstellungsdatum.Value
        Catch
            Me.DateTimePicker1.Value = Now
        End Try

        Try
            Me.DateTimePicker3.Value = doc.daArchivierungsdatum.Value
        Catch
            Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
        End Try

        Try
            If doc.daTermin.Value = "01.01.1900" Then
                Me.DateTimePicker2.ResetText()
                Me.DateTimePicker2.Value = System.DBNull.Value
            Else
                Me.DateTimePicker2.Value = doc.daTermin.Value
            End If
        Catch
            Me.DateTimePicker2.Value = System.DBNull.Value
        End Try

        doc.Dispose()

        Me.Dokumentersetzen = Dokumentersetzen_Laden(Me.DokumentID)
        w.save_dokumentersetzen = Me.Dokumentersetzen
        'w.save_dokumentersetzen = Dokumentersetzen_Laden(Me.DokumentID)

        Me.ColdList.DataSource = Me.Dokumentersetzen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")

        Me.Notizen = Notizen_Laden(Me.DokumentID)
        w.Save_Notizen = Me.Notizen
        '        w.Save_Notizen = Notizen_Laden(Me.DokumentID)
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        w.Save_Dokumentwerte = Generic_Select(10)
        Me.DataSet1.Clear()
        Me.DataSet1.Tables.Clear()
        Me.DataSet1.Tables.Add(DokumentwertListe_laden(Me.DokumentID))
        'hutter 2005-01-28
        DivFnkt.Bezeichnung_Feldwert(Me.DataSet1.Tables(0), False)

        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160
        conn.CloseConnection(True)

        w.Save_ColdIndex = Generic_Select(9)
        Me.TabControl2.Enabled = True

        Dim tmp As DataTable
        tmp = Generic_Select(12)
        w.save_historystatus = tmp.Rows(0).Item(0)
        tmp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_DokWertList"
            Case 2
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Notizen"
            Case 5
                scmCmdToExecute.CommandText = "sp_funktion_zuweisung_gestattet"
            Case 6
                scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
            Case 7
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
            Case 8
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_kube"
            Case 9
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 10
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 11
                scmCmdToExecute.CommandText = "sp_dokument_als_bcdokument"
            Case 12
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 13
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case 14
                scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case 15
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 16
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case 106
                scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
            Case 109
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 110
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 112
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 114
                scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@regel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokWertList.Columns("datenherkunft").Value))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    If Me.DokumentID = Nothing Then Me.DokumentID = ""
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    If Me.CreateDocument = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    If Globals.bckdokument = False Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    End If
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentID))
                Case 7
                    If Me.teamzustaendig = Globals.MitarbeiterNr Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.teamzustaendig))
                    End If
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                Case 9
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 16
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case 106
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentIDBR))
                Case 110
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                Case 109
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                Case 112
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentIDBR))
                Case 114
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))

                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles InfoMeldungList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles InfoMeldungList.FetchRowStyle
        Try
            If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
                e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentbearbeitung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines8 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines9 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines10 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines11 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines12 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines13 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet4 = New System.Data.DataSet()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.DokWertList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MnuValueSelect = New System.Windows.Forms.MenuItem()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RBZustaendigZustaendiger = New System.Windows.Forms.RadioButton()
        Me.rbZustaendigKube = New System.Windows.Forms.RadioButton()
        Me.cbzust = New System.Windows.Forms.ComboBox()
        Me.cbKube = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.cbPostzustellung = New System.Windows.Forms.ComboBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.mnuInfoEmpfaengerAdd = New System.Windows.Forms.MenuItem()
        Me.mnuInfoEmpfaengerDelete = New System.Windows.Forms.MenuItem()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.ZuordnungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokZuordnungAdd = New System.Windows.Forms.MenuItem()
        Me.MnuDokzuordnungDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker2 = New C1.Win.C1Input.C1DateEdit()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TabPage5 = New System.Windows.Forms.TabPage()
        Me.pnlBerechtigungen = New System.Windows.Forms.GroupBox()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.cvertraulich = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.cGesperrt = New System.Windows.Forms.CheckBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.GroupBox11 = New System.Windows.Forms.GroupBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtAnredeZusteller = New System.Windows.Forms.TextBox()
        Me.txtZustelladresse = New System.Windows.Forms.TextBox()
        Me.TabPage7 = New System.Windows.Forms.TabPage()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage8 = New System.Windows.Forms.TabPage()
        Me.GroupBox16 = New System.Windows.Forms.GroupBox()
        Me.txtbezeichnungbr = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.bemerkungbr = New System.Windows.Forms.TextBox()
        Me.GroupBox17 = New System.Windows.Forms.GroupBox()
        Me.DokWertListBR = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu14 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.TabPage9 = New System.Windows.Forms.TabPage()
        Me.GroupBox13 = New System.Windows.Forms.GroupBox()
        Me.InFoMeldungListBR = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu9 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.GroupBox14 = New System.Windows.Forms.GroupBox()
        Me.ZuordnunglistBR = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu11 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.GroupBox15 = New System.Windows.Forms.GroupBox()
        Me.coldlistbr = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu10 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.TabPage10 = New System.Windows.Forms.TabPage()
        Me.pnlBerechtigungenBR = New System.Windows.Forms.GroupBox()
        Me.DokumentFunktionenListBR = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu13 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.GroupBox18 = New System.Windows.Forms.GroupBox()
        Me.Button3Br = New System.Windows.Forms.Button()
        Me.cVertraulichBR = New System.Windows.Forms.CheckBox()
        Me.Label18BR = New System.Windows.Forms.Label()
        Me.cGesperrtBR = New System.Windows.Forms.CheckBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.GroupBox19 = New System.Windows.Forms.GroupBox()
        Me.Notizlistbr = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu12 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.txtPartnerInhaberNr = New System.Windows.Forms.TextBox()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cdokumentwerteanzeigen = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.cbsave = New System.Windows.Forms.ComboBox()
        Me.cbmoeglicheStati = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtstatus = New System.Windows.Forms.Label()
        Me.btntxtBemerkung = New System.Windows.Forms.Button()
        Me.LabelVIBeachten = New System.Windows.Forms.Label()
        Me.PicVIBeachten = New System.Windows.Forms.PictureBox()
        Me.Dataset1BR = New System.Data.DataSet()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.DataSet5 = New System.Data.DataSet()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.GroupBox12.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.TabPage4.SuspendLayout()
        Me.GroupBox7.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox6.SuspendLayout()
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox5.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage5.SuspendLayout()
        Me.pnlBerechtigungen.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox9.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox11.SuspendLayout()
        Me.TabPage7.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPage8.SuspendLayout()
        Me.GroupBox16.SuspendLayout()
        Me.GroupBox17.SuspendLayout()
        CType(Me.DokWertListBR, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage9.SuspendLayout()
        Me.GroupBox13.SuspendLayout()
        CType(Me.InFoMeldungListBR, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox14.SuspendLayout()
        CType(Me.ZuordnunglistBR, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox15.SuspendLayout()
        CType(Me.coldlistbr, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage10.SuspendLayout()
        Me.pnlBerechtigungenBR.SuspendLayout()
        CType(Me.DokumentFunktionenListBR, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox18.SuspendLayout()
        Me.GroupBox19.SuspendLayout()
        CType(Me.Notizlistbr, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Dataset1BR, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(696, 472)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(104, 23)
        Me.btnWeiter.TabIndex = 16
        Me.btnWeiter.Text = "&Weiter>>"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(40, 472)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(104, 23)
        Me.btnCancel.TabIndex = 17
        Me.btnCancel.Text = "&Abbruch"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "SP_Dokumentbearbeitung_Dokumentwerte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("Feldwert", "Feldwert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[SP_Dokumentbearbeitung_Dokumentwerte]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentid", System.Data.SqlDbType.VarChar, 20))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@CreateNew", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Postzustellung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nreintrag", "nreintrag"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_postzustellung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_postzustellung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_postzustellung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_postzustellung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_funktionsgruppe_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_funktionsgruppe_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_funktionsgruppe_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_funktionsgruppe_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage3, Me.TabPage4, Me.TabPage5, Me.TabPage1, Me.TabPage7})
        Me.TabControl2.Enabled = False
        Me.TabControl2.Location = New System.Drawing.Point(8, 112)
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(800, 352)
        Me.TabControl2.TabIndex = 11
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox12, Me.GroupBox10, Me.GroupBox3, Me.GroupBox1, Me.GroupBox2})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(792, 326)
        Me.TabPage3.TabIndex = 0
        Me.TabPage3.Text = "Dokumentinhalt"
        '
        'GroupBox12
        '
        Me.GroupBox12.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox12.Location = New System.Drawing.Point(8, 272)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox12.TabIndex = 37
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Team"
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(128, 16)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(232, 21)
        Me.cbteam.TabIndex = 0
        '
        'GroupBox10
        '
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokWertList})
        Me.GroupBox10.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(400, 312)
        Me.GroupBox10.TabIndex = 38
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Dokumentspezifisch"
        '
        'DokWertList
        '
        Me.DokWertList.AllowFilter = False
        Me.DokWertList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokWertList.AllowSort = False
        Me.DokWertList.AlternatingRows = True
        Me.DokWertList.CaptionHeight = 17
        Me.DokWertList.CollapseColor = System.Drawing.Color.Black
        Me.DokWertList.ContextMenu = Me.ContextMenu2
        Me.DokWertList.DataChanged = False
        Me.DokWertList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokWertList.ExpandColor = System.Drawing.Color.Black
        Me.DokWertList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokWertList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokWertList.Location = New System.Drawing.Point(8, 16)
        Me.DokWertList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokWertList.Name = "DokWertList"
        Me.DokWertList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokWertList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokWertList.PreviewInfo.ZoomFactor = 75
        Me.DokWertList.PrintInfo.ShowOptionsDialog = False
        Me.DokWertList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokWertList.RowDivider = GridLines1
        Me.DokWertList.RowHeight = 15
        Me.DokWertList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokWertList.ScrollTips = False
        Me.DokWertList.Size = New System.Drawing.Size(384, 288)
        Me.DokWertList.TabIndex = 0
        Me.DokWertList.Text = "C1TrueDBGrid1"
        Me.DokWertList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 380, 284</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defau" & _
        "ltRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 380, 284</ClientArea></Bl" & _
        "ob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuValueSelect})
        '
        'MnuValueSelect
        '
        Me.MnuValueSelect.Index = 0
        Me.MnuValueSelect.Text = "&Wert auswählen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbUnterschriftrechts, Me.cbUnterschriftlinks, Me.Label8, Me.Label7})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 184)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox3.TabIndex = 36
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Unterschrift"
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(128, 43)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftrechts.TabIndex = 1
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(128, 19)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftlinks.TabIndex = 0
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 48)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 3
        Me.Label8.Text = "Unterschrift rechts"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 24)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 2
        Me.Label7.Text = "Unterschrift links"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBZustaendigZustaendiger, Me.rbZustaendigKube, Me.cbzust, Me.cbKube})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 96)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox1.TabIndex = 35
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zuständigkeit"
        '
        'RBZustaendigZustaendiger
        '
        Me.RBZustaendigZustaendiger.Location = New System.Drawing.Point(14, 42)
        Me.RBZustaendigZustaendiger.Name = "RBZustaendigZustaendiger"
        Me.RBZustaendigZustaendiger.Size = New System.Drawing.Size(98, 24)
        Me.RBZustaendigZustaendiger.TabIndex = 1
        Me.RBZustaendigZustaendiger.Text = "Zuständiger"
        '
        'rbZustaendigKube
        '
        Me.rbZustaendigKube.Location = New System.Drawing.Point(14, 18)
        Me.rbZustaendigKube.Name = "rbZustaendigKube"
        Me.rbZustaendigKube.Size = New System.Drawing.Size(106, 24)
        Me.rbZustaendigKube.TabIndex = 0
        Me.rbZustaendigKube.Text = "Kundenberater"
        '
        'cbzust
        '
        Me.cbzust.Location = New System.Drawing.Point(128, 47)
        Me.cbzust.Name = "cbzust"
        Me.cbzust.Size = New System.Drawing.Size(232, 21)
        Me.cbzust.TabIndex = 3
        '
        'cbKube
        '
        Me.cbKube.Location = New System.Drawing.Point(128, 21)
        Me.cbKube.Name = "cbKube"
        Me.cbKube.Size = New System.Drawing.Size(232, 21)
        Me.cbKube.TabIndex = 2
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker1, Me.cbPostzustellung, Me.Label5, Me.Label3})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox2.TabIndex = 6
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Allgemein"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 48)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(104, 20)
        Me.DateTimePicker1.TabIndex = 1
        '
        'cbPostzustellung
        '
        Me.cbPostzustellung.Location = New System.Drawing.Point(128, 24)
        Me.cbPostzustellung.Name = "cbPostzustellung"
        Me.cbPostzustellung.Size = New System.Drawing.Size(232, 21)
        Me.cbPostzustellung.TabIndex = 0
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 48)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Dokument-Datum"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 24)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "Post-Zustellung"
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox7, Me.GroupBox6, Me.GroupBox5, Me.GroupBox4})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(792, 326)
        Me.TabPage4.TabIndex = 1
        Me.TabPage4.Text = "Zusammenhänge"
        Me.TabPage4.Visible = False
        '
        'GroupBox7
        '
        Me.GroupBox7.BackColor = System.Drawing.SystemColors.Control
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.InfoMeldungList})
        Me.GroupBox7.Location = New System.Drawing.Point(8, 216)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(776, 100)
        Me.GroupBox7.TabIndex = 3
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Informationsmeldungen"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.ContextMenu = Me.ContextMenu4
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.InfoMeldungList.Location = New System.Drawing.Point(8, 16)
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines2
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(760, 72)
        Me.InfoMeldungList.TabIndex = 0
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, " & _
        "1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""" & _
        "><ClientRect>0, 0, 756, 68</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 756, 68</ClientArea></Blob>"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuInfoEmpfaengerAdd, Me.mnuInfoEmpfaengerDelete})
        '
        'mnuInfoEmpfaengerAdd
        '
        Me.mnuInfoEmpfaengerAdd.Index = 0
        Me.mnuInfoEmpfaengerAdd.Text = "Neuer Info-Empfänger"
        '
        'mnuInfoEmpfaengerDelete
        '
        Me.mnuInfoEmpfaengerDelete.Index = 1
        Me.mnuInfoEmpfaengerDelete.Text = "Info-Empfänger löschen"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.ZuordnungList})
        Me.GroupBox6.Location = New System.Drawing.Point(384, 112)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(400, 96)
        Me.GroupBox6.TabIndex = 2
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Dokument-Zuordnung"
        '
        'ZuordnungList
        '
        Me.ZuordnungList.AllowFilter = True
        Me.ZuordnungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ZuordnungList.AllowSort = True
        Me.ZuordnungList.AlternatingRows = True
        Me.ZuordnungList.CaptionHeight = 17
        Me.ZuordnungList.CollapseColor = System.Drawing.Color.Black
        Me.ZuordnungList.ContextMenu = Me.ContextMenu3
        Me.ZuordnungList.DataChanged = False
        Me.ZuordnungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ZuordnungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ZuordnungList.ExpandColor = System.Drawing.Color.Black
        Me.ZuordnungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ZuordnungList.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ZuordnungList.Location = New System.Drawing.Point(3, 16)
        Me.ZuordnungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ZuordnungList.Name = "ZuordnungList"
        Me.ZuordnungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ZuordnungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ZuordnungList.PreviewInfo.ZoomFactor = 75
        Me.ZuordnungList.PrintInfo.ShowOptionsDialog = False
        Me.ZuordnungList.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ZuordnungList.RowDivider = GridLines3
        Me.ZuordnungList.RowHeight = 15
        Me.ZuordnungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ZuordnungList.ScrollTips = False
        Me.ZuordnungList.Size = New System.Drawing.Size(394, 77)
        Me.ZuordnungList.TabIndex = 0
        Me.ZuordnungList.Text = "C1TrueDBGrid1"
        Me.ZuordnungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 73</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "3</ClientArea></Blob>"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokZuordnungAdd, Me.MnuDokzuordnungDelete, Me.MenuItem1, Me.MnuShowDoc})
        '
        'MnuDokZuordnungAdd
        '
        Me.MnuDokZuordnungAdd.Index = 0
        Me.MnuDokZuordnungAdd.Text = "Dokument hinzufügen"
        '
        'MnuDokzuordnungDelete
        '
        Me.MnuDokzuordnungDelete.Index = 1
        Me.MnuDokzuordnungDelete.Text = "Dokument entfernen"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "-"
        '
        'MnuShowDoc
        '
        Me.MnuShowDoc.Index = 3
        Me.MnuShowDoc.Text = "Dokument anzeigen"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.ColdList})
        Me.GroupBox5.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(400, 100)
        Me.GroupBox5.TabIndex = 1
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Dokumente ersetzen"
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.ContextMenu = Me.ContextMenu7
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(3, 16)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines4
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(394, 81)
        Me.ColdList.TabIndex = 0
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 77</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "7</ClientArea></Blob>"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Dokument auswählen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Dokument entfernen"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker2, Me.Label20, Me.txtBemerkung, Me.DateTimePicker3, Me.Label10, Me.Label6})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(368, 200)
        Me.GroupBox4.TabIndex = 0
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Allgemein"
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.DateTimePicker2.Location = New System.Drawing.Point(88, 48)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.ShowUpDownButtons = False
        Me.DateTimePicker2.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker2.TabIndex = 1
        Me.DateTimePicker2.Tag = Nothing
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 72)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 35
        Me.Label20.Text = "Bemerkung"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(88, 72)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(272, 112)
        Me.txtBemerkung.TabIndex = 2
        Me.txtBemerkung.Text = ""
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker3.TabIndex = 0
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 34
        Me.Label10.Text = "Archiv-Datum"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 48)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 30
        Me.Label6.Text = "Termin"
        '
        'TabPage5
        '
        Me.TabPage5.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlBerechtigungen, Me.GroupBox9, Me.GroupBox8})
        Me.TabPage5.Location = New System.Drawing.Point(4, 22)
        Me.TabPage5.Name = "TabPage5"
        Me.TabPage5.Size = New System.Drawing.Size(792, 326)
        Me.TabPage5.TabIndex = 2
        Me.TabPage5.Text = "Notizen / Rechte"
        Me.TabPage5.Visible = False
        '
        'pnlBerechtigungen
        '
        Me.pnlBerechtigungen.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.pnlBerechtigungen.Location = New System.Drawing.Point(168, 168)
        Me.pnlBerechtigungen.Name = "pnlBerechtigungen"
        Me.pnlBerechtigungen.Size = New System.Drawing.Size(616, 152)
        Me.pnlBerechtigungen.TabIndex = 3
        Me.pnlBerechtigungen.TabStop = False
        Me.pnlBerechtigungen.Text = "Berechtigungseinschränkung"
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.ContextMenu = Me.ContextMenu6
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.Location = New System.Drawing.Point(8, 16)
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines5
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(600, 128)
        Me.DokumentFunktionenList.TabIndex = 0
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 596, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "124</ClientArea></Blob>"
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem4})
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Text = "Berechtigungseinschränkung hinzufügen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "Berechtigungseinschränkung entfernen"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.cvertraulich, Me.Label18, Me.cGesperrt, Me.Label9})
        Me.GroupBox9.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(152, 152)
        Me.GroupBox9.TabIndex = 2
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Schutz"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(16, 96)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(120, 48)
        Me.Button3.TabIndex = 2
        Me.Button3.Text = "Liste der berechtigten Mitarbeiter"
        '
        'cvertraulich
        '
        Me.cvertraulich.Location = New System.Drawing.Point(80, 46)
        Me.cvertraulich.Name = "cvertraulich"
        Me.cvertraulich.Size = New System.Drawing.Size(48, 24)
        Me.cvertraulich.TabIndex = 1
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(16, 48)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(64, 23)
        Me.Label18.TabIndex = 17
        Me.Label18.Text = "Vertraulich"
        '
        'cGesperrt
        '
        Me.cGesperrt.Enabled = False
        Me.cGesperrt.Location = New System.Drawing.Point(80, 24)
        Me.cGesperrt.Name = "cGesperrt"
        Me.cGesperrt.Size = New System.Drawing.Size(48, 24)
        Me.cGesperrt.TabIndex = 0
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 24)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(64, 23)
        Me.Label9.TabIndex = 15
        Me.Label9.Text = "Gesperrt"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(776, 152)
        Me.GroupBox8.TabIndex = 1
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Notizen"
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(368, 36)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines6
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu1
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(8, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines7
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(760, 128)
        Me.Notizlist.TabIndex = 0
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 756, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 756, " & _
        "124</ClientArea></Blob>"
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.GroupBox11})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(792, 326)
        Me.TabPage1.TabIndex = 3
        Me.TabPage1.Text = "Zustelladresse"
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(312, 13)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 0
        '
        'GroupBox11
        '
        Me.GroupBox11.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label13, Me.txtAnredeZusteller, Me.txtZustelladresse})
        Me.GroupBox11.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox11.Name = "GroupBox11"
        Me.GroupBox11.Size = New System.Drawing.Size(296, 200)
        Me.GroupBox11.TabIndex = 0
        Me.GroupBox11.TabStop = False
        Me.GroupBox11.Text = "Zustelladresse"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 150)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(192, 16)
        Me.Label13.TabIndex = 2
        Me.Label13.Text = "Anrede (z.B.: Herr Muster)"
        '
        'txtAnredeZusteller
        '
        Me.txtAnredeZusteller.Location = New System.Drawing.Point(8, 168)
        Me.txtAnredeZusteller.Name = "txtAnredeZusteller"
        Me.txtAnredeZusteller.Size = New System.Drawing.Size(280, 20)
        Me.txtAnredeZusteller.TabIndex = 1
        Me.txtAnredeZusteller.Text = ""
        '
        'txtZustelladresse
        '
        Me.txtZustelladresse.Location = New System.Drawing.Point(8, 16)
        Me.txtZustelladresse.Multiline = True
        Me.txtZustelladresse.Name = "txtZustelladresse"
        Me.txtZustelladresse.Size = New System.Drawing.Size(280, 128)
        Me.txtZustelladresse.TabIndex = 0
        Me.txtZustelladresse.Text = "TextBox1"
        '
        'TabPage7
        '
        Me.TabPage7.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1})
        Me.TabPage7.Location = New System.Drawing.Point(4, 22)
        Me.TabPage7.Name = "TabPage7"
        Me.TabPage7.Size = New System.Drawing.Size(792, 326)
        Me.TabPage7.TabIndex = 6
        Me.TabPage7.Text = "Bedingte Retournierung"
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage8, Me.TabPage9, Me.TabPage10})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(792, 326)
        Me.TabControl1.TabIndex = 0
        '
        'TabPage8
        '
        Me.TabPage8.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox16, Me.GroupBox17})
        Me.TabPage8.Location = New System.Drawing.Point(4, 22)
        Me.TabPage8.Name = "TabPage8"
        Me.TabPage8.Size = New System.Drawing.Size(784, 300)
        Me.TabPage8.TabIndex = 0
        Me.TabPage8.Text = "Dokumentinhalt"
        '
        'GroupBox16
        '
        Me.GroupBox16.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtbezeichnungbr, Me.Label14, Me.Label12, Me.bemerkungbr})
        Me.GroupBox16.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox16.Name = "GroupBox16"
        Me.GroupBox16.Size = New System.Drawing.Size(368, 288)
        Me.GroupBox16.TabIndex = 41
        Me.GroupBox16.TabStop = False
        Me.GroupBox16.Text = "Allgemein"
        '
        'txtbezeichnungbr
        '
        Me.txtbezeichnungbr.Location = New System.Drawing.Point(88, 24)
        Me.txtbezeichnungbr.Name = "txtbezeichnungbr"
        Me.txtbezeichnungbr.ReadOnly = True
        Me.txtbezeichnungbr.Size = New System.Drawing.Size(272, 20)
        Me.txtbezeichnungbr.TabIndex = 0
        Me.txtbezeichnungbr.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 24)
        Me.Label14.Name = "Label14"
        Me.Label14.TabIndex = 40
        Me.Label14.Text = "Bezeichnung"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 56)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(80, 23)
        Me.Label12.TabIndex = 35
        Me.Label12.Text = "Bemerkung"
        '
        'bemerkungbr
        '
        Me.bemerkungbr.Location = New System.Drawing.Point(88, 56)
        Me.bemerkungbr.Multiline = True
        Me.bemerkungbr.Name = "bemerkungbr"
        Me.bemerkungbr.Size = New System.Drawing.Size(272, 80)
        Me.bemerkungbr.TabIndex = 1
        Me.bemerkungbr.Text = ""
        '
        'GroupBox17
        '
        Me.GroupBox17.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokWertListBR})
        Me.GroupBox17.Location = New System.Drawing.Point(376, 8)
        Me.GroupBox17.Name = "GroupBox17"
        Me.GroupBox17.Size = New System.Drawing.Size(400, 288)
        Me.GroupBox17.TabIndex = 38
        Me.GroupBox17.TabStop = False
        Me.GroupBox17.Text = "Dokumentspezifisch"
        '
        'DokWertListBR
        '
        Me.DokWertListBR.AllowFilter = False
        Me.DokWertListBR.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokWertListBR.AllowSort = False
        Me.DokWertListBR.AlternatingRows = True
        Me.DokWertListBR.CaptionHeight = 17
        Me.DokWertListBR.CollapseColor = System.Drawing.Color.Black
        Me.DokWertListBR.ContextMenu = Me.ContextMenu14
        Me.DokWertListBR.DataChanged = False
        Me.DokWertListBR.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokWertListBR.ExpandColor = System.Drawing.Color.Black
        Me.DokWertListBR.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokWertListBR.Images.Add(CType(resources.GetObject("resource.Images7"), System.Drawing.Bitmap))
        Me.DokWertListBR.Location = New System.Drawing.Point(8, 16)
        Me.DokWertListBR.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokWertListBR.Name = "DokWertListBR"
        Me.DokWertListBR.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokWertListBR.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokWertListBR.PreviewInfo.ZoomFactor = 75
        Me.DokWertListBR.PrintInfo.ShowOptionsDialog = False
        Me.DokWertListBR.RecordSelectorWidth = 16
        GridLines8.Color = System.Drawing.Color.DarkGray
        GridLines8.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokWertListBR.RowDivider = GridLines8
        Me.DokWertListBR.RowHeight = 15
        Me.DokWertListBR.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokWertListBR.ScrollTips = False
        Me.DokWertListBR.Size = New System.Drawing.Size(384, 264)
        Me.DokWertListBR.TabIndex = 0
        Me.DokWertListBR.Text = "C1TrueDBGrid1"
        Me.DokWertListBR.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 380, 260</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defau" & _
        "ltRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 380, 260</ClientArea></Bl" & _
        "ob>"
        '
        'ContextMenu14
        '
        Me.ContextMenu14.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem22})
        '
        'MenuItem22
        '
        Me.MenuItem22.Index = 0
        Me.MenuItem22.Text = "&Wert auswählen"
        '
        'TabPage9
        '
        Me.TabPage9.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox13, Me.GroupBox14, Me.GroupBox15})
        Me.TabPage9.Location = New System.Drawing.Point(4, 22)
        Me.TabPage9.Name = "TabPage9"
        Me.TabPage9.Size = New System.Drawing.Size(784, 300)
        Me.TabPage9.TabIndex = 1
        Me.TabPage9.Text = "Zusammenhänge"
        '
        'GroupBox13
        '
        Me.GroupBox13.BackColor = System.Drawing.SystemColors.Control
        Me.GroupBox13.Controls.AddRange(New System.Windows.Forms.Control() {Me.InFoMeldungListBR})
        Me.GroupBox13.Location = New System.Drawing.Point(8, 136)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(776, 152)
        Me.GroupBox13.TabIndex = 9
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Informationsmeldungen"
        '
        'InFoMeldungListBR
        '
        Me.InFoMeldungListBR.AllowFilter = True
        Me.InFoMeldungListBR.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InFoMeldungListBR.AllowSort = True
        Me.InFoMeldungListBR.AllowUpdate = False
        Me.InFoMeldungListBR.AlternatingRows = True
        Me.InFoMeldungListBR.CaptionHeight = 17
        Me.InFoMeldungListBR.CollapseColor = System.Drawing.Color.Black
        Me.InFoMeldungListBR.ContextMenu = Me.ContextMenu9
        Me.InFoMeldungListBR.DataChanged = False
        Me.InFoMeldungListBR.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InFoMeldungListBR.Dock = System.Windows.Forms.DockStyle.Fill
        Me.InFoMeldungListBR.ExpandColor = System.Drawing.Color.Black
        Me.InFoMeldungListBR.GroupByCaption = "Drag a column header here to group by that column"
        Me.InFoMeldungListBR.Images.Add(CType(resources.GetObject("resource.Images8"), System.Drawing.Bitmap))
        Me.InFoMeldungListBR.Location = New System.Drawing.Point(3, 16)
        Me.InFoMeldungListBR.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InFoMeldungListBR.Name = "InFoMeldungListBR"
        Me.InFoMeldungListBR.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InFoMeldungListBR.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InFoMeldungListBR.PreviewInfo.ZoomFactor = 75
        Me.InFoMeldungListBR.PrintInfo.ShowOptionsDialog = False
        Me.InFoMeldungListBR.RecordSelectorWidth = 16
        GridLines9.Color = System.Drawing.Color.DarkGray
        GridLines9.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InFoMeldungListBR.RowDivider = GridLines9
        Me.InFoMeldungListBR.RowHeight = 15
        Me.InFoMeldungListBR.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InFoMeldungListBR.ScrollTips = False
        Me.InFoMeldungListBR.Size = New System.Drawing.Size(770, 133)
        Me.InFoMeldungListBR.TabIndex = 0
        Me.InFoMeldungListBR.Text = "C1TrueDBGrid1"
        Me.InFoMeldungListBR.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, " & _
        "1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""" & _
        "><ClientRect>0, 0, 766, 129</ClientRect><BorderSide>0</BorderSide><CaptionStyle " & _
        "parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenR" & _
        "owStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""St" & _
        "yle13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" m" & _
        "e=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pa" & _
        "rent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /" & _
        "><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordS" & _
        "elector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pa" & _
        "rent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyle" & _
        "s><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pa" & _
        "rent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style paren" & _
        "t=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent" & _
        "=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent" & _
        "=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Hea" & _
        "ding"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style paren" & _
        "t=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</" & _
        "horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clie" & _
        "ntArea>0, 0, 766, 129</ClientArea></Blob>"
        '
        'ContextMenu9
        '
        Me.ContextMenu9.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7, Me.MenuItem8})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Text = "Neuer Info-Empfänger"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 1
        Me.MenuItem8.Text = "Info-Empfänger löschen"
        '
        'GroupBox14
        '
        Me.GroupBox14.Controls.AddRange(New System.Windows.Forms.Control() {Me.ZuordnunglistBR})
        Me.GroupBox14.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox14.Name = "GroupBox14"
        Me.GroupBox14.Size = New System.Drawing.Size(400, 128)
        Me.GroupBox14.TabIndex = 8
        Me.GroupBox14.TabStop = False
        Me.GroupBox14.Text = "Dokument-Zuordnung"
        '
        'ZuordnunglistBR
        '
        Me.ZuordnunglistBR.AllowFilter = True
        Me.ZuordnunglistBR.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ZuordnunglistBR.AllowSort = True
        Me.ZuordnunglistBR.AlternatingRows = True
        Me.ZuordnunglistBR.CaptionHeight = 17
        Me.ZuordnunglistBR.CollapseColor = System.Drawing.Color.Black
        Me.ZuordnunglistBR.ContextMenu = Me.ContextMenu11
        Me.ZuordnunglistBR.DataChanged = False
        Me.ZuordnunglistBR.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ZuordnunglistBR.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ZuordnunglistBR.ExpandColor = System.Drawing.Color.Black
        Me.ZuordnunglistBR.GroupByCaption = "Drag a column header here to group by that column"
        Me.ZuordnunglistBR.Images.Add(CType(resources.GetObject("resource.Images9"), System.Drawing.Bitmap))
        Me.ZuordnunglistBR.Location = New System.Drawing.Point(3, 16)
        Me.ZuordnunglistBR.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ZuordnunglistBR.Name = "ZuordnunglistBR"
        Me.ZuordnunglistBR.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ZuordnunglistBR.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ZuordnunglistBR.PreviewInfo.ZoomFactor = 75
        Me.ZuordnunglistBR.PrintInfo.ShowOptionsDialog = False
        Me.ZuordnunglistBR.RecordSelectorWidth = 16
        GridLines10.Color = System.Drawing.Color.DarkGray
        GridLines10.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ZuordnunglistBR.RowDivider = GridLines10
        Me.ZuordnunglistBR.RowHeight = 15
        Me.ZuordnunglistBR.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ZuordnunglistBR.ScrollTips = False
        Me.ZuordnunglistBR.Size = New System.Drawing.Size(394, 109)
        Me.ZuordnunglistBR.TabIndex = 1
        Me.ZuordnunglistBR.Text = "C1TrueDBGrid1"
        Me.ZuordnunglistBR.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 105</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, " & _
        "105</ClientArea></Blob>"
        '
        'ContextMenu11
        '
        Me.ContextMenu11.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem13, Me.MenuItem14, Me.MenuItem15, Me.MenuItem16})
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 0
        Me.MenuItem13.Text = "Dokument hinzufügen"
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 1
        Me.MenuItem14.Text = "Dokument entfernen"
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 2
        Me.MenuItem15.Text = "-"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 3
        Me.MenuItem16.Text = "Dokument anzeigen"
        '
        'GroupBox15
        '
        Me.GroupBox15.Controls.AddRange(New System.Windows.Forms.Control() {Me.coldlistbr})
        Me.GroupBox15.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox15.Name = "GroupBox15"
        Me.GroupBox15.Size = New System.Drawing.Size(400, 96)
        Me.GroupBox15.TabIndex = 7
        Me.GroupBox15.TabStop = False
        Me.GroupBox15.Text = "Dokumente ersetzen"
        Me.GroupBox15.Visible = False
        '
        'coldlistbr
        '
        Me.coldlistbr.AllowFilter = True
        Me.coldlistbr.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.coldlistbr.AllowSort = True
        Me.coldlistbr.AlternatingRows = True
        Me.coldlistbr.CaptionHeight = 17
        Me.coldlistbr.CollapseColor = System.Drawing.Color.Black
        Me.coldlistbr.ContextMenu = Me.ContextMenu10
        Me.coldlistbr.DataChanged = False
        Me.coldlistbr.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.coldlistbr.Dock = System.Windows.Forms.DockStyle.Fill
        Me.coldlistbr.ExpandColor = System.Drawing.Color.Black
        Me.coldlistbr.GroupByCaption = "Drag a column header here to group by that column"
        Me.coldlistbr.Images.Add(CType(resources.GetObject("resource.Images10"), System.Drawing.Bitmap))
        Me.coldlistbr.Location = New System.Drawing.Point(3, 16)
        Me.coldlistbr.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.coldlistbr.Name = "coldlistbr"
        Me.coldlistbr.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.coldlistbr.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.coldlistbr.PreviewInfo.ZoomFactor = 75
        Me.coldlistbr.PrintInfo.ShowOptionsDialog = False
        Me.coldlistbr.RecordSelectorWidth = 16
        GridLines11.Color = System.Drawing.Color.DarkGray
        GridLines11.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.coldlistbr.RowDivider = GridLines11
        Me.coldlistbr.RowHeight = 15
        Me.coldlistbr.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.coldlistbr.ScrollTips = False
        Me.coldlistbr.Size = New System.Drawing.Size(394, 77)
        Me.coldlistbr.TabIndex = 2
        Me.coldlistbr.Text = "C1TrueDBGrid1"
        Me.coldlistbr.Visible = False
        Me.coldlistbr.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 73</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "3</ClientArea></Blob>"
        '
        'ContextMenu10
        '
        Me.ContextMenu10.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem11, Me.MenuItem12})
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 0
        Me.MenuItem11.Text = "&Dokument auswählen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 1
        Me.MenuItem12.Text = "Dokument entfernen"
        '
        'TabPage10
        '
        Me.TabPage10.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlBerechtigungenBR, Me.GroupBox18, Me.GroupBox19})
        Me.TabPage10.Location = New System.Drawing.Point(4, 22)
        Me.TabPage10.Name = "TabPage10"
        Me.TabPage10.Size = New System.Drawing.Size(784, 300)
        Me.TabPage10.TabIndex = 2
        Me.TabPage10.Text = "Notizen / Rechte"
        '
        'pnlBerechtigungenBR
        '
        Me.pnlBerechtigungenBR.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenListBR})
        Me.pnlBerechtigungenBR.Location = New System.Drawing.Point(160, 144)
        Me.pnlBerechtigungenBR.Name = "pnlBerechtigungenBR"
        Me.pnlBerechtigungenBR.Size = New System.Drawing.Size(616, 152)
        Me.pnlBerechtigungenBR.TabIndex = 7
        Me.pnlBerechtigungenBR.TabStop = False
        Me.pnlBerechtigungenBR.Text = "Berechtigungseinschränkung"
        '
        'DokumentFunktionenListBR
        '
        Me.DokumentFunktionenListBR.AllowFilter = True
        Me.DokumentFunktionenListBR.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenListBR.AllowSort = True
        Me.DokumentFunktionenListBR.AlternatingRows = True
        Me.DokumentFunktionenListBR.CaptionHeight = 17
        Me.DokumentFunktionenListBR.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenListBR.ContextMenu = Me.ContextMenu13
        Me.DokumentFunktionenListBR.DataChanged = False
        Me.DokumentFunktionenListBR.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenListBR.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenListBR.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenListBR.Images.Add(CType(resources.GetObject("resource.Images11"), System.Drawing.Bitmap))
        Me.DokumentFunktionenListBR.Location = New System.Drawing.Point(8, 16)
        Me.DokumentFunktionenListBR.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenListBR.Name = "DokumentFunktionenListBR"
        Me.DokumentFunktionenListBR.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenListBR.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenListBR.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenListBR.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenListBR.RecordSelectorWidth = 16
        GridLines12.Color = System.Drawing.Color.DarkGray
        GridLines12.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenListBR.RowDivider = GridLines12
        Me.DokumentFunktionenListBR.RowHeight = 15
        Me.DokumentFunktionenListBR.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenListBR.ScrollTips = False
        Me.DokumentFunktionenListBR.Size = New System.Drawing.Size(600, 128)
        Me.DokumentFunktionenListBR.TabIndex = 1
        Me.DokumentFunktionenListBR.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenListBR.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 596, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "124</ClientArea></Blob>"
        '
        'ContextMenu13
        '
        Me.ContextMenu13.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem20, Me.MenuItem21})
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 0
        Me.MenuItem20.Text = "Berechtigungseinschränkung hinzufügen"
        '
        'MenuItem21
        '
        Me.MenuItem21.Index = 1
        Me.MenuItem21.Text = "Berechtigungseinschränkung entfernen"
        '
        'GroupBox18
        '
        Me.GroupBox18.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3Br, Me.cVertraulichBR, Me.Label18BR, Me.cGesperrtBR, Me.Label15})
        Me.GroupBox18.Location = New System.Drawing.Point(8, 144)
        Me.GroupBox18.Name = "GroupBox18"
        Me.GroupBox18.Size = New System.Drawing.Size(152, 152)
        Me.GroupBox18.TabIndex = 6
        Me.GroupBox18.TabStop = False
        Me.GroupBox18.Text = "Schutz"
        '
        'Button3Br
        '
        Me.Button3Br.Location = New System.Drawing.Point(16, 96)
        Me.Button3Br.Name = "Button3Br"
        Me.Button3Br.Size = New System.Drawing.Size(120, 48)
        Me.Button3Br.TabIndex = 19
        Me.Button3Br.Text = "Liste der berechtigten Mitarbeiter"
        '
        'cVertraulichBR
        '
        Me.cVertraulichBR.Location = New System.Drawing.Point(80, 46)
        Me.cVertraulichBR.Name = "cVertraulichBR"
        Me.cVertraulichBR.Size = New System.Drawing.Size(48, 24)
        Me.cVertraulichBR.TabIndex = 18
        '
        'Label18BR
        '
        Me.Label18BR.Location = New System.Drawing.Point(16, 48)
        Me.Label18BR.Name = "Label18BR"
        Me.Label18BR.Size = New System.Drawing.Size(64, 23)
        Me.Label18BR.TabIndex = 17
        Me.Label18BR.Text = "Vertraulich"
        '
        'cGesperrtBR
        '
        Me.cGesperrtBR.Enabled = False
        Me.cGesperrtBR.Location = New System.Drawing.Point(80, 24)
        Me.cGesperrtBR.Name = "cGesperrtBR"
        Me.cGesperrtBR.Size = New System.Drawing.Size(48, 24)
        Me.cGesperrtBR.TabIndex = 16
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(16, 24)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(64, 23)
        Me.Label15.TabIndex = 15
        Me.Label15.Text = "Gesperrt"
        '
        'GroupBox19
        '
        Me.GroupBox19.Controls.AddRange(New System.Windows.Forms.Control() {Me.Notizlistbr})
        Me.GroupBox19.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox19.Name = "GroupBox19"
        Me.GroupBox19.Size = New System.Drawing.Size(768, 128)
        Me.GroupBox19.TabIndex = 5
        Me.GroupBox19.TabStop = False
        Me.GroupBox19.Text = "Notizen"
        '
        'Notizlistbr
        '
        Me.Notizlistbr.AllowFilter = True
        Me.Notizlistbr.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlistbr.AllowSort = True
        Me.Notizlistbr.AlternatingRows = True
        Me.Notizlistbr.CaptionHeight = 17
        Me.Notizlistbr.CollapseColor = System.Drawing.Color.Black
        Me.Notizlistbr.ContextMenu = Me.ContextMenu12
        Me.Notizlistbr.DataChanged = False
        Me.Notizlistbr.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlistbr.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Notizlistbr.ExpandColor = System.Drawing.Color.Black
        Me.Notizlistbr.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlistbr.Images.Add(CType(resources.GetObject("resource.Images12"), System.Drawing.Bitmap))
        Me.Notizlistbr.Location = New System.Drawing.Point(3, 16)
        Me.Notizlistbr.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlistbr.Name = "Notizlistbr"
        Me.Notizlistbr.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlistbr.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlistbr.PreviewInfo.ZoomFactor = 75
        Me.Notizlistbr.PrintInfo.ShowOptionsDialog = False
        Me.Notizlistbr.RecordSelectorWidth = 16
        GridLines13.Color = System.Drawing.Color.DarkGray
        GridLines13.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlistbr.RowDivider = GridLines13
        Me.Notizlistbr.RowHeight = 15
        Me.Notizlistbr.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlistbr.ScrollTips = False
        Me.Notizlistbr.Size = New System.Drawing.Size(762, 109)
        Me.Notizlistbr.TabIndex = 1
        Me.Notizlistbr.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 758, 105</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 758, " & _
        "105</ClientArea></Blob>"
        '
        'ContextMenu12
        '
        Me.ContextMenu12.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem17, Me.MenuItem18, Me.MenuItem19})
        '
        'MenuItem17
        '
        Me.MenuItem17.Index = 0
        Me.MenuItem17.Text = "&Neue Notiz"
        '
        'MenuItem18
        '
        Me.MenuItem18.Index = 1
        Me.MenuItem18.Text = "&Notiz bearbeiten"
        '
        'MenuItem19
        '
        Me.MenuItem19.Index = 2
        Me.MenuItem19.Text = "Notiz &löschen"
        '
        'cbVerantwortlich
        '
        Me.cbVerantwortlich.ContextMenu = Me.ContextMenu5
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(520, 64)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(224, 21)
        Me.cbVerantwortlich.TabIndex = 8
        '
        'ContextMenu5
        '
        Me.ContextMenu5.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Berechtigte Mitarbeiter"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(416, 64)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(88, 23)
        Me.Label17.TabIndex = 44
        Me.Label17.Text = "Verantwortlicher"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(416, 40)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 43
        Me.Label16.Text = "Dokumentstatus"
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.ItemHeight = 13
        Me.cbdokumentstatus.Location = New System.Drawing.Point(520, 40)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(264, 21)
        Me.cbdokumentstatus.TabIndex = 7
        '
        'txtPartnerInhaberNr
        '
        Me.txtPartnerInhaberNr.Location = New System.Drawing.Point(344, 72)
        Me.txtPartnerInhaberNr.Name = "txtPartnerInhaberNr"
        Me.txtPartnerInhaberNr.ReadOnly = True
        Me.txtPartnerInhaberNr.Size = New System.Drawing.Size(56, 20)
        Me.txtPartnerInhaberNr.TabIndex = 5
        Me.txtPartnerInhaberNr.Text = ""
        Me.txtPartnerInhaberNr.Visible = False
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(520, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(264, 20)
        Me.txtBezeichnung.TabIndex = 6
        Me.txtBezeichnung.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(416, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.TabIndex = 38
        Me.Label4.Text = "Bezeichnung"
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(352, 16)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 2
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(112, 40)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerZusteller.TabIndex = 1
        Me.txtPartnerZusteller.Text = ""
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(112, 16)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 0
        Me.txtPartnerInhaber.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 34
        Me.Label2.Text = "Partner-Zusteller"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 33
        Me.Label1.Text = "Partner-Inhaber"
        '
        'cdokumentwerteanzeigen
        '
        Me.cdokumentwerteanzeigen.Location = New System.Drawing.Point(536, 467)
        Me.cdokumentwerteanzeigen.Name = "cdokumentwerteanzeigen"
        Me.cdokumentwerteanzeigen.Size = New System.Drawing.Size(160, 32)
        Me.cdokumentwerteanzeigen.TabIndex = 15
        Me.cdokumentwerteanzeigen.Text = "Dokumentinhalte anzeigen"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(376, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 3
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(328, 64)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(24, 24)
        Me.Button4.TabIndex = 4
        Me.Button4.Visible = False
        '
        'cbsave
        '
        Me.cbsave.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbsave.Location = New System.Drawing.Point(744, 64)
        Me.cbsave.Name = "cbsave"
        Me.cbsave.Size = New System.Drawing.Size(21, 21)
        Me.cbsave.TabIndex = 49
        Me.cbsave.Text = "ComboBox1"
        Me.cbsave.Visible = False
        '
        'cbmoeglicheStati
        '
        Me.cbmoeglicheStati.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbmoeglicheStati.Location = New System.Drawing.Point(743, 64)
        Me.cbmoeglicheStati.Name = "cbmoeglicheStati"
        Me.cbmoeglicheStati.Size = New System.Drawing.Size(21, 21)
        Me.cbmoeglicheStati.TabIndex = 9
        Me.cbmoeglicheStati.Text = "ComboBox1"
        '
        'Panel1
        '
        Me.Panel1.Location = New System.Drawing.Point(784, 16)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(24, 100)
        Me.Panel1.TabIndex = 50
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(416, 80)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 32)
        Me.Label11.TabIndex = 52
        Me.Label11.Text = "Berechtigt für Folgestatus"
        Me.Label11.Visible = False
        '
        'txtstatus
        '
        Me.txtstatus.Location = New System.Drawing.Point(520, 88)
        Me.txtstatus.Name = "txtstatus"
        Me.txtstatus.Size = New System.Drawing.Size(224, 16)
        Me.txtstatus.TabIndex = 51
        Me.txtstatus.Text = "Label3"
        Me.txtstatus.Visible = False
        '
        'btntxtBemerkung
        '
        Me.btntxtBemerkung.Image = CType(resources.GetObject("btntxtBemerkung.Image"), System.Drawing.Bitmap)
        Me.btntxtBemerkung.Location = New System.Drawing.Point(764, 64)
        Me.btntxtBemerkung.Name = "btntxtBemerkung"
        Me.btntxtBemerkung.Size = New System.Drawing.Size(21, 21)
        Me.btntxtBemerkung.TabIndex = 10
        '
        'LabelVIBeachten
        '
        Me.LabelVIBeachten.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.LabelVIBeachten.ForeColor = System.Drawing.Color.Red
        Me.LabelVIBeachten.Location = New System.Drawing.Point(48, 72)
        Me.LabelVIBeachten.Name = "LabelVIBeachten"
        Me.LabelVIBeachten.Size = New System.Drawing.Size(176, 23)
        Me.LabelVIBeachten.TabIndex = 54
        Me.LabelVIBeachten.Text = "VI beachten"
        Me.LabelVIBeachten.Visible = False
        '
        'PicVIBeachten
        '
        Me.PicVIBeachten.Image = CType(resources.GetObject("PicVIBeachten.Image"), System.Drawing.Bitmap)
        Me.PicVIBeachten.Location = New System.Drawing.Point(3, 58)
        Me.PicVIBeachten.Name = "PicVIBeachten"
        Me.PicVIBeachten.Size = New System.Drawing.Size(40, 46)
        Me.PicVIBeachten.TabIndex = 58
        Me.PicVIBeachten.TabStop = False
        Me.PicVIBeachten.Visible = False
        '
        'Dataset1BR
        '
        Me.Dataset1BR.DataSetName = "NewDataSet"
        Me.Dataset1BR.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu8
        '
        Me.ContextMenu8.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem9, Me.MenuItem10})
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 0
        Me.MenuItem9.Text = "Neuer Info-Empfänger"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 1
        Me.MenuItem10.Text = "Info-Empfänger löschen"
        '
        'DataSet5
        '
        Me.DataSet5.DataSetName = "NewDataSet"
        Me.DataSet5.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(8, 472)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 60
        '
        'frmDokumentbearbeitung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(810, 501)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.LabelVIBeachten, Me.PicVIBeachten, Me.txtPartnerZusteller, Me.btntxtBemerkung, Me.Label11, Me.txtstatus, Me.Panel1, Me.cbmoeglicheStati, Me.Button4, Me.Button1, Me.cdokumentwerteanzeigen, Me.cbVerantwortlich, Me.Label17, Me.Label16, Me.cbdokumentstatus, Me.txtPartnerInhaberNr, Me.txtBezeichnung, Me.Label4, Me.btnPartnerInhaber, Me.txtPartnerInhaber, Me.Label2, Me.Label1, Me.TabControl2, Me.btnCancel, Me.btnWeiter, Me.cbsave, Me.BtnHelp})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDokumentbearbeitung"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumentbearbeitung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.GroupBox12.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.TabPage4.ResumeLayout(False)
        Me.GroupBox7.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox6.ResumeLayout(False)
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage5.ResumeLayout(False)
        Me.pnlBerechtigungen.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox9.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox11.ResumeLayout(False)
        Me.TabPage7.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage8.ResumeLayout(False)
        Me.GroupBox16.ResumeLayout(False)
        Me.GroupBox17.ResumeLayout(False)
        CType(Me.DokWertListBR, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage9.ResumeLayout(False)
        Me.GroupBox13.ResumeLayout(False)
        CType(Me.InFoMeldungListBR, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox14.ResumeLayout(False)
        CType(Me.ZuordnunglistBR, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox15.ResumeLayout(False)
        CType(Me.coldlistbr, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage10.ResumeLayout(False)
        Me.pnlBerechtigungenBR.ResumeLayout(False)
        CType(Me.DokumentFunktionenListBR, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox18.ResumeLayout(False)
        Me.GroupBox19.ResumeLayout(False)
        CType(Me.Notizlistbr, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Dataset1BR, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Insert_Update_Bedingte_Retournierung Method

Private Sub Insert_Update_Bedingte_Retournierung( _
   ByVal Insertdata As Boolean _
)

Parameters

Insertdata
Required.

Source code

[Visual Basic]
    Private Sub Insert_Update_Bedingte_Retournierung(ByVal Insertdata As Boolean)
        docbr.cpMainConnectionProvider = conn
        docbr.sDokumentid = New SqlString(CType(doc.sDokumentid.Value, String))
        conn.OpenConnection()
        docbr.SelectOne()
        docbr.sDokumentid = New SqlString(CType(Me.DokumentIDBR, String))
        docbr.iDokumenttypnr = New SqlInt32(CType(DokTypBR.iDokumenttypnr.Value, Int32))
        docbr.iPostzustellung = New SqlInt32(CType(0, Int32))
        docbr.iUnterschriftlinks = New SqlInt32(CType(0, Int32))
        docbr.iUnterschriftrechts = New SqlInt32(CType(0, Int32))
        docbr.sBezeichnung = New SqlString(CType(Me.txtbezeichnungbr.Text, String))
        docbr.sBemerkung = New SqlString(CType(Me.bemerkungbr.Text, String))
        docbr.bGesperrt = New SqlBoolean(CType(Me.cGesperrtBR.Checked = True, Boolean))
        docbr.bVertraulich = New SqlBoolean(CType(Me.cVertraulichBR.Checked = True, Boolean))
        docbr.sBedRDokumentid = New SqlString(CType("", String))
        docbr.sDokumentname = New SqlString(CType("", String))
        docbr.iBRVernichtungnachTagen = New SqlInt32(CType(DokTypBR.iTagebisvernichtungbedingteretournierung.Value, Int32))
        docbr.iAnzeigeStatus = New SqlInt32(CType(0, Int32))

        Dim t As DataTable
        t = Generic_Select(114)
        docbr.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
        docbr.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
        If Insertdata Then docbr.Insert() Else docbr.Update()
        t.Dispose()
        If Insertdata Then
            Dim statush As New Statushandling()
            statush.Status_Erstellen(docbr.sDokumentid.Value, False)
            statush.Dispose()
        End If
        conn.CloseConnection(True)
        docbr.iStatusnr = New SqlInt32(CType(Me.Status_History_Bedingte_Retournierung(0, docbr.sDokumentid.Value), Integer))
        conn.OpenConnection()
        docbr.Update()
        conn.CloseConnection(True)

        'Dokumentzuordnung sichern
        Dim i As Integer
        For i = 0 To Me.Dokumentzuorndungenbr.Rows.Count - 1
            If Me.Dokumentzuorndungenbr.Rows(i).Item("zuordnungnr") = 4 Then
                Me.Dokumentzuorndungenbr.Rows(i).Item("aktiv") = 0
            End If
        Next
        '        If Insertdata Then
        Dim rc As DataRowCollection
        Dim newrow As DataRow
        rc = Me.Dokumentzuorndungenbr.Rows
        Dim rowvals(Me.Dokumentzuorndungenbr.Columns.Count - 1) As Object
        rowvals(0) = 1
        rowvals(2) = 1
        rowvals(6) = 4
        rowvals(8) = doc.sDokumentid.Value
        rowvals(10) = Me.txtBemerkung
        newrow = rc.Add(rowvals)
        Me.ZuordnunglistBR.Refresh()
        '       End If
        Cold_Index_Bearbeiten_Bedingte_Retournierung(2, DokumentIDBR)
        Dokumentwerte_Sichern_Bedingte_Retournierung()
        Notizen_Sichern_Bedingte_Retournierung()
        Dokumentzuordnungen_Sichern_Bedingte_Retournierung()
        Dokumentersetzen_Sichern_Bedingte_Retournierung()
        Dokumentinfomeldungen_Sichern_Bedingte_Retournierung()
        Dokumentfunktionen_sichern_Bedingte_Retournierung()
        '    Status_History_Bedingte_Retournierung(docbr.iStatusnr.Value, DokumentIDBR)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Load_Create_Dokument_Bedingte_Retournierung Method

Private Sub Load_Create_Dokument_Bedingte_Retournierung()

Source code

[Visual Basic]
    Private Sub Load_Create_Dokument_Bedingte_Retournierung()
        NewDokumentIDBR = DivFnkt.Generate_Key()
        DokumentIDBR = NewDokumentIDBR
        Load_Defaults_Bedingte_Retournierung()
        w.save_historystatusbr = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Load_Defaults Method

Private Sub Load_Defaults()

Source code

[Visual Basic]
    Private Sub Load_Defaults()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Doktyp.cpMainConnectionProvider = conn
        Doktyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        Doktyp.SelectOne()

        If Doktyp.bFunktionen_zuweisen.Value = True Then
            Dokumentfunktionen_Aktivieren()
        Else
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.pnlBerechtigungen.Visible = False
            Me.pnlBerechtigungenBR.Visible = False
        End If

        ' Bedingte Retournierung
        ' SHU 02.03.2004
        Try
            If Doktyp.iDoktypbedingteretournierung.Value > 0 Then
                'And Me.CreateDocument = True Then
                Me.BedingteRetournierung = True
                Me.TabControl2.TabPages.Add(Me.tbp4)
                'If Globals.dokumentid_changedbr = True Then
                'MyMsg.show_standardmessage(243, MsgBoxStyle.Information)
                'End If
            End If
        Catch
        End Try

        'Bedingte Retournierung Ende

        Me.progress.Bar1.Value = 30
        progress.Refresh()
        'Dokumenttyp-Daten
        If Me.CreateDocument = True Then
            If DivFnkt.Ist_Berechtigt(Doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 2, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = Doktyp.bVertrauliches_dokument.Value = True
                Me.cVertraulichBR.Visible = True
                Me.Label18BR.Visible = True
                Me.cVertraulichBR.Checked = Me.cvertraulich.Checked
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
                Me.cVertraulichBR.Checked = False
                Me.cVertraulichBR.Visible = False
                Me.Label18BR.Visible = False

            End If
        Else
            If DivFnkt.Ist_Berechtigt(Doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 3, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = Doktyp.bVertrauliches_dokument.Value = True
                Me.cVertraulichBR.Visible = True
                Me.Label18BR.Visible = True
                Me.cVertraulichBR.Checked = Me.cvertraulich.Checked
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
                Me.cVertraulichBR.Checked = False
                Me.cVertraulichBR.Visible = False
                Me.Label18BR.Visible = False
            End If
        End If

        Me.progress.Bar1.Value = 40
        progress.Refresh()
        Me.txtBezeichnung.Text = Doktyp.sBezeichnung.Value
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumentid").Value = ""
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumenttypnr").Value = Me.Dokumenttypnr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@CreateNew").Value = 1
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        'hutter 2005-01-28
        DivFnkt.Bezeichnung_Feldwert(Me.DataSet1.Tables(0), True)

        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160

        Me.mcbstatus = New MultiComboBox(Me.cbdokumentstatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)

        Me.mcbkube = New MultiComboBox(Me.cbKube)
        Me.mcbkube.CheckNullValue = True
        Me.mcbkube.NullValueMessage = MyTxt.gettext(18)
        Me.mcbkube.DisplayColumnName = "name"
        Me.mcbkube.ValueColumnName = "mitarbeiternr"
        Me.mcbkube.Fill_Data(Generic_Select(8), False)

        'Postzustellung
        Me.SqlDataAdapter2.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter2.SelectCommand.Parameters("@sprache").Value = Globals.Sprache
        Me.SqlDataAdapter2.Fill(Me.DataSet2)

        mcbpostzustellung = New MultiComboBox(Me.cbPostzustellung)
        Me.mcbpostzustellung.DisplayColumnName = "bezeichnung"
        Me.mcbpostzustellung.ValueColumnName = "nreintrag"
        Dim d As DataTable
        d = Me.DataSet2.Tables(0)
        Me.mcbpostzustellung.Fill_Data(d, False)
        Me.mcbpostzustellung.Enabled = True
        Me.mcbpostzustellung.CheckNullValue = False

        Me.progress.Bar1.Value = 50
        progress.Refresh()
        mcbzust = New MultiComboBox(Me.cbzust)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii

        mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
        Me.mcbunterschriftlinks.DisplayColumnName = "name"
        Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftlinks")
        Me.mcbunterschriftlinks.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftlinks.SelectedValue = ii

        mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
        Me.mcbunterschriftrechts.DisplayColumnName = "name"
        Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftrechts")
        Me.mcbunterschriftrechts.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftrechts.SelectedValue = ii

        Me.mcbunterschriftlinks.CheckNullValue = False
        Me.mcbunterschriftrechts.CheckNullValue = False

        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        FillMcbVerantwortlich()

        Me.rbZustaendigKube.Checked = False
        Me.RBZustaendigZustaendiger.Checked = True
        Me.txtZustelladresse.Text = ""

        If Doktyp.bUnterschrift_links.Value = False Then Me.mcbunterschriftlinks.Enabled = False
        If Doktyp.bUnterschrift_rechts.Value = False Then Me.mcbunterschriftrechts.Enabled = False
        If Doktyp.bUnterschrift_links.Value = True Then Me.mcbunterschriftlinks.Enabled = True
        If Doktyp.bUnterschrift_rechts.Value = True Then Me.mcbunterschriftrechts.Enabled = True

        Me.progress.Bar1.Value = 60
        progress.Refresh()
        Me.zu_retournieren = Doktyp.bZu_retournieren.Value

        'Dokument ersetzen
        Me.Dokumentersetzen = Dokumentersetzen_Laden(Me.DokumentID)
        w.save_dokumentersetzen = Me.Dokumentersetzen
        'w.save_dokumentersetzen = Dokumentersetzen_Laden(Me.DokumentID)
        Me.ColdList.DataSource = Me.Dokumentersetzen
        Me.ColdList.Columns("aktiv").FilterText = True
        Me.ColdList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")
        If Doktyp.bCold_ersetzen.Value <> True Then
            Me.ErsetzenMoeglich = False
        Else
            Me.ErsetzenMoeglich = True
        End If

        'Notizen
        Notizen = Notizen_Laden(Me.DokumentID)
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        'Dokumentzuordnungen
        Me.Dokumentzuorndungen = Dokumentzuordnungen_Laden(Me.DokumentID)
        w.Save_Dokumentzuordnungen = Me.Dokumentzuorndungen
        '        w.Save_Dokumentzuordnungen = Dokumentzuordnungen_Laden(Me.DokumentID)
        Me.ZuordnungList.DataSource = Me.Dokumentzuorndungen

        DivFnkt.SpaltenTitel_Aktualisieren(Me.ZuordnungList, Me.Dokumentzuorndungen, "dokumentzuordnungen")
        Me.ZuordnungList.Columns("aktiv").FilterText = True
        Me.ZuordnungList.FilterBar = False

        Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Translate = True
        Next
        Me.progress.Bar1.Value = 70
        progress.Refresh()

        'Dokumentinfomeldungen
        Me.InfoMeldungList.FetchRowStyles = True
        Me.DokumentInfoMeldungen = Dokumentinfomeldungen_laden(Me.DokumentID)
        w.Save_Dokumentinfomeldungen = Me.DokumentInfoMeldungen
        '        w.Save_Dokumentinfomeldungen = Dokumentinfomeldungen_laden(Me.DokumentID)
        Me.InfoMeldungList.DataSource = Me.DokumentInfoMeldungen
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, Me.DokumentInfoMeldungen, "Dokumentinfomeldung")

        'Team
        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        refresh_team()
        Me.mcbteam.SelectedIndex = 0

        Me.mcbstatus.SelectedIndex = 0
        Me.savestatus = Me.mcbstatus.SelectedValue
        If Edex_Folgestatus <> 0 Then Me.mcbstatus.SelectedIndex = Edex_Folgestatus
        Me.firststatus = Me.savestatus
        Me.saveverantwortlicher = Globals.MitarbeiterNr

        Me.moeglichestati = Generic_Select(15)
        Me.cbmoeglicheStati.Items.Clear()
        Me.funktionsliste = ""
        '        Dim i As Integer
        settooltip()
        For i = 0 To Me.moeglichestati.Rows.Count - 1
            Me.cbmoeglicheStati.Items.Add(Me.moeglichestati.Rows(i).Item("bezeichnung"))
        Next
        'Rel. 3.7 SHU
        If Doktyp.bBezeichnungmut.Value = True Then
            Me.txtBezeichnung.ReadOnly = False
        Else
            Me.txtBezeichnung.ReadOnly = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Load_Defaults_Bedingte_Retournierung Method

Private Sub Load_Defaults_Bedingte_Retournierung()

Source code

[Visual Basic]
    Private Sub Load_Defaults_Bedingte_Retournierung()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        DokTypBR.cpMainConnectionProvider = conn
        DokTypBR.iDokumenttypnr = New SqlInt32(CType(Doktyp.iDoktypbedingteretournierung.Value, Int32))
        DokTypBR.SelectOne()

        If Doktyp.bFunktionen_zuweisen.Value = True Then
            Dokumentfunktionen_AktivierenBR()
        Else
            w.Save_DokumentFunktionenbr = Generic_Select(106)
        End If

        'Me.cVertraulichBR.Visible = Me.cvertraulich.Visible
        Me.txtbezeichnungbr.Text = DokTypBR.sBezeichnung.Value

        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumentid").Value = ""
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumenttypnr").Value = Me.DokTypBR.iDokumenttypnr.Value
        Me.SqlDataAdapter1.SelectCommand.Parameters("@CreateNew").Value = 1
        Me.SqlDataAdapter1.Fill(Me.Dataset1BR)
        Me.DokWertListBR.DataSource = Me.Dataset1BR
        Me.DokWertListBR.DataMember = Me.Dataset1BR.Tables(0).TableName
        For i = 3 To Me.DokWertListBR.Columns.Count - 1
            Me.DokWertListBR.Splits(0).DisplayColumns(i).Visible = False
        Next

        Me.DokWertListBR.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertListBR.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertListBR.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertListBR.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertListBR.Splits(0).DisplayColumns(2).Width = 160

        Me.zu_retournieren = Doktyp.bZu_retournieren.Value

        'Dokument ersetzen
        Me.Dokumentersetzenbr = Dokumentersetzen_Laden(Me.DokumentIDBR)
        w.save_dokumentersetzenbr = Me.Dokumentersetzenbr
        '        w.save_dokumentersetzenbr = Dokumentersetzen_Laden(Me.DokumentIDBR)
        Me.coldlistbr.DataSource = Me.Dokumentersetzenbr
        Me.coldlistbr.DataSource = Me.Dokumentersetzenbr
        Me.coldlistbr.Columns("aktiv").FilterText = True
        Me.coldlistbr.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.coldlistbr, Me.Dokumentersetzenbr, "dokumentersetzen")

        '        DivFnkt.SpaltenTitel_Aktualisieren(Me.coldlistbr, Me.Dokumentersetzenbr, "dokumentersetzen")
        If DokTypBR.bCold_ersetzen.Value <> True Then
            Me.ErsetzenMoeglichbr = False
        Else
            Me.ErsetzenMoeglichbr = True
        End If

        'Notizen
        Notizenbr = Notizen_Laden(Me.DokumentIDBR)
        Me.Notizlistbr.DataSource = Notizenbr
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlistbr, Me.Notizenbr, "notizen")

        'Dokumentzuordnungen
        Me.Dokumentzuorndungenbr = Dokumentzuordnungen_Laden(Me.DokumentIDBR)
        w.Save_Dokumentzuordnungenbr = Me.Dokumentzuorndungenbr
        '        w.Save_Dokumentzuordnungenbr = Dokumentzuordnungen_Laden(Me.DokumentIDBR)
        Me.ZuordnunglistBR.DataSource = Me.Dokumentzuorndungenbr
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ZuordnunglistBR, Me.Dokumentzuorndungenbr, "dokumentzuordnungen")
        Me.ZuordnunglistBR.Columns("aktiv").FilterText = True
        Me.ZuordnunglistBR.FilterBar = False
        Me.ZuordnunglistBR.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.ZuordnunglistBR.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.ZuordnunglistBR.Columns("zuordnungnr").ValueItems.Translate = True
        Next

        'Dokumentinfomeldungen
        Me.InFoMeldungListBR.FetchRowStyles = True
        Me.DokumentInfoMeldungenbr = Dokumentinfomeldungen_laden_Bedingte_Retournierung(Me.DokumentIDBR)
        w.Save_Dokumentinfomeldungenbr = Me.DokumentInfoMeldungenbr
        '        w.Save_Dokumentinfomeldungenbr = Dokumentinfomeldungen_laden_Bedingte_Retournierung(Me.DokumentIDBR)
        Me.InFoMeldungListBR.DataSource = Me.DokumentInfoMeldungenbr
        Me.InFoMeldungListBR.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InFoMeldungListBR, Me.DokumentInfoMeldungenbr, "Dokumentinfomeldung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Load_Edit_Document_Bedingte_Retournierung Method

Private Sub Load_Edit_Document_Bedingte_Retournierung()

Source code

[Visual Basic]
    Private Sub Load_Edit_Document_Bedingte_Retournierung()
        docbr.cpMainConnectionProvider = conn
        conn.OpenConnection()
        docbr.sDokumentid = New SqlString(CType(doc.sBedRDokumentid.Value, String))
        docbr.SelectOne()
        'newdokumentid=me.EditDokumentid
        NewDokumentIDBR = docbr.sDokumentid.Value
        Me.Partnernr = docbr.iNrpar00.Value
        w.Save_Dokumentbr = docbr.SelectOne
        Me.DokumenttypNrBr = docbr.iDokumenttypnr.Value
        DokumentIDBR = docbr.sDokumentid.Value
        Me.Load_Defaults_Bedingte_Retournierung()

        Me.SaveStatusBR = docbr.iStatusnr.Value

        Me.cGesperrtBR.Checked = docbr.bGesperrt.Value = True
        Me.bemerkungbr.Text = docbr.sBemerkung.Value
        Me.txtbezeichnungbr.Text = docbr.sBezeichnung.Value
        'Me.cVertraulichBR.Checked = docbr.bVertraulich.Value = True

        docbr.Dispose()

        Me.Dokumentersetzenbr = Dokumentersetzen_Laden(Me.DokumentIDBR)
        w.save_dokumentersetzenbr = Me.Dokumentersetzenbr
        '        w.save_dokumentersetzenbr = Dokumentersetzen_Laden(Me.DokumentIDBR)
        Me.coldlistbr.DataSource = Me.Dokumentersetzenbr
        DivFnkt.SpaltenTitel_Aktualisieren(Me.coldlistbr, Me.Dokumentersetzenbr, "dokumentersetzen")

        Me.Notizenbr = Notizen_Laden(Me.DokumentIDBR)
        w.Save_Notizenbr = Me.Notizenbr
        '        w.Save_Notizenbr = Notizen_Laden(Me.DokumentIDBR)
        Me.Notizlistbr.DataSource = Notizenbr
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlistbr, Me.Notizenbr, "notizen")

        w.Save_Dokumentwertebr = Generic_Select(110)

        Me.Dataset1BR.Clear()
        Me.Dataset1BR.Tables.Clear()
        Me.Dataset1BR.Tables.Add(DokumentwertListe_ladenbr(Me.DokumentIDBR))
        Me.DokWertListBR.DataSource = Me.Dataset1BR
        Me.DokWertListBR.DataMember = Me.Dataset1BR.Tables(0).TableName
        For i = 3 To Me.DokWertListBR.Columns.Count - 1
            Me.DokWertListBR.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertListBR.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertListBR.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertListBR.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertListBR.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertListBR.Splits(0).DisplayColumns(2).Width = 160
        conn.CloseConnection(True)

        w.Save_ColdIndexbr = Generic_Select(109)
        Me.TabControl2.Enabled = True

        Dim tmp As DataTable
        tmp = Generic_Select(112)
        w.save_historystatusbr = tmp.Rows(0).Item(0)
        tmp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim i As Integer
        Dim s As String
        s = ""
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

        Dim f As New frmBerechtigungen()
        If Me.cvertraulich.Checked Then
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 1, s)
        Else
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 0, s)
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem2_Click_Bedingte_Retournierung Method

Private Sub MenuItem2_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3Br.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3Br.Click
        Dim i As Integer
        Dim s As String
        s = ""
        Try
            For i = 0 To Me.DokumentFunktionenbr.Rows.Count - 1
                If Me.DokumentFunktionenbr.Rows(i).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionenbr.Rows(i).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

        Dim f As New frmBerechtigungen()
        If Me.cVertraulichBR.Checked Then
            f.Fill_Berechtigungen(Me.DokumenttypNrBr, Me.Partnernr, 1, s)
        Else
            f.Fill_Berechtigungen(Me.DokumenttypNrBr, Me.Partnernr, 0, s)
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmDokumentberechtigung()
        f.Dokumenttyp = Me.Dokumenttypnr
        f.Partnernr = Me.Partnernr
        f.Vertraulich = Me.cvertraulich.Checked
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = DokumentFunktionen.Rows
            Dim rowvals(Me.DokumentFunktionenList.Columns.Count - 1)
            rowvals(0) = System.DBNull.Value
            rowvals(1) = f.Funktionsgruppebezeichnung
            rowvals(2) = f.Funktionsgruppenr
            rowvals(3) = f.Anzeigen
            rowvals(4) = f.Bearbeiten
            rowvals(5) = f.Loeschen
            rowvals(6) = f.Abschliessen
            rowvals(7) = True
            rowvals(8) = Now
            rowvals(9) = Globals.MitarbeiterNr
            newrow = rc.Add(rowvals)
            Me.DokumentFunktionenList.Refresh()
            For i = 0 To Me.DokumentFunktionenList.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenList.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                    Me.DokumentFunktionenList.Bookmark = i
                End If
            Next
            Me.FillMcbVerantwortlich()
            If Me.BedingteRetournierung = True Then
                'Einfügen bei Bedingter Retournierung
                Dim rcbr As DataRowCollection
                Dim newrowbr As DataRow
                rc = DokumentFunktionenbr.Rows
                Dim rowvalsbr(Me.DokumentFunktionenListBR.Columns.Count - 1)
                rowvals(0) = System.DBNull.Value
                rowvals(1) = f.Funktionsgruppebezeichnung
                rowvals(2) = f.Funktionsgruppenr
                rowvals(3) = f.Anzeigen
                rowvals(4) = f.Bearbeiten
                rowvals(5) = f.Loeschen
                rowvals(6) = f.Abschliessen
                rowvals(7) = True
                rowvals(8) = Now
                rowvals(9) = Globals.MitarbeiterNr
                newrow = rc.Add(rowvals)
                Me.DokumentFunktionenListBR.Refresh()
                For i = 0 To Me.DokumentFunktionenListBR.Splits(0).Rows.Count - 1
                    If Me.DokumentFunktionenListBR.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                        Me.DokumentFunktionenListBR.Bookmark = i
                    End If
                Next
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem3_Click_Bedingte_Retournierung Method

Private Sub MenuItem3_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem20.Click
        Dim f As New frmDokumentberechtigung()
        f.Dokumenttyp = Me.DokumenttypNrBr
        f.Partnernr = Me.Partnernr
        f.Vertraulich = Me.cVertraulichBR.Checked
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = DokumentFunktionenbr.Rows
            Dim rowvals(Me.DokumentFunktionenListBR.Columns.Count - 1)
            rowvals(0) = System.DBNull.Value
            rowvals(1) = f.Funktionsgruppebezeichnung
            rowvals(2) = f.Funktionsgruppenr
            rowvals(3) = f.Anzeigen
            rowvals(4) = f.Bearbeiten
            rowvals(5) = f.Loeschen
            rowvals(6) = f.Abschliessen
            rowvals(7) = True
            rowvals(8) = Now
            rowvals(9) = Globals.MitarbeiterNr
            newrow = rc.Add(rowvals)
            Me.DokumentFunktionenListBR.Refresh()
            For i = 0 To Me.DokumentFunktionenListBR.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenListBR.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                    Me.DokumentFunktionenListBR.Bookmark = i
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        'Entfernen Bedingte Retournierung
        If Me.BedingteRetournierung = True Then
            Dim i As Integer
            For i = 0 To Me.DokumentFunktionenListBR.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenListBR.Columns("bezeichnung").CellText(i) = Me.DokumentFunktionenList.Columns("bezeichnung").Text Then
                    Me.DokumentFunktionenListBR.Bookmark = i
                    Me.DokumentFunktionenListBR.Columns(7).Value = False
                    Me.Button3.Focus()
                    Me.DokumentFunktionenListBR.Focus()
                End If
            Next
        End If

        Me.DokumentFunktionenList.Columns(7).Value = False
        Me.DokumentFunktionenList.Refresh()
        Me.Button3.Focus()
        Me.DokumentFunktionenList.Focus()
        Me.FillMcbVerantwortlich()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem4_Click_Bedingte_Retournierung Method

Private Sub MenuItem4_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem21.Click
        Me.DokumentFunktionenListBR.Columns(7).Value = False
        Me.DokumentFunktionenListBR.Refresh()
        Me.Button3Br.Focus()
        Me.DokumentFunktionenListBR.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        'fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.Button9.Visible = False
        fx.BtnHelp.Visible = False
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                If Check_Dokumentersetzen(Me.Dokumenttypnr, fx.SelectedDokumentid, True) Then
                    Dim rc As DataRowCollection
                    Dim newrow As DataRow
                    rc = Dokumentersetzen.Rows
                    Dim rowvals(Me.Dokumentersetzen.Columns.Count - 1) As Object
                    rowvals(0) = System.DBNull.Value
                    rowvals(1) = ""
                    If Me.CreateDocument Then
                        rowvals(1) = ""
                    Else
                        rowvals(1) = Me.DokumentID
                    End If
                    rowvals(2) = fx.SelectedDokumentid
                    rowvals(3) = True

                    rowvals(8) = fx.Dokumentbezeichnung
                    rowvals(9) = fx.dokumentdatum
                    newrow = rc.Add(rowvals)
                    Me.ColdList.Refresh()
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem5_Click_Bedingte_Retournierung Method

Private Sub MenuItem5_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                If Check_Dokumentersetzen(Me.DokumenttypNrBr, fx.SelectedDokumentid) Then
                    Dim rc As DataRowCollection
                    Dim newrow As DataRow
                    rc = Dokumentersetzenbr.Rows
                    Dim rowvals(Me.Dokumentersetzenbr.Columns.Count - 1) As Object
                    rowvals(0) = System.DBNull.Value
                    rowvals(1) = ""
                    If Me.CreateDocument Then
                        rowvals(1) = ""
                    Else
                        rowvals(1) = Me.DokumentIDBR
                    End If
                    rowvals(2) = fx.SelectedDokumentid
                    rowvals(3) = True

                    rowvals(8) = fx.Dokumentbezeichnung
                    rowvals(9) = fx.dokumentdatum
                    newrow = rc.Add(rowvals)
                    Me.coldlistbr.Refresh()
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Me.ColdList.Columns("aktiv").Value = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MenuItem6_Click_Bedingte_Retournierung Method

Private Sub MenuItem6_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem12.Click
        Me.coldlistbr.Columns("aktiv").Value = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Try
            Me.Notizlist.Columns(5).Value = False
            Me.Notizlist.Refresh()
            Me.TabControl2.Select()
            Me.Notizlist.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDeleteNotiz_Click_Bedingte_Retournierung Method

Private Sub MnuDeleteNotiz_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem19.Click
        Try
            Me.Notizlistbr.Columns(5).Value = False
            Me.Notizlistbr.Refresh()
            Me.TabControl2.Select()
            Me.Notizlistbr.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDokZuordnungAdd_Click Method

Private Sub MnuDokZuordnungAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokZuordnungAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokZuordnungAdd.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.Button9.Visible = False
        fx.BtnHelp.Visible = False
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                Dim rc As DataRowCollection
                Dim newrow As DataRow
                rc = Me.Dokumentzuorndungen.Rows
                Dim rowvals(Me.Dokumentzuorndungen.Columns.Count - 1) As Object
                rowvals(0) = 0
                rowvals(2) = 1
                rowvals(6) = 1
                rowvals(8) = fx.SelectedDokumentid
                rowvals(10) = fx.Dokumentbezeichnung

                newrow = rc.Add(rowvals)
                Me.ZuordnungList.Refresh()
                'For i = 0 To Me.ZuordnungList.Splits(0).Rows.Count - 1
                'If Me.ZuordnungList.Columns(0).CellText(i) = fx.SelectedDokumentid Then
                '    Me.ZuordnungList.Bookmark = i
                'End If
                'Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDokZuordnungAdd_Click_Bedingte_Retournierung Method

Private Sub MnuDokZuordnungAdd_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungAdd_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.Button9.Visible = False
        fx.BtnHelp.Visible = False

        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                Dim rc As DataRowCollection
                Dim newrow As DataRow
                rc = Me.Dokumentzuorndungenbr.Rows
                Dim rowvals(Me.Dokumentzuorndungenbr.Columns.Count - 1) As Object
                rowvals(0) = 0
                rowvals(2) = 1
                rowvals(6) = 1
                rowvals(8) = fx.SelectedDokumentid
                rowvals(10) = fx.Dokumentbezeichnung
                newrow = rc.Add(rowvals)
                Me.ZuordnunglistBR.Refresh()

            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDokzuordnungDelete_Click Method

Private Sub MnuDokzuordnungDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokzuordnungDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokzuordnungDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokzuordnungDelete.Click
        Me.ZuordnungList.Columns("aktiv").Value = False
        Me.ZuordnungList.Refresh()
        Me.TabControl2.Select()
        Me.ZuordnungList.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuDokzuordnungDelete_Click_Bedingte_Retournierung Method

Private Sub MnuDokzuordnungDelete_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokzuordnungDelete_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Me.ZuordnunglistBR.Columns("aktiv").Value = False
        Me.ZuordnunglistBR.Refresh()
        Me.TabControl2.Select()
        Me.ZuordnunglistBR.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlist.Columns("betreff").Value = f.Betreff
            Me.Notizlist.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlist.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuEditNotiz_Click_Bedingte_Retournierung Method

Private Sub MnuEditNotiz_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlistbr.Columns("betreff").Value
        f.Notiz = Me.Notizlistbr.Columns("Notiz").Value
        f.Mutierer = Me.Notizlistbr.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlistbr.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlistbr.Columns("betreff").Value = f.Betreff
            Me.Notizlistbr.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlistbr.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim f As New frmNotizen()
        f.Mutierer = Globals.MitarbeiterNr.ToString
        f.Notiz = ""
        f.Betreff = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizen.Rows
            Dim rowvals(Me.Notizen.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer

            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizen
            load_Mitarbeiter()

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuNeueNotiz_Click_Bedingte_Retournierung Method

Private Sub MnuNeueNotiz_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        Dim f As New frmNotizen()
        Dim objMitarbeiter As New edokadb.clsMitarbeiter()
        objMitarbeiter.cpMainConnectionProvider = conn
        objMitarbeiter.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        objMitarbeiter.SelectOne()

        f.Notiz = ""
        f.Betreff = ""
        f.Mutierer = objMitarbeiter.sName.ToString & " " & objMitarbeiter.sVorname.ToString & " , " & objMitarbeiter.sTgnummer.ToString
        objMitarbeiter.Dispose()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizenbr.Rows
            Dim rowvals(Me.Notizenbr.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer

            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizenbr

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlistbr, Me.Notizenbr, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlistbr.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlistbr.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuShowDoc_Click Method

Private Sub MnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowDoc.Click
        DivFnkt.ShowDoc(Me.ZuordnungList.Columns(8).Text, Me)
        'Dim doc As New edokadb.clsDokument()
        'Dim Dokument As String
        'Dim FileReader As New DocMgmt()
        'doc.cpMainConnectionProvider = conn
        'doc.sDokumentid = New SqlString(CType(Me.ZuordnungList.Columns(1).Text, String))
        'doc.SelectOne()
        'Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
        'FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument)
        'doc.Dispose()
        'FileReader = Nothing
        'Dim w As New WordLib()
        'w.ShowDoc(Dokument)
        'w = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuShowDoc_Click_Bedingte_Retournierung Method

Private Sub MnuShowDoc_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        DivFnkt.ShowDoc(Me.ZuordnunglistBR.Columns(8).Text, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuValueSelect_Click Method

Private Sub MnuValueSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuValueSelect.Click, _
   DokWertList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuValueSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuValueSelect.Click, DokWertList.DoubleClick
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim s As String
        Dim i As Integer
        Select Case UCase(Me.DokWertList.Columns("feldtyp").Value)
            Case "DATUMSHORT"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToShortDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMMEDIUM"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart
                    s = Format(f.MonthCalendar1.SelectionStart, "dd. MMMM yyyy")
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMLONG"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToLongDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()

            Case "TEXT"
                If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 8) = "&Partner" Then
                    Dim f As New FrmPartnersuche()
                    f.ShowDialog()
                    If f.PartnerNr <> 0 Then
                        Me.DokWertList.Columns("feldwert").Value = Str(f.PartnerNr) + "-" + f.PartnerKurzbezeichnnung
                    End If
                    f.Dispose()
                Else
                    If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 1) = "&" Then
                        Dim f As New frmValueSelector()
                        If Me.DokWertList.Columns("Datenherkunft").Value = "&SekPartnerVV&" Then
                            Dim ss As String
                            Dim ii As Integer
                            For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner&" Then
                                    ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                End If
                            Next
                            ii = InStr(ss, "-")
                            If ii < 1 Then Exit Sub
                            f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                        Else
                            If Me.DokWertList.Columns("Datenherkunft").Value = "&TerPartnerVV&" Then
                                Dim ss As String
                                Dim ii As Integer
                                For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                    If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner3&" Then
                                        ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                    End If
                                Next
                                ii = InStr(ss, "-")
                                If ii < 1 Then Exit Sub
                                f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                            Else
                                f.partnernr = Me.txtPartnerInhaberNr.Text()
                            End If
                        End If
                        f.Text = f.Text + Me.DokWertList.Columns(0).Value
                        f.Datenherkunft = Me.DokWertList.Columns("Datenherkunft").Value
                        'f.partnernr = Me.txtPartnerInhaberNr.Text()
                        f.LoadData()
                        If f.Datenvorhanden = True Then
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then Me.DokWertList.Columns("feldwert").Value = f.SelWert
                        End If
                        f.Dispose()
                    End If
                    End If
            Case Else
        End Select
        If Me.BedingteRetournierung = True Then
            For i = 0 To Me.DokWertListBR.Splits(0).Rows.Count - 1
                If Me.DokWertListBR.Columns("bezeichnung").CellText(i) = Me.DokWertList.Columns("Bezeichnung").Text Then
                    If Me.DokWertListBR.Columns("feldwert").CellText(i) = "" Then
                        Me.DokWertListBR.Bookmark = i
                        Me.DokWertListBR.Columns("feldwert").Text = Me.DokWertList.Columns("Feldwert").Text
                    End If
                End If
            Next
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Me.ActiveControl = Me.TabControl2
        Me.ActiveControl = Me.DokWertList
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.MnuValueSelect_Click_Bedingte_Retournierung Method

Private Sub MnuValueSelect_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem22.Click, _
   DokWertListBR.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuValueSelect_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem22.Click, DokWertListBR.DoubleClick
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim s As String
        Select Case UCase(Me.DokWertListBR.Columns("feldtyp").Value)
            Case "DATUM"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart
                    Me.DokWertListBR.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "TEXT"
                If Microsoft.VisualBasic.Left(Me.DokWertListBR.Columns("Datenherkunft").Value, 8) = "&Partner" Then
                    Dim f As New FrmPartnersuche()
                    f.ShowDialog()
                    If f.PartnerNr <> 0 Then
                        Me.DokWertListBR.Columns("feldwert").Value = Str(f.PartnerNr) + "-" + f.PartnerKurzbezeichnnung
                    End If
                    f.Dispose()
                Else
                    If Microsoft.VisualBasic.Left(Me.DokWertListBR.Columns("Datenherkunft").Value, 1) = "&" Then
                        Dim f As New frmValueSelector()
                        If Me.DokWertListBR.Columns("Datenherkunft").Value = "&SekPartnerVV&" Then
                            Dim ss As String
                            Dim ii As Integer
                            ss = Me.DokWertListBR.Columns("feldwert").CellText(0)
                            ii = InStr(ss, "-")
                            If ii < 1 Then Exit Sub
                            f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                        Else
                            f.partnernr = Me.txtPartnerInhaberNr.Text()
                        End If
                        f.Text = f.Text + Me.DokWertListBR.Columns(0).Value
                        f.Datenherkunft = Me.DokWertListBR.Columns("Datenherkunft").Value
                        'f.partnernr = Me.txtPartnerInhaberNr.Text()
                        f.LoadData()
                        If f.Datenvorhanden = True Then
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then Me.DokWertListBR.Columns("feldwert").Value = f.SelWert
                        End If
                        f.Dispose()
                    End If
                End If
            Case Else
        End Select
        Me.ActiveControl = Me.TabControl2
        Me.ActiveControl = Me.DokWertList
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizen_Laden Method

Private Function Notizen_Laden( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Notizen_Laden(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizen_Sichern Method

Public Sub Notizen_Sichern()

Source code

[Visual Basic]
    Public Sub Notizen_Sichern()
        For i = 0 To Me.Notizen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizen_Sichern_Bedingte_Retournierung Method

Public Sub Notizen_Sichern_Bedingte_Retournierung()

Source code

[Visual Basic]
    Public Sub Notizen_Sichern_Bedingte_Retournierung()
        For i = 0 To Me.Notizenbr.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentIDBR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizenbr.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizenbr.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizenbr.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizenbr.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Notizlist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Notizlist.DoubleClick
        MnuEditNotiz_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizlist_DoubleClick_Bedingte_Retournierung Method

Private Sub Notizlist_DoubleClick_Bedingte_Retournierung( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Notizlistbr.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick_Bedingte_Retournierung(ByVal sender As Object, ByVal e As System.EventArgs) Handles Notizlistbr.DoubleClick
        MnuEditNotiz_Click_Bedingte_Retournierung(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Notizlist_MouseUp Method

Private Sub Notizlist_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseUp
        If Me.Notizen.Rows.Count = 0 Then Exit Sub
        Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.RBZustaendigZustaendiger_CheckedChanged Method

Private Sub RBZustaendigZustaendiger_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBZustaendigZustaendiger.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBZustaendigZustaendiger_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBZustaendigZustaendiger.CheckedChanged
        Me.mcbkube.Enabled = False
        Me.mcbzust.Enabled = True
        Me.mcbzust.Focus()

        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            Me.refresh_team()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Set_DokumentZuErsetzen Method

Private Function Set_DokumentZuErsetzen()

Source code

[Visual Basic]
    Private Function Set_DokumentZuErsetzen()
        Try
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Dokumentersetzen.Rows
            Dim rowvals(Me.Dokumentersetzen.Columns.Count - 1) As Object
            rowvals(0) = System.DBNull.Value
            rowvals(1) = ""
            If Me.CreateDocument Then
                rowvals(1) = ""
            Else
                rowvals(1) = Me.DokumentID
            End If
            rowvals(2) = m_KopyDokID
            rowvals(3) = True

            rowvals(8) = m_KopyErsetzDokBez
            rowvals(9) = m_KopyErsetzDokDatum
            newrow = rc.Add(rowvals)
            '? Me.ColdList.Refresh()
            'Test Stop

        Catch
            MsgBox(Err.Description)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Set_Feldwert Method

Private Sub Set_Feldwert()

Source code

[Visual Basic]
    Private Sub Set_Feldwert()
        Try
            'Me.DokWertList.Columns("feldwert").Value = Me.ValueList.Columns(0).Value
            'Me.DokWertList.Columns("feldwert").Value = Me.Datumselect.Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Status_History Method

Private Function Status_History( _
   ByVal statusnr As Long, _
   ByVal dokumentid As String _
)

Parameters

statusnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Status_History(ByVal statusnr As Long, ByVal dokumentid As String)
        Dim statush As New Statushandling()
        Dim i, i1 As Integer
        If Me.saveverantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.savestatus = Me.mcbstatus.SelectedValue And Not Me.CreateDocument And Me.mcbstatus.SelectedIndex = 0 Then
            If Globals.dokumentcoldindex_status = "" Then
                statush.Dispose()
                Exit Function
            End If
        End If
        If Me.CreateDocument Then
            i = Me.mcbstatus.SelectedValue
            Me.mcbstatus.SelectedIndex = 0
            statush.insert_history_status(get_current_Status(dokumentid), dokumentid, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(1000)
            Me.mcbstatus.SelectedValue = i
            If Me.mcbstatus.SelectedIndex <> 0 Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(get_current_Status(dokumentid), dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
            w.send_statusmessage = True
        Else
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbstatus.SelectedIndex <> 0 Or Globals.dokumentcoldindex_status <> "" Then
                i = Me.mcbstatus.SelectedValue
                Me.mcbstatus.SelectedIndex = 0
                Me.savestatus = Me.mcbstatus.SelectedValue
                statush.insert_history_status(Me.mcbstatus.SelectedValue, dokumentid, Globals.MitarbeiterNr)
                w.send_statusmessage = True
                Me.mcbstatus.SelectedValue = i
                System.Threading.Thread.CurrentThread.Sleep(1000)
            End If
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(Me.mcbstatus.SelectedValue, dokumentid, Me.mcbverantwortlich.SelectedValue)
            End If
        End If

        statush.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Status_History_Bedingte_Retournierung Method

Private Function Status_History_Bedingte_Retournierung( _
   ByVal statusnr As Long, _
   ByVal dokumentid As String _
) As Integer

Parameters

statusnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Status_History_Bedingte_Retournierung(ByVal statusnr As Long, ByVal dokumentid As String) As Integer
        Dim xstatusnr As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.CommandText = "dbo.SP_get_erster_status"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            xstatusnr = scmCmdToExecute.Parameters("@status").Value

        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Erster_Status::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

        Dim statush As New Statushandling()
        Dim i, i1 As Integer

        If Me.CreateDocument = True Then
            statush.insert_history_status(xstatusnr, dokumentid, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(1000)
            statush.Dispose()
            Return xstatusnr
            Exit Function
        End If

        If (Me.saveverantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.SaveStatusBR = statusnr) Then
            Exit Function
        End If

        statush.insert_history_status(xstatusnr, dokumentid, Globals.MitarbeiterNr)
        System.Threading.Thread.CurrentThread.Sleep(1000)
        statush.Dispose()
        Return xstatusnr
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.TMP_Funktion Method

Private Sub TMP_Funktion( _
   ByVal funktion As Integer, _
   ByVal fnr As Integer, _
   ByVal anz As Integer, _
   ByVal bea As Integer, _
   ByVal loe As Integer, _
   ByVal abs As Integer _
)

Parameters

funktion
Required.
fnr
Required.
anz
Required.
bea
Required.
loe
Required.
abs
Required.

Source code

[Visual Basic]
    Private Sub TMP_Funktion(ByVal funktion As Integer, ByVal fnr As Integer, ByVal anz As Integer, ByVal bea As Integer, ByVal loe As Integer, ByVal abs As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_tmp_berechtigungseinschraenkung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, funktion))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, anz))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, bea))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, loe))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, abs))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.TabControl2_Click Method

Private Sub TabControl2_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabControl2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl2_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControl2.Click
        Select Case Me.TabControl2.SelectedTab.Name
            Case "TabPage5"
                load_Mitarbeiter()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.TabControl2_DrawItem Method

Private Sub TabControl2_DrawItem( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DrawItemEventArgs _
) Handles TabControl2.DrawItem

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl2_DrawItem(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DrawItemEventArgs) Handles TabControl2.DrawItem
        If (e.State And DrawItemState.Selected) = DrawItemState.Selected Then
            e.Graphics.FillRectangle(Brushes.WhiteSmoke, TabControl2.GetTabRect(e.Index))
            e.Graphics.DrawString(TabControl2.TabPages(e.Index).Text, New Font("Arial", 10), Brushes.Red, RectangleF.op_Implicit(TabControl2.GetTabRect(e.Index)))

        Else
            e.Graphics.FillRectangle(Brushes.LightGray, TabControl2.GetTabRect(e.Index))
            e.Graphics.DrawString(TabControl2.TabPages(e.Index).Text, New Font("Arial", 10), Brushes.Black, RectangleF.op_Implicit(TabControl2.GetTabRect(e.Index)))
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.TabControl2_SelectedIndexChanged Method

Private Sub TabControl2_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl2.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl2_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl2.SelectedIndexChanged
        Me.changeteam = 2
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Update_Bclabel Method

Private Sub Update_Bclabel( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Sub Update_Bclabel(ByVal typ As Integer)
        If Me.BarcodeID = "" Then Exit Sub
        Dim bc As New edokaDB.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        bc.iBarcodenr = New SqlInt32(CType(Me.BarcodeID, Int32))
        bc.SelectOne()
        conn.OpenConnection()
        If typ = 2 And Me.CreateDocument = True Then
            bc.sDokumentid = New SqlString(CType("", String))
        Else
            bc.sDokumentid = New SqlString(CType(Me.DokumentID, String))
        End If
        bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        bc.Update()
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.Update_Bedingte_Retournierung Method

Private Sub Update_Bedingte_Retournierung()

Source code

[Visual Basic]
    Private Sub Update_Bedingte_Retournierung()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.bereiche_sperren Method

Private Sub bereiche_sperren()

Source code

[Visual Basic]
    Private Sub bereiche_sperren()
        Me.btnPartnerInhaber.Enabled = False
        Me.GroupBox1.Enabled = False
        Me.GroupBox2.Enabled = False
        Me.GroupBox3.Enabled = False
        Me.GroupBox4.Enabled = False
        Me.GroupBox5.Enabled = False
        Me.GroupBox10.Enabled = False
        Me.GroupBox11.Enabled = False
        Me.GroupBox12.Enabled = False
        Me.GroupBox9.Enabled = False
        Me.Button2.Enabled = False
        Me.pnlBerechtigungen.Enabled = False
        Me.pnlBerechtigungenBR.Enabled = False
        Me.cbVerantwortlich.Enabled = False
        Me.mcbverantwortlich.Enabled = False
        Me.cbdokumentstatus.Enabled = False
        Me.mcbstatus.Enabled = False
        Me.DokWertList.Enabled = False
        Me.cdokumentwerteanzeigen.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        If Me.CreateDocument = False Then
            If Globals.Dokumentcoldindex_Changed Then Archivfnkt.Restore_Coldindex(Globals.general_ds.Tables(0), Me.DokumentID)
            If Globals.dokumentid_changed Then Archivfnkt.change_dokumentid(DokumentID, Globals.Dokumentidalt)
            If Me.BedingteRetournierung = True Then
                If Globals.DokumentColdIndex_ChangedBR Then Archivfnkt.Restore_Coldindex(Globals.general_dsbr.Tables(0), Me.DokumentIDBR)
                If Globals.dokumentid_changedbr Then
                    Archivfnkt.change_dokumentid(Me.DokumentIDBR, Globals.Dokumentidaltbr)
                    Dim dok As New edokadb.clsDokument()
                    dok.cpMainConnectionProvider = conn
                    dok.sDokumentid = New SqlString(CType(Globals.Dokumentidalt, String))
                    dok.SelectOne()
                    dok.sBedRDokumentid = New SqlString(CType(Globals.Dokumentidaltbr, String))
                    conn.OpenConnection()
                    dok.Update()
                    conn.CloseConnection(True)
                End If
            End If
        Else
            Update_Bclabel(2)
        End If
        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
        If Me.BedingteRetournierung = True Then
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentIDBR, False, "")
        End If
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        Dim f As New FrmPartnersuche()
        f.profilnr = Me.Profilnr
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.NurAbfrage = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, f.PartnerNr, "", 2, 0, 0, 0) Then
                If Me.txtPartnerInhaber.Text <> "" And Me.txtPartnerInhaber.Text <> Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung Then
                    MyMsg.show_standardmessage(73, MsgBoxStyle.Information)
                End If
                Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                Me.txtPartnerInhaberNr.Text = f.PartnerNr
                Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                Me.TabControl2.Enabled = True
                Me.RBZustaendigZustaendiger.Checked = True
                Me.mcbkube.DataSource = Nothing
                Me.mcbkube.Text = ""
                Me.mcbkube.Items.Clear()
                Me.Partnernr = f.PartnerNr
                Me.VIBeachten = f.VIBeachten
                FillMcbVerantwortlich()
                'EDEX Banklagernd
                Banklagernd_Check()

            Else
                MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                Me.Close()
            End If
            If Me.VIBeachten = True Then
                Me.PicVIBeachten.Visible = True
                Me.LabelVIBeachten.Visible = True
            Else
                Me.PicVIBeachten.Visible = False
                Me.LabelVIBeachten.Visible = False
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
        p.SelectOne()
        If p.bSaldiert.Value = True Then
            If Doktyp.bVertrag.Value = True Then
                MyMsg.show_standardmessage(234, MsgBoxStyle.Critical)
                p.Dispose()
                Exit Sub
            End If
        End If
        p.Dispose()
        If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
            If DivFnkt.EDOKA_Partner_Dokument(3, Me.Dokumenttypnr) = False Then
                MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                Exit Sub
            End If
        End If
        Dim xdata As DataTable
        Dim s As String
        If Me.savestatus = Me.mcbstatus.SelectedValue And Me.savestatus = Me.firststatus Then
            If MyMsg.Show_HinweisMessage(Me.Profilnr, 2, 71, 2) = False Then
                Exit Sub
            End If
        End If
        If Me.txtPartnerInhaber.Text = "" Then
            MyMsg.show_standardmessage(205, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Me.mcbverantwortlich.Text = "" Then
            MyMsg.show_standardmessage(208, MsgBoxStyle.Critical)
            Exit Sub
        End If
        'EDEX Banklagernd
        If Me.Check_Existing_Adresse = True And Trim(Me.txtZustelladresse.Text) = "" Then
            MyMsg.show_standardmessage(610, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Check_Dokumentfunktionen() = False Then Exit Sub
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("zwingend") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("zwingend") = True Then
                    If xdata.Rows(i).Item("feldwert") Is System.DBNull.Value Or xdata.Rows(i).Item("feldwert") = "" Then
                        MyMsg.show_standardmessage(206, MsgBoxStyle.Critical)
                        xdata.Dispose()
                        Me.TabControl2.SelectedIndex = 0
                        Me.DokWertList.Focus()
                        Exit Sub
                    End If
                End If
            End If
        Next
        If Me.BedingteRetournierung = True Then
            xdata = Me.Dataset1BR.Tables(0)
            For i = 0 To xdata.Rows.Count - 1
                If xdata.Rows(i).Item("zwingend") Is System.DBNull.Value Then
                Else
                    If xdata.Rows(i).Item("zwingend") = True Then
                        If xdata.Rows(i).Item("feldwert") Is System.DBNull.Value Or xdata.Rows(i).Item("feldwert") = "" Then
                            MyMsg.show_standardmessage(206, MsgBoxStyle.Critical)
                            '                            Me.TabControl2.TabPages(4).Select()
                            '                            Me.TabControl2.TabPages(4).BringToFront()
                            '                            Me.TabControl2.TabPages(4).Focus()
                            Me.TabControl2.SelectedIndex = 4
                            Me.TabControl1.SelectedIndex = 0
                            Me.DokWertListBR.Focus()
                            xdata.Dispose()
                            Exit Sub
                        End If
                    End If
                End If
            Next
        End If
        If Me.mcbteam.SelectedValue = 0 Then
            MyMsg.show_standardmessage(207, MsgBoxStyle.Critical)
            Me.mcbteam.Focus()
            Exit Sub
        End If
        xdata.Dispose()
        Me.btnWeiter.Enabled = False
        DivFnkt.TraceLog("Start")
        Dokument_Bearbeiten(Me.CreateDocument)
        Try
            'Win32API.ShowWindow(w.HND, Win32API.SW_Maximize)
            'Win32API.BringWindowToTop(w.HND)
            'Win32API.SetActiveWindow(w.HND)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.btntxtBemerkung_Click Method

Private Sub btntxtBemerkung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btntxtBemerkung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btntxtBemerkung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btntxtBemerkung.Click
        Dim f As New frmtxtBemerkung()
        f.txtBemerkung.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then Me.txtBemerkungVerantwortlicher = f.txtBemerkung.Text
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cbKube_SelectedIndexChanged Method

Private Sub cbKube_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbKube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.SelectedIndexChanged
        If Me.changeteam > 0 Then
            Me.changeteam = Me.changeteam - 1
            Exit Sub
        End If
        'Private Sub cbKube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.TextChanged
        Try
            Me.teamzustaendig = Me.mcbkube.SelectedValue
        Catch
        End Try
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cbmoeglicheStati_DropDown Method

Private Sub cbmoeglicheStati_DropDown( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.DropDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.DropDown
        Me.cbmoeglicheStati.Width = 200
        Me.cbsave.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cbmoeglicheStati_Leave Method

Private Sub cbmoeglicheStati_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.Leave
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cbmoeglicheStati_SelectedValueChanged Method

Private Sub cbmoeglicheStati_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedValueChanged
        Dim i As Integer
        Dim DATA As DataTable
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
        Me.txtstatus.Text = Me.cbmoeglicheStati.Text
        Me.Label3.Visible = True
        Me.txtstatus.Visible = True
        If Me.txtstatus.Text = Me.mcbstatus.Text Then
            Me.Label3.Visible = False
            Me.txtstatus.Visible = False
            Me.funktionsliste = ""
            Me.selectedstatus = 0
        Else
            For i = 0 To Me.moeglichestati.Rows.Count - 1
                If Me.txtstatus.Text = Me.moeglichestati.Rows(i).Item("bezeichnung") Then
                    Me.selectedstatus = Me.moeglichestati.Rows(i).Item("nr")
                End If
            Next
        End If
        Me.funktionsliste = ""
        DATA = Generic_Select(16)
        For i = 0 To DATA.Rows.Count - 1
            If Me.funktionsliste <> "" Then Me.funktionsliste = Me.funktionsliste + ";"
            Me.funktionsliste = Me.funktionsliste + LTrim(DATA.Rows(i).Item("funktionnr"))
        Next
        fill_mcbmitarbeiter()
        Me.mcbverantwortlich.SelectedValue = Me.saveverantwortlicher
        Me.mcbverantwortlich.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cbzust_SelectedIndexChanged Method

Private Sub cbzust_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.SelectedIndexChanged
        'Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.TextChanged
        If Me.changeteam > 0 Then
            Me.changeteam = Me.changeteam - 1
            Exit Sub
        End If
        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.check_banklagernd Method

Private Function check_banklagernd() As Integer

Source code

[Visual Basic]
    Private Function check_banklagernd() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_banklagernd"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@banklagernd", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters.Item("@banklagernd").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.cvertraulich_CheckedChanged Method

Private Sub cvertraulich_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cvertraulich.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cvertraulich_CheckedChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cvertraulich.CheckedChanged
        Try
            FillMcbVerantwortlich()
            Me.mcbverantwortlich.Focus()
            Me.mcbkube.SelectAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.delete_tmp_funktionen Method

Private Sub delete_tmp_funktionen()

Source code

[Visual Basic]
    Private Sub delete_tmp_funktionen()
        Dim i As Integer
        TMP_Funktion(3, 0, 0, 0, 0, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbverantwortlich.DataSource = Nothing
        Me.mcbverantwortlich.Items.Clear()
        Me.mcbverantwortlich.CheckNullValue = True
        Me.mcbverantwortlich.NullValueMessage = MyTxt.gettext(18)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        Me.mcbverantwortlich.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.DokumentID, 3, 0, 0, 0, Me.funktionsliste), False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.frmDokumentbearbeitung_Load Method

Private Sub frmDokumentbearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentbearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        progress.Bar1.Value = 10
        progress.Info.Text = "Vorbereitung Dokumenterstellung"
        progress.Refresh()
        progress.Show()
        progress.Refresh()
        tbp0 = Me.TabControl2.TabPages(0)
        tbp1 = Me.TabControl2.TabPages(1)
        tbp2 = Me.TabControl2.TabPages(2)
        tbp3 = Me.TabControl2.TabPages(3)
        tbp4 = Me.TabControl2.TabPages(4)
        Me.TabControl2.TabPages.Clear()
        Me.TabControl2.TabPages.Add(tbp0)
        Me.TabControl2.TabPages.Add(tbp1)
        Me.TabControl2.TabPages.Add(tbp2)
        Me.TabControl2.TabPages.Add(tbp3)
        progress.Bar1.Value = 20
        progress.Refresh()
        Me.On_Load = True
        w.save_stv = Globals.stv
        If Me.CreateDocument Then
            Formular_Laden_Create_Document()
            Me.progress.Bar1.Value = 90
            progress.Refresh()
            If Me.Partnernr <> "" Then
                If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, Me.Partnernr, "", 2, 0, 0, 0) Then
                    Dim f As New FrmPartnersuche()
                    f.Dokumenterstellen = True
                    f.Dokumenttypnrnr = Me.Dokumenttypnr
                    f.Partner_Suche(Me.Partnernr)
                    Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                    If Me.txtPartnerInhaber.Text = " 0 " Then Me.txtPartnerInhaber.Text = ""
                    Me.txtPartnerInhaberNr.Text = f.PartnerNr
                    Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                    Me.TabControl2.Enabled = True
                    Me.VIBeachten = f.VIBeachten
                    f.Dispose()
                    'EDEX Banklagernd
                    Me.progress.Hide()
                    Me.Banklagernd_Check()

                Else
                    MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                    Me.Close()
                End If
            Else
                Me.progress.Hide()
                btnPartnerInhaber_Click(sender, e)
            End If
            If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
                Me.cbKube.SelectedValue = Globals.MitarbeiterNr
            End If
            Me.cbmoeglicheStati.Visible = False
            Me.cbsave.Visible = False
        Else
            Formular_laden_Edit_Document()
            Me.progress.Bar1.Value = 90
            progress.Refresh()
            Dim bc As New DataTable()
            bc = Generic_Select(11)
            If bc.Rows.Count > 0 Then
                Me.BarcodeID = LTrim(Str(bc.Rows(0).Item(0)))
            End If
            bc.Dispose()
            Me.cbmoeglicheStati.Visible = True
            Me.cbsave.Visible = True
        End If
        If Me.BarcodeID <> "" Or Me.Dokumentinfobearbeiten = True Then
            Me.cdokumentwerteanzeigen.Visible = False
        Else
            Me.cdokumentwerteanzeigen.Visible = True
        End If

        ' Bedingte Retournierung
        ' SHU 02.03.2004
        If BedingteRetournierung = True Then
            Bedingte_Retournierung()
        End If
        Me.progress.Bar1.Value = 100
        progress.Refresh()
        'Bedingte Retournierung Ende

        Me.On_Load = False
        If Me.Dokument_Ist_Abgeschlossen Then bereiche_sperren()
        If Me.VIBeachten = True Then
            Me.PicVIBeachten.Visible = True
            Me.LabelVIBeachten.Visible = True
        Else
            Me.PicVIBeachten.Visible = False
            Me.LabelVIBeachten.Visible = False
        End If

        If m_KopyDokErsetzten = True Then
            Set_DokumentZuErsetzen()
        End If

        If BedingteRetournierung = True Then
            progress.Hide()
            Me.Visible = True
            If MyMsg.Show_HinweisMessage(Me.Profilnr, 6, 121, 1) = False Then
                Exit Sub
            End If
        End If

        progress.Close()
        progress.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.get_current_Status Method

Private Function get_current_Status( _
   ByVal dokumentid As String _
) As Long

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function get_current_Status(ByVal dokumentid As String) As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_current_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statustext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            get_current_Status = scmCmdToExecute.Parameters.Item("@currentstatus").Value
            Return get_current_Status
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.get_partnerzusteller Method

Private Function get_partnerzusteller( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_partnerzusteller(ByVal nrpar00 As Integer) As String
        Dim p As New edokadb.clsPartner()
        Dim p1 As New edokadb.clsPartner()
        Dim s As String
        s = ""
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        If p.iNRPAR00.ToString <> p.sNRPARAD.ToString Then
            Try
                p1.cpMainConnectionProvider = conn
                p1.iNRPAR00 = New SqlInt32(CType(p.sNRPARAD.Value, Int32))
                p1.SelectOne()
                s = p1.sNRPARAD.ToString + " " + p1.sBKPAR00.Value
            Catch
                s = ""
            End Try
        End If
        p.Dispose()
        p1.Dispose()
        get_partnerzusteller = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mcbkube_Leave Method

Private Sub mcbkube_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbkube_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbkube.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mcbzust_Leave Method

Private Sub mcbzust_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbzust_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbzust.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mnuInfoEmpfaengerAdd_Click Method

Private Sub mnuInfoEmpfaengerAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerAdd.Click
        Dim f As New frmInformationsEmpfaenger()
        f.Dokumenttypnr = Me.Dokumenttypnr
        If Me.CreateDocument = True Then
            f.fromDokumenttyp = True
        Else
            f.fromDokumenttyp = False
            f.dokumentid = Me.DokumentID
        End If
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungen.Rows
            Dim rowvals(9) As Object
            rowvals(0) = 0
            rowvals(1) = 0
            rowvals(2) = f.Empfaenger
            rowvals(3) = f.Empaengertext
            rowvals(4) = f.Meldungsnr
            rowvals(5) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(6) = f.Bemerkung
            rowvals(7) = f.Statusnr
            rowvals(8) = f.Statustext
            rowvals(9) = 1
            newrow = rc.Add(rowvals)
            Me.InfoMeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mnuInfoEmpfaengerAdd_Click_Bedingte_Retournierung Method

Private Sub mnuInfoEmpfaengerAdd_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerAdd_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim f As New frmInformationsEmpfaenger()
        f.Dokumenttypnr = DokTypBR.iDokumenttypnr.Value
        If Me.CreateDocument = True Then
            f.fromDokumenttyp = True
        Else
            f.fromDokumenttyp = False
            f.dokumentid = Me.DokumentIDBR
        End If
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungenbr.Rows
            Dim rowvals(9) As Object
            rowvals(0) = 0
            rowvals(1) = 0
            rowvals(2) = f.Empfaenger
            rowvals(3) = f.Empaengertext
            rowvals(4) = f.Meldungsnr
            rowvals(5) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(6) = f.Bemerkung
            rowvals(7) = f.Statusnr
            rowvals(8) = f.Statustext
            rowvals(9) = 1
            newrow = rc.Add(rowvals)
            Me.InfoMeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mnuInfoEmpfaengerDelete_Click Method

Private Sub mnuInfoEmpfaengerDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerDelete.Click
        Try
            Me.InfoMeldungList.Columns(9).Value = False
            Me.InfoMeldungList.Refresh()
            Me.TabControl2.Select()
            Me.InfoMeldungList.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.mnuInfoEmpfaengerDelete_Click_Bedingte_Retournierung Method

Private Sub mnuInfoEmpfaengerDelete_Click_Bedingte_Retournierung( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerDelete_Click_Bedingte_Retournierung(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Try
            Me.InFoMeldungListBR.Columns(9).Value = False
            Me.InFoMeldungListBR.Refresh()
            Me.TabControl2.Select()
            Me.InFoMeldungListBR.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.rbZustaendigKube_Click Method

Private Sub rbZustaendigKube_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbZustaendigKube.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbZustaendigKube_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbZustaendigKube.CheckedChanged
        Me.mcbzust.Enabled = False
        Me.mcbkube.Enabled = True
        If Me.rbZustaendigKube.Checked = True Then
            Me.mcbkube.DataSource = Nothing
            Me.mcbkube.Items.Clear()
            Me.mcbkube.Fill_Data(Generic_Select(8), False)
            If Me.mcbkube.Items.Count = 0 Then
                Me.mcbkube.Text = ""
                Me.rbZustaendigKube.Checked = False
                Me.RBZustaendigZustaendiger.Checked = True
                MyMsg.show_standardmessage(24, MsgBoxStyle.Information)
                RBZustaendigZustaendiger_CheckedChanged(sender, e)
                Exit Sub
            End If
        End If
        Try
            Me.mcbkube.Focus()
            Me.mcbkube.SelectedIndex = 0
            Try
                Me.teamzustaendig = Me.mcbkube.SelectedValue
                Me.refresh_team()
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.settooltip Method

Private Sub settooltip()

Source code

[Visual Basic]
    Private Sub settooltip()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbmoeglicheStati, Globals.MyTxt.gettext(22000))
        ttip.SetToolTip(Me.btnPartnerInhaber, Globals.MyTxt.gettext(22001))
        ttip.SetToolTip(Me.Button1, Globals.MyTxt.gettext(22002))
        ttip.SetToolTip(Me.btntxtBemerkung, MyTxt.gettext(22007))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung.txtZustelladresse_Leave Method

Private Sub txtZustelladresse_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtZustelladresse.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtZustelladresse_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtZustelladresse.Leave
        'If check_banklagernd() = True Then
        '    If MyMsg.Show_MessageYesNo(72) = MsgBoxResult.No Then
        '        Me.txtZustelladresse.Text = ""
        '        Me.txtAnredeZusteller.Text = ""
        '    End If
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitung Fields

frmDokumentbearbeitung overview

Fields

field BedingteRetournierung
field BtnHelp
field Button1
field Button2
field Button3
field Button3Br
field Button4
field Check_Existing_Adresse
field ColdList
field ContextMenu1
field ContextMenu10
field ContextMenu11
field ContextMenu12
field ContextMenu13
field ContextMenu14
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field Dataset1BR
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DokTypBR
field DokWertList
field DokWertListBR
field Doktyp
field DokumentFunktionen
field DokumentFunktionenList
field DokumentFunktionenListBR
field DokumentFunktionenbr
field DokumentIDBR
field DokumentInfoMeldungen
field DokumentInfoMeldungenbr
field Dokumentersetzen
field Dokumentersetzenbr
field DokumenttypNrBr
field Dokumentzuorndungen
field Dokumentzuorndungenbr
field ErsetzenMoeglich
field ErsetzenMoeglichbr
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox16
field GroupBox17
field GroupBox18
field GroupBox19
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InFoMeldungListBR
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label18BR
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field NewDokumentIDBR
field Notizen
field Notizenbr
field Notizlist
field Notizlistbr
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SaveBM
field SaveStatusBR
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl1
field TabControl2
field TabPage1
field TabPage10
field TabPage3
field TabPage4
field TabPage5
field TabPage7
field TabPage8
field TabPage9
field Use_BL_Status
field VIBeachten
field ZuordnungList
field ZuordnunglistBR
field bemerkungbr
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cGesperrtBR
field cVertraulichBR
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field changeteam
field coldlistbr
field components
field cvertraulich
field doc
field docbr
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_KopyDokErsetzten
field m_KopyDokID
field m_KopyErsetzDokBez
field m_KopyErsetzDokDatum
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_edex_folgestatus
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field pnlBerechtigungenBR
field progress
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field tbp0
field tbp1
field tbp2
field tbp3
field tbp4
field tbp5
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtbezeichnungbr
field txtstatus
field validationerror
field zu_retournieren

See Also

frmDokumentbearbeitung Class


BedingteRetournierung Variable

Dim BedingteRetournierung As Boolean = False

Source code

[Visual Basic]
    Dim BedingteRetournierung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Button3Br Variable

Friend WithEvents Button3Br As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3Br As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Check_Existing_Adresse Variable

Dim Check_Existing_Adresse As Boolean = False

Source code

[Visual Basic]
    Dim Check_Existing_Adresse As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu10 Variable

Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu11 Variable

Friend WithEvents ContextMenu11 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu11 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu12 Variable

Friend WithEvents ContextMenu12 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu12 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu13 Variable

Friend WithEvents ContextMenu13 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu13 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu14 Variable

Friend WithEvents ContextMenu14 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu14 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ContextMenu9 Variable

Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


CurrentProfil Variable

Dim CurrentProfil As Long

Source code

[Visual Basic]
    Dim CurrentProfil As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DataSet5 Variable

Friend WithEvents DataSet5 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet5 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Dataset1BR Variable

Friend WithEvents Dataset1BR As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents Dataset1BR As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokTypBR Variable

Dim DokTypBR As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim DokTypBR As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokWertList Variable

Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokWertListBR Variable

Friend WithEvents DokWertListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokWertListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Doktyp Variable

Dim Doktyp As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim Doktyp As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentFunktionen Variable

Dim DokumentFunktionen As DataTable

Source code

[Visual Basic]
    Dim DokumentFunktionen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentFunktionenListBR Variable

Friend WithEvents DokumentFunktionenListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentFunktionenbr Variable

Dim DokumentFunktionenbr As New DataTable()

Source code

[Visual Basic]
    Dim DokumentFunktionenbr As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentIDBR Variable

Dim DokumentIDBR As String

Source code

[Visual Basic]
    Dim DokumentIDBR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentInfoMeldungen Variable

Dim DokumentInfoMeldungen As DataTable

Source code

[Visual Basic]
    Dim DokumentInfoMeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumentInfoMeldungenbr Variable

Dim DokumentInfoMeldungenbr As DataTable

Source code

[Visual Basic]
    Dim DokumentInfoMeldungenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Dokumentersetzen Variable

Dim Dokumentersetzen As DataTable

Source code

[Visual Basic]
    Dim Dokumentersetzen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Dokumentersetzenbr Variable

Dim Dokumentersetzenbr As DataTable

Source code

[Visual Basic]
    Dim Dokumentersetzenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


DokumenttypNrBr Variable

Dim DokumenttypNrBr As Integer

Source code

[Visual Basic]
    Dim DokumenttypNrBr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Dokumentzuorndungen Variable

Dim Dokumentzuorndungen As DataTable

Source code

[Visual Basic]
    Dim Dokumentzuorndungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Dokumentzuorndungenbr Variable

Dim Dokumentzuorndungenbr As DataTable

Source code

[Visual Basic]
    Dim Dokumentzuorndungenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ErsetzenMoeglich Variable

Dim ErsetzenMoeglich As Boolean = False

Source code

[Visual Basic]
    Dim ErsetzenMoeglich As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ErsetzenMoeglichbr Variable

Dim ErsetzenMoeglichbr As Boolean = False

Source code

[Visual Basic]
    Dim ErsetzenMoeglichbr As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox11 Variable

Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox13 Variable

Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox14 Variable

Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox15 Variable

Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox16 Variable

Friend WithEvents GroupBox16 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox16 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox17 Variable

Friend WithEvents GroupBox17 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox17 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox18 Variable

Friend WithEvents GroupBox18 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox18 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox19 Variable

Friend WithEvents GroupBox19 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox19 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


InFoMeldungListBR Variable

Friend WithEvents InFoMeldungListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InFoMeldungListBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label18BR Variable

Friend WithEvents Label18BR As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18BR As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


LabelVIBeachten Variable

Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuDokZuordnungAdd Variable

Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuDokzuordnungDelete Variable

Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuShowDoc Variable

Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


MnuValueSelect Variable

Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


NewDokumentID Variable

Dim NewDokumentID As String

Source code

[Visual Basic]
    Dim NewDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


NewDokumentIDBR Variable

Dim NewDokumentIDBR As String

Source code

[Visual Basic]
    Dim NewDokumentIDBR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Notizen Variable

Dim Notizen As DataTable

Source code

[Visual Basic]
    Dim Notizen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Notizenbr Variable

Dim Notizenbr As DataTable

Source code

[Visual Basic]
    Dim Notizenbr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Notizlistbr Variable

Friend WithEvents Notizlistbr As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlistbr As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


PicVIBeachten Variable

Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


RBZustaendigZustaendiger Variable

Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SaveBM Variable

Dim SaveBM

Source code

[Visual Basic]
    Dim SaveBM

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SaveStatusBR Variable

Dim SaveStatusBR As Integer

Source code

[Visual Basic]
    Dim SaveStatusBR As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage10 Variable

Friend WithEvents TabPage10 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage10 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage5 Variable

Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage7 Variable

Friend WithEvents TabPage7 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage7 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage8 Variable

Friend WithEvents TabPage8 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage8 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


TabPage9 Variable

Friend WithEvents TabPage9 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage9 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


Use_BL_Status Variable

Dim Use_BL_Status As Boolean = False

Source code

[Visual Basic]
    Dim Use_BL_Status As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


VIBeachten Variable

Dim VIBeachten As Boolean

Source code

[Visual Basic]
    Dim VIBeachten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ZuordnungList Variable

Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ZuordnunglistBR Variable

Friend WithEvents ZuordnunglistBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ZuordnunglistBR As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


bemerkungbr Variable

Friend WithEvents bemerkungbr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents bemerkungbr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


btntxtBemerkung Variable

Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cGesperrt Variable

Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cGesperrtBR Variable

Friend WithEvents cGesperrtBR As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cGesperrtBR As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cVertraulichBR Variable

Friend WithEvents cVertraulichBR As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cVertraulichBR As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbKube Variable

Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbPostzustellung Variable

Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbmoeglicheStati Variable

Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbsave Variable

Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cbzust Variable

Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cdokumentwerteanzeigen Variable

Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


changeteam Variable

Dim changeteam As Integer = 0

Source code

[Visual Basic]
    Dim changeteam As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


coldlistbr Variable

Friend WithEvents coldlistbr As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents coldlistbr As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


cvertraulich Variable

Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


doc Variable

Dim doc As New edokadb.clsDokument()

Source code

[Visual Basic]
    Dim doc As New edokadb.clsDokument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


docbr Variable

Dim docbr As New edokadb.clsDokument()

Source code

[Visual Basic]
    Dim docbr As New edokadb.clsDokument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


firststatus Variable

Dim firststatus As Integer

Source code

[Visual Basic]
    Dim firststatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


funktionsliste Variable

Dim funktionsliste As String

Source code

[Visual Basic]
    Dim funktionsliste As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


ii Variable

Dim ii As Integer

Source code

[Visual Basic]
    Dim ii As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_KopyDokErsetzten Variable

Dim m_KopyDokErsetzten As Boolean = False

Source code

[Visual Basic]
    Dim m_KopyDokErsetzten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_KopyDokID Variable

Dim m_KopyDokID As String = ""

Source code

[Visual Basic]
    Dim m_KopyDokID As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_KopyErsetzDokBez Variable

Dim m_KopyErsetzDokBez As String

Source code

[Visual Basic]
    Dim m_KopyErsetzDokBez As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_KopyErsetzDokDatum Variable

Dim m_KopyErsetzDokDatum As String

Source code

[Visual Basic]
    Dim m_KopyErsetzDokDatum As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_Partnernr Variable

Dim m_Partnernr As String

Source code

[Visual Basic]
    Dim m_Partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_createdocument Variable

Dim m_createdocument As Boolean

Source code

[Visual Basic]
    Dim m_createdocument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_dokument_ist_abgeschlossen Variable

Dim m_dokument_ist_abgeschlossen As Boolean

Source code

[Visual Basic]
    Dim m_dokument_ist_abgeschlossen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_dokumentinfobearbeiten Variable

Dim m_dokumentinfobearbeiten As Boolean

Source code

[Visual Basic]
    Dim m_dokumentinfobearbeiten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_edex_folgestatus Variable

Dim m_edex_folgestatus As Integer = 0

Source code

[Visual Basic]
    Dim m_edex_folgestatus As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbkube Variable

Dim WithEvents mcbkube As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbkube As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbpostzustellung Variable

Dim WithEvents mcbpostzustellung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbpostzustellung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbstatus Variable

Dim WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbteam Variable

Dim WithEvents mcbteam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbteam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mcbzust Variable

Dim WithEvents mcbzust As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbzust As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mnuInfoEmpfaengerAdd Variable

Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


mnuInfoEmpfaengerDelete Variable

Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


moeglichestati Variable

Dim moeglichestati As DataTable

Source code

[Visual Basic]
    Dim moeglichestati As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


pnlBerechtigungen Variable

Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


pnlBerechtigungenBR Variable

Friend WithEvents pnlBerechtigungenBR As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBerechtigungenBR As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


progress Variable

Dim progress As New frmProgress()

Source code

[Visual Basic]
    Dim progress As New frmProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


rbZustaendigKube Variable

Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


savestatus Variable

Dim savestatus As Integer

Source code

[Visual Basic]
    Dim savestatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


saveverantwortlicher Variable

Dim saveverantwortlicher As Integer

Source code

[Visual Basic]
    Dim saveverantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


selectedstatus Variable

Dim selectedstatus As Integer

Source code

[Visual Basic]
    Dim selectedstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp0 Variable

Dim tbp0 As New TabPage()

Source code

[Visual Basic]
    Dim tbp0 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp1 Variable

Dim tbp1 As New TabPage()

Source code

[Visual Basic]
    Dim tbp1 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp2 Variable

Dim tbp2 As New TabPage()

Source code

[Visual Basic]
    Dim tbp2 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp3 Variable

Dim tbp3 As New TabPage()

Source code

[Visual Basic]
    Dim tbp3 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp4 Variable

Dim tbp4 As New TabPage()

Source code

[Visual Basic]
    Dim tbp4 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


tbp5 Variable

Dim tbp5 As New TabPage()

Source code

[Visual Basic]
    Dim tbp5 As New TabPage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


teamzustaendig Variable

Dim teamzustaendig As Integer

Source code

[Visual Basic]
    Dim teamzustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtAnredeZusteller Variable

Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtBemerkungVerantwortlicher Variable

Dim txtBemerkungVerantwortlicher As String

Source code

[Visual Basic]
    Dim txtBemerkungVerantwortlicher As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtPartnerInhaberNr Variable

Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtZustelladresse Variable

Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtbezeichnungbr Variable

Friend WithEvents txtbezeichnungbr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbezeichnungbr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


txtstatus Variable

Friend WithEvents txtstatus As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtstatus As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


validationerror Variable

Dim validationerror As Boolean = False

Source code

[Visual Basic]
    Dim validationerror As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


zu_retournieren Variable

Dim zu_retournieren As Boolean

Source code

[Visual Basic]
    Dim zu_retournieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitung


frmDokumentbearbeitungBC Class

For a list of all members of this type, see frmDokumentbearbeitungBC Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentbearbeitungBC

Public Class frmDokumentbearbeitungBC
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentbearbeitungBC Members


frmDokumentbearbeitungBC Members

frmDokumentbearbeitungBC overview

Constructors

constructor frmDokumentbearbeitungBC Constructor

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property Edex_Folgestatus
property EditDokumentid
property Notfallimport
property Partnernr
property Profile
property Profilnr

Methods

method Banklagernd_Check
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notfallimport_COLD_Index_Sichern
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method TabControl2_SelectedIndexChanged
method Update_Bclabel
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

Fields

field BtnHelp
field Button1
field Button2
field Button3
field Button4
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentID
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field ErsetzenMoeglich
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label13
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl2
field TabPage3
field TabPage4
field TabPage5
field Use_BL_Status
field ZuordnungList
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field changeteam
field components
field cvertraulich
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_edex_folgestatus
field m_notfall
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field progress
field rbZustaendigKube
field save_stv
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field vibeachten
field w
field zu_retournieren

See Also

frmDokumentbearbeitungBC Class


frmDokumentbearbeitungBC Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC Properties

frmDokumentbearbeitungBC overview

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property Edex_Folgestatus
property EditDokumentid
property Notfallimport
property Partnernr
property Profile
property Profilnr

See Also

frmDokumentbearbeitungBC Class


frmDokumentbearbeitungBC.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.CreateDocument Property

Property CreateDocument() As Boolean

Source code

[Visual Basic]
    Property CreateDocument() As Boolean
        Get
            Return m_createdocument
        End Get
        Set(ByVal Value As Boolean)
            m_createdocument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokument_Ist_Abgeschlossen Property

Property Dokument_Ist_Abgeschlossen() As Boolean

Source code

[Visual Basic]
    Property Dokument_Ist_Abgeschlossen() As Boolean
        Get
            Return m_dokument_ist_abgeschlossen
        End Get
        Set(ByVal Value As Boolean)
            m_dokument_ist_abgeschlossen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentinfobearbeiten Property

Property Dokumentinfobearbeiten() As Boolean

Source code

[Visual Basic]
    Property Dokumentinfobearbeiten() As Boolean
        Get
            Return m_dokumentinfobearbeiten
        End Get
        Set(ByVal Value As Boolean)
            m_dokumentinfobearbeiten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Edex_Folgestatus Property

Property Edex_Folgestatus() As Integer

Source code

[Visual Basic]
    Property Edex_Folgestatus() As Integer
        Get
            Return m_edex_folgestatus
        End Get
        Set(ByVal Value As Integer)
            m_edex_folgestatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.EditDokumentid Property

Property EditDokumentid() As String

Source code

[Visual Basic]
    Property EditDokumentid() As String
        Get
            Return DokumentID
        End Get
        Set(ByVal Value As String)
            DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notfallimport Property

Property Notfallimport() As Boolean

Source code

[Visual Basic]
    Property Notfallimport() As Boolean
        Get
            Return m_notfall
        End Get
        Set(ByVal Value As Boolean)
            m_notfall = Value
            Me.CreateDocument = True
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_Partnernr
        End Get
        Set(ByVal Value As String)
            m_Partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC Methods

frmDokumentbearbeitungBC overview

Methods

method Banklagernd_Check
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notfallimport_COLD_Index_Sichern
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method TabControl2_SelectedIndexChanged
method Update_Bclabel
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

See Also

frmDokumentbearbeitungBC Class


frmDokumentbearbeitungBC.Banklagernd_Check Method

Private Sub Banklagernd_Check()

Source code

[Visual Basic]
    Private Sub Banklagernd_Check()
        Dim i As Integer
        i = check_banklagernd()
        If i = 0 Then Exit Sub
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        dt.iDokumenttypnr = New SqlInt32(CType(Dokumenttypnr, Int32))
        dt.SelectOne()
        If dt.bKundenDokument.Value = False Then
            dt.Dispose()
            Exit Sub
        End If
        dt.Dispose()
        Try
            Select Case i
                Case 1
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, True)
                    f.rbbckbldossier.Checked = True
                    f.rbbckversand.Checked = False
                    f.ShowDialog()
                    If f.rbbckbldossier.Checked = True Then
                        Me.Use_BL_Status = True
                    End If
                    f.Dispose()
                Case 2
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, True)
                    f.rbbckbldossier.Checked = True
                    f.rbbckversand.Checked = False
                    f.ShowDialog()
                    If f.rbbckbldossier.Checked = True Then
                        Me.Use_BL_Status = True
                    End If
                    f.Dispose()
            End Select
        Catch
        Finally
            Try
                Globals.conn.CloseConnection(True)
            Catch
            End Try

        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentbearbeitungsdialog")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            If Me.txtPartnerInhaberNr.Text > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()

        If f.PartnerNr <> 0 Then
            Me.txtZustelladresse.Text = f.zustelladresse
            Me.txtAnredeZusteller.Text = f.Anrede
            Me.txtZustelladresse.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dokumentzuordnungen_Sichern()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        MenuItem2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.DokWertList.Columns("feldwert").Value = f.PartnerNr
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.COLD_Index_Sichern Method

Public Function COLD_Index_Sichern( _
   ByVal indextyp As Integer _
) As DataTable

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Function COLD_Index_Sichern(ByVal indextyp As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Check_Dokumentersetzen Method

Private Function Check_Dokumentersetzen( _
   ByVal dokumenttypnr As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumenttypnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Check_Dokumentersetzen(ByVal dokumenttypnr As Integer, ByVal dokumentid As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentbearbeitung_chcek_dokumentersetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@errormessage", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            s = scmCmdToExecute.Parameters.Item("@errormessage").Value
            If s <> "" Then
                MyMsg.show_standardmessage(Val(s), MsgBoxStyle.Critical)
                Return False
            End If
            Return True
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Check_Dokumentfunktionen Method

Private Function Check_Dokumentfunktionen() As Boolean

Source code

[Visual Basic]
    Private Function Check_Dokumentfunktionen() As Boolean
        Dim i As Integer
        Dim zz As Integer
        Dim bearbeiten As Boolean
        Dim abschliessen As Boolean
        bearbeiten = False
        abschliessen = False
        Check_Dokumentfunktionen = True
        If Me.DokumentFunktionenList.Visible = False Then Exit Function
        zz = 0
        For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
            If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                If Me.DokumentFunktionen.Rows(i).Item("bearbeiten") = True Then bearbeiten = True
                If Me.DokumentFunktionen.Rows(i).Item("abschliessen") = True Then abschliessen = True
                zz = zz + 1
            End If
        Next

        If zz = 0 Then
            Check_Dokumentfunktionen = True
            Exit Function
        End If
        If bearbeiten = False Or abschliessen = False Then
            If bearbeiten = False Then
                MyMsg.show_standardmessage(34, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
            If abschliessen = False Then
                MyMsg.show_standardmessage(35, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Cold_Index_Bearbeiten Method

Public Sub Cold_Index_Bearbeiten( _
   ByVal indextyp As Integer _
)

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten(ByVal indextyp As Integer)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp)
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.Notizen.Rows.Count = 0 Then
            Me.ContextMenu1.MenuItems(1).Enabled = False
            Me.ContextMenu1.MenuItems(2).Enabled = False
        Else
            Me.ContextMenu1.MenuItems(1).Enabled = True
            Me.ContextMenu1.MenuItems(2).Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        If Me.DokWertList.Columns("datenherkunft").Value = "" Then
            Me.MnuValueSelect.Enabled = False
        Else
            Me.MnuValueSelect.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        If Me.ZuordnungList.Splits(0).Rows.Count = 0 Then
            Me.MnuDokzuordnungDelete.Enabled = False
            Me.MnuShowDoc.Enabled = False
        Else
            Me.MnuDokzuordnungDelete.Enabled = True
            Me.MnuShowDoc.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.ContextMenu4_Popup Method

Private Sub ContextMenu4_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu4.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu4_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu4.Popup
        Try
            If Me.InfoMeldungList.Columns("typ").Value = 1 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
            If Me.InfoMeldungList.Splits(0).Rows.Count = 0 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        If Me.ErsetzenMoeglich = False Then
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
            Exit Sub
        End If
        Try
            If Me.ColdList.Splits(0).Rows.Count = 0 Then
                Me.MenuItem6.Enabled = False
            Else
                Me.MenuItem6.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        If Me.On_Load Then Exit Sub
        Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DateTimePicker2_KeyDown Method

Private Sub DateTimePicker2_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles DateTimePicker2.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles DateTimePicker2.KeyDown
        If e.KeyCode = Keys.Delete Then
            Me.DateTimePicker2.ResetText()
            Me.DateTimePicker2.Value = System.DBNull.Value
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Datumselect_ValueChanged Method

Private Sub Datumselect_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Datumselect_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Set_Feldwert()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DokWertList_AfterColEdit Method

Private Sub DokWertList_AfterColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DokWertList.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_AfterColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DokWertList.AfterColEdit
        Me.DokWertList.Update()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DokWertList_BeforeColUpdate Method

Private Sub DokWertList_BeforeColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles DokWertList.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_BeforeColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles DokWertList.BeforeColUpdate
        If InStr(Me.DokWertList.Columns("Datenherkunft").Text, "VV") > 0 Then
            If Len(Me.DokWertList.Columns("feldwert").Text) > 16 Then
                MyMsg.show_standardmessage(235, MsgBoxStyle.Critical)
                e.Cancel = True
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DokWertList_Click Method

Private Sub DokWertList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokWertList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokWertList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokument_Bearbeiten Method

Private Sub Dokument_Bearbeiten( _
   ByVal neu As Boolean _
)

Parameters

neu
Required.

Source code

[Visual Basic]
    Private Sub Dokument_Bearbeiten(ByVal neu As Boolean)
        If Me.Dokument_Ist_Abgeschlossen Then
            Notizen_Sichern()
            Dokumentzuordnungen_Sichern()
            Dokumentinfomeldungen_Sichern()
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            Me.Close()
            Exit Sub
        End If
        w.txtPartner = Me.txtPartnerInhaber.Text
        w.txtDokumenttyp = Me.txtBezeichnung.Text
        w.ProgressBar.Info.Text = "Dokument erstellen"
        w.ProgressBar.Bar1.Value = 10

        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim doc As New edokadb.clsDokument()
        Dim doctyp As New edokadb.clsDokumenttyp()
        Dim docvor As New edokadb.clsOffice_vorlage()

        'Dokumenttyp laden
        doctyp.cpMainConnectionProvider = conn
        doctyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doctyp.SelectOne()

        'OfficeVorlage laden
        docvor.cpMainConnectionProvider = conn
        docvor.iOffice_vorlagenr = New SqlInt32(CType(doctyp.iOffice_vorlagenr.Value, Int32))
        docvor.SelectOne()

        'Dokument erstellen
        doc.cpMainConnectionProvider = conn
        If Me.CreateDocument Then
            doc.sDokumentid = New SqlString(CType(NewDokumentID, String))
        Else
            doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
            doc.SelectOne()
        End If
        doc.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doc.iNrpar00 = New SqlInt32(CType(Me.txtPartnerInhaberNr.Text, Int32))
        doc.bAktiv = New SqlBoolean(True)
        doc.bAmsdokument = New SqlBoolean(CType(False, Boolean))
        doc.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
        doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
        doc.daArchivierungsdatum = New SqlDateTime(CType(Me.DateTimePicker3.Value, DateTime))

        If Me.DateTimePicker2.Value Is System.DBNull.Value Then
            doc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
        Else
            doc.daTermin = New SqlDateTime(CType(Me.DateTimePicker2.Value, DateTime))
        End If

        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
        'Hutter - anpassungen
        If Me.mcbstatus.Text = "Bereit für Ausgangsarchivierung" Then
            doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
        End If
        doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
        doc.bGesperrt = New SqlBoolean(CType(Me.cGesperrt.Checked, Boolean))
        If Me.cGesperrt.Checked Then
            doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
        End If
        doc.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
        doc.bZu_retournieren = New SqlBoolean(CType(doctyp.bZu_retournieren.Value, Boolean))
        doc.iColdstatus = New SqlInt32(CType(0, Int32))
        doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
        If neu = True Then
            doc.iErsteller = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iErstellerteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            doc.daErstelltam = New SqlDateTime(CType(Now, DateTime))
            doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iMutiererteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
            If Globals.bckdokument Then
                doc.iBck = New SqlInt32(CType(1, Int32))
            Else
                doc.iBck = New SqlInt32(CType(1, Int32))
            End If
            doc.iAufbewahrung_elektronisch = New SqlInt32(CType(doctyp.iAufbewahrungsfrist_elektronisch.Value, Int32))
            doc.iAufbewahrung_phaysisch = New SqlInt32(CType(doctyp.iAufbewahrungsfrist_physisch.Value, Int32))
            doc.iBearbeitung_nach_abschluss = New SqlInt32(CType(doctyp.iTage_mutation.Value, Int32))
            doc.iBearbeitungszeit_in_minuten = New SqlInt32(CType(doctyp.iDbearbeitungszeit.Value, Int32))
            doc.iMonierung_in_tagen = New SqlInt32(CType(doctyp.iAnzahl_tage.Value, Int32))
        Else
            doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
        End If

        doc.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
        doc.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
        doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
        doc.bVertraulich = New SqlBoolean(CType(Me.cvertraulich.Checked, Boolean))
        doc.sZustelladresse = New SqlString(CType(Me.txtZustelladresse.Text, String))
        doc.sAnredezustelladresse = New SqlString(CType(Me.txtAnredeZusteller.Text, String))

        'EDEX Banklagernd
        If Me.Use_BL_Status Then
            doc.bBl_scan = New SqlBoolean(CType(True, Boolean))
            doc.bBldossier = New SqlBoolean(CType(True, Boolean))
        Else
            doc.bBl_scan = New SqlBoolean(CType(False, Boolean))
            doc.bBldossier = New SqlBoolean(CType(False, Boolean))
        End If

        If Me.rbZustaendigKube.Checked Then
            doc.iZustaendiger = New SqlInt32(CType(Me.mcbkube.SelectedValue, Int32))
        Else
            doc.iZustaendiger = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
        End If
        doc.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
        doc.bZustaendig_kube = New SqlBoolean(CType(Me.rbZustaendigKube.Checked, Boolean))
        If Me.cGesperrt.Checked Then
            doc.iGesperrt_durch = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
        Else
            doc.iGesperrt_durch = New SqlInt32(CType(0, Int32))
        End If
        doc.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
        doc.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
        doc.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        doc.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
        doc.sColddokumentid = New SqlString(CType("", String))

        doc.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))

        If Not Me.CreateDocument Then
            doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
        End If

        doc.daErstellungsdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
        '        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))

        If docvor.iAnwendungnr.Value = 1 Then
            doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".doc", String))
        Else
            doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".xls", String))
        End If

        If Me.CreateDocument Then doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
        If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
            Dim tx As DataTable
            tx = Generic_Select(13)
            If tx.Rows(0).Item(0) = 1 Then
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
            Else
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            End If
            tx.Dispose()
        End If

        Dim s As String

        s = DivFnkt.Get_Filename(doc.sDokumentname.Value, Me.txtPartnerInhaberNr.Text)
        conn.OpenConnection()
        If Me.CreateDocument Then
            Dim t As DataTable
            t = Generic_Select(14)
            doc.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
            doc.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
            doc.iAnzeigeStatus = New SqlInt32(CType(0, Int32))
            doc.Insert()
            t.Dispose()
            'Hutter Notfallimport
            If Not Me.Notfallimport Then
                Dim statush As New Statushandling()
                statush.Status_Erstellen(doc.sDokumentid.Value, Me.Use_BL_Status)
                statush.Dispose()
            Else
                Generic_Select(20)
            End If
            doc.iStatusnr = New SqlInt32(CType(get_current_Status(doc.sDokumentid.Value), Int32))
            doc.Update()
        Else
            doc.Update()
        End If
        conn.CloseConnection(True)

        DokumentID = doc.sDokumentid.Value
        If Globals.bckdokument = True Or Me.Notfallimport = True Then
            If Not Me.Notfallimport Then
                Cold_Index_Bearbeiten(2)
            Else
                If doctyp.bZu_retournieren.Value = True Then
                    Cold_Index_Bearbeiten(2)
                Else
                    Cold_Index_Bearbeiten(1)
                    Me.Notfallimport_COLD_Index_Sichern(2)
                End If
            End If
        Else
            Cold_Index_Bearbeiten(1)
            If Me.zu_retournieren Then
                Cold_Index_Bearbeiten(2)
            End If
        End If
        DokumentID = doc.sDokumentid.Value
        Dokumentwerte_Sichern()
        Notizen_Sichern()
        Dokumentzuordnungen_Sichern()
        Dokumentersetzen_Sichern()
        Dokumentinfomeldungen_Sichern()
        Dokumentfunktionen_sichern()
        Status_History(doc.iStatusnr.Value)
        If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
            w.ProgressBar.Show()
            w.ProgressBar.Info.Text = "Dokumentwerte zusammenstellen"
            w.ProgressBar.Bar1.Value = 10
        End If
        Dim xdata As DataTable
        xdata = Dokumentwerte(doc.sDokumentid.Value)
        DokumentID = doc.sDokumentid.Value

        'Dokument erstellen bzw. öffnen
        w.DokumentID = doc.sDokumentid.Value
        w.DokumentName = doc.sDokumentname.Value
        If Me.CreateDocument Then
            w.CreateDoc = True
            If Me.BarcodeID = "" Then w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s)
        Else
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.CreateDoc = False
                Dim docrestore As New DocMgmt()
                docrestore.Get_From_DB(DokumentID, s)
                w.Open_Document(s, xdata, doc.iDokumenttypnr.Value)
            End If
        End If

        If Globals.Dokumentcoldindex_Changed Then
            w.dokumentidalt = Globals.Dokumentidalt
            w.save_dokumentcoldindex = Globals.general_ds.Tables(Globals.general_ds.Tables.Count - 1).Copy
            w.Dokumentcoldindex_Changed = Globals.Dokumentcoldindex_Changed
            w.dokumentid_changed = Globals.dokumentid_changed
            w.dokumentcoldindex_status = Globals.dokumentcoldindex_status
            w.Ersetzte_Dokumente_Reaktivieren = Globals.Ersetzte_Dokumente_Reaktivieren
        End If

        'Anzeigen der Dokumentwerte, sofern die Checkbox markiert war
        If Me.cdokumentwerteanzeigen.Checked Then
            Dim f As New frmDokumentwerte()
            f.WordData = xdata
            f.isOk = True
            Me.Cursor = System.Windows.Forms.Cursors.Default
            f.ShowDialog()
            If f.isOk = 0 Then
                f.Dispose()
                w.CloseDoc()
                If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            Else
                If f.isOk = 1 Then
                    f.Dispose()
                    w.Dokument_Vervollstaendigen(xdata)
                    Words.Add(w, w.DokumentName)
                Else
                    If f.isOk = 2 Then
                        f.Dispose()
                        If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                        Me.CreateDocument = False
                        Me.btnWeiter.Enabled = True
                        Me.Show()
                    End If
                End If
            End If
        Else
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.Dokument_Vervollstaendigen(xdata)
                Words.Add(w, w.DokumentName)
            Else
                If Not Me.Dokumentinfobearbeiten = True Then
                    Update_Bclabel(1)
                End If
                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                MyMsg.show_bcmessage(Me.DokumentID)
            End If
        End If
        Me.Hide()
        xdata.Dispose()
        doc.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentersetzen_Laden Method

Private Function Dokumentersetzen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentersetzen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentersetzen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentersetzen_Sichern Method

Public Sub Dokumentersetzen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentersetzen_Sichern()
        For i = 0 To Me.Dokumentersetzen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentersetzen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("coldstatus")))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Ersetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentfunktionen_Aktivieren Method

Private Sub Dokumentfunktionen_Aktivieren()

Source code

[Visual Basic]
    Private Sub Dokumentfunktionen_Aktivieren()
        Dim t As DataTable
        t = Generic_Select(5)
        If t.Rows.Count > 0 Then
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlDataAdapter3.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            '            Me.Funktionsliste.DataSource = Me.DataSet3
            '           Me.Funktionsliste.DataMember = Me.DataSet3.Tables(0).TableName

            t.Clear()
            Me.DokumentFunktionen = Generic_Select(6)
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.DataSet4.Tables.Add(Me.DokumentFunktionen)
            Me.DokumentFunktionenList.DataSource = Me.DataSet4
            Me.DokumentFunktionenList.DataMember = Me.DataSet4.Tables(0).TableName
            Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
            Me.DokumentFunktionenList.FilterBar = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Me.DokumentFunktionen, "berechtigungseinschraenkung")

        Else
            Me.pnlBerechtigungen.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentfunktionen_sichern Method

Public Sub Dokumentfunktionen_sichern()

Source code

[Visual Basic]
    Public Sub Dokumentfunktionen_sichern()
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentfunktionen_Sichern"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@funktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("anzeigen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("bearbeiten")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("loeschen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("abschliessen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("aktiv")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentinfomeldungen_Sichern Method

Public Sub Dokumentinfomeldungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentinfomeldungen_Sichern()
        For i = 0 To Me.DokumentInfoMeldungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("typ")))

                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DokumentwertListe_laden Method

Private Function DokumentwertListe_laden() As DataTable

Source code

[Visual Basic]
    Private Function DokumentwertListe_laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentwerte Method

Private Function Dokumentwerte( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentwerte(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentwerte_Sichern Method

Public Sub Dokumentwerte_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern()
        Dim xdata As DataTable
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Dokumentzuordnungen_Sichern Method

Public Sub Dokumentzuordnungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentzuordnungen_Sichern()
        For i = 0 To Me.Dokumentzuorndungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("NrEintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("DOKUMENTID2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("AKTIV")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.DokwertList_RowColChange Method

Private Sub DokwertList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokWertList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokwertList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokWertList.RowColChange
        Try
            Me.DokWertList.Columns("feldwert").EditMask = Me.DokWertList.Columns("eingabeformat").Value
            Me.DokWertList.Columns("feldwert").EditMaskUpdate = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()
        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String
        s = ""
        Try
            For I = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(I).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(I).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            If Me.cvertraulich.Checked = True Then
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 1, s)
            Else
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 0, s)
            End If
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Formular_Laden_Create_Document Method

Private Sub Formular_Laden_Create_Document()

Source code

[Visual Basic]
    Private Sub Formular_Laden_Create_Document()
        NewDokumentID = DivFnkt.Generate_Key()
        Load_Defaults()
        w.save_historystatus = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Formular_laden_Edit_Document Method

Private Sub Formular_laden_Edit_Document()

Source code

[Visual Basic]
    Private Sub Formular_laden_Edit_Document()
        Dim doc As New edokadb.clsDokument()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        doc.SelectOne()
        doc.cpMainConnectionProvider = conn
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        NewDokumentID = Me.EditDokumentid
        Me.Partnernr = doc.iNrpar00.Value
        doc.SelectOne()
        w.Save_Dokument = doc.SelectOne
        Me.Dokumenttypnr = doc.iDokumenttypnr.Value
        DokumentID = doc.sDokumentid.Value
        Load_Defaults()

        'Parnter laden
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = doc.iNrpar00
        p.SelectOne()
        Me.txtPartnerInhaber.Text = Str(p.iNRPAR00.Value) + " " + p.sBKPAR00.Value
        Me.txtPartnerInhaberNr.Text = p.iNRPAR00.Value
        Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(p.iNRPAR00.Value)
        If p.sCDVIG00.Value = "Y" Or p.iAZEPL00.Value > 1 Or p.bCDVSA00.Value = True Then Me.vibeachten = True Else Me.vibeachten = False
        p.Dispose()

        ii = doc.iPostzustellung.Value
        Me.mcbpostzustellung.SelectedValue = ii
        If doc.bZustaendig_kube.Value = True Then
            ii = doc.iZustaendiger.Value
            Me.mcbkube.SelectedValue = ii
        Else
            ii = doc.iZustaendiger.Value
            Me.mcbzust.SelectedValue = ii
        End If
        ii = doc.iVerantwortlich.Value
        'Prüfung, sofern akt. verantwortlicher = MA-Systemuser, dann aktueller Mitarbeiter setzen
        If ii > 9950 Then
            ii = Globals.MitarbeiterNr
        End If

        Me.mcbverantwortlich.SelectedValue = ii
        Me.saveverantwortlicher = ii

        Me.savestatus = doc.iStatusnr.Value

        ii = doc.iUnterschriftlinks.Value
        Me.mcbunterschriftlinks.SelectedValue = ii
        ii = doc.iUnterschriftrechts.Value
        Me.mcbunterschriftrechts.SelectedValue = ii
        Me.cGesperrt.Checked = doc.bGesperrt.Value = True
        Me.txtBemerkung.Text = doc.sBemerkung.Value
        Me.txtBezeichnung.Text = doc.sBezeichnung.Value
        Me.rbZustaendigKube.Checked = doc.bZustaendig_kube.Value = True
        Me.cvertraulich.Checked = doc.bVertraulich.Value = True
        Me.txtZustelladresse.Text = doc.sZustelladresse.Value
        Me.txtAnredeZusteller.Text = doc.sAnredezustelladresse.Value
        Me.RBZustaendigZustaendiger.Checked = doc.bZustaendig_kube.Value = False
        Me.teamzustaendig = doc.iZustaendiger.Value
        Me.refresh_team()
        Try
            Me.mcbteam.SelectedValue = doc.iMutierertieam.Value
        Catch
            Me.mcbteam.SelectedIndex = 0
        End Try
        Try
            Me.DateTimePicker1.Value = doc.daErstellungsdatum.Value
        Catch
            Me.DateTimePicker1.Value = Now
        End Try

        Try
            Me.DateTimePicker3.Value = doc.daArchivierungsdatum.Value
        Catch
            Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
        End Try

        Try
            If doc.daTermin.Value = "01.01.1900" Then
                Me.DateTimePicker2.ResetText()
                Me.DateTimePicker2.Value = System.DBNull.Value
            Else
                Me.DateTimePicker2.Value = doc.daTermin.Value
            End If
        Catch
            Me.DateTimePicker2.Value = System.DBNull.Value
        End Try

        doc.Dispose()

        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()

        Me.ColdList.DataSource = Me.Dokumentersetzen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")

        Me.Notizen = Notizen_Laden()

        w.Save_Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        w.Save_Dokumentwerte = Generic_Select(10)
        Me.DataSet1.Clear()
        Me.DataSet1.Tables.Clear()
        Me.DataSet1.Tables.Add(DokumentwertListe_laden)
        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160
        conn.CloseConnection(True)

        w.Save_ColdIndex = Generic_Select(9)
        Me.TabControl2.Enabled = True

        Dim tmp As DataTable
        tmp = Generic_Select(12)
        w.save_historystatus = tmp.Rows(0).Item(0)
        tmp.Dispose()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_DokWertList"
            Case 2
                If Me.Notfallimport = True Then
                    scmCmdToExecute.CommandText = "SP_Notfallimport_StatusSelektion"
                Else
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
                End If
            Case 3
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Notizen"
            Case 5
                    scmCmdToExecute.CommandText = "sp_funktion_zuweisung_gestattet"
            Case 6
                    scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
            Case 7
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
            Case 8
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_kube"
            Case 9
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 10
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 11
                    scmCmdToExecute.CommandText = "sp_dokument_als_bcdokument"
            Case 12
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 13
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case 14
                    scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case 15
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 16
                    scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 17
                    'Mitarbeiter
                    scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case 20 'Hutter Notfallimport
                scmCmdToExecute.CommandText = "dbo.sp_notfallimport_status_erstellen"

            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@regel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokWertList.Columns("datenherkunft").Value))
                Case 2
                    If Me.Notfallimport = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                        If Me.DokumentID = Nothing Then Me.DokumentID = ""
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                        If Me.CreateDocument = True Then
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                        Else
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                        End If
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                        If Globals.bckdokument = False Then
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        Else
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                        End If
                    End If
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentID))
                Case 7
                    If Me.teamzustaendig = Globals.MitarbeiterNr Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.teamzustaendig))
                    End If
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                Case 9
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 16
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case 20
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles InfoMeldungList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles InfoMeldungList.FetchRowStyle
        Try
            If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
                e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentbearbeitungBC))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet4 = New System.Data.DataSet()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.GroupBox13 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.DokWertList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MnuValueSelect = New System.Windows.Forms.MenuItem()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RBZustaendigZustaendiger = New System.Windows.Forms.RadioButton()
        Me.rbZustaendigKube = New System.Windows.Forms.RadioButton()
        Me.cbzust = New System.Windows.Forms.ComboBox()
        Me.cbKube = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.cbPostzustellung = New System.Windows.Forms.ComboBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.mnuInfoEmpfaengerAdd = New System.Windows.Forms.MenuItem()
        Me.mnuInfoEmpfaengerDelete = New System.Windows.Forms.MenuItem()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.ZuordnungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokZuordnungAdd = New System.Windows.Forms.MenuItem()
        Me.MnuDokzuordnungDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker2 = New C1.Win.C1Input.C1DateEdit()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TabPage5 = New System.Windows.Forms.TabPage()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.GroupBox11 = New System.Windows.Forms.GroupBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtAnredeZusteller = New System.Windows.Forms.TextBox()
        Me.txtZustelladresse = New System.Windows.Forms.TextBox()
        Me.pnlBerechtigungen = New System.Windows.Forms.GroupBox()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.cvertraulich = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.cGesperrt = New System.Windows.Forms.CheckBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.txtPartnerInhaberNr = New System.Windows.Forms.TextBox()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cdokumentwerteanzeigen = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.cbsave = New System.Windows.Forms.ComboBox()
        Me.cbmoeglicheStati = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtstatus = New System.Windows.Forms.Label()
        Me.btntxtBemerkung = New System.Windows.Forms.Button()
        Me.LabelVIBeachten = New System.Windows.Forms.Label()
        Me.PicVIBeachten = New System.Windows.Forms.PictureBox()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.GroupBox13.SuspendLayout()
        Me.GroupBox12.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.TabPage4.SuspendLayout()
        Me.GroupBox7.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox6.SuspendLayout()
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox5.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage5.SuspendLayout()
        Me.GroupBox11.SuspendLayout()
        Me.pnlBerechtigungen.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox9.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(696, 472)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(104, 23)
        Me.btnWeiter.TabIndex = 12
        Me.btnWeiter.Text = "&Weiter>>"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(40, 472)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(104, 23)
        Me.btnCancel.TabIndex = 13
        Me.btnCancel.Text = "&Abbruch"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "SP_Dokumentbearbeitung_Dokumentwerte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("Feldwert", "Feldwert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[SP_Dokumentbearbeitung_Dokumentwerte]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentid", System.Data.SqlDbType.VarChar, 20))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@CreateNew", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Postzustellung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nreintrag", "nreintrag"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_postzustellung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_postzustellung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_postzustellung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_postzustellung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_funktionsgruppe_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_funktionsgruppe_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_funktionsgruppe_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_funktionsgruppe_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage3, Me.TabPage4, Me.TabPage5})
        Me.TabControl2.Enabled = False
        Me.TabControl2.Location = New System.Drawing.Point(8, 104)
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(800, 360)
        Me.TabControl2.TabIndex = 10
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox13, Me.GroupBox12, Me.GroupBox10, Me.GroupBox3, Me.GroupBox1, Me.GroupBox2})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(792, 334)
        Me.TabPage3.TabIndex = 0
        Me.TabPage3.Text = "Dokument"
        '
        'GroupBox13
        '
        Me.GroupBox13.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker1, Me.Label5})
        Me.GroupBox13.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox13.TabIndex = 0
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Allgemein"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 21)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(104, 20)
        Me.DateTimePicker1.TabIndex = 0
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 21)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Dokument-Datum"
        '
        'GroupBox12
        '
        Me.GroupBox12.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox12.Location = New System.Drawing.Point(8, 208)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox12.TabIndex = 3
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Team"
        Me.GroupBox12.Visible = False
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(128, 16)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(232, 21)
        Me.cbteam.TabIndex = 0
        '
        'GroupBox10
        '
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokWertList})
        Me.GroupBox10.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(400, 312)
        Me.GroupBox10.TabIndex = 37
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Dokumentspezifisch"
        '
        'DokWertList
        '
        Me.DokWertList.AllowFilter = False
        Me.DokWertList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokWertList.AllowSort = False
        Me.DokWertList.AlternatingRows = True
        Me.DokWertList.CaptionHeight = 17
        Me.DokWertList.CollapseColor = System.Drawing.Color.Black
        Me.DokWertList.ContextMenu = Me.ContextMenu2
        Me.DokWertList.DataChanged = False
        Me.DokWertList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokWertList.ExpandColor = System.Drawing.Color.Black
        Me.DokWertList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokWertList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokWertList.Location = New System.Drawing.Point(8, 16)
        Me.DokWertList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokWertList.Name = "DokWertList"
        Me.DokWertList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokWertList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokWertList.PreviewInfo.ZoomFactor = 75
        Me.DokWertList.PrintInfo.ShowOptionsDialog = False
        Me.DokWertList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokWertList.RowDivider = GridLines1
        Me.DokWertList.RowHeight = 15
        Me.DokWertList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokWertList.ScrollTips = False
        Me.DokWertList.Size = New System.Drawing.Size(384, 288)
        Me.DokWertList.TabIndex = 0
        Me.DokWertList.Text = "C1TrueDBGrid1"
        Me.DokWertList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 380, 284</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defau" & _
        "ltRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 380, 284</ClientArea></Bl" & _
        "ob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuValueSelect})
        '
        'MnuValueSelect
        '
        Me.MnuValueSelect.Index = 0
        Me.MnuValueSelect.Text = "&Wert auswählen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbUnterschriftrechts, Me.cbUnterschriftlinks, Me.Label8, Me.Label7})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox3.TabIndex = 4
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Unterschrift"
        Me.GroupBox3.Visible = False
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(128, 43)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftrechts.TabIndex = 1
        Me.cbUnterschriftrechts.Visible = False
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(128, 19)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftlinks.TabIndex = 0
        Me.cbUnterschriftlinks.Visible = False
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 48)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Unterschrift rechts"
        Me.Label8.Visible = False
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 24)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 13
        Me.Label7.Text = "Unterschrift links"
        Me.Label7.Visible = False
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBZustaendigZustaendiger, Me.rbZustaendigKube, Me.cbzust, Me.cbKube})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 72)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox1.TabIndex = 1
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zuständigkeit"
        '
        'RBZustaendigZustaendiger
        '
        Me.RBZustaendigZustaendiger.Location = New System.Drawing.Point(14, 42)
        Me.RBZustaendigZustaendiger.Name = "RBZustaendigZustaendiger"
        Me.RBZustaendigZustaendiger.Size = New System.Drawing.Size(98, 24)
        Me.RBZustaendigZustaendiger.TabIndex = 1
        Me.RBZustaendigZustaendiger.Text = "Zuständiger"
        '
        'rbZustaendigKube
        '
        Me.rbZustaendigKube.Location = New System.Drawing.Point(14, 18)
        Me.rbZustaendigKube.Name = "rbZustaendigKube"
        Me.rbZustaendigKube.Size = New System.Drawing.Size(106, 24)
        Me.rbZustaendigKube.TabIndex = 0
        Me.rbZustaendigKube.Text = "Kundenberater"
        '
        'cbzust
        '
        Me.cbzust.Location = New System.Drawing.Point(128, 47)
        Me.cbzust.Name = "cbzust"
        Me.cbzust.Size = New System.Drawing.Size(232, 21)
        Me.cbzust.TabIndex = 3
        '
        'cbKube
        '
        Me.cbKube.Location = New System.Drawing.Point(128, 21)
        Me.cbKube.Name = "cbKube"
        Me.cbKube.Size = New System.Drawing.Size(232, 21)
        Me.cbKube.TabIndex = 2
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbPostzustellung, Me.Label3})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 184)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 88)
        Me.GroupBox2.TabIndex = 2
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Allgemein"
        Me.GroupBox2.Visible = False
        '
        'cbPostzustellung
        '
        Me.cbPostzustellung.Location = New System.Drawing.Point(128, 24)
        Me.cbPostzustellung.Name = "cbPostzustellung"
        Me.cbPostzustellung.Size = New System.Drawing.Size(232, 21)
        Me.cbPostzustellung.TabIndex = 0
        Me.cbPostzustellung.Visible = False
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 24)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "Post-Zustellung"
        Me.Label3.Visible = False
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox7, Me.GroupBox6, Me.GroupBox5, Me.GroupBox4})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(792, 334)
        Me.TabPage4.TabIndex = 1
        Me.TabPage4.Text = "Zusammenhänge"
        Me.TabPage4.Visible = False
        '
        'GroupBox7
        '
        Me.GroupBox7.BackColor = System.Drawing.SystemColors.Control
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.InfoMeldungList})
        Me.GroupBox7.Location = New System.Drawing.Point(8, 216)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(776, 100)
        Me.GroupBox7.TabIndex = 3
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Informationsmeldungen"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.ContextMenu = Me.ContextMenu4
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.InfoMeldungList.Location = New System.Drawing.Point(8, 16)
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines2
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(760, 72)
        Me.InfoMeldungList.TabIndex = 0
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, " & _
        "1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""" & _
        "><ClientRect>0, 0, 756, 68</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 756, 68</ClientArea></Blob>"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuInfoEmpfaengerAdd, Me.mnuInfoEmpfaengerDelete})
        '
        'mnuInfoEmpfaengerAdd
        '
        Me.mnuInfoEmpfaengerAdd.Index = 0
        Me.mnuInfoEmpfaengerAdd.Text = "Neuer Info-Empfänger"
        '
        'mnuInfoEmpfaengerDelete
        '
        Me.mnuInfoEmpfaengerDelete.Index = 1
        Me.mnuInfoEmpfaengerDelete.Text = "Info-Empfänger löschen"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.ZuordnungList})
        Me.GroupBox6.Location = New System.Drawing.Point(384, 112)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(400, 96)
        Me.GroupBox6.TabIndex = 2
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Dokument-Zuordnung"
        '
        'ZuordnungList
        '
        Me.ZuordnungList.AllowFilter = True
        Me.ZuordnungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ZuordnungList.AllowSort = True
        Me.ZuordnungList.AlternatingRows = True
        Me.ZuordnungList.CaptionHeight = 17
        Me.ZuordnungList.CollapseColor = System.Drawing.Color.Black
        Me.ZuordnungList.ContextMenu = Me.ContextMenu3
        Me.ZuordnungList.DataChanged = False
        Me.ZuordnungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ZuordnungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ZuordnungList.ExpandColor = System.Drawing.Color.Black
        Me.ZuordnungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ZuordnungList.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ZuordnungList.Location = New System.Drawing.Point(3, 16)
        Me.ZuordnungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ZuordnungList.Name = "ZuordnungList"
        Me.ZuordnungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ZuordnungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ZuordnungList.PreviewInfo.ZoomFactor = 75
        Me.ZuordnungList.PrintInfo.ShowOptionsDialog = False
        Me.ZuordnungList.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ZuordnungList.RowDivider = GridLines3
        Me.ZuordnungList.RowHeight = 15
        Me.ZuordnungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ZuordnungList.ScrollTips = False
        Me.ZuordnungList.Size = New System.Drawing.Size(394, 77)
        Me.ZuordnungList.TabIndex = 0
        Me.ZuordnungList.Text = "C1TrueDBGrid1"
        Me.ZuordnungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 73</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "3</ClientArea></Blob>"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokZuordnungAdd, Me.MnuDokzuordnungDelete, Me.MenuItem1, Me.MnuShowDoc})
        '
        'MnuDokZuordnungAdd
        '
        Me.MnuDokZuordnungAdd.Index = 0
        Me.MnuDokZuordnungAdd.Text = "Dokument hinzufügen"
        '
        'MnuDokzuordnungDelete
        '
        Me.MnuDokzuordnungDelete.Index = 1
        Me.MnuDokzuordnungDelete.Text = "Dokument entfernen"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "-"
        '
        'MnuShowDoc
        '
        Me.MnuShowDoc.Index = 3
        Me.MnuShowDoc.Text = "Dokument anzeigen"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.ColdList})
        Me.GroupBox5.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(400, 100)
        Me.GroupBox5.TabIndex = 1
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Dokumente ersetzen"
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.ContextMenu = Me.ContextMenu7
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(3, 16)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines4
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(394, 81)
        Me.ColdList.TabIndex = 0
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 390, 77</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 390, 7" & _
        "7</ClientArea></Blob>"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Dokument auswählen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Dokument entfernen"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker2, Me.Label20, Me.txtBemerkung, Me.DateTimePicker3, Me.Label10, Me.Label6})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(368, 200)
        Me.GroupBox4.TabIndex = 0
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Allgemein"
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.DateTimePicker2.Location = New System.Drawing.Point(88, 48)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.ShowUpDownButtons = False
        Me.DateTimePicker2.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker2.TabIndex = 1
        Me.DateTimePicker2.Tag = Nothing
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 72)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 35
        Me.Label20.Text = "Bemerkung"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(88, 72)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(272, 112)
        Me.txtBemerkung.TabIndex = 2
        Me.txtBemerkung.Text = ""
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker3.TabIndex = 0
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 34
        Me.Label10.Text = "Archiv-Datum"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 48)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 30
        Me.Label6.Text = "Termin"
        '
        'TabPage5
        '
        Me.TabPage5.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.GroupBox11, Me.pnlBerechtigungen, Me.GroupBox9, Me.GroupBox8})
        Me.TabPage5.Location = New System.Drawing.Point(4, 22)
        Me.TabPage5.Name = "TabPage5"
        Me.TabPage5.Size = New System.Drawing.Size(792, 334)
        Me.TabPage5.TabIndex = 2
        Me.TabPage5.Text = "Notizen / Rechte"
        Me.TabPage5.Visible = False
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(536, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 0
        Me.Button2.Visible = False
        '
        'GroupBox11
        '
        Me.GroupBox11.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label13, Me.txtAnredeZusteller, Me.txtZustelladresse})
        Me.GroupBox11.Location = New System.Drawing.Point(232, 67)
        Me.GroupBox11.Name = "GroupBox11"
        Me.GroupBox11.Size = New System.Drawing.Size(296, 200)
        Me.GroupBox11.TabIndex = 4
        Me.GroupBox11.TabStop = False
        Me.GroupBox11.Text = "Zustelladresse"
        Me.GroupBox11.Visible = False
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 150)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(192, 16)
        Me.Label13.TabIndex = 2
        '
        'txtAnredeZusteller
        '
        Me.txtAnredeZusteller.Location = New System.Drawing.Point(8, 168)
        Me.txtAnredeZusteller.Name = "txtAnredeZusteller"
        Me.txtAnredeZusteller.Size = New System.Drawing.Size(280, 20)
        Me.txtAnredeZusteller.TabIndex = 1
        Me.txtAnredeZusteller.Text = ""
        '
        'txtZustelladresse
        '
        Me.txtZustelladresse.Location = New System.Drawing.Point(8, 16)
        Me.txtZustelladresse.Multiline = True
        Me.txtZustelladresse.Name = "txtZustelladresse"
        Me.txtZustelladresse.Size = New System.Drawing.Size(280, 128)
        Me.txtZustelladresse.TabIndex = 0
        Me.txtZustelladresse.Text = ""
        '
        'pnlBerechtigungen
        '
        Me.pnlBerechtigungen.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.pnlBerechtigungen.Location = New System.Drawing.Point(168, 168)
        Me.pnlBerechtigungen.Name = "pnlBerechtigungen"
        Me.pnlBerechtigungen.Size = New System.Drawing.Size(616, 152)
        Me.pnlBerechtigungen.TabIndex = 3
        Me.pnlBerechtigungen.TabStop = False
        Me.pnlBerechtigungen.Text = "Berechtigungseinschränkung"
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.ContextMenu = Me.ContextMenu6
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.Location = New System.Drawing.Point(8, 16)
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines5
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(600, 128)
        Me.DokumentFunktionenList.TabIndex = 1
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 596, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "124</ClientArea></Blob>"
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem4})
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Text = "Berechtigungseinschränkung hinzufügen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "Berechtigungseinschränkung entfernen"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.cvertraulich, Me.Label18, Me.cGesperrt, Me.Label9})
        Me.GroupBox9.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(152, 152)
        Me.GroupBox9.TabIndex = 2
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Schutz"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(16, 96)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(120, 48)
        Me.Button3.TabIndex = 2
        Me.Button3.Text = "Liste der berechtigten Mitarbeiter"
        '
        'cvertraulich
        '
        Me.cvertraulich.Location = New System.Drawing.Point(80, 46)
        Me.cvertraulich.Name = "cvertraulich"
        Me.cvertraulich.Size = New System.Drawing.Size(48, 24)
        Me.cvertraulich.TabIndex = 1
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(16, 48)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(64, 23)
        Me.Label18.TabIndex = 17
        Me.Label18.Text = "Vertraulich"
        '
        'cGesperrt
        '
        Me.cGesperrt.Enabled = False
        Me.cGesperrt.Location = New System.Drawing.Point(80, 24)
        Me.cGesperrt.Name = "cGesperrt"
        Me.cGesperrt.Size = New System.Drawing.Size(48, 24)
        Me.cGesperrt.TabIndex = 0
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 24)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(64, 23)
        Me.Label9.TabIndex = 15
        Me.Label9.Text = "Gesperrt"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(776, 152)
        Me.GroupBox8.TabIndex = 1
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Notizen"
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(80, 40)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines6
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu1
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(8, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines7
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(760, 128)
        Me.Notizlist.TabIndex = 0
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 756, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 756, " & _
        "124</ClientArea></Blob>"
        '
        'cbVerantwortlich
        '
        Me.cbVerantwortlich.ContextMenu = Me.ContextMenu5
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(520, 64)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(224, 21)
        Me.cbVerantwortlich.TabIndex = 7
        '
        'ContextMenu5
        '
        Me.ContextMenu5.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Berechtigte Mitarbeiter"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(416, 64)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(88, 23)
        Me.Label17.TabIndex = 44
        Me.Label17.Text = "Verantwortlicher"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(416, 40)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 43
        Me.Label16.Text = "Dokumentstatus"
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.ItemHeight = 13
        Me.cbdokumentstatus.Location = New System.Drawing.Point(520, 40)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(264, 21)
        Me.cbdokumentstatus.TabIndex = 6
        '
        'txtPartnerInhaberNr
        '
        Me.txtPartnerInhaberNr.Location = New System.Drawing.Point(272, 72)
        Me.txtPartnerInhaberNr.Name = "txtPartnerInhaberNr"
        Me.txtPartnerInhaberNr.ReadOnly = True
        Me.txtPartnerInhaberNr.Size = New System.Drawing.Size(24, 20)
        Me.txtPartnerInhaberNr.TabIndex = 42
        Me.txtPartnerInhaberNr.Text = ""
        Me.txtPartnerInhaberNr.Visible = False
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(520, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(264, 20)
        Me.txtBezeichnung.TabIndex = 5
        Me.txtBezeichnung.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(416, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.TabIndex = 38
        Me.Label4.Text = "Bezeichnung"
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(352, 16)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 2
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(112, 40)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerZusteller.TabIndex = 1
        Me.txtPartnerZusteller.Text = ""
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(112, 16)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 0
        Me.txtPartnerInhaber.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 34
        Me.Label2.Text = "Partner-Zusteller"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 33
        Me.Label1.Text = "Partner-Inhaber"
        '
        'cdokumentwerteanzeigen
        '
        Me.cdokumentwerteanzeigen.Location = New System.Drawing.Point(536, 467)
        Me.cdokumentwerteanzeigen.Name = "cdokumentwerteanzeigen"
        Me.cdokumentwerteanzeigen.Size = New System.Drawing.Size(160, 32)
        Me.cdokumentwerteanzeigen.TabIndex = 11
        Me.cdokumentwerteanzeigen.Text = "Dokumentinhalte anzeigen"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(376, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 3
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(328, 64)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(24, 24)
        Me.Button4.TabIndex = 4
        Me.Button4.Visible = False
        '
        'cbsave
        '
        Me.cbsave.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbsave.Location = New System.Drawing.Point(743, 64)
        Me.cbsave.Name = "cbsave"
        Me.cbsave.Size = New System.Drawing.Size(21, 21)
        Me.cbsave.TabIndex = 8
        Me.cbsave.Text = "ComboBox1"
        Me.cbsave.Visible = False
        '
        'cbmoeglicheStati
        '
        Me.cbmoeglicheStati.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbmoeglicheStati.Location = New System.Drawing.Point(743, 64)
        Me.cbmoeglicheStati.Name = "cbmoeglicheStati"
        Me.cbmoeglicheStati.Size = New System.Drawing.Size(21, 21)
        Me.cbmoeglicheStati.TabIndex = 48
        Me.cbmoeglicheStati.Text = "ComboBox1"
        '
        'Panel1
        '
        Me.Panel1.Location = New System.Drawing.Point(784, 16)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(24, 100)
        Me.Panel1.TabIndex = 50
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(416, 80)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 32)
        Me.Label11.TabIndex = 52
        Me.Label11.Text = "Berechtigt für Folgestatus"
        Me.Label11.Visible = False
        '
        'txtstatus
        '
        Me.txtstatus.Location = New System.Drawing.Point(520, 88)
        Me.txtstatus.Name = "txtstatus"
        Me.txtstatus.Size = New System.Drawing.Size(224, 16)
        Me.txtstatus.TabIndex = 51
        Me.txtstatus.Text = "Label3"
        Me.txtstatus.Visible = False
        '
        'btntxtBemerkung
        '
        Me.btntxtBemerkung.Image = CType(resources.GetObject("btntxtBemerkung.Image"), System.Drawing.Bitmap)
        Me.btntxtBemerkung.Location = New System.Drawing.Point(765, 64)
        Me.btntxtBemerkung.Name = "btntxtBemerkung"
        Me.btntxtBemerkung.Size = New System.Drawing.Size(20, 21)
        Me.btntxtBemerkung.TabIndex = 9
        '
        'LabelVIBeachten
        '
        Me.LabelVIBeachten.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.LabelVIBeachten.ForeColor = System.Drawing.Color.Red
        Me.LabelVIBeachten.Location = New System.Drawing.Point(48, 72)
        Me.LabelVIBeachten.Name = "LabelVIBeachten"
        Me.LabelVIBeachten.Size = New System.Drawing.Size(192, 23)
        Me.LabelVIBeachten.TabIndex = 56
        Me.LabelVIBeachten.Text = "VI beachten"
        Me.LabelVIBeachten.Visible = False
        '
        'PicVIBeachten
        '
        Me.PicVIBeachten.Image = CType(resources.GetObject("PicVIBeachten.Image"), System.Drawing.Bitmap)
        Me.PicVIBeachten.Location = New System.Drawing.Point(5, 55)
        Me.PicVIBeachten.Name = "PicVIBeachten"
        Me.PicVIBeachten.Size = New System.Drawing.Size(43, 41)
        Me.PicVIBeachten.TabIndex = 57
        Me.PicVIBeachten.TabStop = False
        Me.PicVIBeachten.Visible = False
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(8, 472)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 62
        '
        'frmDokumentbearbeitungBC
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(808, 501)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.LabelVIBeachten, Me.btntxtBemerkung, Me.Label11, Me.txtstatus, Me.Panel1, Me.cbsave, Me.cbmoeglicheStati, Me.Button4, Me.Button1, Me.cdokumentwerteanzeigen, Me.cbVerantwortlich, Me.Label17, Me.Label16, Me.cbdokumentstatus, Me.txtPartnerInhaberNr, Me.txtBezeichnung, Me.Label4, Me.btnPartnerInhaber, Me.txtPartnerZusteller, Me.txtPartnerInhaber, Me.Label2, Me.Label1, Me.TabControl2, Me.btnCancel, Me.btnWeiter, Me.PicVIBeachten})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDokumentbearbeitungBC"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumentbearbeitung - Barcodekleber-Dokument"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.GroupBox13.ResumeLayout(False)
        Me.GroupBox12.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.TabPage4.ResumeLayout(False)
        Me.GroupBox7.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox6.ResumeLayout(False)
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage5.ResumeLayout(False)
        Me.GroupBox11.ResumeLayout(False)
        Me.pnlBerechtigungen.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox9.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Load_Defaults Method

Private Sub Load_Defaults()

Source code

[Visual Basic]
    Private Sub Load_Defaults()
        If Me.Notfallimport Then Me.Text = Me.Text + " - Notfall-Dokumenterstellung"
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Dim doktyp As New edokadb.clsDokumenttyp()
        doktyp.cpMainConnectionProvider = conn
        doktyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doktyp.SelectOne()

        If doktyp.bFunktionen_zuweisen.Value = True Then
            Dokumentfunktionen_Aktivieren()
        Else
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.pnlBerechtigungen.Visible = False
        End If
        Me.progress.Bar1.Value = 30
        progress.Refresh()
        'Dokumenttyp-Daten
        If Me.CreateDocument = True Then
            If DivFnkt.Ist_Berechtigt(doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 2, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
            End If
        Else
            If DivFnkt.Ist_Berechtigt(doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 3, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
            End If
        End If

        Me.progress.Bar1.Value = 40
        progress.Refresh()

        Me.txtBezeichnung.Text = doktyp.sBezeichnung.Value
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumentid").Value = ""
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumenttypnr").Value = Me.Dokumenttypnr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@CreateNew").Value = 1
        Me.SqlDataAdapter1.Fill(Me.DataSet1)

        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160

        Me.mcbstatus = New MultiComboBox(Me.cbdokumentstatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)

        Me.mcbkube = New MultiComboBox(Me.cbKube)
        Me.mcbkube.CheckNullValue = True
        Me.mcbkube.NullValueMessage = MyTxt.gettext(18)
        Me.mcbkube.DisplayColumnName = "name"
        Me.mcbkube.ValueColumnName = "mitarbeiternr"
        Me.mcbkube.Fill_Data(Generic_Select(8), False)

        'Postzustellung
        Me.SqlDataAdapter2.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter2.SelectCommand.Parameters("@sprache").Value = Globals.Sprache
        Me.SqlDataAdapter2.Fill(Me.DataSet2)

        mcbpostzustellung = New MultiComboBox(Me.cbPostzustellung)
        Me.mcbpostzustellung.DisplayColumnName = "bezeichnung"
        Me.mcbpostzustellung.ValueColumnName = "nreintrag"
        Dim d As DataTable
        d = Me.DataSet2.Tables(0)
        Me.mcbpostzustellung.Fill_Data(d, False)
        Me.mcbpostzustellung.Enabled = True
        Me.mcbpostzustellung.CheckNullValue = False
        Me.progress.Bar1.Value = 50
        progress.Refresh()
        mcbzust = New MultiComboBox(Me.cbzust)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii

        Me.progress.Bar1.Value = 60
        progress.Refresh()
        If Not Me.Notfallimport Then
            mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
            Me.mcbunterschriftlinks.DisplayColumnName = "name"
            Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
            For i = 0 To Me.Profile.Rows.Count - 1
                If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                    CurrentProfil = i
                End If
            Next
            ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftlinks")
            Me.mcbunterschriftlinks.Fill_Data(Generic_Select(3), True)
            Me.mcbunterschriftlinks.SelectedValue = ii

            mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
            Me.mcbunterschriftrechts.DisplayColumnName = "name"
            Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
            For i = 0 To Me.Profile.Rows.Count - 1
                If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                    CurrentProfil = i
                End If
            Next
            ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftrechts")
            Me.mcbunterschriftrechts.Fill_Data(Generic_Select(3), True)
            Me.mcbunterschriftrechts.SelectedValue = ii

            Me.mcbunterschriftlinks.CheckNullValue = False
            Me.mcbunterschriftrechts.CheckNullValue = False
        End If

        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        FillMcbVerantwortlich()

        Me.progress.Bar1.Value = 70
        progress.Refresh()
        Me.rbZustaendigKube.Checked = False
        Me.RBZustaendigZustaendiger.Checked = True
        Me.txtZustelladresse.Text = ""

        If Not Me.Notfallimport Then
            If doktyp.bUnterschrift_links.Value = False Then Me.mcbunterschriftlinks.Enabled = False
            If doktyp.bUnterschrift_rechts.Value = False Then Me.mcbunterschriftrechts.Enabled = False
            If doktyp.bUnterschrift_links.Value = True Then Me.mcbunterschriftlinks.Enabled = True
            If doktyp.bUnterschrift_rechts.Value = True Then Me.mcbunterschriftrechts.Enabled = True
        Else
            Me.mcbunterschriftlinks.Visible = False
            Me.mcbunterschriftrechts.Visible = False
        End If

        Me.zu_retournieren = doktyp.bZu_retournieren.Value

        doktyp.Dispose()

        'Dokument ersetzen
        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()
        Me.ColdList.DataSource = Me.Dokumentersetzen
        Me.ColdList.Columns("aktiv").FilterText = True
        Me.ColdList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")
        If doktyp.bCold_ersetzen.Value <> True Then
            Me.ErsetzenMoeglich = False
        Else
            Me.ErsetzenMoeglich = True
        End If

        'Notizen
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        'Dokumentzuordnungen
        Me.Dokumentzuorndungen = Dokumentzuordnungen_Laden()
        w.Save_Dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.ZuordnungList.DataSource = Me.Dokumentzuorndungen

        DivFnkt.SpaltenTitel_Aktualisieren(Me.ZuordnungList, Me.Dokumentzuorndungen, "dokumentzuordnungen")
        Me.ZuordnungList.Columns("aktiv").FilterText = True
        Me.ZuordnungList.FilterBar = False

        Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Translate = True
        Next

        Me.progress.Bar1.Value = 80
        progress.Refresh()
        'Dokumentinfomeldungen
        Me.InfoMeldungList.FetchRowStyles = True
        Me.DokumentInfoMeldungen = Dokumentinfomeldungen_laden()
        w.Save_Dokumentinfomeldungen = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = Me.DokumentInfoMeldungen
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, Me.DokumentInfoMeldungen, "Dokumentinfomeldung")

        'Team
        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        refresh_team()

        Me.mcbteam.SelectedIndex = 0

        Me.mcbstatus.SelectedIndex = 0
        Me.savestatus = Me.mcbstatus.SelectedValue
        If Me.Edex_Folgestatus <> 0 Then Me.mcbstatus.SelectedIndex = Me.Edex_Folgestatus
        Me.savestatus = Me.mcbstatus.SelectedValue
        Me.firststatus = Me.savestatus
        Me.saveverantwortlicher = Globals.MitarbeiterNr

        'Hutter Notfallimport
        If Not Me.Notfallimport Then
            Me.moeglichestati = Generic_Select(15)
            Me.cbmoeglicheStati.Items.Clear()
            Me.funktionsliste = ""
            '        Dim i As Integer
            settooltip()
            For i = 0 To Me.moeglichestati.Rows.Count - 1
                Me.cbmoeglicheStati.Items.Add(Me.moeglichestati.Rows(i).Item("bezeichnung"))
            Next
        End If

        'Rel. 3.7 shu
        If doktyp.bBezeichnungmut.Value = True Then
            Me.txtBezeichnung.ReadOnly = False
        Else
            Me.txtBezeichnung.ReadOnly = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim i As Integer
        Dim s As String
        s = ""
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

        Dim f As New frmBerechtigungen()
        If Me.cvertraulich.Checked Then
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 1, s)
        Else
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 0, s)
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmDokumentberechtigung()
        f.Dokumenttyp = Me.Dokumenttypnr
        f.Partnernr = Me.Partnernr
        f.Vertraulich = Me.cvertraulich.Checked
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = DokumentFunktionen.Rows
            Dim rowvals(Me.DokumentFunktionenList.Columns.Count - 1)
            rowvals(0) = System.DBNull.Value
            rowvals(1) = f.Funktionsgruppebezeichnung
            rowvals(2) = f.Funktionsgruppenr
            rowvals(3) = f.Anzeigen
            rowvals(4) = f.Bearbeiten
            rowvals(5) = f.Loeschen
            rowvals(6) = f.Abschliessen
            rowvals(7) = True
            rowvals(8) = Now
            rowvals(9) = Globals.MitarbeiterNr
            newrow = rc.Add(rowvals)
            Me.DokumentFunktionenList.Refresh()
            For i = 0 To Me.DokumentFunktionenList.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenList.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                    Me.DokumentFunktionenList.Bookmark = i
                End If
            Next
            Me.FillMcbVerantwortlich()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Me.DokumentFunktionenList.Columns(7).Value = False
        Me.DokumentFunktionenList.Refresh()
        Me.Button3.Focus()
        Me.DokumentFunktionenList.Focus()
        Me.FillMcbVerantwortlich()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.BtnHelp.Visible = False
        fx.Button9.Visible = False
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                If Check_Dokumentersetzen(Me.Dokumenttypnr, fx.SelectedDokumentid) Then
                    Dim rc As DataRowCollection
                    Dim newrow As DataRow
                    rc = Dokumentersetzen.Rows
                    Dim rowvals(Me.Dokumentersetzen.Columns.Count - 1) As Object
                    rowvals(0) = System.DBNull.Value
                    rowvals(1) = ""
                    If Me.CreateDocument Then
                        rowvals(1) = ""
                    Else
                        rowvals(1) = Me.DokumentID
                    End If
                    rowvals(2) = fx.SelectedDokumentid
                    rowvals(3) = True

                    rowvals(8) = fx.Dokumentbezeichnung
                    rowvals(9) = fx.dokumentdatum
                    newrow = rc.Add(rowvals)
                    Me.ColdList.Refresh()
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Me.ColdList.Columns("aktiv").Value = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Try
            Me.Notizlist.Columns(5).Value = False
            Me.Notizlist.Refresh()
            Me.TabControl2.Select()
            Me.Notizlist.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuDokZuordnungAdd_Click Method

Private Sub MnuDokZuordnungAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokZuordnungAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokZuordnungAdd.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.Button9.Visible = False
        fx.BtnHelp.Visible = False
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                Dim rc As DataRowCollection
                Dim newrow As DataRow
                rc = Me.Dokumentzuorndungen.Rows
                Dim rowvals(Me.Dokumentzuorndungen.Columns.Count - 1) As Object
                rowvals(0) = 0
                rowvals(2) = 1
                rowvals(6) = 1
                rowvals(8) = fx.SelectedDokumentid
                rowvals(10) = fx.Dokumentbezeichnung

                newrow = rc.Add(rowvals)
                Me.ZuordnungList.Refresh()
                'For i = 0 To Me.ZuordnungList.Splits(0).Rows.Count - 1
                'If Me.ZuordnungList.Columns(0).CellText(i) = fx.SelectedDokumentid Then
                '    Me.ZuordnungList.Bookmark = i
                'End If
                'Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuDokzuordnungDelete_Click Method

Private Sub MnuDokzuordnungDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokzuordnungDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokzuordnungDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokzuordnungDelete.Click
        Me.ZuordnungList.Columns("aktiv").Value = False
        Me.ZuordnungList.Refresh()
        Me.TabControl2.Select()
        Me.ZuordnungList.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlist.Columns("betreff").Value = f.Betreff
            Me.Notizlist.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlist.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim f As New frmNotizen()
        f.Mutierer = Globals.MitarbeiterNr.ToString
        f.Notiz = ""
        f.Betreff = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizen.Rows
            Dim rowvals(Me.Notizen.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer
            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizen
            load_Mitarbeiter()

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuShowDoc_Click Method

Private Sub MnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowDoc.Click
        DivFnkt.ShowDoc(Me.ZuordnungList.Columns(8).Text, Me)
        'Dim doc As New edokadb.clsDokument()
        'Dim Dokument As String
        'Dim FileReader As New DocMgmt()
        'doc.cpMainConnectionProvider = conn
        'doc.sDokumentid = New SqlString(CType(Me.ZuordnungList.Columns(1).Value, String))
        'doc.SelectOne()
        'Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
        'FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument)
        'doc.Dispose()
        'FileReader = Nothing
        'Dim w As New WordLib()
        'w.ShowDoc(Dokument)
        'w = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.MnuValueSelect_Click Method

Private Sub MnuValueSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuValueSelect.Click, _
   DokWertList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuValueSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuValueSelect.Click, DokWertList.DoubleClick
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim s As String
        Select Case UCase(Me.DokWertList.Columns("feldtyp").Value)
            Case "DATUMSHORT"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToShortDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMMEDIUM"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart
                    s = Format(f.MonthCalendar1.SelectionStart, "dd. MMMM yyyy")
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMLONG"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToLongDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()

            Case "TEXT"
                If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 8) = "&Partner" Then
                    Dim f As New FrmPartnersuche()
                    f.Dokumenttypnrnr = Me.Dokumenttypnr
                    f.ShowDialog()
                    If f.PartnerNr <> 0 Then
                        Me.DokWertList.Columns("feldwert").Value = Str(f.PartnerNr) + "-" + f.PartnerKurzbezeichnnung
                    End If
                    f.Dispose()
                Else
                    If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 1) = "&" Then
                        Dim f As New frmValueSelector()
                        If Me.DokWertList.Columns("Datenherkunft").Value = "&SekPartnerVV&" Then
                            Dim ss As String
                            Dim ii As Integer
                            For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner&" Then
                                    ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                End If
                            Next
                            'ss = Me.DokWertList.Columns("feldwert").CellText(0)
                            ii = InStr(ss, "-")
                            If ii < 1 Then Exit Sub
                            f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                        Else
                            If Me.DokWertList.Columns("Datenherkunft").Value = "&TerPartnerVV&" Then
                                Dim ss As String
                                Dim ii As Integer
                                For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                    If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner3&" Then
                                        ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                    End If
                                Next
                                'ss = Me.DokWertList.Columns("feldwert").CellText(0)
                                ii = InStr(ss, "-")
                                If ii < 1 Then Exit Sub
                                f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                            Else
                                f.partnernr = Me.txtPartnerInhaberNr.Text()
                            End If
                        End If
                        f.Text = f.Text + Me.DokWertList.Columns(0).Value
                        f.Datenherkunft = Me.DokWertList.Columns("Datenherkunft").Value
                        'f.partnernr = Me.txtPartnerInhaberNr.Text()
                        f.LoadData()
                        If f.Datenvorhanden = True Then
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then Me.DokWertList.Columns("feldwert").Value = f.SelWert
                        End If
                        f.Dispose()
                    End If
                End If
            Case Else
        End Select
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notfallimport_COLD_Index_Sichern Method

Public Function Notfallimport_COLD_Index_Sichern( _
   ByVal indextyp As Integer _
) As DataTable

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Function Notfallimport_COLD_Index_Sichern(ByVal indextyp As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Notfallimport_coldindex"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notizen_Sichern Method

Public Sub Notizen_Sichern()

Source code

[Visual Basic]
    Public Sub Notizen_Sichern()
        For i = 0 To Me.Notizen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Notizlist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Notizlist.DoubleClick
        MnuEditNotiz_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Notizlist_MouseUp Method

Private Sub Notizlist_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseUp
        If Me.Notizen.Rows.Count = 0 Then Exit Sub
        Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.RBZustaendigZustaendiger_CheckedChanged Method

Private Sub RBZustaendigZustaendiger_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBZustaendigZustaendiger.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBZustaendigZustaendiger_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBZustaendigZustaendiger.CheckedChanged
        Me.mcbkube.Enabled = False
        Me.mcbzust.Enabled = True
        Me.mcbzust.Focus()

        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            Me.refresh_team()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Set_Feldwert Method

Private Sub Set_Feldwert()

Source code

[Visual Basic]
    Private Sub Set_Feldwert()
        Try
            'Me.DokWertList.Columns("feldwert").Value = Me.ValueList.Columns(0).Value
            'Me.DokWertList.Columns("feldwert").Value = Me.Datumselect.Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Status_History Method

Private Function Status_History( _
   ByVal statusnr As Long _
)

Parameters

statusnr
Required.

Source code

[Visual Basic]
    Private Function Status_History(ByVal statusnr As Long)
        Dim statush As New Statushandling()
        Dim i, i1 As Integer
        If Me.saveverantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.savestatus = Me.mcbstatus.SelectedValue And Not Me.CreateDocument And Me.mcbstatus.SelectedIndex = 0 Then
            statush.Dispose()
            Exit Function
        End If
        If Me.CreateDocument Then
            i = Me.mcbstatus.SelectedValue
            Me.mcbstatus.SelectedIndex = 0
            statush.insert_history_status(get_current_Status(Me.DokumentID), Me.DokumentID, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(500)
            Me.mcbstatus.SelectedValue = i
            If Me.mcbstatus.SelectedIndex <> 0 Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(get_current_Status(Me.DokumentID), Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
            End If
            w.send_statusmessage = True
        Else
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbstatus.SelectedIndex <> 0 Then
                i = Me.mcbstatus.SelectedValue
                Me.mcbstatus.SelectedIndex = 0
                Me.savestatus = Me.mcbstatus.SelectedValue
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.DokumentID, Globals.MitarbeiterNr)
                w.send_statusmessage = True
                Me.mcbstatus.SelectedValue = i
                System.Threading.Thread.CurrentThread.Sleep(500)
            End If
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
            End If
        End If
        If Me.mcbverantwortlich.SelectedValue <> Globals.MitarbeiterNr Then
            If Me.save_stv = 1 Then
                If Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                    If Me.txtBemerkungVerantwortlicher <> "" Then
                        statush.BemerkungVerantwortlicher = Me.txtBemerkungVerantwortlicher
                    End If
                    statush.Meldung_Verantwortlicher(Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
                End If
            Else
                If Me.txtBemerkungVerantwortlicher <> "" Then
                    statush.BemerkungVerantwortlicher = Me.txtBemerkungVerantwortlicher
                End If
                statush.Meldung_Verantwortlicher(Me.DokumentID, Me.mcbverantwortlich.SelectedValue)

            End If
        End If

        'If Me.txtBemerkungVerantwortlicher <> "" Then
        'statush.BemerkungVerantwortlicher = Me.txtBemerkungVerantwortlicher
        'End If
        'statush.Meldung_Verantwortlicher(Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
        'End If
        If w.send_statusmessage = True Then
            statush.Meldung_Status(Me.DokumentID, Me.mcbstatus.SelectedValue)
        End If
        statush.Dispose()

        statush.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.TabControl2_SelectedIndexChanged Method

Private Sub TabControl2_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl2.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl2_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl2.SelectedIndexChanged
        Me.changeteam = 2
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.Update_Bclabel Method

Private Sub Update_Bclabel( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Sub Update_Bclabel(ByVal typ As Integer)
        If Me.BarcodeID = "" Then Exit Sub
        Dim bc As New edokadb.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        bc.iBarcodenr = New SqlInt32(CType(Me.BarcodeID, Int32))
        bc.SelectOne()
        conn.OpenConnection()
        If typ = 2 And Me.CreateDocument = True Then
            bc.sDokumentid = New SqlString(CType("", String))
        Else
            bc.sDokumentid = New SqlString(CType(Me.DokumentID, String))
        End If
        bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        bc.Update()
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.bereiche_sperren Method

Private Sub bereiche_sperren()

Source code

[Visual Basic]
    Private Sub bereiche_sperren()
        Me.btnPartnerInhaber.Enabled = False
        Me.GroupBox1.Enabled = False
        Me.GroupBox2.Enabled = False
        Me.GroupBox3.Enabled = False
        Me.GroupBox4.Enabled = False
        Me.GroupBox5.Enabled = False
        Me.GroupBox10.Enabled = False
        Me.GroupBox11.Enabled = False
        Me.GroupBox12.Enabled = False
        Me.GroupBox9.Enabled = False
        Me.Button2.Enabled = False
        Me.pnlBerechtigungen.Enabled = False
        Me.cbVerantwortlich.Enabled = False
        Me.mcbverantwortlich.Enabled = False
        Me.cbdokumentstatus.Enabled = False
        Me.mcbstatus.Enabled = False
        Me.DokWertList.Enabled = False
        Me.cdokumentwerteanzeigen.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        If Me.CreateDocument = False Then
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            If Globals.Dokumentcoldindex_Changed Then Archivfnkt.Restore_Coldindex(Globals.general_ds.Tables(0), Me.DokumentID)
            If Globals.dokumentid_changed Then Archivfnkt.change_dokumentid(DokumentID, Globals.Dokumentidalt)
        Else
            Update_Bclabel(2)
        End If

        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        Dim f As New FrmPartnersuche()
        f.profilnr = Me.Profilnr
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.NurAbfrage = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, f.PartnerNr, "", 2, 0, 0, 0) Then
                If Me.txtPartnerInhaber.Text <> "" And Me.txtPartnerInhaber.Text <> Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung Then
                    MyMsg.show_standardmessage(73, MsgBoxStyle.Information)
                End If
                Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                Me.txtPartnerInhaberNr.Text = f.PartnerNr
                Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                Me.TabControl2.Enabled = True
                Me.RBZustaendigZustaendiger.Checked = True
                Me.mcbkube.DataSource = Nothing
                Me.mcbkube.Text = ""
                Me.mcbkube.Items.Clear()
                Me.Partnernr = f.PartnerNr
                Me.vibeachten = f.VIBeachten
                FillMcbVerantwortlich()
                'EDEX Banklagernd
                Banklagernd_Check()
            Else
                MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                Me.Close()
            End If
        End If
        If Me.vibeachten = True Then
            Me.PicVIBeachten.Visible = True
            Me.LabelVIBeachten.Visible = True
        Else
            Me.PicVIBeachten.Visible = False
            Me.LabelVIBeachten.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
            If DivFnkt.EDOKA_Partner_Dokument(3, Me.Dokumenttypnr) = False Then
                MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                Exit Sub
            End If
        End If

        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
        p.SelectOne()
        If p.bSaldiert.Value = True Then
            Dim dt As New edokadb.clsDokumenttyp()
            dt.cpMainConnectionProvider = conn
            dt.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
            dt.SelectOne()
            If dt.bVertrag.Value = True Then
                MyMsg.show_standardmessage(234, MsgBoxStyle.Critical)
                dt.Dispose()
                p.Dispose()
                Exit Sub
            End If
            dt.Dispose()
        End If
        p.Dispose()

        Dim xdata As DataTable
        Dim s As String
        If Me.savestatus = Me.mcbstatus.SelectedValue And Me.savestatus = Me.firststatus Then
            If MyMsg.Show_HinweisMessage(Me.Profilnr, 2, 71, 2) = False Then
                Exit Sub
            End If
        End If
        If Me.txtPartnerInhaber.Text = "" Then
            MyMsg.show_standardmessage(205, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Me.mcbverantwortlich.Text = "" Then
            MyMsg.show_standardmessage(208, MsgBoxStyle.Critical)
            Exit Sub
        End If
        If Check_Dokumentfunktionen() = False Then Exit Sub
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("zwingend") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("zwingend") = True Then
                    If xdata.Rows(i).Item("feldwert") Is System.DBNull.Value Or xdata.Rows(i).Item("feldwert") = "" Then
                        MyMsg.show_standardmessage(206, MsgBoxStyle.Critical)
                        Me.DokWertList.Focus()
                        xdata.Dispose()
                        Exit Sub
                    End If
                End If
            End If
        Next
        If Me.mcbteam.SelectedValue = 0 Then
            MyMsg.show_standardmessage(207, MsgBoxStyle.Critical)
            Me.mcbteam.Focus()
            Exit Sub
        End If
        xdata.Dispose()
        Me.btnWeiter.Enabled = False
        Dokument_Bearbeiten(Me.CreateDocument)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.btntxtBemerkung_Click Method

Private Sub btntxtBemerkung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btntxtBemerkung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btntxtBemerkung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btntxtBemerkung.Click
        Dim f As New frmtxtBemerkung()
        f.txtBemerkung.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then Me.txtBemerkungVerantwortlicher = f.txtBemerkung.Text
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cbKube_SelectedIndexChanged Method

Private Sub cbKube_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbKube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.SelectedIndexChanged
        If Me.changeteam > 0 Then
            Me.changeteam = Me.changeteam - 1
            Exit Sub
        End If

        Try
            Me.teamzustaendig = Me.mcbkube.SelectedValue
        Catch
        End Try
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cbmoeglicheStati_DropDown Method

Private Sub cbmoeglicheStati_DropDown( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.DropDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.DropDown
        Me.cbmoeglicheStati.Width = 200
        Me.cbsave.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cbmoeglicheStati_Leave Method

Private Sub cbmoeglicheStati_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.Leave
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cbmoeglicheStati_SelectedValueChanged Method

Private Sub cbmoeglicheStati_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedValueChanged
        Dim i As Integer
        Dim DATA As DataTable
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
        Me.txtstatus.Text = Me.cbmoeglicheStati.Text
        Me.Label3.Visible = True
        Me.txtstatus.Visible = True
        If Me.txtstatus.Text = Me.mcbstatus.Text Then
            Me.Label3.Visible = False
            Me.txtstatus.Visible = False
            Me.funktionsliste = ""
            Me.selectedstatus = 0
        Else
            For i = 0 To Me.moeglichestati.Rows.Count - 1
                If Me.txtstatus.Text = Me.moeglichestati.Rows(i).Item("bezeichnung") Then
                    Me.selectedstatus = Me.moeglichestati.Rows(i).Item("nr")
                End If
            Next
        End If
        Me.funktionsliste = ""
        DATA = Generic_Select(16)
        For i = 0 To DATA.Rows.Count - 1
            If Me.funktionsliste <> "" Then Me.funktionsliste = Me.funktionsliste + ";"
            Me.funktionsliste = Me.funktionsliste + LTrim(DATA.Rows(i).Item("funktionnr"))
        Next
        fill_mcbmitarbeiter()
        Me.mcbverantwortlich.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cbzust_SelectedIndexChanged Method

Private Sub cbzust_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.SelectedIndexChanged
        If Me.changeteam > 0 Then
            Me.changeteam = Me.changeteam - 1
            Exit Sub
        End If

        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.check_banklagernd Method

Private Function check_banklagernd() As Integer

Source code

[Visual Basic]
    Private Function check_banklagernd() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_banklagernd"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@banklagernd", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters.Item("@banklagernd").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.cvertraulich_CheckedChanged Method

Private Sub cvertraulich_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cvertraulich.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cvertraulich_CheckedChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cvertraulich.CheckedChanged
        Try
            FillMcbVerantwortlich()
            Me.mcbverantwortlich.Focus()
            Me.mcbkube.SelectAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbverantwortlich.DataSource = Nothing
        Me.mcbverantwortlich.Items.Clear()
        Me.mcbverantwortlich.CheckNullValue = True
        Me.mcbverantwortlich.NullValueMessage = MyTxt.gettext(18)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        Me.mcbverantwortlich.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.DokumentID, 3, 0, 0, 0, Me.funktionsliste), False)
        '        Me.mcbmitarbeiter.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.Dokumentid, 3, 0, 0, 0, Me.Funktionsliste), False)

        ' Me.mcbverantwortlich.SelectedValue = Me.mitarbeiternr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.frmDokumentbearbeitung_Load Method

Private Sub frmDokumentbearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentbearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        progress.Bar1.Value = 10
        progress.Info.Text = "Vorbereitung Dokumenterstellung"
        progress.Refresh()
        progress.Show()
        progress.Refresh()

        Me.On_Load = True
        Me.save_stv = Globals.stv
        If Me.CreateDocument Then
            Formular_Laden_Create_Document()
            progress.Bar1.Value = 20
            progress.Refresh()

            If Me.Partnernr <> "" Then
                If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, Me.Partnernr, "", 2, 0, 0, 0) Then
                    Dim f As New FrmPartnersuche()
                    f.Dokumenterstellen = True
                    f.Partner_Suche(Me.Partnernr)
                    Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                    If Me.txtPartnerInhaber.Text = " 0 " Then Me.txtPartnerInhaber.Text = ""
                    Me.txtPartnerInhaberNr.Text = f.PartnerNr
                    Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                    Me.TabControl2.Enabled = True
                    Me.vibeachten = f.VIBeachten
                    f.Dispose()
                    'edex Banklagernd
                    Banklagernd_Check()
                Else
                    MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                    Me.Close()
                End If
            Else
                btnPartnerInhaber_Click(sender, e)
            End If
            If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
                Me.cbKube.SelectedValue = Globals.MitarbeiterNr
            End If
        Else
            Formular_laden_Edit_Document()
            Dim bc As New DataTable()
            bc = Generic_Select(11)
            If bc.Rows.Count > 0 Then
                Me.BarcodeID = LTrim(Str(bc.Rows(0).Item(0)))
            End If
            bc.Dispose()
        End If
        If Me.BarcodeID <> "" Or Me.Dokumentinfobearbeiten = True Then
            Me.cdokumentwerteanzeigen.Visible = False
        Else
            Me.cdokumentwerteanzeigen.Visible = True
        End If

        Me.On_Load = False
        If Me.Dokument_Ist_Abgeschlossen Then bereiche_sperren()
        If Me.vibeachten = True Then
            Me.PicVIBeachten.Visible = True
            Me.LabelVIBeachten.Visible = True
        Else
            Me.PicVIBeachten.Visible = False
            Me.LabelVIBeachten.Visible = False
        End If

        progress.Close()
        progress.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.get_current_Status Method

Private Function get_current_Status( _
   ByVal dokumentid As String _
) As Long

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function get_current_Status(ByVal dokumentid As String) As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_current_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statustext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            get_current_Status = scmCmdToExecute.Parameters.Item("@currentstatus").Value
            Return get_current_Status
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.get_partnerzusteller Method

Private Function get_partnerzusteller( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_partnerzusteller(ByVal nrpar00 As Integer) As String
        Dim p As New edokadb.clsPartner()
        Dim p1 As New edokadb.clsPartner()
        Dim s As String
        s = ""
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        If p.iNRPAR00.ToString <> p.sNRPARAD.ToString Then
            Try
                p1.cpMainConnectionProvider = conn
                p1.iNRPAR00 = New SqlInt32(CType(p.sNRPARAD.Value, Int32))
                p1.SelectOne()
                s = p1.sNRPARAD.ToString + " " + p1.sBKPAR00.Value
            Catch
                s = ""
            End Try
        End If
        p.Dispose()
        p1.Dispose()
        get_partnerzusteller = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.mcbkube_Leave Method

Private Sub mcbkube_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbkube_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbkube.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.mcbzust_Leave Method

Private Sub mcbzust_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbzust_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbzust.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.mnuInfoEmpfaengerAdd_Click Method

Private Sub mnuInfoEmpfaengerAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerAdd.Click
        Dim f As New frmInformationsEmpfaenger()
        f.Dokumenttypnr = Me.Dokumenttypnr
        If Me.CreateDocument = True Then
            f.fromDokumenttyp = True
        Else
            f.fromDokumenttyp = False
            f.dokumentid = Me.DokumentID
        End If
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungen.Rows
            Dim rowvals(9) As Object
            rowvals(0) = 0
            rowvals(1) = 0
            rowvals(2) = f.Empfaenger
            rowvals(3) = f.Empaengertext
            rowvals(4) = f.Meldungsnr
            rowvals(5) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(6) = f.Bemerkung
            rowvals(7) = f.Statusnr
            rowvals(8) = f.Statustext
            rowvals(9) = 1
            newrow = rc.Add(rowvals)
            Me.InfoMeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.mnuInfoEmpfaengerDelete_Click Method

Private Sub mnuInfoEmpfaengerDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerDelete.Click
        Try
            Me.InfoMeldungList.Columns(9).Value = False
            Me.InfoMeldungList.Refresh()
            Me.TabControl2.Select()
            Me.InfoMeldungList.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.rbZustaendigKube_Click Method

Private Sub rbZustaendigKube_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbZustaendigKube.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbZustaendigKube_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbZustaendigKube.CheckedChanged
        Me.mcbzust.Enabled = False
        Me.mcbkube.Enabled = True
        If Me.rbZustaendigKube.Checked = True Then
            Me.mcbkube.DataSource = Nothing
            Me.mcbkube.Items.Clear()
            Me.mcbkube.Fill_Data(Generic_Select(8), False)
            If Me.mcbkube.Items.Count = 0 Then
                Me.mcbkube.Text = ""
                Me.rbZustaendigKube.Checked = False
                Me.RBZustaendigZustaendiger.Checked = True
                MyMsg.show_standardmessage(24, MsgBoxStyle.Information)
                RBZustaendigZustaendiger_CheckedChanged(sender, e)
                Exit Sub
            End If
        End If
        Try
            Me.mcbkube.Focus()
            Me.mcbkube.SelectedIndex = 0
            Try
                Me.teamzustaendig = Me.mcbkube.SelectedValue
                Me.refresh_team()
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.settooltip Method

Private Sub settooltip()

Source code

[Visual Basic]
    Private Sub settooltip()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbmoeglicheStati, Globals.MyTxt.gettext(22000))
        ttip.SetToolTip(Me.btnPartnerInhaber, Globals.MyTxt.gettext(22001))
        ttip.SetToolTip(Me.Button1, Globals.MyTxt.gettext(22002))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC.txtZustelladresse_Leave Method

Private Sub txtZustelladresse_Leave( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtZustelladresse_Leave(ByVal sender As System.Object, ByVal e As System.EventArgs)
        'If check_banklagernd() = True Then
        '    If MyMsg.Show_MessageYesNo(72) = MsgBoxResult.No Then
        '        Me.txtZustelladresse.Text = ""
        '        Me.txtAnredeZusteller.Text = ""
        '    End If
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungBC Fields

frmDokumentbearbeitungBC overview

Fields

field BtnHelp
field Button1
field Button2
field Button3
field Button4
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentID
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field ErsetzenMoeglich
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label13
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl2
field TabPage3
field TabPage4
field TabPage5
field Use_BL_Status
field ZuordnungList
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field changeteam
field components
field cvertraulich
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_edex_folgestatus
field m_notfall
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field progress
field rbZustaendigKube
field save_stv
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field vibeachten
field w
field zu_retournieren

See Also

frmDokumentbearbeitungBC Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


CurrentProfil Variable

Dim CurrentProfil As Long

Source code

[Visual Basic]
    Dim CurrentProfil As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DokWertList Variable

Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DokumentFunktionen Variable

Dim DokumentFunktionen As DataTable

Source code

[Visual Basic]
    Dim DokumentFunktionen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DokumentID Variable

Dim DokumentID As String

Source code

[Visual Basic]
    Dim DokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


DokumentInfoMeldungen Variable

Dim DokumentInfoMeldungen As DataTable

Source code

[Visual Basic]
    Dim DokumentInfoMeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Dokumentersetzen Variable

Dim Dokumentersetzen As DataTable

Source code

[Visual Basic]
    Dim Dokumentersetzen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Dokumentzuorndungen Variable

Dim Dokumentzuorndungen As DataTable

Source code

[Visual Basic]
    Dim Dokumentzuorndungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ErsetzenMoeglich Variable

Dim ErsetzenMoeglich As Boolean = False

Source code

[Visual Basic]
    Dim ErsetzenMoeglich As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox11 Variable

Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox13 Variable

Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


LabelVIBeachten Variable

Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuDokZuordnungAdd Variable

Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuDokzuordnungDelete Variable

Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuShowDoc Variable

Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


MnuValueSelect Variable

Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


NewDokumentID Variable

Dim NewDokumentID As String

Source code

[Visual Basic]
    Dim NewDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Notizen Variable

Dim Notizen As DataTable

Source code

[Visual Basic]
    Dim Notizen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


PicVIBeachten Variable

Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


RBZustaendigZustaendiger Variable

Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


TabPage5 Variable

Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


Use_BL_Status Variable

Dim Use_BL_Status As Boolean = False

Source code

[Visual Basic]
    Dim Use_BL_Status As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ZuordnungList Variable

Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


btntxtBemerkung Variable

Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cGesperrt Variable

Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbKube Variable

Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbPostzustellung Variable

Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbmoeglicheStati Variable

Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbsave Variable

Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cbzust Variable

Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cdokumentwerteanzeigen Variable

Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


changeteam Variable

Dim changeteam As Integer = 0

Source code

[Visual Basic]
    Dim changeteam As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


cvertraulich Variable

Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


firststatus Variable

Dim firststatus As Integer

Source code

[Visual Basic]
    Dim firststatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


funktionsliste Variable

Dim funktionsliste As String

Source code

[Visual Basic]
    Dim funktionsliste As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


ii Variable

Dim ii As Integer

Source code

[Visual Basic]
    Dim ii As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_Partnernr Variable

Dim m_Partnernr As String

Source code

[Visual Basic]
    Dim m_Partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_createdocument Variable

Dim m_createdocument As Boolean

Source code

[Visual Basic]
    Dim m_createdocument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_dokument_ist_abgeschlossen Variable

Dim m_dokument_ist_abgeschlossen As Boolean

Source code

[Visual Basic]
    Dim m_dokument_ist_abgeschlossen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_dokumentinfobearbeiten Variable

Dim m_dokumentinfobearbeiten As Boolean

Source code

[Visual Basic]
    Dim m_dokumentinfobearbeiten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_edex_folgestatus Variable

Dim m_edex_folgestatus As Integer = 0

Source code

[Visual Basic]
    Dim m_edex_folgestatus As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_notfall Variable

Dim m_notfall As Boolean = False

Source code

[Visual Basic]
    Dim m_notfall As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbkube Variable

Dim WithEvents mcbkube As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbkube As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbpostzustellung Variable

Dim WithEvents mcbpostzustellung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbpostzustellung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbstatus Variable

Dim WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbteam Variable

Dim WithEvents mcbteam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbteam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mcbzust Variable

Dim WithEvents mcbzust As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbzust As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mnuInfoEmpfaengerAdd Variable

Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


mnuInfoEmpfaengerDelete Variable

Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


moeglichestati Variable

Dim moeglichestati As DataTable

Source code

[Visual Basic]
    Dim moeglichestati As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


pnlBerechtigungen Variable

Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


progress Variable

Dim progress As New frmProgress()

Source code

[Visual Basic]
    Dim progress As New frmProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


rbZustaendigKube Variable

Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


save_stv Variable

Dim save_stv As Integer

Source code

[Visual Basic]
    Dim save_stv As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


savestatus Variable

Dim savestatus As Integer

Source code

[Visual Basic]
    Dim savestatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


saveverantwortlicher Variable

Dim saveverantwortlicher As Integer

Source code

[Visual Basic]
    Dim saveverantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


selectedstatus Variable

Dim selectedstatus As Integer

Source code

[Visual Basic]
    Dim selectedstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


teamzustaendig Variable

Dim teamzustaendig As Integer

Source code

[Visual Basic]
    Dim teamzustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtAnredeZusteller Variable

Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtBemerkungVerantwortlicher Variable

Dim txtBemerkungVerantwortlicher As String

Source code

[Visual Basic]
    Dim txtBemerkungVerantwortlicher As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtPartnerInhaberNr Variable

Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtZustelladresse Variable

Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


txtstatus Variable

Friend WithEvents txtstatus As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtstatus As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


vibeachten Variable

Dim vibeachten As Boolean

Source code

[Visual Basic]
    Dim vibeachten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


w Variable

Dim w As New WordLib()

Source code

[Visual Basic]
    Dim w As New WordLib()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


zu_retournieren Variable

Dim zu_retournieren As Boolean

Source code

[Visual Basic]
    Dim zu_retournieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungBC


frmDokumentbearbeitungED Class

For a list of all members of this type, see frmDokumentbearbeitungED Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentbearbeitungED

Public Class frmDokumentbearbeitungED
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentbearbeitungED Members


frmDokumentbearbeitungED Members

frmDokumentbearbeitungED overview

Constructors

constructor frmDokumentbearbeitungED Constructor

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property EditDokumentid
property Partnernr
property Profile
property Profilnr

Methods

method Banklagernd_Check
method Button1_Click
method Button2_Click
method Button2_Click_1
method Button3_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method Update_Bclabel
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

Fields

field Button1
field Button2
field Button3
field Button4
field C1DateEdit1
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentID
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field ErsetzenMoeglich
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl2
field TabPage3
field TextBox1
field VIBeachten
field ZuordnungList
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field check_existing_address
field components
field cvertraulich
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field progress
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field w
field zu_retournieren

See Also

frmDokumentbearbeitungED Class


frmDokumentbearbeitungED Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED Properties

frmDokumentbearbeitungED overview

Properties

property BarcodeID
property CreateDocument
property Dokument_Ist_Abgeschlossen
property Dokumentinfobearbeiten
property Dokumenttypnr
property EditDokumentid
property Partnernr
property Profile
property Profilnr

See Also

frmDokumentbearbeitungED Class


frmDokumentbearbeitungED.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.CreateDocument Property

Property CreateDocument() As Boolean

Source code

[Visual Basic]
    Property CreateDocument() As Boolean
        Get
            Return m_createdocument
        End Get
        Set(ByVal Value As Boolean)
            m_createdocument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokument_Ist_Abgeschlossen Property

Property Dokument_Ist_Abgeschlossen() As Boolean

Source code

[Visual Basic]
    Property Dokument_Ist_Abgeschlossen() As Boolean
        Get
            Return m_dokument_ist_abgeschlossen
        End Get
        Set(ByVal Value As Boolean)
            m_dokument_ist_abgeschlossen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentinfobearbeiten Property

Property Dokumentinfobearbeiten() As Boolean

Source code

[Visual Basic]
    Property Dokumentinfobearbeiten() As Boolean
        Get
            Return m_dokumentinfobearbeiten
        End Get
        Set(ByVal Value As Boolean)
            m_dokumentinfobearbeiten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.EditDokumentid Property

Property EditDokumentid() As String

Source code

[Visual Basic]
    Property EditDokumentid() As String
        Get
            Return DokumentID
        End Get
        Set(ByVal Value As String)
            DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_Partnernr
        End Get
        Set(ByVal Value As String)
            m_Partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED Methods

frmDokumentbearbeitungED overview

Methods

method Banklagernd_Check
method Button1_Click
method Button2_Click
method Button2_Click_1
method Button3_Click
method Button3_Click_1
method Button4_Click
method COLD_Index_Sichern
method Check_Dokumentersetzen
method Check_Dokumentfunktionen
method Cold_Index_Bearbeiten
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu3_Popup
method ContextMenu4_Popup
method ContextMenu7_Popup
method DateTimePicker1_ValueChanged
method DateTimePicker2_KeyDown
method Datumselect_ValueChanged
method Dispose
method DokWertList_AfterColEdit
method DokWertList_BeforeColUpdate
method DokWertList_Click
method Dokument_Bearbeiten
method Dokumentersetzen_Laden
method Dokumentersetzen_Sichern
method Dokumentfunktionen_Aktivieren
method Dokumentfunktionen_sichern
method Dokumentinfomeldungen_Sichern
method Dokumentinfomeldungen_laden
method DokumentwertListe_laden
method Dokumentwerte
method Dokumentwerte_Sichern
method Dokumentzuordnungen_Laden
method Dokumentzuordnungen_Sichern
method DokwertList_RowColChange
method FillMcbVerantwortlich
method Formular_Laden_Create_Document
method Formular_laden_Edit_Document
method Generic_Select
method InfoMeldungList_FetchRowStyle
method InitializeComponent
method Load_Defaults
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MnuDeleteNotiz_Click
method MnuDokZuordnungAdd_Click
method MnuDokzuordnungDelete_Click
method MnuEditNotiz_Click
method MnuNeueNotiz_Click
method MnuShowDoc_Click
method MnuValueSelect_Click
method Notizen_Laden
method Notizen_Sichern
method Notizlist_DoubleClick
method Notizlist_MouseDown
method Notizlist_MouseUp
method RBZustaendigZustaendiger_CheckedChanged
method Set_Feldwert
method Status_History
method Update_Bclabel
method bereiche_sperren
method btnCancel_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method btntxtBemerkung_Click
method cbKube_SelectedIndexChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedValueChanged
method cbzust_SelectedIndexChanged
method check_banklagernd
method cvertraulich_CheckedChanged
method fill_mcbmitarbeiter
method frmDokumentbearbeitung_Load
method get_current_Status
method get_partnerzusteller
method load_Mitarbeiter
method mcbkube_Leave
method mcbzust_Leave
method mnuInfoEmpfaengerAdd_Click
method mnuInfoEmpfaengerDelete_Click
method rbZustaendigKube_Click
method refresh_team
method settooltip
method txtZustelladresse_Leave

See Also

frmDokumentbearbeitungED Class


frmDokumentbearbeitungED.Banklagernd_Check Method

Private Sub Banklagernd_Check()

Source code

[Visual Basic]
    Private Sub Banklagernd_Check()
        Dim i As Integer
        i = check_banklagernd()
        If i = 0 Then Exit Sub
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        dt.iDokumenttypnr = New SqlInt32(CType(Dokumenttypnr, Int32))
        dt.SelectOne()
        If dt.bKundenDokument.Value = False Then
            dt.Dispose()
            Exit Sub
        End If
        dt.Dispose()
        Try
            Select Case i
                Case 1
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, True, True)
                    Dim p As New edokadb.clsPartner()
                    p.cpMainConnectionProvider = conn
                    p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
                    p.SelectOne()
                    If p.bSaldiert.Value = True Then
                        f.rbeinzelbldossier.Checked = False
                        f.rbeinzelbldossier.Enabled = False
                        f.RBEinzelPersoenlich.Checked = True
                    Else
                        f.rbeinzelbldossier.Checked = True
                        f.rbeinzelbldossier.Enabled = True
                    End If
                    f.ShowDialog()
                    If f.rbeinzelbldossier.Checked Then
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Me.check_existing_address = False
                    End If
                    If f.rbeinzelblversand.Checked Then
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = True
                        Me.Button2.Enabled = True
                        Me.check_existing_address = True
                    End If
                    If f.RBEinzelPersoenlich.Checked = True Then
                        Me.txtZustelladresse.Text = DivFnkt.get_parnter_namevorname(Me.Partnernr) + vbCrLf + "persönlich ausgehändigt"
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Me.check_existing_address = False
                    End If
                Case 2
                    Dim f As New frmBanklagerndverarbeitung(Me.Partnernr, True, True)
                    Dim p As New edokadb.clsPartner()
                    f.rbeinzelblversand.Enabled = False
                    p.cpMainConnectionProvider = conn
                    p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
                    p.SelectOne()
                    If p.bSaldiert.Value = True Then
                        f.rbeinzelbldossier.Checked = False
                        f.rbeinzelbldossier.Enabled = False
                        f.RBEinzelPersoenlich.Checked = True
                    Else
                        f.rbeinzelbldossier.Checked = True
                        f.rbeinzelbldossier.Enabled = True
                    End If
                    f.ShowDialog()
                    If f.rbeinzelbldossier.Checked Then
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Me.check_existing_address = False
                    End If
                    If f.rbeinzelblversand.Checked Then
                        Me.txtZustelladresse.Text = ""
                        Me.txtZustelladresse.Enabled = True
                        Me.Button2.Enabled = True
                        Me.check_existing_address = True
                    End If
                    If f.RBEinzelPersoenlich.Checked = True Then
                        Me.txtZustelladresse.Text = DivFnkt.get_parnter_namevorname(Me.Partnernr) + vbCrLf + "persönlich ausgehändigt"
                        Me.txtZustelladresse.Enabled = False
                        Me.Button2.Enabled = False
                        Me.check_existing_address = False
                    End If

            End Select
            If i > 0 Then
            End If
        Catch
        Finally
            Try
                Globals.conn.CloseConnection(True)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            If Me.txtPartnerInhaberNr.Text > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.txtPartnerInhaberNr.Text
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()

        If f.PartnerNr <> 0 Then
            Me.txtZustelladresse.Text = f.zustelladresse
            Me.txtAnredeZusteller.Text = f.Anrede
            Me.txtZustelladresse.Focus()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button2_Click_1 Method

Private Sub Button2_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()

        If f.PartnerNr <> 0 Then
            Me.txtZustelladresse.Text = f.zustelladresse
            Me.txtAnredeZusteller.Text = f.Anrede
            Me.txtZustelladresse.Focus()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dokumentzuordnungen_Sichern()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        MenuItem2_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.DokWertList.Columns("feldwert").Value = f.PartnerNr
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.COLD_Index_Sichern Method

Public Function COLD_Index_Sichern( _
   ByVal indextyp As Integer _
) As DataTable

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Function COLD_Index_Sichern(ByVal indextyp As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Check_Dokumentersetzen Method

Private Function Check_Dokumentersetzen( _
   ByVal dokumenttypnr As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumenttypnr
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Private Function Check_Dokumentersetzen(ByVal dokumenttypnr As Integer, ByVal dokumentid As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentbearbeitung_chcek_dokumentersetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@errormessage", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            s = scmCmdToExecute.Parameters.Item("@errormessage").Value
            If s <> "" Then
                MyMsg.show_standardmessage(Val(s), MsgBoxStyle.Critical)
                Return False
            End If
            Return True
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Check_Dokumentfunktionen Method

Private Function Check_Dokumentfunktionen() As Boolean

Source code

[Visual Basic]
    Private Function Check_Dokumentfunktionen() As Boolean
        Dim i As Integer
        Dim zz As Integer
        Dim bearbeiten As Boolean
        Dim abschliessen As Boolean
        bearbeiten = False
        abschliessen = False
        Check_Dokumentfunktionen = True
        If Me.DokumentFunktionenList.Visible = False Then Exit Function
        zz = 0
        For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
            If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                If Me.DokumentFunktionen.Rows(i).Item("bearbeiten") = True Then bearbeiten = True
                If Me.DokumentFunktionen.Rows(i).Item("abschliessen") = True Then abschliessen = True
                zz = zz + 1
            End If
        Next

        If zz = 0 Then
            Check_Dokumentfunktionen = True
            Exit Function
        End If
        If bearbeiten = False Or abschliessen = False Then
            If bearbeiten = False Then
                MyMsg.show_standardmessage(34, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
            If abschliessen = False Then
                MyMsg.show_standardmessage(35, MsgBoxStyle.Critical)
                Check_Dokumentfunktionen = False
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Cold_Index_Bearbeiten Method

Public Sub Cold_Index_Bearbeiten( _
   ByVal indextyp As Integer _
)

Parameters

indextyp
Required.

Source code

[Visual Basic]
    Public Sub Cold_Index_Bearbeiten(ByVal indextyp As Integer)
        Dim xdata As DataTable
        Dim cdata As DataTable
        cdata = COLD_Index_Sichern(indextyp)
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("cold_indexfeld") > 0 Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index_Update"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute.Connection = conn.scoDBConnection
                    scmCmdToExecute.Connection.Open()
                    Try
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@coldfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("cold_indexfeld")))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                        scmCmdToExecute.ExecuteNonQuery()
                    Catch ex As Exception
                        ' // some error occured. Bubble it to caller and encapsulate Exception object
                        Throw New Exception("Dokument_Cold_Index_Update::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute.Connection.Close()
                        scmCmdToExecute.Dispose()
                    End Try
                End If
            End If
        Next
        cdata.Dispose()
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.Notizen.Rows.Count = 0 Then
            Me.ContextMenu1.MenuItems(1).Enabled = False
            Me.ContextMenu1.MenuItems(2).Enabled = False
        Else
            Me.ContextMenu1.MenuItems(1).Enabled = True
            Me.ContextMenu1.MenuItems(2).Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        If Me.DokWertList.Columns("datenherkunft").Value = "" Then
            Me.MnuValueSelect.Enabled = False
        Else
            Me.MnuValueSelect.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        If Me.ZuordnungList.Splits(0).Rows.Count = 0 Then
            Me.MnuDokzuordnungDelete.Enabled = False
            Me.MnuShowDoc.Enabled = False
        Else
            Me.MnuDokzuordnungDelete.Enabled = True
            Me.MnuShowDoc.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.ContextMenu4_Popup Method

Private Sub ContextMenu4_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu4.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu4_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu4.Popup
        Try
            If Me.InfoMeldungList.Columns("typ").Value = 1 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
            If Me.InfoMeldungList.Splits(0).Rows.Count = 0 Then
                Me.mnuInfoEmpfaengerDelete.Enabled = False
            Else
                Me.mnuInfoEmpfaengerDelete.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        If Me.ErsetzenMoeglich = False Then
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
            Exit Sub
        End If
        Try
            If Me.ColdList.Splits(0).Rows.Count = 0 Then
                Me.MenuItem6.Enabled = False
            Else
                Me.MenuItem6.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        If Me.On_Load Then Exit Sub
        Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DateTimePicker2_KeyDown Method

Private Sub DateTimePicker2_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles DateTimePicker2.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles DateTimePicker2.KeyDown
        If e.KeyCode = Keys.Delete Then
            Me.DateTimePicker2.ResetText()
            Me.DateTimePicker2.Value = System.DBNull.Value
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Datumselect_ValueChanged Method

Private Sub Datumselect_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Datumselect_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Set_Feldwert()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DokWertList_AfterColEdit Method

Private Sub DokWertList_AfterColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DokWertList.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_AfterColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DokWertList.AfterColEdit
        Me.DokWertList.Update()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DokWertList_BeforeColUpdate Method

Private Sub DokWertList_BeforeColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles DokWertList.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_BeforeColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles DokWertList.BeforeColUpdate
        If InStr(Me.DokWertList.Columns("Datenherkunft").Text, "VV") > 0 Then
            If Len(Me.DokWertList.Columns("feldwert").Text) > 16 Then
                MyMsg.show_standardmessage(235, MsgBoxStyle.Critical)
                e.Cancel = True
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DokWertList_Click Method

Private Sub DokWertList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokWertList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokWertList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokWertList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokument_Bearbeiten Method

Private Sub Dokument_Bearbeiten( _
   ByVal neu As Boolean _
)

Parameters

neu
Required.

Source code

[Visual Basic]
    Private Sub Dokument_Bearbeiten(ByVal neu As Boolean)
        Try
            Globals.PerfMon.insert_entry("Start Dokumenterstellung/Bearbeitung")
            If Me.Dokument_Ist_Abgeschlossen Then
                Notizen_Sichern()
                Dokumentzuordnungen_Sichern()
                Dokumentinfomeldungen_Sichern()
                DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                Me.Close()
                Exit Sub
            End If
            w.txtPartner = Me.txtPartnerInhaber.Text
            w.txtDokumenttyp = Me.txtBezeichnung.Text
            w.ProgressBar.Info.Text = "Dokument erstellen"
            w.ProgressBar.Bar1.Value = 10
            w.txtBemerkung_Verantwortlicher = Me.txtBemerkungVerantwortlicher

            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim doc As New edokadb.clsDokument()
            Dim doctyp As New edokadb.clsDokumenttyp()
            Dim docvor As New edokadb.clsOffice_vorlage()

            'Dokumenttyp laden
            doctyp.cpMainConnectionProvider = conn
            doctyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
            doctyp.SelectOne()

            'OfficeVorlage laden
            docvor.cpMainConnectionProvider = conn
            docvor.iOffice_vorlagenr = New SqlInt32(CType(doctyp.iOffice_vorlagenr.Value, Int32))
            docvor.SelectOne()

            'Dokument erstellen
            doc.cpMainConnectionProvider = conn
            If Me.CreateDocument Then
                doc.sDokumentid = New SqlString(CType(NewDokumentID, String))
            Else
                doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
                doc.SelectOne()
            End If
            doc.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
            doc.iNrpar00 = New SqlInt32(CType(Me.txtPartnerInhaberNr.Text, Int32))
            doc.bAktiv = New SqlBoolean(True)
            doc.bAmsdokument = New SqlBoolean(CType(False, Boolean))
            doc.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
            doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.daArchivierungsdatum = New SqlDateTime(CType(Me.DateTimePicker3.Value, DateTime))

            If Me.DateTimePicker2.Value Is System.DBNull.Value Then
                doc.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
            Else
                doc.daTermin = New SqlDateTime(CType(Me.DateTimePicker2.Value, DateTime))
            End If

            doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
            'Hutter - anpassungen
            If Me.mcbstatus.Text = "Bereit für Ausgangsarchivierung" Then
                doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
            End If
            doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.bGesperrt = New SqlBoolean(CType(Me.cGesperrt.Checked, Boolean))
            If Me.cGesperrt.Checked Then
                doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
            End If
            doc.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
            doc.bZu_retournieren = New SqlBoolean(CType(doctyp.bZu_retournieren.Value, Boolean))
            doc.iColdstatus = New SqlInt32(CType(0, Int32))
            doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
            If neu = True Then
                doc.iErsteller = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iErstellerteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daErstelltam = New SqlDateTime(CType(Now, DateTime))
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutiererteam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
                If Globals.bckdokument Then
                    doc.iBck = New SqlInt32(CType(1, Int32))
                Else
                    doc.iBck = New SqlInt32(CType(1, Int32))
                End If
                doc.iAufbewahrung_elektronisch = New SqlInt32(CType(doctyp.iAufbewahrungsfrist_elektronisch.Value, Int32))
                doc.iAufbewahrung_phaysisch = New SqlInt32(CType(doctyp.iAufbewahrungsfrist_physisch.Value, Int32))
                doc.iBearbeitung_nach_abschluss = New SqlInt32(CType(doctyp.iTage_mutation.Value, Int32))
                doc.iBearbeitungszeit_in_minuten = New SqlInt32(CType(doctyp.iDbearbeitungszeit.Value, Int32))
                doc.iMonierung_in_tagen = New SqlInt32(CType(doctyp.iAnzahl_tage.Value, Int32))
            Else
                doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.iMutierertieam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))
            End If

            doc.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
            doc.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
            doc.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
            doc.bVertraulich = New SqlBoolean(CType(Me.cvertraulich.Checked, Boolean))
            doc.sZustelladresse = New SqlString(CType(Me.txtZustelladresse.Text, String))
            doc.sAnredezustelladresse = New SqlString(CType(Me.txtAnredeZusteller.Text, String))

            If Me.rbZustaendigKube.Checked Then
                doc.iZustaendiger = New SqlInt32(CType(Me.mcbkube.SelectedValue, Int32))
            Else
                doc.iZustaendiger = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
            End If
            doc.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
            doc.bZustaendig_kube = New SqlBoolean(CType(Me.rbZustaendigKube.Checked, Boolean))
            If Me.cGesperrt.Checked Then
                doc.iGesperrt_durch = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                doc.daGesperrtam = New SqlDateTime(CType(Now, DateTime))
            Else
                doc.iGesperrt_durch = New SqlInt32(CType(0, Int32))
            End If
            doc.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
            doc.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            doc.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
            doc.sColddokumentid = New SqlString(CType("", String))
            doc.iAnzeigeStatus = New SqlInt32(CType(0, Int32))

            doc.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))

            If Not Me.CreateDocument Then
                doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
            End If

            doc.daErstellungsdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
            '        doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))

            If docvor.iAnwendungnr.Value = 1 Then
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".doc", String))
            Else
                doc.sDokumentname = New SqlString(CType(docvor.sPrefix_dokumentname.Value + doc.sDokumentid.Value + ".xls", String))
            End If

            If Me.CreateDocument Then doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
                Dim tx As DataTable
                tx = Generic_Select(13)
                If tx.Rows(0).Item(0) = 1 Then
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
                Else
                    doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
                End If
                tx.Dispose()
            End If

            Dim s As String

            s = DivFnkt.Get_Filename(doc.sDokumentname.Value, Me.txtPartnerInhaberNr.Text)
            conn.OpenConnection()
            If Me.CreateDocument Then
                Dim t As DataTable
                t = Generic_Select(14)
                doc.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
                doc.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
                doc.Insert()
                t.Dispose()
                Dim statush As New Statushandling()
                statush.Status_Erstellen(doc.sDokumentid.Value, False)
                statush.Dispose()
                doc.iStatusnr = New SqlInt32(CType(get_current_Status(doc.sDokumentid.Value), Int32))
                doc.Update()
            Else
                doc.Update()
            End If
            conn.CloseConnection(True)

            DokumentID = doc.sDokumentid.Value
            If Globals.bckdokument = True Then
                Cold_Index_Bearbeiten(2)
            Else
                Cold_Index_Bearbeiten(1)
                If Me.zu_retournieren Then
                    Cold_Index_Bearbeiten(2)
                End If
            End If
            Globals.PerfMon.insert_entry("'-- Begin Dokumentdaten sichern")
            DokumentID = doc.sDokumentid.Value
            Dokumentwerte_Sichern()
            Notizen_Sichern()
            Dokumentzuordnungen_Sichern()
            Dokumentersetzen_Sichern()
            Dokumentinfomeldungen_Sichern()
            Dokumentfunktionen_sichern()
            Status_History(doc.iStatusnr.Value)
            Globals.PerfMon.insert_entry("'-- Ende Dokumentdaten sichern")
            If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                w.ProgressBar.Show()
                w.ProgressBar.Info.Text = "Dokumentwerte zusammenstellen"
                w.ProgressBar.Bar1.Value = 10
            End If
            Globals.PerfMon.insert_entry("'-- Begin Dokumentwerte zusammenstellen")
            Dim xdata As DataTable
            xdata = Dokumentwerte(doc.sDokumentid.Value)
            Globals.PerfMon.insert_entry("'--Ende Dokumentwerte zusammenstellen")
            DokumentID = doc.sDokumentid.Value

            'Dokument erstellen bzw. öffnen
            w.DokumentID = doc.sDokumentid.Value
            w.DokumentName = doc.sDokumentname.Value
            If Me.CreateDocument Then
                w.CreateDoc = True
                If Me.BarcodeID = "" Then
                    If w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s) = False Then
                        w.ProgressBar.Visible = False
                        w.Restore(1)
                        Me.Cursor = Cursors.Default
                        Me.btnWeiter.Enabled = True
                        DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                        Exit Sub
                    End If
                End If

                '                If Me.BarcodeID = "" Then w.Create_Dokument_Before_Fill(doc.iDokumenttypnr.Value, xdata, s)
                '            If docvor.bIdv_nativ.Value = True Then
                '       End If
                '      xdata.Dispose()
                '     doc.Dispose()
                '    Exit Sub
            Else
                If Me.BarcodeID = "" And Me.Dokumentinfobearbeiten = False Then
                    w.CreateDoc = False
                    Dim docrestore As New DocMgmt()
                    docrestore.Get_From_DB(DokumentID, s)
                    w.Open_Document(s, xdata, doc.iDokumenttypnr.Value)
                End If
            End If
            Me.Hide()

            If Globals.Dokumentcoldindex_Changed Then
                w.dokumentidalt = Globals.Dokumentidalt
                w.save_dokumentcoldindex = Globals.general_ds.Tables(Globals.general_ds.Tables.Count - 1).Copy
                w.Dokumentcoldindex_Changed = Globals.Dokumentcoldindex_Changed
                w.dokumentid_changed = Globals.dokumentid_changed
                w.dokumentcoldindex_status = Globals.dokumentcoldindex_status
                w.Ersetzte_Dokumente_Reaktivieren = Globals.Ersetzte_Dokumente_Reaktivieren
            End If

            'Anzeigen der Dokumentwerte, sofern die Checkbox markiert war
            If Me.cdokumentwerteanzeigen.Checked Then
                Globals.PerfMon.insert_entry("'-- Begin Dokumentwerte anzeigen")
                Dim f As New frmDokumentwerte()
                f.WordData = xdata
                f.isOk = True
                Me.Cursor = System.Windows.Forms.Cursors.Default
                f.ShowDialog()
                Globals.PerfMon.insert_entry("'-- Ende Dokumentwerte anzeigen")
                If f.isOk = 0 Then
                    f.Dispose()
                    w.CloseDoc()
                    w.ProgressBar.Close()
                    If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                    DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                Else
                    If f.isOk = 1 Then
                        f.Dispose()
                        w.Dokument_Vervollstaendigen(xdata)
                        Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokumentbearbeitung")
                        If Me.CreateDocument Then
                            DivFnkt.Status_Dokumentbearbeitung(1, Me.DokumentID, True, w.DokumentName)
                        End If
                        Words.Add(w, w.DokumentName)
                    Else
                        If f.isOk = 2 Then
                            f.Dispose()
                            If Me.CreateDocument = True Then w.Restore(1) Else w.Restore(2)
                            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
                            Me.CreateDocument = False
                            Me.btnWeiter.Enabled = True
                            Me.Show()
                        End If
                    End If
                End If
            Else
                w.Dokument_Vervollstaendigen(xdata)
                Globals.PerfMon.insert_entry(Me.DokumentID + " Start Dokumentbearbeitung")
            End If
            xdata.Dispose()
            doc.Dispose()
            Globals.PerfMon.insert_entry(Me.DokumentID + " Ende Dokumenterstellung")
            Try
                w.ProgressBar.Close()
                w.ProgressBar.Dispose()
            Catch
            End Try
        Catch ex As Exception
            w.Close_And_Destroy()
            Dim s As String
            Globals.In_Bearbeitung = False
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, True, w.DokumentName)
            s = Globals.MyTxt.gettext(98)
            s = s + vbCrLf + vbCrLf + ex.Message
            MsgBox(s, MsgBoxStyle.Critical)
            PerfMon.force_insert_entry("Dok (E): " + ex.Message + "-" + " " + Me.Dokumenttypnr.ToString + " " + Me.txtBezeichnung.Text + " " + Me.txtPartnerInhaber.Text + ": ")
            PerfMon.force_insert_entry("Dok (E): Wordlib Errormessage: " + w.Errormessage)
            w.ProgressBar.Visible = False
            Me.Cursor = Cursors.Default
            If Me.CreateDocument Then w.Restore(1) Else w.Restore(2)
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            Me.Cursor = Cursors.Default
            Me.btnWeiter.Enabled = True
            Me.Visible = True
            Try
                conn.CloseConnection(True)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentersetzen_Laden Method

Private Function Dokumentersetzen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentersetzen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentersetzen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentersetzen_Sichern Method

Public Sub Dokumentersetzen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentersetzen_Sichern()
        For i = 0 To Me.Dokumentersetzen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentersetzen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentersetzennr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentersetzennr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hauptdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("dokumentid")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@coldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentersetzen.Rows(i).Item("coldstatus")))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Ersetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentfunktionen_Aktivieren Method

Private Sub Dokumentfunktionen_Aktivieren()

Source code

[Visual Basic]
    Private Sub Dokumentfunktionen_Aktivieren()
        Dim t As DataTable
        t = Generic_Select(5)
        If t.Rows.Count > 0 Then
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlDataAdapter3.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            '            Me.Funktionsliste.DataSource = Me.DataSet3
            '           Me.Funktionsliste.DataMember = Me.DataSet3.Tables(0).TableName

            t.Clear()
            Me.DokumentFunktionen = Generic_Select(6)
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.DataSet4.Tables.Add(Me.DokumentFunktionen)
            Me.DokumentFunktionenList.DataSource = Me.DataSet4
            Me.DokumentFunktionenList.DataMember = Me.DataSet4.Tables(0).TableName
            Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
            Me.DokumentFunktionenList.FilterBar = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Me.DokumentFunktionen, "berechtigungseinschraenkung")

        Else
            Me.pnlBerechtigungen.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentfunktionen_sichern Method

Public Sub Dokumentfunktionen_sichern()

Source code

[Visual Basic]
    Public Sub Dokumentfunktionen_sichern()
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentfunktionen_Sichern"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentfunktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("dokumentfunktiongruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@funktiongruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzeigen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("anzeigen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("bearbeiten")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("loeschen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@abschliessen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("abschliessen")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentFunktionen.Rows(i).Item("aktiv")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentinfomeldungen_Sichern Method

Public Sub Dokumentinfomeldungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentinfomeldungen_Sichern()
        For i = 0 To Me.DokumentInfoMeldungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("dokumentinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentInfoMeldungen.Rows(i).Item("typ")))

                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DokumentwertListe_laden Method

Private Function DokumentwertListe_laden() As DataTable

Source code

[Visual Basic]
    Private Function DokumentwertListe_laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentwerte Method

Private Function Dokumentwerte( _
   ByVal dokumentid As String _
) As DataTable

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function Dokumentwerte(ByVal dokumentid As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentwerte_Sichern Method

Public Sub Dokumentwerte_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentwerte_Sichern()
        Dim xdata As DataTable
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
            If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Connection.Open()
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
                    scmCmdToExecute.ExecuteNonQuery()
                Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Connection.Close()
                    scmCmdToExecute.Dispose()
                End Try
            End If
        Next
        xdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Dokumentzuordnungen_Sichern Method

Public Sub Dokumentzuordnungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumentzuordnungen_Sichern()
        For i = 0 To Me.Dokumentzuorndungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumentzuordnungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentzuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("NrEintrag")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid2", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("DOKUMENTID2")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@zuordnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("zuordnungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentzuorndungen.Rows(i).Item("AKTIV")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.DokwertList_RowColChange Method

Private Sub DokwertList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokWertList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokwertList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokWertList.RowColChange
        Try
            Me.DokWertList.Columns("feldwert").EditMask = Me.DokWertList.Columns("eingabeformat").Value
            Me.DokWertList.Columns("feldwert").EditMaskUpdate = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()
        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String
        s = ""
        Try
            For I = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(I).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(I).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            If Me.cvertraulich.Checked = True Then
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 1, s)
            Else
                dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, Me.Partnernr, "", 3, 0, 0, 0, s)
            End If
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Formular_Laden_Create_Document Method

Private Sub Formular_Laden_Create_Document()

Source code

[Visual Basic]
    Private Sub Formular_Laden_Create_Document()
        NewDokumentID = DivFnkt.Generate_Key()
        Load_Defaults()
        w.save_historystatus = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Formular_laden_Edit_Document Method

Private Sub Formular_laden_Edit_Document()

Source code

[Visual Basic]
    Private Sub Formular_laden_Edit_Document()
        Dim doc As New edokadb.clsDokument()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        doc.SelectOne()
        doc.cpMainConnectionProvider = conn
        doc.sDokumentid = New SqlString(CType(Me.EditDokumentid, String))
        NewDokumentID = Me.EditDokumentid
        Me.Partnernr = doc.iNrpar00.Value
        doc.SelectOne()
        w.Save_Dokument = doc.SelectOne
        Me.Dokumenttypnr = doc.iDokumenttypnr.Value
        DokumentID = doc.sDokumentid.Value
        Load_Defaults()

        'Parnter laden
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = doc.iNrpar00
        p.SelectOne()
        Me.txtPartnerInhaber.Text = Str(p.iNRPAR00.Value) + " " + p.sBKPAR00.Value
        Me.txtPartnerInhaberNr.Text = p.iNRPAR00.Value
        Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(p.iNRPAR00.Value)
        If p.sCDVIG00.Value = "Y" Or p.iAZEPL00.Value > 1 Or p.bCDVSA00.Value = True Then Me.VIBeachten = True Else Me.VIBeachten = False
        p.Dispose()

        ii = doc.iPostzustellung.Value
        Me.mcbpostzustellung.SelectedValue = ii
        If doc.bZustaendig_kube.Value = True Then
            ii = doc.iZustaendiger.Value
            Me.mcbkube.SelectedValue = ii
        Else
            ii = doc.iZustaendiger.Value
            Me.mcbzust.SelectedValue = ii
        End If
        ii = doc.iVerantwortlich.Value
        'Prüfung, sofern akt. verantwortlicher = MA-Systemuser, dann aktueller Mitarbeiter setzen
        If ii > 9950 Then
            ii = Globals.MitarbeiterNr
        End If

        Me.mcbverantwortlich.SelectedValue = ii
        Me.saveverantwortlicher = ii
        w.save_verantwortlicher = ii

        Me.savestatus = doc.iStatusnr.Value

        ii = doc.iUnterschriftlinks.Value
        Me.mcbunterschriftlinks.SelectedValue = ii
        ii = doc.iUnterschriftrechts.Value
        Me.mcbunterschriftrechts.SelectedValue = ii
        Me.cGesperrt.Checked = doc.bGesperrt.Value = True
        Me.txtBemerkung.Text = doc.sBemerkung.Value
        Me.txtBezeichnung.Text = doc.sBezeichnung.Value
        Me.rbZustaendigKube.Checked = doc.bZustaendig_kube.Value = True
        Me.cvertraulich.Checked = doc.bVertraulich.Value = True
        Me.txtZustelladresse.Text = doc.sZustelladresse.Value
        Me.txtAnredeZusteller.Text = doc.sAnredezustelladresse.Value
        Me.RBZustaendigZustaendiger.Checked = doc.bZustaendig_kube.Value = False
        Me.teamzustaendig = doc.iZustaendiger.Value
        Me.refresh_team()
        Try
            Me.mcbteam.SelectedValue = doc.iMutierertieam.Value
        Catch
            Me.mcbteam.SelectedIndex = 0
        End Try
        Try
            Me.DateTimePicker1.Value = doc.daErstellungsdatum.Value
        Catch
            Me.DateTimePicker1.Value = Now
        End Try

        Try
            Me.DateTimePicker3.Value = doc.daArchivierungsdatum.Value
        Catch
            Me.DateTimePicker3.Value = Me.DateTimePicker1.Value
        End Try

        Try
            If doc.daTermin.Value = "01.01.1900" Then
                Me.DateTimePicker2.ResetText()
                Me.DateTimePicker2.Value = System.DBNull.Value
            Else
                Me.DateTimePicker2.Value = doc.daTermin.Value
            End If
        Catch
            Me.DateTimePicker2.Value = System.DBNull.Value
        End Try

        doc.Dispose()

        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()

        Me.ColdList.DataSource = Me.Dokumentersetzen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")

        Me.Notizen = Notizen_Laden()

        w.Save_Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        w.Save_Dokumentwerte = Generic_Select(10)
        Me.DataSet1.Clear()
        Me.DataSet1.Tables.Clear()
        Me.DataSet1.Tables.Add(DokumentwertListe_laden)
        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160
        conn.CloseConnection(True)

        w.Save_ColdIndex = Generic_Select(9)
        Me.TabControl2.Enabled = True

        Dim tmp As DataTable
        tmp = Generic_Select(12)
        w.save_historystatus = tmp.Rows(0).Item(0)
        tmp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_DokWertList"
            Case 2
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Notizen"
            Case 5
                scmCmdToExecute.CommandText = "sp_funktion_zuweisung_gestattet"
            Case 6
                scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
            Case 7
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
            Case 8
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_kube"
            Case 9
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_coldindex"
            Case 10
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_dokumentwerte_select"
            Case 11
                scmCmdToExecute.CommandText = "sp_dokument_als_bcdokument"
            Case 12
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statushistory"
            Case 13
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case 14
                scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
            Case 15
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 16
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"

            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@regel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokWertList.Columns("datenherkunft").Value))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    If Me.DokumentID = Nothing Then Me.DokumentID = ""
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    If Me.CreateDocument = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    If Globals.bckdokument = False Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    End If
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NewDokumentID))
                Case 7
                    If Me.teamzustaendig = Globals.MitarbeiterNr Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.teamzustaendig))
                    End If
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                Case 9
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 16
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))

                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs)
        Try
            If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
                e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentbearbeitungED))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet4 = New System.Data.DataSet()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.GroupBox11 = New System.Windows.Forms.GroupBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtAnredeZusteller = New System.Windows.Forms.TextBox()
        Me.txtZustelladresse = New System.Windows.Forms.TextBox()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.DokWertList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MnuValueSelect = New System.Windows.Forms.MenuItem()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RBZustaendigZustaendiger = New System.Windows.Forms.RadioButton()
        Me.rbZustaendigKube = New System.Windows.Forms.RadioButton()
        Me.cbzust = New System.Windows.Forms.ComboBox()
        Me.cbKube = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.cbPostzustellung = New System.Windows.Forms.ComboBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.mnuInfoEmpfaengerAdd = New System.Windows.Forms.MenuItem()
        Me.mnuInfoEmpfaengerDelete = New System.Windows.Forms.MenuItem()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokZuordnungAdd = New System.Windows.Forms.MenuItem()
        Me.MnuDokzuordnungDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.DateTimePicker2 = New C1.Win.C1Input.C1DateEdit()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.txtPartnerInhaberNr = New System.Windows.Forms.TextBox()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cdokumentwerteanzeigen = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.cbsave = New System.Windows.Forms.ComboBox()
        Me.cbmoeglicheStati = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtstatus = New System.Windows.Forms.Label()
        Me.btntxtBemerkung = New System.Windows.Forms.Button()
        Me.LabelVIBeachten = New System.Windows.Forms.Label()
        Me.PicVIBeachten = New System.Windows.Forms.PictureBox()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.ZuordnungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.C1DateEdit1 = New C1.Win.C1Input.C1DateEdit()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.pnlBerechtigungen = New System.Windows.Forms.GroupBox()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.cvertraulich = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.cGesperrt = New System.Windows.Forms.CheckBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.GroupBox11.SuspendLayout()
        Me.GroupBox12.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox7.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox6.SuspendLayout()
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox5.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox4.SuspendLayout()
        CType(Me.C1DateEdit1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlBerechtigungen.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox9.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(696, 472)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(104, 23)
        Me.btnWeiter.TabIndex = 13
        Me.btnWeiter.Text = "&Weiter>>"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(8, 472)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(104, 23)
        Me.btnCancel.TabIndex = 14
        Me.btnCancel.Text = "&Abbruch"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "SP_Dokumentbearbeitung_Dokumentwerte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("Feldwert", "Feldwert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[SP_Dokumentbearbeitung_Dokumentwerte]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentid", System.Data.SqlDbType.VarChar, 20))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@CreateNew", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Postzustellung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nreintrag", "nreintrag"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_postzustellung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_postzustellung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_postzustellung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_postzustellung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nreintrag", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nreintrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nreintrag", System.Data.SqlDbType.Int, 4, "nreintrag"))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_funktionsgruppe_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_funktionsgruppe_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_funktionsgruppe_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_funktionsgruppe_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage3})
        Me.TabControl2.Enabled = False
        Me.TabControl2.Location = New System.Drawing.Point(8, 104)
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(800, 360)
        Me.TabControl2.TabIndex = 11
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox11, Me.GroupBox12, Me.GroupBox10, Me.GroupBox3, Me.GroupBox1, Me.GroupBox2})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(792, 334)
        Me.TabPage3.TabIndex = 0
        Me.TabPage3.Text = "Dokumentinhalt"
        '
        'GroupBox11
        '
        Me.GroupBox11.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Label13, Me.txtAnredeZusteller, Me.txtZustelladresse})
        Me.GroupBox11.Location = New System.Drawing.Point(384, 128)
        Me.GroupBox11.Name = "GroupBox11"
        Me.GroupBox11.Size = New System.Drawing.Size(400, 192)
        Me.GroupBox11.TabIndex = 5
        Me.GroupBox11.TabStop = False
        Me.GroupBox11.Text = "Zustelladresse"
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(296, 16)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 41
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 150)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(192, 16)
        Me.Label13.TabIndex = 2
        Me.Label13.Text = "Anrede (z.B.: Herr Muster)"
        '
        'txtAnredeZusteller
        '
        Me.txtAnredeZusteller.Location = New System.Drawing.Point(8, 168)
        Me.txtAnredeZusteller.Name = "txtAnredeZusteller"
        Me.txtAnredeZusteller.Size = New System.Drawing.Size(280, 20)
        Me.txtAnredeZusteller.TabIndex = 1
        Me.txtAnredeZusteller.Text = ""
        '
        'txtZustelladresse
        '
        Me.txtZustelladresse.Location = New System.Drawing.Point(8, 16)
        Me.txtZustelladresse.Multiline = True
        Me.txtZustelladresse.Name = "txtZustelladresse"
        Me.txtZustelladresse.Size = New System.Drawing.Size(280, 128)
        Me.txtZustelladresse.TabIndex = 0
        Me.txtZustelladresse.Text = "TextBox1"
        '
        'GroupBox12
        '
        Me.GroupBox12.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox12.Location = New System.Drawing.Point(8, 272)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox12.TabIndex = 3
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Team"
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(128, 16)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(232, 21)
        Me.cbteam.TabIndex = 0
        '
        'GroupBox10
        '
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokWertList})
        Me.GroupBox10.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(400, 112)
        Me.GroupBox10.TabIndex = 4
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Dokumentspezifisch"
        '
        'DokWertList
        '
        Me.DokWertList.AllowFilter = False
        Me.DokWertList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokWertList.AllowSort = False
        Me.DokWertList.AlternatingRows = True
        Me.DokWertList.CaptionHeight = 17
        Me.DokWertList.CollapseColor = System.Drawing.Color.Black
        Me.DokWertList.ContextMenu = Me.ContextMenu2
        Me.DokWertList.DataChanged = False
        Me.DokWertList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokWertList.ExpandColor = System.Drawing.Color.Black
        Me.DokWertList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokWertList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokWertList.Location = New System.Drawing.Point(8, 16)
        Me.DokWertList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokWertList.Name = "DokWertList"
        Me.DokWertList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokWertList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokWertList.PreviewInfo.ZoomFactor = 75
        Me.DokWertList.PrintInfo.ShowOptionsDialog = False
        Me.DokWertList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokWertList.RowDivider = GridLines1
        Me.DokWertList.RowHeight = 15
        Me.DokWertList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokWertList.ScrollTips = False
        Me.DokWertList.Size = New System.Drawing.Size(384, 88)
        Me.DokWertList.TabIndex = 0
        Me.DokWertList.Text = "C1TrueDBGrid1"
        Me.DokWertList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 380, 84</ClientRect><Bo" & _
        "rderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle" & _
        " parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fil" & _
        "terBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""S" & _
        "tyle3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading" & _
        """ me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactive" & _
        "Style parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /" & _
        "><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle pare" & _
        "nt=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1True" & _
        "DBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style par" & _
        "ent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=" & _
        """Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""" & _
        "Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Norm" & _
        "al"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Nor" & _
        "mal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""" & _
        "Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ver" & _
        "tSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defaul" & _
        "tRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 380, 84</ClientArea></Blob" & _
        ">"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuValueSelect})
        '
        'MnuValueSelect
        '
        Me.MnuValueSelect.Index = 0
        Me.MnuValueSelect.Text = "&Wert auswählen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbUnterschriftrechts, Me.cbUnterschriftlinks, Me.Label8, Me.Label7})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 184)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox3.TabIndex = 2
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Unterschrift"
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(128, 43)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftrechts.TabIndex = 1
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(128, 19)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftlinks.TabIndex = 0
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 48)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Unterschrift rechts"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 24)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 13
        Me.Label7.Text = "Unterschrift links"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBZustaendigZustaendiger, Me.rbZustaendigKube, Me.cbzust, Me.cbKube})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 96)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox1.TabIndex = 1
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zuständigkeit"
        '
        'RBZustaendigZustaendiger
        '
        Me.RBZustaendigZustaendiger.Location = New System.Drawing.Point(8, 24)
        Me.RBZustaendigZustaendiger.Name = "RBZustaendigZustaendiger"
        Me.RBZustaendigZustaendiger.Size = New System.Drawing.Size(98, 24)
        Me.RBZustaendigZustaendiger.TabIndex = 0
        Me.RBZustaendigZustaendiger.Text = "Zuständiger"
        '
        'rbZustaendigKube
        '
        Me.rbZustaendigKube.Location = New System.Drawing.Point(14, 18)
        Me.rbZustaendigKube.Name = "rbZustaendigKube"
        Me.rbZustaendigKube.Size = New System.Drawing.Size(106, 24)
        Me.rbZustaendigKube.TabIndex = 8
        Me.rbZustaendigKube.Text = "Kundenberater"
        Me.rbZustaendigKube.Visible = False
        '
        'cbzust
        '
        Me.cbzust.Location = New System.Drawing.Point(128, 32)
        Me.cbzust.Name = "cbzust"
        Me.cbzust.Size = New System.Drawing.Size(232, 21)
        Me.cbzust.TabIndex = 2
        '
        'cbKube
        '
        Me.cbKube.Location = New System.Drawing.Point(128, 21)
        Me.cbKube.Name = "cbKube"
        Me.cbKube.Size = New System.Drawing.Size(232, 21)
        Me.cbKube.TabIndex = 1
        Me.cbKube.Visible = False
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker1, Me.cbPostzustellung, Me.Label5, Me.Label3})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox2.TabIndex = 0
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Allgemein"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 48)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(104, 20)
        Me.DateTimePicker1.TabIndex = 1
        '
        'cbPostzustellung
        '
        Me.cbPostzustellung.Location = New System.Drawing.Point(128, 24)
        Me.cbPostzustellung.Name = "cbPostzustellung"
        Me.cbPostzustellung.Size = New System.Drawing.Size(232, 21)
        Me.cbPostzustellung.TabIndex = 0
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 48)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Dokument-Datum"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 24)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "Post-Zustellung"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuInfoEmpfaengerAdd, Me.mnuInfoEmpfaengerDelete})
        '
        'mnuInfoEmpfaengerAdd
        '
        Me.mnuInfoEmpfaengerAdd.Index = 0
        Me.mnuInfoEmpfaengerAdd.Text = "Neuer Info-Empfänger"
        '
        'mnuInfoEmpfaengerDelete
        '
        Me.mnuInfoEmpfaengerDelete.Index = 1
        Me.mnuInfoEmpfaengerDelete.Text = "Info-Empfänger löschen"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokZuordnungAdd, Me.MnuDokzuordnungDelete, Me.MenuItem1, Me.MnuShowDoc})
        '
        'MnuDokZuordnungAdd
        '
        Me.MnuDokZuordnungAdd.Index = 0
        Me.MnuDokZuordnungAdd.Text = "Dokument hinzufügen"
        '
        'MnuDokzuordnungDelete
        '
        Me.MnuDokzuordnungDelete.Index = 1
        Me.MnuDokzuordnungDelete.Text = "Dokument entfernen"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "-"
        '
        'MnuShowDoc
        '
        Me.MnuShowDoc.Index = 3
        Me.MnuShowDoc.Text = "Dokument anzeigen"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Dokument auswählen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Dokument entfernen"
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.DateTimePicker2.Location = New System.Drawing.Point(88, 48)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.ShowUpDownButtons = False
        Me.DateTimePicker2.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker2.TabIndex = 36
        Me.DateTimePicker2.Tag = Nothing
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 72)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 35
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(88, 72)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(272, 112)
        Me.txtBemerkung.TabIndex = 20
        Me.txtBemerkung.Text = ""
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker3.TabIndex = 18
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 34
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 48)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 30
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem4})
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Text = "Berechtigungseinschränkung hinzufügen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "Berechtigungseinschränkung entfernen"
        '
        'cbVerantwortlich
        '
        Me.cbVerantwortlich.ContextMenu = Me.ContextMenu5
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(520, 64)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(224, 21)
        Me.cbVerantwortlich.TabIndex = 8
        Me.cbVerantwortlich.Visible = False
        '
        'ContextMenu5
        '
        Me.ContextMenu5.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Berechtigte Mitarbeiter"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(416, 64)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(88, 23)
        Me.Label17.TabIndex = 44
        Me.Label17.Text = "Verantwortlicher"
        Me.Label17.Visible = False
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(416, 40)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 43
        Me.Label16.Text = "Dokumentstatus"
        Me.Label16.Visible = False
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.ItemHeight = 13
        Me.cbdokumentstatus.Location = New System.Drawing.Point(520, 40)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(264, 21)
        Me.cbdokumentstatus.TabIndex = 7
        Me.cbdokumentstatus.Visible = False
        '
        'txtPartnerInhaberNr
        '
        Me.txtPartnerInhaberNr.Location = New System.Drawing.Point(344, 72)
        Me.txtPartnerInhaberNr.Name = "txtPartnerInhaberNr"
        Me.txtPartnerInhaberNr.ReadOnly = True
        Me.txtPartnerInhaberNr.Size = New System.Drawing.Size(56, 20)
        Me.txtPartnerInhaberNr.TabIndex = 5
        Me.txtPartnerInhaberNr.Text = ""
        Me.txtPartnerInhaberNr.Visible = False
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(520, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(264, 20)
        Me.txtBezeichnung.TabIndex = 6
        Me.txtBezeichnung.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(416, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.TabIndex = 38
        Me.Label4.Text = "Bezeichnung"
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(352, 16)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 2
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(112, 40)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerZusteller.TabIndex = 1
        Me.txtPartnerZusteller.Text = ""
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(112, 16)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 0
        Me.txtPartnerInhaber.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 34
        Me.Label2.Text = "Partner-Zusteller"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 33
        Me.Label1.Text = "Partner-Inhaber"
        '
        'cdokumentwerteanzeigen
        '
        Me.cdokumentwerteanzeigen.Location = New System.Drawing.Point(536, 467)
        Me.cdokumentwerteanzeigen.Name = "cdokumentwerteanzeigen"
        Me.cdokumentwerteanzeigen.Size = New System.Drawing.Size(160, 32)
        Me.cdokumentwerteanzeigen.TabIndex = 12
        Me.cdokumentwerteanzeigen.Text = "Dokumentinhalte anzeigen"
        Me.cdokumentwerteanzeigen.Visible = False
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(376, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 3
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(296, 64)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(24, 24)
        Me.Button4.TabIndex = 4
        Me.Button4.Visible = False
        '
        'cbsave
        '
        Me.cbsave.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbsave.Location = New System.Drawing.Point(744, 64)
        Me.cbsave.Name = "cbsave"
        Me.cbsave.Size = New System.Drawing.Size(21, 21)
        Me.cbsave.TabIndex = 49
        Me.cbsave.Text = "ComboBox1"
        Me.cbsave.Visible = False
        '
        'cbmoeglicheStati
        '
        Me.cbmoeglicheStati.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbmoeglicheStati.Location = New System.Drawing.Point(743, 64)
        Me.cbmoeglicheStati.Name = "cbmoeglicheStati"
        Me.cbmoeglicheStati.Size = New System.Drawing.Size(21, 21)
        Me.cbmoeglicheStati.TabIndex = 9
        Me.cbmoeglicheStati.Text = "ComboBox1"
        Me.cbmoeglicheStati.Visible = False
        '
        'Panel1
        '
        Me.Panel1.Location = New System.Drawing.Point(784, 16)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(24, 100)
        Me.Panel1.TabIndex = 50
        Me.Panel1.Visible = False
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(416, 80)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 32)
        Me.Label11.TabIndex = 52
        Me.Label11.Text = "Berechtigt für Folgestatus"
        Me.Label11.Visible = False
        '
        'txtstatus
        '
        Me.txtstatus.Location = New System.Drawing.Point(520, 88)
        Me.txtstatus.Name = "txtstatus"
        Me.txtstatus.Size = New System.Drawing.Size(224, 16)
        Me.txtstatus.TabIndex = 51
        Me.txtstatus.Text = "Label3"
        Me.txtstatus.Visible = False
        '
        'btntxtBemerkung
        '
        Me.btntxtBemerkung.Image = CType(resources.GetObject("btntxtBemerkung.Image"), System.Drawing.Bitmap)
        Me.btntxtBemerkung.Location = New System.Drawing.Point(764, 64)
        Me.btntxtBemerkung.Name = "btntxtBemerkung"
        Me.btntxtBemerkung.Size = New System.Drawing.Size(21, 21)
        Me.btntxtBemerkung.TabIndex = 10
        Me.btntxtBemerkung.Visible = False
        '
        'LabelVIBeachten
        '
        Me.LabelVIBeachten.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.LabelVIBeachten.ForeColor = System.Drawing.Color.Red
        Me.LabelVIBeachten.Location = New System.Drawing.Point(48, 72)
        Me.LabelVIBeachten.Name = "LabelVIBeachten"
        Me.LabelVIBeachten.Size = New System.Drawing.Size(240, 21)
        Me.LabelVIBeachten.TabIndex = 54
        Me.LabelVIBeachten.Text = "VI beachten"
        Me.LabelVIBeachten.Visible = False
        '
        'PicVIBeachten
        '
        Me.PicVIBeachten.Image = CType(resources.GetObject("PicVIBeachten.Image"), System.Drawing.Bitmap)
        Me.PicVIBeachten.Location = New System.Drawing.Point(3, 58)
        Me.PicVIBeachten.Name = "PicVIBeachten"
        Me.PicVIBeachten.Size = New System.Drawing.Size(45, 46)
        Me.PicVIBeachten.TabIndex = 55
        Me.PicVIBeachten.TabStop = False
        Me.PicVIBeachten.Visible = False
        '
        'GroupBox7
        '
        Me.GroupBox7.BackColor = System.Drawing.SystemColors.Control
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.InfoMeldungList})
        Me.GroupBox7.Location = New System.Drawing.Point(488, 200)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(32, 96)
        Me.GroupBox7.TabIndex = 59
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Informationsmeldungen"
        Me.GroupBox7.Visible = False
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.ContextMenu = Me.ContextMenu4
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.InfoMeldungList.Location = New System.Drawing.Point(8, 16)
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines2
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(760, 72)
        Me.InfoMeldungList.TabIndex = 0
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, " & _
        "1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""" & _
        "><ClientRect>0, 0, 756, 68</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 756, 68</ClientArea></Blob>"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.ZuordnungList})
        Me.GroupBox6.Location = New System.Drawing.Point(568, 200)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(24, 88)
        Me.GroupBox6.TabIndex = 58
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Dokument-Zuordnung"
        Me.GroupBox6.Visible = False
        '
        'ZuordnungList
        '
        Me.ZuordnungList.AllowFilter = True
        Me.ZuordnungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ZuordnungList.AllowSort = True
        Me.ZuordnungList.AlternatingRows = True
        Me.ZuordnungList.CaptionHeight = 17
        Me.ZuordnungList.CollapseColor = System.Drawing.Color.Black
        Me.ZuordnungList.ContextMenu = Me.ContextMenu3
        Me.ZuordnungList.DataChanged = False
        Me.ZuordnungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ZuordnungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ZuordnungList.ExpandColor = System.Drawing.Color.Black
        Me.ZuordnungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ZuordnungList.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ZuordnungList.Location = New System.Drawing.Point(3, 16)
        Me.ZuordnungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ZuordnungList.Name = "ZuordnungList"
        Me.ZuordnungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ZuordnungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ZuordnungList.PreviewInfo.ZoomFactor = 75
        Me.ZuordnungList.PrintInfo.ShowOptionsDialog = False
        Me.ZuordnungList.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ZuordnungList.RowDivider = GridLines3
        Me.ZuordnungList.RowHeight = 15
        Me.ZuordnungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ZuordnungList.ScrollTips = False
        Me.ZuordnungList.Size = New System.Drawing.Size(18, 69)
        Me.ZuordnungList.TabIndex = 1
        Me.ZuordnungList.Text = "C1TrueDBGrid1"
        Me.ZuordnungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 14, 65</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""" & _
        "Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Even" & _
        "Row"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyl" & _
        "e parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Headi" & _
        "ngStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" " & _
        "me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent" & _
        "=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11" & _
        """ /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""St" & _
        "yle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" m" & _
        "e=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""F" & _
        "ooter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inac" & _
        "tive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor" & _
        """ /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRo" & _
        "w"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSele" & _
        "ctor"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Grou" & _
        "p"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>N" & _
        "one</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 14, 65<" & _
        "/ClientArea></Blob>"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.ColdList})
        Me.GroupBox5.Location = New System.Drawing.Point(600, 192)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(16, 96)
        Me.GroupBox5.TabIndex = 57
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Dokumente ersetzen"
        Me.GroupBox5.Visible = False
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.ContextMenu = Me.ContextMenu7
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(3, 16)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines4
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(10, 77)
        Me.ColdList.TabIndex = 0
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 6, 73</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""S" & _
        "tyle10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenR" & _
        "ow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle" & _
        " parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Headin" & _
        "gStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" m" & _
        "e=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=" & _
        """OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11""" & _
        " /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Sty" & _
        "le1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me" & _
        "=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Fo" & _
        "oter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inact" & _
        "ive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor""" & _
        " /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow" & _
        """ /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelec" & _
        "tor"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group" & _
        """ /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>No" & _
        "ne</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 6, 73</C" & _
        "lientArea></Blob>"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1DateEdit1, Me.Label12, Me.TextBox1, Me.DateTimePicker4, Me.Label14, Me.Label15})
        Me.GroupBox4.Location = New System.Drawing.Point(528, 184)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(24, 192)
        Me.GroupBox4.TabIndex = 56
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Allgemein"
        Me.GroupBox4.Visible = False
        '
        'C1DateEdit1
        '
        Me.C1DateEdit1.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.C1DateEdit1.Location = New System.Drawing.Point(88, 48)
        Me.C1DateEdit1.Name = "C1DateEdit1"
        Me.C1DateEdit1.ShowUpDownButtons = False
        Me.C1DateEdit1.Size = New System.Drawing.Size(96, 20)
        Me.C1DateEdit1.TabIndex = 1
        Me.C1DateEdit1.Tag = Nothing
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 72)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(80, 23)
        Me.Label12.TabIndex = 35
        Me.Label12.Text = "Bemerkung"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 72)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(272, 112)
        Me.TextBox1.TabIndex = 2
        Me.TextBox1.Text = ""
        '
        'DateTimePicker4
        '
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker4.TabIndex = 0
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 24)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(80, 23)
        Me.Label14.TabIndex = 34
        Me.Label14.Text = "Archiv-Datum"
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(8, 48)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(80, 23)
        Me.Label15.TabIndex = 30
        Me.Label15.Text = "Termin"
        '
        'pnlBerechtigungen
        '
        Me.pnlBerechtigungen.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.pnlBerechtigungen.Location = New System.Drawing.Point(648, 200)
        Me.pnlBerechtigungen.Name = "pnlBerechtigungen"
        Me.pnlBerechtigungen.Size = New System.Drawing.Size(16, 152)
        Me.pnlBerechtigungen.TabIndex = 62
        Me.pnlBerechtigungen.TabStop = False
        Me.pnlBerechtigungen.Text = "Berechtigungseinschränkung"
        Me.pnlBerechtigungen.Visible = False
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.ContextMenu = Me.ContextMenu6
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.Location = New System.Drawing.Point(8, 16)
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines5
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(600, 128)
        Me.DokumentFunktionenList.TabIndex = 1
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 596, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "124</ClientArea></Blob>"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.cvertraulich, Me.Label18, Me.cGesperrt, Me.Label9})
        Me.GroupBox9.Location = New System.Drawing.Point(744, 200)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(32, 152)
        Me.GroupBox9.TabIndex = 61
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Schutz"
        Me.GroupBox9.Visible = False
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(16, 96)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(120, 48)
        Me.Button3.TabIndex = 2
        Me.Button3.Text = "Liste der berechtigten Mitarbeiter"
        '
        'cvertraulich
        '
        Me.cvertraulich.Location = New System.Drawing.Point(80, 46)
        Me.cvertraulich.Name = "cvertraulich"
        Me.cvertraulich.Size = New System.Drawing.Size(48, 24)
        Me.cvertraulich.TabIndex = 18
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(16, 48)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(64, 23)
        Me.Label18.TabIndex = 1
        Me.Label18.Text = "Vertraulich"
        '
        'cGesperrt
        '
        Me.cGesperrt.Enabled = False
        Me.cGesperrt.Location = New System.Drawing.Point(80, 24)
        Me.cGesperrt.Name = "cGesperrt"
        Me.cGesperrt.Size = New System.Drawing.Size(48, 24)
        Me.cGesperrt.TabIndex = 16
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 24)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(64, 23)
        Me.Label9.TabIndex = 0
        Me.Label9.Text = "Gesperrt"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox8.Location = New System.Drawing.Point(704, 112)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(40, 152)
        Me.GroupBox8.TabIndex = 60
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Notizen"
        Me.GroupBox8.Visible = False
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(12, 36)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines6
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 4
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu1
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(8, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines7
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(760, 128)
        Me.Notizlist.TabIndex = 1
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 756, 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 756, " & _
        "124</ClientArea></Blob>"
        '
        'frmDokumentbearbeitungED
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(802, 503)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.LabelVIBeachten, Me.pnlBerechtigungen, Me.GroupBox9, Me.GroupBox8, Me.GroupBox7, Me.GroupBox6, Me.GroupBox5, Me.GroupBox4, Me.txtPartnerZusteller, Me.PicVIBeachten, Me.btntxtBemerkung, Me.Label11, Me.txtstatus, Me.Panel1, Me.cbmoeglicheStati, Me.Button4, Me.Button1, Me.cdokumentwerteanzeigen, Me.cbVerantwortlich, Me.Label17, Me.Label16, Me.cbdokumentstatus, Me.txtPartnerInhaberNr, Me.txtBezeichnung, Me.Label4, Me.btnPartnerInhaber, Me.txtPartnerInhaber, Me.Label2, Me.Label1, Me.TabControl2, Me.btnCancel, Me.btnWeiter, Me.cbsave})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmDokumentbearbeitungED"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumentbearbeitung Einzeldokument"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.GroupBox11.ResumeLayout(False)
        Me.GroupBox12.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        CType(Me.DokWertList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.DateTimePicker2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox7.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox6.ResumeLayout(False)
        CType(Me.ZuordnungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox4.ResumeLayout(False)
        CType(Me.C1DateEdit1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlBerechtigungen.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox9.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Load_Defaults Method

Private Sub Load_Defaults()

Source code

[Visual Basic]
    Private Sub Load_Defaults()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Dim doktyp As New edokadb.clsDokumenttyp()
        doktyp.cpMainConnectionProvider = conn
        doktyp.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
        doktyp.SelectOne()

        If doktyp.bFunktionen_zuweisen.Value = True Then
            Dokumentfunktionen_Aktivieren()
        Else
            w.Save_DokumentFunktionen = Generic_Select(6)
            Me.pnlBerechtigungen.Visible = False
        End If

        'Dokumenttyp-Daten
        If Me.CreateDocument = True Then
            If DivFnkt.Ist_Berechtigt(doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 2, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
            End If
        Else
            If DivFnkt.Ist_Berechtigt(doktyp.iDokumenttypnr.Value, Globals.MitarbeiterNr, 0, 0, 3, 0, 0, 1) Then
                Me.cvertraulich.Visible = True
                Me.Label18.Visible = True
                Me.cvertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
            Else
                Me.cvertraulich.Checked = False
                Me.cvertraulich.Visible = False
                Me.Label18.Visible = False
            End If
        End If

        progress.Bar1.Value = 20
        progress.Refresh()

        Me.txtBezeichnung.Text = doktyp.sBezeichnung.Value
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumentid").Value = ""
        Me.SqlDataAdapter1.SelectCommand.Parameters("@Dokumenttypnr").Value = Me.Dokumenttypnr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@CreateNew").Value = 1
        Me.SqlDataAdapter1.Fill(Me.DataSet1)

        Me.DokWertList.DataSource = Me.DataSet1
        Me.DokWertList.DataMember = Me.DataSet1.Tables(0).TableName
        For i = 3 To Me.DokWertList.Columns.Count - 1
            Me.DokWertList.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.DokWertList.Splits(0).DisplayColumns(0).Width = 110
        Me.DokWertList.Splits(0).DisplayColumns(1).Width = 60
        Me.DokWertList.Columns(1).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.DokWertList.Splits(0).DisplayColumns(1).Locked = True
        Me.DokWertList.Splits(0).DisplayColumns(2).Width = 160

        Me.mcbstatus = New MultiComboBox(Me.cbdokumentstatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)

        Me.mcbkube = New MultiComboBox(Me.cbKube)
        Me.mcbkube.CheckNullValue = True
        Me.mcbkube.NullValueMessage = MyTxt.gettext(18)
        Me.mcbkube.DisplayColumnName = "name"
        Me.mcbkube.ValueColumnName = "mitarbeiternr"
        Me.mcbkube.Fill_Data(Generic_Select(8), False)

        progress.Bar1.Value = 30
        progress.Refresh()

        'Postzustellung
        Me.SqlDataAdapter2.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter2.SelectCommand.Parameters("@sprache").Value = Globals.Sprache
        Me.SqlDataAdapter2.Fill(Me.DataSet2)

        mcbpostzustellung = New MultiComboBox(Me.cbPostzustellung)
        Me.mcbpostzustellung.DisplayColumnName = "bezeichnung"
        Me.mcbpostzustellung.ValueColumnName = "nreintrag"
        Dim d As DataTable
        d = Me.DataSet2.Tables(0)
        Me.mcbpostzustellung.Fill_Data(d, False)
        Me.mcbpostzustellung.Enabled = True
        Me.mcbpostzustellung.CheckNullValue = False

        mcbzust = New MultiComboBox(Me.cbzust)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii

        progress.Bar1.Value = 40
        progress.Refresh()

        mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
        Me.mcbunterschriftlinks.DisplayColumnName = "name"
        Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftlinks")
        Me.mcbunterschriftlinks.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftlinks.SelectedValue = ii

        mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
        Me.mcbunterschriftrechts.DisplayColumnName = "name"
        Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
        For i = 0 To Me.Profile.Rows.Count - 1
            If Me.Profile.Rows(i).Item("profilnr") = Me.Profilnr Then
                CurrentProfil = i
            End If
        Next
        ii = Me.Profile.Rows(CurrentProfil).Item("unterschriftrechts")
        Me.mcbunterschriftrechts.Fill_Data(Generic_Select(3), True)
        Me.mcbunterschriftrechts.SelectedValue = ii

        Me.mcbunterschriftlinks.CheckNullValue = False
        Me.mcbunterschriftrechts.CheckNullValue = False

        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        FillMcbVerantwortlich()

        Me.rbZustaendigKube.Checked = False
        Me.RBZustaendigZustaendiger.Checked = True
        Me.txtZustelladresse.Text = ""

        If doktyp.bUnterschrift_links.Value = False Then Me.mcbunterschriftlinks.Enabled = False
        If doktyp.bUnterschrift_rechts.Value = False Then Me.mcbunterschriftrechts.Enabled = False
        If doktyp.bUnterschrift_links.Value = True Then Me.mcbunterschriftlinks.Enabled = True
        If doktyp.bUnterschrift_rechts.Value = True Then Me.mcbunterschriftrechts.Enabled = True

        progress.Bar1.Value = 50
        progress.Refresh()

        Me.zu_retournieren = doktyp.bZu_retournieren.Value

        doktyp.Dispose()

        'Dokument ersetzen
        Me.Dokumentersetzen = Dokumentersetzen_Laden()
        w.save_dokumentersetzen = Dokumentersetzen_Laden()
        Me.ColdList.DataSource = Me.Dokumentersetzen
        Me.ColdList.Columns("aktiv").FilterText = True
        Me.ColdList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, Me.Dokumentersetzen, "dokumentersetzen")
        If doktyp.bCold_ersetzen.Value <> True Then
            Me.ErsetzenMoeglich = False
        Else
            Me.ErsetzenMoeglich = True
        End If

        'Notizen
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

        progress.Bar1.Value = 60
        progress.Refresh()

        'Dokumentzuordnungen
        Me.Dokumentzuorndungen = Dokumentzuordnungen_Laden()
        w.Save_Dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.ZuordnungList.DataSource = Me.Dokumentzuorndungen

        DivFnkt.SpaltenTitel_Aktualisieren(Me.ZuordnungList, Me.Dokumentzuorndungen, "dokumentzuordnungen")
        Me.ZuordnungList.Columns("aktiv").FilterText = True
        Me.ZuordnungList.FilterBar = False

        Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.ZuordnungList.Columns("zuordnungnr").ValueItems.Translate = True
        Next

        progress.Bar1.Value = 70
        progress.Refresh()

        'Dokumentinfomeldungen
        Me.InfoMeldungList.FetchRowStyles = True
        Me.DokumentInfoMeldungen = Dokumentinfomeldungen_laden()
        w.Save_Dokumentinfomeldungen = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = Me.DokumentInfoMeldungen
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, Me.DokumentInfoMeldungen, "Dokumentinfomeldung")

        'Team
        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        refresh_team()
        Me.mcbteam.SelectedIndex = 0

        progress.Bar1.Value = 80
        progress.Refresh()

        Me.mcbstatus.SelectedIndex = 0
        Me.savestatus = Me.mcbstatus.SelectedValue
        Me.firststatus = Me.savestatus
        Me.saveverantwortlicher = Globals.MitarbeiterNr

        Me.moeglichestati = Generic_Select(15)
        Me.cbmoeglicheStati.Items.Clear()
        Me.funktionsliste = ""
        '        Dim i As Integer
        settooltip()
        For i = 0 To Me.moeglichestati.Rows.Count - 1
            Me.cbmoeglicheStati.Items.Add(Me.moeglichestati.Rows(i).Item("bezeichnung"))
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim i As Integer
        Dim s As String
        s = ""
        Try
            For i = 0 To Me.DokumentFunktionen.Rows.Count - 1
                If Me.DokumentFunktionen.Rows(i).Item("aktiv") = 1 Then
                    If s <> "" Then s = s + ";"
                    s = s + Microsoft.VisualBasic.LTrim(Str(Me.DokumentFunktionen.Rows(i).Item("funktionsgruppenr")))
                End If
            Next
        Catch
        End Try
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

        Dim f As New frmBerechtigungen()
        If Me.cvertraulich.Checked Then
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 1, s)
        Else
            f.Fill_Berechtigungen(Me.Dokumenttypnr, Me.Partnernr, 0, s)
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim f As New frmDokumentberechtigung()
        f.Dokumenttyp = Me.Dokumenttypnr
        f.Partnernr = Me.Partnernr
        f.Vertraulich = Me.cvertraulich.Checked
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = DokumentFunktionen.Rows
            Dim rowvals(Me.DokumentFunktionenList.Columns.Count - 1)
            rowvals(0) = System.DBNull.Value
            rowvals(1) = f.Funktionsgruppebezeichnung
            rowvals(2) = f.Funktionsgruppenr
            rowvals(3) = f.Anzeigen
            rowvals(4) = f.Bearbeiten
            rowvals(5) = f.Loeschen
            rowvals(6) = f.Abschliessen
            rowvals(7) = True
            rowvals(8) = Now
            rowvals(9) = Globals.MitarbeiterNr
            newrow = rc.Add(rowvals)
            Me.DokumentFunktionenList.Refresh()
            For i = 0 To Me.DokumentFunktionenList.Splits(0).Rows.Count - 1
                If Me.DokumentFunktionenList.Columns("bezeichnung").CellText(i) = f.Funktionsgruppebezeichnung Then
                    Me.DokumentFunktionenList.Bookmark = i
                End If
            Next
            Me.FillMcbVerantwortlich()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Me.DokumentFunktionenList.Columns(7).Value = False
        Me.DokumentFunktionenList.Refresh()
        Me.Button3.Focus()
        Me.DokumentFunktionenList.Focus()
        Me.FillMcbVerantwortlich()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                If Check_Dokumentersetzen(Me.Dokumenttypnr, fx.SelectedDokumentid) Then
                    Dim rc As DataRowCollection
                    Dim newrow As DataRow
                    rc = Dokumentersetzen.Rows
                    Dim rowvals(Me.Dokumentersetzen.Columns.Count - 1) As Object
                    rowvals(0) = System.DBNull.Value
                    rowvals(1) = ""
                    If Me.CreateDocument Then
                        rowvals(1) = ""
                    Else
                        rowvals(1) = Me.DokumentID
                    End If
                    rowvals(2) = fx.SelectedDokumentid
                    rowvals(3) = True

                    rowvals(8) = fx.Dokumentbezeichnung
                    rowvals(9) = fx.dokumentdatum
                    newrow = rc.Add(rowvals)
                    Me.ColdList.Refresh()
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Me.ColdList.Columns("aktiv").Value = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Try
            Me.Notizlist.Columns(5).Value = False
            Me.Notizlist.Refresh()
            Me.TabControl2.Select()
            Me.Notizlist.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuDokZuordnungAdd_Click Method

Private Sub MnuDokZuordnungAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokZuordnungAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokZuordnungAdd.Click
        Globals.profilnr = Me.Profilnr
        Dim fx As New frmTrefferliste()
        fx.OnlySelect = True
        fx.txtnrpar00.Text = Me.txtPartnerInhaberNr.Text
        fx.Partner_Eingegeben = True
        '        fx.refresh_list()
        fx.ToolBar1.Visible = False
        fx.txtnrpar00.Visible = False
        fx.tvstruktur.ContextMenu = Nothing
        fx.Text = "Dokument für Dokumentzuordnung auswählen"
        fx.ImgCombo.Visible = False
        fx.btnPartnersuche.Visible = False
        fx.LblSearch.Visible = False
        fx.DokList.ContextMenu = fx.ContextMenu3
        fx.SelectedDokumentid = ""
        fx.DoRefresh = True
        fx.ShowDialog()
        Try
            If fx.SelectedDokumentid <> "" Then
                Dim rc As DataRowCollection
                Dim newrow As DataRow
                rc = Me.Dokumentzuorndungen.Rows
                Dim rowvals(Me.Dokumentzuorndungen.Columns.Count - 1) As Object
                rowvals(0) = 0
                rowvals(2) = 1
                rowvals(6) = 1
                rowvals(8) = fx.SelectedDokumentid
                rowvals(10) = fx.Dokumentbezeichnung

                newrow = rc.Add(rowvals)
                Me.ZuordnungList.Refresh()
                'For i = 0 To Me.ZuordnungList.Splits(0).Rows.Count - 1
                'If Me.ZuordnungList.Columns(0).CellText(i) = fx.SelectedDokumentid Then
                '    Me.ZuordnungList.Bookmark = i
                'End If
                'Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        fx.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuDokzuordnungDelete_Click Method

Private Sub MnuDokzuordnungDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokzuordnungDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokzuordnungDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokzuordnungDelete.Click
        Me.ZuordnungList.Columns("aktiv").Value = False
        Me.ZuordnungList.Refresh()
        Me.TabControl2.Select()
        Me.ZuordnungList.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Notizlist.Columns("betreff").Value = f.Betreff
            Me.Notizlist.Columns("notiz").Value = f.Notiz
            Me.Notizlist.Columns("Mutierer").Value = Globals.MitarbeiterNr
            Me.Notizlist.Columns("Mutiert_Am").Text = Now()
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim f As New frmNotizen()
        f.Mutierer = Globals.MitarbeiterNr.ToString

        f.Notiz = ""
        f.Betreff = ""

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow

            rc = Notizen.Rows
            Dim rowvals(Me.Notizen.Columns.Count - 1) As Object
            '            For i = 0 To Me.Notizen.Columns.Count - 1
            '           MsgBox(Me.Notizen.Columns(i).Caption)
            '          Next
            rowvals(0) = System.DBNull.Value
            rowvals(2) = f.Betreff
            rowvals(3) = f.Notiz
            rowvals(5) = True                   'Aktiv
            rowvals(6) = Now()                  'erstellt_am
            rowvals(7) = Now()                  'mutiert_am
            rowvals(8) = Globals.MitarbeiterNr  'mutierer
            newrow = rc.Add(rowvals)
            Me.Notizlist.DataSource = Nothing
            Me.Notizlist.DataSource = Me.Notizen
            load_Mitarbeiter()

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "notizen")

            '            Me.Notizlist.Refresh()
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuShowDoc_Click Method

Private Sub MnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowDoc.Click
        Dim doc As New edokadb.clsDokument()
        Dim Dokument As String
        Dim FileReader As New DocMgmt()
        doc.cpMainConnectionProvider = conn
        doc.sDokumentid = New SqlString(CType(Me.ZuordnungList.Columns(1).Value, String))
        doc.SelectOne()
        Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
        FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument)
        doc.Dispose()
        FileReader = Nothing
        Dim w As New WordLib()
        w.ShowDoc(Dokument)
        w = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.MnuValueSelect_Click Method

Private Sub MnuValueSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuValueSelect.Click, _
   DokWertList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuValueSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuValueSelect.Click, DokWertList.DoubleClick
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim s As String
        Select Case UCase(Me.DokWertList.Columns("feldtyp").Value)
            Case "DATUMSHORT"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToShortDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMMEDIUM"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart
                    s = Format(f.MonthCalendar1.SelectionStart, "dd. MMMM yyyy")
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()
            Case "DATUMLONG"
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    s = f.MonthCalendar1.SelectionStart.ToLongDateString
                    Me.DokWertList.Columns("feldwert").Value = s
                End If
                f.Dispose()

            Case "TEXT"
                If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 8) = "&Partner" Then
                    Dim f As New FrmPartnersuche()
                    f.ShowDialog()
                    If f.PartnerNr <> 0 Then
                        Me.DokWertList.Columns("feldwert").Value = Str(f.PartnerNr) + "-" + f.PartnerKurzbezeichnnung
                    End If
                    f.Dispose()
                Else
                    If Microsoft.VisualBasic.Left(Me.DokWertList.Columns("Datenherkunft").Value, 1) = "&" Then
                        Dim f As New frmValueSelector()
                        If Me.DokWertList.Columns("Datenherkunft").Value = "&SekPartnerVV&" Then
                            Dim ss As String
                            Dim ii As Integer
                            For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner&" Then
                                    ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                End If
                            Next
                            'ss = Me.DokWertList.Columns("feldwert").CellText(0)
                            ii = InStr(ss, "-")
                            If ii < 1 Then Exit Sub
                            f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                        Else
                            If Me.DokWertList.Columns("Datenherkunft").Value = "&TerPartnerVV&" Then
                                Dim ss As String
                                Dim ii As Integer
                                For i = 0 To Me.DokWertList.Splits(0).Rows.Count - 1
                                    If Me.DokWertList.Columns("datenherkunft").CellValue(i) = "&Partner3&" Then
                                        ss = Me.DokWertList.Columns("feldwert").CellText(i)
                                    End If
                                Next
                                'ss = Me.DokWertList.Columns("feldwert").CellText(0)
                                ii = InStr(ss, "-")
                                If ii < 1 Then Exit Sub
                                f.Partnernr = LTrim(Microsoft.VisualBasic.Left(ss, ii - 1))
                            Else
                                f.partnernr = Me.txtPartnerInhaberNr.Text()
                            End If
                        End If
                        f.Text = f.Text + Me.DokWertList.Columns(0).Value
                        f.Datenherkunft = Me.DokWertList.Columns("Datenherkunft").Value
                        'f.partnernr = Me.txtPartnerInhaberNr.Text()
                        f.LoadData()
                        If f.Datenvorhanden = True Then
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then Me.DokWertList.Columns("feldwert").Value = f.SelWert
                        End If
                        f.Dispose()
                    End If
                End If
            Case Else
        End Select
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.CreateDocument Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentID))
            End If
            '            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Notizen_Sichern Method

Public Sub Notizen_Sichern()

Source code

[Visual Basic]
    Public Sub Notizen_Sichern()
        For i = 0 To Me.Notizen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@notiznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiznr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("betreff")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("notiz")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Notizen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs)
        MnuEditNotiz_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Notizlist_MouseUp Method

Private Sub Notizlist_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs)
        If Me.Notizen.Rows.Count = 0 Then Exit Sub
        Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.RBZustaendigZustaendiger_CheckedChanged Method

Private Sub RBZustaendigZustaendiger_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBZustaendigZustaendiger.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBZustaendigZustaendiger_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBZustaendigZustaendiger.CheckedChanged
        Me.mcbkube.Enabled = False
        Me.mcbzust.Enabled = True
        Me.mcbzust.Focus()

        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            Me.refresh_team()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Set_Feldwert Method

Private Sub Set_Feldwert()

Source code

[Visual Basic]
    Private Sub Set_Feldwert()
        Try
            'Me.DokWertList.Columns("feldwert").Value = Me.ValueList.Columns(0).Value
            'Me.DokWertList.Columns("feldwert").Value = Me.Datumselect.Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Status_History Method

Private Function Status_History( _
   ByVal statusnr As Long _
)

Parameters

statusnr
Required.

Source code

[Visual Basic]
    Private Function Status_History(ByVal statusnr As Long)
        Dim statush As New Statushandling()
        Dim i, i1 As Integer
        If Me.saveverantwortlicher = Me.mcbverantwortlich.SelectedValue And Me.savestatus = Me.mcbstatus.SelectedValue And Not Me.CreateDocument And Me.mcbstatus.SelectedIndex = 0 Then
            statush.Dispose()
            Exit Function
        End If
        If Me.CreateDocument Then
            i = Me.mcbstatus.SelectedValue
            Me.mcbstatus.SelectedIndex = 0
            statush.insert_history_status(get_current_Status(Me.DokumentID), Me.DokumentID, Globals.MitarbeiterNr)
            System.Threading.Thread.CurrentThread.Sleep(500)
            Me.mcbstatus.SelectedValue = i
            If Me.mcbstatus.SelectedIndex <> 0 Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(get_current_Status(Me.DokumentID), Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
            End If
            w.send_statusmessage = True
        Else
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbstatus.SelectedIndex <> 0 Then
                i = Me.mcbstatus.SelectedValue
                Me.mcbstatus.SelectedIndex = 0
                Me.savestatus = Me.mcbstatus.SelectedValue
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.DokumentID, Globals.MitarbeiterNr)
                w.send_statusmessage = True
                Me.mcbstatus.SelectedValue = i
                System.Threading.Thread.CurrentThread.Sleep(500)
            End If
            If Me.mcbstatus.SelectedValue <> Me.savestatus Or Me.mcbverantwortlich.SelectedValue <> Me.saveverantwortlicher Then
                statush.insert_history_status(Me.mcbstatus.SelectedValue, Me.DokumentID, Me.mcbverantwortlich.SelectedValue)
            End If
        End If

        statush.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.Update_Bclabel Method

Private Sub Update_Bclabel( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Sub Update_Bclabel(ByVal typ As Integer)
        If Me.BarcodeID = "" Then Exit Sub
        Dim bc As New edokadb.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        bc.iBarcodenr = New SqlInt32(CType(Me.BarcodeID, Int32))
        bc.SelectOne()
        conn.OpenConnection()
        If typ = 2 And Me.CreateDocument = True Then
            bc.sDokumentid = New SqlString(CType("", String))
        Else
            bc.sDokumentid = New SqlString(CType(Me.DokumentID, String))
        End If
        bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        bc.Update()
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.bereiche_sperren Method

Private Sub bereiche_sperren()

Source code

[Visual Basic]
    Private Sub bereiche_sperren()
        Me.btnPartnerInhaber.Enabled = False
        Me.GroupBox1.Enabled = False
        Me.GroupBox2.Enabled = False
        Me.GroupBox3.Enabled = False
        Me.GroupBox4.Enabled = False
        Me.GroupBox5.Enabled = False
        Me.GroupBox10.Enabled = False
        Me.GroupBox11.Enabled = False
        Me.GroupBox12.Enabled = False
        Me.GroupBox9.Enabled = False
        Me.Button2.Enabled = False
        Me.pnlBerechtigungen.Enabled = False
        Me.cbVerantwortlich.Enabled = False
        Me.mcbverantwortlich.Enabled = False
        Me.cbdokumentstatus.Enabled = False
        Me.mcbstatus.Enabled = False
        Me.DokWertList.Enabled = False
        Me.cdokumentwerteanzeigen.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        If Me.CreateDocument = False Then
            DivFnkt.Status_Dokumentbearbeitung(2, Me.DokumentID, False, "")
            If Globals.Dokumentcoldindex_Changed Then Archivfnkt.Restore_Coldindex(Globals.general_ds.Tables(0), Me.DokumentID)
            If Globals.dokumentid_changed Then Archivfnkt.change_dokumentid(DokumentID, Globals.Dokumentidalt)
        Else
            Update_Bclabel(2)
        End If

        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        Dim f As New FrmPartnersuche()
        f.Dokumenttypnrnr = Me.Dokumenttypnr
        f.profilnr = Me.Profilnr
        f.NurAbfrage = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, f.PartnerNr, "", 2, 0, 0, 0) Then
                If Me.txtPartnerInhaber.Text <> "" And Me.txtPartnerInhaber.Text <> Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung Then
                    MyMsg.show_standardmessage(73, MsgBoxStyle.Information)
                End If
                Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                Me.txtPartnerInhaberNr.Text = f.PartnerNr
                Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                Me.TabControl2.Enabled = True
                Me.RBZustaendigZustaendiger.Checked = True
                Me.mcbkube.DataSource = Nothing
                Me.mcbkube.Text = ""
                Me.mcbkube.Items.Clear()
                Me.Partnernr = f.PartnerNr
                Me.VIBeachten = f.VIBeachten
                FillMcbVerantwortlich()
                'EDEX Banklagernd
                Banklagernd_Check()

            Else
                MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                Me.Close()
            End If
            If Me.VIBeachten = True Then
                Me.PicVIBeachten.Visible = True
                Me.LabelVIBeachten.Visible = True
            Else
                Me.PicVIBeachten.Visible = False
                Me.LabelVIBeachten.Visible = False
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
            If DivFnkt.EDOKA_Partner_Dokument(3, Me.Dokumenttypnr) = False Then
                MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                Exit Sub
            End If
        End If
        If Me.check_existing_address = True And Trim(Me.txtZustelladresse.Text) = "" Then
            MyMsg.show_standardmessage(610, MsgBoxStyle.Critical)
            Exit Sub
        End If
        Try
            Dim p As New edokadb.clsPartner()
            p.cpMainConnectionProvider = conn
            p.iNRPAR00 = New SqlInt32(CType(Trim(Me.txtPartnerInhaberNr.Text), Int32))
            p.SelectOne()
            If p.bSaldiert.Value = True Then
                Dim dt As New edokadb.clsDokumenttyp()
                dt.cpMainConnectionProvider = conn
                dt.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
                dt.SelectOne()
                If dt.bVertrag.Value = True Then
                    MyMsg.show_standardmessage(234, MsgBoxStyle.Critical)
                    dt.Dispose()
                    p.Dispose()
                    Exit Sub
                End If
                dt.Dispose()
            End If
            p.Dispose()
        Catch
        End Try
        Dim xdata As DataTable
        Dim s As String
        'SHU
        ' Meldung wird bei Formularaufbau angezeigt
        'If MyMsg.Show_HinweisMessage(Me.Profilnr, 3, 96, 1) = False Then
        '    Exit Sub
        'End If

        If Me.txtPartnerInhaber.Text = "" Then
            Me.txtPartnerInhaber.Text = "1"
            Me.txtPartnerInhaberNr.Text = "1"
        End If
        If Check_Dokumentfunktionen() = False Then Exit Sub
        xdata = Me.DataSet1.Tables(0)
        For i = 0 To xdata.Rows.Count - 1
            If xdata.Rows(i).Item("zwingend") Is System.DBNull.Value Then
            Else
                If xdata.Rows(i).Item("zwingend") = True Then
                    If xdata.Rows(i).Item("feldwert") Is System.DBNull.Value Or xdata.Rows(i).Item("feldwert") = "" Then
                        MyMsg.show_standardmessage(206, MsgBoxStyle.Critical)
                        Me.DokWertList.Focus()
                        xdata.Dispose()
                        Exit Sub
                    End If
                End If
            End If
        Next
        If Me.mcbteam.SelectedValue = 0 Then
            MyMsg.show_standardmessage(207, MsgBoxStyle.Critical)
            Me.mcbteam.Focus()
            Exit Sub
        End If
        xdata.Dispose()
        Me.btnWeiter.Enabled = False
        Dokument_Bearbeiten(Me.CreateDocument)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.btntxtBemerkung_Click Method

Private Sub btntxtBemerkung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btntxtBemerkung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btntxtBemerkung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btntxtBemerkung.Click
        Dim f As New frmtxtBemerkung()
        f.txtBemerkung.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then Me.txtBemerkungVerantwortlicher = f.txtBemerkung.Text
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cbKube_SelectedIndexChanged Method

Private Sub cbKube_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbKube_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbkube.SelectedIndexChanged
        Try
            Me.teamzustaendig = Me.mcbkube.SelectedValue
        Catch
        End Try
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cbmoeglicheStati_DropDown Method

Private Sub cbmoeglicheStati_DropDown( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.DropDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.DropDown
        Me.cbmoeglicheStati.Width = 200
        Me.cbsave.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cbmoeglicheStati_Leave Method

Private Sub cbmoeglicheStati_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.Leave
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cbmoeglicheStati_SelectedValueChanged Method

Private Sub cbmoeglicheStati_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedValueChanged
        Dim i As Integer
        Dim DATA As DataTable
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
        Me.txtstatus.Text = Me.cbmoeglicheStati.Text
        Me.Label3.Visible = True
        Me.txtstatus.Visible = True
        If Me.txtstatus.Text = Me.mcbstatus.Text Then
            Me.Label3.Visible = False
            Me.txtstatus.Visible = False
            Me.funktionsliste = ""
            Me.selectedstatus = 0
        Else
            For i = 0 To Me.moeglichestati.Rows.Count - 1
                If Me.txtstatus.Text = Me.moeglichestati.Rows(i).Item("bezeichnung") Then
                    Me.selectedstatus = Me.moeglichestati.Rows(i).Item("nr")
                End If
            Next
        End If
        Me.funktionsliste = ""
        DATA = Generic_Select(16)
        For i = 0 To DATA.Rows.Count - 1
            If Me.funktionsliste <> "" Then Me.funktionsliste = Me.funktionsliste + ";"
            Me.funktionsliste = Me.funktionsliste + LTrim(DATA.Rows(i).Item("funktionnr"))
        Next
        fill_mcbmitarbeiter()
        Me.mcbverantwortlich.SelectedValue = Me.saveverantwortlicher
        Me.mcbverantwortlich.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cbzust_SelectedIndexChanged Method

Private Sub cbzust_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.SelectedIndexChanged
        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.check_banklagernd Method

Private Function check_banklagernd() As Integer

Source code

[Visual Basic]
    Private Function check_banklagernd() As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_banklagernd"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtPartnerInhaberNr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@banklagernd", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters.Item("@banklagernd").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.cvertraulich_CheckedChanged Method

Private Sub cvertraulich_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cvertraulich_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            FillMcbVerantwortlich()
            Me.mcbverantwortlich.Focus()
            Me.mcbkube.SelectAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbverantwortlich.DataSource = Nothing
        Me.mcbverantwortlich.Items.Clear()
        Me.mcbverantwortlich.CheckNullValue = True
        Me.mcbverantwortlich.NullValueMessage = MyTxt.gettext(18)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        Me.mcbverantwortlich.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.DokumentID, 3, 0, 0, 0, Me.funktionsliste), False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.frmDokumentbearbeitung_Load Method

Private Sub frmDokumentbearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentbearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.On_Load = True
        w.save_stv = Globals.stv
        Me.TabControl2.Enabled = True
        If Me.CreateDocument Then
            progress.Bar1.Value = 10
            progress.Info.Text = "Vorbereitung Dokumenterstellung"
            progress.Refresh()
            progress.Show()
            progress.Refresh()

            Formular_Laden_Create_Document()
            progress.Bar1.Value = 90
            progress.Refresh()

            If Me.Partnernr <> "" Then
                If DivFnkt.Ist_Berechtigt(Me.Dokumenttypnr, Globals.MitarbeiterNr, Me.Partnernr, "", 2, 0, 0, 0) Then
                    Dim f As New FrmPartnersuche()
                    f.Dokumenterstellen = True
                    f.Dokumenttypnrnr = Me.Dokumenttypnr
                    f.Partner_Suche(Me.Partnernr)
                    Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
                    Me.txtPartnerInhaberNr.Text = f.PartnerNr
                    Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
                    Me.VIBeachten = f.VIBeachten
                    f.Dispose()
                    'edex Banklagernd
                    Banklagernd_Check()

                Else
                    MyMsg.show_standardmessage(30, MsgBoxStyle.Critical)
                    Me.Close()
                End If
            Else
                '                btnPartnerInhaber_Click(sender, e)
            End If
            If Val(Me.txtPartnerInhaberNr.Text) > 91000000 Then
                Me.cbKube.SelectedValue = Globals.MitarbeiterNr
            End If
            Me.cbmoeglicheStati.Visible = False
            Me.cbsave.Visible = False
        Else
            Formular_laden_Edit_Document()
            Dim bc As New DataTable()
            bc = Generic_Select(11)
            If bc.Rows.Count > 0 Then
                Me.BarcodeID = LTrim(Str(bc.Rows(0).Item(0)))
            End If
            bc.Dispose()
            Me.cbmoeglicheStati.Visible = True
            Me.cbsave.Visible = True
        End If
        Me.cdokumentwerteanzeigen.Visible = False

        Me.On_Load = False
        If Me.Dokument_Ist_Abgeschlossen Then bereiche_sperren()
        If Me.VIBeachten = True Then
            Me.PicVIBeachten.Visible = True
            Me.LabelVIBeachten.Visible = True
        Else
            Me.PicVIBeachten.Visible = False
            Me.LabelVIBeachten.Visible = False
        End If
        progress.Close()
        progress.Dispose()

        Me.Visible = True
        'Anzeige der Hinweismeldung, dass es sich um ein Einzeldokument handelt
        If MyMsg.Show_HinweisMessage(Me.Profilnr, 3, 96, 1) = False Then
            Exit Sub
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.get_current_Status Method

Private Function get_current_Status( _
   ByVal dokumentid As String _
) As Long

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function get_current_Status(ByVal dokumentid As String) As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_current_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@statustext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            get_current_Status = scmCmdToExecute.Parameters.Item("@currentstatus").Value
            Return get_current_Status
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.get_partnerzusteller Method

Private Function get_partnerzusteller( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_partnerzusteller(ByVal nrpar00 As Integer) As String
        Dim p As New edokadb.clsPartner()
        Dim p1 As New edokadb.clsPartner()
        Dim s As String
        s = ""
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        If p.iNRPAR00.ToString <> p.sNRPARAD.ToString Then
            Try
                p1.cpMainConnectionProvider = conn
                p1.iNRPAR00 = New SqlInt32(CType(p.sNRPARAD.Value, Int32))
                p1.SelectOne()
                s = p1.sNRPARAD.ToString + " " + p1.sBKPAR00.Value
            Catch
                s = ""
            End Try
        End If
        p.Dispose()
        p1.Dispose()
        get_partnerzusteller = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.mcbkube_Leave Method

Private Sub mcbkube_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbkube.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbkube_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbkube.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.mcbzust_Leave Method

Private Sub mcbzust_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbzust_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbzust.Leave
        If Me.On_Load Then Exit Sub
        refresh_team()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.mnuInfoEmpfaengerAdd_Click Method

Private Sub mnuInfoEmpfaengerAdd_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerAdd.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerAdd_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerAdd.Click
        Dim f As New frmInformationsEmpfaenger()
        f.Dokumenttypnr = Me.Dokumenttypnr
        If Me.CreateDocument = True Then
            f.fromDokumenttyp = True
        Else
            f.fromDokumenttyp = False
            f.dokumentid = Me.DokumentID
        End If
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungen.Rows
            Dim rowvals(9) As Object
            rowvals(0) = 0
            rowvals(1) = 0
            rowvals(2) = f.Empfaenger
            rowvals(3) = f.Empaengertext
            rowvals(4) = f.Meldungsnr
            rowvals(5) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(6) = f.Bemerkung
            rowvals(7) = f.Statusnr
            rowvals(8) = f.Statustext
            rowvals(9) = 1
            newrow = rc.Add(rowvals)
            Me.InfoMeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.mnuInfoEmpfaengerDelete_Click Method

Private Sub mnuInfoEmpfaengerDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoEmpfaengerDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoEmpfaengerDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoEmpfaengerDelete.Click
        Try
            Me.InfoMeldungList.Columns(9).Value = False
            Me.InfoMeldungList.Refresh()
            Me.TabControl2.Select()
            Me.InfoMeldungList.Select()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.rbZustaendigKube_Click Method

Private Sub rbZustaendigKube_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbZustaendigKube.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbZustaendigKube_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbZustaendigKube.CheckedChanged
        Me.mcbzust.Enabled = False
        Me.mcbkube.Enabled = True
        If Me.rbZustaendigKube.Checked = True Then
            Me.mcbkube.DataSource = Nothing
            Me.mcbkube.Items.Clear()
            Me.mcbkube.Fill_Data(Generic_Select(8), False)
            If Me.mcbkube.Items.Count = 0 Then
                Me.mcbkube.Text = ""
                Me.rbZustaendigKube.Checked = False
                Me.RBZustaendigZustaendiger.Checked = True
                MyMsg.show_standardmessage(24, MsgBoxStyle.Information)
                RBZustaendigZustaendiger_CheckedChanged(sender, e)
                Exit Sub
            End If
        End If
        Try
            Me.mcbkube.Focus()
            Me.mcbkube.SelectedIndex = 0
            Try
                Me.teamzustaendig = Me.mcbkube.SelectedValue
                Me.refresh_team()
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.settooltip Method

Private Sub settooltip()

Source code

[Visual Basic]
    Private Sub settooltip()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbmoeglicheStati, Globals.MyTxt.gettext(22000))
        ttip.SetToolTip(Me.btnPartnerInhaber, Globals.MyTxt.gettext(22001))
        ttip.SetToolTip(Me.Button1, Globals.MyTxt.gettext(22002))
        ttip.SetToolTip(Me.btntxtBemerkung, MyTxt.gettext(22007))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED.txtZustelladresse_Leave Method

Private Sub txtZustelladresse_Leave( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtZustelladresse_Leave(ByVal sender As System.Object, ByVal e As System.EventArgs)
        'If check_banklagernd() = True Then
        '    If MyMsg.Show_MessageYesNo(72) = MsgBoxResult.No Then
        '        Me.txtZustelladresse.Text = ""
        '        Me.txtAnredeZusteller.Text = ""
        '    End If
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentbearbeitungED Fields

frmDokumentbearbeitungED overview

Fields

field Button1
field Button2
field Button3
field Button4
field C1DateEdit1
field ColdList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field CurrentProfil
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DokWertList
field DokumentFunktionen
field DokumentFunktionenList
field DokumentID
field DokumentInfoMeldungen
field Dokumentersetzen
field Dokumentzuorndungen
field ErsetzenMoeglich
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LabelVIBeachten
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MnuDeleteNotiz
field MnuDokZuordnungAdd
field MnuDokzuordnungDelete
field MnuEditNotiz
field MnuNeueNotiz
field MnuShowDoc
field MnuValueSelect
field NewDokumentID
field Notizen
field Notizlist
field On_Load
field Panel1
field PicVIBeachten
field RBZustaendigZustaendiger
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TabControl2
field TabPage3
field TextBox1
field VIBeachten
field ZuordnungList
field btnCancel
field btnPartnerInhaber
field btnWeiter
field btntxtBemerkung
field cGesperrt
field cbKube
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbdokumentstatus
field cbmoeglicheStati
field cbsave
field cbteam
field cbzust
field cdokumentwerteanzeigen
field check_existing_address
field components
field cvertraulich
field drpMiatarbeiter
field firststatus
field funktionsliste
field i
field ii
field m_Partnernr
field m_barcodeid
field m_createdocument
field m_dokument_ist_abgeschlossen
field m_dokumentinfobearbeiten
field m_dokumenttypnr
field m_profile
field m_profilnr
field mcbkube
field mcbpostzustellung
field mcbstatus
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuInfoEmpfaengerAdd
field mnuInfoEmpfaengerDelete
field moeglichestati
field pnlBerechtigungen
field progress
field rbZustaendigKube
field savestatus
field saveverantwortlicher
field selectedstatus
field teamzustaendig
field txtAnredeZusteller
field txtBemerkung
field txtBemerkungVerantwortlicher
field txtBezeichnung
field txtPartnerInhaber
field txtPartnerInhaberNr
field txtPartnerZusteller
field txtZustelladresse
field txtstatus
field w
field zu_retournieren

See Also

frmDokumentbearbeitungED Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


C1DateEdit1 Variable

Friend WithEvents C1DateEdit1 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents C1DateEdit1 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


CurrentProfil Variable

Dim CurrentProfil As Long

Source code

[Visual Basic]
    Dim CurrentProfil As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DokWertList Variable

Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokWertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DokumentFunktionen Variable

Dim DokumentFunktionen As DataTable

Source code

[Visual Basic]
    Dim DokumentFunktionen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DokumentID Variable

Dim DokumentID As String

Source code

[Visual Basic]
    Dim DokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


DokumentInfoMeldungen Variable

Dim DokumentInfoMeldungen As DataTable

Source code

[Visual Basic]
    Dim DokumentInfoMeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Dokumentersetzen Variable

Dim Dokumentersetzen As DataTable

Source code

[Visual Basic]
    Dim Dokumentersetzen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Dokumentzuorndungen Variable

Dim Dokumentzuorndungen As DataTable

Source code

[Visual Basic]
    Dim Dokumentzuorndungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ErsetzenMoeglich Variable

Dim ErsetzenMoeglich As Boolean = False

Source code

[Visual Basic]
    Dim ErsetzenMoeglich As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox11 Variable

Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


LabelVIBeachten Variable

Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelVIBeachten As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuDokZuordnungAdd Variable

Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokZuordnungAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuDokzuordnungDelete Variable

Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokzuordnungDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuShowDoc Variable

Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


MnuValueSelect Variable

Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuValueSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


NewDokumentID Variable

Dim NewDokumentID As String

Source code

[Visual Basic]
    Dim NewDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Notizen Variable

Dim Notizen As DataTable

Source code

[Visual Basic]
    Dim Notizen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


PicVIBeachten Variable

Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PicVIBeachten As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


RBZustaendigZustaendiger Variable

Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


VIBeachten Variable

Dim VIBeachten As Boolean

Source code

[Visual Basic]
    Dim VIBeachten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ZuordnungList Variable

Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ZuordnungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


btntxtBemerkung Variable

Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btntxtBemerkung As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cGesperrt Variable

Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cGesperrt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbKube Variable

Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbKube As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbPostzustellung Variable

Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbmoeglicheStati Variable

Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbsave Variable

Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cbzust Variable

Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cdokumentwerteanzeigen Variable

Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cdokumentwerteanzeigen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


check_existing_address Variable

Dim check_existing_address As Boolean = False

Source code

[Visual Basic]
    Dim check_existing_address As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


cvertraulich Variable

Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cvertraulich As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


firststatus Variable

Dim firststatus As Integer

Source code

[Visual Basic]
    Dim firststatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


funktionsliste Variable

Dim funktionsliste As String

Source code

[Visual Basic]
    Dim funktionsliste As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


ii Variable

Dim ii As Integer

Source code

[Visual Basic]
    Dim ii As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_Partnernr Variable

Dim m_Partnernr As String

Source code

[Visual Basic]
    Dim m_Partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_createdocument Variable

Dim m_createdocument As Boolean

Source code

[Visual Basic]
    Dim m_createdocument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_dokument_ist_abgeschlossen Variable

Dim m_dokument_ist_abgeschlossen As Boolean

Source code

[Visual Basic]
    Dim m_dokument_ist_abgeschlossen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_dokumentinfobearbeiten Variable

Dim m_dokumentinfobearbeiten As Boolean

Source code

[Visual Basic]
    Dim m_dokumentinfobearbeiten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbkube Variable

Dim WithEvents mcbkube As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbkube As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbpostzustellung Variable

Dim WithEvents mcbpostzustellung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbpostzustellung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbstatus Variable

Dim WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbteam Variable

Dim WithEvents mcbteam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbteam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mcbzust Variable

Dim WithEvents mcbzust As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbzust As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mnuInfoEmpfaengerAdd Variable

Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


mnuInfoEmpfaengerDelete Variable

Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoEmpfaengerDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


moeglichestati Variable

Dim moeglichestati As DataTable

Source code

[Visual Basic]
    Dim moeglichestati As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


pnlBerechtigungen Variable

Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBerechtigungen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


progress Variable

Dim progress As New frmProgress()

Source code

[Visual Basic]
    Dim progress As New frmProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


rbZustaendigKube Variable

Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbZustaendigKube As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


savestatus Variable

Dim savestatus As Integer

Source code

[Visual Basic]
    Dim savestatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


saveverantwortlicher Variable

Dim saveverantwortlicher As Integer

Source code

[Visual Basic]
    Dim saveverantwortlicher As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


selectedstatus Variable

Dim selectedstatus As Integer

Source code

[Visual Basic]
    Dim selectedstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


teamzustaendig Variable

Dim teamzustaendig As Integer

Source code

[Visual Basic]
    Dim teamzustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtAnredeZusteller Variable

Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnredeZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtBemerkungVerantwortlicher Variable

Dim txtBemerkungVerantwortlicher As String

Source code

[Visual Basic]
    Dim txtBemerkungVerantwortlicher As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtPartnerInhaberNr Variable

Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaberNr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtZustelladresse Variable

Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtZustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


txtstatus Variable

Friend WithEvents txtstatus As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtstatus As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


w Variable

Dim w As New WordLib()

Source code

[Visual Basic]
    Dim w As New WordLib()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


zu_retournieren Variable

Dim zu_retournieren As Boolean

Source code

[Visual Basic]
    Dim zu_retournieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentbearbeitungED


frmDokumentberechtigung Class

For a list of all members of this type, see frmDokumentberechtigung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentberechtigung

Public Class frmDokumentberechtigung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentberechtigung Members


frmDokumentberechtigung Members

frmDokumentberechtigung overview

Constructors

constructor frmDokumentberechtigung Constructor

Properties

property Abschliessen
property Anzeigen
property Bearbeiten
property Dokumenttyp
property Funktionsgruppebezeichnung
property Funktionsgruppenr
property Loeschen
property Partnernr
property Vertraulich

Methods

method Berechtigunglist_FetchScrollTips
method CheckedListBox1_ItemCheck
method Dispose
method Generic_Select
method InitializeComponent
method Set_Berechtigungen
method berechtigunglist_DoubleClick
method berechtigunglist_MouseUp
method btnCancel_Click
method btnSave_Click
method frmDokumentberechtigung_Load

Fields

field CheckedListBox1
field GroupBox1
field GroupBox2
field berechtigunglist
field btnCancel
field btnSave
field components
field m_abschliessen
field m_anzeigen
field m_bearbeiten
field m_dokumenttyp
field m_erstellen
field m_funktionsgruppebezeichnung
field m_funktionsgruppenr
field m_loeschen
field m_partnernr
field m_vertraulich

See Also

frmDokumentberechtigung Class


frmDokumentberechtigung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung Properties

frmDokumentberechtigung overview

Properties

property Abschliessen
property Anzeigen
property Bearbeiten
property Dokumenttyp
property Funktionsgruppebezeichnung
property Funktionsgruppenr
property Loeschen
property Partnernr
property Vertraulich

See Also

frmDokumentberechtigung Class


frmDokumentberechtigung.Abschliessen Property

Property Abschliessen() As Boolean

Source code

[Visual Basic]
    Property Abschliessen() As Boolean
        Get
            Return m_abschliessen
        End Get
        Set(ByVal Value As Boolean)
            m_abschliessen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Anzeigen Property

Property Anzeigen() As Boolean

Source code

[Visual Basic]
    Property Anzeigen() As Boolean
        Get
            Return m_anzeigen
        End Get
        Set(ByVal Value As Boolean)
            m_anzeigen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Bearbeiten Property

Property Bearbeiten() As Boolean

Source code

[Visual Basic]
    Property Bearbeiten() As Boolean
        Get
            Return m_bearbeiten
        End Get
        Set(ByVal Value As Boolean)
            m_bearbeiten = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Dokumenttyp Property

Property Dokumenttyp() As Integer

Source code

[Visual Basic]
    Property Dokumenttyp() As Integer
        Get
            Return m_dokumenttyp
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Funktionsgruppebezeichnung Property

Property Funktionsgruppebezeichnung() As String

Source code

[Visual Basic]
    Property Funktionsgruppebezeichnung() As String
        Get
            Return m_funktionsgruppebezeichnung
        End Get
        Set(ByVal Value As String)
            m_funktionsgruppebezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Funktionsgruppenr Property

Property Funktionsgruppenr() As Integer

Source code

[Visual Basic]
    Property Funktionsgruppenr() As Integer
        Get
            Return m_funktionsgruppenr
        End Get
        Set(ByVal Value As Integer)
            m_funktionsgruppenr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Loeschen Property

Property Loeschen() As Boolean

Source code

[Visual Basic]
    Property Loeschen() As Boolean
        Get
            Return m_loeschen
        End Get
        Set(ByVal Value As Boolean)
            m_loeschen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Partnernr Property

Property Partnernr() As Integer

Source code

[Visual Basic]
    Property Partnernr() As Integer
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Integer)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Vertraulich Property

Property Vertraulich() As Boolean

Source code

[Visual Basic]
    Property Vertraulich() As Boolean
        Get
            Return m_vertraulich
        End Get
        Set(ByVal Value As Boolean)
            m_vertraulich = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung Methods

frmDokumentberechtigung overview

Methods

method Berechtigunglist_FetchScrollTips
method CheckedListBox1_ItemCheck
method Dispose
method Generic_Select
method InitializeComponent
method Set_Berechtigungen
method berechtigunglist_DoubleClick
method berechtigunglist_MouseUp
method btnCancel_Click
method btnSave_Click
method frmDokumentberechtigung_Load

See Also

frmDokumentberechtigung Class


frmDokumentberechtigung.Berechtigunglist_FetchScrollTips Method

Private Sub Berechtigunglist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles berechtigunglist.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Berechtigunglist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles berechtigunglist.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.berechtigunglist.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.CheckedListBox1_ItemCheck Method

Private Sub CheckedListBox1_ItemCheck( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemCheckEventArgs _
) Handles CheckedListBox1.ItemCheck

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckedListBox1_ItemCheck(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemCheckEventArgs) Handles CheckedListBox1.ItemCheck
        Dim i As Integer
        Dim bm As Long
        Select Case Me.CheckedListBox1.SelectedValue
            Case 1
                If e.NewValue = CheckState.Checked And Me.berechtigunglist.Columns(2).Value <> 1 Then
                    MyMsg.show_standardmessage(32, MsgBoxStyle.Critical)
                    e.NewValue = CheckState.Unchecked
                    Exit Sub
                End If
                Me.Anzeigen = e.NewValue
            Case 3
                If e.NewValue = CheckState.Checked And Me.berechtigunglist.Columns(4).Value <> 1 Then
                    MyMsg.show_standardmessage(32, MsgBoxStyle.Critical)
                    e.NewValue = CheckState.Unchecked
                    Exit Sub
                End If
                Me.Bearbeiten = e.NewValue
            Case 4
                If e.NewValue = CheckState.Checked And Me.berechtigunglist.Columns(5).Value <> 1 Then
                    MyMsg.show_standardmessage(32, MsgBoxStyle.Critical)
                    e.NewValue = CheckState.Unchecked

                    Exit Sub
                End If
                Me.Loeschen = e.NewValue
            Case 5
                If e.NewValue = CheckState.Checked And Me.berechtigunglist.Columns(6).Value <> 1 Then
                    MyMsg.show_standardmessage(32, MsgBoxStyle.Critical)
                    e.NewValue = CheckState.Unchecked
                    Exit Sub
                End If
                Me.Abschliessen = e.NewValue
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.pv_berechtigung_aktiv_select"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Select Case typ
                Case 1
                    Dim i As Integer
                    For i = 0 To dtToReturn.Rows.Count - 1
                        If dtToReturn.Rows(i).Item("berechtigungnr") = 2 Then
                            dtToReturn.Rows(i).Delete()
                        End If
                    Next
                Case Else
            End Select
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentberechtigung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.btnSave = New System.Windows.Forms.Button()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.berechtigunglist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.CheckedListBox1 = New System.Windows.Forms.CheckedListBox()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        CType(Me.berechtigunglist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox2.SuspendLayout()
        Me.SuspendLayout()
        '
        'btnSave
        '
        Me.btnSave.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnSave.Location = New System.Drawing.Point(592, 344)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.TabIndex = 0
        Me.btnSave.Text = "&Speichern"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.berechtigunglist})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(432, 360)
        Me.GroupBox1.TabIndex = 4
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Mögliche Funktionen"
        '
        'berechtigunglist
        '
        Me.berechtigunglist.AllowFilter = True
        Me.berechtigunglist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.berechtigunglist.AllowSort = False
        Me.berechtigunglist.AlternatingRows = True
        Me.berechtigunglist.CaptionHeight = 17
        Me.berechtigunglist.CollapseColor = System.Drawing.Color.Black
        Me.berechtigunglist.DataChanged = False
        Me.berechtigunglist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.berechtigunglist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.berechtigunglist.ExpandColor = System.Drawing.Color.Black
        Me.berechtigunglist.FilterBar = True
        Me.berechtigunglist.GroupByCaption = "Drag a column header here to group by that column"
        Me.berechtigunglist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.berechtigunglist.Location = New System.Drawing.Point(3, 16)
        Me.berechtigunglist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.berechtigunglist.Name = "berechtigunglist"
        Me.berechtigunglist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.berechtigunglist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.berechtigunglist.PreviewInfo.ZoomFactor = 75
        Me.berechtigunglist.PrintInfo.ShowOptionsDialog = False
        Me.berechtigunglist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.berechtigunglist.RowDivider = GridLines1
        Me.berechtigunglist.RowHeight = 15
        Me.berechtigunglist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.berechtigunglist.ScrollTips = True
        Me.berechtigunglist.Size = New System.Drawing.Size(426, 341)
        Me.berechtigunglist.TabIndex = 16
        Me.berechtigunglist.Text = "berechtigunglist"
        Me.berechtigunglist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorW" & _
        "idth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1"">" & _
        "<ClientRect>0, 0, 422, 337</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><C" & _
        "lientArea>0, 0, 422, 337</ClientArea></Blob>"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.CheckedListBox1})
        Me.GroupBox2.Location = New System.Drawing.Point(440, 8)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(232, 184)
        Me.GroupBox2.TabIndex = 5
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Berechtigungen für die gewählte Funktion"
        '
        'CheckedListBox1
        '
        Me.CheckedListBox1.Location = New System.Drawing.Point(8, 16)
        Me.CheckedListBox1.Name = "CheckedListBox1"
        Me.CheckedListBox1.Size = New System.Drawing.Size(216, 154)
        Me.CheckedListBox1.TabIndex = 4
        '
        'btnCancel
        '
        Me.btnCancel.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.btnCancel.Location = New System.Drawing.Point(512, 344)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.TabIndex = 6
        Me.btnCancel.Text = "&Abbruch"
        '
        'frmDokumentberechtigung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(674, 375)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnCancel, Me.GroupBox2, Me.GroupBox1, Me.btnSave})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentberechtigung"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Berechtigungseinschränkung für Dokumente"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.berechtigunglist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox2.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.Set_Berechtigungen Method

Private Sub Set_Berechtigungen()

Source code

[Visual Basic]
    Private Sub Set_Berechtigungen()
        Me.CheckedListBox1.SetItemChecked(0, False)
        Me.CheckedListBox1.SetItemChecked(1, False)
        Me.CheckedListBox1.SetItemChecked(2, False)
        Me.CheckedListBox1.SetItemChecked(3, False)
        If Me.berechtigunglist.Columns(2).Value = 1 Then Me.CheckedListBox1.SetItemChecked(0, True)
        If Me.berechtigunglist.Columns(4).Value = 1 Then Me.CheckedListBox1.SetItemChecked(1, True)
        If Me.berechtigunglist.Columns(5).Value = 1 Then Me.CheckedListBox1.SetItemChecked(2, True)
        If Me.berechtigunglist.Columns(6).Value = 1 Then Me.CheckedListBox1.SetItemChecked(3, True)
        Me.Anzeigen = Me.berechtigunglist.Columns(2).Value = 1
        Me.Bearbeiten = Me.berechtigunglist.Columns(4).Value = 1
        Me.Loeschen = Me.berechtigunglist.Columns(5).Value = 1
        Me.Abschliessen = Me.berechtigunglist.Columns(6).Value = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.berechtigunglist_DoubleClick Method

Private Sub berechtigunglist_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles berechtigunglist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub berechtigunglist_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles berechtigunglist.DoubleClick
        Try
            Dim i As Integer
            Me.Funktionsgruppenr = Me.berechtigunglist.Columns(1).Value
            Me.Funktionsgruppebezeichnung = Me.berechtigunglist.Columns(0).Value
            Me.DialogResult = DialogResult.OK
            Me.Close()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.berechtigunglist_MouseUp Method

Private Sub berechtigunglist_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles berechtigunglist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub berechtigunglist_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles berechtigunglist.MouseUp
        Set_Berechtigungen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.btnSave_Click Method

Private Sub btnSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        Try
            Dim i As Integer
            Me.Funktionsgruppenr = Me.berechtigunglist.Columns(1).Value
            Me.Funktionsgruppebezeichnung = Me.berechtigunglist.Columns(0).Value
            Me.Close()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung.frmDokumentberechtigung_Load Method

Private Sub frmDokumentberechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentberechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.CheckedListBox1.DataSource = Generic_Select(1)
        Me.CheckedListBox1.ValueMember = "berechtigungnr"
        Me.CheckedListBox1.DisplayMember = "bezeichnung"

        Dim d As New DataTable()
        If Me.Vertraulich Then
            d = DivFnkt.Berechtigte_Funktionen(Dokumenttyp, 0, 0, 0, 0, 0, 0, 1)
        Else
            d = DivFnkt.Berechtigte_Funktionen(Dokumenttyp, 0, 0, 0, 0, 0, 0, 0)
        End If

        Me.berechtigunglist.DataSource = d
        Me.berechtigunglist.DataMember = d.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.berechtigunglist, d, "berechtigungsliste")
        Me.berechtigunglist.Splits(0).DisplayColumns(1).Visible = False
        Set_Berechtigungen()
        Me.berechtigunglist.ScrollTips = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentberechtigung Fields

frmDokumentberechtigung overview

Fields

field CheckedListBox1
field GroupBox1
field GroupBox2
field berechtigunglist
field btnCancel
field btnSave
field components
field m_abschliessen
field m_anzeigen
field m_bearbeiten
field m_dokumenttyp
field m_erstellen
field m_funktionsgruppebezeichnung
field m_funktionsgruppenr
field m_loeschen
field m_partnernr
field m_vertraulich

See Also

frmDokumentberechtigung Class


CheckedListBox1 Variable

Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Source code

[Visual Basic]
    Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


berechtigunglist Variable

Friend WithEvents berechtigunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents berechtigunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_abschliessen Variable

Dim m_abschliessen As Boolean

Source code

[Visual Basic]
    Dim m_abschliessen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_anzeigen Variable

Dim m_anzeigen As Boolean

Source code

[Visual Basic]
    Dim m_anzeigen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_bearbeiten Variable

Dim m_bearbeiten As Boolean

Source code

[Visual Basic]
    Dim m_bearbeiten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_dokumenttyp Variable

Dim m_dokumenttyp As Integer

Source code

[Visual Basic]
    Dim m_dokumenttyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_erstellen Variable

Dim m_erstellen As Boolean

Source code

[Visual Basic]
    Dim m_erstellen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_funktionsgruppebezeichnung Variable

Dim m_funktionsgruppebezeichnung As String

Source code

[Visual Basic]
    Dim m_funktionsgruppebezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_funktionsgruppenr Variable

Dim m_funktionsgruppenr As Integer

Source code

[Visual Basic]
    Dim m_funktionsgruppenr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_loeschen Variable

Dim m_loeschen As Boolean

Source code

[Visual Basic]
    Dim m_loeschen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_partnernr Variable

Dim m_partnernr As Integer

Source code

[Visual Basic]
    Dim m_partnernr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


m_vertraulich Variable

Dim m_vertraulich As Boolean

Source code

[Visual Basic]
    Dim m_vertraulich As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentberechtigung


frmDokumentinformationen Class

For a list of all members of this type, see frmDokumentinformationen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentinformationen

Public Class frmDokumentinformationen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentinformationen Members


frmDokumentinformationen Members

frmDokumentinformationen overview

Constructors

constructor frmDokumentinformationen Constructor (Overloaded)

Properties

property Dokumentid
property Typ

Methods

method Cold_Index_lesen
method Dispose
method Dokumentfunktionen_Laden
method Dokumentinfomeldungen_laden
method Dokumentwert_lesen
method Dokumentzuordnungen_Laden
method ErsetzteDokumente_Laden
method Generic_Select
method InitializeComponent
method Mitarbeiter_Laden
method Notizen_Laden
method Status_lesen
method Statuslist_FetchRowStyle
method TabControl1_Click
method ToolBar1_ButtonClick
method Update_ColdListDokumente_Detail
method Update_Coldindex
method Update_DetailInformation
method Update_Details
method Update_DokumentInfoMeldung
method Update_Dokumentfunktionen
method Update_Dokumentzuordnung
method Update_Ersetzte_Dokumente
method Update_Notizen
method Update_Status
method frmDokumentinformationen_Load
method get_dokumentinfo
method isbck

Fields

field ColdList
field ColdListDokumente
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field ImageList1
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Notizlist
field Panel2
field RBStatusAktuell
field RBStatusHistory
field Splitter2
field Statuslist
field TabControl1
field TabControl2
field TabControl3
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field Zuordnungslist
field bcknr
field colornotset
field components
field drpMiatarbeiter
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_dokumentid
field m_typ
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field statushistory
field ttip
field txtDokumentid
field txtDokumenttyp
field txtErstelltAm
field txtPartnerInhaber
field txtPartnerZusteller
field txtReferenzzeile1
field txtReferenzzeile2
field txtValuta
field txtanzahlseiten
field txtisin
field txtnachvollziehbarkeit
field txtvalor
field txtvvextern1
field txtvvextern2

See Also

frmDokumentinformationen Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal dokumentid As String, ByVal typ As Integer)

See Also

frmDokumentinformationen | EDOKAApp


frmDokumentinformationen Properties

frmDokumentinformationen overview

Properties

property Dokumentid
property Typ

See Also

frmDokumentinformationen Class


frmDokumentinformationen.Dokumentid Property

Property Dokumentid() As String

Source code

[Visual Basic]
    Property Dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Typ Property

Property Typ() As Integer

Source code

[Visual Basic]
    Property Typ() As Integer
        Get
            Return m_typ
        End Get
        Set(ByVal Value As Integer)
            m_typ = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen Methods

frmDokumentinformationen overview

Methods

method Cold_Index_lesen
method Dispose
method Dokumentfunktionen_Laden
method Dokumentinfomeldungen_laden
method Dokumentwert_lesen
method Dokumentzuordnungen_Laden
method ErsetzteDokumente_Laden
method Generic_Select
method InitializeComponent
method Mitarbeiter_Laden
method Notizen_Laden
method Status_lesen
method Statuslist_FetchRowStyle
method TabControl1_Click
method ToolBar1_ButtonClick
method Update_ColdListDokumente_Detail
method Update_Coldindex
method Update_DetailInformation
method Update_Details
method Update_DokumentInfoMeldung
method Update_Dokumentfunktionen
method Update_Dokumentzuordnung
method Update_Ersetzte_Dokumente
method Update_Notizen
method Update_Status
method frmDokumentinformationen_Load
method get_dokumentinfo
method isbck

See Also

frmDokumentinformationen Class


frmDokumentinformationen.Cold_Index_lesen Method

Public Function Cold_Index_lesen( _
   ByVal indextyp As Integer, _
   ByVal iRoot As Integer _
) As DataTable

Parameters

indextyp
Required.
iRoot
Required.

Source code

[Visual Basic]
    Public Function Cold_Index_lesen(ByVal indextyp As Integer, ByVal iRoot As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Coldindex"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Root", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iRoot))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Dokumentfunktionen_Laden Method

Private Function Dokumentfunktionen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentfunktionen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Dokumentwert_lesen Method

Public Function Dokumentwert_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Dokumentwert_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Dokumentwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.ErsetzteDokumente_Laden Method

Private Function ErsetzteDokumente_Laden() As DataTable

Source code

[Visual Basic]
    Private Function ErsetzteDokumente_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_trefferliste_ersetztedokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        '===============================================================================
        'Description: Dynamische Datenherkuft
        'Input      : Typ
        'Output     : Datatable
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Trefferliste::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentinformationen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines8 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines9 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines10 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPageAllgemein = New System.Windows.Forms.TabPage()
        Me.pnlzensur1 = New System.Windows.Forms.Panel()
        Me.lblzensur1 = New System.Windows.Forms.Label()
        Me.TextBox18 = New System.Windows.Forms.TextBox()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.TextBox14 = New System.Windows.Forms.TextBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.TextBox13 = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.TextBox12 = New System.Windows.Forms.TextBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.TextBox11 = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TabPageStatus = New System.Windows.Forms.TabPage()
        Me.Statuslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.RBStatusHistory = New System.Windows.Forms.RadioButton()
        Me.RBStatusAktuell = New System.Windows.Forms.RadioButton()
        Me.TabPageDokumentwerte = New System.Windows.Forms.TabPage()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.pnlzensur2 = New System.Windows.Forms.Panel()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.lblzensur2 = New System.Windows.Forms.Label()
        Me.ColdListDokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.TextBox17 = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.TextBox16 = New System.Windows.Forms.TextBox()
        Me.TextBox15 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.TabPageZuordnung = New System.Windows.Forms.TabPage()
        Me.pnlzensur4 = New System.Windows.Forms.Panel()
        Me.lblzensur4 = New System.Windows.Forms.Label()
        Me.Zuordnungslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPageNotizen = New System.Windows.Forms.TabPage()
        Me.pnlzensur5 = New System.Windows.Forms.Panel()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.lblzensur5 = New System.Windows.Forms.Label()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPageInfomeldung = New System.Windows.Forms.TabPage()
        Me.pnlzensur3 = New System.Windows.Forms.Panel()
        Me.lblzensur3 = New System.Windows.Forms.Label()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPageBerechtigung = New System.Windows.Forms.TabPage()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.pnlzensur6 = New System.Windows.Forms.Panel()
        Me.lblzensur6 = New System.Windows.Forms.Label()
        Me.ErsetzteDokumenteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabControl3 = New System.Windows.Forms.TabControl()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.txtDokumenttyp = New System.Windows.Forms.TextBox()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.txtDokumentid = New System.Windows.Forms.TextBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.txtanzahlseiten = New System.Windows.Forms.TextBox()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.txtReferenzzeile2 = New System.Windows.Forms.TextBox()
        Me.txtReferenzzeile1 = New System.Windows.Forms.TextBox()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.txtnachvollziehbarkeit = New System.Windows.Forms.TextBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.txtisin = New System.Windows.Forms.TextBox()
        Me.txtvalor = New System.Windows.Forms.TextBox()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.txtValuta = New System.Windows.Forms.TextBox()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.txtErstelltAm = New System.Windows.Forms.TextBox()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.txtvvextern2 = New System.Windows.Forms.TextBox()
        Me.txtvvextern1 = New System.Windows.Forms.TextBox()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.TabControl1.SuspendLayout()
        Me.TabPageAllgemein.SuspendLayout()
        Me.pnlzensur1.SuspendLayout()
        Me.TabPageStatus.SuspendLayout()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        Me.TabPageDokumentwerte.SuspendLayout()
        Me.TabControl2.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage3.SuspendLayout()
        Me.TabPageZuordnung.SuspendLayout()
        Me.pnlzensur4.SuspendLayout()
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageNotizen.SuspendLayout()
        Me.pnlzensur5.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageInfomeldung.SuspendLayout()
        Me.pnlzensur3.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageBerechtigung.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        Me.pnlzensur6.SuspendLayout()
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl3.SuspendLayout()
        Me.TabPage4.SuspendLayout()
        Me.SuspendLayout()
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPageAllgemein, Me.TabPageStatus, Me.TabPageDokumentwerte, Me.TabPageZuordnung, Me.TabPageNotizen, Me.TabPageInfomeldung, Me.TabPageBerechtigung, Me.TabPage2})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Top
        Me.TabControl1.Location = New System.Drawing.Point(0, 25)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(786, 248)
        Me.TabControl1.TabIndex = 13
        '
        'TabPageAllgemein
        '
        Me.TabPageAllgemein.BackColor = System.Drawing.Color.Transparent
        Me.TabPageAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur1, Me.TextBox18, Me.Label19, Me.TextBox14, Me.Label15, Me.TextBox13, Me.Label14, Me.TextBox12, Me.Label12, Me.TextBox11, Me.Label11, Me.TextBox10, Me.Label10, Me.TextBox9, Me.Label9, Me.TextBox8, Me.Label8, Me.TextBox7, Me.Label7, Me.TextBox6, Me.Label6, Me.TextBox5, Me.Label5, Me.TextBox4, Me.Label4, Me.TextBox3, Me.Label3, Me.TextBox2, Me.Label2, Me.TextBox1, Me.Label1})
        Me.TabPageAllgemein.Location = New System.Drawing.Point(4, 22)
        Me.TabPageAllgemein.Name = "TabPageAllgemein"
        Me.TabPageAllgemein.Size = New System.Drawing.Size(778, 222)
        Me.TabPageAllgemein.TabIndex = 0
        Me.TabPageAllgemein.Text = "Allgemein"
        '
        'pnlzensur1
        '
        Me.pnlzensur1.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur1})
        Me.pnlzensur1.Location = New System.Drawing.Point(96, 184)
        Me.pnlzensur1.Name = "pnlzensur1"
        Me.pnlzensur1.Size = New System.Drawing.Size(512, 32)
        Me.pnlzensur1.TabIndex = 30
        '
        'lblzensur1
        '
        Me.lblzensur1.Location = New System.Drawing.Point(0, 8)
        Me.lblzensur1.Name = "lblzensur1"
        Me.lblzensur1.Size = New System.Drawing.Size(650, 23)
        Me.lblzensur1.TabIndex = 0
        Me.lblzensur1.Text = "Label21"
        '
        'TextBox18
        '
        Me.TextBox18.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox18.ForeColor = System.Drawing.Color.Black
        Me.TextBox18.Location = New System.Drawing.Point(96, 64)
        Me.TextBox18.Name = "TextBox18"
        Me.TextBox18.ReadOnly = True
        Me.TextBox18.Size = New System.Drawing.Size(208, 20)
        Me.TextBox18.TabIndex = 29
        Me.TextBox18.Text = ""
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(8, 64)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(88, 16)
        Me.Label19.TabIndex = 28
        Me.Label19.Text = "Barcodekleber"
        '
        'TextBox14
        '
        Me.TextBox14.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox14.ForeColor = System.Drawing.Color.Black
        Me.TextBox14.Location = New System.Drawing.Point(392, 160)
        Me.TextBox14.Name = "TextBox14"
        Me.TextBox14.ReadOnly = True
        Me.TextBox14.Size = New System.Drawing.Size(208, 20)
        Me.TextBox14.TabIndex = 27
        Me.TextBox14.Text = ""
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(312, 160)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(80, 23)
        Me.Label15.TabIndex = 26
        Me.Label15.Text = "Termin"
        '
        'TextBox13
        '
        Me.TextBox13.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox13.ForeColor = System.Drawing.Color.Black
        Me.TextBox13.Location = New System.Drawing.Point(96, 160)
        Me.TextBox13.Name = "TextBox13"
        Me.TextBox13.ReadOnly = True
        Me.TextBox13.Size = New System.Drawing.Size(208, 20)
        Me.TextBox13.TabIndex = 25
        Me.TextBox13.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 160)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(88, 23)
        Me.Label14.TabIndex = 24
        Me.Label14.Text = "Verantwortlich"
        '
        'TextBox12
        '
        Me.TextBox12.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox12.ForeColor = System.Drawing.Color.Black
        Me.TextBox12.Location = New System.Drawing.Point(96, 192)
        Me.TextBox12.Multiline = True
        Me.TextBox12.Name = "TextBox12"
        Me.TextBox12.ReadOnly = True
        Me.TextBox12.Size = New System.Drawing.Size(504, 24)
        Me.TextBox12.TabIndex = 23
        Me.TextBox12.Text = ""
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 192)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(88, 23)
        Me.Label12.TabIndex = 22
        Me.Label12.Text = "Bemerkung"
        '
        'TextBox11
        '
        Me.TextBox11.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox11.ForeColor = System.Drawing.Color.Black
        Me.TextBox11.Location = New System.Drawing.Point(96, 136)
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.ReadOnly = True
        Me.TextBox11.Size = New System.Drawing.Size(208, 20)
        Me.TextBox11.TabIndex = 21
        Me.TextBox11.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 136)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(88, 23)
        Me.Label11.TabIndex = 20
        Me.Label11.Text = "Dokumentstatus"
        '
        'TextBox10
        '
        Me.TextBox10.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox10.ForeColor = System.Drawing.Color.Black
        Me.TextBox10.Location = New System.Drawing.Point(392, 88)
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.ReadOnly = True
        Me.TextBox10.Size = New System.Drawing.Size(208, 20)
        Me.TextBox10.TabIndex = 19
        Me.TextBox10.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(312, 88)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 18
        Me.Label10.Text = "Mutiert durch"
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox9.ForeColor = System.Drawing.Color.Black
        Me.TextBox9.Location = New System.Drawing.Point(392, 64)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(208, 20)
        Me.TextBox9.TabIndex = 17
        Me.TextBox9.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(312, 64)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(80, 23)
        Me.Label9.TabIndex = 16
        Me.Label9.Text = "Mutiert am"
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox8.ForeColor = System.Drawing.Color.Black
        Me.TextBox8.Location = New System.Drawing.Point(392, 136)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(208, 20)
        Me.TextBox8.TabIndex = 15
        Me.TextBox8.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(312, 136)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(80, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Gesperrt durch"
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox7.ForeColor = System.Drawing.Color.Black
        Me.TextBox7.Location = New System.Drawing.Point(392, 112)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(208, 20)
        Me.TextBox7.TabIndex = 13
        Me.TextBox7.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(312, 112)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(80, 23)
        Me.Label7.TabIndex = 12
        Me.Label7.Text = "Gesperrt am"
        '
        'TextBox6
        '
        Me.TextBox6.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox6.ForeColor = System.Drawing.Color.Black
        Me.TextBox6.Location = New System.Drawing.Point(392, 40)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.ReadOnly = True
        Me.TextBox6.Size = New System.Drawing.Size(208, 20)
        Me.TextBox6.TabIndex = 11
        Me.TextBox6.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(312, 40)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 10
        Me.Label6.Text = "Erstellt durch"
        '
        'TextBox5
        '
        Me.TextBox5.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox5.ForeColor = System.Drawing.Color.Black
        Me.TextBox5.Location = New System.Drawing.Point(392, 16)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.ReadOnly = True
        Me.TextBox5.Size = New System.Drawing.Size(208, 20)
        Me.TextBox5.TabIndex = 9
        Me.TextBox5.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(312, 16)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 23)
        Me.Label5.TabIndex = 8
        Me.Label5.Text = "Erstellt am"
        '
        'TextBox4
        '
        Me.TextBox4.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox4.ForeColor = System.Drawing.Color.Black
        Me.TextBox4.Location = New System.Drawing.Point(96, 112)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(208, 20)
        Me.TextBox4.TabIndex = 7
        Me.TextBox4.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 112)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(88, 23)
        Me.Label4.TabIndex = 6
        Me.Label4.Text = "Bezeichnung"
        '
        'TextBox3
        '
        Me.TextBox3.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox3.ForeColor = System.Drawing.Color.Black
        Me.TextBox3.Location = New System.Drawing.Point(96, 88)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.ReadOnly = True
        Me.TextBox3.Size = New System.Drawing.Size(208, 20)
        Me.TextBox3.TabIndex = 5
        Me.TextBox3.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 88)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(88, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Dokumentart"
        '
        'TextBox2
        '
        Me.TextBox2.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox2.ForeColor = System.Drawing.Color.Black
        Me.TextBox2.Location = New System.Drawing.Point(96, 16)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.ReadOnly = True
        Me.TextBox2.Size = New System.Drawing.Size(208, 20)
        Me.TextBox2.TabIndex = 3
        Me.TextBox2.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(88, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Partner"
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox1.ForeColor = System.Drawing.Color.Black
        Me.TextBox1.Location = New System.Drawing.Point(96, 40)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(208, 20)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Dokument-ID"
        '
        'TabPageStatus
        '
        Me.TabPageStatus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Statuslist, Me.Panel2})
        Me.TabPageStatus.Location = New System.Drawing.Point(4, 22)
        Me.TabPageStatus.Name = "TabPageStatus"
        Me.TabPageStatus.Size = New System.Drawing.Size(896, 222)
        Me.TabPageStatus.TabIndex = 1
        Me.TabPageStatus.Text = "Dokumentstatus"
        Me.TabPageStatus.Visible = False
        '
        'Statuslist
        '
        Me.Statuslist.AllowArrows = False
        Me.Statuslist.AllowFilter = True
        Me.Statuslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Statuslist.AllowSort = True
        Me.Statuslist.BackColor = System.Drawing.Color.White
        Me.Statuslist.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.Statuslist.CaptionHeight = 17
        Me.Statuslist.CollapseColor = System.Drawing.Color.Transparent
        Me.Statuslist.DataChanged = False
        Me.Statuslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Statuslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Statuslist.ExpandColor = System.Drawing.Color.Transparent
        Me.Statuslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Statuslist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Statuslist.Location = New System.Drawing.Point(0, 32)
        Me.Statuslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Statuslist.Name = "Statuslist"
        Me.Statuslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Statuslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Statuslist.PreviewInfo.ZoomFactor = 75
        Me.Statuslist.PrintInfo.ShowOptionsDialog = False
        Me.Statuslist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Statuslist.RowDivider = GridLines1
        Me.Statuslist.RowHeight = 15
        Me.Statuslist.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.Statuslist.ScrollTips = False
        Me.Statuslist.Size = New System.Drawing.Size(896, 190)
        Me.Statuslist.TabIndex = 3
        Me.Statuslist.Text = "C1TrueDBGrid1"
        Me.Statuslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{BackColor:White;}HighlightRow{ForeColor:HighlightText;BackColor:Highl" & _
        "ight;}Style9{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignV" & _
        "ert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}St" & _
        "yle8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles" & _
        "><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaption" & _
        "Height=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelect" & _
        "orWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""" & _
        "1""><ClientRect>0, 0, 896, 190</ClientRect><BorderSide>0</BorderSide><CaptionStyl" & _
        "e parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><Eve" & _
        "nRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""" & _
        "Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group""" & _
        " me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle " & _
        "parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4""" & _
        " /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Recor" & _
        "dSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style " & _
        "parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedSty" & _
        "les><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style " & _
        "parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style par" & _
        "ent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style pare" & _
        "nt=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style pare" & _
        "nt=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""H" & _
        "eading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style par" & _
        "ent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1" & _
        "</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 896, 190</ClientArea></Blob>"
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBStatusHistory, Me.RBStatusAktuell})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(896, 32)
        Me.Panel2.TabIndex = 1
        '
        'RBStatusHistory
        '
        Me.RBStatusHistory.Location = New System.Drawing.Point(88, 6)
        Me.RBStatusHistory.Name = "RBStatusHistory"
        Me.RBStatusHistory.Size = New System.Drawing.Size(64, 24)
        Me.RBStatusHistory.TabIndex = 4
        Me.RBStatusHistory.Text = "History"
        '
        'RBStatusAktuell
        '
        Me.RBStatusAktuell.Checked = True
        Me.RBStatusAktuell.Location = New System.Drawing.Point(16, 6)
        Me.RBStatusAktuell.Name = "RBStatusAktuell"
        Me.RBStatusAktuell.Size = New System.Drawing.Size(56, 24)
        Me.RBStatusAktuell.TabIndex = 3
        Me.RBStatusAktuell.TabStop = True
        Me.RBStatusAktuell.Text = "Aktuell"
        '
        'TabPageDokumentwerte
        '
        Me.TabPageDokumentwerte.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl2})
        Me.TabPageDokumentwerte.Location = New System.Drawing.Point(4, 22)
        Me.TabPageDokumentwerte.Name = "TabPageDokumentwerte"
        Me.TabPageDokumentwerte.Size = New System.Drawing.Size(896, 222)
        Me.TabPageDokumentwerte.TabIndex = 2
        Me.TabPageDokumentwerte.Text = "Dokumentwerte"
        Me.TabPageDokumentwerte.Visible = False
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage3})
        Me.TabControl2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(896, 222)
        Me.TabControl2.TabIndex = 0
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur2, Me.ColdList, Me.Splitter2, Me.lblzensur2, Me.ColdListDokumente})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(677, 196)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Dokumentarchivierung"
        '
        'pnlzensur2
        '
        Me.pnlzensur2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur2.Location = New System.Drawing.Point(339, 0)
        Me.pnlzensur2.Name = "pnlzensur2"
        Me.pnlzensur2.Size = New System.Drawing.Size(338, 196)
        Me.pnlzensur2.TabIndex = 19
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AllowUpdateOnBlur = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(339, 0)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines2
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(338, 196)
        Me.ColdList.TabIndex = 18
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 334, 192</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 334, 192</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(336, 0)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(3, 196)
        Me.Splitter2.TabIndex = 17
        Me.Splitter2.TabStop = False
        '
        'lblzensur2
        '
        Me.lblzensur2.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur2.Name = "lblzensur2"
        Me.lblzensur2.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur2.TabIndex = 16
        Me.lblzensur2.Text = "Label21"
        '
        'ColdListDokumente
        '
        Me.ColdListDokumente.AllowFilter = True
        Me.ColdListDokumente.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdListDokumente.AllowSort = True
        Me.ColdListDokumente.AllowUpdate = False
        Me.ColdListDokumente.AllowUpdateOnBlur = False
        Me.ColdListDokumente.BackColor = System.Drawing.Color.White
        Me.ColdListDokumente.CaptionHeight = 17
        Me.ColdListDokumente.CollapseColor = System.Drawing.Color.Black
        Me.ColdListDokumente.Cursor = System.Windows.Forms.Cursors.Default
        Me.ColdListDokumente.DataChanged = False
        Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
        Me.ColdListDokumente.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdListDokumente.Dock = System.Windows.Forms.DockStyle.Left
        Me.ColdListDokumente.ExpandColor = System.Drawing.Color.Black
        Me.ColdListDokumente.FlatStyle = C1.Win.C1TrueDBGrid.FlatModeEnum.Popup
        Me.ColdListDokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdListDokumente.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ColdListDokumente.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdListDokumente.Name = "ColdListDokumente"
        Me.ColdListDokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdListDokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdListDokumente.PreviewInfo.ZoomFactor = 75
        Me.ColdListDokumente.PrintInfo.ShowOptionsDialog = False
        Me.ColdListDokumente.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.Transparent
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.None
        Me.ColdListDokumente.RowDivider = GridLines3
        Me.ColdListDokumente.RowHeight = 15
        Me.ColdListDokumente.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.ColdListDokumente.ScrollTips = False
        Me.ColdListDokumente.Size = New System.Drawing.Size(336, 196)
        Me.ColdListDokumente.TabIndex = 13
        Me.ColdListDokumente.Text = "C1TrueDBGrid1"
        Me.ColdListDokumente.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style13{}EvenRow{BackColor:White;}Selected{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Heading{Wrap:True;BackColor:Control;Border:Flat,ControlDark,0, 1," & _
        " 0, 1;ForeColor:ControlText;AlignVert:Center;}Inactive{ForeColor:InactiveCaption" & _
        "Text;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}OddRow{BackCo" & _
        "lor:224, 224, 224;}Footer{}Caption{AlignHorz:Center;}Style25{}Normal{BackColor:W" & _
        "hite;}Style26{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style24" & _
        "{}Style23{AlignHorz:Near;}Style22{}Style21{}Style20{}RecordSelector{AlignImage:C" & _
        "enter;}Style18{}Style19{}Style14{}Style15{}Style16{}Style17{}</Data></Styles><Sp" & _
        "lits><C1.Win.C1TrueDBGrid.HierarchicalView DefRecSelWidth=""16"" Name="""" CaptionHe" & _
        "ight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedC" & _
        "ellBorder"" RecordSelectorWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGrou" & _
        "p=""1""><ClientRect>0, 0, 332, 192</ClientRect><CaptionStyle parent=""Heading"" me=""" & _
        "Style23"" /><EditorStyle parent=""Editor"" me=""Style15"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style21"" /><FilterBarStyle parent=""FilterBar"" me=""Style26"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style17"" /><GroupStyle parent=""Group"" me=""Style25"" /><He" & _
        "adingStyle parent=""Heading"" me=""Style16"" /><HighLightRowStyle parent=""HighlightR" & _
        "ow"" me=""Style20"" /><InactiveStyle parent=""Inactive"" me=""Style19"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style22"" /><RecordSelectorStyle parent=""RecordSelector"" me=""" & _
        "Style24"" /><SelectedStyle parent=""Selected"" me=""Style18"" /><Style parent=""Normal" & _
        """ me=""Style14"" /></C1.Win.C1TrueDBGrid.HierarchicalView></Splits><NamedStyles><S" & _
        "tyle parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent" & _
        "=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""H" & _
        "eading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""No" & _
        "rmal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""No" & _
        "rmal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading" & _
        """ me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""C" & _
        "aption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horz" & _
        "Splits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 332, 192</ClientArea></Blob>"
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox17, Me.Label18, Me.TextBox16, Me.TextBox15, Me.Label17, Me.Label16})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(677, 196)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Diverse"
        Me.TabPage3.Visible = False
        '
        'TextBox17
        '
        Me.TextBox17.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox17.Location = New System.Drawing.Point(104, 72)
        Me.TextBox17.Name = "TextBox17"
        Me.TextBox17.ReadOnly = True
        Me.TextBox17.Size = New System.Drawing.Size(296, 20)
        Me.TextBox17.TabIndex = 5
        Me.TextBox17.Text = ""
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(8, 72)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(96, 23)
        Me.Label18.TabIndex = 4
        Me.Label18.Text = "Zuständig"
        '
        'TextBox16
        '
        Me.TextBox16.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox16.Location = New System.Drawing.Point(104, 32)
        Me.TextBox16.Name = "TextBox16"
        Me.TextBox16.ReadOnly = True
        Me.TextBox16.Size = New System.Drawing.Size(296, 20)
        Me.TextBox16.TabIndex = 3
        Me.TextBox16.Text = ""
        '
        'TextBox15
        '
        Me.TextBox15.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox15.Location = New System.Drawing.Point(104, 8)
        Me.TextBox15.Name = "TextBox15"
        Me.TextBox15.ReadOnly = True
        Me.TextBox15.Size = New System.Drawing.Size(296, 20)
        Me.TextBox15.TabIndex = 2
        Me.TextBox15.Text = ""
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 32)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(96, 23)
        Me.Label17.TabIndex = 1
        Me.Label17.Text = "Unterschrift rechts"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(8, 8)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 0
        Me.Label16.Text = "Unterschrift links"
        '
        'TabPageZuordnung
        '
        Me.TabPageZuordnung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur4, Me.Zuordnungslist})
        Me.TabPageZuordnung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageZuordnung.Name = "TabPageZuordnung"
        Me.TabPageZuordnung.Size = New System.Drawing.Size(896, 222)
        Me.TabPageZuordnung.TabIndex = 6
        Me.TabPageZuordnung.Text = "Dokumentzuordnungen"
        Me.TabPageZuordnung.Visible = False
        '
        'pnlzensur4
        '
        Me.pnlzensur4.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur4})
        Me.pnlzensur4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur4.Name = "pnlzensur4"
        Me.pnlzensur4.Size = New System.Drawing.Size(896, 222)
        Me.pnlzensur4.TabIndex = 15
        '
        'lblzensur4
        '
        Me.lblzensur4.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur4.Name = "lblzensur4"
        Me.lblzensur4.Size = New System.Drawing.Size(640, 23)
        Me.lblzensur4.TabIndex = 0
        Me.lblzensur4.Text = "Label21"
        '
        'Zuordnungslist
        '
        Me.Zuordnungslist.AllowFilter = True
        Me.Zuordnungslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Zuordnungslist.AllowSort = True
        Me.Zuordnungslist.AllowUpdate = False
        Me.Zuordnungslist.AllowUpdateOnBlur = False
        Me.Zuordnungslist.AlternatingRows = True
        Me.Zuordnungslist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Zuordnungslist.CaptionHeight = 17
        Me.Zuordnungslist.CollapseColor = System.Drawing.Color.Black
        Me.Zuordnungslist.DataChanged = False
        Me.Zuordnungslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Zuordnungslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Zuordnungslist.ExpandColor = System.Drawing.Color.Black
        Me.Zuordnungslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Zuordnungslist.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.Zuordnungslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Zuordnungslist.Name = "Zuordnungslist"
        Me.Zuordnungslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Zuordnungslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Zuordnungslist.PreviewInfo.ZoomFactor = 75
        Me.Zuordnungslist.PrintInfo.ShowOptionsDialog = False
        Me.Zuordnungslist.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Zuordnungslist.RowDivider = GridLines4
        Me.Zuordnungslist.RowHeight = 15
        Me.Zuordnungslist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Zuordnungslist.ScrollTips = False
        Me.Zuordnungslist.Size = New System.Drawing.Size(896, 222)
        Me.Zuordnungslist.TabIndex = 14
        Me.Zuordnungslist.Text = "C1TrueDBGrid1"
        Me.Zuordnungslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 892, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 892, 218</ClientArea></Blob>"
        '
        'TabPageNotizen
        '
        Me.TabPageNotizen.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur5, Me.Notizlist})
        Me.TabPageNotizen.Location = New System.Drawing.Point(4, 22)
        Me.TabPageNotizen.Name = "TabPageNotizen"
        Me.TabPageNotizen.Size = New System.Drawing.Size(896, 222)
        Me.TabPageNotizen.TabIndex = 5
        Me.TabPageNotizen.Text = "Notizen"
        Me.TabPageNotizen.Visible = False
        '
        'pnlzensur5
        '
        Me.pnlzensur5.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.lblzensur5})
        Me.pnlzensur5.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur5.Name = "pnlzensur5"
        Me.pnlzensur5.Size = New System.Drawing.Size(896, 222)
        Me.pnlzensur5.TabIndex = 14
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(322, 71)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines5
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'lblzensur5
        '
        Me.lblzensur5.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur5.Name = "lblzensur5"
        Me.lblzensur5.Size = New System.Drawing.Size(648, 23)
        Me.lblzensur5.TabIndex = 0
        Me.lblzensur5.Text = "Label21"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AllowUpdate = False
        Me.Notizlist.AllowUpdateOnBlur = False
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines6
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(896, 222)
        Me.Notizlist.TabIndex = 13
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 892, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 892, 218</ClientArea></Blob>"
        '
        'TabPageInfomeldung
        '
        Me.TabPageInfomeldung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur3, Me.InfoMeldungList})
        Me.TabPageInfomeldung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageInfomeldung.Name = "TabPageInfomeldung"
        Me.TabPageInfomeldung.Size = New System.Drawing.Size(896, 222)
        Me.TabPageInfomeldung.TabIndex = 4
        Me.TabPageInfomeldung.Text = "Informationsmeldungen"
        Me.TabPageInfomeldung.Visible = False
        '
        'pnlzensur3
        '
        Me.pnlzensur3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur3})
        Me.pnlzensur3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur3.Name = "pnlzensur3"
        Me.pnlzensur3.Size = New System.Drawing.Size(896, 222)
        Me.pnlzensur3.TabIndex = 13
        '
        'lblzensur3
        '
        Me.lblzensur3.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur3.Name = "lblzensur3"
        Me.lblzensur3.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur3.TabIndex = 0
        Me.lblzensur3.Text = "Label21"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AllowUpdateOnBlur = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.FetchRowStyles = True
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines7
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(896, 222)
        Me.InfoMeldungList.TabIndex = 12
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyle=""Dott" & _
        "edCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""" & _
        "1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 892, 218</ClientRect><BorderSide>" & _
        "0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""" & _
        "Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarSty" & _
        "le parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" />" & _
        "<GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Sty" & _
        "le2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle par" & _
        "ent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordS" & _
        "electorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selec" & _
        "ted"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.Me" & _
        "rgeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Norm" & _
        "al"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading""" & _
        " me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" m" & _
        "e=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""H" & _
        "ighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""" & _
        "OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" m" & _
        "e=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1" & _
        "</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>" & _
        "16</DefaultRecSelWidth><ClientArea>0, 0, 892, 218</ClientArea></Blob>"
        '
        'TabPageBerechtigung
        '
        Me.TabPageBerechtigung.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.TabPageBerechtigung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageBerechtigung.Name = "TabPageBerechtigung"
        Me.TabPageBerechtigung.Size = New System.Drawing.Size(896, 222)
        Me.TabPageBerechtigung.TabIndex = 7
        Me.TabPageBerechtigung.Text = "Berechtigungseinschränkung"
        Me.TabPageBerechtigung.Visible = False
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AllowUpdate = False
        Me.DokumentFunktionenList.AllowUpdateOnBlur = False
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images7"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines8.Color = System.Drawing.Color.DarkGray
        GridLines8.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines8
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(896, 222)
        Me.DokumentFunktionenList.TabIndex = 14
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 892, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 892, 218</ClientArea></Blob>"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur6, Me.ErsetzteDokumenteList})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(896, 222)
        Me.TabPage2.TabIndex = 8
        Me.TabPage2.Text = "Ersetzte Dokumente"
        Me.TabPage2.Visible = False
        '
        'pnlzensur6
        '
        Me.pnlzensur6.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur6})
        Me.pnlzensur6.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur6.Name = "pnlzensur6"
        Me.pnlzensur6.Size = New System.Drawing.Size(896, 222)
        Me.pnlzensur6.TabIndex = 14
        '
        'lblzensur6
        '
        Me.lblzensur6.Location = New System.Drawing.Point(16, 16)
        Me.lblzensur6.Name = "lblzensur6"
        Me.lblzensur6.Size = New System.Drawing.Size(616, 23)
        Me.lblzensur6.TabIndex = 0
        Me.lblzensur6.Text = "Label21"
        '
        'ErsetzteDokumenteList
        '
        Me.ErsetzteDokumenteList.AllowFilter = True
        Me.ErsetzteDokumenteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ErsetzteDokumenteList.AllowSort = True
        Me.ErsetzteDokumenteList.AllowUpdate = False
        Me.ErsetzteDokumenteList.AllowUpdateOnBlur = False
        Me.ErsetzteDokumenteList.AlternatingRows = True
        Me.ErsetzteDokumenteList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ErsetzteDokumenteList.CaptionHeight = 17
        Me.ErsetzteDokumenteList.CollapseColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.DataChanged = False
        Me.ErsetzteDokumenteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ErsetzteDokumenteList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ErsetzteDokumenteList.ExpandColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ErsetzteDokumenteList.Images.Add(CType(resources.GetObject("resource.Images8"), System.Drawing.Bitmap))
        Me.ErsetzteDokumenteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ErsetzteDokumenteList.Name = "ErsetzteDokumenteList"
        Me.ErsetzteDokumenteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.ZoomFactor = 75
        Me.ErsetzteDokumenteList.PrintInfo.ShowOptionsDialog = False
        Me.ErsetzteDokumenteList.RecordSelectorWidth = 16
        GridLines9.Color = System.Drawing.Color.DarkGray
        GridLines9.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ErsetzteDokumenteList.RowDivider = GridLines9
        Me.ErsetzteDokumenteList.RowHeight = 15
        Me.ErsetzteDokumenteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ErsetzteDokumenteList.ScrollTips = False
        Me.ErsetzteDokumenteList.Size = New System.Drawing.Size(896, 222)
        Me.ErsetzteDokumenteList.TabIndex = 13
        Me.ErsetzteDokumenteList.Text = "C1TrueDBGrid1"
        Me.ErsetzteDokumenteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 892, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 892, 218</ClientArea></Blob>"
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images9"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(576, 48)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines10.Color = System.Drawing.Color.DarkGray
        GridLines10.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines10
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(208, 48)
        Me.DokList.TabIndex = 26
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.Visible = False
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 204," & _
        " 44</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""Sty" & _
        "le10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRow" & _
        """ me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle p" & _
        "arent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingS" & _
        "tyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me=" & _
        """Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""O" & _
        "ddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /" & _
        "><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Style" & _
        "1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""" & _
        "Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foot" & _
        "er"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactiv" & _
        "e"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /" & _
        "><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" " & _
        "/><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelecto" & _
        "r"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" " & _
        "/></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modi" & _
        "fied</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 204, 4" & _
        "4</ClientArea></Blob>"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(786, 25)
        Me.ToolBar1.TabIndex = 27
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabControl3
        '
        Me.TabControl3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage4})
        Me.TabControl3.Dock = System.Windows.Forms.DockStyle.Top
        Me.TabControl3.Location = New System.Drawing.Point(0, 273)
        Me.TabControl3.Name = "TabControl3"
        Me.TabControl3.SelectedIndex = 0
        Me.TabControl3.Size = New System.Drawing.Size(786, 248)
        Me.TabControl3.TabIndex = 28
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtDokumenttyp, Me.Label32, Me.txtDokumentid, Me.Label31, Me.txtanzahlseiten, Me.Label30, Me.txtReferenzzeile2, Me.txtReferenzzeile1, Me.Label28, Me.Label29, Me.txtnachvollziehbarkeit, Me.Label27, Me.txtisin, Me.txtvalor, Me.Label25, Me.Label26, Me.txtValuta, Me.Label24, Me.txtErstelltAm, Me.Label23, Me.txtvvextern2, Me.txtvvextern1, Me.Label22, Me.Label21, Me.txtPartnerZusteller, Me.txtPartnerInhaber, Me.Label20, Me.Label13})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(778, 222)
        Me.TabPage4.TabIndex = 0
        Me.TabPage4.Text = "Allgemein"
        '
        'txtDokumenttyp
        '
        Me.txtDokumenttyp.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtDokumenttyp.ForeColor = System.Drawing.Color.Black
        Me.txtDokumenttyp.Location = New System.Drawing.Point(104, 8)
        Me.txtDokumenttyp.Name = "txtDokumenttyp"
        Me.txtDokumenttyp.ReadOnly = True
        Me.txtDokumenttyp.Size = New System.Drawing.Size(256, 20)
        Me.txtDokumenttyp.TabIndex = 29
        Me.txtDokumenttyp.Text = ""
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(8, 8)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(96, 23)
        Me.Label32.TabIndex = 28
        Me.Label32.Text = "Dokumenttyp"
        '
        'txtDokumentid
        '
        Me.txtDokumentid.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtDokumentid.ForeColor = System.Drawing.Color.Black
        Me.txtDokumentid.Location = New System.Drawing.Point(496, 152)
        Me.txtDokumentid.Name = "txtDokumentid"
        Me.txtDokumentid.ReadOnly = True
        Me.txtDokumentid.Size = New System.Drawing.Size(256, 20)
        Me.txtDokumentid.TabIndex = 27
        Me.txtDokumentid.Text = ""
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(392, 152)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(96, 23)
        Me.Label31.TabIndex = 26
        Me.Label31.Text = "Dokument-ID"
        '
        'txtanzahlseiten
        '
        Me.txtanzahlseiten.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtanzahlseiten.ForeColor = System.Drawing.Color.Black
        Me.txtanzahlseiten.Location = New System.Drawing.Point(496, 128)
        Me.txtanzahlseiten.Name = "txtanzahlseiten"
        Me.txtanzahlseiten.ReadOnly = True
        Me.txtanzahlseiten.Size = New System.Drawing.Size(256, 20)
        Me.txtanzahlseiten.TabIndex = 25
        Me.txtanzahlseiten.Text = ""
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(392, 128)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(104, 23)
        Me.Label30.TabIndex = 24
        Me.Label30.Text = "Anzahl Seiten"
        '
        'txtReferenzzeile2
        '
        Me.txtReferenzzeile2.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtReferenzzeile2.ForeColor = System.Drawing.Color.Black
        Me.txtReferenzzeile2.Location = New System.Drawing.Point(496, 32)
        Me.txtReferenzzeile2.Name = "txtReferenzzeile2"
        Me.txtReferenzzeile2.ReadOnly = True
        Me.txtReferenzzeile2.Size = New System.Drawing.Size(256, 20)
        Me.txtReferenzzeile2.TabIndex = 23
        Me.txtReferenzzeile2.Text = ""
        '
        'txtReferenzzeile1
        '
        Me.txtReferenzzeile1.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtReferenzzeile1.ForeColor = System.Drawing.Color.Black
        Me.txtReferenzzeile1.Location = New System.Drawing.Point(496, 8)
        Me.txtReferenzzeile1.Name = "txtReferenzzeile1"
        Me.txtReferenzzeile1.ReadOnly = True
        Me.txtReferenzzeile1.Size = New System.Drawing.Size(256, 20)
        Me.txtReferenzzeile1.TabIndex = 22
        Me.txtReferenzzeile1.Text = ""
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(392, 32)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(96, 23)
        Me.Label28.TabIndex = 21
        Me.Label28.Text = "Referenzzeile 1"
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(392, 8)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(96, 23)
        Me.Label29.TabIndex = 20
        Me.Label29.Text = "Referenzzeile 1"
        '
        'txtnachvollziehbarkeit
        '
        Me.txtnachvollziehbarkeit.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtnachvollziehbarkeit.ForeColor = System.Drawing.Color.Black
        Me.txtnachvollziehbarkeit.Location = New System.Drawing.Point(496, 104)
        Me.txtnachvollziehbarkeit.Name = "txtnachvollziehbarkeit"
        Me.txtnachvollziehbarkeit.ReadOnly = True
        Me.txtnachvollziehbarkeit.Size = New System.Drawing.Size(256, 20)
        Me.txtnachvollziehbarkeit.TabIndex = 19
        Me.txtnachvollziehbarkeit.Text = ""
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(392, 104)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(104, 23)
        Me.Label27.TabIndex = 18
        Me.Label27.Text = "Nachvollziehbarkeit"
        '
        'txtisin
        '
        Me.txtisin.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtisin.ForeColor = System.Drawing.Color.Black
        Me.txtisin.Location = New System.Drawing.Point(496, 80)
        Me.txtisin.Name = "txtisin"
        Me.txtisin.ReadOnly = True
        Me.txtisin.Size = New System.Drawing.Size(256, 20)
        Me.txtisin.TabIndex = 17
        Me.txtisin.Text = ""
        '
        'txtvalor
        '
        Me.txtvalor.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtvalor.ForeColor = System.Drawing.Color.Black
        Me.txtvalor.Location = New System.Drawing.Point(496, 56)
        Me.txtvalor.Name = "txtvalor"
        Me.txtvalor.ReadOnly = True
        Me.txtvalor.Size = New System.Drawing.Size(256, 20)
        Me.txtvalor.TabIndex = 16
        Me.txtvalor.Text = ""
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(392, 80)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(96, 23)
        Me.Label25.TabIndex = 15
        Me.Label25.Text = "ISIN-Nr"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(392, 56)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(96, 23)
        Me.Label26.TabIndex = 14
        Me.Label26.Text = "Valorennr"
        '
        'txtValuta
        '
        Me.txtValuta.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtValuta.ForeColor = System.Drawing.Color.Black
        Me.txtValuta.Location = New System.Drawing.Point(104, 104)
        Me.txtValuta.Name = "txtValuta"
        Me.txtValuta.ReadOnly = True
        Me.txtValuta.Size = New System.Drawing.Size(256, 20)
        Me.txtValuta.TabIndex = 13
        Me.txtValuta.Text = ""
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(8, 104)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(96, 23)
        Me.Label24.TabIndex = 12
        Me.Label24.Text = "Valutadatum"
        '
        'txtErstelltAm
        '
        Me.txtErstelltAm.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtErstelltAm.ForeColor = System.Drawing.Color.Black
        Me.txtErstelltAm.Location = New System.Drawing.Point(104, 80)
        Me.txtErstelltAm.Name = "txtErstelltAm"
        Me.txtErstelltAm.ReadOnly = True
        Me.txtErstelltAm.Size = New System.Drawing.Size(256, 20)
        Me.txtErstelltAm.TabIndex = 11
        Me.txtErstelltAm.Text = ""
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(8, 80)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(96, 23)
        Me.Label23.TabIndex = 10
        Me.Label23.Text = "Erstellt am"
        '
        'txtvvextern2
        '
        Me.txtvvextern2.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtvvextern2.ForeColor = System.Drawing.Color.Black
        Me.txtvvextern2.Location = New System.Drawing.Point(104, 176)
        Me.txtvvextern2.Name = "txtvvextern2"
        Me.txtvvextern2.ReadOnly = True
        Me.txtvvextern2.Size = New System.Drawing.Size(256, 20)
        Me.txtvvextern2.TabIndex = 9
        Me.txtvvextern2.Text = ""
        '
        'txtvvextern1
        '
        Me.txtvvextern1.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtvvextern1.ForeColor = System.Drawing.Color.Black
        Me.txtvvextern1.Location = New System.Drawing.Point(104, 152)
        Me.txtvvextern1.Name = "txtvvextern1"
        Me.txtvvextern1.ReadOnly = True
        Me.txtvvextern1.Size = New System.Drawing.Size(256, 20)
        Me.txtvvextern1.TabIndex = 8
        Me.txtvvextern1.Text = ""
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(8, 176)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(96, 23)
        Me.Label22.TabIndex = 7
        Me.Label22.Text = "VV Extern 2"
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(8, 152)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(96, 23)
        Me.Label21.TabIndex = 6
        Me.Label21.Text = "VV Extern 1"
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtPartnerZusteller.ForeColor = System.Drawing.Color.Black
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(104, 56)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(256, 20)
        Me.txtPartnerZusteller.TabIndex = 5
        Me.txtPartnerZusteller.Text = ""
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.txtPartnerInhaber.ForeColor = System.Drawing.Color.Black
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(104, 32)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(256, 20)
        Me.txtPartnerInhaber.TabIndex = 4
        Me.txtPartnerInhaber.Text = ""
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 56)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(96, 23)
        Me.Label20.TabIndex = 1
        Me.Label20.Text = "Partner Zusteller"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 32)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(96, 23)
        Me.Label13.TabIndex = 0
        Me.Label13.Text = "Partner Inhaber"
        '
        'frmDokumentinformationen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(786, 269)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl3, Me.TabControl1, Me.ToolBar1, Me.DokList})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Name = "frmDokumentinformationen"
        Me.Text = "Dokumentinformationen"
        Me.TabControl1.ResumeLayout(False)
        Me.TabPageAllgemein.ResumeLayout(False)
        Me.pnlzensur1.ResumeLayout(False)
        Me.TabPageStatus.ResumeLayout(False)
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        Me.TabPageDokumentwerte.ResumeLayout(False)
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage3.ResumeLayout(False)
        Me.TabPageZuordnung.ResumeLayout(False)
        Me.pnlzensur4.ResumeLayout(False)
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageNotizen.ResumeLayout(False)
        Me.pnlzensur5.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageInfomeldung.ResumeLayout(False)
        Me.pnlzensur3.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageBerechtigung.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        Me.pnlzensur6.ResumeLayout(False)
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl3.ResumeLayout(False)
        Me.TabPage4.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Mitarbeiter_Laden Method

Private Sub Mitarbeiter_Laden()

Source code

[Visual Basic]
    Private Sub Mitarbeiter_Laden()
        '===============================================================================
        'Description: Mitarbeiter in DRP Laden DropDown an Grid Binden und Mutierer übersetzen
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        conn.OpenConnection()
        If m_DTMitarbeiter Is Nothing Then
            m_DTMitarbeiter = Generic_Select(17)
        End If

        Me.drpMiatarbeiter.DataSource = m_DTMitarbeiter
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Status_lesen Method

Public Function Status_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Status_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            If Me.statushistory = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Statuslist_FetchRowStyle Method

Private Sub Statuslist_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles Statuslist.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles Statuslist.FetchRowStyle

        If Me.Statuslist.Columns("bezeichnung").CellValue(e.Row) = Me.TextBox11.Text Then
            If colornotset Then
                e.CellStyle.ForeColor = Red
                colornotset = False
            End If
        Else
            e.CellStyle.ForeColor = Black
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.TabControl1_Click Method

Private Sub TabControl1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControl1.Click

        Me.Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_ColdListDokumente_Detail Method

Private Sub Update_ColdListDokumente_Detail( _
   ByVal doenable As Boolean _
)

Parameters

doenable
Required.

Source code

[Visual Basic]
    Private Sub Update_ColdListDokumente_Detail(ByVal doenable As Boolean)
        Try
            Dim cd As DataTable
            If doenable Then Me.ColdList.Enabled = False
            cd = Cold_Index_lesen(Me.ColdListDokumente.Columns("indextypnr").Value, 0)
            Me.ColdList.DataSource = cd
            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, cd, "coldlist")
            Me.TextBox15.Text = Me.DokList.Columns("dokunterschriftlinks").Text
            Me.TextBox16.Text = Me.DokList.Columns("dokunterschriftrechts").Text
            Me.TextBox17.Text = Me.DokList.Columns("dokzustaendig").Text
            Me.ColdList.Enabled = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Coldindex Method

Private Sub Update_Coldindex()

Source code

[Visual Basic]
    Private Sub Update_Coldindex()
        Me.ColdListDokumente.Enabled = False
        Me.ColdList.Enabled = False
        Dim ds As New DataSet()
        Dim cd As DataTable
        Dim cdHierarchie As DataTable

        Dim iCnt As Integer
        Try

            Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal
            cd = Cold_Index_lesen(0, 1)
            cdHierarchie = Cold_Index_lesen(0, 0)
            '----------------------------------------------
            ds.Tables.Add(cd)
            ds.Tables.Add(cdHierarchie)

            Dim dr As DataRelation
            Dim dc1 As DataColumn = cd.Columns("TreeID")
            Dim dc2 As DataColumn = cdHierarchie.Columns("SubTreeID")
            Dim rel As New DataRelation("RelColdIndex", dc1, dc2)
            Try
                Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
            Catch ex As System.ArgumentException
                '  MsgBox(ex.Message)
            End Try

            ds.Relations.Add(rel)
            Me.ColdListDokumente.SetDataBinding(ds, ds.Tables(0).TableName)

            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdListDokumente, cd, "coldlistdokumente")
            If m_ExpandColdListDokumente < 0 Then m_ExpandColdListDokumente = 0
            If m_ExpandColdListDokumente < 1 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        Case "STATUSALT", "ARCHIVDATUMALT"
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                    End Select
                Next
            End If

            Update_ColdListDokumente_Detail(False)
            Me.ColdListDokumente.Enabled = True
            Me.ColdList.Enabled = True
        Catch ex As Exception
            '  MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_DetailInformation Method

Private Sub Update_DetailInformation()

Source code

[Visual Basic]
    Private Sub Update_DetailInformation()
        Globals.PerfMon.insert_entry("'-- Begin Dokumentdetails")
        Me.Notizlist.Enabled = False
        Me.InfoMeldungList.Enabled = False
        Me.Zuordnungslist.Enabled = False
        Me.DokumentFunktionenList.Enabled = False
        Me.Cursor = Cursors.WaitCursor
        Select Case Me.TabControl1.SelectedTab.Name
            Case "TabPageAllgemein"
                Update_Details()
            Case "TabPageDokumentwerte"
                Update_Coldindex()
            Case "TabPageArchivierung"
                'update_archivierung()
            Case "TabPageInfomeldung"
                Update_DokumentInfoMeldung()
            Case "TabPageZuordnung"
                Update_Dokumentzuordnung()
            Case "TabPageStatus"
                Update_Status()
            Case "TabPageNotizen"
                Update_Notizen()
            Case "TabPageBerechtigung"
                Update_Dokumentfunktionen()
            Case "TabPage2"
                Update_Ersetzte_Dokumente()
        End Select
        Me.Notizlist.Enabled = True
        Me.InfoMeldungList.Enabled = True
        Me.Zuordnungslist.Enabled = True
        Me.DokumentFunktionenList.Enabled = True
        Me.Cursor = Cursors.Default
        Update_Details()

        Dim d As DataTable
        Dim I As Integer
        Try
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            If Me.DokList.Columns("verantwortlich").Value <> Globals.MitarbeiterNr Then
                If d.Rows.Count = 0 And Globals.stv = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '           Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    Exit Sub
                End If
                If d.Rows(0).Item("anzeigen") = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '            Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    Exit Sub
                End If
                d.Dispose()
                '
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '         Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
            Else
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '                Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
            End If
        Catch
            Me.TabControl1.Visible = False
        End Try
        Globals.PerfMon.insert_entry("'-- Ende Dokumentdetails")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Details Method

Private Sub Update_Details()

Source code

[Visual Basic]
    Private Sub Update_Details()
        Try
            Dim xbck As String

            Me.TextBox1.Text = Me.DokList.Columns("Dokumentid").Value
            If Me.DokList.Columns("Bemerkung").Text Is System.DBNull.Value Then
                Me.TextBox12.Text = ""
            Else
                Me.TextBox12.Text = Me.DokList.Columns("Bemerkung").Value
                ttip.SetToolTip(Me.TextBox12, Me.TextBox12.Text)
            End If

            If isbck() Then
                xbck = LTrim(Str(Me.bcknr))
                While Len(xbck) < 10
                    xbck = "0" + xbck
                End While
                Me.TextBox18.Text = xbck
            Else
                Me.TextBox18.Text = ""
            End If
            Me.TextBox2.Text = Str(Me.DokList.Columns("PartnerNr").Value) + " " + Me.DokList.Columns("Partnerkurzbezeichnung").Value
            Me.TextBox3.Text = Me.DokList.Columns("Dokumentart").Value
            Me.TextBox4.Text = Me.DokList.Columns("Bezeichnung").Value
            Me.TextBox5.Text = Me.DokList.Columns("Erstellungsdatum").Value
            Me.TextBox6.Text = Me.DokList.Columns("DokErsteller").Value
            If Me.DokList.Columns("Sperrdatum").Value Is System.DBNull.Value Then Me.TextBox7.Text = "" Else Me.TextBox7.Text = Me.DokList.Columns("Sperrdatum").Value
            If Me.DokList.Columns("DokSperrung").Value Is System.DBNull.Value Then
                Me.TextBox8.Text = ""
                Me.TextBox7.Text = ""
            Else
                Me.TextBox8.Text = Me.DokList.Columns("DokSperrung").Value
            End If
            Me.TextBox9.Text = Me.DokList.Columns("Mutationsdatum").Value
            Me.TextBox10.Text = Me.DokList.Columns("DokMutierer").Value
            Me.TextBox11.Text = Me.DokList.Columns("Status").Value
            Me.TextBox13.Text = Me.DokList.Columns("DokVerantwortlich").Value
            Me.TextBox14.Text = ""
            If (Me.DokList.Columns("termin").Value Is System.DBNull.Value) Or (Year(Me.DokList.Columns("termin").Value) = 1900) Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            '            If Me.DokList.Columns("termin").Value Is System.DBNull.Value Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            Me.TabControl1.Visible = True
        Catch ex As Exception
            '      MsgBox(ex.Message)
            '     Me.TabControl1.Visible = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_DokumentInfoMeldung Method

Private Sub Update_DokumentInfoMeldung()

Source code

[Visual Basic]
    Private Sub Update_DokumentInfoMeldung()
        Dim dokumentinfomeldung As DataTable
        dokumentinfomeldung = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = dokumentinfomeldung
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, dokumentinfomeldung, "Dokumentinfomeldung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Dokumentfunktionen Method

Private Sub Update_Dokumentfunktionen()

Source code

[Visual Basic]
    Private Sub Update_Dokumentfunktionen()
        Dim Dokumentfunktionen As DataTable
        Dokumentfunktionen = Dokumentfunktionen_Laden()
        Me.DokumentFunktionenList.DataSource = Dokumentfunktionen
        Me.DokumentFunktionenList.DataMember = Dokumentfunktionen.TableName
        Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
        Me.DokumentFunktionenList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Dokumentfunktionen, "berechtigungseinschraenkung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Dokumentzuordnung Method

Private Sub Update_Dokumentzuordnung()

Source code

[Visual Basic]
    Private Sub Update_Dokumentzuordnung()
        Dim dokumentzuordnungen As DataTable
        Dim i As Integer
        dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.Zuordnungslist.DataSource = dokumentzuordnungen
        Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Translate = True
        Next
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Zuordnungslist, dokumentzuordnungen, "dokumentzuordnungentr")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Ersetzte_Dokumente Method

Private Sub Update_Ersetzte_Dokumente()

Source code

[Visual Basic]
    Private Sub Update_Ersetzte_Dokumente()
        Dim ed As DataTable
        ed = ErsetzteDokumente_Laden()
        Me.ErsetzteDokumenteList.DataSource = ed
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ErsetzteDokumenteList, ed, "ersetztedokumente")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Notizen Method

Private Sub Update_Notizen()

Source code

[Visual Basic]
    Private Sub Update_Notizen()
        Dim Notizen As DataTable
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        Mitarbeiter_Laden()         'koe 28.07.2004
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Notizen, "notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.Update_Status Method

Private Sub Update_Status()

Source code

[Visual Basic]
    Private Sub Update_Status()
        Try
            colornotset = True
            Dim st As DataTable
            st = Status_lesen()
            Me.Statuslist.FetchRowStyles = True
            Me.Statuslist.DataSource = Nothing
            Me.Statuslist.DataSource = st
            DivFnkt.SpaltenTitel_Aktualisieren(Me.Statuslist, st, "statushistory")
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.frmDokumentinformationen_Load Method

Private Sub frmDokumentinformationen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentinformationen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim d As New DataTable()
        d = get_dokumentinfo()
        If Me.Typ = 0 Then
            Me.DokList.DataSource = d
            Me.DokList.DataMember = d.TableName
            Me.Update_DetailInformation()
        Else
            Me.txtDokumenttyp.Text = d.Rows(0).Item("dokumenttyp")
            Me.txtPartnerInhaber.Text = d.Rows(0).Item("partnernr_inhaber") + " " + d.Rows(0).Item("partnername_inhaber")
            Me.txtPartnerZusteller.Text = d.Rows(0).Item("partnernr_zusteller") + " " + d.Rows(0).Item("partnername_zusteller")
            Me.txtReferenzzeile1.Text = d.Rows(0).Item("referenzzeile1")
            Me.txtReferenzzeile2.Text = d.Rows(0).Item("referenzzeile2")
            Me.txtErstelltAm.Text = d.Rows(0).Item("valutadatum")
            Me.txtValuta.Text = d.Rows(0).Item("valutadatum1")
            Me.txtvalor.Text = d.Rows(0).Item("valorennr")
            Me.txtisin.Text = d.Rows(0).Item("isinnr")
            Me.txtDokumentid.Text = d.Rows(0).Item("dokumentid")
            Me.txtanzahlseiten.Text = d.Rows(0).Item("anzahlseiten")
            Me.txtnachvollziehbarkeit.Text = d.Rows(0).Item("nachvollziehbarkeit")
            Me.txtvvextern1.Text = d.Rows(0).Item("vvextern1")
            Me.txtvvextern2.Text = d.Rows(0).Item("vvextern2")
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.get_dokumentinfo Method

Private Function get_dokumentinfo() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumentinfo() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_dokumentinfo"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Typ))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen.isbck Method

Private Function isbck() As Boolean

Source code

[Visual Basic]
    Private Function isbck() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_check_bck"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isbck", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@isbck").Value = 1 Then
                isbck = True
                Me.bcknr = scmCmdToExecute.Parameters("@bcknr").Value
            Else
                isbck = False
                Me.bcknr = 0
            End If

        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("CheckBCK:" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen Fields

frmDokumentinformationen overview

Fields

field ColdList
field ColdListDokumente
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field ImageList1
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Notizlist
field Panel2
field RBStatusAktuell
field RBStatusHistory
field Splitter2
field Statuslist
field TabControl1
field TabControl2
field TabControl3
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field Zuordnungslist
field bcknr
field colornotset
field components
field drpMiatarbeiter
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_dokumentid
field m_typ
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field statushistory
field ttip
field txtDokumentid
field txtDokumenttyp
field txtErstelltAm
field txtPartnerInhaber
field txtPartnerZusteller
field txtReferenzzeile1
field txtReferenzzeile2
field txtValuta
field txtanzahlseiten
field txtisin
field txtnachvollziehbarkeit
field txtvalor
field txtvvextern1
field txtvvextern2

See Also

frmDokumentinformationen Class


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ColdListDokumente Variable

Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ErsetzteDokumenteList Variable

Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


RBStatusAktuell Variable

Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


RBStatusHistory Variable

Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Statuslist Variable

Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabControl3 Variable

Friend WithEvents TabControl3 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl3 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageAllgemein Variable

Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageBerechtigung Variable

Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageDokumentwerte Variable

Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageInfomeldung Variable

Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageNotizen Variable

Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageStatus Variable

Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TabPageZuordnung Variable

Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox11 Variable

Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox12 Variable

Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox13 Variable

Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox14 Variable

Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox15 Variable

Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox16 Variable

Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox17 Variable

Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox18 Variable

Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


Zuordnungslist Variable

Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


bcknr Variable

Dim bcknr As Integer

Source code

[Visual Basic]
    Dim bcknr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


colornotset Variable

Dim colornotset As Boolean = False

Source code

[Visual Basic]
    Dim colornotset As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur1 Variable

Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur2 Variable

Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur3 Variable

Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur4 Variable

Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur5 Variable

Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


lblzensur6 Variable

Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


m_ColdListDokumenteDefaultWidth Variable

Dim m_ColdListDokumenteDefaultWidth As Integer = 336

Source code

[Visual Basic]
    Dim m_ColdListDokumenteDefaultWidth As Integer = 336           ' Breite des Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


m_DTMitarbeiter Variable

Dim m_DTMitarbeiter As DataTable

Source code

[Visual Basic]
    Dim m_DTMitarbeiter As DataTable            'koe 28.07.2004

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


m_ExpandColdListDokumente Variable

Dim m_ExpandColdListDokumente As Integer = 0

Source code

[Visual Basic]
    Dim m_ExpandColdListDokumente As Integer = 0            'koe Anzahl der Expandet Spalten in Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


m_typ Variable

Dim m_typ As Integer

Source code

[Visual Basic]
    Dim m_typ As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur1 Variable

Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur2 Variable

Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur3 Variable

Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur4 Variable

Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur5 Variable

Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


pnlzensur6 Variable

Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


statushistory Variable

Dim statushistory As Boolean

Source code

[Visual Basic]
    Dim statushistory As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


ttip Variable

Dim ttip As New ToolTip()

Source code

[Visual Basic]
    Dim ttip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtDokumentid Variable

Friend WithEvents txtDokumentid As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentid As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtDokumenttyp Variable

Friend WithEvents txtDokumenttyp As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumenttyp As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtErstelltAm Variable

Friend WithEvents txtErstelltAm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtErstelltAm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtReferenzzeile1 Variable

Friend WithEvents txtReferenzzeile1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReferenzzeile1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtReferenzzeile2 Variable

Friend WithEvents txtReferenzzeile2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReferenzzeile2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtValuta Variable

Friend WithEvents txtValuta As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtValuta As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtanzahlseiten Variable

Friend WithEvents txtanzahlseiten As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtanzahlseiten As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtisin Variable

Friend WithEvents txtisin As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtisin As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtnachvollziehbarkeit Variable

Friend WithEvents txtnachvollziehbarkeit As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnachvollziehbarkeit As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtvalor Variable

Friend WithEvents txtvalor As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtvalor As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtvvextern1 Variable

Friend WithEvents txtvvextern1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtvvextern1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


txtvvextern2 Variable

Friend WithEvents txtvvextern2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtvvextern2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentpaket Class

For a list of all members of this type, see frmDokumentpaket Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentpaket

Public Class frmDokumentpaket
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentpaket Members


frmDokumentpaket Members

frmDokumentpaket overview

Constructors

constructor frmDokumentpaket Constructor (Overloaded)

Properties

property InBearbeitung
property Profile
property Profilnr

Methods

method BtnHelp_Click
method Button1_Click
method C1TrueDBGrid1_FetchCellStyle
method ContextMenuDokTyp_Popup
method Dispose
method DokList_FetchRowStyle
method DokList_MouseDown
method Dokumente_Abarbeiten
method Generic_Select
method InitializeComponent
method Load_Dokumentpaket
method MenuItem1_Click
method MnuAddDok_Click
method MnuMark_Click
method MnuSaveAs_Click
method MnuShowDoc_Click
method MnuTrefferliste_Click
method MnuUnmark_Click
method PicHinweis_Click
method Refresh_data
method TagArt
method TagValue
method Timer1_Tick
method ToolBar1_ButtonClick
method barcodedokument_erstellen
method btnAbbruch_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method delete_gespeicherte_dpinstanz
method einzeldokument_erstellen
method frmDokumentpaket_Closing
method frmDokumentpaket_Load
method get_partnerzusteller
method get_uvmdaten
method mnuDPKopieren_Click
method mnuDPMAKopieren_Click
method normaldokument_erstellen

Fields

field BtnHelp
field Button1
field ColDokumenttypNr
field ContextMenuDokTyp
field ContextMenuDokument
field CurrentRow
field DP_Instanz
field DokList
field Dokumentpaketnr
field DokumenttypInBearbeitung
field Dokumenttyphacken
field Dokumenttypnummern
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field IndividuellesDP
field Label1
field Label16
field Label2
field MarkierteDT
field MenuItem1
field MenuItem2
field MenuItem5
field MnuAddDok
field MnuMark
field MnuSaveAs
field MnuShowDoc
field MnuTrefferliste
field MnuUnmark
field MnuVerwaltung
field NrPar00
field PicHinweis
field Timer1
field Timer2
field ToolBar1
field TreeVorlagen
field Wichtigerhinweis
field barcodeid
field btnAbbruch
field btnDPCopy
field btnDPInfo
field btnDPSave
field btnExit
field btnPartnerInhaber
field btnWeiter
field cbdokumentstatus
field components
field dd
field dokumentid
field dp_instanznr
field lblabgeschlossen
field lblhinweis
field m_InBearbeitung
field m_profile
field m_profilnr
field mnuDPKopieren
field mnuDPMAKopieren
field mnusaveStandard
field saveasidvDP
field savedata
field txtPartnerInhaber
field txtPartnerZusteller

See Also

frmDokumentpaket Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal dpvorlagenr As Integer, ByVal indivDP As Boolean, ByVal Partnernr As Integer)

[Visual Basic] Public Sub New(ByVal edex_dpinstanznr As Integer)

See Also

frmDokumentpaket | EDOKAApp


frmDokumentpaket Properties

frmDokumentpaket overview

Properties

property InBearbeitung
property Profile
property Profilnr

See Also

frmDokumentpaket Class


frmDokumentpaket.InBearbeitung Property

Property InBearbeitung() As Boolean

Source code

[Visual Basic]
    Property InBearbeitung() As Boolean
        Get
            Return m_InBearbeitung
        End Get
        Set(ByVal Value As Boolean)
            m_InBearbeitung = Value
            If Value = False Then
                Me.DokList.Enabled = True
                Me.btnAbbruch.Enabled = True
                Me.btnWeiter.Enabled = True
                Me.btnPartnerInhaber.Enabled = True
                Me.ToolBar1.Enabled = True
            Else
                Me.DokList.Enabled = False
                Me.btnAbbruch.Enabled = False
                Me.btnWeiter.Enabled = False
                Me.btnPartnerInhaber.Enabled = False
                Me.ToolBar1.Enabled = False
            End If
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Profilnr Property

Property Profilnr() As Integer

Source code

[Visual Basic]
    Property Profilnr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket Methods

frmDokumentpaket overview

Methods

method BtnHelp_Click
method Button1_Click
method C1TrueDBGrid1_FetchCellStyle
method ContextMenuDokTyp_Popup
method Dispose
method DokList_FetchRowStyle
method DokList_MouseDown
method Dokumente_Abarbeiten
method Generic_Select
method InitializeComponent
method Load_Dokumentpaket
method MenuItem1_Click
method MnuAddDok_Click
method MnuMark_Click
method MnuSaveAs_Click
method MnuShowDoc_Click
method MnuTrefferliste_Click
method MnuUnmark_Click
method PicHinweis_Click
method Refresh_data
method TagArt
method TagValue
method Timer1_Tick
method ToolBar1_ButtonClick
method barcodedokument_erstellen
method btnAbbruch_Click
method btnPartnerInhaber_Click
method btnWeiter_Click
method delete_gespeicherte_dpinstanz
method einzeldokument_erstellen
method frmDokumentpaket_Closing
method frmDokumentpaket_Load
method get_partnerzusteller
method get_uvmdaten
method mnuDPKopieren_Click
method mnuDPMAKopieren_Click
method normaldokument_erstellen

See Also

frmDokumentpaket Class


frmDokumentpaket.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentpaketdialog")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            If Me.NrPar00 > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.NrPar00
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.NrPar00
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.C1TrueDBGrid1_FetchCellStyle Method

Private Sub C1TrueDBGrid1_FetchCellStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs _
) Handles DokList.FetchCellStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs) Handles DokList.FetchCellStyle
        If Me.DokList.Columns(3).CellValue(e.Row) <> 59 Then
            e.CellStyle.BackColor = Color.LightGray
        End If
        e.CellStyle.Borders.BorderType = C1.Win.C1TrueDBGrid.BorderTypeEnum.Flat
        e.CellStyle.Borders.Color = System.Drawing.Color.White
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.ContextMenuDokTyp_Popup Method

Private Sub ContextMenuDokTyp_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenuDokTyp.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenuDokTyp_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenuDokTyp.Popup
        If Me.IndividuellesDP = True Then
            Me.MnuVerwaltung.Visible = True
            Me.mnusaveStandard.Visible = False
        Else
            Me.mnusaveStandard.Visible = True
            Me.MnuVerwaltung.Visible = False
        End If
        If Me.DokList.Columns("Erstellung").Value = 1 Then
            Me.MnuMark.Enabled = True
            Me.MnuUnmark.Enabled = True
        Else
            Me.MnuMark.Enabled = False
            Me.MnuUnmark.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.DokList_FetchRowStyle Method

Private Sub DokList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle
        If Me.DokList.Columns(2).CellValue(e.Row) <> 0 Then
            Dim fnt As Font
        Else
            Dim fnt As Font
            fnt = New Font("Courier New", 8)
            e.CellStyle.Font = fnt
        End If
        If Me.DokList.Columns("aktiv").CellValue(e.Row) = 0 And Me.DokList.Columns("dokumentid").CellValue(e.Row) = "0" Then
            Dim FNT As Font = e.CellStyle.Font
            e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
        End If
        If Me.DokList.Columns("dokumentid").CellValue(e.Row) = "0" And Me.DokList.Columns("Erstellung").CellValue(e.Row) = 0 Then
            e.CellStyle.ForeColor = Color.Gray
        End If
        Me.DokList.RecordSelectorStyle.Borders.BorderType = C1.Win.C1TrueDBGrid.BorderTypeEnum.None
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
        Try
            If Me.DokList.Columns("dOKUMENTID").Text = "0" Then
                Me.DokList.ContextMenu = Me.ContextMenuDokTyp
            Else
                Me.DokList.ContextMenu = Me.ContextMenuDokument
            End If
        Catch

        End Try

        If Me.DokList.ColContaining(e.X) <> 2 Then Exit Sub

        'Beim Klick der rechten Maustaste die Funktion verlassen
        'sonst ändern des Wertes in der Spalte "Haken"
        If e.Button = MouseButtons.Right Then Exit Sub
        Try
            If Me.DokList.Columns(2).Value = 0 Then Exit Sub
            If Me.DokList.Columns(2).Value = 1 Then
                If Me.DokList.Columns("Erstellung").Value = 1 And Me.DokList.Columns("aktiv").Value = 1 Then
                    Me.DokList.Columns(2).Value = 2
                End If
            Else
                If Me.DokList.Columns("Erstellung").Value = 1 And Me.DokList.Columns("aktiv").Value = 1 Then
                    Me.DokList.Columns(2).Value = 1
                End If
            End If
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark - 1
            Catch
            End Try
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark + 1
            Catch
            End Try
            Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
        Catch
        End Try

        Me.lblabgeschlossen.Visible = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Dokumente_Abarbeiten Method

Private Sub Dokumente_Abarbeiten( _
   ByVal check_bearbeitungsende As Boolean _
)

Parameters

check_bearbeitungsende
Required.

Source code

[Visual Basic]
    Private Sub Dokumente_Abarbeiten(ByVal check_bearbeitungsende As Boolean)
        Dim i As Integer
        Dim showbc As Boolean
        ' Me.savedata = Me.DokList.DataSource

        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        Globals.bckdokument = False
        For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
            If Me.DokList.Columns(2).CellValue(i) = 2 Then
                dt.iDokumenttypnr = New SqlInt32(CType(Me.DokList.Columns("dokumenttypnr").CellValue(i), Int32))
                dt.cpMainConnectionProvider = conn
                dt.SelectOne()
                If dt.bAktiv.Value = True Then
                    If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = False Then showbc = True
                    If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = True Then
                        Dim f As New frmbcquestion()
                        f.ShowDialog()
                        If f.DialogResult = DialogResult.Abort Then showbc = True
                        If f.DialogResult = DialogResult.OK Then showbc = False
                        f.Dispose()
                    End If
                    If showbc Then
                        Dim f As New frmBarcodeKleber()
                        f.TopMost = True
                        f.ShowDialog()
                        If f.DialogResult = DialogResult.Abort Then
                            Exit Sub
                        Else
                            If f.DialogResult = DialogResult.OK Then
                                Me.barcodeid = f.BarcodeID
                                Globals.bckdokument = True
                            Else
                            End If
                        End If
                    End If
                    Me.DokList.Bookmark = i
                    Me.DokumenttypInBearbeitung = dt.iDokumenttypnr.Value
                    dt.SelectOne()
                    If Globals.bckdokument = True Then
                        If barcodedokument_erstellen(Me.barcodeid) = True Then
                            Me.DokList.Bookmark = i
                            Me.DokList.Columns(2).Value = 1
                            Me.InBearbeitung = False
                            showbc = False
                            Globals.bckdokument = False
                            Me.dokumentid = "Timer2HandleBC"
                            Me.Timer2.Enabled = True
                            Exit Sub
                        End If
                    Else
                        If dt.bNurnative.Value = True Then
                            If einzeldokument_erstellen() = True Then
                                Me.DokList.Bookmark = i
                                Me.DokList.Columns(2).Value = 1
                                Me.InBearbeitung = False
                                MyMsg.show_standardmessage(413, MsgBoxStyle.Information)
                                Me.dokumentid = "Timer2HandleED"
                                Me.Timer2.Enabled = True
                                Exit Sub
                            End If
                        Else
                            If normaldokument_erstellen(i) = True Then
                                Me.DokList.Bookmark = i
                                Me.DokList.Columns(2).Value = 3
                                Me.InBearbeitung = True
                                Me.Timer1.Enabled = True
                            End If
                        End If
                        Exit For
                    End If
                Else
                    MsgBox("Der ausgewählte Dokumenttyp '" + dt.sBezeichnung.Value + "' ist nicht mehr aktiv.", MsgBoxStyle.Information)
                End If
            End If
        Next
        dt.Dispose()
        Me.CurrentRow = i
        Try
            If Me.MarkierteDT.Count = 1 And Me.MarkierteDT.Item(1) = 999999 And Me.InBearbeitung = False Then
                Me.lblabgeschlossen.Visible = True
                If Me.DP_Instanz = True Then
                    delete_gespeicherte_dpinstanz(Me.dp_instanznr)
                End If
            Else
                Me.lblabgeschlossen.Visible = False
            End If
        Catch
            Me.lblabgeschlossen.Visible = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "edex_sp_dokumentpaketvorlagen_select"
            Case 2, 3
                scmCmdToExecute.CommandText = "edex_sp_dokumentpaket_dokumente_select"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_message_getPartner_Profil"
            Case 5
                scmCmdToExecute.CommandText = "dbo.pv_profil_select"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Select Case typ
            Case 1
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentpaketnr))
            Case 2
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypen", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumenttypInBearbeitung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NrPar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            Case 3
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypen", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnummern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NrPar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dpnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentpaketnr))
            Case 4
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            Case 5
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
        End Select

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentpaket))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnExit = New System.Windows.Forms.ToolBarButton()
        Me.btnDPSave = New System.Windows.Forms.ToolBarButton()
        Me.btnDPCopy = New System.Windows.Forms.ToolBarButton()
        Me.btnDPInfo = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.txtPartnerZusteller = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.cbdokumentstatus = New System.Windows.Forms.ComboBox()
        Me.btnPartnerInhaber = New System.Windows.Forms.Button()
        Me.txtPartnerInhaber = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.TreeVorlagen = New System.Windows.Forms.TreeView()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ContextMenuDokTyp = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MnuAddDok = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MnuVerwaltung = New System.Windows.Forms.MenuItem()
        Me.mnuDPKopieren = New System.Windows.Forms.MenuItem()
        Me.MnuSaveAs = New System.Windows.Forms.MenuItem()
        Me.mnuDPMAKopieren = New System.Windows.Forms.MenuItem()
        Me.mnusaveStandard = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MnuMark = New System.Windows.Forms.MenuItem()
        Me.MnuUnmark = New System.Windows.Forms.MenuItem()
        Me.ContextMenuDokument = New System.Windows.Forms.ContextMenu()
        Me.MnuShowDoc = New System.Windows.Forms.MenuItem()
        Me.MnuTrefferliste = New System.Windows.Forms.MenuItem()
        Me.PicHinweis = New System.Windows.Forms.PictureBox()
        Me.lblhinweis = New System.Windows.Forms.Label()
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.ImageList4 = New System.Windows.Forms.ImageList(Me.components)
        Me.lblabgeschlossen = New System.Windows.Forms.Label()
        Me.Timer2 = New System.Windows.Forms.Timer(Me.components)
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnExit, Me.btnDPSave, Me.btnDPCopy, Me.btnDPInfo})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(568, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnExit
        '
        Me.btnExit.ImageIndex = 0
        '
        'btnDPSave
        '
        Me.btnDPSave.ImageIndex = 1
        Me.btnDPSave.Visible = False
        '
        'btnDPCopy
        '
        Me.btnDPCopy.ImageIndex = 3
        Me.btnDPCopy.Visible = False
        '
        'btnDPInfo
        '
        Me.btnDPInfo.ImageIndex = 2
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'txtPartnerZusteller
        '
        Me.txtPartnerZusteller.Location = New System.Drawing.Point(112, 64)
        Me.txtPartnerZusteller.Name = "txtPartnerZusteller"
        Me.txtPartnerZusteller.ReadOnly = True
        Me.txtPartnerZusteller.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerZusteller.TabIndex = 45
        Me.txtPartnerZusteller.Text = ""
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(376, 40)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 47
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(8, 88)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 51
        Me.Label16.Text = "Dokumentstatus"
        '
        'cbdokumentstatus
        '
        Me.cbdokumentstatus.ItemHeight = 13
        Me.cbdokumentstatus.Items.AddRange(New Object() {"In Bearbeitung", "Zweiter Status der Sequenz"})
        Me.cbdokumentstatus.Location = New System.Drawing.Point(112, 88)
        Me.cbdokumentstatus.Name = "cbdokumentstatus"
        Me.cbdokumentstatus.Size = New System.Drawing.Size(240, 21)
        Me.cbdokumentstatus.TabIndex = 48
        '
        'btnPartnerInhaber
        '
        Me.btnPartnerInhaber.Image = CType(resources.GetObject("btnPartnerInhaber.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInhaber.Location = New System.Drawing.Point(352, 40)
        Me.btnPartnerInhaber.Name = "btnPartnerInhaber"
        Me.btnPartnerInhaber.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInhaber.TabIndex = 46
        '
        'txtPartnerInhaber
        '
        Me.txtPartnerInhaber.Location = New System.Drawing.Point(112, 40)
        Me.txtPartnerInhaber.Name = "txtPartnerInhaber"
        Me.txtPartnerInhaber.ReadOnly = True
        Me.txtPartnerInhaber.Size = New System.Drawing.Size(240, 20)
        Me.txtPartnerInhaber.TabIndex = 44
        Me.txtPartnerInhaber.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 64)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 50
        Me.Label2.Text = "Partner-Zusteller"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 49
        Me.Label1.Text = "Partner-Inhaber"
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(544, 6)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 61
        '
        'TreeVorlagen
        '
        Me.TreeVorlagen.CheckBoxes = True
        Me.TreeVorlagen.ImageList = Me.ImageList3
        Me.TreeVorlagen.Location = New System.Drawing.Point(8, 120)
        Me.TreeVorlagen.Name = "TreeVorlagen"
        Me.TreeVorlagen.Size = New System.Drawing.Size(520, 232)
        Me.TreeVorlagen.TabIndex = 62
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(8, 360)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.TabIndex = 63
        Me.btnAbbruch.Text = "Schliessen"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(488, 360)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.TabIndex = 64
        Me.btnWeiter.Text = "Weiter >"
        '
        'DokList
        '
        Me.DokList.AllowArrows = False
        Me.DokList.AllowColMove = False
        Me.DokList.AllowColSelect = False
        Me.DokList.AllowFilter = False
        Me.DokList.AllowRowSelect = False
        Me.DokList.AllowSort = False
        Me.DokList.AllowUpdate = False
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.BackColor = System.Drawing.Color.White
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ColumnHeaders = False
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.ExposeCellMode = C1.Win.C1TrueDBGrid.ExposeCellModeEnum.ScrollNever
        Me.DokList.FetchRowStyles = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(8, 120)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.NoMarquee
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 20
        GridLines1.Color = System.Drawing.Color.White
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.None
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.DokList.ScrollTips = False
        Me.DokList.Size = New System.Drawing.Size(552, 232)
        Me.DokList.TabIndex = 65
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.Visible = False
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:White;}Footer{}Caption{AlignHorz:" & _
        "Center;Border:None,,0, 0, 0, 0;}Style27{}Normal{BackColor:White;}Style26{}Highli" & _
        "ghtRow{ForeColor:HighlightText;BackColor:White;}Style10{AlignHorz:Near;}Editor{}" & _
        "RecordSelector{AlignImage:Center;BackColor:ActiveCaptionText;}Style9{}Style8{}St" & _
        "yle3{}Style2{}Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Cent" & _
        "er;}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView AllowColMove=" & _
        """False"" AllowColSelect=""False"" AllowRowSelect=""False"" Name="""" AllowRowSizing=""In" & _
        "dividualRows"" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=" & _
        """17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyle=""NoMarquee"" Reco" & _
        "rdSelectorWidth=""20"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrol" & _
        "lGroup=""1""><ClientRect>0, 0, 548, 228</ClientRect><BorderSide>0</BorderSide><Cap" & _
        "tionStyle parent=""Heading"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style" & _
        "2"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""Filter" & _
        "Bar"" me=""Style27"" /><FooterStyle parent=""Footer"" me=""Style4"" /><GroupStyle paren" & _
        "t=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style3"" /><HighLight" & _
        "RowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me" & _
        "=""Style6"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle pare" & _
        "nt=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style5"" " & _
        "/><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits>" & _
        "<NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" " & _
        "/><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><" & _
        "Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><S" & _
        "tyle parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><S" & _
        "tyle parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style " & _
        "parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><" & _
        "Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><hor" & _
        "zSplits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRe" & _
        "cSelWidth><ClientArea>0, 0, 548, 228</ClientArea></Blob>"
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ContextMenuDokTyp
        '
        Me.ContextMenuDokTyp.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MnuAddDok, Me.MenuItem2, Me.MnuVerwaltung, Me.mnusaveStandard, Me.MenuItem5, Me.MnuMark, Me.MnuUnmark})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Informationen zur Dokument&vorlage"
        '
        'MnuAddDok
        '
        Me.MnuAddDok.Index = 1
        Me.MnuAddDok.Text = "&Dokumentvorlage hinzufügen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'MnuVerwaltung
        '
        Me.MnuVerwaltung.Index = 3
        Me.MnuVerwaltung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDPKopieren, Me.MnuSaveAs, Me.mnuDPMAKopieren})
        Me.MnuVerwaltung.Text = "Dokumentpakete verwalten"
        '
        'mnuDPKopieren
        '
        Me.mnuDPKopieren.Index = 0
        Me.mnuDPKopieren.Text = "&Dokumentpaket kopieren"
        '
        'MnuSaveAs
        '
        Me.MnuSaveAs.Index = 1
        Me.MnuSaveAs.Text = "Dokumentpaket speichern"
        '
        'mnuDPMAKopieren
        '
        Me.mnuDPMAKopieren.Index = 2
        Me.mnuDPMAKopieren.Text = "Dokumentpaket für ... kopieren"
        '
        'mnusaveStandard
        '
        Me.mnusaveStandard.Index = 4
        Me.mnusaveStandard.Text = "Als individuelles Dokumentpaket speichern"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 5
        Me.MenuItem5.Text = "-"
        Me.MenuItem5.Visible = False
        '
        'MnuMark
        '
        Me.MnuMark.Index = 6
        Me.MnuMark.Text = "&Zum Erstellen markieren"
        Me.MnuMark.Visible = False
        '
        'MnuUnmark
        '
        Me.MnuUnmark.Index = 7
        Me.MnuUnmark.Text = "&Markierung aufheben"
        Me.MnuUnmark.Visible = False
        '
        'ContextMenuDokument
        '
        Me.ContextMenuDokument.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuShowDoc, Me.MnuTrefferliste})
        '
        'MnuShowDoc
        '
        Me.MnuShowDoc.Index = 0
        Me.MnuShowDoc.Text = "&Dokument anzeigen"
        '
        'MnuTrefferliste
        '
        Me.MnuTrefferliste.Index = 1
        Me.MnuTrefferliste.Text = "&Partnerdossier anzeigen"
        '
        'PicHinweis
        '
        Me.PicHinweis.Image = CType(resources.GetObject("PicHinweis.Image"), System.Drawing.Bitmap)
        Me.PicHinweis.Location = New System.Drawing.Point(456, 48)
        Me.PicHinweis.Name = "PicHinweis"
        Me.PicHinweis.Size = New System.Drawing.Size(40, 46)
        Me.PicHinweis.TabIndex = 66
        Me.PicHinweis.TabStop = False
        Me.PicHinweis.Visible = False
        '
        'lblhinweis
        '
        Me.lblhinweis.Location = New System.Drawing.Point(424, 88)
        Me.lblhinweis.Name = "lblhinweis"
        Me.lblhinweis.Size = New System.Drawing.Size(104, 24)
        Me.lblhinweis.TabIndex = 67
        Me.lblhinweis.Text = "Wichtiger Hinweis vorhanden"
        Me.lblhinweis.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'Timer1
        '
        Me.Timer1.Interval = 4000
        '
        'ImageList4
        '
        Me.ImageList4.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList4.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList4.ImageStream = CType(resources.GetObject("ImageList4.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList4.TransparentColor = System.Drawing.Color.Transparent
        '
        'lblabgeschlossen
        '
        Me.lblabgeschlossen.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblabgeschlossen.ForeColor = System.Drawing.Color.Blue
        Me.lblabgeschlossen.Location = New System.Drawing.Point(96, 360)
        Me.lblabgeschlossen.Name = "lblabgeschlossen"
        Me.lblabgeschlossen.Size = New System.Drawing.Size(392, 24)
        Me.lblabgeschlossen.TabIndex = 68
        Me.lblabgeschlossen.Text = "Das Dokumentpaket wurde abgeschlossen"
        Me.lblabgeschlossen.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.lblabgeschlossen.Visible = False
        '
        'Timer2
        '
        Me.Timer2.Interval = 1000
        '
        'frmDokumentpaket
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(568, 389)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblabgeschlossen, Me.lblhinweis, Me.PicHinweis, Me.DokList, Me.btnWeiter, Me.btnAbbruch, Me.TreeVorlagen, Me.BtnHelp, Me.txtPartnerZusteller, Me.Button1, Me.Label16, Me.cbdokumentstatus, Me.btnPartnerInhaber, Me.txtPartnerInhaber, Me.Label2, Me.Label1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentpaket"
        Me.Text = "Dokumentpaket"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Load_Dokumentpaket Method

Private Sub Load_Dokumentpaket()

Source code

[Visual Basic]
    Private Sub Load_Dokumentpaket()
        'Dokumentpaket
        Dim dp As New edokadb.clsEdex_dokumentpaket()
        dp.cpMainConnectionProvider = conn
        dp.iDokumentpaketnr = New SqlInt32(CType(Me.Dokumentpaketnr, Int32))
        dp.SelectOne()
        Me.Text = "Dokumentpaket: " + dp.sBezeichnung.Value
        If dp.sWichtigehinweise.Value <> "" Then
            Me.lblhinweis.Visible = True
            Me.PicHinweis.Visible = True
            Me.Wichtigerhinweis = dp.sWichtigehinweise.Value
        Else
            Me.lblhinweis.Visible = False
            Me.PicHinweis.Visible = False
            Me.Wichtigerhinweis = ""
        End If
        dp.Dispose()

        'Dokumentpaketvorlagen
        Dim dpv As DataTable
        dpv = Generic_Select(1)

        Dim i As Integer
        For i = 0 To dpv.Rows.Count - 1
            If dpv.Rows(i).Item("dtaktiv") = True Or (Me.DP_Instanz = True Or Me.IndividuellesDP = True) Then
                Me.ColDokumenttypNr.Add(dpv.Rows(i).Item("Dokumenttypnr"))
            End If
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim f As New frmDokumenttypInfo()
        Try
            f.Key = Me.DokList.Columns("Dokumenttypnr").Text
            f.Text = f.Text + " " + Me.DokList.Columns("stext").Text
            f.ShowDialog()
        Catch
        Finally
            f.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuAddDok_Click Method

Private Sub MnuAddDok_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuAddDok.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuAddDok_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuAddDok.Click
        Dim f As New frmVorlagenauswahl()
        f.ToolBar1.Buttons(2).Pushed = True
        'Me.savedata = Me.DokList.DataSource
        f.TVStruktur.ImageList = Me.ImageList3
        f.edex_vorlagenauswahl = True
        f.ShowDialog()
        If f.Dokumentvorlage = 0 Then Exit Sub

        Dim d As DataTable
        Dim i As Integer
        d = Me.DokList.DataSource
        For i = 0 To d.Rows.Count - 1
            If d.Rows(i).Item("dokumenttypnr") = f.Dokumentvorlage Then
                MsgBox("Diese Dokumentvorlage ist im Paket bereits vorhanden.", MsgBoxStyle.Information)
                Exit Sub
            End If
        Next
        Me.ColDokumenttypNr.Add(f.Dokumentvorlage)

        Dim rowvals(4) As Object
        rowvals(0) = "0"
        rowvals(1) = Str(f.Dokumentvorlage)
        rowvals(2) = 1
        rowvals(3) = f.TVStruktur.SelectedNode.ImageIndex
        rowvals(4) = f.TVStruktur.SelectedNode.Text

        If Me.IndividuellesDP = False Then Me.saveasidvDP = True
        d.Rows.Add(rowvals)
        Me.DokList.DataSource = Nothing
        Me.DokList.DataMember = Nothing
        Me.DokList.DataSource = d
        Me.DokList.DataMember = d.TableName

        Me.Refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuMark_Click Method

Private Sub MnuMark_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuMark.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMark_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuMark.Click
        If Me.DokList.Columns("Erstellung").Value = 1 And Me.DokList.Columns("Aktiv").Value = 1 Then
            Dim i
            i = Me.DokList.Bookmark
            Me.DokList.Columns("Haken").Value = 2
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark - 1
            Catch
            End Try
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark + 1
            Catch
            End Try
            Me.DokList.Bookmark = i
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuSaveAs_Click Method

Private Sub MnuSaveAs_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSaveAs.Click, _
   mnusaveStandard.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSaveAs_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSaveAs.Click, mnusaveStandard.Click
        Dim i As Integer
        Me.Dokumenttypnummern = ""
        For Each i In Me.ColDokumenttypNr
            If Me.Dokumenttypnummern <> "" Then Me.Dokumenttypnummern = Me.Dokumenttypnummern + ";"
            Me.Dokumenttypnummern = Me.Dokumenttypnummern + LTrim(Str(i))
        Next
        If Me.IndividuellesDP = False Then
            Dim f As New frmDokumentpaketdefinition(True, Me.Dokumentpaketnr, True, Me.Dokumenttypnummern)
            Cursor = Cursors.WaitCursor
            f.ShowDialog()
            Cursor = Cursors.Default
        Else
            Cursor = Cursors.WaitCursor
            Application.DoEvents()
            Dim f As New frmDokumentpaketdefinition(False, Me.Dokumentpaketnr, True, Me.Dokumenttypnummern)
            f.Visible = False
            f.Width = 1
            f.Height = 1
            Cursor = Cursors.WaitCursor
            Application.DoEvents()
            f.Show()
            Cursor = Cursors.WaitCursor
            Application.DoEvents()
            f.Hide()
            Cursor = Cursors.WaitCursor
            Application.DoEvents()
            If f.FormValidator(False) = False Then
                Cursor = Cursors.Default
                f.Visible = True

                f.Refresh()
                Exit Sub
            Else
                Cursor = Cursors.WaitCursor
                Application.DoEvents()
                f.Save_Dokumentpaket()
                Cursor = Cursors.Default
                MyMsg.show_standardmessage(412, MsgBoxStyle.Information)
                f.Dispose()
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuShowDoc_Click Method

Private Sub MnuShowDoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowDoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowDoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowDoc.Click
        If Microsoft.VisualBasic.Left(Me.DokList.Columns("Dokumentid").Value, 3) = "OFF" Then
            Dim t As DataTable
            t = DivFnkt.Berechtigte_Mitarbeiter(0, Globals.MitarbeiterNr, 0, Me.DokList.Columns("dokumentid").Value, 1, 0, 0, 0, "")
            If t.Rows.Count = 0 Then
                MyMsg.show_standardmessage(43, MsgBoxStyle.Critical)
                Exit Sub
            End If
            DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me)
        Else
            Dim dt As DataTable
            Dim t As DataTable
            dt = get_uvmdaten()
            t = DivFnkt.Berechtigte_Mitarbeiter(0, Globals.MitarbeiterNr, 0, Me.DokList.Columns("dokumentid").Value, 1, 0, 0, 0, "")
            If t.Rows.Count = 0 Then
                MyMsg.show_standardmessage(43, MsgBoxStyle.Critical)
                Exit Sub
            End If
            DivFnkt.Erstellungsdatum = dt.Rows(0).Item("dmers00")
            DivFnkt.Belegart = "UVM"
            DivFnkt.UVMZVDokumenttyp = dt.Rows(0).Item("nrdot00")
            DivFnkt.ShowColdDocHost(dt.Rows(0).Item("nrdoc00"), Me.ParentForm, dt.Rows(0).Item("nrdoc00"), _
                                     dt.Rows(0).Item("nrpar00"), "", dt.Rows(0).Item("doktyp"))
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuTrefferliste_Click Method

Private Sub MnuTrefferliste_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuTrefferliste.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuTrefferliste_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuTrefferliste.Click
        Try
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim t As DataTable
            t = Generic_Select(4)
            If t.Rows.Count > 0 Then
                Globals.profilnr = 0
                Dim f As New frmTrefferliste()
                f.MdiParent = Me.MdiParent
                f.Show()
                f.Partner_Eingegeben = True
                f.txtnrpar00.Text = LTrim(t.Rows(0).Item("NRPAR00"))
                f.refresh_list()
                f.PosDok(Me.DokList.Columns("Dokumentid").Text, t.Rows(0).Item("dokumentart"))
                Me.Cursor = System.Windows.Forms.Cursors.Default
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.MnuUnmark_Click Method

Private Sub MnuUnmark_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuUnmark.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuUnmark_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuUnmark.Click
        If Me.DokList.Columns("Erstellung").Value = 1 And Me.DokList.Columns("Aktiv").Value = 1 Then
            Dim i
            i = Me.DokList.Bookmark
            Me.DokList.Columns("Haken").Value = 1
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark - 1
            Catch
            End Try
            Try
                Me.DokList.Bookmark = Me.DokList.Bookmark + 1
            Catch
            End Try
            Me.DokList.Bookmark = i
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.PicHinweis_Click Method

Private Sub PicHinweis_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles PicHinweis.Click, _
   lblhinweis.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PicHinweis_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles PicHinweis.Click, lblhinweis.Click
        MsgBox(Me.Wichtigerhinweis, MsgBoxStyle.Exclamation)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Refresh_data Method

Private Sub Refresh_data()

Source code

[Visual Basic]
    Private Sub Refresh_data()
        Dim vertraulich As Integer
        Dim i As Integer
        Dim ii As Integer
        Me.Dokumenttypnummern = ""
        For Each i In Me.ColDokumenttypNr
            If Me.Dokumenttypnummern <> "" Then Me.Dokumenttypnummern = Me.Dokumenttypnummern + ";"
            Me.Dokumenttypnummern = Me.Dokumenttypnummern + LTrim(Str(i))
        Next
        dd = Generic_Select(3)

        Me.DokList.DataSource = Nothing
        Me.DokList.DataMember = Nothing
        Me.DokList.DataSource = dd
        Me.DokList.DataMember = dd.TableName
        Me.DokList.Splits(0).DisplayColumns(0).Width = 0
        Me.DokList.Splits(0).DisplayColumns(1).Width = 0
        Me.DokList.Splits(0).DisplayColumns(2).Width = 20
        Me.DokList.Splits(0).DisplayColumns(3).Width = 20
        Me.DokList.Splits(0).DisplayColumns(4).Width = Me.DokList.Width - 60

        For i = 0 To dd.Rows.Count - 1
            If dd.Rows(i).Item("dokumentid") <> "0" Then
                dd.Rows(i - 1).Item("haken") = 1
            End If
            If dd.Rows(i).Item("dokumentid") = "0" Then
                If dd.Rows(i).Item("erstellung") = -1 Then
                    dd.Rows(i).Item("erstellung") = 0
                    dd.Rows(i).Item("Haken") = 1
                Else

                    If dd.Rows(i).Item("vertraulich") = 1 Then vertraulich = 1 Else vertraulich = 0
                    If DivFnkt.Ist_Berechtigt(dd.Rows(i).Item("Dokumenttypnr"), Globals.MitarbeiterNr, Me.NrPar00, "", 2, 0, 0, vertraulich) = True Then
                        dd.Rows(i).Item("erstellung") = 1
                    Else
                        dd.Rows(i).Item("erstellung") = 0
                        dd.Rows(i).Item("Haken") = 1
                    End If
                End If
                Dim set2 As Boolean = False
                If Me.MarkierteDT.Count > 0 Then
                    Try
                        For ii = 1 To Me.MarkierteDT.Count
                            If Me.MarkierteDT.Item(ii) = dd.Rows(i).Item("dokumenttypnr") Then
                                set2 = True
                            End If
                        Next
                        If set2 = True And Me.lblabgeschlossen.Visible = False Then
                            dd.Rows(i).Item("Haken") = 2
                            Me.DokList.Bookmark = i
                            Me.DokList.Columns(2).Value = 2
                            Me.DokList.Columns("erstellung").Value = 1
                            dd.Rows(i).Item("erstellung") = 1
                        Else
                            dd.Rows(i).Item("Haken") = 1
                        End If

                    Catch ex As Exception
                        dd.Rows(i).Item("haken") = 1
                    End Try
                End If
                If dd.Rows(i).Item("Erstellung") = 0 Then dd.Rows(i).Item("haken") = 1
            End If
        Next

        For i = 5 To Me.DokList.Columns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).Width = 0
        Next

        Dim xbmp
        For i = 0 To dd.Rows.Count - 1
            xbmp = dd.Rows(i).Item("imageindex")
            Dim bm As New Bitmap(Me.ImageList3.Images(xbmp))
            Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem(xbmp, bm)
            Me.DokList.Columns(3).ValueItems.Values.Add(v0)
            Me.DokList.Columns(3).ValueItems.Translate = True
        Next

        Dim bmp1 As New Bitmap(Me.ImageList2.Images(0))
        Dim bmp2 As New Bitmap(Me.ImageList2.Images(1))
        Dim bmp3 As New Bitmap(Me.ImageList2.Images(2))
        Dim bmp4 As New Bitmap(Me.ImageList2.Images(3))

        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v4 As New C1.Win.C1TrueDBGrid.ValueItem()

        v1.DisplayValue = bmp1
        v1.Value = 0

        v2.DisplayValue = bmp2
        v2.Value = 1

        v3.DisplayValue = bmp3
        v3.Value = 2

        v4.DisplayValue = bmp4
        v4.Value = 3

        Me.DokList.Columns(2).ValueItems.Values.Add(v1)
        Me.DokList.Columns(2).ValueItems.Values.Add(v2)
        Me.DokList.Columns(2).ValueItems.Values.Add(v3)
        Me.DokList.Columns(2).ValueItems.Values.Add(v4)

        Me.DokList.Columns(2).ValueItems.Translate = True
        'Me.DokList.RowHeight = 20

        Me.DokList.CollapseColor = Color.White
        Me.DokList.AllowHorizontalSplit = False
        Me.DokList.AllowColMove = False

        For i = 0 To Me.DokList.Columns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).Style.Borders.BorderType = C1.Win.C1TrueDBGrid.BorderTypeEnum.None
            Me.DokList.Splits(0).DisplayColumns(i).Style.Borders.Bottom = 0
            Me.DokList.Splits(0).DisplayColumns(i).Style.Borders.Left = 0
            Me.DokList.Splits(0).DisplayColumns(i).Style.Borders.Right = 0
            Me.DokList.Splits(0).DisplayColumns(i).Style.Borders.Top = 0
            Me.DokList.Splits(0).DisplayColumns(i).AllowSizing = False
            Me.DokList.Splits(0).DisplayColumns(i).ColumnDivider.Color = System.Drawing.Color.White
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.TagArt Method

Private Function TagArt( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagArt(ByVal tag As String) As String
        Dim Art As String
        Art = tag
        Return Art.Substring(0, 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.TagValue Method

Private Function TagValue( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagValue(ByVal tag As String) As String
        Dim Keyvalue As String
        Keyvalue = tag
        Return Keyvalue.Substring(3, Len(Keyvalue) - 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.Timer1_Tick Method

Private Sub Timer1_Tick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Timer1.Tick, _
   Timer2.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Timer1.Tick, Timer2.Tick
        Me.Timer2.Enabled = False
        Dim s As String
        Try
            Dim i2 As Integer
            For i2 = 1 To Globals.DP_Collection.Count
                If Globals.DP_Collection.Item(i2) = Me.dokumentid Then Exit Sub
            Next
        Catch
            s = ""
        End Try
        If Me.dokumentid = "" Then Exit Sub
        Me.Timer1.Enabled = False
        Dim EndeBearbeitung As Boolean = False
        If Me.dokumentid = "Timer2HandleED" Then EndeBearbeitung = True
        Me.dokumentid = ""
        Me.InBearbeitung = False
        Dim i As Integer
        Dim i1 As Integer
        Dim bm As Boolean
        bm = Me.DokList.Bookmark

        For i = 1 To Me.MarkierteDT.Count
            Try
                If Me.MarkierteDT.Item(i) = Me.DokumenttypInBearbeitung Then
                    Me.MarkierteDT.Remove(i)
                    If Me.MarkierteDT.Count < 1 Then Me.MarkierteDT.Add("999999")
                    i = i - 1
                End If
            Catch
            End Try
        Next

        Me.Refresh_data()

        Me.DokList.Bookmark = bm

        Dim gg As DataTable = Me.DokList.DataSource
        For Each i In Me.MarkierteDT
            For i1 = 0 To gg.Rows.Count - 1
                If gg.Rows(i1).Item("Dokumentid") = "0" And gg.Rows(i1).Item("dokumenttypnr") = i Then
                    gg.Rows(i1).Item("haken") = 2
                End If
            Next
        Next
        Me.DokList.DataSource = gg
        If EndeBearbeitung = True Then
            If Me.MarkierteDT.Count = 1 And Me.MarkierteDT.Item(1) = 999999 Then
                Me.lblabgeschlossen.Visible = True
                If Me.DP_Instanz = True Then
                    delete_gespeicherte_dpinstanz(Me.dp_instanznr)
                End If
            End If
            Exit Sub
        End If
        Me.Dokumente_Abarbeiten(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 ' Close
                Me.Close()
            Case 1
            Case 2
            Case 3
                Dim f As New frmDokumentpaketInfo()
                f.Key = Me.Dokumentpaketnr
                f.ShowDialog()
                f.Dispose()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.barcodedokument_erstellen Method

Private Function barcodedokument_erstellen( _
   ByVal barcodeid As String _
) As Boolean

Parameters

barcodeid
Required.

Source code

[Visual Basic]
    Private Function barcodedokument_erstellen(ByVal barcodeid As String) As Boolean
        Cursor = Cursors.WaitCursor
        Dim fI As New frmDokumentbearbeitungBC()
        fI.Edex_Folgestatus = Me.cbdokumentstatus.SelectedIndex
        fI.Profile = Me.Profile
        fI.Profilnr = Me.Profilnr
        fI.Partnernr = Me.NrPar00
        fI.BarcodeID = barcodeid
        fI.Dokumenttypnr = Me.DokList.Columns("dokumenttypnr").Text
        fI.CreateDocument = True
        Me.Cursor = Cursors.Default
        fI.ShowDialog()
        fI.Dispose()
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.btnPartnerInhaber_Click Method

Private Sub btnPartnerInhaber_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInhaber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInhaber_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInhaber.Click
        Me.lblabgeschlossen.Visible = False
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
            Me.txtPartnerZusteller.Text = Me.get_partnerzusteller(f.PartnerNr)
            Me.NrPar00 = f.PartnerNr
            Me.Refresh_data()
            Me.DokList.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        Dim i As Integer
        Try
            While Me.MarkierteDT.Count > 0
                Me.MarkierteDT.Remove(1)
            End While
        Catch

        End Try
        For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
            If Me.DokList.Columns(2).CellValue(i) = 2 Then
                Me.MarkierteDT.Add(Me.DokList.Columns("dokumenttypnr").CellValue(i))
            End If
        Next
        Me.CurrentRow = 0

        Dokumente_Abarbeiten(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.delete_gespeicherte_dpinstanz Method

Public Function delete_gespeicherte_dpinstanz( _
   ByVal dp_instanznr As Integer _
)

Parameters

dp_instanznr
Required.

Source code

[Visual Basic]
    Public Function delete_gespeicherte_dpinstanz(ByVal dp_instanznr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "edex_sp_dpinstanz"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dpinstanznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dp_instanznr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try

            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.einzeldokument_erstellen Method

Private Function einzeldokument_erstellen() As Boolean

Source code

[Visual Basic]
    Private Function einzeldokument_erstellen() As Boolean
        Cursor = Cursors.WaitCursor
        Dim fI As New frmDokumentbearbeitungED()
        fI.Profile = Me.Profile
        fI.Profilnr = Me.Profilnr
        fI.Partnernr = Me.NrPar00
        fI.Dokumenttypnr = Me.DokList.Columns("dokumenttypnr").Text
        fI.CreateDocument = True
        Me.Cursor = Cursors.Default
        fI.ShowDialog()
        fI.Dispose()
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.frmDokumentpaket_Closing Method

Private Sub frmDokumentpaket_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaket_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Me.DokList.Enabled = False Then Exit Sub
        Dim dp_unfertig As Boolean = False
        Dim i As Integer
        Dim shaken As String = ""
        For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
            Me.DokList.Bookmark = i
            If Me.DokList.Columns("Haken").Value > 1 Then dp_unfertig = True
            If Me.DokList.Columns("Haken").Value > 0 Then
                If shaken <> "" Then shaken = shaken + ";"
                shaken = shaken + LTrim(Str(Me.DokList.Columns("Haken").Value))
            End If
        Next
        If dp_unfertig Then
            Dim msgresult As Integer
            msgresult = MyMsg.Show_MessageYesNoCancel(411)
            Select Case msgresult
                Case MsgBoxResult.No
                    Exit Sub
                Case MsgBoxResult.Cancel
                    e.Cancel = True
                    Exit Sub
                Case MsgBoxResult.Yes
                    Me.Dokumenttypnummern = ""
                    For Each i In Me.ColDokumenttypNr
                        If Me.Dokumenttypnummern <> "" Then Me.Dokumenttypnummern = Me.Dokumenttypnummern + ";"
                        Me.Dokumenttypnummern = Me.Dokumenttypnummern + LTrim(Str(i))
                    Next
                    Dim dpi As New edokadb.clsEdex_dpinstanz()
                    dpi.cpMainConnectionProvider = conn
                    If Me.dp_instanznr <> 0 Then
                        Try
                            dpi.iNreintrag = New SqlInt32(CType(Me.dp_instanznr, Int32))
                            dpi.SelectOne()
                            dpi.sDokumentpaketnummern = New SqlString(CType(Me.Dokumenttypnummern, String))
                            dpi.sHacken = New SqlString(CType(shaken, String))
                            dpi.iProfilnr = New SqlInt32(CType(Me.Profilnr, Int32))
                            conn.OpenConnection()
                            dpi.Update()
                            conn.CloseConnection(True)
                        Catch
                            MsgBox("Beim Speichern der Dokumentpaketinstanz ist ein Fehler aufgetreten.")
                        End Try
                    Else
                        Try
                            dpi.sDokumentpaketnummern = New SqlString(CType(Me.Dokumenttypnummern, String))
                            dpi.sHacken = New SqlString(CType(shaken, String))
                            dpi.bIndividuellesDP = New SqlBoolean(CType(Me.IndividuellesDP, Boolean))
                            dpi.daErstellt_am = New SqlDateTime(CType(Now(), DateTime))
                            dpi.iDokumentpaketnr = New SqlInt32(CType(Me.Dokumentpaketnr, Int32))
                            dpi.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                            dpi.iNrpar00 = New SqlInt32(CType(Me.NrPar00, Int32))
                            dpi.iProfilnr = New SqlInt32(CType(Me.Profilnr, Int32))
                            conn.OpenConnection()
                            dpi.Insert()
                            conn.CloseConnection(True)
                        Catch
                            MsgBox("Beim Speichern der Dokumentpaketinstanz ist ein Fehler aufgetreten.")
                        End Try
                    End If
            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.frmDokumentpaket_Load Method

Private Sub frmDokumentpaket_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaket_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DokList.Visible = True
        Load_Dokumentpaket()
        If Me.NrPar00 <> 0 Then
            Dim f As New FrmPartnersuche()
            f.Partner_Suche(Me.NrPar00)
            Me.txtPartnerInhaber.Text = Str(f.PartnerNr) + " " + f.PartnerKurzbezeichnnung
            If Me.txtPartnerInhaber.Text = " 0 " Then Me.txtPartnerInhaber.Text = ""
            Me.txtPartnerZusteller.Text = get_partnerzusteller(Me.NrPar00)
            Me.Refresh_data()
            Me.DokList.Enabled = True
        Else
            Me.txtPartnerInhaber.Text = ""
            btnPartnerInhaber_Click(sender, e)
            Me.Refresh_data()
            If Me.NrPar00 = 0 Then Me.DokList.Enabled = False Else Me.DokList.Enabled = True
        End If
        If Me.IndividuellesDP = True Then
            Dim bmp As New Bitmap(Me.ImageList4.Images(1))
            Dim ico As Icon = Icon.FromHandle(bmp.GetHicon())
            Me.Icon = ico
        Else
            Dim bmp As New Bitmap(Me.ImageList4.Images(0))
            Dim ico As Icon = Icon.FromHandle(bmp.GetHicon())
            Me.Icon = ico
        End If
        If Me.DP_Instanz = True Then
            Dim splitter
            Dim splitter1

            Dim i As Integer = 0
            Dim i1 As Integer
            splitter = Me.Dokumenttyphacken.Split(";")
            splitter1 = Me.Dokumenttypnummern.Split(";")

            For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
                Me.DokList.Bookmark = i
                If Me.DokList.Columns("Dokumentid").Value = "0" Then
                    Try
                        i1 = 0
                        Do Until splitter(i1) Is Nothing
                            If splitter1(i1) = Me.DokList.Columns("Dokumenttypnr").Value Then
                                If splitter(i1) = 2 Then
                                    Me.DokList.Columns("Haken").Value = 2
                                Else
                                    Me.DokList.Columns("Haken").Value = 1
                                End If
                                Exit Do
                            End If
                            i1 = i1 + 1
                        Loop
                    Catch
                    End Try
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.get_partnerzusteller Method

Private Function get_partnerzusteller( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_partnerzusteller(ByVal nrpar00 As Integer) As String
        Dim p As New edokadb.clsPartner()
        Dim p1 As New edokadb.clsPartner()
        Dim s As String
        s = ""
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
        p.SelectOne()
        If p.iNRPAR00.ToString <> p.sNRPARAD.ToString Then
            Try
                p1.cpMainConnectionProvider = conn
                p1.iNRPAR00 = New SqlInt32(CType(p.sNRPARAD.Value, Int32))
                p1.SelectOne()
                s = p1.sNRPARAD.ToString + " " + p1.sBKPAR00.Value
            Catch
                s = ""
            End Try
        End If
        p.Dispose()
        p1.Dispose()
        get_partnerzusteller = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.get_uvmdaten Method

Public Function get_uvmdaten() As DataTable

Source code

[Visual Basic]
    Public Function get_uvmdaten() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.edex_sp_get_uvmdata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumenttypnr").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentit", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.mnuDPKopieren_Click Method

Private Sub mnuDPKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDPKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDPKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDPKopieren.Click
        Dim f As frmDokumentpaketdefinition
        If Me.IndividuellesDP Then
            f = New frmDokumentpaketdefinition(False, Me.Dokumentpaketnr, True)
        Else
            f = New frmDokumentpaketdefinition(False, Me.Dokumentpaketnr, True)
        End If
        f.Kopie = True
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.mnuDPMAKopieren_Click Method

Private Sub mnuDPMAKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDPMAKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDPMAKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDPMAKopieren.Click
        Dim ma As New frmMitarbeiterSelektion()
        Dim i As Integer
        i = ma.ShowDialog()
        If Not i = DialogResult.OK Then
            Exit Sub
        End If
        i = ma.Mitarbeiternr
        ma.Dispose()
        Dim f As frmDokumentpaketdefinition
        f = New frmDokumentpaketdefinition(Me.Dokumentpaketnr, i)
        f.Show()
        f.Dispose()
        MyMsg.show_standardmessage(415, MsgBoxStyle.Information)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket.normaldokument_erstellen Method

Private Function normaldokument_erstellen( _
   ByVal colrow As Integer _
) As Boolean

Parameters

colrow
Required.

Source code

[Visual Basic]
    Private Function normaldokument_erstellen(ByVal colrow As Integer) As Boolean
        Cursor = Cursors.WaitCursor()
        Dim fI As New frmDokumentbearbeitung()
        fI.Edex_Folgestatus = Me.cbdokumentstatus.SelectedIndex
        fI.Profile = Me.Profile
        fI.Profilnr = Me.Profilnr
        fI.Partnernr = Me.NrPar00
        fI.Dokumenttypnr = Me.DokList.Columns("dokumenttypnr").CellValue(colrow)
        fI.CreateDocument = True
        Me.Cursor = Cursors.Default
        fI.ShowDialog()
        If fI.w.DokumentID <> "" Then
            Me.dokumentid = fI.w.DokumentID
            Globals.DP_Collection.Add(Me.dokumentid)
            fI.Dispose()
            Return True
        Else
            fI.Dispose()
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket Fields

frmDokumentpaket overview

Fields

field BtnHelp
field Button1
field ColDokumenttypNr
field ContextMenuDokTyp
field ContextMenuDokument
field CurrentRow
field DP_Instanz
field DokList
field Dokumentpaketnr
field DokumenttypInBearbeitung
field Dokumenttyphacken
field Dokumenttypnummern
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field IndividuellesDP
field Label1
field Label16
field Label2
field MarkierteDT
field MenuItem1
field MenuItem2
field MenuItem5
field MnuAddDok
field MnuMark
field MnuSaveAs
field MnuShowDoc
field MnuTrefferliste
field MnuUnmark
field MnuVerwaltung
field NrPar00
field PicHinweis
field Timer1
field Timer2
field ToolBar1
field TreeVorlagen
field Wichtigerhinweis
field barcodeid
field btnAbbruch
field btnDPCopy
field btnDPInfo
field btnDPSave
field btnExit
field btnPartnerInhaber
field btnWeiter
field cbdokumentstatus
field components
field dd
field dokumentid
field dp_instanznr
field lblabgeschlossen
field lblhinweis
field m_InBearbeitung
field m_profile
field m_profilnr
field mnuDPKopieren
field mnuDPMAKopieren
field mnusaveStandard
field saveasidvDP
field savedata
field txtPartnerInhaber
field txtPartnerZusteller

See Also

frmDokumentpaket Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ColDokumenttypNr Variable

Dim ColDokumenttypNr As New Collection()

Source code

[Visual Basic]
    Dim ColDokumenttypNr As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ContextMenuDokTyp Variable

Friend WithEvents ContextMenuDokTyp As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenuDokTyp As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ContextMenuDokument Variable

Friend WithEvents ContextMenuDokument As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenuDokument As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


CurrentRow Variable

Dim CurrentRow As Integer = 0

Source code

[Visual Basic]
    Dim CurrentRow As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


DP_Instanz Variable

Dim DP_Instanz As Boolean = False

Source code

[Visual Basic]
    Dim DP_Instanz As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Dokumentpaketnr Variable

Dim Dokumentpaketnr As Integer

Source code

[Visual Basic]
    Dim Dokumentpaketnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


DokumenttypInBearbeitung Variable

Dim DokumenttypInBearbeitung As String

Source code

[Visual Basic]
    Dim DokumenttypInBearbeitung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Dokumenttyphacken Variable

Dim Dokumenttyphacken As String = ""

Source code

[Visual Basic]
    Dim Dokumenttyphacken As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Dokumenttypnummern Variable

Dim Dokumenttypnummern As String = ""

Source code

[Visual Basic]
    Dim Dokumenttypnummern As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ImageList4 Variable

Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


IndividuellesDP Variable

Dim IndividuellesDP As Boolean

Source code

[Visual Basic]
    Dim IndividuellesDP As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MarkierteDT Variable

Dim MarkierteDT As New Collection()

Source code

[Visual Basic]
    Dim MarkierteDT As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuAddDok Variable

Friend WithEvents MnuAddDok As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAddDok As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuMark Variable

Friend WithEvents MnuMark As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuMark As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuSaveAs Variable

Friend WithEvents MnuSaveAs As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSaveAs As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuShowDoc Variable

Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowDoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuTrefferliste Variable

Friend WithEvents MnuTrefferliste As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuTrefferliste As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuUnmark Variable

Friend WithEvents MnuUnmark As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuUnmark As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


MnuVerwaltung Variable

Friend WithEvents MnuVerwaltung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuVerwaltung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


NrPar00 Variable

Dim NrPar00 As Integer

Source code

[Visual Basic]
    Dim NrPar00 As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


PicHinweis Variable

Friend WithEvents PicHinweis As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PicHinweis As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Timer1 Variable

Friend WithEvents Timer1 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Timer2 Variable

Friend WithEvents Timer2 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer2 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


TreeVorlagen Variable

Friend WithEvents TreeVorlagen As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeVorlagen As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


Wichtigerhinweis Variable

Dim Wichtigerhinweis As String = ""

Source code

[Visual Basic]
    Dim Wichtigerhinweis As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


barcodeid Variable

Dim barcodeid As String

Source code

[Visual Basic]
    Dim barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnDPCopy Variable

Friend WithEvents btnDPCopy As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnDPCopy As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnDPInfo Variable

Friend WithEvents btnDPInfo As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnDPInfo As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnDPSave Variable

Friend WithEvents btnDPSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnDPSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnExit Variable

Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnPartnerInhaber Variable

Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInhaber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


cbdokumentstatus Variable

Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbdokumentstatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


dd Variable

Dim dd As DataTable

Source code

[Visual Basic]
    Dim dd As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


dokumentid Variable

Dim dokumentid As String

Source code

[Visual Basic]
    Dim dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


dp_instanznr Variable

Dim dp_instanznr As Integer = 0

Source code

[Visual Basic]
    Dim dp_instanznr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


lblabgeschlossen Variable

Friend WithEvents lblabgeschlossen As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblabgeschlossen As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


lblhinweis Variable

Friend WithEvents lblhinweis As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhinweis As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


m_InBearbeitung Variable

Dim m_InBearbeitung As Boolean = False

Source code

[Visual Basic]
    Dim m_InBearbeitung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


mnuDPKopieren Variable

Friend WithEvents mnuDPKopieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDPKopieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


mnuDPMAKopieren Variable

Friend WithEvents mnuDPMAKopieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDPMAKopieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


mnusaveStandard Variable

Friend WithEvents mnusaveStandard As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnusaveStandard As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


saveasidvDP Variable

Dim saveasidvDP As Boolean = False

Source code

[Visual Basic]
    Dim saveasidvDP As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


savedata Variable

Dim savedata As DataTable

Source code

[Visual Basic]
    Dim savedata As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


txtPartnerInhaber Variable

Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerInhaber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


txtPartnerZusteller Variable

Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerZusteller As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaketInfo Class

For a list of all members of this type, see frmDokumentpaketInfo Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentpaketInfo

Public Class frmDokumentpaketInfo
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentpaketInfo Members


frmDokumentpaketInfo Members

frmDokumentpaketInfo overview

Constructors

constructor frmDokumentpaketInfo Constructor

Properties

property Key
property Titel

Methods

method Dispose
method Generic_Select
method InitializeComponent
method Load_Beschreibung
method TreeVorlagen_AfterCheck
method TreeVorlagen_BeforeCheck
method btnOK_Click
method frmDokumentpaketInfo_Load

Fields

field CheckValue
field GrpAllgemein
field GrpBeschreibung
field GrpDokumentvorlagen
field GrpHinweis
field ImageList3
field PicHinweis
field RichTextBoxHS1
field TreeVorlagen
field btnOK
field components
field lblBezeichnung
field lblOwner
field m_key
field m_title
field on_Load
field txtBezeichnung
field txtHinweis
field txtOwner

See Also

frmDokumentpaketInfo Class


frmDokumentpaketInfo Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo Properties

frmDokumentpaketInfo overview

Properties

property Key
property Titel

See Also

frmDokumentpaketInfo Class


frmDokumentpaketInfo.Key Property

Property Key() As Integer

Source code

[Visual Basic]
    Property Key() As Integer
        Get
            Return m_key
        End Get
        Set(ByVal Value As Integer)
            m_key = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.Titel Property

Property Titel() As String

Source code

[Visual Basic]
    Property Titel() As String
        Get
            Return m_title
        End Get
        Set(ByVal Value As String)
            m_title = Value

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo Methods

frmDokumentpaketInfo overview

Methods

method Dispose
method Generic_Select
method InitializeComponent
method Load_Beschreibung
method TreeVorlagen_AfterCheck
method TreeVorlagen_BeforeCheck
method btnOK_Click
method frmDokumentpaketInfo_Load

See Also

frmDokumentpaketInfo Class


frmDokumentpaketInfo.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "edex_sp_dokumentpaketinfo"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Select Case typ
            Case 1
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dpnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Key))
        End Select

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentpaketInfo))
        Me.lblBezeichnung = New System.Windows.Forms.Label()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.GrpDokumentvorlagen = New System.Windows.Forms.GroupBox()
        Me.TreeVorlagen = New System.Windows.Forms.TreeView()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.lblOwner = New System.Windows.Forms.Label()
        Me.txtOwner = New System.Windows.Forms.TextBox()
        Me.GrpBeschreibung = New System.Windows.Forms.GroupBox()
        Me.RichTextBoxHS1 = New EDOKAApp.RichTextBoxHS()
        Me.GrpAllgemein = New System.Windows.Forms.GroupBox()
        Me.GrpHinweis = New System.Windows.Forms.GroupBox()
        Me.txtHinweis = New System.Windows.Forms.Label()
        Me.PicHinweis = New System.Windows.Forms.PictureBox()
        Me.btnOK = New System.Windows.Forms.Button()
        Me.GrpDokumentvorlagen.SuspendLayout()
        Me.GrpBeschreibung.SuspendLayout()
        Me.GrpAllgemein.SuspendLayout()
        Me.GrpHinweis.SuspendLayout()
        Me.SuspendLayout()
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.Location = New System.Drawing.Point(16, 16)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(88, 24)
        Me.lblBezeichnung.TabIndex = 1
        Me.lblBezeichnung.Text = "Dokumentpaket"
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.BackColor = System.Drawing.Color.White
        Me.txtBezeichnung.Location = New System.Drawing.Point(104, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.ReadOnly = True
        Me.txtBezeichnung.Size = New System.Drawing.Size(368, 20)
        Me.txtBezeichnung.TabIndex = 2
        Me.txtBezeichnung.Text = "TextBox1"
        '
        'GrpDokumentvorlagen
        '
        Me.GrpDokumentvorlagen.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeVorlagen})
        Me.GrpDokumentvorlagen.Location = New System.Drawing.Point(8, 160)
        Me.GrpDokumentvorlagen.Name = "GrpDokumentvorlagen"
        Me.GrpDokumentvorlagen.Size = New System.Drawing.Size(240, 360)
        Me.GrpDokumentvorlagen.TabIndex = 3
        Me.GrpDokumentvorlagen.TabStop = False
        Me.GrpDokumentvorlagen.Text = "Dokumentvorlagen"
        '
        'TreeVorlagen
        '
        Me.TreeVorlagen.CheckBoxes = True
        Me.TreeVorlagen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeVorlagen.ImageList = Me.ImageList3
        Me.TreeVorlagen.Location = New System.Drawing.Point(3, 16)
        Me.TreeVorlagen.Name = "TreeVorlagen"
        Me.TreeVorlagen.Size = New System.Drawing.Size(234, 341)
        Me.TreeVorlagen.TabIndex = 0
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'lblOwner
        '
        Me.lblOwner.Location = New System.Drawing.Point(488, 16)
        Me.lblOwner.Name = "lblOwner"
        Me.lblOwner.Size = New System.Drawing.Size(80, 24)
        Me.lblOwner.TabIndex = 4
        Me.lblOwner.Text = "Verantwortlich:"
        '
        'txtOwner
        '
        Me.txtOwner.BackColor = System.Drawing.Color.White
        Me.txtOwner.Location = New System.Drawing.Point(576, 16)
        Me.txtOwner.Name = "txtOwner"
        Me.txtOwner.ReadOnly = True
        Me.txtOwner.Size = New System.Drawing.Size(208, 20)
        Me.txtOwner.TabIndex = 5
        Me.txtOwner.Text = "TextBox1"
        '
        'GrpBeschreibung
        '
        Me.GrpBeschreibung.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBoxHS1})
        Me.GrpBeschreibung.Location = New System.Drawing.Point(256, 160)
        Me.GrpBeschreibung.Name = "GrpBeschreibung"
        Me.GrpBeschreibung.Size = New System.Drawing.Size(544, 360)
        Me.GrpBeschreibung.TabIndex = 6
        Me.GrpBeschreibung.TabStop = False
        Me.GrpBeschreibung.Text = "Beschreibung"
        '
        'RichTextBoxHS1
        '
        Me.RichTextBoxHS1.AcceptsTab = True
        Me.RichTextBoxHS1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.RichTextBoxHS1.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.RichTextBoxHS1.Location = New System.Drawing.Point(3, 16)
        Me.RichTextBoxHS1.Name = "RichTextBoxHS1"
        Me.RichTextBoxHS1.ReadOnly = True
        Me.RichTextBoxHS1.Size = New System.Drawing.Size(538, 341)
        Me.RichTextBoxHS1.TabIndex = 4
        Me.RichTextBoxHS1.Text = ""
        '
        'GrpAllgemein
        '
        Me.GrpAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBezeichnung, Me.lblBezeichnung, Me.txtOwner, Me.lblOwner})
        Me.GrpAllgemein.Location = New System.Drawing.Point(8, 8)
        Me.GrpAllgemein.Name = "GrpAllgemein"
        Me.GrpAllgemein.Size = New System.Drawing.Size(800, 48)
        Me.GrpAllgemein.TabIndex = 7
        Me.GrpAllgemein.TabStop = False
        Me.GrpAllgemein.Text = "Allgemeines"
        '
        'GrpHinweis
        '
        Me.GrpHinweis.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtHinweis, Me.PicHinweis})
        Me.GrpHinweis.Location = New System.Drawing.Point(8, 64)
        Me.GrpHinweis.Name = "GrpHinweis"
        Me.GrpHinweis.Size = New System.Drawing.Size(800, 88)
        Me.GrpHinweis.TabIndex = 8
        Me.GrpHinweis.TabStop = False
        Me.GrpHinweis.Text = "Wichtiger Hinweis"
        '
        'txtHinweis
        '
        Me.txtHinweis.Location = New System.Drawing.Point(72, 24)
        Me.txtHinweis.Name = "txtHinweis"
        Me.txtHinweis.Size = New System.Drawing.Size(720, 56)
        Me.txtHinweis.TabIndex = 60
        Me.txtHinweis.Text = "Label1"
        '
        'PicHinweis
        '
        Me.PicHinweis.Image = CType(resources.GetObject("PicHinweis.Image"), System.Drawing.Bitmap)
        Me.PicHinweis.Location = New System.Drawing.Point(16, 24)
        Me.PicHinweis.Name = "PicHinweis"
        Me.PicHinweis.Size = New System.Drawing.Size(40, 46)
        Me.PicHinweis.TabIndex = 59
        Me.PicHinweis.TabStop = False
        Me.PicHinweis.Visible = False
        '
        'btnOK
        '
        Me.btnOK.Location = New System.Drawing.Point(720, 528)
        Me.btnOK.Name = "btnOK"
        Me.btnOK.TabIndex = 9
        Me.btnOK.Text = "OK"
        '
        'frmDokumentpaketInfo
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(802, 557)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnOK, Me.GrpHinweis, Me.GrpAllgemein, Me.GrpBeschreibung, Me.GrpDokumentvorlagen})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentpaketInfo"
        Me.Text = "Informationen zum Dokumentpaket:"
        Me.GrpDokumentvorlagen.ResumeLayout(False)
        Me.GrpBeschreibung.ResumeLayout(False)
        Me.GrpAllgemein.ResumeLayout(False)
        Me.GrpHinweis.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.Load_Beschreibung Method

Private Sub Load_Beschreibung()

Source code

[Visual Basic]
    Private Sub Load_Beschreibung()
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From EDEX_dokumentpaket where dokumentpaketnr=" + Str(Me.Key), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docbeschreibung")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(5)
            Dim K As Long
            K = UBound(MyData)

            Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Me.RichTextBoxHS1.LoadFile(dokname)
        Catch ex As Exception

        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.TreeVorlagen_AfterCheck Method

Private Sub TreeVorlagen_AfterCheck( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeVorlagen.AfterCheck

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeVorlagen_AfterCheck(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeVorlagen.AfterCheck

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.TreeVorlagen_BeforeCheck Method

Private Sub TreeVorlagen_BeforeCheck( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeVorlagen.BeforeCheck

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeVorlagen_BeforeCheck(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeVorlagen.BeforeCheck
        If Me.on_Load Then Exit Sub
        Try
            e.Cancel = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.btnOK_Click Method

Private Sub btnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOK.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo.frmDokumentpaketInfo_Load Method

Private Sub frmDokumentpaketInfo_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaketInfo_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Dim tn As TreeNode

        Me.Text = Me.Text + " " + Me.Titel

        Dim tb As DataTable = Generic_Select(1)
        If tb.Rows.Count > 0 Then
            Me.txtBezeichnung.Text = tb.Rows(0).Item("bezeichnung")
            Me.txtOwner.Text = tb.Rows(0).Item("owner")
            Me.txtHinweis.Text = tb.Rows(0).Item("wichtigehinweise")

            For i = 0 To tb.Rows.Count - 1
                tn = Me.TreeVorlagen.Nodes.Add(tb.Rows(i).Item("DTBezeichnung"))
                tn.Tag = i
                tn.ImageIndex = tb.Rows(i).Item("imageindex")
                tn.SelectedImageIndex = tb.Rows(i).Item("imageindex")
                tn.Checked = tb.Rows(i).Item("zwingend") = 1
            Next

            Load_Beschreibung()

        End If
        If Me.txtHinweis.Text.Length > 0 Then Me.PicHinweis.Visible = True Else Me.PicHinweis.Visible = False
        Me.on_Load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketInfo Fields

frmDokumentpaketInfo overview

Fields

field CheckValue
field GrpAllgemein
field GrpBeschreibung
field GrpDokumentvorlagen
field GrpHinweis
field ImageList3
field PicHinweis
field RichTextBoxHS1
field TreeVorlagen
field btnOK
field components
field lblBezeichnung
field lblOwner
field m_key
field m_title
field on_Load
field txtBezeichnung
field txtHinweis
field txtOwner

See Also

frmDokumentpaketInfo Class


CheckValue Variable

Dim CheckValue As Boolean

Source code

[Visual Basic]
    Dim CheckValue As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


GrpAllgemein Variable

Friend WithEvents GrpAllgemein As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpAllgemein As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


GrpBeschreibung Variable

Friend WithEvents GrpBeschreibung As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpBeschreibung As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


GrpDokumentvorlagen Variable

Friend WithEvents GrpDokumentvorlagen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpDokumentvorlagen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


GrpHinweis Variable

Friend WithEvents GrpHinweis As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpHinweis As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


PicHinweis Variable

Friend WithEvents PicHinweis As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PicHinweis As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


RichTextBoxHS1 Variable

Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Source code

[Visual Basic]
    Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


TreeVorlagen Variable

Friend WithEvents TreeVorlagen As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeVorlagen As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


btnOK Variable

Friend WithEvents btnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


lblBezeichnung Variable

Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


lblOwner Variable

Friend WithEvents lblOwner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblOwner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


m_key Variable

Dim m_key As Integer

Source code

[Visual Basic]
    Dim m_key As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


m_title Variable

Dim m_title As String

Source code

[Visual Basic]
    Dim m_title As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


on_Load Variable

Dim on_Load As Boolean = True

Source code

[Visual Basic]
    Dim on_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


txtHinweis Variable

Friend WithEvents txtHinweis As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtHinweis As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


txtOwner Variable

Friend WithEvents txtOwner As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtOwner As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketInfo


frmDokumentpaketdefinition Class

For a list of all members of this type, see frmDokumentpaketdefinition Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentpaketdefinition

Public Class frmDokumentpaketdefinition
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentpaketdefinition Members


frmDokumentpaketdefinition Members

frmDokumentpaketdefinition overview

Constructors

constructor frmDokumentpaketdefinition Constructor (Overloaded)

Properties

property Anzeige
property Dokumentpaketnr
property Individuelles_DP
property Kopie
property MitarbeiterKopie
property Mitarbeiternr
property Neu
property StrukturNr

Methods

method BtnHelp_Click
method DelNode
method DeleteNodes
method Dispose
method FormValidator
method Generic_Select
method InitializeComponent
method Load_Beschreibung
method Load_Dokumentpaket
method Load_Owners
method Load_Struktur_Daten
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MoveNode
method RichTextBoxHS1_KeyUp
method Save_Beschreibung
method Save_Dokumentpaket
method Save_Sort
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TreeDokVorlagen_DoubleClick
method TreeDokVorlagen_ItemDrag
method TreeDokVorlagen_MouseDown
method TreeSelektion_AfterSelect
method TreeStruktur_AfterSelect
method TreeStruktur_DragOver
method TreeStruktur_KeyDown
method TreeStruktur_MouseDown
method TreeView1_MouseMove
method btnsuche_Click
method ctmenuSelVorlagen_Popup
method ctmenuTreeDokVorlagen_Popup
method ctmnuAktKnotenOeffnen_Click
method ctmnuAktKnotenSchliessen_Click
method ctmnuKnotenOeffnen_Click
method ctmnuKnotenSchliessen_Click
method ctmnuVorlageInfo_Click
method ctmnuVorlageSelect_Click
method ctmnuselVorlagenInfo_Click
method ctmnuselvorlagenVorlageLoeschen_Click
method dokumentvorlage_suchen
method frmDokumentpaketdefinition_Closing
method frmDokumentpaketdefinition_Load
method load_dokumentpaket_dt
method loopother
method mnuMoveItemDown_Click
method mnuMoveItemUp_Click
method save_SortID
method treeSelVorlagen_DragDrop
method treeSelVorlagen_DragEnter
method treeSelVorlagen_Enter
method treeSelVorlagen_ItemDrag
method treeSelVorlagen_MouseDown
method treeStruktur_DragDrop
method treeStruktur_ItemDrag
method treeStruktur_dragenter
method txtBezeichnung_KeyUp
method txtBezeichnung_Leave
method txtBezeichnung_TextChanged
method txtSuchbegriff_KeyDown

Fields

field Aus_Formvalidate
field BtnHelp
field DokumenttypNummern
field FontDialog1
field ImageList1
field ImageList2
field ImageList3
field ImgListSteuerung
field LoadFromUebersicht
field MenuItem1
field MenuItem10
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field Moveitem
field Panel1
field Panel2
field Panel3
field RichTextBoxHS1
field ShowOnly
field Splitter1
field ToolBar1
field ToolTip1
field TreeDokVorlagen
field TreeSelektion
field TreeStruktur
field btnExit
field btnSave
field btnnew
field btnopen
field btnsuche
field cbAktiv
field cboowner
field components
field ctMenuStruktur
field ctmenuBeschreibung
field ctmenuSelVorlagen
field ctmenuTreeDokVorlagen
field ctmnuAktKnotenOeffnen
field ctmnuAktKnotenSchliessen
field ctmnuKnotenOeffnen
field ctmnuKnotenSchliessen
field ctmnuVorlageInfo
field ctmnuVorlageSelect
field ctmnuselVorlagenInfo
field ctmnuselvorlagenVorlageLoeschen
field dterstelltam
field dtmutiertam
field grpAllgemein
field haschanges
field i
field index
field lblBezeichnung
field lblErstelltam
field lblMutiertam
field lblOwner
field lblSuche
field lblWichtigeHinweise
field m_Mitarbeiterkopie
field m_anzeige
field m_dokumentpaketnr
field m_individuell
field m_kopie
field m_mitarbeiternr
field m_neu
field m_strukturnr
field mcbowner
field mnuMoveItemDown
field mnuMoveItemUp
field pnlBeschreibung
field pnlDokumentvorlagen
field pnlSelVorlagen
field pnlStruktur
field pnlTrenner
field selectPoint
field tn
field tn1
field treeSelVorlagen
field txtBezeichnung
field txtSuchbegriff
field txtWichtigeHinweise
field vonmitarbeiter

See Also

frmDokumentpaketdefinition Class


New

Overload List

[Visual Basic] Public Sub New(ByVal Dokumentpaketnr As Integer, ByVal mitarbeiternr As Integer)

[Visual Basic] Public Sub New(ByVal Neues_DP As Boolean, ByVal Dokumentpaketnr As Integer, ByVal individuelles_dp As Boolean, ByVal Dokumenttypnummern As String)

[Visual Basic] Public Sub New(ByVal Neues_DP As Boolean, ByVal dokumentpaketnr As Integer, ByVal individuelles_DP As Boolean)

[Visual Basic] Public Sub New(ByVal Neues_DP As Boolean, ByVal dokumentpaketnr As Integer, ByVal individuelles_DP As Boolean, ByVal ShowOnly As Boolean)

See Also

frmDokumentpaketdefinition | EDOKAApp


frmDokumentpaketdefinition Properties

frmDokumentpaketdefinition overview

Properties

property Anzeige
property Dokumentpaketnr
property Individuelles_DP
property Kopie
property MitarbeiterKopie
property Mitarbeiternr
property Neu
property StrukturNr

See Also

frmDokumentpaketdefinition Class


frmDokumentpaketdefinition.Anzeige Property

Property Anzeige() As Boolean

Source code

[Visual Basic]
    Property Anzeige() As Boolean
        Get
            Return m_anzeige
        End Get
        Set(ByVal Value As Boolean)
            m_anzeige = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Dokumentpaketnr Property

Property Dokumentpaketnr() As Integer

Source code

[Visual Basic]
    Property Dokumentpaketnr() As Integer
        Get
            Return m_dokumentpaketnr
        End Get
        Set(ByVal Value As Integer)
            m_dokumentpaketnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Individuelles_DP Property

Property Individuelles_DP() As Boolean

Source code

[Visual Basic]
    Property Individuelles_DP() As Boolean
        Get
            Return m_individuell
        End Get
        Set(ByVal Value As Boolean)
            m_individuell = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Kopie Property

Property Kopie() As Boolean

Source code

[Visual Basic]
    Property Kopie() As Boolean
        Get
            Return m_kopie
        End Get
        Set(ByVal Value As Boolean)
            m_kopie = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MitarbeiterKopie Property

Property MitarbeiterKopie() As Boolean

Source code

[Visual Basic]
    Property MitarbeiterKopie() As Boolean
        Get
            Return m_Mitarbeiterkopie
        End Get
        Set(ByVal Value As Boolean)
            m_Mitarbeiterkopie = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Mitarbeiternr Property

Property Mitarbeiternr() As Integer

Source code

[Visual Basic]
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Integer)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Neu Property

Property Neu() As Boolean

Source code

[Visual Basic]
    Property Neu() As Boolean
        Get
            Return m_neu
        End Get
        Set(ByVal Value As Boolean)
            m_neu = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.StrukturNr Property

Property StrukturNr() As Integer

Source code

[Visual Basic]
    Property StrukturNr() As Integer
        Get
            Return m_strukturnr
        End Get
        Set(ByVal Value As Integer)
            m_strukturnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition Methods

frmDokumentpaketdefinition overview

Methods

method BtnHelp_Click
method DelNode
method DeleteNodes
method Dispose
method FormValidator
method Generic_Select
method InitializeComponent
method Load_Beschreibung
method Load_Dokumentpaket
method Load_Owners
method Load_Struktur_Daten
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MoveNode
method RichTextBoxHS1_KeyUp
method Save_Beschreibung
method Save_Dokumentpaket
method Save_Sort
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TreeDokVorlagen_DoubleClick
method TreeDokVorlagen_ItemDrag
method TreeDokVorlagen_MouseDown
method TreeSelektion_AfterSelect
method TreeStruktur_AfterSelect
method TreeStruktur_DragOver
method TreeStruktur_KeyDown
method TreeStruktur_MouseDown
method TreeView1_MouseMove
method btnsuche_Click
method ctmenuSelVorlagen_Popup
method ctmenuTreeDokVorlagen_Popup
method ctmnuAktKnotenOeffnen_Click
method ctmnuAktKnotenSchliessen_Click
method ctmnuKnotenOeffnen_Click
method ctmnuKnotenSchliessen_Click
method ctmnuVorlageInfo_Click
method ctmnuVorlageSelect_Click
method ctmnuselVorlagenInfo_Click
method ctmnuselvorlagenVorlageLoeschen_Click
method dokumentvorlage_suchen
method frmDokumentpaketdefinition_Closing
method frmDokumentpaketdefinition_Load
method load_dokumentpaket_dt
method loopother
method mnuMoveItemDown_Click
method mnuMoveItemUp_Click
method save_SortID
method treeSelVorlagen_DragDrop
method treeSelVorlagen_DragEnter
method treeSelVorlagen_Enter
method treeSelVorlagen_ItemDrag
method treeSelVorlagen_MouseDown
method treeStruktur_DragDrop
method treeStruktur_ItemDrag
method treeStruktur_dragenter
method txtBezeichnung_KeyUp
method txtBezeichnung_Leave
method txtBezeichnung_TextChanged
method txtSuchbegriff_KeyDown

See Also

frmDokumentpaketdefinition Class


frmDokumentpaketdefinition.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentpaketdefinitionsdialog")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.DelNode Method

Private Sub DelNode( _
   ByVal tn As TreeNode _
)

Parameters

tn
Required.

Source code

[Visual Basic]
    Private Sub DelNode(ByVal tn As TreeNode)
        Dim df As New edokadb.clsEDEX_Favoriten()
        df.cpMainConnectionProvider = conn
        df.iNreintrag = New SqlInt32(CType(tn.Tag, Int32))
        conn.OpenConnection()
        df.Delete()
        conn.CloseConnection(True)
        df.Dispose()
        'Allfällige individuellen Dokumentpakete deaktivieren
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.edex_sp_dokumentpakete_inaktivieren"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, tn.Tag))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Inaktivieren Dokumentpakete fehlgeschlagen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.DeleteNodes Method

Public Sub DeleteNodes( _
   ByVal pn As TreeNode _
)

Parameters

pn
Required.

Source code

[Visual Basic]
    Public Sub DeleteNodes(ByVal pn As TreeNode)
        Dim i As Integer
        Dim tn As TreeNode

        For Each tn In pn.Nodes
            DelNode(tn)
            If tn.GetNodeCount(False) > 0 Then DeleteNodes(tn)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.FormValidator Method

Public Function FormValidator( _
   ByVal ShowErrors As Boolean _
) As Boolean

Parameters

ShowErrors
Required.

Source code

[Visual Basic]
    Public Function FormValidator(ByVal ShowErrors As Boolean) As Boolean
        Me.Aus_Formvalidate = True
        Dim SaveOK As Boolean = True
        Dim tn As TreeNode
        Dim ctn As TreeNode
        Dim ErrorMsg As String = "Das Dokumentpaket kann aus folgenden Gründen nicht gespeichert werden:"

        ctn = Me.TreeSelektion.SelectedNode

        DivFnkt.Searchnode(Me.TreeSelektion, 1, 0)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.txtBezeichnung.Text = "" Or Me.treeSelVorlagen.GetNodeCount(True) < 2 Then
                tn.ImageIndex = 1
                tn.SelectedImageIndex = 1
                SaveOK = False
                If ShowErrors Then
                    If Me.txtBezeichnung.Text = "" Then ErrorMsg = ErrorMsg + vbCrLf + "- Bezeichnung des Dokumentpaketes fehlt"
                    If Me.treeSelVorlagen.GetNodeCount(True) < 2 Then ErrorMsg = ErrorMsg + vbCrLf + "- Es müssen mind. 2 Vorlagen ausgewählt werden"
                End If
            Else
                tn.ImageIndex = 2
                tn.SelectedImageIndex = 2
            End If

        End If

        DivFnkt.Searchnode(Me.TreeSelektion, 2, 0)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.RichTextBoxHS1.Text.Length < 1 And Me.Individuelles_DP = False Then
                tn.ImageIndex = 1
                tn.SelectedImageIndex = 1
                SaveOK = False
                If ShowErrors Then ErrorMsg = ErrorMsg + vbCrLf + "- Die Beschreibung fehlt"
            Else
                tn.ImageIndex = 2
                tn.SelectedImageIndex = 2
            End If
        End If

        DivFnkt.Searchnode(Me.TreeSelektion, 3, 0)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.StrukturNr = 0 Then
                tn.ImageIndex = 1
                tn.SelectedImageIndex = 1
                SaveOK = False
                If ShowErrors Then ErrorMsg = ErrorMsg + vbCrLf + "- Die Zuordnung zur Struktur fehlt"
            Else
                Try
                    If Me.TreeStruktur.SelectedNode.Tag Is Nothing Then
                        tn.ImageIndex = 1
                        tn.SelectedImageIndex = 1
                        SaveOK = False
                        If ShowErrors Then ErrorMsg = ErrorMsg + vbCrLf + "- Die Zuordnung zur Struktur fehlt"
                    Else
                        tn.ImageIndex = 2
                        tn.SelectedImageIndex = 2

                    End If
                Catch
                    Try
                        If Me.TreeStruktur.Nodes(0).Tag = Me.StrukturNr Then
                            tn.ImageIndex = 2
                            tn.SelectedImageIndex = 2
                            Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
                            DivFnkt.Searchnode(Me.TreeSelektion, ctn.Tag, 0)
                            Exit Function
                        End If
                    Catch
                    End Try
                    tn.ImageIndex = 1
                    tn.SelectedImageIndex = 1
                    SaveOK = False
                    If ShowErrors Then ErrorMsg = ErrorMsg + vbCrLf + "- Die Zuordnung zur Struktur fehlt"
                End Try
            End If
        Else
            SaveOK = False
            If ShowErrors Then ErrorMsg = ErrorMsg + vbCrLf + "- Die Zuordnung zur Struktur fehlt"
        End If
        DivFnkt.Searchnode(Me.TreeSelektion, ctn.Tag, 0)
        Me.Aus_Formvalidate = False

        If SaveOK = False Then
            If ShowErrors = True Then MsgBox(ErrorMsg, MsgBoxStyle.Critical, "Dokumentpaket speichern")
            Return False
        End If
        Me.btnSave.Enabled = True
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "edex_sp_dokumentpaketvorlagen_delete"
            Case 2
                scmCmdToExecute.CommandText = "edex_sp_dokumentpaketvorlagen_select"
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Select Case typ
            Case 1, 2
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentpaketnr))
        End Select

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentpaketdefinition))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnExit = New System.Windows.Forms.ToolBarButton()
        Me.btnSave = New System.Windows.Forms.ToolBarButton()
        Me.btnnew = New System.Windows.Forms.ToolBarButton()
        Me.btnopen = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.grpAllgemein = New System.Windows.Forms.GroupBox()
        Me.cbAktiv = New System.Windows.Forms.CheckBox()
        Me.dtmutiertam = New System.Windows.Forms.DateTimePicker()
        Me.dterstelltam = New System.Windows.Forms.DateTimePicker()
        Me.lblErstelltam = New System.Windows.Forms.Label()
        Me.lblMutiertam = New System.Windows.Forms.Label()
        Me.cboowner = New System.Windows.Forms.ComboBox()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.lblBezeichnung = New System.Windows.Forms.Label()
        Me.lblOwner = New System.Windows.Forms.Label()
        Me.TreeSelektion = New System.Windows.Forms.TreeView()
        Me.ImgListSteuerung = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlDokumentvorlagen = New System.Windows.Forms.GroupBox()
        Me.TreeDokVorlagen = New System.Windows.Forms.TreeView()
        Me.ctmenuTreeDokVorlagen = New System.Windows.Forms.ContextMenu()
        Me.ctmnuVorlageSelect = New System.Windows.Forms.MenuItem()
        Me.ctmnuVorlageInfo = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.ctmnuKnotenSchliessen = New System.Windows.Forms.MenuItem()
        Me.ctmnuKnotenOeffnen = New System.Windows.Forms.MenuItem()
        Me.ctmnuAktKnotenSchliessen = New System.Windows.Forms.MenuItem()
        Me.ctmnuAktKnotenOeffnen = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.pnlTrenner = New System.Windows.Forms.Panel()
        Me.btnsuche = New System.Windows.Forms.Button()
        Me.txtSuchbegriff = New System.Windows.Forms.TextBox()
        Me.lblSuche = New System.Windows.Forms.Label()
        Me.pnlSelVorlagen = New System.Windows.Forms.GroupBox()
        Me.treeSelVorlagen = New System.Windows.Forms.TreeView()
        Me.ctmenuSelVorlagen = New System.Windows.Forms.ContextMenu()
        Me.ctmnuselvorlagenVorlageLoeschen = New System.Windows.Forms.MenuItem()
        Me.ctmnuselVorlagenInfo = New System.Windows.Forms.MenuItem()
        Me.pnlBeschreibung = New System.Windows.Forms.GroupBox()
        Me.RichTextBoxHS1 = New EDOKAApp.RichTextBoxHS()
        Me.ctmenuBeschreibung = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.txtWichtigeHinweise = New System.Windows.Forms.TextBox()
        Me.lblWichtigeHinweise = New System.Windows.Forms.Label()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.FontDialog1 = New System.Windows.Forms.FontDialog()
        Me.pnlStruktur = New System.Windows.Forms.GroupBox()
        Me.TreeStruktur = New System.Windows.Forms.TreeView()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ctMenuStruktur = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.mnuMoveItemUp = New System.Windows.Forms.MenuItem()
        Me.mnuMoveItemDown = New System.Windows.Forms.MenuItem()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.grpAllgemein.SuspendLayout()
        Me.pnlDokumentvorlagen.SuspendLayout()
        Me.pnlTrenner.SuspendLayout()
        Me.pnlSelVorlagen.SuspendLayout()
        Me.pnlBeschreibung.SuspendLayout()
        Me.Panel1.SuspendLayout()
        Me.pnlStruktur.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnExit, Me.btnSave, Me.btnnew, Me.btnopen})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(816, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnExit
        '
        Me.btnExit.ImageIndex = 0
        Me.btnExit.ToolTipText = "Verlassen"
        '
        'btnSave
        '
        Me.btnSave.ImageIndex = 2
        Me.btnSave.ToolTipText = "Speichern"
        '
        'btnnew
        '
        Me.btnnew.ImageIndex = 3
        Me.btnnew.ToolTipText = "Neues Dokumentpaket erstellen"
        '
        'btnopen
        '
        Me.btnopen.ImageIndex = 9
        Me.btnopen.ToolTipText = "Übersicht vorhandener Dokumentpakete und Auswahl"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'grpAllgemein
        '
        Me.grpAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbAktiv, Me.dtmutiertam, Me.dterstelltam, Me.lblErstelltam, Me.lblMutiertam, Me.cboowner, Me.txtBezeichnung, Me.lblBezeichnung, Me.lblOwner})
        Me.grpAllgemein.Dock = System.Windows.Forms.DockStyle.Top
        Me.grpAllgemein.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.grpAllgemein.Location = New System.Drawing.Point(179, 25)
        Me.grpAllgemein.Name = "grpAllgemein"
        Me.grpAllgemein.Size = New System.Drawing.Size(637, 71)
        Me.grpAllgemein.TabIndex = 1
        Me.grpAllgemein.TabStop = False
        Me.grpAllgemein.Text = "Allgemeine Informationen"
        '
        'cbAktiv
        '
        Me.cbAktiv.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.cbAktiv.Location = New System.Drawing.Point(576, 16)
        Me.cbAktiv.Name = "cbAktiv"
        Me.cbAktiv.Size = New System.Drawing.Size(48, 24)
        Me.cbAktiv.TabIndex = 2
        Me.cbAktiv.Text = "Aktiv"
        '
        'dtmutiertam
        '
        Me.dtmutiertam.Enabled = False
        Me.dtmutiertam.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.dtmutiertam.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtmutiertam.Location = New System.Drawing.Point(456, 40)
        Me.dtmutiertam.Name = "dtmutiertam"
        Me.dtmutiertam.Size = New System.Drawing.Size(88, 20)
        Me.dtmutiertam.TabIndex = 7
        Me.dtmutiertam.TabStop = False
        '
        'dterstelltam
        '
        Me.dterstelltam.Enabled = False
        Me.dterstelltam.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.dterstelltam.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dterstelltam.Location = New System.Drawing.Point(456, 16)
        Me.dterstelltam.Name = "dterstelltam"
        Me.dterstelltam.Size = New System.Drawing.Size(88, 20)
        Me.dterstelltam.TabIndex = 6
        Me.dterstelltam.TabStop = False
        '
        'lblErstelltam
        '
        Me.lblErstelltam.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblErstelltam.Location = New System.Drawing.Point(400, 16)
        Me.lblErstelltam.Name = "lblErstelltam"
        Me.lblErstelltam.Size = New System.Drawing.Size(88, 23)
        Me.lblErstelltam.TabIndex = 4
        Me.lblErstelltam.Text = "Erstellt am"
        '
        'lblMutiertam
        '
        Me.lblMutiertam.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblMutiertam.Location = New System.Drawing.Point(400, 40)
        Me.lblMutiertam.Name = "lblMutiertam"
        Me.lblMutiertam.Size = New System.Drawing.Size(88, 23)
        Me.lblMutiertam.TabIndex = 5
        Me.lblMutiertam.Text = "Mutiert am"
        '
        'cboowner
        '
        Me.cboowner.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.cboowner.Location = New System.Drawing.Point(88, 40)
        Me.cboowner.Name = "cboowner"
        Me.cboowner.Size = New System.Drawing.Size(296, 21)
        Me.cboowner.TabIndex = 3
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.txtBezeichnung.Location = New System.Drawing.Point(88, 16)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(296, 20)
        Me.txtBezeichnung.TabIndex = 1
        Me.txtBezeichnung.Text = ""
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblBezeichnung.Location = New System.Drawing.Point(16, 16)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(88, 23)
        Me.lblBezeichnung.TabIndex = 0
        Me.lblBezeichnung.Text = "Bezeichnung"
        '
        'lblOwner
        '
        Me.lblOwner.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblOwner.Location = New System.Drawing.Point(16, 40)
        Me.lblOwner.Name = "lblOwner"
        Me.lblOwner.Size = New System.Drawing.Size(64, 23)
        Me.lblOwner.TabIndex = 3
        Me.lblOwner.Text = "Owner"
        '
        'TreeSelektion
        '
        Me.TreeSelektion.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.TreeSelektion.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeSelektion.HideSelection = False
        Me.TreeSelektion.ImageList = Me.ImgListSteuerung
        Me.TreeSelektion.Location = New System.Drawing.Point(0, 25)
        Me.TreeSelektion.Name = "TreeSelektion"
        Me.TreeSelektion.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Definition Dokumentpaket", 0, 0, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Vorlagen-Selektion", 0, 0), New System.Windows.Forms.TreeNode("Beschreibung", 0, 0), New System.Windows.Forms.TreeNode("Struktur", 0, 0)})})
        Me.TreeSelektion.Size = New System.Drawing.Size(176, 476)
        Me.TreeSelektion.TabIndex = 2
        Me.TreeSelektion.TabStop = False
        '
        'ImgListSteuerung
        '
        Me.ImgListSteuerung.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImgListSteuerung.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImgListSteuerung.ImageStream = CType(resources.GetObject("ImgListSteuerung.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImgListSteuerung.TransparentColor = System.Drawing.Color.Transparent
        '
        'pnlDokumentvorlagen
        '
        Me.pnlDokumentvorlagen.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeDokVorlagen, Me.pnlTrenner})
        Me.pnlDokumentvorlagen.Dock = System.Windows.Forms.DockStyle.Left
        Me.pnlDokumentvorlagen.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.pnlDokumentvorlagen.Location = New System.Drawing.Point(179, 104)
        Me.pnlDokumentvorlagen.Name = "pnlDokumentvorlagen"
        Me.pnlDokumentvorlagen.Size = New System.Drawing.Size(389, 397)
        Me.pnlDokumentvorlagen.TabIndex = 3
        Me.pnlDokumentvorlagen.TabStop = False
        Me.pnlDokumentvorlagen.Text = "Dokumentvorlagen"
        '
        'TreeDokVorlagen
        '
        Me.TreeDokVorlagen.ContextMenu = Me.ctmenuTreeDokVorlagen
        Me.TreeDokVorlagen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeDokVorlagen.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.TreeDokVorlagen.ImageList = Me.ImageList3
        Me.TreeDokVorlagen.Location = New System.Drawing.Point(3, 40)
        Me.TreeDokVorlagen.Name = "TreeDokVorlagen"
        Me.TreeDokVorlagen.Size = New System.Drawing.Size(383, 354)
        Me.TreeDokVorlagen.TabIndex = 1
        Me.TreeDokVorlagen.TabStop = False
        '
        'ctmenuTreeDokVorlagen
        '
        Me.ctmenuTreeDokVorlagen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.ctmnuVorlageSelect, Me.ctmnuVorlageInfo, Me.MenuItem10, Me.ctmnuKnotenSchliessen, Me.ctmnuKnotenOeffnen, Me.ctmnuAktKnotenSchliessen, Me.ctmnuAktKnotenOeffnen})
        '
        'ctmnuVorlageSelect
        '
        Me.ctmnuVorlageSelect.Index = 0
        Me.ctmnuVorlageSelect.Text = "&Vorlage auswählen"
        '
        'ctmnuVorlageInfo
        '
        Me.ctmnuVorlageInfo.Index = 1
        Me.ctmnuVorlageInfo.Text = "&Informationen zur Vorlagen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 2
        Me.MenuItem10.Text = "-"
        '
        'ctmnuKnotenSchliessen
        '
        Me.ctmnuKnotenSchliessen.Index = 3
        Me.ctmnuKnotenSchliessen.Text = "&Alle Knoten schliessen"
        '
        'ctmnuKnotenOeffnen
        '
        Me.ctmnuKnotenOeffnen.Index = 4
        Me.ctmnuKnotenOeffnen.Text = "A&lle Knoten öffnen"
        '
        'ctmnuAktKnotenSchliessen
        '
        Me.ctmnuAktKnotenSchliessen.Index = 5
        Me.ctmnuAktKnotenSchliessen.Text = "&Selektierter Knoten schliessen"
        '
        'ctmnuAktKnotenOeffnen
        '
        Me.ctmnuAktKnotenOeffnen.Index = 6
        Me.ctmnuAktKnotenOeffnen.Text = "&Selektierter Knoten öffnen"
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'pnlTrenner
        '
        Me.pnlTrenner.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnsuche, Me.txtSuchbegriff, Me.lblSuche})
        Me.pnlTrenner.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlTrenner.Location = New System.Drawing.Point(3, 16)
        Me.pnlTrenner.Name = "pnlTrenner"
        Me.pnlTrenner.Size = New System.Drawing.Size(383, 24)
        Me.pnlTrenner.TabIndex = 0
        '
        'btnsuche
        '
        Me.btnsuche.Image = CType(resources.GetObject("btnsuche.Image"), System.Drawing.Bitmap)
        Me.btnsuche.Location = New System.Drawing.Point(362, 0)
        Me.btnsuche.Name = "btnsuche"
        Me.btnsuche.Size = New System.Drawing.Size(21, 21)
        Me.btnsuche.TabIndex = 5
        '
        'txtSuchbegriff
        '
        Me.txtSuchbegriff.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.txtSuchbegriff.Location = New System.Drawing.Point(56, 0)
        Me.txtSuchbegriff.Name = "txtSuchbegriff"
        Me.txtSuchbegriff.Size = New System.Drawing.Size(304, 20)
        Me.txtSuchbegriff.TabIndex = 4
        Me.txtSuchbegriff.Text = ""
        '
        'lblSuche
        '
        Me.lblSuche.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblSuche.Location = New System.Drawing.Point(8, 2)
        Me.lblSuche.Name = "lblSuche"
        Me.lblSuche.Size = New System.Drawing.Size(96, 23)
        Me.lblSuche.TabIndex = 0
        Me.lblSuche.Text = "Suchen"
        '
        'pnlSelVorlagen
        '
        Me.pnlSelVorlagen.Controls.AddRange(New System.Windows.Forms.Control() {Me.treeSelVorlagen})
        Me.pnlSelVorlagen.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.pnlSelVorlagen.Location = New System.Drawing.Point(600, 112)
        Me.pnlSelVorlagen.Name = "pnlSelVorlagen"
        Me.pnlSelVorlagen.TabIndex = 4
        Me.pnlSelVorlagen.TabStop = False
        Me.pnlSelVorlagen.Text = "Ausgewählte Vorlagen"
        '
        'treeSelVorlagen
        '
        Me.treeSelVorlagen.CheckBoxes = True
        Me.treeSelVorlagen.ContextMenu = Me.ctmenuSelVorlagen
        Me.treeSelVorlagen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.treeSelVorlagen.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.treeSelVorlagen.ImageList = Me.ImageList3
        Me.treeSelVorlagen.Location = New System.Drawing.Point(3, 16)
        Me.treeSelVorlagen.Name = "treeSelVorlagen"
        Me.treeSelVorlagen.Size = New System.Drawing.Size(194, 81)
        Me.treeSelVorlagen.TabIndex = 0
        Me.treeSelVorlagen.TabStop = False
        '
        'ctmenuSelVorlagen
        '
        Me.ctmenuSelVorlagen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.ctmnuselvorlagenVorlageLoeschen, Me.ctmnuselVorlagenInfo})
        '
        'ctmnuselvorlagenVorlageLoeschen
        '
        Me.ctmnuselvorlagenVorlageLoeschen.Index = 0
        Me.ctmnuselvorlagenVorlageLoeschen.Text = "Vorlage aus Dokumentpaket löschen"
        '
        'ctmnuselVorlagenInfo
        '
        Me.ctmnuselVorlagenInfo.Index = 1
        Me.ctmnuselVorlagenInfo.Text = "Informationen zur Dokumentvorlage"
        '
        'pnlBeschreibung
        '
        Me.pnlBeschreibung.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBoxHS1, Me.Panel1})
        Me.pnlBeschreibung.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.pnlBeschreibung.Location = New System.Drawing.Point(600, 216)
        Me.pnlBeschreibung.Name = "pnlBeschreibung"
        Me.pnlBeschreibung.Size = New System.Drawing.Size(200, 136)
        Me.pnlBeschreibung.TabIndex = 5
        Me.pnlBeschreibung.TabStop = False
        Me.pnlBeschreibung.Text = "Beschreibung"
        '
        'RichTextBoxHS1
        '
        Me.RichTextBoxHS1.AcceptsTab = True
        Me.RichTextBoxHS1.ContextMenu = Me.ctmenuBeschreibung
        Me.RichTextBoxHS1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.RichTextBoxHS1.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.RichTextBoxHS1.Location = New System.Drawing.Point(3, 16)
        Me.RichTextBoxHS1.Name = "RichTextBoxHS1"
        Me.RichTextBoxHS1.Size = New System.Drawing.Size(194, 37)
        Me.RichTextBoxHS1.TabIndex = 6
        Me.RichTextBoxHS1.Text = ""
        '
        'ctmenuBeschreibung
        '
        Me.ctmenuBeschreibung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Schriftart..."
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Gelb markieren"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "&Markierungen löschen"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtWichtigeHinweise, Me.lblWichtigeHinweise, Me.Panel2})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(3, 53)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(194, 80)
        Me.Panel1.TabIndex = 4
        '
        'txtWichtigeHinweise
        '
        Me.txtWichtigeHinweise.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtWichtigeHinweise.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.txtWichtigeHinweise.Location = New System.Drawing.Point(0, 24)
        Me.txtWichtigeHinweise.MaxLength = 1024
        Me.txtWichtigeHinweise.Multiline = True
        Me.txtWichtigeHinweise.Name = "txtWichtigeHinweise"
        Me.txtWichtigeHinweise.Size = New System.Drawing.Size(194, 56)
        Me.txtWichtigeHinweise.TabIndex = 7
        Me.txtWichtigeHinweise.Text = ""
        '
        'lblWichtigeHinweise
        '
        Me.lblWichtigeHinweise.Dock = System.Windows.Forms.DockStyle.Top
        Me.lblWichtigeHinweise.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblWichtigeHinweise.Location = New System.Drawing.Point(0, 8)
        Me.lblWichtigeHinweise.Name = "lblWichtigeHinweise"
        Me.lblWichtigeHinweise.Size = New System.Drawing.Size(194, 16)
        Me.lblWichtigeHinweise.TabIndex = 0
        Me.lblWichtigeHinweise.Text = "Wichtige Hinweise"
        '
        'Panel2
        '
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(194, 8)
        Me.Panel2.TabIndex = 1
        '
        'pnlStruktur
        '
        Me.pnlStruktur.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeStruktur})
        Me.pnlStruktur.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.pnlStruktur.Location = New System.Drawing.Point(600, 352)
        Me.pnlStruktur.Name = "pnlStruktur"
        Me.pnlStruktur.TabIndex = 6
        Me.pnlStruktur.TabStop = False
        Me.pnlStruktur.Text = "Struktur"
        '
        'TreeStruktur
        '
        Me.TreeStruktur.AllowDrop = True
        Me.TreeStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TreeStruktur.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.TreeStruktur.ImageList = Me.ImageList2
        Me.TreeStruktur.Location = New System.Drawing.Point(3, 16)
        Me.TreeStruktur.Name = "TreeStruktur"
        Me.TreeStruktur.Size = New System.Drawing.Size(194, 81)
        Me.TreeStruktur.TabIndex = 0
        Me.TreeStruktur.TabStop = False
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ctMenuStruktur
        '
        Me.ctMenuStruktur.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7, Me.mnuMoveItemUp, Me.mnuMoveItemDown})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Shortcut = System.Windows.Forms.Shortcut.F2
        Me.MenuItem4.Text = "Umbenennen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 1
        Me.MenuItem5.Shortcut = System.Windows.Forms.Shortcut.Del
        Me.MenuItem5.Text = "Löschen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 2
        Me.MenuItem6.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.MenuItem6.Text = "Neuer Ordner"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 3
        Me.MenuItem7.Text = "-"
        '
        'mnuMoveItemUp
        '
        Me.mnuMoveItemUp.Index = 4
        Me.mnuMoveItemUp.Text = "&Aufwärts"
        '
        'mnuMoveItemDown
        '
        Me.mnuMoveItemDown.Index = 5
        Me.mnuMoveItemDown.Text = "Abbwärts"
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(176, 25)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 476)
        Me.Splitter1.TabIndex = 7
        Me.Splitter1.TabStop = False
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(790, 6)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 68
        Me.BtnHelp.TabStop = False
        '
        'Panel3
        '
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel3.Location = New System.Drawing.Point(179, 96)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(637, 8)
        Me.Panel3.TabIndex = 69
        '
        'frmDokumentpaketdefinition
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(816, 501)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlStruktur, Me.pnlBeschreibung, Me.pnlSelVorlagen, Me.pnlDokumentvorlagen, Me.Panel3, Me.BtnHelp, Me.grpAllgemein, Me.Splitter1, Me.TreeSelektion, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentpaketdefinition"
        Me.ShowInTaskbar = False
        Me.Text = "Dokumentpaket-Definition"
        Me.grpAllgemein.ResumeLayout(False)
        Me.pnlDokumentvorlagen.ResumeLayout(False)
        Me.pnlTrenner.ResumeLayout(False)
        Me.pnlSelVorlagen.ResumeLayout(False)
        Me.pnlBeschreibung.ResumeLayout(False)
        Me.Panel1.ResumeLayout(False)
        Me.pnlStruktur.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Load_Beschreibung Method

Private Sub Load_Beschreibung()

Source code

[Visual Basic]
    Private Sub Load_Beschreibung()
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From EDEX_dokumentpaket where dokumentpaketnr=" + Str(Me.Dokumentpaketnr), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docbeschreibung")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(5)
            Dim K As Long
            K = UBound(MyData)

            Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Me.RichTextBoxHS1.LoadFile(dokname)
        Catch ex As Exception

        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Load_Dokumentpaket Method

Private Sub Load_Dokumentpaket( _
   ByVal Inaktive_Vorlage_Loeschen As Boolean _
)

Parameters

Inaktive_Vorlage_Loeschen
Required.

Source code

[Visual Basic]
    Private Sub Load_Dokumentpaket(ByVal Inaktive_Vorlage_Loeschen As Boolean)
        'Dokumentpaket
        Dim dp As New edokadb.clsEdex_dokumentpaket()
        dp.cpMainConnectionProvider = conn
        dp.iDokumentpaketnr = New SqlInt32(CType(Me.Dokumentpaketnr, Int32))
        dp.SelectOne()
        Me.txtBezeichnung.Text = dp.sBezeichnung.Value
        i = dp.iOwner.Value
        Me.mcbowner.SelectedValue = i
        Me.cbAktiv.Checked = dp.bAktiv.Value = True
        DivFnkt.Searchnode(Me.TreeStruktur, dp.iDokumentartnr.Value, 1)
        If DivFnkt.found = False Then
            '          Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
        End If
        Me.dterstelltam.Value = dp.daErstellt_am.Value
        Me.dtmutiertam.Value = dp.daMutiert_am.Value
        Me.txtWichtigeHinweise.Text = dp.sWichtigehinweise.Value
        Me.StrukturNr = dp.iDokumentartnr.Value
        DivFnkt.Searchnode1(Me.TreeStruktur, Me.StrukturNr, 0)
        If DivFnkt.found Then
            Me.StrukturNr = DivFnkt.FoundNode.Tag
        Else
            Me.StrukturNr = Me.TreeStruktur.Nodes(0).Tag
        End If
        dp.Dispose()

        'Dokumentpaketvorlagen
        Dim dpv As DataTable
        dpv = Generic_Select(2)
        Me.treeSelVorlagen.Nodes.Clear()

        Dim tn As TreeNode
        For i = 0 To dpv.Rows.Count - 1
            If (dpv.Rows(i).Item("dtaktiv") = False And (Me.Individuelles_DP = False Or Me.Kopie = True)) Or Inaktive_Vorlage_Loeschen = True Then
            Else
                tn = Me.treeSelVorlagen.Nodes.Add(dpv.Rows(i).Item("doktypbezeichnung"))
                tn.Checked = dpv.Rows(i).Item("zwingend") = 1
                tn.ImageIndex = dpv.Rows(i).Item("imageindex")
                tn.SelectedImageIndex = dpv.Rows(i).Item("imageindex")
                tn.Tag = "DT_" + LTrim(Str(dpv.Rows(i).Item("dokumenttypnr")))
                Try
                    If dpv.Rows(i).Item("dtaktiv") = 0 Then
                        tn.NodeFont = New System.Drawing.Font(Me.treeSelVorlagen.Font.FontFamily, treeSelVorlagen.Font.Size, FontStyle.Strikeout)
                    End If
                Catch ex As Exception

                End Try
            End If
        Next

        'Beschreibung
        Load_Beschreibung()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Load_Owners Method

Private Sub Load_Owners()

Source code

[Visual Basic]
    Private Sub Load_Owners()
        Dim ii As Integer
        mcbowner = New MultiComboBox(cboowner)
        Me.mcbowner.DisplayColumnName = "name"
        Me.mcbowner.ValueColumnName = "mitarbeiternr"
        Me.mcbowner.Fill_Data(Generic_Select(3), False)
        Me.cboowner.Visible = True
        Me.mcbowner.Visible = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Load_Struktur_Daten Method

Private Sub Load_Struktur_Daten()

Source code

[Visual Basic]
    Private Sub Load_Struktur_Daten()
        Dim d As New edokadb.clsMyDokumentart()
        If Me.Individuelles_DP = False Then
            d.LoadTreeMenu(Me.TreeStruktur, 173)
            Me.TreeStruktur.ExpandAll()
            Me.TreeStruktur.AllowDrop = False
        Else
            d.Load_FavoritenStruktur_dp(Me.TreeStruktur, "", True, 1)
            Me.TreeStruktur.ExpandAll()
            Me.TreeStruktur.AllowDrop = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Me.FontDialog1.ShowColor = True
        Me.FontDialog1.ShowApply = True
        Me.FontDialog1.ShowEffects = True
        Me.FontDialog1.ShowDialog()
        RichTextBoxHS1.SelectionFont = Me.FontDialog1.Font
        RichTextBoxHS1.SelectionColor = Me.FontDialog1.Color
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        RichTextBoxHS1.SelectionBackColor = System.Drawing.Color.Yellow
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        RichTextBoxHS1.BackColorSetWhole(System.Drawing.Color.White)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.TreeStruktur.SelectedNode.Text = a
        Dim df As New edokadb.clsEDEX_Favoriten()
        df.cpMainConnectionProvider = conn
        conn.OpenConnection()
        df.iNreintrag = New SqlInt32(CType(Me.TreeStruktur.SelectedNode.Tag, Int32))
        df.SelectOne()
        df.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        df.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        df.sBezeichnung = New SqlString(CType(Me.TreeStruktur.SelectedNode.Text, String))
        df.bAktiv = New SqlBoolean(CType(True, Boolean))
        df.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        df.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        Try
            df.Update()
            conn.CloseConnection(True)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Dim tn As TreeNode
        tn = Me.TreeStruktur.SelectedNode
        If tn.Parent Is Nothing Then
            MyMsg.show_standardmessage(400, MsgBoxStyle.Information)
            '            MsgBox("Die Root-Einträge können nicht gelöscht werden.", MsgBoxStyle.Information)
            Exit Sub

        End If

        Dim answer As MsgBoxResult
        answer = MyMsg.show_MessageYesNo_ReplaceText(401, tn.Text, "")
        'answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' inkl. allfälligen Untereinträgen löschen?" + vbCrLf + "(Individuelle Dokumentpakete werden inaktiviert)", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        If answer = MsgBoxResult.No Then Exit Sub
        DeleteNodes(Me.TreeStruktur.SelectedNode)
        DelNode(tn)
        tn.Remove()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Dim sNodeText As String
        Dim iDokumentFavoritenNr As Integer

        sNodeText = InputBox("Neuer Ordnername", "Neuer Favoritenordner hinzufügen")
        If sNodeText = "" Then Exit Sub
        Dim fs As New edokadb.clsEDEX_Favoriten()
        fs.cpMainConnectionProvider = conn
        fs.sBezeichnung = New SqlString(CType(sNodeText, String))
        fs.bAktiv = New SqlBoolean(CType(True, Boolean))
        fs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        fs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        fs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        fs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iParentid = New SqlInt32(CType(Me.TreeStruktur.SelectedNode.Tag, Int32))
        fs.iSort = New SqlInt32(CType(0, Int32))
        fs.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        fs.iImageindex = New SqlInt32(CType(60, Int32))
        fs.iImageindexopen = New SqlInt32(CType(60, Int32))
        fs.bDp = New SqlBoolean(CType(True, Boolean))
        fs.bStddp = New SqlBoolean(CType(False, Boolean))
        fs.iDtnr_dpnr = New SqlInt32(CType(0, Int32))
        fs.bStrukturelement = New SqlBoolean(CType(True, Boolean))
        conn.OpenConnection()
        Try
            fs.Insert()
            iDokumentFavoritenNr = fs.iNreintrag.Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            fs.Dispose()
        End Try
        Me.Load_Struktur_Daten()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.MoveNode Method

Private Sub MoveNode( _
   ByVal direction As Integer _
)

Parameters

direction
Required.

Source code

[Visual Basic]
    Private Sub MoveNode(ByVal direction As Integer)
        If Me.Individuelles_DP = False Then Exit Sub
        Dim tn As TreeNode
        Dim tnp As TreeNode
        Dim index As Integer
        tn = Me.TreeStruktur.SelectedNode
        If tn.Parent Is Nothing Then Exit Sub
        tnp = tn.Parent

        If tnp.GetNodeCount(True) < 1 Then
            Exit Sub
        End If

        If direction = 1 And tn.Index > 0 Then
            index = tn.Index - 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If
        If direction = 2 And tn.Index < tnp.GetNodeCount(True) Then
            index = tn.Index + 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If

        Dim i As Integer
        Me.Save_Sort()
        DivFnkt.Searchnode(TreeStruktur, tn.Tag, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.RichTextBoxHS1_KeyUp Method

Private Sub RichTextBoxHS1_KeyUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles RichTextBoxHS1.KeyUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RichTextBoxHS1_KeyUp(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles RichTextBoxHS1.KeyUp
        Me.FormValidator(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Save_Beschreibung Method

Private Sub Save_Beschreibung()

Source code

[Visual Basic]
    Private Sub Save_Beschreibung()
        Dim Connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From edex_dokumentpaket where dokumentpaketnr=" + Str(Me.Dokumentpaketnr), Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Me.RichTextBoxHS1.SaveFile(dokname)
        Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        Try
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            myRow.Item(5) = mydata
            da.Update(ds, "docs")
        Catch ex As Exception
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
        Finally
            fs = Nothing
            cb = Nothing
            ds = Nothing
            da = Nothing
            Connection.Close()
            Connection = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Save_Dokumentpaket Method

Public Sub Save_Dokumentpaket()

Source code

[Visual Basic]
    Public Sub Save_Dokumentpaket()
        If Me.FormValidator(True) = False Then Exit Sub
        Me.haschanges = False
        'Save Paket

        Dim key As Integer
        Dim dp As New edokadb.clsEdex_dokumentpaket()
        dp.cpMainConnectionProvider = conn

        If Neu Then
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("edex_dokumentpaket")
            dbkey.Dispose()
            Me.Dokumentpaketnr = key
        Else
            key = Me.Dokumentpaketnr
            dp.iDokumentpaketnr = New SqlInt32(CType(key, Int32))
            dp.SelectOne()
        End If

        dp.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
        dp.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        dp.sBeschreibung = New SqlString(CType("", String))
        dp.iOwner = New SqlInt32(CType(Me.mcbowner.SelectedValue, Int32))
        dp.bIndividuelles_dp = New SqlBoolean(CType(Me.Individuelles_DP, Boolean))
        dp.iDokumentartnr = New SqlInt32(CType(Me.TreeStruktur.SelectedNode.Tag, Int32))
        dp.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        dp.bAktiv = New SqlBoolean(CType(Me.cbAktiv.Checked, Boolean))
        dp.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        dp.sWichtigehinweise = New SqlString(CType(Me.txtWichtigeHinweise.Text, String))

        conn.OpenConnection()
        If Neu Then
            dp.iDokumentpaketnr = New SqlInt32(CType(key, Int32))
            dp.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            dp.iSort = New SqlInt32(CType(0, Int32))
            dp.Insert()
        Else
            dp.Update()
        End If
        conn.CloseConnection(True)
        dp.Dispose()

        'Save Paketvorlagen
        'Zuerst bestehende Vorlagen löschen
        Generic_Select(1)

        Dim dpv As New edokadb.clsEdex_dokumentpaketvorlage()
        dpv.cpMainConnectionProvider = conn

        Dim tn As TreeNode
        For Each tn In Me.treeSelVorlagen.Nodes
            dpv.bAktiv = New SqlBoolean(CType(True, Boolean))
            dpv.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            dpv.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            dpv.iDokumentpaketnr = New SqlInt32(CType(Me.Dokumentpaketnr, Int32))
            dpv.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            dpv.iSort = New SqlInt32(CType(tn.Index, Int32))
            dpv.iDokumenttypnr = New SqlInt32(CType(TagValue(tn.Tag), Int32))
            dpv.iImageindex = New SqlInt32(CType(tn.ImageIndex, Int32))
            If tn.Checked = True Then
                dpv.iZwingend = New SqlInt32(CType(1, Int32))
            Else
                dpv.iZwingend = New SqlInt32(CType(0, Int32))
            End If
            conn.OpenConnection()
            dpv.Insert()
            conn.CloseConnection(True)
        Next
        dpv.Dispose()

        ' Beschreibung speichern
        Save_Beschreibung()
        Me.Neu = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.Save_Sort Method

Private Sub Save_Sort()

Source code

[Visual Basic]
    Private Sub Save_Sort()
        Dim TNODE As TreeNode
        For Each TNODE In TreeStruktur.Nodes
            If Not TNODE.Parent Is Nothing Then
                save_SortID(TNODE.Parent.Tag, TNODE.Tag, TNODE.Index)
            End If
            loopother(TNODE)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TagArt Method

Private Function TagArt( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagArt(ByVal tag As String) As String
        Dim Art As String
        Art = tag
        Return Art.Substring(0, 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TagValue Method

Private Function TagValue( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagValue(ByVal tag As String) As String
        Dim Keyvalue As String
        Keyvalue = tag
        Return Keyvalue.Substring(3, Len(Keyvalue) - 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Save
                Save_Dokumentpaket()
            Case 2 'neu
                If Me.haschanges = True Then
                    Dim i As Integer
                    i = MyMsg.Show_MessageYesNoCancel(2)
                    If i = MsgBoxResult.Cancel Then Exit Sub
                    If i = MsgBoxResult.Yes Then
                        If Me.FormValidator(True) = False Then
                            Exit Sub
                        Else
                            Me.Save_Dokumentpaket()
                        End If
                    End If
                End If

                Me.Neu = True
                Me.Kopie = False
                Me.TreeSelektion.SelectedNode = Me.TreeSelektion.Nodes(0)
                Me.treeSelVorlagen.Nodes.Clear()
                Me.txtBezeichnung.Text = ""
                Me.dterstelltam.Value = Now
                Me.dtmutiertam.Value = Now
                Me.cbAktiv.Checked = True
                i = Globals.MitarbeiterNr
                Me.mcbowner.SelectedValue = i
                Me.StrukturNr = nothing
                Me.RichTextBoxHS1.Text = ""
                Me.txtWichtigeHinweise.Text = ""
                Me.FormValidator(False)
            Case 3 'Auswahl
                If Me.haschanges = True Then
                    Dim i As Integer
                    i = MyMsg.Show_MessageYesNoCancel(2)
                    If i = MsgBoxResult.Cancel Then Exit Sub
                    If i = MsgBoxResult.Yes Then
                        If Me.FormValidator(True) = False Then
                            Exit Sub
                        Else
                            Me.Save_Dokumentpaket()
                        End If
                    End If
                End If

                Dim f As New frmDokumentpaketuebersicht(Globals.MitarbeiterNr)
                f.individuelles_dp = True

                f.FormMaximize = False
                f.StartPosition = FormStartPosition.Manual
                f.ShowDialog()
                If f.TransferKey <> 0 Then
                    Me.haschanges = False
                    Me.LoadFromUebersicht = True
                    Me.Dokumentpaketnr = f.TransferKey
                    Me.Kopie = False
                    Me.Neu = False
                    Me.treeSelVorlagen.Nodes.Clear()
                    Me.StrukturNr = 0
                    Load_Dokumentpaket(False)
                    Me.LoadFromUebersicht = False
                    Me.FormValidator(False)

                End If
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeDokVorlagen_DoubleClick Method

Private Sub TreeDokVorlagen_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TreeDokVorlagen.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeDokVorlagen_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TreeDokVorlagen.DoubleClick
        If Me.TreeDokVorlagen.SelectedNode.GetNodeCount(True) = 0 Then
            Dim tn As TreeNode
            tn = Me.treeSelVorlagen.Nodes.Add(Me.TreeDokVorlagen.SelectedNode.Text)
            tn.ImageIndex = Me.TreeDokVorlagen.SelectedNode.ImageIndex
            tn.SelectedImageIndex = Me.TreeDokVorlagen.SelectedNode.SelectedImageIndex
            tn.Tag = Me.TreeDokVorlagen.SelectedNode.Tag
            Me.FormValidator(False)
            Me.haschanges = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeDokVorlagen_ItemDrag Method

Private Sub TreeDokVorlagen_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles TreeDokVorlagen.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeDokVorlagen_ItemDrag(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles TreeDokVorlagen.ItemDrag
        If e.Button = MouseButtons.Left Then
            Moveitem = False
            Select Case TagArt(TreeDokVorlagen.SelectedNode.Tag)
                Case "DT_"       'nur Dokumente word,Barcode,Word mit Barcode... (keine Stukturknoten)
                    TreeDokVorlagen.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case Else
                    TreeDokVorlagen.DoDragDrop(e.Item, DragDropEffects.None)

            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeDokVorlagen_MouseDown Method

Private Sub TreeDokVorlagen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeDokVorlagen.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeDokVorlagen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeDokVorlagen.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeDokVorlagen.SelectedNode = TreeDokVorlagen.GetNodeAt(selectPoint)
            Me.treeSelVorlagen.AllowDrop = True
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeSelektion_AfterSelect Method

Private Sub TreeSelektion_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeSelektion.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeSelektion_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeSelektion.AfterSelect
        If Me.Aus_Formvalidate = True Then Exit Sub
        Me.pnlDokumentvorlagen.Visible = False
        Me.pnlDokumentvorlagen.Dock = DockStyle.None
        Me.pnlSelVorlagen.Visible = False
        Me.pnlSelVorlagen.Dock = DockStyle.None
        Me.pnlBeschreibung.Visible = False
        Me.pnlBeschreibung.Dock = DockStyle.None
        Me.pnlStruktur.Visible = False
        Me.pnlSelVorlagen.Dock = DockStyle.None
        Select Case Me.TreeSelektion.SelectedNode.Index
            Case 0
                Me.pnlDokumentvorlagen.Visible = True
                Me.pnlDokumentvorlagen.Dock = DockStyle.Left
                Me.pnlSelVorlagen.Visible = True
                Me.pnlSelVorlagen.Dock = DockStyle.Fill
            Case 1
                Me.pnlBeschreibung.Visible = True
                Me.pnlBeschreibung.Dock = DockStyle.Fill
            Case 2
                Me.pnlStruktur.Visible = True
                Me.pnlStruktur.Dock = DockStyle.Fill
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeStruktur_AfterSelect Method

Private Sub TreeStruktur_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeStruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeStruktur_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeStruktur.AfterSelect
        Dim tn As New TreeNode()
        tn = Me.TreeStruktur.SelectedNode
        tn = Nothing
        Me.TreeStruktur.SelectedNode.SelectedImageIndex = 1
        Me.StrukturNr = Me.TreeStruktur.SelectedNode.Tag
        Me.FormValidator(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeStruktur_DragOver Method

Public Sub TreeStruktur_DragOver( _
   ByVal sender As System.Object, _
   ByVal e As DragEventArgs _
) Handles TreeStruktur.DragOver

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub TreeStruktur_DragOver(ByVal sender As System.Object, ByVal e As DragEventArgs) Handles TreeStruktur.DragOver
        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
               True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        Dim pt As Point = _
            CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
        Dim targetNode As TreeNode = selectedTreeview.GetNodeAt(pt)
        If Not (selectedTreeview.SelectedNode Is targetNode) Then
            selectedTreeview.SelectedNode = targetNode
            Dim dropNode As TreeNode = _
                CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
                TreeNode)

            Do Until targetNode Is Nothing
                If targetNode Is dropNode Then
                    e.Effect = DragDropEffects.None
                    Exit Sub
                End If
                targetNode = targetNode.Parent
            Loop
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeStruktur_KeyDown Method

Private Sub TreeStruktur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TreeStruktur.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeStruktur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TreeStruktur.KeyDown
        If e.Control = True Then
            Select Case e.KeyCode
                Case Keys.N
                    If MenuItem6.Enabled Then
                        MenuItem6_Click(sender, e)
                    End If
                Case Keys.Up
                    Me.MoveNode(1)
                Case Keys.Down
                    Me.MoveNode(2)
            End Select
        End If

        If e.Control = False And e.Alt = False And e.Shift = False Then
            Select Case e.KeyCode
                Case Keys.Return
                Case Keys.F2
                    If MenuItem4.Enabled Then
                        MenuItem4_Click(sender, e)
                    End If
                Case Keys.Delete
                    If MenuItem5.Enabled Then
                        MenuItem5_Click(sender, e)
                    End If
            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeStruktur_MouseDown Method

Private Sub TreeStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeStruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeStruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeStruktur.SelectedNode = TreeStruktur.GetNodeAt(selectPoint)
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.TreeView1_MouseMove Method

Private Sub TreeView1_MouseMove( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeSelektion.MouseMove

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_MouseMove(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeSelektion.MouseMove
        Exit Sub
        Try
            Dim TN As TreeNode
            Static old_node As TreeNode
            Dim node_here As TreeNode = Me.TreeSelektion.GetNodeAt(e.X, e.Y)
            If node_here Is old_node Then Exit Sub
            old_node = node_here

            '     ToolTip1.AutoPopDelay = 1000000
            '      ToolTip1.InitialDelay = 1
            ToolTip1.RemoveAll()
            If old_node Is Nothing Then
                ToolTip1.SetToolTip(Me.TreeSelektion, "")
            Else
                If node_here.Nodes.Count = 0 Then
                    TN = Me.TreeSelektion.GetNodeAt(e.X, e.Y)
                    If TN.Text = "Vorlagen" Then
                        ToolTip1.SetToolTip(Me.TreeSelektion, "Tooltip Vorlagenselektion")
                    End If
                    If TN.Text = "Beschreibung" Then
                        ToolTip1.SetToolTip(Me.TreeSelektion, "Tooltip Beschreibung")
                    End If
                    If TN.Text = "Struktur" Then
                        ToolTip1.SetToolTip(Me.TreeSelektion, "Tooltip Struktur")
                    End If
                End If
            End If
            '           bt.CustomBalloon(ToolTip1, 1)
        Catch
            MsgBox(Err.Description)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.btnsuche_Click Method

Private Sub btnsuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnsuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnsuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnsuche.Click
        dokumentvorlage_suchen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmenuSelVorlagen_Popup Method

Private Sub ctmenuSelVorlagen_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenuSelVorlagen.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmenuSelVorlagen_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenuSelVorlagen.Popup
        If Me.treeSelVorlagen.GetNodeCount(True) < 1 Then
            Me.ctmnuselVorlagenInfo.Enabled = False
            Me.ctmnuselvorlagenVorlageLoeschen.Enabled = False
        Else
            Me.ctmnuselVorlagenInfo.Enabled = True
            Me.ctmnuselvorlagenVorlageLoeschen.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmenuTreeDokVorlagen_Popup Method

Private Sub ctmenuTreeDokVorlagen_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenuTreeDokVorlagen.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmenuTreeDokVorlagen_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenuTreeDokVorlagen.Popup
        If Me.TreeDokVorlagen.SelectedNode.GetNodeCount(True) = 0 Then
            Me.ctmnuVorlageInfo.Enabled = True
            Me.ctmnuVorlageSelect.Enabled = True
        Else
            Me.ctmnuVorlageInfo.Enabled = False
            Me.ctmnuVorlageSelect.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuAktKnotenOeffnen_Click Method

Private Sub ctmnuAktKnotenOeffnen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuAktKnotenOeffnen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuAktKnotenOeffnen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuAktKnotenOeffnen.Click
        Try
            Me.TreeDokVorlagen.Visible = False
            Me.TreeDokVorlagen.SelectedNode.Expand()
        Catch
        End Try
        Me.TreeDokVorlagen.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuAktKnotenSchliessen_Click Method

Private Sub ctmnuAktKnotenSchliessen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuAktKnotenSchliessen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuAktKnotenSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuAktKnotenSchliessen.Click
        Try
            Me.TreeDokVorlagen.Visible = False
            Me.TreeDokVorlagen.SelectedNode.Collapse()
        Catch
        End Try
        Me.TreeDokVorlagen.Visible = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuKnotenOeffnen_Click Method

Private Sub ctmnuKnotenOeffnen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuKnotenOeffnen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuKnotenOeffnen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuKnotenOeffnen.Click
        Try
            Me.TreeDokVorlagen.Visible = False
            Me.TreeDokVorlagen.ExpandAll()
        Catch
        End Try
        Me.TreeDokVorlagen.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuKnotenSchliessen_Click Method

Private Sub ctmnuKnotenSchliessen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuKnotenSchliessen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuKnotenSchliessen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuKnotenSchliessen.Click
        Try
            Me.TreeDokVorlagen.Visible = False
            Me.TreeDokVorlagen.CollapseAll()
        Catch
        End Try
        Me.TreeDokVorlagen.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuVorlageInfo_Click Method

Private Sub ctmnuVorlageInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuVorlageInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuVorlageInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuVorlageInfo.Click
        Dim f As New frmDokumenttypInfo()
        Try
            If TagArt(Me.TreeDokVorlagen.SelectedNode.Tag) = "DT_" Then
                f.Key = TagValue(Me.TreeDokVorlagen.SelectedNode.Tag)
                f.Text = f.Text + Me.TreeDokVorlagen.SelectedNode.Text
                f.ShowDialog()
            End If
        Catch
        Finally
            f.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuVorlageSelect_Click Method

Private Sub ctmnuVorlageSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuVorlageSelect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuVorlageSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuVorlageSelect.Click
        TreeDokVorlagen_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuselVorlagenInfo_Click Method

Private Sub ctmnuselVorlagenInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuselVorlagenInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuselVorlagenInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuselVorlagenInfo.Click
        Dim f As New frmDokumenttypInfo()
        Try
            If TagArt(Me.treeSelVorlagen.SelectedNode.Tag) = "DT_" Then
                f.Key = TagValue(Me.treeSelVorlagen.SelectedNode.Tag)
                f.Text = f.Text + Me.treeSelVorlagen.SelectedNode.Text
                f.ShowDialog()
            End If
        Catch
        Finally
            f.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.ctmnuselvorlagenVorlageLoeschen_Click Method

Private Sub ctmnuselvorlagenVorlageLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuselvorlagenVorlageLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuselvorlagenVorlageLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuselvorlagenVorlageLoeschen.Click
        Try
            Me.treeSelVorlagen.SelectedNode.Remove()
            Me.FormValidator(False)
            Me.haschanges = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.dokumentvorlage_suchen Method

Private Sub dokumentvorlage_suchen()

Source code

[Visual Basic]
    Private Sub dokumentvorlage_suchen()
        Me.TreeDokVorlagen.BeginUpdate()
        Dim d As New edokadb.clsMyDokumentart()

        If Me.Individuelles_DP = True Then
            d.Load_Neue_Dokumente(Me.TreeDokVorlagen, Me.txtSuchbegriff.Text, False, 0)
        Else
            d.Load_Neue_Dokumente_Vollstaendig(Me.TreeDokVorlagen, Me.txtSuchbegriff.Text, False, 0)
        End If
        d.Dispose()
        Me.TreeDokVorlagen.ExpandAll()
        'Me.txtSuchbegriff.Text = ""
        Me.TreeDokVorlagen.EndUpdate()
        Try
            Me.TreeDokVorlagen.SelectedNode = Me.TreeDokVorlagen.Nodes(0)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.frmDokumentpaketdefinition_Closing Method

Private Sub frmDokumentpaketdefinition_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaketdefinition_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Me.Anzeige = True Then Exit Sub
        If Me.haschanges = True Then
            Dim i As Integer
            i = MyMsg.Show_MessageYesNoCancel(2)
            If i = MsgBoxResult.Cancel Then e.Cancel = True
            If i = MsgBoxResult.No Then Exit Sub
            If i = MsgBoxResult.Yes Then
                If Me.FormValidator(True) = False Then
                    e.Cancel = True
                Else
                    Me.Save_Dokumentpaket()
                End If
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.frmDokumentpaketdefinition_Load Method

Private Sub frmDokumentpaketdefinition_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaketdefinition_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'Abhängig ob es sich um ein individuelles Dokumentpaket handelt, die vollständige Dokumentstruktur oder diejenige des
        'Benutzers laden
        'Test'

        Me.Cursor = Cursors.WaitCursor
        Dim d As New edokadb.clsMyDokumentart()
        If Me.Individuelles_DP = True Then
            Me.mcbowner.Enabled = False
            Me.cboowner.Enabled = False
            'd.Load_Neue_Dokumente(Me.TreeDokVorlagen, "", False, 0)
            d.Load_Neue_Dokumente(Me.TreeDokVorlagen, "", False, 0)
        Else
            Me.btnnew.Visible = False
            Me.btnopen.Visible = False
            d.Load_Neue_Dokumente_Vollstaendig(Me.TreeDokVorlagen, "", False, 0)
        End If
        d.Dispose()

        Load_Owners()

        Me.TreeSelektion.Nodes.Clear()
        tn = Me.TreeSelektion.Nodes.Add("Definition")
        tn.Tag = 0
        tn.ImageIndex = 0
        tn.SelectedImageIndex = 0

        tn1 = tn.Nodes.Add("Vorlagen")
        tn1.Tag = 1
        tn1.ImageIndex = 1
        tn1.SelectedImageIndex = 1

        tn1 = tn.Nodes.Add("Beschreibung")
        tn1.Tag = 2
        tn1.ImageIndex = 1
        tn1.SelectedImageIndex = 1

        tn1 = tn.Nodes.Add("Struktur")
        tn1.Tag = 3
        tn1.ImageIndex = 1
        tn1.SelectedImageIndex = 1

        Me.TreeSelektion.ExpandAll()
        DivFnkt.Searchnode(Me.TreeSelektion, 1, 0)
        Load_Struktur_Daten()

        If Neu Then
            Me.dterstelltam.Value = Now
            Me.dtmutiertam.Value = Now
            Me.cbAktiv.Checked = True
            i = Globals.MitarbeiterNr
            Me.mcbowner.SelectedValue = i
        Else
            If Me.DokumenttypNummern = "" Then
                Load_Dokumentpaket(False)
                If MitarbeiterKopie = True Then
                    Me.vonmitarbeiter = Me.mcbowner.Text

                    d.Load_FavoritenStruktur_dp_MAKopie(Me.Mitarbeiternr, Me.TreeStruktur, "", True, 1)
                    Me.TreeStruktur.ExpandAll()
                    Me.TreeStruktur.AllowDrop = True
                    Me.TreeStruktur.SelectedNode = Me.TreeStruktur.Nodes(0)
                    Me.StrukturNr = Me.TreeStruktur.SelectedNode.Tag
                    Me.dterstelltam.Value = Now
                    Me.dtmutiertam.Value = Now
                    Me.cbAktiv.Checked = True
                    Me.mcbowner.SelectedValue = Me.Mitarbeiternr
                    Me.Neu = True
                    Me.txtBezeichnung.Text = Me.txtBezeichnung.Text + " (von " + Me.vonmitarbeiter + ")"
                    Me.Save_Dokumentpaket()
                    Exit Sub
                End If
                If Kopie = True Then
                    Me.dterstelltam.Value = Now
                    Me.dtmutiertam.Value = Now
                    Me.cbAktiv.Checked = True
                    i = Globals.MitarbeiterNr
                    Me.mcbowner.SelectedValue = i
                    Me.StrukturNr = 0
                    Me.Neu = True
                End If
            End If
        End If

        If Me.DokumenttypNummern <> "" Then
            load_dokumentpaket_dt()
        End If

        FormValidator(False)

        Me.TreeDokVorlagen.ExpandAll()
        Me.TreeDokVorlagen.SelectedNode = Me.TreeDokVorlagen.Nodes(0)
        Me.haschanges = False
        Me.Cursor = Cursors.Default
        '        Me.TreeDokVorlagen_MouseDown(sender, e)
        If Me.Anzeige Then Me.btnSave.Visible = False
        If Me.Individuelles_DP = True Then Me.TreeStruktur.ContextMenu = Me.ctMenuStruktur Else Me.TreeStruktur.ContextMenu = Nothing
        If Me.Kopie Then Me.txtBezeichnung.Text = "Kopie von " + Me.txtBezeichnung.Text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.load_dokumentpaket_dt Method

Private Sub load_dokumentpaket_dt()

Source code

[Visual Basic]
    Private Sub load_dokumentpaket_dt()
        Dim splitter
        Dim i1 As Integer
        Dim i As Integer
        Load_Dokumentpaket(True)
        i = Globals.MitarbeiterNr
        Me.mcbowner.SelectedValue = i
        'Me.StrukturNr = 0

        splitter = Microsoft.VisualBasic.Split(Me.DokumenttypNummern, ";")
        i = 0
        Try
            Do Until splitter(i) Is Nothing
                If splitter(i) <> "" Then
                    For i1 = 0 To Me.treeSelVorlagen.GetNodeCount(True) - 1
                        If Me.treeSelVorlagen.Nodes(i1).Tag = "DT_" + splitter(i) Then
                            splitter(i) = "X"
                            Exit For
                        End If
                    Next
                End If
                i = i + 1
            Loop
        Catch
        End Try

        i = 0
        Try
            Do Until splitter(i) Is Nothing
                If splitter(i) <> "X" Then

                    'Dim dview As New DataView(Globals.Vorlagendata, "Dokumenttypnr= '" + "DT_" + splitter(i) + "'", "Parentid, sort", DataViewRowState.CurrentRows)
                    'Dim drv1 As DataRowView
                    'For Each drv1 In dview
                    '    Dim tn As TreeNode
                    '    tn = Me.treeSelVorlagen.Nodes.Add(drv1.Item("dt_Bezeichnung"))
                    '    tn.ImageIndex = drv1.Item("Imageindex")
                    '    tn.SelectedImageIndex = drv1.Item("Imageindex")
                    '    tn.Tag = "DT_" + splitter(i)
                    '    Me.haschanges = True
                    'Next

                    DivFnkt.Searchnode(Me.TreeDokVorlagen, "DT_" + splitter(i), 0)
                    If DivFnkt.found Then
                        Dim tn As TreeNode
                        tn = Me.treeSelVorlagen.Nodes.Add(DivFnkt.FoundNode.Text)
                        tn.ImageIndex = DivFnkt.FoundNode.ImageIndex
                        tn.SelectedImageIndex = DivFnkt.FoundNode.SelectedImageIndex
                        tn.Tag = DivFnkt.FoundNode.Tag
                        Me.haschanges = True
                    End If
                End If
                i = i + 1
            Loop
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.loopother Method

Private Sub loopother( _
   ByVal PNode As TreeNode _
)

Parameters

PNode
Required.

Source code

[Visual Basic]
    Private Sub loopother(ByVal PNode As TreeNode)
        Dim TNode As TreeNode
        For Each TNode In PNode.Nodes
            If Not TNode.Parent Is Nothing Then
                save_SortID(TNode.Parent.Tag, TNode.Tag, TNode.Index)
            End If
            loopother(TNode)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.mnuMoveItemDown_Click Method

Private Sub mnuMoveItemDown_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuMoveItemDown.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuMoveItemDown_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuMoveItemDown.Click
        MoveNode(2)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.mnuMoveItemUp_Click Method

Private Sub mnuMoveItemUp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuMoveItemUp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuMoveItemUp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuMoveItemUp.Click
        MoveNode(1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.save_SortID Method

Private Function save_SortID( _
   ByVal wert As Integer, _
   ByVal keyvalue As Integer, _
   ByVal indexnr As Integer _
)

Parameters

wert
Required.
keyvalue
Required.
indexnr
Required.

Source code

[Visual Basic]
    Private Function save_SortID(ByVal wert As Integer, ByVal keyvalue As Integer, ByVal indexnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "edex_sp_dokumentpaketstruktur_update"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, keyvalue))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexnr))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeSelVorlagen_DragDrop Method

Private Sub treeSelVorlagen_DragDrop( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles treeSelVorlagen.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeSelVorlagen_DragDrop(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles treeSelVorlagen.DragDrop
        Dim OriginalNode As New TreeNode()

        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            Dim OriginalNodeImageIndex As Integer
            Dim OriginalNodeSelectedImageIndex As Integer
            Dim OriginalNodeTag As String
            OriginalNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        End If

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", False) Then
            Dim pt As Point
            Dim DestinationNode As TreeNode
            pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
            DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
            If Me.treeSelVorlagen.GetNodeCount(True) = 0 Then
                TreeDokVorlagen_DoubleClick(sender, e)

            Else
                Dim tn As TreeNode
                Dim tn1 As TreeNode
                If Moveitem Then
                    tn = Me.treeSelVorlagen.SelectedNode
                Else
                    tn = Me.treeSelVorlagen.Nodes.Add(OriginalNode.Text)
                    tn.ImageIndex = OriginalNode.ImageIndex
                    tn.SelectedImageIndex = OriginalNode.SelectedImageIndex
                    tn.Tag = OriginalNode.Tag
                    Me.haschanges = True
                End If

                If DestinationNode Is Nothing Then
                    If Moveitem Then
                        tn1 = Me.treeSelVorlagen.Nodes.Add(tn.Text)
                        tn1.ImageIndex = tn.ImageIndex
                        tn1.SelectedImageIndex = tn.SelectedImageIndex
                        tn1.Tag = tn.Tag
                        tn.Remove()
                        Me.haschanges = True
                    End If
                Else
                    tn.Remove()
                    Me.treeSelVorlagen.Nodes.Insert(DestinationNode.Index, tn)
                    Me.haschanges = True
                End If
            End If

            Me.treeSelVorlagen.AllowDrop = False
            e.Effect = DragDropEffects.None
            Moveitem = False
            Me.FormValidator(False)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeSelVorlagen_DragEnter Method

Private Sub treeSelVorlagen_DragEnter( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles treeSelVorlagen.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeSelVorlagen_DragEnter(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles treeSelVorlagen.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            Me.treeSelVorlagen.AllowDrop = True
            e.Effect = DragDropEffects.Copy
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeSelVorlagen_Enter Method

Private Sub treeSelVorlagen_Enter( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles treeSelVorlagen.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeSelVorlagen_Enter(ByVal sender As Object, ByVal e As System.EventArgs) Handles treeSelVorlagen.Enter
        Me.AllowDrop = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeSelVorlagen_ItemDrag Method

Private Sub treeSelVorlagen_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles treeSelVorlagen.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeSelVorlagen_ItemDrag(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles treeSelVorlagen.ItemDrag
        Moveitem = True

        If e.Button = MouseButtons.Left Then
            Select Case TagArt(treeSelVorlagen.SelectedNode.Tag)
                Case "DT_"       'nur Dokumente word,Barcode,Word mit Barcode... (keine Stukturknoten)
                    treeSelVorlagen.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case Else
                    treeSelVorlagen.DoDragDrop(e.Item, DragDropEffects.None)
            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeSelVorlagen_MouseDown Method

Private Sub treeSelVorlagen_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles treeSelVorlagen.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeSelVorlagen_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles treeSelVorlagen.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.treeSelVorlagen.SelectedNode = treeSelVorlagen.GetNodeAt(selectPoint)
            Me.treeSelVorlagen.AllowDrop = True

        Catch ex As Exception
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeStruktur_DragDrop Method

Private Sub treeStruktur_DragDrop( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles TreeStruktur.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeStruktur_DragDrop(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles TreeStruktur.DragDrop

        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
              True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        Dim dropNode As TreeNode = _
              CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
              TreeNode)

        Dim targetNode As TreeNode = selectedTreeview.SelectedNode
        dropNode.Remove()
        If targetNode Is Nothing Then
            selectedTreeview.Nodes.Add(dropNode)
        Else
            targetNode.Nodes.Add(dropNode)
        End If
        dropNode.EnsureVisible()
        selectedTreeview.SelectedNode = dropNode
        Save_Sort()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeStruktur_ItemDrag Method

Private Sub treeStruktur_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles TreeStruktur.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeStruktur_ItemDrag(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles TreeStruktur.ItemDrag
        If e.Button = MouseButtons.Left Then
            TreeStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.treeStruktur_dragenter Method

Private Sub treeStruktur_dragenter( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles TreeStruktur.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub treeStruktur_dragenter(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles TreeStruktur.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            Me.TreeStruktur.AllowDrop = True
            e.Effect = DragDropEffects.Copy
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.txtBezeichnung_KeyUp Method

Private Sub txtBezeichnung_KeyUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtBezeichnung.KeyUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBezeichnung_KeyUp(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtBezeichnung.KeyUp
        Me.FormValidator(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.txtBezeichnung_Leave Method

Private Sub txtBezeichnung_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtBezeichnung.Leave, _
   RichTextBoxHS1.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBezeichnung_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung.Leave, RichTextBoxHS1.Leave
        Me.FormValidator(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.txtBezeichnung_TextChanged Method

Private Sub txtBezeichnung_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtBezeichnung.TextChanged, _
   RichTextBoxHS1.TextChanged, _
   mcbowner.SelectedValueChanged, _
   cbAktiv.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBezeichnung_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung.TextChanged, RichTextBoxHS1.TextChanged, mcbowner.SelectedValueChanged, cbAktiv.CheckedChanged
        If Me.LoadFromUebersicht = True Then Exit Sub
        Me.haschanges = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition.txtSuchbegriff_KeyDown Method

Private Sub txtSuchbegriff_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtSuchbegriff.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtSuchbegriff_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtSuchbegriff.KeyDown
        If e.KeyCode = Keys.KeyCode.Return Then
            dokumentvorlage_suchen()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition Fields

frmDokumentpaketdefinition overview

Fields

field Aus_Formvalidate
field BtnHelp
field DokumenttypNummern
field FontDialog1
field ImageList1
field ImageList2
field ImageList3
field ImgListSteuerung
field LoadFromUebersicht
field MenuItem1
field MenuItem10
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field Moveitem
field Panel1
field Panel2
field Panel3
field RichTextBoxHS1
field ShowOnly
field Splitter1
field ToolBar1
field ToolTip1
field TreeDokVorlagen
field TreeSelektion
field TreeStruktur
field btnExit
field btnSave
field btnnew
field btnopen
field btnsuche
field cbAktiv
field cboowner
field components
field ctMenuStruktur
field ctmenuBeschreibung
field ctmenuSelVorlagen
field ctmenuTreeDokVorlagen
field ctmnuAktKnotenOeffnen
field ctmnuAktKnotenSchliessen
field ctmnuKnotenOeffnen
field ctmnuKnotenSchliessen
field ctmnuVorlageInfo
field ctmnuVorlageSelect
field ctmnuselVorlagenInfo
field ctmnuselvorlagenVorlageLoeschen
field dterstelltam
field dtmutiertam
field grpAllgemein
field haschanges
field i
field index
field lblBezeichnung
field lblErstelltam
field lblMutiertam
field lblOwner
field lblSuche
field lblWichtigeHinweise
field m_Mitarbeiterkopie
field m_anzeige
field m_dokumentpaketnr
field m_individuell
field m_kopie
field m_mitarbeiternr
field m_neu
field m_strukturnr
field mcbowner
field mnuMoveItemDown
field mnuMoveItemUp
field pnlBeschreibung
field pnlDokumentvorlagen
field pnlSelVorlagen
field pnlStruktur
field pnlTrenner
field selectPoint
field tn
field tn1
field treeSelVorlagen
field txtBezeichnung
field txtSuchbegriff
field txtWichtigeHinweise
field vonmitarbeiter

See Also

frmDokumentpaketdefinition Class


Aus_Formvalidate Variable

Dim Aus_Formvalidate As Boolean = False

Source code

[Visual Basic]
    Dim Aus_Formvalidate As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


DokumenttypNummern Variable

Dim DokumenttypNummern As String = ""

Source code

[Visual Basic]
    Dim DokumenttypNummern As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


FontDialog1 Variable

Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Source code

[Visual Basic]
    Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ImgListSteuerung Variable

Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImgListSteuerung As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


LoadFromUebersicht Variable

Dim LoadFromUebersicht As Boolean = False

Source code

[Visual Basic]
    Dim LoadFromUebersicht As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


Moveitem Variable

Dim Moveitem As Boolean = False

Source code

[Visual Basic]
    Dim Moveitem As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


RichTextBoxHS1 Variable

Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Source code

[Visual Basic]
    Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ShowOnly Variable

Dim ShowOnly As Boolean = False

Source code

[Visual Basic]
    Dim ShowOnly As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


TreeDokVorlagen Variable

Friend WithEvents TreeDokVorlagen As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeDokVorlagen As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


TreeSelektion Variable

Friend WithEvents TreeSelektion As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeSelektion As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


TreeStruktur Variable

Friend WithEvents TreeStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


btnExit Variable

Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


btnnew Variable

Friend WithEvents btnnew As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnnew As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


btnopen Variable

Friend WithEvents btnopen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnopen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


btnsuche Variable

Friend WithEvents btnsuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnsuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


cbAktiv Variable

Friend WithEvents cbAktiv As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbAktiv As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


cboowner Variable

Friend WithEvents cboowner As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboowner As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctMenuStruktur Variable

Friend WithEvents ctMenuStruktur As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctMenuStruktur As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmenuBeschreibung Variable

Friend WithEvents ctmenuBeschreibung As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenuBeschreibung As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmenuSelVorlagen Variable

Friend WithEvents ctmenuSelVorlagen As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenuSelVorlagen As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmenuTreeDokVorlagen Variable

Friend WithEvents ctmenuTreeDokVorlagen As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenuTreeDokVorlagen As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuAktKnotenOeffnen Variable

Friend WithEvents ctmnuAktKnotenOeffnen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuAktKnotenOeffnen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuAktKnotenSchliessen Variable

Friend WithEvents ctmnuAktKnotenSchliessen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuAktKnotenSchliessen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuKnotenOeffnen Variable

Friend WithEvents ctmnuKnotenOeffnen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuKnotenOeffnen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuKnotenSchliessen Variable

Friend WithEvents ctmnuKnotenSchliessen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuKnotenSchliessen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuVorlageInfo Variable

Friend WithEvents ctmnuVorlageInfo As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuVorlageInfo As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuVorlageSelect Variable

Friend WithEvents ctmnuVorlageSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuVorlageSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuselVorlagenInfo Variable

Friend WithEvents ctmnuselVorlagenInfo As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuselVorlagenInfo As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


ctmnuselvorlagenVorlageLoeschen Variable

Friend WithEvents ctmnuselvorlagenVorlageLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuselvorlagenVorlageLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


dterstelltam Variable

Friend WithEvents dterstelltam As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dterstelltam As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


dtmutiertam Variable

Friend WithEvents dtmutiertam As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtmutiertam As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


grpAllgemein Variable

Friend WithEvents grpAllgemein As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents grpAllgemein As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


haschanges Variable

Dim haschanges As Boolean = False

Source code

[Visual Basic]
    Dim haschanges As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


index Variable

Dim index As Integer

Source code

[Visual Basic]
    Dim index As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblBezeichnung Variable

Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblErstelltam Variable

Friend WithEvents lblErstelltam As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblErstelltam As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblMutiertam Variable

Friend WithEvents lblMutiertam As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblMutiertam As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblOwner Variable

Friend WithEvents lblOwner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblOwner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblSuche Variable

Friend WithEvents lblSuche As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblSuche As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


lblWichtigeHinweise Variable

Friend WithEvents lblWichtigeHinweise As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblWichtigeHinweise As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_Mitarbeiterkopie Variable

Dim m_Mitarbeiterkopie As Boolean

Source code

[Visual Basic]
    Dim m_Mitarbeiterkopie As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_anzeige Variable

Dim m_anzeige As Boolean = False

Source code

[Visual Basic]
    Dim m_anzeige As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_dokumentpaketnr Variable

Dim m_dokumentpaketnr As Integer

Source code

[Visual Basic]
    Dim m_dokumentpaketnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_individuell Variable

Dim m_individuell As Boolean

Source code

[Visual Basic]
    Dim m_individuell As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_kopie Variable

Dim m_kopie As Boolean

Source code

[Visual Basic]
    Dim m_kopie As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Integer

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_neu Variable

Dim m_neu As Boolean

Source code

[Visual Basic]
    Dim m_neu As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


m_strukturnr Variable

Dim m_strukturnr As Integer = 0

Source code

[Visual Basic]
    Dim m_strukturnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


mcbowner Variable

Dim WithEvents mcbowner As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbowner As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


mnuMoveItemDown Variable

Friend WithEvents mnuMoveItemDown As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuMoveItemDown As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


mnuMoveItemUp Variable

Friend WithEvents mnuMoveItemUp As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuMoveItemUp As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


pnlBeschreibung Variable

Friend WithEvents pnlBeschreibung As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlBeschreibung As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


pnlDokumentvorlagen Variable

Friend WithEvents pnlDokumentvorlagen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlDokumentvorlagen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


pnlSelVorlagen Variable

Friend WithEvents pnlSelVorlagen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlSelVorlagen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


pnlStruktur Variable

Friend WithEvents pnlStruktur As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents pnlStruktur As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


pnlTrenner Variable

Friend WithEvents pnlTrenner As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlTrenner As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


tn Variable

Dim tn As TreeNode

Source code

[Visual Basic]
    Dim tn As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


tn1 Variable

Dim tn1 As TreeNode

Source code

[Visual Basic]
    Dim tn1 As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


treeSelVorlagen Variable

Friend WithEvents treeSelVorlagen As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents treeSelVorlagen As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


txtSuchbegriff Variable

Friend WithEvents txtSuchbegriff As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtSuchbegriff As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


txtWichtigeHinweise Variable

Friend WithEvents txtWichtigeHinweise As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtWichtigeHinweise As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


vonmitarbeiter Variable

Dim vonmitarbeiter As String = ""

Source code

[Visual Basic]
    Dim vonmitarbeiter As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketuebersicht Class

For a list of all members of this type, see frmDokumentpaketuebersicht Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDokumentpaketuebersicht

Public Class frmDokumentpaketuebersicht
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentpaketuebersicht Members


frmDokumentpaketuebersicht Members

frmDokumentpaketuebersicht overview

Constructors

constructor frmDokumentpaketuebersicht Constructor (Overloaded)

Properties

property Dokumentpaketnr
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Mitarbeiternr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property individuelles_dp

Methods

method ContextMenu1_Popup
method Dispose
method Domainlist_MouseDown
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generic_Select
method InitializeComponent
method Load_data
method MenuItem4_Click
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method btnDokTypSelektion_Click
method btnXLSExport_Click
method cboDokTyp_leave
method cdmnuShow_Click
method ctmnuEdit_Click
method ctmnuNew_Click
method frmDokumentpaketuebersicht_Load
method mcbdoktyp_TextChanged

Fields

field ContextMenu1
field ContextMenu2
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SaveFileDialog1
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field ToolTip1
field btnDokTypSelektion
field btnXLSExport
field cboDokTyp
field cdmnuShow
field components
field ctmnuEdit
field ctmnuNew
field dtDokumenttyp
field lblSelektion
field m_dokumentpaketnr
field m_individuelles_DP
field m_mitarbeiternr
field mcbdoktyp
field on_Load

See Also

frmDokumentpaketuebersicht Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal mitarbeiternr As Integer)

See Also

frmDokumentpaketuebersicht | EDOKAApp


frmDokumentpaketuebersicht Properties

frmDokumentpaketuebersicht overview

Properties

property Dokumentpaketnr
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Mitarbeiternr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property individuelles_dp

See Also

frmDokumentpaketuebersicht Class


frmDokumentpaketuebersicht.Dokumentpaketnr Property

Property Dokumentpaketnr() As Integer

Source code

[Visual Basic]
    Property Dokumentpaketnr() As Integer
        Get
            Return m_dokumentpaketnr

        End Get
        Set(ByVal Value As Integer)
            m_dokumentpaketnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Mitarbeiternr Property

Property Mitarbeiternr() As Integer

Source code

[Visual Basic]
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Integer)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.individuelles_dp Property

Property individuelles_dp() As Boolean

Source code

[Visual Basic]
    Property individuelles_dp() As Boolean
        Get
            Return m_individuelles_DP
        End Get
        Set(ByVal Value As Boolean)
            m_individuelles_DP = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht Methods

frmDokumentpaketuebersicht overview

Methods

method ContextMenu1_Popup
method Dispose
method Domainlist_MouseDown
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generic_Select
method InitializeComponent
method Load_data
method MenuItem4_Click
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method btnDokTypSelektion_Click
method btnXLSExport_Click
method cboDokTyp_leave
method cdmnuShow_Click
method ctmnuEdit_Click
method ctmnuNew_Click
method frmDokumentpaketuebersicht_Load
method mcbdoktyp_TextChanged

See Also

frmDokumentpaketuebersicht Class


frmDokumentpaketuebersicht.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try
            If Not DivFnkt.Check_Sysadmin_Stellvertreter(Me.DomainList.Columns(10).Value) Then
                Me.ctmnuEdit.Enabled = False
                Me.ctmnuNew.Enabled = True
            Else
                Me.ctmnuEdit.Enabled = True
                Me.ctmnuNew.Enabled = True
            End If
        Catch
            If Me.DomainList.Splits(0).Rows.Count < 2 Then
                Me.ctmnuEdit.Enabled = False
                Me.ctmnuNew.Enabled = True
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Domainlist_MouseDown Method

Private Sub Domainlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DomainList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Domainlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DomainList.MouseDown
        Me.DomainList.Bookmark = Me.DomainList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Domainlist_dblclick Method

Private Sub Domainlist_dblclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick, _
   MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Domainlist_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick, MenuItem4.Click
        If ToSelect Or Me.individuelles_dp = True Then
            Me.TransferKey = Me.DomainList.Columns(0).Value
            Me.Close()
            Exit Sub
        End If
        ctmnuEdit_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "edex_sp_get_dokumenttypdaten"
            Case 2
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Select Case typ
            Case 1
            Case Else
        End Select

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentpaketuebersicht))
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.ctmnuNew = New System.Windows.Forms.MenuItem()
        Me.ctmnuEdit = New System.Windows.Forms.MenuItem()
        Me.cdmnuShow = New System.Windows.Forms.MenuItem()
        Me.cboDokTyp = New System.Windows.Forms.ComboBox()
        Me.btnDokTypSelektion = New System.Windows.Forms.Button()
        Me.btnXLSExport = New System.Windows.Forms.Button()
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog()
        Me.lblSelektion = New System.Windows.Forms.Label()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "edex_dokumentpaket", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumentpaketnr", "dokumentpaketnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("owner", "owner"), New System.Data.Common.DataColumnMapping("individuelles_dp", "individuelles_dp"), New System.Data.Common.DataColumnMapping("dpbeschreibung", "dpbeschreibung"), New System.Data.Common.DataColumnMapping("dokumentartnr", "dokumentartnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[edex_pr_dokumentpaket_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentpaketnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentpaketnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_individuelles_dp", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "individuelles_dp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "owner", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=SHUMAIN;initial catalog=edoka;persist security info=False;user id=sa;" & _
        "workstation id=SHUMAIN;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[edex_pr_dokumentpaket_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentpaketnr", System.Data.SqlDbType.Int, 4, "dokumentpaketnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@owner", System.Data.SqlDbType.Int, 4, "owner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@individuelles_dp", System.Data.SqlDbType.Bit, 1, "individuelles_dp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpbeschreibung", System.Data.SqlDbType.VarBinary, 2147483647, "dpbeschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[edex_sp_dokumentpakete_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@filter", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[edex_pr_dokumentpaket_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentpaketnr", System.Data.SqlDbType.Int, 4, "dokumentpaketnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@owner", System.Data.SqlDbType.Int, 4, "owner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@individuelles_dp", System.Data.SqlDbType.Bit, 1, "individuelles_dp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpbeschreibung", System.Data.SqlDbType.VarBinary, 2147483647, "dpbeschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentpaketnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentpaketnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_individuelles_dp", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "individuelles_dp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "owner", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.ctmnuNew, Me.ctmnuEdit, Me.cdmnuShow})
        '
        'ctmnuNew
        '
        Me.ctmnuNew.Index = 0
        Me.ctmnuNew.Text = "&Neues Dokumentpaket"
        '
        'ctmnuEdit
        '
        Me.ctmnuEdit.Index = 1
        Me.ctmnuEdit.Text = "&Dokumentpaket bearbeiten"
        '
        'cdmnuShow
        '
        Me.cdmnuShow.Index = 2
        Me.cdmnuShow.Text = "Dokumentpaket anzeigen"
        '
        'cboDokTyp
        '
        Me.cboDokTyp.Location = New System.Drawing.Point(160, 3)
        Me.cboDokTyp.Name = "cboDokTyp"
        Me.cboDokTyp.Size = New System.Drawing.Size(272, 21)
        Me.cboDokTyp.TabIndex = 8
        '
        'btnDokTypSelektion
        '
        Me.btnDokTypSelektion.Location = New System.Drawing.Point(432, 3)
        Me.btnDokTypSelektion.Name = "btnDokTypSelektion"
        Me.btnDokTypSelektion.Size = New System.Drawing.Size(20, 20)
        Me.btnDokTypSelektion.TabIndex = 9
        Me.btnDokTypSelektion.Text = "..."
        '
        'btnXLSExport
        '
        Me.btnXLSExport.Image = CType(resources.GetObject("btnXLSExport.Image"), System.Drawing.Bitmap)
        Me.btnXLSExport.Location = New System.Drawing.Point(456, 3)
        Me.btnXLSExport.Name = "btnXLSExport"
        Me.btnXLSExport.Size = New System.Drawing.Size(20, 20)
        Me.btnXLSExport.TabIndex = 10
        '
        'SaveFileDialog1
        '
        Me.SaveFileDialog1.FileName = "doc1"
        '
        'lblSelektion
        '
        Me.lblSelektion.Location = New System.Drawing.Point(24, 7)
        Me.lblSelektion.Name = "lblSelektion"
        Me.lblSelektion.Size = New System.Drawing.Size(144, 16)
        Me.lblSelektion.TabIndex = 11
        Me.lblSelektion.Text = "Dokumenttyp-Verwendung:"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "&Dokumentpaket übernehmen"
        '
        'frmDokumentpaketuebersicht
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(1008, 273)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnXLSExport, Me.btnDokTypSelektion, Me.cboDokTyp, Me.lblSelektion})
        Me.Name = "frmDokumentpaketuebersicht"
        Me.Text = "frmDokumentpaketuebersicht"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.Load_data Method

Private Sub Load_data()

Source code

[Visual Basic]
    Private Sub Load_data()
        Dim xd As DataTable
        'Me.DomainList.BeginInit()
        Me.DataSet1.Tables.Clear()
        Me.DomainList.DataSource = Nothing
        Me.DomainList.DataMember = Nothing
        Me.TableName = "dokumentpaket"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        If Me.Mitarbeiternr > 0 Then
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mitarbeiternr", Mitarbeiternr)
        Else
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mitarbeiternr", 0)
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@filter", Me.mcbdoktyp.SelectedValue)
        End If

        Me.SqlDataAdapter1.Fill(Me.DataSet1)

        Me.DomainList.DataSource = Me.DataSet1.Tables(0)
        Me.DomainList.DataMember = Me.DataSet1.Tables(0).TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

        Me.ToolBtnSave.Visible = False

        Me.DomainList.ContextMenu = Me.ContextMenu1
        Me.SqlConnection1.Close()
        If Me.DomainList.Splits(0).Rows.Count < 1 Then Me.btnXLSExport.Enabled = False Else Me.btnXLSExport.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Me.TransferKey = Me.DomainList.Columns(0).Value
        Me.Close()
        Exit Sub
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.btnDokTypSelektion_Click Method

Private Sub btnDokTypSelektion_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnDokTypSelektion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnDokTypSelektion_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDokTypSelektion.Click
        Dim F As New frmDataselect()
        Dim i1 As Integer
        F.Left = Me.MousePosition.X
        F.Top = Me.MousePosition.Y

        F.C1TrueDBGrid1.DataSource = Me.dtDokumenttyp
        F.C1TrueDBGrid1.DataMember = Me.dtDokumenttyp.TableName
        F.C1TrueDBGrid1.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        F.ShowDialog()
        If F.DialogResult = DialogResult.OK Then
            Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
            colRows = F.C1TrueDBGrid1.SelectedRows
            If colRows.Count - 1 = 0 Then
                Dim i As Integer = F.C1TrueDBGrid1.Columns(0).Value
                Me.mcbdoktyp.SelectedValue = i
                Me.Load_data()
            Else
                For i1 = 0 To colRows.Count - 1
                    Dim i As Integer
                    i = F.C1TrueDBGrid1.Columns(0).CellValue(colRows(i1))
                    Me.mcbdoktyp.SelectedValue = i
                    Me.Load_data()
                Next
            End If
        End If
        If F.DialogResult = DialogResult.Yes Then
            Dim i As Integer = F.C1TrueDBGrid1.Columns(0).Value
            Me.mcbdoktyp.SelectedValue = i
            Me.Load_data()
        End If
        F.Dispose()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.btnXLSExport_Click Method

Private Sub btnXLSExport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnXLSExport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnXLSExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnXLSExport.Click
        If Me.DomainList.Splits(0).Rows.Count > 0 Then
            Me.SaveFileDialog1.CheckFileExists = False
            Me.SaveFileDialog1.CheckPathExists = True
            Me.SaveFileDialog1.DefaultExt = "csv"
            Me.SaveFileDialog1.Filter = "CSV-Dateien (*.csv)|*.csv|Alle Dateien (*.*)|*.*"
            Me.SaveFileDialog1.RestoreDirectory = True
            Me.SaveFileDialog1.ShowHelp = True
            Me.SaveFileDialog1.Title = "Liste als CSV-Datei speichern"
            Me.SaveFileDialog1.ValidateNames = True
            Me.SaveFileDialog1.AddExtension = True
            Me.SaveFileDialog1.DefaultExt.Insert(0, "*.csv")
            Me.SaveFileDialog1.AddExtension = True
            Me.SaveFileDialog1.ShowDialog()
            If Me.SaveFileDialog1.FileName <> "" Then
                Me.DomainList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";")
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.cboDokTyp_leave Method

Private Sub cboDokTyp_leave( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbdoktyp.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cboDokTyp_leave(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbdoktyp.Leave
        If Me.on_Load = True Then Exit Sub
        Try
            Me.Load_data()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.cdmnuShow_Click Method

Private Sub cdmnuShow_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cdmnuShow.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cdmnuShow_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cdmnuShow.Click
        Try
            Dim f As New frmDokumentpaketdefinition(False, Me.DomainList.Columns("dokumentpaketnr").Value, False, Me.individuelles_dp)
            f.Anzeige = True
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.ctmnuEdit_Click Method

Private Sub ctmnuEdit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuEdit.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuEdit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuEdit.Click
        Try
            Dim book
            If Globals.MitarbeiterNr <> Me.DomainList.Columns(10).Value Then
                If Not DivFnkt.Check_Sysadmin_Stellvertreter(Me.DomainList.Columns(10).Value) Then
                    Dim f As New frmDokumentpaketdefinition(False, Me.DomainList.Columns("dokumentpaketnr").Value, False, Me.individuelles_dp)
                    book = Me.DomainList.Bookmark
                    f.Anzeige = True
                    f.ShowDialog()
                    Load_data()
                    Me.DomainList.Bookmark = book
                    f.Dispose()
                Else
                    Dim f As New frmDokumentpaketdefinition(False, Me.DomainList.Columns("dokumentpaketnr").Value, Me.individuelles_dp)
                    book = Me.DomainList.Bookmark
                    f.ShowDialog()
                    Load_data()
                    Me.DomainList.Bookmark = book
                    f.Dispose()
                End If
            Else
                Dim f As New frmDokumentpaketdefinition(False, Me.DomainList.Columns("dokumentpaketnr").Value, Me.individuelles_dp)
                book = Me.DomainList.Bookmark
                f.ShowDialog()
                Load_data()
                Me.DomainList.Bookmark = book
                f.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.ctmnuNew_Click Method

Private Sub ctmnuNew_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ctmnuNew.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ctmnuNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ctmnuNew.Click
        Try
            Dim f As New frmDokumentpaketdefinition(True, 0, Me.individuelles_dp)
            f.ShowDialog()
            Me.DomainList.BeginInit()
            Load_data()
            Me.DomainList.EndInit()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.frmDokumentpaketuebersicht_Load Method

Private Sub frmDokumentpaketuebersicht_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumentpaketuebersicht_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.ToolBar1.Height = Me.ToolBar1.Height + 3
        Me.on_Load = True
        If Me.individuelles_dp = True Then
            '    Me.Width = Me.ParentForm.Width / 3
            '   Me.Height = Me.ParentForm.Height / 3
            '  Me.Text = "Übersicht Individuelle Dokumentpakete"

            Me.Text = "Übersicht Individuelle Dokumentpakete"
            Me.Width = 600
            Me.Height = 450

            Me.cboDokTyp.Visible = False
            Me.btnDokTypSelektion.Visible = False
            Me.btnXLSExport.Visible = False
        Else
            Me.DomainList.ContextMenu = Me.ContextMenu1
            Me.Text = "Übersicht Dokumentpakete"
            Me.cboDokTyp.BringToFront()
            Me.btnDokTypSelektion.BringToFront()
            Me.btnXLSExport.BringToFront()
            Me.dtDokumenttyp = Generic_Select(1)

            Me.mcbdoktyp = New MultiComboBox(Me.cboDokTyp)
            Me.mcbdoktyp.Items.Clear()
            Me.mcbdoktyp.CheckNullValue = False
            Me.mcbdoktyp.DisplayColumnName = "Bezeichnung"
            Me.mcbdoktyp.ValueColumnName = "dokumenttypnr"
            Me.mcbdoktyp.Fill_Data(dtDokumenttyp, True, "-- Keine Dokumenttyp-Verwendung --")
            Me.mcbdoktyp.Visible = True
            Me.lblSelektion.BringToFront()
            Me.mcbdoktyp.BringToFront()

            Dim ttip As New ToolTip()
            ttip.SetToolTip(Me.mcbdoktyp, MyTxt.gettext(22106))
            ttip.SetToolTip(Me.btnDokTypSelektion, MyTxt.gettext(22107))
            ttip.SetToolTip(Me.btnXLSExport, MyTxt.gettext(22108))

        End If
        Load_data()

        Me.DomainList.AllowAddNew = False
        Me.on_Load = False
        If Me.individuelles_dp = True Then Me.DomainList.ContextMenu = Me.ContextMenu2 Else Me.DomainList.ContextMenu = Me.ContextMenu1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht.mcbdoktyp_TextChanged Method

Private Sub mcbdoktyp_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbdoktyp.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbdoktyp_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbdoktyp.SelectedIndexChanged
        cboDokTyp_leave(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht Fields

frmDokumentpaketuebersicht overview

Fields

field ContextMenu1
field ContextMenu2
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SaveFileDialog1
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field ToolTip1
field btnDokTypSelektion
field btnXLSExport
field cboDokTyp
field cdmnuShow
field components
field ctmnuEdit
field ctmnuNew
field dtDokumenttyp
field lblSelektion
field m_dokumentpaketnr
field m_individuelles_DP
field m_mitarbeiternr
field mcbdoktyp
field on_Load

See Also

frmDokumentpaketuebersicht Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SaveFileDialog1 Variable

Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Source code

[Visual Basic]
    Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


btnDokTypSelektion Variable

Friend WithEvents btnDokTypSelektion As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnDokTypSelektion As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


btnXLSExport Variable

Friend WithEvents btnXLSExport As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnXLSExport As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


cboDokTyp Variable

Friend WithEvents cboDokTyp As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboDokTyp As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


cdmnuShow Variable

Friend WithEvents cdmnuShow As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents cdmnuShow As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


ctmnuEdit Variable

Friend WithEvents ctmnuEdit As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuEdit As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


ctmnuNew Variable

Friend WithEvents ctmnuNew As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents ctmnuNew As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


dtDokumenttyp Variable

Dim dtDokumenttyp As DataTable

Source code

[Visual Basic]
    Dim dtDokumenttyp As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


lblSelektion Variable

Friend WithEvents lblSelektion As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblSelektion As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


m_dokumentpaketnr Variable

Dim m_dokumentpaketnr As Integer

Source code

[Visual Basic]
    Dim m_dokumentpaketnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


m_individuelles_DP Variable

Dim m_individuelles_DP As Boolean

Source code

[Visual Basic]
    Dim m_individuelles_DP As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Integer = 0

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


mcbdoktyp Variable

Dim WithEvents mcbdoktyp As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbdoktyp As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


on_Load Variable

Dim on_Load As Boolean = False

Source code

[Visual Basic]
    Dim on_Load As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumenttypInfo Class

For a list of all members of this type, see frmDokumenttypInfo Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumenttypInfo

Public Class frmDokumenttypInfo
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumenttypInfo Members


frmDokumenttypInfo Members

frmDokumenttypInfo overview

Constructors

constructor frmDokumenttypInfo Constructor

Properties

property Key

Methods

method C1TrueDBGrid2_Click
method Daten_laden
method Dispose
method Get_From_DB
method InitializeComponent
method ToolBar1_ButtonClick
method frmDokumenttypInfo_Load

Fields

field C1TrueDBGrid1
field C1TrueDBGrid2
field C1TrueDBGrid3
field CheckBox1
field CheckBox2
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field RichTextBox1
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field TextBox1
field TextBox2
field TextBox3
field ToolBar1
field ToolBarButton1
field components
field m_key
field t
field t1
field t2
field t3

See Also

frmDokumenttypInfo Class


frmDokumenttypInfo Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo Properties

frmDokumenttypInfo overview

Properties

property Key

See Also

frmDokumenttypInfo Class


frmDokumenttypInfo.Key Property

Property Key() As Integer

Source code

[Visual Basic]
    Property Key() As Integer
        Get
            Return m_key
        End Get
        Set(ByVal Value As Integer)
            m_key = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo Methods

frmDokumenttypInfo overview

Methods

method C1TrueDBGrid2_Click
method Daten_laden
method Dispose
method Get_From_DB
method InitializeComponent
method ToolBar1_ButtonClick
method frmDokumenttypInfo_Load

See Also

frmDokumenttypInfo Class


frmDokumenttypInfo.C1TrueDBGrid2_Click Method

Private Sub C1TrueDBGrid2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.Daten_laden Method

Private Function Daten_laden( _
   ByVal fnkt As Integer _
) As DataTable

Parameters

fnkt
Required.

Source code

[Visual Basic]
    Private Function Daten_laden(ByVal fnkt As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumenttypinfo"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Key))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.Get_From_DB Method

Public Function Get_From_DB()

Source code

[Visual Basic]
    Public Function Get_From_DB()
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From dokumenttypbeschreibung where dokumenttypbeschreibungnr=" + Str(Key), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docbeschreibung")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(1)
            Dim K As Long
            K = UBound(MyData)

            Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Me.RichTextBox1.LoadFile(dokname)
        Catch ex As Exception
            Return False
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumenttypInfo))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.RichTextBox1 = New System.Windows.Forms.RichTextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.CheckBox2 = New System.Windows.Forms.CheckBox()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.C1TrueDBGrid2 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.C1TrueDBGrid3 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage3.SuspendLayout()
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'RichTextBox1
        '
        Me.RichTextBox1.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.RichTextBox1.Location = New System.Drawing.Point(0, 205)
        Me.RichTextBox1.Name = "RichTextBox1"
        Me.RichTextBox1.ReadOnly = True
        Me.RichTextBox1.Size = New System.Drawing.Size(720, 224)
        Me.RichTextBox1.TabIndex = 0
        Me.RichTextBox1.Text = "RichTextBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(0, 48)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(136, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Vorlagenentwickler:"
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.Color.White
        Me.TextBox1.Location = New System.Drawing.Point(120, 48)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(216, 20)
        Me.TextBox1.TabIndex = 2
        Me.TextBox1.Text = "TextBox1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(0, 72)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(104, 16)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Aufbewahrungsfrist:"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(0, 96)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(104, 16)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Vertraulich möglich:"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(0, 120)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(112, 32)
        Me.Label4.TabIndex = 5
        Me.Label4.Text = "Berechtigungsein-schränkung möglich"
        '
        'TextBox2
        '
        Me.TextBox2.BackColor = System.Drawing.Color.White
        Me.TextBox2.Location = New System.Drawing.Point(120, 72)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.ReadOnly = True
        Me.TextBox2.Size = New System.Drawing.Size(216, 20)
        Me.TextBox2.TabIndex = 6
        Me.TextBox2.Text = "TextBox2"
        '
        'CheckBox1
        '
        Me.CheckBox1.Enabled = False
        Me.CheckBox1.Location = New System.Drawing.Point(120, 96)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.TabIndex = 7
        '
        'CheckBox2
        '
        Me.CheckBox2.Enabled = False
        Me.CheckBox2.Location = New System.Drawing.Point(120, 120)
        Me.CheckBox2.Name = "CheckBox2"
        Me.CheckBox2.TabIndex = 8
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2, Me.TabPage3})
        Me.TabControl1.Location = New System.Drawing.Point(344, 48)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(376, 152)
        Me.TabControl1.TabIndex = 9
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(368, 126)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Status"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowArrows = False
        Me.C1TrueDBGrid1.AllowColMove = False
        Me.C1TrueDBGrid1.AllowColSelect = False
        Me.C1TrueDBGrid1.AllowFilter = False
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AllowUpdate = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ColumnHeaders = False
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(368, 126)
        Me.C1TrueDBGrid1.TabIndex = 1
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}S" & _
        "tyle1{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Con" & _
        "trol;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}S" & _
        "tyle10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Split" & _
        "s><C1.Win.C1TrueDBGrid.MergeView AllowColMove=""False"" AllowColSelect=""False"" Nam" & _
        "e="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" Def" & _
        "RecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0" & _
        ", 0, 364, 122</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2" & _
        """ me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent" & _
        "=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><Foot" & _
        "erStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" />" & _
        "<HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""Highligh" & _
        "tRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""S" & _
        "tyle11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" " & _
        "me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style paren" & _
        "t="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading""" & _
        " me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me" & _
        "=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""" & _
        "Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""" & _
        "EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""Reco" & _
        "rdSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me" & _
        "=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><La" & _
        "yout>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 3" & _
        "64, 122</ClientArea></Blob>"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid2})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(368, 126)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Funktionen Aufhebung/Löschung"
        '
        'C1TrueDBGrid2
        '
        Me.C1TrueDBGrid2.AllowArrows = False
        Me.C1TrueDBGrid2.AllowColMove = False
        Me.C1TrueDBGrid2.AllowColSelect = False
        Me.C1TrueDBGrid2.AllowFilter = False
        Me.C1TrueDBGrid2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid2.AllowSort = True
        Me.C1TrueDBGrid2.AllowUpdate = False
        Me.C1TrueDBGrid2.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid2.AlternatingRows = True
        Me.C1TrueDBGrid2.CaptionHeight = 17
        Me.C1TrueDBGrid2.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.ColumnHeaders = False
        Me.C1TrueDBGrid2.DataChanged = False
        Me.C1TrueDBGrid2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid2.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid2.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid2.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid2.Name = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid2.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid2.RecordSelectorWidth = 17
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid2.RowDivider = GridLines2
        Me.C1TrueDBGrid2.RowHeight = 15
        Me.C1TrueDBGrid2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid2.ScrollTips = False
        Me.C1TrueDBGrid2.Size = New System.Drawing.Size(368, 126)
        Me.C1TrueDBGrid2.TabIndex = 2
        Me.C1TrueDBGrid2.Text = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}S" & _
        "tyle9{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Cen" & _
        "ter;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}S" & _
        "tyle10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Split" & _
        "s><C1.Win.C1TrueDBGrid.MergeView AllowColMove=""False"" AllowColSelect=""False"" Nam" & _
        "e="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" Def" & _
        "RecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0" & _
        ", 0, 364, 122</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2" & _
        """ me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent" & _
        "=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><Foot" & _
        "erStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" />" & _
        "<HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""Highligh" & _
        "tRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""S" & _
        "tyle11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" " & _
        "me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style paren" & _
        "t="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading""" & _
        " me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me" & _
        "=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""" & _
        "Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""" & _
        "EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""Reco" & _
        "rdSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me" & _
        "=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><La" & _
        "yout>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 3" & _
        "64, 122</ClientArea></Blob>"
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid3})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(368, 126)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Funktionen Indexmutation"
        '
        'C1TrueDBGrid3
        '
        Me.C1TrueDBGrid3.AllowArrows = False
        Me.C1TrueDBGrid3.AllowColMove = False
        Me.C1TrueDBGrid3.AllowColSelect = False
        Me.C1TrueDBGrid3.AllowFilter = False
        Me.C1TrueDBGrid3.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid3.AllowSort = True
        Me.C1TrueDBGrid3.AllowUpdate = False
        Me.C1TrueDBGrid3.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid3.AlternatingRows = True
        Me.C1TrueDBGrid3.CaptionHeight = 17
        Me.C1TrueDBGrid3.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid3.ColumnHeaders = False
        Me.C1TrueDBGrid3.DataChanged = False
        Me.C1TrueDBGrid3.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid3.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid3.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid3.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid3.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid3.Name = "C1TrueDBGrid3"
        Me.C1TrueDBGrid3.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid3.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid3.RecordSelectorWidth = 17
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid3.RowDivider = GridLines3
        Me.C1TrueDBGrid3.RowHeight = 15
        Me.C1TrueDBGrid3.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid3.ScrollTips = False
        Me.C1TrueDBGrid3.Size = New System.Drawing.Size(368, 126)
        Me.C1TrueDBGrid3.TabIndex = 2
        Me.C1TrueDBGrid3.Text = "C1TrueDBGrid3"
        Me.C1TrueDBGrid3.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}S" & _
        "tyle9{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Cen" & _
        "ter;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}S" & _
        "tyle10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Split" & _
        "s><C1.Win.C1TrueDBGrid.MergeView AllowColMove=""False"" AllowColSelect=""False"" Nam" & _
        "e="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" Def" & _
        "RecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0" & _
        ", 0, 364, 122</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2" & _
        """ me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent" & _
        "=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><Foot" & _
        "erStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" />" & _
        "<HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""Highligh" & _
        "tRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""S" & _
        "tyle11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" " & _
        "me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style paren" & _
        "t="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading""" & _
        " me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me" & _
        "=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""" & _
        "Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""" & _
        "EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""Reco" & _
        "rdSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me" & _
        "=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><La" & _
        "yout>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 3" & _
        "64, 122</ClientArea></Blob>"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(720, 25)
        Me.ToolBar1.TabIndex = 10
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(0, 184)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(160, 23)
        Me.Label5.TabIndex = 11
        Me.Label5.Text = "Allgemeine Beschreibung"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(168, 98)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(104, 29)
        Me.Label6.TabIndex = 13
        Me.Label6.Text = "Bearbeitung nach Abschluss:"
        '
        'TextBox3
        '
        Me.TextBox3.BackColor = System.Drawing.Color.White
        Me.TextBox3.Location = New System.Drawing.Point(264, 104)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.ReadOnly = True
        Me.TextBox3.Size = New System.Drawing.Size(72, 20)
        Me.TextBox3.TabIndex = 14
        Me.TextBox3.Text = "TextBox3"
        '
        'frmDokumenttypInfo
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(720, 429)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox3, Me.Label6, Me.RichTextBox1, Me.Label5, Me.ToolBar1, Me.TabControl1, Me.CheckBox2, Me.CheckBox1, Me.TextBox2, Me.Label4, Me.Label3, Me.Label2, Me.TextBox1, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumenttypInfo"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Info Dokumentvorlage -"
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage3.ResumeLayout(False)
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo.frmDokumenttypInfo_Load Method

Private Sub frmDokumenttypInfo_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumenttypInfo_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim s As String
        t = Daten_laden(1)
        Me.TextBox1.Text = t.Rows(0).Item(0)
        s = ""
        Try
            s = LTrim(Str(t.Rows(0).Item(1)))
        Catch
            s = "0"
        End Try
        Try
            If t.Rows(0).Item(4) = "True" Then
                s = s + " Jahre ab Aufhebung des Dokumentes"
            Else
                s = s + " Jahre nach Abschluss des Dokumentes"
            End If
        Catch
        End Try
        Me.TextBox2.Text = s

        '        Me.TextBox2.Text = t.Rows(0).Item(1)
        Me.CheckBox1.Checked = t.Rows(0).Item(2) = True
        Me.CheckBox2.Checked = t.Rows(0).Item(3) = True

        Try
            Me.TextBox3.Text = "0 Tage"
            Me.TextBox3.Text = Trim(Str(t.Rows(0).Item(5))) + " Tage"
        Catch
        End Try

        t1 = Daten_laden(2)
        Me.C1TrueDBGrid1.DataSource = t1
        Me.C1TrueDBGrid1.DataMember = t1.TableName

        t2 = Daten_laden(3)
        Me.C1TrueDBGrid2.DataSource = t2
        Me.C1TrueDBGrid2.DataMember = t2.TableName

        t3 = Daten_laden(4)
        Me.C1TrueDBGrid3.DataSource = t3
        Me.C1TrueDBGrid3.DataMember = t3.TableName

        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Width = Me.C1TrueDBGrid1.Width - 60
        Me.C1TrueDBGrid2.Splits(0).DisplayColumns(0).Width = Me.C1TrueDBGrid1.Width - 60
        Me.C1TrueDBGrid3.Splits(0).DisplayColumns(0).Width = Me.C1TrueDBGrid1.Width - 60

        Me.RichTextBox1.Clear()
        Get_From_DB()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypInfo Fields

frmDokumenttypInfo overview

Fields

field C1TrueDBGrid1
field C1TrueDBGrid2
field C1TrueDBGrid3
field CheckBox1
field CheckBox2
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field RichTextBox1
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field TextBox1
field TextBox2
field TextBox3
field ToolBar1
field ToolBarButton1
field components
field m_key
field t
field t1
field t2
field t3

See Also

frmDokumenttypInfo Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


C1TrueDBGrid2 Variable

Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


C1TrueDBGrid3 Variable

Friend WithEvents C1TrueDBGrid3 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid3 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


CheckBox2 Variable

Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


RichTextBox1 Variable

Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


m_key Variable

Dim m_key As Integer

Source code

[Visual Basic]
    Dim m_key As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


t Variable

Dim t As DataTable

Source code

[Visual Basic]
    Dim t As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


t1 Variable

Dim t1 As DataTable

Source code

[Visual Basic]
    Dim t1 As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


t2 Variable

Dim t2 As DataTable

Source code

[Visual Basic]
    Dim t2 As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


t3 Variable

Dim t3 As DataTable

Source code

[Visual Basic]
    Dim t3 As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypInfo


frmDokumenttypOptions Class

For a list of all members of this type, see frmDokumenttypOptions Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumenttypOptions

Public Class frmDokumenttypOptions
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumenttypOptions Members


frmDokumenttypOptions Members

frmDokumenttypOptions overview

Constructors

constructor frmDokumenttypOptions Constructor

Properties

property Dokumenttypnr
property key

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method Get_From_DB
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method Save_To_DB
method ToolBar1_ButtonClick
method ToolBar2_ButtonClick
method frmDokumenttypOptions_Load

Fields

field Button1
field Button2
field Button3
field Button4
field ContextMenu1
field FontDialog1
field GroupBox1
field GroupBox2
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field RichTextBoxHS1
field ToolBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field components
field m_dokumenttypnr
field m_key

See Also

frmDokumenttypOptions Class


frmDokumenttypOptions Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions Properties

frmDokumenttypOptions overview

Properties

property Dokumenttypnr
property key

See Also

frmDokumenttypOptions Class


frmDokumenttypOptions.Dokumenttypnr Property

Property Dokumenttypnr() As Integer

Source code

[Visual Basic]
    Property Dokumenttypnr() As Integer
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttypnr = Value
            Me.key = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.key Property

Property key() As Integer

Source code

[Visual Basic]
    Property key() As Integer
        Get
            Return m_key
        End Get
        Set(ByVal Value As Integer)
            m_key = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions Methods

frmDokumenttypOptions overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method Get_From_DB
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method Save_To_DB
method ToolBar1_ButtonClick
method ToolBar2_ButtonClick
method frmDokumenttypOptions_Load

See Also

frmDokumenttypOptions Class


frmDokumenttypOptions.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        DivFnkt.leererstellung(1, Me.Dokumenttypnr)
        Me.Button1.Enabled = False
        Me.Button2.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        DivFnkt.leererstellung(2, Me.Dokumenttypnr)
        Me.Button1.Enabled = True
        Me.Button2.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        DivFnkt.EDOKA_Partner_Dokument(2, Me.Dokumenttypnr)
        Me.Button4.Enabled = True
        Me.Button3.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        DivFnkt.EDOKA_Partner_Dokument(1, Me.Dokumenttypnr)
        Me.Button4.Enabled = False
        Me.Button3.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Get_From_DB Method

Public Function Get_From_DB()

Source code

[Visual Basic]
    Public Function Get_From_DB()
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From dokumenttypbeschreibung where dokumenttypbeschreibungnr=" + Str(key), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docbeschreibung")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(1)
            Dim K As Long
            K = UBound(MyData)

            Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Me.RichTextBoxHS1.LoadFile(dokname)
            Me.ToolBar1.Buttons(2).Enabled = True
        Catch ex As Exception
            Return False
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumenttypOptions))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.ToolBar2 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.RichTextBoxHS1 = New EDOKAApp.RichTextBoxHS()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.FontDialog1 = New System.Windows.Forms.FontDialog()
        Me.Panel1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(936, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox2, Me.GroupBox1})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(936, 73)
        Me.Panel1.TabIndex = 3
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.Button4})
        Me.GroupBox2.Location = New System.Drawing.Point(208, 4)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(232, 64)
        Me.GroupBox2.TabIndex = 3
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Dokumenterstellung für EDOKA-Partner"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(120, 24)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 1
        Me.Button3.Text = "Verhindern"
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(40, 24)
        Me.Button4.Name = "Button4"
        Me.Button4.TabIndex = 0
        Me.Button4.Text = "Zulassen"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 4)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(192, 64)
        Me.GroupBox1.TabIndex = 2
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Erstellung Leerdokument"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(96, 24)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 1
        Me.Button2.Text = "Verhindern"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(16, 24)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 0
        Me.Button1.Text = "Zulassen"
        '
        'ToolBar2
        '
        Me.ToolBar2.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton2})
        Me.ToolBar2.DropDownArrows = True
        Me.ToolBar2.ImageList = Me.ImageList1
        Me.ToolBar2.Location = New System.Drawing.Point(0, 98)
        Me.ToolBar2.Name = "ToolBar2"
        Me.ToolBar2.ShowToolTips = True
        Me.ToolBar2.Size = New System.Drawing.Size(936, 25)
        Me.ToolBar2.TabIndex = 4
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 2
        '
        'RichTextBoxHS1
        '
        Me.RichTextBoxHS1.AcceptsTab = True
        Me.RichTextBoxHS1.ContextMenu = Me.ContextMenu1
        Me.RichTextBoxHS1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.RichTextBoxHS1.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.RichTextBoxHS1.Location = New System.Drawing.Point(0, 123)
        Me.RichTextBoxHS1.Name = "RichTextBoxHS1"
        Me.RichTextBoxHS1.Size = New System.Drawing.Size(936, 442)
        Me.RichTextBoxHS1.TabIndex = 5
        Me.RichTextBoxHS1.Text = ""
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Schriftart..."
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Gelb markieren"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "&Markierungen löschen"
        '
        'frmDokumenttypOptions
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(936, 565)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBoxHS1, Me.ToolBar2, Me.Panel1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.SizableToolWindow
        Me.Name = "frmDokumenttypOptions"
        Me.ShowInTaskbar = False
        Me.Text = "Diverse Dokumenttyp-Einstellungen"
        Me.Panel1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Me.FontDialog1.ShowColor = True
        Me.FontDialog1.ShowApply = True
        Me.FontDialog1.ShowEffects = True
        Me.FontDialog1.ShowDialog()
        RichTextBoxHS1.SelectionFont = Me.FontDialog1.Font
        RichTextBoxHS1.SelectionColor = Me.FontDialog1.Color
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        RichTextBoxHS1.SelectionBackColor = System.Drawing.Color.Yellow
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        RichTextBoxHS1.BackColorSetWhole(System.Drawing.Color.White)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.Save_To_DB Method

Public Function Save_To_DB()

Source code

[Visual Basic]
    Public Function Save_To_DB()

        Dim Connection As New SqlConnection()

        Dim da As New SqlDataAdapter("Select * From dokumenttypbeschreibung where dokumenttypbeschreibungnr=" + Str(key), Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Me.RichTextBoxHS1.SaveFile(dokname)
        Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        Try
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            If ds.Tables(0).Rows.Count = 0 Then
                ' Neues Dokument speichern
                myRow = ds.Tables(0).NewRow
                myRow.Item(0) = key
                myRow.Item(1) = mydata
                myRow.Item(2) = Now
                myRow.Item(3) = Globals.MitarbeiterNr
                ds.Tables(0).Rows.Add(myRow)
                da.Update(ds, "docs")
            Else
                myRow = ds.Tables(0).Rows(0)
                myRow.Item(1) = mydata
                da.Update(ds, "docs")
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
            Return False
        Finally
            fs = Nothing
            cb = Nothing
            ds = Nothing
            da = Nothing

            Connection.Close()
            Connection = Nothing
        End Try
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.ToolBar2_ButtonClick Method

Private Sub ToolBar2_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar2.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar2_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar2.ButtonClick
        Save_To_DB()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions.frmDokumenttypOptions_Load Method

Private Sub frmDokumenttypOptions_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumenttypOptions_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If DivFnkt.leererstellung(3, Me.Dokumenttypnr) = True Then
            Me.Button2.Enabled = True
            Me.Button1.Enabled = False
        Else
            Me.Button2.Enabled = False
            Me.Button1.Enabled = True
        End If
        If DivFnkt.EDOKA_Partner_Dokument(3, Me.Dokumenttypnr) = True Then
            Me.Button3.Enabled = True
            Me.Button4.Enabled = False
        Else
            Me.Button3.Enabled = False
            Me.Button4.Enabled = True
        End If
        Get_From_DB()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypOptions Fields

frmDokumenttypOptions overview

Fields

field Button1
field Button2
field Button3
field Button4
field ContextMenu1
field FontDialog1
field GroupBox1
field GroupBox2
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field RichTextBoxHS1
field ToolBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field components
field m_dokumenttypnr
field m_key

See Also

frmDokumenttypOptions Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


FontDialog1 Variable

Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Source code

[Visual Basic]
    Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


RichTextBoxHS1 Variable

Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Source code

[Visual Basic]
    Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ToolBar2 Variable

Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Integer

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


m_key Variable

Dim m_key As Integer = 0

Source code

[Visual Basic]
    Dim m_key As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypOptions


frmDokumenttypbeschreibung Class

For a list of all members of this type, see frmDokumenttypbeschreibung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumenttypbeschreibung

Public Class frmDokumenttypbeschreibung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumenttypbeschreibung Members


frmDokumenttypbeschreibung Members

frmDokumenttypbeschreibung overview

Constructors

constructor frmDokumenttypbeschreibung Constructor

Properties

property key

Methods

method Dispose
method Get_From_DB
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method Save_To_DB
method ToolBar1_ButtonClick
method frmDokumenttypbeschreibung_Load

Fields

field ContextMenu1
field FontDialog1
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field RichTextBox1
field RichTextBoxHS1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field components
field m_key

See Also

frmDokumenttypbeschreibung Class


frmDokumenttypbeschreibung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung Properties

frmDokumenttypbeschreibung overview

Properties

property key

See Also

frmDokumenttypbeschreibung Class


frmDokumenttypbeschreibung.key Property

Property key() As Integer

Source code

[Visual Basic]
    Property key() As Integer
        Get
            Return m_key
        End Get
        Set(ByVal Value As Integer)
            m_key = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung Methods

frmDokumenttypbeschreibung overview

Methods

method Dispose
method Get_From_DB
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method Save_To_DB
method ToolBar1_ButtonClick
method frmDokumenttypbeschreibung_Load

See Also

frmDokumenttypbeschreibung Class


frmDokumenttypbeschreibung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.Get_From_DB Method

Public Function Get_From_DB()

Source code

[Visual Basic]
    Public Function Get_From_DB()
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From dokumenttypbeschreibung where dokumenttypbeschreibungnr=" + Str(key), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docbeschreibung")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(1)
            Dim K As Long
            K = UBound(MyData)

            Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Me.RichTextBoxHS1.LoadFile(dokname)
            Me.ToolBar1.Buttons(2).Enabled = True
        Catch ex As Exception
            Return False
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumenttypbeschreibung))
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.FontDialog1 = New System.Windows.Forms.FontDialog()
        Me.RichTextBoxHS1 = New EDOKAApp.RichTextBoxHS()
        Me.SuspendLayout()
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Schriftart..."
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Gelb markieren"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "&Markierungen löschen"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(824, 25)
        Me.ToolBar1.TabIndex = 1
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.Visible = False
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 2
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'RichTextBoxHS1
        '
        Me.RichTextBoxHS1.AcceptsTab = True
        Me.RichTextBoxHS1.ContextMenu = Me.ContextMenu1
        Me.RichTextBoxHS1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.RichTextBoxHS1.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.RichTextBoxHS1.Location = New System.Drawing.Point(0, 25)
        Me.RichTextBoxHS1.Name = "RichTextBoxHS1"
        Me.RichTextBoxHS1.Size = New System.Drawing.Size(824, 476)
        Me.RichTextBoxHS1.TabIndex = 2
        Me.RichTextBoxHS1.Text = ""
        '
        'frmDokumenttypbeschreibung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(824, 501)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBoxHS1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumenttypbeschreibung"
        Me.Text = "Dokumenttypbeschreibung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Me.FontDialog1.ShowColor = True
        Me.FontDialog1.ShowApply = True
        Me.FontDialog1.ShowEffects = True
        Me.FontDialog1.ShowDialog()
        RichTextBoxHS1.SelectionFont = Me.FontDialog1.Font
        RichTextBoxHS1.SelectionColor = Me.FontDialog1.Color
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        RichTextBoxHS1.SelectionBackColor = System.Drawing.Color.Yellow
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        RichTextBoxHS1.BackColorSetWhole(System.Drawing.Color.White)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.Save_To_DB Method

Public Function Save_To_DB()

Source code

[Visual Basic]
    Public Function Save_To_DB()

        Dim Connection As New SqlConnection()

        Dim da As New SqlDataAdapter("Select * From dokumenttypbeschreibung where dokumenttypbeschreibungnr=" + Str(key), Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim dokname As String
        dokname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmp.rtf"
        Me.RichTextBoxHS1.SaveFile(dokname)
        Dim fs As New FileStream(dokname, FileMode.OpenOrCreate, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        Try
            fs.Read(mydata, 0, fs.Length)
            fs.Close()
            Connection.ConnectionString = Globals.sConnectionString
            Connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            If ds.Tables(0).Rows.Count = 0 Then
                ' Neues Dokument speichern
                myRow = ds.Tables(0).NewRow
                myRow.Item(0) = key
                myRow.Item(1) = mydata
                myRow.Item(2) = Now
                myRow.Item(3) = Globals.MitarbeiterNr
                ds.Tables(0).Rows.Add(myRow)
                da.Update(ds, "docs")
            Else
                myRow = ds.Tables(0).Rows(0)
                myRow.Item(1) = mydata
                da.Update(ds, "docs")
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
            MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
            Return False
        Finally
            fs = Nothing
            cb = Nothing
            ds = Nothing
            da = Nothing

            Connection.Close()
            Connection = Nothing
        End Try
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                Dim frm As New frmDomainDokumenttyp()
                frm.ToSelect = True
                frm.TransferKey = 0
                frm.Eintragnr = 0
                frm.Refresh()
                frm.Owner = Me
                frm.ShowDialog()
                If frm.TransferKey = 0 Then
                    frm.Dispose()
                    Exit Sub
                End If
                Me.RichTextBoxHS1.Clear()
                key = frm.TransferKey
                frm.Dispose()
                Get_From_DB()
            Case 2
                If Me.key = 0 Then
                    MsgBox("Sie haben keinen Dokumenttyp ausgewählt.")
                    Exit Sub
                End If
                Save_To_DB()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung.frmDokumenttypbeschreibung_Load Method

Private Sub frmDokumenttypbeschreibung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDokumenttypbeschreibung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_From_DB()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumenttypbeschreibung Fields

frmDokumenttypbeschreibung overview

Fields

field ContextMenu1
field FontDialog1
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field RichTextBox1
field RichTextBoxHS1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field components
field m_key

See Also

frmDokumenttypbeschreibung Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


FontDialog1 Variable

Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Source code

[Visual Basic]
    Friend WithEvents FontDialog1 As System.Windows.Forms.FontDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


RichTextBox1 Variable

Friend WithEvents RichTextBox1 As RichTextBoxHS

Source code

[Visual Basic]
    Friend WithEvents RichTextBox1 As RichTextBoxHS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


RichTextBoxHS1 Variable

Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Source code

[Visual Basic]
    Friend WithEvents RichTextBoxHS1 As EDOKAApp.RichTextBoxHS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


m_key Variable

Dim m_key As Integer = 0

Source code

[Visual Basic]
    Dim m_key As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumenttypbeschreibung


frmDokumentvorlage Class

For a list of all members of this type, see frmDokumentvorlage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentvorlage

Public Class frmDokumentvorlage
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentvorlage Members


frmDokumentvorlage Members

frmDokumentvorlage overview

Constructors

constructor frmDokumentvorlage Constructor

Methods

method Dispose
method InitializeComponent

Fields

field components

See Also

frmDokumentvorlage Class


frmDokumentvorlage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentvorlage


frmDokumentvorlage Methods

frmDokumentvorlage overview

Methods

method Dispose
method InitializeComponent

See Also

frmDokumentvorlage Class


frmDokumentvorlage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentvorlage


frmDokumentvorlage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        components = New System.ComponentModel.Container()
        Me.Text = "frmDokumentvorlage"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentvorlage


frmDokumentvorlage Fields

frmDokumentvorlage overview

Fields

field components

See Also

frmDokumentvorlage Class


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentvorlage


frmDokumentwerte Class

For a list of all members of this type, see frmDokumentwerte Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDokumentwerte

Public Class frmDokumentwerte
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDokumentwerte Members


frmDokumentwerte Members

frmDokumentwerte overview

Constructors

constructor frmDokumentwerte Constructor

Properties

property WordData
property isOk

Methods

method Button1_Click
method C1TrueDBGrid1_Click
method C1TrueDBGrid1_CursorChanged
method C1TrueDBGrid1_MouseUp
method Dispose
method Dokumentwerte_Load
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method TreeView1_AfterSelect
method TxtBestehenderwert_DoubleClick
method btnCancel_Click
method btnWeiter_Click
method convert
method refresh_data
method txtNeuerWert_TextChanged

Fields

field AlleWerte
field Button1
field C1TrueDBGrid1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field TreeView1
field TxtBestehenderwert
field btnCancel
field btnWeiter
field components
field m_data
field m_isOk
field txtNeuerWert

See Also

frmDokumentwerte Class


frmDokumentwerte Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte Properties

frmDokumentwerte overview

Properties

property WordData
property isOk

See Also

frmDokumentwerte Class


frmDokumentwerte.WordData Property

Property WordData() As DataTable

Source code

[Visual Basic]
    Property WordData() As DataTable
        Get
            Return m_data
        End Get
        Set(ByVal Value As DataTable)
            m_data = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.isOk Property

Property isOk() As Integer

Source code

[Visual Basic]
    Property isOk() As Integer
        Get
            Return m_isOk
        End Get
        Set(ByVal Value As Integer)
            m_isOk = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte Methods

frmDokumentwerte overview

Methods

method Button1_Click
method C1TrueDBGrid1_Click
method C1TrueDBGrid1_CursorChanged
method C1TrueDBGrid1_MouseUp
method Dispose
method Dokumentwerte_Load
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method TreeView1_AfterSelect
method TxtBestehenderwert_DoubleClick
method btnCancel_Click
method btnWeiter_Click
method convert
method refresh_data
method txtNeuerWert_TextChanged

See Also

frmDokumentwerte Class


frmDokumentwerte.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.isOk = 2
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.C1TrueDBGrid1_Click Method

Private Sub C1TrueDBGrid1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.Click
        If Me.C1TrueDBGrid1.Columns("oldvalue").Value Is System.DBNull.Value Then Me.TxtBestehenderwert.Text = "" Else Me.TxtBestehenderwert.Text = convert(Me.C1TrueDBGrid1.Columns("oldvalue").Value)
        If Me.C1TrueDBGrid1.Columns("xvalue").Value Is System.DBNull.Value Then Me.txtNeuerWert.Text = "" Else Me.txtNeuerWert.Text = convert(Me.C1TrueDBGrid1.Columns("xvalue").Value)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.C1TrueDBGrid1_CursorChanged Method

Private Sub C1TrueDBGrid1_CursorChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.CursorChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_CursorChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.CursorChanged
        If Me.C1TrueDBGrid1.Columns("oldvalue").Value Is System.DBNull.Value Then Me.TxtBestehenderwert.Text = "" Else Me.TxtBestehenderwert.Text = convert(Me.C1TrueDBGrid1.Columns("oldvalue").Value)
        If Me.C1TrueDBGrid1.Columns("xvalue").Value Is System.DBNull.Value Then Me.txtNeuerWert.Text = "" Else Me.txtNeuerWert.Text = convert(Me.C1TrueDBGrid1.Columns("xvalue").Value)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.C1TrueDBGrid1_MouseUp Method

Private Sub C1TrueDBGrid1_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles C1TrueDBGrid1.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1TrueDBGrid1.MouseUp
        If Me.C1TrueDBGrid1.Columns("oldvalue").Value Is System.DBNull.Value Then Me.TxtBestehenderwert.Text = "" Else Me.TxtBestehenderwert.Text = convert(Me.C1TrueDBGrid1.Columns("oldvalue").Value)
        If Me.C1TrueDBGrid1.Columns("xvalue").Value Is System.DBNull.Value Then Me.txtNeuerWert.Text = "" Else Me.txtNeuerWert.Text = convert(Me.C1TrueDBGrid1.Columns("xvalue").Value)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.Dokumentwerte_Load Method

Private Sub Dokumentwerte_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Dokumentwerte_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim t As DataTable
        Dim i As Integer
        Dim tn As TreeNode
        Me.isOk = False
        t = Generic_Select(1)
        Dim S As String
        For i = 0 To Me.WordData.Rows.Count - 1
            Try
                If Me.WordData.Rows(i).Item("oldvalue") Is System.DBNull.Value Then Me.WordData.Rows(i).Item("oldvalue") = ""
            Catch
            End Try
            Try
                If Me.WordData.Rows(i).Item("xvalue") Is System.DBNull.Value Then Me.WordData.Rows(i).Item("xvalue") = ""
            Catch
            End Try

            Try
                Me.WordData.Rows(i).Item("oldvalue") = Trim(convert(Me.WordData.Rows(i).Item("oldvalue")))
            Catch
            End Try
            Try
                Me.WordData.Rows(i).Item("xvalue") = Trim(convert(Me.WordData.Rows(i).Item("xvalue")))
            Catch
            End Try
            Try
                S = Me.WordData.Rows(i).Item("OLDVALUE")
                S.Replace(Chr(7), "")
                S.Replace(Chr(10), "")
                S.Replace(Chr(13), "")
                Me.WordData.Rows(i).Item("OLDVALUE") = S
            Catch

            End Try
        Next
        Me.TreeView1.Nodes.Clear()
        For i = 0 To t.Rows.Count - 1
            tn = Me.TreeView1.Nodes.Add(t.Rows(i).Item(1))
            tn.Tag = t.Rows(i).Item(0)
        Next
        Dim gaga As New C1.Win.C1TrueDBGrid.ValueItem()
        'Me.WordData.Columns.Add("Mut")
        Me.C1TrueDBGrid1.DataSource = Me.WordData

        Me.TreeView1.Focus()
        Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Kategorien"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDokumentwerte))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.btnWeiter = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TxtBestehenderwert = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.txtNeuerWert = New System.Windows.Forms.TextBox()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ColumnHeaders = False
        Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(200, 32)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(616, 336)
        Me.C1TrueDBGrid1.TabIndex = 0
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""17"" DefRecSelWidth=""17"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 612, 332</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRe" & _
        "cSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 612, 332</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4, Me.MenuItem5})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "Nur geänderte Elemente anzeigen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Alle Elemente anzeigen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "Bestehender Wert übernehmen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 4
        Me.MenuItem5.Text = "Alle bestehenden Werte übernehmen"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(600, 376)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.Size = New System.Drawing.Size(104, 23)
        Me.btnCancel.TabIndex = 5
        Me.btnCancel.Text = "&Abbruch"
        '
        'btnWeiter
        '
        Me.btnWeiter.Location = New System.Drawing.Point(712, 376)
        Me.btnWeiter.Name = "btnWeiter"
        Me.btnWeiter.Size = New System.Drawing.Size(104, 23)
        Me.btnWeiter.TabIndex = 4
        Me.btnWeiter.Text = "&Weiter>>"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(200, 376)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(104, 23)
        Me.Button1.TabIndex = 6
        Me.Button1.Text = "<< &Zurück"
        Me.Button1.Visible = False
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(216, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 7
        Me.Label1.Text = "Element"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(416, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(152, 16)
        Me.Label2.TabIndex = 8
        Me.Label2.Text = "Neuer Dokumentinhalt"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(608, 16)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(160, 16)
        Me.Label3.TabIndex = 9
        Me.Label3.Text = "Bestehender Dokumentinhalt"
        '
        'TreeView1
        '
        Me.TreeView1.ImageIndex = -1
        Me.TreeView1.Location = New System.Drawing.Point(8, 32)
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Textmarken"), New System.Windows.Forms.TreeNode("Felder")})
        Me.TreeView1.SelectedImageIndex = -1
        Me.TreeView1.Size = New System.Drawing.Size(184, 97)
        Me.TreeView1.TabIndex = 10
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 16)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(100, 16)
        Me.Label4.TabIndex = 11
        Me.Label4.Text = "Bereich"
        '
        'TxtBestehenderwert
        '
        Me.TxtBestehenderwert.Location = New System.Drawing.Point(8, 152)
        Me.TxtBestehenderwert.Multiline = True
        Me.TxtBestehenderwert.Name = "TxtBestehenderwert"
        Me.TxtBestehenderwert.ReadOnly = True
        Me.TxtBestehenderwert.Size = New System.Drawing.Size(184, 96)
        Me.TxtBestehenderwert.TabIndex = 12
        Me.TxtBestehenderwert.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 136)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(100, 16)
        Me.Label5.TabIndex = 13
        Me.Label5.Text = "Bestehend"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 256)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(100, 16)
        Me.Label6.TabIndex = 15
        Me.Label6.Text = "Neu"
        '
        'txtNeuerWert
        '
        Me.txtNeuerWert.Location = New System.Drawing.Point(8, 272)
        Me.txtNeuerWert.Multiline = True
        Me.txtNeuerWert.Name = "txtNeuerWert"
        Me.txtNeuerWert.Size = New System.Drawing.Size(184, 96)
        Me.txtNeuerWert.TabIndex = 14
        Me.txtNeuerWert.Text = ""
        '
        'frmDokumentwerte
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(824, 405)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label6, Me.txtNeuerWert, Me.Label5, Me.TxtBestehenderwert, Me.Label4, Me.TreeView1, Me.Label3, Me.Label2, Me.Label1, Me.Button1, Me.btnCancel, Me.btnWeiter, Me.C1TrueDBGrid1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDokumentwerte"
        Me.Text = "Dokumentinhalte"
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Me.AlleWerte = False
        refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.AlleWerte = True
        refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Try
            Me.C1TrueDBGrid1.Columns("xvalue").Value = Me.C1TrueDBGrid1.Columns("oldvalue").CellValue(Me.C1TrueDBGrid1.Bookmark)
            refresh_data()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Dim i As Integer
        For i = 0 To Me.WordData.Rows.Count - 1
            Me.WordData.Rows(i).Item("xvalue") = Me.WordData.Rows(i).Item("oldvalue")
            refresh_data()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.TreeView1_AfterSelect Method

Private Sub TreeView1_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect
        '        If Me.TreeView1.SelectedNode.Text = "Textmarken" Then
        refresh_data()
        Dim i As Integer
        For i = 0 To Me.TreeView1.GetNodeCount(True) - 1
            Me.TreeView1.Nodes(i).ForeColor = System.Drawing.Color.Black
        Next
        Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Red
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.TxtBestehenderwert_DoubleClick Method

Private Sub TxtBestehenderwert_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TxtBestehenderwert.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TxtBestehenderwert_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TxtBestehenderwert.DoubleClick
        Dim i As Integer
        For i = 1 To Me.TxtBestehenderwert.Text.Length
            MsgBox(Microsoft.VisualBasic.Mid(Me.TxtBestehenderwert.Text, i, 1))
            MsgBox(Asc(Microsoft.VisualBasic.Mid(Me.TxtBestehenderwert.Text, i, 1)))

        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        Me.isOk = 0
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.btnWeiter_Click Method

Private Sub btnWeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnWeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnWeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnWeiter.Click
        Me.isOk = 1
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.convert Method

Function convert( _
   ByVal x As String _
) As String

Parameters

x
Required.

Source code

[Visual Basic]
    Function convert(ByVal x As String) As String
        Dim s As String
        Dim s1 As String
        Dim i As Integer
        s = x
        i = InStr(s, Chr(13))
        While i > 0
            s = Microsoft.VisualBasic.Left(s, i - 1) & "#" & Microsoft.VisualBasic.Right(s, Len(s) - (i))
            If Mid(s, i + 1, 1) = Chr(10) Then
                s = Microsoft.VisualBasic.Left(s, i) & Microsoft.VisualBasic.Right(s, Len(s) - (i + 1))
            End If
            i = InStr(s, Chr(13))
        End While
        i = InStr(s, "#")
        While i > 0
            s = Microsoft.VisualBasic.Left(s, i - 1) & vbCrLf & Microsoft.VisualBasic.Right(s, Len(s) - (i))
            i = InStr(s, "#")
        End While
        convert = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.refresh_data Method

Private Sub refresh_data()

Source code

[Visual Basic]
    Private Sub refresh_data()
        Dim i As Integer
        For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
        Next
        Me.C1TrueDBGrid1.Columns("used").FilterText = "1"
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Element").Width = 200
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Element").Visible = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Element").Locked = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("xvalue").Visible = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("oldvalue").Visible = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Width = 110
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("xvalue").Width = 190
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("oldvalue").Width = 190
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("oldvalue").Locked = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("kategorie").Width = 0
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("kategorie").Visible = True
        Me.C1TrueDBGrid1.Columns("kategorie").FilterText = Me.TreeView1.SelectedNode.Tag
        '       Else
        '      Dim i As Integer
        '     For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
        '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
        '   Next
        '  Me.C1TrueDBGrid1.Splits(0).DisplayColumns("feldname").Visible = True
        ' Me.C1TrueDBGrid1.Splits(0).DisplayColumns("xvalue").Visible = True
        'Me.C1TrueDBGrid1.Splits(0).DisplayColumns("oldvalue").Visible = True
        '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Width = 110
        '       Me.C1TrueDBGrid1.Splits(0).DisplayColumns("xvalue").Width = 190
        '      Me.C1TrueDBGrid1.Splits(0).DisplayColumns("oldvalue").Width = 190
        '     Me.C1TrueDBGrid1.Columns("beginntextmarke").FilterText = ""
        '    Me.C1TrueDBGrid1.Columns("feldname").FilterText = "T"
        '   End If
        If AlleWerte = False Then
            For i = 0 To Me.C1TrueDBGrid1.Splits(0).Rows.Count - 1
                Try
                    If Me.C1TrueDBGrid1.Columns("xvalue").CellValue(i) = Me.C1TrueDBGrid1.Columns("oldvalue").CellValue(i) Then
                        Me.C1TrueDBGrid1.Splits(0).Rows(i).Visible = False
                    End If
                Catch
                End Try
            Next
        Else
            For i = 0 To Me.C1TrueDBGrid1.Splits(0).Rows.Count - 1
                Try
                    If Me.C1TrueDBGrid1.Columns("xvalue").CellValue(i) = Me.C1TrueDBGrid1.Columns("oldvalue").CellValue(i) Then
                        Me.C1TrueDBGrid1.Splits(0).Rows(i).Visible = True
                    End If
                Catch
                End Try
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte.txtNeuerWert_TextChanged Method

Private Sub txtNeuerWert_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtNeuerWert.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtNeuerWert_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtNeuerWert.TextChanged
        Me.C1TrueDBGrid1.Columns("xvalue").Value = Me.txtNeuerWert.Text
        refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDokumentwerte Fields

frmDokumentwerte overview

Fields

field AlleWerte
field Button1
field C1TrueDBGrid1
field ContextMenu1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field TreeView1
field TxtBestehenderwert
field btnCancel
field btnWeiter
field components
field m_data
field m_isOk
field txtNeuerWert

See Also

frmDokumentwerte Class


AlleWerte Variable

Dim AlleWerte As Boolean = True

Source code

[Visual Basic]
    Dim AlleWerte As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


TxtBestehenderwert Variable

Friend WithEvents TxtBestehenderwert As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtBestehenderwert As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


btnWeiter Variable

Friend WithEvents btnWeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnWeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


m_data Variable

Dim m_data As DataTable

Source code

[Visual Basic]
    Dim m_data As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


m_isOk Variable

Dim m_isOk As Integer

Source code

[Visual Basic]
    Dim m_isOk As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


txtNeuerWert Variable

Friend WithEvents txtNeuerWert As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtNeuerWert As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentwerte


frmDomainAnwendung Class

For a list of all members of this type, see frmDomainAnwendung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainAnwendung

Public Class frmDomainAnwendung
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainAnwendung Members


frmDomainAnwendung Members

frmDomainAnwendung overview

Constructors

constructor frmDomainAnwendung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainAnwendung Class


frmDomainAnwendung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung Properties

frmDomainAnwendung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainAnwendung Class


frmDomainAnwendung Methods

frmDomainAnwendung overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainAnwendung Class


frmDomainAnwendung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "anwendung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("anwendungnr", "anwendungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_anwendung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_anwendung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_anwendung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_anwendung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainAnwendung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainAnwendung"
        Me.Text = "cldDomainBerechtigung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "anwendung"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAnwendung Fields

frmDomainAnwendung overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainAnwendung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAnwendung


frmDomainAuswertungen Class

For a list of all members of this type, see frmDomainAuswertungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainAuswertungen

Public Class frmDomainAuswertungen
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainAuswertungen Members


frmDomainAuswertungen Members

frmDomainAuswertungen overview

Constructors

constructor frmDomainAuswertungen Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method DomainList_MouseDown
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainAuswertungen_Load
method miExport_Click
method miIport_Click

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field cmReport
field components
field miExport
field miIport

See Also

frmDomainAuswertungen Class


frmDomainAuswertungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen Properties

frmDomainAuswertungen overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainAuswertungen Class


frmDomainAuswertungen Methods

frmDomainAuswertungen overview

Methods

method Dispose
method DomainList_MouseDown
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainAuswertungen_Load
method miExport_Click
method miIport_Click

See Also

frmDomainAuswertungen Class


frmDomainAuswertungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.DomainList_MouseDown Method

Private Sub DomainList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DomainList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DomainList.MouseDown
        If e.Button = MouseButtons.Right Then
            Me.DomainList.Bookmark = Me.DomainList.RowContaining(e.Y)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.cmReport = New System.Windows.Forms.ContextMenu()
        Me.miIport = New System.Windows.Forms.MenuItem()
        Me.miExport = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'cmReport
        '
        Me.cmReport.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.miIport, Me.miExport})
        '
        'miIport
        '
        Me.miIport.Index = 0
        Me.miIport.Text = "Report &Importieren"
        '
        'miExport
        '
        Me.miExport.Index = 1
        Me.miExport.Text = "Report &Exportieren"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("dateiname", "dateiname"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_report_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_report_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 50, "dateiname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_report_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_report_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 50, "dateiname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainAuswertungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainAuswertungen"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(ex.Message)

            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.frmDomainAuswertungen_Load Method

Private Sub frmDomainAuswertungen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainAuswertungen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DomainList.ContextMenu = Me.cmReport

        'Me.TableName = "ParameterSet"
        Me.TableName = "report"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Dim i As Integer
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "odbc" Then Me.DomainList.Columns(i).DefaultValue = False
            If Me.DomainList.Columns(i).DataField = "oledb" Then Me.DomainList.Columns(i).DefaultValue = True
            If Me.DomainList.Columns(i).DataField = "sqlclient" Then Me.DomainList.Columns(i).DefaultValue = False
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.miExport_Click Method

Private Sub miExport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles miExport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub miExport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles miExport.Click
        Dim objReport As New edokadb.clsReporting_Dokumenttyp()
        Dim Dokument_Temp As String
        Dim i As Integer
        Dokument_Temp = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente")

        objReport.Get_DocumentFrom_DB("reportNr", DomainList.Columns("reportNr").Text, "report", "reportfile", Dokument_Temp, DomainList.Columns(3).Value)

        objReport = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen.miIport_Click Method

Private Sub miIport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles miIport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub miIport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles miIport.Click
        Dim iPos As Integer
        Dim sFileName As String
        Dim OpenReportFileDialog As New OpenFileDialog()
        Dim objReport As New edokadb.clsReporting_Dokumenttyp()
        Dim sReportpath As String

        Try
            '===============================================================================
            'Opendialog
            '===============================================================================
            sReportpath = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_reportdateien")
            If Microsoft.VisualBasic.Right(sReportpath, 1) <> "\" Then sReportpath = sReportpath & "\"
            OpenReportFileDialog.InitialDirectory = sReportpath
            OpenReportFileDialog.Filter = "REPORT files (*.rpt)|*.rpt|All files (*.*)|*.*"
            OpenReportFileDialog.FilterIndex = 1
            OpenReportFileDialog.RestoreDirectory = True
            '============Dialog & Fileprügung
            If OpenReportFileDialog.ShowDialog() = DialogResult.OK Then
                iPos = InStrRev(OpenReportFileDialog.FileName, "\")
                If iPos = 0 Then
                    sFileName = OpenReportFileDialog.FileName
                Else
                    sFileName = Microsoft.VisualBasic.Right(OpenReportFileDialog.FileName, Len(OpenReportFileDialog.FileName) - iPos)
                End If
                If InStr(sFileName, ".rpt") < 1 Then
                    MessageBox.Show("Es sind nur Reportfile erlaubt!", "Reportfile", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                    Exit Sub
                End If
                '============File in DB Speichern
                DomainList.Columns(3).Text = sFileName        'dateiname
                SqlDataAdapter1.Update(Me.DataSet1)
                objReport.Save_To_DB(DomainList.Columns("reportNr").Text, OpenReportFileDialog.FileName, "reportfile", DomainList.Bookmark)
            End If

        Catch ex As Exception
            MessageBox.Show(ex.Message, "Error", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)

        End Try
        objReport = Nothing

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungen Fields

frmDomainAuswertungen overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field cmReport
field components
field miExport
field miIport

See Also

frmDomainAuswertungen Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


cmReport Variable

Friend WithEvents cmReport As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents cmReport As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


miExport Variable

Friend WithEvents miExport As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents miExport As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


miIport Variable

Friend WithEvents miIport As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents miIport As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungen


frmDomainAuswertungsgruppe Class

For a list of all members of this type, see frmDomainAuswertungsgruppe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainAuswertungsgruppe

Public Class frmDomainAuswertungsgruppe
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainAuswertungsgruppe Members


frmDomainAuswertungsgruppe Members

frmDomainAuswertungsgruppe overview

Constructors

constructor frmDomainAuswertungsgruppe Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainAuswertungsgruppe Class


frmDomainAuswertungsgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe Properties

frmDomainAuswertungsgruppe overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainAuswertungsgruppe Class


frmDomainAuswertungsgruppe Methods

frmDomainAuswertungsgruppe overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainAuswertungsgruppe Class


frmDomainAuswertungsgruppe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_reportgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_reportgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_reportgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_reportgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=TGTSQLEDOKABSSF;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgentwicklung3;workstation id=TG602640;packet size" & _
        "=4096"
        '
        'frmDomainAuswertungsgruppe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainAuswertungsgruppe"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "reportgruppe"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainAuswertungsgruppe Fields

frmDomainAuswertungsgruppe overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainAuswertungsgruppe Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainAuswertungsgruppe


frmDomainBankinformation Class

For a list of all members of this type, see frmDomainBankinformation Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainBankinformation

Public Class frmDomainBankinformation
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainBankinformation Members


frmDomainBankinformation Members

frmDomainBankinformation overview

Constructors

constructor frmDomainBankinformation Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainBankinformation Class


frmDomainBankinformation Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation Properties

frmDomainBankinformation overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainBankinformation Class


frmDomainBankinformation Methods

frmDomainBankinformation overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainBankinformation Class


frmDomainBankinformation.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "bankinformation", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bankinformationnr", "bankinformationnr"), New System.Data.Common.DataColumnMapping("bankname", "bankname"), New System.Data.Common.DataColumnMapping("adresszeile1", "adresszeile1"), New System.Data.Common.DataColumnMapping("adresszeile2", "adresszeile2"), New System.Data.Common.DataColumnMapping("plz", "plz"), New System.Data.Common.DataColumnMapping("ort", "ort"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("telefax", "telefax"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("internet", "internet"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_bankinformation_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_bankinformation_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankname", System.Data.SqlDbType.VarChar, 255, "bankname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile1", System.Data.SqlDbType.VarChar, 255, "adresszeile1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile2", System.Data.SqlDbType.VarChar, 255, "adresszeile2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@plz", System.Data.SqlDbType.VarChar, 255, "plz"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ort", System.Data.SqlDbType.VarChar, 255, "ort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 255, "telefon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefax", System.Data.SqlDbType.VarChar, 255, "telefax"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 255, "email"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@internet", System.Data.SqlDbType.VarChar, 255, "internet"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_bankinformation_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankname", System.Data.SqlDbType.VarChar, 255, "bankname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile1", System.Data.SqlDbType.VarChar, 255, "adresszeile1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile2", System.Data.SqlDbType.VarChar, 255, "adresszeile2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@plz", System.Data.SqlDbType.VarChar, 255, "plz"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ort", System.Data.SqlDbType.VarChar, 255, "ort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 255, "telefon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefax", System.Data.SqlDbType.VarChar, 255, "telefax"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 255, "email"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@internet", System.Data.SqlDbType.VarChar, 255, "internet"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_internet", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "internet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_plz", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "plz", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefax", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_bankinformation_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_internet", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "internet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_plz", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "plz", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefax", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainBankinformation
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainBankinformation"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "bankinformation"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBankinformation Fields

frmDomainBankinformation overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainBankinformation Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBankinformation


frmDomainBerechtigung Class

For a list of all members of this type, see frmDomainBerechtigung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainBerechtigung

Public Class frmDomainBerechtigung
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainBerechtigung Members


frmDomainBerechtigung Members

frmDomainBerechtigung overview

Constructors

constructor frmDomainBerechtigung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainBerechtigung Class


frmDomainBerechtigung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung Properties

frmDomainBerechtigung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainBerechtigung Class


frmDomainBerechtigung Methods

frmDomainBerechtigung overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainBerechtigung Class


frmDomainBerechtigung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "berechtigung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("sysadminfunktion", "sysadminfunktion"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_berechtigung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_berechtigung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfunktion", System.Data.SqlDbType.Bit, 1, "sysadminfunktion"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_berechtigung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfunktion", System.Data.SqlDbType.Bit, 1, "sysadminfunktion"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfunktion", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfunktion", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_berechtigung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfunktion", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfunktion", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'cldDomainBerechtigung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "cldDomainBerechtigung"
        Me.Text = "cldDomainBerechtigung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "berechtigung"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainBerechtigung Fields

frmDomainBerechtigung overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainBerechtigung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainBerechtigung


frmDomainColdFolder Class

For a list of all members of this type, see frmDomainColdFolder Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainColdFolder

Public Class frmDomainColdFolder
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainColdFolder Members


frmDomainColdFolder Members

frmDomainColdFolder overview

Constructors

constructor frmDomainColdFolder Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainColdFolder Class


frmDomainColdFolder Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder Properties

frmDomainColdFolder overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainColdFolder Class


frmDomainColdFolder Methods

frmDomainColdFolder overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainColdFolder Class


frmDomainColdFolder.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "cold_folder", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("cold_foldernr", "cold_foldernr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("batch_parameter", "batch_parameter"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_cold_folder_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_cold_folder_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_foldernr", System.Data.SqlDbType.Int, 4, "cold_foldernr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@batch_parameter", System.Data.SqlDbType.VarChar, 255, "batch_parameter"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_cold_folder_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_foldernr", System.Data.SqlDbType.Int, 4, "cold_foldernr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@batch_parameter", System.Data.SqlDbType.VarChar, 255, "batch_parameter"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_foldernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_foldernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_batch_parameter", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "batch_parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_cold_folder_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_foldernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_foldernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_batch_parameter", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "batch_parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainColdFolder
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainColdFolder"
        Me.Text = "frmDomainColdFolder"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "cold_folder"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdFolder Fields

frmDomainColdFolder overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainColdFolder Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdFolder


frmDomainColdIndexFeld Class

For a list of all members of this type, see frmDomainColdIndexFeld Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainColdIndexFeld

Public Class frmDomainColdIndexFeld
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainColdIndexFeld Members


frmDomainColdIndexFeld Members

frmDomainColdIndexFeld overview

Constructors

constructor frmDomainColdIndexFeld Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainColdIndexFeld Class


frmDomainColdIndexFeld Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld Properties

frmDomainColdIndexFeld overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainColdIndexFeld Class


frmDomainColdIndexFeld Methods

frmDomainColdIndexFeld overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainColdIndexFeld Class


frmDomainColdIndexFeld.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "cold_indexfeld", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("indexfeldnr", "indexfeldnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("format", "format"), New System.Data.Common.DataColumnMapping("durch_edoka_befuellt", "durch_edoka_befuellt"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_cold_indexfeld_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_cold_indexfeld_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexfeldnr", System.Data.SqlDbType.Int, 4, "indexfeldnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 255, "format"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@durch_edoka_befuellt", System.Data.SqlDbType.Bit, 1, "durch_edoka_befuellt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_cold_indexfeld_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexfeldnr", System.Data.SqlDbType.Int, 4, "indexfeldnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 255, "format"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@durch_edoka_befuellt", System.Data.SqlDbType.Bit, 1, "durch_edoka_befuellt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_durch_edoka_befuellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "durch_edoka_befuellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_cold_indexfeld_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_durch_edoka_befuellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "durch_edoka_befuellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainColdIndexFeld
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainColdIndexFeld"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "cold_indexfeld"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainColdIndexFeld Fields

frmDomainColdIndexFeld overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainColdIndexFeld Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainColdIndexFeld


frmDomainDokumentartDaten Class

For a list of all members of this type, see frmDomainDokumentartDaten Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainDokumentartDaten

Public Class frmDomainDokumentartDaten
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainDokumentartDaten Members


frmDomainDokumentartDaten Members

frmDomainDokumentartDaten overview

Constructors

constructor frmDomainDokumentartDaten Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method HandleDbl
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainDokumentartDaten Class


frmDomainDokumentartDaten Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten Properties

frmDomainDokumentartDaten overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainDokumentartDaten Class


frmDomainDokumentartDaten Methods

frmDomainDokumentartDaten overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method HandleDbl
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainDokumentartDaten Class


frmDomainDokumentartDaten.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.HandleDbl Method

Private Sub HandleDbl( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub HandleDbl(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        Dim f As New frmIconSelector()
        f.ShowDialog()

        If f.DialogResult = DialogResult.OK Then
            Me.DomainList.Columns("imageindex").Value = f.SelectedImage
            Me.DomainList.Columns("imageindexopen").Value = f.SelectedImage
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumentart", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumentartnr", "dokumentartnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("parentid", "parentid"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("imageindex", "imageindex"), New System.Data.Common.DataColumnMapping("imageindexopen", "imageindexopen"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_dokumentart_daten_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_imageindex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "imageindex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_imageindexopen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "imageindexopen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_parentid", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "parentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_dokumentart_daten_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@parentid", System.Data.SqlDbType.Int, 4, "parentid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.Int, 4, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@imageindex", System.Data.SqlDbType.Int, 4, "imageindex"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@imageindexopen", System.Data.SqlDbType.Int, 4, "imageindexopen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_dokumentart_daten_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_dokumentart_daten_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@parentid", System.Data.SqlDbType.Int, 4, "parentid"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.Int, 4, "sort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@imageindex", System.Data.SqlDbType.Int, 4, "imageindex"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@imageindexopen", System.Data.SqlDbType.Int, 4, "imageindexopen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_imageindex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "imageindex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_imageindexopen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "imageindexopen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_parentid", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "parentid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainDokumentartDaten
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainDokumentartDaten"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "dokumentart"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumentartDaten Fields

frmDomainDokumentartDaten overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainDokumentartDaten Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumentartDaten


frmDomainDokumenttyp Class

For a list of all members of this type, see frmDomainDokumenttyp Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainDokumenttyp

Public Class frmDomainDokumenttyp
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainDokumenttyp Members


frmDomainDokumenttyp Members

frmDomainDokumenttyp overview

Constructors

constructor frmDomainDokumenttyp Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method ContextMenu1_Popup
method Dispose
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Is_SysadminBerechtigt
method MenuDokumenttypAendern_Click
method MenuItem10_Click
method MenuItem12_Click
method MenuItem3_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem9_Click
method MnuNeuerDokumenttyp_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load
method load_data
method mnuKopie_Click

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuDokumenttypAendern
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem10
field MenuItem12
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuNeuerDokumenttyp
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field mnuKopie

See Also

frmDomainDokumenttyp Class


frmDomainDokumenttyp Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp Properties

frmDomainDokumenttyp overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainDokumenttyp Class


frmDomainDokumenttyp Methods

frmDomainDokumenttyp overview

Methods

method ContextMenu1_Popup
method Dispose
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Is_SysadminBerechtigt
method MenuDokumenttypAendern_Click
method MenuItem10_Click
method MenuItem12_Click
method MenuItem3_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem9_Click
method MnuNeuerDokumenttyp_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load
method load_data
method mnuKopie_Click

See Also

frmDomainDokumenttyp Class


frmDomainDokumenttyp.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If DivFnkt.leererstellung(3, Me.DomainList.Columns(0).Text) Then
            Me.MenuItem9.Enabled = False
            Me.MenuItem10.Enabled = True
        Else
            Me.MenuItem9.Enabled = True
            Me.MenuItem10.Enabled = False
        End If
        If Not Is_SysadminBerechtigt() Then
            Me.mnuKopie.Enabled = False
            Me.MenuDokumenttypAendern.Enabled = False
        Else
            Me.mnuKopie.Enabled = True
            Me.MenuDokumenttypAendern.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.Domainlist_dblclick Method

Private Sub Domainlist_dblclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Domainlist_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        If ToSelect Then
            Me.TransferKey = Me.DomainList.Columns(0).Value
            Me.Close()
            Exit Sub
        End If
        MenuDokumenttypAendern_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuNeuerDokumenttyp = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.mnuKopie = New System.Windows.Forms.MenuItem()
        Me.MenuDokumenttypAendern = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("dokumentart_weitere", "dokumentart_weitere"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus"), New System.Data.Common.DataColumnMapping("Dokument_wird_erstellt", "Dokument_wird_erstellt"), New System.Data.Common.DataColumnMapping("Dokument_wird_retourniert", "Dokument_wird_retourniert")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_dokumenttyp_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka_tkb;persist security info=False;user id=sa;" & _
        "workstation id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_dokumenttyp_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_dokumenttyp_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_dokumenttyp_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeuerDokumenttyp, Me.MenuItem4, Me.mnuKopie, Me.MenuDokumenttypAendern, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7, Me.MenuItem8, Me.MenuItem9, Me.MenuItem10, Me.MenuItem12})
        '
        'MnuNeuerDokumenttyp
        '
        Me.MnuNeuerDokumenttyp.Index = 0
        Me.MnuNeuerDokumenttyp.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.MnuNeuerDokumenttyp.Text = "&Neuer Dokumenttyp erfassen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.Text = "-"
        '
        'mnuKopie
        '
        Me.mnuKopie.Index = 2
        Me.mnuKopie.Text = "Kopie erstellen"
        '
        'MenuDokumenttypAendern
        '
        Me.MenuDokumenttypAendern.Index = 3
        Me.MenuDokumenttypAendern.Shortcut = System.Windows.Forms.Shortcut.CtrlF2
        Me.MenuDokumenttypAendern.Text = "&Dokumenttyp ändern"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 4
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 5
        Me.MenuItem6.Text = "Dokumenttyp-Auswertung"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 6
        Me.MenuItem7.Text = "Dokumenttyp-Vorlagenfelder-Auswertung"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 7
        Me.MenuItem8.Text = "-"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 8
        Me.MenuItem9.Text = "Erstellung Leerdokument zulassen"
        Me.MenuItem9.Visible = False
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 9
        Me.MenuItem10.Text = "Erstellung Leerdokument verhindern"
        Me.MenuItem10.Visible = False
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 10
        Me.MenuItem12.Text = "Dokumenttyp-Beschreibung"
        Me.MenuItem12.Visible = False
        '
        'frmDomainDokumenttyp
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(800, 465)
        Me.Name = "frmDomainDokumenttyp"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.Is_SysadminBerechtigt Method

Private Function Is_SysadminBerechtigt() As Boolean

Source code

[Visual Basic]
    Private Function Is_SysadminBerechtigt() As Boolean
        Dim dty As New edokadb.clsDokumenttyp()
        Dim dt As DataTable
        dty.cpMainConnectionProvider = conn
        dty.iDokumenttypnr = New SqlInt32(CType(Me.DomainList.Columns("dokumenttypnr").Value, Int32))
        dt = dty.SelectOne()
        If dty.iOwner.Value <> Globals.MitarbeiterNr And Not DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            If DivFnkt.Check_Sysadmin_Stellvertreter(dty.iOwner.Value) = True Then
                dt.Dispose()
                dty.Dispose()
                Return True
            Else
                dt.Dispose()
                dty.Dispose()
                Return False
            End If
        Else
            dt.Dispose()
            dty.Dispose()
            Return True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuDokumenttypAendern_Click Method

Private Sub MenuDokumenttypAendern_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuDokumenttypAendern.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuDokumenttypAendern_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuDokumenttypAendern.Click
        If Not Me.Is_SysadminBerechtigt Then
            MyMsg.show_standardmessage(245, MsgBoxStyle.Information)
            Exit Sub
        End If
        Dim book As New VariantType()
        Dim frm As New frmDomainDokumenttypDetail()
        Try
            frm.NeuerEintrag = False
            frm.DokumentTypkey = Me.DomainList.Columns(0).Value
            book = Me.DomainList.Bookmark
            frm.ShowDialog()
            load_data()
            Me.DomainList.Bookmark = book
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        DivFnkt.leererstellung(2, Me.DomainList.Columns(0).Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem12_Click Method

Private Sub MenuItem12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem12.Click
        Dim f As New frmDokumenttypbeschreibung()
        f.key = Me.DomainList.Columns(0).Text
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Dim f As New frmReporting()
        f.show_report_dokumenttyp(Me.DomainList.Columns(0).Value)
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim ww As New WordLib()
        ww.Create_Dokument(Me.DomainList.Columns(0).Value, True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MenuItem9_Click Method

Private Sub MenuItem9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem9.Click
        DivFnkt.leererstellung(1, Me.DomainList.Columns(0).Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.MnuNeuerDokumenttyp_Click Method

Private Sub MnuNeuerDokumenttyp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeuerDokumenttyp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeuerDokumenttyp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuerDokumenttyp.Click
        Dim frm As New frmDomainDokumenttypDetail()
        frm.NeuerEintrag = True
        frm.ShowDialog()
        load_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case 2
                Domainlist_dblclick(sender, e)
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableName = "dokumenttyp"
        Dim btn As New ToolBarButton()
        btn.ImageIndex = 3
        Me.ToolBar1.Buttons.Add(btn)
        Me.DomainList.ContextMenu = Me.ContextMenu1
        Me.DomainList.AllowAddNew = False
        Me.DomainList.AllowUpdate = False
        load_data()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.load_data Method

Public Sub load_data()

Source code

[Visual Basic]
    Public Sub load_data()
        Try
            Me.DataSet1.Clear()
            Cursor.Current = Cursors.WaitCursor
            Dim dbconn As New EDOKA.DB_Connection()
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlConnection1.Open()

            ' Nur für den aktuell gewählten Mandanten die Daten auslesen
            Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

            Me.SqlDataAdapter1.Fill(Me.DataSet1)
            Me.DomainList.DataSource = Me.DataSet1
            Me.DomainList.DataMember = Me.TableName

            SpaltenTitel_Aktualisieren(Me.DataSet1)

            Cursor.Current = Cursors.Default
            Me.SqlConnection1.Close()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp.mnuKopie_Click Method

Private Sub mnuKopie_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuKopie.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuKopie_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuKopie.Click
        If MyMsg.Show_MessageYesNo(11) = MsgBoxResult.Yes Then
            Dim doktyp As New edokadb.clsDokumenttyp()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Long
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("dokumenttyp")
            dbkey.Dispose()

            doktyp.cpMainConnectionProvider = conn
            doktyp.iDokumenttypnr = New SqlInt32(CType(Me.DomainList.Columns(0).Text, Int32))
            doktyp.SelectOne()
            doktyp.iDokumenttypnr = New SqlInt32(CType(key, Int32))
            doktyp.sBezeichnung = New SqlString(CType(doktyp.sBezeichnung.Value + " (Kopie)", String))
            conn.OpenConnection()
            doktyp.Insert()
            doktyp.Dispose()
            conn.CloseConnection(True)

            Dim iErrorcode As Integer
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.CommandText = "dbo.[sp_dokumenttyp_insert_copy]"
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DomainList.Columns(0).Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, key))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, key))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iErrorcode))
            Try
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
            load_data()
            Dim i As Integer
            For i = 0 To Me.DomainList.Splits(0).Rows.Count - 1
                If key = Me.DomainList.Columns(0).CellValue(i) Then
                    Me.DomainList.Bookmark = key
                End If
            Next

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttyp Fields

frmDomainDokumenttyp overview

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuDokumenttypAendern
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem10
field MenuItem12
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuNeuerDokumenttyp
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field mnuKopie

See Also

frmDomainDokumenttyp Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuDokumenttypAendern Variable

Friend WithEvents MenuDokumenttypAendern As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuDokumenttypAendern As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


MnuNeuerDokumenttyp Variable

Friend WithEvents MnuNeuerDokumenttyp As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeuerDokumenttyp As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


mnuKopie Variable

Friend WithEvents mnuKopie As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuKopie As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttyp


frmDomainDokumenttypDetail Class

For a list of all members of this type, see frmDomainDokumenttypDetail Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainDokumenttypDetail

Public Class frmDomainDokumenttypDetail
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainDokumenttypDetail Members


frmDomainDokumenttypDetail Members

frmDomainDokumenttypDetail overview

Constructors

constructor frmDomainDokumenttypDetail Constructor

Properties

property DokumentTypkey
property NeuerEintrag

Methods

method BeschrausOV_Click
method BtnHelp_Click
method BtnSaveRollen_Click
method BtnStandard_Click
method BtnStandard_Click_1
method Button3_Click
method Button4_Click
method Button5_Click
method Button6_Click
method Button7_Click
method Button8_Click
method Button9_Click
method C1TrueDBGrid1_FetchCellTips
method Change_Dokstatus
method Check_Dokumentpaketvorlage
method Check_Officevorlage
method Check_Status
method Dispose
method Dokumentinfomeldungen_laden
method Dokumenttypinfomeldungen_Sichern
method Fields_AMSDokument
method Fields_Dokumentwirderstellt
method Fields_Dokumentwirderstellt_Ams
method FormValuecbOfficeVorlage_SelectedIndexChanged
method Generic_Select
method Handle_StrukturRadiobuttons
method InitializeComponent
method Insert_Vorlagenfeld
method Load_Data
method Load_Dokumentstatus
method Load_Listen
method MenuErledigung_Setzen_Click
method MenuItem3_Click
method MenuItem7_Click
method MenuItem8_Click
method MnuDokZuordnungauheben_Click
method MnuErledigung_ab_aufheben_Click
method Panel3_Paint
method Save_Changes
method Save_Data
method Save_Rollenliste
method Save_Statusdata
method SetFields
method SpaltenTitel_Aktualisieren
method SpaltenTitel_Aktualisieren1
method SpaltenTitel_Aktualisieren2
method SpaltenTitel_Aktualisieren_StatusRolle
method Statuslist_Click
method Statuslist_aftercellupdate
method TVStruktur_AfterSelect
method TabControl1_SelectedIndexChanged
method ToolBar1_ButtonClick
method TxtBezeichnung_exit
method Update_Aufhebungliste
method Update_RollenListe
method Update_indexmutation
method btnNeueRolle_Click
method btnSelColdfolder_Click
method btnSelDokumentartAusgang_Click
method btnSelDokumentartEingang_Click
method btnSelObNr_Click
method btnSelOfficeVorlage_Click
method btnSelPhysischeAblage_Click
method btnVorlagenfeld_Click
method btnVorlagenfeld_Click_1
method btnsave_Click
method btnsavevorlagenfeldlist_Click
method cZuRetournieren_CheckedChanged
method cZuRetournieren_CheckedChanged_1
method cZuVercolden_CheckedChanged
method camsdokument_click
method cbAufbewahrungelektronisch_SelectedIndexChanged
method cbAufbewahrungphysisch_SelectedIndexChanged
method cbKDE_CheckedChanged
method cbStatustyp_SelectedIndexChanged
method cbsb_CheckedChanged
method chostdokument_click
method cidvnative_CheckedChanged
method fields_Dokumentwirderstellt_retournierung
method fields_Dokumentwirdimportiert
method fields_Dokumentwirdretourniert
method fields_hostdokument
method frmDomainDokumenttypDetail_Closing
method frmDomainDokumenttypDetail_Load
method init_fields
method insert_dokumentmutation
method insert_german
method rbDokStatusStandard_CheckedChanged
method rbDokStatusStandard_Click
method rbEtikette_CheckedChanged
method rbEtikette_Click
method save_vorlagenfeldlist
method set_tooltips
method update_vorlagenfelder
method vorlagenfeldbezeichnunglist_aftercellupdate
method vorlagenfeldbezeichnunglist_update
method vorlagenfeldlist_MouseUp
method vorlagenfeldlist_RowColChange
method vorlagenfeldlist_aftercellupdate

Fields

field Aufhebungliste
field BeschrausOV
field BtnHelp
field BtnSaveRollen
field BtnStandard
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field CDokumentersetzen
field CDokumentwirdretourniert
field ColdIndexfeldList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field DataChanged
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field DataSet6
field DokStatus
field DokumentstatusRolle_Liste
field Dokumenttypnr
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field Grp1
field ImageList1
field ImageList2
field IndexMutationNachAbschluss
field InfomeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LoeschungNachAbschluss
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MnuDokZuordnungauheben
field On_Load
field Panel1
field Panel2
field Panel3
field RBEingang
field RBEinzeldokumente
field RBErstellung
field RBGesamt
field RBHost
field RBKundendossier
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDataAdapter5
field SqlDataAdapter6
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlSelectCommand6
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field StatusDataChanged
field Statuslist
field TVStruktur
field TabControl1
field TabDokumentfelder
field TabPage1
field TabPage2
field TabStatusreihenfolge
field TabStruktur
field TbSerienbrief
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolTip1
field TxTBeschreibung
field TxTBezeichnung
field TxTDokumentartRetournierung
field TxtDokumentartErstellung
field TxtDokumentartGesamt
field TxtDokumentartHost
field TxtDokumentartKundendossier
field VorlagenDataChanged
field btnNeueRolle
field btnSelColdfolder
field btnSelDokumentartAusgang
field btnSelDokumentartEingang
field btnSelOfficeVorlage
field btnSelPhysischeAblage
field btnVorlagenfeld
field btnsave
field btnsavevorlagenfeldlist
field btnselobnr
field cAMSDokument
field cAktiv
field cDokumentwirderstellt
field cEingangErsetztAusgang
field cEmailVersand
field cFunktion_zuweisen
field cHostDokument
field cNichtgeloescht
field cStatusMutation
field cUnterschriftlinks
field cUnterschriftrechts
field cVertraulich
field cWirdImportiert
field cZuRetournieren
field cZuVercolden
field cbAbschluss
field cbAnzeige
field cbArchiv
field cbAufbewahrungelektronisch
field cbAufbewahrungphysisch
field cbBearbeitungszeit
field cbColdFolder
field cbDokartAusgang
field cbDokartEingang
field cbInEdokaDB
field cbKDE
field cbMonierung
field cbOfficeVorlage
field cbOwner
field cbStatustyp
field cbVertrag
field cbbedingteretournierung
field cbedingtretournierbar
field cbezmut
field cbobnr
field cbprozesserstellung
field cbprozessverwendung
field cbsb
field cbsbedituser
field cbsbimport
field cbsbnur
field cbtagebedr
field cidvnative
field components
field dokumentart
field dokumentinfomeldungen
field indexmutationliste
field m_NeuerEintrag
field m_dokumenttypkey
field mcbbedingteretournierung
field mcbowner
field me_onLoad
field neu
field pnlVorlagenfeld
field r
field rbDokStatusStandard
field rbEtikette
field savestatustyp
field t
field tcoldfolder
field tdokumentartausgang
field tdokumentarteingang
field tobnr
field tofficevorlage
field tphysischesarchiv
field tprozess1
field tprozess2
field tstatustyp
field txtDokumentartEinzeldokument
field txtDokumentstatus
field txtDokumentstatus_barcode
field txthostdokumenttyp
field vorlagenfeldbezeichnunglist
field vorlagenfeldlist

See Also

frmDomainDokumenttypDetail Class


frmDomainDokumenttypDetail Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail Properties

frmDomainDokumenttypDetail overview

Properties

property DokumentTypkey
property NeuerEintrag

See Also

frmDomainDokumenttypDetail Class


frmDomainDokumenttypDetail.DokumentTypkey Property

Property DokumentTypkey() As Long

Source code

[Visual Basic]
    Property DokumentTypkey() As Long
        Get
            Return m_dokumenttypkey
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypkey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.NeuerEintrag Property

Property NeuerEintrag() As Boolean

Source code

[Visual Basic]
    Property NeuerEintrag() As Boolean
        Get
            Return m_NeuerEintrag
        End Get
        Set(ByVal Value As Boolean)
            m_NeuerEintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail Methods

frmDomainDokumenttypDetail overview

Methods

method BeschrausOV_Click
method BtnHelp_Click
method BtnSaveRollen_Click
method BtnStandard_Click
method BtnStandard_Click_1
method Button3_Click
method Button4_Click
method Button5_Click
method Button6_Click
method Button7_Click
method Button8_Click
method Button9_Click
method C1TrueDBGrid1_FetchCellTips
method Change_Dokstatus
method Check_Dokumentpaketvorlage
method Check_Officevorlage
method Check_Status
method Dispose
method Dokumentinfomeldungen_laden
method Dokumenttypinfomeldungen_Sichern
method Fields_AMSDokument
method Fields_Dokumentwirderstellt
method Fields_Dokumentwirderstellt_Ams
method FormValuecbOfficeVorlage_SelectedIndexChanged
method Generic_Select
method Handle_StrukturRadiobuttons
method InitializeComponent
method Insert_Vorlagenfeld
method Load_Data
method Load_Dokumentstatus
method Load_Listen
method MenuErledigung_Setzen_Click
method MenuItem3_Click
method MenuItem7_Click
method MenuItem8_Click
method MnuDokZuordnungauheben_Click
method MnuErledigung_ab_aufheben_Click
method Panel3_Paint
method Save_Changes
method Save_Data
method Save_Rollenliste
method Save_Statusdata
method SetFields
method SpaltenTitel_Aktualisieren
method SpaltenTitel_Aktualisieren1
method SpaltenTitel_Aktualisieren2
method SpaltenTitel_Aktualisieren_StatusRolle
method Statuslist_Click
method Statuslist_aftercellupdate
method TVStruktur_AfterSelect
method TabControl1_SelectedIndexChanged
method ToolBar1_ButtonClick
method TxtBezeichnung_exit
method Update_Aufhebungliste
method Update_RollenListe
method Update_indexmutation
method btnNeueRolle_Click
method btnSelColdfolder_Click
method btnSelDokumentartAusgang_Click
method btnSelDokumentartEingang_Click
method btnSelObNr_Click
method btnSelOfficeVorlage_Click
method btnSelPhysischeAblage_Click
method btnVorlagenfeld_Click
method btnVorlagenfeld_Click_1
method btnsave_Click
method btnsavevorlagenfeldlist_Click
method cZuRetournieren_CheckedChanged
method cZuRetournieren_CheckedChanged_1
method cZuVercolden_CheckedChanged
method camsdokument_click
method cbAufbewahrungelektronisch_SelectedIndexChanged
method cbAufbewahrungphysisch_SelectedIndexChanged
method cbKDE_CheckedChanged
method cbStatustyp_SelectedIndexChanged
method cbsb_CheckedChanged
method chostdokument_click
method cidvnative_CheckedChanged
method fields_Dokumentwirderstellt_retournierung
method fields_Dokumentwirdimportiert
method fields_Dokumentwirdretourniert
method fields_hostdokument
method frmDomainDokumenttypDetail_Closing
method frmDomainDokumenttypDetail_Load
method init_fields
method insert_dokumentmutation
method insert_german
method rbDokStatusStandard_CheckedChanged
method rbDokStatusStandard_Click
method rbEtikette_CheckedChanged
method rbEtikette_Click
method save_vorlagenfeldlist
method set_tooltips
method update_vorlagenfelder
method vorlagenfeldbezeichnunglist_aftercellupdate
method vorlagenfeldbezeichnunglist_update
method vorlagenfeldlist_MouseUp
method vorlagenfeldlist_RowColChange
method vorlagenfeldlist_aftercellupdate

See Also

frmDomainDokumenttypDetail Class


frmDomainDokumenttypDetail.BeschrausOV_Click Method

Private Sub BeschrausOV_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BeschrausOV.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BeschrausOV_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BeschrausOV.Click
        Dim i As Long
        Try
            For i = 0 To tofficevorlage.Rows.Count - 1
                If tofficevorlage.Rows(i).Item(0) = Me.cbOfficeVorlage.SelectedValue Then
                    Me.TxTBeschreibung.Text = tofficevorlage.Rows(i).Item("beschreibung")
                End If
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumenttyp")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.BtnSaveRollen_Click Method

Private Sub BtnSaveRollen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnSaveRollen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnSaveRollen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnSaveRollen.Click
        Me.SqlDataAdapter2.Update(Me.DataSet2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.BtnStandard_Click Method

Private Sub BtnStandard_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnStandard_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim iErrorcode As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.CommandText = "dbo.[sp_vorlagenfeld_standards_insert]"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iErrorcode))
        Try
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
            update_vorlagenfelder()
        End Try
        scmCmdToExecute.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.BtnStandard_Click_1 Method

Private Sub BtnStandard_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnStandard.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnStandard_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnStandard.Click
        Dim iErrorcode As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.CommandText = "dbo.[sp_vorlagenfeld_standards_insert]"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iErrorcode))
        Try
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
            update_vorlagenfelder()
        End Try
        scmCmdToExecute.Dispose()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.SqlDataAdapter3.Update(Me.DataSet3)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Dokumenttypinfomeldungen_Sichern()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Me.SqlDataAdapter5.Update(Me.DataSet5)
        Me.IndexMutationNachAbschluss = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button6_Click Method

Private Sub Button6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button6.Click
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ic As Integer
        Dim frm As New frmDomainFunktionsgruppe()
        Dim key As Long
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim vdata As New edokadb.clsDokumentindexmutation()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Eintragnr = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        colRows = frm.DomainList.SelectedRows
        For ic = 0 To colRows.Count - 1
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("dokumentindexmutation")
            vdata.cpMainConnectionProvider = conn
            vdata.iIndexmutationnr = New SqlInt32(CType(key, Int32))
            vdata.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr.Text, Int32))
            vdata.iFunktionnr = New SqlInt32(CType(frm.DomainList.Columns(0).CellValue(colRows(ic)), Int32))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
            Me.IndexMutationNachAbschluss = True
        Next ic
        vdata.Dispose()
        frm.Dispose()
        Update_indexmutation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button7_Click Method

Private Sub Button7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button7.Click
        Try
            Me.SqlDataAdapter6.Update(Me.DataSet6)
            Me.LoeschungNachAbschluss = True
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button8_Click Method

Private Sub Button8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button8.Click
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim ic As Integer
        Dim frm As New frmDomainFunktionsgruppe()
        Dim key As Long
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim vdata As New edokadb.clsDokumentaufhebung()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Eintragnr = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        colRows = frm.DomainList.SelectedRows
        For ic = 0 To colRows.Count - 1
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("dokumentindexmutation")
            vdata.cpMainConnectionProvider = conn
            vdata.iAufhebungnr = New SqlInt32(CType(key, Int32))
            vdata.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr.Text, Int32))
            vdata.iFunktionnr = New SqlInt32(CType(frm.DomainList.Columns(0).CellValue(colRows(ic)), Int32))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
            Me.LoeschungNachAbschluss = True
        Next ic
        vdata.Dispose()
        frm.Dispose()
        Update_Aufhebungliste()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Button9_Click Method

Private Sub Button9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button9.Click
        Dim f As New frmAMSOfficeVorlage()
        f.Dokumenttypnr = Me.DokumentTypkey
        f.ShowDialog()
        update_vorlagenfelder()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.C1TrueDBGrid1_FetchCellTips Method

Private Sub C1TrueDBGrid1_FetchCellTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles vorlagenfeldlist.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles vorlagenfeldlist.FetchCellTips
        Try
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = "vorlagenfeld"
            ts.Feld = Me.vorlagenfeldlist.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
            ts = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Change_Dokstatus Method

Private Sub Change_Dokstatus( _
   ByVal Statustyp As Integer _
)

Parameters

Statustyp
Required.

Source code

[Visual Basic]
    Private Sub Change_Dokstatus(ByVal Statustyp As Integer)
        Me.DokStatus = Statustyp
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Check_Dokumentpaketvorlage Method

Private Function Check_Dokumentpaketvorlage() As Boolean

Source code

[Visual Basic]
    Private Function Check_Dokumentpaketvorlage() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.CommandText = "edex_sp_dokumentpaketvorlage_dokumenttyp"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            scmCmdToExecute.ExecuteNonQuery()
            If scmCmdToExecute.Parameters("@anzahl").Value > 0 Then
                If MyMsg.show_MessageYesNo_ReplaceText(410, LTrim(Str(scmCmdToExecute.Parameters("@anzahl").Value)), "") = MsgBoxResult.Yes Then
                    scmCmdToExecute.CommandText = "edex_sp_dokumentpaketvorlage_dokumenttyp"
                    scmCmdToExecute.Parameters.Clear()
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.ExecuteNonQuery()
                    Return True
                Else
                    Return False
                End If
            Else
                Return True
            End If
        Catch ex As Exception
            Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Check_Officevorlage Method

Private Sub Check_Officevorlage( _
   ByVal sernder As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbOfficeVorlage.SelectedValueChanged

Parameters

sernder
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Check_Officevorlage(ByVal sernder As System.Object, ByVal e As System.EventArgs) Handles cbOfficeVorlage.SelectedValueChanged
        'If me_onLoad Then Exit Sub
        'Dim cdokumenttyp As New edokadb.clsDokumenttyp()
        'Dim dt As DataTable
        'cdokumenttyp.cpMainConnectionProvider = conn
        'cdokumenttyp.iOffice_vorlagenr = New SqlInt32(CType(Me.cbOfficeVorlage.SelectedValue, Int32))
        'dt = cdokumenttyp.SelectAllWoffice_vorlagenrLogic
        'If dt.Rows.Count > 0 Then
        '    Globals.MyMsg.show_standardmessage(203, MsgBoxStyle.Information)
        'End If
        'dt.Dispose()
        'cdokumenttyp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Check_Status Method

Private Function Check_Status() As Boolean

Source code

[Visual Basic]
    Private Function Check_Status() As Boolean
        Dim normal As Integer
        Dim bck As Integer
        If Me.cDokumentwirderstellt.Checked Then normal = 1 Else normal = 0
        If Me.CDokumentwirdretourniert.Checked Then bck = 1 Else bck = 0
        If Me.cAMSDokument.Checked Then normal = 1

        Dim iErrorcode As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.CommandText = "dbo.[sp_check_last_status]"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
        If Me.cbVertrag.Checked = True Then
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vertrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
        Else
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vertrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        End If
        scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, bck))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@normal", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, normal))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@result", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        Try
            scmCmdToExecute.ExecuteNonQuery()
            If scmCmdToExecute.Parameters("@result").Value = 0 Then Return False Else Return True
        Catch ex As Exception
            Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
        End Try
        scmCmdToExecute.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokumenttypinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            If Me.NeuerEintrag Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Val(Me.Dokumenttypnr.Text)))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Dokumenttypinfomeldungen_Sichern Method

Public Sub Dokumenttypinfomeldungen_Sichern()

Source code

[Visual Basic]
    Public Sub Dokumenttypinfomeldungen_Sichern()
        Dim i As Integer
        For i = 0 To Me.dokumentinfomeldungen.Rows.Count - 1
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokumenttypinfomeldungen_sichern"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Connection.Open()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentinfomeldungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("dokumenttypinfomeldungnr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Val(Me.Dokumenttypnr.Text)))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("empfaengernr")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("bemerkung")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@meldungstext", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("meldungstext")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beistatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("beistatus")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentinfomeldungen.Rows(i).Item("aktiv")))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception

                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception(scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Fields_AMSDokument Method

Private Sub Fields_AMSDokument( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Fields_AMSDokument(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = False
        Me.cUnterschriftrechts.Enabled = False
        Me.CDokumentersetzen.Enabled = False
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = False
        Me.cFunktion_zuweisen.Enabled = False

        Me.cUnterschriftlinks.CheckState = CheckState.Unchecked
        Me.cUnterschriftrechts.CheckState = CheckState.Unchecked
        Me.CDokumentersetzen.CheckState = CheckState.Unchecked
        Me.cEmailVersand.CheckState = CheckState.Unchecked
        Me.cFunktion_zuweisen.CheckState = CheckState.Unchecked

        Me.cbBearbeitungszeit.Enabled = False
        Me.cbBearbeitungszeit.Text = ""
        Me.cbMonierung.Enabled = False
        Me.cbMonierung.Text = ""
        Me.cbAbschluss.Enabled = False
        Me.cbAbschluss.Text = ""
        Me.cbInEdokaDB.Enabled = False
        Me.cbInEdokaDB.Text = ""
        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True

        Me.cZuVercolden.CheckState = CheckState.Unchecked
        Me.cZuVercolden.Enabled = False
        Me.cZuRetournieren.CheckState = CheckState.Unchecked
        Me.cZuRetournieren.Enabled = False
        Me.cEingangErsetztAusgang.CheckState = CheckState.Unchecked
        Me.cEingangErsetztAusgang.Enabled = False

        Me.cbDokartAusgang.Enabled = False
        Me.cbDokartAusgang.Text = ""
        Me.cbDokartEingang.Enabled = False
        Me.cbDokartEingang.Text = ""

        Me.cbArchiv.Enabled = False
        Me.cbArchiv.Text = ""
        Me.cidvnative.CheckState = CheckState.Unchecked
        Me.cidvnative.Enabled = False
        Me.rbEtikette.Enabled = False
        Me.cbStatustyp.SelectedValue = 1
        cbStatustyp_SelectedIndexChanged(sender, e)
        Me.RBKundendossier.Checked = True
        Me.RBKundendossier.Visible = True
        Handle_StrukturRadiobuttons(sender, e)
        Me.cWirdImportiert.Checked = False
        Me.cWirdImportiert.Enabled = False
        Me.cHostDokument.Checked = False
        Me.cHostDokument.Enabled = False
        Me.txthostdokumenttyp.Enabled = False
        Me.txthostdokumenttyp.Text = ""
        Me.cDokumentwirderstellt.Enabled = False
        Me.cDokumentwirderstellt.Checked = False
        Me.pnlVorlagenfeld.Enabled = False
        Me.TabControl1.TabPages(2).Enabled = False

        Me.CDokumentwirdretourniert.Enabled = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Fields_Dokumentwirderstellt Method

Private Sub Fields_Dokumentwirderstellt()

Source code

[Visual Basic]
    Private Sub Fields_Dokumentwirderstellt()
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = True
        Me.cUnterschriftrechts.Enabled = True
        Me.CDokumentersetzen.Enabled = True
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = True
        Me.cFunktion_zuweisen.Enabled = True
        Me.cbBearbeitungszeit.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cbAbschluss.Enabled = True
        Me.cbInEdokaDB.Enabled = True

        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cidvnative.Enabled = True
        Me.rbEtikette.Enabled = False

        'Default setzen
        If neu Then
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cStatusMutation.Checked = True
            Me.cidvnative.Checked = False
            Me.cbDokartAusgang.SelectedIndex = 1
            Me.cbDokartEingang.SelectedIndex = 1
            Me.cbColdFolder.SelectedIndex = 1
            Me.cbArchiv.SelectedIndex = 1
            Me.cbobnr.SelectedIndex = 1
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cZuVercolden.Checked = False
            Me.cZuRetournieren.Checked = False
            Me.cEmailVersand.Checked = False
            Me.cFunktion_zuweisen.Checked = False

            Me.cZuVercolden.Enabled = True
            Me.cEingangErsetztAusgang.Enabled = False
            Me.cbArchiv.Enabled = False
            Me.cbDokartAusgang.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Fields_Dokumentwirderstellt_Ams Method

Private Sub Fields_Dokumentwirderstellt_Ams()

Source code

[Visual Basic]
    Private Sub Fields_Dokumentwirderstellt_Ams()
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = True
        Me.cUnterschriftrechts.Enabled = True
        Me.CDokumentersetzen.Enabled = True
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = True
        Me.cFunktion_zuweisen.Enabled = True
        Me.cbBearbeitungszeit.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cbAbschluss.Enabled = True
        Me.cbInEdokaDB.Enabled = True
        Me.rbEtikette.Enabled = False

        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True

        'Default setzen
        If neu Then
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cStatusMutation.Checked = True
            Me.cidvnative.Checked = False
            Me.cbDokartAusgang.SelectedIndex = 1
            Me.cbDokartEingang.SelectedIndex = 1
            Me.cbColdFolder.SelectedIndex = 1
            Me.cbobnr.SelectedIndex = 1
            Me.cbArchiv.SelectedIndex = 1
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cZuVercolden.Checked = False
            Me.cZuRetournieren.Checked = False
            Me.cEmailVersand.Checked = False
            Me.cFunktion_zuweisen.Checked = False

            Me.cZuVercolden.Enabled = True
            Me.cEingangErsetztAusgang.Enabled = False
            Me.cbArchiv.Enabled = False
            Me.cbDokartAusgang.Enabled = False
        End If
        Me.cidvnative.CheckState = CheckState.Unchecked
        Me.cidvnative.Enabled = False
        '       If Me.cUnterschriftlinks.CheckState = CheckState.Unchecked Then
        '      Me.cUnterschriftlinks.CheckState = CheckState.Checked
        '     End If
        '    If Me.cUnterschriftrechts.CheckState = CheckState.Unchecked Then
        '       Me.cUnterschriftrechts.CheckState = CheckState.Checked
        '  End If
        ' If Me.CDokumentersetzen.CheckState = CheckState.Unchecked Then
        '    Me.CDokumentersetzen.CheckState = CheckState.Unchecked
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.FormValuecbOfficeVorlage_SelectedIndexChanged Method

Private Sub FormValuecbOfficeVorlage_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbOfficeVorlage.SelectedIndexChanged, _
   cbDokartAusgang.SelectedIndexChanged, _
   cbDokartEingang.SelectedIndexChanged, _
   cbColdFolder.SelectedIndexChanged, _
   cbArchiv.SelectedIndexChanged, _
   cbBearbeitungszeit.SelectedValueChanged, _
   cbMonierung.SelectedValueChanged, _
   cbAbschluss.SelectedValueChanged, _
   cbInEdokaDB.SelectedValueChanged, _
   cbAufbewahrungelektronisch.SelectedValueChanged, _
   cbAufbewahrungphysisch.SelectedValueChanged, _
   TxtDokumentartErstellung.TextChanged, _
   TxtDokumentartHost.TextChanged, _
   TxtDokumentartKundendossier.TextChanged, _
   TxTDokumentartRetournierung.TextChanged, _
   TxTBeschreibung.TextChanged, _
   TxTBezeichnung.TextChanged, _
   cAMSDokument.Click, _
   CDokumentwirdretourniert.Click, _
   cDokumentwirderstellt.Click, _
   cEingangErsetztAusgang.Click, _
   cHostDokument.Click, _
   cNichtgeloescht.Click, _
   cStatusMutation.Click, _
   cUnterschriftlinks.Click, _
   cUnterschriftrechts.Click, _
   cVertraulich.Click, _
   cWirdImportiert.Click, _
   cZuRetournieren.Click, _
   cZuVercolden.Click, _
   txthostdokumenttyp.TextChanged, _
   cbVertrag.CheckedChanged, _
   cidvnative.CheckedChanged, _
   cFunktion_zuweisen.CheckedChanged, _
   cbobnr.SelectedIndexChanged, _
   cbedingtretournierbar.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FormValuecbOfficeVorlage_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbOfficeVorlage.SelectedIndexChanged, cbDokartAusgang.SelectedIndexChanged, cbDokartEingang.SelectedIndexChanged, cbColdFolder.SelectedIndexChanged, cbArchiv.SelectedIndexChanged, cbBearbeitungszeit.SelectedValueChanged, cbMonierung.SelectedValueChanged, cbAbschluss.SelectedValueChanged, cbInEdokaDB.SelectedValueChanged, cbAufbewahrungelektronisch.SelectedValueChanged, cbAufbewahrungphysisch.SelectedValueChanged, TxtDokumentartErstellung.TextChanged, TxtDokumentartHost.TextChanged, TxtDokumentartKundendossier.TextChanged, TxTDokumentartRetournierung.TextChanged, TxTBeschreibung.TextChanged, TxTBezeichnung.TextChanged, cAMSDokument.Click, CDokumentwirdretourniert.Click, cDokumentwirderstellt.Click, cEingangErsetztAusgang.Click, cHostDokument.Click, cNichtgeloescht.Click, cStatusMutation.Click, cUnterschriftlinks.Click, cUnterschriftrechts.Click, cVertraulich.Click, cWirdImportiert.Click, cZuRetournieren.Click, cZuVercolden.Click, txthostdokumenttyp.TextChanged, cbVertrag.CheckedChanged, cidvnative.CheckedChanged, cFunktion_zuweisen.CheckedChanged, cbobnr.SelectedIndexChanged, cbedingtretournierbar.CheckedChanged
        DataChanged = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_get_dokumenttyp_bedingt"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Handle_StrukturRadiobuttons Method

Private Sub Handle_StrukturRadiobuttons( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBKundendossier.CheckedChanged, _
   RBHost.CheckedChanged, _
   RBErstellung.CheckedChanged, _
   RBEingang.CheckedChanged, _
   RBGesamt.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Handle_StrukturRadiobuttons(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBKundendossier.CheckedChanged, RBHost.CheckedChanged, RBErstellung.CheckedChanged, RBEingang.CheckedChanged, RBGesamt.CheckedChanged
        Me.TVStruktur.Visible = False
        If Me.RBKundendossier.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 2)
            Me.TVStruktur.ExpandAll()
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartKundendossier.Text, 1)
        End If
        If Me.RBHost.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 3)
            Me.TVStruktur.ExpandAll()
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartHost.Text, 1)
        End If
        If Me.RBErstellung.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 4)
            Me.TVStruktur.ExpandAll()
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartErstellung.Text, 1)
        End If
        If Me.RBEingang.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 8)
            Me.TVStruktur.ExpandAll()
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxTDokumentartRetournierung.Text, 1)
        End If
        If Me.RBGesamt.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 1)
            Me.TVStruktur.ExpandAll()
            If CType(Me.TxtDokumentartGesamt.Text, Integer) <> 0 Then
                DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartGesamt.Text, 1)
            End If
            If CType(Me.TxtDokumentartKundendossier.Text, Integer) <> 0 Then
                DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartKundendossier.Text, 1)
            End If
            If CType(Me.TxtDokumentartHost.Text, Integer) <> 0 Then
                DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartHost.Text, 1)
            End If
        End If
        If Me.RBEinzeldokumente.Checked Then
            dokumentart.LoadTreeMenu(Me.TVStruktur, 147)
            Me.TVStruktur.ExpandAll()
            DivFnkt.Searchnode(Me.TVStruktur, Me.txtDokumentartEinzeldokument.Text, 1)
        End If
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainDokumenttypDetail))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines8 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton8 = New System.Windows.Forms.ToolBarButton()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.cidvnative = New System.Windows.Forms.CheckBox()
        Me.txtDokumentstatus_barcode = New System.Windows.Forms.TextBox()
        Me.txtDokumentstatus = New System.Windows.Forms.TextBox()
        Me.cAktiv = New System.Windows.Forms.CheckBox()
        Me.TxtDokumentartGesamt = New System.Windows.Forms.TextBox()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.cbedingtretournierbar = New System.Windows.Forms.CheckBox()
        Me.CDokumentwirdretourniert = New System.Windows.Forms.CheckBox()
        Me.cWirdImportiert = New System.Windows.Forms.CheckBox()
        Me.cDokumentwirderstellt = New System.Windows.Forms.CheckBox()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.txthostdokumenttyp = New System.Windows.Forms.TextBox()
        Me.cHostDokument = New System.Windows.Forms.CheckBox()
        Me.cAMSDokument = New System.Windows.Forms.CheckBox()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.cbprozessverwendung = New System.Windows.Forms.ComboBox()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.cbprozesserstellung = New System.Windows.Forms.ComboBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.TxTDokumentartRetournierung = New System.Windows.Forms.TextBox()
        Me.TxtDokumentartErstellung = New System.Windows.Forms.TextBox()
        Me.TxtDokumentartHost = New System.Windows.Forms.TextBox()
        Me.TxtDokumentartKundendossier = New System.Windows.Forms.TextBox()
        Me.Dokumenttypnr = New System.Windows.Forms.Label()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.cbtagebedr = New System.Windows.Forms.ComboBox()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.cbAufbewahrungphysisch = New System.Windows.Forms.ComboBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.cbAufbewahrungelektronisch = New System.Windows.Forms.ComboBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.cbInEdokaDB = New System.Windows.Forms.ComboBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.cbAbschluss = New System.Windows.Forms.ComboBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.cbMonierung = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.cbBearbeitungszeit = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.cbKDE = New System.Windows.Forms.CheckBox()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.cbVertrag = New System.Windows.Forms.CheckBox()
        Me.cFunktion_zuweisen = New System.Windows.Forms.CheckBox()
        Me.cEmailVersand = New System.Windows.Forms.CheckBox()
        Me.CDokumentersetzen = New System.Windows.Forms.CheckBox()
        Me.cUnterschriftrechts = New System.Windows.Forms.CheckBox()
        Me.cUnterschriftlinks = New System.Windows.Forms.CheckBox()
        Me.cVertraulich = New System.Windows.Forms.CheckBox()
        Me.cNichtgeloescht = New System.Windows.Forms.CheckBox()
        Me.cStatusMutation = New System.Windows.Forms.CheckBox()
        Me.cbAnzeige = New System.Windows.Forms.CheckBox()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.cbbedingteretournierung = New System.Windows.Forms.ComboBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.btnselobnr = New System.Windows.Forms.Button()
        Me.cbobnr = New System.Windows.Forms.ComboBox()
        Me.btnSelDokumentartEingang = New System.Windows.Forms.Button()
        Me.btnSelDokumentartAusgang = New System.Windows.Forms.Button()
        Me.btnSelColdfolder = New System.Windows.Forms.Button()
        Me.btnSelPhysischeAblage = New System.Windows.Forms.Button()
        Me.cbArchiv = New System.Windows.Forms.ComboBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.cbColdFolder = New System.Windows.Forms.ComboBox()
        Me.cEingangErsetztAusgang = New System.Windows.Forms.CheckBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.cbDokartEingang = New System.Windows.Forms.ComboBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.cbDokartAusgang = New System.Windows.Forms.ComboBox()
        Me.cZuRetournieren = New System.Windows.Forms.CheckBox()
        Me.cZuVercolden = New System.Windows.Forms.CheckBox()
        Me.Grp1 = New System.Windows.Forms.GroupBox()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.cbOwner = New System.Windows.Forms.ComboBox()
        Me.btnSelOfficeVorlage = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TxTBeschreibung = New System.Windows.Forms.TextBox()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.BeschrausOV = New System.Windows.Forms.MenuItem()
        Me.TxTBezeichnung = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbOfficeVorlage = New System.Windows.Forms.ComboBox()
        Me.txtDokumentartEinzeldokument = New System.Windows.Forms.TextBox()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabStruktur = New System.Windows.Forms.TabPage()
        Me.TVStruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokZuordnungauheben = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.RBEinzeldokumente = New System.Windows.Forms.RadioButton()
        Me.RBGesamt = New System.Windows.Forms.RadioButton()
        Me.RBEingang = New System.Windows.Forms.RadioButton()
        Me.RBHost = New System.Windows.Forms.RadioButton()
        Me.RBErstellung = New System.Windows.Forms.RadioButton()
        Me.RBKundendossier = New System.Windows.Forms.RadioButton()
        Me.TabStatusreihenfolge = New System.Windows.Forms.TabPage()
        Me.rbEtikette = New System.Windows.Forms.RadioButton()
        Me.rbDokStatusStandard = New System.Windows.Forms.RadioButton()
        Me.BtnSaveRollen = New System.Windows.Forms.Button()
        Me.btnNeueRolle = New System.Windows.Forms.Button()
        Me.DokumentstatusRolle_Liste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.btnsave = New System.Windows.Forms.Button()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.cbStatustyp = New System.Windows.Forms.ComboBox()
        Me.Statuslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.Aufhebungliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.indexmutationliste = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.InfomeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabDokumentfelder = New System.Windows.Forms.TabPage()
        Me.TbSerienbrief = New System.Windows.Forms.TabPage()
        Me.cbsbimport = New System.Windows.Forms.CheckBox()
        Me.cbsbedituser = New System.Windows.Forms.CheckBox()
        Me.cbsbnur = New System.Windows.Forms.CheckBox()
        Me.cbsb = New System.Windows.Forms.CheckBox()
        Me.pnlVorlagenfeld = New System.Windows.Forms.Panel()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.Button9 = New System.Windows.Forms.Button()
        Me.btnVorlagenfeld = New System.Windows.Forms.Button()
        Me.BtnStandard = New System.Windows.Forms.Button()
        Me.btnsavevorlagenfeldlist = New System.Windows.Forms.Button()
        Me.ColdIndexfeldList = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.vorlagenfeldbezeichnunglist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.vorlagenfeldlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlDataAdapter4 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.SqlDataAdapter5 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter6 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand6 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet5 = New System.Data.DataSet()
        Me.DataSet6 = New System.Data.DataSet()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.cbezmut = New System.Windows.Forms.CheckBox()
        Me.Panel1.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.Grp1.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabStruktur.SuspendLayout()
        Me.Panel2.SuspendLayout()
        Me.TabStatusreihenfolge.SuspendLayout()
        CType(Me.DokumentstatusRolle_Liste, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        CType(Me.Aufhebungliste, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.indexmutationliste, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage1.SuspendLayout()
        CType(Me.InfomeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TbSerienbrief.SuspendLayout()
        Me.pnlVorlagenfeld.SuspendLayout()
        Me.Panel3.SuspendLayout()
        CType(Me.ColdIndexfeldList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.vorlagenfeldbezeichnunglist, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.vorlagenfeldlist, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet6, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton3, Me.ToolBarButton2, Me.ToolBarButton4, Me.ToolBarButton5, Me.ToolBarButton6, Me.ToolBarButton7, Me.ToolBarButton8})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(846, 25)
        Me.ToolBar1.TabIndex = 10
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 1
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 5
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 5
        Me.ToolBarButton4.Visible = False
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 9
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 8
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton8
        '
        Me.ToolBarButton8.ImageIndex = 10
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.cidvnative, Me.txtDokumentstatus_barcode, Me.txtDokumentstatus, Me.cAktiv, Me.TxtDokumentartGesamt, Me.GroupBox5, Me.GroupBox4, Me.TxTDokumentartRetournierung, Me.TxtDokumentartErstellung, Me.TxtDokumentartHost, Me.TxtDokumentartKundendossier, Me.Dokumenttypnr, Me.GroupBox3, Me.GroupBox2, Me.GroupBox1, Me.Grp1, Me.txtDokumentartEinzeldokument})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(504, 690)
        Me.Panel1.TabIndex = 13
        '
        'cidvnative
        '
        Me.cidvnative.Location = New System.Drawing.Point(384, 656)
        Me.cidvnative.Name = "cidvnative"
        Me.cidvnative.Size = New System.Drawing.Size(104, 16)
        Me.cidvnative.TabIndex = 27
        Me.cidvnative.Text = "Einzeldokument"
        '
        'txtDokumentstatus_barcode
        '
        Me.txtDokumentstatus_barcode.Location = New System.Drawing.Point(192, 0)
        Me.txtDokumentstatus_barcode.Name = "txtDokumentstatus_barcode"
        Me.txtDokumentstatus_barcode.Size = New System.Drawing.Size(16, 20)
        Me.txtDokumentstatus_barcode.TabIndex = 26
        Me.txtDokumentstatus_barcode.Text = "Retournierung"
        Me.txtDokumentstatus_barcode.Visible = False
        '
        'txtDokumentstatus
        '
        Me.txtDokumentstatus.Location = New System.Drawing.Point(176, 0)
        Me.txtDokumentstatus.Name = "txtDokumentstatus"
        Me.txtDokumentstatus.Size = New System.Drawing.Size(16, 20)
        Me.txtDokumentstatus.TabIndex = 25
        Me.txtDokumentstatus.Text = "Retournierung"
        Me.txtDokumentstatus.Visible = False
        '
        'cAktiv
        '
        Me.cAktiv.Location = New System.Drawing.Point(8, 656)
        Me.cAktiv.Name = "cAktiv"
        Me.cAktiv.Size = New System.Drawing.Size(72, 16)
        Me.cAktiv.TabIndex = 24
        Me.cAktiv.Text = "Aktiv"
        '
        'TxtDokumentartGesamt
        '
        Me.TxtDokumentartGesamt.Location = New System.Drawing.Point(80, 0)
        Me.TxtDokumentartGesamt.Name = "TxtDokumentartGesamt"
        Me.TxtDokumentartGesamt.Size = New System.Drawing.Size(24, 20)
        Me.TxtDokumentartGesamt.TabIndex = 23
        Me.TxtDokumentartGesamt.Text = "Erstellung"
        Me.TxtDokumentartGesamt.Visible = False
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbedingtretournierbar, Me.CDokumentwirdretourniert, Me.cWirdImportiert, Me.cDokumentwirderstellt, Me.Label23, Me.txthostdokumenttyp, Me.cHostDokument, Me.cAMSDokument})
        Me.GroupBox5.Location = New System.Drawing.Point(8, 152)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(488, 80)
        Me.GroupBox5.TabIndex = 1
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Dokument-Modus"
        '
        'cbedingtretournierbar
        '
        Me.cbedingtretournierbar.Location = New System.Drawing.Point(168, 56)
        Me.cbedingtretournierbar.Name = "cbedingtretournierbar"
        Me.cbedingtretournierbar.Size = New System.Drawing.Size(160, 16)
        Me.cbedingtretournierbar.TabIndex = 15
        Me.cbedingtretournierbar.Text = "Bedingt retournierbar"
        '
        'CDokumentwirdretourniert
        '
        Me.CDokumentwirdretourniert.Location = New System.Drawing.Point(16, 57)
        Me.CDokumentwirdretourniert.Name = "CDokumentwirdretourniert"
        Me.CDokumentwirdretourniert.Size = New System.Drawing.Size(160, 16)
        Me.CDokumentwirdretourniert.TabIndex = 5
        Me.CDokumentwirdretourniert.Text = "Retournierung mit Etikette"
        '
        'cWirdImportiert
        '
        Me.cWirdImportiert.Location = New System.Drawing.Point(16, 38)
        Me.cWirdImportiert.Name = "cWirdImportiert"
        Me.cWirdImportiert.Size = New System.Drawing.Size(104, 16)
        Me.cWirdImportiert.TabIndex = 4
        Me.cWirdImportiert.Text = "Wird importiert"
        '
        'cDokumentwirderstellt
        '
        Me.cDokumentwirderstellt.Location = New System.Drawing.Point(16, 16)
        Me.cDokumentwirderstellt.Name = "cDokumentwirderstellt"
        Me.cDokumentwirderstellt.Size = New System.Drawing.Size(136, 24)
        Me.cDokumentwirderstellt.TabIndex = 0
        Me.cDokumentwirderstellt.Text = "Dokument wird erstellt"
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(280, 38)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(32, 23)
        Me.Label23.TabIndex = 14
        Me.Label23.Text = "Typ"
        '
        'txthostdokumenttyp
        '
        Me.txthostdokumenttyp.Enabled = False
        Me.txthostdokumenttyp.Location = New System.Drawing.Point(320, 38)
        Me.txthostdokumenttyp.Name = "txthostdokumenttyp"
        Me.txthostdokumenttyp.Size = New System.Drawing.Size(64, 20)
        Me.txthostdokumenttyp.TabIndex = 3
        Me.txthostdokumenttyp.Text = ""
        '
        'cHostDokument
        '
        Me.cHostDokument.Location = New System.Drawing.Point(168, 38)
        Me.cHostDokument.Name = "cHostDokument"
        Me.cHostDokument.Size = New System.Drawing.Size(112, 16)
        Me.cHostDokument.TabIndex = 2
        Me.cHostDokument.Text = "HOST-Dokument"
        '
        'cAMSDokument
        '
        Me.cAMSDokument.Location = New System.Drawing.Point(168, 16)
        Me.cAMSDokument.Name = "cAMSDokument"
        Me.cAMSDokument.TabIndex = 1
        Me.cAMSDokument.Text = "AMS-Dokument"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.cbprozessverwendung, Me.Label22, Me.cbprozesserstellung, Me.Label21})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 656)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(488, 16)
        Me.GroupBox4.TabIndex = 5
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Prozesse"
        Me.GroupBox4.Visible = False
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(456, 18)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 22
        Me.Button2.Text = "..."
        Me.Button2.Visible = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(208, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 21
        Me.Button1.Text = "..."
        Me.Button1.Visible = False
        '
        'cbprozessverwendung
        '
        Me.cbprozessverwendung.Location = New System.Drawing.Point(320, 18)
        Me.cbprozessverwendung.Name = "cbprozessverwendung"
        Me.cbprozessverwendung.Size = New System.Drawing.Size(136, 21)
        Me.cbprozessverwendung.TabIndex = 3
        Me.cbprozessverwendung.Text = "CBProzessVerwendung"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(248, 21)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(72, 16)
        Me.Label22.TabIndex = 2
        Me.Label22.Text = "Verwendung"
        '
        'cbprozesserstellung
        '
        Me.cbprozesserstellung.Location = New System.Drawing.Point(72, 17)
        Me.cbprozesserstellung.Name = "cbprozesserstellung"
        Me.cbprozesserstellung.Size = New System.Drawing.Size(136, 21)
        Me.cbprozesserstellung.TabIndex = 1
        Me.cbprozesserstellung.Text = "CBProzessErstellung"
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(16, 20)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(56, 16)
        Me.Label21.TabIndex = 0
        Me.Label21.Text = "Erstellung"
        '
        'TxTDokumentartRetournierung
        '
        Me.TxTDokumentartRetournierung.Location = New System.Drawing.Point(136, 0)
        Me.TxTDokumentartRetournierung.Name = "TxTDokumentartRetournierung"
        Me.TxTDokumentartRetournierung.Size = New System.Drawing.Size(16, 20)
        Me.TxTDokumentartRetournierung.TabIndex = 20
        Me.TxTDokumentartRetournierung.Text = "Retournierung"
        Me.TxTDokumentartRetournierung.Visible = False
        '
        'TxtDokumentartErstellung
        '
        Me.TxtDokumentartErstellung.Location = New System.Drawing.Point(112, 0)
        Me.TxtDokumentartErstellung.Name = "TxtDokumentartErstellung"
        Me.TxtDokumentartErstellung.Size = New System.Drawing.Size(16, 20)
        Me.TxtDokumentartErstellung.TabIndex = 19
        Me.TxtDokumentartErstellung.Text = "Erstellung"
        Me.TxtDokumentartErstellung.Visible = False
        '
        'TxtDokumentartHost
        '
        Me.TxtDokumentartHost.Location = New System.Drawing.Point(48, 0)
        Me.TxtDokumentartHost.Name = "TxtDokumentartHost"
        Me.TxtDokumentartHost.Size = New System.Drawing.Size(24, 20)
        Me.TxtDokumentartHost.TabIndex = 18
        Me.TxtDokumentartHost.Text = "Host"
        Me.TxtDokumentartHost.Visible = False
        '
        'TxtDokumentartKundendossier
        '
        Me.TxtDokumentartKundendossier.Location = New System.Drawing.Point(8, 0)
        Me.TxtDokumentartKundendossier.Name = "TxtDokumentartKundendossier"
        Me.TxtDokumentartKundendossier.Size = New System.Drawing.Size(32, 20)
        Me.TxtDokumentartKundendossier.TabIndex = 17
        Me.TxtDokumentartKundendossier.Text = "Kundendossier"
        Me.TxtDokumentartKundendossier.Visible = False
        '
        'Dokumenttypnr
        '
        Me.Dokumenttypnr.Location = New System.Drawing.Point(504, 24)
        Me.Dokumenttypnr.Name = "Dokumenttypnr"
        Me.Dokumenttypnr.Size = New System.Drawing.Size(100, 16)
        Me.Dokumenttypnr.TabIndex = 16
        Me.Dokumenttypnr.Text = "Label20"
        Me.Dokumenttypnr.Visible = False
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label33, Me.Label32, Me.cbtagebedr, Me.Label19, Me.Label18, Me.Label17, Me.Label16, Me.Label15, Me.Label14, Me.Label13, Me.cbAufbewahrungphysisch, Me.Label12, Me.cbAufbewahrungelektronisch, Me.Label11, Me.cbInEdokaDB, Me.Label10, Me.cbAbschluss, Me.Label9, Me.cbMonierung, Me.Label8, Me.cbBearbeitungszeit})
        Me.GroupBox3.Location = New System.Drawing.Point(256, 408)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(240, 248)
        Me.GroupBox3.TabIndex = 4
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Zeiten"
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(192, 176)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(32, 16)
        Me.Label33.TabIndex = 33
        Me.Label33.Text = "Tage"
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(8, 168)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(136, 32)
        Me.Label32.TabIndex = 32
        Me.Label32.Text = "Vernichtung falls nicht retourniert wird nach"
        '
        'cbtagebedr
        '
        Me.cbtagebedr.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbtagebedr.Enabled = False
        Me.cbtagebedr.Location = New System.Drawing.Point(144, 174)
        Me.cbtagebedr.Name = "cbtagebedr"
        Me.cbtagebedr.Size = New System.Drawing.Size(48, 21)
        Me.cbtagebedr.TabIndex = 31
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(192, 24)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(32, 16)
        Me.Label19.TabIndex = 30
        Me.Label19.Text = "Min."
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(192, 144)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(32, 16)
        Me.Label18.TabIndex = 29
        Me.Label18.Text = "Jahre"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(192, 120)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(32, 16)
        Me.Label17.TabIndex = 28
        Me.Label17.Text = "Jahre"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(192, 96)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(32, 16)
        Me.Label16.TabIndex = 27
        Me.Label16.Text = "Mte."
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(192, 72)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(32, 16)
        Me.Label15.TabIndex = 26
        Me.Label15.Text = "Tage"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(192, 48)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(32, 16)
        Me.Label14.TabIndex = 25
        Me.Label14.Text = "Tage"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 144)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(136, 16)
        Me.Label13.TabIndex = 24
        Me.Label13.Text = "Aufbewahrung ph."
        '
        'cbAufbewahrungphysisch
        '
        Me.cbAufbewahrungphysisch.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbAufbewahrungphysisch.Enabled = False
        Me.cbAufbewahrungphysisch.Location = New System.Drawing.Point(144, 144)
        Me.cbAufbewahrungphysisch.Name = "cbAufbewahrungphysisch"
        Me.cbAufbewahrungphysisch.Size = New System.Drawing.Size(48, 21)
        Me.cbAufbewahrungphysisch.TabIndex = 23
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 120)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(136, 16)
        Me.Label12.TabIndex = 22
        Me.Label12.Text = "Aufbewahrung el."
        '
        'cbAufbewahrungelektronisch
        '
        Me.cbAufbewahrungelektronisch.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbAufbewahrungelektronisch.Location = New System.Drawing.Point(144, 120)
        Me.cbAufbewahrungelektronisch.Name = "cbAufbewahrungelektronisch"
        Me.cbAufbewahrungelektronisch.Size = New System.Drawing.Size(48, 21)
        Me.cbAufbewahrungelektronisch.TabIndex = 21
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 96)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(136, 16)
        Me.Label11.TabIndex = 20
        Me.Label11.Text = "in EDOKA-Datenbank"
        '
        'cbInEdokaDB
        '
        Me.cbInEdokaDB.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbInEdokaDB.Location = New System.Drawing.Point(144, 96)
        Me.cbInEdokaDB.Name = "cbInEdokaDB"
        Me.cbInEdokaDB.Size = New System.Drawing.Size(48, 21)
        Me.cbInEdokaDB.TabIndex = 19
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 72)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(136, 16)
        Me.Label10.TabIndex = 18
        Me.Label10.Text = "Bearbeitung n. Abschluss"
        '
        'cbAbschluss
        '
        Me.cbAbschluss.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbAbschluss.Location = New System.Drawing.Point(144, 72)
        Me.cbAbschluss.Name = "cbAbschluss"
        Me.cbAbschluss.Size = New System.Drawing.Size(48, 21)
        Me.cbAbschluss.TabIndex = 17
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(8, 48)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(136, 16)
        Me.Label9.TabIndex = 16
        Me.Label9.Text = "Monierung in Tagen."
        '
        'cbMonierung
        '
        Me.cbMonierung.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbMonierung.Enabled = False
        Me.cbMonierung.Location = New System.Drawing.Point(144, 48)
        Me.cbMonierung.Name = "cbMonierung"
        Me.cbMonierung.Size = New System.Drawing.Size(48, 21)
        Me.cbMonierung.TabIndex = 15
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 24)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(136, 16)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Bearbeitungszeit in Min."
        '
        'cbBearbeitungszeit
        '
        Me.cbBearbeitungszeit.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbBearbeitungszeit.Location = New System.Drawing.Point(144, 24)
        Me.cbBearbeitungszeit.Name = "cbBearbeitungszeit"
        Me.cbBearbeitungszeit.Size = New System.Drawing.Size(48, 21)
        Me.cbBearbeitungszeit.TabIndex = 13
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbAnzeige, Me.cbezmut, Me.cbKDE, Me.Label30, Me.cbVertrag, Me.cFunktion_zuweisen, Me.cEmailVersand, Me.CDokumentersetzen, Me.cUnterschriftrechts, Me.cUnterschriftlinks, Me.cVertraulich, Me.cNichtgeloescht, Me.cStatusMutation})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 408)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(240, 248)
        Me.GroupBox2.TabIndex = 3
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Diverses"
        '
        'cbKDE
        '
        Me.cbKDE.Location = New System.Drawing.Point(16, 192)
        Me.cbKDE.Name = "cbKDE"
        Me.cbKDE.Size = New System.Drawing.Size(216, 24)
        Me.cbKDE.TabIndex = 16
        Me.cbKDE.Text = "Ablage im elektr. Banklagernd-Dossier"
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(32, 32)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(192, 24)
        Me.Label30.TabIndex = 11
        Me.Label30.Text = "(Gesetzliche Aufbewahrungsfrist ab Status 'aufgehoben')"
        '
        'cbVertrag
        '
        Me.cbVertrag.Location = New System.Drawing.Point(16, 13)
        Me.cbVertrag.Name = "cbVertrag"
        Me.cbVertrag.Size = New System.Drawing.Size(216, 24)
        Me.cbVertrag.TabIndex = 10
        Me.cbVertrag.Text = "Dokument hat Gültigkeit"
        '
        'cFunktion_zuweisen
        '
        Me.cFunktion_zuweisen.BackColor = System.Drawing.Color.Transparent
        Me.cFunktion_zuweisen.Location = New System.Drawing.Point(16, 178)
        Me.cFunktion_zuweisen.Name = "cFunktion_zuweisen"
        Me.cFunktion_zuweisen.Size = New System.Drawing.Size(224, 19)
        Me.cFunktion_zuweisen.TabIndex = 9
        Me.cFunktion_zuweisen.Text = "Dokumentberechtigungen einschränken"
        '
        'cEmailVersand
        '
        Me.cEmailVersand.Location = New System.Drawing.Point(16, 163)
        Me.cEmailVersand.Name = "cEmailVersand"
        Me.cEmailVersand.Size = New System.Drawing.Size(216, 19)
        Me.cEmailVersand.TabIndex = 8
        Me.cEmailVersand.Text = "E-Mail-Versand möglich"
        '
        'CDokumentersetzen
        '
        Me.CDokumentersetzen.Location = New System.Drawing.Point(16, 145)
        Me.CDokumentersetzen.Name = "CDokumentersetzen"
        Me.CDokumentersetzen.Size = New System.Drawing.Size(216, 24)
        Me.CDokumentersetzen.TabIndex = 7
        Me.CDokumentersetzen.Text = "Dokumente ersetzen möglich"
        '
        'cUnterschriftrechts
        '
        Me.cUnterschriftrechts.Location = New System.Drawing.Point(16, 128)
        Me.cUnterschriftrechts.Name = "cUnterschriftrechts"
        Me.cUnterschriftrechts.Size = New System.Drawing.Size(216, 24)
        Me.cUnterschriftrechts.TabIndex = 6
        Me.cUnterschriftrechts.Text = "Unterschrift rechts"
        '
        'cUnterschriftlinks
        '
        Me.cUnterschriftlinks.Location = New System.Drawing.Point(16, 111)
        Me.cUnterschriftlinks.Name = "cUnterschriftlinks"
        Me.cUnterschriftlinks.Size = New System.Drawing.Size(216, 24)
        Me.cUnterschriftlinks.TabIndex = 5
        Me.cUnterschriftlinks.Text = "Unterschrift links"
        '
        'cVertraulich
        '
        Me.cVertraulich.Location = New System.Drawing.Point(16, 94)
        Me.cVertraulich.Name = "cVertraulich"
        Me.cVertraulich.Size = New System.Drawing.Size(216, 24)
        Me.cVertraulich.TabIndex = 4
        Me.cVertraulich.Text = "Vertraulich"
        '
        'cNichtgeloescht
        '
        Me.cNichtgeloescht.Location = New System.Drawing.Point(16, 77)
        Me.cNichtgeloescht.Name = "cNichtgeloescht"
        Me.cNichtgeloescht.Size = New System.Drawing.Size(216, 24)
        Me.cNichtgeloescht.TabIndex = 3
        Me.cNichtgeloescht.Text = "Wird bei Reorganisation nicht gelöscht"
        '
        'cStatusMutation
        '
        Me.cStatusMutation.Location = New System.Drawing.Point(16, 59)
        Me.cStatusMutation.Name = "cStatusMutation"
        Me.cStatusMutation.Size = New System.Drawing.Size(216, 24)
        Me.cStatusMutation.TabIndex = 2
        Me.cStatusMutation.Text = "Statusmutation bei Partner-Saldierung"
        '
        'cbAnzeige
        '
        Me.cbAnzeige.Location = New System.Drawing.Point(16, 210)
        Me.cbAnzeige.Name = "cbAnzeige"
        Me.cbAnzeige.Size = New System.Drawing.Size(216, 24)
        Me.cbAnzeige.TabIndex = 17
        Me.cbAnzeige.Text = "Anzeige in der Vorlagenauswahl"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label31, Me.cbbedingteretournierung, Me.Label27, Me.btnselobnr, Me.cbobnr, Me.btnSelDokumentartEingang, Me.btnSelDokumentartAusgang, Me.btnSelColdfolder, Me.btnSelPhysischeAblage, Me.cbArchiv, Me.Label7, Me.Label6, Me.cbColdFolder, Me.cEingangErsetztAusgang, Me.Label5, Me.cbDokartEingang, Me.Label4, Me.cbDokartAusgang, Me.cZuRetournieren, Me.cZuVercolden})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(488, 176)
        Me.GroupBox1.TabIndex = 2
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Archivierung"
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(16, 100)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(176, 29)
        Me.Label31.TabIndex = 22
        Me.Label31.Text = "Löst aus als bedingt retournierbar"
        '
        'cbbedingteretournierung
        '
        Me.cbbedingteretournierung.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbbedingteretournierung.Enabled = False
        Me.cbbedingteretournierung.Location = New System.Drawing.Point(192, 100)
        Me.cbbedingteretournierung.Name = "cbbedingteretournierung"
        Me.cbbedingteretournierung.Size = New System.Drawing.Size(264, 21)
        Me.cbbedingteretournierung.TabIndex = 23
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(128, 152)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(128, 16)
        Me.Label27.TabIndex = 21
        Me.Label27.Text = "Prozess"
        Me.Label27.Visible = False
        '
        'btnselobnr
        '
        Me.btnselobnr.Enabled = False
        Me.btnselobnr.Location = New System.Drawing.Point(456, 152)
        Me.btnselobnr.Name = "btnselobnr"
        Me.btnselobnr.Size = New System.Drawing.Size(24, 23)
        Me.btnselobnr.TabIndex = 20
        Me.btnselobnr.Text = "..."
        Me.btnselobnr.Visible = False
        '
        'cbobnr
        '
        Me.cbobnr.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbobnr.Enabled = False
        Me.cbobnr.Location = New System.Drawing.Point(256, 152)
        Me.cbobnr.Name = "cbobnr"
        Me.cbobnr.Size = New System.Drawing.Size(200, 21)
        Me.cbobnr.TabIndex = 19
        Me.cbobnr.Visible = False
        '
        'btnSelDokumentartEingang
        '
        Me.btnSelDokumentartEingang.Enabled = False
        Me.btnSelDokumentartEingang.Location = New System.Drawing.Point(456, 48)
        Me.btnSelDokumentartEingang.Name = "btnSelDokumentartEingang"
        Me.btnSelDokumentartEingang.Size = New System.Drawing.Size(24, 23)
        Me.btnSelDokumentartEingang.TabIndex = 6
        Me.btnSelDokumentartEingang.Text = "..."
        '
        'btnSelDokumentartAusgang
        '
        Me.btnSelDokumentartAusgang.Enabled = False
        Me.btnSelDokumentartAusgang.Location = New System.Drawing.Point(456, 24)
        Me.btnSelDokumentartAusgang.Name = "btnSelDokumentartAusgang"
        Me.btnSelDokumentartAusgang.Size = New System.Drawing.Size(24, 23)
        Me.btnSelDokumentartAusgang.TabIndex = 3
        Me.btnSelDokumentartAusgang.Text = "..."
        '
        'btnSelColdfolder
        '
        Me.btnSelColdfolder.Enabled = False
        Me.btnSelColdfolder.Location = New System.Drawing.Point(456, 128)
        Me.btnSelColdfolder.Name = "btnSelColdfolder"
        Me.btnSelColdfolder.Size = New System.Drawing.Size(24, 23)
        Me.btnSelColdfolder.TabIndex = 9
        Me.btnSelColdfolder.Text = "..."
        Me.btnSelColdfolder.Visible = False
        '
        'btnSelPhysischeAblage
        '
        Me.btnSelPhysischeAblage.Enabled = False
        Me.btnSelPhysischeAblage.Location = New System.Drawing.Point(456, 72)
        Me.btnSelPhysischeAblage.Name = "btnSelPhysischeAblage"
        Me.btnSelPhysischeAblage.Size = New System.Drawing.Size(24, 23)
        Me.btnSelPhysischeAblage.TabIndex = 11
        Me.btnSelPhysischeAblage.Text = "..."
        '
        'cbArchiv
        '
        Me.cbArchiv.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbArchiv.Enabled = False
        Me.cbArchiv.Location = New System.Drawing.Point(256, 72)
        Me.cbArchiv.Name = "cbArchiv"
        Me.cbArchiv.Size = New System.Drawing.Size(200, 21)
        Me.cbArchiv.TabIndex = 10
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(128, 72)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(104, 16)
        Me.Label7.TabIndex = 18
        Me.Label7.Text = "Physisches Archiv"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(128, 128)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(128, 16)
        Me.Label6.TabIndex = 17
        Me.Label6.Text = "COLD-Ordner"
        Me.Label6.Visible = False
        '
        'cbColdFolder
        '
        Me.cbColdFolder.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbColdFolder.Enabled = False
        Me.cbColdFolder.Location = New System.Drawing.Point(256, 128)
        Me.cbColdFolder.Name = "cbColdFolder"
        Me.cbColdFolder.Size = New System.Drawing.Size(200, 21)
        Me.cbColdFolder.TabIndex = 8
        Me.cbColdFolder.Visible = False
        '
        'cEingangErsetztAusgang
        '
        Me.cEingangErsetztAusgang.Enabled = False
        Me.cEingangErsetztAusgang.Location = New System.Drawing.Point(16, 64)
        Me.cEingangErsetztAusgang.Name = "cEingangErsetztAusgang"
        Me.cEingangErsetztAusgang.Size = New System.Drawing.Size(104, 40)
        Me.cEingangErsetztAusgang.TabIndex = 7
        Me.cEingangErsetztAusgang.Text = "Eingang ersetzt Ausgang"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(128, 48)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(128, 16)
        Me.Label5.TabIndex = 14
        Me.Label5.Text = "DokArt COLD Eingang"
        '
        'cbDokartEingang
        '
        Me.cbDokartEingang.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbDokartEingang.Enabled = False
        Me.cbDokartEingang.Location = New System.Drawing.Point(256, 48)
        Me.cbDokartEingang.Name = "cbDokartEingang"
        Me.cbDokartEingang.Size = New System.Drawing.Size(200, 21)
        Me.cbDokartEingang.TabIndex = 5
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(128, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(128, 16)
        Me.Label4.TabIndex = 12
        Me.Label4.Text = "DokArt COLD Ausgang"
        '
        'cbDokartAusgang
        '
        Me.cbDokartAusgang.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbDokartAusgang.Enabled = False
        Me.cbDokartAusgang.Location = New System.Drawing.Point(256, 24)
        Me.cbDokartAusgang.Name = "cbDokartAusgang"
        Me.cbDokartAusgang.Size = New System.Drawing.Size(200, 21)
        Me.cbDokartAusgang.TabIndex = 1
        '
        'cZuRetournieren
        '
        Me.cZuRetournieren.Enabled = False
        Me.cZuRetournieren.Location = New System.Drawing.Point(16, 43)
        Me.cZuRetournieren.Name = "cZuRetournieren"
        Me.cZuRetournieren.TabIndex = 4
        Me.cZuRetournieren.Text = "zu retournieren"
        '
        'cZuVercolden
        '
        Me.cZuVercolden.Location = New System.Drawing.Point(16, 19)
        Me.cZuVercolden.Name = "cZuVercolden"
        Me.cZuVercolden.TabIndex = 0
        Me.cZuVercolden.Text = "zu vercolden"
        '
        'Grp1
        '
        Me.Grp1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label26, Me.cbOwner, Me.btnSelOfficeVorlage, Me.Label3, Me.Label2, Me.TxTBeschreibung, Me.TxTBezeichnung, Me.Label1, Me.cbOfficeVorlage})
        Me.Grp1.Location = New System.Drawing.Point(8, 24)
        Me.Grp1.Name = "Grp1"
        Me.Grp1.Size = New System.Drawing.Size(488, 128)
        Me.Grp1.TabIndex = 0
        Me.Grp1.TabStop = False
        Me.Grp1.Text = "Vorlage"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(16, 96)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(100, 16)
        Me.Label26.TabIndex = 14
        Me.Label26.Text = "Owner"
        '
        'cbOwner
        '
        Me.cbOwner.Location = New System.Drawing.Point(120, 96)
        Me.cbOwner.Name = "cbOwner"
        Me.cbOwner.Size = New System.Drawing.Size(336, 21)
        Me.cbOwner.TabIndex = 13
        '
        'btnSelOfficeVorlage
        '
        Me.btnSelOfficeVorlage.Location = New System.Drawing.Point(456, 24)
        Me.btnSelOfficeVorlage.Name = "btnSelOfficeVorlage"
        Me.btnSelOfficeVorlage.Size = New System.Drawing.Size(24, 23)
        Me.btnSelOfficeVorlage.TabIndex = 12
        Me.btnSelOfficeVorlage.Text = "..."
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(100, 16)
        Me.Label3.TabIndex = 11
        Me.Label3.Text = "Beschreibung"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(100, 16)
        Me.Label2.TabIndex = 10
        Me.Label2.Text = "Bezeichnung"
        '
        'TxTBeschreibung
        '
        Me.TxTBeschreibung.ContextMenu = Me.ContextMenu3
        Me.TxTBeschreibung.Location = New System.Drawing.Point(120, 72)
        Me.TxTBeschreibung.Multiline = True
        Me.TxTBeschreibung.Name = "TxTBeschreibung"
        Me.TxTBeschreibung.Size = New System.Drawing.Size(336, 24)
        Me.TxTBeschreibung.TabIndex = 9
        Me.TxTBeschreibung.Text = ""
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.BeschrausOV})
        '
        'BeschrausOV
        '
        Me.BeschrausOV.Index = 0
        Me.BeschrausOV.Text = "Beschreibung aus Officevorlage übernehmen"
        '
        'TxTBezeichnung
        '
        Me.TxTBezeichnung.Location = New System.Drawing.Point(120, 48)
        Me.TxTBezeichnung.Name = "TxTBezeichnung"
        Me.TxTBezeichnung.Size = New System.Drawing.Size(336, 20)
        Me.TxTBezeichnung.TabIndex = 8
        Me.TxTBezeichnung.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 7
        Me.Label1.Text = "Office-Vorlage"
        '
        'cbOfficeVorlage
        '
        Me.cbOfficeVorlage.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbOfficeVorlage.Location = New System.Drawing.Point(120, 24)
        Me.cbOfficeVorlage.Name = "cbOfficeVorlage"
        Me.cbOfficeVorlage.Size = New System.Drawing.Size(336, 21)
        Me.cbOfficeVorlage.TabIndex = 6
        '
        'txtDokumentartEinzeldokument
        '
        Me.txtDokumentartEinzeldokument.Location = New System.Drawing.Point(216, 0)
        Me.txtDokumentartEinzeldokument.Name = "txtDokumentartEinzeldokument"
        Me.txtDokumentartEinzeldokument.Size = New System.Drawing.Size(16, 20)
        Me.txtDokumentartEinzeldokument.TabIndex = 29
        Me.txtDokumentartEinzeldokument.Text = ""
        Me.txtDokumentartEinzeldokument.Visible = False
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabStruktur, Me.TabStatusreihenfolge, Me.TabPage2, Me.TabPage1, Me.TabDokumentfelder, Me.TbSerienbrief})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Location = New System.Drawing.Point(504, 25)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.RightToLeft = System.Windows.Forms.RightToLeft.No
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(342, 690)
        Me.TabControl1.TabIndex = 14
        '
        'TabStruktur
        '
        Me.TabStruktur.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.TabStruktur.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVStruktur, Me.Panel2})
        Me.TabStruktur.Location = New System.Drawing.Point(4, 22)
        Me.TabStruktur.Name = "TabStruktur"
        Me.TabStruktur.Size = New System.Drawing.Size(334, 664)
        Me.TabStruktur.TabIndex = 0
        Me.TabStruktur.Text = "Struktur"
        '
        'TVStruktur
        '
        Me.TVStruktur.ContextMenu = Me.ContextMenu2
        Me.TVStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVStruktur.ImageList = Me.ImageList2
        Me.TVStruktur.Location = New System.Drawing.Point(0, 40)
        Me.TVStruktur.Name = "TVStruktur"
        Me.TVStruktur.Size = New System.Drawing.Size(330, 620)
        Me.TVStruktur.TabIndex = 1
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokZuordnungauheben, Me.MenuItem2, Me.MenuItem4})
        '
        'MnuDokZuordnungauheben
        '
        Me.MnuDokZuordnungauheben.Index = 0
        Me.MnuDokZuordnungauheben.Text = "Zuordnung aufheben"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "-"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 2
        Me.MenuItem4.Text = "Dokumenttypen dieser Struktur"
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel2
        '
        Me.Panel2.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBEinzeldokumente, Me.RBGesamt, Me.RBEingang, Me.RBHost, Me.RBErstellung, Me.RBKundendossier})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(330, 40)
        Me.Panel2.TabIndex = 0
        '
        'RBEinzeldokumente
        '
        Me.RBEinzeldokumente.Location = New System.Drawing.Point(8, 8)
        Me.RBEinzeldokumente.Name = "RBEinzeldokumente"
        Me.RBEinzeldokumente.Size = New System.Drawing.Size(296, 24)
        Me.RBEinzeldokumente.TabIndex = 7
        Me.RBEinzeldokumente.Text = "Einzeldokumente"
        Me.RBEinzeldokumente.Visible = False
        '
        'RBGesamt
        '
        Me.RBGesamt.Location = New System.Drawing.Point(184, 8)
        Me.RBGesamt.Name = "RBGesamt"
        Me.RBGesamt.Size = New System.Drawing.Size(112, 24)
        Me.RBGesamt.TabIndex = 6
        Me.RBGesamt.Text = "gesamte Struktur"
        Me.RBGesamt.Visible = False
        '
        'RBEingang
        '
        Me.RBEingang.Location = New System.Drawing.Point(232, 8)
        Me.RBEingang.Name = "RBEingang"
        Me.RBEingang.Size = New System.Drawing.Size(80, 24)
        Me.RBEingang.TabIndex = 5
        Me.RBEingang.Text = "Eingang"
        Me.RBEingang.Visible = False
        '
        'RBHost
        '
        Me.RBHost.Location = New System.Drawing.Point(104, 8)
        Me.RBHost.Name = "RBHost"
        Me.RBHost.Size = New System.Drawing.Size(56, 24)
        Me.RBHost.TabIndex = 4
        Me.RBHost.Text = "HOST"
        '
        'RBErstellung
        '
        Me.RBErstellung.Location = New System.Drawing.Point(104, 8)
        Me.RBErstellung.Name = "RBErstellung"
        Me.RBErstellung.Size = New System.Drawing.Size(80, 24)
        Me.RBErstellung.TabIndex = 3
        Me.RBErstellung.Text = "Erstellung"
        Me.RBErstellung.Visible = False
        '
        'RBKundendossier
        '
        Me.RBKundendossier.Location = New System.Drawing.Point(8, 8)
        Me.RBKundendossier.Name = "RBKundendossier"
        Me.RBKundendossier.TabIndex = 0
        Me.RBKundendossier.Text = "Kundendossier"
        '
        'TabStatusreihenfolge
        '
        Me.TabStatusreihenfolge.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.TabStatusreihenfolge.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbEtikette, Me.rbDokStatusStandard, Me.BtnSaveRollen, Me.btnNeueRolle, Me.DokumentstatusRolle_Liste, Me.Label24, Me.btnsave, Me.Label20, Me.cbStatustyp, Me.Statuslist})
        Me.TabStatusreihenfolge.Location = New System.Drawing.Point(4, 22)
        Me.TabStatusreihenfolge.Name = "TabStatusreihenfolge"
        Me.TabStatusreihenfolge.Size = New System.Drawing.Size(334, 664)
        Me.TabStatusreihenfolge.TabIndex = 1
        Me.TabStatusreihenfolge.Text = "Statusreihenfolge"
        '
        'rbEtikette
        '
        Me.rbEtikette.Enabled = False
        Me.rbEtikette.Location = New System.Drawing.Point(88, 48)
        Me.rbEtikette.Name = "rbEtikette"
        Me.rbEtikette.Size = New System.Drawing.Size(168, 24)
        Me.rbEtikette.TabIndex = 11
        Me.rbEtikette.Text = "Retournierung mit Etikette"
        '
        'rbDokStatusStandard
        '
        Me.rbDokStatusStandard.Location = New System.Drawing.Point(16, 48)
        Me.rbDokStatusStandard.Name = "rbDokStatusStandard"
        Me.rbDokStatusStandard.Size = New System.Drawing.Size(72, 24)
        Me.rbDokStatusStandard.TabIndex = 10
        Me.rbDokStatusStandard.Text = "Standard"
        '
        'BtnSaveRollen
        '
        Me.BtnSaveRollen.Image = CType(resources.GetObject("BtnSaveRollen.Image"), System.Drawing.Bitmap)
        Me.BtnSaveRollen.ImageIndex = 1
        Me.BtnSaveRollen.ImageList = Me.ImageList1
        Me.BtnSaveRollen.Location = New System.Drawing.Point(296, 320)
        Me.BtnSaveRollen.Name = "BtnSaveRollen"
        Me.BtnSaveRollen.Size = New System.Drawing.Size(24, 24)
        Me.BtnSaveRollen.TabIndex = 9
        '
        'btnNeueRolle
        '
        Me.btnNeueRolle.Image = CType(resources.GetObject("btnNeueRolle.Image"), System.Drawing.Bitmap)
        Me.btnNeueRolle.ImageIndex = 3
        Me.btnNeueRolle.ImageList = Me.ImageList1
        Me.btnNeueRolle.Location = New System.Drawing.Point(272, 320)
        Me.btnNeueRolle.Name = "btnNeueRolle"
        Me.btnNeueRolle.Size = New System.Drawing.Size(24, 24)
        Me.btnNeueRolle.TabIndex = 8
        '
        'DokumentstatusRolle_Liste
        '
        Me.DokumentstatusRolle_Liste.AllowFilter = True
        Me.DokumentstatusRolle_Liste.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentstatusRolle_Liste.AllowSort = False
        Me.DokumentstatusRolle_Liste.AlternatingRows = True
        Me.DokumentstatusRolle_Liste.CaptionHeight = 17
        Me.DokumentstatusRolle_Liste.CollapseColor = System.Drawing.Color.Black
        Me.DokumentstatusRolle_Liste.DataChanged = False
        Me.DokumentstatusRolle_Liste.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DokumentstatusRolle_Liste.ExpandColor = System.Drawing.Color.Black
        Me.DokumentstatusRolle_Liste.FilterBar = True
        Me.DokumentstatusRolle_Liste.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentstatusRolle_Liste.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokumentstatusRolle_Liste.Location = New System.Drawing.Point(8, 352)
        Me.DokumentstatusRolle_Liste.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.HighlightCell
        Me.DokumentstatusRolle_Liste.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokumentstatusRolle_Liste.Name = "DokumentstatusRolle_Liste"
        Me.DokumentstatusRolle_Liste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentstatusRolle_Liste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentstatusRolle_Liste.PreviewInfo.ZoomFactor = 75
        Me.DokumentstatusRolle_Liste.PrintInfo.ShowOptionsDialog = False
        Me.DokumentstatusRolle_Liste.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentstatusRolle_Liste.RowDivider = GridLines1
        Me.DokumentstatusRolle_Liste.RowHeight = 15
        Me.DokumentstatusRolle_Liste.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentstatusRolle_Liste.ScrollTips = False
        Me.DokumentstatusRolle_Liste.Size = New System.Drawing.Size(312, 264)
        Me.DokumentstatusRolle_Liste.TabIndex = 7
        Me.DokumentstatusRolle_Liste.Text = "C1TrueDBGrid1"
        Me.DokumentstatusRolle_Liste.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""HighlightCell"" RecordSelectorWidth" & _
        "=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Cli" & _
        "entRect>0, 0, 308, 260</ClientRect><BorderSide>0</BorderSide><CaptionStyle paren" & _
        "t=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowSty" & _
        "le parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13" & _
        """ /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""St" & _
        "yle12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=" & _
        """HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><Odd" & _
        "RowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelect" & _
        "or"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=" & _
        """Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><St" & _
        "yle parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=" & _
        """Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""He" & _
        "ading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Nor" & _
        "mal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Nor" & _
        "mal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading""" & _
        " me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Ca" & _
        "ption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzS" & _
        "plits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAre" & _
        "a>0, 0, 308, 260</ClientArea></Blob>"
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(8, 328)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(200, 16)
        Me.Label24.TabIndex = 6
        Me.Label24.Text = "Funktion, welche den Status setzen kann"
        '
        'btnsave
        '
        Me.btnsave.Image = CType(resources.GetObject("btnsave.Image"), System.Drawing.Bitmap)
        Me.btnsave.Location = New System.Drawing.Point(296, 40)
        Me.btnsave.Name = "btnsave"
        Me.btnsave.Size = New System.Drawing.Size(24, 24)
        Me.btnsave.TabIndex = 5
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(8, 16)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(56, 23)
        Me.Label20.TabIndex = 4
        Me.Label20.Text = "Statustyp"
        '
        'cbStatustyp
        '
        Me.cbStatustyp.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbStatustyp.Location = New System.Drawing.Point(80, 16)
        Me.cbStatustyp.Name = "cbStatustyp"
        Me.cbStatustyp.Size = New System.Drawing.Size(240, 21)
        Me.cbStatustyp.TabIndex = 3
        '
        'Statuslist
        '
        Me.Statuslist.AllowFilter = True
        Me.Statuslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Statuslist.AllowSort = False
        Me.Statuslist.AlternatingRows = True
        Me.Statuslist.CaptionHeight = 17
        Me.Statuslist.CollapseColor = System.Drawing.Color.Black
        Me.Statuslist.DataChanged = False
        Me.Statuslist.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.Statuslist.ExpandColor = System.Drawing.Color.Black
        Me.Statuslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Statuslist.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.Statuslist.Location = New System.Drawing.Point(8, 72)
        Me.Statuslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.HighlightCell
        Me.Statuslist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.Statuslist.Name = "Statuslist"
        Me.Statuslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Statuslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Statuslist.PreviewInfo.ZoomFactor = 75
        Me.Statuslist.PrintInfo.ShowOptionsDialog = False
        Me.Statuslist.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Statuslist.RowDivider = GridLines2
        Me.Statuslist.RowHeight = 15
        Me.Statuslist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Statuslist.ScrollTips = False
        Me.Statuslist.Size = New System.Drawing.Size(312, 232)
        Me.Statuslist.TabIndex = 0
        Me.Statuslist.Text = "C1TrueDBGrid1"
        Me.Statuslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:ControlLight;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tru" & _
        "e;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Con" & _
        "trol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data>" & _
        "</Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tru" & _
        "e"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeSt" & _
        "yle=""HighlightCell"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollG" & _
        "roup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 308, 228</ClientRect><Borde" & _
        "rSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle pa" & _
        "rent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Filter" & _
        "BarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Styl" & _
        "e3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" m" & _
        "e=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveSty" & _
        "le parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><R" & _
        "ecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=" & _
        """Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBG" & _
        "rid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent" & _
        "=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""He" & _
        "ading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Nor" & _
        "mal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal""" & _
        " me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal" & _
        """ me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Nor" & _
        "mal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSp" & _
        "lits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSel" & _
        "Width>16</DefaultRecSelWidth><ClientArea>0, 0, 308, 228</ClientArea></Blob>"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button7, Me.Button8, Me.Button5, Me.Button6, Me.Label29, Me.Label28, Me.Aufhebungliste, Me.indexmutationliste})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(334, 664)
        Me.TabPage2.TabIndex = 4
        Me.TabPage2.Text = "Nach Abschluss"
        '
        'Button7
        '
        Me.Button7.Image = CType(resources.GetObject("Button7.Image"), System.Drawing.Bitmap)
        Me.Button7.ImageIndex = 1
        Me.Button7.ImageList = Me.ImageList1
        Me.Button7.Location = New System.Drawing.Point(304, 304)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(24, 24)
        Me.Button7.TabIndex = 13
        '
        'Button8
        '
        Me.Button8.Image = CType(resources.GetObject("Button8.Image"), System.Drawing.Bitmap)
        Me.Button8.ImageIndex = 3
        Me.Button8.ImageList = Me.ImageList1
        Me.Button8.Location = New System.Drawing.Point(280, 304)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(24, 24)
        Me.Button8.TabIndex = 12
        '
        'Button5
        '
        Me.Button5.Image = CType(resources.GetObject("Button5.Image"), System.Drawing.Bitmap)
        Me.Button5.ImageIndex = 1
        Me.Button5.ImageList = Me.ImageList1
        Me.Button5.Location = New System.Drawing.Point(304, 32)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(24, 24)
        Me.Button5.TabIndex = 11
        '
        'Button6
        '
        Me.Button6.Image = CType(resources.GetObject("Button6.Image"), System.Drawing.Bitmap)
        Me.Button6.ImageIndex = 3
        Me.Button6.ImageList = Me.ImageList1
        Me.Button6.Location = New System.Drawing.Point(280, 32)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(24, 24)
        Me.Button6.TabIndex = 10
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(8, 304)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(200, 16)
        Me.Label29.TabIndex = 5
        Me.Label29.Text = "Aufhebung/Löschung nach Abschluss"
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(8, 32)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(288, 16)
        Me.Label28.TabIndex = 4
        Me.Label28.Text = "Indexmutation nach Abschluss"
        '
        'Aufhebungliste
        '
        Me.Aufhebungliste.AllowFilter = True
        Me.Aufhebungliste.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Aufhebungliste.AllowSort = False
        Me.Aufhebungliste.AlternatingRows = True
        Me.Aufhebungliste.CaptionHeight = 17
        Me.Aufhebungliste.CollapseColor = System.Drawing.Color.Black
        Me.Aufhebungliste.ContextMenu = Me.ContextMenu4
        Me.Aufhebungliste.DataChanged = False
        Me.Aufhebungliste.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.Aufhebungliste.ExpandColor = System.Drawing.Color.Black
        Me.Aufhebungliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.Aufhebungliste.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.Aufhebungliste.Location = New System.Drawing.Point(8, 328)
        Me.Aufhebungliste.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.HighlightCell
        Me.Aufhebungliste.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.Aufhebungliste.Name = "Aufhebungliste"
        Me.Aufhebungliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Aufhebungliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Aufhebungliste.PreviewInfo.ZoomFactor = 75
        Me.Aufhebungliste.PrintInfo.ShowOptionsDialog = False
        Me.Aufhebungliste.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Aufhebungliste.RowDivider = GridLines3
        Me.Aufhebungliste.RowHeight = 15
        Me.Aufhebungliste.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Aufhebungliste.ScrollTips = False
        Me.Aufhebungliste.Size = New System.Drawing.Size(320, 232)
        Me.Aufhebungliste.TabIndex = 3
        Me.Aufhebungliste.Text = "C1TrueDBGrid1"
        Me.Aufhebungliste.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:ControlLight;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tru" & _
        "e;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Con" & _
        "trol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data>" & _
        "</Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tru" & _
        "e"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeSt" & _
        "yle=""HighlightCell"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollG" & _
        "roup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 316, 228</ClientRect><Borde" & _
        "rSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle pa" & _
        "rent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Filter" & _
        "BarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Styl" & _
        "e3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" m" & _
        "e=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveSty" & _
        "le parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><R" & _
        "ecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=" & _
        """Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBG" & _
        "rid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent" & _
        "=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""He" & _
        "ading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Nor" & _
        "mal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal""" & _
        " me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal" & _
        """ me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Nor" & _
        "mal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSp" & _
        "lits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSel" & _
        "Width>16</DefaultRecSelWidth><ClientArea>0, 0, 316, 228</ClientArea></Blob>"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7, Me.MenuItem8})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Text = "&Neuer Info-Empfänger"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 1
        Me.MenuItem8.Text = "&Info-Empfänger löschen"
        '
        'indexmutationliste
        '
        Me.indexmutationliste.AllowFilter = True
        Me.indexmutationliste.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.indexmutationliste.AllowSort = False
        Me.indexmutationliste.AlternatingRows = True
        Me.indexmutationliste.CaptionHeight = 17
        Me.indexmutationliste.CollapseColor = System.Drawing.Color.Black
        Me.indexmutationliste.ContextMenu = Me.ContextMenu4
        Me.indexmutationliste.DataChanged = False
        Me.indexmutationliste.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.indexmutationliste.ExpandColor = System.Drawing.Color.Black
        Me.indexmutationliste.GroupByCaption = "Drag a column header here to group by that column"
        Me.indexmutationliste.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.indexmutationliste.Location = New System.Drawing.Point(8, 56)
        Me.indexmutationliste.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.HighlightCell
        Me.indexmutationliste.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.indexmutationliste.Name = "indexmutationliste"
        Me.indexmutationliste.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.indexmutationliste.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.indexmutationliste.PreviewInfo.ZoomFactor = 75
        Me.indexmutationliste.PrintInfo.ShowOptionsDialog = False
        Me.indexmutationliste.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.indexmutationliste.RowDivider = GridLines4
        Me.indexmutationliste.RowHeight = 15
        Me.indexmutationliste.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.indexmutationliste.ScrollTips = False
        Me.indexmutationliste.Size = New System.Drawing.Size(320, 232)
        Me.indexmutationliste.TabIndex = 2
        Me.indexmutationliste.Text = "C1TrueDBGrid1"
        Me.indexmutationliste.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:ControlLight;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tru" & _
        "e;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Con" & _
        "trol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data>" & _
        "</Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tru" & _
        "e"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeSt" & _
        "yle=""HighlightCell"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollG" & _
        "roup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 316, 228</ClientRect><Borde" & _
        "rSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle pa" & _
        "rent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Filter" & _
        "BarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Styl" & _
        "e3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" m" & _
        "e=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveSty" & _
        "le parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><R" & _
        "ecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=" & _
        """Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBG" & _
        "rid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent" & _
        "=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""He" & _
        "ading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Nor" & _
        "mal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal""" & _
        " me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal" & _
        """ me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Nor" & _
        "mal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSp" & _
        "lits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSel" & _
        "Width>16</DefaultRecSelWidth><ClientArea>0, 0, 316, 228</ClientArea></Blob>"
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button4, Me.InfomeldungList})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(334, 664)
        Me.TabPage1.TabIndex = 3
        Me.TabPage1.Text = "Informationsmeldungen"
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(8, 16)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(24, 24)
        Me.Button4.TabIndex = 6
        '
        'InfomeldungList
        '
        Me.InfomeldungList.AllowFilter = True
        Me.InfomeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfomeldungList.AllowSort = False
        Me.InfomeldungList.AlternatingRows = True
        Me.InfomeldungList.CaptionHeight = 17
        Me.InfomeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfomeldungList.ContextMenu = Me.ContextMenu4
        Me.InfomeldungList.DataChanged = False
        Me.InfomeldungList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.InfomeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfomeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfomeldungList.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.InfomeldungList.Location = New System.Drawing.Point(8, 40)
        Me.InfomeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.HighlightCell
        Me.InfomeldungList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.InfomeldungList.Name = "InfomeldungList"
        Me.InfomeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfomeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfomeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfomeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfomeldungList.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfomeldungList.RowDivider = GridLines5
        Me.InfomeldungList.RowHeight = 15
        Me.InfomeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfomeldungList.ScrollTips = False
        Me.InfomeldungList.Size = New System.Drawing.Size(320, 232)
        Me.InfomeldungList.TabIndex = 1
        Me.InfomeldungList.Text = "C1TrueDBGrid1"
        Me.InfomeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:ControlLight;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tru" & _
        "e;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Ce" & _
        "nter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data>" & _
        "</Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tru" & _
        "e"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeSt" & _
        "yle=""HighlightCell"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollG" & _
        "roup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 316, 228</ClientRect><Borde" & _
        "rSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle pa" & _
        "rent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Filter" & _
        "BarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Styl" & _
        "e3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" m" & _
        "e=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveSty" & _
        "le parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><R" & _
        "ecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=" & _
        """Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBG" & _
        "rid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent" & _
        "=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""He" & _
        "ading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Nor" & _
        "mal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal""" & _
        " me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal" & _
        """ me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Nor" & _
        "mal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSp" & _
        "lits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSel" & _
        "Width>16</DefaultRecSelWidth><ClientArea>0, 0, 316, 228</ClientArea></Blob>"
        '
        'TabDokumentfelder
        '
        Me.TabDokumentfelder.Location = New System.Drawing.Point(4, 22)
        Me.TabDokumentfelder.Name = "TabDokumentfelder"
        Me.TabDokumentfelder.Size = New System.Drawing.Size(334, 664)
        Me.TabDokumentfelder.TabIndex = 2
        Me.TabDokumentfelder.Text = "Vorlagenfelder"
        '
        'TbSerienbrief
        '
        Me.TbSerienbrief.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbsbimport, Me.cbsbedituser, Me.cbsbnur, Me.cbsb})
        Me.TbSerienbrief.Location = New System.Drawing.Point(4, 22)
        Me.TbSerienbrief.Name = "TbSerienbrief"
        Me.TbSerienbrief.Size = New System.Drawing.Size(334, 664)
        Me.TbSerienbrief.TabIndex = 5
        Me.TbSerienbrief.Text = "Serienbriefe"
        '
        'cbsbimport
        '
        Me.cbsbimport.Enabled = False
        Me.cbsbimport.Location = New System.Drawing.Point(24, 104)
        Me.cbsbimport.Name = "cbsbimport"
        Me.cbsbimport.Size = New System.Drawing.Size(280, 24)
        Me.cbsbimport.TabIndex = 3
        Me.cbsbimport.Text = "Benutzer kann eine eigene Vorlage importieren"
        '
        'cbsbedituser
        '
        Me.cbsbedituser.Enabled = False
        Me.cbsbedituser.Location = New System.Drawing.Point(24, 80)
        Me.cbsbedituser.Name = "cbsbedituser"
        Me.cbsbedituser.Size = New System.Drawing.Size(280, 24)
        Me.cbsbedituser.TabIndex = 2
        Me.cbsbedituser.Text = "Benutzer kann die Serienbrief-Vorlage bearbeiten"
        '
        'cbsbnur
        '
        Me.cbsbnur.Enabled = False
        Me.cbsbnur.Location = New System.Drawing.Point(40, 48)
        Me.cbsbnur.Name = "cbsbnur"
        Me.cbsbnur.Size = New System.Drawing.Size(240, 24)
        Me.cbsbnur.TabIndex = 1
        Me.cbsbnur.Text = "Nur als Serienbriefvorlage"
        '
        'cbsb
        '
        Me.cbsb.Location = New System.Drawing.Point(24, 24)
        Me.cbsb.Name = "cbsb"
        Me.cbsb.Size = New System.Drawing.Size(240, 24)
        Me.cbsb.TabIndex = 0
        Me.cbsb.Text = "Vorlage als Serienbrief-Vorlage"
        '
        'pnlVorlagenfeld
        '
        Me.pnlVorlagenfeld.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.pnlVorlagenfeld.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.ColdIndexfeldList, Me.Button3, Me.Label25, Me.vorlagenfeldbezeichnunglist, Me.vorlagenfeldlist})
        Me.pnlVorlagenfeld.Location = New System.Drawing.Point(8, 48)
        Me.pnlVorlagenfeld.Name = "pnlVorlagenfeld"
        Me.pnlVorlagenfeld.Size = New System.Drawing.Size(840, 664)
        Me.pnlVorlagenfeld.TabIndex = 15
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button9, Me.btnVorlagenfeld, Me.BtnStandard, Me.btnsavevorlagenfeldlist})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(836, 32)
        Me.Panel3.TabIndex = 8
        '
        'Button9
        '
        Me.Button9.Location = New System.Drawing.Point(368, 8)
        Me.Button9.Name = "Button9"
        Me.Button9.Size = New System.Drawing.Size(176, 23)
        Me.Button9.TabIndex = 6
        Me.Button9.Text = "AMS-Vorlgenfelder importieren"
        Me.Button9.Visible = False
        '
        'btnVorlagenfeld
        '
        Me.btnVorlagenfeld.Location = New System.Drawing.Point(176, 8)
        Me.btnVorlagenfeld.Name = "btnVorlagenfeld"
        Me.btnVorlagenfeld.Size = New System.Drawing.Size(136, 23)
        Me.btnVorlagenfeld.TabIndex = 5
        Me.btnVorlagenfeld.Text = "&Vorlagenfeld hinzufügen"
        '
        'BtnStandard
        '
        Me.BtnStandard.Location = New System.Drawing.Point(40, 8)
        Me.BtnStandard.Name = "BtnStandard"
        Me.BtnStandard.Size = New System.Drawing.Size(136, 23)
        Me.BtnStandard.TabIndex = 4
        Me.BtnStandard.Text = "&Standards generieren"
        '
        'btnsavevorlagenfeldlist
        '
        Me.btnsavevorlagenfeldlist.Image = CType(resources.GetObject("btnsavevorlagenfeldlist.Image"), System.Drawing.Bitmap)
        Me.btnsavevorlagenfeldlist.Location = New System.Drawing.Point(8, 8)
        Me.btnsavevorlagenfeldlist.Name = "btnsavevorlagenfeldlist"
        Me.btnsavevorlagenfeldlist.Size = New System.Drawing.Size(24, 23)
        Me.btnsavevorlagenfeldlist.TabIndex = 3
        '
        'ColdIndexfeldList
        '
        Me.ColdIndexfeldList.AllowColMove = True
        Me.ColdIndexfeldList.AllowColSelect = True
        Me.ColdIndexfeldList.AllowFilter = True
        Me.ColdIndexfeldList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdIndexfeldList.AllowSort = True
        Me.ColdIndexfeldList.AlternatingRows = False
        Me.ColdIndexfeldList.CaptionHeight = 17
        Me.ColdIndexfeldList.ColumnCaptionHeight = 17
        Me.ColdIndexfeldList.ColumnFooterHeight = 17
        Me.ColdIndexfeldList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdIndexfeldList.FetchRowStyles = False
        Me.ColdIndexfeldList.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.ColdIndexfeldList.LayoutFileName = ""
        Me.ColdIndexfeldList.LayoutName = ""
        Me.ColdIndexfeldList.LayoutURL = ""
        Me.ColdIndexfeldList.Location = New System.Drawing.Point(624, 24)
        Me.ColdIndexfeldList.Name = "ColdIndexfeldList"
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdIndexfeldList.RowDivider = GridLines6
        Me.ColdIndexfeldList.RowHeight = 15
        Me.ColdIndexfeldList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdIndexfeldList.ScrollTips = False
        Me.ColdIndexfeldList.Size = New System.Drawing.Size(120, 120)
        Me.ColdIndexfeldList.TabIndex = 7
        Me.ColdIndexfeldList.Text = "C1TrueDBDropdown1"
        Me.ColdIndexfeldList.Visible = False
        Me.ColdIndexfeldList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 116, 116</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 116, 116</ClientA" & _
        "rea></Blob>"
        '
        'Button3
        '
        Me.Button3.Image = CType(resources.GetObject("Button3.Image"), System.Drawing.Bitmap)
        Me.Button3.Location = New System.Drawing.Point(8, 520)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(24, 23)
        Me.Button3.TabIndex = 6
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(32, 520)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(112, 23)
        Me.Label25.TabIndex = 5
        Me.Label25.Text = "Feldbezeichnung "
        '
        'vorlagenfeldbezeichnunglist
        '
        Me.vorlagenfeldbezeichnunglist.AllowDrop = True
        Me.vorlagenfeldbezeichnunglist.AllowFilter = False
        Me.vorlagenfeldbezeichnunglist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.vorlagenfeldbezeichnunglist.AllowSort = True
        Me.vorlagenfeldbezeichnunglist.AlternatingRows = True
        Me.vorlagenfeldbezeichnunglist.CaptionHeight = 17
        Me.vorlagenfeldbezeichnunglist.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.vorlagenfeldbezeichnunglist.CollapseColor = System.Drawing.Color.Black
        Me.vorlagenfeldbezeichnunglist.ContextMenu = Me.ContextMenu1
        Me.vorlagenfeldbezeichnunglist.DataChanged = False
        Me.vorlagenfeldbezeichnunglist.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.vorlagenfeldbezeichnunglist.ExpandColor = System.Drawing.Color.Black
        Me.vorlagenfeldbezeichnunglist.FilterBar = True
        Me.vorlagenfeldbezeichnunglist.GroupByCaption = "Drag a column header here to group by that column"
        Me.vorlagenfeldbezeichnunglist.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.vorlagenfeldbezeichnunglist.Location = New System.Drawing.Point(0, 552)
        Me.vorlagenfeldbezeichnunglist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.vorlagenfeldbezeichnunglist.Name = "vorlagenfeldbezeichnunglist"
        Me.vorlagenfeldbezeichnunglist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.vorlagenfeldbezeichnunglist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.vorlagenfeldbezeichnunglist.PreviewInfo.ZoomFactor = 75
        Me.vorlagenfeldbezeichnunglist.PrintInfo.ShowOptionsDialog = False
        Me.vorlagenfeldbezeichnunglist.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.vorlagenfeldbezeichnunglist.RowDivider = GridLines7
        Me.vorlagenfeldbezeichnunglist.RowHeight = 15
        Me.vorlagenfeldbezeichnunglist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.vorlagenfeldbezeichnunglist.ScrollTips = False
        Me.vorlagenfeldbezeichnunglist.Size = New System.Drawing.Size(832, 72)
        Me.vorlagenfeldbezeichnunglist.TabIndex = 4
        Me.vorlagenfeldbezeichnunglist.Text = "VorlagenfeldList"
        Me.vorlagenfeldbezeichnunglist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:ControlLight;}S" & _
        "elected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:" & _
        "InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128" & _
        ";}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText" & _
        ";BackColor:Highlight;}Style9{}OddRow{}RecordSelector{AlignImage:Center;}Heading{" & _
        "Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackC" & _
        "olor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{" & _
        "}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowSt" & _
        "yle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" F" & _
        "ilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 828, 68</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=" & _
        """Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSty" & _
        "le parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Head" & _
        "ingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow""" & _
        " me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle paren" & _
        "t=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style1" & _
        "1"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""S" & _
        "tyle1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" " & _
        "me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""" & _
        "Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Ina" & _
        "ctive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edito" & _
        "r"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenR" & _
        "ow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSel" & _
        "ector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gro" & _
        "up"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>" & _
        "None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 828, 6" & _
        "8</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem3, Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Standards generieren"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Text = "&Vorlagenfeld hinzufügen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 2
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 3
        Me.MenuItem6.Text = "V&orlagenfelder speichern"
        '
        'vorlagenfeldlist
        '
        Me.vorlagenfeldlist.AllowDrop = True
        Me.vorlagenfeldlist.AllowFilter = True
        Me.vorlagenfeldlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.vorlagenfeldlist.AllowSort = True
        Me.vorlagenfeldlist.AlternatingRows = True
        Me.vorlagenfeldlist.CaptionHeight = 17
        Me.vorlagenfeldlist.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.vorlagenfeldlist.CollapseColor = System.Drawing.Color.Black
        Me.vorlagenfeldlist.ContextMenu = Me.ContextMenu1
        Me.vorlagenfeldlist.DataChanged = False
        Me.vorlagenfeldlist.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.vorlagenfeldlist.ExpandColor = System.Drawing.Color.Black
        Me.vorlagenfeldlist.FilterBar = True
        Me.vorlagenfeldlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.vorlagenfeldlist.Images.Add(CType(resources.GetObject("resource.Images7"), System.Drawing.Bitmap))
        Me.vorlagenfeldlist.Location = New System.Drawing.Point(0, 40)
        Me.vorlagenfeldlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.vorlagenfeldlist.Name = "vorlagenfeldlist"
        Me.vorlagenfeldlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.vorlagenfeldlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.vorlagenfeldlist.PreviewInfo.ZoomFactor = 75
        Me.vorlagenfeldlist.PrintInfo.ShowOptionsDialog = False
        Me.vorlagenfeldlist.RecordSelectorWidth = 16
        GridLines8.Color = System.Drawing.Color.DarkGray
        GridLines8.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.vorlagenfeldlist.RowDivider = GridLines8
        Me.vorlagenfeldlist.RowHeight = 15
        Me.vorlagenfeldlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.vorlagenfeldlist.ScrollTips = False
        Me.vorlagenfeldlist.Size = New System.Drawing.Size(832, 472)
        Me.vorlagenfeldlist.TabIndex = 0
        Me.vorlagenfeldlist.Text = "VorlagenfeldList"
        Me.vorlagenfeldlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:ControlLight;}S" & _
        "elected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:" & _
        "InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128" & _
        ";}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText" & _
        ";BackColor:Highlight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading{" & _
        "Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;Alig" & _
        "nVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{" & _
        "}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowSt" & _
        "yle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" F" & _
        "ilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 828, 468</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 828, " & _
        "468</ClientArea></Blob>"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "vorlagenfeld", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("vorlagenfeldnr", "vorlagenfeldnr"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("feldname", "feldname"), New System.Data.Common.DataColumnMapping("beginntextmarke", "beginntextmarke"), New System.Data.Common.DataColumnMapping("endetextmarke", "endetextmarke"), New System.Data.Common.DataColumnMapping("einstiegsmakro", "einstiegsmakro"), New System.Data.Common.DataColumnMapping("ausstiegsmakro", "ausstiegsmakro"), New System.Data.Common.DataColumnMapping("reihenfolge", "reihenfolge"), New System.Data.Common.DataColumnMapping("cold_indexfeld", "cold_indexfeld"), New System.Data.Common.DataColumnMapping("eingabe_zwingend", "eingabe_zwingend"), New System.Data.Common.DataColumnMapping("testdaten", "testdaten"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_vorlagenfeld_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausstiegsmakro", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausstiegsmakro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beginntextmarke", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beginntextmarke", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_indexfeld", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_indexfeld", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_einstiegsmakro", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "einstiegsmakro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_endetextmarke", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "endetextmarke", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_testdaten", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "testdaten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_vorlagenfeld_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldregelnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldname", System.Data.SqlDbType.VarChar, 255, "feldname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beginntextmarke", System.Data.SqlDbType.VarChar, 255, "beginntextmarke"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@endetextmarke", System.Data.SqlDbType.VarChar, 255, "endetextmarke"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@einstiegsmakro", System.Data.SqlDbType.Bit, 1, "einstiegsmakro"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausstiegsmakro", System.Data.SqlDbType.Bit, 1, "ausstiegsmakro"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_indexfeld", System.Data.SqlDbType.Int, 4, "cold_indexfeld"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@testdaten", System.Data.SqlDbType.VarChar, 255, "testdaten"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_vorlagenfeld_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_vorlagenfeld_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldregelnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldname", System.Data.SqlDbType.VarChar, 255, "feldname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beginntextmarke", System.Data.SqlDbType.VarChar, 255, "beginntextmarke"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@endetextmarke", System.Data.SqlDbType.VarChar, 255, "endetextmarke"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@einstiegsmakro", System.Data.SqlDbType.Bit, 1, "einstiegsmakro"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausstiegsmakro", System.Data.SqlDbType.Bit, 1, "ausstiegsmakro"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_indexfeld", System.Data.SqlDbType.Int, 4, "cold_indexfeld"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@testdaten", System.Data.SqlDbType.VarChar, 255, "testdaten"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausstiegsmakro", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausstiegsmakro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beginntextmarke", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beginntextmarke", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_indexfeld", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_indexfeld", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_einstiegsmakro", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "einstiegsmakro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_endetextmarke", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "endetextmarke", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_testdaten", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "testdaten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumentstatus_funktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumentstatus_funktionnr", "dokumentstatus_funktionnr"), New System.Data.Common.DataColumnMapping("dokumentstatusnr", "dokumentstatusnr"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_dokumentstatus_funktion_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus_funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_dokumentstatus_funktion_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection2
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus_funktionnr", System.Data.SqlDbType.Int, 4, "dokumentstatus_funktionnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatusnr", System.Data.SqlDbType.Int, 4, "dokumentstatusnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[sp_dokumentstatus_funktion_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection2
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_dokumentstatus_funktion_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus_funktionnr", System.Data.SqlDbType.Int, 4, "dokumentstatus_funktionnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatusnr", System.Data.SqlDbType.Int, 4, "dokumentstatusnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus_funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "vorlagenfeldbezeichnung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("vorlagenfeldbezeichnungnr", "vorlagenfeldbezeichnungnr"), New System.Data.Common.DataColumnMapping("vorlagenfeld", "vorlagenfeld"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_vorlagenfeldbezeichnung_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeld", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeld", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_vorlagenfeldbezeichnung_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldbezeichnungnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldbezeichnungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeld", System.Data.SqlDbType.Int, 4, "vorlagenfeld"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_vorlagenfeldbezeichnung_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeld", System.Data.SqlDbType.Int, 4, "vorlagenfeld"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_vorlagenfeldbezeichnung_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldbezeichnungnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldbezeichnungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "vorlagenfeld"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeld", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeld", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter4
        '
        Me.SqlDataAdapter4.SelectCommand = Me.SqlSelectCommand4
        Me.SqlDataAdapter4.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "coldindex", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("coldindexnr", "coldindexnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[pv_coldindexfeld_auswahl_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@foldernr", System.Data.SqlDbType.Int, 4, "cold_foldernr"))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter5
        '
        Me.SqlDataAdapter5.DeleteCommand = Me.SqlDeleteCommand4
        Me.SqlDataAdapter5.InsertCommand = Me.SqlInsertCommand4
        Me.SqlDataAdapter5.SelectCommand = Me.SqlSelectCommand5
        Me.SqlDataAdapter5.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumentindexmutation", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("indexmutationnr", "indexmutationnr"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv")})})
        Me.SqlDataAdapter5.UpdateCommand = Me.SqlUpdateCommand4
        '
        'SqlDeleteCommand4
        '
        Me.SqlDeleteCommand4.CommandText = "[pv_dokumentindexmutation_delete]"
        Me.SqlDeleteCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand4.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexmutationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexmutationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand4
        '
        Me.SqlInsertCommand4.CommandText = "[pv_dokumentindexmutation_insert]"
        Me.SqlInsertCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand4.Connection = Me.SqlConnection2
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexmutationnr", System.Data.SqlDbType.Int, 4, "indexmutationnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        '
        'SqlSelectCommand5
        '
        Me.SqlSelectCommand5.CommandText = "[pv_dokumentindexmutation_select]"
        Me.SqlSelectCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand5.Connection = Me.SqlConnection2
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        '
        'SqlUpdateCommand4
        '
        Me.SqlUpdateCommand4.CommandText = "[pv_dokumentindexmutation_update]"
        Me.SqlUpdateCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand4.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexmutationnr", System.Data.SqlDbType.Int, 4, "indexmutationnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexmutationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexmutationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter6
        '
        Me.SqlDataAdapter6.DeleteCommand = Me.SqlDeleteCommand5
        Me.SqlDataAdapter6.InsertCommand = Me.SqlInsertCommand5
        Me.SqlDataAdapter6.SelectCommand = Me.SqlSelectCommand6
        Me.SqlDataAdapter6.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumentaufhebung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("aufhebungnr", "aufhebungnr"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv")})})
        Me.SqlDataAdapter6.UpdateCommand = Me.SqlUpdateCommand5
        '
        'SqlDeleteCommand5
        '
        Me.SqlDeleteCommand5.CommandText = "[pv_dokumentaufhebung_delete]"
        Me.SqlDeleteCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand5.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufhebungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufhebungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand5
        '
        Me.SqlInsertCommand5.CommandText = "[pv_dokumentaufhebung_insert]"
        Me.SqlInsertCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand5.Connection = Me.SqlConnection2
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufhebungnr", System.Data.SqlDbType.Int, 4, "aufhebungnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        '
        'SqlSelectCommand6
        '
        Me.SqlSelectCommand6.CommandText = "[pv_dokumentaufhebung_select]"
        Me.SqlSelectCommand6.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand6.Connection = Me.SqlConnection2
        Me.SqlSelectCommand6.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand6.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        '
        'SqlUpdateCommand5
        '
        Me.SqlUpdateCommand5.CommandText = "[pv_dokumentaufhebung_update]"
        Me.SqlUpdateCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand5.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufhebungnr", System.Data.SqlDbType.Int, 4, "aufhebungnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufhebungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufhebungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet5
        '
        Me.DataSet5.DataSetName = "NewDataSet"
        Me.DataSet5.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet6
        '
        Me.DataSet6.DataSetName = "NewDataSet"
        Me.DataSet6.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = ((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(824, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 67
        '
        'cbezmut
        '
        Me.cbezmut.Location = New System.Drawing.Point(16, 228)
        Me.cbezmut.Name = "cbezmut"
        Me.cbezmut.Size = New System.Drawing.Size(216, 24)
        Me.cbezmut.TabIndex = 18
        Me.cbezmut.Text = "Bezeichnung mutierbar"
        '
        'frmDomainDokumenttypDetail
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(846, 715)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.pnlVorlagenfeld, Me.TabControl1, Me.Panel1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.Fixed3D
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.Name = "frmDomainDokumenttypDetail"
        Me.ShowInTaskbar = False
        Me.Text = "Dokumenttyp-Detail"
        Me.Panel1.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.Grp1.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabStruktur.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        Me.TabStatusreihenfolge.ResumeLayout(False)
        CType(Me.DokumentstatusRolle_Liste, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        CType(Me.Aufhebungliste, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.indexmutationliste, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage1.ResumeLayout(False)
        CType(Me.InfomeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TbSerienbrief.ResumeLayout(False)
        Me.pnlVorlagenfeld.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        CType(Me.ColdIndexfeldList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.vorlagenfeldbezeichnunglist, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.vorlagenfeldlist, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet6, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Insert_Vorlagenfeld Method

Private Sub Insert_Vorlagenfeld( _
   ByVal vorlagenfeldregelnr As Integer _
)

Parameters

vorlagenfeldregelnr
Required.

Source code

[Visual Basic]
    Private Sub Insert_Vorlagenfeld(ByVal vorlagenfeldregelnr As Integer)
        Dim iErrorcode As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.CommandText = "dbo.[sp_vorlagenfeld_insert]"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentTypkey))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vorlagenfeldregelnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iErrorcode))
        Try
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception("sp_vorlagenfeld_standard_insert:Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Connection.Close()
            scmCmdToExecute.Dispose()
            update_vorlagenfelder()
        End Try
        scmCmdToExecute.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Load_Data Method

Private Sub Load_Data()

Source code

[Visual Basic]
    Private Sub Load_Data()
        Dim doktyp As New edokadb.clsDokumenttyp()
        doktyp.cpMainConnectionProvider = conn
        doktyp.iDokumenttypnr = New SqlInt32(CType(Me.DokumentTypkey, Int32))
        doktyp.SelectOne()
        Me.cbOfficeVorlage.SelectedValue = doktyp.iOffice_vorlagenr.Value
        Me.TxTBeschreibung.Text = doktyp.sBeschreibung.Value
        Me.TxTBezeichnung.Text = doktyp.sBezeichnung.Value
        Me.cZuVercolden.Checked = doktyp.bZu_vercolden.Value = True
        Me.cZuRetournieren.Checked = doktyp.bZu_retournieren.Value = True
        Me.cEingangErsetztAusgang.Checked = doktyp.bEingang_ersetzt_ausgang.Value = True
        Me.cbArchiv.SelectedValue = doktyp.iPhysisches_archiv.Value
        Me.cbColdFolder.SelectedValue = doktyp.iCold_folder.Value
        Me.cbobnr.SelectedValue = doktyp.iObjektbezeichnungnr.Value
        Me.cbDokartAusgang.SelectedValue = doktyp.iDokumentart_coldausgang.Value
        Me.cbDokartEingang.SelectedValue = doktyp.iDokumentart_coldeingang.Value
        Me.cWirdImportiert.Checked = doktyp.bWird_importiert.Value = True
        Me.cStatusMutation.Checked = doktyp.bPartnersaldierung_statusalt.Value = True
        Me.cNichtgeloescht.Checked = doktyp.bWird_nicht_geloescht.Value = True
        Me.cVertraulich.Checked = doktyp.bVertrauliches_dokument.Value = True
        Me.cUnterschriftlinks.Checked = doktyp.bUnterschrift_links.Value = True
        Me.cUnterschriftrechts.Checked = doktyp.bUnterschrift_rechts.Value = True
        Me.cAMSDokument.Checked = doktyp.bAmsdokument.Value = True
        Me.cHostDokument.Checked = doktyp.bHostdokument.Value = True
        Me.cAktiv.Checked = doktyp.bAktiv.Value = True
        Me.cbBearbeitungszeit.Text = doktyp.iDbearbeitungszeit.Value
        Me.cbMonierung.Text = doktyp.iAnzahl_tage.Value
        Me.cbAbschluss.Text = doktyp.iTage_mutation.Value
        Me.cbAufbewahrungelektronisch.Text = doktyp.iAufbewahrungsfrist_elektronisch.Value
        Me.cbAufbewahrungphysisch.Text = doktyp.iAufbewahrungsfrist_physisch.Value
        Me.cbInEdokaDB.Text = doktyp.iMonate_bis_zur_archivierung.Value
        Me.Dokumenttypnr.Text = doktyp.iDokumenttypnr.Value
        Me.TxtDokumentartKundendossier.Text = doktyp.iDokumentart_kundendossier.Value
        Me.TxtDokumentartErstellung.Text = doktyp.iDokumentart_neuerstellung.Value
        Me.TxtDokumentartHost.Text = doktyp.iDokumentart_host.Value
        Me.TxTDokumentartRetournierung.Text = doktyp.iDokumentart_retournierung.Value
        Me.TxtDokumentartGesamt.Text = doktyp.iDokumentart_weitere.Value
        Me.txtDokumentartEinzeldokument.Text = doktyp.iDokumentart_nativ.Value
        Me.savestatustyp = Me.cbStatustyp.SelectedValue
        Me.cbprozesserstellung.SelectedValue = doktyp.iProzessnr.Value
        Me.cbprozessverwendung.SelectedValue = doktyp.iProzessnr1.Value
        Me.cDokumentwirderstellt.Checked = doktyp.bDokument_wird_erstellt.Value = True
        Me.CDokumentwirdretourniert.Checked = doktyp.bDokument_wird_retourniert.Value = True
        Me.cbedingtretournierbar.Checked = doktyp.bBedingtretournierbar.Value = True
        Me.cbtagebedr.Text = doktyp.iTagebisvernichtungbedingteretournierung.Value
        Me.CDokumentersetzen.Checked = doktyp.bCold_ersetzen.Value = True
        Me.cEmailVersand.Checked = doktyp.bEmail_versand.Value = True
        Me.cFunktion_zuweisen.Checked = doktyp.bFunktionen_zuweisen.Value = True

        Me.txtDokumentstatus_barcode.Text = doktyp.iDokumentstatus_barcode.Value
        Me.txtDokumentstatus.Text = doktyp.iDokumentstatus.Value
        Me.cbVertrag.Checked = doktyp.bVertrag.Value = True
        Dim ii As Integer
        ii = doktyp.iOwner.Value
        Me.mcbowner.SelectedValue = ii

        ii = doktyp.iDoktypbedingteretournierung.Value
        Me.mcbbedingteretournierung.SelectedValue = ii

        If Me.cDokumentwirderstellt.Checked = True Or Me.cbedingtretournierbar.Checked = True Then
            Me.cbStatustyp.SelectedValue = doktyp.iDokumentstatus.Value
        Else
            Me.cbStatustyp.SelectedValue = doktyp.iDokumentstatus_barcode.Value
        End If

        Try
            If doktyp.sHostdokumenttyp.Value Is DBNull.Value Then
                Me.txthostdokumenttyp.Text = ""
            Else
                Me.txthostdokumenttyp.Text = doktyp.sHostdokumenttyp.Value
            End If
        Catch
            Me.txthostdokumenttyp.Text = ""
        End Try
        Me.cbOfficeVorlage.SelectedValue = doktyp.iOffice_vorlagenr.Value
        Me.cidvnative.Checked = doktyp.bNurnative.Value = True

        'EDEX Banklagernd
        Me.cbKDE.Checked = doktyp.bKundenDokument.Value = True
        Me.cbAnzeige.Checked = doktyp.bAnzeigeZurDokumenterstellung.Value = True

        'EDEX Serienbriefe
        Me.cbsb.Checked = doktyp.bSb.Value
        Me.cbsbedituser.Checked = doktyp.bSbedituser.Value
        Me.cbsbimport.Checked = doktyp.bSbimport.Value
        Me.cbsbnur.Checked = doktyp.bSbnur.Value
        Me.cbezmut.Checked = doktyp.bBezeichnungmut.Value

        doktyp.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Load_Dokumentstatus Method

Private Sub Load_Dokumentstatus()

Source code

[Visual Basic]
    Private Sub Load_Dokumentstatus()
        Dim dstatus As New edokadb.clsMyDokumentstatus()
        dstatus.Dokumenttypnr = Me.DokumentTypkey
        Try
            If Me.DokStatus = 1 Then
                dstatus.Statustypnr = Me.txtDokumentstatus_barcode.Text
            Else
                dstatus.Statustypnr = Me.txtDokumentstatus.Text
            End If
        Catch
        End Try
        'dstatus.Statustypnr = Me.cbStatustyp.SelectedValue
        dstatus.cpMainConnectionProvider = conn
        t = dstatus.SelectDokumentstatus()
        Me.Statuslist.DataSource = t
        dstatus.Dispose()
        SpaltenTitel_Aktualisieren()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Load_Listen Method

Private Sub Load_Listen()

Source code

[Visual Basic]
    Private Sub Load_Listen()
        Dim i As Integer
        Me.cbBearbeitungszeit.Items.Clear()
        For i = 0 To 180
            Me.cbBearbeitungszeit.Items.Add(i)
        Next

        Me.cbAufbewahrungelektronisch.Items.Clear()
        Me.cbAufbewahrungphysisch.Items.Clear()
        For i = 0 To 25
            Me.cbAufbewahrungelektronisch.Items.Add(i)
            Me.cbAufbewahrungphysisch.Items.Add(i)
        Next

        Me.cbMonierung.Items.Clear()
        Me.cbAbschluss.Items.Clear()
        For i = 0 To 120
            Me.cbMonierung.Items.Add(i)
            '            Me.cbAbschluss.Items.Add(i)
        Next
        For i = 0 To 30
            Me.cbAbschluss.Items.Add(i)
        Next
        For i = 60 To 1850 Step 30
            Me.cbAbschluss.Items.Add(i)
        Next
        Me.cbAbschluss.Items.Add(1850)
        Me.cbAbschluss.Items.Add(1860)

        Me.cbInEdokaDB.Items.Clear()
        For i = 0 To 24
            Me.cbInEdokaDB.Items.Add(i)
        Next

        Me.cbtagebedr.Items.Clear()
        For i = 0 To 60
            Me.cbtagebedr.Items.Add(i)
        Next

        Dim dofficevorlage As New edokadb.clsOffice_vorlage()
        dofficevorlage.cpMainConnectionProvider = conn
        tofficevorlage = dofficevorlage.SelectAll()
        Me.cbOfficeVorlage.DataSource = Me.tofficevorlage
        Me.cbOfficeVorlage.DisplayMember = "bezeichnung"
        Me.cbOfficeVorlage.ValueMember = "office_vorlagenr"
        dofficevorlage.Dispose()

        Dim dphysischesarchiv As New edokadb.clsPhysischesArchiv()
        dphysischesarchiv.cpMainConnectionProvider = conn
        tphysischesarchiv = dphysischesarchiv.SelectAll
        Me.cbArchiv.DataSource = Me.tphysischesarchiv
        Me.cbArchiv.DisplayMember = "bezeichnung"
        Me.cbArchiv.ValueMember = "physischesarchivnr"
        dphysischesarchiv.Dispose()

        Dim dcoldfolder As New edokadb.clsCold_folder()
        dcoldfolder.cpMainConnectionProvider = conn
        tcoldfolder = dcoldfolder.SelectAll
        For i = 0 To tcoldfolder.Rows.Count - 1
            If tcoldfolder.Rows(i).Item("aktiv") = False Then
                tcoldfolder.Rows(i).Delete()
            End If
        Next
        Me.cbColdFolder.DataSource = Me.tcoldfolder
        Me.cbColdFolder.DisplayMember = "bezeichnung"
        Me.cbColdFolder.ValueMember = "cold_foldernr"
        dcoldfolder.Dispose()

        Dim dobnr As New edokadb.clsObjektbezeichnung()
        dobnr.cpMainConnectionProvider = conn
        tobnr = dobnr.SelectAll
        For i = 0 To tobnr.Rows.Count - 1
            If tobnr.Rows(i).Item("aktiv") = False Then
                tobnr.Rows(i).Delete()
            End If
        Next
        Me.cbobnr.DataSource = Me.tobnr
        Me.cbobnr.DisplayMember = "bezeichnung"
        Me.cbobnr.ValueMember = "objektbezeichnungnr"
        dobnr.Dispose()

        Dim ddokumentartausgang As New edokadb.clsMyDokumentart()
        ddokumentartausgang.cpMainConnectionProvider = conn
        tdokumentartausgang = ddokumentartausgang.SelectHierarchy_By_Root(6)
        Me.cbDokartAusgang.DataSource = Me.tdokumentartausgang
        Me.cbDokartAusgang.DisplayMember = "bezeichnung"
        Me.cbDokartAusgang.ValueMember = "dokumentartnr"

        ddokumentartausgang.cpMainConnectionProvider = conn
        tdokumentarteingang = ddokumentartausgang.SelectHierarchy_By_Root(7)
        Me.cbDokartEingang.DataSource = Me.tdokumentarteingang
        Me.cbDokartEingang.DisplayMember = "bezeichnung"
        Me.cbDokartEingang.ValueMember = "dokumentartnr"
        ddokumentartausgang.Dispose()

        Dim dstatustyp As New edokadb.clsStatustyp()
        dstatustyp.cpMainConnectionProvider = conn
        tstatustyp = dstatustyp.SelectAll
        Me.cbStatustyp.DataSource = Me.tstatustyp
        Me.cbStatustyp.DisplayMember = "bezeichnung"
        Me.cbStatustyp.ValueMember = "statustypnr"
        dstatustyp.Dispose()

        Dim dprozess As New edokadb.clsProzess()
        dprozess.cpMainConnectionProvider = conn
        tprozess1 = dprozess.SelectAll
        tprozess2 = dprozess.SelectAll
        Me.cbprozesserstellung.DataSource = Me.tprozess1
        Me.cbprozesserstellung.DisplayMember = "bezeichnung"
        Me.cbprozesserstellung.ValueMember = "prozessnr"

        Me.cbprozessverwendung.DataSource = Me.tprozess2
        Me.cbprozessverwendung.DisplayMember = "bezeichnung"
        Me.cbprozessverwendung.ValueMember = "prozessnr"

        dprozess.Dispose()

        Dim ii As Integer
        mcbowner = New MultiComboBox(cbOwner)
        Me.mcbowner.DisplayColumnName = "name"
        Me.mcbowner.ValueColumnName = "mitarbeiternr"
        Me.mcbowner.Fill_Data(Generic_Select(3), False)

        mcbbedingteretournierung = New MultiComboBox(Me.cbbedingteretournierung)
        Me.mcbbedingteretournierung.DisplayColumnName = "bezeichnung"
        Me.mcbbedingteretournierung.ValueColumnName = "nummer"
        Me.mcbbedingteretournierung.Fill_Data(Generic_Select(4), True)
        Me.mcbbedingteretournierung.Enabled = True
        Me.cbbedingteretournierung.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MenuErledigung_Setzen_Click Method

Private Sub MenuErledigung_Setzen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuErledigung_Setzen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim frm As New frmSelectStatus()
        Dim i As Integer
        Dim coln As Integer
        For i = 0 To Me.Statuslist.Columns.Count - 1
            If Me.Statuslist.Columns(i).DataField = "erledigung_ab" Then coln = i
        Next
        frm.Dokumenttypnr = Me.DokumentTypkey
        frm.Statustypnr = Me.cbStatustyp.SelectedValue
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Refresh()
        frm.ShowDialog()
        If frm.TransferKey <> 0 Then
            Me.Statuslist.Columns(coln).Value = frm.TransferKey
            Me.StatusDataChanged = True
        End If
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim f As New frmInformationsEmpfaenger()
        f.fromDokumenttyp = True
        f.Dokumenttypnr = Me.Dokumenttypnr.Text
        f.statustyp = Me.cbStatustyp.SelectedValue
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim rc As DataRowCollection
            Dim newrow As DataRow
            rc = Me.DokumentInfoMeldungen.Rows
            Dim rowvals(8) As Object
            rowvals(0) = 0
            rowvals(1) = f.Empfaenger
            rowvals(2) = f.Empaengertext
            rowvals(3) = f.Meldungsnr
            rowvals(4) = f.Meldung
            If Len(f.Bemerkung) > 0 Then f.Bemerkung = f.Bemerkung + vbCrLf + "----------------------" + vbCrLf + vbCrLf
            rowvals(5) = f.Bemerkung
            rowvals(6) = f.Statusnr
            rowvals(7) = f.Statustext
            rowvals(8) = 1
            newrow = rc.Add(rowvals)
            Me.InfomeldungList.Refresh()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Dim i As Integer
        Me.InfomeldungList.Columns(8).Text = False
        Me.InfomeldungList.Refresh()
        Me.TabControl1.Select()
        Me.InfomeldungList.Select()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MnuDokZuordnungauheben_Click Method

Private Sub MnuDokZuordnungauheben_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokZuordnungauheben.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokZuordnungauheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokZuordnungauheben.Click
        If Me.RBKundendossier.Checked Then
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartKundendossier.Text, 2)
            Me.TxtDokumentartKundendossier.Text = 0
        End If
        If Me.RBHost.Checked Then
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartHost.Text, 2)
            Me.TxtDokumentartHost.Text = 0
        End If
        If Me.RBGesamt.Checked Then
            DivFnkt.Searchnode(Me.TVStruktur, Me.TxtDokumentartGesamt.Text, 2)
            Me.TxtDokumentartGesamt.Text = 0
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.MnuErledigung_ab_aufheben_Click Method

Private Sub MnuErledigung_ab_aufheben_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuErledigung_ab_aufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim frm As New frmSelectStatus()
        Dim i As Integer
        Dim coln As Integer
        For i = 0 To Me.Statuslist.Columns.Count - 1
            If Me.Statuslist.Columns(i).DataField = "erledigung_ab" Then coln = i
        Next
        Me.Statuslist.Columns(coln).Value = -1
        Me.StatusDataChanged = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Panel3_Paint Method

Private Sub Panel3_Paint( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
) Handles Panel3.Paint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Panel3_Paint(ByVal sender As System.Object, ByVal e As System.Windows.Forms.PaintEventArgs) Handles Panel3.Paint

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Save_Changes Method

Private Function Save_Changes() As MsgBoxResult

Source code

[Visual Basic]
    Private Function Save_Changes() As MsgBoxResult
        Dim msg As MsgBoxResult
        If Not DataChanged Then
            Return MsgBoxResult.OK
            Exit Function
        End If
        If DataChanged Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                Return MsgBoxResult.OK
            End If
            If msg = MsgBoxResult.Yes Then
                Save_Data()
                DataChanged = False
                Return MsgBoxResult.OK
            End If
            If msg = MsgBoxResult.Cancel Then Return MsgBoxResult.Cancel
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Save_Data = True

        If Check_Status() = False Then
            MyMsg.show_standardmessage(238, MsgBoxStyle.Information)
            Save_Data = False
        End If
        If Me.TxtDokumentartKundendossier.Text = 2 Then
            MyMsg.show_standardmessage(200, MsgBoxStyle.Exclamation)
            Me.TVStruktur.Focus()
            Exit Function
        End If
        If Me.TxTBezeichnung.Text = "" Then
            MyMsg.show_standardmessage(201, MsgBoxStyle.Exclamation)
            Me.TxTBezeichnung.Focus()
            Exit Function
        End If
        If Me.cbedingtretournierbar.Checked = True And Me.cbtagebedr.Text = "0" Then
            MyMsg.show_standardmessage(239, MsgBoxStyle.Critical)
            Me.cbtagebedr.Focus()
            Exit Function
        End If

        'edex 20050206
        If Me.cAktiv.Checked = False Then
            If Check_Dokumentpaketvorlage() = False Then
                Save_Data = False
                Exit Function
            End If
        End If

        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim doktyp As New edokadb.clsDokumenttyp()
        Dim key As Long
        ' neuer DB-Key lesen
        If Me.NeuerEintrag Then
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("dokumenttyp")
            doktyp.iDokumenttypnr = New SqlInt32(CType(key, Int32))
            doktyp.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.DokumentTypkey = key
        Else
            doktyp.cpMainConnectionProvider = conn
            doktyp.iDokumenttypnr = New SqlInt32(CType(Me.DokumentTypkey, Int32))
            doktyp.SelectOne()
        End If
        doktyp.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        doktyp.bAktiv = New SqlBoolean(CType(Me.cAktiv.Checked, Boolean))
        doktyp.iOffice_vorlagenr = New SqlInt32(CType(Me.cbOfficeVorlage.SelectedValue, Int32))
        doktyp.sBeschreibung = New SqlString(CType(Me.TxTBeschreibung.Text, String))
        doktyp.sBezeichnung = New SqlString(CType(Me.TxTBezeichnung.Text, String))

        doktyp.bZu_vercolden = New SqlBoolean(CType(Me.cZuVercolden.Checked, Boolean))
        doktyp.iDokumentart_coldausgang = New SqlInt32(CType(Me.cbDokartAusgang.SelectedValue, Int32))
        doktyp.bZu_retournieren = New SqlBoolean(CType(Me.cZuRetournieren.Checked, Boolean))
        doktyp.iDokumentart_coldeingang = New SqlInt32(CType(Me.cbDokartEingang.SelectedValue, Int32))
        doktyp.bEingang_ersetzt_ausgang = New SqlBoolean(CType(Me.cEingangErsetztAusgang.Checked, Boolean))
        doktyp.iCold_folder = New SqlInt32(CType(Me.cbColdFolder.SelectedValue, Int32))
        doktyp.iObjektbezeichnungnr = New SqlInt32(CType(Me.cbobnr.SelectedValue, Int32))
        doktyp.iPhysisches_archiv = New SqlInt32(CType(Me.cbArchiv.SelectedValue, Int32))

        doktyp.bWird_importiert = New SqlBoolean(CType(Me.cWirdImportiert.Checked, Boolean))
        doktyp.bPartnersaldierung_statusalt = New SqlBoolean(CType(Me.cStatusMutation.Checked, Boolean))
        doktyp.bWird_nicht_geloescht = New SqlBoolean(CType(Me.cNichtgeloescht.Checked, Boolean))
        doktyp.bVertrauliches_dokument = New SqlBoolean(CType(Me.cVertraulich.Checked, Boolean))
        doktyp.bUnterschrift_links = New SqlBoolean(CType(Me.cUnterschriftlinks.Checked, Boolean))
        doktyp.bUnterschrift_rechts = New SqlBoolean(CType(Me.cUnterschriftrechts.Checked, Boolean))
        doktyp.bAmsdokument = New SqlBoolean(CType(Me.cAMSDokument.Checked, Boolean))
        doktyp.bHostdokument = New SqlBoolean(CType(Me.cHostDokument.Checked, Boolean))

        doktyp.iDbearbeitungszeit = New SqlInt32(CType(Me.cbBearbeitungszeit.Text, Int32))
        doktyp.iAnzahl_tage = New SqlInt32(CType(Me.cbMonierung.Text, Int32))
        doktyp.iTage_mutation = New SqlInt32(CType(Me.cbAbschluss.Text, Int32))
        doktyp.iAufbewahrungsfrist_elektronisch = New SqlInt32(CType(Me.cbAufbewahrungelektronisch.Text, Int32))
        doktyp.iAufbewahrungsfrist_physisch = New SqlInt32(CType(Me.cbAufbewahrungphysisch.Text, Int32))
        doktyp.iMonate_bis_zur_archivierung = New SqlInt32(CType(Me.cbInEdokaDB.Text, Int32))

        doktyp.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        doktyp.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))

        doktyp.iDokumentart_kundendossier = New SqlInt32(CType(Me.TxtDokumentartKundendossier.Text, Int32))
        doktyp.iDokumentart_retournierung = New SqlInt32(CType(Me.TxTDokumentartRetournierung.Text, Int32))
        doktyp.iDokumentart_neuerstellung = New SqlInt32(CType(Me.TxtDokumentartErstellung.Text, Int32))
        doktyp.iDokumentart_host = New SqlInt32(CType(Me.TxtDokumentartHost.Text, Int32))
        doktyp.iProzessnr = New SqlInt32(CType(Me.cbprozesserstellung.SelectedValue, Int32))
        doktyp.iProzessnr1 = New SqlInt32(CType(Me.cbprozessverwendung.SelectedValue, Int32))
        doktyp.iDokumentart_weitere = New SqlInt32(CType(Me.TxtDokumentartGesamt.Text, Int32))

        doktyp.sHostdokumenttyp = New SqlString(CType(Me.txthostdokumenttyp.Text, String))
        doktyp.bDokument_wird_erstellt = New SqlBoolean(CType(Me.cDokumentwirderstellt.Checked, Boolean))
        doktyp.bDokument_wird_retourniert = New SqlBoolean(CType(Me.CDokumentwirdretourniert.Checked, Boolean))
        doktyp.bBedingtretournierbar = New SqlBoolean(CType(Me.cbedingtretournierbar.Checked, Boolean))
        Try
            doktyp.iTagebisvernichtungbedingteretournierung = New SqlInt32(CType(Me.cbtagebedr.Text, Int32))
        Catch
            Me.cbtagebedr.Text = 0
            doktyp.iTagebisvernichtungbedingteretournierung = New SqlInt32(CType(Me.cbtagebedr.Text, Int32))
        End Try
        doktyp.iDoktypbedingteretournierung = New SqlInt32(CType(Me.mcbbedingteretournierung.SelectedValue, Int32))
        doktyp.bCold_ersetzen = New SqlBoolean(CType(Me.CDokumentersetzen.Checked, Boolean))
        doktyp.bEmail_versand = New SqlBoolean(CType(Me.cEmailVersand.Checked, Boolean))
        doktyp.bFunktionen_zuweisen = New SqlBoolean(CType(Me.cFunktion_zuweisen.Checked, Boolean))
        doktyp.bNurnative = New SqlBoolean(CType(Me.cidvnative.Checked, Boolean))
        doktyp.iDokumentart_nativ = New SqlInt32(CType(Me.txtDokumentartEinzeldokument.Text, Int32))

        '        doktyp.iDokumentstatus = New SqlInt32(CType(Me.cbStatustyp.SelectedValue, Int32))
        doktyp.iDokumentstatus = New SqlInt32(CType(Me.txtDokumentstatus.Text, Int32))
        doktyp.iDokumentstatus_barcode = New SqlInt32(CType(Me.txtDokumentstatus_barcode.Text, Int32))
        doktyp.bVertrag = New SqlBoolean(CType(Me.cbVertrag.Checked, Boolean))
        doktyp.iOwner = New SqlInt32(CType(Me.mcbowner.SelectedValue, Int32))

        'EDEX Banklagernd
        doktyp.bKundenDokument = New SqlBoolean(CType(Me.cbKDE.Checked, Boolean))
        doktyp.bAnzeigeZurDokumenterstellung = New SqlBoolean(CType(Me.cbAnzeige.Checked, Boolean))

        'EDEX Serienbriefe
        doktyp.bSb = New SqlBoolean(CType(Me.cbsb.Checked = True, Boolean))
        doktyp.bSbedituser = New SqlBoolean(CType(Me.cbsbedituser.Checked = True, Boolean))
        doktyp.bSbimport = New SqlBoolean(CType(Me.cbsbimport.Checked = True, Boolean))
        doktyp.bSbnur = New SqlBoolean(CType(Me.cbsbnur.Checked = True, Boolean))
        doktyp.bBezeichnungmut = New SqlBoolean(CType(Me.cbezmut.Checked = True, Boolean))

        doktyp.cpMainConnectionProvider = conn
        conn.OpenConnection()
        If Me.NeuerEintrag Then
            doktyp.Insert()
            Me.NeuerEintrag = False
        Else
            Try
                doktyp.Update()
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End If
        conn.CloseConnection(True)
        doktyp.Dispose()
        dbkey.Dispose()
        DataChanged = False
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Save_Rollenliste Method

Private Sub Save_Rollenliste()

Source code

[Visual Basic]
    Private Sub Save_Rollenliste()
        If Me.DataSet2.HasChanges Then
            If Globals.MyMsg.Show_MessageYesNo(14) = MsgBoxResult.Yes Then
                Me.SqlDataAdapter2.Update(Me.DataSet2)
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Save_Statusdata Method

Private Sub Save_Statusdata()

Source code

[Visual Basic]
    Private Sub Save_Statusdata()
        Dim i As Integer
        Dim dsdata As New edokadb.clsMyDokumentstatus()
        dsdata.cpMainConnectionProvider = conn
        t = Me.Statuslist.DataSource
        For i = 0 To t.Rows.Count - 1
            dsdata.iDokumentstatusnr = New SqlInt32(CType(t.Rows(i).Item("dokumentstatusnr"), Int32))
            dsdata.SelectOne()
            If dsdata.iErledigung_ab.Value <> t.Rows(i).Item("erledigung_ab") Or _
                dsdata.bFolgestatus_durch_anderen_verantwortlichen.Value <> t.Rows(i).Item("Folgestatus_durch_anderen_verantwortlichen") Then
                dsdata.iErledigung_ab = New SqlInt32(CType(t.Rows(i).Item("erledigung_ab"), Int32))
                dsdata.bFolgestatus_durch_anderen_verantwortlichen = New SqlBoolean(CType(t.Rows(i).Item("folgestatus_durch_anderen_verantwortlichen"), Boolean))
                dsdata.daMutiert_am = New SqlDateTime(Now)
                dsdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                conn.OpenConnection()
                dsdata.iDokumentstatusnr = New SqlInt32(CType(t.Rows(i).Item("dokumentstatusnr"), Int32))
                dsdata.Update()
                conn.CloseConnection(True)
            End If
            Me.StatusDataChanged = False
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.SetFields Method

Private Sub SetFields( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cAMSDokument.CheckedChanged, _
   cDokumentwirderstellt.CheckedChanged, _
   cWirdImportiert.CheckedChanged, _
   CDokumentwirdretourniert.CheckedChanged, _
   cHostDokument.CheckedChanged, _
   cbedingtretournierbar.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub SetFields(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cAMSDokument.CheckedChanged, cDokumentwirderstellt.CheckedChanged, cWirdImportiert.CheckedChanged, CDokumentwirdretourniert.CheckedChanged, cHostDokument.CheckedChanged, cbedingtretournierbar.CheckedChanged
        If Me.On_Load Then Exit Sub
        If Me.cHostDokument.Checked = True Then
            fields_hostdokument(sender, e)
            Exit Sub
        End If
        If Me.cDokumentwirderstellt.Checked = False And _
           Me.cWirdImportiert.Checked = False And _
           Me.CDokumentwirdretourniert.Checked = False And _
           Me.cAMSDokument.Checked = False And Me.cbedingtretournierbar.Checked = False Then
            init_fields()
            Exit Sub
        End If
        If Me.cDokumentwirderstellt.Checked = True And _
           Me.cWirdImportiert.Checked = False And _
           Me.CDokumentwirdretourniert.Checked = False And _
           Me.cAMSDokument.Checked = False Then
            Fields_Dokumentwirderstellt()
            Me.cZuVercolden_CheckedChanged(sender, e)
            Me.cZuRetournieren_CheckedChanged(sender, e)
            Exit Sub
        End If

        If Me.cAMSDokument.Checked = True And Me.cDokumentwirderstellt.Checked = False Then
            'hutter
            'Fields_AMSDokument(sender, e)
            Fields_Dokumentwirderstellt_Ams()
            Me.cZuVercolden_CheckedChanged(sender, e)
            Me.cZuRetournieren_CheckedChanged(sender, e)
            Exit Sub
        End If

        If Me.cDokumentwirderstellt.Checked = True And Me.cAMSDokument.Checked = True And _
           Me.CDokumentwirdretourniert.Checked = False Then
            Fields_Dokumentwirderstellt_Ams()
            Me.cZuVercolden_CheckedChanged(sender, e)
            Me.cZuRetournieren_CheckedChanged(sender, e)
            Exit Sub
        End If

        If Me.cDokumentwirderstellt.Checked = True And Me.CDokumentwirdretourniert.Checked = True Then
            fields_Dokumentwirderstellt_retournierung()
            Me.cZuVercolden_CheckedChanged(sender, e)
            Me.cZuRetournieren_CheckedChanged(sender, e)
        End If

        If Me.CDokumentwirdretourniert.Checked = True And Me.cDokumentwirderstellt.Checked = False Then
            fields_Dokumentwirdretourniert()
            Exit Sub
        End If
        If Me.cbedingtretournierbar.Checked = True Then
            Me.cDokumentwirderstellt.Checked = False
            Me.cWirdImportiert.Checked = False
            Me.CDokumentwirdretourniert.Checked = False
            Me.cAMSDokument.Checked = False
            Me.cHostDokument.Checked = False
            Me.mcbbedingteretournierung.Enabled = False
            Me.cbtagebedr.Enabled = True
            fields_Dokumentwirdretourniert()
            Me.cVertraulich.Checked = False
            Me.cVertraulich.Enabled = False
            Me.cFunktion_zuweisen.Checked = False
            Me.cFunktion_zuweisen.Enabled = False
            Me.rbEtikette.Enabled = False

            Exit Sub
        End If

        If Me.cWirdImportiert.Checked = True Then
            fields_Dokumentwirdimportiert()
            Me.cZuVercolden_CheckedChanged(sender, e)
            Me.cZuRetournieren_CheckedChanged(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        ts.Tabelle = "dokumentstatus"
        For i = 0 To Me.Statuslist.Columns.Count - 1
            s = Me.Statuslist.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.Statuslist.Columns(i).Caption = ts.spaltenname
            If Me.Statuslist.Columns(i).Caption = "" Then
                Me.Statuslist.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.Statuslist.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            If ts.locked Then
                Me.Statuslist.Splits(0).DisplayColumns(i).Locked = True
            End If
            If Me.Statuslist.Columns(i).DataField = "folgestatus_durch_anderen_verantwortlichen" Then
                Me.Statuslist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.SpaltenTitel_Aktualisieren1 Method

Public Sub SpaltenTitel_Aktualisieren1()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren1()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        ts.Tabelle = "vorlagenfeld"
        For i = 0 To Me.vorlagenfeldlist.Columns.Count - 1
            s = Me.vorlagenfeldlist.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.vorlagenfeldlist.Columns(i).Caption = ts.spaltenname
            If Me.vorlagenfeldlist.Columns(i).Caption = "" Then
                Me.vorlagenfeldlist.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.vorlagenfeldlist.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            If ts.locked Then
                Me.vorlagenfeldlist.Splits(0).DisplayColumns(i).Locked = True
            End If
            If Me.vorlagenfeldlist.Columns(i).DataField = "einstiegsmakro" Then
                Me.vorlagenfeldlist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
            If Me.vorlagenfeldlist.Columns(i).DataField = "ausstiegsmakro" Then
                Me.vorlagenfeldlist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
            If Me.vorlagenfeldlist.Columns(i).DataField = "aktiv" Then
                Me.vorlagenfeldlist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
            If Me.vorlagenfeldlist.Columns(i).DataField = "userinterface" Then
                Me.vorlagenfeldlist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
            If Me.vorlagenfeldlist.Columns(i).DataField = "eingabe_zwingend" Then
                Me.vorlagenfeldlist.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
            Me.vorlagenfeldlist.Splits(0).DisplayColumns("userinterface").Locked = True
            Me.vorlagenfeldlist.Splits(0).DisplayColumns("eingabe_zwingend").Locked = False
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.SpaltenTitel_Aktualisieren2 Method

Public Sub SpaltenTitel_Aktualisieren2()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren2()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String
        ts.Tabelle = "vorlagenfeldbezeichnung"
        For i = 0 To Me.vorlagenfeldbezeichnunglist.Columns.Count - 1
            s = Me.vorlagenfeldbezeichnunglist.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.vorlagenfeldbezeichnunglist.Columns(i).Caption = ts.spaltenname
            If Me.vorlagenfeldbezeichnunglist.Columns(i).Caption = "" Then
                Me.vorlagenfeldbezeichnunglist.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.vorlagenfeldbezeichnunglist.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            If ts.locked Then
                Me.vorlagenfeldbezeichnunglist.Splits(0).DisplayColumns(i).Locked = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.SpaltenTitel_Aktualisieren_StatusRolle Method

Public Sub SpaltenTitel_Aktualisieren_StatusRolle()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren_StatusRolle()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        ts.Tabelle = "dokumentstatus_funktion"
        For i = 0 To Me.DokumentstatusRolle_Liste.Columns.Count - 1
            s = Me.DokumentstatusRolle_Liste.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.DokumentstatusRolle_Liste.Columns(i).Caption = ts.spaltenname
            If Me.DokumentstatusRolle_Liste.Columns(i).Caption = "" Then
                Me.DokumentstatusRolle_Liste.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.DokumentstatusRolle_Liste.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            If ts.locked Then
                Me.DokumentstatusRolle_Liste.Splits(0).DisplayColumns(i).Locked = True
            End If
            If Me.DokumentstatusRolle_Liste.Columns(i).DataField = "aktiv" Then
                Me.DokumentstatusRolle_Liste.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DokumentstatusRolle_Liste.Columns(i).DefaultValue = True
                Me.DokumentstatusRolle_Liste.Columns(i).FilterText = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Statuslist_Click Method

Private Sub Statuslist_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles Statuslist.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles Statuslist.RowColChange
        Save_Rollenliste()
        Update_RollenListe()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Statuslist_aftercellupdate Method

Private Sub Statuslist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles Statuslist.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles Statuslist.AfterColEdit
        Me.StatusDataChanged = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.TVStruktur_AfterSelect Method

Private Sub TVStruktur_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TVStruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TVStruktur.AfterSelect
        Dim tn As New TreeNode()
        tn = Me.TVStruktur.SelectedNode
        If tn.GetNodeCount(True) > 0 And Me.TxtDokumentartKundendossier.Text <> "0" Then
            MyMsg.show_standardmessage(202, MsgBoxStyle.Critical)
            tn = Nothing
            Exit Sub
        End If
        tn = Nothing

        If Me.RBKundendossier.Checked Then
            Me.TxtDokumentartKundendossier.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
        If Me.RBHost.Checked Then
            Me.TxtDokumentartHost.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
        If Me.RBEingang.Checked Then
            Me.TxTDokumentartRetournierung.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
        If Me.RBErstellung.Checked Then
            Me.TxtDokumentartErstellung.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
        If Me.RBGesamt.Checked Then
            Me.TxtDokumentartGesamt.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
        If Me.RBEinzeldokumente.Checked Then
            Me.txtDokumentartEinzeldokument.Text = Me.TVStruktur.SelectedNode.Tag
            Me.TVStruktur.SelectedNode.SelectedImageIndex = 1
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.TabControl1_SelectedIndexChanged Method

Private Sub TabControl1_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl1.SelectedIndexChanged
        If Me.DataSet3.HasChanges Then
            Try
                Me.SqlDataAdapter3.Update(Me.DataSet3)
            Catch
            End Try
        End If
        Save_Rollenliste()

        If TabControl1.SelectedIndex = 0 Or TabControl1.SelectedIndex = 1 Then
            If Me.VorlagenDataChanged = True Then
                If MyMsg.Show_MessageYesNo(10) = MsgBoxResult.OK Then
                    Me.save_vorlagenfeldlist()
                End If
                Me.update_vorlagenfelder()
            End If
        End If
        If TabControl1.SelectedIndex = 1 Or TabControl1.SelectedIndex = 2 Then
            pnlVorlagenfeld.Visible = False
            If Save_Changes() <> MsgBoxResult.OK Then TabControl1.SelectedIndex = 0
        End If
        If TabControl1.SelectedIndex = 0 Or TabControl1.SelectedIndex = 2 Then
            pnlVorlagenfeld.Visible = False
            If Me.StatusDataChanged = True Then
                If MyMsg.Show_MessageYesNo(9) = MsgBoxResult.OK Then
                    Save_Statusdata()
                Else
                    Load_Dokumentstatus()
                End If
            End If
        End If
        If TabControl1.SelectedIndex = 2 Then
            pnlVorlagenfeld.Visible = False
        End If
        pnlVorlagenfeld.Visible = False
        If TabControl1.SelectedTab.Name = "TabDokumentfelder" Then
            '            If TabControl1.SelectedIndex = 3 Then
            pnlVorlagenfeld.Visible = True
            update_vorlagenfelder()
        End If
        If TabControl1.SelectedIndex = 5 Then
            If Me.cDokumentwirderstellt.Checked = False Then
                Me.cbsb.Enabled = False
                Me.cbsb.Checked = False
                Me.cbsbnur.Enabled = False
                Me.cbsbnur.Checked = False
                Me.cbsbedituser.Enabled = False
                Me.cbsbedituser.Checked = False
                Me.cbsbimport.Enabled = False
                Me.cbsbimport.Checked = False
            Else
                Dim ov As New edokadb.clsOffice_vorlage()
                Try
                    ov.cpMainConnectionProvider = Globals.conn
                    ov.iOffice_vorlagenr = New SqlInt32(CType(Me.cbOfficeVorlage.SelectedValue, Int32))
                    ov.SelectOne()
                    If ov.iAnwendungnr.Value <> 1 Then
                        Me.cbsb.Enabled = False
                    Else
                        Me.cbsb.Enabled = True
                    End If
                Catch
                    Me.cbsb.Enabled = False
                Finally
                    ov.Dispose()
                End Try
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                If Me.DataSet3.HasChanges Then
                    Try
                        Me.SqlDataAdapter3.Update(Me.DataSet3)
                    Catch
                    End Try
                End If
                If Me.StatusDataChanged Then If MyMsg.Show_MessageYesNo(9) = MsgBoxResult.Yes Then Save_Statusdata()
                If Me.VorlagenDataChanged Then If MyMsg.Show_MessageYesNo(10) = MsgBoxResult.Yes Then Me.save_vorlagenfeldlist()
                Save_Rollenliste()
                If Save_Changes() = MsgBoxResult.OK Then Me.Close()
            Case 1
                Save_Data()
            Case 2
                Dim ww As New WordLib()
                ww.Create_Dokument(Me.DokumentTypkey, False)
                ww = Nothing
            Case 4
                Dim f As New frmReporting()
                f.show_report_dokumenttyp(Me.Dokumenttypnr.Text)
                f.Show()
            Case 5
                Dim ww As New WordLib()
                ww.Create_Dokument(Me.DokumentTypkey, True)
            Case 7
                Dim frm As New frmDokumenttypOptions()
                frm.Dokumenttypnr = Me.Dokumenttypnr.Text
                frm.ShowDialog()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.TxtBezeichnung_exit Method

Private Sub TxtBezeichnung_exit( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TxTBezeichnung.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TxtBezeichnung_exit(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TxTBezeichnung.Leave
        If Me.TxTBezeichnung.Text <> "" Then
            Me.cDokumentwirderstellt.Enabled = True
            Me.cAMSDokument.Enabled = True
            Me.cHostDokument.Enabled = True
        Else
            MyMsg.show_standardmessage(201, MsgBoxStyle.Critical)
            Me.TxTBezeichnung.Focus()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Update_Aufhebungliste Method

Private Sub Update_Aufhebungliste()

Source code

[Visual Basic]
    Private Sub Update_Aufhebungliste()
        Try
            Me.DataSet6.Clear()
            Me.SqlDataAdapter6.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter6.SelectCommand.Parameters.Add("@dokumenttypnr", Me.Dokumenttypnr.Text)
            Me.SqlDataAdapter6.Fill(Me.DataSet6)
            Me.Aufhebungliste.DataSource = Me.DataSet6
            Me.Aufhebungliste.DataMember = Me.DataSet6.Tables(0).TableName
            DivFnkt.SpaltenTitel_Aktualisieren(Me.Aufhebungliste, Me.DataSet6.Tables(0), "dokumenttypaufhebung")
        Catch ex As Exception
            '            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Update_RollenListe Method

Private Sub Update_RollenListe()

Source code

[Visual Basic]
    Private Sub Update_RollenListe()
        Me.DataSet2.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@dokumentstatusnr", Me.Statuslist.Columns(0).Value)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.DokumentstatusRolle_Liste.DataSource = Me.DataSet2
        Me.DokumentstatusRolle_Liste.DataMember = "dokumentstatus_funktion"
        SpaltenTitel_Aktualisieren_StatusRolle()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.Update_indexmutation Method

Private Sub Update_indexmutation()

Source code

[Visual Basic]
    Private Sub Update_indexmutation()
        Try
            Me.DataSet5.Clear()
            Me.SqlDataAdapter5.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter5.SelectCommand.Parameters.Add("@dokumenttypnr", Me.Dokumenttypnr.Text)
            Me.SqlDataAdapter5.Fill(Me.DataSet5)
            Me.indexmutationliste.DataSource = Me.DataSet5
            Me.indexmutationliste.DataMember = Me.DataSet5.Tables(0).TableName
            DivFnkt.SpaltenTitel_Aktualisieren(Me.indexmutationliste, Me.DataSet5.Tables(0), "dokumenttypindexmutation")
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnNeueRolle_Click Method

Private Sub btnNeueRolle_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnNeueRolle.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnNeueRolle_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnNeueRolle.Click
        Dim frm As New frmDomainFunktionsgruppe()
        Dim key As Long
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim vdata As New edokadb.clsDokumentstatus_funktion()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Eintragnr = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        If frm.TransferKey = 0 Then
            frm.Dispose()
            Exit Sub
            Me.cbArchiv.SelectedValue = frm.TransferKey
        End If
        dbkey.cpMainConnectionProvider = conn
        key = dbkey.get_dbkey("dokumentstatus_funktion")
        vdata.cpMainConnectionProvider = conn
        vdata.iDokumentstatus_funktionnr = New SqlInt32(CType(key, Int32))
        vdata.iDokumentstatusnr = New SqlInt32(CType(Me.Statuslist.Columns(0).Value, Int32))
        vdata.iFunktionnr = New SqlInt32(CType(frm.TransferKey, Int32))
        vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
        conn.OpenConnection()
        vdata.Insert()
        conn.CloseConnection(True)
        vdata.Dispose()
        frm.Dispose()
        Update_RollenListe()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelColdfolder_Click Method

Private Sub btnSelColdfolder_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelColdfolder.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelColdfolder_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelColdfolder.Click
        Dim frm As New frmDomainColdFolder()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        If frm.TransferKey <> 0 Then Me.cbColdFolder.SelectedValue = frm.TransferKey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelDokumentartAusgang_Click Method

Private Sub btnSelDokumentartAusgang_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelDokumentartAusgang.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelDokumentartAusgang_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelDokumentartAusgang.Click
        Dim frm As New FrmDomainDokumentart()
        frm.ToSelect = True
        frm.Transferkey = 0
        frm.showlevel = 6
        frm.Refresh()
        frm.ShowDialog()
        If frm.Transferkey <> 0 Then Me.cbDokartAusgang.SelectedValue = frm.Transferkey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelDokumentartEingang_Click Method

Private Sub btnSelDokumentartEingang_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelDokumentartEingang.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelDokumentartEingang_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelDokumentartEingang.Click
        Dim frm As New FrmDomainDokumentart()
        frm.ToSelect = True
        frm.showlevel = 7
        frm.Transferkey = 0
        frm.Refresh()
        frm.ShowDialog()
        If frm.Transferkey <> 0 Then Me.cbDokartEingang.SelectedValue = frm.Transferkey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelObNr_Click Method

Private Sub btnSelObNr_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnselobnr.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelObNr_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnselobnr.Click
        Dim frm As New frmDomainObjektbezeichnung()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        If frm.TransferKey <> 0 Then Me.cbobnr.SelectedValue = frm.TransferKey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelOfficeVorlage_Click Method

Private Sub btnSelOfficeVorlage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelOfficeVorlage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelOfficeVorlage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelOfficeVorlage.Click
        Dim frm As New frmDomainOfficeVorlage()
        frm.ToSelect = True
        frm.Eintragnr = 0
        frm.TransferKey = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        If frm.TransferKey <> 0 Then Me.cbOfficeVorlage.SelectedValue = frm.TransferKey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnSelPhysischeAblage_Click Method

Private Sub btnSelPhysischeAblage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelPhysischeAblage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelPhysischeAblage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelPhysischeAblage.Click
        Dim frm As New frmDomainPhsischesArchiv()
        frm.ToSelect = True
        frm.TransferKey = 0
        frm.Eintragnr = 0
        frm.Refresh()
        frm.Owner = Me
        frm.ShowDialog()
        If frm.TransferKey <> 0 Then Me.cbArchiv.SelectedValue = frm.TransferKey
        frm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnVorlagenfeld_Click Method

Private Sub btnVorlagenfeld_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnVorlagenfeld_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnVorlagenfeld_Click_1 Method

Private Sub btnVorlagenfeld_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnVorlagenfeld.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnVorlagenfeld_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnVorlagenfeld.Click
        Dim i As Long
        Dim x, y As Long
        Dim frm As New frmDomainVorlagenfeldregel()
        frm.ToSelect = True
        frm.Eintragnr = 0
        frm.TransferKey = 0
        frm.ShowDialog()
        For i = 1 To frm.cTransferkey.Count
            Insert_Vorlagenfeld(frm.cTransferkey.Item(i))
        Next
        save_vorlagenfeldlist()
        y = 0
        For i = 0 To Me.vorlagenfeldlist.Splits(0).Rows.Count - 1
            x = Me.vorlagenfeldlist.Columns(0).CellText(i)
            If x > y Then
                Me.vorlagenfeldlist.Bookmark = i
                y = x
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnsave_Click Method

Private Sub btnsave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnsave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnsave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnsave.Click
        Save_Statusdata()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.btnsavevorlagenfeldlist_Click Method

Private Sub btnsavevorlagenfeldlist_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnsavevorlagenfeldlist.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnsavevorlagenfeldlist_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnsavevorlagenfeldlist.Click
        save_vorlagenfeldlist()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cZuRetournieren_CheckedChanged Method

Private Sub cZuRetournieren_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cZuRetournieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cZuRetournieren_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cZuRetournieren.Click
        If Me.cZuRetournieren.Checked = True And Me.cZuRetournieren.Enabled = True Then
            Me.cbDokartEingang.Enabled = True
            Me.cbMonierung.Enabled = True
            Me.cbAufbewahrungphysisch.Enabled = True
            Me.btnSelDokumentartEingang.Enabled = True
            Me.cEingangErsetztAusgang.Enabled = True
            Me.cbArchiv.Enabled = True
            Me.btnSelPhysischeAblage.Enabled = True
        Else
            Me.cbMonierung.Enabled = False
            Me.cbAufbewahrungphysisch.Enabled = False
            Me.cbDokartEingang.Enabled = False
            Me.btnSelDokumentartEingang.Enabled = False
            Me.cEingangErsetztAusgang.Enabled = False
            Me.cbArchiv.Enabled = False
            Me.btnSelPhysischeAblage.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cZuRetournieren_CheckedChanged_1 Method

Private Sub cZuRetournieren_CheckedChanged_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cZuRetournieren.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cZuRetournieren_CheckedChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cZuRetournieren.CheckedChanged
        If Me.cZuRetournieren.Checked Then
            Me.mcbbedingteretournierung.SelectedValue = 0
            Me.mcbbedingteretournierung.Enabled = False
        Else
            Me.mcbbedingteretournierung.SelectedValue = 0
            Me.mcbbedingteretournierung.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cZuVercolden_CheckedChanged Method

Private Sub cZuVercolden_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cZuVercolden.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cZuVercolden_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cZuVercolden.Click
        If Me.cZuVercolden.Checked = True And Me.cZuVercolden.Enabled = True Then
            Me.cbDokartAusgang.Enabled = True
            Me.btnSelDokumentartAusgang.Enabled = True
            Me.cZuRetournieren.Enabled = True
            Me.mcbbedingteretournierung.Enabled = True
            Me.cbColdFolder.Enabled = True
            Me.cbobnr.Enabled = True
            Me.btnSelColdfolder.Enabled = True
            Me.btnselobnr.Enabled = True
        Else
            Me.cbDokartAusgang.Enabled = False
            Me.btnSelDokumentartAusgang.Enabled = False
            Me.cZuRetournieren.Enabled = False
            Me.cbDokartEingang.Enabled = False
            Me.btnSelDokumentartEingang.Enabled = False
            Me.cbColdFolder.Enabled = False
            Me.cbobnr.Enabled = False
            Me.btnselobnr.Enabled = False
            Me.btnSelColdfolder.Enabled = False
            Me.cEingangErsetztAusgang.Enabled = False
            Me.cbArchiv.Enabled = False
            Me.btnSelPhysischeAblage.Enabled = False
        End If
        If Me.cWirdImportiert.Checked = True Then
            Me.cZuRetournieren.Enabled = False
            Me.mcbbedingteretournierung.Enabled = False
            Me.cZuRetournieren.Checked = False
            Me.cbDokartEingang.Enabled = False
            Me.cEingangErsetztAusgang.Checked = False
            Me.cEingangErsetztAusgang.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.camsdokument_click Method

Private Sub camsdokument_click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cAMSDokument.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub camsdokument_click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cAMSDokument.Click
        If Me.cAMSDokument.Checked And Me.cDokumentwirderstellt.Checked = False Then
        Else
            Me.GroupBox1.Enabled = True
            Me.GroupBox2.Enabled = True
            Me.GroupBox3.Enabled = True
            Me.txthostdokumenttyp.Enabled = False
            Me.txthostdokumenttyp.Text = ""
            Me.RBKundendossier.Checked = True
            Me.RBHost.Checked = False
            Me.RBHost.Visible = False
            Handle_StrukturRadiobuttons(sender, e)
            If Me.cDokumentwirderstellt.Checked = True Then
                Me.cWirdImportiert.Enabled = True
                Me.cHostDokument.Enabled = False
            Else
                Me.cWirdImportiert.Enabled = True
                Me.cHostDokument.Enabled = True
            End If
            Me.cDokumentwirderstellt.Enabled = True
            Me.CDokumentwirdretourniert.Enabled = True
            Me.mcbbedingteretournierung.Enabled = True

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cbAufbewahrungelektronisch_SelectedIndexChanged Method

Private Sub cbAufbewahrungelektronisch_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbAufbewahrungelektronisch.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbAufbewahrungelektronisch_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbAufbewahrungelektronisch.SelectedIndexChanged
        'Me.cbAufbewahrungphysisch.SelectedIndex = Me.cbAufbewahrungelektronisch.SelectedIndex
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cbAufbewahrungphysisch_SelectedIndexChanged Method

Private Sub cbAufbewahrungphysisch_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbAufbewahrungphysisch.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbAufbewahrungphysisch_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbAufbewahrungphysisch.SelectedIndexChanged
        'Me.cbAufbewahrungelektronisch.SelectedIndex = Me.cbAufbewahrungphysisch.SelectedIndex
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cbKDE_CheckedChanged Method

Private Sub cbKDE_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbKDE.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbKDE_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbKDE.CheckedChanged
        If Me.cbKDE.Checked = True Then
            If Me.cbArchiv.Enabled = False Then Me.cbArchiv.Enabled = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cbStatustyp_SelectedIndexChanged Method

Private Sub cbStatustyp_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbStatustyp.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbStatustyp_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbStatustyp.SelectedValueChanged
        Dim dstatus As New edokadb.clsMyDokumentstatus()
        If me_onLoad Then
            Exit Sub
        End If
        If Me.DokStatus = 0 Then
            Me.txtDokumentstatus.Text = Me.cbStatustyp.SelectedValue
        Else
            Me.txtDokumentstatus_barcode.Text = Me.cbStatustyp.SelectedValue
        End If
        If Me.cbStatustyp.SelectedValue = 0 And Me.savestatustyp <> Me.cbStatustyp.SelectedValue Then
            If MyMsg.Show_MessageYesNo(7) = MsgBoxResult.Yes Then
                dstatus.Dokumenttypnr = Me.DokumentTypkey
                dstatus.Statustypnr = Me.savestatustyp
                conn.OpenConnection()
                dstatus.cpMainConnectionProvider = conn
                dstatus.DeleteDokumentstatus()
                conn.CloseConnection(True)
                Load_Dokumentstatus()
                Save_Data()
                Me.savestatustyp = Me.cbStatustyp.SelectedValue
            Else
                Me.cbStatustyp.SelectedValue = Me.savestatustyp
            End If
        End If
        If Me.cbStatustyp.SelectedValue <> Me.savestatustyp Then
            If Me.savestatustyp <> 0 Then
                If MyMsg.Show_MessageYesNo(8) = MsgBoxResult.No Then
                    Me.cbStatustyp.SelectedValue = Me.savestatustyp
                    Exit Sub
                End If
            End If
            dstatus.cpMainConnectionProvider = conn
            conn.OpenConnection()
            dstatus.Dokumenttypnr = Me.DokumentTypkey
            dstatus.Statustypnr = Me.cbStatustyp.SelectedValue
            dstatus.Statustyp = Me.DokStatus
            Me.savestatustyp = Me.cbStatustyp.SelectedValue
            Try
                dstatus.InsertDokumentstatus()
            Catch ex As Exception
                MsgBox(ex.Message)
            Finally
                conn.CloseConnection(True)
            End Try
            Load_Dokumentstatus()
            dstatus.Dispose()
            Save_Data()
            Me.savestatustyp = Me.cbStatustyp.SelectedValue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cbsb_CheckedChanged Method

Private Sub cbsb_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbsb.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbsb_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbsb.CheckedChanged
        If Me.cbsb.Checked = True Then
            Me.cbsbnur.Enabled = True
            Me.cbsbedituser.Enabled = True
            Me.cbsbimport.Enabled = True
        Else
            Me.cbsbedituser.Checked = False
            Me.cbsbimport.Checked = False
            Me.cbsbnur.Checked = False
            Me.cbsbedituser.Enabled = False
            Me.cbsbimport.Enabled = False
            Me.cbsbnur.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.chostdokument_click Method

Private Sub chostdokument_click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cHostDokument.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub chostdokument_click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cHostDokument.Click
        If Me.cHostDokument.Checked = False Then
            Me.txthostdokumenttyp.Text = ""
            Me.txthostdokumenttyp.Enabled = False
            Me.cDokumentwirderstellt.Enabled = True
            Me.cWirdImportiert.Enabled = True
            Me.cAMSDokument.Enabled = True
            Me.CDokumentwirdretourniert.Enabled = True
            Me.mcbbedingteretournierung.Enabled = True
            Me.GroupBox1.Enabled = True
            Me.GroupBox2.Enabled = True
            Me.GroupBox3.Enabled = True
            Me.txthostdokumenttyp.Enabled = False
            Me.txthostdokumenttyp.Text = ""
            Me.RBKundendossier.Checked = True
            Me.RBHost.Checked = False
            Me.RBHost.Visible = False
            Handle_StrukturRadiobuttons(sender, e)
            Me.cWirdImportiert.Enabled = True
            Me.cAMSDokument.Enabled = True
            Me.cDokumentwirderstellt.Enabled = True
            Me.rbDokStatusStandard.Enabled = True
            Me.cbStatustyp.Enabled = True
            Me.TabControl1.TabPages(1).Enabled = True
            Me.TabControl1.TabPages(2).Enabled = True

            SetFields(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.cidvnative_CheckedChanged Method

Private Sub cidvnative_CheckedChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cidvnative.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cidvnative_CheckedChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cidvnative.CheckedChanged
        If Me.cidvnative.Checked Then
            Me.RBKundendossier.Visible = False
            Me.RBEinzeldokumente.Visible = True
            Me.RBEinzeldokumente.Checked = True
            Me.TxtDokumentartKundendossier.Text = "0"
        Else
            Me.RBKundendossier.Visible = True
            Me.RBEinzeldokumente.Visible = False
            Me.RBKundendossier.Checked = True
            Me.txtDokumentartEinzeldokument.Text = "0"
        End If

        Me.Handle_StrukturRadiobuttons(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.fields_Dokumentwirderstellt_retournierung Method

Private Sub fields_Dokumentwirderstellt_retournierung()

Source code

[Visual Basic]
    Private Sub fields_Dokumentwirderstellt_retournierung()
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = True
        Me.cUnterschriftrechts.Enabled = True
        Me.CDokumentersetzen.Enabled = True
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = True
        Me.cFunktion_zuweisen.Enabled = True
        Me.cbBearbeitungszeit.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cbAbschluss.Enabled = True
        Me.cbInEdokaDB.Enabled = True

        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True
        Me.rbEtikette.Enabled = True

        'Default setzen
        If neu Then
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cStatusMutation.Checked = True
            Me.cidvnative.Checked = False
            Me.cbDokartAusgang.SelectedIndex = 1
            Me.cbDokartEingang.SelectedIndex = 1
            Me.cbColdFolder.SelectedIndex = 1
            Me.cbArchiv.SelectedIndex = 1
            Me.cUnterschriftlinks.Checked = True
            Me.cUnterschriftrechts.Checked = True
            Me.cZuVercolden.Checked = False
            Me.cZuRetournieren.Checked = False
            Me.cEmailVersand.Checked = False
            Me.cFunktion_zuweisen.Checked = False

            Me.cZuVercolden.Enabled = True
            Me.cZuVercolden.Checked = True
            Me.cZuRetournieren.Enabled = True
            Me.cZuRetournieren.Checked = True
            Me.cEingangErsetztAusgang.Enabled = False
            Me.cbArchiv.Enabled = False
            Me.cbDokartAusgang.Enabled = False
        End If
        Me.cidvnative.Enabled = False
        Me.cidvnative.Checked = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.fields_Dokumentwirdimportiert Method

Private Sub fields_Dokumentwirdimportiert()

Source code

[Visual Basic]
    Private Sub fields_Dokumentwirdimportiert()
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = True
        Me.cUnterschriftrechts.Enabled = True
        Me.CDokumentersetzen.Enabled = True
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = True
        Me.cFunktion_zuweisen.Enabled = True
        Me.cUnterschriftlinks.Checked = True
        Me.cUnterschriftrechts.Checked = True
        Me.cStatusMutation.Checked = True
        Me.cbBearbeitungszeit.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cbAbschluss.Enabled = True
        Me.cbInEdokaDB.Enabled = True
        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True
        Me.cZuVercolden.Enabled = True
        Me.cZuRetournieren.Enabled = True
        Me.cEingangErsetztAusgang.Enabled = True
        Me.cbDokartAusgang.Enabled = True
        Me.cbDokartEingang.Enabled = True
        Me.cbArchiv.Enabled = True
        Me.cidvnative.Checked = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.fields_Dokumentwirdretourniert Method

Private Sub fields_Dokumentwirdretourniert()

Source code

[Visual Basic]
    Private Sub fields_Dokumentwirdretourniert()
        Me.cbVertrag.Enabled = True
        Me.cStatusMutation.Enabled = True
        Me.cNichtgeloescht.Enabled = True
        Me.cUnterschriftlinks.Enabled = False
        Me.cUnterschriftrechts.Enabled = False
        Me.CDokumentersetzen.Enabled = True
        Me.cVertraulich.Enabled = True
        Me.cEmailVersand.Enabled = False
        Me.cFunktion_zuweisen.Enabled = False

        Me.cUnterschriftlinks.CheckState = CheckState.Unchecked
        Me.cUnterschriftrechts.CheckState = CheckState.Unchecked
        '        Me.CDokumentersetzen.CheckState = CheckState.Unchecked
        Me.cEmailVersand.CheckState = CheckState.Unchecked
        Me.cFunktion_zuweisen.CheckState = CheckState.Unchecked

        Me.cbBearbeitungszeit.Enabled = True
        Me.cbMonierung.Enabled = True
        Me.cbAbschluss.Enabled = False
        Me.cbAbschluss.Text = ""
        Me.cbInEdokaDB.Enabled = True
        Me.cbAufbewahrungelektronisch.Enabled = True
        Me.cbAufbewahrungphysisch.Enabled = True

        Me.cZuVercolden.CheckState = CheckState.Unchecked
        Me.cZuVercolden.Enabled = False
        Me.cZuRetournieren.CheckState = CheckState.Checked
        Me.cZuRetournieren.Enabled = False
        Me.cEingangErsetztAusgang.Enabled = False
        Me.cbDokartAusgang.Enabled = False
        Me.cbDokartEingang.Enabled = True
        Me.cbColdFolder.Enabled = True
        Me.cbobnr.Enabled = True
        Me.cbArchiv.Enabled = True
        Me.rbEtikette.Enabled = True

        Me.cbArchiv.Enabled = True
        Me.cidvnative.CheckState = CheckState.Unchecked
        Me.cidvnative.Enabled = False

        Me.cFunktion_zuweisen.Enabled = True

        If neu Then
            Me.cEingangErsetztAusgang.CheckState = CheckState.Unchecked
            Me.CDokumentersetzen.Checked = False
            Me.cFunktion_zuweisen.Checked = False
            Me.cbDokartAusgang.SelectedIndex = 1
            Me.cbDokartEingang.SelectedIndex = 1
            Me.cbColdFolder.SelectedIndex = 1
            Me.cbArchiv.SelectedIndex = 1
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.fields_hostdokument Method

Private Sub fields_hostdokument( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub fields_hostdokument(ByVal sender As Object, ByVal e As System.EventArgs)
        Me.RBKundendossier.Checked = True
        Me.TabControl1.TabPages(1).Enabled = True
        Me.TabControl1.TabPages(2).Enabled = True
        Me.pnlVorlagenfeld.Enabled = True
        Me.TabDokumentfelder.Enabled = True
        Me.RBKundendossier.Visible = True
        Me.RBHost.Visible = False
        Me.RBHost.Checked = False

        'Formatierung für HOST-Dokumente
        Me.cbStatustyp.SelectedValue = 0
        cbStatustyp_SelectedIndexChanged(sender, e)
        Me.txthostdokumenttyp.Enabled = True
        Me.RBKundendossier.Checked = False
        Me.RBKundendossier.Visible = False
        Me.RBHost.Visible = True
        Me.RBHost.Checked = True
        Handle_StrukturRadiobuttons(sender, e)
        Me.cWirdImportiert.Checked = False
        Me.cWirdImportiert.Enabled = False
        Me.cAMSDokument.Checked = False
        Me.cAMSDokument.Enabled = False
        Me.cDokumentwirderstellt.Enabled = False
        Me.cDokumentwirderstellt.Checked = False
        Me.pnlVorlagenfeld.Enabled = False
        Me.TabControl1.TabPages(1).Enabled = False
        Me.TabControl1.TabPages(2).Enabled = False
        Me.CDokumentwirdretourniert.Enabled = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.frmDomainDokumenttypDetail_Closing Method

Private Sub frmDomainDokumenttypDetail_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainDokumenttypDetail_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Check_Status() = False Then
            MyMsg.show_standardmessage(238, MsgBoxStyle.Information)
            e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.frmDomainDokumenttypDetail_Load Method

Private Sub frmDomainDokumenttypDetail_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainDokumenttypDetail_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        me_onLoad = True
        DataChanged = False
        Dim tn As TreeNode
        Load_Listen()
        If Me.NeuerEintrag = False Then
            neu = False
            Me.On_Load = True
            Load_Data()
            Me.On_Load = False
        Else
            neu = True
            init_fields()
            Me.TxtDokumentartKundendossier.Text = 0
            Me.TxtDokumentartErstellung.Text = 0
            Me.TxtDokumentartHost.Text = 0
            Me.TxTDokumentartRetournierung.Text = 0
            Me.TxtDokumentartGesamt.Text = 0
            Me.txtDokumentstatus_barcode.Text = 0
            Me.txtDokumentartEinzeldokument.Text = 0
            Me.txtDokumentstatus.Text = Me.cbStatustyp.SelectedValue
            Me.cbBearbeitungszeit.Text = 1
            Me.cbAufbewahrungelektronisch.Text = 10
            Me.cbAufbewahrungphysisch.Text = 10
            Me.cbInEdokaDB.Text = 3
            Me.cbMonierung.Text = 3
            Me.cbAbschluss.Text = 5
            Me.cAktiv.Checked = True
        End If
        If Me.cidvnative.Checked Then Me.RBEinzeldokumente.Checked = True Else Me.RBKundendossier.Checked = True
        Me.DokStatus = 0
        Load_Dokumentstatus()
        Me.savestatustyp = Me.cbStatustyp.SelectedValue
        Me.StatusDataChanged = False
        Me.DataChanged = False
        Me.VorlagenDataChanged = False
        SetFields(sender, e)
        Me.dokumentinfomeldungen = Me.Dokumentinfomeldungen_laden
        Me.InfomeldungList.DataSource = Me.dokumentinfomeldungen
        Me.InfomeldungList.Columns(8).FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfomeldungList, Me.dokumentinfomeldungen, "Dokumentinfomeldung")
        me_onLoad = False
        set_tooltips()
        Update_Aufhebungliste()
        Update_indexmutation()
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            Me.Label6.Visible = True
            Me.Label27.Visible = True
            Me.cbColdFolder.Visible = True
            Me.cbobnr.Visible = True
            Me.btnSelColdfolder.Visible = True
            Me.btnselobnr.Visible = True
        End If
        If Me.cbKDE.Checked = True Then Me.cbArchiv.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.init_fields Method

Private Sub init_fields()

Source code

[Visual Basic]
    Private Sub init_fields()
        Me.cbVertrag.Enabled = False
        Me.cStatusMutation.Enabled = False
        Me.cNichtgeloescht.Enabled = False
        Me.cUnterschriftlinks.Enabled = False
        Me.cUnterschriftrechts.Enabled = False
        '        Me.CDokumentersetzen.Enabled = False
        Me.cVertraulich.Enabled = False
        Me.cEmailVersand.Enabled = False
        Me.cFunktion_zuweisen.Enabled = False
        Me.cUnterschriftlinks.Checked = False
        Me.cUnterschriftrechts.Checked = False
        Me.cStatusMutation.Checked = False
        Me.cbBearbeitungszeit.Enabled = False
        Me.cbMonierung.Enabled = False
        Me.cbAbschluss.Enabled = False
        Me.cbInEdokaDB.Enabled = False
        Me.cbAufbewahrungelektronisch.Enabled = False
        Me.cbAufbewahrungphysisch.Enabled = False
        Me.cZuVercolden.Enabled = False
        Me.cZuRetournieren.Enabled = False
        Me.cEingangErsetztAusgang.Enabled = False
        Me.cbDokartAusgang.Enabled = False
        Me.cbDokartEingang.Enabled = False
        Me.cbArchiv.Enabled = False
        If Not Me.cidvnative.Checked = True Then Me.cidvnative.Checked = False

        Me.cZuVercolden.Enabled = False
        Me.cbDokartAusgang.Enabled = False
        Me.cbColdFolder.Enabled = False
        Me.cbobnr.Enabled = False

        Me.cUnterschriftlinks.Checked = False
        Me.cUnterschriftrechts.Checked = False
        Me.cZuVercolden.Checked = False
        Me.CDokumentersetzen.Checked = False
        Me.cEmailVersand.Checked = False
        Me.cFunktion_zuweisen.Checked = False
        Me.cEingangErsetztAusgang.Checked = False
        Me.cbtagebedr.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.insert_dokumentmutation Method

Private Sub insert_dokumentmutation( _
   ByVal type As Integer _
)

Parameters

type
Required.

Source code

[Visual Basic]
    Private Sub insert_dokumentmutation(ByVal type As Integer)
        'Dim ud As New edokadb.clsUpdate_Dokument_Indexmutation_Loeschung()
        'ud.cpMainConnectionProvider = conn
        'If type = 1 Then
        '    ud.bLoeschung = New SqlBoolean(CType(False, Boolean))
        '    ud.bIndexmutation = New SqlBoolean(CType(True, Boolean))
        'Else
        '    ud.bLoeschung = New SqlBoolean(CType(True, Boolean))
        '    ud.bIndexmutation = New SqlBoolean(CType(False, Boolean))
        'End If
        'ud.daStatusdatum = New SqlDateTime(CType(Now, DateTime))
        'ud.iStatus = New SqlInt32(CType(0, Int32))
        'ud.iDokumenttypnr = New SqlInt32(CType(Me.DokumentTypkey, Int32))
        'ud.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        'conn.OpenConnection()
        'ud.Insert()
        'conn.CloseConnection(True)
        'ud.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.insert_german Method

Private Sub insert_german()

Source code

[Visual Basic]
    Private Sub insert_german()
        Dim vb As New edokadb.clsVorlagenfeldbezeichnung()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        key = dbkey.get_dbkey("vorlagenfeldbezeichnung")
        vb.cpMainConnectionProvider = conn
        vb.iVorlagenfeldbezeichnungnr = New SqlInt32(CType(key, Int32))
        vb.iVorlagenfeld = New SqlInt32(CType(Me.vorlagenfeldlist.Columns(0).Value, Int32))
        vb.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        vb.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        vb.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        vb.iSprache = New SqlInt32(CType(1, Int32))
        conn.OpenConnection()
        vb.Insert()
        conn.CloseConnection(True)
        vb.Dispose()
        dbkey.Dispose()
        Me.DataSet3.Tables.Clear()
        Me.SqlDataAdapter3.Fill(Me.DataSet3)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.rbDokStatusStandard_CheckedChanged Method

Private Sub rbDokStatusStandard_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbDokStatusStandard.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbDokStatusStandard_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbDokStatusStandard.CheckedChanged
        Change_Dokstatus(0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.rbDokStatusStandard_Click Method

Private Sub rbDokStatusStandard_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbDokStatusStandard.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbDokStatusStandard_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbDokStatusStandard.Click
        If Me.rbDokStatusStandard.Checked Then
            Me.cbStatustyp.SelectedValue = Me.txtDokumentstatus.Text
            Save_Rollenliste()
            Load_Dokumentstatus()
            Update_RollenListe()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.rbEtikette_CheckedChanged Method

Private Sub rbEtikette_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbEtikette.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbEtikette_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbEtikette.CheckedChanged
        Change_Dokstatus(1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.rbEtikette_Click Method

Private Sub rbEtikette_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles rbEtikette.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbEtikette_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles rbEtikette.Click
        If Me.rbEtikette.Checked Then
            Me.cbStatustyp.SelectedValue = Me.txtDokumentstatus_barcode.Text
            Save_Rollenliste()
            Load_Dokumentstatus()
            Update_RollenListe()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.save_vorlagenfeldlist Method

Private Sub save_vorlagenfeldlist()

Source code

[Visual Basic]
    Private Sub save_vorlagenfeldlist()
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
        End Try
        Me.VorlagenDataChanged = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.set_tooltips Method

Private Sub set_tooltips()

Source code

[Visual Basic]
    Private Sub set_tooltips()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbOfficeVorlage, Globals.MyTxt.gettext(20000))
        ttip.SetToolTip(Me.TxTBezeichnung, Globals.MyTxt.gettext(20001))
        ttip.SetToolTip(Me.TxTBeschreibung, Globals.MyTxt.gettext(20002))
        ttip.SetToolTip(Me.cDokumentwirderstellt, Globals.MyTxt.gettext(20003))
        ttip.SetToolTip(Me.cAMSDokument, Globals.MyTxt.gettext(20004))
        ttip.SetToolTip(Me.cHostDokument, Globals.MyTxt.gettext(20005))
        ttip.SetToolTip(Me.txthostdokumenttyp, Globals.MyTxt.gettext(20006))
        ttip.SetToolTip(Me.cWirdImportiert, Globals.MyTxt.gettext(20007))
        ttip.SetToolTip(Me.CDokumentwirdretourniert, Globals.MyTxt.gettext(20008))
        ttip.SetToolTip(Me.cZuVercolden, Globals.MyTxt.gettext(20009))
        ttip.SetToolTip(Me.cbDokartAusgang, Globals.MyTxt.gettext(20010))
        ttip.SetToolTip(Me.cZuRetournieren, Globals.MyTxt.gettext(20011))
        ttip.SetToolTip(Me.cbDokartEingang, Globals.MyTxt.gettext(20012))
        ttip.SetToolTip(Me.cEingangErsetztAusgang, Globals.MyTxt.gettext(20013))
        ttip.SetToolTip(Me.cbColdFolder, Globals.MyTxt.gettext(20014))
        ttip.SetToolTip(Me.cbobnr, Globals.MyTxt.gettext(20040))
        ttip.SetToolTip(Me.cbArchiv, Globals.MyTxt.gettext(20015))
        ttip.SetToolTip(Me.cStatusMutation, Globals.MyTxt.gettext(20016))
        ttip.SetToolTip(Me.cNichtgeloescht, Globals.MyTxt.gettext(20017))
        ttip.SetToolTip(Me.cVertraulich, Globals.MyTxt.gettext(20018))
        ttip.SetToolTip(Me.cUnterschriftlinks, Globals.MyTxt.gettext(20019))
        ttip.SetToolTip(Me.cUnterschriftrechts, Globals.MyTxt.gettext(20020))
        ttip.SetToolTip(Me.CDokumentersetzen, Globals.MyTxt.gettext(20021))
        ttip.SetToolTip(Me.cbBearbeitungszeit, Globals.MyTxt.gettext(20022))
        ttip.SetToolTip(Me.cbMonierung, Globals.MyTxt.gettext(20023))
        ttip.SetToolTip(Me.cbAbschluss, Globals.MyTxt.gettext(20024))
        ttip.SetToolTip(Me.cbInEdokaDB, Globals.MyTxt.gettext(20025))
        ttip.SetToolTip(Me.cbAufbewahrungelektronisch, Globals.MyTxt.gettext(20026))
        ttip.SetToolTip(Me.cbAufbewahrungphysisch, Globals.MyTxt.gettext(20027))
        ttip.SetToolTip(Me.cbprozesserstellung, Globals.MyTxt.gettext(20028))
        ttip.SetToolTip(Me.cbprozessverwendung, Globals.MyTxt.gettext(20029))
        ttip.SetToolTip(Me.cAktiv, Globals.MyTxt.gettext(20030))
        ttip.SetToolTip(Me.TVStruktur, Globals.MyTxt.gettext(20031))
        ttip.SetToolTip(Me.cbStatustyp, Globals.MyTxt.gettext(20032))
        ttip.SetToolTip(Me.Statuslist, Globals.MyTxt.gettext(20033))
        ttip.SetToolTip(Me.DokumentstatusRolle_Liste, Globals.MyTxt.gettext(20034))
        ttip.SetToolTip(Me.cFunktion_zuweisen, Globals.MyTxt.gettext(20035))
        ttip.SetToolTip(Me.cEmailVersand, Globals.MyTxt.gettext(20036))
        ttip.SetToolTip(Me.rbDokStatusStandard, MyTxt.gettext(20037))
        ttip.SetToolTip(Me.rbEtikette, MyTxt.gettext(20038))
        ttip.SetToolTip(Me.cidvnative, MyTxt.gettext(20039))
        ttip.SetToolTip(Me.cbVertrag, MyTxt.gettext(20041))
        ttip.SetToolTip(Me.cbbedingteretournierung, MyTxt.gettext(20042))
        ttip.SetToolTip(Me.cbtagebedr, MyTxt.gettext(20043))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.update_vorlagenfelder Method

Private Sub update_vorlagenfelder()

Source code

[Visual Basic]
    Private Sub update_vorlagenfelder()
        Dim i As Integer
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@Dokumenttypnr", CType(Me.DokumentTypkey, Int32))
        Try
            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Catch
        End Try
        Try
            Me.DataSet1.Clear()
            Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        Me.vorlagenfeldlist.DataSource = Me.DataSet1
        Me.vorlagenfeldlist.DataMember = "vorlagenfeld"
        Me.vorlagenfeldlist.Columns("aktiv").FilterText = True
        SpaltenTitel_Aktualisieren1()

        If Me.cbColdFolder.Enabled = True Then
            Me.SqlDataAdapter4.SelectCommand.Parameters("@foldernr").Value = Me.cbColdFolder.SelectedValue
            Me.SqlDataAdapter4.Fill(Me.DataSet4)
            Me.ColdIndexfeldList.DataSource = Me.DataSet4

            Me.ColdIndexfeldList.DataMember = "ColdIndex"
            Me.ColdIndexfeldList.Columns(0).Caption = Globals.MyTxt.Get_Meldungstext(7018)
            Me.ColdIndexfeldList.Columns(1).Caption = Globals.MyTxt.Get_Meldungstext(7019)
            Me.vorlagenfeldlist.Columns("cold_indexfeld").DropDown = Me.ColdIndexfeldList
        Else
            For i = 0 To Me.vorlagenfeldlist.Columns.Count - 1
                If Me.vorlagenfeldlist.Columns(i).DataField = "cold_indexfeld" Then
                    Me.vorlagenfeldlist.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.vorlagenfeldbezeichnunglist_aftercellupdate Method

Private Sub vorlagenfeldbezeichnunglist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles vorlagenfeldbezeichnunglist.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vorlagenfeldbezeichnunglist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles vorlagenfeldbezeichnunglist.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.vorlagenfeldbezeichnunglist.Columns.Count - 1
                If Me.vorlagenfeldbezeichnunglist.Columns(i).DataField = "mutiert_am" Then Me.vorlagenfeldbezeichnunglist.Columns(i).Value = Now
                If Me.vorlagenfeldbezeichnunglist.Columns(i).DataField = "mutierer" Then Me.vorlagenfeldbezeichnunglist.Columns(i).Value = Globals.MitarbeiterNr
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.vorlagenfeldbezeichnunglist.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey("vorlagenfeldbezeichnunglist")
                Me.vorlagenfeldbezeichnunglist.Columns(0).Value = key
                For i = 0 To Me.vorlagenfeldbezeichnunglist.Columns.Count - 1
                    If Me.vorlagenfeldbezeichnunglist.Columns(i).DataField = "mandantnr" Then
                        Me.vorlagenfeldbezeichnunglist.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.vorlagenfeldbezeichnunglist_update Method

Private Sub vorlagenfeldbezeichnunglist_update()

Source code

[Visual Basic]
    Private Sub vorlagenfeldbezeichnunglist_update()
        If Me.DataSet3.HasChanges Then
            Try
                Me.SqlDataAdapter3.Update(Me.DataSet3)
            Catch
            End Try
        End If
        Me.DataSet3.Clear()
        If Me.vorlagenfeldlist.Columns("userinterface").Value = True Then
            Me.SqlDataAdapter3.SelectCommand.Parameters("@vorlagenfeld").Value = Me.vorlagenfeldlist.Columns(0).Value
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
            If Me.DataSet3.Tables(0).Rows.Count < 1 Then
                insert_german()
            End If
            Me.vorlagenfeldbezeichnunglist.DataSource = Me.DataSet3
            Me.vorlagenfeldbezeichnunglist.DataMember = "Vorlagenfeldbezeichnung"
            SpaltenTitel_Aktualisieren2()
            '            Me.vorlagenfeldbezeichnunglist.AllowAddNew = True
        Else
            '           Me.vorlagenfeldbezeichnunglist.AllowAddNew = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.vorlagenfeldlist_MouseUp Method

Private Sub vorlagenfeldlist_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles vorlagenfeldlist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vorlagenfeldlist_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles vorlagenfeldlist.MouseUp
        vorlagenfeldbezeichnunglist_update()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.vorlagenfeldlist_RowColChange Method

Private Sub vorlagenfeldlist_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles vorlagenfeldlist.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vorlagenfeldlist_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles vorlagenfeldlist.RowColChange
        Try
            Me.vorlagenfeldbezeichnunglist_update()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail.vorlagenfeldlist_aftercellupdate Method

Private Sub vorlagenfeldlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles vorlagenfeldlist.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vorlagenfeldlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles vorlagenfeldlist.AfterColEdit
        Try
            Dim i As Integer
            For i = 0 To Me.vorlagenfeldlist.Columns.Count - 1
                If Me.vorlagenfeldlist.Columns(i).DataField = "mutiert_am" Then Me.vorlagenfeldlist.Columns(i).Value = Now
                If Me.vorlagenfeldlist.Columns(i).DataField = "mutierer" Then Me.vorlagenfeldlist.Columns(i).Value = Globals.MitarbeiterNr
                Me.VorlagenDataChanged = True
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainDokumenttypDetail Fields

frmDomainDokumenttypDetail overview

Fields

field Aufhebungliste
field BeschrausOV
field BtnHelp
field BtnSaveRollen
field BtnStandard
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field CDokumentersetzen
field CDokumentwirdretourniert
field ColdIndexfeldList
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field DataChanged
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field DataSet6
field DokStatus
field DokumentstatusRolle_Liste
field Dokumenttypnr
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field Grp1
field ImageList1
field ImageList2
field IndexMutationNachAbschluss
field InfomeldungList
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LoeschungNachAbschluss
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MnuDokZuordnungauheben
field On_Load
field Panel1
field Panel2
field Panel3
field RBEingang
field RBEinzeldokumente
field RBErstellung
field RBGesamt
field RBHost
field RBKundendossier
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDataAdapter5
field SqlDataAdapter6
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlSelectCommand6
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field StatusDataChanged
field Statuslist
field TVStruktur
field TabControl1
field TabDokumentfelder
field TabPage1
field TabPage2
field TabStatusreihenfolge
field TabStruktur
field TbSerienbrief
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolTip1
field TxTBeschreibung
field TxTBezeichnung
field TxTDokumentartRetournierung
field TxtDokumentartErstellung
field TxtDokumentartGesamt
field TxtDokumentartHost
field TxtDokumentartKundendossier
field VorlagenDataChanged
field btnNeueRolle
field btnSelColdfolder
field btnSelDokumentartAusgang
field btnSelDokumentartEingang
field btnSelOfficeVorlage
field btnSelPhysischeAblage
field btnVorlagenfeld
field btnsave
field btnsavevorlagenfeldlist
field btnselobnr
field cAMSDokument
field cAktiv
field cDokumentwirderstellt
field cEingangErsetztAusgang
field cEmailVersand
field cFunktion_zuweisen
field cHostDokument
field cNichtgeloescht
field cStatusMutation
field cUnterschriftlinks
field cUnterschriftrechts
field cVertraulich
field cWirdImportiert
field cZuRetournieren
field cZuVercolden
field cbAbschluss
field cbAnzeige
field cbArchiv
field cbAufbewahrungelektronisch
field cbAufbewahrungphysisch
field cbBearbeitungszeit
field cbColdFolder
field cbDokartAusgang
field cbDokartEingang
field cbInEdokaDB
field cbKDE
field cbMonierung
field cbOfficeVorlage
field cbOwner
field cbStatustyp
field cbVertrag
field cbbedingteretournierung
field cbedingtretournierbar
field cbezmut
field cbobnr
field cbprozesserstellung
field cbprozessverwendung
field cbsb
field cbsbedituser
field cbsbimport
field cbsbnur
field cbtagebedr
field cidvnative
field components
field dokumentart
field dokumentinfomeldungen
field indexmutationliste
field m_NeuerEintrag
field m_dokumenttypkey
field mcbbedingteretournierung
field mcbowner
field me_onLoad
field neu
field pnlVorlagenfeld
field r
field rbDokStatusStandard
field rbEtikette
field savestatustyp
field t
field tcoldfolder
field tdokumentartausgang
field tdokumentarteingang
field tobnr
field tofficevorlage
field tphysischesarchiv
field tprozess1
field tprozess2
field tstatustyp
field txtDokumentartEinzeldokument
field txtDokumentstatus
field txtDokumentstatus_barcode
field txthostdokumenttyp
field vorlagenfeldbezeichnunglist
field vorlagenfeldlist

See Also

frmDomainDokumenttypDetail Class


Aufhebungliste Variable

Friend WithEvents Aufhebungliste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Aufhebungliste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


BeschrausOV Variable

Friend WithEvents BeschrausOV As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents BeschrausOV As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


BtnSaveRollen Variable

Friend WithEvents BtnSaveRollen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnSaveRollen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


BtnStandard Variable

Friend WithEvents BtnStandard As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnStandard As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Button9 Variable

Friend WithEvents Button9 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button9 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


CDokumentersetzen Variable

Friend WithEvents CDokumentersetzen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CDokumentersetzen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


CDokumentwirdretourniert Variable

Friend WithEvents CDokumentwirdretourniert As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CDokumentwirdretourniert As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ColdIndexfeldList Variable

Friend WithEvents ColdIndexfeldList As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents ColdIndexfeldList As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataChanged Variable

Dim DataChanged As Boolean

Source code

[Visual Basic]
    Dim DataChanged As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet5 Variable

Friend WithEvents DataSet5 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet5 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DataSet6 Variable

Friend WithEvents DataSet6 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet6 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DokStatus Variable

Dim DokStatus As Integer

Source code

[Visual Basic]
    Dim DokStatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


DokumentstatusRolle_Liste Variable

Friend WithEvents DokumentstatusRolle_Liste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentstatusRolle_Liste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Dokumenttypnr Variable

Friend WithEvents Dokumenttypnr As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Dokumenttypnr As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Grp1 Variable

Friend WithEvents Grp1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents Grp1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


IndexMutationNachAbschluss Variable

Dim IndexMutationNachAbschluss As Boolean = False

Source code

[Visual Basic]
    Dim IndexMutationNachAbschluss As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


InfomeldungList Variable

Friend WithEvents InfomeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfomeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


LoeschungNachAbschluss Variable

Dim LoeschungNachAbschluss As Boolean = False

Source code

[Visual Basic]
    Dim LoeschungNachAbschluss As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


MnuDokZuordnungauheben Variable

Friend WithEvents MnuDokZuordnungauheben As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokZuordnungauheben As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBEingang Variable

Friend WithEvents RBEingang As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBEingang As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBEinzeldokumente Variable

Friend WithEvents RBEinzeldokumente As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBEinzeldokumente As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBErstellung Variable

Friend WithEvents RBErstellung As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBErstellung As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBGesamt Variable

Friend WithEvents RBGesamt As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBGesamt As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBHost Variable

Friend WithEvents RBHost As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBHost As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


RBKundendossier Variable

Friend WithEvents RBKundendossier As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBKundendossier As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter4 Variable

Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter5 Variable

Friend WithEvents SqlDataAdapter5 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter5 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDataAdapter6 Variable

Friend WithEvents SqlDataAdapter6 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter6 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDeleteCommand4 Variable

Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlDeleteCommand5 Variable

Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlInsertCommand4 Variable

Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlInsertCommand5 Variable

Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand5 Variable

Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlSelectCommand6 Variable

Friend WithEvents SqlSelectCommand6 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand6 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlUpdateCommand4 Variable

Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


SqlUpdateCommand5 Variable

Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


StatusDataChanged Variable

Dim StatusDataChanged As Boolean

Source code

[Visual Basic]
    Dim StatusDataChanged As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


Statuslist Variable

Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TVStruktur Variable

Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabDokumentfelder Variable

Friend WithEvents TabDokumentfelder As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabDokumentfelder As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabStatusreihenfolge Variable

Friend WithEvents TabStatusreihenfolge As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabStatusreihenfolge As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TabStruktur Variable

Friend WithEvents TabStruktur As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabStruktur As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TbSerienbrief Variable

Friend WithEvents TbSerienbrief As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TbSerienbrief As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolBarButton8 Variable

Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxTBeschreibung Variable

Friend WithEvents TxTBeschreibung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxTBeschreibung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxTBezeichnung Variable

Friend WithEvents TxTBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxTBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxTDokumentartRetournierung Variable

Friend WithEvents TxTDokumentartRetournierung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxTDokumentartRetournierung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxtDokumentartErstellung Variable

Friend WithEvents TxtDokumentartErstellung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtDokumentartErstellung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxtDokumentartGesamt Variable

Friend WithEvents TxtDokumentartGesamt As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtDokumentartGesamt As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxtDokumentartHost Variable

Friend WithEvents TxtDokumentartHost As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtDokumentartHost As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


TxtDokumentartKundendossier Variable

Friend WithEvents TxtDokumentartKundendossier As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtDokumentartKundendossier As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


VorlagenDataChanged Variable

Dim VorlagenDataChanged As Boolean

Source code

[Visual Basic]
    Dim VorlagenDataChanged As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnNeueRolle Variable

Friend WithEvents btnNeueRolle As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnNeueRolle As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnSelColdfolder Variable

Friend WithEvents btnSelColdfolder As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelColdfolder As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnSelDokumentartAusgang Variable

Friend WithEvents btnSelDokumentartAusgang As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelDokumentartAusgang As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnSelDokumentartEingang Variable

Friend WithEvents btnSelDokumentartEingang As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelDokumentartEingang As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnSelOfficeVorlage Variable

Friend WithEvents btnSelOfficeVorlage As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelOfficeVorlage As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnSelPhysischeAblage Variable

Friend WithEvents btnSelPhysischeAblage As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelPhysischeAblage As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnVorlagenfeld Variable

Friend WithEvents btnVorlagenfeld As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnVorlagenfeld As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnsave Variable

Friend WithEvents btnsave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnsave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnsavevorlagenfeldlist Variable

Friend WithEvents btnsavevorlagenfeldlist As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnsavevorlagenfeldlist As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


btnselobnr Variable

Friend WithEvents btnselobnr As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnselobnr As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cAMSDokument Variable

Friend WithEvents cAMSDokument As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cAMSDokument As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cAktiv Variable

Friend WithEvents cAktiv As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cAktiv As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cDokumentwirderstellt Variable

Friend WithEvents cDokumentwirderstellt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cDokumentwirderstellt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cEingangErsetztAusgang Variable

Friend WithEvents cEingangErsetztAusgang As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cEingangErsetztAusgang As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cEmailVersand Variable

Friend WithEvents cEmailVersand As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cEmailVersand As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cFunktion_zuweisen Variable

Friend WithEvents cFunktion_zuweisen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cFunktion_zuweisen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cHostDokument Variable

Friend WithEvents cHostDokument As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cHostDokument As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cNichtgeloescht Variable

Friend WithEvents cNichtgeloescht As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cNichtgeloescht As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cStatusMutation Variable

Friend WithEvents cStatusMutation As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cStatusMutation As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cUnterschriftlinks Variable

Friend WithEvents cUnterschriftlinks As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cUnterschriftlinks As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cUnterschriftrechts Variable

Friend WithEvents cUnterschriftrechts As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cUnterschriftrechts As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cVertraulich Variable

Friend WithEvents cVertraulich As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cVertraulich As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cWirdImportiert Variable

Friend WithEvents cWirdImportiert As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cWirdImportiert As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cZuRetournieren Variable

Friend WithEvents cZuRetournieren As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cZuRetournieren As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cZuVercolden Variable

Friend WithEvents cZuVercolden As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cZuVercolden As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbAbschluss Variable

Friend WithEvents cbAbschluss As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbAbschluss As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbAnzeige Variable

Friend WithEvents cbAnzeige As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbAnzeige As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbArchiv Variable

Friend WithEvents cbArchiv As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbArchiv As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbAufbewahrungelektronisch Variable

Friend WithEvents cbAufbewahrungelektronisch As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbAufbewahrungelektronisch As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbAufbewahrungphysisch Variable

Friend WithEvents cbAufbewahrungphysisch As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbAufbewahrungphysisch As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbBearbeitungszeit Variable

Friend WithEvents cbBearbeitungszeit As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbBearbeitungszeit As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbColdFolder Variable

Friend WithEvents cbColdFolder As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbColdFolder As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbDokartAusgang Variable

Friend WithEvents cbDokartAusgang As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbDokartAusgang As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbDokartEingang Variable

Friend WithEvents cbDokartEingang As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbDokartEingang As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbInEdokaDB Variable

Friend WithEvents cbInEdokaDB As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbInEdokaDB As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbKDE Variable

Friend WithEvents cbKDE As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbKDE As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbMonierung Variable

Friend WithEvents cbMonierung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbMonierung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbOfficeVorlage Variable

Friend WithEvents cbOfficeVorlage As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbOfficeVorlage As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbOwner Variable

Friend WithEvents cbOwner As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbOwner As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbStatustyp Variable

Friend WithEvents cbStatustyp As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbStatustyp As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbVertrag Variable

Friend WithEvents cbVertrag As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbVertrag As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbbedingteretournierung Variable

Friend WithEvents cbbedingteretournierung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbbedingteretournierung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbedingtretournierbar Variable

Friend WithEvents cbedingtretournierbar As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbedingtretournierbar As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbezmut Variable

Friend WithEvents cbezmut As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbezmut As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbobnr Variable

Friend WithEvents cbobnr As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbobnr As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbprozesserstellung Variable

Friend WithEvents cbprozesserstellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbprozesserstellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbprozessverwendung Variable

Friend WithEvents cbprozessverwendung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbprozessverwendung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbsb Variable

Friend WithEvents cbsb As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbsb As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbsbedituser Variable

Friend WithEvents cbsbedituser As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbsbedituser As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbsbimport Variable

Friend WithEvents cbsbimport As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbsbimport As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbsbnur Variable

Friend WithEvents cbsbnur As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbsbnur As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cbtagebedr Variable

Friend WithEvents cbtagebedr As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbtagebedr As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


cidvnative Variable

Friend WithEvents cidvnative As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cidvnative As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


dokumentinfomeldungen Variable

Dim dokumentinfomeldungen As DataTable

Source code

[Visual Basic]
    Dim dokumentinfomeldungen As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


indexmutationliste Variable

Friend WithEvents indexmutationliste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents indexmutationliste As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


m_NeuerEintrag Variable

Dim m_NeuerEintrag As Boolean

Source code

[Visual Basic]
    Dim m_NeuerEintrag As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


m_dokumenttypkey Variable

Dim m_dokumenttypkey As Long

Source code

[Visual Basic]
    Dim m_dokumenttypkey As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


mcbbedingteretournierung Variable

Dim WithEvents mcbbedingteretournierung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbbedingteretournierung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


mcbowner Variable

Dim mcbowner As New MultiComboBox()

Source code

[Visual Basic]
    Dim mcbowner As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


me_onLoad Variable

Dim me_onLoad As Boolean

Source code

[Visual Basic]
    Dim me_onLoad As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


neu Variable

Dim neu As Boolean

Source code

[Visual Basic]
    Dim neu As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


pnlVorlagenfeld Variable

Friend WithEvents pnlVorlagenfeld As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlVorlagenfeld As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


r Variable

Dim r As DataTable

Source code

[Visual Basic]
    Dim r As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


rbDokStatusStandard Variable

Friend WithEvents rbDokStatusStandard As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbDokStatusStandard As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


rbEtikette Variable

Friend WithEvents rbEtikette As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbEtikette As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


savestatustyp Variable

Dim savestatustyp As Long

Source code

[Visual Basic]
    Dim savestatustyp As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


t Variable

Dim t As DataTable

Source code

[Visual Basic]
    Dim t As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tcoldfolder Variable

Dim tcoldfolder As DataTable

Source code

[Visual Basic]
    Dim tcoldfolder As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tdokumentartausgang Variable

Dim tdokumentartausgang As DataTable

Source code

[Visual Basic]
    Dim tdokumentartausgang As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tdokumentarteingang Variable

Dim tdokumentarteingang As DataTable

Source code

[Visual Basic]
    Dim tdokumentarteingang As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tobnr Variable

Dim tobnr As DataTable

Source code

[Visual Basic]
    Dim tobnr As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tofficevorlage Variable

Dim tofficevorlage As DataTable

Source code

[Visual Basic]
    Dim tofficevorlage As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tphysischesarchiv Variable

Dim tphysischesarchiv As DataTable

Source code

[Visual Basic]
    Dim tphysischesarchiv As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tprozess1 Variable

Dim tprozess1 As DataTable

Source code

[Visual Basic]
    Dim tprozess1 As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tprozess2 Variable

Dim tprozess2 As DataTable

Source code

[Visual Basic]
    Dim tprozess2 As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


tstatustyp Variable

Dim tstatustyp As DataTable

Source code

[Visual Basic]
    Dim tstatustyp As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


txtDokumentartEinzeldokument Variable

Friend WithEvents txtDokumentartEinzeldokument As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentartEinzeldokument As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


txtDokumentstatus Variable

Friend WithEvents txtDokumentstatus As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentstatus As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


txtDokumentstatus_barcode Variable

Friend WithEvents txtDokumentstatus_barcode As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDokumentstatus_barcode As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


txthostdokumenttyp Variable

Friend WithEvents txthostdokumenttyp As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txthostdokumenttyp As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


vorlagenfeldbezeichnunglist Variable

Friend WithEvents vorlagenfeldbezeichnunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents vorlagenfeldbezeichnunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


vorlagenfeldlist Variable

Friend WithEvents vorlagenfeldlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents vorlagenfeldlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainDokumenttypDetail


frmDomainEditor Class

For a list of all members of this type, see frmDomainEditor Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.FrmDomainOfficeVorlageDatei
EDOKAApp.frmBLKunde
EDOKAApp.frmBLKundeVIP
EDOKAApp.frmDoaminStellvertretung
EDOKAApp.frmDokumentpaketuebersicht
EDOKAApp.frmDomainAnwendung
EDOKAApp.frmDomainAuswertungen
EDOKAApp.frmDomainAuswertungsgruppe
EDOKAApp.frmDomainBankinformation
EDOKAApp.frmDomainBerechtigung
EDOKAApp.frmDomainColdFolder
EDOKAApp.frmDomainColdIndexFeld
EDOKAApp.frmDomainDokumentartDaten
EDOKAApp.frmDomainDokumenttyp
EDOKAApp.frmDomainFAAppl
EDOKAApp.frmDomainFADokumenttyp
EDOKAApp.frmDomainFeldtyp
EDOKAApp.frmDomainFunktion
EDOKAApp.frmDomainFunktionsgruppe
EDOKAApp.frmDomainGrund
EDOKAApp.frmDomainIDVMakros
EDOKAApp.frmDomainKeyTabelle
EDOKAApp.frmDomainMailtexte
EDOKAApp.frmDomainMandant
EDOKAApp.frmDomainMarktbereich
EDOKAApp.frmDomainMeldungstexte
EDOKAApp.frmDomainNiederlassung
EDOKAApp.frmDomainObjektbezeichnung
EDOKAApp.frmDomainOfficeVorlage
EDOKAApp.frmDomainPhsischesArchiv
EDOKAApp.frmDomainProzess
EDOKAApp.frmDomainRolle
EDOKAApp.frmDomainSQLQueries
EDOKAApp.frmDomainSpalten
EDOKAApp.frmDomainStatusBezeichnung
EDOKAApp.frmDomainStatusTyp
EDOKAApp.frmDomainSteuerbefehl
EDOKAApp.frmDomainSysadminfuntkion
EDOKAApp.frmDomainTeam
EDOKAApp.frmDomainTipTexte
EDOKAApp.frmDomainVorlagenfeldregel
EDOKAApp.frmDomainZuordnungen
EDOKAApp.frmParameterSetName
EDOKAApp.frmSelectStatus
EDOKAApp.frmblkundeMA
EDOKAApp.frmdomainloeschgrund
EDOKAApp.xfrmDomainMitarbeiter

Public Class frmDomainEditor
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainEditor Members


frmDomainEditor Members

frmDomainEditor overview

Constructors

constructor frmDomainEditor Constructor

Properties

property Eintrag
property Eintragnr
property FormMaximize
property Inaktive
property TableName
property ToSelect
property TransferKey

Methods

method C1TrueDBGrid1_FetchCellTips
method Dispose
method Doklist_FetchScrollTips
method DomainList_AfterInsert
method DomainList_Dblklick
method FormSize
method Form_As_SelectForm
method InitializeComponent
method MenuItem2_Click
method SpaltenTitel_Aktualisieren
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmDomainEditor_Cloase
method frmDomainEditor_Load

Fields

field DomainList
field ImageList1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field ToolBar1
field ToolBtnExit
field ToolBtnSave
field Ttip
field components
field m_Eintrag
field m_Eintragnr
field m_Inaktive
field m_Maximize
field m_TableName
field m_ToSelect
field m_TransferKey
field selectedrow
field wp

See Also

frmDomainEditor Class


frmDomainEditor Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor Properties

frmDomainEditor overview

Properties

property Eintrag
property Eintragnr
property FormMaximize
property Inaktive
property TableName
property ToSelect
property TransferKey

See Also

frmDomainEditor Class


frmDomainEditor Methods

frmDomainEditor overview

Methods

method C1TrueDBGrid1_FetchCellTips
method Dispose
method Doklist_FetchScrollTips
method DomainList_AfterInsert
method DomainList_Dblklick
method FormSize
method Form_As_SelectForm
method InitializeComponent
method MenuItem2_Click
method SpaltenTitel_Aktualisieren
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmDomainEditor_Cloase
method frmDomainEditor_Load

See Also

frmDomainEditor Class


frmDomainEditor.C1TrueDBGrid1_FetchCellTips Method

Private Sub C1TrueDBGrid1_FetchCellTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles DomainList.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles DomainList.FetchCellTips
        If g_bRun Then
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = Me.TableName
            Try
                ts.Feld = Me.DomainList.Columns(e.ColIndex).DataField
                ts.getspalte()
                e.CellTip = ts.TipText
            Catch
            End Try
            ts = Nothing
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.Doklist_FetchScrollTips Method

Private Sub Doklist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles DomainList.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Doklist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles DomainList.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.DomainList.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "aktiv" Then
                    Me.DomainList.Columns(i).Value = 1
                End If
                If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
                    Me.DomainList.Columns(i).Value = Now
                End If
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then
                    Me.DomainList.Columns(i).Value = Now
                End If
                If Me.DomainList.Columns(i).DataField = "mutierer" Then
                    Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
                End If
            Next
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.DomainList_Dblklick Method

Private Sub DomainList_Dblklick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_Dblklick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        If ToSelect Then
            Me.TransferKey = Me.DomainList.Columns(0).Value
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.Form_As_SelectForm Method

Private Sub Form_As_SelectForm()

Source code

[Visual Basic]
    Private Sub Form_As_SelectForm()
        If ToSelect Then
            Me.DomainList.AllowAddNew = False
            Me.DomainList.AllowUpdate = False
            Me.ToolBar1.Buttons(1).Visible = False
            Me.MenuItem3.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainEditor))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2, Me.MenuItem3})
        Me.MenuItem1.MergeOrder = 1
        Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.MergeOrder = 1
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
        Me.MenuItem2.Text = "&Schliessen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
        Me.MenuItem3.Text = "&Daten sichern"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnExit, Me.ToolBtnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(592, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBtnExit
        '
        Me.ToolBtnExit.ImageIndex = 0
        '
        'ToolBtnSave
        '
        Me.ToolBtnSave.ImageIndex = 1
        '
        'DomainList
        '
        Me.DomainList.AllowAddNew = True
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(0, 25)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines1
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = False
        Me.DomainList.Size = New System.Drawing.Size(592, 336)
        Me.DomainList.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.DomainList.TabIndex = 7
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{Wrap:True;BackColor:255, 255, " & _
        "192;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightT" & _
        "ext;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{" & _
        "AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;" & _
        "ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11" & _
        "{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeVi" & _
        "ew Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17" & _
        """ ColumnFooterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" Record" & _
        "SelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollG" & _
        "roup=""1""><ClientRect>0, 0, 588, 332</ClientRect><BorderSide>0</BorderSide><Capti" & _
        "onStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" " & _
        "/><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar" & _
        """ me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""" & _
        "Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRow" & _
        "Style parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""S" & _
        "tyle4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=" & _
        """RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><" & _
        "Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Na" & _
        "medStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><" & _
        "Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Sty" & _
        "le parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Styl" & _
        "e parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Styl" & _
        "e parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style par" & _
        "ent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Sty" & _
        "le parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSp" & _
        "lits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSe" & _
        "lWidth><ClientArea>0, 0, 588, 332</ClientArea></Blob>"
        '
        'frmDomainEditor
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 361)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DomainList, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmDomainEditor"
        Me.ShowInTaskbar = False
        Me.Text = "frmDomainEdidor"
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
            Case 1 'Speichern
                Me.ActiveControl = Me.ToolBar1
                Me.ActiveControl = Me.DomainList
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
                If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                For i = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                        Me.DomainList.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.frmDomainEditor_Cloase Method

Private Sub frmDomainEditor_Cloase( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainEditor_Cloase(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor.frmDomainEditor_Load Method

Private Sub frmDomainEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If g_bRun Then
            Me.Text = Me.Eintrag
            Try
                If Me.FormMaximize = True Then Globals.WinPos.Get_Position(Me)
            Catch
            End Try
            Me.DomainList.ScrollTips = True
            'Me.WindowState = FormWindowState.Maximized
            'EDEX_Dokumentpakete 2005-01-13
            If Me.FormMaximize Then Me.WindowState = FormWindowState.Maximized

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainEditor Fields

frmDomainEditor overview

Fields

field DomainList
field ImageList1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field ToolBar1
field ToolBtnExit
field ToolBtnSave
field Ttip
field components
field m_Eintrag
field m_Eintragnr
field m_Inaktive
field m_Maximize
field m_TableName
field m_ToSelect
field m_TransferKey
field selectedrow
field wp

See Also

frmDomainEditor Class


Ttip Variable

Dim Ttip As New ToolTip()

Source code

[Visual Basic]
    Dim Ttip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
    Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
    Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_Inaktive Variable

Dim m_Inaktive As Boolean

Source code

[Visual Basic]
    Dim m_Inaktive As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_Maximize Variable

Dim m_Maximize As Boolean = True

Source code

[Visual Basic]
    Dim m_Maximize As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_TableName Variable

Dim m_TableName As String

Source code

[Visual Basic]
    Dim m_TableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_ToSelect Variable

Dim m_ToSelect As Boolean

Source code

[Visual Basic]
    Dim m_ToSelect As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


m_TransferKey Variable

Dim m_TransferKey As Long

Source code

[Visual Basic]
    Dim m_TransferKey As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


selectedrow Variable

Dim selectedrow As Integer

Source code

[Visual Basic]
    Dim selectedrow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


wp Variable

Dim wp As New WindowPositions()

Source code

[Visual Basic]
    Dim wp As New WindowPositions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainEditor


frmDomainFAAppl Class

For a list of all members of this type, see frmDomainFAAppl Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainFAAppl

Public Class frmDomainFAAppl
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainFAAppl Members


frmDomainFAAppl Members

frmDomainFAAppl overview

Constructors

constructor frmDomainFAAppl Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainFAAppl_Load
method get_journalerstellung
method get_mailperiode
method get_verarbeitungsart

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFAAppl Class


frmDomainFAAppl Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl Properties

frmDomainFAAppl overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainFAAppl Class


frmDomainFAAppl Methods

frmDomainFAAppl overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainFAAppl_Load
method get_journalerstellung
method get_mailperiode
method get_verarbeitungsart

See Also

frmDomainFAAppl Class


frmDomainFAAppl.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "FA_APPL", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ApplNr", "ApplNr"), New System.Data.Common.DataColumnMapping("Bezeichnung", "Bezeichnung"), New System.Data.Common.DataColumnMapping("EDOKA_Mitarbeiter", "EDOKA_Mitarbeiter"), New System.Data.Common.DataColumnMapping("Log_erstellung", "Log_erstellung"), New System.Data.Common.DataColumnMapping("Mail_Empfaneger", "Mail_Empfaneger"), New System.Data.Common.DataColumnMapping("Mail_Periodizitaet", "Mail_Periodizitaet"), New System.Data.Common.DataColumnMapping("Verarbeitungsart", "Verarbeitungsart"), New System.Data.Common.DataColumnMapping("OutputFormat", "OutputFormat"), New System.Data.Common.DataColumnMapping("DTO_Parameter", "DTO_Parameter"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_faappl_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ApplNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ApplNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DTO_Parameter", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "DTO_Parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EDOKA_Mitarbeiter", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EDOKA_Mitarbeiter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Log_erstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Log_erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_Empfaneger", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_Empfaneger", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_Periodizitaet", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_Periodizitaet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_OutputFormat", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "OutputFormat", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Verarbeitungsart", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Verarbeitungsart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgedoka;workstation id=TG602636;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_faappl_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Bezeichnung", System.Data.SqlDbType.VarChar, 50, "Bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EDOKA_Mitarbeiter", System.Data.SqlDbType.Int, 4, "EDOKA_Mitarbeiter"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Log_erstellung", System.Data.SqlDbType.Int, 4, "Log_erstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_Empfaneger", System.Data.SqlDbType.VarChar, 255, "Mail_Empfaneger"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_Periodizitaet", System.Data.SqlDbType.Int, 4, "Mail_Periodizitaet"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Verarbeitungsart", System.Data.SqlDbType.Int, 4, "Verarbeitungsart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@OutputFormat", System.Data.SqlDbType.VarChar, 50, "OutputFormat"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DTO_Parameter", System.Data.SqlDbType.VarChar, 1024, "DTO_Parameter"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_faappl_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_faappl_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Bezeichnung", System.Data.SqlDbType.VarChar, 50, "Bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EDOKA_Mitarbeiter", System.Data.SqlDbType.Int, 4, "EDOKA_Mitarbeiter"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Log_erstellung", System.Data.SqlDbType.Int, 4, "Log_erstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_Empfaneger", System.Data.SqlDbType.VarChar, 255, "Mail_Empfaneger"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_Periodizitaet", System.Data.SqlDbType.Int, 4, "Mail_Periodizitaet"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Verarbeitungsart", System.Data.SqlDbType.Int, 4, "Verarbeitungsart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@OutputFormat", System.Data.SqlDbType.VarChar, 50, "OutputFormat"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DTO_Parameter", System.Data.SqlDbType.VarChar, 1024, "DTO_Parameter"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ApplNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ApplNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DTO_Parameter", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "DTO_Parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EDOKA_Mitarbeiter", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EDOKA_Mitarbeiter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Log_erstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Log_erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_Empfaneger", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_Empfaneger", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_Periodizitaet", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_Periodizitaet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_OutputFormat", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "OutputFormat", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Verarbeitungsart", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Verarbeitungsart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ApplNr", System.Data.SqlDbType.Int, 4, "ApplNr"))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainFAAppl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(624, 273)
        Me.Name = "frmDomainFAAppl"
        Me.Text = """EDOKA-Import - Fremdanwendungen"""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.frmDomainFAAppl_Load Method

Private Sub frmDomainFAAppl_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainFAAppl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Text = "EDOKA-Import - Fremdanwendungen"
        Me.TableName = "fa_appl"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        Dim dt As New DataTable()
        Dim i As Integer
        dt = get_journalerstellung()

        For i = 0 To dt.Rows.Count - 1
            Dim vi As New C1.Win.C1TrueDBGrid.ValueItem()
            vi.DisplayValue = dt.Rows(i).Item("bezeichnung")
            vi.Value = dt.Rows(i).Item("FA_Journalerstellungnr")
            Me.DomainList.Columns("log_erstellung").ValueItems.Values.Add(vi)
            Me.DomainList.Columns("log_erstellung").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
            Me.DomainList.Columns("log_erstellung").ValueItems.Translate = True
        Next

        Dim dv As New DataTable()
        dv = get_verarbeitungsart()
        For i = 0 To dv.Rows.Count - 1
            Dim vi As New C1.Win.C1TrueDBGrid.ValueItem()
            vi.DisplayValue = dv.Rows(i).Item("bezeichnung")
            vi.Value = dv.Rows(i).Item("FA_Verarbeitungsartnr")
            Me.DomainList.Columns("verarbeitungsart").ValueItems.Values.Add(vi)
            Me.DomainList.Columns("verarbeitungsart").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
            Me.DomainList.Columns("verarbeitungsart").ValueItems.Translate = True
        Next

        Dim dm As New DataTable()
        dm = get_mailperiode()
        For i = 0 To dm.Rows.Count - 1
            Dim vi As New C1.Win.C1TrueDBGrid.ValueItem()
            vi.DisplayValue = dm.Rows(i).Item("bezeichnung")
            vi.Value = dm.Rows(i).Item("FA_mailperiodenr")
            Me.DomainList.Columns("Mail_Periodizitaet").ValueItems.Values.Add(vi)
            Me.DomainList.Columns("Mail_Periodizitaet").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
            Me.DomainList.Columns("Mail_Periodizitaet").ValueItems.Translate = True
        Next
        For i = 1 To 5
            Dim s As String
            Dim vi As New C1.Win.C1TrueDBGrid.ValueItem()
            Select Case i
                Case 1
                    s = "PDF"
                Case 2
                    s = "TXT"
                Case 3
                    s = "CSV"
                Case 4
                    s = "DOC"
                Case 5
                    s = "XLS"
            End Select
            vi.DisplayValue = s
            vi.Value = s
            Me.DomainList.Columns("OutputFormat").ValueItems.Values.Add(vi)
            Me.DomainList.Columns("OutputFormat").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
            Me.DomainList.Columns("OutputFormat").ValueItems.Translate = True
        Next

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        dv.Dispose()
        dt.Dispose()
        dm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.get_journalerstellung Method

Public Function get_journalerstellung() As DataTable

Source code

[Visual Basic]
    Public Function get_journalerstellung() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_journalerstellung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.get_mailperiode Method

Public Function get_mailperiode() As DataTable

Source code

[Visual Basic]
    Public Function get_mailperiode() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_mailperiode"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl.get_verarbeitungsart Method

Public Function get_verarbeitungsart() As DataTable

Source code

[Visual Basic]
    Public Function get_verarbeitungsart() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_verarbeitungsart"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFAAppl Fields

frmDomainFAAppl overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFAAppl Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFAAppl


frmDomainFADokumenttyp Class

For a list of all members of this type, see frmDomainFADokumenttyp Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainFADokumenttyp

Public Class frmDomainFADokumenttyp
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainFADokumenttyp Members


frmDomainFADokumenttyp Members

frmDomainFADokumenttyp overview

Constructors

constructor frmDomainFADokumenttyp Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FillDropDown_Appl
method FillDropDown_DokTyp
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainFAAppl_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field drpApplication
field drpDokumenttyp

See Also

frmDomainFADokumenttyp Class


frmDomainFADokumenttyp Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp Properties

frmDomainFADokumenttyp overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainFADokumenttyp Class


frmDomainFADokumenttyp Methods

frmDomainFADokumenttyp overview

Methods

method Dispose
method FillDropDown_Appl
method FillDropDown_DokTyp
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainFAAppl_Load

See Also

frmDomainFADokumenttyp Class


frmDomainFADokumenttyp.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.FillDropDown_Appl Method

Private Sub FillDropDown_Appl()

Source code

[Visual Basic]
    Private Sub FillDropDown_Appl()
        '===============================================================================
        'Spaltenbreite DrpRight
        '===============================================================================
        Dim ds As New DataSet()
        Dim sqlcmd As New SqlCommand()
        Dim da As New SqlDataAdapter(sqlcmd)
        Dim sTranslateTabelname As String
        Dim sTranslateColumn As String

        '======================================================================
        'Klassifizierung
        '======================================================================
        sTranslateTabelname = "FA_Appl"
        Me.drpApplication.ListField = "bezeichnung"
        Me.drpApplication.DataField = "ApplNr"

        If Not ds.Tables(sTranslateTabelname) Is Nothing Then
            ds.Tables(sTranslateTabelname).Clear()
        End If

        With sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "sp_edoka_import_get_appl"
            .Connection = SqlConnection1
            .Parameters.Add("@mandantnr", Globals.MandantNr)
        End With

        Try
            da.Fill(ds, sTranslateTabelname)
            Me.drpApplication.DataSource = ds
            Me.drpApplication.ValueTranslate = True
            Me.drpApplication.DataSource = ds
            Me.drpApplication.DataMember = sTranslateTabelname
            Me.drpApplication.DisplayColumns(0).Width = 30

            'Me.drpApplication.DataSource = ds.Tables(0)
            Me.drpApplication.DataMember = ds.Tables(0).TableName

            Me.DomainList.Columns("ApplNr").DropDown = Me.drpApplication
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.FillDropDown_DokTyp Method

Private Sub FillDropDown_DokTyp()

Source code

[Visual Basic]
    Private Sub FillDropDown_DokTyp()
        '===============================================================================
        'Spaltenbreite DrpRight
        '===============================================================================
        Dim ds As New DataSet()
        Dim sqlcmd As New SqlCommand()
        Dim da As New SqlDataAdapter(sqlcmd)
        Dim sTranslateTabelname As String
        Dim sTranslateColumn As String

        '======================================================================
        'Klassifizierung
        '======================================================================
        sTranslateTabelname = "Dokumenttyp"
        Me.drpDokumenttyp.ListField = "bezeichnung"
        Me.drpDokumenttyp.DataField = "Dokumenttypnr"

        If Not ds.Tables(sTranslateTabelname) Is Nothing Then
            ds.Tables(sTranslateTabelname).Clear()
        End If

        With sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "sp_edoka_import_get_Dokumenttyp"
            .Connection = SqlConnection1
            .Parameters.Add("@mandantnr", Globals.MandantNr)
        End With

        Try
            da.Fill(ds, sTranslateTabelname)
            Me.drpDokumenttyp.DataSource = ds
            Me.drpDokumenttyp.ValueTranslate = True
            Me.drpDokumenttyp.DataSource = ds
            Me.drpDokumenttyp.DataMember = sTranslateTabelname
            Me.drpDokumenttyp.DisplayColumns(0).Width = 30

            'Me.drpApplication.DataSource = ds.Tables(0)
            Me.drpDokumenttyp.DataMember = ds.Tables(0).TableName

            Me.DomainList.Columns("EDOKA_Dokumenttyp").DropDown = Me.drpDokumenttyp
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainFADokumenttyp))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.drpApplication = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.drpDokumenttyp = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.drpApplication, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.drpDokumenttyp, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "FA_Dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("Eintragnr", "Eintragnr"), New System.Data.Common.DataColumnMapping("ApplNr", "ApplNr"), New System.Data.Common.DataColumnMapping("FA_Dokumenttyp", "FA_Dokumenttyp"), New System.Data.Common.DataColumnMapping("EDOKA_Dokumenttyp", "EDOKA_Dokumenttyp"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_fadokumenttyp_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_fadokumenttyp_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ApplNr", System.Data.SqlDbType.Int, 4, "ApplNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@FA_Dokumenttyp", System.Data.SqlDbType.VarChar, 255, "FA_Dokumenttyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EDOKA_Dokumenttyp", System.Data.SqlDbType.Int, 4, "EDOKA_Dokumenttyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Int, 4, "aktiv"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_fadokumenttyp_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ApplNr", System.Data.SqlDbType.Int, 4, "ApplNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@FA_Dokumenttyp", System.Data.SqlDbType.VarChar, 255, "FA_Dokumenttyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EDOKA_Dokumenttyp", System.Data.SqlDbType.Int, 4, "EDOKA_Dokumenttyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Int, 4, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Eintragnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Eintragnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ApplNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ApplNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EDOKA_Dokumenttyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EDOKA_Dokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_FA_Dokumenttyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "FA_Dokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Eintragnr", System.Data.SqlDbType.Int, 4, "Eintragnr"))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_fadokumenttyp_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Eintragnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Eintragnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ApplNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ApplNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EDOKA_Dokumenttyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EDOKA_Dokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_FA_Dokumenttyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "FA_Dokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgedoka;workstation id=TG602636;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'drpApplication
        '
        Me.drpApplication.AllowColMove = True
        Me.drpApplication.AllowColSelect = True
        Me.drpApplication.AllowFilter = True
        Me.drpApplication.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpApplication.AllowSort = True
        Me.drpApplication.AlternatingRows = False
        Me.drpApplication.CaptionHeight = 17
        Me.drpApplication.ColumnCaptionHeight = 17
        Me.drpApplication.ColumnFooterHeight = 17
        Me.drpApplication.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpApplication.FetchRowStyles = False
        Me.drpApplication.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.drpApplication.LayoutFileName = ""
        Me.drpApplication.LayoutName = ""
        Me.drpApplication.LayoutURL = ""
        Me.drpApplication.Location = New System.Drawing.Point(128, 40)
        Me.drpApplication.Name = "drpApplication"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpApplication.RowDivider = GridLines1
        Me.drpApplication.RowHeight = 15
        Me.drpApplication.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpApplication.ScrollTips = False
        Me.drpApplication.Size = New System.Drawing.Size(232, 216)
        Me.drpApplication.TabIndex = 18
        Me.drpApplication.Text = "C1TrueDBDropdown2"
        Me.drpApplication.Visible = False
        Me.drpApplication.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 228, 212</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 228, 212</ClientA" & _
        "rea></Blob>"
        '
        'drpDokumenttyp
        '
        Me.drpDokumenttyp.AllowColMove = True
        Me.drpDokumenttyp.AllowColSelect = True
        Me.drpDokumenttyp.AllowFilter = True
        Me.drpDokumenttyp.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpDokumenttyp.AllowSort = True
        Me.drpDokumenttyp.AlternatingRows = False
        Me.drpDokumenttyp.CaptionHeight = 17
        Me.drpDokumenttyp.ColumnCaptionHeight = 17
        Me.drpDokumenttyp.ColumnFooterHeight = 17
        Me.drpDokumenttyp.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpDokumenttyp.FetchRowStyles = False
        Me.drpDokumenttyp.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.drpDokumenttyp.LayoutFileName = ""
        Me.drpDokumenttyp.LayoutName = ""
        Me.drpDokumenttyp.LayoutURL = ""
        Me.drpDokumenttyp.Location = New System.Drawing.Point(224, 28)
        Me.drpDokumenttyp.Name = "drpDokumenttyp"
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpDokumenttyp.RowDivider = GridLines2
        Me.drpDokumenttyp.RowHeight = 15
        Me.drpDokumenttyp.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpDokumenttyp.ScrollTips = False
        Me.drpDokumenttyp.Size = New System.Drawing.Size(232, 216)
        Me.drpDokumenttyp.TabIndex = 19
        Me.drpDokumenttyp.Text = "C1TrueDBDropdown2"
        Me.drpDokumenttyp.Visible = False
        Me.drpDokumenttyp.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 228, 212</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 228, 212</ClientA" & _
        "rea></Blob>"
        '
        'frmDomainFADokumenttyp
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(680, 273)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpDokumenttyp, Me.drpApplication})
        Me.Name = "frmDomainFADokumenttyp"
        Me.Text = "frmDomainFADokumenttyp"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.drpApplication, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.drpDokumenttyp, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp.frmDomainFAAppl_Load Method

Private Sub frmDomainFAAppl_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainFAAppl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "FA_Dokumenttyp"
        Me.Text = "EDOKA-Import - Zuweisung FA-Dokumenttyp zu EDOKA-Dokumenttyp"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        'Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        Me.FillDropDown_Appl()
        Me.FillDropDown_DokTyp()
        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFADokumenttyp Fields

frmDomainFADokumenttyp overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field drpApplication
field drpDokumenttyp

See Also

frmDomainFADokumenttyp Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


drpApplication Variable

Friend WithEvents drpApplication As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpApplication As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


drpDokumenttyp Variable

Friend WithEvents drpDokumenttyp As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpDokumenttyp As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFADokumenttyp


frmDomainFeldtyp Class

For a list of all members of this type, see frmDomainFeldtyp Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainFeldtyp

Public Class frmDomainFeldtyp
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainFeldtyp Members


frmDomainFeldtyp Members

frmDomainFeldtyp overview

Constructors

constructor frmDomainFeldtyp Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmDomainFeldtyp_Load
method frmDomainSteuerbefehl_Closing

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFeldtyp Class


frmDomainFeldtyp Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp Properties

frmDomainFeldtyp overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainFeldtyp Class


frmDomainFeldtyp Methods

frmDomainFeldtyp overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmDomainFeldtyp_Load
method frmDomainSteuerbefehl_Closing

See Also

frmDomainFeldtyp Class


frmDomainFeldtyp.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Feldtyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("feldtypNr", "feldtypNr"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("format", "format"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_feldtyp_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_feldtyp_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 50, "feldtyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 50, "format"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_feldtyp_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 50, "feldtyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 50, "format"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_feldtyp_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=TGTSQLEDOKABSSF;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgentwicklung3;workstation id=TG602640;packet size" & _
        "=4096"
        '
        'frmDomainFeldtyp
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 339)
        Me.Name = "frmDomainFeldtyp"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.frmDomainFeldtyp_Load Method

Private Sub frmDomainFeldtyp_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainFeldtyp_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "Feldtyp"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Dim i As Integer
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "odbc" Then Me.DomainList.Columns(i).DefaultValue = False
            If Me.DomainList.Columns(i).DataField = "oledb" Then Me.DomainList.Columns(i).DefaultValue = True
            If Me.DomainList.Columns(i).DataField = "sqlclient" Then Me.DomainList.Columns(i).DefaultValue = False
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp.frmDomainSteuerbefehl_Closing Method

Private Sub frmDomainSteuerbefehl_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainSteuerbefehl_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFeldtyp Fields

frmDomainFeldtyp overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFeldtyp Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFeldtyp


frmDomainFunktion Class

For a list of all members of this type, see frmDomainFunktion Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainFunktion

Public Class frmDomainFunktion
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainFunktion Members


frmDomainFunktion Members

frmDomainFunktion overview

Constructors

constructor frmDomainFunktion Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFunktion Class


frmDomainFunktion Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion Properties

frmDomainFunktion overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainFunktion Class


frmDomainFunktion Methods

frmDomainFunktion overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainFunktion Class


frmDomainFunktion.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_funktion_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_funktion_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_funktion_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_funktion_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainFunktion
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(656, 273)
        Me.Name = "frmDomainFunktion"
        Me.Text = "Funktionen"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "funktion"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktion Fields

frmDomainFunktion overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFunktion Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktion


frmDomainFunktionsgruppe Class

For a list of all members of this type, see frmDomainFunktionsgruppe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainFunktionsgruppe

Public Class frmDomainFunktionsgruppe
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainFunktionsgruppe Members


frmDomainFunktionsgruppe Members

frmDomainFunktionsgruppe overview

Constructors

constructor frmDomainFunktionsgruppe Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFunktionsgruppe Class


frmDomainFunktionsgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe Properties

frmDomainFunktionsgruppe overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainFunktionsgruppe Class


frmDomainFunktionsgruppe Methods

frmDomainFunktionsgruppe overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainFunktionsgruppe Class


frmDomainFunktionsgruppe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("funktionszuweisung", "funktionszuweisung"), New System.Data.Common.DataColumnMapping("barcodeetiketten", "barcodeetiketten"), New System.Data.Common.DataColumnMapping("edokapartner", "edokapartner"), New System.Data.Common.DataColumnMapping("Dokumentreaktivierung", "Dokumentreaktivierung"), New System.Data.Common.DataColumnMapping("Partnerzusammenlegung", "Partnerzusammenlegung"), New System.Data.Common.DataColumnMapping("BLV", "BLV")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_funktionsgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionszuweisung", System.Data.SqlDbType.Bit, 1, "funktionszuweisung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodeetiketten", System.Data.SqlDbType.Bit, 1, "barcodeetiketten"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edokapartner", System.Data.SqlDbType.Bit, 1, "edokapartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, "Dokumentreaktivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, "Partnerzusammenlegung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@BLV", System.Data.SqlDbType.Bit, 1, "BLV"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_funktionsgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionszuweisung", System.Data.SqlDbType.Bit, 1, "funktionszuweisung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@barcodeetiketten", System.Data.SqlDbType.Bit, 1, "barcodeetiketten"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edokapartner", System.Data.SqlDbType.Bit, 1, "edokapartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, "Dokumentreaktivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, "Partnerzusammenlegung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@BLV", System.Data.SqlDbType.Bit, 1, "BLV"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_BLV", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "BLV", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokumentreaktivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Partnerzusammenlegung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodeetiketten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodeetiketten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edokapartner", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edokapartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionszuweisung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionszuweisung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_funktionsgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_BLV", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "BLV", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokumentreaktivierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokumentreaktivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Partnerzusammenlegung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Partnerzusammenlegung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_barcodeetiketten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "barcodeetiketten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edokapartner", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edokapartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionszuweisung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionszuweisung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainFunktionsgruppe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, 0)
        Me.Name = "frmDomainFunktionsgruppe"
        Me.Text = "frmDomainFunktionsgruppe"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "funktionsgruppe"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainFunktionsgruppe Fields

frmDomainFunktionsgruppe overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainFunktionsgruppe Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainFunktionsgruppe


frmDomainGrund Class

For a list of all members of this type, see frmDomainGrund Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainGrund

Public Class frmDomainGrund
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainGrund Members


frmDomainGrund Members

frmDomainGrund overview

Constructors

constructor frmDomainGrund Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainGrund Class


frmDomainGrund Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund Properties

frmDomainGrund overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainGrund Class


frmDomainGrund Methods

frmDomainGrund overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainGrund Class


frmDomainGrund.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Grund", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("grundnr", "grundnr"), New System.Data.Common.DataColumnMapping("grund", "grund"), New System.Data.Common.DataColumnMapping("grundtyp", "grundtyp"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu00;initial catalog=edoka;persist security info=False;user id=sa;wo" & _
        "rkstation id=SHU00;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_grund_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_grund_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grundnr", System.Data.SqlDbType.Int, 4, "grundnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grund", System.Data.SqlDbType.VarChar, 255, "grund"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grundtyp", System.Data.SqlDbType.Int, 4, "grundtyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_grund_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grundnr", System.Data.SqlDbType.Int, 4, "grundnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grund", System.Data.SqlDbType.VarChar, 255, "grund"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@grundtyp", System.Data.SqlDbType.Int, 4, "grundtyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grundnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grundnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grund", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grund", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grundtyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grundtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_grund_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grundnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grundnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grund", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grund", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_grundtyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "grundtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainGrund
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, -20)
        Me.Name = "frmDomainGrund"
        Me.Text = "frmDomainGrund"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "grund"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

        Dim i As Integer
        For i = 0 To Me.DomainList.Columns.Count - 1
            'Präsentation von Readonly
            If Me.DomainList.Columns(i).DataField = "ist_in_dll" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DomainList.Columns(i).DefaultValue = False
            End If
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainGrund Fields

frmDomainGrund overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainGrund Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainGrund


frmDomainIDVMakros Class

For a list of all members of this type, see frmDomainIDVMakros Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainIDVMakros

Public Class frmDomainIDVMakros
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainIDVMakros Members


frmDomainIDVMakros Members

frmDomainIDVMakros overview

Constructors

constructor frmDomainIDVMakros Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainIDVMakros Class


frmDomainIDVMakros Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros Properties

frmDomainIDVMakros overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainIDVMakros Class


frmDomainIDVMakros Methods

frmDomainIDVMakros overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainIDVMakros Class


frmDomainIDVMakros.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "idv_makros", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("idvmakronr", "idvmakronr"), New System.Data.Common.DataColumnMapping("makro", "makro"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("ist_in_dll", "ist_in_dll"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_idvmakros_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_idvmakros_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@makro", System.Data.SqlDbType.VarChar, 255, "makro"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ist_in_dll", System.Data.SqlDbType.Bit, 1, "ist_in_dll"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_idvmakros_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@makro", System.Data.SqlDbType.VarChar, 255, "makro"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ist_in_dll", System.Data.SqlDbType.Bit, 1, "ist_in_dll"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ist_in_dll", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ist_in_dll", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_makro", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "makro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_idvmakros_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ist_in_dll", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ist_in_dll", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_makro", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "makro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainIDVMakros
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainIDVMakros"
        Me.Text = "cldDomainBerechtigung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "idv_makros"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

        Dim i As Integer
        For i = 0 To Me.DomainList.Columns.Count - 1
            'Präsentation von Readonly
            If Me.DomainList.Columns(i).DataField = "ist_in_dll" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DomainList.Columns(i).DefaultValue = False
            End If
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainIDVMakros Fields

frmDomainIDVMakros overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainIDVMakros Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainIDVMakros


frmDomainKeyTabelle Class

For a list of all members of this type, see frmDomainKeyTabelle Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainKeyTabelle

Public Class frmDomainKeyTabelle
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainKeyTabelle Members


frmDomainKeyTabelle Members

frmDomainKeyTabelle overview

Constructors

constructor frmDomainKeyTabelle Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainKeyTabelle Class


frmDomainKeyTabelle Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle Properties

frmDomainKeyTabelle overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainKeyTabelle Class


frmDomainKeyTabelle Methods

frmDomainKeyTabelle overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainKeyTabelle Class


frmDomainKeyTabelle.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "key_tabelle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("keynr", "keynr"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("key_wert", "key_wert"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_key_tabelle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_key_tabelle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@key_wert", System.Data.SqlDbType.Int, 4, "key_wert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_key_tabelle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@key_wert", System.Data.SqlDbType.Int, 4, "key_wert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_keynr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "keynr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_key_wert", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "key_wert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@keynr", System.Data.SqlDbType.Int, 4, "keynr"))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_key_tabelle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_keynr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "keynr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_key_wert", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "key_wert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainKeyTabelle
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainKeyTabelle"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "key_tabelle"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainKeyTabelle Fields

frmDomainKeyTabelle overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainKeyTabelle Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainKeyTabelle


frmDomainMailtexte Class

For a list of all members of this type, see frmDomainMailtexte Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainMailtexte

Public Class frmDomainMailtexte
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainMailtexte Members


frmDomainMailtexte Members

frmDomainMailtexte overview

Constructors

constructor frmDomainMailtexte Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMailtexte Class


frmDomainMailtexte Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte Properties

frmDomainMailtexte overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainMailtexte Class


frmDomainMailtexte Methods

frmDomainMailtexte overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainMailtexte Class


frmDomainMailtexte.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mailtexte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mailtextnr", "mailtextnr"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("betreff", "betreff"), New System.Data.Common.DataColumnMapping("inhalt", "inhalt"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_mailtexte_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_mailtexte_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mailtextnr", System.Data.SqlDbType.Int, 4, "mailtextnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@betreff", System.Data.SqlDbType.VarChar, 1024, "betreff"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_mailtexte_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mailtextnr", System.Data.SqlDbType.Int, 4, "mailtextnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@betreff", System.Data.SqlDbType.VarChar, 1024, "betreff"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mailtextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mailtextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_betreff", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "betreff", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_mailtexte_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mailtextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mailtextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_betreff", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "betreff", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tg339012;initial catalog=edoka_parameter;integrated security=SSPI;per" & _
        "sist security info=False;user id=dbedoka11;workstation id=TG602655;packet size=4" & _
        "096"
        '
        'frmDomainMailtexte
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainMailtexte"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "mailtexte"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMailtexte Fields

frmDomainMailtexte overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMailtexte Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMailtexte


frmDomainMandant Class

For a list of all members of this type, see frmDomainMandant Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainMandant

Public Class frmDomainMandant
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainMandant Members


frmDomainMandant Members

frmDomainMandant overview

Constructors

constructor frmDomainMandant Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMandant Class


frmDomainMandant Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant Properties

frmDomainMandant overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainMandant Class


frmDomainMandant Methods

frmDomainMandant overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainMandant Class


frmDomainMandant.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mandant", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr1", "mandantnr1"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "DELETE FROM mandant WHERE (mandantnr = @Original_mandantnr) AND (aktiv = @Origina" & _
        "l_aktiv OR @Original_aktiv IS NULL AND aktiv IS NULL) AND (beschreibung = @Origi" & _
        "nal_beschreibung OR @Original_beschreibung IS NULL AND beschreibung IS NULL) AND" & _
        " (bezeichnung = @Original_bezeichnung OR @Original_bezeichnung IS NULL AND bezei" & _
        "chnung IS NULL) AND (erstellt_am = @Original_erstellt_am OR @Original_erstellt_a" & _
        "m IS NULL AND erstellt_am IS NULL) AND (mandantnr1 = @Original_mandantnr1 OR @Or" & _
        "iginal_mandantnr1 IS NULL AND mandantnr1 IS NULL) AND (mutierer = @Original_muti" & _
        "erer OR @Original_mutierer IS NULL AND mutierer IS NULL) AND (mutiert_am = @Orig" & _
        "inal_mutiert_am OR @Original_mutiert_am IS NULL AND mutiert_am IS NULL)"
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "INSERT INTO mandant(mandantnr, bezeichnung, beschreibung, mandantnr1, aktiv, erst" & _
        "ellt_am, mutiert_am, mutierer) VALUES (@mandantnr, @bezeichnung, @beschreibung, " & _
        "@mandantnr1, @aktiv, @erstellt_am, @mutiert_am, @mutierer); SELECT mandantnr, be" & _
        "zeichnung, beschreibung, mandantnr1, aktiv, erstellt_am, mutiert_am, mutierer FR" & _
        "OM mandant WHERE (mandantnr = @mandantnr)"
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr1", System.Data.SqlDbType.Int, 4, "mandantnr1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "SELECT mandantnr, bezeichnung, beschreibung, mandantnr1, aktiv, erstellt_am, muti" & _
        "ert_am, mutierer FROM mandant"
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "UPDATE mandant SET mandantnr = @mandantnr, bezeichnung = @bezeichnung, beschreibu" & _
        "ng = @beschreibung, mandantnr1 = @mandantnr1, aktiv = @aktiv, erstellt_am = @ers" & _
        "tellt_am, mutiert_am = @mutiert_am, mutierer = @mutierer WHERE (mandantnr = @Ori" & _
        "ginal_mandantnr) AND (aktiv = @Original_aktiv OR @Original_aktiv IS NULL AND akt" & _
        "iv IS NULL) AND (beschreibung = @Original_beschreibung OR @Original_beschreibung" & _
        " IS NULL AND beschreibung IS NULL) AND (bezeichnung = @Original_bezeichnung OR @" & _
        "Original_bezeichnung IS NULL AND bezeichnung IS NULL) AND (erstellt_am = @Origin" & _
        "al_erstellt_am OR @Original_erstellt_am IS NULL AND erstellt_am IS NULL) AND (ma" & _
        "ndantnr1 = @Original_mandantnr1 OR @Original_mandantnr1 IS NULL AND mandantnr1 I" & _
        "S NULL) AND (mutierer = @Original_mutierer OR @Original_mutierer IS NULL AND mut" & _
        "ierer IS NULL) AND (mutiert_am = @Original_mutiert_am OR @Original_mutiert_am IS" & _
        " NULL AND mutiert_am IS NULL); SELECT mandantnr, bezeichnung, beschreibung, mand" & _
        "antnr1, aktiv, erstellt_am, mutiert_am, mutierer FROM mandant WHERE (mandantnr =" & _
        " @mandantnr)"
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr1", System.Data.SqlDbType.Int, 4, "mandantnr1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainMandant
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 329)
        Me.Name = "frmDomainMandant"
        Me.Text = "Mandanten"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "Mandant"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMandant Fields

frmDomainMandant overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMandant Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMandant


frmDomainMarktbereich Class

For a list of all members of this type, see frmDomainMarktbereich Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainMarktbereich

Public Class frmDomainMarktbereich
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainMarktbereich Members


frmDomainMarktbereich Members

frmDomainMarktbereich overview

Constructors

constructor frmDomainMarktbereich Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMarktbereich Class


frmDomainMarktbereich Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich Properties

frmDomainMarktbereich overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainMarktbereich Class


frmDomainMarktbereich Methods

frmDomainMarktbereich overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainMarktbereich Class


frmDomainMarktbereich.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "marktbereich", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("marktbereichnr", "marktbereichnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_marktbereich_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_marktbereich_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_marktbereich_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_marktbereich_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainMarktbereich
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainMarktbereich"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "marktbereich"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMarktbereich Fields

frmDomainMarktbereich overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMarktbereich Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMarktbereich


frmDomainMeldungstexte Class

For a list of all members of this type, see frmDomainMeldungstexte Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainMeldungstexte

Public Class frmDomainMeldungstexte
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainMeldungstexte Members


frmDomainMeldungstexte Members

frmDomainMeldungstexte overview

Constructors

constructor frmDomainMeldungstexte Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMeldungstexte_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMeldungstexte Class


frmDomainMeldungstexte Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte Properties

frmDomainMeldungstexte overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainMeldungstexte Class


frmDomainMeldungstexte Methods

frmDomainMeldungstexte overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMeldungstexte_Load

See Also

frmDomainMeldungstexte Class


frmDomainMeldungstexte.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "meldungstexte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("meldungstextnr", "meldungstextnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("inhalt", "inhalt"), New System.Data.Common.DataColumnMapping("Beschreibung", "Beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_meldungstexte_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_meldungstexte_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@meldungstextnr", System.Data.SqlDbType.Int, 4, "meldungstextnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Beschreibung", System.Data.SqlDbType.VarChar, 255, "Beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_meldungstexte_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@meldungstextnr", System.Data.SqlDbType.Int, 4, "meldungstextnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Beschreibung", System.Data.SqlDbType.VarChar, 255, "Beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_meldungstextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "meldungstextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_meldungstexte_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_meldungstextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "meldungstextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainMeldungstexte
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(688, 249)
        Me.Name = "frmDomainMeldungstexte"
        Me.Text = "Meldungstexte"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902) + ex.Message)
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte.frmDomainMeldungstexte_Load Method

Private Sub frmDomainMeldungstexte_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMeldungstexte_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "Meldungstexte"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMeldungstexte Fields

frmDomainMeldungstexte overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainMeldungstexte Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMeldungstexte


frmDomainMitarbeiter Class

For a list of all members of this type, see frmDomainMitarbeiter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainMitarbeiter

Public Class frmDomainMitarbeiter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainMitarbeiter Members


frmDomainMitarbeiter Members

frmDomainMitarbeiter overview

Constructors

constructor frmDomainMitarbeiter Constructor

Properties

property Eintrag
property Eintragnr
property Inaktive
property TBNameRight_Funktion
property TableName
property ToSelect
property TransferKey

Methods

method BtnConnectFnk_Click |
method BtnConnect_Click |
method C1TrueDBGrid1_FetchCellTips3 |
method CheckTeamFunktion |
method CheckUniqueTGNummer |
method Check_Changes |
method Check_Funktion_Changes |
method ConvertToTyp |
method Dispose |
method DomainList_AfterInsert |
method DomainList_BeforeColEdit |
method DomainList_BeforeInsert |
method DomainList_BeforeRowColChange |
method DomainList_FetchCellTips |
method DomainList_FetchScrollTips |
method DomainList_FilterChange |
method DomainList_RowColChange |
method FillDropDown |
method Formload |
method Funktionmitarbeiter_refresh |
method GetCountIsActive | Gibt die Anzahl Datensätze aus, welche im DataSet in der Spalte Aktiv true sind.
method InitializeComponent |
method MenuItem2_Click |
method Save_Data |
method Save_DataFunktion |
method Save_mitarbeiter_Data |
method ShowControlFunktion |
method ShowControlTeam |
method SpaltenTitel_Aktualisieren |
method TBFunktion_AfterUpdate |
method TBFunktion_BeforeUpdate |
method TBRight_Funktion_RowColChange |
method TBRight_Team_FetchScrollTips |
method TBRight_Team_RowColChange |
method TBTeam_AfterUpdate |
method TBTeam_BeforeUpdate |
method TBTeam_FetchCellTips |
method TBTeam_FetchScrollTips |
method Teammitarbeiter_refresh |
method Timer1_Tick |
method ToolBar1_ButtonClick |
method Update_Mitarbeiterdata |
method btnSaveFunktionmitarbeiter_Click |
method btnSaveTeammitarbeiter_Click |
method check_mitarbeiter_changes |
method domainlist_AfterColUpdate |
method frmClose |
method frmDomainEditor_Load |
method frmDomainMitarbeiter_Resize |
method optFunktion_Click |
method optMitarbeiter_Funktion_Click |
method optMitarbeiter_Team_Click |
method optTeam_Click |
method validateKlassifizierung |
method validateMitarbeiter |
method validateZuordnung |
method validateZuordnungFunction |
method validateZuordnungTeam |

Fields

field BtnConnect
field BtnConnectFnk
field C1TrueDBDropdown1
field DaFunktion
field DaRight_Funktion
field DataSet1
field DataSet2
field DataSet4
field DomainList
field DsRight_Funktion
field DsTeam
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label2
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field PanelFunktionen
field PanelTeam
field Splitter1
field Splitter2
field Splitter3
field Splitter4
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlConnection4
field SqlConnection5
field SqlConnection6
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlSelectCommand6
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field TBFunktion
field TBRight_Funktion
field TBRight_Team
field TBTeam
field Timer1
field ToolBar1
field ToolBarNeu
field ToolBtnExit
field ToolBtnSave
field btnSaveFunktionmitarbeiter
field btnSaveTeammitarbeiter
field components
field daTeam
field drpKlassifizierung
field dsFunltion
field m_Datamode
field m_Eintrag
field m_Eintragnr
field m_FunctionCount
field m_Inaktive
field m_Klassifizierung
field m_LastMAID
field m_LastRow
field m_NewDataRow
field m_TBNameRight_Funktion
field m_TableName
field m_TeamCount
field m_ToSelect
field m_TransferKey
field m_bAddFunktion
field m_bAddTeam
field m_dtKlassifizierung
field optFunktion
field optMitarbeiter_Funktion
field optMitarbeiter_Team
field optTeam
field selectedrow

See Also

frmDomainMitarbeiter Class


frmDomainMitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter Properties

frmDomainMitarbeiter overview

Properties

property Eintrag
property Eintragnr
property Inaktive
property TBNameRight_Funktion
property TableName
property ToSelect
property TransferKey

See Also

frmDomainMitarbeiter Class


frmDomainMitarbeiter.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
    Property Eintrag() As String
        Get
            Return m_Eintrag
        End Get
        Set(ByVal Value As String)
            m_Eintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
    Property Eintragnr() As Long
        Get
            Return m_Eintragnr
        End Get
        Set(ByVal Value As Long)
            m_Eintragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Inaktive Property

Property Inaktive() As Boolean

Source code

[Visual Basic]
    Property Inaktive() As Boolean
        Get
            Return m_Inaktive
        End Get
        Set(ByVal Value As Boolean)
            m_Inaktive = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBNameRight_Funktion Property

Property TBNameRight_Funktion() As String

Source code

[Visual Basic]
    Property TBNameRight_Funktion() As String
        Get
            Return m_TBNameRight_Funktion
        End Get
        Set(ByVal Value As String)
            m_TBNameRight_Funktion = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_TableName
        End Get
        Set(ByVal Value As String)
            m_TableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.ToSelect Property

Property ToSelect() As Boolean

Source code

[Visual Basic]
    Property ToSelect() As Boolean
        Get
            Return m_ToSelect
        End Get
        Set(ByVal Value As Boolean)
            m_ToSelect = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TransferKey Property

Property TransferKey() As Long

Source code

[Visual Basic]
    Property TransferKey() As Long
        Get
            Return m_TransferKey
        End Get
        Set(ByVal Value As Long)
            m_TransferKey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter Methods

frmDomainMitarbeiter overview

Methods

method BtnConnectFnk_Click |
method BtnConnect_Click |
method C1TrueDBGrid1_FetchCellTips3 |
method CheckTeamFunktion |
method CheckUniqueTGNummer |
method Check_Changes |
method Check_Funktion_Changes |
method ConvertToTyp |
method Dispose |
method DomainList_AfterInsert |
method DomainList_BeforeColEdit |
method DomainList_BeforeInsert |
method DomainList_BeforeRowColChange |
method DomainList_FetchCellTips |
method DomainList_FetchScrollTips |
method DomainList_FilterChange |
method DomainList_RowColChange |
method FillDropDown |
method Formload |
method Funktionmitarbeiter_refresh |
method GetCountIsActive | Gibt die Anzahl Datensätze aus, welche im DataSet in der Spalte Aktiv true sind.
method InitializeComponent |
method MenuItem2_Click |
method Save_Data |
method Save_DataFunktion |
method Save_mitarbeiter_Data |
method ShowControlFunktion |
method ShowControlTeam |
method SpaltenTitel_Aktualisieren |
method TBFunktion_AfterUpdate |
method TBFunktion_BeforeUpdate |
method TBRight_Funktion_RowColChange |
method TBRight_Team_FetchScrollTips |
method TBRight_Team_RowColChange |
method TBTeam_AfterUpdate |
method TBTeam_BeforeUpdate |
method TBTeam_FetchCellTips |
method TBTeam_FetchScrollTips |
method Teammitarbeiter_refresh |
method Timer1_Tick |
method ToolBar1_ButtonClick |
method Update_Mitarbeiterdata |
method btnSaveFunktionmitarbeiter_Click |
method btnSaveTeammitarbeiter_Click |
method check_mitarbeiter_changes |
method domainlist_AfterColUpdate |
method frmClose |
method frmDomainEditor_Load |
method frmDomainMitarbeiter_Resize |
method optFunktion_Click |
method optMitarbeiter_Funktion_Click |
method optMitarbeiter_Team_Click |
method optTeam_Click |
method validateKlassifizierung |
method validateMitarbeiter |
method validateZuordnung |
method validateZuordnungFunction |
method validateZuordnungTeam |

See Also

frmDomainMitarbeiter Class


frmDomainMitarbeiter.BtnConnectFnk_Click Method

Private Sub BtnConnectFnk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnectFnk.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnectFnk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnectFnk.Click
        Try
            Dim vdata As New edokadb.clsMitarbeiter_funktionsgruppe()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()

            Dim key As Long
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("mitarbeiter_funktionsgruppe")

            vdata.cpMainConnectionProvider = conn
            vdata.iMitarbeiter_funktionsgruppenr = New SqlInt32(CType(key, Int32))
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            vdata.iMitarbeiternr = New SqlInt32(CType(Me.DomainList.Columns(0).Value, Int32))
            vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBRight_Funktion.Columns(0).Value, Int32))
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
            vdata.Dispose()
            dbkey.Dispose()
            Me.Funktionmitarbeiter_refresh()
            'm_FunctionCount = Me.TBFunktion.Splits(0).Rows.Count()
            m_FunctionCount = GetCountIsActive(Me.dsFunltion)
            m_bAddFunktion = True

            Dim col_Message As New Collection()
            'If validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
            Me.DomainList.AllowFilter = validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion)
            'End If
        Catch
            MsgBox(Err.Description)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.BtnConnect_Click Method

Private Sub BtnConnect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Try
            Dim vdata As New edokadb.clsTeammitarbeiter()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        key = dbkey.get_dbkey("teammitarbeiter")
        vdata.cpMainConnectionProvider = conn
        vdata.iTeammitarbeiternr = New SqlInt32(CType(key, Int32))
        vdata.iTeamnr = New SqlInt32(CType(Me.TBRight_Team.Columns(0).Value, Int32))
        vdata.iMitarbeiternr = New SqlInt32(CType(Me.DomainList.Columns(0).Value, Int32))
        vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
        vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        vdata.iAnteil = New SqlInt32(CType(100, Int32))
        vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        conn.OpenConnection()
        vdata.Insert()
        conn.CloseConnection(True)
        vdata.Dispose()
        dbkey.Dispose()
        Me.Teammitarbeiter_refresh()
        'm_TeamCount = Me.TBTeam.Splits(0).Rows.Count()
        m_TeamCount = GetCountIsActive(Me.DsTeam)
        m_bAddTeam = True

        Dim col_Message As New Collection()
        'If validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
        Me.DomainList.AllowFilter = validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion)
            'End If
        Catch
            MsgBox(Err.Description)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.C1TrueDBGrid1_FetchCellTips3 Method

Private Sub C1TrueDBGrid1_FetchCellTips3( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellTips3(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs)
        Try
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = "team"
            ts.Feld = Me.TBRight_Team.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
            ts = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.CheckTeamFunktion Method

Private Function CheckTeamFunktion() As Boolean

Source code

[Visual Basic]
    Private Function CheckTeamFunktion() As Boolean
        Dim col_Message As New Collection()
        Dim iCnt As Integer
        Dim sMessage As String

        m_FunctionCount = GetCountIsActive(Me.dsFunltion)
        m_TeamCount = GetCountIsActive(Me.DsTeam)
        CheckTeamFunktion = True
        If Not validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
            For iCnt = 1 To col_Message.Count
                sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
            Next
            If m_Datamode = enumDatamode.Neu Then
                'Datensatz wurde noch nicht gespeichert
                sMessage = Globals.MyMsg.Get_Meldungstext(130) & vbCrLf & sMessage  'Speichern Sie die Mitarbeiterdaten und erstellen Sie folgende Zuordnungen
            End If
            MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
            Me.DomainList.Row = m_LastRow
            CheckTeamFunktion = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.CheckUniqueTGNummer Method

Private Function CheckUniqueTGNummer( _
   ByVal TgNummer As String, _
   ByVal MitarbeiterNr As Integer _
) As Boolean

Parameters

TgNummer
Required.
MitarbeiterNr
Required.

Source code

[Visual Basic]
    Private Function CheckUniqueTGNummer(ByVal TgNummer As String, ByVal MitarbeiterNr As Integer) As Boolean
        '===============================================================================
        'Description: Ueberprüft ob die TGNummer eindeutig ist
        'Input      :
        'Criteria   :
        'Output     : TGNummer ist eindeutig = True sonst = False
        'Erstellt   : koe 26.05.2004
        'Geaendert  :
        '===============================================================================
        Dim iAnzahl As Integer
        Dim sqlCmdToExecute As SqlCommand = New SqlCommand()

        sqlCmdToExecute.CommandText = "dbo.[sp_check_UniqueTGNummer]"
        sqlCmdToExecute.CommandType = CommandType.StoredProcedure

        sqlCmdToExecute.Parameters.Add(New SqlParameter("@TgNummer", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, TgNummer))
        sqlCmdToExecute.Parameters.Add(New SqlParameter("@MitarbeiterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, MitarbeiterNr))
        sqlCmdToExecute.Parameters.Add(New SqlParameter("@Anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iAnzahl))
        sqlCmdToExecute.Connection = Me.SqlConnection1

        ' Execute query.
        sqlCmdToExecute.ExecuteNonQuery()
        iAnzahl = New SqlInt32(CType(sqlCmdToExecute.Parameters.Item("@Anzahl").Value, Integer)).Value
        If iAnzahl > 0 Then
            CheckUniqueTGNummer = False
        Else
            CheckUniqueTGNummer = True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Check_Changes Method

Private Sub Check_Changes()

Source code

[Visual Basic]
    Private Sub Check_Changes()

        Dim msg As MsgBoxResult
        If Me.DsTeam.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(12)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Check_Funktion_Changes Method

Private Sub Check_Funktion_Changes()

Source code

[Visual Basic]
    Private Sub Check_Funktion_Changes()
        Dim msg As MsgBoxResult
        If Me.dsFunltion.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(131)
            If msg = MsgBoxResult.Yes Then
                Save_DataFunktion()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.ConvertToTyp Method

Public Function ConvertToTyp( _
   ByVal Source As Object, _
   Optional ByVal Datentyp As EnumDatentyp = EnumDatentyp.IINTEGER, _
   Optional ByVal DefaultValue As String = "0" _
) As Object

Parameters

Source
Required.
Datentyp
Optional. Default value is EnumDatentyp.IINTEGER.
DefaultValue
Optional. Default value is "0".

Source code

[Visual Basic]
    Public Function ConvertToTyp(ByVal Source As Object, _
                                Optional ByVal Datentyp As EnumDatentyp = EnumDatentyp.IINTEGER, _
                                Optional ByVal DefaultValue As String = "0") As Object
        ' Wandelt die System.DBNull.Value's jenach Datentyp in "" (leerstring)
        ' oder in 0 um.

        If Source Is System.DBNull.Value Then
            Source = DefaultValue
        End If

        Select Case Datentyp
            Case EnumDatentyp.BBOOLEAN
                ConvertToTyp = CBool(Source)
            Case EnumDatentyp.LLONG
                ConvertToTyp = CLng(Val(Source))
            Case EnumDatentyp.IINTEGER
                ConvertToTyp = CInt(Val(Source))
            Case EnumDatentyp.DDATUM
                ConvertToTyp = CDate(Source)
            Case EnumDatentyp.SSINGLE
                ConvertToTyp = CSng(Val(Source))
            Case EnumDatentyp.SSTRING
                ConvertToTyp = CStr(Source)
            Case EnumDatentyp.DDOUBLE
                ConvertToTyp = CDbl(Val(Source))
        End Select
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "aktiv" Then
                    Me.DomainList.Columns(i).Value = 1
                End If
                If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
                    Me.DomainList.Columns(i).Value = Now
                End If
                If m_Datamode = enumDatamode.Bearbeiten Then
                    If Me.DomainList.Columns(i).DataField = "mutiert_am" Then
                        Me.DomainList.Columns(i).Value = Now
                    End If
                    If Me.DomainList.Columns(i).DataField = "mutierer" Then
                        Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
                    End If

                End If
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_BeforeColEdit Method

Private Sub DomainList_BeforeColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs _
) Handles DomainList.BeforeColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs) Handles DomainList.BeforeColEdit
        Me.DomainList.AllowFilter = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_BeforeInsert Method

Private Sub DomainList_BeforeInsert( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DomainList.BeforeInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeInsert(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DomainList.BeforeInsert
        m_Datamode = enumDatamode.Neu
        Me.BtnConnect.Enabled = False
        Me.BtnConnectFnk.Enabled = False
        optMitarbeiter_Team.Enabled = False
        optTeam.Enabled = False

        optMitarbeiter_Funktion.Enabled = False
        optFunktion.Enabled = False
        m_bAddTeam = False
        m_bAddFunktion = False
        Me.DomainList.AllowFilter = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_BeforeRowColChange Method

Private Sub DomainList_BeforeRowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DomainList.BeforeRowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeRowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DomainList.BeforeRowColChange
        If optMitarbeiter_Funktion.Checked = False Then
            optMitarbeiter_Funktion.Checked = True
            Funktionmitarbeiter_refresh()
            ShowControlFunktion()
        End If
        If optMitarbeiter_Team.Checked = False Then
            optMitarbeiter_Team.Checked = True
            Teammitarbeiter_refresh()
            ShowControlTeam()
        End If
        m_LastRow = DomainList.Row
        m_LastMAID = Me.DomainList.Columns(0).Value
        m_Klassifizierung = Me.DomainList.Columns("Klasse").Value
        If optMitarbeiter_Funktion.Checked = True Then
            m_FunctionCount = GetCountIsActive(Me.dsFunltion)
        End If
        If optMitarbeiter_Team.Checked = True Then
            m_TeamCount = GetCountIsActive(Me.DsTeam)
        End If
        'm_FunctionCount = Me.TBFunktion.Splits(0).Rows.Count()
        'm_TeamCount = Me.TBTeam.Splits(0).Rows.Count()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_FetchCellTips Method

Private Sub DomainList_FetchCellTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles DomainList.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_FetchCellTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles DomainList.FetchCellTips
        Try
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = Me.TableName
            ts.Feld = Me.DomainList.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
            ts = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_FetchScrollTips Method

Private Sub DomainList_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles DomainList.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles DomainList.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.DomainList.Splits(0).Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_FilterChange Method

Private Sub DomainList_FilterChange( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.FilterChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_FilterChange(ByVal sender As Object, ByVal e As System.EventArgs) Handles DomainList.FilterChange
        Try
            If Me.DomainList.AllowFilter = False Then
                MsgBox(MyMsg.Get_Meldungstext(264), MsgBoxStyle.Information)
            End If
            If Me.DomainList.Splits(0).DisplayColumns.Count <> 0 Then
                If m_LastRow <> DomainList.Row Then
                    Check_Changes()
                    Teammitarbeiter_refresh()
                    Check_Funktion_Changes()
                    Funktionmitarbeiter_refresh()
                End If
            End If
            'Me.DomainList.Refresh()
            Me.Timer1.Start()

        Catch
            'MsgBox(Err.Description)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.DomainList_RowColChange Method

Private Sub DomainList_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DomainList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DomainList.RowColChange
        Dim col_Message As New Collection()
        Dim iCnt As Integer
        Dim sMessage As String
        '===============================================================================
        'Validierung der Teamzuordnung und Funktionszuordnung
        '===============================================================================
        If m_LastRow <> DomainList.Row Then

            If Me.DomainList.Columns("mitarbeiternr").CellText(m_LastRow) <> "" Then

                '===============================================================================
                'Validierung der Felder in der Mitarbeitertabelle
                '===============================================================================
                If Not validateMitarbeiter(col_Message, m_LastRow) Then
                    For iCnt = 1 To col_Message.Count
                        sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
                    Next
                    MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
                    Exit Sub
                End If

                m_FunctionCount = GetCountIsActive(Me.dsFunltion)
                m_TeamCount = GetCountIsActive(Me.DsTeam)
                'm_Klassifizierung = Me.DomainList.Columns("Klasse").Value

                If Not validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
                    For iCnt = 1 To col_Message.Count
                        sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
                    Next
                    If m_Datamode = enumDatamode.Neu Then
                        'Datensatz wurde noch nicht gespeichert
                        sMessage = Globals.MyMsg.Get_Meldungstext(130) & vbCrLf & sMessage  'Speichern Sie die Mitarbeiterdaten und erstellen Sie folgende Zuordnungen
                    End If
                    MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
                    Me.DomainList.Row = m_LastRow

                End If
                'Rel 3.0
                '24.11.2004 / BUD
                m_LastRow = DomainList.Row
            End If
            Check_Changes()     'Prüft Aenderungen im Dataset und speichert diese
            Teammitarbeiter_refresh()
            Check_Funktion_Changes()
            Funktionmitarbeiter_refresh()

        End If
        m_Klassifizierung = Me.DomainList.Columns("Klasse").Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.FillDropDown Method

Private Sub FillDropDown()

Source code

[Visual Basic]
    Private Sub FillDropDown()
        '===============================================================================
        'Spaltenbreite DrpRight
        '===============================================================================
        Dim ds As New DataSet()
        Dim sqlcmd As New SqlCommand()
        Dim da As New SqlDataAdapter(sqlcmd)
        Dim sTranslateTabelname As String
        Dim sTranslateColumn As String

        '======================================================================
        'Klassifizierung
        '======================================================================
        sTranslateTabelname = "Klassifizierung"

        Me.drpKlassifizierung.ListField = "bezeichnung"
        Me.drpKlassifizierung.DataField = "klassenID"

        If Not ds.Tables(sTranslateTabelname) Is Nothing Then
            ds.Tables(sTranslateTabelname).Clear()
        End If

        With sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "sp_Klassifizierung_select"
            .Connection = SqlConnection1
            .Parameters.Add("@mandantnr", Globals.MandantNr)
        End With

        Try
            da.Fill(ds, sTranslateTabelname)
            drpKlassifizierung.DataSource = ds
            Me.drpKlassifizierung.ValueTranslate = True
            Me.drpKlassifizierung.DataSource = ds
            Me.drpKlassifizierung.DataMember = sTranslateTabelname
            Me.drpKlassifizierung.DisplayColumns(0).Width = 30

            m_dtKlassifizierung = ds.Tables(0)

            Me.DomainList.Columns("Klassifizierung").DropDown = Me.drpKlassifizierung
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Formload Method

Public Sub Formload( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub Formload(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SuspendLayout()
        Dim ds As New edokadb.clsSysadminfunktion()
        Try
            ds.cpMainConnectionProvider = conn
            ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
            ds.SelectOne()
            If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
            If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
            If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
            If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
            Me.MenuItem1.Text = Me.Eintrag
        Catch
            'MsgBox("Error Resizing Form")
        Finally
        End Try
        ds.Dispose()
        Me.ResumeLayout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Funktionmitarbeiter_refresh Method

Private Sub Funktionmitarbeiter_refresh()

Source code

[Visual Basic]
    Private Sub Funktionmitarbeiter_refresh()
        Dim iKey As Integer
        If DomainList.Columns(0).CellText(DomainList.Row) = "" Then
            iKey = -1
        Else
            iKey = DomainList.Columns(0).CellText(DomainList.Row)
        End If

        Me.DaFunktion.SelectCommand.Parameters.Clear()
        ' Me.DaFunktion.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        If optMitarbeiter_Funktion.Checked Then
            'Mitarbeiter
            Me.DaFunktion.SelectCommand.Parameters.Add("@Key", iKey)
        Else
            'Funktion
            If DomainList.Columns(0).CellText(DomainList.Row) = "" Then
                Me.DaFunktion.SelectCommand.Parameters.Add("@Key", iKey)
            Else
                Me.DaFunktion.SelectCommand.Parameters.Add("@Key", Me.TBRight_Funktion.Columns(0).Value)
            End If
        End If
        Me.DaFunktion.SelectCommand.Parameters.Add("@Fokus", CInt(Math.Abs(Val(optMitarbeiter_Funktion.Checked))))

        Me.dsFunltion.Clear()
        Me.DaFunktion.Fill(Me.dsFunltion, "funktionmitarbeiter")
        Me.TBFunktion.DataSource = Me.dsFunltion
        Me.TBFunktion.DataMember = "funktionmitarbeiter"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.GetCountIsActive Method

Gibt die Anzahl Datensätze aus, welche im DataSet in der Spalte Aktiv true sind.

Private Function GetCountIsActive( _
   ByVal dsValidate As DataSet _
) As Long

Parameters

dsValidate
Required. DataSet welches geprüft werden soll

Author

Daniel Burren

Version

26.11.2004

Source code

[Visual Basic]
    Private Function GetCountIsActive(ByVal dsValidate As DataSet) As Long
        Dim dview As New DataView(dsValidate.Tables(0), "aktiv=True", "aktiv", DataViewRowState.CurrentRows)
        GetCountIsActive = dview.Count
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainMitarbeiter))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarNeu = New System.Windows.Forms.ToolBarButton()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.TBTeam = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.btnSaveTeammitarbeiter = New System.Windows.Forms.Button()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection5 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection4 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.daTeam = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DsTeam = New System.Data.DataSet()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlDataAdapter4 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.PanelTeam = New System.Windows.Forms.Panel()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.TBRight_Team = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.optTeam = New System.Windows.Forms.RadioButton()
        Me.optMitarbeiter_Team = New System.Windows.Forms.RadioButton()
        Me.BtnConnect = New System.Windows.Forms.Button()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.Splitter3 = New System.Windows.Forms.Splitter()
        Me.PanelFunktionen = New System.Windows.Forms.Panel()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.TBRight_Funktion = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.optFunktion = New System.Windows.Forms.RadioButton()
        Me.optMitarbeiter_Funktion = New System.Windows.Forms.RadioButton()
        Me.BtnConnectFnk = New System.Windows.Forms.Button()
        Me.Splitter4 = New System.Windows.Forms.Splitter()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.TBFunktion = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.btnSaveFunktionmitarbeiter = New System.Windows.Forms.Button()
        Me.DaRight_Funktion = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.DsRight_Funktion = New System.Data.DataSet()
        Me.dsFunltion = New System.Data.DataSet()
        Me.DaFunktion = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand6 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.drpKlassifizierung = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection6 = New System.Data.SqlClient.SqlConnection()
        Me.GroupBox1.SuspendLayout()
        CType(Me.TBTeam, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DsTeam, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.PanelTeam.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        CType(Me.TBRight_Team, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.PanelFunktionen.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        CType(Me.TBRight_Funktion, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel4.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        CType(Me.TBFunktion, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel3.SuspendLayout()
        CType(Me.DsRight_Funktion, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.dsFunltion, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.drpKlassifizierung, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2, Me.MenuItem3})
        Me.MenuItem1.MergeOrder = 1
        Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.MergeOrder = 1
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
        Me.MenuItem2.Text = "&Schliessen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
        Me.MenuItem3.Text = "&Daten sichern"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnExit, Me.ToolBtnSave, Me.ToolBarNeu})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(760, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBtnExit
        '
        Me.ToolBtnExit.ImageIndex = 2
        Me.ToolBtnExit.ToolTipText = "Beenden"
        '
        'ToolBtnSave
        '
        Me.ToolBtnSave.ImageIndex = 1
        Me.ToolBtnSave.ToolTipText = "Speichern"
        '
        'ToolBarNeu
        '
        Me.ToolBarNeu.ImageIndex = 3
        Me.ToolBarNeu.ToolTipText = "Neuen Mitarbeiter erstellen"
        '
        'Splitter1
        '
        Me.Splitter1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter1.Location = New System.Drawing.Point(0, 152)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(760, 8)
        Me.Splitter1.TabIndex = 5
        Me.Splitter1.TabStop = False
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBTeam, Me.Panel2})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Left
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(392, 176)
        Me.GroupBox1.TabIndex = 6
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Team - Zuweisung"
        '
        'TBTeam
        '
        Me.TBTeam.AllowFilter = True
        Me.TBTeam.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBTeam.AllowSort = True
        Me.TBTeam.AlternatingRows = True
        Me.TBTeam.CaptionHeight = 17
        Me.TBTeam.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.TBTeam.CollapseColor = System.Drawing.Color.Black
        Me.TBTeam.DataChanged = False
        Me.TBTeam.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBTeam.ExpandColor = System.Drawing.Color.Black
        Me.TBTeam.FilterBar = True
        Me.TBTeam.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBTeam.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.TBTeam.Location = New System.Drawing.Point(43, 16)
        Me.TBTeam.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBTeam.Name = "TBTeam"
        Me.TBTeam.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBTeam.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBTeam.PreviewInfo.ZoomFactor = 75
        Me.TBTeam.PrintInfo.ShowOptionsDialog = False
        Me.TBTeam.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBTeam.RowDivider = GridLines1
        Me.TBTeam.RowHeight = 15
        Me.TBTeam.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBTeam.ScrollTips = False
        Me.TBTeam.Size = New System.Drawing.Size(157, 144)
        Me.TBTeam.TabIndex = 9
        Me.TBTeam.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 153, 140</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 153, 140</ClientArea></Blob>"
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnSaveTeammitarbeiter})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Location = New System.Drawing.Point(3, 16)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(40, 157)
        Me.Panel2.TabIndex = 6
        '
        'btnSaveTeammitarbeiter
        '
        Me.btnSaveTeammitarbeiter.Image = CType(resources.GetObject("btnSaveTeammitarbeiter.Image"), System.Drawing.Bitmap)
        Me.btnSaveTeammitarbeiter.Location = New System.Drawing.Point(8, 8)
        Me.btnSaveTeammitarbeiter.Name = "btnSaveTeammitarbeiter"
        Me.btnSaveTeammitarbeiter.Size = New System.Drawing.Size(24, 23)
        Me.btnSaveTeammitarbeiter.TabIndex = 3
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("vorname", "vorname"), New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("kurzzeichen", "kurzzeichen"), New System.Data.Common.DataColumnMapping("anrede", "anrede"), New System.Data.Common.DataColumnMapping("tgnummer", "tgnummer"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("fax", "fax"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("unterschrift_text", "unterschrift_text"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("fuermandant", "fuermandant"), New System.Data.Common.DataColumnMapping("showtip", "showtip"), New System.Data.Common.DataColumnMapping("partnernr", "partnernr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("Mailempfang", "Mailempfang"), New System.Data.Common.DataColumnMapping("EdokaMesasge", "EdokaMesasge"), New System.Data.Common.DataColumnMapping("funktion", "funktion"), New System.Data.Common.DataColumnMapping("MailDirektVersenden", "MailDirektVersenden"), New System.Data.Common.DataColumnMapping("Rang", "Rang"), New System.Data.Common.DataColumnMapping("MailDokumentrueckgang", "MailDokumentrueckgang"), New System.Data.Common.DataColumnMapping("klassifizierung", "klassifizierung"), New System.Data.Common.DataColumnMapping("edoka_mail", "edoka_mail"), New System.Data.Common.DataColumnMapping("journalisierung", "journalisierung"), New System.Data.Common.DataColumnMapping("GebMeldung", "GebMeldung"), New System.Data.Common.DataColumnMapping("Mail_1", "Mail_1")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'SqlConnection5
        '
        Me.SqlConnection5.ConnectionString = "data source=tg339012;initial catalog=edoka_parameter;integrated security=SSPI;per" & _
        "sist security info=False;user id=dbedoka11;workstation id=TG602655;packet size=4" & _
        "096"
        '
        'SqlConnection4
        '
        Me.SqlConnection4.ConnectionString = "data source=TG339012;initial catalog=edoka_test;integrated security=SSPI;persist " & _
        "security info=False;workstation id=TG602645;packet size=4096"
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tg302011;initial catalog=edoka_parameter;persist security info=False;" & _
        "user id=sa;workstation id=TG602645;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "team", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("teamnr", "teamnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("kostenstellenr", "kostenstellenr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_team_aktiv_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_team_aktiv_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_team_aktiv_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_team_aktiv_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'daTeam
        '
        Me.daTeam.DeleteCommand = Me.SqlDeleteCommand3
        Me.daTeam.InsertCommand = Me.SqlInsertCommand3
        Me.daTeam.SelectCommand = Me.SqlSelectCommand3
        Me.daTeam.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "teammitarbeiter", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("teammitarbeiternr", "teammitarbeiternr"), New System.Data.Common.DataColumnMapping("teamnr", "teamnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("anteil", "anteil"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.daTeam.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_teammitarbeiter_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teammitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teammitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anteil", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anteil", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_teammitarbeiter_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teammitarbeiternr", System.Data.SqlDbType.Int, 4, "teammitarbeiternr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anteil", System.Data.SqlDbType.Int, 4, "anteil"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_teammitarbeiter_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_teammitarbeiter_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teammitarbeiternr", System.Data.SqlDbType.Int, 4, "teammitarbeiternr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anteil", System.Data.SqlDbType.Int, 4, "anteil"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teammitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teammitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anteil", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anteil", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DsTeam
        '
        Me.DsTeam.DataSetName = "NewDataSet"
        Me.DsTeam.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DomainList
        '
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Top
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(0, 25)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines2
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = True
        Me.DomainList.Size = New System.Drawing.Size(760, 127)
        Me.DomainList.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.DomainList.TabIndex = 4
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.WrapCellPointer = True
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{Locked:False;BackColor:255, 25" & _
        "5, 128;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:Highlig" & _
        "htText;BackColor:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelecto" & _
        "r{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, " & _
        "1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style" & _
        "11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.Merge" & _
        "View Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""" & _
        "17"" ColumnFooterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" Reco" & _
        "rdSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrol" & _
        "lGroup=""1""><ClientRect>0, 0, 756, 123</ClientRect><BorderSide>0</BorderSide><Cap" & _
        "tionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5" & _
        """ /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterB" & _
        "ar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent" & _
        "=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightR" & _
        "owStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=" & _
        """Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle paren" & _
        "t=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /" & _
        "><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><" & _
        "NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /" & _
        "><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><S" & _
        "tyle parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><St" & _
        "yle parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><St" & _
        "yle parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style p" & _
        "arent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><S" & _
        "tyle parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horz" & _
        "Splits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRec" & _
        "SelWidth><ClientArea>0, 0, 756, 123</ClientArea></Blob>"
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(424, 0)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines3
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(200, 216)
        Me.C1TrueDBDropdown1.TabIndex = 9
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 196, 212</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 196, 212</ClientA" & _
        "rea></Blob>"
        '
        'SqlDataAdapter4
        '
        Me.SqlDataAdapter4.DeleteCommand = Me.SqlDeleteCommand4
        Me.SqlDataAdapter4.InsertCommand = Me.SqlInsertCommand4
        Me.SqlDataAdapter4.SelectCommand = Me.SqlSelectCommand4
        Me.SqlDataAdapter4.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter4.UpdateCommand = Me.SqlUpdateCommand4
        '
        'SqlDeleteCommand4
        '
        Me.SqlDeleteCommand4.CommandText = "[pv_funktion_aktiv_delete]"
        Me.SqlDeleteCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand4.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand4
        '
        Me.SqlInsertCommand4.CommandText = "[pv_funktion_aktiv_insert]"
        Me.SqlInsertCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand4.Connection = Me.SqlConnection1
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[pv_funktion_aktiv_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand4
        '
        Me.SqlUpdateCommand4.CommandText = "[pv_funktion_aktiv_update]"
        Me.SqlUpdateCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand4.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'PanelTeam
        '
        Me.PanelTeam.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox2, Me.Splitter2, Me.GroupBox1})
        Me.PanelTeam.Dock = System.Windows.Forms.DockStyle.Top
        Me.PanelTeam.Location = New System.Drawing.Point(0, 160)
        Me.PanelTeam.Name = "PanelTeam"
        Me.PanelTeam.Size = New System.Drawing.Size(760, 176)
        Me.PanelTeam.TabIndex = 10
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBRight_Team, Me.Panel1})
        Me.GroupBox2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox2.Location = New System.Drawing.Point(400, 0)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(360, 176)
        Me.GroupBox2.TabIndex = 10
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Team"
        '
        'TBRight_Team
        '
        Me.TBRight_Team.AllowFilter = True
        Me.TBRight_Team.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBRight_Team.AllowSort = True
        Me.TBRight_Team.AllowUpdate = False
        Me.TBRight_Team.AlternatingRows = True
        Me.TBRight_Team.CaptionHeight = 17
        Me.TBRight_Team.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.TBRight_Team.CollapseColor = System.Drawing.Color.Black
        Me.TBRight_Team.DataChanged = False
        Me.TBRight_Team.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBRight_Team.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBRight_Team.ExpandColor = System.Drawing.Color.Black
        Me.TBRight_Team.FilterBar = True
        Me.TBRight_Team.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBRight_Team.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.TBRight_Team.Location = New System.Drawing.Point(96, 16)
        Me.TBRight_Team.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBRight_Team.Name = "TBRight_Team"
        Me.TBRight_Team.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBRight_Team.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBRight_Team.PreviewInfo.ZoomFactor = 75
        Me.TBRight_Team.PrintInfo.ShowOptionsDialog = False
        Me.TBRight_Team.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBRight_Team.RowDivider = GridLines4
        Me.TBRight_Team.RowHeight = 15
        Me.TBRight_Team.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBRight_Team.ScrollTips = False
        Me.TBRight_Team.Size = New System.Drawing.Size(261, 157)
        Me.TBRight_Team.TabIndex = 6
        Me.TBRight_Team.Text = "C1TrueDBGrid1"
        Me.TBRight_Team.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 257, 153</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cli" & _
        "entArea>0, 0, 257, 153</ClientArea></Blob>"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.optTeam, Me.optMitarbeiter_Team, Me.BtnConnect})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(3, 16)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(93, 157)
        Me.Panel1.TabIndex = 0
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 16)
        Me.Label1.TabIndex = 4
        Me.Label1.Text = "Fokus"
        '
        'optTeam
        '
        Me.optTeam.Location = New System.Drawing.Point(8, 58)
        Me.optTeam.Name = "optTeam"
        Me.optTeam.Size = New System.Drawing.Size(72, 16)
        Me.optTeam.TabIndex = 3
        Me.optTeam.Tag = ""
        Me.optTeam.Text = "Team"
        '
        'optMitarbeiter_Team
        '
        Me.optMitarbeiter_Team.Checked = True
        Me.optMitarbeiter_Team.Location = New System.Drawing.Point(8, 35)
        Me.optMitarbeiter_Team.Name = "optMitarbeiter_Team"
        Me.optMitarbeiter_Team.Size = New System.Drawing.Size(78, 16)
        Me.optMitarbeiter_Team.TabIndex = 2
        Me.optMitarbeiter_Team.TabStop = True
        Me.optMitarbeiter_Team.Text = "Mitarbeiter"
        '
        'BtnConnect
        '
        Me.BtnConnect.Location = New System.Drawing.Point(8, 92)
        Me.BtnConnect.Name = "BtnConnect"
        Me.BtnConnect.TabIndex = 1
        Me.BtnConnect.Text = "< &Verbinden"
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(392, 0)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(8, 176)
        Me.Splitter2.TabIndex = 9
        Me.Splitter2.TabStop = False
        '
        'Splitter3
        '
        Me.Splitter3.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter3.Location = New System.Drawing.Point(0, 336)
        Me.Splitter3.Name = "Splitter3"
        Me.Splitter3.Size = New System.Drawing.Size(760, 8)
        Me.Splitter3.TabIndex = 15
        Me.Splitter3.TabStop = False
        '
        'PanelFunktionen
        '
        Me.PanelFunktionen.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox4, Me.Splitter4, Me.GroupBox3})
        Me.PanelFunktionen.Dock = System.Windows.Forms.DockStyle.Fill
        Me.PanelFunktionen.Location = New System.Drawing.Point(0, 344)
        Me.PanelFunktionen.Name = "PanelFunktionen"
        Me.PanelFunktionen.Size = New System.Drawing.Size(760, 177)
        Me.PanelFunktionen.TabIndex = 16
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBRight_Funktion, Me.Panel4})
        Me.GroupBox4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox4.Location = New System.Drawing.Point(400, 0)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(360, 177)
        Me.GroupBox4.TabIndex = 2
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Funktionen"
        '
        'TBRight_Funktion
        '
        Me.TBRight_Funktion.AllowFilter = True
        Me.TBRight_Funktion.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBRight_Funktion.AllowSort = True
        Me.TBRight_Funktion.AllowUpdate = False
        Me.TBRight_Funktion.AlternatingRows = True
        Me.TBRight_Funktion.CaptionHeight = 17
        Me.TBRight_Funktion.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.TBRight_Funktion.CollapseColor = System.Drawing.Color.Black
        Me.TBRight_Funktion.DataChanged = False
        Me.TBRight_Funktion.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBRight_Funktion.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBRight_Funktion.ExpandColor = System.Drawing.Color.Black
        Me.TBRight_Funktion.FilterBar = True
        Me.TBRight_Funktion.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBRight_Funktion.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.TBRight_Funktion.Location = New System.Drawing.Point(96, 16)
        Me.TBRight_Funktion.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBRight_Funktion.Name = "TBRight_Funktion"
        Me.TBRight_Funktion.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBRight_Funktion.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBRight_Funktion.PreviewInfo.ZoomFactor = 75
        Me.TBRight_Funktion.PrintInfo.ShowOptionsDialog = False
        Me.TBRight_Funktion.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBRight_Funktion.RowDivider = GridLines5
        Me.TBRight_Funktion.RowHeight = 15
        Me.TBRight_Funktion.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBRight_Funktion.ScrollTips = False
        Me.TBRight_Funktion.Size = New System.Drawing.Size(261, 158)
        Me.TBRight_Funktion.TabIndex = 7
        Me.TBRight_Funktion.Text = "C1TrueDBGrid1"
        Me.TBRight_Funktion.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 257, 154</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cli" & _
        "entArea>0, 0, 257, 154</ClientArea></Blob>"
        '
        'Panel4
        '
        Me.Panel4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label2, Me.optFunktion, Me.optMitarbeiter_Funktion, Me.BtnConnectFnk})
        Me.Panel4.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel4.Location = New System.Drawing.Point(3, 16)
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(93, 158)
        Me.Panel4.TabIndex = 1
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(7, 15)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 16)
        Me.Label2.TabIndex = 7
        Me.Label2.Text = "Fokus"
        '
        'optFunktion
        '
        Me.optFunktion.Location = New System.Drawing.Point(7, 57)
        Me.optFunktion.Name = "optFunktion"
        Me.optFunktion.Size = New System.Drawing.Size(72, 16)
        Me.optFunktion.TabIndex = 6
        Me.optFunktion.Tag = ""
        Me.optFunktion.Text = "Funktion"
        '
        'optMitarbeiter_Funktion
        '
        Me.optMitarbeiter_Funktion.Checked = True
        Me.optMitarbeiter_Funktion.Location = New System.Drawing.Point(7, 35)
        Me.optMitarbeiter_Funktion.Name = "optMitarbeiter_Funktion"
        Me.optMitarbeiter_Funktion.Size = New System.Drawing.Size(78, 16)
        Me.optMitarbeiter_Funktion.TabIndex = 5
        Me.optMitarbeiter_Funktion.TabStop = True
        Me.optMitarbeiter_Funktion.Text = "Mitarbeiter"
        '
        'BtnConnectFnk
        '
        Me.BtnConnectFnk.Location = New System.Drawing.Point(8, 92)
        Me.BtnConnectFnk.Name = "BtnConnectFnk"
        Me.BtnConnectFnk.TabIndex = 1
        Me.BtnConnectFnk.Text = "< &Verbinden"
        '
        'Splitter4
        '
        Me.Splitter4.Location = New System.Drawing.Point(392, 0)
        Me.Splitter4.Name = "Splitter4"
        Me.Splitter4.Size = New System.Drawing.Size(8, 177)
        Me.Splitter4.TabIndex = 1
        Me.Splitter4.TabStop = False
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBFunktion, Me.Panel3})
        Me.GroupBox3.Dock = System.Windows.Forms.DockStyle.Left
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(392, 177)
        Me.GroupBox3.TabIndex = 0
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Funktions - Zuweisung"
        '
        'TBFunktion
        '
        Me.TBFunktion.AllowFilter = True
        Me.TBFunktion.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBFunktion.AllowSort = True
        Me.TBFunktion.AlternatingRows = True
        Me.TBFunktion.CaptionHeight = 17
        Me.TBFunktion.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.TBFunktion.CollapseColor = System.Drawing.Color.Black
        Me.TBFunktion.DataChanged = False
        Me.TBFunktion.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBFunktion.ExpandColor = System.Drawing.Color.Black
        Me.TBFunktion.FilterBar = True
        Me.TBFunktion.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBFunktion.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.TBFunktion.Location = New System.Drawing.Point(43, 16)
        Me.TBFunktion.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBFunktion.Name = "TBFunktion"
        Me.TBFunktion.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBFunktion.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBFunktion.PreviewInfo.ZoomFactor = 75
        Me.TBFunktion.PrintInfo.ShowOptionsDialog = False
        Me.TBFunktion.RecordSelectorWidth = 16
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBFunktion.RowDivider = GridLines6
        Me.TBFunktion.RowHeight = 15
        Me.TBFunktion.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBFunktion.ScrollTips = False
        Me.TBFunktion.Size = New System.Drawing.Size(157, 158)
        Me.TBFunktion.TabIndex = 8
        Me.TBFunktion.Text = "C1TrueDBGrid1"
        Me.TBFunktion.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 153, 154</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cli" & _
        "entArea>0, 0, 153, 154</ClientArea></Blob>"
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnSaveFunktionmitarbeiter})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel3.Location = New System.Drawing.Point(3, 16)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(40, 158)
        Me.Panel3.TabIndex = 0
        '
        'btnSaveFunktionmitarbeiter
        '
        Me.btnSaveFunktionmitarbeiter.Image = CType(resources.GetObject("btnSaveFunktionmitarbeiter.Image"), System.Drawing.Bitmap)
        Me.btnSaveFunktionmitarbeiter.Location = New System.Drawing.Point(8, 8)
        Me.btnSaveFunktionmitarbeiter.Name = "btnSaveFunktionmitarbeiter"
        Me.btnSaveFunktionmitarbeiter.Size = New System.Drawing.Size(24, 23)
        Me.btnSaveFunktionmitarbeiter.TabIndex = 4
        '
        'DaRight_Funktion
        '
        Me.DaRight_Funktion.SelectCommand = Me.SqlSelectCommand5
        Me.DaRight_Funktion.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_funktionsgruppe_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("funktionszuweisung", "funktionszuweisung"), New System.Data.Common.DataColumnMapping("barcodeetiketten", "barcodeetiketten"), New System.Data.Common.DataColumnMapping("edokapartner", "edokapartner")})})
        '
        'SqlSelectCommand5
        '
        Me.SqlSelectCommand5.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand5.Connection = Me.SqlConnection1
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'DsRight_Funktion
        '
        Me.DsRight_Funktion.DataSetName = "NewDataSet"
        Me.DsRight_Funktion.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'dsFunltion
        '
        Me.dsFunltion.DataSetName = "NewDataSet"
        Me.dsFunltion.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DaFunktion
        '
        Me.DaFunktion.DeleteCommand = Me.SqlDeleteCommand5
        Me.DaFunktion.InsertCommand = Me.SqlInsertCommand5
        Me.DaFunktion.SelectCommand = Me.SqlSelectCommand6
        Me.DaFunktion.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter_funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiter_funktionsgruppenr", "mitarbeiter_funktionsgruppenr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.DaFunktion.UpdateCommand = Me.SqlUpdateCommand5
        '
        'SqlDeleteCommand5
        '
        Me.SqlDeleteCommand5.CommandText = "[pv_mitarbeiter_funktionsgruppe_delete]"
        Me.SqlDeleteCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand5.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand5
        '
        Me.SqlInsertCommand5.CommandText = "[pv_mitarbeiter_funktionsgruppe_insert]"
        Me.SqlInsertCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand5.Connection = Me.SqlConnection1
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, "mitarbeiter_funktionsgruppenr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand6
        '
        Me.SqlSelectCommand6.CommandText = "[sp_mitarbeiterfunktion_select]"
        Me.SqlSelectCommand6.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand6.Connection = Me.SqlConnection1
        Me.SqlSelectCommand6.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand6.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand6.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand5
        '
        Me.SqlUpdateCommand5.CommandText = "[pv_mitarbeiter_funktionsgruppe_update]"
        Me.SqlUpdateCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand5.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, "mitarbeiter_funktionsgruppenr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'drpKlassifizierung
        '
        Me.drpKlassifizierung.AllowColMove = True
        Me.drpKlassifizierung.AllowColSelect = True
        Me.drpKlassifizierung.AllowFilter = True
        Me.drpKlassifizierung.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpKlassifizierung.AllowSort = True
        Me.drpKlassifizierung.AlternatingRows = False
        Me.drpKlassifizierung.CaptionHeight = 17
        Me.drpKlassifizierung.ColumnCaptionHeight = 17
        Me.drpKlassifizierung.ColumnFooterHeight = 17
        Me.drpKlassifizierung.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpKlassifizierung.FetchRowStyles = False
        Me.drpKlassifizierung.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.drpKlassifizierung.LayoutFileName = ""
        Me.drpKlassifizierung.LayoutName = ""
        Me.drpKlassifizierung.LayoutURL = ""
        Me.drpKlassifizierung.Location = New System.Drawing.Point(80, 40)
        Me.drpKlassifizierung.Name = "drpKlassifizierung"
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpKlassifizierung.RowDivider = GridLines7
        Me.drpKlassifizierung.RowHeight = 15
        Me.drpKlassifizierung.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpKlassifizierung.ScrollTips = False
        Me.drpKlassifizierung.Size = New System.Drawing.Size(232, 216)
        Me.drpKlassifizierung.TabIndex = 17
        Me.drpKlassifizierung.Text = "C1TrueDBDropdown2"
        Me.drpKlassifizierung.Visible = False
        Me.drpKlassifizierung.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 228, 212</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 228, 212</ClientA" & _
        "rea></Blob>"
        '
        'Timer1
        '
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_mitarbeiter_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection6
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_mitarbeiter_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection6
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kurzzeichen", System.Data.SqlDbType.VarChar, 10, "kurzzeichen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anrede", System.Data.SqlDbType.VarChar, 50, "anrede"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mailempfang", System.Data.SqlDbType.Bit, 1, "Mailempfang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EdokaMesasge", System.Data.SqlDbType.Bit, 1, "EdokaMesasge"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktion", System.Data.SqlDbType.VarChar, 255, "funktion"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@MailDirektVersenden", System.Data.SqlDbType.Bit, 1, "MailDirektVersenden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Rang", System.Data.SqlDbType.VarChar, 255, "Rang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@MailDokumentrueckgang", System.Data.SqlDbType.Bit, 1, "MailDokumentrueckgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_mail", System.Data.SqlDbType.Bit, 1, "edoka_mail"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@journalisierung", System.Data.SqlDbType.Bit, 1, "journalisierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@GebMeldung", System.Data.SqlDbType.Bit, 1, "GebMeldung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_1", System.Data.SqlDbType.VarChar, 50, "Mail_1"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_mitarbeiter_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection6
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kurzzeichen", System.Data.SqlDbType.VarChar, 10, "kurzzeichen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anrede", System.Data.SqlDbType.VarChar, 50, "anrede"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mailempfang", System.Data.SqlDbType.Bit, 1, "Mailempfang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@EdokaMesasge", System.Data.SqlDbType.Bit, 1, "EdokaMesasge"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktion", System.Data.SqlDbType.VarChar, 255, "funktion"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@MailDirektVersenden", System.Data.SqlDbType.Bit, 1, "MailDirektVersenden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Rang", System.Data.SqlDbType.VarChar, 255, "Rang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@MailDokumentrueckgang", System.Data.SqlDbType.Bit, 1, "MailDokumentrueckgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_mail", System.Data.SqlDbType.Bit, 1, "edoka_mail"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@journalisierung", System.Data.SqlDbType.Bit, 1, "journalisierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@GebMeldung", System.Data.SqlDbType.Bit, 1, "GebMeldung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mail_1", System.Data.SqlDbType.VarChar, 50, "Mail_1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EdokaMesasge", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EdokaMesasge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_GebMeldung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "GebMeldung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_MailDirektVersenden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "MailDirektVersenden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_MailDokumentrueckgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "MailDokumentrueckgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mailempfang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mailempfang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Rang", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Rang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anrede", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anrede", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_mail", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_mail", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktion", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktion", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_journalisierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "journalisierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kurzzeichen", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kurzzeichen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_mitarbeiter_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection6
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_EdokaMesasge", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "EdokaMesasge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_GebMeldung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "GebMeldung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_MailDirektVersenden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "MailDirektVersenden", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_MailDokumentrueckgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "MailDokumentrueckgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mail_1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mail_1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mailempfang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mailempfang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Rang", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Rang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anrede", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anrede", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_mail", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_mail", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktion", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktion", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_journalisierung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "journalisierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kurzzeichen", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kurzzeichen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection6
        '
        Me.SqlConnection6.ConnectionString = "data source=server02;initial catalog=EDOKA;integrated security=SSPI;persist secur" & _
        "ity info=False;workstation id=WSDEV02;packet size=4096"
        '
        'frmDomainMitarbeiter
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(760, 521)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpKlassifizierung, Me.PanelFunktionen, Me.Splitter3, Me.PanelTeam, Me.C1TrueDBDropdown1, Me.Splitter1, Me.DomainList, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmDomainMitarbeiter"
        Me.ShowInTaskbar = False
        Me.Text = "frmDomainMitarbeiter"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.TBTeam, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DsTeam, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.PanelTeam.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.TBRight_Team, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.PanelFunktionen.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        CType(Me.TBRight_Funktion, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel4.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        CType(Me.TBFunktion, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel3.ResumeLayout(False)
        CType(Me.DsRight_Funktion, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.dsFunltion, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.drpKlassifizierung, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            daTeam.Update(Me.DsTeam)
        Catch ex As Exception
            'MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Save_DataFunktion Method

Private Function Save_DataFunktion() As Boolean

Source code

[Visual Basic]
    Private Function Save_DataFunktion() As Boolean
        Save_DataFunktion = True
        Try
            Me.DaFunktion.Update(Me.dsFunltion, "funktionmitarbeiter")

            'DaFunktion.Update(Me.dsFunltion)
        Catch ex As Exception
            'MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_DataFunktion = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Save_mitarbeiter_Data Method

Private Function Save_mitarbeiter_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_mitarbeiter_Data() As Boolean
        Try
            Save_mitarbeiter_Data = True
            SqlDataAdapter1.Update(Me.DataSet1)
            Update_Mitarbeiterdata()
            m_Datamode = enumDatamode.Bearbeiten
        Catch sqlEx As SqlException
            If InStr(sqlEx.Message, "IX_TGNummer") Then
                MsgBox(Globals.MyMsg.Get_Meldungstext(904))
            End If
            Save_mitarbeiter_Data = False

        Catch ex As Exception
            MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_mitarbeiter_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.ShowControlFunktion Method

Private Sub ShowControlFunktion()

Source code

[Visual Basic]
    Private Sub ShowControlFunktion()
        Me.TBFunktion.Splits(0).DisplayColumns("vorname").Visible = Not optMitarbeiter_Funktion.Checked
        Me.TBFunktion.Splits(0).DisplayColumns("nachname").Visible = Not optMitarbeiter_Funktion.Checked
        Me.TBFunktion.Splits(0).DisplayColumns("tgnummer").Visible = Not optMitarbeiter_Funktion.Checked
        '  Me.TBFunktion.Splits(0).DisplayColumns("mitarbeiternr").Visible = Not optMitarbeiter_Funktion.Checked
        '  Me.TBFunktion.Splits(0).DisplayColumns("Funktion").Visible = optMitarbeiter_Funktion.Checked
        Me.BtnConnectFnk.Enabled = optMitarbeiter_Funktion.Checked

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.ShowControlTeam Method

Private Sub ShowControlTeam()

Source code

[Visual Basic]
    Private Sub ShowControlTeam()
        Me.TBTeam.Splits(0).DisplayColumns("vorname").Visible = Not optMitarbeiter_Team.Checked
        Me.TBTeam.Splits(0).DisplayColumns("nachname").Visible = Not optMitarbeiter_Team.Checked
        Me.TBTeam.Splits(0).DisplayColumns("tgnummer").Visible = Not optMitarbeiter_Team.Checked
        Me.TBTeam.Splits(0).DisplayColumns("mitarbeiternr").Visible = Not optMitarbeiter_Team.Checked
        Me.TBTeam.Splits(0).DisplayColumns("Team").Visible = optMitarbeiter_Team.Checked

        Me.BtnConnect.Enabled = optMitarbeiter_Team.Checked
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tblnr As Integer, _
   ByVal tblname As String, _
   ByVal ds As DataSet _
)

Parameters

tblnr
Required.
tblname
Required.
ds
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        t = ds.Tables(0)
        If tblnr = 1 Then
            ts.Tabelle = tblname
            For i = 0 To Me.DomainList.Columns.Count - 1
                Dim s As String
                s = Me.DomainList.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                If ts.spaltenname <> "" Then
                    Me.DomainList.Columns(i).Caption = ts.spaltenname
                    If ts.ColWith = 0 Then
                        Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                        Me.DomainList.Splits(0).DisplayColumns(i).Visible = False
                    Else
                        Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If

                    'If Me.DomainList.Columns(i).Caption = "" Then
                    '    Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                    'Else
                    '    Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    'End If
                    If ts.locked Then
                        Me.DomainList.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If
                    'Präsentation von aktiv
                    If Me.DomainList.Columns(i).DataField = "aktiv" Then
                        Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.DomainList.Columns(i).ValueItems.DefaultItem = True
                        Me.DomainList.Columns(i).DefaultValue = True
                        Me.DomainList.Columns(i).FilterText = True
                    End If
                    If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
                        Me.DomainList.Columns(i).DefaultValue = Now
                    End If
                Else
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
        If tblnr = 2 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBTeam.Columns.Count - 1
                Dim s As String
                s = Me.TBTeam.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBTeam.Columns(i).Caption = ts.spaltenname
                If ts.ColWith = 0 Then
                    Me.TBTeam.Splits(0).DisplayColumns(i).Width = 0
                    Me.TBTeam.Splits(0).DisplayColumns(i).Visible = False
                Else
                    Me.TBTeam.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If

                'If Me.TBTeam.Columns(i).Caption = "" Then
                '    Me.TBTeam.Splits(0).DisplayColumns(i).Width = 0
                'Else
                '    Me.TBTeam.Splits(0).DisplayColumns(i).Width = ts.ColWith
                'End If
                If ts.locked Then
                    Me.TBTeam.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBTeam.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBTeam.Columns(i).DataField = "aktiv" Then
                    Me.TBTeam.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBTeam.Columns(i).ValueItems.DefaultItem = True
                    Me.TBTeam.Columns(i).DefaultValue = True
                    Me.TBTeam.Columns(i).FilterText = True
                End If
                If Me.TBTeam.Columns(i).DataField = "erstellt_am" Then
                    Me.TBTeam.Columns(i).DefaultValue = Now
                End If
            Next
        End If
        If tblnr = 3 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBRight_Team.Columns.Count - 1
                Dim s As String
                s = Me.TBRight_Team.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBRight_Team.Columns(i).Caption = ts.spaltenname
                If ts.ColWith = 0 Then
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                    Me.DomainList.Splits(0).DisplayColumns(i).Visible = False
                Else
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If

                'If Me.TBRight_Team.Columns(i).Caption = "" Then
                '    Me.TBRight_Team.Splits(0).DisplayColumns(i).Width = 0
                'Else
                '    Me.TBRight_Team.Splits(0).DisplayColumns(i).Width = ts.ColWith
                'End If
                If ts.locked Then
                    Me.TBRight_Team.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBRight_Team.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBRight_Team.Columns(i).DataField = "aktiv" Then
                    Me.TBRight_Team.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBRight_Team.Columns(i).ValueItems.DefaultItem = True
                    Me.TBRight_Team.Columns(i).DefaultValue = True
                    Me.TBRight_Team.Columns(i).FilterText = True
                End If
                If Me.TBRight_Team.Columns(i).DataField = "erstellt_am" Then
                    Me.TBRight_Team.Columns(i).DefaultValue = Now
                End If
            Next
        End If
        'Tabelle Funktionen
        If tblnr = 4 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBRight_Funktion.Columns.Count - 1
                Dim s As String
                s = Me.TBRight_Funktion.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                If ts.spaltenname <> "" Then
                    Me.TBRight_Funktion.Columns(i).Caption = ts.spaltenname
                    If ts.ColWith = 0 Then
                        Me.TBRight_Funktion.Splits(0).DisplayColumns(i).Width = 0
                        Me.TBRight_Funktion.Splits(0).DisplayColumns(i).Visible = False
                    Else
                        Me.TBRight_Funktion.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If

                    If ts.locked Then
                        Me.TBRight_Funktion.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.TBRight_Funktion.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If
                    'Präsentation von aktiv
                    If Me.TBRight_Funktion.Columns(i).DataField = "aktiv" Then
                        Me.TBRight_Funktion.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.TBRight_Funktion.Columns(i).ValueItems.DefaultItem = True
                        Me.TBRight_Funktion.Columns(i).DefaultValue = True
                        Me.TBRight_Funktion.Columns(i).FilterText = True
                    End If
                    If Me.TBRight_Funktion.Columns(i).DataField = "erstellt_am" Then
                        Me.TBRight_Funktion.Columns(i).DefaultValue = Now
                    End If
                Else
                    Me.TBRight_Funktion.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
        'Zuordnung Mitarbeiter Funktion
        If tblnr = 5 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBFunktion.Columns.Count - 1
                Dim s As String
                s = Me.TBFunktion.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBFunktion.Columns(i).Caption = ts.spaltenname
                If ts.ColWith = 0 Then
                    Me.TBFunktion.Splits(0).DisplayColumns(i).Width = 0
                    Me.TBFunktion.Splits(0).DisplayColumns(i).Visible = False
                Else
                    Me.TBFunktion.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                If ts.locked Then
                    Me.TBFunktion.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBFunktion.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBFunktion.Columns(i).DataField = "aktiv" Then
                    Me.TBFunktion.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBFunktion.Columns(i).ValueItems.DefaultItem = True
                    Me.TBFunktion.Columns(i).DefaultValue = True
                    Me.TBFunktion.Columns(i).FilterText = True
                End If
                If Me.TBFunktion.Columns(i).DataField = "erstellt_am" Then
                    Me.TBFunktion.Columns(i).DefaultValue = Now
                End If
            Next
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBFunktion_AfterUpdate Method

Private Sub TBFunktion_AfterUpdate( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TBFunktion.AfterUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBFunktion_AfterUpdate(ByVal sender As Object, ByVal e As System.EventArgs) Handles TBFunktion.AfterUpdate
        m_bAddFunktion = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBFunktion_BeforeUpdate Method

Private Sub TBFunktion_BeforeUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles TBFunktion.BeforeUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBFunktion_BeforeUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles TBFunktion.BeforeUpdate
        'Dim col_Message As New Collection()
        'Dim iCnt As Integer
        'Dim sMessage As String
        ''===============================================================================
        ''Validierung der Funktionzuordnung
        ''===============================================================================
        'If Me.DomainList.Columns("mitarbeiternr").Text <> "" Then
        '    If Not validateZuordnung(col_Message, Me.DomainList.Bookmark, EnumValidierung.Funktion) Then
        '        For iCnt = 1 To col_Message.Count
        '            sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
        '        Next
        '        MsgBox(sMessage, MsgBoxStyle.Exclamation, "Funktion")
        '        e.Cancel = True
        '    End If
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBRight_Funktion_RowColChange Method

Private Sub TBRight_Funktion_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight_Funktion.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Funktion_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight_Funktion.RowColChange
        If Me.optFunktion.Checked Then
            'Check_Funktion_Changes()
            Funktionmitarbeiter_refresh()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBRight_Team_FetchScrollTips Method

Private Sub TBRight_Team_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBRight_Team.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Team_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBRight_Team.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBRight_Team.Splits(0).Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBRight_Team_RowColChange Method

Private Sub TBRight_Team_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight_Team.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Team_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight_Team.RowColChange
        If Me.optTeam.Checked Then
            Check_Changes()
            Teammitarbeiter_refresh()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBTeam_AfterUpdate Method

Private Sub TBTeam_AfterUpdate( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TBTeam.AfterUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBTeam_AfterUpdate(ByVal sender As Object, ByVal e As System.EventArgs) Handles TBTeam.AfterUpdate
        m_bAddTeam = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBTeam_BeforeUpdate Method

Private Sub TBTeam_BeforeUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles TBTeam.BeforeUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBTeam_BeforeUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles TBTeam.BeforeUpdate
        'Dim col_Message As New Collection()
        'Dim iCnt As Integer
        'Dim sMessage As String

        ''===============================================================================
        ''Validierung der Teamzuordnung
        ''===============================================================================
        'If Me.DomainList.Columns("mitarbeiternr").Text <> "" Then
        '    If Not validateZuordnung(col_Message, Me.DomainList.Bookmark, EnumValidierung.Team) Then
        '        For iCnt = 1 To col_Message.Count
        '            sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
        '        Next
        '        MsgBox(sMessage, MsgBoxStyle.Exclamation, "Team")
        '        e.Cancel = True
        '    Else
        '    End If
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBTeam_FetchCellTips Method

Private Sub TBTeam_FetchCellTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles TBTeam.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBTeam_FetchCellTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles TBTeam.FetchCellTips
        Try
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = "teammitarbeiter"
            ts.Feld = Me.TBTeam.Columns(e.ColIndex).DataField
            ts.getspalte()
            e.CellTip = ts.TipText
            ts = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.TBTeam_FetchScrollTips Method

Private Sub TBTeam_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBTeam.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBTeam_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBTeam.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBTeam.Splits(0).Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Teammitarbeiter_refresh Method

Private Sub Teammitarbeiter_refresh()

Source code

[Visual Basic]
    Private Sub Teammitarbeiter_refresh()
        Dim iKey As Integer
        If DomainList.Columns(0).CellText(DomainList.Row) = "" Then
            iKey = -1
        Else
            iKey = DomainList.Columns(0).CellText(DomainList.Row)
        End If
        Me.daTeam.SelectCommand.Parameters.Clear()
        Me.daTeam.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        If optMitarbeiter_Team.Checked Then
            'Mitarbeiter
            ' Me.daTeam.SelectCommand.Parameters.Add("@Key", Me.DomainList.Columns(0).Value)
            Me.daTeam.SelectCommand.Parameters.Add("@Key", iKey)
        Else
            'Team
            If DomainList.Columns(0).CellText(DomainList.Row) = "" Then
                Me.daTeam.SelectCommand.Parameters.Add("@Key", iKey)
            Else
                Me.daTeam.SelectCommand.Parameters.Add("@Key", Me.TBRight_Team.Columns(0).Value)
            End If
        End If
        Me.daTeam.SelectCommand.Parameters.Add("@Fokus", CInt(Math.Abs(Val(optMitarbeiter_Team.Checked))))

        Me.DsTeam.Clear()
        Me.daTeam.Fill(Me.DsTeam)
        Me.TBTeam.DataSource = Me.DsTeam
        Me.TBTeam.DataMember = "teammitarbeiter"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Timer1_Tick Method

Private Sub Timer1_Tick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Timer1.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Timer1.Tick
        Try
            If Me.DomainList.Columns("Klasse").Value <> "" Then
                m_Klassifizierung = Me.DomainList.Columns("Klasse").Value
            Else
                m_Klassifizierung = 1
            End If
        Catch
            m_Klassifizierung = Me.DomainList.Columns("Klasse").Value
        End Try
        Check_Changes()
        Teammitarbeiter_refresh()
        Check_Funktion_Changes()
        Funktionmitarbeiter_refresh()
        Me.Timer1.Stop()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim col_Message As New Collection()
        Dim iCnt As Integer
        Dim sMessage As String
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                '******************************************
                'close button
                '******************************************
                Close()
            Case 1
                '******************************************
                'Speichern
                '******************************************
                Me.DomainList.Col = 1
                If Not validateMitarbeiter(col_Message, m_LastRow) Then
                    For iCnt = 1 To col_Message.Count
                        sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
                    Next
                    MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
                    Me.DomainList.AllowFilter = False
                    Exit Sub
                End If

                Save_Data()
                Me.ActiveControl = Me.ToolBar1
                Save_mitarbeiter_Data()
                Save_DataFunktion()
                Me.BtnConnect.Enabled = True
                Me.BtnConnectFnk.Enabled = True
                optMitarbeiter_Team.Enabled = True
                optTeam.Enabled = True
                m_NewDataRow = False
                optMitarbeiter_Funktion.Enabled = True
                optFunktion.Enabled = True
                If Not validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
                    Me.DomainList.AllowFilter = False
                Else
                    '
                End If
            Case 2
                '******************************************
                'Neuer Mitarbeiter erfassen
                '******************************************
                'Prüfen ob bereits gespeichert
                If m_NewDataRow = True Then
                    MsgBox(MyMsg.Get_Meldungstext(130), MsgBoxStyle.Information)
                    Exit Select
                End If

                m_FunctionCount = GetCountIsActive(Me.dsFunltion)
                m_TeamCount = GetCountIsActive(Me.DsTeam)
                If Not validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
                    For iCnt = 1 To col_Message.Count
                        sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
                    Next
                    If BtnConnect.Enabled = False Then
                        sMessage = Globals.MyMsg.Get_Meldungstext(130) & vbCrLf & sMessage
                        'daten sind noch nicht gespeichert
                        sMessage = sMessage & vbCrLf & Globals.MyMsg.Get_Meldungstext(133)
                        Select Case MsgBox(sMessage, MsgBoxStyle.YesNo + MsgBoxStyle.Exclamation, "Mitarbeiter")
                            Case MsgBoxResult.Yes
                                Exit Sub
                            Case MsgBoxResult.No
                                Exit Sub
                        End Select
                    Else
                        'daten sind gespeichert Aber noch keine Zuordnung
                        MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
                    End If

                    Exit Sub
                End If

                m_NewDataRow = True

                Dim i As Integer
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long

                Me.DomainList.AllowFilter = True
                Me.DomainList.FilterActive = False
                For i = 0 To Me.DomainList.Columns.Count - 1
                    Me.DomainList.Columns(i).FilterText = ""
                    If Me.DomainList.Columns(i).DataField = "aktiv" Then
                        Me.DomainList.Columns(i).FilterText = True
                    End If
                Next
                Me.DomainList.FilterActive = True

                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                dbkey.Dispose()

                Me.DomainList.Columns(0).FilterText = key
                Me.DomainList.Focus()
                i = Me.DomainList.Splits(0).Rows.Count + 1
                Try
                    With DomainList
                        .AllowAddNew = True
                        .MoveLast()
                        .Row = Me.DomainList.Row + 1
                        .Select()
                        .Columns(0).Value = key
                        .Columns("mandantnr").Value = Globals.MandantNr
                        .AllowAddNew = False
                    End With
                Catch ex As Exception
                    MsgBox("Caught exception: " & ex.Message)
                End Try
                Me.DomainList.Refresh()

                Me.DomainList.Col = 1
                Me.DomainList.AllowFilter = False
                Teammitarbeiter_refresh()
                Funktionmitarbeiter_refresh()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.Update_Mitarbeiterdata Method

Private Sub Update_Mitarbeiterdata()

Source code

[Visual Basic]
    Private Sub Update_Mitarbeiterdata()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_MitarbeiterProfilFavoriten"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            conn.OpenConnection()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
            'Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.btnSaveFunktionmitarbeiter_Click Method

Private Sub btnSaveFunktionmitarbeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSaveFunktionmitarbeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSaveFunktionmitarbeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSaveFunktionmitarbeiter.Click
        Save_DataFunktion()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.btnSaveTeammitarbeiter_Click Method

Private Sub btnSaveTeammitarbeiter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSaveTeammitarbeiter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSaveTeammitarbeiter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSaveTeammitarbeiter.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.check_mitarbeiter_changes Method

Private Function check_mitarbeiter_changes() As Boolean

Source code

[Visual Basic]
    Private Function check_mitarbeiter_changes() As Boolean
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(13)
            If msg = MsgBoxResult.Yes Then
                If Save_mitarbeiter_Data() = True Then check_mitarbeiter_changes = True Else check_mitarbeiter_changes = False
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.domainlist_AfterColUpdate Method

Private Sub domainlist_AfterColUpdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_AfterColUpdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            If Me.DomainList.Columns("vorname").Text <> "" And Me.DomainList.Columns("name").Text <> "" Then
                If Me.DomainList.Columns("email").Text = "" Then
                    Me.DomainList.Columns("email").Text = LCase(Me.DomainList.Columns("vorname").Value + "." + Me.DomainList.Columns("name").Value + "@tkb.ch")
                End If
                If Me.DomainList.Columns("unterschrift_text").Text = "" Then
                    Me.DomainList.Columns("unterschrift_text").Text = Me.DomainList.Columns("vorname").Value + " " + Me.DomainList.Columns("name").Value
                End If
                If Me.DomainList.Columns("kurzzeichen").Text = "" Then
                    Me.DomainList.Columns("kurzzeichen").Text = UCase(Microsoft.VisualBasic.Left(Me.DomainList.Columns("vorname").Value, 1) + Microsoft.VisualBasic.Left(Me.DomainList.Columns("name").Value, 1) + Microsoft.VisualBasic.Right(Me.DomainList.Columns("name").Value, 1))
                End If
            End If
            Me.DomainList.Columns("mutiert_am").Value = Now
            Me.DomainList.Columns("mutierer").Value = Globals.MitarbeiterNr

            'For i = 0 To Me.DomainList.Columns.Count - 1
            '    If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
            '    If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
            'Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                For i = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                        Me.DomainList.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim col_Message As New Collection()
        Dim iCnt As Integer
        Dim sMessage As String

        '===============================================================================
        'Validierung der Teamzuordnung und Funktionszuordnung
        '===============================================================================
        If Me.DomainList.Columns("mitarbeiternr").Text <> "" Then
            m_FunctionCount = GetCountIsActive(Me.dsFunltion)
            m_TeamCount = GetCountIsActive(Me.DsTeam)
            'm_FunctionCount = Me.TBFunktion.Splits(0).Rows.Count()
            'm_TeamCount = Me.TBTeam.Splits(0).Rows.Count()

            If Not validateZuordnung(col_Message, m_LastRow, EnumValidierung.Team_Funktion) Then
                For iCnt = 1 To col_Message.Count
                    sMessage = sMessage & col_Message.Item(iCnt) & vbCrLf
                Next
                If BtnConnect.Enabled = False Then
                    sMessage = Globals.MyMsg.Get_Meldungstext(130) & vbCrLf & sMessage
                    'daten sind noch nicht gespeichert
                    sMessage = sMessage & vbCrLf & Globals.MyMsg.Get_Meldungstext(133)
                    Select Case MsgBox(sMessage, MsgBoxStyle.YesNo + MsgBoxStyle.Exclamation, "Mitarbeiter")
                        Case MsgBoxResult.Yes
                            e.Cancel = True
                            Exit Sub
                        Case MsgBoxResult.No
                            Exit Sub
                    End Select
                Else
                    'daten sind gespeichert Aber noch keine Zuordnung
                    MsgBox(sMessage, MsgBoxStyle.Exclamation, "Mitarbeiter")
                    e.Cancel = True
                End If

                Exit Sub
            End If
        End If
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Or Me.DsTeam.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_mitarbeiter_Data() And Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
        End If
        If msg = MsgBoxResult.Cancel Then e.Cancel = True
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.frmDomainEditor_Load Method

Private Sub frmDomainEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        Me.Text = Me.Eintrag
        Dim i As Integer
        TBTeam.Dock = DockStyle.Fill
        TBFunktion.Dock = DockStyle.Fill

        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        Me.SuspendLayout()
        Me.TableName = "mitarbeiter"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        Me.SqlConnection4.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection5.ConnectionString = Globals.sConnectionString
        Me.SqlConnection6.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        Me.GroupBox1.Text = Globals.MyTxt.gettext(7016) 'Team-Zuordnung
        Me.GroupBox2.Text = Globals.MyTxt.gettext(7017) 'Team

        Me.GroupBox3.Text = Globals.MyTxt.gettext(7020) 'Funktions-Zuordnung
        Me.GroupBox4.Text = Globals.MyTxt.gettext(7015) 'Funktion

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.Enabled = False
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        SpaltenTitel_Aktualisieren(1, "mitarbeiter", Me.DataSet1)
        Me.DomainList.Enabled = True
        FillDropDown()

        'Team Mitarbeiter Zuordnung
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight_Team.Enabled = False
        Me.TBRight_Team.DataSource = Me.DataSet2
        Me.TBRight_Team.DataMember = "team"
        SpaltenTitel_Aktualisieren(3, "team", Me.DataSet2)
        Teammitarbeiter_refresh()
        SpaltenTitel_Aktualisieren(2, "teammitarbeiter", Me.DsTeam)
        ShowControlTeam()
        Me.TBRight_Team.Enabled = True

        'Funktion Mitarbeiter Zuordnung
        Me.DaRight_Funktion.SelectCommand.Parameters.Clear()
        Me.DaRight_Funktion.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.TBNameRight_Funktion = "funktionsgruppe"
        Me.DaRight_Funktion.Fill(Me.DsRight_Funktion, Me.TBNameRight_Funktion)
        Me.TBRight_Funktion.Enabled = False
        Me.TBRight_Funktion.DataSource = Me.DsRight_Funktion
        Me.TBRight_Funktion.DataMember = Me.TBNameRight_Funktion
        SpaltenTitel_Aktualisieren(4, Me.TBNameRight_Funktion, Me.DsRight_Funktion)
        Funktionmitarbeiter_refresh()
        SpaltenTitel_Aktualisieren(5, "mitarbeiterfunktion", Me.dsFunltion)
        ShowControlFunktion()
        Me.TBRight_Funktion.Enabled = True

        'funktion
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter4.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter4.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter4.Fill(Me.DataSet4)
        Me.C1TrueDBDropdown1.DataSource = Me.DataSet4
        Me.C1TrueDBDropdown1.DataMember = "funktion"
        Me.C1TrueDBDropdown1.Columns(0).Caption = MyMsg.Get_Meldungstext(7014)
        Me.C1TrueDBDropdown1.Columns(1).Caption = MyMsg.Get_Meldungstext(7015)
        Me.C1TrueDBDropdown1.DisplayColumns(0).Width = 20
        Me.C1TrueDBDropdown1.DisplayColumns(1).Width = 150
        Me.DomainList.Columns("funktionnr").DropDown = Me.C1TrueDBDropdown1

        Me.DomainList.Columns("partnernr").DefaultValue = 0
        Me.DomainList.Columns("Telefon").DefaultValue = "+41 (0)71"
        Me.DomainList.Columns("Fax").DefaultValue = "+41 (0)71"
        Me.DomainList.Columns("showtip").DefaultValue = True
        Me.DomainList.Columns("name").DefaultValue = ""
        Me.DomainList.Columns("vorname").DefaultValue = ""
        Me.DomainList.Columns("email").DefaultValue = ""
        Me.DomainList.Columns("unterschrift_text").DefaultValue = ""
        Me.DomainList.Columns("fuermandant").DefaultValue = Globals.MandantNr
        Me.DomainList.Columns("sprache").DefaultValue = Globals.Sprache
        Me.DomainList.Columns("Mailempfang").DefaultValue = 0
        Me.DomainList.Columns("EdokaMesasge").DefaultValue = 1
        Me.DomainList.Columns("MailDokumentrueckgang").DefaultValue = 1
        Me.DomainList.Columns("klassifizierung").DefaultValue = 1
        Me.DomainList.Columns("edoka_mail").DefaultValue = 1
        Me.DomainList.Columns("journalisierung").DefaultValue = 0
        Me.DomainList.ScrollTips = True
        Me.TBTeam.ScrollTips = True
        Me.TBRight_Team.ScrollTips = True
        Me.ResumeLayout()

        'Rel 3.3
        '24.11.2004 / BUD
        Try
            m_LastRow = Me.DomainList.Row
            m_LastMAID = Int(Me.DomainList.Columns(0).Value)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.frmDomainMitarbeiter_Resize Method

Private Sub frmDomainMitarbeiter_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMitarbeiter_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Dim iOffset As Integer
        iOffset = Me.ToolBar1.Height - Me.Splitter1.Height - Me.Splitter3.Height
        DomainList.Height = (Me.ClientSize.Height - iOffset) / 3
        Me.PanelTeam.Height = (Me.ClientSize.Height - iOffset) / 3
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.optFunktion_Click Method

Private Sub optFunktion_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles optFunktion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub optFunktion_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles optFunktion.Click
        'If CheckTeamFunktion() = False Then
        '    Me.optMitarbeiter_Funktion.Checked = True
        '    Exit Sub
        'End If

        Funktionmitarbeiter_refresh()
        ShowControlFunktion()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.optMitarbeiter_Funktion_Click Method

Private Sub optMitarbeiter_Funktion_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles optMitarbeiter_Funktion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub optMitarbeiter_Funktion_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles optMitarbeiter_Funktion.Click
        Funktionmitarbeiter_refresh()
        ShowControlFunktion()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.optMitarbeiter_Team_Click Method

Private Sub optMitarbeiter_Team_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles optMitarbeiter_Team.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub optMitarbeiter_Team_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles optMitarbeiter_Team.Click
        Teammitarbeiter_refresh()
        ShowControlTeam()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.optTeam_Click Method

Private Sub optTeam_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles optTeam.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub optTeam_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles optTeam.Click
        'If CheckTeamFunktion() = False Then
        '    Me.optMitarbeiter_Team.Checked = True
        '    Exit Sub
        'End If

        Teammitarbeiter_refresh()
        ShowControlTeam()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.validateKlassifizierung Method

Private Function validateKlassifizierung( _
   ByVal iAktuelleKlasse As Integer, _
   ByVal iTyp As EnumValidierung _
) As Boolean

Parameters

iAktuelleKlasse
Required.
iTyp
Required.

Source code

[Visual Basic]
    Private Function validateKlassifizierung(ByVal iAktuelleKlasse As Integer, ByVal iTyp As EnumValidierung) As Boolean
        '===============================================================================
        ' Klassifizierung auslesen
        '===============================================================================
        validateKlassifizierung = False
        Try
            Dim dview As New DataView(m_dtKlassifizierung, "klassenID=" + Trim(CStr(iAktuelleKlasse)), "klassenID", DataViewRowState.CurrentRows)
            Select Case iTyp
                Case EnumValidierung.Funktion
                    validateKlassifizierung = dview.Item(0)("zwingendFunktion")
                Case EnumValidierung.Team
                    validateKlassifizierung = dview.Item(0)("zwingendTeam")
            End Select
        Catch
            MsgBox("error " & Err.Description)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.validateMitarbeiter Method

Private Function validateMitarbeiter( _
   ByRef Message As Collection, _
   ByVal iRow As Integer _
) As Boolean

Parameters

Message
Required.
iRow
Required.

Source code

[Visual Basic]
    Private Function validateMitarbeiter(ByRef Message As Collection, ByVal iRow As Integer) As Boolean
        '===============================================================================
        'Description: Validiert die Dateneingabe des Mitarbeiters
        'Input      :
        'Criteria   :
        'Output     : True wenn die Validierung ok ist
        '             False wenn die Validierung nicht ok ist
        'Erstellt   : koe 19.05.2004
        'Geaendert  :
        '===============================================================================
        Dim iCnt As Integer
        Dim iFirstErrorCol As Integer = 0

        validateMitarbeiter = True
        '===============================================================================
        ' Domliste Feldprüfung
        '===============================================================================
        '============ Name
        If Me.DomainList.Columns("name").CellText(iRow) = "" Then
            validateMitarbeiter = False
            Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(109), Key:="Name")
            If iFirstErrorCol = 0 Then
                For iCnt = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(iCnt).DataField = "name" Then
                        iFirstErrorCol = iCnt
                        Exit For
                    End If
                Next
            End If
        End If
        '============ TGnummer
        If Me.DomainList.Columns("tgnummer").CellText(iRow) = "" Then
            validateMitarbeiter = False
            Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(132), Key:="tgnummer")
            If iFirstErrorCol = 0 Then
                For iCnt = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(iCnt).DataField = "tgnummer" Then
                        iFirstErrorCol = iCnt
                        Exit For
                    End If
                Next
            End If
        End If
        '============ TGnummer Unique
        If Not CheckUniqueTGNummer(Me.DomainList.Columns("tgnummer").CellText(iRow), Me.DomainList.Columns("mitarbeiternr").CellText(iRow)) Then
            validateMitarbeiter = False
            Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(904), Key:="Uniquetgnummer")
            If iFirstErrorCol = 0 Then
                For iCnt = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(iCnt).DataField = "tgnummer" Then
                        iFirstErrorCol = iCnt
                        Exit For
                    End If
                Next
            End If
        End If

        '============ Klasse
        If Me.DomainList.Columns("klassifizierung").CellText(iRow) = "" Then
            validateMitarbeiter = False
            Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(124), Key:="klassifizierung")
            If iFirstErrorCol = 0 Then
                For iCnt = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(iCnt).DataField = "klassifizierung" Then
                        iFirstErrorCol = iCnt
                        Exit For
                    End If
                Next
            End If
        End If

        If iFirstErrorCol > 0 Then
            Me.DomainList.Row = m_LastRow
            Me.DomainList.Col = iFirstErrorCol
        End If
        Me.DomainList.AllowFilter = validateMitarbeiter
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.validateZuordnung Method

Private Function validateZuordnung( _
   ByRef Message As Collection, _
   ByVal iRow As Integer, _
   Optional ByVal ZuordnungValidate As EnumValidierung = EnumValidierung.Team_Funktion _
) As Boolean

Parameters

Message
Required.
iRow
Required.
ZuordnungValidate
Optional. Default value is EnumValidierung.Team_Funktion.

Source code

[Visual Basic]
    Private Function validateZuordnung(ByRef Message As Collection, ByVal iRow As Integer, Optional ByVal ZuordnungValidate As EnumValidierung = EnumValidierung.Team_Funktion) As Boolean
        '===============================================================================
        'Description: Validiert die Zuordnung des Team
        'Input      :
        'Criteria   :
        'Output     : True wenn die Validierung ok ist
        '             False wenn die Validierung nicht ok ist
        'Erstellt   : koe 19.05.2004
        'Geaendert  : BUD 07.12.2004
        '===============================================================================
        Dim iCnt As Integer
        Dim bZuordnungTeam As Boolean = True
        Dim bZuordnungFunktion As Boolean = True
        validateZuordnung = True
        Dim bAktiv As Boolean
        Select Case ZuordnungValidate
            Case EnumValidierung.Team
                ' Zuordnung Team
                bZuordnungTeam = validateZuordnungTeam(Message, iRow)

            Case EnumValidierung.Funktion
                ' Zuordnung Funktionen
                bZuordnungFunktion = validateZuordnungFunction(Message, iRow)

            Case EnumValidierung.Team_Funktion
                ' Zuordnung Team
                bZuordnungTeam = validateZuordnungTeam(Message, iRow)

                ' Zuordnung Funktionen
                bZuordnungFunktion = validateZuordnungFunction(Message, iRow)

        End Select
        If bZuordnungFunktion = False Or bZuordnungTeam = False Then
            Me.DomainList.AllowFilter = False
            validateZuordnung = False
            Me.optFunktion.Enabled = False
            Me.optTeam.Enabled = False
        Else
            Me.optFunktion.Enabled = True
            Me.optTeam.Enabled = True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.validateZuordnungFunction Method

Private Function validateZuordnungFunction( _
   ByRef Message As Collection, _
   ByVal iRow As Integer _
) As Boolean

Parameters

Message
Required.
iRow
Required.

Source code

[Visual Basic]
    Private Function validateZuordnungFunction(ByRef Message As Collection, ByVal iRow As Integer) As Boolean
        '===============================================================================
        ' Zuordnung Funktionen
        '===============================================================================
        Dim iCnt As Integer
        'Dim iaktuelleKlasse As Integer
        'iaktuelleKlasse = ConvertToTyp(Me.DomainList.Columns("klassifizierung").CellValue(iRow), EnumDatentyp.IINTEGER)

        If validateKlassifizierung(m_Klassifizierung, EnumValidierung.Funktion) Then
            'Mitarbeiter muss eine Funktion haben anhand der Klassifizierung
            If m_FunctionCount < 1 Then
                Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(126), Key:="ZU_Funktion")
                validateZuordnungFunction = False
            Else
                With TBFunktion
                    If ConvertToTyp(Me.DomainList.Columns("klassifizierung").CellValue(iRow), EnumDatentyp.IINTEGER) = 1 Then
                        For iCnt = 0 To .Splits(0).Rows.Count - 1
                            If .Columns("Aktiv").CellValue(iCnt) = True Then
                                validateZuordnungFunction = True
                                Exit For
                            Else
                                validateZuordnungFunction = False
                            End If
                        Next
                    End If
                    If validateZuordnungFunction = False Then
                        Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(135), Key:="ZU_FunktionAktiv")
                    End If
                    m_bAddFunktion = validateZuordnungFunction
                End With
            End If
        Else
            'Mitarbeiter darf keine Funktion haben anhand der Klassifizierung
            If m_FunctionCount > 0 Then
                Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(138), Key:="ZU_Funktion")
                validateZuordnungFunction = False
            Else
                validateZuordnungFunction = True
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter.validateZuordnungTeam Method

Private Function validateZuordnungTeam( _
   ByRef Message As Collection, _
   ByVal iRow_Test As Integer _
) As Boolean

Parameters

Message
Required.
iRow_Test
Required.

Source code

[Visual Basic]
    Private Function validateZuordnungTeam(ByRef Message As Collection, ByVal iRow_Test As Integer) As Boolean
        '===============================================================================
        ' Zuordnung Team
        '===============================================================================
        Try
            Dim iCnt As Integer
            If validateKlassifizierung(m_Klassifizierung, EnumValidierung.Team) Then
                'Mitarbeiter muss ein Team haben anhand der Klassifizierung
                If m_TeamCount < 1 Then
                    Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(128), Key:="ZU_Team")
                    validateZuordnungTeam = False
                Else
                    With TBTeam
                        For iCnt = 0 To .Splits(0).Rows.Count - 1
                            If .Columns("Aktiv").CellValue(iCnt) = True Then
                                validateZuordnungTeam = True
                                Exit For
                            Else
                                validateZuordnungTeam = False
                            End If
                        Next
                        If validateZuordnungTeam = False Then
                            Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(134), Key:="ZU_TeamAktiv")
                        End If
                        m_bAddTeam = validateZuordnungTeam
                    End With
                End If
            Else
                'Mitarbeiter darf kein Team haben anhand der Klassifizierung
                If m_TeamCount > 0 Then
                    Message.Add(Item:=Globals.MyMsg.Get_Meldungstext(140), Key:="ZU_Team")
                    validateZuordnungTeam = False
                Else
                    validateZuordnungTeam = True
                End If
            End If
        Catch
            'MsgBox(Err.Description)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainMitarbeiter Fields

frmDomainMitarbeiter overview

Fields

field BtnConnect
field BtnConnectFnk
field C1TrueDBDropdown1
field DaFunktion
field DaRight_Funktion
field DataSet1
field DataSet2
field DataSet4
field DomainList
field DsRight_Funktion
field DsTeam
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label2
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field PanelFunktionen
field PanelTeam
field Splitter1
field Splitter2
field Splitter3
field Splitter4
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlConnection4
field SqlConnection5
field SqlConnection6
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlSelectCommand6
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field TBFunktion
field TBRight_Funktion
field TBRight_Team
field TBTeam
field Timer1
field ToolBar1
field ToolBarNeu
field ToolBtnExit
field ToolBtnSave
field btnSaveFunktionmitarbeiter
field btnSaveTeammitarbeiter
field components
field daTeam
field drpKlassifizierung
field dsFunltion
field m_Datamode
field m_Eintrag
field m_Eintragnr
field m_FunctionCount
field m_Inaktive
field m_Klassifizierung
field m_LastMAID
field m_LastRow
field m_NewDataRow
field m_TBNameRight_Funktion
field m_TableName
field m_TeamCount
field m_ToSelect
field m_TransferKey
field m_bAddFunktion
field m_bAddTeam
field m_dtKlassifizierung
field optFunktion
field optMitarbeiter_Funktion
field optMitarbeiter_Team
field optTeam
field selectedrow

See Also

frmDomainMitarbeiter Class


BtnConnect Variable

Friend WithEvents BtnConnect As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnConnect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


BtnConnectFnk Variable

Friend WithEvents BtnConnectFnk As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnConnectFnk As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DaFunktion Variable

Friend WithEvents DaFunktion As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents DaFunktion As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DaRight_Funktion Variable

Friend WithEvents DaRight_Funktion As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents DaRight_Funktion As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DsRight_Funktion Variable

Friend WithEvents DsRight_Funktion As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DsRight_Funktion As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


DsTeam Variable

Friend WithEvents DsTeam As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DsTeam As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


PanelFunktionen Variable

Friend WithEvents PanelFunktionen As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PanelFunktionen As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


PanelTeam Variable

Friend WithEvents PanelTeam As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PanelTeam As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Splitter3 Variable

Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Splitter4 Variable

Friend WithEvents Splitter4 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter4 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection4 Variable

Friend WithEvents SqlConnection4 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection4 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection5 Variable

Friend WithEvents SqlConnection5 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection5 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlConnection6 Variable

Friend WithEvents SqlConnection6 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection6 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDataAdapter4 Variable

Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDeleteCommand4 Variable

Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlDeleteCommand5 Variable

Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlInsertCommand4 Variable

Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlInsertCommand5 Variable

Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand5 Variable

Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlSelectCommand6 Variable

Friend WithEvents SqlSelectCommand6 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand6 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlUpdateCommand4 Variable

Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


SqlUpdateCommand5 Variable

Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


TBFunktion Variable

Friend WithEvents TBFunktion As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBFunktion As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


TBRight_Funktion Variable

Friend WithEvents TBRight_Funktion As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBRight_Funktion As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


TBRight_Team Variable

Friend WithEvents TBRight_Team As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBRight_Team As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


TBTeam Variable

Friend WithEvents TBTeam As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBTeam As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


Timer1 Variable

Friend WithEvents Timer1 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


ToolBarNeu Variable

Friend WithEvents ToolBarNeu As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarNeu As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


ToolBtnSave Variable

Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


btnSaveFunktionmitarbeiter Variable

Friend WithEvents btnSaveFunktionmitarbeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSaveFunktionmitarbeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


btnSaveTeammitarbeiter Variable

Friend WithEvents btnSaveTeammitarbeiter As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSaveTeammitarbeiter As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


daTeam Variable

Friend WithEvents daTeam As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents daTeam As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


drpKlassifizierung Variable

Friend WithEvents drpKlassifizierung As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpKlassifizierung As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


dsFunltion Variable

Friend WithEvents dsFunltion As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents dsFunltion As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_Datamode Variable

Private m_Datamode As enumDatamode = enumDatamode.Bearbeiten

Source code

[Visual Basic]
    Private m_Datamode As enumDatamode = enumDatamode.Bearbeiten

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
    Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
    Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_FunctionCount Variable

Private m_FunctionCount As Integer

Source code

[Visual Basic]
    Private m_FunctionCount As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_Inaktive Variable

Dim m_Inaktive As Boolean

Source code

[Visual Basic]
    Dim m_Inaktive As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_Klassifizierung Variable

Private m_Klassifizierung As Integer

Source code

[Visual Basic]
    Private m_Klassifizierung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_LastMAID Variable

Dim m_LastMAID As Integer

Source code

[Visual Basic]
    Dim m_LastMAID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_LastRow Variable

Private m_LastRow As Integer

Source code

[Visual Basic]
    Private m_LastRow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_NewDataRow Variable

Dim m_NewDataRow As Boolean = False

Source code

[Visual Basic]
    Dim m_NewDataRow As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_TBNameRight_Funktion Variable

Dim m_TBNameRight_Funktion As String

Source code

[Visual Basic]
    Dim m_TBNameRight_Funktion As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_TableName Variable

Dim m_TableName As String

Source code

[Visual Basic]
    Dim m_TableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_TeamCount Variable

Private m_TeamCount As Integer

Source code

[Visual Basic]
    Private m_TeamCount As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_ToSelect Variable

Dim m_ToSelect As Boolean

Source code

[Visual Basic]
    Dim m_ToSelect As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_TransferKey Variable

Dim m_TransferKey As Long

Source code

[Visual Basic]
    Dim m_TransferKey As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_bAddFunktion Variable

Private m_bAddFunktion As Boolean = True

Source code

[Visual Basic]
    Private m_bAddFunktion As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_bAddTeam Variable

Private m_bAddTeam As Boolean = True

Source code

[Visual Basic]
    Private m_bAddTeam As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


m_dtKlassifizierung Variable

Private m_dtKlassifizierung As DataTable

Source code

[Visual Basic]
    Private m_dtKlassifizierung As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


optFunktion Variable

Friend WithEvents optFunktion As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents optFunktion As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


optMitarbeiter_Funktion Variable

Friend WithEvents optMitarbeiter_Funktion As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents optMitarbeiter_Funktion As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


optMitarbeiter_Team Variable

Friend WithEvents optMitarbeiter_Team As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents optMitarbeiter_Team As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


optTeam Variable

Friend WithEvents optTeam As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents optTeam As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


selectedrow Variable

Dim selectedrow As Integer

Source code

[Visual Basic]
    Dim selectedrow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainMitarbeiter


frmDomainNiederlassung Class

For a list of all members of this type, see frmDomainNiederlassung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainNiederlassung

Public Class frmDomainNiederlassung
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainNiederlassung Members


frmDomainNiederlassung Members

frmDomainNiederlassung overview

Constructors

constructor frmDomainNiederlassung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainNiederlassung Class


frmDomainNiederlassung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung Properties

frmDomainNiederlassung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainNiederlassung Class


frmDomainNiederlassung Methods

frmDomainNiederlassung overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainNiederlassung Class


frmDomainNiederlassung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "niederlassung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("niederlassungnr", "niederlassungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("nlnummer", "nlnummer"), New System.Data.Common.DataColumnMapping("nltyp", "nltyp"), New System.Data.Common.DataColumnMapping("edoka_dokumenterstellung", "edoka_dokumenterstellung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_niederlassung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_niederlassung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_niederlassung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_niederlassung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainNiederlassung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainNiederlassung"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "niederlassung"
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        SpaltenTitel_Aktualisieren(Me.DataSet1)
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "edoka_dokumenterstellung" Then
                Me.DomainList.Columns(i).DefaultValue = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainNiederlassung Fields

frmDomainNiederlassung overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainNiederlassung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainNiederlassung


frmDomainObjektbezeichnung Class

For a list of all members of this type, see frmDomainObjektbezeichnung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainObjektbezeichnung

Public Class frmDomainObjektbezeichnung
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainObjektbezeichnung Members


frmDomainObjektbezeichnung Members

frmDomainObjektbezeichnung overview

Constructors

constructor frmDomainObjektbezeichnung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainObjektbezeichnung Class


frmDomainObjektbezeichnung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung Properties

frmDomainObjektbezeichnung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainObjektbezeichnung Class


frmDomainObjektbezeichnung Methods

frmDomainObjektbezeichnung overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainObjektbezeichnung Class


frmDomainObjektbezeichnung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Objektbezeichnung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("objektbezeichnungnr", "objektbezeichnungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_objektbezeichnung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_objektbezeichnung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@objektbezeichnungnr", System.Data.SqlDbType.Int, 4, "objektbezeichnungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_objektbezeichnung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@objektbezeichnungnr", System.Data.SqlDbType.Int, 4, "objektbezeichnungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_objektbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "objektbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_objektbezeichnung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_objektbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "objektbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainObjektbezeichnung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(624, 297)
        Me.Name = "frmDomainObjektbezeichnung"
        Me.Text = "Objektbezeichnung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "Objektbezeichnung"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainObjektbezeichnung Fields

frmDomainObjektbezeichnung overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainObjektbezeichnung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainObjektbezeichnung


frmDomainOfficeVorlage Class

For a list of all members of this type, see frmDomainOfficeVorlage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainOfficeVorlage

Public Class frmDomainOfficeVorlage
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainOfficeVorlage Members


frmDomainOfficeVorlage Members

frmDomainOfficeVorlage overview

Constructors

constructor frmDomainOfficeVorlage Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method Domainlist_BeforeColEdit
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method MenuItem9_Click
method Mitarbeiter_lesen
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field C1TrueDBDropdown1
field C1TrueDBDropdown2
field ContextMenu1
field DataSet1
field DataSet2
field DataSet3
field DataTable1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem9
field OpenFileDialog1
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainOfficeVorlage Class


frmDomainOfficeVorlage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage Properties

frmDomainOfficeVorlage overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainOfficeVorlage Class


frmDomainOfficeVorlage Methods

frmDomainOfficeVorlage overview

Methods

method Dispose
method Domainlist_BeforeColEdit
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method MenuItem9_Click
method Mitarbeiter_lesen
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainOfficeVorlage Class


frmDomainOfficeVorlage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.Domainlist_BeforeColEdit Method

Private Sub Domainlist_BeforeColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs _
) Handles DomainList.BeforeColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Domainlist_BeforeColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs) Handles DomainList.BeforeColEdit
        If Not DivFnkt.Check_Sysadmin_Stellvertreter(Me.DomainList.Columns("owner").Value) Then
            MyMsg.show_standardmessage(245, MsgBoxStyle.Information)
            e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainOfficeVorlage))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataTable1 = New System.Data.DataTable()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.DataSet3 = New System.Data.DataSet()
        Me.C1TrueDBDropdown2 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataTable1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "office_vorlage", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("vorlageid", "vorlageid"), New System.Data.Common.DataColumnMapping("vorlagename", "vorlagename"), New System.Data.Common.DataColumnMapping("prefix_dokumentname", "prefix_dokumentname"), New System.Data.Common.DataColumnMapping("idv_vorlage", "idv_vorlage"), New System.Data.Common.DataColumnMapping("idv_id", "idv_id"), New System.Data.Common.DataColumnMapping("office_vorlage", "office_vorlage"), New System.Data.Common.DataColumnMapping("absender_ersteller", "absender_ersteller"), New System.Data.Common.DataColumnMapping("idv_nativ", "idv_nativ"), New System.Data.Common.DataColumnMapping("dokument_geschuetzt", "dokument_geschuetzt"), New System.Data.Common.DataColumnMapping("kopfzeile_generieren", "kopfzeile_generieren"), New System.Data.Common.DataColumnMapping("klassifizierung", "klassifizierung"), New System.Data.Common.DataColumnMapping("bcpt", "bcpt"), New System.Data.Common.DataColumnMapping("bcpl", "bcpl"), New System.Data.Common.DataColumnMapping("bcw", "bcw"), New System.Data.Common.DataColumnMapping("bch", "bch"), New System.Data.Common.DataColumnMapping("bchorizontal", "bchorizontal"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("anwendungnr", "anwendungnr"), New System.Data.Common.DataColumnMapping("owner", "owner")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_office_vorlage_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection3
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_absender_ersteller", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "absender_ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bchorizontal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bchorizontal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcpl", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcpl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcpt", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcpt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcw", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcw", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_geschuetzt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_id", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_id", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_nativ", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_vorlage", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kopfzeile_generieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlage", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "owner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prefix_dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlageid", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlageid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagename", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagename", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=shu00;initial catalog=edoka;persist security info=False;user id=sa;wo" & _
        "rkstation id=SHU00;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_office_vorlage_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection3
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlageid", System.Data.SqlDbType.Int, 4, "vorlageid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagename", System.Data.SqlDbType.VarChar, 255, "vorlagename"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, "prefix_dokumentname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_vorlage", System.Data.SqlDbType.Bit, 1, "idv_vorlage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_id", System.Data.SqlDbType.VarChar, 50, "idv_id"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlage", System.Data.SqlDbType.VarChar, 255, "office_vorlage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@absender_ersteller", System.Data.SqlDbType.Bit, 1, "absender_ersteller"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_nativ", System.Data.SqlDbType.Bit, 1, "idv_nativ"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, "dokument_geschuetzt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, "kopfzeile_generieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcpt", System.Data.SqlDbType.Int, 4, "bcpt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcpl", System.Data.SqlDbType.Int, 4, "bcpl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcw", System.Data.SqlDbType.Int, 4, "bcw"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bch", System.Data.SqlDbType.Int, 4, "bch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bchorizontal", System.Data.SqlDbType.Bit, 1, "bchorizontal"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@owner", System.Data.SqlDbType.Int, 4, "owner"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_office_vorlage_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection3
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_office_vorlage_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection3
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlageid", System.Data.SqlDbType.Int, 4, "vorlageid"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagename", System.Data.SqlDbType.VarChar, 255, "vorlagename"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, "prefix_dokumentname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_vorlage", System.Data.SqlDbType.Bit, 1, "idv_vorlage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_id", System.Data.SqlDbType.VarChar, 50, "idv_id"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlage", System.Data.SqlDbType.VarChar, 255, "office_vorlage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@absender_ersteller", System.Data.SqlDbType.Bit, 1, "absender_ersteller"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_nativ", System.Data.SqlDbType.Bit, 1, "idv_nativ"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, "dokument_geschuetzt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, "kopfzeile_generieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcpt", System.Data.SqlDbType.Int, 4, "bcpt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcpl", System.Data.SqlDbType.Int, 4, "bcpl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcw", System.Data.SqlDbType.Int, 4, "bcw"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bch", System.Data.SqlDbType.Int, 4, "bch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bchorizontal", System.Data.SqlDbType.Bit, 1, "bchorizontal"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@owner", System.Data.SqlDbType.Int, 4, "owner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_absender_ersteller", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "absender_ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bchorizontal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bchorizontal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcpl", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcpl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcpt", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcpt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcw", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcw", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_geschuetzt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_id", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_id", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_nativ", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_vorlage", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kopfzeile_generieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlage", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "owner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prefix_dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlageid", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlageid", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagename", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagename", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(280, 16)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines1
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(224, 192)
        Me.C1TrueDBDropdown1.TabIndex = 5
        Me.C1TrueDBDropdown1.TabStop = False
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><DataCols><C1DataColumn Level=""0"" Caption=""Nr"" DataFie" & _
        "ld=""anwendungnr"" DataWidth=""20"" DefaultValue=""1"" NumberFormat=""Standard""><ValueI" & _
        "tems /></C1DataColumn><C1DataColumn Level=""0"" Caption=""Anwendung"" DataField=""bez" & _
        "eichnung"" DataWidth=""50""><ValueItems /></C1DataColumn></DataCols><Styles type=""C" & _
        "1.Win.C1TrueDBGrid.Design.ContextWrapper""><Data>Caption{AlignHorz:Center;}Normal" & _
        "{}Selected{ForeColor:HighlightText;BackColor:Highlight;}Editor{}Style18{AlignHor" & _
        "z:Near;}Style19{AlignHorz:Near;}Style14{AlignHorz:Near;}Style15{AlignHorz:Near;}" & _
        "Style16{}Style17{}Style10{AlignHorz:Near;}Style11{}OddRow{}Style13{}Style12{}Hig" & _
        "hlightRow{ForeColor:HighlightText;BackColor:Highlight;}RecordSelector{AlignImage" & _
        ":Center;}Footer{}Style21{}Style20{}Inactive{ForeColor:InactiveCaptionText;BackCo" & _
        "lor:InactiveCaption;}EvenRow{BackColor:Aqua;}Heading{Wrap:True;AlignVert:Center;" & _
        "Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}FilterBar{}St" & _
        "yle4{}Style9{}Style8{}Style5{}Group{BackColor:ControlDark;Border:None,,0, 0, 0, " & _
        "0;AlignVert:Center;}Style7{}Style6{}Style1{}Style3{}Style2{}</Data></Styles><Spl" & _
        "its><C1.Win.C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelector" & _
        "Width=""16"" RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup" & _
        "=""1""><ClientRect>0, 0, 220, 188</ClientRect><internalCols><C1DropDisplayColumn><" & _
        "DCIdx>0</DCIdx><HeadingStyle parent=""Style2"" me=""Style14"" /><Style parent=""Style" & _
        "1"" me=""Style15"" /><FooterStyle parent=""Style3"" me=""Style16"" /><EditorStyle paren" & _
        "t=""Style5"" me=""Style17"" /><Visible>True</Visible><ColumnDivider>DarkGray,Single<" & _
        "/ColumnDivider><Height>15</Height></C1DropDisplayColumn><C1DropDisplayColumn><DC" & _
        "Idx>1</DCIdx><HeadingStyle parent=""Style2"" me=""Style18"" /><Style parent=""Style1""" & _
        " me=""Style19"" /><FooterStyle parent=""Style3"" me=""Style20"" /><EditorStyle parent=" & _
        """Style5"" me=""Style21"" /><Visible>True</Visible><ColumnDivider>DarkGray,Single</C" & _
        "olumnDivider><Height>15</Height></C1DropDisplayColumn></internalCols><CaptionSty" & _
        "le parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><Ev" & _
        "enRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=" & _
        """Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group" & _
        """ me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle" & _
        " parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4" & _
        """ /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Reco" & _
        "rdSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style" & _
        " parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelW" & _
        "idth><ClientArea>0, 0, 220, 188</ClientArea></Blob>"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "anwendung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("anwendungnr", "anwendungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_anwendung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_anwendung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_anwendung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_anwendung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        Me.DataSet2.Tables.AddRange(New System.Data.DataTable() {Me.DataTable1})
        '
        'DataTable1
        '
        Me.DataTable1.TableName = "Table1"
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka;integrated security=SSPI;persist security i" & _
        "nfo=False;workstation id=SHU;packet size=4096"
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.DefaultExt = "Doc"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem9})
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 0
        Me.MenuItem9.Text = "&Vorlagendateien bearbeiten"
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBDropdown2
        '
        Me.C1TrueDBDropdown2.AllowColMove = True
        Me.C1TrueDBDropdown2.AllowColSelect = True
        Me.C1TrueDBDropdown2.AllowFilter = True
        Me.C1TrueDBDropdown2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown2.AllowSort = True
        Me.C1TrueDBDropdown2.AlternatingRows = False
        Me.C1TrueDBDropdown2.CaptionHeight = 17
        Me.C1TrueDBDropdown2.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown2.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown2.FetchRowStyles = False
        Me.C1TrueDBDropdown2.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown2.LayoutFileName = ""
        Me.C1TrueDBDropdown2.LayoutName = ""
        Me.C1TrueDBDropdown2.LayoutURL = ""
        Me.C1TrueDBDropdown2.Location = New System.Drawing.Point(-52, -102)
        Me.C1TrueDBDropdown2.Name = "C1TrueDBDropdown2"
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown2.RowDivider = GridLines2
        Me.C1TrueDBDropdown2.RowHeight = 15
        Me.C1TrueDBDropdown2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown2.ScrollTips = False
        Me.C1TrueDBDropdown2.Size = New System.Drawing.Size(208, 184)
        Me.C1TrueDBDropdown2.TabIndex = 8
        Me.C1TrueDBDropdown2.Text = "C1TrueDBDropdown2"
        Me.C1TrueDBDropdown2.Visible = False
        Me.C1TrueDBDropdown2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 204, 180</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 204, 180</ClientA" & _
        "rea></Blob>"
        '
        'frmDomainOfficeVorlage
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(752, 305)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBDropdown2, Me.C1TrueDBDropdown1})
        Me.Name = "frmDomainOfficeVorlage"
        Me.Text = "cldDomainBerechtigung"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataTable1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.MenuItem9_Click Method

Private Sub MenuItem9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem9.Click
        Dim f As New FrmDomainOfficeVorlageDatei()
        f.MdiParent = Me.ParentForm
        f.vorlagenr = Me.DomainList.Columns(0).Value
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.Mitarbeiter_lesen Method

Public Function Mitarbeiter_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Mitarbeiter_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_mitarbeiter_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902) + ex.Message)
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableName = "office_vorlage"
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        For i = 0 To Me.DataSet2.Tables(0).Rows.Count

        Next

        Dim vi As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim vi1 As New C1.Win.C1TrueDBGrid.ValueItem()
        vi.DisplayValue = "Word"
        vi.Value = 1
        Me.DomainList.Columns("anwendungnr").ValueItems.Values.Add(vi)
        vi1.DisplayValue = "Excel"
        vi1.Value = 2
        Me.DomainList.Columns("anwendungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        Me.DomainList.Columns("anwendungnr").ValueItems.Values.Add(vi1)
        Me.DomainList.Columns("ANWENDUNGNR").ValueItems.Translate = True

        'Me.C1TrueDBDropdown2.DataSource = Me.DataSet3
        'Me.C1TrueDBDropdown2.DataMember = Me.DataSet3.Tables(0).TableName
        'Me.C1TrueDBDropdown2.AllowFilter = True
        'Me.C1TrueDBDropdown2.DisplayColumns(0).Width = 0
        'Me.C1TrueDBDropdown2.DisplayColumns(1).AutoSize()
        'Me.DomainList.Columns("owner").DropDown = Me.C1TrueDBDropdown2
        'Me.DomainList.Columns("owner").ValueItems.Translate = True

        Me.DomainList.ContextMenu = Me.ContextMenu1

        SpaltenTitel_Aktualisieren(Me.DataSet1)

        For i = 0 To Me.DomainList.Columns.Count - 1
            'Präsentation von Readonly
            If Me.DomainList.Columns(i).DataField = "idv_vorlage" Or _
                Me.DomainList.Columns(i).DataField = "absender_ersteller" Or _
                Me.DomainList.Columns(i).DataField = "idv_nativ" Or _
                Me.DomainList.Columns(i).DataField = "dokument_geschuetzt" Or _
                Me.DomainList.Columns(i).DataField = "bchorizontal" Or _
                Me.DomainList.Columns(i).DataField = "kopfzeile_generieren" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DomainList.Columns(i).DefaultValue = False
            End If
        Next

        'Defaults setzen
        Me.DomainList.Columns("anwendungnr").DefaultValue = 1
        Me.DomainList.Columns("bcpt").DefaultValue = 793
        Me.DomainList.Columns("bcpl").DefaultValue = 360
        Me.DomainList.Columns("bcw").DefaultValue = 200
        Me.DomainList.Columns("bch").DefaultValue = 33
        Me.DomainList.Columns("bchorizontal").DefaultValue = True
        Me.DomainList.Columns("idv_vorlage").DefaultValue = True
        Me.DomainList.Columns("kopfzeile_generieren").DefaultValue = True
        Me.DomainList.Columns("owner").DefaultValue = Globals.MitarbeiterNr

        Me.Refresh()
        Cursor.Current = Cursors.Default

        Dim ma As New DataTable()
        ma = Mitarbeiter_lesen()
        Me.DataSet3.Clear()
        Me.DataSet3.Tables.Add(ma)
        Me.DomainList.Columns("owner").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        For i = 0 To ma.Rows.Count - 1
            Dim v As New C1.Win.C1TrueDBGrid.ValueItem()
            v.DisplayValue = ma.Rows(i).Item(1)
            v.Value = ma.Rows(i).Item(0)
            Me.DomainList.Columns("owner").ValueItems.Values.Add(v)
        Next
        Me.DomainList.Columns("owner").ValueItems.Translate = True
        Me.DomainList.Splits(0).DisplayColumns("owner").FetchStyle = True
        Me.DomainList.Splits(0).DisplayColumns("owner").AutoComplete = True
        Me.DomainList.Splits(0).DisplayColumns("owner").AutoDropDown = True

        'Me.C1TrueDBDropdown2.DataSource = Me.DataSet3
        'Me.C1TrueDBDropdown2.DataMember = Me.DataSet3.Tables(0).TableName
        'Me.C1TrueDBDropdown2.DisplayColumns(0).Width = 0
        'Me.C1TrueDBDropdown2.Columns(0).Caption = "Owner"
        'Me.DomainList.Columns("owner").DropDown = Me.C1TrueDBDropdown2
        'Me.C1TrueDBDropdown2.DisplayColumns(1).AutoSize()
        'Me.DomainList.Splits(0).DisplayColumns("owner").FetchStyle = True
        'Me.DomainList.Splits(0).DisplayColumns("owner").AutoComplete = True
        'Me.DomainList.Splits(0).DisplayColumns("owner").AutoDropDown = True
        'Me.DomainList.Splits()

        If UCase(Microsoft.VisualBasic.Left(Globals.conn.scoDBConnection.DataSource, 3)) = "TGT" Then
            '  Me.MenuItem1.Enabled = True
            '  Me.MenuItem2.Enabled = True
            '  Me.MenuItem7.Enabled = True
            '  Me.MenuItem8.Enabled = True
        Else
            '  Me.MenuItem1.Enabled = False
            '  Me.MenuItem2.Enabled = False
            '  Me.MenuItem7.Enabled = False
            '  Me.MenuItem8.Enabled = False
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainOfficeVorlage Fields

frmDomainOfficeVorlage overview

Fields

field C1TrueDBDropdown1
field C1TrueDBDropdown2
field ContextMenu1
field DataSet1
field DataSet2
field DataSet3
field DataTable1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem9
field OpenFileDialog1
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainOfficeVorlage Class


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


C1TrueDBDropdown2 Variable

Friend WithEvents C1TrueDBDropdown2 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown2 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


DataTable1 Variable

Friend WithEvents DataTable1 As System.Data.DataTable

Source code

[Visual Basic]
    Friend WithEvents DataTable1 As System.Data.DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainOfficeVorlage


frmDomainPhsischesArchiv Class

For a list of all members of this type, see frmDomainPhsischesArchiv Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainPhsischesArchiv

Public Class frmDomainPhsischesArchiv
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainPhsischesArchiv Members


frmDomainPhsischesArchiv Members

frmDomainPhsischesArchiv overview

Constructors

constructor frmDomainPhsischesArchiv Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomaint_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainPhsischesArchiv Class


frmDomainPhsischesArchiv Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv Properties

frmDomainPhsischesArchiv overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainPhsischesArchiv Class


frmDomainPhsischesArchiv Methods

frmDomainPhsischesArchiv overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomaint_Load

See Also

frmDomainPhsischesArchiv Class


frmDomainPhsischesArchiv.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "physischesarchiv", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("physischesarchivnr", "physischesarchivnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_physischesarchiv_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_physischesarchiv_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physischesarchivnr", System.Data.SqlDbType.Int, 4, "physischesarchivnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.VarBinary, 2147483647, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_physischesarchiv_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physischesarchivnr", System.Data.SqlDbType.Int, 4, "physischesarchivnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.VarBinary, 2147483647, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physischesarchivnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physischesarchivnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_physischesarchiv_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physischesarchivnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physischesarchivnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainPhsischesArchiv
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainPhsischesArchiv"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv.frmDomaint_Load Method

Private Sub frmDomaint_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomaint_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableName = "physischesarchiv"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Me.Refresh()
        Cursor.Current = Cursors.Default

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainPhsischesArchiv Fields

frmDomainPhsischesArchiv overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainPhsischesArchiv Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainPhsischesArchiv


frmDomainProzess Class

For a list of all members of this type, see frmDomainProzess Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainProzess

Public Class frmDomainProzess
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainProzess Members


frmDomainProzess Members

frmDomainProzess overview

Constructors

constructor frmDomainProzess Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainProzess Class


frmDomainProzess Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess Properties

frmDomainProzess overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainProzess Class


frmDomainProzess Methods

frmDomainProzess overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainProzess Class


frmDomainProzess.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "prozess", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("erstellung", "erstellung"), New System.Data.Common.DataColumnMapping("verwendung", "verwendung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_prozess_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_prozess_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellung", System.Data.SqlDbType.Bit, 1, "erstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@verwendung", System.Data.SqlDbType.Bit, 1, "verwendung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_prozess_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellung", System.Data.SqlDbType.Bit, 1, "erstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@verwendung", System.Data.SqlDbType.Bit, 1, "verwendung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_verwendung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "verwendung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_prozess_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_verwendung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "verwendung", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainProzess
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainProzess"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "prozess"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Me.DomainList.Columns("erstellung").DefaultValue = True
        Me.DomainList.Columns("verwendung").DefaultValue = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainProzess Fields

frmDomainProzess overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainProzess Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainProzess


frmDomainReportfeldregel Class

For a list of all members of this type, see frmDomainReportfeldregel Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainReportfeldregel

Public Class frmDomainReportfeldregel
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainReportfeldregel Members


frmDomainReportfeldregel Members

frmDomainReportfeldregel overview

Constructors

constructor frmDomainReportfeldregel Constructor

Properties

property Eintrag
property Eintragnr
property Inaktive
property TableName
property ToSelect
property TransferKey

Methods

method Check_Changes
method Dispose
method DomainList_AfterInsert
method DomainList_RowColChange
method FormSize
method Generic_Select
method InitializeComponent
method MenuItem2_Click
method Save_Data
method Save_Reportfeldregel_Data
method SpaltenTitel_Aktualisieren (Overloaded)
method ToolBar1_ButtonClick
method check_Reportfeldregel_changes
method domainlist_aftercellupdate
method frmClose
method frmDomainReportfeldregel_Load
method mcboFeldTyp_Validating
method mcboSteuerbefehl_Validating
method moveDataPointer
method txtBeschreibung_Validating
method txtBezeichnung_Validating

Fields

field DataSet1
field DomainList
field ImageList1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1
field ToolBtnExit
field ToolBtnSave
field cboSteuerbefehl
field cbofeldTyp
field components
field lblBeschreibung
field lblBezeichnung
field lblDatenherkunft
field lblSteuerbefehl
field lblTyp
field m_Eintrag
field m_Eintragnr
field m_Inaktive
field m_TableName
field m_ToSelect
field m_TransferKey
field mcboFeldTyp
field mcboSteuerbefehl
field selectedrow
field txtBeschreibung
field txtBezeichnung
field txtDatenherkunft

See Also

frmDomainReportfeldregel Class


frmDomainReportfeldregel Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel Properties

frmDomainReportfeldregel overview

Properties

property Eintrag
property Eintragnr
property Inaktive
property TableName
property ToSelect
property TransferKey

See Also

frmDomainReportfeldregel Class


frmDomainReportfeldregel.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
    Property Eintrag() As String
        Get
            Return m_Eintrag
        End Get
        Set(ByVal Value As String)
            m_Eintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
    Property Eintragnr() As Long
        Get
            Return m_Eintragnr
        End Get
        Set(ByVal Value As Long)
            m_Eintragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Inaktive Property

Property Inaktive() As Boolean

Source code

[Visual Basic]
    Property Inaktive() As Boolean
        Get
            Return m_Inaktive
        End Get
        Set(ByVal Value As Boolean)
            m_Inaktive = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_TableName
        End Get
        Set(ByVal Value As String)
            m_TableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.ToSelect Property

Property ToSelect() As Boolean

Source code

[Visual Basic]
    Property ToSelect() As Boolean
        Get
            Return m_ToSelect
        End Get
        Set(ByVal Value As Boolean)
            m_ToSelect = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.TransferKey Property

Property TransferKey() As Long

Source code

[Visual Basic]
    Property TransferKey() As Long
        Get
            Return m_TransferKey
        End Get
        Set(ByVal Value As Long)
            m_TransferKey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel Methods

frmDomainReportfeldregel overview

Methods

method Check_Changes
method Dispose
method DomainList_AfterInsert
method DomainList_RowColChange
method FormSize
method Generic_Select
method InitializeComponent
method MenuItem2_Click
method Save_Data
method Save_Reportfeldregel_Data
method SpaltenTitel_Aktualisieren (Overloaded)
method ToolBar1_ButtonClick
method check_Reportfeldregel_changes
method domainlist_aftercellupdate
method frmClose
method frmDomainReportfeldregel_Load
method mcboFeldTyp_Validating
method mcboSteuerbefehl_Validating
method moveDataPointer
method txtBeschreibung_Validating
method txtBezeichnung_Validating

See Also

frmDomainReportfeldregel Class


frmDomainReportfeldregel.Check_Changes Method

Private Sub Check_Changes()

Source code

[Visual Basic]
    Private Sub Check_Changes()
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(12)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            Me.DomainList.Columns("aktiv").Value = 1
            Me.DomainList.Columns("erstellt_am").Value = Now
            Me.DomainList.Columns("mutiert_am").Value = Now
            Me.DomainList.Columns("mutierer").Value = Globals.MitarbeiterNr
            'For i = 0 To DomainList.Columns.Count - 1
            '    If Me.DomainList.Columns(i).DataField = "aktiv" Then
            '        Me.DomainList.Columns(i).Value = 1
            '    End If
            '    If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
            '        Me.DomainList.Columns(i).Value = Now
            '    End If
            '    If Me.DomainList.Columns(i).DataField = "mutiert_am" Then
            '        Me.DomainList.Columns(i).Value = Now
            '    End If
            '    If Me.DomainList.Columns(i).DataField = "mutierer" Then
            '        Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
            '    End If
            'Next
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.DomainList_RowColChange Method

Private Sub DomainList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DomainList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DomainList.RowColChange
        Me.mcboFeldTyp.SelectedValue = Me.DomainList.Columns("feldtypNr").Value           'feldtypNr
        Me.mcboSteuerbefehl.SelectedValue = Me.DomainList.Columns("feldsteuerungNr").Value      'feldsteuerungNr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.FormSize Method

Public Sub FormSize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub FormSize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SuspendLayout()
        Dim ds As New edokadb.clsSysadminfunktion()
        Try
            ds.cpMainConnectionProvider = conn
            ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
            ds.SelectOne()
            If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
            If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
            If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
            If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
            Me.MenuItem1.Text = Me.Eintrag
        Catch
            'MsgBox("Error Resizing Form")
        Finally
        End Try
        ds.Dispose()
        Me.ResumeLayout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As EnumCombotyp _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As EnumCombotyp) As DataTable

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case EnumCombotyp.Feldtyp
                scmCmdToExecute.CommandText = "pv_Feldtyp_Select"
            Case EnumCombotyp.Steuerbefehl
                scmCmdToExecute.CommandText = "pv_Steuerbefehl_Select"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case EnumCombotyp.Feldtyp
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", Globals.MandantNr))
                Case EnumCombotyp.Steuerbefehl
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", Globals.MandantNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainReportfeldregel))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.txtBeschreibung = New System.Windows.Forms.TextBox()
        Me.cboSteuerbefehl = New System.Windows.Forms.ComboBox()
        Me.cbofeldTyp = New System.Windows.Forms.ComboBox()
        Me.txtDatenherkunft = New System.Windows.Forms.TextBox()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.lblTyp = New System.Windows.Forms.Label()
        Me.lblSteuerbefehl = New System.Windows.Forms.Label()
        Me.lblBeschreibung = New System.Windows.Forms.Label()
        Me.lblDatenherkunft = New System.Windows.Forms.Label()
        Me.lblBezeichnung = New System.Windows.Forms.Label()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.Panel2.SuspendLayout()
        Me.Panel3.SuspendLayout()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2, Me.MenuItem3})
        Me.MenuItem1.MergeOrder = 1
        Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.MergeOrder = 1
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
        Me.MenuItem2.Text = "&Schliessen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
        Me.MenuItem3.Text = "&Daten sichern"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnExit, Me.ToolBtnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(888, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBtnExit
        '
        Me.ToolBtnExit.ImageIndex = 2
        '
        'ToolBtnSave
        '
        Me.ToolBtnSave.ImageIndex = 1
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=TGTSQLEDOKABSSF;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgentwicklung3;workstation id=TG602640;packet size" & _
        "=4096"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeldregelNr", "reportfeldregelNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtypNr", "feldtypNr"), New System.Data.Common.DataColumnMapping("feldsteuerungNr", "feldsteuerungNr"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_reportfeldregel_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_reportfeldregel_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_reportfeldregel_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_reportfeldregel_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeldregelNr", "reportfeldregelNr"), New System.Data.Common.DataColumnMapping("Parametername", "Parametername"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtypNr", "feldtypNr"), New System.Data.Common.DataColumnMapping("feldsteuerungNr", "feldsteuerungNr"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("eingabe_zwingend", "eingabe_zwingend")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_reportfeldregel_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Parametername", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Parametername", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_reportfeldregel_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection2
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Parametername", System.Data.SqlDbType.VarChar, 50, "Parametername"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_reportfeldregel_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection2
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_reportfeldregel_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, "reportfeldregelNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Parametername", System.Data.SqlDbType.VarChar, 50, "Parametername"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, "feldtypNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Parametername", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Parametername", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel2, Me.Panel3})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(0, 433)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(888, 160)
        Me.Panel1.TabIndex = 18
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBezeichnung, Me.txtBeschreibung, Me.cboSteuerbefehl, Me.cbofeldTyp, Me.txtDatenherkunft})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel2.Location = New System.Drawing.Point(96, 0)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(792, 160)
        Me.Panel2.TabIndex = 25
        '
        'txtBezeichnung
        '
        Me.txtBezeichnung.Location = New System.Drawing.Point(0, 6)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(648, 20)
        Me.txtBezeichnung.TabIndex = 28
        Me.txtBezeichnung.Text = "Bezeichnung"
        '
        'txtBeschreibung
        '
        Me.txtBeschreibung.Location = New System.Drawing.Point(0, 26)
        Me.txtBeschreibung.Name = "txtBeschreibung"
        Me.txtBeschreibung.Size = New System.Drawing.Size(648, 20)
        Me.txtBeschreibung.TabIndex = 27
        Me.txtBeschreibung.Text = "Beschreibung"
        '
        'cboSteuerbefehl
        '
        Me.cboSteuerbefehl.Location = New System.Drawing.Point(0, 46)
        Me.cboSteuerbefehl.Name = "cboSteuerbefehl"
        Me.cboSteuerbefehl.Size = New System.Drawing.Size(648, 21)
        Me.cboSteuerbefehl.TabIndex = 26
        Me.cboSteuerbefehl.Text = "Steuerbefehl"
        '
        'cbofeldTyp
        '
        Me.cbofeldTyp.Location = New System.Drawing.Point(0, 67)
        Me.cbofeldTyp.Name = "cbofeldTyp"
        Me.cbofeldTyp.Size = New System.Drawing.Size(648, 21)
        Me.cbofeldTyp.TabIndex = 25
        Me.cbofeldTyp.Text = "Feldtype"
        '
        'txtDatenherkunft
        '
        Me.txtDatenherkunft.Location = New System.Drawing.Point(0, 88)
        Me.txtDatenherkunft.Multiline = True
        Me.txtDatenherkunft.Name = "txtDatenherkunft"
        Me.txtDatenherkunft.ScrollBars = System.Windows.Forms.ScrollBars.Both
        Me.txtDatenherkunft.Size = New System.Drawing.Size(648, 72)
        Me.txtDatenherkunft.TabIndex = 24
        Me.txtDatenherkunft.Text = "Datenherkunft"
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblTyp, Me.lblSteuerbefehl, Me.lblBeschreibung, Me.lblDatenherkunft, Me.lblBezeichnung})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(96, 160)
        Me.Panel3.TabIndex = 24
        '
        'lblTyp
        '
        Me.lblTyp.Location = New System.Drawing.Point(6, 69)
        Me.lblTyp.Name = "lblTyp"
        Me.lblTyp.Size = New System.Drawing.Size(88, 16)
        Me.lblTyp.TabIndex = 27
        Me.lblTyp.Text = "Feld-Typ"
        Me.lblTyp.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'lblSteuerbefehl
        '
        Me.lblSteuerbefehl.Location = New System.Drawing.Point(6, 48)
        Me.lblSteuerbefehl.Name = "lblSteuerbefehl"
        Me.lblSteuerbefehl.Size = New System.Drawing.Size(88, 16)
        Me.lblSteuerbefehl.TabIndex = 26
        Me.lblSteuerbefehl.Text = "Steuerbefehl"
        Me.lblSteuerbefehl.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'lblBeschreibung
        '
        Me.lblBeschreibung.Location = New System.Drawing.Point(6, 28)
        Me.lblBeschreibung.Name = "lblBeschreibung"
        Me.lblBeschreibung.Size = New System.Drawing.Size(88, 16)
        Me.lblBeschreibung.TabIndex = 25
        Me.lblBeschreibung.Text = "Beschreibung"
        Me.lblBeschreibung.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'lblDatenherkunft
        '
        Me.lblDatenherkunft.Location = New System.Drawing.Point(4, 89)
        Me.lblDatenherkunft.Name = "lblDatenherkunft"
        Me.lblDatenherkunft.Size = New System.Drawing.Size(88, 16)
        Me.lblDatenherkunft.TabIndex = 24
        Me.lblDatenherkunft.Text = "Datenherkunft"
        Me.lblDatenherkunft.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'lblBezeichnung
        '
        Me.lblBezeichnung.Location = New System.Drawing.Point(6, 8)
        Me.lblBezeichnung.Name = "lblBezeichnung"
        Me.lblBezeichnung.Size = New System.Drawing.Size(88, 16)
        Me.lblBezeichnung.TabIndex = 23
        Me.lblBezeichnung.Text = "Bezeichnung"
        Me.lblBezeichnung.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'DomainList
        '
        Me.DomainList.AllowAddNew = True
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(0, 25)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines1
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = True
        Me.DomainList.Size = New System.Drawing.Size(888, 408)
        Me.DomainList.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.DomainList.TabIndex = 19
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.WrapCellPointer = True
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWi" & _
        "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
        "ClientRect>0, 0, 884, 404</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
        "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
        "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
        "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
        """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
        "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
        "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
        "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
        "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
        "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
        "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
        """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
        "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
        "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
        "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
        """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
        "rzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 884, 404</ClientArea></Blob>"
        '
        'frmDomainReportfeldregel
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(888, 593)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DomainList, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmDomainReportfeldregel"
        Me.ShowInTaskbar = False
        Me.Text = "frmDomainEdidor"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean

        Save_Data = True
        Try

            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.Save_Reportfeldregel_Data Method

Private Function Save_Reportfeldregel_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Reportfeldregel_Data() As Boolean
        Try
            Save_Reportfeldregel_Data = True
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Reportfeldregel_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SpaltenTitel_Aktualisieren Method

Overload List

[Visual Basic] Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet, ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid)

[Visual Basic] Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)

See Also

frmDomainReportfeldregel | EDOKAApp


frmDomainReportfeldregel.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Close()
            Case 1 'Speichern
                Save_Data()
                Save_Reportfeldregel_Data()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.check_Reportfeldregel_changes Method

Private Function check_Reportfeldregel_changes() As Boolean

Source code

[Visual Basic]
    Private Function check_Reportfeldregel_changes() As Boolean
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(13)
            If msg = MsgBoxResult.Yes Then
                If Save_Reportfeldregel_Data() = True Then
                    check_Reportfeldregel_changes = True
                Else
                    check_Reportfeldregel_changes = False
                End If
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            'For i = 0 To Me.DomainList.Columns.Count - 1
            'If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
            Me.DomainList.Columns("mutiert_am").Text = Now
            'If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
            Me.DomainList.Columns("mutierer").Value = Globals.MitarbeiterNr
            'Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                Me.DomainList.Columns("mandantnr").Value = Globals.MandantNr
                'For i = 0 To Me.DomainList.Columns.Count - 1
                '    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                '        Me.DomainList.Columns(i).Value = Globals.MandantNr
                '    End If
                'Next
                dbkey.Dispose()
            End If
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Reportfeldregel_Data() And Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
        End If
        If msg = MsgBoxResult.Cancel Then e.Cancel = True
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.frmDomainReportfeldregel_Load Method

Private Sub frmDomainReportfeldregel_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainReportfeldregel_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Text = Me.Eintrag
        Dim i As Integer

        Me.TableName = "reportfeldregel"
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        Me.SqlDataAdapter1.SelectCommand.Connection = Me.SqlConnection1

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        'SpaltenTitel_Aktualisieren(Me.DataSet1)

        SpaltenTitel_Aktualisieren(Me.DataSet1, DomainList)

        '===============================================================================
        'Datasource Steuerbefehl
        '===============================================================================
        Me.mcboSteuerbefehl = New MultiComboBox(Me.cboSteuerbefehl)

        Me.mcboSteuerbefehl.DisplayColumnName = "steuerung"
        Me.mcboSteuerbefehl.ValueColumnName = "feldsteuerungNr"

        Me.mcboSteuerbefehl.Fill_Data(Generic_Select(EnumCombotyp.Steuerbefehl), False)
        Me.mcboSteuerbefehl.SelectedValue = Me.DomainList.Columns(4).Value
        '===============================================================================
        'Datasource Feldtyp
        '===============================================================================
        Me.mcboFeldTyp = New MultiComboBox(Me.cbofeldTyp)

        Me.mcboFeldTyp.DisplayColumnName = "feldtyp"
        Me.mcboFeldTyp.ValueColumnName = "feldtypNr"

        Me.mcboFeldTyp.Fill_Data(Generic_Select(EnumCombotyp.Feldtyp), False)
        Me.mcboFeldTyp.SelectedValue = Me.DomainList.Columns(3).Value

        '===============================================================================
        'Datasource textfelder
        '===============================================================================
        Me.txtBezeichnung.DataBindings.Add(New System.Windows.Forms.Binding("Text", Me.DataSet1, "Reportfeldregel.Bezeichnung"))
        Me.txtBeschreibung.DataBindings.Add(New System.Windows.Forms.Binding("Text", Me.DataSet1, "Reportfeldregel.Beschreibung"))
        Me.txtDatenherkunft.DataBindings.Add(New System.Windows.Forms.Binding("Text", Me.DataSet1, "Reportfeldregel.Datenherkunft"))
        ' Exit Sub

        'Me.chkZwingend.DataBindings.Add(New System.Windows.Forms.Binding("Checked", Me.DataSet1, "Reportfeldregel.eingabe_zwingend"))
        Me.WindowState = FormWindowState.Maximized
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.mcboFeldTyp_Validating Method

Private Sub mcboFeldTyp_Validating( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles mcboFeldTyp.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcboFeldTyp_Validating(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles mcboFeldTyp.Validating
        Me.DomainList.Columns("feldtypNr").Value = Me.mcboFeldTyp.SelectedValue       'feldtypNr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.mcboSteuerbefehl_Validating Method

Private Sub mcboSteuerbefehl_Validating( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles mcboSteuerbefehl.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcboSteuerbefehl_Validating(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles mcboSteuerbefehl.Validating
        Me.DomainList.Columns("feldsteuerungNr").Value = (Me.mcboSteuerbefehl.SelectedValue) 'feldsteuerungNr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.moveDataPointer Method

Private Sub moveDataPointer()

Source code

[Visual Basic]
    Private Sub moveDataPointer()
        Dim iBookmanrk As Integer
        iBookmanrk = DomainList.Bookmark
        If iBookmanrk > 1 Then
            DomainList.Bookmark = iBookmanrk - 1
            DomainList.Bookmark = iBookmanrk
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.txtBeschreibung_Validating Method

Private Sub txtBeschreibung_Validating( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles txtBeschreibung.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBeschreibung_Validating(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles txtBeschreibung.Validating
        If DomainList.Columns("Beschreibung").Text <> txtBeschreibung.Text Then
            DomainList.Columns("Beschreibung").Text = txtBeschreibung.Text
            moveDataPointer()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.txtBezeichnung_Validating Method

Private Sub txtBezeichnung_Validating( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles txtBezeichnung.Validating

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBezeichnung_Validating(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles txtBezeichnung.Validating
        If DomainList.Columns("Bezeichnung").Text <> txtBezeichnung.Text Then
            DomainList.Columns("Bezeichnung").Text = txtBezeichnung.Text
            moveDataPointer()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel Fields

frmDomainReportfeldregel overview

Fields

field DataSet1
field DomainList
field ImageList1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1
field ToolBtnExit
field ToolBtnSave
field cboSteuerbefehl
field cbofeldTyp
field components
field lblBeschreibung
field lblBezeichnung
field lblDatenherkunft
field lblSteuerbefehl
field lblTyp
field m_Eintrag
field m_Eintragnr
field m_Inaktive
field m_TableName
field m_ToSelect
field m_TransferKey
field mcboFeldTyp
field mcboSteuerbefehl
field selectedrow
field txtBeschreibung
field txtBezeichnung
field txtDatenherkunft

See Also

frmDomainReportfeldregel Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


ToolBtnSave Variable

Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


cboSteuerbefehl Variable

Friend WithEvents cboSteuerbefehl As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cboSteuerbefehl As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


cbofeldTyp Variable

Friend WithEvents cbofeldTyp As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbofeldTyp As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


lblBeschreibung Variable

Friend WithEvents lblBeschreibung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBeschreibung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


lblBezeichnung Variable

Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblBezeichnung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


lblDatenherkunft Variable

Friend WithEvents lblDatenherkunft As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblDatenherkunft As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


lblSteuerbefehl Variable

Friend WithEvents lblSteuerbefehl As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblSteuerbefehl As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


lblTyp Variable

Friend WithEvents lblTyp As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblTyp As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
    Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
    Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_Inaktive Variable

Dim m_Inaktive As Boolean

Source code

[Visual Basic]
    Dim m_Inaktive As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_TableName Variable

Dim m_TableName As String

Source code

[Visual Basic]
    Dim m_TableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_ToSelect Variable

Dim m_ToSelect As Boolean

Source code

[Visual Basic]
    Dim m_ToSelect As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


m_TransferKey Variable

Dim m_TransferKey As Long

Source code

[Visual Basic]
    Dim m_TransferKey As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


mcboFeldTyp Variable

Dim WithEvents mcboFeldTyp As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcboFeldTyp As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


mcboSteuerbefehl Variable

Dim WithEvents mcboSteuerbefehl As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcboSteuerbefehl As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


selectedrow Variable

Dim selectedrow As Integer

Source code

[Visual Basic]
    Dim selectedrow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


txtBeschreibung Variable

Friend WithEvents txtBeschreibung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBeschreibung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


txtDatenherkunft Variable

Friend WithEvents txtDatenherkunft As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDatenherkunft As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainRolle Class

For a list of all members of this type, see frmDomainRolle Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainRolle

Public Class frmDomainRolle
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainRolle Members


frmDomainRolle Members

frmDomainRolle overview

Constructors

constructor frmDomainRolle Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainRolle Class


frmDomainRolle Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle Properties

frmDomainRolle overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainRolle Class


frmDomainRolle Methods

frmDomainRolle overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainRolle Class


frmDomainRolle.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandant", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainRolle
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(568, 277)
        Me.Name = "frmDomainRolle"
        Me.Text = "Rollen"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "rolle"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        Me.DomainList.Columns("sysadminrolle").DefaultValue = False

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainRolle Fields

frmDomainRolle overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainRolle Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainRolle


frmDomainSQLQueries Class

For a list of all members of this type, see frmDomainSQLQueries Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainSQLQueries

Public Class frmDomainSQLQueries
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainSQLQueries Members


frmDomainSQLQueries Members

frmDomainSQLQueries overview

Constructors

constructor frmDomainSQLQueries Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method MenuItem4_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSQLQueries Class


frmDomainSQLQueries Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries Properties

frmDomainSQLQueries overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainSQLQueries Class


frmDomainSQLQueries Methods

frmDomainSQLQueries overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method MenuItem4_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainSQLQueries Class


frmDomainSQLQueries.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sqlqueries", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("querynr", "querynr"), New System.Data.Common.DataColumnMapping("query", "query"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_sqlqueries_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_querynr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "querynr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_query", System.Data.SqlDbType.VarChar, 8000, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "query", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu00;initial catalog=edoka;persist security info=False;user id=sa;wo" & _
        "rkstation id=SHU00;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_sqlqueries_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@querynr", System.Data.SqlDbType.Int, 4, "querynr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@query", System.Data.SqlDbType.VarChar, 8000, "query"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_sqlqueries_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_sqlqueries_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@querynr", System.Data.SqlDbType.Int, 4, "querynr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@query", System.Data.SqlDbType.VarChar, 8000, "query"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_querynr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "querynr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_query", System.Data.SqlDbType.VarChar, 8000, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "query", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "Übernehmen"
        '
        'frmDomainSQLQueries
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, -19)
        Me.Name = "frmDomainSQLQueries"
        Me.Text = "frmDomainSQLQueries"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "sqlqueries"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Me.DomainList.ContextMenu = Me.ContextMenu1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSQLQueries Fields

frmDomainSQLQueries overview

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSQLQueries Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSQLQueries


frmDomainSpalten Class

For a list of all members of this type, see frmDomainSpalten Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainSpalten

Public Class frmDomainSpalten
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainSpalten Members


frmDomainSpalten Members

frmDomainSpalten overview

Constructors

constructor frmDomainSpalten Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generate_Data
method InitializeComponent
method MenuItem3_Click
method MenuItem4_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainSpalten_Load

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSpalten Class


frmDomainSpalten Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten Properties

frmDomainSpalten overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainSpalten Class


frmDomainSpalten Methods

frmDomainSpalten overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Generate_Data
method InitializeComponent
method MenuItem3_Click
method MenuItem4_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainSpalten_Load

See Also

frmDomainSpalten Class


frmDomainSpalten.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.Generate_Data Method

Private Sub Generate_Data( _
   ByVal tablename As String _
)

Parameters

tablename
Required.

Source code

[Visual Basic]
    Private Sub Generate_Data(ByVal tablename As String)
        Me.SqlDataAdapter1.Update(Me.DataSet1)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dttable As New DataTable(tablename)
        scmCmdToExecute.CommandText = "dbo.[sp_update_spalten]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, tablename))
            scmCmdToExecute.Connection.Open()
            scmCmdToExecute.ExecuteNonQuery()
            Return
        Catch ex As Exception
            Throw New Exception(MyMsg.Get_Meldungstext(903), ex)
        Finally
            Me.SqlDataAdapter1.Fill(Me.DataSet1)
            scmCmdToExecute.Connection.Close()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "spalten", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("eintragnr", "eintragnr"), New System.Data.Common.DataColumnMapping("tabelle", "tabelle"), New System.Data.Common.DataColumnMapping("tabellenspalte", "tabellenspalte"), New System.Data.Common.DataColumnMapping("spalte", "spalte"), New System.Data.Common.DataColumnMapping("Readonly", "Readonly"), New System.Data.Common.DataColumnMapping("alsHacken", "alsHacken"), New System.Data.Common.DataColumnMapping("Breite", "Breite"), New System.Data.Common.DataColumnMapping("Reihenfolge", "Reihenfolge"), New System.Data.Common.DataColumnMapping("tiptext", "tiptext"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "Daten aus Tabelle generieren"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_spalten_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_spalten_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eintragnr", System.Data.SqlDbType.Int, 4, "eintragnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tabelle", System.Data.SqlDbType.VarChar, 255, "tabelle"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tabellenspalte", System.Data.SqlDbType.VarChar, 255, "tabellenspalte"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@spalte", System.Data.SqlDbType.VarChar, 255, "spalte"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Readonly", System.Data.SqlDbType.Bit, 1, "Readonly"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@alsHacken", System.Data.SqlDbType.Bit, 1, "alsHacken"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Breite", System.Data.SqlDbType.Int, 4, "Breite"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Reihenfolge", System.Data.SqlDbType.Int, 4, "Reihenfolge"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tiptext", System.Data.SqlDbType.VarChar, 255, "tiptext"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_spalten_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eintragnr", System.Data.SqlDbType.Int, 4, "eintragnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tabelle", System.Data.SqlDbType.VarChar, 255, "tabelle"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tabellenspalte", System.Data.SqlDbType.VarChar, 255, "tabellenspalte"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@spalte", System.Data.SqlDbType.VarChar, 255, "spalte"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Readonly", System.Data.SqlDbType.Bit, 1, "Readonly"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@alsHacken", System.Data.SqlDbType.Bit, 1, "alsHacken"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Breite", System.Data.SqlDbType.Int, 4, "Breite"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Reihenfolge", System.Data.SqlDbType.Int, 4, "Reihenfolge"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tiptext", System.Data.SqlDbType.VarChar, 255, "tiptext"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eintragnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eintragnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Breite", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Breite", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Readonly", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Readonly", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_alsHacken", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "alsHacken", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_spalte", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "spalte", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tabelle", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tabelle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tabellenspalte", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tabellenspalte", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tiptext", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tiptext", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_spalten_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eintragnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eintragnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Breite", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Breite", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Readonly", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Readonly", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_alsHacken", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "alsHacken", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_spalte", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "spalte", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tabelle", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tabelle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tabellenspalte", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tabellenspalte", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tiptext", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tiptext", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainSpalten
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(680, 277)
        Me.Name = "frmDomainSpalten"
        Me.Text = "Spalten"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim f As New frmSysadminTableSelector()
        Dim tablename As String
        tablename = (f.get_tablename())
        If tablename = "" Then Exit Sub
        Generate_Data(tablename)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)

            Dim spalten As New EDOKA.MySpaltenTitel()
            spalten.load_data()
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten.frmDomainSpalten_Load Method

Private Sub frmDomainSpalten_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainSpalten_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DomainList.AllowDelete = True
        Me.DomainList.ContextMenu = Me.ContextMenu1
        Me.TableName = "Spalten"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Dim i As Integer

        For i = 0 To Me.DomainList.Columns.Count - 1
            'Präsentation von Readonly
            If Me.DomainList.Columns(i).DataField = "Readonly" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DomainList.Columns(i).DefaultValue = False
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainSpalten Fields

frmDomainSpalten overview

Fields

field ContextMenu1
field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSpalten Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSpalten


frmDomainStatusBezeichnung Class

For a list of all members of this type, see frmDomainStatusBezeichnung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainStatusBezeichnung

Public Class frmDomainStatusBezeichnung
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainStatusBezeichnung Members


frmDomainStatusBezeichnung Members

frmDomainStatusBezeichnung overview

Constructors

constructor frmDomainStatusBezeichnung Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainStatusBezeichnung Class


frmDomainStatusBezeichnung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung Properties

frmDomainStatusBezeichnung overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainStatusBezeichnung Class


frmDomainStatusBezeichnung Methods

frmDomainStatusBezeichnung overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainStatusBezeichnung Class


frmDomainStatusBezeichnung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "status_bezeichnung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("status_bezeichnungnr", "status_bezeichnungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_status_bezeichnung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_status_bezeichnung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_status_bezeichnung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_status_bezeichnung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainStatusBezeichnung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(648, 357)
        Me.Name = "frmDomainStatusBezeichnung"
        Me.Text = "frmDomainStatusBezeichnung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "status_bezeichnung"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusBezeichnung Fields

frmDomainStatusBezeichnung overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainStatusBezeichnung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusBezeichnung


frmDomainStatusTyp Class

For a list of all members of this type, see frmDomainStatusTyp Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainStatusTyp

Public Class frmDomainStatusTyp
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainStatusTyp Members


frmDomainStatusTyp Members

frmDomainStatusTyp overview

Constructors

constructor frmDomainStatusTyp Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainStatusTyp Class


frmDomainStatusTyp Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp Properties

frmDomainStatusTyp overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainStatusTyp Class


frmDomainStatusTyp Methods

frmDomainStatusTyp overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainStatusTyp Class


frmDomainStatusTyp.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "statustyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("statustypnr", "statustypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_statustyp_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_statustyp_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_statustyp_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_statustyp_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainStatusTyp
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainStatusTyp"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "statustyp"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainStatusTyp Fields

frmDomainStatusTyp overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainStatusTyp Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainStatusTyp


frmDomainSteuerbefehl Class

For a list of all members of this type, see frmDomainSteuerbefehl Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainSteuerbefehl

Public Class frmDomainSteuerbefehl
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainSteuerbefehl Members


frmDomainSteuerbefehl Members

frmDomainSteuerbefehl overview

Constructors

constructor frmDomainSteuerbefehl Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmDomainMandant_Load
method frmDomainSteuerbefehl_Closing

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSteuerbefehl Class


frmDomainSteuerbefehl Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl Properties

frmDomainSteuerbefehl overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainSteuerbefehl Class


frmDomainSteuerbefehl Methods

frmDomainSteuerbefehl overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmDomainMandant_Load
method frmDomainSteuerbefehl_Closing

See Also

frmDomainSteuerbefehl Class


frmDomainSteuerbefehl.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "Steuerbefehle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("feldsteuerungNr", "feldsteuerungNr"), New System.Data.Common.DataColumnMapping("steuerung", "steuerung"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_Steuerbefehl_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_Steuerbefehl_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@steuerung", System.Data.SqlDbType.VarChar, 50, "steuerung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_Steuerbefehl_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, "feldsteuerungNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@steuerung", System.Data.SqlDbType.VarChar, 50, "steuerung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_steuerung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "steuerung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_Steuerbefehl_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_steuerung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "steuerung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=TGTSQLEDOKABSSF;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgentwicklung3;workstation id=TG602640;packet size" & _
        "=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmDomainSteuerbefehl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 360)
        Me.Name = "frmDomainSteuerbefehl"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "Steuerbefehle"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        Dim i As Integer
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "odbc" Then Me.DomainList.Columns(i).DefaultValue = False
            If Me.DomainList.Columns(i).DataField = "oledb" Then Me.DomainList.Columns(i).DefaultValue = True
            If Me.DomainList.Columns(i).DataField = "sqlclient" Then Me.DomainList.Columns(i).DefaultValue = False
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl.frmDomainSteuerbefehl_Closing Method

Private Sub frmDomainSteuerbefehl_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainSteuerbefehl_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSteuerbefehl Fields

frmDomainSteuerbefehl overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSteuerbefehl Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSteuerbefehl


frmDomainSysadminfuntkion Class

For a list of all members of this type, see frmDomainSysadminfuntkion Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainSysadminfuntkion

Public Class frmDomainSysadminfuntkion
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainSysadminfuntkion Members


frmDomainSysadminfuntkion Members

frmDomainSysadminfuntkion overview

Constructors

constructor frmDomainSysadminfuntkion Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSysadminfuntkion Class


frmDomainSysadminfuntkion Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion Properties

frmDomainSysadminfuntkion overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainSysadminfuntkion Class


frmDomainSysadminfuntkion Methods

frmDomainSysadminfuntkion overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainSysadminfuntkion Class


frmDomainSysadminfuntkion.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sysadminfunktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("sysadminfnktnr", "sysadminfnktnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("ParentID", "ParentID"), New System.Data.Common.DataColumnMapping("Sort", "Sort"), New System.Data.Common.DataColumnMapping("ImageIndex", "ImageIndex"), New System.Data.Common.DataColumnMapping("ImageIndexOpen", "ImageIndexOpen"), New System.Data.Common.DataColumnMapping("ftop", "ftop"), New System.Data.Common.DataColumnMapping("fleft", "fleft"), New System.Data.Common.DataColumnMapping("fwidth", "fwidth"), New System.Data.Common.DataColumnMapping("fheight", "fheight"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pf_sysadminfunktion_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pf_sysadminfunktion_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParentID", System.Data.SqlDbType.Int, 4, "ParentID"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Sort", System.Data.SqlDbType.Int, 4, "Sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndex", System.Data.SqlDbType.Int, 4, "ImageIndex"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndexOpen", System.Data.SqlDbType.Int, 4, "ImageIndexOpen"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ftop", System.Data.SqlDbType.Int, 4, "ftop"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fleft", System.Data.SqlDbType.Int, 4, "fleft"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fwidth", System.Data.SqlDbType.Int, 4, "fwidth"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fheight", System.Data.SqlDbType.Int, 4, "fheight"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pf_sysadminfunktion_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParentID", System.Data.SqlDbType.Int, 4, "ParentID"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Sort", System.Data.SqlDbType.Int, 4, "Sort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndex", System.Data.SqlDbType.Int, 4, "ImageIndex"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndexOpen", System.Data.SqlDbType.Int, 4, "ImageIndexOpen"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ftop", System.Data.SqlDbType.Int, 4, "ftop"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fleft", System.Data.SqlDbType.Int, 4, "fleft"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fwidth", System.Data.SqlDbType.Int, 4, "fwidth"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fheight", System.Data.SqlDbType.Int, 4, "fheight"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndexOpen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndexOpen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParentID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParentID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fheight", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fheight", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fleft", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fleft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ftop", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ftop", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fwidth", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fwidth", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pf_sysadminfunktion_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndexOpen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndexOpen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParentID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParentID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fheight", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fheight", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fleft", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fleft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ftop", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ftop", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fwidth", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fwidth", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainSysadminfuntkion
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(728, 409)
        Me.Name = "frmDomainSysadminfuntkion"
        Me.Text = "Systemmenu-Einträge"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "sysadminfunktion"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlConnection1.Open()
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainSysadminfuntkion Fields

frmDomainSysadminfuntkion overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainSysadminfuntkion Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainSysadminfuntkion


frmDomainTeam Class

For a list of all members of this type, see frmDomainTeam Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainTeam

Public Class frmDomainTeam
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainTeam Members


frmDomainTeam Members

frmDomainTeam overview

Constructors

constructor frmDomainTeam Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainTeam Class


frmDomainTeam Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam Properties

frmDomainTeam overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainTeam Class


frmDomainTeam Methods

frmDomainTeam overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainTeam Class


frmDomainTeam.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainTeam))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "team", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("teamnr", "teamnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("kostenstellenr", "kostenstellenr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_team_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_team_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_team_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_team_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "kostenstelle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("kostenstellenr", "kostenstellenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_kostenstelle_aktiv_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_kostenstelle_aktiv_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_kostetenstelle_aktiv_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_kostenstelle_aktiv_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(312, 0)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines1
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(192, 240)
        Me.C1TrueDBDropdown1.TabIndex = 5
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 188, 236</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 188, 236</ClientA" & _
        "rea></Blob>"
        '
        'frmDomainTeam
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBDropdown1})
        Me.Name = "frmDomainTeam"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "team"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        'Kostenstelle
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.C1TrueDBDropdown1.DataSource = Me.DataSet2
        Me.C1TrueDBDropdown1.DataMember = "kostenstelle"
        Me.C1TrueDBDropdown1.Columns(0).Caption = MyMsg.Get_Meldungstext(7006)
        Me.C1TrueDBDropdown1.Columns(1).Caption = MyMsg.Get_Meldungstext(7007)
        Me.C1TrueDBDropdown1.DisplayColumns(0).Width = 20
        Me.DomainList.Columns("kostenstellenr").DropDown = Me.C1TrueDBDropdown1

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTeam Fields

frmDomainTeam overview

Fields

field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainTeam Class


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTeam


frmDomainTipTexte Class

For a list of all members of this type, see frmDomainTipTexte Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainTipTexte

Public Class frmDomainTipTexte
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainTipTexte Members


frmDomainTipTexte Members

frmDomainTipTexte overview

Constructors

constructor frmDomainTipTexte Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMeldungstexte_Load

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainTipTexte Class


frmDomainTipTexte Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte Properties

frmDomainTipTexte overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainTipTexte Class


frmDomainTipTexte Methods

frmDomainTipTexte overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMeldungstexte_Load

See Also

frmDomainTipTexte Class


frmDomainTipTexte.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "tiptexte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("tiptextnr", "tiptextnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("inhalt", "inhalt"), New System.Data.Common.DataColumnMapping("forciert", "forciert"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_tiptexte_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_tiptexte_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tiptextnr", System.Data.SqlDbType.Int, 4, "tiptextnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@forciert", System.Data.SqlDbType.Bit, 1, "forciert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_tiptexte_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tiptextnr", System.Data.SqlDbType.Int, 4, "tiptextnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@forciert", System.Data.SqlDbType.Bit, 1, "forciert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tiptextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tiptextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_forciert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "forciert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_tiptexte_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tiptextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tiptextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_forciert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "forciert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainTipTexte
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(704, 273)
        Me.Name = "frmDomainTipTexte"
        Me.Text = "Hint-Texte"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte.frmDomainMeldungstexte_Load Method

Private Sub frmDomainMeldungstexte_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMeldungstexte_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Me.TableName = "tiptexte"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        SpaltenTitel_Aktualisieren(Me.DataSet1)

        For i = 0 To Me.DomainList.Columns.Count - 1
            'Präsentation von Readonly
            If Me.DomainList.Columns(i).DataField = "forciert" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.DomainList.Columns(i).DefaultValue = False
            End If
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainTipTexte Fields

frmDomainTipTexte overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainTipTexte Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainTipTexte


frmDomainVorlagenfeldregel Class

For a list of all members of this type, see frmDomainVorlagenfeldregel Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainVorlagenfeldregel

Public Class frmDomainVorlagenfeldregel
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainVorlagenfeldregel Members


frmDomainVorlagenfeldregel Members

frmDomainVorlagenfeldregel overview

Constructors

constructor frmDomainVorlagenfeldregel Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property cTransferkey

Methods

method Dispose
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Get_Selected_Items
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field coltransferkey
field components

See Also

frmDomainVorlagenfeldregel Class


frmDomainVorlagenfeldregel Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel Properties

frmDomainVorlagenfeldregel overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)
property cTransferkey

See Also

frmDomainVorlagenfeldregel Class


frmDomainVorlagenfeldregel.cTransferkey Property

Property cTransferkey() As Collection

Source code

[Visual Basic]
    Property cTransferkey() As Collection
        Get
            Return coltransferkey
        End Get
        Set(ByVal Value As Collection)
            coltransferkey = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel Methods

frmDomainVorlagenfeldregel overview

Methods

method Dispose
method Domainlist_dblclick
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method Get_Selected_Items
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

frmDomainVorlagenfeldregel Class


frmDomainVorlagenfeldregel.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.Domainlist_dblclick Method

Private Sub Domainlist_dblclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Domainlist_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        If ToSelect Then
            coltransferkey.Add(Me.DomainList.Columns(0).Text)
            Me.Close()
            Exit Sub
        End If
        Dim frm As New frmVorlagenfelddetail()
        Dim s As String
        frm.TextBox1.Text = Me.DomainList.Columns(1).Text
        frm.TextBox2.Text = Me.DomainList.Columns(2).Text
        frm.cbFeldtyp.Text = Me.DomainList.Columns(3).Text
        frm.cbStandard.Checked = Me.DomainList.Columns(5).Text = "True"
        frm.txtDatenherkunft.Text = Me.DomainList.Columns(4).Text
        frm.TxtTextmakebeginn.Text = Me.DomainList.Columns(6).Text
        frm.txtTextmarkeEnde.Text = Me.DomainList.Columns(7).Text
        frm.txtFeldname.Text = Me.DomainList.Columns(8).Text
        frm.TxtTestdata.Text = Me.DomainList.Columns(9).Text
        frm.ShowDialog()
        Me.DomainList.Columns(1).Text = frm.TextBox1.Text
        Me.DomainList.Columns(2).Text = frm.TextBox2.Text
        Me.DomainList.Columns(3).Text = frm.cbFeldtyp.Text
        Me.DomainList.Columns(4).Text = frm.txtDatenherkunft.Text
        If frm.cbStandard.Checked Then Me.DomainList.Columns(5).Text = "True" Else Me.DomainList.Columns(5).Text = False
        Me.DomainList.Columns(6).Text = frm.TxtTextmakebeginn.Text
        Me.DomainList.Columns(7).Text = frm.txtTextmarkeEnde.Text
        Me.DomainList.Columns(8).Text = frm.txtFeldname.Text
        Me.DomainList.Columns(9).Text = frm.TxtTestdata.Text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.Get_Selected_Items Method

Private Sub Get_Selected_Items()

Source code

[Visual Basic]
    Private Sub Get_Selected_Items()
        Dim i As Long
        For i = 0 To Me.DomainList.SelectedRows.Count - 1
            coltransferkey.Add(Me.DomainList.Columns(0).CellValue(Me.DomainList.SelectedRows.Item(i)))
        Next
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainVorlagenfeldregel))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "vorlagenfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("vorlagenfeldregelnr", "vorlagenfeldregelnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("obbezeichnung", "obbezeichnung"), New System.Data.Common.DataColumnMapping("kategorie", "kategorie"), New System.Data.Common.DataColumnMapping("textmarkebeginn", "textmarkebeginn"), New System.Data.Common.DataColumnMapping("textmarkeende", "textmarkeende"), New System.Data.Common.DataColumnMapping("feldname", "feldname"), New System.Data.Common.DataColumnMapping("testdata", "testdata"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("userinterface", "userinterface"), New System.Data.Common.DataColumnMapping("HINT", "HINT"), New System.Data.Common.DataColumnMapping("eingabeformat", "eingabeformat"), New System.Data.Common.DataColumnMapping("Validierungsregel", "Validierungsregel")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "meldungstexte", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("inhalt", "inhalt")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_Feldtypvorlagenfeldregel_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_meldungstextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "meldungstextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_Feldtypvorlagenfeldregel_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@meldungstextnr", System.Data.SqlDbType.Int, 4, "meldungstextnr"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_Feldtypvorlagenfeldregel_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_Feldtypvorlagenfeldregel_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inhalt", System.Data.SqlDbType.VarChar, 1024, "inhalt"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@meldungstextnr", System.Data.SqlDbType.Int, 4, "meldungstextnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_meldungstextnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "meldungstextnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inhalt", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inhalt", System.Data.DataRowVersion.Original, Nothing))
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(224, 0)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines1
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(208, 184)
        Me.C1TrueDBDropdown1.TabIndex = 5
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 204, 180</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 204, 180</ClientA" & _
        "rea></Blob>"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_vorlagenfeldregel_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_vorlagenfeldregel_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldregelnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 255, "feldtyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 1024, "datenherkunft"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@obbezeichnung", System.Data.SqlDbType.VarChar, 255, "obbezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kategorie", System.Data.SqlDbType.Int, 4, "kategorie"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@textmarkebeginn", System.Data.SqlDbType.VarChar, 255, "textmarkebeginn"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@textmarkeende", System.Data.SqlDbType.VarChar, 255, "textmarkeende"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldname", System.Data.SqlDbType.VarChar, 255, "feldname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@testdata", System.Data.SqlDbType.VarChar, 255, "testdata"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@userinterface", System.Data.SqlDbType.Bit, 1, "userinterface"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@HINT", System.Data.SqlDbType.VarChar, 255, "HINT"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabeformat", System.Data.SqlDbType.VarChar, 255, "eingabeformat"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Validierungsregel", System.Data.SqlDbType.VarChar, 255, "Validierungsregel"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_vorlagenfeldregel_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, "vorlagenfeldregelnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 255, "feldtyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 1024, "datenherkunft"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@obbezeichnung", System.Data.SqlDbType.VarChar, 255, "obbezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kategorie", System.Data.SqlDbType.Int, 4, "kategorie"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@textmarkebeginn", System.Data.SqlDbType.VarChar, 255, "textmarkebeginn"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@textmarkeende", System.Data.SqlDbType.VarChar, 255, "textmarkeende"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldname", System.Data.SqlDbType.VarChar, 255, "feldname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@testdata", System.Data.SqlDbType.VarChar, 255, "testdata"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@userinterface", System.Data.SqlDbType.Bit, 1, "userinterface"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@HINT", System.Data.SqlDbType.VarChar, 255, "HINT"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabeformat", System.Data.SqlDbType.VarChar, 255, "eingabeformat"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Validierungsregel", System.Data.SqlDbType.VarChar, 255, "Validierungsregel"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_HINT", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "HINT", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Validierungsregel", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Validierungsregel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabeformat", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabeformat", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kategorie", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kategorie", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_obbezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "obbezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_testdata", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "testdata", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_textmarkebeginn", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "textmarkebeginn", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_textmarkeende", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "textmarkeende", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_userinterface", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "userinterface", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_vorlagenfeldregel_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagenfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagenfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_HINT", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "HINT", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Validierungsregel", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Validierungsregel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabeformat", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabeformat", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kategorie", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kategorie", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_obbezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "obbezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_testdata", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "testdata", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_textmarkebeginn", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "textmarkebeginn", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_textmarkeende", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "textmarkeende", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_userinterface", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "userinterface", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainVorlagenfeldregel
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(792, 553)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBDropdown1})
        Me.Name = "frmDomainVorlagenfeldregel"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(ex.Message)
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                If ToSelect Then Get_Selected_Items()
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case 2
                Domainlist_dblclick(sender, e)

        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Me.TableName = "vorlagenfeldregel"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.C1TrueDBDropdown1.DataSource = Me.DataSet2
        Me.C1TrueDBDropdown1.DataMember = "meldungstexte"
        Me.C1TrueDBDropdown1.DisplayColumns(1).Width = 0
        Me.C1TrueDBDropdown1.Columns(0).Caption = MyMsg.Get_Meldungstext(7012)
        Me.DomainList.Columns("feldtyp").DropDown = Me.C1TrueDBDropdown1

        SpaltenTitel_Aktualisieren(Me.DataSet1)
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "standard" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
        Next

        Dim btn As New ToolBarButton()
        btn.ImageIndex = 3
        Me.ToolBar1.Buttons.Add(btn)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainVorlagenfeldregel Fields

frmDomainVorlagenfeldregel overview

Fields

field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field coltransferkey
field components

See Also

frmDomainVorlagenfeldregel Class


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


coltransferkey Variable

Dim coltransferkey As New Collection()

Source code

[Visual Basic]
    Dim coltransferkey As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainVorlagenfeldregel


frmDomainZuordnungen Class

For a list of all members of this type, see frmDomainZuordnungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmDomainZuordnungen

Public Class frmDomainZuordnungen
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDomainZuordnungen Members


frmDomainZuordnungen Members

frmDomainZuordnungen overview

Constructors

constructor frmDomainZuordnungen Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainZuordnungen Class


frmDomainZuordnungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen Properties

frmDomainZuordnungen overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmDomainZuordnungen Class


frmDomainZuordnungen Methods

frmDomainZuordnungen overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmDomainZuordnungen Class


frmDomainZuordnungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "zuordnung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("zuordnungnr", "zuordnungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_zuordung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection2
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_zuordung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection2
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zuordnungnr", System.Data.SqlDbType.Int, 4, "zuordnungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_zuordnung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zuordnungnr", System.Data.SqlDbType.Int, 4, "zuordnungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zuordnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zuordnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_zuordnung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zuordnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zuordnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'frmDomainZuordnungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmDomainZuordnungen"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "zuordnung"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDomainZuordnungen Fields

frmDomainZuordnungen overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmDomainZuordnungen Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainZuordnungen


frmDruckMessage Class

For a list of all members of this type, see frmDruckMessage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDruckMessage

Public Class frmDruckMessage
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDruckMessage Members


frmDruckMessage Members

frmDruckMessage overview

Constructors

constructor frmDruckMessage Constructor

Properties

property dt

Methods

method Button1_Click
method Button2_Click
method CheckBox1_CheckedChanged
method Check_Data
method Dispose
method InitializeComponent
method Timer1_Tick
method checkdata
method frmDruckMessage_Closing
method frmDruckMessage_Load
method update_meldung

Fields

field Button1
field Button2
field CheckBox1
field ComboBox1
field Label1
field Timer1
field components

See Also

frmDruckMessage Class


frmDruckMessage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Check_Data()
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage Properties

frmDruckMessage overview

Properties

property dt

See Also

frmDruckMessage Class


dt Property

Public dt As New DataTable()

Source code

[Visual Basic]
    Public dt As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage Methods

frmDruckMessage overview

Methods

method Button1_Click
method Button2_Click
method CheckBox1_CheckedChanged
method Check_Data
method Dispose
method InitializeComponent
method Timer1_Tick
method checkdata
method frmDruckMessage_Closing
method frmDruckMessage_Load
method update_meldung

See Also

frmDruckMessage Class


frmDruckMessage.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New frmSerienbriefe(True, Me.ComboBox1.SelectedValue)
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.CheckBox1_CheckedChanged Method

Private Sub CheckBox1_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles CheckBox1.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckBox1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles CheckBox1.CheckedChanged
        If Me.CheckBox1.Checked = True Then
            Me.update_meldung()
            Me.ComboBox1.DataSource = Nothing
            Me.ComboBox1.Items.Clear()
            Me.Check_Data()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.Check_Data Method

Public Function Check_Data() As Integer

Source code

[Visual Basic]
    Public Function Check_Data() As Integer
        dt = checkdata()
        Me.ComboBox1.DataSource = dt
        Me.ComboBox1.DisplayMember = "bezeichnung"
        Me.ComboBox1.ValueMember = "serienbriefnr"
        If dt.Rows.Count > 0 Then
            Me.Visible = True
            Application.DoEvents()
        Else
            Me.Visible = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDruckMessage))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(296, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Für folgende Serienbriefe wurden Dokumente aufbereitet:"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(8, 40)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(288, 21)
        Me.ComboBox1.TabIndex = 1
        Me.ComboBox1.Text = "ComboBox1"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 72)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(176, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(120, 23)
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "Serienbrief anzeigen"
        '
        'Timer1
        '
        Me.Timer1.Enabled = True
        Me.Timer1.Interval = 1800000
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(8, 104)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(288, 24)
        Me.CheckBox1.TabIndex = 4
        Me.CheckBox1.Text = "Keine Meldungen für diesen Serienbrief erstellen"
        '
        'frmDruckMessage
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(304, 141)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.CheckBox1, Me.Button2, Me.Button1, Me.ComboBox1, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmDruckMessage"
        Me.Text = "Serienbriefe: Aufbereitete Dokumente"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.Timer1_Tick Method

Private Sub Timer1_Tick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Timer1.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Timer1.Tick
        Check_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.checkdata Method

Private Function checkdata() As DataTable

Source code

[Visual Basic]
    Private Function checkdata() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_serienbriefe_gedruckt"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.frmDruckMessage_Closing Method

Private Sub frmDruckMessage_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDruckMessage_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Me.Visible = False
        e.Cancel = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.frmDruckMessage_Load Method

Private Sub frmDruckMessage_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDruckMessage_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        '        Check_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage.update_meldung Method

Private Function update_meldung()

Source code

[Visual Basic]
    Private Function update_meldung()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_set_druckjobmeldung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@serienbriefnr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.ComboBox1.SelectedValue))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            Throw New Exception("sp_edex_sb_set_druckjobmeldung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckMessage Fields

frmDruckMessage overview

Fields

field Button1
field Button2
field CheckBox1
field ComboBox1
field Label1
field Timer1
field components

See Also

frmDruckMessage Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


Timer1 Variable

Friend WithEvents Timer1 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckMessage


frmDruckabschluss Class

For a list of all members of this type, see frmDruckabschluss Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDruckabschluss

Public Class frmDruckabschluss
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmDruckabschluss Members


frmDruckabschluss Members

frmDruckabschluss overview

Constructors

constructor frmDruckabschluss Constructor (Overloaded)

Properties

property datasaved

Methods

method Abbruch_Click
method Button1_Click
method Dispose
method Dokumente_bestaetigen
method InitializeComponent
method Load_empfaenger
method SetProgress
method check_data
method frmDruckabschluss_Load
method save_empfaenger

Fields

field Abbruch
field Button1
field GroupBox1
field GroupBox2
field Label1
field Label2
field StatusBar1
field components
field dsempfaenger
field m_datasaved
field progress
field rbabschliessen
field rbgeneriertedokumentebestätigen
field rbkeineaktion
field rbweiteregenerieren
field serienbrief
field serienbriefnr
field txtbemerkung

See Also

frmDruckabschluss Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal serienbriefnr As Integer)

See Also

frmDruckabschluss | EDOKAApp


frmDruckabschluss Properties

frmDruckabschluss overview

Properties

property datasaved

See Also

frmDruckabschluss Class


frmDruckabschluss.datasaved Property

Property datasaved() As Boolean

Source code

[Visual Basic]
    Property datasaved() As Boolean
        Get
            Return m_datasaved
        End Get
        Set(ByVal Value As Boolean)
            m_datasaved = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss Methods

frmDruckabschluss overview

Methods

method Abbruch_Click
method Button1_Click
method Dispose
method Dokumente_bestaetigen
method InitializeComponent
method Load_empfaenger
method SetProgress
method check_data
method frmDruckabschluss_Load
method save_empfaenger

See Also

frmDruckabschluss Class


frmDruckabschluss.Abbruch_Click Method

Private Sub Abbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Abbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Abbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Abbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        If Me.rbkeineaktion.Checked Then
            Me.datasaved = False
            Me.Close()
        End If
        If Me.rbgeneriertedokumentebestätigen.Checked Then
            Dokumente_bestaetigen()
            Me.save_empfaenger()
            Me.datasaved = True
            Me.Close()
        End If
        If Me.rbabschliessen.Checked Then
            Dokumente_bestaetigen()
            Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()
            serienbrief.cpMainConnectionProvider = Globals.conn
            serienbrief.iSerienbriefnr = New SqlInt32(CType(Me.serienbriefnr, Int32))
            serienbrief.SelectOne()
            serienbrief.iStatus = New SqlInt32(CType(1, Int32))
            Globals.conn.OpenConnection()
            serienbrief.Update()
            Globals.conn.CloseConnection(True)
            serienbrief.Dispose()

            Me.save_empfaenger()
            Me.datasaved = True
            Me.Close()
        End If
        If Me.rbweiteregenerieren.Checked Then
            Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()
            serienbrief.cpMainConnectionProvider = Globals.conn
            serienbrief.iSerienbriefnr = New SqlInt32(CType(Me.serienbriefnr, Int32))
            serienbrief.SelectOne()
            serienbrief.iStatus = New SqlInt32(CType(-1, Int32))
            Globals.conn.OpenConnection()
            serienbrief.Update()
            Globals.conn.CloseConnection(True)
            serienbrief.Dispose()
            Me.save_empfaenger()
            Me.Close()
            Me.datasaved = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.Dokumente_bestaetigen Method

Private Sub Dokumente_bestaetigen()

Source code

[Visual Basic]
    Private Sub Dokumente_bestaetigen()
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        Dim pwert As Integer
        Dim i As Integer
        For i = 0 To Me.dsempfaenger.Tables(0).Rows.Count - 1
            Try
                pwert = 100 / Me.dsempfaenger.Tables(0).Rows.Count * i
            Catch
                pwert = 0
            End Try
            Me.SetProgress(pwert, "Dokumente bestätigen", False)

            Try
                If Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 2 Or Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 3 Then
                    Me.dsempfaenger.Tables(0).Rows(i).Item("Dokument_Gedruckt") = 1
                    Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 4
                End If
            Catch
            End Try
        Next
        Me.SetProgress(100, "", True)
        Cursor = Cursors.Default
        Application.DoEvents()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.rbabschliessen = New System.Windows.Forms.RadioButton()
        Me.rbgeneriertedokumentebestätigen = New System.Windows.Forms.RadioButton()
        Me.rbweiteregenerieren = New System.Windows.Forms.RadioButton()
        Me.rbkeineaktion = New System.Windows.Forms.RadioButton()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.txtbemerkung = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Abbruch = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.rbabschliessen, Me.rbgeneriertedokumentebestätigen, Me.rbweiteregenerieren, Me.rbkeineaktion})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 40)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(320, 128)
        Me.GroupBox1.TabIndex = 0
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Optionen"
        '
        'rbabschliessen
        '
        Me.rbabschliessen.Location = New System.Drawing.Point(16, 96)
        Me.rbabschliessen.Name = "rbabschliessen"
        Me.rbabschliessen.Size = New System.Drawing.Size(200, 24)
        Me.rbabschliessen.TabIndex = 3
        Me.rbabschliessen.Text = "Serienbrief abschliessen"
        '
        'rbgeneriertedokumentebestätigen
        '
        Me.rbgeneriertedokumentebestätigen.Location = New System.Drawing.Point(16, 72)
        Me.rbgeneriertedokumentebestätigen.Name = "rbgeneriertedokumentebestätigen"
        Me.rbgeneriertedokumentebestätigen.Size = New System.Drawing.Size(200, 24)
        Me.rbgeneriertedokumentebestätigen.TabIndex = 2
        Me.rbgeneriertedokumentebestätigen.Text = "Erstellte Dokumente bestätigen"
        '
        'rbweiteregenerieren
        '
        Me.rbweiteregenerieren.Location = New System.Drawing.Point(16, 48)
        Me.rbweiteregenerieren.Name = "rbweiteregenerieren"
        Me.rbweiteregenerieren.Size = New System.Drawing.Size(240, 24)
        Me.rbweiteregenerieren.TabIndex = 1
        Me.rbweiteregenerieren.Text = "Weitere pendente Dokumente generieren"
        '
        'rbkeineaktion
        '
        Me.rbkeineaktion.Location = New System.Drawing.Point(16, 24)
        Me.rbkeineaktion.Name = "rbkeineaktion"
        Me.rbkeineaktion.Size = New System.Drawing.Size(152, 24)
        Me.rbkeineaktion.TabIndex = 0
        Me.rbkeineaktion.Text = "keine Aktion durchführen"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtbemerkung})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 176)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(320, 100)
        Me.GroupBox2.TabIndex = 1
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Beschreibung"
        '
        'txtbemerkung
        '
        Me.txtbemerkung.BackColor = System.Drawing.SystemColors.ActiveBorder
        Me.txtbemerkung.Location = New System.Drawing.Point(8, 16)
        Me.txtbemerkung.Multiline = True
        Me.txtbemerkung.Name = "txtbemerkung"
        Me.txtbemerkung.Size = New System.Drawing.Size(304, 72)
        Me.txtbemerkung.TabIndex = 0
        Me.txtbemerkung.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(248, 288)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "OK"
        '
        'Abbruch
        '
        Me.Abbruch.Location = New System.Drawing.Point(8, 288)
        Me.Abbruch.Name = "Abbruch"
        Me.Abbruch.TabIndex = 3
        Me.Abbruch.Text = "Abbruch"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(64, 23)
        Me.Label1.TabIndex = 4
        Me.Label1.Text = "Serienbrief:"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(80, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(248, 23)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Label2"
        '
        'StatusBar1
        '
        Me.StatusBar1.Location = New System.Drawing.Point(0, 327)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(336, 22)
        Me.StatusBar1.TabIndex = 6
        '
        'frmDruckabschluss
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(336, 349)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.StatusBar1, Me.Label2, Me.Label1, Me.Abbruch, Me.Button1, Me.GroupBox2, Me.GroupBox1})
        Me.Name = "frmDruckabschluss"
        Me.Text = "Serienbrief-Verarbeitung:"
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.Load_empfaenger Method

Private Function Load_empfaenger() As Boolean

Source code

[Visual Basic]
    Private Function Load_empfaenger() As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.serienbriefnr.ToString + "_empfaenger.xml"
            Me.dsempfaenger.Tables.Clear()
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_empfaenger where serienbriefnr=" + Str(Me.serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                    Return False
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(2)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                    Me.dsempfaenger.ReadXml(dokumentname)
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
                Return False
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.SetProgress Method

Private Sub SetProgress( _
   ByVal wert As Integer, _
   ByVal txt As String, _
   ByVal hidedialog As Boolean _
)

Parameters

wert
Required.
txt
Required.
hidedialog
Required.

Source code

[Visual Basic]
    Private Sub SetProgress(ByVal wert As Integer, ByVal txt As String, ByVal hidedialog As Boolean)
        If hidedialog Then
            progress.Hide()
            Exit Sub
        End If
        progress.Visible = True
        If wert + 1 > 100 Then wert = 99
        progress.Bar1.Value = wert + 1
        progress.info.Text = txt
        progress.Refresh()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.check_data Method

Private Function check_data()

Source code

[Visual Basic]
    Private Function check_data()
        Me.rbabschliessen.Enabled = False
        Me.rbgeneriertedokumentebestätigen.Enabled = False
        Me.rbkeineaktion.Enabled = True
        Me.rbweiteregenerieren.Enabled = False
        If Me.serienbrief.iAusgeloest.Value <> 0 Then Me.rbweiteregenerieren.Enabled = True
        If Me.serienbrief.iErstellt.Value <> 0 Or Me.serienbrief.iGedruckt.Value <> 0 Then Me.rbgeneriertedokumentebestätigen.Enabled = True
        If Me.serienbrief.iFehlerhaft.Value = 0 And Me.serienbrief.iAusgeloest.Value = 0 And Me.serienbrief.iInBearbeitung.Value = 0 Then
            Me.rbabschliessen.Enabled = True
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.frmDruckabschluss_Load Method

Private Sub frmDruckabschluss_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDruckabschluss_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        serienbrief.cpMainConnectionProvider = Globals.conn
        serienbrief.iSerienbriefnr = New SqlInt32(CType(Me.serienbriefnr, Int32))
        serienbrief.SelectOne()
        Label2.Text = serienbrief.sBezeichnung.Value
        serienbrief.Dispose()
        Me.StatusBar1.Controls.Add(progress)
        Me.SetProgress(0, "Empfänger prüfen", False)
        If Load_empfaenger() = True Then
            check_data()
        End If
        Me.SetProgress(0, "", True)
        Me.rbkeineaktion.Checked = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss.save_empfaenger Method

Private Function save_empfaenger() As Boolean

Source code

[Visual Basic]
    Private Function save_empfaenger() As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.serienbriefnr.ToString + "_empfaenger.xml"
            Me.dsempfaenger.WriteXml(dokumentname)
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_empfaenger where serienbriefnr=" + Str(Me.serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    'Neue Serienbrief_Empfaenger speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(1) = Me.serienbriefnr
                    myRow.Item(2) = mydata
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "empf")
                Else
                    ' Bestehende Empfängerliste überschreiben
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(2) = mydata
                    DA.Update(ds, "empf")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(700, MsgBoxStyle.Critical)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(700, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss Fields

frmDruckabschluss overview

Fields

field Abbruch
field Button1
field GroupBox1
field GroupBox2
field Label1
field Label2
field StatusBar1
field components
field dsempfaenger
field m_datasaved
field progress
field rbabschliessen
field rbgeneriertedokumentebestätigen
field rbkeineaktion
field rbweiteregenerieren
field serienbrief
field serienbriefnr
field txtbemerkung

See Also

frmDruckabschluss Class


Abbruch Variable

Friend WithEvents Abbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Abbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


dsempfaenger Variable

Dim dsempfaenger As New DataSet()

Source code

[Visual Basic]
    Dim dsempfaenger As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


m_datasaved Variable

Dim m_datasaved As Boolean

Source code

[Visual Basic]
    Dim m_datasaved As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


progress Variable

Dim progress As New ucProgress()

Source code

[Visual Basic]
    Dim progress As New ucProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


rbabschliessen Variable

Friend WithEvents rbabschliessen As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbabschliessen As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


rbgeneriertedokumentebestätigen Variable

Friend WithEvents rbgeneriertedokumentebestätigen As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbgeneriertedokumentebestätigen As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


rbkeineaktion Variable

Friend WithEvents rbkeineaktion As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbkeineaktion As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


rbweiteregenerieren Variable

Friend WithEvents rbweiteregenerieren As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbweiteregenerieren As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


serienbrief Variable

Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()

Source code

[Visual Basic]
    Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


serienbriefnr Variable

Dim serienbriefnr As Integer

Source code

[Visual Basic]
    Dim serienbriefnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


txtbemerkung Variable

Friend WithEvents txtbemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmEDOKA_Import Class

For a list of all members of this type, see frmEDOKA_Import Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmEDOKA_Import

Public Class frmEDOKA_Import
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmEDOKA_Import Members


frmEDOKA_Import Members

frmEDOKA_Import overview

Constructors

constructor frmEDOKA_Import Constructor

Methods

method Dispose
method Get_Doc
method Get_indexdatei
method GrdJournaldetail_FetchRowStyle
method GrdJournale_FetchRowStyle
method GrdJournale_MouseDown
method InitializeComponent
method Load_Data
method MenuItem1_Click
method MenuItem2_Click
method MenuItem2_Click_1
method MnuDokanzeige_Click
method MnuReimport_Click
method ToolBar1_ButtonClick
method Update_Details
method frmEDOKA_Import_Load
method get_Journaldata
method get_Journale
method get_journale_connection
method mnuIndexMutation_Click
method popupjournaldetails_Popup
method save_xmlstring
method save_xmlstring_journal

Fields

field ContextMenu1
field GrdJournaldetail
field GrdJournale
field GrpJournalDetail
field GrpJournale
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field MnuDokanzeige
field MnuReimport
field SaveFileDialog1
field Splitter1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field journaldaten
field journaldetails
field mnuIndexMutation
field mnuindexdaten
field popupjournaldetails

See Also

frmEDOKA_Import Class


frmEDOKA_Import Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import Methods

frmEDOKA_Import overview

Methods

method Dispose
method Get_Doc
method Get_indexdatei
method GrdJournaldetail_FetchRowStyle
method GrdJournale_FetchRowStyle
method GrdJournale_MouseDown
method InitializeComponent
method Load_Data
method MenuItem1_Click
method MenuItem2_Click
method MenuItem2_Click_1
method MnuDokanzeige_Click
method MnuReimport_Click
method ToolBar1_ButtonClick
method Update_Details
method frmEDOKA_Import_Load
method get_Journaldata
method get_Journale
method get_journale_connection
method mnuIndexMutation_Click
method popupjournaldetails_Popup
method save_xmlstring
method save_xmlstring_journal

See Also

frmEDOKA_Import Class


frmEDOKA_Import.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.Get_Doc Method

Private Function Get_Doc( _
   ByVal itemid As Integer, _
   ByVal connectionstring As String _
) As String

Parameters

itemid
Required.
connectionstring
Required.

Source code

[Visual Basic]
    Private Function Get_Doc(ByVal itemid As Integer, ByVal connectionstring As String) As String
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From import_daten where import_data_nr=" + LTrim(Str(itemid)), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim Dokumentfilename As String
        Dim XMLFilename As String
        Dim xmlstring As String
        Dim xmlds As New DataSet()
        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = connectionstring
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            xmlstring = ds.Tables(0).Rows(0).Item(3)
            myRow = ds.Tables(0).Rows(0)

            'Indexfile schreiben
            XMLFilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmpxml.xml"
            FileOpen(11, XMLFilename, OpenMode.Output)
            PrintLine(11, xmlstring)
            FileClose(11)
            xmlds.ReadXml(XMLFilename)
            Dokumentfilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + xmlds.Tables(0).Rows(0).Item(12)
            xmlds.Dispose()
            'Dokumentdatei schreiben
            Dim MyData() As Byte
            MyData = myRow.Item(4)
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(Dokumentfilename, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return Dokumentfilename
        Catch ex As Exception
            FileClose(11)
            Return ""
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.Get_indexdatei Method

Private Function Get_indexdatei( _
   ByVal itemid As Integer, _
   ByVal connectionstring As String _
) As String

Parameters

itemid
Required.
connectionstring
Required.

Source code

[Visual Basic]
    Private Function Get_indexdatei(ByVal itemid As Integer, ByVal connectionstring As String) As String
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From import_job where import_jobnr=" + LTrim(Str(itemid)), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()
        Dim Dokumentfilename As String
        Dim XMLFilename As String
        Dim xmlstring As String
        Dim xmlds As New DataSet()
        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = connectionstring
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dokumentfilename = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmpind.ind"
            Dim MyData() As Byte
            MyData = myRow.Item(7)
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(Dokumentfilename, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return Dokumentfilename
        Catch ex As Exception
            Return ""
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.GrdJournaldetail_FetchRowStyle Method

Private Sub GrdJournaldetail_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles GrdJournaldetail.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub GrdJournaldetail_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles GrdJournaldetail.FetchRowStyle
        If Me.GrdJournaldetail.Columns("Status").CellValue(e.Row) <> "" And _
          Me.GrdJournaldetail.Columns("Status").CellValue(e.Row) <> "0" Then
            e.CellStyle.ForeColor = Color.Red
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.GrdJournale_FetchRowStyle Method

Private Sub GrdJournale_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles GrdJournale.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub GrdJournale_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles GrdJournale.FetchRowStyle
        If Me.GrdJournale.Columns("fehlerhaft").CellValue(e.Row) <> 0 Then
            e.CellStyle.ForeColor = Color.Red
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.GrdJournale_MouseDown Method

Private Sub GrdJournale_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles GrdJournale.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub GrdJournale_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles GrdJournale.MouseDown
        Me.GrdJournale.Bookmark = Me.GrdJournale.RowContaining(e.Y)
        Update_Details()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmEDOKA_Import))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GrpJournale = New System.Windows.Forms.GroupBox()
        Me.GrdJournale = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuindexdaten = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.GrpJournalDetail = New System.Windows.Forms.GroupBox()
        Me.GrdJournaldetail = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.popupjournaldetails = New System.Windows.Forms.ContextMenu()
        Me.mnuIndexMutation = New System.Windows.Forms.MenuItem()
        Me.MnuDokanzeige = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MnuReimport = New System.Windows.Forms.MenuItem()
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog()
        Me.GrpJournale.SuspendLayout()
        CType(Me.GrdJournale, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpJournalDetail.SuspendLayout()
        CType(Me.GrdJournaldetail, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(888, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 12
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'GrpJournale
        '
        Me.GrpJournale.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrdJournale})
        Me.GrpJournale.Dock = System.Windows.Forms.DockStyle.Top
        Me.GrpJournale.Location = New System.Drawing.Point(0, 25)
        Me.GrpJournale.Name = "GrpJournale"
        Me.GrpJournale.Size = New System.Drawing.Size(888, 248)
        Me.GrpJournale.TabIndex = 1
        Me.GrpJournale.TabStop = False
        Me.GrpJournale.Text = "Import_Journale"
        '
        'GrdJournale
        '
        Me.GrdJournale.AllowFilter = True
        Me.GrdJournale.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.GrdJournale.AllowSort = True
        Me.GrdJournale.AllowUpdate = False
        Me.GrdJournale.AllowUpdateOnBlur = False
        Me.GrdJournale.AlternatingRows = True
        Me.GrdJournale.CaptionHeight = 17
        Me.GrdJournale.CollapseColor = System.Drawing.Color.Black
        Me.GrdJournale.ContextMenu = Me.ContextMenu1
        Me.GrdJournale.Cursor = System.Windows.Forms.Cursors.Default
        Me.GrdJournale.DataChanged = False
        Me.GrdJournale.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.GrdJournale.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrdJournale.ExpandColor = System.Drawing.Color.Black
        Me.GrdJournale.FetchRowStyles = True
        Me.GrdJournale.FilterBar = True
        Me.GrdJournale.GroupByCaption = "Drag a column header here to group by that column"
        Me.GrdJournale.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.GrdJournale.Location = New System.Drawing.Point(3, 16)
        Me.GrdJournale.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.GrdJournale.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.GrdJournale.Name = "GrdJournale"
        Me.GrdJournale.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.GrdJournale.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.GrdJournale.PreviewInfo.ZoomFactor = 75
        Me.GrdJournale.PrintInfo.ShowOptionsDialog = False
        Me.GrdJournale.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.GrdJournale.RowDivider = GridLines1
        Me.GrdJournale.RowHeight = 15
        Me.GrdJournale.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.GrdJournale.ScrollTips = True
        Me.GrdJournale.Size = New System.Drawing.Size(882, 229)
        Me.GrdJournale.TabIndex = 26
        Me.GrdJournale.Text = "C1TrueDBGrid1"
        Me.GrdJournale.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 878," & _
        " 225</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 878, " & _
        "225</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuindexdaten, Me.MenuItem2})
        '
        'mnuindexdaten
        '
        Me.mnuindexdaten.Index = 0
        Me.mnuindexdaten.Text = "&Inputdatei anzeigen/mutierem"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Daten für nochmaligen Import bereitstellen"
        '
        'Splitter1
        '
        Me.Splitter1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter1.Location = New System.Drawing.Point(0, 273)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(888, 3)
        Me.Splitter1.TabIndex = 2
        Me.Splitter1.TabStop = False
        '
        'GrpJournalDetail
        '
        Me.GrpJournalDetail.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrdJournaldetail})
        Me.GrpJournalDetail.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpJournalDetail.Location = New System.Drawing.Point(0, 276)
        Me.GrpJournalDetail.Name = "GrpJournalDetail"
        Me.GrpJournalDetail.Size = New System.Drawing.Size(888, 281)
        Me.GrpJournalDetail.TabIndex = 3
        Me.GrpJournalDetail.TabStop = False
        Me.GrpJournalDetail.Text = "Journaldetails"
        '
        'GrdJournaldetail
        '
        Me.GrdJournaldetail.AllowFilter = True
        Me.GrdJournaldetail.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.GrdJournaldetail.AllowSort = True
        Me.GrdJournaldetail.AllowUpdate = False
        Me.GrdJournaldetail.AllowUpdateOnBlur = False
        Me.GrdJournaldetail.AlternatingRows = True
        Me.GrdJournaldetail.CaptionHeight = 17
        Me.GrdJournaldetail.CollapseColor = System.Drawing.Color.Black
        Me.GrdJournaldetail.ContextMenu = Me.popupjournaldetails
        Me.GrdJournaldetail.Cursor = System.Windows.Forms.Cursors.Default
        Me.GrdJournaldetail.DataChanged = False
        Me.GrdJournaldetail.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.GrdJournaldetail.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrdJournaldetail.ExpandColor = System.Drawing.Color.Black
        Me.GrdJournaldetail.FetchRowStyles = True
        Me.GrdJournaldetail.FilterBar = True
        Me.GrdJournaldetail.GroupByCaption = "Drag a column header here to group by that column"
        Me.GrdJournaldetail.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.GrdJournaldetail.ImeMode = System.Windows.Forms.ImeMode.On
        Me.GrdJournaldetail.Location = New System.Drawing.Point(3, 16)
        Me.GrdJournaldetail.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.GrdJournaldetail.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.GrdJournaldetail.Name = "GrdJournaldetail"
        Me.GrdJournaldetail.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.GrdJournaldetail.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.GrdJournaldetail.PreviewInfo.ZoomFactor = 75
        Me.GrdJournaldetail.PrintInfo.ShowOptionsDialog = False
        Me.GrdJournaldetail.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.GrdJournaldetail.RowDivider = GridLines2
        Me.GrdJournaldetail.RowHeight = 15
        Me.GrdJournaldetail.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.GrdJournaldetail.ScrollTips = True
        Me.GrdJournaldetail.Size = New System.Drawing.Size(882, 262)
        Me.GrdJournaldetail.TabIndex = 26
        Me.GrdJournaldetail.Text = "C1TrueDBGrid1"
        Me.GrdJournaldetail.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 878," & _
        " 258</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 878, " & _
        "258</ClientArea></Blob>"
        '
        'popupjournaldetails
        '
        Me.popupjournaldetails.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuIndexMutation, Me.MnuDokanzeige, Me.MenuItem1, Me.MenuItem3, Me.MnuReimport})
        '
        'mnuIndexMutation
        '
        Me.mnuIndexMutation.Index = 0
        Me.mnuIndexMutation.Text = "&Indexdaten anzeigen/mutieren"
        '
        'MnuDokanzeige
        '
        Me.MnuDokanzeige.Index = 1
        Me.MnuDokanzeige.Text = "&Dokument lokal speichern"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "Dokument &anzeigen"
        Me.MenuItem1.Visible = False
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 3
        Me.MenuItem3.Text = "-"
        '
        'MnuReimport
        '
        Me.MnuReimport.Index = 4
        Me.MnuReimport.Text = "Dokument für den nochmaligen Import &bereitstellen"
        '
        'SaveFileDialog1
        '
        Me.SaveFileDialog1.FileName = "doc1"
        '
        'frmEDOKA_Import
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(888, 557)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpJournalDetail, Me.Splitter1, Me.GrpJournale, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmEDOKA_Import"
        Me.ShowInTaskbar = False
        Me.Text = "frmEDOKA_Import"
        Me.GrpJournale.ResumeLayout(False)
        CType(Me.GrdJournale, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpJournalDetail.ResumeLayout(False)
        CType(Me.GrdJournaldetail, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.Load_Data Method

Private Sub Load_Data()

Source code

[Visual Basic]
    Private Sub Load_Data()
        Me.journaldaten = Nothing
        Me.journaldaten = get_Journale()
        Me.GrdJournale.DataSource = journaldaten
        Me.GrdJournale.DataMember = journaldaten.TableName
        Update_Details()
        DivFnkt.SpaltenTitel_Aktualisieren(Me.GrdJournale, Me.journaldaten, "ImportJournal")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim conn_journale As String
        conn_journale = get_journale_connection()
        Dim s As String
        s = Get_Doc(Me.GrdJournaldetail.Columns(1).Value, conn_journale)
        If s = "" Then
            MsgBox("Die Datei konnte nicht gespeichert werden.")
        Else
            Dim i As Integer
            i = Shell(s, AppWinStyle.NormalFocus, False)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuindexdaten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuindexdaten.Click
        Dim conn_journale As String
        conn_journale = get_journale_connection()
        Dim s As String
        s = Get_indexdatei(Me.GrdJournale.Columns(0).Value, conn_journale)
        If s = "" Then Exit Sub
        Dim XMLSTRING As String
        Dim f As New frmEdoka_Import_TextEditor()
        f.Als_Datei = True
        Dim tr As TextReader
        Dim hasdata As Boolean = True
        tr = File.OpenText(s)
        XMLSTRING = tr.ReadToEnd
        f.xmlstring = XMLSTRING
        tr.Close()
        f.Als_Datei = True
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            If save_xmlstring_journal(Me.GrdJournale.Columns(0).Value, conn_journale, s, f.xmlstring) = False Then
                MsgBox("Die Indexdaten konnten nicht gespeichert werden.", MsgBoxStyle.Exclamation)
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.MenuItem2_Click_1 Method

Private Sub MenuItem2_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_set_reimport"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@eintrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.GrdJournale.Columns(0).Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_import_update_xml::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.MnuDokanzeige_Click Method

Private Sub MnuDokanzeige_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokanzeige.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokanzeige_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokanzeige.Click
        Dim conn_journale As String
        conn_journale = get_journale_connection()
        Dim s As String
        s = Get_Doc(Me.GrdJournaldetail.Columns(1).Value, conn_journale)
        If s = "" Then
            MsgBox("Die Datei konnte nicht gespeichert werden.")
        Else
            MsgBox("Datei gespeichert als : " + s)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.MnuReimport_Click Method

Private Sub MnuReimport_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuReimport.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuReimport_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuReimport.Click
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_set_reimport"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@eintrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.GrdJournaldetail.Columns(1).Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_import_update_xml::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                Load_Data()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.Update_Details Method

Private Sub Update_Details()

Source code

[Visual Basic]
    Private Sub Update_Details()
        get_Journaldata()
        Me.GrdJournaldetail.DataSource = Nothing
        Me.GrdJournaldetail.DataMember = Nothing
        Dim dt As DataTable
        dt = get_Journaldata()
        Me.GrdJournaldetail.DataSource = dt
        Me.GrdJournaldetail.DataMember = dt.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.GrdJournaldetail, dt, "Import_Journaldetail")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.frmEDOKA_Import_Load Method

Private Sub frmEDOKA_Import_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmEDOKA_Import_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.get_Journaldata Method

Private Function get_Journaldata() As DataTable

Source code

[Visual Basic]
    Private Function get_Journaldata() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_journaldata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Journalid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.GrdJournale.Columns(0).Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_import_get_journale::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.get_Journale Method

Private Function get_Journale() As DataTable

Source code

[Visual Basic]
    Private Function get_Journale() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_journale"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_import_get_journale::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.get_journale_connection Method

Private Function get_journale_connection() As String

Source code

[Visual Basic]
    Private Function get_journale_connection() As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_journale_connection"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection

        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@connstring", SqlDbType.VarChar, 1024, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@connstring").Value
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_get_journale_connection::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.mnuIndexMutation_Click Method

Private Sub mnuIndexMutation_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuIndexMutation.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuIndexMutation_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuIndexMutation.Click
        Dim f As New frmEdoka_Import_TextEditor()
        f.Als_Datei = False
        f.xmlstring = Me.GrdJournaldetail.Columns("xml").Value
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            save_xmlstring(Me.GrdJournaldetail.Columns(1).Value, f.xmlstring)
            Me.GrdJournaldetail.Columns("xml").Value = f.xmlstring
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.popupjournaldetails_Popup Method

Private Sub popupjournaldetails_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles popupjournaldetails.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub popupjournaldetails_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles popupjournaldetails.Popup
        If Me.GrdJournaldetail.Columns("xml").Value = "" Then
            Me.mnuIndexMutation.Enabled = False
            Me.MnuReimport.Enabled = False
            Me.MnuDokanzeige.Enabled = False
        Else
            Me.mnuIndexMutation.Enabled = True
            Me.MnuReimport.Enabled = True
            Me.MnuDokanzeige.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.save_xmlstring Method

Private Function save_xmlstring( _
   ByVal eintrag As Integer, _
   ByVal xmlstring As String _
) As DataTable

Parameters

eintrag
Required.
xmlstring
Required.

Source code

[Visual Basic]
    Private Function save_xmlstring(ByVal eintrag As Integer, ByVal xmlstring As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edoka_import_update_xml"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@eintrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, eintrag))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@xmlstring", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xmlstring))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("sp_edoka_import_update_xml::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import.save_xmlstring_journal Method

Private Function save_xmlstring_journal( _
   ByVal itemid As Integer, _
   ByVal connectionstring As String, _
   ByVal filename As String, _
   ByVal xml As String _
) As Boolean

Parameters

itemid
Required.
connectionstring
Required.
filename
Required.
xml
Required.

Source code

[Visual Basic]
    Private Function save_xmlstring_journal(ByVal itemid As Integer, ByVal connectionstring As String, ByVal filename As String, ByVal xml As String) As Boolean
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From import_job where import_jobnr=" + LTrim(Str(itemid)), connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()

        FileOpen(11, filename, OpenMode.Output)
        Print(11, xml)
        FileClose(11)
        Dim fs As New FileStream(filename, FileMode.Open, FileAccess.Read)
        Dim mydata(fs.Length) As Byte
        fs.Read(mydata, 0, fs.Length)
        fs.Close()

        Try
            connection.ConnectionString = connectionstring
            connection.Open()
            da.Fill(ds, "docs")

            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            myRow.Item(7) = mydata
            da.Update(ds, "docs")
            Return True
        Catch ex As Exception
            Return False
        Finally
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEDOKA_Import Fields

frmEDOKA_Import overview

Fields

field ContextMenu1
field GrdJournaldetail
field GrdJournale
field GrpJournalDetail
field GrpJournale
field ImageList1
field MenuItem1
field MenuItem2
field MenuItem3
field MnuDokanzeige
field MnuReimport
field SaveFileDialog1
field Splitter1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field journaldaten
field journaldetails
field mnuIndexMutation
field mnuindexdaten
field popupjournaldetails

See Also

frmEDOKA_Import Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


GrdJournaldetail Variable

Friend WithEvents GrdJournaldetail As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents GrdJournaldetail As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


GrdJournale Variable

Friend WithEvents GrdJournale As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents GrdJournale As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


GrpJournalDetail Variable

Friend WithEvents GrpJournalDetail As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpJournalDetail As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


GrpJournale Variable

Friend WithEvents GrpJournale As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpJournale As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


MnuDokanzeige Variable

Friend WithEvents MnuDokanzeige As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokanzeige As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


MnuReimport Variable

Friend WithEvents MnuReimport As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuReimport As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


SaveFileDialog1 Variable

Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Source code

[Visual Basic]
    Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


journaldaten Variable

Dim journaldaten As New DataTable()

Source code

[Visual Basic]
    Dim journaldaten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


journaldetails Variable

Dim journaldetails As New DataTable()

Source code

[Visual Basic]
    Dim journaldetails As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


mnuIndexMutation Variable

Friend WithEvents mnuIndexMutation As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuIndexMutation As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


mnuindexdaten Variable

Friend WithEvents mnuindexdaten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuindexdaten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


popupjournaldetails Variable

Friend WithEvents popupjournaldetails As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents popupjournaldetails As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEDOKA_Import


frmEdokaAdresse Class

For a list of all members of this type, see frmEdokaAdresse Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmEdokaAdresse

Public Class frmEdokaAdresse
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmEdokaAdresse Members


frmEdokaAdresse Members

frmEdokaAdresse overview

Constructors

constructor frmEdokaAdresse Constructor

Properties

property Partnernr

Methods

method Dispose
method InitializeComponent
method btnCancel_Click
method btnSave_Click
method frmEdokaAdresse_Load

Fields

field GroupBox1
field Label10
field Label11
field Label5
field Label6
field Label7
field Label8
field Label9
field btnCancel
field btnSave
field components
field m_partnernr
field txtAdresse1
field txtAdresse2
field txtAdresse3
field txtAdresse4
field txtAdresse5
field txtAdresse6
field txtAdresse7

See Also

frmEdokaAdresse Class


frmEdokaAdresse Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse Properties

frmEdokaAdresse overview

Properties

property Partnernr

See Also

frmEdokaAdresse Class


frmEdokaAdresse.Partnernr Property

Property Partnernr() As Long

Source code

[Visual Basic]
    Property Partnernr() As Long
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Long)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse Methods

frmEdokaAdresse overview

Methods

method Dispose
method InitializeComponent
method btnCancel_Click
method btnSave_Click
method frmEdokaAdresse_Load

See Also

frmEdokaAdresse Class


frmEdokaAdresse.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmEdokaAdresse))
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.txtAdresse7 = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.txtAdresse6 = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtAdresse5 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.txtAdresse4 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.txtAdresse3 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.txtAdresse2 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.txtAdresse1 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.btnSave = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtAdresse7, Me.Label11, Me.txtAdresse6, Me.Label10, Me.txtAdresse5, Me.Label9, Me.txtAdresse4, Me.Label8, Me.txtAdresse3, Me.Label7, Me.txtAdresse2, Me.Label6, Me.txtAdresse1, Me.Label5})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(344, 192)
        Me.GroupBox1.TabIndex = 9
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "EDOKA-interne Adresse"
        '
        'txtAdresse7
        '
        Me.txtAdresse7.Location = New System.Drawing.Point(120, 160)
        Me.txtAdresse7.Name = "txtAdresse7"
        Me.txtAdresse7.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse7.TabIndex = 35
        Me.txtAdresse7.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(16, 160)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(96, 23)
        Me.Label11.TabIndex = 34
        Me.Label11.Text = "Zeile 7"
        '
        'txtAdresse6
        '
        Me.txtAdresse6.Location = New System.Drawing.Point(120, 136)
        Me.txtAdresse6.Name = "txtAdresse6"
        Me.txtAdresse6.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse6.TabIndex = 33
        Me.txtAdresse6.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(16, 136)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(96, 23)
        Me.Label10.TabIndex = 32
        Me.Label10.Text = "Zeile 6"
        '
        'txtAdresse5
        '
        Me.txtAdresse5.Location = New System.Drawing.Point(120, 112)
        Me.txtAdresse5.Name = "txtAdresse5"
        Me.txtAdresse5.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse5.TabIndex = 31
        Me.txtAdresse5.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(16, 112)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(96, 23)
        Me.Label9.TabIndex = 30
        Me.Label9.Text = "Zeile 5"
        '
        'txtAdresse4
        '
        Me.txtAdresse4.Location = New System.Drawing.Point(120, 88)
        Me.txtAdresse4.Name = "txtAdresse4"
        Me.txtAdresse4.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse4.TabIndex = 29
        Me.txtAdresse4.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(16, 88)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(96, 23)
        Me.Label8.TabIndex = 28
        Me.Label8.Text = "Zeile 4"
        '
        'txtAdresse3
        '
        Me.txtAdresse3.Location = New System.Drawing.Point(120, 64)
        Me.txtAdresse3.Name = "txtAdresse3"
        Me.txtAdresse3.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse3.TabIndex = 27
        Me.txtAdresse3.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(16, 64)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(96, 23)
        Me.Label7.TabIndex = 26
        Me.Label7.Text = "Zeile 3"
        '
        'txtAdresse2
        '
        Me.txtAdresse2.Location = New System.Drawing.Point(120, 40)
        Me.txtAdresse2.Name = "txtAdresse2"
        Me.txtAdresse2.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse2.TabIndex = 25
        Me.txtAdresse2.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(16, 40)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(96, 23)
        Me.Label6.TabIndex = 24
        Me.Label6.Text = "Zeile 2"
        '
        'txtAdresse1
        '
        Me.txtAdresse1.Location = New System.Drawing.Point(120, 16)
        Me.txtAdresse1.Name = "txtAdresse1"
        Me.txtAdresse1.Size = New System.Drawing.Size(216, 20)
        Me.txtAdresse1.TabIndex = 23
        Me.txtAdresse1.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(16, 16)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(96, 23)
        Me.Label5.TabIndex = 22
        Me.Label5.Text = "Zeile 1"
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(8, 216)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.TabIndex = 10
        Me.btnSave.Text = "&Sichern"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(272, 216)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.TabIndex = 11
        Me.btnCancel.Text = "&Abbruch"
        '
        'frmEdokaAdresse
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(352, 245)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnCancel, Me.btnSave, Me.GroupBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmEdokaAdresse"
        Me.Text = "EDOKA-Adresse"
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse.btnSave_Click Method

Private Sub btnSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        Dim partner As New edokadb.clsEdoka_adressen()
        Dim adrdata As DataTable
        partner.cpMainConnectionProvider = conn
        conn.OpenConnection()
        partner.iNrpar00 = New SqlInt32(CType(Me.Partnernr, Int32))
        adrdata = partner.SelectOne()
        If adrdata.Rows.Count = 0 Then
            partner.iNrpar00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.sAdresszeile1 = New SqlString(CType(Me.txtAdresse1.Text, String))
            partner.sAdresszeile2 = New SqlString(CType(Me.txtAdresse2.Text, String))
            partner.sAdresszeile3 = New SqlString(CType(Me.txtAdresse3.Text, String))
            partner.sAdresszeile4 = New SqlString(CType(Me.txtAdresse4.Text, String))
            partner.sAdresszeile5 = New SqlString(CType(Me.txtAdresse5.Text, String))
            partner.sAdresszeile6 = New SqlString(CType(Me.txtAdresse6.Text, String))
            partner.sAdresszeile7 = New SqlString(CType(Me.txtAdresse7.Text, String))
            partner.Insert()
        Else
            partner.iNrpar00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.sAdresszeile1 = New SqlString(CType(Me.txtAdresse1.Text, String))
            partner.sAdresszeile2 = New SqlString(CType(Me.txtAdresse2.Text, String))
            partner.sAdresszeile3 = New SqlString(CType(Me.txtAdresse3.Text, String))
            partner.sAdresszeile4 = New SqlString(CType(Me.txtAdresse4.Text, String))
            partner.sAdresszeile5 = New SqlString(CType(Me.txtAdresse5.Text, String))
            partner.sAdresszeile6 = New SqlString(CType(Me.txtAdresse6.Text, String))
            partner.sAdresszeile7 = New SqlString(CType(Me.txtAdresse7.Text, String))
            partner.Update()
        End If
        conn.CloseConnection(True)
        adrdata.Dispose()
        partner.Dispose()
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse.frmEdokaAdresse_Load Method

Private Sub frmEdokaAdresse_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmEdokaAdresse_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim partner As New edokadb.clsEdoka_adressen()
        Dim adrdata As DataTable
        partner.cpMainConnectionProvider = conn
        partner.iNrpar00 = New SqlInt32(CType(Me.Partnernr, Int32))
        adrdata = partner.SelectOne
        If adrdata.Rows.Count > 0 Then
            Me.txtAdresse1.Text = adrdata.Rows(0).Item("Adresszeile1")
            Me.txtAdresse2.Text = adrdata.Rows(0).Item("Adresszeile2")
            Me.txtAdresse3.Text = adrdata.Rows(0).Item("Adresszeile3")
            Me.txtAdresse4.Text = adrdata.Rows(0).Item("Adresszeile4")
            Me.txtAdresse5.Text = adrdata.Rows(0).Item("Adresszeile5")
            Me.txtAdresse6.Text = adrdata.Rows(0).Item("Adresszeile6")
            Me.txtAdresse7.Text = adrdata.Rows(0).Item("Adresszeile7")
        End If
        partner.Dispose()
        adrdata.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdokaAdresse Fields

frmEdokaAdresse overview

Fields

field GroupBox1
field Label10
field Label11
field Label5
field Label6
field Label7
field Label8
field Label9
field btnCancel
field btnSave
field components
field m_partnernr
field txtAdresse1
field txtAdresse2
field txtAdresse3
field txtAdresse4
field txtAdresse5
field txtAdresse6
field txtAdresse7

See Also

frmEdokaAdresse Class


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


m_partnernr Variable

Dim m_partnernr As Long

Source code

[Visual Basic]
    Dim m_partnernr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse1 Variable

Friend WithEvents txtAdresse1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse2 Variable

Friend WithEvents txtAdresse2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse3 Variable

Friend WithEvents txtAdresse3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse4 Variable

Friend WithEvents txtAdresse4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse5 Variable

Friend WithEvents txtAdresse5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse6 Variable

Friend WithEvents txtAdresse6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


txtAdresse7 Variable

Friend WithEvents txtAdresse7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAdresse7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdokaAdresse


frmEdoka_Import_TextEditor Class

For a list of all members of this type, see frmEdoka_Import_TextEditor Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmEdoka_Import_TextEditor

Public Class frmEdoka_Import_TextEditor
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmEdoka_Import_TextEditor Members


frmEdoka_Import_TextEditor Members

frmEdoka_Import_TextEditor overview

Constructors

constructor frmEdoka_Import_TextEditor Constructor

Properties

property Als_Datei
property Saved
property xmlstring

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmEdoka_Import_TextEditor_Load

Fields

field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field ds
field m_inputfile
field m_saved
field m_xmlstring
field s
field tmpxmlfile
field txtxml

See Also

frmEdoka_Import_TextEditor Class


frmEdoka_Import_TextEditor Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor Properties

frmEdoka_Import_TextEditor overview

Properties

property Als_Datei
property Saved
property xmlstring

See Also

frmEdoka_Import_TextEditor Class


frmEdoka_Import_TextEditor.Als_Datei Property

Property Als_Datei() As Boolean

Source code

[Visual Basic]
    Property Als_Datei() As Boolean
        Get
            Return m_inputfile
        End Get
        Set(ByVal Value As Boolean)
            m_inputfile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor.Saved Property

Property Saved() As Boolean

Source code

[Visual Basic]
    Property Saved() As Boolean
        Get
            Return m_saved
        End Get
        Set(ByVal Value As Boolean)
            m_saved = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor.xmlstring Property

Property xmlstring() As String

Source code

[Visual Basic]
    Property xmlstring() As String
        Get
            Return m_xmlstring
        End Get
        Set(ByVal Value As String)
            m_xmlstring = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor Methods

frmEdoka_Import_TextEditor overview

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmEdoka_Import_TextEditor_Load

See Also

frmEdoka_Import_TextEditor Class


frmEdoka_Import_TextEditor.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmEdoka_Import_TextEditor))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.txtxml = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(752, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'txtxml
        '
        Me.txtxml.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtxml.Location = New System.Drawing.Point(0, 25)
        Me.txtxml.Multiline = True
        Me.txtxml.Name = "txtxml"
        Me.txtxml.Size = New System.Drawing.Size(752, 596)
        Me.txtxml.TabIndex = 1
        Me.txtxml.Text = ""
        '
        'frmEdoka_Import_TextEditor
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(752, 621)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtxml, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmEdoka_Import_TextEditor"
        Me.ShowInTaskbar = False
        Me.Text = "XML-Indexdaten-Editor"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
                Me.DialogResult = DialogResult.Abort
                Me.Close()
            Case 1
                Dim i As Integer
                Me.Saved = True
                Me.xmlstring = Me.txtxml.Text
                Me.DialogResult = DialogResult.OK
                Me.Close()
            Case Else

        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor.frmEdoka_Import_TextEditor_Load Method

Private Sub frmEdoka_Import_TextEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmEdoka_Import_TextEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.txtxml.Text = ""
        tmpxmlfile = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "tmpxml.xml"
        FileOpen(1, tmpxmlfile, OpenMode.Output)
        PrintLine(1, Me.xmlstring)
        FileClose(1)
        If Als_Datei Then
            Dim tr As TextReader
            tr = File.OpenText(tmpxmlfile)
            Me.txtxml.AppendText(tr.ReadToEnd)
            tr.Close()
        Else
            ds.ReadXml(tmpxmlfile)
            ds.WriteXml(tmpxmlfile)
            Dim sReader As StreamReader = New StreamReader(tmpxmlfile)
            Me.txtxml.AppendText(sReader.ReadToEnd)
            Try
                sReader.Close()
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmEdoka_Import_TextEditor Fields

frmEdoka_Import_TextEditor overview

Fields

field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field ds
field m_inputfile
field m_saved
field m_xmlstring
field s
field tmpxmlfile
field txtxml

See Also

frmEdoka_Import_TextEditor Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


ds Variable

Dim ds As New DataSet()

Source code

[Visual Basic]
    Dim ds As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


m_inputfile Variable

Dim m_inputfile As Boolean = False

Source code

[Visual Basic]
    Dim m_inputfile As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


m_saved Variable

Dim m_saved As Boolean = False

Source code

[Visual Basic]
    Dim m_saved As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


m_xmlstring Variable

Dim m_xmlstring As String

Source code

[Visual Basic]
    Dim m_xmlstring As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


s Variable

Dim s As String

Source code

[Visual Basic]
    Dim s As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


tmpxmlfile Variable

Dim tmpxmlfile As String

Source code

[Visual Basic]
    Dim tmpxmlfile As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


txtxml Variable

Friend WithEvents txtxml As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtxml As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmEdoka_Import_TextEditor


frmFAQ Class

For a list of all members of this type, see frmFAQ Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmFAQ

Public Class frmFAQ
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmFAQ Members


frmFAQ Members

frmFAQ overview

Constructors

constructor frmFAQ Constructor

Methods

method Button1_Click
method Button1_Click_1
method Dispose
method Get_Data
method InitializeComponent
method TextBox1_KeyDown
method TextBox1_Layout
method TextBox1_TextChanged
method ToolBar1_ButtonClick
method Update_List
method frmFAQ_Load

Fields

field Button1
field DokList
field ImageList1
field Label1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components

See Also

frmFAQ Class


frmFAQ Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ Methods

frmFAQ overview

Methods

method Button1_Click
method Button1_Click_1
method Dispose
method Get_Data
method InitializeComponent
method TextBox1_KeyDown
method TextBox1_Layout
method TextBox1_TextChanged
method ToolBar1_ButtonClick
method Update_List
method frmFAQ_Load

See Also

frmFAQ Class


frmFAQ.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Update_List(Me.TextBox1.Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Update_List(Me.TextBox1.Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.Get_Data Method

Private Function Get_Data( _
   ByVal searchstring As String _
) As DataTable

Parameters

searchstring
Required.

Source code

[Visual Basic]
    Private Function Get_Data(ByVal searchstring As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_faq"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, searchstring))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmFAQ))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(832, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdate = False
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(0, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(832, 484)
        Me.DokList.TabIndex = 28
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Wrap" & _
        ":True;Trimming:None;BackColor:White;}Selected{ForeColor:HighlightText;BackColor:" & _
        "Highlight;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeCol" & _
        "or:ControlText;AlignVert:Center;}Inactive{ForeColor:InactiveCaptionText;BackColo" & _
        "r:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:" & _
        "Center;}Editor{}Normal{Wrap:True;BackColor:Control;}Style27{}Style26{}HighlightR" & _
        "ow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}OddRow{Wrap:True;AlignHo" & _
        "rz:General;BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Style9{}St" & _
        "yle8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:C" & _
        "ontrolDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AllowRowSizing=""IndividualRows"" AlternatingRowStyle=""True"" Ca" & _
        "ptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles" & _
        "=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17" & _
        """ DefRecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientR" & _
        "ect>0, 0, 828, 480</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""H" & _
        "eading"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle " & _
        "parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /" & _
        "><FooterStyle parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style" & _
        "12"" /><HeadingStyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""Hi" & _
        "ghlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRow" & _
        "Style parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector""" & _
        " me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""No" & _
        "rmal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style" & _
        " parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""He" & _
        "ading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Headi" & _
        "ng"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal" & _
        """ me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal" & _
        """ me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me" & _
        "=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Capti" & _
        "on"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSpli" & _
        "ts><Layout>Modified</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 828, 480</ClientArea></Blob>"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(320, 3)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 31
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(56, 7)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 23)
        Me.Label1.TabIndex = 30
        Me.Label1.Text = "Suchen:"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(104, 3)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(214, 20)
        Me.TextBox1.TabIndex = 29
        Me.TextBox1.Text = ""
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmFAQ
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(832, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokList, Me.Button1, Me.Label1, Me.TextBox1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmFAQ"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "FAQ"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox1.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox1.KeyDown
        If e.KeyCode = Keys.Enter Then
            Update_List(Me.TextBox1.Text)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.TextBox1_Layout Method

Private Sub TextBox1_Layout( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.LayoutEventArgs _
) Handles TextBox1.Layout

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_Layout(ByVal sender As Object, ByVal e As System.Windows.Forms.LayoutEventArgs) Handles TextBox1.Layout

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.TextBox1_TextChanged Method

Private Sub TextBox1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TextBox1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TextBox1.TextChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                '2003-12-02 - Druck FAQ - S. Hutter
                Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
                Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

                With DokList.PrintInfo
                    .PageHeaderStyle.Font = fontbold
                    .PageSettings.Margins.Bottom = 20
                    .PageSettings.Margins.Top = 80
                    .PageHeader = "FAQ EDOKA-Version " + Globals.Version + "/" + Globals.Versionsdatum
                    .PageSettings.Landscape = True
                    .PageFooter = "Seite \p von \P" & vbLf & " Druckdatum " & Now()
                    .ShowProgressForm = True
                    .UseGridColors = True
                    .RepeatColumnHeaders = True
                    .VarRowHeight = DokList.PrintInfo.RowHeightEnum.StretchToFit
                    .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.LikeColumn
                    .PageBreak = DokList.PrintInfo.PageBreaksEnum.FitIntoArea
                    .FillAreaWidth = DokList.PrintInfo.FillEmptyEnum.ExtendLast
                    .PrintPreview()
                End With
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.Update_List Method

Private Sub Update_List( _
   ByVal searchstring As String _
)

Parameters

searchstring
Required.

Source code

[Visual Basic]
    Private Sub Update_List(ByVal searchstring As String)
        Dim d As DataTable
        Dim i As Integer
        d = Get_Data(searchstring)
        Me.DokList.DataSource = d
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, d, "faq")
        For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
            Me.DokList.Splits(0).Rows(i).AutoSize()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ.frmFAQ_Load Method

Private Sub frmFAQ_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmFAQ_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Update_List("")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFAQ Fields

frmFAQ overview

Fields

field Button1
field DokList
field ImageList1
field Label1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components

See Also

frmFAQ Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFAQ


frmFavoritenZuordnung Class

For a list of all members of this type, see frmFavoritenZuordnung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmFavoritenZuordnung

Public Class frmFavoritenZuordnung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmFavoritenZuordnung Members


frmFavoritenZuordnung Members

frmFavoritenZuordnung overview

Constructors

constructor frmFavoritenZuordnung Constructor

Properties

property Dokumenttypnr

Methods

method AlreadyExists
method Dispose
method InitializeComponent
method Load_Struktur
method btnAbbruch_Click
method btnNeuerOrdner_Click
method btnOk_Click
method frmFavoritenZuordnung_Load

Fields

field ImageList1
field Label1
field Label2
field Label3
field PictureBox1
field TextBox1
field TreeView1
field btnAbbruch
field btnNeuerOrdner
field btnOk
field components
field m_dokumenttypnr

See Also

frmFavoritenZuordnung Class


frmFavoritenZuordnung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung Properties

frmFavoritenZuordnung overview

Properties

property Dokumenttypnr

See Also

frmFavoritenZuordnung Class


frmFavoritenZuordnung.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung Methods

frmFavoritenZuordnung overview

Methods

method AlreadyExists
method Dispose
method InitializeComponent
method Load_Struktur
method btnAbbruch_Click
method btnNeuerOrdner_Click
method btnOk_Click
method frmFavoritenZuordnung_Load

See Also

frmFavoritenZuordnung Class


frmFavoritenZuordnung.AlreadyExists Method

Private Function AlreadyExists() As Boolean

Source code

[Visual Basic]
    Private Function AlreadyExists() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        AlreadyExists = False
        Try
            scmCmdToExecute.CommandText = "dbo.SP_Favorit_bereits_vorhanden"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@strukturnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TreeView1.SelectedNode.Tag))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr / 10000))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
        If dtToReturn.Rows.Count > 0 Then
            If MyMsg.Show_MessageYesNo(23) = MsgBoxResult.Yes Then
                AlreadyExists = False
            Else
                AlreadyExists = True
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmFavoritenZuordnung))
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.btnOk = New System.Windows.Forms.Button()
        Me.btnAbbruch = New System.Windows.Forms.Button()
        Me.btnNeuerOrdner = New System.Windows.Forms.Button()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.SuspendLayout()
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(8, 8)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(40, 40)
        Me.PictureBox1.TabIndex = 0
        Me.PictureBox1.TabStop = False
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(48, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(264, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Das Dokument wird zu den Favoriten hinzu gefügt"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 56)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Name:"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 80)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(64, 23)
        Me.Label3.TabIndex = 3
        Me.Label3.Text = "Erstellen in:"
        '
        'TreeView1
        '
        Me.TreeView1.ImageList = Me.ImageList1
        Me.TreeView1.Location = New System.Drawing.Point(72, 80)
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Size = New System.Drawing.Size(264, 216)
        Me.TreeView1.TabIndex = 4
        '
        'btnOk
        '
        Me.btnOk.Location = New System.Drawing.Point(344, 16)
        Me.btnOk.Name = "btnOk"
        Me.btnOk.Size = New System.Drawing.Size(88, 23)
        Me.btnOk.TabIndex = 5
        Me.btnOk.Text = "&OK"
        '
        'btnAbbruch
        '
        Me.btnAbbruch.Location = New System.Drawing.Point(344, 48)
        Me.btnAbbruch.Name = "btnAbbruch"
        Me.btnAbbruch.Size = New System.Drawing.Size(88, 23)
        Me.btnAbbruch.TabIndex = 6
        Me.btnAbbruch.Text = "&Abbrechen"
        '
        'btnNeuerOrdner
        '
        Me.btnNeuerOrdner.Location = New System.Drawing.Point(344, 80)
        Me.btnNeuerOrdner.Name = "btnNeuerOrdner"
        Me.btnNeuerOrdner.Size = New System.Drawing.Size(88, 23)
        Me.btnNeuerOrdner.TabIndex = 7
        Me.btnNeuerOrdner.Text = "&Neuer Ordner"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(72, 56)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(264, 20)
        Me.TextBox1.TabIndex = 8
        Me.TextBox1.Text = "TextBox1"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmFavoritenZuordnung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(440, 317)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox1, Me.btnNeuerOrdner, Me.btnAbbruch, Me.btnOk, Me.TreeView1, Me.Label3, Me.Label2, Me.Label1, Me.PictureBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmFavoritenZuordnung"
        Me.Text = "Zu Favoriten Hinzufügen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.Load_Struktur Method

Private Sub Load_Struktur()

Source code

[Visual Basic]
    Private Sub Load_Struktur()
        Dim struktur As New edokadb.clsMyDokumentart()
        struktur.Load_FavoritenStruktur(Me.TreeView1, "", True)
        struktur.Dispose()
        Me.TreeView1.ExpandAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.btnAbbruch_Click Method

Private Sub btnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.btnNeuerOrdner_Click Method

Private Sub btnNeuerOrdner_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnNeuerOrdner.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnNeuerOrdner_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnNeuerOrdner.Click
        Dim a As String
        Dim b As Integer
        a = InputBox("Neuer Ordnername", "Neuer Favoritenordner hinzufügen")
        If a = "" Then Exit Sub
        Dim fs As New edokadb.clsDokumentfavoriten_struktur()
        fs.cpMainConnectionProvider = conn
        fs.sBezeichnung = New SqlString(CType(a, String))
        fs.bAktiv = New SqlBoolean(CType(True, Boolean))
        fs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        fs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        fs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        fs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iParentid = New SqlInt32(CType(Me.TreeView1.SelectedNode.Tag, Int32))
        fs.iSort = New SqlInt32(CType(0, Int32))
        fs.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        fs.iImageindex = New SqlInt32(CType(2, Int32))
        fs.iImageindexopen = New SqlInt32(CType(2, Int32))
        conn.OpenConnection()
        Try
            fs.Insert()
            b = fs.iDokumentfavoritennr.Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            fs.Dispose()
        End Try
        Me.TreeView1.BeginUpdate()
        Load_Struktur()
        Me.TreeView1.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.btnOk_Click Method

Private Sub btnOk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnOk.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnOk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnOk.Click
        Try
            Dim i As Integer
            i = Me.TreeView1.SelectedNode.Tag
        Catch
            MyMsg.show_standardmessage(97, MsgBoxStyle.Critical)
            Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
            Exit Sub
        End Try
        If AlreadyExists() Then Exit Sub
        Dim pf As New edokadb.clsDokumentfavoriten()
        pf.cpMainConnectionProvider = conn
        conn.OpenConnection()
        pf.iDokumentfavoritenstrukturnr = New SqlInt32(CType(Me.TreeView1.SelectedNode.Tag, Int32))
        pf.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        pf.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        pf.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        pf.bAktiv = New SqlBoolean(CType(True, Boolean))
        pf.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr / 10000, Int32))
        pf.Insert()
        conn.CloseConnection(True)
        pf.Dispose()
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung.frmFavoritenZuordnung_Load Method

Private Sub frmFavoritenZuordnung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmFavoritenZuordnung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        load_struktur()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFavoritenZuordnung Fields

frmFavoritenZuordnung overview

Fields

field ImageList1
field Label1
field Label2
field Label3
field PictureBox1
field TextBox1
field TreeView1
field btnAbbruch
field btnNeuerOrdner
field btnOk
field components
field m_dokumenttypnr

See Also

frmFavoritenZuordnung Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


btnAbbruch Variable

Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


btnNeuerOrdner Variable

Friend WithEvents btnNeuerOrdner As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnNeuerOrdner As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


btnOk Variable

Friend WithEvents btnOk As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnOk As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFavoritenZuordnung


frmFunktionsgruppeRolle Class

For a list of all members of this type, see frmFunktionsgruppeRolle Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmFunktionsgruppeRolle

Public Class frmFunktionsgruppeRolle
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmFunktionsgruppeRolle Members


frmFunktionsgruppeRolle Members

frmFunktionsgruppeRolle overview

Constructors

constructor frmFunktionsgruppeRolle Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmFunktionsgruppeRolle Class


frmFunktionsgruppeRolle Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle Properties

frmFunktionsgruppeRolle overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmFunktionsgruppeRolle Class


frmFunktionsgruppeRolle Methods

frmFunktionsgruppeRolle overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmFunktionsgruppeRolle Class


frmFunktionsgruppeRolle.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_funktionsgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_funktionsgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_funktionsgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe_rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("Funktionsgrupperollenr", "Funktionsgrupperollenr"), New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_funktionsgruppe_rolle_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_funktionsgruppe_rolle_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Funktionsgrupperollenr", System.Data.SqlDbType.Int, 4, "Funktionsgrupperollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_funktionsgruppe_rolle_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Funktionsgrupperollenr", System.Data.SqlDbType.Int, 4, "Funktionsgrupperollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Funktionsgrupperollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Funktionsgrupperollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_funktionsgruppe_rolle_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Funktionsgrupperollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Funktionsgrupperollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmFunktionsgruppeRolle
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(648, 497)
        Me.Name = "frmFunktionsgruppeRolle"
        Me.Text = "frmFunktionsgruppeRolle"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsFunktionsgruppe_rolle()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("funktionsgruppe_rolle")
            vdata.iFunktionsgrupperollenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5035, 5036, 5037)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "funktionsgruppe"
        Me.TableNameRight = "rolle"
        Me.TableNameBottom = "funktionsgruppe_rolle"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmFunktionsgruppeRolle Fields

frmFunktionsgruppeRolle overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmFunktionsgruppeRolle Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmFunktionsgruppeRolle


frmGeburtstag Class

For a list of all members of this type, see frmGeburtstag Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmGeburtstag

Public Class frmGeburtstag
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmGeburtstag Members


frmGeburtstag Members

frmGeburtstag overview

Constructors

constructor frmGeburtstag Constructor

Methods

method Dispose
method InitializeComponent
method btnClose_Click
method frmGeburtstag_Load

Fields

field GroupBox1
field PictureBox1
field btnClose
field components
field lblGeburtstagsText

See Also

frmGeburtstag Class


frmGeburtstag Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmGeburtstag Methods

frmGeburtstag overview

Methods

method Dispose
method InitializeComponent
method btnClose_Click
method frmGeburtstag_Load

See Also

frmGeburtstag Class


frmGeburtstag.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmGeburtstag.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmGeburtstag))
        Me.btnClose = New System.Windows.Forms.Button()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.lblGeburtstagsText = New System.Windows.Forms.Label()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'btnClose
        '
        Me.btnClose.Location = New System.Drawing.Point(248, 344)
        Me.btnClose.Name = "btnClose"
        Me.btnClose.Size = New System.Drawing.Size(88, 24)
        Me.btnClose.TabIndex = 0
        Me.btnClose.Text = "Schliessen"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(328, 264)
        Me.GroupBox1.TabIndex = 3
        Me.GroupBox1.TabStop = False
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(12, 32)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(304, 200)
        Me.PictureBox1.TabIndex = 3
        Me.PictureBox1.TabStop = False
        '
        'lblGeburtstagsText
        '
        Me.lblGeburtstagsText.Font = New System.Drawing.Font("Microsoft Sans Serif", 10.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblGeburtstagsText.Location = New System.Drawing.Point(16, 296)
        Me.lblGeburtstagsText.Name = "lblGeburtstagsText"
        Me.lblGeburtstagsText.Size = New System.Drawing.Size(312, 40)
        Me.lblGeburtstagsText.TabIndex = 5
        Me.lblGeburtstagsText.Text = "Herzlichen Glückwunsch"
        '
        'frmGeburtstag
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(344, 373)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblGeburtstagsText, Me.GroupBox1, Me.btnClose})
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmGeburtstag"
        Me.Text = "Herzlichen Glückwunsch"
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmGeburtstag.btnClose_Click Method

Private Sub btnClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmGeburtstag.frmGeburtstag_Load Method

Private Sub frmGeburtstag_Load( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmGeburtstag_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
        lblGeburtstagsText.Text = MyMsg.Get_Meldungstext(270)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmGeburtstag Fields

frmGeburtstag overview

Fields

field GroupBox1
field PictureBox1
field btnClose
field components
field lblGeburtstagsText

See Also

frmGeburtstag Class


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


lblGeburtstagsText Variable

Friend WithEvents lblGeburtstagsText As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblGeburtstagsText As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmGeburtstag


frmHinweismeldung Class

For a list of all members of this type, see frmHinweismeldung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmHinweismeldung

Public Class frmHinweismeldung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmHinweismeldung Members


frmHinweismeldung Members

frmHinweismeldung overview

Constructors

constructor frmHinweismeldung Constructor

Properties

property MsgBoxStyle

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

Fields

field Button1
field Button2
field Button3
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field components
field m_style

See Also

frmHinweismeldung Class


frmHinweismeldung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung Properties

frmHinweismeldung overview

Properties

property MsgBoxStyle

See Also

frmHinweismeldung Class


frmHinweismeldung.MsgBoxStyle Property

Property MsgBoxStyle() As Integer

Source code

[Visual Basic]
    Property MsgBoxStyle() As Integer
        Get
            Return m_style
        End Get
        Set(ByVal Value As Integer)
            m_style = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung Methods

frmHinweismeldung overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

See Also

frmHinweismeldung Class


frmHinweismeldung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmHinweismeldung))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(64, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(384, 112)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Label1"
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(64, 136)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(208, 24)
        Me.CheckBox1.TabIndex = 1
        Me.CheckBox1.Text = "Diese Meldung nicht mehr anzeigen"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(376, 136)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(16, 8)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(48, 48)
        Me.PictureBox1.TabIndex = 3
        Me.PictureBox1.TabStop = False
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(296, 136)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(376, 136)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 5
        Me.Button3.Text = "&Weiter"
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(16, 8)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 6
        Me.PictureBox2.TabStop = False
        '
        'frmHinweismeldung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(458, 168)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox2, Me.Button3, Me.Button2, Me.PictureBox1, Me.Button1, Me.CheckBox1, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmHinweismeldung"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterParent
        Me.Text = "Hinweismeldung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung.frmHinweismeldung_Load Method

Private Sub frmHinweismeldung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmHinweismeldung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.PictureBox1.Visible = False
        Me.PictureBox2.Visible = False
        Me.Button1.Visible = False
        Me.Button2.Visible = False
        Me.Button3.Visible = False
        Select Case Me.MsgBoxStyle
            Case 1
                Me.Button1.Visible = True
                Me.PictureBox1.Visible = True
            Case 2
                Me.Button2.Visible = True
                Me.Button3.Visible = True
                Me.PictureBox2.Visible = True
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung Fields

frmHinweismeldung overview

Fields

field Button1
field Button2
field Button3
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field components
field m_style

See Also

frmHinweismeldung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


m_style Variable

Dim m_style As Integer

Source code

[Visual Basic]
    Dim m_style As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung


frmHinweismeldung1 Class

For a list of all members of this type, see frmHinweismeldung1 Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmHinweismeldung1

Public Class frmHinweismeldung1
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmHinweismeldung1 Members


frmHinweismeldung1 Members

frmHinweismeldung1 overview

Constructors

constructor frmHinweismeldung1 Constructor

Properties

property MsgBoxStyle

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

Fields

field Button1
field Button2
field Button3
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field PictureBox3
field components
field m_style

See Also

frmHinweismeldung1 Class


frmHinweismeldung1 Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1 Properties

frmHinweismeldung1 overview

Properties

property MsgBoxStyle

See Also

frmHinweismeldung1 Class


frmHinweismeldung1.MsgBoxStyle Property

Property MsgBoxStyle() As Integer

Source code

[Visual Basic]
    Property MsgBoxStyle() As Integer
        Get
            Return m_style
        End Get
        Set(ByVal Value As Integer)
            m_style = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1 Methods

frmHinweismeldung1 overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

See Also

frmHinweismeldung1 Class


frmHinweismeldung1.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmHinweismeldung1))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.PictureBox3 = New System.Windows.Forms.PictureBox()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(64, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(512, 168)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Label1"
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(64, 176)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(208, 24)
        Me.CheckBox1.TabIndex = 1
        Me.CheckBox1.Text = "Diese Meldung nicht mehr anzeigen"
        Me.CheckBox1.Visible = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(496, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(0, 104)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(48, 48)
        Me.PictureBox1.TabIndex = 3
        Me.PictureBox1.TabStop = False
        Me.PictureBox1.Visible = False
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(416, 176)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(496, 176)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 5
        Me.Button3.Text = "&Weiter"
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(16, 136)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 6
        Me.PictureBox2.TabStop = False
        Me.PictureBox2.Visible = False
        '
        'PictureBox3
        '
        Me.PictureBox3.Image = CType(resources.GetObject("PictureBox3.Image"), System.Drawing.Bitmap)
        Me.PictureBox3.Location = New System.Drawing.Point(8, 8)
        Me.PictureBox3.Name = "PictureBox3"
        Me.PictureBox3.Size = New System.Drawing.Size(48, 56)
        Me.PictureBox3.TabIndex = 7
        Me.PictureBox3.TabStop = False
        '
        'frmHinweismeldung1
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(578, 208)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox3, Me.PictureBox2, Me.Button3, Me.Button2, Me.PictureBox1, Me.Button1, Me.CheckBox1, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmHinweismeldung1"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Hinweismeldung"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1.frmHinweismeldung_Load Method

Private Sub frmHinweismeldung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmHinweismeldung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.PictureBox1.Visible = False
        Me.PictureBox2.Visible = False
        Me.Button1.Visible = False
        Me.Button2.Visible = False
        Me.Button3.Visible = False
        Select Case Me.MsgBoxStyle
            Case 1
                Me.Button1.Visible = True
                '        Me.PictureBox1.Visible = True
            Case 2
                Me.Button2.Visible = True
                Me.Button3.Visible = True
                '       Me.PictureBox2.Visible = True
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung1 Fields

frmHinweismeldung1 overview

Fields

field Button1
field Button2
field Button3
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field PictureBox3
field components
field m_style

See Also

frmHinweismeldung1 Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


PictureBox3 Variable

Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


m_style Variable

Dim m_style As Integer

Source code

[Visual Basic]
    Dim m_style As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung1


frmHinweismeldung2 Class

For a list of all members of this type, see frmHinweismeldung2 Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmHinweismeldung2

Public Class frmHinweismeldung2
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmHinweismeldung2 Members


frmHinweismeldung2 Members

frmHinweismeldung2 overview

Constructors

constructor frmHinweismeldung2 Constructor

Properties

property MsgBoxStyle
property dokumentid

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

Fields

field Button1
field Button2
field Button3
field Button4
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field PictureBox3
field components
field m_dokumentid
field m_style

See Also

frmHinweismeldung2 Class


frmHinweismeldung2 Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2 Properties

frmHinweismeldung2 overview

Properties

property MsgBoxStyle
property dokumentid

See Also

frmHinweismeldung2 Class


frmHinweismeldung2.MsgBoxStyle Property

Property MsgBoxStyle() As Integer

Source code

[Visual Basic]
    Property MsgBoxStyle() As Integer
        Get
            Return m_style
        End Get
        Set(ByVal Value As Integer)
            m_style = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.dokumentid Property

Property dokumentid() As String

Source code

[Visual Basic]
    Property dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2 Methods

frmHinweismeldung2 overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Dispose
method InitializeComponent
method frmHinweismeldung_Load

See Also

frmHinweismeldung2 Class


frmHinweismeldung2.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Try
            Dim f As New frmSearchDoc()
            f.txtbcknr.Text = Me.dokumentid
            f.Visible = False
            f.Show()
            f.MdiParent = Me.MdiParent
            f.Show_Doc()
            f.Hide()
            Me.Close()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmHinweismeldung2))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.PictureBox3 = New System.Windows.Forms.PictureBox()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(64, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(512, 168)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Label1"
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(64, 176)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(208, 24)
        Me.CheckBox1.TabIndex = 1
        Me.CheckBox1.Text = "Diese Meldung nicht mehr anzeigen"
        Me.CheckBox1.Visible = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(496, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(0, 104)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(48, 48)
        Me.PictureBox1.TabIndex = 3
        Me.PictureBox1.TabStop = False
        Me.PictureBox1.Visible = False
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(416, 176)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(496, 176)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 5
        Me.Button3.Text = "&Weiter"
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(16, 136)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 6
        Me.PictureBox2.TabStop = False
        Me.PictureBox2.Visible = False
        '
        'PictureBox3
        '
        Me.PictureBox3.Image = CType(resources.GetObject("PictureBox3.Image"), System.Drawing.Bitmap)
        Me.PictureBox3.Location = New System.Drawing.Point(8, 8)
        Me.PictureBox3.Name = "PictureBox3"
        Me.PictureBox3.Size = New System.Drawing.Size(48, 56)
        Me.PictureBox3.TabIndex = 7
        Me.PictureBox3.TabStop = False
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(368, 176)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(120, 23)
        Me.Button4.TabIndex = 8
        Me.Button4.Text = "Dokument anzeigen"
        '
        'frmHinweismeldung2
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(578, 208)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button4, Me.PictureBox3, Me.PictureBox2, Me.Button3, Me.Button2, Me.PictureBox1, Me.Button1, Me.CheckBox1, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmHinweismeldung2"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Hinweismeldung"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2.frmHinweismeldung_Load Method

Private Sub frmHinweismeldung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmHinweismeldung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.PictureBox1.Visible = False
        Me.PictureBox2.Visible = False
        Me.Button1.Visible = False
        Me.Button2.Visible = False
        Me.Button3.Visible = False
        Select Case Me.MsgBoxStyle
            Case 1
                Me.Button1.Visible = True
                '        Me.PictureBox1.Visible = True
            Case 2
                Me.Button2.Visible = True
                Me.Button3.Visible = True
                '       Me.PictureBox2.Visible = True
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHinweismeldung2 Fields

frmHinweismeldung2 overview

Fields

field Button1
field Button2
field Button3
field Button4
field CheckBox1
field Label1
field PictureBox1
field PictureBox2
field PictureBox3
field components
field m_dokumentid
field m_style

See Also

frmHinweismeldung2 Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


PictureBox3 Variable

Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox3 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


m_style Variable

Dim m_style As Integer

Source code

[Visual Basic]
    Dim m_style As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHinweismeldung2


frmHostTransfer Class

For a list of all members of this type, see frmHostTransfer Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmHostTransfer

Public Class frmHostTransfer
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmHostTransfer Members


frmHostTransfer Members

frmHostTransfer overview

Constructors

constructor frmHostTransfer Constructor

Properties

property Nrpar00
property Nrpar00_aufbereitet

Methods

method Adresse_values
method Button1_Click
method Button2_Click
method Button3_Click
method Check_Result
method Create_Adress_Abfrage
method Create_Partner_Anfrage
method Create_VV_Abfrage
method Dispose
method GetNewKey
method Get_DBValues
method Get_Data
method Get_URL
method Get_Value
method InitializeComponent
method Parse_Adresse
method Parse_Partner
method Parse_VV
method Partner_Exists
method Update_Progress
method Write_Field
method Write_Header
method Write_State
method attrib
method frmHostTransfer_Load
method load_data
method partner_values
method read_data
method vv_values

Fields

field BKPAR00
field Button1
field Button2
field Button3
field DoInsert
field PartnerExists
field ProgressBar1
field RequestName
field Resultobject
field ResutlSetContent
field components
field da
field db
field doinsert1
field doinsert_etbez0
field doinsert_etpar0
field doinsert_etparn
field doinsert_etparu
field etbez0
field etpar0
field etparn
field etparu
field filename
field ha
field label1
field m_PartnerHatBetreuer
field m_PartnerIstNP
field m_PartnerIstUP
field m_nrpar00
field m_nrpar00_aufbereitet
field partner
field statustext
field url
field vv
field vvz
field xmlElement
field xmlNodes
field xmldoc
field xmlstring

See Also

frmHostTransfer Class


frmHostTransfer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer Properties

frmHostTransfer overview

Properties

property Nrpar00
property Nrpar00_aufbereitet

See Also

frmHostTransfer Class


frmHostTransfer.Nrpar00 Property

Property Nrpar00() As String

Source code

[Visual Basic]
    Property Nrpar00() As String
        Get
            Return m_nrpar00
        End Get
        Set(ByVal Value As String)
            m_nrpar00 = Value
            While Len(m_nrpar00) < 9
                m_nrpar00 = "0" + m_nrpar00
            End While
            Me.Nrpar00_aufbereitet = Me.Nrpar00
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Nrpar00_aufbereitet Property

Property Nrpar00_aufbereitet()

Source code

[Visual Basic]
    Property Nrpar00_aufbereitet()
        Get
            Return m_nrpar00_aufbereitet
        End Get
        Set(ByVal Value)
            m_nrpar00_aufbereitet = Microsoft.VisualBasic.Left(Value, 3) + "." + Microsoft.VisualBasic.Mid(Value, 4, 3) + "." + Microsoft.VisualBasic.Right(Value, 3)
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer Methods

frmHostTransfer overview

Methods

method Adresse_values
method Button1_Click
method Button2_Click
method Button3_Click
method Check_Result
method Create_Adress_Abfrage
method Create_Partner_Anfrage
method Create_VV_Abfrage
method Dispose
method GetNewKey
method Get_DBValues
method Get_Data
method Get_URL
method Get_Value
method InitializeComponent
method Parse_Adresse
method Parse_Partner
method Parse_VV
method Partner_Exists
method Update_Progress
method Write_Field
method Write_Header
method Write_State
method attrib
method frmHostTransfer_Load
method load_data
method partner_values
method read_data
method vv_values

See Also

frmHostTransfer Class


frmHostTransfer.Adresse_values Method

Sub Adresse_values( _
   ByVal xmlelement As Xml.XmlElement _
)

Parameters

xmlelement
Required.

Source code

[Visual Basic]
    Sub Adresse_values(ByVal xmlelement As Xml.XmlElement)
        Dim i As Integer
        Dim s As String
        Dim w As Integer
        Try
            For i = 0 To xmlelement.Attributes.Count - 2
                s = xmlelement.Attributes(i + 1).Value
                If s = "noData" Or s = "null" Then s = ""
                Select Case xmlelement.Attributes(i).Value
                    Case "vorname4"
                        ha.sBEVNM01 = New SqlString(CType(s, String))
                    Case "partnerNrVorAgi"
                    Case "agiVersandadresseZeile1"
                        partner.sTXADZ011 = New SqlString(CType(s, String))
                    Case "titelZwischengestelltNr"
                        If s = "" Then s = "0"
                        ha.siNRTTZ00 = New SqlInt16(CType(s, Int16))
                    Case "strasse"
                        ha.sBESTR00 = New SqlString(CType(s, String))
                    Case "stockwerk"
                        ha.sNRSTC00 = New SqlString(CType(s, String))
                    Case "hausNr"
                        ha.sNRHAU00 = New SqlString(CType(s, String))
                    Case "partnerNrAufbereitet"
                    Case "vorname3"
                        ha.sBEVNM01 = New SqlString(CType(s, String))
                    Case "nagiVersandadresseZeile6"
                        partner.sTXADZ062 = New SqlString(CType(s, String))
                    Case "distrikt"
                        ha.sBEDIS00 = New SqlString(CType(s, String))
                    Case "anredeNr"
                        If s = "" Then s = "0"
                        ha.siNRARD00 = New SqlInt16(CType(s, Int16))
                    Case "postleitzahl"
                        ha.sCDPLZ00 = New SqlString(CType(s, String))
                    Case "zuHdVorname"
                        ha.sBEVNMZH = New SqlString(CType(s, String))
                    Case "nachname2"
                        ha.sBENNMZ2 = New SqlString(CType(s, String))
                    Case "coText1"
                        ha.sBECOT01 = New SqlString(CType(s, String))
                    Case "zuHdKonstanteNr"
                        If s = "" Then s = "0"
                        ha.siNRZHK00 = New SqlInt16(CType(s, Int16))
                    Case "zuHdNamenszusatzNr"
                        If s = "" Then s = "0"
                        ha.siNRNZUZH = New SqlInt16(CType(s, Int16))
                    Case "coText2"
                        ha.sBECOT02 = New SqlString(CType(s, String))
                    Case "agiVersandadresseZeile7"
                        partner.sTXADZ071 = New SqlString(CType(s, String))
                    Case "vorname1"
                        ha.sBEVNM01 = New SqlString(CType(s, String))
                    Case "zuHdNachname1"
                        ha.sBENNM01 = New SqlString(CType(s, String))
                    Case "zuHdAnredeNr"
                        If s = "" Then s = "0"
                        ha.siNRARDZH = New SqlInt16(CType(s, Int16))
                    Case "briefanrede1"
                        ha.sBEBAN01 = New SqlString(CType(s, String))
                        partner.sBEBAN011 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "zuHdTitelZwischengestelltNr"
                        If s = "" Then s = "0"
                        ha.siNRTTZZH = New SqlInt16(CType(s, Int16))
                    Case "ortsNrPtt"
                        If s = "" Then s = "0"
                        ha.iCDORTPT = New SqlInt32(CType(s, Int32))
                    Case "nagiVersandadresseZeile4"
                        partner.sTXADZ042 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "zuHdNachnameTrennzeichen"
                        ha.sBETRZZH = New SqlString(CType(s, String))
                    Case "agiVersandadresseZeile6"
                        partner.sTXADZ061 = New SqlString(CType(s, String))
                    Case "nagiVersandadresseZeile1"
                        partner.sTXADZ012 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "vorname2"
                        ha.sBEVNM01 = New SqlString(CType(s, String))
                    Case "land"
                        If s = "" Then s = "0"
                        ha.siNRLND00 = New SqlInt16(CType(s, Int16))
                    Case "name3"
                        ha.sBENAM03 = New SqlString(CType(s, String))
                    Case "nachname1"
                        ha.sBENNMZ1 = New SqlString(CType(s, String))
                    Case "weiler"
                        ha.sBEWEI00 = New SqlString(CType(s, String))
                    Case "nagiVersandadresseZeile3"
                        partner.sTXADZ032 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "namenaenderungsgrundNr"
                        If s = "" Then s = "0"
                        ha.siNRNGR00 = New SqlInt16(CType(s, Int16))
                    Case "agiVersandadresseZeile4"
                        partner.sTXADZ041 = New SqlString(CType(s, String))
                    Case "briefanrede2GrammForm"
                        If s = "" Then s = "0"
                        ha.siNRFOG02 = New SqlInt16(CType(s, Int16))
                    Case "nagiVersandadresseZeile2"
                        partner.sTXADZ022 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "nagiVersandadresseZeile7"
                        partner.sTXADZ072 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "versandfaehigkeit"
                        ha.sSAVRS00 = New SqlString(CType(s, String))
                        partner.sSAVRS00 = New SqlString(CType(s, String))
                        partner.sCDVIG00 = New SqlString(CType(s, String))
                    Case "banklagerndeZustellungVorh"
                        If s = "" Then s = "0"
                        ha.siNRVAZ00 = New SqlInt16(CType(s, Int16))
                    Case "nr"
                    Case "postfach"
                        ha.sBEFCHPT = New SqlString(CType(s, String))
                    Case "nagiVersandadresseZeile5"
                        partner.sTXADZ052 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "viAdressZusatz"
                    Case "postfachNr"
                        ha.sNRFCHPT = New SqlString(CType(s, String))
                    Case "strassenNrPtt"
                    Case "nachnameTrennzeichen"
                        ha.sBETRZNN = New SqlString(CType(s, String))
                    Case "briefanrede1GrammForm"
                        If s = "" Then s = "0"
                        ha.siNRFOG01 = New SqlInt16(CType(s, Int16))
                    Case "zuHdNachname2"
                        ha.sBENNM02 = New SqlString(CType(s, String))
                    Case "unzustellbarkeitsgrundPttNr"
                        If s = "" Then s = "0"
                        ha.siNRUZG00 = New SqlInt16(CType(s, Int16))
                    Case "namenszusatzNr"
                        If s = "" Then s = "0"
                        ha.siNRNZU00 = New SqlInt16(CType(s, Int16))
                        If s = "" Then s = "0"
                    Case "status"
                        ha.sSAREC00 = New SqlString(CType(s, String))
                    Case "name1"
                        ha.sBENAM01 = New SqlString(CType(s, String))
                    Case "agiVersandadresseZeile5"
                        partner.sTXADZ051 = New SqlString(CType(s, String))
                    Case "zuHdTitelVorgestelltNr"
                        If s = "" Then s = "0"
                        ha.siNRTTV00 = New SqlInt16(CType(s, Int16))
                    Case "agiVersandadresseZeile3"
                        partner.sTXADZ031 = New SqlString(CType(s, String))
                    Case "ortszusatz"
                        ha.sBEORTZS = New SqlString(CType(s, String))
                    Case "name2"
                        ha.sBENAM02 = New SqlString(CType(s, String))
                    Case "agiVersandadresseZeile2"
                        partner.sTXADZ021 = New SqlString(CType(s, String))
                    Case "versionsNr"
                        If s = "" Then s = "0"
                        ha.siNRVRN00 = New SqlInt16(CType(s, Int16))
                    Case "briefanrede2"
                        ha.sBEBAN02 = New SqlString(CType(s, String))
                        partner.sBEBAN012 = New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Case "partnerStatus"
                        ha.sSAREC01 = New SqlString(CType(s, String))
                    Case "artNr"
                    Case "titelVorgestelltNr"
                        If s = "" Then s = "0"
                        ha.siNRTTV00 = New SqlInt16(CType(s, Int16))
                    Case "titelNachgestellt"
                        ha.sBETTN00 = New SqlString(CType(s, String))
                    Case "postort"
                        ha.sBEORTPT = New SqlString(CType(s, String))
                End Select
            Next
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim fehler As Boolean
        Dim s As String
        s = ""
        Try
            If Partner_Exists() Then
                If Me.Get_Data(2) = False Then
                    If s.Length > 0 Then s = s + vbCrLf + vbCrLf
                    s = s + "Fehler beim Übermitteln der VV-Daten"
                    Me.label1.Text = s
                    Exit Sub
                End If
            Else
                If Me.Get_Data(1) = False Then
                    If s.Length > 0 Then s = s + vbCrLf + vbCrLf
                    s = s + "Fehler beim Übermitteln der Partner-Daten"
                    Me.label1.Text = s
                    Exit Sub
                End If
                If Me.Get_Data(3) = False Then
                    If s.Length > 0 Then s = s + vbCrLf + vbCrLf
                    s = s + "Fehler beim Übermitteln der Adressdaten"
                    Me.label1.Text = s
                    Exit Sub
                End If
                If Me.Get_Data(2) = False Then
                    If s.Length > 0 Then s = s + vbCrLf + vbCrLf
                    s = s + "Fehler beim Übermitteln der VV-Daten bzw. keine VV-Daten im HOST vorhanden."
                    Me.label1.Text = s
                    Me.Button1.Visible = False
                    Me.Button2.Visible = False
                    Me.Button3.Visible = True
                    Exit Sub
                End If
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        statustext = statustext + "Allfällig vom HOST übernommenen Angaben werden im nächsten halben Tag vervollständigt."
        Me.Button1.Visible = False
        Me.Button2.Visible = False
        Me.Button3.Visible = True
        Me.Update_Progress(statustext, 100)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.DialogResult = DialogResult.OK
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Check_Result Method

Private Function Check_Result() As Boolean

Source code

[Visual Basic]
    Private Function Check_Result() As Boolean
        'xmldoc.Load("H:\vb.net\EDOKA\XMLParser\XML-Files\Me_pepe_PartnerGesamtLesenAnswer.xml")
        Dim i As Integer
        Try
            xmlNodes = xmldoc.GetElementsByTagName("is-successful-executed")
            For i = 0 To xmlNodes.Count - 1
                If UCase(xmlNodes(i).InnerText) = "TRUE" Then Return True
            Next
        Catch
            MsgBox("Ausführung gescheitert")
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Create_Adress_Abfrage Method

Public Sub Create_Adress_Abfrage()

Source code

[Visual Basic]
    Public Sub Create_Adress_Abfrage()
        Get_DBValues(3)
        Dim writer As New XmlTextWriter(filename, System.Text.Encoding.GetEncoding("ISO-8859-1"))
        Write_Header(writer, 4)
        Write_Field(writer, "partnerNr", Me.Nrpar00)
        Write_Field(writer, "nr", "1")
        Write_Field(writer, "adressform", "A")
        writer.WriteEndElement()
        writer.WriteEndElement()
        writer.Flush()
        writer.Close()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Create_Partner_Anfrage Method

Public Sub Create_Partner_Anfrage()

Source code

[Visual Basic]
    Public Sub Create_Partner_Anfrage()
        Get_DBValues(1)
        Dim writer As New XmlTextWriter(filename, System.Text.Encoding.GetEncoding("ISO-8859-1"))
        Write_Header(writer, 2)
        Write_Field(writer, "nrAufbereitet", Me.Nrpar00_aufbereitet)
        Write_Field(writer, "partnerdatenLesen", "Y")
        Write_Field(writer, "adresseLesen", "Y")
        Write_Field(writer, "segmentdatenLesen", "Y")
        Write_Field(writer, "betreuerdatenLesen", "N")
        Write_Field(writer, "linkMeldungenPruefen", "N")
        Write_Field(writer, "linkPartnerPartnerBeziehungPruefen", "N")
        Write_Field(writer, "linkWirtschaftlicheEinheitPruefen", "N")
        Write_Field(writer, "linkIdNachweisPruefen", "N")
        Write_Field(writer, "linkVersandinstruktionPruefen", "Y")
        writer.WriteEndElement()
        writer.WriteEndElement()
        writer.Flush()
        writer.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Create_VV_Abfrage Method

Public Sub Create_VV_Abfrage()

Source code

[Visual Basic]
    Public Sub Create_VV_Abfrage()
        Get_DBValues(2)
        Dim writer As New XmlTextWriter(filename, System.Text.Encoding.GetEncoding("ISO-8859-1"))
        Write_Header(writer, 3)

        Write_Field(writer, "status", "2")
        Write_Field(writer, "partnerNrAufbereitet", Me.Nrpar00_aufbereitet)

        '        Write_State(writer, "vereinbarungsSubtypNr", "null")
        '       Write_State(writer, "vereinbarungsArtNr", "null")
        Write_Field(writer, "vereinbarungsSubtypNr", "0")
        Write_Field(writer, "vereinbarungsArtNr", "0")
        Write_Field(writer, "vvNr", "null")
        writer.WriteEndElement()
        writer.WriteEndElement()
        writer.Flush()
        writer.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.GetNewKey Method

Private Function GetNewKey() As Integer

Source code

[Visual Basic]
    Private Function GetNewKey() As Integer
        GetNewKey = 0
        Dim ssql As String
        ssql = "SELECT TOP 1 NRBEZ00 + 1 AS NewRow FROM edoka_etbez0 Order By NRBEZ00 DESC"

        Dim connection As New SqlConnection()
        Dim daTemp As New SqlDataAdapter(ssql, connection)
        Dim dsTemp As New DataSet()
        Try
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            daTemp.Fill(dsTemp)
            GetNewKey = dsTemp.Tables(0).Rows(0).Item(0)

        Catch ex As Exception
            Return False
        Finally
            dsTemp = Nothing
            daTemp = Nothing
            connection.Close()
            connection = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Get_DBValues Method

Private Function Get_DBValues( _
   ByVal i As Integer _
) As String

Parameters

i
Required.

Source code

[Visual Basic]
    Private Function Get_DBValues(ByVal i As Integer) As String
        Dim db As New edokadb.clsServices()
        db.cpMainConnectionProvider = Globals.conn
        Select Case i
            Case 1
                'Parnter
                db.iNreintrag = New SqlInt32(CType(2, Int32))
            Case 2
                'VV
                db.iNreintrag = New SqlInt32(CType(3, Int32))
            Case 3
                'Aufbereitete adresse
                db.iNreintrag = New SqlInt32(CType(4, Int32))
        End Select
        db.SelectOne()
        Me.RequestName = db.sRequestName.Value
        Me.Resultobject = db.sResultObject.Value
        Me.ResutlSetContent = db.sResultsetContent.Value
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Get_Data Method

Public Function Get_Data( _
   ByVal type As Integer _
) As Boolean

Parameters

type
Required.

Source code

[Visual Basic]
    Public Function Get_Data(ByVal type As Integer) As Boolean
        Dim s As String
        Me.Update_Progress("", 0)
        Select Case type
            Case 1
                Me.Create_Partner_Anfrage()
                Me.Update_Progress("Partner-Daten übermitteln", 20)
            Case 2
                Me.Create_VV_Abfrage()
                Me.Update_Progress("VV-Daten übermitteln", 50)
            Case 3
                Me.Create_Adress_Abfrage()
                Me.Update_Progress("Adress-Daten übermitteln", 80)
            Case Else
        End Select
        read_data()
        If Check_Result() = False Then
            'MyMsg.show_standardmessage(103, MsgBoxStyle.Critical)
            Return False
            '            MsgBox("Beim Zugriff auf die HOST-Daten ist ein Fehler aufgetreten.")
            Exit Function
        End If
        Select Case type
            Case 1
                Parse_Partner()
                Me.Update_Progress("Partner-Daten speichern", 35)
                If statustext <> "" Then statustext = statustext + vbCrLf + vbCrLf
                statustext = statustext + "Die wichtigsten Partner- und Adressdaten sind in den" + vbCrLf + "EDOKA-Datenbestand übernommen worden." + vbCrLf + vbCrLf
            Case 2
                Parse_VV()
                If statustext <> "" Then statustext = statustext + vbCrLf + vbCrLf
                Me.Update_Progress("VV-Daten speichern", 75)
                statustext = statustext + "Es wurden " + LTrim(Str(vvz)) + " neue VV-Einträge gespeichert." + vbCrLf + vbCrLf
            Case 3
                Parse_Adresse()
                Me.Update_Progress("Adress-Daten speichern", 100)
        End Select
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Get_URL Method

Private Function Get_URL() As String

Source code

[Visual Basic]
    Private Function Get_URL() As String
        Dim db As New edokadb.clsServices()
        db.cpMainConnectionProvider = conn
        db.iNreintrag = New SqlInt32(CType(1, Int32))
        db.SelectOne()
        Me.url = db.sURL.Value
        Return db.sURL.Value
        db.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Get_Value Method

Public Function Get_Value( _
   ByVal KeyValue As String, _
   ByVal xmlElement As Xml.XmlElement _
) As String

Parameters

KeyValue
Required.
xmlElement
Required.

Source code

[Visual Basic]
    Public Function Get_Value(ByVal KeyValue As String, ByVal xmlElement As Xml.XmlElement) As String
        Dim s As String
        Dim i As Integer
        For i = 0 To xmlElement.Attributes.Count - 1
            If xmlElement.Attributes(i).Value = KeyValue Then
                Return xmlElement.Attributes(i + 1).Value
            End If
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmHostTransfer))
        Me.ProgressBar1 = New System.Windows.Forms.ProgressBar()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.label1 = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'ProgressBar1
        '
        Me.ProgressBar1.Location = New System.Drawing.Point(8, 104)
        Me.ProgressBar1.Name = "ProgressBar1"
        Me.ProgressBar1.Size = New System.Drawing.Size(448, 23)
        Me.ProgressBar1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(376, 136)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "Weiter >>"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(8, 136)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 2
        Me.Button2.Text = "Abbruch"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(200, 136)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 4
        Me.Button3.Text = "&OK"
        Me.Button3.Visible = False
        '
        'label1
        '
        Me.label1.Location = New System.Drawing.Point(8, 8)
        Me.label1.Multiline = True
        Me.label1.Name = "label1"
        Me.label1.ReadOnly = True
        Me.label1.Size = New System.Drawing.Size(448, 88)
        Me.label1.TabIndex = 5
        Me.label1.Text = "TextBox1"
        '
        'frmHostTransfer
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(464, 166)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.label1, Me.Button3, Me.Button2, Me.Button1, Me.ProgressBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmHostTransfer"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Partner-Daten vom HOST übermitteln"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Parse_Adresse Method

Private Sub Parse_Adresse()

Source code

[Visual Basic]
    Private Sub Parse_Adresse()
        Dim i As Integer
        Dim o As Integer
        Dim k As Integer
        Dim nrpar00 As Integer
        xmlNodes = xmldoc.GetElementsByTagName("result-object")
        For i = 0 To xmlNodes.Count - 1
            nrpar00 = 0
            nrpar00 = Me.Nrpar00
            partner.cpMainConnectionProvider = Globals.conn
            partner.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
            da = partner.SelectOne()
            If da.Rows.Count = 0 Then DoInsert = True Else DoInsert = False
            ha.cpMainConnectionProvider = Globals.conn
            ha.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = ha.SelectOne
            If da.Rows.Count = 0 Then doinsert1 = True Else doinsert1 = False

            For k = 0 To xmlNodes(0).ChildNodes.Count - 1
                Adresse_values(xmlNodes(i).ChildNodes(k))
            Next
            Globals.conn.OpenConnection()
            If DoInsert Then
                partner.sCDBAL00 = New SqlString(CType("N", String))
                partner.bCDVSA00 = New SqlBoolean(CType(False, Boolean))
                partner.sCDBAL00 = New SqlString(CType("N", String))
                partner.bCDVSA00 = New SqlBoolean(CType(False, Boolean))
                partner.iAZEPL00 = New SqlInt32(CType(1, Integer))
                partner.sBKPAR00 = New SqlString(CType(Me.BKPAR00, String))
                partner.iNRPAR00 = New SqlInt32(CType(Me.Nrpar00, Integer))
                partner.sNRPARAD = New SqlString(CType(Me.Nrpar00, String))
                partner.Insert()
            Else
                partner.Update()
            End If
            If doinsert1 Then
                ha.Insert()
            Else
                ha.Update()
            End If
            Globals.conn.CloseConnection(True)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Parse_Partner Method

Private Sub Parse_Partner()

Source code

[Visual Basic]
    Private Sub Parse_Partner()
        Dim i As Integer
        Dim o As Integer
        Dim k As Integer
        Dim nrpar00 As Integer
        xmlNodes = xmldoc.GetElementsByTagName("result-object")
        For i = 0 To xmlNodes.Count - 1
            nrpar00 = 0
            nrpar00 = Me.Nrpar00
            Me.BKPAR00 = ""
            For o = 0 To xmlNodes(i).ChildNodes.Count - 1
                If Me.BKPAR00 = "" Then
                    Me.BKPAR00 = Get_Value("kurzname", xmlNodes(i).ChildNodes(o))
                Else
                    Exit For
                End If
            Next

            'Exit Sub

            partner.cpMainConnectionProvider = Globals.conn
            partner.iNRPAR00 = New SqlInt32(CType(nrpar00, Int32))
            da = partner.SelectOne()
            If da.Rows.Count = 0 Then
                DoInsert = True
            Else
                DoInsert = False
            End If

            ha.cpMainConnectionProvider = Globals.conn
            ha.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = ha.SelectOne
            If da.Rows.Count = 0 Then
                doinsert1 = True
            Else
                doinsert1 = False
            End If

            'Prüfen ob bereits ein Eintrag vorhanden ist
            etparn.cpMainConnectionProvider = Globals.conn
            etparn.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = etparn.SelectOne
            If da.Rows.Count = 0 Then
                doinsert_etparn = True
            Else
                doinsert_etparn = False
            End If

            'Prüfen ob bereits ein Haubtbetreuer vorhanden ist
            etbez0.cpMainConnectionProvider = Globals.conn
            etbez0.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = etbez0.SelectOne
            If da.Rows.Count = 0 Then
                doinsert_etbez0 = True
            Else
                doinsert_etbez0 = False
            End If

            'Prüfen ob bereits ein Eintrag vorhanden ist
            etparu.cpMainConnectionProvider = Globals.conn
            etparu.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = etparu.SelectOne
            If da.Rows.Count = 0 Then
                doinsert_etparu = True
            Else
                doinsert_etparu = False
            End If

            'Prüfen ob bereits ein Eintrag vorhanden ist
            etpar0.cpMainConnectionProvider = Globals.conn
            etpar0.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            da = etpar0.SelectOne
            If da.Rows.Count = 0 Then
                doinsert_etpar0 = True
            Else
                doinsert_etpar0 = False
            End If

            For k = 0 To xmlNodes(0).ChildNodes.Count - 1
                partner_values(xmlNodes(i).ChildNodes(k))
            Next

            Globals.conn.OpenConnection()
            If DoInsert Then
                partner.sCDBAL00 = New SqlString(CType("N", String))
                partner.bCDVSA00 = New SqlBoolean(CType(False, Boolean))
                partner.sCDBAL00 = New SqlString(CType("N", String))
                partner.bCDVSA00 = New SqlBoolean(CType(False, Boolean))
                partner.iAZEPL00 = New SqlInt32(CType(1, Integer))
                partner.sNRPARAD = New SqlString(CType(Me.Nrpar00, String))
                partner.sBKPAR00 = New SqlString(CType(Me.BKPAR00, String))
                partner.Insert()
            Else
                partner.Update()
            End If
            If doinsert1 Then
                ha.Insert()
            Else
                ha.Update()
            End If

            'Wenn Partner ein NP ist
            If m_PartnerIstNP = True Then
                etparn.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
                If doinsert_etparn Then
                    etparn.siNRVRN00 = New SqlInt16(9999)
                    etparn.sBEBERAL = New SqlString("")
                    etparn.sCDIPA00 = New SqlString("")
                    etparn.sCDMUTER = New SqlString("")
                    etparn.daTSMUT00 = New SqlDateTime(Now())
                    etparn.sSAREC00 = New SqlString("2")
                    etparn.Insert()
                Else
                    etparn.Update()
                End If
            End If

            'Wenn Partner ein UP ist
            If m_PartnerIstUP = True Then
                etparu.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
                If doinsert_etparn Then
                    etparu.siNRVRN00 = New SqlInt16(9999)
                    etparu.sCDIPA00 = New SqlString("")
                    etparu.sCDMUTER = New SqlString("")
                    etparu.daTSMUT00 = New SqlDateTime(Now())
                    etparu.sSAREC00 = New SqlString("2")
                    etparu.Insert()
                Else
                    etparu.Update()
                End If
            End If

            'Wenn Partner ein Hauptbetreuer hat
            If m_PartnerHatBetreuer = True Then
                etbez0.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
                If doinsert_etbez0 Then
                    etbez0.iNRBEZ00 = New SqlInt32(GetNewKey)
                    etbez0.siNRVRN00 = New SqlInt16(9999)
                    etbez0.siNRBEO00 = New SqlInt16(200)
                    etbez0.sCDMUTER = New SqlString("")
                    etbez0.daTSMUT00 = New SqlDateTime(Now())
                    etbez0.sSAREC00 = New SqlString("2")
                    etbez0.Insert()
                Else
                    etbez0.Update()
                End If
            End If

            'ETPAR0
            etpar0.iNRPAR00() = New SqlInt32(CType(nrpar00, Int32))
            If doinsert_etpar0 Then
                etpar0.siNRERF00 = New SqlInt16(0)
                etpar0.siNRAFG00 = New SqlInt16(0)
                etpar0.siNRBBG00 = New SqlInt16(0)
                etpar0.sSAWBG00 = New SqlString("")

                etpar0.siNRVRN00 = New SqlInt16(9999)
                etpar0.sCDMUTER = New SqlString("")
                etpar0.daTSMUT00 = New SqlDateTime(Now())
                etpar0.sSAREC00 = New SqlString("2")
                etpar0.Insert()
            Else
                etpar0.Update()
            End If

            Globals.conn.CloseConnection(True)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Parse_VV Method

Private Sub Parse_VV()

Source code

[Visual Basic]
    Private Sub Parse_VV()
        Dim i As Integer
        Dim o As Integer
        Dim k As Integer
        Dim vvnr As Integer
        xmlNodes = xmldoc.GetElementsByTagName("result-object")
        For i = 0 To xmlNodes.Count - 1
            vvnr = 0
            For o = 0 To xmlNodes(i).ChildNodes.Count - 1
                If vvnr <= 1 Then vvnr = Get_Value("vvNr", xmlNodes(i).ChildNodes(o))
            Next o

            vv.cpMainConnectionProvider = Globals.conn
            vv.iNRVVG00 = New SqlInt32(CType(vvnr, Int32))
            da = vv.SelectOne()
            If da.Rows.Count = 0 Then DoInsert = True Else DoInsert = False
            For k = 0 To xmlNodes(0).ChildNodes.Count - 1
                vv_values(xmlNodes(i).ChildNodes(k))
            Next
            Globals.conn.OpenConnection()
            If DoInsert Then
                'BUD - 19.07.2006 - sBEPRDLG auf leer String setzten
                vv.sBEPRDLG = New SqlString(CType("", String))
                vv.Insert()
                vvz = vvz + 1
            Else
                'vv.Update()
            End If
            Globals.conn.CloseConnection(True)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Partner_Exists Method

Public Function Partner_Exists() As Boolean

Source code

[Visual Basic]
    Public Function Partner_Exists() As Boolean
        Dim db As New edokadb.clsPartner()
        Dim da As New DataTable()
        db.iNRPAR00 = New SqlInt32(CType(Me.Nrpar00, Int32))
        db.cpMainConnectionProvider = Globals.conn
        da = db.SelectOne()
        If da.Rows.Count = 0 Then Return False Else Return True
        da.Dispose()
        db.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Update_Progress Method

Private Sub Update_Progress( _
   ByVal message As String, _
   ByVal value As Integer _
)

Parameters

message
Required.
value
Required.

Source code

[Visual Basic]
    Private Sub Update_Progress(ByVal message As String, ByVal value As Integer)
        Me.ProgressBar1.Value = value
        Me.label1.Text = message
        Application.DoEvents()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Write_Field Method

Private Sub Write_Field( _
   ByVal xmldoc As Xml.XmlTextWriter, _
   ByVal Feldname As String, _
   ByVal Feldvalue As String _
)

Parameters

xmldoc
Required.
Feldname
Required.
Feldvalue
Required.

Source code

[Visual Basic]
    Private Sub Write_Field(ByVal xmldoc As Xml.XmlTextWriter, ByVal Feldname As String, ByVal Feldvalue As String)
        xmldoc.WriteStartElement("field")
        xmldoc.WriteAttributeString("", "name", Nothing, Feldname)
        xmldoc.WriteAttributeString("", "value", Nothing, Feldvalue)
        xmldoc.WriteEndElement()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Write_Header Method

Private Sub Write_Header( _
   ByVal xmldoc As Xml.XmlTextWriter, _
   ByVal Type As Integer _
)

Parameters

xmldoc
Required.
Type
Required.

Source code

[Visual Basic]
    Private Sub Write_Header(ByVal xmldoc As Xml.XmlTextWriter, ByVal Type As Integer)
        'Type 2 = Partner
        'Type 3 = VV des Partner
        'Type 4 = Aufbereitete Adresse"
        Select Case Type
            Case 2
                xmldoc.WriteStartDocument()
                xmldoc.WriteStartElement("content-request")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.RequestName)
                xmldoc.WriteStartElement("request-header")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "personalNr")
                xmldoc.WriteAttributeString("", "value", Nothing, Globals.TGNummer)
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "bankNr")
                xmldoc.WriteAttributeString("", "value", Nothing, "TG")
                'xmldoc.WriteAttributeString("", "value", Nothing, "AK")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sessionId")
                xmldoc.WriteAttributeString("", "value", Nothing, "standard-sessionId")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sprache")
                xmldoc.WriteAttributeString("", "value", Nothing, "1")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("request-params")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "maxAnswers")
                xmldoc.WriteAttributeString("", "value", Nothing, "1")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("resultset-content")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.ResutlSetContent)
                xmldoc.WriteStartElement("result-object")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.Resultobject)
                xmldoc.WriteAttributeString("", "recordNumber", Nothing, "0")
            Case 3
                xmldoc.WriteStartDocument()
                xmldoc.WriteStartElement("content-request")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.RequestName)
                xmldoc.WriteStartElement("request-header")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "personalNr")
                xmldoc.WriteAttributeString("", "value", Nothing, Globals.TGNummer)
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "bankNr")
                xmldoc.WriteAttributeString("", "value", Nothing, "TG")
                'xmldoc.WriteAttributeString("", "value", Nothing, "AK")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sessionId")
                xmldoc.WriteAttributeString("", "value", Nothing, "standard-sessionId")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sprache")
                xmldoc.WriteAttributeString("", "value", Nothing, "1")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("request-params")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "maxAnswers")
                xmldoc.WriteAttributeString("", "value", Nothing, "15")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("resultset-content")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.ResutlSetContent)
                xmldoc.WriteStartElement("result-object")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.Resultobject)
                xmldoc.WriteAttributeString("", "recordNumber", Nothing, "-1")
            Case 4
                xmldoc.WriteStartDocument()
                xmldoc.WriteStartElement("content-request")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.RequestName)
                xmldoc.WriteStartElement("request-header")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "personalNr")
                xmldoc.WriteAttributeString("", "value", Nothing, Globals.TGNummer)
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "bankNr")
                xmldoc.WriteAttributeString("", "value", Nothing, "TG")
                'xmldoc.WriteAttributeString("", "value", Nothing, "AK")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sessionId")
                xmldoc.WriteAttributeString("", "value", Nothing, "standard-sessionId")
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "sprache")
                xmldoc.WriteAttributeString("", "value", Nothing, "1")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("request-params")
                xmldoc.WriteStartElement("field")
                xmldoc.WriteAttributeString("", "name", Nothing, "maxAnswers")
                xmldoc.WriteAttributeString("", "value", Nothing, "2")
                xmldoc.WriteEndElement()
                xmldoc.WriteEndElement()

                xmldoc.WriteStartElement("resultset-content")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.ResutlSetContent)
                xmldoc.WriteStartElement("result-object")
                xmldoc.WriteAttributeString("", "name", Nothing, Me.Resultobject)
                xmldoc.WriteAttributeString("", "recordNumber", Nothing, "1")
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.Write_State Method

Private Sub Write_State( _
   ByVal xmldoc As Xml.XmlTextWriter, _
   ByVal feldname As String, _
   ByVal feldvalue As String _
)

Parameters

xmldoc
Required.
feldname
Required.
feldvalue
Required.

Source code

[Visual Basic]
    Private Sub Write_State(ByVal xmldoc As Xml.XmlTextWriter, ByVal feldname As String, ByVal feldvalue As String)
        xmldoc.WriteStartElement("field")
        xmldoc.WriteAttributeString("", "name", Nothing, feldname)
        xmldoc.WriteAttributeString("", "state", Nothing, feldvalue)
        xmldoc.WriteEndElement()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.attrib Method

Sub attrib( _
   ByVal xmlelement As Xml.XmlElement _
)

Parameters

xmlelement
Required.

Source code

[Visual Basic]
    Sub attrib(ByVal xmlelement As Xml.XmlElement)
        Dim s As String
        Dim i As Integer
        For i = 0 To xmlelement.Attributes.Count - 1
            s = s + xmlelement.Attributes(i).Name & ":" + Chr(9)
            s = s + xmlelement.Attributes(i).Value + Chr(9)
            s = s + Chr(9)
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.frmHostTransfer_Load Method

Private Sub frmHostTransfer_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmHostTransfer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        'Rel 3.6 BUD
        'TGNummer setzten wenn in Testumgebung
        If Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("showlogin") = True Then
            Globals.TGNummer = "TG3896"
            'MsgBox("TG Nummer gesetzt. Muss noch auf Show Login abgefragt werden.")
        End If

        If Me.Partner_Exists Then
            label1.Text = MyTxt.gettext(101)
        Else
            label1.Text = MyTxt.gettext(102)
            Button1.Visible = True
            Button2.Visible = True
        End If
        Me.ProgressBar1.Value = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.load_data Method

Public Sub load_data()

Source code

[Visual Basic]
    Public Sub load_data()
        If Me.Partner_Exists Then
            Me.PartnerExists = True
            label1.Text = MyTxt.gettext(101)
            Button1.Visible = True
            Button2.Visible = True
        Else
            Me.PartnerExists = True
            label1.Text = MyTxt.gettext(102)
            Button1.Visible = True
            Button2.Visible = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.partner_values Method

Sub partner_values( _
   ByVal xmlelement As Xml.XmlElement _
)

Parameters

xmlelement
Required.

Source code

[Visual Basic]
    Sub partner_values(ByVal xmlelement As Xml.XmlElement)
        Dim i As Integer
        Dim s As String
        Dim w As Integer
        For i = 0 To xmlelement.Attributes.Count - 2
            Debug.Write(xmlelement.Attributes(i + 1).Name + ": " + xmlelement.Attributes(i + 1).Value + vbNewLine)
            s = xmlelement.Attributes(i + 1).Value
            If s = "noData" Or s = "null" Then s = ""
            Select Case xmlelement.Attributes(i).Value
                Case "kurzname"
                    partner.sBKPAR00 = New SqlString(CType(s, String)) 'New SqlString(CType(Me.BKPAR00, String))
                    etpar0.sBKPAR00 = New SqlString(CType(s, String))
                Case "status"
                    ha.sSAREC00 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                Case "domizilKanton"
                    partner.sCDBNK00 = New SqlString(CType(s, String)) 'New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    etpar0.sCDDOMKT = New SqlString(CType(s, String))
                Case "hauptbetreuer" 'NRBEU01 in edoka_etbez0 + SAREC00 fix = 2
                    If s = "" Then
                        m_PartnerHatBetreuer = False
                        s = "0"
                    Else
                        m_PartnerHatBetreuer = True
                    End If
                    etbez0.iNRBEU01 = New SqlInt32(CType(s, Int32))
                    etpar0.iNRBEU01 = New SqlInt32(CType(s, Int32))
                Case "abwicklungsformKurzbezeichnung"
                        If s = "NP" Then
                            m_PartnerIstNP = True
                        End If
                        If s = "UP" Then
                            m_PartnerIstUP = True
                        End If
                Case "npGeburtsdatum"
                        If s <> "" Then
                            etparn.daDMGEB00 = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "npGeburtsjahr"
                        If s = "" Then s = "0"
                        etparn.siDMGEBJJ = New SqlInt16(CType(s, Int16))
                Case "eroeffnungsdatum"
                        If s = "" Then s = "01.01.1900"
                        etparn.daDMERF00 = New SqlDateTime(CType(s, DateTime))
                        etbez0.daDMERF00 = New SqlDateTime(CType(s, DateTime))
                        etparu.daDMERF00 = New SqlDateTime(CType(s, DateTime))
                        etpar0.daDMPAREO = New SqlDateTime(CType(s, DateTime))
                        etpar0.daDMERF00 = New SqlDateTime(CType(s, DateTime))
                Case "npGeburtsort"
                        etparn.sBEGEB00 = New SqlString(CType(s, String))
                Case "npBuergerort"
                        etparn.sBEBGO00 = New SqlString(CType(s, String))
                Case "npTodesjahr"
                        If s = "" Then s = "0"
                        etparn.siDMTODJJ = New SqlInt16(CType(s, Int16))
                Case "npGeschlechtNr"
                        If s = "" Then s = "0"
                        etparn.siNRSEX00 = New SqlInt16(CType(s, Int16))
                Case "npZivilstandNr"
                        If s = "" Then s = "0"
                        etparn.siNRZVS00 = New SqlInt16(CType(s, Int16))
                Case "npGueterstandNr"
                        If s = "" Then s = "0"
                        etparn.siNRGST00 = New SqlInt16(CType(s, Int16))
                Case "npAusbildungsstufeNr"
                        If s = "" Then s = "0"
                        etparn.siNRABD00 = New SqlInt16(CType(s, Int16))
                Case "npBerufNr"
                        If s = "" Then s = "0"
                        etparn.iNRBER01 = New SqlInt32(CType(s, Int32))
                Case "npSonstigerBerufNr"
                        If s = "" Then s = "0"
                        etparn.iNRBER02 = New SqlInt32(CType(s, Int32))
                Case "npErwerbsstatusNr"
                        If s = "" Then s = "0"
                        etparn.siNRERW00 = New SqlInt16(CType(s, Int16))
                Case "npAhvNr"
                        etparn.sCDAHV00 = New SqlString(CType(s, String))
                Case "npBvgVersicherungNr"
                        If s = "" Then s = "0"
                        etparn.siNRBVG00 = New SqlInt16(CType(s, Int16))
                Case "npAuslaenderbewilligungNr"
                        If s = "" Then s = "0"
                        etparn.siNRABE00 = New SqlInt16(CType(s, Int16))
                Case "upGruendungsjahr"
                        If s = "" Then s = "0"
                        etparu.siDMGRDJJ = New SqlInt16(CType(s, Int16))
                Case "upGruendungsdatum"
                        If s <> "" Then
                            etparu.daDMGRD00 = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "upAufloesungsdatum"
                        If s <> "" Then
                            etparu.daDMAFL00 = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "upAufloesungsjahr"
                        If s = "" Then s = "0"
                        etparu.siDMAFLJJ = New SqlInt16(CType(s, Int16))
                Case "upAnzahlBeschaeftigte"
                        If s = "" Then s = "0"
                        etparu.dcAZBSC00 = New SqlDecimal(CType(s, Decimal))
                Case "upHandelsregistereintragDatum"
                        If s <> "" Then
                            etparu.daDMHDR00 = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "upSwiftId"
                        etparu.sCDSWI00 = New SqlString(CType(s, String))
                Case "upSicNr"
                        If s = "" Then s = "0"
                        etparu.dcNRSIC00 = New SqlDecimal(CType(s, Decimal))
                Case "upBrancheNoga"
                        etparu.sCDNOG01 = New SqlString(CType(s, String))
                Case "upSonstigeBrancheNoga"
                        etparu.sCDNOG02 = New SqlString(CType(s, String))
                Case "abwicklungsformCode"
                        etpar0.sCDPAW00 = New SqlString(CType(s, String))
                Case "kundeSeit"
                        If s <> "" Then
                            etpar0.daDMPARVN = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "aufhebungsdatum"
                        If s <> "" Then
                            etpar0.daDMPARBI = New SqlDateTime(CType(s, DateTime))
                        End If
                Case "rechtlicherStatusNr"
                        If s = "" Then s = "0"
                        etpar0.siNRRST00 = New SqlInt16(CType(s, Int16))
                Case "korrespondenzspracheNr"
                        If s = "" Then s = "0"
                        etpar0.siNRSPA00 = New SqlInt16(CType(s, Int16))
                Case "geldstromNr"
                        If s = "" Then s = "0"
                        etpar0.siNRGSR00 = New SqlInt16(CType(s, Int16))
                Case "bonitaetNr"
                        If s = "" Then s = "0"
                        etpar0.siNRBON00 = New SqlInt16(CType(s, Int16))
                Case "domizilGemeinde"
                        If s = "" Then s = "0"
                        etpar0.siNRDOMGE = New SqlInt16(CType(s, Int16))
                Case "domizilLand"
                        If s = "" Then s = "0"
                        etpar0.siNRDOM00 = New SqlInt16(CType(s, Int16))
                Case "risikoDomizilLand"
                        If s = "" Then s = "0"
                        etpar0.siNRDOMRI = New SqlInt16(CType(s, Int16))
                Case "nationalitaetLand"
                        If s = "" Then s = "0"
                        etpar0.siNRNAT01 = New SqlInt16(CType(s, Int16))
                Case "weitereNationalitaet"
                        If s = "" Then s = "0"
                        etpar0.siNRNAT02 = New SqlInt16(CType(s, Int16))
                Case "beDatenverantwortlich"
                        If s = "" Then s = "0"
                        etpar0.iNRBEE00 = New SqlInt32(CType(s, Int32))
                Case "integer"
                        etpar0.sSAINT00 = New SqlString(CType(s, String))
                Case "stvBetreuer"
                        If s = "" Then s = "0"
                        etpar0.iNRBEU02 = New SqlInt32(CType(s, Int32))
                Case "sortiername"
                        etpar0.sBKPARSQ = New SqlString(CType(s, String))
                Case "technischerSortierbegriff"
                        etpar0.sCDPARSQ = New SqlString(CType(s, String))
                Case "nachkontrollStatus"
                        etpar0.sSAKTRNA = New SqlString(CType(s, String))
            End Select
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.read_data Method

Private Sub read_data()

Source code

[Visual Basic]
    Private Sub read_data()
        Dim xstreamer As StreamReader
        Dim sStream As Stream
        Dim URLReq As HttpWebRequest
        Dim URLRes As HttpWebResponse
        Dim swriter As System.IO.StreamWriter
        Dim sreader As System.IO.StreamReader
        Dim surl As String = Get_URL()
        Try

            xstreamer = File.OpenText(filename)
            xmlstring = xstreamer.ReadToEnd

            URLReq = WebRequest.Create(surl)
            'URLReq.Method = "GET"
            URLReq.Method = "POST"
            swriter = New System.IO.StreamWriter(URLReq.GetRequestStream())
            swriter.Write(xmlstring)
            swriter.Close()
            Application.DoEvents()

            URLRes = URLReq.GetResponse()
            Application.DoEvents()

            URLRes = URLReq.GetResponse
            Application.DoEvents()
            sreader = New System.IO.StreamReader(URLRes.GetResponseStream(), System.Text.Encoding.GetEncoding("ISO-8859-1"))

            'TEMP TEMP
            Dim x As String
            Dim sw As System.IO.StreamWriter
            Dim ss As String
            'ss = sreader.ReadToEnd
            'MsgBox(ss)

            xmldoc.Load(sreader)
            sreader.Close()
            xstreamer.Close()
        Catch EX As Exception
            xstreamer.Close()
            MsgBox(EX.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer.vv_values Method

Sub vv_values( _
   ByVal xmlelement As Xml.XmlElement _
)

Parameters

xmlelement
Required.

Source code

[Visual Basic]
    Sub vv_values(ByVal xmlelement As Xml.XmlElement)
        Dim i As Integer
        For i = 0 To xmlelement.Attributes.Count - 1
            Select Case xmlelement.Attributes(i).Value
                Case "vvNr"
                    vv.iNRPRD00 = New SqlInt32(CType(xmlelement.Attributes(i + 1).Value, Int32))
                Case "produktNr"
                    vv.iNRPRD00 = New SqlInt32(CType(xmlelement.Attributes(i + 1).Value, Int32))
                Case "vvNrExtern"
                    vv.sNEVVG00 = New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                Case "status"
                    vv.sSAREC00 = New SqlString(CType("2", String))
                Case "partnerNr"
                    vv.iNRPAR00 = New SqlInt32(CType(xmlelement.Attributes(i + 1).Value, Int32))
                Case "vvNrExternAufbereitet"
                    vv.sNAVVG00 = New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                Case "vereinbarungsSubtypNr"
                    vv.iNRVBS00 = New SqlInt32(CType(xmlelement.Attributes(i + 1).Value, Int32))
                Case "rubrik"
                    If xmlelement.Attributes(i + 1).Value <> "noData" Then
                        vv.sTXRBK00 = New SqlString(CType(xmlelement.Attributes(i + 1).Value, String))
                    Else
                        vv.sTXRBK00 = New SqlString(CType("", String))
                    End If
            End Select
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmHostTransfer Fields

frmHostTransfer overview

Fields

field BKPAR00
field Button1
field Button2
field Button3
field DoInsert
field PartnerExists
field ProgressBar1
field RequestName
field Resultobject
field ResutlSetContent
field components
field da
field db
field doinsert1
field doinsert_etbez0
field doinsert_etpar0
field doinsert_etparn
field doinsert_etparu
field etbez0
field etpar0
field etparn
field etparu
field filename
field ha
field label1
field m_PartnerHatBetreuer
field m_PartnerIstNP
field m_PartnerIstUP
field m_nrpar00
field m_nrpar00_aufbereitet
field partner
field statustext
field url
field vv
field vvz
field xmlElement
field xmlNodes
field xmldoc
field xmlstring

See Also

frmHostTransfer Class


BKPAR00 Variable

Dim BKPAR00 As String

Source code

[Visual Basic]
    Dim BKPAR00 As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


DoInsert Variable

Dim DoInsert As Boolean = False

Source code

[Visual Basic]
    Dim DoInsert As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


PartnerExists Variable

Dim PartnerExists As Boolean = False

Source code

[Visual Basic]
    Dim PartnerExists As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


ProgressBar1 Variable

Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Source code

[Visual Basic]
    Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


RequestName Variable

Dim RequestName As String

Source code

[Visual Basic]
    Dim RequestName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


Resultobject Variable

Dim Resultobject As String

Source code

[Visual Basic]
    Dim Resultobject As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


ResutlSetContent Variable

Dim ResutlSetContent As String

Source code

[Visual Basic]
    Dim ResutlSetContent As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


da Variable

Dim da As New DataTable()

Source code

[Visual Basic]
    Dim da As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


db Variable

Dim db As New edokadb.clsServices()

Source code

[Visual Basic]
    Dim db As New edokadb.clsServices()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


doinsert1 Variable

Dim doinsert1 As Boolean = False

Source code

[Visual Basic]
    Dim doinsert1 As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


doinsert_etbez0 Variable

Dim doinsert_etbez0 As Boolean = False

Source code

[Visual Basic]
    Dim doinsert_etbez0 As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


doinsert_etpar0 Variable

Dim doinsert_etpar0 As Boolean = False

Source code

[Visual Basic]
    Dim doinsert_etpar0 As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


doinsert_etparn Variable

Dim doinsert_etparn As Boolean = False

Source code

[Visual Basic]
    Dim doinsert_etparn As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


doinsert_etparu Variable

Dim doinsert_etparu As Boolean = False

Source code

[Visual Basic]
    Dim doinsert_etparu As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


etbez0 Variable

Dim etbez0 As New edokadb.clsEdoka_etbez0()

Source code

[Visual Basic]
    Dim etbez0 As New edokadb.clsEdoka_etbez0()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


etpar0 Variable

Dim etpar0 As New edokadb.clsEdoka_etpar0()

Source code

[Visual Basic]
    Dim etpar0 As New edokadb.clsEdoka_etpar0()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


etparn Variable

Dim etparn As New edokadb.clsEtparn()

Source code

[Visual Basic]
    Dim etparn As New edokadb.clsEtparn()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


etparu Variable

Dim etparu As New edokadb.clsEtparu()

Source code

[Visual Basic]
    Dim etparu As New edokadb.clsEtparu()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


filename Variable

Dim filename As String = Globals.Applikationsdaten.Rows( _
   Globals.AppldataRow _
).Item("pfad_temporaer_dokumente") + "\XMLRequest.xml"

Source code

[Visual Basic]
    Dim filename As String = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + "\XMLRequest.xml"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


ha Variable

Dim ha As New edokadb.clsPartner_Hauptadresse()

Source code

[Visual Basic]
    Dim ha As New edokadb.clsPartner_Hauptadresse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


label1 Variable

Friend WithEvents label1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents label1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


m_PartnerHatBetreuer Variable

Dim m_PartnerHatBetreuer As Boolean = False

Source code

[Visual Basic]
    Dim m_PartnerHatBetreuer As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


m_PartnerIstNP Variable

Dim m_PartnerIstNP As Boolean = False

Source code

[Visual Basic]
    Dim m_PartnerIstNP As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


m_PartnerIstUP Variable

Dim m_PartnerIstUP As Boolean = False

Source code

[Visual Basic]
    Dim m_PartnerIstUP As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


m_nrpar00 Variable

Dim m_nrpar00 As String

Source code

[Visual Basic]
    Dim m_nrpar00 As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


m_nrpar00_aufbereitet Variable

Dim m_nrpar00_aufbereitet As String

Source code

[Visual Basic]
    Dim m_nrpar00_aufbereitet As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


partner Variable

Dim partner As New edokadb.clsPartner()

Source code

[Visual Basic]
    Dim partner As New edokadb.clsPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


statustext Variable

Dim statustext As String = ""

Source code

[Visual Basic]
    Dim statustext As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


url Variable

Dim url As String

Source code

[Visual Basic]
    Dim url As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


vv Variable

Dim vv As New edokadb.clsVV()

Source code

[Visual Basic]
    Dim vv As New edokadb.clsVV()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


vvz Variable

Dim vvz As Integer = 0

Source code

[Visual Basic]
    Dim vvz As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


xmlElement Variable

Dim xmlElement As Xml.XmlElement

Source code

[Visual Basic]
    Dim xmlElement As Xml.XmlElement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


xmlNodes Variable

Dim xmlNodes As Xml.XmlNodeList

Source code

[Visual Basic]
    Dim xmlNodes As Xml.XmlNodeList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


xmldoc Variable

Dim xmldoc As New Xml.XmlDocument()

Source code

[Visual Basic]
    Dim xmldoc As New Xml.XmlDocument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


xmlstring Variable

Dim xmlstring As String

Source code

[Visual Basic]
    Dim xmlstring As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmHostTransfer


frmIDVMakroOfficeVorlage Class

For a list of all members of this type, see frmIDVMakroOfficeVorlage Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmIDVMakroOfficeVorlage

Public Class frmIDVMakroOfficeVorlage
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmIDVMakroOfficeVorlage Members


frmIDVMakroOfficeVorlage Members

frmIDVMakroOfficeVorlage overview

Constructors

constructor frmIDVMakroOfficeVorlage Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmIDVMakroOfficeVorlage Class


frmIDVMakroOfficeVorlage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage Properties

frmIDVMakroOfficeVorlage overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmIDVMakroOfficeVorlage Class


frmIDVMakroOfficeVorlage Methods

frmIDVMakroOfficeVorlage overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmIDVMakroOfficeVorlage Class


frmIDVMakroOfficeVorlage.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "office_vorlage", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("vorlagename", "vorlagename"), New System.Data.Common.DataColumnMapping("prefix_dokumentname", "prefix_dokumentname"), New System.Data.Common.DataColumnMapping("idv_vorlage", "idv_vorlage"), New System.Data.Common.DataColumnMapping("idv_id", "idv_id"), New System.Data.Common.DataColumnMapping("office_vorlage", "office_vorlage"), New System.Data.Common.DataColumnMapping("absender_ersteller", "absender_ersteller"), New System.Data.Common.DataColumnMapping("idv_nativ", "idv_nativ"), New System.Data.Common.DataColumnMapping("dokument_geschuetzt", "dokument_geschuetzt"), New System.Data.Common.DataColumnMapping("kopfzeile_generieren", "kopfzeile_generieren"), New System.Data.Common.DataColumnMapping("klassifizierung", "klassifizierung"), New System.Data.Common.DataColumnMapping("bcptl", "bcptl"), New System.Data.Common.DataColumnMapping("bcw", "bcw"), New System.Data.Common.DataColumnMapping("bch", "bch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("anwendungnr", "anwendungnr")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "idv_makros", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("idvmakronr", "idvmakronr"), New System.Data.Common.DataColumnMapping("makro", "makro"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("ist_in_dll", "ist_in_dll"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "idvmakro_office_vorlage", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("idvmakroofficevorlagenr", "idvmakroofficevorlagenr"), New System.Data.Common.DataColumnMapping("reihenfolge", "reihenfolge"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("idvmakronr", "idvmakronr")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_office_vorlage_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_office_vorlage_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagename", System.Data.SqlDbType.VarChar, 255, "vorlagename"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, "prefix_dokumentname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_vorlage", System.Data.SqlDbType.Bit, 1, "idv_vorlage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_id", System.Data.SqlDbType.VarChar, 50, "idv_id"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlage", System.Data.SqlDbType.VarChar, 255, "office_vorlage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@absender_ersteller", System.Data.SqlDbType.Bit, 1, "absender_ersteller"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_nativ", System.Data.SqlDbType.Bit, 1, "idv_nativ"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, "dokument_geschuetzt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, "kopfzeile_generieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcptl", System.Data.SqlDbType.Int, 4, "bcptl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcw", System.Data.SqlDbType.Int, 4, "bcw"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bch", System.Data.SqlDbType.Int, 4, "bch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_office_vorlage_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorlagename", System.Data.SqlDbType.VarChar, 255, "vorlagename"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, "prefix_dokumentname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_vorlage", System.Data.SqlDbType.Bit, 1, "idv_vorlage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_id", System.Data.SqlDbType.VarChar, 50, "idv_id"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlage", System.Data.SqlDbType.VarChar, 255, "office_vorlage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@absender_ersteller", System.Data.SqlDbType.Bit, 1, "absender_ersteller"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idv_nativ", System.Data.SqlDbType.Bit, 1, "idv_nativ"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, "dokument_geschuetzt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, "kopfzeile_generieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@klassifizierung", System.Data.SqlDbType.Int, 4, "klassifizierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcptl", System.Data.SqlDbType.Int, 4, "bcptl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bcw", System.Data.SqlDbType.Int, 4, "bcw"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bch", System.Data.SqlDbType.Int, 4, "bch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anwendungnr", System.Data.SqlDbType.Int, 4, "anwendungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_absender_ersteller", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "absender_ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcptl", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcptl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcw", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcw", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_geschuetzt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_id", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_id", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_nativ", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_vorlage", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kopfzeile_generieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlage", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prefix_dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagename", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagename", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_office_vorlage_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_absender_ersteller", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "absender_ersteller", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anwendungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anwendungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcptl", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcptl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bcw", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bcw", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_geschuetzt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_geschuetzt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_id", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_id", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_nativ", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idv_vorlage", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idv_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_klassifizierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "klassifizierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kopfzeile_generieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kopfzeile_generieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlage", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prefix_dokumentname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prefix_dokumentname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorlagename", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorlagename", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_idvmakros_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_idvmakros_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@makro", System.Data.SqlDbType.VarChar, 255, "makro"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ist_in_dll", System.Data.SqlDbType.Bit, 1, "ist_in_dll"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_idvmakros_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@makro", System.Data.SqlDbType.VarChar, 255, "makro"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ist_in_dll", System.Data.SqlDbType.Bit, 1, "ist_in_dll"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ist_in_dll", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ist_in_dll", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_makro", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "makro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_idvmakros_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ist_in_dll", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ist_in_dll", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_makro", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "makro", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_idvmakros_officevorlage_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_idvmakros_officevorlage_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakroofficevorlagenr", System.Data.SqlDbType.Int, 4, "idvmakroofficevorlagenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_idvmakros_officevorlage_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakroofficevorlagenr", System.Data.SqlDbType.Int, 4, "idvmakroofficevorlagenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@idvmakronr", System.Data.SqlDbType.Int, 4, "idvmakronr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakroofficevorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakroofficevorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_idvmakros_officevorlage_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakroofficevorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakroofficevorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_idvmakronr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "idvmakronr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmIDVMakroOfficeVorlage
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmIDVMakroOfficeVorlage"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsIdvmakro_office_vorlage()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            vdata.iReihenfolge = New SqlInt32(CType(0, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iOffice_vorlagenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    vdata.iIdvmakronr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iIdvmakronr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    vdata.iOffice_vorlagenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iOffice_vorlagenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                vdata.iIdvmakronr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("idvmakro_office_vorlage")
            vdata.iIdvmakroofficevorlagenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5003, 5004, 5005)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "office_vorlage"
        Me.TableNameRight = "idv_makros"
        Me.TableNameBottom = "idvmakro_office_vorlage"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIDVMakroOfficeVorlage Fields

frmIDVMakroOfficeVorlage overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmIDVMakroOfficeVorlage Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIDVMakroOfficeVorlage


frmIconSelector Class

For a list of all members of this type, see frmIconSelector Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmIconSelector

Public Class frmIconSelector
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmIconSelector Members


frmIconSelector Members

frmIconSelector overview

Constructors

constructor frmIconSelector Constructor

Properties

property SelectedImage

Methods

method Dispose
method Form2_Load
method InitializeComponent
method ListView1_DoubleClick
method ListView1_SelectedIndexChanged

Fields

field Button1
field Button2
field ListView1
field components
field m_imageindex

See Also

frmIconSelector Class


frmIconSelector Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector Properties

frmIconSelector overview

Properties

property SelectedImage

See Also

frmIconSelector Class


frmIconSelector.SelectedImage Property

Property SelectedImage() As Integer

Source code

[Visual Basic]
    Property SelectedImage() As Integer
        Get
            Return m_imageindex
        End Get
        Set(ByVal Value As Integer)
            m_imageindex = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector Methods

frmIconSelector overview

Methods

method Dispose
method Form2_Load
method InitializeComponent
method ListView1_DoubleClick
method ListView1_SelectedIndexChanged

See Also

frmIconSelector Class


frmIconSelector.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector.Form2_Load Method

Private Sub Form2_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form2_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Me.ListView1.LargeImageList = Globals.DokumentartenImages
        Me.Refresh()
        Me.ListView1.Clear()
        For i = 0 To Me.ListView1.LargeImageList.Images.Count - 1
            Me.ListView1.Items.Add(i.ToString, i)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.ListView1 = New System.Windows.Forms.ListView()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'ListView1
        '
        Me.ListView1.Location = New System.Drawing.Point(8, 8)
        Me.ListView1.Name = "ListView1"
        Me.ListView1.Size = New System.Drawing.Size(704, 456)
        Me.ListView1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.Button1.Location = New System.Drawing.Point(8, 472)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&Schliessen"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(88, 472)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 2
        Me.Button2.Text = "&OK"
        '
        'frmIconSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(720, 501)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.ListView1})
        Me.Name = "frmIconSelector"
        Me.Text = "Form2"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector.ListView1_DoubleClick Method

Private Sub ListView1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListView1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListView1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListView1.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListView1.SelectedItems.Count - 1
            Me.SelectedImage = Me.ListView1.SelectedItems(i).ImageIndex
        Next
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector.ListView1_SelectedIndexChanged Method

Private Sub ListView1_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ListView1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListView1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListView1.SelectedIndexChanged
        Dim i As Integer
        For i = 0 To Me.ListView1.SelectedItems.Count - 1
            Me.SelectedImage = Me.ListView1.SelectedItems(i).ImageIndex
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmIconSelector Fields

frmIconSelector overview

Fields

field Button1
field Button2
field ListView1
field components
field m_imageindex

See Also

frmIconSelector Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


ListView1 Variable

Friend WithEvents ListView1 As System.Windows.Forms.ListView

Source code

[Visual Basic]
    Friend WithEvents ListView1 As System.Windows.Forms.ListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


m_imageindex Variable

Dim m_imageindex As Integer

Source code

[Visual Basic]
    Dim m_imageindex As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmIconSelector


frmInformationsEmpfaenger Class

For a list of all members of this type, see frmInformationsEmpfaenger Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmInformationsEmpfaenger

Public Class frmInformationsEmpfaenger
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmInformationsEmpfaenger Members


frmInformationsEmpfaenger Members

frmInformationsEmpfaenger overview

Constructors

constructor frmInformationsEmpfaenger Constructor

Properties

property Bemerkung
property Dokumenttypnr
property Empaengertext
property Empfaenger
property Meldung
property Meldungsnr
property Mitarbeiterdata
property Statusnr
property Statustext
property Statustyp
property dokumentid
property fromDokumenttyp
property mcbempfaenger
property mcbstatus

Methods

method BtnCancel_Click
method BtnOK_Click
method Dispose
method Generic_Select
method InitializeComponent
method cbStatus_SelectedIndexChanged
method frmInformationsEmpfaenger_Load
method mcbstatus_SelectedValueChanged

Fields

field BtnCancel
field BtnOK
field Label1
field Label2
field Label3
field Label4
field M_fromDokumenttyp
field Statusdata
field cbEmpfaenger
field cbStatus
field components
field m_bemerkung
field m_dokumentid
field m_dokumenttypnr
field m_empfaenger
field m_empfaengertext
field m_meldung
field m_meldungsnr
field m_mitarbeiterdata
field m_statusnr
field m_statustext
field m_statustyp
field mailtextnr
field txtBemerkung
field txtStdmeldung

See Also

frmInformationsEmpfaenger Class


frmInformationsEmpfaenger Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()
        InitializeComponent()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger Properties

frmInformationsEmpfaenger overview

Properties

property Bemerkung
property Dokumenttypnr
property Empaengertext
property Empfaenger
property Meldung
property Meldungsnr
property Mitarbeiterdata
property Statusnr
property Statustext
property Statustyp
property dokumentid
property fromDokumenttyp
property mcbempfaenger
property mcbstatus

See Also

frmInformationsEmpfaenger Class


frmInformationsEmpfaenger.Bemerkung Property

Property Bemerkung() As String

Source code

[Visual Basic]
    Property Bemerkung() As String
        Get
            Return m_bemerkung
        End Get
        Set(ByVal Value As String)
            m_bemerkung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Dokumenttypnr Property

Property Dokumenttypnr() As String

Source code

[Visual Basic]
    Property Dokumenttypnr() As String
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As String)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Empaengertext Property

Property Empaengertext() As String

Source code

[Visual Basic]
    Property Empaengertext() As String
        Get
            Return m_empfaengertext
        End Get
        Set(ByVal Value As String)
            m_empfaengertext = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Empfaenger Property

Property Empfaenger() As Integer

Source code

[Visual Basic]
    Property Empfaenger() As Integer
        Get
            Return m_empfaenger
        End Get
        Set(ByVal Value As Integer)
            m_empfaenger = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Meldung Property

Property Meldung() As String

Source code

[Visual Basic]
    Property Meldung() As String
        Get
            Return m_meldung
        End Get
        Set(ByVal Value As String)
            m_meldung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Meldungsnr Property

Property Meldungsnr() As Integer

Source code

[Visual Basic]
    Property Meldungsnr() As Integer
        Get
            Return m_meldungsnr
        End Get
        Set(ByVal Value As Integer)
            m_meldungsnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Mitarbeiterdata Property

Property Mitarbeiterdata() As DataTable

Source code

[Visual Basic]
    Property Mitarbeiterdata() As DataTable
        Get
            Return m_mitarbeiterdata
        End Get
        Set(ByVal Value As DataTable)
            m_mitarbeiterdata = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Statusnr Property

Property Statusnr() As Integer

Source code

[Visual Basic]
    Property Statusnr() As Integer
        Get
            Return m_statusnr
        End Get
        Set(ByVal Value As Integer)
            m_statusnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Statustext Property

Property Statustext() As String

Source code

[Visual Basic]
    Property Statustext() As String
        Get
            Return m_statustext
        End Get
        Set(ByVal Value As String)
            m_statustext = Value

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Statustyp Property

Property Statustyp() As Integer

Source code

[Visual Basic]
    Property Statustyp() As Integer
        Get
            Return m_statustyp
        End Get
        Set(ByVal Value As Integer)
            m_statustyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.dokumentid Property

Property dokumentid() As String

Source code

[Visual Basic]
    Property dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.fromDokumenttyp Property

Property fromDokumenttyp() As Boolean

Source code

[Visual Basic]
    Property fromDokumenttyp() As Boolean
        Get
            Return M_fromDokumenttyp
        End Get
        Set(ByVal Value As Boolean)
            M_fromDokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


mcbempfaenger Property

Public WithEvents mcbempfaenger As New MultiComboBox()

Source code

[Visual Basic]
    Public WithEvents mcbempfaenger As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


mcbstatus Property

Public WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Public WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger Methods

frmInformationsEmpfaenger overview

Methods

method BtnCancel_Click
method BtnOK_Click
method Dispose
method Generic_Select
method InitializeComponent
method cbStatus_SelectedIndexChanged
method frmInformationsEmpfaenger_Load
method mcbstatus_SelectedValueChanged

See Also

frmInformationsEmpfaenger Class


frmInformationsEmpfaenger.BtnCancel_Click Method

Private Sub BtnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.BtnOK_Click Method

Private Sub BtnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnOK.Click
        Me.Bemerkung = Me.txtBemerkung.Text
        Me.Empaengertext = Me.mcbempfaenger.Text
        Me.Empfaenger = Me.mcbempfaenger.SelectedValue
        Me.Statustext = Me.mcbstatus.Text
        Me.Statusnr = Me.mcbstatus.SelectedValue
        Me.Meldungsnr = Me.mailtextnr
        Me.Meldung = Me.txtStdmeldung.Text
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
                Case 2
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 3))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 3
                    scmCmdToExecute.CommandText = "SP_get_mailtext"
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mailtextnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mailtextnr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@sprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                Case 4
                    scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_StatusSelektion"
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
                    'scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Statustyp))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 99))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case Else
            End Select
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmInformationsEmpfaenger))
        Me.cbEmpfaenger = New System.Windows.Forms.ComboBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbStatus = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtStdmeldung = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.BtnOK = New System.Windows.Forms.Button()
        Me.BtnCancel = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'cbEmpfaenger
        '
        Me.cbEmpfaenger.Location = New System.Drawing.Point(96, 16)
        Me.cbEmpfaenger.Name = "cbEmpfaenger"
        Me.cbEmpfaenger.Size = New System.Drawing.Size(176, 21)
        Me.cbEmpfaenger.TabIndex = 0
        Me.cbEmpfaenger.Text = "ComboBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(80, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Empfänger"
        '
        'cbStatus
        '
        Me.cbStatus.Location = New System.Drawing.Point(96, 40)
        Me.cbStatus.Name = "cbStatus"
        Me.cbStatus.Size = New System.Drawing.Size(176, 21)
        Me.cbStatus.TabIndex = 2
        Me.cbStatus.Text = "ComboBox2"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Bei Status"
        '
        'txtStdmeldung
        '
        Me.txtStdmeldung.Enabled = False
        Me.txtStdmeldung.Location = New System.Drawing.Point(96, 72)
        Me.txtStdmeldung.Multiline = True
        Me.txtStdmeldung.Name = "txtStdmeldung"
        Me.txtStdmeldung.Size = New System.Drawing.Size(416, 72)
        Me.txtStdmeldung.TabIndex = 4
        Me.txtStdmeldung.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 5
        Me.Label3.Text = "Meldung"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(16, 152)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(72, 23)
        Me.Label4.TabIndex = 6
        Me.Label4.Text = "Bemerkung"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(96, 152)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(416, 72)
        Me.txtBemerkung.TabIndex = 7
        Me.txtBemerkung.Text = ""
        '
        'BtnOK
        '
        Me.BtnOK.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.BtnOK.Location = New System.Drawing.Point(16, 240)
        Me.BtnOK.Name = "BtnOK"
        Me.BtnOK.TabIndex = 8
        Me.BtnOK.Text = "&OK"
        '
        'BtnCancel
        '
        Me.BtnCancel.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.BtnCancel.Location = New System.Drawing.Point(440, 240)
        Me.BtnCancel.Name = "BtnCancel"
        Me.BtnCancel.TabIndex = 9
        Me.BtnCancel.Text = "&Abbruch"
        '
        'frmInformationsEmpfaenger
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 269)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnCancel, Me.BtnOK, Me.txtBemerkung, Me.Label4, Me.Label3, Me.txtStdmeldung, Me.Label2, Me.cbStatus, Me.Label1, Me.cbEmpfaenger})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmInformationsEmpfaenger"
        Me.Text = "Informationsempfänger"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.cbStatus_SelectedIndexChanged Method

Private Sub cbStatus_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbStatus.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbStatus_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbStatus.SelectedIndexChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.frmInformationsEmpfaenger_Load Method

Private Sub frmInformationsEmpfaenger_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmInformationsEmpfaenger_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbempfaenger = New MultiComboBox(Me.cbEmpfaenger)
        Me.mcbempfaenger.CheckNullValue = True
        Me.mcbempfaenger.NullValueMessage = MyTxt.gettext(18)
        Me.mcbempfaenger.DisplayColumnName = "name"
        Me.mcbempfaenger.ValueColumnName = "mitarbeiternr"
        Me.mcbempfaenger.Fill_Data(Generic_Select(1), False)

        mcbstatus = New MultiComboBox(Me.cbStatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        If Me.fromDokumenttyp = True Then
            Me.mcbstatus.Fill_Data(Generic_Select(4), False)
            Me.Statusdata = Generic_Select(4)
        Else
            Me.mcbstatus.Fill_Data(Generic_Select(2), False)
            Me.Statusdata = Generic_Select(2)
        End If
        mcbstatus_SelectedValueChanged(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger.mcbstatus_SelectedValueChanged Method

Private Sub mcbstatus_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbstatus.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbstatus_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbstatus.SelectedValueChanged
        Dim i As Integer
        Dim istatus As Int32
        Try
            istatus = Me.mcbstatus.SelectedValue
            mailtextnr = istatus
            Dim dt As DataTable
            dt = Generic_Select(3)
            Try
                Me.txtStdmeldung.Text = dt.Rows(0).Item(4)
            Catch
            End Try
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInformationsEmpfaenger Fields

frmInformationsEmpfaenger overview

Fields

field BtnCancel
field BtnOK
field Label1
field Label2
field Label3
field Label4
field M_fromDokumenttyp
field Statusdata
field cbEmpfaenger
field cbStatus
field components
field m_bemerkung
field m_dokumentid
field m_dokumenttypnr
field m_empfaenger
field m_empfaengertext
field m_meldung
field m_meldungsnr
field m_mitarbeiterdata
field m_statusnr
field m_statustext
field m_statustyp
field mailtextnr
field txtBemerkung
field txtStdmeldung

See Also

frmInformationsEmpfaenger Class


BtnCancel Variable

Friend WithEvents BtnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


BtnOK Variable

Friend WithEvents BtnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


M_fromDokumenttyp Variable

Dim M_fromDokumenttyp As Boolean = False

Source code

[Visual Basic]
    Dim M_fromDokumenttyp As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


Statusdata Variable

Dim Statusdata As New DataTable()

Source code

[Visual Basic]
    Dim Statusdata As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


cbEmpfaenger Variable

Friend WithEvents cbEmpfaenger As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbEmpfaenger As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


cbStatus Variable

Friend WithEvents cbStatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbStatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_bemerkung Variable

Dim m_bemerkung As String

Source code

[Visual Basic]
    Dim m_bemerkung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_dokumenttypnr Variable

Dim m_dokumenttypnr As String

Source code

[Visual Basic]
    Dim m_dokumenttypnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_empfaenger Variable

Dim m_empfaenger As Integer

Source code

[Visual Basic]
    Dim m_empfaenger As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_empfaengertext Variable

Dim m_empfaengertext As String

Source code

[Visual Basic]
    Dim m_empfaengertext As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_meldung Variable

Dim m_meldung As String

Source code

[Visual Basic]
    Dim m_meldung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_meldungsnr Variable

Dim m_meldungsnr As Integer

Source code

[Visual Basic]
    Dim m_meldungsnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_mitarbeiterdata Variable

Dim m_mitarbeiterdata As DataTable

Source code

[Visual Basic]
    Dim m_mitarbeiterdata As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_statusnr Variable

Dim m_statusnr As Integer

Source code

[Visual Basic]
    Dim m_statusnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_statustext Variable

Dim m_statustext As String

Source code

[Visual Basic]
    Dim m_statustext As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


m_statustyp Variable

Dim m_statustyp As Integer

Source code

[Visual Basic]
    Dim m_statustyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


mailtextnr Variable

Dim mailtextnr As Integer

Source code

[Visual Basic]
    Dim mailtextnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


txtStdmeldung Variable

Friend WithEvents txtStdmeldung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtStdmeldung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInformationsEmpfaenger


frmInteressent Class

For a list of all members of this type, see frmInteressent Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmInteressent

Public Class frmInteressent
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmInteressent Members


frmInteressent Members

frmInteressent overview

Constructors

constructor frmInteressent Constructor

Properties

property Display
property Partnernr
property Profilnr

Methods

method Dispose
method Generic_Select
method InitializeComponent
method Interessent_Load
method btnCancel_Click
method btnClose_Click
method btnSave_Click
method frmInteressent_Closing
method txtname_Leave
method txtname_TextChanged
method txtplz_Leave

Fields

field Bereits_beantwortet
field Label1
field Label10
field Label11
field Label12
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field adraufbereitet
field adressarray
field btnCancel
field btnClose
field btnSave
field components
field lblsaldiert
field m_display
field m_partnernr
field m_profilnr
field partner
field returncode
field txtadresse1
field txtadresse2
field txtanrede
field txtbriefanrede
field txterfasser
field txtkurzbezeichnung
field txtname
field txtort
field txtplz
field txtvorname
field txtzhd

See Also

frmInteressent Class


frmInteressent Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent Properties

frmInteressent overview

Properties

property Display
property Partnernr
property Profilnr

See Also

frmInteressent Class


frmInteressent.Display Property

Property Display() As Boolean

Source code

[Visual Basic]
    Property Display() As Boolean
        Get
            Return m_display
        End Get
        Set(ByVal Value As Boolean)
            m_display = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.Partnernr Property

Property Partnernr() As Long

Source code

[Visual Basic]
    Property Partnernr() As Long
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Long)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.Profilnr Property

Property Profilnr() As Integer

Source code

[Visual Basic]
    Property Profilnr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent Methods

frmInteressent overview

Methods

method Dispose
method Generic_Select
method InitializeComponent
method Interessent_Load
method btnCancel_Click
method btnClose_Click
method btnSave_Click
method frmInteressent_Closing
method txtname_Leave
method txtname_TextChanged
method txtplz_Leave

See Also

frmInteressent Class


frmInteressent.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_get_ort"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_check_partner"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@plz", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtplz.Text))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@name", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtname.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vorname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtvorname.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtort.Text))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ret", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            If typ = 2 Then Me.returncode = scmCmdToExecute.Parameters("@ret").Value
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmInteressent))
        Me.btnSave = New System.Windows.Forms.Button()
        Me.btnCancel = New System.Windows.Forms.Button()
        Me.btnClose = New System.Windows.Forms.Button()
        Me.txtvorname = New System.Windows.Forms.TextBox()
        Me.txtname = New System.Windows.Forms.TextBox()
        Me.txtzhd = New System.Windows.Forms.TextBox()
        Me.txtadresse1 = New System.Windows.Forms.TextBox()
        Me.txtadresse2 = New System.Windows.Forms.TextBox()
        Me.txtplz = New System.Windows.Forms.TextBox()
        Me.txtort = New System.Windows.Forms.TextBox()
        Me.txtkurzbezeichnung = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtbriefanrede = New System.Windows.Forms.TextBox()
        Me.txtanrede = New System.Windows.Forms.TextBox()
        Me.adraufbereitet = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.txterfasser = New System.Windows.Forms.TextBox()
        Me.lblsaldiert = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(208, 392)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.TabIndex = 11
        Me.btnSave.Text = "&Speichern"
        '
        'btnCancel
        '
        Me.btnCancel.Location = New System.Drawing.Point(120, 392)
        Me.btnCancel.Name = "btnCancel"
        Me.btnCancel.TabIndex = 10
        Me.btnCancel.Text = "&Abbruch"
        '
        'btnClose
        '
        Me.btnClose.Location = New System.Drawing.Point(168, 392)
        Me.btnClose.Name = "btnClose"
        Me.btnClose.TabIndex = 11
        Me.btnClose.Text = "&Schliessen"
        '
        'txtvorname
        '
        Me.txtvorname.Location = New System.Drawing.Point(120, 48)
        Me.txtvorname.Name = "txtvorname"
        Me.txtvorname.Size = New System.Drawing.Size(248, 20)
        Me.txtvorname.TabIndex = 1
        Me.txtvorname.Text = ""
        '
        'txtname
        '
        Me.txtname.Location = New System.Drawing.Point(120, 72)
        Me.txtname.Name = "txtname"
        Me.txtname.Size = New System.Drawing.Size(248, 20)
        Me.txtname.TabIndex = 2
        Me.txtname.Text = ""
        '
        'txtzhd
        '
        Me.txtzhd.Location = New System.Drawing.Point(120, 96)
        Me.txtzhd.Name = "txtzhd"
        Me.txtzhd.Size = New System.Drawing.Size(248, 20)
        Me.txtzhd.TabIndex = 3
        Me.txtzhd.Text = ""
        '
        'txtadresse1
        '
        Me.txtadresse1.Location = New System.Drawing.Point(120, 120)
        Me.txtadresse1.Name = "txtadresse1"
        Me.txtadresse1.Size = New System.Drawing.Size(248, 20)
        Me.txtadresse1.TabIndex = 4
        Me.txtadresse1.Text = ""
        '
        'txtadresse2
        '
        Me.txtadresse2.Location = New System.Drawing.Point(120, 144)
        Me.txtadresse2.Name = "txtadresse2"
        Me.txtadresse2.Size = New System.Drawing.Size(248, 20)
        Me.txtadresse2.TabIndex = 5
        Me.txtadresse2.Text = ""
        '
        'txtplz
        '
        Me.txtplz.Location = New System.Drawing.Point(120, 168)
        Me.txtplz.Name = "txtplz"
        Me.txtplz.Size = New System.Drawing.Size(60, 20)
        Me.txtplz.TabIndex = 6
        Me.txtplz.Text = ""
        '
        'txtort
        '
        Me.txtort.Location = New System.Drawing.Point(232, 168)
        Me.txtort.Name = "txtort"
        Me.txtort.Size = New System.Drawing.Size(136, 20)
        Me.txtort.TabIndex = 7
        Me.txtort.Text = ""
        '
        'txtkurzbezeichnung
        '
        Me.txtkurzbezeichnung.Location = New System.Drawing.Point(120, 200)
        Me.txtkurzbezeichnung.Name = "txtkurzbezeichnung"
        Me.txtkurzbezeichnung.Size = New System.Drawing.Size(248, 20)
        Me.txtkurzbezeichnung.TabIndex = 8
        Me.txtkurzbezeichnung.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(64, 23)
        Me.Label1.TabIndex = 22
        Me.Label1.Text = "Anrede"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(64, 23)
        Me.Label2.TabIndex = 23
        Me.Label2.Text = "Vorname"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 23)
        Me.Label3.TabIndex = 24
        Me.Label3.Text = "Name / Firma"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 96)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(64, 23)
        Me.Label4.TabIndex = 25
        Me.Label4.Text = "z. Hd."
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 120)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(72, 23)
        Me.Label5.TabIndex = 26
        Me.Label5.Text = "Adresszeile 1"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 144)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(72, 23)
        Me.Label6.TabIndex = 27
        Me.Label6.Text = "Adresszeile 2"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 168)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(64, 23)
        Me.Label7.TabIndex = 28
        Me.Label7.Text = "PLZ"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(200, 168)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(32, 23)
        Me.Label8.TabIndex = 29
        Me.Label8.Text = "Ort"
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(8, 200)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(96, 23)
        Me.Label9.TabIndex = 30
        Me.Label9.Text = "Kurzbezeichnung"
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 224)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(64, 23)
        Me.Label10.TabIndex = 31
        Me.Label10.Text = "Briefanrede"
        '
        'txtbriefanrede
        '
        Me.txtbriefanrede.Location = New System.Drawing.Point(120, 224)
        Me.txtbriefanrede.Name = "txtbriefanrede"
        Me.txtbriefanrede.Size = New System.Drawing.Size(248, 20)
        Me.txtbriefanrede.TabIndex = 9
        Me.txtbriefanrede.Text = ""
        '
        'txtanrede
        '
        Me.txtanrede.Location = New System.Drawing.Point(120, 24)
        Me.txtanrede.Name = "txtanrede"
        Me.txtanrede.Size = New System.Drawing.Size(248, 20)
        Me.txtanrede.TabIndex = 0
        Me.txtanrede.Text = ""
        '
        'adraufbereitet
        '
        Me.adraufbereitet.Enabled = False
        Me.adraufbereitet.Location = New System.Drawing.Point(120, 256)
        Me.adraufbereitet.Multiline = True
        Me.adraufbereitet.Name = "adraufbereitet"
        Me.adraufbereitet.Size = New System.Drawing.Size(248, 101)
        Me.adraufbereitet.TabIndex = 33
        Me.adraufbereitet.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 256)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(112, 16)
        Me.Label11.TabIndex = 34
        Me.Label11.Text = "Aufbereitete Adresse"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 360)
        Me.Label12.Name = "Label12"
        Me.Label12.TabIndex = 35
        Me.Label12.Text = "Erfasst durch"
        '
        'txterfasser
        '
        Me.txterfasser.Location = New System.Drawing.Point(120, 360)
        Me.txterfasser.Name = "txterfasser"
        Me.txterfasser.ReadOnly = True
        Me.txterfasser.Size = New System.Drawing.Size(248, 20)
        Me.txterfasser.TabIndex = 36
        Me.txterfasser.TabStop = False
        Me.txterfasser.Text = ""
        '
        'lblsaldiert
        '
        Me.lblsaldiert.Font = New System.Drawing.Font("Microsoft Sans Serif", 11.25!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.lblsaldiert.ForeColor = System.Drawing.Color.Red
        Me.lblsaldiert.Location = New System.Drawing.Point(8, 392)
        Me.lblsaldiert.Name = "lblsaldiert"
        Me.lblsaldiert.Size = New System.Drawing.Size(144, 24)
        Me.lblsaldiert.TabIndex = 37
        Me.lblsaldiert.Text = "Partner ist saldiert"
        '
        'frmInteressent
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(376, 421)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblsaldiert, Me.txterfasser, Me.Label12, Me.Label11, Me.adraufbereitet, Me.txtanrede, Me.Label10, Me.Label9, Me.Label8, Me.Label7, Me.Label6, Me.Label5, Me.Label4, Me.Label3, Me.Label2, Me.Label1, Me.txtbriefanrede, Me.txtkurzbezeichnung, Me.txtort, Me.txtplz, Me.txtadresse2, Me.txtadresse1, Me.txtzhd, Me.txtname, Me.txtvorname, Me.btnClose, Me.btnCancel, Me.btnSave})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmInteressent"
        Me.Text = "Partner eröffnen / bearbeiten"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.Interessent_Load Method

Private Sub Interessent_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Interessent_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Not Me.Display Then MyMsg.Show_HinweisMessage(Me.Profilnr, 1, 100, 1, True)
        Dim partner As New edokadb.clsPartner()
        Dim s As String
        adressarray(0) = ""
        adressarray(1) = ""
        adressarray(2) = ""
        adressarray(3) = ""
        adressarray(4) = ""
        adressarray(5) = ""
        adressarray(6) = ""
        Me.lblsaldiert.Visible = False

        If Me.Partnernr > 0 Then
            partner.cpMainConnectionProvider = conn
            partner.iNRPAR00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.SelectOne()
            Me.txtanrede.Text = partner.sTXADZ012.Value
            Me.txtvorname.Text = partner.sTXADZ022.Value
            Me.txtname.Text = partner.sTXADZ032.Value
            Me.txtzhd.Text = partner.sTXADZ042.Value
            Me.txtadresse1.Text = partner.sTXADZ052.Value
            Me.txtadresse2.Text = partner.sTXADZ062.Value
            Me.txtplz.Text = partner.sTXADZ072.Value
            Me.txtort.Text = partner.sBEBAN012.Value
            Me.txtkurzbezeichnung.Text = partner.sBKPAR00.Value
            Me.txtbriefanrede.Text = partner.sBEBAN011.Value
            Me.txtkurzbezeichnung.Text = partner.sBKPAR00.Value
            adressarray(0) = partner.sTXADZ011.Value
            adressarray(1) = partner.sTXADZ021.Value
            adressarray(2) = partner.sTXADZ031.Value
            adressarray(3) = partner.sTXADZ041.Value
            adressarray(4) = partner.sTXADZ061.Value
            adressarray(5) = partner.sTXADZ061.Value
            adressarray(6) = partner.sTXADZ071.Value
            If partner.bSaldiert.Value = True Then Me.lblsaldiert.Visible = True Else Me.lblsaldiert.Visible = False
            s = ""
            s = s + adressarray(0) + vbCrLf
            s = s + adressarray(1) + vbCrLf
            s = s + adressarray(2) + vbCrLf
            s = s + adressarray(3) + vbCrLf
            s = s + adressarray(4) + vbCrLf
            s = s + adressarray(5) + vbCrLf
            s = s + adressarray(6)
            Me.adraufbereitet.Text = s
        End If

        Dim ma As New edokadb.clsMitarbeiter()
        Try
            Me.txterfasser.Text = ""
            ma.cpMainConnectionProvider = conn
            ma.iMitarbeiternr = New SqlInt32(CType(partner.iNRFOG012.Value, Int32))
            ma.SelectOne()
            Me.txterfasser.Text = ma.sName.Value + " " + ma.sVorname.Value + ", " + ma.sTgnummer.Value
        Catch
        End Try
        ma.Dispose()
        'Me.txtname_Leave(sender, e)
        If Me.Display = True Then
            Me.btnCancel.Visible = False
            Me.btnSave.Visible = False
            Me.btnClose.Visible = True
        Else
            Me.btnCancel.Visible = True
            Me.btnSave.Visible = True
            Me.btnClose.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.btnCancel_Click Method

Private Sub btnCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnCancel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnCancel.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.btnClose_Click Method

Private Sub btnClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.btnSave_Click Method

Private Sub btnSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        If Len(Me.txtkurzbezeichnung.Text) > 35 Then
            MyMsg.show_standardmessage(106, MsgBoxStyle.Information)
            Me.txtkurzbezeichnung.Focus()
            Exit Sub
        End If
        If Len(Me.txtkurzbezeichnung.Text) < 5 Then
            MyMsg.show_standardmessage(108, MsgBoxStyle.Critical)
            Me.txtkurzbezeichnung.Focus()
            Exit Sub
        End If
        If Len(Me.txtname.Text) < 2 Then
            MyMsg.show_standardmessage(109, MsgBoxStyle.Critical)
            Me.txtname.Focus()
            Exit Sub
        End If
        If Len(Me.txtort.Text) < 2 Then
            MyMsg.show_standardmessage(736, MsgBoxStyle.Critical)
            Me.txtname.Focus()
            Exit Sub
        End If

        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        partner.cpMainConnectionProvider = conn
        If Me.Partnernr = 0 Then
            Dim t As DataTable
            t = Generic_Select(2)
            If Me.returncode <> 0 Then

                If Me.Bereits_beantwortet = False Then
                    Dim pa As New FrmPartnersuche()
                    pa.Meldung_Doppelter_Partner = True
                    pa.NurAbfrage = True
                    pa.AusPartnererfassung = True
                    Me.Cursor = Cursors.WaitCursor
                    pa.Doppelte_Partner(Me.txtname.Text, Me.txtort.Text)
                    Me.Cursor = Cursors.Default
                    pa.TopMost = True
                    pa.ShowDialog()
                    Me.Bereits_beantwortet = True
                    If pa.PartnerNr <> 0 Then
                        Me.Partnernr = pa.PartnerNr
                        Me.Close()
                        Exit Sub
                    End If
                    Exit Sub
                Else
                End If
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("Interessent")
        Else
            partner.iNRPAR00 = New SqlInt32(CType(Me.Partnernr, Int32))
            partner.SelectOne()
        End If
        conn.OpenConnection()
        Me.Cursor = Cursors.WaitCursor
        partner.sBKPAR00 = New SqlString(CType(Me.txtkurzbezeichnung.Text, String))
        partner.sBEBAN012 = New SqlString(CType(Me.txtort.Text, String))
        partner.sTXADZ012 = New SqlString(CType(Me.txtanrede.Text, String))
        partner.sTXADZ022 = New SqlString(CType(Me.txtvorname.Text, String))
        partner.sTXADZ032 = New SqlString(CType(Me.txtname.Text, String))
        partner.sTXADZ042 = New SqlString(CType(Me.txtzhd.Text, String))
        partner.sTXADZ052 = New SqlString(CType(Me.txtadresse1.Text, String))
        partner.sTXADZ062 = New SqlString(CType(Me.txtadresse2.Text, String))
        partner.sTXADZ072 = New SqlString(CType(Me.txtplz.Text, String))
        partner.sTXADZ011 = New SqlString(CType(Me.txtadresse1.Text, String))
        partner.sTXADZ021 = New SqlString(CType(Me.txtadresse2.Text, String))
        partner.sBEBAN011 = New SqlString(CType(Me.txtbriefanrede.Text, String))

        partner.sTXADZ011 = New SqlString(CType(Me.adressarray(0).ToString, String))
        partner.sTXADZ021 = New SqlString(CType(Me.adressarray(1).ToString, String))
        partner.sTXADZ031 = New SqlString(CType(Me.adressarray(2).ToString, String))
        partner.sTXADZ041 = New SqlString(CType(Me.adressarray(3).ToString, String))
        partner.sTXADZ051 = New SqlString(CType(Me.adressarray(4).ToString, String))
        partner.sTXADZ061 = New SqlString(CType(Me.adressarray(5).ToString, String))
        partner.sTXADZ071 = New SqlString(CType(Me.adressarray(6).ToString, String))
        partner.iNRFOG012 = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        partner.sTSMUT00 = New SqlString(CType(Now, String))

        partner.sNRADR00 = New SqlString(CType("", String))
        If Me.Partnernr = 0 Then
            partner.iNRPAR00 = New SqlInt32(CType(key, Int32))
            partner.Insert()
            Me.Partnernr = key
        Else
            partner.Update()
        End If
        conn.CloseConnection(True)
        Me.Cursor = Cursors.Default
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.frmInteressent_Closing Method

Private Sub frmInteressent_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmInteressent_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        partner.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.txtname_Leave Method

Private Sub txtname_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtname.Leave, _
   txtort.Leave, _
   txtanrede.Leave, _
   txtvorname.Leave, _
   txtadresse1.Leave, _
   txtadresse2.Leave, _
   txtzhd.Leave, _
   txtplz.Leave, _
   txtanrede.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtname_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtname.Leave, txtort.Leave, txtanrede.Leave, txtvorname.Leave, txtadresse1.Leave, txtadresse2.Leave, txtzhd.Leave, txtplz.Leave, txtanrede.Enter
        If Me.txtvorname.Text = "" Then
            Me.txtkurzbezeichnung.Text = Me.txtname.Text
            Me.txtbriefanrede.Text = "Damen und Herren"
        Else
            Me.txtkurzbezeichnung.Text = Me.txtvorname.Text + " " + Me.txtname.Text
            Me.txtbriefanrede.Text = Me.txtanrede.Text + " " + Me.txtname.Text
        End If
        If Me.txtort.Text <> "" Then
            Me.txtkurzbezeichnung.Text = Me.txtkurzbezeichnung.Text + ", " + Me.txtort.Text
        End If

        'Adresse
        Dim i As Integer
        For i = 0 To 6
            Me.adressarray(i) = ""
        Next
        i = 0
        If Me.txtanrede.Text <> "" Then
            Me.adressarray(i) = Me.txtanrede.Text
            i = i + 1
        End If
        If Me.txtvorname.Text <> "" Then
            Me.adressarray(i) = Me.txtvorname.Text + " " + Me.txtname.Text
            i = i + 1
        Else
            Me.adressarray(i) = Me.txtname.Text
            i = i + 1
        End If

        If Me.txtzhd.Text <> "" Then
            Me.adressarray(i) = Me.txtzhd.Text
            i = i + 1
        End If
        If Me.txtadresse1.Text <> "" Then
            Me.adressarray(i) = Me.txtadresse1.Text
            i = i + 1
        End If
        If Me.txtadresse2.Text <> "" Then
            Me.adressarray(i) = Me.txtadresse2.Text
            i = i + 1
        End If
        Me.adressarray(i) = Me.txtplz.Text + " " + Me.txtort.Text

        Me.adraufbereitet.Text = ""
        Me.adraufbereitet.Text = Me.adressarray(0) + vbCrLf + Me.adressarray(1) + vbCrLf + Me.adressarray(2) + vbCrLf + Me.adressarray(3) + vbCrLf + Me.adressarray(4) + vbCrLf + Me.adressarray(5) + vbCrLf + Me.adressarray(6)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.txtname_TextChanged Method

Private Sub txtname_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtname.TextChanged, _
   txtort.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtname_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtname.TextChanged, txtort.TextChanged
        Me.Bereits_beantwortet = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent.txtplz_Leave Method

Private Sub txtplz_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtplz.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtplz_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtplz.Leave
        Dim plz As DataTable
        plz = Generic_Select(1)
        If plz.Rows.Count > 0 And Me.txtort.Text = "" Then
            Me.txtort.Text = plz.Rows(0).Item(2)
        End If
        plz.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmInteressent Fields

frmInteressent overview

Fields

field Bereits_beantwortet
field Label1
field Label10
field Label11
field Label12
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field adraufbereitet
field adressarray
field btnCancel
field btnClose
field btnSave
field components
field lblsaldiert
field m_display
field m_partnernr
field m_profilnr
field partner
field returncode
field txtadresse1
field txtadresse2
field txtanrede
field txtbriefanrede
field txterfasser
field txtkurzbezeichnung
field txtname
field txtort
field txtplz
field txtvorname
field txtzhd

See Also

frmInteressent Class


Bereits_beantwortet Variable

Dim Bereits_beantwortet As Boolean = False

Source code

[Visual Basic]
    Dim Bereits_beantwortet As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


adraufbereitet Variable

Friend WithEvents adraufbereitet As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents adraufbereitet As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


adressarray Variable

Dim adressarray( _
   6 _
) As String

Source code

[Visual Basic]
    Dim adressarray(6) As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


btnCancel Variable

Friend WithEvents btnCancel As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnCancel As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


lblsaldiert Variable

Friend WithEvents lblsaldiert As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblsaldiert As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


m_display Variable

Dim m_display As Boolean

Source code

[Visual Basic]
    Dim m_display As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


m_partnernr Variable

Dim m_partnernr As Long

Source code

[Visual Basic]
    Dim m_partnernr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


partner Variable

Dim partner As New edokadb.clsPartner()

Source code

[Visual Basic]
    Dim partner As New edokadb.clsPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


returncode Variable

Dim returncode As Integer

Source code

[Visual Basic]
    Dim returncode As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtadresse1 Variable

Friend WithEvents txtadresse1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtadresse1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtadresse2 Variable

Friend WithEvents txtadresse2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtadresse2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtanrede Variable

Friend WithEvents txtanrede As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtanrede As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtbriefanrede Variable

Friend WithEvents txtbriefanrede As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbriefanrede As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txterfasser Variable

Friend WithEvents txterfasser As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txterfasser As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtkurzbezeichnung Variable

Friend WithEvents txtkurzbezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtkurzbezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtname Variable

Friend WithEvents txtname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtort Variable

Friend WithEvents txtort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtplz Variable

Friend WithEvents txtplz As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtplz As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtvorname Variable

Friend WithEvents txtvorname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtvorname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


txtzhd Variable

Friend WithEvents txtzhd As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzhd As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmInteressent


frmKostenstelle Class

For a list of all members of this type, see frmKostenstelle Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmKostenstelle

Public Class frmKostenstelle
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmKostenstelle Members


frmKostenstelle Members

frmKostenstelle overview

Constructors

constructor frmKostenstelle Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmKostenstelle Class


frmKostenstelle Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle Properties

frmKostenstelle overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmKostenstelle Class


frmKostenstelle Methods

frmKostenstelle overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmKostenstelle Class


frmKostenstelle.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmKostenstelle))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlDataAdapter4 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "marktbereich", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("marktbereichnr", "marktbereichnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_marktbereich_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_marktbereich_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_marktbereich_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_marktbereich_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "niederlassung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("niederlassungnr", "niederlassungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("nlnummer", "nlnummer"), New System.Data.Common.DataColumnMapping("nltyp", "nltyp"), New System.Data.Common.DataColumnMapping("edoka_dokumenterstellung", "edoka_dokumenterstellung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_niederlassung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_niederlassung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_niederlassung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_niederlassung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "kostenstelle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("kostenstellenr", "kostenstellenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("kostenstellenummer", "kostenstellenummer"), New System.Data.Common.DataColumnMapping("dokument_kopfzeile", "dokument_kopfzeile"), New System.Data.Common.DataColumnMapping("marktbereichnr", "marktbereichnr"), New System.Data.Common.DataColumnMapping("niederlassungnr", "niederlassungnr"), New System.Data.Common.DataColumnMapping("bankinformationnr", "bankinformationnr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter4
        '
        Me.SqlDataAdapter4.DeleteCommand = Me.SqlDeleteCommand4
        Me.SqlDataAdapter4.InsertCommand = Me.SqlInsertCommand4
        Me.SqlDataAdapter4.SelectCommand = Me.SqlSelectCommand4
        Me.SqlDataAdapter4.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "bankinformation", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("bankinformationnr", "bankinformationnr"), New System.Data.Common.DataColumnMapping("bankname", "bankname"), New System.Data.Common.DataColumnMapping("adresszeile1", "adresszeile1"), New System.Data.Common.DataColumnMapping("adresszeile2", "adresszeile2"), New System.Data.Common.DataColumnMapping("plz", "plz"), New System.Data.Common.DataColumnMapping("ort", "ort"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("telefax", "telefax"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("internet", "internet"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter4.UpdateCommand = Me.SqlUpdateCommand4
        '
        'SqlDeleteCommand4
        '
        Me.SqlDeleteCommand4.CommandText = "[pv_bankinformatione_delete]"
        Me.SqlDeleteCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand4.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_internet", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "internet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_plz", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "plz", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefax", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand4
        '
        Me.SqlInsertCommand4.CommandText = "[pv_bankinformation_insert]"
        Me.SqlInsertCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand4.Connection = Me.SqlConnection1
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankname", System.Data.SqlDbType.VarChar, 255, "bankname"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile1", System.Data.SqlDbType.VarChar, 255, "adresszeile1"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile2", System.Data.SqlDbType.VarChar, 255, "adresszeile2"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@plz", System.Data.SqlDbType.VarChar, 255, "plz"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ort", System.Data.SqlDbType.VarChar, 255, "ort"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 255, "telefon"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefax", System.Data.SqlDbType.VarChar, 255, "telefax"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 255, "email"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@internet", System.Data.SqlDbType.VarChar, 255, "internet"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[pv_bankinformation_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand4
        '
        Me.SqlUpdateCommand4.CommandText = "[pv_bankinformation_update]"
        Me.SqlUpdateCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand4.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankname", System.Data.SqlDbType.VarChar, 255, "bankname"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile1", System.Data.SqlDbType.VarChar, 255, "adresszeile1"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@adresszeile2", System.Data.SqlDbType.VarChar, 255, "adresszeile2"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@plz", System.Data.SqlDbType.VarChar, 255, "plz"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ort", System.Data.SqlDbType.VarChar, 255, "ort"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 255, "telefon"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefax", System.Data.SqlDbType.VarChar, 255, "telefax"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 255, "email"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@internet", System.Data.SqlDbType.VarChar, 255, "internet"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_adresszeile2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "adresszeile2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_internet", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "internet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ort", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_plz", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "plz", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefax", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.ColumnHeaders = False
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(104, 0)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines1
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(392, 264)
        Me.C1TrueDBDropdown1.TabIndex = 19
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 388, 260</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 388, 260</ClientA" & _
        "rea></Blob>"
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;password="""";persist security info=True;" & _
        "user id=sa;workstation id=SHU;packet size=4096"
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_kostenstelle_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection3
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_kostenstelle_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection3
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenummer", System.Data.SqlDbType.Int, 4, "kostenstellenummer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_kopfzeile", System.Data.SqlDbType.VarChar, 255, "dokument_kopfzeile"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_kostenstelle_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection3
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenummer", System.Data.SqlDbType.Int, 4, "kostenstellenummer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_kopfzeile", System.Data.SqlDbType.VarChar, 255, "dokument_kopfzeile"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@marktbereichnr", System.Data.SqlDbType.Int, 4, "marktbereichnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bankinformationnr", System.Data.SqlDbType.Int, 4, "bankinformationnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_kopfzeile", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_kopfzeile", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_kostenstelle_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection3
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bankinformationnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bankinformationnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_kopfzeile", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_kopfzeile", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_marktbereichnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "marktbereichnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmKostenstelle
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBDropdown1})
        Me.Name = "frmKostenstelle"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsKostenstelle()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iMarktbereichnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    vdata.iNiederlassungnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iNiederlassungnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    vdata.iMarktbereichnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iMarktbereichnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                vdata.iKostenstellenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.iKostenstellenr = New SqlInt32(CType(0, Int32))
            vdata.iBankinformationnr = New SqlInt32(CType(1, Int32))
            vdata.sBezeichnung = New SqlString(CType("Neue Kostenstelle", String))
            vdata.sBeschreibung = New SqlString(CType("", String))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("kostenstelle")
            vdata.iKostenstellenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5014, 5015, 5016)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom

        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
        Me.DataSet4.Clear()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter4.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter4.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter4.Fill(Me.DataSet4)
        Me.C1TrueDBDropdown1.DataSource = Me.DataSet4
        Me.C1TrueDBDropdown1.DataMember = "bankinformation"
        Me.C1TrueDBDropdown1.Columns(0).Caption = MyMsg.Get_Meldungstext(7002)
        Me.C1TrueDBDropdown1.Columns(1).Caption = MyMsg.Get_Meldungstext(7003)
        Me.C1TrueDBDropdown1.DisplayColumns(0).Width = 20
        Try
            Me.TBBottom.Columns("bankinformationnr").DropDown = Me.C1TrueDBDropdown1
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902) + ex.Message)
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "marktbereich"
        Me.TableNameRight = "niederlassung"
        Me.TableNameBottom = "kostenstelle"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmKostenstelle Fields

frmKostenstelle overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field C1TrueDBDropdown1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmKostenstelle Class


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDataAdapter4 Variable

Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlDeleteCommand4 Variable

Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlInsertCommand4 Variable

Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


SqlUpdateCommand4 Variable

Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmKostenstelle


frmLoeschgrund Class

For a list of all members of this type, see frmLoeschgrund Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmLoeschgrund

Public Class frmLoeschgrund
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmLoeschgrund Members


frmLoeschgrund Members

frmLoeschgrund overview

Constructors

constructor frmLoeschgrund Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmLoeschgrund_Load
method mcbloeschgrund_SelectedIndexChanged

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field On_Load
field components
field mcbloeschgrund
field txtLoeschgrund

See Also

frmLoeschgrund Class


frmLoeschgrund Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund Methods

frmLoeschgrund overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmLoeschgrund_Load
method mcbloeschgrund_SelectedIndexChanged

See Also

frmLoeschgrund Class


frmLoeschgrund.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        If Len(Me.txtLoeschgrund.Text) < 20 Then
            MyMsg.show_standardmessage(65, MsgBoxStyle.Critical)
        Else
            Me.DialogResult = DialogResult.OK
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.Generic_Select Method

Private Function Generic_Select() As DataTable

Source code

[Visual Basic]
    Private Function Generic_Select() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_grund"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@grundtyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmLoeschgrund))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtLoeschgrund = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 64)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Löschgrund"
        '
        'txtLoeschgrund
        '
        Me.txtLoeschgrund.Location = New System.Drawing.Point(16, 88)
        Me.txtLoeschgrund.Multiline = True
        Me.txtLoeschgrund.Name = "txtLoeschgrund"
        Me.txtLoeschgrund.Size = New System.Drawing.Size(504, 72)
        Me.txtLoeschgrund.TabIndex = 2
        Me.txtLoeschgrund.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(408, 168)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(112, 23)
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "&Dokument löschen"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.Button2.Location = New System.Drawing.Point(16, 168)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(72, 24)
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(16, 32)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(504, 21)
        Me.ComboBox1.TabIndex = 5
        Me.ComboBox1.Text = "ComboBox1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(160, 16)
        Me.Label2.TabIndex = 6
        Me.Label2.Text = "Auswahl  Löschgrund"
        '
        'frmLoeschgrund
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 197)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label2, Me.ComboBox1, Me.Button2, Me.Button1, Me.txtLoeschgrund, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmLoeschgrund"
        Me.Text = "Dokument löschen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.frmLoeschgrund_Load Method

Private Sub frmLoeschgrund_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmLoeschgrund_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.mcbloeschgrund = New MultiComboBox(Me.ComboBox1)
        Me.mcbloeschgrund.CheckNullValue = False
        Me.mcbloeschgrund.DisplayColumnName = "Grund"
        Me.mcbloeschgrund.ValueColumnName = "grundnr"
        Me.mcbloeschgrund.Fill_Data(Generic_Select, False)
        On_Load = False
        Me.txtLoeschgrund.Focus()
        Me.txtLoeschgrund.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund.mcbloeschgrund_SelectedIndexChanged Method

Private Sub mcbloeschgrund_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbloeschgrund.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbloeschgrund_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbloeschgrund.SelectedIndexChanged
        If On_Load Then Exit Sub
        If Microsoft.VisualBasic.Left(Me.mcbloeschgrund.Text, 1) = "(" Then
            Me.txtLoeschgrund.Focus()
            Me.txtLoeschgrund.SelectAll()
            Me.txtLoeschgrund.Text = ""
            Me.txtLoeschgrund.Enabled = True
        Else
            Me.txtLoeschgrund.Text = Me.mcbloeschgrund.Text
            Me.txtLoeschgrund.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLoeschgrund Fields

frmLoeschgrund overview

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field On_Load
field components
field mcbloeschgrund
field txtLoeschgrund

See Also

frmLoeschgrund Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


mcbloeschgrund Variable

Dim WithEvents mcbloeschgrund As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbloeschgrund As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


txtLoeschgrund Variable

Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLoeschgrund


frmLog Class

For a list of all members of this type, see frmLog Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmLog

Public Class frmLog
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmLog Members


frmLog Members

frmLog overview

Constructors

constructor frmLog Constructor

Methods

method Dispose
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method copydata
method frmLog_Load

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field components
field dt

See Also

frmLog Class


frmLog Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog Methods

frmLog overview

Methods

method Dispose
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method copydata
method frmLog_Load

See Also

frmLog Class


frmLog.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        scmCmdToExecute.CommandText = "dbo.sp_performancelog"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                Case Else
            End Select
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmLog))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(616, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 2
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 3
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AllowUpdate = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.Cursor = System.Windows.Forms.Cursors.Default
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(0, 25)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = True
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(616, 340)
        Me.C1TrueDBGrid1.TabIndex = 26
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 612," & _
        " 336</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 612, " & _
        "336</ClientArea></Blob>"
        '
        'frmLog
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(616, 365)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1, Me.ToolBar1})
        Me.Name = "frmLog"
        Me.Text = "Journal"
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                dt = Generic_Select(2)
                frmLog_Load(sender, e)
            Case 2 'Speichern
                frmLog_Load(sender, e)
            Case 3 'Speichern
                copydata()
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog.copydata Method

Private Sub copydata()

Source code

[Visual Basic]
    Private Sub copydata()
        Dim strTemp As String   'string to be copied to the clipboard
        Dim row As Long
        Dim col As C1.Win.C1TrueDBGrid.C1DataColumn
        Dim cols As Integer, rows As Long
        If Me.C1TrueDBGrid1.SelectedRows.Count > 0 Then
            For Each row In Me.C1TrueDBGrid1.SelectedRows
                For Each col In Me.C1TrueDBGrid1.Columns
                    strTemp = strTemp & col.CellText(row) & vbTab
                Next
                strTemp = strTemp & vbCrLf
            Next
            System.Windows.Forms.Clipboard.SetDataObject(strTemp, False)
        Else
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog.frmLog_Load Method

Private Sub frmLog_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmLog_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        dt = Generic_Select(1)
        Me.C1TrueDBGrid1.DataSource = dt
        Me.C1TrueDBGrid1.DataMember = dt.TableName
        Dim i As Integer
        For i = 0 To Me.C1TrueDBGrid1.Splits(0).DisplayColumns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLog Fields

frmLog overview

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field components
field dt

See Also

frmLog Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


dt Variable

Dim dt As DataTable

Source code

[Visual Basic]
    Dim dt As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLog


frmLogin Class

For a list of all members of this type, see frmLogin Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmLogin

Public Class frmLogin
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmLogin Members


frmLogin Members

frmLogin overview

Constructors

constructor frmLogin Constructor

Properties

property Mitarbeiternr

Methods

method Button1_Click
method Button2_Click
method Dispose
method Handle_enter
method InitializeComponent
method frmLogin_Load

Fields

field Button1
field Button2
field ComboBox1
field DataSet1
field Label1
field cbo
field components
field db
field m_mitarbeiternr

See Also

frmLogin Class


frmLogin Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin Properties

frmLogin overview

Properties

property Mitarbeiternr

See Also

frmLogin Class


frmLogin.Mitarbeiternr Property

Property Mitarbeiternr() As Long

Source code

[Visual Basic]
    Property Mitarbeiternr() As Long
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Long)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin Methods

frmLogin overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Handle_enter
method InitializeComponent
method frmLogin_Load

See Also

frmLogin Class


frmLogin.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            m_mitarbeiternr = Me.cbo.SelectedValue
            db.SelectMitarbeiterWithNr(m_mitarbeiternr)
            db.Dispose()
            Close()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        m_mitarbeiternr = -99999
        db.Dispose()
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin.Handle_enter Method

Private Sub Handle_enter( _
   ByVal sender As System.Object, _
   ByVal e As KeyPressEventArgs _
) Handles cbo.KeyPress

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Handle_enter(ByVal sender As System.Object, ByVal e As KeyPressEventArgs) Handles cbo.KeyPress
        If e.KeyChar = Chr(13) Then
            Button1_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmLogin))
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(32, 32)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(248, 21)
        Me.ComboBox1.TabIndex = 0
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(32, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(136, 23)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Bitte melden Sie sich an"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(32, 72)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(104, 24)
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "&Anmelden"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(176, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(104, 24)
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'frmLogin
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(304, 117)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label1, Me.ComboBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmLogin"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "EDOKA-Anmeldung"
        Me.TopMost = True
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin.frmLogin_Load Method

Private Sub frmLogin_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmLogin_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim db As New edokadb.clsMyMitarbeiter()
        Dim t As DataTable
        db.cpMainConnectionProvider = conn
        t = db.SelectAllMandantMitarbeiter
        cbo = New MultiComboBox(Me.ComboBox1)
        cbo.NullValueMessage = Globals.MyTxt.gettext(18)
        cbo.CheckNullValue = True
        cbo.DisplayColumnName = "namevorname"
        cbo.ValueColumnName = "mitarbeiternr"
        cbo.Fill_Data(t, False)
        Me.ComboBox1.Select()
        Me.ComboBox1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmLogin Fields

frmLogin overview

Fields

field Button1
field Button2
field ComboBox1
field DataSet1
field Label1
field cbo
field components
field db
field m_mitarbeiternr

See Also

frmLogin Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


cbo Variable

Dim WithEvents cbo As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents cbo As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


db Variable

Dim db As New edokadb.clsMyMitarbeiter()

Source code

[Visual Basic]
    Dim db As New edokadb.clsMyMitarbeiter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Long

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmLogin


frmMassenMail Class

For a list of all members of this type, see frmMassenMail Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMassenMail

Public Class frmMassenMail
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMassenMail Members


frmMassenMail Members

frmMassenMail overview

Constructors

constructor frmMassenMail Constructor

Properties

property PartnerEingegeben
property Partnernr
property Profilnr

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method Send_Mail
method VeraList_AfterDelete
method VeraList_Click
method VeraList_KeyDown
method VeraList_MouseDown
method frmMassenMail_Load
method get_data

Fields

field Button1
field Button2
field ContextMenu1
field GroupBox1
field Label1
field Label2
field MenuItem1
field MenuItem2
field ProgressBar1
field Vera
field VeraList
field components
field m_PartnerEingegeben
field m_Partnernr
field m_profilnr
field tv
field txtBetreff
field txtInhalt

See Also

frmMassenMail Class


frmMassenMail Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail Properties

frmMassenMail overview

Properties

property PartnerEingegeben
property Partnernr
property Profilnr

See Also

frmMassenMail Class


frmMassenMail.PartnerEingegeben Property

Property PartnerEingegeben() As Boolean

Source code

[Visual Basic]
    Property PartnerEingegeben() As Boolean
        Get
            Return m_PartnerEingegeben
        End Get
        Set(ByVal Value As Boolean)
            m_PartnerEingegeben = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_Partnernr
        End Get
        Set(ByVal Value As String)
            m_Partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.Profilnr Property

Property Profilnr() As Integer

Source code

[Visual Basic]
    Property Profilnr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail Methods

frmMassenMail overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method Send_Mail
method VeraList_AfterDelete
method VeraList_Click
method VeraList_KeyDown
method VeraList_MouseDown
method frmMassenMail_Load
method get_data

See Also

frmMassenMail Class


frmMassenMail.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.ProgressBar1.Visible = True
        Me.ProgressBar1.Step = 100 / Me.VeraList.Splits(0).Rows.Count - 1
        Me.VeraList.Bookmark = 0
        Dim i As Integer
        For i = 0 To Me.VeraList.Splits(0).Rows.Count - 1
            Me.VeraList.Bookmark = Me.VeraList.Bookmark + 1
            Me.ProgressBar1.PerformStep()
            Send_Mail()
        Next
        MsgBox("Die Meldungen wurden versandt.", MsgBoxStyle.Information)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMassenMail))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtBetreff = New System.Windows.Forms.TextBox()
        Me.txtInhalt = New System.Windows.Forms.TextBox()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.VeraList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.ProgressBar1 = New System.Windows.Forms.ProgressBar()
        Me.GroupBox1.SuspendLayout()
        CType(Me.VeraList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Betreff"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 23)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Inhalt"
        '
        'txtBetreff
        '
        Me.txtBetreff.Location = New System.Drawing.Point(64, 16)
        Me.txtBetreff.Name = "txtBetreff"
        Me.txtBetreff.Size = New System.Drawing.Size(552, 20)
        Me.txtBetreff.TabIndex = 2
        Me.txtBetreff.Text = ""
        '
        'txtInhalt
        '
        Me.txtInhalt.Location = New System.Drawing.Point(64, 40)
        Me.txtInhalt.Multiline = True
        Me.txtInhalt.Name = "txtInhalt"
        Me.txtInhalt.Size = New System.Drawing.Size(552, 128)
        Me.txtInhalt.TabIndex = 3
        Me.txtInhalt.Text = ""
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.VeraList})
        Me.GroupBox1.Location = New System.Drawing.Point(64, 176)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(552, 176)
        Me.GroupBox1.TabIndex = 4
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Betroffene Empfänger"
        '
        'VeraList
        '
        Me.VeraList.AllowColMove = False
        Me.VeraList.AllowColSelect = False
        Me.VeraList.AllowDelete = True
        Me.VeraList.AllowFilter = True
        Me.VeraList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.VeraList.AllowSort = True
        Me.VeraList.AllowUpdate = False
        Me.VeraList.AllowUpdateOnBlur = False
        Me.VeraList.AlternatingRows = True
        Me.VeraList.CaptionHeight = 17
        Me.VeraList.CollapseColor = System.Drawing.Color.Black
        Me.VeraList.ContextMenu = Me.ContextMenu1
        Me.VeraList.Cursor = System.Windows.Forms.Cursors.Default
        Me.VeraList.DataChanged = False
        Me.VeraList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.VeraList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.VeraList.ExpandColor = System.Drawing.Color.Black
        Me.VeraList.FetchRowStyles = True
        Me.VeraList.FilterBar = True
        Me.VeraList.GroupByCaption = "Drag a column header here to group by that column"
        Me.VeraList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.VeraList.Location = New System.Drawing.Point(3, 16)
        Me.VeraList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.VeraList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.VeraList.Name = "VeraList"
        Me.VeraList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.VeraList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.VeraList.PreviewInfo.ZoomFactor = 75
        Me.VeraList.PrintInfo.ShowOptionsDialog = False
        Me.VeraList.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.VeraList.RowDivider = GridLines1
        Me.VeraList.RowHeight = 15
        Me.VeraList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.VeraList.ScrollTips = True
        Me.VeraList.Size = New System.Drawing.Size(546, 157)
        Me.VeraList.TabIndex = 26
        Me.VeraList.Text = "C1TrueDBGrid1"
        Me.VeraList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView AllowColMove=""False"" AllowColSelect=""False"" Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellB" & _
        "order"" RecordSelectorWidth=""17"" DefRecSelWidth=""17"" VerticalScrollGroup=""1"" Hori" & _
        "zontalScrollGroup=""1""><ClientRect>0, 0, 542, 153</ClientRect><BorderSide>0</Bord" & _
        "erSide><CaptionStyle parent=""Heading"" me=""Style10"" /><EditorStyle parent=""Editor" & _
        """ me=""Style2"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle par" & _
        "ent=""FilterBar"" me=""Style27"" /><FooterStyle parent=""Footer"" me=""Style4"" /><Group" & _
        "Style parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style3"" /" & _
        "><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""I" & _
        "nactive"" me=""Style6"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelecto" & _
        "rStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" m" & _
        "e=""Style5"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeVie" & _
        "w></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me" & _
        "=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""C" & _
        "aption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Sel" & _
        "ected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlig" & _
        "htRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow" & _
        """ /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Fil" & _
        "terBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vert" & _
        "Splits><horzSplits>1</horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>17" & _
        "</DefaultRecSelWidth><ClientArea>0, 0, 542, 153</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Dokument anzeigen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Empfänger löschen"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(512, 360)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(96, 23)
        Me.Button1.TabIndex = 5
        Me.Button1.Text = "Mails versenden"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(64, 360)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 6
        Me.Button2.Text = "Abbruch"
        '
        'ProgressBar1
        '
        Me.ProgressBar1.Location = New System.Drawing.Point(64, 360)
        Me.ProgressBar1.Name = "ProgressBar1"
        Me.ProgressBar1.Size = New System.Drawing.Size(440, 23)
        Me.ProgressBar1.TabIndex = 7
        Me.ProgressBar1.Visible = False
        '
        'frmMassenMail
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(624, 389)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.ProgressBar1, Me.Button2, Me.Button1, Me.GroupBox1, Me.txtInhalt, Me.txtBetreff, Me.Label2, Me.Label1})
        Me.Name = "frmMassenMail"
        Me.Text = "Masssenmails aufgrund EDOKA-Trefferliste versenden"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.VeraList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        DivFnkt.ShowDoc(Me.VeraList.Columns("dokumentid").Text, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.VeraList.Delete()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.Send_Mail Method

Private Function Send_Mail() As DataTable

Source code

[Visual Basic]
    Private Function Send_Mail() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_message_insert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@absender", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.VeraList.Columns(0).Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtBetreff.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtInhalt.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.VeraList.Columns(3).Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@weiterleiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.VeraList_AfterDelete Method

Private Sub VeraList_AfterDelete( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles VeraList.AfterDelete, _
   VeraList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub VeraList_AfterDelete(ByVal sender As Object, ByVal e As System.EventArgs) Handles VeraList.AfterDelete, VeraList.AfterInsert
        If Me.VeraList.Splits(0).Rows.Count > 0 Then Me.Button1.Enabled = True Else Me.Button1.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.VeraList_Click Method

Private Sub VeraList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles VeraList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub VeraList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles VeraList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.VeraList_KeyDown Method

Private Sub VeraList_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles VeraList.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub VeraList_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles VeraList.KeyDown
        If e.KeyCode = Keys.Delete Then Me.VeraList.Delete()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.VeraList_MouseDown Method

Private Sub VeraList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles VeraList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub VeraList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles VeraList.MouseDown
        Me.VeraList.Bookmark = Me.VeraList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.frmMassenMail_Load Method

Private Sub frmMassenMail_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMassenMail_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim d As New edokadb.clsMyDokumentart()
        d.FirstEntry = 0
        d.LastEntry = 99999999
        If Me.PartnerEingegeben Then
            d.LoadTreeMenu_Profil(Me.tv, Me.Profilnr, Me.Partnernr, Nothing, 1, 1, True)
        Else
            d.LoadTreeMenu_Profil(Me.tv, Me.Profilnr, 0, Nothing, 1, 0, False)
        End If
        Vera = get_data()
        If Vera.Rows.Count = 0 Then
            MyMsg.show_standardmessage(233, MsgBoxStyle.Information)
            Exit Sub
        End If

        Me.VeraList.DataSource = Vera
        Dim i As Integer
        For i = 0 To Me.VeraList.Splits(0).DisplayColumns.Count - 1
            Me.VeraList.Splits(0).DisplayColumns(i).AutoSize()
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail.get_data Method

Private Function get_data() As DataTable

Source code

[Visual Basic]
    Private Function get_data() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_massenmail"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("SP_Massenmail::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMassenMail Fields

frmMassenMail overview

Fields

field Button1
field Button2
field ContextMenu1
field GroupBox1
field Label1
field Label2
field MenuItem1
field MenuItem2
field ProgressBar1
field Vera
field VeraList
field components
field m_PartnerEingegeben
field m_Partnernr
field m_profilnr
field tv
field txtBetreff
field txtInhalt

See Also

frmMassenMail Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


ProgressBar1 Variable

Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Source code

[Visual Basic]
    Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


Vera Variable

Dim Vera As New DataTable()

Source code

[Visual Basic]
    Dim Vera As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


VeraList Variable

Friend WithEvents VeraList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents VeraList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


m_PartnerEingegeben Variable

Dim m_PartnerEingegeben As Boolean

Source code

[Visual Basic]
    Dim m_PartnerEingegeben As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


m_Partnernr Variable

Dim m_Partnernr As String

Source code

[Visual Basic]
    Dim m_Partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


tv Variable

Dim tv As New TreeView()

Source code

[Visual Basic]
    Dim tv As New TreeView()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


txtBetreff Variable

Friend WithEvents txtBetreff As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBetreff As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


txtInhalt Variable

Friend WithEvents txtInhalt As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtInhalt As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMassenMail


frmMehrfachdruck Class

For a list of all members of this type, see frmMehrfachdruck Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMehrfachdruck

Public Class frmMehrfachdruck
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMehrfachdruck Members


frmMehrfachdruck Members

frmMehrfachdruck overview

Constructors

constructor frmMehrfachdruck Constructor

Methods

method AnzeigePopup
method ContextMenu1_Popup
method DeleteEntryCollection
method Dispose
method DruckAnfrage
method GenAnzeige
method GetDataFromColl
method GetDateiNameFromColl
method InitAnzeige
method InitForm
method InitializeComponent
method StartColdDruckJob
method StartEdokaDruckJob
method UpdateCollection
method minimize_all_childs
method mnuAnzeige_Click
method mnuDurck_Click
method nmuDelete_Click
method nmuRefresh_Click

Fields

field ContextMenu1
field MenuItem2
field StatusBar1
field components
field iJobCounter
field iJobID
field lvDruckauftraege
field lvid_Anzahl
field lvid_Auftrag
field lvid_JobID
field lvid_Status
field lvid_Typ
field m_MenuEintrag
field mnuAnzeige
field mnuDurck
field nmuDelete
field nmuRefresh
field printfilename
field printthread
field sAuftraNR
field tmpColColdData
field tmpColOfficeData

See Also

frmMehrfachdruck Class


frmMehrfachdruck Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck Methods

frmMehrfachdruck overview

Methods

method AnzeigePopup
method ContextMenu1_Popup
method DeleteEntryCollection
method Dispose
method DruckAnfrage
method GenAnzeige
method GetDataFromColl
method GetDateiNameFromColl
method InitAnzeige
method InitForm
method InitializeComponent
method StartColdDruckJob
method StartEdokaDruckJob
method UpdateCollection
method minimize_all_childs
method mnuAnzeige_Click
method mnuDurck_Click
method nmuDelete_Click
method nmuRefresh_Click

See Also

frmMehrfachdruck Class


frmMehrfachdruck.AnzeigePopup Method

Private Sub AnzeigePopup()

Source code

[Visual Basic]
    Private Sub AnzeigePopup()
        Try
            minimize_all_childs()
            Me.Focus()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try

            m_MenuEintrag = lvDruckauftraege.SelectedItems.Item(0).Index
            Console.WriteLine("ContextMenu1_Popup =" & m_MenuEintrag.ToString)
            If lvDruckauftraege.Items(m_MenuEintrag).SubItems(2).Text = "Cold-Druck" Then
                If lvDruckauftraege.Items(m_MenuEintrag).SubItems(4).Text = "Dokument bereit zum drucken" Or _
                   lvDruckauftraege.Items(m_MenuEintrag).SubItems(4).Text = "Fehler beim ausdrucken" Then
                    mnuAnzeige.Enabled = True
                    mnuDurck.Enabled = True
                Else
                    mnuAnzeige.Enabled = False
                    mnuDurck.Enabled = False
                End If
            Else
                mnuAnzeige.Enabled = False
                mnuDurck.Enabled = False
            End If
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.DeleteEntryCollection Method

Private Sub DeleteEntryCollection( _
   ByVal iJobID As Integer _
)

Parameters

iJobID
Required.

Source code

[Visual Basic]
    Private Sub DeleteEntryCollection(ByVal iJobID As Integer)
        'Eintrag aus der Collection entfernen
        Try
            Dim i As Integer
            Dim colSpooler As clsSpooler_Data
            Dim element As DictionaryEntry
            For Each element In _HashDruckanzeige
                colSpooler = element.Value
                If colSpooler.JobID = iJobID Then
                    _HashDruckanzeige.Remove(iJobID)
                    Exit For
                End If
            Next

            System.Threading.Thread.CurrentThread.Sleep(1000)
            InitAnzeige()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.DruckAnfrage Method

Public Function DruckAnfrage( _
   ByVal colColdData As Collection, _
   ByVal colOfficeData As Collection _
)

Parameters

colColdData
Required.
colOfficeData
Required.

Source code

[Visual Basic]
    Public Function DruckAnfrage(ByVal colColdData As Collection, ByVal colOfficeData As Collection)
        Try
            'Auftragsnummer generieren
            sAuftraNR = Now().ToString.Trim
            'JobID's zuweisen
            iJobCounter = iJobCounter + 1
            iJobID(0) = iJobCounter 'JobID Cold
            iJobCounter = iJobCounter + 1
            iJobID(1) = iJobCounter 'JobID Office

            If colColdData.Count > 0 Then
                Dim MehrfachDruckColdThread As Thread
                tmpColColdData = colColdData
                MehrfachDruckColdThread = New Thread(AddressOf StartColdDruckJob)
                MehrfachDruckColdThread.IsBackground = True
                MehrfachDruckColdThread.Name = "EDOKA_MehrfachDruck_" + (iJobCounter - 1).ToString.Trim
                MehrfachDruckColdThread.Start()
                _HashThreads.Add(iJobCounter - 1, MehrfachDruckColdThread)
            End If

            If colOfficeData.Count > 0 Then
                Dim MehrfachDruckEdokaThread As Thread
                tmpColOfficeData = colOfficeData
                MehrfachDruckEdokaThread = New Thread(AddressOf StartEdokaDruckJob)
                MehrfachDruckEdokaThread.IsBackground = True
                MehrfachDruckEdokaThread.Name = "EDOKA_MehrfachDruck_" + iJobCounter.ToString.Trim
                MehrfachDruckEdokaThread.Start()
                _HashThreads.Add(iJobCounter, MehrfachDruckEdokaThread)

            End If
            System.Threading.Thread.CurrentThread.Sleep(1500)
            InitAnzeige()
            AnzeigePopup()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.GenAnzeige Method

Private Sub GenAnzeige( _
   ByVal coltmp As Hashtable, _
   ByRef i As Integer _
)

Parameters

coltmp
Required.
i
Required.

Source code

[Visual Basic]
    Private Sub GenAnzeige(ByVal coltmp As Hashtable, ByRef i As Integer)
        Try
            Dim colSpooler As clsSpooler_Data
            'lvDruckauftraege = New ListView()
            lvDruckauftraege.BeginUpdate()
            Try
                lvDruckauftraege.Items.Clear()
            Catch
                lvDruckauftraege = New ListView()
                Me.lvDruckauftraege.Columns.AddRange(New System.Windows.Forms.ColumnHeader() {Me.lvid_JobID, Me.lvid_Auftrag, Me.lvid_Typ, Me.lvid_Anzahl, Me.lvid_Status})
                Me.lvDruckauftraege.ContextMenu = Me.ContextMenu1
                Me.lvDruckauftraege.FullRowSelect = True
                Me.lvDruckauftraege.GridLines = True
                Me.lvDruckauftraege.MultiSelect = False
                Me.lvDruckauftraege.Name = "lvDruckauftraege"
                Me.lvDruckauftraege.Size = New System.Drawing.Size(480, 88)
                Me.lvDruckauftraege.TabIndex = 2
                Me.lvDruckauftraege.View = System.Windows.Forms.View.Details
            End Try

            lvDruckauftraege.Sorting = SortOrder.None

            Dim element As DictionaryEntry

            For Each element In coltmp
                colSpooler = element.Value
                lvDruckauftraege.Items.Add(colSpooler.JobID.ToString.Trim)
                lvDruckauftraege.Items(i).SubItems.Add(colSpooler.AuftragNr)
                lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Typ)
                lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Anzahl)
                lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Status)
                lvDruckauftraege.Items(i).ForeColor = Color.Black
                If colSpooler.Status = "Dokument bereit zum drucken" Then
                    'grün
                    lvDruckauftraege.Items(i).BackColor = Color.FromArgb(255, 164, 253, 143)
                End If
                If colSpooler.Status = "Fehler beim Drucken" Then
                    'rot
                    lvDruckauftraege.Items(i).BackColor = Color.FromArgb(255, 255, 174, 165)
                End If
                i = i + 1
            Next

            lvDruckauftraege.EndUpdate()

            'Dim Sorter As New clsListViewItemComparer(0)
            'lvDruckauftraege.ListViewItemSorter = Sorter
            'lvDruckauftraege.Sort()

        Catch ex As Exception
            MsgBox("Fehler GenAnzeige: " & ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.GetDataFromColl Method

Private Function GetDataFromColl( _
   ByVal OrgColl As Hashtable, _
   ByVal JobID As Integer _
) As Collection

Parameters

OrgColl
Required.
JobID
Required.

Source code

[Visual Basic]
    Private Function GetDataFromColl(ByVal OrgColl As Hashtable, ByVal JobID As Integer) As Collection
        Try
            Dim tmpData As Hashtable
            Dim i As Integer
            Dim gendok As clsSpooler_Data

            tmpData = OrgColl
            Dim element As DictionaryEntry
            For Each element In _HashDruckanzeige
                gendok = element.Value
                If gendok.JobID = JobID Then
                    'JobID gefunden
                    GetDataFromColl = gendok.Data
                    Exit Try
                End If
            Next
        Catch ex As Exception
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.GetDateiNameFromColl Method

Private Function GetDateiNameFromColl( _
   ByVal OrgColl As Hashtable, _
   ByVal JobID As Integer _
) As String

Parameters

OrgColl
Required.
JobID
Required.

Source code

[Visual Basic]
    Private Function GetDateiNameFromColl(ByVal OrgColl As Hashtable, ByVal JobID As Integer) As String
        Try
            Dim tmpData As Hashtable
            Dim i As Integer
            Dim gendok As clsSpooler_Data

            tmpData = OrgColl
            Dim element As DictionaryEntry
            For Each element In _HashDruckanzeige
                gendok = element.Value
                If gendok.JobID = JobID Then
                    'JobID gefunden
                    GetDateiNameFromColl = gendok.DateiName
                    Exit Try
                End If
            Next
        Catch ex As Exception

        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.InitAnzeige Method

Private Sub InitAnzeige()

Source code

[Visual Basic]
    Private Sub InitAnzeige()
        If iMerker = 1 Then
            Exit Sub
        End If
        Try
            iMerker = 1

            Dim ColTrans As ColorTranslator
            System.Threading.Thread.CurrentThread.Sleep(1000)
            If lvDruckauftraege.Items.Count = 0 Then
                StatusBar1.Text = "keine Druckaufträge"
                If Me.Visible = True Then
                    Me.Visible = False
                End If
            End If

            'Anzeige aktualisieren
            'Dim coltmp As Collection
            Dim coltmp As Hashtable
            Dim colSpooler As clsSpooler_Data
            coltmp = _HashDruckanzeige

            Dim i As Integer
            i = 0

            GenAnzeige(coltmp, i)
            'Try

            '    lvDruckauftraege.Items.Clear()
            '    lvDruckauftraege.BeginUpdate()
            '    Dim element As DictionaryEntry
            '    For Each element In coltmp
            '        'For i = 1 To coltmp.Count
            '        colSpooler = element.Value
            '        'colSpooler = coltmp(i)
            '        lvDruckauftraege.Items.Add(colSpooler.JobID)
            '        lvDruckauftraege.Items(i).SubItems.Add(colSpooler.AuftragNr)
            '        lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Typ)
            '        lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Anzahl)
            '        lvDruckauftraege.Items(i).SubItems.Add(colSpooler.Status)
            '        If colSpooler.Status = "Dokument bereit zum drucken" Then
            '            'grün
            '            lvDruckauftraege.Items(i).BackColor = Color.FromArgb(255, 164, 253, 143)
            '        End If
            '        If colSpooler.Status = "Fehler beim Drucken" Then
            '            'rot
            '            lvDruckauftraege.Items(i).BackColor = Color.FromArgb(255, 255, 174, 165)
            '        End If
            '        i &= 1
            '    Next
            '    lvDruckauftraege.EndUpdate()
            'Catch ex As Exception
            '    MsgBox("Fehler4: " & ex.Message)
            'End Try

            Try
                'Statusbar aktualisieren
                If i > 0 Then
                    Me.StatusBar1.Text = "Anzahl Druckaufträge " + i.ToString.Trim
                    If Me.Visible = False Then
                        Me.Top = Me.ParentForm.ClientSize.Height - Me.Height - 50
                        Me.Left = Me.ParentForm.ClientSize.Width - Me.Width - 30
                        minimize_all_childs()
                        Me.Visible = True
                    Else
                        minimize_all_childs()
                    End If
                Else
                    StatusBar1.Text = "keine Druckaufträge"
                    If Me.Visible = True Then
                        Me.Visible = False
                    End If
                End If
            Catch ex As Exception
                MsgBox("Fehler1: " & ex.Message)
            End Try

        Catch ex As Exception
            MsgBox("Fehler3: " & ex.Message)
        Finally
            iMerker = 0
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.InitForm Method

Public Sub InitForm()

Source code

[Visual Basic]
    Public Sub InitForm()
        Try
            Me.Visible = False
            StatusBar1.Text = "Druckspooler initialisieren"
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.lvDruckauftraege = New System.Windows.Forms.ListView()
        Me.lvid_JobID = New System.Windows.Forms.ColumnHeader()
        Me.lvid_Auftrag = New System.Windows.Forms.ColumnHeader()
        Me.lvid_Typ = New System.Windows.Forms.ColumnHeader()
        Me.lvid_Anzahl = New System.Windows.Forms.ColumnHeader()
        Me.lvid_Status = New System.Windows.Forms.ColumnHeader()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuAnzeige = New System.Windows.Forms.MenuItem()
        Me.mnuDurck = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.nmuDelete = New System.Windows.Forms.MenuItem()
        Me.nmuRefresh = New System.Windows.Forms.MenuItem()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.SuspendLayout()
        '
        'lvDruckauftraege
        '
        Me.lvDruckauftraege.Columns.AddRange(New System.Windows.Forms.ColumnHeader() {Me.lvid_JobID, Me.lvid_Auftrag, Me.lvid_Typ, Me.lvid_Anzahl, Me.lvid_Status})
        Me.lvDruckauftraege.ContextMenu = Me.ContextMenu1
        Me.lvDruckauftraege.FullRowSelect = True
        Me.lvDruckauftraege.GridLines = True
        Me.lvDruckauftraege.MultiSelect = False
        Me.lvDruckauftraege.Name = "lvDruckauftraege"
        Me.lvDruckauftraege.Size = New System.Drawing.Size(480, 88)
        Me.lvDruckauftraege.TabIndex = 2
        Me.lvDruckauftraege.View = System.Windows.Forms.View.Details
        '
        'lvid_JobID
        '
        Me.lvid_JobID.Text = "JobID"
        Me.lvid_JobID.Width = 0
        '
        'lvid_Auftrag
        '
        Me.lvid_Auftrag.Text = "Auftrag"
        Me.lvid_Auftrag.Width = 120
        '
        'lvid_Typ
        '
        Me.lvid_Typ.Text = "Typ"
        Me.lvid_Typ.Width = 90
        '
        'lvid_Anzahl
        '
        Me.lvid_Anzahl.Text = "Anzahl"
        Me.lvid_Anzahl.Width = 70
        '
        'lvid_Status
        '
        Me.lvid_Status.Text = "Status"
        Me.lvid_Status.Width = 180
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuAnzeige, Me.mnuDurck, Me.MenuItem2, Me.nmuDelete, Me.nmuRefresh})
        '
        'mnuAnzeige
        '
        Me.mnuAnzeige.Index = 0
        Me.mnuAnzeige.Text = "Dokument Anzeigen"
        '
        'mnuDurck
        '
        Me.mnuDurck.Index = 1
        Me.mnuDurck.Text = "Drucken"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'nmuDelete
        '
        Me.nmuDelete.Index = 3
        Me.nmuDelete.Text = "Auftrag löschen"
        '
        'nmuRefresh
        '
        Me.nmuRefresh.Index = 4
        Me.nmuRefresh.Text = "Auftrag erneut anfordern"
        '
        'StatusBar1
        '
        Me.StatusBar1.Location = New System.Drawing.Point(0, 88)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(482, 22)
        Me.StatusBar1.TabIndex = 3
        '
        'frmMehrfachdruck
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(482, 110)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.StatusBar1, Me.lvDruckauftraege})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmMehrfachdruck"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.Manual
        Me.Text = "Druckaufträge"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.StartColdDruckJob Method

Private Sub StartColdDruckJob()

Source code

[Visual Basic]
    Private Sub StartColdDruckJob()
        Dim sThreadName As String
        Dim iColdJobID As Integer = iJobID(0)
        sThreadName = "EDOKA_MehrfachDruck_" + iColdJobID.ToString.Trim
        Try
            Dim tmpData As Collection
            Dim gendok As clsMehrfachdruck_Data
            Dim rReturn As Object

            Dim timestamp As String
            Dim pdfFileName As String
            Dim sJobNummer As String

            timestamp = Format(Now, "yyyyMMddHHmmss")
            sJobNummer = iColdJobID.ToString.Trim
            Do While Len(sJobNummer) < 4
                sJobNummer = "0" & sJobNummer
            Loop
            pdfFileName = timestamp + "_" + sJobNummer + ".pdf"
            tmpData = tmpColColdData

            'colDruckanzeige.Add(New clsSpooler_Data(iColdJobID, sAuftraNR, "Cold-Druck", "Daten Aufbereitung", tmpData.Count.ToString.Trim, tmpData, Now(), 1, pdfFileName))
            Dim newDruckRow As New clsSpooler_Data(iColdJobID, sAuftraNR, "Cold-Druck", "Daten Aufbereitung", tmpData.Count.ToString.Trim, tmpData, Now(), 1, pdfFileName)
            _HashDruckanzeige.Add(iColdJobID, newDruckRow)

            Console.WriteLine("StartColdDruckJob - JobID=" & iColdJobID.ToString)

            'Wenn mehrere Dokumente gedruckt werden sollen
            Dim i As Integer
            Dim tmp1 As New DataTable()

            tmp1.Columns.Add("DokumentId")
            tmp1.Columns.Add("PartnerNr")
            tmp1.Columns.Add("Typ")
            tmp1.Columns.Add("OfficeDokument")
            tmp1.Columns.Add("DokumentTyp")
            tmp1.Columns.Add("Auftragnr")
            tmp1.Columns.Add("PartnerName")
            tmp1.Columns.Add("Erstellungsdatum")

            Dim row As DataRow

            For i = 1 To tmpData.Count
                gendok = tmpData(i)
                row = tmp1.NewRow
                row.Item("Auftragnr") = gendok.Auftragnr
                row.Item("DokumentId") = gendok.DokumentId
                row.Item("DokumentTyp") = gendok.DokumentTyp
                row.Item("Erstellungsdatum") = gendok.Erstellungsdatum
                row.Item("OfficeDokument") = gendok.OfficeDokument
                row.Item("PartnerName") = gendok.PartnerName
                row.Item("PartnerNr") = gendok.PartnerNr
                Select Case gendok.Typ
                    Case clsMehrfachdruck_Data.Enum_Typ.EDOKA
                        row.Item("Typ") = 1
                    Case clsMehrfachdruck_Data.Enum_Typ.HOST
                        row.Item("Typ") = 2
                    Case clsMehrfachdruck_Data.Enum_Typ.ZV
                        row.Item("Typ") = 3
                End Select

                tmp1.Rows.Add(row)
            Next

            'Cold Dokumente
            For i = 1 To tmpData.Count
                gendok = tmpData(i)
                If gendok.OfficeDokument = False Then
                    DivFnkt.Journal_Dokumentzugriff(gendok.DokumentId, "COLD-Print", 0, 0, "", "")
                End If
            Next

            'Dokumente anfordern
            UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Cold-Dokument anfordern")
            Dim remoteObj As EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07
            Dim Obj As New Object()
            Obj = Activator.GetObject( _
                       GetType(EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07), _
                        System.Configuration.ConfigurationSettings.AppSettings("RemoteObjUrl"))

            ' Auf das Remote-Objekt durch die Schnittstelle zugreifen.
            remoteObj = CType(Obj, EDKB07Verarbeitung.EDKB07Verarbeitung.IEDKB07)
            Try
                remoteObj.GetColdMehrfachDruck(Globals.TGNummer, iColdJobID, tmp1, rReturn)
                'remoteObj = Nothing

                'Dokument erhalten
                UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Cold-Dokument empfangen und speichern")

                Try
                    If rReturn.Length > 1 Then
                        Dim fs As New FileStream(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") & pdfFileName, FileMode.OpenOrCreate, FileAccess.Write)
                        fs.Write(rReturn, 0, rReturn.Length)
                        fs.Close()
                        fs = Nothing
                        Dim s As String
                        UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Dokument bereit zum drucken")
                    Else
                        UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Fehler beim Drucken")
                    End If
                Catch ex As Exception
                    Console.WriteLine("StartColdDruckJob - JobID=" & iColdJobID.ToString & " Fehler 1: " & ex.Message)
                    UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Fehler beim Drucken")
                Finally
                    InitAnzeige()
                    AnzeigePopup()
                End Try

            Catch ex As Exception
                Console.WriteLine("StartColdDruckJob - JobID=" & iColdJobID.ToString & " Fehler 2: " & ex.Message)
                UpdateCollection(iColdJobID, enum_MehrfachdruckFeld.Status, "Fehler beim Drucken")
                InitAnzeige()
                AnzeigePopup()
            End Try

        Catch ex As Exception
            Console.WriteLine("StartColdDruckJob - JobID=" & iColdJobID.ToString & " Fehler 3: " & ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.StartEdokaDruckJob Method

Private Sub StartEdokaDruckJob()

Source code

[Visual Basic]
    Private Sub StartEdokaDruckJob()
        Try
            Dim tmpData As Collection
            Dim iOfficeJobID As Integer = iJobID(1)
            Dim gendok As clsMehrfachdruck_Data
            tmpData = tmpColOfficeData

            Console.WriteLine("StartEdokaDruckJob - JobID=" & iOfficeJobID.ToString)

            'colDruckanzeige.Add(New clsSpooler_Data(iOfficeJobID, sAuftraNR, "Office-Druck", "am drucken", tmpData.Count.ToString.Trim, tmpData, Now(), 1, ""))
            Dim newDruckRow As New clsSpooler_Data(iOfficeJobID, sAuftraNR, "Office-Druck", "am drucken", tmpData.Count.ToString.Trim, tmpData, Now(), 1, "")
            _HashDruckanzeige.Add(iOfficeJobID, newDruckRow)

            System.Threading.Thread.CurrentThread.Sleep(2000)

            'Office Dokumente
            Dim i As Integer
            For i = 1 To tmpData.Count
                gendok = tmpData(i)
                If gendok.OfficeDokument = True Then
                    Console.WriteLine("StartEdokaDruckJob - Vor Drucken=" & iOfficeJobID.ToString)
                    DivFnkt.print_office(gendok.DokumentId, Nothing, False)
                    Console.WriteLine("StartEdokaDruckJob - Nach Drucken=" & iOfficeJobID.ToString)
                    'Druckauftrag anpassen
                    UpdateCollection(iOfficeJobID, enum_MehrfachdruckFeld.Anzahl, i.ToString.Trim + " von " + tmpData.Count.ToString.Trim)
                    If i = tmpData.Count Then
                        UpdateCollection(iOfficeJobID, enum_MehrfachdruckFeld.Status, "gedruckt")
                    End If
                    InitAnzeige()
                End If
            Next
            'Eintrag Löschen
            DeleteEntryCollection(iOfficeJobID)
        Catch ex As Exception
            Console.WriteLine("StartEdokaDruckJob - Fehler =" & ex.Message)
            'MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.UpdateCollection Method

Private Sub UpdateCollection( _
   ByVal iJobID As Integer, _
   ByVal iTyp As enum_MehrfachdruckFeld, _
   ByVal sWert As String _
)

Parameters

iJobID
Required.
iTyp
Required.
sWert
Required.

Source code

[Visual Basic]
    Private Sub UpdateCollection(ByVal iJobID As Integer, ByVal iTyp As enum_MehrfachdruckFeld, ByVal sWert As String)
        'Wert in der Collection updaten
        Try
            Dim i As Integer
            Dim colSpooler As clsSpooler_Data
            Dim element As DictionaryEntry
            For Each element In _HashDruckanzeige
                colSpooler = element.Value
                If colSpooler.JobID = iJobID Then
                    Select Case iTyp
                        Case enum_MehrfachdruckFeld.Anzahl
                            colSpooler.Anzahl = sWert
                        Case enum_MehrfachdruckFeld.Status
                            colSpooler.Status = sWert
                    End Select
                    Exit For
                End If
            Next
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.minimize_all_childs Method

Private Sub minimize_all_childs()

Source code

[Visual Basic]
    Private Sub minimize_all_childs()
        Dim c As Form
        For Each c In Me.ParentForm.MdiChildren
            c.WindowState = FormWindowState.Normal
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.mnuAnzeige_Click Method

Private Sub mnuAnzeige_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuAnzeige.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuAnzeige_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuAnzeige.Click
        Dim iJobID As Integer
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim tmpCollData As New Collection()
            Dim tmpCollLeer As New Collection()
            Dim sDateiName As String

            iJobID = lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text

            sDateiName = GetDateiNameFromColl(_HashDruckanzeige, iJobID)
            sDateiName = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") & sDateiName

            'Dokument Drucken
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "Cold-Dokument drucken")

            Dim objpdf As New clsPDF_print_show()
            objpdf.PrintPDF(sDateiName, clsPDF_print_show.Enum_Art.Anzeigen)
            'print_pdf(sDateiName)

            'Abgeschlossen
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "gedruckt")

            'Eintrag Löschen
            DeleteEntryCollection(iJobID)

        Catch ex As Exception
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "Fehler beim ausdrucken")
        Finally
            Me.Cursor = Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.mnuDurck_Click Method

Private Sub mnuDurck_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDurck.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDurck_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDurck.Click
        Dim iJobID As Integer
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim tmpCollData As New Collection()
            Dim tmpCollLeer As New Collection()
            Dim sDateiName As String

            iJobID = lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text

            sDateiName = GetDateiNameFromColl(_HashDruckanzeige, iJobID)
            sDateiName = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") & sDateiName

            'Dokument Drucken
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "Cold-Dokument drucken")

            Dim objpdf As New clsPDF_print_show()
            objpdf.PrintPDF(sDateiName, clsPDF_print_show.Enum_Art.Drucken)
            'print_pdf(sDateiName)

            'Abgeschlossen
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "gedruckt")

            'Eintrag Löschen
            DeleteEntryCollection(iJobID)

        Catch ex As Exception
            UpdateCollection(iJobID, enum_MehrfachdruckFeld.Status, "Fehler beim ausdrucken")
        Finally
            Me.Cursor = Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.nmuDelete_Click Method

Private Sub nmuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles nmuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub nmuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles nmuDelete.Click
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim iJobID As Integer
            iJobID = lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text

            Console.WriteLine("nmuDelete_Click =" & m_MenuEintrag.ToString & " JobID " & iJobID.ToString)

            Try
                Dim MehrfachDruckThread As Thread
                MehrfachDruckThread = _HashThreads.Item(iJobID)
                MehrfachDruckThread.Abort()
            Catch ex As Exception
                Console.WriteLine("nmuDelete_Click 1=" & m_MenuEintrag.ToString & ex.Message)
            End Try
            DeleteEntryCollection(iJobID)
        Catch ex As Exception
            Console.WriteLine("nmuDelete_Click 2=" & m_MenuEintrag.ToString & ex.Message)
        Finally
            Me.Cursor = Cursors.Default
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck.nmuRefresh_Click Method

Private Sub nmuRefresh_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles nmuRefresh.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub nmuRefresh_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles nmuRefresh.Click
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim tmpCollData As New Collection()
            Dim tmpCollLeer As New Collection()
            'tmpCollData = GetDataFromColl(colDruckanzeige, lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text)
            tmpCollData = GetDataFromColl(_HashDruckanzeige, lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text)

            If lvDruckauftraege.Items(m_MenuEintrag).SubItems(2).Text = "Cold-Druck" Then
                DruckAnfrage(tmpCollData, tmpCollLeer)
            Else
                DruckAnfrage(tmpCollLeer, tmpCollData)
            End If

            If lvDruckauftraege.Items(m_MenuEintrag).SubItems(4).Text = "Fehler beim Drucken" Then
                DeleteEntryCollection(lvDruckauftraege.Items(m_MenuEintrag).SubItems(0).Text())
            Else
                InitAnzeige()
            End If

        Catch ex As Exception
        Finally
            Me.Cursor = Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMehrfachdruck Fields

frmMehrfachdruck overview

Fields

field ContextMenu1
field MenuItem2
field StatusBar1
field components
field iJobCounter
field iJobID
field lvDruckauftraege
field lvid_Anzahl
field lvid_Auftrag
field lvid_JobID
field lvid_Status
field lvid_Typ
field m_MenuEintrag
field mnuAnzeige
field mnuDurck
field nmuDelete
field nmuRefresh
field printfilename
field printthread
field sAuftraNR
field tmpColColdData
field tmpColOfficeData

See Also

frmMehrfachdruck Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


iJobCounter Variable

Dim iJobCounter As Integer = 0

Source code

[Visual Basic]
    Dim iJobCounter As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


iJobID Variable

Dim iJobID( _
   1 _
) As Integer

Source code

[Visual Basic]
    Dim iJobID(1) As Integer 'Job ID's für den Office und Cold Thread

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvDruckauftraege Variable

Friend WithEvents lvDruckauftraege As System.Windows.Forms.ListView

Source code

[Visual Basic]
    Friend WithEvents lvDruckauftraege As System.Windows.Forms.ListView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvid_Anzahl Variable

Friend WithEvents lvid_Anzahl As System.Windows.Forms.ColumnHeader

Source code

[Visual Basic]
    Friend WithEvents lvid_Anzahl As System.Windows.Forms.ColumnHeader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvid_Auftrag Variable

Friend WithEvents lvid_Auftrag As System.Windows.Forms.ColumnHeader

Source code

[Visual Basic]
    Friend WithEvents lvid_Auftrag As System.Windows.Forms.ColumnHeader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvid_JobID Variable

Friend WithEvents lvid_JobID As System.Windows.Forms.ColumnHeader

Source code

[Visual Basic]
    Friend WithEvents lvid_JobID As System.Windows.Forms.ColumnHeader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvid_Status Variable

Friend WithEvents lvid_Status As System.Windows.Forms.ColumnHeader

Source code

[Visual Basic]
    Friend WithEvents lvid_Status As System.Windows.Forms.ColumnHeader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


lvid_Typ Variable

Friend WithEvents lvid_Typ As System.Windows.Forms.ColumnHeader

Source code

[Visual Basic]
    Friend WithEvents lvid_Typ As System.Windows.Forms.ColumnHeader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


m_MenuEintrag Variable

Dim m_MenuEintrag As Integer

Source code

[Visual Basic]
    Dim m_MenuEintrag As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


mnuAnzeige Variable

Friend WithEvents mnuAnzeige As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAnzeige As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


mnuDurck Variable

Friend WithEvents mnuDurck As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDurck As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


nmuDelete Variable

Friend WithEvents nmuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents nmuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


nmuRefresh Variable

Friend WithEvents nmuRefresh As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents nmuRefresh As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


printfilename Variable

Dim printfilename As String

Source code

[Visual Basic]
    Dim printfilename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


printthread Variable

Dim printthread As Thread

Source code

[Visual Basic]
    Dim printthread As Thread

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


sAuftraNR Variable

Dim sAuftraNR As String

Source code

[Visual Basic]
    Dim sAuftraNR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


tmpColColdData Variable

Dim tmpColColdData As Collection

Source code

[Visual Basic]
    Dim tmpColColdData As Collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


tmpColOfficeData Variable

Dim tmpColOfficeData As Collection

Source code

[Visual Basic]
    Dim tmpColOfficeData As Collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMehrfachdruck


frmMeldungen Class

For a list of all members of this type, see frmMeldungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMeldungen

Public Class frmMeldungen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMeldungen Members


frmMeldungen Members

frmMeldungen overview

Constructors

constructor frmMeldungen Constructor

Properties

property propBetreff
property propDokID
property propEmpfaenger
property propMeldungText
property propWithDokID

Methods

method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Check_NewMessage
method DateTimePicker1_TextChanged
method Daten_Aktualisieren
method Dispose
method Generic_Select
method InitializeComponent
method MCBSTV_SelectedValueChanged
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method TimerFired
method ToolBar1_ButtonClick
method frmMeldungen_Closing
method frmMeldungen_Load
method frmMitarbeitereinstellungen_Resize
method meldunglist_Click
method meldunglist_KeyUp
method meldunglist_MouseUp

Events

event NeueMeldung

Fields

field BtnHelp
field Button1
field Button2
field Button3
field ContextMenu1
field DateTimePicker1
field GroupBox1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field LabelAn
field LabelBetreff
field LabelDatum
field LabelVon
field LblDatumDokInfo
field MCBSTV
field Meldungsnr
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MyTimer
field On_Load
field Panel1
field Panel2
field Splitter1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field bWithDokID
field betreff
field cbstellvertreter
field components
field datentyp
field dokumentid
field empfaenger
field meldungen
field meldunglist
field meldungstext

See Also

frmMeldungen Class


frmMeldungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen Properties

frmMeldungen overview

Properties

property propBetreff
property propDokID
property propEmpfaenger
property propMeldungText
property propWithDokID

See Also

frmMeldungen Class


frmMeldungen.propBetreff Property

WriteOnly Property propBetreff() As String

Source code

[Visual Basic]
    WriteOnly Property propBetreff() As String
        Set(ByVal Value As String)
            betreff = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.propDokID Property

WriteOnly Property propDokID() As String

Source code

[Visual Basic]
    WriteOnly Property propDokID() As String
        Set(ByVal Value As String)
            dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.propEmpfaenger Property

WriteOnly Property propEmpfaenger() As Integer

Source code

[Visual Basic]
    WriteOnly Property propEmpfaenger() As Integer
        Set(ByVal Value As Integer)
            empfaenger = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.propMeldungText Property

WriteOnly Property propMeldungText() As String

Source code

[Visual Basic]
    WriteOnly Property propMeldungText() As String
        Set(ByVal Value As String)
            meldungstext = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.propWithDokID Property

WriteOnly Property propWithDokID() As Boolean

Source code

[Visual Basic]
    WriteOnly Property propWithDokID() As Boolean
        Set(ByVal Value As Boolean)
            bWithDokID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen Methods

frmMeldungen overview

Methods

method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button3_Click_1
method Check_NewMessage
method DateTimePicker1_TextChanged
method Daten_Aktualisieren
method Dispose
method Generic_Select
method InitializeComponent
method MCBSTV_SelectedValueChanged
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method TimerFired
method ToolBar1_ButtonClick
method frmMeldungen_Closing
method frmMeldungen_Load
method frmMitarbeitereinstellungen_Resize
method meldunglist_Click
method meldunglist_KeyUp
method meldunglist_MouseUp

See Also

frmMeldungen Class


frmMeldungen.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("edokameldungen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim t As DataTable
        t = DivFnkt.Berechtigte_Mitarbeiter(0, Globals.MitarbeiterNr, 0, Me.meldunglist.Columns("dokumentid").Value, 1, 0, 0, 0, "")
        If t.Rows.Count = 0 Then
            MyMsg.show_standardmessage(41, MsgBoxStyle.Critical)
            Exit Sub
        End If
        DivFnkt.ShowDoc(Me.meldunglist.Columns("dokumentid").Value, Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Try
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim t As DataTable
            t = Generic_Select(7)
            If t.Rows.Count > 0 Then
                Globals.profilnr = 0
                Dim f As New frmTrefferliste()
                f.MdiParent = Me.MdiParent
                f.Show()
                f.Partner_Eingegeben = True
                f.txtnrpar00.Text = LTrim(t.Rows(0).Item("NRPAR00"))
                f.refresh_list()
                f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))
                Me.Cursor = System.Windows.Forms.Cursors.Default
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim D As New edokadb.clsDokument()
        Try
            D.cpMainConnectionProvider = conn
            D.sDokumentid = New SqlString(CType(Me.dokumentid, String))
            D.SelectOne()
            D.daErinnerungam = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
            conn.OpenConnection()
            D.Update()
            conn.CloseConnection(True)
            'Rel 3.3
            '06.12.2004 / BUD
            Dim daDatum As DateTime
            daDatum = CType(Me.DateTimePicker1.Value, DateTime)
            Me.LblDatumDokInfo.Text = daDatum.ToShortDateString ' D.daArchivierungsdatum.ToString
            D.Dispose()
            Me.Button3.Enabled = False
        Catch
        Finally
            D.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Check_NewMessage Method

Private Sub Check_NewMessage()

Source code

[Visual Basic]
    Private Sub Check_NewMessage()
        Dim t As DataTable
        Me.datentyp = 1
        t = Generic_Select(1)
        If t.Rows.Count > 0 Then
            'RaiseEvent NeueMeldung()

            'Me.WindowState = FormWindowState.Normal
            MyTimer.Stop()
            If MyMsg.Show_MessageYesNo(40) = MsgBoxResult.Yes Then
                Daten_Aktualisieren(1)
                Me.WindowState = FormWindowState.Normal
                MyTimer.Start()
            End If
        End If
        t.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.DateTimePicker1_TextChanged Method

Private Sub DateTimePicker1_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker1.TextChanged
        Me.Button3.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Daten_Aktualisieren Method

Private Sub Daten_Aktualisieren( _
   ByVal typ As Integer _
)

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Sub Daten_Aktualisieren(ByVal typ As Integer)
        Me.datentyp = typ
        Me.meldunglist.DataSource = Nothing
        Me.meldungen.Rows.Clear()
        Me.meldungen = Generic_Select(1)
        Me.meldunglist.DataSource = Me.meldungen
        DivFnkt.SpaltenTitel_Aktualisieren(Me.meldunglist, Me.meldungen, "message")

        Dim bmp0 As New Bitmap(Me.ImageList1.Images(1))
        Dim bmp1 As New Bitmap(Me.ImageList1.Images(2))
        Dim bmp2 As New Bitmap(Me.ImageList1.Images(3))
        Dim bmp3 As New Bitmap(Me.ImageList1.Images(4))

        Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
        v0.DisplayValue = bmp0
        v0.Value = 1

        v1.DisplayValue = bmp1
        v1.Value = 2

        v2.DisplayValue = bmp2
        v2.Value = 3
        v3.DisplayValue = bmp3
        v3.Value = 4
        Me.meldunglist.Columns(0).ValueItems.Values.Add(v0)
        Me.meldunglist.Columns(0).ValueItems.Values.Add(v1)
        Me.meldunglist.Columns(0).ValueItems.Values.Add(v2)
        Me.meldunglist.Columns(0).ValueItems.Values.Add(v3)
        Me.meldunglist.Columns(0).ValueItems.Translate = True
        Me.meldunglist.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.Generic_Select Method

Public Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Public Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_message_getmessage"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_message_setgelesen"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_message_setungelesen"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_message_setgeloescht"
            Case 5
                scmCmdToExecute.CommandText = "dbo.SP_message_insert"
            Case 6
                scmCmdToExecute.CommandText = "dbo.SP_message_insert"
            Case 7
                scmCmdToExecute.CommandText = "dbo.SP_message_getPartner_Profil"
            Case 8
                scmCmdToExecute.CommandText = "dbo.SP_message_getstellvertreter"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    If Me.MCBSTV.SelectedValue Is System.DBNull.Value Or Me.MCBSTV.SelectedValue = Nothing Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.MCBSTV.SelectedValue))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.datentyp))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@messagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Meldungsnr))
                Case 3
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@messagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Meldungsnr))
                Case 4
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@messagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Meldungsnr))
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@absender", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, empfaenger))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, betreff))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldungstext))
                    If Me.Button1.Enabled = True Or bWithDokID = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    Else
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@weiterleiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@absender", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@empfaenger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, empfaenger))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, betreff))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldungstext))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@weiterleiten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 7
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 8
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMeldungen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.meldunglist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.LblDatumDokInfo = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.LabelAn = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.LabelDatum = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.LabelBetreff = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.LabelVon = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.cbstellvertreter = New System.Windows.Forms.ComboBox()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.meldunglist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.Panel2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4, Me.ToolBarButton5, Me.ToolBarButton6, Me.ToolBarButton7})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(800, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Fenster schliessen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 5
        Me.ToolBarButton3.ToolTipText = "Alle Meldungen anzeigen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 1
        Me.ToolBarButton4.ToolTipText = "Nicht gelesene Meldungen"
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 2
        Me.ToolBarButton5.ToolTipText = "gelesene Meldungen"
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 3
        Me.ToolBarButton6.ToolTipText = "gelöschte Meldungen"
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.ImageIndex = 4
        Me.ToolBarButton7.ToolTipText = "gesendete Meldungen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'meldunglist
        '
        Me.meldunglist.AllowFilter = True
        Me.meldunglist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.meldunglist.AllowSort = True
        Me.meldunglist.AlternatingRows = True
        Me.meldunglist.CaptionHeight = 17
        Me.meldunglist.CollapseColor = System.Drawing.Color.Black
        Me.meldunglist.ContextMenu = Me.ContextMenu1
        Me.meldunglist.DataChanged = False
        Me.meldunglist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.meldunglist.Dock = System.Windows.Forms.DockStyle.Top
        Me.meldunglist.ExpandColor = System.Drawing.Color.Black
        Me.meldunglist.FilterBar = True
        Me.meldunglist.GroupByCaption = "Drag a column header here to group by that column"
        Me.meldunglist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.meldunglist.Location = New System.Drawing.Point(0, 25)
        Me.meldunglist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.meldunglist.Name = "meldunglist"
        Me.meldunglist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.meldunglist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.meldunglist.PreviewInfo.ZoomFactor = 75
        Me.meldunglist.PrintInfo.ShowOptionsDialog = False
        Me.meldunglist.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.meldunglist.RowDivider = GridLines1
        Me.meldunglist.RowHeight = 15
        Me.meldunglist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.meldunglist.ScrollTips = False
        Me.meldunglist.Size = New System.Drawing.Size(800, 201)
        Me.meldunglist.TabIndex = 1
        Me.meldunglist.Text = "C1TrueDBGrid1"
        Me.meldunglist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 19" & _
        "2;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightTex" & _
        "t;BackColor:Highlight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading" & _
        "{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;Ali" & _
        "gnVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9" & _
        "{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowS" & _
        "tyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" " & _
        "FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""17"" DefRec" & _
        "SelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0" & _
        ", 796, 197</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" m" & _
        "e=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""E" & _
        "venRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterS" & _
        "tyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><He" & _
        "adingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRo" & _
        "w"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle par" & _
        "ent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Styl" & _
        "e11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=" & _
        """Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""" & _
        """ me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me" & _
        "=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""I" & _
        "nactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edi" & _
        "tor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Eve" & _
        "nRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordS" & _
        "elector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""G" & _
        "roup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layou" & _
        "t>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><ClientArea>0, 0, 796," & _
        " 197</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4, Me.MenuItem6, Me.MenuItem5, Me.MenuItem7})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Als ungelesen markieren"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Als gelesen markieren"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 3
        Me.MenuItem4.Text = "&Meldung löschen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 4
        Me.MenuItem6.Text = "-"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 5
        Me.MenuItem5.Text = "&Weiterleiten"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 6
        Me.MenuItem7.Text = "&Neue Meldung erstellen"
        '
        'Splitter1
        '
        Me.Splitter1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter1.Location = New System.Drawing.Point(0, 226)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(800, 3)
        Me.Splitter1.TabIndex = 2
        Me.Splitter1.TabStop = False
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox1, Me.Panel2})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel1.Location = New System.Drawing.Point(0, 229)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(800, 328)
        Me.Panel1.TabIndex = 3
        '
        'TextBox1
        '
        Me.TextBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TextBox1.Location = New System.Drawing.Point(0, 80)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(800, 248)
        Me.TextBox1.TabIndex = 2
        Me.TextBox1.Text = ""
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.Button2, Me.LabelAn, Me.Label1, Me.LabelDatum, Me.Label5, Me.LabelBetreff, Me.Label3, Me.LabelVon, Me.Label2, Me.Button1})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(800, 80)
        Me.Panel2.TabIndex = 1
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.LblDatumDokInfo, Me.Label6, Me.Label4, Me.Button3, Me.DateTimePicker1})
        Me.GroupBox1.Location = New System.Drawing.Point(496, 4)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(304, 72)
        Me.GroupBox1.TabIndex = 25
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Überfällig-Meldung"
        Me.GroupBox1.Visible = False
        '
        'LblDatumDokInfo
        '
        Me.LblDatumDokInfo.Location = New System.Drawing.Point(128, 48)
        Me.LblDatumDokInfo.Name = "LblDatumDokInfo"
        Me.LblDatumDokInfo.Size = New System.Drawing.Size(112, 16)
        Me.LblDatumDokInfo.TabIndex = 28
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 24)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(96, 16)
        Me.Label6.TabIndex = 27
        Me.Label6.Text = "nächste Meldung:"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 48)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(136, 16)
        Me.Label4.TabIndex = 26
        Me.Label4.Text = "in Dok.info. gespeichert:"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(224, 16)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(72, 24)
        Me.Button3.TabIndex = 25
        Me.Button3.Text = "Speichern"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 20)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(88, 20)
        Me.DateTimePicker1.TabIndex = 23
        '
        'Button2
        '
        Me.Button2.Enabled = False
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(0, 53)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 21
        '
        'LabelAn
        '
        Me.LabelAn.Location = New System.Drawing.Point(56, 24)
        Me.LabelAn.Name = "LabelAn"
        Me.LabelAn.Size = New System.Drawing.Size(200, 16)
        Me.LabelAn.TabIndex = 20
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 16)
        Me.Label1.TabIndex = 19
        Me.Label1.Text = "An:"
        '
        'LabelDatum
        '
        Me.LabelDatum.Location = New System.Drawing.Point(312, 8)
        Me.LabelDatum.Name = "LabelDatum"
        Me.LabelDatum.Size = New System.Drawing.Size(112, 16)
        Me.LabelDatum.TabIndex = 18
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(256, 8)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(48, 16)
        Me.Label5.TabIndex = 17
        Me.Label5.Text = "Datum:"
        '
        'LabelBetreff
        '
        Me.LabelBetreff.Location = New System.Drawing.Point(104, 56)
        Me.LabelBetreff.Name = "LabelBetreff"
        Me.LabelBetreff.Size = New System.Drawing.Size(384, 16)
        Me.LabelBetreff.TabIndex = 16
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(56, 56)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(40, 16)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "Betreff"
        '
        'LabelVon
        '
        Me.LabelVon.Location = New System.Drawing.Point(56, 8)
        Me.LabelVon.Name = "LabelVon"
        Me.LabelVon.Size = New System.Drawing.Size(200, 16)
        Me.LabelVon.TabIndex = 14
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 16)
        Me.Label2.TabIndex = 12
        Me.Label2.Text = "Von:"
        '
        'Button1
        '
        Me.Button1.Enabled = False
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(24, 53)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 10
        '
        'cbstellvertreter
        '
        Me.cbstellvertreter.Location = New System.Drawing.Point(150, 2)
        Me.cbstellvertreter.Name = "cbstellvertreter"
        Me.cbstellvertreter.Size = New System.Drawing.Size(179, 21)
        Me.cbstellvertreter.TabIndex = 22
        Me.cbstellvertreter.Text = "ComboBox1"
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(776, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 36
        '
        'frmMeldungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(800, 557)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.cbstellvertreter, Me.Panel1, Me.Splitter1, Me.meldunglist, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmMeldungen"
        Me.Text = "EDOKA-Meldungen"
        CType(Me.meldunglist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MCBSTV_SelectedValueChanged Method

Private Sub MCBSTV_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MCBSTV.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MCBSTV_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles MCBSTV.SelectedValueChanged
        If Not On_Load Then Me.Daten_Aktualisieren(1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim I As Integer
        Dim a As Integer
        Dim savebookmark As Integer = Me.meldunglist.Bookmark
        colRows = Me.meldunglist.SelectedRows
        If colRows.Count > 0 Then
            For I = 0 To colRows.Count - 1
                Me.Meldungsnr = Me.meldunglist.Columns("Messagenr").CellValue(colRows(I))
                For a = 0 To Me.meldunglist.Splits(0).Rows.Count - 1
                    If Me.meldunglist.Columns("messagenr").CellValue(a) = Me.Meldungsnr Then
                        Me.meldunglist.Bookmark = a
                        Me.meldunglist.Columns("Status").Value = 1
                        Generic_Select(3)
                    End If
                Next
            Next I
            Me.meldunglist.Bookmark = savebookmark
        Else
            Try
                Me.meldunglist.Columns("status").Value = 1
                Me.Meldungsnr = Me.meldunglist.Columns("messagenr").Value
                Generic_Select(3)
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim I As Integer
        Dim a As Integer
        colRows = Me.meldunglist.SelectedRows
        Dim savebookmark As Integer = Me.meldunglist.Bookmark
        If colRows.Count > 0 Then
            For I = 0 To colRows.Count - 1
                Me.Meldungsnr = Me.meldunglist.Columns("Messagenr").CellValue(colRows(I))
                For a = 0 To Me.meldunglist.Splits(0).Rows.Count - 1
                    If Me.meldunglist.Columns("messagenr").CellValue(a) = Me.Meldungsnr Then
                        Me.meldunglist.Bookmark = a
                        Me.meldunglist.Columns("Status").Value = 2
                        Generic_Select(2)
                    End If
                Next
            Next I
            Me.meldunglist.Bookmark = savebookmark
        Else
            Try
                Me.meldunglist.Columns("status").Value = 2
                Me.Meldungsnr = Me.meldunglist.Columns("messagenr").Value
                Generic_Select(2)
            Catch
            End Try

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim I As Integer
        Dim a As Integer
        Dim savebookmark As Integer = Me.meldunglist.Bookmark
        colRows = Me.meldunglist.SelectedRows
        If colRows.Count > 0 Then
            For I = 0 To colRows.Count - 1
                Me.Meldungsnr = Me.meldunglist.Columns("Messagenr").CellValue(colRows(I))
                For a = 0 To Me.meldunglist.Splits(0).Rows.Count - 1
                    If Me.meldunglist.Columns("messagenr").CellValue(a) = Me.Meldungsnr Then
                        Me.meldunglist.Bookmark = a
                        Me.meldunglist.Columns("Status").Value = 3
                        Generic_Select(4)
                    End If
                Next
            Next I
            Me.meldunglist.Bookmark = savebookmark
        Else
            Try
                Me.meldunglist.Columns("status").Value = 3
                Me.Meldungsnr = Me.meldunglist.Columns("messagenr").Value
                Generic_Select(4)
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Dim f As New frmMessageWeiterleitung()
        f.TextBox1.Text = ""
        f.TextBox2.Text = "WG:" & Me.meldunglist.Columns("titel").Text
        f.TextBox2.Enabled = False
        f.ShowDialog()
        If f.Empfaenger > 0 Then
            Me.meldungstext = f.Meldungstext + vbCrLf + vbCrLf + vbCrLf + _
                              "---------- Ursprüngliche Nachricht ----------" + vbCrLf + _
                              "Gesendet von: " + Me.meldunglist.Columns("absender").Text + vbCrLf + _
                              "Gesendet am:  " + Me.meldunglist.Columns("erstellt_am").Text + vbCrLf + vbCrLf + vbCrLf + _
                              Me.meldunglist.Columns("meldung").Text
            Me.empfaenger = f.Empfaenger
            Me.betreff = f.TextBox2.Text
            Generic_Select(5)
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        'Neue Meldung erstellen
        Dim f As New frmMessageWeiterleitung()
        Me.dokumentid = ""
        f.TextBox1.Text = ""
        f.TextBox2.Enabled = True
        f.ShowDialog()
        If f.Empfaenger > 0 Then
            Me.meldungstext = f.Meldungstext
            Me.empfaenger = f.Empfaenger
            Me.betreff = f.TextBox2.Text
            Generic_Select(5)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.TimerFired Method

Public Sub TimerFired( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles MyTimer.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub TimerFired(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles MyTimer.Elapsed
        Check_NewMessage()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 2
                Me.Daten_Aktualisieren(99)
            Case 3
                Me.Daten_Aktualisieren(1)
            Case 4
                Me.Daten_Aktualisieren(2)
            Case 5
                Me.Daten_Aktualisieren(3)
            Case 6
                Me.Daten_Aktualisieren(4)
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.frmMeldungen_Closing Method

Private Sub frmMeldungen_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMeldungen_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        '        e.Cancel = True
        '       Me.WindowState = FormWindowState.Minimized
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.frmMeldungen_Load Method

Private Sub frmMeldungen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMeldungen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim stv As New DataTable()
        stv = Generic_Select(8)
        Me.MCBSTV = New MultiComboBox(Me.cbstellvertreter)
        Me.MCBSTV.CheckNullValue = True
        Me.MCBSTV.NullValueMessage = MyTxt.gettext(18)
        Me.MCBSTV.DisplayColumnName = "Mitarbeiter"
        Me.MCBSTV.ValueColumnName = "mitarbeiternr"
        Me.MCBSTV.Fill_Data(stv, False)
        Dim ii As Integer
        Dim i As Integer
        ii = Globals.MitarbeiterNr
        Me.MCBSTV.SelectedValue = ii
        Me.MCBSTV.BringToFront()
        Me.cbstellvertreter.SelectedValue = ii
        If stv.Rows.Count > 1 Then
            Me.cbstellvertreter.Visible = True
            Me.MCBSTV.Visible = True
        Else
            Me.cbstellvertreter.Visible = False
            Me.MCBSTV.Visible = False
        End If
        Daten_Aktualisieren(1)
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.MCBSTV, Globals.MyTxt.gettext(22008))
        AddHandler MyTimer.Elapsed, AddressOf TimerFired
        On_Load = False
        'MyTimer.Start()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.frmMitarbeitereinstellungen_Resize Method

Private Sub frmMitarbeitereinstellungen_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMitarbeitereinstellungen_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.meldunglist_Click Method

Private Sub meldunglist_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles meldunglist.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub meldunglist_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles meldunglist.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.meldunglist_KeyUp Method

Private Sub meldunglist_KeyUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles meldunglist.KeyUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub meldunglist_KeyUp(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles meldunglist.KeyUp
        Try
            Me.TextBox1.Text = Me.meldunglist.Columns("meldung").Text
            Me.LabelVon.Text = Me.meldunglist.Columns("absender").Text
            Me.LabelAn.Text = Me.meldunglist.Columns("empfaenger").Text
            Me.LabelDatum.Text = Me.meldunglist.Columns("erstellt_am").Text
            Me.LabelBetreff.Text = Me.meldunglist.Columns("titel").Text
            Me.GroupBox1.Visible = False

            If Me.meldunglist.Columns("status").Value = 1 Then
                Me.meldunglist.Columns("status").Value = 2
                Me.Meldungsnr = Me.meldunglist.Columns("messagenr").Value
                Generic_Select(2)
            End If
            If Me.meldunglist.Columns("dokumentid").Text <> "" Then
                Me.dokumentid = Me.meldunglist.Columns("dokumentid").Text
                Me.Button1.Enabled = True
                Me.Button2.Enabled = True
                Me.LblDatumDokInfo.Text = ""
                If InStr(Me.LabelBetreff.Text, "Terminerreichung") > 0 Or InStr(Me.LabelBetreff.Text, "überfällig") > 0 Or InStr(Me.LabelBetreff.Text, "Erinnerung") > 0 Then
                    Dim d As New edokadb.clsDokument()
                    d.cpMainConnectionProvider = conn
                    d.sDokumentid = New SqlString(CType(Me.dokumentid, String))
                    d.SelectOne()
                    Dim da As DateTime
                    da = DateAdd(DateInterval.Day, 3, Now)
                    'Rel 3.3
                    '15.11.2004 / BUD
                    Try
                        'Prüfen ob bereits ein Datum in den Dokumentinformationen erfasst ist.
                        If IsDate(d.daErinnerungam.Value) = True And (d.daErinnerungam.Value.ToString) <> "01.01.1900 00:00:00" Then
                            Me.LblDatumDokInfo.Text = d.daErinnerungam.Value.ToShortDateString
                            'Falls das Dokinfo Datum älter oder gleich Heute ist, Vorschlag anzeigen
                            If CDate(d.daErinnerungam.Value.ToShortDateString) <= CDate(Now.ToShortDateString) Then
                                Me.DateTimePicker1.Value = da
                            Else
                                Me.DateTimePicker1.Value = d.daErinnerungam.Value
                            End If

                        Else
                            Me.DateTimePicker1.Value = da
                        End If
                    Catch
                        Me.DateTimePicker1.Value = da
                    End Try
                    Me.GroupBox1.Visible = True
                    d.Dispose()
                End If
            Else
                Me.Button1.Enabled = False
                Me.Button2.Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen.meldunglist_MouseUp Method

Private Sub meldunglist_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles meldunglist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub meldunglist_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles meldunglist.MouseUp
        Try
            Me.TextBox1.Text = Me.meldunglist.Columns("meldung").Text
            Me.LabelVon.Text = Me.meldunglist.Columns("absender").Text
            Me.LabelAn.Text = Me.meldunglist.Columns("empfaenger").Text
            Me.LabelDatum.Text = Me.meldunglist.Columns("erstellt_am").Text
            Me.LabelBetreff.Text = Me.meldunglist.Columns("titel").Text
            Me.GroupBox1.Visible = False

            If Me.meldunglist.Columns("status").Value = 1 Then
                Me.meldunglist.Columns("status").Value = 2
                Me.Meldungsnr = Me.meldunglist.Columns("messagenr").Value
                Generic_Select(2)
            End If
            If Me.meldunglist.Columns("dokumentid").Text <> "" Then
                Me.dokumentid = Me.meldunglist.Columns("dokumentid").Text
                Me.Button1.Enabled = True
                Me.Button2.Enabled = True
                Me.LblDatumDokInfo.Text = ""
                If InStr(Me.LabelBetreff.Text, "Terminerreichung") > 0 Or InStr(Me.LabelBetreff.Text, "überfällig") > 0 Or InStr(Me.LabelBetreff.Text, "Erinnerung") > 0 Then
                    Dim d As New edokadb.clsDokument()
                    d.cpMainConnectionProvider = conn
                    d.sDokumentid = New SqlString(CType(Me.dokumentid, String))
                    d.SelectOne()
                    Dim da As DateTime
                    da = DateAdd(DateInterval.Day, 3, Now)
                    'Rel 3.3
                    '15.11.2004 / BUD
                    Try
                        'Prüfen ob bereits ein Datum in den Dokumentinformationen erfasst ist.
                        If IsDate(d.daErinnerungam.Value) = True And (d.daErinnerungam.Value.ToString) <> "01.01.1900 00:00:00" Then
                            Me.LblDatumDokInfo.Text = d.daErinnerungam.Value.ToShortDateString
                            'Falls das Dokinfo Datum älter oder gleich Heute ist, Vorschlag anzeigen
                            If CDate(d.daErinnerungam.Value.ToShortDateString) <= CDate(Now.ToShortDateString) Then
                                Me.DateTimePicker1.Value = da
                            Else
                                Me.DateTimePicker1.Value = d.daErinnerungam.Value
                            End If

                        Else
                            Me.DateTimePicker1.Value = da
                        End If
                    Catch
                        Me.DateTimePicker1.Value = da
                    End Try
                    Me.GroupBox1.Visible = True
                    d.Dispose()
                End If
            Else
                Me.Button1.Enabled = False
                Me.Button2.Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen Events

frmMeldungen overview

Events

event NeueMeldung

See Also

frmMeldungen Class


NeueMeldung Event

Public Event NeueMeldung()

Source code

[Visual Basic]
    Public Event NeueMeldung()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMeldungen Fields

frmMeldungen overview

Fields

field BtnHelp
field Button1
field Button2
field Button3
field ContextMenu1
field DateTimePicker1
field GroupBox1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field LabelAn
field LabelBetreff
field LabelDatum
field LabelVon
field LblDatumDokInfo
field MCBSTV
field Meldungsnr
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MyTimer
field On_Load
field Panel1
field Panel2
field Splitter1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field bWithDokID
field betreff
field cbstellvertreter
field components
field datentyp
field dokumentid
field empfaenger
field meldungen
field meldunglist
field meldungstext

See Also

frmMeldungen Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


LabelAn Variable

Friend WithEvents LabelAn As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelAn As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


LabelBetreff Variable

Friend WithEvents LabelBetreff As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelBetreff As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


LabelDatum Variable

Friend WithEvents LabelDatum As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelDatum As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


LabelVon Variable

Friend WithEvents LabelVon As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LabelVon As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


LblDatumDokInfo Variable

Friend WithEvents LblDatumDokInfo As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LblDatumDokInfo As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MCBSTV Variable

Dim WithEvents MCBSTV As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents MCBSTV As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Meldungsnr Variable

Dim Meldungsnr As Integer

Source code

[Visual Basic]
    Dim Meldungsnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


MyTimer Variable

Dim WithEvents MyTimer As New System.Timers.Timer( _
   700000 _
)

Source code

[Visual Basic]
    Dim WithEvents MyTimer As New System.Timers.Timer(700000)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


bWithDokID Variable

Dim bWithDokID As Boolean

Source code

[Visual Basic]
    Dim bWithDokID As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


betreff Variable

Dim betreff As String

Source code

[Visual Basic]
    Dim betreff As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


cbstellvertreter Variable

Friend WithEvents cbstellvertreter As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbstellvertreter As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


datentyp Variable

Dim datentyp As Integer

Source code

[Visual Basic]
    Dim datentyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


dokumentid Variable

Dim dokumentid As String

Source code

[Visual Basic]
    Dim dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


empfaenger Variable

Dim empfaenger As Integer

Source code

[Visual Basic]
    Dim empfaenger As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


meldungen Variable

Dim meldungen As New DataTable()

Source code

[Visual Basic]
    Dim meldungen As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


meldunglist Variable

Friend WithEvents meldunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents meldunglist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


meldungstext Variable

Dim meldungstext As String

Source code

[Visual Basic]
    Dim meldungstext As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMeldungen


frmMessageWeiterleitung Class

For a list of all members of this type, see frmMessageWeiterleitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMessageWeiterleitung

Public Class frmMessageWeiterleitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMessageWeiterleitung Members


frmMessageWeiterleitung Members

frmMessageWeiterleitung overview

Constructors

constructor frmMessageWeiterleitung Constructor

Properties

property Empfaenger
property Meldungstext
property propBezeichnung
property propINFO
property propPartnerNR

Methods

method Button1_Click
method Button2_Click
method ChechMeldungEmpfang
method Dispose
method Form1_Load
method Generic_Select
method InitializeComponent

Fields

field Button1
field Button2
field Label1
field Label2
field Label3
field TextBox1
field TextBox2
field cbMitarbeiter
field components
field m_Bezeichnung
field m_INFO
field m_PartnerNR
field m_empfaenger
field m_meldungstext
field mcbmitarbeiter
field txtBez
field txtBezText
field txtDokID
field txtPartnerID
field txtPartnerIDText
field txtdokIDText

See Also

frmMessageWeiterleitung Class


frmMessageWeiterleitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung Properties

frmMessageWeiterleitung overview

Properties

property Empfaenger
property Meldungstext
property propBezeichnung
property propINFO
property propPartnerNR

See Also

frmMessageWeiterleitung Class


frmMessageWeiterleitung.Empfaenger Property

Property Empfaenger() As Integer

Source code

[Visual Basic]
    Property Empfaenger() As Integer
        Get
            Return m_empfaenger
        End Get
        Set(ByVal Value As Integer)
            m_empfaenger = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.Meldungstext Property

Property Meldungstext() As String

Source code

[Visual Basic]
    Property Meldungstext() As String
        Get
            Return m_meldungstext
        End Get
        Set(ByVal Value As String)
            m_meldungstext = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.propBezeichnung Property

WriteOnly Property propBezeichnung() As String

Source code

[Visual Basic]
    WriteOnly Property propBezeichnung() As String
        Set(ByVal Value As String)
            m_Bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.propINFO Property

WriteOnly Property propINFO() As String

Source code

[Visual Basic]
    WriteOnly Property propINFO() As String
        Set(ByVal Value As String)
            m_INFO = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.propPartnerNR Property

WriteOnly Property propPartnerNR() As String

Source code

[Visual Basic]
    WriteOnly Property propPartnerNR() As String
        Set(ByVal Value As String)
            m_PartnerNR = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung Methods

frmMessageWeiterleitung overview

Methods

method Button1_Click
method Button2_Click
method ChechMeldungEmpfang
method Dispose
method Form1_Load
method Generic_Select
method InitializeComponent

See Also

frmMessageWeiterleitung Class


frmMessageWeiterleitung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Empfaenger = 0
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim sMessage As String
        Me.Empfaenger = Me.mcbmitarbeiter.SelectedValue
        Me.Meldungstext = Me.TextBox1.Text
        ' Prüfen ob der Empfänger den Empfang von Meldungen oder Emails eingeschaltet hat.
        If ChechMeldungEmpfang(Me.Empfaenger) = 0 Then
            MyMsg.show_standardmessage(259, MsgBoxStyle.Information)
            Exit Sub
        End If
        If m_Bezeichnung <> "" Or m_PartnerNR <> "" Or m_INFO <> "" Then
            sMessage = Me.Meldungstext + vbCrLf + vbCrLf + "Bezeichnung: " + m_Bezeichnung
            sMessage = sMessage + vbCrLf + "Partner-Nr.: " + m_PartnerNR
            sMessage = sMessage + vbCrLf + "Erstellungsdatum: " + m_INFO
            Me.Meldungstext = sMessage
            Me.TextBox1.Text = sMessage
        End If
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.ChechMeldungEmpfang Method

Private Function ChechMeldungEmpfang( _
   ByVal MitarbeiterID As Integer _
) As Integer

Parameters

MitarbeiterID
Required.

Source code

[Visual Basic]
    Private Function ChechMeldungEmpfang(ByVal MitarbeiterID As Integer) As Integer
        '===============================================================================
        'Description : Überprüft ob der Mitarbeiter mit der übergebenen ID Meldungen oder
        '               Mails aus EDOKA ein- oder ausgeschaltet hat.
        'Input       : Mitarbeiter ID
        'Criteria    :
        'Output      : 0/1 (0=Benachrichtigung ausgeschaltet )
        'Date        : bud 17.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim iReturn As SqlInt32
        scmCmdToExecute.CommandText = "dbo.sp_check_MeldungVersand"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        ChechMeldungEmpfang = 1
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iMANR", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, MitarbeiterID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iResult", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ChechMeldungEmpfang))
            scmCmdToExecute.ExecuteNonQuery()
            iReturn = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iResult").Value, Integer))
            ChechMeldungEmpfang = iReturn.Value
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbmitarbeiter = New MultiComboBox(Me.cbMitarbeiter)
        Me.mcbmitarbeiter.CheckNullValue = True
        Me.mcbmitarbeiter.NullValueMessage = MyTxt.gettext(18)
        Me.mcbmitarbeiter.DisplayColumnName = "mitarbeiter"
        Me.mcbmitarbeiter.ValueColumnName = "mitarbeiternr"
        Me.mcbmitarbeiter.SelectedValue = 0
        Me.mcbmitarbeiter.Fill_Data(Generic_Select(1), False)
        Me.mcbmitarbeiter.Focus()
        Me.mcbmitarbeiter.SelectAll()
        Me.mcbmitarbeiter.Focus()
        If m_Bezeichnung = "" Or m_PartnerNR = "" Or m_INFO = "" Then
            Me.txtBez.Text = ""
            Me.txtBezText.Text = ""
            Me.txtDokID.Text = ""
            Me.txtdokIDText.Text = ""
            Me.txtPartnerID.Text = ""
            Me.txtPartnerIDText.Text = ""
        Else
            Me.txtBez.Text = "Bezeichnung"
            Me.txtBezText.Text = m_Bezeichnung
            Me.txtDokID.Text = "Erstellungsdatum"
            Me.txtdokIDText.Text = m_INFO
            Me.txtPartnerID.Text = "Partner-Nr."
            Me.txtPartnerIDText.Text = m_PartnerNR
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_message_getmitarbeiter"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMessageWeiterleitung))
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.txtBez = New System.Windows.Forms.Label()
        Me.txtDokID = New System.Windows.Forms.Label()
        Me.txtPartnerID = New System.Windows.Forms.Label()
        Me.txtBezText = New System.Windows.Forms.Label()
        Me.txtdokIDText = New System.Windows.Forms.Label()
        Me.txtPartnerIDText = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 4
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(296, 176)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&OK"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.Location = New System.Drawing.Point(96, 16)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(264, 21)
        Me.cbMitarbeiter.TabIndex = 0
        Me.cbMitarbeiter.Text = "ComboBox1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(80, 23)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Empfänger"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(96, 64)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(264, 104)
        Me.TextBox1.TabIndex = 2
        Me.TextBox1.Text = "TextBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 64)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(80, 23)
        Me.Label1.TabIndex = 7
        Me.Label1.Text = "Meldung"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 40)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 23)
        Me.Label3.TabIndex = 8
        Me.Label3.Text = "Betreff"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(96, 40)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(264, 20)
        Me.TextBox2.TabIndex = 1
        Me.TextBox2.Text = ""
        '
        'txtBez
        '
        Me.txtBez.Location = New System.Drawing.Point(8, 216)
        Me.txtBez.Name = "txtBez"
        Me.txtBez.Size = New System.Drawing.Size(80, 16)
        Me.txtBez.TabIndex = 9
        '
        'txtDokID
        '
        Me.txtDokID.Location = New System.Drawing.Point(8, 264)
        Me.txtDokID.Name = "txtDokID"
        Me.txtDokID.Size = New System.Drawing.Size(96, 16)
        Me.txtDokID.TabIndex = 10
        '
        'txtPartnerID
        '
        Me.txtPartnerID.Location = New System.Drawing.Point(8, 240)
        Me.txtPartnerID.Name = "txtPartnerID"
        Me.txtPartnerID.Size = New System.Drawing.Size(80, 16)
        Me.txtPartnerID.TabIndex = 11
        '
        'txtBezText
        '
        Me.txtBezText.Location = New System.Drawing.Point(96, 216)
        Me.txtBezText.Name = "txtBezText"
        Me.txtBezText.Size = New System.Drawing.Size(272, 16)
        Me.txtBezText.TabIndex = 12
        '
        'txtdokIDText
        '
        Me.txtdokIDText.Location = New System.Drawing.Point(96, 264)
        Me.txtdokIDText.Name = "txtdokIDText"
        Me.txtdokIDText.Size = New System.Drawing.Size(272, 16)
        Me.txtdokIDText.TabIndex = 13
        '
        'txtPartnerIDText
        '
        Me.txtPartnerIDText.Location = New System.Drawing.Point(96, 240)
        Me.txtPartnerIDText.Name = "txtPartnerIDText"
        Me.txtPartnerIDText.Size = New System.Drawing.Size(272, 16)
        Me.txtPartnerIDText.TabIndex = 14
        '
        'frmMessageWeiterleitung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 286)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtPartnerIDText, Me.txtdokIDText, Me.txtBezText, Me.txtPartnerID, Me.txtDokID, Me.txtBez, Me.TextBox2, Me.Label3, Me.Label1, Me.TextBox1, Me.Label2, Me.cbMitarbeiter, Me.Button2, Me.Button1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmMessageWeiterleitung"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Meldung "
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMessageWeiterleitung Fields

frmMessageWeiterleitung overview

Fields

field Button1
field Button2
field Label1
field Label2
field Label3
field TextBox1
field TextBox2
field cbMitarbeiter
field components
field m_Bezeichnung
field m_INFO
field m_PartnerNR
field m_empfaenger
field m_meldungstext
field mcbmitarbeiter
field txtBez
field txtBezText
field txtDokID
field txtPartnerID
field txtPartnerIDText
field txtdokIDText

See Also

frmMessageWeiterleitung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


cbMitarbeiter Variable

Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


m_Bezeichnung Variable

Dim m_Bezeichnung As String

Source code

[Visual Basic]
    Dim m_Bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


m_INFO Variable

Dim m_INFO As String

Source code

[Visual Basic]
    Dim m_INFO As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


m_PartnerNR Variable

Dim m_PartnerNR As String

Source code

[Visual Basic]
    Dim m_PartnerNR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


m_empfaenger Variable

Dim m_empfaenger As Integer

Source code

[Visual Basic]
    Dim m_empfaenger As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


m_meldungstext Variable

Dim m_meldungstext As String

Source code

[Visual Basic]
    Dim m_meldungstext As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


mcbmitarbeiter Variable

Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtBez Variable

Friend WithEvents txtBez As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtBez As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtBezText Variable

Friend WithEvents txtBezText As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtBezText As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtDokID Variable

Friend WithEvents txtDokID As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtDokID As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtPartnerID Variable

Friend WithEvents txtPartnerID As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtPartnerID As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtPartnerIDText Variable

Friend WithEvents txtPartnerIDText As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtPartnerIDText As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


txtdokIDText Variable

Friend WithEvents txtdokIDText As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtdokIDText As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMessageWeiterleitung


frmMetaDatenSelector Class

For a list of all members of this type, see frmMetaDatenSelector Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMetaDatenSelector

Public Class frmMetaDatenSelector
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMetaDatenSelector Members


frmMetaDatenSelector Members

frmMetaDatenSelector overview

Constructors

constructor frmMetaDatenSelector Constructor

Properties

property Prop_DokumentID
property Prop_DruckParameter

Methods

method Dispose
method FillParameterCollection
method InitializeComponent
method btnAbbrechen_Click
method btnDrucken_Click
method btnSelectAll_Click
method frmMetaDatenSelector_Load
method genReport

Fields

field GroupBox1
field btnAbbrechen
field btnDrucken
field btnSelectAll
field cbxAllg
field cbxBerEinschr
field cbxDokStatus
field cbxDokWerte
field cbxDokZuordnung
field cbxErsetzteDok
field cbxInfomeldung
field cbxNotizen
field components
field m_DokumentID
field m_DruckParameter

See Also

frmMetaDatenSelector Class


frmMetaDatenSelector Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector Properties

frmMetaDatenSelector overview

Properties

property Prop_DokumentID
property Prop_DruckParameter

See Also

frmMetaDatenSelector Class


frmMetaDatenSelector.Prop_DokumentID Property

Property Prop_DokumentID() As String

Source code

[Visual Basic]
    Property Prop_DokumentID() As String
        Get
            Return m_DokumentID
        End Get
        Set(ByVal Value As String)
            m_DokumentID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.Prop_DruckParameter Property

Property Prop_DruckParameter() As String

Source code

[Visual Basic]
    Property Prop_DruckParameter() As String
        Get
            Return m_DruckParameter
        End Get
        Set(ByVal Value As String)
            m_DruckParameter = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector Methods

frmMetaDatenSelector overview

Methods

method Dispose
method FillParameterCollection
method InitializeComponent
method btnAbbrechen_Click
method btnDrucken_Click
method btnSelectAll_Click
method frmMetaDatenSelector_Load
method genReport

See Also

frmMetaDatenSelector Class


frmMetaDatenSelector.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.FillParameterCollection Method

Private Function FillParameterCollection( _
   ByVal sMetDataOption As String _
) As Collection

Parameters

sMetDataOption
Required.

Source code

[Visual Basic]
    Private Function FillParameterCollection(ByVal sMetDataOption As String) As Collection
        Dim colParameter As New Microsoft.VisualBasic.Collection()
        Dim iCnt As Integer
        Dim sParameterKey As String
        Dim sParameterValue As String
        Dim sFilterDisplayValue As String
        Try
            sParameterKey = "@MANr"
            Debug.Write(sParameterKey & vbCrLf)
            sParameterValue = Globals.MitarbeiterNr
            Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
            colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

            sParameterKey = "@MetDataOption"
            Debug.Write(sParameterKey & vbCrLf)
            sParameterValue = sMetDataOption
            Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
            colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

            sParameterKey = "@OfficeDokID"
            Debug.Write(sParameterKey & vbCrLf)
            sParameterValue = m_DokumentID
            Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
            colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

            FillParameterCollection = colParameter
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMetaDatenSelector))
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.cbxErsetzteDok = New System.Windows.Forms.CheckBox()
        Me.cbxInfomeldung = New System.Windows.Forms.CheckBox()
        Me.cbxDokWerte = New System.Windows.Forms.CheckBox()
        Me.cbxDokZuordnung = New System.Windows.Forms.CheckBox()
        Me.cbxAllg = New System.Windows.Forms.CheckBox()
        Me.cbxDokStatus = New System.Windows.Forms.CheckBox()
        Me.cbxNotizen = New System.Windows.Forms.CheckBox()
        Me.cbxBerEinschr = New System.Windows.Forms.CheckBox()
        Me.btnDrucken = New System.Windows.Forms.Button()
        Me.btnAbbrechen = New System.Windows.Forms.Button()
        Me.btnSelectAll = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbxErsetzteDok, Me.cbxInfomeldung, Me.cbxDokWerte, Me.cbxDokZuordnung, Me.cbxAllg, Me.cbxDokStatus, Me.cbxNotizen, Me.cbxBerEinschr})
        Me.GroupBox1.Location = New System.Drawing.Point(16, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(392, 136)
        Me.GroupBox1.TabIndex = 0
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Selektion"
        '
        'cbxErsetzteDok
        '
        Me.cbxErsetzteDok.Location = New System.Drawing.Point(200, 96)
        Me.cbxErsetzteDok.Name = "cbxErsetzteDok"
        Me.cbxErsetzteDok.Size = New System.Drawing.Size(176, 24)
        Me.cbxErsetzteDok.TabIndex = 7
        Me.cbxErsetzteDok.Text = "Ersetzte Dokumente"
        '
        'cbxInfomeldung
        '
        Me.cbxInfomeldung.Location = New System.Drawing.Point(200, 48)
        Me.cbxInfomeldung.Name = "cbxInfomeldung"
        Me.cbxInfomeldung.Size = New System.Drawing.Size(144, 24)
        Me.cbxInfomeldung.TabIndex = 5
        Me.cbxInfomeldung.Text = "Informationsmeldungen"
        '
        'cbxDokWerte
        '
        Me.cbxDokWerte.Location = New System.Drawing.Point(16, 72)
        Me.cbxDokWerte.Name = "cbxDokWerte"
        Me.cbxDokWerte.Size = New System.Drawing.Size(144, 24)
        Me.cbxDokWerte.TabIndex = 2
        Me.cbxDokWerte.Text = "Dokumentwerte"
        '
        'cbxDokZuordnung
        '
        Me.cbxDokZuordnung.Location = New System.Drawing.Point(16, 96)
        Me.cbxDokZuordnung.Name = "cbxDokZuordnung"
        Me.cbxDokZuordnung.Size = New System.Drawing.Size(144, 24)
        Me.cbxDokZuordnung.TabIndex = 3
        Me.cbxDokZuordnung.Text = "Dokumentzuordnungen"
        '
        'cbxAllg
        '
        Me.cbxAllg.Location = New System.Drawing.Point(16, 24)
        Me.cbxAllg.Name = "cbxAllg"
        Me.cbxAllg.Size = New System.Drawing.Size(96, 24)
        Me.cbxAllg.TabIndex = 0
        Me.cbxAllg.Text = "Allgemein"
        '
        'cbxDokStatus
        '
        Me.cbxDokStatus.Location = New System.Drawing.Point(16, 48)
        Me.cbxDokStatus.Name = "cbxDokStatus"
        Me.cbxDokStatus.Size = New System.Drawing.Size(112, 24)
        Me.cbxDokStatus.TabIndex = 1
        Me.cbxDokStatus.Text = "Dokumentstatus"
        '
        'cbxNotizen
        '
        Me.cbxNotizen.Location = New System.Drawing.Point(200, 24)
        Me.cbxNotizen.Name = "cbxNotizen"
        Me.cbxNotizen.TabIndex = 4
        Me.cbxNotizen.Text = "Notizen"
        '
        'cbxBerEinschr
        '
        Me.cbxBerEinschr.Location = New System.Drawing.Point(200, 72)
        Me.cbxBerEinschr.Name = "cbxBerEinschr"
        Me.cbxBerEinschr.Size = New System.Drawing.Size(184, 24)
        Me.cbxBerEinschr.TabIndex = 6
        Me.cbxBerEinschr.Text = "Berechtigungseinschränkungen"
        '
        'btnDrucken
        '
        Me.btnDrucken.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.btnDrucken.Location = New System.Drawing.Point(336, 160)
        Me.btnDrucken.Name = "btnDrucken"
        Me.btnDrucken.TabIndex = 9
        Me.btnDrucken.Text = "Drucken"
        '
        'btnAbbrechen
        '
        Me.btnAbbrechen.DialogResult = System.Windows.Forms.DialogResult.Abort
        Me.btnAbbrechen.Location = New System.Drawing.Point(256, 160)
        Me.btnAbbrechen.Name = "btnAbbrechen"
        Me.btnAbbrechen.TabIndex = 8
        Me.btnAbbrechen.Text = "Abbrechen"
        '
        'btnSelectAll
        '
        Me.btnSelectAll.Location = New System.Drawing.Point(16, 160)
        Me.btnSelectAll.Name = "btnSelectAll"
        Me.btnSelectAll.Size = New System.Drawing.Size(88, 23)
        Me.btnSelectAll.TabIndex = 10
        Me.btnSelectAll.Text = "Alle auswählen"
        '
        'frmMetaDatenSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(424, 189)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnSelectAll, Me.btnAbbrechen, Me.btnDrucken, Me.GroupBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmMetaDatenSelector"
        Me.Text = "Dokumentinformationen drucken"
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.btnAbbrechen_Click Method

Private Sub btnAbbrechen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnAbbrechen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnAbbrechen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnAbbrechen.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.btnDrucken_Click Method

Private Sub btnDrucken_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnDrucken.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnDrucken_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDrucken.Click
        Try
            Dim s As String
            s = "0;"
            'Allgemeine Informationen
            If cbxAllg.Checked = True Then
                s = s + "1;"
            End If
            'Dokument Status
            If cbxDokStatus.Checked = True Then
                s = s + "2;"
            End If
            'Notizen
            If cbxNotizen.Checked = True Then
                s = s + "3;"
            End If
            'Dokument Zuordnungen
            If cbxDokZuordnung.Checked = True Then
                s = s + "4;"
            End If
            'Dokument Werte
            If cbxDokWerte.Checked = True Then
                s = s + "5;"
            End If
            'Informationsmeldungen
            If cbxInfomeldung.Checked = True Then
                s = s + "6;"
            End If
            'Berechtigungsaeinschränkung
            If cbxBerEinschr.Checked = True Then
                s = s + "7;"
            End If
            'Ersetzte Dokumente
            If cbxErsetzteDok.Checked = True Then
                s = s + "8;"
            End If
            m_DruckParameter = s
            Me.Close()
            'genReport(s)
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.btnSelectAll_Click Method

Private Sub btnSelectAll_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSelectAll.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSelectAll_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSelectAll.Click
        Me.cbxAllg.Checked = True
        Me.cbxBerEinschr.Checked = True
        Me.cbxDokStatus.Checked = True
        Me.cbxDokWerte.Checked = True
        Me.cbxDokZuordnung.Checked = True
        Me.cbxErsetzteDok.Checked = True
        Me.cbxInfomeldung.Checked = True
        Me.cbxNotizen.Checked = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.frmMetaDatenSelector_Load Method

Private Sub frmMetaDatenSelector_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMetaDatenSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector.genReport Method

Public Function genReport( _
   ByVal sMetDataOption _
)

Parameters

sMetDataOption
Required.

Source code

[Visual Basic]
    Public Function genReport(ByVal sMetDataOption)
        Me.Cursor = Cursors.WaitCursor
        Dim f As New frmReportViewer()
        Dim objReport As New edokadb.clsReporting_Dokumenttyp()
        Dim ParameterCollection As New Collection()
        Dim Dokument_Temp As String
        Dim sReportBezNAme As String
        Dim reportNr As Integer
        Dim sReportname As String
        sReportBezNAme = "Metadaten Report"
        sReportname = "MetaDataReport.rpt"
        reportNr = 20

        '=======================================
        'Dokument Speichern
        '=======================================
        Dokument_Temp = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String)
        objReport.Get_DocumentFrom_DB("reportNr", reportNr, "report", "reportfile", Dokument_Temp, sReportname)
        objReport = Nothing
        f.WindowTitel = sReportBezNAme
        'ParameterCollection = FillParameterCollection(sMetDataOption)

        If Not f.show_reportWithParameter(sReportname, "@MANr=" + Str(Globals.MitarbeiterNr) + "&@MetDataOption=" + sMetDataOption + "&@OfficeDokID=" + m_DokumentID) Then
            If MyMsg.Show_MessageYesNo(217) Then
                Exit Function
            End If
        End If

        Try
            'f.crviewer.Visible = True
            f.Show()
        Catch ex As Exception
            Me.Cursor = Cursors.Default
            MsgBox(ex.Message)
        End Try
        Me.Cursor = Cursors.Default
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMetaDatenSelector Fields

frmMetaDatenSelector overview

Fields

field GroupBox1
field btnAbbrechen
field btnDrucken
field btnSelectAll
field cbxAllg
field cbxBerEinschr
field cbxDokStatus
field cbxDokWerte
field cbxDokZuordnung
field cbxErsetzteDok
field cbxInfomeldung
field cbxNotizen
field components
field m_DokumentID
field m_DruckParameter

See Also

frmMetaDatenSelector Class


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


btnAbbrechen Variable

Friend WithEvents btnAbbrechen As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnAbbrechen As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


btnDrucken Variable

Friend WithEvents btnDrucken As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnDrucken As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


btnSelectAll Variable

Friend WithEvents btnSelectAll As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSelectAll As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxAllg Variable

Friend WithEvents cbxAllg As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxAllg As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxBerEinschr Variable

Friend WithEvents cbxBerEinschr As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxBerEinschr As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxDokStatus Variable

Friend WithEvents cbxDokStatus As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxDokStatus As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxDokWerte Variable

Friend WithEvents cbxDokWerte As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxDokWerte As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxDokZuordnung Variable

Friend WithEvents cbxDokZuordnung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxDokZuordnung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxErsetzteDok Variable

Friend WithEvents cbxErsetzteDok As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxErsetzteDok As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxInfomeldung Variable

Friend WithEvents cbxInfomeldung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxInfomeldung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


cbxNotizen Variable

Friend WithEvents cbxNotizen As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbxNotizen As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


m_DokumentID Variable

Dim m_DokumentID As String

Source code

[Visual Basic]
    Dim m_DokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


m_DruckParameter Variable

Dim m_DruckParameter As String = ""

Source code

[Visual Basic]
    Dim m_DruckParameter As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMetaDatenSelector


frmMitarbeiterFunktionsgruppe Class

For a list of all members of this type, see frmMitarbeiterFunktionsgruppe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmMitarbeiterFunktionsgruppe

Public Class frmMitarbeiterFunktionsgruppe
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMitarbeiterFunktionsgruppe Members


frmMitarbeiterFunktionsgruppe Members

frmMitarbeiterFunktionsgruppe overview

Constructors

constructor frmMitarbeiterFunktionsgruppe Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmMitarbeiterFunktionsgruppe Class


frmMitarbeiterFunktionsgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe Properties

frmMitarbeiterFunktionsgruppe overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmMitarbeiterFunktionsgruppe Class


frmMitarbeiterFunktionsgruppe Methods

frmMitarbeiterFunktionsgruppe overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmMitarbeiterFunktionsgruppe Class


frmMitarbeiterFunktionsgruppe.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("vorname", "vorname"), New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("tgnummer", "tgnummer"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("fax", "fax"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("unterschrift_text", "unterschrift_text"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("fuermandant", "fuermandant"), New System.Data.Common.DataColumnMapping("showtip", "showtip"), New System.Data.Common.DataColumnMapping("partnernr", "partnernr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_mitarbeiter_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_mitarbeiter_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_mitarbeiter_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_mitarbeiter_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_funktionsgruppe_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_funktionsgruppe_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_funktionsgruppe_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_funktionsgruppe_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter_funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiter_funktionsgruppenr", "mitarbeiter_funktionsgruppenr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_mitarbeiter_funktionsgruppe_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_mitarbeiter_funktionsgruppe_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, "mitarbeiter_funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_mitarbeiter_funktionsgruppe_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, "mitarbeiter_funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_mitarbeiter_funktionsgruppe_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmMitarbeiterFunktionsgruppe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(608, 469)
        Me.Name = "frmMitarbeiterFunktionsgruppe"
        Me.Text = "frmMitarbeiterFunktionsgruppe"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsMitarbeiter_funktionsgruppe()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iFunktionsgruppenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("mitarbeiter_funktionsgruppe")
            vdata.iMitarbeiter_funktionsgruppenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5038, 5039, 5040)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "mitarbeiter"
        Me.TableNameRight = "funktionsgruppe"
        Me.TableNameBottom = "mitarbeiter_funktionsgruppe"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterFunktionsgruppe Fields

frmMitarbeiterFunktionsgruppe overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmMitarbeiterFunktionsgruppe Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterFunktionsgruppe


frmMitarbeiterRolle Class

For a list of all members of this type, see frmMitarbeiterRolle Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmMitarbeiterRolle

Public Class frmMitarbeiterRolle
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMitarbeiterRolle Members


frmMitarbeiterRolle Members

frmMitarbeiterRolle overview

Constructors

constructor frmMitarbeiterRolle Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmMitarbeiterRolle Class


frmMitarbeiterRolle Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle Properties

frmMitarbeiterRolle overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmMitarbeiterRolle Class


frmMitarbeiterRolle Methods

frmMitarbeiterRolle overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmMitarbeiterRolle Class


frmMitarbeiterRolle.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("vorname", "vorname"), New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("tgnummer", "tgnummer"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("fax", "fax"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("unterschrift_text", "unterschrift_text"), New System.Data.Common.DataColumnMapping("kostenstellenr", "kostenstellenr"), New System.Data.Common.DataColumnMapping("teamnr", "teamnr"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("fuermandant", "fuermandant"), New System.Data.Common.DataColumnMapping("showtip", "showtip"), New System.Data.Common.DataColumnMapping("partnernr", "partnernr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_mitarbeiter_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_mitarbeiter_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_mitarbeiter_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_mitarbeiter_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@kostenstellenr", System.Data.SqlDbType.Int, 4, "kostenstellenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_kostenstellenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "kostenstellenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiterrolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiterrollenr", "mitarbeiterrollenr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_mitarbeiterrolle_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiterrollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiterrollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_mitarbeiterrolle_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiterrollenr", System.Data.SqlDbType.Int, 4, "mitarbeiterrollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_mitarbeiterrolle_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_mitarbeiterrolle_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiterrollenr", System.Data.SqlDbType.Int, 4, "mitarbeiterrollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiterrollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiterrollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmMitarbeiterRolle
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmMitarbeiterRolle"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsMitarbeiterrolle()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iMitarbeiternr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                vdata.iRollenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("mitarbeiterrolle")
            vdata.iMitarbeiterrollenr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5023, 5024, 5025)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom

        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "mitarbeiter"
        Me.TableNameRight = "rolle"
        Me.TableNameBottom = "mitarbeiterrolle"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterRolle Fields

frmMitarbeiterRolle overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmMitarbeiterRolle Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterRolle


frmMitarbeiterSelektion Class

For a list of all members of this type, see frmMitarbeiterSelektion Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMitarbeiterSelektion

Public Class frmMitarbeiterSelektion
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMitarbeiterSelektion Members


frmMitarbeiterSelektion Members

frmMitarbeiterSelektion overview

Constructors

constructor frmMitarbeiterSelektion Constructor

Properties

property Mitarbeiternr

Methods

method Button1_Click
method Button2_Click
method Dispose
method Handle_enter
method InitializeComponent
method frmLogin_Load

Fields

field Button1
field Button2
field ComboBox1
field DataSet1
field Label1
field cbo
field components
field db
field m_mitarbeiternr

See Also

frmMitarbeiterSelektion Class


frmMitarbeiterSelektion Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion Properties

frmMitarbeiterSelektion overview

Properties

property Mitarbeiternr

See Also

frmMitarbeiterSelektion Class


frmMitarbeiterSelektion.Mitarbeiternr Property

Property Mitarbeiternr() As Long

Source code

[Visual Basic]
    Property Mitarbeiternr() As Long
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Long)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion Methods

frmMitarbeiterSelektion overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Handle_enter
method InitializeComponent
method frmLogin_Load

See Also

frmMitarbeiterSelektion Class


frmMitarbeiterSelektion.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            m_mitarbeiternr = Me.cbo.SelectedValue
            Me.DialogResult = DialogResult.OK
            db.Dispose()
            Close()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Cancel
        db.Dispose()
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion.Handle_enter Method

Private Sub Handle_enter( _
   ByVal sender As System.Object, _
   ByVal e As KeyPressEventArgs _
) Handles cbo.KeyPress

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Handle_enter(ByVal sender As System.Object, ByVal e As KeyPressEventArgs) Handles cbo.KeyPress
        If e.KeyChar = Chr(13) Then
            Button1_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMitarbeiterSelektion))
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(32, 32)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(248, 21)
        Me.ComboBox1.TabIndex = 0
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(32, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(280, 23)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Welcher Mitarbeiter soll das Dokumentpaket erhalten?"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(176, 72)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(104, 24)
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "&Weiter"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(32, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(104, 24)
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'frmMitarbeiterSelektion
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(304, 117)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label1, Me.ComboBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmMitarbeiterSelektion"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokumentpaket für Mitarbeiter kopieren"
        Me.TopMost = True
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion.frmLogin_Load Method

Private Sub frmLogin_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmLogin_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim db As New edokadb.clsMyMitarbeiter()
        Dim t As DataTable
        db.cpMainConnectionProvider = conn
        t = db.SelectAllMandantMitarbeiter
        cbo = New MultiComboBox(Me.ComboBox1)
        cbo.NullValueMessage = Globals.MyTxt.gettext(18)
        cbo.CheckNullValue = True
        cbo.DisplayColumnName = "namevorname"
        cbo.ValueColumnName = "mitarbeiternr"
        cbo.Fill_Data(t, False)
        Me.ComboBox1.Select()
        Me.ComboBox1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeiterSelektion Fields

frmMitarbeiterSelektion overview

Fields

field Button1
field Button2
field ComboBox1
field DataSet1
field Label1
field cbo
field components
field db
field m_mitarbeiternr

See Also

frmMitarbeiterSelektion Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


cbo Variable

Dim WithEvents cbo As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents cbo As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


db Variable

Dim db As New edokadb.clsMyMitarbeiter()

Source code

[Visual Basic]
    Dim db As New edokadb.clsMyMitarbeiter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Long

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeiterSelektion


frmMitarbeitereinstellungen Class

For a list of all members of this type, see frmMitarbeitereinstellungen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmMitarbeitereinstellungen

Public Class frmMitarbeitereinstellungen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmMitarbeitereinstellungen Members


frmMitarbeitereinstellungen Members

frmMitarbeitereinstellungen overview

Constructors

constructor frmMitarbeitereinstellungen Constructor

Methods

method BtnHelp_Click
method C1TrueDBGrid1_MouseDown
method CheckIsBenachrichtigung
method Dispose
method FilDokBerechtDataSet
method FilDokNichtBerechtDataSet
method GenerateDokBerechtTable
method GenerateDokNichtBerechtTable
method GenerateTree
method GenerateTreeView
method Generic_Select
method GetTreeInfo
method GrdDatumformat
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method TabControl1_MouseDown
method ToolBar1_ButtonClick
method ToolBar2_ButtonClick
method ToolBar3_ButtonClick
method TreeView1_MouseMove
method check_changes
method fill_c1
method frmMitarbeitereinstellungen_Closing
method frmMitarbeitereinstellungen_Load
method read_to_root
method save_data
method txtSearchNotBerechtigt_KeyDown
method txtSearch_KeyDown

Fields

field BtnHelp
field C1TrueDBGrid1
field C1TrueDBGrid2
field ContextMenu1
field DokBerecht
field DokNotBerecht
field DokNotBerechtOrg
field GroupBox6
field GroupBox7
field GroupBox8
field ImageList1
field ImageList3
field Label1
field Label2
field Label32
field Label33
field Label34
field Label35
field Label4
field MenuItem1
field MenuItem2
field Stellvertretungtyp
field TV2
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field ToolBar1
field ToolBar2
field ToolBar3
field ToolBarButton1
field ToolBarButton2
field ToolTip1
field TreeView1
field bis
field btnSearch
field btnSucheNotBerechtigt
field cEdokaMessage
field cMailDirekt
field cedoka_mail
field changed
field cmaileingang
field cmailempfang
field components
field dtToReturn
field m_bLoadTreeDokBerecht
field m_bLoadTreeDokNichtBerecht
field txtFunktion
field txtMailadresse
field txtRang
field txtSearch
field txtSearchNotBerechtigt
field txtTelefax
field txtTelefon
field vertreter
field von

See Also

frmMitarbeitereinstellungen Class


frmMitarbeitereinstellungen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen Methods

frmMitarbeitereinstellungen overview

Methods

method BtnHelp_Click
method C1TrueDBGrid1_MouseDown
method CheckIsBenachrichtigung
method Dispose
method FilDokBerechtDataSet
method FilDokNichtBerechtDataSet
method GenerateDokBerechtTable
method GenerateDokNichtBerechtTable
method GenerateTree
method GenerateTreeView
method Generic_Select
method GetTreeInfo
method GrdDatumformat
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method TabControl1_MouseDown
method ToolBar1_ButtonClick
method ToolBar2_ButtonClick
method ToolBar3_ButtonClick
method TreeView1_MouseMove
method check_changes
method fill_c1
method frmMitarbeitereinstellungen_Closing
method frmMitarbeitereinstellungen_Load
method read_to_root
method save_data
method txtSearchNotBerechtigt_KeyDown
method txtSearch_KeyDown

See Also

frmMitarbeitereinstellungen Class


frmMitarbeitereinstellungen.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("mitarbeitereinstellungen")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.C1TrueDBGrid1_MouseDown Method

Private Sub C1TrueDBGrid1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles C1TrueDBGrid1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1TrueDBGrid1.MouseDown
        Me.C1TrueDBGrid1.Bookmark = Me.C1TrueDBGrid1.RowContaining(e.Y)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.CheckIsBenachrichtigung Method

Private Function CheckIsBenachrichtigung() As Boolean

Source code

[Visual Basic]
    Private Function CheckIsBenachrichtigung() As Boolean
        'Prüfen ob die Einstellungen auf der DB korrekt sind
        Dim ma As New edokadb.clsMitarbeiter()
        ma.cpMainConnectionProvider = conn
        ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ma.SelectOne()
        If ma.bMailempfang.Value = False And ma.bEdoka_mail.Value = False Then
            CheckIsBenachrichtigung = False
        Else
            CheckIsBenachrichtigung = True
        End If
        ma.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.FilDokBerechtDataSet Method

Private Function FilDokBerechtDataSet( _
   ByVal iUserID As Integer _
) As DataTable

Parameters

iUserID
Required.

Source code

[Visual Basic]
    Private Function FilDokBerechtDataSet(ByVal iUserID As Integer) As DataTable
        '===============================================================================
        'Description : Füllt eine DataTable mit den Dokumentinfos.
        'Input       : BenutzerID
        'Criteria    :
        'Output      : DataTable
        'Date        : bud 18.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        FilDokBerechtDataSet = New DataTable()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_GetBerechtigtDok2_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iUserID))
            sdaAdapter.Fill(FilDokBerechtDataSet)
            DokBerecht = FilDokBerechtDataSet
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.FilDokNichtBerechtDataSet Method

Private Function FilDokNichtBerechtDataSet( _
   ByVal iUserID As Integer _
) As DataTable

Parameters

iUserID
Required.

Source code

[Visual Basic]
    Private Function FilDokNichtBerechtDataSet(ByVal iUserID As Integer) As DataTable
        '===============================================================================
        'Description : Füllt eine DataTable mit den Dokumentinfos.
        'Input       : BenutzerID
        'Criteria    :
        'Output      : DataTable
        'Date        : bud 26.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        FilDokNichtBerechtDataSet = New DataTable()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_GetNichtBerechtigtDok2_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iUserID))
            sdaAdapter.Fill(FilDokNichtBerechtDataSet)

            DokNotBerechtOrg = FilDokNichtBerechtDataSet

        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GenerateDokBerechtTable Method

Private Sub GenerateDokBerechtTable( _
   ByVal UserID As Integer, _
   ByVal iMANR As Integer _
)

Parameters

UserID
Required.
iMANR
Required.

Source code

[Visual Basic]
    Private Sub GenerateDokBerechtTable(ByVal UserID As Integer, ByVal iMANR As Integer)
        '===============================================================================
        'Description : Führ die gepseicherte Prozedur aus, welche eine UserTabelle mit
        '               den Dokumenten für die er berechtigt ist generiert, aus.
        'Input       : BenutzerID
        'Criteria    :
        'Output      :
        'Date        : bud 16.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_GetBerechtigtDok0_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iMANR", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iMANR))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, UserID))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GenerateDokNichtBerechtTable Method

Private Sub GenerateDokNichtBerechtTable( _
   ByVal UserID As Integer, _
   ByVal iMANR As Integer _
)

Parameters

UserID
Required.
iMANR
Required.

Source code

[Visual Basic]
    Private Sub GenerateDokNichtBerechtTable(ByVal UserID As Integer, ByVal iMANR As Integer)
        '===============================================================================
        'Description : Führ die gepseicherte Prozedur aus, welche eine UserTabelle mit
        '               den Dokumenten für die er berechtigt ist generiert, aus.
        'Input       : BenutzerID
        'Criteria    :
        'Output      :
        'Date        : bud 26.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_GetNichtBerechtigtDok0_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iMANR", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iMANR))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, UserID))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GenerateTree Method

Private Sub GenerateTree( _
   ByVal otv As TreeView, _
   ByVal iUserID As Integer, _
   ByVal searchString As String, _
   ByVal filter As Boolean, _
   ByRef DataTableSearch As DataTable, _
   ByRef DataTableOriginal As DataTable, _
   ByVal TreeNr As Integer _
)

Parameters

otv
Required.
iUserID
Required.
searchString
Required.
filter
Required.
DataTableSearch
Required.
DataTableOriginal
Required.
TreeNr
Required.

Source code

[Visual Basic]
    Private Sub GenerateTree(ByVal otv As TreeView, ByVal iUserID As Integer, ByVal searchString As String, ByVal filter As Boolean, ByRef DataTableSearch As DataTable, ByRef DataTableOriginal As DataTable, ByVal TreeNr As Integer)
        '===============================================================================
        'Description : Baut den Baum auf mit den Daten im DataTable
        'Input       : BenutzerID und das Treeview Objekt sowie 2 DataTables
        'Criteria    :
        'Output      :
        'Date        : bud 18.08.2004
        'Modified    : bud 26.08.2004
        '===============================================================================
        '
        '===============================================================================
        Dim i As Integer
        Dim m_collDeletedNodes As Collection
        Dim collNodeKeys As New Collection()
        Dim tnNew As TreeNode
        Dim tnParent As TreeNode
        Dim lastid As Long
        Dim pid As Long

        Select Case TreeNr
            Case 1
                DataTableSearch = FilDokBerechtDataSet(iUserID)
            Case 2
                DataTableSearch = FilDokNichtBerechtDataSet(iUserID)
        End Select

        lastid = 1
        m_collDeletedNodes = Nothing
        m_collDeletedNodes = New Collection()
        otv.Nodes.Clear()

        'Wenn keine Daten angezeigt
        If DataTableOriginal.Rows.Count = 0 Then
            Select Case TreeNr
                Case 1
                    DataTableOriginal = FilDokBerechtDataSet(iUserID)
                Case 2
                    DataTableOriginal = FilDokNichtBerechtDataSet(iUserID)
            End Select
        End If

        'Wenn ein Suchstring gesetzt wurde, dann den String suchen
        If filter = True Then
            If searchString = "" Then
                DataTableSearch = DataTableOriginal
            Else
                Dim splitter
                Dim sstring As String = ""
                If InStr(searchString, " ", CompareMethod.Text) > 0 Then
                    splitter = Microsoft.VisualBasic.Split(searchString, " ")
                    Try
                        i = 0
                        While i < 100
                            If sstring.Length > 0 Then sstring = sstring + " AND "
                            sstring = sstring + "DokTypBez like '%" + splitter(i) + "%'"
                            i = i + 1
                        End While
                    Catch
                        sstring = Microsoft.VisualBasic.Left(sstring, sstring.Length - 5)
                    End Try
                Else
                    sstring = "DokTypBez like '%" + searchString + "%'"
                End If

                Dim dview As New DataView(DataTableOriginal, sstring, "Parentid, sort", DataViewRowState.CurrentRows)
                Dim tbltemp As New DataTable()
                Dim tbltemp1 As New DataTable()
                tbltemp = dview.Table.Clone
                Dim drv As DataRowView
                For Each drv In dview
                    tbltemp.ImportRow(drv.Row)
                    Try
                        read_to_root(drv, tbltemp, DataTableOriginal)
                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try
                Next
                dview.Dispose()
                tbltemp1 = dview.Table.Clone
                Try
                    Dim dview2 As New DataView(tbltemp, "", "ParentID, Sort", DataViewRowState.CurrentRows)
                    Dim drv2 As DataRowView
                    For Each drv2 In dview2
                        tbltemp1.ImportRow(drv2.Row)
                    Next
                    DataTableSearch = tbltemp1
                Catch ex As Exception
                End Try
            End If
        End If

        'Tree zusammenbauen
        For i = 0 To DataTableSearch.Rows.Count - 1
            If DataTableSearch.Rows(i).Item("ParentID") = 0 Then
                tnNew = otv.Nodes.Add(DataTableSearch.Rows(i).Item("bezeichnung"))
                With tnNew
                    .Tag() = DataTableSearch.Rows(i).Item("dokumentartnr")
                    .ImageIndex() = DataTableSearch.Rows(i).Item("ImageIndex")
                    .SelectedImageIndex() = DataTableSearch.Rows(i).Item("ImageIndexOpen")
                End With
                Try
                    collNodeKeys.Add(tnNew, CType(DataTableSearch.Rows(i).Item("dokumentartnr"), String))
                Catch ex As Exception
                    MsgBox(ex.Message, MsgBoxStyle.Critical)
                End Try
            Else
                Try
                    If DataTableSearch.Rows(i).Item("DokTypBez") Is System.DBNull.Value Then
                        tnParent = CType(collNodeKeys.Item(CType(DataTableSearch.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(DataTableSearch.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(DataTableSearch.Rows(i).Item("dokumentartnr"), String)
                            .ImageIndex() = DataTableSearch.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = DataTableSearch.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(DataTableSearch.Rows(i).Item("dokumentartnr"), String))
                    Else
                        If lastid <> DataTableSearch.Rows(i).Item("dokumentartnr") Then
                            tnParent = CType(collNodeKeys.Item(CType(DataTableSearch.Rows(i).Item("ParentID"), String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(DataTableSearch.Rows(i).Item("bezeichnung"), String))
                            With tnNew
                                .Tag() = CType(DataTableSearch.Rows(i).Item("dokumentartnr"), String)
                                .ImageIndex() = DataTableSearch.Rows(i).Item("ImageIndex")
                                .SelectedImageIndex() = DataTableSearch.Rows(i).Item("ImageIndexOpen")
                            End With
                            collNodeKeys.Add(tnNew, CType(DataTableSearch.Rows(i).Item("dokumentartnr"), String))
                            lastid = DataTableSearch.Rows(i).Item("dokumentartnr")
                            pid = lastid
                        End If
                        tnParent = CType(collNodeKeys.Item(CType(pid, String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(DataTableSearch.Rows(i).Item("DokTypBez"), String))
                        With tnNew
                            .Tag() = CType(DataTableSearch.Rows(i).Item("dokumenttypnr"), String)
                            .ImageIndex() = DataTableSearch.Rows(i).Item("dokimage")
                            .SelectedImageIndex() = DataTableSearch.Rows(i).Item("dokimage")
                        End With
                        collNodeKeys.Add(tnNew, CType(DataTableSearch.Rows(i).Item("dokumenttypnr"), String))

                    End If
                Catch ex As Exception
                    MsgBox("Dokart:" & DataTableSearch.Rows(i).Item("dokumentartnr") & " - " & DataTableSearch.Rows(i).Item("dokumenttypnr") & ex.Message, MsgBoxStyle.Critical)
                End Try
            End If

        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GenerateTreeView Method

Private Sub GenerateTreeView( _
   ByVal SearchText As String, _
   ByVal Filter As Boolean, _
   ByVal TreeNr As Integer _
)

Parameters

SearchText
Required.
Filter
Required.
TreeNr
Required.

Source code

[Visual Basic]
    Private Sub GenerateTreeView(ByVal SearchText As String, ByVal Filter As Boolean, ByVal TreeNr As Integer)
        Try
            Me.Cursor = Cursors.WaitCursor
            Select Case TreeNr
                Case 1 'Berechtigte Dokumente
                    If m_bLoadTreeDokBerecht = False Then
                        TreeView1.BeginUpdate()
                        GenerateDokBerechtTable(Globals.MitarbeiterNr, Globals.MitarbeiterNr)
                        GenerateTree(TreeView1, Globals.MitarbeiterNr, SearchText, Filter, dtToReturn, DokBerecht, TreeNr)
                        TreeView1.ExpandAll()
                        TreeView1.EndUpdate()
                        m_bLoadTreeDokBerecht = True
                        If dtToReturn.Rows.Count <> 0 Then
                            TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
                            TreeView1.Refresh()
                            TreeView1.SelectedNode.Checked = True
                        Else
                            TreeView1.Refresh()
                        End If
                    Else
                        TreeView1.BeginUpdate()
                        GenerateTree(TreeView1, Globals.MitarbeiterNr, SearchText, Filter, dtToReturn, DokBerecht, TreeNr)
                        TreeView1.ExpandAll()
                        TreeView1.EndUpdate()
                        If dtToReturn.Rows.Count <> 0 Then
                            TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
                            TreeView1.Refresh()
                            TreeView1.SelectedNode.Checked = True
                        Else
                            TreeView1.Refresh()
                        End If
                    End If
                Case 2 ' Nicht Berechtigte Dokumente
                    If m_bLoadTreeDokNichtBerecht = False Then
                        TV2.BeginUpdate()
                        GenerateDokNichtBerechtTable(Globals.MitarbeiterNr, Globals.MitarbeiterNr)
                        GenerateTree(TV2, Globals.MitarbeiterNr, SearchText, Filter, DokNotBerecht, DokNotBerechtOrg, TreeNr)
                        TV2.ExpandAll()
                        TV2.EndUpdate()
                        m_bLoadTreeDokNichtBerecht = True
                        If DokNotBerecht.Rows.Count <> 0 Then
                            TV2.SelectedNode = Me.TV2.Nodes(0)
                            TV2.Refresh()
                            TV2.SelectedNode.Checked = True
                        Else
                            TV2.Refresh()
                        End If
                    Else
                        TV2.BeginUpdate()
                        GenerateTree(TV2, Globals.MitarbeiterNr, SearchText, Filter, DokNotBerecht, DokNotBerechtOrg, TreeNr)
                        TV2.ExpandAll()
                        TV2.EndUpdate()
                        If DokNotBerecht.Rows.Count <> 0 Then
                            TV2.SelectedNode = Me.TV2.Nodes(0)
                            TV2.Refresh()
                            TV2.SelectedNode.Checked = True
                        Else
                            TV2.Refresh()
                        End If
                    End If
            End Select

            Me.Cursor = Cursors.Default
        Catch
            MsgBox(Err.Description)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_stellvertretungen_select"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_stellvertretungen_insert"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_stellvertretungen_delete"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_stellvertretungen1_select"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 2
                    Dim dbkey As New edokadb.clsMyKey_Tabelle()
                    Dim key As Long
                    dbkey.cpMainConnectionProvider = conn
                    key = dbkey.get_dbkey("StellvertretungDomain")

                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nreintrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, key))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@vertreter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertreter))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@von", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, von))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@bis", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, bis))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Stellvertretungtyp))
                Case 3
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nreintrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.C1TrueDBGrid1.Columns("nreintrag").Text))
                Case 4
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GetTreeInfo Method

Private Function GetTreeInfo( _
   ByVal sText As String _
) As String

Parameters

sText
Required.

Source code

[Visual Basic]
    Private Function GetTreeInfo(ByVal sText As String) As String
        '===============================================================================
        'Description : Daten in der DataTable suchen.
        'Input       : Suchtext
        'Criteria    : Resultat als Text
        'Output      : DataTable
        'Date        : bud 18.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        Dim Pview As New DataView()
        Dim iFind As Integer
        Dim vals(0) As Object
        Dim sTag As String
        Dim sToolVert As String
        Dim sToolMA As String
        Dim sToolVip As String
        Dim sText1 As String
        Dim sText2 As String
        Pview = New DataView(dtToReturn)
        Pview.Sort = "dokumenttypnr"

        vals(0) = sText

        iFind = Pview.Find(vals)
        'Debug.Write(Pview(iFind))

        sText1 = "berechtigt"
        sText2 = "nicht berechtigt"
        If Pview.Item(iFind)("Vertraulich") = 1 Then
            sToolVert = sText1
        Else
            sToolVert = sText2
        End If
        If Pview.Item(iFind)("Mitarbeiter") = 1 Then
            sToolMA = sText1
        Else
            sToolMA = sText2
        End If
        If Pview.Item(iFind)("VIP") = 1 Then
            sToolVip = sText1
        Else
            sToolVip = sText2
        End If
        sTag = vbCrLf + "  Vertraulich = " + sToolVert + vbCrLf
        sTag = sTag + "  Mitarbeiter = " + sToolMA + "  " + vbCrLf
        sTag = sTag + "  VIP = " + sToolVip + "  " + vbCrLf
        GetTreeInfo = sTag

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.GrdDatumformat Method

Private Sub GrdDatumformat( _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid, _
   ByVal SpaltenDatafield As String, _
   ByVal DatumFormat As EnumDatumformat _
)

Parameters

grd
Required.
SpaltenDatafield
Required.
DatumFormat
Required.

Source code

[Visual Basic]
    Private Sub GrdDatumformat(ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid, ByVal SpaltenDatafield As String, ByVal DatumFormat As EnumDatumformat)
        Dim iCount As Integer
        Try
            For iCount = 0 To grd.Columns.Count - 1
                If SpaltenDatafield = CStr(grd.Columns(iCount).DataField) Then
                    Select Case DatumFormat

                        Case EnumDatumformat.Mittel     '=dd.mm.yyyy
                            grd.Columns(iCount).NumberFormat = "dd.MM.yyyy"
                        Case EnumDatumformat.Standart   '= dd.mm.yyyy hh:nn:ss
                            grd.Columns(iCount).NumberFormat = "dd.MM.yyyy HH:mm:nn"
                    End Select
                    Exit For
                End If
            Next

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmMitarbeitereinstellungen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.C1TrueDBGrid2 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtRang = New System.Windows.Forms.TextBox()
        Me.Label35 = New System.Windows.Forms.Label()
        Me.txtFunktion = New System.Windows.Forms.TextBox()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.txtTelefax = New System.Windows.Forms.TextBox()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.txtTelefon = New System.Windows.Forms.TextBox()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.cedoka_mail = New System.Windows.Forms.CheckBox()
        Me.cmaileingang = New System.Windows.Forms.CheckBox()
        Me.cEdokaMessage = New System.Windows.Forms.CheckBox()
        Me.cMailDirekt = New System.Windows.Forms.CheckBox()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.txtMailadresse = New System.Windows.Forms.TextBox()
        Me.cmailempfang = New System.Windows.Forms.CheckBox()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.txtSearch = New System.Windows.Forms.TextBox()
        Me.ToolBar2 = New System.Windows.Forms.ToolBar()
        Me.btnSearch = New System.Windows.Forms.ToolBarButton()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.TV2 = New System.Windows.Forms.TreeView()
        Me.txtSearchNotBerechtigt = New System.Windows.Forms.TextBox()
        Me.ToolBar3 = New System.Windows.Forms.ToolBar()
        Me.btnSucheNotBerechtigt = New System.Windows.Forms.ToolBarButton()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.GroupBox8.SuspendLayout()
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox7.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.SuspendLayout()
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label2, Me.C1TrueDBGrid2, Me.C1TrueDBGrid1, Me.Label1})
        Me.GroupBox8.Location = New System.Drawing.Point(16, 176)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(616, 240)
        Me.GroupBox8.TabIndex = 32
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Stellvertretungen"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 136)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(104, 48)
        Me.Label2.TabIndex = 35
        Me.Label2.Text = "Stellvertreter von"
        '
        'C1TrueDBGrid2
        '
        Me.C1TrueDBGrid2.AllowFilter = True
        Me.C1TrueDBGrid2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid2.AllowSort = True
        Me.C1TrueDBGrid2.AlternatingRows = True
        Me.C1TrueDBGrid2.CaptionHeight = 17
        Me.C1TrueDBGrid2.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.DataChanged = False
        Me.C1TrueDBGrid2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid2.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid2.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid2.Location = New System.Drawing.Point(112, 128)
        Me.C1TrueDBGrid2.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid2.Name = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid2.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid2.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid2.RowDivider = GridLines1
        Me.C1TrueDBGrid2.RowHeight = 15
        Me.C1TrueDBGrid2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid2.ScrollTips = False
        Me.C1TrueDBGrid2.Size = New System.Drawing.Size(496, 104)
        Me.C1TrueDBGrid2.TabIndex = 4
        Me.C1TrueDBGrid2.Text = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 492, 100</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRe" & _
        "cSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 492, 100</ClientArea></Blob>"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(112, 24)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines2
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(496, 96)
        Me.C1TrueDBGrid1.TabIndex = 3
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 492, 92</ClientRect><Bo" & _
        "rderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle" & _
        " parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fil" & _
        "terBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""S" & _
        "tyle3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading" & _
        """ me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactive" & _
        "Style parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /" & _
        "><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle pare" & _
        "nt=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1True" & _
        "DBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style par" & _
        "ent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=" & _
        """Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""" & _
        "Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Norm" & _
        "al"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Nor" & _
        "mal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""" & _
        "Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ver" & _
        "tSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRec" & _
        "SelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 492, 92</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Hinzufügen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Löschen"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(104, 48)
        Me.Label1.TabIndex = 34
        Me.Label1.Text = "Gesetzte Stellvertretungen"
        '
        'GroupBox7
        '
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label4, Me.txtRang, Me.Label35, Me.txtFunktion, Me.Label34, Me.txtTelefax, Me.Label33, Me.txtTelefon})
        Me.GroupBox7.Location = New System.Drawing.Point(376, 16)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(256, 152)
        Me.GroupBox7.TabIndex = 31
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Persönliche Daten"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(16, 120)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(48, 16)
        Me.Label4.TabIndex = 12
        Me.Label4.Text = "Rang"
        '
        'txtRang
        '
        Me.txtRang.Location = New System.Drawing.Point(72, 120)
        Me.txtRang.Name = "txtRang"
        Me.txtRang.Size = New System.Drawing.Size(168, 20)
        Me.txtRang.TabIndex = 9
        Me.txtRang.Text = "TextBox4"
        '
        'Label35
        '
        Me.Label35.Location = New System.Drawing.Point(16, 88)
        Me.Label35.Name = "Label35"
        Me.Label35.Size = New System.Drawing.Size(48, 16)
        Me.Label35.TabIndex = 10
        Me.Label35.Text = "Funktion"
        '
        'txtFunktion
        '
        Me.txtFunktion.Location = New System.Drawing.Point(72, 88)
        Me.txtFunktion.Name = "txtFunktion"
        Me.txtFunktion.Size = New System.Drawing.Size(168, 20)
        Me.txtFunktion.TabIndex = 8
        Me.txtFunktion.Text = "TextBox4"
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(16, 56)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(48, 16)
        Me.Label34.TabIndex = 8
        Me.Label34.Text = "Telefax"
        '
        'txtTelefax
        '
        Me.txtTelefax.Location = New System.Drawing.Point(72, 56)
        Me.txtTelefax.Name = "txtTelefax"
        Me.txtTelefax.Size = New System.Drawing.Size(168, 20)
        Me.txtTelefax.TabIndex = 7
        Me.txtTelefax.Text = "TextBox3"
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(16, 24)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(48, 16)
        Me.Label33.TabIndex = 6
        Me.Label33.Text = "Telefon"
        '
        'txtTelefon
        '
        Me.txtTelefon.Location = New System.Drawing.Point(72, 24)
        Me.txtTelefon.Name = "txtTelefon"
        Me.txtTelefon.Size = New System.Drawing.Size(168, 20)
        Me.txtTelefon.TabIndex = 6
        Me.txtTelefon.Text = "TextBox2"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.cedoka_mail, Me.cmaileingang, Me.cEdokaMessage, Me.cMailDirekt, Me.Label32, Me.txtMailadresse, Me.cmailempfang})
        Me.GroupBox6.Location = New System.Drawing.Point(16, 16)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(352, 152)
        Me.GroupBox6.TabIndex = 30
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Maileinstellungen"
        '
        'cedoka_mail
        '
        Me.cedoka_mail.Location = New System.Drawing.Point(16, 72)
        Me.cedoka_mail.Name = "cedoka_mail"
        Me.cedoka_mail.Size = New System.Drawing.Size(216, 24)
        Me.cedoka_mail.TabIndex = 6
        Me.cedoka_mail.Text = "Meldungen via EDOKA empfangen"
        '
        'cmaileingang
        '
        Me.cmaileingang.Location = New System.Drawing.Point(16, 128)
        Me.cmaileingang.Name = "cmaileingang"
        Me.cmaileingang.Size = New System.Drawing.Size(248, 16)
        Me.cmaileingang.TabIndex = 5
        Me.cmaileingang.Text = "Meldung bei Dokumenteingang empfangen"
        '
        'cEdokaMessage
        '
        Me.cEdokaMessage.Location = New System.Drawing.Point(16, 96)
        Me.cEdokaMessage.Name = "cEdokaMessage"
        Me.cEdokaMessage.Size = New System.Drawing.Size(328, 32)
        Me.cEdokaMessage.TabIndex = 5
        Me.cEdokaMessage.Text = "Informationsmeldung bei Dokumentzuweisung empfangen"
        '
        'cMailDirekt
        '
        Me.cMailDirekt.Location = New System.Drawing.Point(16, 128)
        Me.cMailDirekt.Name = "cMailDirekt"
        Me.cMailDirekt.Size = New System.Drawing.Size(208, 16)
        Me.cMailDirekt.TabIndex = 4
        Me.cMailDirekt.Text = "Direkt versenden"
        Me.cMailDirekt.Visible = False
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(32, 48)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(48, 16)
        Me.Label32.TabIndex = 2
        Me.Label32.Text = "Adresse"
        '
        'txtMailadresse
        '
        Me.txtMailadresse.Location = New System.Drawing.Point(80, 48)
        Me.txtMailadresse.Name = "txtMailadresse"
        Me.txtMailadresse.ReadOnly = True
        Me.txtMailadresse.Size = New System.Drawing.Size(168, 20)
        Me.txtMailadresse.TabIndex = 1
        Me.txtMailadresse.Text = "TextBox1"
        '
        'cmailempfang
        '
        Me.cmailempfang.Location = New System.Drawing.Point(16, 24)
        Me.cmailempfang.Name = "cmailempfang"
        Me.cmailempfang.Size = New System.Drawing.Size(216, 24)
        Me.cmailempfang.TabIndex = 0
        Me.cmailempfang.Text = "Meldungen via E-Mail empfangen"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(672, 25)
        Me.ToolBar1.TabIndex = 33
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Schliessen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.ToolTipText = "Einstellungen sichern"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2, Me.TabPage3})
        Me.TabControl1.ImageList = Me.ImageList3
        Me.TabControl1.Location = New System.Drawing.Point(8, 32)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(656, 464)
        Me.TabControl1.TabIndex = 34
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox6, Me.GroupBox7, Me.GroupBox8})
        Me.TabPage1.Location = New System.Drawing.Point(4, 23)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(648, 437)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Mitarbeitereinstellungen"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtSearch, Me.ToolBar2, Me.TreeView1})
        Me.TabPage2.Location = New System.Drawing.Point(4, 23)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(648, 437)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Leseberechtigte Dokumente"
        '
        'txtSearch
        '
        Me.txtSearch.Location = New System.Drawing.Point(24, 5)
        Me.txtSearch.Name = "txtSearch"
        Me.txtSearch.Size = New System.Drawing.Size(130, 20)
        Me.txtSearch.TabIndex = 36
        Me.txtSearch.Text = ""
        '
        'ToolBar2
        '
        Me.ToolBar2.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnSearch})
        Me.ToolBar2.DropDownArrows = True
        Me.ToolBar2.ImageList = Me.ImageList1
        Me.ToolBar2.Name = "ToolBar2"
        Me.ToolBar2.ShowToolTips = True
        Me.ToolBar2.Size = New System.Drawing.Size(648, 39)
        Me.ToolBar2.TabIndex = 1
        '
        'btnSearch
        '
        Me.btnSearch.ImageIndex = 2
        Me.btnSearch.ToolTipText = "Suchen"
        '
        'TreeView1
        '
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TreeView1.FullRowSelect = True
        Me.TreeView1.HideSelection = False
        Me.TreeView1.ImageList = Me.ImageList3
        Me.TreeView1.Location = New System.Drawing.Point(0, 29)
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Size = New System.Drawing.Size(648, 408)
        Me.TreeView1.TabIndex = 0
        Me.ToolTip1.SetToolTip(Me.TreeView1, "1")
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TV2, Me.txtSearchNotBerechtigt, Me.ToolBar3})
        Me.TabPage3.Location = New System.Drawing.Point(4, 23)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(648, 437)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Nicht leseberechtigte Dokumente"
        '
        'TV2
        '
        Me.TV2.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TV2.FullRowSelect = True
        Me.TV2.HideSelection = False
        Me.TV2.ImageList = Me.ImageList3
        Me.TV2.Location = New System.Drawing.Point(0, 29)
        Me.TV2.Name = "TV2"
        Me.TV2.Size = New System.Drawing.Size(648, 408)
        Me.TV2.TabIndex = 2
        '
        'txtSearchNotBerechtigt
        '
        Me.txtSearchNotBerechtigt.Location = New System.Drawing.Point(24, 5)
        Me.txtSearchNotBerechtigt.Name = "txtSearchNotBerechtigt"
        Me.txtSearchNotBerechtigt.Size = New System.Drawing.Size(130, 20)
        Me.txtSearchNotBerechtigt.TabIndex = 1
        Me.txtSearchNotBerechtigt.Text = ""
        '
        'ToolBar3
        '
        Me.ToolBar3.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnSucheNotBerechtigt})
        Me.ToolBar3.DropDownArrows = True
        Me.ToolBar3.ImageList = Me.ImageList1
        Me.ToolBar3.Name = "ToolBar3"
        Me.ToolBar3.ShowToolTips = True
        Me.ToolBar3.Size = New System.Drawing.Size(648, 39)
        Me.ToolBar3.TabIndex = 0
        '
        'btnSucheNotBerechtigt
        '
        Me.btnSucheNotBerechtigt.ImageIndex = 2
        Me.btnSucheNotBerechtigt.ToolTipText = "Suchen"
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(643, 3)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 68
        '
        'frmMitarbeitereinstellungen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(672, 502)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.TabControl1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmMitarbeitereinstellungen"
        Me.Text = "Mitarbeitereinstellungen"
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox7.ResumeLayout(False)
        Me.GroupBox6.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim f As New frmStellvertreterAdd()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.von = f.DateTimePicker1.Value
            Me.bis = f.DateTimePicker2.Value
            Me.vertreter = f.vertreter
            Me.stellvertretungtyp = f.Stellvertretungtyp
            Generic_Select(2)
            fill_c1()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        If Me.C1TrueDBGrid1.Splits(0).Rows.Count = 0 Then Exit Sub
        If MyMsg.Show_MessageYesNo(16) = MsgBoxResult.Yes Then
            Generic_Select(3)
            fill_c1()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.TabControl1_MouseDown Method

Private Sub TabControl1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TabControl1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TabControl1.MouseDown
        Try
            Me.BringToFront()
            Me.txtSearch.Text = ""
            Me.txtSearchNotBerechtigt.Text = ""

            Select Case Me.TabControl1.SelectedIndex
                Case 0
                    Exit Sub
                Case 1
                    Me.txtSearch.Select()
                    GenerateTreeView("", False, 1)
                Case 2
                    Me.txtSearchNotBerechtigt.Select()
                    GenerateTreeView("", False, 2)
            End Select

        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::Error occured." & ex.Message, ex)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 1
                save_data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.ToolBar2_ButtonClick Method

Private Sub ToolBar2_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar2.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar2_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar2.ButtonClick
        Select Case ToolBar2.Buttons.IndexOf(e.Button)
            Case 0 'Suchen Start
                'Tree Aufbauen und nach SuchText suchen
                GenerateTreeView(Me.txtSearch.Text, True, 1)
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.ToolBar3_ButtonClick Method

Private Sub ToolBar3_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar3.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar3_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar3.ButtonClick
        Select Case ToolBar2.Buttons.IndexOf(e.Button)
            Case 0 'Suchen Start nicht berechtigte Dokumente
                'Tree Aufbauen und nach SuchText suchen
                GenerateTreeView(Me.txtSearchNotBerechtigt.Text, True, 2)
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.TreeView1_MouseMove Method

Private Sub TreeView1_MouseMove( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseMove

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_MouseMove(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseMove
        Try
            Static old_node As TreeNode
            Dim node_here As TreeNode = TreeView1.GetNodeAt(e.X, e.Y)
            If node_here Is old_node Then Exit Sub
            old_node = node_here

            ToolTip1.AutoPopDelay = 1000000
            ToolTip1.InitialDelay = 1
            ToolTip1.RemoveAll()
            If old_node Is Nothing Then
                ToolTip1.SetToolTip(TreeView1, "")
            Else
                If node_here.Nodes.Count = 0 Then
                    TreeView1.SelectedNode = TreeView1.GetNodeAt(e.X, e.Y)
                    ToolTip1.SetToolTip(TreeView1, GetTreeInfo(old_node.Tag))
                End If
            End If

        Catch
            MsgBox(Err.Description)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.check_changes Method

Private Sub check_changes( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cMailDirekt.CheckedChanged, _
   cedoka_mail.CheckStateChanged, _
   cEdokaMessage.CheckedChanged, _
   cmaileingang.CheckedChanged, _
   txtFunktion.TextChanged, _
   txtMailadresse.TextChanged, _
   txtRang.TextChanged, _
   txtTelefax.TextChanged, _
   txtTelefon.TextChanged, _
   cedoka_mail.CheckStateChanged, _
   cEdokaMessage.CheckStateChanged, _
   cmaileingang.CheckStateChanged, _
   cmailempfang.CheckStateChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub check_changes(ByVal sender As Object, ByVal e As System.EventArgs) Handles cMailDirekt.CheckedChanged, cedoka_mail.CheckStateChanged, _
    cEdokaMessage.CheckedChanged, cmaileingang.CheckedChanged, txtFunktion.TextChanged, txtMailadresse.TextChanged, _
    txtRang.TextChanged, txtTelefax.TextChanged, txtTelefon.TextChanged, cedoka_mail.CheckStateChanged, _
    cEdokaMessage.CheckStateChanged, cmaileingang.CheckStateChanged, cmailempfang.CheckStateChanged
        changed = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.fill_c1 Method

Private Sub fill_c1()

Source code

[Visual Basic]
    Private Sub fill_c1()
        Try
            Me.C1TrueDBGrid1.DataSource = Generic_Select(1)
            DivFnkt.SpaltenTitel_Aktualisieren(Me.C1TrueDBGrid1, Generic_Select(1), "stellvertretungen")
            GrdDatumformat(C1TrueDBGrid1, "datumvon", EnumDatumformat.Mittel)
            GrdDatumformat(C1TrueDBGrid1, "datumbis", EnumDatumformat.Mittel)

            Me.C1TrueDBGrid2.DataSource = Generic_Select(4)
            DivFnkt.SpaltenTitel_Aktualisieren(Me.C1TrueDBGrid2, Generic_Select(4), "stellvertretungen")
            GrdDatumformat(C1TrueDBGrid2, "datumvon", EnumDatumformat.Mittel)
            GrdDatumformat(C1TrueDBGrid2, "datumbis", EnumDatumformat.Mittel)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.frmMitarbeitereinstellungen_Closing Method

Private Sub frmMitarbeitereinstellungen_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMitarbeitereinstellungen_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        'Rel 3.3
        '06.12.2004 / BUD
        'Prüfen ob eine Versandart gewählt wurde.
        If changed Then
            If MyMsg.Show_MessageYesNo(2) = MsgBoxResult.Yes Then
                If save_data() = False Then
                    e.Cancel = True
                    Exit Sub
                End If
            End If
        End If
        If CheckIsBenachrichtigung() = False Then
            MsgBox(MyMsg.Get_Meldungstext(265), MsgBoxStyle.Exclamation)
            e.Cancel = True
            Exit Sub
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.frmMitarbeitereinstellungen_Load Method

Private Sub frmMitarbeitereinstellungen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmMitarbeitereinstellungen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ma As New edokadb.clsMitarbeiter()
        ma.cpMainConnectionProvider = conn
        ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ma.SelectOne()
        Me.cEdokaMessage.Checked = ma.bEdokaMesasge.Value
        Me.cedoka_mail.Checked = ma.bEdoka_mail.Value
        Me.cmailempfang.Checked = ma.bMailempfang.Value
        Try
            Me.cMailDirekt.Checked = ma.bMailDirektVersenden.Value
        Catch
            Me.cMailDirekt.Checked = False
        End Try
        Me.txtMailadresse.Text = ma.sEmail.Value
        Me.txtTelefax.Text = ma.sFax.Value
        Me.txtTelefon.Text = ma.sTelefon.Value
        Try
            Me.txtFunktion.Text = ma.sFunktion.Value
        Catch
            Me.txtFunktion.Text = ""
        End Try
        Try
            Me.txtRang.Text = ma.sRang.Value
        Catch
            Me.txtRang.Text = ""
        End Try
        Try
            Me.cmaileingang.Checked = ma.bMailDokumentrueckgang.Value = True
        Catch
            Me.cmaileingang.Checked = True
        End Try
        ma.Dispose()
        fill_c1()
        changed = False

        m_bLoadTreeDokBerecht = False
        'BUD Ausblenden von Tab2 da dies evtl noch nicht fetig ist.
        If 1 <> 1 Then
            Dim m_tab As TabPage
            Dim m_idx As Integer
            m_tab = Me.TabControl1.TabPages(1)
            Me.TabControl1.TabPages.RemoveAt(1)
            m_idx = 1
        End If
        Me.BringToFront()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.read_to_root Method

Function read_to_root( _
   ByVal drv As DataRowView, _
   ByVal dt As DataTable, _
   ByRef DataTableOriginal As DataTable _
)

Parameters

drv
Required.
dt
Required.
DataTableOriginal
Required.

Source code

[Visual Basic]
    Function read_to_root(ByVal drv As DataRowView, ByVal dt As DataTable, ByRef DataTableOriginal As DataTable)
        Dim parent As Integer
        parent = drv.Item(5)
        While parent <> 0
            Dim dview As New DataView(DataTableOriginal, "dokumentartnr= " + Trim(Str(parent)), "Parentid, sort", DataViewRowState.CurrentRows)
            Dim drv1 As DataRowView
            For Each drv1 In dview
                Dim dview1 As New DataView(dt, "dokumentartnr=" + Trim(drv1.Item(0)), "", DataViewRowState.CurrentRows)
                Dim drv2 As DataRowView
                Dim i As Integer
                i = 0
                For Each drv2 In dview1
                    i = i + 1
                Next
                dview1.Dispose()
                If i = 0 Then dt.ImportRow(drv1.Row)
                parent = drv1.Item(5)
                dview.Dispose()
            Next
        End While
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.save_data Method

Public Function save_data() As Boolean

Source code

[Visual Basic]
    Public Function save_data() As Boolean
        'Rel 3.3
        '06.12.2004 / BUD
        'Prüfen ob eine Versandart gewählt wurde.
        If cmailempfang.Checked = False And cedoka_mail.Checked = False Then
            MsgBox(MyMsg.Get_Meldungstext(265), MsgBoxStyle.Exclamation)
            save_data = False
        Else
            save_data = True
        End If

        Dim ma As New edokadb.clsMitarbeiter()
        conn.OpenConnection()
        ma.cpMainConnectionProvider = conn
        ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ma.SelectOne()
        ma.bEdokaMesasge = New SqlBoolean(CType(Me.cEdokaMessage.Checked, Boolean))
        ma.bMailempfang = New SqlBoolean(CType(Me.cmailempfang.Checked, Boolean))
        ma.bMailDirektVersenden = New SqlBoolean(CType(Me.cMailDirekt.Checked, Boolean))
        ma.sEmail = New SqlString(CType(Me.txtMailadresse.Text, String))
        ma.sTelefon = New SqlString(CType(Me.txtTelefon.Text, String))
        ma.sFax = New SqlString(CType(Me.txtTelefax.Text, String))
        ma.sFunktion = New SqlString(CType(Me.txtFunktion.Text, String))
        ma.sRang = New SqlString(CType(Me.txtRang.Text, String))
        ma.bMailDokumentrueckgang = New SqlBoolean(CType(Me.cmaileingang.Checked, Boolean))
        ma.bEdoka_mail = New SqlBoolean(CType(Me.cedoka_mail.Checked, Boolean))
        ma.Update()
        conn.CloseConnection(True)
        ma.Dispose()
        changed = False
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.txtSearchNotBerechtigt_KeyDown Method

Private Sub txtSearchNotBerechtigt_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtSearchNotBerechtigt.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtSearchNotBerechtigt_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtSearchNotBerechtigt.KeyDown
        If e.KeyCode = Keys.Return Then
            'Tree Aufbauen und nach SuchText suchen
            GenerateTreeView(Me.txtSearchNotBerechtigt.Text, True, 2)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen.txtSearch_KeyDown Method

Private Sub txtSearch_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtSearch.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtSearch_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtSearch.KeyDown
        If e.KeyCode = Keys.Return Then
            'Tree Aufbauen und nach SuchText suchen
            GenerateTreeView(Me.txtSearch.Text, True, 1)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmMitarbeitereinstellungen Fields

frmMitarbeitereinstellungen overview

Fields

field BtnHelp
field C1TrueDBGrid1
field C1TrueDBGrid2
field ContextMenu1
field DokBerecht
field DokNotBerecht
field DokNotBerechtOrg
field GroupBox6
field GroupBox7
field GroupBox8
field ImageList1
field ImageList3
field Label1
field Label2
field Label32
field Label33
field Label34
field Label35
field Label4
field MenuItem1
field MenuItem2
field Stellvertretungtyp
field TV2
field TabControl1
field TabPage1
field TabPage2
field TabPage3
field ToolBar1
field ToolBar2
field ToolBar3
field ToolBarButton1
field ToolBarButton2
field ToolTip1
field TreeView1
field bis
field btnSearch
field btnSucheNotBerechtigt
field cEdokaMessage
field cMailDirekt
field cedoka_mail
field changed
field cmaileingang
field cmailempfang
field components
field dtToReturn
field m_bLoadTreeDokBerecht
field m_bLoadTreeDokNichtBerecht
field txtFunktion
field txtMailadresse
field txtRang
field txtSearch
field txtSearchNotBerechtigt
field txtTelefax
field txtTelefon
field vertreter
field von

See Also

frmMitarbeitereinstellungen Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


C1TrueDBGrid2 Variable

Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


DokBerecht Variable

Dim DokBerecht As New DataTable()

Source code

[Visual Basic]
    Dim DokBerecht As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


DokNotBerecht Variable

Dim DokNotBerecht As New DataTable()

Source code

[Visual Basic]
    Dim DokNotBerecht As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


DokNotBerechtOrg Variable

Dim DokNotBerechtOrg As New DataTable()

Source code

[Visual Basic]
    Dim DokNotBerechtOrg As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label35 Variable

Friend WithEvents Label35 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label35 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


Stellvertretungtyp Variable

Dim Stellvertretungtyp As Integer = 0

Source code

[Visual Basic]
    Dim Stellvertretungtyp As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TV2 Variable

Friend WithEvents TV2 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TV2 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolBar2 Variable

Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolBar3 Variable

Friend WithEvents ToolBar3 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar3 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


bis Variable

Dim bis As DateTime

Source code

[Visual Basic]
    Dim bis As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


btnSearch Variable

Friend WithEvents btnSearch As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSearch As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


btnSucheNotBerechtigt Variable

Friend WithEvents btnSucheNotBerechtigt As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSucheNotBerechtigt As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


cEdokaMessage Variable

Friend WithEvents cEdokaMessage As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cEdokaMessage As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


cMailDirekt Variable

Friend WithEvents cMailDirekt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cMailDirekt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


cedoka_mail Variable

Friend WithEvents cedoka_mail As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cedoka_mail As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


changed Variable

Dim changed As Boolean = False

Source code

[Visual Basic]
    Dim changed As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


cmaileingang Variable

Friend WithEvents cmaileingang As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cmaileingang As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


cmailempfang Variable

Friend WithEvents cmailempfang As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cmailempfang As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


dtToReturn Variable

Dim dtToReturn As DataTable = New DataTable()

Source code

[Visual Basic]
    Dim dtToReturn As DataTable = New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


m_bLoadTreeDokBerecht Variable

Dim m_bLoadTreeDokBerecht As Boolean

Source code

[Visual Basic]
    Dim m_bLoadTreeDokBerecht As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


m_bLoadTreeDokNichtBerecht Variable

Dim m_bLoadTreeDokNichtBerecht As Boolean

Source code

[Visual Basic]
    Dim m_bLoadTreeDokNichtBerecht As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtFunktion Variable

Friend WithEvents txtFunktion As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtFunktion As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtMailadresse Variable

Friend WithEvents txtMailadresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtMailadresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtRang Variable

Friend WithEvents txtRang As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtRang As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtSearch Variable

Friend WithEvents txtSearch As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtSearch As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtSearchNotBerechtigt Variable

Friend WithEvents txtSearchNotBerechtigt As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtSearchNotBerechtigt As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtTelefax Variable

Friend WithEvents txtTelefax As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTelefax As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


txtTelefon Variable

Friend WithEvents txtTelefon As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTelefon As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


vertreter Variable

Dim vertreter As Integer

Source code

[Visual Basic]
    Dim vertreter As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


von Variable

Dim von As DateTime

Source code

[Visual Basic]
    Dim von As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmMitarbeitereinstellungen


frmNLDokumente Class

For a list of all members of this type, see frmNLDokumente Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmNLDokumente

Public Class frmNLDokumente
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNLDokumente Members


frmNLDokumente Members

frmNLDokumente overview

Constructors

constructor frmNLDokumente Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmNLDokumente Class


frmNLDokumente Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente Properties

frmNLDokumente overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmNLDokumente Class


frmNLDokumente Methods

frmNLDokumente overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmNLDokumente Class


frmNLDokumente.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "niederlassung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("niederlassungnr", "niederlassungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("nlnummer", "nlnummer"), New System.Data.Common.DataColumnMapping("nltyp", "nltyp"), New System.Data.Common.DataColumnMapping("edoka_dokumenterstellung", "edoka_dokumenterstellung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_niederlassung_dok_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_niederlassung_dok_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_niederlassung_dok_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_niederlassung_dok_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nlnummer", System.Data.SqlDbType.Int, 4, "nlnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nltyp", System.Data.SqlDbType.VarChar, 255, "nltyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, "edoka_dokumenterstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_edoka_dokumenterstellung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "edoka_dokumenterstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nlnummer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nlnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nltyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nltyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("dokumentart_weitere", "dokumentart_weitere"), New System.Data.Common.DataColumnMapping("dokumentart_nativ", "dokumentart_nativ"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus"), New System.Data.Common.DataColumnMapping("Dokument_wird_erstellt", "Dokument_wird_erstellt"), New System.Data.Common.DataColumnMapping("Dokument_wird_retourniert", "Dokument_wird_retourniert"), New System.Data.Common.DataColumnMapping("cold_ersetzen", "cold_ersetzen"), New System.Data.Common.DataColumnMapping("email_versand", "email_versand"), New System.Data.Common.DataColumnMapping("funktionen_zuweisen", "funktionen_zuweisen"), New System.Data.Common.DataColumnMapping("dokumentstatus_barcode", "dokumentstatus_barcode"), New System.Data.Common.DataColumnMapping("nurnative", "nurnative"), New System.Data.Common.DataColumnMapping("Owner", "Owner"), New System.Data.Common.DataColumnMapping("vertrag", "vertrag"), New System.Data.Common.DataColumnMapping("objektbezeichnungnr", "objektbezeichnungnr")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_dokumenttyp_nl_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Owner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_ersetzen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_ersetzen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_nativ", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus_barcode", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus_barcode", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email_versand", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email_versand", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionen_zuweisen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionen_zuweisen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nurnative", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nurnative", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_objektbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "objektbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrag", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_dokumenttyp_nl_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_nativ", System.Data.SqlDbType.Int, 4, "dokumentart_nativ"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_ersetzen", System.Data.SqlDbType.Bit, 1, "cold_ersetzen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email_versand", System.Data.SqlDbType.Bit, 1, "email_versand"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionen_zuweisen", System.Data.SqlDbType.Bit, 1, "funktionen_zuweisen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus_barcode", System.Data.SqlDbType.Int, 4, "dokumentstatus_barcode"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nurnative", System.Data.SqlDbType.Bit, 1, "nurnative"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Owner", System.Data.SqlDbType.Int, 4, "Owner"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrag", System.Data.SqlDbType.Bit, 1, "vertrag"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@objektbezeichnungnr", System.Data.SqlDbType.Int, 4, "objektbezeichnungnr"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_dokumenttyp_nl_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_dokumenttyp_nl_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_nativ", System.Data.SqlDbType.Int, 4, "dokumentart_nativ"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_ersetzen", System.Data.SqlDbType.Bit, 1, "cold_ersetzen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email_versand", System.Data.SqlDbType.Bit, 1, "email_versand"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionen_zuweisen", System.Data.SqlDbType.Bit, 1, "funktionen_zuweisen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus_barcode", System.Data.SqlDbType.Int, 4, "dokumentstatus_barcode"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nurnative", System.Data.SqlDbType.Bit, 1, "nurnative"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Owner", System.Data.SqlDbType.Int, 4, "Owner"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrag", System.Data.SqlDbType.Bit, 1, "vertrag"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@objektbezeichnungnr", System.Data.SqlDbType.Int, 4, "objektbezeichnungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Owner", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Owner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_ersetzen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_ersetzen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_nativ", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_nativ", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus_barcode", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus_barcode", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email_versand", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email_versand", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionen_zuweisen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionen_zuweisen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nurnative", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nurnative", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_objektbezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "objektbezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrag", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrag", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "nldokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("nldokumenttypnr", "nldokumenttypnr"), New System.Data.Common.DataColumnMapping("niederlassungnr", "niederlassungnr"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_nldokumenttyp_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nldokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nldokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_nldokumenttyp_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nldokumenttypnr", System.Data.SqlDbType.Int, 4, "nldokumenttypnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_nldokumenttyp_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_nldokumenttyp_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nldokumenttypnr", System.Data.SqlDbType.Int, 4, "nldokumenttypnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@niederlassungnr", System.Data.SqlDbType.Int, 4, "niederlassungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_nldokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "nldokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_niederlassungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "niederlassungnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmNLDokumente
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmNLDokumente"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsNldokumenttyp()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iNiederlassungnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iNiederlassungnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iNiederlassungnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("nldokumenttyp")
            vdata.iNldokumenttypnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5045, 5046, 5047)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "niederlassung"
        Me.TableNameRight = "dokumenttyp"
        Me.TableNameBottom = "nldokumenttyp"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNLDokumente Fields

frmNLDokumente overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmNLDokumente Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNLDokumente


frmNewNote Class

For a list of all members of this type, see frmNewNote Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNewNote

Public Class frmNewNote
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNewNote Members


frmNewNote Members

frmNewNote overview

Constructors

constructor frmNewNote Constructor

Properties

property ondemand

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method frmNewNote_Load

Fields

field Button1
field Button2
field Label1
field TextBox1
field components

See Also

frmNewNote Class


frmNewNote Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote Properties

frmNewNote overview

Properties

property ondemand

See Also

frmNewNote Class


ondemand Property

Public ondemand As Object

Source code

[Visual Basic]
    Public ondemand As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote Methods

frmNewNote overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method frmNewNote_Load

See Also

frmNewNote Class


frmNewNote.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim ret As Short
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf + vbCrLf + "----------------------------------------------------"
        Me.TextBox1.Text = Me.TextBox1.Text + vbCrLf
        Me.TextBox1.Text = Me.TextBox1.Text + Globals.CurrentMitarbeiterdata.Rows(0).Item("name") + " " + Globals.CurrentMitarbeiterdata.Rows(0).Item("vorname") + ", " + Globals.CurrentMitarbeiterdata.Rows(0).Item("tgnummer")
        ret = Me.ondemand.AnnotateDoc(0, Me.TextBox1.Text, 1, 1, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmNewNote))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Notiz"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(8, 24)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(472, 128)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(160, 160)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(240, 160)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&Speichern"
        '
        'frmNewNote
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(496, 190)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.TextBox1, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmNewNote"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Neue Notiz erfassen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote.frmNewNote_Load Method

Private Sub frmNewNote_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmNewNote_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNewNote Fields

frmNewNote overview

Fields

field Button1
field Button2
field Label1
field TextBox1
field components

See Also

frmNewNote Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNewNote


frmNoteDetail Class

For a list of all members of this type, see frmNoteDetail Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNoteDetail

Public Class frmNoteDetail
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNoteDetail Members


frmNoteDetail Members

frmNoteDetail overview

Constructors

constructor frmNoteDetail Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent

Fields

field Button1
field Label1
field Label2
field TextBox1
field TextBox2
field components

See Also

frmNoteDetail Class


frmNoteDetail Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


frmNoteDetail Methods

frmNoteDetail overview

Methods

method Button1_Click
method Dispose
method InitializeComponent

See Also

frmNoteDetail Class


frmNoteDetail.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


frmNoteDetail.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


frmNoteDetail.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmNoteDetail))
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(64, 48)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(512, 168)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "TextBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Datum"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(64, 16)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(512, 20)
        Me.TextBox2.TabIndex = 2
        Me.TextBox2.Text = "TextBox2"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(56, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Notiz"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(256, 224)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 4
        Me.Button1.Text = "&Schliessen"
        '
        'frmNoteDetail
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(592, 254)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Label2, Me.TextBox2, Me.Label1, Me.TextBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmNoteDetail"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Notiz"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


frmNoteDetail Fields

frmNoteDetail overview

Fields

field Button1
field Label1
field Label2
field TextBox1
field TextBox2
field components

See Also

frmNoteDetail Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNoteDetail


frmNotes Class

For a list of all members of this type, see frmNotes Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNotes

Public Class frmNotes
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNotes Members


frmNotes Members

frmNotes overview

Constructors

constructor frmNotes Constructor

Properties

property k
property notes
property o
property ondemand
property zf

Methods

method BtnDelete_Click
method BtnNew_Click
method ContextMenu1_Popup
method Dispose
method Form1_Load
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method NoteList_DoubleClick
method frmNotes_Closing
method get_annotations

Fields

field BtnDelete
field BtnNew
field ContextMenu1
field MenuItem1
field MenuItem2
field NoteList
field components
field copied
field m_notes
field numnote
field page
field publ
field ret
field txtdatetime
field txttext
field txtuser

See Also

frmNotes Class


frmNotes Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes Properties

frmNotes overview

Properties

property k
property notes
property o
property ondemand
property zf

See Also

frmNotes Class


k Property

Public k As Object

Source code

[Visual Basic]
    Public k As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.notes Property

Property notes() As DataTable

Source code

[Visual Basic]
    Property notes() As DataTable
        Get
            Return m_notes
        End Get
        Set(ByVal Value As DataTable)
            m_notes = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


o Property

Public o As Object

Source code

[Visual Basic]
    Public o As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


ondemand Property

Public ondemand As AxARSOLELib.AxArsOle

Source code

[Visual Basic]
    Public ondemand As AxARSOLELib.AxArsOle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


zf Property

Public zf As Short = 100

Source code

[Visual Basic]
    Public zf As Short = 100

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes Methods

frmNotes overview

Methods

method BtnDelete_Click
method BtnNew_Click
method ContextMenu1_Popup
method Dispose
method Form1_Load
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method NoteList_DoubleClick
method frmNotes_Closing
method get_annotations

See Also

frmNotes Class


frmNotes.BtnDelete_Click Method

Private Sub BtnDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnDelete.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.BtnNew_Click Method

Private Sub BtnNew_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnNew.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnNew_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnNew.Click
        Dim f As New frmNewNote()
        f.ondemand = Me.ondemand
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            get_annotations()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.notes.Rows.Count = 0 Then Me.MenuItem1.Enabled = False Else Me.MenuItem1.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.NoteList.DataSource = Me.notes
        Me.NoteList.DataMember = Me.notes.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.NoteList, Me.notes, "notizlist")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmNotes))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.BtnNew = New System.Windows.Forms.Button()
        Me.BtnDelete = New System.Windows.Forms.Button()
        Me.NoteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        CType(Me.NoteList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'BtnNew
        '
        Me.BtnNew.Location = New System.Drawing.Point(544, 8)
        Me.BtnNew.Name = "BtnNew"
        Me.BtnNew.Size = New System.Drawing.Size(112, 24)
        Me.BtnNew.TabIndex = 1
        Me.BtnNew.Text = "Neue Notiz"
        '
        'BtnDelete
        '
        Me.BtnDelete.Location = New System.Drawing.Point(544, 312)
        Me.BtnDelete.Name = "BtnDelete"
        Me.BtnDelete.Size = New System.Drawing.Size(112, 24)
        Me.BtnDelete.TabIndex = 2
        Me.BtnDelete.Text = "Fenster schliessen"
        '
        'NoteList
        '
        Me.NoteList.AllowFilter = True
        Me.NoteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.NoteList.AllowSort = True
        Me.NoteList.AllowUpdate = False
        Me.NoteList.AllowUpdateOnBlur = False
        Me.NoteList.AlternatingRows = True
        Me.NoteList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.NoteList.CaptionHeight = 17
        Me.NoteList.CollapseColor = System.Drawing.Color.Black
        Me.NoteList.ContextMenu = Me.ContextMenu1
        Me.NoteList.DataChanged = False
        Me.NoteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.NoteList.ExpandColor = System.Drawing.Color.Black
        Me.NoteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.NoteList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.NoteList.Location = New System.Drawing.Point(8, 8)
        Me.NoteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.NoteList.Name = "NoteList"
        Me.NoteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.NoteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.NoteList.PreviewInfo.ZoomFactor = 75
        Me.NoteList.PrintInfo.ShowOptionsDialog = False
        Me.NoteList.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.NoteList.RowDivider = GridLines1
        Me.NoteList.RowHeight = 15
        Me.NoteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.NoteList.ScrollTips = False
        Me.NoteList.Size = New System.Drawing.Size(528, 328)
        Me.NoteList.TabIndex = 13
        Me.NoteList.Text = "C1TrueDBGrid1"
        Me.NoteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""17"" DefRecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 524, 324</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 524, 324</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Notiz anzeigen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "&Neue Notiz erfassen"
        '
        'frmNotes
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(664, 342)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.NoteList, Me.BtnDelete, Me.BtnNew})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmNotes"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Notizen"
        CType(Me.NoteList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Try
            Dim f As New frmNoteDetail()
            f.TextBox2.Text = Me.NoteList.Columns(2).Text
            f.TextBox1.Text = Me.NoteList.Columns(1).Text
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim f As New frmNewNote()
        f.ondemand = Me.ondemand
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            get_annotations()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.NoteList_DoubleClick Method

Private Sub NoteList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles NoteList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub NoteList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles NoteList.DoubleClick
        Try
            Dim f As New frmNoteDetail()
            f.TextBox2.Text = Me.NoteList.Columns(2).Text
            f.TextBox1.Text = Me.NoteList.Columns(1).Text
            f.ShowDialog()
            f.Dispose()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.frmNotes_Closing Method

Private Sub frmNotes_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmNotes_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Me.DialogResult = DialogResult.OK
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes.get_annotations Method

Public Function get_annotations()

Source code

[Visual Basic]
    Public Function get_annotations()
        Me.notes.Rows.Clear()
        Dim rc As DataRowCollection
        Dim newrow As DataRow()
        rc = notes.Rows
        Dim rowvals(7) As Object
        Dim i As Integer
        Me.numnote = Nothing
        ret = Me.ondemand.GetNumDocAnnotations(Me.numnote)

        For i = 0 To Me.numnote - 1
            page = Nothing
            publ = Nothing
            copied = Nothing
            ret = Me.ondemand.GetAnnotationForDoc(i, txttext, txtuser, txtdatetime, page, publ, copied)
            rowvals(0) = i
            rowvals(1) = txttext
            rowvals(3) = txtuser
            rowvals(2) = txtdatetime
            rowvals(4) = page
            rowvals(5) = publ
            rowvals(6) = copied
            rowvals(7) = ""
            notes.Rows.Add(rowvals)
        Next
        Me.NoteList.DataSource = Me.notes
        Me.NoteList.DataMember = Me.notes.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.NoteList, Me.notes, "notizlist")
        For i = 0 To Me.notes.Rows.Count - 1
            Me.NoteList.Splits(0).Rows(i).AutoSize()
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotes Fields

frmNotes overview

Fields

field BtnDelete
field BtnNew
field ContextMenu1
field MenuItem1
field MenuItem2
field NoteList
field components
field copied
field m_notes
field numnote
field page
field publ
field ret
field txtdatetime
field txttext
field txtuser

See Also

frmNotes Class


BtnDelete Variable

Friend WithEvents BtnDelete As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnDelete As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


BtnNew Variable

Friend WithEvents BtnNew As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnNew As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


NoteList Variable

Friend WithEvents NoteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents NoteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


copied Variable

Dim copied As Object

Source code

[Visual Basic]
    Dim copied As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


m_notes Variable

Dim m_notes As DataTable

Source code

[Visual Basic]
    Dim m_notes As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


numnote Variable

Dim numnote As Object

Source code

[Visual Basic]
    Dim numnote As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


page Variable

Dim page As Object

Source code

[Visual Basic]
    Dim page As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


publ Variable

Dim publ As Object

Source code

[Visual Basic]
    Dim publ As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


ret Variable

Dim ret As Short

Source code

[Visual Basic]
    Dim ret As Short

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


txtdatetime Variable

Dim txtdatetime As String = ""

Source code

[Visual Basic]
    Dim txtdatetime As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


txttext Variable

Dim txttext As String = ""

Source code

[Visual Basic]
    Dim txttext As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


txtuser Variable

Dim txtuser As String = ""

Source code

[Visual Basic]
    Dim txtuser As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotes


frmNotfallDataGenerate Class

For a list of all members of this type, see frmNotfallDataGenerate Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNotfallDataGenerate

Public Class frmNotfallDataGenerate
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNotfallDataGenerate Members


frmNotfallDataGenerate Members

frmNotfallDataGenerate overview

Constructors

constructor frmNotfallDataGenerate Constructor

Methods

method Dispose |
method ExportData | Generiert die XLM Dateien
method ExportFiles |
method FilDokBerechtDataSet |
method GenDok |
method GenXMLDataTable | SP ausführen und Daten als XML speichern
method GenerateDataStruktur |
method GenerateFolders |
method GetGenDokTables | Dateien und Prozeduren für den Datenexport auslesen
method GetPfad | Öffnet den FolderBrowser um einen Ordner zu wählen
method InitializeComponent |
method frmNotfallDataGenerate_Load |
method mnuExit_Click | Schliessen des Datenexport-Formulars
method mnuExportData_Click | Start des Daten-Exports
method mnuExportDoks_Click | Start des Dokumentvorlagen-Exports
method read_to_root |

Fields

field DokBerecht
field MainMenu1
field MenuItem1
field MenuItem4
field Panel1
field components
field dtToReturn
field iZaehler
field mExportPfad
field mnuExit
field mnuExportData
field mnuExportDoks
field sPfad

See Also

frmNotfallDataGenerate Class


frmNotfallDataGenerate Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate Methods

frmNotfallDataGenerate overview

Methods

method Dispose |
method ExportData | Generiert die XLM Dateien
method ExportFiles |
method FilDokBerechtDataSet |
method GenDok |
method GenXMLDataTable | SP ausführen und Daten als XML speichern
method GenerateDataStruktur |
method GenerateFolders |
method GetGenDokTables | Dateien und Prozeduren für den Datenexport auslesen
method GetPfad | Öffnet den FolderBrowser um einen Ordner zu wählen
method InitializeComponent |
method frmNotfallDataGenerate_Load |
method mnuExit_Click | Schliessen des Datenexport-Formulars
method mnuExportData_Click | Start des Daten-Exports
method mnuExportDoks_Click | Start des Dokumentvorlagen-Exports
method read_to_root |

See Also

frmNotfallDataGenerate Class


frmNotfallDataGenerate.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.ExportData Method

Generiert die XLM Dateien

Private Function ExportData( _
   ByVal Exportpfad As String _
) As Boolean

Parameters

Exportpfad
Required. Exportpfad, in den die XML Dateien Exportiert werden sollen.

Remarks

Generiert die XML Dateien anhand des DateTables in dem die XML-Dateinamen und die gespeicherten Prozeduren enthalten sind.

Author

Daniel Burren

Version

31.08.2004

Source code

[Visual Basic]
    Private Function ExportData(ByVal Exportpfad As String) As Boolean
        Dim TempDataTable As DataTable
        TempDataTable = GetGenDokTables()

        Dim fProgress As New frmProgress()
        fProgress.Info.Text = "Starten des Exports"
        fProgress.Bar1.Visible = True
        fProgress.Bar1.Maximum = 100
        fProgress.Bar1.Step = (100 / (TempDataTable.Rows.Count + 1))
        fProgress.Show()

        Dim row As DataRow
        For Each row In TempDataTable.Rows
            fProgress.Info.Text = row.Item("Bezeichnung")
            GenXMLDataTable(Exportpfad, row.Item("Prozedur"), row.Item("Dateiname"))
            fProgress.Bar1.PerformStep()
        Next
        fProgress.Bar1.Value = 100
        fProgress.Dispose()

        MsgBox(MyMsg.Get_Meldungstext(260), MsgBoxStyle.Information)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.ExportFiles Method

Private Function ExportFiles( _
   ByVal Exportpfad As String _
) As Boolean

Parameters

Exportpfad
Required.

Source code

[Visual Basic]
    Private Function ExportFiles(ByVal Exportpfad As String) As Boolean
        'Dim objDokument As New edokadb.clsReporting_Dokumenttyp()

        GenerateDataStruktur(Exportpfad)

        'objDokument.Get_DocumentFrom_DB("office_vorlage_dateinr", 10, "Office_Vorlage_Datei", "vorlage", Exportpfad, "10.doc")

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.FilDokBerechtDataSet Method

Private Function FilDokBerechtDataSet() As DataTable

Source code

[Visual Basic]
    Private Function FilDokBerechtDataSet() As DataTable
        '===============================================================================
        'Description : Füllt eine DataTable mit den Dokumentinfos.
        'Input       : BenutzerID
        'Criteria    :
        'Output      : DataTable
        'Date        : bud 18.08.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        FilDokBerechtDataSet = New DataTable()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_Notfall_GetNewDokTree"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            'scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iUserID))
            sdaAdapter.Fill(FilDokBerechtDataSet)
            DokBerecht = FilDokBerechtDataSet
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GenDok Method

Private Function GenDok( _
   ByVal DokTypNr As Integer, _
   ByVal ExportPfad As String _
)

Parameters

DokTypNr
Required.
ExportPfad
Required.

Source code

[Visual Basic]
    Private Function GenDok(ByVal DokTypNr As Integer, ByVal ExportPfad As String)
        '===============================================================================
        'Description : Gibt die DokumentID zurück
        'Input       : Dokument Typ Nummer
        'Criteria    :
        'Output      :
        'Date        : bud 02.09.2004
        'Modified    :
        '===============================================================================
        '
        '===============================================================================
        Dim iDokumentID As Integer
        Dim sDokName As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim objDokument As New edokadb.clsReporting_Dokumenttyp()
        scmCmdToExecute.CommandText = "dbo.sp_Notfall_GetDokID"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@DokTypNr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokTypNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@DokID", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iDokumentID))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@DokName", SqlDbType.VarChar, 50, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, sDokName))

            scmCmdToExecute.ExecuteNonQuery()
            If Not scmCmdToExecute.Parameters.Item("@DokID").Value Is Nothing And Not (scmCmdToExecute.Parameters.Item("@DokID").Value) Is System.DBNull.Value Then
                iDokumentID = scmCmdToExecute.Parameters.Item("@DokID").Value
                sDokName = scmCmdToExecute.Parameters.Item("@DokName").Value
            End If
            If iDokumentID <> 0 Then
                objDokument.Get_DocumentFrom_DB("office_vorlage_dateinr", iDokumentID, "Office_Vorlage_Datei", "vorlage", ExportPfad, sDokName)
            End If

        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GenXMLDataTable Method

SP ausführen und Daten als XML speichern

Private Function GenXMLDataTable( _
   ByVal Exportpfad As String, _
   ByVal sProzedur As String, _
   ByVal sFileName As String _
) As Boolean

Parameters

Exportpfad
Required. Exportpfad, in den die XML Dateien Exportiert werden sollen.
sProzedur
Required. gespeicherte Prozedur von welcher die Daten generiert werden.
sFileName
Required. Dateiname (XML)

Author

Daniel Burren

Version

31.08.2004

Source code

[Visual Basic]
    Private Function GenXMLDataTable(ByVal Exportpfad As String, ByVal sProzedur As String, ByVal sFileName As String) As Boolean
        Dim sTempDataSet As DataSet = New DataSet()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        GenXMLDataTable = True
        scmCmdToExecute.CommandText = sProzedur
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            'scmCmdToExecute.Parameters.Add(New SqlParameter("@intuser", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iUserID))
            sdaAdapter.Fill(sTempDataSet)
            sTempDataSet.WriteXml(Exportpfad & "\" & sFileName, XmlWriteMode.WriteSchema)
        Catch ex As Exception
            GenXMLDataTable = False
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GenerateDataStruktur Method

Private Sub GenerateDataStruktur( _
   ByVal Exportpfad As String _
)

Parameters

Exportpfad
Required.

Source code

[Visual Basic]
    Private Sub GenerateDataStruktur(ByVal Exportpfad As String)
        Try
            Me.Cursor = Cursors.WaitCursor
            GenerateFolders(dtToReturn, DokBerecht, 0, Exportpfad)
            Me.Cursor = Cursors.Default
        Catch
            MsgBox(Err.Description)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GenerateFolders Method

Private Sub GenerateFolders( _
   ByRef DataTableSearch As DataTable, _
   ByRef DataTableOriginal As DataTable, _
   ByVal TreeNr As Integer, _
   ByVal Exportpfad As String _
)

Parameters

DataTableSearch
Required.
DataTableOriginal
Required.
TreeNr
Required.
Exportpfad
Required.

Source code

[Visual Basic]
    Private Sub GenerateFolders(ByRef DataTableSearch As DataTable, ByRef DataTableOriginal As DataTable, ByVal TreeNr As Integer, ByVal Exportpfad As String)
        '===============================================================================
        'Description : Baut den Baum auf mit den Daten im DataTable
        'Input       : BenutzerID und das Treeview Objekt sowie 2 DataTables
        'Criteria    :
        'Output      :
        'Date        : bud 18.08.2004
        'Modified    : bud 21.10.2004
        '===============================================================================
        '
        '===============================================================================
        Dim i As Integer
        Dim m_collDeletedNodes As Collection
        Dim collNodeKeys As New Collection()
        Dim lastid As Long
        Dim pid As Long
        Dim bAbbruch As Boolean = False

        DataTableSearch = FilDokBerechtDataSet()

        lastid = 1
        m_collDeletedNodes = Nothing
        m_collDeletedNodes = New Collection()

        Dim sFolderStart As String
        Dim sFolderOrg As String

        Dim iDokID As Integer
        Dim drv As DataRowView
        sFolderOrg = Exportpfad
        sFolderStart = Exportpfad

        iZaehler = 0

        Dim fProgress As New frmProgress()
        fProgress.Info.Text = "Starten des Exports"
        fProgress.Bar1.Visible = True
        fProgress.Bar1.Maximum = DataTableSearch.Rows.Count
        fProgress.Bar1.Step = 1
        fProgress.Show()

        'Tree zusammenbauen
        For i = 0 To DataTableSearch.Rows.Count - 1
            If DataTableSearch.Rows(i).Item("ParentID") = 0 Then
                If DivFnkt.FolderExist(Exportpfad & "\" & DataTableSearch.Rows(i).Item("bezeichnung")) = True Then
                    If bAbbruch = False Then
                        Try
                            If DivFnkt.Delete_Directory(Exportpfad & "\" & DataTableSearch.Rows(i).Item("bezeichnung")) = False Then
                                MsgBox(MyMsg.Get_Meldungstext(262), MsgBoxStyle.Exclamation)
                                bAbbruch = True
                                Exit For
                            End If
                        Catch
                            bAbbruch = True
                            Exit For
                        End Try

                    End If
                End If
            Else
                Try
                    If DataTableSearch.Rows(i).Item("DokTypBez") Is System.DBNull.Value Then
                        'Keine Vorgänge
                    Else
                        Try
                            If lastid <> DataTableSearch.Rows(i).Item("dokumentartnr") Then
                                sPfad = ""
                                read_to_root(DataTableSearch.Rows(i).Item("dokumentartnr"), DataTableOriginal)
                                sPfad = (Replace(sPfad, "/", "-"))
                                sPfad = (Replace(sPfad, ":", "-"))
                                sPfad = (Replace(sPfad, "*", "-"))
                                sPfad = (Replace(sPfad, "<", "-"))
                                sPfad = (Replace(sPfad, ">", "-"))
                                sPfad = (Replace(sPfad, "|", "-"))
                                sPfad = (Replace(sPfad, "?", "-"))
                                sPfad = (Replace(sPfad, Chr(34), "-"))
                                sPfad = Exportpfad + sPfad
                                DivFnkt.Create_Folders(sPfad)

                                lastid = DataTableSearch.Rows(i).Item("dokumentartnr")
                                pid = lastid
                            End If
                            iZaehler = iZaehler + 1
                            GenDok(DataTableSearch.Rows(i).Item(8) / 10000, sPfad)

                        Catch ex As Exception
                            MsgBox(ex.Message)
                        End Try

                    End If
                Catch ex As Exception
                    MsgBox("Dokart:" & DataTableSearch.Rows(i).Item("dokumentartnr") & " - " & DataTableSearch.Rows(i).Item("dokumenttypnr") & ex.Message, MsgBoxStyle.Critical)
                End Try
            End If
            fProgress.Info.Text = CStr(DataTableSearch.Rows(i).Item("dokumentartnr")) & ".doc"
            fProgress.Bar1.PerformStep()
        Next
        If bAbbruch = False Then
            fProgress.Bar1.Value = DataTableSearch.Rows.Count
            MsgBox(MyMsg.Get_Meldungstext(260), MsgBoxStyle.Information)

        End If
        fProgress.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GetGenDokTables Method

Dateien und Prozeduren für den Datenexport auslesen

Private Function GetGenDokTables() As DataTable

Returns

Daten als DataTable

Remarks

Gibt die in der Tabelle Notfall_DatenExport enthaltenen Definitionen zurück (in einem DataTable). Darin sind enthalten: -gespeicherte Prozedur -XML Dateiname -Progressbar Name

Author

Daniel Burren

Version

13.09.2004

Source code

[Visual Basic]
    Private Function GetGenDokTables() As DataTable
        GetGenDokTables = New DataTable()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Notfall_GetDatenExport"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(GetGenDokTables)
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.GetPfad Method

Öffnet den FolderBrowser um einen Ordner zu wählen

Private Sub GetPfad()

Author

Daniel Burren

Version

31.08.2004

Source code

[Visual Basic]
    Private Sub GetPfad()
        Dim f As New FolderSelect()
        f.InitialDirectory = "C:\"
        f.InitialDirectoryExpanded = True
        Me.Cursor = Cursors.WaitCursor
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Cursor = Cursors.WaitCursor
            mExportPfad = f.fullPath
        End If
        If f.DialogResult = DialogResult.Cancel Then
            mExportPfad = ""
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.mnuExit = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.mnuExportData = New System.Windows.Forms.MenuItem()
        Me.mnuExportDoks = New System.Windows.Forms.MenuItem()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem4})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuExit})
        Me.MenuItem1.Text = "&Datei"
        '
        'mnuExit
        '
        Me.mnuExit.Index = 0
        Me.mnuExit.Text = "B&eenden"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 1
        Me.MenuItem4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuExportData, Me.mnuExportDoks})
        Me.MenuItem4.Text = "Date&n"
        '
        'mnuExportData
        '
        Me.mnuExportData.Index = 0
        Me.mnuExportData.Text = "Daten Export"
        '
        'mnuExportDoks
        '
        Me.mnuExportDoks.Index = 1
        Me.mnuExportDoks.Text = "Dokumentvorlagen Export"
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(616, 8)
        Me.Panel1.TabIndex = 2
        '
        'frmNotfallDataGenerate
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(616, 230)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1})
        Me.Menu = Me.MainMenu1
        Me.Name = "frmNotfallDataGenerate"
        Me.Text = "Datenexport Notfall-Lösung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.frmNotfallDataGenerate_Load Method

Private Sub frmNotfallDataGenerate_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmNotfallDataGenerate_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mExportPfad = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.mnuExit_Click Method

Schliessen des Datenexport-Formulars

Private Sub mnuExit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuExit.Click

Parameters

sender
Required.
e
Required.

Author

Daniel Burren

Source code

[Visual Basic]
    Private Sub mnuExit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuExit.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.mnuExportData_Click Method

Start des Daten-Exports

Private Sub mnuExportData_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuExportData.Click

Parameters

sender
Required.
e
Required.

Author

Daniel Burren

Source code

[Visual Basic]
    Private Sub mnuExportData_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuExportData.Click
        GetPfad()
        Me.Cursor = Cursors.WaitCursor
        If mExportPfad <> "" Then
            ExportData(mExportPfad)
        End If
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.mnuExportDoks_Click Method

Start des Dokumentvorlagen-Exports

Private Sub mnuExportDoks_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuExportDoks.Click

Parameters

sender
Required.
e
Required.

Author

Daniel Burren

Source code

[Visual Basic]
    Private Sub mnuExportDoks_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuExportDoks.Click
        GetPfad()
        Me.Cursor = Cursors.WaitCursor
        If mExportPfad <> "" Then
            ExportFiles(mExportPfad)
        End If
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate.read_to_root Method

Function read_to_root( _
   ByVal sParent As String, _
   ByVal DataTableOriginal As DataTable _
) As Integer

Parameters

sParent
Required.
DataTableOriginal
Required.

Source code

[Visual Basic]
    Function read_to_root(ByVal sParent As String, ByVal DataTableOriginal As DataTable) As Integer
        Dim parent As Integer
        read_to_root = sParent
        parent = sParent
        While read_to_root <> 0
            Dim dview As New DataView(DataTableOriginal, "dokumentartnr= " + Trim(Str(parent)), "Parentid, sort", DataViewRowState.CurrentRows)
            Dim drv1 As DataRowView
            For Each drv1 In dview
                sPfad = "\" + (Replace(drv1.Item(1), "\", "-")) + sPfad
                If drv1.Item(5) = 0 Then
                    read_to_root = 0
                Else
                    If read_to_root(Trim(drv1.Item(5)), DataTableOriginal) = 0 Then
                        read_to_root = 0
                        Exit Function
                    End If
                End If
                dview.Dispose()
            Next
        End While
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallDataGenerate Fields

frmNotfallDataGenerate overview

Fields

field DokBerecht
field MainMenu1
field MenuItem1
field MenuItem4
field Panel1
field components
field dtToReturn
field iZaehler
field mExportPfad
field mnuExit
field mnuExportData
field mnuExportDoks
field sPfad

See Also

frmNotfallDataGenerate Class


DokBerecht Variable

Dim DokBerecht As New DataTable()

Source code

[Visual Basic]
    Dim DokBerecht As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


dtToReturn Variable

Dim dtToReturn As DataTable = New DataTable()

Source code

[Visual Basic]
    Dim dtToReturn As DataTable = New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


iZaehler Variable

Dim iZaehler As Integer

Source code

[Visual Basic]
    Dim iZaehler As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


mExportPfad Variable

Dim mExportPfad As String

Source code

[Visual Basic]
    Dim mExportPfad As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


mnuExit Variable

Friend WithEvents mnuExit As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuExit As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


mnuExportData Variable

Friend WithEvents mnuExportData As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuExportData As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


mnuExportDoks Variable

Friend WithEvents mnuExportDoks As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuExportDoks As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


sPfad Variable

Dim sPfad As String

Source code

[Visual Basic]
    Dim sPfad As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallDataGenerate


frmNotfallimport Class

For a list of all members of this type, see frmNotfallimport Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNotfallimport

Public Class frmNotfallimport
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNotfallimport Members


frmNotfallimport Members

frmNotfallimport overview

Constructors

constructor frmNotfallimport Constructor

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method Mitarbeiterprofile_laden
method Pruefziffer
method ToolBar1_ButtonClick
method btnSave_Click
method check_barcodenr
method doktypexists
method txtdokumenttypnr_Leave

Fields

field Button1
field Button2
field Button3
field ImageList1
field ImageList3
field Label1
field Label2
field Label3
field Label5
field Stdprofilnr
field ToolBar1
field ToolBarButton1
field ToolTip1
field btnSave
field components
field txtbcknr
field txtdokumenttypnr
field txtpartnernr

See Also

frmNotfallimport Class


frmNotfallimport Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport Methods

frmNotfallimport overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent
method Mitarbeiterprofile_laden
method Pruefziffer
method ToolBar1_ButtonClick
method btnSave_Click
method check_barcodenr
method doktypexists
method txtdokumenttypnr_Leave

See Also

frmNotfallimport Class


frmNotfallimport.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim s As String
        Dim v As Long
        s = Me.txtbcknr.Text
        If Len(s) < 9 Then Exit Sub
        If Len(s) > 10 Then Exit Sub
        If Len(s) = 9 Then s = "0" + s
        s = Microsoft.VisualBasic.Left(s, 9)
        v = Val(s)
        v = v + 1
        s = v.ToString
        If Len(s) = 0 Then s = "0" + s
        s = s + LTrim(Pruefziffer(s))
        Me.txtbcknr.Text = s
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f As New frmVorlagenauswahl()
        f.Show_Favoriten = False
        f.TVStruktur.ImageList = Me.ImageList3
        f.Dokumentart = ""
        f.Profile = Mitarbeiterprofile_laden()
        f.ProfilNr = Me.Stdprofilnr
        f.ShowDialog()
        If f.DialogResult.OK Then
            Me.txtdokumenttypnr.Text = f.Dokumentvorlage.ToString
            doktypexists()
            Me.txtpartnernr.Focus()
        End If
        f.Dispose()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim f As New FrmPartnersuche()
        f.ShowDialog()
        f.NurAbfrage = True
        If f.PartnerNr <> 0 Then Me.txtpartnernr.Text = f.PartnerNr.ToString
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmNotfallimport))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtdokumenttypnr = New System.Windows.Forms.TextBox()
        Me.txtpartnernr = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtbcknr = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.btnSave = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(424, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Verlassen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 48)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Dokumenttyp-Nr."
        '
        'txtdokumenttypnr
        '
        Me.txtdokumenttypnr.Location = New System.Drawing.Point(112, 48)
        Me.txtdokumenttypnr.Name = "txtdokumenttypnr"
        Me.txtdokumenttypnr.Size = New System.Drawing.Size(184, 20)
        Me.txtdokumenttypnr.TabIndex = 2
        Me.txtdokumenttypnr.Text = ""
        Me.ToolTip1.SetToolTip(Me.txtdokumenttypnr, "Dokumenttypnr (Dokument unten rechts)")
        '
        'txtpartnernr
        '
        Me.txtpartnernr.Location = New System.Drawing.Point(112, 128)
        Me.txtpartnernr.Name = "txtpartnernr"
        Me.txtpartnernr.Size = New System.Drawing.Size(184, 20)
        Me.txtpartnernr.TabIndex = 4
        Me.txtpartnernr.Text = ""
        Me.ToolTip1.SetToolTip(Me.txtpartnernr, "Eingabe der Partnernr (nicht zwingend)")
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 128)
        Me.Label2.Name = "Label2"
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Partner-Nr."
        '
        'txtbcknr
        '
        Me.txtbcknr.Location = New System.Drawing.Point(112, 160)
        Me.txtbcknr.Name = "txtbcknr"
        Me.txtbcknr.Size = New System.Drawing.Size(184, 20)
        Me.txtbcknr.TabIndex = 6
        Me.txtbcknr.Text = ""
        Me.ToolTip1.SetToolTip(Me.txtbcknr, "Eingabe einer gültigen Barcodekleber-Nr.")
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 160)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 9
        Me.Label5.Text = "Barcodekleber-Nr."
        '
        'btnSave
        '
        Me.btnSave.Location = New System.Drawing.Point(176, 192)
        Me.btnSave.Name = "btnSave"
        Me.btnSave.TabIndex = 11
        Me.btnSave.Text = "Weiter >>"
        Me.ToolTip1.SetToolTip(Me.btnSave, "Barcode-Dokument erstellen")
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(296, 48)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(120, 23)
        Me.Button2.TabIndex = 13
        Me.Button2.Text = "Dokumenttyp suchen"
        Me.ToolTip1.SetToolTip(Me.Button2, "Dialog zur Vorlagenauswahl")
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(296, 128)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(120, 23)
        Me.Button3.TabIndex = 14
        Me.Button3.Text = "Partner suchen"
        Me.ToolTip1.SetToolTip(Me.Button3, "Dialog zur Partnersuche")
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(296, 160)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(120, 23)
        Me.Button1.TabIndex = 15
        Me.Button1.Text = "nächster Barcode"
        Me.ToolTip1.SetToolTip(Me.Button1, "Nächste Barcodenummer generieren")
        '
        'Label3
        '
        Me.Label3.ForeColor = System.Drawing.Color.Red
        Me.Label3.Location = New System.Drawing.Point(112, 70)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(312, 50)
        Me.Label3.TabIndex = 16
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmNotfallimport
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(424, 221)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.Button1, Me.Button3, Me.Button2, Me.btnSave, Me.txtbcknr, Me.Label5, Me.txtpartnernr, Me.Label2, Me.txtdokumenttypnr, Me.Label1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmNotfallimport"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Notfall-Dokumentimport"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.Mitarbeiterprofile_laden Method

Private Function Mitarbeiterprofile_laden() As DataTable

Source code

[Visual Basic]
    Private Function Mitarbeiterprofile_laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_notfallimport_profile"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@stdnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Stdprofilnr = scmCmdToExecute.Parameters.Item("@stdnr").Value
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.Pruefziffer Method

Public Function Pruefziffer( _
   ByVal zahl As String _
) As String

Parameters

zahl
Required.

Source code

[Visual Basic]
    Public Function Pruefziffer(ByVal zahl As String) As String
        Dim ptab(9, 9) As Integer
        Dim pz(9) As Integer
        Dim s1, s2, s3 As String

        Dim i1, i2 As Long

        s1 = "0,9,4,6,8,2,7,1,3,5"
        s2 = s1
        For i1 = 0 To 9
            For i2 = 0 To 9
                ptab(i1, i2) = Mid(s2, (i2 * 2) + 1, 1)
            Next
            s3 = Microsoft.VisualBasic.Left(s1, 1)
            s1 = Microsoft.VisualBasic.Right(s1, Len(s1) - 2)
            s1 = s1 + "," + s3
            s2 = s1
        Next
        pz(0) = 0
        pz(1) = 9
        pz(2) = 8
        pz(3) = 7
        pz(4) = 6
        pz(5) = 5
        pz(6) = 4
        pz(7) = 3
        pz(8) = 2
        pz(9) = 1

        Dim i, x, y, z, e As Integer
        Dim xx As String
        y = 0
        For i = 1 To Len(zahl)
            x = Val(Mid(zahl, i, 1))
            y = ptab(x, y)
        Next
        Pruefziffer = Str(pz(y))
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.btnSave_Click Method

Private Sub btnSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSave_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSave.Click
        If Not doktypexists() Then Exit Sub
        If Not check_barcodenr() Then Exit Sub
        Dim f As New frmDokumentbearbeitungBC()

        'Profile des angemeldeten Benutzers lesen
        f.Profile = Mitarbeiterprofile_laden()
        f.Profilnr = Me.Stdprofilnr
        f.Notfallimport = True
        f.Dokumenttypnr = Me.txtdokumenttypnr.Text
        If Me.txtpartnernr.Text <> "" Then f.Partnernr = Me.txtpartnernr.Text
        f.BarcodeID = Me.txtbcknr.Text
        f.ShowDialog()
        f.Dispose()
        Me.txtdokumenttypnr.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.check_barcodenr Method

Private Function check_barcodenr() As Boolean

Source code

[Visual Basic]
    Private Function check_barcodenr() As Boolean
        Dim v As Long
        Try
            v = Val(LTrim(RTrim(Me.txtbcknr.Text)))
        Catch
            MyMsg.show_standardmessage(36, MsgBoxStyle.Critical)
            Me.txtbcknr.Select()
            Me.txtbcknr.Focus()
            Return False
            Exit Function
        End Try
        Dim bc As New edokadb.clsBarcodeetikette()
        bc.cpMainConnectionProvider = conn
        Try
            bc.iBarcodenr = New SqlInt32(CType(Me.txtbcknr.Text, String))
            bc.SelectOne()
            If bc.iBarcodenr.Value = v Then
                If bc.sDokumentid.Value Is System.DBNull.Value Then
                    bc.sDokumentid = New SqlString(CType("res", String))
                Else
                    If bc.sDokumentid.Value = "" Then
                        bc.sDokumentid = New SqlString(CType("res", String))
                    Else
                        MyMsg.show_standardmessage(37, MsgBoxStyle.Critical)
                        Me.txtbcknr.Select()
                        Me.txtbcknr.Focus()
                        Return False
                        Exit Function
                    End If
                End If
            End If
            conn.OpenConnection()
            bc.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            bc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            bc.Update()
            conn.CloseConnection(True)
            Return True
            Me.DialogResult = DialogResult.OK
            Me.Close()
        Catch
            MyMsg.show_standardmessage(38, MsgBoxStyle.Critical)
            Me.txtbcknr.SelectAll()
            Me.txtbcknr.Focus()
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.doktypexists Method

Private Function doktypexists() As Boolean

Source code

[Visual Basic]
    Private Function doktypexists() As Boolean
        Dim v As Integer

        Try
            v = Val(Me.txtdokumenttypnr.Text)
        Catch
            v = 0
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim s As String
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_notfallimport_DOKUMENTTYP"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, v))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypexists", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Me.Label3.Text = scmCmdToExecute.Parameters("@dokumenttyp").Value
            If scmCmdToExecute.Parameters("@doktypexists").Value = 1 Then
                Return True
            Else
                Return False
            End If
        Catch ex As Exception
            Throw New Exception("::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport.txtdokumenttypnr_Leave Method

Private Sub txtdokumenttypnr_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtdokumenttypnr.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtdokumenttypnr_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtdokumenttypnr.Leave
        doktypexists()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotfallimport Fields

frmNotfallimport overview

Fields

field Button1
field Button2
field Button3
field ImageList1
field ImageList3
field Label1
field Label2
field Label3
field Label5
field Stdprofilnr
field ToolBar1
field ToolBarButton1
field ToolTip1
field btnSave
field components
field txtbcknr
field txtdokumenttypnr
field txtpartnernr

See Also

frmNotfallimport Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


Stdprofilnr Variable

Dim Stdprofilnr As Integer = 0

Source code

[Visual Basic]
    Dim Stdprofilnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


txtbcknr Variable

Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


txtdokumenttypnr Variable

Friend WithEvents txtdokumenttypnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdokumenttypnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


txtpartnernr Variable

Friend WithEvents txtpartnernr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtpartnernr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotfallimport


frmNotizen Class

For a list of all members of this type, see frmNotizen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmNotizen

Public Class frmNotizen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmNotizen Members


frmNotizen Members

frmNotizen overview

Constructors

constructor frmNotizen Constructor

Properties

property Betreff
property FrmReadOnly
property Mutierer
property MutiertAm
property Notiz

Methods

method BtnAbbruch_Click
method BtnOK_Click
method Dispose
method InitializeComponent
method Label3_Click
method btnClose_Click
method frmNotizen_Load

Fields

field BtnAbbruch
field BtnOK
field Label1
field Label2
field TextBox1
field TextBox2
field btnClose
field components
field lblMutierer
field lblMutiertAm
field m_Mutierer
field m_MutiertAm
field m_betreff
field m_notiz
field m_readonly
field txtMutierer
field txtMutiertAm

See Also

frmNotizen Class


frmNotizen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen Properties

frmNotizen overview

Properties

property Betreff
property FrmReadOnly
property Mutierer
property MutiertAm
property Notiz

See Also

frmNotizen Class


frmNotizen.Betreff Property

Property Betreff() As String

Source code

[Visual Basic]
    Property Betreff() As String
        Get
            Return m_betreff
        End Get
        Set(ByVal Value As String)
            m_betreff = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.FrmReadOnly Property

Property FrmReadOnly() As Boolean

Source code

[Visual Basic]
    Property FrmReadOnly() As Boolean
        Get
            Return m_readonly
        End Get
        Set(ByVal Value As Boolean)
            m_readonly = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.Mutierer Property

Property Mutierer() As String

Source code

[Visual Basic]
    Property Mutierer() As String
        Get
            Return m_Mutierer
        End Get
        Set(ByVal Value As String)
            m_Mutierer = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.MutiertAm Property

Property MutiertAm() As String

Source code

[Visual Basic]
    Property MutiertAm() As String
        Get
            Return m_MutiertAm
        End Get
        Set(ByVal Value As String)
            m_MutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.Notiz Property

Property Notiz() As String

Source code

[Visual Basic]
    Property Notiz() As String
        Get
            Return m_notiz
        End Get
        Set(ByVal Value As String)
            m_notiz = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen Methods

frmNotizen overview

Methods

method BtnAbbruch_Click
method BtnOK_Click
method Dispose
method InitializeComponent
method Label3_Click
method btnClose_Click
method frmNotizen_Load

See Also

frmNotizen Class


frmNotizen.BtnAbbruch_Click Method

Private Sub BtnAbbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnAbbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnAbbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnAbbruch.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.BtnOK_Click Method

Private Sub BtnOK_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnOK.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnOK_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnOK.Click
        Me.Betreff = Me.TextBox1.Text
        Me.Notiz = Me.TextBox2.Text

        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmNotizen))
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.BtnAbbruch = New System.Windows.Forms.Button()
        Me.BtnOK = New System.Windows.Forms.Button()
        Me.btnClose = New System.Windows.Forms.Button()
        Me.lblMutierer = New System.Windows.Forms.Label()
        Me.txtMutierer = New System.Windows.Forms.TextBox()
        Me.lblMutiertAm = New System.Windows.Forms.Label()
        Me.txtMutiertAm = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(56, 16)
        Me.TextBox1.MaxLength = 255
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(384, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "TextBox1"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(56, 40)
        Me.TextBox2.MaxLength = 1024
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(384, 216)
        Me.TextBox2.TabIndex = 1
        Me.TextBox2.Text = "TextBox2"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(40, 23)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Betreff"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(40, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Notiz"
        '
        'BtnAbbruch
        '
        Me.BtnAbbruch.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.BtnAbbruch.Location = New System.Drawing.Point(56, 307)
        Me.BtnAbbruch.Name = "BtnAbbruch"
        Me.BtnAbbruch.TabIndex = 4
        Me.BtnAbbruch.Text = "&Abbruch"
        '
        'BtnOK
        '
        Me.BtnOK.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.BtnOK.Location = New System.Drawing.Point(368, 307)
        Me.BtnOK.Name = "BtnOK"
        Me.BtnOK.TabIndex = 5
        Me.BtnOK.Text = "&OK"
        '
        'btnClose
        '
        Me.btnClose.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.btnClose.Location = New System.Drawing.Point(216, 307)
        Me.btnClose.Name = "btnClose"
        Me.btnClose.TabIndex = 6
        Me.btnClose.Text = "&Schliessen"
        '
        'lblMutierer
        '
        Me.lblMutierer.Location = New System.Drawing.Point(8, 267)
        Me.lblMutierer.Name = "lblMutierer"
        Me.lblMutierer.Size = New System.Drawing.Size(48, 16)
        Me.lblMutierer.TabIndex = 8
        Me.lblMutierer.Text = "Mutierer"
        '
        'txtMutierer
        '
        Me.txtMutierer.BackColor = System.Drawing.SystemColors.Control
        Me.txtMutierer.Location = New System.Drawing.Point(56, 264)
        Me.txtMutierer.MaxLength = 255
        Me.txtMutierer.Name = "txtMutierer"
        Me.txtMutierer.ReadOnly = True
        Me.txtMutierer.Size = New System.Drawing.Size(208, 20)
        Me.txtMutierer.TabIndex = 7
        Me.txtMutierer.TabStop = False
        Me.txtMutierer.Text = ""
        '
        'lblMutiertAm
        '
        Me.lblMutiertAm.Location = New System.Drawing.Point(275, 268)
        Me.lblMutiertAm.Name = "lblMutiertAm"
        Me.lblMutiertAm.Size = New System.Drawing.Size(64, 16)
        Me.lblMutiertAm.TabIndex = 10
        Me.lblMutiertAm.Text = "Mutiert am"
        '
        'txtMutiertAm
        '
        Me.txtMutiertAm.BackColor = System.Drawing.SystemColors.Control
        Me.txtMutiertAm.Location = New System.Drawing.Point(332, 264)
        Me.txtMutiertAm.MaxLength = 255
        Me.txtMutiertAm.Name = "txtMutiertAm"
        Me.txtMutiertAm.ReadOnly = True
        Me.txtMutiertAm.Size = New System.Drawing.Size(108, 20)
        Me.txtMutiertAm.TabIndex = 9
        Me.txtMutiertAm.TabStop = False
        Me.txtMutiertAm.Text = ""
        '
        'frmNotizen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(448, 333)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtMutiertAm, Me.lblMutierer, Me.txtMutierer, Me.btnClose, Me.BtnOK, Me.BtnAbbruch, Me.Label2, Me.Label1, Me.TextBox2, Me.TextBox1, Me.lblMutiertAm})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmNotizen"
        Me.Text = "Notizen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.Label3_Click Method

Private Sub Label3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles lblMutierer.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Label3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles lblMutierer.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.btnClose_Click Method

Private Sub btnClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen.frmNotizen_Load Method

Private Sub frmNotizen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmNotizen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'SHU 2004-10-04 - Generelles Anzeige vom Mutierername

        Try
            Dim objMitarbeiter As New edokadb.clsMitarbeiter()
            objMitarbeiter.cpMainConnectionProvider = conn
            objMitarbeiter.iMitarbeiternr = New SqlInt32(CType(Me.Mutierer, Int32))
            objMitarbeiter.SelectOne()
            Me.Mutierer = objMitarbeiter.sName.ToString & " " & objMitarbeiter.sVorname.ToString & " , " & objMitarbeiter.sTgnummer.ToString
            objMitarbeiter.Dispose()
        Catch

        End Try

        Me.TextBox1.Text = Me.Betreff
        Me.TextBox2.Text = Me.Notiz
        Me.txtMutierer.Text = Me.Mutierer
        Me.txtMutiertAm.Text = Me.MutiertAm
        If Me.FrmReadOnly Then
            Me.BtnAbbruch.Visible = False
            Me.BtnOK.Visible = False
            Me.TextBox1.ReadOnly = True
            Me.TextBox2.ReadOnly = True
            Me.btnClose.Visible = True
        Else
            Me.BtnAbbruch.Visible = True
            Me.BtnOK.Visible = True
            Me.btnClose.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmNotizen Fields

frmNotizen overview

Fields

field BtnAbbruch
field BtnOK
field Label1
field Label2
field TextBox1
field TextBox2
field btnClose
field components
field lblMutierer
field lblMutiertAm
field m_Mutierer
field m_MutiertAm
field m_betreff
field m_notiz
field m_readonly
field txtMutierer
field txtMutiertAm

See Also

frmNotizen Class


BtnAbbruch Variable

Friend WithEvents BtnAbbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnAbbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


BtnOK Variable

Friend WithEvents BtnOK As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnOK As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


lblMutierer Variable

Friend WithEvents lblMutierer As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblMutierer As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


lblMutiertAm Variable

Friend WithEvents lblMutiertAm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblMutiertAm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


m_Mutierer Variable

Dim m_Mutierer As String

Source code

[Visual Basic]
    Dim m_Mutierer As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


m_MutiertAm Variable

Dim m_MutiertAm As String

Source code

[Visual Basic]
    Dim m_MutiertAm As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


m_betreff Variable

Dim m_betreff As String

Source code

[Visual Basic]
    Dim m_betreff As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


m_notiz Variable

Dim m_notiz As String

Source code

[Visual Basic]
    Dim m_notiz As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


m_readonly Variable

Dim m_readonly As Boolean = False

Source code

[Visual Basic]
    Dim m_readonly As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


txtMutierer Variable

Friend WithEvents txtMutierer As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtMutierer As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


txtMutiertAm Variable

Friend WithEvents txtMutiertAm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtMutiertAm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmNotizen


frmOffeneDPInstanzen Class

For a list of all members of this type, see frmOffeneDPInstanzen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmOffeneDPInstanzen

Public Class frmOffeneDPInstanzen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmOffeneDPInstanzen Members


frmOffeneDPInstanzen Members

frmOffeneDPInstanzen overview

Constructors

constructor frmOffeneDPInstanzen Constructor

Properties

property dpdaten

Methods

method Dispose
method DokList_DoubleClick
method DokList_MouseDown
method Generic_Select
method InitializeComponent
method Load_Data
method MnuDelete_Click
method ToolBar1_ButtonClick
method frmOffeneDPInstanzen_Load
method mnuOpen_Click

Fields

field ContextMenu1
field DokList
field ImageList1
field MnuDelete
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field mnuOpen

See Also

frmOffeneDPInstanzen Class


frmOffeneDPInstanzen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen Properties

frmOffeneDPInstanzen overview

Properties

property dpdaten

See Also

frmOffeneDPInstanzen Class


dpdaten Property

Public dpdaten As DataTable

Source code

[Visual Basic]
    Public dpdaten As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen Methods

frmOffeneDPInstanzen overview

Methods

method Dispose
method DokList_DoubleClick
method DokList_MouseDown
method Generic_Select
method InitializeComponent
method Load_Data
method MnuDelete_Click
method ToolBar1_ButtonClick
method frmOffeneDPInstanzen_Load
method mnuOpen_Click

See Also

frmOffeneDPInstanzen Class


frmOffeneDPInstanzen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.DokList_DoubleClick Method

Private Sub DokList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DokList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles DokList.DoubleClick
        Dim f As New frmDokumentpaket(Me.DokList.Columns(0).Value)
        f.MdiParent = Me.MdiParent
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.Generic_Select Method

Public Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Public Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1, 2
                scmCmdToExecute.CommandText = "edex_sp_dpinstanz"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        Select Case typ
            Case 1
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dpinstanznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Case 2
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dpinstanznr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns(0).Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))

        End Select

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmOffeneDPInstanzen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuOpen = New System.Windows.Forms.MenuItem()
        Me.MnuDelete = New System.Windows.Forms.MenuItem()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(608, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 3
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(0, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(608, 276)
        Me.DokList.TabIndex = 26
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 604," & _
        " 272</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 604, " & _
        "272</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuOpen, Me.MnuDelete})
        '
        'mnuOpen
        '
        Me.mnuOpen.Index = 0
        Me.mnuOpen.Text = "&Dokumentpaket öffnen"
        '
        'MnuDelete
        '
        Me.MnuDelete.Index = 1
        Me.MnuDelete.Text = "&Dokumentpaket löschen"
        '
        'frmOffeneDPInstanzen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(608, 301)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokList, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmOffeneDPInstanzen"
        Me.Text = "Pendente Dokumentpakete"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.Load_Data Method

Public Sub Load_Data()

Source code

[Visual Basic]
    Public Sub Load_Data()
        Me.DokList.DataSource = Nothing
        Me.DokList.DataMember = Nothing
        dpdaten = Generic_Select(1)
        Me.DokList.DataSource = dpdaten
        Me.DokList.DataMember = dpdaten.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, dpdaten, "DPInstanz")

        Dim bmp1 As New Bitmap(Me.ImageList1.Images(1))
        Dim bmp2 As New Bitmap(Me.ImageList1.Images(2))

        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()

        v1.DisplayValue = bmp1
        v1.Value = 0

        v2.DisplayValue = bmp2
        v2.Value = 1

        Me.DokList.Columns(1).ValueItems.Values.Add(v1)
        Me.DokList.Columns(1).ValueItems.Values.Add(v2)

        Me.DokList.Columns(1).ValueItems.Translate = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.MnuDelete_Click Method

Private Sub MnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDelete.Click
        Generic_Select(2)
        Load_Data()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 ' Close
                Me.Close()
            Case 1
                Load_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.frmOffeneDPInstanzen_Load Method

Private Sub frmOffeneDPInstanzen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmOffeneDPInstanzen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Load_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen.mnuOpen_Click Method

Private Sub mnuOpen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuOpen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuOpen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuOpen.Click
        Me.DokList_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOffeneDPInstanzen Fields

frmOffeneDPInstanzen overview

Fields

field ContextMenu1
field DokList
field ImageList1
field MnuDelete
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field mnuOpen

See Also

frmOffeneDPInstanzen Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


MnuDelete Variable

Friend WithEvents MnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


mnuOpen Variable

Friend WithEvents mnuOpen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuOpen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOffeneDPInstanzen


frmOfficeBearbeitung Class

For a list of all members of this type, see frmOfficeBearbeitung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmOfficeBearbeitung

Public Class frmOfficeBearbeitung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmOfficeBearbeitung Members


frmOfficeBearbeitung Members

frmOfficeBearbeitung overview

Constructors

constructor frmOfficeBearbeitung Constructor

Methods

method Dispose
method InitializeComponent
method frmOfficeBearbeitung_Load

Fields

field TextBox1
field components

See Also

frmOfficeBearbeitung Class


frmOfficeBearbeitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


frmOfficeBearbeitung Methods

frmOfficeBearbeitung overview

Methods

method Dispose
method InitializeComponent
method frmOfficeBearbeitung_Load

See Also

frmOfficeBearbeitung Class


frmOfficeBearbeitung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


frmOfficeBearbeitung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.SystemColors.InactiveBorder
        Me.TextBox1.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.TextBox1.Location = New System.Drawing.Point(48, 56)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(352, 48)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "Ein Word- bzw. ein Excel-Dokument wird z.Zt. von Ihnen bearbeitet. Die Bearbeitun" & _
        "g muss abgeschlossen werden"
        '
        'frmOfficeBearbeitung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(448, 173)
        Me.ControlBox = False
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmOfficeBearbeitung"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "frmOfficeBearbeitung"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


frmOfficeBearbeitung.frmOfficeBearbeitung_Load Method

Private Sub frmOfficeBearbeitung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmOfficeBearbeitung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


frmOfficeBearbeitung Fields

frmOfficeBearbeitung overview

Fields

field TextBox1
field components

See Also

frmOfficeBearbeitung Class


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficeBearbeitung


frmOfficePreview Class

For a list of all members of this type, see frmOfficePreview Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmOfficePreview

Public Class frmOfficePreview
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmOfficePreview Members


frmOfficePreview Members

frmOfficePreview overview

Constructors

constructor frmOfficePreview Constructor (Overloaded)

Methods

method Dispose
method InitializeComponent
method ListBox1_SelectedIndexChanged
method ToolBar1_ButtonClick
method frmOfficePreview_Closing
method frmOfficePreview_Load

Fields

field GroupBox1
field ImageList1
field ListBox1
field ToolBar1
field ToolBarButton1
field components
field webOCWrapper

See Also

frmOfficePreview Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal gd As Collection)

See Also

frmOfficePreview | EDOKAApp


frmOfficePreview Methods

frmOfficePreview overview

Methods

method Dispose
method InitializeComponent
method ListBox1_SelectedIndexChanged
method ToolBar1_ButtonClick
method frmOfficePreview_Closing
method frmOfficePreview_Load

See Also

frmOfficePreview Class


frmOfficePreview.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmOfficePreview))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.webOCWrapper = New WebOCHostCtrl()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(880, 25)
        Me.ToolBar1.TabIndex = 13
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.ListBox1})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Left
        Me.GroupBox1.Location = New System.Drawing.Point(0, 25)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(208, 596)
        Me.GroupBox1.TabIndex = 14
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Generierte Dokumente"
        '
        'ListBox1
        '
        Me.ListBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ListBox1.Location = New System.Drawing.Point(3, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(202, 576)
        Me.ListBox1.TabIndex = 0
        '
        'webOCWrapper
        '
        Me.webOCWrapper.BrowserContextMenu = False
        Me.webOCWrapper.Dock = System.Windows.Forms.DockStyle.Fill
        Me.webOCWrapper.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.webOCWrapper.Location = New System.Drawing.Point(208, 25)
        Me.webOCWrapper.Name = "webOCWrapper"
        Me.webOCWrapper.Size = New System.Drawing.Size(672, 596)
        Me.webOCWrapper.TabIndex = 15
        Me.webOCWrapper.TabStop = False
        '
        'frmOfficePreview
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(880, 621)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.webOCWrapper, Me.GroupBox1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmOfficePreview"
        Me.Text = "Dokument-Vorschau"
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview.ListBox1_SelectedIndexChanged Method

Private Sub ListBox1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.SelectedIndexChanged
        Try
            webOCWrapper.Navigate(Me.ListBox1.SelectedItem)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview.frmOfficePreview_Closing Method

Private Sub frmOfficePreview_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmOfficePreview_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim i As Integer
        Try
            webOCWrapper.Navigate("")
        Catch
        End Try

        For i = 0 To Me.ListBox1.Items.Count - 1
            Try
                File.Delete(Me.ListBox1.Items(i))
            Catch
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview.frmOfficePreview_Load Method

Private Sub frmOfficePreview_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmOfficePreview_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.ListBox1.SelectedIndex = 0
        Application.DoEvents()
        MyMsg.show_standardmessage(724, MsgBoxStyle.Information)
        'Try
        '    webOCWrapper.Navigate(Me.ListBox1.SelectedItem.Text)
        'Catch
        'End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview Fields

frmOfficePreview overview

Fields

field GroupBox1
field ImageList1
field ListBox1
field ToolBar1
field ToolBarButton1
field components
field webOCWrapper

See Also

frmOfficePreview Class


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


webOCWrapper Variable

Friend WithEvents webOCWrapper As WebOCHostCtrl

Source code

[Visual Basic]
    Friend WithEvents webOCWrapper As WebOCHostCtrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmPDFPrinter Class

For a list of all members of this type, see frmPDFPrinter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPDFPrinter

Public Class frmPDFPrinter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPDFPrinter Members


frmPDFPrinter Members

frmPDFPrinter overview

Constructors

constructor frmPDFPrinter Constructor (Overloaded)

Properties

property Part
property alnr

Methods

method Button1_Click
method Dispose
method InitializeComponent
method PrintPDF
method delay
method frmPDFPrinter_Load
method get_partner
method inetOptionsMI_Click

Fields

field Button1
field ImageList1
field Label1
field Label2
field Label3
field MenuItem13
field Panel1
field StatusBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field addressBar
field addressBarLbl
field cbverarbeitung
field components
field contextMenu
field lblpartner
field m_alnr
field m_part
field m_showdoc
field webOCWrapper

See Also

frmPDFPrinter Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal ShowDoc As Boolean)

See Also

frmPDFPrinter | EDOKAApp


frmPDFPrinter Properties

frmPDFPrinter overview

Properties

property Part
property alnr

See Also

frmPDFPrinter Class


frmPDFPrinter.Part Property

Property Part() As Integer

Source code

[Visual Basic]
    Property Part() As Integer
        Get
            Return m_part
        End Get
        Set(ByVal Value As Integer)
            m_part = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.alnr Property

Property alnr() As Integer

Source code

[Visual Basic]
    Property alnr() As Integer
        Get
            Return m_alnr
        End Get
        Set(ByVal Value As Integer)
            m_alnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter Methods

frmPDFPrinter overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method PrintPDF
method delay
method frmPDFPrinter_Load
method get_partner
method inetOptionsMI_Click

See Also

frmPDFPrinter Class


frmPDFPrinter.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            Select Case Me.cbverarbeitung.SelectedIndex
                Case 0
                Case 1
                    Dim frmbla As New frmBLAuslieferungen()
                    frmbla.set_PrintOK(Me.alnr, Part)
                    frmbla.Close()
                    frmbla.Dispose()
                Case 2
                    Dim frmbla As New frmBLAuslieferungen()
                    frmbla.set_PrintNOK(Me.alnr, Part)
                    frmbla.Close()
                    frmbla.Dispose()
            End Select
            Me.Close()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPDFPrinter))
        Me.contextMenu = New System.Windows.Forms.ContextMenu()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.addressBar = New System.Windows.Forms.ComboBox()
        Me.addressBarLbl = New System.Windows.Forms.Label()
        Me.ToolBar2 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.lblpartner = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.cbverarbeitung = New System.Windows.Forms.ComboBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.webOCWrapper = New EDOKAApp.WebOCHostCtrl()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'contextMenu
        '
        Me.contextMenu.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem13})
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 0
        Me.MenuItem13.Text = "Print..."
        '
        'StatusBar1
        '
        Me.StatusBar1.Anchor = ((System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.StatusBar1.Dock = System.Windows.Forms.DockStyle.None
        Me.StatusBar1.Location = New System.Drawing.Point(0, 431)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(666, 24)
        Me.StatusBar1.TabIndex = 1
        '
        'addressBar
        '
        Me.addressBar.Location = New System.Drawing.Point(16, 56)
        Me.addressBar.Name = "addressBar"
        Me.addressBar.Size = New System.Drawing.Size(352, 21)
        Me.addressBar.Sorted = True
        Me.addressBar.TabIndex = 3
        Me.addressBar.Visible = False
        '
        'addressBarLbl
        '
        Me.addressBarLbl.Location = New System.Drawing.Point(16, 12)
        Me.addressBarLbl.Name = "addressBarLbl"
        Me.addressBarLbl.Size = New System.Drawing.Size(100, 16)
        Me.addressBarLbl.TabIndex = 8
        Me.addressBarLbl.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'ToolBar2
        '
        Me.ToolBar2.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar2.DropDownArrows = True
        Me.ToolBar2.ImageList = Me.ImageList1
        Me.ToolBar2.Name = "ToolBar2"
        Me.ToolBar2.ShowToolTips = True
        Me.ToolBar2.Size = New System.Drawing.Size(666, 25)
        Me.ToolBar2.TabIndex = 9
        Me.ToolBar2.Visible = False
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblpartner, Me.Label2, Me.cbverarbeitung, Me.Label3, Me.Button1, Me.Label1})
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(368, 176)
        Me.Panel1.TabIndex = 10
        '
        'lblpartner
        '
        Me.lblpartner.Location = New System.Drawing.Point(56, 8)
        Me.lblpartner.Name = "lblpartner"
        Me.lblpartner.Size = New System.Drawing.Size(336, 23)
        Me.lblpartner.TabIndex = 10
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 23)
        Me.Label2.TabIndex = 9
        Me.Label2.Text = "Partner:"
        '
        'cbverarbeitung
        '
        Me.cbverarbeitung.Items.AddRange(New Object() {"Fenster schliessen", "Ausdruck erfolgreich", "Ausdruck nicht erfolgreich"})
        Me.cbverarbeitung.Location = New System.Drawing.Point(160, 80)
        Me.cbverarbeitung.Name = "cbverarbeitung"
        Me.cbverarbeitung.Size = New System.Drawing.Size(192, 21)
        Me.cbverarbeitung.TabIndex = 8
        Me.cbverarbeitung.Text = "ComboBox1"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 80)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(128, 23)
        Me.Label3.TabIndex = 7
        Me.Label3.Text = "Weitere Verarbeitung:"
        '
        'Button1
        '
        Me.Button1.Enabled = False
        Me.Button1.Location = New System.Drawing.Point(152, 120)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&OK"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(352, 32)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Label1"
        '
        'webOCWrapper
        '
        Me.webOCWrapper.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.webOCWrapper.BrowserContextMenu = False
        Me.webOCWrapper.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.webOCWrapper.Location = New System.Drawing.Point(8, 88)
        Me.webOCWrapper.Name = "webOCWrapper"
        Me.webOCWrapper.Size = New System.Drawing.Size(688, 304)
        Me.webOCWrapper.TabIndex = 11
        Me.webOCWrapper.TabStop = False
        '
        'frmPDFPrinter
        '
        Me.AutoScale = False
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(666, 455)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.ToolBar2, Me.addressBarLbl, Me.StatusBar1, Me.addressBar, Me.webOCWrapper})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.MaximizeBox = False
        Me.MaximumSize = New System.Drawing.Size(368, 176)
        Me.MinimizeBox = False
        Me.Name = "frmPDFPrinter"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Druckbestätigung"
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.PrintPDF Method

Public Sub PrintPDF()

Source code

[Visual Basic]
    Public Sub PrintPDF()
        delay(2)
        '----------------------------
        ' Taskforce Korrektur
        ' BUD - 21.03.2006
        '----------------------------
        'webOCWrapper.Print(doUI:=True)
        Dim objpdf As New clsPDF_print_show()
        objpdf.PrintPDF(addressBar.Text, clsPDF_print_show.Enum_Art.Drucken)
        MsgBox(MyTxt.gettext(618), MsgBoxStyle.Information, "Banklagernd Druck")
        '----------------------------
        Me.Button1.Enabled = True
        Application.DoEvents()
        Dim i As Integer
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.delay Method

Private Sub delay( _
   ByVal seconds As Integer _
)

Parameters

seconds
Required.

Source code

[Visual Basic]
    Private Sub delay(ByVal seconds As Integer)
        Me.Cursor = Cursors.WaitCursor
        Dim starttime As DateTime = DateTime.Now
        Do
            Application.DoEvents()
        Loop While DateTime.Now.Subtract(starttime).TotalSeconds < seconds
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.frmPDFPrinter_Load Method

Private Sub frmPDFPrinter_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPDFPrinter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        get_partner(alnr)
        Me.Text = "Druckbestätigung: " + Me.lblpartner.Text
        Me.Label1.Text = MyTxt.gettext(615)
        '----------------------------
        ' Taskforce Korrektur
        ' BUD - 21.03.2006
        '----------------------------
        'If Me.m_showdoc = True Then
        '    webOCWrapper.Navigate(addressBar.Text)
        'End If
        '----------------------------

        Me.cbverarbeitung.SelectedIndex = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.get_partner Method

Private Function get_partner( _
   ByVal alnr As Integer _
)

Parameters

alnr
Required.

Source code

[Visual Basic]
    Private Function get_partner(ByVal alnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_edex_bl_get_partner"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@alnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bkpar00", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Me.lblpartner.Text = scmCmdToExecute.Parameters("@bkpar00").Value
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter.inetOptionsMI_Click Method

Private Sub inetOptionsMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub inetOptionsMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.InternetOptions()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter Fields

frmPDFPrinter overview

Fields

field Button1
field ImageList1
field Label1
field Label2
field Label3
field MenuItem13
field Panel1
field StatusBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field addressBar
field addressBarLbl
field cbverarbeitung
field components
field contextMenu
field lblpartner
field m_alnr
field m_part
field m_showdoc
field webOCWrapper

See Also

frmPDFPrinter Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


ToolBar2 Variable

Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


addressBar Variable

Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


addressBarLbl Variable

Friend WithEvents addressBarLbl As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents addressBarLbl As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


cbverarbeitung Variable

Friend WithEvents cbverarbeitung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbverarbeitung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


contextMenu Variable

Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


lblpartner Variable

Friend WithEvents lblpartner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpartner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


m_alnr Variable

Dim m_alnr As Integer

Source code

[Visual Basic]
    Dim m_alnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


m_part Variable

Dim m_part As Integer

Source code

[Visual Basic]
    Dim m_part As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


m_showdoc Variable

Dim m_showdoc As Boolean = True

Source code

[Visual Basic]
    Dim m_showdoc As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


webOCWrapper Variable

Friend WithEvents webOCWrapper As EDOKAApp.WebOCHostCtrl

Source code

[Visual Basic]
    Friend WithEvents webOCWrapper As EDOKAApp.WebOCHostCtrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDF_Printer Class

For a list of all members of this type, see frmPDF_Printer Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPDF_Printer

Public Class frmPDF_Printer
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPDF_Printer Members


frmPDF_Printer Members

frmPDF_Printer overview

Constructors

constructor frmPDF_Printer Constructor (Overloaded)

Methods

method Button1_Click
method Button2_Click
method Dispose
method Get_Druckjob
method InitializeComponent
method Prepare_Form
method PrintPDF
method delay
method frmPDF_Printer_Closing
method frmPDF_Printer_Load
method inetOptionsMI_Click

Events

event PrintDOne

Fields

field Button1
field Button2
field ImageList1
field Label1
field MenuItem13
field Panel1
field PictureBox2
field StatusBar1
field addressBar
field components
field contextMenu
field m_druckjobPfad
field m_showdoc
field webOCWrapper

See Also

frmPDF_Printer Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal druckjobPfad As String, ByVal ShowDoc As Boolean)

See Also

frmPDF_Printer | EDOKAApp


frmPDF_Printer Methods

frmPDF_Printer overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Get_Druckjob
method InitializeComponent
method Prepare_Form
method PrintPDF
method delay
method frmPDF_Printer_Closing
method frmPDF_Printer_Load
method inetOptionsMI_Click

See Also

frmPDF_Printer Class


frmPDF_Printer.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Yes
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.No
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.Get_Druckjob Method

Private Function Get_Druckjob()

Source code

[Visual Basic]
    Private Function Get_Druckjob()
        Try
            Dim dokumentname2 = m_druckjobPfad
            Me.addressBar.Text = dokumentname2
            Return True
            Exit Function
        Catch EX As Exception
            'MyMsg.show_standardmessage(716, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPDF_Printer))
        Me.contextMenu = New System.Windows.Forms.ContextMenu()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.addressBar = New System.Windows.Forms.ComboBox()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.webOCWrapper = New EDOKAApp.WebOCHostCtrl()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'contextMenu
        '
        Me.contextMenu.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem13})
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 0
        Me.MenuItem13.Text = "Print..."
        '
        'StatusBar1
        '
        Me.StatusBar1.Anchor = ((System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.StatusBar1.Dock = System.Windows.Forms.DockStyle.None
        Me.StatusBar1.Location = New System.Drawing.Point(0, 405)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(624, 24)
        Me.StatusBar1.TabIndex = 1
        '
        'addressBar
        '
        Me.addressBar.Location = New System.Drawing.Point(16, 56)
        Me.addressBar.Name = "addressBar"
        Me.addressBar.Size = New System.Drawing.Size(352, 21)
        Me.addressBar.Sorted = True
        Me.addressBar.TabIndex = 3
        Me.addressBar.Visible = False
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox2, Me.Button2, Me.Label1, Me.Button1})
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(368, 176)
        Me.Panel1.TabIndex = 10
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(160, 88)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&Nein"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(56, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(264, 48)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Sind die Dokumente erfolgreich gedruckt worden?"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(240, 88)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&Ja"
        '
        'webOCWrapper
        '
        Me.webOCWrapper.BrowserContextMenu = False
        Me.webOCWrapper.Dock = System.Windows.Forms.DockStyle.Fill
        Me.webOCWrapper.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.webOCWrapper.Name = "webOCWrapper"
        Me.webOCWrapper.Size = New System.Drawing.Size(320, 125)
        Me.webOCWrapper.TabIndex = 11
        Me.webOCWrapper.TabStop = False
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(16, 8)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 16
        Me.PictureBox2.TabStop = False
        '
        'frmPDF_Printer
        '
        Me.AutoScale = False
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(320, 125)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.StatusBar1, Me.addressBar, Me.webOCWrapper})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPDF_Printer"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "PDF-Dokument drucken"
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.Prepare_Form Method

Public Sub Prepare_Form()

Source code

[Visual Basic]
    Public Sub Prepare_Form()
        'SHU Mehrfachdruck
        Get_Druckjob()
        If Me.m_showdoc = True Then
            Me.Width = Me.Width * 2.5
            Me.Height = Me.Height * 3.5
            Me.Panel1.Visible = False
            webOCWrapper.Navigate(addressBar.Text)
        Else
            webOCWrapper.Navigate(addressBar.Text)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.PrintPDF Method

Public Sub PrintPDF()

Source code

[Visual Basic]
    Public Sub PrintPDF()
        delay(2)
        webOCWrapper.Print(doUI:=True)
        Me.Button1.Enabled = True
        Application.DoEvents()
        Dim i As Integer
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.delay Method

Private Sub delay( _
   ByVal seconds As Integer _
)

Parameters

seconds
Required.

Source code

[Visual Basic]
    Private Sub delay(ByVal seconds As Integer)
        Me.Cursor = Cursors.WaitCursor
        Dim starttime As DateTime = DateTime.Now
        Do
            Application.DoEvents()
        Loop While DateTime.Now.Subtract(starttime).TotalSeconds < seconds
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.frmPDF_Printer_Closing Method

Private Sub frmPDF_Printer_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPDF_Printer_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Me.Hide()
        If Me.DialogResult = DialogResult.Yes Then RaiseEvent PrintDOne()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.frmPDF_Printer_Load Method

Private Sub frmPDF_Printer_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPDF_Printer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_Druckjob()
        If Me.m_showdoc = True Then
            Me.Width = Me.Width * 2.5
            Me.Height = Me.Height * 3.5
            Me.Panel1.Visible = False
            webOCWrapper.Navigate(addressBar.Text)
        Else
            webOCWrapper.Navigate(addressBar.Text)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer.inetOptionsMI_Click Method

Private Sub inetOptionsMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub inetOptionsMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.InternetOptions()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer Events

frmPDF_Printer overview

Events

event PrintDOne

See Also

frmPDF_Printer Class


PrintDOne Event

Public Event PrintDOne()

Source code

[Visual Basic]
    Public Event PrintDOne()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer Fields

frmPDF_Printer overview

Fields

field Button1
field Button2
field ImageList1
field Label1
field MenuItem13
field Panel1
field PictureBox2
field StatusBar1
field addressBar
field components
field contextMenu
field m_druckjobPfad
field m_showdoc
field webOCWrapper

See Also

frmPDF_Printer Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


addressBar Variable

Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


contextMenu Variable

Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


m_druckjobPfad Variable

Dim m_druckjobPfad As String

Source code

[Visual Basic]
    Dim m_druckjobPfad As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


m_showdoc Variable

Dim m_showdoc As Boolean = True

Source code

[Visual Basic]
    Dim m_showdoc As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


webOCWrapper Variable

Friend WithEvents webOCWrapper As WebOCHostCtrl

Source code

[Visual Basic]
    Friend WithEvents webOCWrapper As WebOCHostCtrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmParameterSetName Class

For a list of all members of this type, see frmParameterSetName Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmParameterSetName

Public Class frmParameterSetName
   Inherits EDOKAApp.frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmParameterSetName Members


frmParameterSetName Members

frmParameterSetName overview

Constructors

constructor frmParameterSetName Constructor

Properties

property DatenModus
property DatenSpeichern
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property ParameterDataset
property ParameterSetName
property ParameterSetNameID
property ReportNr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method DeleteParameterSetList
method DeleteParameterSetName
method Dispose
method DomainList_AfterInsert
method DomainList_BeforeInsert
method DomainList_BeforeRowColChange
method DomainList_Dblklick
method DomainList_MouseDown
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method GetRecordcount
method InitializeComponent
method InsertParameterList
method MenuItem3_Click
method MenuItem5_Click
method MenuItem5_Click_1
method RefreshParameterlist
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method Uebenehmen
method UpdateParameterList
method domainlist_aftercellupdate
method frmParameterSetName_Activated
method frmParameterSetName_Closing
method frmParameterSet_Load
method mnuExit_Click
method mnuUebernehmen_Click

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field cmUebernehmen
field components
field m_bDatenSpeichern
field m_bNewParameterSetListe
field m_dsParameterDataset
field m_iDatenModus
field m_iParameterSetNameID
field m_iReportNr
field m_sParameterSetName
field mnuExit
field mnuUebernehmen

See Also

frmParameterSetName Class


frmParameterSetName Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName Properties

frmParameterSetName overview

Properties

property DatenModus
property DatenSpeichern
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property ParameterDataset
property ParameterSetName
property ParameterSetNameID
property ReportNr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmParameterSetName Class


frmParameterSetName.DatenModus Property

Public Property DatenModus()

Source code

[Visual Basic]
    Public Property DatenModus()
        Get
            Return DatenModus
        End Get
        Set(ByVal Value)
            m_iDatenModus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DatenSpeichern Property

Public Property DatenSpeichern()

Source code

[Visual Basic]
    Public Property DatenSpeichern()
        Get
            DatenSpeichern = m_bDatenSpeichern
        End Get
        Set(ByVal Value)
            m_bDatenSpeichern = Value
            Me.DomainList.AllowAddNew = m_bDatenSpeichern
            Me.DomainList.AllowUpdate = m_bDatenSpeichern
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.ParameterDataset Property

Public Property ParameterDataset()

Source code

[Visual Basic]
    Public Property ParameterDataset()
        Get
            ParameterDataset = m_dsParameterDataset
        End Get
        Set(ByVal Value)
            m_dsParameterDataset = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.ParameterSetName Property

Public Property ParameterSetName()

Source code

[Visual Basic]
    Public Property ParameterSetName()
        Get
            ParameterSetName = m_sParameterSetName
        End Get
        Set(ByVal Value)
            m_sParameterSetName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.ParameterSetNameID Property

Public Property ParameterSetNameID()

Source code

[Visual Basic]
    Public Property ParameterSetNameID()
        Get
            ParameterSetNameID = m_iParameterSetNameID
        End Get
        Set(ByVal Value)
            m_iParameterSetNameID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.ReportNr Property

Public Property ReportNr()

Source code

[Visual Basic]
    Public Property ReportNr()
        Get
            ReportNr = m_iReportNr
        End Get
        Set(ByVal Value)
            m_iReportNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName Methods

frmParameterSetName overview

Methods

method DeleteParameterSetList
method DeleteParameterSetName
method Dispose
method DomainList_AfterInsert
method DomainList_BeforeInsert
method DomainList_BeforeRowColChange
method DomainList_Dblklick
method DomainList_MouseDown
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method GetRecordcount
method InitializeComponent
method InsertParameterList
method MenuItem3_Click
method MenuItem5_Click
method MenuItem5_Click_1
method RefreshParameterlist
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method Uebenehmen
method UpdateParameterList
method domainlist_aftercellupdate
method frmParameterSetName_Activated
method frmParameterSetName_Closing
method frmParameterSet_Load
method mnuExit_Click
method mnuUebernehmen_Click

See Also

frmParameterSetName Class


frmParameterSetName.DeleteParameterSetList Method

Private Function DeleteParameterSetList() As Boolean

Source code

[Visual Basic]
    Private Function DeleteParameterSetList() As Boolean
        '===============================================================================
        'Desc       : Besthende ParameterSetListe werden gelöscht
        'Kriterium  : DomainList.Columns("ParameterSetNameID")
        'Output     : True False
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim scmCmdToExecuteParameterSetlist As SqlCommand = New SqlCommand()
        Dim iErrorCode As Integer
        Dim lCnt As Long
        DeleteParameterSetList = True
        scmCmdToExecuteParameterSetlist.CommandText = "dbo.[sp_ParameterSetList_Delete]"
        scmCmdToExecuteParameterSetlist.CommandType = CommandType.StoredProcedure

        conn.OpenConnection()
        scmCmdToExecuteParameterSetlist.Connection = conn.scoDBConnection

        Try
            scmCmdToExecuteParameterSetlist.Parameters.Clear()
            scmCmdToExecuteParameterSetlist.Parameters.Add(New SqlParameter("@ParameterSetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DomainList.Columns("ParameterSetNameID").Value))
            ' // Execute query ParameterSetList.
            scmCmdToExecuteParameterSetlist.ExecuteNonQuery()
            ' // Execute query ParameterSetName.
        Catch ex As Exception
            DeleteParameterSetList = False
            MessageBox.Show(ex.Message, "Parametersetliste löschen", MessageBoxButtons.OK, MessageBoxIcon.Error, MessageBoxDefaultButton.Button1)
        Finally
            scmCmdToExecuteParameterSetlist.Dispose()
        End Try
        conn.CloseConnection(True)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DeleteParameterSetName Method

Private Function DeleteParameterSetName() As Boolean

Source code

[Visual Basic]
    Private Function DeleteParameterSetName() As Boolean
        '===============================================================================
        'Desc       : Besthende ParameterSetName werden gelöscht
        'Kriterium  : DomainList.Columns("ParameterSetNameID")
        'Output     : True False
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim scmCmdToExecuteParameterSetName As SqlCommand = New SqlCommand()
        DeleteParameterSetName = True
        scmCmdToExecuteParameterSetName.CommandText = "dbo.[sp_ParameterSetName_Delete]"
        scmCmdToExecuteParameterSetName.CommandType = CommandType.StoredProcedure
        conn.OpenConnection()
        scmCmdToExecuteParameterSetName.Connection = conn.scoDBConnection
        Try
            scmCmdToExecuteParameterSetName.Parameters.Clear()
            scmCmdToExecuteParameterSetName.Parameters.Add(New SqlParameter("@ParameterSetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DomainList.Columns("ParameterSetNameID").Value))

            ' // Execute query ParameterSetName.
            scmCmdToExecuteParameterSetName.ExecuteNonQuery()
            DomainList.Refresh()
        Catch ex As Exception
            DeleteParameterSetName = False
            MessageBox.Show(ex.Message, "ParametersetNamen löschen", MessageBoxButtons.OK, MessageBoxIcon.Error, MessageBoxDefaultButton.Button1)
        Finally
            scmCmdToExecuteParameterSetName.Dispose()
        End Try

        conn.CloseConnection(True)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Me.DomainList.Columns("beschreibung").Text = ""

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DomainList_BeforeInsert Method

Private Sub DomainList_BeforeInsert( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DomainList.BeforeInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeInsert(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DomainList.BeforeInsert
        If m_bNewParameterSetListe = False Then
            m_bNewParameterSetListe = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DomainList_BeforeRowColChange Method

Private Sub DomainList_BeforeRowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DomainList.BeforeRowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_BeforeRowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DomainList.BeforeRowColChange

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DomainList_Dblklick Method

Private Sub DomainList_Dblklick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_Dblklick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.DoubleClick
        Uebenehmen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.DomainList_MouseDown Method

Private Sub DomainList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DomainList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DomainList.MouseDown
        If e.Button = MouseButtons.Right Then
            Me.DomainList.Bookmark = Me.DomainList.RowContaining(e.Y)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.GetRecordcount Method

Public Function GetRecordcount() As Integer

Source code

[Visual Basic]
    Public Function GetRecordcount() As Integer
        '===============================================================================
        'Desc       : Ermittelt die Anzahl der Records in der Tabelle ParameterSetList
        'Input 	    :
        'Kriterium  : DomainList.Columns("ParameterSetNameID").Value
        'Updatewert :
        'Output	    : Anzahl Datensätze
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim m_dbkey As Long
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.[sp_ParameterSetList_anzahl]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure

        conn.OpenConnection()
        ' // Use base class' connection object
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@ParameterSetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, DomainList.Columns("ParameterSetNameID").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Anzahl", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, GetRecordcount))
            'scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))
            'scmCmdToExecute.Connection.Open()

            scmCmdToExecute.ExecuteNonQuery()
            GetRecordcount = scmCmdToExecute.Parameters("@Anzahl").Value()

        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            MessageBox.Show(ex.Message, "Anzahl Parametersetliste ", MessageBoxButtons.OK, MessageBoxIcon.Error, MessageBoxDefaultButton.Button1)

        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.cmUebernehmen = New System.Windows.Forms.ContextMenu()
        Me.mnuUebernehmen = New System.Windows.Forms.MenuItem()
        Me.mnuExit = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'cmUebernehmen
        '
        Me.cmUebernehmen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuUebernehmen, Me.mnuExit, Me.MenuItem4, Me.MenuItem5})
        '
        'mnuUebernehmen
        '
        Me.mnuUebernehmen.Index = 0
        Me.mnuUebernehmen.Text = "Ü&bernehmen"
        '
        'mnuExit
        '
        Me.mnuExit.Index = 1
        Me.mnuExit.Text = "B&eenden ohne Übernehmen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 2
        Me.MenuItem4.Text = "-"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 3
        Me.MenuItem5.Text = "Parameterset &löschen"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "ParameterSetName", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ParameterSetNameID", "ParameterSetNameID"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_ParameterSetName_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParameterSetNameID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParameterSetNameID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=TGTSQLEDOKABSSF;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;user id=tgentwicklung3;workstation id=TG602640;packet size" & _
        "=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_ParameterSetName_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParameterSetNameID", System.Data.SqlDbType.Int, 4, "ParameterSetNameID"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_ParameterSetName_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportNr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_ParameterSetName_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParameterSetNameID", System.Data.SqlDbType.Int, 4, "ParameterSetNameID"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParameterSetNameID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParameterSetNameID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmParameterSetName
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(880, 377)
        Me.Name = "frmParameterSetName"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = ""
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.InsertParameterList Method

Private Function InsertParameterList() As Boolean

Source code

[Visual Basic]
    Private Function InsertParameterList() As Boolean
        '===============================================================================
        'Desc       : Neue Parameter werden gespeichert
        'Input      :
        'Output     : True False
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim lCnt As Long
        Dim key As Long
        Dim vdata As New edokadb.clsParameterSetList()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        InsertParameterList = True
        Try
            conn.OpenConnection()
            dbkey.cpMainConnectionProvider = conn
            For lCnt = 0 To m_dsParameterDataset.Tables(0).Rows.Count - 1
                'Alle Benutzerparanmeter durchlaufen
                With vdata
                    key = dbkey.get_dbkey("ParameterSetList")
                    conn.OpenConnection()
                    .cpMainConnectionProvider = conn
                    .iParameterSetListID = New SqlInt32(CType(key, Integer))
                    .iParameterSetNameID = New SqlInt32(CType(Me.DomainList.Columns("ParameterSetNameID").Value, Integer))
                    .iReportReportfeldregelNr = New SqlInt32(CType(m_dsParameterDataset.Tables(0).Rows(lCnt).Item("Reportreportfeldregelnr"), Integer))

                    If Not m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterDisplayValue") Is System.DBNull.Value Then
                        .sParameterDisplayValue = New SqlString(CType(m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterDisplayValue"), String))
                    Else
                        '.sParameterDisplayValue = m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterDisplayValue")
                    End If
                    '.sParameterDisplayValue = New SqlString(CType(m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterDisplayValue"), String))

                    If Not m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterNavigationValue") Is System.DBNull.Value Then
                        .sParameterNavigationValue = New SqlString(CType(m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterNavigationValue"), String))
                    Else
                        '.sParameterNavigationValue = m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterNavigationValue")
                    End If

                    If Not m_dsParameterDataset.Tables(0).Rows(lCnt).Item("datenherkunft") Is System.DBNull.Value Then
                        .sDatenherkunft = New SqlString(CType(m_dsParameterDataset.Tables(0).Rows(lCnt).Item("datenherkunft"), String))
                    Else
                        '.sDatenherkunft = m_dsParameterDataset.Tables(0).Rows(lCnt).Item("datenherkunft")
                    End If
                    .iReihenfolge() = New SqlInt32(lCnt)
                    .iMandantnr = New SqlInt32(Globals.MitarbeiterNr)
                    .bAktiv = New SqlBoolean(True)
                    .daErstellt_am = New SqlDateTime(Now())
                    .daMutiert_am = New SqlDateTime(Now())
                    .iMutierer = New SqlInt32(Globals.MitarbeiterNr)
                End With
                vdata.Insert()
                'conn.Dispose()
            Next
        Catch ex As Exception
            InsertParameterList = False
            MessageBox.Show(ex.Message, "Einfügefehler", MessageBoxButtons.OK, MessageBoxIcon.Error, MessageBoxDefaultButton.Button1)
        End Try

        conn.CloseConnection(True)
        vdata.Dispose()
        dbkey.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        '===============================================================================
        'Desc       : Löschen der ParamterSetNamen Nach OK Bestätigung des Users wird erst die ParametersetListe gelöscht
        '             Danach die ParameterSetName
        'Input      :
        'Output     :
        'Erstellt   : koe 20.10.2003
        'Geaendert  :
        '===============================================================================
        Save_Data()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.MenuItem5_Click_1 Method

Private Sub MenuItem5_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click

        '===============================================================================
        'Desc       : Löschen der ParamterSetNamen Nach OK Bestätigung des Users wird erst die ParametersetListe gelöscht
        '             Danach die ParameterSetName
        'Input      :
        'Output     :
        'Erstellt   : koe 20.10.2003
        'Geaendert  :
        '===============================================================================
        If MyMsg.show_MessageYesNo_ReplaceText(218, DomainList.Columns("bezeichnung").Value, "") = DialogResult.Yes Then          'Möchten Sie das Parameterset " & DomainList.Columns("bezeichnung").Value & " Löschen?"
            'MyMsg.show_standardmessage_ReplaceText(218, MsgBoxStyle.Question, DomainList.Columns("bezeichnung").Value, "")
            DeleteParameterSetList()
            DeleteParameterSetName()
            RefreshParameterlist()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.RefreshParameterlist Method

Private Sub RefreshParameterlist()

Source code

[Visual Basic]
    Private Sub RefreshParameterlist()
        DataSet1.Clear()
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.DataSet1.Tables(0).TableName

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Me.ActiveControl = Me.ToolBar1
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
            If m_bNewParameterSetListe = True Then
                '===============================================================================
                'Ein neuer Parametename wurde vergeben
                '===============================================================================
                If InsertParameterList() = False Then
                    Save_Data = False
                End If
            Else
                '===============================================================================
                'Ein bestehender Parametername wird überschreiben
                '===============================================================================
                If UpdateParameterList() = False Then
                    Save_Data = False
                End If

            End If
            m_bNewParameterSetListe = False
            'Me.Close()
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Select Case m_iDatenModus
                    Case Enum_DatenModus.Laden
                        Uebenehmen()
                    Case Enum_DatenModus.Speichern
                        Me.Close()
                End Select
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.Uebenehmen Method

Private Sub Uebenehmen()

Source code

[Visual Basic]
    Private Sub Uebenehmen()
        Select Case m_iDatenModus
            Case Enum_DatenModus.Laden
                If Me.DomainList.Splits(0).Rows.Count >= 1 And Not Me.DomainList.Columns("ParameterSetNameID").Value Is System.DBNull.Value Then
                    Me.ToSelect = True
                    Me.ParameterSetName = Me.DomainList.Columns("bezeichnung").Value
                    Me.TransferKey = Me.DomainList.Columns("ParameterSetNameID").Value
                Else
                    Me.TransferKey = 0
                End If
                Me.Close()
            Case Enum_DatenModus.Speichern
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.UpdateParameterList Method

Private Function UpdateParameterList() As Boolean

Source code

[Visual Basic]
    Private Function UpdateParameterList() As Boolean
        '===============================================================================
        'Desc       : Besthende Parameter werden ergänzt
        'Kriterium  : ParameterSetNameID,ReportReportfeldregelNr
        'Updatewert : MitarbeiterNr, Parameterwert
        'Output     : True False
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim objParmameterSetList As New edokadb.clsParameterSetList()
        Dim daTable As New DataTable()
        Dim iErrorCode As Integer
        Dim lCnt As Long
        UpdateParameterList = True
        scmCmdToExecute.CommandText = "dbo.[sp_ParameterSetList_Update]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        conn.OpenConnection()
        objParmameterSetList.cpMainConnectionProvider = conn
        daTable = objParmameterSetList.SelectAll()
        conn.CloseConnection(True)
        Try
            If GetRecordcount() = m_dsParameterDataset.Tables(0).Rows.Count Then
                conn.OpenConnection()
                scmCmdToExecute.Connection = conn.scoDBConnection
                For lCnt = 0 To m_dsParameterDataset.Tables(0).Rows.Count - 1
                    scmCmdToExecute.Parameters.Clear()

                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ParameterDisplayValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterDisplayValue")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ParameterNavigationValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_dsParameterDataset.Tables(0).Rows(lCnt).Item("ParameterNavigationValue")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_dsParameterDataset.Tables(0).Rows(lCnt).Item("datenherkunft")))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ParametesetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DomainList.Columns("ParameterSetNameID").Value))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_dsParameterDataset.Tables(0).Rows(lCnt).Item("Reportreportfeldregelnr")))
                    ' // Execute query.
                    scmCmdToExecute.ExecuteNonQuery()
                Next
            Else
                DeleteParameterSetList()
                InsertParameterList()
            End If
        Catch ex As Exception
            UpdateParameterList = False
            MessageBox.Show(ex.Message, "Update Parameterliste", MessageBoxButtons.OK, MessageBoxIcon.Error, MessageBoxDefaultButton.Button1)
        Finally
            scmCmdToExecute.Dispose()
        End Try

        conn.CloseConnection(True)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            Me.DomainList.Columns("reportNr").Value = Me.m_iReportNr
            Me.DomainList.Columns("mandantnr").Value = Globals.MandantNr
            Me.DomainList.Columns("mitarbeiternr").Value = Globals.MitarbeiterNr

            Save_Data()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.frmParameterSetName_Activated Method

Private Sub frmParameterSetName_Activated( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Activated

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmParameterSetName_Activated(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Activated
        Select Case m_iDatenModus
            Case Enum_DatenModus.Laden          'Form wird für Laden der Parameter geöffnet
                Me.ToolBar1.Buttons(1).Visible = False      'Ausschalten des Speichernknopfes
                Me.MenuItem3.Visible = False
            Case Enum_DatenModus.Speichern      'Form wir für Speichern der Parameter geöffnet

        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.frmParameterSetName_Closing Method

Private Sub frmParameterSetName_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmParameterSetName_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then
                    e.Cancel = False
                Else
                    e.Cancel = True
                End If
                If msg = MsgBoxResult.Cancel Then
                    e.Cancel = True
                End If
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.frmParameterSet_Load Method

Private Sub frmParameterSet_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmParameterSet_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim lCnt As Long
        Me.DomainList.ContextMenu = Me.cmUebernehmen

        Me.TableName = "ParameterSetName"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mitarbeiternr", Globals.MitarbeiterNr)
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@reportnr", Me.ReportNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.DataSet1.Tables(0).TableName
        'Me.Eintrag = "Parameterwerte"
        SpaltenTitel_Aktualisieren(Me.DataSet1)
        DomainList.FetchRowStyles = True
        If Me.ParameterSetNameID > 0 Then
            For lCnt = 0 To DomainList.Splits(0).Rows.Count - 1
                If DomainList.Columns("ParameterSetNameID").CellText(lCnt) = Me.ParameterSetNameID Then
                    DomainList.Bookmark = lCnt
                    Exit For
                End If
            Next
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.mnuExit_Click Method

Private Sub mnuExit_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuExit.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuExit_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuExit.Click

        Me.TransferKey = 0
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName.mnuUebernehmen_Click Method

Private Sub mnuUebernehmen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuUebernehmen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuUebernehmen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuUebernehmen.Click
        Uebenehmen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmParameterSetName Fields

frmParameterSetName overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem4
field MenuItem5
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field cmUebernehmen
field components
field m_bDatenSpeichern
field m_bNewParameterSetListe
field m_dsParameterDataset
field m_iDatenModus
field m_iParameterSetNameID
field m_iReportNr
field m_sParameterSetName
field mnuExit
field mnuUebernehmen

See Also

frmParameterSetName Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


cmUebernehmen Variable

Friend WithEvents cmUebernehmen As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents cmUebernehmen As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_bDatenSpeichern Variable

Private m_bDatenSpeichern As Boolean = False

Source code

[Visual Basic]
    Private m_bDatenSpeichern As Boolean = False             'False = Daten Laden True = Daten Speichern

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_bNewParameterSetListe Variable

Private m_bNewParameterSetListe As Boolean = False

Source code

[Visual Basic]
    Private m_bNewParameterSetListe As Boolean = False      ' Wird auf true gesetzt, wenn ein neuer ParametesetName eingegeben wird

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_dsParameterDataset Variable

Private m_dsParameterDataset As DataSet

Source code

[Visual Basic]
    Private m_dsParameterDataset As DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_iDatenModus Variable

Private m_iDatenModus As Enum_DatenModus

Source code

[Visual Basic]
    Private m_iDatenModus As Enum_DatenModus

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_iParameterSetNameID Variable

Private m_iParameterSetNameID As Integer

Source code

[Visual Basic]
    Private m_iParameterSetNameID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_iReportNr Variable

Private m_iReportNr As Integer

Source code

[Visual Basic]
    Private m_iReportNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


m_sParameterSetName Variable

Private m_sParameterSetName As String

Source code

[Visual Basic]
    Private m_sParameterSetName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


mnuExit Variable

Friend WithEvents mnuExit As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuExit As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


mnuUebernehmen Variable

Friend WithEvents mnuUebernehmen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuUebernehmen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmParameterSetName


frmPartnerCold Class

For a list of all members of this type, see frmPartnerCold Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerCold

Public Class frmPartnerCold
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerCold Members


frmPartnerCold Members

frmPartnerCold overview

Constructors

constructor frmPartnerCold Constructor

Methods

method ARSLogin
method Button1_Click_1
method ColdDokumente
method Dispose
method InitializeComponent
method Search_doc
method frmPartnerHost_Load
method hoststruktur_AfterSelect_1

Fields

field Button1
field DataSet1
field DomainList
field GroupBox1
field ImageList1
field Partnernr
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field d
field dokumentart
field hd
field hoststruktur
field i
field ondemand
field pw
field rc
field server
field txtnrpar00
field user
field xnumdocs

See Also

frmPartnerCold Class


frmPartnerCold Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold Methods

frmPartnerCold overview

Methods

method ARSLogin
method Button1_Click_1
method ColdDokumente
method Dispose
method InitializeComponent
method Search_doc
method frmPartnerHost_Load
method hoststruktur_AfterSelect_1

See Also

frmPartnerCold Class


frmPartnerCold.ARSLogin Method

Public Function ARSLogin() As Boolean

Source code

[Visual Basic]
    Public Function ARSLogin() As Boolean
        server = "Test_System"
        user = "TGSYSADM3"
        pw = "TGSYSADM"
        rc = ondemand.setusermessagemode(2)
        rc = ondemand.logoff
        rc = ondemand.logon(server, user, pw)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim s As String
        s = Me.txtnrpar00.Text
        While Len(s) < 9
            s = "0" + s
        End While
        dokumentart.LoadHostTree(Me.hoststruktur, s)
        Me.hoststruktur.ExpandAll()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.ColdDokumente Method

Public Function ColdDokumente()

Source code

[Visual Basic]
    Public Function ColdDokumente()
        ARSLogin()
        hd.cpMainConnectionProvider = conn
        d = hd.SelectAll_HostDokumente
        For i = 0 To d.Rows.Count - 1
            Search_doc(d.Rows(i).Item("hostdokumenttyp"))
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerHost))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Partnernr = New System.Windows.Forms.Label()
        Me.txtnrpar00 = New System.Windows.Forms.TextBox()
        Me.hoststruktur = New System.Windows.Forms.TreeView()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GroupBox1.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Partnernr, Me.txtnrpar00})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(760, 48)
        Me.GroupBox1.TabIndex = 4
        Me.GroupBox1.TabStop = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(192, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(72, 24)
        Me.Button1.TabIndex = 6
        Me.Button1.Text = "Select"
        '
        'Partnernr
        '
        Me.Partnernr.Location = New System.Drawing.Point(8, 16)
        Me.Partnernr.Name = "Partnernr"
        Me.Partnernr.Size = New System.Drawing.Size(56, 23)
        Me.Partnernr.TabIndex = 5
        Me.Partnernr.Text = "Partnernr"
        '
        'txtnrpar00
        '
        Me.txtnrpar00.Location = New System.Drawing.Point(64, 16)
        Me.txtnrpar00.Name = "txtnrpar00"
        Me.txtnrpar00.Size = New System.Drawing.Size(128, 20)
        Me.txtnrpar00.TabIndex = 4
        Me.txtnrpar00.Text = ""
        '
        'hoststruktur
        '
        Me.hoststruktur.Dock = System.Windows.Forms.DockStyle.Left
        Me.hoststruktur.Location = New System.Drawing.Point(0, 48)
        Me.hoststruktur.Name = "hoststruktur"
        Me.hoststruktur.Size = New System.Drawing.Size(272, 533)
        Me.hoststruktur.TabIndex = 5
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[xx_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[xx_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_partner_hostdokumente_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nrpar00", System.Data.SqlDbType.VarChar, 9))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[xx_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DomainList
        '
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AllowUpdate = False
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(272, 48)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines1
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = False
        Me.DomainList.Size = New System.Drawing.Size(488, 533)
        Me.DomainList.TabIndex = 7
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWi" & _
        "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
        "ClientRect>0, 0, 484, 529</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
        "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
        "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
        "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
        """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
        "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
        "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
        "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
        "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
        "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
        "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
        """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
        "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
        "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
        "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
        """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
        "rzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 484, 529</ClientArea></Blob>"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmPartnerHost
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(760, 581)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DomainList, Me.hoststruktur, Me.GroupBox1})
        Me.Name = "frmPartnerHost"
        Me.Text = "frmPartnerHost"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.Search_doc Method

Public Function Search_doc( _
   ByVal searchvalue As String _
) As Long

Parameters

searchvalue
Required.

Source code

[Visual Basic]
    Public Function Search_doc(ByVal searchvalue As String) As Long
        rc = ondemand.OpenFolder("AKKB Kredite")
        rc = ondemand.ClearFolderSearchFields
        rc = ondemand.SetFolderSearchFieldData("dokumenttypnr", 11, searchvalue, searchvalue)
        rc = ondemand.SearchFolder(False)
        rc = ondemand.GetNumDocsInList(xnumdocs)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.frmPartnerHost_Load Method

Private Sub frmPartnerHost_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerHost_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold.hoststruktur_AfterSelect_1 Method

Private Sub hoststruktur_AfterSelect_1( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles hoststruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hoststruktur_AfterSelect_1(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles hoststruktur.AfterSelect
        Me.DataSet1.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@dokumentartnr", Me.hoststruktur.SelectedNode.Tag)
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@nrpar00", Me.txtnrpar00.Text)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = "dokumenttyp"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerCold Fields

frmPartnerCold overview

Fields

field Button1
field DataSet1
field DomainList
field GroupBox1
field ImageList1
field Partnernr
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field d
field dokumentart
field hd
field hoststruktur
field i
field ondemand
field pw
field rc
field server
field txtnrpar00
field user
field xnumdocs

See Also

frmPartnerCold Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


Partnernr Variable

Friend WithEvents Partnernr As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Partnernr As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


d Variable

Dim d As New DataTable()

Source code

[Visual Basic]
    Dim d As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


hd Variable

Dim hd As New edokadb.clsMyDokumenttyp()

Source code

[Visual Basic]
    Dim hd As New edokadb.clsMyDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


hoststruktur Variable

Friend WithEvents hoststruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents hoststruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


i Variable

Dim i As Long

Source code

[Visual Basic]
    Dim i As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


ondemand Variable

Dim ondemand As Object

Source code

[Visual Basic]
    Dim ondemand As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


pw Variable

Dim pw

Source code

[Visual Basic]
    Dim pw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


rc Variable

Dim rc As Integer

Source code

[Visual Basic]
    Dim rc As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


server Variable

Dim server

Source code

[Visual Basic]
    Dim server

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


txtnrpar00 Variable

Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


user Variable

Dim user

Source code

[Visual Basic]
    Dim user

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


xnumdocs Variable

Dim xnumdocs

Source code

[Visual Basic]
    Dim xnumdocs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerCold


frmPartnerDetails Class

For a list of all members of this type, see frmPartnerDetails Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerDetails

Public Class frmPartnerDetails
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerDetails Members


frmPartnerDetails Members

frmPartnerDetails overview

Constructors

constructor frmPartnerDetails Constructor

Properties

property Partnernr

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method frmPartnerDetails_Closing
method frmPartnerDetails_Load
method get_ma_vip
method vvlist_FetchRowStyle

Fields

field Betreuerlabel
field Button1
field Button2
field GBDatLabel
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field Label1
field Label2
field Label3
field cbVip
field cbmitarbeiter
field cbvi
field cbvsa
field components
field m_partnernr
field mypartner
field partner
field txtBkapr00
field txtInhaber
field txtPartnerEmpfaenger
field txtPartnernr
field txtZusatz
field txtZusteller
field txtsaldiert
field vv
field vvlist

See Also

frmPartnerDetails Class


frmPartnerDetails Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails Properties

frmPartnerDetails overview

Properties

property Partnernr

See Also

frmPartnerDetails Class


frmPartnerDetails.Partnernr Property

Property Partnernr() As Long

Source code

[Visual Basic]
    Property Partnernr() As Long
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As Long)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails Methods

frmPartnerDetails overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method frmPartnerDetails_Closing
method frmPartnerDetails_Load
method get_ma_vip
method vvlist_FetchRowStyle

See Also

frmPartnerDetails Class


frmPartnerDetails.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim f1 As New frmEdokaAdresse()
        f1.Partnernr = Me.Partnernr
        f1.ShowDialog()
        frmPartnerDetails_Load(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerDetails))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.txtPartnernr = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.txtBkapr00 = New System.Windows.Forms.TextBox()
        Me.cbvi = New System.Windows.Forms.CheckBox()
        Me.cbvsa = New System.Windows.Forms.CheckBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.txtPartnerEmpfaenger = New System.Windows.Forms.TextBox()
        Me.txtZusteller = New System.Windows.Forms.RichTextBox()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.txtZusatz = New System.Windows.Forms.RichTextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.txtsaldiert = New System.Windows.Forms.Label()
        Me.vvlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.txtInhaber = New System.Windows.Forms.RichTextBox()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.cbVip = New System.Windows.Forms.CheckBox()
        Me.cbmitarbeiter = New System.Windows.Forms.CheckBox()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.Betreuerlabel = New System.Windows.Forms.Label()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.GBDatLabel = New System.Windows.Forms.Label()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        CType(Me.vvlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.GroupBox7.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        Me.SuspendLayout()
        '
        'txtPartnernr
        '
        Me.txtPartnernr.Location = New System.Drawing.Point(72, 8)
        Me.txtPartnernr.Name = "txtPartnernr"
        Me.txtPartnernr.ReadOnly = True
        Me.txtPartnernr.Size = New System.Drawing.Size(80, 20)
        Me.txtPartnernr.TabIndex = 0
        Me.txtPartnernr.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(64, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Partner-Nr."
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(176, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(64, 23)
        Me.Label2.TabIndex = 3
        Me.Label2.Text = "Kurzname"
        '
        'txtBkapr00
        '
        Me.txtBkapr00.Location = New System.Drawing.Point(232, 8)
        Me.txtBkapr00.Name = "txtBkapr00"
        Me.txtBkapr00.ReadOnly = True
        Me.txtBkapr00.Size = New System.Drawing.Size(208, 20)
        Me.txtBkapr00.TabIndex = 2
        Me.txtBkapr00.Text = "TextBox2"
        '
        'cbvi
        '
        Me.cbvi.Location = New System.Drawing.Point(8, 16)
        Me.cbvi.Name = "cbvi"
        Me.cbvi.TabIndex = 4
        Me.cbvi.Text = "VI beachten"
        '
        'cbvsa
        '
        Me.cbvsa.Location = New System.Drawing.Point(120, 16)
        Me.cbvsa.Name = "cbvsa"
        Me.cbvsa.Size = New System.Drawing.Size(112, 24)
        Me.cbvsa.TabIndex = 5
        Me.cbvsa.Text = "Ad. versandfähig"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label3, Me.txtPartnerEmpfaenger, Me.txtZusteller})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 224)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(248, 176)
        Me.GroupBox2.TabIndex = 7
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Zustell-Adresse (VI auf Ebene Partner)"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 144)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(120, 23)
        Me.Label3.TabIndex = 3
        Me.Label3.Text = "Partner-Nr. Empfänger"
        '
        'txtPartnerEmpfaenger
        '
        Me.txtPartnerEmpfaenger.Location = New System.Drawing.Point(128, 144)
        Me.txtPartnerEmpfaenger.Name = "txtPartnerEmpfaenger"
        Me.txtPartnerEmpfaenger.ReadOnly = True
        Me.txtPartnerEmpfaenger.Size = New System.Drawing.Size(112, 20)
        Me.txtPartnerEmpfaenger.TabIndex = 2
        Me.txtPartnerEmpfaenger.Text = "TextBox3"
        '
        'txtZusteller
        '
        Me.txtZusteller.Dock = System.Windows.Forms.DockStyle.Top
        Me.txtZusteller.Location = New System.Drawing.Point(3, 16)
        Me.txtZusteller.Name = "txtZusteller"
        Me.txtZusteller.ReadOnly = True
        Me.txtZusteller.Size = New System.Drawing.Size(242, 120)
        Me.txtZusteller.TabIndex = 0
        Me.txtZusteller.Text = ""
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtZusatz})
        Me.GroupBox3.Location = New System.Drawing.Point(272, 384)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(248, 24)
        Me.GroupBox3.TabIndex = 8
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "EDOKA-Zustelladresse"
        Me.GroupBox3.Visible = False
        '
        'txtZusatz
        '
        Me.txtZusatz.Location = New System.Drawing.Point(8, 16)
        Me.txtZusatz.Name = "txtZusatz"
        Me.txtZusatz.ReadOnly = True
        Me.txtZusatz.Size = New System.Drawing.Size(232, 152)
        Me.txtZusatz.TabIndex = 0
        Me.txtZusatz.Text = "1"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(440, 464)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 10
        Me.Button1.Text = "Schliessen"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(8, 464)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(144, 23)
        Me.Button2.TabIndex = 11
        Me.Button2.Text = "Zustelladresse bearbeiten"
        Me.Button2.Visible = False
        '
        'txtsaldiert
        '
        Me.txtsaldiert.Font = New System.Drawing.Font("Microsoft Sans Serif", 12.0!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.txtsaldiert.ForeColor = System.Drawing.Color.Red
        Me.txtsaldiert.Location = New System.Drawing.Point(216, 464)
        Me.txtsaldiert.Name = "txtsaldiert"
        Me.txtsaldiert.Size = New System.Drawing.Size(168, 23)
        Me.txtsaldiert.TabIndex = 12
        Me.txtsaldiert.Text = "Partner saldiert!"
        '
        'vvlist
        '
        Me.vvlist.AllowFilter = True
        Me.vvlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.vvlist.AllowSort = True
        Me.vvlist.AlternatingRows = True
        Me.vvlist.CaptionHeight = 17
        Me.vvlist.CollapseColor = System.Drawing.Color.Black
        Me.vvlist.ColumnHeaders = False
        Me.vvlist.DataChanged = False
        Me.vvlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.vvlist.ExpandColor = System.Drawing.Color.Black
        Me.vvlist.FetchRowStyles = True
        Me.vvlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.vvlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.vvlist.Location = New System.Drawing.Point(8, 16)
        Me.vvlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.vvlist.Name = "vvlist"
        Me.vvlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.vvlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.vvlist.PreviewInfo.ZoomFactor = 75
        Me.vvlist.PrintInfo.ShowOptionsDialog = False
        Me.vvlist.RecordSelectors = False
        Me.vvlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.vvlist.RowDivider = GridLines1
        Me.vvlist.RowHeight = 15
        Me.vvlist.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.vvlist.ScrollTips = False
        Me.vvlist.Size = New System.Drawing.Size(240, 304)
        Me.vvlist.TabIndex = 13
        Me.vvlist.Text = "C1TrueDBGrid1"
        Me.vvlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView HBarStyle=""None"" Name="""" Altern" & _
        "atingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHei" & _
        "ght=""17"" FetchRowStyles=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" RecordSelectors=""False"" VerticalScrollGroup=""1"" Hori" & _
        "zontalScrollGroup=""1""><ClientRect>0, 0, 236, 300</ClientRect><BorderSide>0</Bord" & _
        "erSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor""" & _
        " me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle pare" & _
        "nt=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupS" & _
        "tyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" />" & _
        "<HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""In" & _
        "active"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelector" & _
        "Style parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me" & _
        "=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView" & _
        "></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=" & _
        """Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Ca" & _
        "ption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Sele" & _
        "cted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highligh" & _
        "tRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow""" & _
        " /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filt" & _
        "erBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertS" & _
        "plits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Def" & _
        "aultRecSelWidth><ClientArea>0, 0, 236, 300</ClientArea></Blob>"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtInhaber})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 80)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(248, 144)
        Me.GroupBox1.TabIndex = 6
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Inhaber-Adresse"
        '
        'txtInhaber
        '
        Me.txtInhaber.Dock = System.Windows.Forms.DockStyle.Fill
        Me.txtInhaber.Location = New System.Drawing.Point(3, 16)
        Me.txtInhaber.Name = "txtInhaber"
        Me.txtInhaber.ReadOnly = True
        Me.txtInhaber.Size = New System.Drawing.Size(242, 125)
        Me.txtInhaber.TabIndex = 1
        Me.txtInhaber.Text = "1"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.vvlist})
        Me.GroupBox4.Location = New System.Drawing.Point(264, 128)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(256, 328)
        Me.GroupBox4.TabIndex = 14
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Vorhandene VV's"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbVip, Me.cbmitarbeiter})
        Me.GroupBox5.Location = New System.Drawing.Point(264, 80)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(256, 48)
        Me.GroupBox5.TabIndex = 15
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Mitarbeiter/VIP"
        '
        'cbVip
        '
        Me.cbVip.Location = New System.Drawing.Point(160, 16)
        Me.cbVip.Name = "cbVip"
        Me.cbVip.Size = New System.Drawing.Size(80, 24)
        Me.cbVip.TabIndex = 18
        Me.cbVip.Text = "VIP"
        '
        'cbmitarbeiter
        '
        Me.cbmitarbeiter.Location = New System.Drawing.Point(8, 16)
        Me.cbmitarbeiter.Name = "cbmitarbeiter"
        Me.cbmitarbeiter.Size = New System.Drawing.Size(144, 24)
        Me.cbmitarbeiter.TabIndex = 17
        Me.cbmitarbeiter.Text = "Mitarbeiter/Angehöriger"
        '
        'GroupBox6
        '
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbvsa, Me.cbvi})
        Me.GroupBox6.Location = New System.Drawing.Point(8, 408)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(248, 48)
        Me.GroupBox6.TabIndex = 16
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Versandinstruktion"
        '
        'GroupBox7
        '
        Me.GroupBox7.Controls.AddRange(New System.Windows.Forms.Control() {Me.Betreuerlabel})
        Me.GroupBox7.Location = New System.Drawing.Point(264, 40)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(256, 40)
        Me.GroupBox7.TabIndex = 17
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Betreuer"
        '
        'Betreuerlabel
        '
        Me.Betreuerlabel.Location = New System.Drawing.Point(8, 14)
        Me.Betreuerlabel.Name = "Betreuerlabel"
        Me.Betreuerlabel.Size = New System.Drawing.Size(240, 23)
        Me.Betreuerlabel.TabIndex = 0
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.GBDatLabel})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 40)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(248, 40)
        Me.GroupBox8.TabIndex = 18
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Geburtsdatum"
        '
        'GBDatLabel
        '
        Me.GBDatLabel.Location = New System.Drawing.Point(8, 14)
        Me.GBDatLabel.Name = "GBDatLabel"
        Me.GBDatLabel.Size = New System.Drawing.Size(200, 23)
        Me.GBDatLabel.TabIndex = 0
        '
        'frmPartnerDetails
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(528, 495)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.GroupBox8, Me.GroupBox7, Me.GroupBox6, Me.GroupBox5, Me.GroupBox4, Me.txtsaldiert, Me.Button2, Me.Button1, Me.GroupBox3, Me.GroupBox2, Me.txtBkapr00, Me.Label1, Me.txtPartnernr, Me.Label2})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPartnerDetails"
        Me.Text = "Partner-Details"
        Me.TopMost = True
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        CType(Me.vvlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        Me.GroupBox6.ResumeLayout(False)
        Me.GroupBox7.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.frmPartnerDetails_Closing Method

Private Sub frmPartnerDetails_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerDetails_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        partner.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.frmPartnerDetails_Load Method

Private Sub frmPartnerDetails_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerDetails_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Cursor = Cursors.WaitCursor
        Dim s As String
        Dim s1 As String
        Dim s2 As String
        Dim s3 As String
        Dim s4 As String
        Me.Betreuerlabel.Text = ""
        partner = mypartner.Partner_Detail(Me.Partnernr)
        vv = mypartner.Partner_VV(Me.Partnernr)
        Me.txtPartnernr.Text = partner.Rows(0).Item("nrpar00")
        Me.txtBkapr00.Text = partner.Rows(0).Item("bkpar00")
        Me.txtPartnerEmpfaenger.Text = partner.Rows(0).Item("nrparad")

        Me.Betreuerlabel.Text = mypartner.Partner_Betreuer(Me.Partnernr)
        Try
            Me.GBDatLabel.Text = mypartner.Partner_Gebdat(Me.Partnernr)
            If Me.GBDatLabel.Text = "" Then Me.GroupBox8.Visible = False Else Me.GroupBox8.Visible = True
        Catch
            Me.GroupBox8.Visible = False
        End Try

        If partner.Rows(0).Item("cdvig00") = "Y" Then
            Me.cbvi.Checked = True
        Else
            '            Me.cbvi.Checked = False
        End If
        If partner.Rows(0).Item("azepl00") > 1 Then
            Me.cbvi.Checked = True
        Else
            '           Me.cbvi.Checked = False
        End If
        If partner.Rows(0).Item("cdvsa00") = True Then
            Me.cbvi.Checked = True
        Else
            '            Me.cbvi.Checked = False
        End If

        Try
            If partner.Rows(0).Item("SAVRS00") = "Y" Then
                Me.cbvsa.Checked = True
            Else
                Me.cbvsa.Checked = False
            End If
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
        If partner.Rows(0).Item("saldiert") = True Then
            Me.txtsaldiert.Visible = True
        Else
            Me.txtsaldiert.Visible = False
        End If
        s = ""
        s1 = ""
        s2 = ""
        s = s + partner.Rows(0).Item("txadz012") + vbCrLf
        s = s + partner.Rows(0).Item("txadz022") + vbCrLf
        s = s + partner.Rows(0).Item("txadz032") + vbCrLf
        s = s + partner.Rows(0).Item("txadz042") + vbCrLf
        s = s + partner.Rows(0).Item("txadz052") + vbCrLf
        s = s + partner.Rows(0).Item("txadz062") + vbCrLf
        s = s + partner.Rows(0).Item("txadz072") + vbCrLf
        s3 = ""
        s3 = s3 + partner.Rows(0).Item("txadz012")
        s3 = s3 + partner.Rows(0).Item("txadz022")
        s3 = s3 + partner.Rows(0).Item("txadz032")
        s3 = s3 + partner.Rows(0).Item("txadz042")
        s3 = s3 + partner.Rows(0).Item("txadz052")
        s3 = s3 + partner.Rows(0).Item("txadz062")
        s3 = s3 + partner.Rows(0).Item("txadz072")

        s1 = s1 + partner.Rows(0).Item("txadz011") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz021") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz031") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz041") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz051") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz061") + vbCrLf
        s1 = s1 + partner.Rows(0).Item("txadz071") + vbCrLf
        s4 = ""
        s4 = s4 + partner.Rows(0).Item("txadz011")
        s4 = s4 + partner.Rows(0).Item("txadz021")
        s4 = s4 + partner.Rows(0).Item("txadz031")
        s4 = s4 + partner.Rows(0).Item("txadz041")
        s4 = s4 + partner.Rows(0).Item("txadz051")
        s4 = s4 + partner.Rows(0).Item("txadz061")
        s4 = s4 + partner.Rows(0).Item("txadz071")

        get_ma_vip()

        'If Not (partner.Rows(0).Item("adresszeile1") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile1") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile1") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile2") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile2") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile2") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile3") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile3") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile3") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile4") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile4") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile4") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile5") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile5") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile5") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile6") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile6") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile6") + vbCrLf
        'End If
        'If Not (partner.Rows(0).Item("adresszeile7") Is System.DBNull.Value) And Not (partner.Rows(0).Item("adresszeile7") = "") Then
        's2 = s2 + partner.Rows(0).Item("adresszeile7") + vbCrLf
        'End If

        If Val(Me.txtPartnerEmpfaenger.Text) <> Val(Me.txtPartnernr.Text) Then
            Me.txtInhaber.Text = s
            Me.txtZusteller.Text = s1
        Else
            Me.txtInhaber.Text = s1
            Me.txtZusteller.Text = ""
            Me.txtPartnerEmpfaenger.Text = ""
        End If

        If Trim(s3) <> Trim(s4) And Trim(s3) <> "" Then
            Me.txtInhaber.Text = s
            Me.txtZusteller.Text = s1
        Else
            Me.txtInhaber.Text = Trim(s1)
        End If
        Me.txtZusatz.Text = s2

        Me.vvlist.DataSource = Nothing
        Me.vvlist.DataMember = Nothing
        Me.vvlist.DataSource = Me.vv
        Me.vvlist.DataMember = "vv"
        Me.vvlist.Splits(0).DisplayColumns(1).Width = 140
        Me.vvlist.Splits(0).DisplayColumns(2).Visible = False
        Me.vvlist.Splits(0).DisplayColumns(3).Visible = False
        Me.Cursor = Cursors.Default
        Dim i As Integer
        For i = 0 To Me.vvlist.Columns.Count - 1
            If UCase(Me.vvlist.Columns(i).Caption) = "SAREC00" Then
                Me.vvlist.Splits(0).DisplayColumns(i).Visible = False
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.get_ma_vip Method

Private Sub get_ma_vip()

Source code

[Visual Basic]
    Private Sub get_ma_vip()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_ma_vip"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Partnernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@ma", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vip", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@ma").Value > 0 Then Me.cbmitarbeiter.Checked = True Else Me.cbmitarbeiter.Checked = False
            If scmCmdToExecute.Parameters("@vip").Value > 0 Then Me.cbVip.Checked = True Else Me.cbVip.Checked = False
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails.vvlist_FetchRowStyle Method

Private Sub vvlist_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles vvlist.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vvlist_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles vvlist.FetchRowStyle
        If Me.vvlist.Columns("sarec00").CellValue(e.Row) <> 2 Then
            Dim FNT As Font = e.CellStyle.Font
            e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerDetails Fields

frmPartnerDetails overview

Fields

field Betreuerlabel
field Button1
field Button2
field GBDatLabel
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field Label1
field Label2
field Label3
field cbVip
field cbmitarbeiter
field cbvi
field cbvsa
field components
field m_partnernr
field mypartner
field partner
field txtBkapr00
field txtInhaber
field txtPartnerEmpfaenger
field txtPartnernr
field txtZusatz
field txtZusteller
field txtsaldiert
field vv
field vvlist

See Also

frmPartnerDetails Class


Betreuerlabel Variable

Friend WithEvents Betreuerlabel As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Betreuerlabel As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GBDatLabel Variable

Friend WithEvents GBDatLabel As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents GBDatLabel As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


cbVip Variable

Friend WithEvents cbVip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbVip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


cbmitarbeiter Variable

Friend WithEvents cbmitarbeiter As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbmitarbeiter As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


cbvi Variable

Friend WithEvents cbvi As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbvi As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


cbvsa Variable

Friend WithEvents cbvsa As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbvsa As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


m_partnernr Variable

Dim m_partnernr As Long

Source code

[Visual Basic]
    Dim m_partnernr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


mypartner Variable

Dim mypartner As New edokaDB.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokaDB.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


partner Variable

Dim partner As DataTable

Source code

[Visual Basic]
    Dim partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtBkapr00 Variable

Friend WithEvents txtBkapr00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBkapr00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtInhaber Variable

Friend WithEvents txtInhaber As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents txtInhaber As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtPartnerEmpfaenger Variable

Friend WithEvents txtPartnerEmpfaenger As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnerEmpfaenger As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtPartnernr Variable

Friend WithEvents txtPartnernr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartnernr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtZusatz Variable

Friend WithEvents txtZusatz As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents txtZusatz As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtZusteller Variable

Friend WithEvents txtZusteller As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents txtZusteller As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


txtsaldiert Variable

Friend WithEvents txtsaldiert As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtsaldiert As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


vv Variable

Dim vv As DataTable

Source code

[Visual Basic]
    Dim vv As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


vvlist Variable

Friend WithEvents vvlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents vvlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerDetails


frmPartnerHost Class

For a list of all members of this type, see frmPartnerHost Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerHost

Public Class frmPartnerHost
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerHost Members


frmPartnerHost Members

frmPartnerHost overview

Constructors

constructor frmPartnerHost Constructor

Methods

method Button1_Click_1
method Dispose
method InitializeComponent
method frmPartnerHost_Load
method hoststruktur_AfterSelect_1

Fields

field Button1
field DataSet1
field DomainList
field GroupBox1
field ImageList1
field Partnernr
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field dokumentart
field hoststruktur
field txtnrpar00

See Also

frmPartnerHost Class


frmPartnerHost Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost Methods

frmPartnerHost overview

Methods

method Button1_Click_1
method Dispose
method InitializeComponent
method frmPartnerHost_Load
method hoststruktur_AfterSelect_1

See Also

frmPartnerHost Class


frmPartnerHost.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim s As String
        s = Me.txtnrpar00.Text
        While Len(s) < 9
            s = "0" + s
        End While
        dokumentart.LoadHostTree(Me.hoststruktur, s)
        Me.hoststruktur.ExpandAll()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerHost))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Partnernr = New System.Windows.Forms.Label()
        Me.txtnrpar00 = New System.Windows.Forms.TextBox()
        Me.hoststruktur = New System.Windows.Forms.TreeView()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DomainList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GroupBox1.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Partnernr, Me.txtnrpar00})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(760, 48)
        Me.GroupBox1.TabIndex = 4
        Me.GroupBox1.TabStop = False
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(192, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(72, 24)
        Me.Button1.TabIndex = 6
        Me.Button1.Text = "Select"
        '
        'Partnernr
        '
        Me.Partnernr.Location = New System.Drawing.Point(8, 16)
        Me.Partnernr.Name = "Partnernr"
        Me.Partnernr.Size = New System.Drawing.Size(56, 23)
        Me.Partnernr.TabIndex = 5
        Me.Partnernr.Text = "Partnernr"
        '
        'txtnrpar00
        '
        Me.txtnrpar00.Location = New System.Drawing.Point(64, 16)
        Me.txtnrpar00.Name = "txtnrpar00"
        Me.txtnrpar00.Size = New System.Drawing.Size(128, 20)
        Me.txtnrpar00.TabIndex = 4
        Me.txtnrpar00.Text = ""
        '
        'hoststruktur
        '
        Me.hoststruktur.Dock = System.Windows.Forms.DockStyle.Left
        Me.hoststruktur.Location = New System.Drawing.Point(0, 48)
        Me.hoststruktur.Name = "hoststruktur"
        Me.hoststruktur.Size = New System.Drawing.Size(272, 533)
        Me.hoststruktur.TabIndex = 5
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[xx_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[xx_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_partner_hostdokumente_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@nrpar00", System.Data.SqlDbType.VarChar, 9))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[xx_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DomainList
        '
        Me.DomainList.AllowFilter = True
        Me.DomainList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DomainList.AllowSort = True
        Me.DomainList.AllowUpdate = False
        Me.DomainList.AlternatingRows = True
        Me.DomainList.CaptionHeight = 17
        Me.DomainList.CollapseColor = System.Drawing.Color.Black
        Me.DomainList.DataChanged = False
        Me.DomainList.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.DomainList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DomainList.ExpandColor = System.Drawing.Color.Black
        Me.DomainList.FilterBar = True
        Me.DomainList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DomainList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DomainList.Location = New System.Drawing.Point(272, 48)
        Me.DomainList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DomainList.Name = "DomainList"
        Me.DomainList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DomainList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DomainList.PreviewInfo.ZoomFactor = 75
        Me.DomainList.PrintInfo.ShowOptionsDialog = False
        Me.DomainList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DomainList.RowDivider = GridLines1
        Me.DomainList.RowHeight = 15
        Me.DomainList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DomainList.ScrollTips = False
        Me.DomainList.Size = New System.Drawing.Size(488, 533)
        Me.DomainList.TabIndex = 7
        Me.DomainList.Text = "C1TrueDBGrid1"
        Me.DomainList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWi" & _
        "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
        "ClientRect>0, 0, 484, 529</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
        "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
        "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
        "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
        """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
        "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
        "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
        "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
        "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
        "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
        "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
        """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
        "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
        "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
        "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
        """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
        "rzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 484, 529</ClientArea></Blob>"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmPartnerHost
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(760, 581)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DomainList, Me.hoststruktur, Me.GroupBox1})
        Me.Name = "frmPartnerHost"
        Me.Text = "frmPartnerHost"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DomainList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost.frmPartnerHost_Load Method

Private Sub frmPartnerHost_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerHost_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost.hoststruktur_AfterSelect_1 Method

Private Sub hoststruktur_AfterSelect_1( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles hoststruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hoststruktur_AfterSelect_1(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles hoststruktur.AfterSelect

        Me.DataSet1.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@dokumentartnr", Me.hoststruktur.SelectedNode.Tag)
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@nrpar00", Me.txtnrpar00.Text)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = "dokumenttyp"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerHost Fields

frmPartnerHost overview

Fields

field Button1
field DataSet1
field DomainList
field GroupBox1
field ImageList1
field Partnernr
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field components
field dokumentart
field hoststruktur
field txtnrpar00

See Also

frmPartnerHost Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


DomainList Variable

Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DomainList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


Partnernr Variable

Friend WithEvents Partnernr As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Partnernr As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


hoststruktur Variable

Friend WithEvents hoststruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents hoststruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


txtnrpar00 Variable

Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerHost


frmPartnerInfo Class

For a list of all members of this type, see frmPartnerInfo Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerInfo

Public Class frmPartnerInfo
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerInfo Members


frmPartnerInfo Members

frmPartnerInfo overview

Constructors

constructor frmPartnerInfo Constructor

Methods

method Dispose
method InitializeComponent
method RichTextBox1_TextChanged

Fields

field RichTextBox1
field components

See Also

frmPartnerInfo Class


frmPartnerInfo Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


frmPartnerInfo Methods

frmPartnerInfo overview

Methods

method Dispose
method InitializeComponent
method RichTextBox1_TextChanged

See Also

frmPartnerInfo Class


frmPartnerInfo.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


frmPartnerInfo.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.RichTextBox1 = New System.Windows.Forms.RichTextBox()
        Me.SuspendLayout()
        '
        'RichTextBox1
        '
        Me.RichTextBox1.Location = New System.Drawing.Point(8, 8)
        Me.RichTextBox1.Name = "RichTextBox1"
        Me.RichTextBox1.Size = New System.Drawing.Size(776, 608)
        Me.RichTextBox1.TabIndex = 0
        Me.RichTextBox1.Text = ""
        '
        'frmPartnerInfo
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(792, 654)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBox1})
        Me.Name = "frmPartnerInfo"
        Me.Text = "frmPartnerInfo"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


frmPartnerInfo.RichTextBox1_TextChanged Method

Private Sub RichTextBox1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RichTextBox1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RichTextBox1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RichTextBox1.TextChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


frmPartnerInfo Fields

frmPartnerInfo overview

Fields

field RichTextBox1
field components

See Also

frmPartnerInfo Class


RichTextBox1 Variable

Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerInfo


frmPartnerlisteLaden Class

For a list of all members of this type, see frmPartnerlisteLaden Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerlisteLaden

Public Class frmPartnerlisteLaden
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerlisteLaden Members


frmPartnerlisteLaden Members

frmPartnerlisteLaden overview

Constructors

constructor frmPartnerlisteLaden Constructor

Properties

property PartnerListeNr

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method Load_Partnerlist
method Load_Partnerlisten
method frmPartnerlisteLaden_Load
method partnerlist_RowColChange

Fields

field Beschreibung
field Button1
field Button2
field Panel1
field TextBox1
field components
field m_partnerlistenr
field partnerlist

See Also

frmPartnerlisteLaden Class


frmPartnerlisteLaden Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden Properties

frmPartnerlisteLaden overview

Properties

property PartnerListeNr

See Also

frmPartnerlisteLaden Class


frmPartnerlisteLaden.PartnerListeNr Property

Property PartnerListeNr() As Integer

Source code

[Visual Basic]
    Property PartnerListeNr() As Integer
        Get
            Return m_partnerlistenr
        End Get
        Set(ByVal Value As Integer)
            m_partnerlistenr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden Methods

frmPartnerlisteLaden overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method Load_Partnerlist
method Load_Partnerlisten
method frmPartnerlisteLaden_Load
method partnerlist_RowColChange

See Also

frmPartnerlisteLaden Class


frmPartnerlisteLaden.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.PartnerListeNr = Me.partnerlist.Columns(0).Text
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerlisteLaden))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.partnerlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Beschreibung = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Panel1.SuspendLayout()
        CType(Me.partnerlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Panel1
        '
        Me.Panel1.BackColor = System.Drawing.SystemColors.Control
        Me.Panel1.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.partnerlist})
        Me.Panel1.Location = New System.Drawing.Point(8, 8)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(416, 136)
        Me.Panel1.TabIndex = 49
        '
        'partnerlist
        '
        Me.partnerlist.AllowFilter = True
        Me.partnerlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.partnerlist.AllowSort = True
        Me.partnerlist.AlternatingRows = True
        Me.partnerlist.CaptionHeight = 17
        Me.partnerlist.CollapseColor = System.Drawing.Color.Black
        Me.partnerlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.partnerlist.DataChanged = False
        Me.partnerlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.partnerlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.partnerlist.ExpandColor = System.Drawing.Color.Black
        Me.partnerlist.FetchRowStyles = True
        Me.partnerlist.FilterBar = True
        Me.partnerlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.partnerlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.partnerlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.partnerlist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.partnerlist.Name = "partnerlist"
        Me.partnerlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.partnerlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.partnerlist.PreviewInfo.ZoomFactor = 75
        Me.partnerlist.PrintInfo.ShowOptionsDialog = False
        Me.partnerlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.partnerlist.RowDivider = GridLines1
        Me.partnerlist.RowHeight = 15
        Me.partnerlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.partnerlist.ScrollTips = True
        Me.partnerlist.Size = New System.Drawing.Size(412, 132)
        Me.partnerlist.TabIndex = 28
        Me.partnerlist.Text = "C1TrueDBGrid1"
        Me.partnerlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 408," & _
        " 128</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 408, " & _
        "128</ClientArea></Blob>"
        '
        'Beschreibung
        '
        Me.Beschreibung.Location = New System.Drawing.Point(8, 152)
        Me.Beschreibung.Name = "Beschreibung"
        Me.Beschreibung.Size = New System.Drawing.Size(80, 16)
        Me.Beschreibung.TabIndex = 50
        Me.Beschreibung.Text = "Beschreibung"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 152)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(336, 80)
        Me.TextBox1.TabIndex = 51
        Me.TextBox1.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 248)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(80, 23)
        Me.Button1.TabIndex = 52
        Me.Button1.Text = "Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(344, 248)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(80, 23)
        Me.Button2.TabIndex = 53
        Me.Button2.Text = "Übernehmen"
        '
        'frmPartnerlisteLaden
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(432, 277)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.TextBox1, Me.Beschreibung, Me.Panel1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPartnerlisteLaden"
        Me.Text = "Partnerliste laden"
        Me.Panel1.ResumeLayout(False)
        CType(Me.partnerlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.Load_Partnerlist Method

Public Function Load_Partnerlist() As String

Source code

[Visual Basic]
    Public Function Load_Partnerlist() As String
        Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.PartnerListeNr.ToString + "_Partnerlist.xml"
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From edex_sb_partnerliste where partnerlistenr=" + Me.PartnerListeNr.ToString, connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()

        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(9)
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return dokumentname
        Catch ex As Exception
            Return ""
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.Load_Partnerlisten Method

Private Function Load_Partnerlisten() As DataTable

Source code

[Visual Basic]
    Private Function Load_Partnerlisten() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_partnerlisten"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@manr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("dbo.sp_edex_sb_get_partnerlisten::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.frmPartnerlisteLaden_Load Method

Private Sub frmPartnerlisteLaden_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerlisteLaden_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim dt As New DataTable()
        dt = Load_Partnerlisten()
        If dt.Rows.Count = 0 Then Me.Button2.Enabled = False
        Me.partnerlist.DataSource = dt
        Me.partnerlist.DataMember = dt.TableName
        Me.partnerlist.Splits(0).DisplayColumns(3).Visible = False
        Me.partnerlist.Bookmark = 0
        Me.partnerlist.Splits(0).DisplayColumns("Nr").Visible = False
        Me.partnerlist.Splits(0).DisplayColumns("Bezeichnung").AutoSize()
        Me.partnerlist.Splits(0).DisplayColumns("Zuständig").AutoSize()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden.partnerlist_RowColChange Method

Private Sub partnerlist_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles partnerlist.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub partnerlist_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles partnerlist.RowColChange
        Me.TextBox1.Text = Me.partnerlist.Columns(3).Text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteLaden Fields

frmPartnerlisteLaden overview

Fields

field Beschreibung
field Button1
field Button2
field Panel1
field TextBox1
field components
field m_partnerlistenr
field partnerlist

See Also

frmPartnerlisteLaden Class


Beschreibung Variable

Friend WithEvents Beschreibung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Beschreibung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


m_partnerlistenr Variable

Dim m_partnerlistenr As Integer

Source code

[Visual Basic]
    Dim m_partnerlistenr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


partnerlist Variable

Friend WithEvents partnerlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents partnerlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteLaden


frmPartnerlisteSpeichern Class

For a list of all members of this type, see frmPartnerlisteSpeichern Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerlisteSpeichern

Public Class frmPartnerlisteSpeichern
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerlisteSpeichern Members


frmPartnerlisteSpeichern Members

frmPartnerlisteSpeichern overview

Constructors

constructor frmPartnerlisteSpeichern Constructor (Overloaded)

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method RadioButton6_CheckedChanged
method frmPartnerlisteSpeichern_Load
method load_funktionen
method save_partner

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field Label3
field RadioButton1
field RadioButton2
field RadioButton3
field RadioButton4
field RadioButton5
field RadioButton6
field TextBox1
field TextBox2
field components
field dsempfaenger
field empfaenger
field mcbfunktionen

See Also

frmPartnerlisteSpeichern Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal dt As DataTable)

See Also

frmPartnerlisteSpeichern | EDOKAApp


frmPartnerlisteSpeichern Methods

frmPartnerlisteSpeichern overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method RadioButton6_CheckedChanged
method frmPartnerlisteSpeichern_Load
method load_funktionen
method save_partner

See Also

frmPartnerlisteSpeichern Class


frmPartnerlisteSpeichern.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        If Me.TextBox1.Text = "" Then
            MyMsg.show_standardmessage(714, MsgBoxStyle.Critical)
            Exit Sub
        End If
        Dim pl As New edokadb.clsEdex_sb_partnerliste()
        pl.cpMainConnectionProvider = Globals.conn
        pl.sBezeichnung = New SqlString(CType(Me.TextBox1.Text, String))
        pl.sBeschreibung = New SqlString(CType(Me.TextBox2.Text, String))
        Dim i As Integer
        If Me.RadioButton1.Checked Then i = 1
        If Me.RadioButton2.Checked Then i = 2
        If Me.RadioButton3.Checked Then i = 3
        If Me.RadioButton4.Checked Then i = 4
        If Me.RadioButton5.Checked Then i = 5
        If Me.RadioButton6.Checked Then i = 6
        If Me.RadioButton6.Checked Then
            pl.iVerwendungcd = New SqlInt32(CType(Me.mcbfunktionen.SelectedValue, Int32))
        Else
            pl.iVerwendungcd = New SqlInt32(CType(0, Int32))
        End If
        pl.iVerwendung = New SqlInt32(CType(i, Int32))
        pl.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        pl.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        pl.bAktiv = New SqlBoolean(CType(True, Boolean))
        pl.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        Globals.conn.OpenConnection()
        pl.Insert()
        Globals.conn.CloseConnection(True)
        save_partner(pl.iPartnerlistenr.Value)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerlisteSpeichern))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.RadioButton5 = New System.Windows.Forms.RadioButton()
        Me.RadioButton4 = New System.Windows.Forms.RadioButton()
        Me.RadioButton3 = New System.Windows.Forms.RadioButton()
        Me.RadioButton2 = New System.Windows.Forms.RadioButton()
        Me.RadioButton1 = New System.Windows.Forms.RadioButton()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.RadioButton6 = New System.Windows.Forms.RadioButton()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(56, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Name"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(96, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(240, 20)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 272)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(72, 24)
        Me.Button1.TabIndex = 8
        Me.Button1.Text = "Abbruch"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(96, 40)
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(240, 96)
        Me.TextBox2.TabIndex = 9
        Me.TextBox2.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(80, 23)
        Me.Label2.TabIndex = 10
        Me.Label2.Text = "Beschreibung"
        '
        'RadioButton5
        '
        Me.RadioButton5.Location = New System.Drawing.Point(96, 210)
        Me.RadioButton5.Name = "RadioButton5"
        Me.RadioButton5.Size = New System.Drawing.Size(80, 24)
        Me.RadioButton5.TabIndex = 16
        Me.RadioButton5.Text = "Persönlich"
        '
        'RadioButton4
        '
        Me.RadioButton4.Location = New System.Drawing.Point(96, 194)
        Me.RadioButton4.Name = "RadioButton4"
        Me.RadioButton4.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton4.TabIndex = 15
        Me.RadioButton4.Text = "Team"
        '
        'RadioButton3
        '
        Me.RadioButton3.Location = New System.Drawing.Point(96, 178)
        Me.RadioButton3.Name = "RadioButton3"
        Me.RadioButton3.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton3.TabIndex = 14
        Me.RadioButton3.Text = "Kostenstelle"
        '
        'RadioButton2
        '
        Me.RadioButton2.Location = New System.Drawing.Point(96, 160)
        Me.RadioButton2.Name = "RadioButton2"
        Me.RadioButton2.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton2.TabIndex = 13
        Me.RadioButton2.Text = "Niederlassung"
        '
        'RadioButton1
        '
        Me.RadioButton1.Location = New System.Drawing.Point(96, 144)
        Me.RadioButton1.Name = "RadioButton1"
        Me.RadioButton1.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton1.TabIndex = 12
        Me.RadioButton1.Text = "Marktbereich"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 144)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 32)
        Me.Label3.TabIndex = 17
        Me.Label3.Text = "Verwendung durch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(264, 272)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(72, 24)
        Me.Button2.TabIndex = 18
        Me.Button2.Text = "Speichern"
        '
        'RadioButton6
        '
        Me.RadioButton6.Location = New System.Drawing.Point(96, 226)
        Me.RadioButton6.Name = "RadioButton6"
        Me.RadioButton6.Size = New System.Drawing.Size(80, 24)
        Me.RadioButton6.TabIndex = 19
        Me.RadioButton6.Text = "Funktion"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(176, 228)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(160, 21)
        Me.ComboBox1.TabIndex = 20
        '
        'frmPartnerlisteSpeichern
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(344, 301)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.RadioButton2, Me.ComboBox1, Me.RadioButton6, Me.Button2, Me.Label3, Me.RadioButton5, Me.RadioButton4, Me.RadioButton3, Me.RadioButton1, Me.Label2, Me.TextBox2, Me.Button1, Me.TextBox1, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPartnerlisteSpeichern"
        Me.Text = "Partnerliste speichern"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.RadioButton6_CheckedChanged Method

Private Sub RadioButton6_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RadioButton6.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RadioButton6_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RadioButton6.CheckedChanged
        If Me.RadioButton6.Checked = True Then Me.mcbfunktionen.Enabled = True Else Me.mcbfunktionen.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.frmPartnerlisteSpeichern_Load Method

Private Sub frmPartnerlisteSpeichern_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerlisteSpeichern_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.RadioButton1.Checked = True
        Me.ComboBox1.Enabled = False
        Me.TextBox1.Text = ""
        Me.TextBox2.Text = ""
        mcbfunktionen = New MultiComboBox(Me.ComboBox1)
        mcbfunktionen.DisplayColumnName = "Bezeichnung"
        mcbfunktionen.ValueColumnName = "funktionsgruppenr"
        mcbfunktionen.CheckNullValue = False
        Dim dt As New DataTable()
        dt = load_funktionen()
        mcbfunktionen.Fill_Data(dt, True)
        mcbfunktionen.SelectedIndex = 0
        mcbfunktionen.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.load_funktionen Method

Private Function load_funktionen() As DataTable

Source code

[Visual Basic]
    Private Function load_funktionen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_funktionen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("dbo.sp_edex_sb_get_funktionen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern.save_partner Method

Private Function save_partner( _
   ByVal partnerlistnr As Integer _
) As Boolean

Parameters

partnerlistnr
Required.

Source code

[Visual Basic]
    Private Function save_partner(ByVal partnerlistnr As Integer) As Boolean
        Try
            Dim i As Integer
            While empfaenger.Columns.Count > 11
                empfaenger.Columns.RemoveAt(empfaenger.Columns.Count - 1)
            End While
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + partnerlistnr.ToString + "_Partnerlist.xml"
            Me.dsempfaenger.Tables.Add(Me.empfaenger.Copy)
            Me.dsempfaenger.WriteXml(dokumentname)
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_partnerliste where partnerlistenr=" + partnerlistnr.ToString, Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                myRow.Item(9) = mydata
                DA.Update(ds, "empf")
            Catch ex As Exception
                MyMsg.show_standardmessage(715, MsgBoxStyle.Critical)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            File.Delete(dokumentname)

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(715, MsgBoxStyle.Critical)
            Return False
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern Fields

frmPartnerlisteSpeichern overview

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field Label3
field RadioButton1
field RadioButton2
field RadioButton3
field RadioButton4
field RadioButton5
field RadioButton6
field TextBox1
field TextBox2
field components
field dsempfaenger
field empfaenger
field mcbfunktionen

See Also

frmPartnerlisteSpeichern Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton1 Variable

Friend WithEvents RadioButton1 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton1 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton2 Variable

Friend WithEvents RadioButton2 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton2 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton3 Variable

Friend WithEvents RadioButton3 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton3 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton4 Variable

Friend WithEvents RadioButton4 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton4 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton5 Variable

Friend WithEvents RadioButton5 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton5 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


RadioButton6 Variable

Friend WithEvents RadioButton6 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton6 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


dsempfaenger Variable

Dim dsempfaenger As New DataSet()

Source code

[Visual Basic]
    Dim dsempfaenger As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


empfaenger Variable

Dim empfaenger As New DataTable()

Source code

[Visual Basic]
    Dim empfaenger As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


mcbfunktionen Variable

Dim mcbfunktionen As New MultiComboBox()

Source code

[Visual Basic]
    Dim mcbfunktionen As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteVerwalten Class

For a list of all members of this type, see frmPartnerlisteVerwalten Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerlisteVerwalten

Public Class frmPartnerlisteVerwalten
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerlisteVerwalten Members


frmPartnerlisteVerwalten Members

frmPartnerlisteVerwalten overview

Constructors

constructor frmPartnerlisteVerwalten Constructor

Methods

method BtnHelp_Click
method Dispose
method InitializeComponent
method Load_Partnerlist
method MnuMainEmfpaengerLoeschen_Click
method MnuMainEmpfaengerBearbeiten_Click
method Partner_Details
method RadioButton6_CheckedChanged
method Save_Data
method ToolBar1_ButtonClick
method add_edokahostpartner
method c1mnupartner1_Click
method frmPartnerlisteVerwalten_Load
method load_funktionen
method load_partnerlisten
method mcblisten_SelectedValueChanged
method save_partner

Fields

field BtnHelp
field C1CommandHolder1
field C1CommandLink1
field C1CommandLink11
field C1CommandLink12
field C1CommandLink21
field C1CommandMenu1
field C1ContextMenu1
field C1MnuMainAddColumn
field C1MnuMainDeleteColumn
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuSerienbriefLoeschen
field ComboBox1
field ComboBox2
field CurrentPartnerbezeichnung
field CurrentPartnernr
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field Panel1
field Partnerlist
field RadioButton1
field RadioButton2
field RadioButton3
field RadioButton4
field RadioButton5
field RadioButton6
field TextBox2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field c1mnumainpreview
field c1mnupartner1
field c1mnupartner2
field c1mnupartner3
field components
field dspartner
field mcbfunktionen
field mcblisten
field mnuCTADDEdokapartner
field mnuctAddHost
field mnuctaddempfaenger
field on_load
field pl

See Also

frmPartnerlisteVerwalten Class


frmPartnerlisteVerwalten Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten Methods

frmPartnerlisteVerwalten overview

Methods

method BtnHelp_Click
method Dispose
method InitializeComponent
method Load_Partnerlist
method MnuMainEmfpaengerLoeschen_Click
method MnuMainEmpfaengerBearbeiten_Click
method Partner_Details
method RadioButton6_CheckedChanged
method Save_Data
method ToolBar1_ButtonClick
method add_edokahostpartner
method c1mnupartner1_Click
method frmPartnerlisteVerwalten_Load
method load_funktionen
method load_partnerlisten
method mcblisten_SelectedValueChanged
method save_partner

See Also

frmPartnerlisteVerwalten Class


frmPartnerlisteVerwalten.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("partnerlistenverwalten")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerlisteVerwalten))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RadioButton2 = New System.Windows.Forms.RadioButton()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.RadioButton6 = New System.Windows.Forms.RadioButton()
        Me.RadioButton5 = New System.Windows.Forms.RadioButton()
        Me.RadioButton4 = New System.Windows.Forms.RadioButton()
        Me.RadioButton3 = New System.Windows.Forms.RadioButton()
        Me.RadioButton1 = New System.Windows.Forms.RadioButton()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ComboBox2 = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.Partnerlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.C1CommandHolder1 = New C1.Win.C1Command.C1CommandHolder()
        Me.C1ContextMenu1 = New C1.Win.C1Command.C1ContextMenu()
        Me.C1CommandLink21 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnupartner1 = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink11 = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmpfaengerBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink12 = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmfpaengerLoeschen = New C1.Win.C1Command.C1Command()
        Me.MnuMainDatei = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainNeuerSerienbrief = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainNew = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefLaden = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoad = New C1.Win.C1Command.C1Command()
        Me.C1MnuSerienbriefLoeschen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSerienbriefLoeschen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefabschliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAbschluss = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefSpeichern = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSave = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainFensterSchliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainClose = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokument = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainVorlageImportieren = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorlageImportieren = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainVorlageBearbeiten = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorageBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink1 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnumainpreview = New C1.Win.C1Command.C1Command()
        Me.MnuMainVorschauErstellen = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteGenerieren = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteDrucken = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteBestaetigen = New C1.Win.C1Command.C1Command()
        Me.MnuMainEmpfaengerliste = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainImportEmpfaneger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainImportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainExportEmpfaenger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainExportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainLoadPartnerliste = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoadPartnerliste = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1Command()
        Me.MnuMainAddEDOKAHOSTPartner = New C1.Win.C1Command.C1Command()
        Me.MnuMainNeuerEDOKAPartnerErfassen = New C1.Win.C1Command.C1Command()
        Me.MnuMainNeuerEmpfaengerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1CommandMenu1 = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainAddColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAddColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainDeleteColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDeleteColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainRenameColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainRenameColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSpaltenselektion = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSpaltenselektion = New C1.Win.C1Command.C1Command()
        Me.MnuMainCheckEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.mnuctAddHost = New C1.Win.C1Command.C1Command()
        Me.mnuCTADDEdokapartner = New C1.Win.C1Command.C1Command()
        Me.mnuctaddempfaenger = New C1.Win.C1Command.C1Command()
        Me.c1mnupartner2 = New C1.Win.C1Command.C1Command()
        Me.c1mnupartner3 = New C1.Win.C1Command.C1Command()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        Me.Panel1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        CType(Me.Partnerlist, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3})
        Me.C1CommandHolder1.SetC1ContextMenu(Me.ToolBar1, Nothing)
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(904, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 28
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        '
        'GroupBox1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox1, Nothing)
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RadioButton2, Me.ComboBox1, Me.RadioButton6, Me.RadioButton5, Me.RadioButton4, Me.RadioButton3, Me.RadioButton1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 216)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(288, 152)
        Me.GroupBox1.TabIndex = 1
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Verwendung durch"
        '
        'RadioButton2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton2, Nothing)
        Me.RadioButton2.Location = New System.Drawing.Point(8, 40)
        Me.RadioButton2.Name = "RadioButton2"
        Me.RadioButton2.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton2.TabIndex = 22
        Me.RadioButton2.Text = "Niederlassung"
        '
        'ComboBox1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.ComboBox1, Nothing)
        Me.ComboBox1.Location = New System.Drawing.Point(88, 110)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(200, 21)
        Me.ComboBox1.TabIndex = 27
        '
        'RadioButton6
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton6, Nothing)
        Me.RadioButton6.Location = New System.Drawing.Point(8, 110)
        Me.RadioButton6.Name = "RadioButton6"
        Me.RadioButton6.Size = New System.Drawing.Size(80, 24)
        Me.RadioButton6.TabIndex = 26
        Me.RadioButton6.Text = "Funktion"
        '
        'RadioButton5
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton5, Nothing)
        Me.RadioButton5.Location = New System.Drawing.Point(8, 92)
        Me.RadioButton5.Name = "RadioButton5"
        Me.RadioButton5.Size = New System.Drawing.Size(80, 24)
        Me.RadioButton5.TabIndex = 25
        Me.RadioButton5.Text = "Persönlich"
        '
        'RadioButton4
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton4, Nothing)
        Me.RadioButton4.Location = New System.Drawing.Point(8, 75)
        Me.RadioButton4.Name = "RadioButton4"
        Me.RadioButton4.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton4.TabIndex = 24
        Me.RadioButton4.Text = "Team"
        '
        'RadioButton3
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton3, Nothing)
        Me.RadioButton3.Location = New System.Drawing.Point(8, 58)
        Me.RadioButton3.Name = "RadioButton3"
        Me.RadioButton3.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton3.TabIndex = 23
        Me.RadioButton3.Text = "Kostenstelle"
        '
        'RadioButton1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RadioButton1, Nothing)
        Me.RadioButton1.Location = New System.Drawing.Point(8, 22)
        Me.RadioButton1.Name = "RadioButton1"
        Me.RadioButton1.Size = New System.Drawing.Size(176, 24)
        Me.RadioButton1.TabIndex = 21
        Me.RadioButton1.Text = "Marktbereich"
        '
        'Panel1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Panel1, Nothing)
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.ComboBox2})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(904, 41)
        Me.Panel1.TabIndex = 2
        '
        'Label1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label1, Nothing)
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(64, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Partnerliste"
        '
        'ComboBox2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.ComboBox2, Nothing)
        Me.ComboBox2.Location = New System.Drawing.Point(72, 8)
        Me.ComboBox2.Name = "ComboBox2"
        Me.ComboBox2.Size = New System.Drawing.Size(272, 21)
        Me.ComboBox2.TabIndex = 0
        '
        'GroupBox2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox2, Nothing)
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Partnerlist})
        Me.GroupBox2.Location = New System.Drawing.Point(0, 66)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(592, 366)
        Me.GroupBox2.TabIndex = 3
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Partner"
        '
        'Partnerlist
        '
        Me.Partnerlist.AllowFilter = True
        Me.Partnerlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Partnerlist.AllowSort = True
        Me.Partnerlist.AlternatingRows = True
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Partnerlist, Me.C1ContextMenu1)
        Me.Partnerlist.CaptionHeight = 17
        Me.Partnerlist.CollapseColor = System.Drawing.Color.Black
        Me.Partnerlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.Partnerlist.DataChanged = False
        Me.Partnerlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Partnerlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Partnerlist.ExpandColor = System.Drawing.Color.Black
        Me.Partnerlist.FetchRowStyles = True
        Me.Partnerlist.FilterBar = True
        Me.Partnerlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Partnerlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Partnerlist.Location = New System.Drawing.Point(3, 16)
        Me.Partnerlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Partnerlist.Name = "Partnerlist"
        Me.Partnerlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Partnerlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Partnerlist.PreviewInfo.ZoomFactor = 75
        Me.Partnerlist.PrintInfo.ShowOptionsDialog = False
        Me.Partnerlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Partnerlist.RowDivider = GridLines1
        Me.Partnerlist.RowHeight = 15
        Me.Partnerlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Partnerlist.ScrollTips = True
        Me.Partnerlist.Size = New System.Drawing.Size(586, 347)
        Me.Partnerlist.TabIndex = 27
        Me.Partnerlist.Text = "C1TrueDBGrid1"
        Me.Partnerlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 582," & _
        " 343</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 582, " & _
        "343</ClientArea></Blob>"
        '
        'C1CommandHolder1
        '
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDatei)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNew)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoad)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSave)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainClose)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokument)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorlageImportieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorageBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorschauErstellen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteGenerieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteDrucken)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteBestaetigen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddEDOKAHOSTPartner)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEDOKAPartnerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEmpfaengerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoadPartnerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSaveAsPartnerlist)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainImportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainExportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.C1CommandMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDeleteColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainRenameColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSpaltenselektion)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAbschluss)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmfpaengerLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainCheckEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSerienbriefLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctAddHost)
        Me.C1CommandHolder1.Commands.Add(Me.mnuCTADDEdokapartner)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctaddempfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.C1ContextMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner1)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner2)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner3)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnumainpreview)
        Me.C1CommandHolder1.ImageList = Me.ImageList1
        Me.C1CommandHolder1.ImageTransparentColor = System.Drawing.Color.LightGray
        Me.C1CommandHolder1.Owner = Me
        Me.C1CommandHolder1.SmoothImages = False
        '
        'C1ContextMenu1
        '
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink21)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink11)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink12)
        Me.C1ContextMenu1.Image = Nothing
        Me.C1ContextMenu1.Name = "C1ContextMenu1"
        '
        'C1CommandLink21
        '
        Me.C1CommandLink21.Command = Me.c1mnupartner1
        Me.C1CommandLink21.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'c1mnupartner1
        '
        Me.c1mnupartner1.Image = CType(resources.GetObject("c1mnupartner1.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner1.ImageIndex = 16
        Me.c1mnupartner1.Name = "c1mnupartner1"
        Me.c1mnupartner1.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'C1CommandLink11
        '
        Me.C1CommandLink11.Command = Me.MnuMainEmpfaengerBearbeiten
        Me.C1CommandLink11.Delimiter = True
        Me.C1CommandLink11.Text = "Markierter Partner bearbeiten"
        '
        'MnuMainEmpfaengerBearbeiten
        '
        Me.MnuMainEmpfaengerBearbeiten.Image = Nothing
        Me.MnuMainEmpfaengerBearbeiten.Name = "MnuMainEmpfaengerBearbeiten"
        Me.MnuMainEmpfaengerBearbeiten.Text = "Markierter Empfänger bearbeiten"
        '
        'C1CommandLink12
        '
        Me.C1CommandLink12.Command = Me.MnuMainEmfpaengerLoeschen
        Me.C1CommandLink12.Text = "Markierter Partner löschen"
        '
        'MnuMainEmfpaengerLoeschen
        '
        Me.MnuMainEmfpaengerLoeschen.Image = Nothing
        Me.MnuMainEmfpaengerLoeschen.Name = "MnuMainEmfpaengerLoeschen"
        Me.MnuMainEmfpaengerLoeschen.Text = "Markierter Empfänger löschen"
        '
        'MnuMainDatei
        '
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainNeuerSerienbrief)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefLaden)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuSerienbriefLoeschen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefabschliessen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefSpeichern)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainFensterSchliessen)
        Me.MnuMainDatei.Image = Nothing
        Me.MnuMainDatei.Name = "MnuMainDatei"
        Me.MnuMainDatei.Text = "&Datei"
        '
        'C1MnuMainNeuerSerienbrief
        '
        Me.C1MnuMainNeuerSerienbrief.Command = Me.MnuMainNew
        Me.C1MnuMainNeuerSerienbrief.Text = "&Neuer Serienbrief"
        '
        'MnuMainNew
        '
        Me.MnuMainNew.Image = CType(resources.GetObject("MnuMainNew.Image"), System.Drawing.Bitmap)
        Me.MnuMainNew.ImageIndex = 20
        Me.MnuMainNew.Name = "MnuMainNew"
        Me.MnuMainNew.Text = "&Neuer Serienbrief"
        '
        'C1MnuMainSerienbriefLaden
        '
        Me.C1MnuMainSerienbriefLaden.Command = Me.MnuMainLoad
        Me.C1MnuMainSerienbriefLaden.Text = "Serienbrief &laden"
        '
        'MnuMainLoad
        '
        Me.MnuMainLoad.Image = CType(resources.GetObject("MnuMainLoad.Image"), System.Drawing.Bitmap)
        Me.MnuMainLoad.ImageIndex = 22
        Me.MnuMainLoad.Name = "MnuMainLoad"
        Me.MnuMainLoad.Text = "Serienbrief &laden"
        '
        'C1MnuSerienbriefLoeschen
        '
        Me.C1MnuSerienbriefLoeschen.Command = Me.MnuMainSerienbriefLoeschen
        Me.C1MnuSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'MnuMainSerienbriefLoeschen
        '
        Me.MnuMainSerienbriefLoeschen.Image = CType(resources.GetObject("MnuMainSerienbriefLoeschen.Image"), System.Drawing.Bitmap)
        Me.MnuMainSerienbriefLoeschen.ImageIndex = 23
        Me.MnuMainSerienbriefLoeschen.Name = "MnuMainSerienbriefLoeschen"
        Me.MnuMainSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'C1MnuMainSerienbriefabschliessen
        '
        Me.C1MnuMainSerienbriefabschliessen.Command = Me.MnuMainAbschluss
        Me.C1MnuMainSerienbriefabschliessen.Text = "Serienbrief abschliessen"
        '
        'MnuMainAbschluss
        '
        Me.MnuMainAbschluss.Image = CType(resources.GetObject("MnuMainAbschluss.Image"), System.Drawing.Bitmap)
        Me.MnuMainAbschluss.ImageIndex = 27
        Me.MnuMainAbschluss.Name = "MnuMainAbschluss"
        Me.MnuMainAbschluss.Text = "Serienbrief abschliessen"
        '
        'C1MnuMainSerienbriefSpeichern
        '
        Me.C1MnuMainSerienbriefSpeichern.Command = Me.MnuMainSave
        Me.C1MnuMainSerienbriefSpeichern.Delimiter = True
        Me.C1MnuMainSerienbriefSpeichern.Text = "&Serienbrief speichern"
        '
        'MnuMainSave
        '
        Me.MnuMainSave.Image = CType(resources.GetObject("MnuMainSave.Image"), System.Drawing.Bitmap)
        Me.MnuMainSave.ImageIndex = 24
        Me.MnuMainSave.Name = "MnuMainSave"
        Me.MnuMainSave.Text = "&Serienbrief speichern"
        '
        'C1MnuMainFensterSchliessen
        '
        Me.C1MnuMainFensterSchliessen.Command = Me.MnuMainClose
        Me.C1MnuMainFensterSchliessen.Delimiter = True
        Me.C1MnuMainFensterSchliessen.Text = "&Fenster schliessen"
        '
        'MnuMainClose
        '
        Me.MnuMainClose.Image = CType(resources.GetObject("MnuMainClose.Image"), System.Drawing.Bitmap)
        Me.MnuMainClose.ImageIndex = 0
        Me.MnuMainClose.Name = "MnuMainClose"
        Me.MnuMainClose.Text = "&Fenster schliessen"
        '
        'MnuMainDokument
        '
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageImportieren)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageBearbeiten)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1CommandLink1)
        Me.MnuMainDokument.Image = Nothing
        Me.MnuMainDokument.Name = "MnuMainDokument"
        Me.MnuMainDokument.Text = "Dokument"
        '
        'C1MnuMainVorlageImportieren
        '
        Me.C1MnuMainVorlageImportieren.Command = Me.MnuMainVorlageImportieren
        Me.C1MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'MnuMainVorlageImportieren
        '
        Me.MnuMainVorlageImportieren.Image = Nothing
        Me.MnuMainVorlageImportieren.Name = "MnuMainVorlageImportieren"
        Me.MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'C1MnuMainVorlageBearbeiten
        '
        Me.C1MnuMainVorlageBearbeiten.Command = Me.MnuMainVorageBearbeiten
        Me.C1MnuMainVorlageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'MnuMainVorageBearbeiten
        '
        Me.MnuMainVorageBearbeiten.Image = CType(resources.GetObject("MnuMainVorageBearbeiten.Image"), System.Drawing.Bitmap)
        Me.MnuMainVorageBearbeiten.ImageIndex = 25
        Me.MnuMainVorageBearbeiten.Name = "MnuMainVorageBearbeiten"
        Me.MnuMainVorageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'C1CommandLink1
        '
        Me.C1CommandLink1.Command = Me.c1mnumainpreview
        Me.C1CommandLink1.Text = "Dokument-Vorschau"
        '
        'c1mnumainpreview
        '
        Me.c1mnumainpreview.Image = CType(resources.GetObject("c1mnumainpreview.Image"), System.Drawing.Bitmap)
        Me.c1mnumainpreview.ImageIndex = 26
        Me.c1mnumainpreview.Name = "c1mnumainpreview"
        Me.c1mnumainpreview.Text = "Dokument-Vorschau"
        '
        'MnuMainVorschauErstellen
        '
        Me.MnuMainVorschauErstellen.Image = CType(resources.GetObject("MnuMainVorschauErstellen.Image"), System.Drawing.Bitmap)
        Me.MnuMainVorschauErstellen.ImageIndex = 26
        Me.MnuMainVorschauErstellen.Name = "MnuMainVorschauErstellen"
        Me.MnuMainVorschauErstellen.Text = "Vorschau erstellen"
        '
        'MnuMainDokumenteGenerieren
        '
        Me.MnuMainDokumenteGenerieren.Image = CType(resources.GetObject("MnuMainDokumenteGenerieren.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteGenerieren.ImageIndex = 15
        Me.MnuMainDokumenteGenerieren.Name = "MnuMainDokumenteGenerieren"
        Me.MnuMainDokumenteGenerieren.Text = "Dokumente &generieren"
        '
        'MnuMainDokumenteDrucken
        '
        Me.MnuMainDokumenteDrucken.Image = CType(resources.GetObject("MnuMainDokumenteDrucken.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteDrucken.ImageIndex = 14
        Me.MnuMainDokumenteDrucken.Name = "MnuMainDokumenteDrucken"
        Me.MnuMainDokumenteDrucken.Text = "Dokumente &drucken"
        '
        'MnuMainDokumenteBestaetigen
        '
        Me.MnuMainDokumenteBestaetigen.Image = CType(resources.GetObject("MnuMainDokumenteBestaetigen.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteBestaetigen.ImageIndex = 13
        Me.MnuMainDokumenteBestaetigen.Name = "MnuMainDokumenteBestaetigen"
        Me.MnuMainDokumenteBestaetigen.Text = "Generierte Dokumente bestätigen"
        '
        'MnuMainEmpfaengerliste
        '
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainImportEmpfaneger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainExportEmpfaenger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainLoadPartnerliste)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainSaveAsPartnerlist)
        Me.MnuMainEmpfaengerliste.Image = Nothing
        Me.MnuMainEmpfaengerliste.Name = "MnuMainEmpfaengerliste"
        Me.MnuMainEmpfaengerliste.Text = "Empfängerliste"
        '
        'C1MnuMainImportEmpfaneger
        '
        Me.C1MnuMainImportEmpfaneger.Command = Me.MnuMainImportEmpfaenger
        Me.C1MnuMainImportEmpfaneger.Delimiter = True
        Me.C1MnuMainImportEmpfaneger.Text = "Empfängerliste importieren"
        '
        'MnuMainImportEmpfaenger
        '
        Me.MnuMainImportEmpfaenger.Image = Nothing
        Me.MnuMainImportEmpfaenger.Name = "MnuMainImportEmpfaenger"
        Me.MnuMainImportEmpfaenger.Text = "Empfängerliste importieren"
        '
        'C1MnuMainExportEmpfaenger
        '
        Me.C1MnuMainExportEmpfaenger.Command = Me.MnuMainExportEmpfaenger
        Me.C1MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'MnuMainExportEmpfaenger
        '
        Me.MnuMainExportEmpfaenger.Image = Nothing
        Me.MnuMainExportEmpfaenger.Name = "MnuMainExportEmpfaenger"
        Me.MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'C1MnuMainLoadPartnerliste
        '
        Me.C1MnuMainLoadPartnerliste.Command = Me.MnuMainLoadPartnerliste
        Me.C1MnuMainLoadPartnerliste.Delimiter = True
        Me.C1MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'MnuMainLoadPartnerliste
        '
        Me.MnuMainLoadPartnerliste.Image = Nothing
        Me.MnuMainLoadPartnerliste.Name = "MnuMainLoadPartnerliste"
        Me.MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'C1MnuMainSaveAsPartnerlist
        '
        Me.C1MnuMainSaveAsPartnerlist.Command = Me.MnuMainSaveAsPartnerlist
        Me.C1MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'MnuMainSaveAsPartnerlist
        '
        Me.MnuMainSaveAsPartnerlist.Image = Nothing
        Me.MnuMainSaveAsPartnerlist.Name = "MnuMainSaveAsPartnerlist"
        Me.MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'MnuMainAddEDOKAHOSTPartner
        '
        Me.MnuMainAddEDOKAHOSTPartner.Image = CType(resources.GetObject("MnuMainAddEDOKAHOSTPartner.Image"), System.Drawing.Bitmap)
        Me.MnuMainAddEDOKAHOSTPartner.ImageIndex = 16
        Me.MnuMainAddEDOKAHOSTPartner.Name = "MnuMainAddEDOKAHOSTPartner"
        Me.MnuMainAddEDOKAHOSTPartner.Shortcut = System.Windows.Forms.Shortcut.CtrlP
        Me.MnuMainAddEDOKAHOSTPartner.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'MnuMainNeuerEDOKAPartnerErfassen
        '
        Me.MnuMainNeuerEDOKAPartnerErfassen.Image = CType(resources.GetObject("MnuMainNeuerEDOKAPartnerErfassen.Image"), System.Drawing.Bitmap)
        Me.MnuMainNeuerEDOKAPartnerErfassen.ImageIndex = 18
        Me.MnuMainNeuerEDOKAPartnerErfassen.Name = "MnuMainNeuerEDOKAPartnerErfassen"
        Me.MnuMainNeuerEDOKAPartnerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.MnuMainNeuerEDOKAPartnerErfassen.Text = "&Neuer EDOKA-Partner erfassen"
        '
        'MnuMainNeuerEmpfaengerErfassen
        '
        Me.MnuMainNeuerEmpfaengerErfassen.Image = CType(resources.GetObject("MnuMainNeuerEmpfaengerErfassen.Image"), System.Drawing.Bitmap)
        Me.MnuMainNeuerEmpfaengerErfassen.ImageIndex = 19
        Me.MnuMainNeuerEmpfaengerErfassen.Name = "MnuMainNeuerEmpfaengerErfassen"
        Me.MnuMainNeuerEmpfaengerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlE
        Me.MnuMainNeuerEmpfaengerErfassen.Text = "Neuer E&mpfänger erfassen"
        '
        'C1CommandMenu1
        '
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainAddColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainDeleteColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainRenameColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainSpaltenselektion)
        Me.C1CommandMenu1.Image = Nothing
        Me.C1CommandMenu1.Name = "C1CommandMenu1"
        Me.C1CommandMenu1.Text = "&Individuelle Dokumentwerte"
        '
        'C1MnuMainAddColumn
        '
        Me.C1MnuMainAddColumn.Command = Me.MnuMainAddColumn
        Me.C1MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'MnuMainAddColumn
        '
        Me.MnuMainAddColumn.Image = Nothing
        Me.MnuMainAddColumn.Name = "MnuMainAddColumn"
        Me.MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'C1MnuMainDeleteColumn
        '
        Me.C1MnuMainDeleteColumn.Command = Me.MnuMainDeleteColumn
        Me.C1MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'MnuMainDeleteColumn
        '
        Me.MnuMainDeleteColumn.Image = Nothing
        Me.MnuMainDeleteColumn.Name = "MnuMainDeleteColumn"
        Me.MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'C1MnuMainRenameColumn
        '
        Me.C1MnuMainRenameColumn.Command = Me.MnuMainRenameColumn
        Me.C1MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'MnuMainRenameColumn
        '
        Me.MnuMainRenameColumn.Image = Nothing
        Me.MnuMainRenameColumn.Name = "MnuMainRenameColumn"
        Me.MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'C1MnuMainSpaltenselektion
        '
        Me.C1MnuMainSpaltenselektion.Command = Me.MnuMainSpaltenselektion
        Me.C1MnuMainSpaltenselektion.Delimiter = True
        Me.C1MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'MnuMainSpaltenselektion
        '
        Me.MnuMainSpaltenselektion.Image = Nothing
        Me.MnuMainSpaltenselektion.Name = "MnuMainSpaltenselektion"
        Me.MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'MnuMainCheckEmpfaenger
        '
        Me.MnuMainCheckEmpfaenger.Image = CType(resources.GetObject("MnuMainCheckEmpfaenger.Image"), System.Drawing.Bitmap)
        Me.MnuMainCheckEmpfaenger.ImageIndex = 17
        Me.MnuMainCheckEmpfaenger.Name = "MnuMainCheckEmpfaenger"
        Me.MnuMainCheckEmpfaenger.Text = "Empfängerliste prüfen"
        '
        'mnuctAddHost
        '
        Me.mnuctAddHost.Image = CType(resources.GetObject("mnuctAddHost.Image"), System.Drawing.Bitmap)
        Me.mnuctAddHost.ImageIndex = 16
        Me.mnuctAddHost.Name = "mnuctAddHost"
        Me.mnuctAddHost.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'mnuCTADDEdokapartner
        '
        Me.mnuCTADDEdokapartner.Image = CType(resources.GetObject("mnuCTADDEdokapartner.Image"), System.Drawing.Bitmap)
        Me.mnuCTADDEdokapartner.ImageIndex = 18
        Me.mnuCTADDEdokapartner.Name = "mnuCTADDEdokapartner"
        Me.mnuCTADDEdokapartner.Text = "Neuer EDOKA-Partner erfassen"
        '
        'mnuctaddempfaenger
        '
        Me.mnuctaddempfaenger.Image = CType(resources.GetObject("mnuctaddempfaenger.Image"), System.Drawing.Bitmap)
        Me.mnuctaddempfaenger.ImageIndex = 19
        Me.mnuctaddempfaenger.Name = "mnuctaddempfaenger"
        Me.mnuctaddempfaenger.Text = "Neuer Empfänger erfassen"
        '
        'c1mnupartner2
        '
        Me.c1mnupartner2.Image = CType(resources.GetObject("c1mnupartner2.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner2.ImageIndex = 18
        Me.c1mnupartner2.Name = "c1mnupartner2"
        Me.c1mnupartner2.Text = "Neuer EDOKA-Partner erfassen"
        '
        'c1mnupartner3
        '
        Me.c1mnupartner3.Image = CType(resources.GetObject("c1mnupartner3.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner3.ImageIndex = 19
        Me.c1mnupartner3.Name = "c1mnupartner3"
        Me.c1mnupartner3.Text = "Neuer Empfänger erfassen"
        '
        'GroupBox3
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox3, Nothing)
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox4, Me.GroupBox1})
        Me.GroupBox3.Dock = System.Windows.Forms.DockStyle.Right
        Me.GroupBox3.Location = New System.Drawing.Point(600, 66)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(304, 371)
        Me.GroupBox3.TabIndex = 4
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Detailinformationen"
        '
        'GroupBox4
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox4, Nothing)
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox2})
        Me.GroupBox4.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox4.Location = New System.Drawing.Point(3, 16)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(298, 192)
        Me.GroupBox4.TabIndex = 0
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Beschreibung"
        '
        'TextBox2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TextBox2, Nothing)
        Me.TextBox2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TextBox2.Location = New System.Drawing.Point(3, 16)
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(292, 173)
        Me.TextBox2.TabIndex = 0
        Me.TextBox2.Text = ""
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.C1CommandHolder1.SetC1ContextMenu(Me.BtnHelp, Nothing)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(879, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 69
        '
        'frmPartnerlisteVerwalten
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.C1CommandHolder1.SetC1ContextMenu(Me, Nothing)
        Me.ClientSize = New System.Drawing.Size(904, 437)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.GroupBox3, Me.GroupBox2, Me.Panel1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPartnerlisteVerwalten"
        Me.Text = "Partnerlisten verwalten"
        Me.GroupBox1.ResumeLayout(False)
        Me.Panel1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.Partnerlist, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.Load_Partnerlist Method

Public Function Load_Partnerlist() As String

Source code

[Visual Basic]
    Public Function Load_Partnerlist() As String
        Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.mcblisten.SelectedValue.ToString + "_Partnerlist.xml"
        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * From edex_sb_partnerliste where partnerlistenr=" + Me.mcblisten.SelectedValue.ToString, connection)
        Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
        Dim ds As New DataSet()

        Try
            'Connectionstring zur Datenbank
            connection.ConnectionString = Globals.sConnectionString
            connection.Open()
            da.Fill(ds, "docs")
            Dim myRow As DataRow
            myRow = ds.Tables(0).Rows(0)
            Dim MyData() As Byte
            MyData = myRow.Item(9)
            Dim K As Long
            K = UBound(MyData)
            Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
            fs.Write(MyData, 0, K)
            fs.Close()
            fs = Nothing
            Return dokumentname
        Catch ex As Exception
            Return ""
        End Try
        CB = Nothing
        ds = Nothing
        da = Nothing
        connection.Close()
        connection = Nothing
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.MnuMainEmfpaengerLoeschen_Click Method

Private Sub MnuMainEmfpaengerLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEmfpaengerLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEmfpaengerLoeschen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEmfpaengerLoeschen.Click
        Try
            Me.Partnerlist.AllowDelete = True
            Me.Partnerlist.Delete()
            Me.Partnerlist.UpdateData()
            Me.Partnerlist.AllowDelete = False
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.MnuMainEmpfaengerBearbeiten_Click Method

Private Sub MnuMainEmpfaengerBearbeiten_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEmpfaengerBearbeiten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEmpfaengerBearbeiten_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEmpfaengerBearbeiten.Click
        Dim f As New frmsbpartnerdetail(False, Me.dspartner.Tables(0), Me.Partnerlist.Columns("partnernr").Text)
        f.txtAnrede.Text = Me.Partnerlist.Columns("Anrede").Text
        f.txtname.Text = Me.Partnerlist.Columns("Name").Text
        f.txtvorname.Text = Me.Partnerlist.Columns("Vorname").Text
        f.txtstrasse.Text = Me.Partnerlist.Columns("Strasse").Text
        f.txtnrpar00.Text = Me.Partnerlist.Columns("Partnernr").Text
        f.txtanrede1.Text = Me.Partnerlist.Columns("Briefanrede1").Text
        f.txtanrede2.Text = Me.Partnerlist.Columns("Briefanrede2").Text
        f.txtort.Text = Me.Partnerlist.Columns("Ort").Text
        f.txtzustelladresse.Text = Me.Partnerlist.Columns("Zustelladresse").Text
        f.txtkurzbezeichnung.Text = Me.Partnerlist.Columns("Kurzbezeichnung").Text
        Dim i As Integer
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            For i = 0 To Me.Partnerlist.Columns.Count - 1
                Me.Partnerlist.Columns(i).Text = ""
            Next
            Me.Partnerlist.Columns("Partnernr").Text = f.txtnrpar00.Text
            Me.Partnerlist.Columns("Anrede").Text = f.txtAnrede.Text
            Me.Partnerlist.Columns("Kurzbezeichnung").Text = f.txtkurzbezeichnung.Text
            Me.Partnerlist.Columns("Name").Text = f.txtname.Text
            Me.Partnerlist.Columns("Vorname").Text = f.txtvorname.Text
            Me.Partnerlist.Columns("Strasse").Text = f.txtstrasse.Text
            Me.Partnerlist.Columns("PLZ").Text = f.txtplz.Text
            Me.Partnerlist.Columns("Ort").Text = f.txtort.Text
            Me.Partnerlist.Columns("Zustelladresse").Text = f.txtzustelladresse.Text
            Me.Partnerlist.Columns("BriefAnrede1").Text = f.txtanrede1.Text
            Me.Partnerlist.Columns("BriefAnrede2").Text = f.txtanrede2.Text
            Me.Partnerlist.UpdateData()
        End If

        Me.Partnerlist.UpdateData()
        Me.Partnerlist.AllowAddNew = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.Partner_Details Method

Private Function Partner_Details( _
   ByVal partnernr As Integer _
)

Parameters

partnernr
Required.

Source code

[Visual Basic]
    Private Function Partner_Details(ByVal partnernr As Integer)
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(partnernr, Int32))
        p.SelectOne()
        Me.CurrentPartnernr = partnernr
        Me.CurrentPartnerbezeichnung = p.sBKPAR00.Value
        p.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.RadioButton6_CheckedChanged Method

Private Sub RadioButton6_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RadioButton6.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RadioButton6_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RadioButton6.CheckedChanged
        If Me.RadioButton6.Checked = True Then
            Me.mcbfunktionen.Enabled = True
        Else
            Me.mcbfunktionen.SelectedIndex = 0
            Me.mcbfunktionen.Enabled = False

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.Save_Data Method

Private Sub Save_Data()

Source code

[Visual Basic]
    Private Sub Save_Data()
        pl.sBeschreibung = New SqlString(CType(Me.TextBox2.Text, String))
        Dim i As Integer
        If Me.RadioButton1.Checked Then i = 1
        If Me.RadioButton2.Checked Then i = 2
        If Me.RadioButton3.Checked Then i = 3
        If Me.RadioButton4.Checked Then i = 4
        If Me.RadioButton5.Checked Then i = 5
        If Me.RadioButton6.Checked Then i = 6
        If Me.RadioButton6.Checked Then
            pl.iVerwendungcd = New SqlInt32(CType(Me.mcbfunktionen.SelectedValue, Int32))
        Else
            pl.iVerwendungcd = New SqlInt32(CType(0, Int32))
        End If
        pl.sBeschreibung = New SqlString(CType(Me.TextBox2.Text, String))
        pl.iVerwendung = New SqlInt32(CType(i, Int32))
        pl.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        pl.bAktiv = New SqlBoolean(CType(True, Boolean))
        pl.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        Globals.conn.OpenConnection()
        pl.Update()
        Globals.conn.CloseConnection(True)
        save_partner(pl.iPartnerlistenr.Value)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.Close()
            Case 1
                Me.Cursor = Cursors.WaitCursor
                Me.Save_Data()
                Me.Cursor = Cursors.Default
            Case 2

        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.add_edokahostpartner Method

Private Sub add_edokahostpartner()

Source code

[Visual Basic]
    Private Sub add_edokahostpartner()
        Me.Partnerlist.AllowAddNew() = True
        Me.Partnerlist.MoveLast()
        Me.Partnerlist.Row = Me.Partnerlist.Row + 1
        Me.Partnerlist.Select()
        Dim i As Integer
        For i = 0 To Me.Partnerlist.Columns.Count - 1
            Me.Partnerlist.Columns(i).Text = ""
        Next
        Me.Partnerlist.Columns("partnernr").Text = Me.CurrentPartnernr
        Me.Partnerlist.Columns("Kurzbezeichnung").Text = Me.CurrentPartnerbezeichnung
        Me.Partnerlist.UpdateData()
        Me.dspartner.AcceptChanges()
        Me.Partnerlist.AllowAddNew = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.c1mnupartner1_Click Method

Private Sub c1mnupartner1_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1mnupartner1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1mnupartner1_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1mnupartner1.Click
        Dim f As New FrmPartnersuche()
        f.TopMost = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Partner_Details(f.PartnerNr)
            add_edokahostpartner()
            Me.Partnerlist.UpdateData()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.frmPartnerlisteVerwalten_Load Method

Private Sub frmPartnerlisteVerwalten_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerlisteVerwalten_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbfunktionen = New MultiComboBox(Me.ComboBox1)
        mcbfunktionen.DisplayColumnName = "Bezeichnung"
        mcbfunktionen.ValueColumnName = "funktionsgruppenr"
        mcbfunktionen.CheckNullValue = False
        Dim dt As New DataTable()
        dt = load_funktionen()
        mcbfunktionen.Fill_Data(dt, True)
        mcbfunktionen.SelectedIndex = 0
        mcbfunktionen.Visible = True

        mcblisten = New MultiComboBox(Me.ComboBox2)
        mcblisten.DisplayColumnName = "Bezeichnung"
        mcblisten.ValueColumnName = "Nr"
        mcblisten.CheckNullValue = False
        Dim dt1 As New DataTable()
        dt1 = load_partnerlisten()
        mcblisten.Fill_Data(dt1, False)
        mcblisten.Visible = True
        on_load = False
        Try
            If Me.mcblisten.Items.Count > 0 Then
                mcblisten.SelectedIndex = 0
            Else
                Me.TextBox2.Text = ""
                Me.ComboBox1.Text = ""
                Me.RadioButton1.Enabled = False
                Me.RadioButton2.Enabled = False
                Me.RadioButton3.Enabled = False
                Me.RadioButton4.Enabled = False
                Me.RadioButton5.Enabled = False
                Me.RadioButton6.Enabled = False
                Me.ToolBar1.Buttons(1).Enabled = False
                Me.ToolBar1.Buttons(2).Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.load_funktionen Method

Private Function load_funktionen() As DataTable

Source code

[Visual Basic]
    Private Function load_funktionen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_funktionen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("dbo.sp_edex_sb_get_funktionen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.load_partnerlisten Method

Private Function load_partnerlisten() As DataTable

Source code

[Visual Basic]
    Private Function load_partnerlisten() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_partnerlisten_v"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@manr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("dbo.sp_edex_sb_get_funktionen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.mcblisten_SelectedValueChanged Method

Private Sub mcblisten_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcblisten.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcblisten_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcblisten.SelectedValueChanged
        Try
            If on_load Then Exit Sub
            pl.cpMainConnectionProvider = Globals.conn
            pl.iPartnerlistenr = New SqlInt32(CType(Me.mcblisten.SelectedValue, Int32))
            pl.SelectOne()
            Me.RadioButton1.Checked = pl.iVerwendung.Value = 1
            Me.RadioButton2.Checked = pl.iVerwendung.Value = 2
            Me.RadioButton3.Checked = pl.iVerwendung.Value = 3
            Me.RadioButton4.Checked = pl.iVerwendung.Value = 4
            Me.RadioButton5.Checked = pl.iVerwendung.Value = 5
            Me.RadioButton6.Checked = pl.iVerwendung.Value = 6
            Me.TextBox2.Text = pl.sBeschreibung.Value
            If Me.RadioButton6.Checked = True Then
                Me.mcbfunktionen.SelectedValue = Me.pl.iVerwendungcd.Value
                Me.mcbfunktionen.Enabled = True
            Else
                Me.mcbfunktionen.Enabled = False
            End If
            Me.dspartner.Tables.Clear()
            Me.dspartner.ReadXml(Me.Load_Partnerlist)
            Me.Partnerlist.DataSource = Nothing
            Me.Partnerlist.DataMember = Nothing
            Me.Partnerlist.DataSource = Me.dspartner.Tables(0)
            Me.Partnerlist.DataMember = Me.dspartner.Tables(0).TableName
            Dim i As Integer
            For i = 0 To Me.Partnerlist.Splits(0).DisplayColumns.Count - 1
                Me.Partnerlist.Splits(0).DisplayColumns(i).AutoSize()
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten.save_partner Method

Private Function save_partner( _
   ByVal partnerlistnr As Integer _
) As Boolean

Parameters

partnerlistnr
Required.

Source code

[Visual Basic]
    Private Function save_partner(ByVal partnerlistnr As Integer) As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + partnerlistnr.ToString + "_Partnerlist.xml"
            Me.dspartner.WriteXml(dokumentname)
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_partnerliste where partnerlistenr=" + partnerlistnr.ToString, Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                myRow.Item(9) = mydata
                DA.Update(ds, "empf")
            Catch ex As Exception
                MyMsg.show_standardmessage(715, MsgBoxStyle.Critical)
                Return False
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            File.Delete(dokumentname)

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(715, MsgBoxStyle.Critical)
            Return False
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnerlisteVerwalten Fields

frmPartnerlisteVerwalten overview

Fields

field BtnHelp
field C1CommandHolder1
field C1CommandLink1
field C1CommandLink11
field C1CommandLink12
field C1CommandLink21
field C1CommandMenu1
field C1ContextMenu1
field C1MnuMainAddColumn
field C1MnuMainDeleteColumn
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuSerienbriefLoeschen
field ComboBox1
field ComboBox2
field CurrentPartnerbezeichnung
field CurrentPartnernr
field GroupBox1
field GroupBox2
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field Panel1
field Partnerlist
field RadioButton1
field RadioButton2
field RadioButton3
field RadioButton4
field RadioButton5
field RadioButton6
field TextBox2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field c1mnumainpreview
field c1mnupartner1
field c1mnupartner2
field c1mnupartner3
field components
field dspartner
field mcbfunktionen
field mcblisten
field mnuCTADDEdokapartner
field mnuctAddHost
field mnuctaddempfaenger
field on_load
field pl

See Also

frmPartnerlisteVerwalten Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandHolder1 Variable

Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Source code

[Visual Basic]
    Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandLink1 Variable

Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandLink11 Variable

Friend WithEvents C1CommandLink11 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink11 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandLink12 Variable

Friend WithEvents C1CommandLink12 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink12 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandLink21 Variable

Friend WithEvents C1CommandLink21 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink21 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1CommandMenu1 Variable

Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1ContextMenu1 Variable

Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Source code

[Visual Basic]
    Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainAddColumn Variable

Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainDeleteColumn Variable

Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainExportEmpfaenger Variable

Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainFensterSchliessen Variable

Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainImportEmpfaneger Variable

Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainLoadPartnerliste Variable

Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainNeuerSerienbrief Variable

Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainRenameColumn Variable

Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainSaveAsPartnerlist Variable

Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainSerienbriefLaden Variable

Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainSerienbriefSpeichern Variable

Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainSerienbriefabschliessen Variable

Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainSpaltenselektion Variable

Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainVorlageBearbeiten Variable

Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuMainVorlageImportieren Variable

Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


C1MnuSerienbriefLoeschen Variable

Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ComboBox2 Variable

Friend WithEvents ComboBox2 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox2 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


CurrentPartnerbezeichnung Variable

Dim CurrentPartnerbezeichnung As String

Source code

[Visual Basic]
    Dim CurrentPartnerbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


CurrentPartnernr Variable

Dim CurrentPartnernr As Integer

Source code

[Visual Basic]
    Dim CurrentPartnernr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainAbschluss Variable

Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainAddColumn Variable

Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainAddEDOKAHOSTPartner Variable

Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainCheckEmpfaenger Variable

Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainClose Variable

Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDatei Variable

Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDeleteColumn Variable

Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDokument Variable

Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDokumenteBestaetigen Variable

Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDokumenteDrucken Variable

Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainDokumenteGenerieren Variable

Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainEmfpaengerLoeschen Variable

Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainEmpfaengerBearbeiten Variable

Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainEmpfaengerliste Variable

Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainExportEmpfaenger Variable

Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainImportEmpfaenger Variable

Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainLoad Variable

Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainLoadPartnerliste Variable

Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainNeuerEDOKAPartnerErfassen Variable

Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainNeuerEmpfaengerErfassen Variable

Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainNew Variable

Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainRenameColumn Variable

Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainSave Variable

Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainSaveAsPartnerlist Variable

Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainSerienbriefLoeschen Variable

Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainSpaltenselektion Variable

Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainVorageBearbeiten Variable

Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainVorlageImportieren Variable

Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


MnuMainVorschauErstellen Variable

Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


Partnerlist Variable

Friend WithEvents Partnerlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Partnerlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton1 Variable

Friend WithEvents RadioButton1 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton1 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton2 Variable

Friend WithEvents RadioButton2 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton2 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton3 Variable

Friend WithEvents RadioButton3 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton3 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton4 Variable

Friend WithEvents RadioButton4 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton4 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton5 Variable

Friend WithEvents RadioButton5 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton5 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


RadioButton6 Variable

Friend WithEvents RadioButton6 As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RadioButton6 As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


c1mnumainpreview Variable

Friend WithEvents c1mnumainpreview As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnumainpreview As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


c1mnupartner1 Variable

Friend WithEvents c1mnupartner1 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner1 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


c1mnupartner2 Variable

Friend WithEvents c1mnupartner2 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner2 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


c1mnupartner3 Variable

Friend WithEvents c1mnupartner3 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner3 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


dspartner Variable

Dim dspartner As New DataSet()

Source code

[Visual Basic]
    Dim dspartner As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


mcbfunktionen Variable

Dim WithEvents mcbfunktionen As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbfunktionen As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


mcblisten Variable

Dim WithEvents mcblisten As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcblisten As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


mnuCTADDEdokapartner Variable

Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


mnuctAddHost Variable

Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


mnuctaddempfaenger Variable

Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


on_load Variable

Dim on_load As Boolean = True

Source code

[Visual Basic]
    Dim on_load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


pl Variable

Dim pl As New edokadb.clsEdex_sb_partnerliste()

Source code

[Visual Basic]
    Dim pl As New edokadb.clsEdex_sb_partnerliste()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteVerwalten


frmPartnersucheInfo Class

For a list of all members of this type, see frmPartnersucheInfo Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnersucheInfo

Public Class frmPartnersucheInfo
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnersucheInfo Members


frmPartnersucheInfo Members

frmPartnersucheInfo overview

Constructors

constructor frmPartnersucheInfo Constructor

Methods

method Dispose
method InitializeComponent
method frmPartnersucheInfo_KeyDown
method frmPartnersucheInfo_Load

Fields

field Button1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field PictureBox1
field components

See Also

frmPartnersucheInfo Class


frmPartnersucheInfo Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnersucheInfo Methods

frmPartnersucheInfo overview

Methods

method Dispose
method InitializeComponent
method frmPartnersucheInfo_KeyDown
method frmPartnersucheInfo_Load

See Also

frmPartnersucheInfo Class


frmPartnersucheInfo.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnersucheInfo.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnersucheInfo))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.PictureBox1 = New System.Windows.Forms.PictureBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(64, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(552, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Sie können Partner mit der Partnernummer, dem Kurznamen, einem Freitext oder eine" & _
        "r VV-Nummer suchen."
        '
        'PictureBox1
        '
        Me.PictureBox1.Image = CType(resources.GetObject("PictureBox1.Image"), System.Drawing.Bitmap)
        Me.PictureBox1.Location = New System.Drawing.Point(8, 16)
        Me.PictureBox1.Name = "PictureBox1"
        Me.PictureBox1.Size = New System.Drawing.Size(48, 48)
        Me.PictureBox1.TabIndex = 4
        Me.PictureBox1.TabStop = False
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(64, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(552, 32)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Bei der Partnernummer-Suche ist die gesamte Partnernummer ohne Interpunktionen (m" & _
        "it oder ohne führende Nullen) zu verwenden. Bei der VV-Suche sind Interpunktions" & _
        "zeichen möglich."
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(64, 80)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(552, 40)
        Me.Label3.TabIndex = 6
        Me.Label3.Text = "Bei der Kurznamen- und Freitext-Suche sind mehrere, durch Leerzeichen getrennte B" & _
        "egriff als Suchkriterium möglich. Die Begriffe werden bei der Kurznamen-Suche im" & _
        " Kurznamen, bei der Freitext-Suche in sämtlichen Partner-Informationen (Kurzbeze" & _
        "ichnung, Inhaber-Adresse und Zustelladresse) gesucht."
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(64, 128)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(552, 32)
        Me.Label4.TabIndex = 7
        Me.Label4.Text = "Verwenden Sie mehrere Suchbegriffe, werden in der Trefferliste nur Partner aufgef" & _
        "ührt, bei denen sämtliche Suchbegriffe gefunden wurden, und zwar unabhängig von " & _
        "der Reihenfolge der erfassten Suchbegriffe. "
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(64, 168)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(552, 32)
        Me.Label5.TabIndex = 8
        Me.Label5.Text = "Bei einem Suchbegriff wird ein Treffer erzielt, wenn er irgendwo in einem Datensa" & _
        "tz enthalten ist. EDOKA setzt für die Suche vor und nach dem Suchbegriff automat" & _
        "isch sogenannte Wildcards (*)."
        '
        'Label6
        '
        Me.Label6.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label6.Location = New System.Drawing.Point(64, 208)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(552, 16)
        Me.Label6.TabIndex = 9
        Me.Label6.Text = "Beispiel (Suche im Kurznamen):"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(80, 240)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(552, 16)
        Me.Label8.TabIndex = 11
        Me.Label8.Text = "Treffer:"
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(152, 240)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(552, 16)
        Me.Label9.TabIndex = 12
        Me.Label9.Text = "Hans Egg, Mauren"
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(152, 256)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(552, 16)
        Me.Label10.TabIndex = 13
        Me.Label10.Text = "Hanselmann & Egger, Kreuzlingen"
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(152, 272)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(552, 16)
        Me.Label11.TabIndex = 14
        Me.Label11.Text = "Hans Maurer, Eggersriet"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(64, 304)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(560, 32)
        Me.Label12.TabIndex = 15
        Me.Label12.Text = "Sie können selber Wildcards verwenden. Verwenden Sie * für eine beliebige Anzahl " & _
        "beliebiger Zeichen und _ für ein einzelnes, beliebiges Zeichen"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(152, 392)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(552, 16)
        Me.Label14.TabIndex = 19
        Me.Label14.Text = "Meier & Huber, Kreuzlingen"
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(152, 376)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(552, 16)
        Me.Label15.TabIndex = 18
        Me.Label15.Text = "Franz Meyer, Weinfelden"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(80, 360)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(552, 16)
        Me.Label16.TabIndex = 17
        Me.Label16.Text = "Suchkriterium:"
        '
        'Label17
        '
        Me.Label17.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label17.Location = New System.Drawing.Point(64, 344)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(552, 16)
        Me.Label17.TabIndex = 16
        Me.Label17.Text = "Beispiel (Suche im Kurznamen):"
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(80, 376)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(48, 16)
        Me.Label18.TabIndex = 21
        Me.Label18.Text = "Treffer:"
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(152, 360)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(552, 16)
        Me.Label19.TabIndex = 22
        Me.Label19.Text = "Me_er"
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(80, 224)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(552, 16)
        Me.Label20.TabIndex = 23
        Me.Label20.Text = "Suchkriterium:"
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(152, 224)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(552, 16)
        Me.Label21.TabIndex = 24
        Me.Label21.Text = "Hans Egg, Mauren"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(152, 432)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(552, 16)
        Me.Label7.TabIndex = 30
        Me.Label7.Text = "Me*er, Arbon"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(152, 464)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(552, 16)
        Me.Label13.TabIndex = 28
        Me.Label13.Text = "Meinrad Dornacher, Arbon"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(152, 448)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(552, 16)
        Me.Label22.TabIndex = 27
        Me.Label22.Text = "Rolf Meissner, Arbon"
        '
        'Label23
        '
        Me.Label23.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Bold, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label23.Location = New System.Drawing.Point(64, 416)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(552, 16)
        Me.Label23.TabIndex = 25
        Me.Label23.Text = "Beispiel (Suche im Kurznamen):"
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(80, 448)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(48, 16)
        Me.Label24.TabIndex = 29
        Me.Label24.Text = "Treffer:"
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(80, 432)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(552, 16)
        Me.Label25.TabIndex = 26
        Me.Label25.Text = "Suchkriterium:"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(152, 480)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(552, 16)
        Me.Label26.TabIndex = 31
        Me.Label26.Text = "Meier und Tischler, Arbon"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(272, 520)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 0
        Me.Button1.Text = "&Schliessen"
        '
        'frmPartnersucheInfo
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(624, 549)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Label26, Me.Label7, Me.Label13, Me.Label22, Me.Label23, Me.Label24, Me.Label25, Me.Label21, Me.Label20, Me.Label19, Me.Label14, Me.Label15, Me.Label17, Me.Label12, Me.Label11, Me.Label10, Me.Label9, Me.Label8, Me.Label6, Me.Label5, Me.Label4, Me.Label3, Me.Label2, Me.PictureBox1, Me.Label1, Me.Label18, Me.Label16})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Name = "frmPartnersucheInfo"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Info zur Partnersuche"
        Me.TopMost = True
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnersucheInfo.frmPartnersucheInfo_KeyDown Method

Private Sub frmPartnersucheInfo_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles MyBase.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnersucheInfo_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles MyBase.KeyDown
        If e.KeyCode = Keys.Return Then Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnersucheInfo.frmPartnersucheInfo_Load Method

Private Sub frmPartnersucheInfo_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnersucheInfo_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Button1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnersucheInfo Fields

frmPartnersucheInfo overview

Fields

field Button1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field PictureBox1
field components

See Also

frmPartnersucheInfo Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


PictureBox1 Variable

Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox1 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnersucheInfo


frmPartnerzusammenlegung Class

For a list of all members of this type, see frmPartnerzusammenlegung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPartnerzusammenlegung

Public Class frmPartnerzusammenlegung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPartnerzusammenlegung Members


frmPartnerzusammenlegung Members

frmPartnerzusammenlegung overview

Constructors

constructor frmPartnerzusammenlegung Constructor

Methods

method Abbruch_Click
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Button5_Click
method Button7_Click
method Button8_Click
method ContextMenu1_Popup
method ContextMenu2_Popup
method Dispose
method FormatTimeStamp
method Generic_Select
method InitializeComponent
method Insert_ColdUpdate
method ListBox1_SelectedValueChanged
method MenuItem1_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem6_Click
method MenuItem7_Click
method Refresh_All
method Refresh_Daten_2
method Refresh_daten_1
method ToolBar1_ButtonClick
method Update_DokumentColdIndexwert
method Update_EDOKA_Partner
method Update_Partnernr
method Update_vvnr
method btnDossierHaupt_Click
method btnPartnerauswahl1_Click
method btninaktivieren_Click
method frmPartnerzusammenlegung_Closing
method frmPartnerzusammenlegung_Load
method frmPartnerzusammenlegung_Resize
method frmPartnerzusammenlegung_VisibleChanged
method get_data
method get_dokumente

Fields

field Abbruch
field BtnHelp
field Button2
field Button3
field Button4
field Button5
field Button7
field Button8
field C1TrueDBGrid1
field CheckBox1
field ContextMenu1
field ContextMenu2
field Currentrow
field Detaillist
field DoAbend
field EDOKApartner
field EdokaPartnernr
field GroupBox1
field GroupBox2
field GroupBox3
field Hostpartnernr
field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field ListBox1
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field Panel1
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox19
field TextBox20
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field Textbox2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field btnDossierHaupt
field btnPartnerauswahl1
field btninaktivieren
field btnpartnerauswahl2
field components
field dokumente
field dokumentid
field eintragnr
field kurzname
field ort
field tsm

See Also

frmPartnerzusammenlegung Class


frmPartnerzusammenlegung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung Methods

frmPartnerzusammenlegung overview

Methods

method Abbruch_Click
method BtnHelp_Click
method Button1_Click
method Button2_Click
method Button3_Click
method Button4_Click
method Button5_Click
method Button7_Click
method Button8_Click
method ContextMenu1_Popup
method ContextMenu2_Popup
method Dispose
method FormatTimeStamp
method Generic_Select
method InitializeComponent
method Insert_ColdUpdate
method ListBox1_SelectedValueChanged
method MenuItem1_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem6_Click
method MenuItem7_Click
method Refresh_All
method Refresh_Daten_2
method Refresh_daten_1
method ToolBar1_ButtonClick
method Update_DokumentColdIndexwert
method Update_EDOKA_Partner
method Update_Partnernr
method Update_vvnr
method btnDossierHaupt_Click
method btnPartnerauswahl1_Click
method btninaktivieren_Click
method frmPartnerzusammenlegung_Closing
method frmPartnerzusammenlegung_Load
method frmPartnerzusammenlegung_Resize
method frmPartnerzusammenlegung_VisibleChanged
method get_data
method get_dokumente

See Also

frmPartnerzusammenlegung Class


frmPartnerzusammenlegung.Abbruch_Click Method

Private Sub Abbruch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Abbruch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Abbruch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Abbruch.Click
        Me.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("partnerdossierszusammenlegen1")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnpartnerauswahl2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnpartnerauswahl2.Click
        Dim f As New FrmPartnersuche()
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            If f.PartnerNr < 91000000 Then
                MyMsg.show_standardmessage(256, MsgBoxStyle.Information)
                Exit Sub
            End If
            Me.TextBox14.Text = f.PartnerNr
            Me.Button5.Enabled = False
            Me.Button4.Enabled = False
        Else
            f.Dispose()
            Exit Sub
        End If
        f.Dispose()
        Dim d As DataTable
        Dim s As String
        Me.Hostpartnernr = Val(Me.TextBox14.Text)
        d = Generic_Select(22)
        Me.TextBox14.Text = ""
        Me.TextBox13.Text = ""
        Me.TextBox12.Text = ""
        Me.TextBox11.Text = ""
        Me.TextBox10.Text = ""
        Me.TextBox9.Text = ""
        Me.TextBox8.Text = ""
        Me.TextBox18.Text = ""
        Me.TextBox16.Text = ""
        Me.TextBox20.Text = ""
        If d.Rows.Count > 0 Then
            If Me.Hostpartnernr < 91000000 Then
                Me.TextBox14.Text = d.Rows(0).Item("nrpar00")
                Me.TextBox13.Text = d.Rows(0).Item("namefirma")
                Me.TextBox12.Text = d.Rows(0).Item("vorname")
                Me.TextBox11.Text = d.Rows(0).Item("strasse")
                Me.TextBox10.Text = d.Rows(0).Item("plz")
                Me.TextBox9.Text = d.Rows(0).Item("ort")
                Me.TextBox18.Text = d.Rows(0).Item("bkpar00")
                Me.TextBox16.Text = d.Rows(0).Item("kube")
                Me.TextBox20.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))

                If d.Rows(0).Item("txadz012") <> "" Then
                    s = d.Rows(0).Item("txadz012") + vbCrLf + d.Rows(0).Item("txadz022") + vbCrLf + d.Rows(0).Item("txadz032") + vbCrLf + d.Rows(0).Item("txadz042") + vbCrLf + d.Rows(0).Item("txadz052") + vbCrLf + d.Rows(0).Item("txadz062") + vbCrLf + d.Rows(0).Item("txadz072") + vbCrLf
                Else
                    s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                End If
                Me.TextBox8.Text = s
                Me.Label14.Text = "Kunden-berater"
            Else
                Me.TextBox14.Text = d.Rows(0).Item("nrpar00")
                Me.TextBox15.Text = d.Rows(0).Item("bkpar00")
                Me.TextBox13.Text = d.Rows(0).Item("txadz032")
                Me.TextBox12.Text = d.Rows(0).Item("txadz022")
                Me.TextBox10.Text = d.Rows(0).Item("TXADZ072")
                Me.TextBox9.Text = d.Rows(0).Item("beban012")
                If Len(d.Rows(0).Item("txadz062")) > 0 Then
                    Me.TextBox11.Text = d.Rows(0).Item("txadz052") + "/" + d.Rows(0).Item("txadz062")
                Else
                    Me.TextBox11.Text = d.Rows(0).Item("txadz052")
                End If
                s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                Me.TextBox8.Text = s
                Me.TextBox16.Text = d.Rows(0).Item("erfasser")
                Me.TextBox20.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))
                Me.Label14.Text = "Erfasser"
                Me.EdokaPartnernr = Val(Me.TextBox14.Text)
                d = Generic_Select(19)
                If d.Rows(0).Item(0) > 0 Then Me.Label21.Visible = False Else Me.Label21.Visible = True
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim i As Integer
        Me.Hostpartnernr = Val(Me.TextBox1.Text)
        Me.EdokaPartnernr = Val(Me.TextBox14.Text)
        Generic_Select(4)
        i = Me.ListBox1.SelectedIndex
        Me.Refresh_All()
        Try
            Me.ListBox1.SelectedIndex = i
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim doks As DataTable
        Dim i As Integer
        Dim i1 As Integer
        Me.EdokaPartnernr = Val(Me.TextBox14.Text)
        Me.Hostpartnernr = Val(Me.TextBox1.Text)
        kurzname = Me.TextBox15.Text()
        ort = Me.TextBox6.Text
        doks = Generic_Select(5)
        If doks.Rows.Count = 0 Then
            Generic_Select(6)
            MyMsg.show_standardmessage(251, MsgBoxStyle.Information)
            i = Me.ListBox1.SelectedIndex
            Me.Refresh_All()
            Try
                Me.ListBox1.SelectedIndex = i
            Catch
            End Try
            Me.ListBox1.Focus()
            Exit Sub
        End If
        For i = 0 To doks.Rows.Count - 1
            dokumentid = doks.Rows(i).Item("dokumentid")
            dokumente = get_dokumente()
            For i1 = 0 To dokumente.Rows.Count - 1
                Update_Partnernr(dokumentid, Me.Hostpartnernr)
                Update_vvnr(dokumentid, "")
            Next
            Generic_Select(7)
            'Partner umhängen
            Try
                Dim d As New edokadb.clsDokument()
                Dim kurzname As String
                Dim ort As String
                d.cpMainConnectionProvider = Globals.conn
                d.sDokumentid = New SqlString(CType(dokumentid, String))
                d.SelectOne()
                d.iNrpar00 = New SqlInt32(CType(Me.Hostpartnernr, Int32))
                conn.OpenConnection()
                d.Update()
                conn.CloseConnection(True)
                d.Dispose()
            Catch
            End Try
        Next
        Generic_Select(6)
        MyMsg.show_standardmessage_ReplaceText(254, MsgBoxStyle.Information, Trim(Str(doks.Rows.Count)), "")
        i = Me.ListBox1.SelectedIndex
        Me.Refresh_All()
        Try
            Me.ListBox1.SelectedIndex = i
        Catch
        End Try
        Me.ListBox1.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Currentrow = Currentrow - 1
        Update_EDOKA_Partner(Currentrow)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Currentrow = Currentrow + 1
        Update_EDOKA_Partner(Currentrow)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button7_Click Method

Private Sub Button7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button7.Click
        Dim d As Integer
        d = Val(Me.TextBox1.Text)
        If d > 91000000 Then
            Dim f As New frmInteressent()
            f.Partnernr = d
            f.Display = True
            f.ShowDialog()
            f.Dispose()
        Else
            Dim f As New frmPartnerDetails()
            f.Partnernr = d
            f.ShowDialog()
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Button8_Click Method

Private Sub Button8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button8.Click
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.txtnrpar00.Text = Me.TextBox14.Text
        f.Partnernr = Me.TextBox14.Text
        f.Partner_Eingegeben = True
        f.refresh_list()
        f.Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try
            If Me.C1TrueDBGrid1.Columns(5).Value = True Then
                Me.MenuItem3.Enabled = True
                Me.MenuItem7.Enabled = False
            Else
                Me.MenuItem7.Enabled = True
                Me.MenuItem3.Enabled = False
            End If
        Catch
            Me.MenuItem7.Enabled = True
            Me.MenuItem3.Enabled = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Try
            If Me.C1TrueDBGrid1.Columns(9).Value = True Then
                Me.MenuItem4.Enabled = False
            Else
                Me.MenuItem4.Enabled = True
            End If
        Catch
            Me.MenuItem4.Enabled = True
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.FormatTimeStamp Method

Private Function FormatTimeStamp( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Private Function FormatTimeStamp(ByVal s As String) As String
        If Mid(s, 5, 1) = "-" Or Mid(s, 5, 1) = "." Then
            Return Mid(s, 9, 2) + "." + Mid(s, 6, 2) + "." + Microsoft.VisualBasic.Left(s, 4)
        Else
            If Mid(s, 9, 1) <> " " Then
                Return Microsoft.VisualBasic.Left(s, 2) + "." + Mid(s, 4, 2) + "." + Mid(s, 7, 4)
            Else
                Return Microsoft.VisualBasic.Left(s, 2) + "." + Mid(s, 4, 2) + ".20" + Mid(s, 7, 2)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Partnerzusammenlegung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 0
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ohnepartnerabgleich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@returncode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                Case 3
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 3))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                Case 4
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 4))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                Case 5
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 5))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 6))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                Case 7
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 7))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                Case 10
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 10))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 11
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 11))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case 12
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 12))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 13))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 14
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 14))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 15
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 15))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 16
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 16))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 17
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 17))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.eintragnr))
                Case 18
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 18))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                Case 19
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 19))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                Case 20
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 20))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                Case 21
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 21))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.EdokaPartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                Case 22
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@hostpartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Hostpartnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@edokapartner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@eintragnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@ohnepartnerabgleich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                Case Else
            End Select
            sdaAdapter.Fill(dtToReturn)
            Select Case typ
                Case 0
                    Dim i As Integer
                    i = scmCmdToExecute.Parameters("@returncode").Value
                    If i <> 0 Then
                        If i = 1 Then
                            MyMsg.show_standardmessage(255, MsgBoxStyle.Information)
                        End If
                        If i = 2 Then
                            MyMsg.show_standardmessage(257, MsgBoxStyle.Information)
                        End If
                        Me.DoAbend = True
                    End If
                Case Else
            End Select
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPartnerzusammenlegung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.TextBox19 = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Detaillist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TextBox17 = New System.Windows.Forms.TextBox()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.btnDossierHaupt = New System.Windows.Forms.Button()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.TextBox15 = New System.Windows.Forms.TextBox()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Textbox2 = New System.Windows.Forms.TextBox()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.btnPartnerauswahl1 = New System.Windows.Forms.Button()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.TextBox20 = New System.Windows.Forms.TextBox()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.TextBox18 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.TextBox16 = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.TextBox11 = New System.Windows.Forms.TextBox()
        Me.TextBox12 = New System.Windows.Forms.TextBox()
        Me.TextBox13 = New System.Windows.Forms.TextBox()
        Me.TextBox14 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.btnpartnerauswahl2 = New System.Windows.Forms.Button()
        Me.Abbruch = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.btninaktivieren = New System.Windows.Forms.Button()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        CType(Me.Detaillist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.Panel1.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label20, Me.TextBox19, Me.Label18, Me.Detaillist, Me.TextBox17, Me.Label16, Me.Button7, Me.GroupBox3, Me.btnDossierHaupt, Me.Label15, Me.TextBox15, Me.Label13, Me.TextBox7, Me.Label6, Me.TextBox6, Me.TextBox5, Me.TextBox4, Me.TextBox3, Me.Textbox2, Me.TextBox1, Me.Label5, Me.Label4, Me.Label3, Me.Label2, Me.Label1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 32)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(568, 512)
        Me.GroupBox1.TabIndex = 3
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Hauptpartner"
        '
        'Label20
        '
        Me.Label20.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label20.ForeColor = System.Drawing.Color.Red
        Me.Label20.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.Label20.Location = New System.Drawing.Point(288, 448)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(272, 23)
        Me.Label20.TabIndex = 29
        Me.Label20.Text = "Partner hat keine Dokumente"
        Me.Label20.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'TextBox19
        '
        Me.TextBox19.BackColor = System.Drawing.Color.White
        Me.TextBox19.Location = New System.Drawing.Point(360, 320)
        Me.TextBox19.Name = "TextBox19"
        Me.TextBox19.ReadOnly = True
        Me.TextBox19.Size = New System.Drawing.Size(200, 20)
        Me.TextBox19.TabIndex = 9
        Me.TextBox19.Text = "Meier Fredy, TG1234"
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(288, 320)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(72, 24)
        Me.Label18.TabIndex = 27
        Me.Label18.Text = "Mutations-Datum"
        '
        'Detaillist
        '
        Me.Detaillist.AllowFilter = True
        Me.Detaillist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Detaillist.AllowSort = True
        Me.Detaillist.AllowUpdateOnBlur = False
        Me.Detaillist.AlternatingRows = True
        Me.Detaillist.CaptionHeight = 17
        Me.Detaillist.CollapseColor = System.Drawing.Color.Black
        Me.Detaillist.Cursor = System.Windows.Forms.Cursors.Default
        Me.Detaillist.DataChanged = False
        Me.Detaillist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Detaillist.ExpandColor = System.Drawing.Color.Black
        Me.Detaillist.FetchRowStyles = True
        Me.Detaillist.FilterBar = True
        Me.Detaillist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Detaillist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Detaillist.Location = New System.Drawing.Point(288, 368)
        Me.Detaillist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Detaillist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.Detaillist.Name = "Detaillist"
        Me.Detaillist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Detaillist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Detaillist.PreviewInfo.ZoomFactor = 75
        Me.Detaillist.PrintInfo.ShowOptionsDialog = False
        Me.Detaillist.RecordSelectors = False
        Me.Detaillist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Detaillist.RowDivider = GridLines1
        Me.Detaillist.RowHeight = 15
        Me.Detaillist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Detaillist.ScrollTips = True
        Me.Detaillist.Size = New System.Drawing.Size(272, 100)
        Me.Detaillist.TabIndex = 10
        Me.Detaillist.Text = "C1TrueDBGrid1"
        Me.Detaillist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1" & _
        """><ClientRect>0, 0, 268, 96</ClientRect><BorderSide>0</BorderSide><CaptionStyle " & _
        "parent=""Heading"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><Even" & _
        "RowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""S" & _
        "tyle27"" /><FooterStyle parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" " & _
        "me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle p" & _
        "arent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" " & _
        "/><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Record" & _
        "Selector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style5"" /><Style p" & _
        "arent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyl" & _
        "es><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style p" & _
        "arent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style pare" & _
        "nt=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style paren" & _
        "t=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style paren" & _
        "t=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""He" & _
        "ading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style pare" & _
        "nt=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1<" & _
        "/horzSplits><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth>" & _
        "<ClientArea>0, 0, 268, 96</ClientArea></Blob>"
        '
        'TextBox17
        '
        Me.TextBox17.BackColor = System.Drawing.Color.White
        Me.TextBox17.Location = New System.Drawing.Point(360, 288)
        Me.TextBox17.Name = "TextBox17"
        Me.TextBox17.ReadOnly = True
        Me.TextBox17.Size = New System.Drawing.Size(200, 20)
        Me.TextBox17.TabIndex = 8
        Me.TextBox17.Text = "Meier Fredy, TG1234"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(288, 288)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(72, 24)
        Me.Label16.TabIndex = 22
        Me.Label16.Text = "Kunden-berater"
        '
        'Button7
        '
        Me.Button7.Location = New System.Drawing.Point(288, 480)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(128, 23)
        Me.Button7.TabIndex = 11
        Me.Button7.Text = "Partnerinformationen"
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.ListBox1})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 24)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(256, 456)
        Me.GroupBox3.TabIndex = 0
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Zur Verfügung stehende Hauptpartner"
        '
        'ListBox1
        '
        Me.ListBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ListBox1.Location = New System.Drawing.Point(3, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(250, 433)
        Me.ListBox1.TabIndex = 0
        '
        'btnDossierHaupt
        '
        Me.btnDossierHaupt.Location = New System.Drawing.Point(432, 480)
        Me.btnDossierHaupt.Name = "btnDossierHaupt"
        Me.btnDossierHaupt.Size = New System.Drawing.Size(128, 23)
        Me.btnDossierHaupt.TabIndex = 12
        Me.btnDossierHaupt.Text = "Partnerdossier"
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(288, 352)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(112, 16)
        Me.Label15.TabIndex = 17
        Me.Label15.Text = "Partnerdetails"
        '
        'TextBox15
        '
        Me.TextBox15.BackColor = System.Drawing.Color.White
        Me.TextBox15.Location = New System.Drawing.Point(360, 256)
        Me.TextBox15.Name = "TextBox15"
        Me.TextBox15.ReadOnly = True
        Me.TextBox15.Size = New System.Drawing.Size(200, 20)
        Me.TextBox15.TabIndex = 7
        Me.TextBox15.Text = "Meier Fredy, TG1234"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(288, 256)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(72, 24)
        Me.Label13.TabIndex = 13
        Me.Label13.Text = "Kurzbez."
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.White
        Me.TextBox7.Location = New System.Drawing.Point(360, 160)
        Me.TextBox7.Multiline = True
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(200, 80)
        Me.TextBox7.TabIndex = 6
        Me.TextBox7.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(288, 160)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(72, 32)
        Me.Label6.TabIndex = 11
        Me.Label6.Text = "Inhaber-adresse"
        '
        'TextBox6
        '
        Me.TextBox6.BackColor = System.Drawing.Color.White
        Me.TextBox6.Location = New System.Drawing.Point(416, 128)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.ReadOnly = True
        Me.TextBox6.Size = New System.Drawing.Size(144, 20)
        Me.TextBox6.TabIndex = 5
        Me.TextBox6.Text = "Frauenfeld"
        '
        'TextBox5
        '
        Me.TextBox5.BackColor = System.Drawing.Color.White
        Me.TextBox5.Location = New System.Drawing.Point(360, 128)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.ReadOnly = True
        Me.TextBox5.Size = New System.Drawing.Size(48, 20)
        Me.TextBox5.TabIndex = 4
        Me.TextBox5.Text = "8500"
        '
        'TextBox4
        '
        Me.TextBox4.BackColor = System.Drawing.Color.White
        Me.TextBox4.Location = New System.Drawing.Point(360, 104)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(200, 20)
        Me.TextBox4.TabIndex = 3
        Me.TextBox4.Text = "Winzerweg 12"
        '
        'TextBox3
        '
        Me.TextBox3.BackColor = System.Drawing.Color.White
        Me.TextBox3.Location = New System.Drawing.Point(360, 80)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.ReadOnly = True
        Me.TextBox3.Size = New System.Drawing.Size(200, 20)
        Me.TextBox3.TabIndex = 2
        Me.TextBox3.Text = "Hans"
        '
        'Textbox2
        '
        Me.Textbox2.BackColor = System.Drawing.Color.White
        Me.Textbox2.Location = New System.Drawing.Point(360, 56)
        Me.Textbox2.Name = "Textbox2"
        Me.Textbox2.ReadOnly = True
        Me.Textbox2.Size = New System.Drawing.Size(200, 20)
        Me.Textbox2.TabIndex = 1
        Me.Textbox2.Text = "Muster"
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.Color.White
        Me.TextBox1.Location = New System.Drawing.Point(360, 24)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(200, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "1065467"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(288, 24)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(72, 23)
        Me.Label5.TabIndex = 4
        Me.Label5.Text = "Partnernr"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(288, 128)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(72, 23)
        Me.Label4.TabIndex = 3
        Me.Label4.Text = "PLZ/Ort"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(288, 104)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 2
        Me.Label3.Text = "Strasse"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(288, 80)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Vorname"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(288, 56)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Name/Firma"
        '
        'btnPartnerauswahl1
        '
        Me.btnPartnerauswahl1.Image = CType(resources.GetObject("btnPartnerauswahl1.Image"), System.Drawing.Bitmap)
        Me.btnPartnerauswahl1.Location = New System.Drawing.Point(552, 8)
        Me.btnPartnerauswahl1.Name = "btnPartnerauswahl1"
        Me.btnPartnerauswahl1.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerauswahl1.TabIndex = 1
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label21, Me.TextBox20, Me.Label19, Me.TextBox18, Me.Label17, Me.Button8, Me.Button5, Me.Button4, Me.TextBox16, Me.Label14, Me.TextBox8, Me.Label7, Me.TextBox9, Me.TextBox10, Me.TextBox11, Me.TextBox12, Me.TextBox13, Me.TextBox14, Me.Label8, Me.Label9, Me.Label10, Me.Label11, Me.Label12})
        Me.GroupBox2.Location = New System.Drawing.Point(584, 32)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(296, 512)
        Me.GroupBox2.TabIndex = 4
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "<< Partner für Zusammenlegung"
        '
        'Label21
        '
        Me.Label21.Font = New System.Drawing.Font("Microsoft Sans Serif", 9.75!, System.Drawing.FontStyle.Regular, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label21.ForeColor = System.Drawing.Color.Red
        Me.Label21.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.Label21.Location = New System.Drawing.Point(8, 448)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(272, 23)
        Me.Label21.TabIndex = 35
        Me.Label21.Text = "Partner hat keine Dokumente"
        Me.Label21.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        '
        'TextBox20
        '
        Me.TextBox20.BackColor = System.Drawing.Color.White
        Me.TextBox20.Location = New System.Drawing.Point(80, 320)
        Me.TextBox20.Name = "TextBox20"
        Me.TextBox20.ReadOnly = True
        Me.TextBox20.Size = New System.Drawing.Size(200, 20)
        Me.TextBox20.TabIndex = 9
        Me.TextBox20.Text = "Meier Fredy, TG1234"
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(8, 320)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(72, 24)
        Me.Label19.TabIndex = 33
        Me.Label19.Text = "Mutations-Datum"
        '
        'TextBox18
        '
        Me.TextBox18.BackColor = System.Drawing.Color.White
        Me.TextBox18.Location = New System.Drawing.Point(80, 256)
        Me.TextBox18.Name = "TextBox18"
        Me.TextBox18.ReadOnly = True
        Me.TextBox18.Size = New System.Drawing.Size(200, 20)
        Me.TextBox18.TabIndex = 7
        Me.TextBox18.Text = "Müller Hugo, TG6789"
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 256)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(72, 24)
        Me.Label17.TabIndex = 31
        Me.Label17.Text = "Kurzbez."
        '
        'Button8
        '
        Me.Button8.Location = New System.Drawing.Point(8, 480)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(128, 23)
        Me.Button8.TabIndex = 10
        Me.Button8.Text = "Partnerdossier"
        '
        'Button5
        '
        Me.Button5.Image = CType(resources.GetObject("Button5.Image"), System.Drawing.Bitmap)
        Me.Button5.Location = New System.Drawing.Point(232, 480)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(56, 23)
        Me.Button5.TabIndex = 12
        '
        'Button4
        '
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(176, 480)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(56, 23)
        Me.Button4.TabIndex = 11
        '
        'TextBox16
        '
        Me.TextBox16.BackColor = System.Drawing.Color.White
        Me.TextBox16.Location = New System.Drawing.Point(80, 288)
        Me.TextBox16.Name = "TextBox16"
        Me.TextBox16.ReadOnly = True
        Me.TextBox16.Size = New System.Drawing.Size(200, 20)
        Me.TextBox16.TabIndex = 8
        Me.TextBox16.Text = "Müller Hugo, TG6789"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 288)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(72, 24)
        Me.Label14.TabIndex = 26
        Me.Label14.Text = "Erfasser"
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.White
        Me.TextBox8.Location = New System.Drawing.Point(80, 160)
        Me.TextBox8.Multiline = True
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(200, 80)
        Me.TextBox8.TabIndex = 6
        Me.TextBox8.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 160)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(72, 23)
        Me.Label7.TabIndex = 24
        Me.Label7.Text = "Adresse"
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.White
        Me.TextBox9.Location = New System.Drawing.Point(136, 128)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(144, 20)
        Me.TextBox9.TabIndex = 5
        Me.TextBox9.Text = "Frauenfeld"
        '
        'TextBox10
        '
        Me.TextBox10.Location = New System.Drawing.Point(80, 128)
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.Size = New System.Drawing.Size(48, 20)
        Me.TextBox10.TabIndex = 4
        Me.TextBox10.Text = "8500"
        '
        'TextBox11
        '
        Me.TextBox11.BackColor = System.Drawing.Color.White
        Me.TextBox11.Location = New System.Drawing.Point(80, 104)
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.ReadOnly = True
        Me.TextBox11.Size = New System.Drawing.Size(200, 20)
        Me.TextBox11.TabIndex = 3
        Me.TextBox11.Text = "Winzerweg 12"
        '
        'TextBox12
        '
        Me.TextBox12.BackColor = System.Drawing.Color.White
        Me.TextBox12.Location = New System.Drawing.Point(80, 80)
        Me.TextBox12.Name = "TextBox12"
        Me.TextBox12.ReadOnly = True
        Me.TextBox12.Size = New System.Drawing.Size(200, 20)
        Me.TextBox12.TabIndex = 2
        Me.TextBox12.Text = "Hans"
        '
        'TextBox13
        '
        Me.TextBox13.BackColor = System.Drawing.Color.White
        Me.TextBox13.Location = New System.Drawing.Point(80, 56)
        Me.TextBox13.Name = "TextBox13"
        Me.TextBox13.ReadOnly = True
        Me.TextBox13.Size = New System.Drawing.Size(200, 20)
        Me.TextBox13.TabIndex = 1
        Me.TextBox13.Text = "Muster"
        '
        'TextBox14
        '
        Me.TextBox14.BackColor = System.Drawing.Color.White
        Me.TextBox14.Location = New System.Drawing.Point(80, 24)
        Me.TextBox14.Name = "TextBox14"
        Me.TextBox14.ReadOnly = True
        Me.TextBox14.Size = New System.Drawing.Size(200, 20)
        Me.TextBox14.TabIndex = 0
        Me.TextBox14.Text = "91004587"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 24)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(72, 23)
        Me.Label8.TabIndex = 17
        Me.Label8.Text = "Partnernr"
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(8, 128)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(72, 23)
        Me.Label9.TabIndex = 16
        Me.Label9.Text = "PLZ/Ort"
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 104)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(72, 23)
        Me.Label10.TabIndex = 15
        Me.Label10.Text = "Strasse"
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 80)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(72, 23)
        Me.Label11.TabIndex = 14
        Me.Label11.Text = "Vorname"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 56)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(72, 23)
        Me.Label12.TabIndex = 13
        Me.Label12.Text = "Name"
        '
        'btnpartnerauswahl2
        '
        Me.btnpartnerauswahl2.Image = CType(resources.GetObject("btnpartnerauswahl2.Image"), System.Drawing.Bitmap)
        Me.btnpartnerauswahl2.Location = New System.Drawing.Point(824, 8)
        Me.btnpartnerauswahl2.Name = "btnpartnerauswahl2"
        Me.btnpartnerauswahl2.Size = New System.Drawing.Size(24, 24)
        Me.btnpartnerauswahl2.TabIndex = 2
        '
        'Abbruch
        '
        Me.Abbruch.Location = New System.Drawing.Point(440, 552)
        Me.Abbruch.Name = "Abbruch"
        Me.Abbruch.Size = New System.Drawing.Size(128, 24)
        Me.Abbruch.TabIndex = 8
        Me.Abbruch.Text = "Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(592, 552)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(128, 24)
        Me.Button2.TabIndex = 7
        Me.Button2.Text = "Nicht zusammenlegen"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(736, 552)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(136, 24)
        Me.Button3.TabIndex = 5
        Me.Button3.Text = "Zusammenlegen"
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(312, 560)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.TabIndex = 5
        Me.CheckBox1.Text = "Mail an KuBe"
        Me.CheckBox1.Visible = False
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(888, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.ToolTipText = "Pendente Zusammenlegungen"
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 2
        Me.ToolBarButton3.ToolTipText = "Zusammengelegte Partner"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 3
        Me.ToolBarButton4.ToolTipText = "Ansicht schliessen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.ContextMenu = Me.ContextMenu1
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.Panel1.Location = New System.Drawing.Point(176, 552)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(112, 32)
        Me.Panel1.TabIndex = 34
        Me.Panel1.Visible = False
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7, Me.MenuItem3, Me.MenuItem2, Me.MenuItem1})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Text = "'Nicht zusammenlegen' setzen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Text = "'Nicht zusammenlegen'  zurücksetzen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 3
        Me.MenuItem1.Text = "&Ansicht schliessen"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AllowUpdate = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.Cursor = System.Windows.Forms.Cursors.Default
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines2
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = True
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(112, 32)
        Me.C1TrueDBGrid1.TabIndex = 27
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 108," & _
        " 28</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""Sty" & _
        "le10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRow" & _
        """ me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle p" & _
        "arent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingS" & _
        "tyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me=" & _
        """Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""O" & _
        "ddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /" & _
        "><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Style" & _
        "1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""" & _
        "Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foot" & _
        "er"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactiv" & _
        "e"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /" & _
        "><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" " & _
        "/><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelecto" & _
        "r"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" " & _
        "/></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modi" & _
        "fied</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 108, 2" & _
        "8</ClientArea></Blob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4, Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "Zusammenlegung rückgängig"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 1
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 2
        Me.MenuItem6.Text = "&Ansicht schliessen"
        '
        'btninaktivieren
        '
        Me.btninaktivieren.Location = New System.Drawing.Point(736, 552)
        Me.btninaktivieren.Name = "btninaktivieren"
        Me.btninaktivieren.Size = New System.Drawing.Size(136, 32)
        Me.btninaktivieren.TabIndex = 6
        Me.btninaktivieren.Text = "Partner ohne Dokumente löschen"
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(856, 8)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 35
        '
        'frmPartnerzusammenlegung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(888, 589)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.btninaktivieren, Me.Panel1, Me.btnpartnerauswahl2, Me.btnPartnerauswahl1, Me.ToolBar1, Me.CheckBox1, Me.Button3, Me.Button2, Me.Abbruch, Me.GroupBox2, Me.GroupBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPartnerzusammenlegung"
        Me.Text = "Partnerdossier-Zusammenlegung"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.Detaillist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.Panel1.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Insert_ColdUpdate Method

Public Function Insert_ColdUpdate( _
   ByVal dokumentid As String, _
   ByVal colddokumentid As String, _
   ByVal indextyp As Integer, _
   ByVal feldnr As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
colddokumentid
Required.
indextyp
Required.
feldnr
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Insert_ColdUpdate(ByVal dokumentid As String, ByVal colddokumentid As String, ByVal indextyp As Integer, ByVal feldnr As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_insert_coldupdate"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@feldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, feldnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.ListBox1_SelectedValueChanged Method

Private Sub ListBox1_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.SelectedValueChanged
        Dim s As String
        Dim i As Integer
        Dim d As DataTable
        i = Microsoft.VisualBasic.InStr(Me.ListBox1.SelectedItem, " ")
        s = Trim(Microsoft.VisualBasic.Left(Me.ListBox1.SelectedItem, i - 1))
        Me.Hostpartnernr = Val(s)
        d = Generic_Select(1)
        Me.Label20.Visible = False
        Me.Label21.Visible = False
        If d.Rows.Count > 0 Then
            If Me.Hostpartnernr < 91000000 Then
                Me.TextBox1.Text = d.Rows(0).Item("nrpar00")
                Me.Textbox2.Text = d.Rows(0).Item("namefirma")
                Me.TextBox3.Text = d.Rows(0).Item("vorname")
                Me.TextBox4.Text = d.Rows(0).Item("strasse")
                Me.TextBox5.Text = d.Rows(0).Item("plz")
                Me.TextBox6.Text = d.Rows(0).Item("ort")
                Me.TextBox15.Text = d.Rows(0).Item("bkpar00")
                Me.TextBox17.Text = d.Rows(0).Item("kube")

                Me.TextBox19.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))

                If d.Rows(0).Item("txadz012") <> "" Then
                    s = d.Rows(0).Item("txadz012") + vbCrLf + d.Rows(0).Item("txadz022") + vbCrLf + d.Rows(0).Item("txadz032") + vbCrLf + d.Rows(0).Item("txadz042") + vbCrLf + d.Rows(0).Item("txadz052") + vbCrLf + d.Rows(0).Item("txadz062") + vbCrLf + d.Rows(0).Item("txadz072") + vbCrLf
                Else
                    s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                End If
                Me.TextBox7.Text = s
                Me.Label15.Visible = True
                Me.Detaillist.Visible = True
                Me.Label16.Text = "Kunden-berater"
                Me.Label6.Text = "Inhaber-adresse"
            Else
                Me.TextBox1.Text = ""
                Me.Textbox2.Text = ""
                Me.TextBox3.Text = ""
                Me.TextBox4.Text = ""
                Me.TextBox5.Text = ""
                Me.TextBox6.Text = ""
                Me.TextBox15.Text = ""
                Me.TextBox17.Text = ""
                Me.TextBox19.Text = ""

                Me.TextBox1.Text = d.Rows(0).Item("nrpar00")
                Me.TextBox15.Text = d.Rows(0).Item("bkpar00")
                Me.Textbox2.Text = d.Rows(0).Item("txadz032")
                Me.TextBox3.Text = d.Rows(0).Item("txadz022")
                Me.TextBox5.Text = d.Rows(0).Item("TXADZ072")
                Me.TextBox6.Text = d.Rows(0).Item("beban012")
                If Len(d.Rows(0).Item("txadz062")) > 0 Then
                    Me.TextBox4.Text = d.Rows(0).Item("txadz052") + "/" + d.Rows(0).Item("txadz062")
                Else
                    Me.TextBox4.Text = d.Rows(0).Item("txadz052")
                End If
                s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                Me.TextBox7.Text = s
                Me.TextBox17.Text = d.Rows(0).Item("erfasser")
                Me.TextBox19.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))
                Me.Label15.Visible = False
                Me.Detaillist.Visible = False
                Me.Label16.Text = "Erfasser"
                Me.Label6.Text = "Adresse"
                Me.Hostpartnernr = Val(Me.TextBox1.Text)
                d = Generic_Select(18)
                If d.Rows(0).Item(0) > 0 Then Me.Label20.Visible = False Else Me.Label20.Visible = True
            End If
            d = Generic_Select(2)
            If Me.Detaillist.Visible Then
                Me.Detaillist.DataSource = d
                Me.Detaillist.DataMember = d.TableName
                Me.Detaillist.Splits(0).DisplayColumns(0).Width = ((Me.Detaillist.Width / 3) * 1) - 4
                Me.Detaillist.Splits(0).DisplayColumns(1).Width = ((Me.Detaillist.Width / 3) * 2) - 4
            End If

            EDOKApartner = Generic_Select(3)
            Update_EDOKA_Partner(0)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Me.Panel1.Dock = DockStyle.None
        Me.Panel1.Visible = False
        Me.Refresh_All()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Dim i As Integer
        i = Me.C1TrueDBGrid1.Bookmark
        Me.eintragnr = Me.C1TrueDBGrid1.Columns("nr").Value
        Generic_Select(12)
        Refresh_daten_1()
        Me.C1TrueDBGrid1.Bookmark = i

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim doks As DataTable
        Dim dat As DataTable
        Dim i As Integer
        Dim i1 As Integer
        If MyMsg.Show_MessageYesNo(252) = MsgBoxResult.No Then Exit Sub
        Me.Hostpartnernr = Me.C1TrueDBGrid1.Columns(1).Value
        Me.EdokaPartnernr = Me.C1TrueDBGrid1.Columns(3).Value
        doks = Generic_Select(14)
        dat = Generic_Select(15)
        Me.kurzname = dat.Rows(0).Item("bkpar00")
        Me.ort = dat.Rows(0).Item("beortpt")

        For i = 0 To doks.Rows.Count - 1
            dokumentid = doks.Rows(i).Item("dokumentid")
            dokumente = get_dokumente()
            For i1 = 0 To dokumente.Rows.Count - 1
                Update_Partnernr(dokumentid, Me.EdokaPartnernr)
                Update_vvnr(dokumentid, "")
            Next
            Generic_Select(16)
            'Partner umhängen
            Try
                Dim d As New edokadb.clsDokument()
                d.cpMainConnectionProvider = Globals.conn
                d.sDokumentid = New SqlString(CType(dokumentid, String))
                d.SelectOne()
                d.iNrpar00 = New SqlInt32(CType(Me.EdokaPartnernr, Int32))
                conn.OpenConnection()
                d.Update()
                conn.CloseConnection(True)
                d.Dispose()
            Catch
            End Try
        Next
        Generic_Select(17)
        MyMsg.show_standardmessage_ReplaceText(253, MsgBoxStyle.Information, Trim(Str(doks.Rows.Count)), "")
        Me.Refresh_Daten_2()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Me.Panel1.Dock = DockStyle.None
        Me.Panel1.Visible = False
        Me.Refresh_All()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Dim i As Integer
        i = Me.C1TrueDBGrid1.Bookmark
        Me.eintragnr = Me.C1TrueDBGrid1.Columns("nr").Value
        Generic_Select(13)
        Refresh_daten_1()
        Me.C1TrueDBGrid1.Bookmark = i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Refresh_All Method

Public Sub Refresh_All()

Source code

[Visual Basic]
    Public Sub Refresh_All()
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            Me.btnPartnerauswahl1.Visible = True
            Me.btnpartnerauswahl2.Visible = True
            Me.ToolBarButton2.Visible = True
            Me.ToolBarButton3.Visible = True
            Me.ToolBarButton4.Visible = True

        Else
            Me.btnPartnerauswahl1.Visible = False
            Me.btnpartnerauswahl2.Visible = False
            Me.ToolBarButton2.Visible = False
            Me.ToolBarButton3.Visible = False
            Me.ToolBarButton4.Visible = False
        End If
        Me.TextBox1.Text = ""
        Me.Textbox2.Text = ""
        Me.TextBox3.Text = ""
        Me.TextBox4.Text = ""
        Me.TextBox5.Text = ""
        Me.TextBox6.Text = ""
        Me.TextBox15.Text = ""
        Me.TextBox17.Text = ""
        Me.TextBox7.Text = ""
        Me.TextBox19.Text = ""

        Dim d As DataTable
        Dim i As Integer
        Dim s As String
        Me.ListBox1.Items.Clear()
        Me.DoAbend = False
        d = Generic_Select(0)
        If DoAbend Then
            Me.Hide()
            Exit Sub
        End If
        For i = 0 To d.Rows.Count - 1
            Me.ListBox1.Items.Add(Trim(Str(d.Rows(i).Item(0))) + " " + d.Rows(i).Item(1))
        Next
        If i > 0 Then
            Me.ListBox1.SelectedIndex = 0
        End If
        Me.Cursor = Cursors.Default
        Me.Refresh()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Refresh_Daten_2 Method

Private Sub Refresh_Daten_2()

Source code

[Visual Basic]
    Private Sub Refresh_Daten_2()
        Dim i As Integer
        Me.C1TrueDBGrid1.BeginInit()
        Me.Panel1.Visible = True
        Me.Panel1.Dock = DockStyle.Fill
        Me.btnPartnerauswahl1.Visible = False
        Me.btnpartnerauswahl2.Visible = False
        Dim d As DataTable
        d = Generic_Select(11)
        Me.C1TrueDBGrid1.DataSource = d
        Me.C1TrueDBGrid1.DataMember = d.TableName
        For i = 0 To Me.C1TrueDBGrid1.Splits(0).DisplayColumns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
        Me.C1TrueDBGrid1.Columns(9).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.C1TrueDBGrid1.EndInit()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Refresh_daten_1 Method

Private Sub Refresh_daten_1()

Source code

[Visual Basic]
    Private Sub Refresh_daten_1()
        Dim i As Integer
        Me.C1TrueDBGrid1.BeginInit()
        Me.Panel1.Visible = True
        Me.Panel1.Dock = DockStyle.Fill
        Me.btnPartnerauswahl1.Visible = False
        Me.btnpartnerauswahl2.Visible = False
        Dim d As DataTable
        d = Generic_Select(10)
        Me.C1TrueDBGrid1.DataSource = d
        Me.C1TrueDBGrid1.DataMember = d.TableName
        For i = 0 To Me.C1TrueDBGrid1.Splits(0).DisplayColumns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
        Me.C1TrueDBGrid1.Columns(5).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.C1TrueDBGrid1.Columns(9).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.C1TrueDBGrid1.EndInit()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Hide()
            Case 1
                Refresh_daten_1()
                Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
            Case 2
                refresh_daten_2()
                Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu2
            Case 3
                Me.Panel1.Dock = DockStyle.None
                Me.Panel1.Visible = False
                Me.Refresh_All()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Update_DokumentColdIndexwert Method

Public Function Update_DokumentColdIndexwert( _
   ByVal dokumentid As String, _
   ByVal Indextyp As Integer, _
   ByVal indexfeld As Integer, _
   ByVal wert As String _
)

Parameters

dokumentid
Required.
Indextyp
Required.
indexfeld
Required.
wert
Required.

Source code

[Visual Basic]
    Public Function Update_DokumentColdIndexwert(ByVal dokumentid As String, ByVal Indextyp As Integer, ByVal indexfeld As Integer, ByVal wert As String)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Archiv_Update_DokumentColdIndexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        conn.OpenConnection()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Indextyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexfeld))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@wert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Update_EDOKA_Partner Method

Private Function Update_EDOKA_Partner( _
   ByVal rowid As Integer _
)

Parameters

rowid
Required.

Source code

[Visual Basic]
    Private Function Update_EDOKA_Partner(ByVal rowid As Integer)
        Dim s As String
        Dim d As DataTable
        Me.TextBox14.Text = ""
        Me.TextBox13.Text = ""
        Me.TextBox12.Text = ""
        Me.TextBox11.Text = ""
        Me.TextBox10.Text = ""
        Me.TextBox9.Text = ""
        Me.TextBox8.Text = ""
        Me.TextBox18.Text = ""
        Me.TextBox16.Text = ""
        Me.TextBox20.Text = ""

        If EDOKApartner.Rows.Count - 1 >= rowid Then
            Me.TextBox14.Text = EDOKApartner.Rows(rowid).Item("nrpar00")
            Me.TextBox18.Text = EDOKApartner.Rows(rowid).Item("bkpar00")
            Me.TextBox13.Text = EDOKApartner.Rows(rowid).Item("txadz032")
            Me.TextBox12.Text = EDOKApartner.Rows(rowid).Item("txadz022")
            Me.TextBox10.Text = EDOKApartner.Rows(rowid).Item("TXADZ072")
            Me.TextBox9.Text = EDOKApartner.Rows(rowid).Item("beban012")
            Try
                If Len(EDOKApartner.Rows(rowid).Item("txadz062")) > 0 Then
                    Me.TextBox11.Text = EDOKApartner.Rows(rowid).Item("txadz052") + "/" + EDOKApartner.Rows(rowid).Item("txadz062")
                Else
                    Me.TextBox11.Text = EDOKApartner.Rows(rowid).Item("txadz052")
                End If
            Catch ex As Exception
                Me.TextBox11.Text = EDOKApartner.Rows(rowid).Item("txadz052")
            End Try
            Me.TextBox16.Text = EDOKApartner.Rows(rowid).Item("erfasser")
            Me.TextBox20.Text = FormatTimeStamp(EDOKApartner.Rows(rowid).Item("tsmut00"))
            s = EDOKApartner.Rows(rowid).Item("txadz011") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz021") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz031") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz041") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz051") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz061") + vbCrLf + EDOKApartner.Rows(rowid).Item("txadz071") + vbCrLf
            Me.TextBox8.Text = s

            Me.EdokaPartnernr = Val(Me.TextBox14.Text)
            d = Generic_Select(19)
            If d.Rows(0).Item(0) > 0 Then Me.Label21.Visible = False Else Me.Label21.Visible = True
        End If
        Currentrow = rowid
        Me.Button5.Enabled = False
        Me.Button4.Enabled = False
        If EDOKApartner.Rows.Count - 1 > rowid Then
            Me.Button5.Enabled = True
        End If
        If rowid > 0 Then Me.Button4.Enabled = True
        If Me.Label20.Visible Or Me.Label21.Visible Then Me.btninaktivieren.visible = True Else Me.btninaktivieren.visible = False

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Update_Partnernr Method

Public Sub Update_Partnernr( _
   ByVal dokumentid As String, _
   ByVal partnernr As String _
)

Parameters

dokumentid
Required.
partnernr
Required.

Source code

[Visual Basic]
    Public Sub Update_Partnernr(ByVal dokumentid As String, ByVal partnernr As String)
        'ort = get_data("&PartnerInhaberOrt&")
        Dim i As Integer
        Dim s As String
        s = Trim(partnernr)
        While Len(s) < 9
            s = "0" + s
        End While
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 1, s)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 1, s)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 2, kurzname)
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 8, ort)
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 8, ort)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.Update_vvnr Method

Public Sub Update_vvnr( _
   ByVal dokumentid As String, _
   ByVal vvnr As String _
)

Parameters

dokumentid
Required.
vvnr
Required.

Source code

[Visual Basic]
    Public Sub Update_vvnr(ByVal dokumentid As String, ByVal vvnr As String)
        Dim i As Integer
        For i = 0 To Me.dokumente.Rows.Count - 1
            Insert_ColdUpdate(dokumentid, RTrim(dokumente.Rows(i).Item("wert")), dokumente.Rows(i).Item("indextyp"), 3, "")
            Update_DokumentColdIndexwert(dokumentid, dokumente.Rows(i).Item("indextyp"), 3, "")
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.btnDossierHaupt_Click Method

Private Sub btnDossierHaupt_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnDossierHaupt.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnDossierHaupt_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnDossierHaupt.Click
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.txtnrpar00.Text = Me.TextBox1.Text
        f.Partnernr = Me.TextBox1.Text
        f.Partner_Eingegeben = True
        f.refresh_list()
        f.Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.btnPartnerauswahl1_Click Method

Private Sub btnPartnerauswahl1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerauswahl1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerauswahl1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerauswahl1.Click
        Dim f As New FrmPartnersuche()
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.TextBox1.Text = f.PartnerNr
        Else
            f.Dispose()
            Exit Sub
        End If
        f.Dispose()

        Dim s As String
        Dim i As Integer
        Dim d As DataTable
        Me.Hostpartnernr = Val(Me.TextBox1.Text)
        d = Generic_Select(22)
        If d.Rows.Count > 0 Then
            If Me.Hostpartnernr < 91000000 Then
                Me.TextBox1.Text = d.Rows(0).Item("nrpar00")
                Me.Textbox2.Text = d.Rows(0).Item("namefirma")
                Me.TextBox3.Text = d.Rows(0).Item("vorname")
                Me.TextBox4.Text = d.Rows(0).Item("strasse")
                Me.TextBox5.Text = d.Rows(0).Item("plz")
                Me.TextBox6.Text = d.Rows(0).Item("ort")
                Me.TextBox15.Text = d.Rows(0).Item("bkpar00")
                Me.TextBox17.Text = d.Rows(0).Item("kube")
                Me.TextBox19.Text = ""

                If d.Rows(0).Item("txadz012") <> "" Then
                    s = d.Rows(0).Item("txadz012") + vbCrLf + d.Rows(0).Item("txadz022") + vbCrLf + d.Rows(0).Item("txadz032") + vbCrLf + d.Rows(0).Item("txadz042") + vbCrLf + d.Rows(0).Item("txadz052") + vbCrLf + d.Rows(0).Item("txadz062") + vbCrLf + d.Rows(0).Item("txadz072") + vbCrLf
                Else
                    s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                End If
                Me.TextBox19.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))
                Me.TextBox7.Text = s
                Me.Label15.Visible = True
                Me.Detaillist.Visible = True
                Me.Label16.Text = "Kunden-berater"
                Me.Label6.Text = "Inhaber-adresse"
            Else
                Me.TextBox1.Text = ""
                Me.Textbox2.Text = ""
                Me.TextBox3.Text = ""
                Me.TextBox4.Text = ""
                Me.TextBox5.Text = ""
                Me.TextBox6.Text = ""
                Me.TextBox15.Text = ""
                Me.TextBox17.Text = ""
                Me.TextBox19.Text = ""

                Me.TextBox1.Text = d.Rows(0).Item("nrpar00")
                Me.TextBox15.Text = d.Rows(0).Item("bkpar00")
                Me.Textbox2.Text = d.Rows(0).Item("txadz032")
                Me.TextBox3.Text = d.Rows(0).Item("txadz022")
                Me.TextBox5.Text = d.Rows(0).Item("TXADZ072")
                Me.TextBox6.Text = d.Rows(0).Item("beban012")
                If Len(d.Rows(0).Item("txadz062")) > 0 Then
                    Me.TextBox4.Text = d.Rows(0).Item("txadz052") + "/" + d.Rows(0).Item("txadz062")
                Else
                    Me.TextBox4.Text = d.Rows(0).Item("txadz052")
                End If
                s = d.Rows(0).Item("txadz011") + vbCrLf + d.Rows(0).Item("txadz021") + vbCrLf + d.Rows(0).Item("txadz031") + vbCrLf + d.Rows(0).Item("txadz041") + vbCrLf + d.Rows(0).Item("txadz051") + vbCrLf + d.Rows(0).Item("txadz061") + vbCrLf + d.Rows(0).Item("txadz071") + vbCrLf
                Me.TextBox7.Text = s
                Me.TextBox17.Text = d.Rows(0).Item("erfasser")
                Me.TextBox19.Text = FormatTimeStamp(d.Rows(0).Item("tsmut00"))
                Me.Label15.Visible = False
                Me.Detaillist.Visible = False
                Me.Label16.Text = "Erfasser"
                Me.Label6.Text = "Adresse"
                Me.Hostpartnernr = Val(Me.TextBox1.Text)
                d = Generic_Select(18)
                If d.Rows(0).Item(0) > 0 Then Me.Label20.Visible = False Else Me.Label20.Visible = True

            End If
            d = Generic_Select(2)
            If Me.Detaillist.Visible Then
                Me.Detaillist.DataSource = d
                Me.Detaillist.DataMember = d.TableName
                Me.Detaillist.Splits(0).DisplayColumns(0).Width = ((Me.Detaillist.Width / 3) * 1) - 4
                Me.Detaillist.Splits(0).DisplayColumns(0).Width = ((Me.Detaillist.Width / 3) * 2) - 4
            End If

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.btninaktivieren_Click Method

Private Sub btninaktivieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btninaktivieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btninaktivieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btninaktivieren.Click
        Dim i As Integer
        If Me.Label20.Visible Then
            Me.Hostpartnernr = Val(Me.TextBox1.Text)
            Generic_Select(20)
        End If
        If Me.Label21.Visible Then
            Me.EdokaPartnernr = Val(Me.TextBox14.Text)
            Generic_Select(21)
        End If
        i = Me.ListBox1.SelectedIndex
        Me.Refresh_All()
        Try
            Me.ListBox1.SelectedIndex = i
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.frmPartnerzusammenlegung_Closing Method

Private Sub frmPartnerzusammenlegung_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerzusammenlegung_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        e.Cancel = True
        Me.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.frmPartnerzusammenlegung_Load Method

Private Sub frmPartnerzusammenlegung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerzusammenlegung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.frmPartnerzusammenlegung_Resize Method

Private Sub frmPartnerzusammenlegung_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerzusammenlegung_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.frmPartnerzusammenlegung_VisibleChanged Method

Private Sub frmPartnerzusammenlegung_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.VisibleChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPartnerzusammenlegung_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.VisibleChanged
        If Me.Label20.Visible Or Me.Label21.Visible Then Me.btninaktivieren.Visible = True Else Me.btninaktivieren.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.get_data Method

Private Function get_data( _
   ByVal datenherkunft As String _
) As String

Parameters

datenherkunft
Required.

Source code

[Visual Basic]
    Private Function get_data(ByVal datenherkunft As String) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentwerte_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, datenherkunft))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@value").Value
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung.get_dokumente Method

Private Function get_dokumente() As DataTable

Source code

[Visual Basic]
    Private Function get_dokumente() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_indexmutation_getdokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumentid))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPartnerzusammenlegung Fields

frmPartnerzusammenlegung overview

Fields

field Abbruch
field BtnHelp
field Button2
field Button3
field Button4
field Button5
field Button7
field Button8
field C1TrueDBGrid1
field CheckBox1
field ContextMenu1
field ContextMenu2
field Currentrow
field Detaillist
field DoAbend
field EDOKApartner
field EdokaPartnernr
field GroupBox1
field GroupBox2
field GroupBox3
field Hostpartnernr
field ImageList1
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field ListBox1
field MenuItem1
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field Panel1
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox19
field TextBox20
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field Textbox2
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field btnDossierHaupt
field btnPartnerauswahl1
field btninaktivieren
field btnpartnerauswahl2
field components
field dokumente
field dokumentid
field eintragnr
field kurzname
field ort
field tsm

See Also

frmPartnerzusammenlegung Class


Abbruch Variable

Friend WithEvents Abbruch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Abbruch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Currentrow Variable

Dim Currentrow As Integer

Source code

[Visual Basic]
    Dim Currentrow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Detaillist Variable

Friend WithEvents Detaillist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Detaillist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


DoAbend Variable

Dim DoAbend As Boolean = False

Source code

[Visual Basic]
    Dim DoAbend As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


EDOKApartner Variable

Dim EDOKApartner As DataTable

Source code

[Visual Basic]
    Dim EDOKApartner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


EdokaPartnernr Variable

Dim EdokaPartnernr As Integer

Source code

[Visual Basic]
    Dim EdokaPartnernr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Hostpartnernr Variable

Dim Hostpartnernr As Integer

Source code

[Visual Basic]
    Dim Hostpartnernr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox11 Variable

Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox12 Variable

Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox13 Variable

Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox14 Variable

Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox15 Variable

Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox16 Variable

Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox17 Variable

Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox18 Variable

Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox19 Variable

Friend WithEvents TextBox19 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox19 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox20 Variable

Friend WithEvents TextBox20 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox20 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


Textbox2 Variable

Friend WithEvents Textbox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents Textbox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


btnDossierHaupt Variable

Friend WithEvents btnDossierHaupt As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnDossierHaupt As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


btnPartnerauswahl1 Variable

Friend WithEvents btnPartnerauswahl1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerauswahl1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


btninaktivieren Variable

Friend WithEvents btninaktivieren As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btninaktivieren As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


btnpartnerauswahl2 Variable

Friend WithEvents btnpartnerauswahl2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnpartnerauswahl2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


dokumente Variable

Dim dokumente As New DataTable()

Source code

[Visual Basic]
    Dim dokumente As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


dokumentid Variable

Dim dokumentid As String

Source code

[Visual Basic]
    Dim dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


eintragnr Variable

Dim eintragnr As Integer

Source code

[Visual Basic]
    Dim eintragnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


kurzname Variable

Dim kurzname As String

Source code

[Visual Basic]
    Dim kurzname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


ort Variable

Dim ort As String

Source code

[Visual Basic]
    Dim ort As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


tsm Variable

Dim tsm As String

Source code

[Visual Basic]
    Dim tsm As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerzusammenlegung


frmPasswort Class

For a list of all members of this type, see frmPasswort Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmPasswort

Public Class frmPasswort
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmPasswort Members


frmPasswort Members

frmPasswort overview

Constructors

constructor frmPasswort Constructor

Properties

property isok

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method PasswortText_KeyDown
method PasswortText_TextChanged
method frmPasswort_Load

Fields

field Button1
field Button2
field Label1
field PasswortText
field components
field m_isok

See Also

frmPasswort Class


frmPasswort Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort Properties

frmPasswort overview

Properties

property isok

See Also

frmPasswort Class


frmPasswort.isok Property

Property isok() As Boolean

Source code

[Visual Basic]
    Property isok() As Boolean
        Get
            Return m_isok
        End Get
        Set(ByVal Value As Boolean)
            m_isok = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort Methods

frmPasswort overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method PasswortText_KeyDown
method PasswortText_TextChanged
method frmPasswort_Load

See Also

frmPasswort Class


frmPasswort.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.OK
        isok = True
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        isok = False
        Me.DialogResult = DialogResult.Abort
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmPasswort))
        Me.PasswortText = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'PasswortText
        '
        Me.PasswortText.Location = New System.Drawing.Point(72, 24)
        Me.PasswortText.Name = "PasswortText"
        Me.PasswortText.PasswordChar = Microsoft.VisualBasic.ChrW(42)
        Me.PasswortText.Size = New System.Drawing.Size(144, 20)
        Me.PasswortText.TabIndex = 0
        Me.PasswortText.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(56, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Passwort:"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(32, 72)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&OK"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(144, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&Abbruch"
        '
        'frmPasswort
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(240, 117)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label1, Me.PasswortText})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmPasswort"
        Me.Text = "Passwort"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.PasswortText_KeyDown Method

Private Sub PasswortText_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles PasswortText.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PasswortText_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles PasswortText.KeyDown
        If e.KeyCode = Keys.Enter Then Me.Button1_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.PasswortText_TextChanged Method

Private Sub PasswortText_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles PasswortText.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PasswortText_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PasswortText.TextChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort.frmPasswort_Load Method

Private Sub frmPasswort_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPasswort_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmPasswort Fields

frmPasswort overview

Fields

field Button1
field Button2
field Label1
field PasswortText
field components
field m_isok

See Also

frmPasswort Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


PasswortText Variable

Friend WithEvents PasswortText As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents PasswortText As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


m_isok Variable

Dim m_isok As Boolean

Source code

[Visual Basic]
    Dim m_isok As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPasswort


frmProfil Class

For a list of all members of this type, see frmProfil Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmProfil

Public Class frmProfil
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmProfil Members


frmProfil Members

frmProfil overview

Constructors

constructor frmProfil Constructor

Properties

property ProfilNr
property Profile_Geaendert

Methods

method Activate_Details
method BtnHelp_Click
method Button10_Click
method Button11_Click
method Button12_Click
method Button13_Click
method Button14_Click
method Button15_Click
method Button15_Click_1
method Button16_Click
method Button17_Click
method Button18_Click
method Button19_Click
method Button1_Click
method Button1_Click_1
method Button20_Click
method Button21_Click
method Button22_Click
method Button23_Click
method Button24_Click
method Button25_Click
method Button26_Click
method Button27_Click
method Button28_Click
method Button29_Click
method Button2_Click_1
method Button3_Click_1
method Button5_Click
method Button9_Click
method Button9_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method ContextMenu2_Popup
method Convert_Seldate_bis
method Convert_Seldate_von
method CutDate
method DateTimePicker13_ValueChanged
method DateTimePicker14_ValueChanged
method DateTimePicker15_ValueChanged
method DateTimePicker16_ValueChanged
method DateTimePicker17_ValueChanged
method DateTimePicker18_ValueChanged
method DateTimePicker19_ValueChanged
method DateTimePicker1_Enter
method DateTimePicker1_ValueChanged
method DateTimePicker20_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker7_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method InitializeComponent
method Insertitem
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem19_Click
method MenuItem20_Click
method MenuItem21_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method PartnerSuchResultat
method Profil_Colors
method Profile_AfterSelect
method Profile_MouseDown
method Remove_Selected_Items
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_MouseDown
method TabControl2_SelectedIndexChanged
method TabPagesClear
method TextBox1_KeyDown
method TextBox4_KeyDown
method TextBox5_KeyDown
method TextBox6_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method TreeView1_Click
method Treeview1_MouseDown
method Treeview1_Mouseup
method ValueList
method btnPartnersuche_Click
method btnzvauftragsnr_Click
method cbrollend1_CheckedChanged
method check_changes
method cinklalt_CheckedChanged
method cinklaltversant_CheckedChanged
method del_entry
method frmProfil_Closing
method frmProfil_Load
method frmProfil_Resize
method init_datumzvuvm
method init_profile
method init_treeview1
method lbselect_DoubleClick
method lbsortfields_DoubleClick
method mcb_Changed
method nodeswithdata
method plausi_edoka
method plausi_host
method reset_color
method reset_dokart
method set_tips
method showhidetv
method txtdatum1_TextChanged
method txtuvmauftrag_KeyDown
method txtzvauftraggeber_KeyDown
method txtzvauftragsnr_KeyDown
method txtzvbeguenstigter_KeyDown
method txtzvbetrag_KeyDown
method txtzvclearingnr_KeyDown
method txtzviso_KeyDown
method txtzvpcnr_KeyDown
method txtzvpostennr_KeyDown
method txtzvreferenznr_KeyDown
method txtzvswift_KeyDown
method txtzvverarbeitungsart_KeyDown
method txtzvzahlungsart_KeyDown

Fields

field ActiveList
field BtnHelp
field Button1
field Button10
field Button11
field Button12
field Button13
field Button14
field Button15
field Button16
field Button17
field Button18
field Button19
field Button2
field Button20
field Button21
field Button22
field Button23
field Button24
field Button25
field Button26
field Button27
field Button28
field Button29
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field C1TrueDBGrid1
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox3
field CheckBox4
field CheckBox5
field ColorDialog1
field ComboBox10
field ComboBox6
field ComboBox9
field ContextMenu1
field ContextMenu2
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker13
field DateTimePicker14
field DateTimePicker15
field DateTimePicker16
field DateTimePicker17
field DateTimePicker18
field DateTimePicker19
field DateTimePicker2
field DateTimePicker20
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field DatumHostText1
field DatumHostText2
field FirstNodeWithData
field GroupBox1
field GroupBox10
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox2
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox9
field Groupbox3
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field LBSelectHost
field LBSort
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label40
field Label41
field Label42
field Label43
field Label44
field Label45
field Label46
field Label47
field Label48
field Label49
field Label5
field Label50
field Label51
field Label52
field Label53
field Label54
field Label55
field Label56
field Label57
field Label58
field Label59
field Label6
field Label60
field Label61
field Label62
field Label63
field Label64
field Label65
field Label66
field Label7
field Label8
field Label9
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PartnerList
field Partnerdialog
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPage5
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field TreeView2
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field btnini
field btnzvauftraggeber
field btnzvauftragsnr
field btnzvbeguenstiger
field btnzvbetrag
field btnzvclearing
field btnzviso
field btnzvpcnr
field btnzvposten
field btnzvreferenz
field btnzvswift
field btnzvverarbeitungsart
field btnzvzahlungsart
field cb1
field cb2
field cb3
field cb3_1
field cb4
field cb5
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbd2
field cbd4
field cbd6
field cbmavip
field cbrollend1
field cbrollend2
field cbrollend3
field cbrollend4
field cbrollend5
field cbrollend6
field cbrollend8
field cbrollend9
field cbteam
field cbuvmrollend1
field cbuvmrollend2
field cbuvmrollend3
field cbuvmrollend4
field cbzvrollend1
field cbzvrollend2
field cbzvrollend3
field cbzvrollend4
field changes
field checkchanges
field cinklalt
field cinklaltversant
field colbtn1
field colbtn2
field colbtn3
field colbtn4
field colbtn5
field colbtn6
field colconv
field components
field ctmenu1
field datumtext1
field datumtext2
field datumtext3
field datumtext4
field datumtext5
field datumtext6
field dokumentart
field expandzv
field first
field hostinklmavip
field i
field ifirst
field lbSortfields
field lbentry
field lblhostdatum2
field lblhostdatum3
field lblhostdatum31
field lbselect
field li
field m_profile_geaendert
field m_profilnr
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field oninit
field partner
field pnlhostdiv
field pnluvm
field pnlzv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tdtzv
field textdatum1uvm
field textdatum1zv
field textdatum2uvm
field textdatum2zv
field textdatum3uvm
field textdatum3zv
field textdatum4uvm
field textdatum4zv
field tko
field tku
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum1uvm
field txtdatum1zv
field txtdatum2
field txtdatum2uvm
field txtdatum2zv
field txtdatum3
field txtdatum3uvm
field txtdatum3zv
field txtdatum4
field txtdatum4uvm
field txtdatum4zv
field txtdatum5
field txtdatum6
field txtuvmauftragnr
field txtzvauftraggeber
field txtzvauftragsnr
field txtzvbeguenstigter
field txtzvbetrag
field txtzvclearingnr
field txtzviso
field txtzvpcnr
field txtzvpostennr
field txtzvreferenznr
field txtzvswift
field txtzvverarbeitungsart
field txtzvzahlungsart

See Also

frmProfil Class


frmProfil Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil Properties

frmProfil overview

Properties

property ProfilNr
property Profile_Geaendert

See Also

frmProfil Class


frmProfil.ProfilNr Property

Property ProfilNr() As Integer

Source code

[Visual Basic]
    Property ProfilNr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Profile_Geaendert Property

Property Profile_Geaendert() As Boolean

Source code

[Visual Basic]
    Property Profile_Geaendert() As Boolean
        Get
            Return m_profile_geaendert
        End Get
        Set(ByVal Value As Boolean)
            m_profile_geaendert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil Methods

frmProfil overview

Methods

method Activate_Details
method BtnHelp_Click
method Button10_Click
method Button11_Click
method Button12_Click
method Button13_Click
method Button14_Click
method Button15_Click
method Button15_Click_1
method Button16_Click
method Button17_Click
method Button18_Click
method Button19_Click
method Button1_Click
method Button1_Click_1
method Button20_Click
method Button21_Click
method Button22_Click
method Button23_Click
method Button24_Click
method Button25_Click
method Button26_Click
method Button27_Click
method Button28_Click
method Button29_Click
method Button2_Click_1
method Button3_Click_1
method Button5_Click
method Button9_Click
method Button9_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method ContextMenu2_Popup
method Convert_Seldate_bis
method Convert_Seldate_von
method CutDate
method DateTimePicker13_ValueChanged
method DateTimePicker14_ValueChanged
method DateTimePicker15_ValueChanged
method DateTimePicker16_ValueChanged
method DateTimePicker17_ValueChanged
method DateTimePicker18_ValueChanged
method DateTimePicker19_ValueChanged
method DateTimePicker1_Enter
method DateTimePicker1_ValueChanged
method DateTimePicker20_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker7_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method InitializeComponent
method Insertitem
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem19_Click
method MenuItem20_Click
method MenuItem21_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method PartnerSuchResultat
method Profil_Colors
method Profile_AfterSelect
method Profile_MouseDown
method Remove_Selected_Items
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_MouseDown
method TabControl2_SelectedIndexChanged
method TabPagesClear
method TextBox1_KeyDown
method TextBox4_KeyDown
method TextBox5_KeyDown
method TextBox6_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method TreeView1_Click
method Treeview1_MouseDown
method Treeview1_Mouseup
method ValueList
method btnPartnersuche_Click
method btnzvauftragsnr_Click
method cbrollend1_CheckedChanged
method check_changes
method cinklalt_CheckedChanged
method cinklaltversant_CheckedChanged
method del_entry
method frmProfil_Closing
method frmProfil_Load
method frmProfil_Resize
method init_datumzvuvm
method init_profile
method init_treeview1
method lbselect_DoubleClick
method lbsortfields_DoubleClick
method mcb_Changed
method nodeswithdata
method plausi_edoka
method plausi_host
method reset_color
method reset_dokart
method set_tips
method showhidetv
method txtdatum1_TextChanged
method txtuvmauftrag_KeyDown
method txtzvauftraggeber_KeyDown
method txtzvauftragsnr_KeyDown
method txtzvbeguenstigter_KeyDown
method txtzvbetrag_KeyDown
method txtzvclearingnr_KeyDown
method txtzviso_KeyDown
method txtzvpcnr_KeyDown
method txtzvpostennr_KeyDown
method txtzvreferenznr_KeyDown
method txtzvswift_KeyDown
method txtzvverarbeitungsart_KeyDown
method txtzvzahlungsart_KeyDown

See Also

frmProfil Class


frmProfil.Activate_Details Method

Private Sub Activate_Details()

Source code

[Visual Basic]
    Private Sub Activate_Details()
        Me.TreeView1.SelectedNode = Nothing
        If Me.FirstNodeWithData Is Nothing Then
            DivFnkt.Searchnode1(Me.TreeView1, 41, 99)
            If DivFnkt.found Then
                'If colconv.ConvertToString(DivFnkt.FoundNode.ForeColor) = colconv.ConvertToString(System.Drawing.Color.Blue) Then
                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                'Me.PnlDokumentart.Visible = True
                'End If
            End If
        Else
            Me.TreeView1.SelectedNode = Me.FirstNodeWithData
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("profilverwaltung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button10_Click Method

Private Sub Button10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button10.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 58, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox5.Text)
                tn1.Tag = Me.TextBox5.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox5.Text = ""
                Me.changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button11_Click Method

Private Sub Button11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button11.Click
        Button15_Click_1(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button12_Click Method

Private Sub Button12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button12.Click
        Me.txtdatum1.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button13_Click Method

Private Sub Button13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button13.Click
        Me.txtdatum2.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button14_Click Method

Private Sub Button14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button14.Click
        Me.txtdatum3.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button15_Click Method

Private Sub Button15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button15.Click
        Me.txtdatum4.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button15_Click_1 Method

Private Sub Button15_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button15_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            If Me.lbSortfields.SelectedItems.Count > 0 Then
                If Me.LBSelectHost.Visible = True Then
                    Me.LBSelectHost.Items.Add(Me.lbSortfields.SelectedItem + " | " + Me.LBSort.SelectedItem)
                    Me.lbSortfields.Items.RemoveAt(Me.lbSortfields.SelectedIndex)
                Else
                    Me.lbselect.Items.Add(Me.lbSortfields.SelectedItem + " | " + Me.LBSort.SelectedItem)
                    Me.lbSortfields.Items.RemoveAt(Me.lbSortfields.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button16_Click Method

Private Sub Button16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button16.Click
        Me.txtdatum5.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button17_Click Method

Private Sub Button17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button17.Click
        Me.txtdatum6.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button18_Click Method

Private Sub Button18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button18.Click
        Me.HostDatum2.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button19_Click Method

Private Sub Button19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button19.Click
        Me.HostDatum1.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles colbtn6.Click, _
   colbtn5.Click, _
   colbtn4.Click, _
   colbtn3.Click, _
   colbtn2.Click, _
   colbtn1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles colbtn6.Click, colbtn5.Click, colbtn4.Click, colbtn3.Click, colbtn2.Click, colbtn1.Click
        Dim cName As String = CType(sender, System.Windows.Forms.Button).Name
        If Me.ColorDialog1.ShowDialog() = DialogResult.Cancel Then Exit Sub

        Me.ColorDialog1.AnyColor = True
        Button5_Click(sender, e)
        Select Case cName
            Case "colbtn1"
                Me.colbtn1.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn2"
                Me.colbtn2.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn3"
                Me.colbtn3.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn4"
                Me.colbtn4.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn5"
                Me.colbtn5.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn6"
                Me.colbtn6.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.txtdatum1.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button20_Click Method

Private Sub Button20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button20.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 54, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox6.Text)
                tn1.Tag = Me.TextBox6.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox6.Text = ""
                Me.changes = True

            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button21_Click Method

Private Sub Button21_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button21_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button21.Click
        Me.txtdatum4zv.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button22_Click Method

Private Sub Button22_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button22.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button22_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button22.Click
        Me.txtdatum2zv.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button23_Click Method

Private Sub Button23_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button23.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button23_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button23.Click
        Me.txtdatum3zv.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button24_Click Method

Private Sub Button24_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button24.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button24_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button24.Click
        Me.txtdatum1zv.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button25_Click Method

Private Sub Button25_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button25.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button25_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button25.Click
        Me.txtdatum4uvm.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button26_Click Method

Private Sub Button26_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button26.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button26_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button26.Click
        Me.txtdatum2uvm.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button27_Click Method

Private Sub Button27_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button27.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button27_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button27.Click
        Me.txtdatum3uvm.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button28_Click Method

Private Sub Button28_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button28.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button28_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button28.Click
        Me.txtdatum1uvm.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button29_Click Method

Private Sub Button29_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button29.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button29_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button29.Click
        Dim tn As New TreeNode()
        Dim tn1 As New TreeNode()
        Try
            DivFnkt.Searchnode1(Me.TreeView1, 93, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.txtuvmauftragnr.Text)
                tn1.Tag = Me.txtuvmauftragnr.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.txtuvmauftragnr.Text = ""
                Me.changes = True
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button2_Click_1 Method

Private Sub Button2_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.txtdatum3.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.txtdatum5.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Dim colconv As New ColorConverter()
        Me.colbtn1.BackColor = colconv.ConvertFromString("Control")
        Me.colbtn2.BackColor = Me.colbtn1.BackColor
        Me.colbtn3.BackColor = Me.colbtn1.BackColor
        Me.colbtn4.BackColor = Me.colbtn1.BackColor
        Me.colbtn5.BackColor = Me.colbtn1.BackColor
        Me.colbtn6.BackColor = Me.colbtn1.BackColor
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button9_Click Method

Private Sub Button9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim tn As New TreeNode()
        tn = Me.TreeView1.SelectedNode
        tn = tn.Nodes.Add(Me.TextBox4.Text)
        tn.Tag = Me.TextBox4.Text
        tn.ForeColor = System.Drawing.Color.Red
        tn.ImageIndex = 4
        tn.SelectedImageIndex = 4
        Me.TreeView1.SelectedNode.ExpandAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Button9_Click_1 Method

Private Sub Button9_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button9.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 59, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox4.Text)
                tn1.Tag = Me.TextBox4.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox4.Text = ""
                Me.changes = True

            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles PartnerList.DoubleClick, _
   C1TrueDBGrid1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PartnerList.DoubleClick, C1TrueDBGrid1.DoubleClick
        Dim tn As New TreeNode()
        If Me.TreeView1.SelectedNode.Tag < 10 Then
            MsgBox("Bitte wählen Sie einen Knoten aus, der das Hinzufügen von Selektionskriterien erlaubt.")
            Exit Sub
        End If

        ' Änderung durch Partnerselektion
        If Me.TreeView1.SelectedNode.Tag = 41 Then
            tn = Me.TreeView1.SelectedNode
            tn = tn.Nodes.Add(Str(Me.PartnerList.Columns(0).Value) + " - " + Me.PartnerList.Columns(1).Value)
            tn.Tag = Me.PartnerList.Columns(0).Value
            tn.ForeColor = System.Drawing.Color.Red
            tn.ImageIndex = 4
            tn.SelectedImageIndex = 4
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
            Exit Sub
        End If
        Try
            tn = Me.TreeView1.SelectedNode
            Dim i As Integer
            Dim row As Long
            Dim col As C1.Win.C1TrueDBGrid.C1DataColumn
            If Me.C1TrueDBGrid1.SelectedRows.Count > 0 Then
                For Each row In Me.C1TrueDBGrid1.SelectedRows
                    tn = Me.TreeView1.SelectedNode
                    tn = tn.Nodes.Add(Me.C1TrueDBGrid1.Columns(1).CellText(row))
                    If Me.C1TrueDBGrid1.Columns(2).CellValue(row) = False Then
                        tn.ForeColor = System.Drawing.Color.Gray
                    Else
                        tn.ForeColor = System.Drawing.Color.Red
                    End If
                    tn.Tag = Me.C1TrueDBGrid1.Columns(0).CellValue(row)
                    tn.ImageIndex = 4
                    tn.SelectedImageIndex = 4
                Next
            Else
                tn = tn.Nodes.Add(Me.C1TrueDBGrid1.Columns(1).Value)
                tn.Tag = Me.C1TrueDBGrid1.Columns(0).Value
                If Me.C1TrueDBGrid1.Columns(2).Value = False Then
                    tn.ForeColor = System.Drawing.Color.Gray
                Else
                    tn.ForeColor = System.Drawing.Color.Red
                End If
                tn.ImageIndex = 4
                tn.SelectedImageIndex = 4
            End If
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
        Catch
        End Try
        Exit Sub
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.CTmenu1_Popup Method

Private Sub CTmenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CTmenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenu1.Popup
        Try
            Dim tn As TreeNode
            tn = Me.TreeView1.SelectedNode
            Try
                Dim I As Integer
                I = tn.Parent.Tag
            Catch
                Me.MnuDel.Enabled = False
                Me.MenuItem14.Enabled = False
                Exit Sub
            End Try

            Me.MnuDel.Enabled = False
            Me.MenuItem14.Enabled = False
            Select Case tn.Parent.Tag
                Case 11, 12, 13, 14, 15, 21, 22, 23, 24, 25, 31, 32, 33, 34, 35, 41, 42, 43, 44, 71, 72, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 91, 92, 93, 51, 52, 53, 54, 58, 59
                    Me.MnuDel.Enabled = True
                Case 999, 1, 2, 3, 70, 90, 5, 90, 30, 998
                    If tn.Tag <> 42 And tn.Tag <> 45 And tn.Tag <> 62 And tn.Tag <> 60 And tn.Tag <> 72 And tn.Tag <> 92 And tn.Tag <> 52 And tn.Tag <> 55 And tn.Tag <> 61 Then

                        Me.MenuItem14.Enabled = True
                    End If
            End Select
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Dim s, s1 As String
        Dim i As Integer
        Dim splitter
        If Me.LBSelectHost.Visible = True Then
            If LBSelectHost.SelectedItems.Count < 1 Then
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            Else
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            End If
            Try
                s = LBSelectHost.SelectedItem
                splitter = Microsoft.VisualBasic.Split(s, " | ")
                Select Case splitter(1)
                    Case "Absteigend"
                        s1 = "Aufsteigend"
                    Case "Aufsteigend"
                        s1 = "Absteigend"
                    Case Else
                        s1 = "Aufsteigend"
                End Select
                Me.MenuItem21.Text = "Sortierungsart " + s1
            Catch
            End Try
        Else
            If lbselect.SelectedItems.Count < 1 Then
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            Else
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            End If
            Try
                s = lbselect.SelectedItem
                splitter = Microsoft.VisualBasic.Split(s, " | ")
                Select Case splitter(1)
                    Case "Absteigend"
                        s1 = "Aufsteigend"
                    Case "Aufsteigend"
                        s1 = "Absteigend"
                    Case Else
                        s1 = "Aufsteigend"
                End Select
                Me.MenuItem21.Text = "Sortierungsart " + s1
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Convert_Seldate_bis Method

Private Function Convert_Seldate_bis( _
   ByVal d As String _
) As String

Parameters

d
Required.

Source code

[Visual Basic]
    Private Function Convert_Seldate_bis(ByVal d As String) As String
        Dim splitter
        Dim da As DateTime
        Dim i As Integer
        Dim ds As String
        ds = d
        If ds = "" Or ds = "(heute)-999999" Then
            Return ""
        End If
        If Microsoft.VisualBasic.Left(d, 1) = "(" Then
            d = Mid(d, 2, Len(d) - 1)
            splitter = Microsoft.VisualBasic.Split(d, "-")
            Try
                i = Val(splitter(1))
                da = Now
                da = DateAdd(DateInterval.Day, i * -1, Now)
                If i = 0 Then Return CutDate(da) Else Return CutDate(da)

            Catch ex As Exception
                Return ""
            End Try

        Else
            Return d
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Convert_Seldate_von Method

Private Function Convert_Seldate_von( _
   ByVal d As String _
) As String

Parameters

d
Required.

Source code

[Visual Basic]
    Private Function Convert_Seldate_von(ByVal d As String) As String
        Dim splitter
        Dim da As DateTime
        Dim i As Integer
        Dim ds As String
        ds = d
        If ds = "" Or ds = "(heute)-999999" Then
            Return ""
        End If
        If Microsoft.VisualBasic.Left(d, 1) = "(" Then
            d = Mid(d, 2, Len(d) - 1)
            splitter = Microsoft.VisualBasic.Split(d, "-")
            Try
                i = Val(splitter(1))
                da = Now
                da = DateAdd(DateInterval.Day, i * -1, Now)
                If i = 0 Then Return CutDate(Now) Else Return CutDate(da)

            Catch ex As Exception
                Return ""
            End Try

        Else
            Return d
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.CutDate Method

Private Function CutDate( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Private Function CutDate(ByVal s As String) As String
        Dim i As Integer
        i = Microsoft.VisualBasic.InStr(s, " ")
        If i > 0 Then CutDate = Microsoft.VisualBasic.Left(s, i - 1) Else CutDate = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker13_ValueChanged Method

Private Sub DateTimePicker13_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker13.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker13_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker13.ValueChanged
        Me.txtdatum3zv.Text = CutDate(Me.DateTimePicker13.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum3zv.Text, Date)
            Me.DateTimePicker13.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker14_ValueChanged Method

Private Sub DateTimePicker14_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker14.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker14_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker14.ValueChanged
        Me.txtdatum1zv.Text = CutDate(Me.DateTimePicker14.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum1zv.Text, Date)
            Me.DateTimePicker14.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker15_ValueChanged Method

Private Sub DateTimePicker15_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker15.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker15_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker15.ValueChanged
        Me.txtdatum2zv.Text = CutDate(Me.DateTimePicker15.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum2zv.Text, Date)
            Me.DateTimePicker15.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker16_ValueChanged Method

Private Sub DateTimePicker16_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker16.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker16_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker16.ValueChanged
        Me.txtdatum4zv.Text = CutDate(Me.DateTimePicker14.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum4zv.Text, Date)
            Me.DateTimePicker16.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker17_ValueChanged Method

Private Sub DateTimePicker17_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker17.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker17_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker17.ValueChanged
        Me.txtdatum3uvm.Text = CutDate(Me.DateTimePicker17.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum3uvm.Text, Date)
            Me.DateTimePicker17.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker18_ValueChanged Method

Private Sub DateTimePicker18_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker18.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker18_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker18.ValueChanged
        Me.txtdatum1uvm.Text = CutDate(Me.DateTimePicker18.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum1uvm.Text, Date)
            Me.DateTimePicker18.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker19_ValueChanged Method

Private Sub DateTimePicker19_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker19.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker19_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker19.ValueChanged
        Me.txtdatum2uvm.Text = CutDate(Me.DateTimePicker19.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum2uvm.Text, Date)
            Me.DateTimePicker19.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker1_Enter Method

Private Sub DateTimePicker1_Enter( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.Enter, _
   DateTimePicker2.Enter, _
   DateTimePicker3.Enter, _
   DateTimePicker4.Enter, _
   DateTimePicker5.Enter, _
   DateTimePicker6.Enter, _
   DateTimePicker8.Enter, _
   DateTimePicker9.Enter, _
   DateTimePicker13.Enter, _
   DateTimePicker14.Enter, _
   DateTimePicker15.Enter, _
   DateTimePicker16.Enter, _
   DateTimePicker17.Enter, _
   DateTimePicker18.Enter, _
   DateTimePicker19.Enter, _
   DateTimePicker20.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_Enter(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker1.Enter, _
    DateTimePicker2.Enter, DateTimePicker3.Enter, DateTimePicker4.Enter, DateTimePicker5.Enter, DateTimePicker6.Enter, DateTimePicker8.Enter, DateTimePicker9.Enter, DateTimePicker13.Enter, DateTimePicker14.Enter, _
    DateTimePicker15.Enter, DateTimePicker16.Enter, DateTimePicker17.Enter, DateTimePicker18.Enter, DateTimePicker19.Enter, DateTimePicker20.Enter
        Dim dp As DateTimePicker
        Dim D As Date
        dp = sender
        Select Case UCase(dp.Name)
            Case "DATETIMEPICKER1"
                If Me.txtdatum1.Text <> "" Then
                    D = CType(Me.txtdatum1.Text, Date)
                    Me.DateTimePicker1.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker1.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER2"
                If Me.txtdatum2.Text <> "" Then
                    D = CType(Me.txtdatum2.Text, Date)
                    Me.DateTimePicker2.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker2.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER3"
                If Me.txtdatum3.Text <> "" Then
                    D = CType(Me.txtdatum3.Text, Date)
                    Me.DateTimePicker3.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker3.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER4"
                If Me.txtdatum4.Text <> "" Then
                    D = CType(Me.txtdatum4.Text, Date)
                    Me.DateTimePicker4.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker4.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER5"
                If Me.txtdatum5.Text <> "" Then
                    D = CType(Me.txtdatum5.Text, Date)
                    Me.DateTimePicker5.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker5.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER6"
                If Me.txtdatum6.Text <> "" Then
                    D = CType(Me.txtdatum6.Text, Date)
                    Me.DateTimePicker6.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker6.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER8"
                If Me.HostDatum2.Text <> "" Then
                    D = CType(Me.HostDatum2.Text, Date)
                    Me.DateTimePicker8.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker8.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER9"
                If Me.HostDatum1.Text <> "" Then
                    D = CType(Me.HostDatum1.Text, Date)
                    Me.DateTimePicker9.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker9.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER13"
                If Me.txtdatum3zv.Text <> "" Then
                    D = CType(Me.txtdatum3zv.Text, Date)
                    Me.DateTimePicker13.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker13.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER14"
                If Me.txtdatum1zv.Text <> "" Then
                    D = CType(Me.txtdatum1zv.Text, Date)
                    Me.DateTimePicker14.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker14.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER15"
                If Me.txtdatum2zv.Text <> "" Then
                    D = CType(Me.txtdatum2zv.Text, Date)
                    Me.DateTimePicker15.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker15.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER16"
                If Me.txtdatum4zv.Text <> "" Then
                    D = CType(Me.txtdatum4zv.Text, Date)
                    Me.DateTimePicker16.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker16.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER17"
                If Me.txtdatum3uvm.Text <> "" Then
                    D = CType(Me.txtdatum3uvm.Text, Date)
                    Me.DateTimePicker17.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker17.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER18"
                If Me.txtdatum1uvm.Text <> "" Then
                    D = CType(Me.txtdatum1uvm.Text, Date)
                    Me.DateTimePicker18.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker18.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER19"
                If Me.txtdatum2uvm.Text <> "" Then
                    D = CType(Me.txtdatum2uvm.Text, Date)
                    Me.DateTimePicker19.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker19.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER20"
                If Me.txtdatum4uvm.Text <> "" Then
                    D = CType(Me.txtdatum4uvm.Text, Date)
                    Me.DateTimePicker20.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker20.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        Me.txtdatum1.Text = CutDate(Me.DateTimePicker1.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum1.Text, Date)
            Me.DateTimePicker1.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker20_ValueChanged Method

Private Sub DateTimePicker20_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker20.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker20_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker20.ValueChanged
        Me.txtdatum4uvm.Text = CutDate(Me.DateTimePicker20.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum4uvm.Text, Date)
            Me.DateTimePicker20.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker2_ValueChanged Method

Private Sub DateTimePicker2_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker2.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker2.ValueChanged
        Me.txtdatum2.Text = CutDate(Me.DateTimePicker2.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum2.Text, Date)
            Me.DateTimePicker2.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker3_ValueChanged Method

Private Sub DateTimePicker3_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker3.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker3_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker3.ValueChanged
        Me.txtdatum3.Text = CutDate(Me.DateTimePicker3.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum3.Text, Date)
            Me.DateTimePicker3.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker4_ValueChanged Method

Private Sub DateTimePicker4_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker4.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker4_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker4.ValueChanged
        Me.txtdatum4.Text = CutDate(Me.DateTimePicker4.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum4.Text, Date)
            Me.DateTimePicker4.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker5_ValueChanged Method

Private Sub DateTimePicker5_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker5.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker5_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker5.ValueChanged
        Me.txtdatum5.Text = CutDate(Me.DateTimePicker5.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum5.Text, Date)
            Me.DateTimePicker5.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker6_ValueChanged Method

Private Sub DateTimePicker6_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker6.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker6_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker6.ValueChanged
        Me.txtdatum6.Text = CutDate(Me.DateTimePicker6.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum6.Text, Date)
            Me.DateTimePicker6.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try

        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker7_ValueChanged Method

Private Sub DateTimePicker7_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker7.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker7_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker7.ValueChanged
        Me.HostDatum3.Text = CutDate(Me.DateTimePicker7.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker8_ValueChanged Method

Private Sub DateTimePicker8_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker8.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker8_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker8.ValueChanged
        Me.HostDatum2.Text = CutDate(Me.DateTimePicker8.Value)
        Try
            Dim d As Date
            d = CType(Me.HostDatum2.Text, Date)
            Me.DateTimePicker8.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.DateTimePicker9_ValueChanged Method

Private Sub DateTimePicker9_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker9.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker9_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker9.ValueChanged
        Me.HostDatum1.Text = CutDate(Me.DateTimePicker9.Value)
        Try
            Dim d As Date
            d = CType(Me.HostDatum1.Text, Date)
            Me.DateTimePicker9.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Mitarbeiter"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Status"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Marktbereich"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Niederlassung"
            Case 5
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Kostenstelle"
            Case 6
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Team"
            Case 7
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp"
            Case 8
                scmCmdToExecute.CommandText = "dbo.SP_Profil_DokumenttypHost"
            Case 9
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Mitarbeiter_kube"
            Case 10
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp_uvm"
            Case 11
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp_ZV"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.GetNodeData Method

Private Function GetNodeData( _
   ByVal tnParent As TreeNode, _
   ByRef iParent As Integer _
) As String

Parameters

tnParent
Required.
iParent
Required.

Source code

[Visual Basic]
    Private Function GetNodeData(ByVal tnParent As TreeNode, ByRef iParent As Integer) As String
        Dim tn As TreeNode
        If tnParent.GetNodeCount(True) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        Do Until tn Is Nothing
            Try
                If tn.Parent.Tag = iParent Then
                    Me.NodeText = Me.NodeText & ";" & tn.Tag
                End If
            Catch ex As Exception
            End Try

            If tn.GetNodeCount(True) > 0 Then
                Call GetNodeData(tn, iParent)
            End If
            tn = tn.NextNode
        Loop
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.GetNodeDatastring Method

Private Function GetNodeDatastring( _
   ByVal iparent As Integer _
) As String

Parameters

iparent
Required.

Source code

[Visual Basic]
    Private Function GetNodeDatastring(ByVal iparent As Integer) As String
        Me.NodeText = ""
        DivFnkt.Searchnode1(Me.TreeView1, iparent, 0)
        If DivFnkt.found Then
            GetNodeData(DivFnkt.FoundNode, iparent)
            Try
                Me.NodeText = Microsoft.VisualBasic.Right(Me.NodeText, Len(Me.NodeText) - 1)
            Catch
                Me.NodeText = ""
            End Try
        End If
        Return Me.NodeText
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmProfil))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnClose = New System.Windows.Forms.ToolBarButton()
        Me.btnOpen = New System.Windows.Forms.ToolBarButton()
        Me.btnSave = New System.Windows.Forms.ToolBarButton()
        Me.btnini = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ColorDialog1 = New System.Windows.Forms.ColorDialog()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.MnuListe = New System.Windows.Forms.ContextMenu()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.Profile = New System.Windows.Forms.TreeView()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.ComboBox10 = New System.Windows.Forms.ComboBox()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.ComboBox9 = New System.Windows.Forms.ComboBox()
        Me.ctmenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDel = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.CTMenuErsteller = New System.Windows.Forms.ContextMenu()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.CTMenuVerantwortlicher = New System.Windows.Forms.ContextMenu()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.CTMenuMutierer = New System.Windows.Forms.ContextMenu()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuSelectDokumentart = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteDokumentart = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.TreeView2 = New System.Windows.Forms.TreeView()
        Me.PnlDokumentDaten = New System.Windows.Forms.Panel()
        Me.cinklaltversant = New System.Windows.Forms.CheckBox()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.Label40 = New System.Windows.Forms.Label()
        Me.txtdatum3 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.txtdatum4 = New System.Windows.Forms.TextBox()
        Me.txtdatum6 = New System.Windows.Forms.TextBox()
        Me.txtdatum2 = New System.Windows.Forms.TextBox()
        Me.Button16 = New System.Windows.Forms.Button()
        Me.cbrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Button17 = New System.Windows.Forms.Button()
        Me.Button15 = New System.Windows.Forms.Button()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Button13 = New System.Windows.Forms.Button()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.Button14 = New System.Windows.Forms.Button()
        Me.Button12 = New System.Windows.Forms.Button()
        Me.cbrollend5 = New System.Windows.Forms.CheckBox()
        Me.cbrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbrollend2 = New System.Windows.Forms.CheckBox()
        Me.datumtext5 = New System.Windows.Forms.Label()
        Me.Label39 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.txtdatum1 = New System.Windows.Forms.TextBox()
        Me.cbrollend6 = New System.Windows.Forms.CheckBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.cbrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtdatum5 = New System.Windows.Forms.TextBox()
        Me.datumtext1 = New System.Windows.Forms.Label()
        Me.datumtext2 = New System.Windows.Forms.Label()
        Me.datumtext3 = New System.Windows.Forms.Label()
        Me.datumtext4 = New System.Windows.Forms.Label()
        Me.datumtext6 = New System.Windows.Forms.Label()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker2 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker5 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker6 = New System.Windows.Forms.DateTimePicker()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.txtdatum3zv = New System.Windows.Forms.TextBox()
        Me.txtdatum4zv = New System.Windows.Forms.TextBox()
        Me.txtdatum2zv = New System.Windows.Forms.TextBox()
        Me.cbzvrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.Button21 = New System.Windows.Forms.Button()
        Me.DateTimePicker13 = New System.Windows.Forms.DateTimePicker()
        Me.Button22 = New System.Windows.Forms.Button()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.Label41 = New System.Windows.Forms.Label()
        Me.Button23 = New System.Windows.Forms.Button()
        Me.Button24 = New System.Windows.Forms.Button()
        Me.cbzvrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbzvrollend2 = New System.Windows.Forms.CheckBox()
        Me.Label42 = New System.Windows.Forms.Label()
        Me.txtdatum1zv = New System.Windows.Forms.TextBox()
        Me.Label43 = New System.Windows.Forms.Label()
        Me.cbzvrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label44 = New System.Windows.Forms.Label()
        Me.textdatum1zv = New System.Windows.Forms.Label()
        Me.textdatum2zv = New System.Windows.Forms.Label()
        Me.textdatum3zv = New System.Windows.Forms.Label()
        Me.textdatum4zv = New System.Windows.Forms.Label()
        Me.DateTimePicker14 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker15 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker16 = New System.Windows.Forms.DateTimePicker()
        Me.TabPage5 = New System.Windows.Forms.TabPage()
        Me.txtdatum4uvm = New System.Windows.Forms.TextBox()
        Me.txtdatum3uvm = New System.Windows.Forms.TextBox()
        Me.txtdatum2uvm = New System.Windows.Forms.TextBox()
        Me.cbuvmrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label49 = New System.Windows.Forms.Label()
        Me.Button25 = New System.Windows.Forms.Button()
        Me.DateTimePicker17 = New System.Windows.Forms.DateTimePicker()
        Me.Button26 = New System.Windows.Forms.Button()
        Me.Label50 = New System.Windows.Forms.Label()
        Me.Label51 = New System.Windows.Forms.Label()
        Me.Button27 = New System.Windows.Forms.Button()
        Me.Button28 = New System.Windows.Forms.Button()
        Me.cbuvmrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbuvmrollend2 = New System.Windows.Forms.CheckBox()
        Me.Label52 = New System.Windows.Forms.Label()
        Me.txtdatum1uvm = New System.Windows.Forms.TextBox()
        Me.Label53 = New System.Windows.Forms.Label()
        Me.cbuvmrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label54 = New System.Windows.Forms.Label()
        Me.textdatum1uvm = New System.Windows.Forms.Label()
        Me.textdatum2uvm = New System.Windows.Forms.Label()
        Me.textdatum3uvm = New System.Windows.Forms.Label()
        Me.textdatum4uvm = New System.Windows.Forms.Label()
        Me.DateTimePicker18 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker19 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker20 = New System.Windows.Forms.DateTimePicker()
        Me.cinklalt = New System.Windows.Forms.CheckBox()
        Me.cbmavip = New System.Windows.Forms.CheckBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.cbd6 = New System.Windows.Forms.CheckBox()
        Me.cbd4 = New System.Windows.Forms.CheckBox()
        Me.cbd2 = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Groupbox3 = New System.Windows.Forms.GroupBox()
        Me.pnlzv = New System.Windows.Forms.Panel()
        Me.btnzvzahlungsart = New System.Windows.Forms.Button()
        Me.Label62 = New System.Windows.Forms.Label()
        Me.txtzvzahlungsart = New System.Windows.Forms.TextBox()
        Me.btnzvverarbeitungsart = New System.Windows.Forms.Button()
        Me.Label61 = New System.Windows.Forms.Label()
        Me.txtzvverarbeitungsart = New System.Windows.Forms.TextBox()
        Me.btnzvswift = New System.Windows.Forms.Button()
        Me.Label60 = New System.Windows.Forms.Label()
        Me.txtzvswift = New System.Windows.Forms.TextBox()
        Me.btnzvreferenz = New System.Windows.Forms.Button()
        Me.Label59 = New System.Windows.Forms.Label()
        Me.txtzvreferenznr = New System.Windows.Forms.TextBox()
        Me.btnzvposten = New System.Windows.Forms.Button()
        Me.Label58 = New System.Windows.Forms.Label()
        Me.txtzvpostennr = New System.Windows.Forms.TextBox()
        Me.btnzvpcnr = New System.Windows.Forms.Button()
        Me.Label57 = New System.Windows.Forms.Label()
        Me.txtzvpcnr = New System.Windows.Forms.TextBox()
        Me.btnzvbeguenstiger = New System.Windows.Forms.Button()
        Me.Label56 = New System.Windows.Forms.Label()
        Me.txtzvbeguenstigter = New System.Windows.Forms.TextBox()
        Me.btnzviso = New System.Windows.Forms.Button()
        Me.Label55 = New System.Windows.Forms.Label()
        Me.txtzviso = New System.Windows.Forms.TextBox()
        Me.btnzvclearing = New System.Windows.Forms.Button()
        Me.Label48 = New System.Windows.Forms.Label()
        Me.txtzvclearingnr = New System.Windows.Forms.TextBox()
        Me.btnzvbetrag = New System.Windows.Forms.Button()
        Me.Label47 = New System.Windows.Forms.Label()
        Me.txtzvbetrag = New System.Windows.Forms.TextBox()
        Me.btnzvauftraggeber = New System.Windows.Forms.Button()
        Me.Label46 = New System.Windows.Forms.Label()
        Me.txtzvauftraggeber = New System.Windows.Forms.TextBox()
        Me.btnzvauftragsnr = New System.Windows.Forms.Button()
        Me.Label63 = New System.Windows.Forms.Label()
        Me.txtzvauftragsnr = New System.Windows.Forms.TextBox()
        Me.GroupBox13 = New System.Windows.Forms.GroupBox()
        Me.pnlhostdiv = New System.Windows.Forms.Panel()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.Label66 = New System.Windows.Forms.Label()
        Me.Label65 = New System.Windows.Forms.Label()
        Me.Label64 = New System.Windows.Forms.Label()
        Me.Button20 = New System.Windows.Forms.Button()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Button9 = New System.Windows.Forms.Button()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Button10 = New System.Windows.Forms.Button()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.hostinklmavip = New System.Windows.Forms.CheckBox()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.DateTimePicker7 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.Button18 = New System.Windows.Forms.Button()
        Me.Button19 = New System.Windows.Forms.Button()
        Me.DatumHostText2 = New System.Windows.Forms.Label()
        Me.DatumHostText1 = New System.Windows.Forms.Label()
        Me.cbrollend9 = New System.Windows.Forms.CheckBox()
        Me.cbrollend8 = New System.Windows.Forms.CheckBox()
        Me.HostDatum1 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.lblhostdatum31 = New System.Windows.Forms.Label()
        Me.ComboBox6 = New System.Windows.Forms.ComboBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.lblhostdatum3 = New System.Windows.Forms.Label()
        Me.HostDatum3 = New System.Windows.Forms.TextBox()
        Me.HostTag3 = New System.Windows.Forms.ComboBox()
        Me.HostDatum2 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker8 = New System.Windows.Forms.DateTimePicker()
        Me.lblhostdatum2 = New System.Windows.Forms.Label()
        Me.DateTimePicker9 = New System.Windows.Forms.DateTimePicker()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.Label35 = New System.Windows.Forms.Label()
        Me.CheckBox3 = New System.Windows.Forms.CheckBox()
        Me.CheckBox4 = New System.Windows.Forms.CheckBox()
        Me.CheckBox5 = New System.Windows.Forms.CheckBox()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label36 = New System.Windows.Forms.Label()
        Me.Label37 = New System.Windows.Forms.Label()
        Me.Label38 = New System.Windows.Forms.Label()
        Me.DateTimePicker10 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker11 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker12 = New System.Windows.Forms.DateTimePicker()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.pnluvm = New System.Windows.Forms.Panel()
        Me.Button29 = New System.Windows.Forms.Button()
        Me.txtuvmauftragnr = New System.Windows.Forms.TextBox()
        Me.Label45 = New System.Windows.Forms.Label()
        Me.GroupBox14 = New System.Windows.Forms.GroupBox()
        Me.PnlDokumentart = New System.Windows.Forms.Panel()
        Me.TVDokart = New System.Windows.Forms.TreeView()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.TVHostDok = New System.Windows.Forms.TreeView()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.LBSelectHost = New System.Windows.Forms.ListBox()
        Me.Button11 = New System.Windows.Forms.Button()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.lbselect = New System.Windows.Forms.ListBox()
        Me.LBSort = New System.Windows.Forms.ListBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.lbSortfields = New System.Windows.Forms.ListBox()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.PnlPartner = New System.Windows.Forms.Panel()
        Me.PartnerList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.btnPartnersuche = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.colbtn6 = New System.Windows.Forms.Button()
        Me.colbtn5 = New System.Windows.Forms.Button()
        Me.colbtn4 = New System.Windows.Forms.Button()
        Me.colbtn3 = New System.Windows.Forms.Button()
        Me.colbtn2 = New System.Windows.Forms.Button()
        Me.colbtn1 = New System.Windows.Forms.Button()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.cb3_1 = New System.Windows.Forms.CheckBox()
        Me.cb5 = New System.Windows.Forms.CheckBox()
        Me.cb4 = New System.Windows.Forms.CheckBox()
        Me.cb3 = New System.Windows.Forms.CheckBox()
        Me.cb2 = New System.Windows.Forms.CheckBox()
        Me.cb1 = New System.Windows.Forms.CheckBox()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.Panel2.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage1.SuspendLayout()
        Me.PnlDokumentDaten.SuspendLayout()
        Me.TabControl2.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.TabPage3.SuspendLayout()
        Me.TabPage5.SuspendLayout()
        Me.pnlzv.SuspendLayout()
        Me.pnlhostdiv.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.pnluvm.SuspendLayout()
        Me.PnlDokumentart.SuspendLayout()
        Me.Panel3.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel4.SuspendLayout()
        Me.PnlPartner.SuspendLayout()
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage4.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox9.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = -1
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5})
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Schliessen"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnClose, Me.btnOpen, Me.btnSave, Me.btnini})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(792, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnClose
        '
        Me.btnClose.ImageIndex = 0
        Me.btnClose.ToolTipText = "Fenster schliessen"
        '
        'btnOpen
        '
        Me.btnOpen.ImageIndex = 7
        Me.btnOpen.Visible = False
        '
        'btnSave
        '
        Me.btnSave.ImageIndex = 1
        '
        'btnini
        '
        Me.btnini.ImageIndex = 12
        Me.btnini.ToolTipText = "Profil initialisieren"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(792, 8)
        Me.Panel1.TabIndex = 4
        '
        'MnuListe
        '
        Me.MnuListe.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem12, Me.MenuItem6, Me.MenuItem7, Me.MenuItem9, Me.MenuItem11, Me.MenuItem13, Me.MenuItem8, Me.MenuItem10})
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 0
        Me.MenuItem12.Text = "Übernehmen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Auswählen"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 2
        Me.MenuItem7.Text = "Als Standard"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 3
        Me.MenuItem9.Text = "-"
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 4
        Me.MenuItem11.Text = "Neues Profil"
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 5
        Me.MenuItem13.Text = "Profil kopieren"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 6
        Me.MenuItem8.Text = "Umbenennen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 7
        Me.MenuItem10.Text = "Löschen"
        '
        'Panel2
        '
        Me.Panel2.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Profile})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Location = New System.Drawing.Point(0, 33)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(176, 544)
        Me.Panel2.TabIndex = 11
        '
        'Profile
        '
        Me.Profile.ContextMenu = Me.MnuListe
        Me.Profile.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Profile.FullRowSelect = True
        Me.Profile.ImageIndex = -1
        Me.Profile.Name = "Profile"
        Me.Profile.SelectedImageIndex = -1
        Me.Profile.ShowLines = False
        Me.Profile.ShowPlusMinus = False
        Me.Profile.Size = New System.Drawing.Size(174, 542)
        Me.Profile.Sorted = True
        Me.Profile.TabIndex = 0
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(200, 552)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(112, 24)
        Me.Button4.TabIndex = 14
        Me.Button4.Text = "Übernehmen"
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(16, 64)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(48, 23)
        Me.Label25.TabIndex = 3
        '
        'ComboBox10
        '
        Me.ComboBox10.Location = New System.Drawing.Point(64, 64)
        Me.ComboBox10.Name = "ComboBox10"
        Me.ComboBox10.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox10.TabIndex = 2
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(16, 32)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(48, 23)
        Me.Label24.TabIndex = 1
        '
        'ComboBox9
        '
        Me.ComboBox9.Location = New System.Drawing.Point(64, 32)
        Me.ComboBox9.Name = "ComboBox9"
        Me.ComboBox9.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox9.TabIndex = 0
        '
        'ctmenu1
        '
        Me.ctmenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDel, Me.MenuItem14})
        '
        'MnuDel
        '
        Me.MnuDel.Index = 0
        Me.MnuDel.Text = "Eintrag löschen"
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 1
        Me.MenuItem14.Text = "Einträge löschen"
        '
        'CTMenuErsteller
        '
        Me.CTMenuErsteller.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem15, Me.MenuItem16})
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 0
        Me.MenuItem15.Text = "Partner übernehmen"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 1
        Me.MenuItem16.Text = "Detailinformationen"
        '
        'CTMenuVerantwortlicher
        '
        Me.CTMenuVerantwortlicher.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem20})
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 0
        Me.MenuItem20.Text = "Eintrag übernehmen"
        '
        'CTMenuMutierer
        '
        Me.CTMenuMutierer.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem24, Me.MenuItem25, Me.MenuItem26, Me.MenuItem27})
        '
        'MenuItem24
        '
        Me.MenuItem24.Index = 0
        Me.MenuItem24.Text = "&Eintrag selektieren"
        '
        'MenuItem25
        '
        Me.MenuItem25.Index = 1
        Me.MenuItem25.Text = "&Selektion aufheben"
        '
        'MenuItem26
        '
        Me.MenuItem26.Index = 2
        Me.MenuItem26.Text = "-"
        '
        'MenuItem27
        '
        Me.MenuItem27.Index = 3
        Me.MenuItem27.Text = "&Alle aufheben"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "profil", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp"), New System.Data.Common.DataColumnMapping("doktyp", "doktyp"), New System.Data.Common.DataColumnMapping("inklmavip", "inklmavip"), New System.Data.Common.DataColumnMapping("inklalt", "inklalt"), New System.Data.Common.DataColumnMapping("hostpartner", "hostpartner"), New System.Data.Common.DataColumnMapping("hostdokart", "hostdokart"), New System.Data.Common.DataColumnMapping("hostdoktyp", "hostdoktyp"), New System.Data.Common.DataColumnMapping("hosttag1", "hosttag1"), New System.Data.Common.DataColumnMapping("hostdatum1", "hostdatum1"), New System.Data.Common.DataColumnMapping("hosttag2", "hosttag2"), New System.Data.Common.DataColumnMapping("hostdatum2", "hostdatum2"), New System.Data.Common.DataColumnMapping("hosttag3", "hosttag3"), New System.Data.Common.DataColumnMapping("hostdatum3", "hostdatum3"), New System.Data.Common.DataColumnMapping("inklhostmavip", "inklhostmavip")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_profil_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_profil_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 50, "hosttag1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 50, "hostdatum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 50, "hosttag2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 50, "hostdatum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 50, "hosttag3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 50, "hostdatum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_profil_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_profil_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 50, "hosttag1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 50, "hostdatum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 50, "hosttag2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 50, "hostdatum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 50, "hosttag3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 50, "hostdatum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(176, 33)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 544)
        Me.Splitter1.TabIndex = 15
        Me.Splitter1.TabStop = False
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem17, Me.MenuItem18, Me.MenuItem21, Me.MenuItem22, Me.MenuItem19})
        '
        'MenuItem17
        '
        Me.MenuItem17.Index = 0
        Me.MenuItem17.Text = "&Aufwärts"
        '
        'MenuItem18
        '
        Me.MenuItem18.Index = 1
        Me.MenuItem18.Text = "A&bwärts"
        '
        'MenuItem21
        '
        Me.MenuItem21.Index = 2
        Me.MenuItem21.Text = "Sortierung ändern"
        '
        'MenuItem22
        '
        Me.MenuItem22.Index = 3
        Me.MenuItem22.Text = "-"
        '
        'MenuItem19
        '
        Me.MenuItem19.Index = 4
        Me.MenuItem19.Text = "&Löschen"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuSelectDokumentart, Me.MnuDeleteDokumentart, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4})
        '
        'MnuSelectDokumentart
        '
        Me.MnuSelectDokumentart.Index = 0
        Me.MnuSelectDokumentart.Text = "Eintrag auswählen"
        '
        'MnuDeleteDokumentart
        '
        Me.MnuDeleteDokumentart.Index = 1
        Me.MnuDeleteDokumentart.Text = "Eintrag abwählen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 3
        Me.MenuItem3.Text = "Knoten öffnen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 4
        Me.MenuItem4.Text = "Knoten schliessen"
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeView2, Me.PnlDokumentDaten, Me.pnlzv, Me.pnlhostdiv, Me.pnluvm, Me.PnlDokumentart, Me.Panel3, Me.TreeView1, Me.TVHostDok, Me.Panel4, Me.PnlPartner})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(605, 518)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Selektion / Sortierung"
        '
        'TreeView2
        '
        Me.TreeView2.ImageIndex = -1
        Me.TreeView2.Location = New System.Drawing.Point(24, 104)
        Me.TreeView2.Name = "TreeView2"
        Me.TreeView2.SelectedImageIndex = -1
        Me.TreeView2.TabIndex = 12
        '
        'PnlDokumentDaten
        '
        Me.PnlDokumentDaten.Controls.AddRange(New System.Windows.Forms.Control() {Me.cinklaltversant, Me.TabControl2, Me.cinklalt, Me.cbmavip, Me.Label8, Me.Label7, Me.Label6, Me.Label5, Me.cbd6, Me.cbd4, Me.cbd2, Me.Label18, Me.Label16, Me.Label14, Me.GroupBox10, Me.Button1, Me.Button2, Me.Button3, Me.Groupbox3})
        Me.PnlDokumentDaten.Location = New System.Drawing.Point(224, 8)
        Me.PnlDokumentDaten.Name = "PnlDokumentDaten"
        Me.PnlDokumentDaten.Size = New System.Drawing.Size(376, 496)
        Me.PnlDokumentDaten.TabIndex = 1
        Me.PnlDokumentDaten.Visible = False
        '
        'cinklaltversant
        '
        Me.cinklaltversant.Location = New System.Drawing.Point(16, 286)
        Me.cinklaltversant.Name = "cinklaltversant"
        Me.cinklaltversant.Size = New System.Drawing.Size(336, 24)
        Me.cinklaltversant.TabIndex = 89
        Me.cinklaltversant.Text = "versandte, vor Abschluss gelöschte Dokumente"
        '
        'TabControl2
        '
        Me.TabControl2.Appearance = System.Windows.Forms.TabAppearance.FlatButtons
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage2, Me.TabPage3, Me.TabPage5})
        Me.TabControl2.Location = New System.Drawing.Point(16, 24)
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(344, 208)
        Me.TabControl2.TabIndex = 86
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label40, Me.txtdatum3, Me.Label17, Me.txtdatum4, Me.txtdatum6, Me.txtdatum2, Me.Button16, Me.cbrollend1, Me.Label15, Me.Button17, Me.Button15, Me.DateTimePicker3, Me.Button13, Me.Label23, Me.Label12, Me.Button14, Me.Button12, Me.cbrollend5, Me.cbrollend4, Me.cbrollend2, Me.datumtext5, Me.Label39, Me.Label13, Me.txtdatum1, Me.cbrollend6, Me.Label11, Me.cbrollend3, Me.Label10, Me.txtdatum5, Me.datumtext1, Me.datumtext2, Me.datumtext3, Me.datumtext4, Me.datumtext6, Me.DateTimePicker1, Me.DateTimePicker2, Me.DateTimePicker4, Me.DateTimePicker5, Me.DateTimePicker6})
        Me.TabPage2.Location = New System.Drawing.Point(4, 25)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(336, 179)
        Me.TabPage2.TabIndex = 0
        Me.TabPage2.Text = "EDOKA-Dokumente"
        '
        'Label40
        '
        Me.Label40.Location = New System.Drawing.Point(72, 120)
        Me.Label40.Name = "Label40"
        Me.Label40.Size = New System.Drawing.Size(32, 23)
        Me.Label40.TabIndex = 63
        Me.Label40.Text = "von"
        '
        'txtdatum3
        '
        Me.txtdatum3.BackColor = System.Drawing.Color.White
        Me.txtdatum3.Enabled = False
        Me.txtdatum3.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3.Location = New System.Drawing.Point(112, 64)
        Me.txtdatum3.Name = "txtdatum3"
        Me.txtdatum3.ReadOnly = True
        Me.txtdatum3.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3.TabIndex = 56
        Me.txtdatum3.Text = ""
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 120)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(72, 23)
        Me.Label17.TabIndex = 52
        Me.Label17.Text = "Archivierung"
        '
        'txtdatum4
        '
        Me.txtdatum4.BackColor = System.Drawing.Color.White
        Me.txtdatum4.Enabled = False
        Me.txtdatum4.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4.Location = New System.Drawing.Point(112, 88)
        Me.txtdatum4.Name = "txtdatum4"
        Me.txtdatum4.ReadOnly = True
        Me.txtdatum4.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4.TabIndex = 57
        Me.txtdatum4.Text = ""
        '
        'txtdatum6
        '
        Me.txtdatum6.BackColor = System.Drawing.Color.White
        Me.txtdatum6.Enabled = False
        Me.txtdatum6.ForeColor = System.Drawing.Color.Black
        Me.txtdatum6.Location = New System.Drawing.Point(112, 144)
        Me.txtdatum6.Name = "txtdatum6"
        Me.txtdatum6.ReadOnly = True
        Me.txtdatum6.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum6.TabIndex = 59
        Me.txtdatum6.Text = ""
        '
        'txtdatum2
        '
        Me.txtdatum2.BackColor = System.Drawing.Color.White
        Me.txtdatum2.Enabled = False
        Me.txtdatum2.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2.Location = New System.Drawing.Point(112, 32)
        Me.txtdatum2.Name = "txtdatum2"
        Me.txtdatum2.ReadOnly = True
        Me.txtdatum2.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2.TabIndex = 55
        Me.txtdatum2.Text = ""
        '
        'Button16
        '
        Me.Button16.Image = CType(resources.GetObject("Button16.Image"), System.Drawing.Bitmap)
        Me.Button16.Location = New System.Drawing.Point(288, 120)
        Me.Button16.Name = "Button16"
        Me.Button16.Size = New System.Drawing.Size(32, 24)
        Me.Button16.TabIndex = 77
        '
        'cbrollend1
        '
        Me.cbrollend1.Location = New System.Drawing.Point(216, 8)
        Me.cbrollend1.Name = "cbrollend1"
        Me.cbrollend1.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend1.TabIndex = 57
        Me.cbrollend1.Text = "(rollend)"
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(8, 64)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(64, 23)
        Me.Label15.TabIndex = 50
        Me.Label15.Text = "Mutation"
        '
        'Button17
        '
        Me.Button17.Image = CType(resources.GetObject("Button17.Image"), System.Drawing.Bitmap)
        Me.Button17.Location = New System.Drawing.Point(288, 144)
        Me.Button17.Name = "Button17"
        Me.Button17.Size = New System.Drawing.Size(32, 24)
        Me.Button17.TabIndex = 78
        '
        'Button15
        '
        Me.Button15.Image = CType(resources.GetObject("Button15.Image"), System.Drawing.Bitmap)
        Me.Button15.Location = New System.Drawing.Point(288, 88)
        Me.Button15.Name = "Button15"
        Me.Button15.Size = New System.Drawing.Size(32, 24)
        Me.Button15.TabIndex = 76
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(112, 64)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker3.TabIndex = 44
        Me.DateTimePicker3.TabStop = False
        Me.DateTimePicker3.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Button13
        '
        Me.Button13.Image = CType(resources.GetObject("Button13.Image"), System.Drawing.Bitmap)
        Me.Button13.Location = New System.Drawing.Point(288, 32)
        Me.Button13.Name = "Button13"
        Me.Button13.Size = New System.Drawing.Size(32, 24)
        Me.Button13.TabIndex = 74
        '
        'Label23
        '
        Me.Label23.Location = New System.Drawing.Point(72, 64)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(32, 23)
        Me.Label23.TabIndex = 61
        Me.Label23.Text = "von"
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(72, 88)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(32, 23)
        Me.Label12.TabIndex = 62
        Me.Label12.Text = "bis"
        '
        'Button14
        '
        Me.Button14.Image = CType(resources.GetObject("Button14.Image"), System.Drawing.Bitmap)
        Me.Button14.Location = New System.Drawing.Point(288, 64)
        Me.Button14.Name = "Button14"
        Me.Button14.Size = New System.Drawing.Size(32, 24)
        Me.Button14.TabIndex = 75
        '
        'Button12
        '
        Me.Button12.Image = CType(resources.GetObject("Button12.Image"), System.Drawing.Bitmap)
        Me.Button12.Location = New System.Drawing.Point(288, 8)
        Me.Button12.Name = "Button12"
        Me.Button12.Size = New System.Drawing.Size(32, 24)
        Me.Button12.TabIndex = 73
        '
        'cbrollend5
        '
        Me.cbrollend5.Location = New System.Drawing.Point(216, 120)
        Me.cbrollend5.Name = "cbrollend5"
        Me.cbrollend5.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend5.TabIndex = 67
        Me.cbrollend5.Text = "(rollend)"
        '
        'cbrollend4
        '
        Me.cbrollend4.Location = New System.Drawing.Point(216, 88)
        Me.cbrollend4.Name = "cbrollend4"
        Me.cbrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend4.TabIndex = 66
        Me.cbrollend4.Text = "(rollend)"
        '
        'cbrollend2
        '
        Me.cbrollend2.Location = New System.Drawing.Point(216, 32)
        Me.cbrollend2.Name = "cbrollend2"
        Me.cbrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend2.TabIndex = 58
        Me.cbrollend2.Text = "(rollend)"
        '
        'datumtext5
        '
        Me.datumtext5.Location = New System.Drawing.Point(224, 120)
        Me.datumtext5.Name = "datumtext5"
        Me.datumtext5.TabIndex = 71
        Me.datumtext5.Visible = False
        '
        'Label39
        '
        Me.Label39.Location = New System.Drawing.Point(72, 144)
        Me.Label39.Name = "Label39"
        Me.Label39.Size = New System.Drawing.Size(32, 23)
        Me.Label39.TabIndex = 64
        Me.Label39.Text = "bis"
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 8)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(56, 23)
        Me.Label13.TabIndex = 48
        Me.Label13.Text = "Erstellung"
        '
        'txtdatum1
        '
        Me.txtdatum1.BackColor = System.Drawing.Color.White
        Me.txtdatum1.Enabled = False
        Me.txtdatum1.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1.Location = New System.Drawing.Point(112, 8)
        Me.txtdatum1.Name = "txtdatum1"
        Me.txtdatum1.ReadOnly = True
        Me.txtdatum1.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1.TabIndex = 54
        Me.txtdatum1.Text = ""
        '
        'cbrollend6
        '
        Me.cbrollend6.Location = New System.Drawing.Point(216, 144)
        Me.cbrollend6.Name = "cbrollend6"
        Me.cbrollend6.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend6.TabIndex = 68
        Me.cbrollend6.Text = "(rollend)"
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(72, 32)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(32, 23)
        Me.Label11.TabIndex = 56
        Me.Label11.Text = "bis"
        '
        'cbrollend3
        '
        Me.cbrollend3.Location = New System.Drawing.Point(216, 64)
        Me.cbrollend3.Name = "cbrollend3"
        Me.cbrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend3.TabIndex = 65
        Me.cbrollend3.Text = "(rollend)"
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(72, 8)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(32, 23)
        Me.Label10.TabIndex = 0
        Me.Label10.Text = "von"
        '
        'txtdatum5
        '
        Me.txtdatum5.BackColor = System.Drawing.Color.White
        Me.txtdatum5.Enabled = False
        Me.txtdatum5.ForeColor = System.Drawing.Color.Black
        Me.txtdatum5.Location = New System.Drawing.Point(112, 120)
        Me.txtdatum5.Name = "txtdatum5"
        Me.txtdatum5.ReadOnly = True
        Me.txtdatum5.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum5.TabIndex = 58
        Me.txtdatum5.Text = ""
        '
        'datumtext1
        '
        Me.datumtext1.Location = New System.Drawing.Point(224, 8)
        Me.datumtext1.Name = "datumtext1"
        Me.datumtext1.TabIndex = 59
        Me.datumtext1.Visible = False
        '
        'datumtext2
        '
        Me.datumtext2.Location = New System.Drawing.Point(224, 32)
        Me.datumtext2.Name = "datumtext2"
        Me.datumtext2.TabIndex = 60
        Me.datumtext2.Visible = False
        '
        'datumtext3
        '
        Me.datumtext3.Location = New System.Drawing.Point(224, 64)
        Me.datumtext3.Name = "datumtext3"
        Me.datumtext3.TabIndex = 69
        Me.datumtext3.Visible = False
        '
        'datumtext4
        '
        Me.datumtext4.Location = New System.Drawing.Point(224, 88)
        Me.datumtext4.Name = "datumtext4"
        Me.datumtext4.TabIndex = 70
        Me.datumtext4.Visible = False
        '
        'datumtext6
        '
        Me.datumtext6.Location = New System.Drawing.Point(224, 144)
        Me.datumtext6.Name = "datumtext6"
        Me.datumtext6.TabIndex = 72
        Me.datumtext6.Visible = False
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker1.Location = New System.Drawing.Point(112, 8)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker1.TabIndex = 42
        Me.DateTimePicker1.TabStop = False
        Me.DateTimePicker1.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker2.Location = New System.Drawing.Point(112, 32)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker2.TabIndex = 43
        Me.DateTimePicker2.TabStop = False
        Me.DateTimePicker2.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker4
        '
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(112, 88)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker4.TabIndex = 45
        Me.DateTimePicker4.TabStop = False
        Me.DateTimePicker4.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'DateTimePicker5
        '
        Me.DateTimePicker5.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker5.Location = New System.Drawing.Point(112, 120)
        Me.DateTimePicker5.Name = "DateTimePicker5"
        Me.DateTimePicker5.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker5.TabIndex = 46
        Me.DateTimePicker5.TabStop = False
        Me.DateTimePicker5.Value = New Date(2004, 1, 14, 18, 49, 58, 703)
        '
        'DateTimePicker6
        '
        Me.DateTimePicker6.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker6.Location = New System.Drawing.Point(112, 144)
        Me.DateTimePicker6.Name = "DateTimePicker6"
        Me.DateTimePicker6.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker6.TabIndex = 47
        Me.DateTimePicker6.TabStop = False
        Me.DateTimePicker6.Value = New Date(2004, 1, 14, 18, 49, 58, 703)
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtdatum3zv, Me.txtdatum4zv, Me.txtdatum2zv, Me.cbzvrollend1, Me.Label26, Me.Button21, Me.DateTimePicker13, Me.Button22, Me.Label28, Me.Label41, Me.Button23, Me.Button24, Me.cbzvrollend4, Me.cbzvrollend2, Me.Label42, Me.txtdatum1zv, Me.Label43, Me.cbzvrollend3, Me.Label44, Me.textdatum1zv, Me.textdatum2zv, Me.textdatum3zv, Me.textdatum4zv, Me.DateTimePicker14, Me.DateTimePicker15, Me.DateTimePicker16})
        Me.TabPage3.Location = New System.Drawing.Point(4, 25)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(336, 179)
        Me.TabPage3.TabIndex = 1
        Me.TabPage3.Text = "ZV-Belege"
        '
        'txtdatum3zv
        '
        Me.txtdatum3zv.BackColor = System.Drawing.Color.White
        Me.txtdatum3zv.Enabled = False
        Me.txtdatum3zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3zv.Location = New System.Drawing.Point(112, 64)
        Me.txtdatum3zv.Name = "txtdatum3zv"
        Me.txtdatum3zv.ReadOnly = True
        Me.txtdatum3zv.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3zv.TabIndex = 86
        Me.txtdatum3zv.Text = ""
        '
        'txtdatum4zv
        '
        Me.txtdatum4zv.BackColor = System.Drawing.Color.White
        Me.txtdatum4zv.Enabled = False
        Me.txtdatum4zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4zv.Location = New System.Drawing.Point(112, 88)
        Me.txtdatum4zv.Name = "txtdatum4zv"
        Me.txtdatum4zv.ReadOnly = True
        Me.txtdatum4zv.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4zv.TabIndex = 88
        Me.txtdatum4zv.Text = ""
        '
        'txtdatum2zv
        '
        Me.txtdatum2zv.BackColor = System.Drawing.Color.White
        Me.txtdatum2zv.Enabled = False
        Me.txtdatum2zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2zv.Location = New System.Drawing.Point(112, 32)
        Me.txtdatum2zv.Name = "txtdatum2zv"
        Me.txtdatum2zv.ReadOnly = True
        Me.txtdatum2zv.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2zv.TabIndex = 85
        Me.txtdatum2zv.Text = ""
        '
        'cbzvrollend1
        '
        Me.cbzvrollend1.Location = New System.Drawing.Point(216, 8)
        Me.cbzvrollend1.Name = "cbzvrollend1"
        Me.cbzvrollend1.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend1.TabIndex = 89
        Me.cbzvrollend1.Text = "(rollend)"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(8, 64)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(64, 48)
        Me.Label26.TabIndex = 83
        Me.Label26.Text = "Archivie-rung"
        '
        'Button21
        '
        Me.Button21.Image = CType(resources.GetObject("Button21.Image"), System.Drawing.Bitmap)
        Me.Button21.Location = New System.Drawing.Point(288, 88)
        Me.Button21.Name = "Button21"
        Me.Button21.Size = New System.Drawing.Size(32, 24)
        Me.Button21.TabIndex = 102
        '
        'DateTimePicker13
        '
        Me.DateTimePicker13.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker13.Location = New System.Drawing.Point(112, 64)
        Me.DateTimePicker13.Name = "DateTimePicker13"
        Me.DateTimePicker13.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker13.TabIndex = 80
        Me.DateTimePicker13.TabStop = False
        Me.DateTimePicker13.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Button22
        '
        Me.Button22.Image = CType(resources.GetObject("Button22.Image"), System.Drawing.Bitmap)
        Me.Button22.Location = New System.Drawing.Point(288, 32)
        Me.Button22.Name = "Button22"
        Me.Button22.Size = New System.Drawing.Size(32, 24)
        Me.Button22.TabIndex = 100
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(72, 64)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(32, 23)
        Me.Label28.TabIndex = 93
        Me.Label28.Text = "von"
        '
        'Label41
        '
        Me.Label41.Location = New System.Drawing.Point(72, 88)
        Me.Label41.Name = "Label41"
        Me.Label41.Size = New System.Drawing.Size(32, 23)
        Me.Label41.TabIndex = 94
        Me.Label41.Text = "bis"
        '
        'Button23
        '
        Me.Button23.Image = CType(resources.GetObject("Button23.Image"), System.Drawing.Bitmap)
        Me.Button23.Location = New System.Drawing.Point(288, 64)
        Me.Button23.Name = "Button23"
        Me.Button23.Size = New System.Drawing.Size(32, 24)
        Me.Button23.TabIndex = 101
        '
        'Button24
        '
        Me.Button24.Image = CType(resources.GetObject("Button24.Image"), System.Drawing.Bitmap)
        Me.Button24.Location = New System.Drawing.Point(288, 8)
        Me.Button24.Name = "Button24"
        Me.Button24.Size = New System.Drawing.Size(32, 24)
        Me.Button24.TabIndex = 99
        '
        'cbzvrollend4
        '
        Me.cbzvrollend4.Location = New System.Drawing.Point(216, 88)
        Me.cbzvrollend4.Name = "cbzvrollend4"
        Me.cbzvrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend4.TabIndex = 96
        Me.cbzvrollend4.Text = "(rollend)"
        '
        'cbzvrollend2
        '
        Me.cbzvrollend2.Location = New System.Drawing.Point(216, 32)
        Me.cbzvrollend2.Name = "cbzvrollend2"
        Me.cbzvrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend2.TabIndex = 90
        Me.cbzvrollend2.Text = "(rollend)"
        '
        'Label42
        '
        Me.Label42.Location = New System.Drawing.Point(8, 8)
        Me.Label42.Name = "Label42"
        Me.Label42.Size = New System.Drawing.Size(56, 23)
        Me.Label42.TabIndex = 82
        Me.Label42.Text = "Valuta"
        '
        'txtdatum1zv
        '
        Me.txtdatum1zv.BackColor = System.Drawing.Color.White
        Me.txtdatum1zv.Enabled = False
        Me.txtdatum1zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1zv.Location = New System.Drawing.Point(112, 8)
        Me.txtdatum1zv.Name = "txtdatum1zv"
        Me.txtdatum1zv.ReadOnly = True
        Me.txtdatum1zv.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1zv.TabIndex = 84
        Me.txtdatum1zv.Text = ""
        '
        'Label43
        '
        Me.Label43.Location = New System.Drawing.Point(72, 32)
        Me.Label43.Name = "Label43"
        Me.Label43.Size = New System.Drawing.Size(32, 23)
        Me.Label43.TabIndex = 87
        Me.Label43.Text = "bis"
        '
        'cbzvrollend3
        '
        Me.cbzvrollend3.Location = New System.Drawing.Point(216, 64)
        Me.cbzvrollend3.Name = "cbzvrollend3"
        Me.cbzvrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend3.TabIndex = 95
        Me.cbzvrollend3.Text = "(rollend)"
        '
        'Label44
        '
        Me.Label44.Location = New System.Drawing.Point(72, 8)
        Me.Label44.Name = "Label44"
        Me.Label44.Size = New System.Drawing.Size(32, 23)
        Me.Label44.TabIndex = 77
        Me.Label44.Text = "von"
        '
        'textdatum1zv
        '
        Me.textdatum1zv.Location = New System.Drawing.Point(224, 8)
        Me.textdatum1zv.Name = "textdatum1zv"
        Me.textdatum1zv.TabIndex = 91
        Me.textdatum1zv.Visible = False
        '
        'textdatum2zv
        '
        Me.textdatum2zv.Location = New System.Drawing.Point(224, 32)
        Me.textdatum2zv.Name = "textdatum2zv"
        Me.textdatum2zv.TabIndex = 92
        Me.textdatum2zv.Visible = False
        '
        'textdatum3zv
        '
        Me.textdatum3zv.Location = New System.Drawing.Point(224, 64)
        Me.textdatum3zv.Name = "textdatum3zv"
        Me.textdatum3zv.TabIndex = 97
        Me.textdatum3zv.Visible = False
        '
        'textdatum4zv
        '
        Me.textdatum4zv.Location = New System.Drawing.Point(224, 88)
        Me.textdatum4zv.Name = "textdatum4zv"
        Me.textdatum4zv.TabIndex = 98
        Me.textdatum4zv.Visible = False
        '
        'DateTimePicker14
        '
        Me.DateTimePicker14.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker14.Location = New System.Drawing.Point(112, 8)
        Me.DateTimePicker14.Name = "DateTimePicker14"
        Me.DateTimePicker14.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker14.TabIndex = 78
        Me.DateTimePicker14.TabStop = False
        Me.DateTimePicker14.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker15
        '
        Me.DateTimePicker15.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker15.Location = New System.Drawing.Point(112, 32)
        Me.DateTimePicker15.Name = "DateTimePicker15"
        Me.DateTimePicker15.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker15.TabIndex = 79
        Me.DateTimePicker15.TabStop = False
        Me.DateTimePicker15.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker16
        '
        Me.DateTimePicker16.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker16.Location = New System.Drawing.Point(112, 88)
        Me.DateTimePicker16.Name = "DateTimePicker16"
        Me.DateTimePicker16.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker16.TabIndex = 81
        Me.DateTimePicker16.TabStop = False
        Me.DateTimePicker16.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'TabPage5
        '
        Me.TabPage5.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtdatum4uvm, Me.txtdatum3uvm, Me.txtdatum2uvm, Me.cbuvmrollend1, Me.Label49, Me.Button25, Me.DateTimePicker17, Me.Button26, Me.Label50, Me.Label51, Me.Button27, Me.Button28, Me.cbuvmrollend4, Me.cbuvmrollend2, Me.Label52, Me.txtdatum1uvm, Me.Label53, Me.cbuvmrollend3, Me.Label54, Me.textdatum1uvm, Me.textdatum2uvm, Me.textdatum3uvm, Me.textdatum4uvm, Me.DateTimePicker18, Me.DateTimePicker19, Me.DateTimePicker20})
        Me.TabPage5.Location = New System.Drawing.Point(4, 25)
        Me.TabPage5.Name = "TabPage5"
        Me.TabPage5.Size = New System.Drawing.Size(336, 179)
        Me.TabPage5.TabIndex = 2
        Me.TabPage5.Text = "Basis-Verträge"
        '
        'txtdatum4uvm
        '
        Me.txtdatum4uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum4uvm.Enabled = False
        Me.txtdatum4uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4uvm.Location = New System.Drawing.Point(112, 88)
        Me.txtdatum4uvm.Name = "txtdatum4uvm"
        Me.txtdatum4uvm.ReadOnly = True
        Me.txtdatum4uvm.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4uvm.TabIndex = 88
        Me.txtdatum4uvm.Text = ""
        '
        'txtdatum3uvm
        '
        Me.txtdatum3uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum3uvm.Enabled = False
        Me.txtdatum3uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3uvm.Location = New System.Drawing.Point(112, 64)
        Me.txtdatum3uvm.Name = "txtdatum3uvm"
        Me.txtdatum3uvm.ReadOnly = True
        Me.txtdatum3uvm.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3uvm.TabIndex = 86
        Me.txtdatum3uvm.Text = ""
        '
        'txtdatum2uvm
        '
        Me.txtdatum2uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum2uvm.Enabled = False
        Me.txtdatum2uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2uvm.Location = New System.Drawing.Point(112, 32)
        Me.txtdatum2uvm.Name = "txtdatum2uvm"
        Me.txtdatum2uvm.ReadOnly = True
        Me.txtdatum2uvm.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2uvm.TabIndex = 85
        Me.txtdatum2uvm.Text = ""
        '
        'cbuvmrollend1
        '
        Me.cbuvmrollend1.Location = New System.Drawing.Point(216, 8)
        Me.cbuvmrollend1.Name = "cbuvmrollend1"
        Me.cbuvmrollend1.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend1.TabIndex = 89
        Me.cbuvmrollend1.Text = "(rollend)"
        '
        'Label49
        '
        Me.Label49.Location = New System.Drawing.Point(8, 64)
        Me.Label49.Name = "Label49"
        Me.Label49.Size = New System.Drawing.Size(64, 32)
        Me.Label49.TabIndex = 83
        Me.Label49.Text = "Archivie-rung"
        '
        'Button25
        '
        Me.Button25.Image = CType(resources.GetObject("Button25.Image"), System.Drawing.Bitmap)
        Me.Button25.Location = New System.Drawing.Point(288, 88)
        Me.Button25.Name = "Button25"
        Me.Button25.Size = New System.Drawing.Size(32, 24)
        Me.Button25.TabIndex = 102
        '
        'DateTimePicker17
        '
        Me.DateTimePicker17.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker17.Location = New System.Drawing.Point(112, 64)
        Me.DateTimePicker17.Name = "DateTimePicker17"
        Me.DateTimePicker17.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker17.TabIndex = 80
        Me.DateTimePicker17.TabStop = False
        Me.DateTimePicker17.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Button26
        '
        Me.Button26.Image = CType(resources.GetObject("Button26.Image"), System.Drawing.Bitmap)
        Me.Button26.Location = New System.Drawing.Point(288, 32)
        Me.Button26.Name = "Button26"
        Me.Button26.Size = New System.Drawing.Size(32, 24)
        Me.Button26.TabIndex = 100
        '
        'Label50
        '
        Me.Label50.Location = New System.Drawing.Point(72, 64)
        Me.Label50.Name = "Label50"
        Me.Label50.Size = New System.Drawing.Size(32, 23)
        Me.Label50.TabIndex = 93
        Me.Label50.Text = "von"
        '
        'Label51
        '
        Me.Label51.Location = New System.Drawing.Point(72, 88)
        Me.Label51.Name = "Label51"
        Me.Label51.Size = New System.Drawing.Size(32, 23)
        Me.Label51.TabIndex = 94
        Me.Label51.Text = "bis"
        '
        'Button27
        '
        Me.Button27.Image = CType(resources.GetObject("Button27.Image"), System.Drawing.Bitmap)
        Me.Button27.Location = New System.Drawing.Point(288, 64)
        Me.Button27.Name = "Button27"
        Me.Button27.Size = New System.Drawing.Size(32, 24)
        Me.Button27.TabIndex = 101
        '
        'Button28
        '
        Me.Button28.Image = CType(resources.GetObject("Button28.Image"), System.Drawing.Bitmap)
        Me.Button28.Location = New System.Drawing.Point(288, 8)
        Me.Button28.Name = "Button28"
        Me.Button28.Size = New System.Drawing.Size(32, 24)
        Me.Button28.TabIndex = 99
        '
        'cbuvmrollend4
        '
        Me.cbuvmrollend4.Location = New System.Drawing.Point(216, 88)
        Me.cbuvmrollend4.Name = "cbuvmrollend4"
        Me.cbuvmrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend4.TabIndex = 96
        Me.cbuvmrollend4.Text = "(rollend)"
        '
        'cbuvmrollend2
        '
        Me.cbuvmrollend2.Location = New System.Drawing.Point(216, 32)
        Me.cbuvmrollend2.Name = "cbuvmrollend2"
        Me.cbuvmrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend2.TabIndex = 90
        Me.cbuvmrollend2.Text = "(rollend)"
        '
        'Label52
        '
        Me.Label52.Location = New System.Drawing.Point(8, 8)
        Me.Label52.Name = "Label52"
        Me.Label52.Size = New System.Drawing.Size(56, 23)
        Me.Label52.TabIndex = 82
        Me.Label52.Text = "Erstellung"
        '
        'txtdatum1uvm
        '
        Me.txtdatum1uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum1uvm.Enabled = False
        Me.txtdatum1uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1uvm.Location = New System.Drawing.Point(112, 8)
        Me.txtdatum1uvm.Name = "txtdatum1uvm"
        Me.txtdatum1uvm.ReadOnly = True
        Me.txtdatum1uvm.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1uvm.TabIndex = 84
        Me.txtdatum1uvm.Text = ""
        '
        'Label53
        '
        Me.Label53.Location = New System.Drawing.Point(72, 32)
        Me.Label53.Name = "Label53"
        Me.Label53.Size = New System.Drawing.Size(32, 23)
        Me.Label53.TabIndex = 87
        Me.Label53.Text = "bis"
        '
        'cbuvmrollend3
        '
        Me.cbuvmrollend3.Location = New System.Drawing.Point(216, 64)
        Me.cbuvmrollend3.Name = "cbuvmrollend3"
        Me.cbuvmrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend3.TabIndex = 95
        Me.cbuvmrollend3.Text = "(rollend)"
        '
        'Label54
        '
        Me.Label54.Location = New System.Drawing.Point(72, 8)
        Me.Label54.Name = "Label54"
        Me.Label54.Size = New System.Drawing.Size(32, 23)
        Me.Label54.TabIndex = 77
        Me.Label54.Text = "von"
        '
        'textdatum1uvm
        '
        Me.textdatum1uvm.Location = New System.Drawing.Point(224, 8)
        Me.textdatum1uvm.Name = "textdatum1uvm"
        Me.textdatum1uvm.TabIndex = 91
        Me.textdatum1uvm.Visible = False
        '
        'textdatum2uvm
        '
        Me.textdatum2uvm.Location = New System.Drawing.Point(224, 32)
        Me.textdatum2uvm.Name = "textdatum2uvm"
        Me.textdatum2uvm.TabIndex = 92
        Me.textdatum2uvm.Visible = False
        '
        'textdatum3uvm
        '
        Me.textdatum3uvm.Location = New System.Drawing.Point(224, 64)
        Me.textdatum3uvm.Name = "textdatum3uvm"
        Me.textdatum3uvm.TabIndex = 97
        Me.textdatum3uvm.Visible = False
        '
        'textdatum4uvm
        '
        Me.textdatum4uvm.Location = New System.Drawing.Point(224, 88)
        Me.textdatum4uvm.Name = "textdatum4uvm"
        Me.textdatum4uvm.TabIndex = 98
        Me.textdatum4uvm.Visible = False
        '
        'DateTimePicker18
        '
        Me.DateTimePicker18.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker18.Location = New System.Drawing.Point(112, 8)
        Me.DateTimePicker18.Name = "DateTimePicker18"
        Me.DateTimePicker18.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker18.TabIndex = 78
        Me.DateTimePicker18.TabStop = False
        Me.DateTimePicker18.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker19
        '
        Me.DateTimePicker19.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker19.Location = New System.Drawing.Point(112, 32)
        Me.DateTimePicker19.Name = "DateTimePicker19"
        Me.DateTimePicker19.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker19.TabIndex = 79
        Me.DateTimePicker19.TabStop = False
        Me.DateTimePicker19.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker20
        '
        Me.DateTimePicker20.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker20.Location = New System.Drawing.Point(112, 88)
        Me.DateTimePicker20.Name = "DateTimePicker20"
        Me.DateTimePicker20.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker20.TabIndex = 81
        Me.DateTimePicker20.TabStop = False
        Me.DateTimePicker20.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'cinklalt
        '
        Me.cinklalt.Location = New System.Drawing.Point(16, 264)
        Me.cinklalt.Name = "cinklalt"
        Me.cinklalt.Size = New System.Drawing.Size(336, 24)
        Me.cinklalt.TabIndex = 84
        Me.cinklalt.Text = "nach Abschluss gelöschte oder aufgehobene Dokumente"
        '
        'cbmavip
        '
        Me.cbmavip.Location = New System.Drawing.Point(16, 248)
        Me.cbmavip.Name = "cbmavip"
        Me.cbmavip.Size = New System.Drawing.Size(264, 24)
        Me.cbmavip.TabIndex = 82
        Me.cbmavip.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.cbmavip.Visible = False
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(256, 344)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(40, 23)
        Me.Label8.TabIndex = 70
        Me.Label8.Text = "Tagen"
        Me.Label8.Visible = False
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(256, 320)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(40, 23)
        Me.Label7.TabIndex = 69
        Me.Label7.Text = "Tagen"
        Me.Label7.Visible = False
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(32, 344)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(160, 23)
        Me.Label6.TabIndex = 67
        Me.Label6.Text = "Mutationsdatum in den letzen "
        Me.Label6.Visible = False
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(32, 320)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(160, 23)
        Me.Label5.TabIndex = 66
        Me.Label5.Text = "Erstellungsdatum in den letzen"
        Me.Label5.Visible = False
        '
        'cbd6
        '
        Me.cbd6.Location = New System.Drawing.Point(16, 464)
        Me.cbd6.Name = "cbd6"
        Me.cbd6.Size = New System.Drawing.Size(16, 24)
        Me.cbd6.TabIndex = 64
        Me.cbd6.Visible = False
        '
        'cbd4
        '
        Me.cbd4.Location = New System.Drawing.Point(16, 440)
        Me.cbd4.Name = "cbd4"
        Me.cbd4.Size = New System.Drawing.Size(16, 24)
        Me.cbd4.TabIndex = 62
        Me.cbd4.Visible = False
        '
        'cbd2
        '
        Me.cbd2.Location = New System.Drawing.Point(16, 416)
        Me.cbd2.Name = "cbd2"
        Me.cbd2.Size = New System.Drawing.Size(16, 24)
        Me.cbd2.TabIndex = 60
        Me.cbd2.Visible = False
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(48, 464)
        Me.Label18.Name = "Label18"
        Me.Label18.TabIndex = 53
        Me.Label18.Text = "Archivierung bis"
        Me.Label18.Visible = False
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(48, 440)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 51
        Me.Label16.Text = "Mutation bis"
        Me.Label16.Visible = False
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(48, 416)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(96, 23)
        Me.Label14.TabIndex = 49
        Me.Label14.Text = "Erstellung bis"
        Me.Label14.Visible = False
        '
        'GroupBox10
        '
        Me.GroupBox10.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox10.Location = New System.Drawing.Point(8, 248)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(360, 64)
        Me.GroupBox10.TabIndex = 85
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Datenselektion"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(344, 48)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(16, 16)
        Me.Button1.TabIndex = 74
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(344, 88)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(16, 16)
        Me.Button2.TabIndex = 75
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(344, 136)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(16, 16)
        Me.Button3.TabIndex = 76
        '
        'Groupbox3
        '
        Me.Groupbox3.Location = New System.Drawing.Point(8, 8)
        Me.Groupbox3.Name = "Groupbox3"
        Me.Groupbox3.Size = New System.Drawing.Size(360, 232)
        Me.Groupbox3.TabIndex = 87
        Me.Groupbox3.TabStop = False
        Me.Groupbox3.Text = "Datum-Selektion"
        '
        'pnlzv
        '
        Me.pnlzv.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnzvzahlungsart, Me.Label62, Me.txtzvzahlungsart, Me.btnzvverarbeitungsart, Me.Label61, Me.txtzvverarbeitungsart, Me.btnzvswift, Me.Label60, Me.txtzvswift, Me.btnzvreferenz, Me.Label59, Me.txtzvreferenznr, Me.btnzvposten, Me.Label58, Me.txtzvpostennr, Me.btnzvpcnr, Me.Label57, Me.txtzvpcnr, Me.btnzvbeguenstiger, Me.Label56, Me.txtzvbeguenstigter, Me.btnzviso, Me.Label55, Me.txtzviso, Me.btnzvclearing, Me.Label48, Me.txtzvclearingnr, Me.btnzvbetrag, Me.Label47, Me.txtzvbetrag, Me.btnzvauftraggeber, Me.Label46, Me.txtzvauftraggeber, Me.btnzvauftragsnr, Me.Label63, Me.txtzvauftragsnr, Me.GroupBox13})
        Me.pnlzv.Location = New System.Drawing.Point(224, 8)
        Me.pnlzv.Name = "pnlzv"
        Me.pnlzv.Size = New System.Drawing.Size(376, 504)
        Me.pnlzv.TabIndex = 11
        '
        'btnzvzahlungsart
        '
        Me.btnzvzahlungsart.Location = New System.Drawing.Point(320, 384)
        Me.btnzvzahlungsart.Name = "btnzvzahlungsart"
        Me.btnzvzahlungsart.Size = New System.Drawing.Size(32, 24)
        Me.btnzvzahlungsart.TabIndex = 35
        Me.btnzvzahlungsart.Text = "OK"
        '
        'Label62
        '
        Me.Label62.Location = New System.Drawing.Point(16, 384)
        Me.Label62.Name = "Label62"
        Me.Label62.TabIndex = 34
        Me.Label62.Text = "Zahlungsart"
        '
        'txtzvzahlungsart
        '
        Me.txtzvzahlungsart.Location = New System.Drawing.Point(120, 384)
        Me.txtzvzahlungsart.Name = "txtzvzahlungsart"
        Me.txtzvzahlungsart.Size = New System.Drawing.Size(192, 20)
        Me.txtzvzahlungsart.TabIndex = 33
        Me.txtzvzahlungsart.Text = ""
        '
        'btnzvverarbeitungsart
        '
        Me.btnzvverarbeitungsart.Location = New System.Drawing.Point(320, 352)
        Me.btnzvverarbeitungsart.Name = "btnzvverarbeitungsart"
        Me.btnzvverarbeitungsart.Size = New System.Drawing.Size(32, 24)
        Me.btnzvverarbeitungsart.TabIndex = 32
        Me.btnzvverarbeitungsart.Text = "OK"
        '
        'Label61
        '
        Me.Label61.Location = New System.Drawing.Point(16, 352)
        Me.Label61.Name = "Label61"
        Me.Label61.TabIndex = 31
        Me.Label61.Text = "Verarbeitungsart"
        '
        'txtzvverarbeitungsart
        '
        Me.txtzvverarbeitungsart.Location = New System.Drawing.Point(120, 352)
        Me.txtzvverarbeitungsart.Name = "txtzvverarbeitungsart"
        Me.txtzvverarbeitungsart.Size = New System.Drawing.Size(192, 20)
        Me.txtzvverarbeitungsart.TabIndex = 30
        Me.txtzvverarbeitungsart.Text = ""
        '
        'btnzvswift
        '
        Me.btnzvswift.Location = New System.Drawing.Point(320, 320)
        Me.btnzvswift.Name = "btnzvswift"
        Me.btnzvswift.Size = New System.Drawing.Size(32, 24)
        Me.btnzvswift.TabIndex = 29
        Me.btnzvswift.Text = "OK"
        '
        'Label60
        '
        Me.Label60.Location = New System.Drawing.Point(16, 320)
        Me.Label60.Name = "Label60"
        Me.Label60.TabIndex = 28
        Me.Label60.Text = "SWIFT-Adresse"
        '
        'txtzvswift
        '
        Me.txtzvswift.Location = New System.Drawing.Point(120, 320)
        Me.txtzvswift.Name = "txtzvswift"
        Me.txtzvswift.Size = New System.Drawing.Size(192, 20)
        Me.txtzvswift.TabIndex = 27
        Me.txtzvswift.Text = ""
        '
        'btnzvreferenz
        '
        Me.btnzvreferenz.Location = New System.Drawing.Point(320, 288)
        Me.btnzvreferenz.Name = "btnzvreferenz"
        Me.btnzvreferenz.Size = New System.Drawing.Size(32, 24)
        Me.btnzvreferenz.TabIndex = 26
        Me.btnzvreferenz.Text = "OK"
        '
        'Label59
        '
        Me.Label59.Location = New System.Drawing.Point(16, 288)
        Me.Label59.Name = "Label59"
        Me.Label59.TabIndex = 25
        Me.Label59.Text = "Referenz-Nr"
        '
        'txtzvreferenznr
        '
        Me.txtzvreferenznr.Location = New System.Drawing.Point(120, 288)
        Me.txtzvreferenznr.Name = "txtzvreferenznr"
        Me.txtzvreferenznr.Size = New System.Drawing.Size(192, 20)
        Me.txtzvreferenznr.TabIndex = 24
        Me.txtzvreferenznr.Text = ""
        '
        'btnzvposten
        '
        Me.btnzvposten.Location = New System.Drawing.Point(320, 256)
        Me.btnzvposten.Name = "btnzvposten"
        Me.btnzvposten.Size = New System.Drawing.Size(32, 24)
        Me.btnzvposten.TabIndex = 23
        Me.btnzvposten.Text = "OK"
        '
        'Label58
        '
        Me.Label58.Location = New System.Drawing.Point(16, 256)
        Me.Label58.Name = "Label58"
        Me.Label58.TabIndex = 22
        Me.Label58.Text = "Posten-Nr"
        '
        'txtzvpostennr
        '
        Me.txtzvpostennr.Location = New System.Drawing.Point(120, 256)
        Me.txtzvpostennr.Name = "txtzvpostennr"
        Me.txtzvpostennr.Size = New System.Drawing.Size(192, 20)
        Me.txtzvpostennr.TabIndex = 21
        Me.txtzvpostennr.Text = ""
        '
        'btnzvpcnr
        '
        Me.btnzvpcnr.Location = New System.Drawing.Point(320, 224)
        Me.btnzvpcnr.Name = "btnzvpcnr"
        Me.btnzvpcnr.Size = New System.Drawing.Size(32, 24)
        Me.btnzvpcnr.TabIndex = 20
        Me.btnzvpcnr.Text = "OK"
        '
        'Label57
        '
        Me.Label57.Location = New System.Drawing.Point(16, 224)
        Me.Label57.Name = "Label57"
        Me.Label57.TabIndex = 19
        Me.Label57.Text = "PC-Nr"
        '
        'txtzvpcnr
        '
        Me.txtzvpcnr.Location = New System.Drawing.Point(120, 224)
        Me.txtzvpcnr.Name = "txtzvpcnr"
        Me.txtzvpcnr.Size = New System.Drawing.Size(192, 20)
        Me.txtzvpcnr.TabIndex = 18
        Me.txtzvpcnr.Text = ""
        '
        'btnzvbeguenstiger
        '
        Me.btnzvbeguenstiger.Location = New System.Drawing.Point(320, 192)
        Me.btnzvbeguenstiger.Name = "btnzvbeguenstiger"
        Me.btnzvbeguenstiger.Size = New System.Drawing.Size(32, 24)
        Me.btnzvbeguenstiger.TabIndex = 17
        Me.btnzvbeguenstiger.Text = "OK"
        '
        'Label56
        '
        Me.Label56.Location = New System.Drawing.Point(16, 192)
        Me.Label56.Name = "Label56"
        Me.Label56.TabIndex = 16
        Me.Label56.Text = "Kto. Begünstiger"
        '
        'txtzvbeguenstigter
        '
        Me.txtzvbeguenstigter.Location = New System.Drawing.Point(120, 192)
        Me.txtzvbeguenstigter.Name = "txtzvbeguenstigter"
        Me.txtzvbeguenstigter.Size = New System.Drawing.Size(192, 20)
        Me.txtzvbeguenstigter.TabIndex = 15
        Me.txtzvbeguenstigter.Text = ""
        '
        'btnzviso
        '
        Me.btnzviso.Location = New System.Drawing.Point(320, 160)
        Me.btnzviso.Name = "btnzviso"
        Me.btnzviso.Size = New System.Drawing.Size(32, 24)
        Me.btnzviso.TabIndex = 14
        Me.btnzviso.Text = "OK"
        '
        'Label55
        '
        Me.Label55.Location = New System.Drawing.Point(16, 160)
        Me.Label55.Name = "Label55"
        Me.Label55.TabIndex = 13
        Me.Label55.Text = "ISO-Währung"
        '
        'txtzviso
        '
        Me.txtzviso.Location = New System.Drawing.Point(120, 160)
        Me.txtzviso.Name = "txtzviso"
        Me.txtzviso.Size = New System.Drawing.Size(192, 20)
        Me.txtzviso.TabIndex = 12
        Me.txtzviso.Text = ""
        '
        'btnzvclearing
        '
        Me.btnzvclearing.Location = New System.Drawing.Point(320, 128)
        Me.btnzvclearing.Name = "btnzvclearing"
        Me.btnzvclearing.Size = New System.Drawing.Size(32, 24)
        Me.btnzvclearing.TabIndex = 11
        Me.btnzvclearing.Text = "OK"
        '
        'Label48
        '
        Me.Label48.Location = New System.Drawing.Point(16, 128)
        Me.Label48.Name = "Label48"
        Me.Label48.TabIndex = 10
        Me.Label48.Text = "Clearingnr"
        '
        'txtzvclearingnr
        '
        Me.txtzvclearingnr.Location = New System.Drawing.Point(120, 128)
        Me.txtzvclearingnr.Name = "txtzvclearingnr"
        Me.txtzvclearingnr.Size = New System.Drawing.Size(192, 20)
        Me.txtzvclearingnr.TabIndex = 9
        Me.txtzvclearingnr.Text = ""
        '
        'btnzvbetrag
        '
        Me.btnzvbetrag.Location = New System.Drawing.Point(320, 96)
        Me.btnzvbetrag.Name = "btnzvbetrag"
        Me.btnzvbetrag.Size = New System.Drawing.Size(32, 24)
        Me.btnzvbetrag.TabIndex = 8
        Me.btnzvbetrag.Text = "OK"
        '
        'Label47
        '
        Me.Label47.Location = New System.Drawing.Point(16, 96)
        Me.Label47.Name = "Label47"
        Me.Label47.TabIndex = 7
        Me.Label47.Text = "Betrag"
        '
        'txtzvbetrag
        '
        Me.txtzvbetrag.Location = New System.Drawing.Point(120, 96)
        Me.txtzvbetrag.Name = "txtzvbetrag"
        Me.txtzvbetrag.Size = New System.Drawing.Size(192, 20)
        Me.txtzvbetrag.TabIndex = 6
        Me.txtzvbetrag.Text = ""
        '
        'btnzvauftraggeber
        '
        Me.btnzvauftraggeber.Location = New System.Drawing.Point(320, 64)
        Me.btnzvauftraggeber.Name = "btnzvauftraggeber"
        Me.btnzvauftraggeber.Size = New System.Drawing.Size(32, 24)
        Me.btnzvauftraggeber.TabIndex = 5
        Me.btnzvauftraggeber.Text = "OK"
        '
        'Label46
        '
        Me.Label46.Location = New System.Drawing.Point(16, 64)
        Me.Label46.Name = "Label46"
        Me.Label46.TabIndex = 4
        Me.Label46.Text = "Auftraggeber"
        '
        'txtzvauftraggeber
        '
        Me.txtzvauftraggeber.Location = New System.Drawing.Point(120, 64)
        Me.txtzvauftraggeber.Name = "txtzvauftraggeber"
        Me.txtzvauftraggeber.Size = New System.Drawing.Size(192, 20)
        Me.txtzvauftraggeber.TabIndex = 3
        Me.txtzvauftraggeber.Text = ""
        '
        'btnzvauftragsnr
        '
        Me.btnzvauftragsnr.Location = New System.Drawing.Point(320, 32)
        Me.btnzvauftragsnr.Name = "btnzvauftragsnr"
        Me.btnzvauftragsnr.Size = New System.Drawing.Size(32, 24)
        Me.btnzvauftragsnr.TabIndex = 2
        Me.btnzvauftragsnr.Text = "OK"
        '
        'Label63
        '
        Me.Label63.Location = New System.Drawing.Point(16, 32)
        Me.Label63.Name = "Label63"
        Me.Label63.TabIndex = 1
        Me.Label63.Text = "Auftragsnummer"
        '
        'txtzvauftragsnr
        '
        Me.txtzvauftragsnr.Location = New System.Drawing.Point(120, 32)
        Me.txtzvauftragsnr.Name = "txtzvauftragsnr"
        Me.txtzvauftragsnr.Size = New System.Drawing.Size(192, 20)
        Me.txtzvauftragsnr.TabIndex = 0
        Me.txtzvauftragsnr.Text = ""
        '
        'GroupBox13
        '
        Me.GroupBox13.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(360, 408)
        Me.GroupBox13.TabIndex = 36
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Diverse Selektionskriterien"
        '
        'pnlhostdiv
        '
        Me.pnlhostdiv.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox4, Me.Label20, Me.hostinklmavip, Me.Label29, Me.DateTimePicker7, Me.GroupBox6, Me.Label32, Me.Label33, Me.Label34, Me.Label35, Me.CheckBox3, Me.CheckBox4, Me.CheckBox5, Me.TextBox7, Me.TextBox8, Me.TextBox9, Me.Label36, Me.Label37, Me.Label38, Me.DateTimePicker10, Me.DateTimePicker11, Me.DateTimePicker12, Me.Button8, Me.Button7, Me.Button6})
        Me.pnlhostdiv.Location = New System.Drawing.Point(224, 8)
        Me.pnlhostdiv.Name = "pnlhostdiv"
        Me.pnlhostdiv.Size = New System.Drawing.Size(376, 496)
        Me.pnlhostdiv.TabIndex = 7
        Me.pnlhostdiv.Visible = False
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label66, Me.Label65, Me.Label64, Me.Button20, Me.TextBox6, Me.Button9, Me.TextBox4, Me.Button10, Me.TextBox5})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(360, 128)
        Me.GroupBox4.TabIndex = 91
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Diverse Selektionskriterien"
        '
        'Label66
        '
        Me.Label66.Location = New System.Drawing.Point(16, 88)
        Me.Label66.Name = "Label66"
        Me.Label66.Size = New System.Drawing.Size(104, 23)
        Me.Label66.TabIndex = 91
        Me.Label66.Text = "ISIN-Nummer"
        '
        'Label65
        '
        Me.Label65.Location = New System.Drawing.Point(16, 56)
        Me.Label65.Name = "Label65"
        Me.Label65.Size = New System.Drawing.Size(104, 23)
        Me.Label65.TabIndex = 90
        Me.Label65.Text = "Valoren-Nummer"
        '
        'Label64
        '
        Me.Label64.Location = New System.Drawing.Point(16, 24)
        Me.Label64.Name = "Label64"
        Me.Label64.Size = New System.Drawing.Size(104, 23)
        Me.Label64.TabIndex = 89
        Me.Label64.Text = "VV-Nummer extern"
        '
        'Button20
        '
        Me.Button20.Location = New System.Drawing.Point(248, 24)
        Me.Button20.Name = "Button20"
        Me.Button20.Size = New System.Drawing.Size(40, 23)
        Me.Button20.TabIndex = 88
        Me.Button20.Text = "&OK"
        '
        'TextBox6
        '
        Me.TextBox6.Location = New System.Drawing.Point(128, 24)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.Size = New System.Drawing.Size(112, 20)
        Me.TextBox6.TabIndex = 87
        Me.TextBox6.Text = ""
        '
        'Button9
        '
        Me.Button9.Location = New System.Drawing.Point(248, 56)
        Me.Button9.Name = "Button9"
        Me.Button9.Size = New System.Drawing.Size(40, 23)
        Me.Button9.TabIndex = 88
        Me.Button9.Text = "&OK"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(128, 56)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.Size = New System.Drawing.Size(112, 20)
        Me.TextBox4.TabIndex = 87
        Me.TextBox4.Text = ""
        '
        'Button10
        '
        Me.Button10.Location = New System.Drawing.Point(248, 88)
        Me.Button10.Name = "Button10"
        Me.Button10.Size = New System.Drawing.Size(40, 23)
        Me.Button10.TabIndex = 89
        Me.Button10.Text = "&OK"
        '
        'TextBox5
        '
        Me.TextBox5.Location = New System.Drawing.Point(128, 88)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.Size = New System.Drawing.Size(112, 20)
        Me.TextBox5.TabIndex = 88
        Me.TextBox5.Text = ""
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(184, 336)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 86
        Me.Label20.Text = "ISIN-Nummer"
        Me.Label20.Visible = False
        '
        'hostinklmavip
        '
        Me.hostinklmavip.Location = New System.Drawing.Point(16, 376)
        Me.hostinklmavip.Name = "hostinklmavip"
        Me.hostinklmavip.Size = New System.Drawing.Size(264, 24)
        Me.hostinklmavip.TabIndex = 82
        Me.hostinklmavip.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.hostinklmavip.Visible = False
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(16, 32)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(80, 23)
        Me.Label29.TabIndex = 48
        Me.Label29.Text = "Valuta-Datum"
        '
        'DateTimePicker7
        '
        Me.DateTimePicker7.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker7.Location = New System.Drawing.Point(264, 328)
        Me.DateTimePicker7.Name = "DateTimePicker7"
        Me.DateTimePicker7.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker7.TabIndex = 46
        Me.DateTimePicker7.TabStop = False
        Me.DateTimePicker7.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        Me.DateTimePicker7.Visible = False
        '
        'GroupBox6
        '
        Me.GroupBox6.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button18, Me.Button19, Me.DatumHostText2, Me.DatumHostText1, Me.cbrollend9, Me.cbrollend8, Me.HostDatum1, Me.Label9, Me.Label4, Me.lblhostdatum31, Me.ComboBox6, Me.Label27, Me.lblhostdatum3, Me.HostDatum3, Me.HostTag3, Me.HostDatum2, Me.DateTimePicker8, Me.lblhostdatum2, Me.DateTimePicker9})
        Me.GroupBox6.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(360, 88)
        Me.GroupBox6.TabIndex = 83
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Datumsselektion"
        '
        'Button18
        '
        Me.Button18.Image = CType(resources.GetObject("Button18.Image"), System.Drawing.Bitmap)
        Me.Button18.Location = New System.Drawing.Point(308, 49)
        Me.Button18.Name = "Button18"
        Me.Button18.Size = New System.Drawing.Size(32, 24)
        Me.Button18.TabIndex = 97
        '
        'Button19
        '
        Me.Button19.Image = CType(resources.GetObject("Button19.Image"), System.Drawing.Bitmap)
        Me.Button19.Location = New System.Drawing.Point(308, 25)
        Me.Button19.Name = "Button19"
        Me.Button19.Size = New System.Drawing.Size(32, 24)
        Me.Button19.TabIndex = 96
        '
        'DatumHostText2
        '
        Me.DatumHostText2.Location = New System.Drawing.Point(216, 80)
        Me.DatumHostText2.Name = "DatumHostText2"
        Me.DatumHostText2.TabIndex = 95
        Me.DatumHostText2.Text = "Label26"
        Me.DatumHostText2.Visible = False
        '
        'DatumHostText1
        '
        Me.DatumHostText1.Location = New System.Drawing.Point(88, 80)
        Me.DatumHostText1.Name = "DatumHostText1"
        Me.DatumHostText1.TabIndex = 94
        Me.DatumHostText1.Text = "Label26"
        Me.DatumHostText1.Visible = False
        '
        'cbrollend9
        '
        Me.cbrollend9.Location = New System.Drawing.Point(232, 48)
        Me.cbrollend9.Name = "cbrollend9"
        Me.cbrollend9.TabIndex = 93
        Me.cbrollend9.Text = "(rollend)"
        '
        'cbrollend8
        '
        Me.cbrollend8.Location = New System.Drawing.Point(232, 24)
        Me.cbrollend8.Name = "cbrollend8"
        Me.cbrollend8.Size = New System.Drawing.Size(96, 24)
        Me.cbrollend8.TabIndex = 92
        Me.cbrollend8.Text = "(rollend)"
        '
        'HostDatum1
        '
        Me.HostDatum1.BackColor = System.Drawing.Color.White
        Me.HostDatum1.Enabled = False
        Me.HostDatum1.ForeColor = System.Drawing.Color.Black
        Me.HostDatum1.Location = New System.Drawing.Point(128, 24)
        Me.HostDatum1.Name = "HostDatum1"
        Me.HostDatum1.ReadOnly = True
        Me.HostDatum1.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum1.TabIndex = 54
        Me.HostDatum1.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(88, 48)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(40, 23)
        Me.Label9.TabIndex = 91
        Me.Label9.Text = "bis"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(88, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(40, 23)
        Me.Label4.TabIndex = 90
        Me.Label4.Text = "von"
        '
        'lblhostdatum31
        '
        Me.lblhostdatum31.Location = New System.Drawing.Point(240, 152)
        Me.lblhostdatum31.Name = "lblhostdatum31"
        Me.lblhostdatum31.Size = New System.Drawing.Size(96, 16)
        Me.lblhostdatum31.TabIndex = 89
        Me.lblhostdatum31.Text = "(19.12.2003)"
        Me.lblhostdatum31.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.lblhostdatum31.Visible = False
        '
        'ComboBox6
        '
        Me.ComboBox6.ItemHeight = 13
        Me.ComboBox6.Items.AddRange(New Object() {"(heute)", "(heute-1)", "(heute-2)", "(heute-3)", "(heute-4)", "(heute-5)", "(heute-6)", "(heute-7)", "(heute-8)", "(heute-9)", "(heute-10)", "(heute-11)", "(heute-12)", "(heute-13)", "(heute-14)", "(heute-15)", "(heute-16)", "(heute-17)", "(heute-18)", "(heute-19)", "(heute-20)", "(heute-21)", "(heute-22)", "(heute-23)", "(heute-24)", "(heute-25)", "(heute-26)", "(heute-27)", "(heute-28)", "(heute-29)", "(heute-30)"})
        Me.ComboBox6.Location = New System.Drawing.Point(240, 128)
        Me.ComboBox6.Name = "ComboBox6"
        Me.ComboBox6.Size = New System.Drawing.Size(115, 21)
        Me.ComboBox6.TabIndex = 3
        Me.ComboBox6.Text = "ComboBox6"
        Me.ComboBox6.Visible = False
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(8, 128)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(72, 23)
        Me.Label27.TabIndex = 52
        Me.Label27.Text = "Archivierung"
        Me.Label27.Visible = False
        '
        'lblhostdatum3
        '
        Me.lblhostdatum3.Location = New System.Drawing.Point(160, 128)
        Me.lblhostdatum3.Name = "lblhostdatum3"
        Me.lblhostdatum3.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum3.TabIndex = 79
        Me.lblhostdatum3.Visible = False
        '
        'HostDatum3
        '
        Me.HostDatum3.BackColor = System.Drawing.Color.White
        Me.HostDatum3.Enabled = False
        Me.HostDatum3.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.HostDatum3.Location = New System.Drawing.Point(240, 128)
        Me.HostDatum3.Name = "HostDatum3"
        Me.HostDatum3.ReadOnly = True
        Me.HostDatum3.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum3.TabIndex = 58
        Me.HostDatum3.Text = "TextBox4"
        Me.HostDatum3.Visible = False
        '
        'HostTag3
        '
        Me.HostTag3.ItemHeight = 13
        Me.HostTag3.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.HostTag3.Location = New System.Drawing.Point(80, 128)
        Me.HostTag3.Name = "HostTag3"
        Me.HostTag3.Size = New System.Drawing.Size(56, 21)
        Me.HostTag3.TabIndex = 71
        Me.HostTag3.Text = "HostTag3"
        Me.HostTag3.Visible = False
        '
        'HostDatum2
        '
        Me.HostDatum2.BackColor = System.Drawing.Color.White
        Me.HostDatum2.Enabled = False
        Me.HostDatum2.ForeColor = System.Drawing.Color.Black
        Me.HostDatum2.Location = New System.Drawing.Point(128, 48)
        Me.HostDatum2.Name = "HostDatum2"
        Me.HostDatum2.ReadOnly = True
        Me.HostDatum2.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum2.TabIndex = 56
        Me.HostDatum2.Text = ""
        '
        'DateTimePicker8
        '
        Me.DateTimePicker8.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker8.Location = New System.Drawing.Point(128, 48)
        Me.DateTimePicker8.Name = "DateTimePicker8"
        Me.DateTimePicker8.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker8.TabIndex = 44
        Me.DateTimePicker8.TabStop = False
        Me.DateTimePicker8.Value = New Date(2004, 1, 14, 18, 49, 59, 203)
        '
        'lblhostdatum2
        '
        Me.lblhostdatum2.Location = New System.Drawing.Point(160, 72)
        Me.lblhostdatum2.Name = "lblhostdatum2"
        Me.lblhostdatum2.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum2.TabIndex = 78
        Me.lblhostdatum2.Visible = False
        '
        'DateTimePicker9
        '
        Me.DateTimePicker9.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker9.Location = New System.Drawing.Point(128, 24)
        Me.DateTimePicker9.Name = "DateTimePicker9"
        Me.DateTimePicker9.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker9.TabIndex = 42
        Me.DateTimePicker9.TabStop = False
        Me.DateTimePicker9.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(304, 456)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(40, 23)
        Me.Label32.TabIndex = 70
        Me.Label32.Text = "Tagen"
        Me.Label32.Visible = False
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(304, 432)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(40, 23)
        Me.Label33.TabIndex = 69
        Me.Label33.Text = "Tagen"
        Me.Label33.Visible = False
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(80, 456)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(160, 23)
        Me.Label34.TabIndex = 67
        Me.Label34.Text = "Mutationsdatum in den letzen "
        Me.Label34.Visible = False
        '
        'Label35
        '
        Me.Label35.Location = New System.Drawing.Point(80, 432)
        Me.Label35.Name = "Label35"
        Me.Label35.Size = New System.Drawing.Size(160, 23)
        Me.Label35.TabIndex = 66
        Me.Label35.Text = "Erstellungsdatum in den letzen"
        Me.Label35.Visible = False
        '
        'CheckBox3
        '
        Me.CheckBox3.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox3.Name = "CheckBox3"
        Me.CheckBox3.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox3.TabIndex = 64
        Me.CheckBox3.Visible = False
        '
        'CheckBox4
        '
        Me.CheckBox4.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox4.Name = "CheckBox4"
        Me.CheckBox4.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox4.TabIndex = 62
        Me.CheckBox4.Visible = False
        '
        'CheckBox5
        '
        Me.CheckBox5.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox5.Name = "CheckBox5"
        Me.CheckBox5.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox5.TabIndex = 60
        Me.CheckBox5.Visible = False
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.White
        Me.TextBox7.Enabled = False
        Me.TextBox7.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox7.Location = New System.Drawing.Point(160, 464)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(80, 20)
        Me.TextBox7.TabIndex = 59
        Me.TextBox7.Text = "TextBox4"
        Me.TextBox7.Visible = False
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.White
        Me.TextBox8.Enabled = False
        Me.TextBox8.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox8.Location = New System.Drawing.Point(160, 440)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(80, 20)
        Me.TextBox8.TabIndex = 57
        Me.TextBox8.Text = "TextBox4"
        Me.TextBox8.Visible = False
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.White
        Me.TextBox9.Enabled = False
        Me.TextBox9.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox9.Location = New System.Drawing.Point(160, 416)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(80, 20)
        Me.TextBox9.TabIndex = 55
        Me.TextBox9.Text = "TextBox4"
        Me.TextBox9.Visible = False
        '
        'Label36
        '
        Me.Label36.Location = New System.Drawing.Point(48, 464)
        Me.Label36.Name = "Label36"
        Me.Label36.TabIndex = 53
        Me.Label36.Text = "Archivierung bis"
        Me.Label36.Visible = False
        '
        'Label37
        '
        Me.Label37.Location = New System.Drawing.Point(48, 440)
        Me.Label37.Name = "Label37"
        Me.Label37.Size = New System.Drawing.Size(96, 23)
        Me.Label37.TabIndex = 51
        Me.Label37.Text = "Mutation bis"
        Me.Label37.Visible = False
        '
        'Label38
        '
        Me.Label38.Location = New System.Drawing.Point(48, 416)
        Me.Label38.Name = "Label38"
        Me.Label38.Size = New System.Drawing.Size(96, 23)
        Me.Label38.TabIndex = 49
        Me.Label38.Text = "Erstellung bis"
        Me.Label38.Visible = False
        '
        'DateTimePicker10
        '
        Me.DateTimePicker10.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker10.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker10.Name = "DateTimePicker10"
        Me.DateTimePicker10.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker10.TabIndex = 47
        Me.DateTimePicker10.TabStop = False
        Me.DateTimePicker10.Value = New Date(2004, 1, 14, 18, 49, 59, 312)
        Me.DateTimePicker10.Visible = False
        '
        'DateTimePicker11
        '
        Me.DateTimePicker11.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker11.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker11.Name = "DateTimePicker11"
        Me.DateTimePicker11.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker11.TabIndex = 45
        Me.DateTimePicker11.TabStop = False
        Me.DateTimePicker11.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker11.Visible = False
        '
        'DateTimePicker12
        '
        Me.DateTimePicker12.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker12.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker12.Name = "DateTimePicker12"
        Me.DateTimePicker12.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker12.TabIndex = 43
        Me.DateTimePicker12.TabStop = False
        Me.DateTimePicker12.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker12.Visible = False
        '
        'Button8
        '
        Me.Button8.Location = New System.Drawing.Point(344, 48)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(16, 16)
        Me.Button8.TabIndex = 74
        '
        'Button7
        '
        Me.Button7.Location = New System.Drawing.Point(344, 80)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(16, 16)
        Me.Button7.TabIndex = 75
        '
        'Button6
        '
        Me.Button6.Location = New System.Drawing.Point(360, 336)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(16, 16)
        Me.Button6.TabIndex = 76
        Me.Button6.Visible = False
        '
        'pnluvm
        '
        Me.pnluvm.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button29, Me.txtuvmauftragnr, Me.Label45, Me.GroupBox14})
        Me.pnluvm.Location = New System.Drawing.Point(224, 8)
        Me.pnluvm.Name = "pnluvm"
        Me.pnluvm.Size = New System.Drawing.Size(376, 504)
        Me.pnluvm.TabIndex = 9
        '
        'Button29
        '
        Me.Button29.Location = New System.Drawing.Point(256, 32)
        Me.Button29.Name = "Button29"
        Me.Button29.Size = New System.Drawing.Size(40, 24)
        Me.Button29.TabIndex = 2
        Me.Button29.Text = "&OK"
        '
        'txtuvmauftragnr
        '
        Me.txtuvmauftragnr.Location = New System.Drawing.Point(104, 32)
        Me.txtuvmauftragnr.Name = "txtuvmauftragnr"
        Me.txtuvmauftragnr.Size = New System.Drawing.Size(152, 20)
        Me.txtuvmauftragnr.TabIndex = 1
        Me.txtuvmauftragnr.Text = ""
        '
        'Label45
        '
        Me.Label45.Location = New System.Drawing.Point(16, 32)
        Me.Label45.Name = "Label45"
        Me.Label45.TabIndex = 0
        Me.Label45.Text = "Auftragnummer"
        '
        'GroupBox14
        '
        Me.GroupBox14.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox14.Name = "GroupBox14"
        Me.GroupBox14.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox14.TabIndex = 3
        Me.GroupBox14.TabStop = False
        Me.GroupBox14.Text = "Diverse Selektionskriterien"
        '
        'PnlDokumentart
        '
        Me.PnlDokumentart.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVDokart})
        Me.PnlDokumentart.Location = New System.Drawing.Point(224, 8)
        Me.PnlDokumentart.Name = "PnlDokumentart"
        Me.PnlDokumentart.Size = New System.Drawing.Size(376, 504)
        Me.PnlDokumentart.TabIndex = 4
        Me.PnlDokumentart.Visible = False
        '
        'TVDokart
        '
        Me.TVDokart.ContextMenu = Me.ContextMenu1
        Me.TVDokart.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVDokart.ImageIndex = -1
        Me.TVDokart.Name = "TVDokart"
        Me.TVDokart.SelectedImageIndex = -1
        Me.TVDokart.Size = New System.Drawing.Size(376, 504)
        Me.TVDokart.TabIndex = 0
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.Panel3.Location = New System.Drawing.Point(224, 8)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(368, 496)
        Me.Panel3.TabIndex = 2
        Me.Panel3.Visible = False
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.CTMenuVerantwortlicher
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 17
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(368, 496)
        Me.C1TrueDBGrid1.TabIndex = 0
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorW" & _
        "idth=""17"" DefRecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1"">" & _
        "<ClientRect>0, 0, 364, 492</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>17</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 364, 492</ClientArea></Blob>"
        '
        'TreeView1
        '
        Me.TreeView1.ContextMenu = Me.ctmenu1
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeView1.FullRowSelect = True
        Me.TreeView1.ImageList = Me.ImageList2
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Dokument", 0, 0, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Daten"), New System.Windows.Forms.TreeNode("Dokumentart"), New System.Windows.Forms.TreeNode("Dokumentstatus"), New System.Windows.Forms.TreeNode("Partner")}), New System.Windows.Forms.TreeNode("Ersteller", 8, 8, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Mutierer", 9, 9, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Verantwortlich", 7, 7, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")})})
        Me.TreeView1.Size = New System.Drawing.Size(216, 518)
        Me.TreeView1.TabIndex = 0
        '
        'TVHostDok
        '
        Me.TVHostDok.ContextMenu = Me.ContextMenu1
        Me.TVHostDok.ImageIndex = -1
        Me.TVHostDok.Location = New System.Drawing.Point(224, 8)
        Me.TVHostDok.Name = "TVHostDok"
        Me.TVHostDok.SelectedImageIndex = -1
        Me.TVHostDok.Size = New System.Drawing.Size(376, 504)
        Me.TVHostDok.TabIndex = 6
        Me.TVHostDok.Visible = False
        '
        'Panel4
        '
        Me.Panel4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label19, Me.LBSelectHost, Me.Button11, Me.Label22, Me.lbselect, Me.LBSort, Me.Label21, Me.lbSortfields, Me.GroupBox12})
        Me.Panel4.Location = New System.Drawing.Point(224, 8)
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(376, 504)
        Me.Panel4.TabIndex = 8
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(200, 32)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(100, 16)
        Me.Label19.TabIndex = 19
        Me.Label19.Text = "Sortierungsart"
        '
        'LBSelectHost
        '
        Me.LBSelectHost.ContextMenu = Me.ContextMenu2
        Me.LBSelectHost.Location = New System.Drawing.Point(40, 312)
        Me.LBSelectHost.Name = "LBSelectHost"
        Me.LBSelectHost.Size = New System.Drawing.Size(296, 134)
        Me.LBSelectHost.TabIndex = 18
        '
        'Button11
        '
        Me.Button11.Location = New System.Drawing.Point(152, 264)
        Me.Button11.Name = "Button11"
        Me.Button11.Size = New System.Drawing.Size(80, 24)
        Me.Button11.TabIndex = 17
        Me.Button11.Text = "Einfügen"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(40, 296)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(112, 16)
        Me.Label22.TabIndex = 16
        Me.Label22.Text = "Sortierungs-Kriterien"
        '
        'lbselect
        '
        Me.lbselect.ContextMenu = Me.ContextMenu2
        Me.lbselect.Location = New System.Drawing.Point(40, 312)
        Me.lbselect.Name = "lbselect"
        Me.lbselect.Size = New System.Drawing.Size(296, 134)
        Me.lbselect.TabIndex = 15
        '
        'LBSort
        '
        Me.LBSort.Items.AddRange(New Object() {"Absteigend", "Aufsteigend"})
        Me.LBSort.Location = New System.Drawing.Point(200, 48)
        Me.LBSort.Name = "LBSort"
        Me.LBSort.Size = New System.Drawing.Size(136, 199)
        Me.LBSort.Sorted = True
        Me.LBSort.TabIndex = 14
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(40, 32)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(100, 16)
        Me.Label21.TabIndex = 13
        Me.Label21.Text = "Sortierkriterien"
        '
        'lbSortfields
        '
        Me.lbSortfields.Items.AddRange(New Object() {"Bemerkung", "Bezeichnung", "Dokument-ID", "Dokumentart", "Ersteller", "Erstellungsdatum", "Mutationsdatum", "Mutierer", "Status", "Termin", "Verantwortlicher", "Zuständiger"})
        Me.lbSortfields.Location = New System.Drawing.Point(40, 48)
        Me.lbSortfields.Name = "lbSortfields"
        Me.lbSortfields.Size = New System.Drawing.Size(136, 199)
        Me.lbSortfields.Sorted = True
        Me.lbSortfields.TabIndex = 12
        '
        'GroupBox12
        '
        Me.GroupBox12.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(360, 448)
        Me.GroupBox12.TabIndex = 20
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Sortierung"
        '
        'PnlPartner
        '
        Me.PnlPartner.Controls.AddRange(New System.Windows.Forms.Control() {Me.PartnerList, Me.btnPartnersuche, Me.Label3, Me.TextBox3, Me.Label2, Me.TextBox2, Me.Label1, Me.TextBox1})
        Me.PnlPartner.Location = New System.Drawing.Point(224, 8)
        Me.PnlPartner.Name = "PnlPartner"
        Me.PnlPartner.Size = New System.Drawing.Size(376, 504)
        Me.PnlPartner.TabIndex = 3
        Me.PnlPartner.Visible = False
        '
        'PartnerList
        '
        Me.PartnerList.AllowFilter = True
        Me.PartnerList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.PartnerList.AllowSort = True
        Me.PartnerList.AllowUpdate = False
        Me.PartnerList.AllowUpdateOnBlur = False
        Me.PartnerList.AlternatingRows = True
        Me.PartnerList.CaptionHeight = 17
        Me.PartnerList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.PartnerList.CollapseColor = System.Drawing.Color.Black
        Me.PartnerList.ContextMenu = Me.CTMenuErsteller
        Me.PartnerList.DataChanged = False
        Me.PartnerList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.PartnerList.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.PartnerList.ExpandColor = System.Drawing.Color.Black
        Me.PartnerList.FetchRowStyles = True
        Me.PartnerList.FilterBar = True
        Me.PartnerList.GroupByCaption = "Drag a column header here to group by that column"
        Me.PartnerList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.PartnerList.Location = New System.Drawing.Point(0, 104)
        Me.PartnerList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.PartnerList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.PartnerList.Name = "PartnerList"
        Me.PartnerList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.PartnerList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.PartnerList.PreviewInfo.ZoomFactor = 75
        Me.PartnerList.PrintInfo.ShowOptionsDialog = False
        Me.PartnerList.RecordSelectorWidth = 17
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.PartnerList.RowDivider = GridLines2
        Me.PartnerList.RowHeight = 15
        Me.PartnerList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.PartnerList.ScrollTips = False
        Me.PartnerList.Size = New System.Drawing.Size(376, 400)
        Me.PartnerList.TabIndex = 17
        Me.PartnerList.Text = "C1TrueDBGrid1"
        Me.PartnerList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:Silver;}RecordSelector{AlignImage:Center" & _
        ";}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:Contro" & _
        "lText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style1" & _
        "3{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" Altern" & _
        "atingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHei" & _
        "ght=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" " & _
        "RecordSelectorWidth=""17"" DefRecSelWidth=""17"" VerticalScrollGroup=""1"" HorizontalS" & _
        "crollGroup=""1""><ClientRect>0, 0, 372, 396</ClientRect><BorderSide>0</BorderSide>" & _
        "<CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""St" & _
        "yle5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""Fil" & _
        "terBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle pa" & _
        "rent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLi" & _
        "ghtRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive""" & _
        " me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle p" & _
        "arent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style" & _
        "6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Spli" & _
        "ts><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Headin" & _
        "g"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" " & _
        "/><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /" & _
        "><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /" & _
        "><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Sty" & _
        "le parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" " & _
        "/><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><" & _
        "horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>17</DefaultRec" & _
        "SelWidth><ClientArea>0, 0, 372, 396</ClientArea></Blob>"
        '
        'btnPartnersuche
        '
        Me.btnPartnersuche.Image = CType(resources.GetObject("btnPartnersuche.Image"), System.Drawing.Bitmap)
        Me.btnPartnersuche.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.btnPartnersuche.Location = New System.Drawing.Point(288, 32)
        Me.btnPartnersuche.Name = "btnPartnersuche"
        Me.btnPartnersuche.Size = New System.Drawing.Size(72, 40)
        Me.btnPartnersuche.TabIndex = 16
        Me.btnPartnersuche.Text = "&Suchen"
        Me.btnPartnersuche.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "Freitext"
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(88, 64)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(160, 20)
        Me.TextBox3.TabIndex = 14
        Me.TextBox3.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 13
        Me.Label2.Text = "Kurzname"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(88, 40)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(160, 20)
        Me.TextBox2.TabIndex = 12
        Me.TextBox2.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 11
        Me.Label1.Text = "Partner-Nr."
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(160, 20)
        Me.TextBox1.TabIndex = 10
        Me.TextBox1.Text = ""
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox2, Me.GroupBox1, Me.GroupBox9, Me.GroupBox5})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(605, 518)
        Me.TabPage4.TabIndex = 3
        Me.TabPage4.Text = "Unterschriften / Hinweise / Darstellung"
        Me.TabPage4.Visible = False
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox2.TabIndex = 10
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Team"
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(112, 21)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(240, 21)
        Me.cbteam.TabIndex = 8
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button5, Me.colbtn6, Me.colbtn5, Me.colbtn4, Me.colbtn3, Me.colbtn2, Me.colbtn1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(360, 72)
        Me.GroupBox1.TabIndex = 8
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Farbgebung der Dokumentliste"
        '
        'Button5
        '
        Me.Button5.Location = New System.Drawing.Point(288, 19)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(64, 40)
        Me.Button5.TabIndex = 44
        Me.Button5.Text = "Standard herstellen"
        '
        'colbtn6
        '
        Me.colbtn6.Location = New System.Drawing.Point(96, 40)
        Me.colbtn6.Name = "colbtn6"
        Me.colbtn6.Size = New System.Drawing.Size(88, 20)
        Me.colbtn6.TabIndex = 43
        Me.colbtn6.Text = "Pendent"
        '
        'colbtn5
        '
        Me.colbtn5.Location = New System.Drawing.Point(184, 40)
        Me.colbtn5.Name = "colbtn5"
        Me.colbtn5.Size = New System.Drawing.Size(88, 20)
        Me.colbtn5.TabIndex = 42
        Me.colbtn5.Text = "Überfällig"
        '
        'colbtn4
        '
        Me.colbtn4.Location = New System.Drawing.Point(184, 16)
        Me.colbtn4.Name = "colbtn4"
        Me.colbtn4.Size = New System.Drawing.Size(88, 20)
        Me.colbtn4.TabIndex = 41
        Me.colbtn4.Text = "Terminiert"
        '
        'colbtn3
        '
        Me.colbtn3.Location = New System.Drawing.Point(8, 40)
        Me.colbtn3.Name = "colbtn3"
        Me.colbtn3.Size = New System.Drawing.Size(88, 20)
        Me.colbtn3.TabIndex = 40
        Me.colbtn3.Text = "In Bearbeitung"
        '
        'colbtn2
        '
        Me.colbtn2.Location = New System.Drawing.Point(96, 16)
        Me.colbtn2.Name = "colbtn2"
        Me.colbtn2.Size = New System.Drawing.Size(88, 20)
        Me.colbtn2.TabIndex = 39
        Me.colbtn2.Text = "Verantwortlich"
        '
        'colbtn1
        '
        Me.colbtn1.Location = New System.Drawing.Point(8, 16)
        Me.colbtn1.Name = "colbtn1"
        Me.colbtn1.Size = New System.Drawing.Size(88, 20)
        Me.colbtn1.TabIndex = 38
        Me.colbtn1.Text = "Standard"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.cb3_1, Me.cb5, Me.cb4, Me.cb3, Me.cb2, Me.cb1})
        Me.GroupBox9.Location = New System.Drawing.Point(376, 8)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(216, 232)
        Me.GroupBox9.TabIndex = 7
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Hinweismeldungen"
        '
        'cb3_1
        '
        Me.cb3_1.Location = New System.Drawing.Point(8, 120)
        Me.cb3_1.Name = "cb3_1"
        Me.cb3_1.Size = New System.Drawing.Size(192, 32)
        Me.cb3_1.TabIndex = 10
        Me.cb3_1.Text = "Bedingte Retournierung"
        '
        'cb5
        '
        Me.cb5.Location = New System.Drawing.Point(16, 176)
        Me.cb5.Name = "cb5"
        Me.cb5.Size = New System.Drawing.Size(144, 32)
        Me.cb5.TabIndex = 9
        Me.cb5.Text = "Meldung XY5 anzeigen"
        Me.cb5.Visible = False
        '
        'cb4
        '
        Me.cb4.Location = New System.Drawing.Point(16, 152)
        Me.cb4.Name = "cb4"
        Me.cb4.Size = New System.Drawing.Size(144, 32)
        Me.cb4.TabIndex = 8
        Me.cb4.Text = "Meldung XY4 anzeigen"
        Me.cb4.Visible = False
        '
        'cb3
        '
        Me.cb3.Location = New System.Drawing.Point(8, 88)
        Me.cb3.Name = "cb3"
        Me.cb3.Size = New System.Drawing.Size(192, 32)
        Me.cb3.TabIndex = 7
        Me.cb3.Text = "Einzeldokument"
        '
        'cb2
        '
        Me.cb2.Location = New System.Drawing.Point(8, 56)
        Me.cb2.Name = "cb2"
        Me.cb2.Size = New System.Drawing.Size(200, 32)
        Me.cb2.TabIndex = 6
        Me.cb2.Text = "Dokumentbearbeitung - Statuswechsel"
        '
        'cb1
        '
        Me.cb1.Location = New System.Drawing.Point(8, 24)
        Me.cb1.Name = "cb1"
        Me.cb1.Size = New System.Drawing.Size(200, 32)
        Me.cb1.TabIndex = 5
        Me.cb1.Text = "Partnererfassung"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label31, Me.cbUnterschriftrechts, Me.Label30, Me.cbUnterschriftlinks})
        Me.GroupBox5.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(360, 88)
        Me.GroupBox5.TabIndex = 2
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Unterschriften"
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(24, 56)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(72, 23)
        Me.Label31.TabIndex = 8
        Me.Label31.Text = "Rechts"
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(112, 56)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(240, 21)
        Me.cbUnterschriftrechts.TabIndex = 7
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(24, 24)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(72, 23)
        Me.Label30.TabIndex = 6
        Me.Label30.Text = "Links"
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(112, 24)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(240, 21)
        Me.cbUnterschriftlinks.TabIndex = 5
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage4})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.ItemSize = New System.Drawing.Size(112, 18)
        Me.TabControl1.Location = New System.Drawing.Point(179, 33)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(613, 544)
        Me.TabControl1.TabIndex = 16
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(768, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 33
        '
        'frmProfil
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(792, 577)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.TabControl1, Me.Splitter1, Me.Button4, Me.Panel2, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmProfil"
        Me.Text = "Profile verwalten"
        Me.Panel2.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage1.ResumeLayout(False)
        Me.PnlDokumentDaten.ResumeLayout(False)
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.TabPage3.ResumeLayout(False)
        Me.TabPage5.ResumeLayout(False)
        Me.pnlzv.ResumeLayout(False)
        Me.pnlhostdiv.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox6.ResumeLayout(False)
        Me.pnluvm.ResumeLayout(False)
        Me.PnlDokumentart.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel4.ResumeLayout(False)
        Me.PnlPartner.ResumeLayout(False)
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage4.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox9.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Insertitem Method

Private Sub Insertitem( _
   ByVal lb As ListBox, _
   ByVal s As String _
)

Parameters

lb
Required.
s
Required.

Source code

[Visual Basic]
    Private Sub Insertitem(ByVal lb As ListBox, ByVal s As String)
        Dim i As Integer
        Dim inserted As Boolean = False
        For i = 0 To lb.Items.Count - 1
            lb.SelectedIndex = i
            If s > lb.SelectedItem And Not inserted Then
                lb.Items.Insert(i, s)
                inserted = True
            End If
        Next
        If Not inserted Then lb.Items.Insert(i, s)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Load_Profil Method

Private Sub Load_Profil( _
   ByVal profilnr As Long _
)

Parameters

profilnr
Required.

Source code

[Visual Basic]
    Private Sub Load_Profil(ByVal profilnr As Long)
        Me.FirstNodeWithData = Nothing
        checkchanges = False
        'hutter 20041014
        'Me.TreeView1.BeginUpdate()
        Me.TVDokart.BeginUpdate()
        Dim p As New edokadb.clsProfil()
        Dim ma As New edokadb.clsMitarbeiter()
        Dim s As String
        Dim splitter
        Dim i As Integer
        p.cpMainConnectionProvider = conn
        conn.OpenConnection()
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()
        init_treeview1()

        'Selektion
        Try
            Set_Values(p.sDpartner.Value, Me.tpe, 41)
            Set_Values(p.sHostpartner.Value, Me.tku, 51)
            Set_Values(p.sVmb.Value, Me.tmb, 11)
            Set_Values(p.sVnl.Value, Me.tnl, 12)
            Set_Values(p.sVkost.Value, Me.tko, 13)
            Set_Values(p.sVteam.Value, Me.tte, 14)
            Set_Values(p.sVma.Value, Me.tpe, 15)

            Set_Values(p.sEmb.Value, Me.tmb, 21)
            Set_Values(p.sEnl.Value, Me.tnl, 22)
            Set_Values(p.sEkost.Value, Me.tko, 23)
            Set_Values(p.sEteam.Value, Me.tte, 24)
            Set_Values(p.sEma.Value, Me.tpe, 25)

            Set_Values(p.sMmb.Value, Me.tmb, 31)
            Set_Values(p.sMnl.Value, Me.tnl, 32)
            Set_Values(p.sMkost.Value, Me.tko, 33)
            Set_Values(p.sMteam.Value, Me.tte, 34)
            Set_Values(p.sMma.Value, Me.tpe, 35)
            Set_Values(p.sDdokstatus.Value, Me.tst, 44)
            Set_Values(p.sDoktyp.Value, Me.tdt, 43)
            Set_Values(p.sDdokart.Value, Me.tst, 42)
            Set_Values(p.sHostdatum3.Value, Me.tpe, 58)
            Set_Values(p.sHosttag3.Value, Me.tpe, 59)
            Set_Values(p.sHosttag1.Value, Me.tpe, 54)

            Set_Values(p.sHostdokart.Value, Me.tpe, 52)
            Set_Values(p.sHostdoktyp.Value, Me.tdh, 53)

            'Set_Values(p.sHostdoktyp.Value, Me.tdh, 53)
            Set_Values(p.sZvauftraggeber.Value, Me.tdh, 74)
            Set_Values(p.sZvauftragnr.Value, Me.tdh, 73)
            Set_Values(p.sZvbetrag.Value, Me.tdh, 75)
            Set_Values(p.sZvclearingnr.Value, Me.tdh, 76)
            Set_Values(p.sZviso.Value, Me.tdh, 77)
            Set_Values(p.sZvkontobeg.Value, Me.tdh, 78)
            Set_Values(p.sZvpcnr.Value, Me.tdh, 79)
            Set_Values(p.sZvposten.Value, Me.tdh, 80)
            Set_Values(p.sZvreferenznr.Value, Me.tdh, 81)
            Set_Values(p.sZvswift.Value, Me.tdh, 82)
            Set_Values(p.sZvverarbeitungsart.Value, Me.tdh, 83)
            Set_Values(p.sZvzahlungsart.Value, Me.tdh, 84)
            Set_Values(p.sZvdokumenttyp.Value, Me.tdtzv, 71)

            'Rel 3.7 / BUD
            'Set_Values(p.sUvmauftragnr.Value, Me.tdh, 93)
            'Set_Values(p.sUvmdoktyp.Value, Me.tdtuvm, 91)

            DivFnkt.Searchnode1(Me.TreeView1, 51, 0)
            If DivFnkt.found Then
                If p.sHostpartner.Value <> "" Then
                    '                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 42, 0)
            If DivFnkt.found Then
                If p.sDdokart.Value <> "" Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If
            DivFnkt.Searchnode1(Me.TreeView1, 52, 0)
            If DivFnkt.found Then
                If p.sHostdokart.Value <> "" Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If
            DivFnkt.Searchnode1(Me.TreeView1, 58, 0)
            If DivFnkt.found Then
                If p.sHosttag3.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 59, 0)
            If DivFnkt.found Then
                If p.sHostdatum3.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 54, 0)
            If DivFnkt.found Then
                If p.sHosttag1.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            'Unterschriften/Hinweise

            Me.mcbunterschriftlinks.SelectedValue = p.iUnterschriftlinks.Value
            Me.mcbunterschriftrechts.SelectedValue = p.iUnterschriftrechts.Value
            Me.mcbTeam.SelectedValue = p.iTeam.Value
            If p.iHw1.IsNull Then Me.cb1.Checked = False Else Me.cb1.Checked = p.iHw1.Value
            If p.iHw2.IsNull Then Me.cb2.Checked = False Else Me.cb2.Checked = p.iHw2.Value
            If p.iHw3.IsNull Then Me.cb3.Checked = False Else Me.cb3.Checked = p.iHw3.Value
            If p.iHw4.IsNull Then Me.cb4.Checked = False Else Me.cb4.Checked = p.iHw4.Value
            If p.iHw5.IsNull Then Me.cb5.Checked = False Else Me.cb5.Checked = p.iHw5.Value
            If p.iHw6.IsNull Then Me.cb3_1.Checked = False Else Me.cb3_1.Checked = p.iHw6.Value

            'Darstellung/Sortierung
            Try
                Me.colbtn1.BackColor = colconv.ConvertFromString(p.sColor1.Value)
                Me.colbtn2.BackColor = colconv.ConvertFromString(p.sColor2.Value)
                Me.colbtn3.BackColor = colconv.ConvertFromString(p.sColor3.Value)
                Me.colbtn4.BackColor = colconv.ConvertFromString(p.sColor4.Value)
                Me.colbtn5.BackColor = colconv.ConvertFromString(p.sColor5.Value)
                Me.colbtn6.BackColor = colconv.ConvertFromString(p.sColor6.Value)
            Catch
            End Try

            Me.lbselect.Items.Clear()
            s = p.sSort.Value
            Try
                splitter = Microsoft.VisualBasic.Split(s, ";")
                i = 0
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        Me.lbselect.Items.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try

            Me.LBSelectHost.Items.Clear()
            s = p.sHosttag2.Value
            Try
                splitter = Microsoft.VisualBasic.Split(s, ";")
                i = 0
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        Me.LBSelectHost.Items.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try

            Me.txtdatum1.Text = Convert_Seldate_von(p.sDatum1.Value)
            If p.sDatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum1.Value, 2) = "(h" Then Me.cbrollend1.Checked = True
            Me.txtdatum2.Text = Convert_Seldate_bis(p.sDatum2.Value)
            If p.sDatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum2.Value, 2) = "(h" Then Me.cbrollend2.Checked = True
            Me.txtdatum3.Text = Convert_Seldate_von(p.sDatum3.Value)
            If p.sDatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum3.Value, 2) = "(h" Then Me.cbrollend3.Checked = True
            Me.txtdatum4.Text = Convert_Seldate_bis(p.sDatum4.Value)
            If p.sDatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum4.Value, 2) = "(h" Then Me.cbrollend4.Checked = True
            Me.txtdatum5.Text = Convert_Seldate_von(p.sDatum5.Value)
            If p.sDatum5.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum5.Value, 2) = "(h" Then Me.cbrollend5.Checked = True
            Me.txtdatum6.Text = Convert_Seldate_bis(p.sDatum6.Value)
            If p.sDatum6.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum6.Value, 2) = "(h" Then Me.cbrollend6.Checked = True

            Me.HostDatum1.Text = Convert_Seldate_von(p.sHostdatum1.Value)
            If p.sHostdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sHostdatum1.Value, 2) = "(h" Then Me.cbrollend8.Checked = True
            Me.HostDatum2.Text = Convert_Seldate_bis(p.sHostdatum2.Value)
            If p.sHostdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sHostdatum2.Value, 2) = "(h" Then Me.cbrollend9.Checked = True

            'Rel 3.7 / BUD
            'Me.txtdatum1uvm.Text = Convert_Seldate_von(p.sUvmdatum1.Value)
            'If p.sUvmdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum1.Value, 2) = "(h" Then Me.cbuvmrollend1.Checked = True
            'Me.txtdatum2uvm.Text = Convert_Seldate_von(p.sUvmdatum2.Value)
            'If p.sUvmdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum2.Value, 2) = "(h" Then Me.cbuvmrollend2.Checked = True
            'Me.txtdatum3uvm.Text = Convert_Seldate_von(p.sUvmdatum3.Value)
            'If p.sUvmdatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum3.Value, 2) = "(h" Then Me.cbuvmrollend3.Checked = True
            'Me.txtdatum4uvm.Text = Convert_Seldate_von(p.sUvmdatum4.Value)
            'If p.sUvmdatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum4.Value, 2) = "(h" Then Me.cbuvmrollend4.Checked = True

            Me.txtdatum1zv.Text = Convert_Seldate_von(p.sZvdatum1.Value)
            If p.sZvdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum1.Value, 2) = "(h" Then Me.cbzvrollend1.Checked = True
            Me.txtdatum2zv.Text = Convert_Seldate_von(p.sZvdatum2.Value)
            If p.sZvdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum2.Value, 2) = "(h" Then Me.cbzvrollend2.Checked = True
            Me.txtdatum3zv.Text = Convert_Seldate_von(p.sZvdatum3.Value)
            If p.sZvdatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum3.Value, 2) = "(h" Then Me.cbzvrollend3.Checked = True
            Me.txtdatum4zv.Text = Convert_Seldate_von(p.sZvdatum4.Value)
            If p.sZvdatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum4.Value, 2) = "(h" Then Me.cbzvrollend4.Checked = True

            Me.hostinklmavip.Checked = p.bInklhostmavip.Value = True

            Dim div As Boolean = False
            If p.sDatum1.Value <> "(heute)-999999" Then div = True
            If p.sDatum2.Value <> "(heute)" And p.sDatum2.Value <> "(heute)-0" Then div = True
            If p.sDatum3.Value <> "(heute)-999999" Then div = True
            If p.sDatum4.Value <> "(heute)" And p.sDatum4.Value <> "(heute)-0" Then div = True
            If p.sDatum5.Value <> "(heute)-999999" Then div = True
            If p.sDatum6.Value <> "(heute)" And p.sDatum6.Value <> "(heute)-0" Then div = True
            If div Then
                DivFnkt.Searchnode(Me.TreeView1, 45, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            div = False
            If p.sHostdatum1.Value <> "(heute)-999999" Then div = True
            If p.sHostdatum2.Value <> "(heute)" And p.sHostdatum2.Value <> "(heute)-0" Then div = True

            If div Then
                DivFnkt.Searchnode(Me.TreeView1, 55, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            If p.sSort.Value <> "" Then
                DivFnkt.Searchnode(Me.TreeView1, 60, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            If p.sHosttag2.Value <> "" Then
                DivFnkt.Searchnode(Me.TreeView1, 61, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            Dim div1 As Boolean
            'Rel 3.7 / BUD
            'Me.expanduvm = False
            Me.expandzv = False
            div1 = False
            'If p.sUvmdatum1.Value <> "(heute)-999999" Then div1 = True
            'If p.sUvmdatum2.Value <> "(heute)" And p.sUvmdatum2.Value <> "(heute)-0" Then div1 = True
            'If p.sUvmdatum3.Value <> "(heute)-999999" Then div1 = True
            'If p.sUvmdatum4.Value <> "(heute)" And p.sUvmdatum4.Value <> "(heute)-0" Then div1 = True
            If div1 Then
                'Rel 3.7 / BUD
                'DivFnkt.Searchnode(Me.TreeView1, 92, 0)
                'If DivFnkt.found Then
                '    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                '    DivFnkt.FoundNode.ImageIndex = 4
                '    DivFnkt.FoundNode.Parent.Expand()
                '    If Me.FirstNodeWithData Is Nothing Then
                '        Me.FirstNodeWithData = DivFnkt.FoundNode
                '    End If
                '    Me.expanduvm = True
                'End If
            End If
            div1 = False
            If p.sZvdatum1.Value <> "(heute)-999999" Then div1 = True
            If p.sZvdatum2.Value <> "(heute)" And p.sZvdatum2.Value <> "(heute)-0" Then div1 = True
            If p.sZvdatum3.Value <> "(heute)-999999" Then div1 = True
            If p.sZvdatum4.Value <> "(heute)" And p.sZvdatum4.Value <> "(heute)-0" Then div1 = True
            If div1 Then
                DivFnkt.Searchnode(Me.TreeView1, 72, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    DivFnkt.FoundNode.Parent.Expand()
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                    Me.expandzv = True
                End If
            End If

            Me.cbmavip.Checked = p.bInklmavip.Value = True
            Me.cinklalt.Checked = p.bInklalt.Value = True
            Me.cinklaltversant.Checked = p.bInkInaktVersant.Value = True

            DivFnkt.Searchnode1(Me.TreeView1, 62, 99)
            If DivFnkt.found Then
                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                If Me.cinklalt.Checked = True Or Me.cinklaltversant.Checked = True Then
                    Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Red
                Else
                    Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            If p.sVma.Value = "" And p.sVmb.Value = "" And p.sVnl.Value = "" And p.sVkost.Value = "" And p.sVteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If
            If p.sMma.Value = "" And p.sMmb.Value = "" And p.sMnl.Value = "" And p.sMkost.Value = "" And p.sMteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If
            If p.sEma.Value = "" And p.sEmb.Value = "" And p.sEnl.Value = "" And p.sEkost.Value = "" And p.sEteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If

            'Profilunabhängige Daten
            ma.cpMainConnectionProvider = conn
            ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            ma.SelectOne()
            Try
                '               Me.FirstNodeWithData.ForeColor = System.Drawing.Color.Blue
            Catch
            End Try
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
        conn.CloseConnection(True)
        'shieb        Me.TreeView1.EndUpdate()
        Me.TVDokart.EndUpdate()

        checkchanges = True
        Try
        Catch
            If Me.FirstNodeWithData Is Nothing Then
                Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
            Else
                Me.TreeView1.SelectedNode = Me.FirstNodeWithData
            End If
        End Try
        '  Me.TreeView1.BeginUpdate()
        Me.TreeView1.ExpandAll()
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        'Rel 3.7 / BUD
        'nodeswithdata(90)
        nodeswithdata(72)
        'Rel 3.7 / BUD
        'nodeswithdata(92)

        'hutter 20041014
        'Me.TreeView1.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        If MyMsg.Show_MessageYesNo(16) = MsgBoxResult.Yes Then
            Dim p As New edokadb.clsProfil()
            p.cpMainConnectionProvider = conn
            Me.Profile_Geaendert = True
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(False, Boolean))
            p.Update()
            p.Dispose()
            conn.CloseConnection(True)
            Me.ProfilNr = 0
            Me.showhidetv(True)
            frmProfil_Load(sender, e)
            Me.showhidetv(False)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        check_changes()
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfil()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("profil")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(0, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(True, Boolean))
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.sVma = New SqlString(CType(Globals.MitarbeiterNr, String))

            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.showhidetv(True)
            Me.frmProfil_Load(sender, e)
            Me.init_datumzvuvm()
            Me.showhidetv(False)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem13_Click Method

Private Sub MenuItem13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfil()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("profil")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
            p.SelectOne()
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.showhidetv(True)
            Me.frmProfil_Load(sender, e)
            Me.showhidetv(False)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem14_Click Method

Private Sub MenuItem14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Try
            Dim tn As TreeNode
            Dim tn1 As TreeNode
            tn = TreeView1.SelectedNode
            While tn.GetNodeCount(True) > 0
                tn.Nodes(0).Remove()
            End While
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        Try
            Me.C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        Try
            If Me.PartnerList.Columns(0).Value > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem17_Click Method

Private Sub MenuItem17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        Dim i As Integer
        Dim s As String
        If Me.LBSelectHost.Visible = True Then
            If Me.LBSelectHost.SelectedItems.Count > 0 Then
                Try
                    i = LBSelectHost.SelectedIndex
                    s = LBSelectHost.SelectedItem
                    If i > 0 Then
                        LBSelectHost.Items.RemoveAt(i)
                        LBSelectHost.Items.Insert(i - 1, s)
                        LBSelectHost.SelectedIndex = i - 1
                    End If
                Catch
                End Try
            End If
        Else
            Try
                If Me.lbselect.SelectedItems.Count > 0 Then
                    i = lbselect.SelectedIndex
                    s = lbselect.SelectedItem
                    If i > 0 Then
                        lbselect.Items.RemoveAt(i)
                        lbselect.Items.Insert(i - 1, s)
                        lbselect.SelectedIndex = i - 1
                    End If
                End If
            Catch
            End Try
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem18_Click Method

Private Sub MenuItem18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim i As Integer
        Dim s As String
        If Me.LBSelectHost.Visible = True Then
            Try
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    i = LBSelectHost.SelectedIndex
                    s = LBSelectHost.SelectedItem
                    If i < LBSelectHost.Items.Count - 1 Then
                        LBSelectHost.Items.RemoveAt(i)
                        LBSelectHost.Items.Insert(i + 1, s)
                        LBSelectHost.SelectedIndex = i + 1
                    End If
                    changes = True
                End If
            Catch
            End Try
        Else
            Try
                If Me.lbselect.SelectedItems.Count > 0 Then
                    i = lbselect.SelectedIndex
                    s = lbselect.SelectedItem
                    If i < lbselect.Items.Count - 1 Then
                        lbselect.Items.RemoveAt(i)
                        lbselect.Items.Insert(i + 1, s)
                        lbselect.SelectedIndex = i + 1
                    End If
                    changes = True
                End If
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem19_Click Method

Private Sub MenuItem19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem19.Click
        Dim splitter
        Try
            If Me.LBSelectHost.Visible = True Then
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.LBSelectHost.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.LBSelectHost.Items.RemoveAt(Me.LBSelectHost.SelectedIndex)
                End If
            Else
                If Me.lbselect.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.lbselect.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.lbselect.Items.RemoveAt(Me.lbselect.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem20_Click Method

Private Sub MenuItem20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem20.Click
        Try
            C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem21_Click Method

Private Sub MenuItem21_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem21_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem21.Click
        Dim s, s1 As String
        Dim splitter
        If Me.LBSelectHost.Visible = True Then
            If Me.LBSelectHost.SelectedItems.Count > 0 Then
                Try
                    s = LBSelectHost.SelectedItem
                    splitter = Microsoft.VisualBasic.Split(s, " | ")
                    Select Case splitter(1)
                        Case "Absteigend"
                            s1 = "Aufsteigend"
                        Case "Aufsteigend"
                            s1 = "Absteigend"
                        Case Else
                            s1 = "Aufsteigend"
                    End Select
                    s = splitter(0) + " | " + s1
                    i = LBSelectHost.SelectedIndex
                    LBSelectHost.SelectedIndex = i
                    LBSelectHost.Items.RemoveAt(i)
                    LBSelectHost.Items.Insert(i, s)
                Catch
                End Try
            End If
        Else
            If Me.lbselect.SelectedItems.Count > 0 Then
                Try
                    s = lbselect.SelectedItem
                    splitter = Microsoft.VisualBasic.Split(s, " | ")
                    Select Case splitter(1)
                        Case "Absteigend"
                            s1 = "Aufsteigend"
                        Case "Aufsteigend"
                            s1 = "Absteigend"
                        Case Else
                            s1 = "Aufsteigend"
                    End Select
                    s = splitter(0) + " | " + s1
                    i = lbselect.SelectedIndex
                    lbselect.SelectedIndex = i
                    lbselect.Items.RemoveAt(i)
                    lbselect.Items.Insert(i, s)
                Catch
                End Try
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Try
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.TVDokart.BeginUpdate()
                Me.TVDokart.SelectedNode.ExpandAll()
                Me.TVDokart.EndUpdate()
            Else
                Me.TVHostDok.BeginUpdate()
                Me.TVHostDok.SelectedNode.ExpandAll()
                Me.TVHostDok.EndUpdate()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.Collapse()
        Else
            Me.TVHostDok.SelectedNode.Collapse()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Try
            Dim tn As TreeNode
            Dim p As New edokadb.clsProfil()
            p.cpMainConnectionProvider = conn
            Me.Profile.BeginUpdate()
            tn = Me.Profile.Nodes(0)
            Do Until tn Is Nothing
                If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                    conn.OpenConnection()
                    p.iProfilnr = New SqlInt32(CType(tn.Tag, Int32))
                    p.SelectOne()
                    p.bStandard = New SqlBoolean(CType(False, Boolean))
                    p.Update()
                    conn.CloseConnection(True)
                End If
                tn.BackColor = System.Drawing.Color.White
                tn = tn.NextNode
            Loop
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bStandard = New SqlBoolean(CType(True, Boolean))
            p.Update()
            conn.CloseConnection(True)
            p.Dispose()
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.LightBlue
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Try
            Dim a As String
            a = InputBox(MyTxt.gettext(501))
            If a <> "" Then
                Me.showhidetv(True)
                Me.Profile_Geaendert = True
                Me.Profile.SelectedNode.Text = a
                Me.Profname = a
                If checkchanges Then changes = True
                Me.showhidetv(False)
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MnDel_Click Method

Private Sub MnDel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnDel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDel.Click
        Try
            Dim tn As TreeNode
            tn = TreeView1.SelectedNode
            tn.Remove()
            changes = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MnuDeleteDokumentart_Click Method

Private Sub MnuDeleteDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 2
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Black
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 2
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Black
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MnuListe_Popup Method

Private Sub MnuListe_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MnuListe.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuListe_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MnuListe.Popup
        Dim i As Integer
        If Me.Profil_Ungueltig = True Then
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = False
            Next
            Exit Sub
        Else
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = True
            Next
        End If
        Try
            If Me.Profile.GetNodeCount(True) < 2 Then
                MenuItem10.Enabled = False
            Else
                MenuItem10.Enabled = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.MnuSelectDokumentart_Click Method

Private Sub MnuSelectDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSelectDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSelectDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSelectDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 1
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Red
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 1
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Red
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Panel1_Paint Method

Private Sub Panel1_Paint( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
) Handles Panel1.Paint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Panel1_Paint(ByVal sender As System.Object, ByVal e As System.Windows.Forms.PaintEventArgs) Handles Panel1.Paint

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.PartnerList_FetchRowStyle Method

Private Sub PartnerList_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles PartnerList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles PartnerList.FetchRowStyle
        If Microsoft.VisualBasic.Left(Me.PartnerList.Columns(0).CellValue(e.Row), 1) = "9" Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.PartnerSuchResultat Method

Private Sub PartnerSuchResultat() Handles Partnerdialog.partner_selected

Source code

[Visual Basic]
    Private Sub PartnerSuchResultat() Handles Partnerdialog.partner_selected
        Dim tn As New TreeNode()
        Dim tn1 As New TreeNode()
        If Me.TreeView1.SelectedNode.Tag = 41 Then
            tn = Me.TreeView1.SelectedNode
            tn1 = tn.Nodes.Add(Trim(Str(Me.Partnerdialog.PartnerNr)) + " - " + Me.Partnerdialog.PartnerKurzbezeichnnung)
            tn1.Tag = Trim(Str(Me.Partnerdialog.PartnerNr))
            tn1.ForeColor = System.Drawing.Color.Red
            tn1.ImageIndex = 4
            tn1.SelectedImageIndex = 4
            Me.TreeView1.SelectedNode.ExpandAll()
            Me.changes = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Profil_Colors Method

Private Function Profil_Colors()

Source code

[Visual Basic]
    Private Function Profil_Colors()
        Dim tn As TreeNode
        Me.Profile.BeginUpdate()
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                tn.BackColor = System.Drawing.Color.LightBlue
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
            tn = tn.NextNode
        Loop
        Try
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.Silver
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Profile_AfterSelect Method

Private Sub Profile_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles Profile.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles Profile.AfterSelect
        If Not On_Load Then
            check_changes()
            If Me.Profil_Ungueltig Then
                Me.Profile.SelectedNode = Me.savenode
                MyMsg.show_standardmessage(105, MsgBoxStyle.Critical)
                Exit Sub
            End If
            Me.savenode = Me.Profile.SelectedNode
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            check_changes()
            Me.ProfilNr = Me.Profile.SelectedNode.Tag
            Me.TreeView1.BeginUpdate()
            Me.showhidetv(True)
            init_treeview1()
            frmProfil_Load(sender, e)
            Me.TreeView1.SelectedNode = Nothing
            Me.showhidetv(False)
            Me.TreeView1.EndUpdate()
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Profile_MouseDown Method

Private Sub Profile_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Profile.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Profile.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                Profile.SelectedNode = Profile.GetNodeAt(selectPoint)
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Remove_Selected_Items Method

Private Sub Remove_Selected_Items( _
   ByVal lb As ListBox _
)

Parameters

lb
Required.

Source code

[Visual Basic]
    Private Sub Remove_Selected_Items(ByVal lb As ListBox)
        Dim i As Integer
        Dim b As Integer
        Dim splitter
        For i = 0 To lb.Items.Count - 1
            lb.SelectedIndex = i
            splitter = Microsoft.VisualBasic.Split(lb.SelectedItem)

            Try
                For b = 0 To Me.lbSortfields.Items.Count - 1
                    Me.lbSortfields.SelectedIndex = b
                    If Me.lbSortfields.SelectedItem = splitter(0) Then Me.lbSortfields.Items.RemoveAt(b)
                Next
            Catch
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Save_Profile Method

Private Sub Save_Profile()

Source code

[Visual Basic]
    Private Sub Save_Profile()
        Dim p As New edokadb.clsProfil()
        Dim tn As TreeNode
        Dim d As DataTable
        Dim tmptreeview As New TreeView()
        p.cpMainConnectionProvider = conn
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()

        'Selektion
        Dim s As String

        Dim i As Integer
        'hutter 20041014
        'Me.TreeView1.BeginUpdate()
        p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))

        p.sVmb = New SqlString(CType(GetNodeDatastring(11), String))
        p.sVnl = New SqlString(CType(GetNodeDatastring(12), String))
        p.sVkost = New SqlString(CType(GetNodeDatastring(13), String))
        p.sVteam = New SqlString(CType(GetNodeDatastring(14), String))
        p.sVma = New SqlString(CType(GetNodeDatastring(15), String))

        p.sEmb = New SqlString(CType(GetNodeDatastring(21), String))
        p.sEnl = New SqlString(CType(GetNodeDatastring(22), String))
        p.sEkost = New SqlString(CType(GetNodeDatastring(23), String))
        p.sEteam = New SqlString(CType(GetNodeDatastring(24), String))
        p.sEma = New SqlString(CType(GetNodeDatastring(25), String))

        p.sMmb = New SqlString(CType(GetNodeDatastring(31), String))
        p.sMnl = New SqlString(CType(GetNodeDatastring(32), String))
        p.sMkost = New SqlString(CType(GetNodeDatastring(33), String))
        p.sMteam = New SqlString(CType(GetNodeDatastring(34), String))
        p.sMma = New SqlString(CType(GetNodeDatastring(35), String))

        p.sDpartner = New SqlString(CType(GetNodeDatastring(41), String))
        p.sDoktyp = New SqlString(CType(GetNodeDatastring(43), String))
        p.sDdokstatus = New SqlString(CType(GetNodeDatastring(44), String))

        p.sHostpartner = New SqlString(CType(GetNodeDatastring(51), String))
        p.sHostdoktyp = New SqlString(CType(GetNodeDatastring(53), String))
        p.bInklhostmavip = New SqlBoolean(CType(Me.hostinklmavip.Checked, Boolean))
        p.sHosttag3 = New SqlString(CType(GetNodeDatastring(59), String))
        p.sHostdatum3 = New SqlString(CType(GetNodeDatastring(58), String))
        p.sHosttag1 = New SqlString(CType(GetNodeDatastring(54), String))

        tmptreeview = Me.TVDokart
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        'tmptreeview.Dispose()
        p.sDdokart = New SqlString(CType(s, String))

        tmptreeview = Me.TVHostDok
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        p.sHostdokart = New SqlString(CType(s, String))

        p.bInklmavip = New SqlBoolean(CType(Me.cbmavip.Checked, Boolean))
        p.bInklalt = New SqlBoolean(CType(Me.cinklalt.Checked, Boolean))
        p.bInkInaktVersant = New SqlBoolean(CType(Me.cinklaltversant.Checked, Boolean))

        s = ""
        For i = 0 To Me.lbselect.Items.Count - 1
            s = s + Me.lbselect.Items(i) + ";"
        Next
        p.sSort = New SqlString(CType(s, String))

        s = ""
        For i = 0 To Me.LBSelectHost.Items.Count - 1
            s = s + Me.LBSelectHost.Items(i) + ";"
        Next
        p.sHosttag2 = New SqlString(CType(s, String))

        'Unterschriften / Hinweise
        If Me.mcbunterschriftlinks.SelectedValue = Nothing Then
            p.iUnterschriftlinks = New SqlInt32(CType(0, Int32))
        Else
            p.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
        End If
        If Me.mcbunterschriftrechts.SelectedValue = Nothing Then
            p.iUnterschriftrechts = New SqlInt32(CType(0, Int32))
        Else
            p.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
        End If
        If Me.mcbTeam.SelectedText = Nothing Then
            p.iTeam = New SqlInt32(CType(0, Int32))
        Else
            p.iTeam = New SqlInt32(CType(Me.mcbTeam.SelectedValue, Int32))
        End If

        If Me.cb1.Checked = True Then
            p.iHw1 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw1 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb2.Checked = True Then
            p.iHw2 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw2 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb3.Checked = True Then
            p.iHw3 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw3 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb3_1.Checked = True Then
            p.iHw6 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw6 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb4.Checked = True Then
            p.iHw4 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw4 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb5.Checked = True Then
            p.iHw5 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw5 = New SqlInt32(CType(0, Int32))
        End If

        If colconv.ConvertToString(Me.Profile.SelectedNode.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Or p.bStandard.Value = True Then
            p.bStandard = New SqlBoolean(CType(True, Boolean))
        Else
            p.bStandard = New SqlBoolean(CType(False, Boolean))
        End If

        'Colors
        p.sColor1 = New SqlString(CType(colconv.ConvertToString(Me.colbtn1.BackColor), String))
        p.sColor2 = New SqlString(CType(colconv.ConvertToString(Me.colbtn2.BackColor), String))
        p.sColor3 = New SqlString(CType(colconv.ConvertToString(Me.colbtn3.BackColor), String))
        p.sColor4 = New SqlString(CType(colconv.ConvertToString(Me.colbtn4.BackColor), String))
        p.sColor5 = New SqlString(CType(colconv.ConvertToString(Me.colbtn5.BackColor), String))
        p.sColor6 = New SqlString(CType(colconv.ConvertToString(Me.colbtn6.BackColor), String))

        'Selektionsdaten
        p.sDatum1 = New SqlString(CType(Me.datumtext1.Text, String))
        p.sDatum2 = New SqlString(CType(Me.datumtext2.Text, String))
        p.sDatum3 = New SqlString(CType(Me.datumtext3.Text, String))
        p.sDatum4 = New SqlString(CType(Me.datumtext4.Text, String))
        p.sDatum5 = New SqlString(CType(Me.datumtext5.Text, String))
        p.sDatum6 = New SqlString(CType(Me.datumtext6.Text, String))
        p.sHostdatum1 = New SqlString(CType(Me.DatumHostText1.Text, String))
        p.sHostdatum2 = New SqlString(CType(Me.DatumHostText2.Text, String))

        'Rel 3.7 / BUD
        'p.sUvmdatum1 = New SqlString(CType(Me.textdatum1uvm.Text, String))
        'p.sUvmdatum2 = New SqlString(CType(Me.textdatum2uvm.Text, String))
        'p.sUvmdatum3 = New SqlString(CType(Me.textdatum3uvm.Text, String))
        'p.sUvmdatum4 = New SqlString(CType(Me.textdatum4uvm.Text, String))

        p.sZvdatum1 = New SqlString(CType(Me.textdatum1zv.Text, String))
        p.sZvdatum2 = New SqlString(CType(Me.textdatum2zv.Text, String))
        p.sZvdatum3 = New SqlString(CType(Me.textdatum3zv.Text, String))
        p.sZvdatum4 = New SqlString(CType(Me.textdatum4zv.Text, String))

        'Rel 3.7 / BUD
        'p.sUvmdoktyp = New SqlString(CType(GetNodeDatastring(91), String))
        'p.sUvmauftragnr = New SqlString(CType(GetNodeDatastring(93), String))

        p.sZvauftraggeber = New SqlString(CType(GetNodeDatastring(74), String))
        p.sZvauftragnr = New SqlString(CType(GetNodeDatastring(73), String))
        p.sZvbetrag = New SqlString(CType(GetNodeDatastring(75), String))
        p.sZvclearingnr = New SqlString(CType(GetNodeDatastring(76), String))
        p.sZvdokumenttyp = New SqlString(CType(GetNodeDatastring(71), String))
        p.sZviso = New SqlString(CType(GetNodeDatastring(77), String))
        p.sZvkontobeg = New SqlString(CType(GetNodeDatastring(78), String))
        p.sZvpcnr = New SqlString(CType(GetNodeDatastring(79), String))
        p.sZvposten = New SqlString(CType(GetNodeDatastring(80), String))
        p.sZvreferenznr = New SqlString(CType(GetNodeDatastring(81), String))
        p.sZvswift = New SqlString(CType(GetNodeDatastring(82), String))
        p.sZvverarbeitungsart = New SqlString(CType(GetNodeDatastring(83), String))
        p.sZvzahlungsart = New SqlString(CType(GetNodeDatastring(84), String))

        Dim s1 As String
        Dim s2 As String

        If Me.Profname <> "" Then p.sBezeichnung = New SqlString(CType(Profname, String))
        conn.OpenConnection()
        p.Update()

        conn.CloseConnection(True)
        p.Dispose()
        'Me.TreeView1.EndUpdate()
        changes = False
        Me.Load_Profil(Me.ProfilNr)
        'Me.TreeView1.ExpandAll()
        Me.Profil_Ungueltig = False
        'Me.TreeView1.BeginUpdate()
        'nodeswithdata(1)
        'nodeswithdata(2)
        'nodeswithdata(3)
        'nodeswithdata(70)
        'nodeswithdata(90)
        'Me.TreeView1.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Set_Values Method

Private Sub Set_Values( _
   ByVal data As String, _
   ByVal ds As DataTable, _
   ByVal node As Integer _
)

Parameters

data
Required.
ds
Required.
node
Required.

Source code

[Visual Basic]
    Private Sub Set_Values(ByVal data As String, ByVal ds As DataTable, ByVal node As Integer)
        If data = "" Then Exit Sub
        Dim splitter
        Dim i As Integer
        Dim s As String
        Dim tn As TreeNode
        Dim dv As New DataTable()
        Dim i1 As Integer
        Dim v As Double
        Select Case node
            Case 11, 21, 31
                dv = Me.tmb
            Case 12, 22, 32
                dv = Me.tnl
            Case 13, 23, 33
                dv = Me.tko
            Case 14, 24, 34
                dv = Me.tte
            Case 15, 25, 35
                dv = Me.tpe
            Case 51
                dv = Me.tku
            Case 43
                dv = Me.tdt
            Case 53
                dv = Me.tdh
            Case 44
                dv = Me.tst
            Case 71
                dv = Me.tdtzv
                'Rel 3.7 / BUD
                'Case 91
                '    dv = Me.tdtuvm
            Case Else
        End Select
        s = data
        splitter = Microsoft.VisualBasic.Split(s, ";")
        i = 0
        Try
            Do Until splitter(i) Is Nothing
                Select Case node
                    Case 41
                        Dim p As New edokadb.clsPartner()
                        Try
                            DivFnkt.Searchnode1(Me.TreeView1, node, 0)
                            If DivFnkt.found Then
                                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                tn = Me.TreeView1.SelectedNode
                                p.cpMainConnectionProvider = conn
                                p.iNRPAR00 = New SqlInt32(CType(splitter(i), Int32))
                                p.SelectOne()
                                tn = tn.Nodes.Add(splitter(i) + " - " + p.sBKPAR00.Value)
                                tn.Tag = splitter(i)
                                Me.FirstNodeWithData = DivFnkt.FoundNode
                                tn.ImageIndex = 4
                                tn.SelectedImageIndex = 4
                                tn.ForeColor = System.Drawing.Color.Red
                            End If
                        Catch ex As Exception
                        Finally
                            p.Dispose()
                            'i = i + 1
                        End Try
                    Case 42, 52
                        DivFnkt.Searchnode(Me.TVDokart, splitter(i), 0)
                        If DivFnkt.found Then
                            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
                            DivFnkt.FoundNode.ImageIndex = 1
                            If Not DivFnkt.FoundNode.Parent.IsExpanded Then DivFnkt.FoundNode.Parent.ExpandAll()
                        End If
                    Case 54, 58, 59, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 92, 93, 94
                        Try
                            DivFnkt.Searchnode1(Me.TreeView1, node, 0)
                            If DivFnkt.found And splitter(i) <> "" Then
                                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                tn = Me.TreeView1.SelectedNode
                                tn = tn.Nodes.Add(splitter(i))
                                tn.Tag = splitter(i)
                                If Me.FirstNodeWithData Is Nothing Then
                                    Me.FirstNodeWithData = DivFnkt.FoundNode
                                End If
                                tn.ImageIndex = 4
                                tn.SelectedImageIndex = 4
                                tn.ForeColor = System.Drawing.Color.Red
                            End If
                        Catch
                        End Try
                    Case Else
                        For i1 = 0 To dv.Rows.Count - 1
                            v = Val(splitter(i))
                            If dv.Rows(i1).Item(0) = splitter(i) Then
                                DivFnkt.Searchnode1(Me.TreeView1, node, 99)
                                If DivFnkt.found Then
                                    If Me.FirstNodeWithData Is Nothing Then
                                        Me.FirstNodeWithData = DivFnkt.FoundNode
                                    End If
                                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                    tn = Me.TreeView1.SelectedNode
                                    tn = tn.Nodes.Add(dv.Rows(i1).Item(1))
                                    tn.Tag = dv.Rows(i1).Item(0)
                                    tn.ImageIndex = 4
                                    tn.SelectedImageIndex = 4
                                    If dv.Rows(i1).Item(2) = False Then
                                        tn.ForeColor = System.Drawing.Color.Gray
                                    Else
                                        tn.ForeColor = System.Drawing.Color.Red
                                    End If
                                End If

                            End If
                        Next
                End Select
                i = i + 1
            Loop
        Catch ex As Exception
            '            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        t = partner
        ts.Tabelle = "Partner"
        For i = 0 To Me.PartnerList.Columns.Count - 1
            s = Me.PartnerList.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.PartnerList.Columns(i).Caption = ts.spaltenname
            If Me.PartnerList.Columns(i).Caption = "" Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            '            If Me.PartnerList.Columns(i).Caption = "" Then Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            If ts.locked Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.PartnerList.Columns(i).DataField = "aktiv" Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.PartnerList.Columns(i).ValueItems.DefaultItem = True
                Me.PartnerList.Columns(i).DefaultValue = True
                Me.PartnerList.Columns(i).FilterText = True
            End If
            If Me.PartnerList.Columns(i).DataField = "erstellt_am" Then
                Me.PartnerList.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TVDokart_MouseDown Method

Private Sub TVDokart_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVDokart.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVDokart_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVDokart.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TVDokart.SelectedNode = TVDokart.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TabControl2_SelectedIndexChanged Method

Private Sub TabControl2_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl2.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl2_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl2.SelectedIndexChanged
        If On_Load = True Then Exit Sub
        If Me.TabControl2.SelectedIndex = 0 Then
            Me.GroupBox10.Visible = True
            Me.cinklalt.Visible = True
            Me.cinklaltversant.Visible = True
        Else
            Me.GroupBox10.Visible = False
            Me.cinklalt.Visible = False
            Me.cinklaltversant.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TabPagesClear Method

Private Sub TabPagesClear()

Source code

[Visual Basic]
    Private Sub TabPagesClear()
        'Rel 3.7 / BUD -- UVM TabPage löschen
        Dim tbp0 As New TabPage()
        Dim tbp1 As New TabPage()
        Dim tbp2 As New TabPage()
        tbp0 = Me.TabControl2.TabPages(0)
        tbp1 = Me.TabControl2.TabPages(1)
        tbp2 = Me.TabControl2.TabPages(2)
        Me.TabControl2.TabPages.Clear()
        Me.TabControl2.TabPages.Add(tbp0)
        Me.TabControl2.TabPages.Add(tbp1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox3.KeyDown, _
   TextBox2.KeyDown, _
   TextBox1.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox3.KeyDown, TextBox2.KeyDown, TextBox1.KeyDown
        If e.KeyCode = Keys.Return Then btnPartnersuche_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TextBox4_KeyDown Method

Private Sub TextBox4_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox4.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox4_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox4.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button9_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TextBox5_KeyDown Method

Private Sub TextBox5_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox5.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox5_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox5.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button10_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TextBox6_KeyDown Method

Private Sub TextBox6_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox6.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox6_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox6.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button20_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.MenuItem5_Click(sender, e)
            Case 1

            Case 2
                Me.showhidetv(True)
                Me.TreeView1.BeginUpdate()
                Me.Profile.BeginUpdate()
                Me.On_Load = True
                Me.oninit = True
                Save_Profile()
                Me.Profile.EndUpdate()
                If Me.Profil_Ungueltig = True Then MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
                Me.On_Load = False
                Me.oninit = False
                Me.TreeView1.EndUpdate()
                Me.TreeView2.Visible = False
                Me.showhidetv(False)
            Case 3
                Me.TreeView1.BeginUpdate()
                Me.showhidetv(True)
                oninit = True
                init_profile()
                Me.init_datumzvuvm()
                oninit = False
                Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
                Me.TreeView1.EndUpdate()
                Me.showhidetv(False)
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TreeView1_AfterSelect Method

Private Sub TreeView1_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect
        If On_Load Then Exit Sub
        If oninit Then Exit Sub
        Me.PnlDokumentDaten.Visible = False
        Me.Panel3.Visible = False
        Me.PnlPartner.Visible = False
        Me.PnlDokumentart.Visible = False
        Me.TVDokart.Visible = False
        Me.TVHostDok.Visible = False
        Me.pnlhostdiv.Visible = False
        Me.Panel4.Visible = False
        Me.pnluvm.Visible = False
        Me.pnlzv.Visible = False

        Try
            If Me.TreeView1.SelectedNode.ImageIndex < 6 Then
                Me.TreeView1.SelectedNode.ImageIndex = 4
                Me.TreeView1.SelectedNode.SelectedImageIndex = 4
            End If
            Select Case TreeView1.SelectedNode.Tag
                Case 11, 21, 31
                    Me.C1TrueDBGrid1.DataSource = tmb
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 12, 22, 32
                    Me.C1TrueDBGrid1.DataSource = tnl
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 13, 23, 33
                    Me.C1TrueDBGrid1.DataSource = tko
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 14, 24, 34
                    Me.C1TrueDBGrid1.DataSource = tte
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 15, 25, 35
                    Me.C1TrueDBGrid1.DataSource = tpe
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 41
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 42
                    Me.PnlDokumentart.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                    Me.TVDokart.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 43
                    Me.C1TrueDBGrid1.DataSource = tdt
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 44
                    Me.C1TrueDBGrid1.DataSource = tst
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 45
                    Me.Panel3.Visible = False
                    Me.PnlDokumentDaten.Visible = True
                    Me.TabControl2.SelectedIndex = 0
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 62
                    Me.Panel3.Visible = False
                    Me.PnlDokumentDaten.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 51
                    Me.C1TrueDBGrid1.DataSource = tku
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 52
                    Me.TVHostDok.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 53
                    Me.C1TrueDBGrid1.DataSource = tdh
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 55
                    Me.pnlhostdiv.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 58
                    Me.pnlhostdiv.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 54
                    Me.pnlhostdiv.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 59
                    Me.pnlhostdiv.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 60
                    Me.Panel4.Visible = True
                    Me.lbSortfields.Items.Clear()
                    Me.lbSortfields.Items.AddRange(New Object() {"Bemerkung", "Bezeichnung", "Dokumentart", "DokumentID", "Ersteller", "Erstellungsdatum", "Mutationsdatum", "Mutierer", "Status", "Termin", "Verantwortlicher", "Zuständiger"})
                    Remove_Selected_Items(Me.lbselect)
                    Me.LBSelectHost.Visible = False
                    Me.lbselect.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 61
                    Me.Panel4.Visible = True
                    Me.lbSortfields.Items.Clear()
                    Me.lbSortfields.Items.AddRange(New Object() {"DokumentID", "Dokumenttyp-Nr", "Isin-Nr", "Valutadatum", "Valorennr", "VVExtern1", "VVExtern2"})
                    Remove_Selected_Items(Me.LBSelectHost)
                    Me.LBSelectHost.Visible = True
                    Me.lbselect.Visible = False
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 71
                    Me.C1TrueDBGrid1.DataSource = tdtzv
                    Me.Panel3.Visible = True
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 72
                    Me.Panel3.Visible = False
                    Me.PnlDokumentDaten.Visible = True
                    Me.TabControl2.SelectedIndex = 1
                    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                    'Rel 3.7 / BUD
                    'Case 91
                    '    Me.C1TrueDBGrid1.DataSource = tdtuvm
                    '    Me.Panel3.Visible = True
                    '    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                    'Case 93
                    '    Me.pnluvm.Visible = True
                    '    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                    'Case 92
                    '    Me.Panel3.Visible = False
                    '    Me.PnlDokumentDaten.Visible = True
                    '    Me.TabControl2.SelectedIndex = 2
                    '    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
                Case 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84
                    Me.Panel3.Visible = False
                    Me.pnlzv.Visible = True
            End Select
            Dim i As Integer
            Dim w As Integer
            w = Me.C1TrueDBGrid1.Columns.Count - 2
            w = (Me.C1TrueDBGrid1.Width - 150) / w
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Width = 150
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
            For i = 3 To Me.C1TrueDBGrid1.Splits(0).DisplayColumns.Count - 1
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = w
            Next

            Try
                Me.C1TrueDBGrid1.Columns("Aktiv").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.C1TrueDBGrid1.Columns("Aktiv").FilterText = True
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Aktiv").Width = 50
            Catch
            End Try

        Catch
        End Try

        'Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.TreeView1_Click Method

Private Sub TreeView1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TreeView1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeView1.Click
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Treeview1_MouseDown Method

Private Sub Treeview1_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Treeview1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TreeView1.SelectedNode = TreeView1.GetNodeAt(selectPoint)
            Catch
            End Try
            If TreeView1.SelectedNode.Tag = 41 And e.Button = MouseButtons.Left Then
                Me.Partnerdialog.TopMost = True
                Me.Partnerdialog.Left = Me.MousePosition.X + 50
                Me.Partnerdialog.Top = Me.MousePosition.Y - 20
                Me.Partnerdialog.Show()
                Me.Partnerdialog.NoClose = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
        Catch
        End Try
        'Cursor positionieren
        Try
            Select Case Me.TreeView1.SelectedNode.Tag
                Case 58
                    Me.TextBox5.Focus()
                Case 54
                    Me.TextBox6.Focus()
                Case 59
                    Me.TextBox4.Focus()
                Case Else
            End Select
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.Treeview1_Mouseup Method

Private Sub Treeview1_Mouseup( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Treeview1_Mouseup(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseUp
        'Cursor positionieren
        Try
            Select Case Me.TreeView1.SelectedNode.Tag
                Case 58
                    Me.TextBox5.Focus()
                Case 54
                    Me.TextBox6.Focus()
                Case 59
                    Me.TextBox4.Focus()
                Case 73
                    Me.txtzvauftragsnr.Focus()
                Case 74
                    Me.txtzvauftraggeber.Focus()
                Case 75
                    Me.txtzvbetrag.Focus()
                Case 76
                    Me.txtzvclearingnr.Focus()
                Case 77
                    Me.txtzviso.Focus()
                Case 78
                    Me.txtzvbeguenstigter.Focus()
                Case 79
                    Me.txtzvpcnr.Focus()
                Case 80
                    Me.txtzvpostennr.Focus()
                Case 81
                    Me.txtzvreferenznr.Focus()
                Case 82
                    Me.txtzvswift.Focus()
                Case 83
                    Me.txtzvverarbeitungsart.Focus()
                Case 84
                    Me.txtzvzahlungsart.Focus()
                    'Rel 3.7 / BUD
                    'Case 93
                    '    Me.txtuvmauftragnr.Focus()
                Case Else
            End Select
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.ValueList Method

Private Function ValueList( _
   ByVal c As ListView _
) As String

Parameters

c
Required.

Source code

[Visual Basic]
    Private Function ValueList(ByVal c As ListView) As String
        Dim s As String
        s = ""
        For i = 0 To c.Items.Count - 1
            s = s + c.Items(i).Text + ";"
            If UCase(c.Name) = "SELPARTNER" Then
                li = c.Items(i)
                s = s + li.SubItems(1).Text + ";"
            End If
        Next
        Return s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.btnPartnersuche_Click Method

Private Sub btnPartnersuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnersuche.Click
        Me.PartnerList.DataSource = Nothing
        Me.PartnerList.DataMember = Nothing
        If Me.TextBox1.Text <> "" Then
            Try
                Dim d As Double
                d = Val(Me.TextBox1.Text)
                If d = 0 Then
                    MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                    Me.TextBox1.Focus()
                    Exit Sub
                End If
                partner = mypartner.search_partner(d, 50, 0)
            Catch
                MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                Me.TextBox1.Focus()
                Exit Sub
            End Try
        Else
            If Me.TextBox2.Text <> "" Then
                partner = mypartner.search_partner(Me.TextBox2.Text, 50, 1)
            Else
                partner = mypartner.search_partner(Me.TextBox3.Text, 50, 2)
            End If
        End If
        If partner.Rows.Count = 0 Then
            MyMsg.show_standardmessage(204, MsgBoxStyle.Exclamation)
        Else
            Me.PartnerList.DataSource = partner
            Me.PartnerList.DataMember = "Partner"
            SpaltenTitel_Aktualisieren()
            Dim i As Long
            Dim ii As Long
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.btnzvauftragsnr_Click Method

Private Sub btnzvauftragsnr_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnzvauftragsnr.Click, _
   btnzvreferenz.Click, _
   btnzvposten.Click, _
   btnzvverarbeitungsart.Click, _
   btnzvpcnr.Click, _
   btnzvbeguenstiger.Click, _
   btnzviso.Click, _
   btnzvclearing.Click, _
   btnzvzahlungsart.Click, _
   btnzvbetrag.Click, _
   btnzvswift.Click, _
   btnzvauftraggeber.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnzvauftragsnr_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnzvauftragsnr.Click, btnzvreferenz.Click, btnzvposten.Click, _
    btnzvverarbeitungsart.Click, btnzvpcnr.Click, btnzvbeguenstiger.Click, btnzviso.Click, btnzvclearing.Click, btnzvzahlungsart.Click, btnzvbetrag.Click, btnzvswift.Click, _
    btnzvauftraggeber.Click
        Dim tn As New TreeNode()
        Dim tn1 As New TreeNode()
        Dim tb As Object
        Dim o As TextBox
        Dim t As String
        tb = sender
        Dim i As Integer = 0

        Select Case tb.Name
            Case "btnzvauftragsnr", "txtzvauftragsnr"
                i = 73
                o = Me.txtzvauftragsnr
            Case "btnzvauftraggeber", "txtzvauftraggeber"
                i = 74
                o = Me.txtzvauftraggeber
            Case "btnzvbetrag", "txtzvbetrag"
                i = 75
                o = Me.txtzvbetrag
            Case "btnzvclearing", "txtzvclearingnr"
                i = 76
                o = Me.txtzvclearingnr
            Case "btnzviso", "txtzviso"
                i = 77
                o = Me.txtzviso
            Case "btnzvbeguenstiger", "txtzvbeguenstigter"
                i = 78
                o = Me.txtzvbeguenstigter
            Case "btnzvpcnr", "txtzvpcnr"
                i = 79
                o = Me.txtzvpcnr
            Case "btnzvposten", "txtzvpostennr"
                i = 80
                o = Me.txtzvpostennr
            Case "btnzvreferenz", "txtzvrerenznr"
                i = 81
                o = Me.txtzvreferenznr
            Case "btnzvswift", "txtzvswift"
                i = 82
                o = Me.txtzvswift
            Case "btnzvverarbeitungsart", "txtzvverarbeitungsart"
                i = 83
                o = Me.txtzvverarbeitungsart
            Case "btnzvzahlungsart", "txtzvzahlungsart"
                i = 84
                o = Me.txtzvzahlungsart
            Case Else
                i = 0
        End Select
        Try
            If i > 0 Then
                DivFnkt.Searchnode1(Me.TreeView1, i, 99)
                If DivFnkt.found = True Then
                    tn = DivFnkt.FoundNode
                    tn1 = tn.Nodes.Add(o.Text)
                    tn1.Tag = o.Text
                    tn1.ForeColor = System.Drawing.Color.Red
                    tn1.ImageIndex = 4
                    tn1.SelectedImageIndex = 4
                    tn1.Parent.ExpandAll()
                    o.Text = ""
                    Me.changes = True
                End If
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.cbrollend1_CheckedChanged Method

Private Sub cbrollend1_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbrollend6.CheckedChanged, _
   cbrollend5.CheckedChanged, _
   cbrollend4.CheckedChanged, _
   cbrollend3.CheckedChanged, _
   cbrollend2.CheckedChanged, _
   cbrollend1.CheckedChanged, _
   cbrollend8.CheckedChanged, _
   cbrollend9.CheckedChanged, _
   cbuvmrollend1.CheckedChanged, _
   cbuvmrollend2.CheckedChanged, _
   cbuvmrollend3.CheckedChanged, _
   cbuvmrollend4.CheckedChanged, _
   cbzvrollend1.CheckedChanged, _
   cbzvrollend2.CheckedChanged, _
   cbzvrollend3.CheckedChanged, _
   cbzvrollend4.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbrollend1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbrollend6.CheckedChanged, cbrollend5.CheckedChanged, cbrollend4.CheckedChanged, cbrollend3.CheckedChanged, cbrollend2.CheckedChanged, cbrollend1.CheckedChanged, cbrollend8.CheckedChanged, cbrollend9.CheckedChanged, cbuvmrollend1.CheckedChanged, cbuvmrollend2.CheckedChanged, cbuvmrollend3.CheckedChanged, cbuvmrollend4.CheckedChanged, cbzvrollend1.CheckedChanged, cbzvrollend2.CheckedChanged, cbzvrollend3.CheckedChanged, cbzvrollend4.CheckedChanged
        Dim cb As CheckBox
        cb = sender
        Select Case cb.Name
            Case "cbrollend1"
                txtdatum1_TextChanged(Me.txtdatum1, e)
            Case "cbrollend2"
                txtdatum1_TextChanged(Me.txtdatum2, e)
            Case "cbrollend3"
                txtdatum1_TextChanged(Me.txtdatum3, e)
            Case "cbrollend4"
                txtdatum1_TextChanged(Me.txtdatum4, e)
            Case "cbrollend5"
                txtdatum1_TextChanged(Me.txtdatum5, e)
            Case "cbrollend6"
                txtdatum1_TextChanged(Me.txtdatum6, e)
            Case "cbrollend8"
                txtdatum1_TextChanged(Me.HostDatum1, e)
            Case "cbrollend9"
                txtdatum1_TextChanged(Me.HostDatum2, e)
                'Rel 3.7 / BUD
                'Case "cbuvmrollend1"
                '    txtdatum1_TextChanged(Me.txtdatum1uvm, e)
                'Case "cbuvmrollend2"
                '    txtdatum1_TextChanged(Me.txtdatum2uvm, e)
                'Case "cbuvmrollend3"
                '    txtdatum1_TextChanged(Me.txtdatum3uvm, e)
                'Case "cbuvmrollend4"
                '    txtdatum1_TextChanged(Me.txtdatum4uvm, e)
            Case "cbzvrollend1"
                txtdatum1_TextChanged(Me.txtdatum1zv, e)
            Case "cbzvrollend2"
                txtdatum1_TextChanged(Me.txtdatum2zv, e)
            Case "cbzvrollend3"
                txtdatum1_TextChanged(Me.txtdatum3zv, e)
            Case "cbzvrollend4"
                txtdatum1_TextChanged(Me.txtdatum4zv, e)
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        If On_Load Then Exit Sub
        If changes Then
            If Me.FirstNodeWithData Is Nothing Then
                Me.Profil_Ungueltig = True
            End If
            If MyMsg.Show_MessageYesNo(2) = MsgBoxResult.Yes Then
                Me.Save_Profile()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.cinklalt_CheckedChanged Method

Private Sub cinklalt_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cinklalt.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cinklalt_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cinklalt.CheckedChanged
        Dim tn As New TreeNode()
        DivFnkt.Searchnode1(Me.TreeView1, 62, 99)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.cinklalt.Checked Then
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
            Else
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.cinklaltversant_CheckedChanged Method

Private Sub cinklaltversant_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cinklaltversant.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cinklaltversant_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cinklaltversant.CheckedChanged
        Dim tn As New TreeNode()
        DivFnkt.Searchnode1(Me.TreeView1, 62, 99)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.cinklaltversant.Checked Then
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
            Else
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.del_entry Method

Private Sub del_entry( _
   ByVal node As Integer _
)

Parameters

node
Required.

Source code

[Visual Basic]
    Private Sub del_entry(ByVal node As Integer)
        Dim tn As TreeNode
        DivFnkt.Searchnode1(Me.TreeView1, node, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
            Try
                tn = Me.TreeView1.SelectedNode
                While tn.GetNodeCount(True) > 0
                    tn.Nodes(0).Remove()
                End While
                tn.ForeColor = System.Drawing.Color.Black
            Catch
            End Try

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.frmProfil_Closing Method

Private Sub frmProfil_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        check_changes()
        If Me.FirstNodeWithData Is Nothing Then
            If MyMsg.Show_MessageYesNo(104) = MsgBoxResult.No Then e.Cancel = True
        End If
        'If Me.Profil_Ungueltig Then
        'MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
        'e.Cancel = True
        'Else
        '    e.Cancel = False
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.frmProfil_Load Method

Private Sub frmProfil_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        On_Load = True

        'TabPage löschen aber nur das erste mal beim Laden des Formulars.
        If ifirst = 0 Then
            TabPagesClear()
            ifirst = ifirst + 1
        End If

        Me.TreeView2.Top = Me.TreeView1.Top
        Me.TreeView2.Left = Me.TreeView1.Left
        Me.TreeView2.Width = Me.TreeView1.Width
        Me.TreeView2.Height = Me.TreeView1.Height
        Me.TreeView2.Visible = False
        Me.Cursor = Cursors.WaitCursor
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString

        Me.Profile.BeginUpdate()
        checkchanges = False
        changes = False
        Me.Profile.Nodes.Clear()
        Me.DataSet1.Clear()
        'Personendaten
        Dim tn, tn1 As TreeNode
        If first Then
            init_treeview1()
            tmb = Generic_Select(3)
            tnl = Generic_Select(4)
            tko = Generic_Select(5)
            tte = Generic_Select(6)
            tst = Generic_Select(2)
            tpe = Generic_Select(1)
            tdt = Generic_Select(7)
            tdh = Generic_Select(8)
            tku = Generic_Select(9)
            'Rel 3.7 / BUD
            'tdtuvm = Generic_Select(10)

            tdtzv = Generic_Select(11)

            mcbTeam = New MultiComboBox(Me.cbteam)
            Me.mcbTeam.DisplayColumnName = "Bezeichnung"
            Me.mcbTeam.ValueColumnName = "teamnr"
            Me.mcbTeam.Fill_Data(tte, True)
            Me.mcbTeam.Visible = True
            Me.mcbTeam.CheckNullValue = False

            mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
            Me.mcbunterschriftlinks.CheckNullValue = False
            Me.mcbunterschriftlinks.DisplayColumnName = "name"
            Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftlinks.Fill_Data(tpe, True)
            Me.mcbunterschriftlinks.Visible = True

            mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
            Me.mcbunterschriftrechts.CheckNullValue = False
            Me.mcbunterschriftrechts.DisplayColumnName = "name"
            Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftrechts.Fill_Data(tpe, True)
            Me.mcbunterschriftrechts.Visible = True
        End If

        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        tda = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        hdata.Dispose()

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
            tn = Me.Profile.Nodes.Add(Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung"))
            tn.Tag = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
            If Me.DataSet1.Tables(0).Rows(i).Item("standard") Then
                tn.BackColor = System.Drawing.Color.LightBlue
                If Me.ProfilNr = 0 Then Me.ProfilNr = tn.Tag
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
        Next
        first = False
        Load_Profil(Me.ProfilNr)
        checkchanges = False
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If tn.Tag = Me.ProfilNr Then Me.Profile.SelectedNode = tn
            tn = tn.NextNode
        Loop
        On_Load = False
        first = False
        Me.TreeView1.ExpandAll()
        Profil_Colors()
        Me.LBSort.SelectedIndex = 0
        Me.lbSortfields.SelectedIndex = 0
        checkchanges = True
        Me.Profile.EndUpdate()
        Profname = ""
        Activate_Details()
        Me.Cursor = Cursors.Default
        'hutter 20041014
        'Me.TreeView1.BeginUpdate()
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        'Rel 3.7 / BUD
        'nodeswithdata(90)
        nodeswithdata(72)
        'Rel 3.7 / BUD
        'nodeswithdata(92)
        'hutter 20041014
        'Me.TreeView1.EndUpdate()
        set_tips()
        Me.showhidetv(False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.frmProfil_Resize Method

Private Sub frmProfil_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.init_datumzvuvm Method

Private Sub init_datumzvuvm()

Source code

[Visual Basic]
    Private Sub init_datumzvuvm()
        Me.txtdatum1zv.Text = Now.ToShortDateString
        'Rel 3.7 / BUD
        'Me.txtdatum1uvm.Text = Now.ToShortDateString
        'Me.cbuvmrollend1.Checked = True
        Me.cbzvrollend1.Checked = True

        DivFnkt.Searchnode1(Me.TreeView1, 72, 99)
        DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
        DivFnkt.FoundNode.Parent.ExpandAll()

        'Rel 3.7 / BUD
        'DivFnkt.Searchnode1(Me.TreeView1, 92, 99)
        'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
        'DivFnkt.FoundNode.Parent.ExpandAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.init_profile Method

Private Sub init_profile()

Source code

[Visual Basic]
    Private Sub init_profile()
        Dim i As Integer
        For i = 11 To 15
            del_entry(i)
            del_entry(i + 10)
            del_entry(i + 20)
        Next
        del_entry(41)
        del_entry(43)
        del_entry(44)
        del_entry(53)
        del_entry(54)
        del_entry(51)
        del_entry(58)
        del_entry(59)
        del_entry(71)
        del_entry(73)
        del_entry(74)
        del_entry(75)
        del_entry(76)
        del_entry(77)
        del_entry(78)
        del_entry(79)
        del_entry(80)
        del_entry(81)
        del_entry(82)
        del_entry(83)
        del_entry(84)
        del_entry(91)
        del_entry(93)
        del_entry(94)

        Me.LBSelectHost.Items.Clear()
        Me.lbselect.Items.Clear()
        Me.cinklalt.Checked = False
        Me.cinklaltversant.Checked = False
        Me.txtdatum1.Text = ""
        Me.cbrollend1.Checked = False
        Me.txtdatum2.Text = ""
        Me.cbrollend2.Checked = True

        Me.txtdatum3.Text = ""
        Me.cbrollend3.Checked = False
        Me.txtdatum4.Text = ""
        Me.cbrollend4.Checked = True
        Me.txtdatum5.Text = ""
        Me.cbrollend5.Checked = False
        Me.txtdatum6.Text = ""
        Me.cbrollend6.Checked = True

        Me.HostDatum1.Text = ""
        Me.cbrollend8.Checked = False
        Me.HostDatum2.Text = ""
        Me.cbrollend9.Checked = True

        'Rel 3.7 / BUD
        'Me.txtdatum1uvm.Text = ""
        'Me.txtdatum2uvm.Text = ""
        'Me.txtdatum3uvm.Text = ""
        'Me.txtdatum4uvm.Text = ""
        'Me.cbuvmrollend1.Checked = False
        'Me.cbuvmrollend2.Checked = True
        'Me.cbuvmrollend3.Checked = False
        'Me.cbuvmrollend4.Checked = True

        Me.txtdatum1zv.Text = ""
        Me.txtdatum2zv.Text = ""
        Me.txtdatum3zv.Text = ""
        Me.txtdatum4zv.Text = ""
        Me.cbzvrollend1.Checked = False
        Me.cbzvrollend2.Checked = True
        Me.cbzvrollend3.Checked = False
        Me.cbzvrollend4.Checked = True

        Try
            Dim tmpdate As DateTime
            tmpdate = DateAdd(DateInterval.Day, -180, Now)
            Me.txtdatum1zv.Text = tmpdate.ToShortDateString
        Catch
        End Try
        reset_dokart()

        reset_color(60)
        reset_color(61)
        reset_color(62)
        reset_color(45)
        reset_color(55)
        reset_color(42)
        reset_color(52)
        Me.changes = True
        DivFnkt.Searchnode1(Me.TreeView1, 41, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
        End If
        'hutter 20041014
        'Me.TreeView1.BeginUpdate()
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        'Rel 3.7 / BUD
        'nodeswithdata(90)
        nodeswithdata(72)
        'Rel 3.7 / BUD
        'nodeswithdata(92)

        'hutter 20041014
        'Me.TreeView1.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.init_treeview1 Method

Private Function init_treeview1()

Source code

[Visual Basic]
    Private Function init_treeview1()
        Me.TreeView1.Nodes.Clear()
        Dim t0, tn, tn1 As TreeNode
        'hutter 20041014
        'TreeView1.BeginUpdate()
        Me.TreeView1.Nodes.Clear()
        t0 = Me.TreeView1.Nodes.Add("Partner")
        t0.ImageIndex = 10
        t0.SelectedImageIndex = 10
        t0.Tag = 999
        tn1 = t0.Nodes.Add("Partner")
        tn1.Tag = 41
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = t0.Nodes.Add("Kundenbetreuer")
        tn1.Tag = 51
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        t0 = Me.TreeView1.Nodes.Add("EDOKA-Dokumente")
        t0.ImageIndex = 6
        t0.SelectedImageIndex = 6
        t0.Tag = 998
        tn = t0.Nodes.Add("Verantwortlich")
        tn.ImageIndex = 7
        tn.SelectedImageIndex = 7
        tn.Tag = 1
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 11
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 12
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 13
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 14
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 15
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        'tn = Me.TreeView1.Nodes.Add("Ersteller")
        tn = t0.Nodes.Add("Ersteller")
        tn.ImageIndex = 8
        tn.SelectedImageIndex = 8
        tn.Tag = 2
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 21
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 22
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 23
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 24
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 25
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn = t0.Nodes.Add("Mutierer")
        'tn = Me.TreeView1.Nodes.Add("Mutierer")
        tn.ImageIndex = 9
        tn.SelectedImageIndex = 9
        tn.Tag = 3
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 31
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 32
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 33
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 34
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 35
        tn1.ImageIndex = 4

        'tn = t0.Nodes.Add("Diverses")
        '        tn = Me.TreeView1.Nodes.Add("Diverses")
        'tn.ImageIndex = 6
        'tn.SelectedImageIndex = 6
        'tn.Tag = 4

        'tn1 = tn.Nodes.Add("Partner")
        'tn1.Tag = 41
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumentart")
        tn1.Tag = 42
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumenttyp")
        tn1.Tag = 43
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumentstatus")
        tn1.Tag = 44
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Datum-Selektion")
        tn1.Tag = 45
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("inkl. gelöschte/aufgehobene")
        tn1.Tag = 62
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Sortierung")
        tn1.Tag = 60
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn = t0.Nodes.Add("ZV-Belege")
        tn.Tag = 70
        tn.ImageIndex = 12
        tn.SelectedImageIndex = 12

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 71
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Datum-Selektion")
        tn1.Tag = 72
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Auftrags-Nr.")
        tn1.Tag = 73
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Auftraggeber")
        tn1.Tag = 74
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Betrag")
        tn1.Tag = 75
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Clearing-Nr.")
        tn1.Tag = 76
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("ISO-Währung")
        tn1.Tag = 77
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Konto Begünstigter")
        tn1.Tag = 78
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("PC-Nr")
        tn1.Tag = 79
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Posten-Nr.")
        tn1.Tag = 80
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Referenz-Nr.")
        tn1.Tag = 81
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("SWIFT-Adresse")
        tn1.Tag = 82
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Verarbeitungsart")
        tn1.Tag = 83
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Zahlungsart")
        tn1.Tag = 84
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn.Collapse()

        'Rel 3.7 / BUD
        'tn = t0.Nodes.Add("Basis-Verträge")
        'tn.Tag = 90
        'tn.ImageIndex = 13
        'tn.SelectedImageIndex = 13

        'tn1 = tn.Nodes.Add("Dokumenttyp")
        'tn1.Tag = 91
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        'tn1 = tn.Nodes.Add("Datum-Selektion")
        'tn1.Tag = 92
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        'tn1 = tn.Nodes.Add("Auftrags-Nr.")
        'tn1.Tag = 93
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        'tn = t0.Nodes.Add("HOST-Dokumente")
        tn = Me.TreeView1.Nodes.Add("Host-Dokumente")
        tn.ImageIndex = 11
        tn.SelectedImageIndex = 11
        tn.Tag = 5
        '        tn1 = tn.Nodes.Add("Partner")
        '       tn1.Tag = 51
        '      tn1.ImageIndex = 4
        '     tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Dokumentart")
        tn1.Tag = 52
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 53
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        'tn1 = tn.Nodes.Add("Dokumentstatus")
        'tn1.Tag = 54
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("VV")
        tn1.Tag = 54
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Valorennr")
        tn1.Tag = 59
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("ISIN-Nr")
        tn1.Tag = 58
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Datum-Selektion")
        tn1.Tag = 55
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Sortierung")
        tn1.Tag = 61
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        Me.TVDokart.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVDokart, 2)
        Me.TVDokart.CollapseAll()

        Me.TVHostDok.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVHostDok, 3)
        Me.TVHostDok.ExpandAll()
        'hutter 20041014
        'Me.TreeView1.EndUpdate()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.lbselect_DoubleClick Method

Private Sub lbselect_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles LBSelectHost.DoubleClick, _
   lbselect.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lbselect_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LBSelectHost.DoubleClick, lbselect.DoubleClick
        Dim splitter
        Try
            If Me.LBSelectHost.Visible = True Then
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.LBSelectHost.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.LBSelectHost.Items.RemoveAt(Me.LBSelectHost.SelectedIndex)
                End If
            Else
                If Me.lbselect.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.lbselect.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.lbselect.Items.RemoveAt(Me.lbselect.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.lbsortfields_DoubleClick Method

Private Sub lbsortfields_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles LBSort.DoubleClick, _
   lbSortfields.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lbsortfields_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LBSort.DoubleClick, lbSortfields.DoubleClick
        Button15_Click_1(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.mcb_Changed Method

Private Sub mcb_Changed( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbunterschriftlinks.SelectedValueChanged, _
   mcbunterschriftrechts.SelectedValueChanged, _
   mcbTeam.SelectedValueChanged, _
   cb5.CheckedChanged, _
   cb4.CheckedChanged, _
   cb2.CheckedChanged, _
   cb1.CheckedChanged, _
   cb3.CheckedChanged, _
   cb3_1.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcb_Changed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbunterschriftlinks.SelectedValueChanged, mcbunterschriftrechts.SelectedValueChanged, mcbTeam.SelectedValueChanged, cb5.CheckedChanged, cb4.CheckedChanged, cb2.CheckedChanged, cb1.CheckedChanged, cb3.CheckedChanged, cb3_1.CheckedChanged
        If checkchanges Then
            changes = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.nodeswithdata Method

Private Function nodeswithdata( _
   ByVal node As Integer _
) As Boolean

Parameters

node
Required.

Source code

[Visual Basic]
    Private Function nodeswithdata(ByVal node As Integer) As Boolean
        If node <> 70 And node <> 90 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 6 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 70 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 15 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 90 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 4 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 72 Then
            If expandzv Then
                DivFnkt.Searchnode1(Me.TreeView1, 70, 99)
                If DivFnkt.found = True Then DivFnkt.FoundNode.Expand()
            End If
        End If
        'Rel 3.7 / BUD
        'If node = 92 Then
        '    If expanduvm Then
        '        DivFnkt.Searchnode1(Me.TreeView1, 90, 99)
        '        If DivFnkt.found = True Then DivFnkt.FoundNode.Expand()
        '    End If
        'End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.plausi_edoka Method

Public Function plausi_edoka( _
   ByVal p As edokadb.clsProfil _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_edoka(ByVal p As edokadb.clsProfil) As Boolean
        Dim ma As String
        Dim te As String
        Dim mb As String
        Dim nl As String
        Dim ko As String

        Dim d1 As Date
        Dim d2 As Date
        Dim d3 As Date
        Dim t1 As Integer
        Dim t2 As Integer
        Dim t3 As Integer

        If p.sDpartner.Value <> "" Then Return True
        ma = p.sVma.Value + p.sMma.Value + p.sEma.Value
        te = p.sVteam.Value + p.sMteam.Value + p.sEteam.Value
        mb = p.sMmb.Value + p.sVmb.Value + p.sEmb.Value
        nl = p.sVnl.Value + p.sMnl.Value + p.sEnl.Value
        ko = p.sVkost.Value + p.sMkost.Value + p.sEkost.Value

        If p.sDatum1.Value = "(heute)" Then d1 = Now Else d1 = p.sDatum1.Value
        If p.sDatum3.Value = "(heute)" Then d2 = Now Else d2 = p.sDatum3.Value
        If p.sDatum5.Value = "(heute)" Then d3 = Now Else d3 = p.sDatum5.Value

        If ma <> "" And te = "" And mb = "" And nl = "" Then
            If t1 <= 365 And t2 <= 365 And t3 <> 365 Then
                Return True
            Else
                MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If te <> "" Or ko <> "" Then
            If t1 <= 90 And t2 <= 90 And t3 <= 90 Then
                Return True
            Else
                MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If nl <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If mb <> "" Then
            If t1 <= 7 And t2 <= 7 And t3 <= 7 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If p.sDdokart.Value <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(96, MsgBoxStyle.Critical)
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.plausi_host Method

Public Function plausi_host( _
   ByVal p As edokadb.clsProfil _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_host(ByVal p As edokadb.clsProfil) As Boolean
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.reset_color Method

Private Sub reset_color( _
   ByVal node As Integer _
)

Parameters

node
Required.

Source code

[Visual Basic]
    Private Sub reset_color(ByVal node As Integer)
        Dim tn As TreeNode
        DivFnkt.Searchnode1(Me.TreeView1, node, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
            Try
                tn = Me.TreeView1.SelectedNode
                tn.ForeColor = System.Drawing.Color.Black
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.reset_dokart Method

Private Sub reset_dokart()

Source code

[Visual Basic]
    Private Sub reset_dokart()
        Dim tmptreeview As TreeView
        tmptreeview = Me.TVDokart
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        tmptreeview = Me.TVHostDok
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.set_tips Method

Private Sub set_tips()

Source code

[Visual Basic]
    Private Sub set_tips()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.showhidetv Method

Private Sub showhidetv( _
   ByVal showit As Boolean _
)

Parameters

showit
Required.

Source code

[Visual Basic]
    Private Sub showhidetv(ByVal showit As Boolean)
        Me.TreeView2.Top = Me.TreeView1.Top
        Me.TreeView2.Left = Me.TreeView1.Left
        Me.TreeView2.Height = Me.TreeView1.Height
        Me.TreeView2.Width = Me.TreeView1.Width
        If showit Then
            Me.TreeView2.Visible = True
            Me.TreeView1.Visible = False
        Else
            Me.TreeView2.Visible = False
            Me.TreeView1.Visible = True
            Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtdatum1_TextChanged Method

Private Sub txtdatum1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles txtdatum1.TextChanged, _
   txtdatum2.TextChanged, _
   txtdatum3.TextChanged, _
   txtdatum4.TextChanged, _
   txtdatum5.TextChanged, _
   txtdatum6.TextChanged, _
   HostDatum1.TextChanged, _
   HostDatum2.TextChanged, _
   txtdatum1uvm.TextChanged, _
   txtdatum2uvm.TextChanged, _
   txtdatum3uvm.TextChanged, _
   txtdatum4uvm.TextChanged, _
   txtdatum1zv.TextChanged, _
   txtdatum2zv.TextChanged, _
   txtdatum3zv.TextChanged, _
   txtdatum4zv.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtdatum1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtdatum1.TextChanged, txtdatum2.TextChanged, _
    txtdatum3.TextChanged, txtdatum4.TextChanged, txtdatum5.TextChanged, txtdatum6.TextChanged, HostDatum1.TextChanged, HostDatum2.TextChanged, _
    txtdatum1uvm.TextChanged, txtdatum2uvm.TextChanged, txtdatum3uvm.TextChanged, txtdatum4uvm.TextChanged, txtdatum1zv.TextChanged, txtdatum2zv.TextChanged, txtdatum3zv.TextChanged, txtdatum4zv.TextChanged
        Dim tb As TextBox
        Dim xt As DateTime
        Dim i As Integer
        tb = sender

        Select Case tb.Name
            Case "txtdatum1"
                If Me.txtdatum1.Text = "" Then
                    Me.datumtext1.Text = "(heute)-999999"
                    Me.cbrollend1.Checked = False
                    Me.cbrollend1.Enabled = False
                Else
                    If Format(Me.DateTimePicker1.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum1.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend1.Enabled = True
                    If Me.cbrollend1.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum1.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext1.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext1.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext1.Text = Me.txtdatum1.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext1.Text, "heute") > 0 Then Me.cbrollend1.Checked = True
                End If
            Case "txtdatum2"
                If Me.txtdatum2.Text = "" Then
                    Me.datumtext2.Text = "(heute)"
                    Me.cbrollend2.Checked = True
                    Me.cbrollend2.Enabled = False
                    '    Me.txtdatum2.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker2.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum2.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend2.Enabled = True
                    If Me.cbrollend2.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum2.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext2.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext2.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext2.Text = Me.txtdatum2.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext2.Text, "heute") > 0 Then Me.cbrollend2.Checked = True
                End If
            Case "txtdatum3"
                If Me.txtdatum3.Text = "" Then
                    Me.datumtext3.Text = "(heute)-999999"
                    Me.cbrollend3.Checked = False
                    Me.cbrollend3.Enabled = False
                Else
                    If Format(Me.DateTimePicker3.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum3.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend3.Enabled = True
                    If Me.cbrollend3.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum3.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext3.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext3.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext3.Text = Me.txtdatum3.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext3.Text, "heute") > 0 Then Me.cbrollend3.Checked = True
                End If
            Case "txtdatum4"
                If Me.txtdatum4.Text = "" Then
                    Me.datumtext4.Text = "(heute)"
                    Me.cbrollend4.Checked = True
                    Me.cbrollend4.Enabled = False
                    '   Me.txtdatum4.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker4.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum4.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend4.Enabled = True
                    If Me.cbrollend4.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum4.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext4.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext4.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext4.Text = Me.txtdatum4.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext4.Text, "heute") > 0 Then Me.cbrollend4.Checked = True
                End If
            Case "txtdatum5"
                If Me.txtdatum5.Text = "" Then
                    Me.datumtext5.Text = "(heute)-999999"
                    Me.cbrollend5.Checked = False
                    Me.cbrollend5.Enabled = False
                Else
                    If Format(Me.DateTimePicker5.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum5.Text = CutDate(Now.ToString)
                    End If

                    Me.cbrollend5.Enabled = True
                    If Me.cbrollend5.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum5.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext5.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext5.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext5.Text = Me.txtdatum5.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext5.Text, "heute") > 0 Then Me.cbrollend5.Checked = True
                End If
            Case "txtdatum6"
                If Me.txtdatum6.Text = "" Then
                    Me.datumtext6.Text = "(heute)"
                    Me.cbrollend6.Checked = True
                    Me.cbrollend6.Enabled = False
                    '  Me.txtdatum6.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker6.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum6.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend6.Enabled = True
                    If Me.cbrollend6.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum6.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext6.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext6.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext6.Text = Me.txtdatum6.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext6.Text, "heute") > 0 Then Me.cbrollend6.Checked = True
                End If

            Case "HostDatum1"
                If Me.HostDatum1.Text = "" Then
                    Me.DatumHostText1.Text = "(heute)-999999"
                    Me.cbrollend8.Checked = False
                    Me.cbrollend8.Enabled = False
                Else
                    If Format(Me.DateTimePicker9.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.HostDatum1.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend8.Enabled = True
                    If Me.cbrollend8.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.HostDatum1.Text, DateTime))
                        If i = 0 Then
                            Me.DatumHostText1.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.DatumHostText1.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.DatumHostText1.Text = Me.HostDatum1.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.DatumHostText1.Text, "heute") > 0 Then Me.cbrollend8.Checked = True
                End If
            Case "HostDatum2"
                If Me.HostDatum2.Text = "" Then
                    Me.DatumHostText2.Text = "(heute)"
                    Me.cbrollend9.Checked = True
                    Me.cbrollend9.Enabled = False
                    ' Me.txtdatum6.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker8.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.HostDatum2.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend9.Enabled = True
                    If Me.cbrollend9.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.HostDatum2.Text, DateTime))
                        If i = 0 Then
                            Me.DatumHostText2.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.DatumHostText2.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.DatumHostText2.Text = Me.HostDatum2.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.DatumHostText2.Text, "heute") > 0 Then Me.cbrollend9.Checked = True
                End If
                'Rel 3.7 / BUD
                'Case "txtdatum1uvm"
                '    If Me.txtdatum1uvm.Text = "" Then
                '        Me.textdatum1uvm.Text = "(heute)-999999"
                '        Me.cbuvmrollend1.Checked = False
                '        Me.cbuvmrollend1.Enabled = False
                '    Else
                '        If Format(Me.DateTimePicker18.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                '            Me.txtdatum1uvm.Text = CutDate(Now.ToString)
                '        End If
                '        Me.cbuvmrollend1.Enabled = True
                '        If Me.cbuvmrollend1.Checked Then
                '            i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum1uvm.Text, DateTime))
                '            If i = 0 Then
                '                Me.textdatum1uvm.Text = "(heute)-0"
                '            Else
                '                If i < 0 Then i = i * -1
                '                Me.textdatum1uvm.Text = "(heute)-" + Trim(Str(i))
                '            End If
                '        Else
                '            Me.textdatum1uvm.Text = Me.txtdatum1uvm.Text
                '        End If
                '        If Microsoft.VisualBasic.InStr(Me.textdatum1uvm.Text, "heute") > 0 Then Me.cbuvmrollend1.Checked = True
                '    End If
                'Case "txtdatum2uvm"
                '    If Me.txtdatum2uvm.Text = "" Then
                '        Me.textdatum2uvm.Text = "(heute)"
                '        Me.cbuvmrollend2.Checked = False
                '        Me.cbuvmrollend2.Enabled = False
                '    Else
                '        If Format(Me.DateTimePicker19.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                '            Me.txtdatum2uvm.Text = CutDate(Now.ToString)
                '        End If
                '        Me.cbuvmrollend2.Enabled = True
                '        If Me.cbuvmrollend2.Checked Then
                '            i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum2uvm.Text, DateTime))
                '            If i = 0 Then
                '                Me.textdatum2uvm.Text = "(heute)-0"
                '            Else
                '                If i < 0 Then i = i * -1
                '                Me.textdatum2uvm.Text = "(heute)-" + Trim(Str(i))
                '            End If
                '        Else
                '            Me.textdatum2uvm.Text = Me.txtdatum2uvm.Text
                '        End If
                '        If Microsoft.VisualBasic.InStr(Me.textdatum2uvm.Text, "heute") > 0 Then Me.cbuvmrollend2.Checked = True
                '    End If
                'Case "txtdatum3uvm"
                '    If Me.txtdatum3uvm.Text = "" Then
                '        Me.textdatum3uvm.Text = "(heute)-999999"
                '        Me.cbuvmrollend3.Checked = False
                '        Me.cbuvmrollend3.Enabled = False
                '    Else
                '        If Format(Me.DateTimePicker17.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                '            Me.txtdatum3uvm.Text = CutDate(Now.ToString)
                '        End If
                '        Me.cbuvmrollend3.Enabled = True
                '        If Me.cbuvmrollend3.Checked Then
                '            i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum3uvm.Text, DateTime))
                '            If i = 0 Then
                '                Me.textdatum3uvm.Text = "(heute)-0"
                '            Else
                '                If i < 0 Then i = i * -1
                '                Me.textdatum3uvm.Text = "(heute)-" + Trim(Str(i))
                '            End If
                '        Else
                '            Me.textdatum3uvm.Text = Me.txtdatum3uvm.Text
                '        End If
                '        If Microsoft.VisualBasic.InStr(Me.textdatum3uvm.Text, "heute") > 0 Then Me.cbuvmrollend3.Checked = True
                '    End If
                'Case "txtdatum4uvm"
                '    If Me.txtdatum4uvm.Text = "" Then
                '        Me.textdatum4uvm.Text = "(heute)"
                '        Me.cbuvmrollend4.Checked = False
                '        Me.cbuvmrollend4.Enabled = False
                '    Else
                '        If Format(Me.DateTimePicker20.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                '            Me.txtdatum4uvm.Text = CutDate(Now.ToString)
                '        End If
                '        Me.cbuvmrollend4.Enabled = True
                '        If Me.cbuvmrollend4.Checked Then
                '            i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum4uvm.Text, DateTime))
                '            If i = 0 Then
                '                Me.textdatum4uvm.Text = "(heute)-0"
                '            Else
                '                If i < 0 Then i = i * -1
                '                Me.textdatum4uvm.Text = "(heute)-" + Trim(Str(i))
                '            End If
                '        Else
                '            Me.textdatum4uvm.Text = Me.txtdatum4uvm.Text
                '        End If
                '        If Microsoft.VisualBasic.InStr(Me.textdatum4uvm.Text, "heute") > 0 Then Me.cbuvmrollend4.Checked = True
                '    End If
            Case "txtdatum1zv"
                If Me.txtdatum1zv.Text = "" Then
                    Me.textdatum1zv.Text = "(heute)-999999"
                    Me.cbzvrollend1.Checked = False
                    Me.cbzvrollend1.Enabled = False
                Else
                    If Format(Me.DateTimePicker14.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum1zv.Text = CutDate(Now.ToString)
                    End If
                    Me.cbzvrollend1.Enabled = True
                    If Me.cbzvrollend1.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum1zv.Text, DateTime))
                        If i = 0 Then
                            Me.textdatum1zv.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.textdatum1zv.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.textdatum1zv.Text = Me.txtdatum1zv.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.textdatum1zv.Text, "heute") > 0 Then Me.cbzvrollend1.Checked = True
                End If
            Case "txtdatum2zv"
                If Me.txtdatum2zv.Text = "" Then
                    Me.textdatum2zv.Text = "(heute)"
                    Me.cbzvrollend2.Checked = False
                    Me.cbzvrollend2.Enabled = False
                Else
                    If Format(Me.DateTimePicker15.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum2zv.Text = CutDate(Now.ToString)
                    End If
                    Me.cbzvrollend2.Enabled = True
                    If Me.cbzvrollend2.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum2zv.Text, DateTime))
                        If i = 0 Then
                            Me.textdatum2zv.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.textdatum2zv.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.textdatum2zv.Text = Me.txtdatum2zv.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.textdatum2zv.Text, "heute") > 0 Then Me.cbzvrollend2.Checked = True
                End If
            Case "txtdatum3zv"
                If Me.txtdatum3zv.Text = "" Then
                    Me.textdatum3zv.Text = "(heute)-999999"
                    Me.cbzvrollend3.Checked = False
                    Me.cbzvrollend3.Enabled = False
                Else
                    If Format(Me.DateTimePicker13.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum3zv.Text = CutDate(Now.ToString)
                    End If
                    Me.cbuvmrollend3.Enabled = True
                    If Me.cbzvrollend3.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum3zv.Text, DateTime))
                        If i = 0 Then
                            Me.textdatum3zv.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.textdatum3zv.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.textdatum3zv.Text = Me.txtdatum3zv.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.textdatum3zv.Text, "heute") > 0 Then Me.cbzvrollend3.Checked = True
                End If
            Case "txtdatum4zv"
                If Me.txtdatum4zv.Text = "" Then
                    Me.textdatum4zv.Text = "(heute)"
                    Me.cbzvrollend4.Checked = False
                    Me.cbzvrollend4.Enabled = False
                Else
                    If Format(Me.DateTimePicker16.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum4zv.Text = CutDate(Now.ToString)
                    End If
                    Me.cbzvrollend4.Enabled = True
                    If Me.cbzvrollend4.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum4zv.Text, DateTime))
                        If i = 0 Then
                            Me.textdatum4zv.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.textdatum4zv.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.textdatum4zv.Text = Me.txtdatum4zv.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.textdatum4zv.Text, "heute") > 0 Then Me.cbzvrollend4.Checked = True
                End If
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtuvmauftrag_KeyDown Method

Private Sub txtuvmauftrag_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox3.KeyDown, _
   TextBox2.KeyDown, _
   txtuvmauftragnr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtuvmauftrag_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox3.KeyDown, TextBox2.KeyDown, txtuvmauftragnr.KeyDown
        If e.KeyCode = Keys.Return Then Button29_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvauftraggeber_KeyDown Method

Private Sub txtzvauftraggeber_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvauftraggeber.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvauftraggeber_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvauftraggeber.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvauftragsnr_KeyDown Method

Private Sub txtzvauftragsnr_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvauftragsnr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvauftragsnr_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvauftragsnr.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvbeguenstigter_KeyDown Method

Private Sub txtzvbeguenstigter_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvbeguenstigter.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvbeguenstigter_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvbeguenstigter.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvbetrag_KeyDown Method

Private Sub txtzvbetrag_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvbetrag.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvbetrag_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvbetrag.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvclearingnr_KeyDown Method

Private Sub txtzvclearingnr_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvclearingnr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvclearingnr_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvclearingnr.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzviso_KeyDown Method

Private Sub txtzviso_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzviso.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzviso_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzviso.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvpcnr_KeyDown Method

Private Sub txtzvpcnr_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvpcnr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvpcnr_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvpcnr.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvpostennr_KeyDown Method

Private Sub txtzvpostennr_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvpostennr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvpostennr_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvpostennr.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvreferenznr_KeyDown Method

Private Sub txtzvreferenznr_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvreferenznr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvreferenznr_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvreferenznr.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvswift_KeyDown Method

Private Sub txtzvswift_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvswift.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvswift_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvswift.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvverarbeitungsart_KeyDown Method

Private Sub txtzvverarbeitungsart_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvverarbeitungsart.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvverarbeitungsart_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvverarbeitungsart.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil.txtzvzahlungsart_KeyDown Method

Private Sub txtzvzahlungsart_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtzvzahlungsart.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtzvzahlungsart_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtzvzahlungsart.KeyDown
        If e.KeyCode = Keys.Return Then btnzvauftragsnr_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfil Fields

frmProfil overview

Fields

field ActiveList
field BtnHelp
field Button1
field Button10
field Button11
field Button12
field Button13
field Button14
field Button15
field Button16
field Button17
field Button18
field Button19
field Button2
field Button20
field Button21
field Button22
field Button23
field Button24
field Button25
field Button26
field Button27
field Button28
field Button29
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field C1TrueDBGrid1
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox3
field CheckBox4
field CheckBox5
field ColorDialog1
field ComboBox10
field ComboBox6
field ComboBox9
field ContextMenu1
field ContextMenu2
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker13
field DateTimePicker14
field DateTimePicker15
field DateTimePicker16
field DateTimePicker17
field DateTimePicker18
field DateTimePicker19
field DateTimePicker2
field DateTimePicker20
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field DatumHostText1
field DatumHostText2
field FirstNodeWithData
field GroupBox1
field GroupBox10
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox2
field GroupBox4
field GroupBox5
field GroupBox6
field GroupBox9
field Groupbox3
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field LBSelectHost
field LBSort
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label40
field Label41
field Label42
field Label43
field Label44
field Label45
field Label46
field Label47
field Label48
field Label49
field Label5
field Label50
field Label51
field Label52
field Label53
field Label54
field Label55
field Label56
field Label57
field Label58
field Label59
field Label6
field Label60
field Label61
field Label62
field Label63
field Label64
field Label65
field Label66
field Label7
field Label8
field Label9
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PartnerList
field Partnerdialog
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPage4
field TabPage5
field TextBox1
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field TreeView2
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field btnini
field btnzvauftraggeber
field btnzvauftragsnr
field btnzvbeguenstiger
field btnzvbetrag
field btnzvclearing
field btnzviso
field btnzvpcnr
field btnzvposten
field btnzvreferenz
field btnzvswift
field btnzvverarbeitungsart
field btnzvzahlungsart
field cb1
field cb2
field cb3
field cb3_1
field cb4
field cb5
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbd2
field cbd4
field cbd6
field cbmavip
field cbrollend1
field cbrollend2
field cbrollend3
field cbrollend4
field cbrollend5
field cbrollend6
field cbrollend8
field cbrollend9
field cbteam
field cbuvmrollend1
field cbuvmrollend2
field cbuvmrollend3
field cbuvmrollend4
field cbzvrollend1
field cbzvrollend2
field cbzvrollend3
field cbzvrollend4
field changes
field checkchanges
field cinklalt
field cinklaltversant
field colbtn1
field colbtn2
field colbtn3
field colbtn4
field colbtn5
field colbtn6
field colconv
field components
field ctmenu1
field datumtext1
field datumtext2
field datumtext3
field datumtext4
field datumtext5
field datumtext6
field dokumentart
field expandzv
field first
field hostinklmavip
field i
field ifirst
field lbSortfields
field lbentry
field lblhostdatum2
field lblhostdatum3
field lblhostdatum31
field lbselect
field li
field m_profile_geaendert
field m_profilnr
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field oninit
field partner
field pnlhostdiv
field pnluvm
field pnlzv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tdtzv
field textdatum1uvm
field textdatum1zv
field textdatum2uvm
field textdatum2zv
field textdatum3uvm
field textdatum3zv
field textdatum4uvm
field textdatum4zv
field tko
field tku
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum1uvm
field txtdatum1zv
field txtdatum2
field txtdatum2uvm
field txtdatum2zv
field txtdatum3
field txtdatum3uvm
field txtdatum3zv
field txtdatum4
field txtdatum4uvm
field txtdatum4zv
field txtdatum5
field txtdatum6
field txtuvmauftragnr
field txtzvauftraggeber
field txtzvauftragsnr
field txtzvbeguenstigter
field txtzvbetrag
field txtzvclearingnr
field txtzviso
field txtzvpcnr
field txtzvpostennr
field txtzvreferenznr
field txtzvswift
field txtzvverarbeitungsart
field txtzvzahlungsart

See Also

frmProfil Class


ActiveList Variable

Dim ActiveList As Integer

Source code

[Visual Basic]
    Dim ActiveList As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button10 Variable

Friend WithEvents Button10 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button10 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button11 Variable

Friend WithEvents Button11 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button11 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button12 Variable

Friend WithEvents Button12 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button12 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button13 Variable

Friend WithEvents Button13 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button13 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button14 Variable

Friend WithEvents Button14 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button14 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button15 Variable

Friend WithEvents Button15 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button15 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button16 Variable

Friend WithEvents Button16 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button16 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button17 Variable

Friend WithEvents Button17 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button17 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button18 Variable

Friend WithEvents Button18 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button18 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button19 Variable

Friend WithEvents Button19 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button19 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button20 Variable

Friend WithEvents Button20 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button20 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button21 Variable

Friend WithEvents Button21 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button21 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button22 Variable

Friend WithEvents Button22 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button22 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button23 Variable

Friend WithEvents Button23 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button23 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button24 Variable

Friend WithEvents Button24 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button24 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button25 Variable

Friend WithEvents Button25 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button25 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button26 Variable

Friend WithEvents Button26 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button26 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button27 Variable

Friend WithEvents Button27 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button27 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button28 Variable

Friend WithEvents Button28 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button28 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button29 Variable

Friend WithEvents Button29 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button29 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Button9 Variable

Friend WithEvents Button9 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button9 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CTMenuErsteller Variable

Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CTMenuMutierer Variable

Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CTMenuVerantwortlicher Variable

Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CheckBox3 Variable

Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CheckBox4 Variable

Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


CheckBox5 Variable

Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ColorDialog1 Variable

Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Source code

[Visual Basic]
    Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ComboBox10 Variable

Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ComboBox6 Variable

Friend WithEvents ComboBox6 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox6 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ComboBox9 Variable

Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker10 Variable

Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker11 Variable

Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker12 Variable

Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker13 Variable

Friend WithEvents DateTimePicker13 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker13 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker14 Variable

Friend WithEvents DateTimePicker14 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker14 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker15 Variable

Friend WithEvents DateTimePicker15 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker15 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker16 Variable

Friend WithEvents DateTimePicker16 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker16 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker17 Variable

Friend WithEvents DateTimePicker17 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker17 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker18 Variable

Friend WithEvents DateTimePicker18 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker18 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker19 Variable

Friend WithEvents DateTimePicker19 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker19 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker20 Variable

Friend WithEvents DateTimePicker20 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker20 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker5 Variable

Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker6 Variable

Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker7 Variable

Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker8 Variable

Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DateTimePicker9 Variable

Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DatumHostText1 Variable

Friend WithEvents DatumHostText1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents DatumHostText1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


DatumHostText2 Variable

Friend WithEvents DatumHostText2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents DatumHostText2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


FirstNodeWithData Variable

Dim FirstNodeWithData As TreeNode

Source code

[Visual Basic]
    Dim FirstNodeWithData As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox13 Variable

Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox14 Variable

Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Groupbox3 Variable

Friend WithEvents Groupbox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents Groupbox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


HostDatum1 Variable

Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


HostDatum2 Variable

Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


HostDatum3 Variable

Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


HostTag3 Variable

Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


LBSelectHost Variable

Friend WithEvents LBSelectHost As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSelectHost As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


LBSort Variable

Friend WithEvents LBSort As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSort As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label35 Variable

Friend WithEvents Label35 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label35 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label36 Variable

Friend WithEvents Label36 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label36 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label37 Variable

Friend WithEvents Label37 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label37 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label38 Variable

Friend WithEvents Label38 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label38 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label39 Variable

Friend WithEvents Label39 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label39 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label40 Variable

Friend WithEvents Label40 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label40 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label41 Variable

Friend WithEvents Label41 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label41 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label42 Variable

Friend WithEvents Label42 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label42 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label43 Variable

Friend WithEvents Label43 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label43 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label44 Variable

Friend WithEvents Label44 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label44 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label45 Variable

Friend WithEvents Label45 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label45 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label46 Variable

Friend WithEvents Label46 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label46 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label47 Variable

Friend WithEvents Label47 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label47 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label48 Variable

Friend WithEvents Label48 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label48 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label49 Variable

Friend WithEvents Label49 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label49 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label50 Variable

Friend WithEvents Label50 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label50 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label51 Variable

Friend WithEvents Label51 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label51 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label52 Variable

Friend WithEvents Label52 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label52 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label53 Variable

Friend WithEvents Label53 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label53 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label54 Variable

Friend WithEvents Label54 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label54 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label55 Variable

Friend WithEvents Label55 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label55 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label56 Variable

Friend WithEvents Label56 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label56 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label57 Variable

Friend WithEvents Label57 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label57 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label58 Variable

Friend WithEvents Label58 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label58 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label59 Variable

Friend WithEvents Label59 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label59 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label60 Variable

Friend WithEvents Label60 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label60 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label61 Variable

Friend WithEvents Label61 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label61 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label62 Variable

Friend WithEvents Label62 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label62 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label63 Variable

Friend WithEvents Label63 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label63 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label64 Variable

Friend WithEvents Label64 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label64 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label65 Variable

Friend WithEvents Label65 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label65 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label66 Variable

Friend WithEvents Label66 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label66 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MnuDel Variable

Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MnuDeleteDokumentart Variable

Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MnuListe Variable

Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


MnuSelectDokumentart Variable

Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


NodeText Variable

Dim NodeText As String

Source code

[Visual Basic]
    Dim NodeText As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


PartnerList Variable

Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Partnerdialog Variable

Dim WithEvents Partnerdialog As New FrmPartnersuche()

Source code

[Visual Basic]
    Dim WithEvents Partnerdialog As New FrmPartnersuche()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


PnlDokumentDaten Variable

Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


PnlDokumentart Variable

Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


PnlPartner Variable

Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Profil_Ungueltig Variable

Dim Profil_Ungueltig As Boolean

Source code

[Visual Basic]
    Dim Profil_Ungueltig As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Profile Variable

Friend WithEvents Profile As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents Profile As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Profname Variable

Dim Profname As String

Source code

[Visual Basic]
    Dim Profname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TVDokart Variable

Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TVHostDok Variable

Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabPage3 Variable

Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TabPage5 Variable

Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage5 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


TreeView2 Variable

Friend WithEvents TreeView2 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView2 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnOpen Variable

Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnPartnersuche Variable

Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnini Variable

Friend WithEvents btnini As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnini As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvauftraggeber Variable

Friend WithEvents btnzvauftraggeber As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvauftraggeber As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvauftragsnr Variable

Friend WithEvents btnzvauftragsnr As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvauftragsnr As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvbeguenstiger Variable

Friend WithEvents btnzvbeguenstiger As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvbeguenstiger As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvbetrag Variable

Friend WithEvents btnzvbetrag As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvbetrag As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvclearing Variable

Friend WithEvents btnzvclearing As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvclearing As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzviso Variable

Friend WithEvents btnzviso As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzviso As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvpcnr Variable

Friend WithEvents btnzvpcnr As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvpcnr As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvposten Variable

Friend WithEvents btnzvposten As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvposten As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvreferenz Variable

Friend WithEvents btnzvreferenz As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvreferenz As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvswift Variable

Friend WithEvents btnzvswift As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvswift As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvverarbeitungsart Variable

Friend WithEvents btnzvverarbeitungsart As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvverarbeitungsart As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


btnzvzahlungsart Variable

Friend WithEvents btnzvzahlungsart As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnzvzahlungsart As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb1 Variable

Friend WithEvents cb1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb2 Variable

Friend WithEvents cb2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb3 Variable

Friend WithEvents cb3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb3_1 Variable

Friend WithEvents cb3_1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb3_1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb4 Variable

Friend WithEvents cb4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cb5 Variable

Friend WithEvents cb5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbd2 Variable

Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbd4 Variable

Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbd6 Variable

Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbmavip Variable

Friend WithEvents cbmavip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbmavip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend1 Variable

Friend WithEvents cbrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend2 Variable

Friend WithEvents cbrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend3 Variable

Friend WithEvents cbrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend4 Variable

Friend WithEvents cbrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend5 Variable

Friend WithEvents cbrollend5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend6 Variable

Friend WithEvents cbrollend6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend8 Variable

Friend WithEvents cbrollend8 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend8 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbrollend9 Variable

Friend WithEvents cbrollend9 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend9 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbuvmrollend1 Variable

Friend WithEvents cbuvmrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbuvmrollend2 Variable

Friend WithEvents cbuvmrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbuvmrollend3 Variable

Friend WithEvents cbuvmrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbuvmrollend4 Variable

Friend WithEvents cbuvmrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbzvrollend1 Variable

Friend WithEvents cbzvrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbzvrollend2 Variable

Friend WithEvents cbzvrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbzvrollend3 Variable

Friend WithEvents cbzvrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cbzvrollend4 Variable

Friend WithEvents cbzvrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


changes Variable

Dim changes As Boolean

Source code

[Visual Basic]
    Dim changes As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


checkchanges Variable

Dim checkchanges As Boolean

Source code

[Visual Basic]
    Dim checkchanges As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cinklalt Variable

Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


cinklaltversant Variable

Friend WithEvents cinklaltversant As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cinklaltversant As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn1 Variable

Friend WithEvents colbtn1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn2 Variable

Friend WithEvents colbtn2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn3 Variable

Friend WithEvents colbtn3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn4 Variable

Friend WithEvents colbtn4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn5 Variable

Friend WithEvents colbtn5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colbtn6 Variable

Friend WithEvents colbtn6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


colconv Variable

Dim colconv As New ColorConverter()

Source code

[Visual Basic]
    Dim colconv As New ColorConverter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ctmenu1 Variable

Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext1 Variable

Friend WithEvents datumtext1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext2 Variable

Friend WithEvents datumtext2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext3 Variable

Friend WithEvents datumtext3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext4 Variable

Friend WithEvents datumtext4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext5 Variable

Friend WithEvents datumtext5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


datumtext6 Variable

Friend WithEvents datumtext6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


expandzv Variable

Dim expandzv As Boolean = False

Source code

[Visual Basic]
    Dim expandzv As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


first Variable

Dim first As Boolean = True

Source code

[Visual Basic]
    Dim first As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


hostinklmavip Variable

Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


ifirst Variable

Dim ifirst As Integer = 0

Source code

[Visual Basic]
    Dim ifirst As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lbSortfields Variable

Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lbentry Variable

Dim lbentry( _
   1 _
) As Object

Source code

[Visual Basic]
    Dim lbentry(1) As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lblhostdatum2 Variable

Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lblhostdatum3 Variable

Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lblhostdatum31 Variable

Friend WithEvents lblhostdatum31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


lbselect Variable

Friend WithEvents lbselect As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents lbselect As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


li Variable

Dim li As ListViewItem

Source code

[Visual Basic]
    Dim li As ListViewItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


m_profile_geaendert Variable

Dim m_profile_geaendert As Boolean

Source code

[Visual Basic]
    Dim m_profile_geaendert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


mcbTeam Variable

Dim WithEvents mcbTeam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbTeam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


mypartner Variable

Dim mypartner As New edokadb.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokadb.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


oninit Variable

Dim oninit As Boolean = False

Source code

[Visual Basic]
    Dim oninit As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


partner Variable

Dim partner As DataTable

Source code

[Visual Basic]
    Dim partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


pnlhostdiv Variable

Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


pnluvm Variable

Friend WithEvents pnluvm As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnluvm As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


pnlzv Variable

Friend WithEvents pnlzv As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzv As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


savenode Variable

Dim savenode As TreeNode

Source code

[Visual Basic]
    Dim savenode As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tda Variable

Dim tda As DataTable

Source code

[Visual Basic]
    Dim tda As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tdh Variable

Dim tdh As DataTable

Source code

[Visual Basic]
    Dim tdh As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tdt Variable

Dim tdt As DataTable

Source code

[Visual Basic]
    Dim tdt As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tdtzv Variable

Dim tdtzv As DataTable

Source code

[Visual Basic]
    Dim tdtzv As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum1uvm Variable

Friend WithEvents textdatum1uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum1uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum1zv Variable

Friend WithEvents textdatum1zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum1zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum2uvm Variable

Friend WithEvents textdatum2uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum2uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum2zv Variable

Friend WithEvents textdatum2zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum2zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum3uvm Variable

Friend WithEvents textdatum3uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum3uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum3zv Variable

Friend WithEvents textdatum3zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum3zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum4uvm Variable

Friend WithEvents textdatum4uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum4uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


textdatum4zv Variable

Friend WithEvents textdatum4zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum4zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tko Variable

Dim tko As DataTable

Source code

[Visual Basic]
    Dim tko As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tku Variable

Dim tku As DataTable

Source code

[Visual Basic]
    Dim tku As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tmb Variable

Dim tmb As DataTable

Source code

[Visual Basic]
    Dim tmb As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tnl Variable

Dim tnl As DataTable

Source code

[Visual Basic]
    Dim tnl As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tpe Variable

Dim tpe As DataTable

Source code

[Visual Basic]
    Dim tpe As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tst Variable

Dim tst As DataTable

Source code

[Visual Basic]
    Dim tst As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


tte Variable

Dim tte As DataTable

Source code

[Visual Basic]
    Dim tte As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum1 Variable

Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum1uvm Variable

Friend WithEvents txtdatum1uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum1zv Variable

Friend WithEvents txtdatum1zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum2 Variable

Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum2uvm Variable

Friend WithEvents txtdatum2uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum2zv Variable

Friend WithEvents txtdatum2zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum3 Variable

Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum3uvm Variable

Friend WithEvents txtdatum3uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum3zv Variable

Friend WithEvents txtdatum3zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum4 Variable

Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum4uvm Variable

Friend WithEvents txtdatum4uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum4zv Variable

Friend WithEvents txtdatum4zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum5 Variable

Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtdatum6 Variable

Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtuvmauftragnr Variable

Friend WithEvents txtuvmauftragnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtuvmauftragnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvauftraggeber Variable

Friend WithEvents txtzvauftraggeber As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvauftraggeber As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvauftragsnr Variable

Friend WithEvents txtzvauftragsnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvauftragsnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvbeguenstigter Variable

Friend WithEvents txtzvbeguenstigter As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvbeguenstigter As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvbetrag Variable

Friend WithEvents txtzvbetrag As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvbetrag As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvclearingnr Variable

Friend WithEvents txtzvclearingnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvclearingnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzviso Variable

Friend WithEvents txtzviso As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzviso As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvpcnr Variable

Friend WithEvents txtzvpcnr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvpcnr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvpostennr Variable

Friend WithEvents txtzvpostennr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvpostennr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvreferenznr Variable

Friend WithEvents txtzvreferenznr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvreferenznr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvswift Variable

Friend WithEvents txtzvswift As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvswift As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvverarbeitungsart Variable

Friend WithEvents txtzvverarbeitungsart As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvverarbeitungsart As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


txtzvzahlungsart Variable

Friend WithEvents txtzvzahlungsart As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzvzahlungsart As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfil


frmProfilDokAuswertung Class

For a list of all members of this type, see frmProfilDokAuswertung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmProfilDokAuswertung

Public Class frmProfilDokAuswertung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmProfilDokAuswertung Members


frmProfilDokAuswertung Members

frmProfilDokAuswertung overview

Constructors

constructor frmProfilDokAuswertung Constructor

Properties

property Datenherkunft
property DislpayResult
property NavigationResult
property ProfilNr
property Profile_Geaendert

Methods

method Activate_Details
method Button1_Click
method Button1_Click_1
method Button2_Click_1
method Button3_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method CutDate
method DateTimePicker1_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method InitializeComponent
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem20_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method Profil_Colors
method Profile_AfterSelect
method Profile_MouseDown
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_DoubleClick
method TVDokart_MouseDown
method TextBox1_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method Treeview1_MouseDown
method ValueList
method btnPartnersuche_Click
method cbtag1_TextChanged
method cbtag2_TextChanged
method cbtag3_TextChanged
method check_changes
method frmProfilDokAuswertung_Load
method frmProfil_Closing
method hosttag1_TextChanged
method hosttag2_TextChanged
method hosttag3_TextChanged
method init_treeview1
method mcb_Changed
method plausi_edoka
method plausi_host
method pnlhostdiv_Paint

Fields

field ActiveList
field Button1
field Button2
field Button3
field Button4
field Button6
field Button7
field Button8
field C1TrueDBGrid1
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox3
field CheckBox4
field CheckBox5
field ColorDialog1
field ComboBox10
field ComboBox9
field ContextMenu1
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field FirstNodeWithData
field GroupBox10
field GroupBox3
field GroupBox6
field GroupBox7
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag1
field HostTag2
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label2
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem15
field MenuItem16
field MenuItem2
field MenuItem20
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel2
field Panel3
field PartnerList
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabPage1
field TextBox1
field TextBox2
field TextBox3
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field cbd2
field cbd4
field cbd6
field cbmavip
field cbtag1
field cbtag2
field cbtag3
field changes
field checkchanges
field cinklalt
field colconv
field components
field ctmenu1
field dokumentart
field first
field hostinklmavip
field i
field lbentry
field lbldatum1
field lbldatum2
field lbldatum3
field lblhostdatum1
field lblhostdatum2
field lblhostdatum3
field li
field m_profile_geaendert
field m_profilnr
field m_sDatenherkunft
field m_sDislpayResult
field m_sNavigationResult
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field partner
field pnlhostdiv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tko
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum2
field txtdatum3
field txtdatum4
field txtdatum5
field txtdatum6

See Also

frmProfilDokAuswertung Class


frmProfilDokAuswertung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung Properties

frmProfilDokAuswertung overview

Properties

property Datenherkunft
property DislpayResult
property NavigationResult
property ProfilNr
property Profile_Geaendert

See Also

frmProfilDokAuswertung Class


frmProfilDokAuswertung.Datenherkunft Property

Property Datenherkunft() As String

Source code

[Visual Basic]
    Property Datenherkunft() As String
        ' Werte dienen für die Anziege
        Get
            Return m_sDatenherkunft
        End Get
        Set(ByVal Value As String)
            m_sDatenherkunft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DislpayResult Property

Property DislpayResult() As String

Source code

[Visual Basic]
    Property DislpayResult() As String
        Get
            Return m_sDislpayResult
        End Get
        Set(ByVal Value As String)
            m_sDislpayResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.NavigationResult Property

Property NavigationResult() As String

Source code

[Visual Basic]
    Property NavigationResult() As String
        ' Werte dienen für die Steuerung
        Get
            Return m_sNavigationResult
        End Get
        Set(ByVal Value As String)
            m_sNavigationResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.ProfilNr Property

Property ProfilNr() As Integer

Source code

[Visual Basic]
    Property ProfilNr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Profile_Geaendert Property

Property Profile_Geaendert() As Boolean

Source code

[Visual Basic]
    Property Profile_Geaendert() As Boolean
        Get
            Return m_profile_geaendert
        End Get
        Set(ByVal Value As Boolean)
            m_profile_geaendert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung Methods

frmProfilDokAuswertung overview

Methods

method Activate_Details
method Button1_Click
method Button1_Click_1
method Button2_Click_1
method Button3_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method CutDate
method DateTimePicker1_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method InitializeComponent
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem20_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method Profil_Colors
method Profile_AfterSelect
method Profile_MouseDown
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_DoubleClick
method TVDokart_MouseDown
method TextBox1_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method Treeview1_MouseDown
method ValueList
method btnPartnersuche_Click
method cbtag1_TextChanged
method cbtag2_TextChanged
method cbtag3_TextChanged
method check_changes
method frmProfilDokAuswertung_Load
method frmProfil_Closing
method hosttag1_TextChanged
method hosttag2_TextChanged
method hosttag3_TextChanged
method init_treeview1
method mcb_Changed
method plausi_edoka
method plausi_host
method pnlhostdiv_Paint

See Also

frmProfilDokAuswertung Class


frmProfilDokAuswertung.Activate_Details Method

Private Sub Activate_Details()

Source code

[Visual Basic]
    Private Sub Activate_Details()
        Me.TreeView1.SelectedNode = Nothing
        If Me.FirstNodeWithData Is Nothing Then
            DivFnkt.Searchnode1(Me.TreeView1, 42, 99)
            If DivFnkt.found Then
                If colconv.ConvertToString(DivFnkt.FoundNode.ForeColor) = colconv.ConvertToString(System.Drawing.Color.Blue) Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.PnlDokumentart.Visible = True
                End If
            End If
        Else
            Me.TreeView1.SelectedNode = Me.FirstNodeWithData
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim cName As String = CType(sender, System.Windows.Forms.Button).Name
        If Me.ColorDialog1.ShowDialog() = DialogResult.Cancel Then Exit Sub

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.txtdatum1.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Button2_Click_1 Method

Private Sub Button2_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.txtdatum3.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.txtdatum5.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.DoubleClick, _
   PartnerList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.DoubleClick, PartnerList.DoubleClick
        Dim tn As New TreeNode()
        If Me.TreeView1.SelectedNode.Tag < 10 Then
            MsgBox("Bitte wählen Sie einen Knoten aus, der das Hinzufügen von Selektionskriterien erlaubt.")
            Exit Sub
        End If
        If Me.TreeView1.SelectedNode.Tag = 41 Or Me.TreeView1.SelectedNode.Tag = 51 Then
            tn = Me.TreeView1.SelectedNode
            tn = tn.Nodes.Add(Str(Me.PartnerList.Columns(0).Value) + " - " + Me.PartnerList.Columns(1).Value)
            tn.Tag = Me.PartnerList.Columns(0).Value
            tn.ForeColor = System.Drawing.Color.Red
            tn.ImageIndex = 4
            tn.SelectedImageIndex = 4
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
            Exit Sub
        End If
        Try
            tn = Me.TreeView1.SelectedNode
            tn = tn.Nodes.Add(Me.C1TrueDBGrid1.Columns(1).Value)
            tn.Tag = Me.C1TrueDBGrid1.Columns(0).Value
            If Me.C1TrueDBGrid1.Columns(2).Value = False Then
                tn.ForeColor = System.Drawing.Color.Gray
            Else
                tn.ForeColor = System.Drawing.Color.Red
            End If
            tn.ImageIndex = 4
            tn.SelectedImageIndex = 4
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
        Catch
        End Try
        Exit Sub
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.CTmenu1_Popup Method

Private Sub CTmenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CTmenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenu1.Popup
        Try
            Dim tn As TreeNode
            tn = TreeView1.SelectedNode
            If tn.Tag = 1 Or tn.Tag = 2 Or tn.Tag = 3 Or tn.Tag = 4 Then
                Me.MnuDel.Enabled = False
            End If
            If tn.Parent.Tag <> 1 And tn.Parent.Tag <> 2 And tn.Parent.Tag <> 3 And tn.Parent.Tag <> 4 Then
                Me.MnuDel.Enabled = True
            Else
                Me.MnuDel.Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.CutDate Method

Private Function CutDate( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Private Function CutDate(ByVal s As String) As String
        Dim i As Integer
        i = Microsoft.VisualBasic.InStr(s, " ")
        CutDate = Microsoft.VisualBasic.Left(s, i - 1)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        Me.txtdatum1.Text = CutDate(Me.DateTimePicker1.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker2_ValueChanged Method

Private Sub DateTimePicker2_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker2.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker2.ValueChanged
        Me.txtdatum2.Text = CutDate(Me.DateTimePicker2.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker3_ValueChanged Method

Private Sub DateTimePicker3_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker3.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker3_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker3.ValueChanged
        Me.txtdatum3.Text = CutDate(Me.DateTimePicker3.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker4_ValueChanged Method

Private Sub DateTimePicker4_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker4.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker4_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker4.ValueChanged
        Me.txtdatum4.Text = CutDate(Me.DateTimePicker4.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker5_ValueChanged Method

Private Sub DateTimePicker5_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker5.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker5_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker5.ValueChanged
        Me.txtdatum5.Text = CutDate(Me.DateTimePicker5.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker6_ValueChanged Method

Private Sub DateTimePicker6_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker6.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker6_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker6.ValueChanged
        Me.txtdatum6.Text = CutDate(Me.DateTimePicker6.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker8_ValueChanged Method

Private Sub DateTimePicker8_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker8.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker8_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker8.ValueChanged
        Me.HostDatum2.Text = CutDate(Me.DateTimePicker8.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.DateTimePicker9_ValueChanged Method

Private Sub DateTimePicker9_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker9.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker9_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker9.ValueChanged
        Me.HostDatum1.Text = CutDate(Me.DateTimePicker9.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Mitarbeiter"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Status"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Marktbereich"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Niederlassung"
            Case 5
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Kostenstelle"
            Case 6
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Team"
            Case 7
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp"
            Case 8
                scmCmdToExecute.CommandText = "dbo.SP_Profil_DokumenttypHost"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.GetNodeData Method

Private Function GetNodeData( _
   ByVal tnParent As TreeNode, _
   ByRef iParent As Integer _
) As String

Parameters

tnParent
Required.
iParent
Required.

Source code

[Visual Basic]
    Private Function GetNodeData(ByVal tnParent As TreeNode, ByRef iParent As Integer) As String
        Dim tn As TreeNode
        If tnParent.GetNodeCount(True) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        Do Until tn Is Nothing
            Try
                If tn.Parent.Tag = iParent Then
                    Me.NodeText = Me.NodeText & ";" & tn.Tag
                End If
            Catch ex As Exception
            End Try

            If tn.GetNodeCount(True) > 0 Then
                Call GetNodeData(tn, iParent)
            End If
            tn = tn.NextNode
        Loop
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.GetNodeDatastring Method

Private Function GetNodeDatastring( _
   ByVal iparent As Integer _
) As String

Parameters

iparent
Required.

Source code

[Visual Basic]
    Private Function GetNodeDatastring(ByVal iparent As Integer) As String
        Me.NodeText = ""
        DivFnkt.Searchnode1(Me.TreeView1, iparent, 0)
        If DivFnkt.found Then
            GetNodeData(DivFnkt.FoundNode, iparent)
            Try
                Me.NodeText = Microsoft.VisualBasic.Right(Me.NodeText, Len(Me.NodeText) - 1)
            Catch
                Me.NodeText = ""
            End Try
        End If
        Return Me.NodeText
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmProfilDokAuswertung))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnClose = New System.Windows.Forms.ToolBarButton()
        Me.btnOpen = New System.Windows.Forms.ToolBarButton()
        Me.btnSave = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ColorDialog1 = New System.Windows.Forms.ColorDialog()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.MnuListe = New System.Windows.Forms.ContextMenu()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.Profile = New System.Windows.Forms.TreeView()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.ComboBox10 = New System.Windows.Forms.ComboBox()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.ComboBox9 = New System.Windows.Forms.ComboBox()
        Me.ctmenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDel = New System.Windows.Forms.MenuItem()
        Me.CTMenuErsteller = New System.Windows.Forms.ContextMenu()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.CTMenuVerantwortlicher = New System.Windows.Forms.ContextMenu()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.CTMenuMutierer = New System.Windows.Forms.ContextMenu()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.pnlhostdiv = New System.Windows.Forms.Panel()
        Me.hostinklmavip = New System.Windows.Forms.CheckBox()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.lblhostdatum3 = New System.Windows.Forms.Label()
        Me.lblhostdatum2 = New System.Windows.Forms.Label()
        Me.lblhostdatum1 = New System.Windows.Forms.Label()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.HostTag3 = New System.Windows.Forms.ComboBox()
        Me.HostTag2 = New System.Windows.Forms.ComboBox()
        Me.HostTag1 = New System.Windows.Forms.ComboBox()
        Me.HostDatum3 = New System.Windows.Forms.TextBox()
        Me.HostDatum2 = New System.Windows.Forms.TextBox()
        Me.HostDatum1 = New System.Windows.Forms.TextBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.DateTimePicker7 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker8 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker9 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.Label35 = New System.Windows.Forms.Label()
        Me.CheckBox3 = New System.Windows.Forms.CheckBox()
        Me.CheckBox4 = New System.Windows.Forms.CheckBox()
        Me.CheckBox5 = New System.Windows.Forms.CheckBox()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label36 = New System.Windows.Forms.Label()
        Me.Label37 = New System.Windows.Forms.Label()
        Me.Label38 = New System.Windows.Forms.Label()
        Me.DateTimePicker10 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker11 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker12 = New System.Windows.Forms.DateTimePicker()
        Me.TVHostDok = New System.Windows.Forms.TreeView()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuSelectDokumentart = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteDokumentart = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.PnlDokumentDaten = New System.Windows.Forms.Panel()
        Me.cinklalt = New System.Windows.Forms.CheckBox()
        Me.cbmavip = New System.Windows.Forms.CheckBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.lbldatum3 = New System.Windows.Forms.Label()
        Me.lbldatum2 = New System.Windows.Forms.Label()
        Me.lbldatum1 = New System.Windows.Forms.Label()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.cbtag3 = New System.Windows.Forms.ComboBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.cbtag2 = New System.Windows.Forms.ComboBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.cbtag1 = New System.Windows.Forms.ComboBox()
        Me.cbd6 = New System.Windows.Forms.CheckBox()
        Me.cbd4 = New System.Windows.Forms.CheckBox()
        Me.cbd2 = New System.Windows.Forms.CheckBox()
        Me.txtdatum6 = New System.Windows.Forms.TextBox()
        Me.txtdatum5 = New System.Windows.Forms.TextBox()
        Me.txtdatum4 = New System.Windows.Forms.TextBox()
        Me.txtdatum3 = New System.Windows.Forms.TextBox()
        Me.txtdatum2 = New System.Windows.Forms.TextBox()
        Me.txtdatum1 = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.DateTimePicker6 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker5 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker2 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.PnlDokumentart = New System.Windows.Forms.Panel()
        Me.TVDokart = New System.Windows.Forms.TreeView()
        Me.PnlPartner = New System.Windows.Forms.Panel()
        Me.PartnerList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.btnPartnersuche = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.Panel2.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.pnlhostdiv.SuspendLayout()
        Me.PnlDokumentDaten.SuspendLayout()
        Me.PnlDokumentart.SuspendLayout()
        Me.PnlPartner.SuspendLayout()
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel3.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5})
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Schliessen"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnClose, Me.btnOpen, Me.btnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(792, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnClose
        '
        Me.btnClose.ImageIndex = 0
        Me.btnClose.ToolTipText = "Fenster schliessen"
        '
        'btnOpen
        '
        Me.btnOpen.ImageIndex = 7
        Me.btnOpen.Visible = False
        '
        'btnSave
        '
        Me.btnSave.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(792, 8)
        Me.Panel1.TabIndex = 4
        '
        'MnuListe
        '
        Me.MnuListe.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem12, Me.MenuItem6, Me.MenuItem7, Me.MenuItem9, Me.MenuItem11, Me.MenuItem13, Me.MenuItem8, Me.MenuItem10})
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 0
        Me.MenuItem12.Text = "Übernehmen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Auswählen"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 2
        Me.MenuItem7.Text = "Als Standard"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 3
        Me.MenuItem9.Text = "-"
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 4
        Me.MenuItem11.Text = "Neus Profil"
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 5
        Me.MenuItem13.Text = "Profil kopieren"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 6
        Me.MenuItem8.Text = "Umbenennen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 7
        Me.MenuItem10.Text = "Löschen"
        '
        'Panel2
        '
        Me.Panel2.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Profile})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Location = New System.Drawing.Point(0, 33)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(176, 544)
        Me.Panel2.TabIndex = 11
        '
        'Profile
        '
        Me.Profile.ContextMenu = Me.MnuListe
        Me.Profile.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Profile.FullRowSelect = True
        Me.Profile.ImageIndex = -1
        Me.Profile.Name = "Profile"
        Me.Profile.SelectedImageIndex = -1
        Me.Profile.ShowLines = False
        Me.Profile.ShowPlusMinus = False
        Me.Profile.Size = New System.Drawing.Size(174, 542)
        Me.Profile.Sorted = True
        Me.Profile.TabIndex = 0
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(200, 552)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(112, 24)
        Me.Button4.TabIndex = 14
        Me.Button4.Text = "Übernehmen"
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(16, 64)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(48, 23)
        Me.Label25.TabIndex = 3
        '
        'ComboBox10
        '
        Me.ComboBox10.Location = New System.Drawing.Point(64, 64)
        Me.ComboBox10.Name = "ComboBox10"
        Me.ComboBox10.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox10.TabIndex = 2
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(16, 32)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(48, 23)
        Me.Label24.TabIndex = 1
        '
        'ComboBox9
        '
        Me.ComboBox9.Location = New System.Drawing.Point(64, 32)
        Me.ComboBox9.Name = "ComboBox9"
        Me.ComboBox9.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox9.TabIndex = 0
        '
        'ctmenu1
        '
        Me.ctmenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDel})
        '
        'MnuDel
        '
        Me.MnuDel.Index = 0
        Me.MnuDel.Text = "Eintrag löschen"
        '
        'CTMenuErsteller
        '
        Me.CTMenuErsteller.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem15, Me.MenuItem16})
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 0
        Me.MenuItem15.Text = "Partner übernehmen"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 1
        Me.MenuItem16.Text = "Detailinformationen"
        '
        'CTMenuVerantwortlicher
        '
        Me.CTMenuVerantwortlicher.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem20})
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 0
        Me.MenuItem20.Text = "Eintrag übernehmen"
        '
        'CTMenuMutierer
        '
        Me.CTMenuMutierer.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem24, Me.MenuItem25, Me.MenuItem26, Me.MenuItem27})
        '
        'MenuItem24
        '
        Me.MenuItem24.Index = 0
        Me.MenuItem24.Text = "&Eintrag selektieren"
        '
        'MenuItem25
        '
        Me.MenuItem25.Index = 1
        Me.MenuItem25.Text = "&Selektion aufheben"
        '
        'MenuItem26
        '
        Me.MenuItem26.Index = 2
        Me.MenuItem26.Text = "-"
        '
        'MenuItem27
        '
        Me.MenuItem27.Index = 3
        Me.MenuItem27.Text = "&Alle aufheben"
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=localhost;initial catalog=Edoka;password=sqlsa;persist security info=" & _
        "True;user id=sa;workstation id=NB12;packet size=4096"
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=localhost;initial catalog=edoka;password=sqlsa;persist security info=" & _
        "True;user id=sa;workstation id=PC120;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(176, 33)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 544)
        Me.Splitter1.TabIndex = 15
        Me.Splitter1.TabStop = False
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Location = New System.Drawing.Point(179, 33)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(613, 544)
        Me.TabControl1.TabIndex = 16
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlhostdiv, Me.TVHostDok, Me.PnlDokumentDaten, Me.PnlDokumentart, Me.PnlPartner, Me.Panel3, Me.TreeView1})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(605, 518)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Selektion"
        '
        'pnlhostdiv
        '
        Me.pnlhostdiv.Controls.AddRange(New System.Windows.Forms.Control() {Me.hostinklmavip, Me.GroupBox7, Me.Label4, Me.Label9, Me.lblhostdatum3, Me.lblhostdatum2, Me.lblhostdatum1, Me.Button6, Me.Button7, Me.Button8, Me.Label26, Me.HostTag3, Me.HostTag2, Me.HostTag1, Me.HostDatum3, Me.HostDatum2, Me.HostDatum1, Me.Label27, Me.Label28, Me.Label29, Me.DateTimePicker7, Me.DateTimePicker8, Me.DateTimePicker9, Me.GroupBox6, Me.Label32, Me.Label33, Me.Label34, Me.Label35, Me.CheckBox3, Me.CheckBox4, Me.CheckBox5, Me.TextBox7, Me.TextBox8, Me.TextBox9, Me.Label36, Me.Label37, Me.Label38, Me.DateTimePicker10, Me.DateTimePicker11, Me.DateTimePicker12})
        Me.pnlhostdiv.Location = New System.Drawing.Point(224, 8)
        Me.pnlhostdiv.Name = "pnlhostdiv"
        Me.pnlhostdiv.Size = New System.Drawing.Size(376, 496)
        Me.pnlhostdiv.TabIndex = 7
        Me.pnlhostdiv.Visible = False
        '
        'hostinklmavip
        '
        Me.hostinklmavip.Location = New System.Drawing.Point(16, 168)
        Me.hostinklmavip.Name = "hostinklmavip"
        Me.hostinklmavip.Size = New System.Drawing.Size(264, 24)
        Me.hostinklmavip.TabIndex = 82
        Me.hostinklmavip.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        '
        'GroupBox7
        '
        Me.GroupBox7.Location = New System.Drawing.Point(8, 152)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox7.TabIndex = 84
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Datenselektion"
        '
        'Label4
        '
        Me.Label4.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label4.Location = New System.Drawing.Point(168, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(64, 23)
        Me.Label4.TabIndex = 81
        Me.Label4.Text = "Ab Datum"
        '
        'Label9
        '
        Me.Label9.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label9.Location = New System.Drawing.Point(248, 24)
        Me.Label9.Name = "Label9"
        Me.Label9.TabIndex = 80
        Me.Label9.Text = "Bis Datum"
        '
        'lblhostdatum3
        '
        Me.lblhostdatum3.Location = New System.Drawing.Point(168, 112)
        Me.lblhostdatum3.Name = "lblhostdatum3"
        Me.lblhostdatum3.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum3.TabIndex = 79
        '
        'lblhostdatum2
        '
        Me.lblhostdatum2.Location = New System.Drawing.Point(168, 80)
        Me.lblhostdatum2.Name = "lblhostdatum2"
        Me.lblhostdatum2.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum2.TabIndex = 78
        '
        'lblhostdatum1
        '
        Me.lblhostdatum1.Location = New System.Drawing.Point(168, 48)
        Me.lblhostdatum1.Name = "lblhostdatum1"
        Me.lblhostdatum1.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum1.TabIndex = 77
        '
        'Button6
        '
        Me.Button6.Location = New System.Drawing.Point(344, 112)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(16, 16)
        Me.Button6.TabIndex = 76
        '
        'Button7
        '
        Me.Button7.Location = New System.Drawing.Point(344, 80)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(16, 16)
        Me.Button7.TabIndex = 75
        '
        'Button8
        '
        Me.Button8.Location = New System.Drawing.Point(344, 48)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(16, 16)
        Me.Button8.TabIndex = 74
        '
        'Label26
        '
        Me.Label26.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label26.Location = New System.Drawing.Point(88, 24)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(72, 23)
        Me.Label26.TabIndex = 73
        Me.Label26.Text = "Anzahl Tage"
        '
        'HostTag3
        '
        Me.HostTag3.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.HostTag3.Location = New System.Drawing.Point(88, 110)
        Me.HostTag3.Name = "HostTag3"
        Me.HostTag3.Size = New System.Drawing.Size(56, 21)
        Me.HostTag3.TabIndex = 71
        Me.HostTag3.Text = "HostTag3"
        '
        'HostTag2
        '
        Me.HostTag2.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.HostTag2.Location = New System.Drawing.Point(88, 78)
        Me.HostTag2.Name = "HostTag2"
        Me.HostTag2.Size = New System.Drawing.Size(56, 21)
        Me.HostTag2.TabIndex = 68
        Me.HostTag2.Text = "HostTag2"
        '
        'HostTag1
        '
        Me.HostTag1.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.HostTag1.Location = New System.Drawing.Point(88, 46)
        Me.HostTag1.Name = "HostTag1"
        Me.HostTag1.Size = New System.Drawing.Size(56, 21)
        Me.HostTag1.TabIndex = 65
        Me.HostTag1.Text = "ComboBox1"
        '
        'HostDatum3
        '
        Me.HostDatum3.BackColor = System.Drawing.Color.White
        Me.HostDatum3.Enabled = False
        Me.HostDatum3.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.HostDatum3.Location = New System.Drawing.Point(248, 110)
        Me.HostDatum3.Name = "HostDatum3"
        Me.HostDatum3.ReadOnly = True
        Me.HostDatum3.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum3.TabIndex = 58
        Me.HostDatum3.Text = "TextBox4"
        '
        'HostDatum2
        '
        Me.HostDatum2.BackColor = System.Drawing.Color.White
        Me.HostDatum2.Enabled = False
        Me.HostDatum2.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.HostDatum2.Location = New System.Drawing.Point(248, 78)
        Me.HostDatum2.Name = "HostDatum2"
        Me.HostDatum2.ReadOnly = True
        Me.HostDatum2.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum2.TabIndex = 56
        Me.HostDatum2.Text = "TextBox4"
        '
        'HostDatum1
        '
        Me.HostDatum1.BackColor = System.Drawing.Color.White
        Me.HostDatum1.Enabled = False
        Me.HostDatum1.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.HostDatum1.Location = New System.Drawing.Point(248, 46)
        Me.HostDatum1.Name = "HostDatum1"
        Me.HostDatum1.ReadOnly = True
        Me.HostDatum1.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum1.TabIndex = 54
        Me.HostDatum1.Text = ""
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(16, 111)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(72, 23)
        Me.Label27.TabIndex = 52
        Me.Label27.Text = "Archivierung"
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(16, 79)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(64, 23)
        Me.Label28.TabIndex = 50
        Me.Label28.Text = "Mutation"
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(16, 47)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(56, 23)
        Me.Label29.TabIndex = 48
        Me.Label29.Text = "Erstellung"
        '
        'DateTimePicker7
        '
        Me.DateTimePicker7.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker7.Location = New System.Drawing.Point(248, 110)
        Me.DateTimePicker7.Name = "DateTimePicker7"
        Me.DateTimePicker7.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker7.TabIndex = 46
        Me.DateTimePicker7.TabStop = False
        '
        'DateTimePicker8
        '
        Me.DateTimePicker8.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker8.Location = New System.Drawing.Point(248, 78)
        Me.DateTimePicker8.Name = "DateTimePicker8"
        Me.DateTimePicker8.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker8.TabIndex = 44
        Me.DateTimePicker8.TabStop = False
        '
        'DateTimePicker9
        '
        Me.DateTimePicker9.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker9.Location = New System.Drawing.Point(248, 46)
        Me.DateTimePicker9.Name = "DateTimePicker9"
        Me.DateTimePicker9.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker9.TabIndex = 42
        Me.DateTimePicker9.TabStop = False
        '
        'GroupBox6
        '
        Me.GroupBox6.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox6.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(360, 136)
        Me.GroupBox6.TabIndex = 83
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Datumsselektion"
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(256, 344)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(40, 23)
        Me.Label32.TabIndex = 70
        Me.Label32.Text = "Tagen"
        Me.Label32.Visible = False
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(256, 320)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(40, 23)
        Me.Label33.TabIndex = 69
        Me.Label33.Text = "Tagen"
        Me.Label33.Visible = False
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(32, 344)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(160, 23)
        Me.Label34.TabIndex = 67
        Me.Label34.Text = "Mutationsdatum in den letzen "
        Me.Label34.Visible = False
        '
        'Label35
        '
        Me.Label35.Location = New System.Drawing.Point(32, 320)
        Me.Label35.Name = "Label35"
        Me.Label35.Size = New System.Drawing.Size(160, 23)
        Me.Label35.TabIndex = 66
        Me.Label35.Text = "Erstellungsdatum in den letzen"
        Me.Label35.Visible = False
        '
        'CheckBox3
        '
        Me.CheckBox3.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox3.Name = "CheckBox3"
        Me.CheckBox3.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox3.TabIndex = 64
        Me.CheckBox3.Visible = False
        '
        'CheckBox4
        '
        Me.CheckBox4.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox4.Name = "CheckBox4"
        Me.CheckBox4.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox4.TabIndex = 62
        Me.CheckBox4.Visible = False
        '
        'CheckBox5
        '
        Me.CheckBox5.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox5.Name = "CheckBox5"
        Me.CheckBox5.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox5.TabIndex = 60
        Me.CheckBox5.Visible = False
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.White
        Me.TextBox7.Enabled = False
        Me.TextBox7.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox7.Location = New System.Drawing.Point(160, 464)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(80, 20)
        Me.TextBox7.TabIndex = 59
        Me.TextBox7.Text = "TextBox4"
        Me.TextBox7.Visible = False
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.White
        Me.TextBox8.Enabled = False
        Me.TextBox8.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox8.Location = New System.Drawing.Point(160, 440)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(80, 20)
        Me.TextBox8.TabIndex = 57
        Me.TextBox8.Text = "TextBox4"
        Me.TextBox8.Visible = False
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.White
        Me.TextBox9.Enabled = False
        Me.TextBox9.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox9.Location = New System.Drawing.Point(160, 416)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(80, 20)
        Me.TextBox9.TabIndex = 55
        Me.TextBox9.Text = "TextBox4"
        Me.TextBox9.Visible = False
        '
        'Label36
        '
        Me.Label36.Location = New System.Drawing.Point(48, 464)
        Me.Label36.Name = "Label36"
        Me.Label36.TabIndex = 53
        Me.Label36.Text = "Archivierung bis"
        Me.Label36.Visible = False
        '
        'Label37
        '
        Me.Label37.Location = New System.Drawing.Point(48, 440)
        Me.Label37.Name = "Label37"
        Me.Label37.Size = New System.Drawing.Size(96, 23)
        Me.Label37.TabIndex = 51
        Me.Label37.Text = "Mutation bis"
        Me.Label37.Visible = False
        '
        'Label38
        '
        Me.Label38.Location = New System.Drawing.Point(48, 416)
        Me.Label38.Name = "Label38"
        Me.Label38.Size = New System.Drawing.Size(96, 23)
        Me.Label38.TabIndex = 49
        Me.Label38.Text = "Erstellung bis"
        Me.Label38.Visible = False
        '
        'DateTimePicker10
        '
        Me.DateTimePicker10.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker10.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker10.Name = "DateTimePicker10"
        Me.DateTimePicker10.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker10.TabIndex = 47
        Me.DateTimePicker10.TabStop = False
        Me.DateTimePicker10.Visible = False
        '
        'DateTimePicker11
        '
        Me.DateTimePicker11.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker11.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker11.Name = "DateTimePicker11"
        Me.DateTimePicker11.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker11.TabIndex = 45
        Me.DateTimePicker11.TabStop = False
        Me.DateTimePicker11.Visible = False
        '
        'DateTimePicker12
        '
        Me.DateTimePicker12.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker12.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker12.Name = "DateTimePicker12"
        Me.DateTimePicker12.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker12.TabIndex = 43
        Me.DateTimePicker12.TabStop = False
        Me.DateTimePicker12.Visible = False
        '
        'TVHostDok
        '
        Me.TVHostDok.ContextMenu = Me.ContextMenu1
        Me.TVHostDok.ImageIndex = -1
        Me.TVHostDok.Location = New System.Drawing.Point(224, 8)
        Me.TVHostDok.Name = "TVHostDok"
        Me.TVHostDok.SelectedImageIndex = -1
        Me.TVHostDok.Size = New System.Drawing.Size(376, 504)
        Me.TVHostDok.TabIndex = 6
        Me.TVHostDok.Visible = False
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuSelectDokumentart, Me.MnuDeleteDokumentart, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4})
        '
        'MnuSelectDokumentart
        '
        Me.MnuSelectDokumentart.Index = 0
        Me.MnuSelectDokumentart.Text = "Eintrag auswählen"
        '
        'MnuDeleteDokumentart
        '
        Me.MnuDeleteDokumentart.Index = 1
        Me.MnuDeleteDokumentart.Text = "Eintrag abwählen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 3
        Me.MenuItem3.Text = "Knoten öffnen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 4
        Me.MenuItem4.Text = "Knoten schliessen"
        '
        'PnlDokumentDaten
        '
        Me.PnlDokumentDaten.Controls.AddRange(New System.Windows.Forms.Control() {Me.cinklalt, Me.cbmavip, Me.Label12, Me.Label11, Me.lbldatum3, Me.lbldatum2, Me.lbldatum1, Me.Button3, Me.Button2, Me.Button1, Me.Label10, Me.cbtag3, Me.Label8, Me.Label7, Me.cbtag2, Me.Label6, Me.Label5, Me.cbtag1, Me.cbd6, Me.cbd4, Me.cbd2, Me.txtdatum6, Me.txtdatum5, Me.txtdatum4, Me.txtdatum3, Me.txtdatum2, Me.txtdatum1, Me.Label18, Me.Label17, Me.Label16, Me.Label15, Me.Label14, Me.Label13, Me.DateTimePicker6, Me.DateTimePicker5, Me.DateTimePicker4, Me.DateTimePicker3, Me.DateTimePicker2, Me.DateTimePicker1, Me.GroupBox3, Me.GroupBox10})
        Me.PnlDokumentDaten.Location = New System.Drawing.Point(224, 8)
        Me.PnlDokumentDaten.Name = "PnlDokumentDaten"
        Me.PnlDokumentDaten.Size = New System.Drawing.Size(376, 496)
        Me.PnlDokumentDaten.TabIndex = 1
        Me.PnlDokumentDaten.Visible = False
        '
        'cinklalt
        '
        Me.cinklalt.Location = New System.Drawing.Point(16, 168)
        Me.cinklalt.Name = "cinklalt"
        Me.cinklalt.Size = New System.Drawing.Size(336, 24)
        Me.cinklalt.TabIndex = 84
        Me.cinklalt.Text = "Dokumentselektion inkl. gelöschte/aufgehobene Dokumente"
        '
        'cbmavip
        '
        Me.cbmavip.Location = New System.Drawing.Point(16, 168)
        Me.cbmavip.Name = "cbmavip"
        Me.cbmavip.Size = New System.Drawing.Size(264, 24)
        Me.cbmavip.TabIndex = 82
        Me.cbmavip.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.cbmavip.Visible = False
        '
        'Label12
        '
        Me.Label12.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label12.Location = New System.Drawing.Point(168, 24)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(64, 23)
        Me.Label12.TabIndex = 81
        Me.Label12.Text = "Ab Datum"
        '
        'Label11
        '
        Me.Label11.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label11.Location = New System.Drawing.Point(248, 24)
        Me.Label11.Name = "Label11"
        Me.Label11.TabIndex = 80
        Me.Label11.Text = "Bis Datum"
        '
        'lbldatum3
        '
        Me.lbldatum3.Location = New System.Drawing.Point(168, 112)
        Me.lbldatum3.Name = "lbldatum3"
        Me.lbldatum3.Size = New System.Drawing.Size(72, 21)
        Me.lbldatum3.TabIndex = 79
        '
        'lbldatum2
        '
        Me.lbldatum2.Location = New System.Drawing.Point(168, 80)
        Me.lbldatum2.Name = "lbldatum2"
        Me.lbldatum2.Size = New System.Drawing.Size(72, 21)
        Me.lbldatum2.TabIndex = 78
        '
        'lbldatum1
        '
        Me.lbldatum1.Location = New System.Drawing.Point(168, 48)
        Me.lbldatum1.Name = "lbldatum1"
        Me.lbldatum1.Size = New System.Drawing.Size(72, 21)
        Me.lbldatum1.TabIndex = 77
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(344, 112)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(16, 16)
        Me.Button3.TabIndex = 76
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(344, 80)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(16, 16)
        Me.Button2.TabIndex = 75
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(344, 48)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(16, 16)
        Me.Button1.TabIndex = 74
        '
        'Label10
        '
        Me.Label10.Font = New System.Drawing.Font("Microsoft Sans Serif", 8.25!, System.Drawing.FontStyle.Underline, System.Drawing.GraphicsUnit.Point, CType(0, Byte))
        Me.Label10.Location = New System.Drawing.Point(88, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(72, 23)
        Me.Label10.TabIndex = 73
        Me.Label10.Text = "Anzahl Tage"
        '
        'cbtag3
        '
        Me.cbtag3.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.cbtag3.Location = New System.Drawing.Point(88, 110)
        Me.cbtag3.Name = "cbtag3"
        Me.cbtag3.Size = New System.Drawing.Size(56, 21)
        Me.cbtag3.TabIndex = 71
        Me.cbtag3.Text = "ComboBox1"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(256, 344)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(40, 23)
        Me.Label8.TabIndex = 70
        Me.Label8.Text = "Tagen"
        Me.Label8.Visible = False
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(256, 320)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(40, 23)
        Me.Label7.TabIndex = 69
        Me.Label7.Text = "Tagen"
        Me.Label7.Visible = False
        '
        'cbtag2
        '
        Me.cbtag2.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.cbtag2.Location = New System.Drawing.Point(88, 78)
        Me.cbtag2.Name = "cbtag2"
        Me.cbtag2.Size = New System.Drawing.Size(56, 21)
        Me.cbtag2.TabIndex = 68
        Me.cbtag2.Text = "ComboBox1"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(32, 344)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(160, 23)
        Me.Label6.TabIndex = 67
        Me.Label6.Text = "Mutationsdatum in den letzen "
        Me.Label6.Visible = False
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(32, 320)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(160, 23)
        Me.Label5.TabIndex = 66
        Me.Label5.Text = "Erstellungsdatum in den letzen"
        Me.Label5.Visible = False
        '
        'cbtag1
        '
        Me.cbtag1.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.cbtag1.Location = New System.Drawing.Point(88, 46)
        Me.cbtag1.Name = "cbtag1"
        Me.cbtag1.Size = New System.Drawing.Size(56, 21)
        Me.cbtag1.TabIndex = 65
        Me.cbtag1.Text = "ComboBox1"
        '
        'cbd6
        '
        Me.cbd6.Location = New System.Drawing.Point(16, 464)
        Me.cbd6.Name = "cbd6"
        Me.cbd6.Size = New System.Drawing.Size(16, 24)
        Me.cbd6.TabIndex = 64
        Me.cbd6.Visible = False
        '
        'cbd4
        '
        Me.cbd4.Location = New System.Drawing.Point(16, 440)
        Me.cbd4.Name = "cbd4"
        Me.cbd4.Size = New System.Drawing.Size(16, 24)
        Me.cbd4.TabIndex = 62
        Me.cbd4.Visible = False
        '
        'cbd2
        '
        Me.cbd2.Location = New System.Drawing.Point(16, 416)
        Me.cbd2.Name = "cbd2"
        Me.cbd2.Size = New System.Drawing.Size(16, 24)
        Me.cbd2.TabIndex = 60
        Me.cbd2.Visible = False
        '
        'txtdatum6
        '
        Me.txtdatum6.BackColor = System.Drawing.Color.White
        Me.txtdatum6.Enabled = False
        Me.txtdatum6.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum6.Location = New System.Drawing.Point(160, 464)
        Me.txtdatum6.Name = "txtdatum6"
        Me.txtdatum6.ReadOnly = True
        Me.txtdatum6.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum6.TabIndex = 59
        Me.txtdatum6.Text = "TextBox4"
        Me.txtdatum6.Visible = False
        '
        'txtdatum5
        '
        Me.txtdatum5.BackColor = System.Drawing.Color.White
        Me.txtdatum5.Enabled = False
        Me.txtdatum5.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum5.Location = New System.Drawing.Point(248, 110)
        Me.txtdatum5.Name = "txtdatum5"
        Me.txtdatum5.ReadOnly = True
        Me.txtdatum5.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum5.TabIndex = 58
        Me.txtdatum5.Text = "TextBox4"
        '
        'txtdatum4
        '
        Me.txtdatum4.BackColor = System.Drawing.Color.White
        Me.txtdatum4.Enabled = False
        Me.txtdatum4.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum4.Location = New System.Drawing.Point(160, 440)
        Me.txtdatum4.Name = "txtdatum4"
        Me.txtdatum4.ReadOnly = True
        Me.txtdatum4.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4.TabIndex = 57
        Me.txtdatum4.Text = "TextBox4"
        Me.txtdatum4.Visible = False
        '
        'txtdatum3
        '
        Me.txtdatum3.BackColor = System.Drawing.Color.White
        Me.txtdatum3.Enabled = False
        Me.txtdatum3.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum3.Location = New System.Drawing.Point(248, 78)
        Me.txtdatum3.Name = "txtdatum3"
        Me.txtdatum3.ReadOnly = True
        Me.txtdatum3.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3.TabIndex = 56
        Me.txtdatum3.Text = "TextBox4"
        '
        'txtdatum2
        '
        Me.txtdatum2.BackColor = System.Drawing.Color.White
        Me.txtdatum2.Enabled = False
        Me.txtdatum2.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum2.Location = New System.Drawing.Point(160, 416)
        Me.txtdatum2.Name = "txtdatum2"
        Me.txtdatum2.ReadOnly = True
        Me.txtdatum2.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2.TabIndex = 55
        Me.txtdatum2.Text = "TextBox4"
        Me.txtdatum2.Visible = False
        '
        'txtdatum1
        '
        Me.txtdatum1.BackColor = System.Drawing.Color.White
        Me.txtdatum1.Enabled = False
        Me.txtdatum1.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.txtdatum1.Location = New System.Drawing.Point(248, 46)
        Me.txtdatum1.Name = "txtdatum1"
        Me.txtdatum1.ReadOnly = True
        Me.txtdatum1.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1.TabIndex = 54
        Me.txtdatum1.Text = "TextBox4"
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(48, 464)
        Me.Label18.Name = "Label18"
        Me.Label18.TabIndex = 53
        Me.Label18.Text = "Archivierung bis"
        Me.Label18.Visible = False
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(16, 111)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(72, 23)
        Me.Label17.TabIndex = 52
        Me.Label17.Text = "Archivierung"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(48, 440)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 51
        Me.Label16.Text = "Mutation bis"
        Me.Label16.Visible = False
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(16, 79)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(64, 23)
        Me.Label15.TabIndex = 50
        Me.Label15.Text = "Mutation"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(48, 416)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(96, 23)
        Me.Label14.TabIndex = 49
        Me.Label14.Text = "Erstellung bis"
        Me.Label14.Visible = False
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(16, 47)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(56, 23)
        Me.Label13.TabIndex = 48
        Me.Label13.Text = "Erstellung"
        '
        'DateTimePicker6
        '
        Me.DateTimePicker6.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker6.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker6.Name = "DateTimePicker6"
        Me.DateTimePicker6.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker6.TabIndex = 47
        Me.DateTimePicker6.TabStop = False
        Me.DateTimePicker6.Visible = False
        '
        'DateTimePicker5
        '
        Me.DateTimePicker5.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker5.Location = New System.Drawing.Point(248, 110)
        Me.DateTimePicker5.Name = "DateTimePicker5"
        Me.DateTimePicker5.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker5.TabIndex = 46
        Me.DateTimePicker5.TabStop = False
        '
        'DateTimePicker4
        '
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker4.TabIndex = 45
        Me.DateTimePicker4.TabStop = False
        Me.DateTimePicker4.Visible = False
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(248, 78)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker3.TabIndex = 44
        Me.DateTimePicker3.TabStop = False
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker2.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker2.TabIndex = 43
        Me.DateTimePicker2.TabStop = False
        Me.DateTimePicker2.Visible = False
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(248, 46)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker1.TabIndex = 42
        Me.DateTimePicker1.TabStop = False
        '
        'GroupBox3
        '
        Me.GroupBox3.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox3.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(360, 136)
        Me.GroupBox3.TabIndex = 83
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Datumsselektion"
        '
        'GroupBox10
        '
        Me.GroupBox10.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox10.Location = New System.Drawing.Point(8, 152)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox10.TabIndex = 85
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Datenselektion"
        '
        'PnlDokumentart
        '
        Me.PnlDokumentart.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVDokart})
        Me.PnlDokumentart.Location = New System.Drawing.Point(224, 8)
        Me.PnlDokumentart.Name = "PnlDokumentart"
        Me.PnlDokumentart.Size = New System.Drawing.Size(376, 504)
        Me.PnlDokumentart.TabIndex = 4
        Me.PnlDokumentart.Visible = False
        '
        'TVDokart
        '
        Me.TVDokart.ContextMenu = Me.ContextMenu1
        Me.TVDokart.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVDokart.ImageIndex = -1
        Me.TVDokart.Name = "TVDokart"
        Me.TVDokart.SelectedImageIndex = -1
        Me.TVDokart.Size = New System.Drawing.Size(376, 504)
        Me.TVDokart.TabIndex = 0
        '
        'PnlPartner
        '
        Me.PnlPartner.Controls.AddRange(New System.Windows.Forms.Control() {Me.PartnerList, Me.btnPartnersuche, Me.Label3, Me.TextBox3, Me.Label2, Me.TextBox2, Me.Label1, Me.TextBox1})
        Me.PnlPartner.Location = New System.Drawing.Point(224, 8)
        Me.PnlPartner.Name = "PnlPartner"
        Me.PnlPartner.Size = New System.Drawing.Size(376, 504)
        Me.PnlPartner.TabIndex = 3
        Me.PnlPartner.Visible = False
        '
        'PartnerList
        '
        Me.PartnerList.AllowFilter = True
        Me.PartnerList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.PartnerList.AllowSort = True
        Me.PartnerList.AllowUpdate = False
        Me.PartnerList.AllowUpdateOnBlur = False
        Me.PartnerList.AlternatingRows = True
        Me.PartnerList.CaptionHeight = 17
        Me.PartnerList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.PartnerList.CollapseColor = System.Drawing.Color.Black
        Me.PartnerList.ContextMenu = Me.CTMenuErsteller
        Me.PartnerList.DataChanged = False
        Me.PartnerList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.PartnerList.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.PartnerList.ExpandColor = System.Drawing.Color.Black
        Me.PartnerList.FetchRowStyles = True
        Me.PartnerList.FilterBar = True
        Me.PartnerList.GroupByCaption = "Drag a column header here to group by that column"
        Me.PartnerList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.PartnerList.Location = New System.Drawing.Point(0, 104)
        Me.PartnerList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.PartnerList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.PartnerList.Name = "PartnerList"
        Me.PartnerList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.PartnerList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.PartnerList.PreviewInfo.ZoomFactor = 75
        Me.PartnerList.PrintInfo.ShowOptionsDialog = False
        Me.PartnerList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.PartnerList.RowDivider = GridLines1
        Me.PartnerList.RowHeight = 15
        Me.PartnerList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.PartnerList.ScrollTips = False
        Me.PartnerList.Size = New System.Drawing.Size(376, 400)
        Me.PartnerList.TabIndex = 17
        Me.PartnerList.Text = "C1TrueDBGrid1"
        Me.PartnerList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:Silver;}RecordSelector{AlignImage:Center" & _
        ";}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:Contro" & _
        "lText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style1" & _
        "3{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" Altern" & _
        "atingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHei" & _
        "ght=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" " & _
        "RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalS" & _
        "crollGroup=""1""><ClientRect>0, 0, 372, 396</ClientRect><BorderSide>0</BorderSide>" & _
        "<CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""St" & _
        "yle5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""Fil" & _
        "terBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle pa" & _
        "rent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLi" & _
        "ghtRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive""" & _
        " me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle p" & _
        "arent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style" & _
        "6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Spli" & _
        "ts><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Headin" & _
        "g"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" " & _
        "/><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /" & _
        "><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /" & _
        "><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Sty" & _
        "le parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" " & _
        "/><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><" & _
        "horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRec" & _
        "SelWidth><ClientArea>0, 0, 372, 396</ClientArea></Blob>"
        '
        'btnPartnersuche
        '
        Me.btnPartnersuche.Image = CType(resources.GetObject("btnPartnersuche.Image"), System.Drawing.Bitmap)
        Me.btnPartnersuche.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.btnPartnersuche.Location = New System.Drawing.Point(288, 32)
        Me.btnPartnersuche.Name = "btnPartnersuche"
        Me.btnPartnersuche.Size = New System.Drawing.Size(72, 40)
        Me.btnPartnersuche.TabIndex = 16
        Me.btnPartnersuche.Text = "&Suchen"
        Me.btnPartnersuche.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "Freitext"
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(88, 64)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(160, 20)
        Me.TextBox3.TabIndex = 14
        Me.TextBox3.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 13
        Me.Label2.Text = "Kurzname"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(88, 40)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(160, 20)
        Me.TextBox2.TabIndex = 12
        Me.TextBox2.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 11
        Me.Label1.Text = "Partner-Nr."
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(160, 20)
        Me.TextBox1.TabIndex = 10
        Me.TextBox1.Text = ""
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.Panel3.Location = New System.Drawing.Point(224, 8)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(368, 496)
        Me.Panel3.TabIndex = 2
        Me.Panel3.Visible = False
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.CTMenuVerantwortlicher
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines2
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(368, 496)
        Me.C1TrueDBGrid1.TabIndex = 0
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorW" & _
        "idth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1"">" & _
        "<ClientRect>0, 0, 364, 492</ClientRect><BorderSide>0</BorderSide><CaptionStyle p" & _
        "arent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRo" & _
        "wStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Sty" & _
        "le13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me" & _
        "=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle par" & _
        "ent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" />" & _
        "<OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSe" & _
        "lector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style par" & _
        "ent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles" & _
        "><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style par" & _
        "ent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent" & _
        "=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=" & _
        """Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=" & _
        """Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Head" & _
        "ing"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent" & _
        "=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</h" & _
        "orzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Clien" & _
        "tArea>0, 0, 364, 492</ClientArea></Blob>"
        '
        'TreeView1
        '
        Me.TreeView1.ContextMenu = Me.ctmenu1
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeView1.FullRowSelect = True
        Me.TreeView1.ImageList = Me.ImageList2
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Dokument", 0, 0, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Daten"), New System.Windows.Forms.TreeNode("Dokumentart"), New System.Windows.Forms.TreeNode("Dokumentstatus"), New System.Windows.Forms.TreeNode("Partner")}), New System.Windows.Forms.TreeNode("Ersteller", 8, 8, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Mutierer", 9, 9, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Verantwortlich", 7, 7, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")})})
        Me.TreeView1.Size = New System.Drawing.Size(216, 518)
        Me.TreeView1.TabIndex = 0
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=pc120;initial catalog=edoka;password=sqlsa;persist security info=True" & _
        ";user id=sa;workstation id=PC120;packet size=4096"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "ProfilDokAuswertung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp"), New System.Data.Common.DataColumnMapping("doktyp", "doktyp"), New System.Data.Common.DataColumnMapping("inklmavip", "inklmavip"), New System.Data.Common.DataColumnMapping("inklalt", "inklalt"), New System.Data.Common.DataColumnMapping("hostpartner", "hostpartner"), New System.Data.Common.DataColumnMapping("hostdokart", "hostdokart"), New System.Data.Common.DataColumnMapping("hostdoktyp", "hostdoktyp"), New System.Data.Common.DataColumnMapping("hosttag1", "hosttag1"), New System.Data.Common.DataColumnMapping("hostdatum1", "hostdatum1"), New System.Data.Common.DataColumnMapping("hosttag2", "hosttag2"), New System.Data.Common.DataColumnMapping("hostdatum2", "hostdatum2"), New System.Data.Common.DataColumnMapping("hosttag3", "hosttag3"), New System.Data.Common.DataColumnMapping("hostdatum3", "hostdatum3"), New System.Data.Common.DataColumnMapping("inklhostmavip", "inklhostmavip"), New System.Data.Common.DataColumnMapping("Expr1", "Expr1")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_ProfilDokAuswertung_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection3
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Expr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_ProfilDokAuswertung_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection3
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 255, "hosttag1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 255, "hostdatum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 255, "hosttag2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 255, "hostdatum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 255, "hosttag3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 255, "hostdatum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_ProfilDokAuswertung_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection3
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "Expr1"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_ProfilDokAuswertung_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection3
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 255, "hosttag1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 255, "hostdatum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 255, "hosttag2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 255, "hostdatum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 255, "hosttag3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 255, "hostdatum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Expr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmProfilDokAuswertung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(792, 577)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.Splitter1, Me.Button4, Me.Panel2, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmProfilDokAuswertung"
        Me.Text = "Profile Dokumentauswertung"
        Me.Panel2.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.pnlhostdiv.ResumeLayout(False)
        Me.PnlDokumentDaten.ResumeLayout(False)
        Me.PnlDokumentart.ResumeLayout(False)
        Me.PnlPartner.ResumeLayout(False)
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel3.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Load_Profil Method

Private Sub Load_Profil( _
   ByVal profilnr As Long _
)

Parameters

profilnr
Required.

Source code

[Visual Basic]
    Private Sub Load_Profil(ByVal profilnr As Long)
        Me.FirstNodeWithData = Nothing
        checkchanges = False
        Me.TreeView1.BeginUpdate()
        Me.TVDokart.BeginUpdate()
        Dim p As New edokadb.clsProfilDokAuswertung()
        Dim ma As New edokadb.clsMitarbeiter()
        Dim s As String
        Dim splitter
        Dim i As Integer
        p.cpMainConnectionProvider = conn
        conn.OpenConnection()
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()
        init_treeview1()

        'Selektion
        Try
            Set_Values(p.sVmb.Value, Me.tmb, 11)
            Set_Values(p.sVnl.Value, Me.tnl, 12)
            Set_Values(p.sVkost.Value, Me.tko, 13)
            Set_Values(p.sVteam.Value, Me.tte, 14)
            Set_Values(p.sVma.Value, Me.tpe, 15)

            Set_Values(p.sEmb.Value, Me.tmb, 21)
            Set_Values(p.sEnl.Value, Me.tnl, 22)
            Set_Values(p.sEkost.Value, Me.tko, 23)
            Set_Values(p.sEteam.Value, Me.tte, 24)
            Set_Values(p.sEma.Value, Me.tpe, 25)

            Set_Values(p.sMmb.Value, Me.tmb, 31)
            Set_Values(p.sMnl.Value, Me.tnl, 32)
            Set_Values(p.sMkost.Value, Me.tko, 33)
            Set_Values(p.sMteam.Value, Me.tte, 34)
            Set_Values(p.sMma.Value, Me.tpe, 35)
            Set_Values(p.sDpartner.Value, Me.tpe, 41)
            Set_Values(p.sDdokstatus.Value, Me.tst, 44)
            Set_Values(p.sDoktyp.Value, Me.tdt, 43)
            Set_Values(p.sDdokart.Value, Me.tst, 42)

            Set_Values(p.sHostpartner.Value, Me.tpe, 51)
            Set_Values(p.sHostdokart.Value, Me.tpe, 52)
            Set_Values(p.sHostdoktyp.Value, Me.tdh, 53)

            DivFnkt.Searchnode(Me.TreeView1, 42, 0)
            If DivFnkt.found Then
                If p.sDdokart.Value <> "" Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode(Me.TreeView1, 52, 0)
            If DivFnkt.found Then
                If p.sHostdokart.Value <> "" Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If
            'Unterschriften/Hinweise

            Me.mcbunterschriftlinks.SelectedValue = p.iUnterschriftlinks.Value
            Me.mcbunterschriftrechts.SelectedValue = p.iUnterschriftrechts.Value
            Me.mcbTeam.SelectedValue = p.iTeam.Value
            '            If p.iHw1.IsNull Then p.iHw1 = 0
            '            If p.iHw2.IsNull Then p.iHw2 = 0
            '            If p.iHw3.IsNull Then Me.cb3 = False Else Me.cb3.Checked = p.iHw3.Value
            '            If p.iHw4.IsNull Then Me.cb4.Checked = False Else Me.cb4.Checked = p.iHw4.Value
            '            If p.iHw5.IsNull Then Me.cb5.Checked = False Else Me.cb5.Checked = p.iHw5.Value'

            'Darstellung/Sortierung
            Try
                'Me.colbtn1.BackColor = colconv.ConvertFromString(p.sColor1.Value)
                'Me.colbtn2.BackColor = colconv.ConvertFromString(p.sColor2.Value)
                'Me.colbtn3.BackColor = colconv.ConvertFromString(p.sColor3.Value)
                'Me.colbtn4.BackColor = colconv.ConvertFromString(p.sColor4.Value)
                'Me.colbtn5.BackColor = colconv.ConvertFromString(p.sColor5.Value)
                'Me.colbtn6.BackColor = colconv.ConvertFromString(p.sColor6.Value)
            Catch
            End Try

            'Me.lbselect.Items.Clear()
            s = p.sSort.Value
            Try
                splitter = Microsoft.VisualBasic.Split(s, ";")
                i = 0
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        'Me.lbselect.Items.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try

            Me.cbtag1.Text = p.sDatum2.Value
            Me.cbtag2.Text = p.sDatum4.Value
            Me.cbtag3.Text = p.sDatum6.Value
            Me.txtdatum1.Text = p.sDatum1.Value
            Me.txtdatum3.Text = p.sDatum3.Value
            Me.txtdatum5.Text = p.sDatum5.Value

            Me.HostDatum1.Text = p.sHostdatum1.Value
            Me.HostDatum2.Text = p.sHostdatum2.Value
            Me.HostDatum3.Text = p.sHostdatum3.Value
            Me.HostTag1.Text = p.sHosttag1.Value
            Me.HostTag2.Text = p.sHosttag2.Value
            Me.HostTag3.Text = p.sHosttag3.Value
            Me.hostinklmavip.Checked = p.bInklhostmavip.Value = True

            If Me.cbtag1.Text <> "" Or Me.cbtag2.Text <> "" Or Me.cbtag3.Text <> "" Or Me.txtdatum1.Text <> "(heute)" Or _
            Me.txtdatum3.Text <> "(heute)" Or Me.txtdatum5.Text <> "(heute)" Or Me.hostinklmavip.Checked = True Then
                DivFnkt.Searchnode(Me.TreeView1, 45, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If
            If Me.HostTag1.Text <> "" Or Me.HostTag2.Text <> "" Or Me.HostTag3.Text <> "" Or Me.HostDatum1.Text <> "(heute)" Or _
            Me.HostDatum2.Text <> "(heute)" Or Me.HostDatum3.Text <> "(heute)" Then
                DivFnkt.Searchnode(Me.TreeView1, 55, 0)
                If DivFnkt.found Then
                    '       DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            Me.cbmavip.Checked = p.bInklmavip.Value = True
            Me.cinklalt.Checked = p.bInklalt.Value = True

            p.Dispose()

            'Profilunabhängige Daten
            ma.cpMainConnectionProvider = conn
            ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            ma.SelectOne()
            Try
                '               Me.FirstNodeWithData.ForeColor = System.Drawing.Color.Blue
            Catch
            End Try
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
        conn.CloseConnection(True)
        Me.TreeView1.EndUpdate()
        Me.TVDokart.EndUpdate()
        checkchanges = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        If MyMsg.Show_MessageYesNo(16) = MsgBoxResult.Yes Then
            Dim p As New edokadb.clsProfilDokAuswertung()
            p.cpMainConnectionProvider = conn
            Me.Profile_Geaendert = True
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(False, Boolean))
            p.Update()
            p.Dispose()
            conn.CloseConnection(True)
            Me.ProfilNr = 0
            frmProfilDokAuswertung_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        check_changes()
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfilDokAuswertung()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("profildokauswertung")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(0, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(True, Boolean))
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.sVma = New SqlString(CType(Globals.MitarbeiterNr, String))

            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.frmProfilDokAuswertung_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem13_Click Method

Private Sub MenuItem13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfilDokAuswertung()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("ProfilDokAuswertung")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
            p.SelectOne()
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.frmProfilDokAuswertung_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        Try
            Me.C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        Try
            If Me.PartnerList.Columns(0).Value > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem20_Click Method

Private Sub MenuItem20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem20.Click
        Try
            C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Try
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.TVDokart.BeginUpdate()
                Me.TVDokart.SelectedNode.ExpandAll()
                Me.TVDokart.EndUpdate()
            Else
                Me.TVHostDok.BeginUpdate()
                Me.TVHostDok.SelectedNode.ExpandAll()
                Me.TVHostDok.EndUpdate()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.Collapse()
        Else
            Me.TVHostDok.SelectedNode.Collapse()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        'Schliessen
        m_sDislpayResult = "Profilname = " & Profile.SelectedNode.Text
        m_sNavigationResult = Profile.SelectedNode.Tag
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Try
            Dim tn As TreeNode
            Dim p As New edokadb.clsProfilDokAuswertung()
            p.cpMainConnectionProvider = conn
            Me.Profile.BeginUpdate()
            tn = Me.Profile.Nodes(0)
            Do Until tn Is Nothing
                If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                    conn.OpenConnection()
                    p.iProfilnr = New SqlInt32(CType(tn.Tag, Int32))
                    p.SelectOne()
                    p.bStandard = New SqlBoolean(CType(False, Boolean))
                    p.Update()
                    conn.CloseConnection(True)
                End If
                tn.BackColor = System.Drawing.Color.White
                tn = tn.NextNode
            Loop
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bStandard = New SqlBoolean(CType(True, Boolean))
            p.Update()
            conn.CloseConnection(True)
            p.Dispose()
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.LightBlue
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Try
            Dim a As String
            a = InputBox(MyTxt.gettext(501))
            If a <> "" Then
                Me.Profile_Geaendert = True
                Me.Profile.SelectedNode.Text = a
                Me.Profname = a
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MnDel_Click Method

Private Sub MnDel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnDel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDel.Click
        Try
            Dim tn As TreeNode
            tn = TreeView1.SelectedNode
            tn.Remove()
            changes = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MnuDeleteDokumentart_Click Method

Private Sub MnuDeleteDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 2
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Black
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 2
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Black
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MnuListe_Popup Method

Private Sub MnuListe_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MnuListe.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuListe_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MnuListe.Popup
        Dim i As Integer
        If Me.Profil_Ungueltig = True Then
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = False
            Next
        Else
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = True
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.MnuSelectDokumentart_Click Method

Private Sub MnuSelectDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSelectDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSelectDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSelectDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 1
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Red
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 1
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Red
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Panel1_Paint Method

Private Sub Panel1_Paint( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
) Handles Panel1.Paint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Panel1_Paint(ByVal sender As System.Object, ByVal e As System.Windows.Forms.PaintEventArgs) Handles Panel1.Paint

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.PartnerList_FetchRowStyle Method

Private Sub PartnerList_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles PartnerList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles PartnerList.FetchRowStyle
        If Microsoft.VisualBasic.Left(Me.PartnerList.Columns(0).CellValue(e.Row), 1) = "9" Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Profil_Colors Method

Private Function Profil_Colors()

Source code

[Visual Basic]
    Private Function Profil_Colors()
        Dim tn As TreeNode
        Me.Profile.BeginUpdate()
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                tn.BackColor = System.Drawing.Color.LightBlue
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
            tn = tn.NextNode
        Loop
        Try
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.Silver
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Profile_AfterSelect Method

Private Sub Profile_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles Profile.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles Profile.AfterSelect
        If Not On_Load Then
            check_changes()
            If Me.Profil_Ungueltig Then
                Me.Profile.SelectedNode = Me.savenode
                MyMsg.show_standardmessage(105, MsgBoxStyle.Critical)
                Exit Sub
            End If
            Me.savenode = Me.Profile.SelectedNode
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            check_changes()
            Me.ProfilNr = Me.Profile.SelectedNode.Tag
            init_treeview1()
            frmProfilDokAuswertung_Load(sender, e)
            Me.TreeView1.SelectedNode = Nothing
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Profile_MouseDown Method

Private Sub Profile_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Profile.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Profile.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                Profile.SelectedNode = Profile.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Save_Profile Method

Private Sub Save_Profile()

Source code

[Visual Basic]
    Private Sub Save_Profile()
        Dim p As New edokadb.clsProfilDokAuswertung()
        Dim tn As TreeNode
        Dim d As DataTable
        Dim tmptreeview As New TreeView()
        p.cpMainConnectionProvider = conn
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()

        'Selektion
        Dim s As String

        Dim i As Integer
        Me.TreeView1.BeginUpdate()
        p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))

        p.sVmb = New SqlString(CType(GetNodeDatastring(11), String))
        p.sVnl = New SqlString(CType(GetNodeDatastring(12), String))
        p.sVkost = New SqlString(CType(GetNodeDatastring(13), String))
        p.sVteam = New SqlString(CType(GetNodeDatastring(14), String))
        p.sVma = New SqlString(CType(GetNodeDatastring(15), String))

        p.sEmb = New SqlString(CType(GetNodeDatastring(21), String))
        p.sEnl = New SqlString(CType(GetNodeDatastring(22), String))
        p.sEkost = New SqlString(CType(GetNodeDatastring(23), String))
        p.sEteam = New SqlString(CType(GetNodeDatastring(24), String))
        p.sEma = New SqlString(CType(GetNodeDatastring(25), String))

        p.sMmb = New SqlString(CType(GetNodeDatastring(31), String))
        p.sMnl = New SqlString(CType(GetNodeDatastring(32), String))
        p.sMkost = New SqlString(CType(GetNodeDatastring(33), String))
        p.sMteam = New SqlString(CType(GetNodeDatastring(34), String))
        p.sMma = New SqlString(CType(GetNodeDatastring(35), String))

        p.sDpartner = New SqlString(CType(GetNodeDatastring(41), String))
        p.sDoktyp = New SqlString(CType(GetNodeDatastring(43), String))
        p.sDdokstatus = New SqlString(CType(GetNodeDatastring(44), String))

        p.sHostpartner = New SqlString(CType(GetNodeDatastring(51), String))
        p.sHostdoktyp = New SqlString(CType(GetNodeDatastring(53), String))
        p.bInklhostmavip = New SqlBoolean(CType(Me.hostinklmavip.Checked, Boolean))

        tmptreeview = Me.TVDokart
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        'tmptreeview.Dispose()
        p.sDdokart = New SqlString(CType(s, String))

        tmptreeview = Me.TVHostDok
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        p.sHostdokart = New SqlString(CType(s, String))

        p.bInklmavip = New SqlBoolean(CType(Me.cbmavip.Checked, Boolean))
        p.bInklalt = New SqlBoolean(CType(Me.cinklalt.Checked, Boolean))

        p.sSort = New SqlString(CType(s, String))

        If Me.mcbTeam.SelectedText = Nothing Then
            p.iTeam = New SqlInt32(CType(0, Int32))
        Else
            p.iTeam = New SqlInt32(CType(Me.mcbTeam.SelectedValue, Int32))
        End If

        If colconv.ConvertToString(Me.Profile.SelectedNode.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Or p.bStandard.Value = True Then
            p.bStandard = New SqlBoolean(CType(True, Boolean))
        Else
            p.bStandard = New SqlBoolean(CType(False, Boolean))
        End If

        p.sDatum1 = New SqlString(CType(Me.txtdatum1.Text, String))
        p.sDatum3 = New SqlString(CType(Me.txtdatum3.Text, String))
        p.sDatum5 = New SqlString(CType(Me.txtdatum5.Text, String))
        p.sDatum2 = New SqlString(CType(Me.cbtag1.Text, String))
        p.sDatum4 = New SqlString(CType(Me.cbtag2.Text, String))
        p.sDatum6 = New SqlString(CType(Me.cbtag3.Text, String))

        p.sHostdatum1 = New SqlString(CType(Me.HostDatum1.Text, String))
        p.sHostdatum2 = New SqlString(CType(Me.HostDatum2.Text, String))
        p.sHostdatum3 = New SqlString(CType(Me.HostDatum3.Text, String))
        p.sHosttag1 = New SqlString(CType(Me.HostTag1.Text, String))
        p.sHosttag2 = New SqlString(CType(Me.HostTag2.Text, String))
        p.sHosttag3 = New SqlString(CType(Me.HostTag3.Text, String))

        Dim s1 As String
        Dim s2 As String

        '        s1 = p.sHostdatum1.Value + p.sHostdatum2.Value + p.sHostdatum3.Value + p.sHostdokart.Value + p.sHostdoktyp.Value + p.sHostpartner.Value + p.sHosttag1.Value + p.sHosttag2.Value + p.sHosttag3.Value
        '       s2 = p.sVmb.Value + p.sVnl.Value + p.sVkost.Value + p.sVteam.Value + p.sVma.Value + _
        '           p.sEmb.Value + p.sEnl.Value + p.sEkost.Value + p.sEteam.Value + p.sEma.Value + _
        '          p.sMmb.Value + p.sMnl.Value + p.sMkost.Value + p.sMteam.Value + p.sMma.Value + _
        '         p.sDpartner.Value + p.sDoktyp.Value + p.sDdokart.Value + p.sDdokstatus.Value + p.sDatum1.Value + p.sDatum2.Value + p.sDatum3.Value + p.sDatum4.Value + p.sDatum5.Value

        '        If s1 = "(heute)(heute)(heute)" And s2 = "(heute)(heute)(heute)" Then
        '           MyMsg.show_standardmessage(91, MsgBoxStyle.Critical)
        '          p.Dispose()
        '         Me.TreeView1.EndUpdate()
        '        Exit Sub
        '   End If
        '        If s1 <> "" And s2 <> "" Then
        '           Dim a As Integer
        '          a = MyMsg.Show_MessageYesNoCancel(90)
        '         If a = MsgBoxResult.Cancel Then
        '            p.Dispose()
        '           Me.TreeView1.EndUpdate()
        '          Exit Sub
        '     End If
        ''    If a = MsgBoxResult.Yes Then
        '                p.sHostpartner = New SqlString(CType("", String))
        '               p.sHostdokart = New SqlString(CType("", String))
        '              p.sHostdoktyp = New SqlString(CType("", String))
        '             p.sHostdatum1 = New SqlString(CType("", String))
        '            p.sHostdatum2 = New SqlString(CType("", String))
        '           p.sHostdatum3 = New SqlString(CType("", String))
        '          p.bInklhostmavip = New SqlBoolean(CType(False, Boolean))
        ''         If plausi_edoka(p) = False Then
        '           p.Dispose()
        '          Me.TreeView1.EndUpdate()
        '         Exit Sub
        '    End If
        '            Else
        '               p.sVmb = New SqlString(CType("", String))
        '              p.sVnl = New SqlString(CType("", String))
        '             p.sVkost = New SqlString(CType("", String))
        '            p.sVteam = New SqlString(CType("", String))
        '           p.sVma = New SqlString(CType("0", String))
        '
        '               p.sEmb = New SqlString(CType("", String))
        '              p.sEnl = New SqlString(CType("", String))
        '             p.sEkost = New SqlString(CType("", String))
        '            p.sEteam = New SqlString(CType("", String))
        '           p.sEma = New SqlString(CType("", String))
        '
        '               p.sMmb = New SqlString(CType("", String))
        '              p.sMnl = New SqlString(CType("", String))
        '             p.sMkost = New SqlString(CType("", String))
        '            p.sMteam = New SqlString(CType("", String))
        '           p.sMma = New SqlString(CType("", String))
        '
        '               p.sDpartner = New SqlString(CType("", String))
        '              p.sDoktyp = New SqlString(CType("", String))
        '             p.sDdokstatus = New SqlString(CType("", String))
        '            p.bInklmavip = New SqlBoolean(CType(False, Boolean))
        '           p.bInklalt = New SqlBoolean(CType(False, Boolean))
        '          If plausi_host(p) = False Then
        '             p.Dispose()
        '            Me.TreeView1.EndUpdate()
        '           Exit Sub
        '      End If
        ' End If
        'End If

        If Me.Profname <> "" Then p.sBezeichnung = New SqlString(CType(Profname, String))
        conn.OpenConnection()
        p.Update()

        conn.CloseConnection(True)
        p.Dispose()
        Me.TreeView1.EndUpdate()
        changes = False
        Me.Load_Profil(Me.ProfilNr)
        Me.TreeView1.ExpandAll()
        Me.Profil_Ungueltig = False
        If Me.FirstNodeWithData Is Nothing Then
            Me.Profil_Ungueltig = True
            Exit Sub
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Set_Values Method

Private Sub Set_Values( _
   ByVal data As String, _
   ByVal ds As DataTable, _
   ByVal node As Integer _
)

Parameters

data
Required.
ds
Required.
node
Required.

Source code

[Visual Basic]
    Private Sub Set_Values(ByVal data As String, ByVal ds As DataTable, ByVal node As Integer)
        Dim splitter
        Dim i As Integer
        Dim s As String
        Dim tn As TreeNode
        Dim dv As New DataTable()
        Dim i1 As Integer
        Dim v As Double
        If node = 11 Or node = 21 Or node = 31 Then
            dv = Me.tmb
        End If
        If node = 12 Or node = 22 Or node = 32 Then
            dv = Me.tnl
        End If
        If node = 13 Or node = 23 Or node = 33 Then
            dv = Me.tko
        End If
        If node = 14 Or node = 24 Or node = 34 Then
            dv = Me.tte
        End If
        If node = 15 Or node = 25 Or node = 35 Then
            dv = Me.tpe
        End If
        If node = 43 Then dv = Me.tdt
        If node = 53 Then dv = Me.tdh
        If node = 44 Then dv = Me.tst
        s = data
        splitter = Microsoft.VisualBasic.Split(s, ";")
        i = 0
        Try
            Do Until splitter(i) Is Nothing
                If node <> 41 And node <> 42 And node <> 51 Then
                    For i1 = 0 To dv.Rows.Count - 1
                        v = Val(splitter(i))
                        If dv.Rows(i1).Item(0) = splitter(i) Then
                            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
                            If DivFnkt.found Then
                                If Me.FirstNodeWithData Is Nothing Then
                                    Me.FirstNodeWithData = DivFnkt.FoundNode
                                End If
                                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                tn = Me.TreeView1.SelectedNode
                                tn = tn.Nodes.Add(dv.Rows(i1).Item(1))
                                tn.Tag = dv.Rows(i1).Item(0)
                                tn.ImageIndex = 4
                                tn.SelectedImageIndex = 4
                                If dv.Rows(i1).Item(2) = False Then
                                    tn.ForeColor = System.Drawing.Color.Gray
                                Else
                                    tn.ForeColor = System.Drawing.Color.Red
                                End If
                            End If

                        End If

                    Next
                    i = i + 1
                End If
                If node = 41 Or node = 51 Then
                    Dim p As New edokadb.clsPartner()
                    Try
                        DivFnkt.Searchnode1(Me.TreeView1, node, 0)
                        If DivFnkt.found Then
                            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                            tn = Me.TreeView1.SelectedNode
                            p.cpMainConnectionProvider = conn
                            p.iNRPAR00 = New SqlInt32(CType(splitter(i), Int32))
                            p.SelectOne()
                            tn = tn.Nodes.Add(splitter(i) + " - " + p.sBKPAR00.Value)
                            tn.Tag = splitter(i)
                            If Me.FirstNodeWithData Is Nothing Then
                                Me.FirstNodeWithData = DivFnkt.FoundNode
                            End If
                            tn.ImageIndex = 4
                            tn.SelectedImageIndex = 4
                            tn.ForeColor = System.Drawing.Color.Red
                        End If
                    Catch ex As Exception
                        'MsgBox(ex.Message)
                    Finally
                        p.Dispose()
                        i = i + 1
                    End Try
                End If
                If node = 42 Then
                    Try
                        DivFnkt.Searchnode(Me.TVDokart, splitter(i), 0)
                        If DivFnkt.found Then
                            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
                            DivFnkt.FoundNode.ImageIndex = 1
                            If Not DivFnkt.FoundNode.Parent.IsExpanded Then DivFnkt.FoundNode.Parent.ExpandAll()
                        End If
                    Catch
                    End Try
                    i = i + 1
                End If
                If node = 52 Then
                    Try
                        DivFnkt.Searchnode(Me.TVHostDok, splitter(i), 0)
                        If DivFnkt.found Then
                            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
                            DivFnkt.FoundNode.ImageIndex = 1
                            If Not DivFnkt.FoundNode.Parent.IsExpanded Then DivFnkt.FoundNode.Parent.ExpandAll()
                        End If
                    Catch
                    End Try
                End If
            Loop
        Catch ex As Exception
            '            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        t = partner
        ts.Tabelle = "Partner"
        For i = 0 To Me.PartnerList.Columns.Count - 1
            s = Me.PartnerList.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.PartnerList.Columns(i).Caption = ts.spaltenname
            If Me.PartnerList.Columns(i).Caption = "" Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            '            If Me.PartnerList.Columns(i).Caption = "" Then Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            If ts.locked Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.PartnerList.Columns(i).DataField = "aktiv" Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.PartnerList.Columns(i).ValueItems.DefaultItem = True
                Me.PartnerList.Columns(i).DefaultValue = True
                Me.PartnerList.Columns(i).FilterText = True
            End If
            If Me.PartnerList.Columns(i).DataField = "erstellt_am" Then
                Me.PartnerList.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.TVDokart_DoubleClick Method

Private Sub TVDokart_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TVDokart.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVDokart_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles TVDokart.DoubleClick
        '        If Me.TVDokart.SelectedNode.ImageIndex <> 1 Then
        '           Me.TVDokart.SelectedNode.ImageIndex = 1
        '          Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Red
        '     Else
        '        Me.TVDokart.SelectedNode.ImageIndex = 2
        '       Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Black
        '  End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.TVDokart_MouseDown Method

Private Sub TVDokart_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVDokart.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVDokart_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVDokart.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TVDokart.SelectedNode = TVDokart.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox1.KeyDown, _
   TextBox2.KeyDown, _
   TextBox3.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox1.KeyDown, TextBox2.KeyDown, TextBox3.KeyDown
        If e.KeyCode = Keys.Return Then btnPartnersuche_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.MenuItem5_Click(sender, e)       'Schliessen
            Case 1
            Case 2                                  'Save
                Save_Profile()
                If Me.Profil_Ungueltig = True Then MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.TreeView1_AfterSelect Method

Private Sub TreeView1_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect
        If On_Load Then Exit Sub

        Me.PnlDokumentDaten.Visible = False
        Me.Panel3.Visible = False
        Me.PnlPartner.Visible = False
        Me.PnlDokumentart.Visible = False
        Me.TVDokart.Visible = False
        Me.TVHostDok.Visible = False
        Me.pnlhostdiv.Visible = False

        Try
            If Me.TreeView1.SelectedNode.ImageIndex < 6 Then
                Me.TreeView1.SelectedNode.ImageIndex = 4
                Me.TreeView1.SelectedNode.SelectedImageIndex = 4
            End If
            If Me.TreeView1.SelectedNode.Tag = 11 Or Me.TreeView1.SelectedNode.Tag = 21 Or Me.TreeView1.SelectedNode.Tag = 31 Then
                Me.C1TrueDBGrid1.DataSource = tmb
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 12 Or Me.TreeView1.SelectedNode.Tag = 22 Or Me.TreeView1.SelectedNode.Tag = 32 Then
                Me.C1TrueDBGrid1.DataSource = tnl
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 13 Or Me.TreeView1.SelectedNode.Tag = 23 Or Me.TreeView1.SelectedNode.Tag = 33 Then
                Me.C1TrueDBGrid1.DataSource = tko
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 14 Or Me.TreeView1.SelectedNode.Tag = 24 Or Me.TreeView1.SelectedNode.Tag = 34 Then
                Me.C1TrueDBGrid1.DataSource = tte
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 15 Or Me.TreeView1.SelectedNode.Tag = 25 Or Me.TreeView1.SelectedNode.Tag = 35 Then
                Me.C1TrueDBGrid1.DataSource = tpe
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.PnlDokumentart.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 43 Then
                Me.C1TrueDBGrid1.DataSource = tdt
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 44 Then
                Me.C1TrueDBGrid1.DataSource = tst
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 45 Then
                Me.Panel3.Visible = False
                Me.PnlDokumentDaten.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            'Edoka-Dokument
            If Me.TreeView1.SelectedNode.Tag = 41 Then
                Me.Panel3.Visible = False
                Me.PnlDokumentDaten.Visible = False
                Me.PnlPartner.Visible = True
                Me.TextBox1.Focus()
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            'Host-Partner
            If Me.TreeView1.SelectedNode.Tag = 51 Then
                Me.Panel3.Visible = False
                Me.PnlDokumentDaten.Visible = False
                Me.PnlPartner.Visible = True
                Me.TextBox1.Focus()
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.TVDokart.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 52 Then
                Me.TVHostDok.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 53 Then
                Me.C1TrueDBGrid1.DataSource = tdh
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 55 Then
                Me.pnlhostdiv.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            Dim i As Integer
            For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
                If i <> 1 And i <> 2 Then
                    Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
                Else
                    If i = 1 Then
                        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = Me.C1TrueDBGrid1.Width - 150
                    Else
                        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = 100
                    End If
                End If
            Next
        Catch
        End Try
        Try
            Me.C1TrueDBGrid1.Columns(2).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            Me.C1TrueDBGrid1.Columns(2).FilterText = True
        Catch
        End Try

        'Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.Treeview1_MouseDown Method

Private Sub Treeview1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Treeview1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TreeView1.SelectedNode = TreeView1.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.ValueList Method

Private Function ValueList( _
   ByVal c As ListView _
) As String

Parameters

c
Required.

Source code

[Visual Basic]
    Private Function ValueList(ByVal c As ListView) As String
        Dim s As String
        s = ""
        For i = 0 To c.Items.Count - 1
            s = s + c.Items(i).Text + ";"
            If UCase(c.Name) = "SELPARTNER" Then
                li = c.Items(i)
                s = s + li.SubItems(1).Text + ";"
            End If
        Next
        Return s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.btnPartnersuche_Click Method

Private Sub btnPartnersuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnersuche.Click
        Me.PartnerList.DataSource = Nothing
        Me.PartnerList.DataMember = Nothing
        If Me.TextBox1.Text <> "" Then
            Try
                Dim d As Double
                d = Val(Me.TextBox1.Text)
                If d = 0 Then
                    MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                    Me.TextBox1.Focus()
                    Exit Sub
                End If
                partner = mypartner.search_partner(d, 50, 0)
            Catch
                MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                Me.TextBox1.Focus()
                Exit Sub
            End Try
        Else
            If Me.TextBox2.Text <> "" Then
                partner = mypartner.search_partner(Me.TextBox2.Text, 50, 1)
            Else
                partner = mypartner.search_partner(Me.TextBox3.Text, 50, 2)
            End If
        End If
        If partner.Rows.Count = 0 Then
            MyMsg.show_standardmessage(204, MsgBoxStyle.Exclamation)
        Else
            Me.PartnerList.DataSource = partner
            Me.PartnerList.DataMember = "Partner"
            SpaltenTitel_Aktualisieren()
            Dim i As Long
            Dim ii As Long
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.cbtag1_TextChanged Method

Private Sub cbtag1_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbtag1.TextChanged, _
   txtdatum1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbtag1_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbtag1.TextChanged, txtdatum1.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lbldatum1.Text = ""
        Try
            i = Val(Me.cbtag1.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.txtdatum1.Text
        Catch
            d = Today
        End Try
        Me.lbldatum1.Text = DateAdd(DateInterval.Day, i, d)
        If Me.txtdatum1.Text = "" Then Me.txtdatum1.Text = "(heute)"
        If Me.cbtag1.Text = "" Then Me.lbldatum1.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.cbtag2_TextChanged Method

Private Sub cbtag2_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbtag2.TextChanged, _
   txtdatum3.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbtag2_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbtag2.TextChanged, txtdatum3.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lbldatum2.Text = ""
        Try
            i = Val(Me.cbtag2.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.txtdatum3.Text
        Catch
            d = Today
        End Try
        Me.lbldatum2.Text = DateAdd(DateInterval.Day, i, d)
        If Me.txtdatum3.Text = "" Then Me.txtdatum3.Text = "(heute)"
        If Me.cbtag2.Text = "" Then Me.lbldatum2.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.cbtag3_TextChanged Method

Private Sub cbtag3_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbtag3.TextChanged, _
   txtdatum5.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbtag3_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbtag3.TextChanged, txtdatum5.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lbldatum3.Text = ""
        Try
            i = Val(Me.cbtag3.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.txtdatum5.Text
        Catch
            d = Today
        End Try
        Me.lbldatum3.Text = DateAdd(DateInterval.Day, i, d)
        If Me.txtdatum5.Text = "" Then Me.txtdatum5.Text = "(heute)"
        If Me.cbtag3.Text = "" Then Me.lbldatum3.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        If On_Load Then Exit Sub
        If changes Then
            If Me.FirstNodeWithData Is Nothing Then
                Me.Profil_Ungueltig = True
            End If
            If MyMsg.Show_MessageYesNo(2) = MsgBoxResult.Yes Then
                Me.Save_Profile()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.frmProfilDokAuswertung_Load Method

Private Sub frmProfilDokAuswertung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfilDokAuswertung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Cursor = Cursors.WaitCursor
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        On_Load = True
        Me.Profile.BeginUpdate()
        checkchanges = False
        changes = False
        Me.Profile.Nodes.Clear()
        Me.DataSet1.Clear()
        'Personendaten
        Dim tn, tn1 As TreeNode
        If first Then
            init_treeview1()
            tmb = Generic_Select(3)
            tnl = Generic_Select(4)
            tko = Generic_Select(5)
            tte = Generic_Select(6)
            tst = Generic_Select(2)
            tpe = Generic_Select(1)
            tdt = Generic_Select(7)
            tdh = Generic_Select(8)

            Me.mcbTeam.DisplayColumnName = "Bezeichnung"
            Me.mcbTeam.ValueColumnName = "teamnr"
            Me.mcbTeam.Fill_Data(tte, True)
            Me.mcbTeam.Visible = True
            Me.mcbTeam.CheckNullValue = False

        End If

        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        tda = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        hdata.Dispose()

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)

        If Me.DataSet1.Tables(0).Rows.Count = 0 Then

            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Long
            dbkey.cpMainConnectionProvider = conn
            conn.OpenConnection()
            key = dbkey.get_dbkey("ProfilDokAuswertung")
            conn.CloseConnection(True)
            dbkey.Dispose()
            Dim objProfilDokauswertung As New edokadb.clsProfilDokAuswertung()
            objProfilDokauswertung.iProfilnr = New SqlInt32(CType(0, Int32))
            objProfilDokauswertung.cpMainConnectionProvider = conn
            objProfilDokauswertung.SelectOne()
            objProfilDokauswertung.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            objProfilDokauswertung.iProfilnr = New SqlInt32(CType(key, Int32))
            objProfilDokauswertung.sBezeichnung = New SqlString(CType("Standard", String))
            conn.OpenConnection()
            objProfilDokauswertung.Insert()
            conn.CloseConnection(True)
            Me.DataSet1.Clear()
            Me.SqlDataAdapter1.Fill(Me.DataSet1)
            Me.ProfilNr = Me.DataSet1.Tables(0).Rows(0).Item("ProfilNr")
        End If
        For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
            tn = Me.Profile.Nodes.Add(Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung"))
            tn.Tag = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
            If Me.DataSet1.Tables(0).Rows(i).Item("standard") Then
                tn.BackColor = System.Drawing.Color.LightBlue
                If Me.ProfilNr = 0 Then Me.ProfilNr = tn.Tag
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
        Next
        If Me.DataSet1.Tables(0).Rows.Count > 0 And Me.ProfilNr = 0 Then
            Me.ProfilNr = Me.DataSet1.Tables(0).Rows(0).Item("ProfilNr")
        End If
        first = False
        Load_Profil(Me.ProfilNr)
        checkchanges = False
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If tn.Tag = Me.ProfilNr Then Me.Profile.SelectedNode = tn
            tn = tn.NextNode
        Loop
        On_Load = False
        first = False
        Me.TreeView1.ExpandAll()
        Profil_Colors()
        checkchanges = True
        Me.Profile.EndUpdate()
        Profname = ""
        Activate_Details()
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.frmProfil_Closing Method

Private Sub frmProfil_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        check_changes()
        If Me.Profil_Ungueltig Then
            MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
            e.Cancel = True
        Else
            e.Cancel = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.hosttag1_TextChanged Method

Private Sub hosttag1_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles HostTag1.TextChanged, _
   HostDatum1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hosttag1_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles HostTag1.TextChanged, HostDatum1.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lblhostdatum1.Text = ""
        Try
            i = Val(Me.HostTag1.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.HostDatum1.Text
        Catch
            d = Today
        End Try
        Me.lblhostdatum1.Text = DateAdd(DateInterval.Day, i, d)
        If Me.HostDatum1.Text = "" Then Me.HostDatum1.Text = "(heute)"
        If Me.HostTag1.Text = "" Then Me.lblhostdatum1.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.hosttag2_TextChanged Method

Private Sub hosttag2_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles HostTag2.TextChanged, _
   HostDatum2.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hosttag2_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles HostTag2.TextChanged, HostDatum2.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lblhostdatum2.Text = ""
        Try
            i = Val(Me.HostTag2.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.HostDatum2.Text
        Catch
            d = Today
        End Try
        Me.lblhostdatum2.Text = DateAdd(DateInterval.Day, i, d)
        If Me.HostDatum2.Text = "" Then Me.HostDatum2.Text = "(heute)"
        If Me.HostTag2.Text = "" Then Me.lblhostdatum2.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.hosttag3_TextChanged Method

Private Sub hosttag3_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles HostTag3.TextChanged, _
   HostDatum3.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hosttag3_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles HostTag3.TextChanged, HostDatum3.TextChanged
        Dim d As Date
        Dim i As Integer
        Me.lblhostdatum3.Text = ""
        Try
            i = Val(Me.HostTag3.Text) * -1
        Catch
            Exit Sub
        End Try
        Try
            d = Me.HostDatum3.Text
        Catch
            d = Today
        End Try
        Me.lblhostdatum3.Text = DateAdd(DateInterval.Day, i, d)
        If Me.HostDatum3.Text = "" Then Me.HostDatum3.Text = "(heute)"
        If Me.HostTag3.Text = "" Then Me.lblhostdatum3.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.init_treeview1 Method

Private Function init_treeview1()

Source code

[Visual Basic]
    Private Function init_treeview1()
        Me.TreeView1.Nodes.Clear()
        Dim tn, tn1 As TreeNode
        TreeView1.BeginUpdate()
        Me.TreeView1.Nodes.Clear()
        tn = Me.TreeView1.Nodes.Add("Verantwortlich")
        tn.ImageIndex = 7
        tn.SelectedImageIndex = 7
        tn.Tag = 1
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 11
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 12
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 13
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 14
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 15
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4

        tn = Me.TreeView1.Nodes.Add("Ersteller")
        tn.ImageIndex = 8
        tn.SelectedImageIndex = 8
        tn.Tag = 2
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 21
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 22
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 23
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 24
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 25
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn = Me.TreeView1.Nodes.Add("Mutierer")
        tn.ImageIndex = 9
        tn.SelectedImageIndex = 9
        tn.Tag = 3
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 31
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 32
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 33
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 34
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 35
        tn1.ImageIndex = 4

        tn = Me.TreeView1.Nodes.Add("EDOKA-Dokumente")
        tn.ImageIndex = 6
        tn.SelectedImageIndex = 6
        tn.Tag = 4
        tn1 = tn.Nodes.Add("Partner")
        tn1.Tag = 41
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Dokumentart")
        tn1.Tag = 42
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 43
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Dokumentstatus")
        tn1.Tag = 44
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Diverse")
        tn1.Tag = 45
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        '        tn = Me.TreeView1.Nodes.Add("Host-Dokumente")
        '       tn.ImageIndex = 6
        '      tn.SelectedImageIndex = 6
        '     tn.Tag = 5
        '    tn1 = tn.Nodes.Add("Partner")
        '        tn1.Tag = 51
        '       tn1.ImageIndex = 4
        '      tn1.SelectedImageIndex = 4
        '     tn1 = tn.Nodes.Add("Dokumentart")
        '    tn1.Tag = 52
        '   tn1.ImageIndex = 4
        '  tn1.SelectedImageIndex = 4

        ' tn1 = tn.Nodes.Add("Dokumenttyp")
        'tn1.Tag = 53
        '        t() n1.ImageIndex = 4
        '       tn1.SelectedImageIndex = 4

        '        tn1 = tn.Nodes.Add("Dokumentstatus")
        '       tn1.Tag = 54
        '      tn1.ImageIndex = 4
        '     tn1.SelectedImageIndex = 4

        '      tn1 = tn.Nodes.Add("Diverse")
        '     tn1.Tag = 55
        '    tn1.ImageIndex = 4
        '   tn1.SelectedImageIndex = 4

        Me.TVDokart.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVDokart, 2)
        Me.TVDokart.CollapseAll()

        Me.TVHostDok.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVHostDok, 3)
        Me.TVHostDok.ExpandAll()

        Me.TreeView1.EndUpdate()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.mcb_Changed Method

Private Sub mcb_Changed( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbunterschriftlinks.SelectedValueChanged, _
   mcbunterschriftrechts.SelectedValueChanged, _
   mcbTeam.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcb_Changed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbunterschriftlinks.SelectedValueChanged, mcbunterschriftrechts.SelectedValueChanged, mcbTeam.SelectedValueChanged
        If checkchanges Then
            changes = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.plausi_edoka Method

Public Function plausi_edoka( _
   ByVal p As edokadb.clsProfilDokAuswertung _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_edoka(ByVal p As edokadb.clsProfilDokAuswertung) As Boolean
        Dim ma As String
        Dim te As String
        Dim mb As String
        Dim nl As String
        Dim ko As String

        Dim d1 As Date
        Dim d2 As Date
        Dim d3 As Date
        Dim t1 As Integer
        Dim t2 As Integer
        Dim t3 As Integer

        If p.sDpartner.Value <> "" Then Return True
        ma = p.sVma.Value + p.sMma.Value + p.sEma.Value
        te = p.sVteam.Value + p.sMteam.Value + p.sEteam.Value
        mb = p.sMmb.Value + p.sVmb.Value + p.sEmb.Value
        nl = p.sVnl.Value + p.sMnl.Value + p.sEnl.Value
        ko = p.sVkost.Value + p.sMkost.Value + p.sEkost.Value

        If p.sDatum1.Value = "(heute)" Then d1 = Now Else d1 = p.sDatum1.Value
        If p.sDatum3.Value = "(heute)" Then d2 = Now Else d2 = p.sDatum3.Value
        If p.sDatum5.Value = "(heute)" Then d3 = Now Else d3 = p.sDatum5.Value

        If Me.lbldatum1.Text <> "" Then t1 = DateDiff(DateInterval.Day, d1, CType(Me.lbldatum1.Text, Date)) Else t1 = DateDiff(DateInterval.Day, d1, CType("01.07.2003", Date))
        If Me.lbldatum2.Text <> "" Then t2 = DateDiff(DateInterval.Day, d2, CType(Me.lbldatum2.Text, Date)) Else t2 = DateDiff(DateInterval.Day, d2, CType("01.07.2003", Date))
        If Me.lbldatum3.Text <> "" Then t3 = DateDiff(DateInterval.Day, d3, CType(Me.lbldatum3.Text, Date)) Else t3 = DateDiff(DateInterval.Day, d3, CType("01.07.2003", Date))

        If ma <> "" And te = "" And mb = "" And nl = "" Then
            If t1 <= 365 And t2 <= 365 And t3 <> 365 Then
                Return True
            Else
                MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If te <> "" Or ko <> "" Then
            If t1 <= 90 And t2 <= 90 And t3 <= 90 Then
                Return True
            Else
                MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If nl <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If mb <> "" Then
            If t1 <= 7 And t2 <= 7 And t3 <= 7 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If p.sDdokart.Value <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(96, MsgBoxStyle.Critical)
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.plausi_host Method

Public Function plausi_host( _
   ByVal p As edokadb.clsProfilDokAuswertung _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_host(ByVal p As edokadb.clsProfilDokAuswertung) As Boolean
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung.pnlhostdiv_Paint Method

Private Sub pnlhostdiv_Paint( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
) Handles pnlhostdiv.Paint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub pnlhostdiv_Paint(ByVal sender As System.Object, ByVal e As System.Windows.Forms.PaintEventArgs) Handles pnlhostdiv.Paint

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilDokAuswertung Fields

frmProfilDokAuswertung overview

Fields

field ActiveList
field Button1
field Button2
field Button3
field Button4
field Button6
field Button7
field Button8
field C1TrueDBGrid1
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox3
field CheckBox4
field CheckBox5
field ColorDialog1
field ComboBox10
field ComboBox9
field ContextMenu1
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field FirstNodeWithData
field GroupBox10
field GroupBox3
field GroupBox6
field GroupBox7
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag1
field HostTag2
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label2
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem15
field MenuItem16
field MenuItem2
field MenuItem20
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel2
field Panel3
field PartnerList
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabPage1
field TextBox1
field TextBox2
field TextBox3
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field cbd2
field cbd4
field cbd6
field cbmavip
field cbtag1
field cbtag2
field cbtag3
field changes
field checkchanges
field cinklalt
field colconv
field components
field ctmenu1
field dokumentart
field first
field hostinklmavip
field i
field lbentry
field lbldatum1
field lbldatum2
field lbldatum3
field lblhostdatum1
field lblhostdatum2
field lblhostdatum3
field li
field m_profile_geaendert
field m_profilnr
field m_sDatenherkunft
field m_sDislpayResult
field m_sNavigationResult
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field partner
field pnlhostdiv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tko
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum2
field txtdatum3
field txtdatum4
field txtdatum5
field txtdatum6

See Also

frmProfilDokAuswertung Class


ActiveList Variable

Dim ActiveList As Integer

Source code

[Visual Basic]
    Dim ActiveList As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CTMenuErsteller Variable

Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CTMenuMutierer Variable

Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CTMenuVerantwortlicher Variable

Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CheckBox3 Variable

Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CheckBox4 Variable

Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


CheckBox5 Variable

Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ColorDialog1 Variable

Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Source code

[Visual Basic]
    Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ComboBox10 Variable

Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ComboBox9 Variable

Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker10 Variable

Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker11 Variable

Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker12 Variable

Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker5 Variable

Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker6 Variable

Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker7 Variable

Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker8 Variable

Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


DateTimePicker9 Variable

Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


FirstNodeWithData Variable

Dim FirstNodeWithData As TreeNode

Source code

[Visual Basic]
    Dim FirstNodeWithData As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostDatum1 Variable

Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostDatum2 Variable

Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostDatum3 Variable

Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostTag1 Variable

Friend WithEvents HostTag1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents HostTag1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostTag2 Variable

Friend WithEvents HostTag2 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents HostTag2 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


HostTag3 Variable

Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label35 Variable

Friend WithEvents Label35 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label35 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label36 Variable

Friend WithEvents Label36 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label36 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label37 Variable

Friend WithEvents Label37 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label37 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label38 Variable

Friend WithEvents Label38 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label38 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MnuDel Variable

Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MnuDeleteDokumentart Variable

Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MnuListe Variable

Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


MnuSelectDokumentart Variable

Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


NodeText Variable

Dim NodeText As String

Source code

[Visual Basic]
    Dim NodeText As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


PartnerList Variable

Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


PnlDokumentDaten Variable

Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


PnlDokumentart Variable

Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


PnlPartner Variable

Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Profil_Ungueltig Variable

Dim Profil_Ungueltig As Boolean

Source code

[Visual Basic]
    Dim Profil_Ungueltig As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Profile Variable

Friend WithEvents Profile As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents Profile As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Profname Variable

Dim Profname As String

Source code

[Visual Basic]
    Dim Profname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TVDokart Variable

Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TVHostDok Variable

Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


btnOpen Variable

Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


btnPartnersuche Variable

Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbd2 Variable

Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbd4 Variable

Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbd6 Variable

Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbmavip Variable

Friend WithEvents cbmavip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbmavip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbtag1 Variable

Friend WithEvents cbtag1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbtag1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbtag2 Variable

Friend WithEvents cbtag2 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbtag2 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cbtag3 Variable

Friend WithEvents cbtag3 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbtag3 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


changes Variable

Dim changes As Boolean

Source code

[Visual Basic]
    Dim changes As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


checkchanges Variable

Dim checkchanges As Boolean

Source code

[Visual Basic]
    Dim checkchanges As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


cinklalt Variable

Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


colconv Variable

Dim colconv As New ColorConverter()

Source code

[Visual Basic]
    Dim colconv As New ColorConverter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


ctmenu1 Variable

Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


first Variable

Dim first As Boolean = True

Source code

[Visual Basic]
    Dim first As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


hostinklmavip Variable

Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lbentry Variable

Dim lbentry( _
   1 _
) As Object

Source code

[Visual Basic]
    Dim lbentry(1) As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lbldatum1 Variable

Friend WithEvents lbldatum1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lbldatum1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lbldatum2 Variable

Friend WithEvents lbldatum2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lbldatum2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lbldatum3 Variable

Friend WithEvents lbldatum3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lbldatum3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lblhostdatum1 Variable

Friend WithEvents lblhostdatum1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lblhostdatum2 Variable

Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


lblhostdatum3 Variable

Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


li Variable

Dim li As ListViewItem

Source code

[Visual Basic]
    Dim li As ListViewItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


m_profile_geaendert Variable

Dim m_profile_geaendert As Boolean

Source code

[Visual Basic]
    Dim m_profile_geaendert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


m_sDatenherkunft Variable

Dim m_sDatenherkunft As String

Source code

[Visual Basic]
    Dim m_sDatenherkunft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


m_sDislpayResult Variable

Dim m_sDislpayResult As String

Source code

[Visual Basic]
    Dim m_sDislpayResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


m_sNavigationResult Variable

Dim m_sNavigationResult As String

Source code

[Visual Basic]
    Dim m_sNavigationResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


mcbTeam Variable

Dim WithEvents mcbTeam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbTeam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


mypartner Variable

Dim mypartner As New edokadb.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokadb.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


partner Variable

Dim partner As DataTable

Source code

[Visual Basic]
    Dim partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


pnlhostdiv Variable

Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


savenode Variable

Dim savenode As TreeNode

Source code

[Visual Basic]
    Dim savenode As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tda Variable

Dim tda As DataTable

Source code

[Visual Basic]
    Dim tda As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tdh Variable

Dim tdh As DataTable

Source code

[Visual Basic]
    Dim tdh As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tdt Variable

Dim tdt As DataTable

Source code

[Visual Basic]
    Dim tdt As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tko Variable

Dim tko As DataTable

Source code

[Visual Basic]
    Dim tko As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tmb Variable

Dim tmb As DataTable

Source code

[Visual Basic]
    Dim tmb As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tnl Variable

Dim tnl As DataTable

Source code

[Visual Basic]
    Dim tnl As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tpe Variable

Dim tpe As DataTable

Source code

[Visual Basic]
    Dim tpe As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tst Variable

Dim tst As DataTable

Source code

[Visual Basic]
    Dim tst As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


tte Variable

Dim tte As DataTable

Source code

[Visual Basic]
    Dim tte As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum1 Variable

Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum2 Variable

Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum3 Variable

Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum4 Variable

Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum5 Variable

Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


txtdatum6 Variable

Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilDokAuswertung


frmProfilinfo Class

For a list of all members of this type, see frmProfilinfo Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmProfilinfo

Public Class frmProfilinfo
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmProfilinfo Members


frmProfilinfo Members

frmProfilinfo overview

Constructors

constructor frmProfilinfo Constructor

Properties

property ProfilNr
property Profile_Geaendert

Methods

method Activate_Details
method Button10_Click
method Button11_Click
method Button12_Click
method Button13_Click
method Button14_Click
method Button15_Click
method Button15_Click_1
method Button16_Click
method Button17_Click
method Button18_Click
method Button19_Click
method Button1_Click
method Button1_Click_1
method Button1_ContextMenuChanged
method Button20_Click
method Button2_Click_1
method Button3_Click_1
method Button5_Click
method Button9_Click
method Button9_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method ContextMenu2_Popup
method Convert_Seldate_bis
method Convert_Seldate_von
method CutDate
method DateTimePicker1_Enter
method DateTimePicker1_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker7_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method GroupBox10_Enter
method InitializeComponent
method Insertitem
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem19_Click
method MenuItem20_Click
method MenuItem21_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method Profil_Colors
method Profile_AfterSelect
method Profile_BeforeSelect
method Profile_MouseDown
method Remove_Selected_Items
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_DoubleClick
method TVDokart_MouseDown
method TabPage1_Click
method TextBox1_KeyDown
method TextBox4_KeyDown
method TextBox5_KeyDown
method TextBox6_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method TreeView1_Click
method Treeview1_MouseDown
method Update_Datumnode
method ValueList
method btnPartnersuche_Click
method cbrollend1_CheckedChanged
method check_changes
method cinklalt_CheckedChanged
method del_entry
method frmProfil_Closing
method frmProfil_Load
method init_profile
method init_treeview1
method lbselect_DoubleClick
method lbsortfields_DoubleClick
method mcb_Changed
method nodeswithdata
method plausi_edoka
method plausi_host
method reset_color
method reset_dokart
method set_tips
method test
method txtdatum1_TextChanged

Fields

field ActiveList
field Button1
field Button10
field Button11
field Button12
field Button13
field Button14
field Button15
field Button16
field Button17
field Button18
field Button19
field Button2
field Button20
field Button21
field Button22
field Button23
field Button24
field Button25
field Button26
field Button27
field Button28
field Button29
field Button3
field Button30
field Button31
field Button32
field Button33
field Button34
field Button35
field Button36
field Button37
field Button38
field Button39
field Button4
field Button40
field Button41
field Button42
field Button43
field Button44
field Button45
field Button46
field Button47
field Button48
field Button49
field Button5
field Button50
field Button51
field Button6
field Button7
field Button8
field Button9
field C1TrueDBGrid1
field C1TrueDBGrid2
field C1TrueDBGrid3
field C1TrueDBGrid4
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox1
field CheckBox10
field CheckBox11
field CheckBox12
field CheckBox13
field CheckBox14
field CheckBox15
field CheckBox16
field CheckBox17
field CheckBox18
field CheckBox19
field CheckBox2
field CheckBox20
field CheckBox21
field CheckBox3
field CheckBox4
field CheckBox5
field CheckBox6
field CheckBox7
field CheckBox8
field CheckBox9
field ColorDialog1
field ComboBox1
field ComboBox10
field ComboBox2
field ComboBox3
field ComboBox4
field ComboBox5
field ComboBox6
field ComboBox7
field ComboBox9
field ContextMenu1
field ContextMenu2
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker13
field DateTimePicker14
field DateTimePicker15
field DateTimePicker16
field DateTimePicker17
field DateTimePicker18
field DateTimePicker19
field DateTimePicker2
field DateTimePicker20
field DateTimePicker21
field DateTimePicker22
field DateTimePicker23
field DateTimePicker24
field DateTimePicker25
field DateTimePicker26
field DateTimePicker27
field DateTimePicker28
field DateTimePicker29
field DateTimePicker3
field DateTimePicker30
field DateTimePicker31
field DateTimePicker32
field DateTimePicker33
field DateTimePicker34
field DateTimePicker35
field DateTimePicker36
field DateTimePicker37
field DateTimePicker38
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field DatumHostText1
field DatumHostText2
field FirstNodeWithData
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox16
field GroupBox17
field GroupBox18
field GroupBox19
field GroupBox2
field GroupBox20
field GroupBox21
field GroupBox22
field GroupBox23
field GroupBox24
field GroupBox25
field GroupBox26
field GroupBox27
field GroupBox28
field GroupBox29
field GroupBox3
field GroupBox30
field GroupBox31
field GroupBox32
field GroupBox33
field GroupBox34
field GroupBox35
field GroupBox36
field GroupBox37
field GroupBox38
field GroupBox39
field GroupBox4
field GroupBox40
field GroupBox41
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field LBSelectHost
field LBSort
field Label1
field Label10
field Label100
field Label101
field Label102
field Label103
field Label104
field Label105
field Label106
field Label107
field Label108
field Label109
field Label11
field Label110
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label40
field Label41
field Label42
field Label43
field Label44
field Label45
field Label46
field Label47
field Label48
field Label49
field Label5
field Label50
field Label51
field Label52
field Label53
field Label54
field Label55
field Label56
field Label57
field Label58
field Label59
field Label6
field Label60
field Label61
field Label62
field Label63
field Label64
field Label65
field Label66
field Label67
field Label68
field Label69
field Label7
field Label70
field Label71
field Label72
field Label73
field Label74
field Label75
field Label76
field Label77
field Label78
field Label79
field Label8
field Label80
field Label81
field Label82
field Label83
field Label84
field Label85
field Label86
field Label87
field Label88
field Label89
field Label9
field Label90
field Label91
field Label92
field Label93
field Label94
field Label95
field Label96
field Label97
field Label98
field Label99
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel10
field Panel2
field Panel3
field Panel4
field Panel5
field Panel6
field Panel7
field Panel8
field Panel9
field PartnerList
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabPage1
field TabPage4
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox19
field TextBox2
field TextBox20
field TextBox21
field TextBox22
field TextBox23
field TextBox24
field TextBox25
field TextBox26
field TextBox27
field TextBox28
field TextBox29
field TextBox3
field TextBox30
field TextBox31
field TextBox32
field TextBox33
field TextBox34
field TextBox35
field TextBox36
field TextBox37
field TextBox38
field TextBox39
field TextBox4
field TextBox40
field TextBox41
field TextBox42
field TextBox43
field TextBox44
field TextBox45
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field TreeView2
field TreeView3
field TreeView4
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field btnini
field cb1
field cb2
field cb3
field cb3_1
field cb4
field cb5
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbd2
field cbd4
field cbd6
field cbrollend1
field cbrollend2
field cbrollend3
field cbrollend4
field cbrollend5
field cbrollend6
field cbrollend8
field cbrollend9
field cbteam
field cbuvmrollend1
field cbuvmrollend2
field cbuvmrollend3
field cbuvmrollend4
field cbzvrollend1
field cbzvrollend2
field cbzvrollend3
field cbzvrollend4
field changes
field checkchanges
field cinklalt
field colbtn1
field colbtn2
field colbtn3
field colbtn4
field colbtn5
field colbtn6
field colconv
field components
field ctmenu1
field datumtext1
field datumtext2
field datumtext3
field datumtext4
field datumtext5
field datumtext6
field dokumentart
field expanduvm
field expandzv
field first
field hostinklmavip
field i
field lbSortfields
field lbentry
field lblhostdatum2
field lblhostdatum3
field lblhostdatum31
field lbselect
field li
field m_profile_geaendert
field m_profilnr
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field oninit
field partner
field pnlhostdiv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tdtuvm
field tdtzv
field textdatum1uvm
field textdatum1zv
field textdatum2uvm
field textdatum2zv
field textdatum3uvm
field textdatum3zv
field textdatum4uvm
field textdatum4zv
field tko
field tku
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum1uvm
field txtdatum1zv
field txtdatum2
field txtdatum2uvm
field txtdatum2zv
field txtdatum3
field txtdatum3uvm
field txtdatum3zv
field txtdatum4
field txtdatum4uvm
field txtdatum4zv
field txtdatum5
field txtdatum6

See Also

frmProfilinfo Class


frmProfilinfo Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo Properties

frmProfilinfo overview

Properties

property ProfilNr
property Profile_Geaendert

See Also

frmProfilinfo Class


frmProfilinfo.ProfilNr Property

Property ProfilNr() As Integer

Source code

[Visual Basic]
    Property ProfilNr() As Integer
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Integer)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Profile_Geaendert Property

Property Profile_Geaendert() As Boolean

Source code

[Visual Basic]
    Property Profile_Geaendert() As Boolean
        Get
            Return m_profile_geaendert
        End Get
        Set(ByVal Value As Boolean)
            m_profile_geaendert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo Methods

frmProfilinfo overview

Methods

method Activate_Details
method Button10_Click
method Button11_Click
method Button12_Click
method Button13_Click
method Button14_Click
method Button15_Click
method Button15_Click_1
method Button16_Click
method Button17_Click
method Button18_Click
method Button19_Click
method Button1_Click
method Button1_Click_1
method Button1_ContextMenuChanged
method Button20_Click
method Button2_Click_1
method Button3_Click_1
method Button5_Click
method Button9_Click
method Button9_Click_1
method C1TrueDBGrid1_DoubleClick
method CTmenu1_Popup
method ContextMenu2_Popup
method Convert_Seldate_bis
method Convert_Seldate_von
method CutDate
method DateTimePicker1_Enter
method DateTimePicker1_ValueChanged
method DateTimePicker2_ValueChanged
method DateTimePicker3_ValueChanged
method DateTimePicker4_ValueChanged
method DateTimePicker5_ValueChanged
method DateTimePicker6_ValueChanged
method DateTimePicker7_ValueChanged
method DateTimePicker8_ValueChanged
method DateTimePicker9_ValueChanged
method Dispose
method Generic_Select
method GetNodeData
method GetNodeDatastring
method GroupBox10_Enter
method InitializeComponent
method Insertitem
method Load_Profil
method MenuItem10_Click
method MenuItem11_Click
method MenuItem13_Click
method MenuItem14_Click
method MenuItem15_Click
method MenuItem16_Click
method MenuItem17_Click
method MenuItem18_Click
method MenuItem19_Click
method MenuItem20_Click
method MenuItem21_Click
method MenuItem3_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem7_Click
method MenuItem8_Click
method MnDel_Click
method MnuDeleteDokumentart_Click
method MnuListe_Popup
method MnuSelectDokumentart_Click
method Panel1_Paint
method PartnerList_FetchRowStyle
method Profil_Colors
method Profile_AfterSelect
method Profile_BeforeSelect
method Profile_MouseDown
method Remove_Selected_Items
method Save_Profile
method Set_Values
method SpaltenTitel_Aktualisieren
method TVDokart_DoubleClick
method TVDokart_MouseDown
method TabPage1_Click
method TextBox1_KeyDown
method TextBox4_KeyDown
method TextBox5_KeyDown
method TextBox6_KeyDown
method ToolBar1_ButtonClick
method TreeView1_AfterSelect
method TreeView1_Click
method Treeview1_MouseDown
method Update_Datumnode
method ValueList
method btnPartnersuche_Click
method cbrollend1_CheckedChanged
method check_changes
method cinklalt_CheckedChanged
method del_entry
method frmProfil_Closing
method frmProfil_Load
method init_profile
method init_treeview1
method lbselect_DoubleClick
method lbsortfields_DoubleClick
method mcb_Changed
method nodeswithdata
method plausi_edoka
method plausi_host
method reset_color
method reset_dokart
method set_tips
method test
method txtdatum1_TextChanged

See Also

frmProfilinfo Class


frmProfilinfo.Activate_Details Method

Private Sub Activate_Details()

Source code

[Visual Basic]
    Private Sub Activate_Details()
        Me.TreeView1.SelectedNode = Nothing
        If Me.FirstNodeWithData Is Nothing Then
            DivFnkt.Searchnode1(Me.TreeView1, 41, 99)
            If DivFnkt.found Then
                'If colconv.ConvertToString(DivFnkt.FoundNode.ForeColor) = colconv.ConvertToString(System.Drawing.Color.Blue) Then
                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                'Me.PnlDokumentart.Visible = True
                'End If
            End If
        Else
            Me.TreeView1.SelectedNode = Me.FirstNodeWithData
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button10_Click Method

Private Sub Button10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button10.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 58, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox5.Text)
                tn1.Tag = Me.TextBox5.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox5.Text = ""
                Me.changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button11_Click Method

Private Sub Button11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button11.Click
        Button15_Click_1(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button12_Click Method

Private Sub Button12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button12.Click
        Me.txtdatum1.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button13_Click Method

Private Sub Button13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button13.Click
        Me.txtdatum2.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button14_Click Method

Private Sub Button14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button14.Click
        Me.txtdatum3.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button15_Click Method

Private Sub Button15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button15.Click
        Me.txtdatum4.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button15_Click_1 Method

Private Sub Button15_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button15_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            If Me.lbSortfields.SelectedItems.Count > 0 Then
                If Me.LBSelectHost.Visible = True Then
                    Me.LBSelectHost.Items.Add(Me.lbSortfields.SelectedItem + " | " + Me.LBSort.SelectedItem)
                    Me.lbSortfields.Items.RemoveAt(Me.lbSortfields.SelectedIndex)
                Else
                    Me.lbselect.Items.Add(Me.lbSortfields.SelectedItem + " | " + Me.LBSort.SelectedItem)
                    Me.lbSortfields.Items.RemoveAt(Me.lbSortfields.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button16_Click Method

Private Sub Button16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button16.Click
        Me.txtdatum5.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button17_Click Method

Private Sub Button17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button17.Click
        Me.txtdatum6.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button18_Click Method

Private Sub Button18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button18.Click
        Me.HostDatum2.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button19_Click Method

Private Sub Button19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button19.Click
        Me.HostDatum1.Text = ""
        Me.changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles colbtn6.Click, _
   colbtn5.Click, _
   colbtn4.Click, _
   colbtn3.Click, _
   colbtn2.Click, _
   colbtn1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles colbtn6.Click, colbtn5.Click, colbtn4.Click, colbtn3.Click, colbtn2.Click, colbtn1.Click
        Dim cName As String = CType(sender, System.Windows.Forms.Button).Name
        If Me.ColorDialog1.ShowDialog() = DialogResult.Cancel Then Exit Sub

        Me.ColorDialog1.AnyColor = True
        Button5_Click(sender, e)
        Select Case cName
            Case "colbtn1"
                Me.colbtn1.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn2"
                Me.colbtn2.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn3"
                Me.colbtn3.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn4"
                Me.colbtn4.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn5"
                Me.colbtn5.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
            Case "colbtn6"
                Me.colbtn6.BackColor = Me.ColorDialog1.Color
                If checkchanges Then changes = True
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button1_Click_1 Method

Private Sub Button1_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.txtdatum1.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button1_ContextMenuChanged Method

Private Sub Button1_ContextMenuChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.ContextMenuChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_ContextMenuChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.ContextMenuChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button20_Click Method

Private Sub Button20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button20.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 54, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox6.Text)
                tn1.Tag = Me.TextBox6.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox6.Text = ""
                Me.changes = True

            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button2_Click_1 Method

Private Sub Button2_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.txtdatum3.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button3_Click_1 Method

Private Sub Button3_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.txtdatum5.Text = ""
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Dim colconv As New ColorConverter()
        Me.colbtn1.BackColor = colconv.ConvertFromString("Control")
        Me.colbtn2.BackColor = Me.colbtn1.BackColor
        Me.colbtn3.BackColor = Me.colbtn1.BackColor
        Me.colbtn4.BackColor = Me.colbtn1.BackColor
        Me.colbtn5.BackColor = Me.colbtn1.BackColor
        Me.colbtn6.BackColor = Me.colbtn1.BackColor
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button9_Click Method

Private Sub Button9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim tn As New TreeNode()
        tn = Me.TreeView1.SelectedNode
        tn = tn.Nodes.Add(Me.TextBox4.Text)
        tn.Tag = Me.TextBox4.Text
        tn.ForeColor = System.Drawing.Color.Red
        tn.ImageIndex = 4
        tn.SelectedImageIndex = 4
        Me.TreeView1.SelectedNode.ExpandAll()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Button9_Click_1 Method

Private Sub Button9_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button9.Click
        Try
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            DivFnkt.Searchnode1(Me.TreeView1, 59, 99)
            If DivFnkt.found = True Then
                tn = DivFnkt.FoundNode
                tn1 = tn.Nodes.Add(Me.TextBox4.Text)
                tn1.Tag = Me.TextBox4.Text
                tn1.ForeColor = System.Drawing.Color.Red
                tn1.ImageIndex = 4
                tn1.SelectedImageIndex = 4
                tn1.Parent.ExpandAll()
                Me.TextBox4.Text = ""
                Me.changes = True

            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles PartnerList.DoubleClick, _
   C1TrueDBGrid1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PartnerList.DoubleClick, C1TrueDBGrid1.DoubleClick
        Dim tn As New TreeNode()
        If Me.TreeView1.SelectedNode.Tag < 10 Then
            MsgBox("Bitte wählen Sie einen Knoten aus, der das Hinzufügen von Selektionskriterien erlaubt.")
            Exit Sub
        End If

        ' Änderung durch Partnerselektion
        If Me.TreeView1.SelectedNode.Tag = 41 Then
            tn = Me.TreeView1.SelectedNode
            tn = tn.Nodes.Add(Str(Me.PartnerList.Columns(0).Value) + " - " + Me.PartnerList.Columns(1).Value)
            tn.Tag = Me.PartnerList.Columns(0).Value
            tn.ForeColor = System.Drawing.Color.Red
            tn.ImageIndex = 4
            tn.SelectedImageIndex = 4
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
            Exit Sub
        End If
        Try
            tn = Me.TreeView1.SelectedNode
            Dim i As Integer
            Dim row As Long
            Dim col As C1.Win.C1TrueDBGrid.C1DataColumn
            If Me.C1TrueDBGrid1.SelectedRows.Count > 0 Then
                For Each row In Me.C1TrueDBGrid1.SelectedRows
                    tn = Me.TreeView1.SelectedNode
                    tn = tn.Nodes.Add(Me.C1TrueDBGrid1.Columns(1).CellText(row))
                    If Me.C1TrueDBGrid1.Columns(2).CellValue(row) = False Then
                        tn.ForeColor = System.Drawing.Color.Gray
                    Else
                        tn.ForeColor = System.Drawing.Color.Red
                    End If
                    tn.Tag = Me.C1TrueDBGrid1.Columns(0).CellValue(row)
                    tn.ImageIndex = 4
                    tn.SelectedImageIndex = 4
                Next
            Else
                tn = tn.Nodes.Add(Me.C1TrueDBGrid1.Columns(1).Value)
                tn.Tag = Me.C1TrueDBGrid1.Columns(0).Value
                If Me.C1TrueDBGrid1.Columns(2).Value = False Then
                    tn.ForeColor = System.Drawing.Color.Gray
                Else
                    tn.ForeColor = System.Drawing.Color.Red
                End If
                tn.ImageIndex = 4
                tn.SelectedImageIndex = 4
            End If
            Me.TreeView1.SelectedNode.ExpandAll()
            If checkchanges Then changes = True
        Catch
        End Try
        Exit Sub
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.CTmenu1_Popup Method

Private Sub CTmenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ctmenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CTmenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ctmenu1.Popup
        Try
            Dim tn As TreeNode
            tn = Me.TreeView1.SelectedNode
            Try
                Dim I As Integer
                I = tn.Parent.Tag
            Catch
                Me.MnuDel.Enabled = False
                Me.MenuItem14.Enabled = False
                Exit Sub
            End Try
            If tn.Text = "Diverse" Or tn.Text = "Dokumentart" Or tn.Text = "Verantwortlich" Or tn.Text = "Ersteller" Or tn.Text = "Mutierer" Or tn.Text = "Datum-Selektion" Or tn.Text = "inkl. gelöschte/aufgehobene" Or tn.Text = "Sortierung" Then
                Me.MnuDel.Enabled = False
                Me.MenuItem14.Enabled = False

                Exit Sub
            End If

            Me.MnuDel.Enabled = False
            Me.MenuItem14.Enabled = False
            If tn.Parent.Tag = 58 Or tn.Parent.Tag = 59 Or tn.Parent.Tag = 54 Then
                Me.MnuDel.Enabled = True
                Exit Sub
            End If

            If tn.Parent.Tag = 1 Or tn.Parent.Tag = 2 Or tn.Parent.Tag = 3 Or tn.Parent.Tag = 4 Or tn.Tag = 5 Then
                Me.MnuDel.Enabled = False
                Me.MenuItem14.Enabled = True
                Exit Sub
            End If

            If tn.Tag = 41 Or tn.Tag = 54 Or tn.Tag = 51 Or tn.Tag = 58 Or tn.Tag = 59 Or tn.Tag = 54 Or tn.Tag = 42 Or tn.Tag = 43 Or tn.Tag = 44 Or tn.Tag = 52 Or tn.Tag = 53 Then
                Me.MnuDel.Enabled = False
                Me.MenuItem14.Enabled = True
                Exit Sub
            End If
            Me.MnuDel.Enabled = True

        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Dim s, s1 As String
        Dim i As Integer
        Dim splitter
        If Me.LBSelectHost.Visible = True Then
            If LBSelectHost.SelectedItems.Count < 1 Then
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            Else
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            End If
            Try
                s = LBSelectHost.SelectedItem
                splitter = Microsoft.VisualBasic.Split(s, " | ")
                Select Case splitter(1)
                    Case "Absteigend"
                        s1 = "Aufsteigend"
                    Case "Aufsteigend"
                        s1 = "Absteigend"
                    Case Else
                        s1 = "Aufsteigend"
                End Select
                Me.MenuItem21.Text = "Sortierungsart " + s1
            Catch
            End Try
        Else
            If lbselect.SelectedItems.Count < 1 Then
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            Else
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            End If
            Try
                s = lbselect.SelectedItem
                splitter = Microsoft.VisualBasic.Split(s, " | ")
                Select Case splitter(1)
                    Case "Absteigend"
                        s1 = "Aufsteigend"
                    Case "Aufsteigend"
                        s1 = "Absteigend"
                    Case Else
                        s1 = "Aufsteigend"
                End Select
                Me.MenuItem21.Text = "Sortierungsart " + s1
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Convert_Seldate_bis Method

Private Function Convert_Seldate_bis( _
   ByVal d As String _
) As String

Parameters

d
Required.

Source code

[Visual Basic]
    Private Function Convert_Seldate_bis(ByVal d As String) As String
        Dim splitter
        Dim da As DateTime
        Dim i As Integer
        Dim ds As String
        ds = d
        If ds = "" Or ds = "(heute)-999999" Then
            Return ""
        End If
        If Microsoft.VisualBasic.Left(d, 1) = "(" Then
            d = Mid(d, 2, Len(d) - 1)
            splitter = Microsoft.VisualBasic.Split(d, "-")
            Try
                i = Val(splitter(1))
                da = Now
                da = DateAdd(DateInterval.Day, i * -1, Now)
                If i = 0 Then Return CutDate(da) Else Return CutDate(da)

            Catch ex As Exception
                Return ""
            End Try

        Else
            Return d
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Convert_Seldate_von Method

Private Function Convert_Seldate_von( _
   ByVal d As String _
) As String

Parameters

d
Required.

Source code

[Visual Basic]
    Private Function Convert_Seldate_von(ByVal d As String) As String
        Dim splitter
        Dim da As DateTime
        Dim i As Integer
        Dim ds As String
        ds = d
        If ds = "" Or ds = "(heute)-999999" Then
            Return ""
        End If
        If Microsoft.VisualBasic.Left(d, 1) = "(" Then
            d = Mid(d, 2, Len(d) - 1)
            splitter = Microsoft.VisualBasic.Split(d, "-")
            Try
                i = Val(splitter(1))
                da = Now
                da = DateAdd(DateInterval.Day, i * -1, Now)
                If i = 0 Then Return CutDate(Now) Else Return CutDate(da)

            Catch ex As Exception
                Return ""
            End Try

        Else
            Return d
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.CutDate Method

Private Function CutDate( _
   ByVal s As String _
) As String

Parameters

s
Required.

Source code

[Visual Basic]
    Private Function CutDate(ByVal s As String) As String
        Dim i As Integer
        i = Microsoft.VisualBasic.InStr(s, " ")
        If i > 0 Then CutDate = Microsoft.VisualBasic.Left(s, i - 1) Else CutDate = s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker1_Enter Method

Private Sub DateTimePicker1_Enter( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.Enter, _
   DateTimePicker2.Enter, _
   DateTimePicker3.Enter, _
   DateTimePicker4.Enter, _
   DateTimePicker5.Enter, _
   DateTimePicker6.Enter, _
   DateTimePicker8.Enter, _
   DateTimePicker9.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_Enter(ByVal sender As Object, ByVal e As System.EventArgs) Handles DateTimePicker1.Enter, _
    DateTimePicker2.Enter, DateTimePicker3.Enter, DateTimePicker4.Enter, DateTimePicker5.Enter, DateTimePicker6.Enter, DateTimePicker8.Enter, DateTimePicker9.Enter
        Dim dp As DateTimePicker
        Dim D As Date
        dp = sender
        Select Case UCase(dp.Name)
            Case "DATETIMEPICKER1"
                If Me.txtdatum1.Text <> "" Then
                    D = CType(Me.txtdatum1.Text, Date)
                    Me.DateTimePicker1.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker1.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER2"
                If Me.txtdatum2.Text <> "" Then
                    D = CType(Me.txtdatum2.Text, Date)
                    Me.DateTimePicker2.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker2.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER3"
                If Me.txtdatum3.Text <> "" Then
                    D = CType(Me.txtdatum3.Text, Date)
                    Me.DateTimePicker3.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker3.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER4"
                If Me.txtdatum4.Text <> "" Then
                    D = CType(Me.txtdatum4.Text, Date)
                    Me.DateTimePicker4.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker4.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER5"
                If Me.txtdatum5.Text <> "" Then
                    D = CType(Me.txtdatum5.Text, Date)
                    Me.DateTimePicker5.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker5.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER6"
                If Me.txtdatum6.Text <> "" Then
                    D = CType(Me.txtdatum6.Text, Date)
                    Me.DateTimePicker6.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker6.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER8"
                If Me.HostDatum2.Text <> "" Then
                    D = CType(Me.HostDatum2.Text, Date)
                    Me.DateTimePicker8.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker8.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If
            Case "DATETIMEPICKER9"
                If Me.HostDatum1.Text <> "" Then
                    D = CType(Me.HostDatum1.Text, Date)
                    Me.DateTimePicker9.Value = New Date(Year(D), Month(D), Microsoft.VisualBasic.Day(D), 0, 0, 0)
                Else
                    Me.DateTimePicker9.Value = New Date(Year(Now), Month(Now), Microsoft.VisualBasic.Day(Now), 0, 0, 0)
                End If

            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        Me.txtdatum1.Text = CutDate(Me.DateTimePicker1.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum1.Text, Date)
            Me.DateTimePicker1.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker2_ValueChanged Method

Private Sub DateTimePicker2_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker2.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker2_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker2.ValueChanged
        Me.txtdatum2.Text = CutDate(Me.DateTimePicker2.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum2.Text, Date)
            Me.DateTimePicker2.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker3_ValueChanged Method

Private Sub DateTimePicker3_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker3.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker3_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker3.ValueChanged
        Me.txtdatum3.Text = CutDate(Me.DateTimePicker3.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum3.Text, Date)
            Me.DateTimePicker3.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker4_ValueChanged Method

Private Sub DateTimePicker4_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker4.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker4_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker4.ValueChanged
        Me.txtdatum4.Text = CutDate(Me.DateTimePicker4.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum4.Text, Date)
            Me.DateTimePicker4.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker5_ValueChanged Method

Private Sub DateTimePicker5_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker5.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker5_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker5.ValueChanged
        Me.txtdatum5.Text = CutDate(Me.DateTimePicker5.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum5.Text, Date)
            Me.DateTimePicker5.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker6_ValueChanged Method

Private Sub DateTimePicker6_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker6.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker6_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker6.ValueChanged
        Me.txtdatum6.Text = CutDate(Me.DateTimePicker6.Value)
        Try
            Dim d As Date
            d = CType(Me.txtdatum6.Text, Date)
            Me.DateTimePicker6.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try

        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker7_ValueChanged Method

Private Sub DateTimePicker7_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker7.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker7_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker7.ValueChanged
        Me.HostDatum3.Text = CutDate(Me.DateTimePicker7.Value)
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker8_ValueChanged Method

Private Sub DateTimePicker8_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker8.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker8_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker8.ValueChanged
        Me.HostDatum2.Text = CutDate(Me.DateTimePicker8.Value)
        Try
            Dim d As Date
            d = CType(Me.HostDatum2.Text, Date)
            Me.DateTimePicker8.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.DateTimePicker9_ValueChanged Method

Private Sub DateTimePicker9_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker9.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker9_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker9.ValueChanged
        Me.HostDatum1.Text = CutDate(Me.DateTimePicker9.Value)
        Try
            Dim d As Date
            d = CType(Me.HostDatum1.Text, Date)
            Me.DateTimePicker9.Value = New Date(Year(d), Month(d), Microsoft.VisualBasic.Day(d), 0, 0, 0)
        Catch
        End Try
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Mitarbeiter"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Status"
            Case 3
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Marktbereich"
            Case 4
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Niederlassung"
            Case 5
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Kostenstelle"
            Case 6
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Team"
            Case 7
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp"
            Case 8
                scmCmdToExecute.CommandText = "dbo.SP_Profil_DokumenttypHost"
            Case 9
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Mitarbeiter_kube"
            Case 10
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp_uvm"
            Case 11
                scmCmdToExecute.CommandText = "dbo.SP_Profil_Dokumenttyp_ZV"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.GetNodeData Method

Private Function GetNodeData( _
   ByVal tnParent As TreeNode, _
   ByRef iParent As Integer _
) As String

Parameters

tnParent
Required.
iParent
Required.

Source code

[Visual Basic]
    Private Function GetNodeData(ByVal tnParent As TreeNode, ByRef iParent As Integer) As String
        Dim tn As TreeNode
        If tnParent.GetNodeCount(True) > 0 Then
            tn = tnParent.Nodes(0)
        Else
            tn = Nothing
        End If
        Do Until tn Is Nothing
            Try
                If tn.Parent.Tag = iParent Then
                    Me.NodeText = Me.NodeText & ";" & tn.Tag
                End If
            Catch ex As Exception
            End Try

            If tn.GetNodeCount(True) > 0 Then
                Call GetNodeData(tn, iParent)
            End If
            tn = tn.NextNode
        Loop
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.GetNodeDatastring Method

Private Function GetNodeDatastring( _
   ByVal iparent As Integer _
) As String

Parameters

iparent
Required.

Source code

[Visual Basic]
    Private Function GetNodeDatastring(ByVal iparent As Integer) As String
        Me.NodeText = ""
        DivFnkt.Searchnode1(Me.TreeView1, iparent, 0)
        If DivFnkt.found Then
            GetNodeData(DivFnkt.FoundNode, iparent)
            Try
                Me.NodeText = Microsoft.VisualBasic.Right(Me.NodeText, Len(Me.NodeText) - 1)
            Catch
                Me.NodeText = ""
            End Try
        End If
        Return Me.NodeText
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.GroupBox10_Enter Method

Private Sub GroupBox10_Enter( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles GroupBox10.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub GroupBox10_Enter(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles GroupBox10.Enter

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmProfilinfo))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnClose = New System.Windows.Forms.ToolBarButton()
        Me.btnOpen = New System.Windows.Forms.ToolBarButton()
        Me.btnSave = New System.Windows.Forms.ToolBarButton()
        Me.btnini = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ColorDialog1 = New System.Windows.Forms.ColorDialog()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.MnuListe = New System.Windows.Forms.ContextMenu()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.Profile = New System.Windows.Forms.TreeView()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Label25 = New System.Windows.Forms.Label()
        Me.ComboBox10 = New System.Windows.Forms.ComboBox()
        Me.Label24 = New System.Windows.Forms.Label()
        Me.ComboBox9 = New System.Windows.Forms.ComboBox()
        Me.ctmenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDel = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.CTMenuErsteller = New System.Windows.Forms.ContextMenu()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.CTMenuVerantwortlicher = New System.Windows.Forms.ContextMenu()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.CTMenuMutierer = New System.Windows.Forms.ContextMenu()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuSelectDokumentart = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteDokumentart = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.C1TrueDBGrid3 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button46 = New System.Windows.Forms.Button()
        Me.Label93 = New System.Windows.Forms.Label()
        Me.TextBox40 = New System.Windows.Forms.TextBox()
        Me.Label94 = New System.Windows.Forms.Label()
        Me.TextBox41 = New System.Windows.Forms.TextBox()
        Me.Label95 = New System.Windows.Forms.Label()
        Me.TextBox42 = New System.Windows.Forms.TextBox()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.GroupBox13 = New System.Windows.Forms.GroupBox()
        Me.GroupBox15 = New System.Windows.Forms.GroupBox()
        Me.PnlDokumentart = New System.Windows.Forms.Panel()
        Me.TVDokart = New System.Windows.Forms.TreeView()
        Me.GroupBox16 = New System.Windows.Forms.GroupBox()
        Me.TVHostDok = New System.Windows.Forms.TreeView()
        Me.PnlDokumentDaten = New System.Windows.Forms.Panel()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.cbd6 = New System.Windows.Forms.CheckBox()
        Me.cbd4 = New System.Windows.Forms.CheckBox()
        Me.cbd2 = New System.Windows.Forms.CheckBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.Button17 = New System.Windows.Forms.Button()
        Me.Button16 = New System.Windows.Forms.Button()
        Me.Button15 = New System.Windows.Forms.Button()
        Me.Button14 = New System.Windows.Forms.Button()
        Me.Button13 = New System.Windows.Forms.Button()
        Me.Button12 = New System.Windows.Forms.Button()
        Me.cbrollend6 = New System.Windows.Forms.CheckBox()
        Me.cbrollend5 = New System.Windows.Forms.CheckBox()
        Me.cbrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label39 = New System.Windows.Forms.Label()
        Me.Label40 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.Label23 = New System.Windows.Forms.Label()
        Me.cbrollend2 = New System.Windows.Forms.CheckBox()
        Me.cbrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.txtdatum1 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.txtdatum2 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker2 = New System.Windows.Forms.DateTimePicker()
        Me.txtdatum3 = New System.Windows.Forms.TextBox()
        Me.txtdatum4 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.txtdatum5 = New System.Windows.Forms.TextBox()
        Me.txtdatum6 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker6 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker5 = New System.Windows.Forms.DateTimePicker()
        Me.datumtext6 = New System.Windows.Forms.Label()
        Me.datumtext5 = New System.Windows.Forms.Label()
        Me.datumtext4 = New System.Windows.Forms.Label()
        Me.datumtext3 = New System.Windows.Forms.Label()
        Me.datumtext2 = New System.Windows.Forms.Label()
        Me.datumtext1 = New System.Windows.Forms.Label()
        Me.GroupBox10 = New System.Windows.Forms.GroupBox()
        Me.cinklalt = New System.Windows.Forms.CheckBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.pnlhostdiv = New System.Windows.Forms.Panel()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Button20 = New System.Windows.Forms.Button()
        Me.GroupBox11 = New System.Windows.Forms.GroupBox()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Button10 = New System.Windows.Forms.Button()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Button9 = New System.Windows.Forms.Button()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.hostinklmavip = New System.Windows.Forms.CheckBox()
        Me.GroupBox7 = New System.Windows.Forms.GroupBox()
        Me.Label29 = New System.Windows.Forms.Label()
        Me.DateTimePicker7 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox6 = New System.Windows.Forms.GroupBox()
        Me.Button18 = New System.Windows.Forms.Button()
        Me.Button19 = New System.Windows.Forms.Button()
        Me.DatumHostText2 = New System.Windows.Forms.Label()
        Me.DatumHostText1 = New System.Windows.Forms.Label()
        Me.cbrollend9 = New System.Windows.Forms.CheckBox()
        Me.cbrollend8 = New System.Windows.Forms.CheckBox()
        Me.HostDatum1 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.lblhostdatum31 = New System.Windows.Forms.Label()
        Me.ComboBox6 = New System.Windows.Forms.ComboBox()
        Me.Label27 = New System.Windows.Forms.Label()
        Me.lblhostdatum3 = New System.Windows.Forms.Label()
        Me.HostDatum3 = New System.Windows.Forms.TextBox()
        Me.HostTag3 = New System.Windows.Forms.ComboBox()
        Me.HostDatum2 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker8 = New System.Windows.Forms.DateTimePicker()
        Me.lblhostdatum2 = New System.Windows.Forms.Label()
        Me.DateTimePicker9 = New System.Windows.Forms.DateTimePicker()
        Me.Label32 = New System.Windows.Forms.Label()
        Me.Label33 = New System.Windows.Forms.Label()
        Me.Label34 = New System.Windows.Forms.Label()
        Me.Label35 = New System.Windows.Forms.Label()
        Me.CheckBox3 = New System.Windows.Forms.CheckBox()
        Me.CheckBox4 = New System.Windows.Forms.CheckBox()
        Me.CheckBox5 = New System.Windows.Forms.CheckBox()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label36 = New System.Windows.Forms.Label()
        Me.Label37 = New System.Windows.Forms.Label()
        Me.Label38 = New System.Windows.Forms.Label()
        Me.DateTimePicker10 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker11 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker12 = New System.Windows.Forms.DateTimePicker()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.GroupBox24 = New System.Windows.Forms.GroupBox()
        Me.GroupBox31 = New System.Windows.Forms.GroupBox()
        Me.GroupBox32 = New System.Windows.Forms.GroupBox()
        Me.TreeView4 = New System.Windows.Forms.TreeView()
        Me.Panel9 = New System.Windows.Forms.Panel()
        Me.GroupBox33 = New System.Windows.Forms.GroupBox()
        Me.TextBox28 = New System.Windows.Forms.TextBox()
        Me.Button37 = New System.Windows.Forms.Button()
        Me.GroupBox34 = New System.Windows.Forms.GroupBox()
        Me.TextBox29 = New System.Windows.Forms.TextBox()
        Me.Button38 = New System.Windows.Forms.Button()
        Me.GroupBox35 = New System.Windows.Forms.GroupBox()
        Me.TextBox30 = New System.Windows.Forms.TextBox()
        Me.Button39 = New System.Windows.Forms.Button()
        Me.Label73 = New System.Windows.Forms.Label()
        Me.CheckBox16 = New System.Windows.Forms.CheckBox()
        Me.GroupBox36 = New System.Windows.Forms.GroupBox()
        Me.Label74 = New System.Windows.Forms.Label()
        Me.DateTimePicker25 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox37 = New System.Windows.Forms.GroupBox()
        Me.Button40 = New System.Windows.Forms.Button()
        Me.Button41 = New System.Windows.Forms.Button()
        Me.Label75 = New System.Windows.Forms.Label()
        Me.Label76 = New System.Windows.Forms.Label()
        Me.CheckBox17 = New System.Windows.Forms.CheckBox()
        Me.CheckBox18 = New System.Windows.Forms.CheckBox()
        Me.TextBox31 = New System.Windows.Forms.TextBox()
        Me.Label77 = New System.Windows.Forms.Label()
        Me.Label78 = New System.Windows.Forms.Label()
        Me.Label79 = New System.Windows.Forms.Label()
        Me.ComboBox5 = New System.Windows.Forms.ComboBox()
        Me.Label80 = New System.Windows.Forms.Label()
        Me.Label81 = New System.Windows.Forms.Label()
        Me.TextBox32 = New System.Windows.Forms.TextBox()
        Me.ComboBox7 = New System.Windows.Forms.ComboBox()
        Me.TextBox33 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker26 = New System.Windows.Forms.DateTimePicker()
        Me.Label82 = New System.Windows.Forms.Label()
        Me.DateTimePicker27 = New System.Windows.Forms.DateTimePicker()
        Me.Label83 = New System.Windows.Forms.Label()
        Me.Label84 = New System.Windows.Forms.Label()
        Me.Label85 = New System.Windows.Forms.Label()
        Me.Label86 = New System.Windows.Forms.Label()
        Me.CheckBox19 = New System.Windows.Forms.CheckBox()
        Me.CheckBox20 = New System.Windows.Forms.CheckBox()
        Me.CheckBox21 = New System.Windows.Forms.CheckBox()
        Me.TextBox34 = New System.Windows.Forms.TextBox()
        Me.TextBox35 = New System.Windows.Forms.TextBox()
        Me.TextBox36 = New System.Windows.Forms.TextBox()
        Me.Label87 = New System.Windows.Forms.Label()
        Me.Label88 = New System.Windows.Forms.Label()
        Me.Label89 = New System.Windows.Forms.Label()
        Me.DateTimePicker28 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker29 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker30 = New System.Windows.Forms.DateTimePicker()
        Me.Button42 = New System.Windows.Forms.Button()
        Me.Button43 = New System.Windows.Forms.Button()
        Me.Button44 = New System.Windows.Forms.Button()
        Me.Panel10 = New System.Windows.Forms.Panel()
        Me.C1TrueDBGrid2 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button45 = New System.Windows.Forms.Button()
        Me.Label90 = New System.Windows.Forms.Label()
        Me.TextBox37 = New System.Windows.Forms.TextBox()
        Me.Label91 = New System.Windows.Forms.Label()
        Me.TextBox38 = New System.Windows.Forms.TextBox()
        Me.Label92 = New System.Windows.Forms.Label()
        Me.TextBox39 = New System.Windows.Forms.TextBox()
        Me.GroupBox30 = New System.Windows.Forms.GroupBox()
        Me.txtdatum3zv = New System.Windows.Forms.TextBox()
        Me.txtdatum4zv = New System.Windows.Forms.TextBox()
        Me.txtdatum2zv = New System.Windows.Forms.TextBox()
        Me.cbzvrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label56 = New System.Windows.Forms.Label()
        Me.DateTimePicker19 = New System.Windows.Forms.DateTimePicker()
        Me.Label57 = New System.Windows.Forms.Label()
        Me.Label58 = New System.Windows.Forms.Label()
        Me.cbzvrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbzvrollend2 = New System.Windows.Forms.CheckBox()
        Me.Label59 = New System.Windows.Forms.Label()
        Me.txtdatum1zv = New System.Windows.Forms.TextBox()
        Me.Label60 = New System.Windows.Forms.Label()
        Me.cbzvrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label61 = New System.Windows.Forms.Label()
        Me.textdatum1zv = New System.Windows.Forms.Label()
        Me.textdatum2zv = New System.Windows.Forms.Label()
        Me.textdatum3zv = New System.Windows.Forms.Label()
        Me.textdatum4zv = New System.Windows.Forms.Label()
        Me.DateTimePicker20 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker21 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker22 = New System.Windows.Forms.DateTimePicker()
        Me.Button32 = New System.Windows.Forms.Button()
        Me.Button33 = New System.Windows.Forms.Button()
        Me.GroupBox25 = New System.Windows.Forms.GroupBox()
        Me.GroupBox26 = New System.Windows.Forms.GroupBox()
        Me.GroupBox27 = New System.Windows.Forms.GroupBox()
        Me.TreeView3 = New System.Windows.Forms.TreeView()
        Me.Panel7 = New System.Windows.Forms.Panel()
        Me.GroupBox28 = New System.Windows.Forms.GroupBox()
        Me.TextBox19 = New System.Windows.Forms.TextBox()
        Me.Button29 = New System.Windows.Forms.Button()
        Me.GroupBox29 = New System.Windows.Forms.GroupBox()
        Me.TextBox20 = New System.Windows.Forms.TextBox()
        Me.Button30 = New System.Windows.Forms.Button()
        Me.GroupBox38 = New System.Windows.Forms.GroupBox()
        Me.TextBox21 = New System.Windows.Forms.TextBox()
        Me.Button31 = New System.Windows.Forms.Button()
        Me.Label62 = New System.Windows.Forms.Label()
        Me.CheckBox10 = New System.Windows.Forms.CheckBox()
        Me.GroupBox39 = New System.Windows.Forms.GroupBox()
        Me.Label63 = New System.Windows.Forms.Label()
        Me.DateTimePicker23 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox40 = New System.Windows.Forms.GroupBox()
        Me.Button34 = New System.Windows.Forms.Button()
        Me.Button35 = New System.Windows.Forms.Button()
        Me.Label64 = New System.Windows.Forms.Label()
        Me.Label65 = New System.Windows.Forms.Label()
        Me.CheckBox11 = New System.Windows.Forms.CheckBox()
        Me.CheckBox12 = New System.Windows.Forms.CheckBox()
        Me.TextBox22 = New System.Windows.Forms.TextBox()
        Me.Label66 = New System.Windows.Forms.Label()
        Me.Label67 = New System.Windows.Forms.Label()
        Me.Label68 = New System.Windows.Forms.Label()
        Me.ComboBox3 = New System.Windows.Forms.ComboBox()
        Me.Label69 = New System.Windows.Forms.Label()
        Me.Label70 = New System.Windows.Forms.Label()
        Me.TextBox23 = New System.Windows.Forms.TextBox()
        Me.ComboBox4 = New System.Windows.Forms.ComboBox()
        Me.TextBox24 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker24 = New System.Windows.Forms.DateTimePicker()
        Me.Label71 = New System.Windows.Forms.Label()
        Me.DateTimePicker31 = New System.Windows.Forms.DateTimePicker()
        Me.Label72 = New System.Windows.Forms.Label()
        Me.Label96 = New System.Windows.Forms.Label()
        Me.Label97 = New System.Windows.Forms.Label()
        Me.Label98 = New System.Windows.Forms.Label()
        Me.CheckBox13 = New System.Windows.Forms.CheckBox()
        Me.CheckBox14 = New System.Windows.Forms.CheckBox()
        Me.CheckBox15 = New System.Windows.Forms.CheckBox()
        Me.TextBox25 = New System.Windows.Forms.TextBox()
        Me.TextBox26 = New System.Windows.Forms.TextBox()
        Me.TextBox27 = New System.Windows.Forms.TextBox()
        Me.Label99 = New System.Windows.Forms.Label()
        Me.Label100 = New System.Windows.Forms.Label()
        Me.Label101 = New System.Windows.Forms.Label()
        Me.DateTimePicker32 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker33 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker34 = New System.Windows.Forms.DateTimePicker()
        Me.Button36 = New System.Windows.Forms.Button()
        Me.Button47 = New System.Windows.Forms.Button()
        Me.Button48 = New System.Windows.Forms.Button()
        Me.Panel8 = New System.Windows.Forms.Panel()
        Me.C1TrueDBGrid4 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button49 = New System.Windows.Forms.Button()
        Me.Label102 = New System.Windows.Forms.Label()
        Me.TextBox43 = New System.Windows.Forms.TextBox()
        Me.Label103 = New System.Windows.Forms.Label()
        Me.TextBox44 = New System.Windows.Forms.TextBox()
        Me.Label104 = New System.Windows.Forms.Label()
        Me.TextBox45 = New System.Windows.Forms.TextBox()
        Me.GroupBox41 = New System.Windows.Forms.GroupBox()
        Me.txtdatum4uvm = New System.Windows.Forms.TextBox()
        Me.txtdatum3uvm = New System.Windows.Forms.TextBox()
        Me.txtdatum2uvm = New System.Windows.Forms.TextBox()
        Me.cbuvmrollend1 = New System.Windows.Forms.CheckBox()
        Me.Label105 = New System.Windows.Forms.Label()
        Me.DateTimePicker35 = New System.Windows.Forms.DateTimePicker()
        Me.Label106 = New System.Windows.Forms.Label()
        Me.Label107 = New System.Windows.Forms.Label()
        Me.cbuvmrollend4 = New System.Windows.Forms.CheckBox()
        Me.cbuvmrollend2 = New System.Windows.Forms.CheckBox()
        Me.Label108 = New System.Windows.Forms.Label()
        Me.txtdatum1uvm = New System.Windows.Forms.TextBox()
        Me.Label109 = New System.Windows.Forms.Label()
        Me.cbuvmrollend3 = New System.Windows.Forms.CheckBox()
        Me.Label110 = New System.Windows.Forms.Label()
        Me.textdatum1uvm = New System.Windows.Forms.Label()
        Me.textdatum2uvm = New System.Windows.Forms.Label()
        Me.textdatum3uvm = New System.Windows.Forms.Label()
        Me.textdatum4uvm = New System.Windows.Forms.Label()
        Me.DateTimePicker36 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker37 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker38 = New System.Windows.Forms.DateTimePicker()
        Me.Button50 = New System.Windows.Forms.Button()
        Me.Button51 = New System.Windows.Forms.Button()
        Me.GroupBox14 = New System.Windows.Forms.GroupBox()
        Me.PnlPartner = New System.Windows.Forms.Panel()
        Me.GroupBox17 = New System.Windows.Forms.GroupBox()
        Me.GroupBox18 = New System.Windows.Forms.GroupBox()
        Me.TreeView2 = New System.Windows.Forms.TreeView()
        Me.Panel5 = New System.Windows.Forms.Panel()
        Me.GroupBox19 = New System.Windows.Forms.GroupBox()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.Button21 = New System.Windows.Forms.Button()
        Me.GroupBox20 = New System.Windows.Forms.GroupBox()
        Me.TextBox11 = New System.Windows.Forms.TextBox()
        Me.Button22 = New System.Windows.Forms.Button()
        Me.GroupBox21 = New System.Windows.Forms.GroupBox()
        Me.TextBox12 = New System.Windows.Forms.TextBox()
        Me.Button23 = New System.Windows.Forms.Button()
        Me.Label26 = New System.Windows.Forms.Label()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.GroupBox22 = New System.Windows.Forms.GroupBox()
        Me.Label28 = New System.Windows.Forms.Label()
        Me.DateTimePicker13 = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox23 = New System.Windows.Forms.GroupBox()
        Me.Button24 = New System.Windows.Forms.Button()
        Me.Button25 = New System.Windows.Forms.Button()
        Me.Label41 = New System.Windows.Forms.Label()
        Me.Label42 = New System.Windows.Forms.Label()
        Me.CheckBox2 = New System.Windows.Forms.CheckBox()
        Me.CheckBox6 = New System.Windows.Forms.CheckBox()
        Me.TextBox13 = New System.Windows.Forms.TextBox()
        Me.Label43 = New System.Windows.Forms.Label()
        Me.Label44 = New System.Windows.Forms.Label()
        Me.Label45 = New System.Windows.Forms.Label()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label46 = New System.Windows.Forms.Label()
        Me.Label47 = New System.Windows.Forms.Label()
        Me.TextBox14 = New System.Windows.Forms.TextBox()
        Me.ComboBox2 = New System.Windows.Forms.ComboBox()
        Me.TextBox15 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker14 = New System.Windows.Forms.DateTimePicker()
        Me.Label48 = New System.Windows.Forms.Label()
        Me.DateTimePicker15 = New System.Windows.Forms.DateTimePicker()
        Me.Label49 = New System.Windows.Forms.Label()
        Me.Label50 = New System.Windows.Forms.Label()
        Me.Label51 = New System.Windows.Forms.Label()
        Me.Label52 = New System.Windows.Forms.Label()
        Me.CheckBox7 = New System.Windows.Forms.CheckBox()
        Me.CheckBox8 = New System.Windows.Forms.CheckBox()
        Me.CheckBox9 = New System.Windows.Forms.CheckBox()
        Me.TextBox16 = New System.Windows.Forms.TextBox()
        Me.TextBox17 = New System.Windows.Forms.TextBox()
        Me.TextBox18 = New System.Windows.Forms.TextBox()
        Me.Label53 = New System.Windows.Forms.Label()
        Me.Label54 = New System.Windows.Forms.Label()
        Me.Label55 = New System.Windows.Forms.Label()
        Me.DateTimePicker16 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker17 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker18 = New System.Windows.Forms.DateTimePicker()
        Me.Button26 = New System.Windows.Forms.Button()
        Me.Button27 = New System.Windows.Forms.Button()
        Me.Button28 = New System.Windows.Forms.Button()
        Me.Panel6 = New System.Windows.Forms.Panel()
        Me.PartnerList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.btnPartnersuche = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.LBSelectHost = New System.Windows.Forms.ListBox()
        Me.Button11 = New System.Windows.Forms.Button()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.lbselect = New System.Windows.Forms.ListBox()
        Me.LBSort = New System.Windows.Forms.ListBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.lbSortfields = New System.Windows.Forms.ListBox()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage4 = New System.Windows.Forms.TabPage()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.colbtn6 = New System.Windows.Forms.Button()
        Me.colbtn5 = New System.Windows.Forms.Button()
        Me.colbtn4 = New System.Windows.Forms.Button()
        Me.colbtn3 = New System.Windows.Forms.Button()
        Me.colbtn2 = New System.Windows.Forms.Button()
        Me.colbtn1 = New System.Windows.Forms.Button()
        Me.GroupBox9 = New System.Windows.Forms.GroupBox()
        Me.cb3_1 = New System.Windows.Forms.CheckBox()
        Me.cb5 = New System.Windows.Forms.CheckBox()
        Me.cb4 = New System.Windows.Forms.CheckBox()
        Me.cb3 = New System.Windows.Forms.CheckBox()
        Me.cb2 = New System.Windows.Forms.CheckBox()
        Me.cb1 = New System.Windows.Forms.CheckBox()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.Label31 = New System.Windows.Forms.Label()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.Label30 = New System.Windows.Forms.Label()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.Panel2.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage1.SuspendLayout()
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox13.SuspendLayout()
        Me.GroupBox15.SuspendLayout()
        Me.PnlDokumentart.SuspendLayout()
        Me.GroupBox16.SuspendLayout()
        Me.PnlDokumentDaten.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox10.SuspendLayout()
        Me.pnlhostdiv.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.GroupBox11.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        Me.GroupBox6.SuspendLayout()
        Me.GroupBox24.SuspendLayout()
        Me.GroupBox31.SuspendLayout()
        Me.GroupBox32.SuspendLayout()
        Me.Panel9.SuspendLayout()
        Me.GroupBox33.SuspendLayout()
        Me.GroupBox34.SuspendLayout()
        Me.GroupBox35.SuspendLayout()
        Me.GroupBox37.SuspendLayout()
        Me.Panel10.SuspendLayout()
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox30.SuspendLayout()
        Me.GroupBox25.SuspendLayout()
        Me.GroupBox26.SuspendLayout()
        Me.GroupBox27.SuspendLayout()
        Me.Panel7.SuspendLayout()
        Me.GroupBox28.SuspendLayout()
        Me.GroupBox29.SuspendLayout()
        Me.GroupBox38.SuspendLayout()
        Me.GroupBox40.SuspendLayout()
        Me.Panel8.SuspendLayout()
        CType(Me.C1TrueDBGrid4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox41.SuspendLayout()
        Me.GroupBox14.SuspendLayout()
        Me.GroupBox17.SuspendLayout()
        Me.GroupBox18.SuspendLayout()
        Me.Panel5.SuspendLayout()
        Me.GroupBox19.SuspendLayout()
        Me.GroupBox20.SuspendLayout()
        Me.GroupBox21.SuspendLayout()
        Me.GroupBox23.SuspendLayout()
        Me.Panel6.SuspendLayout()
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel4.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage4.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox9.SuspendLayout()
        Me.GroupBox5.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.SuspendLayout()
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem5})
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 0
        Me.MenuItem5.Text = "&Schliessen"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnClose, Me.btnOpen, Me.btnSave, Me.btnini})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(682, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnClose
        '
        Me.btnClose.ImageIndex = 0
        Me.btnClose.ToolTipText = "Fenster schliessen"
        '
        'btnOpen
        '
        Me.btnOpen.ImageIndex = 7
        Me.btnOpen.Visible = False
        '
        'btnSave
        '
        Me.btnSave.ImageIndex = 1
        Me.btnSave.Visible = False
        '
        'btnini
        '
        Me.btnini.ImageIndex = 12
        Me.btnini.ToolTipText = "Profil initialisieren"
        Me.btnini.Visible = False
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(682, 8)
        Me.Panel1.TabIndex = 4
        '
        'MnuListe
        '
        Me.MnuListe.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem12, Me.MenuItem6, Me.MenuItem7, Me.MenuItem9, Me.MenuItem11, Me.MenuItem13, Me.MenuItem8, Me.MenuItem10})
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 0
        Me.MenuItem12.Text = "Übernehmen"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 1
        Me.MenuItem6.Text = "Auswählen"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 2
        Me.MenuItem7.Text = "Als Standard"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 3
        Me.MenuItem9.Text = "-"
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 4
        Me.MenuItem11.Text = "Neus Profil"
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 5
        Me.MenuItem13.Text = "Profil kopieren"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 6
        Me.MenuItem8.Text = "Umbenennen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 7
        Me.MenuItem10.Text = "Löschen"
        '
        'Panel2
        '
        Me.Panel2.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Profile})
        Me.Panel2.Location = New System.Drawing.Point(0, 33)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(176, 544)
        Me.Panel2.TabIndex = 11
        '
        'Profile
        '
        Me.Profile.ContextMenu = Me.MnuListe
        Me.Profile.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Profile.FullRowSelect = True
        Me.Profile.ImageIndex = -1
        Me.Profile.Name = "Profile"
        Me.Profile.SelectedImageIndex = -1
        Me.Profile.ShowLines = False
        Me.Profile.ShowPlusMinus = False
        Me.Profile.Size = New System.Drawing.Size(174, 542)
        Me.Profile.Sorted = True
        Me.Profile.TabIndex = 0
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(200, 552)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(112, 24)
        Me.Button4.TabIndex = 14
        Me.Button4.Text = "Übernehmen"
        '
        'Label25
        '
        Me.Label25.Location = New System.Drawing.Point(16, 64)
        Me.Label25.Name = "Label25"
        Me.Label25.Size = New System.Drawing.Size(48, 23)
        Me.Label25.TabIndex = 3
        '
        'ComboBox10
        '
        Me.ComboBox10.Location = New System.Drawing.Point(64, 64)
        Me.ComboBox10.Name = "ComboBox10"
        Me.ComboBox10.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox10.TabIndex = 2
        '
        'Label24
        '
        Me.Label24.Location = New System.Drawing.Point(16, 32)
        Me.Label24.Name = "Label24"
        Me.Label24.Size = New System.Drawing.Size(48, 23)
        Me.Label24.TabIndex = 1
        '
        'ComboBox9
        '
        Me.ComboBox9.Location = New System.Drawing.Point(64, 32)
        Me.ComboBox9.Name = "ComboBox9"
        Me.ComboBox9.Size = New System.Drawing.Size(216, 21)
        Me.ComboBox9.TabIndex = 0
        '
        'ctmenu1
        '
        Me.ctmenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDel, Me.MenuItem14})
        '
        'MnuDel
        '
        Me.MnuDel.Index = 0
        Me.MnuDel.Text = "Eintrag löschen"
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 1
        Me.MenuItem14.Text = "Einträge löschen"
        '
        'CTMenuErsteller
        '
        Me.CTMenuErsteller.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem15, Me.MenuItem16})
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 0
        Me.MenuItem15.Text = "Partner übernehmen"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 1
        Me.MenuItem16.Text = "Detailinformationen"
        '
        'CTMenuVerantwortlicher
        '
        Me.CTMenuVerantwortlicher.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem20})
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 0
        Me.MenuItem20.Text = "Eintrag übernehmen"
        '
        'CTMenuMutierer
        '
        Me.CTMenuMutierer.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem24, Me.MenuItem25, Me.MenuItem26, Me.MenuItem27})
        '
        'MenuItem24
        '
        Me.MenuItem24.Index = 0
        Me.MenuItem24.Text = "&Eintrag selektieren"
        '
        'MenuItem25
        '
        Me.MenuItem25.Index = 1
        Me.MenuItem25.Text = "&Selektion aufheben"
        '
        'MenuItem26
        '
        Me.MenuItem26.Index = 2
        Me.MenuItem26.Text = "-"
        '
        'MenuItem27
        '
        Me.MenuItem27.Index = 3
        Me.MenuItem27.Text = "&Alle aufheben"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "profil", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp"), New System.Data.Common.DataColumnMapping("doktyp", "doktyp"), New System.Data.Common.DataColumnMapping("inklmavip", "inklmavip"), New System.Data.Common.DataColumnMapping("inklalt", "inklalt"), New System.Data.Common.DataColumnMapping("hostpartner", "hostpartner"), New System.Data.Common.DataColumnMapping("hostdokart", "hostdokart"), New System.Data.Common.DataColumnMapping("hostdoktyp", "hostdoktyp"), New System.Data.Common.DataColumnMapping("hosttag1", "hosttag1"), New System.Data.Common.DataColumnMapping("hostdatum1", "hostdatum1"), New System.Data.Common.DataColumnMapping("hosttag2", "hosttag2"), New System.Data.Common.DataColumnMapping("hostdatum2", "hostdatum2"), New System.Data.Common.DataColumnMapping("hosttag3", "hosttag3"), New System.Data.Common.DataColumnMapping("hostdatum3", "hostdatum3"), New System.Data.Common.DataColumnMapping("inklhostmavip", "inklhostmavip")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_profil_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_profil_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 50, "hosttag1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 50, "hostdatum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 50, "hosttag2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 50, "hostdatum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 50, "hosttag3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 50, "hostdatum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_profil_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_profil_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param2", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@doktyp", System.Data.SqlDbType.VarChar, 255, "doktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklmavip", System.Data.SqlDbType.Bit, 1, "inklmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklalt", System.Data.SqlDbType.Bit, 1, "inklalt"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostpartner", System.Data.SqlDbType.VarChar, 255, "hostpartner"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokart", System.Data.SqlDbType.VarChar, 255, "hostdokart"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdoktyp", System.Data.SqlDbType.VarChar, 255, "hostdoktyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag1", System.Data.SqlDbType.VarChar, 50, "hosttag1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum1", System.Data.SqlDbType.VarChar, 50, "hostdatum1"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag2", System.Data.SqlDbType.VarChar, 50, "hosttag2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum2", System.Data.SqlDbType.VarChar, 50, "hostdatum2"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hosttag3", System.Data.SqlDbType.VarChar, 50, "hosttag3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdatum3", System.Data.SqlDbType.VarChar, 50, "hostdatum3"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@inklhostmavip", System.Data.SqlDbType.Bit, 1, "inklhostmavip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profilnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profilnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktive", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktive", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_color8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "color8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum4", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum5", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum6", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum7", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datum8", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datum8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ddokstatus", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ddokstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_doktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "doktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ekost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ekost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ema", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ema", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_emb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "emb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_enl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "enl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstaelterals", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstaelterals", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdatum3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdatum3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokart", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokart", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdoktyp", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdoktyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostpartner", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostpartner", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag1", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag2", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hosttag3", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hosttag3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw10", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw10", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw11", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw11", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw2", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw2", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw3", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw3", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw4", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw4", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw5", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw5", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw6", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw6", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw7", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw7", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw8", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw8", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hw9", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hw9", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklhostmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklhostmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_inklmavip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "inklmavip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mteam", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutaelterasl", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutaelterasl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_profiltyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "profiltyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sort", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_standard", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "standard", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_team", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "team", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftlinks", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftlinks", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschriftrechts", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschriftrechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vkost", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vkost", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vma", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vma", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vmb", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vmb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vnl", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vnl", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vteam", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vteam", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(0, 33)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 642)
        Me.Splitter1.TabIndex = 15
        Me.Splitter1.TabStop = False
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem17, Me.MenuItem18, Me.MenuItem21, Me.MenuItem22, Me.MenuItem19})
        '
        'MenuItem17
        '
        Me.MenuItem17.Index = 0
        Me.MenuItem17.Text = "&Aufwärts"
        '
        'MenuItem18
        '
        Me.MenuItem18.Index = 1
        Me.MenuItem18.Text = "A&bwärts"
        '
        'MenuItem21
        '
        Me.MenuItem21.Index = 2
        Me.MenuItem21.Text = "Sortierung ändern"
        '
        'MenuItem22
        '
        Me.MenuItem22.Index = 3
        Me.MenuItem22.Text = "-"
        '
        'MenuItem19
        '
        Me.MenuItem19.Index = 4
        Me.MenuItem19.Text = "&Löschen"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuSelectDokumentart, Me.MnuDeleteDokumentart, Me.MenuItem2, Me.MenuItem3, Me.MenuItem4})
        '
        'MnuSelectDokumentart
        '
        Me.MnuSelectDokumentart.Index = 0
        Me.MnuSelectDokumentart.Text = "Eintrag auswählen"
        '
        'MnuDeleteDokumentart
        '
        Me.MnuDeleteDokumentart.Index = 1
        Me.MnuDeleteDokumentart.Text = "Eintrag abwählen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 3
        Me.MenuItem3.Text = "Knoten öffnen"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 4
        Me.MenuItem4.Text = "Knoten schliessen"
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid3, Me.Button46, Me.Label93, Me.TextBox40, Me.Label94, Me.TextBox41, Me.Label95, Me.TextBox42, Me.TreeView1, Me.GroupBox13, Me.GroupBox14, Me.Panel4, Me.Panel3, Me.C1TrueDBGrid1})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(671, 616)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Selektion /Sortierung"
        '
        'C1TrueDBGrid3
        '
        Me.C1TrueDBGrid3.AllowFilter = True
        Me.C1TrueDBGrid3.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid3.AllowSort = True
        Me.C1TrueDBGrid3.CaptionHeight = 17
        Me.C1TrueDBGrid3.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid3.DataChanged = False
        Me.C1TrueDBGrid3.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid3.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid3.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid3.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid3.Location = New System.Drawing.Point(304, 0)
        Me.C1TrueDBGrid3.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid3.Name = "C1TrueDBGrid3"
        Me.C1TrueDBGrid3.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid3.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid3.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid3.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid3.RowDivider = GridLines1
        Me.C1TrueDBGrid3.RowHeight = 15
        Me.C1TrueDBGrid3.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid3.ScrollTips = False
        Me.C1TrueDBGrid3.TabIndex = 20
        Me.C1TrueDBGrid3.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" Def" & _
        "RecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0" & _
        ", 0, 0, 0</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 0, 0<" & _
        "/ClientArea></Blob>"
        '
        'Button46
        '
        Me.Button46.Location = New System.Drawing.Point(936, 456)
        Me.Button46.Name = "Button46"
        Me.Button46.TabIndex = 21
        Me.Button46.Visible = False
        '
        'Label93
        '
        Me.Label93.Location = New System.Drawing.Point(1016, 424)
        Me.Label93.Name = "Label93"
        Me.Label93.TabIndex = 22
        '
        'TextBox40
        '
        Me.TextBox40.Location = New System.Drawing.Point(1040, 464)
        Me.TextBox40.Name = "TextBox40"
        Me.TextBox40.TabIndex = 23
        Me.TextBox40.Text = ""
        '
        'Label94
        '
        Me.Label94.Location = New System.Drawing.Point(928, 384)
        Me.Label94.Name = "Label94"
        Me.Label94.TabIndex = 24
        '
        'TextBox41
        '
        Me.TextBox41.Location = New System.Drawing.Point(1024, 176)
        Me.TextBox41.Name = "TextBox41"
        Me.TextBox41.TabIndex = 25
        Me.TextBox41.Text = ""
        '
        'Label95
        '
        Me.Label95.Location = New System.Drawing.Point(968, 224)
        Me.Label95.Name = "Label95"
        Me.Label95.TabIndex = 26
        '
        'TextBox42
        '
        Me.TextBox42.Location = New System.Drawing.Point(1008, 104)
        Me.TextBox42.Name = "TextBox42"
        Me.TextBox42.TabIndex = 27
        Me.TextBox42.Text = ""
        '
        'TreeView1
        '
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeView1.FullRowSelect = True
        Me.TreeView1.ImageList = Me.ImageList2
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Dokument", 0, 0, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Daten"), New System.Windows.Forms.TreeNode("Dokumentart"), New System.Windows.Forms.TreeNode("Dokumentstatus"), New System.Windows.Forms.TreeNode("Partner")}), New System.Windows.Forms.TreeNode("Ersteller", 8, 8, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Mutierer", 9, 9, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Verantwortlich", 7, 7, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")})})
        Me.TreeView1.Size = New System.Drawing.Size(368, 616)
        Me.TreeView1.TabIndex = 0
        '
        'GroupBox13
        '
        Me.GroupBox13.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox15, Me.GroupBox16, Me.PnlDokumentDaten, Me.pnlhostdiv, Me.GroupBox24, Me.GroupBox25})
        Me.GroupBox13.Location = New System.Drawing.Point(376, 8)
        Me.GroupBox13.Name = "GroupBox13"
        Me.GroupBox13.Size = New System.Drawing.Size(296, 600)
        Me.GroupBox13.TabIndex = 9
        Me.GroupBox13.TabStop = False
        Me.GroupBox13.Text = "Dokumentarten"
        '
        'GroupBox15
        '
        Me.GroupBox15.Controls.AddRange(New System.Windows.Forms.Control() {Me.PnlDokumentart})
        Me.GroupBox15.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox15.Name = "GroupBox15"
        Me.GroupBox15.Size = New System.Drawing.Size(280, 280)
        Me.GroupBox15.TabIndex = 0
        Me.GroupBox15.TabStop = False
        Me.GroupBox15.Text = "EDOKA-Dokumente"
        '
        'PnlDokumentart
        '
        Me.PnlDokumentart.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVDokart})
        Me.PnlDokumentart.Location = New System.Drawing.Point(8, 16)
        Me.PnlDokumentart.Name = "PnlDokumentart"
        Me.PnlDokumentart.Size = New System.Drawing.Size(264, 256)
        Me.PnlDokumentart.TabIndex = 4
        '
        'TVDokart
        '
        Me.TVDokart.ImageIndex = -1
        Me.TVDokart.Name = "TVDokart"
        Me.TVDokart.SelectedImageIndex = -1
        Me.TVDokart.Size = New System.Drawing.Size(264, 256)
        Me.TVDokart.TabIndex = 0
        '
        'GroupBox16
        '
        Me.GroupBox16.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVHostDok})
        Me.GroupBox16.Location = New System.Drawing.Point(8, 312)
        Me.GroupBox16.Name = "GroupBox16"
        Me.GroupBox16.Size = New System.Drawing.Size(280, 280)
        Me.GroupBox16.TabIndex = 8
        Me.GroupBox16.TabStop = False
        Me.GroupBox16.Text = "HOST-Dokumente"
        '
        'TVHostDok
        '
        Me.TVHostDok.ImageIndex = -1
        Me.TVHostDok.Location = New System.Drawing.Point(8, 16)
        Me.TVHostDok.Name = "TVHostDok"
        Me.TVHostDok.SelectedImageIndex = -1
        Me.TVHostDok.Size = New System.Drawing.Size(264, 256)
        Me.TVHostDok.TabIndex = 6
        '
        'PnlDokumentDaten
        '
        Me.PnlDokumentDaten.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label8, Me.Label7, Me.Label6, Me.Label5, Me.cbd6, Me.cbd4, Me.cbd2, Me.Label18, Me.Label16, Me.Label15, Me.Label14, Me.Label13, Me.GroupBox3, Me.GroupBox10, Me.Button1, Me.Button2, Me.Button3})
        Me.PnlDokumentDaten.Location = New System.Drawing.Point(16, 232)
        Me.PnlDokumentDaten.Name = "PnlDokumentDaten"
        Me.PnlDokumentDaten.Size = New System.Drawing.Size(128, 16)
        Me.PnlDokumentDaten.TabIndex = 1
        Me.PnlDokumentDaten.Visible = False
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(256, 344)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(40, 23)
        Me.Label8.TabIndex = 70
        Me.Label8.Text = "Tagen"
        Me.Label8.Visible = False
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(256, 320)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(40, 23)
        Me.Label7.TabIndex = 69
        Me.Label7.Text = "Tagen"
        Me.Label7.Visible = False
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(32, 344)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(160, 23)
        Me.Label6.TabIndex = 67
        Me.Label6.Text = "Mutationsdatum in den letzen "
        Me.Label6.Visible = False
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(32, 320)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(160, 23)
        Me.Label5.TabIndex = 66
        Me.Label5.Text = "Erstellungsdatum in den letzen"
        Me.Label5.Visible = False
        '
        'cbd6
        '
        Me.cbd6.Location = New System.Drawing.Point(16, 464)
        Me.cbd6.Name = "cbd6"
        Me.cbd6.Size = New System.Drawing.Size(16, 24)
        Me.cbd6.TabIndex = 64
        Me.cbd6.Visible = False
        '
        'cbd4
        '
        Me.cbd4.Location = New System.Drawing.Point(16, 440)
        Me.cbd4.Name = "cbd4"
        Me.cbd4.Size = New System.Drawing.Size(16, 24)
        Me.cbd4.TabIndex = 62
        Me.cbd4.Visible = False
        '
        'cbd2
        '
        Me.cbd2.Location = New System.Drawing.Point(16, 416)
        Me.cbd2.Name = "cbd2"
        Me.cbd2.Size = New System.Drawing.Size(16, 24)
        Me.cbd2.TabIndex = 60
        Me.cbd2.Visible = False
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(48, 464)
        Me.Label18.Name = "Label18"
        Me.Label18.TabIndex = 53
        Me.Label18.Text = "Archivierung bis"
        Me.Label18.Visible = False
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(48, 440)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 51
        Me.Label16.Text = "Mutation bis"
        Me.Label16.Visible = False
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(8, 88)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(64, 23)
        Me.Label15.TabIndex = 50
        Me.Label15.Text = "Mutation"
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(48, 416)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(96, 23)
        Me.Label14.TabIndex = 49
        Me.Label14.Text = "Erstellung bis"
        Me.Label14.Visible = False
        '
        'Label13
        '
        Me.Label13.Location = New System.Drawing.Point(8, 32)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(56, 23)
        Me.Label13.TabIndex = 48
        Me.Label13.Text = "Erstellung"
        '
        'GroupBox3
        '
        Me.GroupBox3.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button17, Me.Button16, Me.Button15, Me.Button14, Me.Button13, Me.Button12, Me.cbrollend6, Me.cbrollend5, Me.cbrollend4, Me.cbrollend3, Me.Label39, Me.Label40, Me.Label12, Me.Label23, Me.cbrollend2, Me.cbrollend1, Me.Label11, Me.Label10, Me.txtdatum1, Me.DateTimePicker1, Me.txtdatum2, Me.DateTimePicker2, Me.txtdatum3, Me.txtdatum4, Me.Label17, Me.txtdatum5, Me.txtdatum6, Me.DateTimePicker6, Me.DateTimePicker3, Me.DateTimePicker4, Me.DateTimePicker5, Me.datumtext6, Me.datumtext5, Me.datumtext4, Me.datumtext3, Me.datumtext2, Me.datumtext1})
        Me.GroupBox3.Location = New System.Drawing.Point(0, 8)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(280, 184)
        Me.GroupBox3.TabIndex = 83
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Datumsselektion"
        '
        'Button17
        '
        Me.Button17.Image = CType(resources.GetObject("Button17.Image"), System.Drawing.Bitmap)
        Me.Button17.Location = New System.Drawing.Point(288, 173)
        Me.Button17.Name = "Button17"
        Me.Button17.Size = New System.Drawing.Size(32, 24)
        Me.Button17.TabIndex = 78
        '
        'Button16
        '
        Me.Button16.Image = CType(resources.GetObject("Button16.Image"), System.Drawing.Bitmap)
        Me.Button16.Location = New System.Drawing.Point(288, 149)
        Me.Button16.Name = "Button16"
        Me.Button16.Size = New System.Drawing.Size(32, 24)
        Me.Button16.TabIndex = 77
        '
        'Button15
        '
        Me.Button15.Image = CType(resources.GetObject("Button15.Image"), System.Drawing.Bitmap)
        Me.Button15.Location = New System.Drawing.Point(288, 117)
        Me.Button15.Name = "Button15"
        Me.Button15.Size = New System.Drawing.Size(32, 24)
        Me.Button15.TabIndex = 76
        '
        'Button14
        '
        Me.Button14.Image = CType(resources.GetObject("Button14.Image"), System.Drawing.Bitmap)
        Me.Button14.Location = New System.Drawing.Point(288, 93)
        Me.Button14.Name = "Button14"
        Me.Button14.Size = New System.Drawing.Size(32, 24)
        Me.Button14.TabIndex = 75
        '
        'Button13
        '
        Me.Button13.Image = CType(resources.GetObject("Button13.Image"), System.Drawing.Bitmap)
        Me.Button13.Location = New System.Drawing.Point(288, 61)
        Me.Button13.Name = "Button13"
        Me.Button13.Size = New System.Drawing.Size(32, 24)
        Me.Button13.TabIndex = 74
        '
        'Button12
        '
        Me.Button12.Image = CType(resources.GetObject("Button12.Image"), System.Drawing.Bitmap)
        Me.Button12.Location = New System.Drawing.Point(288, 37)
        Me.Button12.Name = "Button12"
        Me.Button12.Size = New System.Drawing.Size(32, 24)
        Me.Button12.TabIndex = 73
        '
        'cbrollend6
        '
        Me.cbrollend6.Location = New System.Drawing.Point(216, 160)
        Me.cbrollend6.Name = "cbrollend6"
        Me.cbrollend6.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend6.TabIndex = 68
        Me.cbrollend6.Text = "(rollend)"
        '
        'cbrollend5
        '
        Me.cbrollend5.Location = New System.Drawing.Point(216, 136)
        Me.cbrollend5.Name = "cbrollend5"
        Me.cbrollend5.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend5.TabIndex = 67
        Me.cbrollend5.Text = "(rollend)"
        '
        'cbrollend4
        '
        Me.cbrollend4.Location = New System.Drawing.Point(216, 104)
        Me.cbrollend4.Name = "cbrollend4"
        Me.cbrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend4.TabIndex = 66
        Me.cbrollend4.Text = "(rollend)"
        '
        'cbrollend3
        '
        Me.cbrollend3.Location = New System.Drawing.Point(216, 80)
        Me.cbrollend3.Name = "cbrollend3"
        Me.cbrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend3.TabIndex = 65
        Me.cbrollend3.Text = "(rollend)"
        '
        'Label39
        '
        Me.Label39.Location = New System.Drawing.Point(72, 160)
        Me.Label39.Name = "Label39"
        Me.Label39.Size = New System.Drawing.Size(32, 23)
        Me.Label39.TabIndex = 64
        Me.Label39.Text = "bis"
        '
        'Label40
        '
        Me.Label40.Location = New System.Drawing.Point(72, 136)
        Me.Label40.Name = "Label40"
        Me.Label40.Size = New System.Drawing.Size(32, 23)
        Me.Label40.TabIndex = 63
        Me.Label40.Text = "von"
        '
        'Label12
        '
        Me.Label12.Enabled = False
        Me.Label12.Location = New System.Drawing.Point(72, 104)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(32, 23)
        Me.Label12.TabIndex = 62
        Me.Label12.Text = "bis"
        '
        'Label23
        '
        Me.Label23.Enabled = False
        Me.Label23.Location = New System.Drawing.Point(72, 80)
        Me.Label23.Name = "Label23"
        Me.Label23.Size = New System.Drawing.Size(32, 23)
        Me.Label23.TabIndex = 61
        Me.Label23.Text = "von"
        '
        'cbrollend2
        '
        Me.cbrollend2.Location = New System.Drawing.Point(216, 48)
        Me.cbrollend2.Name = "cbrollend2"
        Me.cbrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbrollend2.TabIndex = 58
        Me.cbrollend2.Text = "(rollend)"
        '
        'cbrollend1
        '
        Me.cbrollend1.Location = New System.Drawing.Point(216, 24)
        Me.cbrollend1.Name = "cbrollend1"
        Me.cbrollend1.Size = New System.Drawing.Size(80, 24)
        Me.cbrollend1.TabIndex = 57
        Me.cbrollend1.Text = "(rollend)"
        '
        'Label11
        '
        Me.Label11.Enabled = False
        Me.Label11.Location = New System.Drawing.Point(72, 48)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(32, 23)
        Me.Label11.TabIndex = 56
        Me.Label11.Text = "bis"
        '
        'Label10
        '
        Me.Label10.Enabled = False
        Me.Label10.Location = New System.Drawing.Point(72, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(32, 23)
        Me.Label10.TabIndex = 0
        Me.Label10.Text = "von"
        '
        'txtdatum1
        '
        Me.txtdatum1.BackColor = System.Drawing.Color.White
        Me.txtdatum1.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1.Location = New System.Drawing.Point(112, 24)
        Me.txtdatum1.Name = "txtdatum1"
        Me.txtdatum1.ReadOnly = True
        Me.txtdatum1.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1.TabIndex = 54
        Me.txtdatum1.Text = ""
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker1.Location = New System.Drawing.Point(112, 24)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker1.TabIndex = 42
        Me.DateTimePicker1.TabStop = False
        Me.DateTimePicker1.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'txtdatum2
        '
        Me.txtdatum2.BackColor = System.Drawing.Color.White
        Me.txtdatum2.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2.Location = New System.Drawing.Point(112, 48)
        Me.txtdatum2.Name = "txtdatum2"
        Me.txtdatum2.ReadOnly = True
        Me.txtdatum2.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2.TabIndex = 55
        Me.txtdatum2.Text = ""
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker2.Location = New System.Drawing.Point(112, 48)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker2.TabIndex = 43
        Me.DateTimePicker2.TabStop = False
        Me.DateTimePicker2.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'txtdatum3
        '
        Me.txtdatum3.BackColor = System.Drawing.Color.White
        Me.txtdatum3.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3.Location = New System.Drawing.Point(112, 80)
        Me.txtdatum3.Name = "txtdatum3"
        Me.txtdatum3.ReadOnly = True
        Me.txtdatum3.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3.TabIndex = 56
        Me.txtdatum3.Text = ""
        '
        'txtdatum4
        '
        Me.txtdatum4.BackColor = System.Drawing.Color.White
        Me.txtdatum4.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4.Location = New System.Drawing.Point(112, 104)
        Me.txtdatum4.Name = "txtdatum4"
        Me.txtdatum4.ReadOnly = True
        Me.txtdatum4.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4.TabIndex = 57
        Me.txtdatum4.Text = ""
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 136)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(72, 23)
        Me.Label17.TabIndex = 52
        Me.Label17.Text = "Archivierung"
        '
        'txtdatum5
        '
        Me.txtdatum5.BackColor = System.Drawing.Color.White
        Me.txtdatum5.ForeColor = System.Drawing.Color.Black
        Me.txtdatum5.Location = New System.Drawing.Point(112, 136)
        Me.txtdatum5.Name = "txtdatum5"
        Me.txtdatum5.ReadOnly = True
        Me.txtdatum5.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum5.TabIndex = 58
        Me.txtdatum5.Text = ""
        '
        'txtdatum6
        '
        Me.txtdatum6.BackColor = System.Drawing.Color.White
        Me.txtdatum6.ForeColor = System.Drawing.Color.Black
        Me.txtdatum6.Location = New System.Drawing.Point(112, 160)
        Me.txtdatum6.Name = "txtdatum6"
        Me.txtdatum6.ReadOnly = True
        Me.txtdatum6.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum6.TabIndex = 59
        Me.txtdatum6.Text = ""
        '
        'DateTimePicker6
        '
        Me.DateTimePicker6.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker6.Location = New System.Drawing.Point(112, 160)
        Me.DateTimePicker6.Name = "DateTimePicker6"
        Me.DateTimePicker6.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker6.TabIndex = 47
        Me.DateTimePicker6.TabStop = False
        Me.DateTimePicker6.Value = New Date(2004, 1, 14, 18, 49, 58, 703)
        '
        'DateTimePicker3
        '
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(112, 80)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker3.TabIndex = 44
        Me.DateTimePicker3.TabStop = False
        Me.DateTimePicker3.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'DateTimePicker4
        '
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(112, 104)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker4.TabIndex = 45
        Me.DateTimePicker4.TabStop = False
        Me.DateTimePicker4.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'DateTimePicker5
        '
        Me.DateTimePicker5.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker5.Location = New System.Drawing.Point(112, 136)
        Me.DateTimePicker5.Name = "DateTimePicker5"
        Me.DateTimePicker5.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker5.TabIndex = 46
        Me.DateTimePicker5.TabStop = False
        Me.DateTimePicker5.Value = New Date(2004, 1, 14, 18, 49, 58, 703)
        '
        'datumtext6
        '
        Me.datumtext6.Location = New System.Drawing.Point(224, 160)
        Me.datumtext6.Name = "datumtext6"
        Me.datumtext6.TabIndex = 72
        Me.datumtext6.Visible = False
        '
        'datumtext5
        '
        Me.datumtext5.Location = New System.Drawing.Point(224, 136)
        Me.datumtext5.Name = "datumtext5"
        Me.datumtext5.TabIndex = 71
        Me.datumtext5.Visible = False
        '
        'datumtext4
        '
        Me.datumtext4.Location = New System.Drawing.Point(224, 104)
        Me.datumtext4.Name = "datumtext4"
        Me.datumtext4.TabIndex = 70
        Me.datumtext4.Visible = False
        '
        'datumtext3
        '
        Me.datumtext3.Location = New System.Drawing.Point(224, 80)
        Me.datumtext3.Name = "datumtext3"
        Me.datumtext3.TabIndex = 69
        Me.datumtext3.Visible = False
        '
        'datumtext2
        '
        Me.datumtext2.Location = New System.Drawing.Point(224, 48)
        Me.datumtext2.Name = "datumtext2"
        Me.datumtext2.TabIndex = 60
        Me.datumtext2.Visible = False
        '
        'datumtext1
        '
        Me.datumtext1.Location = New System.Drawing.Point(224, 24)
        Me.datumtext1.Name = "datumtext1"
        Me.datumtext1.TabIndex = 59
        Me.datumtext1.Visible = False
        '
        'GroupBox10
        '
        Me.GroupBox10.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox10.Controls.AddRange(New System.Windows.Forms.Control() {Me.cinklalt})
        Me.GroupBox10.Location = New System.Drawing.Point(0, 192)
        Me.GroupBox10.Name = "GroupBox10"
        Me.GroupBox10.Size = New System.Drawing.Size(280, 56)
        Me.GroupBox10.TabIndex = 85
        Me.GroupBox10.TabStop = False
        Me.GroupBox10.Text = "Datenselektion"
        '
        'cinklalt
        '
        Me.cinklalt.Location = New System.Drawing.Point(16, 16)
        Me.cinklalt.Name = "cinklalt"
        Me.cinklalt.Size = New System.Drawing.Size(216, 32)
        Me.cinklalt.TabIndex = 84
        Me.cinklalt.Text = "Dokumentselektion inkl. gelöschte/aufgehobene Dokumente"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(344, 48)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(16, 16)
        Me.Button1.TabIndex = 74
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(344, 88)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(16, 16)
        Me.Button2.TabIndex = 75
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(344, 136)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(16, 16)
        Me.Button3.TabIndex = 76
        '
        'pnlhostdiv
        '
        Me.pnlhostdiv.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox4, Me.GroupBox11, Me.GroupBox8, Me.Label20, Me.hostinklmavip, Me.GroupBox7, Me.Label29, Me.DateTimePicker7, Me.GroupBox6, Me.Label32, Me.Label33, Me.Label34, Me.Label35, Me.CheckBox3, Me.CheckBox4, Me.CheckBox5, Me.TextBox7, Me.TextBox8, Me.TextBox9, Me.Label36, Me.Label37, Me.Label38, Me.DateTimePicker10, Me.DateTimePicker11, Me.DateTimePicker12, Me.Button8, Me.Button7, Me.Button6})
        Me.pnlhostdiv.Location = New System.Drawing.Point(16, 264)
        Me.pnlhostdiv.Name = "pnlhostdiv"
        Me.pnlhostdiv.Size = New System.Drawing.Size(152, 24)
        Me.pnlhostdiv.TabIndex = 7
        Me.pnlhostdiv.Visible = False
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox6, Me.Button20})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox4.TabIndex = 91
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "VV-Nummer extern"
        '
        'TextBox6
        '
        Me.TextBox6.Location = New System.Drawing.Point(8, 24)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.Size = New System.Drawing.Size(112, 20)
        Me.TextBox6.TabIndex = 87
        Me.TextBox6.Text = ""
        '
        'Button20
        '
        Me.Button20.Location = New System.Drawing.Point(128, 24)
        Me.Button20.Name = "Button20"
        Me.Button20.Size = New System.Drawing.Size(40, 23)
        Me.Button20.TabIndex = 88
        Me.Button20.Text = "&OK"
        '
        'GroupBox11
        '
        Me.GroupBox11.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox5, Me.Button10})
        Me.GroupBox11.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox11.Name = "GroupBox11"
        Me.GroupBox11.Size = New System.Drawing.Size(360, 64)
        Me.GroupBox11.TabIndex = 90
        Me.GroupBox11.TabStop = False
        Me.GroupBox11.Text = "ISIN-Nummer"
        '
        'TextBox5
        '
        Me.TextBox5.Location = New System.Drawing.Point(8, 24)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.Size = New System.Drawing.Size(112, 20)
        Me.TextBox5.TabIndex = 88
        Me.TextBox5.Text = ""
        '
        'Button10
        '
        Me.Button10.Location = New System.Drawing.Point(128, 24)
        Me.Button10.Name = "Button10"
        Me.Button10.Size = New System.Drawing.Size(40, 23)
        Me.Button10.TabIndex = 89
        Me.Button10.Text = "&OK"
        '
        'GroupBox8
        '
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox4, Me.Button9})
        Me.GroupBox8.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox8.TabIndex = 89
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Valoren-Nummer"
        '
        'TextBox4
        '
        Me.TextBox4.Location = New System.Drawing.Point(8, 24)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.Size = New System.Drawing.Size(112, 20)
        Me.TextBox4.TabIndex = 87
        Me.TextBox4.Text = ""
        '
        'Button9
        '
        Me.Button9.Location = New System.Drawing.Point(128, 24)
        Me.Button9.Name = "Button9"
        Me.Button9.Size = New System.Drawing.Size(40, 23)
        Me.Button9.TabIndex = 88
        Me.Button9.Text = "&OK"
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(80, 312)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 86
        Me.Label20.Text = "ISIN-Nummer"
        Me.Label20.Visible = False
        '
        'hostinklmavip
        '
        Me.hostinklmavip.Location = New System.Drawing.Point(16, 376)
        Me.hostinklmavip.Name = "hostinklmavip"
        Me.hostinklmavip.Size = New System.Drawing.Size(264, 24)
        Me.hostinklmavip.TabIndex = 82
        Me.hostinklmavip.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.hostinklmavip.Visible = False
        '
        'GroupBox7
        '
        Me.GroupBox7.Location = New System.Drawing.Point(8, 360)
        Me.GroupBox7.Name = "GroupBox7"
        Me.GroupBox7.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox7.TabIndex = 84
        Me.GroupBox7.TabStop = False
        Me.GroupBox7.Text = "Datenselektion"
        Me.GroupBox7.Visible = False
        '
        'Label29
        '
        Me.Label29.Location = New System.Drawing.Point(8, 32)
        Me.Label29.Name = "Label29"
        Me.Label29.Size = New System.Drawing.Size(48, 32)
        Me.Label29.TabIndex = 48
        Me.Label29.Text = "Valuta-Datum"
        '
        'DateTimePicker7
        '
        Me.DateTimePicker7.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker7.Location = New System.Drawing.Point(264, 328)
        Me.DateTimePicker7.Name = "DateTimePicker7"
        Me.DateTimePicker7.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker7.TabIndex = 46
        Me.DateTimePicker7.TabStop = False
        Me.DateTimePicker7.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        Me.DateTimePicker7.Visible = False
        '
        'GroupBox6
        '
        Me.GroupBox6.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox6.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button18, Me.Button19, Me.DatumHostText2, Me.DatumHostText1, Me.cbrollend9, Me.cbrollend8, Me.HostDatum1, Me.Label9, Me.Label4, Me.lblhostdatum31, Me.ComboBox6, Me.Label27, Me.lblhostdatum3, Me.HostDatum3, Me.HostTag3, Me.HostDatum2, Me.DateTimePicker8, Me.lblhostdatum2, Me.DateTimePicker9})
        Me.GroupBox6.Location = New System.Drawing.Point(0, 8)
        Me.GroupBox6.Name = "GroupBox6"
        Me.GroupBox6.Size = New System.Drawing.Size(280, 88)
        Me.GroupBox6.TabIndex = 83
        Me.GroupBox6.TabStop = False
        Me.GroupBox6.Text = "Datumsselektion"
        '
        'Button18
        '
        Me.Button18.Image = CType(resources.GetObject("Button18.Image"), System.Drawing.Bitmap)
        Me.Button18.Location = New System.Drawing.Point(308, 49)
        Me.Button18.Name = "Button18"
        Me.Button18.Size = New System.Drawing.Size(32, 24)
        Me.Button18.TabIndex = 97
        '
        'Button19
        '
        Me.Button19.Image = CType(resources.GetObject("Button19.Image"), System.Drawing.Bitmap)
        Me.Button19.Location = New System.Drawing.Point(308, 25)
        Me.Button19.Name = "Button19"
        Me.Button19.Size = New System.Drawing.Size(32, 24)
        Me.Button19.TabIndex = 96
        '
        'DatumHostText2
        '
        Me.DatumHostText2.Location = New System.Drawing.Point(216, 80)
        Me.DatumHostText2.Name = "DatumHostText2"
        Me.DatumHostText2.TabIndex = 95
        Me.DatumHostText2.Text = "Label26"
        Me.DatumHostText2.Visible = False
        '
        'DatumHostText1
        '
        Me.DatumHostText1.Location = New System.Drawing.Point(88, 80)
        Me.DatumHostText1.Name = "DatumHostText1"
        Me.DatumHostText1.TabIndex = 94
        Me.DatumHostText1.Text = "Label26"
        Me.DatumHostText1.Visible = False
        '
        'cbrollend9
        '
        Me.cbrollend9.Location = New System.Drawing.Point(200, 48)
        Me.cbrollend9.Name = "cbrollend9"
        Me.cbrollend9.TabIndex = 93
        Me.cbrollend9.Text = "(rollend)"
        '
        'cbrollend8
        '
        Me.cbrollend8.Location = New System.Drawing.Point(200, 24)
        Me.cbrollend8.Name = "cbrollend8"
        Me.cbrollend8.Size = New System.Drawing.Size(96, 24)
        Me.cbrollend8.TabIndex = 92
        Me.cbrollend8.Text = "(rollend)"
        '
        'HostDatum1
        '
        Me.HostDatum1.BackColor = System.Drawing.Color.White
        Me.HostDatum1.ForeColor = System.Drawing.Color.Black
        Me.HostDatum1.Location = New System.Drawing.Point(96, 24)
        Me.HostDatum1.Name = "HostDatum1"
        Me.HostDatum1.ReadOnly = True
        Me.HostDatum1.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum1.TabIndex = 54
        Me.HostDatum1.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(56, 48)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(40, 23)
        Me.Label9.TabIndex = 91
        Me.Label9.Text = "bis"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(56, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(40, 23)
        Me.Label4.TabIndex = 90
        Me.Label4.Text = "von"
        '
        'lblhostdatum31
        '
        Me.lblhostdatum31.Location = New System.Drawing.Point(240, 152)
        Me.lblhostdatum31.Name = "lblhostdatum31"
        Me.lblhostdatum31.Size = New System.Drawing.Size(96, 16)
        Me.lblhostdatum31.TabIndex = 89
        Me.lblhostdatum31.Text = "(19.12.2003)"
        Me.lblhostdatum31.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.lblhostdatum31.Visible = False
        '
        'ComboBox6
        '
        Me.ComboBox6.ItemHeight = 13
        Me.ComboBox6.Items.AddRange(New Object() {"(heute)", "(heute-1)", "(heute-2)", "(heute-3)", "(heute-4)", "(heute-5)", "(heute-6)", "(heute-7)", "(heute-8)", "(heute-9)", "(heute-10)", "(heute-11)", "(heute-12)", "(heute-13)", "(heute-14)", "(heute-15)", "(heute-16)", "(heute-17)", "(heute-18)", "(heute-19)", "(heute-20)", "(heute-21)", "(heute-22)", "(heute-23)", "(heute-24)", "(heute-25)", "(heute-26)", "(heute-27)", "(heute-28)", "(heute-29)", "(heute-30)"})
        Me.ComboBox6.Location = New System.Drawing.Point(240, 128)
        Me.ComboBox6.Name = "ComboBox6"
        Me.ComboBox6.Size = New System.Drawing.Size(115, 21)
        Me.ComboBox6.TabIndex = 3
        Me.ComboBox6.Text = "ComboBox6"
        Me.ComboBox6.Visible = False
        '
        'Label27
        '
        Me.Label27.Location = New System.Drawing.Point(8, 128)
        Me.Label27.Name = "Label27"
        Me.Label27.Size = New System.Drawing.Size(72, 23)
        Me.Label27.TabIndex = 52
        Me.Label27.Text = "Archivierung"
        Me.Label27.Visible = False
        '
        'lblhostdatum3
        '
        Me.lblhostdatum3.Location = New System.Drawing.Point(160, 128)
        Me.lblhostdatum3.Name = "lblhostdatum3"
        Me.lblhostdatum3.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum3.TabIndex = 79
        Me.lblhostdatum3.Visible = False
        '
        'HostDatum3
        '
        Me.HostDatum3.BackColor = System.Drawing.Color.White
        Me.HostDatum3.Enabled = False
        Me.HostDatum3.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.HostDatum3.Location = New System.Drawing.Point(240, 128)
        Me.HostDatum3.Name = "HostDatum3"
        Me.HostDatum3.ReadOnly = True
        Me.HostDatum3.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum3.TabIndex = 58
        Me.HostDatum3.Text = "TextBox4"
        Me.HostDatum3.Visible = False
        '
        'HostTag3
        '
        Me.HostTag3.ItemHeight = 13
        Me.HostTag3.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.HostTag3.Location = New System.Drawing.Point(80, 128)
        Me.HostTag3.Name = "HostTag3"
        Me.HostTag3.Size = New System.Drawing.Size(56, 21)
        Me.HostTag3.TabIndex = 71
        Me.HostTag3.Text = "HostTag3"
        Me.HostTag3.Visible = False
        '
        'HostDatum2
        '
        Me.HostDatum2.BackColor = System.Drawing.Color.White
        Me.HostDatum2.ForeColor = System.Drawing.Color.Black
        Me.HostDatum2.Location = New System.Drawing.Point(96, 48)
        Me.HostDatum2.Name = "HostDatum2"
        Me.HostDatum2.ReadOnly = True
        Me.HostDatum2.Size = New System.Drawing.Size(79, 20)
        Me.HostDatum2.TabIndex = 56
        Me.HostDatum2.Text = ""
        '
        'DateTimePicker8
        '
        Me.DateTimePicker8.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker8.Location = New System.Drawing.Point(96, 48)
        Me.DateTimePicker8.Name = "DateTimePicker8"
        Me.DateTimePicker8.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker8.TabIndex = 44
        Me.DateTimePicker8.TabStop = False
        Me.DateTimePicker8.Value = New Date(2004, 1, 14, 18, 49, 59, 203)
        '
        'lblhostdatum2
        '
        Me.lblhostdatum2.Location = New System.Drawing.Point(160, 72)
        Me.lblhostdatum2.Name = "lblhostdatum2"
        Me.lblhostdatum2.Size = New System.Drawing.Size(72, 21)
        Me.lblhostdatum2.TabIndex = 78
        Me.lblhostdatum2.Visible = False
        '
        'DateTimePicker9
        '
        Me.DateTimePicker9.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker9.Location = New System.Drawing.Point(96, 24)
        Me.DateTimePicker9.Name = "DateTimePicker9"
        Me.DateTimePicker9.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker9.TabIndex = 42
        Me.DateTimePicker9.TabStop = False
        Me.DateTimePicker9.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        '
        'Label32
        '
        Me.Label32.Location = New System.Drawing.Point(304, 456)
        Me.Label32.Name = "Label32"
        Me.Label32.Size = New System.Drawing.Size(40, 23)
        Me.Label32.TabIndex = 70
        Me.Label32.Text = "Tagen"
        Me.Label32.Visible = False
        '
        'Label33
        '
        Me.Label33.Location = New System.Drawing.Point(304, 432)
        Me.Label33.Name = "Label33"
        Me.Label33.Size = New System.Drawing.Size(40, 23)
        Me.Label33.TabIndex = 69
        Me.Label33.Text = "Tagen"
        Me.Label33.Visible = False
        '
        'Label34
        '
        Me.Label34.Location = New System.Drawing.Point(80, 456)
        Me.Label34.Name = "Label34"
        Me.Label34.Size = New System.Drawing.Size(160, 23)
        Me.Label34.TabIndex = 67
        Me.Label34.Text = "Mutationsdatum in den letzen "
        Me.Label34.Visible = False
        '
        'Label35
        '
        Me.Label35.Location = New System.Drawing.Point(80, 432)
        Me.Label35.Name = "Label35"
        Me.Label35.Size = New System.Drawing.Size(160, 23)
        Me.Label35.TabIndex = 66
        Me.Label35.Text = "Erstellungsdatum in den letzen"
        Me.Label35.Visible = False
        '
        'CheckBox3
        '
        Me.CheckBox3.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox3.Name = "CheckBox3"
        Me.CheckBox3.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox3.TabIndex = 64
        Me.CheckBox3.Visible = False
        '
        'CheckBox4
        '
        Me.CheckBox4.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox4.Name = "CheckBox4"
        Me.CheckBox4.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox4.TabIndex = 62
        Me.CheckBox4.Visible = False
        '
        'CheckBox5
        '
        Me.CheckBox5.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox5.Name = "CheckBox5"
        Me.CheckBox5.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox5.TabIndex = 60
        Me.CheckBox5.Visible = False
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.White
        Me.TextBox7.Enabled = False
        Me.TextBox7.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox7.Location = New System.Drawing.Point(160, 464)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(80, 20)
        Me.TextBox7.TabIndex = 59
        Me.TextBox7.Text = "TextBox4"
        Me.TextBox7.Visible = False
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.White
        Me.TextBox8.Enabled = False
        Me.TextBox8.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox8.Location = New System.Drawing.Point(160, 440)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(80, 20)
        Me.TextBox8.TabIndex = 57
        Me.TextBox8.Text = "TextBox4"
        Me.TextBox8.Visible = False
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.White
        Me.TextBox9.Enabled = False
        Me.TextBox9.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox9.Location = New System.Drawing.Point(160, 416)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(80, 20)
        Me.TextBox9.TabIndex = 55
        Me.TextBox9.Text = "TextBox4"
        Me.TextBox9.Visible = False
        '
        'Label36
        '
        Me.Label36.Location = New System.Drawing.Point(48, 464)
        Me.Label36.Name = "Label36"
        Me.Label36.TabIndex = 53
        Me.Label36.Text = "Archivierung bis"
        Me.Label36.Visible = False
        '
        'Label37
        '
        Me.Label37.Location = New System.Drawing.Point(48, 440)
        Me.Label37.Name = "Label37"
        Me.Label37.Size = New System.Drawing.Size(96, 23)
        Me.Label37.TabIndex = 51
        Me.Label37.Text = "Mutation bis"
        Me.Label37.Visible = False
        '
        'Label38
        '
        Me.Label38.Location = New System.Drawing.Point(48, 416)
        Me.Label38.Name = "Label38"
        Me.Label38.Size = New System.Drawing.Size(96, 23)
        Me.Label38.TabIndex = 49
        Me.Label38.Text = "Erstellung bis"
        Me.Label38.Visible = False
        '
        'DateTimePicker10
        '
        Me.DateTimePicker10.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker10.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker10.Name = "DateTimePicker10"
        Me.DateTimePicker10.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker10.TabIndex = 47
        Me.DateTimePicker10.TabStop = False
        Me.DateTimePicker10.Value = New Date(2004, 1, 14, 18, 49, 59, 312)
        Me.DateTimePicker10.Visible = False
        '
        'DateTimePicker11
        '
        Me.DateTimePicker11.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker11.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker11.Name = "DateTimePicker11"
        Me.DateTimePicker11.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker11.TabIndex = 45
        Me.DateTimePicker11.TabStop = False
        Me.DateTimePicker11.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker11.Visible = False
        '
        'DateTimePicker12
        '
        Me.DateTimePicker12.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker12.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker12.Name = "DateTimePicker12"
        Me.DateTimePicker12.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker12.TabIndex = 43
        Me.DateTimePicker12.TabStop = False
        Me.DateTimePicker12.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker12.Visible = False
        '
        'Button8
        '
        Me.Button8.Location = New System.Drawing.Point(344, 48)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(16, 16)
        Me.Button8.TabIndex = 74
        '
        'Button7
        '
        Me.Button7.Location = New System.Drawing.Point(344, 80)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(16, 16)
        Me.Button7.TabIndex = 75
        '
        'Button6
        '
        Me.Button6.Location = New System.Drawing.Point(360, 336)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(16, 16)
        Me.Button6.TabIndex = 76
        Me.Button6.Visible = False
        '
        'GroupBox24
        '
        Me.GroupBox24.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox31, Me.GroupBox30})
        Me.GroupBox24.Location = New System.Drawing.Point(16, 344)
        Me.GroupBox24.Name = "GroupBox24"
        Me.GroupBox24.Size = New System.Drawing.Size(232, 32)
        Me.GroupBox24.TabIndex = 19
        Me.GroupBox24.TabStop = False
        Me.GroupBox24.Text = "ZV-Belege"
        Me.GroupBox24.Visible = False
        '
        'GroupBox31
        '
        Me.GroupBox31.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox32, Me.Panel9, Me.Panel10})
        Me.GroupBox31.Location = New System.Drawing.Point(592, 8)
        Me.GroupBox31.Name = "GroupBox31"
        Me.GroupBox31.Size = New System.Drawing.Size(296, 488)
        Me.GroupBox31.TabIndex = 10
        Me.GroupBox31.TabStop = False
        Me.GroupBox31.Text = "Host-Dokumente"
        '
        'GroupBox32
        '
        Me.GroupBox32.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeView4})
        Me.GroupBox32.Location = New System.Drawing.Point(8, 24)
        Me.GroupBox32.Name = "GroupBox32"
        Me.GroupBox32.Size = New System.Drawing.Size(280, 160)
        Me.GroupBox32.TabIndex = 8
        Me.GroupBox32.TabStop = False
        Me.GroupBox32.Text = "Dokumentart"
        '
        'TreeView4
        '
        Me.TreeView4.ImageIndex = -1
        Me.TreeView4.Location = New System.Drawing.Point(8, 16)
        Me.TreeView4.Name = "TreeView4"
        Me.TreeView4.SelectedImageIndex = -1
        Me.TreeView4.Size = New System.Drawing.Size(264, 136)
        Me.TreeView4.TabIndex = 6
        '
        'Panel9
        '
        Me.Panel9.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox33, Me.GroupBox34, Me.GroupBox35, Me.Label73, Me.CheckBox16, Me.GroupBox36, Me.Label74, Me.DateTimePicker25, Me.GroupBox37, Me.Label83, Me.Label84, Me.Label85, Me.Label86, Me.CheckBox19, Me.CheckBox20, Me.CheckBox21, Me.TextBox34, Me.TextBox35, Me.TextBox36, Me.Label87, Me.Label88, Me.Label89, Me.DateTimePicker28, Me.DateTimePicker29, Me.DateTimePicker30, Me.Button42, Me.Button43, Me.Button44})
        Me.Panel9.Location = New System.Drawing.Point(8, 192)
        Me.Panel9.Name = "Panel9"
        Me.Panel9.Size = New System.Drawing.Size(280, 104)
        Me.Panel9.TabIndex = 7
        '
        'GroupBox33
        '
        Me.GroupBox33.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox28, Me.Button37})
        Me.GroupBox33.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox33.Name = "GroupBox33"
        Me.GroupBox33.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox33.TabIndex = 91
        Me.GroupBox33.TabStop = False
        Me.GroupBox33.Text = "VV-Nummer extern"
        '
        'TextBox28
        '
        Me.TextBox28.Location = New System.Drawing.Point(8, 24)
        Me.TextBox28.Name = "TextBox28"
        Me.TextBox28.Size = New System.Drawing.Size(112, 20)
        Me.TextBox28.TabIndex = 87
        Me.TextBox28.Text = ""
        '
        'Button37
        '
        Me.Button37.Location = New System.Drawing.Point(128, 24)
        Me.Button37.Name = "Button37"
        Me.Button37.Size = New System.Drawing.Size(40, 23)
        Me.Button37.TabIndex = 88
        Me.Button37.Text = "&OK"
        '
        'GroupBox34
        '
        Me.GroupBox34.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox29, Me.Button38})
        Me.GroupBox34.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox34.Name = "GroupBox34"
        Me.GroupBox34.Size = New System.Drawing.Size(360, 64)
        Me.GroupBox34.TabIndex = 90
        Me.GroupBox34.TabStop = False
        Me.GroupBox34.Text = "ISIN-Nummer"
        '
        'TextBox29
        '
        Me.TextBox29.Location = New System.Drawing.Point(8, 24)
        Me.TextBox29.Name = "TextBox29"
        Me.TextBox29.Size = New System.Drawing.Size(112, 20)
        Me.TextBox29.TabIndex = 88
        Me.TextBox29.Text = ""
        '
        'Button38
        '
        Me.Button38.Location = New System.Drawing.Point(128, 24)
        Me.Button38.Name = "Button38"
        Me.Button38.Size = New System.Drawing.Size(40, 23)
        Me.Button38.TabIndex = 89
        Me.Button38.Text = "&OK"
        '
        'GroupBox35
        '
        Me.GroupBox35.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox30, Me.Button39})
        Me.GroupBox35.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox35.Name = "GroupBox35"
        Me.GroupBox35.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox35.TabIndex = 89
        Me.GroupBox35.TabStop = False
        Me.GroupBox35.Text = "Valoren-Nummer"
        '
        'TextBox30
        '
        Me.TextBox30.Location = New System.Drawing.Point(8, 24)
        Me.TextBox30.Name = "TextBox30"
        Me.TextBox30.Size = New System.Drawing.Size(112, 20)
        Me.TextBox30.TabIndex = 87
        Me.TextBox30.Text = ""
        '
        'Button39
        '
        Me.Button39.Location = New System.Drawing.Point(128, 24)
        Me.Button39.Name = "Button39"
        Me.Button39.Size = New System.Drawing.Size(40, 23)
        Me.Button39.TabIndex = 88
        Me.Button39.Text = "&OK"
        '
        'Label73
        '
        Me.Label73.Location = New System.Drawing.Point(80, 312)
        Me.Label73.Name = "Label73"
        Me.Label73.Size = New System.Drawing.Size(80, 23)
        Me.Label73.TabIndex = 86
        Me.Label73.Text = "ISIN-Nummer"
        Me.Label73.Visible = False
        '
        'CheckBox16
        '
        Me.CheckBox16.Location = New System.Drawing.Point(16, 376)
        Me.CheckBox16.Name = "CheckBox16"
        Me.CheckBox16.Size = New System.Drawing.Size(264, 24)
        Me.CheckBox16.TabIndex = 82
        Me.CheckBox16.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.CheckBox16.Visible = False
        '
        'GroupBox36
        '
        Me.GroupBox36.Location = New System.Drawing.Point(8, 360)
        Me.GroupBox36.Name = "GroupBox36"
        Me.GroupBox36.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox36.TabIndex = 84
        Me.GroupBox36.TabStop = False
        Me.GroupBox36.Text = "Datenselektion"
        Me.GroupBox36.Visible = False
        '
        'Label74
        '
        Me.Label74.Location = New System.Drawing.Point(8, 32)
        Me.Label74.Name = "Label74"
        Me.Label74.Size = New System.Drawing.Size(48, 32)
        Me.Label74.TabIndex = 48
        Me.Label74.Text = "Valuta-Datum"
        '
        'DateTimePicker25
        '
        Me.DateTimePicker25.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker25.Location = New System.Drawing.Point(264, 328)
        Me.DateTimePicker25.Name = "DateTimePicker25"
        Me.DateTimePicker25.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker25.TabIndex = 46
        Me.DateTimePicker25.TabStop = False
        Me.DateTimePicker25.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        Me.DateTimePicker25.Visible = False
        '
        'GroupBox37
        '
        Me.GroupBox37.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox37.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button40, Me.Button41, Me.Label75, Me.Label76, Me.CheckBox17, Me.CheckBox18, Me.TextBox31, Me.Label77, Me.Label78, Me.Label79, Me.ComboBox5, Me.Label80, Me.Label81, Me.TextBox32, Me.ComboBox7, Me.TextBox33, Me.DateTimePicker26, Me.Label82, Me.DateTimePicker27})
        Me.GroupBox37.Location = New System.Drawing.Point(0, 8)
        Me.GroupBox37.Name = "GroupBox37"
        Me.GroupBox37.Size = New System.Drawing.Size(280, 88)
        Me.GroupBox37.TabIndex = 83
        Me.GroupBox37.TabStop = False
        Me.GroupBox37.Text = "Datumsselektion"
        '
        'Button40
        '
        Me.Button40.Image = CType(resources.GetObject("Button40.Image"), System.Drawing.Bitmap)
        Me.Button40.Location = New System.Drawing.Point(308, 49)
        Me.Button40.Name = "Button40"
        Me.Button40.Size = New System.Drawing.Size(32, 24)
        Me.Button40.TabIndex = 97
        '
        'Button41
        '
        Me.Button41.Image = CType(resources.GetObject("Button41.Image"), System.Drawing.Bitmap)
        Me.Button41.Location = New System.Drawing.Point(308, 25)
        Me.Button41.Name = "Button41"
        Me.Button41.Size = New System.Drawing.Size(32, 24)
        Me.Button41.TabIndex = 96
        '
        'Label75
        '
        Me.Label75.Location = New System.Drawing.Point(216, 80)
        Me.Label75.Name = "Label75"
        Me.Label75.TabIndex = 95
        Me.Label75.Text = "Label26"
        Me.Label75.Visible = False
        '
        'Label76
        '
        Me.Label76.Location = New System.Drawing.Point(88, 80)
        Me.Label76.Name = "Label76"
        Me.Label76.TabIndex = 94
        Me.Label76.Text = "Label26"
        Me.Label76.Visible = False
        '
        'CheckBox17
        '
        Me.CheckBox17.Location = New System.Drawing.Point(200, 48)
        Me.CheckBox17.Name = "CheckBox17"
        Me.CheckBox17.TabIndex = 93
        Me.CheckBox17.Text = "(rollend)"
        '
        'CheckBox18
        '
        Me.CheckBox18.Location = New System.Drawing.Point(200, 24)
        Me.CheckBox18.Name = "CheckBox18"
        Me.CheckBox18.Size = New System.Drawing.Size(96, 24)
        Me.CheckBox18.TabIndex = 92
        Me.CheckBox18.Text = "(rollend)"
        '
        'TextBox31
        '
        Me.TextBox31.BackColor = System.Drawing.Color.White
        Me.TextBox31.ForeColor = System.Drawing.Color.Black
        Me.TextBox31.Location = New System.Drawing.Point(96, 24)
        Me.TextBox31.Name = "TextBox31"
        Me.TextBox31.ReadOnly = True
        Me.TextBox31.Size = New System.Drawing.Size(79, 20)
        Me.TextBox31.TabIndex = 54
        Me.TextBox31.Text = ""
        '
        'Label77
        '
        Me.Label77.Location = New System.Drawing.Point(56, 48)
        Me.Label77.Name = "Label77"
        Me.Label77.Size = New System.Drawing.Size(40, 23)
        Me.Label77.TabIndex = 91
        Me.Label77.Text = "bis"
        '
        'Label78
        '
        Me.Label78.Location = New System.Drawing.Point(56, 24)
        Me.Label78.Name = "Label78"
        Me.Label78.Size = New System.Drawing.Size(40, 23)
        Me.Label78.TabIndex = 90
        Me.Label78.Text = "von"
        '
        'Label79
        '
        Me.Label79.Location = New System.Drawing.Point(240, 152)
        Me.Label79.Name = "Label79"
        Me.Label79.Size = New System.Drawing.Size(96, 16)
        Me.Label79.TabIndex = 89
        Me.Label79.Text = "(19.12.2003)"
        Me.Label79.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.Label79.Visible = False
        '
        'ComboBox5
        '
        Me.ComboBox5.ItemHeight = 13
        Me.ComboBox5.Items.AddRange(New Object() {"(heute)", "(heute-1)", "(heute-2)", "(heute-3)", "(heute-4)", "(heute-5)", "(heute-6)", "(heute-7)", "(heute-8)", "(heute-9)", "(heute-10)", "(heute-11)", "(heute-12)", "(heute-13)", "(heute-14)", "(heute-15)", "(heute-16)", "(heute-17)", "(heute-18)", "(heute-19)", "(heute-20)", "(heute-21)", "(heute-22)", "(heute-23)", "(heute-24)", "(heute-25)", "(heute-26)", "(heute-27)", "(heute-28)", "(heute-29)", "(heute-30)"})
        Me.ComboBox5.Location = New System.Drawing.Point(240, 128)
        Me.ComboBox5.Name = "ComboBox5"
        Me.ComboBox5.Size = New System.Drawing.Size(115, 21)
        Me.ComboBox5.TabIndex = 3
        Me.ComboBox5.Text = "ComboBox6"
        Me.ComboBox5.Visible = False
        '
        'Label80
        '
        Me.Label80.Location = New System.Drawing.Point(8, 128)
        Me.Label80.Name = "Label80"
        Me.Label80.Size = New System.Drawing.Size(72, 23)
        Me.Label80.TabIndex = 52
        Me.Label80.Text = "Archivierung"
        Me.Label80.Visible = False
        '
        'Label81
        '
        Me.Label81.Location = New System.Drawing.Point(160, 128)
        Me.Label81.Name = "Label81"
        Me.Label81.Size = New System.Drawing.Size(72, 21)
        Me.Label81.TabIndex = 79
        Me.Label81.Visible = False
        '
        'TextBox32
        '
        Me.TextBox32.BackColor = System.Drawing.Color.White
        Me.TextBox32.Enabled = False
        Me.TextBox32.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox32.Location = New System.Drawing.Point(240, 128)
        Me.TextBox32.Name = "TextBox32"
        Me.TextBox32.ReadOnly = True
        Me.TextBox32.Size = New System.Drawing.Size(79, 20)
        Me.TextBox32.TabIndex = 58
        Me.TextBox32.Text = "TextBox4"
        Me.TextBox32.Visible = False
        '
        'ComboBox7
        '
        Me.ComboBox7.ItemHeight = 13
        Me.ComboBox7.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.ComboBox7.Location = New System.Drawing.Point(80, 128)
        Me.ComboBox7.Name = "ComboBox7"
        Me.ComboBox7.Size = New System.Drawing.Size(56, 21)
        Me.ComboBox7.TabIndex = 71
        Me.ComboBox7.Text = "HostTag3"
        Me.ComboBox7.Visible = False
        '
        'TextBox33
        '
        Me.TextBox33.BackColor = System.Drawing.Color.White
        Me.TextBox33.ForeColor = System.Drawing.Color.Black
        Me.TextBox33.Location = New System.Drawing.Point(96, 48)
        Me.TextBox33.Name = "TextBox33"
        Me.TextBox33.ReadOnly = True
        Me.TextBox33.Size = New System.Drawing.Size(79, 20)
        Me.TextBox33.TabIndex = 56
        Me.TextBox33.Text = ""
        '
        'DateTimePicker26
        '
        Me.DateTimePicker26.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker26.Location = New System.Drawing.Point(96, 48)
        Me.DateTimePicker26.Name = "DateTimePicker26"
        Me.DateTimePicker26.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker26.TabIndex = 44
        Me.DateTimePicker26.TabStop = False
        Me.DateTimePicker26.Value = New Date(2004, 1, 14, 18, 49, 59, 203)
        '
        'Label82
        '
        Me.Label82.Location = New System.Drawing.Point(160, 72)
        Me.Label82.Name = "Label82"
        Me.Label82.Size = New System.Drawing.Size(72, 21)
        Me.Label82.TabIndex = 78
        Me.Label82.Visible = False
        '
        'DateTimePicker27
        '
        Me.DateTimePicker27.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker27.Location = New System.Drawing.Point(96, 24)
        Me.DateTimePicker27.Name = "DateTimePicker27"
        Me.DateTimePicker27.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker27.TabIndex = 42
        Me.DateTimePicker27.TabStop = False
        Me.DateTimePicker27.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        '
        'Label83
        '
        Me.Label83.Location = New System.Drawing.Point(304, 456)
        Me.Label83.Name = "Label83"
        Me.Label83.Size = New System.Drawing.Size(40, 23)
        Me.Label83.TabIndex = 70
        Me.Label83.Text = "Tagen"
        Me.Label83.Visible = False
        '
        'Label84
        '
        Me.Label84.Location = New System.Drawing.Point(304, 432)
        Me.Label84.Name = "Label84"
        Me.Label84.Size = New System.Drawing.Size(40, 23)
        Me.Label84.TabIndex = 69
        Me.Label84.Text = "Tagen"
        Me.Label84.Visible = False
        '
        'Label85
        '
        Me.Label85.Location = New System.Drawing.Point(80, 456)
        Me.Label85.Name = "Label85"
        Me.Label85.Size = New System.Drawing.Size(160, 23)
        Me.Label85.TabIndex = 67
        Me.Label85.Text = "Mutationsdatum in den letzen "
        Me.Label85.Visible = False
        '
        'Label86
        '
        Me.Label86.Location = New System.Drawing.Point(80, 432)
        Me.Label86.Name = "Label86"
        Me.Label86.Size = New System.Drawing.Size(160, 23)
        Me.Label86.TabIndex = 66
        Me.Label86.Text = "Erstellungsdatum in den letzen"
        Me.Label86.Visible = False
        '
        'CheckBox19
        '
        Me.CheckBox19.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox19.Name = "CheckBox19"
        Me.CheckBox19.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox19.TabIndex = 64
        Me.CheckBox19.Visible = False
        '
        'CheckBox20
        '
        Me.CheckBox20.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox20.Name = "CheckBox20"
        Me.CheckBox20.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox20.TabIndex = 62
        Me.CheckBox20.Visible = False
        '
        'CheckBox21
        '
        Me.CheckBox21.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox21.Name = "CheckBox21"
        Me.CheckBox21.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox21.TabIndex = 60
        Me.CheckBox21.Visible = False
        '
        'TextBox34
        '
        Me.TextBox34.BackColor = System.Drawing.Color.White
        Me.TextBox34.Enabled = False
        Me.TextBox34.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox34.Location = New System.Drawing.Point(160, 464)
        Me.TextBox34.Name = "TextBox34"
        Me.TextBox34.ReadOnly = True
        Me.TextBox34.Size = New System.Drawing.Size(80, 20)
        Me.TextBox34.TabIndex = 59
        Me.TextBox34.Text = "TextBox4"
        Me.TextBox34.Visible = False
        '
        'TextBox35
        '
        Me.TextBox35.BackColor = System.Drawing.Color.White
        Me.TextBox35.Enabled = False
        Me.TextBox35.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox35.Location = New System.Drawing.Point(160, 440)
        Me.TextBox35.Name = "TextBox35"
        Me.TextBox35.ReadOnly = True
        Me.TextBox35.Size = New System.Drawing.Size(80, 20)
        Me.TextBox35.TabIndex = 57
        Me.TextBox35.Text = "TextBox4"
        Me.TextBox35.Visible = False
        '
        'TextBox36
        '
        Me.TextBox36.BackColor = System.Drawing.Color.White
        Me.TextBox36.Enabled = False
        Me.TextBox36.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox36.Location = New System.Drawing.Point(160, 416)
        Me.TextBox36.Name = "TextBox36"
        Me.TextBox36.ReadOnly = True
        Me.TextBox36.Size = New System.Drawing.Size(80, 20)
        Me.TextBox36.TabIndex = 55
        Me.TextBox36.Text = "TextBox4"
        Me.TextBox36.Visible = False
        '
        'Label87
        '
        Me.Label87.Location = New System.Drawing.Point(48, 464)
        Me.Label87.Name = "Label87"
        Me.Label87.TabIndex = 53
        Me.Label87.Text = "Archivierung bis"
        Me.Label87.Visible = False
        '
        'Label88
        '
        Me.Label88.Location = New System.Drawing.Point(48, 440)
        Me.Label88.Name = "Label88"
        Me.Label88.Size = New System.Drawing.Size(96, 23)
        Me.Label88.TabIndex = 51
        Me.Label88.Text = "Mutation bis"
        Me.Label88.Visible = False
        '
        'Label89
        '
        Me.Label89.Location = New System.Drawing.Point(48, 416)
        Me.Label89.Name = "Label89"
        Me.Label89.Size = New System.Drawing.Size(96, 23)
        Me.Label89.TabIndex = 49
        Me.Label89.Text = "Erstellung bis"
        Me.Label89.Visible = False
        '
        'DateTimePicker28
        '
        Me.DateTimePicker28.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker28.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker28.Name = "DateTimePicker28"
        Me.DateTimePicker28.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker28.TabIndex = 47
        Me.DateTimePicker28.TabStop = False
        Me.DateTimePicker28.Value = New Date(2004, 1, 14, 18, 49, 59, 312)
        Me.DateTimePicker28.Visible = False
        '
        'DateTimePicker29
        '
        Me.DateTimePicker29.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker29.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker29.Name = "DateTimePicker29"
        Me.DateTimePicker29.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker29.TabIndex = 45
        Me.DateTimePicker29.TabStop = False
        Me.DateTimePicker29.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker29.Visible = False
        '
        'DateTimePicker30
        '
        Me.DateTimePicker30.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker30.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker30.Name = "DateTimePicker30"
        Me.DateTimePicker30.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker30.TabIndex = 43
        Me.DateTimePicker30.TabStop = False
        Me.DateTimePicker30.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker30.Visible = False
        '
        'Button42
        '
        Me.Button42.Location = New System.Drawing.Point(344, 48)
        Me.Button42.Name = "Button42"
        Me.Button42.Size = New System.Drawing.Size(16, 16)
        Me.Button42.TabIndex = 74
        '
        'Button43
        '
        Me.Button43.Location = New System.Drawing.Point(344, 80)
        Me.Button43.Name = "Button43"
        Me.Button43.Size = New System.Drawing.Size(16, 16)
        Me.Button43.TabIndex = 75
        '
        'Button44
        '
        Me.Button44.Location = New System.Drawing.Point(360, 336)
        Me.Button44.Name = "Button44"
        Me.Button44.Size = New System.Drawing.Size(16, 16)
        Me.Button44.TabIndex = 76
        Me.Button44.Visible = False
        '
        'Panel10
        '
        Me.Panel10.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid2, Me.Button45, Me.Label90, Me.TextBox37, Me.Label91, Me.TextBox38, Me.Label92, Me.TextBox39})
        Me.Panel10.Location = New System.Drawing.Point(256, 432)
        Me.Panel10.Name = "Panel10"
        Me.Panel10.Size = New System.Drawing.Size(24, 40)
        Me.Panel10.TabIndex = 3
        Me.Panel10.Visible = False
        '
        'C1TrueDBGrid2
        '
        Me.C1TrueDBGrid2.AllowFilter = True
        Me.C1TrueDBGrid2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid2.AllowSort = True
        Me.C1TrueDBGrid2.AllowUpdate = False
        Me.C1TrueDBGrid2.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid2.AlternatingRows = True
        Me.C1TrueDBGrid2.CaptionHeight = 17
        Me.C1TrueDBGrid2.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.C1TrueDBGrid2.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.ContextMenu = Me.CTMenuErsteller
        Me.C1TrueDBGrid2.DataChanged = False
        Me.C1TrueDBGrid2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid2.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.C1TrueDBGrid2.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.FetchRowStyles = True
        Me.C1TrueDBGrid2.FilterBar = True
        Me.C1TrueDBGrid2.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid2.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid2.Location = New System.Drawing.Point(0, -360)
        Me.C1TrueDBGrid2.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid2.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.C1TrueDBGrid2.Name = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid2.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid2.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid2.RowDivider = GridLines2
        Me.C1TrueDBGrid2.RowHeight = 15
        Me.C1TrueDBGrid2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid2.ScrollTips = False
        Me.C1TrueDBGrid2.Size = New System.Drawing.Size(24, 400)
        Me.C1TrueDBGrid2.TabIndex = 17
        Me.C1TrueDBGrid2.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{Font:Microsoft Sans Serif, 8.25pt;}Highlight" & _
        "Row{ForeColor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:Silver" & _
        ";}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Ra" & _
        "ised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignH" & _
        "orz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1T" & _
        "rueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" Column" & _
        "CaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True" & _
        """ MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" V" & _
        "erticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 20, 396</Clie" & _
        "ntRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" />" & _
        "<Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Sty" & _
        "le parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Styl" & _
        "e parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style pa" & _
        "rent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style p" & _
        "arent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Styl" & _
        "e parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedS" & _
        "tyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><" & _
        "DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 20, 396</ClientArea>" & _
        "</Blob>"
        '
        'Button45
        '
        Me.Button45.Image = CType(resources.GetObject("Button45.Image"), System.Drawing.Bitmap)
        Me.Button45.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.Button45.Location = New System.Drawing.Point(288, 32)
        Me.Button45.Name = "Button45"
        Me.Button45.Size = New System.Drawing.Size(72, 40)
        Me.Button45.TabIndex = 16
        Me.Button45.Text = "&Suchen"
        Me.Button45.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label90
        '
        Me.Label90.Location = New System.Drawing.Point(8, 64)
        Me.Label90.Name = "Label90"
        Me.Label90.Size = New System.Drawing.Size(72, 23)
        Me.Label90.TabIndex = 15
        Me.Label90.Text = "Freitext"
        '
        'TextBox37
        '
        Me.TextBox37.Location = New System.Drawing.Point(88, 64)
        Me.TextBox37.Name = "TextBox37"
        Me.TextBox37.Size = New System.Drawing.Size(160, 20)
        Me.TextBox37.TabIndex = 14
        Me.TextBox37.Text = ""
        '
        'Label91
        '
        Me.Label91.Location = New System.Drawing.Point(8, 40)
        Me.Label91.Name = "Label91"
        Me.Label91.Size = New System.Drawing.Size(72, 23)
        Me.Label91.TabIndex = 13
        Me.Label91.Text = "Kurzname"
        '
        'TextBox38
        '
        Me.TextBox38.Location = New System.Drawing.Point(88, 40)
        Me.TextBox38.Name = "TextBox38"
        Me.TextBox38.Size = New System.Drawing.Size(160, 20)
        Me.TextBox38.TabIndex = 12
        Me.TextBox38.Text = ""
        '
        'Label92
        '
        Me.Label92.Location = New System.Drawing.Point(8, 16)
        Me.Label92.Name = "Label92"
        Me.Label92.Size = New System.Drawing.Size(72, 23)
        Me.Label92.TabIndex = 11
        Me.Label92.Text = "Partner-Nr."
        '
        'TextBox39
        '
        Me.TextBox39.Location = New System.Drawing.Point(88, 16)
        Me.TextBox39.Name = "TextBox39"
        Me.TextBox39.Size = New System.Drawing.Size(160, 20)
        Me.TextBox39.TabIndex = 10
        Me.TextBox39.Text = ""
        '
        'GroupBox30
        '
        Me.GroupBox30.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox30.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtdatum3zv, Me.txtdatum4zv, Me.txtdatum2zv, Me.cbzvrollend1, Me.Label56, Me.DateTimePicker19, Me.Label57, Me.Label58, Me.cbzvrollend4, Me.cbzvrollend2, Me.Label59, Me.txtdatum1zv, Me.Label60, Me.cbzvrollend3, Me.Label61, Me.textdatum1zv, Me.textdatum2zv, Me.textdatum3zv, Me.textdatum4zv, Me.DateTimePicker20, Me.DateTimePicker21, Me.DateTimePicker22, Me.Button32, Me.Button33})
        Me.GroupBox30.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox30.Name = "GroupBox30"
        Me.GroupBox30.Size = New System.Drawing.Size(280, 128)
        Me.GroupBox30.TabIndex = 83
        Me.GroupBox30.TabStop = False
        Me.GroupBox30.Text = "Datumsselektion"
        '
        'txtdatum3zv
        '
        Me.txtdatum3zv.BackColor = System.Drawing.Color.White
        Me.txtdatum3zv.Enabled = False
        Me.txtdatum3zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3zv.Location = New System.Drawing.Point(112, 80)
        Me.txtdatum3zv.Name = "txtdatum3zv"
        Me.txtdatum3zv.ReadOnly = True
        Me.txtdatum3zv.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3zv.TabIndex = 108
        Me.txtdatum3zv.Text = ""
        '
        'txtdatum4zv
        '
        Me.txtdatum4zv.BackColor = System.Drawing.Color.White
        Me.txtdatum4zv.Enabled = False
        Me.txtdatum4zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4zv.Location = New System.Drawing.Point(112, 104)
        Me.txtdatum4zv.Name = "txtdatum4zv"
        Me.txtdatum4zv.ReadOnly = True
        Me.txtdatum4zv.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4zv.TabIndex = 110
        Me.txtdatum4zv.Text = ""
        '
        'txtdatum2zv
        '
        Me.txtdatum2zv.BackColor = System.Drawing.Color.White
        Me.txtdatum2zv.Enabled = False
        Me.txtdatum2zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2zv.Location = New System.Drawing.Point(112, 48)
        Me.txtdatum2zv.Name = "txtdatum2zv"
        Me.txtdatum2zv.ReadOnly = True
        Me.txtdatum2zv.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2zv.TabIndex = 107
        Me.txtdatum2zv.Text = ""
        '
        'cbzvrollend1
        '
        Me.cbzvrollend1.Enabled = False
        Me.cbzvrollend1.Location = New System.Drawing.Point(216, 24)
        Me.cbzvrollend1.Name = "cbzvrollend1"
        Me.cbzvrollend1.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend1.TabIndex = 111
        Me.cbzvrollend1.Text = "(rollend)"
        '
        'Label56
        '
        Me.Label56.Location = New System.Drawing.Point(8, 80)
        Me.Label56.Name = "Label56"
        Me.Label56.Size = New System.Drawing.Size(64, 48)
        Me.Label56.TabIndex = 105
        Me.Label56.Text = "Archivie-rung"
        '
        'DateTimePicker19
        '
        Me.DateTimePicker19.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker19.Location = New System.Drawing.Point(112, 80)
        Me.DateTimePicker19.Name = "DateTimePicker19"
        Me.DateTimePicker19.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker19.TabIndex = 102
        Me.DateTimePicker19.TabStop = False
        Me.DateTimePicker19.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Label57
        '
        Me.Label57.Location = New System.Drawing.Point(72, 80)
        Me.Label57.Name = "Label57"
        Me.Label57.Size = New System.Drawing.Size(32, 23)
        Me.Label57.TabIndex = 115
        Me.Label57.Text = "von"
        '
        'Label58
        '
        Me.Label58.Location = New System.Drawing.Point(72, 104)
        Me.Label58.Name = "Label58"
        Me.Label58.Size = New System.Drawing.Size(32, 23)
        Me.Label58.TabIndex = 116
        Me.Label58.Text = "bis"
        '
        'cbzvrollend4
        '
        Me.cbzvrollend4.Enabled = False
        Me.cbzvrollend4.Location = New System.Drawing.Point(216, 104)
        Me.cbzvrollend4.Name = "cbzvrollend4"
        Me.cbzvrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend4.TabIndex = 118
        Me.cbzvrollend4.Text = "(rollend)"
        '
        'cbzvrollend2
        '
        Me.cbzvrollend2.Enabled = False
        Me.cbzvrollend2.Location = New System.Drawing.Point(216, 48)
        Me.cbzvrollend2.Name = "cbzvrollend2"
        Me.cbzvrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend2.TabIndex = 112
        Me.cbzvrollend2.Text = "(rollend)"
        '
        'Label59
        '
        Me.Label59.Location = New System.Drawing.Point(8, 24)
        Me.Label59.Name = "Label59"
        Me.Label59.Size = New System.Drawing.Size(56, 23)
        Me.Label59.TabIndex = 104
        Me.Label59.Text = "Valuta"
        '
        'txtdatum1zv
        '
        Me.txtdatum1zv.BackColor = System.Drawing.Color.White
        Me.txtdatum1zv.Enabled = False
        Me.txtdatum1zv.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1zv.Location = New System.Drawing.Point(112, 24)
        Me.txtdatum1zv.Name = "txtdatum1zv"
        Me.txtdatum1zv.ReadOnly = True
        Me.txtdatum1zv.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1zv.TabIndex = 106
        Me.txtdatum1zv.Text = ""
        '
        'Label60
        '
        Me.Label60.Location = New System.Drawing.Point(72, 48)
        Me.Label60.Name = "Label60"
        Me.Label60.Size = New System.Drawing.Size(32, 23)
        Me.Label60.TabIndex = 109
        Me.Label60.Text = "bis"
        '
        'cbzvrollend3
        '
        Me.cbzvrollend3.Enabled = False
        Me.cbzvrollend3.Location = New System.Drawing.Point(216, 80)
        Me.cbzvrollend3.Name = "cbzvrollend3"
        Me.cbzvrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbzvrollend3.TabIndex = 117
        Me.cbzvrollend3.Text = "(rollend)"
        '
        'Label61
        '
        Me.Label61.Location = New System.Drawing.Point(72, 24)
        Me.Label61.Name = "Label61"
        Me.Label61.Size = New System.Drawing.Size(32, 23)
        Me.Label61.TabIndex = 99
        Me.Label61.Text = "von"
        '
        'textdatum1zv
        '
        Me.textdatum1zv.Enabled = False
        Me.textdatum1zv.Location = New System.Drawing.Point(224, 24)
        Me.textdatum1zv.Name = "textdatum1zv"
        Me.textdatum1zv.TabIndex = 113
        Me.textdatum1zv.Visible = False
        '
        'textdatum2zv
        '
        Me.textdatum2zv.Enabled = False
        Me.textdatum2zv.Location = New System.Drawing.Point(224, 48)
        Me.textdatum2zv.Name = "textdatum2zv"
        Me.textdatum2zv.TabIndex = 114
        Me.textdatum2zv.Visible = False
        '
        'textdatum3zv
        '
        Me.textdatum3zv.Enabled = False
        Me.textdatum3zv.Location = New System.Drawing.Point(224, 80)
        Me.textdatum3zv.Name = "textdatum3zv"
        Me.textdatum3zv.TabIndex = 119
        Me.textdatum3zv.Visible = False
        '
        'textdatum4zv
        '
        Me.textdatum4zv.Enabled = False
        Me.textdatum4zv.Location = New System.Drawing.Point(224, 104)
        Me.textdatum4zv.Name = "textdatum4zv"
        Me.textdatum4zv.TabIndex = 120
        Me.textdatum4zv.Visible = False
        '
        'DateTimePicker20
        '
        Me.DateTimePicker20.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker20.Location = New System.Drawing.Point(112, 24)
        Me.DateTimePicker20.Name = "DateTimePicker20"
        Me.DateTimePicker20.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker20.TabIndex = 100
        Me.DateTimePicker20.TabStop = False
        Me.DateTimePicker20.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker21
        '
        Me.DateTimePicker21.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker21.Location = New System.Drawing.Point(112, 48)
        Me.DateTimePicker21.Name = "DateTimePicker21"
        Me.DateTimePicker21.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker21.TabIndex = 101
        Me.DateTimePicker21.TabStop = False
        Me.DateTimePicker21.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker22
        '
        Me.DateTimePicker22.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker22.Location = New System.Drawing.Point(112, 104)
        Me.DateTimePicker22.Name = "DateTimePicker22"
        Me.DateTimePicker22.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker22.TabIndex = 103
        Me.DateTimePicker22.TabStop = False
        Me.DateTimePicker22.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Button32
        '
        Me.Button32.Image = CType(resources.GetObject("Button32.Image"), System.Drawing.Bitmap)
        Me.Button32.Location = New System.Drawing.Point(308, 49)
        Me.Button32.Name = "Button32"
        Me.Button32.Size = New System.Drawing.Size(32, 24)
        Me.Button32.TabIndex = 97
        '
        'Button33
        '
        Me.Button33.Image = CType(resources.GetObject("Button33.Image"), System.Drawing.Bitmap)
        Me.Button33.Location = New System.Drawing.Point(308, 25)
        Me.Button33.Name = "Button33"
        Me.Button33.Size = New System.Drawing.Size(32, 24)
        Me.Button33.TabIndex = 96
        '
        'GroupBox25
        '
        Me.GroupBox25.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox26, Me.GroupBox41})
        Me.GroupBox25.Location = New System.Drawing.Point(16, 344)
        Me.GroupBox25.Name = "GroupBox25"
        Me.GroupBox25.Size = New System.Drawing.Size(232, 16)
        Me.GroupBox25.TabIndex = 28
        Me.GroupBox25.TabStop = False
        Me.GroupBox25.Text = "Basis-Verträge"
        '
        'GroupBox26
        '
        Me.GroupBox26.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox27, Me.Panel7, Me.Panel8})
        Me.GroupBox26.Location = New System.Drawing.Point(592, 8)
        Me.GroupBox26.Name = "GroupBox26"
        Me.GroupBox26.Size = New System.Drawing.Size(296, 488)
        Me.GroupBox26.TabIndex = 10
        Me.GroupBox26.TabStop = False
        Me.GroupBox26.Text = "Host-Dokumente"
        '
        'GroupBox27
        '
        Me.GroupBox27.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeView3})
        Me.GroupBox27.Location = New System.Drawing.Point(8, 24)
        Me.GroupBox27.Name = "GroupBox27"
        Me.GroupBox27.Size = New System.Drawing.Size(280, 160)
        Me.GroupBox27.TabIndex = 8
        Me.GroupBox27.TabStop = False
        Me.GroupBox27.Text = "Dokumentart"
        '
        'TreeView3
        '
        Me.TreeView3.ImageIndex = -1
        Me.TreeView3.Location = New System.Drawing.Point(8, 16)
        Me.TreeView3.Name = "TreeView3"
        Me.TreeView3.SelectedImageIndex = -1
        Me.TreeView3.Size = New System.Drawing.Size(264, 136)
        Me.TreeView3.TabIndex = 6
        '
        'Panel7
        '
        Me.Panel7.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox28, Me.GroupBox29, Me.GroupBox38, Me.Label62, Me.CheckBox10, Me.GroupBox39, Me.Label63, Me.DateTimePicker23, Me.GroupBox40, Me.Label72, Me.Label96, Me.Label97, Me.Label98, Me.CheckBox13, Me.CheckBox14, Me.CheckBox15, Me.TextBox25, Me.TextBox26, Me.TextBox27, Me.Label99, Me.Label100, Me.Label101, Me.DateTimePicker32, Me.DateTimePicker33, Me.DateTimePicker34, Me.Button36, Me.Button47, Me.Button48})
        Me.Panel7.Location = New System.Drawing.Point(8, 192)
        Me.Panel7.Name = "Panel7"
        Me.Panel7.Size = New System.Drawing.Size(280, 104)
        Me.Panel7.TabIndex = 7
        '
        'GroupBox28
        '
        Me.GroupBox28.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox19, Me.Button29})
        Me.GroupBox28.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox28.Name = "GroupBox28"
        Me.GroupBox28.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox28.TabIndex = 91
        Me.GroupBox28.TabStop = False
        Me.GroupBox28.Text = "VV-Nummer extern"
        '
        'TextBox19
        '
        Me.TextBox19.Location = New System.Drawing.Point(8, 24)
        Me.TextBox19.Name = "TextBox19"
        Me.TextBox19.Size = New System.Drawing.Size(112, 20)
        Me.TextBox19.TabIndex = 87
        Me.TextBox19.Text = ""
        '
        'Button29
        '
        Me.Button29.Location = New System.Drawing.Point(128, 24)
        Me.Button29.Name = "Button29"
        Me.Button29.Size = New System.Drawing.Size(40, 23)
        Me.Button29.TabIndex = 88
        Me.Button29.Text = "&OK"
        '
        'GroupBox29
        '
        Me.GroupBox29.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox20, Me.Button30})
        Me.GroupBox29.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox29.Name = "GroupBox29"
        Me.GroupBox29.Size = New System.Drawing.Size(360, 64)
        Me.GroupBox29.TabIndex = 90
        Me.GroupBox29.TabStop = False
        Me.GroupBox29.Text = "ISIN-Nummer"
        '
        'TextBox20
        '
        Me.TextBox20.Location = New System.Drawing.Point(8, 24)
        Me.TextBox20.Name = "TextBox20"
        Me.TextBox20.Size = New System.Drawing.Size(112, 20)
        Me.TextBox20.TabIndex = 88
        Me.TextBox20.Text = ""
        '
        'Button30
        '
        Me.Button30.Location = New System.Drawing.Point(128, 24)
        Me.Button30.Name = "Button30"
        Me.Button30.Size = New System.Drawing.Size(40, 23)
        Me.Button30.TabIndex = 89
        Me.Button30.Text = "&OK"
        '
        'GroupBox38
        '
        Me.GroupBox38.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox21, Me.Button31})
        Me.GroupBox38.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox38.Name = "GroupBox38"
        Me.GroupBox38.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox38.TabIndex = 89
        Me.GroupBox38.TabStop = False
        Me.GroupBox38.Text = "Valoren-Nummer"
        '
        'TextBox21
        '
        Me.TextBox21.Location = New System.Drawing.Point(8, 24)
        Me.TextBox21.Name = "TextBox21"
        Me.TextBox21.Size = New System.Drawing.Size(112, 20)
        Me.TextBox21.TabIndex = 87
        Me.TextBox21.Text = ""
        '
        'Button31
        '
        Me.Button31.Location = New System.Drawing.Point(128, 24)
        Me.Button31.Name = "Button31"
        Me.Button31.Size = New System.Drawing.Size(40, 23)
        Me.Button31.TabIndex = 88
        Me.Button31.Text = "&OK"
        '
        'Label62
        '
        Me.Label62.Location = New System.Drawing.Point(80, 312)
        Me.Label62.Name = "Label62"
        Me.Label62.Size = New System.Drawing.Size(80, 23)
        Me.Label62.TabIndex = 86
        Me.Label62.Text = "ISIN-Nummer"
        Me.Label62.Visible = False
        '
        'CheckBox10
        '
        Me.CheckBox10.Location = New System.Drawing.Point(16, 376)
        Me.CheckBox10.Name = "CheckBox10"
        Me.CheckBox10.Size = New System.Drawing.Size(264, 24)
        Me.CheckBox10.TabIndex = 82
        Me.CheckBox10.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.CheckBox10.Visible = False
        '
        'GroupBox39
        '
        Me.GroupBox39.Location = New System.Drawing.Point(8, 360)
        Me.GroupBox39.Name = "GroupBox39"
        Me.GroupBox39.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox39.TabIndex = 84
        Me.GroupBox39.TabStop = False
        Me.GroupBox39.Text = "Datenselektion"
        Me.GroupBox39.Visible = False
        '
        'Label63
        '
        Me.Label63.Location = New System.Drawing.Point(8, 32)
        Me.Label63.Name = "Label63"
        Me.Label63.Size = New System.Drawing.Size(48, 32)
        Me.Label63.TabIndex = 48
        Me.Label63.Text = "Valuta-Datum"
        '
        'DateTimePicker23
        '
        Me.DateTimePicker23.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker23.Location = New System.Drawing.Point(264, 328)
        Me.DateTimePicker23.Name = "DateTimePicker23"
        Me.DateTimePicker23.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker23.TabIndex = 46
        Me.DateTimePicker23.TabStop = False
        Me.DateTimePicker23.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        Me.DateTimePicker23.Visible = False
        '
        'GroupBox40
        '
        Me.GroupBox40.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox40.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button34, Me.Button35, Me.Label64, Me.Label65, Me.CheckBox11, Me.CheckBox12, Me.TextBox22, Me.Label66, Me.Label67, Me.Label68, Me.ComboBox3, Me.Label69, Me.Label70, Me.TextBox23, Me.ComboBox4, Me.TextBox24, Me.DateTimePicker24, Me.Label71, Me.DateTimePicker31})
        Me.GroupBox40.Location = New System.Drawing.Point(0, 8)
        Me.GroupBox40.Name = "GroupBox40"
        Me.GroupBox40.Size = New System.Drawing.Size(280, 88)
        Me.GroupBox40.TabIndex = 83
        Me.GroupBox40.TabStop = False
        Me.GroupBox40.Text = "Datumsselektion"
        '
        'Button34
        '
        Me.Button34.Image = CType(resources.GetObject("Button34.Image"), System.Drawing.Bitmap)
        Me.Button34.Location = New System.Drawing.Point(308, 49)
        Me.Button34.Name = "Button34"
        Me.Button34.Size = New System.Drawing.Size(32, 24)
        Me.Button34.TabIndex = 97
        '
        'Button35
        '
        Me.Button35.Image = CType(resources.GetObject("Button35.Image"), System.Drawing.Bitmap)
        Me.Button35.Location = New System.Drawing.Point(308, 25)
        Me.Button35.Name = "Button35"
        Me.Button35.Size = New System.Drawing.Size(32, 24)
        Me.Button35.TabIndex = 96
        '
        'Label64
        '
        Me.Label64.Location = New System.Drawing.Point(216, 80)
        Me.Label64.Name = "Label64"
        Me.Label64.TabIndex = 95
        Me.Label64.Text = "Label26"
        Me.Label64.Visible = False
        '
        'Label65
        '
        Me.Label65.Location = New System.Drawing.Point(88, 80)
        Me.Label65.Name = "Label65"
        Me.Label65.TabIndex = 94
        Me.Label65.Text = "Label26"
        Me.Label65.Visible = False
        '
        'CheckBox11
        '
        Me.CheckBox11.Location = New System.Drawing.Point(200, 48)
        Me.CheckBox11.Name = "CheckBox11"
        Me.CheckBox11.TabIndex = 93
        Me.CheckBox11.Text = "(rollend)"
        '
        'CheckBox12
        '
        Me.CheckBox12.Location = New System.Drawing.Point(200, 24)
        Me.CheckBox12.Name = "CheckBox12"
        Me.CheckBox12.Size = New System.Drawing.Size(96, 24)
        Me.CheckBox12.TabIndex = 92
        Me.CheckBox12.Text = "(rollend)"
        '
        'TextBox22
        '
        Me.TextBox22.BackColor = System.Drawing.Color.White
        Me.TextBox22.ForeColor = System.Drawing.Color.Black
        Me.TextBox22.Location = New System.Drawing.Point(96, 24)
        Me.TextBox22.Name = "TextBox22"
        Me.TextBox22.ReadOnly = True
        Me.TextBox22.Size = New System.Drawing.Size(79, 20)
        Me.TextBox22.TabIndex = 54
        Me.TextBox22.Text = ""
        '
        'Label66
        '
        Me.Label66.Location = New System.Drawing.Point(56, 48)
        Me.Label66.Name = "Label66"
        Me.Label66.Size = New System.Drawing.Size(40, 23)
        Me.Label66.TabIndex = 91
        Me.Label66.Text = "bis"
        '
        'Label67
        '
        Me.Label67.Location = New System.Drawing.Point(56, 24)
        Me.Label67.Name = "Label67"
        Me.Label67.Size = New System.Drawing.Size(40, 23)
        Me.Label67.TabIndex = 90
        Me.Label67.Text = "von"
        '
        'Label68
        '
        Me.Label68.Location = New System.Drawing.Point(240, 152)
        Me.Label68.Name = "Label68"
        Me.Label68.Size = New System.Drawing.Size(96, 16)
        Me.Label68.TabIndex = 89
        Me.Label68.Text = "(19.12.2003)"
        Me.Label68.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.Label68.Visible = False
        '
        'ComboBox3
        '
        Me.ComboBox3.ItemHeight = 13
        Me.ComboBox3.Items.AddRange(New Object() {"(heute)", "(heute-1)", "(heute-2)", "(heute-3)", "(heute-4)", "(heute-5)", "(heute-6)", "(heute-7)", "(heute-8)", "(heute-9)", "(heute-10)", "(heute-11)", "(heute-12)", "(heute-13)", "(heute-14)", "(heute-15)", "(heute-16)", "(heute-17)", "(heute-18)", "(heute-19)", "(heute-20)", "(heute-21)", "(heute-22)", "(heute-23)", "(heute-24)", "(heute-25)", "(heute-26)", "(heute-27)", "(heute-28)", "(heute-29)", "(heute-30)"})
        Me.ComboBox3.Location = New System.Drawing.Point(240, 128)
        Me.ComboBox3.Name = "ComboBox3"
        Me.ComboBox3.Size = New System.Drawing.Size(115, 21)
        Me.ComboBox3.TabIndex = 3
        Me.ComboBox3.Text = "ComboBox6"
        Me.ComboBox3.Visible = False
        '
        'Label69
        '
        Me.Label69.Location = New System.Drawing.Point(8, 128)
        Me.Label69.Name = "Label69"
        Me.Label69.Size = New System.Drawing.Size(72, 23)
        Me.Label69.TabIndex = 52
        Me.Label69.Text = "Archivierung"
        Me.Label69.Visible = False
        '
        'Label70
        '
        Me.Label70.Location = New System.Drawing.Point(160, 128)
        Me.Label70.Name = "Label70"
        Me.Label70.Size = New System.Drawing.Size(72, 21)
        Me.Label70.TabIndex = 79
        Me.Label70.Visible = False
        '
        'TextBox23
        '
        Me.TextBox23.BackColor = System.Drawing.Color.White
        Me.TextBox23.Enabled = False
        Me.TextBox23.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox23.Location = New System.Drawing.Point(240, 128)
        Me.TextBox23.Name = "TextBox23"
        Me.TextBox23.ReadOnly = True
        Me.TextBox23.Size = New System.Drawing.Size(79, 20)
        Me.TextBox23.TabIndex = 58
        Me.TextBox23.Text = "TextBox4"
        Me.TextBox23.Visible = False
        '
        'ComboBox4
        '
        Me.ComboBox4.ItemHeight = 13
        Me.ComboBox4.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.ComboBox4.Location = New System.Drawing.Point(80, 128)
        Me.ComboBox4.Name = "ComboBox4"
        Me.ComboBox4.Size = New System.Drawing.Size(56, 21)
        Me.ComboBox4.TabIndex = 71
        Me.ComboBox4.Text = "HostTag3"
        Me.ComboBox4.Visible = False
        '
        'TextBox24
        '
        Me.TextBox24.BackColor = System.Drawing.Color.White
        Me.TextBox24.ForeColor = System.Drawing.Color.Black
        Me.TextBox24.Location = New System.Drawing.Point(96, 48)
        Me.TextBox24.Name = "TextBox24"
        Me.TextBox24.ReadOnly = True
        Me.TextBox24.Size = New System.Drawing.Size(79, 20)
        Me.TextBox24.TabIndex = 56
        Me.TextBox24.Text = ""
        '
        'DateTimePicker24
        '
        Me.DateTimePicker24.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker24.Location = New System.Drawing.Point(96, 48)
        Me.DateTimePicker24.Name = "DateTimePicker24"
        Me.DateTimePicker24.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker24.TabIndex = 44
        Me.DateTimePicker24.TabStop = False
        Me.DateTimePicker24.Value = New Date(2004, 1, 14, 18, 49, 59, 203)
        '
        'Label71
        '
        Me.Label71.Location = New System.Drawing.Point(160, 72)
        Me.Label71.Name = "Label71"
        Me.Label71.Size = New System.Drawing.Size(72, 21)
        Me.Label71.TabIndex = 78
        Me.Label71.Visible = False
        '
        'DateTimePicker31
        '
        Me.DateTimePicker31.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker31.Location = New System.Drawing.Point(96, 24)
        Me.DateTimePicker31.Name = "DateTimePicker31"
        Me.DateTimePicker31.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker31.TabIndex = 42
        Me.DateTimePicker31.TabStop = False
        Me.DateTimePicker31.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        '
        'Label72
        '
        Me.Label72.Location = New System.Drawing.Point(304, 456)
        Me.Label72.Name = "Label72"
        Me.Label72.Size = New System.Drawing.Size(40, 23)
        Me.Label72.TabIndex = 70
        Me.Label72.Text = "Tagen"
        Me.Label72.Visible = False
        '
        'Label96
        '
        Me.Label96.Location = New System.Drawing.Point(304, 432)
        Me.Label96.Name = "Label96"
        Me.Label96.Size = New System.Drawing.Size(40, 23)
        Me.Label96.TabIndex = 69
        Me.Label96.Text = "Tagen"
        Me.Label96.Visible = False
        '
        'Label97
        '
        Me.Label97.Location = New System.Drawing.Point(80, 456)
        Me.Label97.Name = "Label97"
        Me.Label97.Size = New System.Drawing.Size(160, 23)
        Me.Label97.TabIndex = 67
        Me.Label97.Text = "Mutationsdatum in den letzen "
        Me.Label97.Visible = False
        '
        'Label98
        '
        Me.Label98.Location = New System.Drawing.Point(80, 432)
        Me.Label98.Name = "Label98"
        Me.Label98.Size = New System.Drawing.Size(160, 23)
        Me.Label98.TabIndex = 66
        Me.Label98.Text = "Erstellungsdatum in den letzen"
        Me.Label98.Visible = False
        '
        'CheckBox13
        '
        Me.CheckBox13.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox13.Name = "CheckBox13"
        Me.CheckBox13.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox13.TabIndex = 64
        Me.CheckBox13.Visible = False
        '
        'CheckBox14
        '
        Me.CheckBox14.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox14.Name = "CheckBox14"
        Me.CheckBox14.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox14.TabIndex = 62
        Me.CheckBox14.Visible = False
        '
        'CheckBox15
        '
        Me.CheckBox15.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox15.Name = "CheckBox15"
        Me.CheckBox15.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox15.TabIndex = 60
        Me.CheckBox15.Visible = False
        '
        'TextBox25
        '
        Me.TextBox25.BackColor = System.Drawing.Color.White
        Me.TextBox25.Enabled = False
        Me.TextBox25.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox25.Location = New System.Drawing.Point(160, 464)
        Me.TextBox25.Name = "TextBox25"
        Me.TextBox25.ReadOnly = True
        Me.TextBox25.Size = New System.Drawing.Size(80, 20)
        Me.TextBox25.TabIndex = 59
        Me.TextBox25.Text = "TextBox4"
        Me.TextBox25.Visible = False
        '
        'TextBox26
        '
        Me.TextBox26.BackColor = System.Drawing.Color.White
        Me.TextBox26.Enabled = False
        Me.TextBox26.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox26.Location = New System.Drawing.Point(160, 440)
        Me.TextBox26.Name = "TextBox26"
        Me.TextBox26.ReadOnly = True
        Me.TextBox26.Size = New System.Drawing.Size(80, 20)
        Me.TextBox26.TabIndex = 57
        Me.TextBox26.Text = "TextBox4"
        Me.TextBox26.Visible = False
        '
        'TextBox27
        '
        Me.TextBox27.BackColor = System.Drawing.Color.White
        Me.TextBox27.Enabled = False
        Me.TextBox27.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox27.Location = New System.Drawing.Point(160, 416)
        Me.TextBox27.Name = "TextBox27"
        Me.TextBox27.ReadOnly = True
        Me.TextBox27.Size = New System.Drawing.Size(80, 20)
        Me.TextBox27.TabIndex = 55
        Me.TextBox27.Text = "TextBox4"
        Me.TextBox27.Visible = False
        '
        'Label99
        '
        Me.Label99.Location = New System.Drawing.Point(48, 464)
        Me.Label99.Name = "Label99"
        Me.Label99.TabIndex = 53
        Me.Label99.Text = "Archivierung bis"
        Me.Label99.Visible = False
        '
        'Label100
        '
        Me.Label100.Location = New System.Drawing.Point(48, 440)
        Me.Label100.Name = "Label100"
        Me.Label100.Size = New System.Drawing.Size(96, 23)
        Me.Label100.TabIndex = 51
        Me.Label100.Text = "Mutation bis"
        Me.Label100.Visible = False
        '
        'Label101
        '
        Me.Label101.Location = New System.Drawing.Point(48, 416)
        Me.Label101.Name = "Label101"
        Me.Label101.Size = New System.Drawing.Size(96, 23)
        Me.Label101.TabIndex = 49
        Me.Label101.Text = "Erstellung bis"
        Me.Label101.Visible = False
        '
        'DateTimePicker32
        '
        Me.DateTimePicker32.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker32.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker32.Name = "DateTimePicker32"
        Me.DateTimePicker32.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker32.TabIndex = 47
        Me.DateTimePicker32.TabStop = False
        Me.DateTimePicker32.Value = New Date(2004, 1, 14, 18, 49, 59, 312)
        Me.DateTimePicker32.Visible = False
        '
        'DateTimePicker33
        '
        Me.DateTimePicker33.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker33.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker33.Name = "DateTimePicker33"
        Me.DateTimePicker33.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker33.TabIndex = 45
        Me.DateTimePicker33.TabStop = False
        Me.DateTimePicker33.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker33.Visible = False
        '
        'DateTimePicker34
        '
        Me.DateTimePicker34.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker34.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker34.Name = "DateTimePicker34"
        Me.DateTimePicker34.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker34.TabIndex = 43
        Me.DateTimePicker34.TabStop = False
        Me.DateTimePicker34.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker34.Visible = False
        '
        'Button36
        '
        Me.Button36.Location = New System.Drawing.Point(344, 48)
        Me.Button36.Name = "Button36"
        Me.Button36.Size = New System.Drawing.Size(16, 16)
        Me.Button36.TabIndex = 74
        '
        'Button47
        '
        Me.Button47.Location = New System.Drawing.Point(344, 80)
        Me.Button47.Name = "Button47"
        Me.Button47.Size = New System.Drawing.Size(16, 16)
        Me.Button47.TabIndex = 75
        '
        'Button48
        '
        Me.Button48.Location = New System.Drawing.Point(360, 336)
        Me.Button48.Name = "Button48"
        Me.Button48.Size = New System.Drawing.Size(16, 16)
        Me.Button48.TabIndex = 76
        Me.Button48.Visible = False
        '
        'Panel8
        '
        Me.Panel8.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid4, Me.Button49, Me.Label102, Me.TextBox43, Me.Label103, Me.TextBox44, Me.Label104, Me.TextBox45})
        Me.Panel8.Location = New System.Drawing.Point(256, 432)
        Me.Panel8.Name = "Panel8"
        Me.Panel8.Size = New System.Drawing.Size(24, 40)
        Me.Panel8.TabIndex = 3
        Me.Panel8.Visible = False
        '
        'C1TrueDBGrid4
        '
        Me.C1TrueDBGrid4.AllowFilter = True
        Me.C1TrueDBGrid4.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid4.AllowSort = True
        Me.C1TrueDBGrid4.AllowUpdate = False
        Me.C1TrueDBGrid4.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid4.AlternatingRows = True
        Me.C1TrueDBGrid4.CaptionHeight = 17
        Me.C1TrueDBGrid4.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.C1TrueDBGrid4.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid4.ContextMenu = Me.CTMenuErsteller
        Me.C1TrueDBGrid4.DataChanged = False
        Me.C1TrueDBGrid4.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid4.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.C1TrueDBGrid4.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid4.FetchRowStyles = True
        Me.C1TrueDBGrid4.FilterBar = True
        Me.C1TrueDBGrid4.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid4.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid4.Location = New System.Drawing.Point(0, -360)
        Me.C1TrueDBGrid4.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid4.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.C1TrueDBGrid4.Name = "C1TrueDBGrid4"
        Me.C1TrueDBGrid4.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid4.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid4.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid4.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid4.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid4.RowDivider = GridLines3
        Me.C1TrueDBGrid4.RowHeight = 15
        Me.C1TrueDBGrid4.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid4.ScrollTips = False
        Me.C1TrueDBGrid4.Size = New System.Drawing.Size(24, 400)
        Me.C1TrueDBGrid4.TabIndex = 17
        Me.C1TrueDBGrid4.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid4.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{Font:Microsoft Sans Serif, 8.25pt;}Highlight" & _
        "Row{ForeColor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:Silver" & _
        ";}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:R" & _
        "aised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignH" & _
        "orz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1T" & _
        "rueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" Column" & _
        "CaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True" & _
        """ MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" V" & _
        "erticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 20, 396</Clie" & _
        "ntRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" />" & _
        "<Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Sty" & _
        "le parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Styl" & _
        "e parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style pa" & _
        "rent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style p" & _
        "arent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Styl" & _
        "e parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedS" & _
        "tyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><" & _
        "DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 20, 396</ClientArea>" & _
        "</Blob>"
        '
        'Button49
        '
        Me.Button49.Image = CType(resources.GetObject("Button49.Image"), System.Drawing.Bitmap)
        Me.Button49.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.Button49.Location = New System.Drawing.Point(288, 32)
        Me.Button49.Name = "Button49"
        Me.Button49.Size = New System.Drawing.Size(72, 40)
        Me.Button49.TabIndex = 16
        Me.Button49.Text = "&Suchen"
        Me.Button49.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label102
        '
        Me.Label102.Location = New System.Drawing.Point(8, 64)
        Me.Label102.Name = "Label102"
        Me.Label102.Size = New System.Drawing.Size(72, 23)
        Me.Label102.TabIndex = 15
        Me.Label102.Text = "Freitext"
        '
        'TextBox43
        '
        Me.TextBox43.Location = New System.Drawing.Point(88, 64)
        Me.TextBox43.Name = "TextBox43"
        Me.TextBox43.Size = New System.Drawing.Size(160, 20)
        Me.TextBox43.TabIndex = 14
        Me.TextBox43.Text = ""
        '
        'Label103
        '
        Me.Label103.Location = New System.Drawing.Point(8, 40)
        Me.Label103.Name = "Label103"
        Me.Label103.Size = New System.Drawing.Size(72, 23)
        Me.Label103.TabIndex = 13
        Me.Label103.Text = "Kurzname"
        '
        'TextBox44
        '
        Me.TextBox44.Location = New System.Drawing.Point(88, 40)
        Me.TextBox44.Name = "TextBox44"
        Me.TextBox44.Size = New System.Drawing.Size(160, 20)
        Me.TextBox44.TabIndex = 12
        Me.TextBox44.Text = ""
        '
        'Label104
        '
        Me.Label104.Location = New System.Drawing.Point(8, 16)
        Me.Label104.Name = "Label104"
        Me.Label104.Size = New System.Drawing.Size(72, 23)
        Me.Label104.TabIndex = 11
        Me.Label104.Text = "Partner-Nr."
        '
        'TextBox45
        '
        Me.TextBox45.Location = New System.Drawing.Point(88, 16)
        Me.TextBox45.Name = "TextBox45"
        Me.TextBox45.Size = New System.Drawing.Size(160, 20)
        Me.TextBox45.TabIndex = 10
        Me.TextBox45.Text = ""
        '
        'GroupBox41
        '
        Me.GroupBox41.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox41.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtdatum4uvm, Me.txtdatum3uvm, Me.txtdatum2uvm, Me.cbuvmrollend1, Me.Label105, Me.DateTimePicker35, Me.Label106, Me.Label107, Me.cbuvmrollend4, Me.cbuvmrollend2, Me.Label108, Me.txtdatum1uvm, Me.Label109, Me.cbuvmrollend3, Me.Label110, Me.textdatum1uvm, Me.textdatum2uvm, Me.textdatum3uvm, Me.textdatum4uvm, Me.DateTimePicker36, Me.DateTimePicker37, Me.DateTimePicker38, Me.Button50, Me.Button51})
        Me.GroupBox41.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox41.Name = "GroupBox41"
        Me.GroupBox41.Size = New System.Drawing.Size(280, 128)
        Me.GroupBox41.TabIndex = 83
        Me.GroupBox41.TabStop = False
        Me.GroupBox41.Text = "Datumsselektion"
        '
        'txtdatum4uvm
        '
        Me.txtdatum4uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum4uvm.Enabled = False
        Me.txtdatum4uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum4uvm.Location = New System.Drawing.Point(112, 104)
        Me.txtdatum4uvm.Name = "txtdatum4uvm"
        Me.txtdatum4uvm.ReadOnly = True
        Me.txtdatum4uvm.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum4uvm.TabIndex = 110
        Me.txtdatum4uvm.Text = ""
        '
        'txtdatum3uvm
        '
        Me.txtdatum3uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum3uvm.Enabled = False
        Me.txtdatum3uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum3uvm.Location = New System.Drawing.Point(112, 80)
        Me.txtdatum3uvm.Name = "txtdatum3uvm"
        Me.txtdatum3uvm.ReadOnly = True
        Me.txtdatum3uvm.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum3uvm.TabIndex = 108
        Me.txtdatum3uvm.Text = ""
        '
        'txtdatum2uvm
        '
        Me.txtdatum2uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum2uvm.Enabled = False
        Me.txtdatum2uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum2uvm.Location = New System.Drawing.Point(112, 48)
        Me.txtdatum2uvm.Name = "txtdatum2uvm"
        Me.txtdatum2uvm.ReadOnly = True
        Me.txtdatum2uvm.Size = New System.Drawing.Size(80, 20)
        Me.txtdatum2uvm.TabIndex = 107
        Me.txtdatum2uvm.Text = ""
        '
        'cbuvmrollend1
        '
        Me.cbuvmrollend1.Enabled = False
        Me.cbuvmrollend1.Location = New System.Drawing.Point(216, 24)
        Me.cbuvmrollend1.Name = "cbuvmrollend1"
        Me.cbuvmrollend1.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend1.TabIndex = 111
        Me.cbuvmrollend1.Text = "(rollend)"
        '
        'Label105
        '
        Me.Label105.Location = New System.Drawing.Point(8, 80)
        Me.Label105.Name = "Label105"
        Me.Label105.Size = New System.Drawing.Size(64, 32)
        Me.Label105.TabIndex = 105
        Me.Label105.Text = "Archivie-rung"
        '
        'DateTimePicker35
        '
        Me.DateTimePicker35.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker35.Location = New System.Drawing.Point(112, 80)
        Me.DateTimePicker35.Name = "DateTimePicker35"
        Me.DateTimePicker35.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker35.TabIndex = 102
        Me.DateTimePicker35.TabStop = False
        Me.DateTimePicker35.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Label106
        '
        Me.Label106.Location = New System.Drawing.Point(72, 80)
        Me.Label106.Name = "Label106"
        Me.Label106.Size = New System.Drawing.Size(32, 23)
        Me.Label106.TabIndex = 115
        Me.Label106.Text = "von"
        '
        'Label107
        '
        Me.Label107.Location = New System.Drawing.Point(72, 104)
        Me.Label107.Name = "Label107"
        Me.Label107.Size = New System.Drawing.Size(32, 23)
        Me.Label107.TabIndex = 116
        Me.Label107.Text = "bis"
        '
        'cbuvmrollend4
        '
        Me.cbuvmrollend4.Enabled = False
        Me.cbuvmrollend4.Location = New System.Drawing.Point(216, 104)
        Me.cbuvmrollend4.Name = "cbuvmrollend4"
        Me.cbuvmrollend4.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend4.TabIndex = 118
        Me.cbuvmrollend4.Text = "(rollend)"
        '
        'cbuvmrollend2
        '
        Me.cbuvmrollend2.Enabled = False
        Me.cbuvmrollend2.Location = New System.Drawing.Point(216, 48)
        Me.cbuvmrollend2.Name = "cbuvmrollend2"
        Me.cbuvmrollend2.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend2.TabIndex = 112
        Me.cbuvmrollend2.Text = "(rollend)"
        '
        'Label108
        '
        Me.Label108.Location = New System.Drawing.Point(8, 24)
        Me.Label108.Name = "Label108"
        Me.Label108.Size = New System.Drawing.Size(56, 23)
        Me.Label108.TabIndex = 104
        Me.Label108.Text = "Erstellung"
        '
        'txtdatum1uvm
        '
        Me.txtdatum1uvm.BackColor = System.Drawing.Color.White
        Me.txtdatum1uvm.Enabled = False
        Me.txtdatum1uvm.ForeColor = System.Drawing.Color.Black
        Me.txtdatum1uvm.Location = New System.Drawing.Point(112, 24)
        Me.txtdatum1uvm.Name = "txtdatum1uvm"
        Me.txtdatum1uvm.ReadOnly = True
        Me.txtdatum1uvm.Size = New System.Drawing.Size(79, 20)
        Me.txtdatum1uvm.TabIndex = 106
        Me.txtdatum1uvm.Text = ""
        '
        'Label109
        '
        Me.Label109.Location = New System.Drawing.Point(72, 48)
        Me.Label109.Name = "Label109"
        Me.Label109.Size = New System.Drawing.Size(32, 23)
        Me.Label109.TabIndex = 109
        Me.Label109.Text = "bis"
        '
        'cbuvmrollend3
        '
        Me.cbuvmrollend3.Enabled = False
        Me.cbuvmrollend3.Location = New System.Drawing.Point(216, 80)
        Me.cbuvmrollend3.Name = "cbuvmrollend3"
        Me.cbuvmrollend3.Size = New System.Drawing.Size(72, 24)
        Me.cbuvmrollend3.TabIndex = 117
        Me.cbuvmrollend3.Text = "(rollend)"
        '
        'Label110
        '
        Me.Label110.Location = New System.Drawing.Point(72, 24)
        Me.Label110.Name = "Label110"
        Me.Label110.Size = New System.Drawing.Size(32, 23)
        Me.Label110.TabIndex = 99
        Me.Label110.Text = "von"
        '
        'textdatum1uvm
        '
        Me.textdatum1uvm.Enabled = False
        Me.textdatum1uvm.Location = New System.Drawing.Point(224, 24)
        Me.textdatum1uvm.Name = "textdatum1uvm"
        Me.textdatum1uvm.TabIndex = 113
        Me.textdatum1uvm.Visible = False
        '
        'textdatum2uvm
        '
        Me.textdatum2uvm.Enabled = False
        Me.textdatum2uvm.Location = New System.Drawing.Point(224, 48)
        Me.textdatum2uvm.Name = "textdatum2uvm"
        Me.textdatum2uvm.TabIndex = 114
        Me.textdatum2uvm.Visible = False
        '
        'textdatum3uvm
        '
        Me.textdatum3uvm.Enabled = False
        Me.textdatum3uvm.Location = New System.Drawing.Point(224, 80)
        Me.textdatum3uvm.Name = "textdatum3uvm"
        Me.textdatum3uvm.TabIndex = 119
        Me.textdatum3uvm.Visible = False
        '
        'textdatum4uvm
        '
        Me.textdatum4uvm.Enabled = False
        Me.textdatum4uvm.Location = New System.Drawing.Point(224, 104)
        Me.textdatum4uvm.Name = "textdatum4uvm"
        Me.textdatum4uvm.TabIndex = 120
        Me.textdatum4uvm.Visible = False
        '
        'DateTimePicker36
        '
        Me.DateTimePicker36.Format = System.Windows.Forms.DateTimePickerFormat.Custom
        Me.DateTimePicker36.Location = New System.Drawing.Point(112, 24)
        Me.DateTimePicker36.Name = "DateTimePicker36"
        Me.DateTimePicker36.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker36.TabIndex = 100
        Me.DateTimePicker36.TabStop = False
        Me.DateTimePicker36.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker37
        '
        Me.DateTimePicker37.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker37.Location = New System.Drawing.Point(112, 48)
        Me.DateTimePicker37.Name = "DateTimePicker37"
        Me.DateTimePicker37.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker37.TabIndex = 101
        Me.DateTimePicker37.TabStop = False
        Me.DateTimePicker37.Value = New Date(2004, 1, 14, 18, 49, 58, 750)
        '
        'DateTimePicker38
        '
        Me.DateTimePicker38.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker38.Location = New System.Drawing.Point(112, 104)
        Me.DateTimePicker38.Name = "DateTimePicker38"
        Me.DateTimePicker38.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker38.TabIndex = 103
        Me.DateTimePicker38.TabStop = False
        Me.DateTimePicker38.Value = New Date(2004, 1, 14, 18, 49, 58, 734)
        '
        'Button50
        '
        Me.Button50.Image = CType(resources.GetObject("Button50.Image"), System.Drawing.Bitmap)
        Me.Button50.Location = New System.Drawing.Point(308, 49)
        Me.Button50.Name = "Button50"
        Me.Button50.Size = New System.Drawing.Size(32, 24)
        Me.Button50.TabIndex = 97
        '
        'Button51
        '
        Me.Button51.Image = CType(resources.GetObject("Button51.Image"), System.Drawing.Bitmap)
        Me.Button51.Location = New System.Drawing.Point(308, 25)
        Me.Button51.Name = "Button51"
        Me.Button51.Size = New System.Drawing.Size(32, 24)
        Me.Button51.TabIndex = 96
        '
        'GroupBox14
        '
        Me.GroupBox14.Controls.AddRange(New System.Windows.Forms.Control() {Me.PnlPartner, Me.GroupBox17})
        Me.GroupBox14.Location = New System.Drawing.Point(648, 192)
        Me.GroupBox14.Name = "GroupBox14"
        Me.GroupBox14.Size = New System.Drawing.Size(216, 128)
        Me.GroupBox14.TabIndex = 10
        Me.GroupBox14.TabStop = False
        Me.GroupBox14.Text = "Host-Dokumente"
        Me.GroupBox14.Visible = False
        '
        'PnlPartner
        '
        Me.PnlPartner.Location = New System.Drawing.Point(256, 432)
        Me.PnlPartner.Name = "PnlPartner"
        Me.PnlPartner.Size = New System.Drawing.Size(24, 40)
        Me.PnlPartner.TabIndex = 3
        Me.PnlPartner.Visible = False
        '
        'GroupBox17
        '
        Me.GroupBox17.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox18, Me.Panel5, Me.Panel6})
        Me.GroupBox17.Location = New System.Drawing.Point(592, 8)
        Me.GroupBox17.Name = "GroupBox17"
        Me.GroupBox17.Size = New System.Drawing.Size(296, 488)
        Me.GroupBox17.TabIndex = 10
        Me.GroupBox17.TabStop = False
        Me.GroupBox17.Text = "Host-Dokumente"
        '
        'GroupBox18
        '
        Me.GroupBox18.Controls.AddRange(New System.Windows.Forms.Control() {Me.TreeView2})
        Me.GroupBox18.Location = New System.Drawing.Point(8, 24)
        Me.GroupBox18.Name = "GroupBox18"
        Me.GroupBox18.Size = New System.Drawing.Size(280, 160)
        Me.GroupBox18.TabIndex = 8
        Me.GroupBox18.TabStop = False
        Me.GroupBox18.Text = "Dokumentart"
        '
        'TreeView2
        '
        Me.TreeView2.ImageIndex = -1
        Me.TreeView2.Location = New System.Drawing.Point(8, 16)
        Me.TreeView2.Name = "TreeView2"
        Me.TreeView2.SelectedImageIndex = -1
        Me.TreeView2.Size = New System.Drawing.Size(264, 136)
        Me.TreeView2.TabIndex = 6
        '
        'Panel5
        '
        Me.Panel5.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox19, Me.GroupBox20, Me.GroupBox21, Me.Label26, Me.CheckBox1, Me.GroupBox22, Me.Label28, Me.DateTimePicker13, Me.GroupBox23, Me.Label49, Me.Label50, Me.Label51, Me.Label52, Me.CheckBox7, Me.CheckBox8, Me.CheckBox9, Me.TextBox16, Me.TextBox17, Me.TextBox18, Me.Label53, Me.Label54, Me.Label55, Me.DateTimePicker16, Me.DateTimePicker17, Me.DateTimePicker18, Me.Button26, Me.Button27, Me.Button28})
        Me.Panel5.Location = New System.Drawing.Point(8, 192)
        Me.Panel5.Name = "Panel5"
        Me.Panel5.Size = New System.Drawing.Size(280, 104)
        Me.Panel5.TabIndex = 7
        '
        'GroupBox19
        '
        Me.GroupBox19.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox10, Me.Button21})
        Me.GroupBox19.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox19.Name = "GroupBox19"
        Me.GroupBox19.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox19.TabIndex = 91
        Me.GroupBox19.TabStop = False
        Me.GroupBox19.Text = "VV-Nummer extern"
        '
        'TextBox10
        '
        Me.TextBox10.Location = New System.Drawing.Point(8, 24)
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.Size = New System.Drawing.Size(112, 20)
        Me.TextBox10.TabIndex = 87
        Me.TextBox10.Text = ""
        '
        'Button21
        '
        Me.Button21.Location = New System.Drawing.Point(128, 24)
        Me.Button21.Name = "Button21"
        Me.Button21.Size = New System.Drawing.Size(40, 23)
        Me.Button21.TabIndex = 88
        Me.Button21.Text = "&OK"
        '
        'GroupBox20
        '
        Me.GroupBox20.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox11, Me.Button22})
        Me.GroupBox20.Location = New System.Drawing.Point(8, 232)
        Me.GroupBox20.Name = "GroupBox20"
        Me.GroupBox20.Size = New System.Drawing.Size(360, 64)
        Me.GroupBox20.TabIndex = 90
        Me.GroupBox20.TabStop = False
        Me.GroupBox20.Text = "ISIN-Nummer"
        '
        'TextBox11
        '
        Me.TextBox11.Location = New System.Drawing.Point(8, 24)
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.Size = New System.Drawing.Size(112, 20)
        Me.TextBox11.TabIndex = 88
        Me.TextBox11.Text = ""
        '
        'Button22
        '
        Me.Button22.Location = New System.Drawing.Point(128, 24)
        Me.Button22.Name = "Button22"
        Me.Button22.Size = New System.Drawing.Size(40, 23)
        Me.Button22.TabIndex = 89
        Me.Button22.Text = "&OK"
        '
        'GroupBox21
        '
        Me.GroupBox21.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox12, Me.Button23})
        Me.GroupBox21.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox21.Name = "GroupBox21"
        Me.GroupBox21.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox21.TabIndex = 89
        Me.GroupBox21.TabStop = False
        Me.GroupBox21.Text = "Valoren-Nummer"
        '
        'TextBox12
        '
        Me.TextBox12.Location = New System.Drawing.Point(8, 24)
        Me.TextBox12.Name = "TextBox12"
        Me.TextBox12.Size = New System.Drawing.Size(112, 20)
        Me.TextBox12.TabIndex = 87
        Me.TextBox12.Text = ""
        '
        'Button23
        '
        Me.Button23.Location = New System.Drawing.Point(128, 24)
        Me.Button23.Name = "Button23"
        Me.Button23.Size = New System.Drawing.Size(40, 23)
        Me.Button23.TabIndex = 88
        Me.Button23.Text = "&OK"
        '
        'Label26
        '
        Me.Label26.Location = New System.Drawing.Point(80, 312)
        Me.Label26.Name = "Label26"
        Me.Label26.Size = New System.Drawing.Size(80, 23)
        Me.Label26.TabIndex = 86
        Me.Label26.Text = "ISIN-Nummer"
        Me.Label26.Visible = False
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(16, 376)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(264, 24)
        Me.CheckBox1.TabIndex = 82
        Me.CheckBox1.Text = "Partnerselektion inkl. Mitarbeiter- und VIP"
        Me.CheckBox1.Visible = False
        '
        'GroupBox22
        '
        Me.GroupBox22.Location = New System.Drawing.Point(8, 360)
        Me.GroupBox22.Name = "GroupBox22"
        Me.GroupBox22.Size = New System.Drawing.Size(360, 48)
        Me.GroupBox22.TabIndex = 84
        Me.GroupBox22.TabStop = False
        Me.GroupBox22.Text = "Datenselektion"
        Me.GroupBox22.Visible = False
        '
        'Label28
        '
        Me.Label28.Location = New System.Drawing.Point(8, 32)
        Me.Label28.Name = "Label28"
        Me.Label28.Size = New System.Drawing.Size(48, 32)
        Me.Label28.TabIndex = 48
        Me.Label28.Text = "Valuta-Datum"
        '
        'DateTimePicker13
        '
        Me.DateTimePicker13.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker13.Location = New System.Drawing.Point(264, 328)
        Me.DateTimePicker13.Name = "DateTimePicker13"
        Me.DateTimePicker13.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker13.TabIndex = 46
        Me.DateTimePicker13.TabStop = False
        Me.DateTimePicker13.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        Me.DateTimePicker13.Visible = False
        '
        'GroupBox23
        '
        Me.GroupBox23.BackColor = System.Drawing.Color.Transparent
        Me.GroupBox23.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button24, Me.Button25, Me.Label41, Me.Label42, Me.CheckBox2, Me.CheckBox6, Me.TextBox13, Me.Label43, Me.Label44, Me.Label45, Me.ComboBox1, Me.Label46, Me.Label47, Me.TextBox14, Me.ComboBox2, Me.TextBox15, Me.DateTimePicker14, Me.Label48, Me.DateTimePicker15})
        Me.GroupBox23.Location = New System.Drawing.Point(0, 8)
        Me.GroupBox23.Name = "GroupBox23"
        Me.GroupBox23.Size = New System.Drawing.Size(280, 88)
        Me.GroupBox23.TabIndex = 83
        Me.GroupBox23.TabStop = False
        Me.GroupBox23.Text = "Datumsselektion"
        '
        'Button24
        '
        Me.Button24.Image = CType(resources.GetObject("Button24.Image"), System.Drawing.Bitmap)
        Me.Button24.Location = New System.Drawing.Point(308, 49)
        Me.Button24.Name = "Button24"
        Me.Button24.Size = New System.Drawing.Size(32, 24)
        Me.Button24.TabIndex = 97
        '
        'Button25
        '
        Me.Button25.Image = CType(resources.GetObject("Button25.Image"), System.Drawing.Bitmap)
        Me.Button25.Location = New System.Drawing.Point(308, 25)
        Me.Button25.Name = "Button25"
        Me.Button25.Size = New System.Drawing.Size(32, 24)
        Me.Button25.TabIndex = 96
        '
        'Label41
        '
        Me.Label41.Location = New System.Drawing.Point(216, 80)
        Me.Label41.Name = "Label41"
        Me.Label41.TabIndex = 95
        Me.Label41.Text = "Label26"
        Me.Label41.Visible = False
        '
        'Label42
        '
        Me.Label42.Location = New System.Drawing.Point(88, 80)
        Me.Label42.Name = "Label42"
        Me.Label42.TabIndex = 94
        Me.Label42.Text = "Label26"
        Me.Label42.Visible = False
        '
        'CheckBox2
        '
        Me.CheckBox2.Location = New System.Drawing.Point(200, 48)
        Me.CheckBox2.Name = "CheckBox2"
        Me.CheckBox2.TabIndex = 93
        Me.CheckBox2.Text = "(rollend)"
        '
        'CheckBox6
        '
        Me.CheckBox6.Location = New System.Drawing.Point(200, 24)
        Me.CheckBox6.Name = "CheckBox6"
        Me.CheckBox6.Size = New System.Drawing.Size(96, 24)
        Me.CheckBox6.TabIndex = 92
        Me.CheckBox6.Text = "(rollend)"
        '
        'TextBox13
        '
        Me.TextBox13.BackColor = System.Drawing.Color.White
        Me.TextBox13.ForeColor = System.Drawing.Color.Black
        Me.TextBox13.Location = New System.Drawing.Point(96, 24)
        Me.TextBox13.Name = "TextBox13"
        Me.TextBox13.ReadOnly = True
        Me.TextBox13.Size = New System.Drawing.Size(79, 20)
        Me.TextBox13.TabIndex = 54
        Me.TextBox13.Text = ""
        '
        'Label43
        '
        Me.Label43.Location = New System.Drawing.Point(56, 48)
        Me.Label43.Name = "Label43"
        Me.Label43.Size = New System.Drawing.Size(40, 23)
        Me.Label43.TabIndex = 91
        Me.Label43.Text = "bis"
        '
        'Label44
        '
        Me.Label44.Location = New System.Drawing.Point(56, 24)
        Me.Label44.Name = "Label44"
        Me.Label44.Size = New System.Drawing.Size(40, 23)
        Me.Label44.TabIndex = 90
        Me.Label44.Text = "von"
        '
        'Label45
        '
        Me.Label45.Location = New System.Drawing.Point(240, 152)
        Me.Label45.Name = "Label45"
        Me.Label45.Size = New System.Drawing.Size(96, 16)
        Me.Label45.TabIndex = 89
        Me.Label45.Text = "(19.12.2003)"
        Me.Label45.TextAlign = System.Drawing.ContentAlignment.MiddleCenter
        Me.Label45.Visible = False
        '
        'ComboBox1
        '
        Me.ComboBox1.ItemHeight = 13
        Me.ComboBox1.Items.AddRange(New Object() {"(heute)", "(heute-1)", "(heute-2)", "(heute-3)", "(heute-4)", "(heute-5)", "(heute-6)", "(heute-7)", "(heute-8)", "(heute-9)", "(heute-10)", "(heute-11)", "(heute-12)", "(heute-13)", "(heute-14)", "(heute-15)", "(heute-16)", "(heute-17)", "(heute-18)", "(heute-19)", "(heute-20)", "(heute-21)", "(heute-22)", "(heute-23)", "(heute-24)", "(heute-25)", "(heute-26)", "(heute-27)", "(heute-28)", "(heute-29)", "(heute-30)"})
        Me.ComboBox1.Location = New System.Drawing.Point(240, 128)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(115, 21)
        Me.ComboBox1.TabIndex = 3
        Me.ComboBox1.Text = "ComboBox6"
        Me.ComboBox1.Visible = False
        '
        'Label46
        '
        Me.Label46.Location = New System.Drawing.Point(8, 128)
        Me.Label46.Name = "Label46"
        Me.Label46.Size = New System.Drawing.Size(72, 23)
        Me.Label46.TabIndex = 52
        Me.Label46.Text = "Archivierung"
        Me.Label46.Visible = False
        '
        'Label47
        '
        Me.Label47.Location = New System.Drawing.Point(160, 128)
        Me.Label47.Name = "Label47"
        Me.Label47.Size = New System.Drawing.Size(72, 21)
        Me.Label47.TabIndex = 79
        Me.Label47.Visible = False
        '
        'TextBox14
        '
        Me.TextBox14.BackColor = System.Drawing.Color.White
        Me.TextBox14.Enabled = False
        Me.TextBox14.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox14.Location = New System.Drawing.Point(240, 128)
        Me.TextBox14.Name = "TextBox14"
        Me.TextBox14.ReadOnly = True
        Me.TextBox14.Size = New System.Drawing.Size(79, 20)
        Me.TextBox14.TabIndex = 58
        Me.TextBox14.Text = "TextBox4"
        Me.TextBox14.Visible = False
        '
        'ComboBox2
        '
        Me.ComboBox2.ItemHeight = 13
        Me.ComboBox2.Items.AddRange(New Object() {"", "0", "1", "2", "3", "4", "5", "6", "7", "8", "9", "10", "11", "12", "13", "14", "15", "16", "17", "18", "19", "20", "21", "22", "23", "24", "25", "26", "27", "28", "29", "30", "31", "32", "33", "34", "35", "36", "37", "38", "39", "40", "41", "42", "43", "44", "45", "46", "47", "48", "49", "50", "51", "52", "53", "54", "55", "56", "57", "58", "59", "60", "61", "62", "63", "64", "65", "66", "67", "68", "69", "70", "71", "72", "73", "74", "75", "76", "77", "78", "79", "80", "81", "82", "83", "84", "85", "86", "87", "88", "89", "90", "91", "92", "93", "94", "95", "96", "97", "98", "99", "100", "101", "102", "103", "104", "105", "106", "107", "108", "109", "110", "111", "112", "113", "114", "115", "116", "117", "118", "119", "120", "121", "122", "123", "124", "125", "126", "127", "128", "129", "130", "131", "132", "133", "134", "135", "136", "137", "138", "139", "140", "141", "142", "143", "144", "145", "146", "147", "148", "149", "150", "151", "152", "153", "154", "155", "156", "157", "158", "159", "160", "161", "162", "163", "164", "165", "166", "167", "168", "169", "170", "171", "172", "173", "174", "175", "176", "177", "178", "179", "180", "181", "182", "183", "184", "185", "186", "187", "188", "189", "190", "191", "192", "193", "194", "195", "196", "197", "198", "199", "200", "201", "202", "203", "204", "205", "206", "207", "208", "209", "210", "211", "212", "213", "214", "215", "216", "217", "218", "219", "220", "221", "222", "223", "224", "225", "226", "227", "228", "229", "230", "231", "232", "233", "234", "235", "236", "237", "238", "239", "240", "241", "242", "243", "244", "245", "246", "247", "248", "249", "250", "251", "252", "253", "254", "255", "256", "257", "258", "259", "260", "261", "262", "263", "264", "265", "266", "267", "268", "269", "270", "271", "272", "273", "274", "275", "276", "277", "278", "279", "280", "281", "282", "283", "284", "285", "286", "287", "288", "289", "290", "291", "292", "293", "294", "295", "296", "297", "298", "299", "300", "301", "302", "303", "304", "305", "306", "307", "308", "309", "310", "311", "312", "313", "314", "315", "316", "317", "318", "319", "320", "321", "322", "323", "324", "325", "326", "327", "328", "329", "330", "331", "332", "333", "334", "335", "336", "337", "338", "339", "340", "341", "342", "343", "344", "345", "346", "347", "348", "349", "350", "351", "352", "353", "354", "355", "356", "357", "358", "359", "360", "361", "362", "363", "364", "365"})
        Me.ComboBox2.Location = New System.Drawing.Point(80, 128)
        Me.ComboBox2.Name = "ComboBox2"
        Me.ComboBox2.Size = New System.Drawing.Size(56, 21)
        Me.ComboBox2.TabIndex = 71
        Me.ComboBox2.Text = "HostTag3"
        Me.ComboBox2.Visible = False
        '
        'TextBox15
        '
        Me.TextBox15.BackColor = System.Drawing.Color.White
        Me.TextBox15.ForeColor = System.Drawing.Color.Black
        Me.TextBox15.Location = New System.Drawing.Point(96, 48)
        Me.TextBox15.Name = "TextBox15"
        Me.TextBox15.ReadOnly = True
        Me.TextBox15.Size = New System.Drawing.Size(79, 20)
        Me.TextBox15.TabIndex = 56
        Me.TextBox15.Text = ""
        '
        'DateTimePicker14
        '
        Me.DateTimePicker14.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker14.Location = New System.Drawing.Point(96, 48)
        Me.DateTimePicker14.Name = "DateTimePicker14"
        Me.DateTimePicker14.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker14.TabIndex = 44
        Me.DateTimePicker14.TabStop = False
        Me.DateTimePicker14.Value = New Date(2004, 1, 14, 18, 49, 59, 203)
        '
        'Label48
        '
        Me.Label48.Location = New System.Drawing.Point(160, 72)
        Me.Label48.Name = "Label48"
        Me.Label48.Size = New System.Drawing.Size(72, 21)
        Me.Label48.TabIndex = 78
        Me.Label48.Visible = False
        '
        'DateTimePicker15
        '
        Me.DateTimePicker15.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker15.Location = New System.Drawing.Point(96, 24)
        Me.DateTimePicker15.Name = "DateTimePicker15"
        Me.DateTimePicker15.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker15.TabIndex = 42
        Me.DateTimePicker15.TabStop = False
        Me.DateTimePicker15.Value = New Date(2004, 1, 14, 18, 49, 59, 125)
        '
        'Label49
        '
        Me.Label49.Location = New System.Drawing.Point(304, 456)
        Me.Label49.Name = "Label49"
        Me.Label49.Size = New System.Drawing.Size(40, 23)
        Me.Label49.TabIndex = 70
        Me.Label49.Text = "Tagen"
        Me.Label49.Visible = False
        '
        'Label50
        '
        Me.Label50.Location = New System.Drawing.Point(304, 432)
        Me.Label50.Name = "Label50"
        Me.Label50.Size = New System.Drawing.Size(40, 23)
        Me.Label50.TabIndex = 69
        Me.Label50.Text = "Tagen"
        Me.Label50.Visible = False
        '
        'Label51
        '
        Me.Label51.Location = New System.Drawing.Point(80, 456)
        Me.Label51.Name = "Label51"
        Me.Label51.Size = New System.Drawing.Size(160, 23)
        Me.Label51.TabIndex = 67
        Me.Label51.Text = "Mutationsdatum in den letzen "
        Me.Label51.Visible = False
        '
        'Label52
        '
        Me.Label52.Location = New System.Drawing.Point(80, 432)
        Me.Label52.Name = "Label52"
        Me.Label52.Size = New System.Drawing.Size(160, 23)
        Me.Label52.TabIndex = 66
        Me.Label52.Text = "Erstellungsdatum in den letzen"
        Me.Label52.Visible = False
        '
        'CheckBox7
        '
        Me.CheckBox7.Location = New System.Drawing.Point(16, 464)
        Me.CheckBox7.Name = "CheckBox7"
        Me.CheckBox7.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox7.TabIndex = 64
        Me.CheckBox7.Visible = False
        '
        'CheckBox8
        '
        Me.CheckBox8.Location = New System.Drawing.Point(16, 440)
        Me.CheckBox8.Name = "CheckBox8"
        Me.CheckBox8.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox8.TabIndex = 62
        Me.CheckBox8.Visible = False
        '
        'CheckBox9
        '
        Me.CheckBox9.Location = New System.Drawing.Point(16, 416)
        Me.CheckBox9.Name = "CheckBox9"
        Me.CheckBox9.Size = New System.Drawing.Size(16, 24)
        Me.CheckBox9.TabIndex = 60
        Me.CheckBox9.Visible = False
        '
        'TextBox16
        '
        Me.TextBox16.BackColor = System.Drawing.Color.White
        Me.TextBox16.Enabled = False
        Me.TextBox16.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox16.Location = New System.Drawing.Point(160, 464)
        Me.TextBox16.Name = "TextBox16"
        Me.TextBox16.ReadOnly = True
        Me.TextBox16.Size = New System.Drawing.Size(80, 20)
        Me.TextBox16.TabIndex = 59
        Me.TextBox16.Text = "TextBox4"
        Me.TextBox16.Visible = False
        '
        'TextBox17
        '
        Me.TextBox17.BackColor = System.Drawing.Color.White
        Me.TextBox17.Enabled = False
        Me.TextBox17.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox17.Location = New System.Drawing.Point(160, 440)
        Me.TextBox17.Name = "TextBox17"
        Me.TextBox17.ReadOnly = True
        Me.TextBox17.Size = New System.Drawing.Size(80, 20)
        Me.TextBox17.TabIndex = 57
        Me.TextBox17.Text = "TextBox4"
        Me.TextBox17.Visible = False
        '
        'TextBox18
        '
        Me.TextBox18.BackColor = System.Drawing.Color.White
        Me.TextBox18.Enabled = False
        Me.TextBox18.ForeColor = System.Drawing.Color.WhiteSmoke
        Me.TextBox18.Location = New System.Drawing.Point(160, 416)
        Me.TextBox18.Name = "TextBox18"
        Me.TextBox18.ReadOnly = True
        Me.TextBox18.Size = New System.Drawing.Size(80, 20)
        Me.TextBox18.TabIndex = 55
        Me.TextBox18.Text = "TextBox4"
        Me.TextBox18.Visible = False
        '
        'Label53
        '
        Me.Label53.Location = New System.Drawing.Point(48, 464)
        Me.Label53.Name = "Label53"
        Me.Label53.TabIndex = 53
        Me.Label53.Text = "Archivierung bis"
        Me.Label53.Visible = False
        '
        'Label54
        '
        Me.Label54.Location = New System.Drawing.Point(48, 440)
        Me.Label54.Name = "Label54"
        Me.Label54.Size = New System.Drawing.Size(96, 23)
        Me.Label54.TabIndex = 51
        Me.Label54.Text = "Mutation bis"
        Me.Label54.Visible = False
        '
        'Label55
        '
        Me.Label55.Location = New System.Drawing.Point(48, 416)
        Me.Label55.Name = "Label55"
        Me.Label55.Size = New System.Drawing.Size(96, 23)
        Me.Label55.TabIndex = 49
        Me.Label55.Text = "Erstellung bis"
        Me.Label55.Visible = False
        '
        'DateTimePicker16
        '
        Me.DateTimePicker16.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker16.Location = New System.Drawing.Point(160, 464)
        Me.DateTimePicker16.Name = "DateTimePicker16"
        Me.DateTimePicker16.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker16.TabIndex = 47
        Me.DateTimePicker16.TabStop = False
        Me.DateTimePicker16.Value = New Date(2004, 1, 14, 18, 49, 59, 312)
        Me.DateTimePicker16.Visible = False
        '
        'DateTimePicker17
        '
        Me.DateTimePicker17.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker17.Location = New System.Drawing.Point(160, 440)
        Me.DateTimePicker17.Name = "DateTimePicker17"
        Me.DateTimePicker17.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker17.TabIndex = 45
        Me.DateTimePicker17.TabStop = False
        Me.DateTimePicker17.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker17.Visible = False
        '
        'DateTimePicker18
        '
        Me.DateTimePicker18.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker18.Location = New System.Drawing.Point(160, 416)
        Me.DateTimePicker18.Name = "DateTimePicker18"
        Me.DateTimePicker18.Size = New System.Drawing.Size(98, 20)
        Me.DateTimePicker18.TabIndex = 43
        Me.DateTimePicker18.TabStop = False
        Me.DateTimePicker18.Value = New Date(2004, 1, 14, 18, 49, 59, 328)
        Me.DateTimePicker18.Visible = False
        '
        'Button26
        '
        Me.Button26.Location = New System.Drawing.Point(344, 48)
        Me.Button26.Name = "Button26"
        Me.Button26.Size = New System.Drawing.Size(16, 16)
        Me.Button26.TabIndex = 74
        '
        'Button27
        '
        Me.Button27.Location = New System.Drawing.Point(344, 80)
        Me.Button27.Name = "Button27"
        Me.Button27.Size = New System.Drawing.Size(16, 16)
        Me.Button27.TabIndex = 75
        '
        'Button28
        '
        Me.Button28.Location = New System.Drawing.Point(360, 336)
        Me.Button28.Name = "Button28"
        Me.Button28.Size = New System.Drawing.Size(16, 16)
        Me.Button28.TabIndex = 76
        Me.Button28.Visible = False
        '
        'Panel6
        '
        Me.Panel6.Controls.AddRange(New System.Windows.Forms.Control() {Me.PartnerList, Me.btnPartnersuche, Me.Label3, Me.TextBox3, Me.Label2, Me.TextBox2, Me.Label1, Me.TextBox1})
        Me.Panel6.Location = New System.Drawing.Point(256, 432)
        Me.Panel6.Name = "Panel6"
        Me.Panel6.Size = New System.Drawing.Size(24, 40)
        Me.Panel6.TabIndex = 3
        Me.Panel6.Visible = False
        '
        'PartnerList
        '
        Me.PartnerList.AllowFilter = True
        Me.PartnerList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.PartnerList.AllowSort = True
        Me.PartnerList.AllowUpdate = False
        Me.PartnerList.AllowUpdateOnBlur = False
        Me.PartnerList.AlternatingRows = True
        Me.PartnerList.CaptionHeight = 17
        Me.PartnerList.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
        Me.PartnerList.CollapseColor = System.Drawing.Color.Black
        Me.PartnerList.ContextMenu = Me.CTMenuErsteller
        Me.PartnerList.DataChanged = False
        Me.PartnerList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.PartnerList.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.PartnerList.ExpandColor = System.Drawing.Color.Black
        Me.PartnerList.FetchRowStyles = True
        Me.PartnerList.FilterBar = True
        Me.PartnerList.GroupByCaption = "Drag a column header here to group by that column"
        Me.PartnerList.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.PartnerList.Location = New System.Drawing.Point(0, -360)
        Me.PartnerList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.PartnerList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.PartnerList.Name = "PartnerList"
        Me.PartnerList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.PartnerList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.PartnerList.PreviewInfo.ZoomFactor = 75
        Me.PartnerList.PrintInfo.ShowOptionsDialog = False
        Me.PartnerList.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.PartnerList.RowDivider = GridLines4
        Me.PartnerList.RowHeight = 15
        Me.PartnerList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.PartnerList.ScrollTips = False
        Me.PartnerList.Size = New System.Drawing.Size(24, 400)
        Me.PartnerList.TabIndex = 17
        Me.PartnerList.Text = "C1TrueDBGrid1"
        Me.PartnerList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{Font:Microsoft Sans Serif, 8.25pt;}Highlight" & _
        "Row{ForeColor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:Silver" & _
        ";}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Ra" & _
        "ised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignH" & _
        "orz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1T" & _
        "rueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" Column" & _
        "CaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True" & _
        """ MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" V" & _
        "erticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 20, 396</Clie" & _
        "ntRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" />" & _
        "<Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Sty" & _
        "le parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Styl" & _
        "e parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style pa" & _
        "rent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style p" & _
        "arent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Styl" & _
        "e parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedS" & _
        "tyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><" & _
        "DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 20, 396</ClientArea>" & _
        "</Blob>"
        '
        'btnPartnersuche
        '
        Me.btnPartnersuche.Image = CType(resources.GetObject("btnPartnersuche.Image"), System.Drawing.Bitmap)
        Me.btnPartnersuche.ImageAlign = System.Drawing.ContentAlignment.MiddleLeft
        Me.btnPartnersuche.Location = New System.Drawing.Point(288, 32)
        Me.btnPartnersuche.Name = "btnPartnersuche"
        Me.btnPartnersuche.Size = New System.Drawing.Size(72, 40)
        Me.btnPartnersuche.TabIndex = 16
        Me.btnPartnersuche.Text = "&Suchen"
        Me.btnPartnersuche.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(72, 23)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "Freitext"
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(88, 64)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(160, 20)
        Me.TextBox3.TabIndex = 14
        Me.TextBox3.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(72, 23)
        Me.Label2.TabIndex = 13
        Me.Label2.Text = "Kurzname"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(88, 40)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(160, 20)
        Me.TextBox2.TabIndex = 12
        Me.TextBox2.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 11
        Me.Label1.Text = "Partner-Nr."
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 16)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(160, 20)
        Me.TextBox1.TabIndex = 10
        Me.TextBox1.Text = ""
        '
        'Panel4
        '
        Me.Panel4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label19, Me.LBSelectHost, Me.Button11, Me.Label22, Me.lbselect, Me.LBSort, Me.Label21, Me.lbSortfields, Me.GroupBox12})
        Me.Panel4.Location = New System.Drawing.Point(824, 384)
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(48, 32)
        Me.Panel4.TabIndex = 8
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(200, 32)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(100, 16)
        Me.Label19.TabIndex = 19
        Me.Label19.Text = "Sortierungsart"
        '
        'LBSelectHost
        '
        Me.LBSelectHost.ContextMenu = Me.ContextMenu2
        Me.LBSelectHost.Location = New System.Drawing.Point(40, 312)
        Me.LBSelectHost.Name = "LBSelectHost"
        Me.LBSelectHost.Size = New System.Drawing.Size(296, 134)
        Me.LBSelectHost.TabIndex = 18
        '
        'Button11
        '
        Me.Button11.Location = New System.Drawing.Point(152, 264)
        Me.Button11.Name = "Button11"
        Me.Button11.Size = New System.Drawing.Size(80, 24)
        Me.Button11.TabIndex = 17
        Me.Button11.Text = "Einfügen"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(40, 296)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(112, 16)
        Me.Label22.TabIndex = 16
        Me.Label22.Text = "Sortierungs-Kriterien"
        '
        'lbselect
        '
        Me.lbselect.ContextMenu = Me.ContextMenu2
        Me.lbselect.Location = New System.Drawing.Point(40, 312)
        Me.lbselect.Name = "lbselect"
        Me.lbselect.Size = New System.Drawing.Size(296, 134)
        Me.lbselect.TabIndex = 15
        '
        'LBSort
        '
        Me.LBSort.Items.AddRange(New Object() {"Absteigend", "Aufsteigend"})
        Me.LBSort.Location = New System.Drawing.Point(200, 48)
        Me.LBSort.Name = "LBSort"
        Me.LBSort.Size = New System.Drawing.Size(136, 199)
        Me.LBSort.Sorted = True
        Me.LBSort.TabIndex = 14
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(40, 32)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(100, 16)
        Me.Label21.TabIndex = 13
        Me.Label21.Text = "Sortierkriterien"
        '
        'lbSortfields
        '
        Me.lbSortfields.Items.AddRange(New Object() {"Bemerkung", "Bezeichnung", "Dokument-ID", "Dokumentart", "Ersteller", "Erstellungsdatum", "Mutationsdatum", "Mutierer", "Status", "Termin", "Verantwortlicher", "Zuständiger"})
        Me.lbSortfields.Location = New System.Drawing.Point(40, 48)
        Me.lbSortfields.Name = "lbSortfields"
        Me.lbSortfields.Size = New System.Drawing.Size(136, 199)
        Me.lbSortfields.Sorted = True
        Me.lbSortfields.TabIndex = 12
        '
        'GroupBox12
        '
        Me.GroupBox12.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(360, 448)
        Me.GroupBox12.TabIndex = 20
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Sortierung"
        '
        'Panel3
        '
        Me.Panel3.Location = New System.Drawing.Point(736, 400)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(104, 104)
        Me.Panel3.TabIndex = 2
        Me.Panel3.Visible = False
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.CTMenuVerantwortlicher
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FilterBar = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(840, 416)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines5
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(40, 24)
        Me.C1TrueDBGrid1.TabIndex = 0
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorW" & _
        "idth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1"">" & _
        "<ClientRect>0, 0, 36, 20</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 36, 20</ClientArea></Blob>"
        '
        'TabPage4
        '
        Me.TabPage4.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox2, Me.GroupBox1, Me.GroupBox9, Me.GroupBox5})
        Me.TabPage4.Location = New System.Drawing.Point(4, 22)
        Me.TabPage4.Name = "TabPage4"
        Me.TabPage4.Size = New System.Drawing.Size(671, 616)
        Me.TabPage4.TabIndex = 3
        Me.TabPage4.Text = "Unterschriften / Hinweise / Darstellung"
        Me.TabPage4.Visible = False
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 104)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(360, 56)
        Me.GroupBox2.TabIndex = 10
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Team"
        '
        'cbteam
        '
        Me.cbteam.Location = New System.Drawing.Point(112, 21)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(240, 21)
        Me.cbteam.TabIndex = 8
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button5, Me.colbtn6, Me.colbtn5, Me.colbtn4, Me.colbtn3, Me.colbtn2, Me.colbtn1})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 168)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(360, 72)
        Me.GroupBox1.TabIndex = 8
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Farbgebung der Dokumentliste"
        '
        'Button5
        '
        Me.Button5.Location = New System.Drawing.Point(288, 19)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(64, 40)
        Me.Button5.TabIndex = 44
        Me.Button5.Text = "Standard herstellen"
        '
        'colbtn6
        '
        Me.colbtn6.Location = New System.Drawing.Point(96, 40)
        Me.colbtn6.Name = "colbtn6"
        Me.colbtn6.Size = New System.Drawing.Size(88, 20)
        Me.colbtn6.TabIndex = 43
        Me.colbtn6.Text = "Pendent"
        '
        'colbtn5
        '
        Me.colbtn5.Location = New System.Drawing.Point(184, 40)
        Me.colbtn5.Name = "colbtn5"
        Me.colbtn5.Size = New System.Drawing.Size(88, 20)
        Me.colbtn5.TabIndex = 42
        Me.colbtn5.Text = "Überfällig"
        '
        'colbtn4
        '
        Me.colbtn4.Location = New System.Drawing.Point(184, 16)
        Me.colbtn4.Name = "colbtn4"
        Me.colbtn4.Size = New System.Drawing.Size(88, 20)
        Me.colbtn4.TabIndex = 41
        Me.colbtn4.Text = "Terminiert"
        '
        'colbtn3
        '
        Me.colbtn3.Location = New System.Drawing.Point(8, 40)
        Me.colbtn3.Name = "colbtn3"
        Me.colbtn3.Size = New System.Drawing.Size(88, 20)
        Me.colbtn3.TabIndex = 40
        Me.colbtn3.Text = "In Bearbeitung"
        '
        'colbtn2
        '
        Me.colbtn2.Location = New System.Drawing.Point(96, 16)
        Me.colbtn2.Name = "colbtn2"
        Me.colbtn2.Size = New System.Drawing.Size(88, 20)
        Me.colbtn2.TabIndex = 39
        Me.colbtn2.Text = "Verantwortlich"
        '
        'colbtn1
        '
        Me.colbtn1.Location = New System.Drawing.Point(8, 16)
        Me.colbtn1.Name = "colbtn1"
        Me.colbtn1.Size = New System.Drawing.Size(88, 20)
        Me.colbtn1.TabIndex = 38
        Me.colbtn1.Text = "Standard"
        '
        'GroupBox9
        '
        Me.GroupBox9.Controls.AddRange(New System.Windows.Forms.Control() {Me.cb3_1, Me.cb5, Me.cb4, Me.cb3, Me.cb2, Me.cb1})
        Me.GroupBox9.Location = New System.Drawing.Point(376, 8)
        Me.GroupBox9.Name = "GroupBox9"
        Me.GroupBox9.Size = New System.Drawing.Size(216, 232)
        Me.GroupBox9.TabIndex = 7
        Me.GroupBox9.TabStop = False
        Me.GroupBox9.Text = "Hinweismeldungen"
        '
        'cb3_1
        '
        Me.cb3_1.Location = New System.Drawing.Point(8, 120)
        Me.cb3_1.Name = "cb3_1"
        Me.cb3_1.Size = New System.Drawing.Size(192, 32)
        Me.cb3_1.TabIndex = 10
        Me.cb3_1.Text = "Bedingte Retournierung"
        '
        'cb5
        '
        Me.cb5.Location = New System.Drawing.Point(16, 176)
        Me.cb5.Name = "cb5"
        Me.cb5.Size = New System.Drawing.Size(144, 32)
        Me.cb5.TabIndex = 9
        Me.cb5.Text = "Meldung XY5 anzeigen"
        Me.cb5.Visible = False
        '
        'cb4
        '
        Me.cb4.Location = New System.Drawing.Point(16, 152)
        Me.cb4.Name = "cb4"
        Me.cb4.Size = New System.Drawing.Size(144, 32)
        Me.cb4.TabIndex = 8
        Me.cb4.Text = "Meldung XY4 anzeigen"
        Me.cb4.Visible = False
        '
        'cb3
        '
        Me.cb3.Location = New System.Drawing.Point(8, 88)
        Me.cb3.Name = "cb3"
        Me.cb3.Size = New System.Drawing.Size(192, 32)
        Me.cb3.TabIndex = 7
        Me.cb3.Text = "Einzeldokument"
        '
        'cb2
        '
        Me.cb2.Location = New System.Drawing.Point(8, 56)
        Me.cb2.Name = "cb2"
        Me.cb2.Size = New System.Drawing.Size(200, 32)
        Me.cb2.TabIndex = 6
        Me.cb2.Text = "Dokumentbearbeitung - Statuswechsel"
        '
        'cb1
        '
        Me.cb1.Location = New System.Drawing.Point(8, 24)
        Me.cb1.Name = "cb1"
        Me.cb1.Size = New System.Drawing.Size(200, 32)
        Me.cb1.TabIndex = 5
        Me.cb1.Text = "Partnererfassung"
        '
        'GroupBox5
        '
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label31, Me.cbUnterschriftrechts, Me.Label30, Me.cbUnterschriftlinks})
        Me.GroupBox5.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(360, 88)
        Me.GroupBox5.TabIndex = 2
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Unterschriften"
        '
        'Label31
        '
        Me.Label31.Location = New System.Drawing.Point(24, 56)
        Me.Label31.Name = "Label31"
        Me.Label31.Size = New System.Drawing.Size(72, 23)
        Me.Label31.TabIndex = 8
        Me.Label31.Text = "Rechts"
        '
        'cbUnterschriftrechts
        '
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(112, 56)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(240, 21)
        Me.cbUnterschriftrechts.TabIndex = 7
        '
        'Label30
        '
        Me.Label30.Location = New System.Drawing.Point(24, 24)
        Me.Label30.Name = "Label30"
        Me.Label30.Size = New System.Drawing.Size(72, 23)
        Me.Label30.TabIndex = 6
        Me.Label30.Text = "Links"
        '
        'cbUnterschriftlinks
        '
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(112, 24)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(240, 21)
        Me.cbUnterschriftlinks.TabIndex = 5
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage4})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.ItemSize = New System.Drawing.Size(112, 18)
        Me.TabControl1.Location = New System.Drawing.Point(3, 33)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(679, 642)
        Me.TabControl1.TabIndex = 16
        '
        'frmProfilinfo
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(682, 675)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.Splitter1, Me.Button4, Me.Panel2, Me.Panel1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmProfilinfo"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Profil-Information - "
        Me.Panel2.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage1.ResumeLayout(False)
        CType(Me.C1TrueDBGrid3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox13.ResumeLayout(False)
        Me.GroupBox15.ResumeLayout(False)
        Me.PnlDokumentart.ResumeLayout(False)
        Me.GroupBox16.ResumeLayout(False)
        Me.PnlDokumentDaten.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox10.ResumeLayout(False)
        Me.pnlhostdiv.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.GroupBox11.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        Me.GroupBox6.ResumeLayout(False)
        Me.GroupBox24.ResumeLayout(False)
        Me.GroupBox31.ResumeLayout(False)
        Me.GroupBox32.ResumeLayout(False)
        Me.Panel9.ResumeLayout(False)
        Me.GroupBox33.ResumeLayout(False)
        Me.GroupBox34.ResumeLayout(False)
        Me.GroupBox35.ResumeLayout(False)
        Me.GroupBox37.ResumeLayout(False)
        Me.Panel10.ResumeLayout(False)
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox30.ResumeLayout(False)
        Me.GroupBox25.ResumeLayout(False)
        Me.GroupBox26.ResumeLayout(False)
        Me.GroupBox27.ResumeLayout(False)
        Me.Panel7.ResumeLayout(False)
        Me.GroupBox28.ResumeLayout(False)
        Me.GroupBox29.ResumeLayout(False)
        Me.GroupBox38.ResumeLayout(False)
        Me.GroupBox40.ResumeLayout(False)
        Me.Panel8.ResumeLayout(False)
        CType(Me.C1TrueDBGrid4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox41.ResumeLayout(False)
        Me.GroupBox14.ResumeLayout(False)
        Me.GroupBox17.ResumeLayout(False)
        Me.GroupBox18.ResumeLayout(False)
        Me.Panel5.ResumeLayout(False)
        Me.GroupBox19.ResumeLayout(False)
        Me.GroupBox20.ResumeLayout(False)
        Me.GroupBox21.ResumeLayout(False)
        Me.GroupBox23.ResumeLayout(False)
        Me.Panel6.ResumeLayout(False)
        CType(Me.PartnerList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel4.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage4.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox9.ResumeLayout(False)
        Me.GroupBox5.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Insertitem Method

Private Sub Insertitem( _
   ByVal lb As ListBox, _
   ByVal s As String _
)

Parameters

lb
Required.
s
Required.

Source code

[Visual Basic]
    Private Sub Insertitem(ByVal lb As ListBox, ByVal s As String)
        Dim i As Integer
        Dim inserted As Boolean = False
        For i = 0 To lb.Items.Count - 1
            lb.SelectedIndex = i
            If s > lb.SelectedItem And Not inserted Then
                lb.Items.Insert(i, s)
                inserted = True
            End If
        Next
        If Not inserted Then lb.Items.Insert(i, s)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Load_Profil Method

Private Sub Load_Profil( _
   ByVal profilnr As Long _
)

Parameters

profilnr
Required.

Source code

[Visual Basic]
    Private Sub Load_Profil(ByVal profilnr As Long)
        Me.FirstNodeWithData = Nothing
        checkchanges = False
        Me.TreeView1.BeginUpdate()
        Me.TVDokart.BeginUpdate()
        Dim p As New edokadb.clsProfil()
        Dim ma As New edokadb.clsMitarbeiter()
        Dim s As String
        Dim splitter
        Dim i As Integer
        p.cpMainConnectionProvider = conn
        conn.OpenConnection()
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()
        init_treeview1()

        'Selektion
        Try
            Set_Values(p.sDpartner.Value, Me.tpe, 41)
            Set_Values(p.sHostpartner.Value, Me.tku, 51)
            Set_Values(p.sVmb.Value, Me.tmb, 11)
            Set_Values(p.sVnl.Value, Me.tnl, 12)
            Set_Values(p.sVkost.Value, Me.tko, 13)
            Set_Values(p.sVteam.Value, Me.tte, 14)
            Set_Values(p.sVma.Value, Me.tpe, 15)

            Set_Values(p.sEmb.Value, Me.tmb, 21)
            Set_Values(p.sEnl.Value, Me.tnl, 22)
            Set_Values(p.sEkost.Value, Me.tko, 23)
            Set_Values(p.sEteam.Value, Me.tte, 24)
            Set_Values(p.sEma.Value, Me.tpe, 25)

            Set_Values(p.sMmb.Value, Me.tmb, 31)
            Set_Values(p.sMnl.Value, Me.tnl, 32)
            Set_Values(p.sMkost.Value, Me.tko, 33)
            Set_Values(p.sMteam.Value, Me.tte, 34)
            Set_Values(p.sMma.Value, Me.tpe, 35)
            Set_Values(p.sDdokstatus.Value, Me.tst, 44)
            Set_Values(p.sDoktyp.Value, Me.tdt, 43)
            Set_Values(p.sDdokart.Value, Me.tst, 42)
            Set_Values(p.sHostdatum3.Value, Me.tpe, 58)
            Set_Values(p.sHosttag3.Value, Me.tpe, 59)
            Set_Values(p.sHosttag1.Value, Me.tpe, 54)

            Set_Values(p.sHostdokart.Value, Me.tpe, 52)
            Set_Values(p.sHostdoktyp.Value, Me.tdh, 53)

            'Set_Values(p.sHostdoktyp.Value, Me.tdh, 53)
            Set_Values(p.sZvauftraggeber.Value, Me.tdh, 74)
            Set_Values(p.sZvauftragnr.Value, Me.tdh, 73)
            Set_Values(p.sZvbetrag.Value, Me.tdh, 75)
            Set_Values(p.sZvclearingnr.Value, Me.tdh, 76)
            Set_Values(p.sZviso.Value, Me.tdh, 77)
            Set_Values(p.sZvkontobeg.Value, Me.tdh, 78)
            Set_Values(p.sZvpcnr.Value, Me.tdh, 79)
            Set_Values(p.sZvposten.Value, Me.tdh, 80)
            Set_Values(p.sZvreferenznr.Value, Me.tdh, 81)
            Set_Values(p.sZvswift.Value, Me.tdh, 82)
            Set_Values(p.sZvverarbeitungsart.Value, Me.tdh, 83)
            Set_Values(p.sZvzahlungsart.Value, Me.tdh, 84)
            Set_Values(p.sZvdokumenttyp.Value, Me.tdtzv, 71)

            Set_Values(p.sUvmauftragnr.Value, Me.tdh, 93)
            Set_Values(p.sUvmdoktyp.Value, Me.tdtuvm, 91)

            DivFnkt.Searchnode1(Me.TreeView1, 51, 0)
            If DivFnkt.found Then
                If p.sHostpartner.Value <> "" Then
                    '                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 42, 0)
            If DivFnkt.found Then
                If p.sDdokart.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If
            DivFnkt.Searchnode1(Me.TreeView1, 52, 0)
            If DivFnkt.found Then
                If p.sHostdokart.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If
            DivFnkt.Searchnode1(Me.TreeView1, 58, 0)
            If DivFnkt.found Then
                If p.sHosttag3.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 59, 0)
            If DivFnkt.found Then
                If p.sHostdatum3.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            DivFnkt.Searchnode1(Me.TreeView1, 54, 0)
            If DivFnkt.found Then
                If p.sHosttag1.Value <> "" Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    If Me.FirstNodeWithData Is Nothing Then Me.FirstNodeWithData = DivFnkt.FoundNode
                Else
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            'Unterschriften/Hinweise

            Me.mcbunterschriftlinks.SelectedValue = p.iUnterschriftlinks.Value
            Me.mcbunterschriftrechts.SelectedValue = p.iUnterschriftrechts.Value
            Me.mcbTeam.SelectedValue = p.iTeam.Value
            If p.iHw1.IsNull Then Me.cb1.Checked = False Else Me.cb1.Checked = p.iHw1.Value
            If p.iHw2.IsNull Then Me.cb2.Checked = False Else Me.cb2.Checked = p.iHw2.Value
            If p.iHw3.IsNull Then Me.cb3.Checked = False Else Me.cb3.Checked = p.iHw3.Value
            If p.iHw4.IsNull Then Me.cb4.Checked = False Else Me.cb4.Checked = p.iHw4.Value
            If p.iHw5.IsNull Then Me.cb5.Checked = False Else Me.cb5.Checked = p.iHw5.Value
            If p.iHw6.IsNull Then Me.cb3_1.Checked = False Else Me.cb3_1.Checked = p.iHw6.Value

            'Darstellung/Sortierung
            Try
                Me.colbtn1.BackColor = colconv.ConvertFromString(p.sColor1.Value)
                Me.colbtn2.BackColor = colconv.ConvertFromString(p.sColor2.Value)
                Me.colbtn3.BackColor = colconv.ConvertFromString(p.sColor3.Value)
                Me.colbtn4.BackColor = colconv.ConvertFromString(p.sColor4.Value)
                Me.colbtn5.BackColor = colconv.ConvertFromString(p.sColor5.Value)
                Me.colbtn6.BackColor = colconv.ConvertFromString(p.sColor6.Value)
            Catch
            End Try

            Me.lbselect.Items.Clear()
            s = p.sSort.Value
            Try
                splitter = Microsoft.VisualBasic.Split(s, ";")
                i = 0
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        Me.lbselect.Items.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try

            Me.LBSelectHost.Items.Clear()
            s = p.sHosttag2.Value
            Try
                splitter = Microsoft.VisualBasic.Split(s, ";")
                i = 0
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        Me.LBSelectHost.Items.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try

            Me.txtdatum1.Text = Convert_Seldate_von(p.sDatum1.Value)
            If p.sDatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum1.Value, 2) = "(h" Then Me.cbrollend1.Checked = True
            Me.txtdatum2.Text = Convert_Seldate_bis(p.sDatum2.Value)
            If p.sDatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum2.Value, 2) = "(h" Then Me.cbrollend2.Checked = True
            Me.txtdatum3.Text = Convert_Seldate_von(p.sDatum3.Value)
            If p.sDatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum3.Value, 2) = "(h" Then Me.cbrollend3.Checked = True
            Me.txtdatum4.Text = Convert_Seldate_bis(p.sDatum4.Value)
            If p.sDatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum4.Value, 2) = "(h" Then Me.cbrollend4.Checked = True
            Me.txtdatum5.Text = Convert_Seldate_von(p.sDatum5.Value)
            If p.sDatum5.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum5.Value, 2) = "(h" Then Me.cbrollend5.Checked = True
            Me.txtdatum6.Text = Convert_Seldate_bis(p.sDatum6.Value)
            If p.sDatum6.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sDatum6.Value, 2) = "(h" Then Me.cbrollend6.Checked = True

            Me.HostDatum1.Text = Convert_Seldate_von(p.sHostdatum1.Value)
            If p.sHostdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sHostdatum1.Value, 2) = "(h" Then Me.cbrollend8.Checked = True
            Me.HostDatum2.Text = Convert_Seldate_bis(p.sHostdatum2.Value)
            If p.sHostdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sHostdatum2.Value, 2) = "(h" Then Me.cbrollend9.Checked = True

            Me.txtdatum1uvm.Text = Convert_Seldate_von(p.sUvmdatum1.Value)
            If p.sUvmdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum1.Value, 2) = "(h" Then Me.cbuvmrollend1.Checked = True
            Me.txtdatum2uvm.Text = Convert_Seldate_von(p.sUvmdatum2.Value)
            If p.sUvmdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum2.Value, 2) = "(h" Then Me.cbuvmrollend2.Checked = True
            Me.txtdatum3uvm.Text = Convert_Seldate_von(p.sUvmdatum3.Value)
            If p.sUvmdatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum3.Value, 2) = "(h" Then Me.cbuvmrollend3.Checked = True
            Me.txtdatum4uvm.Text = Convert_Seldate_von(p.sUvmdatum4.Value)
            If p.sUvmdatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sUvmdatum4.Value, 2) = "(h" Then Me.cbuvmrollend4.Checked = True

            Me.txtdatum1zv.Text = Convert_Seldate_von(p.sZvdatum1.Value)
            If p.sZvdatum1.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum1.Value, 2) = "(h" Then Me.cbzvrollend1.Checked = True
            Me.txtdatum2zv.Text = Convert_Seldate_von(p.sZvdatum2.Value)
            If p.sZvdatum2.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum2.Value, 2) = "(h" Then Me.cbzvrollend2.Checked = True
            Me.txtdatum3zv.Text = Convert_Seldate_von(p.sZvdatum3.Value)
            If p.sZvdatum3.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum3.Value, 2) = "(h" Then Me.cbzvrollend3.Checked = True
            Me.txtdatum4zv.Text = Convert_Seldate_von(p.sZvdatum4.Value)
            If p.sZvdatum4.Value <> "(heute)-999999" And Microsoft.VisualBasic.Left(p.sZvdatum4.Value, 2) = "(h" Then Me.cbzvrollend4.Checked = True

            Me.hostinklmavip.Checked = p.bInklhostmavip.Value = True

            Dim div As Boolean = False
            If p.sDatum1.Value <> "(heute)-999999" Then div = True
            If p.sDatum2.Value <> "(heute)" And p.sDatum2.Value <> "(heute)-0" Then div = True
            If p.sDatum3.Value <> "(heute)-999999" Then div = True
            If p.sDatum4.Value <> "(heute)" And p.sDatum4.Value <> "(heute)-0" Then div = True
            If p.sDatum5.Value <> "(heute)-999999" Then div = True
            If p.sDatum6.Value <> "(heute)" And p.sDatum6.Value <> "(heute)-0" Then div = True
            If div Then
                DivFnkt.Searchnode(Me.TreeView1, 45, 0)
                If DivFnkt.found Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            div = False
            If p.sHostdatum1.Value <> "(heute)-999999" Then div = True
            If p.sHostdatum2.Value <> "(heute)" And p.sHostdatum2.Value <> "(heute)-0" Then div = True

            If div Then
                DivFnkt.Searchnode(Me.TreeView1, 55, 0)
                If DivFnkt.found Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            If p.sSort.Value <> "" Then
                DivFnkt.Searchnode(Me.TreeView1, 60, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            If p.sHosttag2.Value <> "" Then
                DivFnkt.Searchnode(Me.TreeView1, 61, 0)
                If DivFnkt.found Then
                    DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                End If
            End If

            Dim div1 As Boolean
            Me.expanduvm = False
            Me.expandzv = False
            div1 = False
            If p.sUvmdatum1.Value <> "(heute)-999999" Then div1 = True
            If p.sUvmdatum2.Value <> "(heute)" And p.sUvmdatum2.Value <> "(heute)-0" Then div1 = True
            If p.sUvmdatum3.Value <> "(heute)-999999" Then div1 = True
            If p.sUvmdatum4.Value <> "(heute)" And p.sUvmdatum4.Value <> "(heute)-0" Then div1 = True
            If div1 Then
                DivFnkt.Searchnode(Me.TreeView1, 92, 0)
                If DivFnkt.found Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    DivFnkt.FoundNode.Parent.Expand()
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                    Me.expanduvm = True
                End If
            End If
            div1 = False
            If p.sZvdatum1.Value <> "(heute)-999999" Then div1 = True
            If p.sZvdatum2.Value <> "(heute)" And p.sZvdatum2.Value <> "(heute)-0" Then div1 = True
            If p.sZvdatum3.Value <> "(heute)-999999" Then div1 = True
            If p.sZvdatum4.Value <> "(heute)" And p.sZvdatum4.Value <> "(heute)-0" Then div1 = True
            If div1 Then
                DivFnkt.Searchnode(Me.TreeView1, 72, 0)
                If DivFnkt.found Then
                    'DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Blue
                    DivFnkt.FoundNode.ImageIndex = 4
                    DivFnkt.FoundNode.Parent.Expand()
                    If Me.FirstNodeWithData Is Nothing Then
                        Me.FirstNodeWithData = DivFnkt.FoundNode
                    End If
                    Me.expandzv = True
                End If
            End If

            Me.cinklalt.Checked = p.bInklalt.Value = True
            DivFnkt.Searchnode1(Me.TreeView1, 62, 99)
            If DivFnkt.found Then
                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                If Me.cinklalt.Checked = True Then
                    Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Red
                Else
                    Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Black
                End If
            End If

            If p.sVma.Value = "" And p.sVmb.Value = "" And p.sVnl.Value = "" And p.sVkost.Value = "" And p.sVteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If
            If p.sMma.Value = "" And p.sMmb.Value = "" And p.sMnl.Value = "" And p.sMkost.Value = "" And p.sMteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If
            If p.sEma.Value = "" And p.sEmb.Value = "" And p.sEnl.Value = "" And p.sEkost.Value = "" And p.sEteam.Value = "" Then
            Else
                DivFnkt.Searchnode1(Me.TreeView1, 1, 99)
                If DivFnkt.found Then
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                    Me.TreeView1.SelectedNode.ExpandAll()
                End If
            End If

            'Profilunabhängige Daten
            ma.cpMainConnectionProvider = conn
            ma.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            ma.SelectOne()
            Try
                '               Me.FirstNodeWithData.ForeColor = System.Drawing.Color.Blue
            Catch
            End Try
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try
        conn.CloseConnection(True)
        'shieb        Me.TreeView1.EndUpdate()
        Me.TVDokart.EndUpdate()

        checkchanges = True
        Try
        Catch
            If Me.FirstNodeWithData Is Nothing Then
                Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
            Else
                Me.TreeView1.SelectedNode = Me.FirstNodeWithData
            End If
        End Try
        '  Me.TreeView1.BeginUpdate()
        Update_Datumnode(45, Me.txtdatum1, Me.txtdatum2, Me.cbrollend1, Me.cbrollend2, "Erstellung")
        Update_Datumnode(45, Me.txtdatum3, Me.txtdatum4, Me.cbrollend3, Me.cbrollend4, "Mutation")
        Update_Datumnode(45, Me.txtdatum5, Me.txtdatum6, Me.cbrollend5, Me.cbrollend6, "Archivdatum")
        Update_Datumnode(55, Me.HostDatum1, Me.HostDatum2, Me.cbrollend8, Me.cbrollend9, "Valuta")
        Update_Datumnode(72, Me.txtdatum1zv, Me.txtdatum2zv, Me.cbzvrollend1, Me.cbzvrollend2, "Valuta")
        Update_Datumnode(72, Me.txtdatum3zv, Me.txtdatum4zv, Me.cbzvrollend3, Me.cbzvrollend4, "Archivierung")
        Update_Datumnode(92, Me.txtdatum1uvm, Me.txtdatum2uvm, Me.cbuvmrollend1, Me.cbuvmrollend2, "Erstellung")
        Update_Datumnode(92, Me.txtdatum3uvm, Me.txtdatum4uvm, Me.cbuvmrollend3, Me.cbuvmrollend4, "Archivierung")

        Me.TreeView1.ExpandAll()
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        nodeswithdata(90)
        nodeswithdata(72)
        nodeswithdata(92)

        Me.TreeView1.EndUpdate()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        If MyMsg.Show_MessageYesNo(16) = MsgBoxResult.Yes Then
            Dim p As New edokadb.clsProfil()
            p.cpMainConnectionProvider = conn
            Me.Profile_Geaendert = True
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(False, Boolean))
            p.Update()
            p.Dispose()
            conn.CloseConnection(True)
            Me.ProfilNr = 0
            frmProfil_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        check_changes()
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfil()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("profil")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(0, Int32))
            p.SelectOne()
            p.bAktiv = New SqlBoolean(CType(True, Boolean))
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            p.sVma = New SqlString(CType(Globals.MitarbeiterNr, String))

            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.frmProfil_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem13_Click Method

Private Sub MenuItem13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Dim a As String
        a = InputBox(MyTxt.gettext(501))
        If a <> "" Then
            Me.Profile_Geaendert = True
            Dim p As New edokadb.clsProfil()
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim key As Int32
            dbkey.cpMainConnectionProvider = conn
            p.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("profil")
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
            p.SelectOne()
            p.sBezeichnung = New SqlString(CType(a, String))
            p.iProfilnr = New SqlInt32(CType(key, Int32))
            p.Insert()
            conn.CloseConnection(True)
            p.Dispose()
            dbkey.Dispose()
            Me.ProfilNr = key
            Me.frmProfil_Load(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem14_Click Method

Private Sub MenuItem14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Try
            Dim tn As TreeNode
            Dim tn1 As TreeNode
            tn = TreeView1.SelectedNode
            While tn.GetNodeCount(True) > 0
                tn.Nodes(0).Remove()
            End While
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        Try
            Me.C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        Try
            If Me.PartnerList.Columns(0).Value > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.PartnerList.Columns(0).Value
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem17_Click Method

Private Sub MenuItem17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        Dim i As Integer
        Dim s As String
        If Me.LBSelectHost.Visible = True Then
            If Me.LBSelectHost.SelectedItems.Count > 0 Then
                Try
                    i = LBSelectHost.SelectedIndex
                    s = LBSelectHost.SelectedItem
                    If i > 0 Then
                        LBSelectHost.Items.RemoveAt(i)
                        LBSelectHost.Items.Insert(i - 1, s)
                        LBSelectHost.SelectedIndex = i - 1
                    End If
                Catch
                End Try
            End If
        Else
            Try
                If Me.lbselect.SelectedItems.Count > 0 Then
                    i = lbselect.SelectedIndex
                    s = lbselect.SelectedItem
                    If i > 0 Then
                        lbselect.Items.RemoveAt(i)
                        lbselect.Items.Insert(i - 1, s)
                        lbselect.SelectedIndex = i - 1
                    End If
                End If
            Catch
            End Try
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem18_Click Method

Private Sub MenuItem18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim i As Integer
        Dim s As String
        If Me.LBSelectHost.Visible = True Then
            Try
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    i = LBSelectHost.SelectedIndex
                    s = LBSelectHost.SelectedItem
                    If i < LBSelectHost.Items.Count - 1 Then
                        LBSelectHost.Items.RemoveAt(i)
                        LBSelectHost.Items.Insert(i + 1, s)
                        LBSelectHost.SelectedIndex = i + 1
                    End If
                    changes = True
                End If
            Catch
            End Try
        Else
            Try
                If Me.lbselect.SelectedItems.Count > 0 Then
                    i = lbselect.SelectedIndex
                    s = lbselect.SelectedItem
                    If i < lbselect.Items.Count - 1 Then
                        lbselect.Items.RemoveAt(i)
                        lbselect.Items.Insert(i + 1, s)
                        lbselect.SelectedIndex = i + 1
                    End If
                    changes = True
                End If
            Catch
            End Try
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem19_Click Method

Private Sub MenuItem19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem19.Click
        Dim splitter
        Try
            If Me.LBSelectHost.Visible = True Then
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.LBSelectHost.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.LBSelectHost.Items.RemoveAt(Me.LBSelectHost.SelectedIndex)
                End If
            Else
                If Me.lbselect.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.lbselect.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.lbselect.Items.RemoveAt(Me.lbselect.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem20_Click Method

Private Sub MenuItem20_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem20.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem20_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem20.Click
        Try
            C1TrueDBGrid1_DoubleClick(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem21_Click Method

Private Sub MenuItem21_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem21_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem21.Click
        Dim s, s1 As String
        Dim splitter
        If Me.LBSelectHost.Visible = True Then
            If Me.LBSelectHost.SelectedItems.Count > 0 Then
                Try
                    s = LBSelectHost.SelectedItem
                    splitter = Microsoft.VisualBasic.Split(s, " | ")
                    Select Case splitter(1)
                        Case "Absteigend"
                            s1 = "Aufsteigend"
                        Case "Aufsteigend"
                            s1 = "Absteigend"
                        Case Else
                            s1 = "Aufsteigend"
                    End Select
                    s = splitter(0) + " | " + s1
                    i = LBSelectHost.SelectedIndex
                    LBSelectHost.SelectedIndex = i
                    LBSelectHost.Items.RemoveAt(i)
                    LBSelectHost.Items.Insert(i, s)
                Catch
                End Try
            End If
        Else
            If Me.lbselect.SelectedItems.Count > 0 Then
                Try
                    s = lbselect.SelectedItem
                    splitter = Microsoft.VisualBasic.Split(s, " | ")
                    Select Case splitter(1)
                        Case "Absteigend"
                            s1 = "Aufsteigend"
                        Case "Aufsteigend"
                            s1 = "Absteigend"
                        Case Else
                            s1 = "Aufsteigend"
                    End Select
                    s = splitter(0) + " | " + s1
                    i = lbselect.SelectedIndex
                    lbselect.SelectedIndex = i
                    lbselect.Items.RemoveAt(i)
                    lbselect.Items.Insert(i, s)
                Catch
                End Try
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Try
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.TVDokart.BeginUpdate()
                Me.TVDokart.SelectedNode.ExpandAll()
                Me.TVDokart.EndUpdate()
            Else
                Me.TVHostDok.BeginUpdate()
                Me.TVHostDok.SelectedNode.ExpandAll()
                Me.TVHostDok.EndUpdate()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.Collapse()
        Else
            Me.TVHostDok.SelectedNode.Collapse()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Try
            Dim tn As TreeNode
            Dim p As New edokadb.clsProfil()
            p.cpMainConnectionProvider = conn
            Me.Profile.BeginUpdate()
            tn = Me.Profile.Nodes(0)
            Do Until tn Is Nothing
                If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                    conn.OpenConnection()
                    p.iProfilnr = New SqlInt32(CType(tn.Tag, Int32))
                    p.SelectOne()
                    p.bStandard = New SqlBoolean(CType(False, Boolean))
                    p.Update()
                    conn.CloseConnection(True)
                End If
                tn.BackColor = System.Drawing.Color.White
                tn = tn.NextNode
            Loop
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.Profile.SelectedNode.Tag, Int32))
            p.SelectOne()
            p.bStandard = New SqlBoolean(CType(True, Boolean))
            p.Update()
            conn.CloseConnection(True)
            p.Dispose()
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.LightBlue
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Try
            Dim a As String
            a = InputBox(MyTxt.gettext(501))
            If a <> "" Then
                Me.Profile_Geaendert = True
                Me.Profile.SelectedNode.Text = a
                Me.Profname = a
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MnDel_Click Method

Private Sub MnDel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnDel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDel.Click
        Try
            Dim tn As TreeNode
            tn = TreeView1.SelectedNode
            tn.Remove()
            changes = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MnuDeleteDokumentart_Click Method

Private Sub MnuDeleteDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 2
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Black
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 2
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Black
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MnuListe_Popup Method

Private Sub MnuListe_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MnuListe.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuListe_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MnuListe.Popup
        Dim i As Integer
        If Me.Profil_Ungueltig = True Then
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = False
            Next
        Else
            For i = 0 To Me.MnuListe.MenuItems.Count - 1
                Me.MnuListe.MenuItems(i).Enabled = True
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.MnuSelectDokumentart_Click Method

Private Sub MnuSelectDokumentart_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSelectDokumentart.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSelectDokumentart_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSelectDokumentart.Click
        If Me.TreeView1.SelectedNode.Tag = 42 Then
            Me.TVDokart.SelectedNode.ImageIndex = 1
            Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Red
        Else
            Me.TVHostDok.SelectedNode.ImageIndex = 1
            Me.TVHostDok.SelectedNode.ForeColor = System.Drawing.Color.Red
        End If
        changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Panel1_Paint Method

Private Sub Panel1_Paint( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
) Handles Panel1.Paint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Panel1_Paint(ByVal sender As System.Object, ByVal e As System.Windows.Forms.PaintEventArgs) Handles Panel1.Paint

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.PartnerList_FetchRowStyle Method

Private Sub PartnerList_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles PartnerList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles PartnerList.FetchRowStyle
        If Microsoft.VisualBasic.Left(Me.PartnerList.Columns(0).CellValue(e.Row), 1) = "9" Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Profil_Colors Method

Private Function Profil_Colors()

Source code

[Visual Basic]
    Private Function Profil_Colors()
        Dim tn As TreeNode
        Me.Profile.BeginUpdate()
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If colconv.ConvertToString(tn.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Then
                tn.BackColor = System.Drawing.Color.LightBlue
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
            tn = tn.NextNode
        Loop
        Try
            Me.Profile.SelectedNode.BackColor = System.Drawing.Color.Silver
            Me.Profile.EndUpdate()
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Profile_AfterSelect Method

Private Sub Profile_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles Profile.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles Profile.AfterSelect
        If Not On_Load Then
            check_changes()
            If Me.Profil_Ungueltig Then
                Me.Profile.SelectedNode = Me.savenode
                MyMsg.show_standardmessage(105, MsgBoxStyle.Critical)
                Exit Sub
            End If
            Me.savenode = Me.Profile.SelectedNode
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            check_changes()
            Me.ProfilNr = Me.Profile.SelectedNode.Tag
            init_treeview1()
            frmProfil_Load(sender, e)
            Me.TreeView1.SelectedNode = Nothing
        End If
        Me.Cursor = System.Windows.Forms.Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Profile_BeforeSelect Method

Private Sub Profile_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles Profile.BeforeSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles Profile.BeforeSelect
        '    If Not On_Load Then
        '        Me.savenode = Me.Profile.SelectedNode
        '        If Me.Profil_Ungueltig And Not Me.On_Load Then
        '            MyMsg.show_standardmessage(105, MsgBoxStyle.Critical)
        '            Me.Profile.SelectedNode = Me.savenode
        '            Me.Profil_Ungueltig = False
        '            Exit Sub
        '        End If
        '        Me.savenode = Me.Profile.SelectedNode
        '    End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Profile_MouseDown Method

Private Sub Profile_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Profile.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Profile_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Profile.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                Profile.SelectedNode = Profile.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Remove_Selected_Items Method

Private Sub Remove_Selected_Items( _
   ByVal lb As ListBox _
)

Parameters

lb
Required.

Source code

[Visual Basic]
    Private Sub Remove_Selected_Items(ByVal lb As ListBox)
        Dim i As Integer
        Dim b As Integer
        Dim splitter
        For i = 0 To lb.Items.Count - 1
            lb.SelectedIndex = i
            splitter = Microsoft.VisualBasic.Split(lb.SelectedItem)

            Try
                For b = 0 To Me.lbSortfields.Items.Count - 1
                    Me.lbSortfields.SelectedIndex = b
                    If Me.lbSortfields.SelectedItem = splitter(0) Then Me.lbSortfields.Items.RemoveAt(b)
                Next
            Catch
            End Try
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Save_Profile Method

Private Sub Save_Profile()

Source code

[Visual Basic]
    Private Sub Save_Profile()
        Dim p As New edokadb.clsProfil()
        Dim tn As TreeNode
        Dim d As DataTable
        Dim tmptreeview As New TreeView()
        p.cpMainConnectionProvider = conn
        p.iProfilnr = New SqlInt32(CType(Me.ProfilNr, Int32))
        p.SelectOne()

        'Selektion
        Dim s As String

        Dim i As Integer
        Me.TreeView1.BeginUpdate()
        p.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        p.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))

        p.sVmb = New SqlString(CType(GetNodeDatastring(11), String))
        p.sVnl = New SqlString(CType(GetNodeDatastring(12), String))
        p.sVkost = New SqlString(CType(GetNodeDatastring(13), String))
        p.sVteam = New SqlString(CType(GetNodeDatastring(14), String))
        p.sVma = New SqlString(CType(GetNodeDatastring(15), String))

        p.sEmb = New SqlString(CType(GetNodeDatastring(21), String))
        p.sEnl = New SqlString(CType(GetNodeDatastring(22), String))
        p.sEkost = New SqlString(CType(GetNodeDatastring(23), String))
        p.sEteam = New SqlString(CType(GetNodeDatastring(24), String))
        p.sEma = New SqlString(CType(GetNodeDatastring(25), String))

        p.sMmb = New SqlString(CType(GetNodeDatastring(31), String))
        p.sMnl = New SqlString(CType(GetNodeDatastring(32), String))
        p.sMkost = New SqlString(CType(GetNodeDatastring(33), String))
        p.sMteam = New SqlString(CType(GetNodeDatastring(34), String))
        p.sMma = New SqlString(CType(GetNodeDatastring(35), String))

        p.sDpartner = New SqlString(CType(GetNodeDatastring(41), String))
        p.sDoktyp = New SqlString(CType(GetNodeDatastring(43), String))
        p.sDdokstatus = New SqlString(CType(GetNodeDatastring(44), String))

        p.sHostpartner = New SqlString(CType(GetNodeDatastring(51), String))
        p.sHostdoktyp = New SqlString(CType(GetNodeDatastring(53), String))
        p.bInklhostmavip = New SqlBoolean(CType(Me.hostinklmavip.Checked, Boolean))
        p.sHosttag3 = New SqlString(CType(GetNodeDatastring(59), String))
        p.sHostdatum3 = New SqlString(CType(GetNodeDatastring(58), String))
        p.sHosttag1 = New SqlString(CType(GetNodeDatastring(54), String))

        tmptreeview = Me.TVDokart
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        'tmptreeview.Dispose()
        p.sDdokart = New SqlString(CType(s, String))

        tmptreeview = Me.TVHostDok
        s = ""
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            s = s + ";" + DivFnkt.FoundNode.Tag
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        p.sHostdokart = New SqlString(CType(s, String))

        'p.bInklmavip = New SqlBoolean(CType(Me.cbmavip.Checked, Boolean))
        p.bInklalt = New SqlBoolean(CType(Me.cinklalt.Checked, Boolean))

        s = ""
        For i = 0 To Me.lbselect.Items.Count - 1
            s = s + Me.lbselect.Items(i) + ";"
        Next
        p.sSort = New SqlString(CType(s, String))

        s = ""
        For i = 0 To Me.LBSelectHost.Items.Count - 1
            s = s + Me.LBSelectHost.Items(i) + ";"
        Next
        p.sHosttag2 = New SqlString(CType(s, String))

        'Unterschriften / Hinweise
        If Me.mcbunterschriftlinks.SelectedValue = Nothing Then
            p.iUnterschriftlinks = New SqlInt32(CType(0, Int32))
        Else
            p.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
        End If
        If Me.mcbunterschriftrechts.SelectedValue = Nothing Then
            p.iUnterschriftrechts = New SqlInt32(CType(0, Int32))
        Else
            p.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
        End If
        If Me.mcbTeam.SelectedText = Nothing Then
            p.iTeam = New SqlInt32(CType(0, Int32))
        Else
            p.iTeam = New SqlInt32(CType(Me.mcbTeam.SelectedValue, Int32))
        End If

        If Me.cb1.Checked = True Then
            p.iHw1 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw1 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb2.Checked = True Then
            p.iHw2 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw2 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb3.Checked = True Then
            p.iHw3 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw3 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb3_1.Checked = True Then
            p.iHw6 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw6 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb4.Checked = True Then
            p.iHw4 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw4 = New SqlInt32(CType(0, Int32))
        End If
        If Me.cb5.Checked = True Then
            p.iHw5 = New SqlInt32(CType(1, Int32))
        Else
            p.iHw5 = New SqlInt32(CType(0, Int32))
        End If

        If colconv.ConvertToString(Me.Profile.SelectedNode.BackColor) = colconv.ConvertToString(System.Drawing.Color.LightBlue) Or p.bStandard.Value = True Then
            p.bStandard = New SqlBoolean(CType(True, Boolean))
        Else
            p.bStandard = New SqlBoolean(CType(False, Boolean))
        End If

        'Colors
        p.sColor1 = New SqlString(CType(colconv.ConvertToString(Me.colbtn1.BackColor), String))
        p.sColor2 = New SqlString(CType(colconv.ConvertToString(Me.colbtn2.BackColor), String))
        p.sColor3 = New SqlString(CType(colconv.ConvertToString(Me.colbtn3.BackColor), String))
        p.sColor4 = New SqlString(CType(colconv.ConvertToString(Me.colbtn4.BackColor), String))
        p.sColor5 = New SqlString(CType(colconv.ConvertToString(Me.colbtn5.BackColor), String))
        p.sColor6 = New SqlString(CType(colconv.ConvertToString(Me.colbtn6.BackColor), String))

        'Selektionsdaten
        p.sDatum1 = New SqlString(CType(Me.datumtext1.Text, String))
        p.sDatum2 = New SqlString(CType(Me.datumtext2.Text, String))
        p.sDatum3 = New SqlString(CType(Me.datumtext3.Text, String))
        p.sDatum4 = New SqlString(CType(Me.datumtext4.Text, String))
        p.sDatum5 = New SqlString(CType(Me.datumtext5.Text, String))
        p.sDatum6 = New SqlString(CType(Me.datumtext6.Text, String))
        p.sHostdatum1 = New SqlString(CType(Me.DatumHostText1.Text, String))
        p.sHostdatum2 = New SqlString(CType(Me.DatumHostText2.Text, String))

        Dim s1 As String
        Dim s2 As String

        If Me.Profname <> "" Then p.sBezeichnung = New SqlString(CType(Profname, String))
        conn.OpenConnection()
        p.Update()

        conn.CloseConnection(True)
        p.Dispose()
        Me.TreeView1.EndUpdate()
        changes = False
        Me.Load_Profil(Me.ProfilNr)
        Me.TreeView1.ExpandAll()
        Me.Profil_Ungueltig = False
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        nodeswithdata(90)
        nodeswithdata(72)
        nodeswithdata(92)
        'If Me.FirstNodeWithData Is Nothing Then
        'Me.Profil_Ungueltig = True
        'Exit Sub
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Set_Values Method

Private Sub Set_Values( _
   ByVal data As String, _
   ByVal ds As DataTable, _
   ByVal node As Integer _
)

Parameters

data
Required.
ds
Required.
node
Required.

Source code

[Visual Basic]
    Private Sub Set_Values(ByVal data As String, ByVal ds As DataTable, ByVal node As Integer)
        If data = "" Then Exit Sub
        Dim splitter
        Dim i As Integer
        Dim s As String
        Dim tn As TreeNode
        Dim dv As New DataTable()
        Dim i1 As Integer
        Dim v As Double
        Select Case node
            Case 11, 21, 31
                dv = Me.tmb
            Case 12, 22, 32
                dv = Me.tnl
            Case 13, 23, 33
                dv = Me.tko
            Case 14, 24, 34
                dv = Me.tte
            Case 15, 25, 35
                dv = Me.tpe
            Case 51
                dv = Me.tku
            Case 43
                dv = Me.tdt
            Case 53
                dv = Me.tdh
            Case 44
                dv = Me.tst
            Case 71
                dv = Me.tdtzv
            Case 91
                dv = Me.tdtuvm
            Case Else
        End Select
        s = data
        splitter = Microsoft.VisualBasic.Split(s, ";")
        i = 0
        Try
            Do Until splitter(i) Is Nothing
                Select Case node
                    Case 41
                        Dim p As New edokadb.clsPartner()
                        Try
                            DivFnkt.Searchnode1(Me.TreeView1, node, 0)
                            If DivFnkt.found Then
                                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                tn = Me.TreeView1.SelectedNode
                                p.cpMainConnectionProvider = conn
                                p.iNRPAR00 = New SqlInt32(CType(splitter(i), Int32))
                                p.SelectOne()
                                tn = tn.Nodes.Add(splitter(i) + " - " + p.sBKPAR00.Value)
                                tn.Tag = splitter(i)
                                Me.FirstNodeWithData = DivFnkt.FoundNode
                                tn.ImageIndex = 4
                                tn.SelectedImageIndex = 4
                                tn.ForeColor = System.Drawing.Color.Red
                            End If
                        Catch ex As Exception
                        Finally
                            p.Dispose()
                            i = i + 1
                        End Try
                    Case 42, 52
                        DivFnkt.Searchnode(Me.TVDokart, splitter(i), 0)
                        If DivFnkt.found Then
                            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
                            DivFnkt.FoundNode.ImageIndex = 1
                            If Not DivFnkt.FoundNode.Parent.IsExpanded Then DivFnkt.FoundNode.Parent.ExpandAll()
                        End If
                    Case 54, 58, 59, 73, 74, 75, 76, 77, 78, 79, 80, 81, 82, 83, 84, 92, 93, 94
                        Try
                            DivFnkt.Searchnode1(Me.TreeView1, node, 0)
                            If DivFnkt.found And splitter(i) <> "" Then
                                Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                tn = Me.TreeView1.SelectedNode
                                tn = tn.Nodes.Add(splitter(i))
                                tn.Tag = splitter(i)
                                If Me.FirstNodeWithData Is Nothing Then
                                    Me.FirstNodeWithData = DivFnkt.FoundNode
                                End If
                                tn.ImageIndex = 4
                                tn.SelectedImageIndex = 4
                                tn.ForeColor = System.Drawing.Color.Red
                            End If
                        Catch
                        End Try
                    Case Else
                        For i1 = 0 To dv.Rows.Count - 1
                            v = Val(splitter(i))
                            If dv.Rows(i1).Item(0) = splitter(i) Then
                                DivFnkt.Searchnode1(Me.TreeView1, node, 99)
                                If DivFnkt.found Then
                                    If Me.FirstNodeWithData Is Nothing Then
                                        Me.FirstNodeWithData = DivFnkt.FoundNode
                                    End If
                                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode
                                    tn = Me.TreeView1.SelectedNode
                                    tn = tn.Nodes.Add(dv.Rows(i1).Item(1))
                                    tn.Tag = dv.Rows(i1).Item(0)
                                    tn.ImageIndex = 4
                                    tn.SelectedImageIndex = 4
                                    If dv.Rows(i1).Item(2) = False Then
                                        tn.ForeColor = System.Drawing.Color.Gray
                                    Else
                                        tn.ForeColor = System.Drawing.Color.Red
                                    End If
                                End If

                            End If
                        Next
                End Select
                i = i + 1
            Loop
        Catch ex As Exception
            '            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        t = partner
        ts.Tabelle = "Partner"
        For i = 0 To Me.PartnerList.Columns.Count - 1
            s = Me.PartnerList.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.PartnerList.Columns(i).Caption = ts.spaltenname
            If Me.PartnerList.Columns(i).Caption = "" Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.PartnerList.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            '            If Me.PartnerList.Columns(i).Caption = "" Then Me.PartnerList.Splits(0).DisplayColumns(i).Width = 0
            If ts.locked Then
                Me.PartnerList.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If Me.PartnerList.Columns(i).DataField = "aktiv" Then
                Me.PartnerList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.PartnerList.Columns(i).ValueItems.DefaultItem = True
                Me.PartnerList.Columns(i).DefaultValue = True
                Me.PartnerList.Columns(i).FilterText = True
            End If
            If Me.PartnerList.Columns(i).DataField = "erstellt_am" Then
                Me.PartnerList.Columns(i).DefaultValue = Now
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TVDokart_DoubleClick Method

Private Sub TVDokart_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TVDokart.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVDokart_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TVDokart.DoubleClick
        '        If Me.TVDokart.SelectedNode.ImageIndex <> 1 Then
        '           Me.TVDokart.SelectedNode.ImageIndex = 1
        '          Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Red
        '     Else
        '        Me.TVDokart.SelectedNode.ImageIndex = 2
        '       Me.TVDokart.SelectedNode.ForeColor = System.Drawing.Color.Black
        '  End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TVDokart_MouseDown Method

Private Sub TVDokart_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVDokart.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVDokart_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVDokart.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TVDokart.SelectedNode = TVDokart.GetNodeAt(selectPoint)
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TabPage1_Click Method

Private Sub TabPage1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabPage1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabPage1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabPage1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TextBox1_KeyDown Method

Private Sub TextBox1_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox3.KeyDown, _
   TextBox2.KeyDown, _
   TextBox1.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox3.KeyDown, TextBox2.KeyDown, TextBox1.KeyDown
        If e.KeyCode = Keys.Return Then btnPartnersuche_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TextBox4_KeyDown Method

Private Sub TextBox4_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox4.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox4_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox4.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button9_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TextBox5_KeyDown Method

Private Sub TextBox5_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox5.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox5_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox5.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button10_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TextBox6_KeyDown Method

Private Sub TextBox6_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TextBox6.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox6_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TextBox6.KeyDown
        If e.KeyCode = Keys.Enter Then
            Me.Button20_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
                '                Me.MenuItem5_Click(sender, e)
            Case 1
            Case 2
                Me.TreeView1.BeginUpdate()
                Me.Profile.BeginUpdate()
                Me.On_Load = True
                Me.oninit = True
                Save_Profile()
                Me.Profile.EndUpdate()
                Me.TreeView1.EndUpdate()
                If Me.Profil_Ungueltig = True Then MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
                Me.On_Load = False
                Me.oninit = False
            Case 3
                Me.TreeView1.BeginUpdate()
                oninit = True
                init_profile()
                oninit = False
                Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
                Me.TreeView1.EndUpdate()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TreeView1_AfterSelect Method

Private Sub TreeView1_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect
        If On_Load Then Exit Sub
        If oninit Then Exit Sub
        '        Me.PnlDokumentDaten.Visible = False
        '        Me.Panel3.Visible = False
        '        Me.PnlPartner.Visible = False
        '        Me.PnlDokumentart.Visible = False
        '        Me.TVDokart.Visible = False
        '        Me.TVHostDok.Visible = False
        '        Me.pnlhostdiv.Visible = False
        '        Me.Panel4.Visible = False

        Try
            If Me.TreeView1.SelectedNode.ImageIndex < 6 Then
                Me.TreeView1.SelectedNode.ImageIndex = 4
                Me.TreeView1.SelectedNode.SelectedImageIndex = 4
            End If
            If Me.TreeView1.SelectedNode.Tag = 11 Or Me.TreeView1.SelectedNode.Tag = 21 Or Me.TreeView1.SelectedNode.Tag = 31 Then
                Me.C1TrueDBGrid1.DataSource = tmb
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 12 Or Me.TreeView1.SelectedNode.Tag = 22 Or Me.TreeView1.SelectedNode.Tag = 32 Then
                Me.C1TrueDBGrid1.DataSource = tnl
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 13 Or Me.TreeView1.SelectedNode.Tag = 23 Or Me.TreeView1.SelectedNode.Tag = 33 Then
                Me.C1TrueDBGrid1.DataSource = tko
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 14 Or Me.TreeView1.SelectedNode.Tag = 24 Or Me.TreeView1.SelectedNode.Tag = 34 Then
                Me.C1TrueDBGrid1.DataSource = tte
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 15 Or Me.TreeView1.SelectedNode.Tag = 25 Or Me.TreeView1.SelectedNode.Tag = 35 Then
                Me.C1TrueDBGrid1.DataSource = tpe
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 41 Then
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.PnlDokumentart.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 43 Then
                Me.C1TrueDBGrid1.DataSource = tdt
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 44 Then
                Me.C1TrueDBGrid1.DataSource = tst
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 45 Then
                Me.Panel3.Visible = False
                Me.PnlDokumentDaten.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 62 Then
                Me.Panel3.Visible = False
                Me.PnlDokumentDaten.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            'Edoka-Dokument
            'If Me.TreeView1.SelectedNode.Tag = 41 Then
            '    Me.Partnerdialog.TopMost = True
            '    Me.Partnerdialog.Show()
            '    Me.Partnerdialog.NoClose = True
            '    Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            '    '
            '    '                Me.Panel3.Visible = False
            '    '                Me.PnlDokumentDaten.Visible = False
            '    '                Me.PnlPartner.Visible = True
            '    '                Me.TextBox1.Focus()
            '    '                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            'End If
            'Host-kundenbetreuer
            If Me.TreeView1.SelectedNode.Tag = 51 Then
                Me.C1TrueDBGrid1.DataSource = tku
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 42 Then
                Me.TVDokart.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 52 Then
                Me.TVHostDok.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 53 Then
                Me.C1TrueDBGrid1.DataSource = tdh
                Me.Panel3.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 55 Then
                Me.pnlhostdiv.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 58 Then
                Me.pnlhostdiv.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 54 Then
                Me.pnlhostdiv.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 59 Then
                Me.pnlhostdiv.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 60 Then
                Me.Panel4.Visible = True
                Me.lbSortfields.Items.Clear()
                Me.lbSortfields.Items.AddRange(New Object() {"Bemerkung", "Bezeichnung", "Dokumentart", "DokumentID", "Ersteller", "Erstellungsdatum", "Mutationsdatum", "Mutierer", "Status", "Termin", "Verantwortlicher", "Zuständiger"})
                Remove_Selected_Items(Me.lbselect)
                Me.LBSelectHost.Visible = False
                Me.lbselect.Visible = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            If Me.TreeView1.SelectedNode.Tag = 61 Then
                Me.Panel4.Visible = True
                Me.lbSortfields.Items.Clear()
                Me.lbSortfields.Items.AddRange(New Object() {"DokumentID", "Dokumenttyp-Nr", "Isin-Nr", "Valutadatum", "Valorennr", "VVExtern1", "VVExtern2"})
                Remove_Selected_Items(Me.LBSelectHost)
                Me.LBSelectHost.Visible = True
                Me.lbselect.Visible = False
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
            'hutter
            Dim i As Integer
            Dim w As Integer
            w = Me.C1TrueDBGrid1.Columns.Count - 2
            w = (Me.C1TrueDBGrid1.Width - 150) / w
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Width = 150
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
            For i = 3 To Me.C1TrueDBGrid1.Splits(0).DisplayColumns.Count - 1
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = w
            Next

            Try
                Me.C1TrueDBGrid1.Columns("Aktiv").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.C1TrueDBGrid1.Columns("Aktiv").FilterText = True
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Aktiv").Width = 50
            Catch
            End Try

            'For i = 1 To Me.C1TrueDBGrid1.Columns.Count - 1
            '    If Me.C1TrueDBGrid1.Columns.Count > 3 Then
            '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = 80
            '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(2).Width = Me.C1TrueDBGrid1.Width - 100
            '    Else
            '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = 100
            '    End If
            'Next

            'For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            '    If i <> 1 And i <> 2 And i <> 3 Then
            '        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
            '    Else
            '        If i = 1 Then
            '            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = Me.C1TrueDBGrid1.Width - 150
            '        Else
            '            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Width = 100
            '        End If
            '    End If
            'Next
        Catch
        End Try

        'Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.TreeView1_Click Method

Private Sub TreeView1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TreeView1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TreeView1.Click
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Treeview1_MouseDown Method

Private Sub Treeview1_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Treeview1_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Try
                TreeView1.SelectedNode = TreeView1.GetNodeAt(selectPoint)
            Catch
            End Try
            If TreeView1.SelectedNode.Tag = 41 And e.Button = MouseButtons.Left Then
                'Me.Partnerdialog.TopMost = True
                'Me.Partnerdialog.Left = Me.MousePosition.X + 50
                'Me.Partnerdialog.Top = Me.MousePosition.Y - 20
                'Me.Partnerdialog.Show()
                'Me.Partnerdialog.NoClose = True
                Me.TreeView1.SelectedNode.SelectedImageIndex = 5
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.Update_Datumnode Method

Private Sub Update_Datumnode( _
   ByVal node As Integer, _
   ByVal txt1 As TextBox, _
   ByVal txt2 As TextBox, _
   ByVal cb1 As CheckBox, _
   ByVal cb2 As CheckBox, _
   ByVal Nodebezeichnung As String _
)

Parameters

node
Required.
txt1
Required.
txt2
Required.
cb1
Required.
cb2
Required.
Nodebezeichnung
Required.

Source code

[Visual Basic]
    Private Sub Update_Datumnode(ByVal node As Integer, ByVal txt1 As TextBox, ByVal txt2 As TextBox, ByVal cb1 As CheckBox, ByVal cb2 As CheckBox, ByVal Nodebezeichnung As String)
        DivFnkt.Searchnode1(Me.TreeView1, node, 99)
        If txt1.Text <> "" Or txt2.Text <> "" Then
            Dim tn As New TreeNode()
            tn = DivFnkt.FoundNode.Nodes.Add(Nodebezeichnung)
            tn.ImageIndex = 4
            tn.SelectedImageIndex = 4
            tn.ForeColor = System.Drawing.Color.Red
            If txt1.Text <> "" Then
                tn.Text = tn.Text + " von " + txt1.Text
                If cb1.Checked = True Then tn.Text = tn.Text + " (rollend)"
            End If
            If txt2.Text <> "" Then
                tn.Text = tn.Text + " bis " + txt2.Text
                If cb2.Checked = True Then tn.Text = tn.Text + " (rollend)"
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.ValueList Method

Private Function ValueList( _
   ByVal c As ListView _
) As String

Parameters

c
Required.

Source code

[Visual Basic]
    Private Function ValueList(ByVal c As ListView) As String
        Dim s As String
        s = ""
        For i = 0 To c.Items.Count - 1
            s = s + c.Items(i).Text + ";"
            If UCase(c.Name) = "SELPARTNER" Then
                li = c.Items(i)
                s = s + li.SubItems(1).Text + ";"
            End If
        Next
        Return s
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.btnPartnersuche_Click Method

Private Sub btnPartnersuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnersuche.Click
        Me.PartnerList.DataSource = Nothing
        Me.PartnerList.DataMember = Nothing
        If Me.TextBox1.Text <> "" Then
            Try
                Dim d As Double
                d = Val(Me.TextBox1.Text)
                If d = 0 Then
                    MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                    Me.TextBox1.Focus()
                    Exit Sub
                End If
                partner = mypartner.search_partner(d, 50, 0)
            Catch
                MyMsg.show_standardmessage(20, MsgBoxStyle.Critical)
                Me.TextBox1.Focus()
                Exit Sub
            End Try
        Else
            If Me.TextBox2.Text <> "" Then
                partner = mypartner.search_partner(Me.TextBox2.Text, 50, 1)
            Else
                partner = mypartner.search_partner(Me.TextBox3.Text, 50, 2)
            End If
        End If
        If partner.Rows.Count = 0 Then
            MyMsg.show_standardmessage(204, MsgBoxStyle.Exclamation)
        Else
            Me.PartnerList.DataSource = partner
            Me.PartnerList.DataMember = "Partner"
            SpaltenTitel_Aktualisieren()
            Dim i As Long
            Dim ii As Long
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.cbrollend1_CheckedChanged Method

Private Sub cbrollend1_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbrollend6.CheckedChanged, _
   cbrollend5.CheckedChanged, _
   cbrollend4.CheckedChanged, _
   cbrollend3.CheckedChanged, _
   cbrollend2.CheckedChanged, _
   cbrollend1.CheckedChanged, _
   cbrollend8.CheckedChanged, _
   cbrollend9.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbrollend1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbrollend6.CheckedChanged, cbrollend5.CheckedChanged, cbrollend4.CheckedChanged, cbrollend3.CheckedChanged, cbrollend2.CheckedChanged, cbrollend1.CheckedChanged, cbrollend8.CheckedChanged, cbrollend9.CheckedChanged
        Dim cb As CheckBox
        cb = sender
        Select Case cb.Name
            Case "cbrollend1"
                txtdatum1_TextChanged(Me.txtdatum1, e)
            Case "cbrollend2"
                txtdatum1_TextChanged(Me.txtdatum2, e)
            Case "cbrollend3"
                txtdatum1_TextChanged(Me.txtdatum3, e)
            Case "cbrollend4"
                txtdatum1_TextChanged(Me.txtdatum4, e)
            Case "cbrollend5"
                txtdatum1_TextChanged(Me.txtdatum5, e)
            Case "cbrollend6"
                txtdatum1_TextChanged(Me.txtdatum6, e)
            Case "cbrollend8"
                txtdatum1_TextChanged(Me.HostDatum1, e)
            Case "cbrollend9"
                txtdatum1_TextChanged(Me.HostDatum2, e)
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        If On_Load Then Exit Sub
        If changes Then
            If Me.FirstNodeWithData Is Nothing Then
                Me.Profil_Ungueltig = True
            End If
            If MyMsg.Show_MessageYesNo(2) = MsgBoxResult.Yes Then
                Me.Save_Profile()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.cinklalt_CheckedChanged Method

Private Sub cinklalt_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cinklalt.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cinklalt_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cinklalt.CheckedChanged
        Dim tn As New TreeNode()
        DivFnkt.Searchnode1(Me.TreeView1, 62, 99)
        If DivFnkt.found Then
            tn = DivFnkt.FoundNode
            If Me.cinklalt.Checked Then
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
            Else
                tn.Text = "inkl. gelöschte/aufgehobene"
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.del_entry Method

Private Sub del_entry( _
   ByVal node As Integer _
)

Parameters

node
Required.

Source code

[Visual Basic]
    Private Sub del_entry(ByVal node As Integer)
        Dim tn As TreeNode
        DivFnkt.Searchnode1(Me.TreeView1, node, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
            Try
                tn = Me.TreeView1.SelectedNode
                While tn.GetNodeCount(True) > 0
                    tn.Nodes(0).Remove()
                End While
                tn.ForeColor = System.Drawing.Color.Black
            Catch
            End Try

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.frmProfil_Closing Method

Private Sub frmProfil_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        'check_changes()
        'If Me.FirstNodeWithData Is Nothing Then
        'If MyMsg.Show_MessageYesNo(104) = MsgBoxResult.No Then e.Cancel = True
        'End If
        'If Me.Profil_Ungueltig Then
        'MyMsg.show_standardmessage(104, MsgBoxStyle.Critical)
        'e.Cancel = True
        'Else
        '    e.Cancel = False
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.frmProfil_Load Method

Private Sub frmProfil_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProfil_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Cursor = Cursors.WaitCursor
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        On_Load = True
        Me.Profile.BeginUpdate()
        checkchanges = False
        changes = False
        Me.Profile.Nodes.Clear()
        Me.DataSet1.Clear()
        'Personendaten
        Dim tn, tn1 As TreeNode
        If first Then
            init_treeview1()
            tmb = Generic_Select(3)
            tnl = Generic_Select(4)
            tko = Generic_Select(5)
            tte = Generic_Select(6)
            tst = Generic_Select(2)
            tpe = Generic_Select(1)
            tdt = Generic_Select(7)
            tdh = Generic_Select(8)
            tku = Generic_Select(9)
            tdtuvm = Generic_Select(10)
            tdtzv = Generic_Select(11)

            mcbTeam = New MultiComboBox(Me.cbteam)
            Me.mcbTeam.DisplayColumnName = "Bezeichnung"
            Me.mcbTeam.ValueColumnName = "teamnr"
            Me.mcbTeam.Fill_Data(tte, True)
            Me.mcbTeam.Visible = True
            Me.mcbTeam.CheckNullValue = False

            mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
            Me.mcbunterschriftlinks.CheckNullValue = False
            Me.mcbunterschriftlinks.DisplayColumnName = "name"
            Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftlinks.Fill_Data(tpe, True)
            Me.mcbunterschriftlinks.Visible = True

            mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
            Me.mcbunterschriftrechts.CheckNullValue = False
            Me.mcbunterschriftrechts.DisplayColumnName = "name"
            Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftrechts.Fill_Data(tpe, True)
            Me.mcbunterschriftrechts.Visible = True
        End If

        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        tda = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        hdata.Dispose()

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
            tn = Me.Profile.Nodes.Add(Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung"))
            tn.Tag = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
            If Me.DataSet1.Tables(0).Rows(i).Item("standard") Then
                tn.BackColor = System.Drawing.Color.LightBlue
                If Me.ProfilNr = 0 Then Me.ProfilNr = tn.Tag
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
        Next
        first = False
        Load_Profil(Me.ProfilNr)
        checkchanges = False
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If tn.Tag = Me.ProfilNr Then Me.Profile.SelectedNode = tn
            tn = tn.NextNode
        Loop
        On_Load = False
        first = False
        Me.TreeView1.ExpandAll()
        Profil_Colors()
        Me.LBSort.SelectedIndex = 0
        Me.lbSortfields.SelectedIndex = 0
        checkchanges = True
        Me.Profile.EndUpdate()
        Profname = ""
        Activate_Details()
        Me.Cursor = Cursors.Default
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        nodeswithdata(90)
        nodeswithdata(72)
        nodeswithdata(92)
        set_tips()
        Me.TreeView1.SelectedNode = Me.TreeView1.Nodes(0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.init_profile Method

Private Sub init_profile()

Source code

[Visual Basic]
    Private Sub init_profile()
        Dim i As Integer
        For i = 11 To 15
            del_entry(i)
            del_entry(i + 10)
            del_entry(i + 20)
        Next
        del_entry(41)
        del_entry(43)
        del_entry(44)
        del_entry(53)
        del_entry(54)
        del_entry(51)
        del_entry(58)
        del_entry(59)
        Me.LBSelectHost.Items.Clear()
        Me.lbselect.Items.Clear()
        Me.cinklalt.Checked = False
        Me.txtdatum1.Text = ""
        Me.cbrollend1.Checked = False
        Me.txtdatum2.Text = ""
        Me.cbrollend2.Checked = True

        Me.txtdatum3.Text = ""
        Me.cbrollend3.Checked = False
        Me.txtdatum4.Text = ""
        Me.cbrollend4.Checked = True
        Me.txtdatum5.Text = ""
        Me.cbrollend5.Checked = False
        Me.txtdatum6.Text = ""
        Me.cbrollend6.Checked = True

        Me.HostDatum1.Text = ""
        Me.cbrollend8.Checked = False
        Me.HostDatum2.Text = ""
        Me.cbrollend9.Checked = True
        reset_dokart()

        reset_color(60)
        reset_color(61)
        reset_color(62)
        reset_color(45)
        reset_color(55)
        reset_color(42)
        reset_color(52)
        Me.changes = True
        DivFnkt.Searchnode1(Me.TreeView1, 41, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
        End If
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        nodeswithdata(90)
        nodeswithdata(72)
        nodeswithdata(92)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.init_treeview1 Method

Private Function init_treeview1()

Source code

[Visual Basic]
    Private Function init_treeview1()
        Me.TreeView1.Nodes.Clear()
        Dim t0, tn, tn1 As TreeNode
        TreeView1.BeginUpdate()
        Me.TreeView1.Nodes.Clear()
        t0 = Me.TreeView1.Nodes.Add("Partner")
        t0.ImageIndex = 10
        t0.SelectedImageIndex = 10
        t0.Tag = 999
        tn1 = t0.Nodes.Add("Partner")
        tn1.Tag = 41
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = t0.Nodes.Add("Kundenbetreuer")
        tn1.Tag = 51
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        t0 = Me.TreeView1.Nodes.Add("EDOKA-Dokumente")
        t0.ImageIndex = 6
        t0.SelectedImageIndex = 6
        t0.Tag = 998
        tn = t0.Nodes.Add("Verantwortlich")
        tn.ImageIndex = 7
        tn.SelectedImageIndex = 7
        tn.Tag = 1
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 11
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 12
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 13
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 14
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 15
        tn1.SelectedImageIndex = 4
        tn1.ImageIndex = 4
        'tn = Me.TreeView1.Nodes.Add("Ersteller")
        tn = t0.Nodes.Add("Ersteller")
        tn.ImageIndex = 8
        tn.SelectedImageIndex = 8
        tn.Tag = 2
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.Tag = 21
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.Tag = 22
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 23
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 24
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 25
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn = t0.Nodes.Add("Mutierer")
        'tn = Me.TreeView1.Nodes.Add("Mutierer")
        tn.ImageIndex = 9
        tn.SelectedImageIndex = 9
        tn.Tag = 3
        tn1 = tn.Nodes.Add("Marktbereich")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 31
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Niederlassung")
        tn1.SelectedImageIndex = 4
        tn1.Tag = 32
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Kostenstelle")
        tn1.Tag = 33
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Team")
        tn1.Tag = 34
        tn1.ImageIndex = 4
        tn1 = tn.Nodes.Add("Mitarbeiter")
        tn1.Tag = 35
        tn1.ImageIndex = 4

        'tn = t0.Nodes.Add("Diverses")
        '        tn = Me.TreeView1.Nodes.Add("Diverses")
        'tn.ImageIndex = 6
        'tn.SelectedImageIndex = 6
        'tn.Tag = 4

        'tn1 = tn.Nodes.Add("Partner")
        'tn1.Tag = 41
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumentart")
        tn1.Tag = 42
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumenttyp")
        tn1.Tag = 43
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Dokumentstatus")
        tn1.Tag = 44
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Datum-Selektion")
        tn1.Tag = 45
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("inkl. gelöschte/aufgehobene")
        tn1.Tag = 62
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = t0.Nodes.Add("Sortierung")
        tn1.Tag = 60
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn = t0.Nodes.Add("ZV-Belege")
        tn.Tag = 70
        tn.ImageIndex = 13
        tn.SelectedImageIndex = 13

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 71
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Datum-Selektion")
        tn1.Tag = 72
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Auftrags-Nr.")
        tn1.Tag = 73
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Auftraggeber")
        tn1.Tag = 74
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Betrag")
        tn1.Tag = 75
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Clearing-Nr.")
        tn1.Tag = 76
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("ISO-Währung")
        tn1.Tag = 77
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Konto Begünstigter")
        tn1.Tag = 78
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("PC-Nr")
        tn1.Tag = 79
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Posten-Nr.")
        tn1.Tag = 80
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Referenz-Nr.")
        tn1.Tag = 81
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("SWIFT-Adresse")
        tn1.Tag = 82
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Verarbeitungsart")
        tn1.Tag = 83
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Zahlungsart")
        tn1.Tag = 84
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn.Collapse()

        tn = t0.Nodes.Add("Basis-Verträge")
        tn.Tag = 90
        tn.ImageIndex = 12
        tn.SelectedImageIndex = 12

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 91
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Datum-Selektion")
        tn1.Tag = 92
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Auftrags-Nr.")
        tn1.Tag = 93
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        'tn1 = tn.Nodes.Add("Sortierung")
        'tn1.Tag = 94
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4
        'tn.Collapse()

        'tn = t0.Nodes.Add("HOST-Dokumente")
        tn = Me.TreeView1.Nodes.Add("Host-Dokumente")
        tn.ImageIndex = 11
        tn.SelectedImageIndex = 11
        tn.Tag = 5
        '        tn1 = tn.Nodes.Add("Partner")
        '       tn1.Tag = 51
        '      tn1.ImageIndex = 4
        '     tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Dokumentart")
        tn1.Tag = 52
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Dokumenttyp")
        tn1.Tag = 53
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        'tn1 = tn.Nodes.Add("Dokumentstatus")
        'tn1.Tag = 54
        'tn1.ImageIndex = 4
        'tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("VV")
        tn1.Tag = 54
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        tn1 = tn.Nodes.Add("Valorennr")
        tn1.Tag = 59
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("ISIN-Nr")
        tn1.Tag = 58
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Datum-Selektion")
        tn1.Tag = 55
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4
        tn1 = tn.Nodes.Add("Sortierung")
        tn1.Tag = 61
        tn1.ImageIndex = 4
        tn1.SelectedImageIndex = 4

        Me.TVDokart.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVDokart, 2)
        Me.TVDokart.CollapseAll()

        Me.TVHostDok.Nodes.Clear()
        dokumentart.LoadTreeMenu(Me.TVHostDok, 3)
        Me.TVHostDok.ExpandAll()

        Me.TreeView1.EndUpdate()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.lbselect_DoubleClick Method

Private Sub lbselect_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles LBSelectHost.DoubleClick, _
   lbselect.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lbselect_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LBSelectHost.DoubleClick, lbselect.DoubleClick
        Dim splitter
        Try
            If Me.LBSelectHost.Visible = True Then
                If Me.LBSelectHost.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.LBSelectHost.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.LBSelectHost.Items.RemoveAt(Me.LBSelectHost.SelectedIndex)
                End If
            Else
                If Me.lbselect.SelectedItems.Count > 0 Then
                    splitter = Microsoft.VisualBasic.Split(Me.lbselect.SelectedItem, " | ")
                    Insertitem(Me.lbSortfields, splitter(0))
                    Me.lbselect.Items.RemoveAt(Me.lbselect.SelectedIndex)
                End If
                If checkchanges Then changes = True
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.lbsortfields_DoubleClick Method

Private Sub lbsortfields_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles LBSort.DoubleClick, _
   lbSortfields.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lbsortfields_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles LBSort.DoubleClick, lbSortfields.DoubleClick
        Button15_Click_1(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.mcb_Changed Method

Private Sub mcb_Changed( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbunterschriftlinks.SelectedValueChanged, _
   mcbunterschriftrechts.SelectedValueChanged, _
   mcbTeam.SelectedValueChanged, _
   cb5.CheckedChanged, _
   cb4.CheckedChanged, _
   cb2.CheckedChanged, _
   cb1.CheckedChanged, _
   cb3.CheckedChanged, _
   cb3_1.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcb_Changed(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbunterschriftlinks.SelectedValueChanged, mcbunterschriftrechts.SelectedValueChanged, mcbTeam.SelectedValueChanged, cb5.CheckedChanged, cb4.CheckedChanged, cb2.CheckedChanged, cb1.CheckedChanged, cb3.CheckedChanged, cb3_1.CheckedChanged
        If checkchanges Then
            changes = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.nodeswithdata Method

Private Function nodeswithdata( _
   ByVal node As Integer _
) As Boolean

Parameters

node
Required.

Source code

[Visual Basic]
    Private Function nodeswithdata(ByVal node As Integer) As Boolean
        If node <> 70 And node <> 90 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 6 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 70 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 15 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 90 Then
            DivFnkt.Searchnode1(Me.TreeView1, node, 99)
            If DivFnkt.FoundNode.GetNodeCount(True) < 4 Then DivFnkt.FoundNode.Collapse()
        End If
        If node = 72 Then
            If expandzv Then
                DivFnkt.Searchnode1(Me.TreeView1, 70, 99)
                If DivFnkt.found = True Then DivFnkt.FoundNode.ExpandAll()
            End If
        End If
        If node = 92 Then
            If expanduvm Then
                DivFnkt.Searchnode1(Me.TreeView1, 90, 99)
                If DivFnkt.found = True Then DivFnkt.FoundNode.ExpandAll()
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.plausi_edoka Method

Public Function plausi_edoka( _
   ByVal p As edokadb.clsProfil _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_edoka(ByVal p As edokadb.clsProfil) As Boolean
        Dim ma As String
        Dim te As String
        Dim mb As String
        Dim nl As String
        Dim ko As String

        Dim d1 As Date
        Dim d2 As Date
        Dim d3 As Date
        Dim t1 As Integer
        Dim t2 As Integer
        Dim t3 As Integer

        If p.sDpartner.Value <> "" Then Return True
        ma = p.sVma.Value + p.sMma.Value + p.sEma.Value
        te = p.sVteam.Value + p.sMteam.Value + p.sEteam.Value
        mb = p.sMmb.Value + p.sVmb.Value + p.sEmb.Value
        nl = p.sVnl.Value + p.sMnl.Value + p.sEnl.Value
        ko = p.sVkost.Value + p.sMkost.Value + p.sEkost.Value

        If p.sDatum1.Value = "(heute)" Then d1 = Now Else d1 = p.sDatum1.Value
        If p.sDatum3.Value = "(heute)" Then d2 = Now Else d2 = p.sDatum3.Value
        If p.sDatum5.Value = "(heute)" Then d3 = Now Else d3 = p.sDatum5.Value

        If ma <> "" And te = "" And mb = "" And nl = "" Then
            If t1 <= 365 And t2 <= 365 And t3 <> 365 Then
                Return True
            Else
                MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If te <> "" Or ko <> "" Then
            If t1 <= 90 And t2 <= 90 And t3 <= 90 Then
                Return True
            Else
                MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
                Return False
            End If
        End If

        If nl <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If mb <> "" Then
            If t1 <= 7 And t2 <= 7 And t3 <= 7 Then
                Return True
            Else
                MyMsg.show_standardmessage(94, MsgBoxStyle.Critical)
            End If
        End If

        If p.sDdokart.Value <> "" Then
            If t1 <= 30 And t2 <= 30 And t3 <= 30 Then
                Return True
            Else
                MyMsg.show_standardmessage(96, MsgBoxStyle.Critical)
            End If
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.plausi_host Method

Public Function plausi_host( _
   ByVal p As edokadb.clsProfil _
) As Boolean

Parameters

p
Required.

Source code

[Visual Basic]
    Public Function plausi_host(ByVal p As edokadb.clsProfil) As Boolean
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.reset_color Method

Private Sub reset_color( _
   ByVal node As Integer _
)

Parameters

node
Required.

Source code

[Visual Basic]
    Private Sub reset_color(ByVal node As Integer)
        Dim tn As TreeNode
        DivFnkt.Searchnode1(Me.TreeView1, node, 99)
        If DivFnkt.found Then
            Me.TreeView1.SelectedNode = DivFnkt.FoundNode
            Try
                tn = Me.TreeView1.SelectedNode
                tn.ForeColor = System.Drawing.Color.Black
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.reset_dokart Method

Private Sub reset_dokart()

Source code

[Visual Basic]
    Private Sub reset_dokart()
        Dim tmptreeview As TreeView
        tmptreeview = Me.TVDokart
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
        tmptreeview = Me.TVHostDok
        DivFnkt.Searchnode2(tmptreeview, 0, 0)
        While DivFnkt.found
            DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
            DivFnkt.FoundNode.ImageIndex = 0
            DivFnkt.Searchnode2(tmptreeview, 0, 0)
        End While
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.set_tips Method

Private Sub set_tips()

Source code

[Visual Basic]
    Private Sub set_tips()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.test Method

Public Function test() As TreeView

Source code

[Visual Basic]
    Public Function test() As TreeView
        Me.Cursor = Cursors.WaitCursor
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        On_Load = True
        Me.Profile.BeginUpdate()
        checkchanges = False
        changes = False
        Me.Profile.Nodes.Clear()
        Me.DataSet1.Clear()
        'Personendaten
        Dim tn, tn1 As TreeNode
        If first Then
            init_treeview1()
            tmb = Generic_Select(3)
            tnl = Generic_Select(4)
            tko = Generic_Select(5)
            tte = Generic_Select(6)
            tst = Generic_Select(2)
            tpe = Generic_Select(1)
            tdt = Generic_Select(7)
            tdh = Generic_Select(8)
            tku = Generic_Select(9)

            mcbTeam = New MultiComboBox(Me.cbteam)
            Me.mcbTeam.DisplayColumnName = "Bezeichnung"
            Me.mcbTeam.ValueColumnName = "teamnr"
            Me.mcbTeam.Fill_Data(tte, True)
            Me.mcbTeam.Visible = True
            Me.mcbTeam.CheckNullValue = False

            mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
            Me.mcbunterschriftlinks.CheckNullValue = False
            Me.mcbunterschriftlinks.DisplayColumnName = "name"
            Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftlinks.Fill_Data(tpe, True)
            Me.mcbunterschriftlinks.Visible = True

            mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
            Me.mcbunterschriftrechts.CheckNullValue = False
            Me.mcbunterschriftrechts.DisplayColumnName = "name"
            Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
            Me.mcbunterschriftrechts.Fill_Data(tpe, True)
            Me.mcbunterschriftrechts.Visible = True
        End If

        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        tda = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        hdata.Dispose()

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
            tn = Me.Profile.Nodes.Add(Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung"))
            tn.Tag = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
            If Me.DataSet1.Tables(0).Rows(i).Item("standard") Then
                tn.BackColor = System.Drawing.Color.LightBlue
                If Me.ProfilNr = 0 Then Me.ProfilNr = tn.Tag
            Else
                tn.BackColor = System.Drawing.Color.White
            End If
        Next
        first = False
        Load_Profil(Me.ProfilNr)
        checkchanges = False
        tn = Me.Profile.Nodes(0)
        Do Until tn Is Nothing
            If tn.Tag = Me.ProfilNr Then Me.Profile.SelectedNode = tn
            tn = tn.NextNode
        Loop
        On_Load = False
        first = False
        Me.TreeView1.ExpandAll()
        Profil_Colors()
        Me.LBSort.SelectedIndex = 0
        Me.lbSortfields.SelectedIndex = 0
        checkchanges = True
        Me.Profile.EndUpdate()
        Profname = ""
        Activate_Details()
        Me.Cursor = Cursors.Default
        nodeswithdata(1)
        nodeswithdata(2)
        nodeswithdata(3)
        nodeswithdata(70)
        nodeswithdata(90)
        nodeswithdata(72)
        nodeswithdata(92)
        set_tips()
        Return Me.TreeView1
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo.txtdatum1_TextChanged Method

Private Sub txtdatum1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles txtdatum1.TextChanged, _
   txtdatum2.TextChanged, _
   txtdatum3.TextChanged, _
   txtdatum4.TextChanged, _
   txtdatum5.TextChanged, _
   txtdatum6.TextChanged, _
   HostDatum1.TextChanged, _
   HostDatum2.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtdatum1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtdatum1.TextChanged, txtdatum2.TextChanged, txtdatum3.TextChanged, txtdatum4.TextChanged, txtdatum5.TextChanged, txtdatum6.TextChanged, HostDatum1.TextChanged, HostDatum2.TextChanged
        Dim tb As TextBox
        Dim xt As DateTime
        Dim i As Integer
        tb = sender

        'Select Case tb.Name
        '    Case "txtdatum1"
        '        tb1 = Me.txtdatum1
        '        tp = Me.DateTimePicker1
        '        cb = Me.cbrollend1
        '        tl = Me.datumtext1
        '    Case "txtdatum2"
        '        tb1 = Me.txtdatum2
        '        tp = Me.DateTimePicker2
        '        cb = Me.cbrollend2
        '        tl = Me.datumtext2
        '    Case "txtdatum3"
        '        tb1 = Me.txtdatum3
        '        tp = Me.DateTimePicker3
        '        cb = Me.cbrollend3
        '        tl = Me.datumtext3
        '    Case "txtdatum4"
        '        tb1 = Me.txtdatum4
        '        tp = Me.DateTimePicker4
        '        cb = Me.cbrollend4
        '        tl = Me.datumtext4
        '    Case "txtdatum5"
        '        tb1 = Me.txtdatum5
        '        tp = Me.DateTimePicker5
        '        cb = Me.cbrollend5
        '        tl = Me.datumtext5
        '    Case "txtdatum6"
        '        tb1 = Me.txtdatum6
        '        tp = Me.DateTimePicker6
        '        cb = Me.cbrollend6
        '        tl = Me.datumtext6
        'End Select
        'If tb1.Text = "" Then

        '    tl.Text = "(heute)-99999"
        '    cb.Checked = False
        '    cb.Enabled = False
        'Else
        '    If tp.Value > Now Then
        '        tl.Text = CutDate(Now.ToString)
        '        Exit Sub
        '    End If
        '    cb.Enabled = True
        '    If cb.Checked Then
        '        tl.Text = "(heute)-" + Trim(Str(DateDiff(DateInterval.Day, CType(tb1.Text, DateTime), Now)))
        '    Else
        '        tl.Text = tb1.Text
        '    End If
        'End If

        Select Case tb.Name
            Case "txtdatum1"
                If Me.txtdatum1.Text = "" Then
                    Me.datumtext1.Text = "(heute)-999999"
                    Me.cbrollend1.Checked = False
                    Me.cbrollend1.Enabled = False
                Else
                    If Format(Me.DateTimePicker1.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum1.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend1.Enabled = True
                    If Me.cbrollend1.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum1.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext1.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext1.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext1.Text = Me.txtdatum1.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext1.Text, "heute") > 0 Then Me.cbrollend1.Checked = True
                End If
            Case "txtdatum2"
                If Me.txtdatum2.Text = "" Then
                    Me.datumtext2.Text = "(heute)"
                    Me.cbrollend2.Checked = True
                    Me.cbrollend2.Enabled = False
                    '    Me.txtdatum2.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker2.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum2.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend2.Enabled = True
                    If Me.cbrollend2.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum2.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext2.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext2.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext2.Text = Me.txtdatum2.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext2.Text, "heute") > 0 Then Me.cbrollend2.Checked = True
                End If
            Case "txtdatum3"
                If Me.txtdatum3.Text = "" Then
                    Me.datumtext3.Text = "(heute)-999999"
                    Me.cbrollend3.Checked = False
                    Me.cbrollend3.Enabled = False
                Else
                    If Format(Me.DateTimePicker3.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum3.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend3.Enabled = True
                    If Me.cbrollend3.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum3.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext3.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext3.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext3.Text = Me.txtdatum3.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext3.Text, "heute") > 0 Then Me.cbrollend3.Checked = True
                End If
            Case "txtdatum4"
                If Me.txtdatum4.Text = "" Then
                    Me.datumtext4.Text = "(heute)"
                    Me.cbrollend4.Checked = True
                    Me.cbrollend4.Enabled = False
                    '   Me.txtdatum4.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker4.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum4.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend4.Enabled = True
                    If Me.cbrollend4.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum4.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext4.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext4.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext4.Text = Me.txtdatum4.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext4.Text, "heute") > 0 Then Me.cbrollend4.Checked = True
                End If
            Case "txtdatum5"
                If Me.txtdatum5.Text = "" Then
                    Me.datumtext5.Text = "(heute)-999999"
                    Me.cbrollend5.Checked = False
                    Me.cbrollend5.Enabled = False
                Else
                    If Format(Me.DateTimePicker5.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum5.Text = CutDate(Now.ToString)
                    End If

                    Me.cbrollend5.Enabled = True
                    If Me.cbrollend5.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum5.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext5.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext5.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext5.Text = Me.txtdatum5.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext5.Text, "heute") > 0 Then Me.cbrollend5.Checked = True
                End If
            Case "txtdatum6"
                If Me.txtdatum6.Text = "" Then
                    Me.datumtext6.Text = "(heute)"
                    Me.cbrollend6.Checked = True
                    Me.cbrollend6.Enabled = False
                    '  Me.txtdatum6.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker6.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.txtdatum6.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend6.Enabled = True
                    If Me.cbrollend6.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.txtdatum6.Text, DateTime))
                        If i = 0 Then
                            Me.datumtext6.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.datumtext6.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.datumtext6.Text = Me.txtdatum6.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.datumtext6.Text, "heute") > 0 Then Me.cbrollend6.Checked = True
                End If

            Case "HostDatum1"
                If Me.HostDatum1.Text = "" Then
                    Me.DatumHostText1.Text = "(heute)-999999"
                    Me.cbrollend8.Checked = False
                    Me.cbrollend8.Enabled = False
                Else
                    If Format(Me.DateTimePicker9.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.HostDatum1.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend8.Enabled = True
                    If Me.cbrollend8.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.HostDatum1.Text, DateTime))
                        If i = 0 Then
                            Me.DatumHostText1.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.DatumHostText1.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.DatumHostText1.Text = Me.HostDatum1.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.DatumHostText1.Text, "heute") > 0 Then Me.cbrollend8.Checked = True
                End If
            Case "HostDatum2"
                If Me.HostDatum2.Text = "" Then
                    Me.DatumHostText2.Text = "(heute)"
                    Me.cbrollend9.Checked = True
                    Me.cbrollend9.Enabled = False
                    ' Me.txtdatum6.Text = CutDate(Now.ToString)
                Else
                    If Format(Me.DateTimePicker8.Value, "yyyyMMdd") > Format(Now, "yyyyMMdd") Then
                        Me.HostDatum2.Text = CutDate(Now.ToString)
                    End If
                    Me.cbrollend9.Enabled = True
                    If Me.cbrollend9.Checked Then
                        i = DateDiff(DateInterval.Day, Now, CType(Me.HostDatum2.Text, DateTime))
                        If i = 0 Then
                            Me.DatumHostText2.Text = "(heute)-0"
                        Else
                            If i < 0 Then i = i * -1
                            Me.DatumHostText2.Text = "(heute)-" + Trim(Str(i))
                        End If
                    Else
                        Me.DatumHostText2.Text = Me.HostDatum2.Text
                    End If
                    If Microsoft.VisualBasic.InStr(Me.DatumHostText2.Text, "heute") > 0 Then Me.cbrollend9.Checked = True
                End If

        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProfilinfo Fields

frmProfilinfo overview

Fields

field ActiveList
field Button1
field Button10
field Button11
field Button12
field Button13
field Button14
field Button15
field Button16
field Button17
field Button18
field Button19
field Button2
field Button20
field Button21
field Button22
field Button23
field Button24
field Button25
field Button26
field Button27
field Button28
field Button29
field Button3
field Button30
field Button31
field Button32
field Button33
field Button34
field Button35
field Button36
field Button37
field Button38
field Button39
field Button4
field Button40
field Button41
field Button42
field Button43
field Button44
field Button45
field Button46
field Button47
field Button48
field Button49
field Button5
field Button50
field Button51
field Button6
field Button7
field Button8
field Button9
field C1TrueDBGrid1
field C1TrueDBGrid2
field C1TrueDBGrid3
field C1TrueDBGrid4
field CTMenuErsteller
field CTMenuMutierer
field CTMenuVerantwortlicher
field CheckBox1
field CheckBox10
field CheckBox11
field CheckBox12
field CheckBox13
field CheckBox14
field CheckBox15
field CheckBox16
field CheckBox17
field CheckBox18
field CheckBox19
field CheckBox2
field CheckBox20
field CheckBox21
field CheckBox3
field CheckBox4
field CheckBox5
field CheckBox6
field CheckBox7
field CheckBox8
field CheckBox9
field ColorDialog1
field ComboBox1
field ComboBox10
field ComboBox2
field ComboBox3
field ComboBox4
field ComboBox5
field ComboBox6
field ComboBox7
field ComboBox9
field ContextMenu1
field ContextMenu2
field DataSet1
field DateTimePicker1
field DateTimePicker10
field DateTimePicker11
field DateTimePicker12
field DateTimePicker13
field DateTimePicker14
field DateTimePicker15
field DateTimePicker16
field DateTimePicker17
field DateTimePicker18
field DateTimePicker19
field DateTimePicker2
field DateTimePicker20
field DateTimePicker21
field DateTimePicker22
field DateTimePicker23
field DateTimePicker24
field DateTimePicker25
field DateTimePicker26
field DateTimePicker27
field DateTimePicker28
field DateTimePicker29
field DateTimePicker3
field DateTimePicker30
field DateTimePicker31
field DateTimePicker32
field DateTimePicker33
field DateTimePicker34
field DateTimePicker35
field DateTimePicker36
field DateTimePicker37
field DateTimePicker38
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DateTimePicker7
field DateTimePicker8
field DateTimePicker9
field DatumHostText1
field DatumHostText2
field FirstNodeWithData
field GroupBox1
field GroupBox10
field GroupBox11
field GroupBox12
field GroupBox13
field GroupBox14
field GroupBox15
field GroupBox16
field GroupBox17
field GroupBox18
field GroupBox19
field GroupBox2
field GroupBox20
field GroupBox21
field GroupBox22
field GroupBox23
field GroupBox24
field GroupBox25
field GroupBox26
field GroupBox27
field GroupBox28
field GroupBox29
field GroupBox3
field GroupBox30
field GroupBox31
field GroupBox32
field GroupBox33
field GroupBox34
field GroupBox35
field GroupBox36
field GroupBox37
field GroupBox38
field GroupBox39
field GroupBox4
field GroupBox40
field GroupBox41
field GroupBox5
field GroupBox6
field GroupBox7
field GroupBox8
field GroupBox9
field HostDatum1
field HostDatum2
field HostDatum3
field HostTag3
field ImageList1
field ImageList2
field ImageList3
field LBSelectHost
field LBSort
field Label1
field Label10
field Label100
field Label101
field Label102
field Label103
field Label104
field Label105
field Label106
field Label107
field Label108
field Label109
field Label11
field Label110
field Label12
field Label13
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label21
field Label22
field Label23
field Label24
field Label25
field Label26
field Label27
field Label28
field Label29
field Label3
field Label30
field Label31
field Label32
field Label33
field Label34
field Label35
field Label36
field Label37
field Label38
field Label39
field Label4
field Label40
field Label41
field Label42
field Label43
field Label44
field Label45
field Label46
field Label47
field Label48
field Label49
field Label5
field Label50
field Label51
field Label52
field Label53
field Label54
field Label55
field Label56
field Label57
field Label58
field Label59
field Label6
field Label60
field Label61
field Label62
field Label63
field Label64
field Label65
field Label66
field Label67
field Label68
field Label69
field Label7
field Label70
field Label71
field Label72
field Label73
field Label74
field Label75
field Label76
field Label77
field Label78
field Label79
field Label8
field Label80
field Label81
field Label82
field Label83
field Label84
field Label85
field Label86
field Label87
field Label88
field Label89
field Label9
field Label90
field Label91
field Label92
field Label93
field Label94
field Label95
field Label96
field Label97
field Label98
field Label99
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MnuDel
field MnuDeleteDokumentart
field MnuListe
field MnuSelectDokumentart
field NodeText
field On_Load
field Panel1
field Panel10
field Panel2
field Panel3
field Panel4
field Panel5
field Panel6
field Panel7
field Panel8
field Panel9
field PartnerList
field PnlDokumentDaten
field PnlDokumentart
field PnlPartner
field Profil_Ungueltig
field Profile
field Profname
field Splitter1
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVDokart
field TVHostDok
field TabControl1
field TabPage1
field TabPage4
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox19
field TextBox2
field TextBox20
field TextBox21
field TextBox22
field TextBox23
field TextBox24
field TextBox25
field TextBox26
field TextBox27
field TextBox28
field TextBox29
field TextBox3
field TextBox30
field TextBox31
field TextBox32
field TextBox33
field TextBox34
field TextBox35
field TextBox36
field TextBox37
field TextBox38
field TextBox39
field TextBox4
field TextBox40
field TextBox41
field TextBox42
field TextBox43
field TextBox44
field TextBox45
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field TreeView1
field TreeView2
field TreeView3
field TreeView4
field btnClose
field btnOpen
field btnPartnersuche
field btnSave
field btnini
field cb1
field cb2
field cb3
field cb3_1
field cb4
field cb5
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbd2
field cbd4
field cbd6
field cbrollend1
field cbrollend2
field cbrollend3
field cbrollend4
field cbrollend5
field cbrollend6
field cbrollend8
field cbrollend9
field cbteam
field cbuvmrollend1
field cbuvmrollend2
field cbuvmrollend3
field cbuvmrollend4
field cbzvrollend1
field cbzvrollend2
field cbzvrollend3
field cbzvrollend4
field changes
field checkchanges
field cinklalt
field colbtn1
field colbtn2
field colbtn3
field colbtn4
field colbtn5
field colbtn6
field colconv
field components
field ctmenu1
field datumtext1
field datumtext2
field datumtext3
field datumtext4
field datumtext5
field datumtext6
field dokumentart
field expanduvm
field expandzv
field first
field hostinklmavip
field i
field lbSortfields
field lbentry
field lblhostdatum2
field lblhostdatum3
field lblhostdatum31
field lbselect
field li
field m_profile_geaendert
field m_profilnr
field mcbTeam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mypartner
field oninit
field partner
field pnlhostdiv
field savenode
field selectPoint
field tda
field tdh
field tdt
field tdtuvm
field tdtzv
field textdatum1uvm
field textdatum1zv
field textdatum2uvm
field textdatum2zv
field textdatum3uvm
field textdatum3zv
field textdatum4uvm
field textdatum4zv
field tko
field tku
field tmb
field tnl
field tpe
field tst
field tte
field txtdatum1
field txtdatum1uvm
field txtdatum1zv
field txtdatum2
field txtdatum2uvm
field txtdatum2zv
field txtdatum3
field txtdatum3uvm
field txtdatum3zv
field txtdatum4
field txtdatum4uvm
field txtdatum4zv
field txtdatum5
field txtdatum6

See Also

frmProfilinfo Class


ActiveList Variable

Dim ActiveList As Integer

Source code

[Visual Basic]
    Dim ActiveList As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button10 Variable

Friend WithEvents Button10 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button10 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button11 Variable

Friend WithEvents Button11 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button11 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button12 Variable

Friend WithEvents Button12 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button12 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button13 Variable

Friend WithEvents Button13 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button13 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button14 Variable

Friend WithEvents Button14 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button14 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button15 Variable

Friend WithEvents Button15 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button15 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button16 Variable

Friend WithEvents Button16 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button16 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button17 Variable

Friend WithEvents Button17 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button17 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button18 Variable

Friend WithEvents Button18 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button18 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button19 Variable

Friend WithEvents Button19 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button19 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button20 Variable

Friend WithEvents Button20 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button20 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button21 Variable

Friend WithEvents Button21 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button21 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button22 Variable

Friend WithEvents Button22 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button22 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button23 Variable

Friend WithEvents Button23 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button23 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button24 Variable

Friend WithEvents Button24 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button24 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button25 Variable

Friend WithEvents Button25 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button25 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button26 Variable

Friend WithEvents Button26 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button26 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button27 Variable

Friend WithEvents Button27 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button27 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button28 Variable

Friend WithEvents Button28 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button28 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button29 Variable

Friend WithEvents Button29 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button29 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button30 Variable

Friend WithEvents Button30 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button30 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button31 Variable

Friend WithEvents Button31 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button31 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button32 Variable

Friend WithEvents Button32 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button32 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button33 Variable

Friend WithEvents Button33 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button33 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button34 Variable

Friend WithEvents Button34 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button34 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button35 Variable

Friend WithEvents Button35 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button35 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button36 Variable

Friend WithEvents Button36 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button36 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button37 Variable

Friend WithEvents Button37 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button37 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button38 Variable

Friend WithEvents Button38 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button38 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button39 Variable

Friend WithEvents Button39 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button39 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button40 Variable

Friend WithEvents Button40 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button40 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button41 Variable

Friend WithEvents Button41 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button41 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button42 Variable

Friend WithEvents Button42 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button42 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button43 Variable

Friend WithEvents Button43 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button43 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button44 Variable

Friend WithEvents Button44 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button44 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button45 Variable

Friend WithEvents Button45 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button45 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button46 Variable

Friend WithEvents Button46 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button46 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button47 Variable

Friend WithEvents Button47 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button47 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button48 Variable

Friend WithEvents Button48 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button48 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button49 Variable

Friend WithEvents Button49 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button49 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button50 Variable

Friend WithEvents Button50 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button50 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button51 Variable

Friend WithEvents Button51 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button51 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Button9 Variable

Friend WithEvents Button9 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button9 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


C1TrueDBGrid2 Variable

Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


C1TrueDBGrid3 Variable

Friend WithEvents C1TrueDBGrid3 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid3 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


C1TrueDBGrid4 Variable

Friend WithEvents C1TrueDBGrid4 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid4 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CTMenuErsteller Variable

Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuErsteller As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CTMenuMutierer Variable

Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuMutierer As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CTMenuVerantwortlicher Variable

Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents CTMenuVerantwortlicher As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox10 Variable

Friend WithEvents CheckBox10 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox10 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox11 Variable

Friend WithEvents CheckBox11 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox11 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox12 Variable

Friend WithEvents CheckBox12 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox12 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox13 Variable

Friend WithEvents CheckBox13 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox13 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox14 Variable

Friend WithEvents CheckBox14 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox14 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox15 Variable

Friend WithEvents CheckBox15 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox15 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox16 Variable

Friend WithEvents CheckBox16 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox16 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox17 Variable

Friend WithEvents CheckBox17 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox17 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox18 Variable

Friend WithEvents CheckBox18 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox18 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox19 Variable

Friend WithEvents CheckBox19 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox19 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox2 Variable

Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox20 Variable

Friend WithEvents CheckBox20 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox20 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox21 Variable

Friend WithEvents CheckBox21 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox21 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox3 Variable

Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox4 Variable

Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox5 Variable

Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox6 Variable

Friend WithEvents CheckBox6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox7 Variable

Friend WithEvents CheckBox7 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox7 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox8 Variable

Friend WithEvents CheckBox8 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox8 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


CheckBox9 Variable

Friend WithEvents CheckBox9 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox9 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ColorDialog1 Variable

Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Source code

[Visual Basic]
    Friend WithEvents ColorDialog1 As System.Windows.Forms.ColorDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox10 Variable

Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox10 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox2 Variable

Friend WithEvents ComboBox2 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox2 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox3 Variable

Friend WithEvents ComboBox3 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox3 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox4 Variable

Friend WithEvents ComboBox4 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox4 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox5 Variable

Friend WithEvents ComboBox5 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox5 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox6 Variable

Friend WithEvents ComboBox6 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox6 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox7 Variable

Friend WithEvents ComboBox7 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox7 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ComboBox9 Variable

Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox9 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker10 Variable

Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker10 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker11 Variable

Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker11 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker12 Variable

Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker12 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker13 Variable

Friend WithEvents DateTimePicker13 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker13 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker14 Variable

Friend WithEvents DateTimePicker14 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker14 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker15 Variable

Friend WithEvents DateTimePicker15 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker15 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker16 Variable

Friend WithEvents DateTimePicker16 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker16 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker17 Variable

Friend WithEvents DateTimePicker17 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker17 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker18 Variable

Friend WithEvents DateTimePicker18 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker18 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker19 Variable

Friend WithEvents DateTimePicker19 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker19 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker20 Variable

Friend WithEvents DateTimePicker20 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker20 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker21 Variable

Friend WithEvents DateTimePicker21 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker21 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker22 Variable

Friend WithEvents DateTimePicker22 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker22 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker23 Variable

Friend WithEvents DateTimePicker23 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker23 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker24 Variable

Friend WithEvents DateTimePicker24 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker24 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker25 Variable

Friend WithEvents DateTimePicker25 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker25 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker26 Variable

Friend WithEvents DateTimePicker26 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker26 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker27 Variable

Friend WithEvents DateTimePicker27 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker27 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker28 Variable

Friend WithEvents DateTimePicker28 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker28 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker29 Variable

Friend WithEvents DateTimePicker29 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker29 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker30 Variable

Friend WithEvents DateTimePicker30 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker30 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker31 Variable

Friend WithEvents DateTimePicker31 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker31 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker32 Variable

Friend WithEvents DateTimePicker32 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker32 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker33 Variable

Friend WithEvents DateTimePicker33 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker33 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker34 Variable

Friend WithEvents DateTimePicker34 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker34 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker35 Variable

Friend WithEvents DateTimePicker35 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker35 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker36 Variable

Friend WithEvents DateTimePicker36 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker36 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker37 Variable

Friend WithEvents DateTimePicker37 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker37 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker38 Variable

Friend WithEvents DateTimePicker38 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker38 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker5 Variable

Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker6 Variable

Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker7 Variable

Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker7 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker8 Variable

Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker8 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DateTimePicker9 Variable

Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker9 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DatumHostText1 Variable

Friend WithEvents DatumHostText1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents DatumHostText1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


DatumHostText2 Variable

Friend WithEvents DatumHostText2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents DatumHostText2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


FirstNodeWithData Variable

Dim FirstNodeWithData As TreeNode

Source code

[Visual Basic]
    Dim FirstNodeWithData As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox10 Variable

Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox10 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox11 Variable

Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox11 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox13 Variable

Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox13 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox14 Variable

Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox14 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox15 Variable

Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox15 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox16 Variable

Friend WithEvents GroupBox16 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox16 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox17 Variable

Friend WithEvents GroupBox17 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox17 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox18 Variable

Friend WithEvents GroupBox18 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox18 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox19 Variable

Friend WithEvents GroupBox19 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox19 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox20 Variable

Friend WithEvents GroupBox20 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox20 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox21 Variable

Friend WithEvents GroupBox21 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox21 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox22 Variable

Friend WithEvents GroupBox22 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox22 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox23 Variable

Friend WithEvents GroupBox23 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox23 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox24 Variable

Friend WithEvents GroupBox24 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox24 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox25 Variable

Friend WithEvents GroupBox25 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox25 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox26 Variable

Friend WithEvents GroupBox26 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox26 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox27 Variable

Friend WithEvents GroupBox27 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox27 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox28 Variable

Friend WithEvents GroupBox28 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox28 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox29 Variable

Friend WithEvents GroupBox29 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox29 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox30 Variable

Friend WithEvents GroupBox30 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox30 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox31 Variable

Friend WithEvents GroupBox31 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox31 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox32 Variable

Friend WithEvents GroupBox32 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox32 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox33 Variable

Friend WithEvents GroupBox33 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox33 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox34 Variable

Friend WithEvents GroupBox34 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox34 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox35 Variable

Friend WithEvents GroupBox35 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox35 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox36 Variable

Friend WithEvents GroupBox36 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox36 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox37 Variable

Friend WithEvents GroupBox37 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox37 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox38 Variable

Friend WithEvents GroupBox38 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox38 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox39 Variable

Friend WithEvents GroupBox39 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox39 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox40 Variable

Friend WithEvents GroupBox40 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox40 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox41 Variable

Friend WithEvents GroupBox41 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox41 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox6 Variable

Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox6 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox7 Variable

Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox7 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


GroupBox9 Variable

Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox9 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


HostDatum1 Variable

Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


HostDatum2 Variable

Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


HostDatum3 Variable

Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents HostDatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


HostTag3 Variable

Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents HostTag3 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


LBSelectHost Variable

Friend WithEvents LBSelectHost As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSelectHost As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


LBSort Variable

Friend WithEvents LBSort As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSort As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label100 Variable

Friend WithEvents Label100 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label100 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label101 Variable

Friend WithEvents Label101 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label101 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label102 Variable

Friend WithEvents Label102 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label102 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label103 Variable

Friend WithEvents Label103 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label103 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label104 Variable

Friend WithEvents Label104 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label104 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label105 Variable

Friend WithEvents Label105 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label105 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label106 Variable

Friend WithEvents Label106 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label106 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label107 Variable

Friend WithEvents Label107 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label107 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label108 Variable

Friend WithEvents Label108 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label108 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label109 Variable

Friend WithEvents Label109 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label109 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label110 Variable

Friend WithEvents Label110 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label110 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label23 Variable

Friend WithEvents Label23 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label23 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label24 Variable

Friend WithEvents Label24 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label24 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label25 Variable

Friend WithEvents Label25 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label25 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label26 Variable

Friend WithEvents Label26 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label26 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label27 Variable

Friend WithEvents Label27 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label27 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label28 Variable

Friend WithEvents Label28 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label28 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label29 Variable

Friend WithEvents Label29 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label29 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label30 Variable

Friend WithEvents Label30 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label30 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label31 Variable

Friend WithEvents Label31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label32 Variable

Friend WithEvents Label32 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label32 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label33 Variable

Friend WithEvents Label33 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label33 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label34 Variable

Friend WithEvents Label34 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label34 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label35 Variable

Friend WithEvents Label35 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label35 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label36 Variable

Friend WithEvents Label36 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label36 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label37 Variable

Friend WithEvents Label37 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label37 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label38 Variable

Friend WithEvents Label38 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label38 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label39 Variable

Friend WithEvents Label39 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label39 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label40 Variable

Friend WithEvents Label40 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label40 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label41 Variable

Friend WithEvents Label41 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label41 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label42 Variable

Friend WithEvents Label42 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label42 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label43 Variable

Friend WithEvents Label43 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label43 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label44 Variable

Friend WithEvents Label44 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label44 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label45 Variable

Friend WithEvents Label45 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label45 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label46 Variable

Friend WithEvents Label46 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label46 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label47 Variable

Friend WithEvents Label47 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label47 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label48 Variable

Friend WithEvents Label48 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label48 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label49 Variable

Friend WithEvents Label49 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label49 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label50 Variable

Friend WithEvents Label50 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label50 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label51 Variable

Friend WithEvents Label51 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label51 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label52 Variable

Friend WithEvents Label52 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label52 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label53 Variable

Friend WithEvents Label53 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label53 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label54 Variable

Friend WithEvents Label54 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label54 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label55 Variable

Friend WithEvents Label55 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label55 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label56 Variable

Friend WithEvents Label56 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label56 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label57 Variable

Friend WithEvents Label57 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label57 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label58 Variable

Friend WithEvents Label58 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label58 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label59 Variable

Friend WithEvents Label59 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label59 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label60 Variable

Friend WithEvents Label60 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label60 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label61 Variable

Friend WithEvents Label61 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label61 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label62 Variable

Friend WithEvents Label62 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label62 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label63 Variable

Friend WithEvents Label63 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label63 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label64 Variable

Friend WithEvents Label64 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label64 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label65 Variable

Friend WithEvents Label65 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label65 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label66 Variable

Friend WithEvents Label66 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label66 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label67 Variable

Friend WithEvents Label67 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label67 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label68 Variable

Friend WithEvents Label68 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label68 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label69 Variable

Friend WithEvents Label69 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label69 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label70 Variable

Friend WithEvents Label70 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label70 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label71 Variable

Friend WithEvents Label71 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label71 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label72 Variable

Friend WithEvents Label72 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label72 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label73 Variable

Friend WithEvents Label73 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label73 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label74 Variable

Friend WithEvents Label74 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label74 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label75 Variable

Friend WithEvents Label75 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label75 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label76 Variable

Friend WithEvents Label76 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label76 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label77 Variable

Friend WithEvents Label77 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label77 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label78 Variable

Friend WithEvents Label78 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label78 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label79 Variable

Friend WithEvents Label79 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label79 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label80 Variable

Friend WithEvents Label80 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label80 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label81 Variable

Friend WithEvents Label81 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label81 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label82 Variable

Friend WithEvents Label82 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label82 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label83 Variable

Friend WithEvents Label83 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label83 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label84 Variable

Friend WithEvents Label84 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label84 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label85 Variable

Friend WithEvents Label85 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label85 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label86 Variable

Friend WithEvents Label86 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label86 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label87 Variable

Friend WithEvents Label87 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label87 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label88 Variable

Friend WithEvents Label88 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label88 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label89 Variable

Friend WithEvents Label89 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label89 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label90 Variable

Friend WithEvents Label90 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label90 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label91 Variable

Friend WithEvents Label91 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label91 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label92 Variable

Friend WithEvents Label92 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label92 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label93 Variable

Friend WithEvents Label93 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label93 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label94 Variable

Friend WithEvents Label94 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label94 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label95 Variable

Friend WithEvents Label95 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label95 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label96 Variable

Friend WithEvents Label96 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label96 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label97 Variable

Friend WithEvents Label97 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label97 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label98 Variable

Friend WithEvents Label98 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label98 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Label99 Variable

Friend WithEvents Label99 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label99 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MnuDel Variable

Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MnuDeleteDokumentart Variable

Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MnuListe Variable

Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuListe As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


MnuSelectDokumentart Variable

Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSelectDokumentart As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


NodeText Variable

Dim NodeText As String

Source code

[Visual Basic]
    Dim NodeText As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel10 Variable

Friend WithEvents Panel10 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel10 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel5 Variable

Friend WithEvents Panel5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel6 Variable

Friend WithEvents Panel6 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel6 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel7 Variable

Friend WithEvents Panel7 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel7 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel8 Variable

Friend WithEvents Panel8 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel8 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Panel9 Variable

Friend WithEvents Panel9 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel9 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


PartnerList Variable

Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents PartnerList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


PnlDokumentDaten Variable

Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentDaten As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


PnlDokumentart Variable

Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlDokumentart As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


PnlPartner Variable

Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents PnlPartner As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Profil_Ungueltig Variable

Dim Profil_Ungueltig As Boolean

Source code

[Visual Basic]
    Dim Profil_Ungueltig As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Profile Variable

Friend WithEvents Profile As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents Profile As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Profname Variable

Dim Profname As String

Source code

[Visual Basic]
    Dim Profname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TVDokart Variable

Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVDokart As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TVHostDok Variable

Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVHostDok As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TabPage4 Variable

Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage4 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox11 Variable

Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox12 Variable

Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox13 Variable

Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox14 Variable

Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox15 Variable

Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox16 Variable

Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox17 Variable

Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox18 Variable

Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox19 Variable

Friend WithEvents TextBox19 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox19 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox20 Variable

Friend WithEvents TextBox20 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox20 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox21 Variable

Friend WithEvents TextBox21 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox21 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox22 Variable

Friend WithEvents TextBox22 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox22 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox23 Variable

Friend WithEvents TextBox23 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox23 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox24 Variable

Friend WithEvents TextBox24 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox24 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox25 Variable

Friend WithEvents TextBox25 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox25 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox26 Variable

Friend WithEvents TextBox26 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox26 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox27 Variable

Friend WithEvents TextBox27 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox27 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox28 Variable

Friend WithEvents TextBox28 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox28 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox29 Variable

Friend WithEvents TextBox29 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox29 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox30 Variable

Friend WithEvents TextBox30 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox30 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox31 Variable

Friend WithEvents TextBox31 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox31 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox32 Variable

Friend WithEvents TextBox32 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox32 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox33 Variable

Friend WithEvents TextBox33 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox33 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox34 Variable

Friend WithEvents TextBox34 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox34 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox35 Variable

Friend WithEvents TextBox35 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox35 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox36 Variable

Friend WithEvents TextBox36 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox36 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox37 Variable

Friend WithEvents TextBox37 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox37 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox38 Variable

Friend WithEvents TextBox38 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox38 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox39 Variable

Friend WithEvents TextBox39 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox39 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox40 Variable

Friend WithEvents TextBox40 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox40 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox41 Variable

Friend WithEvents TextBox41 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox41 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox42 Variable

Friend WithEvents TextBox42 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox42 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox43 Variable

Friend WithEvents TextBox43 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox43 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox44 Variable

Friend WithEvents TextBox44 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox44 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox45 Variable

Friend WithEvents TextBox45 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox45 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TreeView2 Variable

Friend WithEvents TreeView2 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView2 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TreeView3 Variable

Friend WithEvents TreeView3 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView3 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


TreeView4 Variable

Friend WithEvents TreeView4 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView4 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


btnClose Variable

Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


btnOpen Variable

Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnOpen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


btnPartnersuche Variable

Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


btnini Variable

Friend WithEvents btnini As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnini As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb1 Variable

Friend WithEvents cb1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb2 Variable

Friend WithEvents cb2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb3 Variable

Friend WithEvents cb3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb3_1 Variable

Friend WithEvents cb3_1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb3_1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb4 Variable

Friend WithEvents cb4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cb5 Variable

Friend WithEvents cb5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cb5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbd2 Variable

Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbd4 Variable

Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbd6 Variable

Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbd6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend1 Variable

Friend WithEvents cbrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend2 Variable

Friend WithEvents cbrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend3 Variable

Friend WithEvents cbrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend4 Variable

Friend WithEvents cbrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend5 Variable

Friend WithEvents cbrollend5 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend5 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend6 Variable

Friend WithEvents cbrollend6 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend6 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend8 Variable

Friend WithEvents cbrollend8 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend8 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbrollend9 Variable

Friend WithEvents cbrollend9 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbrollend9 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbuvmrollend1 Variable

Friend WithEvents cbuvmrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbuvmrollend2 Variable

Friend WithEvents cbuvmrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbuvmrollend3 Variable

Friend WithEvents cbuvmrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbuvmrollend4 Variable

Friend WithEvents cbuvmrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbuvmrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbzvrollend1 Variable

Friend WithEvents cbzvrollend1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbzvrollend2 Variable

Friend WithEvents cbzvrollend2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbzvrollend3 Variable

Friend WithEvents cbzvrollend3 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend3 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cbzvrollend4 Variable

Friend WithEvents cbzvrollend4 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbzvrollend4 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


changes Variable

Dim changes As Boolean

Source code

[Visual Basic]
    Dim changes As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


checkchanges Variable

Dim checkchanges As Boolean

Source code

[Visual Basic]
    Dim checkchanges As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


cinklalt Variable

Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cinklalt As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn1 Variable

Friend WithEvents colbtn1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn2 Variable

Friend WithEvents colbtn2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn3 Variable

Friend WithEvents colbtn3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn4 Variable

Friend WithEvents colbtn4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn5 Variable

Friend WithEvents colbtn5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colbtn6 Variable

Friend WithEvents colbtn6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents colbtn6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


colconv Variable

Dim colconv As New ColorConverter()

Source code

[Visual Basic]
    Dim colconv As New ColorConverter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


ctmenu1 Variable

Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ctmenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext1 Variable

Friend WithEvents datumtext1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext2 Variable

Friend WithEvents datumtext2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext3 Variable

Friend WithEvents datumtext3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext4 Variable

Friend WithEvents datumtext4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext5 Variable

Friend WithEvents datumtext5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


datumtext6 Variable

Friend WithEvents datumtext6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents datumtext6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


dokumentart Variable

Dim dokumentart As New edokadb.clsMyDokumentart()

Source code

[Visual Basic]
    Dim dokumentart As New edokadb.clsMyDokumentart()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


expanduvm Variable

Dim expanduvm As Boolean

Source code

[Visual Basic]
    Dim expanduvm As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


expandzv Variable

Dim expandzv As Boolean

Source code

[Visual Basic]
    Dim expandzv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


first Variable

Dim first As Boolean = True

Source code

[Visual Basic]
    Dim first As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


hostinklmavip Variable

Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents hostinklmavip As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lbSortfields Variable

Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lbentry Variable

Dim lbentry( _
   1 _
) As Object

Source code

[Visual Basic]
    Dim lbentry(1) As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lblhostdatum2 Variable

Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lblhostdatum3 Variable

Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lblhostdatum31 Variable

Friend WithEvents lblhostdatum31 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblhostdatum31 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


lbselect Variable

Friend WithEvents lbselect As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents lbselect As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


li Variable

Dim li As ListViewItem

Source code

[Visual Basic]
    Dim li As ListViewItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


m_profile_geaendert Variable

Dim m_profile_geaendert As Boolean

Source code

[Visual Basic]
    Dim m_profile_geaendert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


m_profilnr Variable

Dim m_profilnr As Integer

Source code

[Visual Basic]
    Dim m_profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


mcbTeam Variable

Dim WithEvents mcbTeam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbTeam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


mypartner Variable

Dim mypartner As New edokadb.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokadb.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


oninit Variable

Dim oninit As Boolean = False

Source code

[Visual Basic]
    Dim oninit As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


partner Variable

Dim partner As DataTable

Source code

[Visual Basic]
    Dim partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


pnlhostdiv Variable

Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlhostdiv As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


savenode Variable

Dim savenode As TreeNode

Source code

[Visual Basic]
    Dim savenode As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tda Variable

Dim tda As DataTable

Source code

[Visual Basic]
    Dim tda As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tdh Variable

Dim tdh As DataTable

Source code

[Visual Basic]
    Dim tdh As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tdt Variable

Dim tdt As DataTable

Source code

[Visual Basic]
    Dim tdt As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tdtuvm Variable

Dim tdtuvm As DataTable = Generic_Select( _
   10 _
)

Source code

[Visual Basic]
    Dim tdtuvm As DataTable = Generic_Select(10)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tdtzv Variable

Dim tdtzv As DataTable

Source code

[Visual Basic]
    Dim tdtzv As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum1uvm Variable

Friend WithEvents textdatum1uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum1uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum1zv Variable

Friend WithEvents textdatum1zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum1zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum2uvm Variable

Friend WithEvents textdatum2uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum2uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum2zv Variable

Friend WithEvents textdatum2zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum2zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum3uvm Variable

Friend WithEvents textdatum3uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum3uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum3zv Variable

Friend WithEvents textdatum3zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum3zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum4uvm Variable

Friend WithEvents textdatum4uvm As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum4uvm As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


textdatum4zv Variable

Friend WithEvents textdatum4zv As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents textdatum4zv As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tko Variable

Dim tko As DataTable

Source code

[Visual Basic]
    Dim tko As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tku Variable

Dim tku As DataTable

Source code

[Visual Basic]
    Dim tku As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tmb Variable

Dim tmb As DataTable

Source code

[Visual Basic]
    Dim tmb As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tnl Variable

Dim tnl As DataTable

Source code

[Visual Basic]
    Dim tnl As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tpe Variable

Dim tpe As DataTable

Source code

[Visual Basic]
    Dim tpe As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tst Variable

Dim tst As DataTable

Source code

[Visual Basic]
    Dim tst As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


tte Variable

Dim tte As DataTable

Source code

[Visual Basic]
    Dim tte As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum1 Variable

Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum1uvm Variable

Friend WithEvents txtdatum1uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum1zv Variable

Friend WithEvents txtdatum1zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum1zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum2 Variable

Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum2uvm Variable

Friend WithEvents txtdatum2uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum2zv Variable

Friend WithEvents txtdatum2zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum2zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum3 Variable

Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum3uvm Variable

Friend WithEvents txtdatum3uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum3zv Variable

Friend WithEvents txtdatum3zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum3zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum4 Variable

Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum4uvm Variable

Friend WithEvents txtdatum4uvm As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4uvm As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum4zv Variable

Friend WithEvents txtdatum4zv As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum4zv As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum5 Variable

Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


txtdatum6 Variable

Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtdatum6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProfilinfo


frmProgress Class

For a list of all members of this type, see frmProgress Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmProgress

Public Class frmProgress
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmProgress Members


frmProgress Members

frmProgress overview

Constructors

constructor frmProgress Constructor (Overloaded)

Properties

property CloseIsInvisible

Methods

method Dispose
method Info_TextChanged
method InitializeComponent
method frmProgress_Closing
method frmProgress_Load

Fields

field Bar1
field Info
field components
field m_CloseIsInvisible

See Also

frmProgress Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal CloseIsInvisible As Boolean)

See Also

frmProgress | EDOKAApp


frmProgress Properties

frmProgress overview

Properties

property CloseIsInvisible

See Also

frmProgress Class


frmProgress.CloseIsInvisible Property

Property CloseIsInvisible() As Boolean

Source code

[Visual Basic]
    Property CloseIsInvisible() As Boolean
        Get
            Return m_CloseIsInvisible
        End Get
        Set(ByVal Value As Boolean)
            m_CloseIsInvisible = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress Methods

frmProgress overview

Methods

method Dispose
method Info_TextChanged
method InitializeComponent
method frmProgress_Closing
method frmProgress_Load

See Also

frmProgress Class


frmProgress.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress.Info_TextChanged Method

Private Sub Info_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Info.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Info_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles Info.TextChanged
        Me.Refresh()
        System.Windows.Forms.Application.DoEvents()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.Info = New System.Windows.Forms.Label()
        Me.Bar1 = New UtilityLibrary.WinControls.ProgressBarEx()
        Me.SuspendLayout()
        '
        'Info
        '
        Me.Info.Location = New System.Drawing.Point(8, 16)
        Me.Info.Name = "Info"
        Me.Info.Size = New System.Drawing.Size(392, 23)
        Me.Info.TabIndex = 1
        Me.Info.Text = "Label1"
        '
        'Bar1
        '
        Me.Bar1.BackgroundBitmap = Nothing
        Me.Bar1.BackgroundColor = System.Drawing.Color.FromArgb(CType(220, Byte), CType(217, Byte), CType(211, Byte))
        Me.Bar1.Border3D = System.Windows.Forms.Border3DStyle.Flat
        Me.Bar1.BorderColor = System.Drawing.SystemColors.Highlight
        Me.Bar1.EnableBorder3D = True
        Me.Bar1.ForegroundBitmap = Nothing
        Me.Bar1.ForegroundColor = System.Drawing.Color.Blue
        Me.Bar1.GradientEndColor = System.Drawing.Color.Navy
        Me.Bar1.GradientMiddleColor = System.Drawing.Color.Blue
        Me.Bar1.GradientStartColor = System.Drawing.Color.FromArgb(CType(128, Byte), CType(128, Byte), CType(255, Byte))
        Me.Bar1.Location = New System.Drawing.Point(8, 40)
        Me.Bar1.Maximum = 100
        Me.Bar1.Minimum = 0
        Me.Bar1.Name = "Bar1"
        Me.Bar1.ProgressTextColor = System.Drawing.Color.Empty
        Me.Bar1.ProgressTextHiglightColor = System.Drawing.Color.Empty
        Me.Bar1.ShowProgressText = True
        Me.Bar1.Size = New System.Drawing.Size(392, 32)
        Me.Bar1.Smooth = True
        Me.Bar1.Step = 10
        Me.Bar1.TabIndex = 2
        Me.Bar1.Text = "ProgressBarEx1"
        Me.Bar1.Value = 0
        '
        'frmProgress
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(408, 87)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Bar1, Me.Info})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmProgress"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Fortschrittsanzeige"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress.frmProgress_Closing Method

Private Sub frmProgress_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProgress_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Me.CloseIsInvisible = True Then
            Me.Visible = False
            e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress.frmProgress_Load Method

Private Sub frmProgress_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmProgress_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress Fields

frmProgress overview

Fields

field Bar1
field Info
field components
field m_CloseIsInvisible

See Also

frmProgress Class


Bar1 Variable

Friend WithEvents Bar1 As UtilityLibrary.WinControls.ProgressBarEx

Source code

[Visual Basic]
    Friend WithEvents Bar1 As UtilityLibrary.WinControls.ProgressBarEx

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


Info Variable

Friend WithEvents Info As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Info As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


m_CloseIsInvisible Variable

Dim m_CloseIsInvisible As Boolean = False

Source code

[Visual Basic]
    Dim m_CloseIsInvisible As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmQuery Class

For a list of all members of this type, see frmQuery Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmQuery

Public Class frmQuery
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmQuery Members


frmQuery Members

frmQuery overview

Constructors

constructor frmQuery Constructor

Methods

method ComboBox1_SelectedIndexChanged
method Dispose
method InitializeComponent
method Load_File
method Run_Query
method ToolBar1_ButtonClick
method copydata
method frmQuery_Load
method get_queries

Fields

field ComboBox1
field DokList
field ImageList1
field Label1
field OpenFileDialog1
field SaveFileDialog1
field Splitter1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field components

See Also

frmQuery Class


frmQuery Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery Methods

frmQuery overview

Methods

method ComboBox1_SelectedIndexChanged
method Dispose
method InitializeComponent
method Load_File
method Run_Query
method ToolBar1_ButtonClick
method copydata
method frmQuery_Load
method get_queries

See Also

frmQuery Class


frmQuery.ComboBox1_SelectedIndexChanged Method

Private Sub ComboBox1_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ComboBox1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ComboBox1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles ComboBox1.SelectedIndexChanged
        Try
            Me.TextBox1.Text = Me.ComboBox1.SelectedValue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmQuery))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton9 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton8 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label1 = New System.Windows.Forms.Label()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4, Me.ToolBarButton5, Me.ToolBarButton6, Me.ToolBarButton7, Me.ToolBarButton9, Me.ToolBarButton8})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(600, 25)
        Me.ToolBar1.TabIndex = 27
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Verlassen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.ToolTipText = "SQL-Datei vom Filesystem laden"
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 2
        Me.ToolBarButton3.ToolTipText = "Abfrage ausführen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 3
        Me.ToolBarButton4.ToolTipText = "Markierte Zeilen/Spalten in die Zwischenablage kopieren"
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 5
        Me.ToolBarButton6.ToolTipText = "SQL-Abfrage aus der Datenbank laden"
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.ImageIndex = 7
        Me.ToolBarButton7.ToolTipText = "SQL-Abfrage speichen (Ctrl+V im Grid)"
        '
        'ToolBarButton9
        '
        Me.ToolBarButton9.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton8
        '
        Me.ToolBarButton8.ImageIndex = 4
        Me.ToolBarButton8.ToolTipText = "Resultattabelle in einer CSV-Datei Speichen (für Excel)"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TextBox1
        '
        Me.TextBox1.Dock = System.Windows.Forms.DockStyle.Top
        Me.TextBox1.Location = New System.Drawing.Point(0, 25)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(600, 159)
        Me.TextBox1.TabIndex = 28
        Me.TextBox1.Text = ""
        '
        'OpenFileDialog1
        '
        Me.OpenFileDialog1.DefaultExt = "*.sql"
        '
        'Splitter1
        '
        Me.Splitter1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter1.Location = New System.Drawing.Point(0, 184)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(600, 3)
        Me.Splitter1.TabIndex = 29
        Me.Splitter1.TabStop = False
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdate = False
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(0, 187)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(600, 266)
        Me.DokList.TabIndex = 30
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 596," & _
        " 262</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 596, " & _
        "262</ClientArea></Blob>"
        '
        'SaveFileDialog1
        '
        Me.SaveFileDialog1.FileName = "doc1"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(272, 4)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(312, 21)
        Me.ComboBox1.TabIndex = 31
        Me.ComboBox1.Text = "ComboBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(184, 6)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 16)
        Me.Label1.TabIndex = 32
        Me.Label1.Text = "Abfrageauswahl"
        '
        'frmQuery
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 453)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.ComboBox1, Me.DokList, Me.Splitter1, Me.TextBox1, Me.ToolBar1})
        Me.Name = "frmQuery"
        Me.Text = "SQL-Query"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.Load_File Method

Private Sub Load_File( _
   ByVal Filename As String _
)

Parameters

Filename
Required.

Source code

[Visual Basic]
    Private Sub Load_File(ByVal Filename As String)
        Try
            Dim ofile As System.IO.File
            Dim oread As System.IO.StreamReader
            oread = ofile.OpenText(Filename)
            Me.TextBox1.Text = oread.ReadToEnd
            oread.Close()
            ofile = Nothing
            oread = Nothing
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.Run_Query Method

Private Sub Run_Query()

Source code

[Visual Basic]
    Private Sub Run_Query()
        Try

            Dim qr As New SqlDataAdapter(Me.TextBox1.Text, Globals.sConnectionString)
            Dim dsi As New DataSet()
            Me.Cursor = Cursors.WaitCursor
            dsi.Tables.Clear()
            qr.Fill(dsi, "Daten")
            Me.DokList.DataSource = Nothing
            Try
                Me.DokList.DataSource = dsi.Tables(0)
                Me.DokList.DataMember = dsi.Tables(0).TableName
            Catch
            End Try
            Me.Cursor = Cursors.Default
            If dsi.Tables.Count < 1 Then
                MsgBox("Abfrage wurde erfolgreich beendet.")
            End If
        Catch ex As Exception
            Me.Cursor = Cursors.Default
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 1
                Me.OpenFileDialog1.ShowDialog()
                If Me.OpenFileDialog1.FileName <> "" Then
                    Load_File(Me.OpenFileDialog1.FileName)
                End If
            Case 2
                Run_Query()
                'If UCase(Microsoft.VisualBasic.Left(Me.TextBox1.Text, 6)) <> "SELECT" Then
                '    MsgBox("Es können nur Select-Statements ausgeführt werden")
                '    Exit Sub
                'Else
                '    Run_Query()
                'End If
            Case 3
                copydata()
            Case 5 'Load Query from Database
                Dim f As New frmDomainSQLQueries()
                f.DomainList.AllowAddNew = False
                f.ShowDialog()
                Try
                    Me.TextBox1.Text = f.DomainList.Columns("query").Value
                Catch
                End Try
                f.Dispose()
            Case 6
                Dim f As New frmDomainSQLQueries()
                Clipboard.SetDataObject(Me.TextBox1.Text)
                f.ShowDialog()
                f.Dispose()
            Case 8
                If Me.DokList.Splits(0).Rows.Count > 0 Then
                    Me.SaveFileDialog1.AddExtension = True
                    Me.SaveFileDialog1.DefaultExt.Insert(0, "*.csv")
                    Me.SaveFileDialog1.ShowDialog()
                    If Me.SaveFileDialog1.FileName <> "" Then
                        Me.DokList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";")
                        '                        Me.DokList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows)
                    End If
                End If
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.copydata Method

Private Sub copydata()

Source code

[Visual Basic]
    Private Sub copydata()
        Dim strTemp As String   'string to be copied to the clipboard
        Dim row As Long
        Dim col As C1.Win.C1TrueDBGrid.C1DataColumn
        Dim cols As Integer, rows As Long
        If Me.DokList.SelectedRows.Count > 0 Then
            For Each row In Me.DokList.SelectedRows
                For Each col In Me.DokList.Columns
                    strTemp = strTemp & col.CellText(row) & vbTab
                Next
                strTemp = strTemp & vbCrLf
            Next
            System.Windows.Forms.Clipboard.SetDataObject(strTemp, False)
        Else
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.frmQuery_Load Method

Private Sub frmQuery_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmQuery_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.WindowState = FormWindowState.Maximized
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) = False Then
            Me.ComboBox1.Visible = True
            Me.Label1.Visible = True
            Me.TextBox1.ReadOnly = True
            Dim dt As New DataTable()
            dt = Me.get_queries(0)
            Me.ComboBox1.DataSource = dt
            Me.ComboBox1.DisplayMember = "beschreibung"
            Me.ComboBox1.ValueMember = "query"
            If dt.Rows.Count < 1 Then
                Me.ComboBox1.Text = "Keine Abfrage verfügbar"
            Else
                Me.ComboBox1.SelectedIndex = 0
            End If
            Me.ToolBar1.Buttons(1).Enabled = False
            Me.ToolBar1.Buttons(5).Enabled = False
            Me.ToolBar1.Buttons(6).Enabled = False
        Else
            Me.ComboBox1.Visible = True
            Me.Label1.Visible = True
            Dim dt As New DataTable()
            dt = Me.get_queries(1)
            Me.ComboBox1.DataSource = dt
            Me.ComboBox1.DisplayMember = "beschreibung"
            Me.ComboBox1.ValueMember = "query"
            If dt.Rows.Count < 1 Then
                Me.ComboBox1.Text = "Keine Abfrage verfügbar"
            Else
                Me.ComboBox1.SelectedIndex = 0
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery.get_queries Method

Public Function get_queries( _
   ByVal type As Integer _
) As DataTable

Parameters

type
Required.

Source code

[Visual Basic]
    Public Function get_queries(ByVal type As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_sqlqueries_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmQuery Fields

frmQuery overview

Fields

field ComboBox1
field DokList
field ImageList1
field Label1
field OpenFileDialog1
field SaveFileDialog1
field Splitter1
field TextBox1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field components

See Also

frmQuery Class


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


SaveFileDialog1 Variable

Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Source code

[Visual Basic]
    Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton8 Variable

Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


ToolBarButton9 Variable

Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmQuery


frmReaktivierungsgrund Class

For a list of all members of this type, see frmReaktivierungsgrund Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmReaktivierungsgrund

Public Class frmReaktivierungsgrund
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReaktivierungsgrund Members


frmReaktivierungsgrund Members

frmReaktivierungsgrund overview

Constructors

constructor frmReaktivierungsgrund Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmLoeschgrund_Load
method mcbloeschgrund_SelectedIndexChanged

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field On_Load
field components
field mcbloeschgrund
field txtLoeschgrund

See Also

frmReaktivierungsgrund Class


frmReaktivierungsgrund Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund Methods

frmReaktivierungsgrund overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmLoeschgrund_Load
method mcbloeschgrund_SelectedIndexChanged

See Also

frmReaktivierungsgrund Class


frmReaktivierungsgrund.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        If Len(Me.txtLoeschgrund.Text) < 20 Then
            MyMsg.show_standardmessage(65, MsgBoxStyle.Critical)
        Else
            Me.DialogResult = DialogResult.OK
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.Generic_Select Method

Private Function Generic_Select() As DataTable

Source code

[Visual Basic]
    Private Function Generic_Select() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_grund"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@grundtyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmReaktivierungsgrund))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtLoeschgrund = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 64)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(128, 16)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Reaktivierungsgrund"
        '
        'txtLoeschgrund
        '
        Me.txtLoeschgrund.Location = New System.Drawing.Point(16, 88)
        Me.txtLoeschgrund.Multiline = True
        Me.txtLoeschgrund.Name = "txtLoeschgrund"
        Me.txtLoeschgrund.Size = New System.Drawing.Size(504, 72)
        Me.txtLoeschgrund.TabIndex = 2
        Me.txtLoeschgrund.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(392, 168)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(128, 23)
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "&Dokument reaktivieren"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.Button2.Location = New System.Drawing.Point(16, 168)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(72, 24)
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(16, 32)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(504, 21)
        Me.ComboBox1.TabIndex = 5
        Me.ComboBox1.Text = "ComboBox1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(160, 16)
        Me.Label2.TabIndex = 6
        Me.Label2.Text = "Auswahl  Reaktivierungsgrund"
        '
        'frmReaktivierungsgrund
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 197)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label2, Me.ComboBox1, Me.Button2, Me.Button1, Me.txtLoeschgrund, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmReaktivierungsgrund"
        Me.Text = "$"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.frmLoeschgrund_Load Method

Private Sub frmLoeschgrund_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmLoeschgrund_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.mcbloeschgrund = New MultiComboBox(Me.ComboBox1)
        Me.mcbloeschgrund.CheckNullValue = False
        Me.mcbloeschgrund.DisplayColumnName = "Grund"
        Me.mcbloeschgrund.ValueColumnName = "grundnr"
        Me.mcbloeschgrund.Fill_Data(Generic_Select, False)
        On_Load = False
        Me.txtLoeschgrund.Focus()
        Me.txtLoeschgrund.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund.mcbloeschgrund_SelectedIndexChanged Method

Private Sub mcbloeschgrund_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbloeschgrund.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbloeschgrund_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbloeschgrund.SelectedIndexChanged
        If On_Load Then Exit Sub
        If Microsoft.VisualBasic.Left(Me.mcbloeschgrund.Text, 1) = "(" Then
            Me.txtLoeschgrund.Focus()
            Me.txtLoeschgrund.SelectAll()
            Me.txtLoeschgrund.Text = ""
            Me.txtLoeschgrund.Enabled = True
        Else
            Me.txtLoeschgrund.Text = Me.mcbloeschgrund.Text
            Me.txtLoeschgrund.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReaktivierungsgrund Fields

frmReaktivierungsgrund overview

Fields

field Button1
field Button2
field ComboBox1
field Label1
field Label2
field On_Load
field components
field mcbloeschgrund
field txtLoeschgrund

See Also

frmReaktivierungsgrund Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


mcbloeschgrund Variable

Dim WithEvents mcbloeschgrund As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbloeschgrund As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


txtLoeschgrund Variable

Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReaktivierungsgrund


frmReleaseNotes Class

For a list of all members of this type, see frmReleaseNotes Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmReleaseNotes

Public Class frmReleaseNotes
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReleaseNotes Members


frmReleaseNotes Members

frmReleaseNotes overview

Constructors

constructor frmReleaseNotes Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method PrintDocument1_BeginPrint
method PrintDocument1_EndPrint
method PrintDocument1_PrintPage
method PrintPreviewDialog1_Load
method ToolBar1_ButtonClick
method frmReleaseNotes_Load
method frmReleaseNotes_Resize

Fields

field ImageList1
field PageSetupDialog1
field PrintDialog1
field PrintDocument1
field PrintPreviewDialog1
field RichTextBox1
field Richtextboxex1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field components
field m_nFirstCharOnPage

See Also

frmReleaseNotes Class


frmReleaseNotes Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes Methods

frmReleaseNotes overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method MenuItem3_Click
method PrintDocument1_BeginPrint
method PrintDocument1_EndPrint
method PrintDocument1_PrintPage
method PrintPreviewDialog1_Load
method ToolBar1_ButtonClick
method frmReleaseNotes_Load
method frmReleaseNotes_Resize

See Also

frmReleaseNotes Class


frmReleaseNotes.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmReleaseNotes))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.PageSetupDialog1 = New System.Windows.Forms.PageSetupDialog()
        Me.PrintDocument1 = New System.Drawing.Printing.PrintDocument()
        Me.PrintDialog1 = New System.Windows.Forms.PrintDialog()
        Me.PrintPreviewDialog1 = New System.Windows.Forms.PrintPreviewDialog()
        Me.RichTextBox1 = New System.Windows.Forms.RichTextBox()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(714, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 2
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'PageSetupDialog1
        '
        Me.PageSetupDialog1.Document = Me.PrintDocument1
        '
        'PrintDocument1
        '
        '
        'PrintDialog1
        '
        Me.PrintDialog1.Document = Me.PrintDocument1
        '
        'PrintPreviewDialog1
        '
        Me.PrintPreviewDialog1.AutoScrollMargin = New System.Drawing.Size(0, 0)
        Me.PrintPreviewDialog1.AutoScrollMinSize = New System.Drawing.Size(0, 0)
        Me.PrintPreviewDialog1.ClientSize = New System.Drawing.Size(400, 300)
        Me.PrintPreviewDialog1.Document = Me.PrintDocument1
        Me.PrintPreviewDialog1.Enabled = True
        Me.PrintPreviewDialog1.Icon = CType(resources.GetObject("PrintPreviewDialog1.Icon"), System.Drawing.Icon)
        Me.PrintPreviewDialog1.Location = New System.Drawing.Point(44, 44)
        Me.PrintPreviewDialog1.MaximumSize = New System.Drawing.Size(0, 0)
        Me.PrintPreviewDialog1.Name = "PrintPreviewDialog1"
        Me.PrintPreviewDialog1.Opacity = 1
        Me.PrintPreviewDialog1.TransparencyKey = System.Drawing.Color.Empty
        Me.PrintPreviewDialog1.Visible = False
        '
        'RichTextBox1
        '
        Me.RichTextBox1.Location = New System.Drawing.Point(0, 24)
        Me.RichTextBox1.Name = "RichTextBox1"
        Me.RichTextBox1.Size = New System.Drawing.Size(696, 440)
        Me.RichTextBox1.TabIndex = 3
        Me.RichTextBox1.Text = "RichTextBox1"
        '
        'frmReleaseNotes
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(714, 575)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.RichTextBox1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmReleaseNotes"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Release-Informationen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.PageSetupDialog1.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        If (PrintPreviewDialog1.ShowDialog = DialogResult.OK) Then
            PrintDocument1.Print()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        PrintDocument1.Print()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.PrintDocument1_BeginPrint Method

Private Sub PrintDocument1_BeginPrint( _
   ByVal sender As Object, _
   ByVal e As System.Drawing.Printing.PrintEventArgs _
) Handles PrintDocument1.BeginPrint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PrintDocument1_BeginPrint(ByVal sender As Object, ByVal e As System.Drawing.Printing.PrintEventArgs) Handles PrintDocument1.BeginPrint
        m_nFirstCharOnPage = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.PrintDocument1_EndPrint Method

Private Sub PrintDocument1_EndPrint( _
   ByVal sender As Object, _
   ByVal e As System.Drawing.Printing.PrintEventArgs _
) Handles PrintDocument1.EndPrint

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PrintDocument1_EndPrint(ByVal sender As Object, ByVal e As System.Drawing.Printing.PrintEventArgs) Handles PrintDocument1.EndPrint
        Richtextboxex1.FormatRangeDone()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.PrintDocument1_PrintPage Method

Private Sub PrintDocument1_PrintPage( _
   ByVal sender As Object, _
   ByVal e As System.Drawing.Printing.PrintPageEventArgs _
) Handles PrintDocument1.PrintPage

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PrintDocument1_PrintPage(ByVal sender As Object, ByVal e As System.Drawing.Printing.PrintPageEventArgs) Handles PrintDocument1.PrintPage
        m_nFirstCharOnPage = Richtextboxex1.FormatRange(False, _
                                                e, _
                                                m_nFirstCharOnPage, _
                                                Richtextboxex1.TextLength)

        If (m_nFirstCharOnPage < Richtextboxex1.TextLength) Then
            e.HasMorePages = True
        Else
            e.HasMorePages = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.PrintPreviewDialog1_Load Method

Private Sub PrintPreviewDialog1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles PrintPreviewDialog1.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PrintPreviewDialog1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles PrintPreviewDialog1.Load
        Me.PrintPreviewDialog1.Height = 600
        Me.PrintPreviewDialog1.Width = 800
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 1
                If Me.PageSetupDialog1.ShowDialog() = DialogResult.OK Then
                    PrintDocument1.Print()
                End If
            Case 2
                PrintPreviewDialog1.ShowDialog()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.frmReleaseNotes_Load Method

Private Sub frmReleaseNotes_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReleaseNotes_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.Richtextboxex1 = New RichTextBoxEx(Me.RichTextBox1)
        Me.Richtextboxex1.LoadFile(Application.StartupPath + "\relnotes.rtf")
        Me.Richtextboxex1.Top = Me.ToolBar1.Top + Me.ToolBar1.Height + 1
        Me.Richtextboxex1.Width = Me.ToolBar1.Width
        Me.Richtextboxex1.Height = Me.Height - Me.ToolBar1.Height - 30
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes.frmReleaseNotes_Resize Method

Private Sub frmReleaseNotes_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReleaseNotes_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Try
            Me.Richtextboxex1.Top = Me.ToolBar1.Top + Me.ToolBar1.Height + 1
            Me.Richtextboxex1.Width = Me.ToolBar1.Width
            Me.Richtextboxex1.Height = Me.Height - Me.ToolBar1.Height - 30
        Catch
        End Try

        '        Try
        '        Me.Richtextboxex1.Top = Me.ToolBar1.Top + Me.ToolBar1.Height
        '        Me.Richtextboxex1.Width = Me.ToolBar1.Width
        '        Me.Richtextboxex1.Height = Me.Height - Me.ToolBar1.Height
        '       Catch
        '      End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReleaseNotes Fields

frmReleaseNotes overview

Fields

field ImageList1
field PageSetupDialog1
field PrintDialog1
field PrintDocument1
field PrintPreviewDialog1
field RichTextBox1
field Richtextboxex1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field components
field m_nFirstCharOnPage

See Also

frmReleaseNotes Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


PageSetupDialog1 Variable

Friend WithEvents PageSetupDialog1 As System.Windows.Forms.PageSetupDialog

Source code

[Visual Basic]
    Friend WithEvents PageSetupDialog1 As System.Windows.Forms.PageSetupDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


PrintDialog1 Variable

Friend WithEvents PrintDialog1 As System.Windows.Forms.PrintDialog

Source code

[Visual Basic]
    Friend WithEvents PrintDialog1 As System.Windows.Forms.PrintDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


PrintDocument1 Variable

Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Source code

[Visual Basic]
    Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


PrintPreviewDialog1 Variable

Friend WithEvents PrintPreviewDialog1 As System.Windows.Forms.PrintPreviewDialog

Source code

[Visual Basic]
    Friend WithEvents PrintPreviewDialog1 As System.Windows.Forms.PrintPreviewDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


RichTextBox1 Variable

Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Source code

[Visual Basic]
    Friend WithEvents RichTextBox1 As System.Windows.Forms.RichTextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


Richtextboxex1 Variable

Dim Richtextboxex1 As RichTextBoxEx

Source code

[Visual Basic]
    Dim Richtextboxex1 As RichTextBoxEx

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


m_nFirstCharOnPage Variable

Private m_nFirstCharOnPage As Integer

Source code

[Visual Basic]
    Private m_nFirstCharOnPage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReleaseNotes


frmReportFelder Class

For a list of all members of this type, see frmReportFelder Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmReportFelder

Public Class frmReportFelder
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReportFelder Members


frmReportFelder Members

frmReportFelder overview

Constructors

constructor frmReportFelder Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReportFelder Class


frmReportFelder Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder Properties

frmReportFelder overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmReportFelder Class


frmReportFelder Methods

frmReportFelder overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmReportFelder Class


frmReportFelder.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportnr", "reportnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("dateiname", "dateiname"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("odbc", "odbc"), New System.Data.Common.DataColumnMapping("oledb", "oledb"), New System.Data.Common.DataColumnMapping("sqlclient", "sqlclient")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_report_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_odbc", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "odbc", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_oledb", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "oledb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sqlclient", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sqlclient", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_report_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 255, "dateiname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@odbc", System.Data.SqlDbType.Bit, 1, "odbc"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@oledb", System.Data.SqlDbType.Bit, 1, "oledb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sqlclient", System.Data.SqlDbType.Bit, 1, "sqlclient"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_report_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_report_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 1024, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dateiname", System.Data.SqlDbType.VarChar, 255, "dateiname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@odbc", System.Data.SqlDbType.Bit, 1, "odbc"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@oledb", System.Data.SqlDbType.Bit, 1, "oledb"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sqlclient", System.Data.SqlDbType.Bit, 1, "sqlclient"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dateiname", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dateiname", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_odbc", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "odbc", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_oledb", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "oledb", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sqlclient", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sqlclient", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeldregelnr", "reportfeldregelnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtyp", "feldtyp"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("darstellung", "darstellung"), New System.Data.Common.DataColumnMapping("multiselect", "multiselect"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_reportfeldregel_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_darstellung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "darstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_multiselect", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "multiselect", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_reportfeldregel_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelnr", System.Data.SqlDbType.Int, 4, "reportfeldregelnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 50, "feldtyp"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 1024, "datenherkunft"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@darstellung", System.Data.SqlDbType.VarChar, 50, "darstellung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@multiselect", System.Data.SqlDbType.VarChar, 1024, "multiselect"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_reportfeldregel_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_reportfeldregel_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelnr", System.Data.SqlDbType.Int, 4, "reportfeldregelnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtyp", System.Data.SqlDbType.VarChar, 50, "feldtyp"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 1024, "datenherkunft"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@darstellung", System.Data.SqlDbType.VarChar, 50, "darstellung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@multiselect", System.Data.SqlDbType.VarChar, 1024, "multiselect"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_darstellung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "darstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "datenherkunft", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "feldtyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_multiselect", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "multiselect", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportfeld", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeld_nr", "reportfeld_nr"), New System.Data.Common.DataColumnMapping("reportfeldregelnr", "reportfeldregelnr"), New System.Data.Common.DataColumnMapping("reportnr", "reportnr"), New System.Data.Common.DataColumnMapping("reihenfolge", "reihenfolge"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_reportfeld_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_reportfeld_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeld_nr", System.Data.SqlDbType.Int, 4, "reportfeld_nr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelnr", System.Data.SqlDbType.Int, 4, "reportfeldregelnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_reportfeld_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeld_nr", System.Data.SqlDbType.Int, 4, "reportfeld_nr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelnr", System.Data.SqlDbType.Int, 4, "reportfeldregelnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportnr", System.Data.SqlDbType.Int, 4, "reportnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeld_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeld_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_reportfeld_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeld_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeld_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportfeldregelnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmReportFelder
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmReportFelder"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsReportfeld()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iReportnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                vdata.iReportfeldregelnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.iReihenfolge = New SqlInt32(CType(1, Int32))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("reportfeld")
            vdata.iReportfeld_nr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5020, 5021, 5022)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom

        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "report"
        Me.TableNameRight = "reportfeldregel"
        Me.TableNameBottom = "reportfeld"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportFelder Fields

frmReportFelder overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReportFelder Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportFelder


frmReportSelection Class

For a list of all members of this type, see frmReportSelection Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmReportSelection

Public Class frmReportSelection
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReportSelection Members


frmReportSelection Members

frmReportSelection overview

Constructors

constructor frmReportSelection Constructor

Properties

property ParameterSetNameID
property ReportNr
property ReportgruppeNr
property TableName

Methods

method ClearParameterFields
method CreateDatasourceDokumentauswertung
method Dispose
method FillParameter
method FillParameterCollection
method FillParameterRows
method FillReport
method InitializeComponent
method OpenParameterDialog
method PharseDatenherkunft
method SpaltenTitel_Aktualisieren
method SpaltenTitel_AktualisierenHUT
method ToolBar1_ButtonClick
method ValidateParameterfields
method frmReportSelection_Closing
method frmReportSelection_Load
method frmReportSelection_Resize
method gbxReportgruppen_Enter
method getlastDayInMonth
method grdParameter_BeforeColEdit
method grdParameter_BeforeColUpdate
method grdParameter_ButtonClick
method grdParameter_DoubleClick
method grdParameter_FetchCellStyle
method grdParameter_KeyDown
method grdReport_MouseDown
method grdReport_RowColChange
method grdReportgruppen_RowColChange
method loadParameterList
method mnuExit_Click

Fields

field DataSet1
field ImageList1
field MainMenu1
field Splitter1
field Splitter2
field Splitter3
field Splitter4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand4
field SqlUpdateCommand1
field ToolBar1
field ToolBarButton1
field ToolBtnClearParameter
field ToolBtnExit
field ToolBtnOpenParSet
field ToolBtnPreview
field ToolBtnSave
field components
field daParameter
field daReport
field dsParameter
field dsReport
field gbxReport
field gbxReportBeschreibung
field gbxReportgruppen
field gbxReserve
field grdParameter
field grdReport
field grdReportgruppen
field grxParameter
field m_iParameterSetNameID
field m_iReportNr
field m_iReportgruppeNr
field m_sTableName
field pnlBottom
field pnlParameter
field pnlRepoert_Reportbeschreibung
field pnlReportgruppe
field pnlTop
field txtReportDescription

See Also

frmReportSelection Class


frmReportSelection Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection Properties

frmReportSelection overview

Properties

property ParameterSetNameID
property ReportNr
property ReportgruppeNr
property TableName

See Also

frmReportSelection Class


frmReportSelection.ParameterSetNameID Property

Property ParameterSetNameID() As Integer

Source code

[Visual Basic]
    Property ParameterSetNameID() As Integer
        Get
            Return m_iParameterSetNameID
        End Get
        Set(ByVal Value As Integer)
            m_iParameterSetNameID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.ReportNr Property

Property ReportNr()

Source code

[Visual Basic]
    Property ReportNr()
        Get
            Return m_iReportNr
        End Get
        Set(ByVal Value)
            m_iReportNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.ReportgruppeNr Property

Property ReportgruppeNr()

Source code

[Visual Basic]
    Property ReportgruppeNr()
        Get
            Return m_iReportgruppeNr
        End Get
        Set(ByVal Value)
            m_iReportgruppeNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_sTableName
        End Get
        Set(ByVal Value As String)
            m_sTableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection Methods

frmReportSelection overview

Methods

method ClearParameterFields
method CreateDatasourceDokumentauswertung
method Dispose
method FillParameter
method FillParameterCollection
method FillParameterRows
method FillReport
method InitializeComponent
method OpenParameterDialog
method PharseDatenherkunft
method SpaltenTitel_Aktualisieren
method SpaltenTitel_AktualisierenHUT
method ToolBar1_ButtonClick
method ValidateParameterfields
method frmReportSelection_Closing
method frmReportSelection_Load
method frmReportSelection_Resize
method gbxReportgruppen_Enter
method getlastDayInMonth
method grdParameter_BeforeColEdit
method grdParameter_BeforeColUpdate
method grdParameter_ButtonClick
method grdParameter_DoubleClick
method grdParameter_FetchCellStyle
method grdParameter_KeyDown
method grdReport_MouseDown
method grdReport_RowColChange
method grdReportgruppen_RowColChange
method loadParameterList
method mnuExit_Click

See Also

frmReportSelection Class


frmReportSelection.ClearParameterFields Method

Private Sub ClearParameterFields()

Source code

[Visual Basic]
    Private Sub ClearParameterFields()
        '===============================================================================
        'Desc  :    Setzt alle Parameterwerte auf Null
        'Input :    Datatabel der Persönlichen Parameterwerte
        'Output:
        'Erstellt  : koe 20.10.2003
        'Geaendert :
        '===============================================================================
        'Me.dsParameter.Tables(0)
        Dim RowParameter As DataRow
        For Each RowParameter In Me.dsParameter.Tables(0).Rows
            RowParameter.Item("ParameterNavigationValue") = ""
            RowParameter.Item("ParameterDisplayValue") = ""
        Next RowParameter
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.CreateDatasourceDokumentauswertung Method

Private Sub CreateDatasourceDokumentauswertung( _
   ByVal ProfilNr As Integer _
)

Parameters

ProfilNr
Required.

Source code

[Visual Basic]
    Private Sub CreateDatasourceDokumentauswertung(ByVal ProfilNr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.[SP_DokAuswertung_GetData]"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure

        scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ProfilNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        scmCmdToExecute.Connection = Me.SqlConnection1
        'scmCmdToExecute.Connection.Open()
        scmCmdToExecute.CommandTimeout = 120
        scmCmdToExecute.ExecuteNonQuery()
        scmCmdToExecute.CommandTimeout = 30

        scmCmdToExecute.Parameters.Clear()
        scmCmdToExecute.CommandText = "dbo.[sp_DokAuswertung_Getdata_Hierarchie]"

        scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ProfilNr", SqlDbType.NVarChar, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, CStr(ProfilNr)))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@bCreateTabel", SqlDbType.Bit, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
        scmCmdToExecute.ExecuteNonQuery()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.FillParameter Method

Private Sub FillParameter()

Source code

[Visual Basic]
    Private Sub FillParameter()
        '===============================================================================
        'Desc       : Füllen des Grid Parameter Kriterium ist die ReportNr ab Property
        'Input      :
        'Output     :
        'Erstellt   : koe 20.10.2003
        'Geaendert  :
        '===============================================================================
        Me.daParameter.SelectCommand.Parameters.Clear()
        Me.daParameter.SelectCommand.Parameters.Add("@reportNr", Me.m_iReportNr)
        Me.dsParameter.Clear()
        Me.daParameter.Fill(Me.dsParameter, "ParametersForReport")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.FillParameterCollection Method

Private Function FillParameterCollection() As Collection

Source code

[Visual Basic]
    Private Function FillParameterCollection() As Collection
        '===============================================================================
        'Desc       : Abfüllern der Parametercollection
        'Output	    : collection
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim colParameter As New Microsoft.VisualBasic.Collection()
        'Dim x As Microsoft.VisualBasic.Collection
        Dim iCnt As Integer
        Dim sParameterKey As String
        Dim sParameterValue As String
        Dim sFilterDisplayValue As String
        Try
            For iCnt = 0 To grdParameter.Splits(0).Rows.Count - 1
                '*********************************************************************************************************************
                'parameter
                '*********************************************************************************************************************
                sParameterKey = "@" & UCase(grdParameter.Columns("Parametername").CellText(iCnt))
                sParameterValue = grdParameter.Columns("ParameterNavigationValue").CellText(iCnt)
                Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
                colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)
                '*********************************************************************************************************************
                'Filter
                '*********************************************************************************************************************
                sParameterKey = "@FILTER" & UCase(grdParameter.Columns("Parametername").CellText(iCnt))

                If grdParameter.Columns("ParameterDisplayValue").CellText(iCnt) = "" Then
                    sParameterValue = grdParameter.Columns("Parameter").CellText(iCnt) & " = Keine " & grdParameter.Columns("ParameterDisplayValue").CellText(iCnt)
                Else
                    sParameterValue = grdParameter.Columns("Parameter").CellText(iCnt) & " = " & grdParameter.Columns("ParameterDisplayValue").CellText(iCnt)
                End If
                '*********************************************************************************************************************
                'String auf 254 länge schneiden Grund Crystal report
                '*********************************************************************************************************************

                'Debug.Write(Len(sParameterValue))
                sParameterValue = Microsoft.VisualBasic.Left(sParameterValue, 254)
                Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
                colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

                Select Case sParameterKey
                    Case "@SORTIERUNG"
                        sParameterKey = "@SORTIERUNG_DISPLAY"
                        Debug.Write(sParameterKey & vbCrLf)
                        sParameterValue = grdParameter.Columns("ParameterDisplayValue").CellText(iCnt)
                        sParameterValue = Microsoft.VisualBasic.Left(sParameterValue, 254)
                        colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)
                End Select
            Next
            '*********************************************************************************************************************
            'Parameter welche im Report sein müssen
            '*********************************************************************************************************************
            sParameterKey = "@MANr"
            Debug.Write(sParameterKey & vbCrLf)
            sParameterValue = Globals.MitarbeiterNr
            Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
            colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

            sParameterKey = "@ReportTitel"
            Debug.Write(sParameterKey & vbCrLf)
            sParameterValue = grdReport.Columns("report").Text
            Debug.Write(sParameterKey & vbTab & sParameterValue & vbCrLf)
            colParameter.Add(Item:=sParameterValue, Key:=sParameterKey)

            FillParameterCollection = colParameter
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.FillParameterRows Method

Private Sub FillParameterRows( _
   ByVal thisTable As DataTable _
)

Parameters

thisTable
Required.

Source code

[Visual Basic]
    Private Sub FillParameterRows(ByVal thisTable As DataTable)
        '===============================================================================
        'Desc  :    Abfüllen der Persönlichen Parameterwerte für den gewählten Report
        'Input :    Datatabel der Persönlichen Parameterwerte
        'Output:
        'Erstellt  : koe 20.10.2003
        'Geaendert :
        '===============================================================================
        Dim RowParameter As DataRow
        Dim iReportReportfeldregelNr As Integer
        Dim RowParameterList As DataRow
        Dim sParameterwert As String
        For Each RowParameterList In thisTable.Rows
            iReportReportfeldregelNr = RowParameterList.Item("ReportReportfeldregelNr")

            For Each RowParameter In Me.dsParameter.Tables(0).Rows
                If RowParameter.Item("ReportReportfeldregelNr") = iReportReportfeldregelNr Then
                    RowParameter.Item("datenherkunft") = RowParameterList.Item("datenherkunft")
                    RowParameter.Item("ParameterDisplayValue") = RowParameterList.Item("ParameterDisplayValue")
                    If PharseDatenherkunft(RowParameterList.Item("datenherkunft"), sParameterwert) = True Then
                        'Parameter verwendet dynamische Datum
                        RowParameter.Item("ParameterNavigationValue") = sParameterwert
                    Else
                        RowParameter.Item("ParameterNavigationValue") = RowParameterList.Item("ParameterNavigationValue")
                    End If
                    Select Case RowParameterList.Item("datenherkunft")
                        Case "&Dokumentauswertung&"
                            CreateDatasourceDokumentauswertung(CInt(sParameterwert))
                    End Select
                    Exit For
                End If

            Next
        Next RowParameterList
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.FillReport Method

Private Sub FillReport()

Source code

[Visual Basic]
    Private Sub FillReport()
        '===============================================================================
        'Desc       : Füllen des Grid Report Kriterium ist ReportgruppenNr ab Property
        'Input      :
        'Output     :
        'Erstellt   : koe 20.10.2003
        'Geaendert  :
        '===============================================================================
        Me.daReport.SelectCommand.Parameters.Clear()
        Me.daReport.SelectCommand.Parameters.Add("@reportgruppeNr", Me.m_iReportgruppeNr)
        Me.dsReport.Clear()
        Me.daReport.Fill(Me.dsReport, "ReportsForGroup")
        If grdReport.Bookmark < 0 Then
            Me.m_iReportNr = 0
            Me.txtReportDescription.Text = ""

        Else
            'Me.m_iReportNr = dsReport.Tables(0).Rows(grdReport.Bookmark).Item("reportNr")
            Me.m_iReportNr = grdReport.Columns("reportNr").Value
            Me.txtReportDescription.Text = grdReport.Columns("beschreibung").CellValue(grdReport.Row)

        End If
        FillParameter()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmReportSelection))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnOpenParSet = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnClearParameter = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBtnPreview = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.pnlTop = New System.Windows.Forms.Panel()
        Me.pnlBottom = New System.Windows.Forms.Panel()
        Me.daReport = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.dsReport = New System.Data.DataSet()
        Me.dsParameter = New System.Data.DataSet()
        Me.daParameter = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.pnlReportgruppe = New System.Windows.Forms.Panel()
        Me.gbxReserve = New System.Windows.Forms.GroupBox()
        Me.Splitter3 = New System.Windows.Forms.Splitter()
        Me.gbxReportgruppen = New System.Windows.Forms.GroupBox()
        Me.grdReportgruppen = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.pnlRepoert_Reportbeschreibung = New System.Windows.Forms.Panel()
        Me.gbxReportBeschreibung = New System.Windows.Forms.GroupBox()
        Me.txtReportDescription = New System.Windows.Forms.TextBox()
        Me.Splitter4 = New System.Windows.Forms.Splitter()
        Me.gbxReport = New System.Windows.Forms.GroupBox()
        Me.grdReport = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.pnlParameter = New System.Windows.Forms.Panel()
        Me.grxParameter = New System.Windows.Forms.GroupBox()
        Me.grdParameter = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.dsReport, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.dsParameter, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlReportgruppe.SuspendLayout()
        Me.gbxReportgruppen.SuspendLayout()
        CType(Me.grdReportgruppen, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlRepoert_Reportbeschreibung.SuspendLayout()
        Me.gbxReportBeschreibung.SuspendLayout()
        Me.gbxReport.SuspendLayout()
        CType(Me.grdReport, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.pnlParameter.SuspendLayout()
        Me.grxParameter.SuspendLayout()
        CType(Me.grdParameter, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_reportgruppe_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_Mitarbeiter_Reportgruppen_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiterNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnExit, Me.ToolBtnOpenParSet, Me.ToolBtnSave, Me.ToolBtnClearParameter, Me.ToolBarButton1, Me.ToolBtnPreview})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(864, 25)
        Me.ToolBar1.TabIndex = 6
        '
        'ToolBtnExit
        '
        Me.ToolBtnExit.ImageIndex = 0
        Me.ToolBtnExit.ToolTipText = "Beenden"
        '
        'ToolBtnOpenParSet
        '
        Me.ToolBtnOpenParSet.ImageIndex = 5
        Me.ToolBtnOpenParSet.ToolTipText = "Öffnet persönliche Parameterwerte"
        '
        'ToolBtnSave
        '
        Me.ToolBtnSave.ImageIndex = 1
        Me.ToolBtnSave.ToolTipText = "Speichern"
        '
        'ToolBtnClearParameter
        '
        Me.ToolBtnClearParameter.ImageIndex = 6
        Me.ToolBtnClearParameter.ToolTipText = "Löscht alle Parametereingaben"
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBtnPreview
        '
        Me.ToolBtnPreview.ImageIndex = 4
        Me.ToolBtnPreview.ToolTipText = "Report Vorschau"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'MainMenu1
        '
        Me.MainMenu1.RightToLeft = System.Windows.Forms.RightToLeft.No
        '
        'pnlTop
        '
        Me.pnlTop.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlTop.Location = New System.Drawing.Point(0, 25)
        Me.pnlTop.Name = "pnlTop"
        Me.pnlTop.Size = New System.Drawing.Size(864, 8)
        Me.pnlTop.TabIndex = 10
        '
        'pnlBottom
        '
        Me.pnlBottom.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.pnlBottom.Location = New System.Drawing.Point(0, 689)
        Me.pnlBottom.Name = "pnlBottom"
        Me.pnlBottom.Size = New System.Drawing.Size(864, 8)
        Me.pnlBottom.TabIndex = 13
        '
        'daReport
        '
        Me.daReport.SelectCommand = Me.SqlSelectCommand2
        Me.daReport.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportgruppe_report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ReportgruppeReportNr", "ReportgruppeReportNr"), New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("report", "report"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("dateiname", "dateiname")})})
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[sp_ReportsForGroup_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportGruppenNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        '
        'dsReport
        '
        Me.dsReport.DataSetName = "NewDataSet"
        Me.dsReport.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'dsParameter
        '
        Me.dsParameter.DataSetName = "NewDataSet"
        Me.dsParameter.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'daParameter
        '
        Me.daParameter.DeleteCommand = Me.SqlDeleteCommand1
        Me.daParameter.InsertCommand = Me.SqlInsertCommand1
        Me.daParameter.SelectCommand = Me.SqlSelectCommand4
        Me.daParameter.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_reportfeldregel_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportfeldregelNr", "reportfeldregelNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("feldtypNr", "feldtypNr"), New System.Data.Common.DataColumnMapping("feldsteuerungNr", "feldsteuerungNr"), New System.Data.Common.DataColumnMapping("datenherkunft", "datenherkunft"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("eingabe_zwingend", "eingabe_zwingend")})})
        Me.daParameter.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_reportfeldregel_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_reportfeldregel_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[sp_reportFeldregel_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_reportfeldregel_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "reportfeldregelNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "feldtypNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "feldsteuerungNr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datenherkunft", System.Data.SqlDbType.VarChar, 2048, "datenherkunft"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_datenherkunft", System.Data.SqlDbType.VarChar, 2048))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldsteuerungNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_feldtypNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'pnlReportgruppe
        '
        Me.pnlReportgruppe.Controls.AddRange(New System.Windows.Forms.Control() {Me.gbxReserve, Me.Splitter3, Me.gbxReportgruppen})
        Me.pnlReportgruppe.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlReportgruppe.Location = New System.Drawing.Point(0, 33)
        Me.pnlReportgruppe.Name = "pnlReportgruppe"
        Me.pnlReportgruppe.Size = New System.Drawing.Size(864, 95)
        Me.pnlReportgruppe.TabIndex = 43
        '
        'gbxReserve
        '
        Me.gbxReserve.Dock = System.Windows.Forms.DockStyle.Fill
        Me.gbxReserve.Location = New System.Drawing.Point(400, 0)
        Me.gbxReserve.Name = "gbxReserve"
        Me.gbxReserve.Size = New System.Drawing.Size(464, 95)
        Me.gbxReserve.TabIndex = 47
        Me.gbxReserve.TabStop = False
        Me.gbxReserve.Text = "gbxReserve"
        Me.gbxReserve.Visible = False
        '
        'Splitter3
        '
        Me.Splitter3.Location = New System.Drawing.Point(392, 0)
        Me.Splitter3.Name = "Splitter3"
        Me.Splitter3.Size = New System.Drawing.Size(8, 95)
        Me.Splitter3.TabIndex = 45
        Me.Splitter3.TabStop = False
        '
        'gbxReportgruppen
        '
        Me.gbxReportgruppen.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdReportgruppen})
        Me.gbxReportgruppen.Dock = System.Windows.Forms.DockStyle.Left
        Me.gbxReportgruppen.Name = "gbxReportgruppen"
        Me.gbxReportgruppen.Size = New System.Drawing.Size(392, 95)
        Me.gbxReportgruppen.TabIndex = 44
        Me.gbxReportgruppen.TabStop = False
        Me.gbxReportgruppen.Text = "Reportgruppen"
        '
        'grdReportgruppen
        '
        Me.grdReportgruppen.AllowFilter = True
        Me.grdReportgruppen.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdReportgruppen.AllowSort = True
        Me.grdReportgruppen.AllowUpdate = False
        Me.grdReportgruppen.AlternatingRows = True
        Me.grdReportgruppen.CaptionHeight = 17
        Me.grdReportgruppen.CollapseColor = System.Drawing.Color.Black
        Me.grdReportgruppen.DataChanged = False
        Me.grdReportgruppen.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdReportgruppen.ExpandColor = System.Drawing.Color.Black
        Me.grdReportgruppen.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdReportgruppen.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.grdReportgruppen.Location = New System.Drawing.Point(16, 24)
        Me.grdReportgruppen.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.grdReportgruppen.Name = "grdReportgruppen"
        Me.grdReportgruppen.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdReportgruppen.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdReportgruppen.PreviewInfo.ZoomFactor = 75
        Me.grdReportgruppen.PrintInfo.ShowOptionsDialog = False
        Me.grdReportgruppen.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdReportgruppen.RowDivider = GridLines1
        Me.grdReportgruppen.RowHeight = 15
        Me.grdReportgruppen.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdReportgruppen.ScrollTips = False
        Me.grdReportgruppen.Size = New System.Drawing.Size(221, 56)
        Me.grdReportgruppen.TabIndex = 0
        Me.grdReportgruppen.Text = "C1TrueDBGrid2"
        Me.grdReportgruppen.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}S" & _
        "tyle1{}OddRow{BackColor:White;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 217, 52</ClientRect><Bo" & _
        "rderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle" & _
        " parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fil" & _
        "terBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""S" & _
        "tyle3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading" & _
        """ me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactive" & _
        "Style parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /" & _
        "><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle pare" & _
        "nt=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1True" & _
        "DBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style par" & _
        "ent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=" & _
        """Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""" & _
        "Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Norm" & _
        "al"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Nor" & _
        "mal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""" & _
        "Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ver" & _
        "tSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRec" & _
        "SelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 217, 52</ClientArea></Blob>"
        '
        'Splitter1
        '
        Me.Splitter1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter1.Location = New System.Drawing.Point(0, 128)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(864, 8)
        Me.Splitter1.TabIndex = 44
        Me.Splitter1.TabStop = False
        '
        'pnlRepoert_Reportbeschreibung
        '
        Me.pnlRepoert_Reportbeschreibung.Controls.AddRange(New System.Windows.Forms.Control() {Me.gbxReportBeschreibung, Me.Splitter4, Me.gbxReport})
        Me.pnlRepoert_Reportbeschreibung.Dock = System.Windows.Forms.DockStyle.Top
        Me.pnlRepoert_Reportbeschreibung.Location = New System.Drawing.Point(0, 136)
        Me.pnlRepoert_Reportbeschreibung.Name = "pnlRepoert_Reportbeschreibung"
        Me.pnlRepoert_Reportbeschreibung.Size = New System.Drawing.Size(864, 152)
        Me.pnlRepoert_Reportbeschreibung.TabIndex = 45
        '
        'gbxReportBeschreibung
        '
        Me.gbxReportBeschreibung.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtReportDescription})
        Me.gbxReportBeschreibung.Location = New System.Drawing.Point(424, 16)
        Me.gbxReportBeschreibung.Name = "gbxReportBeschreibung"
        Me.gbxReportBeschreibung.Size = New System.Drawing.Size(200, 64)
        Me.gbxReportBeschreibung.TabIndex = 49
        Me.gbxReportBeschreibung.TabStop = False
        Me.gbxReportBeschreibung.Text = "Reportbeschreibung"
        '
        'txtReportDescription
        '
        Me.txtReportDescription.BackColor = System.Drawing.SystemColors.Control
        Me.txtReportDescription.Location = New System.Drawing.Point(8, 16)
        Me.txtReportDescription.Multiline = True
        Me.txtReportDescription.Name = "txtReportDescription"
        Me.txtReportDescription.ReadOnly = True
        Me.txtReportDescription.ScrollBars = System.Windows.Forms.ScrollBars.Both
        Me.txtReportDescription.Size = New System.Drawing.Size(88, 40)
        Me.txtReportDescription.TabIndex = 1
        Me.txtReportDescription.Text = ""
        '
        'Splitter4
        '
        Me.Splitter4.Location = New System.Drawing.Point(400, 0)
        Me.Splitter4.Name = "Splitter4"
        Me.Splitter4.Size = New System.Drawing.Size(8, 152)
        Me.Splitter4.TabIndex = 48
        Me.Splitter4.TabStop = False
        '
        'gbxReport
        '
        Me.gbxReport.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdReport})
        Me.gbxReport.Dock = System.Windows.Forms.DockStyle.Left
        Me.gbxReport.Name = "gbxReport"
        Me.gbxReport.Size = New System.Drawing.Size(400, 152)
        Me.gbxReport.TabIndex = 47
        Me.gbxReport.TabStop = False
        Me.gbxReport.Text = "Report"
        '
        'grdReport
        '
        Me.grdReport.AllowFilter = True
        Me.grdReport.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdReport.AllowSort = True
        Me.grdReport.AllowUpdate = False
        Me.grdReport.AlternatingRows = True
        Me.grdReport.CaptionHeight = 17
        Me.grdReport.CollapseColor = System.Drawing.Color.Black
        Me.grdReport.DataChanged = False
        Me.grdReport.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdReport.ExpandColor = System.Drawing.Color.Black
        Me.grdReport.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdReport.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.grdReport.Location = New System.Drawing.Point(16, 16)
        Me.grdReport.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.grdReport.Name = "grdReport"
        Me.grdReport.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdReport.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdReport.PreviewInfo.ZoomFactor = 75
        Me.grdReport.PrintInfo.ShowOptionsDialog = False
        Me.grdReport.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdReport.RowDivider = GridLines2
        Me.grdReport.RowHeight = 15
        Me.grdReport.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdReport.ScrollTips = False
        Me.grdReport.Size = New System.Drawing.Size(120, 56)
        Me.grdReport.TabIndex = 0
        Me.grdReport.Text = "C1TrueDBGrid1"
        Me.grdReport.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}S" & _
        "tyle1{}OddRow{BackColor:White;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 116, 52</ClientRect><Bo" & _
        "rderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle" & _
        " parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fil" & _
        "terBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""S" & _
        "tyle3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading" & _
        """ me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactive" & _
        "Style parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /" & _
        "><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle pare" & _
        "nt=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1True" & _
        "DBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style par" & _
        "ent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=" & _
        """Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""" & _
        "Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Norm" & _
        "al"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Nor" & _
        "mal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""" & _
        "Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ver" & _
        "tSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRec" & _
        "SelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 116, 52</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter2.Location = New System.Drawing.Point(0, 288)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(864, 8)
        Me.Splitter2.TabIndex = 46
        Me.Splitter2.TabStop = False
        '
        'pnlParameter
        '
        Me.pnlParameter.Controls.AddRange(New System.Windows.Forms.Control() {Me.grxParameter})
        Me.pnlParameter.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlParameter.Location = New System.Drawing.Point(0, 296)
        Me.pnlParameter.Name = "pnlParameter"
        Me.pnlParameter.Size = New System.Drawing.Size(864, 393)
        Me.pnlParameter.TabIndex = 47
        '
        'grxParameter
        '
        Me.grxParameter.BackColor = System.Drawing.SystemColors.Control
        Me.grxParameter.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdParameter})
        Me.grxParameter.Location = New System.Drawing.Point(40, 48)
        Me.grxParameter.Name = "grxParameter"
        Me.grxParameter.Size = New System.Drawing.Size(120, 96)
        Me.grxParameter.TabIndex = 45
        Me.grxParameter.TabStop = False
        Me.grxParameter.Text = "Parameter"
        '
        'grdParameter
        '
        Me.grdParameter.AllowFilter = True
        Me.grdParameter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdParameter.AllowSort = True
        Me.grdParameter.AllowUpdate = False
        Me.grdParameter.AlternatingRows = True
        Me.grdParameter.CaptionHeight = 17
        Me.grdParameter.CollapseColor = System.Drawing.Color.Black
        Me.grdParameter.DataChanged = False
        Me.grdParameter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdParameter.ExpandColor = System.Drawing.Color.Black
        Me.grdParameter.FetchRowStyles = True
        Me.grdParameter.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdParameter.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.grdParameter.Location = New System.Drawing.Point(8, 16)
        Me.grdParameter.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.grdParameter.Name = "grdParameter"
        Me.grdParameter.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdParameter.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdParameter.PreviewInfo.ZoomFactor = 75
        Me.grdParameter.PrintInfo.ShowOptionsDialog = False
        Me.grdParameter.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdParameter.RowDivider = GridLines3
        Me.grdParameter.RowHeight = 15
        Me.grdParameter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdParameter.ScrollTips = False
        Me.grdParameter.Size = New System.Drawing.Size(96, 48)
        Me.grdParameter.TabIndex = 3
        Me.grdParameter.Text = "C1TrueDBGrid1"
        Me.grdParameter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{Align" & _
        "Horz:Center;}Normal{BackColor:Control;}HighlightRow{ForeColor:HighlightText;Back" & _
        "Color:Highlight;}Style1{}OddRow{BackColor:White;}RecordSelector{AlignImage:Cente" & _
        "r;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:Contr" & _
        "olText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style" & _
        "13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" Alter" & _
        "natingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHe" & _
        "ight=""17"" FetchRowStyles=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWi" & _
        "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
        "ClientRect>0, 0, 92, 44</ClientRect><BorderSide>0</BorderSide><CaptionStyle pare" & _
        "nt=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowSt" & _
        "yle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style1" & _
        "3"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""S" & _
        "tyle12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent" & _
        "=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><Od" & _
        "dRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelec" & _
        "tor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent" & _
        "=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><S" & _
        "tyle parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent" & _
        "=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""H" & _
        "eading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""No" & _
        "rmal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""No" & _
        "rmal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading" & _
        """ me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""C" & _
        "aption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horz" & _
        "Splits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 92, 44</ClientArea></Blob>"
        '
        'frmReportSelection
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(864, 697)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlParameter, Me.Splitter2, Me.pnlRepoert_Reportbeschreibung, Me.Splitter1, Me.pnlReportgruppe, Me.pnlBottom, Me.pnlTop, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmReportSelection"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "frmReportSelection"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.dsReport, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.dsParameter, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlReportgruppe.ResumeLayout(False)
        Me.gbxReportgruppen.ResumeLayout(False)
        CType(Me.grdReportgruppen, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlRepoert_Reportbeschreibung.ResumeLayout(False)
        Me.gbxReportBeschreibung.ResumeLayout(False)
        Me.gbxReport.ResumeLayout(False)
        CType(Me.grdReport, System.ComponentModel.ISupportInitialize).EndInit()
        Me.pnlParameter.ResumeLayout(False)
        Me.grxParameter.ResumeLayout(False)
        CType(Me.grdParameter, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.OpenParameterDialog Method

Private Sub OpenParameterDialog()

Source code

[Visual Basic]
    Private Sub OpenParameterDialog()
        '*********************************************************************************************************************
        'Description:   Oeffnet die Parametersialoge
        'Input:
        'Criteria:
        'Output:
        'Erstellt   : koe 11.01.2004
        'Geaendert:
        '*********************************************************************************************************************
        Dim sDislpayResult As String
        Dim sNavigationResult As String
        Dim bDialogOK As Boolean = False
        Dim s_Result As String
        Dim s_datenherkunft As String
        Me.Cursor = Cursors.WaitCursor
        Select Case UCase(Me.grdParameter.Columns("SteuerbefehlNr").Value)
            Case 1              'STANDART
            Case 2              'PARTNERSUCHE

                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Partner"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                Me.SuspendLayout()

                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
                Me.ResumeLayout()

            Case 3          'Kalender
                Dim f As New frmCalendar()
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = ""
                    sNavigationResult = f.MonthCalendar1.SelectionStart
                    sDislpayResult = sNavigationResult
                End If
                f.Dispose()

            Case 4          'Datumbereich
                Dim f As New frmDatumSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()

            Case 5          'Dokumenttypnummer
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Dokumenttyp"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()

            Case 6          'Rollen
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Rollen"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 7          'Funktionen
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Funktionsgruppen"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 8          'Mitarbeiter
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Mitarbeiter"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If

                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 9          'Dokumentauswertung (Profil)
                Dim f As New frmProfilDokAuswertung()
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then

                    Me.Cursor = Cursors.WaitCursor
                    Me.Refresh()
                    Me.ResumeLayout()
                    bDialogOK = True
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                    s_datenherkunft = ""
                    Try
                        CreateDatasourceDokumentauswertung(CInt(sNavigationResult))

                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try
                    Me.SuspendLayout()
                End If
                f.Dispose()
                Me.Cursor = Cursors.Default

            Case 10          'Sortierung
                Dim f As New frmSortSelect()
                f.ReportID = Me.grdReport.Columns("reportNr").Value
                Try
                    f.ShowDialog()
                    If f.dialogResult = DialogResult.OK Then
                        bDialogOK = True
                        sNavigationResult = f.NavigationResult
                        sDislpayResult = f.DislpayResult
                        s_datenherkunft = ""
                    End If
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try
                f.Dispose()
            Case 11          'Team
                Dim f As New frmValueSelect()
                Me.Cursor = Cursors.WaitCursor
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Team"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 12          'Berechtigung
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Berechtigung"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If

                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 13          'Sysadminfunktion
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Sysadminfunktionen"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If

                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()
            Case 14          'Ja Nein
                Select Case Me.grdParameter.Columns("ParameterDisplayValue").Text
                    Case ""
                        Me.grdParameter.Columns("ParameterDisplayValue").Text = "Ja"
                        Me.grdParameter.Columns("ParameterNavigationValue").Text = "1"
                    Case "Ja"
                        Me.grdParameter.Columns("ParameterDisplayValue").Text = "Nein"
                        Me.grdParameter.Columns("ParameterNavigationValue").Text = "0"
                    Case "Nein"
                        Me.grdParameter.Columns("ParameterDisplayValue").Text = ""
                        Me.grdParameter.Columns("ParameterNavigationValue").Text = ""
                End Select
            Case 15          'Dokumentart
                Dim f As New frmValueSelect()
                f.datenherkunft = Me.grdParameter.Columns("datenherkunft").Text
                f.StartPosition = FormStartPosition.CenterParent
                f.SelectionType = frmValueSelect.Enum_SelelectType.ValueSelect
                f.Text = "Dokumentart"
                If Me.grdParameter.Columns("ParameterNavigationValue").Text = "" Then
                    f.NavigationResult = ""
                    f.DislpayResult = ""
                Else
                    f.NavigationResult = CType(Me.grdParameter.Columns("ParameterNavigationValue").Text, String)
                    f.DislpayResult = CType(Me.grdParameter.Columns("ParameterDisplayValue").Text, String)
                End If
                f.ShowDialog()
                If f.dialogResult = DialogResult.OK Then
                    bDialogOK = True
                    s_datenherkunft = f.datenherkunft
                    sNavigationResult = f.NavigationResult
                    sDislpayResult = f.DislpayResult
                End If
                f.Dispose()

            Case Else
                MessageBox.Show(MyTxt.gettext(18), "Falsche Steuerbefehl Nr.", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
        End Select
        '===============================================================================
        'Spalten im Grid aktualisieren
        '===============================================================================
        Me.Cursor = Cursors.Default
        If bDialogOK = True Then
            Me.grdParameter.Columns("ParameterNavigationValue").Text = sNavigationResult
            Me.grdParameter.Columns("ParameterDisplayValue").Text = sDislpayResult
            Me.grdParameter.Columns("datenherkunft").Text = s_datenherkunft
        End If
        Me.ActiveControl = Me.ToolBar1
        Me.ActiveControl = Me.grdParameter

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.PharseDatenherkunft Method

Private Function PharseDatenherkunft( _
   ByVal Datenherkunft As String, _
   ByRef Parameterwert As String _
) As Boolean

Parameters

Datenherkunft
Required.
Parameterwert
Required.

Source code

[Visual Basic]
    Private Function PharseDatenherkunft(ByVal Datenherkunft As String, ByRef Parameterwert As String) As Boolean
        '===============================================================================
        'Desc       : Ermitteln von dynamischen Datum im Datumbereich
        'Input 	    :
        'Kriterium  :
        'Updatewert :
        'Output	    :
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim a_Datenherkunft() As String
        Dim StartDate As String
        Dim EndDate As String
        a_Datenherkunft = Split(Datenherkunft, ";")

        Select Case Microsoft.VisualBasic.Left(Datenherkunft, 2)
            Case "0;"           'Von_Bis
                PharseDatenherkunft = False

            Case "1;"           'Datum_Bis_Heute
                StartDate = a_Datenherkunft(1)
                EndDate = Format(Now(), "dd.MM.yyyy")
                PharseDatenherkunft = True

            Case "2;"           'Tage_Bis_Heute
                StartDate = Format(DateAdd(DateInterval.Day, -a_Datenherkunft(1), Now()), "dd.MM.yyyy")
                EndDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now), getlastDayInMonth(Now())), "dd.MM.yyyy")
                PharseDatenherkunft = True

            Case "3;"           'Aktueller_Monat
                StartDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now), 1), "dd.MM.yyyy")
                EndDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now), getlastDayInMonth(Now())), "dd.MM.yyyy")
                Parameterwert = "BETWEEN " & StartDate & " AND " & EndDate
                PharseDatenherkunft = True

            Case "4;"           'Aktueller_MonatVon_Bis
                StartDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), a_Datenherkunft(1)), "dd.MM.yyyy")
                If a_Datenherkunft(2) = "Letzter Tag" Then
                    EndDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), getlastDayInMonth(Now())), "dd.MM.yyyy")
                Else
                    EndDate = Format(DateSerial(DatePart(DateInterval.Year, Now()), DatePart(DateInterval.Month, Now()), a_Datenherkunft(3)), "dd.MM.yyyy")
                End If
                Parameterwert = "BETWEEN " & StartDate & " AND " & EndDate
                PharseDatenherkunft = True

            Case Else
                StartDate = Format(Now(), "dd.MM.yyyy")
                EndDate = Format(Now(), "dd.MM.yyyy")
                PharseDatenherkunft = False

        End Select
        Parameterwert = "BETWEEN " & StartDate & " AND " & EndDate

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet, _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid _
)

Parameters

ds
Required.
grd
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet, ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid)

        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim cols(grd.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        Dim DisplayColumnsCount As Integer
        Dim aSpalten(0, 0) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim Reihe As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim iMaxSortOrderValue As Integer = 0
        Dim dsMaxSortOrder As New DataSet()
        Dim bSetNewSortOrder As Boolean = True
        Dim iSpaltenOffset As Integer = 0 'Offset wenn Nothing in Array

        '============ Bestimmt Anzahl Displaycolumn und MaxValue Sortorder
        'Dim ssql As String
        'ssql = "SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'"
        Dim daMaxSortOrder As New SqlDataAdapter("SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'", Globals.sConnectionString)
        daMaxSortOrder.Fill(dsMaxSortOrder)
        DisplayColumnsCount = grd.Splits(0).DisplayColumns.Count - 1
        iMaxSortOrderValue = dsMaxSortOrder.Tables(0).Rows(0).Item(0)
        ReDim aSpalten(iMaxSortOrderValue - 1, 0)       'Array für Anzahlen definieren

        Try
            t = ds.Tables(0)
            ts.Tabelle = Me.TableName
            For i = 0 To grd.Columns.Count - 1
                s = grd.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                grd.Columns(i).Caption = ts.spaltenname
                If ts.ColWith = 0 Then
                    grd.Splits(0).DisplayColumns(i).Width = 0
                    grd.Splits(0).DisplayColumns(i).Visible = False
                Else
                    grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If

                'If grd.Columns(i).Caption = "" Then
                '    'grd.Splits(0).DisplayColumns(i).Visible = False
                '    grd.Splits(0).DisplayColumns(i).Width = 0
                '    'grd.Columns(i).Caption = grd.Columns(i).DataField
                'Else
                '    grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
                'End If
                If ts.locked Then
                    grd.Splits(0).DisplayColumns(i).Locked = True
                End If

                If ts.AlsHacken Then
                    grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If grd.Columns(i).DataField = "aktiv" Then
                    grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    grd.Columns(i).ValueItems.DefaultItem = True
                    grd.Columns(i).DefaultValue = True
                    grd.Columns(i).FilterText = True
                End If
                If grd.Columns(i).DataField = "erstellt_am" Then
                    grd.Columns(i).DefaultValue = Now
                End If

                '============ Aktuelle Spalte in ArraySpalten schreiben
                '============ Sortorder darf nicht 0 sein
                If iMaxSortOrderValue > 0 Then
                    If ts.Order = 0 Then
                        MessageBox.Show("Fehler Reihenfolge" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit dem Wert 0 sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Sortierreihenfolge 0", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                    Else
                        Reihe = grd.Splits(0).DisplayColumns(i)
                        If Not aSpalten(ts.Order - 1, 0) Is Nothing Then
                            '============ Arrayplatz bereits bleget
                            '                        MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Prüfen Sie die Sortierreihenfoge der Tabelle " & Me.TableName & " in der Systemadministration Spalten!", MessageBoxButtons.OK, "Sortierreihenfolge ", MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                            MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit 2 gleichen Werten sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Doppelte Sortier-Nummer " & ts.Order, MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                            'bSetNewSortOrder = False
                        End If
                        If ts.Order > 0 And aSpalten(ts.Order - 1, 0) Is Nothing Then
                            '============ Aktuelle Spalte in ArraySpalten schreiben
                            aSpalten(ts.Order - 1, 0) = Reihe
                        End If
                    End If
                End If
            Next

            If iMaxSortOrderValue > 0 And bSetNewSortOrder = True Then
                '===============================================================================
                'Wenn in der Sortierreihenfoge keine 0 steht werden die Spalten neu Sortiert
                '===============================================================================
                Try
                    '============ Spalten löschen
                    For i = 0 To DisplayColumnsCount
                        grd.Splits(0).DisplayColumns.RemoveAt(0)
                    Next
                Catch
                End Try
                '============ Spalten nachh Sortorder einfügen
                For i = 0 To iMaxSortOrderValue - 1
                    Try
                        If Not aSpalten(i, 0) Is Nothing Then
                            If aSpalten(i, 0).Width > 0 Then
                                grd.Splits(0).DisplayColumns.Insert(i - iSpaltenOffset, aSpalten(i, 0))
                            Else
                                iSpaltenOffset += 1
                            End If
                        Else
                            iSpaltenOffset += 1
                        End If
                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try

                Next
            End If
            dsMaxSortOrder = Nothing
            daMaxSortOrder = Nothing

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.SpaltenTitel_AktualisierenHUT Method

Public Sub SpaltenTitel_AktualisierenHUT( _
   ByVal ds As DataSet, _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid _
)

Parameters

ds
Required.
grd
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_AktualisierenHUT(ByVal ds As DataSet, ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid)
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim anzcols As Integer
        Dim cols(grd.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String
        anzcols = grd.Splits(0).DisplayColumns.Count
        t = ds.Tables(0)
        ts.Tabelle = TableName
        For i = 0 To grd.Columns.Count - 1
            s = grd.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            grd.Columns(i).Caption = ts.spaltenname
            'If grd.Columns(i).Caption = "" Then
            If ts.ColWith = 0 Then
                grd.Splits(0).DisplayColumns(i).Width = 0
                grd.Splits(0).DisplayColumns(i).Visible = False
            Else
                grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            '            If grd.Columns(i).Caption = "" Then grd.Splits(0).DisplayColumns(i).Width = 0
            If ts.locked Then
                grd.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If grd.Columns(i).DataField = "aktiv" Then
                grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                grd.Columns(i).ValueItems.DefaultItem = True
                grd.Columns(i).DefaultValue = True
                grd.Columns(i).FilterText = True
            End If
            If grd.Columns(i).DataField = "erstellt_am" Then
                grd.Columns(i).DefaultValue = Now
            End If
            'grd.Splits(0).DisplayColumns.Insert(ts.Order, grd.Splits(0).DisplayColumns(i))
            'grd.Splits(0).DisplayColumns.RemoveAt(i)
            '            cols(ts.Order) = grd.Splits(0).DisplayColumns(i)
        Next
        '       For i = 0 To grd.Splits(0).DisplayColumns.Count - 1
        '          grd.Splits(0).DisplayColumns.RemoveAt(0)
        '     Next
        '    For i = anzcols To 0 Step -1
        '       grd.Splits(0).DisplayColumns.Insert(0, cols(i))
        '  Next
        ' cols = Nothing
        '
        'Form_As_SelectForm()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick

        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Close()
            Case 2 'Speichern
                Dim f As New frmParameterSetName()
                'f.MdiParent = Me.ParentForm
                f.DatenSpeichern = True
                f.Eintrag = "Parameterset speichern"
                f.ReportNr = Me.grdReport.Columns("reportnr").Value
                f.ParameterSetNameID = Me.ParameterSetNameID
                Me.ParameterSetNameID = f.TransferKey
                f.ParameterDataset = Me.dsParameter
                f.DatenModus = f.Enum_DatenModus.Speichern
                f.ShowDialog()
                f.Dispose()
            Case 1  'laden
                Dim f As New frmParameterSetName()
                ' f.MdiParent = Me.ParentForm
                f.DatenSpeichern = False
                f.ReportNr = Me.grdReport.Columns("reportnr").Value
                f.Eintrag = "Parameterset laden"
                f.DatenModus = f.Enum_DatenModus.Laden
                f.ShowDialog()
                Me.grxParameter.Text = "Parameter " & f.ParameterSetName
                Me.ParameterSetNameID = f.TransferKey
                grxParameter.Text = "Parameter " & f.ParameterSetName
                f.Dispose()
                If Me.ParameterSetNameID > 0 Then
                    ClearParameterFields()
                    loadParameterList() 'Laden der Parameter in die Tabelle
                End If
            Case 3  'ClearParameter
                ClearParameterFields()
            Case 5  'Preview
                Me.Cursor = Cursors.WaitCursor
                Dim f As New frmReporting()
                Dim objReport As New edokadb.clsReporting_Dokumenttyp()
                Dim ParameterCollection As New Collection()
                Dim Dokument_Temp As String
                If ValidateParameterfields() = True Then

                    '=======================================
                    'Dokument Speichern
                    '=======================================
                    Dokument_Temp = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String)
                    objReport.Get_DocumentFrom_DB("reportNr", grdReport.Columns("reportNr").Text, "report", "reportfile", Dokument_Temp, grdReport.Columns("dateiname").Value)
                    objReport = Nothing
                    f.WindowTitel = grdReport.Columns("report").Text
                    ParameterCollection = FillParameterCollection()

                    If Not f.show_report(grdReport.Columns("dateiname").Text, ParameterCollection) Then
                        If MyMsg.Show_MessageYesNo(217) Then  'Sie haben keine Parameter übergeben! Die Datenaufbereitung könnter längere Zei
                            Exit Sub
                        End If
                    End If
                    ' f.MdiParent = Me.ParentForm
                    Try

                        f.Show()

                    Catch ex As Exception
                        Me.Cursor = Cursors.Default
                        MsgBox(ex.Message)
                    End Try

                End If
                Me.Cursor = Cursors.Default

            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.ValidateParameterfields Method

Private Function ValidateParameterfields() As Boolean

Source code

[Visual Basic]
    Private Function ValidateParameterfields() As Boolean
        '===============================================================================
        'Desc       : Prüfene der Parameter auf Zwingende Felder und Formate
        'Input      :
        'Output     :
        'Erstellt   : koe 20.10.2003
        'Geaendert  :
        '===============================================================================
        Dim lcnt As Long
        ValidateParameterfields = True
        For lcnt = 0 To grdParameter.Splits(0).Rows.Count - 1
            'Validierung auf zwingend
            'If Me.grdParameter.Columns("eingabe_zwingend").Value <> 0 Then
            If Me.grdParameter.Columns("eingabe_zwingend").CellText(lcnt) = True Then
                If Me.grdParameter.Columns("ParameterNavigationValue").CellText(lcnt) = "" Then
                    MessageBox.Show("Der Parameterwert " & Me.grdParameter.Columns("Parameter").CellText(lcnt) & " verlangt eine Eingabe?", "Auswertung", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                    ValidateParameterfields = False
                    Exit For
                End If
            End If
        Next

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.frmReportSelection_Closing Method

Private Sub frmReportSelection_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReportSelection_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.frmReportSelection_Load Method

Private Sub frmReportSelection_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReportSelection_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Try
            Me.Cursor = Cursors.WaitCursor
            grdReportgruppen.Dock = DockStyle.Fill

            grdReport.Dock = DockStyle.Fill

            gbxReportBeschreibung.Dock = DockStyle.Fill
            txtReportDescription.Dock = DockStyle.Fill

            grxParameter.Dock = DockStyle.Fill
            grdParameter.Dock = DockStyle.Fill

            'Me.grdReportgruppen.Dock = DockStyle.Fill
            'Me.grdReport.Dock = DockStyle.Fill
            'Me.grdParameter.Dock = DockStyle.Fill
            'Me.txtReportDescription.Dock = DockStyle.Fill

            Me.SqlConnection1.ConnectionString = Globals.sConnectionString
            Me.SqlConnection1.Open()

            ' Nur für den aktuell gewählten Mandanten die Daten auslesen
            Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@MitarbeiterNr", Globals.MitarbeiterNr)
            Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantNr", Globals.MandantNr)
            '============ Datenanbindung Reportgruppen
            SqlDataAdapter1.Fill(Me.DataSet1, "Mitarbeiter_ReportGruppe")
            Me.TableName = Me.DataSet1.Tables(0).TableName
            Me.grdReportgruppen.DataMember = Me.TableName
            Me.grdReportgruppen.DataSource = Me.DataSet1
            If Me.grdReportgruppen.Splits(0).Rows.Count > 0 Then
                Me.m_iReportgruppeNr = Me.grdReportgruppen.Columns("reportgruppeNr").Value
            Else
                Me.m_iReportgruppeNr = 0
            End If
            SpaltenTitel_Aktualisieren(Me.DataSet1, Me.grdReportgruppen)

            '============ Datenanbindung Reportgruppen
            FillReport()        'Füllen der Reportliste anhand der reportgruppeNr
            Me.TableName = Me.dsReport.Tables(0).TableName
            Me.grdReport.DataMember = Me.TableName
            Me.grdReport.DataSource = Me.dsReport
            SpaltenTitel_Aktualisieren(Me.dsReport, Me.grdReport)

            '============ Datenanbindung Parameter
            FillParameter()        'Füllen der Reportliste anhand der reportgruppeNr
            Me.TableName = Me.dsParameter.Tables(0).TableName
            Me.grdParameter.DataMember = Me.TableName
            Me.grdParameter.DataSource = Me.dsParameter
            SpaltenTitel_Aktualisieren(Me.dsParameter, Me.grdParameter)
            Me.grdParameter.Splits(0).DisplayColumns("ParameterDisplayValue").Button = True
            Me.grdParameter.Splits(0).DisplayColumns("ParameterDisplayValue").FetchStyle = True

            'grdParameter.Splits(0).DisplayColumns(0).Button = True

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
        Try
            Globals.WinPos.Get_Position(Me)
        Catch ex As Exception
            MsgBox(ex.Message)

        Finally
        End Try

        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.frmReportSelection_Resize Method

Private Sub frmReportSelection_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReportSelection_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Dim iHight As Integer

        iHight = Me.ClientSize.Height - (ToolBar1.Height + pnlTop.Height + Splitter1.Height + Splitter2.Height + pnlBottom.Height)
        'iHight = Me.Height - Me.ToolBar1.Height - Me.Splitter2.Height - Me.Splitter4.Height - Me.Panel1.Height - Me.Panel3.Height
        pnlReportgruppe.Height = iHight / 3
        pnlRepoert_Reportbeschreibung.Height = iHight / 3

        Me.gbxReportgruppen.Width = pnlTop.Width / 2
        Me.gbxReport.Width = pnlTop.Width / 2
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.gbxReportgruppen_Enter Method

Private Sub gbxReportgruppen_Enter( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles gbxReportgruppen.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub gbxReportgruppen_Enter(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles gbxReportgruppen.Enter

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.getlastDayInMonth Method

Private Function getlastDayInMonth( _
   ByVal Datum As Date _
) As Integer

Parameters

Datum
Required.

Source code

[Visual Basic]
    Private Function getlastDayInMonth(ByVal Datum As Date) As Integer
        '===============================================================================
        'Desc       : Ermittelt den letzten Tag des Monats
        'Input 	    : Datum
        'Kriterium  :
        'Updatewert :
        'Output	    : Letzter Tag des Monats
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim iFirstDayNextMonat As Integer
        Dim iMonat As Integer
        Dim dDate As Date
        iMonat = DatePart(DateInterval.Month, Datum, FirstDayOfWeek.Monday)
        dDate = DateSerial(DatePart(DateInterval.Year, Datum, FirstDayOfWeek.Monday), iMonat + 1, 1)
        iFirstDayNextMonat = DatePart(DateInterval.Day, DateAdd(DateInterval.Day, -1, dDate), FirstDayOfWeek.Monday)

        getlastDayInMonth = iFirstDayNextMonat

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_BeforeColEdit Method

Private Sub grdParameter_BeforeColEdit( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs _
) Handles grdParameter.BeforeColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_BeforeColEdit(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs) Handles grdParameter.BeforeColEdit
        Select Case Me.grdParameter.Columns("Datenherkunft").Text
            'Case "&Funktionsgruppe&", "&Mitarbeiter&", "&Rollen&", "&Dokumenttyp&"
        Case Else
                MessageBox.Show("Diese Spalte kann nicht editiert werden!" & vbLf & "Wählen Sie einen Wert aus der Liste aus, indem sie die Schaltfläche im Feld betätigen.", "Gesperrtes Feld", MessageBoxButtons.OK, MessageBoxIcon.Information)
                MyMsg.show_standardmessage(215, MsgBoxStyle.Exclamation)  'Der ertste Datumswert  #1 entspricht nicht einem Datumformat! Format = DD.MM.JJJJ

                e.Cancel = True
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_BeforeColUpdate Method

Private Sub grdParameter_BeforeColUpdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles grdParameter.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_BeforeColUpdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles grdParameter.BeforeColUpdate
        Dim aParametervalue() As String
        Select Case Me.grdParameter.Columns("feldtypNr").CellText(grdParameter.Bookmark)
            Case 2, 3   '2 = Ganzzahl, 3 = Dezimalzahl 2"
                If Not Me.grdParameter.Columns("ParameterNavigationValue") Is System.DBNull.Value And Me.grdParameter.Columns("ParameterNavigationValue").Value <> "" Then
                    If Not IsNumeric(Me.grdParameter.Columns("ParameterNavigationValue").Value) Then
                        MyMsg.show_standardmessage_ReplaceText(212, MsgBoxStyle.Exclamation, Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark), Me.grdParameter.Columns("Format").CellText(grdParameter.Bookmark))  'Ihre Eingabe im Parameterwert #1 entspricht nicht der Vormatvorlage! Format = #2
                        e.Cancel = True
                    End If
                End If
            Case 4      'Boolean
                If Not Me.grdParameter.Columns("ParameterNavigationValue") Is System.DBNull.Value And Me.grdParameter.Columns("ParameterNavigationValue").Value <> "" Then
                    If Not IsNumeric(Me.grdParameter.Columns("ParameterNavigationValue").Value) Then
                        MyMsg.show_standardmessage_ReplaceText(212, MsgBoxStyle.Exclamation, Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark), Me.grdParameter.Columns("Format").CellText(grdParameter.Bookmark))  'Ihre Eingabe im Parameterwert #1 entspricht nicht der Vormatvorlage! Format = #2
                        e.Cancel = True

                    End If
                End If
            Case 5      'Datum
                If Not Me.grdParameter.Columns("ParameterNavigationValue") Is System.DBNull.Value And Me.grdParameter.Columns("ParameterNavigationValue").Value <> "" Then
                    If Not IsDate(Me.grdParameter.Columns("ParameterNavigationValue").Value) Then
                        MyMsg.show_standardmessage_ReplaceText(212, MsgBoxStyle.Exclamation, Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark), Me.grdParameter.Columns("Format").CellText(grdParameter.Bookmark))  'Ihre Eingabe im Parameterwert #1 entspricht nicht der Vormatvorlage! Format = #2
                        e.Cancel = True
                    End If
                End If

            Case 6      'Datumbereich
                If Not Me.grdParameter.Columns("ParameterNavigationValue") Is System.DBNull.Value And Me.grdParameter.Columns("ParameterNavigationValue").Value <> "" Then
                    aParametervalue = Split(Me.grdParameter.Columns("ParameterNavigationValue").Value, " ")
                    If UBound(aParametervalue) = 3 Then
                        If Not IsDate(aParametervalue(1)) Then
                            MyMsg.show_standardmessage_ReplaceText(213, MsgBoxStyle.Exclamation, Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark), Me.grdParameter.Columns("Format").CellText(grdParameter.Bookmark))  'Der ertste Datumswert  #1 entspricht nicht einem Datumformat! Format = DD.MM.JJJJ
                            e.Cancel = True
                        End If

                        If Not IsDate(aParametervalue(3)) Then
                            MyMsg.show_standardmessage_ReplaceText(214, MsgBoxStyle.Exclamation, Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark), Me.grdParameter.Columns("Format").CellText(grdParameter.Bookmark))  'Der zweite Datumswert  #1 entspricht nicht einem Datumformat!Format = DD.MM.JJJJ
                            MessageBox.Show("Der zweite Datumswert  " & aParametervalue(3) & " entspricht nicht einem Datumformat! " & vbLf & vbLf & "Format = DD.MM.JJJJ", "Auswertung", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                            e.Cancel = True
                        End If

                        If UCase(aParametervalue(0)) <> "BETWEEN" Then
                            MessageBox.Show("Das erste Wort muss BETWEEN heissen! " & vbLf & vbLf & "Eingabeformat = BETWEEN [Datum] AND [DATUM]", "Auswertung", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                            e.Cancel = True
                        End If

                        If UCase(aParametervalue(2)) <> "AND" Then
                            MessageBox.Show("Das Wort zwischen den Datum muss AND sein! " & vbLf & vbLf & "Eingabeformat = BETWEEN [Datum] AND [DATUM]", "Auswertung", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                            e.Cancel = True
                        End If
                    Else
                        MessageBox.Show("Falsche Parameteranzahl in " & Me.grdParameter.Columns("Parameter").CellText(grdParameter.Bookmark) & "!" & vbLf & vbLf & "Eingabeformat = BETWEEN [Datum] AND [DATUM]", "Auswertung", MessageBoxButtons.OK, MessageBoxIcon.Exclamation, MessageBoxDefaultButton.Button1)
                        e.Cancel = True

                    End If
                End If

        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_ButtonClick Method

Private Sub grdParameter_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles grdParameter.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_ButtonClick(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles grdParameter.ButtonClick
        OpenParameterDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_DoubleClick Method

Private Sub grdParameter_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles grdParameter.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles grdParameter.DoubleClick
        OpenParameterDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_FetchCellStyle Method

Private Sub grdParameter_FetchCellStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs _
) Handles grdParameter.FetchCellStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_FetchCellStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs) Handles grdParameter.FetchCellStyle
        If Me.grdParameter.Columns("eingabe_zwingend").CellValue(e.Row) = True Then
            e.CellStyle.BackColor = System.Drawing.Color.Pink
        End If
        If Me.grdParameter.Columns("SteuerbefehlNr").CellValue(e.Row) = 14 Then     'JaNeinFeld
            'Me.grdParameter.Columns("SteuerbefehlNr").CellValue(e.Row)
            'e.CellStyle.
            'grdParameter.Columns("ParameterDisplayValue").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            'e.CellStyle.d = System.Drawing.Color.Pink
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdParameter_KeyDown Method

Private Sub grdParameter_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles grdParameter.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdParameter_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles grdParameter.KeyDown
        If e.KeyCode = Keys.Delete Then
            grdParameter.Columns("ParameterDisplayValue").Text = ""
            grdParameter.Columns("ParameterNavigationValue").Text = ""

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdReport_MouseDown Method

Private Sub grdReport_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles grdReport.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdReport_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles grdReport.MouseDown
        If Me.grdReport.Splits(0).Rows.Count > 0 Then
            Me.m_iReportNr = Me.grdReport.Columns("reportNr").Value
        Else
            Me.m_iReportNr = 0
        End If
        FillParameter()        'Füllen der Parameterliste anhand der reportNr
        Me.txtReportDescription.Text = grdReport.Columns("beschreibung").CellValue(grdReport.Row)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdReport_RowColChange Method

Private Sub grdReport_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdReport.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdReport_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdReport.RowColChange
        If Me.grdReport.Splits(0).Rows.Count > 0 Then
            Me.m_iReportNr = Me.grdReport.Columns("reportNr").Value
        Else
            Me.m_iReportNr = 0
        End If
        FillParameter()        'Füllen der Parameterliste anhand der reportNr
        Me.txtReportDescription.Text = grdReport.Columns("beschreibung").CellValue(grdReport.Row)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.grdReportgruppen_RowColChange Method

Private Sub grdReportgruppen_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles grdReportgruppen.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdReportgruppen_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles grdReportgruppen.RowColChange

        'If Me.grdReport.Splits(0).Rows.Count > 0 Then
        Me.m_iReportgruppeNr = Me.grdReportgruppen.Columns("reportgruppeNr").Value
        'Else
        '    Me.m_iReportgruppeNr = 0
        'End If
        FillReport()        'Füllen der Reportliste anhand der reportgruppeNr

        If Me.grdReport.Splits(0).Rows.Count = 1 Then
            Me.m_iReportNr = Me.grdReport.Columns("reportNr").Value
            FillParameter()        'Füllen der Parameterliste anhand der reportNr
            Me.txtReportDescription.Text = grdReport.Columns("beschreibung").CellValue(grdReport.Row)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.loadParameterList Method

Private Sub loadParameterList()

Source code

[Visual Basic]
    Private Sub loadParameterList()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "sp_ParameterSetListe_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        scmCmdToExecute.Parameters.Clear()
        scmCmdToExecute.Parameters.Add(New SqlParameter("@ParameterSetNameID", SqlDbType.Int, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.ParameterSetNameID))
        sdaAdapter.Fill(dtToReturn)
        FillParameterRows(dtToReturn)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection.mnuExit_Click Method

Private Sub mnuExit_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuExit_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs)
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportSelection Fields

frmReportSelection overview

Fields

field DataSet1
field ImageList1
field MainMenu1
field Splitter1
field Splitter2
field Splitter3
field Splitter4
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand4
field SqlUpdateCommand1
field ToolBar1
field ToolBarButton1
field ToolBtnClearParameter
field ToolBtnExit
field ToolBtnOpenParSet
field ToolBtnPreview
field ToolBtnSave
field components
field daParameter
field daReport
field dsParameter
field dsReport
field gbxReport
field gbxReportBeschreibung
field gbxReportgruppen
field gbxReserve
field grdParameter
field grdReport
field grdReportgruppen
field grxParameter
field m_iParameterSetNameID
field m_iReportNr
field m_iReportgruppeNr
field m_sTableName
field pnlBottom
field pnlParameter
field pnlRepoert_Reportbeschreibung
field pnlReportgruppe
field pnlTop
field txtReportDescription

See Also

frmReportSelection Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


Splitter3 Variable

Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


Splitter4 Variable

Friend WithEvents Splitter4 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter4 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBtnClearParameter Variable

Friend WithEvents ToolBtnClearParameter As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnClearParameter As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBtnOpenParSet Variable

Friend WithEvents ToolBtnOpenParSet As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnOpenParSet As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBtnPreview Variable

Friend WithEvents ToolBtnPreview As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnPreview As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


ToolBtnSave Variable

Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


daParameter Variable

Friend WithEvents daParameter As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents daParameter As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


daReport Variable

Friend WithEvents daReport As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents daReport As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


dsParameter Variable

Friend WithEvents dsParameter As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents dsParameter As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


dsReport Variable

Friend WithEvents dsReport As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents dsReport As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


gbxReport Variable

Friend WithEvents gbxReport As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents gbxReport As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


gbxReportBeschreibung Variable

Friend WithEvents gbxReportBeschreibung As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents gbxReportBeschreibung As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


gbxReportgruppen Variable

Friend WithEvents gbxReportgruppen As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents gbxReportgruppen As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


gbxReserve Variable

Friend WithEvents gbxReserve As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents gbxReserve As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


grdParameter Variable

Friend WithEvents grdParameter As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdParameter As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


grdReport Variable

Friend WithEvents grdReport As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdReport As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


grdReportgruppen Variable

Friend WithEvents grdReportgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdReportgruppen As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


grxParameter Variable

Friend WithEvents grxParameter As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents grxParameter As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


m_iParameterSetNameID Variable

Private m_iParameterSetNameID As Integer

Source code

[Visual Basic]
    Private m_iParameterSetNameID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


m_iReportNr Variable

Private m_iReportNr As Integer

Source code

[Visual Basic]
    Private m_iReportNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


m_iReportgruppeNr Variable

Private m_iReportgruppeNr As Integer

Source code

[Visual Basic]
    Private m_iReportgruppeNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


m_sTableName Variable

Private m_sTableName As String

Source code

[Visual Basic]
    Private m_sTableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


pnlBottom Variable

Friend WithEvents pnlBottom As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlBottom As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


pnlParameter Variable

Friend WithEvents pnlParameter As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlParameter As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


pnlRepoert_Reportbeschreibung Variable

Friend WithEvents pnlRepoert_Reportbeschreibung As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlRepoert_Reportbeschreibung As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


pnlReportgruppe Variable

Friend WithEvents pnlReportgruppe As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlReportgruppe As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


pnlTop Variable

Friend WithEvents pnlTop As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlTop As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


txtReportDescription Variable

Friend WithEvents txtReportDescription As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtReportDescription As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportSelection


frmReportViewer Class

For a list of all members of this type, see frmReportViewer Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmReportViewer

Public Class frmReportViewer
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReportViewer Members


frmReportViewer Members

frmReportViewer overview

Constructors

constructor frmReportViewer Constructor

Properties

property WindowTitel

Methods

method Dispose
method FileExist
method InitializeComponent
method ToolBar1_ButtonClick
method frmReportViewer_Load
method show_reportWithParameter

Fields

field ImageList1
field ToolBar1
field components
field crParameterDiscreteValue
field crParameterFieldDefinition
field crParameterFieldDefinitions
field crParameterValues
field crviewer
field i
field m_sWindowTitel
field mnuClose
field rpt
field s
field tbCurrent
field tliCurrent

See Also

frmReportViewer Class


frmReportViewer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer Properties

frmReportViewer overview

Properties

property WindowTitel

See Also

frmReportViewer Class


frmReportViewer.WindowTitel Property

Property WindowTitel() As String

Source code

[Visual Basic]
    Property WindowTitel() As String
        Get
            Return m_sWindowTitel
        End Get
        Set(ByVal Value As String)
            m_sWindowTitel = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer Methods

frmReportViewer overview

Methods

method Dispose
method FileExist
method InitializeComponent
method ToolBar1_ButtonClick
method frmReportViewer_Load
method show_reportWithParameter

See Also

frmReportViewer Class


frmReportViewer.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer.FileExist Method

Private Function FileExist( _
   ByVal FilePath As String, _
   ByVal FileName As String _
) As Boolean

Parameters

FilePath
Required.
FileName
Required.

Source code

[Visual Basic]
    Private Function FileExist(ByVal FilePath As String, ByVal FileName As String) As Boolean
        '===============================================================================
        'Ermittelt ob eine Datei vorhanden ist.
        'Input : Verzeichnis
        'Output: True/False
        'Erstellt  : koe 20.10.2003
        'Geaendert :
        '===============================================================================
        Try
            If Microsoft.VisualBasic.Right(FilePath, 1) <> "\" Then
                FilePath = FilePath + "\"
            End If

            If System.IO.Directory.Exists(FilePath) Then
                If System.IO.File.Exists(FilePath & FileName) Then
                    FileExist = True
                Else
                    MyMsg.show_standardmessage_ReplaceText(210, MsgBoxStyle.Exclamation, FilePath & " " & FileName, "") 'Datei  #1 nicht gefunden!
                    FileExist = False
                End If
            Else
                MyMsg.show_standardmessage_ReplaceText(210, MsgBoxStyle.Exclamation, FilePath, "") '"Verzeichnis " & FilePath & " nicht gefunden!
                FileExist = False
            End If
        Catch ex As Exception
            MessageBox.Show(ex.Message, "Reportdatei", MessageBoxButtons.OK, MessageBoxIcon.Exclamation)
            FileExist = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmReportViewer))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.mnuClose = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.crviewer = New CrystalDecisions.Windows.Forms.CrystalReportViewer()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.mnuClose})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(816, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'mnuClose
        '
        Me.mnuClose.ImageIndex = 4
        Me.mnuClose.ToolTipText = "Schliessen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'crviewer
        '
        Me.crviewer.ActiveViewIndex = -1
        Me.crviewer.Dock = System.Windows.Forms.DockStyle.Fill
        Me.crviewer.Location = New System.Drawing.Point(0, 25)
        Me.crviewer.Name = "crviewer"
        Me.crviewer.ReportSource = "C:\EDOKA\EDOKA\Report\Reports\MetaDataReport.rpt"
        Me.crviewer.ShowCloseButton = False
        Me.crviewer.ShowGroupTreeButton = False
        Me.crviewer.ShowRefreshButton = False
        Me.crviewer.Size = New System.Drawing.Size(816, 500)
        Me.crviewer.TabIndex = 1
        '
        'frmReportViewer
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(816, 525)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.crviewer, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmReportViewer"
        Me.Text = "Report-Viewer"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer.frmReportViewer_Load Method

Private Sub frmReportViewer_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReportViewer_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer.show_reportWithParameter Method

Public Function show_reportWithParameter( _
   ByVal ReportName As String, _
   ByVal param As String _
) As Boolean

Parameters

ReportName
Required.
param
Required.

Source code

[Visual Basic]
    Public Function show_reportWithParameter(ByVal ReportName As String, ByVal param As String) As Boolean
        '===============================================================================
        'Desc       : Anziegen des gewählten report
        'Input 	    : Reportname
        'Kriterium  : Der Report muss im Verzeichenis welches in der Tabelle Applikation
        '             hinterlegt ist, vorhanden sein
        'Erstellt   : bud 25.05.2005
        'Geaendert  :
        '===============================================================================
        Dim sReportpath As String
        If m_sWindowTitel <> "" Then
            Me.Text = m_sWindowTitel
        End If
        Try
            sReportpath = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String)
            If Microsoft.VisualBasic.Right(sReportpath, 1) <> "\" Then
                sReportpath = sReportpath & "\"
            End If
            '=============================================
            'Fileprüfung
            '=============================================
            If FileExist(sReportpath, ReportName) = True Then
                rpt.Load(sReportpath & ReportName)
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

                '***************************************************
                '***************************************************
                Dim intCounter As Integer
                intCounter = rpt.DataDefinition.ParameterFields.Count

                If intCounter = 1 Then
                    If InStr(rpt.DataDefinition.ParameterFields(0).ParameterFieldName, ".", CompareMethod.Text) > 0 Then
                        intCounter = 0
                    End If

                End If

                Dim strParValPair() As String
                Dim strVal() As String
                Dim index As Integer
                Dim paraValue As New CrystalDecisions.Shared.ParameterDiscreteValue()
                Dim currValue As CrystalDecisions.Shared.ParameterValues
                Dim ConInfo As New CrystalDecisions.Shared.TableLogOnInfo()
                Dim mySubReportObject As CrystalDecisions.CrystalReports.Engine.SubreportObject
                Dim mySubRepDoc As New CrystalDecisions.CrystalReports.Engine.ReportDocument()
                Dim intCounter1 As Integer

                If intCounter > 0 And Trim(param) <> "" Then
                    strParValPair = param.Split(CType("&", Char))

                    'For i = 0 To intCounter - 1
                    '    If rpt.DataDefinition.ParameterFields(i).Name = "@MANr" Then
                    '        strVal = strParValPair(0).Split(CType("=", Char))
                    '        paraValue.Value = strVal(1)
                    '        currValue = rpt.DataDefinition.ParameterFields(strVal(0)).CurrentValues
                    '        currValue.Add(paraValue)
                    '        rpt.DataDefinition.ParameterFields(i).ApplyCurrentValues(currValue)
                    '    End If
                    '    If rpt.DataDefinition.ParameterFields(i).Name = "@MetDataOption" Then
                    '        strVal = strParValPair(1).Split(CType("=", Char))
                    '        paraValue.Value = strVal(1)
                    '        currValue = rpt.DataDefinition.ParameterFields(strVal(0)).CurrentValues
                    '        currValue.Add(paraValue)
                    '        rpt.DataDefinition.ParameterFields(i).ApplyCurrentValues(currValue)
                    '    End If
                    '    If rpt.DataDefinition.ParameterFields(i).Name = "@OfficeDokID" Then
                    '        strVal = strParValPair(2).Split(CType("=", Char))
                    '        paraValue.Value = strVal(1)
                    '        currValue = rpt.DataDefinition.ParameterFields(strVal(0)).CurrentValues
                    '        currValue.Add(paraValue)
                    '        rpt.DataDefinition.ParameterFields(i).ApplyCurrentValues(currValue)
                    '    End If
                    'Next

                    For index = 0 To UBound(strParValPair)
                        If InStr(strParValPair(index), "=") > 0 Then
                            strVal = strParValPair(index).Split(CType("=", Char))
                            paraValue.Value = strVal(1)
                            currValue = rpt.DataDefinition.ParameterFields(strVal(0)).CurrentValues
                            currValue.Add(paraValue)
                            rpt.DataDefinition.ParameterFields(strVal(0)).ApplyCurrentValues(currValue)
                        End If
                    Next
                End If

                ConInfo.ConnectionInfo.UserID = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("user_report"), String)
                ConInfo.ConnectionInfo.Password = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_report"), String)
                ConInfo.ConnectionInfo.ServerName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_server"), String)
                ConInfo.ConnectionInfo.DatabaseName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_db"), String)

                For intCounter = 0 To rpt.Database.Tables.Count - 1
                    rpt.Database.Tables(intCounter).ApplyLogOnInfo(ConInfo)
                Next

                For index = 0 To rpt.ReportDefinition.Sections.Count - 1
                    For intCounter = 0 To rpt.ReportDefinition.Sections(index).ReportObjects.Count - 1
                        With rpt.ReportDefinition.Sections(index)
                            If .ReportObjects(intCounter).Kind = CrystalDecisions.Shared.ReportObjectKind.SubreportObject Then
                                mySubReportObject = CType(.ReportObjects(intCounter), CrystalDecisions.CrystalReports.Engine.SubreportObject)
                                mySubRepDoc = mySubReportObject.OpenSubreport(mySubReportObject.SubreportName)
                                For intCounter1 = 0 To mySubRepDoc.Database.Tables.Count - 1
                                    mySubRepDoc.Database.Tables(intCounter1).ApplyLogOnInfo(ConInfo)
                                    mySubRepDoc.Database.Tables(intCounter1).ApplyLogOnInfo(ConInfo)
                                Next
                            End If
                        End With
                    Next

                Next

                Dim crReportDocument As ReportDocument 'Untyped report object
                Me.crviewer.ReportSource = rpt

                Me.crviewer.Zoom(2)
                Me.Cursor = System.Windows.Forms.Cursors.Default
                show_reportWithParameter = True

                Exit Function
            End If
        Catch Exp As LoadSaveReportException
            show_reportWithParameter = False
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Catch Exp As Exception
            show_reportWithParameter = False
            Me.Cursor = System.Windows.Forms.Cursors.Default
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReportViewer Fields

frmReportViewer overview

Fields

field ImageList1
field ToolBar1
field components
field crParameterDiscreteValue
field crParameterFieldDefinition
field crParameterFieldDefinitions
field crParameterValues
field crviewer
field i
field m_sWindowTitel
field mnuClose
field rpt
field s
field tbCurrent
field tliCurrent

See Also

frmReportViewer Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


crParameterDiscreteValue Variable

Dim crParameterDiscreteValue As ParameterDiscreteValue

Source code

[Visual Basic]
    Dim crParameterDiscreteValue As ParameterDiscreteValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


crParameterFieldDefinition Variable

Dim crParameterFieldDefinition As ParameterFieldDefinition

Source code

[Visual Basic]
    Dim crParameterFieldDefinition As ParameterFieldDefinition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


crParameterFieldDefinitions Variable

Dim crParameterFieldDefinitions As ParameterFieldDefinitions

Source code

[Visual Basic]
    Dim crParameterFieldDefinitions As ParameterFieldDefinitions

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


crParameterValues Variable

Dim crParameterValues As ParameterValues

Source code

[Visual Basic]
    Dim crParameterValues As ParameterValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


crviewer Variable

Friend WithEvents crviewer As CrystalDecisions.Windows.Forms.CrystalReportViewer

Source code

[Visual Basic]
    Friend WithEvents crviewer As CrystalDecisions.Windows.Forms.CrystalReportViewer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


m_sWindowTitel Variable

Dim m_sWindowTitel As String

Source code

[Visual Basic]
    Dim m_sWindowTitel As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


mnuClose Variable

Friend WithEvents mnuClose As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents mnuClose As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


rpt Variable

Dim rpt As New ReportDocument()

Source code

[Visual Basic]
    Dim rpt As New ReportDocument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


s Variable

Dim s As String

Source code

[Visual Basic]
    Dim s As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


tbCurrent Variable

Dim tbCurrent As CrystalDecisions.CrystalReports.Engine.Table

Source code

[Visual Basic]
    Dim tbCurrent As CrystalDecisions.CrystalReports.Engine.Table

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


tliCurrent Variable

Dim tliCurrent As CrystalDecisions.Shared.TableLogOnInfo

Source code

[Visual Basic]
    Dim tliCurrent As CrystalDecisions.Shared.TableLogOnInfo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportViewer


frmReport_reportfeldregel Class

For a list of all members of this type, see frmReport_reportfeldregel Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmReport_reportfeldregel

Public Class frmReport_reportfeldregel
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReport_reportfeldregel Members


frmReport_reportfeldregel Members

frmReport_reportfeldregel overview

Constructors

constructor frmReport_reportfeldregel Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_AfterColEdit
method TBBottom_AfterColUpdate
method TBBottom_BeforeRowColChange
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmReport_reportfeldregel_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReport_reportfeldregel Class


frmReport_reportfeldregel Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel Properties

frmReport_reportfeldregel overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmReport_reportfeldregel Class


frmReport_reportfeldregel Methods

frmReport_reportfeldregel overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_AfterColEdit
method TBBottom_AfterColUpdate
method TBBottom_BeforeRowColChange
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmReport_reportfeldregel_Load

See Also

frmReport_reportfeldregel Class


frmReport_reportfeldregel.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_reportgruppe_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_report_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_reportgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_reportgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_reportfeldregel_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_reportgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report_reportfeldregel", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ReportReportfeldregelNr", "ReportReportfeldregelNr"), New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("ReportFeldRegelNr", "ReportFeldRegelNr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("Reihenfolge", "Reihenfolge"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("eingabe_zwingend", "eingabe_zwingend")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_report_reportfeldregel_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_report_reportfeldregel_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportReportfeldregelNr", System.Data.SqlDbType.Int, 4, "ReportReportfeldregelNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFeldRegelNr", System.Data.SqlDbType.Int, 4, "ReportFeldRegelNr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Reihenfolge", System.Data.SqlDbType.Int, 4, "Reihenfolge"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_report_reportfeldregel_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportReportfeldregelNr", System.Data.SqlDbType.Int, 4, "ReportReportfeldregelNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFeldRegelNr", System.Data.SqlDbType.Int, 4, "ReportFeldRegelNr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Reihenfolge", System.Data.SqlDbType.Int, 4, "Reihenfolge"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingabe_zwingend", System.Data.SqlDbType.Bit, 1, "eingabe_zwingend"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportReportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportReportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFeldRegelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportFeldRegelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_report_reportfeldregel_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportReportfeldregelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportReportfeldregelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFeldRegelNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportFeldRegelNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingabe_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingabe_zwingend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmReport_reportfeldregel
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, -20)
        Me.Name = "frmReport_reportfeldregel"
        Me.Text = ""
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim CurrentSel As Boolean
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsReport_reportfeldregel() ' .clsReportfeld()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        CurrentSel = False
        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            CurrentSel = True
            ic = ic + 1
        End If

        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            vdata.bEingabe_zwingend = New SqlBoolean(CType(0, Boolean))
            If Me.FokusLeft.Checked Then
                vdata.iReportNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If CurrentSel Then
                    vdata.iReportFeldRegelNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iReportFeldRegelNr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If CurrentSel Then
                    vdata.iReportNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iReportNr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If
                vdata.iReportFeldRegelNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.iReihenfolge = New SqlInt32(CType(1, Int32))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("report_reportfeldregel")
            vdata.iReportReportfeldregelNr = New SqlInt32(CType(key, Int32))
            'vdata.iReportfeld_nr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataMember = Me.DataSet1.Tables(0).TableName
        Me.TBLeft.DataSource = Me.DataSet1

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.DataSet2.Tables(0).TableName

        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5018, 5022, 5048)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()

        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.DataSet3.Tables(0).TableName

        'Me.TBBottom.DataMember = Me.TableNameBottom

        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
        Exit Function

        Dim vdata As New edokadb.clsReport_reportfeldregel() ' .clsReportfeld()
        Dim iCount As Integer
        Dim bEingabe_zwingend As Boolean = CType(Me.TBBottom.Columns(11).Value, Boolean)
        Dim bAktive As Boolean = CType(Me.TBBottom.Columns(5).Value, Boolean)
        Save_Data = True
        Try
            vdata.cpMainConnectionProvider = conn
            vdata.iReportReportfeldregelNr = New SqlInt32(CType(Me.TBBottom.Columns("ReportReportfeldregelNr").Value, Integer))
            vdata.SelectOne()

            vdata.bEingabe_zwingend = New SqlBoolean(CType(Me.TBBottom.Columns(11).Value, Boolean)) 'Eingabe erforderlich
            vdata.bAktiv = New SqlBoolean(CType(Me.TBBottom.Columns(5).Value, Boolean)) 'Aktiv

            conn.OpenConnection()
            vdata.Update()
            conn.CloseConnection(True)

            'vdata.iReportReportfeldregelNr = New SqlInt32(CType(Me.TBBottom.Columns("ReportReportfeldregelNr").Value, Integer))
            'vdata.bEingabe_zwingend = New SqlBoolean(CType(Me.TBBottom.Columns(11).CellValue(iCount), Boolean)) 'Eingabe erforderlich
            'vdata.bAktiv = New SqlBoolean(CType(Me.TBBottom.Columns(5).CellValue(iCount), Boolean)) 'Aktiv
            'vdata.iMutierer = New SqlInt32(CType(Me.TBBottom.Columns(10).CellValue(iCount), Integer))   '"Mutierer
            'vdata.daMutiert_am = New SqlDateTime(CType(Me.TBBottom.Columns(8).CellValue(iCount), Date)) '"Mutiert_am"
            'vdata.iReportFeldRegelNr = New SqlInt32(CType(Me.TBBottom.Columns(2).Value, Integer))       'reportnr

        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBBottom_AfterColEdit Method

Private Sub TBBottom_AfterColEdit( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_AfterColEdit(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBBottom_AfterColUpdate Method

Private Sub TBBottom_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles TBBottom.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles TBBottom.BeforeColUpdate

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBBottom_BeforeRowColChange Method

Private Sub TBBottom_BeforeRowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles TBBottom.BeforeRowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_BeforeRowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles TBBottom.BeforeRowColChange
        If Me.DataSet3.HasChanges Then
            Save_Data()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        Me.SuspendLayout()
        check_changes()
        Refresh_TBBottom()
        Me.ResumeLayout(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel.frmReport_reportfeldregel_Load Method

Private Sub frmReport_reportfeldregel_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReport_reportfeldregel_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "report"
        Me.TableNameRight = "reportfeldregel"
        Me.TableNameBottom = "report_reportfeldregel"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReport_reportfeldregel Fields

frmReport_reportfeldregel overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReport_reportfeldregel Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReport_reportfeldregel


frmReportgruppe_Report Class

For a list of all members of this type, see frmReportgruppe_Report Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmReportgruppe_Report

Public Class frmReportgruppe_Report
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReportgruppe_Report Members


frmReportgruppe_Report Members

frmReportgruppe_Report overview

Constructors

constructor frmReportgruppe_Report Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmReportgruppe_Report_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReportgruppe_Report Class


frmReportgruppe_Report Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report Properties

frmReportgruppe_Report overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmReportgruppe_Report Class


frmReportgruppe_Report Methods

frmReportgruppe_Report overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmReportgruppe_Report_Load

See Also

frmReportgruppe_Report Class


frmReportgruppe_Report.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktionsgruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionsgruppenr", "funktionsgruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_reportgruppe_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_reportgruppe_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_reportgruppe_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_reportgruppe_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, "funktionsgruppenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionsgruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_report_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "reportgruppe_report", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ReportgruppeReportNr", "ReportgruppeReportNr"), New System.Data.Common.DataColumnMapping("reportgruppeNr", "reportgruppeNr"), New System.Data.Common.DataColumnMapping("reportNr", "reportNr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_reportgruppe_report_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_reportgruppe_report_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportgruppeReportNr", System.Data.SqlDbType.Int, 4, "ReportgruppeReportNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_reportgruppe_report_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportgruppeReportNr", System.Data.SqlDbType.Int, 4, "ReportgruppeReportNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportgruppeNr", System.Data.SqlDbType.Int, 4, "reportgruppeNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reportNr", System.Data.SqlDbType.Int, 4, "reportNr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportgruppeReportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportgruppeReportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_reportgruppe_report_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportgruppeReportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportgruppeReportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportNr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reportgruppeNr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reportgruppeNr", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmReportgruppe_Report
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(104, -20)
        Me.Name = "frmReportgruppe_Report"
        Me.Text = "frmFunktionsgruppeRolle"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsReportgruppe_report()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iReportNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iReportNr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                    vdata.iReportgruppeNr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iReportNr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("Reportgruppe_Report")
            vdata.iReportgruppeReportNr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.DataSet1.Tables(0).TableName

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.DataSet2.Tables(0).TableName
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5027, 5050, 5019)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.DataSet3.Tables(0).TableName

        ' Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        'SpaltenTitel_Aktualisieren(3, "reportgruppe_report", Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report.frmReportgruppe_Report_Load Method

Private Sub frmReportgruppe_Report_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReportgruppe_Report_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "reportgruppe"
        Me.TableNameRight = "report"
        Me.TableNameBottom = "reportgruppe_report"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReportgruppe_Report Fields

frmReportgruppe_Report overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmReportgruppe_Report Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReportgruppe_Report


frmReporting Class

For a list of all members of this type, see frmReporting Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmReporting

Public Class frmReporting
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmReporting Members


frmReporting Members

frmReporting overview

Constructors

constructor frmReporting Constructor

Properties

property WindowTitel

Methods

method Dispose
method FileExist
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method frmReporting_Load
method report_login
method show_report (Overloaded)
method show_reportWithParameter
method show_report_dokumenttyp
method show_report_dokumenttypVFelder

Fields

field ImageList1
field ToolBar1
field ToolBarButton1
field components
field crParameterDiscreteValue
field crParameterFieldDefinition
field crParameterFieldDefinitions
field crParameterValues
field crviewer
field i
field m_sWindowTitel
field reportDocument1
field rpt
field s
field tbCurrent
field tliCurrent

See Also

frmReporting Class


frmReporting Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting Properties

frmReporting overview

Properties

property WindowTitel

See Also

frmReporting Class


frmReporting.WindowTitel Property

Property WindowTitel() As String

Source code

[Visual Basic]
    Property WindowTitel() As String
        Get
            Return m_sWindowTitel
        End Get
        Set(ByVal Value As String)
            m_sWindowTitel = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting Methods

frmReporting overview

Methods

method Dispose
method FileExist
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method frmReporting_Load
method report_login
method show_report (Overloaded)
method show_reportWithParameter
method show_report_dokumenttyp
method show_report_dokumenttypVFelder

See Also

frmReporting Class


frmReporting.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.FileExist Method

Private Function FileExist( _
   ByVal FilePath As String, _
   ByVal FileName As String _
) As Boolean

Parameters

FilePath
Required.
FileName
Required.

Source code

[Visual Basic]
    Private Function FileExist(ByVal FilePath As String, ByVal FileName As String) As Boolean
        '===============================================================================
        'Ermittelt ob eine Datei vorhanden ist.
        'Input : Verzeichnis
        'Output: True/False
        'Erstellt  : koe 20.10.2003
        'Geaendert :
        '===============================================================================
        Try
            If Microsoft.VisualBasic.Right(FilePath, 1) <> "\" Then
                FilePath = FilePath + "\"
            End If

            If System.IO.Directory.Exists(FilePath) Then
                If System.IO.File.Exists(FilePath & FileName) Then
                    FileExist = True
                Else
                    MyMsg.show_standardmessage_ReplaceText(210, MsgBoxStyle.Exclamation, FilePath & " " & FileName, "") 'Datei  #1 nicht gefunden!
                    FileExist = False
                End If
            Else
                MyMsg.show_standardmessage_ReplaceText(210, MsgBoxStyle.Exclamation, FilePath, "") '"Verzeichnis " & FilePath & " nicht gefunden!
                FileExist = False
            End If
        Catch ex As Exception
            MessageBox.Show(ex.Message, "Reportdatei", MessageBoxButtons.OK, MessageBoxIcon.Exclamation)
            FileExist = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer, _
   ByVal xvalue As Long _
) As DataTable

Parameters

typ
Required.
xvalue
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer, ByVal xvalue As Long) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_reporting_dokart_tree"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@iroot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xvalue))
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmReporting))
        Me.reportDocument1 = New CrystalDecisions.CrystalReports.Engine.ReportDocument()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.crviewer = New CrystalDecisions.Windows.Forms.CrystalReportViewer()
        Me.SuspendLayout()
        '
        'reportDocument1
        '
        Me.reportDocument1.PrintOptions.PaperOrientation = CrystalDecisions.Shared.PaperOrientation.DefaultPaperOrientation
        Me.reportDocument1.PrintOptions.PaperSize = CrystalDecisions.Shared.PaperSize.DefaultPaperSize
        Me.reportDocument1.PrintOptions.PaperSource = CrystalDecisions.Shared.PaperSource.Upper
        Me.reportDocument1.PrintOptions.PrinterDuplex = CrystalDecisions.Shared.PrinterDuplex.Default
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(912, 25)
        Me.ToolBar1.TabIndex = 1
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 4
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'crviewer
        '
        Me.crviewer.ActiveViewIndex = -1
        Me.crviewer.Dock = System.Windows.Forms.DockStyle.Fill
        Me.crviewer.Location = New System.Drawing.Point(0, 25)
        Me.crviewer.Name = "crviewer"
        Me.crviewer.ReportSource = Nothing
        Me.crviewer.ShowCloseButton = False
        Me.crviewer.ShowGroupTreeButton = False
        Me.crviewer.ShowRefreshButton = False
        Me.crviewer.Size = New System.Drawing.Size(912, 484)
        Me.crviewer.TabIndex = 2
        '
        'frmReporting
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(912, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.crviewer, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmReporting"
        Me.Text = "frmReporting"
        Me.WindowState = System.Windows.Forms.FormWindowState.Maximized
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.frmReporting_Load Method

Private Sub frmReporting_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmReporting_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.report_login Method

Public Sub report_login( _
   ByVal _report As ReportDocument _
)

Parameters

_report
Required.

Source code

[Visual Basic]
    Public Sub report_login(ByVal _report As ReportDocument)
        For Each tbCurrent In _report.Database.Tables
            tliCurrent = tbCurrent.LogOnInfo
            With tliCurrent.ConnectionInfo
                .ServerName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_server"), String)
                .UserID = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("user_report"), String)
                .Password = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_report"), String)
                .DatabaseName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_db"), String)
            End With
            tbCurrent.ApplyLogOnInfo(tliCurrent)
        Next (tbCurrent)

        'Loop through each report object looking for sub reports
        Dim _reportObject As ReportObject
        Dim _subReport As SubreportObject
        For Each _reportObject In _report.ReportDefinition.ReportObjects
            'Check the report object type
            If TypeOf (_reportObject) Is SubreportObject Then
                _subReport = CType(_reportObject, SubreportObject)
                report_login(_subReport.OpenSubreport(_subReport.SubreportName))
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


show_report Method

Overload List

[Visual Basic] Public Function show_report(ByVal ReportName As String, ByVal ParameterCollection As Collection) As Boolean

[Visual Basic] Public Sub show_report(ByVal ReportNr As Long)

See Also

frmReporting | EDOKAApp


frmReporting.show_reportWithParameter Method

Public Function show_reportWithParameter( _
   ByVal ReportName As String, _
   ByVal param As String _
) As Boolean

Parameters

ReportName
Required.
param
Required.

Source code

[Visual Basic]
    Public Function show_reportWithParameter(ByVal ReportName As String, ByVal param As String) As Boolean
        '===============================================================================
        'Desc       : Anziegen des gewählten report
        'Input 	    : Reportname
        'Kriterium  : Der Report muss im Verzeichenis welches in der Tabelle Applikation
        '             hinterlegt ist, vorhanden sein
        'Erstellt   : bud 25.05.2005
        'Geaendert  :
        '===============================================================================
        Dim sReportpath As String
        If m_sWindowTitel <> "" Then
            Me.Text = m_sWindowTitel
        End If
        Try
            sReportpath = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String)
            If Microsoft.VisualBasic.Right(sReportpath, 1) <> "\" Then
                sReportpath = sReportpath & "\"
            End If
            '=============================================
            'Fileprüfung
            '=============================================
            If FileExist(sReportpath, ReportName) = True Then
                rpt.Load(sReportpath & ReportName)
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor

                '***************************************************
                '***************************************************
                Dim intCounter As Integer
                intCounter = rpt.DataDefinition.ParameterFields.Count

                If intCounter = 1 Then
                    If InStr(rpt.DataDefinition.ParameterFields(0).ParameterFieldName, ".", CompareMethod.Text) > 0 Then
                        intCounter = 0
                    End If

                End If

                Dim strParValPair() As String
                Dim strVal() As String
                Dim index As Integer
                Dim paraValue As New CrystalDecisions.Shared.ParameterDiscreteValue()
                Dim currValue As CrystalDecisions.Shared.ParameterValues
                Dim ConInfo As New CrystalDecisions.Shared.TableLogOnInfo()
                Dim mySubReportObject As CrystalDecisions.CrystalReports.Engine.SubreportObject
                Dim mySubRepDoc As New CrystalDecisions.CrystalReports.Engine.ReportDocument()
                Dim intCounter1 As Integer

                If intCounter > 0 And Trim(param) <> "" Then
                    strParValPair = param.Split(CType("&", Char))

                    For index = 0 To UBound(strParValPair)
                        If InStr(strParValPair(index), "=") > 0 Then
                            strVal = strParValPair(index).Split(CType("=", Char))
                            paraValue.Value = strVal(1)
                            currValue = rpt.DataDefinition.ParameterFields(strVal(0)).CurrentValues
                            currValue.Add(paraValue)
                            rpt.DataDefinition.ParameterFields(strVal(0)).ApplyCurrentValues(currValue)
                        End If
                    Next
                End If

                ConInfo.ConnectionInfo.UserID = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("user_report"), String)
                ConInfo.ConnectionInfo.Password = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_report"), String)
                ConInfo.ConnectionInfo.ServerName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_server"), String)
                ConInfo.ConnectionInfo.DatabaseName = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("report_db"), String)

                For intCounter = 0 To rpt.Database.Tables.Count - 1
                    rpt.Database.Tables(intCounter).ApplyLogOnInfo(ConInfo)
                Next

                For index = 0 To rpt.ReportDefinition.Sections.Count - 1
                    For intCounter = 0 To rpt.ReportDefinition.Sections(index).ReportObjects.Count - 1
                        With rpt.ReportDefinition.Sections(index)
                            If .ReportObjects(intCounter).Kind = CrystalDecisions.Shared.ReportObjectKind.SubreportObject Then
                                mySubReportObject = CType(.ReportObjects(intCounter), CrystalDecisions.CrystalReports.Engine.SubreportObject)
                                mySubRepDoc = mySubReportObject.OpenSubreport(mySubReportObject.SubreportName)
                                For intCounter1 = 0 To mySubRepDoc.Database.Tables.Count - 1
                                    mySubRepDoc.Database.Tables(intCounter1).ApplyLogOnInfo(ConInfo)
                                    mySubRepDoc.Database.Tables(intCounter1).ApplyLogOnInfo(ConInfo)
                                Next
                            End If
                        End With
                    Next

                Next

                Dim crReportDocument As ReportDocument 'Untyped report object
                Me.crviewer.ReportSource = rpt

                Me.crviewer.Zoom(2)
                Me.Cursor = System.Windows.Forms.Cursors.Default
                show_reportWithParameter = True

                Exit Function
            End If
        Catch Exp As LoadSaveReportException
            show_reportWithParameter = False
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Catch Exp As Exception
            show_reportWithParameter = False
            Me.Cursor = System.Windows.Forms.Cursors.Default
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.show_report_dokumenttyp Method

Public Sub show_report_dokumenttyp( _
   ByVal Dokumenttypnr As Long _
)

Parameters

Dokumenttypnr
Required.

Source code

[Visual Basic]
    Public Sub show_report_dokumenttyp(ByVal Dokumenttypnr As Long)
        Dim dt As New DataTable()
        Try
            dt = Generic_Select(1, Dokumenttypnr)
            Me.Text = Globals.MyTxt.gettext(21000)
            'rpt.Load("c:\edoka\edoka\reporting\Reports\dokumenttyp.rpt")

            'rpt.Load(CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_reportdateien"), String) & "\dokumenttyp.rpt")
            rpt.Load(CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String) & "\dokumenttyp.rpt")
            report_login(rpt)

            'Get the collection of parameters from the report
            crParameterFieldDefinitions = rpt.DataDefinition.ParameterFields

            'Access the specified parameter from the collection
            For i = 0 To 0
                crParameterFieldDefinition = crParameterFieldDefinitions.Item(i)
                crParameterValues = crParameterFieldDefinition.CurrentValues
                crParameterDiscreteValue = New ParameterDiscreteValue()
                crParameterDiscreteValue.Value = Dokumenttypnr
                crParameterValues.Add(crParameterDiscreteValue)
                crParameterFieldDefinition.ApplyCurrentValues(crParameterValues)
            Next
            Me.crviewer.ReportSource = rpt
            Me.crviewer.Zoom(2)
        Catch Exp As LoadSaveReportException
            MsgBox("Incorrect path for loading report.", _
                    MsgBoxStyle.Critical, "Load Report Error")
        Catch Exp As Exception
            MsgBox(Exp.Message, MsgBoxStyle.Critical, "General Error")
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.show_report_dokumenttypVFelder Method

Public Sub show_report_dokumenttypVFelder( _
   ByVal dokumenttypnr As Long, _
   ByVal id As String _
)

Parameters

dokumenttypnr
Required.
id
Required.

Source code

[Visual Basic]
    Public Sub show_report_dokumenttypVFelder(ByVal dokumenttypnr As Long, ByVal id As String)
        Try
            Me.Text = Globals.MyTxt.gettext(21001)
            rpt.Load(CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_reportdateien"), String) & "\dokumenttypVFelder.rpt")
            '            rpt.Load("l:\edoka\Reports\dokumenttypVFelder.rpt")
            report_login(rpt)
            'Get the collection of parameters from the report
            crParameterFieldDefinitions = rpt.DataDefinition.ParameterFields
            'Access the specified parameter from the collection
            crParameterFieldDefinition = crParameterFieldDefinitions.Item("@id")
            crParameterValues = crParameterFieldDefinition.CurrentValues
            crParameterDiscreteValue = New ParameterDiscreteValue()
            crParameterDiscreteValue.Value = id
            crParameterValues.Add(crParameterDiscreteValue)
            crParameterFieldDefinition.ApplyCurrentValues(crParameterValues)
            Me.crviewer.ReportSource = rpt
            Me.crviewer.Zoom(2)
        Catch Exp As LoadSaveReportException
            MsgBox("Incorrect path for loading report.", _
                    MsgBoxStyle.Critical, "Load Report Error")
        Catch Exp As Exception
            MsgBox(Exp.Message, MsgBoxStyle.Critical, "General Error")
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting Fields

frmReporting overview

Fields

field ImageList1
field ToolBar1
field ToolBarButton1
field components
field crParameterDiscreteValue
field crParameterFieldDefinition
field crParameterFieldDefinitions
field crParameterValues
field crviewer
field i
field m_sWindowTitel
field reportDocument1
field rpt
field s
field tbCurrent
field tliCurrent

See Also

frmReporting Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


crParameterDiscreteValue Variable

Dim crParameterDiscreteValue As ParameterDiscreteValue

Source code

[Visual Basic]
    Dim crParameterDiscreteValue As ParameterDiscreteValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


crParameterFieldDefinition Variable

Dim crParameterFieldDefinition As ParameterFieldDefinition

Source code

[Visual Basic]
    Dim crParameterFieldDefinition As ParameterFieldDefinition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


crParameterFieldDefinitions Variable

Dim crParameterFieldDefinitions As ParameterFieldDefinitions

Source code

[Visual Basic]
    Dim crParameterFieldDefinitions As ParameterFieldDefinitions

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


crParameterValues Variable

Dim crParameterValues As ParameterValues

Source code

[Visual Basic]
    Dim crParameterValues As ParameterValues

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


crviewer Variable

Friend WithEvents crviewer As CrystalDecisions.Windows.Forms.CrystalReportViewer

Source code

[Visual Basic]
    Friend WithEvents crviewer As CrystalDecisions.Windows.Forms.CrystalReportViewer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


m_sWindowTitel Variable

Dim m_sWindowTitel As String

Source code

[Visual Basic]
    Dim m_sWindowTitel As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


reportDocument1 Variable

Friend WithEvents reportDocument1 As CrystalDecisions.CrystalReports.Engine.ReportDocument

Source code

[Visual Basic]
    Friend WithEvents reportDocument1 As CrystalDecisions.CrystalReports.Engine.ReportDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


rpt Variable

Dim rpt As New ReportDocument()

Source code

[Visual Basic]
    Dim rpt As New ReportDocument()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


s Variable

Dim s As String

Source code

[Visual Basic]
    Dim s As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


tbCurrent Variable

Dim tbCurrent As CrystalDecisions.CrystalReports.Engine.Table

Source code

[Visual Basic]
    Dim tbCurrent As CrystalDecisions.CrystalReports.Engine.Table

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


tliCurrent Variable

Dim tliCurrent As CrystalDecisions.Shared.TableLogOnInfo

Source code

[Visual Basic]
    Dim tliCurrent As CrystalDecisions.Shared.TableLogOnInfo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmRestorJournal Class

For a list of all members of this type, see frmRestorJournal Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmRestorJournal

Public Class frmRestorJournal
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRestorJournal Members


frmRestorJournal Members

frmRestorJournal overview

Constructors

constructor frmRestorJournal Constructor

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmRestorJournal_Load
method get_data

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field components

See Also

frmRestorJournal Class


frmRestorJournal Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal Methods

frmRestorJournal overview

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method frmRestorJournal_Load
method get_data

See Also

frmRestorJournal Class


frmRestorJournal.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmRestorJournal))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(536, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(0, 25)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(536, 248)
        Me.C1TrueDBGrid1.TabIndex = 1
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Borde" & _
        "r:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" Colu" & _
        "mnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" Def" & _
        "RecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0" & _
        ", 0, 532, 244</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2" & _
        """ me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent" & _
        "=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><Foot" & _
        "erStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" />" & _
        "<HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""Highligh" & _
        "tRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""S" & _
        "tyle11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" " & _
        "me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style paren" & _
        "t="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading""" & _
        " me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me" & _
        "=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""" & _
        "Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""" & _
        "EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""Reco" & _
        "rdSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me" & _
        "=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><La" & _
        "yout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 5" & _
        "32, 244</ClientArea></Blob>"
        '
        'frmRestorJournal
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 273)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1, Me.ToolBar1})
        Me.Name = "frmRestorJournal"
        Me.Text = "Journal Dokument-Restore"
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal.frmRestorJournal_Load Method

Private Sub frmRestorJournal_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRestorJournal_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim t As DataTable
        Dim i As Integer
        t = get_data()
        Me.C1TrueDBGrid1.DataSource = t
        Me.C1TrueDBGrid1.DataMember = t.TableName
        For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).AutoSize()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal.get_data Method

Public Function get_data() As DataTable

Source code

[Visual Basic]
    Public Function get_data() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokumentrestore"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRestorJournal Fields

frmRestorJournal overview

Fields

field C1TrueDBGrid1
field ImageList1
field ToolBar1
field ToolBarButton1
field components

See Also

frmRestorJournal Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRestorJournal


frmRevision Class

For a list of all members of this type, see frmRevision Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmRevision

Public Class frmRevision
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRevision Members


frmRevision Members

frmRevision overview

Constructors

constructor frmRevision Constructor

Methods

method Dispose
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method frmRevision_Load

Fields

field DokList
field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components

See Also

frmRevision Class


frmRevision Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision Methods

frmRevision overview

Methods

method Dispose
method Generic_Select
method InitializeComponent
method ToolBar1_ButtonClick
method frmRevision_Load

See Also

frmRevision Class


frmRevision.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision.Generic_Select Method

Private Function Generic_Select() As DataTable

Source code

[Visual Basic]
    Private Function Generic_Select() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Revisionsjournal_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmRevision))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(776, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdate = False
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(0, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines1
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(776, 436)
        Me.DokList.TabIndex = 26
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 772," & _
        " 432</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 772, " & _
        "432</ClientArea></Blob>"
        '
        'frmRevision
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(776, 461)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokList, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmRevision"
        Me.Text = "Revisionsdaten"
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                Me.DokList.PrintInfo.PrintPreview()
                Me.DokList.PrintInfo.PageSettings.Landscape = False
                Me.DokList.PrintInfo.ShowProgressForm = True
                Me.DokList.PrintInfo.ShowOptionsDialog = True
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision.frmRevision_Load Method

Private Sub frmRevision_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRevision_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Me.DokList.DataSource = Generic_Select()
        For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRevision Fields

frmRevision overview

Fields

field DokList
field ImageList1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components

See Also

frmRevision Class


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRevision


frmRolleBerechtigung Class

For a list of all members of this type, see frmRolleBerechtigung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmRolleBerechtigung

Public Class frmRolleBerechtigung
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRolleBerechtigung Members


frmRolleBerechtigung Members

frmRolleBerechtigung overview

Constructors

constructor frmRolleBerechtigung Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolleBerechtigung Class


frmRolleBerechtigung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung Properties

frmRolleBerechtigung overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmRolleBerechtigung Class


frmRolleBerechtigung Methods

frmRolleBerechtigung overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmRolleBerechtigung Class


frmRolleBerechtigung.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "berechtigung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("sysadminfunktion", "sysadminfunktion"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_berechtigung_ohne_Dokumente_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_berechtigung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfunktion", System.Data.SqlDbType.Bit, 1, "sysadminfunktion"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_berechtigung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfunktion", System.Data.SqlDbType.Bit, 1, "sysadminfunktion"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfunktion", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfunktion", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_berechtigung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfunktion", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfunktion", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolleberechtigung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rolleberechtigungnr", "rolleberechtigungnr"), New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_rolleberechtigung_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_rolleberechtigung_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolleberechtigungnr", System.Data.SqlDbType.Int, 4, "rolleberechtigungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_rolleberechtigung_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolleberechtigungnr", System.Data.SqlDbType.Int, 4, "rolleberechtigungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolleberechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolleberechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_rolleberechtigung_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolleberechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolleberechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmRolleBerechtigung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 508)
        Me.Name = "frmRolleBerechtigung"
        Me.Text = "frmRolleBerechtigung"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsRolleberechtigung()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iBerechtigungnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iBerechtigungnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iBerechtigungnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("idvmakro_office_vorlage")
            vdata.iRolleberechtigungnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5042, 5043, 5044)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "rolle"
        Me.TableNameRight = "berechtigung"
        Me.TableNameBottom = "rolleberechtigung"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleBerechtigung Fields

frmRolleBerechtigung overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolleBerechtigung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleBerechtigung


frmRolleDokumentHierarchie Class

For a list of all members of this type, see frmRolleDokumentHierarchie Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmRolleDokumentHierarchie

Public Class frmRolleDokumentHierarchie
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRolleDokumentHierarchie Members


frmRolleDokumentHierarchie Members

frmRolleDokumentHierarchie overview

Constructors

constructor frmRolleDokumentHierarchie Constructor

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

Methods

method BtnConnect_Click_1
method CheckedListBox1_ItemCheck
method CheckedListbox1_Selectedvalues
method Dispose
method FormSize
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MnuErstellung_Click
method MnuGesamt_Click
method MnuHost_Click
method MnuKundendossier_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_Click
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBBottom_Update
method TBLeft_Click
method TBLeft_FetchScrollTips
method TBRight_Click
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Close
method frmRolle_SysadminFunktion_Load
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

Fields

field BtnConnect
field CheckedListBox1
field ContextMenu1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft
field FokusRight
field GroupBox1
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field MnuErstellung
field MnuGesamt
field MnuHost
field MnuKundendossier
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Set_Selected_Values
field Splitter1
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field hierarchie
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRolleDokumentHierarchie Class


frmRolleDokumentHierarchie Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()

        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie Properties

frmRolleDokumentHierarchie overview

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

See Also

frmRolleDokumentHierarchie Class


frmRolleDokumentHierarchie.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
    Property Eintrag() As String
        Get
            Return m_Eintrag
        End Get
        Set(ByVal Value As String)
            m_Eintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
    Property Eintragnr() As Long
        Get
            Return m_Eintragnr
        End Get
        Set(ByVal Value As Long)
            m_Eintragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.KeyLeft Property

Property KeyLeft() As Long

Source code

[Visual Basic]
    Property KeyLeft() As Long
        Get
            Return m_KeyLeft
        End Get
        Set(ByVal Value As Long)
            m_KeyLeft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.KeyRight Property

Property KeyRight() As Long

Source code

[Visual Basic]
    Property KeyRight() As Long
        Get
            Return m_KeyRight
        End Get
        Set(ByVal Value As Long)
            m_KeyRight = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TableNameBottom Property

Property TableNameBottom() As String

Source code

[Visual Basic]
    Property TableNameBottom() As String
        Get
            Return m_TableNameBottom
        End Get
        Set(ByVal Value As String)
            m_TableNameBottom = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TableNameLeft Property

Property TableNameLeft() As String

Source code

[Visual Basic]
    Property TableNameLeft() As String
        Get
            Return m_TableNameLeft
        End Get
        Set(ByVal Value As String)
            m_TableNameLeft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TableNameRight Property

Property TableNameRight() As String

Source code

[Visual Basic]
    Property TableNameRight() As String
        Get
            Return m_TableNameRight
        End Get
        Set(ByVal Value As String)
            m_TableNameRight = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie Methods

frmRolleDokumentHierarchie overview

Methods

method BtnConnect_Click_1
method CheckedListBox1_ItemCheck
method CheckedListbox1_Selectedvalues
method Dispose
method FormSize
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MnuErstellung_Click
method MnuGesamt_Click
method MnuHost_Click
method MnuKundendossier_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_Click
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBBottom_Update
method TBLeft_Click
method TBLeft_FetchScrollTips
method TBRight_Click
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Close
method frmRolle_SysadminFunktion_Load
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

See Also

frmRolleDokumentHierarchie Class


frmRolleDokumentHierarchie.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.CheckedListBox1_ItemCheck Method

Private Sub CheckedListBox1_ItemCheck( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemCheckEventArgs _
) Handles CheckedListBox1.ItemCheck

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckedListBox1_ItemCheck(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemCheckEventArgs) Handles CheckedListBox1.ItemCheck
        Dim i As Integer
        Dim bm As Long
        If Set_Selected_Values Then Exit Sub
        Select Case Me.CheckedListBox1.SelectedValue
            Case 1
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "anzeigen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 2
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "erstellen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 3
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "bearbeiten" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 4
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "loeschen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 5
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "abschliessen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
        End Select
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.CheckedListbox1_Selectedvalues Method

Private Sub CheckedListbox1_Selectedvalues()

Source code

[Visual Basic]
    Private Sub CheckedListbox1_Selectedvalues()
        Dim i As Integer
        Set_Selected_Values = True
        Me.CheckedListBox1.SetItemChecked(0, False)
        Me.CheckedListBox1.SetItemChecked(1, False)
        Me.CheckedListBox1.SetItemChecked(2, False)
        Me.CheckedListBox1.SetItemChecked(3, False)
        Me.CheckedListBox1.SetItemChecked(4, False)

        Try
            For i = 0 To TBBottom.Columns.Count - 1
                If Me.TBBottom.Columns(i).DataField = "anzeigen" Then
                    Me.CheckedListBox1.SetItemChecked(0, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "erstellen" Then
                    Me.CheckedListBox1.SetItemChecked(1, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "bearbeiten" Then
                    Me.CheckedListBox1.SetItemChecked(2, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "loeschen" Then
                    Me.CheckedListBox1.SetItemChecked(3, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "abschliessen" Then
                    Me.CheckedListBox1.SetItemChecked(4, Me.TBBottom.Columns(i).Text)
                End If
            Next
        Catch
        End Try
        Set_Selected_Values = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.FormSize Method

Public Sub FormSize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub FormSize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ds As New edokadb.clsSysadminfunktion()
        Try
            ds.cpMainConnectionProvider = conn
            ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
            ds.SelectOne()
            If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
            If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
            If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
            If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
            Me.MenuItem1.Text = Me.Eintrag
        Catch
            '    MsgBox("Error Resizing Form")
        Finally
        End Try
        ds.Dispose()
        Me.Text = Me.Eintrag
        Try
            Globals.WinPos.Get_Position(Me)
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmRolleDokumentHierarchie))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.GrpRight = New System.Windows.Forms.GroupBox()
        Me.TBRight = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.GrpLeft = New System.Windows.Forms.GroupBox()
        Me.TBLeft = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.GrpFocus = New System.Windows.Forms.GroupBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.FokusRight = New System.Windows.Forms.RadioButton()
        Me.FokusLeft = New System.Windows.Forms.RadioButton()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.GrpBottom = New System.Windows.Forms.GroupBox()
        Me.TBBottom = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.CheckedListBox1 = New System.Windows.Forms.CheckedListBox()
        Me.Panel5 = New System.Windows.Forms.Panel()
        Me.BtnConnect = New System.Windows.Forms.Button()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuGesamt = New System.Windows.Forms.MenuItem()
        Me.MnuKundendossier = New System.Windows.Forms.MenuItem()
        Me.MnuErstellung = New System.Windows.Forms.MenuItem()
        Me.MnuHost = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.Panel2.SuspendLayout()
        Me.GrpRight.SuspendLayout()
        CType(Me.TBRight, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpLeft.SuspendLayout()
        CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpFocus.SuspendLayout()
        Me.Panel3.SuspendLayout()
        Me.GrpBottom.SuspendLayout()
        CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox1.SuspendLayout()
        Me.Panel5.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarBtnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(640, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarBtnSave
        '
        Me.ToolBarBtnSave.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(640, 16)
        Me.Panel1.TabIndex = 1
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpRight, Me.Splitter1, Me.GrpLeft})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Location = New System.Drawing.Point(0, 41)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(640, 199)
        Me.Panel2.TabIndex = 2
        '
        'GrpRight
        '
        Me.GrpRight.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBRight})
        Me.GrpRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpRight.Location = New System.Drawing.Point(315, 0)
        Me.GrpRight.Name = "GrpRight"
        Me.GrpRight.Size = New System.Drawing.Size(325, 199)
        Me.GrpRight.TabIndex = 2
        Me.GrpRight.TabStop = False
        Me.GrpRight.Text = "GroupBox2"
        '
        'TBRight
        '
        Me.TBRight.AllowFilter = True
        Me.TBRight.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBRight.AllowSort = True
        Me.TBRight.AllowUpdate = False
        Me.TBRight.AlternatingRows = True
        Me.TBRight.CaptionHeight = 17
        Me.TBRight.CollapseColor = System.Drawing.Color.Black
        Me.TBRight.DataChanged = False
        Me.TBRight.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBRight.ExpandColor = System.Drawing.Color.Black
        Me.TBRight.FilterBar = True
        Me.TBRight.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBRight.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.TBRight.Location = New System.Drawing.Point(3, 16)
        Me.TBRight.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBRight.Name = "TBRight"
        Me.TBRight.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBRight.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBRight.PreviewInfo.ZoomFactor = 75
        Me.TBRight.PrintInfo.ShowOptionsDialog = False
        Me.TBRight.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBRight.RowDivider = GridLines1
        Me.TBRight.RowHeight = 15
        Me.TBRight.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBRight.ScrollTips = False
        Me.TBRight.Size = New System.Drawing.Size(319, 180)
        Me.TBRight.TabIndex = 8
        Me.TBRight.Text = "C1TrueDBGrid1"
        Me.TBRight.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 315, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 315, 176</ClientArea></Blob>"
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(312, 0)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 199)
        Me.Splitter1.TabIndex = 1
        Me.Splitter1.TabStop = False
        '
        'GrpLeft
        '
        Me.GrpLeft.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBLeft})
        Me.GrpLeft.Dock = System.Windows.Forms.DockStyle.Left
        Me.GrpLeft.Name = "GrpLeft"
        Me.GrpLeft.Size = New System.Drawing.Size(312, 199)
        Me.GrpLeft.TabIndex = 0
        Me.GrpLeft.TabStop = False
        Me.GrpLeft.Text = "GroupBox1"
        '
        'TBLeft
        '
        Me.TBLeft.AllowFilter = True
        Me.TBLeft.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBLeft.AllowSort = True
        Me.TBLeft.AllowUpdate = False
        Me.TBLeft.AlternatingRows = True
        Me.TBLeft.CaptionHeight = 17
        Me.TBLeft.CollapseColor = System.Drawing.Color.Black
        Me.TBLeft.DataChanged = False
        Me.TBLeft.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBLeft.ExpandColor = System.Drawing.Color.Black
        Me.TBLeft.FilterBar = True
        Me.TBLeft.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBLeft.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.TBLeft.Location = New System.Drawing.Point(3, 16)
        Me.TBLeft.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBLeft.Name = "TBLeft"
        Me.TBLeft.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBLeft.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBLeft.PreviewInfo.ZoomFactor = 75
        Me.TBLeft.PrintInfo.ShowOptionsDialog = False
        Me.TBLeft.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBLeft.RowDivider = GridLines2
        Me.TBLeft.RowHeight = 15
        Me.TBLeft.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBLeft.ScrollTips = False
        Me.TBLeft.Size = New System.Drawing.Size(306, 180)
        Me.TBLeft.TabIndex = 8
        Me.TBLeft.Text = "C1TrueDBGrid1"
        Me.TBLeft.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 302, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 302, 176</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter2.Location = New System.Drawing.Point(0, 240)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(640, 3)
        Me.Splitter2.TabIndex = 3
        Me.Splitter2.TabStop = False
        '
        'GrpFocus
        '
        Me.GrpFocus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.FokusRight, Me.FokusLeft})
        Me.GrpFocus.Location = New System.Drawing.Point(216, 0)
        Me.GrpFocus.Name = "GrpFocus"
        Me.GrpFocus.Size = New System.Drawing.Size(200, 32)
        Me.GrpFocus.TabIndex = 17
        Me.GrpFocus.TabStop = False
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(78, 13)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 16)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Fokus"
        '
        'FokusRight
        '
        Me.FokusRight.Location = New System.Drawing.Point(176, 12)
        Me.FokusRight.Name = "FokusRight"
        Me.FokusRight.Size = New System.Drawing.Size(16, 16)
        Me.FokusRight.TabIndex = 1
        '
        'FokusLeft
        '
        Me.FokusLeft.Location = New System.Drawing.Point(9, 13)
        Me.FokusLeft.Name = "FokusLeft"
        Me.FokusLeft.Size = New System.Drawing.Size(104, 16)
        Me.FokusLeft.TabIndex = 0
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpBottom, Me.Panel5, Me.Panel4})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel3.Location = New System.Drawing.Point(0, 243)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(640, 270)
        Me.Panel3.TabIndex = 18
        '
        'GrpBottom
        '
        Me.GrpBottom.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBBottom, Me.GroupBox1})
        Me.GrpBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBottom.Location = New System.Drawing.Point(0, 40)
        Me.GrpBottom.Name = "GrpBottom"
        Me.GrpBottom.Size = New System.Drawing.Size(640, 190)
        Me.GrpBottom.TabIndex = 2
        Me.GrpBottom.TabStop = False
        Me.GrpBottom.Text = "GroupBox1"
        '
        'TBBottom
        '
        Me.TBBottom.AllowFilter = True
        Me.TBBottom.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBBottom.AllowSort = True
        Me.TBBottom.AlternatingRows = True
        Me.TBBottom.CaptionHeight = 17
        Me.TBBottom.CollapseColor = System.Drawing.Color.Black
        Me.TBBottom.DataChanged = False
        Me.TBBottom.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBBottom.ExpandColor = System.Drawing.Color.Black
        Me.TBBottom.FilterBar = True
        Me.TBBottom.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBBottom.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.TBBottom.Location = New System.Drawing.Point(3, 16)
        Me.TBBottom.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBBottom.Name = "TBBottom"
        Me.TBBottom.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBBottom.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBBottom.PreviewInfo.ZoomFactor = 75
        Me.TBBottom.PrintInfo.ShowOptionsDialog = False
        Me.TBBottom.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBBottom.RowDivider = GridLines3
        Me.TBBottom.RowHeight = 15
        Me.TBBottom.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBBottom.ScrollTips = False
        Me.TBBottom.Size = New System.Drawing.Size(402, 171)
        Me.TBBottom.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.TBBottom.TabIndex = 11
        Me.TBBottom.Text = "C1TrueDBGrid1"
        Me.TBBottom.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 398, 167</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 398, 167</ClientArea></Blob>"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.CheckedListBox1})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Right
        Me.GroupBox1.Location = New System.Drawing.Point(405, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(232, 171)
        Me.GroupBox1.TabIndex = 10
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "GroupBox1"
        '
        'CheckedListBox1
        '
        Me.CheckedListBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.CheckedListBox1.Location = New System.Drawing.Point(3, 16)
        Me.CheckedListBox1.Name = "CheckedListBox1"
        Me.CheckedListBox1.Size = New System.Drawing.Size(226, 139)
        Me.CheckedListBox1.TabIndex = 0
        '
        'Panel5
        '
        Me.Panel5.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnConnect})
        Me.Panel5.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel5.Name = "Panel5"
        Me.Panel5.Size = New System.Drawing.Size(640, 40)
        Me.Panel5.TabIndex = 1
        '
        'BtnConnect
        '
        Me.BtnConnect.Location = New System.Drawing.Point(288, 8)
        Me.BtnConnect.Name = "BtnConnect"
        Me.BtnConnect.TabIndex = 0
        Me.BtnConnect.Text = "&Verbinden"
        '
        'Panel4
        '
        Me.Panel4.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel4.Location = New System.Drawing.Point(0, 230)
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(640, 40)
        Me.Panel4.TabIndex = 0
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem2})
        Me.MenuItem1.MergeOrder = 1
        Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
        Me.MenuItem1.Shortcut = System.Windows.Forms.Shortcut.F4
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
        Me.MenuItem3.Text = "&Daten sichern"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
        Me.MenuItem2.Text = "&Schliessen"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle_dokumentart", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rolledokumentartnr", "rolledokumentartnr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("dokumentartnr", "dokumentartnr"), New System.Data.Common.DataColumnMapping("ausschluss", "ausschluss"), New System.Data.Common.DataColumnMapping("normal", "normal"), New System.Data.Common.DataColumnMapping("vertraulich_gestattet", "vertraulich_gestattet"), New System.Data.Common.DataColumnMapping("mitarbeiter_gestattet", "mitarbeiter_gestattet"), New System.Data.Common.DataColumnMapping("chiffre_gestattet", "chiffre_gestattet"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("anzeigen", "anzeigen"), New System.Data.Common.DataColumnMapping("erstellen", "erstellen"), New System.Data.Common.DataColumnMapping("bearbeiten", "bearbeiten"), New System.Data.Common.DataColumnMapping("loeschen", "loeschen"), New System.Data.Common.DataColumnMapping("abschliessen", "abschliessen")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand2
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuGesamt, Me.MnuKundendossier, Me.MnuErstellung, Me.MnuHost})
        '
        'MnuGesamt
        '
        Me.MnuGesamt.Index = 0
        Me.MnuGesamt.Text = "Gesamte Hierarchie"
        '
        'MnuKundendossier
        '
        Me.MnuKundendossier.Index = 1
        Me.MnuKundendossier.Text = "Kundendossier"
        '
        'MnuErstellung
        '
        Me.MnuErstellung.Index = 2
        Me.MnuErstellung.Text = "Erstellung"
        Me.MnuErstellung.Visible = False
        '
        'MnuHost
        '
        Me.MnuHost.Index = 3
        Me.MnuHost.Text = "HOST"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_berechtigung_aktiv_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_berechtigung_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_berechtigung_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_berechtigung_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_berechtigung_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[sp_rolle_dokumentart_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_rolle_dokumentart_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolledokumentartnr", System.Data.SqlDbType.Int, 4, "rolledokumentartnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausschluss", System.Data.SqlDbType.Bit, 1, "ausschluss"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@normal", System.Data.SqlDbType.Bit, 1, "normal"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, "vertraulich_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, "mitarbeiter_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@chiffre_gestattet", System.Data.SqlDbType.Bit, 1, "chiffre_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzeigen", System.Data.SqlDbType.Bit, 1, "anzeigen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellen", System.Data.SqlDbType.Bit, 1, "erstellen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bearbeiten", System.Data.SqlDbType.Bit, 1, "bearbeiten"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschen", System.Data.SqlDbType.Bit, 1, "loeschen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@abschliessen", System.Data.SqlDbType.Bit, 1, "abschliessen"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_rolle_dokumentart_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolledokumentartnr", System.Data.SqlDbType.Int, 4, "rolledokumentartnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentartnr", System.Data.SqlDbType.Int, 4, "dokumentartnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausschluss", System.Data.SqlDbType.Bit, 1, "ausschluss"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@normal", System.Data.SqlDbType.Bit, 1, "normal"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, "vertraulich_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, "mitarbeiter_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@chiffre_gestattet", System.Data.SqlDbType.Bit, 1, "chiffre_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzeigen", System.Data.SqlDbType.Bit, 1, "anzeigen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellen", System.Data.SqlDbType.Bit, 1, "erstellen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bearbeiten", System.Data.SqlDbType.Bit, 1, "bearbeiten"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschen", System.Data.SqlDbType.Bit, 1, "loeschen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@abschliessen", System.Data.SqlDbType.Bit, 1, "abschliessen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolledokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolledokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_abschliessen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "abschliessen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzeigen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzeigen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausschluss", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausschluss", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bearbeiten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bearbeiten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_chiffre_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "chiffre_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_normal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "normal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich_gestattet", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_rolle_dokumentart_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolledokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolledokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_abschliessen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "abschliessen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzeigen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzeigen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausschluss", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausschluss", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bearbeiten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bearbeiten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_chiffre_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "chiffre_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentartnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentartnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_normal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "normal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich_gestattet", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmRolleDokumentHierarchie
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(640, 513)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.GrpFocus, Me.Splitter2, Me.Panel2, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmRolleDokumentHierarchie"
        Me.Text = "frmRelEditor"
        Me.Panel2.ResumeLayout(False)
        Me.GrpRight.ResumeLayout(False)
        CType(Me.TBRight, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpLeft.ResumeLayout(False)
        CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpFocus.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        Me.GrpBottom.ResumeLayout(False)
        CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox1.ResumeLayout(False)
        Me.Panel5.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsRolle_dokumentart()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iDokumentartnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iDokumentartnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iDokumentartnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.bAbschliessen = New SqlBoolean(CType(False, Boolean))
            vdata.bAnzeigen = New SqlBoolean(CType(False, Boolean))
            vdata.bErstellen = New SqlBoolean(CType(False, Boolean))
            vdata.bBearbeiten = New SqlBoolean(CType(False, Boolean))
            vdata.bLoeschen = New SqlBoolean(CType(False, Boolean))

            vdata.bAusschluss = New SqlBoolean(CType(False, Boolean))
            vdata.bMitarbeiter_gestattet = New SqlBoolean(CType(False, Boolean))
            vdata.bVertraulich_gestattet = New SqlBoolean(CType(False, Boolean))
            vdata.bChiffre_gestattet = New SqlBoolean(CType(False, Boolean))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("rolle_dokumentart")
            vdata.iRolledokumentartnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft
        UpdateGrpText(5029, 5030, 5031)
        Me.GroupBox1.Text = Globals.MyTxt.gettext(5041)

        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet4)
        Me.CheckedListBox1.DataSource = Me.DataSet4.Tables(0)
        Me.CheckedListBox1.ValueMember = "berechtigungnr"
        Me.CheckedListBox1.DisplayMember = "bezeichnung"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MnuErstellung_Click Method

Private Sub MnuErstellung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuErstellung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuErstellung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuErstellung.Click
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(4)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MnuGesamt_Click Method

Private Sub MnuGesamt_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuGesamt.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuGesamt_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuGesamt.Click
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MnuHost_Click Method

Private Sub MnuHost_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuHost.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuHost_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuHost.Click
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(3)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.MnuKundendossier_Click Method

Private Sub MnuKundendossier_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuKundendossier.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuKundendossier_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuKundendossier.Click
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(2)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
        CheckedListbox1_Selectedvalues()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902) + ex.Message)
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tblnr As Integer, _
   ByVal tblname As String, _
   ByVal ds As DataSet _
)

Parameters

tblnr
Required.
tblname
Required.
ds
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        t = ds.Tables(0)
        If tblnr = 1 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBLeft.Columns.Count - 1
                Dim s As String
                s = Me.TBLeft.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                If ts.spaltenname <> "" Then
                    Me.TBLeft.Columns(i).Caption = ts.spaltenname
                    If Me.TBLeft.Columns(i).Caption = "" Then
                        Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                    Else
                        Me.TBLeft.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If
                    If ts.locked Then
                        Me.TBLeft.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If
                    'Präsentation von aktiv
                    If Me.TBLeft.Columns(i).DataField = "aktiv" Then
                        Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.TBLeft.Columns(i).ValueItems.DefaultItem = True
                        Me.TBLeft.Columns(i).DefaultValue = True
                        Me.TBLeft.Columns(i).FilterText = True
                    End If
                    If Me.TBLeft.Columns(i).DataField = "erstellt_am" Then
                        Me.TBLeft.Columns(i).DefaultValue = Now
                    End If
                Else
                    Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
        If tblnr = 2 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBRight.Columns.Count - 1
                Dim s As String
                s = Me.TBRight.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBRight.Columns(i).Caption = ts.spaltenname
                If Me.TBRight.Columns(i).Caption = "" Then
                    Me.TBRight.Splits(0).DisplayColumns(i).Width = 0
                Else
                    Me.TBRight.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                If ts.locked Then
                    Me.TBRight.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBRight.Columns(i).DataField = "aktiv" Then
                    Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBRight.Columns(i).ValueItems.DefaultItem = True
                    Me.TBRight.Columns(i).DefaultValue = True
                    Me.TBRight.Columns(i).FilterText = True
                End If
                If Me.TBRight.Columns(i).DataField = "erstellt_am" Then
                    Me.TBRight.Columns(i).DefaultValue = Now
                End If
            Next
        End If
        If tblnr = 3 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBBottom.Columns.Count - 1
                Dim s As String
                s = Me.TBBottom.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBBottom.Columns(i).Caption = ts.spaltenname
                If Me.TBBottom.Columns(i).Caption = "" Then
                    Me.TBBottom.Splits(0).DisplayColumns(i).Width = 0
                Else
                    Me.TBBottom.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                If ts.locked Then
                    Me.TBBottom.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                    Me.TBBottom.Columns(i).DefaultValue = True
                    Me.TBBottom.Columns(i).FilterText = True
                End If
                If Me.TBBottom.Columns(i).DataField = "erstellt_am" Then
                    Me.TBBottom.Columns(i).DefaultValue = Now
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Splitter1_SplitterMoved Method

Private Sub Splitter1_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter1.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splitter1_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter1.SplitterMoved
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.Splitter2_SplitterMoved Method

Private Sub Splitter2_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter2.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splitter2_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter2.SplitterMoved
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBBottom_Click Method

Private Sub TBBottom_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBBottom.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBBottom.RowColChange
        check_changes()
        CheckedListbox1_Selectedvalues()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBBottom_FetchScrollTips Method

Private Sub TBBottom_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBBottom.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBBottom.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBBottom.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBBottom_Format Method

Public Sub TBBottom_Format()

Source code

[Visual Basic]
    Public Sub TBBottom_Format()
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            'Präsentation von aktiv
            If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).DefaultValue = True
                Me.TBBottom.Splits(0).DisplayColumns(i).Locked = False
            End If
            If Me.TBBottom.Columns(i).DataField = "zwingend" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                Me.TBBottom.Columns(i).DefaultValue = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBLeft_FetchScrollTips Method

Private Sub TBLeft_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBLeft.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBLeft.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBLeft.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.TBRight_FetchScrollTips Method

Private Sub TBRight_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBRight.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBRight.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBRight.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.UpdateGrpText Method

Public Sub UpdateGrpText( _
   ByVal w1 As Integer, _
   ByVal w2 As Integer, _
   ByVal w3 As Integer _
)

Parameters

w1
Required.
w2
Required.
w3
Required.

Source code

[Visual Basic]
    Public Sub UpdateGrpText(ByVal w1 As Integer, ByVal w2 As Integer, ByVal w3 As Integer)
        Me.GrpLeft.Text = Globals.MyTxt.gettext(w1)
        Me.GrpRight.Text = Globals.MyTxt.gettext(w2)
        Me.GrpBottom.Text = Globals.MyTxt.gettext(w3)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmRolle_SysadminFunktion_Close Method

Private Sub frmRolle_SysadminFunktion_Close( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Close(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "rolle"
        Me.TableNameRight = "dokumentart"
        Me.TableNameBottom = "rolle_dokumentart"
        LoadData()
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        Me.TBRight.ContextMenu = Me.ContextMenu1
        MnuKundendossier_Click(sender, e)
        Me.TBLeft.Columns("rollelevel").FilterText = 2
        Me.TBLeft.ScrollTips = True
        Me.TBRight.ScrollTips = True
        Me.TBBottom.ScrollTips = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmVerbEditor_Layout Method

Private Sub frmVerbEditor_Layout( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.LayoutEventArgs _
) Handles MyBase.Layout

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_Layout(ByVal sender As System.Object, ByVal e As System.Windows.Forms.LayoutEventArgs) Handles MyBase.Layout
        Me.GrpLeft.Width = Me.ClientSize.Width / 2
        Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmVerbEditor_Load Method

Private Sub frmVerbEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.FokusLeft.Checked = True
        Me.FokusRight.Checked = False
        Me.Text = Me.Eintrag
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie.frmVerbEditor_WndChange Method

Private Sub frmVerbEditor_WndChange( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_WndChange(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.GrpLeft.Width = Me.ClientSize.Width / 2
        Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentHierarchie Fields

frmRolleDokumentHierarchie overview

Fields

field BtnConnect
field CheckedListBox1
field ContextMenu1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft
field FokusRight
field GroupBox1
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field MnuErstellung
field MnuGesamt
field MnuHost
field MnuKundendossier
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Set_Selected_Values
field Splitter1
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field hierarchie
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRolleDokumentHierarchie Class


BtnConnect Variable

Friend WithEvents BtnConnect As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnConnect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


CheckedListBox1 Variable

Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Source code

[Visual Basic]
    Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


FokusLeft Variable

Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


FokusRight Variable

Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


GrpBottom Variable

Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


GrpFocus Variable

Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


GrpLeft Variable

Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


GrpRight Variable

Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MnuErstellung Variable

Friend WithEvents MnuErstellung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuErstellung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MnuGesamt Variable

Friend WithEvents MnuGesamt As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuGesamt As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MnuHost Variable

Friend WithEvents MnuHost As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuHost As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


MnuKundendossier Variable

Friend WithEvents MnuKundendossier As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuKundendossier As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Panel5 Variable

Friend WithEvents Panel5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Set_Selected_Values Variable

Dim Set_Selected_Values As Boolean

Source code

[Visual Basic]
    Dim Set_Selected_Values As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


TBBottom Variable

Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


TBLeft Variable

Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


TBRight Variable

Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


ToolBarBtnSave Variable

Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


hierarchie Variable

Dim hierarchie As DataTable

Source code

[Visual Basic]
    Dim hierarchie As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
    Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
    Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_KeyLeft Variable

Dim m_KeyLeft As Long

Source code

[Visual Basic]
    Dim m_KeyLeft As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_KeyRight Variable

Dim m_KeyRight As Long

Source code

[Visual Basic]
    Dim m_KeyRight As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_TableNameBottom Variable

Dim m_TableNameBottom As String

Source code

[Visual Basic]
    Dim m_TableNameBottom As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_TableNameLeft Variable

Dim m_TableNameLeft As String

Source code

[Visual Basic]
    Dim m_TableNameLeft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


m_TableNameRight Variable

Dim m_TableNameRight As String

Source code

[Visual Basic]
    Dim m_TableNameRight As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentHierarchie


frmRolleDokumentTyp Class

For a list of all members of this type, see frmRolleDokumentTyp Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmRolleDokumentTyp

Public Class frmRolleDokumentTyp
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRolleDokumentTyp Members


frmRolleDokumentTyp Members

frmRolleDokumentTyp overview

Constructors

constructor frmRolleDokumentTyp Constructor

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

Methods

method BtnConnect_Click_1
method CheckedListBox1_ItemCheck
method CheckedListbox1_Selectedvalues
method Dispose
method FormSize
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MnuErstellung_Click
method MnuGesamt_Click
method MnuHost_Click
method MnuKundendossier_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_Click
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBBottom_Update
method TBLeft_Click
method TBLeft_FetchScrollTips
method TBRight_Click
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Close
method frmRolle_SysadminFunktion_Load
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

Fields

field BtnConnect
field CheckedListBox1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field FokusLeft
field FokusRight
field GroupBox1
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Set_Selected_Values
field Splitter1
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDataAdapter5
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field hierarchie
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRolleDokumentTyp Class


frmRolleDokumentTyp Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()

        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp Properties

frmRolleDokumentTyp overview

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

See Also

frmRolleDokumentTyp Class


frmRolleDokumentTyp.Eintrag Property

Property Eintrag() As String

Source code

[Visual Basic]
    Property Eintrag() As String
        Get
            Return m_Eintrag
        End Get
        Set(ByVal Value As String)
            m_Eintrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Eintragnr Property

Property Eintragnr() As Long

Source code

[Visual Basic]
    Property Eintragnr() As Long
        Get
            Return m_Eintragnr
        End Get
        Set(ByVal Value As Long)
            m_Eintragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.KeyLeft Property

Property KeyLeft() As Long

Source code

[Visual Basic]
    Property KeyLeft() As Long
        Get
            Return m_KeyLeft
        End Get
        Set(ByVal Value As Long)
            m_KeyLeft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.KeyRight Property

Property KeyRight() As Long

Source code

[Visual Basic]
    Property KeyRight() As Long
        Get
            Return m_KeyRight
        End Get
        Set(ByVal Value As Long)
            m_KeyRight = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TableNameBottom Property

Property TableNameBottom() As String

Source code

[Visual Basic]
    Property TableNameBottom() As String
        Get
            Return m_TableNameBottom
        End Get
        Set(ByVal Value As String)
            m_TableNameBottom = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TableNameLeft Property

Property TableNameLeft() As String

Source code

[Visual Basic]
    Property TableNameLeft() As String
        Get
            Return m_TableNameLeft
        End Get
        Set(ByVal Value As String)
            m_TableNameLeft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TableNameRight Property

Property TableNameRight() As String

Source code

[Visual Basic]
    Property TableNameRight() As String
        Get
            Return m_TableNameRight
        End Get
        Set(ByVal Value As String)
            m_TableNameRight = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp Methods

frmRolleDokumentTyp overview

Methods

method BtnConnect_Click_1
method CheckedListBox1_ItemCheck
method CheckedListbox1_Selectedvalues
method Dispose
method FormSize
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MnuErstellung_Click
method MnuGesamt_Click
method MnuHost_Click
method MnuKundendossier_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_Click
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBBottom_Update
method TBLeft_Click
method TBLeft_FetchScrollTips
method TBRight_Click
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Close
method frmRolle_SysadminFunktion_Load
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

See Also

frmRolleDokumentTyp Class


frmRolleDokumentTyp.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.CheckedListBox1_ItemCheck Method

Private Sub CheckedListBox1_ItemCheck( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemCheckEventArgs _
) Handles CheckedListBox1.ItemCheck

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckedListBox1_ItemCheck(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemCheckEventArgs) Handles CheckedListBox1.ItemCheck
        Dim i As Integer
        Dim bm As Long
        If Set_Selected_Values Then Exit Sub
        Select Case Me.CheckedListBox1.SelectedValue
            Case 1
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "anzeigen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 2
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "erstellen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 3
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "bearbeiten" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 4
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "loeschen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
            Case 5
                For i = 0 To TBBottom.Columns.Count - 1
                    If Me.TBBottom.Columns(i).DataField = "abschliessen" Then
                        Me.TBBottom.Columns(i).Value = e.NewValue
                    End If
                Next
        End Select
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.CheckedListbox1_Selectedvalues Method

Private Sub CheckedListbox1_Selectedvalues()

Source code

[Visual Basic]
    Private Sub CheckedListbox1_Selectedvalues()
        Dim i As Integer
        Set_Selected_Values = True
        Me.CheckedListBox1.SetItemChecked(0, False)
        Me.CheckedListBox1.SetItemChecked(1, False)
        Me.CheckedListBox1.SetItemChecked(2, False)
        Me.CheckedListBox1.SetItemChecked(3, False)
        Me.CheckedListBox1.SetItemChecked(4, False)
        Try
            For i = 0 To TBBottom.Columns.Count - 1
                If Me.TBBottom.Columns(i).DataField = "anzeigen" Then
                    Me.CheckedListBox1.SetItemChecked(0, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "erstellen" Then
                    Me.CheckedListBox1.SetItemChecked(1, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "bearbeiten" Then
                    Me.CheckedListBox1.SetItemChecked(2, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "loeschen" Then
                    Me.CheckedListBox1.SetItemChecked(3, Me.TBBottom.Columns(i).Text)
                End If
                If Me.TBBottom.Columns(i).DataField = "abschliessen" Then
                    Me.CheckedListBox1.SetItemChecked(4, Me.TBBottom.Columns(i).Text)
                End If
            Next
        Catch
        End Try
        Set_Selected_Values = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.FormSize Method

Public Sub FormSize( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub FormSize(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim ds As New edokadb.clsSysadminfunktion()
        Try
            ds.cpMainConnectionProvider = conn
            ds.iSysadminfnktnr = New SqlInt32(CType(m_Eintragnr, Int32))
            ds.SelectOne()
            If ds.iFleft.Value <> 0 Then Me.Left = ds.iFleft.Value
            If ds.iFtop.Value <> 0 Then Me.Top = ds.iFtop.Value
            If ds.iFwidth.Value <> 0 Then Me.Width = ds.iFwidth.Value
            If ds.iFheight.Value <> 0 Then Me.Height = ds.iFheight.Value
            Me.MenuItem1.Text = Me.Eintrag
        Catch
            '    MsgBox("Error Resizing Form")
        Finally
        End Try
        ds.Dispose()
        Me.Text = Me.Eintrag
        Try
            Globals.WinPos.Get_Position(Me)
        Catch
        Finally
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmRolleDokumentTyp))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarBtnSave = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.GrpRight = New System.Windows.Forms.GroupBox()
        Me.TBRight = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.GrpLeft = New System.Windows.Forms.GroupBox()
        Me.TBLeft = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.GrpFocus = New System.Windows.Forms.GroupBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.FokusRight = New System.Windows.Forms.RadioButton()
        Me.FokusLeft = New System.Windows.Forms.RadioButton()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.GrpBottom = New System.Windows.Forms.GroupBox()
        Me.TBBottom = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.CheckedListBox1 = New System.Windows.Forms.CheckedListBox()
        Me.Panel5 = New System.Windows.Forms.Panel()
        Me.BtnConnect = New System.Windows.Forms.Button()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.SqlDataAdapter4 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter5 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand5 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet5 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.Panel2.SuspendLayout()
        Me.GrpRight.SuspendLayout()
        CType(Me.TBRight, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpLeft.SuspendLayout()
        CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpFocus.SuspendLayout()
        Me.Panel3.SuspendLayout()
        Me.GrpBottom.SuspendLayout()
        CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox1.SuspendLayout()
        Me.Panel5.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarBtnSave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(640, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarBtnSave
        '
        Me.ToolBarBtnSave.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(640, 16)
        Me.Panel1.TabIndex = 1
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpRight, Me.Splitter1, Me.GrpLeft})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Location = New System.Drawing.Point(0, 41)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(640, 199)
        Me.Panel2.TabIndex = 2
        '
        'GrpRight
        '
        Me.GrpRight.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBRight})
        Me.GrpRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpRight.Location = New System.Drawing.Point(315, 0)
        Me.GrpRight.Name = "GrpRight"
        Me.GrpRight.Size = New System.Drawing.Size(325, 199)
        Me.GrpRight.TabIndex = 2
        Me.GrpRight.TabStop = False
        Me.GrpRight.Text = "GroupBox2"
        '
        'TBRight
        '
        Me.TBRight.AllowFilter = True
        Me.TBRight.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBRight.AllowSort = True
        Me.TBRight.AllowUpdate = False
        Me.TBRight.AlternatingRows = True
        Me.TBRight.CaptionHeight = 17
        Me.TBRight.CollapseColor = System.Drawing.Color.Black
        Me.TBRight.DataChanged = False
        Me.TBRight.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBRight.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBRight.ExpandColor = System.Drawing.Color.Black
        Me.TBRight.FilterBar = True
        Me.TBRight.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBRight.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.TBRight.Location = New System.Drawing.Point(3, 16)
        Me.TBRight.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBRight.Name = "TBRight"
        Me.TBRight.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBRight.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBRight.PreviewInfo.ZoomFactor = 75
        Me.TBRight.PrintInfo.ShowOptionsDialog = False
        Me.TBRight.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBRight.RowDivider = GridLines1
        Me.TBRight.RowHeight = 15
        Me.TBRight.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBRight.ScrollTips = False
        Me.TBRight.Size = New System.Drawing.Size(319, 180)
        Me.TBRight.TabIndex = 8
        Me.TBRight.Text = "C1TrueDBGrid1"
        Me.TBRight.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 315, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 315, 176</ClientArea></Blob>"
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(312, 0)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 199)
        Me.Splitter1.TabIndex = 1
        Me.Splitter1.TabStop = False
        '
        'GrpLeft
        '
        Me.GrpLeft.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBLeft})
        Me.GrpLeft.Dock = System.Windows.Forms.DockStyle.Left
        Me.GrpLeft.Name = "GrpLeft"
        Me.GrpLeft.Size = New System.Drawing.Size(312, 199)
        Me.GrpLeft.TabIndex = 0
        Me.GrpLeft.TabStop = False
        Me.GrpLeft.Text = "GroupBox1"
        '
        'TBLeft
        '
        Me.TBLeft.AllowFilter = True
        Me.TBLeft.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBLeft.AllowSort = True
        Me.TBLeft.AllowUpdate = False
        Me.TBLeft.AlternatingRows = True
        Me.TBLeft.CaptionHeight = 17
        Me.TBLeft.CollapseColor = System.Drawing.Color.Black
        Me.TBLeft.DataChanged = False
        Me.TBLeft.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBLeft.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBLeft.ExpandColor = System.Drawing.Color.Black
        Me.TBLeft.FilterBar = True
        Me.TBLeft.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBLeft.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.TBLeft.Location = New System.Drawing.Point(3, 16)
        Me.TBLeft.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBLeft.Name = "TBLeft"
        Me.TBLeft.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBLeft.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBLeft.PreviewInfo.ZoomFactor = 75
        Me.TBLeft.PrintInfo.ShowOptionsDialog = False
        Me.TBLeft.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBLeft.RowDivider = GridLines2
        Me.TBLeft.RowHeight = 15
        Me.TBLeft.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBLeft.ScrollTips = False
        Me.TBLeft.Size = New System.Drawing.Size(306, 180)
        Me.TBLeft.TabIndex = 8
        Me.TBLeft.Text = "C1TrueDBGrid1"
        Me.TBLeft.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 302, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 302, 176</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter2.Location = New System.Drawing.Point(0, 240)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(640, 3)
        Me.Splitter2.TabIndex = 3
        Me.Splitter2.TabStop = False
        '
        'GrpFocus
        '
        Me.GrpFocus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.FokusRight, Me.FokusLeft})
        Me.GrpFocus.Location = New System.Drawing.Point(216, 0)
        Me.GrpFocus.Name = "GrpFocus"
        Me.GrpFocus.Size = New System.Drawing.Size(200, 32)
        Me.GrpFocus.TabIndex = 17
        Me.GrpFocus.TabStop = False
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(78, 13)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(48, 16)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Fokus"
        '
        'FokusRight
        '
        Me.FokusRight.Location = New System.Drawing.Point(176, 12)
        Me.FokusRight.Name = "FokusRight"
        Me.FokusRight.Size = New System.Drawing.Size(16, 16)
        Me.FokusRight.TabIndex = 1
        '
        'FokusLeft
        '
        Me.FokusLeft.Location = New System.Drawing.Point(9, 13)
        Me.FokusLeft.Name = "FokusLeft"
        Me.FokusLeft.Size = New System.Drawing.Size(104, 16)
        Me.FokusLeft.TabIndex = 0
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpBottom, Me.Panel5, Me.Panel4})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel3.Location = New System.Drawing.Point(0, 243)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(640, 270)
        Me.Panel3.TabIndex = 18
        '
        'GrpBottom
        '
        Me.GrpBottom.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBBottom, Me.GroupBox1})
        Me.GrpBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GrpBottom.Location = New System.Drawing.Point(0, 40)
        Me.GrpBottom.Name = "GrpBottom"
        Me.GrpBottom.Size = New System.Drawing.Size(640, 190)
        Me.GrpBottom.TabIndex = 2
        Me.GrpBottom.TabStop = False
        Me.GrpBottom.Text = "GroupBox1"
        '
        'TBBottom
        '
        Me.TBBottom.AllowFilter = True
        Me.TBBottom.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.TBBottom.AllowSort = True
        Me.TBBottom.AlternatingRows = True
        Me.TBBottom.CaptionHeight = 17
        Me.TBBottom.CollapseColor = System.Drawing.Color.Black
        Me.TBBottom.DataChanged = False
        Me.TBBottom.DeadAreaBackColor = System.Drawing.Color.Gray
        Me.TBBottom.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TBBottom.ExpandColor = System.Drawing.Color.Black
        Me.TBBottom.FilterBar = True
        Me.TBBottom.GroupByCaption = "Drag a column header here to group by that column"
        Me.TBBottom.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.TBBottom.Location = New System.Drawing.Point(3, 16)
        Me.TBBottom.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
        Me.TBBottom.Name = "TBBottom"
        Me.TBBottom.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.TBBottom.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.TBBottom.PreviewInfo.ZoomFactor = 75
        Me.TBBottom.PrintInfo.ShowOptionsDialog = False
        Me.TBBottom.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.TBBottom.RowDivider = GridLines3
        Me.TBBottom.RowHeight = 15
        Me.TBBottom.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.TBBottom.ScrollTips = False
        Me.TBBottom.Size = New System.Drawing.Size(402, 171)
        Me.TBBottom.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.TBBottom.TabIndex = 11
        Me.TBBottom.Text = "C1TrueDBGrid1"
        Me.TBBottom.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 128;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:ControlLight;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFoo" & _
        "terHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWid" & _
        "th=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><C" & _
        "lientRect>0, 0, 398, 167</ClientRect><BorderSide>0</BorderSide><CaptionStyle par" & _
        "ent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowS" & _
        "tyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style" & _
        "13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""" & _
        "Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle paren" & _
        "t=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><O" & _
        "ddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSele" & _
        "ctor"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style paren" & _
        "t=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><" & _
        "Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style paren" & _
        "t=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""" & _
        "Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""N" & _
        "ormal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""N" & _
        "ormal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headin" & _
        "g"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""" & _
        "Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</hor" & _
        "zSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientA" & _
        "rea>0, 0, 398, 167</ClientArea></Blob>"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.CheckedListBox1})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Right
        Me.GroupBox1.Location = New System.Drawing.Point(405, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(232, 171)
        Me.GroupBox1.TabIndex = 10
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "GroupBox1"
        '
        'CheckedListBox1
        '
        Me.CheckedListBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.CheckedListBox1.Location = New System.Drawing.Point(3, 16)
        Me.CheckedListBox1.Name = "CheckedListBox1"
        Me.CheckedListBox1.Size = New System.Drawing.Size(226, 139)
        Me.CheckedListBox1.TabIndex = 0
        '
        'Panel5
        '
        Me.Panel5.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnConnect})
        Me.Panel5.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel5.Name = "Panel5"
        Me.Panel5.Size = New System.Drawing.Size(640, 40)
        Me.Panel5.TabIndex = 1
        '
        'BtnConnect
        '
        Me.BtnConnect.Location = New System.Drawing.Point(288, 8)
        Me.BtnConnect.Name = "BtnConnect"
        Me.BtnConnect.TabIndex = 0
        Me.BtnConnect.Text = "&Verbinden"
        '
        'Panel4
        '
        Me.Panel4.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel4.Location = New System.Drawing.Point(0, 230)
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(640, 40)
        Me.Panel4.TabIndex = 0
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem2})
        Me.MenuItem1.MergeOrder = 1
        Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
        Me.MenuItem1.Shortcut = System.Windows.Forms.Shortcut.F4
        Me.MenuItem1.Text = "&Datei"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 0
        Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
        Me.MenuItem3.Text = "&Daten sichern"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
        Me.MenuItem2.Text = "&Schliessen"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("rollelevel", "rollelevel"), New System.Data.Common.DataColumnMapping("sysadminrolle", "sysadminrolle"), New System.Data.Common.DataColumnMapping("zugehoerigkeit", "zugehoerigkeit"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollelevel", System.Data.SqlDbType.Int, 4, "rollelevel"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminrolle", System.Data.SqlDbType.Bit, 1, "sysadminrolle"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, "zugehoerigkeit"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollelevel", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollelevel", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminrolle", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminrolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zugehoerigkeit", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zugehoerigkeit", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "pv_berechtigung_aktiv_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_berechtigung_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_berechtigung_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_berechtigung_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_berechtigung_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter4
        '
        Me.SqlDataAdapter4.DeleteCommand = Me.SqlDeleteCommand4
        Me.SqlDataAdapter4.InsertCommand = Me.SqlInsertCommand4
        Me.SqlDataAdapter4.SelectCommand = Me.SqlSelectCommand4
        Me.SqlDataAdapter4.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("dokumentart_weitere", "dokumentart_weitere"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus"), New System.Data.Common.DataColumnMapping("Dokument_wird_erstellt", "Dokument_wird_erstellt"), New System.Data.Common.DataColumnMapping("Dokument_wird_retourniert", "Dokument_wird_retourniert")})})
        Me.SqlDataAdapter4.UpdateCommand = Me.SqlUpdateCommand4
        '
        'SqlDeleteCommand4
        '
        Me.SqlDeleteCommand4.CommandText = "[pv_dokumenttyp_delete]"
        Me.SqlDeleteCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand4.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand4
        '
        Me.SqlInsertCommand4.CommandText = "[pv_dokumenttyp_insert]"
        Me.SqlInsertCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand4.Connection = Me.SqlConnection1
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[pv_dokumenttyp_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand4
        '
        Me.SqlUpdateCommand4.CommandText = "[pv_dokumenttyp_update]"
        Me.SqlUpdateCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand4.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter5
        '
        Me.SqlDataAdapter5.DeleteCommand = Me.SqlDeleteCommand5
        Me.SqlDataAdapter5.InsertCommand = Me.SqlInsertCommand5
        Me.SqlDataAdapter5.SelectCommand = Me.SqlSelectCommand5
        Me.SqlDataAdapter5.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zu_vercolden", "zu_vercolden"), New System.Data.Common.DataColumnMapping("zu_retournieren", "zu_retournieren"), New System.Data.Common.DataColumnMapping("eingang_ersetzt_ausgang", "eingang_ersetzt_ausgang"), New System.Data.Common.DataColumnMapping("wird_importiert", "wird_importiert"), New System.Data.Common.DataColumnMapping("anzahl_tage", "anzahl_tage"), New System.Data.Common.DataColumnMapping("dbearbeitungszeit", "dbearbeitungszeit"), New System.Data.Common.DataColumnMapping("tage_mutation", "tage_mutation"), New System.Data.Common.DataColumnMapping("partnersaldierung_statusalt", "partnersaldierung_statusalt"), New System.Data.Common.DataColumnMapping("wird_nicht_geloescht", "wird_nicht_geloescht"), New System.Data.Common.DataColumnMapping("vertrauliches_dokument", "vertrauliches_dokument"), New System.Data.Common.DataColumnMapping("unterschrift_links", "unterschrift_links"), New System.Data.Common.DataColumnMapping("unterschrift_rechts", "unterschrift_rechts"), New System.Data.Common.DataColumnMapping("monate_bis_zur_archivierung", "monate_bis_zur_archivierung"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_elektronisch", "aufbewahrungsfrist_elektronisch"), New System.Data.Common.DataColumnMapping("aufbewahrungsfrist_physisch", "aufbewahrungsfrist_physisch"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("office_vorlagenr", "office_vorlagenr"), New System.Data.Common.DataColumnMapping("dokumentart_kundendossier", "dokumentart_kundendossier"), New System.Data.Common.DataColumnMapping("dokumentart_neuerstellung", "dokumentart_neuerstellung"), New System.Data.Common.DataColumnMapping("dokumentart_retournierung", "dokumentart_retournierung"), New System.Data.Common.DataColumnMapping("dokumentart_coldausgang", "dokumentart_coldausgang"), New System.Data.Common.DataColumnMapping("dokumentart_coldeingang", "dokumentart_coldeingang"), New System.Data.Common.DataColumnMapping("dokumentart_host", "dokumentart_host"), New System.Data.Common.DataColumnMapping("dokumentart_weitere", "dokumentart_weitere"), New System.Data.Common.DataColumnMapping("prozessnr", "prozessnr"), New System.Data.Common.DataColumnMapping("prozessnr1", "prozessnr1"), New System.Data.Common.DataColumnMapping("amsdokument", "amsdokument"), New System.Data.Common.DataColumnMapping("hostdokument", "hostdokument"), New System.Data.Common.DataColumnMapping("hostdokumenttyp", "hostdokumenttyp"), New System.Data.Common.DataColumnMapping("cold_folder", "cold_folder"), New System.Data.Common.DataColumnMapping("physisches_archiv", "physisches_archiv"), New System.Data.Common.DataColumnMapping("dokumentstatus", "dokumentstatus"), New System.Data.Common.DataColumnMapping("Dokument_wird_erstellt", "Dokument_wird_erstellt"), New System.Data.Common.DataColumnMapping("Dokument_wird_retourniert", "Dokument_wird_retourniert")})})
        Me.SqlDataAdapter5.UpdateCommand = Me.SqlUpdateCommand5
        '
        'SqlDeleteCommand5
        '
        Me.SqlDeleteCommand5.CommandText = "[pv_dokumenttyp_delete]"
        Me.SqlDeleteCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand5.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand5
        '
        Me.SqlInsertCommand5.CommandText = "[pv_dokumenttyp_insert]"
        Me.SqlInsertCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand5.Connection = Me.SqlConnection1
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlInsertCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        '
        'SqlSelectCommand5
        '
        Me.SqlSelectCommand5.CommandText = "[pv_dokumenttyp_select]"
        Me.SqlSelectCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand5.Connection = Me.SqlConnection1
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlUpdateCommand5
        '
        Me.SqlUpdateCommand5.CommandText = "[pv_dokumenttyp_update]"
        Me.SqlUpdateCommand5.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand5.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_vercolden", System.Data.SqlDbType.Bit, 1, "zu_vercolden"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zu_retournieren", System.Data.SqlDbType.Bit, 1, "zu_retournieren"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, "eingang_ersetzt_ausgang"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_importiert", System.Data.SqlDbType.Bit, 1, "wird_importiert"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzahl_tage", System.Data.SqlDbType.Int, 4, "anzahl_tage"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dbearbeitungszeit", System.Data.SqlDbType.Int, 4, "dbearbeitungszeit"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tage_mutation", System.Data.SqlDbType.Int, 4, "tage_mutation"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, "partnersaldierung_statusalt"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, "wird_nicht_geloescht"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, "vertrauliches_dokument"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_links", System.Data.SqlDbType.Bit, 1, "unterschrift_links"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_rechts", System.Data.SqlDbType.Bit, 1, "unterschrift_rechts"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, "monate_bis_zur_archivierung"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_elektronisch"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, "aufbewahrungsfrist_physisch"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@office_vorlagenr", System.Data.SqlDbType.Int, 4, "office_vorlagenr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, "dokumentart_kundendossier"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, "dokumentart_neuerstellung"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_retournierung", System.Data.SqlDbType.Int, 4, "dokumentart_retournierung"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, "dokumentart_coldausgang"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, "dokumentart_coldeingang"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_host", System.Data.SqlDbType.Int, 4, "dokumentart_host"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentart_weitere", System.Data.SqlDbType.Int, 4, "dokumentart_weitere"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr", System.Data.SqlDbType.Int, 4, "prozessnr"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@prozessnr1", System.Data.SqlDbType.Int, 4, "prozessnr1"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@amsdokument", System.Data.SqlDbType.Bit, 1, "amsdokument"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokument", System.Data.SqlDbType.Bit, 1, "hostdokument"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, "hostdokumenttyp"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_folder", System.Data.SqlDbType.Int, 4, "cold_folder"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@physisches_archiv", System.Data.SqlDbType.Int, 4, "physisches_archiv"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentstatus", System.Data.SqlDbType.Int, 4, "dokumentstatus"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, "Dokument_wird_erstellt"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, "Dokument_wird_retourniert"))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_erstellt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_erstellt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Dokument_wird_retourniert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Dokument_wird_retourniert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_amsdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "amsdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzahl_tage", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzahl_tage", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_elektronisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_elektronisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aufbewahrungsfrist_physisch", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aufbewahrungsfrist_physisch", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_folder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_folder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dbearbeitungszeit", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dbearbeitungszeit", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldausgang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_coldeingang", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_coldeingang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_host", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_host", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_kundendossier", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_kundendossier", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_neuerstellung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_neuerstellung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_retournierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_retournierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentart_weitere", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentart_weitere", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentstatus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentstatus", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_eingang_ersetzt_ausgang", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "eingang_ersetzt_ausgang", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_hostdokumenttyp", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "hostdokumenttyp", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_monate_bis_zur_archivierung", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "monate_bis_zur_archivierung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_office_vorlagenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "office_vorlagenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnersaldierung_statusalt", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnersaldierung_statusalt", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_physisches_archiv", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "physisches_archiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_prozessnr1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "prozessnr1", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tage_mutation", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tage_mutation", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_links", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_links", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_rechts", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_rechts", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertrauliches_dokument", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertrauliches_dokument", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_importiert", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_importiert", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_wird_nicht_geloescht", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "wird_nicht_geloescht", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_retournieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_retournieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand5.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zu_vercolden", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zu_vercolden", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet5
        '
        Me.DataSet5.DataSetName = "NewDataSet"
        Me.DataSet5.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle_dokumenttyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rolle_dokumenttyp_nr", "rolle_dokumenttyp_nr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("berechtigungnr", "berechtigungnr"), New System.Data.Common.DataColumnMapping("ausschluss", "ausschluss"), New System.Data.Common.DataColumnMapping("normal", "normal"), New System.Data.Common.DataColumnMapping("vertraulich_gestattet", "vertraulich_gestattet"), New System.Data.Common.DataColumnMapping("mitarbeiter_gestattet", "mitarbeiter_gestattet"), New System.Data.Common.DataColumnMapping("chiffre_gestattet", "chiffre_gestattet"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("anzeigen", "anzeigen"), New System.Data.Common.DataColumnMapping("erstellen", "erstellen"), New System.Data.Common.DataColumnMapping("bearbeiten", "bearbeiten"), New System.Data.Common.DataColumnMapping("loeschen", "loeschen"), New System.Data.Common.DataColumnMapping("abschliessen", "abschliessen")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_rolle_dokumenttyp_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_dokumenttyp_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_dokumenttyp_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_abschliessen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "abschliessen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzeigen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzeigen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausschluss", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausschluss", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bearbeiten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bearbeiten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_chiffre_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "chiffre_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_normal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "normal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich_gestattet", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_rolle_dokumenttyp_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_dokumenttyp_nr", System.Data.SqlDbType.Int, 4, "rolle_dokumenttyp_nr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausschluss", System.Data.SqlDbType.Bit, 1, "ausschluss"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@normal", System.Data.SqlDbType.Bit, 1, "normal"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, "vertraulich_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, "mitarbeiter_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@chiffre_gestattet", System.Data.SqlDbType.Bit, 1, "chiffre_gestattet"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzeigen", System.Data.SqlDbType.Bit, 1, "anzeigen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellen", System.Data.SqlDbType.Bit, 1, "erstellen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bearbeiten", System.Data.SqlDbType.Bit, 1, "bearbeiten"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschen", System.Data.SqlDbType.Bit, 1, "loeschen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@abschliessen", System.Data.SqlDbType.Bit, 1, "abschliessen"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[sp_rolle_dokumenttyp_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_rolle_dokumenttyp_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_dokumenttyp_nr", System.Data.SqlDbType.Int, 4, "rolle_dokumenttyp_nr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumenttypnr", System.Data.SqlDbType.Int, 4, "dokumenttypnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@berechtigungnr", System.Data.SqlDbType.Int, 4, "berechtigungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ausschluss", System.Data.SqlDbType.Bit, 1, "ausschluss"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@normal", System.Data.SqlDbType.Bit, 1, "normal"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, "vertraulich_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, "mitarbeiter_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@chiffre_gestattet", System.Data.SqlDbType.Bit, 1, "chiffre_gestattet"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@anzeigen", System.Data.SqlDbType.Bit, 1, "anzeigen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellen", System.Data.SqlDbType.Bit, 1, "erstellen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bearbeiten", System.Data.SqlDbType.Bit, 1, "bearbeiten"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschen", System.Data.SqlDbType.Bit, 1, "loeschen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@abschliessen", System.Data.SqlDbType.Bit, 1, "abschliessen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_dokumenttyp_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_dokumenttyp_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_abschliessen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "abschliessen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_anzeigen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "anzeigen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ausschluss", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ausschluss", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bearbeiten", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bearbeiten", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_berechtigungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "berechtigungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_chiffre_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "chiffre_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumenttypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumenttypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiter_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiter_gestattet", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_normal", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "normal", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vertraulich_gestattet", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vertraulich_gestattet", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmRolleDokumentTyp
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(640, 513)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.GrpFocus, Me.Splitter2, Me.Panel2, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmRolleDokumentTyp"
        Me.Text = "frmRelEditor"
        Me.Panel2.ResumeLayout(False)
        Me.GrpRight.ResumeLayout(False)
        CType(Me.TBRight, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpLeft.ResumeLayout(False)
        CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpFocus.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        Me.GrpBottom.ResumeLayout(False)
        CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox1.ResumeLayout(False)
        Me.Panel5.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet5, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsRolle_dokumenttyp()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iDokumenttypnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.bAbschliessen = New SqlBoolean(CType(False, Boolean))
            vdata.bAnzeigen = New SqlBoolean(CType(False, Boolean))
            vdata.bErstellen = New SqlBoolean(CType(False, Boolean))
            vdata.bBearbeiten = New SqlBoolean(CType(False, Boolean))
            vdata.bLoeschen = New SqlBoolean(CType(False, Boolean))

            vdata.bAusschluss = New SqlBoolean(CType(False, Boolean))
            vdata.bMitarbeiter_gestattet = New SqlBoolean(CType(False, Boolean))
            vdata.bVertraulich_gestattet = New SqlBoolean(CType(False, Boolean))
            vdata.bChiffre_gestattet = New SqlBoolean(CType(False, Boolean))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("rolle_dokumenttyp")
            vdata.iRolle_dokumenttyp_nr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft
        UpdateGrpText(5032, 5033, 5034)
        Me.GroupBox1.Text = Globals.MyTxt.gettext(5041)

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter5.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter5.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter5.Fill(Me.DataSet5)
        Me.TBRight.DataSource = Me.DataSet5
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet5)

        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet4)
        Me.CheckedListBox1.DataSource = Me.DataSet4.Tables(0)
        Me.CheckedListBox1.ValueMember = "berechtigungnr"
        Me.CheckedListBox1.DisplayMember = "bezeichnung"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MnuErstellung_Click Method

Private Sub MnuErstellung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuErstellung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(4)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MnuGesamt_Click Method

Private Sub MnuGesamt_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuGesamt_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(1)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MnuHost_Click Method

Private Sub MnuHost_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuHost_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(3)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.MnuKundendossier_Click Method

Private Sub MnuKundendossier_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuKundendossier_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            Me.DataSet2.Tables.Clear()
        Catch
        End Try
        Dim hdata As New edokadb.clsMyDokumentart()
        hdata.cpMainConnectionProvider = conn
        hierarchie = hdata.SelectHierarchy_Parametrisierung_By_Root(2)
        Me.TBRight.DataSource = hierarchie
        Me.DataSet2.Tables.Add(hierarchie)
        SpaltenTitel_Aktualisieren(2, "dokumentart", Me.DataSet2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
        CheckedListbox1_Selectedvalues()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tblnr As Integer, _
   ByVal tblname As String, _
   ByVal ds As DataSet _
)

Parameters

tblnr
Required.
tblname
Required.
ds
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        t = ds.Tables(0)
        If tblnr = 1 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBLeft.Columns.Count - 1
                Dim s As String
                s = Me.TBLeft.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                If ts.spaltenname <> "" Then
                    Me.TBLeft.Columns(i).Caption = ts.spaltenname
                    If Me.TBLeft.Columns(i).Caption = "" Then
                        Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                    Else
                        Me.TBLeft.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If
                    If ts.locked Then
                        Me.TBLeft.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If
                    'Präsentation von aktiv
                    If Me.TBLeft.Columns(i).DataField = "aktiv" Then
                        Me.TBLeft.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.TBLeft.Columns(i).ValueItems.DefaultItem = True
                        Me.TBLeft.Columns(i).DefaultValue = True
                        Me.TBLeft.Columns(i).FilterText = True
                    End If
                    If Me.TBLeft.Columns(i).DataField = "erstellt_am" Then
                        Me.TBLeft.Columns(i).DefaultValue = Now
                    End If
                Else
                    Me.TBLeft.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
        If tblnr = 2 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBRight.Columns.Count - 1
                Dim s As String
                s = Me.TBRight.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBRight.Columns(i).Caption = ts.spaltenname
                If Me.TBRight.Columns(i).Caption = "" Then
                    Me.TBRight.Splits(0).DisplayColumns(i).Width = 0
                Else
                    Me.TBRight.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                If ts.locked Then
                    Me.TBRight.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBRight.Columns(i).DataField = "aktiv" Then
                    Me.TBRight.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBRight.Columns(i).ValueItems.DefaultItem = True
                    Me.TBRight.Columns(i).DefaultValue = True
                    Me.TBRight.Columns(i).FilterText = True
                End If
                If Me.TBRight.Columns(i).DataField = "erstellt_am" Then
                    Me.TBRight.Columns(i).DefaultValue = Now
                End If
            Next
        End If
        If tblnr = 3 Then
            ts.Tabelle = tblname
            For i = 0 To Me.TBBottom.Columns.Count - 1
                Dim s As String
                s = Me.TBBottom.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                Me.TBBottom.Columns(i).Caption = ts.spaltenname
                If Me.TBBottom.Columns(i).Caption = "" Then
                    Me.TBBottom.Splits(0).DisplayColumns(i).Width = 0
                Else
                    Me.TBBottom.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                If ts.locked Then
                    Me.TBBottom.Splits(0).DisplayColumns(i).Locked = True
                End If
                If ts.AlsHacken Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                    Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                    Me.TBBottom.Columns(i).DefaultValue = True
                    Me.TBBottom.Columns(i).FilterText = True
                End If
                If Me.TBBottom.Columns(i).DataField = "erstellt_am" Then
                    Me.TBBottom.Columns(i).DefaultValue = Now
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Splitter1_SplitterMoved Method

Private Sub Splitter1_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter1.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splitter1_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter1.SplitterMoved
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.Splitter2_SplitterMoved Method

Private Sub Splitter2_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter2.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splitter2_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter2.SplitterMoved
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBBottom_Click Method

Private Sub TBBottom_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBBottom.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBBottom.RowColChange
        check_changes()
        CheckedListbox1_Selectedvalues()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBBottom_FetchScrollTips Method

Private Sub TBBottom_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBBottom.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBBottom.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBBottom.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBBottom_Format Method

Public Sub TBBottom_Format()

Source code

[Visual Basic]
    Public Sub TBBottom_Format()
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            'Präsentation von aktiv
            If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).DefaultValue = True
                Me.TBBottom.Splits(0).DisplayColumns(i).Locked = False
            End If
            If Me.TBBottom.Columns(i).DataField = "zwingend" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                Me.TBBottom.Columns(i).DefaultValue = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBLeft_FetchScrollTips Method

Private Sub TBLeft_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBLeft.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBLeft.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBLeft.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.TBRight_FetchScrollTips Method

Private Sub TBRight_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBRight.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBRight.FetchScrollTips
        Select Case e.ScrollBar
            Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBRight.Splits(0).Rows.Count)
        End Select
        e.TipStyle.ForeColor = Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.UpdateGrpText Method

Public Sub UpdateGrpText( _
   ByVal w1 As Integer, _
   ByVal w2 As Integer, _
   ByVal w3 As Integer _
)

Parameters

w1
Required.
w2
Required.
w3
Required.

Source code

[Visual Basic]
    Public Sub UpdateGrpText(ByVal w1 As Integer, ByVal w2 As Integer, ByVal w3 As Integer)
        Me.GrpLeft.Text = Globals.MyTxt.gettext(w1)
        Me.GrpRight.Text = Globals.MyTxt.gettext(w2)
        Me.GrpBottom.Text = Globals.MyTxt.gettext(w3)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmRolle_SysadminFunktion_Close Method

Private Sub frmRolle_SysadminFunktion_Close( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Close(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "rolle"
        Me.TableNameRight = "dokumenttyp"
        Me.TableNameBottom = "rolle_dokumenttyp"
        LoadData()
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        Me.TBLeft.Columns("rollelevel").FilterText = 3
        Me.TBLeft.ScrollTips = True
        Me.TBBottom.ScrollTips = True
        Me.TBRight.ScrollTips = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmVerbEditor_Layout Method

Private Sub frmVerbEditor_Layout( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.LayoutEventArgs _
) Handles MyBase.Layout

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_Layout(ByVal sender As System.Object, ByVal e As System.Windows.Forms.LayoutEventArgs) Handles MyBase.Layout
        Me.GrpLeft.Width = Me.ClientSize.Width / 2
        Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmVerbEditor_Load Method

Private Sub frmVerbEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.FokusLeft.Checked = True
        Me.FokusRight.Checked = False
        Me.Text = Me.Eintrag
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp.frmVerbEditor_WndChange Method

Private Sub frmVerbEditor_WndChange( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVerbEditor_WndChange(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.GrpLeft.Width = Me.ClientSize.Width / 2
        Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
        Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleDokumentTyp Fields

frmRolleDokumentTyp overview

Fields

field BtnConnect
field CheckedListBox1
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field DataSet5
field FokusLeft
field FokusRight
field GroupBox1
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Set_Selected_Values
field Splitter1
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDataAdapter5
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlDeleteCommand5
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlInsertCommand4
field SqlInsertCommand5
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlSelectCommand4
field SqlSelectCommand5
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field SqlUpdateCommand4
field SqlUpdateCommand5
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field hierarchie
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRolleDokumentTyp Class


BtnConnect Variable

Friend WithEvents BtnConnect As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnConnect As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


CheckedListBox1 Variable

Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Source code

[Visual Basic]
    Friend WithEvents CheckedListBox1 As System.Windows.Forms.CheckedListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


DataSet5 Variable

Friend WithEvents DataSet5 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet5 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


FokusLeft Variable

Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents FokusLeft As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


FokusRight Variable

Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents FokusRight As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


GrpBottom Variable

Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpBottom As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


GrpFocus Variable

Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpFocus As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


GrpLeft Variable

Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpLeft As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


GrpRight Variable

Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpRight As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Panel5 Variable

Friend WithEvents Panel5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Set_Selected_Values Variable

Dim Set_Selected_Values As Boolean

Source code

[Visual Basic]
    Dim Set_Selected_Values As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDataAdapter4 Variable

Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDataAdapter5 Variable

Friend WithEvents SqlDataAdapter5 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter5 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDeleteCommand4 Variable

Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlDeleteCommand5 Variable

Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlInsertCommand4 Variable

Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlInsertCommand5 Variable

Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlSelectCommand5 Variable

Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlUpdateCommand4 Variable

Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


SqlUpdateCommand5 Variable

Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand5 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


TBBottom Variable

Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBBottom As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


TBLeft Variable

Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBLeft As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


TBRight Variable

Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents TBRight As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


ToolBarBtnSave Variable

Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarBtnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


hierarchie Variable

Dim hierarchie As DataTable

Source code

[Visual Basic]
    Dim hierarchie As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
    Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
    Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_KeyLeft Variable

Dim m_KeyLeft As Long

Source code

[Visual Basic]
    Dim m_KeyLeft As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_KeyRight Variable

Dim m_KeyRight As Long

Source code

[Visual Basic]
    Dim m_KeyRight As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_TableNameBottom Variable

Dim m_TableNameBottom As String

Source code

[Visual Basic]
    Dim m_TableNameBottom As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_TableNameLeft Variable

Dim m_TableNameLeft As String

Source code

[Visual Basic]
    Dim m_TableNameLeft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


m_TableNameRight Variable

Dim m_TableNameRight As String

Source code

[Visual Basic]
    Dim m_TableNameRight As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleDokumentTyp


frmRolleReportGruppe Class

For a list of all members of this type, see frmRolleReportGruppe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmRolleReportGruppe

Public Class frmRolleReportGruppe
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRolleReportGruppe Members


frmRolleReportGruppe Members

frmRolleReportGruppe overview

Constructors

constructor frmRolleReportGruppe Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolleReportGruppe Class


frmRolleReportGruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe Properties

frmRolleReportGruppe overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmRolleReportGruppe Class


frmRolleReportGruppe Methods

frmRolleReportGruppe overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmRolleReportGruppe Class


frmRolleReportGruppe.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet2 = New System.Data.DataSet()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "report_gruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("report_gruppenr", "report_gruppenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_reportgruppe_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_reportgruppe_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_reportgruppe_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_reportgruppe_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle_report_gruppe", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rolle_report_gruppe_nr", "rolle_report_gruppe_nr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("report_gruppenr", "report_gruppenr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_rolle_report_gruppe_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_report_gruppe_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_report_gruppe_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_rolle_report_gruppe_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_report_gruppe_nr", System.Data.SqlDbType.Int, 4, "rolle_report_gruppe_nr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_rolle_report_gruppe_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_rolle_report_gruppe_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_report_gruppe_nr", System.Data.SqlDbType.Int, 4, "rolle_report_gruppe_nr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@report_gruppenr", System.Data.SqlDbType.Int, 4, "report_gruppenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_report_gruppe_nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_report_gruppe_nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_report_gruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "report_gruppenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmRolleReportGruppe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmRolleReportGruppe"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsRolle_report_gruppe()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iReport_gruppenr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iReport_gruppenr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iRolle_report_gruppe_nr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("rolle_report_gruppe")
            vdata.iRolle_report_gruppe_nr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        'Me.TBRight.DataMember = Me.TableNameRight
        Me.TBRight.DataMember = Me.DataSet2.Tables(0).TableName
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5026, 5027, 5028)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()

        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        MsgBox(Me.DataSet3.Tables(0).Rows.Count)
        Me.TBBottom.DataMember = Me.DataSet3.Tables(0).TableName
        'Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "rolle"
        Me.TableNameRight = "reportgruppe"
        Me.TableNameBottom = "rolle_report_gruppe"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolleReportGruppe Fields

frmRolleReportGruppe overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolleReportGruppe Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolleReportGruppe


frmRolle_Sysadminfunktion Class

For a list of all members of this type, see frmRolle_Sysadminfunktion Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmRolle_Sysadminfunktion

Public Class frmRolle_Sysadminfunktion
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRolle_Sysadminfunktion Members


frmRolle_Sysadminfunktion Members

frmRolle_Sysadminfunktion overview

Constructors

constructor frmRolle_Sysadminfunktion Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolle_Sysadminfunktion Class


frmRolle_Sysadminfunktion Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion Properties

frmRolle_Sysadminfunktion overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmRolle_Sysadminfunktion Class


frmRolle_Sysadminfunktion Methods

frmRolle_Sysadminfunktion overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmRolle_Sysadminfunktion Class


frmRolle_Sysadminfunktion.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_rolle_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_rolle_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_rolle_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_rolle_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sysadminfunktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("sysadminfnktnr", "sysadminfnktnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("ParentID", "ParentID"), New System.Data.Common.DataColumnMapping("Sort", "Sort"), New System.Data.Common.DataColumnMapping("ImageIndex", "ImageIndex"), New System.Data.Common.DataColumnMapping("ImageIndexOpen", "ImageIndexOpen"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pf_sysadminfunktion_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pf_sysadminfunktion_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParentID", System.Data.SqlDbType.Int, 4, "ParentID"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Sort", System.Data.SqlDbType.Int, 4, "Sort"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndex", System.Data.SqlDbType.Int, 4, "ImageIndex"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndexOpen", System.Data.SqlDbType.Int, 4, "ImageIndexOpen"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pf_sysadminfunktion_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ParentID", System.Data.SqlDbType.Int, 4, "ParentID"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Sort", System.Data.SqlDbType.Int, 4, "Sort"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndex", System.Data.SqlDbType.Int, 4, "ImageIndex"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ImageIndexOpen", System.Data.SqlDbType.Int, 4, "ImageIndexOpen"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndexOpen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndexOpen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParentID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParentID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pf_sysadminfunktion_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndex", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndex", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ImageIndexOpen", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ImageIndexOpen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ParentID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ParentID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Sort", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Sort", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "rolle_sysadminfunktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("rolle_sysadminfnktnr", "rolle_sysadminfnktnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("sysadminfnktnr", "sysadminfnktnr"), New System.Data.Common.DataColumnMapping("rollenr", "rollenr"), New System.Data.Common.DataColumnMapping("mandant", "mandant")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_rolle_sysadminfunktion_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_rolle_sysadminfunktion_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_sysadminfnktnr", System.Data.SqlDbType.Int, 4, "rolle_sysadminfnktnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandant", System.Data.SqlDbType.Int, 4, "mandant"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_rolle_sysadminfunktion_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rolle_sysadminfnktnr", System.Data.SqlDbType.Int, 4, "rolle_sysadminfnktnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sysadminfnktnr", System.Data.SqlDbType.Int, 4, "sysadminfnktnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@rollenr", System.Data.SqlDbType.Int, 4, "rollenr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandant", System.Data.SqlDbType.Int, 4, "mandant"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_rolle_sysadminfunktion_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rolle_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rolle_sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_rollenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "rollenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sysadminfnktnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sysadminfnktnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmRolle_Sysadmin
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmRolle_Sysadmin"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsRolle_sysadminfunktion()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandant = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iSysadminfnktnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iSysadminfnktnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iRollenr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iSysadminfnktnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("rolle_sysadminfunktion")
            vdata.iRolle_sysadminfnktnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim t As DataTable

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5000, 5001, 5002)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableNameLeft = "rolle"
        Me.TableNameRight = "sysadminfunktion"
        Me.TableNameBottom = "rolle_sysadminfunktion"
        LoadData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmRolle_Sysadminfunktion Fields

frmRolle_Sysadminfunktion overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmRolle_Sysadminfunktion Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRolle_Sysadminfunktion


frmSBPDFPrinter Class

For a list of all members of this type, see frmSBPDFPrinter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSBPDFPrinter

Public Class frmSBPDFPrinter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSBPDFPrinter Members


frmSBPDFPrinter Members

frmSBPDFPrinter overview

Constructors

constructor frmSBPDFPrinter Constructor (Overloaded)

Methods

method Button1_Click
method Button2_Click
method Dispose
method Get_Druckjob
method InitializeComponent
method PrintPDF
method delay
method frmPDFPrinter_Load
method frmSBPDFPrinter_Closing
method inetOptionsMI_Click

Events

event PrintDOne

Fields

field Button1
field Button2
field ImageList1
field Label1
field MenuItem13
field Panel1
field PictureBox2
field StatusBar1
field addressBar
field components
field contextMenu
field m_druckjobnr
field m_showdoc
field webOCWrapper

See Also

frmSBPDFPrinter Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal druckjobnr As Integer, ByVal ShowDoc As Boolean)

See Also

frmSBPDFPrinter | EDOKAApp


frmSBPDFPrinter Methods

frmSBPDFPrinter overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Get_Druckjob
method InitializeComponent
method PrintPDF
method delay
method frmPDFPrinter_Load
method frmSBPDFPrinter_Closing
method inetOptionsMI_Click

See Also

frmSBPDFPrinter Class


frmSBPDFPrinter.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Yes
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.No
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.Get_Druckjob Method

Private Function Get_Druckjob()

Source code

[Visual Basic]
    Private Function Get_Druckjob()
        Try
            ''Test BUD
            'If m_mitPfadNormal = True Then
            '    Dim dokumentname2 = m_Pfad
            '    Me.addressBar.Text = dokumentname2
            '    Return True
            '    Exit Function
            'End If

            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.m_druckjobnr.ToString + "_empfaenger.pdf"
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_druckjob where druckjobnr=" + Me.m_druckjobnr.ToString, Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(716, MsgBoxStyle.Critical)
                    Return False
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(6)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                    Me.addressBar.Text = dokumentname
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(716, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
                Return False
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(716, MsgBoxStyle.Critical)
            Return False
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSBPDFPrinter))
        Me.contextMenu = New System.Windows.Forms.ContextMenu()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.addressBar = New System.Windows.Forms.ComboBox()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.PictureBox2 = New System.Windows.Forms.PictureBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.webOCWrapper = New EDOKAApp.WebOCHostCtrl()
        Me.Panel1.SuspendLayout()
        Me.SuspendLayout()
        '
        'contextMenu
        '
        Me.contextMenu.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem13})
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 0
        Me.MenuItem13.Text = "Print..."
        '
        'StatusBar1
        '
        Me.StatusBar1.Anchor = ((System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.StatusBar1.Dock = System.Windows.Forms.DockStyle.None
        Me.StatusBar1.Location = New System.Drawing.Point(0, 405)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(624, 24)
        Me.StatusBar1.TabIndex = 1
        '
        'addressBar
        '
        Me.addressBar.Location = New System.Drawing.Point(16, 56)
        Me.addressBar.Name = "addressBar"
        Me.addressBar.Size = New System.Drawing.Size(352, 21)
        Me.addressBar.Sorted = True
        Me.addressBar.TabIndex = 3
        Me.addressBar.Visible = False
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.PictureBox2, Me.Button2, Me.Label1, Me.Button1})
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(368, 176)
        Me.Panel1.TabIndex = 10
        '
        'PictureBox2
        '
        Me.PictureBox2.Image = CType(resources.GetObject("PictureBox2.Image"), System.Drawing.Bitmap)
        Me.PictureBox2.Location = New System.Drawing.Point(16, 8)
        Me.PictureBox2.Name = "PictureBox2"
        Me.PictureBox2.Size = New System.Drawing.Size(40, 50)
        Me.PictureBox2.TabIndex = 15
        Me.PictureBox2.TabStop = False
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(160, 88)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&Nein"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(56, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(264, 48)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Sind die Dokumente des Druckstapels erfolgreich gedruckt worden?"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(240, 88)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&Ja"
        '
        'webOCWrapper
        '
        Me.webOCWrapper.BrowserContextMenu = False
        Me.webOCWrapper.Dock = System.Windows.Forms.DockStyle.Fill
        Me.webOCWrapper.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.webOCWrapper.Name = "webOCWrapper"
        Me.webOCWrapper.Size = New System.Drawing.Size(320, 125)
        Me.webOCWrapper.TabIndex = 11
        Me.webOCWrapper.TabStop = False
        '
        'frmSBPDFPrinter
        '
        Me.AutoScale = False
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(320, 125)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.StatusBar1, Me.addressBar, Me.webOCWrapper})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSBPDFPrinter"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Serienbriefe drucken"
        Me.Panel1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.PrintPDF Method

Public Sub PrintPDF()

Source code

[Visual Basic]
    Public Sub PrintPDF()
        delay(2)
        '----------------------------
        ' Taskforce Korrektur
        ' BUD - 21.03.2006
        '----------------------------
        'webOCWrapper.Print(doUI:=True)
        Dim objpdf As New clsPDF_print_show()
        objpdf.PrintPDF(addressBar.Text, clsPDF_print_show.Enum_Art.Drucken)
        'MsgBox(MyTxt.gettext(618), MsgBoxStyle.Information, "Banklagernd Druck")
        '----------------------------
        Me.Button1.Enabled = True
        Application.DoEvents()
        Dim i As Integer
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.delay Method

Private Sub delay( _
   ByVal seconds As Integer _
)

Parameters

seconds
Required.

Source code

[Visual Basic]
    Private Sub delay(ByVal seconds As Integer)
        Me.Cursor = Cursors.WaitCursor
        Dim starttime As DateTime = DateTime.Now
        Do
            Application.DoEvents()
        Loop While DateTime.Now.Subtract(starttime).TotalSeconds < seconds
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.frmPDFPrinter_Load Method

Private Sub frmPDFPrinter_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmPDFPrinter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Get_Druckjob()
        If Me.m_showdoc = True Then
            Me.Width = Me.Width * 2.5
            Me.Height = Me.Height * 3.5
            Me.Panel1.Visible = False
            webOCWrapper.Navigate(addressBar.Text)
        Else
            '----------------------------
            ' Taskforce Korrektur
            ' BUD - 21.03.2006
            '----------------------------
            'webOCWrapper.Navigate(addressBar.Text)
            '----------------------------
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.frmSBPDFPrinter_Closing Method

Private Sub frmSBPDFPrinter_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSBPDFPrinter_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Me.Hide()
        If Me.DialogResult = DialogResult.Yes Then RaiseEvent PrintDOne()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter.inetOptionsMI_Click Method

Private Sub inetOptionsMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub inetOptionsMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.InternetOptions()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter Events

frmSBPDFPrinter overview

Events

event PrintDOne

See Also

frmSBPDFPrinter Class


PrintDOne Event

Public Event PrintDOne()

Source code

[Visual Basic]
    Public Event PrintDOne()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter Fields

frmSBPDFPrinter overview

Fields

field Button1
field Button2
field ImageList1
field Label1
field MenuItem13
field Panel1
field PictureBox2
field StatusBar1
field addressBar
field components
field contextMenu
field m_druckjobnr
field m_showdoc
field webOCWrapper

See Also

frmSBPDFPrinter Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


PictureBox2 Variable

Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents PictureBox2 As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


addressBar Variable

Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


contextMenu Variable

Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


m_druckjobnr Variable

Dim m_druckjobnr As Integer

Source code

[Visual Basic]
    Dim m_druckjobnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


m_showdoc Variable

Dim m_showdoc As Boolean = True

Source code

[Visual Basic]
    Dim m_showdoc As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


webOCWrapper Variable

Friend WithEvents webOCWrapper As WebOCHostCtrl

Source code

[Visual Basic]
    Friend WithEvents webOCWrapper As WebOCHostCtrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBSpaltenDarstellung Class

For a list of all members of this type, see frmSBSpaltenDarstellung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSBSpaltenDarstellung

Public Class frmSBSpaltenDarstellung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSBSpaltenDarstellung Members


frmSBSpaltenDarstellung Members

frmSBSpaltenDarstellung overview

Constructors

constructor frmSBSpaltenDarstellung Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox2_DoubleClick
method ToolBar1_ButtonClick
method frmSpaltenDarstellung_Load

Fields

field Button1
field Button2
field ImageList1
field Label1
field Label2
field ListBox1
field ListBox2
field ToolBar1
field ToolBarButton1
field components

See Also

frmSBSpaltenDarstellung Class


frmSBSpaltenDarstellung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung Methods

frmSBSpaltenDarstellung overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox2_DoubleClick
method ToolBar1_ButtonClick
method frmSpaltenDarstellung_Load

See Also

frmSBSpaltenDarstellung Class


frmSBSpaltenDarstellung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        ListBox1_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        ListBox2_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSBSpaltenDarstellung))
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.ListBox2 = New System.Windows.Forms.ListBox()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 56)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox1.Size = New System.Drawing.Size(184, 329)
        Me.ListBox1.Sorted = True
        Me.ListBox1.TabIndex = 0
        '
        'ListBox2
        '
        Me.ListBox2.Location = New System.Drawing.Point(232, 56)
        Me.ListBox2.Name = "ListBox2"
        Me.ListBox2.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox2.Size = New System.Drawing.Size(184, 329)
        Me.ListBox2.Sorted = True
        Me.ListBox2.TabIndex = 1
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(432, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(144, 16)
        Me.Label1.TabIndex = 3
        Me.Label1.Text = "Vorhandene Spalten"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(232, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(144, 16)
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Anzuzeigende Spalten"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.ImageIndex = 4
        Me.Button1.ImageList = Me.ImageList1
        Me.Button1.Location = New System.Drawing.Point(200, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(32, 32)
        Me.Button1.TabIndex = 5
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.ImageIndex = 3
        Me.Button2.ImageList = Me.ImageList1
        Me.Button2.Location = New System.Drawing.Point(200, 216)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(32, 32)
        Me.Button2.TabIndex = 6
        '
        'frmSpaltenDarstellung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(432, 397)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label2, Me.Label1, Me.ToolBar1, Me.ListBox2, Me.ListBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSpaltenDarstellung"
        Me.Text = "Spalten-Selektion"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.ListBox1_DoubleClick Method

Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox2.Items.Add(Me.ListBox1.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItems(0))
        Next
        'Me.ListBox2.Items.Add(Me.ListBox1.SelectedI
        'Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItem)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.ListBox2_DoubleClick Method

Private Sub ListBox2_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox2.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox2_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox2.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox1.Items.Add(Me.ListBox2.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItems(0))
        Next
        'Me.ListBox1.Items.Add(Me.ListBox2.SelectedItem)
        'Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItem)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung.frmSpaltenDarstellung_Load Method

Private Sub frmSpaltenDarstellung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSpaltenDarstellung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSBSpaltenDarstellung Fields

frmSBSpaltenDarstellung overview

Fields

field Button1
field Button2
field ImageList1
field Label1
field Label2
field ListBox1
field ListBox2
field ToolBar1
field ToolBarButton1
field components

See Also

frmSBSpaltenDarstellung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


ListBox2 Variable

Friend WithEvents ListBox2 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox2 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBSpaltenDarstellung


frmSearchDoc Class

For a list of all members of this type, see frmSearchDoc Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSearchDoc

Public Class frmSearchDoc
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSearchDoc Members


frmSearchDoc Members

frmSearchDoc overview

Constructors

constructor frmSearchDoc Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method Show_Doc
method Show_Doc_ohne_Message
method frmSearchDoc_Load
method show_trefferliste
method txtbcknr_KeyDown

Fields

field Button1
field Button2
field Label1
field components
field txtbcknr

See Also

frmSearchDoc Class


frmSearchDoc Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc Methods

frmSearchDoc overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method Show_Doc
method Show_Doc_ohne_Message
method frmSearchDoc_Load
method show_trefferliste
method txtbcknr_KeyDown

See Also

frmSearchDoc Class


frmSearchDoc.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        show_doc()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSearchDoc))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtbcknr = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(168, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Dokument-ID/Barcodekleber-Nr:"
        '
        'txtbcknr
        '
        Me.txtbcknr.Location = New System.Drawing.Point(16, 48)
        Me.txtbcknr.Name = "txtbcknr"
        Me.txtbcknr.Size = New System.Drawing.Size(152, 20)
        Me.txtbcknr.TabIndex = 29
        Me.txtbcknr.Text = ""
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(16, 88)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 30
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(96, 88)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 31
        Me.Button2.Text = "&OK"
        '
        'frmSearchDoc
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(192, 141)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.txtbcknr, Me.Label1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSearchDoc"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Dokument suchen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.Show_Doc Method

Public Sub Show_Doc()

Source code

[Visual Basic]
    Public Sub Show_Doc()
        Me.Hide()
        Me.DialogResult = DialogResult.OK
        Me.Hide()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_search_bck"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtbcknr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentart", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@OldDokumentFound", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@rc").Value = 0 Then
                If scmCmdToExecute.Parameters("@OldDokumentFound").Value = 0 Then
                    show_trefferliste(scmCmdToExecute.Parameters("@nrpar00").Value, Me.txtbcknr.Text, scmCmdToExecute.Parameters("@Dokumentart").Value)
                Else
                    'DokumentID/Barcode wurde durch eine neue Erstezt
                    MyMsg.show_standardmessage(502, MsgBoxStyle.Information) 'Ein Dokument mit der eingegeben ID/Barcodekleber-Nr wurde durch eine neue ID/Barcodekleber-Nr. erstezt.
                    show_trefferliste(scmCmdToExecute.Parameters("@nrpar00").Value, Me.txtbcknr.Text, scmCmdToExecute.Parameters("@Dokumentart").Value)
                End If
                Me.Close()
            Else
                MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
                Me.Show()
            End If

        Catch ex As Exception
            MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
            Me.Show()
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.Show_Doc_ohne_Message Method

Public Function Show_Doc_ohne_Message() As Boolean

Source code

[Visual Basic]
    Public Function Show_Doc_ohne_Message() As Boolean
        Me.Hide()
        Me.DialogResult = DialogResult.OK
        Me.Hide()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_search_bck"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtbcknr.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentart", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@OldDokumentFound", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@rc").Value = 0 Then
                If scmCmdToExecute.Parameters("@OldDokumentFound").Value = 0 Then
                    show_trefferliste(scmCmdToExecute.Parameters("@nrpar00").Value, Me.txtbcknr.Text, scmCmdToExecute.Parameters("@Dokumentart").Value)
                Else
                    'DokumentID/Barcode wurde durch eine neue Erstezt
                    'MyMsg.show_standardmessage(502, MsgBoxStyle.Information) 'Ein Dokument mit der eingegeben ID/Barcodekleber-Nr wurde durch eine neue ID/Barcodekleber-Nr. erstezt.
                    show_trefferliste(scmCmdToExecute.Parameters("@nrpar00").Value, Me.txtbcknr.Text, scmCmdToExecute.Parameters("@Dokumentart").Value)
                End If
                '                Me.Close()
                Return True
            Else
                Return False
                'MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
                'Me.Show()
            End If

        Catch ex As Exception
            MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
            Me.Show()
            Return False
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            Me.Close()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.frmSearchDoc_Load Method

Private Sub frmSearchDoc_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSearchDoc_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.show_trefferliste Method

Private Sub show_trefferliste( _
   ByVal nrpar00 As Integer, _
   ByVal dokumentid As String, _
   ByVal dokumentart As Integer _
)

Parameters

nrpar00
Required.
dokumentid
Required.
dokumentart
Required.

Source code

[Visual Basic]
    Private Sub show_trefferliste(ByVal nrpar00 As Integer, ByVal dokumentid As String, ByVal dokumentart As Integer)
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.txtnrpar00.Text = nrpar00.ToString
        f.Partnernr = nrpar00
        f.Partner_Eingegeben = True
        f.refresh_list()
        f.Refresh_All(True)
        f.PosDok(dokumentid, dokumentart)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        ' Globals.Apphandle = Me.Handle.ToInt32
        'Win32API.SetForegroundWindow(Me.Handle.ToInt32)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc.txtbcknr_KeyDown Method

Private Sub txtbcknr_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtbcknr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtbcknr_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtbcknr.KeyDown
        If e.KeyCode = Keys.Enter Then
            Button2_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSearchDoc Fields

frmSearchDoc overview

Fields

field Button1
field Button2
field Label1
field components
field txtbcknr

See Also

frmSearchDoc Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


txtbcknr Variable

Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSearchDoc


frmSelectStatus Class

For a list of all members of this type, see frmSelectStatus Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmSelectStatus

Public Class frmSelectStatus
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSelectStatus Members


frmSelectStatus Members

frmSelectStatus overview

Constructors

constructor frmSelectStatus Constructor

Properties

property Dokumenttypnr
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Statustypnr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MySpaltenTitel_Aktualisieren
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field m_dokumenttypnr
field m_statustypnr

See Also

frmSelectStatus Class


frmSelectStatus Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus Properties

frmSelectStatus overview

Properties

property Dokumenttypnr
property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property Statustypnr
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmSelectStatus Class


frmSelectStatus.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
    Property Dokumenttypnr() As Long
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Long)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.Statustypnr Property

Property Statustypnr() As Long

Source code

[Visual Basic]
    Property Statustypnr() As Long
        Get
            Return m_statustypnr
        End Get
        Set(ByVal Value As Long)
            m_statustypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus Methods

frmSelectStatus overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MySpaltenTitel_Aktualisieren
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmSelectStatus Class


frmSelectStatus.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmSelectStatus
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 272)
        Me.Name = "frmSelectStatus"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterParent
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.MySpaltenTitel_Aktualisieren Method

Private Sub MySpaltenTitel_Aktualisieren()

Source code

[Visual Basic]
    Private Sub MySpaltenTitel_Aktualisieren()
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        ts.Tabelle = "dokumentstatus"
        For i = 0 To Me.DomainList.Columns.Count - 1
            s = Me.DomainList.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            Me.DomainList.Columns(i).Caption = ts.spaltenname
            If Me.DomainList.Columns(i).Caption = "" Then
                Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
            Else
                Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If
            If ts.locked Then
                Me.DomainList.Splits(0).DisplayColumns(i).Locked = True
            End If
            If Me.DomainList.Columns(i).DataField = "folgestatus_durch_anderen_verantwortlichen" Then
                Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "dokumentstatus"
        Dim t As DataTable
        Dim dstatus As New edokadb.clsMyDokumentstatus()
        dstatus.Dokumenttypnr = Dokumenttypnr
        dstatus.Statustypnr = Statustypnr
        dstatus.cpMainConnectionProvider = conn
        t = dstatus.SelectDokumentstatus
        Me.DomainList.DataSource = t
        MySpaltenTitel_Aktualisieren()
        Me.DomainList.AllowAddNew = False
        Me.DomainList.AllowUpdate = False
        Me.ToolBar1.Buttons(1).Visible = False
        Me.MenuItem3.Visible = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSelectStatus Fields

frmSelectStatus overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components
field m_dokumenttypnr
field m_statustypnr

See Also

frmSelectStatus Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


m_statustypnr Variable

Dim m_statustypnr As Long

Source code

[Visual Basic]
    Dim m_statustypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSelectStatus


frmSerienbriefe Class

For a list of all members of this type, see frmSerienbriefe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSerienbriefe

Public Class frmSerienbriefe
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSerienbriefe Members


frmSerienbriefe Members

frmSerienbriefe overview

Constructors

constructor frmSerienbriefe Constructor (Overloaded)

Methods

method Bar25I
method Bar25Ics
method BtnHelp_Click
method C1Command1_Click
method C1ContextMenu1_Popup
method C1ContextMenu2_Popup
method C1MnuPersSbLoad_Click
method C1TrueDBGrid1_FetchCellTips3
method C1mnuPartnerdossier_Click
method C1mnuPersVorlageSave_Click
method Check_Archiviert
method Check_Column
method Check_Columnname
method Check_Data
method Check_Importtable
method Create_Layout
method DateTimePicker1_ValueChanged
method Dispose
method Dokumente_Generieren
method Empflist_FetchScrollTips
method Export_Empfaenger
method Extract_CSV
method FillDataTableFromText
method FillMcbVerantwortlich
method Funktionen_Freigeben
method Generate_Barcodes
method Generate_Tree
method Generic_Select
method Get_Vorlagenfelder
method HeaderFooterAnzeigen
method Import_Empfaenger
method InitializeComponent
method Insert_Kopfzeile
method Insert_TextFelder
method Insert_Value
method Load_Layout
method Load_Printdialog
method Load_Reserved_Words
method Load_Serienbrief
method Load_data
method Load_empfaenger
method MenuEmpfaenger_Popup
method MnuDeleteEmpfaenger_Click
method MnuDeleteNotiz_Click
method MnuEditEmpfaenger_Click
method MnuEditNotiz_Click
method MnuMainAbschluss_Click
method MnuMainAddColumn_Click
method MnuMainClose_Click
method MnuMainDeleteColumn_Click
method MnuMainDokument_Popup
method MnuMainDokumenteBestaetigen_Click
method MnuMainDokumenteDrucken_Click
method MnuMainEDOKAPartnerErfassen_Click
method MnuMainEmfpaengerLoeschen_Click
method MnuMainEmpfaengerBearbeiten_Click
method MnuMainEmpfaengerliste_Click
method MnuMainExportEmpfaenger_Click
method MnuMainImportEmpfaenger_Click
method MnuMainLoadPartnerliste_Click
method MnuMainLoad_Click
method MnuMainNew_Click
method MnuMainRenameColumn_Click
method MnuMainSaveAsPartnerlist_Click
method MnuMainSave_Click
method MnuMainSerienbriefLoeschen_Click
method MnuMainSpaltenselektion_Click
method MnuMainVorageBearbeiten_Click
method MnuMainVorlageImportieren_Click
method MnuNeueNotiz_Click
method MnuSpaltenSelektion_Click
method Notizlist_DoubleClick
method Partner_Details
method RBZustaendigKubedesPartners_CheckedChanged
method Save_Layout
method SetProgress
method TVStatus_AfterSelect
method TVStatus__MouseDown
method ToolBar1_ButtonClick
method Vorlage_Auslesen
method Vorlage_Speichern
method Vorschau_Erstellen
method add_edokahostpartner
method c1mnumainpreview_Click
method c1mnupartner1_Click
method c1mnupartner2_Click
method c1mnupartner3_Click
method cbzust_SelectedIndexChanged
method check_vorlagenfelder
method check_zwingende_felder
method create_checktable
method create_supporttable
method delete_serienbrief
method delrow
method empflist_ColMove
method empflist_ColResize
method empflist_DoubleClick
method empflist_FetchRowStyle
method empflist_MouseDown
method frmSerienbriefe_Closing
method frmSerienbriefe_Load
method get_druckjobname
method get_druckjobs
method get_idvwerte
method get_postzustellung
method get_status
method init_empfaenger
method ins_Barcode
method insert_Barcode
method insert_Textfield
method ist_archiviert
method load_Mitarbeiter
method load_defaults
method load_notizen
method load_persvorlage
method mcbverantwortlich_SelectedIndexChanged
method mcbverantwortlich_leave
method mnuNeuerSerienbrief_Click
method mnuaddhost_Click
method mnuc2abschliessen_Click
method mnuc2bestaetigen_Click
method mnuc2generieren_Click
method mnuc2partnerlistepruefen_Click
method mnuc2printjob_Click
method mnuc2printpreview_Click
method mnuctErstellungWiederholen_Click
method mnuidvspalteumbenennen_Click
method mnuidwspalteentfernen_Click
method mnuidwspaltehinzufuegen_Click
method mnunewedoka_Click
method mnunewempfaenger_Click
method mnusaveasedokapartner_Click
method oledbimport
method pdfprinter_PrintDOne
method refresh_team
method save_checkdata
method save_data
method save_empfaenger
method serienbrief_abschliessen
method set_columnorder
method set_druckjobstatus
method set_gedruckt
method set_headerbookmark
method statustimer_Tick
method txtBezeichnung_TextChanged

Fields

field BarTextIn
field BarTextOut
field BtnHelp
field C1Command1
field C1CommandHolder1
field C1CommandLink1
field C1CommandLink11
field C1CommandLink12
field C1CommandLink14
field C1CommandLink15
field C1CommandLink17
field C1CommandLink18
field C1CommandLink19
field C1CommandLink2
field C1CommandLink20
field C1CommandLink21
field C1CommandLink22
field C1CommandLink23
field C1CommandLink24
field C1CommandLink25
field C1CommandLink26
field C1CommandLink27
field C1CommandLink3
field C1CommandLink4
field C1CommandMenu1
field C1ContextMenu1
field C1ContextMenu2
field C1DateEdit1
field C1DateEdit2
field C1MainMenu1
field C1MnuIndividuelleDokumentwerte
field C1MnuMainAddColumn
field C1MnuMainDatei
field C1MnuMainDeleteColumn
field C1MnuMainDokument
field C1MnuMainEmpfaengerliste
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuPersSbLoad
field C1MnuSerienbriefLoeschen
field C1mnuPartnerdossier
field C1mnuPersVorlageSave
field CharValue
field CheckSum
field CurrentColumn
field CurrentPartnerbezeichnung
field CurrentPartnernr
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DoCheckSum
field Dokumenttypnr
field GenerierteDokumente
field GroupBox1
field GroupBox12
field GroupBox2
field GroupBox3
field GroupBox5
field GroupBox8
field II
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MenuEmpfaenger
field MenuItem10
field MenuItem12
field MenuItem14
field MenuItem23
field MenuNotiz
field MnuDeleteEmpfaenger
field MnuDeleteNotiz
field MnuEditEmpfaenger
field MnuEditNotiz
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEDOKAPartnerErfassen
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field MnuNeueNotiz
field MnuSpaltenSelektion
field Notizen
field Notizlist
field On_Fill
field On_Load
field OpenFileDialog1
field OpenForPrinting
field Panel1
field Panel2
field RBZustaendigKubedesPartners
field RBZustaendigZustaendiger
field SaveFileDialog1
field Serienbriefnr
field ShowSaveMessage
field Splitter1
field StatusBar1
field Sum
field TVStatus
field TabControl1
field TabPage1
field TabPage2
field TempString
field TextBox1
field TextBox10
field TextBox2
field Textboxes
field Textboxesi
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton11
field ToolBarButton12
field ToolBarButton13
field ToolBarButton14
field ToolBarButton15
field ToolBarButton16
field ToolBarButton17
field ToolBarButton18
field ToolBarButton19
field ToolBarButton2
field ToolBarButton20
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field barcodeout
field beginntextmarke
field blkunde
field c1mnumainpreview
field c1mnupartner1
field c1mnupartner2
field c1mnupartner3
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbteam
field cbzust
field clsempf
field components
field datachanged
field dokid
field doktyp
field drpMiatarbeiter
field druckjobs
field dsempfaenger
field dtstatus
field empflist
field endetextmarke
field feldname
field mcbpostzustellung
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuAddEmpfaenger
field mnuCTADDEdokapartner
field mnuaddhost
field mnuc2abschliessen
field mnuc2bestaetigen
field mnuc2generieren
field mnuc2partnerlistepruefen
field mnuc2printjob
field mnuc2printmenu
field mnuc2printpreview
field mnuctAddHost
field mnuctErstellungWiederholen
field mnuctaddempfaenger
field mnuidvspalteumbenennen
field mnuidwspalteentfernen
field mnuidwspaltehinzufuegen
field mnunewedoka
field mnunewempfaenger
field mnusaveasedokapartner
field objword
field officevorlage
field pdfprinter
field printsbnr
field progress
field progressvisible
field reservedwords
field save_DSInit
field save_verantwortlich
field selectPoint
field serienbrief
field serienbrief_notizen
field statustimer
field teamzustaendig
field txtBemerkung
field txtBezeichnung
field vorlagendaten

See Also

frmSerienbriefe Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal openforprinting As Boolean, ByVal serienbriefnr As Integer)

See Also

frmSerienbriefe | EDOKAApp


frmSerienbriefe Methods

frmSerienbriefe overview

Methods

method Bar25I
method Bar25Ics
method BtnHelp_Click
method C1Command1_Click
method C1ContextMenu1_Popup
method C1ContextMenu2_Popup
method C1MnuPersSbLoad_Click
method C1TrueDBGrid1_FetchCellTips3
method C1mnuPartnerdossier_Click
method C1mnuPersVorlageSave_Click
method Check_Archiviert
method Check_Column
method Check_Columnname
method Check_Data
method Check_Importtable
method Create_Layout
method DateTimePicker1_ValueChanged
method Dispose
method Dokumente_Generieren
method Empflist_FetchScrollTips
method Export_Empfaenger
method Extract_CSV
method FillDataTableFromText
method FillMcbVerantwortlich
method Funktionen_Freigeben
method Generate_Barcodes
method Generate_Tree
method Generic_Select
method Get_Vorlagenfelder
method HeaderFooterAnzeigen
method Import_Empfaenger
method InitializeComponent
method Insert_Kopfzeile
method Insert_TextFelder
method Insert_Value
method Load_Layout
method Load_Printdialog
method Load_Reserved_Words
method Load_Serienbrief
method Load_data
method Load_empfaenger
method MenuEmpfaenger_Popup
method MnuDeleteEmpfaenger_Click
method MnuDeleteNotiz_Click
method MnuEditEmpfaenger_Click
method MnuEditNotiz_Click
method MnuMainAbschluss_Click
method MnuMainAddColumn_Click
method MnuMainClose_Click
method MnuMainDeleteColumn_Click
method MnuMainDokument_Popup
method MnuMainDokumenteBestaetigen_Click
method MnuMainDokumenteDrucken_Click
method MnuMainEDOKAPartnerErfassen_Click
method MnuMainEmfpaengerLoeschen_Click
method MnuMainEmpfaengerBearbeiten_Click
method MnuMainEmpfaengerliste_Click
method MnuMainExportEmpfaenger_Click
method MnuMainImportEmpfaenger_Click
method MnuMainLoadPartnerliste_Click
method MnuMainLoad_Click
method MnuMainNew_Click
method MnuMainRenameColumn_Click
method MnuMainSaveAsPartnerlist_Click
method MnuMainSave_Click
method MnuMainSerienbriefLoeschen_Click
method MnuMainSpaltenselektion_Click
method MnuMainVorageBearbeiten_Click
method MnuMainVorlageImportieren_Click
method MnuNeueNotiz_Click
method MnuSpaltenSelektion_Click
method Notizlist_DoubleClick
method Partner_Details
method RBZustaendigKubedesPartners_CheckedChanged
method Save_Layout
method SetProgress
method TVStatus_AfterSelect
method TVStatus__MouseDown
method ToolBar1_ButtonClick
method Vorlage_Auslesen
method Vorlage_Speichern
method Vorschau_Erstellen
method add_edokahostpartner
method c1mnumainpreview_Click
method c1mnupartner1_Click
method c1mnupartner2_Click
method c1mnupartner3_Click
method cbzust_SelectedIndexChanged
method check_vorlagenfelder
method check_zwingende_felder
method create_checktable
method create_supporttable
method delete_serienbrief
method delrow
method empflist_ColMove
method empflist_ColResize
method empflist_DoubleClick
method empflist_FetchRowStyle
method empflist_MouseDown
method frmSerienbriefe_Closing
method frmSerienbriefe_Load
method get_druckjobname
method get_druckjobs
method get_idvwerte
method get_postzustellung
method get_status
method init_empfaenger
method ins_Barcode
method insert_Barcode
method insert_Textfield
method ist_archiviert
method load_Mitarbeiter
method load_defaults
method load_notizen
method load_persvorlage
method mcbverantwortlich_SelectedIndexChanged
method mcbverantwortlich_leave
method mnuNeuerSerienbrief_Click
method mnuaddhost_Click
method mnuc2abschliessen_Click
method mnuc2bestaetigen_Click
method mnuc2generieren_Click
method mnuc2partnerlistepruefen_Click
method mnuc2printjob_Click
method mnuc2printpreview_Click
method mnuctErstellungWiederholen_Click
method mnuidvspalteumbenennen_Click
method mnuidwspalteentfernen_Click
method mnuidwspaltehinzufuegen_Click
method mnunewedoka_Click
method mnunewempfaenger_Click
method mnusaveasedokapartner_Click
method oledbimport
method pdfprinter_PrintDOne
method refresh_team
method save_checkdata
method save_data
method save_empfaenger
method serienbrief_abschliessen
method set_columnorder
method set_druckjobstatus
method set_gedruckt
method set_headerbookmark
method statustimer_Tick
method txtBezeichnung_TextChanged

See Also

frmSerienbriefe Class


frmSerienbriefe.Bar25I Method

Public Function Bar25I( _
   ByVal BarTextIn As String _
) As String

Parameters

BarTextIn
Required.

Source code

[Visual Basic]
    Public Function Bar25I(ByVal BarTextIn As String) As String

        ' Initialize input and output strings
        BarTextOut = ""
        BarTextIn = RTrim(LTrim(BarTextIn))

        ' Throw away non-numeric data
        TempString = ""
        For II = 1 To Len(BarTextIn)
            If IsNumeric(Mid(BarTextIn, II, 1)) Then
                TempString = TempString & Mid(BarTextIn, II, 1)
            End If
        Next II

        ' If not an even number of digits, add a leading 0
        If (Len(TempString) Mod 2) = 1 Then
            TempString = "0" & TempString
        End If

        ' Break digit pairs up and convert to characters- build output string
        For II = 1 To Len(TempString) Step 2
            'Break string into pairs of digits and get value
            CharValue = Mid(TempString, II, 2)
            'translate value to ASCII and save in BarTextOut
            If CharValue < 90 Then
                BarTextOut = BarTextOut & Chr(CharValue + 33)
            Else
                BarTextOut = BarTextOut & Chr(CharValue + 71)
            End If
        Next II

        'Build ouput string, trailing space for Windows rasterization bug
        barcodeout = "{" & BarTextOut & "} "

        'Return the string
        Bar25I = barcodeout

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Bar25Ics Method

Public Function Bar25Ics( _
   ByVal BarTextIn As String _
) As String

Parameters

BarTextIn
Required.

Source code

[Visual Basic]
    Public Function Bar25Ics(ByVal BarTextIn As String) As String

        ' Initialize input and output strings
        BarTextOut = ""
        BarTextIn = RTrim(LTrim(BarTextIn))

        ' Throw away non-numeric data
        TempString = ""
        For II = 1 To Len(BarTextIn)
            If IsNumeric(Mid(BarTextIn, II, 1)) Then
                TempString = TempString & Mid(BarTextIn, II, 1)
            End If
        Next II

        ' If not an odd number of digits, add a leading 0
        If (Len(TempString) Mod 2) = 0 Then
            TempString = "0" & TempString
        End If

        ' Figure out the checksum digit
        Sum = 0
        For II = 1 To Len(TempString)
            CharValue = Mid(TempString, II, 1)
            If (II Mod 2) = 1 Then
                Sum = Sum + (3 * CharValue)
            Else
                Sum = Sum + CharValue
            End If
        Next II

        ' Figure checksum, add it as last digit
        CheckSum = 10 - (Sum Mod 10)
        If CheckSum = 10 Then CheckSum = 0
        TempString = TempString & Chr(48 + CheckSum)

        ' Break digit pairs up and convert to characters- build output string
        For II = 1 To Len(TempString) Step 2
            'Break string into pairs of digits and get value
            CharValue = Mid(TempString, II, 2)
            'translate value to ASCII and save in BarTextOut
            If CharValue < 90 Then
                BarTextOut = BarTextOut & Chr(CharValue + 33)
            Else
                BarTextOut = BarTextOut & Chr(CharValue + 71)
            End If
        Next II

        'Build ouput string, trailing space for Windows rasterization bug
        barcodeout = "{" & BarTextOut & "} "

        'Return the string
        Bar25Ics = barcodeout

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("serienbriefe1")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1Command1_Click Method

Private Sub C1Command1_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles C1Command1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1Command1_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles C1Command1.Click
        Dim s As String
        s = Me.TVStatus.SelectedNode.Tag
        s = s.Substring(4)
        Me.set_druckjobstatus(3, s)
        Me.Generate_Tree()
        '        Me.refresh_data()
        'Me.pdfprinter_PrintDOne()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1ContextMenu1_Popup Method

Private Sub C1ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1ContextMenu1.Popup
        Me.c1mnupartner1.Enabled = False
        Me.c1mnupartner2.Enabled = False
        Me.c1mnupartner3.Enabled = False
        Me.MnuMainEmpfaengerBearbeiten.Enabled = False
        Me.MnuMainEmfpaengerLoeschen.Enabled = False
        Me.MnuMainEDOKAPartnerErfassen.Enabled = False
        Me.MnuMainCheckEmpfaenger.Enabled = False
        Me.mnuctErstellungWiederholen.Enabled = False
        Me.C1mnuPartnerdossier.Enabled = False
        Me.empflist.AllowUpdate = False

        Try
            If Me.serienbrief.iStatus.Value > 0 Or Me.serienbrief.iStatus.Value = -1 Then
                Me.c1mnupartner1.Enabled = False
                Me.c1mnupartner2.Enabled = False
                Me.c1mnupartner3.Enabled = False
                Me.MnuMainEmpfaengerBearbeiten.Enabled = False
                Me.MnuMainEmfpaengerLoeschen.Enabled = False
                Me.MnuMainEDOKAPartnerErfassen.Enabled = False
                Me.MnuMainCheckEmpfaenger.Enabled = False
                Me.mnuctErstellungWiederholen.Enabled = False
                Me.C1mnuPartnerdossier.Enabled = False
                Me.empflist.AllowUpdate = False

                Try
                    If Me.empflist.Columns("Partnernr").Text <> "" Then
                        Me.C1mnuPartnerdossier.Enabled = True
                    End If
                Catch
                End Try

                Exit Sub
            End If

            Me.c1mnupartner1.Enabled = False
            Me.c1mnupartner2.Enabled = False
            Me.c1mnupartner3.Enabled = False
            Me.MnuMainEmpfaengerBearbeiten.Enabled = False
            Me.MnuMainEmfpaengerLoeschen.Enabled = False
            Me.MnuMainEDOKAPartnerErfassen.Enabled = False
            Me.MnuMainCheckEmpfaenger.Enabled = False
            Me.mnuctErstellungWiederholen.Enabled = False
            Me.C1mnuPartnerdossier.Enabled = False

            Try
                Select Case Me.TVStatus.SelectedNode.Tag
                    'Fehlerhaft
                Case -1
                        Me.c1mnupartner1.Enabled = True
                        Me.c1mnupartner2.Enabled = True
                        Me.c1mnupartner3.Enabled = True
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = True
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = True
                        Me.MnuMainCheckEmpfaenger.Enabled = True
                        Me.mnuctErstellungWiederholen.Enabled = True
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                        'Noch nicht generiert
                    Case 0
                        Me.c1mnupartner1.Enabled = True
                        Me.c1mnupartner2.Enabled = True
                        Me.c1mnupartner3.Enabled = True
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = True
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = True
                        Me.MnuMainCheckEmpfaenger.Enabled = True
                        Me.mnuctErstellungWiederholen.Enabled = False
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                    Case 1
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = False
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = False
                        Me.MnuMainCheckEmpfaenger.Enabled = False
                        Me.mnuctErstellungWiederholen.Enabled = False
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                    Case 2
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = False
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = False
                        Me.MnuMainCheckEmpfaenger.Enabled = False
                        Me.mnuctErstellungWiederholen.Enabled = True
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                    Case 3
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = False
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = False
                        Me.MnuMainCheckEmpfaenger.Enabled = False
                        Me.mnuctErstellungWiederholen.Enabled = True
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                    Case 4
                        Me.MnuMainEmpfaengerBearbeiten.Enabled = False
                        Me.MnuMainEmfpaengerLoeschen.Enabled = True
                        Me.MnuMainEDOKAPartnerErfassen.Enabled = False
                        Me.MnuMainCheckEmpfaenger.Enabled = False
                        Me.mnuctErstellungWiederholen.Enabled = True
                        Try
                            If Me.empflist.Columns("Partnernr").Text <> "" Then
                                Me.C1mnuPartnerdossier.Enabled = True
                            End If
                        Catch
                        End Try
                End Select

                Try
                    If Me.TVStatus.SelectedNode.Tag = 0 Then
                        Me.c1mnupartner1.Enabled = True
                        Me.c1mnupartner2.Enabled = True
                        Me.c1mnupartner3.Enabled = True

                    Else
                        Me.c1mnupartner1.Enabled = False
                        Me.c1mnupartner2.Enabled = False
                        Me.c1mnupartner3.Enabled = False
                    End If
                Catch

                End Try
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1ContextMenu2_Popup Method

Private Sub C1ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1ContextMenu2.Popup
        Me.mnuc2partnerlistepruefen.Enabled = False
        Me.mnuc2bestaetigen.Enabled = False
        Me.mnuc2generieren.Enabled = False
        Me.mnuc2printmenu.Enabled = False
        Me.mnuc2abschliessen.Enabled = False
        Try
            Dim o As Object
            If Me.serienbrief.iStatus.Value > 0 Then
                Me.mnuc2partnerlistepruefen.Enabled = False
                Me.mnuc2bestaetigen.Enabled = False
                Me.mnuc2generieren.Enabled = False
                Me.mnuc2printmenu.Enabled = False
                Me.mnuc2abschliessen.Enabled = False
                Exit Sub
            End If

            Me.mnuc2partnerlistepruefen.Enabled = False
            Me.mnuc2bestaetigen.Enabled = False
            Me.mnuc2generieren.Enabled = False
            Me.mnuc2printmenu.Enabled = False
            Me.mnuc2abschliessen.Enabled = True
            Try
                Select Case Me.TVStatus.SelectedNode.Tag
                    Case -1
                        If Me.TVStatus.SelectedNode.Text.IndexOf("(0)") = -1 Then
                            '                        Me.mnuc2bestaetigen.Enabled = True
                            Me.mnuc2partnerlistepruefen.Enabled = True

                        End If
                    Case 0
                        If Me.TVStatus.SelectedNode.Text.IndexOf("(0)") = -1 Then
                            Me.mnuc2generieren.Enabled = True
                            Me.mnuc2partnerlistepruefen.Enabled = True
                        End If
                    Case 1
                    Case 2
                        If Me.TVStatus.SelectedNode.Text.IndexOf("(0)") = -1 Then
                            Me.mnuc2bestaetigen.Enabled = True
                        End If
                    Case 3
                        If Me.TVStatus.SelectedNode.Text.IndexOf("(0)") = -1 Then
                            Me.mnuc2bestaetigen.Enabled = True
                        End If
                    Case 4
                    Case Else
                        If Microsoft.VisualBasic.InStr(Me.TVStatus.SelectedNode.Tag, "Job:") > 0 Then
                            Me.mnuc2bestaetigen.Enabled = True
                            Me.mnuc2printmenu.Enabled = True
                        End If
                End Select
            Catch
                Try
                    If Microsoft.VisualBasic.InStr(Me.TVStatus.SelectedNode.Tag, "Job:") > 0 Then
                        Me.mnuc2bestaetigen.Enabled = True
                        Me.mnuc2printmenu.Enabled = True
                    End If
                Catch
                End Try
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1MnuPersSbLoad_Click Method

Private Sub C1MnuPersSbLoad_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles C1MnuPersSbLoad.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1MnuPersSbLoad_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles C1MnuPersSbLoad.Click
        Dim f As New frmpersvorlageladen(Me.Dokumenttypnr)
        f.ShowDialog()
        If f.PersVorlageNr <> 0 Then
            load_persvorlage(f.PersVorlageNr)
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1TrueDBGrid1_FetchCellTips3 Method

Private Sub C1TrueDBGrid1_FetchCellTips3( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles empflist.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellTips3(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles empflist.FetchCellTips
        Try
            e.CellTip = ""
            If Me.empflist.Columns("Status").Value < 1 Then
                Select Case Me.empflist.Columns("Fehlercode").Text
                    Case 1
                        e.CellTip = MyTxt.gettext(727)
                    Case 2
                        e.CellTip = MyTxt.gettext(726)
                    Case 3
                        e.CellTip = MyTxt.gettext(725)
                    Case 4
                        e.CellTip = MyTxt.gettext(732)
                End Select
            End If
            If Me.empflist.Columns("Fehlercode").Value = 9 Then
                If e.CellTip <> "" Then
                    e.CellTip = e.CellTip + "/" + MyTxt.gettext(738)
                Else
                    e.CellTip = MyTxt.gettext(738)
                End If
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1mnuPartnerdossier_Click Method

Private Sub C1mnuPartnerdossier_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles C1mnuPartnerdossier.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1mnuPartnerdossier_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles C1mnuPartnerdossier.Click
        Try
            Dim dokumentid As String
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim t As DataTable
            Try
                dokumentid = Me.empflist.Columns("Dokumentid").Text
            Catch
                dokumentid = ""
            End Try

            If dokumentid <> "" Then
                Dim f1 As New frmSearchDoc()
                f1.txtbcknr.Text = (dokumentid)
                f1.Visible = False
                'f.Show()
                f1.Visible = False
                f1.MdiParent = Me.MdiParent
                If f1.Show_Doc_ohne_Message = True Then
                    f1.Hide()
                    Exit Sub
                Else
                    Globals.profilnr = 0
                    Dim f As New frmTrefferliste()
                    f.MdiParent = Me.MdiParent
                    f.Show()
                    f.Partner_Eingegeben = True
                    f.txtnrpar00.Text = LTrim(Me.empflist.Columns("Partnernr").Value)
                    f.refresh_list()
                    'f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))
                    Me.Cursor = System.Windows.Forms.Cursors.Default

                End If
            Else
                Globals.profilnr = 0
                Dim f As New frmTrefferliste()
                f.MdiParent = Me.MdiParent
                f.Show()
                f.Partner_Eingegeben = True
                f.txtnrpar00.Text = LTrim(Me.empflist.Columns("Partnernr").Value)
                f.refresh_list()
                'f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))
                Me.Cursor = System.Windows.Forms.Cursors.Default
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.C1mnuPersVorlageSave_Click Method

Private Sub C1mnuPersVorlageSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles C1mnuPersVorlageSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1mnuPersVorlageSave_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles C1mnuPersVorlageSave.Click
        Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger_vorlage.xml"
        Dim vorlagenname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Serienbriefnr.ToString + "_vorlage.doc"
        Me.Vorlage_Auslesen(Me.Serienbriefnr)
        Try
            Dim s As String
            s = InputBox("Bitte geben Sie einen Name für das Serienbrief-Muster ein.", "Serienbrief-Muster speichern")
            If s = "" Then Exit Sub

            Dim tmpds As New DataSet()
            Dim i As Integer
            For i = 0 To Me.dsempfaenger.Tables.Count - 1
                tmpds.Tables.Add(Me.dsempfaenger.Tables(i).Copy)
            Next
            tmpds.Tables(0).Rows.Clear()
            Dim tmpdrow As DataRow
            tmpdrow = tmpds.Tables(0).NewRow
            For i = 0 To tmpds.Tables(0).Columns.Count - 1
                tmpdrow.Item(i) = " "
            Next
            tmpds.Tables(0).Rows.Add(tmpdrow)
            tmpds.WriteXml(dokumentname)

            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_persvorlage where persvorlagenr=0", Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim fs1 As New FileStream(vorlagenname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Dim mydata1(fs1.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                fs1.Read(mydata1, 0, fs1.Length)
                fs1.Close()

                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "persvorlage")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    'Neue Serienbrief_Empfaenger speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(1) = Globals.MitarbeiterNr
                    myRow.Item(2) = s
                    myRow.Item(3) = Now
                    myRow.Item(4) = Now
                    myRow.Item(5) = 1
                    myRow.Item(6) = mydata
                    myRow.Item(7) = mydata1
                    myRow.Item(8) = Me.Dokumenttypnr
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "persvorlage")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(700, MsgBoxStyle.Critical)
            Finally
                File.Delete(dokumentname)
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing
            Connection.Close()
            Connection = Nothing
        Catch ex As Exception
        Finally
            Try
                File.Delete(dokumentname)
            Catch
            End Try
            Try
                File.Delete(vorlagenname)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Check_Archiviert Method

Private Function Check_Archiviert( _
   ByVal dokumentid As String, _
   ByVal DOKUMENTVERSANDT As Boolean _
)

Parameters

dokumentid
Required.
DOKUMENTVERSANDT
Required.

Source code

[Visual Basic]
    Private Function Check_Archiviert(ByVal dokumentid As String, ByVal DOKUMENTVERSANDT As Boolean)
        Dim i As Integer
        Dim Versandt As Boolean
        Dim status As String
        i = ist_archiviert(dokumentid)
        '0 : Dokument ist nicht archiviert
        '1 : Dokument ist archiviert und noch nicht abgeschlossen
        '2 : Dokument ist abgeschlossen : - Keine Aktion bei abgeschlossenen Dokumenten
        If i <> 0 And i <> 1 Then Exit Function
        If Versandt = 1 Then status = "Alt" Else status = "ungültig"
        'Löschung des Dokumentes durchführen
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_delete"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschgrund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "Serienbrief-Löschung:" + Globals.MitarbeiterNr.ToString + ":" + Now.ToString))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            If i = 1 Then
                Dim scmCmdToExecute1 As SqlCommand = New SqlCommand()
                scmCmdToExecute1.CommandText = "dbo.SP_Dokument_updateinaktversant"
                scmCmdToExecute1.CommandType = CommandType.StoredProcedure
                scmCmdToExecute1.Connection = conn.scoDBConnection
                conn.OpenConnection()
                Try
                    scmCmdToExecute1.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    scmCmdToExecute1.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute1.ExecuteNonQuery()
                Catch ex As Exception
                    Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute1.Dispose()
                    conn.CloseConnection(True)
                End Try
                'Ende
                Dim dt As DataTable
                Dim sth As New Statushandling()
                dt = sth.get_coldindex_and_statusnr(dokumentid, False, False)
                Archivfnkt.insert_coldupdate_status(dt, dokumentid, status)
                sth.Dispose()
            End If
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Check_Column Method

Private Function Check_Column( _
   ByVal colname As String, _
   ByRef dt As DataTable _
) As Boolean

Parameters

colname
Required.
dt
Required.

Source code

[Visual Basic]
    Private Function Check_Column(ByVal colname As String, ByRef dt As DataTable) As Boolean
        Dim i As Integer
        For i = 0 To dt.Columns.Count - 1
            If dt.Columns(i).ColumnName = colname Then Return True
        Next
        dt.Columns.Add(colname)
        Try
            dt.Rows(0).Item(colname) = ""
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Check_Columnname Method

Private Function Check_Columnname( _
   ByVal inp As String _
) As String

Parameters

inp
Required.

Source code

[Visual Basic]
    Private Function Check_Columnname(ByVal inp As String) As String
        Dim s As String
        For Each s In Me.reservedwords
            If UCase(inp) = UCase(s) Then
                Return "#Error#"
            End If
        Next

        Select Case Microsoft.VisualBasic.Left(inp, 1)
            Case "1", "2", "3", "4", "5", "6", "7", "8", "9", "0"
                Return "#Error#"
            Case " "
                Return False
                If inp.IndexOf("\") > -1 Or _
                   inp.IndexOf("#") > -1 Or _
                   inp.IndexOf("/") > -1 Or _
                   inp.IndexOf(".") > -1 Or _
                   inp.IndexOf("=") > -1 Or _
                   inp.IndexOf(",") > -1 Then
                    Return "#Error#"
                End If
        End Select
        inp = inp.Replace(" ", "_")
        inp = inp.Replace("-", "_")
        inp = inp.Replace("ö", "oe")
        inp = inp.Replace("Ö", "OE")
        inp = inp.Replace("ü", "ue")
        inp = inp.Replace("Ü", "UE")
        inp = inp.Replace("ä", "ae")
        inp = inp.Replace("Ä", "AE")

        Return inp
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Check_Data Method

Private Function Check_Data() As DataTable

Source code

[Visual Basic]
    Private Function Check_Data() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_check_partner"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@manr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            If doktyp.bVertrag.Value = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertrag", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If

            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_edex_sb_get_postzustellung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Check_Importtable Method

Private Function Check_Importtable( _
   ByRef dt As DataTable _
) As Boolean

Parameters

dt
Required.

Source code

[Visual Basic]
    Private Function Check_Importtable(ByRef dt As DataTable) As Boolean
        Dim s As String = "Folgende Felder sind in Ihren Import-Daten nicht vorhanden:" + vbCrLf
        Dim S1 As String = s
        If dt.Rows.Count < 1 Then
            Dim myRow As DataRow
            myRow = dt.NewRow
            Dim I As Integer
            For I = 0 To dt.Columns.Count - 1
                myRow.Item(I) = ""
            Next I
            dt.Rows.Add(myRow)
        End If

        Check_Column("Partnernr", dt)
        Check_Column("Kurzbezeichnung", dt)
        Check_Column("Name", dt)
        Check_Column("Vorname", dt)
        Check_Column("Strasse", dt)
        Check_Column("PLZ", dt)
        Check_Column("Ort", dt)
        Check_Column("Zustelladresse", dt)
        Check_Column("Briefanrede1", dt)
        Check_Column("Briefanrede2", dt)
        Check_Column("Anrede", dt)

        Check_Column("STATUS", dt)
        Check_Column("FEHLERCODE", dt)
        Check_Column("DOKUMENTIDBDR", dt)
        Check_Column("ERSTELLER", dt)
        Check_Column("DRUCKJOBID", dt)
        Check_Column("BLKUNDE", dt)
        Check_Column("DOKUMENT_GEDRUCKT", dt)
        Check_Column("AKTIV", dt)
        Check_Column("DOKUMENTID", dt)

        Dim dr As DataRow
        For Each dr In dt.Rows
            Try
                If dr.Item("Status") = "0" Or dr.Item("Status") Is System.DBNull.Value Or dr.Item("Status") = "" Then
                    dr.Item("Status") = "0"
                    dr.Item("fehlercode") = ""
                    dr.Item("Dokumentid") = ""
                    dr.Item("Dokumentidbdr") = ""
                    dr.Item("blkunde") = False
                    dr.Item("dokument_gedruckt") = False
                    dr.Item("Aktiv") = True
                End If
            Catch
                dr.Item("Status") = "0"
                dr.Item("fehlercode") = ""
                dr.Item("Dokumentid") = ""
                dr.Item("Dokumentidbdr") = ""
                dr.Item("blkunde") = False
                dr.Item("dokument_gedruckt") = False
                dr.Item("Aktiv") = True
            End Try
        Next

        Dim II As Integer
        s = ""
        S1 = ""
        For II = 0 To dt.Columns.Count - 1
            s = Check_Columnname(dt.Columns(II).ColumnName)
            If s = "#Error#" Then
                S1 = S1 + "- " + dt.Columns(II).ColumnName + vbCrLf
            Else
                If s <> dt.Columns(II).ColumnName Then
                    dt.Columns(II).ColumnName = s
                End If
            End If
        Next
        If S1 <> "" Then
            MyMsg.show_standardmessage_ReplaceText(731, MsgBoxStyle.Critical, S1, "")
            Return False
        End If
        Dim dn As New DataTable()
        dn = set_columnorder(dt)
        dt.Clear()

        Dim drr As DataRow
        For Each drr In dn.Rows
            dt.ImportRow(drr)
        Next
        Me.dsempfaenger.Tables.Clear()
        Me.dsempfaenger.Tables.Add(dn.Copy)
        dn.Dispose()
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Create_Layout Method

Private Sub Create_Layout()

Source code

[Visual Basic]
    Private Sub Create_Layout()
        Try
            Dim i As Integer
            For i = 0 To Me.empflist.Columns.Count - 1
                Me.empflist.Splits(0).DisplayColumns(i).AutoSize()
            Next
            Me.empflist.Splits(0).DisplayColumns("STATUS").Visible = False
            Me.empflist.Splits(0).DisplayColumns("FEHLERCODE").Visible = False
            Me.empflist.Splits(0).DisplayColumns("BLKUNDE").Visible = False
            Me.empflist.Splits(0).DisplayColumns("DOKUMENT_GEDRUCKT").Visible = False
            Me.empflist.Splits(0).DisplayColumns("AKTIV").Visible = False
            Me.empflist.Splits(0).DisplayColumns("DOKUMENTID").Visible = False
            Me.empflist.Splits(0).DisplayColumns("DOKUMENTIDBDR").Visible = False
            Me.empflist.Splits(0).DisplayColumns("ERSTELLER").Visible = False
            Me.empflist.Splits(0).DisplayColumns("DRUCKJOBID").Visible = False
            Me.empflist.Refresh()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.DateTimePicker1_ValueChanged Method

Private Sub DateTimePicker1_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DateTimePicker1.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
        Me.DateTimePicker5.Value = Me.DateTimePicker1.Value
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Dokumente_Generieren Method

Private Function Dokumente_Generieren()

Source code

[Visual Basic]
    Private Function Dokumente_Generieren()
        Dim Kopfzeile As Boolean
        serienbrief.cpMainConnectionProvider = Globals.conn
        serienbrief.iSerienbriefnr = New SqlInt32(CType(Me.Serienbriefnr, Int32))
        serienbrief.SelectOne()
        doktyp.cpMainConnectionProvider = Globals.conn
        doktyp.iDokumenttypnr = serienbrief.iDokumenttypnr
        doktyp.SelectOne()
        officevorlage.cpMainConnectionProvider = Globals.conn
        officevorlage.iOffice_vorlagenr = doktyp.iOffice_vorlagenr
        officevorlage.SelectOne()
        If officevorlage.bKopfzeile_generieren.Value = True Then
            Kopfzeile = True
        Else
            Kopfzeile = False
        End If
        serienbrief.Dispose()
        doktyp.Dispose()
        officevorlage.Dispose()

        objword = New Word.ApplicationClass()
        objword.WindowState = Word.WdWindowState.wdWindowStateMinimize
        objword.Visible = False
        Dim i As Integer
        Dim i1 As Integer
        Dim pstep As Double
        Dim pval As Double
        Dim feldnr As String
        Try
            pstep = 70 / vorlagendaten.Rows.Count
        Catch
            pval = 30
        End Try
        For i = 0 To vorlagendaten.Rows.Count - 1
            Try
                pval = pval + pstep
                SetProgress(pval, "Dokumente generieren", False)
                Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Serienbriefnr.ToString + "_vorlage.doc"
                objword.Documents.Open(dokumentname)
                objword.Visible = False
                objword.WindowState = Word.WdWindowState.wdWindowStateMinimize
                If Kopfzeile Then
                    Insert_Kopfzeile()
                End If
                Dim sp1 As String
                Dim sp2() As String
                For i1 = 0 To vorlagendaten.Columns.Count - 1
                    'If vorlagendaten.Columns(i1).ColumnName = "_Alter" Or vorlagendaten.Columns(i1).ColumnName = "Alter" Or vorlagendaten.Columns(i1).ColumnName = "Alter_" Then
                    '    MsgBox("Gaga")
                    'End If
                    Try
                        sp1 = vorlagendaten.Columns(i1).ColumnName
                        sp2 = sp1.Split("_09_")
                        sp1 = sp2(0) + "_09_" + sp2(2)
                        feldnr = sp2(1).ToString
                        sp1 = sp1
                    Catch
                        sp1 = vorlagendaten.Columns(i1).ColumnName
                        feldnr = sp1
                    End Try
                    Select Case sp1
                        'Mapping Zustelladresse
                    Case "F_09_1", "F_09_10"
                            If vorlagendaten.Rows(i).Item("Zustelladresse") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Zustelladresse")
                            End If
                        Case "F_09_89"
                            If vorlagendaten.Rows(i).Item("Name") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Name")
                            End If
                        Case "F_09_111"
                            If vorlagendaten.Rows(i).Item("Vorname") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Vorname")
                            End If
                        Case "F_09_122", "F_09_123", "F_09_20"
                            Dim s As String = ""
                            Dim s1
                            If vorlagendaten.Rows(i).Item("Briefanrede1") <> "" Then
                                s = vorlagendaten.Rows(i).Item("Briefanrede1")
                                If Microsoft.VisualBasic.Left(s, 4) = "Herr" Then
                                    s = "r " + s
                                Else
                                    s = " " + s
                                End If
                            End If
                            If vorlagendaten.Rows(i).Item("Briefanrede2") <> "" Then
                                If s <> "" Then s = s + vbCrLf
                                s1 = vorlagendaten.Rows(i).Item("Briefanrede2")
                                If Microsoft.VisualBasic.Left(s1, 4) = "Herr" Then
                                    s = s + "Sehr geehrter " + s1
                                Else
                                    s = s + "Sehr geehrte " + s1
                                End If
                            End If
                            If s <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = s
                            End If
                        Case "F_09_98"
                            If vorlagendaten.Rows(i).Item("Strasse") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Strasse")
                            End If
                        Case "F_09_93"
                            If vorlagendaten.Rows(i).Item("Ort") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Ort")
                            End If
                        Case "F_09_93"
                            If vorlagendaten.Rows(i).Item("Ort") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("Ort")
                            End If
                        Case "F_09_96"
                            If vorlagendaten.Rows(i).Item("PLZ") <> "" Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("PLZ")
                            End If
                        Case "F_09_132"
                            If vorlagendaten.Rows(i).Item("PLZ") <> "" Or vorlagendaten.Rows(i).Item("Ort") <> 0 Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item("PLZ") + " " + vorlagendaten.Rows(i).Item("Ort")
                            End If
                        Case Else
                    End Select

                    'Verknüpfte Felder
                    Try
                        Dim i2 As Integer
                        For i2 = 0 To Me.dsempfaenger.Tables("VerkFelder").Rows.Count - 1
                            If feldnr = Me.dsempfaenger.Tables("verkfelder").Rows(i2).Item("Vorlagenfeldnr").ToString Then
                                vorlagendaten.Rows(i).Item(i1) = vorlagendaten.Rows(i).Item(Me.dsempfaenger.Tables("verkfelder").Rows(i2).Item("IDVWert"))
                            End If
                        Next

                    Catch

                    End Try
                    If vorlagendaten.Rows(i).Item(i1) Is System.DBNull.Value Then
                        vorlagendaten.Rows(i).Item(i1) = ""
                    End If
                    If Microsoft.VisualBasic.Left(vorlagendaten.Columns(i1).ColumnName, 5) = "F_09_" Then
                        Insert_Value(vorlagendaten.Rows(i).Item(i1), vorlagendaten.Columns(i1).ColumnName)
                    End If
                    If Microsoft.VisualBasic.Left(vorlagendaten.Columns(i1).ColumnName, 5) = "I_09_" Then
                        Dim intfeldname As String
                        Dim Intbookmark As String
                        Dim IntWert As String
                        intfeldname = vorlagendaten.Columns(i1).ColumnName
                        Intbookmark = Microsoft.VisualBasic.Right(vorlagendaten.Columns(i1).ColumnName, Len(vorlagendaten.Columns(i1).ColumnName) - 5)
                        IntWert = Microsoft.VisualBasic.Right(vorlagendaten.Columns(i1).ColumnName, Len(vorlagendaten.Columns(i1).ColumnName) - 14)

                        Dim SplitArray() As String
                        Dim ind As Integer
                        ind = IntWert.IndexOf("_09_")
                        IntWert = Microsoft.VisualBasic.Left(IntWert, ind)
                        'SplitArray = IntWert.Split("_09_")
                        'IntWert = SplitArray(0)
                        'IntWert = RenCol(IntWert)
                        Insert_Value(vorlagendaten.Rows(i).Item(IntWert), Intbookmark)
                    End If

                Next
                If doktyp.bZu_retournieren.Value = True Or vorlagendaten.Rows(i).Item("blkunde") = 1 Or vorlagendaten.Rows(i).Item("Dokumentidbdr") <> "" Then
                    blkunde = vorlagendaten.Rows(i).Item("blkunde")
                    If vorlagendaten.Rows(i).Item("Dokumentidbdr") <> "" Then
                        dokid = vorlagendaten.Rows(i).Item("Dokumentidbdr")
                    Else
                        dokid = vorlagendaten.Rows(i).Item("Dokumentid")
                    End If
                    Generate_Barcodes()
                    blkunde = ""
                End If
                Dim dm As String
                dm = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Serienbriefnr.ToString + "_vorlage_" + i.ToString + ".doc"
                objword.ActiveDocument.SaveAs(dm)
                Me.GenerierteDokumente.Add(dm)
                objword.Documents.Close(SAVECHANGES:=False)
            Catch ex As Exception
                MsgBox(ex.Message)
                vorlagendaten.Rows(i).Item("Status") = -1
            End Try
        Next

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Empflist_FetchScrollTips Method

Private Sub Empflist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles empflist.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Empflist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles empflist.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Horizontal
                    e.ScrollTip = Me.empflist.Columns(e.ColIndex).Caption
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " / " & _
                        CStr(Me.empflist.Splits(0).Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Export_Empfaenger Method

Private Sub Export_Empfaenger()

Source code

[Visual Basic]
    Private Sub Export_Empfaenger()
        Me.SaveFileDialog1.Filter = "CSV-Dateien (*.csv)|*.csv|Alle Dateien (*.*)|*.*"
        Me.SaveFileDialog1.ShowDialog()
        If Me.SaveFileDialog1.FileName <> "" Then
            Me.Extract_CSV(Me.dsempfaenger.Tables(0), Me.SaveFileDialog1.FileName)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Extract_CSV Method

Private Sub Extract_CSV( _
   ByVal dt As DataTable, _
   ByVal filename As String _
)

Parameters

dt
Required.
filename
Required.

Source code

[Visual Basic]
    Private Sub Extract_CSV(ByVal dt As DataTable, ByVal filename As String)
        Dim s As String
        Dim i As Integer
        Dim c As Integer

        Dim tw As TextWriter
        tw = New StreamWriter(New FileStream(filename, FileMode.Create))
        Dim w As TextWriter
        s = ""
        For i = 0 To dt.Columns.Count - 1
            s = s + dt.Columns(i).ColumnName + ";"
        Next
        tw.WriteLine(s)
        s = ""
        For i = 0 To dt.Rows.Count - 1
            For c = 0 To dt.Columns.Count - 1
                Try
                    s = s + CType(dt.Rows(i).Item(c), String) + ";"
                Catch
                    s = s + ""
                End Try
            Next
            tw.WriteLine(s)
            s = ""
        Next
        tw.Flush()
        tw.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.FillDataTableFromText Method

Private Function FillDataTableFromText( _
   ByVal file As String _
) As DataTable

Parameters

file
Required.

Source code

[Visual Basic]
    Private Function FillDataTableFromText(ByVal file As String) As DataTable
        Select Case UCase(Microsoft.VisualBasic.Right(file, 3))
            Case "CSV"
                Dim csv As New MyNameSpace.CSVDataAdapter(file, True, ";")
                csv.Fill(Me.dsempfaenger)
                Me.dsempfaenger.Tables(0).TableName = "empfdatatable"
            Case "TXT"
                Dim csv As New MyNameSpace.CSVDataAdapter(file, True, ";")
                csv.Fill(Me.dsempfaenger)
                Me.dsempfaenger.Tables(0).TableName = "empfdatatable"
            Case "XLS"
                oledbimport(file, "XLS")
                Me.dsempfaenger.Tables(0).TableName = "empfdatatable"
        End Select
        Dim dv As DataRow

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.FillMcbVerantwortlich Method

Private Function FillMcbVerantwortlich()

Source code

[Visual Basic]
    Private Function FillMcbVerantwortlich()

        Dim dd As New DataTable()
        Dim I As Integer
        Dim s As String
        s = ""
        Try
            I = Me.mcbverantwortlich.SelectedValue
            If I = 0 Then I = Globals.MitarbeiterNr

            Me.mcbverantwortlich.DataSource = Nothing
            Me.mcbverantwortlich.Items.Clear()
            dd = DivFnkt.Berechtigte_Mitarbeiter(Me.Dokumenttypnr, 0, 0, "", 3, 0, 0, 0, s)
            Me.mcbverantwortlich.Fill_Data(dd, False)
            Me.mcbverantwortlich.SelectedValue = I
            If Me.mcbverantwortlich.Items.Count = 0 Then
                Me.mcbverantwortlich.Text = ""
                Me.mcbverantwortlich.CheckNullValue = False
            Else
                Me.mcbverantwortlich.CheckNullValue = True
            End If
        Catch ex As Exception
            'MsgBox(ex.Message)
        Finally
            dd.Clear()
            dd.Dispose()
        End Try
        Me.save_verantwortlich = Me.mcbverantwortlich.SelectedValue
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Funktionen_Freigeben Method

Private Sub Funktionen_Freigeben( _
   ByVal Freigabe As Boolean _
)

Parameters

Freigabe
Required.

Source code

[Visual Basic]
    Private Sub Funktionen_Freigeben(ByVal Freigabe As Boolean)

        Me.txtBezeichnung.Enabled = Freigabe
        Me.mcbverantwortlich.Enabled = Freigabe

        'Me.empflist.AllowAddNew = Freigabe
        Me.empflist.AllowDelete = Freigabe
        Me.empflist.AllowUpdate = Freigabe

        Me.GroupBox1.Enabled = Freigabe
        Me.GroupBox2.Enabled = Freigabe
        Me.GroupBox3.Enabled = Freigabe
        Me.GroupBox5.Enabled = Freigabe
        Me.GroupBox8.Enabled = Freigabe

        Me.MnuMainDokument.Enabled = Freigabe
        Me.MnuMainEmpfaengerliste.Enabled = Freigabe
        Me.C1CommandMenu1.Enabled = Freigabe
        Me.MnuMainAbschluss.Enabled = Freigabe
        Me.MnuMainSave.Enabled = Freigabe
        Me.MnuMainSerienbriefLoeschen.Enabled = Freigabe

        Try
            If Me.doktyp.bSbimport.Value = True Then
                Me.MnuMainVorlageImportieren.Enabled = True
            Else
                Me.MnuMainVorlageImportieren.Enabled = False
            End If
        Catch
        End Try

        Dim i As Integer
        If Freigabe = False Then
            For i = 0 To Me.ToolBar1.Buttons.Count - 1
                Me.ToolBar1.Buttons(i).Enabled = False
            Next
            Me.ToolBar1.Buttons(0).Enabled = True
            Me.ToolBar1.Buttons(1).Enabled = True
            Me.ToolBar1.Buttons(2).Enabled = True
        Else
            For i = 0 To Me.ToolBar1.Buttons.Count - 1
                Me.ToolBar1.Buttons(i).Enabled = True
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Generate_Barcodes Method

Private Sub Generate_Barcodes()

Source code

[Visual Basic]
    Private Sub Generate_Barcodes()
        Insert_TextFelder()
        ins_Barcode()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Generate_Tree Method

Private Sub Generate_Tree()

Source code

[Visual Basic]
    Private Sub Generate_Tree()
        Dim notreeselected As Boolean
        Me.TVStatus.BeginUpdate()
        Dim savetn As New TreeNode()
        Try
            savetn = Me.TVStatus.SelectedNode
            If savetn Is Nothing Then notreeselected = True Else notreeselected = False
        Catch
            notreeselected = True
        End Try
        Me.SetProgress(20, "Struktur aktualisieren", False)
        'Dim dx As DataRow
        'For Each dx In Me.dsempfaenger.Tables(0).Rows
        '    dx.Item("status") = 0
        'Next
        'Me.save_data()
        Me.TVStatus.Nodes.Clear()
        Dim tn As New TreeNode()
        Dim tn1 As New TreeNode()
        Dim tn2 As New TreeNode()

        Dim iFehlerhaft As Integer
        Dim iInBearbeitung As Integer
        Dim iNichtgeneriert As Integer
        Dim iAusgeloest As Integer
        Dim iErstellt As Integer
        Dim iGedruckt As Integer
        Dim iBestaetigt As Integer

        Dim dv As DataRow()
        Dim DR As DataRow
        dv = Me.dsempfaenger.Tables(0).Select("Status='-1'")
        iFehlerhaft = 0
        For Each DR In dv
            iFehlerhaft = iFehlerhaft + 1
        Next
        iNichtgeneriert = 0
        dv = Me.dsempfaenger.Tables(0).Select("Status='0' or Status=''")
        For Each DR In dv
            iNichtgeneriert = iNichtgeneriert + 1
        Next
        'If NeuerSB Then iNichtgeneriert = iNichtgeneriert - 1

        iAusgeloest = 0
        dv = Me.dsempfaenger.Tables(0).Select("Status='1'")
        For Each DR In dv
            iAusgeloest = iAusgeloest + 1
        Next

        iErstellt = 0
        dv = Me.dsempfaenger.Tables(0).Select("Status='2'")
        For Each DR In dv
            iErstellt = iErstellt + 1
        Next
        iGedruckt = 0
        dv = Me.dsempfaenger.Tables(0).Select("Status='3'")
        For Each DR In dv
            iGedruckt = iGedruckt + 1
        Next
        iBestaetigt = 0
        dv = Me.dsempfaenger.Tables(0).Select("Status='4'")
        For Each DR In dv
            iBestaetigt = iBestaetigt + 1
        Next

        Me.SetProgress(40, "Struktur aktualisieren", False)

        Dim z As Integer
        'If NeuerSB Then
        '    If NeuerSB Then z = 0 Else z = Me.dsempfaenger.Tables(0).Rows.Count
        'End If
        tn = Me.TVStatus.Nodes.Add(Me.serienbrief.sBezeichnung.Value + " (" + z.ToString + ")")

        tn.SelectedImageIndex = 0
        tn.ImageIndex = -99
        tn.Tag = -3
        If Me.serienbrief.iStatus.Value > 0 Then
            tn1 = tn.Nodes.Add("in Bearbeitung (0)")
        Else
            tn1 = tn.Nodes.Add("in Bearbeitung (" + Str(iFehlerhaft + iNichtgeneriert + iErstellt + iGedruckt + iBestaetigt).Trim + ")")
        End If

        tn1.Tag = -9
        tn1.SelectedImageIndex = 0
        tn1.ImageIndex = -99
        If Me.serienbrief.iStatus.Value > 0 Then
            tn1 = tn.Nodes.Add("Dokumentgenerierung ausgelöst " + "(" + Str(iAusgeloest).Trim + ")")
            tn1.Tag = 1
            tn1.SelectedImageIndex = 0
            tn1.ImageIndex = -99
            tn1 = tn.Nodes.Add("Abgeschlossen (" + Str(iFehlerhaft + iNichtgeneriert + iErstellt + iGedruckt + iBestaetigt).Trim + ")")
            tn1.Tag = -4
            tn1.SelectedImageIndex = 0
            tn1.ImageIndex = -99
        End If
        tn2 = tn1.Nodes.Add("Fehlerhaft " + "(" + Str(iFehlerhaft).Trim + ")")
        tn2.Tag = -1
        tn2.SelectedImageIndex = 0
        tn2.ImageIndex = -99
        tn2 = tn1.Nodes.Add("Empfänger in Bearbeitung " + "(" + Str(iNichtgeneriert).Trim + ")")
        tn2.Tag = 0
        tn2.SelectedImageIndex = 0
        tn2.ImageIndex = -99
        tn2 = tn1.Nodes.Add("Dokumente erstellt " + "(" + Str(iErstellt).Trim + ")")
        tn2.Tag = 2
        tn2.SelectedImageIndex = 0
        tn2.ImageIndex = -99

        'Druckstapel hinzufügen
        Me.SetProgress(60, "Struktur aktualisieren", False)

        druckjobs = get_druckjobs()
        If druckjobs.Rows.Count > 0 Then
            Dim tn3 As New TreeNode()
            Dim i As Integer
            For i = 0 To druckjobs.Rows.Count - 1
                tn3 = tn2.Nodes.Add(druckjobs.Rows(i).Item(3))
                tn3.Tag = "Job:" + druckjobs.Rows(i).Item(0).ToString
                tn3.ImageIndex = -99
                tn3.SelectedImageIndex = 0
            Next
        End If

        tn2 = tn1.Nodes.Add("Dokumente gedruckt " + "(" + Str(iGedruckt).Trim + ")")
        tn2.Tag = 3
        tn2.SelectedImageIndex = 0
        tn2.ImageIndex = -99

        Me.SetProgress(80, "Struktur aktualisieren", False)

        tn2 = tn1.Nodes.Add("Dokumente bestätigt " + "(" + Str(iBestaetigt).Trim + ")")
        tn2.Tag = 4
        tn2.SelectedImageIndex = 0
        tn2.ImageIndex = -99
        Me.TVStatus.ExpandAll()
        If Me.serienbrief.iStatus.Value < 1 Then
            tn1 = tn.Nodes.Add("Dokumentgenerierung ausgelöst " + "(" + Str(iAusgeloest).Trim + ")")
            tn1.Tag = 1
            tn1.SelectedImageIndex = 0
            tn1.ImageIndex = -99
            tn1 = tn.Nodes.Add("Abgeschlossen")
            tn1.Tag = -4
            tn1.SelectedImageIndex = 0
            tn1.ImageIndex = -99

        End If
        If notreeselected = True Then
            DivFnkt.Searchnode1(Me.TVStatus, 0, 99)
            If DivFnkt.found Then
                Me.TVStatus.SelectedNode = DivFnkt.FoundNode
            End If
        Else
            Try
                DivFnkt.Searchnode1(Me.TVStatus, savetn.Tag, 99)
                If DivFnkt.found Then
                    Me.TVStatus.SelectedNode = DivFnkt.FoundNode
                End If
            Catch
            End Try

            Try
                If Me.serienbrief.iStatus.Value = -1 Then
                    DivFnkt.Searchnode1(Me.TVStatus, 1, 99)
                    If DivFnkt.found Then
                        Me.TVStatus.SelectedNode = DivFnkt.FoundNode
                    End If
                End If
            Catch
            End Try
        End If
        Me.SetProgress(100, "Struktur aktualisieren", True)
        Me.TVStatus.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 7
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_team"
            Case 17
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 7
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.teamzustaendig))
                Case 17
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Get_Vorlagenfelder Method

Private Function Get_Vorlagenfelder( _
   ByVal dokumenttypnr As Integer _
) As DataTable

Parameters

dokumenttypnr
Required.

Source code

[Visual Basic]
    Private Function Get_Vorlagenfelder(ByVal dokumenttypnr As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_vorlagenfelder"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.HeaderFooterAnzeigen Method

Private Sub HeaderFooterAnzeigen()

Source code

[Visual Basic]
    Private Sub HeaderFooterAnzeigen()
        If objword.ActiveWindow.View.SplitSpecial <> Word.WdSpecialPane.wdPaneNone Then
            objword.ActiveWindow.Panes.Item(2).Close()
        End If
        If objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdNormalView Or objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdOutlineView Then
            objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdPrintView
        End If
        objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekCurrentPageHeader
        If objword.Selection.HeaderFooter.IsHeader = True Then
            objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekCurrentPageFooter
        Else
            objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekCurrentPageHeader
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Import_Empfaenger Method

Private Function Import_Empfaenger() As Boolean

Source code

[Visual Basic]
    Private Function Import_Empfaenger() As Boolean
        Dim saveds As New DataSet()
        saveds = Me.dsempfaenger.Copy
        Me.OpenFileDialog1.Filter = "Excel-Dateien (*.xls)|*.xls|CSV-Dateien (*.csv)|*.csv|Text-Dateien (*.txt)|*.txt|Alle Dateien (*.*)|*.*"
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName = "" Then Return False
        Application.DoEvents()
        Dim dt As New DataTable()
        Dim savedt As New DataTable()
        Dim savedt1 As New DataTable()
        If Me.OpenFileDialog1.FileName <> "" Then
            SetProgress(20, "Empfänger importieren", False)
            savedt = Me.dsempfaenger.Tables(0).Copy
            Me.dsempfaenger.Tables.Clear()
            FillDataTableFromText(Me.OpenFileDialog1.FileName)
            If Check_Importtable(Me.dsempfaenger.Tables(0)) = True Then
                create_supporttable()
            Else
                Me.dsempfaenger = saveds.Copy
                Me.SetProgress(100, "", True)
                Exit Function
            End If

            If savedt.Rows.Count > 0 Then
                savedt1 = Me.dsempfaenger.Tables(0).Copy
                Me.dsempfaenger.Tables.Clear()
                Me.dsempfaenger.Tables.Add(savedt.Copy)
                savedt.Dispose()
                Dim r1 As Integer
                Dim c1 As Integer
                Dim dr As DataRow
                Dim inserted As Boolean
                For r1 = 0 To savedt1.Rows.Count - 1
                    dr = Me.dsempfaenger.Tables(0).NewRow
                    inserted = False
                    Try
                        For c1 = 0 To savedt1.Columns.Count - 1
                            dr.Item(savedt1.Columns(c1).ColumnName) = savedt1.Rows(r1).Item(c1)
                            inserted = True
                        Next

                    Catch
                    End Try
                    Try
                        If inserted Then Me.dsempfaenger.Tables(0).Rows.Add(dr)
                    Catch
                    End Try
                Next
            End If
            Me.empflist.DataMember = Nothing
            Me.empflist.DataSource = Nothing
            Try
                Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
                Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Catch
            End Try
            SetProgress(40, "Layout erstellen", False)
            Create_Layout()
            SetProgress(60, "Felder prüfen", False)
            check_vorlagenfelder()
            Dim i As Integer
            Dim i1 As Integer
            For i = 0 To Me.dsempfaenger.Tables(0).Rows.Count - 1
                For i1 = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
                    If Me.dsempfaenger.Tables(0).Rows(i).Item(i1) Is System.DBNull.Value Then
                        Me.dsempfaenger.Tables(0).Rows(i).Item(i1) = ""
                    End If
                Next
            Next
            'Me.NeuerSB = False
            Me.empflist.MultiSelect = c1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
            Me.Generate_Tree()
        End If
        saveds.Dispose()
        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSerienbriefe))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton19 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton14 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton8 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton9 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton10 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton11 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton12 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton13 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton15 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton17 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton16 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton18 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton20 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList4 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.empflist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.TVStatus = New System.Windows.Forms.TreeView()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.GroupBox8 = New System.Windows.Forms.GroupBox()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.MenuNotiz = New System.Windows.Forms.ContextMenu()
        Me.MnuNeueNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuEditNotiz = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteNotiz = New System.Windows.Forms.MenuItem()
        Me.GroupBox5 = New System.Windows.Forms.GroupBox()
        Me.C1DateEdit2 = New C1.Win.C1Input.C1DateEdit()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker6 = New System.Windows.Forms.DateTimePicker()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.GroupBox12 = New System.Windows.Forms.GroupBox()
        Me.cbteam = New System.Windows.Forms.ComboBox()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.cbUnterschriftrechts = New System.Windows.Forms.ComboBox()
        Me.cbUnterschriftlinks = New System.Windows.Forms.ComboBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.RBZustaendigKubedesPartners = New System.Windows.Forms.RadioButton()
        Me.RBZustaendigZustaendiger = New System.Windows.Forms.RadioButton()
        Me.cbzust = New System.Windows.Forms.ComboBox()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.cbPostzustellung = New System.Windows.Forms.ComboBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.C1DateEdit1 = New C1.Win.C1Input.C1DateEdit()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker5 = New System.Windows.Forms.DateTimePicker()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.MenuEmpfaenger = New System.Windows.Forms.ContextMenu()
        Me.mnuAddEmpfaenger = New System.Windows.Forms.MenuItem()
        Me.mnuaddhost = New System.Windows.Forms.MenuItem()
        Me.mnunewedoka = New System.Windows.Forms.MenuItem()
        Me.mnunewempfaenger = New System.Windows.Forms.MenuItem()
        Me.MnuEditEmpfaenger = New System.Windows.Forms.MenuItem()
        Me.MnuDeleteEmpfaenger = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.mnusaveasedokapartner = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.MenuItem23 = New System.Windows.Forms.MenuItem()
        Me.mnuidwspaltehinzufuegen = New System.Windows.Forms.MenuItem()
        Me.mnuidwspalteentfernen = New System.Windows.Forms.MenuItem()
        Me.mnuidvspalteumbenennen = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MnuSpaltenSelektion = New System.Windows.Forms.MenuItem()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.DateTimePicker3 = New System.Windows.Forms.DateTimePicker()
        Me.Label13 = New System.Windows.Forms.Label()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.DateTimePicker4 = New System.Windows.Forms.DateTimePicker()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.txtBezeichnung = New System.Windows.Forms.TextBox()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog()
        Me.C1MainMenu1 = New C1.Win.C1Command.C1MainMenu()
        Me.C1CommandHolder1 = New C1.Win.C1Command.C1CommandHolder()
        Me.C1ContextMenu1 = New C1.Win.C1Command.C1ContextMenu()
        Me.C1CommandLink21 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnupartner1 = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink26 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnupartner2 = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink27 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnupartner3 = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink11 = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmpfaengerBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink12 = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmfpaengerLoeschen = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink2 = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEDOKAPartnerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink14 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuctErstellungWiederholen = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink15 = New C1.Win.C1Command.C1CommandLink()
        Me.C1mnuPartnerdossier = New C1.Win.C1Command.C1Command()
        Me.C1ContextMenu2 = New C1.Win.C1Command.C1ContextMenu()
        Me.C1CommandLink24 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2partnerlistepruefen = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink20 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2generieren = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink18 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2printmenu = New C1.Win.C1Command.C1CommandMenu()
        Me.C1CommandLink22 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2printjob = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink25 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2printpreview = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink23 = New C1.Win.C1Command.C1CommandLink()
        Me.C1Command1 = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink19 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2bestaetigen = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink17 = New C1.Win.C1Command.C1CommandLink()
        Me.mnuc2abschliessen = New C1.Win.C1Command.C1Command()
        Me.MnuMainDatei = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainNeuerSerienbrief = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainNew = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefLaden = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoad = New C1.Win.C1Command.C1Command()
        Me.C1MnuSerienbriefLoeschen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSerienbriefLoeschen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefabschliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAbschluss = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefSpeichern = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSave = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainFensterSchliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainClose = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokument = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainVorlageImportieren = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorlageImportieren = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainVorlageBearbeiten = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorageBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink1 = New C1.Win.C1Command.C1CommandLink()
        Me.c1mnumainpreview = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink3 = New C1.Win.C1Command.C1CommandLink()
        Me.C1mnuPersVorlageSave = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink4 = New C1.Win.C1Command.C1CommandLink()
        Me.C1MnuPersSbLoad = New C1.Win.C1Command.C1Command()
        Me.MnuMainVorschauErstellen = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteGenerieren = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteDrucken = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokumenteBestaetigen = New C1.Win.C1Command.C1Command()
        Me.MnuMainEmpfaengerliste = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainImportEmpfaneger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainImportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainExportEmpfaenger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainExportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainLoadPartnerliste = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoadPartnerliste = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1Command()
        Me.MnuMainAddEDOKAHOSTPartner = New C1.Win.C1Command.C1Command()
        Me.MnuMainNeuerEDOKAPartnerErfassen = New C1.Win.C1Command.C1Command()
        Me.MnuMainNeuerEmpfaengerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1CommandMenu1 = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainAddColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAddColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainDeleteColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDeleteColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainRenameColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainRenameColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSpaltenselektion = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSpaltenselektion = New C1.Win.C1Command.C1Command()
        Me.MnuMainCheckEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.mnuctAddHost = New C1.Win.C1Command.C1Command()
        Me.mnuCTADDEdokapartner = New C1.Win.C1Command.C1Command()
        Me.mnuctaddempfaenger = New C1.Win.C1Command.C1Command()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.C1MnuMainDatei = New C1.Win.C1Command.C1CommandLink()
        Me.C1MnuMainDokument = New C1.Win.C1Command.C1CommandLink()
        Me.C1MnuMainEmpfaengerliste = New C1.Win.C1Command.C1CommandLink()
        Me.C1MnuIndividuelleDokumentwerte = New C1.Win.C1Command.C1CommandLink()
        Me.statustimer = New System.Windows.Forms.Timer(Me.components)
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        CType(Me.empflist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.TabPage2.SuspendLayout()
        Me.GroupBox8.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox5.SuspendLayout()
        CType(Me.C1DateEdit2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox12.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox2.SuspendLayout()
        CType(Me.C1DateEdit1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4, Me.ToolBarButton5, Me.ToolBarButton19, Me.ToolBarButton14, Me.ToolBarButton6, Me.ToolBarButton7, Me.ToolBarButton8, Me.ToolBarButton9, Me.ToolBarButton10, Me.ToolBarButton11, Me.ToolBarButton12, Me.ToolBarButton13, Me.ToolBarButton15, Me.ToolBarButton17, Me.ToolBarButton16, Me.ToolBarButton18, Me.ToolBarButton20})
        Me.C1CommandHolder1.SetC1ContextMenu(Me.ToolBar1, Nothing)
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList4
        Me.ToolBar1.Location = New System.Drawing.Point(0, 21)
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(744, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Serienbrief-Funktion schliessen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 20
        Me.ToolBarButton2.ToolTipText = "Neuer Serienbrief erstellen"
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 22
        Me.ToolBarButton3.ToolTipText = "Serienbrief öffnen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 23
        Me.ToolBarButton4.ToolTipText = "Serienbrief löschen"
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 24
        Me.ToolBarButton5.ToolTipText = "Serienbrief speichern"
        '
        'ToolBarButton19
        '
        Me.ToolBarButton19.ImageIndex = 27
        Me.ToolBarButton19.ToolTipText = "Serienbrief abschliessen"
        '
        'ToolBarButton14
        '
        Me.ToolBarButton14.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        Me.ToolBarButton14.Visible = False
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        Me.ToolBarButton6.Visible = False
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.ImageIndex = 25
        Me.ToolBarButton7.ToolTipText = "Dokumentvorlage bearbeiten"
        Me.ToolBarButton7.Visible = False
        '
        'ToolBarButton8
        '
        Me.ToolBarButton8.ImageIndex = 26
        Me.ToolBarButton8.ToolTipText = "Vorschau erstellen"
        Me.ToolBarButton8.Visible = False
        '
        'ToolBarButton9
        '
        Me.ToolBarButton9.ImageIndex = 15
        Me.ToolBarButton9.ToolTipText = "Dokumente generieren"
        Me.ToolBarButton9.Visible = False
        '
        'ToolBarButton10
        '
        Me.ToolBarButton10.ImageIndex = 14
        Me.ToolBarButton10.ToolTipText = "Dokumente drucken"
        Me.ToolBarButton10.Visible = False
        '
        'ToolBarButton11
        '
        Me.ToolBarButton11.ImageIndex = 13
        Me.ToolBarButton11.ToolTipText = "Gedruckte Dokumente bestätigen"
        Me.ToolBarButton11.Visible = False
        '
        'ToolBarButton12
        '
        Me.ToolBarButton12.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        Me.ToolBarButton12.Visible = False
        '
        'ToolBarButton13
        '
        Me.ToolBarButton13.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        Me.ToolBarButton13.Visible = False
        '
        'ToolBarButton15
        '
        Me.ToolBarButton15.ImageIndex = 16
        Me.ToolBarButton15.ToolTipText = "HOST/EDOKA-Partner hinzufügen"
        Me.ToolBarButton15.Visible = False
        '
        'ToolBarButton17
        '
        Me.ToolBarButton17.ImageIndex = 18
        Me.ToolBarButton17.ToolTipText = "Neuer EDOKA-Partner erfassen"
        Me.ToolBarButton17.Visible = False
        '
        'ToolBarButton16
        '
        Me.ToolBarButton16.ImageIndex = 19
        Me.ToolBarButton16.ToolTipText = "Neuer Empfänger erfassen"
        Me.ToolBarButton16.Visible = False
        '
        'ToolBarButton18
        '
        Me.ToolBarButton18.ImageIndex = 17
        Me.ToolBarButton18.ToolTipText = "Empfängerliste prüfen"
        Me.ToolBarButton18.Visible = False
        '
        'ToolBarButton20
        '
        Me.ToolBarButton20.ImageIndex = 28
        '
        'ImageList4
        '
        Me.ImageList4.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList4.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList4.ImageStream = CType(resources.GetObject("ImageList4.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList4.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        '
        'TabControl1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TabControl1, Nothing)
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Location = New System.Drawing.Point(0, 85)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(744, 410)
        Me.TabControl1.TabIndex = 42
        '
        'TabPage1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TabPage1, Nothing)
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.empflist, Me.Splitter1, Me.Panel1})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(736, 384)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Empfänger"
        '
        'empflist
        '
        Me.empflist.AllowFilter = True
        Me.empflist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.empflist.AllowSort = True
        Me.empflist.AlternatingRows = True
        Me.C1CommandHolder1.SetC1ContextMenu(Me.empflist, Me.C1ContextMenu1)
        Me.empflist.CaptionHeight = 17
        Me.empflist.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Floating
        Me.empflist.CollapseColor = System.Drawing.Color.Black
        Me.empflist.Cursor = System.Windows.Forms.Cursors.Default
        Me.empflist.DataChanged = False
        Me.empflist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.empflist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.empflist.ExpandColor = System.Drawing.Color.Black
        Me.empflist.FetchRowStyles = True
        Me.empflist.FilterBar = True
        Me.empflist.GroupByCaption = "Drag a column header here to group by that column"
        Me.empflist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.empflist.Location = New System.Drawing.Point(243, 0)
        Me.empflist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.empflist.Name = "empflist"
        Me.empflist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.empflist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.empflist.PreviewInfo.ZoomFactor = 75
        Me.empflist.PrintInfo.ShowOptionsDialog = False
        Me.empflist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.empflist.RowDivider = GridLines1
        Me.empflist.RowHeight = 15
        Me.empflist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.empflist.ScrollTips = True
        Me.empflist.Size = New System.Drawing.Size(493, 384)
        Me.empflist.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.empflist.TabIndex = 26
        Me.empflist.Text = "C1TrueDBGrid1"
        Me.empflist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 489," & _
        " 380</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 489, " & _
        "380</ClientArea></Blob>"
        '
        'Splitter1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Splitter1, Nothing)
        Me.Splitter1.Location = New System.Drawing.Point(240, 0)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 384)
        Me.Splitter1.TabIndex = 28
        Me.Splitter1.TabStop = False
        '
        'Panel1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Panel1, Nothing)
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVStatus})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(240, 384)
        Me.Panel1.TabIndex = 27
        '
        'TVStatus
        '
        Me.TVStatus.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TVStatus, Me.C1ContextMenu2)
        Me.TVStatus.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVStatus.ImageList = Me.ImageList2
        Me.TVStatus.Name = "TVStatus"
        Me.TVStatus.Size = New System.Drawing.Size(240, 384)
        Me.TVStatus.TabIndex = 0
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'TabPage2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TabPage2, Nothing)
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox8, Me.GroupBox5, Me.GroupBox12, Me.GroupBox3, Me.GroupBox1, Me.GroupBox2})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(736, 384)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Dokumentinhalt"
        '
        'GroupBox8
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox8, Nothing)
        Me.GroupBox8.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.Notizlist})
        Me.GroupBox8.Location = New System.Drawing.Point(384, 192)
        Me.GroupBox8.Name = "GroupBox8"
        Me.GroupBox8.Size = New System.Drawing.Size(336, 200)
        Me.GroupBox8.TabIndex = 45
        Me.GroupBox8.TabStop = False
        Me.GroupBox8.Text = "Notizen"
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.C1CommandHolder1.SetC1ContextMenu(Me.drpMiatarbeiter, Nothing)
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(24, 64)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines2
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AlternatingRows = True
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Notizlist, Nothing)
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.MenuNotiz
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.Dock = System.Windows.Forms.DockStyle.Top
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.Notizlist.Location = New System.Drawing.Point(3, 16)
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines3
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(330, 176)
        Me.Notizlist.TabIndex = 0
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecS" & _
        "elWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0," & _
        " 326, 172</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me" & _
        "=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""Ev" & _
        "enRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><Hea" & _
        "dingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow" & _
        """ me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle pare" & _
        "nt=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style" & _
        "11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""" & _
        "Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent=""""" & _
        " me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=" & _
        """Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""In" & _
        "active"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Edit" & _
        "or"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""Even" & _
        "Row"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSe" & _
        "lector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Gr" & _
        "oup"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout" & _
        ">None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 326, " & _
        "172</ClientArea></Blob>"
        '
        'MenuNotiz
        '
        Me.MenuNotiz.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNeueNotiz, Me.MnuEditNotiz, Me.MnuDeleteNotiz})
        '
        'MnuNeueNotiz
        '
        Me.MnuNeueNotiz.Index = 0
        Me.MnuNeueNotiz.Text = "&Neue Notiz"
        '
        'MnuEditNotiz
        '
        Me.MnuEditNotiz.Index = 1
        Me.MnuEditNotiz.Text = "&Notiz bearbeiten"
        '
        'MnuDeleteNotiz
        '
        Me.MnuDeleteNotiz.Index = 2
        Me.MnuDeleteNotiz.Text = "Notiz &löschen"
        '
        'GroupBox5
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox5, Nothing)
        Me.GroupBox5.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1DateEdit2, Me.Label6, Me.TextBox1, Me.DateTimePicker6, Me.Label7, Me.Label8})
        Me.GroupBox5.Location = New System.Drawing.Point(384, 8)
        Me.GroupBox5.Name = "GroupBox5"
        Me.GroupBox5.Size = New System.Drawing.Size(336, 176)
        Me.GroupBox5.TabIndex = 44
        Me.GroupBox5.TabStop = False
        Me.GroupBox5.Text = "Allgemein"
        '
        'C1DateEdit2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.C1DateEdit2, Nothing)
        '
        'C1DateEdit2.Calendar
        '
        Me.C1DateEdit2.Calendar.Date = New Date(2005, 9, 4, 0, 0, 0, 0)
        Me.C1DateEdit2.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.C1DateEdit2.Location = New System.Drawing.Point(88, 24)
        Me.C1DateEdit2.Name = "C1DateEdit2"
        Me.C1DateEdit2.ShowUpDownButtons = False
        Me.C1DateEdit2.Size = New System.Drawing.Size(96, 20)
        Me.C1DateEdit2.TabIndex = 41
        Me.C1DateEdit2.Tag = Nothing
        Me.C1DateEdit2.Value = New Date(2005, 10, 11, 0, 0, 0, 0)
        '
        'Label6
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label6, Nothing)
        Me.Label6.Location = New System.Drawing.Point(8, 48)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 40
        Me.Label6.Text = "Bemerkung"
        '
        'TextBox1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TextBox1, Nothing)
        Me.TextBox1.Location = New System.Drawing.Point(88, 48)
        Me.TextBox1.Multiline = True
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(240, 120)
        Me.TextBox1.TabIndex = 37
        Me.TextBox1.Text = ""
        '
        'DateTimePicker6
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.DateTimePicker6, Nothing)
        Me.DateTimePicker6.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker6.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker6.Name = "DateTimePicker6"
        Me.DateTimePicker6.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker6.TabIndex = 36
        Me.DateTimePicker6.Visible = False
        '
        'Label7
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label7, Nothing)
        Me.Label7.Location = New System.Drawing.Point(8, 104)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(80, 23)
        Me.Label7.TabIndex = 39
        Me.Label7.Text = "Archiv-Datum"
        Me.Label7.Visible = False
        '
        'Label8
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label8, Nothing)
        Me.Label8.Location = New System.Drawing.Point(8, 24)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(80, 23)
        Me.Label8.TabIndex = 38
        Me.Label8.Text = "Termin"
        '
        'GroupBox12
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox12, Nothing)
        Me.GroupBox12.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbteam})
        Me.GroupBox12.Location = New System.Drawing.Point(8, 272)
        Me.GroupBox12.Name = "GroupBox12"
        Me.GroupBox12.Size = New System.Drawing.Size(368, 48)
        Me.GroupBox12.TabIndex = 41
        Me.GroupBox12.TabStop = False
        Me.GroupBox12.Text = "Team"
        '
        'cbteam
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbteam, Nothing)
        Me.cbteam.Location = New System.Drawing.Point(128, 16)
        Me.cbteam.Name = "cbteam"
        Me.cbteam.Size = New System.Drawing.Size(232, 21)
        Me.cbteam.TabIndex = 0
        '
        'GroupBox3
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox3, Nothing)
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbUnterschriftrechts, Me.cbUnterschriftlinks, Me.Label9, Me.Label10})
        Me.GroupBox3.Location = New System.Drawing.Point(8, 192)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(368, 72)
        Me.GroupBox3.TabIndex = 40
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Unterschrift"
        '
        'cbUnterschriftrechts
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbUnterschriftrechts, Nothing)
        Me.cbUnterschriftrechts.Location = New System.Drawing.Point(128, 43)
        Me.cbUnterschriftrechts.Name = "cbUnterschriftrechts"
        Me.cbUnterschriftrechts.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftrechts.TabIndex = 1
        '
        'cbUnterschriftlinks
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbUnterschriftlinks, Nothing)
        Me.cbUnterschriftlinks.Location = New System.Drawing.Point(128, 19)
        Me.cbUnterschriftlinks.Name = "cbUnterschriftlinks"
        Me.cbUnterschriftlinks.Size = New System.Drawing.Size(232, 21)
        Me.cbUnterschriftlinks.TabIndex = 0
        '
        'Label9
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label9, Nothing)
        Me.Label9.Location = New System.Drawing.Point(8, 48)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(96, 23)
        Me.Label9.TabIndex = 3
        Me.Label9.Text = "Unterschrift rechts"
        '
        'Label10
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label10, Nothing)
        Me.Label10.Location = New System.Drawing.Point(8, 24)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(96, 23)
        Me.Label10.TabIndex = 2
        Me.Label10.Text = "Unterschrift links"
        '
        'GroupBox1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox1, Nothing)
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBZustaendigKubedesPartners, Me.RBZustaendigZustaendiger, Me.cbzust})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 96)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(368, 88)
        Me.GroupBox1.TabIndex = 39
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zuständigkeit"
        '
        'RBZustaendigKubedesPartners
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RBZustaendigKubedesPartners, Nothing)
        Me.RBZustaendigKubedesPartners.Location = New System.Drawing.Point(16, 48)
        Me.RBZustaendigKubedesPartners.Name = "RBZustaendigKubedesPartners"
        Me.RBZustaendigKubedesPartners.Size = New System.Drawing.Size(112, 24)
        Me.RBZustaendigKubedesPartners.TabIndex = 4
        Me.RBZustaendigKubedesPartners.Text = "Kundenbetreuer des Partners"
        '
        'RBZustaendigZustaendiger
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.RBZustaendigZustaendiger, Nothing)
        Me.RBZustaendigZustaendiger.Location = New System.Drawing.Point(16, 24)
        Me.RBZustaendigZustaendiger.Name = "RBZustaendigZustaendiger"
        Me.RBZustaendigZustaendiger.Size = New System.Drawing.Size(98, 24)
        Me.RBZustaendigZustaendiger.TabIndex = 1
        Me.RBZustaendigZustaendiger.Text = "Zuständiger"
        '
        'cbzust
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbzust, Nothing)
        Me.cbzust.Location = New System.Drawing.Point(128, 24)
        Me.cbzust.Name = "cbzust"
        Me.cbzust.Size = New System.Drawing.Size(232, 21)
        Me.cbzust.TabIndex = 3
        '
        'GroupBox2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.GroupBox2, Nothing)
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.DateTimePicker1, Me.cbPostzustellung, Me.Label11, Me.Label12})
        Me.GroupBox2.Location = New System.Drawing.Point(8, 8)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(368, 80)
        Me.GroupBox2.TabIndex = 38
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Allgemein"
        '
        'DateTimePicker1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.DateTimePicker1, Nothing)
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(128, 48)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(104, 20)
        Me.DateTimePicker1.TabIndex = 1
        '
        'cbPostzustellung
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbPostzustellung, Nothing)
        Me.cbPostzustellung.Location = New System.Drawing.Point(128, 24)
        Me.cbPostzustellung.Name = "cbPostzustellung"
        Me.cbPostzustellung.Size = New System.Drawing.Size(232, 21)
        Me.cbPostzustellung.TabIndex = 0
        '
        'Label11
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label11, Nothing)
        Me.Label11.Location = New System.Drawing.Point(16, 48)
        Me.Label11.Name = "Label11"
        Me.Label11.TabIndex = 11
        Me.Label11.Text = "Dokument-Datum"
        '
        'Label12
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label12, Nothing)
        Me.Label12.Location = New System.Drawing.Point(16, 24)
        Me.Label12.Name = "Label12"
        Me.Label12.TabIndex = 10
        Me.Label12.Text = "Post-Zustellung"
        '
        'C1DateEdit1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.C1DateEdit1, Nothing)
        '
        'C1DateEdit1.Calendar
        '
        Me.C1DateEdit1.Calendar.Date = New Date(2005, 9, 4, 0, 0, 0, 0)
        Me.C1DateEdit1.FormatType = C1.Win.C1Input.FormatTypeEnum.ShortDate
        Me.C1DateEdit1.Location = New System.Drawing.Point(88, 48)
        Me.C1DateEdit1.Name = "C1DateEdit1"
        Me.C1DateEdit1.ShowUpDownButtons = False
        Me.C1DateEdit1.Size = New System.Drawing.Size(96, 20)
        Me.C1DateEdit1.TabIndex = 41
        Me.C1DateEdit1.Tag = Nothing
        '
        'Label3
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label3, Nothing)
        Me.Label3.Location = New System.Drawing.Point(8, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 23)
        Me.Label3.TabIndex = 40
        '
        'TextBox2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TextBox2, Nothing)
        Me.TextBox2.Location = New System.Drawing.Point(88, 72)
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(240, 112)
        Me.TextBox2.TabIndex = 37
        Me.TextBox2.Text = ""
        '
        'DateTimePicker5
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.DateTimePicker5, Nothing)
        Me.DateTimePicker5.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker5.Location = New System.Drawing.Point(88, 20)
        Me.DateTimePicker5.Name = "DateTimePicker5"
        Me.DateTimePicker5.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker5.TabIndex = 36
        '
        'Label4
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label4, Nothing)
        Me.Label4.Location = New System.Drawing.Point(8, 20)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(80, 23)
        Me.Label4.TabIndex = 39
        '
        'Label5
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label5, Nothing)
        Me.Label5.Location = New System.Drawing.Point(8, 44)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 23)
        Me.Label5.TabIndex = 38
        '
        'MenuEmpfaenger
        '
        Me.MenuEmpfaenger.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuAddEmpfaenger, Me.MnuEditEmpfaenger, Me.MnuDeleteEmpfaenger, Me.MenuItem12, Me.mnusaveasedokapartner, Me.MenuItem14, Me.MenuItem23})
        '
        'mnuAddEmpfaenger
        '
        Me.mnuAddEmpfaenger.Index = 0
        Me.mnuAddEmpfaenger.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuaddhost, Me.mnunewedoka, Me.mnunewempfaenger})
        Me.mnuAddEmpfaenger.Text = "Empänger hinzufügen"
        '
        'mnuaddhost
        '
        Me.mnuaddhost.Index = 0
        Me.mnuaddhost.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.mnuaddhost.Text = "&HOST-/EDOKA-Partner"
        '
        'mnunewedoka
        '
        Me.mnunewedoka.Index = 1
        Me.mnunewedoka.Shortcut = System.Windows.Forms.Shortcut.CtrlE
        Me.mnunewedoka.Text = "&Neuer EDOKA-Partner erfassen"
        '
        'mnunewempfaenger
        '
        Me.mnunewempfaenger.Index = 2
        Me.mnunewempfaenger.Shortcut = System.Windows.Forms.Shortcut.CtrlA
        Me.mnunewempfaenger.Text = "Neuer E&mpfänger erfassen"
        '
        'MnuEditEmpfaenger
        '
        Me.MnuEditEmpfaenger.Index = 1
        Me.MnuEditEmpfaenger.Text = "Empfänger bearbeiten"
        '
        'MnuDeleteEmpfaenger
        '
        Me.MnuDeleteEmpfaenger.Index = 2
        Me.MnuDeleteEmpfaenger.Text = "&Empfänger löschen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 3
        Me.MenuItem12.Text = "-"
        '
        'mnusaveasedokapartner
        '
        Me.mnusaveasedokapartner.Index = 4
        Me.mnusaveasedokapartner.Text = "&Empfänger als EDOKA-Partner speichern"
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 5
        Me.MenuItem14.Text = "-"
        '
        'MenuItem23
        '
        Me.MenuItem23.Index = 6
        Me.MenuItem23.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuidwspaltehinzufuegen, Me.mnuidwspalteentfernen, Me.mnuidvspalteumbenennen, Me.MenuItem10, Me.MnuSpaltenSelektion})
        Me.MenuItem23.Text = "Individuelle Dokumentwerte"
        '
        'mnuidwspaltehinzufuegen
        '
        Me.mnuidwspaltehinzufuegen.Index = 0
        Me.mnuidwspaltehinzufuegen.Text = "Spalte hinzufügen"
        '
        'mnuidwspalteentfernen
        '
        Me.mnuidwspalteentfernen.Index = 1
        Me.mnuidwspalteentfernen.Text = "Spalte löschen"
        '
        'mnuidvspalteumbenennen
        '
        Me.mnuidvspalteumbenennen.Index = 2
        Me.mnuidvspalteumbenennen.Text = "Spalte umbenennen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 3
        Me.MenuItem10.Text = "-"
        '
        'MnuSpaltenSelektion
        '
        Me.MnuSpaltenSelektion.Index = 4
        Me.MnuSpaltenSelektion.Text = "&Spalten-Selektion"
        '
        'Label20
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label20, Nothing)
        Me.Label20.Location = New System.Drawing.Point(8, 72)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(80, 23)
        Me.Label20.TabIndex = 35
        '
        'txtBemerkung
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.txtBemerkung, Nothing)
        Me.txtBemerkung.Location = New System.Drawing.Point(88, 72)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(240, 112)
        Me.txtBemerkung.TabIndex = 2
        Me.txtBemerkung.Text = ""
        '
        'DateTimePicker3
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.DateTimePicker3, Nothing)
        Me.DateTimePicker3.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker3.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker3.Name = "DateTimePicker3"
        Me.DateTimePicker3.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker3.TabIndex = 0
        '
        'Label13
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label13, Nothing)
        Me.Label13.Location = New System.Drawing.Point(8, 24)
        Me.Label13.Name = "Label13"
        Me.Label13.Size = New System.Drawing.Size(80, 23)
        Me.Label13.TabIndex = 34
        '
        'Label14
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label14, Nothing)
        Me.Label14.Location = New System.Drawing.Point(8, 48)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(80, 23)
        Me.Label14.TabIndex = 30
        '
        'Label16
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label16, Nothing)
        Me.Label16.Location = New System.Drawing.Point(8, 72)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(80, 23)
        Me.Label16.TabIndex = 35
        Me.Label16.Text = "Bemerkung"
        '
        'TextBox10
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.TextBox10, Nothing)
        Me.TextBox10.Location = New System.Drawing.Point(88, 72)
        Me.TextBox10.Multiline = True
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.Size = New System.Drawing.Size(240, 112)
        Me.TextBox10.TabIndex = 2
        Me.TextBox10.Text = ""
        '
        'DateTimePicker4
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.DateTimePicker4, Nothing)
        Me.DateTimePicker4.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker4.Location = New System.Drawing.Point(88, 24)
        Me.DateTimePicker4.Name = "DateTimePicker4"
        Me.DateTimePicker4.Size = New System.Drawing.Size(96, 20)
        Me.DateTimePicker4.TabIndex = 0
        '
        'Label17
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label17, Nothing)
        Me.Label17.Location = New System.Drawing.Point(8, 24)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(80, 23)
        Me.Label17.TabIndex = 34
        Me.Label17.Text = "Archiv-Datum"
        '
        'Label18
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label18, Nothing)
        Me.Label18.Location = New System.Drawing.Point(8, 48)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(80, 23)
        Me.Label18.TabIndex = 30
        Me.Label18.Text = "Termin"
        '
        'Label1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label1, Nothing)
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 48
        Me.Label1.Text = "Bezeichnung"
        '
        'txtBezeichnung
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.txtBezeichnung, Nothing)
        Me.txtBezeichnung.Location = New System.Drawing.Point(80, 8)
        Me.txtBezeichnung.Name = "txtBezeichnung"
        Me.txtBezeichnung.Size = New System.Drawing.Size(320, 20)
        Me.txtBezeichnung.TabIndex = 49
        Me.txtBezeichnung.Text = ""
        '
        'cbVerantwortlich
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.cbVerantwortlich, Nothing)
        Me.cbVerantwortlich.Enabled = False
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(512, 8)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(224, 21)
        Me.cbVerantwortlich.TabIndex = 45
        '
        'Label2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Label2, Nothing)
        Me.Label2.Location = New System.Drawing.Point(408, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(88, 23)
        Me.Label2.TabIndex = 46
        Me.Label2.Text = "Verantwortlicher"
        '
        'Panel2
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.Panel2, Nothing)
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbVerantwortlich, Me.Label2, Me.Label1, Me.txtBezeichnung})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Location = New System.Drawing.Point(0, 46)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(744, 39)
        Me.Panel2.TabIndex = 50
        '
        'SaveFileDialog1
        '
        Me.SaveFileDialog1.FileName = "doc1"
        '
        'C1MainMenu1
        '
        Me.C1MainMenu1.CommandHolder = Me.C1CommandHolder1
        Me.C1MainMenu1.CommandLinks.Add(Me.C1MnuMainDatei)
        Me.C1MainMenu1.CommandLinks.Add(Me.C1MnuMainDokument)
        Me.C1MainMenu1.CommandLinks.Add(Me.C1MnuMainEmpfaengerliste)
        Me.C1MainMenu1.CommandLinks.Add(Me.C1MnuIndividuelleDokumentwerte)
        Me.C1MainMenu1.Dock = System.Windows.Forms.DockStyle.Top
        Me.C1MainMenu1.Name = "C1MainMenu1"
        Me.C1MainMenu1.Size = New System.Drawing.Size(744, 21)
        Me.C1MainMenu1.Text = "C1MainMenu1"
        '
        'C1CommandHolder1
        '
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDatei)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNew)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoad)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSave)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainClose)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokument)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorlageImportieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorageBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorschauErstellen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteGenerieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteDrucken)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteBestaetigen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddEDOKAHOSTPartner)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEDOKAPartnerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEmpfaengerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoadPartnerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSaveAsPartnerlist)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainImportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainExportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEDOKAPartnerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.C1CommandMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDeleteColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainRenameColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSpaltenselektion)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAbschluss)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmfpaengerLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainCheckEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSerienbriefLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctAddHost)
        Me.C1CommandHolder1.Commands.Add(Me.mnuCTADDEdokapartner)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctaddempfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.C1ContextMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctErstellungWiederholen)
        Me.C1CommandHolder1.Commands.Add(Me.C1mnuPartnerdossier)
        Me.C1CommandHolder1.Commands.Add(Me.C1ContextMenu2)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2abschliessen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2bestaetigen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2generieren)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2printmenu)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2printjob)
        Me.C1CommandHolder1.Commands.Add(Me.C1Command1)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2partnerlistepruefen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuc2printpreview)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner1)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner2)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnupartner3)
        Me.C1CommandHolder1.Commands.Add(Me.c1mnumainpreview)
        Me.C1CommandHolder1.Commands.Add(Me.C1mnuPersVorlageSave)
        Me.C1CommandHolder1.Commands.Add(Me.C1MnuPersSbLoad)
        Me.C1CommandHolder1.ImageList = Me.ImageList1
        Me.C1CommandHolder1.ImageTransparentColor = System.Drawing.Color.LightGray
        Me.C1CommandHolder1.Owner = Me
        Me.C1CommandHolder1.SmoothImages = False
        '
        'C1ContextMenu1
        '
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink21)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink26)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink27)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink11)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink12)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink2)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink14)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink15)
        Me.C1ContextMenu1.Image = Nothing
        Me.C1ContextMenu1.Name = "C1ContextMenu1"
        '
        'C1CommandLink21
        '
        Me.C1CommandLink21.Command = Me.c1mnupartner1
        Me.C1CommandLink21.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'c1mnupartner1
        '
        Me.c1mnupartner1.Image = CType(resources.GetObject("c1mnupartner1.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner1.ImageIndex = 16
        Me.c1mnupartner1.Name = "c1mnupartner1"
        Me.c1mnupartner1.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'C1CommandLink26
        '
        Me.C1CommandLink26.Command = Me.c1mnupartner2
        Me.C1CommandLink26.Text = "Neuer EDOKA-Partner erfassen"
        '
        'c1mnupartner2
        '
        Me.c1mnupartner2.Image = CType(resources.GetObject("c1mnupartner2.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner2.ImageIndex = 18
        Me.c1mnupartner2.Name = "c1mnupartner2"
        Me.c1mnupartner2.Text = "Neuer EDOKA-Partner erfassen"
        '
        'C1CommandLink27
        '
        Me.C1CommandLink27.Command = Me.c1mnupartner3
        Me.C1CommandLink27.Text = "Neuer Empfänger erfassen"
        '
        'c1mnupartner3
        '
        Me.c1mnupartner3.Image = CType(resources.GetObject("c1mnupartner3.Image"), System.Drawing.Bitmap)
        Me.c1mnupartner3.ImageIndex = 19
        Me.c1mnupartner3.Name = "c1mnupartner3"
        Me.c1mnupartner3.Text = "Neuer Empfänger erfassen"
        '
        'C1CommandLink11
        '
        Me.C1CommandLink11.Command = Me.MnuMainEmpfaengerBearbeiten
        Me.C1CommandLink11.Delimiter = True
        Me.C1CommandLink11.Text = "Markierter Empfänger bearbeiten"
        '
        'MnuMainEmpfaengerBearbeiten
        '
        Me.MnuMainEmpfaengerBearbeiten.Image = Nothing
        Me.MnuMainEmpfaengerBearbeiten.Name = "MnuMainEmpfaengerBearbeiten"
        Me.MnuMainEmpfaengerBearbeiten.Text = "Markierter Empfänger bearbeiten"
        '
        'C1CommandLink12
        '
        Me.C1CommandLink12.Command = Me.MnuMainEmfpaengerLoeschen
        Me.C1CommandLink12.Text = "Markierter Empfänger löschen"
        '
        'MnuMainEmfpaengerLoeschen
        '
        Me.MnuMainEmfpaengerLoeschen.Image = Nothing
        Me.MnuMainEmfpaengerLoeschen.Name = "MnuMainEmfpaengerLoeschen"
        Me.MnuMainEmfpaengerLoeschen.Text = "Markierter Empfänger löschen"
        '
        'C1CommandLink2
        '
        Me.C1CommandLink2.Command = Me.MnuMainEDOKAPartnerErfassen
        Me.C1CommandLink2.Delimiter = True
        Me.C1CommandLink2.Text = "Markierter Empfänger als EDOKA-Partner erfassen"
        '
        'MnuMainEDOKAPartnerErfassen
        '
        Me.MnuMainEDOKAPartnerErfassen.Image = Nothing
        Me.MnuMainEDOKAPartnerErfassen.Name = "MnuMainEDOKAPartnerErfassen"
        Me.MnuMainEDOKAPartnerErfassen.Text = "Markierter Empfänger als EDOKA-Partner erfassen"
        '
        'C1CommandLink14
        '
        Me.C1CommandLink14.Command = Me.mnuctErstellungWiederholen
        Me.C1CommandLink14.Delimiter = True
        Me.C1CommandLink14.Text = "Dokumenterstellung wiederholen"
        '
        'mnuctErstellungWiederholen
        '
        Me.mnuctErstellungWiederholen.Image = Nothing
        Me.mnuctErstellungWiederholen.Name = "mnuctErstellungWiederholen"
        Me.mnuctErstellungWiederholen.Text = "Dokumenterstellung wiederholen"
        '
        'C1CommandLink15
        '
        Me.C1CommandLink15.Command = Me.C1mnuPartnerdossier
        Me.C1CommandLink15.Text = "Partnerdossier anzeigen"
        '
        'C1mnuPartnerdossier
        '
        Me.C1mnuPartnerdossier.Image = Nothing
        Me.C1mnuPartnerdossier.Name = "C1mnuPartnerdossier"
        Me.C1mnuPartnerdossier.Text = "Partnerdossier anzeigen"
        '
        'C1ContextMenu2
        '
        Me.C1ContextMenu2.CommandLinks.Add(Me.C1CommandLink24)
        Me.C1ContextMenu2.CommandLinks.Add(Me.C1CommandLink20)
        Me.C1ContextMenu2.CommandLinks.Add(Me.C1CommandLink18)
        Me.C1ContextMenu2.CommandLinks.Add(Me.C1CommandLink19)
        Me.C1ContextMenu2.CommandLinks.Add(Me.C1CommandLink17)
        Me.C1ContextMenu2.Image = Nothing
        Me.C1ContextMenu2.Name = "C1ContextMenu2"
        '
        'C1CommandLink24
        '
        Me.C1CommandLink24.Command = Me.mnuc2partnerlistepruefen
        Me.C1CommandLink24.Text = "Empfängerliste prüfen"
        '
        'mnuc2partnerlistepruefen
        '
        Me.mnuc2partnerlistepruefen.Image = CType(resources.GetObject("mnuc2partnerlistepruefen.Image"), System.Drawing.Bitmap)
        Me.mnuc2partnerlistepruefen.ImageIndex = 17
        Me.mnuc2partnerlistepruefen.Name = "mnuc2partnerlistepruefen"
        Me.mnuc2partnerlistepruefen.Text = "Partnerliste prüfen"
        '
        'C1CommandLink20
        '
        Me.C1CommandLink20.Command = Me.mnuc2generieren
        Me.C1CommandLink20.Text = "Dokumente generieren"
        '
        'mnuc2generieren
        '
        Me.mnuc2generieren.Image = CType(resources.GetObject("mnuc2generieren.Image"), System.Drawing.Bitmap)
        Me.mnuc2generieren.ImageIndex = 15
        Me.mnuc2generieren.Name = "mnuc2generieren"
        Me.mnuc2generieren.Text = "Dokumente generieren"
        '
        'C1CommandLink18
        '
        Me.C1CommandLink18.Command = Me.mnuc2printmenu
        Me.C1CommandLink18.Delimiter = True
        Me.C1CommandLink18.Text = "Druckstapel"
        '
        'mnuc2printmenu
        '
        Me.mnuc2printmenu.CommandLinks.Add(Me.C1CommandLink22)
        Me.mnuc2printmenu.CommandLinks.Add(Me.C1CommandLink25)
        Me.mnuc2printmenu.CommandLinks.Add(Me.C1CommandLink23)
        Me.mnuc2printmenu.Image = CType(resources.GetObject("mnuc2printmenu.Image"), System.Drawing.Bitmap)
        Me.mnuc2printmenu.ImageIndex = 14
        Me.mnuc2printmenu.Name = "mnuc2printmenu"
        Me.mnuc2printmenu.Text = "Druckstapel"
        '
        'C1CommandLink22
        '
        Me.C1CommandLink22.Command = Me.mnuc2printjob
        Me.C1CommandLink22.Text = "Druckstapel ausdrucken"
        '
        'mnuc2printjob
        '
        Me.mnuc2printjob.Image = CType(resources.GetObject("mnuc2printjob.Image"), System.Drawing.Bitmap)
        Me.mnuc2printjob.ImageIndex = 14
        Me.mnuc2printjob.Name = "mnuc2printjob"
        Me.mnuc2printjob.Text = "Druckstapel ausdrucken"
        '
        'C1CommandLink25
        '
        Me.C1CommandLink25.Command = Me.mnuc2printpreview
        Me.C1CommandLink25.Text = "Druckstapel anzeigen"
        '
        'mnuc2printpreview
        '
        Me.mnuc2printpreview.Image = Nothing
        Me.mnuc2printpreview.Name = "mnuc2printpreview"
        Me.mnuc2printpreview.Text = "Druckstapel anzeigen"
        '
        'C1CommandLink23
        '
        Me.C1CommandLink23.Command = Me.C1Command1
        Me.C1CommandLink23.Delimiter = True
        Me.C1CommandLink23.Text = "Druckstapel löschen"
        '
        'C1Command1
        '
        Me.C1Command1.Image = Nothing
        Me.C1Command1.Name = "C1Command1"
        Me.C1Command1.Text = "Druckstapel löschen"
        '
        'C1CommandLink19
        '
        Me.C1CommandLink19.Command = Me.mnuc2bestaetigen
        Me.C1CommandLink19.Delimiter = True
        Me.C1CommandLink19.Text = "Dokumente bestätigen"
        '
        'mnuc2bestaetigen
        '
        Me.mnuc2bestaetigen.Image = CType(resources.GetObject("mnuc2bestaetigen.Image"), System.Drawing.Bitmap)
        Me.mnuc2bestaetigen.ImageIndex = 13
        Me.mnuc2bestaetigen.Name = "mnuc2bestaetigen"
        Me.mnuc2bestaetigen.Text = "Dokumente bestätigen"
        '
        'C1CommandLink17
        '
        Me.C1CommandLink17.Command = Me.mnuc2abschliessen
        Me.C1CommandLink17.Text = "Serienbrief abschliessen"
        '
        'mnuc2abschliessen
        '
        Me.mnuc2abschliessen.Image = CType(resources.GetObject("mnuc2abschliessen.Image"), System.Drawing.Bitmap)
        Me.mnuc2abschliessen.ImageIndex = 27
        Me.mnuc2abschliessen.Name = "mnuc2abschliessen"
        Me.mnuc2abschliessen.Text = "Serienbrief abschliessen"
        '
        'MnuMainDatei
        '
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainNeuerSerienbrief)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefLaden)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuSerienbriefLoeschen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefabschliessen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefSpeichern)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainFensterSchliessen)
        Me.MnuMainDatei.Image = Nothing
        Me.MnuMainDatei.Name = "MnuMainDatei"
        Me.MnuMainDatei.Text = "&Datei"
        '
        'C1MnuMainNeuerSerienbrief
        '
        Me.C1MnuMainNeuerSerienbrief.Command = Me.MnuMainNew
        Me.C1MnuMainNeuerSerienbrief.Text = "&Neuer Serienbrief"
        '
        'MnuMainNew
        '
        Me.MnuMainNew.Image = CType(resources.GetObject("MnuMainNew.Image"), System.Drawing.Bitmap)
        Me.MnuMainNew.ImageIndex = 20
        Me.MnuMainNew.Name = "MnuMainNew"
        Me.MnuMainNew.Text = "&Neuer Serienbrief"
        '
        'C1MnuMainSerienbriefLaden
        '
        Me.C1MnuMainSerienbriefLaden.Command = Me.MnuMainLoad
        Me.C1MnuMainSerienbriefLaden.Text = "Serienbrief &laden"
        '
        'MnuMainLoad
        '
        Me.MnuMainLoad.Image = CType(resources.GetObject("MnuMainLoad.Image"), System.Drawing.Bitmap)
        Me.MnuMainLoad.ImageIndex = 22
        Me.MnuMainLoad.Name = "MnuMainLoad"
        Me.MnuMainLoad.Text = "Serienbrief &laden"
        '
        'C1MnuSerienbriefLoeschen
        '
        Me.C1MnuSerienbriefLoeschen.Command = Me.MnuMainSerienbriefLoeschen
        Me.C1MnuSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'MnuMainSerienbriefLoeschen
        '
        Me.MnuMainSerienbriefLoeschen.Image = CType(resources.GetObject("MnuMainSerienbriefLoeschen.Image"), System.Drawing.Bitmap)
        Me.MnuMainSerienbriefLoeschen.ImageIndex = 23
        Me.MnuMainSerienbriefLoeschen.Name = "MnuMainSerienbriefLoeschen"
        Me.MnuMainSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'C1MnuMainSerienbriefabschliessen
        '
        Me.C1MnuMainSerienbriefabschliessen.Command = Me.MnuMainAbschluss
        Me.C1MnuMainSerienbriefabschliessen.Text = "Serienbrief abschliessen"
        '
        'MnuMainAbschluss
        '
        Me.MnuMainAbschluss.Image = CType(resources.GetObject("MnuMainAbschluss.Image"), System.Drawing.Bitmap)
        Me.MnuMainAbschluss.ImageIndex = 27
        Me.MnuMainAbschluss.Name = "MnuMainAbschluss"
        Me.MnuMainAbschluss.Text = "Serienbrief abschliessen"
        '
        'C1MnuMainSerienbriefSpeichern
        '
        Me.C1MnuMainSerienbriefSpeichern.Command = Me.MnuMainSave
        Me.C1MnuMainSerienbriefSpeichern.Delimiter = True
        Me.C1MnuMainSerienbriefSpeichern.Text = "&Serienbrief speichern"
        '
        'MnuMainSave
        '
        Me.MnuMainSave.Image = CType(resources.GetObject("MnuMainSave.Image"), System.Drawing.Bitmap)
        Me.MnuMainSave.ImageIndex = 24
        Me.MnuMainSave.Name = "MnuMainSave"
        Me.MnuMainSave.Text = "&Serienbrief speichern"
        '
        'C1MnuMainFensterSchliessen
        '
        Me.C1MnuMainFensterSchliessen.Command = Me.MnuMainClose
        Me.C1MnuMainFensterSchliessen.Delimiter = True
        Me.C1MnuMainFensterSchliessen.Text = "&Fenster schliessen"
        '
        'MnuMainClose
        '
        Me.MnuMainClose.Image = CType(resources.GetObject("MnuMainClose.Image"), System.Drawing.Bitmap)
        Me.MnuMainClose.ImageIndex = 0
        Me.MnuMainClose.Name = "MnuMainClose"
        Me.MnuMainClose.Text = "&Fenster schliessen"
        '
        'MnuMainDokument
        '
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageImportieren)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageBearbeiten)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1CommandLink1)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1CommandLink3)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1CommandLink4)
        Me.MnuMainDokument.Image = Nothing
        Me.MnuMainDokument.Name = "MnuMainDokument"
        Me.MnuMainDokument.Text = "Dokument"
        '
        'C1MnuMainVorlageImportieren
        '
        Me.C1MnuMainVorlageImportieren.Command = Me.MnuMainVorlageImportieren
        Me.C1MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'MnuMainVorlageImportieren
        '
        Me.MnuMainVorlageImportieren.Image = Nothing
        Me.MnuMainVorlageImportieren.Name = "MnuMainVorlageImportieren"
        Me.MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'C1MnuMainVorlageBearbeiten
        '
        Me.C1MnuMainVorlageBearbeiten.Command = Me.MnuMainVorageBearbeiten
        Me.C1MnuMainVorlageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'MnuMainVorageBearbeiten
        '
        Me.MnuMainVorageBearbeiten.Image = CType(resources.GetObject("MnuMainVorageBearbeiten.Image"), System.Drawing.Bitmap)
        Me.MnuMainVorageBearbeiten.ImageIndex = 25
        Me.MnuMainVorageBearbeiten.Name = "MnuMainVorageBearbeiten"
        Me.MnuMainVorageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'C1CommandLink1
        '
        Me.C1CommandLink1.Command = Me.c1mnumainpreview
        Me.C1CommandLink1.Text = "Dokument-Vorschau"
        '
        'c1mnumainpreview
        '
        Me.c1mnumainpreview.Image = CType(resources.GetObject("c1mnumainpreview.Image"), System.Drawing.Bitmap)
        Me.c1mnumainpreview.ImageIndex = 26
        Me.c1mnumainpreview.Name = "c1mnumainpreview"
        Me.c1mnumainpreview.Text = "Dokument-Vorschau"
        '
        'C1CommandLink3
        '
        Me.C1CommandLink3.Command = Me.C1mnuPersVorlageSave
        Me.C1CommandLink3.Delimiter = True
        Me.C1CommandLink3.Text = "Serienbrief-Muster speichern"
        '
        'C1mnuPersVorlageSave
        '
        Me.C1mnuPersVorlageSave.Image = Nothing
        Me.C1mnuPersVorlageSave.Name = "C1mnuPersVorlageSave"
        Me.C1mnuPersVorlageSave.Text = "Serienbrief-Muster speichern"
        '
        'C1CommandLink4
        '
        Me.C1CommandLink4.Command = Me.C1MnuPersSbLoad
        Me.C1CommandLink4.Text = "Serienbrief-Muster laden"
        '
        'C1MnuPersSbLoad
        '
        Me.C1MnuPersSbLoad.Image = Nothing
        Me.C1MnuPersSbLoad.Name = "C1MnuPersSbLoad"
        Me.C1MnuPersSbLoad.Text = "Pers. Serienbriefvorlage laden"
        '
        'MnuMainVorschauErstellen
        '
        Me.MnuMainVorschauErstellen.Image = CType(resources.GetObject("MnuMainVorschauErstellen.Image"), System.Drawing.Bitmap)
        Me.MnuMainVorschauErstellen.ImageIndex = 26
        Me.MnuMainVorschauErstellen.Name = "MnuMainVorschauErstellen"
        Me.MnuMainVorschauErstellen.Text = "Vorschau erstellen"
        '
        'MnuMainDokumenteGenerieren
        '
        Me.MnuMainDokumenteGenerieren.Image = CType(resources.GetObject("MnuMainDokumenteGenerieren.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteGenerieren.ImageIndex = 15
        Me.MnuMainDokumenteGenerieren.Name = "MnuMainDokumenteGenerieren"
        Me.MnuMainDokumenteGenerieren.Text = "Dokumente &generieren"
        '
        'MnuMainDokumenteDrucken
        '
        Me.MnuMainDokumenteDrucken.Image = CType(resources.GetObject("MnuMainDokumenteDrucken.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteDrucken.ImageIndex = 14
        Me.MnuMainDokumenteDrucken.Name = "MnuMainDokumenteDrucken"
        Me.MnuMainDokumenteDrucken.Text = "Dokumente &drucken"
        '
        'MnuMainDokumenteBestaetigen
        '
        Me.MnuMainDokumenteBestaetigen.Image = CType(resources.GetObject("MnuMainDokumenteBestaetigen.Image"), System.Drawing.Bitmap)
        Me.MnuMainDokumenteBestaetigen.ImageIndex = 13
        Me.MnuMainDokumenteBestaetigen.Name = "MnuMainDokumenteBestaetigen"
        Me.MnuMainDokumenteBestaetigen.Text = "Generierte Dokumente bestätigen"
        '
        'MnuMainEmpfaengerliste
        '
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainImportEmpfaneger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainExportEmpfaenger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainLoadPartnerliste)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainSaveAsPartnerlist)
        Me.MnuMainEmpfaengerliste.Image = Nothing
        Me.MnuMainEmpfaengerliste.Name = "MnuMainEmpfaengerliste"
        Me.MnuMainEmpfaengerliste.Text = "Empfängerliste"
        '
        'C1MnuMainImportEmpfaneger
        '
        Me.C1MnuMainImportEmpfaneger.Command = Me.MnuMainImportEmpfaenger
        Me.C1MnuMainImportEmpfaneger.Delimiter = True
        Me.C1MnuMainImportEmpfaneger.Text = "Empfängerliste importieren"
        '
        'MnuMainImportEmpfaenger
        '
        Me.MnuMainImportEmpfaenger.Image = Nothing
        Me.MnuMainImportEmpfaenger.Name = "MnuMainImportEmpfaenger"
        Me.MnuMainImportEmpfaenger.Text = "Empfängerliste importieren"
        '
        'C1MnuMainExportEmpfaenger
        '
        Me.C1MnuMainExportEmpfaenger.Command = Me.MnuMainExportEmpfaenger
        Me.C1MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'MnuMainExportEmpfaenger
        '
        Me.MnuMainExportEmpfaenger.Image = Nothing
        Me.MnuMainExportEmpfaenger.Name = "MnuMainExportEmpfaenger"
        Me.MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'C1MnuMainLoadPartnerliste
        '
        Me.C1MnuMainLoadPartnerliste.Command = Me.MnuMainLoadPartnerliste
        Me.C1MnuMainLoadPartnerliste.Delimiter = True
        Me.C1MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'MnuMainLoadPartnerliste
        '
        Me.MnuMainLoadPartnerliste.Image = Nothing
        Me.MnuMainLoadPartnerliste.Name = "MnuMainLoadPartnerliste"
        Me.MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'C1MnuMainSaveAsPartnerlist
        '
        Me.C1MnuMainSaveAsPartnerlist.Command = Me.MnuMainSaveAsPartnerlist
        Me.C1MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'MnuMainSaveAsPartnerlist
        '
        Me.MnuMainSaveAsPartnerlist.Image = Nothing
        Me.MnuMainSaveAsPartnerlist.Name = "MnuMainSaveAsPartnerlist"
        Me.MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'MnuMainAddEDOKAHOSTPartner
        '
        Me.MnuMainAddEDOKAHOSTPartner.Image = CType(resources.GetObject("MnuMainAddEDOKAHOSTPartner.Image"), System.Drawing.Bitmap)
        Me.MnuMainAddEDOKAHOSTPartner.ImageIndex = 16
        Me.MnuMainAddEDOKAHOSTPartner.Name = "MnuMainAddEDOKAHOSTPartner"
        Me.MnuMainAddEDOKAHOSTPartner.Shortcut = System.Windows.Forms.Shortcut.CtrlP
        Me.MnuMainAddEDOKAHOSTPartner.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'MnuMainNeuerEDOKAPartnerErfassen
        '
        Me.MnuMainNeuerEDOKAPartnerErfassen.Image = CType(resources.GetObject("MnuMainNeuerEDOKAPartnerErfassen.Image"), System.Drawing.Bitmap)
        Me.MnuMainNeuerEDOKAPartnerErfassen.ImageIndex = 18
        Me.MnuMainNeuerEDOKAPartnerErfassen.Name = "MnuMainNeuerEDOKAPartnerErfassen"
        Me.MnuMainNeuerEDOKAPartnerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.MnuMainNeuerEDOKAPartnerErfassen.Text = "&Neuer EDOKA-Partner erfassen"
        '
        'MnuMainNeuerEmpfaengerErfassen
        '
        Me.MnuMainNeuerEmpfaengerErfassen.Image = CType(resources.GetObject("MnuMainNeuerEmpfaengerErfassen.Image"), System.Drawing.Bitmap)
        Me.MnuMainNeuerEmpfaengerErfassen.ImageIndex = 19
        Me.MnuMainNeuerEmpfaengerErfassen.Name = "MnuMainNeuerEmpfaengerErfassen"
        Me.MnuMainNeuerEmpfaengerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlE
        Me.MnuMainNeuerEmpfaengerErfassen.Text = "Neuer E&mpfänger erfassen"
        '
        'C1CommandMenu1
        '
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainAddColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainDeleteColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainRenameColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainSpaltenselektion)
        Me.C1CommandMenu1.Image = Nothing
        Me.C1CommandMenu1.Name = "C1CommandMenu1"
        Me.C1CommandMenu1.Text = "&Dokumentspezifische Werte"
        '
        'C1MnuMainAddColumn
        '
        Me.C1MnuMainAddColumn.Command = Me.MnuMainAddColumn
        Me.C1MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'MnuMainAddColumn
        '
        Me.MnuMainAddColumn.Image = Nothing
        Me.MnuMainAddColumn.Name = "MnuMainAddColumn"
        Me.MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'C1MnuMainDeleteColumn
        '
        Me.C1MnuMainDeleteColumn.Command = Me.MnuMainDeleteColumn
        Me.C1MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'MnuMainDeleteColumn
        '
        Me.MnuMainDeleteColumn.Image = Nothing
        Me.MnuMainDeleteColumn.Name = "MnuMainDeleteColumn"
        Me.MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'C1MnuMainRenameColumn
        '
        Me.C1MnuMainRenameColumn.Command = Me.MnuMainRenameColumn
        Me.C1MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'MnuMainRenameColumn
        '
        Me.MnuMainRenameColumn.Image = Nothing
        Me.MnuMainRenameColumn.Name = "MnuMainRenameColumn"
        Me.MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'C1MnuMainSpaltenselektion
        '
        Me.C1MnuMainSpaltenselektion.Command = Me.MnuMainSpaltenselektion
        Me.C1MnuMainSpaltenselektion.Delimiter = True
        Me.C1MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'MnuMainSpaltenselektion
        '
        Me.MnuMainSpaltenselektion.Image = Nothing
        Me.MnuMainSpaltenselektion.Name = "MnuMainSpaltenselektion"
        Me.MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'MnuMainCheckEmpfaenger
        '
        Me.MnuMainCheckEmpfaenger.Image = CType(resources.GetObject("MnuMainCheckEmpfaenger.Image"), System.Drawing.Bitmap)
        Me.MnuMainCheckEmpfaenger.ImageIndex = 17
        Me.MnuMainCheckEmpfaenger.Name = "MnuMainCheckEmpfaenger"
        Me.MnuMainCheckEmpfaenger.Text = "Empfängerliste prüfen"
        '
        'mnuctAddHost
        '
        Me.mnuctAddHost.Image = CType(resources.GetObject("mnuctAddHost.Image"), System.Drawing.Bitmap)
        Me.mnuctAddHost.ImageIndex = 16
        Me.mnuctAddHost.Name = "mnuctAddHost"
        Me.mnuctAddHost.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'mnuCTADDEdokapartner
        '
        Me.mnuCTADDEdokapartner.Image = CType(resources.GetObject("mnuCTADDEdokapartner.Image"), System.Drawing.Bitmap)
        Me.mnuCTADDEdokapartner.ImageIndex = 18
        Me.mnuCTADDEdokapartner.Name = "mnuCTADDEdokapartner"
        Me.mnuCTADDEdokapartner.Text = "Neuer EDOKA-Partner erfassen"
        '
        'mnuctaddempfaenger
        '
        Me.mnuctaddempfaenger.Image = CType(resources.GetObject("mnuctaddempfaenger.Image"), System.Drawing.Bitmap)
        Me.mnuctaddempfaenger.ImageIndex = 19
        Me.mnuctaddempfaenger.Name = "mnuctaddempfaenger"
        Me.mnuctaddempfaenger.Text = "Neuer Empfänger erfassen"
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.C1CommandHolder1.SetC1ContextMenu(Me.BtnHelp, Nothing)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(720, 24)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 68
        '
        'StatusBar1
        '
        Me.C1CommandHolder1.SetC1ContextMenu(Me.StatusBar1, Nothing)
        Me.StatusBar1.Location = New System.Drawing.Point(0, 495)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(744, 22)
        Me.StatusBar1.TabIndex = 70
        '
        'C1MnuMainDatei
        '
        Me.C1MnuMainDatei.Command = Me.MnuMainDatei
        Me.C1MnuMainDatei.Text = "&Datei"
        '
        'C1MnuMainDokument
        '
        Me.C1MnuMainDokument.Command = Me.MnuMainDokument
        Me.C1MnuMainDokument.Text = "Dokument"
        '
        'C1MnuMainEmpfaengerliste
        '
        Me.C1MnuMainEmpfaengerliste.Command = Me.MnuMainEmpfaengerliste
        Me.C1MnuMainEmpfaengerliste.Text = "Empfängerliste"
        '
        'C1MnuIndividuelleDokumentwerte
        '
        Me.C1MnuIndividuelleDokumentwerte.Command = Me.C1CommandMenu1
        Me.C1MnuIndividuelleDokumentwerte.Text = "&Dokumentspezifische Werte"
        '
        'statustimer
        '
        Me.statustimer.Interval = 3000
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmSerienbriefe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.C1CommandHolder1.SetC1ContextMenu(Me, Nothing)
        Me.ClientSize = New System.Drawing.Size(744, 517)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.StatusBar1, Me.BtnHelp, Me.Panel2, Me.ToolBar1, Me.C1MainMenu1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSerienbriefe"
        Me.Text = "Serienbrief"
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        CType(Me.empflist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.TabPage2.ResumeLayout(False)
        Me.GroupBox8.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox5.ResumeLayout(False)
        CType(Me.C1DateEdit2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox12.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.C1DateEdit1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Insert_Kopfzeile Method

Private Sub Insert_Kopfzeile()

Source code

[Visual Basic]
    Private Sub Insert_Kopfzeile()
        objword.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        If objword.ActiveWindow.View.SplitSpecial <> Word.WdSpecialPane.wdPaneNone Then
            objword.ActiveWindow.Panes.Item(2).Close()
        End If
        If objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdNormalView Or objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdOutlineView Then
            objword.ActiveWindow.ActivePane.View.Type = Word.WdViewType.wdPrintView
        End If
        objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekCurrentPageHeader
        set_headerbookmark()
        objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekMainDocument
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Insert_TextFelder Method

Private Sub Insert_TextFelder()

Source code

[Visual Basic]
    Private Sub Insert_TextFelder()
        Dim xname As String
        Dim i As Integer
        Dim pages As Long
        Dim prop As Object

        pages = objword.ActiveDocument.BuiltInDocumentProperties("NUMBER OF PAGES").value

        Textboxesi = 1
        objword.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        For i = 1 To pages
            xname = Str(i)
            If Microsoft.VisualBasic.Left(xname, 1) = " " Then xname = Microsoft.VisualBasic.Right(xname, Len(xname) - 1)
            objword.Selection.GoTo(what:=Word.WdGoToItem.wdGoToPage, Name:=xname)
            insert_Textfield()
            objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekMainDocument
        Next i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Insert_Value Method

Private Sub Insert_Value( _
   ByVal feldwert As String, _
   ByVal feldname As String _
)

Parameters

feldwert
Required.
feldname
Required.

Source code

[Visual Basic]
    Private Sub Insert_Value(ByVal feldwert As String, ByVal feldname As String)
        Dim i As Integer
        Dim dc As DataRow
        Dim pos1 As Integer
        Dim pos2 As Integer

        If Microsoft.VisualBasic.Left(feldname, 5) = "TMISB" Then
            beginntextmarke = feldname
            endetextmarke = ""
            feldname = ""
        Else
            For Each dc In dsempfaenger.Tables("UsedFelder").Rows
                If dc.Item("TempFeldName") = feldname Then
                    beginntextmarke = dc.Item("Beginntextmarke")
                    endetextmarke = dc.Item("Endetextmarke")
                    feldname = dc.Item("Feldname")
                    Exit For
                End If
            Next
        End If

        If beginntextmarke <> "" And endetextmarke = "" Then
            Try
                objword.ActiveDocument.Bookmarks.Item(beginntextmarke).Select()
                objword.Selection.Text = feldwert
            Catch ex As Exception
            End Try
        End If

        If beginntextmarke <> "" And endetextmarke <> "" Then
            Try
                pos1 = objword.ActiveDocument.Bookmarks.Item(beginntextmarke).Start
                pos2 = objword.ActiveDocument.Bookmarks.Item(endetextmarke).Start
                objword.Selection.SetRange(Start:=pos1, End:=pos2)
                objword.Selection.TypeText(Text:=feldwert)
            Catch ex As Exception
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_Layout Method

Private Sub Load_Layout()

Source code

[Visual Basic]
    Private Sub Load_Layout()
        If Me.dsempfaenger.Tables.Count < 3 Then
            Exit Sub
        End If
        Dim filename As String = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger.lyt"
        Dim FiStr As FileStream = _
            New FileStream(filename, FileMode.Create)
        Dim StrRe As StreamWriter = New StreamWriter(FiStr)
        StrRe.Write(Me.dsempfaenger.Tables("Layout").Rows(0).Item(0))
        StrRe.Close()
        Me.empflist.LoadLayout(filename)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_Printdialog Method

Public Sub Load_Printdialog()

Source code

[Visual Basic]
    Public Sub Load_Printdialog()
        Dim f As New frmsbdruck(Me.Serienbriefnr)
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_Reserved_Words Method

Private Function Load_Reserved_Words()

Source code

[Visual Basic]
    Private Function Load_Reserved_Words()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_load_reserved_Words"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            For i = 0 To dtToReturn.Rows.Count - 1
                Me.reservedwords.Add(dtToReturn.Rows(i).Item(0))
            Next
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_Serienbrief Method

Public Sub Load_Serienbrief( _
   ByVal sbnr As Integer _
)

Parameters

sbnr
Required.

Source code

[Visual Basic]
    Public Sub Load_Serienbrief(ByVal sbnr As Integer)
        'NeuerSB = False
        Me.Serienbriefnr = sbnr
        SetProgress(10, "Vorlage laden", False)
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        Me.Load_data()
        SetProgress(100, "Vorlage laden", True)
        Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
        Me.Cursor = Cursors.Default
        Application.DoEvents()
        If Me.serienbrief.iStatus.Value > 0 Then
            Me.GroupBox2.Enabled = False
            Me.GroupBox1.Enabled = False
            Me.GroupBox3.Enabled = False
            Me.GroupBox12.Enabled = False
            Me.GroupBox5.Enabled = False
            Me.GroupBox8.Enabled = False
            Me.txtBemerkung.Enabled = False
            Me.mcbverantwortlich.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_data Method

Private Sub Load_data()

Source code

[Visual Basic]
    Private Sub Load_data()
        SetProgress(20, "Vorlage laden", False)
        Me.serienbrief.cpMainConnectionProvider = Globals.conn
        Me.serienbrief.iSerienbriefnr = New SqlInt32(CType(Me.Serienbriefnr, Int32))
        Me.serienbrief.SelectOne()
        Me.doktyp.cpMainConnectionProvider = Globals.conn
        Me.doktyp.iDokumenttypnr = New SqlInt32(CType(Me.serienbrief.iDokumenttypnr.Value, Int32))
        Me.doktyp.SelectOne()
        Me.Dokumenttypnr = Me.doktyp.iDokumenttypnr.Value
        SetProgress(40, "Vorlage laden", False)
        On_Fill = True
        Me.FillMcbVerantwortlich()
        On_Fill = False

        Me.txtBezeichnung.Text = Me.serienbrief.sBezeichnung.Value
        Me.mcbverantwortlich.SelectedValue = Me.serienbrief.iVerantwortlich.Value
        Dim i As Integer
        i = Me.serienbrief.iPostzustellung.Value
        Try
            Me.mcbpostzustellung.SelectedValue = i
        Catch
            Me.mcbpostzustellung.SelectedValue = 0
        End Try
        SetProgress(50, "Vorlage laden", False)
        Me.DateTimePicker1.Value = Me.serienbrief.daDokumentdatum.Value
        If Me.serienbrief.iZustaendig.Value = -1 Then
            Me.mcbzust.Enabled = False
            Me.RBZustaendigKubedesPartners.Checked = True
            Me.RBZustaendigZustaendiger.Checked = False
        Else
            Me.mcbzust.Enabled = True
            Me.RBZustaendigKubedesPartners.Checked = False
            Me.RBZustaendigZustaendiger.Checked = True
            Me.mcbzust.SelectedValue = Me.serienbrief.iVerantwortlich.Value
        End If
        Me.mcbunterschriftlinks.SelectedValue = Me.serienbrief.iUnterschriftlinks.Value
        Me.mcbunterschriftrechts.SelectedValue = Me.serienbrief.iUnterschriftrechts.Value
        Me.DateTimePicker5.Value = Me.serienbrief.daArchivdatum.Value
        Try
            Me.C1DateEdit1.Value = Me.serienbrief.daTermin.Value
        Catch
        End Try
        Me.mcbteam.SelectedValue = Me.serienbrief.iTeam.Value
        Me.txtBemerkung.Text = Me.serienbrief.sBemerkung.Value

        Try
            Me.Height = Me.serienbrief.iWindowheight.Value
            Me.Width = Me.serienbrief.iWindowwidth.Value
            Me.Panel1.Width = Me.serienbrief.iTreewidth.Value
        Catch
        End Try
        SetProgress(60, "Vorlage laden", False)
        Me.empflist.DataSource = Nothing
        Me.empflist.DataMember = Nothing
        SetProgress(70, "Vorlage laden", False)
        Me.Load_empfaenger()
        Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
        Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName

        SetProgress(80, "Vorlage laden", False)
        Me.Load_Layout()
        Me.Funktionen_Freigeben(True)
        SetProgress(80, "Vorlage laden", False)
        If Me.serienbrief.iStatus.Value <> 0 Then
            Me.Funktionen_Freigeben(False)
        End If
        'Notizen
        Me.Notizen = load_notizen()
        Me.Notizlist.DataSource = Nothing
        Me.Notizlist.DataSource = Me.Notizen
        Me.Notizlist.DataMember = Me.Notizen.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "edex_sb_notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Load_empfaenger Method

Private Function Load_empfaenger() As Boolean

Source code

[Visual Basic]
    Private Function Load_empfaenger() As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger.xml"
            Me.dsempfaenger.Tables.Clear()
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_empfaenger where serienbriefnr=" + Str(Me.Serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                    Return False
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(2)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                    Me.dsempfaenger.ReadXml(dokumentname)
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
                Return False
            Finally
                File.Delete(dokumentname)
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Try
                If Me.dsempfaenger.Tables(2).TableName <> "Layout" Then
                    Dim tmpds As New DataSet()
                    Dim i As Integer
                    Dim s As String
                    tmpds.Tables.Add("empfdatatable")

                    For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
                        s = Me.dsempfaenger.Tables(0).Columns(i).ColumnName
                        Try
                            tmpds.Tables(0).Columns.Add(s)
                        Catch
                        End Try
                        If UCase(s) = "ERSTELLER" Then
                            tmpds.Tables(0).Columns.Add("DRUCKJOBID")
                        End If
                    Next
                    'tmpds.Tables.Add(Me.save_DSInit.Copy)
                    For i = 0 To Me.dsempfaenger.Tables.Count - 1
                        tmpds.Tables.Add(Me.dsempfaenger.Tables(i).Copy)
                    Next
                    Me.dsempfaenger.Tables.Clear()
                    For i = 0 To tmpds.Tables.Count - 1
                        Me.dsempfaenger.Tables.Add(tmpds.Tables(i).Copy)
                    Next
                    Try
                        Me.dsempfaenger.Tables(0).Rows(0).Delete()
                    Catch
                    End Try
                    tmpds.Dispose()
                End If
            Catch
            End Try
            Return True
        Catch EX As Exception
                MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                Return False
            End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MenuEmpfaenger_Popup Method

Private Sub MenuEmpfaenger_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuEmpfaenger.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuEmpfaenger_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuEmpfaenger.Popup
        If Me.dsempfaenger.Tables(0).Rows.Count = 0 Then
            Me.MnuEditEmpfaenger.Enabled = False
            Me.MnuDeleteEmpfaenger.Enabled = False
            Me.mnusaveasedokapartner.Enabled = False
        Else
            Me.MnuEditEmpfaenger.Enabled = True
            Me.MnuDeleteEmpfaenger.Enabled = True
            Me.mnusaveasedokapartner.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuDeleteEmpfaenger_Click Method

Private Sub MnuDeleteEmpfaenger_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteEmpfaenger.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteEmpfaenger_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteEmpfaenger.Click
        Try
            Dim i As Integer
            Dim c1row As Object
            Dim pstep As Double
            Dim pcount As Integer
            Dim pval As Double = 0
            Dim versandt As Boolean

            If Me.TVStatus.SelectedNode.Tag = 2 Or Me.TVStatus.SelectedNode.Tag = 3 Or Me.TVStatus.SelectedNode.Tag = 4 Then
                Dim msgres As MsgBoxResult
                msgres = MyMsg.Show_MessageYesNoCancel(735)
                If msgres = MsgBoxResult.Cancel Then Exit Sub
                If msgres = MsgBoxResult.Yes Then versandt = True
                If msgres = MsgBoxResult.No Then versandt = False
            Else
                versandt = False
            End If

            If Me.empflist.SelectedRows.Count > 0 Then
                Me.empflist.BeginInit()
                pcount = Me.empflist.SelectedRows.Count
                pstep = 100 / Me.empflist.SelectedRows.Count

                For i = Me.empflist.SelectedRows.Count - 1 To -1 Step -1
                    Me.empflist.Bookmark = Me.empflist.SelectedRows(i)
                    'Löschung
                    If Me.empflist.Columns("Dokumentid").Value <> "" Then
                        Check_Archiviert(Me.empflist.Columns("Dokumentid").Value, versandt)
                        Me.empflist.Delete()
                    Else
                        Me.empflist.Delete()
                    End If
                    pval = pval + pstep
                    pcount = pcount - 1
                    SetProgress(pval, "Empfänger löschen (" + pcount.ToString + ")", False)
                Next
                Me.empflist.SelectedRows.Clear()

                Dim s As String
                s = Me.empflist.Columns("Status").FilterText
                'Me.empflist.Columns("Status").FilterText = ""
                'SetProgress(pval, "Empfänger löschen (" + pcount.ToString + ")", False)

                ' Dim i As Integer

                'While Me.empflist.SelectedRows.Count > 0
                '    xd = Me.empflist.SelectedRows(Me.empflist.SelectedRows.Count - 1)
                '    MsgBox(xd.Item(0))
                '    delrow(Me.empflist.SelectedRows(Me.empflist.SelectedRows.Count - 1))
                '    pval = pval + pstep
                '    pcount = pcount - 1
                '    SetProgress(pval, "Empfänger löschen (" + pcount.ToString + ")", False)
                'End While
                Me.empflist.UpdateData()
                SetProgress(pval, "Empfänger löschen (0)", True)
                Me.empflist.Columns("Status").FilterText = s
                Me.empflist.EndInit()
            Else
                If Me.empflist.Columns("Dokumentid").Value <> "" Then
                    Check_Archiviert(Me.empflist.Columns("Dokumentid").Value, versandt)
                    Me.empflist.Delete()
                Else
                    Me.empflist.Delete()
                End If
                Me.empflist.UpdateData()
            End If
            Me.save_data()
            Me.Generate_Tree()
            Me.datachanged = False
        Catch
        Finally
            Me.dsempfaenger.AcceptChanges()
            Me.Generate_Tree()
            Me.Cursor = Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuDeleteNotiz_Click Method

Private Sub MnuDeleteNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDeleteNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDeleteNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDeleteNotiz.Click
        Me.serienbrief_notizen.cpMainConnectionProvider = Globals.conn
        Me.serienbrief_notizen.iNotiznr = New SqlInt32(CType(Me.Notizlist.Columns("notiznr").Value, Int32))
        Me.serienbrief_notizen.SelectOne()
        Me.serienbrief_notizen.bAktiv = New SqlBoolean(CType(False, Boolean))
        Me.serienbrief_notizen.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        Globals.conn.OpenConnection()
        Me.serienbrief_notizen.Update()
        Globals.conn.CloseConnection(True)
        Me.Notizen = Me.load_notizen()
        Me.Notizlist.DataSource = Me.Notizen
        Me.Notizlist.DataMember = Me.Notizen.TableName
        Dim i As Integer
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "edex_sb_notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuEditEmpfaenger_Click Method

Private Sub MnuEditEmpfaenger_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditEmpfaenger.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditEmpfaenger_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditEmpfaenger.Click
        Dim f As New frmsbpartnerdetail(False, Me.dsempfaenger.Tables(0), Me.empflist.Columns("partnernr").Text)
        f.txtAnrede.Text = Me.empflist.Columns("Anrede").Text
        f.txtname.Text = Me.empflist.Columns("Name").Text
        f.txtvorname.Text = Me.empflist.Columns("Vorname").Text
        f.txtstrasse.Text = Me.empflist.Columns("Strasse").Text
        f.txtnrpar00.Text = Me.empflist.Columns("Partnernr").Text
        f.txtanrede1.Text = Me.empflist.Columns("Briefanrede1").Text
        f.txtanrede2.Text = Me.empflist.Columns("Briefanrede2").Text
        f.txtplz.Text = Me.empflist.Columns("PLZ").Text
        f.txtort.Text = Me.empflist.Columns("Ort").Text
        f.txtzustelladresse.Text = Me.empflist.Columns("Zustelladresse").Text
        f.txtkurzbezeichnung.Text = Me.empflist.Columns("Kurzbezeichnung").Text

        Dim dt As New DataTable()

        dt = Me.get_idvwerte
        Dim i As Integer
        For i = 0 To dt.Rows.Count - 1
            dt.Rows(i).Item(1) = Me.empflist.Columns(dt.Rows(i).Item(0)).Text
        Next
        f.WertList.DataSource = dt
        f.WertList.DataMember = dt.TableName
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            For i = 0 To Me.empflist.Columns.Count - 1
                Me.empflist.Columns(i).Text = ""
            Next
            Me.empflist.Columns("Partnernr").Text = f.txtnrpar00.Text
            Me.empflist.Columns("Anrede").Text = f.txtAnrede.Text
            Me.empflist.Columns("Kurzbezeichnung").Text = f.txtkurzbezeichnung.Text
            Me.empflist.Columns("Name").Text = f.txtname.Text
            Me.empflist.Columns("Vorname").Text = f.txtvorname.Text
            Me.empflist.Columns("Strasse").Text = f.txtstrasse.Text
            Me.empflist.Columns("PLZ").Text = f.txtplz.Text
            Me.empflist.Columns("Ort").Text = f.txtort.Text
            Me.empflist.Columns("Zustelladresse").Text = f.txtzustelladresse.Text
            Me.empflist.Columns("BriefAnrede1").Text = f.txtanrede1.Text
            Me.empflist.Columns("BriefAnrede2").Text = f.txtanrede2.Text
            Me.empflist.Columns("Status").Text = "0"
            For i = 0 To dt.Rows.Count - 1
                Me.empflist.Columns(dt.Rows(i).Item(0)).text = dt.Rows(i).Item(1)
            Next
            Me.empflist.UpdateData()
        End If
        Me.empflist.AllowAddNew = False

        Me.Generate_Tree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuEditNotiz_Click Method

Private Sub MnuEditNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuEditNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuEditNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuEditNotiz.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("Mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("Mutiert_Am").Text

        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.serienbrief_notizen.cpMainConnectionProvider = Globals.conn
            Me.serienbrief_notizen.iNotiznr = New SqlInt32(CType(Me.Notizlist.Columns("notiznr").Value, Int32))
            Me.serienbrief_notizen.SelectOne()
            Me.serienbrief_notizen.sBetreff = New SqlString(CType(f.Betreff, String))
            Me.serienbrief_notizen.sNotiz = New SqlString(CType(f.Notiz, String))
            Me.serienbrief_notizen.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            Me.serienbrief_notizen.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Globals.conn.OpenConnection()
            Me.serienbrief_notizen.Update()
            Globals.conn.CloseConnection(True)
            Me.Notizen = Me.load_notizen()
            Me.Notizlist.DataSource = Me.Notizen
            Me.Notizlist.DataMember = Me.Notizen.TableName

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "edex_sb_notizen")
            Dim i As Integer
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainAbschluss_Click Method

Private Sub MnuMainAbschluss_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainAbschluss.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainAbschluss_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainAbschluss.Click
        If MyMsg.Show_MessageYesNo(712) = MsgBoxResult.Yes Then
            Try
                Me.Cursor = Cursors.WaitCursor
                MnuMainDokumenteBestaetigen_Click(sender, e)
                Me.save_data()
                serienbrief_abschliessen()
                Load_Serienbrief(Me.Serienbriefnr)
                Me.Funktionen_Freigeben(False)
                Me.Generate_Tree()
            Catch
            Finally
                Me.Cursor = Cursors.Default
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainAddColumn_Click Method

Private Sub MnuMainAddColumn_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainAddColumn.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainAddColumn_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainAddColumn.Click
        If Me.dsempfaenger.Tables(0).Rows.Count = 0 Then
            MyMsg.show_standardmessage(730, MsgBoxStyle.Information)
            Exit Sub
        End If
        Dim s As String
        s = InputBox("Bitte geben Sie den Namen der neuen Spalte ein.", "")
        If s <> "" Then
            s = Check_Columnname(s)
            If s = "#Error#" Then
                MyMsg.show_standardmessage(729, MsgBoxStyle.Critical)
                Exit Sub
            End If
            Dim i As Integer
            For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
                If Me.dsempfaenger.Tables(0).Columns(i).Caption = s Then
                    MyMsg.show_standardmessage(704, MsgBoxStyle.Critical)
                    Exit Sub
                End If
            Next
            Me.dsempfaenger.Tables(0).Columns.Add(s)
            '            Me.dsempfaenger.Tables(0).Columns(Me.dsempfaenger.Tables(0).Columns.Count - 1).DefaultValue = "0"
            Me.dsempfaenger.Tables(0).Rows(0).Item(Me.dsempfaenger.Tables(0).Columns.Count - 1) = ""

            Me.empflist.DataMember = Nothing
            Me.empflist.DataSource = Nothing
            Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
            Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Me.dsempfaenger.Tables(1).Columns.Add(s)
            Me.dsempfaenger.Tables(1).Rows(0).Item(s) = 0
            Me.Create_Layout()
            Me.Save_Layout()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainClose_Click Method

Private Sub MnuMainClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainClose_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainDeleteColumn_Click Method

Private Sub MnuMainDeleteColumn_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainDeleteColumn.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainDeleteColumn_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainDeleteColumn.Click
        mnuidwspalteentfernen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainDokument_Popup Method

Private Sub MnuMainDokument_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MnuMainDokument.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainDokument_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MnuMainDokument.Popup
        DivFnkt.Searchnode1(Me.TVStatus, 0, 99)
        If DivFnkt.found Then
            If DivFnkt.FoundNode.Text.Substring(DivFnkt.FoundNode.Text.Length - 3, 3) = "(0)" Then
                Me.c1mnumainpreview.Enabled = False
            Else
                Me.c1mnumainpreview.Enabled = True
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainDokumenteBestaetigen_Click Method

Private Sub MnuMainDokumenteBestaetigen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainDokumenteBestaetigen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainDokumenteBestaetigen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainDokumenteBestaetigen.Click
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()

        Dim i As Integer
        For i = 0 To Me.dsempfaenger.Tables(0).Rows.Count - 1
            Try
                If Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 2 Or Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 3 Then
                    Me.dsempfaenger.Tables(0).Rows(i).Item("Dokument_Gedruckt") = 1
                    Me.dsempfaenger.Tables(0).Rows(i).Item("STATUS") = 4
                End If
            Catch
            End Try
        Next
        Cursor = Cursors.Default
        Application.DoEvents()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainDokumenteDrucken_Click Method

Private Sub MnuMainDokumenteDrucken_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainDokumenteDrucken.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainDokumenteDrucken_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainDokumenteDrucken.Click
        If MyMsg.Show_MessageYesNo(719) <> MsgBoxResult.Yes Then
            Exit Sub
        End If
        Me.save_data()
        Dim f As New frmsbdruck(Me.Serienbriefnr)
        f.ShowDialog()
        If f.datasaved = True Then
            Me.Load_Serienbrief(Me.Serienbriefnr)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainEDOKAPartnerErfassen_Click Method

Private Sub MnuMainEDOKAPartnerErfassen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEDOKAPartnerErfassen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEDOKAPartnerErfassen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEDOKAPartnerErfassen.Click
        Me.mnusaveasedokapartner_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainEmfpaengerLoeschen_Click Method

Private Sub MnuMainEmfpaengerLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEmfpaengerLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEmfpaengerLoeschen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEmfpaengerLoeschen.Click
        MnuDeleteEmpfaenger_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainEmpfaengerBearbeiten_Click Method

Private Sub MnuMainEmpfaengerBearbeiten_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEmpfaengerBearbeiten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEmpfaengerBearbeiten_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEmpfaengerBearbeiten.Click
        Dim f As New frmsbpartnerdetail(False, Me.dsempfaenger.Tables(0), Me.empflist.Columns("partnernr").Text)
        f.txtAnrede.Text = Me.empflist.Columns("Anrede").Text
        f.txtname.Text = Me.empflist.Columns("Name").Text
        f.txtvorname.Text = Me.empflist.Columns("Vorname").Text
        f.txtstrasse.Text = Me.empflist.Columns("Strasse").Text
        f.txtnrpar00.Text = Me.empflist.Columns("Partnernr").Text
        f.txtanrede1.Text = Me.empflist.Columns("Briefanrede1").Text
        f.txtanrede2.Text = Me.empflist.Columns("Briefanrede2").Text
        f.txtplz.Text = Me.empflist.Columns("plz").Text
        f.txtort.Text = Me.empflist.Columns("Ort").Text
        f.txtzustelladresse.Text = Me.empflist.Columns("Zustelladresse").Text
        f.txtkurzbezeichnung.Text = Me.empflist.Columns("Kurzbezeichnung").Text
        Dim dt As New DataTable()

        dt = Me.get_idvwerte
        Dim i As Integer
        For i = 0 To dt.Rows.Count - 1
            dt.Rows(i).Item(1) = Me.empflist.Columns(dt.Rows(i).Item(0)).Text
        Next
        f.WertList.DataSource = dt
        f.WertList.DataMember = dt.TableName
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            For i = 0 To Me.empflist.Columns.Count - 1
                Me.empflist.Columns(i).Text = ""
            Next
            Me.empflist.Columns("Partnernr").Text = f.txtnrpar00.Text
            Me.empflist.Columns("Anrede").Text = f.txtAnrede.Text
            Me.empflist.Columns("Kurzbezeichnung").Text = f.txtkurzbezeichnung.Text
            Me.empflist.Columns("Name").Text = f.txtname.Text
            Me.empflist.Columns("Vorname").Text = f.txtvorname.Text
            Me.empflist.Columns("Strasse").Text = f.txtstrasse.Text
            Me.empflist.Columns("PLZ").Text = f.txtplz.Text
            Me.empflist.Columns("Ort").Text = f.txtort.Text
            Me.empflist.Columns("Zustelladresse").Text = f.txtzustelladresse.Text
            Me.empflist.Columns("BriefAnrede1").Text = f.txtanrede1.Text
            Me.empflist.Columns("BriefAnrede2").Text = f.txtanrede2.Text
            Me.empflist.Columns("Status").Text = 0
            For i = 0 To dt.Rows.Count - 1
                Me.empflist.Columns(dt.Rows(i).Item(0)).text = dt.Rows(i).Item(1)
            Next
            Me.empflist.UpdateData()
        End If

        For i = 0 To dt.Rows.Count - 1
            Me.empflist.Columns(dt.Rows(i).Item(0)).text = dt.Rows(i).Item(1)
        Next
        Me.empflist.UpdateData()
        Me.empflist.AllowAddNew = False
        Me.Generate_Tree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainEmpfaengerliste_Click Method

Private Sub MnuMainEmpfaengerliste_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainEmpfaengerliste.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainEmpfaengerliste_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainEmpfaengerliste.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainExportEmpfaenger_Click Method

Private Sub MnuMainExportEmpfaenger_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainExportEmpfaenger.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainExportEmpfaenger_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainExportEmpfaenger.Click
        Me.Export_Empfaenger()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainImportEmpfaenger_Click Method

Private Sub MnuMainImportEmpfaenger_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainImportEmpfaenger.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainImportEmpfaenger_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainImportEmpfaenger.Click
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        If Not Me.Import_Empfaenger Then
            Me.Cursor = Cursors.Default
            Exit Sub
        End If
        SetProgress(80, "Vorlagenfelder abgleichen", False)
        Dim f1 As New frmtextmarken(Me.Serienbriefnr, False, Me.dsempfaenger, doktyp.iDokumenttypnr.Value)
        Dim dtusedfelder As New DataTable()
        dtusedfelder = f1.init_used_felder()
        dtusedfelder.TableName = "UsedFelder"
        Me.dsempfaenger.Tables.Add(dtusedfelder.Copy)
        dtusedfelder.Dispose()
        f1.Dispose()
        If Me.doktyp.bSbedituser.Value = False Then
            SetProgress(90, "Vorlagenfelder abgleichen", False)

            Me.dsempfaenger.Tables.Add("VerkFelder")
            Dim d1 As New DataColumn()
            Dim d2 As New DataColumn()
            Dim d3 As New DataColumn()
            d1.Caption = "IDVWert"
            d1.ColumnName = "IDVWert"
            d1.DefaultValue = ""
            d2.Caption = "Standardwert"
            d2.ColumnName = "Standardwert"
            d2.DefaultValue = ""
            d3.Caption = "Vorlagenfeldnr"
            d3.ColumnName = "Vorlagenfeldnr"
            d3.DefaultValue = ""
            With Me.dsempfaenger.Tables("Verkfelder").Columns
                .Add(d1)
                .Add(d2)
                .Add(d3)
            End With
            Dim dv As DataRow
            For Each dv In Me.dsempfaenger.Tables(0).Rows
                dv.Item("Dokumentid") = ""
                dv.Item("Dokumentidbdr") = ""
            Next
        End If
        SetProgress(100, "Datenimport beendet", False)

        SetProgress(100, "Datenimport beendet", True)
        Me.Cursor = Cursors.Default
        Application.DoEvents()
        Me.Load_Layout()
        Me.mnuc2partnerlistepruefen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainLoadPartnerliste_Click Method

Private Sub MnuMainLoadPartnerliste_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainLoadPartnerliste.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainLoadPartnerliste_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainLoadPartnerliste.Click
        Dim f As New frmPartnerlisteLaden()
        Dim tmpds As New DataSet()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim savedt As New DataTable()
            Dim savedt1 As New DataTable()
            savedt = Me.dsempfaenger.Tables(0).Copy
            Me.dsempfaenger.Tables.Clear()
            Dim s As String
            s = f.Load_Partnerlist
            If s <> "" Then
                Me.dsempfaenger.ReadXml(s)
            End If
            If Check_Importtable(Me.dsempfaenger.Tables(0)) = True Then
                create_supporttable()
            End If
            If savedt.Rows.Count > 0 Then
                'If Me.NeuerSB = True Then
                '    Me.NeuerSB = False
                'Else
                savedt1 = Me.dsempfaenger.Tables(0).Copy
                Me.dsempfaenger.Tables.Clear()
                Me.dsempfaenger.Tables.Add(savedt.Copy)
                savedt.Dispose()
                Dim r1 As Integer
                Dim c1 As Integer
                Dim dr As DataRow
                Dim inserted As Boolean
                For r1 = 0 To savedt1.Rows.Count - 1
                    dr = Me.dsempfaenger.Tables(0).NewRow
                    inserted = False
                    Try
                        For c1 = 0 To savedt1.Columns.Count - 1
                            dr.Item(savedt1.Columns(c1).ColumnName) = savedt1.Rows(r1).Item(c1)
                            inserted = True
                        Next

                    Catch
                    End Try
                    Try
                        If inserted Then Me.dsempfaenger.Tables(0).Rows.Add(dr)
                    Catch
                    End Try
                Next
                ' End If
            End If
            Me.empflist.DataMember = Nothing
            Me.empflist.DataSource = Nothing
            Try
                Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
                Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Catch
            End Try
            SetProgress(40, "Layout erstellen", False)
            Create_Layout()
            SetProgress(60, "Felder prüfen", False)
            check_vorlagenfelder()
            Dim i As Integer
            Dim i1 As Integer
            For i = 0 To Me.dsempfaenger.Tables(0).Rows.Count - 1
                For i1 = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
                    If Me.dsempfaenger.Tables(0).Rows(i).Item(i1) Is System.DBNull.Value Then
                        Me.dsempfaenger.Tables(0).Rows(i).Item(i1) = ""
                    End If
                Next
            Next
            'Me.NeuerSB = False

            Dim f1 As New frmtextmarken(Me.Serienbriefnr, False, Me.dsempfaenger, doktyp.iDokumenttypnr.Value)
            Dim dtusedfelder As New DataTable()
            dtusedfelder = f1.init_used_felder()
            dtusedfelder.TableName = "UsedFelder"
            Me.dsempfaenger.Tables.Add(dtusedfelder.Copy)
            dtusedfelder.Dispose()
            f1.Dispose()
            If Me.doktyp.bSbedituser.Value = False Then
                SetProgress(90, "Vorlagenfelder abgleichen", False)

                Me.dsempfaenger.Tables.Add("VerkFelder")
                Dim d1 As New DataColumn()
                Dim d2 As New DataColumn()
                Dim d3 As New DataColumn()
                d1.Caption = "IDVWert"
                d1.ColumnName = "IDVWert"
                d1.DefaultValue = ""
                d2.Caption = "Standardwert"
                d2.ColumnName = "Standardwert"
                d2.DefaultValue = ""
                d3.Caption = "Vorlagenfeldnr"
                d3.ColumnName = "Vorlagenfeldnr"
                d3.DefaultValue = ""
                With Me.dsempfaenger.Tables("Verkfelder").Columns
                    .Add(d1)
                    .Add(d2)
                    .Add(d3)
                End With
                Dim dv As DataRow
                For Each dv In Me.dsempfaenger.Tables(0).Rows
                    dv.Item("Dokumentid") = ""
                    dv.Item("Dokumentidbdr") = ""
                Next
            End If
            SetProgress(100, "Datenimport beendet", False)

            SetProgress(100, "Datenimport beendet", True)
            Me.Cursor = Cursors.Default
            Application.DoEvents()

            Me.empflist.MultiSelect = c1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
            Me.Generate_Tree()
        End If
        f.Dispose()
        Me.mnuc2partnerlistepruefen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainLoad_Click Method

Private Sub MnuMainLoad_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainLoad.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainLoad_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainLoad.Click
        On_Load = True
        Dim f As New frmSerienbriefe_Load()
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.Serienbriefnr = f.Serienbriefnr
            Load_Serienbrief(Me.Serienbriefnr)
            'Tree Aufbauen
            Me.TVStatus.Nodes.Clear()
            Me.Generate_Tree()
            datachanged = False
            Me.dsempfaenger.AcceptChanges()
        End If
        On_Load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainNew_Click Method

Private Sub MnuMainNew_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainNew.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainNew_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainNew.Click
        On_Load = True
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()
        Dim f As New frmVorlagenauswahl_Serienbriefe()
        f.Show_Favoriten = False
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            'NeuerSB = True
            Me.Cursor = Cursors.WaitCursor
            Application.DoEvents()
            SetProgress(10, "Vorlage laden", False)
            Me.doktyp.cpMainConnectionProvider = Globals.conn
            Me.doktyp.iDokumenttypnr = New SqlInt32(CType(f.Dokumentvorlage, Int32))
            Me.doktyp.SelectOne()
            Me.txtBezeichnung.Text = doktyp.sBezeichnung.Value
            Me.txtBezeichnung.Enabled = True
            Me.Dokumenttypnr = doktyp.iDokumenttypnr.Value
            SetProgress(20, "Vorlage laden", False)
            init_empfaenger()
            SetProgress(30, "Vorlage laden", False)
            check_vorlagenfelder()
            SetProgress(30, "Vorlage laden", False)
            On_Fill = True
            Me.FillMcbVerantwortlich()
            On_Fill = False
            If Me.mcbverantwortlich.Items.Count = 0 Then
                MyMsg.show_standardmessage(723, MsgBoxStyle.Critical)
                Funktionen_Freigeben(False)
                Me.SetProgress(0, "", True)
                Exit Sub
            End If
            Funktionen_Freigeben(True)
            SetProgress(40, "Vorlage laden", False)
            Me.ShowSaveMessage = False
            Me.MnuMainSave_Click(sender, Nothing)
            Me.ShowSaveMessage = True
            Vorlage_Speichern("")
            SetProgress(50, "Vorlage laden", False)
            Application.DoEvents()
            Dim f1 As New frmtextmarken(Me.Serienbriefnr, False, Me.dsempfaenger, doktyp.iDokumenttypnr.Value)
            Dim dtusedfelder As New DataTable()
            SetProgress(60, "Vorlage laden", False)
            dtusedfelder = f1.init_used_felder()
            dtusedfelder.TableName = "UsedFelder"
            Me.dsempfaenger.Tables.Add(dtusedfelder.Copy)
            SetProgress(70, "Vorlage laden", False)
            dtusedfelder.Dispose()
            f1.Dispose()
            If Me.doktyp.bSbedituser.Value = False Then
                Me.dsempfaenger.Tables.Add("VerkFelder")
                Dim d1 As New DataColumn()
                Dim d2 As New DataColumn()
                Dim d3 As New DataColumn()
                d1.Caption = "IDVWert"
                d1.ColumnName = "IDVWert"
                d1.DefaultValue = ""
                d2.Caption = "Standardwert"
                d2.ColumnName = "Standardwert"
                d2.DefaultValue = ""
                d3.Caption = "Vorlagenfeldnr"
                d3.ColumnName = "Vorlagenfeldnr"
                d3.DefaultValue = ""
                With Me.dsempfaenger.Tables("Verkfelder").Columns
                    .Add(d1)
                    .Add(d2)
                    .Add(d3)
                End With
            End If
            SetProgress(80, "Vorlage laden", False)
            Me.Cursor = Cursors.Default
            Application.DoEvents()
            Me.TVStatus.Nodes.Clear()
            Me.empflist.Delete()
            Me.empflist.UpdateData()
            Me.dsempfaenger.AcceptChanges()
            Me.save_data()
            Me.Generate_Tree()

        End If
        SetProgress(100, "Vorlage laden", True)
        System.Threading.Thread.CurrentThread.Sleep(500)
        SetProgress(100, "Vorlage laden", True)
        On_Load = False
        datachanged = False
        Me.dsempfaenger.AcceptChanges()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainRenameColumn_Click Method

Private Sub MnuMainRenameColumn_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainRenameColumn.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainRenameColumn_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainRenameColumn.Click
        mnuidvspalteumbenennen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainSaveAsPartnerlist_Click Method

Private Sub MnuMainSaveAsPartnerlist_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainSaveAsPartnerlist.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainSaveAsPartnerlist_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainSaveAsPartnerlist.Click
        Dim f As New frmPartnerlisteSpeichern(Me.dsempfaenger.Tables(0))
        f.ShowDialog()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainSave_Click Method

Private Sub MnuMainSave_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainSave.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainSave_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainSave.Click
        Me.save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainSerienbriefLoeschen_Click Method

Private Sub MnuMainSerienbriefLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainSerienbriefLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainSerienbriefLoeschen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainSerienbriefLoeschen.Click
        If MyMsg.Show_MessageYesNo(711) = MsgBoxResult.Yes Then
            If Me.Serienbriefnr <> 0 Then
                delete_serienbrief()
            End If
            Me.TVStatus.Nodes.Clear()
            Me.txtBezeichnung.Text = ""
            Me.init_empfaenger()
            Me.Funktionen_Freigeben(False)
            Me.dsempfaenger.AcceptChanges()
            Me.datachanged = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainSpaltenselektion_Click Method

Private Sub MnuMainSpaltenselektion_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainSpaltenselektion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainSpaltenselektion_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainSpaltenselektion.Click
        MnuSpaltenSelektion_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainVorageBearbeiten_Click Method

Private Sub MnuMainVorageBearbeiten_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainVorageBearbeiten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainVorageBearbeiten_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainVorageBearbeiten.Click
        Me.Cursor = Cursors.WaitCursor
        Application.DoEvents()

        Dim bearbeitung As Boolean = False
        If Globals.MitarbeiterNr = doktyp.iOwner.Value Then
            bearbeitung = True
        Else
            bearbeitung = Me.doktyp.bSbedituser.Value
        End If
        If bearbeitung = False Then
            MyMsg.show_standardmessage(724, MsgBoxStyle.Information)
        End If
        Dim f As New frmtextmarken(Me.Serienbriefnr, bearbeitung, Me.dsempfaenger, Dokumenttypnr)
        Me.Cursor = Cursors.Default
        Application.DoEvents()
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuMainVorlageImportieren_Click Method

Private Sub MnuMainVorlageImportieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles MnuMainVorlageImportieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMainVorlageImportieren_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles MnuMainVorlageImportieren.Click

        Me.OpenFileDialog1.Filter = "Word-Dateien (*.doc)|*.doc|Alle Dateien (*.*)|*.*"
        Me.OpenFileDialog1.ShowDialog()
        Dim dt As New DataTable()
        If Me.OpenFileDialog1.FileName <> "" Then
            Me.Vorlage_Speichern(Me.OpenFileDialog1.FileName)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuNeueNotiz_Click Method

Private Sub MnuNeueNotiz_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeueNotiz.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeueNotiz_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeueNotiz.Click
        Dim i As Integer
        Dim f As New frmNotizen()
        f.Mutierer = Globals.MitarbeiterNr.ToString
        f.Notiz = ""
        f.Betreff = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.serienbrief_notizen.cpMainConnectionProvider = Globals.conn
            Me.serienbrief_notizen.iSerienbriefnr = New SqlInt32(CType(Me.Serienbriefnr, Int32))
            Me.serienbrief_notizen.sBetreff = New SqlString(CType(f.Betreff, String))
            Me.serienbrief_notizen.sNotiz = New SqlString(CType(f.Notiz, String))
            Me.serienbrief_notizen.bAktiv = New SqlBoolean(CType(True, Boolean))
            Me.serienbrief_notizen.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            Me.serienbrief_notizen.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            Me.serienbrief_notizen.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            Me.serienbrief_notizen.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            Globals.conn.OpenConnection()
            Me.serienbrief_notizen.Insert()
            Globals.conn.CloseConnection(True)
            Me.load_notizen()
            Me.Notizlist.DataSource = Me.Notizen
            Me.Notizlist.DataMember = Me.Notizen.TableName

            DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Me.Notizen, "edex_sb_notizen")
            Try
                For i = 0 To Me.Notizlist.Splits(0).Rows.Count - 1
                    If Me.Notizlist.Columns("betreff").CellText(i) = f.Betreff Then
                        Me.Notizlist.Bookmark = i
                    End If
                Next
            Catch
            End Try
        End If
        f.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.MnuSpaltenSelektion_Click Method

Private Sub MnuSpaltenSelektion_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuSpaltenSelektion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuSpaltenSelektion_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuSpaltenSelektion.Click
        Dim F As New frmSBSpaltenDarstellung()
        Dim i As Integer
        F.ListBox1.Items.Clear()
        F.ListBox2.Items.Clear()
        Try
            For i = 0 To Me.empflist.Columns.Count - 1
                If Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "AKTIV" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "BLKUNDE" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "DOKUMENT_GEDRUCKT" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "DOKUMENTID" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "DOKUMENTIDBDR" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "ERSTELLER" Or _
                Me.empflist.Splits(0).DisplayColumns(i).Name.ToString = "FEHLERCODE" Then

                Else
                    Try
                        If Me.empflist.Splits(0).DisplayColumns(i).Visible = False Then
                            If Me.empflist.Splits(0).DisplayColumns(i).Name().ToString <> "" Then
                                F.ListBox1.Items.Add(Me.empflist.Splits(0).DisplayColumns(i).Name())
                            End If
                        End If
                    Catch
                    End Try
                    Try
                        If Me.empflist.Splits(0).DisplayColumns(i).Visible = True Then F.ListBox2.Items.Add(Me.empflist.Splits(0).DisplayColumns(i).Name())
                    Catch
                    End Try

                End If

            Next
        Catch ex As Exception

        End Try
        F.ShowDialog()
        For i = 0 To F.ListBox1.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.empflist.Columns.Count - 1
                    If Me.empflist.Splits(0).DisplayColumns(xx).Name = F.ListBox1.Items(i) Then
                        Me.empflist.Splits(0).DisplayColumns(xx).Visible = False
                    End If
                Next
            Catch
            End Try
        Next
        For i = 0 To F.ListBox2.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.empflist.Columns.Count - 1
                    If Me.empflist.Splits(0).DisplayColumns(xx).Name = F.ListBox2.Items(i) Then
                        Me.empflist.Splits(0).DisplayColumns(xx).Visible = True
                    End If
                Next
            Catch
            End Try
        Next
        F.Dispose()
        Me.Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Notizlist_DoubleClick Method

Private Sub Notizlist_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            MnuEditNotiz_Click(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Partner_Details Method

Private Function Partner_Details( _
   ByVal partnernr As Integer _
)

Parameters

partnernr
Required.

Source code

[Visual Basic]
    Private Function Partner_Details(ByVal partnernr As Integer)
        Dim p As New edokadb.clsPartner()
        p.cpMainConnectionProvider = conn
        p.iNRPAR00 = New SqlInt32(CType(partnernr, Int32))
        p.SelectOne()
        Me.CurrentPartnernr = partnernr
        Me.CurrentPartnerbezeichnung = p.sBKPAR00.Value
        p.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.RBZustaendigKubedesPartners_CheckedChanged Method

Private Sub RBZustaendigKubedesPartners_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles RBZustaendigKubedesPartners.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBZustaendigKubedesPartners_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles RBZustaendigKubedesPartners.CheckedChanged
        If Me.RBZustaendigKubedesPartners.Checked Then
            Me.mcbzust.Enabled = False
        Else
            Me.mcbzust.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Save_Layout Method

Private Sub Save_Layout()

Source code

[Visual Basic]
    Private Sub Save_Layout()
        Dim filename As String = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger.lyt"
        Me.empflist.SaveLayout(filename)
        If Me.dsempfaenger.Tables.Count < 3 Then
            Me.dsempfaenger.Tables.Add("Layout")
            Me.dsempfaenger.Tables("Layout").Columns.Add("LayoutData")
            Dim myRow As DataRow
            myRow = Me.dsempfaenger.Tables("Layout").NewRow
            myRow.Item(0) = ""
            Me.dsempfaenger.Tables("Layout").Rows.Add(myRow)
        End If

        Dim FiStr As FileStream = _
            New FileStream(filename, FileMode.Open)
        Dim StrRe As StreamReader = New StreamReader(FiStr)
        Dim i As Integer
        Dim s As String
        s = StrRe.ReadToEnd
        StrRe.Close()
        Me.dsempfaenger.Tables("Layout").Rows(0).Item(0) = s
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.SetProgress Method

Private Sub SetProgress( _
   ByVal wert As Integer, _
   ByVal txt As String, _
   ByVal hidedialog As Boolean _
)

Parameters

wert
Required.
txt
Required.
hidedialog
Required.

Source code

[Visual Basic]
    Private Sub SetProgress(ByVal wert As Integer, ByVal txt As String, ByVal hidedialog As Boolean)
        'Me.progress.Width = Me.Panel1.Width
        If hidedialog Then
            progress.Hide()
            progressvisible = False
            Exit Sub
        End If
        If Me.progressvisible = False Then
            Try
                progress.Show()
            Catch
            End Try
            progress.Visible = True
        End If
        If wert + 1 > 100 Then wert = 99
        progress.Bar1.Value = wert + 1
        progress.info.Text = txt
        progress.Refresh()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.TVStatus_AfterSelect Method

Private Sub TVStatus_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TVStatus.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStatus_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TVStatus.AfterSelect
        Me.empflist.BeginInit()
        Me.empflist.SelectedRows.Clear()
        Try
            If Microsoft.VisualBasic.InStr(Me.TVStatus.SelectedNode.Tag, "Job:") > 0 Then
                Dim s As String
                s = Me.TVStatus.SelectedNode.Tag
                s = s.Substring(4)
                Dim i As Integer
                For i = 0 To Me.empflist.Columns.Count - 1
                    Me.empflist.Columns(i).FilterText = ""
                Next
                Me.empflist.Columns("Druckjobid").FilterText = Me.get_druckjobname(s)
                Me.empflist.EndInit()

                Exit Sub
            End If
        Catch
        End Try
        Try
            If Me.TVStatus.SelectedNode.Tag = -3 Then
                Dim dview As New DataView(Me.dsempfaenger.Tables(0), "", "", DataViewRowState.CurrentRows)
                Me.empflist.DataSource = Nothing
                Me.empflist.DataMember = Nothing
                Me.empflist.DataSource = dview
                Me.empflist.DataMember = dview.Table.TableName
                If Me.serienbrief.iStatus.Value = -1 Or Me.serienbrief.iStatus.Value > 1 Then
                    Me.empflist.AllowUpdate = False
                End If
                Me.Load_Layout()
                Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
                Me.empflist.EndInit()
                Exit Sub
            End If
            If Me.TVStatus.SelectedNode.Tag = -4 Then
                If Me.serienbrief.iStatus.Value <> -2 Then
                    Dim dview As New DataView(Me.dsempfaenger.Tables(0), "Status = '5'", "", DataViewRowState.CurrentRows)
                    Me.empflist.DataSource = Nothing
                    Me.empflist.DataMember = Nothing
                    Me.empflist.DataSource = dview
                    Me.empflist.DataMember = dview.Table.TableName
                    If Me.serienbrief.iStatus.Value = -1 Or Me.serienbrief.iStatus.Value > 1 Then
                        Me.empflist.AllowUpdate = False
                    End If
                    Me.Load_Layout()
                    Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
                    Me.empflist.EndInit()
                    Exit Sub
                Else
                    Dim dview As New DataView(Me.dsempfaenger.Tables(0), "Status < '5'", "", DataViewRowState.CurrentRows)
                    Me.empflist.DataSource = Nothing
                    Me.empflist.DataMember = Nothing
                    Me.empflist.DataSource = dview
                    Me.empflist.DataMember = dview.Table.TableName
                    If Me.serienbrief.iStatus.Value = -1 Or Me.serienbrief.iStatus.Value > 1 Then
                        Me.empflist.AllowUpdate = False
                    End If
                    Me.Load_Layout()
                    Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
                    Me.empflist.EndInit()
                    Exit Sub

                End If
            End If

            If Me.TVStatus.SelectedNode.Tag = -9 Then
                Dim dview As New DataView(Me.dsempfaenger.Tables(0), "Status < '3'", "", DataViewRowState.CurrentRows)
                Me.empflist.DataSource = Nothing
                Me.empflist.DataMember = Nothing
                Me.empflist.DataSource = dview
                Me.empflist.DataMember = dview.Table.TableName
                If Me.serienbrief.iStatus.Value = -1 Or Me.serienbrief.iStatus.Value > 1 Then
                    Me.empflist.AllowUpdate = False

                End If
                Me.Load_Layout()
                Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
                Me.empflist.EndInit()
                Exit Sub
            End If

            Me.empflist.DataSource = Nothing
            Me.empflist.DataMember = Nothing

            Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
            Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Me.Load_Layout()
            Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended

            If Me.TVStatus.SelectedNode.Tag = -1 Or Me.TVStatus.SelectedNode.Tag = 0 Then
                Me.empflist.AllowUpdate = True
            Else
                Me.empflist.AllowUpdate = False
            End If
            Me.empflist.Columns("status").FilterText = Me.TVStatus.SelectedNode.Tag

        Catch ex As Exception
        Finally
            Me.empflist.EndInit()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.TVStatus__MouseDown Method

Private Sub TVStatus__MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVStatus.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStatus__MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVStatus.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            TVStatus.SelectedNode = TVStatus.GetNodeAt(selectPoint)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Cursor = Cursors.WaitCursor
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.MnuMainClose_Click(sender, Nothing)
            Case 1
                Me.MnuMainNew_Click(sender, Nothing)
            Case 2
                Me.MnuMainLoad_Click(sender, Nothing)
            Case 3
                Me.MnuMainSerienbriefLoeschen_Click(sender, Nothing)
            Case 4
                Me.MnuMainSave_Click(sender, Nothing)
            Case 5
                Me.MnuMainAbschluss_Click(sender, Nothing)
            Case 8
                Me.MnuMainVorageBearbeiten_Click(sender, Nothing)
            Case 9
            Case 10
                '                MnuMainDokumenteGenerieren_Click(sender, Nothing)
            Case 11
                MnuMainDokumenteDrucken_Click(sender, Nothing)
            Case 12
                MnuMainDokumenteBestaetigen_Click(sender, Nothing)

            Case 15
            Case 16
            Case 18
            Case 19
                Me.Generate_Tree()

                '                MnuMainCheckEmpfaenger_Click(sender, Nothing)
        End Select
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Vorlage_Auslesen Method

Private Function Vorlage_Auslesen( _
   ByVal serienbriefnr As Integer _
) As Boolean

Parameters

serienbriefnr
Required.

Source code

[Visual Basic]
    Private Function Vorlage_Auslesen(ByVal serienbriefnr As Integer) As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + serienbriefnr.ToString + "_vorlage.doc"
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_vorlage where serienbriefnr=" + Str(serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(713, MsgBoxStyle.Critical)
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(1)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                End If
            Catch ex As Exception
                Return False
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            Return False
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Vorlage_Speichern Method

Private Sub Vorlage_Speichern( _
   ByVal filename As String _
)

Parameters

filename
Required.

Source code

[Visual Basic]
    Private Sub Vorlage_Speichern(ByVal filename As String)
        'Dokumentvorlage aus Office-Vorlage-Datei auslesen, sofern Filename = ""
        Dim Dokumentname As String = ""
        If filename = "" Then
            Dim x As New FrmDomainOfficeVorlageDatei()
            Dokumentname = x.Get_From_DB(Me.doktyp.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
            x.Dispose()
        Else
            Dokumentname = filename
        End If

        Try
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_vorlage where serienbriefnr=" + Str(Me.Serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(Dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "vorlage")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    'Neue Serienbrief_Empfaenger speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Me.Serienbriefnr
                    myRow.Item(1) = mydata
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "vorlage")
                Else
                    ' Bestehende Empfängerliste überschreiben
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(1) = mydata
                    DA.Update(ds, "vorlage")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(702, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
        Catch ex As Exception
        Finally
            If filename = "" Then File.Delete(Dokumentname)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.Vorschau_Erstellen Method

Private Sub Vorschau_Erstellen()

Source code

[Visual Basic]
    Private Sub Vorschau_Erstellen()
        SetProgress(10, "Verarbeitung initialisieren", False)
        Dim saveempfaenger As New DataSet()
        Dim TMPDT As New DataTable()
        Dim i, i1 As Integer

        saveempfaenger = Me.dsempfaenger.Copy

        Dim dt As New DataTable()
        dt = Me.dsempfaenger.Tables(0).Copy
        dt.Rows.Clear()
        Dim rowval As DataRow
        If Me.empflist.SelectedRows.Count > 0 Then
            For i = 0 To Me.empflist.SelectedRows.Count - 1
                rowval = dt.NewRow
                For i1 = 0 To Me.empflist.Columns.Count - 1
                    Me.empflist.Row = Me.empflist.SelectedRows(i)

                    rowval(i1) = Me.empflist.Columns(i1).Value
                Next
                dt.Rows.Add(rowval)
            Next
        Else
            rowval = dt.NewRow
            For i1 = 0 To Me.empflist.Columns.Count - 1
                Try
                    rowval(i1) = Me.empflist.Columns(i1).Value
                Catch
                End Try
            Next
            dt.Rows.Add(rowval)
        End If
        Dim cm As CurrencyManager
        Me.dsempfaenger.Tables(0).Rows.Clear()
        For i = 0 To dt.Rows.Count - 1
            Try
                Me.dsempfaenger.Tables(0).ImportRow(dt.Rows(i))
            Catch ex As Exception
                Dim a As Integer = 1

            End Try
        Next
        clsempf = New clsEmpfaengerdata(Me.dsempfaenger, Me.Serienbriefnr)
        '        Dim clsempf As New clsEmpfaengerdata(Me.dsempfaenger, Me.Serienbriefnr)

        SetProgress(10, "Daten zusammenstellen", False)
        vorlagendaten = clsempf.Vorlagendaten_aufbreiten()
        SetProgress(20, "Vorlage auslesen", False)
        Me.Vorlage_Auslesen(Me.Serienbriefnr)
        SetProgress(30, "Dokumente generieren", False)
        Me.Dokumente_Generieren()
        SetProgress(100, "Vorschau erstellt", True)
        Me.objword.Visible = True
        If objword.Documents.Count < 1 Then
            objword.Quit(SAVECHANGES:=False)
        End If
        Me.objword = Nothing
        Me.dsempfaenger = saveempfaenger.Copy
        Me.empflist.DataSource = Nothing
        Me.empflist.DataMember = Nothing
        Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
        Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
        Me.empflist.Refresh()
        Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
        Me.Load_Layout()
        SetProgress(100, "Vorschau erstellt", True)
        clsempf = Nothing

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.add_edokahostpartner Method

Private Sub add_edokahostpartner( _
   ByVal vibeachten As Boolean _
)

Parameters

vibeachten
Required.

Source code

[Visual Basic]
    Private Sub add_edokahostpartner(ByVal vibeachten As Boolean)
        Me.empflist.AllowAddNew() = True
        Me.empflist.MoveLast()
        Me.empflist.Row = Me.empflist.Row + 1
        Me.empflist.Select()
        Dim i As Integer
        For i = 0 To Me.empflist.Columns.Count - 1
            Me.empflist.Columns(i).Text = ""
        Next
        Me.empflist.Columns("partnernr").Text = Me.CurrentPartnernr
        Me.empflist.Columns("Kurzbezeichnung").Text = Me.CurrentPartnerbezeichnung
        Me.empflist.Columns("Status").Text = 0
        If vibeachten = True Then Me.empflist.Columns("fehlercode").Value = 9
        Me.empflist.UpdateData()
        'If NeuerSB Then
        '    NeuerSB = False
        '    'Me.dsempfaenger.Tables(0).Rows(0).Delete()
        'End If
        Me.dsempfaenger.AcceptChanges()
        Me.empflist.AllowAddNew = False
        Me.datachanged = True
        Me.Generate_Tree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.c1mnumainpreview_Click Method

Private Sub c1mnumainpreview_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1mnumainpreview.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1mnumainpreview_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1mnumainpreview.Click
        Do While GenerierteDokumente.Count > 0
            GenerierteDokumente.Remove(1)
        Loop

        Me.empflist.BeginInit()
        Try
            Me.Vorschau_Erstellen()
            If Me.GenerierteDokumente.Count > 0 Then
                Dim f As New frmOfficePreview(GenerierteDokumente)
                f.Show()
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            Me.empflist.EndInit()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.c1mnupartner1_Click Method

Private Sub c1mnupartner1_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1mnupartner1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1mnupartner1_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1mnupartner1.Click
        Me.mnuaddhost_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.c1mnupartner2_Click Method

Private Sub c1mnupartner2_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1mnupartner2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1mnupartner2_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1mnupartner2.Click
        Me.mnunewedoka_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.c1mnupartner3_Click Method

Private Sub c1mnupartner3_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1mnupartner3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1mnupartner3_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1mnupartner3.Click
        Me.mnunewempfaenger_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.cbzust_SelectedIndexChanged Method

Private Sub cbzust_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mcbzust.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbzust_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mcbzust.SelectedIndexChanged
        Try
            Me.teamzustaendig = Me.mcbzust.SelectedValue
            refresh_team()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.check_vorlagenfelder Method

Private Sub check_vorlagenfelder()

Source code

[Visual Basic]
    Private Sub check_vorlagenfelder()
        Dim dt As New DataTable()
        Dim i As Integer
        Dim progressvaluestep As Integer
        Dim progressvalue As Integer = 0
        Dim i1 As Integer
        Dim ok As Boolean = False
        Dim s As String

        SetProgress(0, "Felder Prüfen", False)
        dt = Me.Get_Vorlagenfelder(Me.Dokumenttypnr)
        Try
            progressvaluestep = 100 / dt.Rows.Count
        Catch
            progressvaluestep = 1
        End Try
        SetProgress(progressvalue, "Felder Prüfen", False)
        For i = 0 To dt.Rows.Count - 1
            Try
                Dim X As String
                X = Me.dsempfaenger.Tables(0).Rows(0).Item(dt.Rows(i).Item(0))
            Catch

                Me.dsempfaenger.Tables(0).Columns.Add(dt.Rows(i).Item(0))
                Me.dsempfaenger.Tables(0).Rows(0).Item(dt.Rows(i).Item(0)) = ""
                Me.dsempfaenger.Tables(1).Columns.Add(dt.Rows(i).Item(0))
                Try
                    If dt.Rows(i).Item(1) = True Then
                        Me.dsempfaenger.Tables(1).Rows(0).Item(dt.Rows(i).Item(0)) = 1
                    Else
                        Me.dsempfaenger.Tables(1).Rows(0).Item(dt.Rows(i).Item(0)) = 0
                    End If
                Catch
                    Me.dsempfaenger.Tables(1).Rows(0).Item(dt.Rows(i).Item(0)) = 0
                End Try
                s = s + "- " + dt.Rows(i).Item(0) + vbCrLf

            End Try

        Next
        'For i1 = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
        '    For i = 0 To dt.Rows.Count - 1
        '        If Me.dsempfaenger.Tables(0).Columns(i1).ColumnName = dt.Rows(i).Item(0) Then
        '            ok = True
        '            Exit For
        '        End If
        '        If Not ok Then
        '            Me.dsempfaenger.Tables(0).Columns.Add(dt.Rows(i).Item(0))
        '            Me.dsempfaenger.Tables(0).Rows(0).Item(dt.Rows(i).Item(0)) = ""
        '            Me.dsempfaenger.Tables(1).Columns.Add(dt.Rows(i).Item(0))
        '            If dt.Rows(i).Item(1) = True Then
        '                Me.dsempfaenger.Tables(1).Rows(0).Item(dt.Rows(i).Item(0)) = 1
        '            Else
        '                Me.dsempfaenger.Tables(1).Rows(0).Item(dt.Rows(i).Item(0)) = 0
        '            End If
        '            s = s + "- " + dt.Rows(i).Item(0)
        '        End If
        '        ok = True
        '    Next
        '    progressvalue = progressvalue + progressvaluestep
        '    SetProgress(progressvalue, "Felder Prüfen", False)
        'Next
        Me.empflist.DataMember = Nothing
        Me.empflist.DataSource = Nothing
        Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
        Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
        Me.Create_Layout()
        Me.Save_Layout()
        If s <> "" Then
            MyMsg.show_standardmessage_ReplaceText(703, MsgBoxStyle.Information, s, "")
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.check_zwingende_felder Method

Private Sub check_zwingende_felder()

Source code

[Visual Basic]
    Private Sub check_zwingende_felder()
        Dim dr As DataRow()
        Dim dr1 As DataRow
        Dim i As Integer
        For i = 20 To Me.dsempfaenger.Tables(0).Columns.Count - 1
            If Me.dsempfaenger.Tables(1).Rows(0).Item(Me.dsempfaenger.Tables(0).Columns(i).ColumnName) = 1 Then
                dr = Me.dsempfaenger.Tables(0).Select("[" + Me.dsempfaenger.Tables(0).Columns(i).ColumnName + "] <>''")
                For Each dr1 In dr
                    If dr1.Item("Status") = 0 Then dr1.Item("Status") = 0
                Next

                dr = Me.dsempfaenger.Tables(0).Select("[" + Me.dsempfaenger.Tables(0).Columns(i).ColumnName + "] =''")
                For Each dr1 In dr
                    If dr1.Item("Status") = 0 Then
                        dr1.Item("Status") = -1
                        dr1.Item("Fehlercode") = 2
                    End If
                Next
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.create_checktable Method

Private Function create_checktable()

Source code

[Visual Basic]
    Private Function create_checktable()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_check_partner_create_table"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@manr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.create_supporttable Method

Private Sub create_supporttable()

Source code

[Visual Basic]
    Private Sub create_supporttable()
        Dim dt As New DataTable()
        Dim i As Integer
        For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
            dt.Columns.Add(Me.dsempfaenger.Tables(0).Columns(i).ColumnName)
        Next
        Dim myRow As DataRow
        myRow = dt.NewRow
        For i = 0 To dt.Columns.Count - 1
            myRow.Item(i) = 0
        Next i
        dt.Rows.Add(myRow)
        If Check_Column("Partnernr", dt) Then dt.Rows(0).Item("Partnernr") = 1
        If Check_Column("Kurzbezeichnung", dt) Then dt.Rows(0).Item("Kurzbezeichnung") = 1
        If Check_Column("Anrede", dt) Then dt.Rows(0).Item("Anrede") = 1
        If Check_Column("Name", dt) Then dt.Rows(0).Item("Name") = 1
        If Check_Column("Vorname", dt) Then dt.Rows(0).Item("Vorname") = 1
        If Check_Column("Strasse", dt) Then dt.Rows(0).Item("Strasse") = 1
        If Check_Column("PLZ", dt) Then dt.Rows(0).Item("PLZ") = 1
        If Check_Column("Ort", dt) Then dt.Rows(0).Item("Ort") = 1
        If Check_Column("Zustelladresse", dt) Then dt.Rows(0).Item("Zustelladresse") = 1
        If Check_Column("Briefanrede1", dt) Then dt.Rows(0).Item("Briefanrede1") = 1
        If Check_Column("Briefanrede2", dt) Then dt.Rows(0).Item("Briefanrede2") = 1
        Me.dsempfaenger.Tables.Add(dt)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.delete_serienbrief Method

Private Function delete_serienbrief() As DataTable

Source code

[Visual Basic]
    Private Function delete_serienbrief() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_delete_serienbrief"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@serienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Serienbriefnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.delrow Method

Private Function delrow( _
   ByVal c1row As Object _
)

Parameters

c1row
Required.

Source code

[Visual Basic]
    Private Function delrow(ByVal c1row As Object)
        Try
            Me.empflist.Row = c1row

            Me.empflist.Delete()
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.empflist_ColMove Method

Private Sub empflist_ColMove( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColMoveEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub empflist_ColMove(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColMoveEventArgs)
        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.empflist_ColResize Method

Private Sub empflist_ColResize( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColResizeEventArgs _
) Handles empflist.ColResize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub empflist_ColResize(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColResizeEventArgs) Handles empflist.ColResize
        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.empflist_DoubleClick Method

Private Sub empflist_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles empflist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub empflist_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles empflist.DoubleClick
        Try
            If Me.serienbrief.iStatus.Value <> 0 Then Exit Sub
            MnuEditEmpfaenger_Click(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.empflist_FetchRowStyle Method

Private Sub empflist_FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles empflist.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub empflist_FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles empflist.FetchRowStyle
        Try
            Select Case empflist.Columns("Fehlercode").CellValue(e.Row)
                Case 9
                    e.CellStyle.ForeColor = Color.Blue
                    'Case 1
                    '    e.CellStyle.ForeColor = Color.Blue
                    'Case 2
                    '    e.CellStyle.ForeColor = Color.Green
                    'Case Else
                    '    e.CellStyle.ForeColor = Color.Black
            End Select

        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.empflist_MouseDown Method

Private Sub empflist_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles empflist.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub empflist_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles empflist.MouseUp
        Try
            Me.empflist.Bookmark = Me.empflist.RowContaining(e.Y)
            Me.CurrentColumn = Me.empflist.ColContaining(e.X) - 1
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.frmSerienbriefe_Closing Method

Private Sub frmSerienbriefe_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSerienbriefe_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        If Me.mcbverantwortlich.Enabled = False Then Exit Sub

        If Me.txtBezeichnung.Text = "" Then
            Exit Sub
        End If
        If Me.serienbrief.iStatus.Value <> 0 Then
            Exit Sub
        End If
        If Me.dsempfaenger.HasChanges = True Or datachanged Then
            Dim i As MsgBoxResult
            i = MyMsg.Show_MessageYesNoCancel(721)
            If i = MsgBoxResult.Cancel Then e.Cancel = True
            If i = MsgBoxResult.No Then Exit Sub
            If i = MsgBoxResult.Yes Then
                Me.save_data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.frmSerienbriefe_Load Method

Private Sub frmSerienbriefe_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSerienbriefe_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        On_Load = True
        datachanged = False
        datachanged = False
        load_defaults()
        Funktionen_Freigeben(False)
        init_empfaenger()
        Me.empflist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.Extended
        Me.StatusBar1.Controls.Add(progress)
        Me.SetProgress(0, "", True)

        If Me.OpenForPrinting Then
            Me.Serienbriefnr = Me.printsbnr
            Load_Serienbrief(Me.Serienbriefnr)
            'Tree Aufbauen
            Me.TVStatus.Nodes.Clear()
            Me.Generate_Tree()
        End If
        Me.datachanged = False
        Me.dsempfaenger.AcceptChanges()
        On_Load = False
        Load_Reserved_Words()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.get_druckjobname Method

Private Function get_druckjobname( _
   ByVal druckjobid _
) As String

Parameters

druckjobid
Required.

Source code

[Visual Basic]
    Private Function get_druckjobname(ByVal druckjobid) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_druckjobname"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@id", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, druckjobid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@druckjobname", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            sdaAdapter.Fill(dtToReturn)
            Return scmCmdToExecute.Parameters("@druckjobname").Value
        Catch ex As Exception
            Return ""
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.get_druckjobs Method

Private Function get_druckjobs() As DataTable

Source code

[Visual Basic]
    Private Function get_druckjobs() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "sp_edex_sb_get_druckjob"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@sbnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Serienbriefnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.get_idvwerte Method

Private Function get_idvwerte() As DataTable

Source code

[Visual Basic]
    Private Function get_idvwerte() As DataTable
        Dim i As Integer
        Dim dt As New DataTable()
        dt.Columns.Add("Feldname")
        dt.Columns.Add("Wert")
        For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
            Select Case UCase(Me.dsempfaenger.Tables(0).Columns(i).Caption)
                Case "PARTNERNR", "KURZBEZEICHNUNG", "ANREDE", "NAME", "VORNAME", "STRASSE", "PLZ", "ORT", "ZUSTELLADRESSE", "BRIEFANREDE1", "BRIEFANREDE2", "STATUS", "FEHLERCODE", "BLKUNDE", "DOKUMENT_GEDRUCKT", "AKTIV", "DOKUMENTID", "DOKUMENTIDBDR", "ERSTELLER", "DRUCKJOBID"
                Case Else
                    Dim myRow As DataRow
                    myRow = dt.NewRow
                    myRow.Item(0) = Me.dsempfaenger.Tables(0).Columns(i).Caption
                    myRow.Item(1) = ""
                    dt.Rows.Add(myRow)
            End Select
        Next
        Return dt
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.get_postzustellung Method

Private Function get_postzustellung() As DataTable

Source code

[Visual Basic]
    Private Function get_postzustellung() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_postzustellung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@sprache", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_edex_sb_get_postzustellung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.get_status Method

Private Function get_status() As DataTable

Source code

[Visual Basic]
    Private Function get_status() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.init_empfaenger Method

Private Sub init_empfaenger()

Source code

[Visual Basic]
    Private Sub init_empfaenger()
        Try
            Me.empflist.DataSource = Nothing
            Me.empflist.DataMember = Nothing
            Me.dsempfaenger.Tables.Clear()
            Me.Serienbriefnr = 0
            If Me.Load_empfaenger = True Then
                Check_Column("DRUCKJOBID", Me.dsempfaenger.Tables(0))
                Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
                Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            End If
            Load_Layout()
            Me.empflist.AllowAddNew = False
            Me.save_DSInit = Me.dsempfaenger.Tables(0)
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.ins_Barcode Method

Private Sub ins_Barcode()

Source code

[Visual Basic]
    Private Sub ins_Barcode()

        Dim xname As String
        Dim i As Integer
        Dim pages As Long
        pages = objword.ActiveDocument.BuiltInDocumentProperties("NUMBER OF PAGES").value

        objword.Selection.HomeKey(Unit:=Word.WdUnits.wdStory)
        Textboxesi = 1
        For i = 1 To pages
            xname = Str(i)
            If Microsoft.VisualBasic.Left(xname, 1) = " " Then xname = Microsoft.VisualBasic.Right(xname, Len(xname) - 1)
            objword.Selection.GoTo(what:=Word.WdGoToItem.wdGoToPage, Name:=xname)
            HeaderFooterAnzeigen()
            insert_Barcode(i)
            Textboxesi = Textboxesi + 1
            objword.ActiveWindow.ActivePane.View.SeekView = Word.WdSeekView.wdSeekMainDocument
        Next i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.insert_Barcode Method

Private Sub insert_Barcode( _
   ByVal x As Integer _
)

Parameters

x
Required.

Source code

[Visual Basic]
    Private Sub insert_Barcode(ByVal x As Integer)

        Dim Form
        Dim strsel As String
        Dim strresult
        Dim s As String

        Try
            Form = objword.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
            Form.Select()
            Form = objword.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
            Form.Select()
            If officevorlage.bBchorizontal.Value = False Then
                objword.ActiveDocument.Tables.Add(Range:=objword.Selection.Range, NumRows:=1, NumColumns:=1)
                With objword.Selection.Tables.Item(1)
                    .Borders.Item(Word.WdBorderType.wdBorderLeft).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Item(Word.WdBorderType.wdBorderRight).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Item(Word.WdBorderType.wdBorderTop).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Item(Word.WdBorderType.wdBorderBottom).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Item(Word.WdBorderType.wdBorderDiagonalDown).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Item(Word.WdBorderType.wdBorderDiagonalUp).LineStyle = Word.WdLineStyle.wdLineStyleNone
                    .Borders.Shadow = False
                End With
                objword.Selection.Orientation = Word.WdTextOrientation.wdTextOrientationUpward
                objword.Selection.Tables.Item(1).Rows.HeightRule = Word.WdRowHeightRule.wdRowHeightAtLeast
                objword.Selection.Tables.Item(1).Rows.Height = Form.height
            End If

            Dim id As String
            id = dokid
            s = Bar25I(Microsoft.VisualBasic.Right(Microsoft.VisualBasic.Right(id, Len(id) - 6), 16))
            objword.Selection.TypeText(Text:=s)
            objword.Selection.HomeKey(Unit:=Word.WdUnits.wdLine, Extend:=Word.WdMovementType.wdExtend)
            objword.Selection.Font.Name = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("barcode_font")
            objword.Selection.Font.Size = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("bcfont_groesse")
            objword.Selection.ParagraphFormat.Alignment = Word.WdParagraphAlignment.wdAlignParagraphRight
            objword.Selection.EndKey(Unit:=Word.WdUnits.wdLine)
            objword.Selection.Font.Name = "Arial"
            objword.Selection.Font.Size = 8

            Dim Zeichen As String
            If doktyp.bZu_retournieren.Value = True Then
                Dim dokt As New edokadb.clsDokumenttyp()
                dokt.cpMainConnectionProvider = Globals.conn
                dokt.iDokumenttypnr = New SqlInt32(CType(doktyp.iDoktypbedingteretournierung.Value, Int32))
                dokt.SelectOne()
                If dokt.iPhysisches_archiv.Value = 2 Then
                    'EDEX Banklagernd
                    Zeichen = " F"
                    'objWord.Selection.TypeText(" F")
                Else
                    Zeichen = " U"
                    'objWord.Selection.TypeText(" U")
                End If
                dokt.Dispose()
            Else
                If doktyp.iPhysisches_archiv.Value = 2 Then
                    Zeichen = " F"
                    '                        objWord.Selection.TypeText(" F")
                Else
                    Zeichen = " U"
                    'objWord.Selection.TypeText(" U")
                End If
            End If
            If blkunde <> "" Then
                Zeichen = Zeichen + "/B"
            End If
            objword.Selection.TypeText(Zeichen)

            Form = Nothing
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.insert_Textfield Method

Private Sub insert_Textfield()

Source code

[Visual Basic]
    Private Sub insert_Textfield()
        Dim Public_barcodeleft
        Dim Public_barcodetop
        Dim Public_barcodewidth#
        Dim Public_barcodeheight
        Try
            Public_barcodeleft = 260
            Public_barcodetop = 794
            Public_barcodewidth = 300
            Public_barcodeheight = 33

            HeaderFooterAnzeigen()
            objword.Selection.HeaderFooter.Shapes.AddTextbox(1, Public_barcodeleft, Public_barcodetop, _
                Public_barcodewidth#, Public_barcodeheight).Select()
            '  objWord.Selection.ShapeRange.TextFrame.TextRange.Select
            'objword.Selection.ShapeRange.Line.Visible = Office.MsoTriState.msoFalse
            'objword.Selection.ShapeRange.Line.Visible = Office.Core.MsoTriState.msoFalse
            '            objword.Selection.ShapeRange.Line.Visible = Microsoft.Office.Core.MsoTriState.msoFalse
            objword.Selection.ShapeRange.TextFrame.MarginLeft = 0.0#
            objword.Selection.ShapeRange.TextFrame.MarginRight = 0.0#
            objword.Selection.ShapeRange.TextFrame.MarginTop = 0.0#
            objword.Selection.ShapeRange.TextFrame.MarginBottom = 0.0#
            objword.Selection.Collapse()
            Textboxes(Textboxesi) = objword.Selection.HeaderFooter.Shapes.Item(Textboxesi).Name
            Textboxesi = Textboxesi + 1
            Exit Sub

        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.ist_archiviert Method

Private Function ist_archiviert( _
   ByVal dokumentid As String _
) As Integer

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Private Function ist_archiviert(ByVal dokumentid As String) As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_dokument_bereits_archiviert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@istarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bdrarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            ' EDEX Banklagernd
            scmCmdToExecute.Parameters.Add(New SqlParameter("@blarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bldelete", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@istarchiviert").Value
            Return i
        Catch ex As Exception
            'MsgBox(ex.Message)
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.load_Mitarbeiter Method

Private Sub load_Mitarbeiter()

Source code

[Visual Basic]
    Private Sub load_Mitarbeiter()
        conn.OpenConnection()
        Dim t As DataTable
        t = Generic_Select(17)

        Me.drpMiatarbeiter.DataSource = t
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.load_defaults Method

Private Sub load_defaults()

Source code

[Visual Basic]
    Private Sub load_defaults()
        Dim dd As New DataTable()
        Dim ii As Integer
        'Postzustellung
        mcbpostzustellung = New MultiComboBox(Me.cbPostzustellung)
        mcbpostzustellung.Visible = True
        Me.mcbpostzustellung.DisplayColumnName = "bezeichnung"
        Me.mcbpostzustellung.ValueColumnName = "nreintrag"
        Me.mcbpostzustellung.Fill_Data(Me.get_postzustellung, False)
        Me.mcbpostzustellung.Enabled = True
        Me.mcbpostzustellung.CheckNullValue = False

        'Unterschrift links / rechts / Zustaendiger
        dd = Generic_Select(3)
        mcbunterschriftlinks = New MultiComboBox(Me.cbUnterschriftlinks)
        Me.mcbunterschriftlinks.DisplayColumnName = "name"
        Me.mcbunterschriftlinks.ValueColumnName = "mitarbeiternr"
        Me.mcbunterschriftlinks.Fill_Data(dd, True)
        mcbunterschriftrechts = New MultiComboBox(Me.cbUnterschriftrechts)
        Me.mcbunterschriftrechts.DisplayColumnName = "name"
        Me.mcbunterschriftrechts.ValueColumnName = "mitarbeiternr"
        Me.mcbunterschriftrechts.Fill_Data(dd, True)
        Me.mcbunterschriftlinks.CheckNullValue = False
        Me.mcbunterschriftrechts.CheckNullValue = False
        Me.mcbunterschriftlinks.Visible = True
        Me.mcbunterschriftrechts.Visible = True
        mcbzust = New MultiComboBox(Me.cbzust)
        Me.mcbzust.DisplayColumnName = "name"
        Me.mcbzust.ValueColumnName = "mitarbeiternr"
        Me.mcbzust.Fill_Data(Generic_Select(3), False)
        ii = Globals.MitarbeiterNr
        Me.mcbzust.SelectedValue = ii
        Me.RBZustaendigZustaendiger.Checked = True
        Me.mcbzust.Visible = True

        'Verantwortlicher
        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"
        on_fill = True
        FillMcbVerantwortlich()
        on_fill = False
        Me.mcbverantwortlich.Visible = True
        Me.mcbverantwortlich.Enabled = True

        'Team
        Me.mcbteam = New MultiComboBox(Me.cbteam)
        Me.mcbteam.CheckNullValue = True
        Me.mcbteam.NullValueMessage = MyTxt.gettext(18)
        Me.mcbteam.DisplayColumnName = "bezeichnung"
        Me.mcbteam.ValueColumnName = "teamnr"
        Me.teamzustaendig = Globals.MitarbeiterNr
        refresh_team()
        Me.mcbteam.SelectedIndex = 0
        Me.mcbteam.Visible = True
        Me.dtstatus = Me.get_status
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.load_notizen Method

Private Function load_notizen() As DataTable

Source code

[Visual Basic]
    Private Function load_notizen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_ notizen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@serienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Serienbriefnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            conn.CloseConnection(True)
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.load_persvorlage Method

Private Sub load_persvorlage( _
   ByVal persvorlagenr As Integer _
)

Parameters

persvorlagenr
Required.

Source code

[Visual Basic]
    Private Sub load_persvorlage(ByVal persvorlagenr As Integer)
        Try
            Me.dsempfaenger.Tables.Clear()
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger_vorlage.xml"
            Dim vorlagenname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Serienbriefnr.ToString + "_vorlage.doc"
            Me.dsempfaenger.Tables.Clear()
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_persvorlage where persvorlagenr=" + persvorlagenr.ToString, Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(6)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                    Me.dsempfaenger.ReadXml(dokumentname)

                    Dim k1 As Long
                    MyData = myRow.Item(7)
                    K = UBound(MyData)
                    Dim fs1 As New FileStream(vorlagenname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs1.Write(MyData, 0, K)
                    fs1.Close()
                    fs1 = Nothing
                    Me.Vorlage_Speichern(vorlagenname)
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
            Finally
                File.Delete(dokumentname)
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Me.dsempfaenger.Tables(0).Rows.Clear()
            Me.save_empfaenger()
            Me.Load_data()
            Me.SetProgress(100, "Vorlage laden", True)
            Me.Generate_Tree()
        Catch EX As Exception
            MyMsg.show_standardmessage(701, MsgBoxStyle.Critical)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mcbverantwortlich_SelectedIndexChanged Method

Private Sub mcbverantwortlich_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbverantwortlich.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbverantwortlich_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbverantwortlich.SelectedIndexChanged
        If Me.On_Fill Then Exit Sub
        If Not On_Load Then
            If Me.mcbverantwortlich.SelectedValue <> Me.save_verantwortlich Then
                If MyMsg.Show_MessageYesNo(734) = MsgBoxResult.Yes Then
                    Me.datachanged = True
                    Me.save_data()
                    Me.Funktionen_Freigeben(False)
                Else
                    Me.mcbverantwortlich.SelectedValue = Me.save_verantwortlich
                End If
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mcbverantwortlich_leave Method

Private Sub mcbverantwortlich_leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbverantwortlich.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbverantwortlich_leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbverantwortlich.Leave
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuNeuerSerienbrief_Click Method

Private Sub mnuNeuerSerienbrief_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuNeuerSerienbrief_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.txtBezeichnung.Text = ""
        Me.txtBezeichnung.Focus()
        Funktionen_Freigeben(True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuaddhost_Click Method

Private Sub mnuaddhost_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuaddhost.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuaddhost_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuaddhost.Click
        Dim f As New FrmPartnersuche()
        f.TopMost = False
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Partner_Details(f.PartnerNr)
            add_edokahostpartner(f.VIBeachten)
            Me.empflist.UpdateData()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2abschliessen_Click Method

Private Sub mnuc2abschliessen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2abschliessen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2abschliessen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2abschliessen.Click
        MnuMainAbschluss_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2bestaetigen_Click Method

Private Sub mnuc2bestaetigen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2bestaetigen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2bestaetigen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2bestaetigen.Click
        Dim dr As DataRow()
        Dim dr1 As DataRow
        Try
            If Me.TVStatus.SelectedNode.Tag = 2 Or Me.TVStatus.SelectedNode.Tag = 3 Then
                dr = Me.dsempfaenger.Tables(0).Select("Status='" + Me.TVStatus.SelectedNode.Tag.ToString + "'")
            Else
                Dim s As String
                Dim druckjobname As String
                s = Me.TVStatus.SelectedNode.Tag
                s = s.Substring(4)
                druckjobname = get_druckjobname(s)
                dr = Me.dsempfaenger.Tables(0).Select("Druckjobid='" + druckjobname + "'")
            End If
        Catch
            Dim s As String
            Dim druckjobname As String
            s = Me.TVStatus.SelectedNode.Tag
            s = s.Substring(4)
            druckjobname = get_druckjobname(s)
            dr = Me.dsempfaenger.Tables(0).Select("Druckjobid='" + druckjobname + "'")
        End Try
        For Each dr1 In dr
            dr1.Item("status") = 4
        Next
        Me.save_data()
        Me.Generate_Tree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2generieren_Click Method

Private Sub mnuc2generieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2generieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2generieren_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2generieren.Click
        Try
            mnuc2partnerlistepruefen_Click(sender, e)
        Catch
        End Try
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = Globals.conn
        dt.iDokumenttypnr = New SqlInt32(CType(Me.serienbrief.iDokumenttypnr.Value, Int32))
        dt.SelectOne()
        Dim iNichtgeneriert As Integer = 0
        Dim dv As DataRow()
        Dim DR As DataRow

        dv = Me.dsempfaenger.Tables(0).Select("Status='0' or Status=''")
        For Each DR In dv
            iNichtgeneriert = iNichtgeneriert + 1
        Next

        Dim pstep As Double
        Dim pcount As Integer
        Dim pval As Double = 0
        pcount = iNichtgeneriert
        pstep = 100 / iNichtgeneriert
        For Each DR In Me.dsempfaenger.Tables(0).Rows
            If DR.Item("Status") = 0 Then
                If dt.bNurnative.Value = False And DR.Item("Partnernr") = "" Then
                    DR.Item("Status") = -1
                    DR.Item("Fehlercode") = 1
                Else
                    If DR.Item("Status") = 0 Then DR.Item("Status") = 1
                End If
                pval = pval + pstep
                pcount = pcount - 1
                SetProgress(pval, "Empfänger bearbeiten (" + pcount.ToString + ")", False)
            End If
        Next
        Me.Generate_Tree()

        Me.serienbrief.iStatus = New SqlInt32(CType(-1, Int32))
        Me.save_data()
        Me.Funktionen_Freigeben(False)
        Try
            DivFnkt.Searchnode1(Me.TVStatus, 1, -99)
            If DivFnkt.found Then Me.TVStatus.SelectedNode = DivFnkt.FoundNode
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2partnerlistepruefen_Click Method

Private Sub mnuc2partnerlistepruefen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2partnerlistepruefen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2partnerlistepruefen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2partnerlistepruefen.Click
        Me.Cursor = Cursors.WaitCursor
        Me.SetProgress(10, "Empfänger prüfen", False)
        Application.DoEvents()
        create_checktable()
        Me.SetProgress(20, "Empfänger prüfen", False)
        save_checkdata()
        Me.SetProgress(60, "Empfänger prüfen", False)
        Dim dt As New DataTable()
        Dim i As Integer
        dt = Check_Data()
        Me.SetProgress(80, "Empfänger prüfen", False)
        For i = 0 To dt.Rows.Count - 1
            Dim dr As DataRow()
            Dim dr1 As DataRow
            dr = Me.dsempfaenger.Tables(0).Select("Partnernr='" + dt.Rows(i).Item(0).ToString + "'")
            If dr.Length = 0 Then
                dr = Me.dsempfaenger.Tables(0).Select("Partnernr=''")
            End If
            For Each dr1 In dr
                dr1.Item("Status") = dt.Rows(i).Item("status")
                Try
                    If dt.Rows(i).Item("Fehlercode") > 0 Then
                        dr1.Item("Fehlercode") = dt.Rows(i).Item("Fehlercode")
                    End If
                Catch

                End Try
            Next
            'Me.dsempfaenger.Tables(0).Rows(dt.Rows(i).Item("rowid")).Item("status") = dt.Rows(i).Item("status")
        Next

        If Me.dsempfaenger.Tables(0).Columns.Count > 20 Then
            check_zwingende_felder()
        End If
        Me.Cursor = Cursors.Default
        Application.DoEvents()
        Me.SetProgress(100, "Empfänger prüfen", True)
        Me.Generate_Tree()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2printjob_Click Method

Private Sub mnuc2printjob_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2printjob.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2printjob_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2printjob.Click
        Dim s As String
        s = Me.TVStatus.SelectedNode.Tag
        s = s.Substring(4)
        pdfprinter = New frmSBPDFPrinter(s, False)
        pdfprinter.Show()
        Application.DoEvents()
        pdfprinter.PrintPDF()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuc2printpreview_Click Method

Private Sub mnuc2printpreview_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuc2printpreview.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuc2printpreview_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuc2printpreview.Click
        Dim s As String
        s = Me.TVStatus.SelectedNode.Tag
        s = s.Substring(4)
        pdfprinter = New frmSBPDFPrinter(s, True)
        pdfprinter.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuctErstellungWiederholen_Click Method

Private Sub mnuctErstellungWiederholen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles mnuctErstellungWiederholen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuctErstellungWiederholen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles mnuctErstellungWiederholen.Click
        Dim i As Integer
        Dim c1row As Object
        Dim pstep As Double
        Dim pcount As Integer
        Dim pval As Double = 0
        Dim versandt As Boolean

        If Me.TVStatus.SelectedNode.Tag = 2 Or Me.TVStatus.SelectedNode.Tag = 3 Or Me.TVStatus.SelectedNode.Tag = 4 Then
            Dim msgres As MsgBoxResult
            msgres = MyMsg.Show_MessageYesNoCancel(735)
            If msgres = MsgBoxResult.Cancel Then Exit Sub
            If msgres = MsgBoxResult.Yes Then versandt = True
            If msgres = MsgBoxResult.No Then versandt = False
        Else
            versandt = False
        End If

        If Me.empflist.SelectedRows.Count > 0 Then
            Me.empflist.BeginInit()
            pcount = Me.empflist.SelectedRows.Count
            pstep = 100 / Me.empflist.SelectedRows.Count
            SetProgress(pval, "Empfänger bearbeiten (" + pcount.ToString + ")", False)
            Dim s As String
            s = Me.empflist.Columns("Status").FilterText
            Me.empflist.Columns("Status").FilterText = ""
            For i = 0 To Me.empflist.SelectedRows.Count - 1
                Me.empflist.Row = Me.empflist.SelectedRows(i)
                Me.empflist.Bookmark = Me.empflist.SelectedRows(i)
                If Me.empflist.Columns("Dokumentid").Value <> "" Then
                    Check_Archiviert(Me.empflist.Columns("Dokumentid").Value, versandt)
                    Me.empflist.Columns("Dokumentid").Value = ""
                    Me.empflist.Columns("Dokumentidbdr").Value = ""
                    Me.empflist.Columns("Dokument_Gedruckt").Value = ""
                    Me.empflist.Columns("Status").Value = 0
                Else
                    Me.empflist.Columns("Dokumentid").Value = ""
                    Me.empflist.Columns("Dokumentidbdr").Value = ""
                    Me.empflist.Columns("Dokument_Gedruckt").Value = ""
                    Me.empflist.Columns("Status").Value = 0
                End If
                'Me.empflist.Columns("Dokumentid").Value = ""
                'Me.empflist.Columns("Dokumentidbdr").Value = ""
                'Me.empflist.Columns("Dokument_Gedruckt").Value = ""
                'Me.empflist.Columns("Status").Value = 0
                pval = pval + pstep
                pcount = pcount - 1
                SetProgress(pval, "Empfänger bearbeiten (" + pcount.ToString + ")", False)
            Next
            Me.empflist.UpdateData()
            Me.empflist.Columns("Status").FilterText = s

            SetProgress(pval, "Empfänger bearbeiten(0)", True)
            Me.empflist.EndInit()
        Else
            If Me.empflist.Columns("Dokumentid").Value <> "" Then
                Check_Archiviert(Me.empflist.Columns("Dokumentid").Value, versandt)
                Me.empflist.Columns("Dokumentid").Value = ""
                Me.empflist.Columns("Dokumentidbdr").Value = ""
                Me.empflist.Columns("Dokument_Gedruckt").Value = ""
                Me.empflist.Columns("Status").Value = 0
            Else
                Me.empflist.Columns("Dokumentid").Value = ""
                Me.empflist.Columns("Dokumentidbdr").Value = ""
                Me.empflist.Columns("Dokument_Gedruckt").Value = ""
                Me.empflist.Columns("Status").Value = 0
            End If
            'Me.empflist.Columns("Dokumentid").Value = ""
            'Me.empflist.Columns("Dokumentidbdr").Value = ""
            'Me.empflist.Columns("Dokument_Gedruckt").Value = ""
            'Me.empflist.Columns("Status").Value = "0"
            'Me.empflist.UpdateData()
        End If
        Me.save_data()
        Me.Generate_Tree()
        Me.datachanged = False
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuidvspalteumbenennen_Click Method

Private Sub mnuidvspalteumbenennen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuidvspalteumbenennen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuidvspalteumbenennen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuidvspalteumbenennen.Click
        If Me.dsempfaenger.Tables(1).Rows(0).Item(Me.CurrentColumn) = 1 Then
            MyMsg.show_standardmessage(707, MsgBoxStyle.Critical)
            Exit Sub
        End If
        Dim s As String
        s = InputBox(MyMsg.Get_Meldungstext(708) + " " + Me.dsempfaenger.Tables(0).Columns(Me.CurrentColumn + 1).Caption + MyMsg.Get_Meldungstext(709))
        If s <> "" Then
            s = Me.Check_Columnname(s)
            If s = "#Error#" Then
                MyMsg.show_standardmessage(729, MsgBoxStyle.Critical)
                Exit Sub
            End If

            Me.dsempfaenger.Tables(0).Columns(Me.CurrentColumn + 1).ColumnName = s
            Me.dsempfaenger.Tables(1).Columns(Me.CurrentColumn).ColumnName = s
            Me.empflist.DataMember = Nothing
            Me.empflist.DataSource = Nothing
            Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
            Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Me.Create_Layout()
            Me.Save_Layout()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuidwspalteentfernen_Click Method

Private Sub mnuidwspalteentfernen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuidwspalteentfernen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuidwspalteentfernen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuidwspalteentfernen.Click
        Try
            'Wenn in der zweiten Tabelle das Flag der entsprechenden Spalte auf 1 ist, kann die Spalte nicht gelöscht werden
            If Me.dsempfaenger.Tables(1).Rows(0).Item(Me.CurrentColumn) = True Then
                MyMsg.show_standardmessage(705, MsgBoxStyle.Critical)
                Exit Sub
            End If
            'Sofern die Spalte gelöscht wird, wird das Dataset und die Empfängerliste aktualisiert
            If MyMsg.show_MessageYesNo_ReplaceText(706, Me.empflist.Columns(Me.CurrentColumn + 1).Caption, "") = MsgBoxResult.Yes Then
                Me.dsempfaenger.Tables(0).Columns.Remove(Me.empflist.Columns(Me.CurrentColumn + 1).Caption)
                Me.dsempfaenger.Tables(1).Columns.Remove(Me.empflist.Columns(Me.CurrentColumn + 1).Caption)
                Me.empflist.DataMember = Nothing
                Me.empflist.DataSource = Nothing
                Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
                Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
                Me.Create_Layout()
                Me.Save_Layout()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnuidwspaltehinzufuegen_Click Method

Private Sub mnuidwspaltehinzufuegen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuidwspaltehinzufuegen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuidwspaltehinzufuegen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuidwspaltehinzufuegen.Click
        Dim s As String
        s = InputBox("Bitte geben Sie den Namen der neuen Spalte ein.", "")
        If s <> "" Then
            Dim i As Integer
            For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
                If Me.dsempfaenger.Tables(0).Columns(i).Caption = s Then
                    MyMsg.show_standardmessage(704, MsgBoxStyle.Critical)
                    Exit Sub
                End If
            Next
            Me.dsempfaenger.Tables(0).Columns.Add(s)
            '            Me.dsempfaenger.Tables(0).Columns(Me.dsempfaenger.Tables(0).Columns.Count - 1).DefaultValue = "0"
            Me.dsempfaenger.Tables(0).Rows(0).Item(Me.dsempfaenger.Tables(0).Columns.Count - 1) = ""

            Me.empflist.DataMember = Nothing
            Me.empflist.DataSource = Nothing
            Me.empflist.DataSource = Me.dsempfaenger.Tables(0)
            Me.empflist.DataMember = Me.dsempfaenger.Tables(0).TableName
            Me.dsempfaenger.Tables(1).Columns.Add(s)
            'Tabelle 2 ergänzen, damit die Spalten auch gelöscht werden kann
            Me.dsempfaenger.Tables(1).Rows(0).Item(s) = 0
            Me.Create_Layout()
            Me.Save_Layout()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnunewedoka_Click Method

Private Sub mnunewedoka_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnunewedoka.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnunewedoka_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnunewedoka.Click
        Dim f As New frmInteressent()
        f.TopMost = False
        f.Profilnr = 0
        f.Display = False
        Try
            f.Partnernr = 0
            f.ShowDialog()
        Catch
            f.Partnernr = 0
            f.ShowDialog()
        Finally
            If f.Partnernr > 0 Then
                Me.Partner_Details(f.Partnernr)
                add_edokahostpartner(False)
                Me.empflist.UpdateData()
                Me.Generate_Tree()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnunewempfaenger_Click Method

Private Sub mnunewempfaenger_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnunewempfaenger.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnunewempfaenger_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnunewempfaenger.Click
        Dim f As New frmsbpartnerdetail(True, Me.dsempfaenger.Tables(0), 0)
        f.txtAnrede.Text = ""
        f.txtname.Text = ""
        f.txtvorname.Text = ""
        f.txtstrasse.Text = ""
        f.txtplz.Text = ""
        f.txtort.Text = ""
        f.txtzustelladresse.Text = ""
        Dim dt As New DataTable()
        dt = Me.get_idvwerte
        f.WertList.DataSource = dt
        f.WertList.DataMember = dt.TableName
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Me.empflist.AllowAddNew = True
            Me.empflist.MoveLast()
            Me.empflist.Row = Me.empflist.Row + 1
            Me.empflist.Select()
            Dim i As Integer
            For i = 0 To Me.empflist.Columns.Count - 1
                Me.empflist.Columns(i).Text = ""
            Next
            Me.empflist.Columns("Anrede").Text = f.txtAnrede.Text
            Me.empflist.Columns("Kurzbezeichnung").Text = f.txtkurzbezeichnung.Text
            Me.empflist.Columns("Name").Text = f.txtname.Text
            Me.empflist.Columns("Vorname").Text = f.txtvorname.Text
            Me.empflist.Columns("Strasse").Text = f.txtstrasse.Text
            Me.empflist.Columns("PLZ").Text = f.txtplz.Text
            Me.empflist.Columns("Ort").Text = f.txtort.Text
            Me.empflist.Columns("Zustelladresse").Text = f.txtzustelladresse.Text
            Me.empflist.Columns("BriefAnrede1").Text = f.txtanrede1.Text
            Me.empflist.Columns("BriefAnrede2").Text = f.txtanrede2.Text
            Me.empflist.Columns("Status").Text = 0

            For i = 0 To dt.Rows.Count - 1
                Me.empflist.Columns(dt.Rows(i).Item(0)).text = dt.Rows(i).Item(1)
            Next
            Me.empflist.UpdateData()
            'If NeuerSB = True Then
            '    NeuerSB = False
            '    Me.dsempfaenger.Tables(0).Rows(0).Delete()
            '    Me.dsempfaenger.AcceptChanges()
            'End If
            Me.datachanged = True
            Me.empflist.AllowAddNew = False
            Me.Generate_Tree()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.mnusaveasedokapartner_Click Method

Private Sub mnusaveasedokapartner_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnusaveasedokapartner.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnusaveasedokapartner_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnusaveasedokapartner.Click
        Dim f As New frmInteressent()
        f.txtanrede.Text = Me.empflist.Columns("Anrede").Text
        f.txtname.Text = Me.empflist.Columns("name").Text
        f.txtvorname.Text = Me.empflist.Columns("vorname").Text
        f.txtadresse1.Text = Me.empflist.Columns("Strasse").Text
        f.txtplz.Text = Me.empflist.Columns("plz").Text
        f.txtort.Text = Me.empflist.Columns("ort").Text
        f.txtbriefanrede.Text = Me.empflist.Columns("Briefanrede1").Text
        f.txtkurzbezeichnung.Text = Me.empflist.Columns("Kurzbezeichnung").Text
        f.adraufbereitet.Text = Me.empflist.Columns("Zustelladresse").Text
        f.ShowDialog()
        If f.Partnernr <> 0 Then
            Me.empflist.Columns("partnernr").Text = f.Partnernr.ToString
            Me.empflist.Columns("anrede").Text = ""
            Me.empflist.Columns("name").Text = ""
            Me.empflist.Columns("Vorname").Text = ""
            Me.empflist.Columns("Strasse").Text = ""
            Me.empflist.Columns("plz").Text = ""
            Me.empflist.Columns("ort").Text = ""
            Me.empflist.Columns("Zustelladresse").Text = ""
            Me.empflist.Columns("BriefAnrede1").Text = ""
            Me.empflist.Columns("BriefAnrede2").Text = ""
            Me.empflist.Columns("Anrede").Text = ""
            Me.empflist.Columns("Zustelladresse").Text = ""
            Me.empflist.UpdateData()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.oledbimport Method

Private Function oledbimport( _
   ByVal file As String, _
   ByVal filetype As String _
)

Parameters

file
Required.
filetype
Required.

Source code

[Visual Basic]
    Private Function oledbimport(ByVal file As String, ByVal filetype As String)
        Dim dt As New DataTable()
        Dim conn As OleDbConnection
        Dim sql As String
        Dim FileConnection As String
        Dim oda As New OleDbDataAdapter()
        Dim msg As String

        Select Case filetype
            Case "XLS"
                FileConnection = "provider=Microsoft.Jet.OLEDB.4.0; " & "data source='" & file & " '; " & "Extended Properties=Excel 8.0;"
                sql = "select * from [Tabelle1$]"
        End Select

        Try
            Try
                conn = New OleDbConnection()
                conn.ConnectionString = FileConnection
                conn.Open()
            Catch ex As Exception
                msg = ex.Message
            End Try
            oda = New OleDbDataAdapter(sql, conn)
            oda.Fill(dt)
            Me.dsempfaenger.Tables.Add(dt)
            Return dt
        Catch ex As Exception
        Finally
            oda.Dispose()
            conn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.pdfprinter_PrintDOne Method

Private Sub pdfprinter_PrintDOne() Handles pdfprinter.PrintDOne

Source code

[Visual Basic]
    Private Sub pdfprinter_PrintDOne() Handles pdfprinter.PrintDOne
        Dim s As String
        s = Me.TVStatus.SelectedNode.Tag
        s = s.Substring(4)
        Me.set_druckjobstatus(1, s)
        set_gedruckt(s)
        Me.Generate_Tree()
        If Me.druckjobs.Rows.Count = 0 Then
            Dim f As New frmDruckabschluss(Me.Serienbriefnr)
            f.ShowDialog()
            If f.datasaved Then
                '                MyMsg.show_standardmessage(723, MsgBoxStyle.Information)
                Me.On_Load = True
                Load_Serienbrief(Me.Serienbriefnr)
                'Tree Aufbauen
                Me.TVStatus.Nodes.Clear()
                Me.Generate_Tree()
                datachanged = False
                Me.dsempfaenger.AcceptChanges()
                Me.On_Load = False
            End If
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.refresh_team Method

Public Sub refresh_team()

Source code

[Visual Basic]
    Public Sub refresh_team()
        Dim tt As New DataTable()
        tt = Generic_Select(7)
        Me.mcbteam.DataSource = Nothing
        Me.mcbteam.Items.Clear()
        If tt.Rows.Count > 1 Then
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = True
        Else
            Me.mcbteam.Fill_Data(tt, False)
            Me.mcbteam.Enabled = False
        End If
        tt.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.save_checkdata Method

Private Function save_checkdata()

Source code

[Visual Basic]
    Private Function save_checkdata()
        Dim tdt As New DataTable("TMPSB_" + Globals.MitarbeiterNr.ToString)
        Dim tdr As DataRow

        Dim i As Integer
        tdt.Columns.Add("Partnernr")
        tdt.Columns.Add("Status")
        tdt.Columns.Add("Rowid")
        tdt.Columns.Add("Fehlercode")

        Dim dv As DataRow()
        Dim DR As DataRow

        dv = Me.dsempfaenger.Tables(0).Select()
        i = 0

        For Each DR In dv
            Dim ii As Integer
            Try
                ii = DR.Item("Status")
            Catch
                ii = 0
            End Try
            If ii < 2 Then
                DR.Item("Status") = -1
                tdr = tdt.NewRow
                If Me.doktyp.bNurnative.Value = False And DR.Item("Partnernr").ToString = "" Then
                    tdr.Item(0) = 0
                    tdr.Item(1) = -1
                    tdr.Item(2) = i
                    tdr.Item(3) = 0
                Else
                    tdr.Item(0) = Val(DR.Item("Partnernr"))
                    tdr.Item(1) = 0
                    tdr.Item(2) = i
                    tdr.Item(3) = 3
                End If
                tdt.Rows.Add(tdr)
            End If
            i = i + 1
        Next

        Dim connection As New SqlConnection()
        Dim da As New SqlDataAdapter("Select * from TMPSB_" + Globals.MitarbeiterNr.ToString, connection)
        Dim cb As New SqlCommandBuilder(da)
        connection.ConnectionString = Globals.sConnectionString
        connection.Open()
        da.Update(tdt)
        connection.Close()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.save_data Method

Private Sub save_data()

Source code

[Visual Basic]
    Private Sub save_data()
        'Neuer Serienbrief speichern

        Try
            Dim iFehlerhaft As Integer
            Dim iInBearbeitung As Integer
            Dim iNichtgeneriert As Integer
            Dim iAusgeloest As Integer
            Dim iErstellt As Integer
            Dim iGedruckt As Integer
            Dim iBestaetigt As Integer

            Dim dv As DataRow()
            Dim DR As DataRow
            dv = Me.dsempfaenger.Tables(0).Select("Status='-1'")
            iFehlerhaft = 0
            For Each DR In dv
                iFehlerhaft = iFehlerhaft + 1
            Next
            iNichtgeneriert = 0
            dv = Me.dsempfaenger.Tables(0).Select("Status='0' or Status=''")
            For Each DR In dv
                iNichtgeneriert = iNichtgeneriert + 1
            Next
            'If NeuerSB Then iNichtgeneriert = iNichtgeneriert - 1

            iAusgeloest = 0
            dv = Me.dsempfaenger.Tables(0).Select("Status='1'")
            For Each DR In dv
                iAusgeloest = iAusgeloest + 1
            Next

            iErstellt = 0
            dv = Me.dsempfaenger.Tables(0).Select("Status='2'")
            For Each DR In dv
                iErstellt = iErstellt + 1
            Next
            iGedruckt = 0
            dv = Me.dsempfaenger.Tables(0).Select("Status='3'")
            For Each DR In dv
                iGedruckt = iGedruckt + 1
            Next
            iBestaetigt = 0
            dv = Me.dsempfaenger.Tables(0).Select("Status='4'")
            For Each DR In dv
                iBestaetigt = iBestaetigt + 1
            Next

            Me.serienbrief.iFehlerhaft = New SqlInt32(CType(iFehlerhaft, Int32))
            Me.serienbrief.iInBearbeitung = New SqlInt32(CType(iNichtgeneriert, Int32))
            Me.serienbrief.iErstellt = New SqlInt32(CType(iErstellt, Int32))
            Me.serienbrief.iGedruckt = New SqlInt32(CType(iGedruckt, Int32))
            Me.serienbrief.iBestaetigt = New SqlInt32(CType(iBestaetigt, Int32))
            Me.serienbrief.iAusgeloest = New SqlInt32(CType(iAusgeloest, Int32))

            If Me.Serienbriefnr = 0 Then
                Me.serienbrief.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
                Me.serienbrief.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
                Me.serienbrief.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
                Me.serienbrief.daDokumentdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
                Me.serienbrief.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
                If Me.RBZustaendigKubedesPartners.Checked = True Then
                    Me.serienbrief.iZustaendig = New SqlInt32(CType(-1, Int32))
                Else
                    Me.serienbrief.iZustaendig = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
                End If
                Me.serienbrief.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
                Me.serienbrief.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
                Me.serienbrief.iTeam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                Me.serienbrief.daArchivdatum = New SqlDateTime(CType(Me.DateTimePicker5.Value, DateTime))
                Try
                    Me.serienbrief.daTermin = New SqlDateTime(CType(Me.C1DateEdit1.Value, DateTime))
                Catch
                End Try
                Me.serienbrief.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
                Me.serienbrief.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
                Me.serienbrief.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
                Me.serienbrief.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                Me.serienbrief.iStatus = New SqlInt32(CType(0, Int32))
                Me.serienbrief.bAktiv = New SqlBoolean(CType(True, Boolean))
                Me.serienbrief.iWindowheight = New SqlInt32(CType(Me.Height, Int32))
                Me.serienbrief.iWindowwidth = New SqlInt32(CType(Me.Width, Int32))
                Me.serienbrief.iTreewidth = New SqlInt32(CType(Me.Panel1.Width, Int32))
                Me.serienbrief.cpMainConnectionProvider = Globals.conn

                Globals.conn.OpenConnection()
                Me.serienbrief.Insert()
                Globals.conn.CloseConnection(True)
                Me.Serienbriefnr = Me.serienbrief.iSerienbriefnr.Value
            Else
                Me.serienbrief.sBezeichnung = New SqlString(CType(Me.txtBezeichnung.Text, String))
                Me.serienbrief.iVerantwortlich = New SqlInt32(CType(Me.mcbverantwortlich.SelectedValue, Int32))
                Me.serienbrief.iPostzustellung = New SqlInt32(CType(Me.mcbpostzustellung.SelectedValue, Int32))
                Me.serienbrief.daDokumentdatum = New SqlDateTime(CType(Me.DateTimePicker1.Value, DateTime))
                Me.serienbrief.iDokumenttypnr = New SqlInt32(CType(Me.Dokumenttypnr, Int32))
                If Me.RBZustaendigKubedesPartners.Checked = True Then
                    Me.serienbrief.iZustaendig = New SqlInt32(CType(-1, Int32))
                Else
                    Me.serienbrief.iZustaendig = New SqlInt32(CType(Me.mcbzust.SelectedValue, Int32))
                End If
                Me.serienbrief.iUnterschriftlinks = New SqlInt32(CType(Me.mcbunterschriftlinks.SelectedValue, Int32))
                Me.serienbrief.iUnterschriftrechts = New SqlInt32(CType(Me.mcbunterschriftrechts.SelectedValue, Int32))
                Me.serienbrief.iTeam = New SqlInt32(CType(Me.mcbteam.SelectedValue, Int32))
                Me.serienbrief.daArchivdatum = New SqlDateTime(CType(Me.DateTimePicker5.Value, DateTime))
                Try
                    Me.serienbrief.daTermin = New SqlDateTime(CType(Me.C1DateEdit1.Value, DateTime))
                Catch
                End Try
                Me.serienbrief.sBemerkung = New SqlString(CType(Me.txtBemerkung.Text, String))
                Me.serienbrief.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
                Me.serienbrief.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
                Me.serienbrief.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                'Me.serienbrief.iStatus = New SqlInt32(CType(0, Int32))
                Me.serienbrief.bAktiv = New SqlBoolean(CType(True, Boolean))
                Me.serienbrief.cpMainConnectionProvider = Globals.conn
                Me.serienbrief.iWindowheight = New SqlInt32(CType(Me.Height, Int32))
                Me.serienbrief.iWindowwidth = New SqlInt32(CType(Me.Width, Int32))
                Me.serienbrief.iTreewidth = New SqlInt32(CType(Me.Panel1.Width, Int32))
                Globals.conn.OpenConnection()
                Me.serienbrief.Update()
                Globals.conn.CloseConnection(True)
            End If
            Me.dsempfaenger.AcceptChanges()
            Me.save_empfaenger()
            Me.datachanged = False
            Me.StatusBar1.Text = MyTxt.gettext(720)
            Me.statustimer.Enabled = True
            '            If Me.ShowSaveMessage Then MyMsg.show_standardmessage(720, MsgBoxStyle.Information)
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.save_empfaenger Method

Private Function save_empfaenger() As Boolean

Source code

[Visual Basic]
    Private Function save_empfaenger() As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.Serienbriefnr.ToString + "_empfaenger.xml"
            Try
                If Me.dsempfaenger.Tables(0).Rows.Count > 0 Then Me.dsempfaenger.Tables(0).TableName = "empfdatatable"
            Catch
            End Try
            Me.dsempfaenger.WriteXml(dokumentname)
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_empfaenger where serienbriefnr=" + Str(Me.Serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    'Neue Serienbrief_Empfaenger speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(1) = Me.Serienbriefnr
                    myRow.Item(2) = mydata
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "empf")
                Else
                    ' Bestehende Empfängerliste überschreiben
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(2) = mydata
                    DA.Update(ds, "empf")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(700, MsgBoxStyle.Critical)
                Return False
            Finally
                File.Delete(dokumentname)
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(700, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.serienbrief_abschliessen Method

Private Function serienbrief_abschliessen()

Source code

[Visual Basic]
    Private Function serienbrief_abschliessen()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_serienbrief_abschliessen "
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@serienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Serienbriefnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@manr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.set_columnorder Method

Private Function set_columnorder( _
   ByRef dt As DataTable _
) As DataTable

Parameters

dt
Required.

Source code

[Visual Basic]
    Private Function set_columnorder(ByRef dt As DataTable) As DataTable
        Dim dn As New DataTable()
        Check_Column("Partnernr", dn)
        Check_Column("Kurzbezeichnung", dn)
        Check_Column("Name", dn)
        Check_Column("Vorname", dn)
        Check_Column("Strasse", dn)
        Check_Column("PLZ", dn)
        Check_Column("Ort", dn)
        Check_Column("Zustelladresse", dn)
        Check_Column("Briefanrede1", dn)
        Check_Column("Briefanrede2", dn)
        Check_Column("Anrede", dn)
        Check_Column("STATUS", dn)
        Check_Column("FEHLERCODE", dn)
        Check_Column("DOKUMENTIDBDR", dn)
        Check_Column("ERSTELLER", dn)
        Check_Column("DRUCKJOBID", dn)
        Check_Column("BLKUNDE", dn)
        Check_Column("DOKUMENT_GEDRUCKT", dn)
        Check_Column("AKTIV", dn)
        Check_Column("DOKUMENTID", dn)

        Dim i As Integer
        Dim i1 As Integer
        For i = 0 To dt.Columns.Count - 1
            Check_Column(dt.Columns(i).ColumnName, dn)
        Next

        For i = 0 To dt.Rows.Count - 1
            Dim myRow As DataRow
            myRow = dn.NewRow
            For i1 = 0 To dt.Columns.Count - 1
                myRow.Item(dt.Columns(i1).ColumnName) = dt.Rows(i).Item(i1)
            Next
            myRow.Item("Status") = 0
            dn.Rows.Add(myRow)
        Next
        Return dn
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.set_druckjobstatus Method

Private Function set_druckjobstatus( _
   ByVal status As Integer, _
   ByVal printjobnr As Integer _
) As DataTable

Parameters

status
Required.
printjobnr
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus(ByVal status As Integer, ByVal printjobnr As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "sp_edex_sb_set_druckjobstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@druckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, printjobnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.set_gedruckt Method

Private Sub set_gedruckt( _
   ByVal druckjobid As String _
)

Parameters

druckjobid
Required.

Source code

[Visual Basic]
    Private Sub set_gedruckt(ByVal druckjobid As String)
        Dim druckjobname As String
        druckjobname = ""
        If druckjobid <> "" Then
            druckjobname = get_druckjobname(druckjobid)
        End If

        Dim dr As DataRow()
        Dim dr1 As DataRow
        If druckjobname <> "" Then
            dr = Me.dsempfaenger.Tables(0).Select("Druckjobid='" + druckjobname + "'")
        Else
            dr = Me.dsempfaenger.Tables(0).Select("Status='2'")
        End If
        For Each dr1 In dr
            dr1.Item("Status") = 3
        Next
        Me.save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.set_headerbookmark Method

Private Sub set_headerbookmark()

Source code

[Visual Basic]
    Private Sub set_headerbookmark()
        Try
            objword.ActiveDocument.Bookmarks.Item("TGEDKCompanyBBEB99").Select()
        Catch
            objword.Selection.MoveDown(Unit:=Word.WdUnits.wdLine, Count:=1)
            With objword.ActiveDocument.Bookmarks
                .Add(Range:=objword.Selection.Range, Name:="TGEDKCompanyBBEB99")
                .DefaultSorting = Word.WdBookmarkSortBy.wdSortByName
                .ShowHidden = False
            End With
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.statustimer_Tick Method

Private Sub statustimer_Tick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles statustimer.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub statustimer_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles statustimer.Tick
        Me.statustimer.Enabled = False
        Me.StatusBar1.Text = ""
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe.txtBezeichnung_TextChanged Method

Private Sub txtBezeichnung_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtBezeichnung.TextChanged, _
   mcbpostzustellung.TextChanged, _
   mcbteam.TextChanged, _
   mcbunterschriftlinks.TextChanged, _
   mcbunterschriftrechts.TextChanged, _
   mcbzust.TextChanged, _
   RBZustaendigKubedesPartners.CheckedChanged, _
   RBZustaendigZustaendiger.CheckedChanged, _
   DateTimePicker6.ValueChanged, _
   txtBemerkung.TextChanged, _
   mcbverantwortlich.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtBezeichnung_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtBezeichnung.TextChanged, mcbpostzustellung.TextChanged, mcbteam.TextChanged, mcbunterschriftlinks.TextChanged, mcbunterschriftrechts.TextChanged, mcbzust.TextChanged, RBZustaendigKubedesPartners.CheckedChanged, RBZustaendigZustaendiger.CheckedChanged, DateTimePicker6.ValueChanged, txtBemerkung.TextChanged, mcbverantwortlich.TextChanged
        If Not On_Load Then
            Me.datachanged = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe Fields

frmSerienbriefe overview

Fields

field BarTextIn
field BarTextOut
field BtnHelp
field C1Command1
field C1CommandHolder1
field C1CommandLink1
field C1CommandLink11
field C1CommandLink12
field C1CommandLink14
field C1CommandLink15
field C1CommandLink17
field C1CommandLink18
field C1CommandLink19
field C1CommandLink2
field C1CommandLink20
field C1CommandLink21
field C1CommandLink22
field C1CommandLink23
field C1CommandLink24
field C1CommandLink25
field C1CommandLink26
field C1CommandLink27
field C1CommandLink3
field C1CommandLink4
field C1CommandMenu1
field C1ContextMenu1
field C1ContextMenu2
field C1DateEdit1
field C1DateEdit2
field C1MainMenu1
field C1MnuIndividuelleDokumentwerte
field C1MnuMainAddColumn
field C1MnuMainDatei
field C1MnuMainDeleteColumn
field C1MnuMainDokument
field C1MnuMainEmpfaengerliste
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuPersSbLoad
field C1MnuSerienbriefLoeschen
field C1mnuPartnerdossier
field C1mnuPersVorlageSave
field CharValue
field CheckSum
field CurrentColumn
field CurrentPartnerbezeichnung
field CurrentPartnernr
field DateTimePicker1
field DateTimePicker2
field DateTimePicker3
field DateTimePicker4
field DateTimePicker5
field DateTimePicker6
field DoCheckSum
field Dokumenttypnr
field GenerierteDokumente
field GroupBox1
field GroupBox12
field GroupBox2
field GroupBox3
field GroupBox5
field GroupBox8
field II
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field Label1
field Label10
field Label11
field Label12
field Label13
field Label14
field Label16
field Label17
field Label18
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field MenuEmpfaenger
field MenuItem10
field MenuItem12
field MenuItem14
field MenuItem23
field MenuNotiz
field MnuDeleteEmpfaenger
field MnuDeleteNotiz
field MnuEditEmpfaenger
field MnuEditNotiz
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEDOKAPartnerErfassen
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field MnuNeueNotiz
field MnuSpaltenSelektion
field Notizen
field Notizlist
field On_Fill
field On_Load
field OpenFileDialog1
field OpenForPrinting
field Panel1
field Panel2
field RBZustaendigKubedesPartners
field RBZustaendigZustaendiger
field SaveFileDialog1
field Serienbriefnr
field ShowSaveMessage
field Splitter1
field StatusBar1
field Sum
field TVStatus
field TabControl1
field TabPage1
field TabPage2
field TempString
field TextBox1
field TextBox10
field TextBox2
field Textboxes
field Textboxesi
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton11
field ToolBarButton12
field ToolBarButton13
field ToolBarButton14
field ToolBarButton15
field ToolBarButton16
field ToolBarButton17
field ToolBarButton18
field ToolBarButton19
field ToolBarButton2
field ToolBarButton20
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field barcodeout
field beginntextmarke
field blkunde
field c1mnumainpreview
field c1mnupartner1
field c1mnupartner2
field c1mnupartner3
field cbPostzustellung
field cbUnterschriftlinks
field cbUnterschriftrechts
field cbVerantwortlich
field cbteam
field cbzust
field clsempf
field components
field datachanged
field dokid
field doktyp
field drpMiatarbeiter
field druckjobs
field dsempfaenger
field dtstatus
field empflist
field endetextmarke
field feldname
field mcbpostzustellung
field mcbteam
field mcbunterschriftlinks
field mcbunterschriftrechts
field mcbverantwortlich
field mcbzust
field mnuAddEmpfaenger
field mnuCTADDEdokapartner
field mnuaddhost
field mnuc2abschliessen
field mnuc2bestaetigen
field mnuc2generieren
field mnuc2partnerlistepruefen
field mnuc2printjob
field mnuc2printmenu
field mnuc2printpreview
field mnuctAddHost
field mnuctErstellungWiederholen
field mnuctaddempfaenger
field mnuidvspalteumbenennen
field mnuidwspalteentfernen
field mnuidwspaltehinzufuegen
field mnunewedoka
field mnunewempfaenger
field mnusaveasedokapartner
field objword
field officevorlage
field pdfprinter
field printsbnr
field progress
field progressvisible
field reservedwords
field save_DSInit
field save_verantwortlich
field selectPoint
field serienbrief
field serienbrief_notizen
field statustimer
field teamzustaendig
field txtBemerkung
field txtBezeichnung
field vorlagendaten

See Also

frmSerienbriefe Class


BarTextIn Variable

Private BarTextIn As String

Source code

[Visual Basic]
    Private BarTextIn As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


BarTextOut Variable

Private BarTextOut As String

Source code

[Visual Basic]
    Private BarTextOut As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1Command1 Variable

Friend WithEvents C1Command1 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents C1Command1 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandHolder1 Variable

Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Source code

[Visual Basic]
    Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink1 Variable

Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink11 Variable

Friend WithEvents C1CommandLink11 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink11 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink12 Variable

Friend WithEvents C1CommandLink12 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink12 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink14 Variable

Friend WithEvents C1CommandLink14 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink14 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink15 Variable

Friend WithEvents C1CommandLink15 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink15 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink17 Variable

Friend WithEvents C1CommandLink17 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink17 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink18 Variable

Friend WithEvents C1CommandLink18 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink18 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink19 Variable

Friend WithEvents C1CommandLink19 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink19 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink2 Variable

Friend WithEvents C1CommandLink2 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink2 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink20 Variable

Friend WithEvents C1CommandLink20 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink20 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink21 Variable

Friend WithEvents C1CommandLink21 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink21 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink22 Variable

Friend WithEvents C1CommandLink22 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink22 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink23 Variable

Friend WithEvents C1CommandLink23 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink23 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink24 Variable

Friend WithEvents C1CommandLink24 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink24 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink25 Variable

Friend WithEvents C1CommandLink25 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink25 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink26 Variable

Friend WithEvents C1CommandLink26 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink26 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink27 Variable

Friend WithEvents C1CommandLink27 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink27 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink3 Variable

Friend WithEvents C1CommandLink3 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink3 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandLink4 Variable

Friend WithEvents C1CommandLink4 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink4 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1CommandMenu1 Variable

Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1ContextMenu1 Variable

Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Source code

[Visual Basic]
    Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1ContextMenu2 Variable

Friend WithEvents C1ContextMenu2 As C1.Win.C1Command.C1ContextMenu

Source code

[Visual Basic]
    Friend WithEvents C1ContextMenu2 As C1.Win.C1Command.C1ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1DateEdit1 Variable

Friend WithEvents C1DateEdit1 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents C1DateEdit1 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1DateEdit2 Variable

Friend WithEvents C1DateEdit2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents C1DateEdit2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MainMenu1 Variable

Friend WithEvents C1MainMenu1 As C1.Win.C1Command.C1MainMenu

Source code

[Visual Basic]
    Friend WithEvents C1MainMenu1 As C1.Win.C1Command.C1MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuIndividuelleDokumentwerte Variable

Friend WithEvents C1MnuIndividuelleDokumentwerte As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuIndividuelleDokumentwerte As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainAddColumn Variable

Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainDatei Variable

Friend WithEvents C1MnuMainDatei As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDatei As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainDeleteColumn Variable

Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainDokument Variable

Friend WithEvents C1MnuMainDokument As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDokument As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainEmpfaengerliste Variable

Friend WithEvents C1MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainExportEmpfaenger Variable

Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainFensterSchliessen Variable

Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainImportEmpfaneger Variable

Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainLoadPartnerliste Variable

Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainNeuerSerienbrief Variable

Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainRenameColumn Variable

Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainSaveAsPartnerlist Variable

Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainSerienbriefLaden Variable

Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainSerienbriefSpeichern Variable

Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainSerienbriefabschliessen Variable

Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainSpaltenselektion Variable

Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainVorlageBearbeiten Variable

Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuMainVorlageImportieren Variable

Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuPersSbLoad Variable

Friend WithEvents C1MnuPersSbLoad As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents C1MnuPersSbLoad As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1MnuSerienbriefLoeschen Variable

Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1mnuPartnerdossier Variable

Friend WithEvents C1mnuPartnerdossier As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents C1mnuPartnerdossier As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


C1mnuPersVorlageSave Variable

Friend WithEvents C1mnuPersVorlageSave As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents C1mnuPersVorlageSave As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


CharValue Variable

Private CharValue As Long

Source code

[Visual Basic]
    Private CharValue As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


CheckSum Variable

Private CheckSum As Integer

Source code

[Visual Basic]
    Private CheckSum As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


CurrentColumn Variable

Dim CurrentColumn As Integer

Source code

[Visual Basic]
    Dim CurrentColumn As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


CurrentPartnerbezeichnung Variable

Dim CurrentPartnerbezeichnung As String

Source code

[Visual Basic]
    Dim CurrentPartnerbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


CurrentPartnernr Variable

Dim CurrentPartnernr As Integer

Source code

[Visual Basic]
    Dim CurrentPartnernr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As C1.Win.C1Input.C1DateEdit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker3 Variable

Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker3 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker4 Variable

Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker4 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker5 Variable

Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker5 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DateTimePicker6 Variable

Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker6 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


DoCheckSum Variable

Private DoCheckSum As Integer

Source code

[Visual Basic]
    Private DoCheckSum As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Dokumenttypnr Variable

Dim Dokumenttypnr As Integer = 0

Source code

[Visual Basic]
    Dim Dokumenttypnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GenerierteDokumente Variable

Dim GenerierteDokumente As New Collection()

Source code

[Visual Basic]
    Dim GenerierteDokumente As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox12 Variable

Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox12 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox5 Variable

Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox5 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


GroupBox8 Variable

Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox8 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


II Variable

Private II As Integer

Source code

[Visual Basic]
    Private II As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ImageList4 Variable

Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label13 Variable

Friend WithEvents Label13 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label13 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuEmpfaenger Variable

Friend WithEvents MenuEmpfaenger As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MenuEmpfaenger As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuItem23 Variable

Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MenuNotiz Variable

Friend WithEvents MenuNotiz As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MenuNotiz As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuDeleteEmpfaenger Variable

Friend WithEvents MnuDeleteEmpfaenger As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteEmpfaenger As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuDeleteNotiz Variable

Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDeleteNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuEditEmpfaenger Variable

Friend WithEvents MnuEditEmpfaenger As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditEmpfaenger As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuEditNotiz Variable

Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuEditNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainAbschluss Variable

Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainAddColumn Variable

Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainAddEDOKAHOSTPartner Variable

Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainCheckEmpfaenger Variable

Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainClose Variable

Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDatei Variable

Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDeleteColumn Variable

Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDokument Variable

Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDokumenteBestaetigen Variable

Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDokumenteDrucken Variable

Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainDokumenteGenerieren Variable

Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainEDOKAPartnerErfassen Variable

Friend WithEvents MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainEmfpaengerLoeschen Variable

Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainEmpfaengerBearbeiten Variable

Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainEmpfaengerliste Variable

Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainExportEmpfaenger Variable

Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainImportEmpfaenger Variable

Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainLoad Variable

Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainLoadPartnerliste Variable

Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainNeuerEDOKAPartnerErfassen Variable

Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainNeuerEmpfaengerErfassen Variable

Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainNew Variable

Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainRenameColumn Variable

Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainSave Variable

Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainSaveAsPartnerlist Variable

Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainSerienbriefLoeschen Variable

Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainSpaltenselektion Variable

Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainVorageBearbeiten Variable

Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainVorlageImportieren Variable

Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuMainVorschauErstellen Variable

Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuNeueNotiz Variable

Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeueNotiz As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


MnuSpaltenSelektion Variable

Friend WithEvents MnuSpaltenSelektion As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuSpaltenSelektion As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Notizen Variable

Dim Notizen As New DataTable()

Source code

[Visual Basic]
    Dim Notizen As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


On_Fill Variable

Dim On_Fill As Boolean = False

Source code

[Visual Basic]
    Dim On_Fill As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


OpenForPrinting Variable

Dim OpenForPrinting As Boolean = False

Source code

[Visual Basic]
    Dim OpenForPrinting As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


RBZustaendigKubedesPartners Variable

Friend WithEvents RBZustaendigKubedesPartners As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigKubedesPartners As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


RBZustaendigZustaendiger Variable

Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBZustaendigZustaendiger As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


SaveFileDialog1 Variable

Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Source code

[Visual Basic]
    Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Serienbriefnr Variable

Dim Serienbriefnr As Integer = 0

Source code

[Visual Basic]
    Dim Serienbriefnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ShowSaveMessage Variable

Dim ShowSaveMessage As Boolean = True

Source code

[Visual Basic]
    Dim ShowSaveMessage As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Sum Variable

Private Sum As Long

Source code

[Visual Basic]
    Private Sum As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TVStatus Variable

Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TempString Variable

Private TempString As String

Source code

[Visual Basic]
    Private TempString As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Textboxes Variable

Dim Textboxes( _
   100 _
) As String

Source code

[Visual Basic]
    Dim Textboxes(100) As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


Textboxesi Variable

Dim Textboxesi As Integer

Source code

[Visual Basic]
    Dim Textboxesi As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton10 Variable

Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton11 Variable

Friend WithEvents ToolBarButton11 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton11 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton12 Variable

Friend WithEvents ToolBarButton12 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton12 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton13 Variable

Friend WithEvents ToolBarButton13 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton13 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton14 Variable

Friend WithEvents ToolBarButton14 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton14 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton15 Variable

Friend WithEvents ToolBarButton15 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton15 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton16 Variable

Friend WithEvents ToolBarButton16 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton16 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton17 Variable

Friend WithEvents ToolBarButton17 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton17 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton18 Variable

Friend WithEvents ToolBarButton18 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton18 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton19 Variable

Friend WithEvents ToolBarButton19 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton19 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton20 Variable

Friend WithEvents ToolBarButton20 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton20 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton8 Variable

Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


ToolBarButton9 Variable

Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


barcodeout Variable

Private barcodeout

Source code

[Visual Basic]
    Private barcodeout

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


beginntextmarke Variable

Dim beginntextmarke As String

Source code

[Visual Basic]
    Dim beginntextmarke As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


blkunde Variable

Dim blkunde As String = ""

Source code

[Visual Basic]
    Dim blkunde As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


c1mnumainpreview Variable

Friend WithEvents c1mnumainpreview As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnumainpreview As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


c1mnupartner1 Variable

Friend WithEvents c1mnupartner1 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner1 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


c1mnupartner2 Variable

Friend WithEvents c1mnupartner2 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner2 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


c1mnupartner3 Variable

Friend WithEvents c1mnupartner3 As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1mnupartner3 As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbPostzustellung Variable

Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPostzustellung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbUnterschriftlinks Variable

Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftlinks As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbUnterschriftrechts Variable

Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbUnterschriftrechts As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbteam Variable

Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbteam As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


cbzust Variable

Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbzust As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


clsempf Variable

Dim clsempf As clsEmpfaengerdata

Source code

[Visual Basic]
    Dim clsempf As clsEmpfaengerdata

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


datachanged Variable

Dim datachanged As Boolean

Source code

[Visual Basic]
    Dim datachanged As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


dokid Variable

Dim dokid As String

Source code

[Visual Basic]
    Dim dokid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


doktyp Variable

Dim doktyp As New edokadb.clsDokumenttyp()

Source code

[Visual Basic]
    Dim doktyp As New edokadb.clsDokumenttyp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


druckjobs Variable

Dim druckjobs As New DataTable()

Source code

[Visual Basic]
    Dim druckjobs As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


dsempfaenger Variable

Dim dsempfaenger As New DataSet()

Source code

[Visual Basic]
    Dim dsempfaenger As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


dtstatus Variable

Dim dtstatus As New DataTable()

Source code

[Visual Basic]
    Dim dtstatus As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


empflist Variable

Friend WithEvents empflist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents empflist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


endetextmarke Variable

Dim endetextmarke As String

Source code

[Visual Basic]
    Dim endetextmarke As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


feldname Variable

Dim feldname As String

Source code

[Visual Basic]
    Dim feldname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbpostzustellung Variable

Dim WithEvents mcbpostzustellung As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbpostzustellung As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbteam Variable

Dim WithEvents mcbteam As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbteam As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbunterschriftlinks Variable

Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftlinks As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbunterschriftrechts Variable

Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbunterschriftrechts As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mcbzust Variable

Dim WithEvents mcbzust As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbzust As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuAddEmpfaenger Variable

Friend WithEvents mnuAddEmpfaenger As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuAddEmpfaenger As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuCTADDEdokapartner Variable

Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuaddhost Variable

Friend WithEvents mnuaddhost As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuaddhost As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2abschliessen Variable

Friend WithEvents mnuc2abschliessen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2abschliessen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2bestaetigen Variable

Friend WithEvents mnuc2bestaetigen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2bestaetigen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2generieren Variable

Friend WithEvents mnuc2generieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2generieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2partnerlistepruefen Variable

Friend WithEvents mnuc2partnerlistepruefen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2partnerlistepruefen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2printjob Variable

Friend WithEvents mnuc2printjob As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2printjob As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2printmenu Variable

Friend WithEvents mnuc2printmenu As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents mnuc2printmenu As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuc2printpreview Variable

Friend WithEvents mnuc2printpreview As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuc2printpreview As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuctAddHost Variable

Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuctErstellungWiederholen Variable

Friend WithEvents mnuctErstellungWiederholen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctErstellungWiederholen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuctaddempfaenger Variable

Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuidvspalteumbenennen Variable

Friend WithEvents mnuidvspalteumbenennen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuidvspalteumbenennen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuidwspalteentfernen Variable

Friend WithEvents mnuidwspalteentfernen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuidwspalteentfernen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnuidwspaltehinzufuegen Variable

Friend WithEvents mnuidwspaltehinzufuegen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuidwspaltehinzufuegen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnunewedoka Variable

Friend WithEvents mnunewedoka As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnunewedoka As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnunewempfaenger Variable

Friend WithEvents mnunewempfaenger As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnunewempfaenger As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


mnusaveasedokapartner Variable

Friend WithEvents mnusaveasedokapartner As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnusaveasedokapartner As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


objword Variable

Dim objword As Word.ApplicationClass

Source code

[Visual Basic]
    Dim objword As Word.ApplicationClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


officevorlage Variable

Dim officevorlage As New edokadb.clsOffice_vorlage()

Source code

[Visual Basic]
    Dim officevorlage As New edokadb.clsOffice_vorlage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


pdfprinter Variable

Dim WithEvents pdfprinter As frmSBPDFPrinter

Source code

[Visual Basic]
    Dim WithEvents pdfprinter As frmSBPDFPrinter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


printsbnr Variable

Dim printsbnr As Integer

Source code

[Visual Basic]
    Dim printsbnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


progress Variable

Dim progress As New ucProgress()

Source code

[Visual Basic]
    Dim progress As New ucProgress()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


progressvisible Variable

Dim progressvisible As Boolean = False

Source code

[Visual Basic]
    Dim progressvisible As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


reservedwords Variable

Dim reservedwords As New Collection()

Source code

[Visual Basic]
    Dim reservedwords As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


save_DSInit Variable

Dim save_DSInit As New DataTable()

Source code

[Visual Basic]
    Dim save_DSInit As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


save_verantwortlich Variable

Dim save_verantwortlich As Integer = 0

Source code

[Visual Basic]
    Dim save_verantwortlich As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


serienbrief Variable

Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()

Source code

[Visual Basic]
    Dim serienbrief As New edokadb.clsEdex_sb_serienbrief()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


serienbrief_notizen Variable

Dim serienbrief_notizen As New edokadb.clsEdex_sb_notizen()

Source code

[Visual Basic]
    Dim serienbrief_notizen As New edokadb.clsEdex_sb_notizen()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


statustimer Variable

Friend WithEvents statustimer As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents statustimer As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


teamzustaendig Variable

Dim teamzustaendig As Integer

Source code

[Visual Basic]
    Dim teamzustaendig As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


txtBezeichnung Variable

Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


vorlagendaten Variable

Dim vorlagendaten As New DataTable()

Source code

[Visual Basic]
    Dim vorlagendaten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe_Load Class

For a list of all members of this type, see frmSerienbriefe_Load Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSerienbriefe_Load

Public Class frmSerienbriefe_Load
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSerienbriefe_Load Members


frmSerienbriefe_Load Members

frmSerienbriefe_Load overview

Constructors

constructor frmSerienbriefe_Load Constructor

Properties

property Serienbriefnr

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method Load_Serienbriefe
method frmSerienbriefe_Load_Load
method sblist_DoubleClick
method sblist_RowColChange

Fields

field Button1
field Button2
field GroupBox1
field ListBox1
field Panel1
field Panel2
field Panel3
field TVStatus
field components
field m_serienbriefnr
field sblist

See Also

frmSerienbriefe_Load Class


frmSerienbriefe_Load Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load Properties

frmSerienbriefe_Load overview

Properties

property Serienbriefnr

See Also

frmSerienbriefe_Load Class


frmSerienbriefe_Load.Serienbriefnr Property

Property Serienbriefnr() As Integer

Source code

[Visual Basic]
    Property Serienbriefnr() As Integer
        Get
            Return m_serienbriefnr
        End Get
        Set(ByVal Value As Integer)
            m_serienbriefnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load Methods

frmSerienbriefe_Load overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method Load_Serienbriefe
method frmSerienbriefe_Load_Load
method sblist_DoubleClick
method sblist_RowColChange

See Also

frmSerienbriefe_Load Class


frmSerienbriefe_Load.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            Me.Serienbriefnr = Me.sblist.Columns(0).Value
        Catch
            Exit Sub
        End Try

        'Me.Serienbriefnr = Me.ListBox1.SelectedValue
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.Serienbriefnr = -1
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSerienbriefe_Load))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.TVStatus = New System.Windows.Forms.TreeView()
        Me.sblist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Panel1.SuspendLayout()
        Me.Panel2.SuspendLayout()
        Me.Panel3.SuspendLayout()
        CType(Me.sblist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox1.SuspendLayout()
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(176, 448)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(368, 30)
        Me.ListBox1.TabIndex = 0
        '
        'Button1
        '
        Me.Button1.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.Button1.Location = New System.Drawing.Point(688, 16)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&OK"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(8, 16)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 2
        Me.Button2.Text = "&Abbruch"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel1.Location = New System.Drawing.Point(0, 253)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(768, 48)
        Me.Panel1.TabIndex = 28
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.sblist})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(528, 253)
        Me.Panel2.TabIndex = 29
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TVStatus})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel3.Location = New System.Drawing.Point(3, 16)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(234, 234)
        Me.Panel3.TabIndex = 30
        '
        'TVStatus
        '
        Me.TVStatus.BackColor = System.Drawing.Color.FromArgb(CType(255, Byte), CType(255, Byte), CType(192, Byte))
        Me.TVStatus.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TVStatus.ImageIndex = -1
        Me.TVStatus.Name = "TVStatus"
        Me.TVStatus.SelectedImageIndex = -1
        Me.TVStatus.Size = New System.Drawing.Size(234, 234)
        Me.TVStatus.TabIndex = 1
        '
        'sblist
        '
        Me.sblist.AllowFilter = True
        Me.sblist.AllowSort = True
        Me.sblist.AllowUpdate = False
        Me.sblist.AllowUpdateOnBlur = False
        Me.sblist.AlternatingRows = True
        Me.sblist.CaptionHeight = 17
        Me.sblist.CollapseColor = System.Drawing.Color.Black
        Me.sblist.Cursor = System.Windows.Forms.Cursors.Default
        Me.sblist.DataChanged = False
        Me.sblist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.sblist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.sblist.ExpandColor = System.Drawing.Color.Black
        Me.sblist.FetchRowStyles = True
        Me.sblist.FilterBar = True
        Me.sblist.GroupByCaption = "Drag a column header here to group by that column"
        Me.sblist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.sblist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.sblist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.sblist.Name = "sblist"
        Me.sblist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.sblist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.sblist.PreviewInfo.ZoomFactor = 75
        Me.sblist.PrintInfo.ShowOptionsDialog = False
        Me.sblist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.sblist.RowDivider = GridLines1
        Me.sblist.RowHeight = 15
        Me.sblist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.sblist.ScrollTips = True
        Me.sblist.Size = New System.Drawing.Size(528, 253)
        Me.sblist.TabIndex = 29
        Me.sblist.Text = "C1TrueDBGrid1"
        Me.sblist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Wrap" & _
        ":True;Trimming:None;BackColor:White;}Selected{ForeColor:HighlightText;BackColor:" & _
        "Highlight;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeCol" & _
        "or:ControlText;AlignVert:Center;}Inactive{ForeColor:InactiveCaptionText;BackColo" & _
        "r:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:" & _
        "Center;}Editor{}Normal{Wrap:True;BackColor:Control;}Style27{}Style26{}HighlightR" & _
        "ow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}OddRow{Wrap:True;AlignHo" & _
        "rz:General;BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Style9{}St" & _
        "yle8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:C" & _
        "ontrolDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AllowRowSizing=""IndividualRows"" AlternatingRowStyle=""True"" Ca" & _
        "ptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles" & _
        "=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16" & _
        """ DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientR" & _
        "ect>0, 0, 524, 249</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""H" & _
        "eading"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle " & _
        "parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /" & _
        "><FooterStyle parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style" & _
        "12"" /><HeadingStyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""Hi" & _
        "ghlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRow" & _
        "Style parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector""" & _
        " me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""No" & _
        "rmal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style" & _
        " parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""He" & _
        "ading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Headi" & _
        "ng"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal" & _
        """ me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal" & _
        """ me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me" & _
        "=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Capti" & _
        "on"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSpli" & _
        "ts><Layout>Modified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 524, 249</ClientArea></Blob>"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.GroupBox1.Location = New System.Drawing.Point(528, 0)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(240, 253)
        Me.GroupBox1.TabIndex = 31
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Details zum Serienbrief"
        '
        'frmSerienbriefe_Load
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(768, 301)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.Panel2, Me.Panel1, Me.ListBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSerienbriefe_Load"
        Me.Text = "Serienbrief laden"
        Me.Panel1.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        CType(Me.sblist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox1.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.ListBox1_DoubleClick Method

Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Me.Button1_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.Load_Serienbriefe Method

Private Function Load_Serienbriefe() As DataTable

Source code

[Visual Basic]
    Private Function Load_Serienbriefe() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_serienbriefe"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.frmSerienbriefe_Load_Load Method

Private Sub frmSerienbriefe_Load_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSerienbriefe_Load_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim dt As New DataTable()
        dt = Load_Serienbriefe()
        Me.sblist.DataSource = dt
        Me.sblist.DataMember = dt.TableName
        Me.sblist.Splits(0).DisplayColumns(0).Visible = False
        Dim i As Integer
        For i = 5 To Me.sblist.Splits(0).DisplayColumns.Count - 1
            Me.sblist.Splits(0).DisplayColumns(i).Visible = False
        Next
        'Me.sblist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.IndividualRows
        Me.sblist.Splits(0).DisplayColumns(1).Width = 170
        Me.sblist.Splits(0).DisplayColumns(2).Width = 80
        Me.sblist.Splits(0).DisplayColumns(3).Width = 120
        Me.sblist.Splits(0).DisplayColumns(4).Width = 100

        For i = 0 To Me.sblist.Splits(0).Rows.Count - 1
            Me.sblist.Splits(0).Rows(i).AutoSize()
        Next
        If dt.Rows.Count < 1 Then
            Me.Button1.Enabled = False
        End If
        '        Me.sblist.Columns("Status").FilterText = "in Bearbeitung"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.sblist_DoubleClick Method

Private Sub sblist_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles sblist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub sblist_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles sblist.DoubleClick
        Try
            Me.Button1_Click(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load.sblist_RowColChange Method

Private Sub sblist_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles sblist.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub sblist_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles sblist.RowColChange
        Try
            Me.TVStatus.BeginUpdate()
            Me.TVStatus.Nodes.Clear()
            Dim tn As New TreeNode()
            Dim tn1 As New TreeNode()
            Dim tn2 As New TreeNode()

            Dim iFehlerhaft As Integer
            Dim iInBearbeitung As Integer
            Dim iNichtgeneriert As Integer
            Dim iAusgeloest As Integer
            Dim iErstellt As Integer
            Dim iGedruckt As Integer
            Dim iBestaetigt As Integer

            iFehlerhaft = Me.sblist.Columns("fehlerhaft").Value
            iNichtgeneriert = Me.sblist.Columns("inBearbeitung").Value
            iAusgeloest = Me.sblist.Columns("ausgeloest").Value
            iErstellt = Me.sblist.Columns("erstellt").Value
            iGedruckt = Me.sblist.Columns("gedruckt").Value
            iBestaetigt = Me.sblist.Columns("bestaetigt").Value

            tn = Me.TVStatus.Nodes.Add(Me.sblist.Columns(1).Text)

            tn.SelectedImageIndex = 0
            tn.ImageIndex = -99
            tn.Tag = -3
            If Me.sblist.Columns("sbstatus").Value > 0 Then
                tn1 = tn.Nodes.Add("in Bearbeitung (0)")
            Else
                tn1 = tn.Nodes.Add("in Bearbeitung (" + Str(iFehlerhaft + iNichtgeneriert + iErstellt + iGedruckt + iBestaetigt).Trim + ")")
            End If

            tn1.Tag = -9
            tn1.SelectedImageIndex = 0
            tn1.ImageIndex = -99
            If Me.sblist.Columns("sbstatus").Value > 0 Then
                tn1 = tn.Nodes.Add("Dokumentgenerierung ausgelöst " + "(" + Str(iAusgeloest).Trim + ")")
                tn1.Tag = 1
                tn1.SelectedImageIndex = 0
                tn1.ImageIndex = -99
                tn1 = tn.Nodes.Add("Abgeschlossen (" + Str(iFehlerhaft + iNichtgeneriert + iErstellt + iGedruckt + iBestaetigt).Trim + ")")
                tn1.Tag = -4
                tn1.SelectedImageIndex = 0
                tn1.ImageIndex = -99
            End If
            tn2 = tn1.Nodes.Add("Fehlerhaft " + "(" + Str(iFehlerhaft).Trim + ")")
            tn2.Tag = -1
            tn2.SelectedImageIndex = 0
            tn2.ImageIndex = -99
            tn2 = tn1.Nodes.Add("Empfänger in Bearbeitung " + "(" + Str(iNichtgeneriert).Trim + ")")
            tn2.Tag = 0
            tn2.SelectedImageIndex = 0
            tn2.ImageIndex = -99
            tn2 = tn1.Nodes.Add("Dokumente erstellt " + "(" + Str(iErstellt).Trim + ")")
            tn2.Tag = 2
            tn2.SelectedImageIndex = 0
            tn2.ImageIndex = -99

            tn2 = tn1.Nodes.Add("Dokumente gedruckt " + "(" + Str(iGedruckt).Trim + ")")
            tn2.Tag = 3
            tn2.SelectedImageIndex = 0
            tn2.ImageIndex = -99

            tn2 = tn1.Nodes.Add("Dokumente bestätigt " + "(" + Str(iBestaetigt).Trim + ")")
            tn2.Tag = 4
            tn2.SelectedImageIndex = 0
            tn2.ImageIndex = -99
            Me.TVStatus.ExpandAll()
            If Me.sblist.Columns("sbstatus").Value < 1 Then
                tn1 = tn.Nodes.Add("Dokumentgenerierung ausgelöst " + "(" + Str(iAusgeloest).Trim + ")")
                tn1.Tag = 1
                tn1.SelectedImageIndex = 0
                tn1.ImageIndex = -99
                tn1 = tn.Nodes.Add("Abgeschlossen")
                tn1.Tag = -4
                tn1.SelectedImageIndex = 0
                tn1.ImageIndex = -99

            End If
        Catch
        Finally
            Me.TVStatus.EndUpdate()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSerienbriefe_Load Fields

frmSerienbriefe_Load overview

Fields

field Button1
field Button2
field GroupBox1
field ListBox1
field Panel1
field Panel2
field Panel3
field TVStatus
field components
field m_serienbriefnr
field sblist

See Also

frmSerienbriefe_Load Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


TVStatus Variable

Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStatus As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


m_serienbriefnr Variable

Dim m_serienbriefnr As Integer

Source code

[Visual Basic]
    Dim m_serienbriefnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


sblist Variable

Friend WithEvents sblist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents sblist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe_Load


frmSetDokVerantwortlicher Class

For a list of all members of this type, see frmSetDokVerantwortlicher Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSetDokVerantwortlicher

Public Class frmSetDokVerantwortlicher
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSetDokVerantwortlicher Members


frmSetDokVerantwortlicher Members

frmSetDokVerantwortlicher overview

Constructors

constructor frmSetDokVerantwortlicher Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method fill_mcbmitarbeiter
method frmSetDokVerantwortlicher_Load

Fields

field Button1
field Button2
field Label1
field Label2
field TextBox1
field cbMitarbeiter
field components
field mcbmitarbeiter

See Also

frmSetDokVerantwortlicher Class


frmSetDokVerantwortlicher Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher Methods

frmSetDokVerantwortlicher overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method fill_mcbmitarbeiter
method frmSetDokVerantwortlicher_Load

See Also

frmSetDokVerantwortlicher Class


frmSetDokVerantwortlicher.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim i As Integer
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_wechsel_verantwortlicher"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TextBox1.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@verantwortlicher", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbmitarbeiter.SelectedValue))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters("@status").Value
            If i = 1 Then
                MsgBox("Ein Dokument mit der ID '" & Me.TextBox1.Text & " existiert nicht")
            Else
                Dim sth As New Statushandling()
                i = scmCmdToExecute.Parameters("@currentstatus").Value
                sth.insert_history_status(i, Me.TextBox1.Text, Me.mcbmitarbeiter.SelectedValue)
                sth.Dispose()
                MsgBox("Der Wechsel des Verantwortlichen wurde erfolgreich durchgeführt.")
            End If
        Catch ex As Exception
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.sp_dokverantwortlich_mitarbeiter"
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(128, 24)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(240, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Dokument-ID"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.Location = New System.Drawing.Point(128, 56)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(240, 21)
        Me.cbMitarbeiter.TabIndex = 4
        Me.cbMitarbeiter.Text = "cbmitarbeiter"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 56)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(120, 23)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Neuer Verantwortlicher"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(104, 112)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 6
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(192, 112)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 7
        Me.Button2.Text = "&OK"
        '
        'frmSetDokVerantwortlicher
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 158)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label2, Me.cbMitarbeiter, Me.Label1, Me.TextBox1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Name = "frmSetDokVerantwortlicher"
        Me.Text = "Dokumentverantwortlichern setzen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbmitarbeiter.DataSource = Nothing
        Me.mcbmitarbeiter.Items.Clear()
        Me.mcbmitarbeiter.CheckNullValue = False
        Me.mcbmitarbeiter.NullValueMessage = MyTxt.gettext(18)
        Me.mcbmitarbeiter.DisplayColumnName = "mitarbeiter"
        Me.mcbmitarbeiter.ValueColumnName = "mitarbeiternr"
        Me.mcbmitarbeiter.Fill_Data(Generic_Select(1), False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher.frmSetDokVerantwortlicher_Load Method

Private Sub frmSetDokVerantwortlicher_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSetDokVerantwortlicher_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbmitarbeiter = New MultiComboBox(Me.cbMitarbeiter)
        fill_mcbmitarbeiter()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSetDokVerantwortlicher Fields

frmSetDokVerantwortlicher overview

Fields

field Button1
field Button2
field Label1
field Label2
field TextBox1
field cbMitarbeiter
field components
field mcbmitarbeiter

See Also

frmSetDokVerantwortlicher Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


cbMitarbeiter Variable

Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


mcbmitarbeiter Variable

Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSetDokVerantwortlicher


frmSicherungsjournal Class

For a list of all members of this type, see frmSicherungsjournal Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSicherungsjournal

Public Class frmSicherungsjournal
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSicherungsjournal Members


frmSicherungsjournal Members

frmSicherungsjournal overview

Constructors

constructor frmSicherungsjournal Constructor

Methods

method C1TrueDBGrid1_SelChange
method C1TruedbGrid_MouseDown
method ContextMenu1_Popup
method Dispose
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method Refresh_Data
method Refresh_data2
method ToolBar1_ButtonClick
method frmSicherungsjournal_Load

Fields

field C1TrueDBGrid1
field C1TrueDBGrid2
field ContextMenu1
field GroupBox1
field GroupBox2
field ImageList1
field MenuItem1
field MenuItem2
field ToolBar1
field ToolBarButton1
field components
field data1
field data2

See Also

frmSicherungsjournal Class


frmSicherungsjournal Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal Methods

frmSicherungsjournal overview

Methods

method C1TrueDBGrid1_SelChange
method C1TruedbGrid_MouseDown
method ContextMenu1_Popup
method Dispose
method Generic_Select
method InitializeComponent
method MenuItem1_Click
method MenuItem2_Click
method Refresh_Data
method Refresh_data2
method ToolBar1_ButtonClick
method frmSicherungsjournal_Load

See Also

frmSicherungsjournal Class


frmSicherungsjournal.C1TrueDBGrid1_SelChange Method

Private Sub C1TrueDBGrid1_SelChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles C1TrueDBGrid1.SelChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_SelChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles C1TrueDBGrid1.SelChange
        Refresh_data2()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.C1TruedbGrid_MouseDown Method

Private Sub C1TruedbGrid_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles C1TrueDBGrid1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TruedbGrid_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1TrueDBGrid1.MouseDown
        Me.C1TrueDBGrid1.Bookmark = Me.C1TrueDBGrid1.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If Me.C1TrueDBGrid1.Columns(6).Value = True Then
            Me.MenuItem1.Enabled = False
            Me.MenuItem2.Enabled = False
        Else
            Me.MenuItem1.Enabled = True
            Me.MenuItem2.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.Generic_Select Method

Private Function Generic_Select( _
   ByVal fnkt As Integer, _
   ByVal pk As Integer _
) As DataTable

Parameters

fnkt
Required.
pk
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal fnkt As Integer, ByVal pk As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_sicherungsjournal"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@pk", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, pk))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSicherungsjournal))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.GroupBox2 = New System.Windows.Forms.GroupBox()
        Me.C1TrueDBGrid2 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.GroupBox1.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox2.SuspendLayout()
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(768, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid1})
        Me.GroupBox1.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox1.Location = New System.Drawing.Point(0, 25)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(768, 271)
        Me.GroupBox1.TabIndex = 1
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Journale"
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.AllowUpdate = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(3, 16)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(762, 252)
        Me.C1TrueDBGrid1.TabIndex = 4
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 758, 248</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRe" & _
        "cSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 758, 248</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Daten zum Löschen freigeben"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Löschfreigabe rückgängig"
        '
        'GroupBox2
        '
        Me.GroupBox2.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBGrid2})
        Me.GroupBox2.Dock = System.Windows.Forms.DockStyle.Top
        Me.GroupBox2.Location = New System.Drawing.Point(0, 296)
        Me.GroupBox2.Name = "GroupBox2"
        Me.GroupBox2.Size = New System.Drawing.Size(768, 468)
        Me.GroupBox2.TabIndex = 2
        Me.GroupBox2.TabStop = False
        Me.GroupBox2.Text = "Journaldetail"
        '
        'C1TrueDBGrid2
        '
        Me.C1TrueDBGrid2.AllowFilter = True
        Me.C1TrueDBGrid2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid2.AllowSort = True
        Me.C1TrueDBGrid2.AllowUpdate = False
        Me.C1TrueDBGrid2.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid2.AlternatingRows = True
        Me.C1TrueDBGrid2.CaptionHeight = 17
        Me.C1TrueDBGrid2.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.DataChanged = False
        Me.C1TrueDBGrid2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.C1TrueDBGrid2.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid2.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid2.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid2.Location = New System.Drawing.Point(3, 16)
        Me.C1TrueDBGrid2.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid2.Name = "C1TrueDBGrid2"
        Me.C1TrueDBGrid2.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid2.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid2.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid2.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid2.RowDivider = GridLines2
        Me.C1TrueDBGrid2.RowHeight = 15
        Me.C1TrueDBGrid2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid2.ScrollTips = False
        Me.C1TrueDBGrid2.Size = New System.Drawing.Size(762, 449)
        Me.C1TrueDBGrid2.TabIndex = 4
        Me.C1TrueDBGrid2.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""Tr" & _
        "ue"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeS" & _
        "tyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScr" & _
        "ollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 758, 445</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRe" & _
        "cSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 758, 445</ClientArea></Blob>"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmSicherungsjournal
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(768, 525)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox2, Me.GroupBox1, Me.ToolBar1})
        Me.Name = "frmSicherungsjournal"
        Me.Text = "Sicherungsjournal"
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox2.ResumeLayout(False)
        CType(Me.C1TrueDBGrid2, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim bm As Object
        bm = Me.C1TrueDBGrid1.Bookmark
        Generic_Select(2, Me.C1TrueDBGrid1.Columns(0).Value)
        Refresh_Data()
        Me.C1TrueDBGrid1.Bookmark = bm
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Dim bm As Object
        bm = Me.C1TrueDBGrid1.Bookmark
        Generic_Select(3, Me.C1TrueDBGrid1.Columns(0).Value)
        Refresh_Data()
        Me.C1TrueDBGrid1.Bookmark = bm
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.Refresh_Data Method

Private Sub Refresh_Data()

Source code

[Visual Basic]
    Private Sub Refresh_Data()
        data1 = Generic_Select(0, 0)
        Me.C1TrueDBGrid1.DataSource = data1
        Me.C1TrueDBGrid1.DataMember = data1.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.C1TrueDBGrid1, data1, "SaveJournal")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.Refresh_data2 Method

Private Function Refresh_data2()

Source code

[Visual Basic]
    Private Function Refresh_data2()
        'Rel 3.3 - (Try/Catch AND If/End If)
        '22.11.2004 / BUD
        Try
            If Me.C1TrueDBGrid1.Splits(0).Rows.Count <> 0 Then
                data2 = Generic_Select(1, Me.C1TrueDBGrid1.Columns(0).Value)
                Me.C1TrueDBGrid2.DataSource = data2
                Me.C1TrueDBGrid2.DataMember = data2.TableName
                DivFnkt.SpaltenTitel_Aktualisieren(Me.C1TrueDBGrid2, data2, "SaveJournalDetail")
            End If
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal.frmSicherungsjournal_Load Method

Private Sub frmSicherungsjournal_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSicherungsjournal_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Refresh_Data()
        Refresh_data2()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSicherungsjournal Fields

frmSicherungsjournal overview

Fields

field C1TrueDBGrid1
field C1TrueDBGrid2
field ContextMenu1
field GroupBox1
field GroupBox2
field ImageList1
field MenuItem1
field MenuItem2
field ToolBar1
field ToolBarButton1
field components
field data1
field data2

See Also

frmSicherungsjournal Class


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


C1TrueDBGrid2 Variable

Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid2 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


GroupBox2 Variable

Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox2 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


data1 Variable

Dim data1 As New DataTable()

Source code

[Visual Basic]
    Dim data1 As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


data2 Variable

Dim data2 As New DataTable()

Source code

[Visual Basic]
    Dim data2 As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSicherungsjournal


frmSortSelect Class

For a list of all members of this type, see frmSortSelect Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSortSelect

Public Class frmSortSelect
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSortSelect Members


frmSortSelect Members

frmSortSelect overview

Constructors

constructor frmSortSelect Constructor

Properties

property Datenherkunft
property DislpayResult
property NavigationResult
property ReportID
property TableName

Methods

method AddToSelected
method Button11_Click
method DeleteFromSelected
method Dispose
method FillProperty
method InitializeComponent
method Insertitem
method LBSelect_DoubleClick
method LBSort_DoubleClick
method ToolBar1_ButtonClick
method cmdCancel_Click
method cmdOk_Click
method frmSortSelect_Closing
method frmSortSelect_Load
method grdSortOrderUser_BeforeColEdit
method grdSortOrderUser_BeforeInsert
method lbSortfields_DoubleClick
method mnuDelete_Click
method mnuDown_Click
method mnuSortOrder_Click
method mnuUp_Click

Fields

field Button11
field ContextMenu2
field ImageList1
field LBSelect
field LBSort
field Label19
field Label21
field Label22
field Panel2
field SqlConnection1
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1
field abbrechen
field components
field daSortOrder
field daSortOrderUser
field dsSortOrder
field dsSortOrderUser
field i
field lbSortfields
field m_iLastID
field m_sDatenherkunft
field m_sDislpayResult
field m_sNavigationResult
field m_sReportID
field m_sTableName
field mnuDelete
field mnuDown
field mnuSortOrder
field mnuUp
field speichern

See Also

frmSortSelect Class


frmSortSelect Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect Properties

frmSortSelect overview

Properties

property Datenherkunft
property DislpayResult
property NavigationResult
property ReportID
property TableName

See Also

frmSortSelect Class


frmSortSelect.Datenherkunft Property

Property Datenherkunft() As String

Source code

[Visual Basic]
    Property Datenherkunft() As String
        ' Werte dienen für die Anziege
        Get
            Return m_sDatenherkunft
        End Get
        Set(ByVal Value As String)
            m_sDatenherkunft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.DislpayResult Property

Property DislpayResult() As String

Source code

[Visual Basic]
    Property DislpayResult() As String
        Get
            Return m_sDislpayResult
        End Get
        Set(ByVal Value As String)
            m_sDislpayResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.NavigationResult Property

Property NavigationResult() As String

Source code

[Visual Basic]
    Property NavigationResult() As String
        ' Werte dienen für die Steuerung
        Get
            Return m_sNavigationResult
        End Get
        Set(ByVal Value As String)
            m_sNavigationResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.ReportID Property

Property ReportID() As String

Source code

[Visual Basic]
    Property ReportID() As String
        Get
            Return m_sReportID
        End Get
        Set(ByVal Value As String)
            m_sReportID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_sTableName
        End Get
        Set(ByVal Value As String)
            m_sTableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect Methods

frmSortSelect overview

Methods

method AddToSelected
method Button11_Click
method DeleteFromSelected
method Dispose
method FillProperty
method InitializeComponent
method Insertitem
method LBSelect_DoubleClick
method LBSort_DoubleClick
method ToolBar1_ButtonClick
method cmdCancel_Click
method cmdOk_Click
method frmSortSelect_Closing
method frmSortSelect_Load
method grdSortOrderUser_BeforeColEdit
method grdSortOrderUser_BeforeInsert
method lbSortfields_DoubleClick
method mnuDelete_Click
method mnuDown_Click
method mnuSortOrder_Click
method mnuUp_Click

See Also

frmSortSelect Class


frmSortSelect.AddToSelected Method

Private Sub AddToSelected()

Source code

[Visual Basic]
    Private Sub AddToSelected()
        Try
            If lbSortfields.SelectedItems.Count > 0 Then

                '            If lbSortfields.Items.Count > 0 Then
                Me.LBSelect.Items.Add(Me.lbSortfields.SelectedItem + " | " + Me.LBSort.SelectedItem)
                Me.lbSortfields.Items.RemoveAt(Me.lbSortfields.SelectedIndex)
            End If
            If lbSortfields.Items.Count > 0 Then
                lbSortfields.SelectedIndex = 0
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.Button11_Click Method

Private Sub Button11_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Button11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button11_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Button11.Click
        AddToSelected()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.DeleteFromSelected Method

Private Sub DeleteFromSelected()

Source code

[Visual Basic]
    Private Sub DeleteFromSelected()
        Dim splitter
        Try
            If LBSelect.SelectedItems.Count > 0 Then

                'If LBSelect.Items.Count > 0 Then
                splitter = Microsoft.VisualBasic.Split(Me.LBSelect.SelectedItem, " | ")
                Insertitem(Me.lbSortfields, splitter(0))
                Me.LBSelect.Items.RemoveAt(Me.LBSelect.SelectedIndex)
            End If
            If LBSelect.Items.Count > 0 Then
                LBSelect.SelectedIndex = 0
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.FillProperty Method

Private Sub FillProperty()

Source code

[Visual Basic]
    Private Sub FillProperty()
        '===============================================================================
        'Desc       : Füllen der Property  DislpayResult  & NavigationResult
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim iCount As Integer
        Dim iCnt As Integer
        Dim sSeperater As String
        Dim sSortOrderDisplay(1) As String
        Dim sSortOrderNavigation(1) As String
        Dim sSortOrderDown As String
        sSortOrderDisplay(0) = " Absteigend "
        sSortOrderDisplay(1) = " Aufdsteigend "
        sSortOrderNavigation(0) = " DESC "
        sSortOrderNavigation(1) = " ASC "
        m_sNavigationResult = "ORDER BY "

        sSeperater = ""

        Dim splitter
        For iCount = 0 To Me.LBSelect.Items.Count - 1
            splitter = Microsoft.VisualBasic.Split(Me.LBSelect.Items.Item(iCount), " | ")
            For iCnt = 0 To Me.dsSortOrder.Tables(0).Rows.Count - 1
                If splitter(0) = dsSortOrder.Tables(0).Rows(iCnt).Item("DisplayFieldName") Then
                    m_sDislpayResult = m_sDislpayResult & sSeperater & dsSortOrder.Tables(0).Rows(iCnt).Item("DisplayFieldName") & " " & splitter(1)
                    Select Case splitter(1)
                        Case "Absteigend"
                            m_sNavigationResult = m_sNavigationResult & sSeperater & dsSortOrder.Tables(0).Rows(iCnt).Item("ReportFieldName") & " DESC"
                        Case "Aufsteigend"
                            m_sNavigationResult = m_sNavigationResult & sSeperater & dsSortOrder.Tables(0).Rows(iCnt).Item("ReportFieldName") & " ASC"
                    End Select
                    sSeperater = ", "
                    Exit For
                End If
            Next

        Next
        'Insertitem(Me.lbSortfields, splitter(0))
        'Me.LBSelect.Items.RemoveAt(Me.LBSelect.SelectedIndex)

        'With grdSortOrderUser
        '    Try
        '        .AllowAddNew = False
        '        If .Splits(0).Rows.Count = 0 Then
        '            m_sNavigationResult = ""
        '        End If
        '        For iCount = 0 To .Splits(0).Rows.Count - 1
        '            m_sDislpayResult = m_sDislpayResult & sSeperater & .Columns("DisplayFieldName").CellValue(iCount) & sSortOrderDisplay(Abs(CInt(.Columns("Aufsteigend").CellValue(iCount))))
        '            m_sNavigationResult = m_sNavigationResult & sSeperater & .Columns("ReportFieldName").CellValue(iCount) & sSortOrderNavigation(Abs(CInt(.Columns("Aufsteigend").CellValue(iCount))))
        '            sSeperater = ", "
        '        Next
        '    Catch ex As Exception
        '        MsgBox(ex.Message)
        '    End Try
        'End With
        'ORDER BY Partner.NRPAR00, Partner.BKPAR00, dokumenttyp.bezeichnung, dokument.erstelltam, dokument.mutiertam, dokument_status.bezeichnung DESC
        Select Case m_sDatenherkunft
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSortSelect))
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.dsSortOrderUser = New System.Data.DataSet()
        Me.dsSortOrder = New System.Data.DataSet()
        Me.daSortOrder = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.daSortOrderUser = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.mnuUp = New System.Windows.Forms.MenuItem()
        Me.mnuDown = New System.Windows.Forms.MenuItem()
        Me.mnuDelete = New System.Windows.Forms.MenuItem()
        Me.mnuSortOrder = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.speichern = New System.Windows.Forms.ToolBarButton()
        Me.abbrechen = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.LBSelect = New System.Windows.Forms.ListBox()
        Me.Button11 = New System.Windows.Forms.Button()
        Me.Label22 = New System.Windows.Forms.Label()
        Me.LBSort = New System.Windows.Forms.ListBox()
        Me.Label21 = New System.Windows.Forms.Label()
        Me.lbSortfields = New System.Windows.Forms.ListBox()
        CType(Me.dsSortOrderUser, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.dsSortOrder, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        Me.SuspendLayout()
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=tgtsqledokabssf;initial catalog=edoka;integrated security=SSPI;persis" & _
        "t security info=False;workstation id=TG602643;packet size=4096"
        '
        'dsSortOrderUser
        '
        Me.dsSortOrderUser.DataSetName = "NewDataSet"
        Me.dsSortOrderUser.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'dsSortOrder
        '
        Me.dsSortOrder.DataSetName = "NewDataSet"
        Me.dsSortOrder.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'daSortOrder
        '
        Me.daSortOrder.DeleteCommand = Me.SqlDeleteCommand1
        Me.daSortOrder.InsertCommand = Me.SqlInsertCommand1
        Me.daSortOrder.SelectCommand = Me.SqlSelectCommand1
        Me.daSortOrder.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "ReportingSortOrder", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("DisplayFieldName", "DisplayFieldName"), New System.Data.Common.DataColumnMapping("Aufsteigend", "Aufsteigend"), New System.Data.Common.DataColumnMapping("ID", "ID"), New System.Data.Common.DataColumnMapping("ReportID", "ReportID"), New System.Data.Common.DataColumnMapping("ReportFieldName", "ReportFieldName")})})
        Me.daSortOrder.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_ReportingSortOrder_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aufsteigend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Aufsteigend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "DisplayFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportID", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_ReportingSortOrder_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, "DisplayFieldName"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aufsteigend", System.Data.SqlDbType.Bit, 1, "Aufsteigend"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ID", System.Data.SqlDbType.Int, 4, "ID"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportID", System.Data.SqlDbType.Int, 4, "ReportID"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFieldName", System.Data.SqlDbType.VarChar, 1024, "ReportFieldName"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_ReportingSortOrder_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportID", System.Data.SqlDbType.Int, 4, "ReportID"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_ReportingSortOrder_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, "DisplayFieldName"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aufsteigend", System.Data.SqlDbType.Bit, 1, "Aufsteigend"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ID", System.Data.SqlDbType.Int, 4, "ID"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "ReportID"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFieldName", System.Data.SqlDbType.VarChar, 1024, "ReportFieldName"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aufsteigend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Aufsteigend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "DisplayFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportID", System.Data.DataRowVersion.Original, Nothing))
        '
        'daSortOrderUser
        '
        Me.daSortOrderUser.DeleteCommand = Me.SqlDeleteCommand2
        Me.daSortOrderUser.InsertCommand = Me.SqlInsertCommand2
        Me.daSortOrderUser.SelectCommand = Me.SqlSelectCommand2
        Me.daSortOrderUser.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "ReportingSortOrderUser", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("ID", "ID"), New System.Data.Common.DataColumnMapping("ReportingSortOrderID", "ReportingSortOrderID"), New System.Data.Common.DataColumnMapping("ReportID", "ReportID"), New System.Data.Common.DataColumnMapping("DisplayFieldName", "DisplayFieldName"), New System.Data.Common.DataColumnMapping("ReportFieldName", "ReportFieldName"), New System.Data.Common.DataColumnMapping("Aufsteigend", "Aufsteigend"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("SortOrder", "SortOrder"), New System.Data.Common.DataColumnMapping("Mandant_Nr", "Mandant_Nr"), New System.Data.Common.DataColumnMapping("Aktiv", "Aktiv"), New System.Data.Common.DataColumnMapping("Erstellt_Am", "Erstellt_Am"), New System.Data.Common.DataColumnMapping("Mutiert_Am", "Mutiert_Am"), New System.Data.Common.DataColumnMapping("Mutierer", "Mutierer"), New System.Data.Common.DataColumnMapping("Loeschen", "Loeschen")})})
        Me.daSortOrderUser.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_ReportingSortOrderUser_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aufsteigend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Aufsteigend", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "DisplayFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Erstellt_Am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Erstellt_Am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Loeschen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Loeschen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mandant_Nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mandant_Nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mutiert_Am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Mutiert_Am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFieldName", System.Data.SqlDbType.VarChar, 1024, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportFieldName", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportingSortOrderID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "ReportingSortOrderID", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_SortOrder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "SortOrder", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_ReportingSortOrderUser_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ID", System.Data.SqlDbType.Int, 4, "ID"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportingSortOrderID", System.Data.SqlDbType.Int, 4, "ReportingSortOrderID"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportID", System.Data.SqlDbType.Int, 4, "ReportID"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DisplayFieldName", System.Data.SqlDbType.VarChar, 1024, "DisplayFieldName"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFieldName", System.Data.SqlDbType.VarChar, 1024, "ReportFieldName"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aufsteigend", System.Data.SqlDbType.Bit, 1, "Aufsteigend"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@SortOrder", System.Data.SqlDbType.Int, 4, "SortOrder"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mandant_Nr", System.Data.SqlDbType.Int, 4, "Mandant_Nr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aktiv", System.Data.SqlDbType.Bit, 1, "Aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Erstellt_Am", System.Data.SqlDbType.DateTime, 8, "Erstellt_Am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mutiert_Am", System.Data.SqlDbType.DateTime, 8, "Mutiert_Am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mutierer", System.Data.SqlDbType.Int, 4, "Mutierer"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Loeschen", System.Data.SqlDbType.Bit, 1, "Loeschen"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_ReportingSortOrderUser_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportID", System.Data.SqlDbType.Int, 4, "ReportID"))
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_ReportingSortOrderUser_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportingSortOrderID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@DisplayFieldName", System.Data.SqlDbType.VarChar, 1024))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ReportFieldName", System.Data.SqlDbType.VarChar, 1024))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aufsteigend", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@SortOrder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mandant_Nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Erstellt_Am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mutiert_Am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Loeschen", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Aufsteigend", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_DisplayFieldName", System.Data.SqlDbType.VarChar, 1024))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Erstellt_Am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Loeschen", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mandant_Nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Mutiert_Am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportFieldName", System.Data.SqlDbType.VarChar, 1024))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_ReportingSortOrderID", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_SortOrder", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuUp, Me.mnuDown, Me.mnuDelete, Me.mnuSortOrder})
        '
        'mnuUp
        '
        Me.mnuUp.Index = 0
        Me.mnuUp.Text = "&Aufwärts"
        '
        'mnuDown
        '
        Me.mnuDown.Index = 1
        Me.mnuDown.Text = "A&bwärts"
        '
        'mnuDelete
        '
        Me.mnuDelete.Index = 2
        Me.mnuDelete.Text = "&Löschen"
        '
        'mnuSortOrder
        '
        Me.mnuSortOrder.Index = 3
        Me.mnuSortOrder.Text = "Sortierung ändern"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.abbrechen, Me.speichern})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(338, 25)
        Me.ToolBar1.TabIndex = 11
        '
        'speichern
        '
        Me.speichern.ImageIndex = 0
        Me.speichern.Tag = "Speichern"
        Me.speichern.ToolTipText = "übernehmen"
        '
        'abbrechen
        '
        Me.abbrechen.ImageIndex = 1
        Me.abbrechen.Tag = "Abbrechen"
        Me.abbrechen.ToolTipText = "Beenden ohne Datenübernahme"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label19, Me.LBSelect, Me.Button11, Me.Label22, Me.LBSort, Me.Label21, Me.lbSortfields})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Location = New System.Drawing.Point(0, 25)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(328, 508)
        Me.Panel2.TabIndex = 12
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(176, 15)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(100, 16)
        Me.Label19.TabIndex = 27
        Me.Label19.Text = "Sortierungsart"
        '
        'LBSelect
        '
        Me.LBSelect.ContextMenu = Me.ContextMenu2
        Me.LBSelect.Location = New System.Drawing.Point(16, 288)
        Me.LBSelect.Name = "LBSelect"
        Me.LBSelect.Size = New System.Drawing.Size(296, 199)
        Me.LBSelect.TabIndex = 26
        '
        'Button11
        '
        Me.Button11.Location = New System.Drawing.Point(128, 248)
        Me.Button11.Name = "Button11"
        Me.Button11.Size = New System.Drawing.Size(80, 24)
        Me.Button11.TabIndex = 25
        Me.Button11.Text = "Einfügen"
        '
        'Label22
        '
        Me.Label22.Location = New System.Drawing.Point(16, 272)
        Me.Label22.Name = "Label22"
        Me.Label22.Size = New System.Drawing.Size(100, 16)
        Me.Label22.TabIndex = 24
        Me.Label22.Text = "Sortierung"
        '
        'LBSort
        '
        Me.LBSort.Items.AddRange(New Object() {"Absteigend", "Aufsteigend"})
        Me.LBSort.Location = New System.Drawing.Point(176, 31)
        Me.LBSort.Name = "LBSort"
        Me.LBSort.Size = New System.Drawing.Size(136, 199)
        Me.LBSort.Sorted = True
        Me.LBSort.TabIndex = 22
        '
        'Label21
        '
        Me.Label21.Location = New System.Drawing.Point(16, 15)
        Me.Label21.Name = "Label21"
        Me.Label21.Size = New System.Drawing.Size(100, 16)
        Me.Label21.TabIndex = 21
        Me.Label21.Text = "Sortierkriterien"
        '
        'lbSortfields
        '
        Me.lbSortfields.Location = New System.Drawing.Point(16, 31)
        Me.lbSortfields.Name = "lbSortfields"
        Me.lbSortfields.Size = New System.Drawing.Size(136, 199)
        Me.lbSortfields.Sorted = True
        Me.lbSortfields.TabIndex = 20
        '
        'frmSortSelect
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(338, 533)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel2, Me.ToolBar1})
        Me.Name = "frmSortSelect"
        Me.Text = "Sortierung"
        CType(Me.dsSortOrderUser, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.dsSortOrder, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.Insertitem Method

Private Sub Insertitem( _
   ByVal lb As ListBox, _
   ByVal s As String _
)

Parameters

lb
Required.
s
Required.

Source code

[Visual Basic]
    Private Sub Insertitem(ByVal lb As ListBox, ByVal s As String)
        Dim i As Integer
        Dim inserted As Boolean = False
        For i = 0 To lb.Items.Count - 1
            lb.SelectedIndex = i
            If s > lb.SelectedItem And Not inserted Then
                lb.Items.Insert(i, s)
                inserted = True
            End If
        Next
        If Not inserted Then lb.Items.Insert(i, s)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.LBSelect_DoubleClick Method

Private Sub LBSelect_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles LBSelect.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub LBSelect_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles LBSelect.DoubleClick
        DeleteFromSelected()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.LBSort_DoubleClick Method

Private Sub LBSort_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles LBSort.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub LBSort_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles LBSort.DoubleClick
        Button11_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case e.Button.Tag
            Case "Abbrechen"
                Me.DialogResult = DialogResult.Cancel
                Me.Close()
            Case "Speichern"
                FillProperty()
                Me.DialogResult = DialogResult.OK
                Me.Close()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.cmdCancel_Click Method

Private Sub cmdCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.DialogResult = DialogResult.Cancel
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.cmdOk_Click Method

Private Sub cmdOk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdOk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.frmSortSelect_Closing Method

Private Sub frmSortSelect_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSortSelect_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Try
            Globals.WinPos.Set_Position(Me)
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.frmSortSelect_Load Method

Private Sub frmSortSelect_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSortSelect_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim iCount As Integer
        Dim iWidth As Integer = 50

        Try
            Globals.WinPos.Get_Position(Me)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        '===============================================================================
        'Datasource Sortorderfelder des Reports
        '===============================================================================
        Me.daSortOrder.SelectCommand.Parameters("@ReportID").Value = m_sReportID
        Me.daSortOrder.Fill(Me.dsSortOrder)

        For iCount = 0 To dsSortOrder.Tables(0).Rows.Count - 1
            Me.lbSortfields.Items.Add(dsSortOrder.Tables(0).Rows(iCount).Item("DisplayFieldName"))
        Next
        If dsSortOrder.Tables(0).Rows.Count > 0 Then
            Me.lbSortfields.SelectedIndex = 0
        End If
        LBSort.SelectedIndex = 0

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.grdSortOrderUser_BeforeColEdit Method

Private Sub grdSortOrderUser_BeforeColEdit( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdSortOrderUser_BeforeColEdit(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColEditEventArgs)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.grdSortOrderUser_BeforeInsert Method

Private Sub grdSortOrderUser_BeforeInsert( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdSortOrderUser_BeforeInsert(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs)
        Debug.Write("BeforeInsert  ")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.lbSortfields_DoubleClick Method

Private Sub lbSortfields_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles lbSortfields.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lbSortfields_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles lbSortfields.DoubleClick
        Button11_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.mnuDelete_Click Method

Private Sub mnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDelete.Click
        DeleteFromSelected()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.mnuDown_Click Method

Private Sub mnuDown_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDown.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDown_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDown.Click
        Dim i As Integer
        Dim s As String
        Try
            i = LBSelect.SelectedIndex
            s = LBSelect.SelectedItem
            If i < LBSelect.Items.Count - 1 Then
                LBSelect.Items.RemoveAt(i)
                LBSelect.Items.Insert(i + 1, s)
                LBSelect.SelectedIndex = i + 1
            End If
            'changes = True
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.mnuSortOrder_Click Method

Private Sub mnuSortOrder_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuSortOrder.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuSortOrder_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSortOrder.Click
        Dim s, s1 As String
        Dim splitter
        Try
            s = LBSelect.SelectedItem
            splitter = Microsoft.VisualBasic.Split(s, " | ")
            Select Case splitter(1)
                Case "Absteigend"
                    s1 = "Aufsteigend"
                Case "Aufsteigend"
                    s1 = "Absteigend"
                Case Else
                    s1 = "Aufsteigend"
            End Select
            s = splitter(0) + " | " + s1
            i = LBSelect.SelectedIndex
            LBSelect.SelectedIndex = i
            LBSelect.Items.RemoveAt(i)
            LBSelect.Items.Insert(i, s)
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect.mnuUp_Click Method

Private Sub mnuUp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuUp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuUp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuUp.Click
        Dim i As Integer
        Dim s As String
        Try
            i = LBSelect.SelectedIndex
            s = LBSelect.SelectedItem
            If i > 0 Then
                LBSelect.Items.RemoveAt(i)
                LBSelect.Items.Insert(i - 1, s)
                LBSelect.SelectedIndex = i - 1
            End If
        Catch
        End Try
        'changes = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSortSelect Fields

frmSortSelect overview

Fields

field Button11
field ContextMenu2
field ImageList1
field LBSelect
field LBSort
field Label19
field Label21
field Label22
field Panel2
field SqlConnection1
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlInsertCommand1
field SqlInsertCommand2
field SqlSelectCommand1
field SqlSelectCommand2
field SqlUpdateCommand1
field SqlUpdateCommand2
field ToolBar1
field abbrechen
field components
field daSortOrder
field daSortOrderUser
field dsSortOrder
field dsSortOrderUser
field i
field lbSortfields
field m_iLastID
field m_sDatenherkunft
field m_sDislpayResult
field m_sNavigationResult
field m_sReportID
field m_sTableName
field mnuDelete
field mnuDown
field mnuSortOrder
field mnuUp
field speichern

See Also

frmSortSelect Class


Button11 Variable

Friend WithEvents Button11 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button11 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


LBSelect Variable

Friend WithEvents LBSelect As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSelect As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


LBSort Variable

Friend WithEvents LBSort As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents LBSort As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


Label21 Variable

Friend WithEvents Label21 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label21 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


Label22 Variable

Friend WithEvents Label22 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label22 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


abbrechen Variable

Friend WithEvents abbrechen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents abbrechen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


daSortOrder Variable

Friend WithEvents daSortOrder As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents daSortOrder As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


daSortOrderUser Variable

Friend WithEvents daSortOrderUser As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents daSortOrderUser As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


dsSortOrder Variable

Friend WithEvents dsSortOrder As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents dsSortOrder As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


dsSortOrderUser Variable

Friend WithEvents dsSortOrderUser As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents dsSortOrderUser As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


lbSortfields Variable

Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents lbSortfields As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_iLastID Variable

Dim m_iLastID As Integer

Source code

[Visual Basic]
    Dim m_iLastID As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_sDatenherkunft Variable

Dim m_sDatenherkunft As String

Source code

[Visual Basic]
    Dim m_sDatenherkunft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_sDislpayResult Variable

Dim m_sDislpayResult As String

Source code

[Visual Basic]
    Dim m_sDislpayResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_sNavigationResult Variable

Dim m_sNavigationResult As String

Source code

[Visual Basic]
    Dim m_sNavigationResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_sReportID Variable

Dim m_sReportID As String

Source code

[Visual Basic]
    Dim m_sReportID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


m_sTableName Variable

Dim m_sTableName As String

Source code

[Visual Basic]
    Dim m_sTableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


mnuDelete Variable

Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


mnuDown Variable

Friend WithEvents mnuDown As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDown As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


mnuSortOrder Variable

Friend WithEvents mnuSortOrder As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuSortOrder As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


mnuUp Variable

Friend WithEvents mnuUp As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuUp As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


speichern Variable

Friend WithEvents speichern As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents speichern As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSortSelect


frmSpaltenDarstellung Class

For a list of all members of this type, see frmSpaltenDarstellung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSpaltenDarstellung

Public Class frmSpaltenDarstellung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSpaltenDarstellung Members


frmSpaltenDarstellung Members

frmSpaltenDarstellung overview

Constructors

constructor frmSpaltenDarstellung Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox2_DoubleClick
method ToolBar1_ButtonClick
method frmSpaltenDarstellung_Load

Fields

field Button1
field Button2
field ImageList1
field Label1
field Label2
field ListBox1
field ListBox2
field ToolBar1
field ToolBarButton1
field components

See Also

frmSpaltenDarstellung Class


frmSpaltenDarstellung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung Methods

frmSpaltenDarstellung overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent
method ListBox1_DoubleClick
method ListBox2_DoubleClick
method ToolBar1_ButtonClick
method frmSpaltenDarstellung_Load

See Also

frmSpaltenDarstellung Class


frmSpaltenDarstellung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        ListBox1_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        ListBox2_DoubleClick(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSpaltenDarstellung))
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        Me.ListBox2 = New System.Windows.Forms.ListBox()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(16, 56)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox1.Size = New System.Drawing.Size(184, 329)
        Me.ListBox1.Sorted = True
        Me.ListBox1.TabIndex = 0
        '
        'ListBox2
        '
        Me.ListBox2.Location = New System.Drawing.Point(232, 56)
        Me.ListBox2.Name = "ListBox2"
        Me.ListBox2.SelectionMode = System.Windows.Forms.SelectionMode.MultiExtended
        Me.ListBox2.Size = New System.Drawing.Size(184, 329)
        Me.ListBox2.Sorted = True
        Me.ListBox2.TabIndex = 1
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(432, 25)
        Me.ToolBar1.TabIndex = 2
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(144, 16)
        Me.Label1.TabIndex = 3
        Me.Label1.Text = "Vorhandene Spalten"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(232, 40)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(144, 16)
        Me.Label2.TabIndex = 4
        Me.Label2.Text = "Anzuzeigende Spalten"
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.ImageIndex = 4
        Me.Button1.ImageList = Me.ImageList1
        Me.Button1.Location = New System.Drawing.Point(200, 176)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(32, 32)
        Me.Button1.TabIndex = 5
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.ImageIndex = 3
        Me.Button2.ImageList = Me.ImageList1
        Me.Button2.Location = New System.Drawing.Point(200, 216)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(32, 32)
        Me.Button2.TabIndex = 6
        '
        'frmSpaltenDarstellung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(432, 397)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label2, Me.Label1, Me.ToolBar1, Me.ListBox2, Me.ListBox1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSpaltenDarstellung"
        Me.Text = "Spalten-Selektion"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.ListBox1_DoubleClick Method

Private Sub ListBox1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox2.Items.Add(Me.ListBox1.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox1.SelectedItems.Count - 1
            Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItems(0))
        Next
        'Me.ListBox2.Items.Add(Me.ListBox1.SelectedI
        'Me.ListBox1.Items.Remove(Me.ListBox1.SelectedItem)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.ListBox2_DoubleClick Method

Private Sub ListBox2_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ListBox2.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ListBox2_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox2.DoubleClick
        Dim i As Integer
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox1.Items.Add(Me.ListBox2.SelectedItems(i))
        Next
        For i = 0 To Me.ListBox2.SelectedItems.Count - 1
            Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItems(0))
        Next
        'Me.ListBox1.Items.Add(Me.ListBox2.SelectedItem)
        'Me.ListBox2.Items.Remove(Me.ListBox2.SelectedItem)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung.frmSpaltenDarstellung_Load Method

Private Sub frmSpaltenDarstellung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSpaltenDarstellung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmSpaltenDarstellung Fields

frmSpaltenDarstellung overview

Fields

field Button1
field Button2
field ImageList1
field Label1
field Label2
field ListBox1
field ListBox2
field ToolBar1
field ToolBarButton1
field components

See Also

frmSpaltenDarstellung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


ListBox2 Variable

Friend WithEvents ListBox2 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox2 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSpaltenDarstellung


frmStatusSetzen Class

For a list of all members of this type, see frmStatusSetzen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmStatusSetzen

Public Class frmStatusSetzen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmStatusSetzen Members


frmStatusSetzen Members

frmStatusSetzen overview

Constructors

constructor frmStatusSetzen Constructor

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method Generic_Select
method InitializeComponent
method Mitarbeiter_lesen
method Status_lesen
method Statuslist_Click
method Statuslist_MouseDown
method Statuslist_RowColChange
method ToolBar1_ButtonClick
method frmStatusSetzen_Load
method mcbloeschgrund_SelectedIndexChanged
method refresh_status

Fields

field Button1
field Button2
field Button3
field CheckBox1
field CheckBox2
field ComboBox1
field GroupBox1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field On_Load
field Statuslist
field TabControl1
field TabPage1
field TabPage2
field TextBox1
field TextBox2
field ToolBar1
field ToolBarButton1
field cbVerantwortlich
field components
field mcbloeschgrund
field mcbverantwortlich
field st
field txtLoeschgrund

See Also

frmStatusSetzen Class


frmStatusSetzen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen Methods

frmStatusSetzen overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method Generic_Select
method InitializeComponent
method Mitarbeiter_lesen
method Status_lesen
method Statuslist_Click
method Statuslist_MouseDown
method Statuslist_RowColChange
method ToolBar1_ButtonClick
method frmStatusSetzen_Load
method mcbloeschgrund_SelectedIndexChanged
method refresh_status

See Also

frmStatusSetzen Class


frmStatusSetzen.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim st As New Statushandling()
        st.insert_history_status(Me.Statuslist.Columns(0).Text, Me.TextBox1.Text, Me.mcbverantwortlich.SelectedValue)
        If Me.TextBox2.Text = "Abgeschlossen" Then
            st.Dokument_Abschliessen(Me.TextBox1.Text, Me.Statuslist.Columns(0).Value)
        End If
        refresh_status()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_korrektur_dokument_status_zuruecksetzen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TextBox1.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@grund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtLoeschgrund.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            If Me.CheckBox1.Checked Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ausgangsarchiviert", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ausgangsarchiviert", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            If Me.CheckBox2.Checked Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@eingangsarchiviert", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@eingangsarchiviert", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            End If

            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            Throw New Exception("Dokument_Status_Zurücksetzen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
            MsgBox("Der Dokumentstatus wurde zurückgesetzt.", MsgBoxStyle.Information)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim d As New edokadb.clsDokument()
        d.cpMainConnectionProvider = Globals.conn
        d.sDokumentid = New SqlString(CType(Me.TextBox1.Text, String))
        d.SelectOne()
        d.iStatusnr = New SqlInt32(CType(Me.Statuslist.Columns(0).Text, Int32))
        conn.OpenConnection()
        d.Update()
        conn.CloseConnection(True)
        d.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Generic_Select Method

Private Function Generic_Select() As DataTable

Source code

[Visual Basic]
    Private Function Generic_Select() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_get_grund"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@grundtyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 3))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmStatusSetzen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.cbVerantwortlich = New System.Windows.Forms.ComboBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Statuslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.CheckBox2 = New System.Windows.Forms.CheckBox()
        Me.CheckBox1 = New System.Windows.Forms.CheckBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.txtLoeschgrund = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TabControl1.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        Me.GroupBox1.SuspendLayout()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(610, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(88, 40)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(160, 20)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = "TextBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 2
        Me.Label1.Text = "Dokument-ID"
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage2})
        Me.TabControl1.Location = New System.Drawing.Point(8, 72)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(592, 272)
        Me.TabControl1.TabIndex = 3
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button3, Me.Button1, Me.Label5, Me.cbVerantwortlich, Me.TextBox2, Me.Label2, Me.GroupBox1})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(584, 246)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Status setzen"
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(424, 208)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(136, 23)
        Me.Button3.TabIndex = 20
        Me.Button3.Text = "Dokument positionieren"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(472, 184)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(88, 23)
        Me.Button1.TabIndex = 19
        Me.Button1.Text = "Status setzen"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 208)
        Me.Label5.Name = "Label5"
        Me.Label5.TabIndex = 18
        Me.Label5.Text = "Verantwortlicher"
        '
        'cbVerantwortlich
        '
        Me.cbVerantwortlich.ItemHeight = 13
        Me.cbVerantwortlich.Location = New System.Drawing.Point(112, 208)
        Me.cbVerantwortlich.Name = "cbVerantwortlich"
        Me.cbVerantwortlich.Size = New System.Drawing.Size(248, 21)
        Me.cbVerantwortlich.TabIndex = 17
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(112, 184)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.ReadOnly = True
        Me.TextBox2.Size = New System.Drawing.Size(248, 20)
        Me.TextBox2.TabIndex = 16
        Me.TextBox2.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 184)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(104, 16)
        Me.Label2.TabIndex = 15
        Me.Label2.Text = "Status zum Setzen:"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Statuslist})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 16)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(560, 160)
        Me.GroupBox1.TabIndex = 14
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Aktuelle Dokumentstatus"
        '
        'Statuslist
        '
        Me.Statuslist.AllowArrows = False
        Me.Statuslist.AllowFilter = True
        Me.Statuslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Statuslist.AllowSort = True
        Me.Statuslist.BackColor = System.Drawing.Color.White
        Me.Statuslist.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.Statuslist.CaptionHeight = 17
        Me.Statuslist.CollapseColor = System.Drawing.Color.Transparent
        Me.Statuslist.DataChanged = False
        Me.Statuslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Statuslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Statuslist.ExpandColor = System.Drawing.Color.Transparent
        Me.Statuslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Statuslist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Statuslist.Location = New System.Drawing.Point(3, 16)
        Me.Statuslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Statuslist.Name = "Statuslist"
        Me.Statuslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Statuslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Statuslist.PreviewInfo.ZoomFactor = 75
        Me.Statuslist.PrintInfo.ShowOptionsDialog = False
        Me.Statuslist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Statuslist.RowDivider = GridLines1
        Me.Statuslist.RowHeight = 15
        Me.Statuslist.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.Statuslist.ScrollTips = False
        Me.Statuslist.Size = New System.Drawing.Size(554, 141)
        Me.Statuslist.TabIndex = 4
        Me.Statuslist.Text = "C1TrueDBGrid1"
        Me.Statuslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{BackColor:White;}HighlightRow{ForeColor:HighlightText;BackColor:Highl" & _
        "ight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackCo" & _
        "lor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}St" & _
        "yle8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles" & _
        "><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaption" & _
        "Height=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelect" & _
        "orWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""" & _
        "1""><ClientRect>0, 0, 554, 141</ClientRect><BorderSide>0</BorderSide><CaptionStyl" & _
        "e parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><Eve" & _
        "nRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""" & _
        "Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group""" & _
        " me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle " & _
        "parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4""" & _
        " /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Recor" & _
        "dSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style " & _
        "parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedSty" & _
        "les><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style " & _
        "parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style par" & _
        "ent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style pare" & _
        "nt=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style pare" & _
        "nt=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""H" & _
        "eading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style par" & _
        "ent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1" & _
        "</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 554, 141</ClientArea></Blob>"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.CheckBox2, Me.CheckBox1, Me.Label6, Me.Button2, Me.Label3, Me.ComboBox1, Me.txtLoeschgrund, Me.Label4})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(584, 246)
        Me.TabPage2.TabIndex = 1
        Me.TabPage2.Text = "Status zurücksetzen"
        '
        'CheckBox2
        '
        Me.CheckBox2.Location = New System.Drawing.Point(8, 160)
        Me.CheckBox2.Name = "CheckBox2"
        Me.CheckBox2.Size = New System.Drawing.Size(192, 24)
        Me.CheckBox2.TabIndex = 14
        Me.CheckBox2.Text = "Dokument eingangsarchiviert"
        '
        'CheckBox1
        '
        Me.CheckBox1.Location = New System.Drawing.Point(8, 144)
        Me.CheckBox1.Name = "CheckBox1"
        Me.CheckBox1.Size = New System.Drawing.Size(184, 16)
        Me.CheckBox1.TabIndex = 13
        Me.CheckBox1.Text = "Dokument ausgangsarchiviert"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 200)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(536, 32)
        Me.Label6.TabIndex = 12
        Me.Label6.Text = "Nach dem Zurücksetzen sind auf der Trefferliste im Register Dokumentwerte allfäll" & _
        "ige Status zu ändern  und ggf. Coldbilder zu aktualisieren"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(416, 144)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(96, 23)
        Me.Button2.TabIndex = 11
        Me.Button2.Text = "Status zurücksetzen"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 16)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(100, 16)
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "Auswahl  Löschgrund"
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(8, 40)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(504, 21)
        Me.ComboBox1.TabIndex = 9
        Me.ComboBox1.Text = "ComboBox1"
        '
        'txtLoeschgrund
        '
        Me.txtLoeschgrund.Location = New System.Drawing.Point(8, 88)
        Me.txtLoeschgrund.Multiline = True
        Me.txtLoeschgrund.Name = "txtLoeschgrund"
        Me.txtLoeschgrund.Size = New System.Drawing.Size(504, 48)
        Me.txtLoeschgrund.TabIndex = 8
        Me.txtLoeschgrund.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 72)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(128, 16)
        Me.Label4.TabIndex = 7
        Me.Label4.Text = "Grund"
        '
        'frmStatusSetzen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(610, 359)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl1, Me.Label1, Me.TextBox1, Me.ToolBar1})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmStatusSetzen"
        Me.ShowInTaskbar = False
        Me.Text = "Status setzen"
        Me.TabControl1.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Mitarbeiter_lesen Method

Public Function Mitarbeiter_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Mitarbeiter_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_mitarbeiter_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Status_lesen Method

Public Function Status_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Status_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.TextBox1.Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Statuslist_Click Method

Private Sub Statuslist_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Statuslist.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Statuslist.Click
        Try
            Me.TextBox2.Text = Me.Statuslist.Columns(1).Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Statuslist_MouseDown Method

Private Sub Statuslist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Statuslist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Statuslist.MouseDown
        Try
        Catch
            Me.TextBox2.Text = Me.Statuslist.Columns(1).Text
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.Statuslist_RowColChange Method

Private Sub Statuslist_RowColChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles Statuslist.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_RowColChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles Statuslist.RowColChange
        Try
            Me.TextBox2.Text = Me.Statuslist.Columns(1).Text
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.frmStatusSetzen_Load Method

Private Sub frmStatusSetzen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmStatusSetzen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        refresh_status()
        Me.mcbverantwortlich = New MultiComboBox(cbVerantwortlich)
        Me.mcbverantwortlich.DisplayColumnName = "mitarbeiter"
        Me.mcbverantwortlich.ValueColumnName = "mitarbeiternr"

        Dim dd As New DataTable()
        dd = Mitarbeiter_lesen()
        Me.mcbverantwortlich.Fill_Data(dd, False)

        Me.mcbloeschgrund = New MultiComboBox(Me.ComboBox1)
        Me.mcbloeschgrund.CheckNullValue = False
        Me.mcbloeschgrund.DisplayColumnName = "Grund"
        Me.mcbloeschgrund.ValueColumnName = "grundnr"
        Me.mcbloeschgrund.Fill_Data(Generic_Select, False)
        On_Load = False
        Me.txtLoeschgrund.Focus()
        Me.txtLoeschgrund.Text = ""

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.mcbloeschgrund_SelectedIndexChanged Method

Private Sub mcbloeschgrund_SelectedIndexChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbloeschgrund.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbloeschgrund_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbloeschgrund.SelectedIndexChanged
        If On_Load Then Exit Sub
        If Microsoft.VisualBasic.Left(Me.mcbloeschgrund.Text, 1) = "(" Then
            Me.txtLoeschgrund.Focus()
            Me.txtLoeschgrund.SelectAll()
            Me.txtLoeschgrund.Text = ""
            Me.txtLoeschgrund.Enabled = True
        Else
            Me.txtLoeschgrund.Text = Me.mcbloeschgrund.Text
            Me.txtLoeschgrund.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen.refresh_status Method

Private Sub refresh_status()

Source code

[Visual Basic]
    Private Sub refresh_status()
        st = Status_lesen()
        Me.Statuslist.FetchRowStyles = True
        Me.Statuslist.DataSource = Nothing
        Me.Statuslist.DataSource = st
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Statuslist, st, "statushistory")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatusSetzen Fields

frmStatusSetzen overview

Fields

field Button1
field Button2
field Button3
field CheckBox1
field CheckBox2
field ComboBox1
field GroupBox1
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field On_Load
field Statuslist
field TabControl1
field TabPage1
field TabPage2
field TextBox1
field TextBox2
field ToolBar1
field ToolBarButton1
field cbVerantwortlich
field components
field mcbloeschgrund
field mcbverantwortlich
field st
field txtLoeschgrund

See Also

frmStatusSetzen Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


CheckBox1 Variable

Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox1 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


CheckBox2 Variable

Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents CheckBox2 As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


Statuslist Variable

Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


cbVerantwortlich Variable

Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbVerantwortlich As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


mcbloeschgrund Variable

Dim WithEvents mcbloeschgrund As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbloeschgrund As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


mcbverantwortlich Variable

Dim WithEvents mcbverantwortlich As MultiComboBox

Source code

[Visual Basic]
    Dim WithEvents mcbverantwortlich As MultiComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


st Variable

Dim st As DataTable

Source code

[Visual Basic]
    Dim st As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


txtLoeschgrund Variable

Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtLoeschgrund As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatusSetzen


frmStatustypStatusbezeichnung Class

For a list of all members of this type, see frmStatustypStatusbezeichnung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmStatustypStatusbezeichnung

Public Class frmStatustypStatusbezeichnung
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmStatustypStatusbezeichnung Members


frmStatustypStatusbezeichnung Members

frmStatustypStatusbezeichnung overview

Constructors

constructor frmStatustypStatusbezeichnung Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MyTBBottom_Format
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmStatustypStatusbezeichnung Class


frmStatustypStatusbezeichnung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung Properties

frmStatustypStatusbezeichnung overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmStatustypStatusbezeichnung Class


frmStatustypStatusbezeichnung Methods

frmStatustypStatusbezeichnung overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method MyTBBottom_Format
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmStatustypStatusbezeichnung Class


frmStatustypStatusbezeichnung.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.DataSet4 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "statustyp", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("statustypnr", "statustypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_statustyp_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_statustyp_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_statustyp_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_statustyp_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.VarChar, 10, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "status_bezeichnung", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("status_bezeichnungnr", "status_bezeichnungnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_status_bezeichnung_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_status_bezeichnung_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_status_bezeichnung_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_status_bezeichnung_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "status", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("statusnr", "statusnr"), New System.Data.Common.DataColumnMapping("statustypnr", "statustypnr"), New System.Data.Common.DataColumnMapping("status_bezeichnungnr", "status_bezeichnungnr"), New System.Data.Common.DataColumnMapping("reihenfolge", "reihenfolge"), New System.Data.Common.DataColumnMapping("folgestatus_durch_anderen_verantwortlichen", "folgestatus_durch_anderen_verantwortlichen"), New System.Data.Common.DataColumnMapping("folgestatus_durch_andere_rolle", "folgestatus_durch_andere_rolle"), New System.Data.Common.DataColumnMapping("dokumentbearbeitung_moeglich", "dokumentbearbeitung_moeglich"), New System.Data.Common.DataColumnMapping("erledigung_ab", "erledigung_ab"), New System.Data.Common.DataColumnMapping("dokument_ausgangsarchivieren", "dokument_ausgangsarchivieren"), New System.Data.Common.DataColumnMapping("dokument_bearbeitung_abgeschlossen", "dokument_bearbeitung_abgeschlossen"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_status_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_ausgangsarchivieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_ausgangsarchivieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_bearbeitung_abgeschlossen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_bearbeitung_abgeschlossen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentbearbeitung_moeglich", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentbearbeitung_moeglich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erledigung_ab", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erledigung_ab", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_folgestatus_durch_andere_rolle", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "folgestatus_durch_andere_rolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_folgestatus_durch_anderen_verantwortlichen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "folgestatus_durch_anderen_verantwortlichen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_status_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statusnr", System.Data.SqlDbType.Int, 4, "statusnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@folgestatus_durch_anderen_verantwortlichen", System.Data.SqlDbType.Bit, 1, "folgestatus_durch_anderen_verantwortlichen"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@folgestatus_durch_andere_rolle", System.Data.SqlDbType.Int, 4, "folgestatus_durch_andere_rolle"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentbearbeitung_moeglich", System.Data.SqlDbType.Bit, 1, "dokumentbearbeitung_moeglich"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erledigung_ab", System.Data.SqlDbType.Int, 4, "erledigung_ab"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_ausgangsarchivieren", System.Data.SqlDbType.Bit, 1, "dokument_ausgangsarchivieren"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_bearbeitung_abgeschlossen", System.Data.SqlDbType.Bit, 1, "dokument_bearbeitung_abgeschlossen"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_status_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_status_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statusnr", System.Data.SqlDbType.Int, 4, "statusnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@statustypnr", System.Data.SqlDbType.Int, 4, "statustypnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status_bezeichnungnr", System.Data.SqlDbType.Int, 4, "status_bezeichnungnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@reihenfolge", System.Data.SqlDbType.Int, 4, "reihenfolge"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@folgestatus_durch_anderen_verantwortlichen", System.Data.SqlDbType.Bit, 1, "folgestatus_durch_anderen_verantwortlichen"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@folgestatus_durch_andere_rolle", System.Data.SqlDbType.Int, 4, "folgestatus_durch_andere_rolle"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentbearbeitung_moeglich", System.Data.SqlDbType.Bit, 1, "dokumentbearbeitung_moeglich"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erledigung_ab", System.Data.SqlDbType.Int, 4, "erledigung_ab"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_ausgangsarchivieren", System.Data.SqlDbType.Bit, 1, "dokument_ausgangsarchivieren"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokument_bearbeitung_abgeschlossen", System.Data.SqlDbType.Bit, 1, "dokument_bearbeitung_abgeschlossen"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statusnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statusnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_ausgangsarchivieren", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_ausgangsarchivieren", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokument_bearbeitung_abgeschlossen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokument_bearbeitung_abgeschlossen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_dokumentbearbeitung_moeglich", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "dokumentbearbeitung_moeglich", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erledigung_ab", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erledigung_ab", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_folgestatus_durch_andere_rolle", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "folgestatus_durch_andere_rolle", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_folgestatus_durch_anderen_verantwortlichen", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "folgestatus_durch_anderen_verantwortlichen", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_reihenfolge", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "reihenfolge", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_status_bezeichnungnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "status_bezeichnungnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_statustypnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "statustypnr", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmStatustypStatusbezeichnung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmStatustypStatusbezeichnung"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsStatus()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iStatustypnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iStatus_bezeichnungnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iStatus_bezeichnungnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iStatustypnr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iStatustypnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iStatus_bezeichnungnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.bDokument_ausgangsarchivieren = New SqlBoolean(CType(False, Boolean))
            vdata.bDokument_bearbeitung_abgeschlossen = New SqlBoolean(CType(False, Boolean))
            vdata.bDokumentbearbeitung_moeglich = New SqlBoolean(CType(False, Boolean))
            vdata.bFolgestatus_durch_anderen_verantwortlichen = New SqlBoolean(CType(False, Boolean))
            vdata.iErledigung_ab = New SqlInt32(CType(-1, Int32))
            vdata.iReihenfolge = New SqlInt32(CType(0, Int32))
            vdata.iFolgestatus_durch_andere_rolle = New SqlInt32(CType(0, Int32))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("status")
            vdata.iStatusnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5011, 5012, 5013)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        save_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.MyTBBottom_Format Method

Public Sub MyTBBottom_Format()

Source code

[Visual Basic]
    Public Sub MyTBBottom_Format()
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            'Präsentation von aktiv
            If Me.TBBottom.Columns(i).DataField = "aktiv" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).DefaultValue = True
                Me.TBBottom.Splits(0).DisplayColumns(i).Locked = False
            End If
            If Me.TBBottom.Columns(i).DataField = "zwingend" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
                Me.TBBottom.Columns(i).DefaultValue = True
            End If
            If Me.TBBottom.Columns(i).DataField = "folgestatus_durch_anderen_verantwortlichen" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
            End If
            If Me.TBBottom.Columns(i).DataField = "dokumentbearbeitung_moeglich" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
            End If
            If Me.TBBottom.Columns(i).DataField = "dokument_ausgangsarchivieren" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
            End If
            If Me.TBBottom.Columns(i).DataField = "dokumentbeaerbeitung_abgeschlossen" Then
                Me.TBBottom.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                Me.TBBottom.Columns(i).ValueItems.DefaultItem = True
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
        MyTBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "statustyp"
        Me.TableNameRight = "status_bezeichnung"
        Me.TableNameBottom = "status"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatustypStatusbezeichnung Fields

frmStatustypStatusbezeichnung overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field DataSet4
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmStatustypStatusbezeichnung Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatustypStatusbezeichnung


frmStatuswechsel Class

For a list of all members of this type, see frmStatuswechsel Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmStatuswechsel

Public Class frmStatuswechsel
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmStatuswechsel Members


frmStatuswechsel Members

frmStatuswechsel overview

Constructors

constructor frmStatuswechsel Constructor

Properties

property Dokumentid
property Mitarbeiternr
property currentstatus

Methods

method Button1_Click
method Button2_Click
method Dispose
method Form1_Load
method Generic_Select
method InitializeComponent
method TextBox1_TextChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedIndexChanged
method cbmoeglicheStati_SelectedValueChanged
method cbsave_SelectedIndexChanged
method fill_mcbmitarbeiter

Fields

field Button1
field Button2
field Button3
field Funktionsliste
field Label1
field Label2
field Label3
field Label4
field Panel1
field cbMitarbeiter
field cbStatus
field cbmoeglicheStati
field cbsave
field components
field m_currentstatus
field m_dokumentid
field m_mitarbeiternr
field mcbmitarbeiter
field mcbstatus
field moeglichstati
field selectedstatus
field txtBemerkung
field txtstatus

See Also

frmStatuswechsel Class


frmStatuswechsel Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel Properties

frmStatuswechsel overview

Properties

property Dokumentid
property Mitarbeiternr
property currentstatus

See Also

frmStatuswechsel Class


frmStatuswechsel.Dokumentid Property

Property Dokumentid() As String

Source code

[Visual Basic]
    Property Dokumentid() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.Mitarbeiternr Property

Property Mitarbeiternr() As Integer

Source code

[Visual Basic]
    Property Mitarbeiternr() As Integer
        Get
            Return m_mitarbeiternr
        End Get
        Set(ByVal Value As Integer)
            m_mitarbeiternr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.currentstatus Property

Property currentstatus() As Integer

Source code

[Visual Basic]
    Property currentstatus() As Integer
        Get
            Return m_currentstatus
        End Get
        Set(ByVal Value As Integer)
            m_currentstatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel Methods

frmStatuswechsel overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Form1_Load
method Generic_Select
method InitializeComponent
method TextBox1_TextChanged
method cbmoeglicheStati_DropDown
method cbmoeglicheStati_Leave
method cbmoeglicheStati_SelectedIndexChanged
method cbmoeglicheStati_SelectedValueChanged
method cbsave_SelectedIndexChanged
method fill_mcbmitarbeiter

See Also

frmStatuswechsel Class


frmStatuswechsel.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        '26.10.03 - Hutter
        Dim statuswechsel As Boolean = False
        Dim verantwechsel As Boolean = False

        If Me.mcbstatus.Text = "In Bearbeitung" Then
            If Archivfnkt.check_bereits_archiviert(Me.Dokumentid, False) = False Then
                Windows.Forms.Application.DoEvents()
                Me.Cursor = Cursors.Default
                Exit Sub
            Else
                If Globals.dokumentid_changed Then
                    Me.Dokumentid = Globals.DokumentID_New_Copy
                End If
            End If
        End If
        '26.10.03

        Dim sth As New Statushandling()
        Dim doc As New edokadb.clsDokument()
        doc.cpMainConnectionProvider = conn
        conn.OpenConnection()
        doc.sDokumentid = New SqlString(CType(Me.Dokumentid, String))
        doc.SelectOne()

        Dim statush As New Statushandling()
        statush.NeuerStatus = Me.mcbstatus.SelectedValue
        statush.Check_Neuer_Status()
        If statush.Folgestatus = True And Me.mcbmitarbeiter.SelectedValue = Me.Mitarbeiternr Then
            MyMsg.show_standardmessage(21, MsgBoxStyle.Critical)
            Me.mcbmitarbeiter.Focus()
            statush.Dispose()
            doc.Dispose()
            Exit Sub
        End If

        If UCase(Me.mcbstatus.Text) <> "KONTROLLIERT (JEDERZEIT)" Then
            doc.bBereit_zur_archivierung = New SqlBoolean(CType(False, Boolean))
        End If
        If statush.Ausgangsarchivierung = True Then
            doc.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
        End If
        If doc.iVerantwortlich.Value <> Me.mcbmitarbeiter.SelectedValue Then
            '26.10.03 - hutter
            verantwechsel = True
            '26.10.03
            doc.iVerantwortlich = New SqlInt32(CType(Me.mcbmitarbeiter.SelectedValue, Int32))
            sth.BemerkungVerantwortlicher = Me.txtBemerkung.Text
            sth.Meldung_Verantwortlicher(Me.Dokumentid, Me.mcbmitarbeiter.SelectedValue)
        End If

        If statush.Ablgeschossen = True Or Me.mcbstatus.Text = "Abgeschlossen" Then
            doc.iVerantwortlich = New SqlInt32(CType(9998, Int32))
        End If

        If doc.iStatusnr.Value <> Me.mcbstatus.SelectedValue Then
            '26.10.03
            statuswechsel = True
            '26.10.03
            Dim st As New SqlDataAdapter("Select status_bezeichnungnr from dokument_status where dokument_statusnr=" & Me.mcbstatus.SelectedValue, Globals.sConnectionString)
            Dim std As New DataSet()
            st.Fill(std, "bez")
            If std.Tables(0).Rows(0).Item(0) <> 8 Then
                doc.iStatusnr = New SqlInt32(CType(Me.mcbstatus.SelectedValue, Int32))
            End If
            sth.Meldung_Status(Me.Dokumentid, Me.mcbstatus.SelectedValue)
            std.Dispose()
            st.Dispose()
        End If
        doc.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        doc.daMutiertam = New SqlDateTime(CType(Now, DateTime))

        If Not doc.iDokdurchkubeweitergegeben.Value = 1 Then
            Dim tx As DataTable
            tx = Generic_Select(13)
            If tx.Rows(0).Item(0) = 1 Then
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(1, Int32))
            Else
                doc.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
            End If
            tx.Dispose()
        End If

        '26.10.03 - Hutter
        If Me.mcbstatus.Text = "In Bearbeitung" Then
            doc.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
            doc.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
        End If

        doc.Update()
        conn.CloseConnection(True)

        If statuswechsel Or verantwechsel Then
            statush.insert_history_status(CType(Me.mcbstatus.SelectedValue, Int32), Me.Dokumentid, Me.mcbmitarbeiter.SelectedValue)
        End If
        statush.check_abschluss(Me.Dokumentid, Me.mcbmitarbeiter.SelectedValue)
        Me.Close()
        doc.Dispose()
        statush.Dispose()
        '26.10.03
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.mcbstatus = New MultiComboBox(Me.cbStatus)
        Me.mcbstatus.CheckNullValue = True
        Me.mcbstatus.NullValueMessage = MyTxt.gettext(18)
        Me.mcbstatus.DisplayColumnName = "Bezeichnung"
        Me.mcbstatus.ValueColumnName = "dokumentstatusnr"
        Me.mcbstatus.Fill_Data(Generic_Select(2), False)
        Me.mcbstatus.SelectedValue = Me.currentstatus

        Me.moeglichstati = Generic_Select(6)
        Me.cbmoeglicheStati.Items.Clear()
        Dim i As Integer
        For i = 0 To Me.moeglichstati.Rows.Count - 1
            Me.cbmoeglicheStati.Items.Add(Me.moeglichstati.Rows(i).Item("bezeichnung"))
        Next

        Me.Funktionsliste = ""
        mcbmitarbeiter = New MultiComboBox(Me.cbMitarbeiter)
        fill_mcbmitarbeiter()

        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.cbmoeglicheStati, Globals.MyTxt.gettext(22000))

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 2
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 3
                scmCmdToExecute.CommandText = "SP_Dokumentbearbeitung_Mitarbeiter"
            Case 4
                scmCmdToExecute.CommandText = "SP_message_generate_verantwortlicher_wechsel"
            Case 6
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel"
            Case 7
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_statuswechsel_funktionen"
            Case 13
                scmCmdToExecute.CommandText = "sp_dokumentbearbeitung_ist_kundenberater"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 2
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 4
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbstatus.SelectedValue))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@verantwortlicher", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.mcbmitarbeiter.SelectedValue))
                Case 6
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Case 7
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@currentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.selectedstatus))
                Case 13
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            If typ = 2 Then
                Me.currentstatus = scmCmdToExecute.Parameters("@currentstatus").Value
            End If
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmStatuswechsel))
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.cbStatus = New System.Windows.Forms.ComboBox()
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.cbmoeglicheStati = New System.Windows.Forms.ComboBox()
        Me.cbsave = New System.Windows.Forms.ComboBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.txtstatus = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.SuspendLayout()
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 232)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 0
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.Location = New System.Drawing.Point(304, 232)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 1
        Me.Button2.Text = "&OK"
        '
        'cbStatus
        '
        Me.cbStatus.Location = New System.Drawing.Point(112, 16)
        Me.cbStatus.Name = "cbStatus"
        Me.cbStatus.Size = New System.Drawing.Size(264, 21)
        Me.cbStatus.TabIndex = 2
        Me.cbStatus.Text = "ComboBox1"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.Location = New System.Drawing.Point(112, 48)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(240, 21)
        Me.cbMitarbeiter.TabIndex = 3
        Me.cbMitarbeiter.Text = "ComboBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(96, 23)
        Me.Label1.TabIndex = 4
        Me.Label1.Text = "Dokumentstatus"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(80, 23)
        Me.Label2.TabIndex = 5
        Me.Label2.Text = "Verantwortlich"
        '
        'Button3
        '
        Me.Button3.Image = CType(resources.GetObject("Button3.Image"), System.Drawing.Bitmap)
        Me.Button3.Location = New System.Drawing.Point(176, 264)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(24, 24)
        Me.Button3.TabIndex = 6
        Me.Button3.Visible = False
        '
        'cbmoeglicheStati
        '
        Me.cbmoeglicheStati.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbmoeglicheStati.Location = New System.Drawing.Point(354, 48)
        Me.cbmoeglicheStati.Name = "cbmoeglicheStati"
        Me.cbmoeglicheStati.Size = New System.Drawing.Size(21, 21)
        Me.cbmoeglicheStati.TabIndex = 7
        Me.cbmoeglicheStati.Text = "ComboBox1"
        '
        'cbsave
        '
        Me.cbsave.Items.AddRange(New Object() {"abc", "def", "gagas d sd", "sdf sdf sfd "})
        Me.cbsave.Location = New System.Drawing.Point(352, 48)
        Me.cbsave.Name = "cbsave"
        Me.cbsave.Size = New System.Drawing.Size(21, 21)
        Me.cbsave.TabIndex = 8
        Me.cbsave.Text = "ComboBox1"
        Me.cbsave.Visible = False
        '
        'Panel1
        '
        Me.Panel1.Location = New System.Drawing.Point(374, 8)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(16, 100)
        Me.Panel1.TabIndex = 9
        '
        'txtstatus
        '
        Me.txtstatus.Location = New System.Drawing.Point(112, 80)
        Me.txtstatus.Name = "txtstatus"
        Me.txtstatus.Size = New System.Drawing.Size(224, 23)
        Me.txtstatus.TabIndex = 10
        Me.txtstatus.Text = "Label3"
        Me.txtstatus.Visible = False
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(96, 32)
        Me.Label3.TabIndex = 11
        Me.Label3.Text = "Berechtigt für Folgestatus"
        Me.Label3.Visible = False
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 104)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(192, 16)
        Me.Label4.TabIndex = 12
        Me.Label4.Text = "Bemerkung für den Verantwortlichen"
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(8, 120)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(368, 104)
        Me.txtBemerkung.TabIndex = 13
        Me.txtBemerkung.Text = ""
        '
        'frmStatuswechsel
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 263)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBemerkung, Me.Label4, Me.Label3, Me.txtstatus, Me.Panel1, Me.cbsave, Me.Button3, Me.Label2, Me.Label1, Me.cbMitarbeiter, Me.cbStatus, Me.Button2, Me.Button1, Me.cbmoeglicheStati})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedDialog
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmStatuswechsel"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Status / Verantwortlicher wechseln"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.TextBox1_TextChanged Method

Private Sub TextBox1_TextChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles txtBemerkung.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TextBox1_TextChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles txtBemerkung.TextChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.cbmoeglicheStati_DropDown Method

Private Sub cbmoeglicheStati_DropDown( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.DropDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_DropDown(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.DropDown
        Me.cbmoeglicheStati.Width = 200
        Me.cbsave.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.cbmoeglicheStati_Leave Method

Private Sub cbmoeglicheStati_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.Leave
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.cbmoeglicheStati_SelectedIndexChanged Method

Private Sub cbmoeglicheStati_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedIndexChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.cbmoeglicheStati_SelectedValueChanged Method

Private Sub cbmoeglicheStati_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbmoeglicheStati.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbmoeglicheStati_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbmoeglicheStati.SelectedValueChanged
        Dim i As Integer
        Dim DATA As DataTable
        Me.cbsave.Visible = False
        Me.cbmoeglicheStati.Width = 21
        Me.txtstatus.Text = Me.cbmoeglicheStati.Text
        Me.Label3.Visible = True
        Me.txtstatus.Visible = True
        If Me.txtstatus.Text = Me.mcbstatus.Text Then
            Me.Label3.Visible = False
            Me.txtstatus.Visible = False
            Me.Funktionsliste = ""
            Me.selectedstatus = 0
        Else
            For i = 0 To Me.moeglichstati.Rows.Count - 1
                If Me.txtstatus.Text = Me.moeglichstati.Rows(i).Item("bezeichnung") Then
                    Me.selectedstatus = Me.moeglichstati.Rows(i).Item("nr")
                End If
            Next
        End If
        Me.Funktionsliste = ""
        DATA = Generic_Select(7)
        For i = 0 To DATA.Rows.Count - 1
            If Me.Funktionsliste <> "" Then Me.Funktionsliste = Me.Funktionsliste + ";"
            Me.Funktionsliste = Me.Funktionsliste + LTrim(DATA.Rows(i).Item("funktionnr"))
        Next
        fill_mcbmitarbeiter()
        Me.mcbmitarbeiter.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.cbsave_SelectedIndexChanged Method

Private Sub cbsave_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbsave.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbsave_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbsave.SelectedIndexChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel.fill_mcbmitarbeiter Method

Private Sub fill_mcbmitarbeiter()

Source code

[Visual Basic]
    Private Sub fill_mcbmitarbeiter()
        Me.mcbmitarbeiter.DataSource = Nothing
        Me.mcbmitarbeiter.Items.Clear()
        Me.mcbmitarbeiter.CheckNullValue = True
        Me.mcbmitarbeiter.NullValueMessage = MyTxt.gettext(18)
        Me.mcbmitarbeiter.DisplayColumnName = "mitarbeiter"
        Me.mcbmitarbeiter.ValueColumnName = "mitarbeiternr"
        Me.mcbmitarbeiter.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.Dokumentid, 3, 0, 0, 0, Me.Funktionsliste), False)
        '        Me.mcbmitarbeiter.Fill_Data(DivFnkt.Berechtigte_Mitarbeiter(0, 0, 0, Me.Dokumentid, 3, 0, 0, 0, Me.Funktionsliste), False)

        Me.mcbmitarbeiter.SelectedValue = Me.Mitarbeiternr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStatuswechsel Fields

frmStatuswechsel overview

Fields

field Button1
field Button2
field Button3
field Funktionsliste
field Label1
field Label2
field Label3
field Label4
field Panel1
field cbMitarbeiter
field cbStatus
field cbmoeglicheStati
field cbsave
field components
field m_currentstatus
field m_dokumentid
field m_mitarbeiternr
field mcbmitarbeiter
field mcbstatus
field moeglichstati
field selectedstatus
field txtBemerkung
field txtstatus

See Also

frmStatuswechsel Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Funktionsliste Variable

Dim Funktionsliste As String

Source code

[Visual Basic]
    Dim Funktionsliste As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


cbMitarbeiter Variable

Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


cbStatus Variable

Friend WithEvents cbStatus As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbStatus As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


cbmoeglicheStati Variable

Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbmoeglicheStati As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


cbsave Variable

Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbsave As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


m_currentstatus Variable

Dim m_currentstatus As Integer

Source code

[Visual Basic]
    Dim m_currentstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


m_mitarbeiternr Variable

Dim m_mitarbeiternr As Integer

Source code

[Visual Basic]
    Dim m_mitarbeiternr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


mcbmitarbeiter Variable

Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


mcbstatus Variable

Dim WithEvents mcbstatus As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbstatus As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


moeglichstati Variable

Dim moeglichstati As DataTable

Source code

[Visual Basic]
    Dim moeglichstati As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


selectedstatus Variable

Dim selectedstatus As Integer

Source code

[Visual Basic]
    Dim selectedstatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


txtstatus Variable

Friend WithEvents txtstatus As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents txtstatus As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStatuswechsel


frmStellvertreterAdd Class

For a list of all members of this type, see frmStellvertreterAdd Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmStellvertreterAdd

Public Class frmStellvertreterAdd
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmStellvertreterAdd Members


frmStellvertreterAdd Members

frmStellvertreterAdd overview

Constructors

constructor frmStellvertreterAdd Constructor

Properties

property Stellvertretungtyp
property vertreter

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmStellvertreterAdd_Load

Fields

field Button1
field Button2
field DateTimePicker1
field DateTimePicker2
field Label1
field Label2
field Label3
field Label4
field cbMitarbeiter
field cbfunktion
field components
field m_stvtyp
field m_vertreter
field mcbStellvertretungtyp
field mcbmitarbeiter

See Also

frmStellvertreterAdd Class


frmStellvertreterAdd Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd Properties

frmStellvertreterAdd overview

Properties

property Stellvertretungtyp
property vertreter

See Also

frmStellvertreterAdd Class


frmStellvertreterAdd.Stellvertretungtyp Property

Property Stellvertretungtyp() As Integer

Source code

[Visual Basic]
    Property Stellvertretungtyp() As Integer
        Get
            Return m_stvtyp
        End Get
        Set(ByVal Value As Integer)
            m_stvtyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.vertreter Property

Property vertreter() As Integer

Source code

[Visual Basic]
    Property vertreter() As Integer
        Get
            Return m_vertreter
        End Get
        Set(ByVal Value As Integer)
            m_vertreter = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd Methods

frmStellvertreterAdd overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method frmStellvertreterAdd_Load

See Also

frmStellvertreterAdd Class


frmStellvertreterAdd.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.vertreter = Me.mcbmitarbeiter.SelectedValue
        If Me.cbfunktion.Visible = False Then
            Me.Stellvertretungtyp = 0
        Else
            Me.Stellvertretungtyp = Me.mcbStellvertretungtyp.SelectedValue
        End If
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.Abort
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_stellvertretungen_mitarbeiter"
            Case 2
                scmCmdToExecute.CommandText = "dbo.sp_stellvertretungtyp"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.DateTimePicker1 = New System.Windows.Forms.DateTimePicker()
        Me.DateTimePicker2 = New System.Windows.Forms.DateTimePicker()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.cbMitarbeiter = New System.Windows.Forms.ComboBox()
        Me.cbfunktion = New System.Windows.Forms.ComboBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(24, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(72, 23)
        Me.Label1.TabIndex = 6
        Me.Label1.Text = "Stellvertreter"
        '
        'DateTimePicker1
        '
        Me.DateTimePicker1.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker1.Location = New System.Drawing.Point(96, 53)
        Me.DateTimePicker1.Name = "DateTimePicker1"
        Me.DateTimePicker1.Size = New System.Drawing.Size(88, 20)
        Me.DateTimePicker1.TabIndex = 1
        '
        'DateTimePicker2
        '
        Me.DateTimePicker2.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.DateTimePicker2.Location = New System.Drawing.Point(224, 53)
        Me.DateTimePicker2.Name = "DateTimePicker2"
        Me.DateTimePicker2.Size = New System.Drawing.Size(88, 20)
        Me.DateTimePicker2.TabIndex = 2
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(24, 53)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(64, 23)
        Me.Label2.TabIndex = 9
        Me.Label2.Text = "von"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(192, 53)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(24, 23)
        Me.Label3.TabIndex = 10
        Me.Label3.Text = "bis"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(224, 120)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 3
        Me.Button1.Text = "&OK"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.Abort
        Me.Button2.Location = New System.Drawing.Point(136, 120)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 4
        Me.Button2.Text = "&Abbruch"
        '
        'cbMitarbeiter
        '
        Me.cbMitarbeiter.Location = New System.Drawing.Point(96, 24)
        Me.cbMitarbeiter.Name = "cbMitarbeiter"
        Me.cbMitarbeiter.Size = New System.Drawing.Size(312, 21)
        Me.cbMitarbeiter.TabIndex = 0
        Me.cbMitarbeiter.Text = "ComboBox1"
        '
        'cbfunktion
        '
        Me.cbfunktion.Location = New System.Drawing.Point(96, 80)
        Me.cbfunktion.Name = "cbfunktion"
        Me.cbfunktion.Size = New System.Drawing.Size(312, 21)
        Me.cbfunktion.TabIndex = 11
        Me.cbfunktion.Text = "ComboBox1"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(24, 82)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(72, 23)
        Me.Label4.TabIndex = 12
        Me.Label4.Text = "Umfang"
        '
        'frmStellvertreterAdd
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(448, 157)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbfunktion, Me.Label4, Me.cbMitarbeiter, Me.Button2, Me.Button1, Me.Label3, Me.Label2, Me.DateTimePicker2, Me.DateTimePicker1, Me.Label1})
        Me.MaximizeBox = False
        Me.MinimizeBox = False
        Me.Name = "frmStellvertreterAdd"
        Me.ShowInTaskbar = False
        Me.Text = "Neuer Stellvertreter"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd.frmStellvertreterAdd_Load Method

Private Sub frmStellvertreterAdd_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmStellvertreterAdd_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        mcbmitarbeiter = New MultiComboBox(Me.cbMitarbeiter)
        Me.mcbmitarbeiter.CheckNullValue = False
        Me.mcbmitarbeiter.NullValueMessage = MyTxt.gettext(18)
        Me.mcbmitarbeiter.DisplayColumnName = "mitarbeiter"
        Me.mcbmitarbeiter.ValueColumnName = "mitarbeiternr"
        Me.mcbmitarbeiter.Fill_Data(Generic_Select(1), False)
        Me.mcbmitarbeiter.SelectedValue = Globals.MitarbeiterNr

        Me.DateTimePicker1.Value = Now
        Me.DateTimePicker2.Value = Now

        'Prüfung, ob aktueller Mitarbeiter Sysadminrechte hat
        Dim menu As New edokadb.clsMySysadminfunkion()
        Dim TV As New TreeView()
        menu.LoadTreeMenu(TV)
        If TV.GetNodeCount(True) > 0 Then
            Me.Label4.Visible = True
            Me.cbfunktion.Visible = True
            Me.mcbStellvertretungtyp = New MultiComboBox(Me.cbfunktion)
            Me.mcbStellvertretungtyp.CheckNullValue = False
            Me.mcbStellvertretungtyp.DisplayColumnName = "bezeichnung"
            Me.mcbStellvertretungtyp.ValueColumnName = "stellvertretungtypnr"
            Me.mcbStellvertretungtyp.Fill_Data(Generic_Select(2), False)
            Dim i As Integer = 0
            Me.mcbStellvertretungtyp.SelectedValue = i
        Else
            Me.Label4.Visible = False
            Me.cbfunktion.Visible = False
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmStellvertreterAdd Fields

frmStellvertreterAdd overview

Fields

field Button1
field Button2
field DateTimePicker1
field DateTimePicker2
field Label1
field Label2
field Label3
field Label4
field cbMitarbeiter
field cbfunktion
field components
field m_stvtyp
field m_vertreter
field mcbStellvertretungtyp
field mcbmitarbeiter

See Also

frmStellvertreterAdd Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


DateTimePicker1 Variable

Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker1 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


DateTimePicker2 Variable

Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents DateTimePicker2 As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


cbMitarbeiter Variable

Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbMitarbeiter As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


cbfunktion Variable

Friend WithEvents cbfunktion As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbfunktion As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


m_stvtyp Variable

Dim m_stvtyp As Integer

Source code

[Visual Basic]
    Dim m_stvtyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


m_vertreter Variable

Dim m_vertreter As Integer

Source code

[Visual Basic]
    Dim m_vertreter As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


mcbStellvertretungtyp Variable

Dim WithEvents mcbStellvertretungtyp As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbStellvertretungtyp As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


mcbmitarbeiter Variable

Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbmitarbeiter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmStellvertreterAdd


frmSuchFormular Class

For a list of all members of this type, see frmSuchFormular Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSuchFormular

Public Class frmSuchFormular
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSuchFormular Members


frmSuchFormular Members

frmSuchFormular overview

Constructors

constructor frmSuchFormular Constructor (Overloaded)

Properties

property show_checkmessage

Methods

method AddDaten
method AddOperator
method Add_Operatoren
method AndOr_erstellen
method BtnHelp_Click
method BuildSQL
method C1TrueDBGrid1_AfterColUpdate
method C1TrueDBGrid1_AfterDelete
method C1TrueDBGrid1_BeforeColUpdate
method C1TrueDBGrid1_BeforeRowColChange
method C1TrueDBGrid1_BeforeUpdate
method C1TrueDBGrid1_Click
method C1TrueDBGrid1_ComboSelect
method C1TrueDBGrid1_DoubleClick
method C1TrueDBGrid1_FetchCellStyle
method C1TrueDBGrid1_FetchRowStyle
method C1TrueDBGrid1_Leave
method C1TrueDBGrid1_MouseDown
method C1TrueDBGrid1_MouseUp
method C1TrueDBGrid1_TextChanged
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu4_Popup
method Datentabelle_erstellen
method Dispose
method DokList_Click
method DokList_DoubleClick
method DokList_FetchRowStyle
method DokList_MouseDown
method Doklist_FetchScrollTips
method FeldWerteValidieren
method Form1_Load
method Format_grid
method Freitext_Suche
method Generic_Select (Overloaded)
method Get_Freitextsuchfeld
method Get_Sql
method InitializeComponent
method Insert_valueitems
method Load_Layout
method Load_Suchprofil
method MenuItem10_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem8_Click
method MenuItem9_Click
method MnuDatenselektion_Click
method MnuDelete_Click
method PartnerSuchResultat
method Run_Sql
method Save_Layout
method Save_Suchprofil
method Show_mittels_Coldviewer
method StartDruckJob
method TabControl1_Click
method TabControl1_SelectedIndexChanged
method TempSQLTabelle
method ToolBar1_ButtonClick
method TreeView1_AfterExpand
method TreeView1_AfterSelect
method TreeView1_BeforeExpand
method TreeView1_BeforeSelect
method TreeView1_MouseDown
method Update_Profildaten
method btnSearch_Click
method cbProfile_KeyDown
method cbProfile_SelectedValueChanged
method check_Berechtigung
method check_cbprofile
method delete_existing_data
method delete_profile
method frmSuchFormular_Resize
method get_profile
method get_suchdaten
method get_suchprofile
method init_treeview
method profile_ergaenzen
method rbzv6monate_CheckedChanged
method rbzvvollständig_CheckedChanged
method save_data
method setcolors
method stammdaten_laden

Fields

field AndOr
field BTNDELETEPROFIL
field BtnHelp
field C1TrueDBGrid1
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field Datachanged
field Daten
field DokList
field DruckThread
field DynNrEintrag
field EDOKADaten
field Gruppierung
field HOSTDaten
field ImageList1
field ImageList2
field ImageList3
field Label1
field MenuItem1
field MenuItem10
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MitFreitext
field MnuDatenselektion
field MnuDelete
field On_Load
field Operatoren
field Panel1
field Panel2
field Partnerdialog
field Pview
field SaveFileDialog1
field Splitter1
field Splitter2
field Splitter3
field Suche
field TabControl1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolTip1
field TreeView1
field UVMDaten
field User_Hat_Berechtigung
field ZVDaten
field btnSave
field btnSearch
field btndruck
field cbProfile
field components
field dokumentid
field gendokcold
field i
field intds
field intdt
field m_NeueSuche
field m_showcheckmessage
field m_updateprofildaten
field oldnode
field parameter
field partnernr
field profile
field rbzv6monate
field rbzvvollständig
field savenode
field selectPoint
field sql
field sqlcollection
field sqlcount
field sqldbfeldformat
field sqlwhere

See Also

frmSuchFormular Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal NeueSuche As Boolean)

See Also

frmSuchFormular | EDOKAApp


frmSuchFormular Properties

frmSuchFormular overview

Properties

property show_checkmessage

See Also

frmSuchFormular Class


frmSuchFormular.show_checkmessage Property

Property show_checkmessage() As Boolean

Source code

[Visual Basic]
    Property show_checkmessage() As Boolean
        Get
            Return m_showcheckmessage
        End Get
        Set(ByVal Value As Boolean)
            m_showcheckmessage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular Methods

frmSuchFormular overview

Methods

method AddDaten
method AddOperator
method Add_Operatoren
method AndOr_erstellen
method BtnHelp_Click
method BuildSQL
method C1TrueDBGrid1_AfterColUpdate
method C1TrueDBGrid1_AfterDelete
method C1TrueDBGrid1_BeforeColUpdate
method C1TrueDBGrid1_BeforeRowColChange
method C1TrueDBGrid1_BeforeUpdate
method C1TrueDBGrid1_Click
method C1TrueDBGrid1_ComboSelect
method C1TrueDBGrid1_DoubleClick
method C1TrueDBGrid1_FetchCellStyle
method C1TrueDBGrid1_FetchRowStyle
method C1TrueDBGrid1_Leave
method C1TrueDBGrid1_MouseDown
method C1TrueDBGrid1_MouseUp
method C1TrueDBGrid1_TextChanged
method ContextMenu1_Popup
method ContextMenu2_Popup
method ContextMenu4_Popup
method Datentabelle_erstellen
method Dispose
method DokList_Click
method DokList_DoubleClick
method DokList_FetchRowStyle
method DokList_MouseDown
method Doklist_FetchScrollTips
method FeldWerteValidieren
method Form1_Load
method Format_grid
method Freitext_Suche
method Generic_Select (Overloaded)
method Get_Freitextsuchfeld
method Get_Sql
method InitializeComponent
method Insert_valueitems
method Load_Layout
method Load_Suchprofil
method MenuItem10_Click
method MenuItem1_Click
method MenuItem2_Click
method MenuItem4_Click
method MenuItem5_Click
method MenuItem6_Click
method MenuItem7_Click
method MenuItem8_Click
method MenuItem9_Click
method MnuDatenselektion_Click
method MnuDelete_Click
method PartnerSuchResultat
method Run_Sql
method Save_Layout
method Save_Suchprofil
method Show_mittels_Coldviewer
method StartDruckJob
method TabControl1_Click
method TabControl1_SelectedIndexChanged
method TempSQLTabelle
method ToolBar1_ButtonClick
method TreeView1_AfterExpand
method TreeView1_AfterSelect
method TreeView1_BeforeExpand
method TreeView1_BeforeSelect
method TreeView1_MouseDown
method Update_Profildaten
method btnSearch_Click
method cbProfile_KeyDown
method cbProfile_SelectedValueChanged
method check_Berechtigung
method check_cbprofile
method delete_existing_data
method delete_profile
method frmSuchFormular_Resize
method get_profile
method get_suchdaten
method get_suchprofile
method init_treeview
method profile_ergaenzen
method rbzv6monate_CheckedChanged
method rbzvvollständig_CheckedChanged
method save_data
method setcolors
method stammdaten_laden

See Also

frmSuchFormular Class


frmSuchFormular.AddDaten Method

Private Function AddDaten( _
   ByVal NodeTag As Integer _
)

Parameters

NodeTag
Required.

Source code

[Visual Basic]
    Private Function AddDaten(ByVal NodeTag As Integer)
        If MitFreitext = 1 Then
            If Me.C1TrueDBGrid1.Splits(0).Rows.Count > 0 Then Exit Function
        End If
        Dim rowvals(10) As Object
        Dim rowcount As Integer
        rowcount = Me.C1TrueDBGrid1.Splits(0).Rows.Count
        If rowcount > 0 And (Me.C1TrueDBGrid1.Columns("OP1").CellText(rowcount - 1) = "" Or Me.C1TrueDBGrid1.Columns("daten1").CellText(rowcount - 1) = "") Then Exit Function
        rowvals(0) = DynNrEintrag
        DynNrEintrag = DynNrEintrag + 1
        'hutter 20040928 rowvals(1) = 0
        rowvals(1) = DynNrEintrag
        rowvals(2) = NodeTag
        rowvals(3) = Globals.MitarbeiterNr
        If Me.C1TrueDBGrid1.Splits(0).Rows.Count > 0 Then
            rowvals(4) = "oder"
        Else
            rowvals(4) = ""
        End If
        rowvals(5) = "="
        rowvals(6) = ""
        rowvals(8) = ""
        rowvals(9) = ""
        rowvals(7) = ""
        rowvals(10) = ""

        For i = 0 To Me.parameter.Rows.Count - 1
            If Me.parameter.Rows(i).Item("nodenr") = Me.TreeView1.SelectedNode.Tag Then
                If Me.parameter.Rows(i).Item("suchdialog") > 0 Then
                    rowvals(7) = 1
                    rowvals(10) = 1
                End If
                Exit For
            End If
        Next

        Me.Daten.Rows.Add(rowvals)
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Locked = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = True

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.AddOperator Method

Private Function AddOperator( _
   ByVal OP As String _
) As Object

Parameters

OP
Required.

Source code

[Visual Basic]
    Private Function AddOperator(ByVal OP As String) As Object
        Dim rowvals(0) As Object
        rowvals(0) = OP
        Return rowvals
        rowvals = Nothing
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Add_Operatoren Method

Private Sub Add_Operatoren( _
   ByVal op As String _
)

Parameters

op
Required.

Source code

[Visual Basic]
    Private Sub Add_Operatoren(ByVal op As String)
        Me.Operatoren.Columns.Clear()
        Me.Operatoren.Rows.Clear()
        Me.Operatoren.Columns.Add("Operator")
        Dim x() As String
        x = op.Split(";")
        Dim j As Integer
        For j = 0 To x.GetUpperBound(0) - 1
            Me.Operatoren.Rows.Add(AddOperator(x(j)))
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.AndOr_erstellen Method

Private Sub AndOr_erstellen()

Source code

[Visual Basic]
    Private Sub AndOr_erstellen()
        Me.AndOr.Columns.Add("AndOr")
        Me.AndOr.Rows.Add(AddOperator("und"))
        Me.AndOr.Rows.Add(AddOperator("oder"))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("dokumentsuche")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.BuildSQL Method

Private Function BuildSQL() As Boolean

Source code

[Visual Basic]
    Private Function BuildSQL() As Boolean
        ' Löschen der Temporären tabelle
        Me.TempSQLTabelle(1, 0, "")
        While sqlcollection.Count > 0
            sqlcollection.Remove(1)
        End While

        Dim i As Integer
        Dim sqlwherevollstaendig As String
        Dim sqlstring As String

        '       Pview = Daten.DefaultView
        '      Pview.Sort = "NodeNr, ID"
        oldnode = -1
        For i = 0 To Me.Daten.Rows.Count - 1
            If Me.Daten.Rows(i).Item("daten1") <> "" Then
                If Me.oldnode <> -1 And Me.oldnode <> Me.Daten.Rows(i).Item("nodenr") Then
                    sqlstring = sqlstring + "(" + sqlwherevollstaendig + ") "
                    sqlwherevollstaendig = ""
                    sqlwhere = ""
                    If Me.rbzv6monate.Visible = True And Me.rbzv6monate.Checked = True Then
                        sqlstring = Replace(sqlstring, "zvbelege.", "zvbelege6mte.")
                    End If
                    sqlcollection.Add(sqlstring)
                    ' SQL_String in temporäre Tabelle schreiben
                    Me.TempSQLTabelle(2, Me.oldnode, sqlstring)
                    sqlstring = ""
                    sqlcount = sqlcount + 1
                    Me.oldnode = Me.Daten.Rows(i).Item("nodenr")
                Else
                    Me.oldnode = Me.Daten.Rows(i).Item("nodenr")
                End If

                Select Case Me.Daten.Rows(i).Item("andor")
                    Case "und"
                        sqlwherevollstaendig = sqlwherevollstaendig + " and "
                    Case "oder"
                        sqlwherevollstaendig = sqlwherevollstaendig + " or "
                End Select

                Get_Sql(Me.Daten.Rows(i).Item("nodenr"))

                Select Case sqldbfeldformat
                    Case "varchar"
                        sqlwhere = sqlwhere.Replace("#Wert", "'#Wert'")
                    Case Else
                End Select

                Select Case Me.Daten.Rows(i).Item("op1")
                    Case "=", "<>", "<=", ">=", ">", "<"
                        sqlwhere = sqlwhere.Replace("#op1", Me.Daten.Rows(i).Item("op1"))
                        If sqldbfeldformat = "datetime" Then
                            Try
                                Dim d As DateTime
                                d = Me.Daten.Rows(i).Item("daten1")
                                sqlwhere = sqlwhere.Replace("#Wert", Format(d, "yyyy-MM-dd"))
                            Catch
                            End Try
                        Else
                            sqlwhere = sqlwhere.Replace("#Wert", Me.Daten.Rows(i).Item("daten1"))
                        End If
                    Case "wie"
                        sqlwhere = sqlwhere.Replace("#op1", " Like ")
                        sqlwhere = sqlwhere.Replace("#Wert", "%" + Me.Daten.Rows(i).Item("daten1") + "%")
                    Case "nicht wie"
                        sqlwhere = sqlwhere.Replace("#op1", " Not Like ")
                        sqlwhere = sqlwhere.Replace("#Wert", "%" + Me.Daten.Rows(i).Item("daten1") + "%")
                    Case "zwischen"
                        sqlwhere = Microsoft.VisualBasic.Left(sqlwhere, InStr(sqlwhere, "#op1") - 1)
                        sqlwhere = sqlwhere + " between "
                        Select Case sqldbfeldformat
                            Case "varchar"
                                sqlwhere = sqlwhere + "'" + Me.Daten.Rows(i).Item("daten1") + "' and '" + Me.Daten.Rows(i).Item("daten2") + "'"
                            Case "datetime"
                                Dim d As DateTime
                                Dim d1 As DateTime
                                d = Me.Daten.Rows(i).Item("daten1")
                                d1 = Me.Daten.Rows(i).Item("daten2")
                                sqlwhere = sqlwhere + "convert(datetime,'" + Format(d, "yyyy-MM-dd") + " 00:00:00',102) and convert(datetime,'" + Format(d1, "yyyy-MM-dd") + " 00:00:00',102)"
                            Case Else
                                sqlwhere = sqlwhere + "'" + Me.Daten.Rows(i).Item("daten1") + "' and '" + Me.Daten.Rows(i).Item("daten2") + "'"
                        End Select
                    Case Else
                End Select
                sqlwherevollstaendig = sqlwherevollstaendig + " " + sqlwhere
                sqlwhere = ""
            End If
        Next
        sqlstring = sqlstring + "(" + sqlwherevollstaendig + ")"
        If sqlstring = "()" Then
            MyMsg.show_standardmessage(805, MsgBoxStyle.Exclamation)
            Return False
        End If

        'Rel 3.5 / BUD - Prüfen ob der Suchtext zu lang ist.
        If Len(sqlstring) > 1024 Then
            MyMsg.show_standardmessage(810, MsgBoxStyle.Exclamation)
            Return False
        End If

        If Me.rbzv6monate.Visible = True And Me.rbzv6monate.Checked = True Then
            sqlstring = Replace(sqlstring, "zvbelege.", "zvbelege6mte.")
        End If

        sqlcollection.Add(sqlstring)
        Me.TempSQLTabelle(2, Me.oldnode, sqlstring)
        '        Pview.Sort = "ID"

        Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_AfterColUpdate Method

Private Sub C1TrueDBGrid1_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles C1TrueDBGrid1.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1TrueDBGrid1.AfterColUpdate
        If Me.TreeView1.SelectedNode.Text = "Freitext" Then
            If Me.C1TrueDBGrid1.Columns("Daten1").Text <> "" Then
                Me.MitFreitext = 1
            Else
                Me.MitFreitext = 0
            End If
        End If
        If Me.C1TrueDBGrid1.Columns("op1").Text <> "zwischen" Then
            Me.C1TrueDBGrid1.Columns("op2").Text = ""
            Me.C1TrueDBGrid1.Columns("daten2").Text = ""
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Locked = True
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = True
        Else
            Me.C1TrueDBGrid1.Columns("op2").Text = "und"
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Locked = True
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = False
        End If
        Me.C1TrueDBGrid1.UpdateData()
        If Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked And Me.C1TrueDBGrid1.Col = 6 And Me.C1TrueDBGrid1.Columns("daten1").Text <> "" Then
            Me.AddDaten(Me.TreeView1.SelectedNode.Tag)
        Else
            If Me.C1TrueDBGrid1.Columns("daten1").Text <> "" And Me.C1TrueDBGrid1.Columns("daten2").Text <> "" Then
                Me.AddDaten(Me.TreeView1.SelectedNode.Tag)
            End If
        End If
        If Me.C1TrueDBGrid1.Col = 5 And Me.C1TrueDBGrid1.Columns("op1").Text = "wie" Or _
        Me.C1TrueDBGrid1.Columns("op1").Text = "zwischen" Then
            Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.Normal
            Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.Normal
        Else
            Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
            Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        End If

        'Rel 3.5 / BUD
        FeldWerteValidieren()
        'Dim s As String
        'Dim F As Double
        'Dim i As Integer
        'Select Case Me.C1TrueDBGrid1.Columns("daten1").EditMask
        '    Case "999999999"
        '        If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
        '        If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
        '        s = Trim(s)
        '        While Len(s) < 9
        '            s = "0" + s
        '        End While
        '        If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
        '        If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
        '    Case "&&&&&&&&&&&&&&&"
        '        If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
        '        If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
        '        s = Trim(s)
        '        i = Len(s)
        '        F = InStr(s, ".")
        '        If F = 0 Then
        '            s = s + ".00"
        '        End If

        '        If i - F = 0 Then s = s + "00"
        '        If i - F = 1 Then s = s + "0"

        '        Try
        '            F = Microsoft.VisualBasic.Val(s)
        '            If F = 0 Then s = "0.00"
        '            If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
        '            If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
        '        Catch
        '            MyMsg.show_standardmessage(801, MsgBoxStyle.Exclamation)
        '        End Try
        '    Case "9999999999999999"
        '        If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
        '        If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
        '        s = Trim(s)
        '        'Falls kein Wert vorhanden ist, keine Nuller anhängen
        '        If Len(s) = 0 Then Exit Select
        '        While Len(s) < 16
        '            s = "0" + s
        '        End While
        '        If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
        '        If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
        'End Select

        Me.C1TrueDBGrid1.Col = Me.C1TrueDBGrid1.Col + 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_AfterDelete Method

Private Sub C1TrueDBGrid1_AfterDelete( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.AfterDelete

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_AfterDelete(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.AfterDelete

        Try
            If Me.C1TrueDBGrid1.Bookmark = 0 Then
                Me.C1TrueDBGrid1.Columns("andor").Text = ""
            End If
        Catch
        End Try
        If Me.TreeView1.SelectedNode.Text = "Freitext" And Me.C1TrueDBGrid1.Splits(0).Rows.Count = 0 Then Me.MitFreitext = 0
        If Me.C1TrueDBGrid1.Splits(0).Rows.Count = 0 Then Me.AddDaten(Me.TreeView1.SelectedNode.Tag)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_BeforeColUpdate Method

Private Sub C1TrueDBGrid1_BeforeColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs _
) Handles C1TrueDBGrid1.BeforeColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_BeforeColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BeforeColUpdateEventArgs) Handles C1TrueDBGrid1.BeforeColUpdate
        'Rel 3.5 / BUD
        FeldWerteValidieren()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_BeforeRowColChange Method

Private Sub C1TrueDBGrid1_BeforeRowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles C1TrueDBGrid1.BeforeRowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_BeforeRowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles C1TrueDBGrid1.BeforeRowColChange
        'Rel 3.5 / BUD
        FeldWerteValidieren()

        If Me.Datachanged = True Then Me.Datachanged = True
        Me.C1TrueDBGrid1.UpdateData()
        setcolors()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_BeforeUpdate Method

Private Sub C1TrueDBGrid1_BeforeUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles C1TrueDBGrid1.BeforeUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_BeforeUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles C1TrueDBGrid1.BeforeUpdate
        'Rel 3.5 / BUD
        FeldWerteValidieren()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_Click Method

Private Sub C1TrueDBGrid1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.Click
        If C1TrueDBGrid1.Splits.Count > 0 Then	   'RST 2006-2006-10-04
            If C1TrueDBGrid1.Splits(0).DisplayColumns.Count > 0 Then		  'RST 2006-2006-10-04
                If Me.C1TrueDBGrid1.Row = 0 Then
                    Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").Locked = True
                Else
                    Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").Locked = False
                End If
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_ComboSelect Method

Private Sub C1TrueDBGrid1_ComboSelect( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles C1TrueDBGrid1.ComboSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_ComboSelect(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles C1TrueDBGrid1.ComboSelect
        If Me.C1TrueDBGrid1.Col = 6 Then
            Me.C1TrueDBGrid1.Columns("key1").Value = Me.C1TrueDBGrid1.Columns(Me.C1TrueDBGrid1.Col).Value
        End If
        Me.C1TrueDBGrid1.UpdateData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.DoubleClick
        If C1TrueDBGrid1.Splits(0).DisplayColumns.Count > 0 Then
            Me.MnuDatenselektion_Click(sender, e)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_FetchCellStyle Method

Private Sub C1TrueDBGrid1_FetchCellStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs _
) Handles C1TrueDBGrid1.FetchCellStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs) Handles C1TrueDBGrid1.FetchCellStyle
        If e.Col = 4 Then
            If Me.C1TrueDBGrid1.Columns(4).CellText(e.Row) = "und" Or Me.C1TrueDBGrid1.Columns(4).CellText(e.Row) = "oder" Then
                e.CellStyle.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Near
            Else
                e.CellStyle.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_FetchRowStyle Method

Private Sub C1TrueDBGrid1_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles C1TrueDBGrid1.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1TrueDBGrid1.FetchRowStyle
        Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
        Dim bmp0 As New Bitmap(Me.ImageList3.Images(0))
        Dim bmp1 As New Bitmap(Me.ImageList3.Images(0))

        v0.DisplayValue = bmp0
        v0.Value = 1

        v1.DisplayValue = bmp1
        v1.Value = 1

        Me.C1TrueDBGrid1.Columns(7).ValueItems.Values.Add(v0)
        Me.C1TrueDBGrid1.Columns(10).ValueItems.Values.Add(v1)
        Me.C1TrueDBGrid1.Columns(7).ValueItems.Translate = True
        Me.C1TrueDBGrid1.Columns(10).ValueItems.Translate = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("btn1").Locked = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("btn2").Locked = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_Leave Method

Private Sub C1TrueDBGrid1_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.Leave
        Try
            Me.C1TrueDBGrid1.UpdateData()
            setcolors()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_MouseDown Method

Private Sub C1TrueDBGrid1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles C1TrueDBGrid1.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1TrueDBGrid1.MouseUp
        Me.C1TrueDBGrid1.Bookmark = Me.C1TrueDBGrid1.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_MouseUp Method

Private Sub C1TrueDBGrid1_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles C1TrueDBGrid1.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles C1TrueDBGrid1.MouseUp
        Try
            If Me.C1TrueDBGrid1.Columns("op1").Text = "zwischen" Then
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Locked = False
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = False
            Else
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Locked = True
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = True
            End If

            If Me.C1TrueDBGrid1.ColContaining(e.X) = 7 And Me.C1TrueDBGrid1.Columns(7).Value = 1 Then
                Me.MnuDatenselektion_Click(sender, e)
                Exit Sub
            End If
            If Me.C1TrueDBGrid1.ColContaining(e.X) = 10 And Me.C1TrueDBGrid1.Columns(10).Value = 1 And Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Daten2").Locked = False Then
                Me.MnuDatenselektion_Click(sender, e)
                Exit Sub
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.C1TrueDBGrid1_TextChanged Method

Private Sub C1TrueDBGrid1_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.TextChanged
        setcolors()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Try
            'noch keine suchresultate
            Dim item As MenuItem
            If C1TrueDBGrid1.Splits(0).Rows.Count <= 0 Then
                For Each item In ContextMenu1.MenuItems
                    item.Enabled = False
                Next
            Else
                For Each item In ContextMenu1.MenuItems
                    item.Enabled = True
                Next
            End If
        Catch ex As Exception
            MessageBox.Show(EDOKALib.BusinessFacade.Meldungstext.GetInhaltById(300) + vbCrLf + vbCrLf + ex.Message + vbCrLf + ex.StackTrace, EDOKALib.Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Try
            Me.MenuItem2.Enabled = False
            Me.MenuItem10.Enabled = False
            User_Hat_Berechtigung = False
            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            Try
                If d.Rows(0).Item("anzeigen") = 1 Then
                    Me.User_Hat_Berechtigung = True
                    Me.MenuItem2.Enabled = True
                    Me.MenuItem10.Enabled = True
                Else
                    Me.MenuItem2.Enabled = False
                    Me.User_Hat_Berechtigung = False
                    Me.MenuItem10.Enabled = False
                End If
            Catch
            End Try
        Catch
            User_Hat_Berechtigung = True
            Me.MenuItem2.Enabled = True
            Me.MenuItem10.Enabled = True

        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.ContextMenu4_Popup Method

Private Sub ContextMenu4_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu4.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu4_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu4.Popup
        Dim i As Integer
        If Not IsNothing(TreeView1.SelectedNode) Then
            If Me.TreeView1.SelectedNode.GetNodeCount(True) > 0 Then
                Me.MenuItem8.Enabled = False
            Else
                Me.MenuItem8.Enabled = True
            End If
        Else
            Me.MenuItem8.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Datentabelle_erstellen Method

Private Function Datentabelle_erstellen()

Source code

[Visual Basic]
    Private Function Datentabelle_erstellen()
        Me.Daten.Columns.Add("ID")
        Me.Daten.Columns.Add("Suchprofilnr")
        Me.Daten.Columns.Add("NodeNr")
        Me.Daten.Columns.Add("Mitarbeiternr")
        Me.Daten.Columns.Add("ANDOR")
        Me.Daten.Columns.Add("OP1")
        Me.Daten.Columns.Add("Daten1")
        Me.Daten.Columns.Add("Btn1")
        Me.Daten.Columns.Add("OP2")
        Me.Daten.Columns.Add("Daten2")
        Me.Daten.Columns.Add("btn2")
        Me.Daten.Columns.Add("Key1")
        Me.Daten.Columns.Add("Key2")

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.DokList_Click Method

Private Sub DokList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.DokList_DoubleClick Method

Private Sub DokList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DokList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles DokList.DoubleClick
        Try
            Me.MenuItem2.Enabled = False
            Me.MenuItem10.Enabled = False
            User_Hat_Berechtigung = False
            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            Try
                If d.Rows(0).Item("anzeigen") = 1 Then
                    Me.User_Hat_Berechtigung = True
                    Me.MenuItem2.Enabled = True
                    Me.MenuItem10.Enabled = True
                Else
                    Me.MenuItem2.Enabled = False
                    Me.User_Hat_Berechtigung = False
                    Me.MenuItem10.Enabled = False
                End If
            Catch
            End Try
        Catch
            User_Hat_Berechtigung = True
            Me.MenuItem2.Enabled = True
            Me.MenuItem10.Enabled = True

        End Try
        Try
            Me.MenuItem2_Click(sender, e)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.DokList_FetchRowStyle Method

Private Sub DokList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle
        '***********************
        'Release 3.3 / korrigiert Rel 3.5
        '08.11.2004 / BUD
        '***********************
        Try
            If Me.DokList.Columns("Statusbezeichnungnr").CellValue(e.Row) = -3 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Try
            Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
            Try
                Me.partnernr = Me.DokList.Columns("partnernr").Text
            Catch ex As Exception
                Try
                    Me.partnernr = Me.DokList.Columns("partnernr_inhaber").Text
                Catch ex1 As Exception
                    Try
                        Me.partnernr = Me.DokList.Columns(20).Text
                    Catch
                    End Try
                End Try
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Doklist_FetchScrollTips Method

Private Sub Doklist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles DokList.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Doklist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles DokList.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Horizontal
                    e.ScrollTip = Me.DokList.Columns(e.ColIndex).Caption
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " of " & _
                        CStr(Me.DokList.Splits(0).Rows.Count)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.FeldWerteValidieren Method

Private Sub FeldWerteValidieren()

Source code

[Visual Basic]
    Private Sub FeldWerteValidieren()
        Dim s As String
        Dim F As Double
        Dim i As Integer
        Select Case Me.C1TrueDBGrid1.Columns("daten1").EditMask
            Case "999999999"
                If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
                If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
                s = Trim(s)
                While Len(s) < 9
                    s = "0" + s
                End While
                If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
                If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
            Case "&&&&&&&&&&&&&&&"
                If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
                If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
                s = Trim(s)
                i = Len(s)
                F = InStr(s, ".")
                If F = 0 Then
                    s = s + ".00"
                End If

                If i - F = 0 Then s = s + "00"
                If i - F = 1 Then s = s + "0"

                Try
                    F = Microsoft.VisualBasic.Val(s)
                    If F = 0 Then s = "0.00"
                    If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
                    If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
                Catch
                    MyMsg.show_standardmessage(801, MsgBoxStyle.Exclamation)
                End Try
            Case "9999999999999999"
                If Me.C1TrueDBGrid1.Col = 6 Then s = Me.C1TrueDBGrid1.Columns("Daten1").Text
                If Me.C1TrueDBGrid1.Col = 9 Then s = Me.C1TrueDBGrid1.Columns("Daten2").Text
                s = Trim(s)
                'Falls kein Wert vorhanden ist, keine Nuller anhängen
                If Len(s) = 0 Then Exit Select
                While Len(s) < 16
                    s = "0" + s
                End While
                If Me.C1TrueDBGrid1.Col = 6 Then Me.C1TrueDBGrid1.Columns(6).Text = s
                If Me.C1TrueDBGrid1.Col = 9 Then Me.C1TrueDBGrid1.Columns(9).Text = s
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.On_Load = True
        Dim db As New EDOKA.DB_Connection()
        init_treeview()
        For i = 0 To 50
            intds.Tables.Add(New DataTable())
        Next
        Datentabelle_erstellen()
        AndOr_erstellen()
        Me.C1TrueDBGrid1.Splits(0).FetchRowStyles = True

        get_suchprofile()
        Me.TreeView1.Select()
        Me.TreeView1.Focus()
        check_cbprofile()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Format_grid Method

Private Sub Format_grid()

Source code

[Visual Basic]
    Private Sub Format_grid()
        Dim i As Integer
        Me.C1TrueDBGrid1.Columns("OP1").ValueItems.Values.Clear()
        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Values.Clear()
        Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.Normal
        Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.Normal

        Me.C1TrueDBGrid1.Columns("op1").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        For i = 0 To Operatoren.Rows.Count - 1
            Dim v As New C1.Win.C1TrueDBGrid.ValueItem()
            v.DisplayValue = Operatoren.Rows(i).Item(0)
            v.Value = Operatoren.Rows(i).Item(0)
            Me.C1TrueDBGrid1.Columns("op1").ValueItems.Values.Add(v)
        Next
        Me.C1TrueDBGrid1.Columns("op1").ValueItems.MaxComboItems = 10
        Me.C1TrueDBGrid1.Columns("op1").ValueItems.Translate = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op1").FetchStyle = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op1").AutoComplete = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op1").AutoDropDown = True

        Me.C1TrueDBGrid1.Columns("andor").Caption = "Und/Oder"
        Me.C1TrueDBGrid1.Columns("op1").Caption = "Operator"
        Me.C1TrueDBGrid1.Columns("daten1").Caption = "1. Kriterium"
        Me.C1TrueDBGrid1.Columns("op2").Caption = "Operator"
        Me.C1TrueDBGrid1.Columns("daten2").Caption = "2. Kriterium"
        Me.C1TrueDBGrid1.Columns("BTN1").Caption = "S"
        Me.C1TrueDBGrid1.Columns("BTN2").Caption = "S"

        Me.C1TrueDBGrid1.Columns("ANDOR").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
        v1.DisplayValue = "und"
        v1.Value = "und"
        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Values.Add(v1)
        Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
        v2.DisplayValue = "oder"
        v2.Value = "oder"
        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Values.Add(v2)
        '        Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
        '        v3.DisplayValue = "> und"
        '        v3.Value = "> und"
        '        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Values.Add(v3)
        '        Dim v4 As New C1.Win.C1TrueDBGrid.ValueItem()
        '        v4.DisplayValue = "> oder"
        '        v4.Value = "> oder"
        '        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Values.Add(v4)

        Me.C1TrueDBGrid1.Columns("andor").ValueItems.MaxComboItems = 10
        Me.C1TrueDBGrid1.Columns("andor").ValueItems.Translate = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").FetchStyle = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").AutoComplete = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").AutoDropDown = True

        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(0).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(1).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(2).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(3).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(11).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(12).Visible = False
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(4).Width = 70
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(5).Width = 70
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(6).Width = 140
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(7).Width = 20
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(8).Width = 70
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(9).Width = 140
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(10).Width = 20
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(4).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(5).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(8).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(7).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns(10).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Center

        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("andor").Style.ForeColor = System.Drawing.Color.Blue
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op1").Style.ForeColor = System.Drawing.Color.Blue
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("op2").Style.ForeColor = System.Drawing.Color.Blue
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Freitext_Suche Method

Private Sub Freitext_Suche()

Source code

[Visual Basic]
    Private Sub Freitext_Suche()
        Me.Cursor = Cursors.WaitCursor
        Dim suchdaten As New DataTable()
        Me.TabControl1.SelectedIndex = 1
        Me.Refresh()
        suchdaten.Columns.Add("feld")
        suchdaten.Columns.Add("Wert1")
        suchdaten.Columns.Add("Wert2")
        suchdaten.Columns.Add("OP")
        Me.DokList.DataSource = Nothing
        Try
            Me.TabControl1.Enabled = False
            Dim rowvals(3) As Object
            For i = 0 To Me.Daten.Rows.Count - 1
                If Me.Daten.Rows(i).Item("daten1") <> "" Then
                    rowvals(0) = Me.Get_Freitextsuchfeld(Me.Daten.Rows(i).Item("nodenr"))
                    rowvals(1) = Me.Daten.Rows(i).Item("daten1")
                    rowvals(2) = Me.Daten.Rows(i).Item("daten2")
                    rowvals(3) = Me.Daten.Rows(i).Item("op1")
                    suchdaten.Rows.Add(rowvals)
                End If
            Next i
            Dim coldsuche As New frmcoldview()
            Dim t As New DataTable()
            Try
                If Me.TreeView1.SelectedNode.Parent.Tag = 7 Then
                    t = coldsuche.frmSuchform_Freitextsuche(suchdaten, "", "UVM")
                Else
                    t = coldsuche.frmSuchform_Freitextsuche(suchdaten, "", "ZV")
                End If
            Catch
                If Me.TreeView1.SelectedNode.Tag = 7 Then
                    t = coldsuche.frmSuchform_Freitextsuche(suchdaten, "", "UVM")
                End If
                If Me.TreeView1.SelectedNode.Tag = 8 Then
                    t = coldsuche.frmSuchform_Freitextsuche(suchdaten, "", "ZV")
                End If
            End Try
            Me.DokList.DataSource = t
            If t.Rows.Count < 1 Then
                MyMsg.show_standardmessage(806, MsgBoxStyle.Information)
                Me.TabControl1.SelectedIndex = 0
                Me.TabControl1.Enabled = True
                Me.Cursor = Cursors.Default
                Exit Sub
            End If

            Try
                'Berechtigungsprüfung auf Ebene Mitarbeiter/VIP und sofern der angemeldete Benutze¨r
                'keine Berechtigung hat, Record löschen
                For i = 0 To t.Rows.Count - 1
                    If Me.ZVDaten = True Then
                        If check_Berechtigung(t.Rows(i).Item("partnernr"), t.Rows(i).Item("BEZEICHNUNG"), "ZV") = False Then
                            t.Rows(i).Delete()
                            i = i - 1
                        End If
                    Else
                        If check_Berechtigung(t.Rows(i).Item("partnernr"), t.Rows(i).Item("BEZEICHNUNG"), "UVM") = False Then
                            t.Rows(i).Delete()
                            i = i - 1
                        End If
                    End If
                Next
            Catch
            End Try
            If t.Rows.Count < 1 Then
                MyMsg.show_standardmessage(806, MsgBoxStyle.Information)
                Me.TabControl1.SelectedIndex = 0
                Me.TabControl1.Enabled = True
                Me.Cursor = Cursors.Default
                Exit Sub
            End If

            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, t, "trefferliste")
            For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                If UCase(Me.DokList.Columns(i).DataField) = "PARTNERNR_INHABER" Then HOSTDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "NRAUF00" Then UVMDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "CDVAR00" Then ZVDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "GESCHAEFTSFALL" Then EDOKADaten = True
                Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
            Next
            Try
                Me.DokList.Splits(0).DisplayColumns(8).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
            Catch EX As Exception

            End Try
            Me.TabControl1.Enabled = True
            Me.TabControl1.SelectedIndex = 1
            Me.Cursor = Cursors.Default
        Catch EX As Exception
            Me.TabControl1.Enabled = True
            Me.Cursor = Cursors.Default
        Finally

        End Try
        'Me.DokList.DataMember = t.TableName
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Generic_Select Method

Overload List

[Visual Basic] Private Function Generic_Select(ByVal typ As Integer) As DataTable

[Visual Basic] Private Function Generic_Select(ByVal typ As Integer, ByVal sp As String) As DataTable

See Also

frmSuchFormular | EDOKAApp


frmSuchFormular.Get_Freitextsuchfeld Method

Private Function Get_Freitextsuchfeld( _
   ByVal Nodenr As Integer _
)

Parameters

Nodenr
Required.

Source code

[Visual Basic]
    Private Function Get_Freitextsuchfeld(ByVal Nodenr As Integer)
        Dim i As Integer
        For i = 0 To Me.parameter.Rows.Count - 1
            If Me.parameter.Rows(i).Item("nodenr") = Nodenr Then
                Return Me.parameter.Rows(i).Item("Freitextsuchfeld")
                Exit For
            End If
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Get_Sql Method

Private Function Get_Sql( _
   ByVal Nodenr As Integer _
)

Parameters

Nodenr
Required.

Source code

[Visual Basic]
    Private Function Get_Sql(ByVal Nodenr As Integer)
        Dim i As Integer
        For i = 0 To Me.parameter.Rows.Count - 1
            If Me.parameter.Rows(i).Item("nodenr") = Nodenr Then
                sqlwhere = Me.parameter.Rows(i).Item("sqlwhere")
                sqldbfeldformat = Me.parameter.Rows(i).Item("dbfeldformat")
                Exit For
            End If
        Next
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmSuchFormular))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.Suche = New System.Windows.Forms.TabPage()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.btnSearch = New System.Windows.Forms.Button()
        Me.Splitter3 = New System.Windows.Forms.Splitter()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDatenselektion = New System.Windows.Forms.MenuItem()
        Me.MnuDelete = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.TreeView1 = New System.Windows.Forms.TreeView()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.Gruppierung = New System.Windows.Forms.TabPage()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.btndruck = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.btnSave = New System.Windows.Forms.ToolBarButton()
        Me.BTNDELETEPROFIL = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.cbProfile = New System.Windows.Forms.ComboBox()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.SaveFileDialog1 = New System.Windows.Forms.SaveFileDialog()
        Me.rbzv6monate = New System.Windows.Forms.RadioButton()
        Me.rbzvvollständig = New System.Windows.Forms.RadioButton()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.TabControl1.SuspendLayout()
        Me.Suche.SuspendLayout()
        Me.Panel2.SuspendLayout()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.Gruppierung.SuspendLayout()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Suche, Me.Gruppierung})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl1.Location = New System.Drawing.Point(0, 25)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(792, 508)
        Me.TabControl1.TabIndex = 0
        '
        'Suche
        '
        Me.Suche.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel2, Me.Splitter3, Me.C1TrueDBGrid1, Me.Panel1, Me.Splitter1, Me.TreeView1})
        Me.Suche.Location = New System.Drawing.Point(4, 22)
        Me.Suche.Name = "Suche"
        Me.Suche.Size = New System.Drawing.Size(784, 482)
        Me.Suche.TabIndex = 0
        Me.Suche.Text = "Suche"
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnSearch})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Location = New System.Drawing.Point(163, 235)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(621, 29)
        Me.Panel2.TabIndex = 7
        '
        'btnSearch
        '
        Me.btnSearch.Name = "btnSearch"
        Me.btnSearch.Size = New System.Drawing.Size(120, 24)
        Me.btnSearch.TabIndex = 5
        Me.btnSearch.Text = "Suchen"
        '
        'Splitter3
        '
        Me.Splitter3.Dock = System.Windows.Forms.DockStyle.Top
        Me.Splitter3.Location = New System.Drawing.Point(163, 232)
        Me.Splitter3.Name = "Splitter3"
        Me.Splitter3.Size = New System.Drawing.Size(621, 3)
        Me.Splitter3.TabIndex = 6
        Me.Splitter3.TabStop = False
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowDelete = True
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = False
        Me.C1TrueDBGrid1.AllowUpdateOnBlur = False
        Me.C1TrueDBGrid1.AlternatingRows = True
        Me.C1TrueDBGrid1.BackColor = System.Drawing.Color.White
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.ContextMenu = Me.ContextMenu1
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.Dock = System.Windows.Forms.DockStyle.Top
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(163, 32)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.FloatingEditor
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.SystemColors.Control
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(621, 200)
        Me.C1TrueDBGrid1.SpringMode = True
        Me.C1TrueDBGrid1.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.C1TrueDBGrid1.TabIndex = 3
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;Border:Raised,,1, 1, 1, 1;}Normal{BackColor:White;}HighlightRow{ForeColor:Hi" & _
        "ghlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordS" & _
        "elector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1," & _
        " 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;" & _
        "}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid" & _
        ".MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHe" & _
        "ight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyle=""FloatingEd" & _
        "itor"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" Horiz" & _
        "ontalScrollGroup=""1"" SpringMode=""True""><ClientRect>0, 0, 617, 196</ClientRect><B" & _
        "orderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyl" & _
        "e parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><Fi" & _
        "lterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""" & _
        "Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Headin" & _
        "g"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><Inactiv" & _
        "eStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" " & _
        "/><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle par" & _
        "ent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1Tru" & _
        "eDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style pa" & _
        "rent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent" & _
        "=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=" & _
        """Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Nor" & _
        "mal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""No" & _
        "rmal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=" & _
        """Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><ve" & _
        "rtSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modified</Layout><Defau" & _
        "ltRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 617, 196</ClientArea></Bl" & _
        "ob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDatenselektion, Me.MnuDelete, Me.MenuItem9})
        '
        'MnuDatenselektion
        '
        Me.MnuDatenselektion.Index = 0
        Me.MnuDatenselektion.Text = "&Datenselektion"
        '
        'MnuDelete
        '
        Me.MnuDelete.Index = 1
        Me.MnuDelete.Text = "&Eintrag löschen"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 2
        Me.MenuItem9.Text = "Alle Einträge löschen"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Location = New System.Drawing.Point(163, 0)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(621, 32)
        Me.Panel1.TabIndex = 5
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(608, 23)
        Me.Label1.TabIndex = 0
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(160, 0)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 482)
        Me.Splitter1.TabIndex = 2
        Me.Splitter1.TabStop = False
        '
        'TreeView1
        '
        Me.TreeView1.ContextMenu = Me.ContextMenu4
        Me.TreeView1.Dock = System.Windows.Forms.DockStyle.Left
        Me.TreeView1.FullRowSelect = True
        Me.TreeView1.ImageList = Me.ImageList2
        Me.TreeView1.Name = "TreeView1"
        Me.TreeView1.Nodes.AddRange(New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Dokument", 0, 0, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Daten"), New System.Windows.Forms.TreeNode("Dokumentart"), New System.Windows.Forms.TreeNode("Dokumentstatus"), New System.Windows.Forms.TreeNode("Partner")}), New System.Windows.Forms.TreeNode("Ersteller", 8, 8, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Mutierer", 9, 9, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")}), New System.Windows.Forms.TreeNode("Verantwortlich", 7, 7, New System.Windows.Forms.TreeNode() {New System.Windows.Forms.TreeNode("Kostenstelle"), New System.Windows.Forms.TreeNode("Marktbereich"), New System.Windows.Forms.TreeNode("Mitarbeiter"), New System.Windows.Forms.TreeNode("Niederlassung"), New System.Windows.Forms.TreeNode("Team")})})
        Me.TreeView1.Size = New System.Drawing.Size(160, 482)
        Me.TreeView1.TabIndex = 1
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem8})
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 0
        Me.MenuItem8.Text = "Selektionskriterien löschen"
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'Gruppierung
        '
        Me.Gruppierung.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokList})
        Me.Gruppierung.Location = New System.Drawing.Point(4, 22)
        Me.Gruppierung.Name = "Gruppierung"
        Me.Gruppierung.Size = New System.Drawing.Size(784, 482)
        Me.Gruppierung.TabIndex = 1
        Me.Gruppierung.Text = "Resultat"
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu2
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines2
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(784, 482)
        Me.DokList.TabIndex = 10
        Me.DokList.Text = "C1TrueDBGrid2"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:224, 224, 224;}" & _
        "Selected{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor" & _
        ":InactiveCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 19" & _
        "2;}Footer{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightTex" & _
        "t;BackColor:Highlight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading" & _
        "{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;Ali" & _
        "gnVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9" & _
        "{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowS" & _
        "tyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" " & _
        "FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSel" & _
        "ectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGrou" & _
        "p=""1""><ClientRect>0, 0, 780, 478</ClientRect><BorderSide>0</BorderSide><CaptionS" & _
        "tyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><" & _
        "EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" m" & _
        "e=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gro" & _
        "up"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSty" & _
        "le parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Styl" & _
        "e4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Re" & _
        "cordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Sty" & _
        "le parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Named" & _
        "Styles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Sty" & _
        "le parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style " & _
        "parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style p" & _
        "arent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style p" & _
        "arent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent" & _
        "=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style " & _
        "parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplit" & _
        "s>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth>" & _
        "<ClientArea>0, 0, 780, 478</ClientArea></Blob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2, Me.MenuItem10, Me.MenuItem1, Me.MenuItem3, Me.MenuItem4, Me.MenuItem5, Me.MenuItem6})
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Dokument anzeigen"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 1
        Me.MenuItem10.Text = "&Dokument(e) drucken"
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 2
        Me.MenuItem1.Text = "&Partnerdossier"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 3
        Me.MenuItem3.Text = "-"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 4
        Me.MenuItem4.Text = "Spalten-Selektion"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 5
        Me.MenuItem5.Text = "Spalten-Darstellung sichern"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 6
        Me.MenuItem6.Text = "Standard-Spalten-Darstellung"
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton4, Me.btndruck, Me.ToolBarButton3, Me.ToolBarButton2, Me.btnSave, Me.BTNDELETEPROFIL})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(792, 25)
        Me.ToolBar1.TabIndex = 8
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        Me.ToolBarButton1.ToolTipText = "Schliessen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 21
        Me.ToolBarButton4.ToolTipText = "Neue Dokumentsuche"
        '
        'btndruck
        '
        Me.btndruck.ImageIndex = 1
        Me.btndruck.ToolTipText = "Resultate drucken"
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 22
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 15
        Me.ToolBarButton2.ToolTipText = "Profil initialisieren"
        '
        'btnSave
        '
        Me.btnSave.ImageIndex = 16
        Me.btnSave.ToolTipText = "Suchprofil speichern"
        '
        'BTNDELETEPROFIL
        '
        Me.BTNDELETEPROFIL.ImageIndex = 18
        Me.BTNDELETEPROFIL.ToolTipText = "Aktuelles Suchprofil löschen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(0, 25)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(3, 508)
        Me.Splitter2.TabIndex = 9
        Me.Splitter2.TabStop = False
        '
        'cbProfile
        '
        Me.cbProfile.AllowDrop = True
        Me.cbProfile.ContextMenu = Me.ContextMenu3
        Me.cbProfile.Location = New System.Drawing.Point(167, 5)
        Me.cbProfile.Name = "cbProfile"
        Me.cbProfile.Size = New System.Drawing.Size(172, 21)
        Me.cbProfile.TabIndex = 25
        Me.cbProfile.Text = "ComboBox1"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Text = "&Dokumentsuche zurücksetzen"
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'SaveFileDialog1
        '
        Me.SaveFileDialog1.FileName = "Resultate_Dokumentsuche"
        '
        'rbzv6monate
        '
        Me.rbzv6monate.Location = New System.Drawing.Point(353, 3)
        Me.rbzv6monate.Name = "rbzv6monate"
        Me.rbzv6monate.Size = New System.Drawing.Size(224, 16)
        Me.rbzv6monate.TabIndex = 26
        Me.rbzv6monate.Text = "Suche innerhalb der letzten 6 Monate"
        Me.ToolTip1.SetToolTip(Me.rbzv6monate, "Datenbestand mit Valutadatum innerhalb der letzen 6 Monate durchsuchen")
        '
        'rbzvvollständig
        '
        Me.rbzvvollständig.Location = New System.Drawing.Point(353, 19)
        Me.rbzvvollständig.Name = "rbzvvollständig"
        Me.rbzvvollständig.Size = New System.Drawing.Size(144, 16)
        Me.rbzvvollständig.TabIndex = 27
        Me.rbzvvollständig.Text = "Vollständige Suche"
        Me.ToolTip1.SetToolTip(Me.rbzvvollständig, "Vollständiger Datenbestand durchsuchen")
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(704, 3)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 33
        '
        'frmSuchFormular
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(792, 533)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.rbzvvollständig, Me.rbzv6monate, Me.cbProfile, Me.Splitter2, Me.TabControl1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmSuchFormular"
        Me.Text = "Dokumentsuche"
        Me.TabControl1.ResumeLayout(False)
        Me.Suche.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.Gruppierung.ResumeLayout(False)
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Insert_valueitems Method

Private Function Insert_valueitems( _
   ByVal tbl As DataTable _
)

Parameters

tbl
Required.

Source code

[Visual Basic]
    Private Function Insert_valueitems(ByVal tbl As DataTable)
        Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Values.Clear()
        Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Values.Clear()
        Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox
        Dim i As Integer
        For i = 0 To tbl.Rows.Count - 1
            If tbl.Rows(i).Item(2) = True Or tbl.Columns.Count < 2 Then
                Dim v As New C1.Win.C1TrueDBGrid.ValueItem()
                v.DisplayValue = tbl.Rows(i).Item(1)
                v.Value = tbl.Rows(i).Item(0)
                Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Values.Add(v)
                Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Values.Add(v)
            End If
        Next
        Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Translate = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten1").FetchStyle = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten1").AutoComplete = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten1").AutoDropDown = True
        Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Translate = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").FetchStyle = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").AutoComplete = True
        Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").AutoDropDown = True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Load_Layout Method

Private Function Load_Layout( _
   ByVal suchprofilnr As Integer _
) As Boolean

Parameters

suchprofilnr
Required.

Source code

[Visual Basic]
    Private Function Load_Layout(ByVal suchprofilnr As Integer) As Boolean
        Dim docname As String
        Try
            docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "s.lyt", "")
            If HOSTDaten = True Then docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "HOSTs.lyt", "")
            If ZVDaten = True Then docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "ZVs.lyt", "")
            If UVMDaten = False Then
            Else
                docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "UVMs.lyt", "")
            End If
        Catch
        End Try

        If Dir(docname) = "" Then
            Dim p As New DocMgmt()
            '***********************************
            'Standardlayout laden entfernt
            '29.7.2004 / SHU
            '***********************************
            Try
                If p.Get_suchlayout_from_DB(suchprofilnr, docname) <> "" Then
                    Me.DokList.LoadLayout(docname)
                    Return True
                End If
            Catch
            Finally
                p = Nothing
                Load_Layout = False
            End Try
        Else

            Me.DokList.LoadLayout(docname)
            Return True
        End If
        Dim i As Integer
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Load_Suchprofil Method

Private Sub Load_Suchprofil( _
   ByVal profilname As String _
)

Parameters

profilname
Required.

Source code

[Visual Basic]
    Private Sub Load_Suchprofil(ByVal profilname As String)
        Dim Connection As New SqlConnection()
        Dim DA As New SqlDataAdapter("select * from suchprofil where mitarbeiternr=" + Trim(Str(Globals.MitarbeiterNr)) + " and Profilname='" + profilname + "'", Connection)
        Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
        Dim ds As New DataSet()

        Connection.ConnectionString = Globals.sConnectionString
        Connection.Open()
        DA.Fill(ds, "Profil")
        If ds.Tables(0).Rows.Count > 0 Then
            MyMsg.show_standardmessage(804, MsgBoxStyle.Exclamation)
            Connection.Close()
            Exit Sub
        End If
        Me.Daten = ds.Tables(0).Rows(0).Item(2)
        'MsgBox(Me.Daten.Rows.Count)
        cb = Nothing
        ds = Nothing
        DA = Nothing
        Connection.Close()
        Connection = Nothing

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        Dim show_Berechtigungsmeldung As Boolean = False

        Dim gendokCold As New Collection()
        Dim gendokOffice As New Collection()

        If Me.DokList.SelectedRows.Count = 0 Then
            Try
                Me.Cursor = Cursors.WaitCursor
                If HOSTDaten Then
                    'Host Daten abfüllen
                    gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
                    clsMehrfachdruck_Data.Enum_Typ.HOST, False, Me.DokList.Columns("dokumenttypnr").Text, "", Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("valutadatum").Text))
                    fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                    Exit Sub
                End If

                If ZVDaten Then
                    'ZV Daten abfüllen
                    gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns(1).Text, Me.DokList.Columns(3).Text, _
                     clsMehrfachdruck_Data.Enum_Typ.ZV, False, Me.DokList.Columns(0).Text, Me.DokList.Columns(2).Text, "", Me.DokList.Columns(8).Text))
                    fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                    Exit Sub
                End If

                If User_Hat_Berechtigung Then
                    Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                    scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
                    scmCmdToExecute.CommandType = CommandType.StoredProcedure
                    Dim dtToReturn As DataTable = New DataTable()
                    Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                    Try
                        scmCmdToExecute.Connection = conn.scoDBConnection
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                        sdaAdapter.Fill(dtToReturn)

                        'Zuerst prüfen ob das Cold Bild vorhanden ist.
                        If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                            'DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").Value, Me, Me.DokList.Columns("dokumentid").Value)
                            gendokCold.Add(New clsMehrfachdruck_Data(DivFnkt.get_colddokumentid(Me.DokList.Columns("dokumentid").Value, 0), Me.DokList.Columns("partnernr").Value, clsMehrfachdruck_Data.Enum_Typ.EDOKA, False, "", "", "", ""))
                            fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                        Else
                            If scmCmdToExecute.Parameters("@office").Value > 0 Then
                                DivFnkt.print_office(Me.DokList.Columns("dokumentid").Value, Me)
                            End If
                        End If
                    Catch
                    End Try
                Else
                    MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
                End If
            Catch ex As Exception
            Finally
                Me.Cursor = Cursors.Default
            End Try
        Else
            'Mehrere Dokumente gewählt
            Dim i As Integer
            Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
            colRows = Me.DokList.SelectedRows

            If colRows.Count > 200 Then
                MsgBox("Sie können nicht mehr als 200 Dokumente auf einmal drucken. Sie haben " + LTrim(Str(colRows.Count)) + " Dokumente ausgewählt.", MsgBoxStyle.Exclamation)
                Exit Sub
            End If

            'Wenn mehr als ein Dokument selektiert ist dann Meldung zum Fragen anzeigen
            If colRows.Count > 1 Then
                If MsgBox("Alle markierten Dokumente (" + LTrim(Str(colRows.Count)) + ") drucken?", MsgBoxStyle.YesNo) = MsgBoxResult.No Then
                    Exit Sub
                End If
            End If

            Me.Cursor = Cursors.WaitCursor

            'Loop über die Selektierten Dokumente und die Werte je nach Typ in eine Collection abspeichern
            For i = 0 To colRows.Count - 1
                Try

                    If HOSTDaten Then
                        'Host Daten abfüllen
                        gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), _
                        Me.DokList.Columns("partnernr_inhaber").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.HOST, False, _
                        Me.DokList.Columns("dokumenttypnr").CellValue(colRows(i)), "", _
                        Me.DokList.Columns("partnername_inhaber").CellValue(colRows(i)), _
                        Me.DokList.Columns("valutadatum").CellValue(colRows(i))))
                        Exit Try
                    End If

                    If ZVDaten Then
                        Try
                            'ZV Daten abfüllen
                            gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns(1).CellValue(colRows(i)), _
                            Me.DokList.Columns(3).CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.ZV, False, _
                            Me.DokList.Columns(0).CellValue(colRows(i)), Me.DokList.Columns(2).CellValue(colRows(i)), _
                            "", Me.DokList.Columns(8).CellValue(colRows(i))))
                        Catch ex As Exception
                        End Try
                        Exit Try
                    End If

                    'If UVMDaten Then
                    '    DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).CellValue(colRows(i))
                    '    DivFnkt.Belegart = "UVM"
                    '    DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(7).CellValue(colRows(i))
                    '    DivFnkt.Auftragnr = Me.DokList.Columns(4).CellValue(colRows(i))
                    '    DivFnkt.printcolddocHost(Me.DokList.Columns(1).CellValue(colRows(i)), Me.ParentForm, _
                    '    Me.DokList.Columns(1).CellValue(colRows(i)), _
                    '    Me.DokList.Columns(2).CellValue(colRows(i)), _
                    '    Me.DokList.Columns(2).CellValue(colRows(i)), _
                    '    Me.DokList.Columns(7).CellValue(colRows(i)), False)
                    '    Exit Try
                    'End If

                    Dim d As DataTable
                    Try
                        d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(colRows(i)), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(colRows(i)), Me.DokList.Columns("dokumentid").CellValue(colRows(i)), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(colRows(i)), "")
                        If d.Rows(0).Item("anzeigen") <> 1 Then
                            show_Berechtigungsmeldung = True
                            Exit Try
                        Else
                            User_Hat_Berechtigung = True
                        End If
                        d.Dispose()
                    Catch
                        User_Hat_Berechtigung = False
                        show_Berechtigungsmeldung = True
                    End Try

                    If User_Hat_Berechtigung Then
                        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                        scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
                        scmCmdToExecute.CommandType = CommandType.StoredProcedure
                        Dim dtToReturn As DataTable = New DataTable()
                        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                        Try
                            scmCmdToExecute.Connection = conn.scoDBConnection
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").CellValue(colRows(i))))
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                            scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                            sdaAdapter.Fill(dtToReturn)

                            'Zuerst prüfen ob das Cold Dokument vorhanden ist.
                            If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                                gendokCold.Add(New clsMehrfachdruck_Data(DivFnkt.get_colddokumentid(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), 0), Me.DokList.Columns("partnernr").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.EDOKA, False, "", "", "", ""))
                            Else
                                If scmCmdToExecute.Parameters("@office").Value > 0 Then
                                    gendokOffice.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), Me.DokList.Columns("partnernr").CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.EDOKA, True, "", "", "", ""))
                                End If
                            End If

                        Catch
                        End Try
                    End If
                Catch
                End Try
            Next

            Try
                fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
            Catch ex As Exception
            Finally
                Me.Cursor = Cursors.Default
            End Try
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        If EDOKADaten = True Then
            Try
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                Dim t As DataTable
                dokumentid = Me.DokList.Columns("dokumentid").Text
                t = Generic_Select(7)
                If t.Rows.Count > 0 Then
                    Globals.profilnr = 0
                    Dim f As New frmTrefferliste()
                    f.MdiParent = Me.MdiParent
                    f.Show()
                    f.Partner_Eingegeben = True
                    f.txtnrpar00.Text = LTrim(t.Rows(0).Item("NRPAR00"))
                    f.refresh_list()
                    f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))
                    Me.Cursor = System.Windows.Forms.Cursors.Default
                    Exit Sub
                End If
            Catch
            End Try
        End If
        If UVMDaten = True Then
            Try
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                Dim t As DataTable
                dokumentid = ""
                t = Generic_Select(7)
                If t.Rows.Count > 0 Then
                    Globals.profilnr = 0
                    Dim f As New frmTrefferliste()
                    f.MdiParent = Me.MdiParent
                    f.Show()
                    f.Partner_Eingegeben = True
                    f.txtnrpar00.Text = LTrim(t.Rows(0).Item("NRPAR00"))
                    f.refresh_list()
                    f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))

                    For i = 0 To f.DokList.Splits(0).Rows.Count - 1
                        If Me.DokList.Columns(1).Text = f.DokList.Columns(1).CellValue(i) And _
                        Me.DokList.Columns(4).Text = f.DokList.Columns(4).CellValue(i) Then
                            f.DokList.Bookmark = i
                        End If
                    Next

                    Me.Cursor = System.Windows.Forms.Cursors.Default
                    Exit Sub
                End If
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
        End If
        If ZVDaten = True Then
            Try
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                Dim t As DataTable
                dokumentid = ""
                t = Generic_Select(7)
                If t.Rows.Count > 0 Then
                    Globals.profilnr = 0
                    Dim f As New frmTrefferliste()
                    f.MdiParent = Me.MdiParent
                    f.Show()
                    f.Partner_Eingegeben = True
                    f.txtnrpar00.Text = LTrim(t.Rows(0).Item("NRPAR00"))
                    f.refresh_list()
                    f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))

                    For i = 0 To f.DokList.Splits(0).Rows.Count - 1
                        If Me.DokList.Columns(2).Value = f.DokList.Columns(18).CellValue(i) And _
                        Me.DokList.Columns(1).Text = f.DokList.Columns(11).CellValue(i) Then
                            f.DokList.Bookmark = i
                        End If
                    Next

                    Me.Cursor = System.Windows.Forms.Cursors.Default
                    Exit Sub
                End If
            Catch ex As Exception
                'MsgBox(ex.Message)
            End Try
        End If

        If HOSTDaten = True Then
            Try
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                Dim t As DataTable
                dokumentid = Me.DokList.Columns("dokumentid").Text
                t = Generic_Select(7)
                Dim f As New frmTrefferliste()
                f.MdiParent = Me.MdiParent
                f.Show()
                f.Partner_Eingegeben = True
                f.txtnrpar00.Text = Microsoft.VisualBasic.Right(Me.DokList.Columns("Partnernr_inhaber").Text, 7)
                f.refresh_list()
                f.Refresh_All(True)
                DivFnkt.Searchnode(f.tvstruktur, " " + f.txtnrpar00.Text + "-" + Str(998), 99)
                If DivFnkt.found Then
                    f.tvstruktur.SelectedNode = DivFnkt.FoundNode
                    f.Update_Partnerstruktur()
                    f.tvstruktur.SelectedNode.ExpandAll()
                    f.PosDok(dokumentid, t.Rows(0).Item("dokumentart"))

                End If
                Me.Cursor = System.Windows.Forms.Cursors.Default
                Exit Sub
            Catch ex As Exception

                'MsgBox(ex.Message)

            End Try

        Else
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim f As New frmTrefferliste()
            f.MdiParent = Me.MdiParent
            f.Show()
            f.Partner_Eingegeben = True
            f.txtnrpar00.Text = Me.partnernr
            f.refresh_list()
            f.Refresh_All(True)
            Me.Cursor = System.Windows.Forms.Cursors.Default
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        'Mehrere Dokumente anzeigen / SHU / 20060116
        If ZVDaten And Me.DokList.SelectedRows.Count > 0 Then
            Me.Show_mittels_Coldviewer()
            Exit Sub
        End If
        Try
            If HOSTDaten Then
                DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
                DivFnkt.Belegart = "HOST"
                DivFnkt.ShowColdDocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
                Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttypnr").Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            End If
            If ZVDaten Then
                Try
                    DivFnkt.Erstellungsdatum = Me.DokList.Columns(8).Text
                    DivFnkt.Auftragnr = Me.DokList.Columns(2).Text
                    DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                    DivFnkt.Belegart = "ZV"
                    DivFnkt.ShowColdDocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(3).Text, "", Me.DokList.Columns(0).Text)
                    Me.Cursor = Cursors.Default
                    Exit Sub
                Catch ex As Exception
                End Try
            End If
            'If UVMDaten Then
            '    DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).Text
            '    DivFnkt.Belegart = "UVM"
            '    DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(7).Text
            '    DivFnkt.Auftragnr = Me.DokList.Columns(4).Text
            '    DivFnkt.ShowColdDocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(2).Text, _
            '    Me.DokList.Columns(2).Text, Me.DokList.Columns(7).Text)
            '    Me.Cursor = Cursors.Default
            '    Exit Sub
            'End If
            If User_Hat_Berechtigung Then
                DivFnkt.Erstellungsdatum = ""
                DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
                Me.Cursor = Cursors.Default
            Else
                MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Dim F As New frmSpaltenDarstellung()
        Dim i As Integer
        F.ListBox1.Items.Clear()
        F.ListBox2.Items.Clear()
        Try
            For i = 0 To Me.DokList.Columns.Count - 1
                If Me.DokList.Splits(0).DisplayColumns(i).Visible = False Then F.ListBox1.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
                If Me.DokList.Splits(0).DisplayColumns(i).Visible = True Then F.ListBox2.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
            Next
        Catch

        End Try
        F.ShowDialog()
        For i = 0 To F.ListBox1.Items.Count - 1
            Me.DokList.Splits(0).DisplayColumns(F.ListBox1.Items(i)).Visible = False
        Next
        For i = 0 To F.ListBox2.Items.Count - 1
            Me.DokList.Splits(0).DisplayColumns(F.ListBox2.Items(i)).Visible = True
        Next
        F.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem5_Click Method

Private Sub MenuItem5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem5.Click
        Me.Save_Layout(Me.cbProfile.SelectedValue)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Try
            If HOSTDaten Then File.Delete(DivFnkt.Get_Filename(Trim(Me.cbProfile.SelectedValue) + "Hosts.lyt", 0))
            If ZVDaten Then File.Delete(DivFnkt.Get_Filename(Trim(Me.cbProfile.SelectedValue) + "ZVs.lyt", 0))
            If UVMDaten Then File.Delete(DivFnkt.Get_Filename(Trim(Me.cbProfile.SelectedValue) + "UVMs.lyt", 0))
            If EDOKADaten Then File.Delete(DivFnkt.Get_Filename(Trim(Me.cbProfile.SelectedValue) + "s.lyt", 0))
        Catch
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_suchprofillayout_delete"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.cbProfile.SelectedValue))
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
        End Try
        Dim i As Integer
        For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
            Me.DokList.Splits(0).DisplayColumns(i).Visible = True
            Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Update_Profildaten()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Dim i As Integer
        For i = 0 To Me.Daten.Rows.Count - 1
            Try
                If Me.Daten.Rows(i).Item(2) = Me.TreeView1.SelectedNode.Tag Then
                    Me.Daten.Rows(i).Delete()
                    i = i - 1
                End If
            Catch ex As Exception
            End Try
        Next
        Me.Daten.AcceptChanges()
        Me.C1TrueDBGrid1.UpdateData()
        Me.AddDaten(Me.TreeView1.SelectedNode.Tag)
        Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Black
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MenuItem9_Click Method

Private Sub MenuItem9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem9.Click
        Me.MenuItem8_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MnuDatenselektion_Click Method

Private Sub MnuDatenselektion_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDatenselektion.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDatenselektion_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDatenselektion.Click
        If C1TrueDBGrid1.Splits(0).DisplayColumns.Count <= 0 Then
            Return
        End If

        Dim i1 As Integer
        For i = 0 To Me.parameter.Rows.Count - 1
            If Me.parameter.Rows(i).Item("nodenr") = Me.TreeView1.SelectedNode.Tag Then
                Select Case Me.parameter.Rows(i).Item("suchdialog")
                    Case 2
                        If Me.parameter.Rows(i).Item("interne_tabelle") <> 0 Then
                            Dim F As New frmDataselect()
                            f.Left = Me.MousePosition.X
                            f.Top = Me.MousePosition.Y

                            stammdaten_laden(Me.parameter.Rows(i).Item("interne_tabelle"), Me.parameter.Rows(i).Item("select_stored_procedure"))
                            f.C1TrueDBGrid1.DataSource = Me.intds.Tables(Me.parameter.Rows(i).Item("interne_tabelle"))
                            f.C1TrueDBGrid1.DataMember = Me.intds.Tables(Me.parameter.Rows(i).Item("interne_tabelle")).TableName
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then
                                Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
                                colRows = f.C1TrueDBGrid1.SelectedRows
                                If colRows.Count > 0 Then

                                    For i1 = 0 To colRows.Count - 1
                                        Me.C1TrueDBGrid1.Columns("daten1").Text = f.C1TrueDBGrid1.Columns(0).CellText(colRows(i1))
                                        Me.C1TrueDBGrid1.Columns("key1").Value = f.C1TrueDBGrid1.Columns(0).CellText(colRows(i1))
                                        AddDaten(Me.TreeView1.SelectedNode.Tag)
                                        Me.C1TrueDBGrid1.Row = Me.C1TrueDBGrid1.Row + 1
                                    Next
                                Else
                                    Try
                                        Me.C1TrueDBGrid1.Columns("DATEN1").Text = F.C1TrueDBGrid1.Columns(0).Text
                                        Me.C1TrueDBGrid1.Columns("key1").Text = f.C1TrueDBGrid1.Columns(0).Text
                                        AddDaten(Me.TreeView1.SelectedNode.Tag)
                                        Me.C1TrueDBGrid1.Row = Me.C1TrueDBGrid1.Row + 1
                                    Catch
                                    End Try
                                End If

                            End If
                            If F.DialogResult = DialogResult.Yes Then
                                Me.C1TrueDBGrid1.Columns("DATEN1").Text = F.C1TrueDBGrid1.Columns(0).Text
                                Me.C1TrueDBGrid1.Columns("key1").Text = f.C1TrueDBGrid1.Columns(0).Text
                                AddDaten(Me.TreeView1.SelectedNode.Tag)
                                Me.C1TrueDBGrid1.Row = Me.C1TrueDBGrid1.Row + 1
                            End If
                            f.Dispose()
                        End If
                    Case 1
                        Me.Partnerdialog.TopMost = True
                        Me.Partnerdialog.Left = Me.MousePosition.X
                        Me.Partnerdialog.Top = Me.MousePosition.Y

                        Me.Partnerdialog.Left = Me.MousePosition.X + 50
                        Me.Partnerdialog.Top = Me.MousePosition.Y - 20
                        Me.Partnerdialog.Show()
                        Me.Partnerdialog.NoClose = True
                        Me.C1TrueDBGrid1.Col = Me.C1TrueDBGrid1.Col + 1
                    Case 3
                        'hutter
                        If Me.C1TrueDBGrid1.Splits(0).DisplayColumns(9).Locked = True And (Me.C1TrueDBGrid1.Col = 9 Or Me.C1TrueDBGrid1.Col = 10) Then Exit Sub
                        If Me.C1TrueDBGrid1.Col = 6 Or Me.C1TrueDBGrid1.Col = 9 Or Me.C1TrueDBGrid1.Col = 7 Or Me.C1TrueDBGrid1.Col = 10 Then
                            Dim f As New frmCalendar_SP()
                            f.Left = Me.MousePosition.X
                            f.Top = Me.MousePosition.Y
                            f.ShowDialog()
                            If f.DialogResult = DialogResult.OK Then
                                Dim d As DateTime
                                Dim s As String
                                d = f.MonthCalendar1.SelectionStart
                                Select Case Me.C1TrueDBGrid1.Columns(6).EditMask
                                    Case "99999999"
                                        s = Format(d, "yyyyMMdd")
                                    Case "00000000"
                                        s = Format(d, "yyyyMMdd")
                                    Case "00.00.0000"
                                        s = Format(d, "dd.MM.yyyy")
                                    Case "99.99.9999"
                                        s = Format(d, "dd.MM.yyyy")
                                End Select
                                If Me.C1TrueDBGrid1.Col = 6 Or Me.C1TrueDBGrid1.Col = 7 Then
                                    Me.C1TrueDBGrid1.Columns(6).Text = s
                                    AddDaten(Me.TreeView1.SelectedNode.Tag)
                                    Me.C1TrueDBGrid1.Col = Me.C1TrueDBGrid1.Col + 1
                                End If
                                If (Me.C1TrueDBGrid1.Col = 9 Or Me.C1TrueDBGrid1.Col = 10) And Me.C1TrueDBGrid1.Splits(0).DisplayColumns("daten2").Locked = False Then
                                    Me.C1TrueDBGrid1.Columns(9).Text = s
                                    AddDaten(Me.TreeView1.SelectedNode.Tag)
                                    Me.C1TrueDBGrid1.Col = Me.C1TrueDBGrid1.Col = 6
                                End If
                            End If
                            f.Dispose()
                        End If
                End Select
                Exit For
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.MnuDelete_Click Method

Private Sub MnuDelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDelete.Click
        Me.C1TrueDBGrid1.Delete()
        Me.C1TrueDBGrid1.UpdateData()
        C1TrueDBGrid1_AfterDelete(sender, e)
        Try
            setcolors()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.PartnerSuchResultat Method

Private Sub PartnerSuchResultat() Handles Partnerdialog.partner_selected

Source code

[Visual Basic]
    Private Sub PartnerSuchResultat() Handles Partnerdialog.partner_selected
        Dim s As String
        Select Case Me.C1TrueDBGrid1.Columns("daten1").EditMask
            Case "999999999"
                s = Trim(Me.Partnerdialog.PartnerNr.ToString)
                While Len(s) < 9
                    s = "0" + s
                End While
            Case Else
                s = Me.Partnerdialog.PartnerNr.ToString
        End Select
        Me.C1TrueDBGrid1.Columns("daten1").Text = s
        AddDaten(Me.TreeView1.SelectedNode.Tag)
        Me.Partnerdialog.Hide()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Run_Sql Method

Private Function Run_Sql()

Source code

[Visual Basic]
    Private Function Run_Sql()
        Dim i As Integer
        Dim resultdaten As New DataTable()
        Me.DokList.DataSource = resultdaten
        Me.DokList.DataMember = resultdaten.TableName
        If Me.rbzv6monate.Visible = True And Me.rbzv6monate.Checked = True Then
            resultdaten = Me.TempSQLTabelle(4, 0, "")
        Else
            resultdaten = Me.TempSQLTabelle(3, 0, "")
        End If

        If resultdaten.Rows.Count > 0 Then

            Me.btndruck.Enabled = True
            Me.ToolBarButton3.Enabled = True

            Me.DokList.DataSource = resultdaten
            Me.DokList.DataMember = resultdaten.TableName
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, resultdaten, "trefferliste")
            For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                If UCase(Me.DokList.Columns(i).DataField) = "PARTNERNR_INHABER" Then HOSTDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "NRAUF00" Then UVMDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "CDVAR00" Then ZVDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "GESCHAEFTSFALL" Then EDOKADaten = True
                Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
            Next
            If Me.cbProfile.Enabled = True Then
                If Not Load_Layout(Me.cbProfile.SelectedValue) Then
                    For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                        Me.DokList.Splits(0).DisplayColumns(i).Visible = True
                        Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
                    Next
                End If
            End If
            'hutter 20041012

            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns("Betrag").Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                End If
            Catch
            End Try

            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns("BTBET00").Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                End If
            Catch
            End Try
        Else
            MyMsg.show_standardmessage(806, MsgBoxStyle.Information)
            Me.TabControl1.SelectedIndex = 0
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Save_Layout Method

Private Sub Save_Layout( _
   ByVal suchprofilnr As Integer _
)

Parameters

suchprofilnr
Required.

Source code

[Visual Basic]
    Private Sub Save_Layout(ByVal suchprofilnr As Integer)
        Dim p As New DocMgmt()
        Try
            Dim docname As String
            Try
                '***********************************
                'Layoutfile für alle Dokumenttypen setzen
                '29.7.2004 / SHU
                '***********************************

                docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "s.lyt", "")
                If HOSTDaten Then docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "HOSTs.lyt", "")
                If ZVDaten Then docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "ZVs.lyt", "")
                If UVMDaten = False Then
                Else
                    docname = DivFnkt.Get_Filename(LTrim(Str(suchprofilnr)) + "UVMs.lyt", "")
                End If
            Catch
            End Try
            Me.DokList.SaveLayout(docname)
            If p.Save_SuchLayout_DB(Me.cbProfile.SelectedValue, docname) Then
                Me.DokList.LoadLayout(docname)
            End If
        Catch
        Finally
            p = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Save_Suchprofil Method

Private Sub Save_Suchprofil( _
   ByVal Profilname As String _
)

Parameters

Profilname
Required.

Source code

[Visual Basic]
    Private Sub Save_Suchprofil(ByVal Profilname As String)
        Dim sp As New edokadb.clsSuchprofil()
        Dim da As New DataTable()
        Try
            sp.cpMainConnectionProvider = conn
            conn.OpenConnection()
            sp.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            sp.sProfilname = New SqlString(CType(Profilname, String))
            da = sp.SelectOne()
            If da.Rows.Count > 0 Then
                save_data(True, da.Rows(0).Item(0))
            Else
                sp.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                sp.sProfilname = New SqlString(CType(Profilname, String))
                sp.Insert()
                sp.SelectOne()
                conn.CloseConnection(True)
                save_data(False, sp.iSuchprofilnr.Value)
            End If
        Catch ex As Exception
            conn.CloseConnection(True)
        Finally
            sp.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Show_mittels_Coldviewer Method

Private Sub Show_mittels_Coldviewer()

Source code

[Visual Basic]
    Private Sub Show_mittels_Coldviewer()
        'Mehrere Dokumente gewählt
        Dim gendokcold As New Collection()
        Dim i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        colRows = Me.DokList.SelectedRows
        For i = 0 To colRows.Count - 1
            Try
                'COLD-Dokumentanzeige der ZV-Belege
                If ZVDaten Then
                    Try
                        'ZV Daten abfüllen
                        gendokcold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns(1).CellValue(colRows(i)), _
                        Me.DokList.Columns(3).CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.ZV, False, _
                        Me.DokList.Columns(0).CellValue(colRows(i)), Me.DokList.Columns(2).CellValue(colRows(i)), _
                        "", Me.DokList.Columns(9).CellValue(colRows(i))))
                    Catch ex As Exception
                    End Try
                    Exit Try
                End If

            Catch
            End Try
        Next
        Try
            Dim f As New frmcoldviewer()
            f.dokdata = gendokcold
            f.MdiParent = Me.MdiParent
            f.Hide()
            f.Visible = False
            f.Show()
            f.Visible = True
            f.Refresh()
            Application.DoEvents()
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.StartDruckJob Method

Private Sub StartDruckJob()

Source code

[Visual Basic]
    Private Sub StartDruckJob()
        Dim show_Berechtigungsmeldung As Boolean = False
        Try
            Dim fp As New frmProgress()
            fp.Info.Text = "Dokumente drucken"
            fp.Text = "Dokumente Drucken"
            Try
                Dim i As Integer
                Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
                colRows = Me.DokList.SelectedRows
                If MsgBox("Alle markierten Dokumente (" + LTrim(Str(colRows.Count)) + ") drucken?", MsgBoxStyle.YesNo) = MsgBoxResult.No Then
                    fp.Dispose()
                    Exit Sub
                End If
                fp.Bar1.Maximum = colRows.Count
                fp.Bar1.Value = 0
                fp.Show()
                Application.DoEvents()
                fp.Refresh()
                Application.DoEvents()
                For i = 0 To colRows.Count - 1
                    Try
                        If HOSTDaten Then
                            DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").CellValue(colRows(i))
                            DivFnkt.Belegart = "HOST"
                            DivFnkt.printcolddocHost(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), _
                            Me.ParentForm, Me.DokList.Columns("dokumentid").CellValue(colRows(i)), _
                            Me.DokList.Columns("partnernr_inhaber").CellValue(colRows(i)), _
                            Me.DokList.Columns("partnername_inhaber").CellValue(colRows(i)), _
                              Me.DokList.Columns("dokumenttypnr").CellValue(colRows(i)), False)
                            Exit Try
                        End If
                        If ZVDaten Then
                            Try
                                DivFnkt.Erstellungsdatum = Me.DokList.Columns(8).CellValue(colRows(i))
                                DivFnkt.Auftragnr = Me.DokList.Columns(2).CellValue(colRows(i))
                                DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).CellValue(colRows(i))
                                DivFnkt.Belegart = "ZV"
                                DivFnkt.printcolddocHost(Me.DokList.Columns(1).CellValue(colRows(i)), _
                                Me.ParentForm, Me.DokList.Columns(1).CellValue(colRows(i)), _
                                Me.DokList.Columns(3).CellValue(colRows(i)), _
                                "", Me.DokList.Columns(0).CellValue(colRows(i)), False)
                            Catch ex As Exception
                            End Try
                            Exit Try
                        End If
                        If UVMDaten Then
                            DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).CellValue(colRows(i))
                            DivFnkt.Belegart = "UVM"
                            DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(7).CellValue(colRows(i))
                            DivFnkt.Auftragnr = Me.DokList.Columns(4).CellValue(colRows(i))
                            DivFnkt.printcolddocHost(Me.DokList.Columns(1).CellValue(colRows(i)), Me.ParentForm, _
                            Me.DokList.Columns(1).CellValue(colRows(i)), _
                            Me.DokList.Columns(2).CellValue(colRows(i)), _
                            Me.DokList.Columns(2).CellValue(colRows(i)), _
                            Me.DokList.Columns(7).CellValue(colRows(i)), False)
                            Exit Try
                        End If
                        Dim d As DataTable
                        Try
                            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(colRows(i)), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(colRows(i)), Me.DokList.Columns("dokumentid").CellValue(colRows(i)), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(colRows(i)), "")
                            If d.Rows(0).Item("anzeigen") <> 1 Then
                                show_Berechtigungsmeldung = True
                                Exit Try
                            Else
                                User_Hat_Berechtigung = True
                            End If
                            d.Dispose()
                        Catch
                            User_Hat_Berechtigung = False
                            show_Berechtigungsmeldung = True
                        End Try

                        If User_Hat_Berechtigung Then
                            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                            scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
                            scmCmdToExecute.CommandType = CommandType.StoredProcedure
                            Dim dtToReturn As DataTable = New DataTable()
                            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                            Try
                                scmCmdToExecute.Connection = conn.scoDBConnection
                                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").CellValue(colRows(i))))
                                scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                                scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                                sdaAdapter.Fill(dtToReturn)

                                If scmCmdToExecute.Parameters("@office").Value > 0 Then
                                    DivFnkt.print_office(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), Me)
                                Else
                                    If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                                        '************************************************
                                        'UVM Migration / Erste Variante
                                        'Start
                                        '************************************************
                                        ''Rel 3.7 / BUD / Probleme mit Mehrfach Druck
                                        'If InStr(Me.DokList.Columns("dokumentid").Value, "OFFEDK003") <> 0 Then
                                        '    DivFnkt.gen_PrintColdDocUVM(Me.DokList.Columns("Partner-Nr").Value, Me.DokList.Columns("geschaeftsfall").Text, Me.DokList.Columns("Erstellungsdatum").Value, False)
                                        'Else
                                        '    DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), Me, Me.DokList.Columns("dokumentid").CellValue(colRows(i)), False)
                                        'End If
                                        '************************************************
                                        'ENDE
                                        '************************************************
                                        DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").CellValue(colRows(i)), Me, Me.DokList.Columns("dokumentid").CellValue(colRows(i)), False)
                                    End If
                                End If
                            Catch
                            End Try
                        End If
                    Catch
                    End Try
                    fp.Bar1.Value = fp.Bar1.Value + 1
                    Application.DoEvents()
                    fp.Refresh()
                    Application.DoEvents()
                Next
            Catch
            Finally
                Try
                    fp.Visible = False
                Catch
                End Try
                fp.Dispose()
            End Try
            If show_Berechtigungsmeldung Then
                MyMsg.show_standardmessage(276, MsgBoxStyle.Information)
            End If
        Catch
            DruckThread.Abort()
        Finally
            Try
                DruckThread.Abort()
            Catch

            End Try
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TabControl1_Click Method

Private Sub TabControl1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControl1.Click

        If Me.TabControl1.SelectedIndex = 0 Then Me.TabControl1.Width = 608 Else Me.TabControl1.Width = 170
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TabControl1_SelectedIndexChanged Method

Private Sub TabControl1_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl1.SelectedIndexChanged
        If Me.TabControl1.SelectedIndex = 0 Then
            Me.ToolBarButton3.Enabled = False
            Me.btndruck.Enabled = False
        Else
            If Me.DokList.Splits(0).Rows.Count > 0 Then
                Me.ToolBarButton3.Enabled = True
                Me.btndruck.Enabled = True
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TempSQLTabelle Method

Private Function TempSQLTabelle( _
   ByVal Fnkt As Integer, _
   ByVal nodenr As Integer, _
   ByVal sqlstring As String _
) As DataTable

Parameters

Fnkt
Required.
nodenr
Required.
sqlstring
Required.

Source code

[Visual Basic]
    Private Function TempSQLTabelle(ByVal Fnkt As Integer, ByVal nodenr As Integer, ByVal sqlstring As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_Suche"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@suchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Fnkt))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@nodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nodenr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@sqlstring", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, sqlstring))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@moredata", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@moredata").Value > 0 Then
                Dim s As String
                s = Trim(Str(scmCmdToExecute.Parameters("@moredata").Value))
                MyMsg.show_standardmessage_ReplaceText(807, MsgBoxStyle.Critical, s, s)
            End If
            Return dtToReturn
        Catch ex As Exception
            MyMsg.show_standardmessage(277, MsgBoxStyle.Critical)
            'Catch ex As Exception
            '    MsgBox(ex.Message)
            'Catch dbex As DataException
            '           Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0		  'close button
                Me.Close()
            Case 1		  ' Neue Dokumentesuche beginnen
                Me.m_NeueSuche = True
                Me.show_checkmessage = False
                Me.cbProfile.DataSource = Nothing
                Me.cbProfile.Items.Clear()
                get_suchprofile()
                Me.TreeView1.Select()
                Me.TreeView1.Focus()
                check_cbprofile()
                Me.TabControl1.SelectedIndex = 0
                Me.C1TrueDBGrid1.DataSource = Nothing
                Me.DokList.DataSource = Nothing
                Me.TabControl1.SelectedIndex = 0
            Case 2
                Try
                    Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
                    Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

                    With DokList.PrintInfo
                        .PageHeaderStyle.Font = fontbold
                        .PageSettings.Margins.Bottom = 20
                        .PageSettings.Margins.Top = 80
                        .PageSettings.Landscape = True
                        .PageFooter = "Seite \p von \P" & vbLf & " Druckdatum " & Now()
                        .ShowProgressForm = True
                        .UseGridColors = True
                        .RepeatColumnHeaders = True
                        .VarRowHeight = DokList.PrintInfo.RowHeightEnum.StretchToFit
                        .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
                        .PageBreak = DokList.PrintInfo.PageBreaksEnum.OnColumn
                        .FillAreaWidth = DokList.PrintInfo.FillEmptyEnum.ExtendLast
                        '.ShowOptionsDialog = True
                        .PrintPreview()
                    End With
                Catch
                End Try

            Case 3		  'CSV-Export
                If Me.DokList.Splits(0).Rows.Count > 0 Then
                    Me.SaveFileDialog1.AddExtension = True
                    Me.SaveFileDialog1.DefaultExt.Insert(0, "*.csv")
                    Me.SaveFileDialog1.Filter = "CSV-Dateien|*.CSV"
                    Me.SaveFileDialog1.ShowDialog()
                    If Me.SaveFileDialog1.FileName <> "" Then
                        Me.DokList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";", "", "", False, System.Text.Encoding.Default.BodyName)
                        '2006-10-17: RS Me.DokList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows, ";")
                        '                        Me.DokList.ExportToDelimitedFile(Me.SaveFileDialog1.FileName, C1.Win.C1TrueDBGrid.RowSelectorEnum.AllRows)
                    End If
                End If

            Case 4
                Me.MitFreitext = 0
                Me.init_treeview()
                Me.Daten.Rows.Clear()
                Me.TreeView1.CollapseAll()
                Me.DokList.DataSource = Nothing
                Me.TabControl1.SelectedIndex = 0
            Case 5
                Dim looper As Integer = 0
                Me.DokList.DataSource = Nothing
                Me.TabControl1.SelectedIndex = 0

                Dim s As String
                If Me.cbProfile.Enabled = True Then S = Me.cbProfile.Text
                While looper = 0
                    s = InputBox("Name der Dokumentsuche:", "Dokumentsuche speichern", S)
                    If s = "" Then
                        looper = 1
                        Exit Sub
                    End If
                    If s <> "" And s <> "<Neue Dokumentsuche>" Then
                        Save_Suchprofil(s)
                        looper = 1
                    Else
                        If s = "<Neue Dokumentsuche>" Then MyMsg.show_standardmessage(808, MsgBoxStyle.Critical)
                    End If
                End While
                get_suchprofile()
                Dim i As Integer
                For i = 0 To Me.profile.Rows.Count - 1
                    If UCase(Me.profile.Rows(i).Item("profilname")) = UCase(s) Then
                        Me.cbProfile.SelectedValue = Me.profile.Rows(i).Item("suchprofilnr")
                    End If
                Next
                Me.check_cbprofile()
            Case 6
                Dim s As String
                If MyMsg.Show_MessageYesNo(803) = MsgBoxResult.Yes Then
                    delete_profile()
                    get_suchprofile()
                End If
                Me.check_cbprofile()
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TreeView1_AfterExpand Method

Private Sub TreeView1_AfterExpand( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterExpand(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterExpand
        Me.savenode = e.Node
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TreeView1_AfterSelect Method

Private Sub TreeView1_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TreeView1.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TreeView1.AfterSelect
        Dim i As Integer
        Dim x As Integer

        Dim Freitext_nicht_moeglich As Boolean = False
        Try
            If Me.TreeView1.SelectedNode.Text = "Freitext" Then
                Dim tnx As New TreeNode()
                tnx = Me.TreeView1.SelectedNode.Parent
                Dim tny As New TreeNode()
                For Each tny In tnx.Nodes
                    Me.C1TrueDBGrid1.Columns("NodeNr").FilterText = tny.Tag
                    If Me.C1TrueDBGrid1.Splits(0).Rows.Count > 1 Then
                        If Me.C1TrueDBGrid1.Splits(0).Rows.Count > 2 Or Me.C1TrueDBGrid1.Columns("Daten1").CellValue(2) <> "" Then
                            Freitext_nicht_moeglich = True
                        End If
                    End If
                Next
            End If
        Catch
        End Try

        Try
            If Me.TreeView1.SelectedNode.Tag = 8 Then
                Me.rbzv6monate.Visible = True
                Me.rbzvvollständig.Visible = True
                If Me.rbzv6monate.Checked <> True And Me.rbzvvollständig.Checked <> True Then Me.rbzv6monate.Checked = True
            Else
                Me.rbzv6monate.Visible = False
                Me.rbzvvollständig.Visible = False
            End If
            If Me.TreeView1.SelectedNode.Parent.Tag = 8 Then
                Me.rbzv6monate.Visible = True
                Me.rbzvvollständig.Visible = True
                If Me.rbzv6monate.Checked <> True And Me.rbzvvollständig.Checked <> True Then Me.rbzv6monate.Checked = True
            Else
                Me.rbzv6monate.Visible = False
                Me.rbzvvollständig.Visible = False
            End If
        Catch
        End Try

        Dim tn As TreeNode
        Dim dr As DataRow()

        If Me.TreeView1.SelectedNode.SelectedImageIndex < 6 Then Me.TreeView1.SelectedNode.SelectedImageIndex = 5
        For i = 0 To Me.parameter.Rows.Count - 1
            If Me.parameter.Rows(i).Item("nodenr") = e.Node.Tag Then
                If Me.parameter.Rows(i).Item("select_stored_procedure") <> "" Then
                    stammdaten_laden(Me.parameter.Rows(i).Item("interne_tabelle"), Me.parameter.Rows(i).Item("select_stored_procedure"))
                End If
                Exit For
            End If
        Next
        If Me.parameter.Rows(i).Item("datenrow") = True Then
            Me.Label1.Text = Me.parameter.Rows(i).Item("Beschreibung")
            Me.C1TrueDBGrid1.DataSource = Daten
            Me.C1TrueDBGrid1.DataMember = Daten.TableName
            Me.C1TrueDBGrid1.Columns("NodeNr").FilterText = e.Node.Tag
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Daten1").AutoDropDown = False
            Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Daten2").AutoDropDown = False
            Me.C1TrueDBGrid1.Columns("daten1").ValueItems.Values.Clear()
            Me.C1TrueDBGrid1.Columns("daten2").ValueItems.Values.Clear()
            Add_Operatoren(Me.parameter.Rows(i).Item("operatoren"))
            AddDaten(e.Node.Tag)
            Me.Format_grid()
            If Me.parameter.Rows(i).Item("interne_tabelle") > 0 Then
                Insert_valueitems(intds.Tables(Me.parameter.Rows(i).Item("interne_tabelle")))
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Daten1").AutoDropDown = True
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns("Daten2").AutoDropDown = True
            End If
            Me.C1TrueDBGrid1.Columns("daten1").EditMaskUpdate = True
            Me.C1TrueDBGrid1.Columns("daten2").EditMaskUpdate = True
            Me.C1TrueDBGrid1.Columns("Daten1").EditMask = ""
            Me.C1TrueDBGrid1.Columns("Daten2").EditMask = ""
            If Me.parameter.Rows(i).Item("feldformat") <> "" Then
                Me.C1TrueDBGrid1.Columns("daten1").EditMaskUpdate = True
                Me.C1TrueDBGrid1.Columns("daten2").EditMaskUpdate = True
                Me.C1TrueDBGrid1.Columns("Daten1").EditMask = Me.parameter.Rows(i).Item("feldformat")
                Me.C1TrueDBGrid1.Columns("Daten2").EditMask = Me.parameter.Rows(i).Item("feldformat")
            End If
            If Freitext_nicht_moeglich Then Me.C1TrueDBGrid1.Splits(0).Locked = True Else Me.C1TrueDBGrid1.Splits(0).Locked = False
        Else
            Me.C1TrueDBGrid1.DataSource = Nothing
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TreeView1_BeforeExpand Method

Private Sub TreeView1_BeforeExpand( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeView1.BeforeExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_BeforeExpand(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView1.BeforeExpand
        Try
            If Me.On_Load = True Then Exit Sub
            Me.TreeView1.BeginUpdate()
            If e.Node.Tag = 1 Or e.Node.Tag = 6 Or e.Node.Tag = 7 Or e.Node.Tag = 8 Then
                If Me.savenode.Tag <> e.Node.Tag Then
                    If Me.Daten.Rows.Count > 0 And Me.show_checkmessage = True And Not Me.m_updateprofildaten Then
                        If MyMsg.Show_MessageYesNo(800) = MsgBoxResult.Yes Then
                            Dim i As Integer
                            For i = 0 To Me.Daten.Rows.Count - 1
                                DivFnkt.Searchnode1(Me.TreeView1, Me.Daten.Rows(i).Item("nodenr"), 99)
                                If DivFnkt.found Then DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Black
                            Next
                            Me.Daten.Rows.Clear()
                            Me.savenode.Collapse()
                        Else
                            e.Cancel = True
                            Exit Sub
                        End If
                    End If
                    Me.show_checkmessage = True
                    Try
                        If Me.savenode.Tag = 2 Or Me.savenode.Tag = 3 Or Me.savenode.Tag = 4 Then
                            Me.savenode.Parent.Collapse()
                        Else
                            Me.savenode.Collapse()
                        End If
                        'Me.savenode.Collapse()
                        'e.Node.ExpandAll()
                        Me.savenode = e.Node
                    Catch
                        Me.TreeView1.EndUpdate()
                    End Try
                End If

            End If
            Me.TreeView1.EndUpdate()
        Catch
            Try
                Me.savenode = Me.TreeView1.SelectedNode
            Catch
            End Try
        Finally
            Me.TreeView1.EndUpdate()

        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TreeView1_BeforeSelect Method

Private Sub TreeView1_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles TreeView1.BeforeSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles TreeView1.BeforeSelect
        Try
            setcolors()
            Me.C1TrueDBGrid1.UpdateData()
            If Me.TreeView1.SelectedNode.SelectedImageIndex < 6 Then Me.TreeView1.SelectedNode.SelectedImageIndex = 4
            'If Me.MitFreitext = 0 Then
            '    If Me.C1TrueDBGrid1.Splits(0).Rows.Count > 1 Then
            '        Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Red
            '    Else
            '        Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Black
            '    End If
            'Else
            '    If Me.C1TrueDBGrid1.Splits(0).Rows.Count = 1 And Me.C1TrueDBGrid1.Splits(0).colum Then
            '    End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.TreeView1_MouseDown Method

Private Sub TreeView1_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TreeView1.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TreeView1_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TreeView1.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.TreeView1.SelectedNode = Me.TreeView1.GetNodeAt(selectPoint)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmSucFormular.TreeView1_MouseDown: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Info)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.Update_Profildaten Method

Public Sub Update_Profildaten()

Source code

[Visual Basic]
    Public Sub Update_Profildaten()
        Me.m_updateprofildaten = True
        Me.Daten.Rows.Clear()
        Me.Daten = Me.get_suchdaten(Me.cbProfile.SelectedValue)
        Me.init_treeview()
        Dim i As Integer
        Dim I1 As Integer
        For i = 0 To Me.Daten.Rows.Count - 1
            DivFnkt.Searchnode1(Me.TreeView1, Me.Daten.Rows(i).Item("nodenr"), 99)
            If DivFnkt.found Then
                DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
                If Me.Daten.Rows(i).Item("nodenr") = 100 Or Me.Daten.Rows(i).Item("nodenr") = 101 And DivFnkt.found Then
                    Me.MitFreitext = 1
                End If

                Me.Daten.Rows(i).Item("BTN1") = ""
                Me.Daten.Rows(i).Item("BTN2") = ""
                For I1 = 0 To Me.parameter.Rows.Count - 1
                    If Me.parameter.Rows(I1).Item("nodenr") = DivFnkt.FoundNode.Tag Then
                        If Me.parameter.Rows(I1).Item("suchdialog") > 0 Then
                            Me.Daten.Rows(i).Item("BTN1") = 1
                            Me.Daten.Rows(i).Item("BTN2") = 1
                        End If
                        Exit For
                    End If
                Next

                If DivFnkt.FoundNode.Parent.Tag = 2 Or DivFnkt.FoundNode.Parent.Tag = 3 Or DivFnkt.FoundNode.Parent.Tag = 4 Then
                    Dim n As New TreeNode()
                    n = DivFnkt.FoundNode.Parent
                    n.Parent.ExpandAll()
                Else
                    If DivFnkt.FoundNode.Parent.Tag = 8 Then
                        Me.rbzv6monate.Visible = True
                        Me.rbzvvollständig.Visible = True
                        Me.rbzv6monate.Checked = True
                    Else
                        Me.rbzv6monate.Visible = False
                        Me.rbzvvollständig.Visible = False
                        Me.rbzv6monate.Checked = False
                    End If
                    DivFnkt.FoundNode.Parent.ExpandAll()
                    Me.TreeView1.SelectedNode = DivFnkt.FoundNode.Parent()
                End If
            End If

        Next
        Me.m_updateprofildaten = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.btnSearch_Click Method

Private Sub btnSearch_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnSearch.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnSearch_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnSearch.Click
        If Me.Datachanged And Me.cbProfile.Enabled = True Then
            If MyMsg.Show_MessageYesNo(802) = MsgBoxResult.Yes Then
                Me.Save_Suchprofil(Me.cbProfile.Text)

            End If
        End If
        If Me.MitFreitext Then
            Freitext_Suche()
            Exit Sub
        End If
        EDOKADaten = False
        UVMDaten = False
        ZVDaten = False
        HOSTDaten = False
        Try
            If Not BuildSQL() Then Exit Sub
            Me.DokList.Enabled = False
            Me.DokList.DataSource = Nothing
            Me.TabControl1.Width = 170
            Me.TabControl1.SelectedIndex = 1
            Me.Cursor = Cursors.WaitCursor
            Me.TabControl1.Enabled = False
            Run_Sql()
            Me.DokList.Enabled = True
            Me.Cursor = Cursors.Default
            '' BUD **************************

            'For i = 0 To Me.DokList.Columns.Count - 1
            '    If Me.DokList.Columns("Statusbezeichnungnr").CellValue(e.Row) = -3 Then
            '        Dim FNT As Font = e.CellStyle.Font
            '        e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            '    End If
            'Next
            '' BUD **************************
        Catch
        Finally
            Me.TabControl1.Enabled = True
            Me.DokList.Enabled = True
            Me.Cursor = Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.cbProfile_KeyDown Method

Private Sub cbProfile_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles cbProfile.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbProfile_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles cbProfile.KeyDown
        If e.KeyCode = Keys.Enter Then
            Update_Profildaten()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.cbProfile_SelectedValueChanged Method

Private Sub cbProfile_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles cbProfile.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbProfile_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles cbProfile.SelectedValueChanged
        If On_Load Then Exit Sub
        Update_Profildaten()
        Me.On_Load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.check_Berechtigung Method

Private Function check_Berechtigung( _
   ByVal nrpar00 As Integer, _
   ByVal dokumenttyp As String, _
   ByVal doktyp As String _
) As Boolean

Parameters

nrpar00
Required.
dokumenttyp
Required.
doktyp
Required.

Source code

[Visual Basic]
    Private Function check_Berechtigung(ByVal nrpar00 As Integer, ByVal dokumenttyp As String, ByVal doktyp As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofil_check_berechtigung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttyp))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigt", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Connection.Open()
        Catch
        End Try
        Try
            scmCmdToExecute.ExecuteNonQuery()
            If scmCmdToExecute.Parameters("@berechtigt").Value = 1 Then
                Return True
            Else
                Return False
            End If
        Catch ex As Exception
            '            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            Try
                scmCmdToExecute.Connection.Close()
            Catch
            End Try
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.check_cbprofile Method

Private Sub check_cbprofile()

Source code

[Visual Basic]
    Private Sub check_cbprofile()
        If Me.cbProfile.Items.Count > 0 Then Me.BTNDELETEPROFIL.Enabled = True Else Me.BTNDELETEPROFIL.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.delete_existing_data Method

Private Sub delete_existing_data( _
   ByVal suchprofilnr As Integer _
)

Parameters

suchprofilnr
Required.

Source code

[Visual Basic]
    Private Sub delete_existing_data(ByVal suchprofilnr As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofildaten_delete"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@suchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, suchprofilnr))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            '            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            Try
                scmCmdToExecute.Connection.Close()
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.delete_profile Method

Private Sub delete_profile()

Source code

[Visual Basic]
    Private Sub delete_profile()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofil_delete"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Parameters.Add(New SqlParameter("@suchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.cbProfile.SelectedValue))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Connection.Open()
        Catch
        End Try
        Try
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            '            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            Try
                scmCmdToExecute.Connection.Close()
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.frmSuchFormular_Resize Method

Private Sub frmSuchFormular_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSuchFormular_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.get_profile Method

Private Function get_profile() As DataTable

Source code

[Visual Basic]
    Private Function get_profile() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofildaten_get_profile"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            dtToReturn = profile_ergaenzen(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            '           Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.get_suchdaten Method

Private Function get_suchdaten( _
   ByVal suchprofilnr As Integer _
) As DataTable

Parameters

suchprofilnr
Required.

Source code

[Visual Basic]
    Private Function get_suchdaten(ByVal suchprofilnr As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        scmCmdToExecute.CommandText = "dbo.SP_suchprofildaten_get_daten"
        scmCmdToExecute.Parameters.Add(New SqlParameter("@suchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, suchprofilnr))
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox(ex.Message)
            '           Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.get_suchprofile Method

Private Sub get_suchprofile()

Source code

[Visual Basic]
    Private Sub get_suchprofile()
        On_Load = True
        Me.cbProfile.DataSource = Nothing

        profile.Rows.Clear()
        profile = Me.get_profile

        Me.cbProfile.DataSource = profile
        Me.cbProfile.DisplayMember = "profilname"
        Me.cbProfile.ValueMember = "suchprofilnr"

        If Me.cbProfile.Items.Count > 0 Then
            Me.get_suchdaten(Me.cbProfile.SelectedValue)
            For i = 0 To Me.Daten.Rows.Count - 1
                DivFnkt.Searchnode1(Me.TreeView1, Me.Daten.Rows(i).Item("nodenr"), 99)
                If DivFnkt.found Then DivFnkt.FoundNode.ForeColor = System.Drawing.Color.Red
            Next
            Me.cbProfile.Enabled = True
            Me.MenuItem4.Enabled = True
            Me.MenuItem5.Enabled = True
            Me.MenuItem6.Enabled = True
        Else
            Me.MenuItem4.Enabled = False
            Me.MenuItem5.Enabled = False
            Me.MenuItem6.Enabled = False
            Me.cbProfile.Text = ""
            Me.cbProfile.Enabled = False
        End If

        On_Load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.init_treeview Method

Private Function init_treeview()

Source code

[Visual Basic]
    Private Function init_treeview()
        Me.TreeView1.Nodes.Clear()
        Dim collNodeKeys As New Collection()
        Dim tnNew As TreeNode
        Dim tnParent As TreeNode
        Dim Oldparent As Integer = -1
        Me.TreeView1.BeginUpdate()
        parameter = Generic_Select(0, "")
        For i = 0 To parameter.Rows.Count - 1
            If parameter.Rows(i).Item("Parent") = 0 Then
                tnNew = TreeView1.Nodes.Add(parameter.Rows(i).Item("bezeichnung"))
                With tnNew
                    .Tag() = parameter.Rows(i).Item("nodenr")
                    .ImageIndex() = parameter.Rows(i).Item("ImageIndex")
                    .SelectedImageIndex() = parameter.Rows(i).Item("ImageIndexOpen")
                End With
                Try
                    collNodeKeys.Add(tnNew, CType(parameter.Rows(i).Item("nodenr"), String))
                Catch ex As Exception
                    MsgBox(ex.Message, MsgBoxStyle.Critical)
                End Try
            Else
                Try
                    tnParent = CType(collNodeKeys.Item(CType(parameter.Rows(i).Item("Parent"), String)), TreeNode)
                    tnNew = tnParent.Nodes.Add(CType(parameter.Rows(i).Item("bezeichnung"), String))
                    With tnNew
                        .Tag() = CType(parameter.Rows(i).Item("NodeNr"), String)
                        .ImageIndex() = parameter.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = parameter.Rows(i).Item("ImageIndexOpen")
                    End With
                    collNodeKeys.Add(tnNew, CType(parameter.Rows(i).Item("nodenr"), String))
                Catch ex As Exception
                    MsgBox(ex.Message, MsgBoxStyle.Critical)
                End Try
            End If
        Next
        Me.TreeView1.EndUpdate()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.profile_ergaenzen Method

Private Function profile_ergaenzen( _
   ByVal dat As DataTable _
) As DataTable

Parameters

dat
Required.

Source code

[Visual Basic]
    Private Function profile_ergaenzen(ByVal dat As DataTable) As DataTable
        If Me.m_NeueSuche = False Then
            Return dat
            Exit Function
        End If

        Dim datnew As New DataTable()
        Dim i As Integer
        For i = 0 To dat.Columns.Count - 1
            datnew.Columns.Add(dat.Columns(i).Caption)
        Next
        Dim rowvals(1) As Object
        Dim rowcount As Integer
        rowcount = dat.Rows.Count
        rowvals(0) = -1
        rowvals(1) = "<Neue Dokumentsuche>"
        datnew.Rows.Add(rowvals)

        For i = 0 To dat.Rows.Count - 1
            rowvals(0) = dat.Rows(i).Item(0)
            rowvals(1) = dat.Rows(i).Item(1)
            datnew.Rows.Add(rowvals)
        Next
        Return datnew
        datnew.Dispose()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.rbzv6monate_CheckedChanged Method

Private Sub rbzv6monate_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbzv6monate.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbzv6monate_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbzv6monate.CheckedChanged
        If Me.rbzv6monate.Checked = True Then
            Me.rbzv6monate.ForeColor = Color.Red
        Else
            Me.rbzv6monate.ForeColor = Color.Black
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.rbzvvollständig_CheckedChanged Method

Private Sub rbzvvollständig_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles rbzvvollständig.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub rbzvvollständig_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles rbzvvollständig.CheckedChanged
        If Me.rbzvvollständig.Checked = True Then
            Me.rbzvvollständig.ForeColor = Color.Red
        Else
            Me.rbzvvollständig.ForeColor = Color.Black
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.save_data Method

Private Sub save_data( _
   ByVal Bestehende_Loeschen As Boolean, _
   ByVal Suchprofilnr As Integer _
)

Parameters

Bestehende_Loeschen
Required.
Suchprofilnr
Required.

Source code

[Visual Basic]
    Private Sub save_data(ByVal Bestehende_Loeschen As Boolean, ByVal Suchprofilnr As Integer)
        If Bestehende_Loeschen Then delete_existing_data(Suchprofilnr)
        Dim data As New edokadb.clsSuchdaten()
        data.cpMainConnectionProvider = conn
        conn.OpenConnection()
        For i = 0 To Me.Daten.Rows.Count - 1
            If CType(Me.Daten.Rows(i).Item("daten1"), String) <> "" Then
                data.iId = New SqlInt32(CType(Daten.Rows(i).Item("id"), Int32))
                data.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                data.iNodenr = New SqlInt32(CType(Daten.Rows(i).Item("nodenr"), Int32))
                data.iSuchprofilnr = New SqlInt32(CType(Suchprofilnr, Int32))
                data.sAndor = New SqlString(CType(Daten.Rows(i).Item("andor"), String))
                data.sOp1 = New SqlString(CType(Daten.Rows(i).Item("op1"), String))
                data.sDaten1 = New SqlString(CType(Daten.Rows(i).Item("daten1"), String))
                data.sOp2 = New SqlString(CType(Daten.Rows(i).Item("op2"), String))
                data.sDaten2 = New SqlString(CType(Daten.Rows(i).Item("daten2"), String))
                data.Insert()
            End If
        Next
        conn.CloseConnection(True)
        data.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.setcolors Method

Private Sub setcolors()

Source code

[Visual Basic]
    Private Sub setcolors()
        Try
            Me.C1TrueDBGrid1.UpdateData()
            Dim c As Integer = 0
            Dim i As Integer
            For i = 0 To Me.C1TrueDBGrid1.Splits(0).Rows.Count - 1
                If Me.C1TrueDBGrid1.Columns(2).Value = Me.TreeView1.SelectedNode.Tag Then
                    If Me.C1TrueDBGrid1.Columns("Daten1").CellText(i) <> "" Then c = 1
                End If
            Next
            If c = 1 Then
                Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Red
            Else
                Me.TreeView1.SelectedNode.ForeColor = System.Drawing.Color.Black
            End If

        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular.stammdaten_laden Method

Private Function stammdaten_laden( _
   ByVal Nr As Integer, _
   ByVal sp As String _
)

Parameters

Nr
Required.
sp
Required.

Source code

[Visual Basic]
    Private Function stammdaten_laden(ByVal Nr As Integer, ByVal sp As String)
        Dim tmptbl As New DataTable()
        If Nr = 0 Then Exit Function
        If intds.Tables(Nr).Rows.Count < 1 Then
            tmptbl = Generic_Select(Nr, sp)
            intds.Tables(Nr).Rows.Clear()
            intds.Tables(Nr).Columns.Clear()
            For i = 0 To tmptbl.Columns.Count - 1
                intds.Tables(Nr).Columns.Add(tmptbl.Columns(i).Caption)
            Next
            For i = 0 To tmptbl.Rows.Count - 1
                intds.Tables(Nr).Rows.Add(tmptbl.Rows(i).ItemArray)
            Next
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular Fields

frmSuchFormular overview

Fields

field AndOr
field BTNDELETEPROFIL
field BtnHelp
field C1TrueDBGrid1
field ContextMenu1
field ContextMenu2
field ContextMenu3
field ContextMenu4
field Datachanged
field Daten
field DokList
field DruckThread
field DynNrEintrag
field EDOKADaten
field Gruppierung
field HOSTDaten
field ImageList1
field ImageList2
field ImageList3
field Label1
field MenuItem1
field MenuItem10
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MitFreitext
field MnuDatenselektion
field MnuDelete
field On_Load
field Operatoren
field Panel1
field Panel2
field Partnerdialog
field Pview
field SaveFileDialog1
field Splitter1
field Splitter2
field Splitter3
field Suche
field TabControl1
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolTip1
field TreeView1
field UVMDaten
field User_Hat_Berechtigung
field ZVDaten
field btnSave
field btnSearch
field btndruck
field cbProfile
field components
field dokumentid
field gendokcold
field i
field intds
field intdt
field m_NeueSuche
field m_showcheckmessage
field m_updateprofildaten
field oldnode
field parameter
field partnernr
field profile
field rbzv6monate
field rbzvvollständig
field savenode
field selectPoint
field sql
field sqlcollection
field sqlcount
field sqldbfeldformat
field sqlwhere

See Also

frmSuchFormular Class


AndOr Variable

Dim AndOr As New DataTable()

Source code

[Visual Basic]
    Dim AndOr As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


BTNDELETEPROFIL Variable

Friend WithEvents BTNDELETEPROFIL As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents BTNDELETEPROFIL As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Datachanged Variable

Dim Datachanged As Boolean = False

Source code

[Visual Basic]
    Dim Datachanged As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Daten Variable

Dim Daten As New DataTable()

Source code

[Visual Basic]
    Dim Daten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


DruckThread Variable

Dim DruckThread As Thread

Source code

[Visual Basic]
    Dim DruckThread As Thread

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


DynNrEintrag Variable

Dim DynNrEintrag As Integer = 0

Source code

[Visual Basic]
    Dim DynNrEintrag As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


EDOKADaten Variable

Dim EDOKADaten As Boolean = False

Source code

[Visual Basic]
    Dim EDOKADaten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Gruppierung Variable

Friend WithEvents Gruppierung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents Gruppierung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


HOSTDaten Variable

Dim HOSTDaten As Boolean = False

Source code

[Visual Basic]
    Dim HOSTDaten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MitFreitext Variable

Dim MitFreitext As Integer

Source code

[Visual Basic]
    Dim MitFreitext As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MnuDatenselektion Variable

Friend WithEvents MnuDatenselektion As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDatenselektion As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


MnuDelete Variable

Friend WithEvents MnuDelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Operatoren Variable

Dim Operatoren As New DataTable()

Source code

[Visual Basic]
    Dim Operatoren As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Partnerdialog Variable

Dim WithEvents Partnerdialog As New FrmPartnersuche()

Source code

[Visual Basic]
    Dim WithEvents Partnerdialog As New FrmPartnersuche()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Pview Variable

Dim Pview As New DataView()

Source code

[Visual Basic]
    Dim Pview As New DataView()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


SaveFileDialog1 Variable

Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Source code

[Visual Basic]
    Friend WithEvents SaveFileDialog1 As System.Windows.Forms.SaveFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Splitter3 Variable

Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter3 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


Suche Variable

Friend WithEvents Suche As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents Suche As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


TreeView1 Variable

Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TreeView1 As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


UVMDaten Variable

Dim UVMDaten As Boolean = False

Source code

[Visual Basic]
    Dim UVMDaten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


User_Hat_Berechtigung Variable

Dim User_Hat_Berechtigung As Boolean = False

Source code

[Visual Basic]
    Dim User_Hat_Berechtigung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


ZVDaten Variable

Dim ZVDaten As Boolean = False

Source code

[Visual Basic]
    Dim ZVDaten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


btnSave Variable

Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnSave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


btnSearch Variable

Friend WithEvents btnSearch As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnSearch As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


btndruck Variable

Friend WithEvents btndruck As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btndruck As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


cbProfile Variable

Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


dokumentid Variable

Dim dokumentid As String

Source code

[Visual Basic]
    Dim dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


gendokcold Variable

Dim gendokcold As Collection

Source code

[Visual Basic]
    Dim gendokcold As Collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


i Variable

Dim i As Integer

Source code

[Visual Basic]
    Dim i As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


intds Variable

Dim intds As New DataSet()

Source code

[Visual Basic]
    Dim intds As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


intdt Variable

Dim intdt As New DataTable()

Source code

[Visual Basic]
    Dim intdt As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


m_NeueSuche Variable

Dim m_NeueSuche As Boolean

Source code

[Visual Basic]
    Dim m_NeueSuche As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


m_showcheckmessage Variable

Dim m_showcheckmessage As Boolean

Source code

[Visual Basic]
    Dim m_showcheckmessage As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


m_updateprofildaten Variable

Dim m_updateprofildaten As Boolean = False

Source code

[Visual Basic]
    Dim m_updateprofildaten As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


oldnode Variable

Dim oldnode As Integer = 0

Source code

[Visual Basic]
    Dim oldnode As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


parameter Variable

Dim parameter As New DataTable()

Source code

[Visual Basic]
    Dim parameter As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


partnernr Variable

Dim partnernr As String

Source code

[Visual Basic]
    Dim partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


profile Variable

Dim profile As New DataTable()

Source code

[Visual Basic]
    Dim profile As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


rbzv6monate Variable

Friend WithEvents rbzv6monate As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbzv6monate As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


rbzvvollständig Variable

Friend WithEvents rbzvvollständig As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents rbzvvollständig As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


savenode Variable

Dim savenode As TreeNode

Source code

[Visual Basic]
    Dim savenode As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


sql Variable

Dim sql() As String

Source code

[Visual Basic]
    Dim sql() As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


sqlcollection Variable

Dim sqlcollection As New Collection()

Source code

[Visual Basic]
    Dim sqlcollection As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


sqlcount Variable

Dim sqlcount As Integer = 0

Source code

[Visual Basic]
    Dim sqlcount As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


sqldbfeldformat Variable

Dim sqldbfeldformat As String

Source code

[Visual Basic]
    Dim sqldbfeldformat As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


sqlwhere Variable

Dim sqlwhere As String

Source code

[Visual Basic]
    Dim sqlwhere As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSysadminTableSelector Class

For a list of all members of this type, see frmSysadminTableSelector Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmSysadminTableSelector

Public Class frmSysadminTableSelector
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmSysadminTableSelector Members


frmSysadminTableSelector Members

frmSysadminTableSelector overview

Constructors

constructor frmSysadminTableSelector Constructor

Methods

method Dispose
method InitializeComponent
method frmSysadminTableSelector_Load
method get_tablename
method listbox1_dblclick

Fields

field DataSet1
field ListBox1
field SqlConnection1
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field components

See Also

frmSysadminTableSelector Class


frmSysadminTableSelector Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector Methods

frmSysadminTableSelector overview

Methods

method Dispose
method InitializeComponent
method frmSysadminTableSelector_Load
method get_tablename
method listbox1_dblclick

See Also

frmSysadminTableSelector Class


frmSysadminTableSelector.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ListBox1 = New System.Windows.Forms.ListBox()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sysobjects", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("id", "id"), New System.Data.Common.DataColumnMapping("xtype", "xtype"), New System.Data.Common.DataColumnMapping("uid", "uid"), New System.Data.Common.DataColumnMapping("info", "info"), New System.Data.Common.DataColumnMapping("status", "status"), New System.Data.Common.DataColumnMapping("base_schema_ver", "base_schema_ver"), New System.Data.Common.DataColumnMapping("replinfo", "replinfo"), New System.Data.Common.DataColumnMapping("parent_obj", "parent_obj"), New System.Data.Common.DataColumnMapping("crdate", "crdate"), New System.Data.Common.DataColumnMapping("ftcatid", "ftcatid"), New System.Data.Common.DataColumnMapping("schema_ver", "schema_ver"), New System.Data.Common.DataColumnMapping("stats_schema_ver", "stats_schema_ver"), New System.Data.Common.DataColumnMapping("type", "type"), New System.Data.Common.DataColumnMapping("userstat", "userstat"), New System.Data.Common.DataColumnMapping("sysstat", "sysstat"), New System.Data.Common.DataColumnMapping("indexdel", "indexdel"), New System.Data.Common.DataColumnMapping("refdate", "refdate"), New System.Data.Common.DataColumnMapping("version", "version"), New System.Data.Common.DataColumnMapping("deltrig", "deltrig"), New System.Data.Common.DataColumnMapping("instrig", "instrig"), New System.Data.Common.DataColumnMapping("updtrig", "updtrig"), New System.Data.Common.DataColumnMapping("seltrig", "seltrig"), New System.Data.Common.DataColumnMapping("category", "category"), New System.Data.Common.DataColumnMapping("cache", "cache")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_sysobjects_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.NVarChar, 128, "name"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@id", System.Data.SqlDbType.Int, 4, "id"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@xtype", System.Data.SqlDbType.VarChar, 2, "xtype"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@uid", System.Data.SqlDbType.Int, 2, "uid"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@info", System.Data.SqlDbType.Int, 2, "info"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@status", System.Data.SqlDbType.Int, 4, "status"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@base_schema_ver", System.Data.SqlDbType.Int, 4, "base_schema_ver"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@replinfo", System.Data.SqlDbType.Int, 4, "replinfo"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@parent_obj", System.Data.SqlDbType.Int, 4, "parent_obj"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@crdate", System.Data.SqlDbType.DateTime, 8, "crdate"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ftcatid", System.Data.SqlDbType.Int, 2, "ftcatid"))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_sysobjects_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ListBox1
        '
        Me.ListBox1.Location = New System.Drawing.Point(8, 16)
        Me.ListBox1.Name = "ListBox1"
        Me.ListBox1.Size = New System.Drawing.Size(240, 316)
        Me.ListBox1.TabIndex = 0
        '
        'frmSysadminTableSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(256, 349)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.ListBox1})
        Me.Name = "frmSysadminTableSelector"
        Me.Text = "Tabelle auswählen"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector.frmSysadminTableSelector_Load Method

Private Sub frmSysadminTableSelector_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmSysadminTableSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
            Me.ListBox1.Items.Add(Me.DataSet1.Tables(0).Rows(i)(0))
        Next
        Me.SqlConnection1.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector.get_tablename Method

Public Function get_tablename() As String

Source code

[Visual Basic]
    Public Function get_tablename() As String
        get_tablename = ""
        Me.ShowDialog()
        Return Me.ListBox1.SelectedItem
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector.listbox1_dblclick Method

Private Sub listbox1_dblclick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles ListBox1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub listbox1_dblclick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles ListBox1.DoubleClick
        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmSysadminTableSelector Fields

frmSysadminTableSelector overview

Fields

field DataSet1
field ListBox1
field SqlConnection1
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field components

See Also

frmSysadminTableSelector Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


ListBox1 Variable

Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Source code

[Visual Basic]
    Friend WithEvents ListBox1 As System.Windows.Forms.ListBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSysadminTableSelector


frmTrefferliste Class

For a list of all members of this type, see frmTrefferliste Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmTrefferliste

Public Class frmTrefferliste
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmTrefferliste Members


frmTrefferliste Members

frmTrefferliste overview

Constructors

constructor frmTrefferliste Constructor

Properties

property DoRefresh
property Dokumentbezeichnung
property FirstEntry
property FromMenu
property Geschaeftsfall
property ImgCombo
property LastEntry
property OnlySelect
property PageDirection
property Partner_Eingegeben
property Partnernr
property Profilnr
property SelectedBeschreibung
property SelectedDocart
property SelectedDokumentid
property dokumentdatum

Methods

method Alle_Dokumente_Des_Geschaeftsfalles |
method BtnHelp_Click |
method Button1_Click |
method Button2_Click |
method Button3_Click |
method Button4_Click |
method Button5_Click |
method Button6_Click |
method Button9_Click |
method C1TrueDBGrid1_FetchCellStyle |
method ColdListDokumente_Collapse |
method ColdListDokumente_Expand |
method ColdListDokumente_Leave |
method ColdListDokumente_MouseUp |
method ColdListDokumente_RowColChange |
method Cold_Index_lesen |
method ContextMenu10_Popup |
method ContextMenu1_Popup |
method ContextMenu2_Popup |
method ContextMenu7_Popup |
method ContextMenu8_Popup |
method ContextMenu9_Popup |
method Create_Dokument |
method Create_Search_Menu |
method Dispose |
method DoKeyenter |
method DokList_Click |
method DokList_DoubleClick |
method DokList_MouseDown |
method DokList_MouseUp |
method DokList_RowColChange |
method DokList_SelChange |
method Doklist_FetchScrollTips |
method Dokumente_lesen |
method Dokumentfunktionen_Laden |
method Dokumentinfomeldungen_laden |
method Dokumentwert_lesen |
method Dokumentzuordnungen_Laden |
method DruckMetaDaten |
method ErsetzteDokumente_Laden |
method FetchRowStyle |
method Form1_Load |
method Generic_Select |
method GetNode |
method InfoMeldungList_FetchRowStyle |
method Init_Pages |
method InitializeComponent |
method Load_Layout |
method Load_Profiles |
method MenuItem10_Click |
method MenuItem11_Click |
method MenuItem12_Click |
method MenuItem14_Click |
method MenuItem15_Click |
method MenuItem16_Click |
method MenuItem17_Click |
method MenuItem18_Click |
method MenuItem19_Click |
method MenuItem1_Click |
method MenuItem21_Click |
method MenuItem22_Click |
method MenuItem24_Click |
method MenuItem25_Click |
method MenuItem26_Click |
method MenuItem27_Click |
method MenuItem28_Click |
method MenuItem29_Click |
method MenuItem2_Click |
method MenuItem31_Click |
method MenuItem32_Click |
method MenuItem33_Popup |
method MenuItem34_Click |
method MenuItem35_Click |
method MenuItem37_Click |
method MenuItem39_Click |
method MenuItem3_Click |
method MenuItem40_Click |
method MenuItem41_Click |
method MenuItem43_Click |
method MenuItem44_Click |
method MenuItem46_Click |
method MenuItem47_Click |
method MenuItem48_Click |
method MenuItem49_Click |
method MenuItem4_Click |
method MenuItem50_Click |
method MenuItem51_Click |
method MenuItem6_Click |
method MenuItem7_Click |
method MenuItem8_Click |
method MenuItemISINSUche_Click |
method MenuItemPartnersuche_Click |
method MenuItemVVSuche_Click |
method MenuItemValorSuche_Click |
method Mitarbeiter_Laden |
method MnuABDokAufheben_Click |
method MnuABDokLoeschen_Click |
method MnuClose_Click |
method MnuDokumentSelect_Click |
method MnuDokumentreaktivieren_Click |
method MnuNotizanzeigen_Click |
method Name_of_Trefferliste |
method Notizen_Laden |
method Notizlist_MouseDown |
method PosDok |
method RBStatusAktuell_Click |
method Refresh_All |
method SaveButtonToProfil |
method Save_Layout |
method SetDataFromProfil | Liest das Profil aus und setzt die Buttons in den richtigen Status
method SetMetaDataDruck |
method SetToolbar1Buttons | Setzt die Buttons und den Tooltip.
method Set_Colors |
method Splitter2_Move |
method Status_lesen |
method Statuslist_FetchRowStyle |
method TVstruktur_MouseDown |
method TabControl1_Click |
method TabPage1_Click |
method TabPageDokumentwerte_Click |
method ToolBar1_ButtonClick |
method Update_ColdListDokumente_Detail |
method Update_Coldindex |
method Update_DetailInformation |
method Update_Details |
method Update_Doklist |
method Update_DokumentInfoMeldung |
method Update_Dokumentfunktionen |
method Update_Dokumentzuordnung |
method Update_Ersetzte_Dokumente |
method Update_Notizen |
method Update_Partnerstruktur |
method Update_Status |
method btnPartnersuche_VisibleChanged |
method cbProfile_SelectedIndexChanged |
method check_blkunde |
method check_dokumentreaktivieren |
method dokument_ist_abgeschlossen |
method frmTrefferliste_Closing |
method frmTrefferliste_Resize |
method getDokumentID |
method get_contextmenu_ber |
method getnodedepth |
method imgcombo_SelectedIndexChanged_1 |
method insert_used_dp |
method isbck |
method lblpageno_TextChanged |
method mnuDokKopieren_Click |
method mnuDokTypInfo_Click |
method mnuDruckAllgemein_Click |
method mnuDruckBerechtigung_Click |
method mnuDruckDokStatus_Click |
method mnuDruckDokumentwerte_Click |
method mnuDruckErsetzte_Click |
method mnuDruckInfoMeldung_Click |
method mnuDruckNotizen_Click |
method mnuDruckZuordnung_Click |
method mnuFreitextSuche_Click |
method mnuSendMessage_Click |
method mnublkunde_Click |
method nrpar00_KeyDown |
method refresh_list |
method set_abgeschlossen_menu |
method set_combo |
method set_tips |
method tvstruktur_AfterExpand |
method tvstruktur_AfterSelect |
method tvstruktur_BeforeExpand |
method tvstruktur_DoubleClick |
method tvstruktur_MouseEnter |
method tvstruktur_MouseMove |
method txtbcknr_KeyDown |
method txtnrpar00_textchanged |

Fields

field AlleDokumente
field BtnHelp
field BtnPrint
field BtnProfil
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field ColdList
field ColdListDokumente
field ContextMenu1
field ContextMenu10
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field ContextMenuAllgemein
field ContextMenuBerechtigung
field ContextMenuInfoMeldung
field CurrentPage
field DataSet1
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field HOSTDATEN
field ImageList1
field ImageList2
field ImageList3
field ImageList3_Sik
field ImageList4
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LblSearch
field LoadProfiles
field M_FROMMENU
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem56
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemISINSUche
field MenuItemPartnersuche
field MenuItemVVSuche
field MenuItemValorSuche
field MnuABDokAufheben
field MnuABDokLoeschen
field MnuAbgeschlossen
field MnuClose
field MnuDokumentSelect
field MnuDokumentreaktivieren
field MnuNotizanzeigen
field MnuProfil
field MnuSearch
field Notizlist
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PreviewAlleDokumente
field RBStatusAktuell
field RBStatusHistory
field SearchTip
field Splitter1
field Splitter2
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field Statuslist
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton7
field UVMDaten
field ZVDaten
field Zuordnungslist
field al
field bcknr
field bntNewDoc
field btnExit
field btnPartnersuche
field cbProfile
field cmitprofil
field colornotset
field components
field doklistrowcount
field drpMiatarbeiter
field lblpageno
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_ColdListWidthOrg
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_FirstEntry
field m_LastEntry
field m_OrgData_change
field m_OrgData_dt
field m_bInakAlt
field m_bInakVersant
field m_dokumentbezeichnung
field m_dokumentdatum
field m_geschaeftsfall
field m_onlyselect
field m_pagedirection
field m_partnernr
field m_profilnr
field m_refresh
field m_sTempColdDokID
field m_selectedbeschreibung
field m_selecteddocart
field m_selecteddokumentid
field maxpage
field mnuDokKopieren
field mnuDokTypInfo
field mnuDruckAllgemein
field mnuDruckBerechtigung
field mnuDruckDokStatus
field mnuDruckDokumentwerte
field mnuDruckErsetzte
field mnuDruckInfoMeldung
field mnuDruckNotizen
field mnuDruckZuordnung
field mnuFreitextSuche
field mnuSendMessage
field mnu_gelabgesch
field mnu_gelversant
field mnublkunde
field on_refresh
field pnlSearch
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field savenode
field scolor1
field scolor2
field scolor3
field scolor4
field scolor5
field scolor6
field selectPoint
field selp
field statushistory
field tpagemax
field tpagemin
field tt
field ttip
field tvstruktur
field txtbcknr
field txtnrpar00
field update_host
field vertraulich

See Also

frmTrefferliste Class


frmTrefferliste Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()
        Me.FirstEntry = 0
        Me.LastEntry = 0
        Me.PageDirection = 0

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

        Dim i As Integer
        On_Load = True
        ImgCombo = New ImageComboBox(Me.cbProfile)
        ImgCombo.ImageList = Me.ImageList2
        Load_Profiles()
        al.Clear()
        Dim a As String
        Dim b As Integer
        Dim c As Integer
        Try
            Me.LoadProfiles = True
            For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
                a = Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung")
                b = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                c = Me.DataSet1.Tables(0).Rows(i).Item("Profiltyp") - 1
                al.Add(New ImgGenericList(a, b, -1))
            Next
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try

        ImgCombo.DataSource = al
        ImgCombo.DisplayMember = "Display"
        ImgCombo.ValueMember = "ID"
        ImgCombo.ImageIndexMember = "Index"
        ImgCombo.BringToFront()
        ImgCombo.Enabled = True
        ImgCombo.Visible = True
        Dim i1 As Integer
        Dim i2 As Integer
        Dim xx As Integer
        If Globals.profilnr = 0 Then
            For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
                If Me.DataSet1.Tables(0).Rows(i).Item("standard") = True And Me.Profilnr = 0 Then
                    Me.ImgCombo.SelectedValue = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                    Me.Profilnr = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                End If
            Next
        Else
            Me.ImgCombo.SelectedValue = Globals.profilnr
            Me.Profilnr = Globals.profilnr
            Globals.profilnr = 0
        End If
        Me.LoadProfiles = False
        Name_of_Trefferliste()
        Globals.DokumentartenImages = Me.ImageList3
        On_Load = False
        Set_Colors()
        set_tips()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste Properties

frmTrefferliste overview

Properties

property DoRefresh
property Dokumentbezeichnung
property FirstEntry
property FromMenu
property Geschaeftsfall
property ImgCombo
property LastEntry
property OnlySelect
property PageDirection
property Partner_Eingegeben
property Partnernr
property Profilnr
property SelectedBeschreibung
property SelectedDocart
property SelectedDokumentid
property dokumentdatum

See Also

frmTrefferliste Class


frmTrefferliste.DoRefresh Property

Property DoRefresh() As Boolean

Source code

[Visual Basic]
    Property DoRefresh() As Boolean
        Get
            Return m_refresh
        End Get
        Set(ByVal Value As Boolean)
            m_refresh = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumentbezeichnung Property

Property Dokumentbezeichnung() As String

Source code

[Visual Basic]
    Property Dokumentbezeichnung() As String
        Get
            Return m_dokumentbezeichnung
        End Get
        Set(ByVal Value As String)
            m_dokumentbezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.FirstEntry Property

Property FirstEntry() As Integer

Source code

[Visual Basic]
    Property FirstEntry() As Integer
        Get
            Return m_FirstEntry
        End Get
        Set(ByVal Value As Integer)
            m_FirstEntry = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.FromMenu Property

Property FromMenu() As Boolean

Source code

[Visual Basic]
    Property FromMenu() As Boolean
        Get
            Return M_FROMMENU
        End Get
        Set(ByVal Value As Boolean)
            M_FROMMENU = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Geschaeftsfall Property

Property Geschaeftsfall() As String

Source code

[Visual Basic]
    Property Geschaeftsfall() As String
        Get
            Return m_geschaeftsfall
        End Get
        Set(ByVal Value As String)
            m_geschaeftsfall = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImgCombo Property

Public WithEvents ImgCombo As ImageComboBox

Source code

[Visual Basic]
    Public WithEvents ImgCombo As ImageComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.LastEntry Property

Property LastEntry() As Integer

Source code

[Visual Basic]
    Property LastEntry() As Integer
        Get
            Return m_LastEntry
        End Get
        Set(ByVal Value As Integer)
            m_LastEntry = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.OnlySelect Property

Property OnlySelect() As Boolean

Source code

[Visual Basic]
    Property OnlySelect() As Boolean
        Get
            Return m_onlyselect
        End Get
        Set(ByVal Value As Boolean)
            m_onlyselect = False
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.PageDirection Property

Property PageDirection() As Integer

Source code

[Visual Basic]
    Property PageDirection() As Integer
        Get
            Return m_pagedirection
        End Get
        Set(ByVal Value As Integer)
            m_pagedirection = Value
            Try
                If m_pagedirection > 0 Then Me.Button4.Enabled = True Else Me.Button4.Enabled = False
            Catch
            End Try
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Partner_Eingegeben Property

Public Partner_Eingegeben As Boolean

Source code

[Visual Basic]
    Public Partner_Eingegeben As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As String)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
            '            MsgBox(m_profilnr)
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SelectedBeschreibung Property

Property SelectedBeschreibung()

Source code

[Visual Basic]
    Property SelectedBeschreibung()
        Get
            Return m_selectedbeschreibung
        End Get
        Set(ByVal Value)
            m_selectedbeschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SelectedDocart Property

Property SelectedDocart() As String

Source code

[Visual Basic]
    Property SelectedDocart() As String
        Get
            Return m_selecteddocart
        End Get
        Set(ByVal Value As String)
            m_selecteddocart = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SelectedDokumentid Property

Property SelectedDokumentid() As String

Source code

[Visual Basic]
    Property SelectedDokumentid() As String
        Get
            Return m_selecteddokumentid
        End Get
        Set(ByVal Value As String)
            m_selecteddokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.dokumentdatum Property

Property dokumentdatum() As DateTime

Source code

[Visual Basic]
    Property dokumentdatum() As DateTime
        Get
            Return m_dokumentdatum
        End Get
        Set(ByVal Value As DateTime)
            m_dokumentdatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste Methods

frmTrefferliste overview

Methods

method Alle_Dokumente_Des_Geschaeftsfalles |
method BtnHelp_Click |
method Button1_Click |
method Button2_Click |
method Button3_Click |
method Button4_Click |
method Button5_Click |
method Button6_Click |
method Button9_Click |
method C1TrueDBGrid1_FetchCellStyle |
method ColdListDokumente_Collapse |
method ColdListDokumente_Expand |
method ColdListDokumente_Leave |
method ColdListDokumente_MouseUp |
method ColdListDokumente_RowColChange |
method Cold_Index_lesen |
method ContextMenu10_Popup |
method ContextMenu1_Popup |
method ContextMenu2_Popup |
method ContextMenu7_Popup |
method ContextMenu8_Popup |
method ContextMenu9_Popup |
method Create_Dokument |
method Create_Search_Menu |
method Dispose |
method DoKeyenter |
method DokList_Click |
method DokList_DoubleClick |
method DokList_MouseDown |
method DokList_MouseUp |
method DokList_RowColChange |
method DokList_SelChange |
method Doklist_FetchScrollTips |
method Dokumente_lesen |
method Dokumentfunktionen_Laden |
method Dokumentinfomeldungen_laden |
method Dokumentwert_lesen |
method Dokumentzuordnungen_Laden |
method DruckMetaDaten |
method ErsetzteDokumente_Laden |
method FetchRowStyle |
method Form1_Load |
method Generic_Select |
method GetNode |
method InfoMeldungList_FetchRowStyle |
method Init_Pages |
method InitializeComponent |
method Load_Layout |
method Load_Profiles |
method MenuItem10_Click |
method MenuItem11_Click |
method MenuItem12_Click |
method MenuItem14_Click |
method MenuItem15_Click |
method MenuItem16_Click |
method MenuItem17_Click |
method MenuItem18_Click |
method MenuItem19_Click |
method MenuItem1_Click |
method MenuItem21_Click |
method MenuItem22_Click |
method MenuItem24_Click |
method MenuItem25_Click |
method MenuItem26_Click |
method MenuItem27_Click |
method MenuItem28_Click |
method MenuItem29_Click |
method MenuItem2_Click |
method MenuItem31_Click |
method MenuItem32_Click |
method MenuItem33_Popup |
method MenuItem34_Click |
method MenuItem35_Click |
method MenuItem37_Click |
method MenuItem39_Click |
method MenuItem3_Click |
method MenuItem40_Click |
method MenuItem41_Click |
method MenuItem43_Click |
method MenuItem44_Click |
method MenuItem46_Click |
method MenuItem47_Click |
method MenuItem48_Click |
method MenuItem49_Click |
method MenuItem4_Click |
method MenuItem50_Click |
method MenuItem51_Click |
method MenuItem6_Click |
method MenuItem7_Click |
method MenuItem8_Click |
method MenuItemISINSUche_Click |
method MenuItemPartnersuche_Click |
method MenuItemVVSuche_Click |
method MenuItemValorSuche_Click |
method Mitarbeiter_Laden |
method MnuABDokAufheben_Click |
method MnuABDokLoeschen_Click |
method MnuClose_Click |
method MnuDokumentSelect_Click |
method MnuDokumentreaktivieren_Click |
method MnuNotizanzeigen_Click |
method Name_of_Trefferliste |
method Notizen_Laden |
method Notizlist_MouseDown |
method PosDok |
method RBStatusAktuell_Click |
method Refresh_All |
method SaveButtonToProfil |
method Save_Layout |
method SetDataFromProfil | Liest das Profil aus und setzt die Buttons in den richtigen Status
method SetMetaDataDruck |
method SetToolbar1Buttons | Setzt die Buttons und den Tooltip.
method Set_Colors |
method Splitter2_Move |
method Status_lesen |
method Statuslist_FetchRowStyle |
method TVstruktur_MouseDown |
method TabControl1_Click |
method TabPage1_Click |
method TabPageDokumentwerte_Click |
method ToolBar1_ButtonClick |
method Update_ColdListDokumente_Detail |
method Update_Coldindex |
method Update_DetailInformation |
method Update_Details |
method Update_Doklist |
method Update_DokumentInfoMeldung |
method Update_Dokumentfunktionen |
method Update_Dokumentzuordnung |
method Update_Ersetzte_Dokumente |
method Update_Notizen |
method Update_Partnerstruktur |
method Update_Status |
method btnPartnersuche_VisibleChanged |
method cbProfile_SelectedIndexChanged |
method check_blkunde |
method check_dokumentreaktivieren |
method dokument_ist_abgeschlossen |
method frmTrefferliste_Closing |
method frmTrefferliste_Resize |
method getDokumentID |
method get_contextmenu_ber |
method getnodedepth |
method imgcombo_SelectedIndexChanged_1 |
method insert_used_dp |
method isbck |
method lblpageno_TextChanged |
method mnuDokKopieren_Click |
method mnuDokTypInfo_Click |
method mnuDruckAllgemein_Click |
method mnuDruckBerechtigung_Click |
method mnuDruckDokStatus_Click |
method mnuDruckDokumentwerte_Click |
method mnuDruckErsetzte_Click |
method mnuDruckInfoMeldung_Click |
method mnuDruckNotizen_Click |
method mnuDruckZuordnung_Click |
method mnuFreitextSuche_Click |
method mnuSendMessage_Click |
method mnublkunde_Click |
method nrpar00_KeyDown |
method refresh_list |
method set_abgeschlossen_menu |
method set_combo |
method set_tips |
method tvstruktur_AfterExpand |
method tvstruktur_AfterSelect |
method tvstruktur_BeforeExpand |
method tvstruktur_DoubleClick |
method tvstruktur_MouseEnter |
method tvstruktur_MouseMove |
method txtbcknr_KeyDown |
method txtnrpar00_textchanged |

See Also

frmTrefferliste Class


frmTrefferliste.Alle_Dokumente_Des_Geschaeftsfalles Method

Public Sub Alle_Dokumente_Des_Geschaeftsfalles()

Source code

[Visual Basic]
    Public Sub Alle_Dokumente_Des_Geschaeftsfalles()
        Dim d As New edokadb.clsMyDokumentart()
        d.SearchString = 0
        d.FirstEntry = 1
        d.LastEntry = 99999999
        d.Geschaeftsfall = Me.Geschaeftsfall
        d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, False)
        d.Geschaeftsfall = Me.Geschaeftsfall
        PreviewAlleDokumente = True		'neu koe 29.09.2003
        If Me.tvstruktur.GetNodeCount(False) = 1 Then
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            Me.Update_Partnerstruktur()
            Me.tvstruktur.ExpandAll()
        End If
        AlleDokumente = True
        Update_Doklist()
        AlleDokumente = False
        Me.Text = Me.Text + " - Geschäftsfall: " + Me.Geschaeftsfall
        Me.cbProfile.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("Trefferliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnersuche.Click
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = True
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Cursor = Cursors.WaitCursor
            Me.txtnrpar00.Text = f.PartnerNr
            Me.Partner_Eingegeben = True
            refresh_list()
            Me.Cursor = Cursors.Default
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Update_Doklist()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.tvstruktur.BeginUpdate()
        Me.CurrentPage = CurrentPage - 1
        If Me.CurrentPage < 1 Then Me.CurrentPage = 1
        Me.Partner_Eingegeben = False
        Me.on_refresh = True
        refresh_list()
        Me.on_refresh = False
        Me.tvstruktur.EndUpdate()
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Me.tvstruktur.BeginUpdate()
        Me.CurrentPage = CurrentPage + 1
        Me.PageDirection = 2
        Me.Partner_Eingegeben = False
        Me.on_refresh = True
        refresh_list()
        Me.on_refresh = False
        Me.tvstruktur.EndUpdate()
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button6_Click Method

Private Sub Button6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button6.Click
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(Me.tvstruktur.GetNodeCount(False) - 1)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Button9_Click Method

Private Sub Button9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button9.Click
        Dim f As New frmProfilinfo()
        f.ProfilNr = Me.Profilnr
        f.Text = f.Text + Me.ImgCombo.Text
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.C1TrueDBGrid1_FetchCellStyle Method

Private Sub C1TrueDBGrid1_FetchCellStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs _
) Handles DokList.FetchCellStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs) Handles DokList.FetchCellStyle
        Try
            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(e.Row), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(e.Row), Me.DokList.Columns("dokumentid").CellValue(e.Row), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(e.Row), "")
            If d.Rows.Count = 0 Then
                e.CellStyle.ForeColor = Color.Transparent
                '                Me.DokList.Splits(0).DisplayColumns("Bemerkung").Width = 0
                'Me.DokList.Splits(0).DisplayColumns("Bemerkung").Style.ForeColor = System.Drawing.Color.Transparent
                Me.vertraulich = True
                Exit Sub
            End If
            If d.Rows(0).Item("anzeigen") = 0 Then
                Me.vertraulich = True
                e.CellStyle.ForeColor = Color.Transparent
                Exit Sub
            End If
            d.Dispose()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ColdListDokumente_Collapse Method

Private Sub ColdListDokumente_Collapse( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs _
) Handles ColdListDokumente.Collapse

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Collapse(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs) Handles ColdListDokumente.Collapse
        Dim iCnt As Integer
        m_ColdListDokumenteDefaultWidth = ColdListDokumente.Splits(0).DisplayColumns("dokumentbezeichnung").Width + ColdListDokumente.Splits(0).DisplayColumns("status").Width + ColdListDokumente.Splits(0).DisplayColumns("archivdatum").Width + 25

        Try
            m_ExpandColdListDokumente = m_ExpandColdListDokumente - 1
            If m_ExpandColdListDokumente < 0 Then m_ExpandColdListDokumente = 0
            If m_ExpandColdListDokumente < 1 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        'Spalten ausblenden
                    Case "STATUSALT", "ARCHIVDATUMALT"
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                            ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
                    End Select
                Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ColdListDokumente_Expand Method

Private Sub ColdListDokumente_Expand( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs _
) Handles ColdListDokumente.Expand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Expand(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs) Handles ColdListDokumente.Expand
        Dim iCnt As Integer
        m_ColdListDokumenteDefaultWidth = ColdListDokumente.Splits(0).DisplayColumns("dokumentbezeichnung").Width + ColdListDokumente.Splits(0).DisplayColumns("status").Width + ColdListDokumente.Splits(0).DisplayColumns("archivdatum").Width + 25

        Try
            m_ExpandColdListDokumente = m_ExpandColdListDokumente + 1
            If m_ExpandColdListDokumente < 2 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        Case "STATUSALT", "ARCHIVDATUMALT"
                            m_ColdListDokumenteDefaultWidth = m_ColdListDokumenteDefaultWidth + ColdListDokumente.Splits(0).DisplayColumns(iCnt).Width
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = True
                    End Select
                Next
                ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ColdListDokumente_Leave Method

Private Sub ColdListDokumente_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ColdListDokumente.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles ColdListDokumente.Leave
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ColdListDokumente_MouseUp Method

Private Sub ColdListDokumente_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles ColdListDokumente.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles ColdListDokumente.MouseUp
        Dim iCnt As Integer
        Dim sDokID As String
        Dim sDokstatus As String
        Dim iStapelNr As Integer
        Try
            Update_ColdListDokumente_Detail(True)
            If ColdListDokumente.Col > 5 Then
                For iCnt = 0 To ColdListDokumente.Columns.Count - 1
                    Select Case UCase(ColdListDokumente.Columns(iCnt).DataField)
                        Case "STAPELNR"
                            iStapelNr = ColdListDokumente.Columns(iCnt).Text
                        Case "COLDDOKID"
                            sDokID = ColdListDokumente.Columns(iCnt).Text
                        Case "STATUSALT"
                            sDokstatus = ColdListDokumente.Columns(iCnt).Text
                    End Select
                Next
                'Rel 3.5 / BUD
                m_sTempColdDokID = sDokID
                For iCnt = 0 To ColdList.Splits(0).Rows.Count - 1
                    ColdList.Bookmark = iCnt
                    Select Case ColdList.Columns("indexfeld_nr").CellText(iCnt)
                        Case 11 ' Stapelnummer
                            ColdList.Columns("IndexWert").Text = Format(iStapelNr, "0#####")
                        Case 7  'Dokumentstatus
                            ColdList.Columns("IndexWert").Text = sDokstatus
                        Case 10  'Dokumentid
                            ColdList.Columns("IndexWert").Text = sDokID
                    End Select
                Next
                ColdList.Bookmark = 0
            Else
                m_sTempColdDokID = Me.ColdListDokumente.Columns("colddokumentid").Text
            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ColdListDokumente_RowColChange Method

Private Sub ColdListDokumente_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles ColdListDokumente.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles ColdListDokumente.RowColChange
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Cold_Index_lesen Method

Public Function Cold_Index_lesen( _
   ByVal indextyp As Integer, _
   ByVal iRoot As Integer _
) As DataTable

Parameters

indextyp
Required.
iRoot
Required.

Source code

[Visual Basic]
    Public Function Cold_Index_lesen(ByVal indextyp As Integer, ByVal iRoot As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Coldindex"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Root", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iRoot))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu10_Popup Method

Private Sub ContextMenu10_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu10.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu10_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu10.Popup
        If Me.ErsetzteDokumenteList.Splits(0).Rows.Count = 0 Then Me.MenuItem27.Enabled = False Else Me.MenuItem27.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Dim i As Integer
        Dim dtctm As New DataTable()
            Dim bDokIstVertraulich As Boolean
            Dim bMAistBerechtigt As Boolean
            Dim User_Hat_Berechtigung As Boolean = False
            Dim nDokumentErstellen As Boolean = False
            If Me.DokList.Splits(0).Rows.Count < 1 Then
                For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                    Me.ContextMenu1.MenuItems(i).Enabled = False
                Next
                Exit Sub
            End If

            Dim bm As Object
            For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                If Me.Partnernr < 1 Then
                    Me.ContextMenu1.MenuItems(i).Enabled = False
                Else
                    Me.ContextMenu1.MenuItems(i).Enabled = True
                End If
            Next

        '************************************************
        'UVM Migration / Erste Variante
        'Start
        '************************************************
        'Try
        '    'Rel 3.7 / BUD - Auf UVM Prüfen ist neu
        '    If Trim(Me.DokList.Columns("Geschaeftsfall").Text.ToString) <> "" And Microsoft.VisualBasic.Left(Me.DokList.Columns("Geschaeftsfall").Text.ToString.Trim, 3) <> "UVM" Then
        '        Me.MenuItem49.Enabled = True
        '    Else
        '        Me.MenuItem49.Enabled = False
        '    End If
        'Catch
        'End Try
        '************************************************
        'ENDE
        '************************************************

            If Globals.Bearbeitung_Problemdokumente = True Then
                Me.MenuItem29.Enabled = False
                Me.MenuItem31.Enabled = False
            End If
            Try
                Me.Cursor = Cursors.WaitCursor
                Dim d As New DataTable()
                Me.MenuItem3.Enabled = False
                Me.MenuItem4.Enabled = False
                Me.MenuItem44.Enabled = False
                Me.MenuItem6.Enabled = False
                Me.MenuItem16.Enabled = False
                Me.MenuItem21.Enabled = True
                Me.MenuItem33.Enabled = False
                Try
                    If UVMDaten Or ZVDaten Or HOSTDATEN Then
                        For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                            Me.ContextMenu1.MenuItems(i).Enabled = False
                        Next
                        Me.ContextMenu1.MenuItems(0).Enabled = True
                        Me.MenuItem24.Enabled = True
                        Me.MenuItem25.Enabled = True
                        Me.MenuItem33.Enabled = True
                        Me.MenuItem43.Enabled = True
                        Me.MenuItem45.Enabled = True
                        Exit Sub
                    End If
                Catch
                End Try
                bMAistBerechtigt = False
                d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
                If d.Rows.Count > 0 Then User_Hat_Berechtigung = True
                Try
                    If d.Rows(0).Item("anzeigen") = 1 Then
                        bMAistBerechtigt = True
                        Me.MenuItem4.Enabled = True
                        Me.MenuItem44.Enabled = True
                        Me.MenuItem33.Enabled = True
                        'Bud
                        Me.MenuItem21.Enabled = True
                    End If
                Catch
                End Try
                Try
                    If d.Rows(0).Item("erstellen") = 1 Then
                        nDokumentErstellen = True
                    End If
                Catch
                End Try
                Try
                    If d.Rows(0).Item("bearbeiten") = 1 Then
                        Me.MenuItem3.Enabled = True
                        Me.MenuItem21.Enabled = True
                        Me.MenuItem6.Enabled = True
                    End If
                Catch
                End Try
                Try
                    If d.Rows(0).Item("loeschen") = 1 Then Me.MenuItem16.Enabled = True
                Catch
                End Try

                'Contextmenu_Ber BUD/SHU Rel. 3.7
                dtctm = get_contextmenu_ber()
                bDokIstVertraulich = False
                If (Me.DokList.Columns("verantwortlich").Value <> Globals.MitarbeiterNr) And Globals.stv = 0 Then
                    Me.MenuItem3.Enabled = False
                    'Rel 3.3
                    '08.11.2004 / BUD
                    If ((Me.DokList.Columns("vertraulich").Text) = True Or (Me.DokList.Columns("  B").Value <> "")) Then
                        If bMAistBerechtigt = False Then
                            Me.MenuItem21.Enabled = False
                            bDokIstVertraulich = True
                        End If
                    Else
                        Me.MenuItem21.Enabled = True
                    End If

                    '***
                    If dtctm.Rows(0).Item("abschlussstatus") <> 0 Then
                        set_abgeschlossen_menu(bDokIstVertraulich, dtctm)
                    End If
                    'If Not dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text) Then
                    'Else
                    '    set_abgeschlossen_menu(bDokIstVertraulich)
                    'End If
                    '***

                    Me.MenuItem6.Enabled = False
                    Me.MenuItem16.Enabled = False
                Else
                    'If Not dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text) Then
                    If dtctm.Rows(0).Item("abschlussstatus") = 0 Then
                        Me.MenuItem4.Enabled = True
                        Me.MenuItem44.Enabled = True
                        Me.MenuItem33.Enabled = True
                        Me.MenuItem3.Enabled = True
                        Me.MenuItem21.Enabled = True
                        Me.MenuItem6.Enabled = True
                        If d.Rows(0).Item("loeschen") = 1 Then Me.MenuItem16.Enabled = True
                    Else
                        set_abgeschlossen_menu(bDokIstVertraulich, dtctm)
                        Me.MenuItem3.Enabled = False
                        'Me.MenuItem21.Enabled = False
                        Me.MenuItem6.Enabled = False
                        Me.MenuItem16.Enabled = False
                    End If
                End If

                If Me.DokList.Columns("status_bezeichnungnr").Value = -2 Or Me.DokList.Columns("status_bezeichnungnr").Value = -3 Then
                    Me.MnuAbgeschlossen.Enabled = True
                    set_abgeschlossen_menu(bDokIstVertraulich, dtctm)
                    If Me.DokList.Columns("status_bezeichnungnr").Value = -2 Then
                        'If check_bearbeitung() = True Then Me.MenuItem3.Enabled = True
                        If dtctm.Rows(0).Item("bearbeitung") <> 0 Then Me.MenuItem3.Enabled = True
                    End If
                    If Me.MnuABDokAufheben.Enabled = True Or Me.MnuABDokLoeschen.Enabled = True Then
                        Me.MnuDokumentreaktivieren.Visible = False
                    Else
                        If check_dokumentreaktivieren() = True Then
                            Me.MnuDokumentreaktivieren.Visible = True
                        Else
                            Me.MnuDokumentreaktivieren.Visible = False
                        End If
                    End If
                Else
                    Me.MnuAbgeschlossen.Enabled = False
                    set_abgeschlossen_menu(bDokIstVertraulich, dtctm)
                End If

                'Bedingt Retournierbares Dokument
                'If DivFnkt.BDR_Dokument(Me.DokList.Columns("dokumentid").Text) Then
                If dtctm.Rows(0).Item("bedingtretournierbar") <> 0 Then
                    Me.MenuItem3.Enabled = False
                End If
                Me.Cursor = Cursors.Default
            Catch ex As Exception
            End Try
            Try
                'If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                If dtctm.Rows(0).Item("issysadmin") <> 0 Then
                    Me.MenuItem4.Enabled = True
                    Me.MenuItem3.Enabled = True
                    Me.MenuItem16.Enabled = True
                    Me.MenuItem6.Enabled = True
                    Me.MenuItem21.Enabled = True
                    Me.MnuABDokAufheben.Enabled = True
                    Me.MnuABDokLoeschen.Enabled = True
                    Me.MenuItem38.Visible = True
                    Me.MnuDokumentreaktivieren.Visible = True
                    Me.MenuItem50.Visible = True
                    Me.MenuItem51.Visible = True
                Else
                    '                Me.MenuItem38.Visible = False
                    '               Me.MenuItem50.Visible = False
                    '              Me.MenuItem51.Visible = False
                End If
            Catch
            End Try
            Try
                If User_Hat_Berechtigung Then MenuItem33_Popup(sender, e)
            Catch
        End Try

        Try
            'If CHK_DLLDokument(Me.DokList.Columns("geschäftsfall").Value) = True Then
            If dtctm.Rows(0).Item("dlldokument") <> 0 Then
                Me.MenuItem49.Enabled = True
                Me.MenuItem3.Enabled = False
                Me.MenuItem16.Enabled = False
                Me.MenuItem6.Enabled = False
                'Me.MenuItem21.Enabled = False
                If Not User_Hat_Berechtigung Then
                    Me.MenuItem4.Enabled = False
                    Me.MenuItem33.Enabled = False
                    Me.MenuItem44.Enabled = False
                End If
            Else
                If Microsoft.VisualBasic.Left(Me.DokList.Columns("dokumentname").Text, 4) = "Imp_" Then
                    Me.MenuItem3.Enabled = False
                    Me.MenuItem33.Enabled = False
                    Me.MenuItem44.Enabled = False
                    If Me.DokList.Columns("verantwortlich").Value > 9000 Then
                        Me.MenuItem6.Enabled = False
                    End If
                End If
                If Me.DokList.Columns("geschäftsfall").Value <> "" And Microsoft.VisualBasic.Left(Me.DokList.Columns("Geschaeftsfall").Text.ToString.Trim, 3) <> "UVM" Then
                    Me.MenuItem49.Enabled = True
                Else
                    Me.MenuItem49.Enabled = False
                End If
            End If
        Catch ex As Exception
        End Try
        'Rel 3.3 / BUD / 08.11.2004
        Me.MenuItem45.Enabled = True
        If Me.MenuItem4.Enabled = True And nDokumentErstellen = True Then
            Me.mnuDokKopieren.Enabled = True
            'If Check_DokisInDB() = False Then
            If dtctm.Rows(0).Item("officedokument") = 0 Then
                Me.MenuItem44.Enabled = False
                'Rel 3.4 / BUD / 5.01.2005
                Me.MenuItem3.Enabled = False
                Me.mnuDokKopieren.Enabled = False
            End If
            'If CHK_DLLDokument(Me.DokList.Columns("geschäftsfall").Value) = True Then
            If dtctm.Rows(0).Item("dlldokument") <> 0 Then
                Me.mnuDokKopieren.Enabled = False
            End If
        Else
            Me.mnuDokKopieren.Enabled = False
        End If
        If dtctm.Rows(0).Item("blquittung") <> 0 Then
            Me.MenuItem3.Enabled = False
            Me.MenuItem16.Enabled = False
            Me.MenuItem33.Enabled = False
            Me.MenuItem21.Enabled = False
            Me.mnuDokKopieren.Enabled = False
        End If
        dtctm.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Try
            'mindestens ein node muess selected sein
            Dim i As Integer
            Console.WriteLine("popup" & DateTime.Now.Second & "_" & DateTime.Now.Millisecond)
            'If Not Me.Partnernr.ToLower() = "keine daten" Then
            '	If check_blkunde(Me.Partnernr) Then
            '		Me.mnublkunde.Enabled = True
            '	Else
            '		Me.mnublkunde.Enabled = False
            '	End If
            'End If

            Try
                If Me.tvstruktur.SelectedNode.ImageIndex = -1 Then
                    For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                        Me.ContextMenu2.MenuItems(i).Enabled = False
                    Next
                Else
                    For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                        Me.ContextMenu2.MenuItems(i).Enabled = True
                    Next
                End If
            Catch ex As Exception
                Throw ex
            Finally
                'sry för de hack, aber es god nöd anersch ><
                If Not Me.Partnernr.ToLower() = "keine daten" Then
                    If check_blkunde(Me.Partnernr) Then
                        Me.mnublkunde.Enabled = True
                    Else
                        Me.mnublkunde.Enabled = False
                    End If
                End If
            End Try

            If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                Me.MenuItem46.Visible = True
            Else
                Me.MenuItem46.Visible = False
            End If
            If Globals.Bearbeitung_Problemdokumente = True Then
                Me.MenuItem12.Enabled = False
                Me.MenuItem15.Enabled = False
            End If
            Try
                Me.mnuFreitextSuche.Visible = False
                If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then Me.mnuFreitextSuche.Visible = True
                If Me.DokList.Columns("nrauf00").Text <> "" Then Me.mnuFreitextSuche.Visible = True
            Catch
            End Try
        Catch ex As Exception
                TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.EdokaApp.frmTrefferliste.ContextMenu2_Popup", ex.Message + " " + ex.StackTrace, TraceLevel.Info)
            End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        If Me.Zuordnungslist.Splits(0).Rows.Count > 0 Then
            If Trim(Me.Zuordnungslist.Columns("ErstellungIn").Text.ToString) = "" Then
                MenuItem26.Enabled = True
                MenuItem47.Enabled = True
                MenuItem48.Enabled = False
            Else
                MenuItem26.Enabled = False
                MenuItem47.Enabled = False
                MenuItem48.Enabled = True
            End If
        Else
            MenuItem26.Enabled = False
            MenuItem47.Enabled = False
            MenuItem48.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu8_Popup Method

Private Sub ContextMenu8_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu8.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu8_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu8.Popup
        If Len(Me.ColdListDokumente.Columns("colddokumentid").Text) = 0 Then
            Me.MenuItem28.Enabled = False
        Else
            Me.MenuItem28.Enabled = True
        End If
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            Me.MenuItem38.Visible = True
            Me.MenuItem38.Enabled = True
            Me.MenuItem50.Visible = True
            Me.MenuItem51.Visible = True
            Me.MenuItem38.Visible = True
            Me.MenuItem38.Enabled = True
            Me.MenuItem50.Visible = True
            Me.MenuItem51.Visible = True
        Else
            Me.MenuItem38.Visible = False
            Me.MenuItem38.Enabled = False
            Me.MenuItem50.Visible = False
            Me.MenuItem51.Visible = False

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ContextMenu9_Popup Method

Private Sub ContextMenu9_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu9.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu9_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu9.Popup
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) = False Then MenuItem32.Enabled = False Else MenuItem32.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Create_Dokument Method

Public Sub Create_Dokument( _
   ByVal BestehenderPartner As Boolean, _
   ByVal showfavoriten As Boolean _
)

Parameters

BestehenderPartner
Required.
showfavoriten
Required.

Source code

[Visual Basic]
    Public Sub Create_Dokument(ByVal BestehenderPartner As Boolean, ByVal showfavoriten As Boolean)
        Dim n As New TreeNode()
        Dim f As New frmVorlagenauswahl()
        f.TVStruktur.ImageList = Me.ImageList3
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Me.Profilnr = Me.ImgCombo.SelectedValue
        f.Show_Favoriten = showfavoriten
        f.ProfilNr = Me.Profilnr
        f.Profile = Me.DataSet1.Tables(0)
        f.Dokumentart = Me.SelectedDocart
        Globals.Individuelles_Dokumentpaket = False
        Globals.DokumentPaket = False

        f.ShowDialog()
        f.Hide()
        Windows.Forms.Application.DoEvents()
        If f.DialogResult = DialogResult.OK Then
            If Globals.DokumentPaket = True Then
                If Globals.Individuelles_Dokumentpaket = True Then
                    insert_used_dp(f.Dokumentvorlage, 0)
                    If BestehenderPartner = True Then
                        Dim dp1 As New frmDokumentpaket(f.Dokumentvorlage, True, Me.Partnernr)
                        dp1.Profile = Me.DataSet1.Tables(0)
                        dp1.Profilnr = Me.Profilnr
                        dp1.MdiParent = Me.MdiParent
                        dp1.Show()
                        Exit Sub
                    Else
                        Dim dp1 As New frmDokumentpaket(f.Dokumentvorlage, True, 0)
                        dp1.Profile = Me.DataSet1.Tables(0)
                        dp1.Profilnr = Me.Profilnr
                        dp1.MdiParent = Me.MdiParent
                        dp1.Show()
                        Exit Sub
                    End If

                Else
                    insert_used_dp(f.Dokumentvorlage, 1)
                    If BestehenderPartner = True Then
                        Dim dp2 As New frmDokumentpaket(f.Dokumentvorlage, False, Me.Partnernr)
                        dp2.Profile = Me.DataSet1.Tables(0)
                        dp2.Profilnr = Me.Profilnr
                        dp2.MdiParent = Me.MdiParent
                        dp2.Show()
                        Exit Sub
                    Else
                        Dim dp2 As New frmDokumentpaket(f.Dokumentvorlage, False, 0)
                        dp2.Profile = Me.DataSet1.Tables(0)
                        dp2.Profilnr = Me.Profilnr
                        dp2.MdiParent = Me.MdiParent
                        dp2.Show()
                        Exit Sub
                    End If
                End If
            End If

            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            If Globals.bckdokument = False And Not Globals.EinzelDokument Then
                Dim fI As New frmDokumentbearbeitung()
                fI.Profilnr = Me.Profilnr
                fI.Profile = Me.DataSet1.Tables(0)
                If BestehenderPartner = True Then
                    If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                        MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                        f.Dispose()
                        fi.Dispose()
                        Me.Cursor = System.Windows.Forms.Cursors.Default
                        Exit Sub
                    End If
                    fI.Partnernr = Me.Partnernr
                Else
                    fI.Partnernr = ""
                End If
                fI.Dokumenttypnr = f.Dokumentvorlage
                fI.CreateDocument = True
                fI.BarcodeID = f.BarcodeID
                f.Dispose()
                fI.ShowDialog()
                fI.Hide()
                Windows.Forms.Application.DoEvents()
            Else
                If Globals.bckdokument = True Then
                    Dim fi As New frmDokumentbearbeitungBC()
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    If BestehenderPartner = True Then
                        If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                            MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                            f.Dispose()
                            fi.Dispose()
                            Me.Cursor = System.Windows.Forms.Cursors.Default
                            Exit Sub
                        End If
                        fI.Partnernr = Me.Partnernr
                    Else
                        fI.Partnernr = ""
                    End If
                    fI.Dokumenttypnr = f.Dokumentvorlage
                    fI.CreateDocument = True
                    fI.BarcodeID = f.BarcodeID
                    f.Dispose()
                    fI.ShowDialog()
                    fI.Hide()
                    Windows.Forms.Application.DoEvents()
                Else
                    Dim fi As New frmDokumentbearbeitungED()
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    If BestehenderPartner = True Then
                        If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                            MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                            f.Dispose()
                            fi.Dispose()
                            Me.Cursor = System.Windows.Forms.Cursors.Default
                            Exit Sub
                        End If
                        fI.Partnernr = Me.Partnernr
                    Else
                        fI.Partnernr = ""
                    End If
                    fI.Dokumenttypnr = f.Dokumentvorlage
                    fI.CreateDocument = True
                    fI.BarcodeID = f.BarcodeID
                    f.Dispose()
                    fI.ShowDialog()
                    fI.Hide()

                End If
            End If
        End If
        Me.ToolBar1.Buttons(5).ImageIndex = 8
        '        n = Me.savenode
        '        Me.on_refresh = True
        '       refresh_list()
        '      Me.savenode = n
        '     Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        'Me.on_refresh = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Create_Search_Menu Method

Private Sub Create_Search_Menu()

Source code

[Visual Basic]
    Private Sub Create_Search_Menu()
        Dim odm As New OwnerMenu()
        odm.Add(Me.MenuItemPartnersuche, New Bitmap(Me.ImageList3.Images(18)), 0, False)

        odm.Add(Me.MenuItemVVSuche, New Bitmap(Me.ImageList3.Images(15)), 1, False)
        odm.Add(Me.MenuItemValorSuche, New Bitmap(Me.ImageList3.Images(15)), 2, False)
        odm.Add(Me.MenuItemISINSUche, New Bitmap(Me.ImageList3.Images(15)), 3, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DoKeyenter Method

Public Sub DoKeyenter()

Source code

[Visual Basic]
    Public Sub DoKeyenter()
        If Me.txtnrpar00.Text = "" Then
            Me.txtnrpar00.Focus()
            Exit Sub
        End If
        Init_Pages()

        If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
            While Len(Me.txtnrpar00.Text) < 16
                Me.txtnrpar00.Text = "0" + Me.txtnrpar00.Text
            End While
        End If

        If Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":" Then
            Try
                Dim d As Integer
                d = Val(Me.txtnrpar00.Text)
                Me.txtnrpar00.Text = d
            Catch
                MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                Me.txtnrpar00.Focus()
                Me.txtnrpar00.SelectAll()
                Exit Sub
            End Try
        End If
        Globals.PerfMon.insert_entry("Start Partner ausgewählt")
        Me.Cursor = Cursors.WaitCursor
        Partner_Eingegeben = True
        refresh_list()
        If Me.btnPartnersuche.Visible = True Then Me.Refresh_All(True)
        Me.Cursor = Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partner ausgewählt")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_Click Method

Private Sub DokList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_DoubleClick Method

Private Sub DokList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DokList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles DokList.DoubleClick
        Me.MenuItem4_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Globals.PerfMon.insert_entry("Start Dokumentwechsel in Dokumentliste")
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
        Update_DetailInformation()
        Globals.PerfMon.insert_entry("Stop Dokumentwechsel in Dokumentliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_MouseUp Method

Private Sub DokList_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseUp
        '       Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_RowColChange Method

Private Sub DokList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokList.RowColChange
        Dim iCnt As Integer
        If m_ExpandColdListDokumente > 0 Then
            m_ExpandColdListDokumente = 0
            For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                    'Spalten ausblenden
                Case "STATUSALT", "ARCHIVDATUMALT"
                        ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                        ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
                End Select
            Next

        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DokList_SelChange Method

Private Sub DokList_SelChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DokList.SelChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_SelChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DokList.SelChange
        Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Doklist_FetchScrollTips Method

Private Sub Doklist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles DokList.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Doklist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles DokList.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Horizontal
                    e.ScrollTip = Me.DokList.Columns(e.ColIndex).Caption
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " of " & _
                        CStr(Me.doklistrowcount)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumente_lesen Method

Public Function Dokumente_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Dokumente_lesen() As DataTable
        Dim iTag As String
        Dim ipartner As String
        Dim i As Integer
        Try
            iTag = Me.tvstruktur.SelectedNode.Tag
            i = InStr(iTag, "-")
            If i > 0 Then
                ipartner = Val(Microsoft.VisualBasic.Left(iTag, i - 1))
                iTag = Microsoft.VisualBasic.Right(iTag, Len(iTag) - (i + 1))
            Else
                ipartner = Me.Partnernr
                '            ipartner = 0
                iTag = 0
            End If
        Catch
            iTag = 0
            ipartner = 0
            Me.Partnernr = 0
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_getdata_new"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Partnernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerlist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistdokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iTag))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistpartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ipartner))
            If Me.txtnrpar00.Text <> "" Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vollstaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vollstaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@partnereingegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            If Me.AlleDokumente = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@alledokumente", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@alledokumente", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))

            If Me.txtnrpar00.Text.Length > 0 Then
                If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "VA:" + Me.txtnrpar00.Text))
                End If
                If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "IS:" + Me.txtnrpar00.Text))
                End If
                If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "VV:" + Me.txtnrpar00.Text))
                End If
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Geschaeftsfall))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            'MsgBox(ex.Message)
            '    ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumente lesen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumentfunktionen_Laden Method

Private Function Dokumentfunktionen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentfunktionen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumentwert_lesen Method

Public Function Dokumentwert_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Dokumentwert_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Dokumentwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.DruckMetaDaten Method

Private Function DruckMetaDaten( _
   ByVal iTyp As EnumMetaDatenDruckTyp _
)

Parameters

iTyp
Required.

Source code

[Visual Basic]
    Private Function DruckMetaDaten(ByVal iTyp As EnumMetaDatenDruckTyp)
        Try
            Dim f As New frmMetaDatenSelector()
            Select Case iTyp
                Case EnumMetaDatenDruckTyp.AllgemeineInformationen
                    f.cbxAllg.Checked = True
                Case EnumMetaDatenDruckTyp.Berechtigungsaeinschränkung
                    f.cbxBerEinschr.Checked = True
                Case EnumMetaDatenDruckTyp.DokumentStatus
                    f.cbxDokStatus.Checked = True
                Case EnumMetaDatenDruckTyp.DokumentWerte
                    f.cbxDokWerte.Checked = True
                Case EnumMetaDatenDruckTyp.DokumentZuordnungen
                    f.cbxDokZuordnung.Checked = True
                Case EnumMetaDatenDruckTyp.ErsetzteDokumente
                    f.cbxErsetzteDok.Checked = True
                Case EnumMetaDatenDruckTyp.Informationsmeldungen
                    f.cbxInfomeldung.Checked = True
                Case EnumMetaDatenDruckTyp.Notizen
                    f.cbxNotizen.Checked = True
            End Select
            f.Prop_DokumentID = Me.DokList.Columns("dokumentid").Value
            f.ShowDialog()
            If f.DialogResult = DialogResult.OK Then
                f.genReport(f.Prop_DruckParameter)
            End If
            f.Dispose()
        Catch
        Finally

        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ErsetzteDokumente_Laden Method

Private Function ErsetzteDokumente_Laden() As DataTable

Source code

[Visual Basic]
    Private Function ErsetzteDokumente_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_trefferliste_ersetztedokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.FetchRowStyle Method

Private Sub FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle

        Dim convcol As New ColorConverter()
        Dim d As DataTable
        Dim i As Integer
        Me.vertraulich = False
        Try
            If Me.DokList.Columns("vertraulich").CellValue(e.Row) = True Then
                d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(e.Row), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(e.Row), Me.DokList.Columns("dokumentid").CellValue(e.Row), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(e.Row), "")

                If d.Rows.Count = 0 Then
                    'e.CellStyle.ForeColor = Color.Transparent
                    Me.vertraulich = True
                    Exit Sub
                End If
                If d.Rows(0).Item("anzeigen") = 0 Then
                    Me.vertraulich = True
                    '                    e.CellStyle.ForeColor = Color.Transparent
                    Exit Sub
                End If
            End If

            'Rel 3.6 BUD
            'Inaktive Dokumente
            If Me.DokList.Columns("aktivesdokument").CellValue(e.Row) = False And Me.DokList.Columns("AnzeigeStatus").CellValue(e.Row) = 0 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            End If

            'Inaktive versante Dokumente
            If Me.DokList.Columns("aktivesdokument").CellValue(e.Row) = False And Me.DokList.Columns("AnzeigeStatus").CellValue(e.Row) = 1 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
                e.CellStyle.ForeColor = Color.Gray
            End If

            'Status Aufgehoben
            If Me.DokList.Columns("Statusbezeichnungnr").CellValue(e.Row) = -3 And Me.DokList.Columns("AnzeigeStatus").CellValue(e.Row) = 0 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            End If
        Catch ex As Exception
        End Try

        If convcol.ConvertToString(scolor1) <> "Control" Then e.CellStyle.ForeColor = scolor1
        Try
            If Me.DokList.Columns("verantwortlich").CellValue(e.Row) = Globals.MitarbeiterNr Then
                If convcol.ConvertToString(scolor2) <> "Control" Then
                    e.CellStyle.ForeColor = scolor2
                    Exit Sub
                End If
            End If

            If Not Me.DokList.Columns("termin").CellValue(e.Row) Is System.DBNull.Value Then
                If Not (Year(Me.DokList.Columns("termin").Value) = 1900) Then
                    'Terminiert
                    If Me.DokList.Columns("termin").CellValue(e.Row) > Microsoft.VisualBasic.Now Then
                        If convcol.ConvertToString(scolor4) <> "Control" Then
                            e.CellStyle.ForeColor = scolor4
                            Exit Sub
                        End If
                    End If
                    'Überfällig
                    If Me.DokList.Columns("termin").CellValue(e.Row) <= Microsoft.VisualBasic.Now Then
                        If convcol.ConvertToString(scolor5) <> "Control" Then
                            e.CellStyle.ForeColor = scolor5
                            Exit Sub
                        End If
                    End If
                End If
            End If

            If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) = 5 Then
                If convcol.ConvertToString(scolor6) <> "Control" Then
                    e.CellStyle.ForeColor = scolor6
                    Exit Sub
                End If
            End If
            If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) = -1 Then
                If convcol.ConvertToString(scolor3) <> "Control" Then
                    e.CellStyle.ForeColor = scolor3
                    Exit Sub
                End If
            End If
            '   If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) > -2 Then
            '   If convcol.ConvertToString(scolor3) <> "Control" Then
            '  e.CellStyle.ForeColor = scolor3
            ' Exit Sub
            'End If
            'End If

            convcol = Nothing

        Catch ex As Exception
            '    MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        AddHandler ImgCombo.SelectedValueChanged, AddressOf imgcombo_SelectedIndexChanged_1
        Init_Pages()
        Me.lblzensur1.Text = MyTxt.gettext(22009)
        Me.lblzensur2.Text = MyTxt.gettext(22009)
        Me.lblzensur3.Text = MyTxt.gettext(22009)
        Me.lblzensur4.Text = MyTxt.gettext(22009)
        Me.lblzensur5.Text = MyTxt.gettext(22009)
        Me.lblzensur6.Text = MyTxt.gettext(22009)

        'SHU 2004-12-07 Lasche Dokumentstatus als Default anzeigen
        Me.TabControl1.SelectedIndex = 1

        refresh_list()
        If Me.DoRefresh Then Refresh_All(True)
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.Button2, Globals.MyTxt.gettext(22003))
        ttip.SetToolTip(Me.btnPartnersuche, Globals.MyTxt.gettext(22004))
        ttip.SetToolTip(Me.txtbcknr, Globals.MyTxt.gettext(22005))
        ttip.SetToolTip(Me.cbProfile, Globals.MyTxt.gettext(22006))
        If Me.LblSearch.Visible = False Then
            Me.Label20.Visible = False
            Me.txtbcknr.Visible = False
            Me.Button2.Visible = False
        End If

        If Globals.Bearbeitung_Problemdokumente = True Then
            Me.bntNewDoc.Enabled = False
            Me.ToolBarButton2.Enabled = False
            Me.cbProfile.Visible = False
            Me.LblSearch.Visible = False
            Me.txtnrpar00.Visible = False
            Me.btnPartnersuche.Visible = False
            Me.Button1.Visible = False
            Me.MenuItem29.Enabled = False
            Me.MenuItem31.Enabled = False
            Me.MenuItem15.Enabled = False
            Me.MenuItem12.Enabled = False
            Me.BtnHelp.Visible = True
            Me.Button9.Visible = False
        Else
            Me.bntNewDoc.Enabled = True
            Me.ToolBarButton2.Enabled = True
            Me.cbProfile.Visible = True
            Me.LblSearch.Visible = True
            Me.txtnrpar00.Visible = True
            Me.btnPartnersuche.Visible = True
            If Me.ImgCombo.Visible = False Then
                Me.txtnrpar00.Visible = False
                Me.btnPartnersuche.Visible = False
                Me.Button1.Visible = False
            End If

            Me.MenuItem29.Enabled = True
            Me.MenuItem31.Enabled = True
            Me.MenuItem15.Enabled = True
            Me.MenuItem12.Enabled = True
        End If
        Create_Search_Menu()

        'Buttons gemäss Profil richtig setzten
        SetDataFromProfil()

        m_ColdListWidthOrg = Me.Splitter2.SplitPosition
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        '===============================================================================
        'Description: Dynamische Datenherkuft
        'Input      : Typ
        'Output     : Datatable
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Trefferliste::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.GetNode Method

Private Function GetNode( _
   ByVal text As String, _
   ByVal parentCollection As TreeNodeCollection _
) As TreeNode

Parameters

text
Required.
parentCollection
Required.

Source code

[Visual Basic]
    Private Function GetNode(ByVal text As String, ByVal parentCollection As TreeNodeCollection) As TreeNode
        Dim ret As TreeNode
        Dim child As TreeNode

        For Each child In parentCollection 'step through the parentcollection
            If child.Tag = text Then
                ret = child
            ElseIf child.GetNodeCount(False) > 0 Then ' if there is child items then call this function recursively
                ret = GetNode(text, child.Nodes)
            End If
            If Not ret Is Nothing Then Exit For 'if something was found, exit out of the for loop

        Next

        Return ret
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles InfoMeldungList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles InfoMeldungList.FetchRowStyle
        If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Init_Pages Method

Private Sub Init_Pages()

Source code

[Visual Basic]
    Private Sub Init_Pages()
        Me.PageDirection = 0
        Me.tpagemin(0) = 0
        Me.tpagemax(0) = 999999999
        Me.tpagemin(1) = 0
        Me.tpagemax(1) = 999999999
        Dim i As Integer
        For i = 0 To 99
            Me.tpagemax(i) = 0
            Me.tpagemin(i) = 0
        Next
        Me.CurrentPage = 1
        Me.maxpage = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmTrefferliste))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines8 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines9 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines10 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnExit = New System.Windows.Forms.ToolBarButton()
        Me.BtnPrint = New System.Windows.Forms.ToolBarButton()
        Me.bntNewDoc = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.mnu_gelversant = New System.Windows.Forms.ToolBarButton()
        Me.mnu_gelabgesch = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.BtnProfil = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.MnuProfil = New System.Windows.Forms.ContextMenu()
        Me.txtnrpar00 = New System.Windows.Forms.TextBox()
        Me.MnuSearch = New System.Windows.Forms.ContextMenu()
        Me.MenuItemPartnersuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemVVSuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemValorSuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemISINSUche = New System.Windows.Forms.MenuItem()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.pnlSearch = New System.Windows.Forms.Panel()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.tvstruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem46 = New System.Windows.Forms.MenuItem()
        Me.MenuItem52 = New System.Windows.Forms.MenuItem()
        Me.mnuFreitextSuche = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.lblpageno = New System.Windows.Forms.Label()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.ImageList3_Sik = New System.Windows.Forms.ImageList(Me.components)
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.MnuAbgeschlossen = New System.Windows.Forms.MenuItem()
        Me.MnuABDokLoeschen = New System.Windows.Forms.MenuItem()
        Me.MnuABDokAufheben = New System.Windows.Forms.MenuItem()
        Me.MnuDokumentreaktivieren = New System.Windows.Forms.MenuItem()
        Me.MenuItem36 = New System.Windows.Forms.MenuItem()
        Me.MenuItem33 = New System.Windows.Forms.MenuItem()
        Me.MenuItem34 = New System.Windows.Forms.MenuItem()
        Me.MenuItem35 = New System.Windows.Forms.MenuItem()
        Me.MenuItem44 = New System.Windows.Forms.MenuItem()
        Me.MenuItem49 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem29 = New System.Windows.Forms.MenuItem()
        Me.MenuItem31 = New System.Windows.Forms.MenuItem()
        Me.mnuDokKopieren = New System.Windows.Forms.MenuItem()
        Me.MenuItem53 = New System.Windows.Forms.MenuItem()
        Me.MenuItem30 = New System.Windows.Forms.MenuItem()
        Me.MenuItem23 = New System.Windows.Forms.MenuItem()
        Me.mnuSendMessage = New System.Windows.Forms.MenuItem()
        Me.mnuDokTypInfo = New System.Windows.Forms.MenuItem()
        Me.MenuItem56 = New System.Windows.Forms.MenuItem()
        Me.MenuItem42 = New System.Windows.Forms.MenuItem()
        Me.MenuItem45 = New System.Windows.Forms.MenuItem()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem43 = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPageAllgemein = New System.Windows.Forms.TabPage()
        Me.ContextMenuAllgemein = New System.Windows.Forms.ContextMenu()
        Me.mnuDruckAllgemein = New System.Windows.Forms.MenuItem()
        Me.pnlzensur1 = New System.Windows.Forms.Panel()
        Me.lblzensur1 = New System.Windows.Forms.Label()
        Me.TextBox18 = New System.Windows.Forms.TextBox()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.TextBox14 = New System.Windows.Forms.TextBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.TextBox13 = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.TextBox12 = New System.Windows.Forms.TextBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.TextBox11 = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TabPageStatus = New System.Windows.Forms.TabPage()
        Me.Statuslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu9 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem32 = New System.Windows.Forms.MenuItem()
        Me.mnuDruckDokStatus = New System.Windows.Forms.MenuItem()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.RBStatusHistory = New System.Windows.Forms.RadioButton()
        Me.RBStatusAktuell = New System.Windows.Forms.RadioButton()
        Me.TabPageDokumentwerte = New System.Windows.Forms.TabPage()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.pnlzensur2 = New System.Windows.Forms.Panel()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.lblzensur2 = New System.Windows.Forms.Label()
        Me.ColdListDokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem28 = New System.Windows.Forms.MenuItem()
        Me.MenuItem38 = New System.Windows.Forms.MenuItem()
        Me.MenuItem40 = New System.Windows.Forms.MenuItem()
        Me.MenuItem41 = New System.Windows.Forms.MenuItem()
        Me.MenuItem39 = New System.Windows.Forms.MenuItem()
        Me.MenuItem50 = New System.Windows.Forms.MenuItem()
        Me.MenuItem51 = New System.Windows.Forms.MenuItem()
        Me.mnuDruckDokumentwerte = New System.Windows.Forms.MenuItem()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.TextBox17 = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.TextBox16 = New System.Windows.Forms.TextBox()
        Me.TextBox15 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.TabPageZuordnung = New System.Windows.Forms.TabPage()
        Me.pnlzensur4 = New System.Windows.Forms.Panel()
        Me.lblzensur4 = New System.Windows.Forms.Label()
        Me.Zuordnungslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem47 = New System.Windows.Forms.MenuItem()
        Me.MenuItem48 = New System.Windows.Forms.MenuItem()
        Me.mnuDruckZuordnung = New System.Windows.Forms.MenuItem()
        Me.TabPageNotizen = New System.Windows.Forms.TabPage()
        Me.pnlzensur5 = New System.Windows.Forms.Panel()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.lblzensur5 = New System.Windows.Forms.Label()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.MnuNotizanzeigen = New System.Windows.Forms.MenuItem()
        Me.mnuDruckNotizen = New System.Windows.Forms.MenuItem()
        Me.TabPageInfomeldung = New System.Windows.Forms.TabPage()
        Me.pnlzensur3 = New System.Windows.Forms.Panel()
        Me.lblzensur3 = New System.Windows.Forms.Label()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenuInfoMeldung = New System.Windows.Forms.ContextMenu()
        Me.mnuDruckInfoMeldung = New System.Windows.Forms.MenuItem()
        Me.TabPageBerechtigung = New System.Windows.Forms.TabPage()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenuBerechtigung = New System.Windows.Forms.ContextMenu()
        Me.mnuDruckBerechtigung = New System.Windows.Forms.MenuItem()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.pnlzensur6 = New System.Windows.Forms.Panel()
        Me.lblzensur6 = New System.Windows.Forms.Label()
        Me.ErsetzteDokumenteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu10 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.mnuDruckErsetzte = New System.Windows.Forms.MenuItem()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.cbProfile = New System.Windows.Forms.ComboBox()
        Me.LblSearch = New System.Windows.Forms.Label()
        Me.btnPartnersuche = New System.Windows.Forms.Button()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokumentSelect = New System.Windows.Forms.MenuItem()
        Me.MenuItem37 = New System.Windows.Forms.MenuItem()
        Me.MnuClose = New System.Windows.Forms.MenuItem()
        Me.ImageList4 = New System.Windows.Forms.ImageList(Me.components)
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.cmitprofil = New System.Windows.Forms.CheckBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.txtbcknr = New System.Windows.Forms.TextBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button9 = New System.Windows.Forms.Button()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.mnublkunde = New System.Windows.Forms.MenuItem()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.pnlSearch.SuspendLayout()
        Me.Panel4.SuspendLayout()
        Me.Panel3.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPageAllgemein.SuspendLayout()
        Me.pnlzensur1.SuspendLayout()
        Me.TabPageStatus.SuspendLayout()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        Me.TabPageDokumentwerte.SuspendLayout()
        Me.TabControl2.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage3.SuspendLayout()
        Me.TabPageZuordnung.SuspendLayout()
        Me.pnlzensur4.SuspendLayout()
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageNotizen.SuspendLayout()
        Me.pnlzensur5.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageInfomeldung.SuspendLayout()
        Me.pnlzensur3.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageBerechtigung.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        Me.pnlzensur6.SuspendLayout()
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnExit, Me.BtnPrint, Me.bntNewDoc, Me.ToolBarButton2, Me.ToolBarButton4, Me.ToolBarButton3, Me.mnu_gelversant, Me.mnu_gelabgesch, Me.ToolBarButton7, Me.BtnProfil, Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(984, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnExit
        '
        Me.btnExit.ImageIndex = 0
        Me.btnExit.ToolTipText = "Trefferliste schliessen"
        '
        'BtnPrint
        '
        Me.BtnPrint.ImageIndex = 1
        Me.BtnPrint.ToolTipText = "Trefferliste drucken"
        '
        'bntNewDoc
        '
        Me.bntNewDoc.ImageIndex = 2
        Me.bntNewDoc.ToolTipText = "Neues Dokument erstellen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 4
        Me.ToolBarButton2.ToolTipText = "Dokument-Favoriten anzeigen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 7
        Me.ToolBarButton3.ToolTipText = "Partnerstruktur aktualisieren"
        '
        'mnu_gelversant
        '
        Me.mnu_gelversant.ImageIndex = 14
        Me.mnu_gelversant.Style = System.Windows.Forms.ToolBarButtonStyle.ToggleButton
        '
        'mnu_gelabgesch
        '
        Me.mnu_gelabgesch.ImageIndex = 15
        Me.mnu_gelabgesch.Style = System.Windows.Forms.ToolBarButtonStyle.ToggleButton
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'BtnProfil
        '
        Me.BtnProfil.ImageIndex = 3
        Me.BtnProfil.ToolTipText = "Profil bearbeiten"
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        Me.MenuItem1.Text = "&Trefferliste"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Schliessen"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "profil", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_profil_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection3
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_profil_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection3
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tg302011;initial catalog=edoka_parameter;persist security info=False;" & _
        "user id=sa;workstation id=TG602645;packet size=4096"
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'txtnrpar00
        '
        Me.txtnrpar00.ContextMenu = Me.MnuSearch
        Me.txtnrpar00.Location = New System.Drawing.Point(444, 3)
        Me.txtnrpar00.Name = "txtnrpar00"
        Me.txtnrpar00.Size = New System.Drawing.Size(112, 20)
        Me.txtnrpar00.TabIndex = 7
        Me.txtnrpar00.Text = ""
        '
        'MnuSearch
        '
        Me.MnuSearch.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItemPartnersuche, Me.MenuItemVVSuche, Me.MenuItemValorSuche, Me.MenuItemISINSUche})
        '
        'MenuItemPartnersuche
        '
        Me.MenuItemPartnersuche.Index = 0
        Me.MenuItemPartnersuche.Text = "Partner"
        '
        'MenuItemVVSuche
        '
        Me.MenuItemVVSuche.Index = 1
        Me.MenuItemVVSuche.Text = "VV-Nr."
        '
        'MenuItemValorSuche
        '
        Me.MenuItemValorSuche.Index = 2
        Me.MenuItemValorSuche.Text = "Valor"
        '
        'MenuItemISINSUche
        '
        Me.MenuItemISINSUche.Index = 3
        Me.MenuItemISINSUche.Text = "ISIN"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlSearch})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(288, 524)
        Me.Panel1.TabIndex = 8
        '
        'pnlSearch
        '
        Me.pnlSearch.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel4, Me.Panel3})
        Me.pnlSearch.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlSearch.Name = "pnlSearch"
        Me.pnlSearch.Size = New System.Drawing.Size(288, 524)
        Me.pnlSearch.TabIndex = 0
        '
        'Panel4
        '
        Me.Panel4.Controls.AddRange(New System.Windows.Forms.Control() {Me.tvstruktur})
        Me.Panel4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(288, 500)
        Me.Panel4.TabIndex = 1
        '
        'tvstruktur
        '
        Me.tvstruktur.ContextMenu = Me.ContextMenu2
        Me.tvstruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.tvstruktur.ImageList = Me.ImageList3
        Me.tvstruktur.Name = "tvstruktur"
        Me.tvstruktur.Size = New System.Drawing.Size(288, 500)
        Me.tvstruktur.TabIndex = 4
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7, Me.MenuItem15, Me.MenuItem12, Me.MenuItem8, Me.MenuItem9, Me.MenuItem19, Me.MenuItem22, Me.MenuItem20, Me.MenuItem10, Me.MenuItem11, Me.MenuItem46, Me.MenuItem52, Me.mnuFreitextSuche, Me.mnublkunde})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Shortcut = System.Windows.Forms.Shortcut.F6
        Me.MenuItem7.Text = "Partnerdossier öffnen"
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 1
        Me.MenuItem15.Text = "&Dokument für gewählten Partner erstellen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 2
        Me.MenuItem12.Text = "Dokument erstellen"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 3
        Me.MenuItem8.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem8.Text = "Aktualisieren"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 4
        Me.MenuItem9.Text = "-"
        '
        'MenuItem19
        '
        Me.MenuItem19.Index = 5
        Me.MenuItem19.Shortcut = System.Windows.Forms.Shortcut.CtrlA
        Me.MenuItem19.Text = "Alle Dokumente des Partners"
        '
        'MenuItem22
        '
        Me.MenuItem22.Index = 6
        Me.MenuItem22.Text = "&Partnerdetails anzeigen"
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 7
        Me.MenuItem20.Text = "-"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 8
        Me.MenuItem10.Shortcut = System.Windows.Forms.Shortcut.F3
        Me.MenuItem10.Text = "Knoten öffnen"
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 9
        Me.MenuItem11.Shortcut = System.Windows.Forms.Shortcut.F4
        Me.MenuItem11.Text = "Knoten schliessen"
        '
        'MenuItem46
        '
        Me.MenuItem46.Index = 10
        Me.MenuItem46.Text = "E-Mail senden"
        '
        'MenuItem52
        '
        Me.MenuItem52.Index = 11
        Me.MenuItem52.Text = "-"
        '
        'mnuFreitextSuche
        '
        Me.mnuFreitextSuche.Index = 12
        Me.mnuFreitextSuche.Text = "Freitextsuche"
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblpageno, Me.Button8, Me.Button7, Me.Button6, Me.Button5, Me.Button4, Me.Button3})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel3.Location = New System.Drawing.Point(0, 500)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(288, 24)
        Me.Panel3.TabIndex = 0
        '
        'lblpageno
        '
        Me.lblpageno.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.lblpageno.Location = New System.Drawing.Point(128, 4)
        Me.lblpageno.Name = "lblpageno"
        Me.lblpageno.Size = New System.Drawing.Size(40, 16)
        Me.lblpageno.TabIndex = 6
        Me.lblpageno.Text = "1"
        Me.lblpageno.TextAlign = System.Drawing.ContentAlignment.TopCenter
        '
        'Button8
        '
        Me.Button8.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button8.Location = New System.Drawing.Point(256, 0)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(32, 22)
        Me.Button8.TabIndex = 5
        Me.Button8.Text = "Button8"
        Me.Button8.Visible = False
        '
        'Button7
        '
        Me.Button7.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button7.Location = New System.Drawing.Point(256, -4)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(32, 22)
        Me.Button7.TabIndex = 4
        Me.Button7.Text = "Button7"
        Me.Button7.Visible = False
        '
        'Button6
        '
        Me.Button6.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button6.Image = CType(resources.GetObject("Button6.Image"), System.Drawing.Bitmap)
        Me.Button6.Location = New System.Drawing.Point(168, 4)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(56, 16)
        Me.Button6.TabIndex = 3
        '
        'Button5
        '
        Me.Button5.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button5.Image = CType(resources.GetObject("Button5.Image"), System.Drawing.Bitmap)
        Me.Button5.Location = New System.Drawing.Point(72, 4)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(56, 16)
        Me.Button5.TabIndex = 2
        '
        'Button4
        '
        Me.Button4.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(224, 4)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(48, 16)
        Me.Button4.TabIndex = 1
        '
        'Button3
        '
        Me.Button3.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button3.Image = CType(resources.GetObject("Button3.Image"), System.Drawing.Bitmap)
        Me.Button3.Location = New System.Drawing.Point(16, 4)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(56, 16)
        Me.Button3.TabIndex = 0
        '
        'ImageList3_Sik
        '
        Me.ImageList3_Sik.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3_Sik.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3_Sik.ImageStream = CType(resources.GetObject("ImageList3_Sik.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3_Sik.TransparentColor = System.Drawing.Color.Transparent
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(288, 25)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 524)
        Me.Splitter1.TabIndex = 9
        Me.Splitter1.TabStop = False
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4, Me.MenuItem3, Me.MenuItem16, Me.MnuAbgeschlossen, Me.MenuItem36, Me.MenuItem33, Me.MenuItem44, Me.MenuItem49, Me.MenuItem5, Me.MenuItem6, Me.MenuItem21, Me.MenuItem13, Me.MenuItem29, Me.MenuItem31, Me.mnuDokKopieren, Me.MenuItem53, Me.MenuItem30, Me.MenuItem23, Me.mnuSendMessage, Me.mnuDokTypInfo, Me.MenuItem56, Me.MenuItem42, Me.MenuItem45, Me.MenuItem14})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "Dokument &anzeigen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Text = "Dokument &bearbeiten"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 2
        Me.MenuItem16.Text = "Dokument &löschen"
        '
        'MnuAbgeschlossen
        '
        Me.MnuAbgeschlossen.Index = 3
        Me.MnuAbgeschlossen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuABDokLoeschen, Me.MnuABDokAufheben, Me.MnuDokumentreaktivieren})
        Me.MnuAbgeschlossen.Text = "&Abgeschlossenes Dokument"
        '
        'MnuABDokLoeschen
        '
        Me.MnuABDokLoeschen.Index = 0
        Me.MnuABDokLoeschen.Text = "Löschen"
        '
        'MnuABDokAufheben
        '
        Me.MnuABDokAufheben.Index = 1
        Me.MnuABDokAufheben.Text = "Aufheben"
        '
        'MnuDokumentreaktivieren
        '
        Me.MnuDokumentreaktivieren.Index = 2
        Me.MnuDokumentreaktivieren.Text = "Dokument reaktivieren"
        '
        'MenuItem36
        '
        Me.MenuItem36.Index = 4
        Me.MenuItem36.Text = "-"
        '
        'MenuItem33
        '
        Me.MenuItem33.Index = 5
        Me.MenuItem33.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem34, Me.MenuItem35})
        Me.MenuItem33.Text = "Dokument &drucken"
        '
        'MenuItem34
        '
        Me.MenuItem34.Index = 0
        Me.MenuItem34.Text = "&Office-Dokument drucken"
        '
        'MenuItem35
        '
        Me.MenuItem35.Index = 1
        Me.MenuItem35.Text = "&Cold-Dokument drucken"
        '
        'MenuItem44
        '
        Me.MenuItem44.Index = 6
        Me.MenuItem44.Text = "Office-Dokument anzeigen"
        '
        'MenuItem49
        '
        Me.MenuItem49.Index = 7
        Me.MenuItem49.Text = "&Alle Dokumente des Geschäftsfalles anzeigen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 8
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 9
        Me.MenuItem6.Text = "&Status/Verantwortlicher wechseln"
        '
        'MenuItem21
        '
        Me.MenuItem21.Index = 10
        Me.MenuItem21.Text = "Dokument&informationen bearbeiten"
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 11
        Me.MenuItem13.Text = "-"
        '
        'MenuItem29
        '
        Me.MenuItem29.Index = 12
        Me.MenuItem29.Text = "Dokument für gewählten Partner &erstellen"
        '
        'MenuItem31
        '
        Me.MenuItem31.Index = 13
        Me.MenuItem31.Text = "D&okument erstellen"
        '
        'mnuDokKopieren
        '
        Me.mnuDokKopieren.Index = 14
        Me.mnuDokKopieren.Text = "Dokument kopieren"
        '
        'MenuItem53
        '
        Me.MenuItem53.Index = 15
        Me.MenuItem53.Text = "-"
        '
        'MenuItem30
        '
        Me.MenuItem30.Index = 16
        Me.MenuItem30.Text = "-"
        Me.MenuItem30.Visible = False
        '
        'MenuItem23
        '
        Me.MenuItem23.Index = 17
        Me.MenuItem23.Text = "-"
        Me.MenuItem23.Visible = False
        '
        'mnuSendMessage
        '
        Me.mnuSendMessage.Index = 18
        Me.mnuSendMessage.Text = "EDOKA-&Meldung versenden"
        '
        'mnuDokTypInfo
        '
        Me.mnuDokTypInfo.Index = 19
        Me.mnuDokTypInfo.Text = "Information zur Dokumentvorlage"
        '
        'MenuItem56
        '
        Me.MenuItem56.Index = 20
        Me.MenuItem56.Text = "-"
        Me.MenuItem56.Visible = False
        '
        'MenuItem42
        '
        Me.MenuItem42.Index = 21
        Me.MenuItem42.Text = "-"
        '
        'MenuItem45
        '
        Me.MenuItem45.Index = 22
        Me.MenuItem45.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem24, Me.MenuItem25, Me.MenuItem43})
        Me.MenuItem45.Text = "Spalten-Definitionen"
        '
        'MenuItem24
        '
        Me.MenuItem24.Index = 0
        Me.MenuItem24.Text = "Spalten-Selektion"
        '
        'MenuItem25
        '
        Me.MenuItem25.Index = 1
        Me.MenuItem25.Text = "Spalten-Darstellung sichern"
        '
        'MenuItem43
        '
        Me.MenuItem43.Index = 2
        Me.MenuItem43.Text = "Standard-Spalten-Darstellung"
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 23
        Me.MenuItem14.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem14.Text = "Aktualisieren"
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPageAllgemein, Me.TabPageStatus, Me.TabPageDokumentwerte, Me.TabPageZuordnung, Me.TabPageNotizen, Me.TabPageInfomeldung, Me.TabPageBerechtigung, Me.TabPage2})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TabControl1.Location = New System.Drawing.Point(291, 301)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(693, 248)
        Me.TabControl1.TabIndex = 12
        '
        'TabPageAllgemein
        '
        Me.TabPageAllgemein.BackColor = System.Drawing.Color.Transparent
        Me.TabPageAllgemein.ContextMenu = Me.ContextMenuAllgemein
        Me.TabPageAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur1, Me.TextBox18, Me.Label19, Me.TextBox14, Me.Label15, Me.TextBox13, Me.Label14, Me.TextBox12, Me.Label12, Me.TextBox11, Me.Label11, Me.TextBox10, Me.Label10, Me.TextBox9, Me.Label9, Me.TextBox8, Me.Label8, Me.TextBox7, Me.Label7, Me.TextBox6, Me.Label6, Me.TextBox5, Me.Label5, Me.TextBox4, Me.Label4, Me.TextBox3, Me.Label3, Me.TextBox2, Me.Label2, Me.TextBox1, Me.Label1})
        Me.TabPageAllgemein.Location = New System.Drawing.Point(4, 22)
        Me.TabPageAllgemein.Name = "TabPageAllgemein"
        Me.TabPageAllgemein.Size = New System.Drawing.Size(685, 222)
        Me.TabPageAllgemein.TabIndex = 0
        Me.TabPageAllgemein.Text = "Allgemein"
        '
        'ContextMenuAllgemein
        '
        Me.ContextMenuAllgemein.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDruckAllgemein})
        '
        'mnuDruckAllgemein
        '
        Me.mnuDruckAllgemein.Index = 0
        Me.mnuDruckAllgemein.Text = "Allgemeine Daten drucken"
        '
        'pnlzensur1
        '
        Me.pnlzensur1.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur1})
        Me.pnlzensur1.Location = New System.Drawing.Point(96, 184)
        Me.pnlzensur1.Name = "pnlzensur1"
        Me.pnlzensur1.Size = New System.Drawing.Size(512, 32)
        Me.pnlzensur1.TabIndex = 30
        '
        'lblzensur1
        '
        Me.lblzensur1.Location = New System.Drawing.Point(0, 8)
        Me.lblzensur1.Name = "lblzensur1"
        Me.lblzensur1.Size = New System.Drawing.Size(650, 23)
        Me.lblzensur1.TabIndex = 0
        Me.lblzensur1.Text = "Label21"
        '
        'TextBox18
        '
        Me.TextBox18.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox18.ForeColor = System.Drawing.Color.Black
        Me.TextBox18.Location = New System.Drawing.Point(96, 64)
        Me.TextBox18.Name = "TextBox18"
        Me.TextBox18.ReadOnly = True
        Me.TextBox18.Size = New System.Drawing.Size(208, 20)
        Me.TextBox18.TabIndex = 29
        Me.TextBox18.Text = ""
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(8, 64)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(88, 16)
        Me.Label19.TabIndex = 28
        Me.Label19.Text = "Barcodekleber"
        '
        'TextBox14
        '
        Me.TextBox14.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox14.ForeColor = System.Drawing.Color.Black
        Me.TextBox14.Location = New System.Drawing.Point(392, 160)
        Me.TextBox14.Name = "TextBox14"
        Me.TextBox14.ReadOnly = True
        Me.TextBox14.Size = New System.Drawing.Size(208, 20)
        Me.TextBox14.TabIndex = 27
        Me.TextBox14.Text = ""
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(312, 160)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(80, 23)
        Me.Label15.TabIndex = 26
        Me.Label15.Text = "Termin"
        '
        'TextBox13
        '
        Me.TextBox13.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox13.ForeColor = System.Drawing.Color.Black
        Me.TextBox13.Location = New System.Drawing.Point(96, 160)
        Me.TextBox13.Name = "TextBox13"
        Me.TextBox13.ReadOnly = True
        Me.TextBox13.Size = New System.Drawing.Size(208, 20)
        Me.TextBox13.TabIndex = 25
        Me.TextBox13.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 160)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(88, 23)
        Me.Label14.TabIndex = 24
        Me.Label14.Text = "Verantwortlich"
        '
        'TextBox12
        '
        Me.TextBox12.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox12.ForeColor = System.Drawing.Color.Black
        Me.TextBox12.Location = New System.Drawing.Point(96, 192)
        Me.TextBox12.Multiline = True
        Me.TextBox12.Name = "TextBox12"
        Me.TextBox12.ReadOnly = True
        Me.TextBox12.Size = New System.Drawing.Size(504, 24)
        Me.TextBox12.TabIndex = 23
        Me.TextBox12.Text = ""
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 192)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(88, 23)
        Me.Label12.TabIndex = 22
        Me.Label12.Text = "Bemerkung"
        '
        'TextBox11
        '
        Me.TextBox11.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox11.ForeColor = System.Drawing.Color.Black
        Me.TextBox11.Location = New System.Drawing.Point(96, 136)
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.ReadOnly = True
        Me.TextBox11.Size = New System.Drawing.Size(208, 20)
        Me.TextBox11.TabIndex = 21
        Me.TextBox11.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 136)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(88, 23)
        Me.Label11.TabIndex = 20
        Me.Label11.Text = "Dokumentstatus"
        '
        'TextBox10
        '
        Me.TextBox10.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox10.ForeColor = System.Drawing.Color.Black
        Me.TextBox10.Location = New System.Drawing.Point(392, 88)
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.ReadOnly = True
        Me.TextBox10.Size = New System.Drawing.Size(208, 20)
        Me.TextBox10.TabIndex = 19
        Me.TextBox10.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(312, 88)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 18
        Me.Label10.Text = "Mutiert durch"
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox9.ForeColor = System.Drawing.Color.Black
        Me.TextBox9.Location = New System.Drawing.Point(392, 64)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(208, 20)
        Me.TextBox9.TabIndex = 17
        Me.TextBox9.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(312, 64)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(80, 23)
        Me.Label9.TabIndex = 16
        Me.Label9.Text = "Mutiert am"
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox8.ForeColor = System.Drawing.Color.Black
        Me.TextBox8.Location = New System.Drawing.Point(392, 136)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(208, 20)
        Me.TextBox8.TabIndex = 15
        Me.TextBox8.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(312, 136)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(80, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Gesperrt durch"
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox7.ForeColor = System.Drawing.Color.Black
        Me.TextBox7.Location = New System.Drawing.Point(392, 112)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(208, 20)
        Me.TextBox7.TabIndex = 13
        Me.TextBox7.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(312, 112)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(80, 23)
        Me.Label7.TabIndex = 12
        Me.Label7.Text = "Gesperrt am"
        '
        'TextBox6
        '
        Me.TextBox6.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox6.ForeColor = System.Drawing.Color.Black
        Me.TextBox6.Location = New System.Drawing.Point(392, 40)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.ReadOnly = True
        Me.TextBox6.Size = New System.Drawing.Size(208, 20)
        Me.TextBox6.TabIndex = 11
        Me.TextBox6.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(312, 40)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 10
        Me.Label6.Text = "Erstellt durch"
        '
        'TextBox5
        '
        Me.TextBox5.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox5.ForeColor = System.Drawing.Color.Black
        Me.TextBox5.Location = New System.Drawing.Point(392, 16)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.ReadOnly = True
        Me.TextBox5.Size = New System.Drawing.Size(208, 20)
        Me.TextBox5.TabIndex = 9
        Me.TextBox5.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(312, 16)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 23)
        Me.Label5.TabIndex = 8
        Me.Label5.Text = "Erstellt am"
        '
        'TextBox4
        '
        Me.TextBox4.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox4.ForeColor = System.Drawing.Color.Black
        Me.TextBox4.Location = New System.Drawing.Point(96, 112)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(208, 20)
        Me.TextBox4.TabIndex = 7
        Me.TextBox4.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 112)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(88, 23)
        Me.Label4.TabIndex = 6
        Me.Label4.Text = "Bezeichnung"
        '
        'TextBox3
        '
        Me.TextBox3.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox3.ForeColor = System.Drawing.Color.Black
        Me.TextBox3.Location = New System.Drawing.Point(96, 88)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.ReadOnly = True
        Me.TextBox3.Size = New System.Drawing.Size(208, 20)
        Me.TextBox3.TabIndex = 5
        Me.TextBox3.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 88)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(88, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Dokumentart"
        '
        'TextBox2
        '
        Me.TextBox2.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox2.ForeColor = System.Drawing.Color.Black
        Me.TextBox2.Location = New System.Drawing.Point(96, 16)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.ReadOnly = True
        Me.TextBox2.Size = New System.Drawing.Size(208, 20)
        Me.TextBox2.TabIndex = 3
        Me.TextBox2.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(88, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Partner"
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox1.ForeColor = System.Drawing.Color.Black
        Me.TextBox1.Location = New System.Drawing.Point(96, 40)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(208, 20)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Dokument-ID"
        '
        'TabPageStatus
        '
        Me.TabPageStatus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Statuslist, Me.Panel2})
        Me.TabPageStatus.Location = New System.Drawing.Point(4, 22)
        Me.TabPageStatus.Name = "TabPageStatus"
        Me.TabPageStatus.Size = New System.Drawing.Size(685, 222)
        Me.TabPageStatus.TabIndex = 1
        Me.TabPageStatus.Text = "Dokumentstatus"
        '
        'Statuslist
        '
        Me.Statuslist.AllowArrows = False
        Me.Statuslist.AllowFilter = True
        Me.Statuslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Statuslist.AllowSort = True
        Me.Statuslist.BackColor = System.Drawing.Color.White
        Me.Statuslist.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.Statuslist.CaptionHeight = 17
        Me.Statuslist.CollapseColor = System.Drawing.Color.Transparent
        Me.Statuslist.ContextMenu = Me.ContextMenu9
        Me.Statuslist.DataChanged = False
        Me.Statuslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Statuslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Statuslist.ExpandColor = System.Drawing.Color.Transparent
        Me.Statuslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Statuslist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Statuslist.Location = New System.Drawing.Point(0, 32)
        Me.Statuslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Statuslist.Name = "Statuslist"
        Me.Statuslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Statuslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Statuslist.PreviewInfo.ZoomFactor = 75
        Me.Statuslist.PrintInfo.ShowOptionsDialog = False
        Me.Statuslist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Statuslist.RowDivider = GridLines1
        Me.Statuslist.RowHeight = 15
        Me.Statuslist.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.Statuslist.ScrollTips = False
        Me.Statuslist.Size = New System.Drawing.Size(685, 190)
        Me.Statuslist.TabIndex = 3
        Me.Statuslist.Text = "C1TrueDBGrid1"
        Me.Statuslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{BackColor:White;}HighlightRow{ForeColor:HighlightText;BackColor:Highl" & _
        "ight;}Style9{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignV" & _
        "ert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}St" & _
        "yle8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles" & _
        "><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaption" & _
        "Height=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelect" & _
        "orWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""" & _
        "1""><ClientRect>0, 0, 685, 190</ClientRect><BorderSide>0</BorderSide><CaptionStyl" & _
        "e parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><Eve" & _
        "nRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""" & _
        "Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group""" & _
        " me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle " & _
        "parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4""" & _
        " /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Recor" & _
        "dSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style " & _
        "parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedSty" & _
        "les><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style " & _
        "parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style par" & _
        "ent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style pare" & _
        "nt=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style pare" & _
        "nt=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""H" & _
        "eading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style par" & _
        "ent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1" & _
        "</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 685, 190</ClientArea></Blob>"
        '
        'ContextMenu9
        '
        Me.ContextMenu9.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem32, Me.mnuDruckDokStatus})
        '
        'MenuItem32
        '
        Me.MenuItem32.Index = 0
        Me.MenuItem32.Text = "Status setzen"
        '
        'mnuDruckDokStatus
        '
        Me.mnuDruckDokStatus.Index = 1
        Me.mnuDruckDokStatus.Text = "Dokumentstatus drucken"
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBStatusHistory, Me.RBStatusAktuell})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(685, 32)
        Me.Panel2.TabIndex = 1
        '
        'RBStatusHistory
        '
        Me.RBStatusHistory.Location = New System.Drawing.Point(88, 6)
        Me.RBStatusHistory.Name = "RBStatusHistory"
        Me.RBStatusHistory.Size = New System.Drawing.Size(64, 24)
        Me.RBStatusHistory.TabIndex = 4
        Me.RBStatusHistory.Text = "History"
        '
        'RBStatusAktuell
        '
        Me.RBStatusAktuell.Checked = True
        Me.RBStatusAktuell.Location = New System.Drawing.Point(16, 6)
        Me.RBStatusAktuell.Name = "RBStatusAktuell"
        Me.RBStatusAktuell.Size = New System.Drawing.Size(56, 24)
        Me.RBStatusAktuell.TabIndex = 3
        Me.RBStatusAktuell.TabStop = True
        Me.RBStatusAktuell.Text = "Aktuell"
        '
        'TabPageDokumentwerte
        '
        Me.TabPageDokumentwerte.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl2})
        Me.TabPageDokumentwerte.Location = New System.Drawing.Point(4, 22)
        Me.TabPageDokumentwerte.Name = "TabPageDokumentwerte"
        Me.TabPageDokumentwerte.Size = New System.Drawing.Size(685, 222)
        Me.TabPageDokumentwerte.TabIndex = 2
        Me.TabPageDokumentwerte.Text = "Dokumentwerte"
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage3})
        Me.TabControl2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(685, 222)
        Me.TabControl2.TabIndex = 0
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur2, Me.ColdList, Me.Splitter2, Me.lblzensur2, Me.ColdListDokumente})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(677, 196)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Dokumentarchivierung"
        '
        'pnlzensur2
        '
        Me.pnlzensur2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur2.Location = New System.Drawing.Point(339, 0)
        Me.pnlzensur2.Name = "pnlzensur2"
        Me.pnlzensur2.Size = New System.Drawing.Size(338, 196)
        Me.pnlzensur2.TabIndex = 19
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AllowUpdateOnBlur = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(339, 0)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines2
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(338, 196)
        Me.ColdList.TabIndex = 18
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 334, 192</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 334, 192</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(336, 0)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(3, 196)
        Me.Splitter2.TabIndex = 17
        Me.Splitter2.TabStop = False
        '
        'lblzensur2
        '
        Me.lblzensur2.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur2.Name = "lblzensur2"
        Me.lblzensur2.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur2.TabIndex = 16
        Me.lblzensur2.Text = "Label21"
        '
        'ColdListDokumente
        '
        Me.ColdListDokumente.AllowFilter = True
        Me.ColdListDokumente.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdListDokumente.AllowSort = True
        Me.ColdListDokumente.AllowUpdate = False
        Me.ColdListDokumente.AllowUpdateOnBlur = False
        Me.ColdListDokumente.BackColor = System.Drawing.Color.White
        Me.ColdListDokumente.CaptionHeight = 17
        Me.ColdListDokumente.CollapseColor = System.Drawing.Color.Black
        Me.ColdListDokumente.ContextMenu = Me.ContextMenu8
        Me.ColdListDokumente.Cursor = System.Windows.Forms.Cursors.Default
        Me.ColdListDokumente.DataChanged = False
        Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
        Me.ColdListDokumente.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdListDokumente.Dock = System.Windows.Forms.DockStyle.Left
        Me.ColdListDokumente.ExpandColor = System.Drawing.Color.Black
        Me.ColdListDokumente.FlatStyle = C1.Win.C1TrueDBGrid.FlatModeEnum.Popup
        Me.ColdListDokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdListDokumente.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ColdListDokumente.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdListDokumente.Name = "ColdListDokumente"
        Me.ColdListDokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdListDokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdListDokumente.PreviewInfo.ZoomFactor = 75
        Me.ColdListDokumente.PrintInfo.ShowOptionsDialog = False
        Me.ColdListDokumente.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.Transparent
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.None
        Me.ColdListDokumente.RowDivider = GridLines3
        Me.ColdListDokumente.RowHeight = 15
        Me.ColdListDokumente.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.ColdListDokumente.ScrollTips = False
        Me.ColdListDokumente.Size = New System.Drawing.Size(336, 196)
        Me.ColdListDokumente.TabIndex = 13
        Me.ColdListDokumente.Text = "C1TrueDBGrid1"
        Me.ColdListDokumente.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style13{}EvenRow{BackColor:White;}Selected{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Heading{Wrap:True;BackColor:Control;Border:Flat,ControlDark,0, 1," & _
        " 0, 1;ForeColor:ControlText;AlignVert:Center;}Inactive{ForeColor:InactiveCaption" & _
        "Text;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}OddRow{BackCo" & _
        "lor:224, 224, 224;}Footer{}Caption{AlignHorz:Center;}Style25{}Normal{BackColor:W" & _
        "hite;}Style26{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style24" & _
        "{}Style23{AlignHorz:Near;}Style22{}Style21{}Style20{}RecordSelector{AlignImage:C" & _
        "enter;}Style18{}Style19{}Style14{}Style15{}Style16{}Style17{}</Data></Styles><Sp" & _
        "lits><C1.Win.C1TrueDBGrid.HierarchicalView DefRecSelWidth=""16"" Name="""" CaptionHe" & _
        "ight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedC" & _
        "ellBorder"" RecordSelectorWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGrou" & _
        "p=""1""><ClientRect>0, 0, 332, 192</ClientRect><CaptionStyle parent=""Heading"" me=""" & _
        "Style23"" /><EditorStyle parent=""Editor"" me=""Style15"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style21"" /><FilterBarStyle parent=""FilterBar"" me=""Style26"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style17"" /><GroupStyle parent=""Group"" me=""Style25"" /><He" & _
        "adingStyle parent=""Heading"" me=""Style16"" /><HighLightRowStyle parent=""HighlightR" & _
        "ow"" me=""Style20"" /><InactiveStyle parent=""Inactive"" me=""Style19"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style22"" /><RecordSelectorStyle parent=""RecordSelector"" me=""" & _
        "Style24"" /><SelectedStyle parent=""Selected"" me=""Style18"" /><Style parent=""Normal" & _
        """ me=""Style14"" /></C1.Win.C1TrueDBGrid.HierarchicalView></Splits><NamedStyles><S" & _
        "tyle parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent" & _
        "=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""H" & _
        "eading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""No" & _
        "rmal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""No" & _
        "rmal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading" & _
        """ me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""C" & _
        "aption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horz" & _
        "Splits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 332, 192</ClientArea></Blob>"
        '
        'ContextMenu8
        '
        Me.ContextMenu8.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem28, Me.MenuItem38, Me.MenuItem50, Me.MenuItem51, Me.mnuDruckDokumentwerte})
        '
        'MenuItem28
        '
        Me.MenuItem28.Index = 0
        Me.MenuItem28.Text = "Dokument anzeigen"
        '
        'MenuItem38
        '
        Me.MenuItem38.Index = 1
        Me.MenuItem38.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem40, Me.MenuItem41, Me.MenuItem39})
        Me.MenuItem38.Text = "&Status-Mutation"
        '
        'MenuItem40
        '
        Me.MenuItem40.Index = 0
        Me.MenuItem40.Text = "&Alt"
        '
        'MenuItem41
        '
        Me.MenuItem41.Index = 1
        Me.MenuItem41.Text = "&Aktuell"
        '
        'MenuItem39
        '
        Me.MenuItem39.Index = 2
        Me.MenuItem39.Text = "&Ungültig"
        '
        'MenuItem50
        '
        Me.MenuItem50.Index = 2
        Me.MenuItem50.Text = "Eintrag Löschen"
        '
        'MenuItem51
        '
        Me.MenuItem51.Index = 3
        Me.MenuItem51.Text = "Eintrag 'Aktiv' setzen"
        '
        'mnuDruckDokumentwerte
        '
        Me.mnuDruckDokumentwerte.Index = 4
        Me.mnuDruckDokumentwerte.Text = "Dokumentwerte drucken"
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox17, Me.Label18, Me.TextBox16, Me.TextBox15, Me.Label17, Me.Label16})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(677, 196)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Diverse"
        '
        'TextBox17
        '
        Me.TextBox17.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox17.Location = New System.Drawing.Point(104, 72)
        Me.TextBox17.Name = "TextBox17"
        Me.TextBox17.ReadOnly = True
        Me.TextBox17.Size = New System.Drawing.Size(296, 20)
        Me.TextBox17.TabIndex = 5
        Me.TextBox17.Text = ""
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(8, 72)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(96, 23)
        Me.Label18.TabIndex = 4
        Me.Label18.Text = "Zuständig"
        '
        'TextBox16
        '
        Me.TextBox16.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox16.Location = New System.Drawing.Point(104, 32)
        Me.TextBox16.Name = "TextBox16"
        Me.TextBox16.ReadOnly = True
        Me.TextBox16.Size = New System.Drawing.Size(296, 20)
        Me.TextBox16.TabIndex = 3
        Me.TextBox16.Text = ""
        '
        'TextBox15
        '
        Me.TextBox15.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox15.Location = New System.Drawing.Point(104, 8)
        Me.TextBox15.Name = "TextBox15"
        Me.TextBox15.ReadOnly = True
        Me.TextBox15.Size = New System.Drawing.Size(296, 20)
        Me.TextBox15.TabIndex = 2
        Me.TextBox15.Text = ""
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 32)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(96, 23)
        Me.Label17.TabIndex = 1
        Me.Label17.Text = "Unterschrift rechts"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(8, 8)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 0
        Me.Label16.Text = "Unterschrift links"
        '
        'TabPageZuordnung
        '
        Me.TabPageZuordnung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur4, Me.Zuordnungslist})
        Me.TabPageZuordnung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageZuordnung.Name = "TabPageZuordnung"
        Me.TabPageZuordnung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageZuordnung.TabIndex = 6
        Me.TabPageZuordnung.Text = "Dokumentzuordnungen"
        '
        'pnlzensur4
        '
        Me.pnlzensur4.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur4})
        Me.pnlzensur4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur4.Name = "pnlzensur4"
        Me.pnlzensur4.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur4.TabIndex = 15
        '
        'lblzensur4
        '
        Me.lblzensur4.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur4.Name = "lblzensur4"
        Me.lblzensur4.Size = New System.Drawing.Size(640, 23)
        Me.lblzensur4.TabIndex = 0
        Me.lblzensur4.Text = "Label21"
        '
        'Zuordnungslist
        '
        Me.Zuordnungslist.AllowFilter = True
        Me.Zuordnungslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Zuordnungslist.AllowSort = True
        Me.Zuordnungslist.AllowUpdate = False
        Me.Zuordnungslist.AllowUpdateOnBlur = False
        Me.Zuordnungslist.AlternatingRows = True
        Me.Zuordnungslist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Zuordnungslist.CaptionHeight = 17
        Me.Zuordnungslist.CollapseColor = System.Drawing.Color.Black
        Me.Zuordnungslist.ContextMenu = Me.ContextMenu7
        Me.Zuordnungslist.DataChanged = False
        Me.Zuordnungslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Zuordnungslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Zuordnungslist.ExpandColor = System.Drawing.Color.Black
        Me.Zuordnungslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Zuordnungslist.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.Zuordnungslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Zuordnungslist.Name = "Zuordnungslist"
        Me.Zuordnungslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Zuordnungslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Zuordnungslist.PreviewInfo.ZoomFactor = 75
        Me.Zuordnungslist.PrintInfo.ShowOptionsDialog = False
        Me.Zuordnungslist.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Zuordnungslist.RowDivider = GridLines4
        Me.Zuordnungslist.RowHeight = 15
        Me.Zuordnungslist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Zuordnungslist.ScrollTips = False
        Me.Zuordnungslist.Size = New System.Drawing.Size(685, 222)
        Me.Zuordnungslist.TabIndex = 14
        Me.Zuordnungslist.Text = "C1TrueDBGrid1"
        Me.Zuordnungslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem26, Me.MenuItem47, Me.MenuItem48, Me.mnuDruckZuordnung})
        '
        'MenuItem26
        '
        Me.MenuItem26.Index = 0
        Me.MenuItem26.Text = "Dokument anzeigen"
        '
        'MenuItem47
        '
        Me.MenuItem47.Index = 1
        Me.MenuItem47.Text = "Partner-Dossier anzeigen"
        '
        'MenuItem48
        '
        Me.MenuItem48.Index = 2
        Me.MenuItem48.Text = "&Alle Dokumente des Geschäftsfalles anzeigen"
        '
        'mnuDruckZuordnung
        '
        Me.mnuDruckZuordnung.Index = 3
        Me.mnuDruckZuordnung.Text = "Dokumentzuordnungen drucken"
        '
        'TabPageNotizen
        '
        Me.TabPageNotizen.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur5, Me.Notizlist})
        Me.TabPageNotizen.Location = New System.Drawing.Point(4, 22)
        Me.TabPageNotizen.Name = "TabPageNotizen"
        Me.TabPageNotizen.Size = New System.Drawing.Size(685, 222)
        Me.TabPageNotizen.TabIndex = 5
        Me.TabPageNotizen.Text = "Notizen"
        '
        'pnlzensur5
        '
        Me.pnlzensur5.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.lblzensur5})
        Me.pnlzensur5.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur5.Name = "pnlzensur5"
        Me.pnlzensur5.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur5.TabIndex = 14
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(322, 71)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines5
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style9{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Co" & _
        "ntrol;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style1{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'lblzensur5
        '
        Me.lblzensur5.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur5.Name = "lblzensur5"
        Me.lblzensur5.Size = New System.Drawing.Size(648, 23)
        Me.lblzensur5.TabIndex = 0
        Me.lblzensur5.Text = "Label21"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AllowUpdate = False
        Me.Notizlist.AllowUpdateOnBlur = False
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu4
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines6
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(685, 222)
        Me.Notizlist.TabIndex = 13
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNotizanzeigen, Me.mnuDruckNotizen})
        '
        'MnuNotizanzeigen
        '
        Me.MnuNotizanzeigen.Index = 0
        Me.MnuNotizanzeigen.Text = "&Notiz anzeigen"
        '
        'mnuDruckNotizen
        '
        Me.mnuDruckNotizen.Index = 1
        Me.mnuDruckNotizen.Text = "Notizen &drucken"
        '
        'TabPageInfomeldung
        '
        Me.TabPageInfomeldung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur3, Me.InfoMeldungList})
        Me.TabPageInfomeldung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageInfomeldung.Name = "TabPageInfomeldung"
        Me.TabPageInfomeldung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageInfomeldung.TabIndex = 4
        Me.TabPageInfomeldung.Text = "Informationsmeldungen"
        '
        'pnlzensur3
        '
        Me.pnlzensur3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur3})
        Me.pnlzensur3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur3.Name = "pnlzensur3"
        Me.pnlzensur3.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur3.TabIndex = 13
        '
        'lblzensur3
        '
        Me.lblzensur3.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur3.Name = "lblzensur3"
        Me.lblzensur3.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur3.TabIndex = 0
        Me.lblzensur3.Text = "Label21"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AllowUpdateOnBlur = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.ContextMenu = Me.ContextMenuInfoMeldung
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.FetchRowStyles = True
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines7
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(685, 222)
        Me.InfoMeldungList.TabIndex = 12
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyle=""Dott" & _
        "edCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""" & _
        "1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>" & _
        "0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""" & _
        "Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarSty" & _
        "le parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" />" & _
        "<GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Sty" & _
        "le2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle par" & _
        "ent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordS" & _
        "electorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selec" & _
        "ted"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.Me" & _
        "rgeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Norm" & _
        "al"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading""" & _
        " me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" m" & _
        "e=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""H" & _
        "ighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""" & _
        "OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" m" & _
        "e=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1" & _
        "</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>" & _
        "16</DefaultRecSelWidth><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenuInfoMeldung
        '
        Me.ContextMenuInfoMeldung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDruckInfoMeldung})
        '
        'mnuDruckInfoMeldung
        '
        Me.mnuDruckInfoMeldung.Index = 0
        Me.mnuDruckInfoMeldung.Text = "Informationsmeldungen drucken"
        '
        'TabPageBerechtigung
        '
        Me.TabPageBerechtigung.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.TabPageBerechtigung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageBerechtigung.Name = "TabPageBerechtigung"
        Me.TabPageBerechtigung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageBerechtigung.TabIndex = 7
        Me.TabPageBerechtigung.Text = "Berechtigungseinschränkung"
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AllowUpdate = False
        Me.DokumentFunktionenList.AllowUpdateOnBlur = False
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.ContextMenu = Me.ContextMenuBerechtigung
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images7"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines8.Color = System.Drawing.Color.DarkGray
        GridLines8.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines8
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(685, 222)
        Me.DokumentFunktionenList.TabIndex = 14
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenuBerechtigung
        '
        Me.ContextMenuBerechtigung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDruckBerechtigung})
        '
        'mnuDruckBerechtigung
        '
        Me.mnuDruckBerechtigung.Index = 0
        Me.mnuDruckBerechtigung.Text = "Berechtigungseinschränkung drucken"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur6, Me.ErsetzteDokumenteList})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(685, 222)
        Me.TabPage2.TabIndex = 8
        Me.TabPage2.Text = "Ersetzte Dokumente"
        '
        'pnlzensur6
        '
        Me.pnlzensur6.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur6})
        Me.pnlzensur6.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur6.Name = "pnlzensur6"
        Me.pnlzensur6.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur6.TabIndex = 14
        '
        'lblzensur6
        '
        Me.lblzensur6.Location = New System.Drawing.Point(16, 16)
        Me.lblzensur6.Name = "lblzensur6"
        Me.lblzensur6.Size = New System.Drawing.Size(616, 23)
        Me.lblzensur6.TabIndex = 0
        Me.lblzensur6.Text = "Label21"
        '
        'ErsetzteDokumenteList
        '
        Me.ErsetzteDokumenteList.AllowFilter = True
        Me.ErsetzteDokumenteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ErsetzteDokumenteList.AllowSort = True
        Me.ErsetzteDokumenteList.AllowUpdate = False
        Me.ErsetzteDokumenteList.AllowUpdateOnBlur = False
        Me.ErsetzteDokumenteList.AlternatingRows = True
        Me.ErsetzteDokumenteList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ErsetzteDokumenteList.CaptionHeight = 17
        Me.ErsetzteDokumenteList.CollapseColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.ContextMenu = Me.ContextMenu10
        Me.ErsetzteDokumenteList.DataChanged = False
        Me.ErsetzteDokumenteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ErsetzteDokumenteList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ErsetzteDokumenteList.ExpandColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ErsetzteDokumenteList.Images.Add(CType(resources.GetObject("resource.Images8"), System.Drawing.Bitmap))
        Me.ErsetzteDokumenteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ErsetzteDokumenteList.Name = "ErsetzteDokumenteList"
        Me.ErsetzteDokumenteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.ZoomFactor = 75
        Me.ErsetzteDokumenteList.PrintInfo.ShowOptionsDialog = False
        Me.ErsetzteDokumenteList.RecordSelectorWidth = 16
        GridLines9.Color = System.Drawing.Color.DarkGray
        GridLines9.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ErsetzteDokumenteList.RowDivider = GridLines9
        Me.ErsetzteDokumenteList.RowHeight = 15
        Me.ErsetzteDokumenteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ErsetzteDokumenteList.ScrollTips = False
        Me.ErsetzteDokumenteList.Size = New System.Drawing.Size(685, 222)
        Me.ErsetzteDokumenteList.TabIndex = 13
        Me.ErsetzteDokumenteList.Text = "C1TrueDBGrid1"
        Me.ErsetzteDokumenteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu10
        '
        Me.ContextMenu10.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem27, Me.mnuDruckErsetzte})
        '
        'MenuItem27
        '
        Me.MenuItem27.Index = 0
        Me.MenuItem27.Text = "&Dokument anzeigen"
        '
        'mnuDruckErsetzte
        '
        Me.mnuDruckErsetzte.Index = 1
        Me.mnuDruckErsetzte.Text = "Ersetzte Dokumente drucken"
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem17, Me.MenuItem18})
        '
        'MenuItem17
        '
        Me.MenuItem17.Index = 0
        Me.MenuItem17.Text = "&Ausgangsarchiviert"
        '
        'MenuItem18
        '
        Me.MenuItem18.Index = 1
        Me.MenuItem18.Text = "&Eingangsarchiviert"
        '
        'cbProfile
        '
        Me.cbProfile.AllowDrop = True
        Me.cbProfile.Location = New System.Drawing.Point(200, 4)
        Me.cbProfile.Name = "cbProfile"
        Me.cbProfile.Size = New System.Drawing.Size(172, 21)
        Me.cbProfile.TabIndex = 24
        Me.cbProfile.Text = "ComboBox1"
        '
        'LblSearch
        '
        Me.LblSearch.Location = New System.Drawing.Point(400, 6)
        Me.LblSearch.Name = "LblSearch"
        Me.LblSearch.Size = New System.Drawing.Size(58, 16)
        Me.LblSearch.TabIndex = 13
        Me.LblSearch.Text = "Partner:"
        '
        'btnPartnersuche
        '
        Me.btnPartnersuche.Image = CType(resources.GetObject("btnPartnersuche.Image"), System.Drawing.Bitmap)
        Me.btnPartnersuche.Location = New System.Drawing.Point(556, 1)
        Me.btnPartnersuche.Name = "btnPartnersuche"
        Me.btnPartnersuche.Size = New System.Drawing.Size(24, 23)
        Me.btnPartnersuche.TabIndex = 14
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokumentSelect, Me.MenuItem37, Me.MnuClose})
        '
        'MnuDokumentSelect
        '
        Me.MnuDokumentSelect.Index = 0
        Me.MnuDokumentSelect.Text = "&Dokument auswählen"
        '
        'MenuItem37
        '
        Me.MenuItem37.Index = 1
        Me.MenuItem37.Text = "Dokument anzeigen"
        '
        'MnuClose
        '
        Me.MnuClose.Index = 2
        Me.MnuClose.Text = "Fenster schliessen"
        '
        'ImageList4
        '
        Me.ImageList4.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList4.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList4.ImageStream = CType(resources.GetObject("ImageList4.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList4.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images9"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(291, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines10.Color = System.Drawing.Color.DarkGray
        GridLines10.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines10
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(693, 276)
        Me.DokList.TabIndex = 25
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 689," & _
        " 272</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 689, " & _
        "272</ClientArea></Blob>"
        '
        'cmitprofil
        '
        Me.cmitprofil.Checked = True
        Me.cmitprofil.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cmitprofil.Location = New System.Drawing.Point(470, 2)
        Me.cmitprofil.Name = "cmitprofil"
        Me.cmitprofil.Size = New System.Drawing.Size(16, 24)
        Me.cmitprofil.TabIndex = 26
        Me.cmitprofil.Text = "CheckBox1"
        Me.cmitprofil.Visible = False
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(904, 2)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 27
        Me.Button2.Visible = False
        '
        'txtbcknr
        '
        Me.txtbcknr.Location = New System.Drawing.Point(760, 3)
        Me.txtbcknr.Name = "txtbcknr"
        Me.txtbcknr.Size = New System.Drawing.Size(144, 20)
        Me.txtbcknr.TabIndex = 28
        Me.txtbcknr.Text = ""
        Me.txtbcknr.Visible = False
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(720, 7)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(88, 16)
        Me.Label20.TabIndex = 29
        Me.Label20.Text = "Dok-ID/BCK-Nr."
        Me.Label20.Visible = False
        '
        'Button1
        '
        Me.Button1.Enabled = False
        Me.Button1.FlatStyle = System.Windows.Forms.FlatStyle.Flat
        Me.Button1.ForeColor = System.Drawing.SystemColors.Control
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(556, 1)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 30
        '
        'Button9
        '
        Me.Button9.Cursor = System.Windows.Forms.Cursors.Default
        Me.Button9.ForeColor = System.Drawing.SystemColors.Control
        Me.Button9.Image = CType(resources.GetObject("Button9.Image"), System.Drawing.Bitmap)
        Me.Button9.Location = New System.Drawing.Point(372, 2)
        Me.Button9.Name = "Button9"
        Me.Button9.Size = New System.Drawing.Size(26, 23)
        Me.Button9.TabIndex = 31
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(960, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 67
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'mnublkunde
        '
        Me.mnublkunde.Index = 13
        Me.mnublkunde.Text = "Banklagernd-Dossier anzeigen"
        '
        'frmTrefferliste
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(984, 549)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.cbProfile, Me.Button9, Me.Button1, Me.txtbcknr, Me.Label20, Me.Button2, Me.btnPartnersuche, Me.cmitprofil, Me.txtnrpar00, Me.DokList, Me.TabControl1, Me.LblSearch, Me.Splitter1, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmTrefferliste"
        Me.ShowInTaskbar = False
        Me.Text = "Trefferliste - Profil XX"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.pnlSearch.ResumeLayout(False)
        Me.Panel4.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPageAllgemein.ResumeLayout(False)
        Me.pnlzensur1.ResumeLayout(False)
        Me.TabPageStatus.ResumeLayout(False)
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        Me.TabPageDokumentwerte.ResumeLayout(False)
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage3.ResumeLayout(False)
        Me.TabPageZuordnung.ResumeLayout(False)
        Me.pnlzensur4.ResumeLayout(False)
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageNotizen.ResumeLayout(False)
        Me.pnlzensur5.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageInfomeldung.ResumeLayout(False)
        Me.pnlzensur3.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageBerechtigung.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        Me.pnlzensur6.ResumeLayout(False)
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Load_Layout Method

Private Sub Load_Layout()

Source code

[Visual Basic]
    Private Sub Load_Layout()
        Dim docname As String
        'Anzeige Buttons richtig setzen
        SetDataFromProfil()
        Try
            Dim m_IsEdokaDok As Boolean = True 'Ist ein Edoka Dokument
            docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + ".lyt", "")
            If HOSTDATEN = True Then
                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
                m_IsEdokaDok = False
            End If
            If ZVDaten = True Then
                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
                m_IsEdokaDok = False
            End If
            If UVMDaten = False Then
            Else
                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
                m_IsEdokaDok = False
            End If

            'Ist ein Edoka Dokument
            'BUD 3.6
            If m_IsEdokaDok = True Then
                '******************************************************
                'Gelösche/aufgehobene und gelöschte versante inaktiv
                If m_bInakAlt = False And m_bInakVersant = False Then
                    'Me.DokList.Columns("aktiv").FilterText = True
                    'Me.DokList.Columns("AnzeigeStatus").FilterText = 0
                    Me.DokList.Columns("aktiv").FilterText = ""
                    Me.DokList.Columns("AnzeigeStatus").FilterText = ""

                    'Daten zusammensetzen
                    If m_OrgData_change = False Then
                        m_OrgData_dt = Me.DokList.DataSource
                        m_OrgData_change = True
                    End If
                    Dim Temp_dt As DataTable
                    Dim dview As New DataView(m_OrgData_dt, " (aktivesdokument = 1) AND (AnzeigeStatus = 0 ) AND (NOT status_bezeichnungnr = -3)", "AnzeigeStatus", DataViewRowState.CurrentRows)
                    Temp_dt = m_OrgData_dt.Clone

                    Dim drv1 As DataRowView
                    For Each drv1 In dview
                        Dim srcRow As DataRow = drv1.Row
                        Temp_dt.ImportRow(srcRow)
                    Next
                    Me.DokList.DataSource = Temp_dt
                    DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, Temp_dt, "trefferliste")
                Else
                    '******************************************************
                    'Nur Gelösche/aufgehobene Aktiv
                    If m_bInakAlt = True And m_bInakVersant = False Then
                        Me.DokList.Columns("aktiv").FilterText = ""
                        Me.DokList.Columns("AnzeigeStatus").FilterText = 0
                    End If
                    '******************************************************
                    'Nur gelöschte versante Aktiv
                    If m_bInakAlt = False And m_bInakVersant = True Then
                        Me.DokList.Columns("aktiv").FilterText = ""
                        Me.DokList.Columns("AnzeigeStatus").FilterText = ""

                        'Daten zusammensetzen
                        If m_OrgData_change = False Then
                            m_OrgData_dt = Me.DokList.DataSource
                            m_OrgData_change = True
                        End If
                        Dim Temp_dt As DataTable
                        Dim dview As New DataView(m_OrgData_dt, "aktivesdokument =0 AND (AnzeigeStatus = 1 )", "AnzeigeStatus", DataViewRowState.CurrentRows)
                        Temp_dt = m_OrgData_dt.Clone

                        Dim drv1 As DataRowView
                        For Each drv1 In dview
                            Dim srcRow As DataRow = drv1.Row
                            Temp_dt.ImportRow(srcRow)
                        Next
                        'AND NOT (status_bezeichnungnr = -3)
                        Dim dview2 As New DataView(m_OrgData_dt, "aktivesdokument =1 AND NOT status_bezeichnungnr = -3 ", "AnzeigeStatus", DataViewRowState.CurrentRows)
                        Dim drv2 As DataRowView
                        For Each drv2 In dview2
                            Dim srcRow As DataRow = drv2.Row
                            Temp_dt.ImportRow(srcRow)
                        Next
                        Me.DokList.DataSource = Temp_dt
                        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, Temp_dt, "trefferliste")
                    End If
                    'Beide Aktiv
                    If m_bInakAlt = True And m_bInakVersant = True Then
                        Me.DokList.Columns("aktiv").FilterText = ""
                        Me.DokList.Columns("AnzeigeStatus").FilterText = ""
                    End If
                End If

            End If

        Catch ex As Exception
        End Try

        If Dir(docname) = "" Then
            Dim p As New DocMgmt()
            '***********************************
            'Standardlayout laden entfernt
            '29.7.2004 / SHU
            '***********************************
            Try
                If p.Get_layout_from_DB(Me.Profilnr, docname) <> "" Then
                    Me.DokList.LoadLayout(docname)
                End If
            Catch
                Dim i1 As Integer
                For i1 = 0 To Me.DokList.Columns.Count - 1
                    Me.DokList.Splits(0).DisplayColumns(i1).Visible = True
                    Me.DokList.Splits(0).DisplayColumns(i1).AutoSize()
                Next
            Finally
                p = Nothing
            End Try
        Else
            Me.DokList.LoadLayout(docname)
        End If
        Dim i As Integer

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Load_Profiles Method

Private Sub Load_Profiles()

Source code

[Visual Basic]
    Private Sub Load_Profiles()
        Me.DataSet1.Clear()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        If Microsoft.VisualBasic.Right(Me.tvstruktur.SelectedNode.Tag, 3) = 998 Then
            '            update_host = True
            Update_Partnerstruktur()
            '           update_host = False
            Me.tvstruktur.SelectedNode.ExpandAll()
        Else
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        Me.tvstruktur.SelectedNode.Collapse()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem12_Click Method

Private Sub MenuItem12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem12.Click
        Create_Dokument(False, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem14_Click Method

Private Sub MenuItem14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Globals.PerfMon.insert_entry("Start Update Dokumentliste")
        Update_Doklist()
        Globals.PerfMon.insert_entry("Stop Update Dokumentliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        Create_Dokument(True, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Dim f As New frmLoeschgrund()
        Archivfnkt.Inkl_Bedingter_Retournierung = False
        If Archivfnkt.check_bereits_archiviert(Me.DokList.Columns("dokumentid").Text, True, Me.DokList.Columns("Statusbezeichnungnr").Value) = False Then
            Exit Sub
        End If
        f.txtLoeschgrund.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_delete"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                Dim loeschgrund As String
                If f.txtLoeschgrund.Text.Length > 254 Then				'begrentzt durch dbo.dokument.loeschgrund
                    loeschgrund = f.txtLoeschgrund.Text.Substring(0, 254)
                Else
                    loeschgrund = f.txtLoeschgrund.Text
                End If

                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                'rs 2006-10-19 scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschgrund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, f.txtLoeschgrund.Text))
                scmCmdToExecute.Parameters.Add("@loeschgrund", loeschgrund)
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)

                'Prüfen
                If Globals.DokAnKundeVersantPruefen = True Then
                    If Me.DokList.Columns("Statusbezeichnungnr").Value > -2 Then
                        Globals.DokAnKundeVersant = True
                    Else
                        Globals.DokAnKundeVersant = False
                    End If
                End If
                'Wenn das Dokument bereits an den Partner versant wurde, zusätzlich den Anzeige Status setzen und
                'den Löschgrund als Notiz speichern
                If Globals.DokAnKundeVersant = True Then
                    Dim scmCmdToExecute1 As SqlCommand = New SqlCommand()
                    scmCmdToExecute1.CommandText = "dbo.SP_Dokument_updateinaktversant"
                    scmCmdToExecute1.CommandType = CommandType.StoredProcedure
                    scmCmdToExecute1.Connection = conn.scoDBConnection
                    conn.OpenConnection()
                    Try
                        scmCmdToExecute1.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                        scmCmdToExecute1.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                        scmCmdToExecute1.ExecuteNonQuery()
                    Catch ex As Exception
                        Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                    Finally
                        scmCmdToExecute1.Dispose()
                        conn.CloseConnection(True)
                    End Try
                End If
                'Ende
                Dim dt As DataTable
                Dim sth As New Statushandling()
                dt = sth.get_coldindex_and_statusnr(Me.DokList.Columns("dokumentid").Text, False, False)
                Archivfnkt.insert_coldupdate_status(dt, Me.DokList.Columns("dokumentid").Text, "Alt")
                sth.Dispose()
                Try
                    Update_Doklist()
                Catch ex As Exception
                End Try
            End Try
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem17_Click Method

Private Sub MenuItem17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        Dim statush As New Statushandling()
        Dim dok As New edokadb.clsDokument()
        Try
            dok.cpMainConnectionProvider = conn
            dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Value, String))
            dok.SelectOne()
            dok.iStatusnr = New SqlInt32(CType(statush.Set_Ausgangsarchiviert(Me.DokList.Columns("dokumentid").Text), Integer))
            conn.OpenConnection()
            dok.Update()
            conn.CloseConnection(True)
            statush.Dispose()
            dok.Dispose()
            statush.check_abschluss(Me.DokList.Columns("dokumentid").Text, Globals.MitarbeiterNr)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem18_Click Method

Private Sub MenuItem18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim statush As New Statushandling()
        Dim dok As New edokadb.clsDokument()
        dok.cpMainConnectionProvider = conn
        dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Value, String))
        dok.SelectOne()
        dok.iStatusnr = New SqlInt32(CType(statush.Set_Eingangsarchiviert(Me.DokList.Columns("dokumentid").Text), Integer))
        conn.OpenConnection()
        dok.Update()
        conn.CloseConnection(True)
        statush.Dispose()
        dok.Dispose()
        statush.check_abschluss(Me.DokList.Columns("dokumentid").Text, Globals.MitarbeiterNr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem19_Click Method

Private Sub MenuItem19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem19.Click
        m_OrgData_change = False
        PreviewAlleDokumente = True  'neu koe 29.09.2003
        AlleDokumente = True
        Update_Doklist()
        AlleDokumente = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem21_Click Method

Private Sub MenuItem21_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem21_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem21.Click
        Me.Cursor = Cursors.WaitCursor
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then
            Me.Cursor = Cursors.Default
            Exit Sub
        End If
        DivFnkt.Status_Dokumentbearbeitung(1, Me.DokList.Columns("dokumentid").Value, False, "")
        Me.Cursor = Cursors.WaitCursor
        Dim x
        x = Me.DokList.Bookmark
        Dim f As New frmDokumentInfoEdit()
        f.NurDokinfo = True
        f.Profilnr = Me.Profilnr
        f.Dokument_Ist_Abgeschlossen = dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text)
        f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
        f.Profile = Me.DataSet1.Tables(0)
        f.Dokumentinfobearbeiten = True
        f.CreateDocument = False
        f.ShowDialog()
        f.Hide()
        Windows.Forms.Application.DoEvents()
        Update_Doklist()
        Try
            Me.DokList.Bookmark = x
            Update_DetailInformation()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem22_Click Method

Private Sub MenuItem22_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem22.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem22_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem22.Click
        Try
            Dim d As Long
            d = Val(Me.Partnernr)
            If d > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = d
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = d
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem24_Click Method

Private Sub MenuItem24_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem24.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem24_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem24.Click
        Dim F As New frmSpaltenDarstellung()
        Dim i As Integer
        F.ListBox1.Items.Clear()
        F.ListBox2.Items.Clear()
        Try
            For i = 0 To Me.DokList.Columns.Count - 1
                Try
                    If Me.DokList.Splits(0).DisplayColumns(i).Visible = False Then
                        If Me.DokList.Splits(0).DisplayColumns(i).Name().ToString <> "" Then
                            F.ListBox1.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
                        End If
                    End If
                Catch
                End Try
                Try
                    If Me.DokList.Splits(0).DisplayColumns(i).Visible = True Then F.ListBox2.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
                Catch
                End Try
            Next
        Catch ex As Exception

        End Try
        F.ShowDialog()
        For i = 0 To F.ListBox1.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.DokList.Columns.Count - 1
                    If Me.DokList.Splits(0).DisplayColumns(xx).Name = F.ListBox1.Items(i) Then
                        Me.DokList.Splits(0).DisplayColumns(xx).Visible = False
                    End If
                Next
                '                Me.DokList.Splits(0).DisplayColumns(F.ListBox1.Items(i)).Visible = False
            Catch
            End Try
        Next
        For i = 0 To F.ListBox2.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.DokList.Columns.Count - 1
                    If Me.DokList.Splits(0).DisplayColumns(xx).Name = F.ListBox2.Items(i) Then
                        Me.DokList.Splits(0).DisplayColumns(xx).Visible = True
                    End If
                Next
                '                Me.DokList.Splits(0).DisplayColumns(F.ListBox2.Items(i)).Visible = True
            Catch
            End Try
        Next
        F.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem25_Click Method

Private Sub MenuItem25_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem25.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem25_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem25.Click
        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem26_Click Method

Private Sub MenuItem26_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem26.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem26_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem26.Click
        DivFnkt.ShowDoc(Me.Zuordnungslist.Columns("dokumentid2").Value, Me.ParentForm)
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem27_Click Method

Private Sub MenuItem27_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem27.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem27_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem27.Click
        DivFnkt.ShowDoc(Me.ErsetzteDokumenteList.Columns("dokumentid").Text, Me.ParentForm)
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem28_Click Method

Private Sub MenuItem28_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem28.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem28_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem28.Click
        '************************************************
        'UVM Migration / Erste Variante
        'Start
        '************************************************
        ''Rel 3.7 / BUD
        'If InStr(Me.DokList.Columns("dokumentid").Text, "OFFEDK003") <> 0 Then
        '    DivFnkt.gen_ShowColdDocUVM(Me.DokList.Columns("Partner-Nr").Value, Me.DokList.Columns("geschaeftsfall").Text, Me.DokList.Columns("Erstellungsdatum").Value, Me.ParentForm)
        'Else
        '    DivFnkt.ShowColdDoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, m_sTempColdDokID)
        'End If
        '************************************************
        'ENDE
        '************************************************
        DivFnkt.ShowColdDoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, m_sTempColdDokID)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem29_Click Method

Private Sub MenuItem29_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem29.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem29_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem29.Click
        Create_Dokument(True, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem31_Click Method

Private Sub MenuItem31_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem31.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem31_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem31.Click
        Create_Dokument(False, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem32_Click Method

Private Sub MenuItem32_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem32.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem32_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem32.Click
        Dim f As New frmStatusSetzen()
        f.TextBox1.Text = Me.DokList.Columns("dokumentid").Text
        f.ShowDialog()
        Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem33_Popup Method

Private Sub MenuItem33_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem33.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem33_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem33.Popup
        'Hutter 2004-10-04 Aktivierung COLD-Print
        If Me.ZVDaten Or Me.UVMDaten Or Me.HOSTDATEN Then
            Me.MenuItem34.Enabled = False
            Me.MenuItem35.Enabled = True
            Me.MenuItem33.Enabled = True
            Exit Sub
        End If

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)

            If scmCmdToExecute.Parameters("@office").Value > 0 Then
                Me.MenuItem34.Enabled = True
            Else
                Me.MenuItem34.Enabled = False
            End If
            If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                Me.MenuItem35.Enabled = True
            Else
                Me.MenuItem35.Enabled = False
            End If
            'If DivFnkt.isbck(Me.DokList.Columns("dokumentid").Value) Then Me.MenuItem34.Enabled = False
            If Me.MenuItem34.Enabled = False And Me.MenuItem35.Enabled = False Then
                Me.MenuItem33.Enabled = False
            Else
                Me.MenuItem33.Enabled = True
            End If

            'Else
            'Me.MenuItem34.Enabled = False
            'Me.MenuItem44.Enabled = False
            'If Not DivFnkt.isbck(Me.DokList.Columns("dokumentid").Value) Then Me.MenuItem33.Enabled = False
            'End If
            ''HUTTER 2004-10-04 - AKTIVIERUNG Colt-Print
            'If Me.ZVDaten = True Or UVMDaten = True Or HOSTDATEN = True Then
            '    Me.MenuItem33.Enabled = True
            '    Me.MenuItem35.Enabled = True
            '    '         End If
            '    '            If scmCmdToExecute.Parameters("@COLD").Value > 0 Then
            '    '           Me.MenuItem35.Enabled = True
            '    '          Me.MenuItem33.Enabled = True
            'Else
            '    Me.MenuItem35.Enabled = False
            'End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem34_Click Method

Private Sub MenuItem34_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem34.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem34_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem34.Click
        DivFnkt.print_office(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem35_Click Method

Private Sub MenuItem35_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem35.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem35_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem35.Click
        'hutter 2004-10-04 Aktivierung Cold-Print
        If Me.HOSTDATEN = True Then
            Try
                Dim gendokCold As New Collection()
                Dim gendokOffice As New Collection()
                'Host Daten abfüllen
                gendokCold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
                clsMehrfachdruck_Data.Enum_Typ.HOST, False, Me.DokList.Columns("dokumenttypnr").Text, "", Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("valutadatum").Text))
                fMehrfachdruck.DruckAnfrage(gendokCold, gendokOffice)
                'DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
                'DivFnkt.Belegart = "HOST"
                'DivFnkt.printcolddocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttyp").Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            Catch ex As Exception
            Finally
                Me.Cursor = Cursors.Default
            End Try
        End If
        If Me.ZVDaten = True Then
            Try
                DivFnkt.Erstellungsdatum = Me.DokList.Columns(3).Text
                DivFnkt.Auftragnr = Me.DokList.Columns(18).Text
                DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                DivFnkt.Belegart = "ZV"

                DivFnkt.printcolddocHost(Me.DokList.Columns(11).Text, Me.ParentForm, Me.DokList.Columns(11).Text, Me.DokList.Columns(20).Text, _
                Me.DokList.Columns(20).Text, Me.DokList.Columns(0).Text)

                Me.Cursor = Cursors.Default
                Exit Sub
            Catch
            End Try
        End If
        If Me.UVMDaten = True Then
            DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).Text
            DivFnkt.Belegart = "UVM"
            DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
            DivFnkt.Auftragnr = Me.DokList.Columns(4).Text
            DivFnkt.printcolddocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(2).Text, _
            Me.DokList.Columns(2).Text, Me.DokList.Columns(0).Text)
            Me.Cursor = Cursors.Default
            Exit Sub
        End If

        'Try
        '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
        '        DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
        '        DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text)
        '        Me.Cursor = Cursors.Default
        '        Exit Sub
        '    End If
        'Catch

        'End Try
        DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem37_Click Method

Private Sub MenuItem37_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem37.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem37_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem37.Click
        MenuItem4_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem39_Click Method

Private Sub MenuItem39_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem39.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem39_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem39.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Ungültig")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        'Bedingte Retournierung
        Dim Bedingte_Retournierung_vorhanden As Boolean = False
        Dim dokumentidbr As String

        Dim dok As New edokadb.clsDokument()
        dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Text, String))
        dok.cpMainConnectionProvider = conn
        dok.SelectOne()
        Try
            If dok.sBedRDokumentid.Value <> "" Then
                Bedingte_Retournierung_vorhanden = True
                dokumentidbr = dok.sBedRDokumentid.Value
                Archivfnkt.Inkl_Bedingter_Retournierung = True
                Archivfnkt.Dokument_Bedingte_Retournierung = dokumentidbr
            Else
                Bedingte_Retournierung_vorhanden = False
                Archivfnkt.Inkl_Bedingter_Retournierung = False
            End If
        Catch
            Bedingte_Retournierung_vorhanden = False
            Archivfnkt.Inkl_Bedingter_Retournierung = False
        End Try

        Dim barcodekleberdokument As Boolean = isbck()
        Globals.Dokumentcoldindex_Changed = False
        Globals.DokumentColdIndex_ChangedBR = False

        Globals.dokumentid_changed = False
        Globals.dokumentid_changedbr = False

        Globals.Ersetzte_Dokumente_Reaktivieren = False
        Globals.ersetzte_dokumente_reaktivierenbr = False

        Archivfnkt.bck = barcodekleberdokument
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Me.Cursor = Cursors.WaitCursor
        If Archivfnkt.check_bereits_archiviert(Me.DokList.Columns("dokumentid").Text, False) = False Then
            Windows.Forms.Application.DoEvents()
            Me.Cursor = Cursors.Default
            dok.Dispose()
            Exit Sub
        End If
        Archivfnkt.bck = False
        Windows.Forms.Application.DoEvents()
        Me.Cursor = Cursors.WaitCursor
        If Globals.dokumentid_changed Then
            DivFnkt.Status_Dokumentbearbeitung(1, Globals.DokumentID_New_Copy, False, "")
        Else
            DivFnkt.Status_Dokumentbearbeitung(1, Me.DokList.Columns("dokumentid").Value, False, "")
        End If

        If Globals.dokumentid_changedbr Then
            If Globals.dokumentid_changed Then
                dok.sDokumentid = New SqlString(CType(Globals.DokumentID_New_Copy, String))
                dok.SelectOne()
            End If
            dok.sBedRDokumentid = New SqlString(CType(Globals.DokumentID_New_CopyBR, String))
            conn.OpenConnection()
            dok.Update()
            conn.CloseConnection(True)
            dok.Dispose()
            DivFnkt.Status_Dokumentbearbeitung(1, Globals.DokumentID_New_CopyBR, False, "")
        Else
            DivFnkt.Status_Dokumentbearbeitung(1, dokumentidbr, False, "")
        End If
        Dim x
        x = Me.DokList.Bookmark
        If Not barcodekleberdokument Then
            Dim f As New frmDokumentbearbeitung()
            f.Profilnr = Me.Profilnr

            If Globals.dokumentid_changed Then
                f.EditDokumentid = Globals.DokumentID_New_Copy
            Else
                f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
            End If

            If Globals.dokumentid_changedbr Then
                f.EditDokumentidbr = Globals.DokumentID_New_CopyBR
            Else
                f.EditDokumentidbr = dokumentidbr
            End If

            f.Profile = Me.DataSet1.Tables(0)
            f.Dokumentinfobearbeiten = False
            f.CreateDocument = False
            f.ShowDialog()
            Update_Doklist()
            Try
                Me.DokList.Bookmark = x
                Update_DetailInformation()
            Catch
            End Try
        Else
            Dim f As New frmDokumentbearbeitungBC()
            f.Profilnr = Me.Profilnr

            If Globals.dokumentid_changed Then
                f.EditDokumentid = Globals.DokumentID_New_Copy
            Else
                f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
            End If

            f.Profile = Me.DataSet1.Tables(0)
            f.Dokumentinfobearbeiten = False
            f.CreateDocument = False
            f.ShowDialog()
            Update_Doklist()
            Try
                Me.DokList.Bookmark = x
                Update_DetailInformation()
            Catch
            End Try
        End If
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem40_Click Method

Private Sub MenuItem40_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem40.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem40_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem40.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Alt")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem41_Click Method

Private Sub MenuItem41_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem41.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem41_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem41.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Aktuell")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem43_Click Method

Private Sub MenuItem43_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem43.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem43_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem43.Click
        Dim type As Integer
        type = 0
        Try
            If ZVDaten Then
                type = 4
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "ZV.lyt", 0))
            End If
            If UVMDaten Then
                type = 3
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "UVM.lyt", 0))
            End If
            If HOSTDATEN Then
                type = 2
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "HOST.lyt", 0))
            End If
            If type = 0 Then
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + ".lyt", 0))
                type = 1
            End If
        Catch
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_delete_profillayout"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, type))
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
        End Try
        Update_Doklist()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem44_Click Method

Private Sub MenuItem44_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem44.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem44_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem44.Click
        DivFnkt.show_office(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem46_Click Method

Private Sub MenuItem46_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem46.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem46_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem46.Click
        Dim f As New frmMassenMail()
        f.Profilnr = Me.Profilnr
        If Partner_Eingegeben Then
            f.PartnerEingegeben = True
            f.Partnernr = Me.txtnrpar00.Text
        Else
            f.PartnerEingegeben = False
        End If
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem47_Click Method

Private Sub MenuItem47_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem47.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem47_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem47.Click
        Dim f As New frmSearchDoc()
        f.txtbcknr.Text = (Me.Zuordnungslist.Columns("dokumentid2").Value)
        f.Visible = False
        'f.Show()
        f.Visible = False
        f.MdiParent = Me.MdiParent
        f.Show_Doc()
        f.Hide()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem48_Click Method

Private Sub MenuItem48_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem48.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem48_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem48.Click
        MenuItem49_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem49_Click Method

Private Sub MenuItem49_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem49.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem49_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem49.Click
        Globals.PerfMon.insert_entry("Start Partnerdossier öffnen")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Globals.profilnr = Me.Profilnr
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.Geschaeftsfall = Me.DokList.Columns("Geschaeftsfall").Text
        f.Alle_Dokumente_Des_Geschaeftsfalles()
        f.txtnrpar00.Visible = False
        f.ImgCombo.Visible = False
        f.btnPartnersuche.Visible = False
        f.Button1.Visible = False
        f.LblSearch.Visible = False
        Dim i As Integer
        For i = 3 To f.ToolBar1.Buttons.Count - 1
            f.ToolBar1.Buttons(i).Enabled = False
        Next
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partnerdossier öffnen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Try
            If HOSTDATEN Then
                DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
                DivFnkt.Belegart = "HOST"
                DivFnkt.ShowColdDocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
                Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttyp").Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            End If
            If ZVDaten Then
                'SHU 20060112 - Mehrfachanzeige von ZV-Belegen
                If Me.DokList.SelectedRows.Count > 0 Then
                    Dim gendokcold As New Collection()
                    Dim i As Integer
                    Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
                    colRows = Me.DokList.SelectedRows
                    For i = 0 To colRows.Count - 1
                        Try
                            'COLD-Dokumentanzeige der ZV-Belege
                            If ZVDaten Then
                                Try
                                    'ZV Daten abfüllen
                                    gendokcold.Add(New clsMehrfachdruck_Data(Me.DokList.Columns(11).CellValue(colRows(i)), _
                                    Me.DokList.Columns(3).CellValue(colRows(i)), clsMehrfachdruck_Data.Enum_Typ.ZV, False, _
                                    Me.DokList.Columns(0).CellValue(colRows(i)), Me.DokList.Columns(18).CellValue(colRows(i)), _
                                    "", Me.DokList.Columns(9).CellValue(colRows(i))))
                                Catch ex As Exception
                                End Try
                                Exit Try
                            End If

                        Catch
                        End Try
                    Next
                    Try
                        Dim f As New frmcoldviewer()
                        f.dokdata = gendokcold

                        'Dim f As New frmcoldviewer(gendokcold)
                        f.MdiParent = Me.MdiParent
                        f.Hide()
                        f.Visible = False
                        f.Show()
                        f.Visible = True
                        f.Refresh()
                        Application.DoEvents()
                    Catch ex As Exception
                    End Try
                    Exit Sub
                End If

                Try
                    DivFnkt.Erstellungsdatum = Me.DokList.Columns(3).Text
                    DivFnkt.Auftragnr = Me.DokList.Columns(18).Text
                    DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                    DivFnkt.Belegart = "ZV"
                    DivFnkt.ShowColdDocHost(Me.DokList.Columns(11).Text, Me.ParentForm, Me.DokList.Columns(11).Text, Me.DokList.Columns(20).Text, _
                    Me.DokList.Columns(20).Text, Me.DokList.Columns(0).Text)
                    Me.Cursor = Cursors.Default
                    Exit Sub
                Catch ex As Exception
                End Try
            End If
            If UVMDaten Then
                DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).Text
                DivFnkt.Belegart = "UVM"
                DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                DivFnkt.Auftragnr = Me.DokList.Columns(4).Text
                DivFnkt.ShowColdDocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(2).Text, _
                Me.DokList.Columns(2).Text, Me.DokList.Columns(0).Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            End If

            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            Try
                If d.Rows(0).Item("anzeigen") = 1 Then
                    '************************************************
                    'UVM Migration / Erste Variante
                    'Start
                    '************************************************
                    ''*** BUD / Rel 3.7
                    'If InStr(Me.DokList.Columns("dokumentid").Value, "OFFEDK003") <> 0 Then
                    '    DivFnkt.gen_ShowColdDocUVM(Me.DokList.Columns("Partner-Nr").Value, Me.DokList.Columns("geschaeftsfall").Text, Me.DokList.Columns("Erstellungsdatum").Value, Me.ParentForm)
                    '    Me.Cursor = Cursors.Default
                    '    Exit Sub
                    'Else
                    '    DivFnkt.Erstellungsdatum = ""
                    '    DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
                    '    Me.Cursor = Cursors.Default
                    'End If
                    '************************************************
                    'ENDE
                    '************************************************
                    DivFnkt.Erstellungsdatum = ""
                    DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
                    Me.Cursor = Cursors.Default
                    '*** Ende
                Else
                    MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
                End If
            Catch
                MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem50_Click Method

Private Sub MenuItem50_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem50.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem50_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem50.Click
        Dim cd As Integer
        cd = Me.ColdListDokumente.Columns("indextypnr").Value
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Korrektur_delete_dokumentcoldindexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, cd))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Delete_Dokumentcoldindexwert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            Update_Coldindex()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem51_Click Method

Private Sub MenuItem51_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem51.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem51_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem51.Click
        Dim cd As Integer
        cd = Me.ColdListDokumente.Columns("indextypnr").Value
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Korrektur_delete_dokumentcoldindexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, cd))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.ExecuteNonQuery()
            If scmCmdToExecute.Parameters("@rc").Value <> 0 Then
                MsgBox("Dokumenteintrag kann nicht gändert werden, da ein Indextyp mit Nr. 1/2 bereits vorhanden ist.", MsgBoxStyle.Critical)
                Exit Sub
            End If
        Catch ex As Exception
            Throw New Exception("Delete_Dokumentcoldindexwert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            Update_Coldindex()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Dim x
        Dim f As New frmStatuswechsel()
        f.currentstatus = Me.DokList.Columns("statusnr").Text
        x = Me.DokList.Bookmark
        f.Dokumentid = Me.DokList.Columns("dokumentid").Value
        f.Mitarbeiternr = Me.DokList.Columns("Verantwortlich").Value
        f.ShowDialog()
        Update_Doklist()
        Try
            Me.DokList.Bookmark = x
            Update_DetailInformation()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Globals.PerfMon.insert_entry("Start Partnerdossier öffnen")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Globals.profilnr = Me.Profilnr
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.Partner_Eingegeben = True
        f.txtnrpar00.Text = LTrim(Me.Partnernr.ToString)
        f.refresh_list()
        f.Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partnerdossier öffnen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Globals.PerfMon.insert_entry("Start Strukurbaum aktualisieren")
        Refresh_All(True)
        Globals.PerfMon.insert_entry("Stop Strukurbaum aktualisieren")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItemISINSUche_Click Method

Private Sub MenuItemISINSUche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemISINSUche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemISINSUche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemISINSUche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItemPartnersuche_Click Method

Private Sub MenuItemPartnersuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemPartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemPartnersuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22104))
        Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = True
        If Me.txtnrpar00.Text.Length > 0 Then DoKeyenter() Else Me.Button1_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItemVVSuche_Click Method

Private Sub MenuItemVVSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemVVSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemVVSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemVVSuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MenuItemValorSuche_Click Method

Private Sub MenuItemValorSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemValorSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemValorSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemValorSuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Mitarbeiter_Laden Method

Private Sub Mitarbeiter_Laden()

Source code

[Visual Basic]
    Private Sub Mitarbeiter_Laden()
        '===============================================================================
        'Description: Mitarbeiter in DRP Laden DropDown an Grid Binden und Mutierer übersetzen
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        conn.OpenConnection()
        If m_DTMitarbeiter Is Nothing Then
            m_DTMitarbeiter = Generic_Select(17)
        End If

        Me.drpMiatarbeiter.DataSource = m_DTMitarbeiter
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuABDokAufheben_Click Method

Private Sub MnuABDokAufheben_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuABDokAufheben.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuABDokAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuABDokAufheben.Click
        Dim sth As New Statushandling()
        If MyMsg.Show_MessageYesNo(70) = MsgBoxResult.Yes Then
            sth.set_aufgehoben(Me.DokList.Columns("dokumentid").Text)
            Me.Update_Doklist()
        End If
        sth.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuABDokLoeschen_Click Method

Private Sub MnuABDokLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuABDokLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuABDokLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuABDokLoeschen.Click
        MenuItem16_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuClose_Click Method

Private Sub MnuClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuDokumentSelect_Click Method

Private Sub MnuDokumentSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentSelect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentSelect.Click
        Me.SelectedDokumentid = Me.DokList.Columns("dokumentid").Text
        Me.Dokumentbezeichnung = Me.DokList.Columns("bezeichnung").Text
        Me.dokumentdatum = Me.DokList.Columns("erstellungsdatum").Text
        'Me.SelectedBeschreibung = Me.DokList.Columns("beschreibung").Text
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuDokumentreaktivieren_Click Method

Private Sub MnuDokumentreaktivieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentreaktivieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentreaktivieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentreaktivieren.Click
        Dim f As New frmReaktivierungsgrund()
        f.txtLoeschgrund.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Korrektur_Dokument_Reaktivieren"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Grund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, f.txtLoeschgrund.Text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("Dokument_Reaktivieren::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)
                Update_Doklist()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.MnuNotizanzeigen_Click Method

Private Sub MnuNotizanzeigen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNotizanzeigen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNotizanzeigen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNotizanzeigen.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("mutiert_am").Text
        f.FrmReadOnly = True
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Name_of_Trefferliste Method

Private Sub Name_of_Trefferliste()

Source code

[Visual Basic]
    Private Sub Name_of_Trefferliste()
        Dim i As Integer
        Dim s As String
        If Me.Partner_Eingegeben Then
            i = Microsoft.VisualBasic.InStr(Me.Text, "-")
            s = Microsoft.VisualBasic.Left(Me.Text, i)
            s = s & " " & Me.tvstruktur.Nodes(0).Text
        Else
            i = Microsoft.VisualBasic.InStr(Me.Text, "-")
            s = Microsoft.VisualBasic.Left(Me.Text, i)
            's = s & " " & Me.cbProfile.Text
            s = s & " " & Me.ImgCombo.Text
        End If
        Me.Text = s
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.PosDok Method

Public Sub PosDok( _
   ByVal dokumentid As String, _
   ByVal dokumentart As Integer _
)

Parameters

dokumentid
Required.
dokumentart
Required.

Source code

[Visual Basic]
    Public Sub PosDok(ByVal dokumentid As String, ByVal dokumentart As Integer)
        Try
            Dim s As String
            s = " " + Me.txtnrpar00.Text + "-" + Str(dokumentart)
            Dim i As Integer

            DivFnkt.Searchnode(Me.tvstruktur, s, 0)
            If DivFnkt.found = True Then Me.tvstruktur.SelectedNode = DivFnkt.FoundNode
            '  Me.Update_Doklist()

            If Len(dokumentid) = 10 Then
                dokumentid = getDokumentID(dokumentid, 1)
            End If

            For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
                If UCase(Me.DokList.Columns("dokumentid").CellValue(i)) = UCase(dokumentid) Then
                    Me.DokList.Bookmark = i
                    Me.Update_DetailInformation()
                End If
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.RBStatusAktuell_Click Method

Private Sub RBStatusAktuell_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles RBStatusAktuell.Click, _
   RBStatusHistory.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBStatusAktuell_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles RBStatusAktuell.Click, RBStatusHistory.Click
        If Me.RBStatusAktuell.Checked = True Then
            statushistory = False
            Update_DetailInformation()
        End If
        If Me.RBStatusHistory.Checked = True Then
            statushistory = True
            Update_DetailInformation()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Refresh_All Method

Public Sub Refresh_All( _
   ByVal refreshlist As Boolean _
)

Parameters

refreshlist
Required.

Source code

[Visual Basic]
    Public Sub Refresh_All(ByVal refreshlist As Boolean)
        Dim n As TreeNode
        n = Me.savenode
        Dim v As Long
        v = Val(Me.Partnernr)
        Dim isexpanded As Boolean = True
        If refreshlist Then
            on_refresh = True
            refresh_list()
            on_refresh = False
        End If
        Me.tvstruktur.BeginUpdate()
        Dim i As Integer
        For i = 0 To Me.tvstruktur.Nodes.Count - 1
            If Me.tvstruktur.Nodes(i).Tag = v Then
                Try
                    Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(i)
                    If isexpanded Then Update_Partnerstruktur()
                    Me.tvstruktur.SelectedNode.ExpandAll()
                Catch
                End Try
            End If
        Next
        Try
            DivFnkt.Searchnode3(Me.tvstruktur, n.Tag, 0)
            If DivFnkt.found = True Then
                Update_Partnerstruktur()
                DivFnkt.Searchnode(Me.tvstruktur, n.Tag, n.ImageIndex)
                If DivFnkt.found = True Then
                    Me.tvstruktur.SelectedNode = DivFnkt.FoundNode
                    Me.tvstruktur.SelectedNode.ExpandAll()
                End If
            End If
        Catch
        End Try
        Me.tvstruktur.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SaveButtonToProfil Method

Private Sub SaveButtonToProfil( _
   ByVal ButtonIndex As Integer, _
   ByVal bStatus As Boolean _
)

Parameters

ButtonIndex
Required.
bStatus
Required.

Source code

[Visual Basic]
    Private Sub SaveButtonToProfil(ByVal ButtonIndex As Integer, ByVal bStatus As Boolean)
        If ButtonIndex = 6 Or ButtonIndex = 7 Then
            Dim p As New edokadb.clsProfil()
            p.cpMainConnectionProvider = conn
            conn.OpenConnection()
            p.iProfilnr = New SqlInt32(CType(Me.m_profilnr, Int32))
            p.SelectOne()
            Select Case ButtonIndex
                Case 7
                    p.bInklalt = New SqlBoolean(CType(bStatus, Boolean))
                    p.Update()
                Case 6
                    p.bInkInaktVersant = New SqlBoolean(CType(bStatus, Boolean))
                    p.Update()
            End Select
            conn.CloseConnection(True)
            p.Dispose()

            'Load_Layout()
            If Me.DokList.Columns.Count > 0 Then
                Update_Doklist()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Save_Layout Method

Private Sub Save_Layout()

Source code

[Visual Basic]
    Private Sub Save_Layout()
        Dim p As New DocMgmt()
        Try
            Dim docname As String
            Try
                '***********************************
                'Layoutfile für alle Dokumenttypen setzen
                '29.7.2004 / SHU
                '***********************************

                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + ".lyt", "")
                If HOSTDATEN Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
                If ZVDaten Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
                If UVMDaten = False Then
                Else
                    docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
                End If

                'Try
                '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
                '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
                '    End If
                'Catch
                'End Try
                'Try
                '    If Me.DokList.Columns("NRAUF00").Text <> "" Then
                '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
                '    End If
                'Catch
                'End Try
                'Try
                '    Dim i As Integer
                '    For i = 0 To Me.DokList.Columns.Count - 1
                '        If Me.DokList.Columns(i).DataField = "CDZAH00" Then
                '            docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
                '        End If
                '    Next
                'Catch
                'End Try
            Catch
            End Try
            Me.DokList.SaveLayout(docname)
            If p.Save_Layout_DB(Me.Profilnr, docname) Then
                Me.DokList.LoadLayout(docname)
            End If
        Catch
        Finally
            p = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SetDataFromProfil Method

Liest das Profil aus und setzt die Buttons in den richtigen Status

Private Sub SetDataFromProfil()

Author

Daniel Burren

Version

Release 3.6

Source code

[Visual Basic]
    Private Sub SetDataFromProfil()
        Dim p As New edokadb.clsProfil()
        p.cpMainConnectionProvider = conn
        conn.OpenConnection()
        p.iProfilnr = New SqlInt32(CType(Me.m_profilnr, Int32))
        p.SelectOne()

        m_bInakAlt = p.bInklalt.Value
        m_bInakVersant = p.bInkInaktVersant.Value

        conn.CloseConnection(True)
        p.Dispose()

        Me.ToolBar1.Buttons(7).Pushed = m_bInakAlt
        Me.ToolBar1.Buttons(6).Pushed = m_bInakVersant
        SetToolbar1Buttons(7, m_bInakAlt)
        SetToolbar1Buttons(6, m_bInakVersant)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SetMetaDataDruck Method

Private Sub SetMetaDataDruck( _
   ByVal bStatus As Boolean _
)

Parameters

bStatus
Required.

Source code

[Visual Basic]
    Private Sub SetMetaDataDruck(ByVal bStatus As Boolean)
        'Kontextmenu Meta Daten Druck
        mnuDruckDokumentwerte.Enabled = bStatus
        mnuDruckNotizen.Enabled = bStatus
        mnuDruckErsetzte.Enabled = bStatus
        mnuDruckInfoMeldung.Enabled = bStatus
        mnuDruckZuordnung.Enabled = bStatus
        mnuDruckDokStatus.Enabled = bStatus
        mnuDruckBerechtigung.Enabled = bStatus
        mnuDruckAllgemein.Enabled = bStatus
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.SetToolbar1Buttons Method

Setzt die Buttons und den Tooltip.

Private Sub SetToolbar1Buttons( _
   ByVal iButton As Integer, _
   ByVal bPushed As Boolean _
)

Parameters

iButton
Required.
bPushed
Required.

Author

Daniel Burren

Version

3.6

Source code

[Visual Basic]
    Private Sub SetToolbar1Buttons(ByVal iButton As Integer, ByVal bPushed As Boolean)
        Dim sText As String
        Dim iMessage As Integer
        Select Case bPushed
            Case True
                sText = MyMsg.Get_Meldungstext(273)
            Case False
                sText = MyMsg.Get_Meldungstext(274)
        End Select
        Select Case iButton
            Case 7
                iMessage = 271
            Case 6
                iMessage = 272
        End Select
        Me.ToolBar1.Buttons(iButton).ToolTipText = MyMsg.ReplaceTextinMSG(MyMsg.Get_Meldungstext(iMessage), sText, "")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Set_Colors Method

Public Sub Set_Colors()

Source code

[Visual Basic]
    Public Sub Set_Colors()
        Dim i As Integer
        Dim convcol As New ColorConverter()
        Dim da As DataTable
        da = Me.DataSet1.Tables(0)
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item("profilnr") = Me.ImgCombo.SelectedValue Then
                scolor1 = convcol.ConvertFromString(da.Rows(i).Item("color1"))
                scolor2 = convcol.ConvertFromString(da.Rows(i).Item("color2"))
                scolor3 = convcol.ConvertFromString(da.Rows(i).Item("color3"))
                scolor4 = convcol.ConvertFromString(da.Rows(i).Item("color4"))
                scolor5 = convcol.ConvertFromString(da.Rows(i).Item("color5"))
                scolor6 = convcol.ConvertFromString(da.Rows(i).Item("color6"))
            End If
        Next
        da.Dispose()
        convcol = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Splitter2_Move Method

Private Sub Splitter2_Move( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Splitter2.Move

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Splitter2_Move(ByVal sender As Object, ByVal e As System.EventArgs) Handles Splitter2.Move
        'If m_ColdListWidthOrg <> 0 Then
        '    Dim iSpliterPosition As Integer
        '    Dim iTabWidth As Integer
        '    Dim iTempResVorher As Integer
        '    Dim iSpaltenanpassung As Integer
        '    iSpliterPosition = Me.Splitter2.SplitPosition
        '    iTabWidth = Me.TabControl1.Width
        '    iTempResVorher = iTabWidth - m_ColdListWidthOrg
        '    iSpaltenanpassung = (iTabWidth - iSpliterPosition) - iTempResVorher
        '    Me.ColdList.Splits(0).DisplayColumns(1).Width = Me.ColdList.Splits(0).DisplayColumns(1).Width + iSpaltenanpassung
        '    If Me.ColdList.Splits(0).DisplayColumns(1).Width < 11 Then
        '        Me.ColdList.Splits(0).DisplayColumns(1).Width = 10
        '    End If
        '    m_ColdListWidthOrg = Me.Splitter2.SplitPosition

        '    '            Me.ColdList.Splits(0).DisplayColumns(1).Width = Me.ColdList.Width - Me.ColdList.Splits(0).DisplayColumns(0).Width - Me.ColdList.Splits(0).DisplayColumns(2).Width
        'End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Status_lesen Method

Public Function Status_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Status_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            If Me.statushistory = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Statuslist_FetchRowStyle Method

Private Sub Statuslist_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles Statuslist.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles Statuslist.FetchRowStyle

        If Me.Statuslist.Columns("bezeichnung").CellValue(e.Row) = Me.TextBox11.Text Then
            If colornotset Then
                e.CellStyle.ForeColor = Red
                colornotset = False
            End If
        Else
            e.CellStyle.ForeColor = Black
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.TVstruktur_MouseDown Method

Private Sub TVstruktur_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvstruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVstruktur_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvstruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            tvstruktur.SelectedNode = tvstruktur.GetNodeAt(selectPoint)
            Console.WriteLine("mousedown" & DateTime.Now.Second & "_" & DateTime.Now.Millisecond)

            PreviewAlleDokumente = False        'Node-Spezifische Dokumente Anzeigen neu koe 29.09.2003
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.TabControl1_Click Method

Private Sub TabControl1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControl1.Click

        Me.Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.TabPage1_Click Method

Private Sub TabPage1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabPage1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabPage1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabPage1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.TabPageDokumentwerte_Click Method

Private Sub TabPageDokumentwerte_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabPageDokumentwerte.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabPageDokumentwerte_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabPageDokumentwerte.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                'drucken button
                Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
                Dim fontregular As New Font("Arial", 12, FontStyle.Regular)
                Dim sRoot() As String
                Try
                    'If DokList.Splits(0).Rows.Count = 0 Then Exit Sub
                    With DokList.PrintInfo
                        .PageHeaderStyle.Font = fontbold
                        .PageSettings.Margins.Bottom = 20
                        .PageSettings.Margins.Top = 80
                        .PageSettings.Landscape = True
                        .PageFooter = "Seite \p von \P" & vbLf & " Druckdatum " & Now()
                        If PreviewAlleDokumente = True Then
                            'Alle Dokumente anzeigen
                            sRoot = Split(Me.tvstruktur.SelectedNode.FullPath(), "\")
                            .PageHeader = Trim(sRoot(LBound(sRoot)))
                        Else
                            'Dokumente Per Node anzeigen
                            .PageHeader = Me.tvstruktur.SelectedNode.FullPath()
                        End If
                        .ShowProgressForm = True
                        .UseGridColors = True
                        .RepeatColumnHeaders = True
                        .VarRowHeight = DokList.PrintInfo.RowHeightEnum.StretchToFit
                        .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
                        .PageBreak = DokList.PrintInfo.PageBreaksEnum.OnColumn
                        .FillAreaWidth = DokList.PrintInfo.FillEmptyEnum.ExtendLast
                        '.ShowOptionsDialog = True
                        .PrintPreview()
                    End With
                Catch
                End Try
            Case 2
                Me.SelectedDocart = ""
                Create_Dokument(False, False)
            Case 3
                Me.SelectedDocart = ""
                Create_Dokument(False, True)
                Exit Sub
                Dim f As New frmVorlagenauswahl()

                F.TVStruktur.ImageList = Me.ImageList3
                Me.Profilnr = Me.cbProfile.SelectedValue
                Me.Profilnr = Me.ImgCombo.SelectedValue
                f.Dokumentart = ""
                f.Show_Favoriten = True
                f.ProfilNr = Me.Profilnr
                f.Profile = Me.DataSet1.Tables(0)
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    Me.Cursor = Cursors.WaitCursor
                    Dim fI As New frmDokumentbearbeitung()
                    fI.Partnernr = ""
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    fI.Dokumenttypnr = F.Dokumentvorlage
                    fI.CreateDocument = True
                    F.Dispose()
                    Me.Cursor = Cursors.Default
                    fI.ShowDialog()
                    on_refresh = True
                    refresh_list()
                    on_refresh = False
                End If
            Case 6
                If Me.ToolBar1.Buttons(6).Pushed = True Then
                    SetToolbar1Buttons(6, True)
                    SaveButtonToProfil(6, True)
                Else
                    SetToolbar1Buttons(6, False)
                    SaveButtonToProfil(6, False)
                End If
            Case 7
                If Me.ToolBar1.Buttons(7).Pushed = True Then
                    SetToolbar1Buttons(7, True)
                    SaveButtonToProfil(7, True)
                Else
                    SetToolbar1Buttons(7, False)
                    SaveButtonToProfil(7, False)
                End If
            Case 9 'Profil bearbeiten
                Dim f As New frmProfil()
                Me.Cursor = Cursors.WaitCursor
                Me.Profilnr = Me.cbProfile.SelectedValue
                Me.Profilnr = Me.ImgCombo.SelectedValue
                f.ProfilNr = Me.Profilnr
                f.ShowDialog()
                Init_Pages()

                f.Hide()
                Windows.Forms.Application.DoEvents()
                Me.ToolBar1.Buttons(5).ImageIndex = 7
                Load_Profiles()
                If f.Profile_Geaendert Then
                    Me.Cursor = Cursors.Default
                    MyMsg.show_standardmessage(50, MsgBoxStyle.Information)
                    Exit Sub
                End If
                '                Me.txtnrpar00.Text = ""
                Me.txtnrpar00.Text = ""
                If f.ProfilNr <> Me.Profilnr Then
                    Me.Profilnr = f.ProfilNr
                    Me.cbProfile.SelectedValue = Me.Profilnr
                    Me.ImgCombo.SelectedValue = Me.Profilnr
                    i = f.ProfilNr
                    Me.ImgCombo.SelectedValue = i
                    Refresh_All(True)
                    Name_of_Trefferliste()
                    Me.tvstruktur.Focus()
                    Update_Doklist()
                Else
                    imgcombo_SelectedIndexChanged_1(sender, e)
                    '                    Load_Profiles()
                    'Me.Profilnr = f.ProfilNr
                    'Me.cbProfile.SelectedValue = Me.Profilnr
                    'i = Me.Profilnr
                    'Me.ImgCombo.SelectedValue = i
                    'imgcombo_SelectedIndexChanged_1(sender, e)
                    'Name_of_Trefferliste()
                    'Partner_Eingegeben = False
                    ''Me.refresh_list()
                    'MenuItem8_Click(sender, e)
                End If
                Load_Layout()
            Case 5
                Globals.PerfMon.insert_entry("Start Strukturbaum aktualisieren (Toolbar)")
                Me.on_refresh = True
                refresh_list()
                Refresh_All(True)
                Me.Cursor = System.Windows.Forms.Cursors.Default
                Me.on_refresh = False
                Me.ToolBar1.Buttons(5).ImageIndex = 7
                Globals.PerfMon.insert_entry("Stop Strukturbaum aktualisieren (Toolbar)")
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_ColdListDokumente_Detail Method

Private Sub Update_ColdListDokumente_Detail( _
   ByVal doenable As Boolean _
)

Parameters

doenable
Required.

Source code

[Visual Basic]
    Private Sub Update_ColdListDokumente_Detail(ByVal doenable As Boolean)
        Try
            Dim cd As DataTable
            If doenable Then Me.ColdList.Enabled = False
            cd = Cold_Index_lesen(Me.ColdListDokumente.Columns("indextypnr").Value, 0)
            Me.ColdList.DataSource = cd
            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, cd, "coldlist")
            Me.TextBox15.Text = Me.DokList.Columns("dokunterschriftlinks").Text
            Me.TextBox16.Text = Me.DokList.Columns("dokunterschriftrechts").Text
            Me.TextBox17.Text = Me.DokList.Columns("dokzustaendig").Text
            Me.ColdList.Enabled = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Coldindex Method

Private Sub Update_Coldindex()

Source code

[Visual Basic]
    Private Sub Update_Coldindex()
        Me.ColdListDokumente.Enabled = False
        Me.ColdList.Enabled = False
        Dim ds As New DataSet()
        Dim cd As DataTable
        Dim cdHierarchie As DataTable

        Dim iCnt As Integer
        Try

            Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal
            cd = Cold_Index_lesen(0, 1)
            cdHierarchie = Cold_Index_lesen(0, 0)
            '----------------------------------------------
            ds.Tables.Add(cd)
            ds.Tables.Add(cdHierarchie)

            Dim dr As DataRelation
            Dim dc1 As DataColumn = cd.Columns("TreeID")
            Dim dc2 As DataColumn = cdHierarchie.Columns("SubTreeID")
            Dim rel As New DataRelation("RelColdIndex", dc1, dc2)
            Try
                Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
            Catch ex As System.ArgumentException
                '  MsgBox(ex.Message)
            End Try

            ds.Relations.Add(rel)
            Me.ColdListDokumente.SetDataBinding(ds, ds.Tables(0).TableName)

            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdListDokumente, cd, "coldlistdokumente")
            If m_ExpandColdListDokumente < 0 Then m_ExpandColdListDokumente = 0
            If m_ExpandColdListDokumente < 1 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        Case "STATUSALT", "ARCHIVDATUMALT"
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                    End Select
                Next
            End If

            Update_ColdListDokumente_Detail(False)
            Me.ColdListDokumente.Enabled = True
            Me.ColdList.Enabled = True
        Catch ex As Exception
            '  MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_DetailInformation Method

Private Sub Update_DetailInformation()

Source code

[Visual Basic]
    Private Sub Update_DetailInformation()
        Globals.PerfMon.insert_entry("'-- Begin Dokumentdetails")
        Me.Notizlist.Enabled = False
        Me.InfoMeldungList.Enabled = False
        Me.Zuordnungslist.Enabled = False
        Me.DokumentFunktionenList.Enabled = False
        Me.Cursor = Cursors.WaitCursor
        Select Case Me.TabControl1.SelectedTab.Name
            Case "TabPageAllgemein"
                Update_Details()
            Case "TabPageDokumentwerte"
                Update_Coldindex()
            Case "TabPageArchivierung"
                'update_archivierung()
            Case "TabPageInfomeldung"
                Update_DokumentInfoMeldung()
            Case "TabPageZuordnung"
                Update_Dokumentzuordnung()
            Case "TabPageStatus"
                Update_Status()
            Case "TabPageNotizen"
                Update_Notizen()
            Case "TabPageBerechtigung"
                Update_Dokumentfunktionen()
            Case "TabPage2"
                Update_Ersetzte_Dokumente()
        End Select
        Me.Notizlist.Enabled = True
        Me.InfoMeldungList.Enabled = True
        Me.Zuordnungslist.Enabled = True
        Me.DokumentFunktionenList.Enabled = True
        Me.Cursor = Cursors.Default
        Update_Details()

        Dim d As DataTable
        Dim I As Integer
        Try
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            If Me.DokList.Columns("verantwortlich").Value <> Globals.MitarbeiterNr Then
                If d.Rows.Count = 0 And Globals.stv = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '           Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    'Rel 3.6
                    SetMetaDataDruck(False)

                    Exit Sub
                End If
                If d.Rows(0).Item("anzeigen") = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '            Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    'Rel 3.6
                    SetMetaDataDruck(False)

                    Exit Sub
                End If
                d.Dispose()
                '
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '         Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
                'Rel 3.6
                SetMetaDataDruck(True)
            Else
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '                Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
                'Rel 3.6
                SetMetaDataDruck(True)
            End If
        Catch
            Me.TabControl1.Visible = False
        End Try
        Globals.PerfMon.insert_entry("'-- Ende Dokumentdetails")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Details Method

Private Sub Update_Details()

Source code

[Visual Basic]
    Private Sub Update_Details()
        Try
            Dim xbck As String

            Me.TextBox1.Text = Me.DokList.Columns("Dokumentid").Value
            If Me.DokList.Columns("Bemerkung").Text Is System.DBNull.Value Then
                Me.TextBox12.Text = ""
            Else
                Me.TextBox12.Text = Me.DokList.Columns("Bemerkung").Value
                ttip.SetToolTip(Me.TextBox12, Me.TextBox12.Text)
            End If

            If isbck() Then
                xbck = LTrim(Str(Me.bcknr))
                While Len(xbck) < 10
                    xbck = "0" + xbck
                End While
                Me.TextBox18.Text = xbck
            Else
                Me.TextBox18.Text = ""
            End If
            Me.TextBox2.Text = Str(Me.DokList.Columns("PartnerNr").Value) + " " + Me.DokList.Columns("Partnerkurzbezeichnung").Value
            Me.TextBox3.Text = Me.DokList.Columns("Dokumentart").Value
            Me.TextBox4.Text = Me.DokList.Columns("Bezeichnung").Value
            Me.TextBox5.Text = Me.DokList.Columns("Erstellungsdatum").Value
            Me.TextBox6.Text = Me.DokList.Columns("DokErsteller").Value
            If Me.DokList.Columns("Sperrdatum").Value Is System.DBNull.Value Then Me.TextBox7.Text = "" Else Me.TextBox7.Text = Me.DokList.Columns("Sperrdatum").Value
            If Me.DokList.Columns("DokSperrung").Value Is System.DBNull.Value Then
                Me.TextBox8.Text = ""
                Me.TextBox7.Text = ""
            Else
                Me.TextBox8.Text = Me.DokList.Columns("DokSperrung").Value
            End If
            Me.TextBox9.Text = Me.DokList.Columns("Mutationsdatum").Value
            Me.TextBox10.Text = Me.DokList.Columns("DokMutierer").Value
            Me.TextBox11.Text = Me.DokList.Columns("Status").Value
            Me.TextBox13.Text = Me.DokList.Columns("DokVerantwortlich").Value
            Me.TextBox14.Text = ""
            If (Me.DokList.Columns("termin").Value Is System.DBNull.Value) Or (Year(Me.DokList.Columns("termin").Value) = 1900) Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            '            If Me.DokList.Columns("termin").Value Is System.DBNull.Value Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            Me.TabControl1.Visible = True
        Catch ex As Exception
            '      MsgBox(ex.Message)
            '     Me.TabControl1.Visible = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Doklist Method

Private Sub Update_Doklist()

Source code

[Visual Basic]
    Private Sub Update_Doklist()
        Try
            If on_refresh Then
                Try
                    Me.DokList.DataSource = Nothing
                    Me.TabControl1.Visible = False
                Catch
                End Try
                Exit Sub
            End If
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim i As Integer
            Dim xd As DataTable
            Me.DokList.Enabled = False
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            xd = Dokumente_lesen()
            Me.doklistrowcount = xd.Rows.Count
            Me.DokList.DataSource = xd
            Try
                If xd.Rows.Count = 0 Then
                    Me.DokList.DataSource = Nothing
                    Me.TabControl1.Visible = False
                End If
            Catch
            End Try

            HOSTDATEN = False
            UVMDaten = False
            ZVDaten = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, xd, "trefferliste")
            For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                If UCase(Me.DokList.Columns(i).DataField) = "PARTNERNR_INHABER" Then HOSTDATEN = True
                If UCase(Me.DokList.Columns(i).DataField) = "NRAUF00" Then UVMDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "CDVAR00" Then ZVDaten = True
                Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
            Next

            Load_Layout()
            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns(2).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                    'Dim I1 As Integer
                    'For I1 = 0 To Me.DokList.Columns.Count - 1
                    '    If Me.DokList.Splits(0).DisplayColumns(I1).Name().ToString = "Betrag" Then
                    '        Me.DokList.Splits(0).DisplayColumns(I1).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                    '    End If
                    'Next
                End If
            Catch
            End Try

            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns("Betrag").Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                End If
            Catch
            End Try

            If Not HOSTDATEN And Not ZVDaten And Not UVMDaten Then Me.DokList.Splits(0).DisplayColumns("bemerkung").FetchStyle = True

            Me.Cursor = System.Windows.Forms.Cursors.Default
            Try
                Dim cols(Me.DokList.Splits(0).DisplayColumns.Count - 1) As C1.Win.C1TrueDBGrid.C1DisplayColumn
                Dim anzcols As Integer
                anzcols = Me.DokList.Splits(0).DisplayColumns.Count
                Update_DetailInformation()

                Dim bmp0 As New Bitmap(Me.ImageList4.Images(0))
                Dim bmp1 As New Bitmap(Me.ImageList4.Images(1))
                Dim bmp2 As New Bitmap(Me.ImageList4.Images(2))
                Dim bmp3 As New Bitmap(Me.ImageList4.Images(3))

                Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
                v0.DisplayValue = bmp0
                v0.Value = 1

                v1.DisplayValue = bmp1
                v1.Value = 2

                v2.DisplayValue = bmp2
                v2.Value = 3

                v3.DisplayValue = bmp3
                v3.Value = 4

                For i = 0 To 3
                    Me.DokList.Columns(i).ValueItems.Values.Add(v0)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v1)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v2)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v3)

                    Me.DokList.Columns(i).ValueItems.Translate = True
                Next i

                Me.DokList.Enabled = True
            Catch
            End Try
        Catch ex As Exception
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Finally
            Me.Cursor = System.Windows.Forms.Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_DokumentInfoMeldung Method

Private Sub Update_DokumentInfoMeldung()

Source code

[Visual Basic]
    Private Sub Update_DokumentInfoMeldung()
        Dim dokumentinfomeldung As DataTable
        dokumentinfomeldung = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = dokumentinfomeldung
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, dokumentinfomeldung, "Dokumentinfomeldung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Dokumentfunktionen Method

Private Sub Update_Dokumentfunktionen()

Source code

[Visual Basic]
    Private Sub Update_Dokumentfunktionen()
        Dim Dokumentfunktionen As DataTable
        Dokumentfunktionen = Dokumentfunktionen_Laden()
        Me.DokumentFunktionenList.DataSource = Dokumentfunktionen
        Me.DokumentFunktionenList.DataMember = Dokumentfunktionen.TableName
        Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
        Me.DokumentFunktionenList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Dokumentfunktionen, "berechtigungseinschraenkung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Dokumentzuordnung Method

Private Sub Update_Dokumentzuordnung()

Source code

[Visual Basic]
    Private Sub Update_Dokumentzuordnung()
        Dim dokumentzuordnungen As DataTable
        Dim i As Integer
        dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.Zuordnungslist.DataSource = dokumentzuordnungen
        Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Translate = True
        Next
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Zuordnungslist, dokumentzuordnungen, "dokumentzuordnungentr")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Ersetzte_Dokumente Method

Private Sub Update_Ersetzte_Dokumente()

Source code

[Visual Basic]
    Private Sub Update_Ersetzte_Dokumente()
        Dim ed As DataTable
        ed = ErsetzteDokumente_Laden()
        Me.ErsetzteDokumenteList.DataSource = ed
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ErsetzteDokumenteList, ed, "ersetztedokumente")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Notizen Method

Private Sub Update_Notizen()

Source code

[Visual Basic]
    Private Sub Update_Notizen()
        Dim Notizen As DataTable
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        Mitarbeiter_Laden()         'koe 28.07.2004
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Notizen, "notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Partnerstruktur Method

Public Sub Update_Partnerstruktur()

Source code

[Visual Basic]
    Public Sub Update_Partnerstruktur()
        Dim x As Long
        '        If Me.update_host Then Exit Sub
        Globals.hasmessage = 0
        x = Val(Me.Partnernr)
        If x = 0 Then Exit Sub
        Globals.PerfMon.insert_entry("'-- Begin Update Partnerstruktur")
        Me.Cursor = Cursors.WaitCursor
        '        Me.tvstruktur.BeginUpdate()

        If (Me.tvstruktur.SelectedNode.Nodes.Count = 1 And InStr(Me.tvstruktur.SelectedNode.Tag, "-") = 0) Or _
        Me.tvstruktur.SelectedNode.Text = "HOST " Then
            Me.tvstruktur.SelectedNode.Nodes.Clear()
            Me.DokList.Enabled = False
            Dim d As New edokadb.clsMyDokumentart()
            '            Me.tvstruktur.BeginUpdate()
            d.Geschaeftsfall = Me.Geschaeftsfall
            d.SelectPartner = False
            d.SearchString = ""
            If Me.Partner_Eingegeben = True Then
                If Me.txtnrpar00.Text.Length > 0 Then
                    If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" Then
                        d.SearchString = "VA:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" Then
                        d.SearchString = "IS:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
                        d.SearchString = "VV:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":" Then
                        d.SearchString = "HOST"
                    End If
                Else
                    d.SearchString = ""
                End If
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.Partnernr, Me.tvstruktur.SelectedNode, 1, 1, False)
            Else
                If Me.txtnrpar00.Text.Length > 0 Then
                    If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" Then
                        d.SearchString = "VA:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" Then
                        d.SearchString = "IS:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
                        d.SearchString = "VV:" + Me.txtnrpar00.Text
                    End If
                Else
                    d.SearchString = ""
                End If
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.Partnernr, Me.tvstruktur.SelectedNode, 1, 0, False)
            End If
        End If
        '       Me.tvstruktur.EndUpdate()
        Me.DokList.Enabled = True
        '       Me.tvstruktur.EndUpdate()
        Me.Cursor = Cursors.Default
        If Not Me.update_host Then
            If Globals.hasmessage = 1 Then MyMsg.show_standardmessage(90, MsgBoxStyle.Information)
            '            Me.update_host = True
        End If
        Globals.PerfMon.insert_entry("'-- Ende Update Partnerstruktur")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.Update_Status Method

Private Sub Update_Status()

Source code

[Visual Basic]
    Private Sub Update_Status()
        Try
            colornotset = True
            Dim st As DataTable
            st = Status_lesen()
            Me.Statuslist.FetchRowStyles = True
            Me.Statuslist.DataSource = Nothing
            Me.Statuslist.DataSource = st
            DivFnkt.SpaltenTitel_Aktualisieren(Me.Statuslist, st, "statushistory")
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.btnPartnersuche_VisibleChanged Method

Private Sub btnPartnersuche_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.VisibleChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnersuche_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnPartnersuche.VisibleChanged
        If Me.btnPartnersuche.Visible = False Then
            Me.Button1.Visible = True
        Else
            Me.Button1.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.cbProfile_SelectedIndexChanged Method

Private Sub cbProfile_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbProfile.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbProfile_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbProfile.SelectedIndexChanged
        Me.PageDirection = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.check_blkunde Method

Private Function check_blkunde( _
   ByVal nrpar00 As Integer _
) As Boolean

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function check_blkunde(ByVal nrpar00 As Integer) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_check_blkunde"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@blkunde", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@blkunde").Value = 0 Then
                Return False

            Else
                Return True
            End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.check_dokumentreaktivieren Method

Private Function check_dokumentreaktivieren() As Boolean

Source code

[Visual Basic]
    Private Function check_dokumentreaktivieren() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_dokumentreaktivierung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentreaktivierung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@dokumentreaktivierung").Value
            If i = 0 Then
                check_dokumentreaktivieren = False
            Else
                check_dokumentreaktivieren = True
            End If
        Catch ex As Exception
            '            MsgBox(ex.Message)
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.dokument_ist_abgeschlossen Method

Public Function dokument_ist_abgeschlossen( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function dokument_ist_abgeschlossen(ByVal dokumentid As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokument_abgeschlossen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@abschlussstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@abschlussstatus").Value
            If i = 0 Then
                dokument_ist_abgeschlossen = False
            Else
                dokument_ist_abgeschlossen = True
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.frmTrefferliste_Closing Method

Private Sub frmTrefferliste_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmTrefferliste_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        '        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.frmTrefferliste_Resize Method

Private Sub frmTrefferliste_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmTrefferliste_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.Button2.Left = Me.ToolBar1.Width - Me.Button2.Width
        Try
            Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.getDokumentID Method

Private Function getDokumentID( _
   ByVal bckNr As String, _
   ByVal typ As Integer _
) As String

Parameters

bckNr
Required.
typ
Required.

Source code

[Visual Basic]
    Private Function getDokumentID(ByVal bckNr As String, ByVal typ As Integer) As String
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_search_bck_DokID"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, bckNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, typ))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@DokumentID", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            getDokumentID = scmCmdToExecute.Parameters("@DokumentID").Value

        Catch ex As Exception
            MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
            getDokumentID = bckNr
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.get_contextmenu_ber Method

Private Function get_contextmenu_ber() As DataTable

Source code

[Visual Basic]
    Private Function get_contextmenu_ber() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_contextmenu"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("geschäftsfall").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.getnodedepth Method

Private Function getnodedepth( _
   ByVal node As TreeNode _
) As Long

Parameters

node
Required.

Source code

[Visual Basic]
    Private Function getnodedepth(ByVal node As TreeNode) As Long
        Try
            Me.Partnernr = LTrim(RTrim(Microsoft.VisualBasic.Left(node.Parent.Text, 11)))
        Catch
        End Try
        If Not (node.Parent Is Nothing) Then
            getnodedepth = getnodedepth(node.Parent) + 1
        Else
            getnodedepth = 1
            Try
                Me.Partnernr = LTrim(RTrim(Microsoft.VisualBasic.Left(node.Text, 11)))
            Catch
            End Try
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.imgcombo_SelectedIndexChanged_1 Method

Private Sub imgcombo_SelectedIndexChanged_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub imgcombo_SelectedIndexChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim i As Integer
        Init_Pages()
        Globals.PerfMon.insert_entry("Start Wechsel Profil")
        If Me.On_Load = True Then Exit Sub
        If Me.LoadProfiles Then Exit Sub
        Me.Partner_Eingegeben = False
        i = Me.ImgCombo.SelectedValue
        Set_Colors()
        Me.txtnrpar00.Text = ""
        Try
            Name_of_Trefferliste()
            Me.Profilnr = Me.ImgCombo.SelectedValue
        Catch
        End Try
        on_refresh = True
        refresh_list()
        on_refresh = False
        Load_Layout()
        Globals.PerfMon.insert_entry("Stop Wechsel Profil")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.insert_used_dp Method

Private Function insert_used_dp( _
   ByVal dpnr As Integer, _
   ByVal standard As Integer _
)

Parameters

dpnr
Required.
standard
Required.

Source code

[Visual Basic]
    Private Function insert_used_dp(ByVal dpnr As Integer, ByVal standard As Integer)
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_register_used_dp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dpnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dpnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@std", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, standard))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@blkunde").Value = 0 Then
                Return False

            Else
                Return True
            End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.isbck Method

Private Function isbck() As Boolean

Source code

[Visual Basic]
    Private Function isbck() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_check_bck"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isbck", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@isbck").Value = 1 Then
                isbck = True
                Me.bcknr = scmCmdToExecute.Parameters("@bcknr").Value
            Else
                isbck = False
                Me.bcknr = 0
            End If

        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("CheckBCK:" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.lblpageno_TextChanged Method

Private Sub lblpageno_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles lblpageno.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lblpageno_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles lblpageno.TextChanged
        If Me.lblpageno.Text = "0" Then Me.lblpageno.Text = "1"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDokKopieren_Click Method

Private Sub mnuDokKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDokKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDokKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDokKopieren.Click
        Try
            Dim f As New frmDokumentKopieren(Me.Partnernr)
            f.propDokumentID = Me.DokList.Columns("dokumentid").Value
            f.propDokumentTyp = Me.DokList.Columns("dokumenttypnr").Value
            f.propProfilDataTable = Me.DataSet1.Tables(0)
            f.propProfilNr = Me.Profilnr
            f.propDokumentBez = Me.DokList.Columns("Bezeichnung").Value
            f.propDokumentDatum = Me.DokList.Columns("Erstellungsdatum").Value
            f.Show()
            f.TopMost = True
            'f.ShowDialog()
        Catch
            MsgBox(Err.Description)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDokTypInfo_Click Method

Private Sub mnuDokTypInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDokTypInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDokTypInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDokTypInfo.Click
        Dim f As New frmDokumenttypInfo()
        Try
            f.Key = Me.DokList.Columns("dokumenttypnr").Value
            f.Text = Me.DokList.Columns("Bezeichnung").Value
            f.ShowDialog()
        Catch
        Finally
            f.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckAllgemein_Click Method

Private Sub mnuDruckAllgemein_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckAllgemein.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckAllgemein_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckAllgemein.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.AllgemeineInformationen)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckBerechtigung_Click Method

Private Sub mnuDruckBerechtigung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckBerechtigung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckBerechtigung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckBerechtigung.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.Berechtigungsaeinschränkung)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckDokStatus_Click Method

Private Sub mnuDruckDokStatus_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckDokStatus.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckDokStatus_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckDokStatus.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.DokumentStatus)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckDokumentwerte_Click Method

Private Sub mnuDruckDokumentwerte_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckDokumentwerte.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckDokumentwerte_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckDokumentwerte.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.DokumentWerte)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckErsetzte_Click Method

Private Sub mnuDruckErsetzte_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckErsetzte.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckErsetzte_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckErsetzte.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.ErsetzteDokumente)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckInfoMeldung_Click Method

Private Sub mnuDruckInfoMeldung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckInfoMeldung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckInfoMeldung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckInfoMeldung.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.Informationsmeldungen)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckNotizen_Click Method

Private Sub mnuDruckNotizen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckNotizen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckNotizen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckNotizen.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.Notizen)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuDruckZuordnung_Click Method

Private Sub mnuDruckZuordnung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDruckZuordnung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDruckZuordnung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDruckZuordnung.Click
        Try
            DruckMetaDaten(EnumMetaDatenDruckTyp.DokumentZuordnungen)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuFreitextSuche_Click Method

Private Sub mnuFreitextSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuFreitextSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuFreitextSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuFreitextSuche.Click
        Dim s As String
        s = InputBox("Suchbegriff", "EDOKA-Freitextsuche")
        If s = "" Then Exit Sub
        If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
            Dim d As DataTable
            Dim x As New frmcoldview()
            d = x.Freitextsuche(Me.DokList.DataSource, s, "HOST")
            Me.DokList.DataSource = d
            x.Dispose()
        End If
        Try
            If Me.DokList.Columns("nrauf00").Text <> "" Then
                Dim d As DataTable
                Dim x As New frmcoldview()
                d = x.Freitextsuche(Me.DokList.DataSource, s, "UVM")
                Me.DokList.DataSource = d
                x.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnuSendMessage_Click Method

Private Sub mnuSendMessage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuSendMessage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuSendMessage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSendMessage.Click
        '*************************************************************
        'Sendet eine EDOKA-Meldung mit der gewählten DokID
        '
        'Ersteller: bud
        'Erstellt am: 09.08.2004
        'Rel 3.2
        '*************************************************************
        Dim fMessage As New frmMeldungen()
        Dim f As New frmMessageWeiterleitung()
        Dim sMessage As String

        f.TextBox1.Text = ""
        f.TextBox2.Text = ""

        f.propBezeichnung = Me.DokList.Columns("Bezeichnung").Value
        f.propINFO = Me.DokList.Columns("Erstellungsdatum").Value
        f.propPartnerNR = Me.DokList.Columns("partnernr").Value
        '
        'Me.DokList.Columns("nrpar00").CellValue(e.Row)
        f.TextBox2.Enabled = True
        f.ShowDialog()

        If f.Empfaenger > 0 Then
            fMessage.propWithDokID = True
            fMessage.propDokID = Me.DokList.Columns("dokumentid").Value
            fMessage.propBetreff = f.TextBox2.Text
            fMessage.propEmpfaenger = f.Empfaenger
            fMessage.propMeldungText = f.TextBox1.Text
            fMessage.Generic_Select(5)
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.mnublkunde_Click Method

Private Sub mnublkunde_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnublkunde.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnublkunde_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnublkunde.Click
        Dim f As New frmBLDossier()
        f.NRPar00 = Me.Partnernr
        f.MdiParent = Me.MdiParent
        f.Profilnr = Me.Profilnr
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.nrpar00_KeyDown Method

Private Sub nrpar00_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtnrpar00.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub nrpar00_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtnrpar00.KeyDown
        If e.KeyCode = Keys.Enter Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.refresh_list Method

Public Sub refresh_list()

Source code

[Visual Basic]
    Public Sub refresh_list()
        If On_Load Then Exit Sub
        Globals.PerfMon.insert_entry("'-- Begin Aufbau Strukturbaum")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Me.DokList.DataSource = Nothing
        Me.TabControl1.Visible = False
        Me.DokList.Enabled = False
        Dim d As New edokadb.clsMyDokumentart()
        Globals.hasmessage = 0
        Me.tvstruktur.BeginUpdate()

        d.SelectPartner = True
        If Partner_Eingegeben And Microsoft.VisualBasic.Left(Me.LblSearch.Text, Len(Me.LblSearch.Text) - 1) = Me.MenuItemPartnersuche.Text Then
            Me.on_refresh = True
            d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.txtnrpar00.Text, Nothing, 1, 1, True)
            If Me.tvstruktur.GetNodeCount(False) = 0 Then
                Me.tvstruktur.Nodes.Add("Keine Daten vorhanden")
            End If
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            Me.Partnernr = LTrim(RTrim(Me.txtnrpar00.Text))
            Name_of_Trefferliste()
            Me.tvstruktur.SelectedNode.ExpandAll()

            Me.Button3.Enabled = False
            Me.Button4.Enabled = False
            Me.lblpageno.Text = 1
            Me.on_refresh = False
        Else
            If Partner_Eingegeben Then
                d.SearchString = UCase(Microsoft.VisualBasic.Left(Me.LblSearch.Text, 2) + ":" + Me.txtnrpar00.Text)
                If CurrentPage = 1 Then tpagemax(0) = 0
            Else
                d.SearchString = ""
            End If

            If tpagemin(CurrentPage) = 0 Then
                'd.FirstEntry = 0
                d.FirstEntry = tpagemax(CurrentPage - 1)
                d.LastEntry = 999999999
            Else
                d.FirstEntry = tpagemin(CurrentPage)
                d.LastEntry = tpagemax(CurrentPage)
            End If
            d.PageDirection = Me.PageDirection
            If Partner_Eingegeben Then
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, True)
            Else
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, False)
            End If

            If tpagemin(CurrentPage) = 0 Then
                Me.tpagemin(CurrentPage) = d.FirstEntry
                Me.tpagemax(CurrentPage) = d.LastEntry
            End If

            If Me.CurrentPage = 1 Then Me.Button3.Enabled = False Else Me.Button3.Enabled = True
            If d.PageDirection > 0 Or maxpage > CurrentPage Then Me.PageDirection = 1 Else Me.PageDirection = 0
            If Me.CurrentPage >= Me.maxpage Then Me.maxpage = Me.CurrentPage
            Me.lblpageno.Text = Me.CurrentPage.ToString
        End If

        'Me.tvstruktur.ExpandAll()
        If Me.tvstruktur.GetNodeCount(False) = 1 Then
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            getnodedepth(Me.tvstruktur.SelectedNode)
            Name_of_Trefferliste()
            Me.Update_Partnerstruktur()
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If
        If Me.tvstruktur.GetNodeCount(False) = 0 Then
            Me.tvstruktur.Nodes.Add("Keine Daten vorhanden")
        End If
        Me.DokList.Enabled = True
        Me.tvstruktur.EndUpdate()
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("'-- Ende Aufbau Strukturbaum")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.set_abgeschlossen_menu Method

Private Sub set_abgeschlossen_menu( _
   ByVal bDokIstVertraulich As Boolean, _
   ByVal dtCTM As DataTable _
)

Parameters

bDokIstVertraulich
Required.
dtCTM
Required.

Source code

[Visual Basic]
    Private Sub set_abgeschlossen_menu(ByVal bDokIstVertraulich As Boolean, ByVal dtCTM As DataTable)
        Try
            Me.MnuABDokAufheben.Enabled = False
            Me.MnuABDokLoeschen.Enabled = False
            Me.MenuItem38.Visible = False

            If dtCTM.Rows(0).Item("indexmutation") <> 0 Then
                If bDokIstVertraulich = False Then
                    Me.MenuItem21.Enabled = True
                End If
                'Me.MenuItem38.Enabled = True
            End If
            If dtCTM.Rows(0).Item("aufhebung") <> 0 Then
                Me.MnuABDokAufheben.Enabled = True
                If bDokIstVertraulich = False Then
                    Me.MenuItem21.Enabled = True
                End If
            End If
            If dtCTM.Rows(0).Item("loeschung") <> 0 Then
                If Me.DokList.Columns("aktivesdokument").Value = True Then
                    Me.MnuABDokLoeschen.Enabled = True
                End If
                'Me.MenuItem21.Enabled = True
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::Error occured." & ex.Message, ex)
        Finally

        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.set_combo Method

Public Sub set_combo( _
   ByVal pnr As Integer _
)

Parameters

pnr
Required.

Source code

[Visual Basic]
    Public Sub set_combo(ByVal pnr As Integer)
        Dim i As Integer
        Dim ii As Integer
        Me.On_Load = True
        For i = 0 To Me.ImgCombo.Items.Count - 1
            Me.ImgCombo.SelectedIndex = i
            ii = Me.ImgCombo.SelectedValue
            If ii = pnr Then Me.ImgCombo.SelectedIndex = i
        Next
        Me.ImgCombo.SelectedValue = pnr
        Me.Profilnr = pnr
        Me.OnlySelect = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.set_tips Method

Private Sub set_tips()

Source code

[Visual Basic]
    Private Sub set_tips()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.Button3, Globals.MyTxt.gettext(22100))
        ttip.SetToolTip(Me.Button5, Globals.MyTxt.gettext(22101))
        ttip.SetToolTip(Me.Button6, Globals.MyTxt.gettext(22102))
        ttip.SetToolTip(Me.Button4, Globals.MyTxt.gettext(22103))
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22104))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_AfterExpand Method

Private Sub tvstruktur_AfterExpand( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles tvstruktur.AfterExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_AfterExpand(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles tvstruktur.AfterExpand
        Try
            Me.tvstruktur.SelectedNode.ExpandAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_AfterSelect Method

Private Sub tvstruktur_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles tvstruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles tvstruktur.AfterSelect
        m_OrgData_change = False
        If on_refresh Then Exit Sub
        If Me.tvstruktur.SelectedNode.Text = "HOST " Then Exit Sub
        Try
            If Len(Trim(Me.tvstruktur.SelectedNode.Tag)) < 9 Then Me.on_refresh = True
        Catch
        End Try
        'Me.tvstruktur.BeginUpdate()
        Globals.PerfMon.insert_entry("Start Auswahl Strukturbaum (Click)")
        Dim splitter() As String
        Dim i As Integer
        i = getnodedepth(Me.tvstruktur.SelectedNode)
        Try
            Me.savenode.ForeColor = Black
        Catch
        End Try
        Me.tvstruktur.SelectedNode.ForeColor = Red
        Me.savenode = Me.tvstruktur.SelectedNode
        Me.tvstruktur.BeginUpdate()
        If InStr(LTrim(Me.tvstruktur.SelectedNode.Tag), " ") > 0 Then
            splitter = Split(LTrim(Me.tvstruktur.SelectedNode.Tag), " ")
            Try
                Me.SelectedDocart = splitter(1)
                Update_Doklist()
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            Catch
                Me.SelectedDocart = ""
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            End Try
        Else
            Me.SelectedDocart = ""
            Update_Doklist()
            For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                Me.ContextMenu2.MenuItems(i).Enabled = True
            Next
        End If
        Me.tvstruktur.EndUpdate()
        Me.Cursor = Cursors.Default
        Me.on_refresh = False
        Globals.PerfMon.insert_entry("Stop Auswahl Strukturbaum (Click)")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_BeforeExpand Method

Private Sub tvstruktur_BeforeExpand( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles tvstruktur.BeforeExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_BeforeExpand(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles tvstruktur.BeforeExpand
        Try
            If Me.On_Load Then Exit Sub
            If Me.on_refresh Then Exit Sub
            'Me.tvstruktur.BeginUpdate()
            If Me.tvstruktur.SelectedNode.IsExpanded = False Then
                Globals.PerfMon.insert_entry("Start Strukturelement öffnen")
                Update_Partnerstruktur()
                Globals.PerfMon.insert_entry("Stop Strukturelement öffnen")
            End If
            'Me.tvstruktur.EndUpdate()
            Me.Cursor = Cursors.Default
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_DoubleClick Method

Private Sub tvstruktur_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles tvstruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles tvstruktur.DoubleClick
        If Me.tvstruktur.SelectedNode.Text = "HOST " Then
            Me.Update_Partnerstruktur()
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_MouseEnter Method

Private Sub tvstruktur_MouseEnter( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles tvstruktur.MouseEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_MouseEnter(ByVal sender As Object, ByVal e As System.EventArgs) Handles tvstruktur.MouseEnter
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.tvstruktur_MouseMove Method

Private Sub tvstruktur_MouseMove( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvstruktur.MouseMove

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvstruktur.MouseMove
        Try
            If e.X < 10 Then
                selp.Y = e.Y
                selp.X = e.X
                Dim i As Integer
                i = Me.tvstruktur.GetNodeAt(selp).Index + 1
                If i = 1 Then
                    tt.RemoveAll()
                    Exit Sub
                End If
                tt.SetToolTip(Me.tvstruktur, Str(i) + " / " + Str(Me.tvstruktur.Nodes.Count))
                tt.AutoPopDelay = 500
            Else
                tt.RemoveAll()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.txtbcknr_KeyDown Method

Private Sub txtbcknr_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtbcknr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtbcknr_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtbcknr.KeyDown
        If e.KeyCode = Keys.Enter Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "sp_search_bck"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtbcknr.Text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@OldDokumentFound", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@rc").Value = 0 Then
                    If scmCmdToExecute.Parameters("@OldDokumentFound").Value = 0 Then
                        Me.txtnrpar00.Text = scmCmdToExecute.Parameters("@nrpar00").Value
                    Else
                        'DokumentID/Barcode wurde durch eine neue Erstezt
                        MyMsg.show_standardmessage(502, MsgBoxStyle.Information)						 'Ein Dokument mit der eingegeben ID/Barcodekleber-Nr wurde durch eine neue ID/Barcodekleber-Nr. erstezt.
                        Me.txtnrpar00.Text = scmCmdToExecute.Parameters("@nrpar00").Value
                    End If
                    DoKeyenter()
                Else
                    MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
                End If

            Catch ex As Exception
                MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste.txtnrpar00_textchanged Method

Private Sub txtnrpar00_textchanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtnrpar00.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtnrpar00_textchanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtnrpar00.TextChanged
        If Me.txtnrpar00.Text = "" Then Me.Partner_Eingegeben = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferliste Fields

frmTrefferliste overview

Fields

field AlleDokumente
field BtnHelp
field BtnPrint
field BtnProfil
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field ColdList
field ColdListDokumente
field ContextMenu1
field ContextMenu10
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field ContextMenuAllgemein
field ContextMenuBerechtigung
field ContextMenuInfoMeldung
field CurrentPage
field DataSet1
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field HOSTDATEN
field ImageList1
field ImageList2
field ImageList3
field ImageList3_Sik
field ImageList4
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LblSearch
field LoadProfiles
field M_FROMMENU
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem56
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemISINSUche
field MenuItemPartnersuche
field MenuItemVVSuche
field MenuItemValorSuche
field MnuABDokAufheben
field MnuABDokLoeschen
field MnuAbgeschlossen
field MnuClose
field MnuDokumentSelect
field MnuDokumentreaktivieren
field MnuNotizanzeigen
field MnuProfil
field MnuSearch
field Notizlist
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PreviewAlleDokumente
field RBStatusAktuell
field RBStatusHistory
field SearchTip
field Splitter1
field Splitter2
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field Statuslist
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton7
field UVMDaten
field ZVDaten
field Zuordnungslist
field al
field bcknr
field bntNewDoc
field btnExit
field btnPartnersuche
field cbProfile
field cmitprofil
field colornotset
field components
field doklistrowcount
field drpMiatarbeiter
field lblpageno
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_ColdListWidthOrg
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_FirstEntry
field m_LastEntry
field m_OrgData_change
field m_OrgData_dt
field m_bInakAlt
field m_bInakVersant
field m_dokumentbezeichnung
field m_dokumentdatum
field m_geschaeftsfall
field m_onlyselect
field m_pagedirection
field m_partnernr
field m_profilnr
field m_refresh
field m_sTempColdDokID
field m_selectedbeschreibung
field m_selecteddocart
field m_selecteddokumentid
field maxpage
field mnuDokKopieren
field mnuDokTypInfo
field mnuDruckAllgemein
field mnuDruckBerechtigung
field mnuDruckDokStatus
field mnuDruckDokumentwerte
field mnuDruckErsetzte
field mnuDruckInfoMeldung
field mnuDruckNotizen
field mnuDruckZuordnung
field mnuFreitextSuche
field mnuSendMessage
field mnu_gelabgesch
field mnu_gelversant
field mnublkunde
field on_refresh
field pnlSearch
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field savenode
field scolor1
field scolor2
field scolor3
field scolor4
field scolor5
field scolor6
field selectPoint
field selp
field statushistory
field tpagemax
field tpagemin
field tt
field ttip
field tvstruktur
field txtbcknr
field txtnrpar00
field update_host
field vertraulich

See Also

frmTrefferliste Class


AlleDokumente Variable

Dim AlleDokumente As Boolean = False

Source code

[Visual Basic]
    Dim AlleDokumente As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


BtnPrint Variable

Friend WithEvents BtnPrint As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents BtnPrint As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


BtnProfil Variable

Friend WithEvents BtnProfil As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents BtnProfil As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Button9 Variable

Friend WithEvents Button9 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button9 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ColdListDokumente Variable

Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu10 Variable

Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenu9 Variable

Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenuAllgemein Variable

Friend WithEvents ContextMenuAllgemein As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenuAllgemein As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenuBerechtigung Variable

Friend WithEvents ContextMenuBerechtigung As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenuBerechtigung As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ContextMenuInfoMeldung Variable

Friend WithEvents ContextMenuInfoMeldung As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenuInfoMeldung As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


CurrentPage Variable

Dim CurrentPage As Integer

Source code

[Visual Basic]
    Dim CurrentPage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ErsetzteDokumenteList Variable

Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


HOSTDATEN Variable

Dim HOSTDATEN As Boolean

Source code

[Visual Basic]
    Dim HOSTDATEN As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImageList3_Sik Variable

Friend WithEvents ImageList3_Sik As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3_Sik As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ImageList4 Variable

Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


LblSearch Variable

Friend WithEvents LblSearch As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LblSearch As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


LoadProfiles Variable

Dim LoadProfiles As Boolean = False

Source code

[Visual Basic]
    Dim LoadProfiles As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


M_FROMMENU Variable

Dim M_FROMMENU As Boolean = False

Source code

[Visual Basic]
    Dim M_FROMMENU As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem23 Variable

Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem28 Variable

Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem29 Variable

Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem30 Variable

Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem31 Variable

Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem32 Variable

Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem33 Variable

Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem34 Variable

Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem35 Variable

Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem36 Variable

Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem37 Variable

Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem38 Variable

Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem39 Variable

Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem40 Variable

Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem41 Variable

Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem42 Variable

Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem43 Variable

Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem44 Variable

Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem45 Variable

Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem46 Variable

Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem47 Variable

Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem48 Variable

Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem49 Variable

Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem50 Variable

Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem51 Variable

Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem52 Variable

Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem53 Variable

Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem56 Variable

Friend WithEvents MenuItem56 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem56 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItemISINSUche Variable

Friend WithEvents MenuItemISINSUche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemISINSUche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItemPartnersuche Variable

Friend WithEvents MenuItemPartnersuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemPartnersuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItemVVSuche Variable

Friend WithEvents MenuItemVVSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemVVSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MenuItemValorSuche Variable

Friend WithEvents MenuItemValorSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemValorSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuABDokAufheben Variable

Friend WithEvents MnuABDokAufheben As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuABDokAufheben As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuABDokLoeschen Variable

Friend WithEvents MnuABDokLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuABDokLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuAbgeschlossen Variable

Friend WithEvents MnuAbgeschlossen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAbgeschlossen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuClose Variable

Friend WithEvents MnuClose As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuClose As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuDokumentSelect Variable

Friend WithEvents MnuDokumentSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuDokumentreaktivieren Variable

Friend WithEvents MnuDokumentreaktivieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentreaktivieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuNotizanzeigen Variable

Friend WithEvents MnuNotizanzeigen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNotizanzeigen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuProfil Variable

Friend WithEvents MnuProfil As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuProfil As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


MnuSearch Variable

Friend WithEvents MnuSearch As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuSearch As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


PreviewAlleDokumente Variable

Dim PreviewAlleDokumente As Boolean = False

Source code

[Visual Basic]
    Dim PreviewAlleDokumente As Boolean = False 'koe 29.09.2003

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


RBStatusAktuell Variable

Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


RBStatusHistory Variable

Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SearchTip Variable

Dim SearchTip As New ToolTip()

Source code

[Visual Basic]
    Dim SearchTip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Statuslist Variable

Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPage3 Variable

Private WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Private WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageAllgemein Variable

Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageBerechtigung Variable

Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageDokumentwerte Variable

Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageInfomeldung Variable

Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageNotizen Variable

Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageStatus Variable

Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TabPageZuordnung Variable

Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox11 Variable

Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox12 Variable

Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox13 Variable

Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox14 Variable

Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox15 Variable

Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox16 Variable

Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox17 Variable

Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox18 Variable

Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


UVMDaten Variable

Dim UVMDaten As Boolean

Source code

[Visual Basic]
    Dim UVMDaten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ZVDaten Variable

Dim ZVDaten As Boolean

Source code

[Visual Basic]
    Dim ZVDaten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


Zuordnungslist Variable

Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


al Variable

Dim al As New ArrayList()

Source code

[Visual Basic]
    Dim al As New ArrayList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


bcknr Variable

Dim bcknr As Integer

Source code

[Visual Basic]
    Dim bcknr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


bntNewDoc Variable

Friend WithEvents bntNewDoc As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents bntNewDoc As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


btnExit Variable

Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


btnPartnersuche Variable

Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


cbProfile Variable

Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


cmitprofil Variable

Friend WithEvents cmitprofil As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cmitprofil As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


colornotset Variable

Dim colornotset As Boolean = False

Source code

[Visual Basic]
    Dim colornotset As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


doklistrowcount Variable

Dim doklistrowcount As Long

Source code

[Visual Basic]
    Dim doklistrowcount As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblpageno Variable

Friend WithEvents lblpageno As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpageno As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur1 Variable

Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur2 Variable

Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur3 Variable

Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur4 Variable

Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur5 Variable

Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


lblzensur6 Variable

Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_ColdListDokumenteDefaultWidth Variable

Dim m_ColdListDokumenteDefaultWidth As Integer = 336

Source code

[Visual Basic]
    Dim m_ColdListDokumenteDefaultWidth As Integer = 336           ' Breite des Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_ColdListWidthOrg Variable

Dim m_ColdListWidthOrg As Integer

Source code

[Visual Basic]
    Dim m_ColdListWidthOrg As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_DTMitarbeiter Variable

Dim m_DTMitarbeiter As DataTable

Source code

[Visual Basic]
    Dim m_DTMitarbeiter As DataTable            'koe 28.07.2004

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_ExpandColdListDokumente Variable

Dim m_ExpandColdListDokumente As Integer = 0

Source code

[Visual Basic]
    Dim m_ExpandColdListDokumente As Integer = 0            'koe Anzahl der Expandet Spalten in Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_FirstEntry Variable

Dim m_FirstEntry As Integer

Source code

[Visual Basic]
    Dim m_FirstEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_LastEntry Variable

Dim m_LastEntry As Integer

Source code

[Visual Basic]
    Dim m_LastEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_OrgData_change Variable

Dim m_OrgData_change As Boolean = False

Source code

[Visual Basic]
    Dim m_OrgData_change As Boolean = False 'Daten haben sich geändert für Datenselektion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_OrgData_dt Variable

Dim m_OrgData_dt As DataTable

Source code

[Visual Basic]
    Dim m_OrgData_dt As DataTable 'Für die Datenselektion bei Inaktiven und versanten Dokumenten

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_bInakAlt Variable

Dim m_bInakAlt As Boolean = False

Source code

[Visual Basic]
    Dim m_bInakAlt As Boolean = False 'Inaktive gelöschte / aufgehobene

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_bInakVersant Variable

Dim m_bInakVersant As Boolean = False

Source code

[Visual Basic]
    Dim m_bInakVersant As Boolean = False 'Inaktive gelösche und versante Dokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_dokumentbezeichnung Variable

Dim m_dokumentbezeichnung As String

Source code

[Visual Basic]
    Dim m_dokumentbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_dokumentdatum Variable

Dim m_dokumentdatum As DateTime

Source code

[Visual Basic]
    Dim m_dokumentdatum As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_geschaeftsfall Variable

Dim m_geschaeftsfall As String

Source code

[Visual Basic]
    Dim m_geschaeftsfall As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_onlyselect Variable

Dim m_onlyselect As Boolean = False

Source code

[Visual Basic]
    Dim m_onlyselect As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_pagedirection Variable

Dim m_pagedirection As Integer

Source code

[Visual Basic]
    Dim m_pagedirection As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_partnernr Variable

Dim m_partnernr As String

Source code

[Visual Basic]
    Dim m_partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_refresh Variable

Dim m_refresh As Boolean = False

Source code

[Visual Basic]
    Dim m_refresh As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_sTempColdDokID Variable

Dim m_sTempColdDokID As String

Source code

[Visual Basic]
    Dim m_sTempColdDokID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_selectedbeschreibung Variable

Dim m_selectedbeschreibung As String

Source code

[Visual Basic]
    Dim m_selectedbeschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_selecteddocart Variable

Dim m_selecteddocart As String

Source code

[Visual Basic]
    Dim m_selecteddocart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


m_selecteddokumentid Variable

Dim m_selecteddokumentid As String

Source code

[Visual Basic]
    Dim m_selecteddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


maxpage Variable

Dim maxpage As Integer

Source code

[Visual Basic]
    Dim maxpage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDokKopieren Variable

Friend WithEvents mnuDokKopieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDokKopieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDokTypInfo Variable

Friend WithEvents mnuDokTypInfo As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDokTypInfo As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckAllgemein Variable

Friend WithEvents mnuDruckAllgemein As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckAllgemein As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckBerechtigung Variable

Friend WithEvents mnuDruckBerechtigung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckBerechtigung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckDokStatus Variable

Friend WithEvents mnuDruckDokStatus As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckDokStatus As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckDokumentwerte Variable

Friend WithEvents mnuDruckDokumentwerte As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckDokumentwerte As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckErsetzte Variable

Friend WithEvents mnuDruckErsetzte As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckErsetzte As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckInfoMeldung Variable

Friend WithEvents mnuDruckInfoMeldung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckInfoMeldung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckNotizen Variable

Friend WithEvents mnuDruckNotizen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckNotizen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuDruckZuordnung Variable

Friend WithEvents mnuDruckZuordnung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDruckZuordnung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuFreitextSuche Variable

Friend WithEvents mnuFreitextSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuFreitextSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnuSendMessage Variable

Friend WithEvents mnuSendMessage As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuSendMessage As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnu_gelabgesch Variable

Friend WithEvents mnu_gelabgesch As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents mnu_gelabgesch As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnu_gelversant Variable

Friend WithEvents mnu_gelversant As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents mnu_gelversant As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


mnublkunde Variable

Friend WithEvents mnublkunde As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnublkunde As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


on_refresh Variable

Dim on_refresh As Boolean = False

Source code

[Visual Basic]
    Dim on_refresh As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlSearch Variable

Friend WithEvents pnlSearch As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlSearch As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur1 Variable

Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur2 Variable

Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur3 Variable

Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur4 Variable

Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur5 Variable

Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


pnlzensur6 Variable

Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


savenode Variable

Dim savenode As New TreeNode()

Source code

[Visual Basic]
    Dim savenode As New TreeNode()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor1 Variable

Dim scolor1 As Color

Source code

[Visual Basic]
    Dim scolor1 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor2 Variable

Dim scolor2 As Color

Source code

[Visual Basic]
    Dim scolor2 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor3 Variable

Dim scolor3 As Color

Source code

[Visual Basic]
    Dim scolor3 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor4 Variable

Dim scolor4 As Color

Source code

[Visual Basic]
    Dim scolor4 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor5 Variable

Dim scolor5 As Color

Source code

[Visual Basic]
    Dim scolor5 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


scolor6 Variable

Dim scolor6 As Color

Source code

[Visual Basic]
    Dim scolor6 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


selp Variable

Dim selp As New System.Drawing.Point()

Source code

[Visual Basic]
    Dim selp As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


statushistory Variable

Dim statushistory As Boolean

Source code

[Visual Basic]
    Dim statushistory As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


tpagemax Variable

Dim tpagemax( _
   99 _
) As Integer

Source code

[Visual Basic]
    Dim tpagemax(99) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


tpagemin Variable

Dim tpagemin( _
   99 _
) As Integer

Source code

[Visual Basic]
    Dim tpagemin(99) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


tt Variable

Dim tt As New ToolTip()

Source code

[Visual Basic]
    Dim tt As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


ttip Variable

Dim ttip As New ToolTip()

Source code

[Visual Basic]
    Dim ttip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


tvstruktur Variable

Friend WithEvents tvstruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents tvstruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


txtbcknr Variable

Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


txtnrpar00 Variable

Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


update_host Variable

Dim update_host As Boolean = False

Source code

[Visual Basic]
    Dim update_host As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


vertraulich Variable

Dim vertraulich As Boolean = False

Source code

[Visual Basic]
    Dim vertraulich As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferliste


frmTrefferlistex Class

For a list of all members of this type, see frmTrefferlistex Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmTrefferlistex

Public Class frmTrefferlistex
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmTrefferlistex Members


frmTrefferlistex Members

frmTrefferlistex overview

Constructors

constructor frmTrefferlistex Constructor

Properties

property DoRefresh
property Dokumentbezeichnung
property FirstEntry
property FromMenu
property Geschaeftsfall
property ImgCombo
property LastEntry
property OnlySelect
property PageDirection
property Partner_Eingegeben
property Partnernr
property Profilnr
property SelectedBeschreibung
property SelectedDocart
property SelectedDokumentid
property dokumentdatum

Methods

method Alle_Dokumente_Des_Geschaeftsfalles |
method BtnHelp_Click |
method Button1_Click |
method Button2_Click |
method Button3_Click |
method Button4_Click |
method Button5_Click |
method Button6_Click |
method Button9_Click |
method C1TrueDBGrid1_FetchCellStyle |
method Check_DokisInDB | Prüft ob ein Officedokument in der Datenbank vorhanden ist.
method ColdListDokumente_Collapse |
method ColdListDokumente_Expand |
method ColdListDokumente_Leave |
method ColdListDokumente_MouseUp |
method ColdListDokumente_RowColChange |
method Cold_Index_lesen |
method ContextMenu10_Popup |
method ContextMenu1_Popup |
method ContextMenu2_Popup |
method ContextMenu7_Popup |
method ContextMenu8_Popup |
method ContextMenu9_Popup |
method Create_Dokument |
method Create_Search_Menu |
method Dispose |
method DoKeyenter |
method DokList_Click |
method DokList_DoubleClick |
method DokList_MouseDown |
method DokList_MouseUp |
method DokList_RowColChange |
method DokList_SelChange |
method Doklist_FetchScrollTips |
method Dokumente_lesen |
method Dokumentfunktionen_Laden |
method Dokumentinfomeldungen_laden |
method Dokumentwert_lesen |
method Dokumentzuordnungen_Laden |
method ErsetzteDokumente_Laden |
method FetchRowStyle |
method Form1_Load |
method Generic_Select |
method GetNode |
method InfoMeldungList_FetchRowStyle |
method Init_Pages |
method InitializeComponent |
method Load_Layout |
method Load_Profiles |
method MenuItem10_Click |
method MenuItem11_Click |
method MenuItem12_Click |
method MenuItem14_Click |
method MenuItem15_Click |
method MenuItem16_Click |
method MenuItem17_Click |
method MenuItem18_Click |
method MenuItem19_Click |
method MenuItem1_Click |
method MenuItem21_Click |
method MenuItem22_Click |
method MenuItem24_Click |
method MenuItem25_Click |
method MenuItem26_Click |
method MenuItem27_Click |
method MenuItem28_Click |
method MenuItem29_Click |
method MenuItem2_Click |
method MenuItem31_Click |
method MenuItem32_Click |
method MenuItem33_Popup |
method MenuItem34_Click |
method MenuItem35_Click |
method MenuItem37_Click |
method MenuItem39_Click |
method MenuItem3_Click |
method MenuItem40_Click |
method MenuItem41_Click |
method MenuItem43_Click |
method MenuItem44_Click |
method MenuItem46_Click |
method MenuItem47_Click |
method MenuItem48_Click |
method MenuItem49_Click |
method MenuItem4_Click |
method MenuItem50_Click |
method MenuItem51_Click |
method MenuItem6_Click |
method MenuItem7_Click |
method MenuItem8_Click |
method MenuItemISINSUche_Click |
method MenuItemPartnersuche_Click |
method MenuItemVVSuche_Click |
method MenuItemValorSuche_Click |
method Mitarbeiter_Laden |
method MnuABDokAufheben_Click |
method MnuABDokIndexMutation_Click |
method MnuABDokLoeschen_Click |
method MnuClose_Click |
method MnuDokumentSelect_Click |
method MnuDokumentreaktivieren_Click |
method MnuNotizanzeigen_Click |
method Name_of_Trefferliste |
method Notizen_Laden |
method Notizlist_MouseDown |
method PosDok |
method RBStatusAktuell_Click |
method Refresh_All |
method Save_Layout |
method Set_Colors |
method Status_lesen |
method Statuslist_FetchRowStyle |
method TVstruktur_MouseDown |
method TabControl1_Click |
method TabControl1_SelectedIndexChanged |
method TabPage1_Click |
method TabPageDokumentwerte_Click |
method ToolBar1_ButtonClick |
method Update_ColdListDokumente_Detail |
method Update_Coldindex |
method Update_DetailInformation |
method Update_Details |
method Update_Doklist |
method Update_DokumentInfoMeldung |
method Update_Dokumentfunktionen |
method Update_Dokumentzuordnung |
method Update_Ersetzte_Dokumente |
method Update_Notizen |
method Update_Partnerstruktur |
method Update_Status |
method btnPartnersuche_VisibleChanged |
method cbProfile_SelectedIndexChanged |
method check_bearbeitung |
method check_dokumentreaktivieren |
method dokument_ist_abgeschlossen |
method frmTrefferliste_Closing |
method frmTrefferliste_Resize |
method gaga |
method getnodedepth |
method imgcombo_SelectedIndexChanged_1 |
method isbck |
method lblpageno_TextChanged |
method mnuFreitextSuche_Click |
method mnuSendMessage_Click |
method nrpar00_KeyDown |
method refresh_list |
method set_abgeschlossen_menu |
method set_combo |
method set_tips |
method tvstruktur_AfterExpand |
method tvstruktur_AfterSelect |
method tvstruktur_BeforeExpand |
method tvstruktur_DoubleClick |
method tvstruktur_MouseEnter |
method tvstruktur_MouseMove |
method txtbcknr_KeyDown |
method txtnrpar00_textchanged |

Fields

field AlleDokumente
field BtnHelp
field BtnPrint
field BtnProfil
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field ColdList
field ColdListDokumente
field ContextMenu1
field ContextMenu10
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field CurrentPage
field DataSet1
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field HOSTDATEN
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LblSearch
field LoadProfiles
field M_FROMMENU
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem54
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemISINSUche
field MenuItemPartnersuche
field MenuItemVVSuche
field MenuItemValorSuche
field MnuABDokAufheben
field MnuABDokLoeschen
field MnuAbgeschlossen
field MnuClose
field MnuDokumentSelect
field MnuDokumentreaktivieren
field MnuNotizanzeigen
field MnuProfil
field MnuSearch
field Notizlist
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PreviewAlleDokumente
field RBStatusAktuell
field RBStatusHistory
field SearchTip
field Splitter1
field Splitter2
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field Statuslist
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field UVMDaten
field ZVDaten
field Zuordnungslist
field al
field bcknr
field bntNewDoc
field btnExit
field btnPartnersuche
field cbProfile
field cmitprofil
field colornotset
field components
field doklistrowcount
field drpMiatarbeiter
field lblpageno
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_FirstEntry
field m_LastEntry
field m_dokumentbezeichnung
field m_dokumentdatum
field m_geschaeftsfall
field m_onlyselect
field m_pagedirection
field m_partnernr
field m_profilnr
field m_refresh
field m_selectedbeschreibung
field m_selecteddocart
field m_selecteddokumentid
field maxpage
field mnuFreitextSuche
field mnuSendMessage
field on_refresh
field pnlSearch
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field savenode
field scolor1
field scolor2
field scolor3
field scolor4
field scolor5
field scolor6
field selectPoint
field selp
field statushistory
field tpagemax
field tpagemin
field tt
field ttip
field tvstruktur
field txtbcknr
field txtnrpar00
field update_host
field vertraulich

See Also

frmTrefferlistex Class


frmTrefferlistex Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()
        Me.FirstEntry = 0
        Me.LastEntry = 0
        Me.PageDirection = 0

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

        Dim i As Integer
        On_Load = True
        ImgCombo = New ImageComboBox(Me.cbProfile)
        ImgCombo.ImageList = Me.ImageList2
        Load_Profiles()
        al.Clear()
        Dim a As String
        Dim b As Integer
        Dim c As Integer
        Try
            Me.LoadProfiles = True
            For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
                a = Me.DataSet1.Tables(0).Rows(i).Item("bezeichnung")
                b = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                c = Me.DataSet1.Tables(0).Rows(i).Item("Profiltyp") - 1
                al.Add(New ImgGenericList(a, b, c))
            Next
        Catch ex As Exception
            'MsgBox(ex.Message)
        End Try

        ImgCombo.DataSource = al
        ImgCombo.DisplayMember = "Display"
        ImgCombo.ValueMember = "ID"
        ImgCombo.ImageIndexMember = "Index"
        ImgCombo.BringToFront()
        ImgCombo.Enabled = True
        ImgCombo.Visible = True
        Dim i1 As Integer
        Dim i2 As Integer
        Dim xx As Integer
        If Globals.profilnr = 0 Then
            For i = 0 To Me.DataSet1.Tables(0).Rows.Count - 1
                If Me.DataSet1.Tables(0).Rows(i).Item("standard") = True And Me.Profilnr = 0 Then
                    Me.ImgCombo.SelectedValue = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                    Me.Profilnr = Me.DataSet1.Tables(0).Rows(i).Item("profilnr")
                End If
            Next
        Else
            Me.ImgCombo.SelectedValue = Globals.profilnr
            Me.Profilnr = Globals.profilnr
            Globals.profilnr = 0
        End If
        Me.LoadProfiles = False
        Name_of_Trefferliste()
        Globals.DokumentartenImages = Me.ImageList3
        On_Load = False
        Set_Colors()
        set_tips()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex Properties

frmTrefferlistex overview

Properties

property DoRefresh
property Dokumentbezeichnung
property FirstEntry
property FromMenu
property Geschaeftsfall
property ImgCombo
property LastEntry
property OnlySelect
property PageDirection
property Partner_Eingegeben
property Partnernr
property Profilnr
property SelectedBeschreibung
property SelectedDocart
property SelectedDokumentid
property dokumentdatum

See Also

frmTrefferlistex Class


frmTrefferlistex.DoRefresh Property

Property DoRefresh() As Boolean

Source code

[Visual Basic]
    Property DoRefresh() As Boolean
        Get
            Return m_refresh
        End Get
        Set(ByVal Value As Boolean)
            m_refresh = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumentbezeichnung Property

Property Dokumentbezeichnung() As String

Source code

[Visual Basic]
    Property Dokumentbezeichnung() As String
        Get
            Return m_dokumentbezeichnung
        End Get
        Set(ByVal Value As String)
            m_dokumentbezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.FirstEntry Property

Property FirstEntry() As Integer

Source code

[Visual Basic]
    Property FirstEntry() As Integer
        Get
            Return m_FirstEntry
        End Get
        Set(ByVal Value As Integer)
            m_FirstEntry = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.FromMenu Property

Property FromMenu() As Boolean

Source code

[Visual Basic]
    Property FromMenu() As Boolean
        Get
            Return M_FROMMENU
        End Get
        Set(ByVal Value As Boolean)
            M_FROMMENU = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Geschaeftsfall Property

Property Geschaeftsfall() As String

Source code

[Visual Basic]
    Property Geschaeftsfall() As String
        Get
            Return m_geschaeftsfall
        End Get
        Set(ByVal Value As String)
            m_geschaeftsfall = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ImgCombo Property

Public WithEvents ImgCombo As ImageComboBox

Source code

[Visual Basic]
    Public WithEvents ImgCombo As ImageComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.LastEntry Property

Property LastEntry() As Integer

Source code

[Visual Basic]
    Property LastEntry() As Integer
        Get
            Return m_LastEntry
        End Get
        Set(ByVal Value As Integer)
            m_LastEntry = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.OnlySelect Property

Property OnlySelect() As Boolean

Source code

[Visual Basic]
    Property OnlySelect() As Boolean
        Get
            Return m_onlyselect
        End Get
        Set(ByVal Value As Boolean)
            m_onlyselect = False
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.PageDirection Property

Property PageDirection() As Integer

Source code

[Visual Basic]
    Property PageDirection() As Integer
        Get
            Return m_pagedirection
        End Get
        Set(ByVal Value As Integer)
            m_pagedirection = Value
            Try
                If m_pagedirection > 0 Then Me.Button4.Enabled = True Else Me.Button4.Enabled = False
            Catch
            End Try
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Partner_Eingegeben Property

Public Partner_Eingegeben As Boolean

Source code

[Visual Basic]
    Public Partner_Eingegeben As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As String)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Profilnr Property

Property Profilnr() As Long

Source code

[Visual Basic]
    Property Profilnr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
            '            MsgBox(m_profilnr)
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.SelectedBeschreibung Property

Property SelectedBeschreibung()

Source code

[Visual Basic]
    Property SelectedBeschreibung()
        Get
            Return m_selectedbeschreibung
        End Get
        Set(ByVal Value)
            m_selectedbeschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.SelectedDocart Property

Property SelectedDocart() As String

Source code

[Visual Basic]
    Property SelectedDocart() As String
        Get
            Return m_selecteddocart
        End Get
        Set(ByVal Value As String)
            m_selecteddocart = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.SelectedDokumentid Property

Property SelectedDokumentid() As String

Source code

[Visual Basic]
    Property SelectedDokumentid() As String
        Get
            Return m_selecteddokumentid
        End Get
        Set(ByVal Value As String)
            m_selecteddokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.dokumentdatum Property

Property dokumentdatum() As DateTime

Source code

[Visual Basic]
    Property dokumentdatum() As DateTime
        Get
            Return m_dokumentdatum
        End Get
        Set(ByVal Value As DateTime)
            m_dokumentdatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex Methods

frmTrefferlistex overview

Methods

method Alle_Dokumente_Des_Geschaeftsfalles |
method BtnHelp_Click |
method Button1_Click |
method Button2_Click |
method Button3_Click |
method Button4_Click |
method Button5_Click |
method Button6_Click |
method Button9_Click |
method C1TrueDBGrid1_FetchCellStyle |
method Check_DokisInDB | Prüft ob ein Officedokument in der Datenbank vorhanden ist.
method ColdListDokumente_Collapse |
method ColdListDokumente_Expand |
method ColdListDokumente_Leave |
method ColdListDokumente_MouseUp |
method ColdListDokumente_RowColChange |
method Cold_Index_lesen |
method ContextMenu10_Popup |
method ContextMenu1_Popup |
method ContextMenu2_Popup |
method ContextMenu7_Popup |
method ContextMenu8_Popup |
method ContextMenu9_Popup |
method Create_Dokument |
method Create_Search_Menu |
method Dispose |
method DoKeyenter |
method DokList_Click |
method DokList_DoubleClick |
method DokList_MouseDown |
method DokList_MouseUp |
method DokList_RowColChange |
method DokList_SelChange |
method Doklist_FetchScrollTips |
method Dokumente_lesen |
method Dokumentfunktionen_Laden |
method Dokumentinfomeldungen_laden |
method Dokumentwert_lesen |
method Dokumentzuordnungen_Laden |
method ErsetzteDokumente_Laden |
method FetchRowStyle |
method Form1_Load |
method Generic_Select |
method GetNode |
method InfoMeldungList_FetchRowStyle |
method Init_Pages |
method InitializeComponent |
method Load_Layout |
method Load_Profiles |
method MenuItem10_Click |
method MenuItem11_Click |
method MenuItem12_Click |
method MenuItem14_Click |
method MenuItem15_Click |
method MenuItem16_Click |
method MenuItem17_Click |
method MenuItem18_Click |
method MenuItem19_Click |
method MenuItem1_Click |
method MenuItem21_Click |
method MenuItem22_Click |
method MenuItem24_Click |
method MenuItem25_Click |
method MenuItem26_Click |
method MenuItem27_Click |
method MenuItem28_Click |
method MenuItem29_Click |
method MenuItem2_Click |
method MenuItem31_Click |
method MenuItem32_Click |
method MenuItem33_Popup |
method MenuItem34_Click |
method MenuItem35_Click |
method MenuItem37_Click |
method MenuItem39_Click |
method MenuItem3_Click |
method MenuItem40_Click |
method MenuItem41_Click |
method MenuItem43_Click |
method MenuItem44_Click |
method MenuItem46_Click |
method MenuItem47_Click |
method MenuItem48_Click |
method MenuItem49_Click |
method MenuItem4_Click |
method MenuItem50_Click |
method MenuItem51_Click |
method MenuItem6_Click |
method MenuItem7_Click |
method MenuItem8_Click |
method MenuItemISINSUche_Click |
method MenuItemPartnersuche_Click |
method MenuItemVVSuche_Click |
method MenuItemValorSuche_Click |
method Mitarbeiter_Laden |
method MnuABDokAufheben_Click |
method MnuABDokIndexMutation_Click |
method MnuABDokLoeschen_Click |
method MnuClose_Click |
method MnuDokumentSelect_Click |
method MnuDokumentreaktivieren_Click |
method MnuNotizanzeigen_Click |
method Name_of_Trefferliste |
method Notizen_Laden |
method Notizlist_MouseDown |
method PosDok |
method RBStatusAktuell_Click |
method Refresh_All |
method Save_Layout |
method Set_Colors |
method Status_lesen |
method Statuslist_FetchRowStyle |
method TVstruktur_MouseDown |
method TabControl1_Click |
method TabControl1_SelectedIndexChanged |
method TabPage1_Click |
method TabPageDokumentwerte_Click |
method ToolBar1_ButtonClick |
method Update_ColdListDokumente_Detail |
method Update_Coldindex |
method Update_DetailInformation |
method Update_Details |
method Update_Doklist |
method Update_DokumentInfoMeldung |
method Update_Dokumentfunktionen |
method Update_Dokumentzuordnung |
method Update_Ersetzte_Dokumente |
method Update_Notizen |
method Update_Partnerstruktur |
method Update_Status |
method btnPartnersuche_VisibleChanged |
method cbProfile_SelectedIndexChanged |
method check_bearbeitung |
method check_dokumentreaktivieren |
method dokument_ist_abgeschlossen |
method frmTrefferliste_Closing |
method frmTrefferliste_Resize |
method gaga |
method getnodedepth |
method imgcombo_SelectedIndexChanged_1 |
method isbck |
method lblpageno_TextChanged |
method mnuFreitextSuche_Click |
method mnuSendMessage_Click |
method nrpar00_KeyDown |
method refresh_list |
method set_abgeschlossen_menu |
method set_combo |
method set_tips |
method tvstruktur_AfterExpand |
method tvstruktur_AfterSelect |
method tvstruktur_BeforeExpand |
method tvstruktur_DoubleClick |
method tvstruktur_MouseEnter |
method tvstruktur_MouseMove |
method txtbcknr_KeyDown |
method txtnrpar00_textchanged |

See Also

frmTrefferlistex Class


frmTrefferlistex.Alle_Dokumente_Des_Geschaeftsfalles Method

Public Sub Alle_Dokumente_Des_Geschaeftsfalles()

Source code

[Visual Basic]
    Public Sub Alle_Dokumente_Des_Geschaeftsfalles()
        Dim d As New edokadb.clsMyDokumentart()
        d.SearchString = 0
        d.FirstEntry = 1
        d.LastEntry = 99999999
        d.Geschaeftsfall = Me.Geschaeftsfall
        d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, False)
        d.Geschaeftsfall = Me.Geschaeftsfall
        PreviewAlleDokumente = True  'neu koe 29.09.2003
        If Me.tvstruktur.GetNodeCount(False) = 1 Then
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            Me.Update_Partnerstruktur()
            Me.tvstruktur.ExpandAll()
        End If
        AlleDokumente = True
        Update_Doklist()
        AlleDokumente = False
        Me.Text = Me.Text + " - Geschäftsfall: " + Me.Geschaeftsfall
        Me.cbProfile.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("Trefferliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnersuche.Click
        Dim f As New FrmPartnersuche()
        f.NurAbfrage = True
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            Me.Cursor = Cursors.WaitCursor
            Me.txtnrpar00.Text = f.PartnerNr
            Me.Partner_Eingegeben = True
            refresh_list()
            Me.Cursor = Cursors.Default
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Update_Doklist()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Me.tvstruktur.BeginUpdate()
        Me.CurrentPage = CurrentPage - 1
        If Me.CurrentPage < 1 Then Me.CurrentPage = 1
        Me.Partner_Eingegeben = False
        Me.on_refresh = True
        refresh_list()
        Me.on_refresh = False
        Me.tvstruktur.EndUpdate()
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button4_Click Method

Private Sub Button4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button4.Click
        Me.tvstruktur.BeginUpdate()
        Me.CurrentPage = CurrentPage + 1
        Me.PageDirection = 2
        Me.Partner_Eingegeben = False
        Me.on_refresh = True
        refresh_list()
        Me.on_refresh = False
        Me.tvstruktur.EndUpdate()
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button5_Click Method

Private Sub Button5_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button5.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button5_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button5.Click
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button6_Click Method

Private Sub Button6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button6.Click
        Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(Me.tvstruktur.GetNodeCount(False) - 1)
        Me.tvstruktur.Focus()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Button9_Click Method

Private Sub Button9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button9.Click
        Dim f As New frmProfilinfo()
        f.ProfilNr = Me.Profilnr
        f.Text = f.Text + Me.ImgCombo.Text
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.C1TrueDBGrid1_FetchCellStyle Method

Private Sub C1TrueDBGrid1_FetchCellStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs _
) Handles DokList.FetchCellStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchCellStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellStyleEventArgs) Handles DokList.FetchCellStyle
        Try
            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(e.Row), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(e.Row), Me.DokList.Columns("dokumentid").CellValue(e.Row), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(e.Row), "")
            If d.Rows.Count = 0 Then
                e.CellStyle.ForeColor = Color.Transparent
                '                Me.DokList.Splits(0).DisplayColumns("Bemerkung").Width = 0
                'Me.DokList.Splits(0).DisplayColumns("Bemerkung").Style.ForeColor = System.Drawing.Color.Transparent
                Me.vertraulich = True
                Exit Sub
            End If
            If d.Rows(0).Item("anzeigen") = 0 Then
                Me.vertraulich = True
                e.CellStyle.ForeColor = Color.Transparent
                Exit Sub
            End If
            d.Dispose()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Check_DokisInDB Method

Prüft ob ein Officedokument in der Datenbank vorhanden ist.

Private Function Check_DokisInDB() As Boolean

Author

Daniel Burren

Version

08.11.2004

Source code

[Visual Basic]
    Private Function Check_DokisInDB() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)

            If scmCmdToExecute.Parameters("@office").Value > 0 Then
                Check_DokisInDB = True
            Else
                Check_DokisInDB = False
            End If

        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ColdListDokumente_Collapse Method

Private Sub ColdListDokumente_Collapse( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs _
) Handles ColdListDokumente.Collapse

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Collapse(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs) Handles ColdListDokumente.Collapse
        Dim iCnt As Integer
        m_ColdListDokumenteDefaultWidth = ColdListDokumente.Splits(0).DisplayColumns("dokumentbezeichnung").Width + ColdListDokumente.Splits(0).DisplayColumns("status").Width + ColdListDokumente.Splits(0).DisplayColumns("archivdatum").Width + 25

        Try
            m_ExpandColdListDokumente = m_ExpandColdListDokumente - 1
            If m_ExpandColdListDokumente < 0 Then m_ExpandColdListDokumente = 0
            If m_ExpandColdListDokumente < 1 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        'Spalten ausblenden
                    Case "STATUSALT", "ARCHIVDATUMALT"
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                            ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
                    End Select
                Next
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ColdListDokumente_Expand Method

Private Sub ColdListDokumente_Expand( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs _
) Handles ColdListDokumente.Expand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Expand(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.BandEventArgs) Handles ColdListDokumente.Expand
        Dim iCnt As Integer
        m_ColdListDokumenteDefaultWidth = ColdListDokumente.Splits(0).DisplayColumns("dokumentbezeichnung").Width + ColdListDokumente.Splits(0).DisplayColumns("status").Width + ColdListDokumente.Splits(0).DisplayColumns("archivdatum").Width + 25

        Try
            m_ExpandColdListDokumente = m_ExpandColdListDokumente + 1
            If m_ExpandColdListDokumente < 2 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        Case "STATUSALT", "ARCHIVDATUMALT"
                            m_ColdListDokumenteDefaultWidth = m_ColdListDokumenteDefaultWidth + ColdListDokumente.Splits(0).DisplayColumns(iCnt).Width
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = True
                    End Select
                Next
                ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
            End If
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ColdListDokumente_Leave Method

Private Sub ColdListDokumente_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ColdListDokumente.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles ColdListDokumente.Leave
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ColdListDokumente_MouseUp Method

Private Sub ColdListDokumente_MouseUp( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles ColdListDokumente.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_MouseUp(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles ColdListDokumente.MouseUp
        Dim iCnt As Integer
        Dim sDokID As String
        Dim sDokstatus As String
        Dim iStapelNr As Integer
        Try
            Update_ColdListDokumente_Detail(True)
            If ColdListDokumente.Col > 5 Then
                For iCnt = 0 To ColdListDokumente.Columns.Count - 1
                    Select Case UCase(ColdListDokumente.Columns(iCnt).DataField)
                        Case "STAPELNR"
                            iStapelNr = ColdListDokumente.Columns(iCnt).Text
                        Case "COLDDOKID"
                            sDokID = ColdListDokumente.Columns(iCnt).Text
                        Case "STATUSALT"
                            sDokstatus = ColdListDokumente.Columns(iCnt).Text
                    End Select
                Next
                For iCnt = 0 To ColdList.Splits(0).Rows.Count - 1
                    ColdList.Bookmark = iCnt
                    Select Case ColdList.Columns("indexfeld_nr").CellText(iCnt)
                        Case 11 ' Stapelnummer
                            ColdList.Columns("IndexWert").Text = Format(iStapelNr, "0#####")
                        Case 7  'Dokumentstatus
                            ColdList.Columns("IndexWert").Text = sDokstatus
                        Case 10  'Dokumentid
                            ColdList.Columns("IndexWert").Text = sDokID
                    End Select
                Next
                ColdList.Bookmark = 0
            Else

            End If
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ColdListDokumente_RowColChange Method

Private Sub ColdListDokumente_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles ColdListDokumente.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ColdListDokumente_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles ColdListDokumente.RowColChange
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Cold_Index_lesen Method

Public Function Cold_Index_lesen( _
   ByVal indextyp As Integer, _
   ByVal iRoot As Integer _
) As DataTable

Parameters

indextyp
Required.
iRoot
Required.

Source code

[Visual Basic]
    Public Function Cold_Index_lesen(ByVal indextyp As Integer, ByVal iRoot As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Coldindex"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Root", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iRoot))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu10_Popup Method

Private Sub ContextMenu10_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu10.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu10_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu10.Popup
        If Me.ErsetzteDokumenteList.Splits(0).Rows.Count = 0 Then Me.MenuItem27.Enabled = False Else Me.MenuItem27.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        Dim i As Integer
        Dim User_Hat_Berechtigung As Boolean = False
            If Me.DokList.Splits(0).Rows.Count < 1 Then
                For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                    Me.ContextMenu1.MenuItems(i).Enabled = False
                Next
                Exit Sub
            End If

            Dim bm As Object
            For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                If Me.Partnernr < 1 Then
                    Me.ContextMenu1.MenuItems(i).Enabled = False
                Else
                    Me.ContextMenu1.MenuItems(i).Enabled = True
                End If
            Next

            Try
                If Trim(Me.DokList.Columns("Geschaeftsfall").Text.ToString) <> "" Then
                    Me.MenuItem49.Enabled = True
                Else
                    Me.MenuItem49.Enabled = False
                End If
            Catch

            End Try

            If Globals.Bearbeitung_Problemdokumente = True Then
                Me.MenuItem29.Enabled = False
                Me.MenuItem31.Enabled = False
            End If
            Try
                Me.Cursor = Cursors.WaitCursor
                Dim d As New DataTable()
                Me.MenuItem3.Enabled = False
                Me.MenuItem4.Enabled = False
                Me.MenuItem44.Enabled = False
                Me.MenuItem6.Enabled = False
                Me.MenuItem16.Enabled = False
                Me.MenuItem21.Enabled = True
                Me.MenuItem33.Enabled = False
                Try
                    If UVMDaten Or ZVDaten Or HOSTDATEN Then
                        For i = 0 To Me.ContextMenu1.MenuItems.Count - 1
                            Me.ContextMenu1.MenuItems(i).Enabled = False
                        Next
                        Me.ContextMenu1.MenuItems(0).Enabled = True
                        Me.MenuItem24.Enabled = True
                        Me.MenuItem25.Enabled = True
                        Me.MenuItem33.Enabled = True
                        Me.MenuItem43.Enabled = True
                        Exit Sub
                    End If
                Catch
                End Try

                d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
                If d.Rows.Count > 0 Then User_Hat_Berechtigung = True
                Try
                    If d.Rows(0).Item("anzeigen") = 1 Then
                        Me.MenuItem4.Enabled = True
                        Me.MenuItem44.Enabled = True
                        Me.MenuItem33.Enabled = True
                    End If
                Catch
                End Try

                Try
                    If d.Rows(0).Item("bearbeiten") = 1 Then
                        Me.MenuItem3.Enabled = True
                        Me.MenuItem21.Enabled = True
                        Me.MenuItem6.Enabled = True
                    End If
                Catch
                End Try
                Try
                    If d.Rows(0).Item("loeschen") = 1 Then Me.MenuItem16.Enabled = True
                Catch
                End Try

                If (Me.DokList.Columns("verantwortlich").Value <> Globals.MitarbeiterNr) And Globals.stv = 0 Then
                    Me.MenuItem3.Enabled = False
                    Me.MenuItem21.Enabled = True
                    If Not dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text) Then
                    Else
                        set_abgeschlossen_menu()
                    End If
                    Me.MenuItem6.Enabled = False
                    Me.MenuItem16.Enabled = False
                Else
                    If Not dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text) Then
                        Me.MenuItem4.Enabled = True
                        Me.MenuItem44.Enabled = True
                        Me.MenuItem33.Enabled = True
                        Me.MenuItem3.Enabled = True
                        Me.MenuItem21.Enabled = True
                        Me.MenuItem6.Enabled = True
                        If d.Rows(0).Item("loeschen") = 1 Then Me.MenuItem16.Enabled = True
                    Else
                        set_abgeschlossen_menu()
                        Me.MenuItem3.Enabled = False
                        'Me.MenuItem21.Enabled = False
                        Me.MenuItem6.Enabled = False
                        Me.MenuItem16.Enabled = False
                    End If
                End If

                If Me.DokList.Columns("status_bezeichnungnr").Value = -2 Or Me.DokList.Columns("status_bezeichnungnr").Value = -3 Then
                    Me.MnuAbgeschlossen.Enabled = True
                    set_abgeschlossen_menu()
                    If Me.DokList.Columns("status_bezeichnungnr").Value = -2 Then
                        If check_bearbeitung() = True Then Me.MenuItem3.Enabled = True
                    End If
                    If Me.MnuABDokAufheben.Enabled = True Or Me.MnuABDokLoeschen.Enabled = True Then
                        Me.MnuDokumentreaktivieren.Visible = False
                    Else
                        If check_dokumentreaktivieren() = True Then
                            Me.MnuDokumentreaktivieren.Visible = True
                        Else
                            Me.MnuDokumentreaktivieren.Visible = False
                        End If
                    End If
                Else
                    Me.MnuAbgeschlossen.Enabled = False
                    set_abgeschlossen_menu()
                End If

                'Bedingt Retournierbares Dokument
                If DivFnkt.BDR_Dokument(Me.DokList.Columns("dokumentid").Text) Then
                    Me.MenuItem3.Enabled = False

                End If
                Me.Cursor = Cursors.Default
            Catch ex As Exception
            End Try
            Try
                If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                    Me.MenuItem4.Enabled = True
                    Me.MenuItem3.Enabled = True
                    Me.MenuItem16.Enabled = True
                    Me.MenuItem6.Enabled = True
                    Me.MenuItem21.Enabled = True
                    Me.MnuABDokAufheben.Enabled = True
                    Me.MnuABDokLoeschen.Enabled = True
                    Me.MenuItem38.Visible = True
                    Me.MnuDokumentreaktivieren.Visible = True
                    Me.MenuItem50.Visible = True
                    Me.MenuItem51.Visible = True
                Else
                    '                Me.MenuItem38.Visible = False
                    '               Me.MenuItem50.Visible = False
                    '              Me.MenuItem51.Visible = False
                End If
            Catch
            End Try
            Try
                If User_Hat_Berechtigung Then MenuItem33_Popup(sender, e)
            Catch
            End Try

            Try
                If Me.DokList.Columns("geschaeftsfall").Text.ToString <> "" Then
                    Me.MenuItem49.Enabled = True
                    Me.MenuItem3.Enabled = False
                    Me.MenuItem16.Enabled = False
                    Me.MenuItem6.Enabled = False
                    'Me.MenuItem21.Enabled = False
                    If Not User_Hat_Berechtigung Then
                        Me.MenuItem4.Enabled = False
                        Me.MenuItem33.Enabled = False
                        Me.MenuItem44.Enabled = False
                    End If
                Else
                    Me.MenuItem49.Enabled = False
                End If
            Catch
            End Try
            'Rel 3.3
            '08.11.2004 / BUD
            If Me.MenuItem44.Enabled = True Then
                If Check_DokisInDB() = False Then
                    Me.MenuItem44.Enabled = False
                End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu2_Popup Method

Private Sub ContextMenu2_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu2_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu2.Popup
        Try
            Dim i As Integer
            If Me.tvstruktur.SelectedNode.ImageIndex = -1 Then
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = False
                Next
            Else
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next

            End If
            If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                Me.MenuItem46.Visible = True
            Else
                Me.MenuItem46.Visible = False
            End If
            If Globals.Bearbeitung_Problemdokumente = True Then
                Me.MenuItem12.Enabled = False
                Me.MenuItem15.Enabled = False
            End If
            Try
                Me.mnuFreitextSuche.Visible = False
                If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then Me.mnuFreitextSuche.Visible = True
                If Me.DokList.Columns("nrauf00").Text <> "" Then Me.mnuFreitextSuche.Visible = True
            Catch
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu7_Popup Method

Private Sub ContextMenu7_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu7.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu7_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu7.Popup
        If Me.Zuordnungslist.Splits(0).Rows.Count > 0 Then
            If Trim(Me.Zuordnungslist.Columns("ErstellungIn").Text.ToString) = "" Then
                MenuItem26.Enabled = True
                MenuItem47.Enabled = True
                MenuItem48.Enabled = False
            Else
                MenuItem26.Enabled = False
                MenuItem47.Enabled = False
                MenuItem48.Enabled = True
            End If
        Else
            MenuItem26.Enabled = False
            MenuItem47.Enabled = False
            MenuItem48.Enabled = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu8_Popup Method

Private Sub ContextMenu8_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu8.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu8_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu8.Popup
        If Len(Me.ColdListDokumente.Columns("colddokumentid").Text) = 0 Then
            Me.MenuItem28.Enabled = False
        Else
            Me.MenuItem28.Enabled = True
        End If
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
            Me.MenuItem38.Visible = True
            Me.MenuItem38.Enabled = True
            Me.MenuItem50.Visible = True
            Me.MenuItem51.Visible = True
            Me.MenuItem38.Visible = True
            Me.MenuItem38.Enabled = True
            Me.MenuItem50.Visible = True
            Me.MenuItem51.Visible = True
        Else
            Me.MenuItem38.Visible = False
            Me.MenuItem38.Enabled = False
            Me.MenuItem50.Visible = False
            Me.MenuItem51.Visible = False

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ContextMenu9_Popup Method

Private Sub ContextMenu9_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu9.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu9_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu9.Popup
        If DivFnkt.MA_Is_Sysadmin(Globals.MitarbeiterNr) = False Then MenuItem32.Enabled = False Else MenuItem32.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Create_Dokument Method

Public Sub Create_Dokument( _
   ByVal BestehenderPartner As Boolean, _
   ByVal showfavoriten As Boolean _
)

Parameters

BestehenderPartner
Required.
showfavoriten
Required.

Source code

[Visual Basic]
    Public Sub Create_Dokument(ByVal BestehenderPartner As Boolean, ByVal showfavoriten As Boolean)
        Dim n As New TreeNode()
        Dim f As New frmVorlagenauswahl()
        f.TVStruktur.ImageList = Me.ImageList3
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Me.Profilnr = Me.ImgCombo.SelectedValue
        f.Show_Favoriten = showfavoriten
        f.ProfilNr = Me.Profilnr
        f.Profile = Me.DataSet1.Tables(0)
        f.Dokumentart = Me.SelectedDocart
        Globals.Individuelles_Dokumentpaket = False
        Globals.DokumentPaket = False
        f.ShowDialog()
        f.Hide()
        Windows.Forms.Application.DoEvents()
        If f.DialogResult = DialogResult.OK Then
            If Globals.DokumentPaket = True Then
                If Globals.Individuelles_Dokumentpaket = True Then
                    MsgBox("Individuelles Dokumentpaket erstellen")
                    Exit Sub
                Else
                    MsgBox("Standard-Dokumentpaket erstellen")
                    Exit Sub
                End If
            End If
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            If Globals.bckdokument = False And Not Globals.EinzelDokument Then
                Dim fI As New frmDokumentbearbeitung()
                fI.Profilnr = Me.Profilnr
                fI.Profile = Me.DataSet1.Tables(0)
                If BestehenderPartner = True Then
                    If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                        MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                        f.Dispose()
                        fi.Dispose()
                        Me.Cursor = System.Windows.Forms.Cursors.Default
                        Exit Sub
                    End If
                    fI.Partnernr = Me.Partnernr
                Else
                    fI.Partnernr = ""
                End If
                fI.Dokumenttypnr = f.Dokumentvorlage
                fI.CreateDocument = True
                fI.BarcodeID = f.BarcodeID
                f.Dispose()
                fI.ShowDialog()
                fI.Hide()
                Windows.Forms.Application.DoEvents()
            Else
                If Globals.bckdokument = True Then
                    Dim fi As New frmDokumentbearbeitungBC()
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    If BestehenderPartner = True Then
                        If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                            MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                            f.Dispose()
                            fi.Dispose()
                            Me.Cursor = System.Windows.Forms.Cursors.Default
                            Exit Sub
                        End If
                        fI.Partnernr = Me.Partnernr
                    Else
                        fI.Partnernr = ""
                    End If
                    fI.Dokumenttypnr = f.Dokumentvorlage
                    fI.CreateDocument = True
                    fI.BarcodeID = f.BarcodeID
                    f.Dispose()
                    fI.ShowDialog()
                    fI.Hide()
                    Windows.Forms.Application.DoEvents()
                Else
                    Dim fi As New frmDokumentbearbeitungED()
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    If BestehenderPartner = True Then
                        If Me.Partnernr > 91000000 And DivFnkt.EDOKA_Partner_Dokument(3, f.Dokumentvorlage) = False Then
                            MyMsg.show_standardmessage(110, MsgBoxStyle.Critical)
                            f.Dispose()
                            fi.Dispose()
                            Me.Cursor = System.Windows.Forms.Cursors.Default
                            Exit Sub
                        End If
                        fI.Partnernr = Me.Partnernr
                    Else
                        fI.Partnernr = ""
                    End If
                    fI.Dokumenttypnr = f.Dokumentvorlage
                    fI.CreateDocument = True
                    fI.BarcodeID = f.BarcodeID
                    f.Dispose()
                    fI.ShowDialog()
                    fI.Hide()

                End If
            End If
        End If
        Me.ToolBar1.Buttons(5).ImageIndex = 8
        '        n = Me.savenode
        '        Me.on_refresh = True
        '       refresh_list()
        '      Me.savenode = n
        '     Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        'Me.on_refresh = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Create_Search_Menu Method

Private Sub Create_Search_Menu()

Source code

[Visual Basic]
    Private Sub Create_Search_Menu()
        Dim odm As New OwnerMenu()
        odm.Add(Me.MenuItemPartnersuche, New Bitmap(Me.ImageList3.Images(18)), 0, False)

        odm.Add(Me.MenuItemVVSuche, New Bitmap(Me.ImageList3.Images(15)), 1, False)
        odm.Add(Me.MenuItemValorSuche, New Bitmap(Me.ImageList3.Images(15)), 2, False)
        odm.Add(Me.MenuItemISINSUche, New Bitmap(Me.ImageList3.Images(15)), 3, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DoKeyenter Method

Public Sub DoKeyenter()

Source code

[Visual Basic]
    Public Sub DoKeyenter()
        If Me.txtnrpar00.Text = "" Then
            Me.txtnrpar00.Focus()
            Exit Sub
        End If
        Init_Pages()

        If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
            While Len(Me.txtnrpar00.Text) < 16
                Me.txtnrpar00.Text = "0" + Me.txtnrpar00.Text
            End While
        End If

        If Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":" Then
            Try
                Dim d As Integer
                d = Val(Me.txtnrpar00.Text)
                Me.txtnrpar00.Text = d
            Catch
                MyMsg.show_standardmessage(22, MsgBoxStyle.Critical)
                Me.txtnrpar00.Focus()
                Me.txtnrpar00.SelectAll()
                Exit Sub
            End Try
        End If
        Globals.PerfMon.insert_entry("Start Partner ausgewählt")
        Me.Cursor = Cursors.WaitCursor
        Partner_Eingegeben = True
        refresh_list()
        If Me.btnPartnersuche.Visible = True Then Me.Refresh_All(True)
        Me.Cursor = Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partner ausgewählt")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_Click Method

Private Sub DokList_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DokList.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DokList.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_DoubleClick Method

Private Sub DokList_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles DokList.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles DokList.DoubleClick
        Me.MenuItem4_Click(sender, e)
        'Try
        '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
        '        DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
        '        DivFnkt.ShowColdDocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
        '        Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttyp").Text)
        '        Exit Sub
        '    End If
        'Catch
        'End Try

        'Try
        '    DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
        '    Me.Cursor = Cursors.Default
        'Catch
        'End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_MouseDown Method

Private Sub DokList_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseDown
        Globals.PerfMon.insert_entry("Start Dokumentwechsel in Dokumentliste")
        Me.DokList.Bookmark = Me.DokList.RowContaining(e.Y)
        Update_DetailInformation()
        Globals.PerfMon.insert_entry("Stop Dokumentwechsel in Dokumentliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_MouseUp Method

Private Sub DokList_MouseUp( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles DokList.MouseUp

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_MouseUp(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles DokList.MouseUp
        '       Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_RowColChange Method

Private Sub DokList_RowColChange( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles DokList.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_RowColChange(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles DokList.RowColChange
        Dim iCnt As Integer
        If m_ExpandColdListDokumente > 0 Then
            m_ExpandColdListDokumente = 0
            For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                    'Spalten ausblenden
                Case "STATUSALT", "ARCHIVDATUMALT"
                        ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                        ColdListDokumente.Width = m_ColdListDokumenteDefaultWidth
                End Select
            Next

        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.DokList_SelChange Method

Private Sub DokList_SelChange( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs _
) Handles DokList.SelChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DokList_SelChange(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.CancelEventArgs) Handles DokList.SelChange
        Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Doklist_FetchScrollTips Method

Private Sub Doklist_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles DokList.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Doklist_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles DokList.FetchScrollTips
        Try
            Select Case e.ScrollBar
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Horizontal
                    e.ScrollTip = Me.DokList.Columns(e.ColIndex).Caption
                Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                    e.ScrollTip = CStr(e.Row + 1) & " of " & _
                        CStr(Me.doklistrowcount)
            End Select
            e.TipStyle.ForeColor = Color.Blue
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumente_lesen Method

Public Function Dokumente_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Dokumente_lesen() As DataTable
        Dim iTag As String
        Dim ipartner As String
        Dim i As Integer
        Try
            iTag = Me.tvstruktur.SelectedNode.Tag
            i = InStr(iTag, "-")
            If i > 0 Then
                ipartner = Val(Microsoft.VisualBasic.Left(iTag, i - 1))
                iTag = Microsoft.VisualBasic.Right(iTag, Len(iTag) - (i + 1))
            Else
                ipartner = Me.Partnernr
                '            ipartner = 0
                iTag = 0
            End If
        Catch
            iTag = 0
            ipartner = 0
            Me.Partnernr = 0
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_getdata_new"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Partnernr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerlist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistdokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, iTag))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistpartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ipartner))
            If Me.txtnrpar00.Text <> "" Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vollstaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vollstaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@partnereingegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            If Me.AlleDokumente = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@alledokumente", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@alledokumente", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))

            If Me.txtnrpar00.Text.Length > 0 Then
                If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "VA:" + Me.txtnrpar00.Text))
                End If
                If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "IS:" + Me.txtnrpar00.Text))
                End If
                If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" And Me.txtnrpar00.Text <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "VV:" + Me.txtnrpar00.Text))
                End If
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Geschaeftsfall))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            'MsgBox(ex.Message)
            '    ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumente lesen::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumentfunktionen_Laden Method

Private Function Dokumentfunktionen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Dokumentfunktionen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_dokumentfunktion_zugewiesen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumentinfomeldungen_laden Method

Private Function Dokumentinfomeldungen_laden()

Source code

[Visual Basic]
    Private Function Dokumentinfomeldungen_laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentinfomeldung_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumentinfomeldung_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumentwert_lesen Method

Public Function Dokumentwert_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Dokumentwert_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Dokumentwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Dokumentzuordnungen_Laden Method

Private Function Dokumentzuordnungen_Laden()

Source code

[Visual Basic]
    Private Function Dokumentzuordnungen_Laden()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Dokumentzuordnungen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ErsetzteDokumente_Laden Method

Private Function ErsetzteDokumente_Laden() As DataTable

Source code

[Visual Basic]
    Private Function ErsetzteDokumente_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_trefferliste_ersetztedokumente"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.FetchRowStyle Method

Private Sub FetchRowStyle( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles DokList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FetchRowStyle(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles DokList.FetchRowStyle

        Dim convcol As New ColorConverter()
        Dim d As DataTable
        Dim i As Integer
        Me.vertraulich = False
        Try
            If Me.DokList.Columns("vertraulich").CellValue(e.Row) = True Then
                d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(e.Row), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(e.Row), Me.DokList.Columns("dokumentid").CellValue(e.Row), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(e.Row), "")

                If d.Rows.Count = 0 Then
                    'e.CellStyle.ForeColor = Color.Transparent
                    Me.vertraulich = True
                    Exit Sub
                End If
                If d.Rows(0).Item("anzeigen") = 0 Then
                    Me.vertraulich = True
                    '                    e.CellStyle.ForeColor = Color.Transparent
                    Exit Sub
                End If
            End If

            'hutter if eingebaut
            'If Globals.Mitarbeiter.iPartnernr.Value <> Me.DokList.Columns("nrpar00").CellValue(e.Row) Then
            'd = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").CellValue(e.Row), Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").CellValue(e.Row), Me.DokList.Columns("dokumentid").CellValue(e.Row), 0, 0, 0, Me.DokList.Columns("vertraulich").CellValue(e.Row), "")
            'If d.Rows.Count = 0 Then
            '    'e.CellStyle.ForeColor = Color.Transparent
            '    '                Me.DokList.Splits(0).DisplayColumns("Bemerkung").Width = 0
            '    'Me.DokList.Splits(0).DisplayColumns("Bemerkung").Style.ForeColor = System.Drawing.Color.Transparent
            '    Me.vertraulich = True
            '    Exit Sub
            'End If
            'If d.Rows(0).Item("anzeigen") = 0 Then
            '    Me.vertraulich = True
            '    e.CellStyle.ForeColor = Color.Transparent
            '    Exit Sub
            'End If
            'End If
            'hutter

            If Me.DokList.Columns("aktivesdokument").CellValue(e.Row) = False Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            End If
            If Me.DokList.Columns("Statusbezeichnungnr").CellValue(e.Row) = -3 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)
            End If
        Catch ex As Exception
        End Try

        If convcol.ConvertToString(scolor1) <> "Control" Then e.CellStyle.ForeColor = scolor1
        Try
            If Me.DokList.Columns("verantwortlich").CellValue(e.Row) = Globals.MitarbeiterNr Then
                If convcol.ConvertToString(scolor2) <> "Control" Then
                    e.CellStyle.ForeColor = scolor2
                    Exit Sub
                End If
            End If

            If Not Me.DokList.Columns("termin").CellValue(e.Row) Is System.DBNull.Value Then
                If Not (Year(Me.DokList.Columns("termin").Value) = 1900) Then
                    'Terminiert
                    If Me.DokList.Columns("termin").CellValue(e.Row) > Microsoft.VisualBasic.Now Then
                        If convcol.ConvertToString(scolor4) <> "Control" Then
                            e.CellStyle.ForeColor = scolor4
                            Exit Sub
                        End If
                    End If
                    'Überfällig
                    If Me.DokList.Columns("termin").CellValue(e.Row) <= Microsoft.VisualBasic.Now Then
                        If convcol.ConvertToString(scolor5) <> "Control" Then
                            e.CellStyle.ForeColor = scolor5
                            Exit Sub
                        End If
                    End If
                End If
            End If

            If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) = 5 Then
                If convcol.ConvertToString(scolor6) <> "Control" Then
                    e.CellStyle.ForeColor = scolor6
                    Exit Sub
                End If
            End If
            If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) = -1 Then
                If convcol.ConvertToString(scolor3) <> "Control" Then
                    e.CellStyle.ForeColor = scolor3
                    Exit Sub
                End If
            End If
            '   If Me.DokList.Columns("status_bezeichnungnr").CellValue(e.Row) > -2 Then
            '   If convcol.ConvertToString(scolor3) <> "Control" Then
            '  e.CellStyle.ForeColor = scolor3
            ' Exit Sub
            'End If
            'End If

            convcol = Nothing

        Catch ex As Exception
            '    MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        AddHandler ImgCombo.SelectedValueChanged, AddressOf imgcombo_SelectedIndexChanged_1
        Init_Pages()
        Me.lblzensur1.Text = MyTxt.gettext(22009)
        Me.lblzensur2.Text = MyTxt.gettext(22009)
        Me.lblzensur3.Text = MyTxt.gettext(22009)
        Me.lblzensur4.Text = MyTxt.gettext(22009)
        Me.lblzensur5.Text = MyTxt.gettext(22009)
        Me.lblzensur6.Text = MyTxt.gettext(22009)

        refresh_list()
        If Me.DoRefresh Then Refresh_All(True)
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.Button2, Globals.MyTxt.gettext(22003))
        ttip.SetToolTip(Me.btnPartnersuche, Globals.MyTxt.gettext(22004))
        ttip.SetToolTip(Me.txtbcknr, Globals.MyTxt.gettext(22005))
        ttip.SetToolTip(Me.cbProfile, Globals.MyTxt.gettext(22006))
        If Me.LblSearch.Visible = False Then
            Me.Label20.Visible = False
            Me.txtbcknr.Visible = False
            Me.Button2.Visible = False
        End If

        If Globals.Bearbeitung_Problemdokumente = True Then
            Me.bntNewDoc.Enabled = False
            Me.ToolBarButton2.Enabled = False
            Me.cbProfile.Visible = False
            Me.LblSearch.Visible = False
            Me.txtnrpar00.Visible = False
            Me.btnPartnersuche.Visible = False
            Me.Button1.Visible = False
            Me.MenuItem29.Enabled = False
            Me.MenuItem31.Enabled = False
            Me.MenuItem15.Enabled = False
            Me.MenuItem12.Enabled = False
            Me.BtnHelp.Visible = True
            Me.Button9.Visible = False
        Else
            Me.bntNewDoc.Enabled = True
            Me.ToolBarButton2.Enabled = True
            Me.cbProfile.Visible = True
            Me.LblSearch.Visible = True
            Me.txtnrpar00.Visible = True
            Me.btnPartnersuche.Visible = True
            If Me.ImgCombo.Visible = False Then
                Me.txtnrpar00.Visible = False
                Me.btnPartnersuche.Visible = False
                Me.Button1.Visible = False
            End If

            Me.MenuItem29.Enabled = True
            Me.MenuItem31.Enabled = True
            Me.MenuItem15.Enabled = True
            Me.MenuItem12.Enabled = True
        End If
        Create_Search_Menu()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        '===============================================================================
        'Description: Dynamische Datenherkuft
        'Input      : Typ
        'Output     : Datatable
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 17
                'Mitarbeiter
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 17
                    'Mitarbeiter
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "&AlleMitarbeiter&"))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Trefferliste::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.GetNode Method

Private Function GetNode( _
   ByVal text As String, _
   ByVal parentCollection As TreeNodeCollection _
) As TreeNode

Parameters

text
Required.
parentCollection
Required.

Source code

[Visual Basic]
    Private Function GetNode(ByVal text As String, ByVal parentCollection As TreeNodeCollection) As TreeNode
        Dim ret As TreeNode
        Dim child As TreeNode

        For Each child In parentCollection 'step through the parentcollection
            If child.Tag = text Then
                ret = child
            ElseIf child.GetNodeCount(False) > 0 Then ' if there is child items then call this function recursively
                ret = GetNode(text, child.Nodes)
            End If
            If Not ret Is Nothing Then Exit For 'if something was found, exit out of the for loop

        Next

        Return ret
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.InfoMeldungList_FetchRowStyle Method

Private Sub InfoMeldungList_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles InfoMeldungList.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub InfoMeldungList_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles InfoMeldungList.FetchRowStyle
        If Me.InfoMeldungList.Columns("typ").CellValue(e.Row) = 1 Then
            e.CellStyle.BackColor = System.Drawing.Color.CadetBlue
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Init_Pages Method

Private Sub Init_Pages()

Source code

[Visual Basic]
    Private Sub Init_Pages()
        Me.PageDirection = 0
        Me.tpagemin(0) = 0
        Me.tpagemax(0) = 999999999
        Me.tpagemin(1) = 0
        Me.tpagemax(1) = 999999999
        Dim i As Integer
        For i = 0 To 99
            Me.tpagemax(i) = 0
            Me.tpagemin(i) = 0
        Next
        Me.CurrentPage = 1
        Me.maxpage = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmTrefferliste))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines4 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines5 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines6 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines7 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines8 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines9 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines10 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnExit = New System.Windows.Forms.ToolBarButton()
        Me.BtnPrint = New System.Windows.Forms.ToolBarButton()
        Me.bntNewDoc = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.BtnProfil = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.MainMenu1 = New System.Windows.Forms.MainMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection3 = New System.Data.SqlClient.SqlConnection()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.MnuProfil = New System.Windows.Forms.ContextMenu()
        Me.txtnrpar00 = New System.Windows.Forms.TextBox()
        Me.MnuSearch = New System.Windows.Forms.ContextMenu()
        Me.MenuItemPartnersuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemVVSuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemValorSuche = New System.Windows.Forms.MenuItem()
        Me.MenuItemISINSUche = New System.Windows.Forms.MenuItem()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.pnlSearch = New System.Windows.Forms.Panel()
        Me.Panel4 = New System.Windows.Forms.Panel()
        Me.tvstruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.MenuItem15 = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem19 = New System.Windows.Forms.MenuItem()
        Me.MenuItem22 = New System.Windows.Forms.MenuItem()
        Me.MenuItem20 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.MenuItem11 = New System.Windows.Forms.MenuItem()
        Me.MenuItem46 = New System.Windows.Forms.MenuItem()
        Me.MenuItem52 = New System.Windows.Forms.MenuItem()
        Me.mnuFreitextSuche = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.lblpageno = New System.Windows.Forms.Label()
        Me.Button8 = New System.Windows.Forms.Button()
        Me.Button7 = New System.Windows.Forms.Button()
        Me.Button6 = New System.Windows.Forms.Button()
        Me.Button5 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MenuItem16 = New System.Windows.Forms.MenuItem()
        Me.MenuItem36 = New System.Windows.Forms.MenuItem()
        Me.MenuItem33 = New System.Windows.Forms.MenuItem()
        Me.MenuItem34 = New System.Windows.Forms.MenuItem()
        Me.MenuItem35 = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem21 = New System.Windows.Forms.MenuItem()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.MenuItem29 = New System.Windows.Forms.MenuItem()
        Me.MenuItem31 = New System.Windows.Forms.MenuItem()
        Me.MenuItem53 = New System.Windows.Forms.MenuItem()
        Me.mnuSendMessage = New System.Windows.Forms.MenuItem()
        Me.MenuItem54 = New System.Windows.Forms.MenuItem()
        Me.MenuItem30 = New System.Windows.Forms.MenuItem()
        Me.MenuItem14 = New System.Windows.Forms.MenuItem()
        Me.MnuAbgeschlossen = New System.Windows.Forms.MenuItem()
        Me.MnuABDokLoeschen = New System.Windows.Forms.MenuItem()
        Me.MnuABDokAufheben = New System.Windows.Forms.MenuItem()
        Me.MnuDokumentreaktivieren = New System.Windows.Forms.MenuItem()
        Me.MenuItem23 = New System.Windows.Forms.MenuItem()
        Me.MenuItem44 = New System.Windows.Forms.MenuItem()
        Me.MenuItem45 = New System.Windows.Forms.MenuItem()
        Me.MenuItem24 = New System.Windows.Forms.MenuItem()
        Me.MenuItem25 = New System.Windows.Forms.MenuItem()
        Me.MenuItem42 = New System.Windows.Forms.MenuItem()
        Me.MenuItem43 = New System.Windows.Forms.MenuItem()
        Me.MenuItem49 = New System.Windows.Forms.MenuItem()
        Me.TabControl1 = New System.Windows.Forms.TabControl()
        Me.TabPageAllgemein = New System.Windows.Forms.TabPage()
        Me.pnlzensur1 = New System.Windows.Forms.Panel()
        Me.lblzensur1 = New System.Windows.Forms.Label()
        Me.TextBox18 = New System.Windows.Forms.TextBox()
        Me.Label19 = New System.Windows.Forms.Label()
        Me.TextBox14 = New System.Windows.Forms.TextBox()
        Me.Label15 = New System.Windows.Forms.Label()
        Me.TextBox13 = New System.Windows.Forms.TextBox()
        Me.Label14 = New System.Windows.Forms.Label()
        Me.TextBox12 = New System.Windows.Forms.TextBox()
        Me.Label12 = New System.Windows.Forms.Label()
        Me.TextBox11 = New System.Windows.Forms.TextBox()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.TextBox10 = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.TextBox9 = New System.Windows.Forms.TextBox()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.TextBox8 = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.TextBox7 = New System.Windows.Forms.TextBox()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.TextBox6 = New System.Windows.Forms.TextBox()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.TextBox5 = New System.Windows.Forms.TextBox()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.TextBox4 = New System.Windows.Forms.TextBox()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.TabPageStatus = New System.Windows.Forms.TabPage()
        Me.Statuslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu9 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem32 = New System.Windows.Forms.MenuItem()
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.RBStatusHistory = New System.Windows.Forms.RadioButton()
        Me.RBStatusAktuell = New System.Windows.Forms.RadioButton()
        Me.TabPageDokumentwerte = New System.Windows.Forms.TabPage()
        Me.TabControl2 = New System.Windows.Forms.TabControl()
        Me.TabPage1 = New System.Windows.Forms.TabPage()
        Me.pnlzensur2 = New System.Windows.Forms.Panel()
        Me.ColdList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.lblzensur2 = New System.Windows.Forms.Label()
        Me.ColdListDokumente = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu8 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem28 = New System.Windows.Forms.MenuItem()
        Me.MenuItem38 = New System.Windows.Forms.MenuItem()
        Me.MenuItem40 = New System.Windows.Forms.MenuItem()
        Me.MenuItem41 = New System.Windows.Forms.MenuItem()
        Me.MenuItem39 = New System.Windows.Forms.MenuItem()
        Me.MenuItem50 = New System.Windows.Forms.MenuItem()
        Me.MenuItem51 = New System.Windows.Forms.MenuItem()
        Me.TabPage3 = New System.Windows.Forms.TabPage()
        Me.TextBox17 = New System.Windows.Forms.TextBox()
        Me.Label18 = New System.Windows.Forms.Label()
        Me.TextBox16 = New System.Windows.Forms.TextBox()
        Me.TextBox15 = New System.Windows.Forms.TextBox()
        Me.Label17 = New System.Windows.Forms.Label()
        Me.Label16 = New System.Windows.Forms.Label()
        Me.TabPageZuordnung = New System.Windows.Forms.TabPage()
        Me.pnlzensur4 = New System.Windows.Forms.Panel()
        Me.lblzensur4 = New System.Windows.Forms.Label()
        Me.Zuordnungslist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu7 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem26 = New System.Windows.Forms.MenuItem()
        Me.MenuItem47 = New System.Windows.Forms.MenuItem()
        Me.MenuItem48 = New System.Windows.Forms.MenuItem()
        Me.TabPageNotizen = New System.Windows.Forms.TabPage()
        Me.pnlzensur5 = New System.Windows.Forms.Panel()
        Me.drpMiatarbeiter = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.lblzensur5 = New System.Windows.Forms.Label()
        Me.Notizlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu4 = New System.Windows.Forms.ContextMenu()
        Me.MnuNotizanzeigen = New System.Windows.Forms.MenuItem()
        Me.TabPageInfomeldung = New System.Windows.Forms.TabPage()
        Me.pnlzensur3 = New System.Windows.Forms.Panel()
        Me.lblzensur3 = New System.Windows.Forms.Label()
        Me.InfoMeldungList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPageBerechtigung = New System.Windows.Forms.TabPage()
        Me.DokumentFunktionenList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.TabPage2 = New System.Windows.Forms.TabPage()
        Me.pnlzensur6 = New System.Windows.Forms.Panel()
        Me.lblzensur6 = New System.Windows.Forms.Label()
        Me.ErsetzteDokumenteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu10 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem27 = New System.Windows.Forms.MenuItem()
        Me.ContextMenu6 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem17 = New System.Windows.Forms.MenuItem()
        Me.MenuItem18 = New System.Windows.Forms.MenuItem()
        Me.cbProfile = New System.Windows.Forms.ComboBox()
        Me.LblSearch = New System.Windows.Forms.Label()
        Me.btnPartnersuche = New System.Windows.Forms.Button()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokumentSelect = New System.Windows.Forms.MenuItem()
        Me.MenuItem37 = New System.Windows.Forms.MenuItem()
        Me.MnuClose = New System.Windows.Forms.MenuItem()
        Me.ImageList4 = New System.Windows.Forms.ImageList(Me.components)
        Me.ContextMenu5 = New System.Windows.Forms.ContextMenu()
        Me.DokList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.cmitprofil = New System.Windows.Forms.CheckBox()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.txtbcknr = New System.Windows.Forms.TextBox()
        Me.Label20 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button9 = New System.Windows.Forms.Button()
        Me.BtnHelp = New System.Windows.Forms.Button()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel1.SuspendLayout()
        Me.pnlSearch.SuspendLayout()
        Me.Panel4.SuspendLayout()
        Me.Panel3.SuspendLayout()
        Me.TabControl1.SuspendLayout()
        Me.TabPageAllgemein.SuspendLayout()
        Me.pnlzensur1.SuspendLayout()
        Me.TabPageStatus.SuspendLayout()
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel2.SuspendLayout()
        Me.TabPageDokumentwerte.SuspendLayout()
        Me.TabControl2.SuspendLayout()
        Me.TabPage1.SuspendLayout()
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage3.SuspendLayout()
        Me.TabPageZuordnung.SuspendLayout()
        Me.pnlzensur4.SuspendLayout()
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageNotizen.SuspendLayout()
        Me.pnlzensur5.SuspendLayout()
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageInfomeldung.SuspendLayout()
        Me.pnlzensur3.SuspendLayout()
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPageBerechtigung.SuspendLayout()
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.TabPage2.SuspendLayout()
        Me.pnlzensur6.SuspendLayout()
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnExit, Me.BtnPrint, Me.bntNewDoc, Me.ToolBarButton2, Me.ToolBarButton4, Me.ToolBarButton3, Me.BtnProfil, Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(984, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnExit
        '
        Me.btnExit.ImageIndex = 0
        Me.btnExit.ToolTipText = "Trefferliste schliessen"
        '
        'BtnPrint
        '
        Me.BtnPrint.ImageIndex = 1
        Me.BtnPrint.ToolTipText = "Trefferliste drucken"
        '
        'bntNewDoc
        '
        Me.bntNewDoc.ImageIndex = 2
        Me.bntNewDoc.ToolTipText = "Neues Dokument erstellen"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 4
        Me.ToolBarButton2.ToolTipText = "Dokument-Favoriten anzeigen"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 7
        Me.ToolBarButton3.ToolTipText = "Partnerstruktur aktualisieren"
        '
        'BtnProfil
        '
        Me.BtnProfil.ImageIndex = 3
        Me.BtnProfil.ToolTipText = "Profil bearbeiten"
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'MainMenu1
        '
        Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem2})
        Me.MenuItem1.Text = "&Trefferliste"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 0
        Me.MenuItem2.Text = "&Schliessen"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "profil", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("profilnr", "profilnr"), New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("standard", "standard"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("color1", "color1"), New System.Data.Common.DataColumnMapping("color2", "color2"), New System.Data.Common.DataColumnMapping("color3", "color3"), New System.Data.Common.DataColumnMapping("color4", "color4"), New System.Data.Common.DataColumnMapping("color5", "color5"), New System.Data.Common.DataColumnMapping("color6", "color6"), New System.Data.Common.DataColumnMapping("color7", "color7"), New System.Data.Common.DataColumnMapping("color8", "color8"), New System.Data.Common.DataColumnMapping("unterschriftlinks", "unterschriftlinks"), New System.Data.Common.DataColumnMapping("unterschriftrechts", "unterschriftrechts"), New System.Data.Common.DataColumnMapping("hw1", "hw1"), New System.Data.Common.DataColumnMapping("hw2", "hw2"), New System.Data.Common.DataColumnMapping("hw3", "hw3"), New System.Data.Common.DataColumnMapping("hw4", "hw4"), New System.Data.Common.DataColumnMapping("hw5", "hw5"), New System.Data.Common.DataColumnMapping("hw6", "hw6"), New System.Data.Common.DataColumnMapping("hw7", "hw7"), New System.Data.Common.DataColumnMapping("hw8", "hw8"), New System.Data.Common.DataColumnMapping("hw9", "hw9"), New System.Data.Common.DataColumnMapping("hw10", "hw10"), New System.Data.Common.DataColumnMapping("hw11", "hw11"), New System.Data.Common.DataColumnMapping("vmb", "vmb"), New System.Data.Common.DataColumnMapping("vnl", "vnl"), New System.Data.Common.DataColumnMapping("vkost", "vkost"), New System.Data.Common.DataColumnMapping("vteam", "vteam"), New System.Data.Common.DataColumnMapping("vma", "vma"), New System.Data.Common.DataColumnMapping("mmb", "mmb"), New System.Data.Common.DataColumnMapping("mnl", "mnl"), New System.Data.Common.DataColumnMapping("mkost", "mkost"), New System.Data.Common.DataColumnMapping("mteam", "mteam"), New System.Data.Common.DataColumnMapping("mma", "mma"), New System.Data.Common.DataColumnMapping("emb", "emb"), New System.Data.Common.DataColumnMapping("enl", "enl"), New System.Data.Common.DataColumnMapping("ekost", "ekost"), New System.Data.Common.DataColumnMapping("eteam", "eteam"), New System.Data.Common.DataColumnMapping("ema", "ema"), New System.Data.Common.DataColumnMapping("dpartner", "dpartner"), New System.Data.Common.DataColumnMapping("ddokart", "ddokart"), New System.Data.Common.DataColumnMapping("ddokstatus", "ddokstatus"), New System.Data.Common.DataColumnMapping("datum1", "datum1"), New System.Data.Common.DataColumnMapping("datum2", "datum2"), New System.Data.Common.DataColumnMapping("datum3", "datum3"), New System.Data.Common.DataColumnMapping("datum4", "datum4"), New System.Data.Common.DataColumnMapping("datum5", "datum5"), New System.Data.Common.DataColumnMapping("datum6", "datum6"), New System.Data.Common.DataColumnMapping("datum7", "datum7"), New System.Data.Common.DataColumnMapping("datum8", "datum8"), New System.Data.Common.DataColumnMapping("erstaelterals", "erstaelterals"), New System.Data.Common.DataColumnMapping("mutaelterasl", "mutaelterasl"), New System.Data.Common.DataColumnMapping("team", "team"), New System.Data.Common.DataColumnMapping("sort", "sort"), New System.Data.Common.DataColumnMapping("aktive", "aktive"), New System.Data.Common.DataColumnMapping("profiltyp", "profiltyp")})})
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_profil_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection3
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profilnr", System.Data.SqlDbType.Int, 4, "profilnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@standard", System.Data.SqlDbType.Bit, 1, "standard"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color1", System.Data.SqlDbType.VarChar, 50, "color1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color2", System.Data.SqlDbType.VarChar, 50, "color2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color3", System.Data.SqlDbType.VarChar, 50, "color3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color4", System.Data.SqlDbType.VarChar, 50, "color4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color5", System.Data.SqlDbType.VarChar, 50, "color5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color6", System.Data.SqlDbType.VarChar, 50, "color6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color7", System.Data.SqlDbType.VarChar, 50, "color7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@color8", System.Data.SqlDbType.VarChar, 50, "color8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftlinks", System.Data.SqlDbType.Int, 4, "unterschriftlinks"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschriftrechts", System.Data.SqlDbType.Int, 4, "unterschriftrechts"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw1", System.Data.SqlDbType.Int, 4, "hw1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw2", System.Data.SqlDbType.Int, 4, "hw2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw3", System.Data.SqlDbType.Int, 4, "hw3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw4", System.Data.SqlDbType.Int, 4, "hw4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw5", System.Data.SqlDbType.Int, 4, "hw5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw6", System.Data.SqlDbType.Int, 4, "hw6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw7", System.Data.SqlDbType.Int, 4, "hw7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw8", System.Data.SqlDbType.Int, 4, "hw8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw9", System.Data.SqlDbType.Int, 4, "hw9"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw10", System.Data.SqlDbType.Int, 4, "hw10"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@hw11", System.Data.SqlDbType.Int, 4, "hw11"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vmb", System.Data.SqlDbType.VarChar, 255, "vmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vnl", System.Data.SqlDbType.VarChar, 255, "vnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vkost", System.Data.SqlDbType.VarChar, 255, "vkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vteam", System.Data.SqlDbType.VarChar, 255, "vteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vma", System.Data.SqlDbType.VarChar, 255, "vma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mmb", System.Data.SqlDbType.VarChar, 255, "mmb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mnl", System.Data.SqlDbType.VarChar, 255, "mnl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mkost", System.Data.SqlDbType.VarChar, 255, "mkost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mteam", System.Data.SqlDbType.VarChar, 255, "mteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mma", System.Data.SqlDbType.VarChar, 255, "mma"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@emb", System.Data.SqlDbType.VarChar, 255, "emb"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@enl", System.Data.SqlDbType.VarChar, 255, "enl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ekost", System.Data.SqlDbType.VarChar, 255, "ekost"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@eteam", System.Data.SqlDbType.VarChar, 255, "eteam"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ema", System.Data.SqlDbType.VarChar, 255, "ema"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dpartner", System.Data.SqlDbType.VarChar, 255, "dpartner"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokart", System.Data.SqlDbType.VarChar, 255, "ddokart"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@ddokstatus", System.Data.SqlDbType.VarChar, 255, "ddokstatus"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum1", System.Data.SqlDbType.VarChar, 50, "datum1"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum2", System.Data.SqlDbType.VarChar, 50, "datum2"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum3", System.Data.SqlDbType.VarChar, 50, "datum3"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum4", System.Data.SqlDbType.VarChar, 50, "datum4"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum5", System.Data.SqlDbType.VarChar, 50, "datum5"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum6", System.Data.SqlDbType.VarChar, 50, "datum6"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum7", System.Data.SqlDbType.VarChar, 50, "datum7"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@datum8", System.Data.SqlDbType.VarChar, 50, "datum8"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstaelterals", System.Data.SqlDbType.VarChar, 50, "erstaelterals"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutaelterasl", System.Data.SqlDbType.VarChar, 50, "mutaelterasl"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@team", System.Data.SqlDbType.Int, 4, "team"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sort", System.Data.SqlDbType.VarChar, 1024, "sort"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktive", System.Data.SqlDbType.Bit, 1, "aktive"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@profiltyp", System.Data.SqlDbType.Int, 4, "profiltyp"))
        '
        'SqlConnection3
        '
        Me.SqlConnection3.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_profil_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection3
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=tg302011;initial catalog=edoka_parameter;persist security info=False;" & _
        "user id=sa;workstation id=TG602645;packet size=4096"
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'txtnrpar00
        '
        Me.txtnrpar00.ContextMenu = Me.MnuSearch
        Me.txtnrpar00.Location = New System.Drawing.Point(392, 3)
        Me.txtnrpar00.Name = "txtnrpar00"
        Me.txtnrpar00.Size = New System.Drawing.Size(112, 20)
        Me.txtnrpar00.TabIndex = 7
        Me.txtnrpar00.Text = ""
        '
        'MnuSearch
        '
        Me.MnuSearch.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItemPartnersuche, Me.MenuItemVVSuche, Me.MenuItemValorSuche, Me.MenuItemISINSUche})
        '
        'MenuItemPartnersuche
        '
        Me.MenuItemPartnersuche.Index = 0
        Me.MenuItemPartnersuche.Text = "Partner"
        '
        'MenuItemVVSuche
        '
        Me.MenuItemVVSuche.Index = 1
        Me.MenuItemVVSuche.Text = "VV-Nr."
        '
        'MenuItemValorSuche
        '
        Me.MenuItemValorSuche.Index = 2
        Me.MenuItemValorSuche.Text = "Valor"
        '
        'MenuItemISINSUche
        '
        Me.MenuItemISINSUche.Index = 3
        Me.MenuItemISINSUche.Text = "ISIN"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlSearch})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(288, 524)
        Me.Panel1.TabIndex = 8
        '
        'pnlSearch
        '
        Me.pnlSearch.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel4, Me.Panel3})
        Me.pnlSearch.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlSearch.Name = "pnlSearch"
        Me.pnlSearch.Size = New System.Drawing.Size(288, 524)
        Me.pnlSearch.TabIndex = 0
        '
        'Panel4
        '
        Me.Panel4.Controls.AddRange(New System.Windows.Forms.Control() {Me.tvstruktur})
        Me.Panel4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel4.Name = "Panel4"
        Me.Panel4.Size = New System.Drawing.Size(288, 500)
        Me.Panel4.TabIndex = 1
        '
        'tvstruktur
        '
        Me.tvstruktur.ContextMenu = Me.ContextMenu2
        Me.tvstruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.tvstruktur.ImageList = Me.ImageList3
        Me.tvstruktur.Name = "tvstruktur"
        Me.tvstruktur.Size = New System.Drawing.Size(288, 500)
        Me.tvstruktur.TabIndex = 4
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem7, Me.MenuItem15, Me.MenuItem12, Me.MenuItem8, Me.MenuItem9, Me.MenuItem19, Me.MenuItem22, Me.MenuItem20, Me.MenuItem10, Me.MenuItem11, Me.MenuItem46, Me.MenuItem52, Me.mnuFreitextSuche})
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 0
        Me.MenuItem7.Shortcut = System.Windows.Forms.Shortcut.F6
        Me.MenuItem7.Text = "Partnerdossier öffnen"
        '
        'MenuItem15
        '
        Me.MenuItem15.Index = 1
        Me.MenuItem15.Text = "&Dokument für gewählten Partner erstellen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 2
        Me.MenuItem12.Text = "Dokument erstellen"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 3
        Me.MenuItem8.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem8.Text = "Aktualisieren"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 4
        Me.MenuItem9.Text = "-"
        '
        'MenuItem19
        '
        Me.MenuItem19.Index = 5
        Me.MenuItem19.Shortcut = System.Windows.Forms.Shortcut.CtrlA
        Me.MenuItem19.Text = "Alle Dokumente des Partners"
        '
        'MenuItem22
        '
        Me.MenuItem22.Index = 6
        Me.MenuItem22.Text = "&Partnerdetails anzeigen"
        '
        'MenuItem20
        '
        Me.MenuItem20.Index = 7
        Me.MenuItem20.Text = "-"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 8
        Me.MenuItem10.Shortcut = System.Windows.Forms.Shortcut.F3
        Me.MenuItem10.Text = "Knoten öffnen"
        '
        'MenuItem11
        '
        Me.MenuItem11.Index = 9
        Me.MenuItem11.Shortcut = System.Windows.Forms.Shortcut.F4
        Me.MenuItem11.Text = "Knoten schliessen"
        '
        'MenuItem46
        '
        Me.MenuItem46.Index = 10
        Me.MenuItem46.Text = "E-Mail senden"
        '
        'MenuItem52
        '
        Me.MenuItem52.Index = 11
        Me.MenuItem52.Text = "-"
        '
        'mnuFreitextSuche
        '
        Me.mnuFreitextSuche.Index = 12
        Me.mnuFreitextSuche.Text = "Freitextsuche"
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.ImageStream = CType(resources.GetObject("ImageList3.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblpageno, Me.Button8, Me.Button7, Me.Button6, Me.Button5, Me.Button4, Me.Button3})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.Panel3.Location = New System.Drawing.Point(0, 500)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(288, 24)
        Me.Panel3.TabIndex = 0
        '
        'lblpageno
        '
        Me.lblpageno.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.lblpageno.Location = New System.Drawing.Point(128, 4)
        Me.lblpageno.Name = "lblpageno"
        Me.lblpageno.Size = New System.Drawing.Size(40, 16)
        Me.lblpageno.TabIndex = 6
        Me.lblpageno.Text = "1"
        Me.lblpageno.TextAlign = System.Drawing.ContentAlignment.TopCenter
        '
        'Button8
        '
        Me.Button8.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button8.Location = New System.Drawing.Point(256, 0)
        Me.Button8.Name = "Button8"
        Me.Button8.Size = New System.Drawing.Size(32, 22)
        Me.Button8.TabIndex = 5
        Me.Button8.Text = "Button8"
        Me.Button8.Visible = False
        '
        'Button7
        '
        Me.Button7.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button7.Location = New System.Drawing.Point(256, -4)
        Me.Button7.Name = "Button7"
        Me.Button7.Size = New System.Drawing.Size(32, 22)
        Me.Button7.TabIndex = 4
        Me.Button7.Text = "Button7"
        Me.Button7.Visible = False
        '
        'Button6
        '
        Me.Button6.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button6.Image = CType(resources.GetObject("Button6.Image"), System.Drawing.Bitmap)
        Me.Button6.Location = New System.Drawing.Point(168, 4)
        Me.Button6.Name = "Button6"
        Me.Button6.Size = New System.Drawing.Size(56, 16)
        Me.Button6.TabIndex = 3
        '
        'Button5
        '
        Me.Button5.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button5.Image = CType(resources.GetObject("Button5.Image"), System.Drawing.Bitmap)
        Me.Button5.Location = New System.Drawing.Point(72, 4)
        Me.Button5.Name = "Button5"
        Me.Button5.Size = New System.Drawing.Size(56, 16)
        Me.Button5.TabIndex = 2
        '
        'Button4
        '
        Me.Button4.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button4.Image = CType(resources.GetObject("Button4.Image"), System.Drawing.Bitmap)
        Me.Button4.Location = New System.Drawing.Point(224, 4)
        Me.Button4.Name = "Button4"
        Me.Button4.Size = New System.Drawing.Size(48, 16)
        Me.Button4.TabIndex = 1
        '
        'Button3
        '
        Me.Button3.Anchor = System.Windows.Forms.AnchorStyles.Bottom
        Me.Button3.Image = CType(resources.GetObject("Button3.Image"), System.Drawing.Bitmap)
        Me.Button3.Location = New System.Drawing.Point(16, 4)
        Me.Button3.Name = "Button3"
        Me.Button3.Size = New System.Drawing.Size(56, 16)
        Me.Button3.TabIndex = 0
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(288, 25)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 524)
        Me.Splitter1.TabIndex = 9
        Me.Splitter1.TabStop = False
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem4, Me.MenuItem3, Me.MenuItem16, Me.MenuItem36, Me.MenuItem33, Me.MenuItem5, Me.MenuItem6, Me.MenuItem21, Me.MenuItem13, Me.MenuItem29, Me.MenuItem31, Me.MenuItem53, Me.mnuSendMessage, Me.MenuItem54, Me.MenuItem30, Me.MenuItem14, Me.MnuAbgeschlossen, Me.MenuItem23, Me.MenuItem44, Me.MenuItem45, Me.MenuItem24, Me.MenuItem25, Me.MenuItem42, Me.MenuItem43, Me.MenuItem49})
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 0
        Me.MenuItem4.Text = "Dokument anzeigen"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 1
        Me.MenuItem3.Text = "&Dokument bearbeiten"
        '
        'MenuItem16
        '
        Me.MenuItem16.Index = 2
        Me.MenuItem16.Text = "&Dokument löschen"
        '
        'MenuItem36
        '
        Me.MenuItem36.Index = 3
        Me.MenuItem36.Text = "-"
        '
        'MenuItem33
        '
        Me.MenuItem33.Index = 4
        Me.MenuItem33.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem34, Me.MenuItem35})
        Me.MenuItem33.Text = "Dokument drucken"
        '
        'MenuItem34
        '
        Me.MenuItem34.Index = 0
        Me.MenuItem34.Text = "&Office-Dokument drucken"
        '
        'MenuItem35
        '
        Me.MenuItem35.Index = 1
        Me.MenuItem35.Text = "&Cold-Dokument drucken"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 5
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 6
        Me.MenuItem6.Text = "Status/Verantwortlicher wechseln"
        '
        'MenuItem21
        '
        Me.MenuItem21.Index = 7
        Me.MenuItem21.Text = "&Dokumentinformationen bearbeiten"
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 8
        Me.MenuItem13.Text = "-"
        '
        'MenuItem29
        '
        Me.MenuItem29.Index = 9
        Me.MenuItem29.Text = "&Dokument für gewählten Partner erstellen"
        '
        'MenuItem31
        '
        Me.MenuItem31.Index = 10
        Me.MenuItem31.Text = "&Dokument erstellen"
        '
        'MenuItem53
        '
        Me.MenuItem53.Index = 11
        Me.MenuItem53.Text = "-"
        '
        'mnuSendMessage
        '
        Me.mnuSendMessage.Index = 12
        Me.mnuSendMessage.Text = "EDOKA-Meldung versenden"
        '
        'MenuItem54
        '
        Me.MenuItem54.Index = 13
        Me.MenuItem54.Text = "-"
        '
        'MenuItem30
        '
        Me.MenuItem30.Index = 14
        Me.MenuItem30.Text = "-"
        Me.MenuItem30.Visible = False
        '
        'MenuItem14
        '
        Me.MenuItem14.Index = 15
        Me.MenuItem14.Shortcut = System.Windows.Forms.Shortcut.F5
        Me.MenuItem14.Text = "Aktualisieren"
        '
        'MnuAbgeschlossen
        '
        Me.MnuAbgeschlossen.Index = 16
        Me.MnuAbgeschlossen.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuABDokLoeschen, Me.MnuABDokAufheben, Me.MnuDokumentreaktivieren})
        Me.MnuAbgeschlossen.Text = "&Abgeschlossenes Dokument"
        '
        'MnuABDokLoeschen
        '
        Me.MnuABDokLoeschen.Index = 0
        Me.MnuABDokLoeschen.Text = "Löschen"
        '
        'MnuABDokAufheben
        '
        Me.MnuABDokAufheben.Index = 1
        Me.MnuABDokAufheben.Text = "Aufheben"
        '
        'MnuDokumentreaktivieren
        '
        Me.MnuDokumentreaktivieren.Index = 2
        Me.MnuDokumentreaktivieren.Text = "Dokument reaktivieren"
        '
        'MenuItem23
        '
        Me.MenuItem23.Index = 17
        Me.MenuItem23.Text = "-"
        '
        'MenuItem44
        '
        Me.MenuItem44.Index = 18
        Me.MenuItem44.Text = "Office-Dokument anzeigen"
        '
        'MenuItem45
        '
        Me.MenuItem45.Index = 19
        Me.MenuItem45.Text = "-"
        '
        'MenuItem24
        '
        Me.MenuItem24.Index = 20
        Me.MenuItem24.Text = "Spalten-Selektion"
        '
        'MenuItem25
        '
        Me.MenuItem25.Index = 21
        Me.MenuItem25.Text = "Spalten-Darstellung sichern"
        '
        'MenuItem42
        '
        Me.MenuItem42.Index = 22
        Me.MenuItem42.Text = "-"
        '
        'MenuItem43
        '
        Me.MenuItem43.Index = 23
        Me.MenuItem43.Text = "Standard-Spalten-Darstellung"
        '
        'MenuItem49
        '
        Me.MenuItem49.Index = 24
        Me.MenuItem49.Text = "&Alle Dokumente des Geschäftsfalles anzeigen"
        '
        'TabControl1
        '
        Me.TabControl1.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPageAllgemein, Me.TabPageStatus, Me.TabPageDokumentwerte, Me.TabPageZuordnung, Me.TabPageNotizen, Me.TabPageInfomeldung, Me.TabPageBerechtigung, Me.TabPage2})
        Me.TabControl1.Dock = System.Windows.Forms.DockStyle.Bottom
        Me.TabControl1.Location = New System.Drawing.Point(291, 301)
        Me.TabControl1.Name = "TabControl1"
        Me.TabControl1.SelectedIndex = 0
        Me.TabControl1.Size = New System.Drawing.Size(693, 248)
        Me.TabControl1.TabIndex = 12
        '
        'TabPageAllgemein
        '
        Me.TabPageAllgemein.BackColor = System.Drawing.Color.Transparent
        Me.TabPageAllgemein.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur1, Me.TextBox18, Me.Label19, Me.TextBox14, Me.Label15, Me.TextBox13, Me.Label14, Me.TextBox12, Me.Label12, Me.TextBox11, Me.Label11, Me.TextBox10, Me.Label10, Me.TextBox9, Me.Label9, Me.TextBox8, Me.Label8, Me.TextBox7, Me.Label7, Me.TextBox6, Me.Label6, Me.TextBox5, Me.Label5, Me.TextBox4, Me.Label4, Me.TextBox3, Me.Label3, Me.TextBox2, Me.Label2, Me.TextBox1, Me.Label1})
        Me.TabPageAllgemein.Location = New System.Drawing.Point(4, 22)
        Me.TabPageAllgemein.Name = "TabPageAllgemein"
        Me.TabPageAllgemein.Size = New System.Drawing.Size(685, 222)
        Me.TabPageAllgemein.TabIndex = 0
        Me.TabPageAllgemein.Text = "Allgemein"
        '
        'pnlzensur1
        '
        Me.pnlzensur1.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur1})
        Me.pnlzensur1.Location = New System.Drawing.Point(96, 184)
        Me.pnlzensur1.Name = "pnlzensur1"
        Me.pnlzensur1.Size = New System.Drawing.Size(512, 32)
        Me.pnlzensur1.TabIndex = 30
        '
        'lblzensur1
        '
        Me.lblzensur1.Location = New System.Drawing.Point(0, 8)
        Me.lblzensur1.Name = "lblzensur1"
        Me.lblzensur1.Size = New System.Drawing.Size(650, 23)
        Me.lblzensur1.TabIndex = 0
        Me.lblzensur1.Text = "Label21"
        '
        'TextBox18
        '
        Me.TextBox18.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox18.ForeColor = System.Drawing.Color.Black
        Me.TextBox18.Location = New System.Drawing.Point(96, 64)
        Me.TextBox18.Name = "TextBox18"
        Me.TextBox18.ReadOnly = True
        Me.TextBox18.Size = New System.Drawing.Size(208, 20)
        Me.TextBox18.TabIndex = 29
        Me.TextBox18.Text = ""
        '
        'Label19
        '
        Me.Label19.Location = New System.Drawing.Point(8, 64)
        Me.Label19.Name = "Label19"
        Me.Label19.Size = New System.Drawing.Size(88, 16)
        Me.Label19.TabIndex = 28
        Me.Label19.Text = "Barcodekleber"
        '
        'TextBox14
        '
        Me.TextBox14.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox14.ForeColor = System.Drawing.Color.Black
        Me.TextBox14.Location = New System.Drawing.Point(392, 160)
        Me.TextBox14.Name = "TextBox14"
        Me.TextBox14.ReadOnly = True
        Me.TextBox14.Size = New System.Drawing.Size(208, 20)
        Me.TextBox14.TabIndex = 27
        Me.TextBox14.Text = ""
        '
        'Label15
        '
        Me.Label15.Location = New System.Drawing.Point(312, 160)
        Me.Label15.Name = "Label15"
        Me.Label15.Size = New System.Drawing.Size(80, 23)
        Me.Label15.TabIndex = 26
        Me.Label15.Text = "Termin"
        '
        'TextBox13
        '
        Me.TextBox13.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox13.ForeColor = System.Drawing.Color.Black
        Me.TextBox13.Location = New System.Drawing.Point(96, 160)
        Me.TextBox13.Name = "TextBox13"
        Me.TextBox13.ReadOnly = True
        Me.TextBox13.Size = New System.Drawing.Size(208, 20)
        Me.TextBox13.TabIndex = 25
        Me.TextBox13.Text = ""
        '
        'Label14
        '
        Me.Label14.Location = New System.Drawing.Point(8, 160)
        Me.Label14.Name = "Label14"
        Me.Label14.Size = New System.Drawing.Size(88, 23)
        Me.Label14.TabIndex = 24
        Me.Label14.Text = "Verantwortlich"
        '
        'TextBox12
        '
        Me.TextBox12.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox12.ForeColor = System.Drawing.Color.Black
        Me.TextBox12.Location = New System.Drawing.Point(96, 192)
        Me.TextBox12.Multiline = True
        Me.TextBox12.Name = "TextBox12"
        Me.TextBox12.ReadOnly = True
        Me.TextBox12.Size = New System.Drawing.Size(504, 24)
        Me.TextBox12.TabIndex = 23
        Me.TextBox12.Text = ""
        '
        'Label12
        '
        Me.Label12.Location = New System.Drawing.Point(8, 192)
        Me.Label12.Name = "Label12"
        Me.Label12.Size = New System.Drawing.Size(88, 23)
        Me.Label12.TabIndex = 22
        Me.Label12.Text = "Bemerkung"
        '
        'TextBox11
        '
        Me.TextBox11.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox11.ForeColor = System.Drawing.Color.Black
        Me.TextBox11.Location = New System.Drawing.Point(96, 136)
        Me.TextBox11.Name = "TextBox11"
        Me.TextBox11.ReadOnly = True
        Me.TextBox11.Size = New System.Drawing.Size(208, 20)
        Me.TextBox11.TabIndex = 21
        Me.TextBox11.Text = ""
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 136)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(88, 23)
        Me.Label11.TabIndex = 20
        Me.Label11.Text = "Dokumentstatus"
        '
        'TextBox10
        '
        Me.TextBox10.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox10.ForeColor = System.Drawing.Color.Black
        Me.TextBox10.Location = New System.Drawing.Point(392, 88)
        Me.TextBox10.Name = "TextBox10"
        Me.TextBox10.ReadOnly = True
        Me.TextBox10.Size = New System.Drawing.Size(208, 20)
        Me.TextBox10.TabIndex = 19
        Me.TextBox10.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(312, 88)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(80, 23)
        Me.Label10.TabIndex = 18
        Me.Label10.Text = "Mutiert durch"
        '
        'TextBox9
        '
        Me.TextBox9.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox9.ForeColor = System.Drawing.Color.Black
        Me.TextBox9.Location = New System.Drawing.Point(392, 64)
        Me.TextBox9.Name = "TextBox9"
        Me.TextBox9.ReadOnly = True
        Me.TextBox9.Size = New System.Drawing.Size(208, 20)
        Me.TextBox9.TabIndex = 17
        Me.TextBox9.Text = ""
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(312, 64)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(80, 23)
        Me.Label9.TabIndex = 16
        Me.Label9.Text = "Mutiert am"
        '
        'TextBox8
        '
        Me.TextBox8.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox8.ForeColor = System.Drawing.Color.Black
        Me.TextBox8.Location = New System.Drawing.Point(392, 136)
        Me.TextBox8.Name = "TextBox8"
        Me.TextBox8.ReadOnly = True
        Me.TextBox8.Size = New System.Drawing.Size(208, 20)
        Me.TextBox8.TabIndex = 15
        Me.TextBox8.Text = ""
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(312, 136)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(80, 23)
        Me.Label8.TabIndex = 14
        Me.Label8.Text = "Gesperrt durch"
        '
        'TextBox7
        '
        Me.TextBox7.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox7.ForeColor = System.Drawing.Color.Black
        Me.TextBox7.Location = New System.Drawing.Point(392, 112)
        Me.TextBox7.Name = "TextBox7"
        Me.TextBox7.ReadOnly = True
        Me.TextBox7.Size = New System.Drawing.Size(208, 20)
        Me.TextBox7.TabIndex = 13
        Me.TextBox7.Text = ""
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(312, 112)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(80, 23)
        Me.Label7.TabIndex = 12
        Me.Label7.Text = "Gesperrt am"
        '
        'TextBox6
        '
        Me.TextBox6.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox6.ForeColor = System.Drawing.Color.Black
        Me.TextBox6.Location = New System.Drawing.Point(392, 40)
        Me.TextBox6.Name = "TextBox6"
        Me.TextBox6.ReadOnly = True
        Me.TextBox6.Size = New System.Drawing.Size(208, 20)
        Me.TextBox6.TabIndex = 11
        Me.TextBox6.Text = ""
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(312, 40)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 10
        Me.Label6.Text = "Erstellt durch"
        '
        'TextBox5
        '
        Me.TextBox5.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox5.ForeColor = System.Drawing.Color.Black
        Me.TextBox5.Location = New System.Drawing.Point(392, 16)
        Me.TextBox5.Name = "TextBox5"
        Me.TextBox5.ReadOnly = True
        Me.TextBox5.Size = New System.Drawing.Size(208, 20)
        Me.TextBox5.TabIndex = 9
        Me.TextBox5.Text = ""
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(312, 16)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 23)
        Me.Label5.TabIndex = 8
        Me.Label5.Text = "Erstellt am"
        '
        'TextBox4
        '
        Me.TextBox4.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox4.ForeColor = System.Drawing.Color.Black
        Me.TextBox4.Location = New System.Drawing.Point(96, 112)
        Me.TextBox4.Name = "TextBox4"
        Me.TextBox4.ReadOnly = True
        Me.TextBox4.Size = New System.Drawing.Size(208, 20)
        Me.TextBox4.TabIndex = 7
        Me.TextBox4.Text = ""
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 112)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(88, 23)
        Me.Label4.TabIndex = 6
        Me.Label4.Text = "Bezeichnung"
        '
        'TextBox3
        '
        Me.TextBox3.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox3.ForeColor = System.Drawing.Color.Black
        Me.TextBox3.Location = New System.Drawing.Point(96, 88)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.ReadOnly = True
        Me.TextBox3.Size = New System.Drawing.Size(208, 20)
        Me.TextBox3.TabIndex = 5
        Me.TextBox3.Text = ""
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 88)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(88, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Dokumentart"
        '
        'TextBox2
        '
        Me.TextBox2.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox2.ForeColor = System.Drawing.Color.Black
        Me.TextBox2.Location = New System.Drawing.Point(96, 16)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.ReadOnly = True
        Me.TextBox2.Size = New System.Drawing.Size(208, 20)
        Me.TextBox2.TabIndex = 3
        Me.TextBox2.Text = ""
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 16)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(88, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Partner"
        '
        'TextBox1
        '
        Me.TextBox1.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.TextBox1.ForeColor = System.Drawing.Color.Black
        Me.TextBox1.Location = New System.Drawing.Point(96, 40)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.ReadOnly = True
        Me.TextBox1.Size = New System.Drawing.Size(208, 20)
        Me.TextBox1.TabIndex = 1
        Me.TextBox1.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 40)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Dokument-ID"
        '
        'TabPageStatus
        '
        Me.TabPageStatus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Statuslist, Me.Panel2})
        Me.TabPageStatus.Location = New System.Drawing.Point(4, 22)
        Me.TabPageStatus.Name = "TabPageStatus"
        Me.TabPageStatus.Size = New System.Drawing.Size(685, 222)
        Me.TabPageStatus.TabIndex = 1
        Me.TabPageStatus.Text = "Dokumentstatus"
        '
        'Statuslist
        '
        Me.Statuslist.AllowArrows = False
        Me.Statuslist.AllowFilter = True
        Me.Statuslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Statuslist.AllowSort = True
        Me.Statuslist.BackColor = System.Drawing.Color.White
        Me.Statuslist.BorderStyle = System.Windows.Forms.BorderStyle.None
        Me.Statuslist.CaptionHeight = 17
        Me.Statuslist.CollapseColor = System.Drawing.Color.Transparent
        Me.Statuslist.ContextMenu = Me.ContextMenu9
        Me.Statuslist.DataChanged = False
        Me.Statuslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Statuslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Statuslist.ExpandColor = System.Drawing.Color.Transparent
        Me.Statuslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Statuslist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.Statuslist.Location = New System.Drawing.Point(0, 32)
        Me.Statuslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Statuslist.Name = "Statuslist"
        Me.Statuslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Statuslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Statuslist.PreviewInfo.ZoomFactor = 75
        Me.Statuslist.PrintInfo.ShowOptionsDialog = False
        Me.Statuslist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Statuslist.RowDivider = GridLines1
        Me.Statuslist.RowHeight = 15
        Me.Statuslist.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.Statuslist.ScrollTips = False
        Me.Statuslist.Size = New System.Drawing.Size(685, 190)
        Me.Statuslist.TabIndex = 3
        Me.Statuslist.Text = "C1TrueDBGrid1"
        Me.Statuslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{BackColor:White;}HighlightRow{ForeColor:HighlightText;BackColor:Highl" & _
        "ight;}Style1{}OddRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackCo" & _
        "lor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}St" & _
        "yle8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles" & _
        "><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" CaptionHeight=""17"" ColumnCaption" & _
        "Height=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelect" & _
        "orWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""" & _
        "1""><ClientRect>0, 0, 685, 190</ClientRect><BorderSide>0</BorderSide><CaptionStyl" & _
        "e parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><Eve" & _
        "nRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""" & _
        "Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group""" & _
        " me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle " & _
        "parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4""" & _
        " /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""Recor" & _
        "dSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style " & _
        "parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedSty" & _
        "les><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style " & _
        "parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style par" & _
        "ent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style pare" & _
        "nt=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style pare" & _
        "nt=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""H" & _
        "eading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style par" & _
        "ent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1" & _
        "</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Cl" & _
        "ientArea>0, 0, 685, 190</ClientArea></Blob>"
        '
        'ContextMenu9
        '
        Me.ContextMenu9.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem32})
        '
        'MenuItem32
        '
        Me.MenuItem32.Index = 0
        Me.MenuItem32.Text = "Status setzen"
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.RBStatusHistory, Me.RBStatusAktuell})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(685, 32)
        Me.Panel2.TabIndex = 1
        '
        'RBStatusHistory
        '
        Me.RBStatusHistory.Location = New System.Drawing.Point(88, 6)
        Me.RBStatusHistory.Name = "RBStatusHistory"
        Me.RBStatusHistory.Size = New System.Drawing.Size(64, 24)
        Me.RBStatusHistory.TabIndex = 4
        Me.RBStatusHistory.Text = "History"
        '
        'RBStatusAktuell
        '
        Me.RBStatusAktuell.Checked = True
        Me.RBStatusAktuell.Location = New System.Drawing.Point(16, 6)
        Me.RBStatusAktuell.Name = "RBStatusAktuell"
        Me.RBStatusAktuell.Size = New System.Drawing.Size(56, 24)
        Me.RBStatusAktuell.TabIndex = 3
        Me.RBStatusAktuell.TabStop = True
        Me.RBStatusAktuell.Text = "Aktuell"
        '
        'TabPageDokumentwerte
        '
        Me.TabPageDokumentwerte.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabControl2})
        Me.TabPageDokumentwerte.Location = New System.Drawing.Point(4, 22)
        Me.TabPageDokumentwerte.Name = "TabPageDokumentwerte"
        Me.TabPageDokumentwerte.Size = New System.Drawing.Size(685, 222)
        Me.TabPageDokumentwerte.TabIndex = 2
        Me.TabPageDokumentwerte.Text = "Dokumentwerte"
        '
        'TabControl2
        '
        Me.TabControl2.Controls.AddRange(New System.Windows.Forms.Control() {Me.TabPage1, Me.TabPage3})
        Me.TabControl2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.TabControl2.Name = "TabControl2"
        Me.TabControl2.SelectedIndex = 0
        Me.TabControl2.Size = New System.Drawing.Size(685, 222)
        Me.TabControl2.TabIndex = 0
        '
        'TabPage1
        '
        Me.TabPage1.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur2, Me.ColdList, Me.Splitter2, Me.lblzensur2, Me.ColdListDokumente})
        Me.TabPage1.Location = New System.Drawing.Point(4, 22)
        Me.TabPage1.Name = "TabPage1"
        Me.TabPage1.Size = New System.Drawing.Size(677, 196)
        Me.TabPage1.TabIndex = 0
        Me.TabPage1.Text = "Dokumentarchivierung"
        '
        'pnlzensur2
        '
        Me.pnlzensur2.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur2.Location = New System.Drawing.Point(339, 0)
        Me.pnlzensur2.Name = "pnlzensur2"
        Me.pnlzensur2.Size = New System.Drawing.Size(338, 196)
        Me.pnlzensur2.TabIndex = 19
        '
        'ColdList
        '
        Me.ColdList.AllowFilter = True
        Me.ColdList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdList.AllowSort = True
        Me.ColdList.AllowUpdate = False
        Me.ColdList.AllowUpdateOnBlur = False
        Me.ColdList.AlternatingRows = True
        Me.ColdList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ColdList.CaptionHeight = 17
        Me.ColdList.CollapseColor = System.Drawing.Color.Black
        Me.ColdList.DataChanged = False
        Me.ColdList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ColdList.ExpandColor = System.Drawing.Color.Black
        Me.ColdList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.ColdList.Location = New System.Drawing.Point(339, 0)
        Me.ColdList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdList.Name = "ColdList"
        Me.ColdList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdList.PreviewInfo.ZoomFactor = 75
        Me.ColdList.PrintInfo.ShowOptionsDialog = False
        Me.ColdList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ColdList.RowDivider = GridLines2
        Me.ColdList.RowHeight = 15
        Me.ColdList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ColdList.ScrollTips = False
        Me.ColdList.Size = New System.Drawing.Size(338, 196)
        Me.ColdList.TabIndex = 18
        Me.ColdList.Text = "C1TrueDBGrid1"
        Me.ColdList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 334, 192</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 334, 192</ClientArea></Blob>"
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(336, 0)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(3, 196)
        Me.Splitter2.TabIndex = 17
        Me.Splitter2.TabStop = False
        '
        'lblzensur2
        '
        Me.lblzensur2.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur2.Name = "lblzensur2"
        Me.lblzensur2.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur2.TabIndex = 16
        Me.lblzensur2.Text = "Label21"
        '
        'ColdListDokumente
        '
        Me.ColdListDokumente.AllowFilter = True
        Me.ColdListDokumente.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ColdListDokumente.AllowSort = True
        Me.ColdListDokumente.AllowUpdate = False
        Me.ColdListDokumente.AllowUpdateOnBlur = False
        Me.ColdListDokumente.BackColor = System.Drawing.Color.White
        Me.ColdListDokumente.CaptionHeight = 17
        Me.ColdListDokumente.CollapseColor = System.Drawing.Color.Black
        Me.ColdListDokumente.ContextMenu = Me.ContextMenu8
        Me.ColdListDokumente.Cursor = System.Windows.Forms.Cursors.Default
        Me.ColdListDokumente.DataChanged = False
        Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
        Me.ColdListDokumente.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ColdListDokumente.Dock = System.Windows.Forms.DockStyle.Left
        Me.ColdListDokumente.ExpandColor = System.Drawing.Color.Black
        Me.ColdListDokumente.FlatStyle = C1.Win.C1TrueDBGrid.FlatModeEnum.Popup
        Me.ColdListDokumente.GroupByCaption = "Drag a column header here to group by that column"
        Me.ColdListDokumente.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.ColdListDokumente.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ColdListDokumente.Name = "ColdListDokumente"
        Me.ColdListDokumente.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ColdListDokumente.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ColdListDokumente.PreviewInfo.ZoomFactor = 75
        Me.ColdListDokumente.PrintInfo.ShowOptionsDialog = False
        Me.ColdListDokumente.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.Transparent
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.None
        Me.ColdListDokumente.RowDivider = GridLines3
        Me.ColdListDokumente.RowHeight = 15
        Me.ColdListDokumente.RowSubDividerColor = System.Drawing.Color.Transparent
        Me.ColdListDokumente.ScrollTips = False
        Me.ColdListDokumente.Size = New System.Drawing.Size(336, 196)
        Me.ColdListDokumente.TabIndex = 13
        Me.ColdListDokumente.Text = "C1TrueDBGrid1"
        Me.ColdListDokumente.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style13{}EvenRow{BackColor:White;}Selected{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Heading{Wrap:True;AlignVert:Center;Border:Flat,ControlDark,0, 1, " & _
        "0, 1;ForeColor:ControlText;BackColor:Control;}Inactive{ForeColor:InactiveCaption" & _
        "Text;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Footer{}Capti" & _
        "on{AlignHorz:Center;}Style20{}HighlightRow{ForeColor:HighlightText;BackColor:Hig" & _
        "hlight;}Normal{BackColor:White;}Style26{}Style25{}Style24{}Style23{AlignHorz:Nea" & _
        "r;}Style22{}Style21{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:C" & _
        "enter;}Style18{}Style19{}Style14{}Style15{}Style16{}Style17{}</Data></Styles><Sp" & _
        "lits><C1.Win.C1TrueDBGrid.HierarchicalView DefRecSelWidth=""16"" Name="""" CaptionHe" & _
        "ight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedC" & _
        "ellBorder"" RecordSelectorWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGrou" & _
        "p=""1""><ClientRect>0, 0, 332, 192</ClientRect><CaptionStyle parent=""Heading"" me=""" & _
        "Style23"" /><EditorStyle parent=""Editor"" me=""Style15"" /><EvenRowStyle parent=""Eve" & _
        "nRow"" me=""Style21"" /><FilterBarStyle parent=""FilterBar"" me=""Style26"" /><FooterSt" & _
        "yle parent=""Footer"" me=""Style17"" /><GroupStyle parent=""Group"" me=""Style25"" /><He" & _
        "adingStyle parent=""Heading"" me=""Style16"" /><HighLightRowStyle parent=""HighlightR" & _
        "ow"" me=""Style20"" /><InactiveStyle parent=""Inactive"" me=""Style19"" /><OddRowStyle " & _
        "parent=""OddRow"" me=""Style22"" /><RecordSelectorStyle parent=""RecordSelector"" me=""" & _
        "Style24"" /><SelectedStyle parent=""Selected"" me=""Style18"" /><Style parent=""Normal" & _
        """ me=""Style14"" /></C1.Win.C1TrueDBGrid.HierarchicalView></Splits><NamedStyles><S" & _
        "tyle parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent" & _
        "=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""H" & _
        "eading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""No" & _
        "rmal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""No" & _
        "rmal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading" & _
        """ me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""C" & _
        "aption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horz" & _
        "Splits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientAr" & _
        "ea>0, 0, 332, 192</ClientArea></Blob>"
        '
        'ContextMenu8
        '
        Me.ContextMenu8.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem28, Me.MenuItem38, Me.MenuItem50, Me.MenuItem51})
        '
        'MenuItem28
        '
        Me.MenuItem28.Index = 0
        Me.MenuItem28.Text = "Dokument anzeigen"
        '
        'MenuItem38
        '
        Me.MenuItem38.Index = 1
        Me.MenuItem38.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem40, Me.MenuItem41, Me.MenuItem39})
        Me.MenuItem38.Text = "&Status-Mutation"
        '
        'MenuItem40
        '
        Me.MenuItem40.Index = 0
        Me.MenuItem40.Text = "&Alt"
        '
        'MenuItem41
        '
        Me.MenuItem41.Index = 1
        Me.MenuItem41.Text = "&Aktuell"
        '
        'MenuItem39
        '
        Me.MenuItem39.Index = 2
        Me.MenuItem39.Text = "&Ungültig"
        '
        'MenuItem50
        '
        Me.MenuItem50.Index = 2
        Me.MenuItem50.Text = "Eintrag Löschen"
        '
        'MenuItem51
        '
        Me.MenuItem51.Index = 3
        Me.MenuItem51.Text = "Eintrag 'Aktiv' setzen"
        '
        'TabPage3
        '
        Me.TabPage3.Controls.AddRange(New System.Windows.Forms.Control() {Me.TextBox17, Me.Label18, Me.TextBox16, Me.TextBox15, Me.Label17, Me.Label16})
        Me.TabPage3.Location = New System.Drawing.Point(4, 22)
        Me.TabPage3.Name = "TabPage3"
        Me.TabPage3.Size = New System.Drawing.Size(677, 196)
        Me.TabPage3.TabIndex = 2
        Me.TabPage3.Text = "Diverse"
        '
        'TextBox17
        '
        Me.TextBox17.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox17.Location = New System.Drawing.Point(104, 72)
        Me.TextBox17.Name = "TextBox17"
        Me.TextBox17.ReadOnly = True
        Me.TextBox17.Size = New System.Drawing.Size(296, 20)
        Me.TextBox17.TabIndex = 5
        Me.TextBox17.Text = ""
        '
        'Label18
        '
        Me.Label18.Location = New System.Drawing.Point(8, 72)
        Me.Label18.Name = "Label18"
        Me.Label18.Size = New System.Drawing.Size(96, 23)
        Me.Label18.TabIndex = 4
        Me.Label18.Text = "Zuständig"
        '
        'TextBox16
        '
        Me.TextBox16.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox16.Location = New System.Drawing.Point(104, 32)
        Me.TextBox16.Name = "TextBox16"
        Me.TextBox16.ReadOnly = True
        Me.TextBox16.Size = New System.Drawing.Size(296, 20)
        Me.TextBox16.TabIndex = 3
        Me.TextBox16.Text = ""
        '
        'TextBox15
        '
        Me.TextBox15.BackColor = System.Drawing.SystemColors.HighlightText
        Me.TextBox15.Location = New System.Drawing.Point(104, 8)
        Me.TextBox15.Name = "TextBox15"
        Me.TextBox15.ReadOnly = True
        Me.TextBox15.Size = New System.Drawing.Size(296, 20)
        Me.TextBox15.TabIndex = 2
        Me.TextBox15.Text = ""
        '
        'Label17
        '
        Me.Label17.Location = New System.Drawing.Point(8, 32)
        Me.Label17.Name = "Label17"
        Me.Label17.Size = New System.Drawing.Size(96, 23)
        Me.Label17.TabIndex = 1
        Me.Label17.Text = "Unterschrift rechts"
        '
        'Label16
        '
        Me.Label16.Location = New System.Drawing.Point(8, 8)
        Me.Label16.Name = "Label16"
        Me.Label16.Size = New System.Drawing.Size(96, 23)
        Me.Label16.TabIndex = 0
        Me.Label16.Text = "Unterschrift links"
        '
        'TabPageZuordnung
        '
        Me.TabPageZuordnung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur4, Me.Zuordnungslist})
        Me.TabPageZuordnung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageZuordnung.Name = "TabPageZuordnung"
        Me.TabPageZuordnung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageZuordnung.TabIndex = 6
        Me.TabPageZuordnung.Text = "Dokumentzuordnungen"
        '
        'pnlzensur4
        '
        Me.pnlzensur4.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur4})
        Me.pnlzensur4.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur4.Name = "pnlzensur4"
        Me.pnlzensur4.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur4.TabIndex = 15
        '
        'lblzensur4
        '
        Me.lblzensur4.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur4.Name = "lblzensur4"
        Me.lblzensur4.Size = New System.Drawing.Size(640, 23)
        Me.lblzensur4.TabIndex = 0
        Me.lblzensur4.Text = "Label21"
        '
        'Zuordnungslist
        '
        Me.Zuordnungslist.AllowFilter = True
        Me.Zuordnungslist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Zuordnungslist.AllowSort = True
        Me.Zuordnungslist.AllowUpdate = False
        Me.Zuordnungslist.AllowUpdateOnBlur = False
        Me.Zuordnungslist.AlternatingRows = True
        Me.Zuordnungslist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Zuordnungslist.CaptionHeight = 17
        Me.Zuordnungslist.CollapseColor = System.Drawing.Color.Black
        Me.Zuordnungslist.ContextMenu = Me.ContextMenu7
        Me.Zuordnungslist.DataChanged = False
        Me.Zuordnungslist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Zuordnungslist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Zuordnungslist.ExpandColor = System.Drawing.Color.Black
        Me.Zuordnungslist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Zuordnungslist.Images.Add(CType(resources.GetObject("resource.Images3"), System.Drawing.Bitmap))
        Me.Zuordnungslist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Zuordnungslist.Name = "Zuordnungslist"
        Me.Zuordnungslist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Zuordnungslist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Zuordnungslist.PreviewInfo.ZoomFactor = 75
        Me.Zuordnungslist.PrintInfo.ShowOptionsDialog = False
        Me.Zuordnungslist.RecordSelectorWidth = 16
        GridLines4.Color = System.Drawing.Color.DarkGray
        GridLines4.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Zuordnungslist.RowDivider = GridLines4
        Me.Zuordnungslist.RowHeight = 15
        Me.Zuordnungslist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Zuordnungslist.ScrollTips = False
        Me.Zuordnungslist.Size = New System.Drawing.Size(685, 222)
        Me.Zuordnungslist.TabIndex = 14
        Me.Zuordnungslist.Text = "C1TrueDBGrid1"
        Me.Zuordnungslist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu7
        '
        Me.ContextMenu7.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem26, Me.MenuItem47, Me.MenuItem48})
        '
        'MenuItem26
        '
        Me.MenuItem26.Index = 0
        Me.MenuItem26.Text = "Dokument anzeigen"
        '
        'MenuItem47
        '
        Me.MenuItem47.Index = 1
        Me.MenuItem47.Text = "Partner-Dossier anzeigen"
        '
        'MenuItem48
        '
        Me.MenuItem48.Index = 2
        Me.MenuItem48.Text = "&Alle Dokumente des Geschäftsfalles anzeigen"
        '
        'TabPageNotizen
        '
        Me.TabPageNotizen.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur5, Me.Notizlist})
        Me.TabPageNotizen.Location = New System.Drawing.Point(4, 22)
        Me.TabPageNotizen.Name = "TabPageNotizen"
        Me.TabPageNotizen.Size = New System.Drawing.Size(685, 222)
        Me.TabPageNotizen.TabIndex = 5
        Me.TabPageNotizen.Text = "Notizen"
        '
        'pnlzensur5
        '
        Me.pnlzensur5.Controls.AddRange(New System.Windows.Forms.Control() {Me.drpMiatarbeiter, Me.lblzensur5})
        Me.pnlzensur5.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur5.Name = "pnlzensur5"
        Me.pnlzensur5.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur5.TabIndex = 14
        '
        'drpMiatarbeiter
        '
        Me.drpMiatarbeiter.AllowColMove = True
        Me.drpMiatarbeiter.AllowColSelect = True
        Me.drpMiatarbeiter.AllowFilter = True
        Me.drpMiatarbeiter.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.drpMiatarbeiter.AllowSort = True
        Me.drpMiatarbeiter.AlternatingRows = True
        Me.drpMiatarbeiter.CaptionHeight = 17
        Me.drpMiatarbeiter.ColumnCaptionHeight = 17
        Me.drpMiatarbeiter.ColumnFooterHeight = 17
        Me.drpMiatarbeiter.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.drpMiatarbeiter.FetchRowStyles = False
        Me.drpMiatarbeiter.Images.Add(CType(resources.GetObject("resource.Images4"), System.Drawing.Bitmap))
        Me.drpMiatarbeiter.LayoutFileName = ""
        Me.drpMiatarbeiter.LayoutName = ""
        Me.drpMiatarbeiter.LayoutURL = ""
        Me.drpMiatarbeiter.Location = New System.Drawing.Point(322, 71)
        Me.drpMiatarbeiter.Name = "drpMiatarbeiter"
        GridLines5.Color = System.Drawing.Color.DarkGray
        GridLines5.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.drpMiatarbeiter.RowDivider = GridLines5
        Me.drpMiatarbeiter.RowHeight = 15
        Me.drpMiatarbeiter.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.drpMiatarbeiter.ScrollTips = False
        Me.drpMiatarbeiter.Size = New System.Drawing.Size(40, 80)
        Me.drpMiatarbeiter.TabIndex = 3
        Me.drpMiatarbeiter.Text = "C1TrueDBDropdown1"
        Me.drpMiatarbeiter.Visible = False
        Me.drpMiatarbeiter.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cen" & _
        "ter;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}O" & _
        "ddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:Center;}Heading{Wrap:Tr" & _
        "ue;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:C" & _
        "enter;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data" & _
        "></Styles><Splits><C1.Win.C1TrueDBGrid.DropdownView Name="""" AlternatingRowStyle=" & _
        """True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" Marqu" & _
        "eeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" RecordSelectors=""False"" Vert" & _
        "icalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 36, 76</ClientRe" & _
        "ct><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=" & _
        """Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""" & _
        "FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle" & _
        " parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><Hig" & _
        "hLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inacti" & _
        "ve"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyl" & _
        "e parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""St" & _
        "yle6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.DropdownView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 36, 76</ClientArea></Blob>"
        '
        'lblzensur5
        '
        Me.lblzensur5.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur5.Name = "lblzensur5"
        Me.lblzensur5.Size = New System.Drawing.Size(648, 23)
        Me.lblzensur5.TabIndex = 0
        Me.lblzensur5.Text = "Label21"
        '
        'Notizlist
        '
        Me.Notizlist.AllowFilter = True
        Me.Notizlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.Notizlist.AllowSort = True
        Me.Notizlist.AllowUpdate = False
        Me.Notizlist.AllowUpdateOnBlur = False
        Me.Notizlist.AlternatingRows = True
        Me.Notizlist.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.Notizlist.CaptionHeight = 17
        Me.Notizlist.CollapseColor = System.Drawing.Color.Black
        Me.Notizlist.ContextMenu = Me.ContextMenu4
        Me.Notizlist.DataChanged = False
        Me.Notizlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.Notizlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Notizlist.ExpandColor = System.Drawing.Color.Black
        Me.Notizlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.Notizlist.Images.Add(CType(resources.GetObject("resource.Images5"), System.Drawing.Bitmap))
        Me.Notizlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.Notizlist.Name = "Notizlist"
        Me.Notizlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.Notizlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.Notizlist.PreviewInfo.ZoomFactor = 75
        Me.Notizlist.PrintInfo.ShowOptionsDialog = False
        Me.Notizlist.RecordSelectorWidth = 16
        GridLines6.Color = System.Drawing.Color.DarkGray
        GridLines6.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.Notizlist.RowDivider = GridLines6
        Me.Notizlist.RowHeight = 15
        Me.Notizlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.Notizlist.ScrollTips = False
        Me.Notizlist.Size = New System.Drawing.Size(685, 222)
        Me.Notizlist.TabIndex = 13
        Me.Notizlist.Text = "C1TrueDBGrid1"
        Me.Notizlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Border:Rais" & _
        "ed,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu4
        '
        Me.ContextMenu4.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuNotizanzeigen})
        '
        'MnuNotizanzeigen
        '
        Me.MnuNotizanzeigen.Index = 0
        Me.MnuNotizanzeigen.Text = "&Notiz anzeigen"
        '
        'TabPageInfomeldung
        '
        Me.TabPageInfomeldung.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur3, Me.InfoMeldungList})
        Me.TabPageInfomeldung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageInfomeldung.Name = "TabPageInfomeldung"
        Me.TabPageInfomeldung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageInfomeldung.TabIndex = 4
        Me.TabPageInfomeldung.Text = "Informationsmeldungen"
        '
        'pnlzensur3
        '
        Me.pnlzensur3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur3})
        Me.pnlzensur3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur3.Name = "pnlzensur3"
        Me.pnlzensur3.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur3.TabIndex = 13
        '
        'lblzensur3
        '
        Me.lblzensur3.Location = New System.Drawing.Point(8, 8)
        Me.lblzensur3.Name = "lblzensur3"
        Me.lblzensur3.Size = New System.Drawing.Size(624, 23)
        Me.lblzensur3.TabIndex = 0
        Me.lblzensur3.Text = "Label21"
        '
        'InfoMeldungList
        '
        Me.InfoMeldungList.AllowFilter = True
        Me.InfoMeldungList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.InfoMeldungList.AllowSort = True
        Me.InfoMeldungList.AllowUpdate = False
        Me.InfoMeldungList.AllowUpdateOnBlur = False
        Me.InfoMeldungList.AlternatingRows = True
        Me.InfoMeldungList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.InfoMeldungList.CaptionHeight = 17
        Me.InfoMeldungList.CollapseColor = System.Drawing.Color.Black
        Me.InfoMeldungList.DataChanged = False
        Me.InfoMeldungList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.InfoMeldungList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.InfoMeldungList.ExpandColor = System.Drawing.Color.Black
        Me.InfoMeldungList.FetchRowStyles = True
        Me.InfoMeldungList.GroupByCaption = "Drag a column header here to group by that column"
        Me.InfoMeldungList.Images.Add(CType(resources.GetObject("resource.Images6"), System.Drawing.Bitmap))
        Me.InfoMeldungList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.InfoMeldungList.Name = "InfoMeldungList"
        Me.InfoMeldungList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.InfoMeldungList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.InfoMeldungList.PreviewInfo.ZoomFactor = 75
        Me.InfoMeldungList.PrintInfo.ShowOptionsDialog = False
        Me.InfoMeldungList.RecordSelectorWidth = 16
        GridLines7.Color = System.Drawing.Color.DarkGray
        GridLines7.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.InfoMeldungList.RowDivider = GridLines7
        Me.InfoMeldungList.RowHeight = 15
        Me.InfoMeldungList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.InfoMeldungList.ScrollTips = False
        Me.InfoMeldungList.Size = New System.Drawing.Size(685, 222)
        Me.InfoMeldungList.TabIndex = 12
        Me.InfoMeldungList.Text = "C1TrueDBGrid1"
        Me.InfoMeldungList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" MarqueeStyle=""Dott" & _
        "edCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""" & _
        "1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>" & _
        "0</BorderSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""" & _
        "Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarSty" & _
        "le parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" />" & _
        "<GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Sty" & _
        "le2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle par" & _
        "ent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordS" & _
        "electorStyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selec" & _
        "ted"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.Me" & _
        "rgeView></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Norm" & _
        "al"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading""" & _
        " me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" m" & _
        "e=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""H" & _
        "ighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""" & _
        "OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" m" & _
        "e=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1" & _
        "</vertSplits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>" & _
        "16</DefaultRecSelWidth><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'TabPageBerechtigung
        '
        Me.TabPageBerechtigung.Controls.AddRange(New System.Windows.Forms.Control() {Me.DokumentFunktionenList})
        Me.TabPageBerechtigung.Location = New System.Drawing.Point(4, 22)
        Me.TabPageBerechtigung.Name = "TabPageBerechtigung"
        Me.TabPageBerechtigung.Size = New System.Drawing.Size(685, 222)
        Me.TabPageBerechtigung.TabIndex = 7
        Me.TabPageBerechtigung.Text = "Berechtigungseinschränkung"
        '
        'DokumentFunktionenList
        '
        Me.DokumentFunktionenList.AllowFilter = True
        Me.DokumentFunktionenList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokumentFunktionenList.AllowSort = True
        Me.DokumentFunktionenList.AllowUpdate = False
        Me.DokumentFunktionenList.AllowUpdateOnBlur = False
        Me.DokumentFunktionenList.AlternatingRows = True
        Me.DokumentFunktionenList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.DokumentFunktionenList.CaptionHeight = 17
        Me.DokumentFunktionenList.CollapseColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.DataChanged = False
        Me.DokumentFunktionenList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokumentFunktionenList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokumentFunktionenList.ExpandColor = System.Drawing.Color.Black
        Me.DokumentFunktionenList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokumentFunktionenList.Images.Add(CType(resources.GetObject("resource.Images7"), System.Drawing.Bitmap))
        Me.DokumentFunktionenList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokumentFunktionenList.Name = "DokumentFunktionenList"
        Me.DokumentFunktionenList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokumentFunktionenList.PreviewInfo.ZoomFactor = 75
        Me.DokumentFunktionenList.PrintInfo.ShowOptionsDialog = False
        Me.DokumentFunktionenList.RecordSelectorWidth = 16
        GridLines8.Color = System.Drawing.Color.DarkGray
        GridLines8.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokumentFunktionenList.RowDivider = GridLines8
        Me.DokumentFunktionenList.RowHeight = 15
        Me.DokumentFunktionenList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokumentFunktionenList.ScrollTips = False
        Me.DokumentFunktionenList.Size = New System.Drawing.Size(685, 222)
        Me.DokumentFunktionenList.TabIndex = 14
        Me.DokumentFunktionenList.Text = "C1TrueDBGrid1"
        Me.DokumentFunktionenList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'TabPage2
        '
        Me.TabPage2.Controls.AddRange(New System.Windows.Forms.Control() {Me.pnlzensur6, Me.ErsetzteDokumenteList})
        Me.TabPage2.Location = New System.Drawing.Point(4, 22)
        Me.TabPage2.Name = "TabPage2"
        Me.TabPage2.Size = New System.Drawing.Size(685, 222)
        Me.TabPage2.TabIndex = 8
        Me.TabPage2.Text = "Ersetzte Dokumente"
        '
        'pnlzensur6
        '
        Me.pnlzensur6.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblzensur6})
        Me.pnlzensur6.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlzensur6.Name = "pnlzensur6"
        Me.pnlzensur6.Size = New System.Drawing.Size(685, 222)
        Me.pnlzensur6.TabIndex = 14
        '
        'lblzensur6
        '
        Me.lblzensur6.Location = New System.Drawing.Point(16, 16)
        Me.lblzensur6.Name = "lblzensur6"
        Me.lblzensur6.Size = New System.Drawing.Size(616, 23)
        Me.lblzensur6.TabIndex = 0
        Me.lblzensur6.Text = "Label21"
        '
        'ErsetzteDokumenteList
        '
        Me.ErsetzteDokumenteList.AllowFilter = True
        Me.ErsetzteDokumenteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.ErsetzteDokumenteList.AllowSort = True
        Me.ErsetzteDokumenteList.AllowUpdate = False
        Me.ErsetzteDokumenteList.AllowUpdateOnBlur = False
        Me.ErsetzteDokumenteList.AlternatingRows = True
        Me.ErsetzteDokumenteList.BackColor = System.Drawing.Color.FromArgb(CType(224, Byte), CType(224, Byte), CType(224, Byte))
        Me.ErsetzteDokumenteList.CaptionHeight = 17
        Me.ErsetzteDokumenteList.CollapseColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.ContextMenu = Me.ContextMenu10
        Me.ErsetzteDokumenteList.DataChanged = False
        Me.ErsetzteDokumenteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.ErsetzteDokumenteList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.ErsetzteDokumenteList.ExpandColor = System.Drawing.Color.Black
        Me.ErsetzteDokumenteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.ErsetzteDokumenteList.Images.Add(CType(resources.GetObject("resource.Images8"), System.Drawing.Bitmap))
        Me.ErsetzteDokumenteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.ErsetzteDokumenteList.Name = "ErsetzteDokumenteList"
        Me.ErsetzteDokumenteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.ErsetzteDokumenteList.PreviewInfo.ZoomFactor = 75
        Me.ErsetzteDokumenteList.PrintInfo.ShowOptionsDialog = False
        Me.ErsetzteDokumenteList.RecordSelectorWidth = 16
        GridLines9.Color = System.Drawing.Color.DarkGray
        GridLines9.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.ErsetzteDokumenteList.RowDivider = GridLines9
        Me.ErsetzteDokumenteList.RowHeight = 15
        Me.ErsetzteDokumenteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.ErsetzteDokumenteList.ScrollTips = False
        Me.ErsetzteDokumenteList.Size = New System.Drawing.Size(685, 222)
        Me.ErsetzteDokumenteList.TabIndex = 13
        Me.ErsetzteDokumenteList.Text = "C1TrueDBGrid1"
        Me.ErsetzteDokumenteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{BackColor:224, 224, 224;}HighlightRow{ForeCo" & _
        "lor:HighlightText;BackColor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}R" & _
        "ecordSelector{AlignImage:Center;}Heading{Wrap:True;AlignVert:Center;Border:Raise" & _
        "d,,1, 1, 1, 1;ForeColor:ControlText;BackColor:Control;}Style8{}Style10{AlignHorz" & _
        ":Near;}Style11{}Style12{}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1True" & _
        "DBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCap" & _
        "tionHeight=""17"" ColumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSe" & _
        "lectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGro" & _
        "up=""1""><ClientRect>0, 0, 681, 218</ClientRect><BorderSide>0</BorderSide><Caption" & _
        "Style parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" />" & _
        "<EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" " & _
        "me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Gr" & _
        "oup"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowSt" & _
        "yle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Sty" & _
        "le4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""R" & _
        "ecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><St" & _
        "yle parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><Name" & _
        "dStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><St" & _
        "yle parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style" & _
        " parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style " & _
        "parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style " & _
        "parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style paren" & _
        "t=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style" & _
        " parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSpli" & _
        "ts>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth" & _
        "><ClientArea>0, 0, 681, 218</ClientArea></Blob>"
        '
        'ContextMenu10
        '
        Me.ContextMenu10.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem27})
        '
        'MenuItem27
        '
        Me.MenuItem27.Index = 0
        Me.MenuItem27.Text = "&Dokument anzeigen"
        '
        'ContextMenu6
        '
        Me.ContextMenu6.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem17, Me.MenuItem18})
        '
        'MenuItem17
        '
        Me.MenuItem17.Index = 0
        Me.MenuItem17.Text = "&Ausgangsarchiviert"
        '
        'MenuItem18
        '
        Me.MenuItem18.Index = 1
        Me.MenuItem18.Text = "&Eingangsarchiviert"
        '
        'cbProfile
        '
        Me.cbProfile.AllowDrop = True
        Me.cbProfile.Location = New System.Drawing.Point(148, 4)
        Me.cbProfile.Name = "cbProfile"
        Me.cbProfile.Size = New System.Drawing.Size(172, 21)
        Me.cbProfile.TabIndex = 24
        Me.cbProfile.Text = "ComboBox1"
        '
        'LblSearch
        '
        Me.LblSearch.Location = New System.Drawing.Point(348, 6)
        Me.LblSearch.Name = "LblSearch"
        Me.LblSearch.Size = New System.Drawing.Size(58, 16)
        Me.LblSearch.TabIndex = 13
        Me.LblSearch.Text = "Partner:"
        '
        'btnPartnersuche
        '
        Me.btnPartnersuche.Image = CType(resources.GetObject("btnPartnersuche.Image"), System.Drawing.Bitmap)
        Me.btnPartnersuche.Location = New System.Drawing.Point(504, 1)
        Me.btnPartnersuche.Name = "btnPartnersuche"
        Me.btnPartnersuche.Size = New System.Drawing.Size(24, 23)
        Me.btnPartnersuche.TabIndex = 14
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokumentSelect, Me.MenuItem37, Me.MnuClose})
        '
        'MnuDokumentSelect
        '
        Me.MnuDokumentSelect.Index = 0
        Me.MnuDokumentSelect.Text = "&Dokument auswählen"
        '
        'MenuItem37
        '
        Me.MenuItem37.Index = 1
        Me.MenuItem37.Text = "Dokument anzeigen"
        '
        'MnuClose
        '
        Me.MnuClose.Index = 2
        Me.MnuClose.Text = "Fenster schliessen"
        '
        'ImageList4
        '
        Me.ImageList4.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList4.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList4.ImageStream = CType(resources.GetObject("ImageList4.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList4.TransparentColor = System.Drawing.Color.Transparent
        '
        'DokList
        '
        Me.DokList.AllowFilter = True
        Me.DokList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.DokList.AllowSort = True
        Me.DokList.AllowUpdateOnBlur = False
        Me.DokList.AlternatingRows = True
        Me.DokList.CaptionHeight = 17
        Me.DokList.CollapseColor = System.Drawing.Color.Black
        Me.DokList.ContextMenu = Me.ContextMenu1
        Me.DokList.Cursor = System.Windows.Forms.Cursors.Default
        Me.DokList.DataChanged = False
        Me.DokList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.DokList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.DokList.ExpandColor = System.Drawing.Color.Black
        Me.DokList.FetchRowStyles = True
        Me.DokList.FilterBar = True
        Me.DokList.GroupByCaption = "Drag a column header here to group by that column"
        Me.DokList.Images.Add(CType(resources.GetObject("resource.Images9"), System.Drawing.Bitmap))
        Me.DokList.Location = New System.Drawing.Point(291, 25)
        Me.DokList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.DokList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.DokList.Name = "DokList"
        Me.DokList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.DokList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.DokList.PreviewInfo.ZoomFactor = 75
        Me.DokList.PrintInfo.ShowOptionsDialog = False
        Me.DokList.RecordSelectorWidth = 16
        GridLines10.Color = System.Drawing.Color.DarkGray
        GridLines10.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.DokList.RowDivider = GridLines10
        Me.DokList.RowHeight = 15
        Me.DokList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.DokList.ScrollTips = True
        Me.DokList.Size = New System.Drawing.Size(693, 276)
        Me.DokList.TabIndex = 25
        Me.DokList.Text = "C1TrueDBGrid1"
        Me.DokList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 689," & _
        " 272</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 689, " & _
        "272</ClientArea></Blob>"
        '
        'cmitprofil
        '
        Me.cmitprofil.Checked = True
        Me.cmitprofil.CheckState = System.Windows.Forms.CheckState.Checked
        Me.cmitprofil.Location = New System.Drawing.Point(418, 2)
        Me.cmitprofil.Name = "cmitprofil"
        Me.cmitprofil.Size = New System.Drawing.Size(16, 24)
        Me.cmitprofil.TabIndex = 26
        Me.cmitprofil.Text = "CheckBox1"
        Me.cmitprofil.Visible = False
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(864, 2)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 23)
        Me.Button2.TabIndex = 27
        Me.Button2.Visible = False
        '
        'txtbcknr
        '
        Me.txtbcknr.Location = New System.Drawing.Point(584, 3)
        Me.txtbcknr.Name = "txtbcknr"
        Me.txtbcknr.Size = New System.Drawing.Size(144, 20)
        Me.txtbcknr.TabIndex = 28
        Me.txtbcknr.Text = ""
        Me.txtbcknr.Visible = False
        '
        'Label20
        '
        Me.Label20.Location = New System.Drawing.Point(504, 7)
        Me.Label20.Name = "Label20"
        Me.Label20.Size = New System.Drawing.Size(88, 16)
        Me.Label20.TabIndex = 29
        Me.Label20.Text = "Dok-ID/BCK-Nr."
        Me.Label20.Visible = False
        '
        'Button1
        '
        Me.Button1.Enabled = False
        Me.Button1.FlatStyle = System.Windows.Forms.FlatStyle.Flat
        Me.Button1.ForeColor = System.Drawing.SystemColors.Control
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(504, 1)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 23)
        Me.Button1.TabIndex = 30
        '
        'Button9
        '
        Me.Button9.Cursor = System.Windows.Forms.Cursors.Default
        Me.Button9.ForeColor = System.Drawing.SystemColors.Control
        Me.Button9.Image = CType(resources.GetObject("Button9.Image"), System.Drawing.Bitmap)
        Me.Button9.Location = New System.Drawing.Point(320, 2)
        Me.Button9.Name = "Button9"
        Me.Button9.Size = New System.Drawing.Size(26, 23)
        Me.Button9.TabIndex = 31
        '
        'BtnHelp
        '
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(960, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 67
        '
        'frmTrefferliste
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(984, 549)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.cbProfile, Me.Button9, Me.Button1, Me.txtbcknr, Me.Label20, Me.Button2, Me.btnPartnersuche, Me.cmitprofil, Me.txtnrpar00, Me.DokList, Me.TabControl1, Me.LblSearch, Me.Splitter1, Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Menu = Me.MainMenu1
        Me.Name = "frmTrefferliste"
        Me.ShowInTaskbar = False
        Me.Text = "Trefferliste - Profil XX"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel1.ResumeLayout(False)
        Me.pnlSearch.ResumeLayout(False)
        Me.Panel4.ResumeLayout(False)
        Me.Panel3.ResumeLayout(False)
        Me.TabControl1.ResumeLayout(False)
        Me.TabPageAllgemein.ResumeLayout(False)
        Me.pnlzensur1.ResumeLayout(False)
        Me.TabPageStatus.ResumeLayout(False)
        CType(Me.Statuslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel2.ResumeLayout(False)
        Me.TabPageDokumentwerte.ResumeLayout(False)
        Me.TabControl2.ResumeLayout(False)
        Me.TabPage1.ResumeLayout(False)
        CType(Me.ColdList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.ColdListDokumente, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage3.ResumeLayout(False)
        Me.TabPageZuordnung.ResumeLayout(False)
        Me.pnlzensur4.ResumeLayout(False)
        CType(Me.Zuordnungslist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageNotizen.ResumeLayout(False)
        Me.pnlzensur5.ResumeLayout(False)
        CType(Me.drpMiatarbeiter, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.Notizlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageInfomeldung.ResumeLayout(False)
        Me.pnlzensur3.ResumeLayout(False)
        CType(Me.InfoMeldungList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPageBerechtigung.ResumeLayout(False)
        CType(Me.DokumentFunktionenList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.TabPage2.ResumeLayout(False)
        Me.pnlzensur6.ResumeLayout(False)
        CType(Me.ErsetzteDokumenteList, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DokList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Load_Layout Method

Private Sub Load_Layout()

Source code

[Visual Basic]
    Private Sub Load_Layout()
        Dim docname As String
        Try
            docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + ".lyt", "")
            If HOSTDATEN = True Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
            If ZVDaten = True Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
            If UVMDaten = False Then
            Else
                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
            End If
            'Try
            '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
            '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
            '    End If
            'Catch
            'End Try
            'Try
            '    If Me.DokList.Columns("NRAUF00").Text <> "" Then
            '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
            '    End If
            'Catch
            'End Try
            'Try
            '    Dim ii As Integer
            '    For ii = 0 To Me.DokList.Columns.Count - 1
            '        If Me.DokList.Columns(ii).DataField = "CDZAH00" Then
            '            docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
            '        End If
            '    Next

            '    ''If Me.DokList.Columns("CDZAH00").Text <> "" Then
            '    '    docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
            '    'End If
            'Catch
            'End Try
        Catch
        End Try

        If Dir(docname) = "" Then
            Dim p As New DocMgmt()
            '***********************************
            'Standardlayout laden entfernt
            '29.7.2004 / SHU
            '***********************************
            Try
                If p.Get_layout_from_DB(Me.Profilnr, docname) <> "" Then
                    Me.DokList.LoadLayout(docname)
                End If
            Catch
            Finally
                p = Nothing
            End Try
        Else
            Me.DokList.LoadLayout(docname)
        End If
        Dim i As Integer
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Load_Profiles Method

Private Sub Load_Profiles()

Source code

[Visual Basic]
    Private Sub Load_Profiles()
        Me.DataSet1.Clear()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection3.ConnectionString = Globals.sConnectionString
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mitarbeiternr").Value = Globals.MitarbeiterNr
        Me.SqlDataAdapter1.SelectCommand.Parameters("@mandantnr").Value = Globals.MandantNr
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        If Microsoft.VisualBasic.Right(Me.tvstruktur.SelectedNode.Tag, 3) = 998 Then
            '            update_host = True
            Update_Partnerstruktur()
            '           update_host = False
            Me.tvstruktur.SelectedNode.ExpandAll()
        Else
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem11_Click Method

Private Sub MenuItem11_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem11.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem11_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem11.Click
        Me.tvstruktur.SelectedNode.Collapse()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem12_Click Method

Private Sub MenuItem12_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem12.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem12_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem12.Click
        Create_Dokument(False, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem14_Click Method

Private Sub MenuItem14_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem14.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem14_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem14.Click
        Globals.PerfMon.insert_entry("Start Update Dokumentliste")
        Update_Doklist()
        Globals.PerfMon.insert_entry("Stop Update Dokumentliste")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem15_Click Method

Private Sub MenuItem15_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem15.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem15_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem15.Click
        Create_Dokument(True, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem16_Click Method

Private Sub MenuItem16_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem16.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem16_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem16.Click
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Dim f As New frmLoeschgrund()
        Archivfnkt.Inkl_Bedingter_Retournierung = False
        If Archivfnkt.check_bereits_archiviert(Me.DokList.Columns("dokumentid").Text, True) = False Then Exit Sub
        f.txtLoeschgrund.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Dokument_delete"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschgrund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, f.txtLoeschgrund.Text))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)
                Dim dt As DataTable
                Dim sth As New Statushandling()
                dt = sth.get_coldindex_and_statusnr(Me.DokList.Columns("dokumentid").Text, False, False)
                Archivfnkt.insert_coldupdate_status(dt, Me.DokList.Columns("dokumentid").Text, "Alt")
                sth.Dispose()
                Update_Doklist()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem17_Click Method

Private Sub MenuItem17_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem17.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem17_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem17.Click
        Dim statush As New Statushandling()
        Dim dok As New edokadb.clsDokument()
        Try
            dok.cpMainConnectionProvider = conn
            dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Value, String))
            dok.SelectOne()
            dok.iStatusnr = New SqlInt32(CType(statush.Set_Ausgangsarchiviert(Me.DokList.Columns("dokumentid").Text), Integer))
            conn.OpenConnection()
            dok.Update()
            conn.CloseConnection(True)
            statush.Dispose()
            dok.Dispose()
            statush.check_abschluss(Me.DokList.Columns("dokumentid").Text, Globals.MitarbeiterNr)
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem18_Click Method

Private Sub MenuItem18_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem18.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem18_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem18.Click
        Dim statush As New Statushandling()
        Dim dok As New edokadb.clsDokument()
        dok.cpMainConnectionProvider = conn
        dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Value, String))
        dok.SelectOne()
        dok.iStatusnr = New SqlInt32(CType(statush.Set_Eingangsarchiviert(Me.DokList.Columns("dokumentid").Text), Integer))
        conn.OpenConnection()
        dok.Update()
        conn.CloseConnection(True)
        statush.Dispose()
        dok.Dispose()
        statush.check_abschluss(Me.DokList.Columns("dokumentid").Text, Globals.MitarbeiterNr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem19_Click Method

Private Sub MenuItem19_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem19.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem19_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem19.Click
        PreviewAlleDokumente = True  'neu koe 29.09.2003
        AlleDokumente = True
        Update_Doklist()
        AlleDokumente = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem21_Click Method

Private Sub MenuItem21_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem21.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem21_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem21.Click
        Me.Cursor = Cursors.WaitCursor
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then
            Me.Cursor = Cursors.Default
            Exit Sub
        End If
        DivFnkt.Status_Dokumentbearbeitung(1, Me.DokList.Columns("dokumentid").Value, False, "")
        Me.Cursor = Cursors.WaitCursor
        Dim x
        x = Me.DokList.Bookmark
        Dim f As New frmDokumentInfoEdit()
        f.NurDokinfo = True
        f.Profilnr = Me.Profilnr
        f.Dokument_Ist_Abgeschlossen = dokument_ist_abgeschlossen(Me.DokList.Columns("dokumentid").Text)
        f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
        f.Profile = Me.DataSet1.Tables(0)
        f.Dokumentinfobearbeiten = True
        f.CreateDocument = False
        f.ShowDialog()
        f.Hide()
        Windows.Forms.Application.DoEvents()
        Update_Doklist()
        Try
            Me.DokList.Bookmark = x
            Update_DetailInformation()
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem22_Click Method

Private Sub MenuItem22_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem22.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem22_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem22.Click
        Try
            Dim d As Long
            d = Val(Me.Partnernr)
            If d > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = d
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = d
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem24_Click Method

Private Sub MenuItem24_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem24.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem24_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem24.Click
        Dim F As New frmSpaltenDarstellung()
        Dim i As Integer
        F.ListBox1.Items.Clear()
        F.ListBox2.Items.Clear()
        Try
            For i = 0 To Me.DokList.Columns.Count - 1
                Try
                    If Me.DokList.Splits(0).DisplayColumns(i).Visible = False Then
                        If Me.DokList.Splits(0).DisplayColumns(i).Name().ToString <> "" Then
                            F.ListBox1.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
                        End If
                    End If
                Catch
                End Try
                Try
                    If Me.DokList.Splits(0).DisplayColumns(i).Visible = True Then F.ListBox2.Items.Add(Me.DokList.Splits(0).DisplayColumns(i).Name())
                Catch
                End Try
            Next
        Catch ex As Exception

        End Try
        F.ShowDialog()
        For i = 0 To F.ListBox1.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.DokList.Columns.Count - 1
                    If Me.DokList.Splits(0).DisplayColumns(xx).Name = F.ListBox1.Items(i) Then
                        Me.DokList.Splits(0).DisplayColumns(xx).Visible = False
                    End If
                Next
                '                Me.DokList.Splits(0).DisplayColumns(F.ListBox1.Items(i)).Visible = False
            Catch
            End Try
        Next
        For i = 0 To F.ListBox2.Items.Count - 1
            Try
                Dim xx As Integer
                For xx = 0 To Me.DokList.Columns.Count - 1
                    If Me.DokList.Splits(0).DisplayColumns(xx).Name = F.ListBox2.Items(i) Then
                        Me.DokList.Splits(0).DisplayColumns(xx).Visible = True
                    End If
                Next
                '                Me.DokList.Splits(0).DisplayColumns(F.ListBox2.Items(i)).Visible = True
            Catch
            End Try
        Next
        F.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem25_Click Method

Private Sub MenuItem25_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem25.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem25_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem25.Click
        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem26_Click Method

Private Sub MenuItem26_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem26.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem26_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem26.Click
        DivFnkt.ShowDoc(Me.Zuordnungslist.Columns("dokumentid2").Value, Me.ParentForm)
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem27_Click Method

Private Sub MenuItem27_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem27.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem27_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem27.Click
        DivFnkt.ShowDoc(Me.ErsetzteDokumenteList.Columns("dokumentid").Text, Me.ParentForm)
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem28_Click Method

Private Sub MenuItem28_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem28.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem28_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem28.Click
        DivFnkt.ShowColdDoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.ColdListDokumente.Columns("colddokumentid").Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem29_Click Method

Private Sub MenuItem29_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem29.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem29_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem29.Click
        Create_Dokument(True, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem31_Click Method

Private Sub MenuItem31_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem31.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem31_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem31.Click
        Create_Dokument(False, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem32_Click Method

Private Sub MenuItem32_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem32.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem32_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem32.Click
        Dim f As New frmStatusSetzen()
        f.TextBox1.Text = Me.DokList.Columns("dokumentid").Text
        f.ShowDialog()
        Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem33_Popup Method

Private Sub MenuItem33_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem33.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem33_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem33.Popup
        'Hutter 2004-10-04 Aktivierung COLD-Print
        If Me.ZVDaten Or Me.UVMDaten Or Me.HOSTDATEN Then
            Me.MenuItem34.Enabled = False
            Me.MenuItem35.Enabled = True
            Me.MenuItem33.Enabled = True
            Exit Sub
        End If

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_check_dokument"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@office", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@cold", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)

            If scmCmdToExecute.Parameters("@office").Value > 0 Then
                Me.MenuItem34.Enabled = True
            Else
                Me.MenuItem34.Enabled = False
            End If
            If scmCmdToExecute.Parameters("@cold").Value > 0 Then
                Me.MenuItem35.Enabled = True
            Else
                Me.MenuItem35.Enabled = False
            End If
            'If DivFnkt.isbck(Me.DokList.Columns("dokumentid").Value) Then Me.MenuItem34.Enabled = False
            If Me.MenuItem34.Enabled = False And Me.MenuItem35.Enabled = False Then
                Me.MenuItem33.Enabled = False
            Else
                Me.MenuItem33.Enabled = True
            End If

            'Else
            'Me.MenuItem34.Enabled = False
            'Me.MenuItem44.Enabled = False
            'If Not DivFnkt.isbck(Me.DokList.Columns("dokumentid").Value) Then Me.MenuItem33.Enabled = False
            'End If
            ''HUTTER 2004-10-04 - AKTIVIERUNG Colt-Print
            'If Me.ZVDaten = True Or UVMDaten = True Or HOSTDATEN = True Then
            '    Me.MenuItem33.Enabled = True
            '    Me.MenuItem35.Enabled = True
            '    '         End If
            '    '            If scmCmdToExecute.Parameters("@COLD").Value > 0 Then
            '    '           Me.MenuItem35.Enabled = True
            '    '          Me.MenuItem33.Enabled = True
            'Else
            '    Me.MenuItem35.Enabled = False
            'End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem34_Click Method

Private Sub MenuItem34_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem34.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem34_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem34.Click
        DivFnkt.print_office(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem35_Click Method

Private Sub MenuItem35_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem35.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem35_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem35.Click
        'hutter 2004-10-04 Aktivierung Cold-Print
        If Me.HOSTDATEN = True Then
            Try
                DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
                DivFnkt.Belegart = "HOST"

                DivFnkt.printcolddocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttyp").Text)

                Me.Cursor = Cursors.Default
                Exit Sub
            Catch
            End Try
        End If
        If Me.ZVDaten = True Then
            Try
                DivFnkt.Erstellungsdatum = Me.DokList.Columns(3).Text
                DivFnkt.Auftragnr = Me.DokList.Columns(18).Text
                DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                DivFnkt.Belegart = "ZV"

                DivFnkt.printcolddocHost(Me.DokList.Columns(11).Text, Me.ParentForm, Me.DokList.Columns(11).Text, Me.DokList.Columns(20).Text, _
                Me.DokList.Columns(20).Text, Me.DokList.Columns(0).Text)

                Me.Cursor = Cursors.Default
                Exit Sub
            Catch
            End Try
        End If
        If Me.UVMDaten = True Then
            DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).Text
            DivFnkt.Belegart = "UVM"
            DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
            DivFnkt.Auftragnr = Me.DokList.Columns(4).Text
            DivFnkt.printcolddocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(2).Text, _
            Me.DokList.Columns(2).Text, Me.DokList.Columns(0).Text)
            Me.Cursor = Cursors.Default
            Exit Sub
        End If

        'Try
        '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
        '        DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
        '        DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text)
        '        Me.Cursor = Cursors.Default
        '        Exit Sub
        '    End If
        'Catch

        'End Try
        DivFnkt.printcolddoc(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem37_Click Method

Private Sub MenuItem37_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem37.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem37_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem37.Click
        MenuItem4_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem39_Click Method

Private Sub MenuItem39_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem39.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem39_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem39.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Ungültig")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        'Bedingte Retournierung
        Dim Bedingte_Retournierung_vorhanden As Boolean = False
        Dim dokumentidbr As String

        Dim dok As New edokadb.clsDokument()
        dok.sDokumentid = New SqlString(CType(Me.DokList.Columns("dokumentid").Text, String))
        dok.cpMainConnectionProvider = conn
        dok.SelectOne()
        Try
            If dok.sBedRDokumentid.Value <> "" Then
                Bedingte_Retournierung_vorhanden = True
                dokumentidbr = dok.sBedRDokumentid.Value
                Archivfnkt.Inkl_Bedingter_Retournierung = True
                Archivfnkt.Dokument_Bedingte_Retournierung = dokumentidbr
            Else
                Bedingte_Retournierung_vorhanden = False
                Archivfnkt.Inkl_Bedingter_Retournierung = False
            End If
        Catch
            Bedingte_Retournierung_vorhanden = False
            Archivfnkt.Inkl_Bedingter_Retournierung = False
        End Try

        Dim barcodekleberdokument As Boolean = isbck()
        Globals.Dokumentcoldindex_Changed = False
        Globals.DokumentColdIndex_ChangedBR = False

        Globals.dokumentid_changed = False
        Globals.dokumentid_changedbr = False

        Globals.Ersetzte_Dokumente_Reaktivieren = False
        Globals.ersetzte_dokumente_reaktivierenbr = False

        Archivfnkt.bck = barcodekleberdokument
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Me.Cursor = Cursors.WaitCursor
        If Archivfnkt.check_bereits_archiviert(Me.DokList.Columns("dokumentid").Text, False) = False Then
            Windows.Forms.Application.DoEvents()
            Me.Cursor = Cursors.Default
            dok.Dispose()
            Exit Sub
        End If
        Archivfnkt.bck = False
        Windows.Forms.Application.DoEvents()
        Me.Cursor = Cursors.WaitCursor
        If Globals.dokumentid_changed Then
            DivFnkt.Status_Dokumentbearbeitung(1, Globals.DokumentID_New_Copy, False, "")
        Else
            DivFnkt.Status_Dokumentbearbeitung(1, Me.DokList.Columns("dokumentid").Value, False, "")
        End If

        If Globals.dokumentid_changedbr Then
            If Globals.dokumentid_changed Then
                dok.sDokumentid = New SqlString(CType(Globals.DokumentID_New_Copy, String))
                dok.SelectOne()
            End If
            dok.sBedRDokumentid = New SqlString(CType(Globals.DokumentID_New_CopyBR, String))
            conn.OpenConnection()
            dok.Update()
            conn.CloseConnection(True)
            dok.Dispose()
            DivFnkt.Status_Dokumentbearbeitung(1, Globals.DokumentID_New_CopyBR, False, "")
        Else
            DivFnkt.Status_Dokumentbearbeitung(1, dokumentidbr, False, "")
        End If
        Dim x
        x = Me.DokList.Bookmark
        If Not barcodekleberdokument Then
            Dim f As New frmDokumentbearbeitung()
            f.Profilnr = Me.Profilnr

            If Globals.dokumentid_changed Then
                f.EditDokumentid = Globals.DokumentID_New_Copy
            Else
                f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
            End If

            If Globals.dokumentid_changedbr Then
                f.EditDokumentidbr = Globals.DokumentID_New_CopyBR
            Else
                f.EditDokumentidbr = dokumentidbr
            End If

            f.Profile = Me.DataSet1.Tables(0)
            f.Dokumentinfobearbeiten = False
            f.CreateDocument = False
            f.ShowDialog()
            Update_Doklist()
            Try
                Me.DokList.Bookmark = x
                Update_DetailInformation()
            Catch
            End Try
        Else
            Dim f As New frmDokumentbearbeitungBC()
            f.Profilnr = Me.Profilnr

            If Globals.dokumentid_changed Then
                f.EditDokumentid = Globals.DokumentID_New_Copy
            Else
                f.EditDokumentid = Me.DokList.Columns("dokumentid").Value
            End If

            f.Profile = Me.DataSet1.Tables(0)
            f.Dokumentinfobearbeiten = False
            f.CreateDocument = False
            f.ShowDialog()
            Update_Doklist()
            Try
                Me.DokList.Bookmark = x
                Update_DetailInformation()
            Catch
            End Try
        End If
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem40_Click Method

Private Sub MenuItem40_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem40.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem40_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem40.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Alt")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem41_Click Method

Private Sub MenuItem41_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem41.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem41_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem41.Click
        Dim f As New FrmIndexMutation()
        f.Update_Status(Me.DokList.Columns("dokumentid").Text, Me.ColdListDokumente.Columns("colddokumentid").Text, 0, "Aktuell")
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem43_Click Method

Private Sub MenuItem43_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem43.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem43_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem43.Click
        Dim type As Integer
        type = 0
        Try
            If ZVDaten Then
                type = 4
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "ZV.lyt", 0))
            End If
            If UVMDaten Then
                type = 3
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "UVM.lyt", 0))
            End If
            If HOSTDATEN Then
                type = 2
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + "HOST.lyt", 0))
            End If
            If type = 0 Then
                File.Delete(DivFnkt.Get_Filename(Trim(Me.Profilnr) + ".lyt", 0))
                type = 1
            End If
        Catch
        End Try
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_delete_profillayout"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Profilnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, type))
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
        End Try
        Update_Doklist()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem44_Click Method

Private Sub MenuItem44_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem44.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem44_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem44.Click
        DivFnkt.show_office(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem46_Click Method

Private Sub MenuItem46_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem46.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem46_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem46.Click
        Dim f As New frmMassenMail()
        f.Profilnr = Me.Profilnr
        If Partner_Eingegeben Then
            f.PartnerEingegeben = True
            f.Partnernr = Me.txtnrpar00.Text
        Else
            f.PartnerEingegeben = False
        End If
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem47_Click Method

Private Sub MenuItem47_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem47.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem47_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem47.Click
        Dim f As New frmSearchDoc()
        f.txtbcknr.Text = (Me.Zuordnungslist.Columns("dokumentid2").Value)
        f.Visible = False
        'f.Show()
        f.Visible = False
        f.MdiParent = Me.MdiParent
        f.Show_Doc()
        f.Hide()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem48_Click Method

Private Sub MenuItem48_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem48.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem48_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem48.Click
        MenuItem49_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem49_Click Method

Private Sub MenuItem49_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem49.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem49_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem49.Click
        Globals.PerfMon.insert_entry("Start Partnerdossier öffnen")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Globals.profilnr = Me.Profilnr
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.Geschaeftsfall = Me.DokList.Columns("Geschaeftsfall").Text
        f.Alle_Dokumente_Des_Geschaeftsfalles()
        f.txtnrpar00.Visible = False
        f.ImgCombo.Visible = False
        f.btnPartnersuche.Visible = False
        f.Button1.Visible = False
        f.LblSearch.Visible = False
        Dim i As Integer
        For i = 3 To f.ToolBar1.Buttons.Count - 1
            f.ToolBar1.Buttons(i).Enabled = False
        Next
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partnerdossier öffnen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem4_Click Method

Private Sub MenuItem4_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem4.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem4_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem4.Click
        Try
            If HOSTDATEN Then
                DivFnkt.Erstellungsdatum = Me.DokList.Columns("valutadatum").Text
                DivFnkt.Belegart = "HOST"
                DivFnkt.ShowColdDocHost(Me.DokList.Columns("dokumentid").Text, Me.ParentForm, Me.DokList.Columns("dokumentid").Text, Me.DokList.Columns("partnernr_inhaber").Text, _
                Me.DokList.Columns("partnername_inhaber").Text, Me.DokList.Columns("dokumenttyp").Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            End If
            If ZVDaten Then
                Try
                    DivFnkt.Erstellungsdatum = Me.DokList.Columns(3).Text
                    DivFnkt.Auftragnr = Me.DokList.Columns(18).Text
                    DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                    DivFnkt.Belegart = "ZV"
                    DivFnkt.ShowColdDocHost(Me.DokList.Columns(11).Text, Me.ParentForm, Me.DokList.Columns(11).Text, Me.DokList.Columns(20).Text, _
                    Me.DokList.Columns(20).Text, Me.DokList.Columns(0).Text)
                    Me.Cursor = Cursors.Default
                    Exit Sub
                Catch ex As Exception
                End Try
            End If
            If UVMDaten Then
                DivFnkt.Erstellungsdatum = Me.DokList.Columns(5).Text
                DivFnkt.Belegart = "UVM"
                DivFnkt.UVMZVDokumenttyp = Me.DokList.Columns(0).Text
                DivFnkt.Auftragnr = Me.DokList.Columns(4).Text
                DivFnkt.ShowColdDocHost(Me.DokList.Columns(1).Text, Me.ParentForm, Me.DokList.Columns(1).Text, Me.DokList.Columns(2).Text, _
                Me.DokList.Columns(2).Text, Me.DokList.Columns(0).Text)
                Me.Cursor = Cursors.Default
                Exit Sub
            End If

            Dim d As DataTable
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            Try
                If d.Rows(0).Item("anzeigen") = 1 Then
                    DivFnkt.Erstellungsdatum = ""
                    DivFnkt.ShowDoc(Me.DokList.Columns("dokumentid").Value, Me.ParentForm)
                    Me.Cursor = Cursors.Default
                Else
                    MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
                End If
            Catch
                MyMsg.show_standardmessage(809, MsgBoxStyle.Information)
            End Try
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem50_Click Method

Private Sub MenuItem50_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem50.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem50_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem50.Click
        Dim cd As Integer
        cd = Me.ColdListDokumente.Columns("indextypnr").Value
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Korrektur_delete_dokumentcoldindexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, cd))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Delete_Dokumentcoldindexwert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            Update_Coldindex()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem51_Click Method

Private Sub MenuItem51_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem51.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem51_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem51.Click
        Dim cd As Integer
        cd = Me.ColdListDokumente.Columns("indextypnr").Value
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.SP_Korrektur_delete_dokumentcoldindexwert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        conn.OpenConnection()
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, cd))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.ExecuteNonQuery()
            If scmCmdToExecute.Parameters("@rc").Value <> 0 Then
                MsgBox("Dokumenteintrag kann nicht gändert werden, da ein Indextyp mit Nr. 1/2 bereits vorhanden ist.", MsgBoxStyle.Critical)
                Exit Sub
            End If
        Catch ex As Exception
            Throw New Exception("Delete_Dokumentcoldindexwert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            conn.CloseConnection(True)
            Update_Coldindex()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        If DivFnkt.Status_Dokumentbearbeitung(3, Me.DokList.Columns("dokumentid").Value, False, "") = False Then Exit Sub
        Dim x
        Dim f As New frmStatuswechsel()
        f.currentstatus = Me.DokList.Columns("statusnr").Text
        x = Me.DokList.Bookmark
        f.Dokumentid = Me.DokList.Columns("dokumentid").Value
        f.Mitarbeiternr = Me.DokList.Columns("Verantwortlich").Value
        f.ShowDialog()
        Update_Doklist()
        Try
            Me.DokList.Bookmark = x
            Update_DetailInformation()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem7_Click Method

Private Sub MenuItem7_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem7.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem7_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem7.Click
        Globals.PerfMon.insert_entry("Start Partnerdossier öffnen")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Globals.profilnr = Me.Profilnr
        Dim f As New frmTrefferliste()
        f.MdiParent = Me.MdiParent
        f.Show()
        f.Partner_Eingegeben = True
        f.txtnrpar00.Text = LTrim(Me.Partnernr.ToString)
        f.refresh_list()
        f.Refresh_All(True)
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("Stop Partnerdossier öffnen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        Globals.PerfMon.insert_entry("Start Strukurbaum aktualisieren")
        Refresh_All(True)
        Globals.PerfMon.insert_entry("Stop Strukurbaum aktualisieren")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItemISINSUche_Click Method

Private Sub MenuItemISINSUche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemISINSUche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemISINSUche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemISINSUche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItemPartnersuche_Click Method

Private Sub MenuItemPartnersuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemPartnersuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemPartnersuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemPartnersuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22104))
        Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = True
        If Me.txtnrpar00.Text.Length > 0 Then DoKeyenter() Else Me.Button1_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItemVVSuche_Click Method

Private Sub MenuItemVVSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemVVSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemVVSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemVVSuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MenuItemValorSuche_Click Method

Private Sub MenuItemValorSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItemValorSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItemValorSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItemValorSuche.Click
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22105))
        Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":"
        Me.txtnrpar00.Focus()
        Me.txtnrpar00.SelectAll()
        Me.btnPartnersuche.Visible = False
        If Me.txtnrpar00.Text <> "" Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Mitarbeiter_Laden Method

Private Sub Mitarbeiter_Laden()

Source code

[Visual Basic]
    Private Sub Mitarbeiter_Laden()
        '===============================================================================
        'Description: Mitarbeiter in DRP Laden DropDown an Grid Binden und Mutierer übersetzen
        'Date       : koe 28.07.2004
        'Modified   :
        '===============================================================================
        conn.OpenConnection()
        If m_DTMitarbeiter Is Nothing Then
            m_DTMitarbeiter = Generic_Select(17)
        End If

        Me.drpMiatarbeiter.DataSource = m_DTMitarbeiter
        Me.drpMiatarbeiter.ListField = "FullName"
        Me.drpMiatarbeiter.DataField = "mitarbeiternr"
        Me.drpMiatarbeiter.ValueTranslate = True
        Me.Notizlist.Columns("mutierer").DropDown = Me.drpMiatarbeiter
        conn.CloseConnection(True)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuABDokAufheben_Click Method

Private Sub MnuABDokAufheben_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuABDokAufheben.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuABDokAufheben_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuABDokAufheben.Click
        Dim sth As New Statushandling()
        If MyMsg.Show_MessageYesNo(70) = MsgBoxResult.Yes Then
            sth.set_aufgehoben(Me.DokList.Columns("dokumentid").Text)
            Me.Update_Doklist()
        End If
        sth.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuABDokIndexMutation_Click Method

Private Sub MnuABDokIndexMutation_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuABDokIndexMutation_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim f As New FrmIndexMutation()
        f.Dokumentid = Me.DokList.Columns("dokumentid").Value
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuABDokLoeschen_Click Method

Private Sub MnuABDokLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuABDokLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuABDokLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuABDokLoeschen.Click
        MenuItem16_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuClose_Click Method

Private Sub MnuClose_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuClose.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuClose_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuClose.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuDokumentSelect_Click Method

Private Sub MnuDokumentSelect_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentSelect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentSelect_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentSelect.Click
        Me.SelectedDokumentid = Me.DokList.Columns("dokumentid").Text
        Me.Dokumentbezeichnung = Me.DokList.Columns("bezeichnung").Text
        Me.dokumentdatum = Me.DokList.Columns("erstellungsdatum").Text
        'Me.SelectedBeschreibung = Me.DokList.Columns("beschreibung").Text
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuDokumentreaktivieren_Click Method

Private Sub MnuDokumentreaktivieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentreaktivieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentreaktivieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentreaktivieren.Click
        Dim f As New frmReaktivierungsgrund()
        f.txtLoeschgrund.Text = ""
        f.ShowDialog()
        If f.DialogResult = DialogResult.OK Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_Korrektur_Dokument_Reaktivieren"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            conn.OpenConnection()
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Grund", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, f.txtLoeschgrund.Text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                Throw New Exception("Dokument_Reaktivieren::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                conn.CloseConnection(True)
                Update_Doklist()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.MnuNotizanzeigen_Click Method

Private Sub MnuNotizanzeigen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNotizanzeigen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNotizanzeigen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNotizanzeigen.Click
        Dim f As New frmNotizen()
        f.Betreff = Me.Notizlist.Columns("betreff").Value
        f.Notiz = Me.Notizlist.Columns("Notiz").Value
        f.Mutierer = Me.Notizlist.Columns("mutierer").Text
        f.MutiertAm = Me.Notizlist.Columns("mutiert_am").Text
        f.FrmReadOnly = True
        f.ShowDialog()
        f.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Name_of_Trefferliste Method

Private Sub Name_of_Trefferliste()

Source code

[Visual Basic]
    Private Sub Name_of_Trefferliste()
        Dim i As Integer
        Dim s As String
        If Me.Partner_Eingegeben Then
            i = Microsoft.VisualBasic.InStr(Me.Text, "-")
            s = Microsoft.VisualBasic.Left(Me.Text, i)
            s = s & " " & Me.tvstruktur.Nodes(0).Text
        Else
            i = Microsoft.VisualBasic.InStr(Me.Text, "-")
            s = Microsoft.VisualBasic.Left(Me.Text, i)
            's = s & " " & Me.cbProfile.Text
            s = s & " " & Me.ImgCombo.Text
        End If
        Me.Text = s
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Notizen_Laden Method

Private Function Notizen_Laden() As DataTable

Source code

[Visual Basic]
    Private Function Notizen_Laden() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Dokument_Notizen_select"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Notizlist_MouseDown Method

Private Sub Notizlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles Notizlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Notizlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles Notizlist.MouseDown
        Me.Notizlist.Bookmark = Me.Notizlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.PosDok Method

Public Sub PosDok( _
   ByVal dokumentid As String, _
   ByVal dokumentart As Integer _
)

Parameters

dokumentid
Required.
dokumentart
Required.

Source code

[Visual Basic]
    Public Sub PosDok(ByVal dokumentid As String, ByVal dokumentart As Integer)
        Try
            Dim s As String
            s = " " + Me.txtnrpar00.Text + "-" + Str(dokumentart)
            Dim i As Integer

            DivFnkt.Searchnode(Me.tvstruktur, s, 0)
            If DivFnkt.found = True Then Me.tvstruktur.SelectedNode = DivFnkt.FoundNode
            '  Me.Update_Doklist()

            For i = 0 To Me.DokList.Splits(0).Rows.Count - 1
                If Me.DokList.Columns("dokumentid").CellValue(i) = dokumentid Then
                    Me.DokList.Bookmark = i
                    Me.Update_DetailInformation()
                End If
            Next
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.RBStatusAktuell_Click Method

Private Sub RBStatusAktuell_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles RBStatusAktuell.Click, _
   RBStatusHistory.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub RBStatusAktuell_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles RBStatusAktuell.Click, RBStatusHistory.Click
        If Me.RBStatusAktuell.Checked = True Then
            statushistory = False
            Update_DetailInformation()
        End If
        If Me.RBStatusHistory.Checked = True Then
            statushistory = True
            Update_DetailInformation()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Refresh_All Method

Public Sub Refresh_All( _
   ByVal refreshlist As Boolean _
)

Parameters

refreshlist
Required.

Source code

[Visual Basic]
    Public Sub Refresh_All(ByVal refreshlist As Boolean)
        Dim n As TreeNode
        n = Me.savenode
        Dim v As Long
        v = Val(Me.Partnernr)
        Dim isexpanded As Boolean = True
        If refreshlist Then
            on_refresh = True
            refresh_list()
            on_refresh = False
        End If
        Me.tvstruktur.BeginUpdate()
        Dim i As Integer
        For i = 0 To Me.tvstruktur.Nodes.Count - 1
            If Me.tvstruktur.Nodes(i).Tag = v Then
                Try
                    Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(i)
                    If isexpanded Then Update_Partnerstruktur()
                    Me.tvstruktur.SelectedNode.ExpandAll()
                Catch
                End Try
            End If
        Next
        Try
            DivFnkt.Searchnode3(Me.tvstruktur, n.Tag, 0)
            If DivFnkt.found = True Then
                Update_Partnerstruktur()
                DivFnkt.Searchnode(Me.tvstruktur, n.Tag, n.ImageIndex)
                If DivFnkt.found = True Then
                    Me.tvstruktur.SelectedNode = DivFnkt.FoundNode
                    Me.tvstruktur.SelectedNode.ExpandAll()
                End If
            End If
        Catch
        End Try
        Me.tvstruktur.EndUpdate()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Save_Layout Method

Private Sub Save_Layout()

Source code

[Visual Basic]
    Private Sub Save_Layout()
        Dim p As New DocMgmt()
        Try
            Dim docname As String
            Try
                '***********************************
                'Layoutfile für alle Dokumenttypen setzen
                '29.7.2004 / SHU
                '***********************************

                docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + ".lyt", "")
                If HOSTDATEN Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
                If ZVDaten Then docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
                If UVMDaten = False Then
                Else
                    docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
                End If

                'Try
                '    If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
                '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "HOST.lyt", "")
                '    End If
                'Catch
                'End Try
                'Try
                '    If Me.DokList.Columns("NRAUF00").Text <> "" Then
                '        docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "UVM.lyt", "")
                '    End If
                'Catch
                'End Try
                'Try
                '    Dim i As Integer
                '    For i = 0 To Me.DokList.Columns.Count - 1
                '        If Me.DokList.Columns(i).DataField = "CDZAH00" Then
                '            docname = DivFnkt.Get_Filename(LTrim(Str(Me.Profilnr)) + "ZV.lyt", "")
                '        End If
                '    Next
                'Catch
                'End Try
            Catch
            End Try
            Me.DokList.SaveLayout(docname)
            If p.Save_Layout_DB(Me.Profilnr, docname) Then
                Me.DokList.LoadLayout(docname)
            End If
        Catch
        Finally
            p = Nothing
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Set_Colors Method

Public Sub Set_Colors()

Source code

[Visual Basic]
    Public Sub Set_Colors()
        Dim i As Integer
        Dim convcol As New ColorConverter()
        Dim da As DataTable
        da = Me.DataSet1.Tables(0)
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item("profilnr") = Me.ImgCombo.SelectedValue Then
                scolor1 = convcol.ConvertFromString(da.Rows(i).Item("color1"))
                scolor2 = convcol.ConvertFromString(da.Rows(i).Item("color2"))
                scolor3 = convcol.ConvertFromString(da.Rows(i).Item("color3"))
                scolor4 = convcol.ConvertFromString(da.Rows(i).Item("color4"))
                scolor5 = convcol.ConvertFromString(da.Rows(i).Item("color5"))
                scolor6 = convcol.ConvertFromString(da.Rows(i).Item("color6"))
            End If
        Next
        da.Dispose()
        convcol = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Status_lesen Method

Public Function Status_lesen() As DataTable

Source code

[Visual Basic]
    Public Function Status_lesen() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.SP_Trefferliste_Select_Status"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokList.Columns("dokumentid").Value))
            If Me.statushistory = True Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Statuslist_FetchRowStyle Method

Private Sub Statuslist_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles Statuslist.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Statuslist_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles Statuslist.FetchRowStyle

        If Me.Statuslist.Columns("bezeichnung").CellValue(e.Row) = Me.TextBox11.Text Then
            If colornotset Then
                e.CellStyle.ForeColor = Red
                colornotset = False
            End If
        Else
            e.CellStyle.ForeColor = Black
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.TVstruktur_MouseDown Method

Private Sub TVstruktur_MouseDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvstruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVstruktur_MouseDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvstruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            tvstruktur.SelectedNode = tvstruktur.GetNodeAt(selectPoint)
            PreviewAlleDokumente = False        'Node-Spezifische Dokumente Anzeigen neu koe 29.09.2003
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.TabControl1_Click Method

Private Sub TabControl1_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabControl1.Click

        Me.Update_DetailInformation()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.TabControl1_SelectedIndexChanged Method

Private Sub TabControl1_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabControl1.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabControl1_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabControl1.SelectedIndexChanged

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.TabPage1_Click Method

Private Sub TabPage1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles TabPage1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabPage1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles TabPage1.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.TabPageDokumentwerte_Click Method

Private Sub TabPageDokumentwerte_Click( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles TabPageDokumentwerte.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TabPageDokumentwerte_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles TabPageDokumentwerte.Click

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim i As Integer
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1
                Dim fontbold As New Font("Arial", 12, FontStyle.Bold)
                Dim fontregular As New Font("Arial", 12, FontStyle.Regular)

                'Me.DokList.PrintInfo.PrintPreview()
                'Me.DokList.PrintInfo.PageSettings.Landscape = False
                'Me.DokList.PrintInfo.ShowProgressForm = True
                'Me.DokList.PrintInfo.ShowOptionsDialog = True

                Dim sRoot() As String  'neu koe 29.09.2003

                'Ersetzen koe 29.09.2003

                With DokList.PrintInfo
                    .PageHeaderStyle.Font = fontbold
                    .PageSettings.Margins.Bottom = 20
                    .PageSettings.Margins.Top = 80
                    .PageSettings.Landscape = True
                    .PageFooter = "Seite \p von \P" & vbLf & " Druckdatum " & Now()
                    If PreviewAlleDokumente = True Then
                        'Alle Dokumente anzeigen
                        sRoot = Split(Me.tvstruktur.SelectedNode.FullPath(), "\")
                        .PageHeader = Trim(sRoot(LBound(sRoot)))
                    Else
                        'Dokumente Per Node anzeigen
                        .PageHeader = Me.tvstruktur.SelectedNode.FullPath()
                    End If
                    .ShowProgressForm = True
                    .UseGridColors = True
                    .RepeatColumnHeaders = True
                    .VarRowHeight = DokList.PrintInfo.RowHeightEnum.StretchToFit
                    .WrapText = C1.Win.C1TrueDBGrid.PrintInfo.WrapTextEnum.NoWrap
                    .PageBreak = DokList.PrintInfo.PageBreaksEnum.OnColumn
                    .FillAreaWidth = DokList.PrintInfo.FillEmptyEnum.ExtendLast
                    '.ShowOptionsDialog = True
                    .PrintPreview()
                End With
            Case 2
                Me.SelectedDocart = ""
                Create_Dokument(False, False)
            Case 3
                Me.SelectedDocart = ""
                Create_Dokument(False, True)
                Exit Sub
                Dim f As New frmVorlagenauswahl()

                F.TVStruktur.ImageList = Me.ImageList3
                Me.Profilnr = Me.cbProfile.SelectedValue
                Me.Profilnr = Me.ImgCombo.SelectedValue
                f.Dokumentart = ""
                f.Show_Favoriten = True
                f.ProfilNr = Me.Profilnr
                f.Profile = Me.DataSet1.Tables(0)
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    Me.Cursor = Cursors.WaitCursor
                    Dim fI As New frmDokumentbearbeitung()
                    fI.Partnernr = ""
                    fI.Profilnr = Me.Profilnr
                    fI.Profile = Me.DataSet1.Tables(0)
                    fI.Dokumenttypnr = F.Dokumentvorlage
                    fI.CreateDocument = True
                    F.Dispose()
                    Me.Cursor = Cursors.Default
                    fI.ShowDialog()
                    on_refresh = True
                    refresh_list()
                    on_refresh = False
                End If
            Case 6
                Dim f As New frmProfil()
                Me.Cursor = Cursors.WaitCursor
                Me.Profilnr = Me.cbProfile.SelectedValue
                Me.Profilnr = Me.ImgCombo.SelectedValue
                f.ProfilNr = Me.Profilnr
                f.ShowDialog()
                Init_Pages()

                f.Hide()
                Windows.Forms.Application.DoEvents()
                Me.ToolBar1.Buttons(5).ImageIndex = 7
                Load_Profiles()
                If f.Profile_Geaendert Then
                    Me.Cursor = Cursors.Default
                    MyMsg.show_standardmessage(50, MsgBoxStyle.Information)
                    Exit Sub
                End If
                '                Me.txtnrpar00.Text = ""
                Me.txtnrpar00.Text = ""
                If f.ProfilNr <> Me.Profilnr Then
                    Me.Profilnr = f.ProfilNr
                    Me.cbProfile.SelectedValue = Me.Profilnr
                    Me.ImgCombo.SelectedValue = Me.Profilnr
                    i = f.ProfilNr
                    Me.ImgCombo.SelectedValue = i
                    Refresh_All(True)
                    Name_of_Trefferliste()
                    Me.tvstruktur.Focus()
                    Update_Doklist()
                Else
                    imgcombo_SelectedIndexChanged_1(sender, e)
                    '                    Load_Profiles()
                    'Me.Profilnr = f.ProfilNr
                    'Me.cbProfile.SelectedValue = Me.Profilnr
                    'i = Me.Profilnr
                    'Me.ImgCombo.SelectedValue = i
                    'imgcombo_SelectedIndexChanged_1(sender, e)
                    'Name_of_Trefferliste()
                    'Partner_Eingegeben = False
                    ''Me.refresh_list()
                    'MenuItem8_Click(sender, e)
                End If
                Load_Layout()
            Case 5
                Globals.PerfMon.insert_entry("Start Strukturbaum aktualisieren (Toolbar)")
                Me.on_refresh = True
                refresh_list()
                Refresh_All(True)
                Me.Cursor = System.Windows.Forms.Cursors.Default
                Me.on_refresh = False
                Me.ToolBar1.Buttons(5).ImageIndex = 7
                Globals.PerfMon.insert_entry("Stop Strukturbaum aktualisieren (Toolbar)")
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_ColdListDokumente_Detail Method

Private Sub Update_ColdListDokumente_Detail( _
   ByVal doenable As Boolean _
)

Parameters

doenable
Required.

Source code

[Visual Basic]
    Private Sub Update_ColdListDokumente_Detail(ByVal doenable As Boolean)
        Try
            Dim cd As DataTable
            If doenable Then Me.ColdList.Enabled = False
            cd = Cold_Index_lesen(Me.ColdListDokumente.Columns("indextypnr").Value, 0)
            Me.ColdList.DataSource = cd
            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdList, cd, "coldlist")
            Me.TextBox15.Text = Me.DokList.Columns("dokunterschriftlinks").Text
            Me.TextBox16.Text = Me.DokList.Columns("dokunterschriftrechts").Text
            Me.TextBox17.Text = Me.DokList.Columns("dokzustaendig").Text
            Me.ColdList.Enabled = True
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Coldindex Method

Private Sub Update_Coldindex()

Source code

[Visual Basic]
    Private Sub Update_Coldindex()
        Me.ColdListDokumente.Enabled = False
        Me.ColdList.Enabled = False
        Dim ds As New DataSet()
        Dim cd As DataTable
        Dim cdHierarchie As DataTable

        Dim iCnt As Integer
        Try

            Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Normal
            cd = Cold_Index_lesen(0, 1)
            cdHierarchie = Cold_Index_lesen(0, 0)
            '----------------------------------------------
            ds.Tables.Add(cd)
            ds.Tables.Add(cdHierarchie)

            Dim dr As DataRelation
            Dim dc1 As DataColumn = cd.Columns("TreeID")
            Dim dc2 As DataColumn = cdHierarchie.Columns("SubTreeID")
            Dim rel As New DataRelation("RelColdIndex", dc1, dc2)
            Try
                Me.ColdListDokumente.DataView = C1.Win.C1TrueDBGrid.DataViewEnum.Hierarchical
            Catch ex As System.ArgumentException
                '  MsgBox(ex.Message)
            End Try

            ds.Relations.Add(rel)
            Me.ColdListDokumente.SetDataBinding(ds, ds.Tables(0).TableName)

            DivFnkt.SpaltenTitel_Aktualisieren(Me.ColdListDokumente, cd, "coldlistdokumente")
            If m_ExpandColdListDokumente < 0 Then m_ExpandColdListDokumente = 0
            If m_ExpandColdListDokumente < 1 Then
                For iCnt = 0 To ColdListDokumente.Splits(0).DisplayColumns.Count - 1
                    Select Case UCase(ColdListDokumente.Splits(0).DisplayColumns(iCnt).DataColumn.DataField)
                        Case "STATUSALT", "ARCHIVDATUMALT"
                            ColdListDokumente.Splits(0).DisplayColumns(iCnt).Visible = False
                    End Select
                Next
            End If

            Update_ColdListDokumente_Detail(False)
            Me.ColdListDokumente.Enabled = True
            Me.ColdList.Enabled = True
        Catch ex As Exception
            '  MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_DetailInformation Method

Private Sub Update_DetailInformation()

Source code

[Visual Basic]
    Private Sub Update_DetailInformation()
        Globals.PerfMon.insert_entry("'-- Begin Dokumentdetails")
        Me.Notizlist.Enabled = False
        Me.InfoMeldungList.Enabled = False
        Me.Zuordnungslist.Enabled = False
        Me.DokumentFunktionenList.Enabled = False
        Me.Cursor = Cursors.WaitCursor
        Select Case Me.TabControl1.SelectedTab.Name
            Case "TabPageAllgemein"
                Update_Details()
            Case "TabPageDokumentwerte"
                Update_Coldindex()
            Case "TabPageArchivierung"
                'update_archivierung()
            Case "TabPageInfomeldung"
                Update_DokumentInfoMeldung()
            Case "TabPageZuordnung"
                Update_Dokumentzuordnung()
            Case "TabPageStatus"
                Update_Status()
            Case "TabPageNotizen"
                Update_Notizen()
            Case "TabPageBerechtigung"
                Update_Dokumentfunktionen()
            Case "TabPage2"
                Update_Ersetzte_Dokumente()
        End Select
        Me.Notizlist.Enabled = True
        Me.InfoMeldungList.Enabled = True
        Me.Zuordnungslist.Enabled = True
        Me.DokumentFunktionenList.Enabled = True
        Me.Cursor = Cursors.Default
        Update_Details()

        Dim d As DataTable
        Dim I As Integer
        Try
            d = DivFnkt.Berechtigte_Mitarbeiter(Me.DokList.Columns("dokumenttypnr").Value, Globals.MitarbeiterNr, Me.DokList.Columns("partnernr").Value, Me.DokList.Columns("dokumentid").Value, 0, 0, 0, Me.DokList.Columns("vertraulich").Value, "")
            If Me.DokList.Columns("verantwortlich").Value <> Globals.MitarbeiterNr Then
                If d.Rows.Count = 0 And Globals.stv = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '           Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    Exit Sub
                End If
                If d.Rows(0).Item("anzeigen") = 0 Then
                    Me.pnlzensur1.Visible = True
                    Me.pnlzensur2.Visible = True
                    Me.pnlzensur3.Visible = True
                    Me.pnlzensur4.Visible = True
                    Me.pnlzensur5.Visible = True
                    Me.pnlzensur6.Visible = True
                    Me.lblzensur1.Visible = True
                    Me.lblzensur2.Visible = True
                    Me.lblzensur3.Visible = True
                    Me.lblzensur4.Visible = True
                    Me.lblzensur5.Visible = True
                    Me.lblzensur6.Visible = True
                    Me.ColdListDokumente.Visible = False
                    '            Me.DokList.Columns("Bemerkung").Value = ""
                    Me.TabControl1.Visible = True
                    Exit Sub
                End If
                d.Dispose()
                '
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '         Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
            Else
                Me.pnlzensur1.Visible = False
                Me.pnlzensur2.Visible = False
                Me.pnlzensur3.Visible = False
                Me.pnlzensur4.Visible = False
                Me.pnlzensur5.Visible = False
                Me.pnlzensur6.Visible = False
                Me.lblzensur1.Visible = False
                Me.lblzensur2.Visible = False
                Me.lblzensur3.Visible = False
                Me.lblzensur4.Visible = False
                Me.lblzensur5.Visible = False
                Me.lblzensur6.Visible = False
                Me.ColdListDokumente.Visible = True
                '                Me.DokList.Columns("Bemerkung").Value = ""
                Me.TabControl1.Visible = True
            End If
        Catch
            Me.TabControl1.Visible = False
        End Try
        Globals.PerfMon.insert_entry("'-- Ende Dokumentdetails")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Details Method

Private Sub Update_Details()

Source code

[Visual Basic]
    Private Sub Update_Details()
        Try
            Dim xbck As String

            Me.TextBox1.Text = Me.DokList.Columns("Dokumentid").Value
            If Me.DokList.Columns("Bemerkung").Text Is System.DBNull.Value Then
                Me.TextBox12.Text = ""
            Else
                Me.TextBox12.Text = Me.DokList.Columns("Bemerkung").Value
                ttip.SetToolTip(Me.TextBox12, Me.TextBox12.Text)
            End If

            If isbck() Then
                xbck = LTrim(Str(Me.bcknr))
                While Len(xbck) < 10
                    xbck = "0" + xbck
                End While
                Me.TextBox18.Text = xbck
            Else
                Me.TextBox18.Text = ""
            End If
            Me.TextBox2.Text = Str(Me.DokList.Columns("PartnerNr").Value) + " " + Me.DokList.Columns("Partnerkurzbezeichnung").Value
            Me.TextBox3.Text = Me.DokList.Columns("Dokumentart").Value
            Me.TextBox4.Text = Me.DokList.Columns("Bezeichnung").Value
            Me.TextBox5.Text = Me.DokList.Columns("Erstellungsdatum").Value
            Me.TextBox6.Text = Me.DokList.Columns("DokErsteller").Value
            If Me.DokList.Columns("Sperrdatum").Value Is System.DBNull.Value Then Me.TextBox7.Text = "" Else Me.TextBox7.Text = Me.DokList.Columns("Sperrdatum").Value
            If Me.DokList.Columns("DokSperrung").Value Is System.DBNull.Value Then
                Me.TextBox8.Text = ""
                Me.TextBox7.Text = ""
            Else
                Me.TextBox8.Text = Me.DokList.Columns("DokSperrung").Value
            End If
            Me.TextBox9.Text = Me.DokList.Columns("Mutationsdatum").Value
            Me.TextBox10.Text = Me.DokList.Columns("DokMutierer").Value
            Me.TextBox11.Text = Me.DokList.Columns("Status").Value
            Me.TextBox13.Text = Me.DokList.Columns("DokVerantwortlich").Value
            Me.TextBox14.Text = ""
            If (Me.DokList.Columns("termin").Value Is System.DBNull.Value) Or (Year(Me.DokList.Columns("termin").Value) = 1900) Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            '            If Me.DokList.Columns("termin").Value Is System.DBNull.Value Then Me.TextBox14.Text = "" Else Me.TextBox14.Text = Me.DokList.Columns("Termin").Value
            Me.TabControl1.Visible = True
        Catch ex As Exception
            '      MsgBox(ex.Message)
            '     Me.TabControl1.Visible = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Doklist Method

Private Sub Update_Doklist()

Source code

[Visual Basic]
    Private Sub Update_Doklist()
        Try
            If on_refresh Then
                Try
                    Me.DokList.DataSource = Nothing
                    Me.TabControl1.Visible = False
                Catch
                End Try
                Exit Sub
            End If
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            Dim i As Integer
            Dim xd As DataTable
            Me.DokList.Enabled = False
            Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
            xd = Dokumente_lesen()
            Me.doklistrowcount = xd.Rows.Count
            Me.DokList.DataSource = xd
            Try
                If xd.Rows.Count = 0 Then
                    Me.DokList.DataSource = Nothing
                    Me.TabControl1.Visible = False
                End If
            Catch
            End Try

            HOSTDATEN = False
            UVMDaten = False
            ZVDaten = False
            DivFnkt.SpaltenTitel_Aktualisieren(Me.DokList, xd, "trefferliste")
            For i = 0 To Me.DokList.Splits(0).DisplayColumns.Count - 1
                If UCase(Me.DokList.Columns(i).DataField) = "PARTNERNR_INHABER" Then HOSTDATEN = True
                If UCase(Me.DokList.Columns(i).DataField) = "NRAUF00" Then UVMDaten = True
                If UCase(Me.DokList.Columns(i).DataField) = "CDVAR00" Then ZVDaten = True
                Me.DokList.Splits(0).DisplayColumns(i).AutoSize()
            Next

            Load_Layout()
            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns(2).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                    'Dim I1 As Integer
                    'For I1 = 0 To Me.DokList.Columns.Count - 1
                    '    If Me.DokList.Splits(0).DisplayColumns(I1).Name().ToString = "Betrag" Then
                    '        Me.DokList.Splits(0).DisplayColumns(I1).Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                    '    End If
                    'Next
                End If
            Catch
            End Try

            Try
                If ZVDaten = True Then
                    Me.DokList.Splits(0).DisplayColumns("Betrag").Style.HorizontalAlignment = C1.Win.C1TrueDBGrid.AlignHorzEnum.Far
                End If
            Catch
            End Try

            If Not HOSTDATEN And Not ZVDaten And Not UVMDaten Then Me.DokList.Splits(0).DisplayColumns("bemerkung").FetchStyle = True

            Me.Cursor = System.Windows.Forms.Cursors.Default
            Try
                Dim cols(Me.DokList.Splits(0).DisplayColumns.Count - 1) As C1.Win.C1TrueDBGrid.C1DisplayColumn
                Dim anzcols As Integer
                anzcols = Me.DokList.Splits(0).DisplayColumns.Count
                Update_DetailInformation()

                Dim bmp0 As New Bitmap(Me.ImageList4.Images(0))
                Dim bmp1 As New Bitmap(Me.ImageList4.Images(1))
                Dim bmp2 As New Bitmap(Me.ImageList4.Images(2))
                Dim bmp3 As New Bitmap(Me.ImageList4.Images(3))

                Dim v0 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v1 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v2 As New C1.Win.C1TrueDBGrid.ValueItem()
                Dim v3 As New C1.Win.C1TrueDBGrid.ValueItem()
                v0.DisplayValue = bmp0
                v0.Value = 1

                v1.DisplayValue = bmp1
                v1.Value = 2

                v2.DisplayValue = bmp2
                v2.Value = 3

                v3.DisplayValue = bmp3
                v3.Value = 4

                For i = 0 To 3
                    Me.DokList.Columns(i).ValueItems.Values.Add(v0)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v1)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v2)
                    Me.DokList.Columns(i).ValueItems.Values.Add(v3)

                    Me.DokList.Columns(i).ValueItems.Translate = True
                Next i

                Me.DokList.Enabled = True
            Catch
            End Try
        Catch ex As Exception
            Me.Cursor = System.Windows.Forms.Cursors.Default
        Finally
            Me.Cursor = System.Windows.Forms.Cursors.Default
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_DokumentInfoMeldung Method

Private Sub Update_DokumentInfoMeldung()

Source code

[Visual Basic]
    Private Sub Update_DokumentInfoMeldung()
        Dim dokumentinfomeldung As DataTable
        dokumentinfomeldung = Dokumentinfomeldungen_laden()
        Me.InfoMeldungList.DataSource = dokumentinfomeldung
        Me.InfoMeldungList.Columns("aktiv").FilterText = True
        DivFnkt.SpaltenTitel_Aktualisieren(Me.InfoMeldungList, dokumentinfomeldung, "Dokumentinfomeldung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Dokumentfunktionen Method

Private Sub Update_Dokumentfunktionen()

Source code

[Visual Basic]
    Private Sub Update_Dokumentfunktionen()
        Dim Dokumentfunktionen As DataTable
        Dokumentfunktionen = Dokumentfunktionen_Laden()
        Me.DokumentFunktionenList.DataSource = Dokumentfunktionen
        Me.DokumentFunktionenList.DataMember = Dokumentfunktionen.TableName
        Me.DokumentFunktionenList.Columns("aktiv").FilterText = True
        Me.DokumentFunktionenList.FilterBar = False
        DivFnkt.SpaltenTitel_Aktualisieren(Me.DokumentFunktionenList, Dokumentfunktionen, "berechtigungseinschraenkung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Dokumentzuordnung Method

Private Sub Update_Dokumentzuordnung()

Source code

[Visual Basic]
    Private Sub Update_Dokumentzuordnung()
        Dim dokumentzuordnungen As DataTable
        Dim i As Integer
        dokumentzuordnungen = Dokumentzuordnungen_Laden()
        Me.Zuordnungslist.DataSource = dokumentzuordnungen
        Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.ComboBox

        Dim dxx As New SqlDataAdapter("Select zuordnungnr, bezeichnung from zuordnung", Globals.sConnectionString)
        Dim dh As New DataSet()
        dxx.Fill(dh, "dd")
        Dim vv(100)
        For i = 0 To dh.Tables(0).Rows.Count - 1
            vv(i) = New C1.Win.C1TrueDBGrid.ValueItem()
            vv(i).DisplayValue = dh.Tables(0).Rows(i).Item("bezeichnung")
            vv(i).Value = dh.Tables(0).Rows(i).Item("zuordnungnr")
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Values.Add(vv(i))
            Me.Zuordnungslist.Columns("zuordnungnr").ValueItems.Translate = True
        Next
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Zuordnungslist, dokumentzuordnungen, "dokumentzuordnungentr")

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Ersetzte_Dokumente Method

Private Sub Update_Ersetzte_Dokumente()

Source code

[Visual Basic]
    Private Sub Update_Ersetzte_Dokumente()
        Dim ed As DataTable
        ed = ErsetzteDokumente_Laden()
        Me.ErsetzteDokumenteList.DataSource = ed
        DivFnkt.SpaltenTitel_Aktualisieren(Me.ErsetzteDokumenteList, ed, "ersetztedokumente")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Notizen Method

Private Sub Update_Notizen()

Source code

[Visual Basic]
    Private Sub Update_Notizen()
        Dim Notizen As DataTable
        Notizen = Notizen_Laden()
        Me.Notizlist.DataSource = Notizen
        Mitarbeiter_Laden()         'koe 28.07.2004
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Notizlist, Notizen, "notizen")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Partnerstruktur Method

Public Sub Update_Partnerstruktur()

Source code

[Visual Basic]
    Public Sub Update_Partnerstruktur()
        Dim x As Long
        '        If Me.update_host Then Exit Sub
        Globals.hasmessage = 0
        x = Val(Me.Partnernr)
        If x = 0 Then Exit Sub
        Globals.PerfMon.insert_entry("'-- Begin Update Partnerstruktur")
        Me.Cursor = Cursors.WaitCursor
        '        Me.tvstruktur.BeginUpdate()

        If (Me.tvstruktur.SelectedNode.Nodes.Count = 1 And InStr(Me.tvstruktur.SelectedNode.Tag, "-") = 0) Or _
        Me.tvstruktur.SelectedNode.Text = "HOST " Then
            Me.tvstruktur.SelectedNode.Nodes.Clear()
            Me.DokList.Enabled = False
            Dim d As New edokadb.clsMyDokumentart()
            '            Me.tvstruktur.BeginUpdate()
            d.Geschaeftsfall = Me.Geschaeftsfall
            d.SelectPartner = False
            d.SearchString = ""
            If Me.Partner_Eingegeben = True Then
                If Me.txtnrpar00.Text.Length > 0 Then
                    If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" Then
                        d.SearchString = "VA:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" Then
                        d.SearchString = "IS:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
                        d.SearchString = "VV:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemPartnersuche.Text + ":" Then
                        d.SearchString = "HOST"
                    End If
                Else
                    d.SearchString = ""
                End If
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.Partnernr, Me.tvstruktur.SelectedNode, 1, 1, False)
            Else
                If Me.txtnrpar00.Text.Length > 0 Then
                    If Me.LblSearch.Text = Me.MenuItemValorSuche.Text + ":" Then
                        d.SearchString = "VA:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemISINSUche.Text + ":" Then
                        d.SearchString = "IS:" + Me.txtnrpar00.Text
                    End If
                    If Me.LblSearch.Text = Me.MenuItemVVSuche.Text + ":" Then
                        d.SearchString = "VV:" + Me.txtnrpar00.Text
                    End If
                Else
                    d.SearchString = ""
                End If
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.Partnernr, Me.tvstruktur.SelectedNode, 1, 0, False)
            End If
        End If
        '       Me.tvstruktur.EndUpdate()
        Me.DokList.Enabled = True
        '       Me.tvstruktur.EndUpdate()
        Me.Cursor = Cursors.Default
        If Not Me.update_host Then
            If Globals.hasmessage = 1 Then MyMsg.show_standardmessage(90, MsgBoxStyle.Information)
            '            Me.update_host = True
        End If
        Globals.PerfMon.insert_entry("'-- Ende Update Partnerstruktur")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.Update_Status Method

Private Sub Update_Status()

Source code

[Visual Basic]
    Private Sub Update_Status()
        colornotset = True
        Dim st As DataTable
        st = Status_lesen()
        Me.Statuslist.FetchRowStyles = True
        Me.Statuslist.DataSource = Nothing
        Me.Statuslist.DataSource = st
        DivFnkt.SpaltenTitel_Aktualisieren(Me.Statuslist, st, "statushistory")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.btnPartnersuche_VisibleChanged Method

Private Sub btnPartnersuche_VisibleChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnersuche.VisibleChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnersuche_VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles btnPartnersuche.VisibleChanged
        If Me.btnPartnersuche.Visible = False Then
            Me.Button1.Visible = True
        Else
            Me.Button1.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.cbProfile_SelectedIndexChanged Method

Private Sub cbProfile_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbProfile.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbProfile_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbProfile.SelectedIndexChanged
        Me.PageDirection = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.check_bearbeitung Method

Private Function check_bearbeitung() As Boolean

Source code

[Visual Basic]
    Private Function check_bearbeitung() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_bearbeitung_nach_abschluss"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bearbeitung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@bearbeitung").Value
            If i = 0 Then
                check_bearbeitung = False
            Else
                check_bearbeitung = True
            End If
        Catch ex As Exception
            '            MsgBox(ex.Message)
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.check_dokumentreaktivieren Method

Private Function check_dokumentreaktivieren() As Boolean

Source code

[Visual Basic]
    Private Function check_dokumentreaktivieren() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_check_dokumentreaktivierung"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentreaktivierung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@dokumentreaktivierung").Value
            If i = 0 Then
                check_dokumentreaktivieren = False
            Else
                check_dokumentreaktivieren = True
            End If
        Catch ex As Exception
            '            MsgBox(ex.Message)
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.dokument_ist_abgeschlossen Method

Public Function dokument_ist_abgeschlossen( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
    Public Function dokument_ist_abgeschlossen(ByVal dokumentid As String) As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_dokument_abgeschlossen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@abschlussstatus", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            i = scmCmdToExecute.Parameters.Item("@abschlussstatus").Value
            If i = 0 Then
                dokument_ist_abgeschlossen = False
            Else
                dokument_ist_abgeschlossen = True
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.frmTrefferliste_Closing Method

Private Sub frmTrefferliste_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmTrefferliste_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        '        Save_Layout()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.frmTrefferliste_Resize Method

Private Sub frmTrefferliste_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmTrefferliste_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.Button2.Left = Me.ToolBar1.Width - Me.Button2.Width
        Try
            Me.BtnHelp.Left = Me.ToolBar1.Width - Me.BtnHelp.Width
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.gaga Method

Private Sub gaga()

Source code

[Visual Basic]
    Private Sub gaga()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.getnodedepth Method

Private Function getnodedepth( _
   ByVal node As TreeNode _
) As Long

Parameters

node
Required.

Source code

[Visual Basic]
    Private Function getnodedepth(ByVal node As TreeNode) As Long
        Try
            Me.Partnernr = LTrim(RTrim(Microsoft.VisualBasic.Left(node.Parent.Text, 11)))
        Catch
        End Try
        If Not (node.Parent Is Nothing) Then
            getnodedepth = getnodedepth(node.Parent) + 1
        Else
            getnodedepth = 1
            Try
                Me.Partnernr = LTrim(RTrim(Microsoft.VisualBasic.Left(node.Text, 11)))
            Catch
            End Try
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.imgcombo_SelectedIndexChanged_1 Method

Private Sub imgcombo_SelectedIndexChanged_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub imgcombo_SelectedIndexChanged_1(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim i As Integer
        Init_Pages()
        Globals.PerfMon.insert_entry("Start Wechsel Profil")
        If Me.On_Load = True Then Exit Sub
        If Me.LoadProfiles Then Exit Sub
        Me.Partner_Eingegeben = False
        i = Me.ImgCombo.SelectedValue
        Set_Colors()
        Me.txtnrpar00.Text = ""
        Try
            Name_of_Trefferliste()
            Me.Profilnr = Me.ImgCombo.SelectedValue
        Catch
        End Try
        on_refresh = True
        refresh_list()
        on_refresh = False
        Load_Layout()
        Globals.PerfMon.insert_entry("Stop Wechsel Profil")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.isbck Method

Private Function isbck() As Boolean

Source code

[Visual Basic]
    Private Function isbck() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "sp_check_bck"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@isbck", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@isbck").Value = 1 Then
                isbck = True
                Me.bcknr = scmCmdToExecute.Parameters("@bcknr").Value
            Else
                isbck = False
                Me.bcknr = 0
            End If

        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("CheckBCK:" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.lblpageno_TextChanged Method

Private Sub lblpageno_TextChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles lblpageno.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub lblpageno_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles lblpageno.TextChanged
        If Me.lblpageno.Text = "0" Then Me.lblpageno.Text = "1"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.mnuFreitextSuche_Click Method

Private Sub mnuFreitextSuche_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuFreitextSuche.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuFreitextSuche_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuFreitextSuche.Click
        Dim s As String
        s = InputBox("Suchbegriff", "EDOKA-Freitextsuche")
        If s = "" Then Exit Sub
        If Me.DokList.Columns("partnernr_inhaber").Text <> "" Then
            Dim d As DataTable
            Dim x As New frmcoldview()
            d = x.Freitextsuche(Me.DokList.DataSource, s, "HOST")
            Me.DokList.DataSource = d
            x.Dispose()
        End If
        Try
            If Me.DokList.Columns("nrauf00").Text <> "" Then
                Dim d As DataTable
                Dim x As New frmcoldview()
                d = x.Freitextsuche(Me.DokList.DataSource, s, "UVM")
                Me.DokList.DataSource = d
                x.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.mnuSendMessage_Click Method

Private Sub mnuSendMessage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuSendMessage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuSendMessage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuSendMessage.Click
        '*************************************************************
        'Sendet eine EDOKA-Meldung mit der gewählten DokID
        '
        'Ersteller: bud
        'Erstellt am: 09.08.2004
        'Rel 3.2
        '*************************************************************
        Dim fMessage As New frmMeldungen()
        Dim f As New frmMessageWeiterleitung()
        Dim sMessage As String

        f.TextBox1.Text = ""
        f.TextBox2.Text = ""

        f.propBezeichnung = Me.DokList.Columns("Bezeichnung").Value
        f.propINFO = Me.DokList.Columns("Erstellungsdatum").Value
        f.propPartnerNR = Me.DokList.Columns("partnernr").Value
        '
        'Me.DokList.Columns("nrpar00").CellValue(e.Row)
        f.TextBox2.Enabled = True
        f.ShowDialog()

        If f.Empfaenger > 0 Then
            fMessage.propWithDokID = True
            fMessage.propDokID = Me.DokList.Columns("dokumentid").Value
            fMessage.propBetreff = f.TextBox2.Text
            fMessage.propEmpfaenger = f.Empfaenger
            fMessage.propMeldungText = f.TextBox1.Text
            fMessage.Generic_Select(5)
            f.Dispose()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.nrpar00_KeyDown Method

Private Sub nrpar00_KeyDown( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtnrpar00.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub nrpar00_KeyDown(ByVal sender As System.Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtnrpar00.KeyDown
        If e.KeyCode = Keys.Enter Then
            DoKeyenter()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.refresh_list Method

Public Sub refresh_list()

Source code

[Visual Basic]
    Public Sub refresh_list()
        If On_Load Then Exit Sub
        Globals.PerfMon.insert_entry("'-- Begin Aufbau Strukturbaum")
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        Me.DokList.DataSource = Nothing
        Me.TabControl1.Visible = False
        Me.DokList.Enabled = False
        Dim d As New edokadb.clsMyDokumentart()
        Globals.hasmessage = 0
        Me.tvstruktur.BeginUpdate()

        d.SelectPartner = True
        If Partner_Eingegeben And Microsoft.VisualBasic.Left(Me.LblSearch.Text, Len(Me.LblSearch.Text) - 1) = Me.MenuItemPartnersuche.Text Then
            Me.on_refresh = True
            d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, Me.txtnrpar00.Text, Nothing, 1, 1, True)
            If Me.tvstruktur.GetNodeCount(False) = 0 Then
                Me.tvstruktur.Nodes.Add("Keine Daten vorhanden")
            End If
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            Me.Partnernr = LTrim(RTrim(Me.txtnrpar00.Text))
            Name_of_Trefferliste()
            Me.tvstruktur.SelectedNode.ExpandAll()

            Me.Button3.Enabled = False
            Me.Button4.Enabled = False
            Me.lblpageno.Text = 1
            Me.on_refresh = False
        Else
            If Partner_Eingegeben Then
                d.SearchString = UCase(Microsoft.VisualBasic.Left(Me.LblSearch.Text, 2) + ":" + Me.txtnrpar00.Text)
                If CurrentPage = 1 Then tpagemax(0) = 0
            Else
                d.SearchString = ""
            End If

            If tpagemin(CurrentPage) = 0 Then
                'd.FirstEntry = 0
                d.FirstEntry = tpagemax(CurrentPage - 1)
                d.LastEntry = 999999999
            Else
                d.FirstEntry = tpagemin(CurrentPage)
                d.LastEntry = tpagemax(CurrentPage)
            End If
            d.PageDirection = Me.PageDirection
            If Partner_Eingegeben Then
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, True)
            Else
                d.LoadTreeMenu_Profil(Me.tvstruktur, Me.Profilnr, 0, Nothing, 1, 0, False)
            End If

            If tpagemin(CurrentPage) = 0 Then
                Me.tpagemin(CurrentPage) = d.FirstEntry
                Me.tpagemax(CurrentPage) = d.LastEntry
            End If

            If Me.CurrentPage = 1 Then Me.Button3.Enabled = False Else Me.Button3.Enabled = True
            If d.PageDirection > 0 Or maxpage > CurrentPage Then Me.PageDirection = 1 Else Me.PageDirection = 0
            If Me.CurrentPage >= Me.maxpage Then Me.maxpage = Me.CurrentPage
            Me.lblpageno.Text = Me.CurrentPage.ToString
        End If

        'Me.tvstruktur.ExpandAll()
        If Me.tvstruktur.GetNodeCount(False) = 1 Then
            Me.tvstruktur.SelectedNode = Me.tvstruktur.Nodes(0)
            getnodedepth(Me.tvstruktur.SelectedNode)
            Name_of_Trefferliste()
            Me.Update_Partnerstruktur()
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If
        If Me.tvstruktur.GetNodeCount(False) = 0 Then
            Me.tvstruktur.Nodes.Add("Keine Daten vorhanden")
        End If
        Me.DokList.Enabled = True
        Me.tvstruktur.EndUpdate()
        Me.Cursor = System.Windows.Forms.Cursors.Default
        Globals.PerfMon.insert_entry("'-- Ende Aufbau Strukturbaum")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.set_abgeschlossen_menu Method

Private Sub set_abgeschlossen_menu()

Source code

[Visual Basic]
    Private Sub set_abgeschlossen_menu()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_abgeschlossenes_dokument"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("dokumentid").Text))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@indexmutation", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aufhebung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@loeschung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            Me.MnuABDokAufheben.Enabled = False
            Me.MnuABDokLoeschen.Enabled = False
            Me.MenuItem38.Visible = False

            i = scmCmdToExecute.Parameters.Item("@indexmutation").Value
            If i <> 0 Then
                Me.MenuItem21.Enabled = True
                'Me.MenuItem38.Enabled = True
            End If
            i = scmCmdToExecute.Parameters.Item("@aufhebung").Value
            If i <> 0 Then
                Me.MnuABDokAufheben.Enabled = True
                Me.MenuItem21.Enabled = True
            End If
            i = scmCmdToExecute.Parameters.Item("@loeschung").Value
            If i <> 0 Then
                If Me.DokList.Columns("aktivesdokument").Value = True Then
                    Me.MnuABDokLoeschen.Enabled = True
                End If
                '                Me.MenuItem21.Enabled = True
            End If
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.set_combo Method

Public Sub set_combo( _
   ByVal pnr As Integer _
)

Parameters

pnr
Required.

Source code

[Visual Basic]
    Public Sub set_combo(ByVal pnr As Integer)
        Dim i As Integer
        Dim ii As Integer
        Me.On_Load = True
        For i = 0 To Me.ImgCombo.Items.Count - 1
            Me.ImgCombo.SelectedIndex = i
            ii = Me.ImgCombo.SelectedValue
            If ii = pnr Then Me.ImgCombo.SelectedIndex = i
        Next
        Me.ImgCombo.SelectedValue = pnr
        Me.Profilnr = pnr
        Me.OnlySelect = False

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.set_tips Method

Private Sub set_tips()

Source code

[Visual Basic]
    Private Sub set_tips()
        Dim ttip As New ToolTip()
        ttip.SetToolTip(Me.Button3, Globals.MyTxt.gettext(22100))
        ttip.SetToolTip(Me.Button5, Globals.MyTxt.gettext(22101))
        ttip.SetToolTip(Me.Button6, Globals.MyTxt.gettext(22102))
        ttip.SetToolTip(Me.Button4, Globals.MyTxt.gettext(22103))
        SearchTip.RemoveAll()
        SearchTip.SetToolTip(Me.txtnrpar00, Globals.MyTxt.gettext(22104))
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_AfterExpand Method

Private Sub tvstruktur_AfterExpand( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles tvstruktur.AfterExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_AfterExpand(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles tvstruktur.AfterExpand
        Try
            Me.tvstruktur.SelectedNode.ExpandAll()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_AfterSelect Method

Private Sub tvstruktur_AfterSelect( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles tvstruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_AfterSelect(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles tvstruktur.AfterSelect
        Try
            If on_refresh Then Exit Sub
            If Me.tvstruktur.SelectedNode.Text = "HOST " Then Exit Sub
            Try
                If Len(Trim(Me.tvstruktur.SelectedNode.Tag)) < 9 Then Me.on_refresh = True
            Catch
            End Try
            'Me.tvstruktur.BeginUpdate()
            Globals.PerfMon.insert_entry("Start Auswahl Strukturbaum (Click)")
            Dim splitter() As String
            Dim i As Integer
            i = getnodedepth(Me.tvstruktur.SelectedNode)
            Try
                Me.savenode.ForeColor = Black
            Catch
            End Try
            Me.tvstruktur.SelectedNode.ForeColor = Red
            Me.savenode = Me.tvstruktur.SelectedNode
            Me.tvstruktur.BeginUpdate()
            If InStr(LTrim(Me.tvstruktur.SelectedNode.Tag), " ") > 0 Then
                splitter = Split(LTrim(Me.tvstruktur.SelectedNode.Tag), " ")
                Try
                    Me.SelectedDocart = splitter(1)
                    Update_Doklist()
                    For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                        Me.ContextMenu2.MenuItems(i).Enabled = True
                    Next
                Catch
                    Me.SelectedDocart = ""
                    For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                        Me.ContextMenu2.MenuItems(i).Enabled = False
                    Next
                End Try
            Else
                Me.SelectedDocart = ""
                Update_Doklist()
                For i = 0 To Me.ContextMenu2.MenuItems.Count - 1
                    Me.ContextMenu2.MenuItems(i).Enabled = True
                Next
            End If
            Me.tvstruktur.EndUpdate()
            Me.Cursor = Cursors.Default
            Me.on_refresh = False
            Globals.PerfMon.insert_entry("Stop Auswahl Strukturbaum (Click)")
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_BeforeExpand Method

Private Sub tvstruktur_BeforeExpand( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles tvstruktur.BeforeExpand

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_BeforeExpand(ByVal sender As System.Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles tvstruktur.BeforeExpand
        Try
            If Me.On_Load Then Exit Sub
            If Me.on_refresh Then Exit Sub
            'Me.tvstruktur.BeginUpdate()
            If Me.tvstruktur.SelectedNode.IsExpanded = False Then
                Globals.PerfMon.insert_entry("Start Strukturelement öffnen")
                Update_Partnerstruktur()
                Globals.PerfMon.insert_entry("Stop Strukturelement öffnen")
            End If
            'Me.tvstruktur.EndUpdate()
            Me.Cursor = Cursors.Default
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_DoubleClick Method

Private Sub tvstruktur_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles tvstruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles tvstruktur.DoubleClick
        If Me.tvstruktur.SelectedNode.Text = "HOST " Then
            Me.Update_Partnerstruktur()
            Me.tvstruktur.SelectedNode.ExpandAll()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_MouseEnter Method

Private Sub tvstruktur_MouseEnter( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles tvstruktur.MouseEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_MouseEnter(ByVal sender As Object, ByVal e As System.EventArgs) Handles tvstruktur.MouseEnter
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.tvstruktur_MouseMove Method

Private Sub tvstruktur_MouseMove( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles tvstruktur.MouseMove

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tvstruktur_MouseMove(ByVal sender As System.Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles tvstruktur.MouseMove
        Try
            If e.X < 10 Then
                selp.Y = e.Y
                selp.X = e.X
                Dim i As Integer
                i = Me.tvstruktur.GetNodeAt(selp).Index + 1
                If i = 1 Then
                    tt.RemoveAll()
                    Exit Sub
                End If
                tt.SetToolTip(Me.tvstruktur, Str(i) + " / " + Str(Me.tvstruktur.Nodes.Count))
                tt.AutoPopDelay = 500
            Else
                tt.RemoveAll()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.txtbcknr_KeyDown Method

Private Sub txtbcknr_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles txtbcknr.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtbcknr_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles txtbcknr.KeyDown
        If e.KeyCode = Keys.Enter Then
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "sp_search_bck"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtbcknr.Text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@rc", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@OldDokumentFound", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@rc").Value = 0 Then
                    If scmCmdToExecute.Parameters("@OldDokumentFound").Value = 0 Then
                        Me.txtnrpar00.Text = scmCmdToExecute.Parameters("@nrpar00").Value
                    Else
                        'DokumentID/Barcode wurde durch eine neue Erstezt
                        MyMsg.show_standardmessage(502, MsgBoxStyle.Information) 'Ein Dokument mit der eingegeben ID/Barcodekleber-Nr wurde durch eine neue ID/Barcodekleber-Nr. erstezt.
                        Me.txtnrpar00.Text = scmCmdToExecute.Parameters("@nrpar00").Value
                    End If
                    DoKeyenter()
                Else
                    MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
                End If

            Catch ex As Exception
                MyMsg.show_standardmessage(85, MsgBoxStyle.Information)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex.txtnrpar00_textchanged Method

Private Sub txtnrpar00_textchanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtnrpar00.TextChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtnrpar00_textchanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtnrpar00.TextChanged
        If Me.txtnrpar00.Text = "" Then Me.Partner_Eingegeben = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmTrefferlistex Fields

frmTrefferlistex overview

Fields

field AlleDokumente
field BtnHelp
field BtnPrint
field BtnProfil
field Button1
field Button2
field Button3
field Button4
field Button5
field Button6
field Button7
field Button8
field Button9
field ColdList
field ColdListDokumente
field ContextMenu1
field ContextMenu10
field ContextMenu2
field ContextMenu3
field ContextMenu4
field ContextMenu5
field ContextMenu6
field ContextMenu7
field ContextMenu8
field ContextMenu9
field CurrentPage
field DataSet1
field DokList
field DokumentFunktionenList
field ErsetzteDokumenteList
field HOSTDATEN
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field InfoMeldungList
field Label1
field Label10
field Label11
field Label12
field Label14
field Label15
field Label16
field Label17
field Label18
field Label19
field Label2
field Label20
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field LblSearch
field LoadProfiles
field M_FROMMENU
field MainMenu1
field MenuItem1
field MenuItem10
field MenuItem11
field MenuItem12
field MenuItem13
field MenuItem14
field MenuItem15
field MenuItem16
field MenuItem17
field MenuItem18
field MenuItem19
field MenuItem2
field MenuItem20
field MenuItem21
field MenuItem22
field MenuItem23
field MenuItem24
field MenuItem25
field MenuItem26
field MenuItem27
field MenuItem28
field MenuItem29
field MenuItem3
field MenuItem30
field MenuItem31
field MenuItem32
field MenuItem33
field MenuItem34
field MenuItem35
field MenuItem36
field MenuItem37
field MenuItem38
field MenuItem39
field MenuItem4
field MenuItem40
field MenuItem41
field MenuItem42
field MenuItem43
field MenuItem44
field MenuItem45
field MenuItem46
field MenuItem47
field MenuItem48
field MenuItem49
field MenuItem5
field MenuItem50
field MenuItem51
field MenuItem52
field MenuItem53
field MenuItem54
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuItemISINSUche
field MenuItemPartnersuche
field MenuItemVVSuche
field MenuItemValorSuche
field MnuABDokAufheben
field MnuABDokLoeschen
field MnuAbgeschlossen
field MnuClose
field MnuDokumentSelect
field MnuDokumentreaktivieren
field MnuNotizanzeigen
field MnuProfil
field MnuSearch
field Notizlist
field On_Load
field Panel1
field Panel2
field Panel3
field Panel4
field PreviewAlleDokumente
field RBStatusAktuell
field RBStatusHistory
field SearchTip
field Splitter1
field Splitter2
field SqlConnection1
field SqlConnection2
field SqlConnection3
field SqlDataAdapter1
field SqlInsertCommand1
field SqlSelectCommand1
field Statuslist
field TabControl1
field TabControl2
field TabPage1
field TabPage2
field TabPage3
field TabPageAllgemein
field TabPageBerechtigung
field TabPageDokumentwerte
field TabPageInfomeldung
field TabPageNotizen
field TabPageStatus
field TabPageZuordnung
field TextBox1
field TextBox10
field TextBox11
field TextBox12
field TextBox13
field TextBox14
field TextBox15
field TextBox16
field TextBox17
field TextBox18
field TextBox2
field TextBox3
field TextBox4
field TextBox5
field TextBox6
field TextBox7
field TextBox8
field TextBox9
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field UVMDaten
field ZVDaten
field Zuordnungslist
field al
field bcknr
field bntNewDoc
field btnExit
field btnPartnersuche
field cbProfile
field cmitprofil
field colornotset
field components
field doklistrowcount
field drpMiatarbeiter
field lblpageno
field lblzensur1
field lblzensur2
field lblzensur3
field lblzensur4
field lblzensur5
field lblzensur6
field m_ColdListDokumenteDefaultWidth
field m_DTMitarbeiter
field m_ExpandColdListDokumente
field m_FirstEntry
field m_LastEntry
field m_dokumentbezeichnung
field m_dokumentdatum
field m_geschaeftsfall
field m_onlyselect
field m_pagedirection
field m_partnernr
field m_profilnr
field m_refresh
field m_selectedbeschreibung
field m_selecteddocart
field m_selecteddokumentid
field maxpage
field mnuFreitextSuche
field mnuSendMessage
field on_refresh
field pnlSearch
field pnlzensur1
field pnlzensur2
field pnlzensur3
field pnlzensur4
field pnlzensur5
field pnlzensur6
field savenode
field scolor1
field scolor2
field scolor3
field scolor4
field scolor5
field scolor6
field selectPoint
field selp
field statushistory
field tpagemax
field tpagemin
field tt
field ttip
field tvstruktur
field txtbcknr
field txtnrpar00
field update_host
field vertraulich

See Also

frmTrefferlistex Class


AlleDokumente Variable

Dim AlleDokumente As Boolean = False

Source code

[Visual Basic]
    Dim AlleDokumente As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


BtnPrint Variable

Friend WithEvents BtnPrint As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents BtnPrint As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


BtnProfil Variable

Friend WithEvents BtnProfil As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents BtnProfil As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button5 Variable

Friend WithEvents Button5 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button5 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button6 Variable

Friend WithEvents Button6 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button6 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button7 Variable

Friend WithEvents Button7 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button7 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button8 Variable

Friend WithEvents Button8 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button8 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Button9 Variable

Friend WithEvents Button9 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button9 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ColdList Variable

Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ColdListDokumente Variable

Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ColdListDokumente As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu10 Variable

Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu10 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu4 Variable

Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu4 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu5 Variable

Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu5 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu6 Variable

Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu6 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu7 Variable

Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu7 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu8 Variable

Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu8 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ContextMenu9 Variable

Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu9 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


CurrentPage Variable

Dim CurrentPage As Integer

Source code

[Visual Basic]
    Dim CurrentPage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


DokList Variable

Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


DokumentFunktionenList Variable

Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents DokumentFunktionenList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ErsetzteDokumenteList Variable

Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents ErsetzteDokumenteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


HOSTDATEN Variable

Dim HOSTDATEN As Boolean

Source code

[Visual Basic]
    Dim HOSTDATEN As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ImageList4 Variable

Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


InfoMeldungList Variable

Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents InfoMeldungList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label12 Variable

Friend WithEvents Label12 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label12 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label14 Variable

Friend WithEvents Label14 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label14 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label15 Variable

Friend WithEvents Label15 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label15 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label16 Variable

Friend WithEvents Label16 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label16 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label17 Variable

Friend WithEvents Label17 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label17 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label18 Variable

Friend WithEvents Label18 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label18 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label19 Variable

Friend WithEvents Label19 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label19 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label20 Variable

Friend WithEvents Label20 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label20 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


LblSearch Variable

Friend WithEvents LblSearch As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents LblSearch As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


LoadProfiles Variable

Dim LoadProfiles As Boolean = False

Source code

[Visual Basic]
    Dim LoadProfiles As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


M_FROMMENU Variable

Dim M_FROMMENU As Boolean = False

Source code

[Visual Basic]
    Dim M_FROMMENU As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MainMenu1 Variable

Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Source code

[Visual Basic]
    Friend WithEvents MainMenu1 As System.Windows.Forms.MainMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem11 Variable

Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem11 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem14 Variable

Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem14 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem15 Variable

Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem15 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem16 Variable

Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem16 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem17 Variable

Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem17 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem18 Variable

Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem18 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem19 Variable

Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem19 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem20 Variable

Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem20 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem21 Variable

Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem21 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem22 Variable

Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem22 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem23 Variable

Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem23 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem24 Variable

Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem24 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem25 Variable

Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem25 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem26 Variable

Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem26 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem27 Variable

Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem27 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem28 Variable

Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem28 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem29 Variable

Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem29 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem30 Variable

Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem30 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem31 Variable

Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem31 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem32 Variable

Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem32 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem33 Variable

Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem33 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem34 Variable

Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem34 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem35 Variable

Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem35 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem36 Variable

Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem36 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem37 Variable

Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem37 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem38 Variable

Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem38 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem39 Variable

Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem39 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem40 Variable

Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem40 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem41 Variable

Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem41 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem42 Variable

Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem42 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem43 Variable

Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem43 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem44 Variable

Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem44 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem45 Variable

Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem45 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem46 Variable

Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem46 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem47 Variable

Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem47 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem48 Variable

Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem48 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem49 Variable

Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem49 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem50 Variable

Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem50 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem51 Variable

Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem51 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem52 Variable

Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem52 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem53 Variable

Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem53 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem54 Variable

Friend WithEvents MenuItem54 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem54 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItemISINSUche Variable

Friend WithEvents MenuItemISINSUche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemISINSUche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItemPartnersuche Variable

Friend WithEvents MenuItemPartnersuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemPartnersuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItemVVSuche Variable

Friend WithEvents MenuItemVVSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemVVSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MenuItemValorSuche Variable

Friend WithEvents MenuItemValorSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItemValorSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuABDokAufheben Variable

Friend WithEvents MnuABDokAufheben As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuABDokAufheben As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuABDokLoeschen Variable

Friend WithEvents MnuABDokLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuABDokLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuAbgeschlossen Variable

Friend WithEvents MnuAbgeschlossen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAbgeschlossen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuClose Variable

Friend WithEvents MnuClose As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuClose As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuDokumentSelect Variable

Friend WithEvents MnuDokumentSelect As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentSelect As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuDokumentreaktivieren Variable

Friend WithEvents MnuDokumentreaktivieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentreaktivieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuNotizanzeigen Variable

Friend WithEvents MnuNotizanzeigen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNotizanzeigen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuProfil Variable

Friend WithEvents MnuProfil As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuProfil As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


MnuSearch Variable

Friend WithEvents MnuSearch As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents MnuSearch As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Notizlist Variable

Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Notizlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


On_Load Variable

Dim On_Load As Boolean

Source code

[Visual Basic]
    Dim On_Load As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Panel4 Variable

Friend WithEvents Panel4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


PreviewAlleDokumente Variable

Dim PreviewAlleDokumente As Boolean = False

Source code

[Visual Basic]
    Dim PreviewAlleDokumente As Boolean = False 'koe 29.09.2003

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


RBStatusAktuell Variable

Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusAktuell As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


RBStatusHistory Variable

Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Source code

[Visual Basic]
    Friend WithEvents RBStatusHistory As System.Windows.Forms.RadioButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SearchTip Variable

Dim SearchTip As New ToolTip()

Source code

[Visual Basic]
    Dim SearchTip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlConnection3 Variable

Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection3 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Statuslist Variable

Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Statuslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabControl1 Variable

Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl1 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabControl2 Variable

Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Source code

[Visual Basic]
    Friend WithEvents TabControl2 As System.Windows.Forms.TabControl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPage1 Variable

Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage1 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPage2 Variable

Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPage2 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPage3 Variable

Private WithEvents TabPage3 As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Private WithEvents TabPage3 As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageAllgemein Variable

Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageAllgemein As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageBerechtigung Variable

Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageBerechtigung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageDokumentwerte Variable

Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageDokumentwerte As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageInfomeldung Variable

Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageInfomeldung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageNotizen Variable

Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageNotizen As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageStatus Variable

Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageStatus As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TabPageZuordnung Variable

Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Source code

[Visual Basic]
    Friend WithEvents TabPageZuordnung As System.Windows.Forms.TabPage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox10 Variable

Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox10 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox11 Variable

Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox11 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox12 Variable

Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox12 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox13 Variable

Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox13 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox14 Variable

Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox14 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox15 Variable

Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox15 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox16 Variable

Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox16 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox17 Variable

Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox17 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox18 Variable

Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox18 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox4 Variable

Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox4 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox5 Variable

Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox5 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox6 Variable

Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox6 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox7 Variable

Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox7 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox8 Variable

Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox8 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


TextBox9 Variable

Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox9 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


UVMDaten Variable

Dim UVMDaten As Boolean

Source code

[Visual Basic]
    Dim UVMDaten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ZVDaten Variable

Dim ZVDaten As Boolean

Source code

[Visual Basic]
    Dim ZVDaten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


Zuordnungslist Variable

Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents Zuordnungslist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


al Variable

Dim al As New ArrayList()

Source code

[Visual Basic]
    Dim al As New ArrayList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


bcknr Variable

Dim bcknr As Integer

Source code

[Visual Basic]
    Dim bcknr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


bntNewDoc Variable

Friend WithEvents bntNewDoc As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents bntNewDoc As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


btnExit Variable

Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


btnPartnersuche Variable

Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnersuche As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


cbProfile Variable

Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbProfile As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


cmitprofil Variable

Friend WithEvents cmitprofil As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cmitprofil As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


colornotset Variable

Dim colornotset As Boolean = False

Source code

[Visual Basic]
    Dim colornotset As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


doklistrowcount Variable

Dim doklistrowcount As Long

Source code

[Visual Basic]
    Dim doklistrowcount As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


drpMiatarbeiter Variable

Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents drpMiatarbeiter As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblpageno Variable

Friend WithEvents lblpageno As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpageno As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur1 Variable

Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur2 Variable

Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur3 Variable

Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur4 Variable

Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur5 Variable

Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


lblzensur6 Variable

Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblzensur6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_ColdListDokumenteDefaultWidth Variable

Dim m_ColdListDokumenteDefaultWidth As Integer = 336

Source code

[Visual Basic]
    Dim m_ColdListDokumenteDefaultWidth As Integer = 336           ' Breite des Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_DTMitarbeiter Variable

Dim m_DTMitarbeiter As DataTable

Source code

[Visual Basic]
    Dim m_DTMitarbeiter As DataTable            'koe 28.07.2004

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_ExpandColdListDokumente Variable

Dim m_ExpandColdListDokumente As Integer = 0

Source code

[Visual Basic]
    Dim m_ExpandColdListDokumente As Integer = 0            'koe Anzahl der Expandet Spalten in Grid ColdListDokumente

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_FirstEntry Variable

Dim m_FirstEntry As Integer

Source code

[Visual Basic]
    Dim m_FirstEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_LastEntry Variable

Dim m_LastEntry As Integer

Source code

[Visual Basic]
    Dim m_LastEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_dokumentbezeichnung Variable

Dim m_dokumentbezeichnung As String

Source code

[Visual Basic]
    Dim m_dokumentbezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_dokumentdatum Variable

Dim m_dokumentdatum As DateTime

Source code

[Visual Basic]
    Dim m_dokumentdatum As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_geschaeftsfall Variable

Dim m_geschaeftsfall As String

Source code

[Visual Basic]
    Dim m_geschaeftsfall As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_onlyselect Variable

Dim m_onlyselect As Boolean = False

Source code

[Visual Basic]
    Dim m_onlyselect As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_pagedirection Variable

Dim m_pagedirection As Integer

Source code

[Visual Basic]
    Dim m_pagedirection As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_partnernr Variable

Dim m_partnernr As String

Source code

[Visual Basic]
    Dim m_partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_refresh Variable

Dim m_refresh As Boolean = False

Source code

[Visual Basic]
    Dim m_refresh As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_selectedbeschreibung Variable

Dim m_selectedbeschreibung As String

Source code

[Visual Basic]
    Dim m_selectedbeschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_selecteddocart Variable

Dim m_selecteddocart As String

Source code

[Visual Basic]
    Dim m_selecteddocart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


m_selecteddokumentid Variable

Dim m_selecteddokumentid As String

Source code

[Visual Basic]
    Dim m_selecteddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


maxpage Variable

Dim maxpage As Integer

Source code

[Visual Basic]
    Dim maxpage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


mnuFreitextSuche Variable

Friend WithEvents mnuFreitextSuche As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuFreitextSuche As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


mnuSendMessage Variable

Friend WithEvents mnuSendMessage As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuSendMessage As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


on_refresh Variable

Dim on_refresh As Boolean = False

Source code

[Visual Basic]
    Dim on_refresh As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlSearch Variable

Friend WithEvents pnlSearch As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlSearch As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur1 Variable

Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur2 Variable

Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur3 Variable

Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur4 Variable

Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur4 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur5 Variable

Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur5 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


pnlzensur6 Variable

Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlzensur6 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


savenode Variable

Dim savenode As New TreeNode()

Source code

[Visual Basic]
    Dim savenode As New TreeNode()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor1 Variable

Dim scolor1 As Color

Source code

[Visual Basic]
    Dim scolor1 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor2 Variable

Dim scolor2 As Color

Source code

[Visual Basic]
    Dim scolor2 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor3 Variable

Dim scolor3 As Color

Source code

[Visual Basic]
    Dim scolor3 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor4 Variable

Dim scolor4 As Color

Source code

[Visual Basic]
    Dim scolor4 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor5 Variable

Dim scolor5 As Color

Source code

[Visual Basic]
    Dim scolor5 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


scolor6 Variable

Dim scolor6 As Color

Source code

[Visual Basic]
    Dim scolor6 As Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


selp Variable

Dim selp As New System.Drawing.Point()

Source code

[Visual Basic]
    Dim selp As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


statushistory Variable

Dim statushistory As Boolean

Source code

[Visual Basic]
    Dim statushistory As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


tpagemax Variable

Dim tpagemax( _
   99 _
) As Integer

Source code

[Visual Basic]
    Dim tpagemax(99) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


tpagemin Variable

Dim tpagemin( _
   99 _
) As Integer

Source code

[Visual Basic]
    Dim tpagemin(99) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


tt Variable

Dim tt As New ToolTip()

Source code

[Visual Basic]
    Dim tt As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


ttip Variable

Dim ttip As New ToolTip()

Source code

[Visual Basic]
    Dim ttip As New ToolTip()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


tvstruktur Variable

Friend WithEvents tvstruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents tvstruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


txtbcknr Variable

Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtbcknr As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


txtnrpar00 Variable

Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


update_host Variable

Dim update_host As Boolean = False

Source code

[Visual Basic]
    Dim update_host As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


vertraulich Variable

Dim vertraulich As Boolean = False

Source code

[Visual Basic]
    Dim vertraulich As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmTrefferlistex


frmValueSelect Class

For a list of all members of this type, see frmValueSelect Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmValueSelect

Public Class frmValueSelect
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmValueSelect Members


frmValueSelect Members

frmValueSelect overview

Constructors

constructor frmValueSelect Constructor

Properties

property Datenherkunft
property DislpayResult
property ID
property NavigationResult
property SelectionType
property TableName

Methods

method AddToSelectetd
method CreateDatatablel
method Dispose
method FillProperty
method Generic_Select
method InitializeComponent
method InsertPartner
method PartnerList_DoubleClick
method SpaltenTitel_Aktualisieren
method Timer1_Tick
method cmdCancel_Click
method cmdOk_Click
method frmValueSelect_Load
method grdSelected_DoubleClick
method grdSelected_MouseDown
method grdValue_DoubleClick
method grdValue_MouseDown
method tlbValueSelect_ButtonClick

Fields

field Abbrechen
field ImageList1
field Panel1
field Panel2
field Panel3
field PartnerSearch
field Partnersuche
field Splitter1
field Timer1
field Uebernehmen
field components
field dtSelected
field grdSelected
field grdValue
field m_iSelectionType
field m_sDatenherkunft
field m_sDislpayResult
field m_sID
field m_sNavigationResult
field m_sTableName
field mypartner
field partner
field timHinweismeldung
field tlbValueSelect

See Also

frmValueSelect Class


frmValueSelect Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect Properties

frmValueSelect overview

Properties

property Datenherkunft
property DislpayResult
property ID
property NavigationResult
property SelectionType
property TableName

See Also

frmValueSelect Class


frmValueSelect.Datenherkunft Property

Property Datenherkunft() As String

Source code

[Visual Basic]
    Property Datenherkunft() As String
        ' Werte dienen für die Anziege
        Get
            Return m_sDatenherkunft
        End Get
        Set(ByVal Value As String)
            m_sDatenherkunft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.DislpayResult Property

Property DislpayResult() As String

Source code

[Visual Basic]
    Property DislpayResult() As String
        Get
            Return m_sDislpayResult
        End Get
        Set(ByVal Value As String)
            m_sDislpayResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.ID Property

Property ID() As String

Source code

[Visual Basic]
    Property ID() As String
        'Typisierung für datenherkunft Bestimmt Welche Stored Procedure aufgerufen wird
        Get
            Return m_sID
        End Get
        Set(ByVal Value As String)
            m_sID = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.NavigationResult Property

Property NavigationResult() As String

Source code

[Visual Basic]
    Property NavigationResult() As String
        ' Werte dienen für die Steuerung
        Get
            Return m_sNavigationResult
        End Get
        Set(ByVal Value As String)
            m_sNavigationResult = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.SelectionType Property

Property SelectionType() As Enum_SelelectType

Source code

[Visual Basic]
    Property SelectionType() As Enum_SelelectType
        'Typisierung für datenherkunft Bestimmt Welche Stored Procedure aufgerufen wird
        Get
            Return m_iSelectionType
        End Get
        Set(ByVal Value As Enum_SelelectType)
            m_iSelectionType = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.TableName Property

Property TableName() As String

Source code

[Visual Basic]
    Property TableName() As String
        Get
            Return m_sTableName
        End Get
        Set(ByVal Value As String)
            m_sTableName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect Methods

frmValueSelect overview

Methods

method AddToSelectetd
method CreateDatatablel
method Dispose
method FillProperty
method Generic_Select
method InitializeComponent
method InsertPartner
method PartnerList_DoubleClick
method SpaltenTitel_Aktualisieren
method Timer1_Tick
method cmdCancel_Click
method cmdOk_Click
method frmValueSelect_Load
method grdSelected_DoubleClick
method grdSelected_MouseDown
method grdValue_DoubleClick
method grdValue_MouseDown
method tlbValueSelect_ButtonClick

See Also

frmValueSelect Class


frmValueSelect.AddToSelectetd Method

Private Sub AddToSelectetd()

Source code

[Visual Basic]
    Private Sub AddToSelectetd()
        '*********************************************************************************************************************
        'Description: Datensattz in das Grid selected übenehmen
        'Input:
        'Criteria:
        'Output:
        'Erstellt   : koe 11.01.2004
        'Geaendert:
        '*********************************************************************************************************************
        Dim rc As DataRowCollection
        Dim newrow As DataRow()
        Dim rowvals(1) As Object
        Dim iCount As Integer

        Select Case m_sDatenherkunft
            Case "&Mitarbeiter&"
                With grdSelected
                    For iCount = 0 To .Splits(0).Rows.Count - 1
                        If grdValue.Columns(1).Text = .Columns(1).CellValue(iCount) Then
                            Exit Sub
                        End If
                    Next
                End With
                rowvals(0) = grdValue.Columns(0).Text
                rowvals(1) = grdValue.Columns("Nachname").Text
            Case "&Partner&"
                With grdSelected
                    For iCount = 0 To .Splits(0).Rows.Count - 1
                        If Me.PartnerSearch.PartnerKurzbezeichnnung = .Columns(1).CellValue(iCount) Then
                            Exit Sub
                        End If
                    Next
                End With
                rowvals(0) = Me.PartnerSearch.PartnerNr
                rowvals(1) = Me.PartnerSearch.PartnerKurzbezeichnnung

            Case Else
                With grdSelected
                    For iCount = 0 To .Splits(0).Rows.Count - 1
                        If grdValue.Columns(1).Text = .Columns("Bezeichnung").CellValue(iCount) Then
                            Exit Sub
                        End If
                    Next
                End With
                rowvals(0) = grdValue.Columns(0).Text
                rowvals(1) = grdValue.Columns("Bezeichnung").Text
        End Select
        dtSelected.Rows.Add(rowvals)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.CreateDatatablel Method

Private Sub CreateDatatablel()

Source code

[Visual Basic]
    Private Sub CreateDatatablel()
        Dim rc As DataRowCollection
        Dim newrow As DataRow()
        Dim sDisplayResult() As String
        Dim sNavigationResult() As String
        Dim rowvals(1) As Object
        Dim iCount As Integer
        Select Case m_sDatenherkunft
            Case "&Mitarbeiter&"
                With dtSelected
                    .Columns.Add("ID")
                    .Columns.Add("Bezeichnung")
                End With
            Case Else
                With dtSelected
                    .Columns.Add("ID")
                    .Columns.Add("Bezeichnung")
                End With
        End Select

        rc = dtSelected.Rows
        sDisplayResult = Split(m_sDislpayResult, ";")
        sNavigationResult = Split(m_sNavigationResult, ";")

        If UBound(sNavigationResult) > 0 Then
            For iCount = 0 To UBound(sNavigationResult)
                rowvals(0) = sNavigationResult(iCount)
                rowvals(1) = sDisplayResult(iCount)
                dtSelected.Rows.Add(rowvals)
            Next
        Else
            If m_sNavigationResult <> "" Then
                rowvals(0) = m_sNavigationResult
                rowvals(1) = m_sDislpayResult
                dtSelected.Rows.Add(rowvals)
            End If

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.FillProperty Method

Private Sub FillProperty()

Source code

[Visual Basic]
    Private Sub FillProperty()
        '===============================================================================
        'Desc       : Füllen der Property  DislpayResult  & NavigationResult
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim row As Long
        Dim iCnt As Integer
        Dim sDelimeter As String = ""
        m_sDislpayResult = ""
        m_sNavigationResult = ""
        For iCnt = 0 To grdSelected.Splits(0).Rows.Count - 1
            Me.m_sDislpayResult = Me.m_sDislpayResult & sDelimeter & Me.grdSelected.Columns(1).CellText(iCnt)
            Me.m_sNavigationResult = Me.m_sNavigationResult & sDelimeter & Me.grdSelected.Columns(0).CellText(iCnt)
            sDelimeter = ";"
        Next

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.Generic_Select Method

Private Function Generic_Select() As DataTable

Source code

[Visual Basic]
    Private Function Generic_Select() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable

        Select Case m_iSelectionType
            Case Enum_SelelectType.ValueSelect
                scmCmdToExecute.CommandText = "dbo.SP_ValueSelect"
            Case Else
                MyMsg.show_standardmessage(209, MsgBoxStyle.Information)
                Exit Function
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        'Dim dtToReturn As DataTable = New DataTable(Me.TableName)
        dtToReturn = New DataTable(Me.TableName)
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Clear()
            scmCmdToExecute.Parameters.Add(New SqlParameter("@Datenherkunft", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Datenherkunft))
            sdaAdapter.Fill(dtToReturn)
            'sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("SelectValue::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmValueSelect))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.tlbValueSelect = New System.Windows.Forms.ToolBar()
        Me.Abbrechen = New System.Windows.Forms.ToolBarButton()
        Me.Uebernehmen = New System.Windows.Forms.ToolBarButton()
        Me.Partnersuche = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel2 = New System.Windows.Forms.Panel()
        Me.grdValue = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Splitter1 = New System.Windows.Forms.Splitter()
        Me.Panel3 = New System.Windows.Forms.Panel()
        Me.grdSelected = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
        Me.timHinweismeldung = New System.Windows.Forms.Timer(Me.components)
        Me.Panel1.SuspendLayout()
        Me.Panel2.SuspendLayout()
        CType(Me.grdValue, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.Panel3.SuspendLayout()
        CType(Me.grdSelected, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Panel1
        '
        Me.Panel1.BorderStyle = System.Windows.Forms.BorderStyle.FixedSingle
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.tlbValueSelect})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(752, 32)
        Me.Panel1.TabIndex = 6
        '
        'tlbValueSelect
        '
        Me.tlbValueSelect.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.Abbrechen, Me.Uebernehmen, Me.Partnersuche})
        Me.tlbValueSelect.DropDownArrows = True
        Me.tlbValueSelect.ImageList = Me.ImageList1
        Me.tlbValueSelect.Name = "tlbValueSelect"
        Me.tlbValueSelect.ShowToolTips = True
        Me.tlbValueSelect.Size = New System.Drawing.Size(750, 25)
        Me.tlbValueSelect.TabIndex = 6
        '
        'Abbrechen
        '
        Me.Abbrechen.ImageIndex = 1
        Me.Abbrechen.Tag = "Abbrechen"
        Me.Abbrechen.ToolTipText = "Abbrechen"
        '
        'Uebernehmen
        '
        Me.Uebernehmen.ImageIndex = 4
        Me.Uebernehmen.Tag = "Uebernehmen"
        Me.Uebernehmen.ToolTipText = "Übernehmen"
        '
        'Partnersuche
        '
        Me.Partnersuche.ImageIndex = 3
        Me.Partnersuche.Tag = "Partnersuche"
        Me.Partnersuche.ToolTipText = "Partnersuche"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel2
        '
        Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdValue})
        Me.Panel2.Dock = System.Windows.Forms.DockStyle.Left
        Me.Panel2.Location = New System.Drawing.Point(0, 32)
        Me.Panel2.Name = "Panel2"
        Me.Panel2.Size = New System.Drawing.Size(396, 551)
        Me.Panel2.TabIndex = 7
        '
        'grdValue
        '
        Me.grdValue.AllowFilter = True
        Me.grdValue.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdValue.AllowSort = True
        Me.grdValue.AllowUpdate = False
        Me.grdValue.AlternatingRows = True
        Me.grdValue.CaptionHeight = 17
        Me.grdValue.CollapseColor = System.Drawing.Color.Black
        Me.grdValue.DataChanged = False
        Me.grdValue.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdValue.ExpandColor = System.Drawing.Color.Black
        Me.grdValue.FetchRowStyles = True
        Me.grdValue.FilterBar = True
        Me.grdValue.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdValue.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.grdValue.Location = New System.Drawing.Point(26, 20)
        Me.grdValue.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.grdValue.Name = "grdValue"
        Me.grdValue.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdValue.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdValue.PreviewInfo.ZoomFactor = 75
        Me.grdValue.PrintInfo.ShowOptionsDialog = False
        Me.grdValue.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdValue.RowDivider = GridLines1
        Me.grdValue.RowHeight = 15
        Me.grdValue.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdValue.ScrollTips = False
        Me.grdValue.Size = New System.Drawing.Size(282, 88)
        Me.grdValue.TabIndex = 4
        Me.grdValue.Text = "C1TrueDBGrid1"
        Me.grdValue.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
        "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellB" & _
        "order"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" Hori" & _
        "zontalScrollGroup=""1""><ClientRect>0, 0, 278, 84</ClientRect><BorderSide>0</Borde" & _
        "rSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" " & _
        "me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle paren" & _
        "t=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupSt" & _
        "yle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><" & _
        "HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Ina" & _
        "ctive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorS" & _
        "tyle parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=" & _
        """Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView>" & _
        "</Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""" & _
        "Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Cap" & _
        "tion"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selec" & _
        "ted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highlight" & _
        "Row"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" " & _
        "/><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filte" & _
        "rBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSp" & _
        "lits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Defa" & _
        "ultRecSelWidth><ClientArea>0, 0, 278, 84</ClientArea></Blob>"
        '
        'Splitter1
        '
        Me.Splitter1.Location = New System.Drawing.Point(396, 32)
        Me.Splitter1.Name = "Splitter1"
        Me.Splitter1.Size = New System.Drawing.Size(3, 551)
        Me.Splitter1.TabIndex = 8
        Me.Splitter1.TabStop = False
        '
        'Panel3
        '
        Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.grdSelected})
        Me.Panel3.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel3.Location = New System.Drawing.Point(399, 32)
        Me.Panel3.Name = "Panel3"
        Me.Panel3.Size = New System.Drawing.Size(353, 551)
        Me.Panel3.TabIndex = 9
        '
        'grdSelected
        '
        Me.grdSelected.AllowDelete = True
        Me.grdSelected.AllowFilter = True
        Me.grdSelected.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.grdSelected.AllowSort = True
        Me.grdSelected.AllowUpdate = False
        Me.grdSelected.AlternatingRows = True
        Me.grdSelected.CaptionHeight = 17
        Me.grdSelected.CollapseColor = System.Drawing.Color.Black
        Me.grdSelected.DataChanged = False
        Me.grdSelected.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.grdSelected.Dock = System.Windows.Forms.DockStyle.Fill
        Me.grdSelected.ExpandColor = System.Drawing.Color.Black
        Me.grdSelected.FetchRowStyles = True
        Me.grdSelected.FilterBar = True
        Me.grdSelected.GroupByCaption = "Drag a column header here to group by that column"
        Me.grdSelected.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.grdSelected.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.grdSelected.Name = "grdSelected"
        Me.grdSelected.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.grdSelected.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.grdSelected.PreviewInfo.ZoomFactor = 75
        Me.grdSelected.PrintInfo.ShowOptionsDialog = False
        Me.grdSelected.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.grdSelected.RowDivider = GridLines2
        Me.grdSelected.RowHeight = 15
        Me.grdSelected.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.grdSelected.ScrollTips = False
        Me.grdSelected.Size = New System.Drawing.Size(353, 551)
        Me.grdSelected.TabIndex = 5
        Me.grdSelected.Text = "C1TrueDBGrid1"
        Me.grdSelected.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
        "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
        "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
        "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
        "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
        ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
        ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
        "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
        " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
        "oterHeight=""17"" FetchRowStyles=""True"" FilterBar=""True"" MarqueeStyle=""DottedCellB" & _
        "order"" RecordSelectorWidth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" Hori" & _
        "zontalScrollGroup=""1""><ClientRect>0, 0, 349, 547</ClientRect><BorderSide>0</Bord" & _
        "erSide><CaptionStyle parent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor""" & _
        " me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Style8"" /><FilterBarStyle pare" & _
        "nt=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupS" & _
        "tyle parent=""Group"" me=""Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" />" & _
        "<HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""In" & _
        "active"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelector" & _
        "Style parent=""RecordSelector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me" & _
        "=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView" & _
        "></Splits><NamedStyles><Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=" & _
        """Heading"" /><Style parent=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Ca" & _
        "ption"" /><Style parent=""Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Sele" & _
        "cted"" /><Style parent=""Normal"" me=""Editor"" /><Style parent=""Normal"" me=""Highligh" & _
        "tRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow""" & _
        " /><Style parent=""Heading"" me=""RecordSelector"" /><Style parent=""Normal"" me=""Filt" & _
        "erBar"" /><Style parent=""Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertS" & _
        "plits><horzSplits>1</horzSplits><Layout>None</Layout><DefaultRecSelWidth>16</Def" & _
        "aultRecSelWidth><ClientArea>0, 0, 349, 547</ClientArea></Blob>"
        '
        'Timer1
        '
        '
        'timHinweismeldung
        '
        Me.timHinweismeldung.Interval = 1000
        '
        'frmValueSelect
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(752, 583)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.Splitter1, Me.Panel2, Me.Panel1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmValueSelect"
        Me.Text = "frmValueSelect"
        Me.Panel1.ResumeLayout(False)
        Me.Panel2.ResumeLayout(False)
        CType(Me.grdValue, System.ComponentModel.ISupportInitialize).EndInit()
        Me.Panel3.ResumeLayout(False)
        CType(Me.grdSelected, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.InsertPartner Method

Private Sub InsertPartner() Handles PartnerSearch.partner_selected

Source code

[Visual Basic]
    Private Sub InsertPartner() Handles PartnerSearch.partner_selected
        '*********************************************************************************************************************
        'Description: Wird aufgerufen, wenn aus der Partnerwahl ein Record übernommen wird
        'Input:
        'Criteria:
        'Output:
        'Erstellt   : koe 11.01.2004
        'Geaendert:
        '*********************************************************************************************************************
        'Dim msg As String
        'Dim fHinweis As New frmHinweismeldung()
        AddToSelectetd()
        'msg = MyTxt.Get_Meldungstext(216) '+ vbCrLf + vbCrLf + "Partner: " + Me.txtPartner + vbCrLf + "Dokument: " & Me.txtDokumenttyp
        'fHinweis.MsgBoxStyle = 1
        'fHinweis.Label1.Text = msg
        'fHinweis.CheckBox1.Visible = False
        'fHinweis.Show()
        'fHinweis.TopMost = True
        'Me.timHinweismeldung.Enabled = True

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.PartnerList_DoubleClick Method

Private Sub PartnerList_DoubleClick( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub PartnerList_DoubleClick(ByVal sender As System.Object, ByVal e As System.EventArgs)
        AddToSelectetd()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet, _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid _
)

Parameters

ds
Required.
grd
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet, ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid)

        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim cols(grd.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        Dim DisplayColumnsCount As Integer
        Dim aSpalten(0, 0) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim Reihe As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim iMaxSortOrderValue As Integer = 0
        Dim dsMaxSortOrder As New DataSet()
        Dim bSetNewSortOrder As Boolean = True
        Dim iSpaltenOffset As Integer = 0 'Offset wenn Nothing in Array

        '============ Bestimmt Anzahl Displaycolumn und MaxValue Sortorder
        'Dim ssql As String
        'ssql = "SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'"
        Dim daMaxSortOrder As New SqlDataAdapter("SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'", Globals.sConnectionString)
        Try
            daMaxSortOrder.Fill(dsMaxSortOrder)
            DisplayColumnsCount = grd.Splits(0).DisplayColumns.Count - 1
            iMaxSortOrderValue = dsMaxSortOrder.Tables(0).Rows(0).Item(0)
            ReDim aSpalten(iMaxSortOrderValue - 1, 0)       'Array für Anzahlen definieren

            t = ds.Tables(0)
            ts.Tabelle = Me.TableName
            For i = 0 To grd.Columns.Count - 1
                s = grd.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                grd.Columns(i).Caption = ts.spaltenname
                If ts.ColWith = 0 Then
                    grd.Splits(0).DisplayColumns(i).Width = 0
                    grd.Splits(0).DisplayColumns(i).Visible = False
                Else
                    grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If

                'If grd.Columns(i).Caption = "" Then
                '    'grd.Splits(0).DisplayColumns(i).Visible = False
                '    grd.Splits(0).DisplayColumns(i).Width = 0
                '    'grd.Columns(i).Caption = grd.Columns(i).DataField
                'Else
                '    grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
                'End If
                If ts.locked Then
                    grd.Splits(0).DisplayColumns(i).Locked = True
                End If

                If ts.AlsHacken Then
                    grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If grd.Columns(i).DataField = "aktiv" Then
                    grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    grd.Columns(i).ValueItems.DefaultItem = True
                    grd.Columns(i).DefaultValue = True
                    grd.Columns(i).FilterText = True
                End If
                If grd.Columns(i).DataField = "erstellt_am" Then
                    grd.Columns(i).DefaultValue = Now
                End If

                '============ Aktuelle Spalte in ArraySpalten schreiben
                '============ Sortorder darf nicht 0 sein
                If iMaxSortOrderValue > 0 Then
                    If ts.Order = 0 Then
                        MessageBox.Show("Fehler Reihenfolge" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit dem Wert 0 sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Sortierreihenfolge 0", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                    Else
                        Reihe = grd.Splits(0).DisplayColumns(i)
                        If Not aSpalten(ts.Order - 1, 0) Is Nothing Then
                            '============ Arrayplatz bereits bleget
                            '                        MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Prüfen Sie die Sortierreihenfoge der Tabelle " & Me.TableName & " in der Systemadministration Spalten!", MessageBoxButtons.OK, "Sortierreihenfolge ", MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                            MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit 2 gleichen Werten sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Doppelte Sortier-Nummer " & ts.Order, MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                            'bSetNewSortOrder = False
                        End If
                        If ts.Order > 0 And aSpalten(ts.Order - 1, 0) Is Nothing Then
                            '============ Aktuelle Spalte in ArraySpalten schreiben
                            aSpalten(ts.Order - 1, 0) = Reihe
                        End If
                    End If
                End If
            Next

            If iMaxSortOrderValue > 0 And bSetNewSortOrder = True Then
                '===============================================================================
                'Wenn in der Sortierreihenfoge keine 0 steht werden die Spalten neu Sortiert
                '===============================================================================
                Try
                    '============ Spalten löschen
                    For i = 0 To DisplayColumnsCount
                        grd.Splits(0).DisplayColumns.RemoveAt(0)
                    Next
                Catch
                End Try
                '============ Spalten nachh Sortorder einfügen
                For i = 0 To iMaxSortOrderValue - 1
                    Try
                        If Not aSpalten(i, 0) Is Nothing Then
                            If aSpalten(i, 0).Width > 0 Then
                                grd.Splits(0).DisplayColumns.Insert(i - iSpaltenOffset, aSpalten(i, 0))
                            Else
                                iSpaltenOffset += 1
                            End If
                        Else
                            iSpaltenOffset += 1
                        End If
                    Catch ex As Exception
                        MsgBox(ex.Message)
                    End Try

                Next
            End If
            dsMaxSortOrder = Nothing
            daMaxSortOrder = Nothing

        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.Timer1_Tick Method

Private Sub Timer1_Tick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles Timer1.Tick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Tick(ByVal sender As Object, ByVal e As System.EventArgs) Handles Timer1.Tick
        Me.Timer1.Enabled = False
        Me.PartnerSearch.NoClose = True
        Me.PartnerSearch.TopMost = True
        Me.PartnerSearch.Show()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.cmdCancel_Click Method

Private Sub cmdCancel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdCancel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Me.DialogResult = DialogResult.Cancel
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.cmdOk_Click Method

Private Sub cmdOk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cmdOk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        FillProperty()
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.frmValueSelect_Load Method

Private Sub frmValueSelect_Load( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmValueSelect_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Load
        '===============================================================================
        'Desc       : Laden der Datem gem Datenherkunft
        'Output	    : Wenn eine ID übergeben wurde wird das GridValue Positioniert
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim iCount As Integer
        Dim i As Integer = 50
        Dim sRowName As String
        Try
            Me.TableName = "Valueselect" & Replace(m_sDatenherkunft, "&", "")
            Dim DS As New DataSet(Me.TableName)
            Dim DSSelected As New DataSet("Valueselected")
            Select Case m_sDatenherkunft
                Case "&Partner&"
                    Panel2.Width = 0
                    Me.tlbValueSelect.Buttons(2).Enabled = True
                    Me.tlbValueSelect.Buttons(2).Visible = True
                Case Else
                    Me.tlbValueSelect.Buttons(2).Enabled = False
                    Me.tlbValueSelect.Buttons(2).Visible = False
                    grdValue.Dock = DockStyle.Fill
                    grdValue.Visible = True
                    grdValue.DataSource = Generic_Select()
                    DS.Tables.Add(grdValue.DataSource)
                    SpaltenTitel_Aktualisieren(DS, Me.grdValue)
                    grdValue.Columns("aktiv").FilterText = True

            End Select

            CreateDatatablel()
            grdSelected.DataSource = dtSelected
            grdSelected.DataMember = dtSelected.TableName

            DSSelected.Tables.Add(grdSelected.DataSource)
            Me.TableName = DSSelected.Tables(0).TableName
            SpaltenTitel_Aktualisieren(DSSelected, Me.grdSelected)
            Select Case m_sDatenherkunft
                Case "&Partner&"
                    Me.Timer1.Enabled = True
            End Select
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.grdSelected_DoubleClick Method

Private Sub grdSelected_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles grdSelected.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdSelected_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles grdSelected.DoubleClick
        grdSelected.Delete()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.grdSelected_MouseDown Method

Private Sub grdSelected_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles grdSelected.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdSelected_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles grdSelected.MouseDown
        If e.X < 2 And e.Y < 2 Then
            MsgBox(dtSelected.TableName)
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.grdValue_DoubleClick Method

Private Sub grdValue_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles grdValue.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdValue_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles grdValue.DoubleClick
        AddToSelectetd()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.grdValue_MouseDown Method

Private Sub grdValue_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles grdValue.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub grdValue_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles grdValue.MouseDown
        If e.X < 2 And e.Y < 2 Then
            MsgBox(Me.TableName)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect.tlbValueSelect_ButtonClick Method

Private Sub tlbValueSelect_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles tlbValueSelect.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub tlbValueSelect_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles tlbValueSelect.ButtonClick
        Select Case tlbValueSelect.Buttons.IndexOf(e.Button)
            Case 0 'close Exit
                Me.DialogResult = DialogResult.Cancel
                Me.Close()

            Case 1 'Uebernehnmen
                FillProperty()
                Me.DialogResult = DialogResult.OK
                Me.Close()
            Case 2 'Partnersuche
                Me.PartnerSearch.NoClose = True
                Me.PartnerSearch.TopMost = True
                Me.PartnerSearch.Show()

        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelect Fields

frmValueSelect overview

Fields

field Abbrechen
field ImageList1
field Panel1
field Panel2
field Panel3
field PartnerSearch
field Partnersuche
field Splitter1
field Timer1
field Uebernehmen
field components
field dtSelected
field grdSelected
field grdValue
field m_iSelectionType
field m_sDatenherkunft
field m_sDislpayResult
field m_sID
field m_sNavigationResult
field m_sTableName
field mypartner
field partner
field timHinweismeldung
field tlbValueSelect

See Also

frmValueSelect Class


Abbrechen Variable

Friend WithEvents Abbrechen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents Abbrechen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Panel2 Variable

Friend WithEvents Panel2 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel2 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Panel3 Variable

Friend WithEvents Panel3 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel3 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


PartnerSearch Variable

Dim WithEvents PartnerSearch As New FrmPartnersuche()

Source code

[Visual Basic]
    Dim WithEvents PartnerSearch As New FrmPartnersuche()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Partnersuche Variable

Friend WithEvents Partnersuche As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents Partnersuche As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Splitter1 Variable

Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter1 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Timer1 Variable

Friend WithEvents Timer1 As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


Uebernehmen Variable

Friend WithEvents Uebernehmen As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents Uebernehmen As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


dtSelected Variable

Dim dtSelected As New DataTable( _
   "Valueselected" _
)

Source code

[Visual Basic]
    Dim dtSelected As New DataTable("Valueselected")

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


grdSelected Variable

Friend WithEvents grdSelected As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdSelected As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


grdValue Variable

Friend WithEvents grdValue As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents grdValue As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_iSelectionType Variable

Dim m_iSelectionType As Enum_SelelectType

Source code

[Visual Basic]
    Dim m_iSelectionType As Enum_SelelectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_sDatenherkunft Variable

Dim m_sDatenherkunft As String

Source code

[Visual Basic]
    Dim m_sDatenherkunft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_sDislpayResult Variable

Dim m_sDislpayResult As String

Source code

[Visual Basic]
    Dim m_sDislpayResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_sID Variable

Dim m_sID As String

Source code

[Visual Basic]
    Dim m_sID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_sNavigationResult Variable

Dim m_sNavigationResult As String

Source code

[Visual Basic]
    Dim m_sNavigationResult As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


m_sTableName Variable

Private m_sTableName As String

Source code

[Visual Basic]
    Private m_sTableName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


mypartner Variable

Dim mypartner As New edokadb.clsMyPartner()

Source code

[Visual Basic]
    Dim mypartner As New edokadb.clsMyPartner()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


partner Variable

Dim partner As DataTable

Source code

[Visual Basic]
    Dim partner As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


timHinweismeldung Variable

Friend WithEvents timHinweismeldung As System.Windows.Forms.Timer

Source code

[Visual Basic]
    Friend WithEvents timHinweismeldung As System.Windows.Forms.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


tlbValueSelect Variable

Friend WithEvents tlbValueSelect As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents tlbValueSelect As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelect


frmValueSelector Class

For a list of all members of this type, see frmValueSelector Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmValueSelector

Public Class frmValueSelector
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmValueSelector Members


frmValueSelector Members

frmValueSelector overview

Constructors

constructor frmValueSelector Constructor

Properties

property Datenherkunft
property Datenvorhanden
property Partnernr
property SelWert

Methods

method Button1_Click
method Button2_Click
method C1TrueDBGrid1_DoubleClick
method C1TrueDBGrid1_FetchRowStyle
method Dispose
method Generic_Select
method InitializeComponent
method LoadData
method frmValueSelector_Load

Fields

field Button1
field Button2
field C1TrueDBGrid1
field components
field m_datenherkunft
field m_datenvorhanden
field m_partnernr
field m_value

See Also

frmValueSelector Class


frmValueSelector Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector Properties

frmValueSelector overview

Properties

property Datenherkunft
property Datenvorhanden
property Partnernr
property SelWert

See Also

frmValueSelector Class


frmValueSelector.Datenherkunft Property

Property Datenherkunft() As String

Source code

[Visual Basic]
    Property Datenherkunft() As String
        Get
            Return m_datenherkunft
        End Get
        Set(ByVal Value As String)
            m_datenherkunft = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.Datenvorhanden Property

Property Datenvorhanden() As Boolean

Source code

[Visual Basic]
    Property Datenvorhanden() As Boolean
        Get
            Return m_datenvorhanden
        End Get
        Set(ByVal Value As Boolean)
            m_datenvorhanden = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.Partnernr Property

Property Partnernr() As String

Source code

[Visual Basic]
    Property Partnernr() As String
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As String)
            m_partnernr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.SelWert Property

Property SelWert() As String

Source code

[Visual Basic]
    Property SelWert() As String
        Get
            Return m_value
        End Get
        Set(ByVal Value As String)
            m_value = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector Methods

frmValueSelector overview

Methods

method Button1_Click
method Button2_Click
method C1TrueDBGrid1_DoubleClick
method C1TrueDBGrid1_FetchRowStyle
method Dispose
method Generic_Select
method InitializeComponent
method LoadData
method frmValueSelector_Load

See Also

frmValueSelector Class


frmValueSelector.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            Me.SelWert = Me.C1TrueDBGrid1.Columns(0).Value
        Catch
        End Try
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.SelWert = Me.C1TrueDBGrid1.Columns(0).Value
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.C1TrueDBGrid1_DoubleClick Method

Private Sub C1TrueDBGrid1_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles C1TrueDBGrid1.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles C1TrueDBGrid1.DoubleClick
        Me.SelWert = Me.C1TrueDBGrid1.Columns(0).Value
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.C1TrueDBGrid1_FetchRowStyle Method

Private Sub C1TrueDBGrid1_FetchRowStyle( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs _
) Handles C1TrueDBGrid1.FetchRowStyle

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub C1TrueDBGrid1_FetchRowStyle(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.FetchRowStyleEventArgs) Handles C1TrueDBGrid1.FetchRowStyle
        Try
            If Me.C1TrueDBGrid1.Columns("sarec00").CellValue(e.Row) <> 2 Then
                Dim FNT As Font = e.CellStyle.Font
                e.CellStyle.Font = New Font(FNT, FontStyle.Strikeout)

            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()

        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_DokWertList"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Partnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@regel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Datenherkunft))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmValueSelector))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.C1TrueDBGrid1 = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'C1TrueDBGrid1
        '
        Me.C1TrueDBGrid1.AllowFilter = True
        Me.C1TrueDBGrid1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBGrid1.AllowSort = True
        Me.C1TrueDBGrid1.CaptionHeight = 17
        Me.C1TrueDBGrid1.CollapseColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.DataChanged = False
        Me.C1TrueDBGrid1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBGrid1.ExpandColor = System.Drawing.Color.Black
        Me.C1TrueDBGrid1.FetchRowStyles = True
        Me.C1TrueDBGrid1.GroupByCaption = "Drag a column header here to group by that column"
        Me.C1TrueDBGrid1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBGrid1.Location = New System.Drawing.Point(8, 8)
        Me.C1TrueDBGrid1.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.C1TrueDBGrid1.Name = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.C1TrueDBGrid1.PreviewInfo.ZoomFactor = 75
        Me.C1TrueDBGrid1.PrintInfo.ShowOptionsDialog = False
        Me.C1TrueDBGrid1.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBGrid1.RowDivider = GridLines1
        Me.C1TrueDBGrid1.RowHeight = 15
        Me.C1TrueDBGrid1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBGrid1.ScrollTips = False
        Me.C1TrueDBGrid1.Size = New System.Drawing.Size(408, 264)
        Me.C1TrueDBGrid1.TabIndex = 0
        Me.C1TrueDBGrid1.Text = "C1TrueDBGrid1"
        Me.C1TrueDBGrid1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Footer" & _
        "{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:C" & _
        "ontrolText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{}" & _
        "Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name="""" " & _
        "CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyl" & _
        "es=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWidt" & _
        "h=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 404, " & _
        "260</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Style2"" me=""Styl" & _
        "e10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow""" & _
        " me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle pa" & _
        "rent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingSt" & _
        "yle parent=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""" & _
        "Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""Od" & _
        "dRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" />" & _
        "<SelectedStyle parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1" & _
        """ /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""N" & _
        "ormal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foote" & _
        "r"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive" & _
        """ /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" />" & _
        "<Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /" & _
        "><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector" & _
        """ /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /" & _
        "></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None<" & _
        "/Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 404, 260</C" & _
        "lientArea></Blob>"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.Cancel
        Me.Button1.Location = New System.Drawing.Point(8, 280)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(344, 280)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 2
        Me.Button2.Text = "&OK"
        '
        'frmValueSelector
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(424, 309)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.C1TrueDBGrid1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmValueSelector"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Selektion "
        CType(Me.C1TrueDBGrid1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        m_datenvorhanden = True
        Dim d As DataTable
        d = Generic_Select(1)
        Me.C1TrueDBGrid1.DataSource = d
        If Me.C1TrueDBGrid1.Splits(0).Rows.Count = 0 Then
            MyMsg.show_standardmessage(19, MsgBoxStyle.Information)
            m_datenvorhanden = False
        End If
        Dim i As Integer
        For i = 0 To Me.C1TrueDBGrid1.Columns.Count - 1
            If Me.C1TrueDBGrid1.Columns(i).Caption = "SAREC00" Then
                Me.C1TrueDBGrid1.Splits(0).DisplayColumns(i).Visible = False
            End If
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector.frmValueSelector_Load Method

Private Sub frmValueSelector_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmValueSelector_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmValueSelector Fields

frmValueSelector overview

Fields

field Button1
field Button2
field C1TrueDBGrid1
field components
field m_datenherkunft
field m_datenvorhanden
field m_partnernr
field m_value

See Also

frmValueSelector Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


C1TrueDBGrid1 Variable

Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBGrid1 As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


m_datenherkunft Variable

Dim m_datenherkunft As String

Source code

[Visual Basic]
    Dim m_datenherkunft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


m_datenvorhanden Variable

Dim m_datenvorhanden As Boolean

Source code

[Visual Basic]
    Dim m_datenvorhanden As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


m_partnernr Variable

Dim m_partnernr As String

Source code

[Visual Basic]
    Dim m_partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


m_value Variable

Dim m_value As String

Source code

[Visual Basic]
    Dim m_value As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmValueSelector


frmVorlagenauswahl Class

For a list of all members of this type, see frmVorlagenauswahl Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmVorlagenauswahl

Public Class frmVorlagenauswahl
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmVorlagenauswahl Members


frmVorlagenauswahl Members

frmVorlagenauswahl overview

Constructors

constructor frmVorlagenauswahl Constructor

Properties

property BarcodeID
property Dokumentart
property Dokumentpaket
property Dokumentvorlage
property ProfilNr
property Profile
property Show_Favoriten
property edex_vorlagenauswahl

Methods

method BtnHelp_Click
method Check_Barcode
method ContextMenu1_Popup
method ContextMenu3_Popup
method DelNode
method DeleteNodes
method Dispose
method DocumentAllreadyExists
method DokumentErstellen
method FavoritenStruktur_BeforeSelect
method FavoritenStruktur_DoubleClick
method FavoritenStruktur_Dragdrop_insert
method FavoritenStruktur_ItemDrag
method FavoritenStruktur_KeyDown
method FavoritenStruktur_MouseDown
method Favoritenstruktur_DragDrop
method Favoritenstruktur_DragOver
method Favoritenstruktur_dragenter
method Finalize
method GetDokumentFavoritNr
method Get_Filter
method Get_dtnr_dpnr
method InitializeComponent
method Load_Struktur
method MenuExpand_Click
method MenuItem10_Click
method MenuItem6_Click
method MenuItem8_Click
method MenuItem9_Click
method MenuUnExpand_Click
method MenuUnexpandsel_Click
method MnuAddFavoriten_Click
method MnuDokumenterstellen_Click
method MnuDokumentpaketKopieren_Click
method MnuExpandSel_Click
method MnuFavoritentfernen_Click
method MnuIDVBearbeitung_Click
method MnuMaKopie_Click
method MnuNeuesDokumentpaket_Click
method MnuShowFavoriten_Click
method MoveNode
method RenameNodeFavoritenstruktur
method ResizeForm
method RootNodesFavoritenStrukturExist
method Save_Nodedata
method SearchDokFavoritenNode
method ShowControls
method TVStruktur_AfterSelect
method TVStruktur_ItemDrag
method TVStruktur_KeyDown
method TVStruktur_MouseDown
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TxtSearch_KeyDown
method Update_Menu
method Vorlagenauswahl_Load
method formatForm
method frmVorlagenauswahl_Resize
method mcbfilter_SelectedValueChanged
method mnuDokument_erstellen_Click
method mnuInfoDokumentvorlage_Click
method mnuLoeschen_Click
method mnuNeuerOrdner_Click
method mnuUmbenennen_Click

Fields

field BtnHelp
field ComboBox1
field ContextMenu1
field ContextMenu3
field DataSet1
field FavoritenStruktur
field ImageList1
field ImageList2
field ImageList3
field ItemMove
field Label1
field MenuExpand
field MenuItem1
field MenuItem10
field MenuItem12
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuUnExpand
field MenuUnexpandsel
field MnuAddFavoriten
field MnuDokumenterstellen
field MnuDokumentpaketKopieren
field MnuExpandSel
field MnuIDVBearbeitung
field MnuMAKopie
field MnuNeuesDokumentpaket
field MnuPaketverwaltung
field MnuShowFavoriten
field On_Load
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVStruktur
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolTip1
field TxtSearch
field components
field itodelete
field m_Dokumentpaket
field m_barcodeid
field m_dokumentart
field m_dokumentvorlage
field m_edex_Vorlagenauswahl
field m_favoriten
field m_iImagesOffestImagelist1
field m_iWindowWidth
field m_profile
field m_profilnr
field mcbfilter
field mnuDokument_erstellen
field mnuInfoDokumentvorlage
field mnuLoeschen
field mnuNeuerOrdner
field mnuUmbenennen
field picSmiley
field pnlFavoriten
field selectPoint
field ssort
field todelete

See Also

frmVorlagenauswahl Class


frmVorlagenauswahl Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl Properties

frmVorlagenauswahl overview

Properties

property BarcodeID
property Dokumentart
property Dokumentpaket
property Dokumentvorlage
property ProfilNr
property Profile
property Show_Favoriten
property edex_vorlagenauswahl

See Also

frmVorlagenauswahl Class


frmVorlagenauswahl.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Dokumentart Property

Property Dokumentart() As String

Source code

[Visual Basic]
    Property Dokumentart() As String
        Get
            Return m_dokumentart
        End Get
        Set(ByVal Value As String)
            m_dokumentart = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Dokumentpaket Property

Property Dokumentpaket() As Boolean

Source code

[Visual Basic]
    Property Dokumentpaket() As Boolean
        Get
            Return m_Dokumentpaket
        End Get
        Set(ByVal Value As Boolean)
            m_Dokumentpaket = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Dokumentvorlage Property

Property Dokumentvorlage() As Long

Source code

[Visual Basic]
    Property Dokumentvorlage() As Long
        Get
            Return m_dokumentvorlage
        End Get
        Set(ByVal Value As Long)
            m_dokumentvorlage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ProfilNr Property

Property ProfilNr() As Long

Source code

[Visual Basic]
    Property ProfilNr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Show_Favoriten Property

Property Show_Favoriten() As Boolean

Source code

[Visual Basic]
    Property Show_Favoriten() As Boolean
        Get
            Return m_favoriten
        End Get
        Set(ByVal Value As Boolean)
            m_favoriten = Value
            Me.ToolBar1.Buttons(3).Pushed() = m_favoriten
            Me.ToolBar1.Buttons(2).Pushed() = Not m_favoriten
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.edex_vorlagenauswahl Property

Property edex_vorlagenauswahl() As Boolean

Source code

[Visual Basic]
    Property edex_vorlagenauswahl() As Boolean
        Get
            Return m_edex_Vorlagenauswahl
        End Get
        Set(ByVal Value As Boolean)
            m_edex_Vorlagenauswahl = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl Methods

frmVorlagenauswahl overview

Methods

method BtnHelp_Click
method Check_Barcode
method ContextMenu1_Popup
method ContextMenu3_Popup
method DelNode
method DeleteNodes
method Dispose
method DocumentAllreadyExists
method DokumentErstellen
method FavoritenStruktur_BeforeSelect
method FavoritenStruktur_DoubleClick
method FavoritenStruktur_Dragdrop_insert
method FavoritenStruktur_ItemDrag
method FavoritenStruktur_KeyDown
method FavoritenStruktur_MouseDown
method Favoritenstruktur_DragDrop
method Favoritenstruktur_DragOver
method Favoritenstruktur_dragenter
method Finalize
method GetDokumentFavoritNr
method Get_Filter
method Get_dtnr_dpnr
method InitializeComponent
method Load_Struktur
method MenuExpand_Click
method MenuItem10_Click
method MenuItem6_Click
method MenuItem8_Click
method MenuItem9_Click
method MenuUnExpand_Click
method MenuUnexpandsel_Click
method MnuAddFavoriten_Click
method MnuDokumenterstellen_Click
method MnuDokumentpaketKopieren_Click
method MnuExpandSel_Click
method MnuFavoritentfernen_Click
method MnuIDVBearbeitung_Click
method MnuMaKopie_Click
method MnuNeuesDokumentpaket_Click
method MnuShowFavoriten_Click
method MoveNode
method RenameNodeFavoritenstruktur
method ResizeForm
method RootNodesFavoritenStrukturExist
method Save_Nodedata
method SearchDokFavoritenNode
method ShowControls
method TVStruktur_AfterSelect
method TVStruktur_ItemDrag
method TVStruktur_KeyDown
method TVStruktur_MouseDown
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TxtSearch_KeyDown
method Update_Menu
method Vorlagenauswahl_Load
method formatForm
method frmVorlagenauswahl_Resize
method mcbfilter_SelectedValueChanged
method mnuDokument_erstellen_Click
method mnuInfoDokumentvorlage_Click
method mnuLoeschen_Click
method mnuNeuerOrdner_Click
method mnuUmbenennen_Click

See Also

frmVorlagenauswahl Class


frmVorlagenauswahl.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        If Me.ToolBar1.Buttons(2).Pushed = False Then
            Globals.HTMLHelp.ShowHelpToc("favoriten")
        Else
            Globals.HTMLHelp.ShowHelpToc("vorlagenauswahl")
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Check_Barcode Method

Private Function Check_Barcode() As Boolean

Source code

[Visual Basic]
    Private Function Check_Barcode() As Boolean
        If Me.edex_vorlagenauswahl = True Then
            Return True
            Exit Function

        End If
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        dt.iDokumenttypnr = New SqlInt32(CType(Me.Dokumentvorlage, Int32))
        dt.SelectOne()
        Me.BarcodeID = ""
        Check_Barcode = True
        Dim showbc As Boolean = False
        If dt.bNurnative.Value = True Then
            Globals.EinzelDokument = True
            Return True
        End If
        If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = False Then showbc = True
        If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = True Then
            Dim f As New frmbcquestion()
            f.ShowDialog()
            If f.DialogResult = DialogResult.Abort Then showbc = True
            If f.DialogResult = DialogResult.OK Then showbc = False
            f.Dispose()
        End If
        If showbc Then
            Dim f As New frmBarcodeKleber()
            f.ShowDialog()
            If f.DialogResult = DialogResult.Abort Then
                Check_Barcode = False
            Else
                If f.DialogResult = DialogResult.OK Then
                    Me.BarcodeID = f.BarcodeID
                    Check_Barcode = True
                    Globals.bckdokument = True
                Else
                    Check_Barcode = False
                End If
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" Then
            Me.MenuItem6.Enabled = False
        Else
            Me.MenuItem6.Enabled = True
        End If
        'Dim i As Integer
        'Try
        '    i = TagValue(Me.TVStruktur.SelectedNode.Tag)
        '    Me.MenuItem6.Enabled = False
        '    If DivFnkt.leererstellung(3, i) = True Then Me.MenuItem6.Enabled = True
        'Catch
        '    Me.MenuItem6.Enabled = False
        'End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        Try
            Me.MnuNeuesDokumentpaket.Enabled = False
            Me.MnuDokumentpaketKopieren.Enabled = False
            Me.MnuIDVBearbeitung.Enabled = False
            Me.MnuMAKopie.Enabled = False

            If Me.FavoritenStruktur.SelectedNode.ImageIndex < 60 + Me.DP_Imagepos Then
                Me.MnuPaketverwaltung.Enabled = False
                Exit Sub
            Else
                Me.MnuPaketverwaltung.Enabled = True
            End If

            If Me.FavoritenStruktur.SelectedNode.ImageIndex > 59 + Me.DP_Imagepos Then
                Me.MnuNeuesDokumentpaket.Enabled = True
            End If
            If Me.FavoritenStruktur.SelectedNode.ImageIndex = 61 + Me.DP_Imagepos Then
                Me.MnuIDVBearbeitung.Enabled = True
                Me.MnuMAKopie.Enabled = True
                Me.MnuDokumentpaketKopieren.Enabled = True
            End If
            If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + Me.DP_Imagepos Then
                Me.MnuDokumentpaketKopieren.Enabled = True
            End If
        Catch
            Me.MnuPaketverwaltung.Enabled = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.DelNode Method

Private Sub DelNode( _
   ByVal tn As TreeNode _
)

Parameters

tn
Required.

Source code

[Visual Basic]
    Private Sub DelNode(ByVal tn As TreeNode)
        If tn.ImageIndex = 61 + DP_Imagepos Then
            Dim dp As New edokadb.clsEdex_dokumentpaket()
            dp.cpMainConnectionProvider = conn
            dp.iDokumentpaketnr = New SqlInt32(CType(TagValue(tn.Tag), Int32))
            conn.OpenConnection()
            dp.SelectOne()
            dp.bAktiv = New SqlBoolean(CType(False, Boolean))

            dp.Update()
            conn.CloseConnection(True)
            dp.Dispose()
        Else
            Dim df As New edokadb.clsEDEX_Favoriten()
            df.cpMainConnectionProvider = conn
            df.iNreintrag = New SqlInt32(CType(TagValue(tn.Tag), Int32))
            conn.OpenConnection()
            df.Delete()
            conn.CloseConnection(True)
            df.Dispose()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.DeleteNodes Method

Public Sub DeleteNodes( _
   ByVal pn As TreeNode _
)

Parameters

pn
Required.

Source code

[Visual Basic]
    Public Sub DeleteNodes(ByVal pn As TreeNode)
        Dim i As Integer
        Dim tn As TreeNode

        For Each tn In pn.Nodes
            DelNode(tn)
            If tn.GetNodeCount(False) > 0 Then DeleteNodes(tn)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.DocumentAllreadyExists Method

Private Function DocumentAllreadyExists( _
   ByVal strukturnr As Integer, _
   ByVal doktypnr As Integer _
) As EnumFavoritenDokumentenAktion

Parameters

strukturnr
Required.
doktypnr
Required.

Source code

[Visual Basic]
    Private Function DocumentAllreadyExists(ByVal strukturnr As Integer, ByVal doktypnr As Integer) As EnumFavoritenDokumentenAktion
        '===============================================================================
        'Description : Ermittelt, ob das Dokument berits in der Struktur vorhanden ist
        'Input       : strukturnr = PK des Favoriten
        '              doktypnr = PK des Dokumenttyp
        'Output      : Ausgeführte Aktion Einfuegen oder Ueberschreiben oder NichtUebreschreiben
        'Date        : koe 24.08.2004
        'Modified    :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        DocumentAllreadyExists = EnumFavoritenDokumentenAktion.Einfuegen     'Dokument wir in die Favoriten eingefuegt
        Try
            scmCmdToExecute.CommandText = "dbo.SP_Favorit_bereits_vorhanden"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@strukturnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, strukturnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, doktypnr))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
        If dtToReturn.Rows.Count > 0 Then
            If MyMsg.Show_MessageYesNo(23) = MsgBoxResult.Yes Then
                'Die gewählte Dokumentvorlage ist bereits bei den Favoriten eingetragen. Wollen Sie sie erneut übernehmen?
                DocumentAllreadyExists = EnumFavoritenDokumentenAktion.Ueberschreiben 'Dokument wir in die Favoriten Ueberschrieben
            Else
                DocumentAllreadyExists = EnumFavoritenDokumentenAktion.NichtUebreschreiben 'Dokument wir in den Favoriten nicht Ueberschrieben
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.DokumentErstellen Method

Private Sub DokumentErstellen()

Source code

[Visual Basic]
    Private Sub DokumentErstellen()
        Dim iDokumentFavoritenNr As Integer
        If FavoritenStruktur.SelectedNode.ImageIndex <> 1 And FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            If FavoritenStruktur.SelectedNode.ImageIndex = 61 + DP_Imagepos Then
                Me.Dokumentvorlage = TagValue(FavoritenStruktur.SelectedNode.Tag)
                Globals.DokumentPaket = True
                Globals.Individuelles_Dokumentpaket = True
                Globals.bckdokument = False
                Globals.EinzelDokument = False
                Me.DialogResult = DialogResult.OK
                Me.Close()
                Exit Sub
            End If
            If FavoritenStruktur.SelectedNode.ImageIndex = 62 + DP_Imagepos Then
                iDokumentFavoritenNr = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
                Me.Dokumentvorlage = iDokumentFavoritenNr
                Globals.DokumentPaket = True
                Globals.Individuelles_Dokumentpaket = False
                Globals.bckdokument = False
                Globals.EinzelDokument = False
                Me.DialogResult = DialogResult.OK
                Me.Close()
                Exit Sub
            End If
            Me.Dokumentvorlage = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
            Globals.bckdokument = False
            Globals.EinzelDokument = False
            If Check_Barcode() = False Then Exit Sub
            Me.DialogResult = DialogResult.OK
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_BeforeSelect Method

Private Sub FavoritenStruktur_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles FavoritenStruktur.BeforeSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles FavoritenStruktur.BeforeSelect
        Try
            'Me.FavoritenStruktur.SelectedNode.BackColor = System.Drawing.Color.White
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_DoubleClick Method

Private Sub FavoritenStruktur_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles FavoritenStruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles FavoritenStruktur.DoubleClick
        DokumentErstellen()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_Dragdrop_insert Method

Private Sub FavoritenStruktur_Dragdrop_insert( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_Dragdrop_insert(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs)
        Dim pt As Point
        Dim DestinationNode As TreeNode
        Dim Strukturnr As Integer
        Dim tn As TreeNode
        Dim tnnew As TreeNode

        Dim Originalnode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
        DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
        If DestinationNode.ImageIndex <> 1 And DestinationNode.ImageIndex <> 60 + DP_Imagepos Then
            tn = DestinationNode.Parent
            Strukturnr = TagValue(tn.Tag)
        Else
            tn = DestinationNode
            Strukturnr = TagValue(tn.Tag)
        End If

        tnnew = tn.Nodes.Add(Originalnode.Text)
        tnnew.ImageIndex = Originalnode.ImageIndex + DP_Imagepos
        tnnew.SelectedImageIndex = Originalnode.SelectedImageIndex + DP_Imagepos

        Dim ps As New edokaDB.clsEDEX_Favoriten()
        ps.cpMainConnectionProvider = conn
        ps.sBezeichnung = New SqlString(CType(Originalnode.Text, String))
        ps.bAktiv = New SqlBoolean(CType(True, Boolean))
        ps.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        ps.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        ps.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        ps.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ps.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ps.iParentid = New SqlInt32(CType(TagValue(DestinationNode.Tag), Int32))
        ps.iSort = New SqlInt32(CType(tnnew.Index, Int32))
        ps.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        ps.iImageindex = New SqlInt32(CType(Originalnode.ImageIndex, Int32))
        ps.iImageindexopen = New SqlInt32(CType(Originalnode.SelectedImageIndex, Int32))
        If DestinationNode.ImageIndex >= 60 + DP_Imagepos Then
            ps.bDp = New SqlBoolean(CType(True, Boolean))
            ps.iDtnr_dpnr = New SqlInt32(CType(TagValue(Originalnode.Tag), Int32))
        Else
            ps.bDp = New SqlBoolean(CType(False, Boolean))
            ps.iDtnr_dpnr = New SqlInt32(CType(TagValue(Originalnode.Tag), Int32))
        End If
        ps.bStddp = New SqlBoolean(CType(False, Boolean))
        ps.bStrukturelement = New SqlBoolean(CType(False, Boolean))
        conn.OpenConnection()
        Try
            ps.Insert()
            Strukturnr = ps.iNreintrag.Value
            tnnew.Tag = TagArt(tn.Tag) + LTrim(Str(Strukturnr))
            tn.ExpandAll()
        Catch
        Finally
            conn.CloseConnection(True)
            ps.Dispose()
        End Try
        Me.FavoritenStruktur.AllowDrop = False
        e.Effect = DragDropEffects.None
        Originalnode = Nothing
        DestinationNode = Nothing
        e.Effect = DragDropEffects.None
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_ItemDrag Method

Private Sub FavoritenStruktur_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles FavoritenStruktur.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_ItemDrag(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles FavoritenStruktur.ItemDrag
        Me.ItemMove = True
        Me.FavoritenStruktur.AllowDrop = True
        If e.Button = MouseButtons.Left Then
            FavoritenStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_KeyDown Method

Private Sub FavoritenStruktur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles FavoritenStruktur.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles FavoritenStruktur.KeyDown
        If e.Control = True Then
            Select Case e.KeyCode
                Case Keys.N
                    If mnuNeuerOrdner.Enabled Then
                        mnuNeuerOrdner_Click(sender, e)
                    End If
                Case Keys.Up
                    Me.MoveNode(1)
                Case Keys.Down
                    Me.MoveNode(2)
            End Select
        End If

        If e.Control = False And e.Alt = False And e.Shift = False Then
            Select Case e.KeyCode
                Case Keys.Return
                    If Me.FavoritenStruktur.SelectedNode.ImageIndex = 1 Or Me.FavoritenStruktur.SelectedNode.ImageIndex = 60 + DP_Imagepos Then
                        If Me.FavoritenStruktur.SelectedNode.IsExpanded Then
                            Me.FavoritenStruktur.SelectedNode.Collapse()
                        Else
                            Me.FavoritenStruktur.SelectedNode.Expand()
                        End If
                    Else
                        If mnuDokument_erstellen.Enabled Then
                            DokumentErstellen()
                        End If
                    End If
                Case Keys.F2
                    If mnuUmbenennen.Enabled Then
                        mnuUmbenennen_Click(sender, e)
                    End If
                Case Keys.Delete
                    If mnuLoeschen.Enabled Then
                        mnuLoeschen_Click(sender, e)
                    End If
                Case Keys.Up
                    Update_Menu()
                Case Keys.Down
                    Update_Menu()
            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.FavoritenStruktur_MouseDown Method

Private Sub FavoritenStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles FavoritenStruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles FavoritenStruktur.MouseDown
        Dim mouseEvents As MouseEventArgs
        mouseEvents = e
        selectPoint.Y = mouseEvents.Y
        selectPoint.X = mouseEvents.X
        Try
            FavoritenStruktur.SelectedNode = FavoritenStruktur.GetNodeAt(selectPoint)
        Catch
        End Try

        Update_Menu()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Favoritenstruktur_DragDrop Method

Private Sub Favoritenstruktur_DragDrop( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles FavoritenStruktur.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Favoritenstruktur_DragDrop(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles FavoritenStruktur.DragDrop
        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
              True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        If Me.ItemMove = False Then
            FavoritenStruktur_Dragdrop_insert(sender, e)
            Exit Sub
        End If

        Dim dropNode As TreeNode = _
              CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
              TreeNode)
        Dim targetNode As TreeNode = selectedTreeview.SelectedNode
        dropNode.Remove()
        If targetNode Is Nothing Then
            selectedTreeview.Nodes.Add(dropNode)
        Else
            targetNode.Nodes.Add(dropNode)
        End If
        dropNode.EnsureVisible()
        selectedTreeview.SelectedNode = dropNode

        Dim tn As TreeNode
        tn = targetNode
        Dim i As Integer
        i = tn.GetNodeCount(True)
        For i = 0 To targetNode.GetNodeCount(True) - 1
            Save_Nodedata(tn.Nodes(i))
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Favoritenstruktur_DragOver Method

Public Sub Favoritenstruktur_DragOver( _
   ByVal sender As System.Object, _
   ByVal e As DragEventArgs _
) Handles FavoritenStruktur.DragOver

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub Favoritenstruktur_DragOver(ByVal sender As System.Object, ByVal e As DragEventArgs) Handles FavoritenStruktur.DragOver
        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
              True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        Dim Originalnode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        Dim pt As Point = _
            CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
        Dim targetNode As TreeNode = selectedTreeview.GetNodeAt(pt)
        If targetNode Is Nothing Then Exit Sub
        selectedTreeview.SelectedNode = targetNode
        If Originalnode.ImageIndex <= 60 And targetNode.ImageIndex <> 1 Then
            e.Effect = DragDropEffects.None
            Exit Sub
        End If
        If Originalnode.ImageIndex >= 60 And targetNode.ImageIndex <> 60 + DP_Imagepos Then
            e.Effect = DragDropEffects.None
            Exit Sub
        End If
        If Not (selectedTreeview.SelectedNode Is targetNode) Then
            selectedTreeview.SelectedNode = targetNode
            Dim dropNode As TreeNode = _
                CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
                TreeNode)
            Do Until targetNode Is Nothing
                If targetNode Is dropNode Then
                    e.Effect = DragDropEffects.None
                    Exit Sub
                End If
                targetNode = targetNode.Parent
            Loop
        End If
        e.Effect = DragDropEffects.Copy
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Favoritenstruktur_dragenter Method

Private Sub Favoritenstruktur_dragenter( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles FavoritenStruktur.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Favoritenstruktur_dragenter(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles FavoritenStruktur.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            Me.FavoritenStruktur.AllowDrop = True
            e.Effect = DragDropEffects.Copy
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Finalize Method

Protected Overrides Sub Finalize()

Source code

[Visual Basic]
    Protected Overrides Sub Finalize()
        MyBase.Finalize()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.GetDokumentFavoritNr Method

Private Function GetDokumentFavoritNr( _
   ByVal DokumenttypNr As Integer _
) As Integer

Parameters

DokumenttypNr
Required.

Source code

[Visual Basic]
    Private Function GetDokumentFavoritNr(ByVal DokumenttypNr As Integer) As Integer
        '===============================================================================
        'Description : Aus dem  DokumenttypNr aus der Tabelle dokumentfavoriten
        '              wird die DokumentFavoritNr ermittelt
        'Input       : DokumenttypNr
        'Criteria    : MitarbeiterNr
        'Output      : DokumentfavoritNr
        'Date        : koe 19.08.2004
        'Modified    :
        '===============================================================================
        Dim iDokumentFavoritNr As Integer
        Dim sqlConnection As New SqlConnection()
        Dim Sqlcmd As New SqlCommand()
        sqlConnection = conn.scoDBConnection
        sqlConnection.Open()
        With Sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "sp_get_DokumentFavoritNr"

            .Parameters.Clear()
            .Parameters.Add(New SqlParameter("@MitarbeiterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, Globals.MitarbeiterNr))
            .Parameters.Add(New SqlParameter("@DokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, DokumenttypNr))
            .Parameters.Add(New SqlParameter("@DokumentFavoritNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iDokumentFavoritNr))

            .Connection = sqlConnection
            .ExecuteNonQuery()
            iDokumentFavoritNr = New SqlInt32(CType(.Parameters.Item("@DokumentFavoritNr").Value, Integer)).Value
            GetDokumentFavoritNr = iDokumentFavoritNr

        End With
        Sqlcmd.Dispose()
        sqlConnection.Close()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Get_Filter Method

Private Function Get_Filter() As DataTable

Source code

[Visual Basic]
    Private Function Get_Filter() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.CommandText = "dbo.sp_get_Filter_NeueDokumente"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Get_Filter_NeueDokumente::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Get_dtnr_dpnr Method

Private Function Get_dtnr_dpnr( _
   ByVal nreintrag As Integer _
) As Integer

Parameters

nreintrag
Required.

Source code

[Visual Basic]
    Private Function Get_dtnr_dpnr(ByVal nreintrag As Integer) As Integer
        '===============================================================================
        'Description : Aus dem PrimaryKey dokumentfavoritnr aus der Tabelle dokumentfavoriten
        '              wird die DokumenttypNr ermittelt
        'Input       : DokumentfavoritNr
        'Criteria    : MitarbeiterNr
        'Output      : DokumenttypNr
        'Date        : koe 19.08.2004
        'Modified    :
        '===============================================================================
        Dim iDokumenttypNr As Integer
        Dim sqlConnection As New SqlConnection()
        Dim Sqlcmd As New SqlCommand()
        sqlConnection = conn.scoDBConnection
        '      If sqlConnection.State = ConnectionState.Closed Then
        sqlConnection.Open()
        '     End If
        With Sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "dbo.edex_sp_get_dtdp_key"

            .Parameters.Clear()
            .Parameters.Add(New SqlParameter("@nreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, nreintrag))
            .Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))

            .Connection = sqlConnection
            .ExecuteNonQuery()
            Sqlcmd.Dispose()
            sqlConnection.Close()
            Return .Parameters.Item("@key").Value
        End With
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmVorlagenauswahl))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TVStruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokumenterstellen = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MnuAddFavoriten = New System.Windows.Forms.MenuItem()
        Me.MnuShowFavoriten = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuUnExpand = New System.Windows.Forms.MenuItem()
        Me.MenuExpand = New System.Windows.Forms.MenuItem()
        Me.MenuUnexpandsel = New System.Windows.Forms.MenuItem()
        Me.MnuExpandSel = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TxtSearch = New System.Windows.Forms.TextBox()
        Me.pnlFavoriten = New System.Windows.Forms.Panel()
        Me.FavoritenStruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.mnuDokument_erstellen = New System.Windows.Forms.MenuItem()
        Me.mnuInfoDokumentvorlage = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MnuPaketverwaltung = New System.Windows.Forms.MenuItem()
        Me.MnuIDVBearbeitung = New System.Windows.Forms.MenuItem()
        Me.MnuNeuesDokumentpaket = New System.Windows.Forms.MenuItem()
        Me.MnuDokumentpaketKopieren = New System.Windows.Forms.MenuItem()
        Me.MnuMAKopie = New System.Windows.Forms.MenuItem()
        Me.mnuLoeschen = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.mnuUmbenennen = New System.Windows.Forms.MenuItem()
        Me.mnuNeuerOrdner = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.picSmiley = New System.Windows.Forms.PictureBox()
        Me.pnlFavoriten.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton5, Me.ToolBarButton4, Me.ToolBarButton6, Me.ToolBarButton3})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList2
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(552, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 1
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 2
        Me.ToolBarButton4.ToolTipText = "Favoriten anzeigen"
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 3
        Me.ToolBarButton6.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 3
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TVStruktur
        '
        Me.TVStruktur.ContextMenu = Me.ContextMenu1
        Me.TVStruktur.Dock = System.Windows.Forms.DockStyle.Left
        Me.TVStruktur.HideSelection = False
        Me.TVStruktur.ImageList = Me.ImageList3
        Me.TVStruktur.Location = New System.Drawing.Point(0, 25)
        Me.TVStruktur.Name = "TVStruktur"
        Me.TVStruktur.Size = New System.Drawing.Size(552, 540)
        Me.TVStruktur.TabIndex = 1
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokumenterstellen, Me.MenuItem8, Me.MenuItem2, Me.MnuAddFavoriten, Me.MnuShowFavoriten, Me.MenuItem1, Me.MenuUnExpand, Me.MenuExpand, Me.MenuUnexpandsel, Me.MnuExpandSel, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7})
        '
        'MnuDokumenterstellen
        '
        Me.MnuDokumenterstellen.Index = 0
        Me.MnuDokumenterstellen.Text = "&Dokument erstellen"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 1
        Me.MenuItem8.Text = "Informationen zur Dokumentvorlage"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        Me.MenuItem2.Visible = False
        '
        'MnuAddFavoriten
        '
        Me.MnuAddFavoriten.Index = 3
        Me.MnuAddFavoriten.Text = "&Vorlage zu den Favoriten hinzufügen..."
        Me.MnuAddFavoriten.Visible = False
        '
        'MnuShowFavoriten
        '
        Me.MnuShowFavoriten.Index = 4
        Me.MnuShowFavoriten.Text = "&Favoriten anzeigen"
        Me.MnuShowFavoriten.Visible = False
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 5
        Me.MenuItem1.Text = "-"
        '
        'MenuUnExpand
        '
        Me.MenuUnExpand.Index = 6
        Me.MenuUnExpand.Text = "Alle Knoten schliessen"
        '
        'MenuExpand
        '
        Me.MenuExpand.Index = 7
        Me.MenuExpand.Text = "Alle Knoten öffnen"
        '
        'MenuUnexpandsel
        '
        Me.MenuUnexpandsel.Index = 8
        Me.MenuUnexpandsel.Text = "Selektierter Knoten schliessen"
        '
        'MnuExpandSel
        '
        Me.MnuExpandSel.Index = 9
        Me.MnuExpandSel.Text = "Selektierter Knoten öffnen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 10
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 11
        Me.MenuItem6.Text = "Dokumentvorschau"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 12
        Me.MenuItem7.Text = "-"
        Me.MenuItem7.Visible = False
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'TxtSearch
        '
        Me.TxtSearch.Location = New System.Drawing.Point(104, 4)
        Me.TxtSearch.Name = "TxtSearch"
        Me.TxtSearch.Size = New System.Drawing.Size(200, 20)
        Me.TxtSearch.TabIndex = 2
        Me.TxtSearch.Text = ""
        '
        'pnlFavoriten
        '
        Me.pnlFavoriten.Controls.AddRange(New System.Windows.Forms.Control() {Me.FavoritenStruktur})
        Me.pnlFavoriten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlFavoriten.Location = New System.Drawing.Point(557, 25)
        Me.pnlFavoriten.Name = "pnlFavoriten"
        Me.pnlFavoriten.Size = New System.Drawing.Size(0, 540)
        Me.pnlFavoriten.TabIndex = 3
        Me.pnlFavoriten.Visible = False
        '
        'FavoritenStruktur
        '
        Me.FavoritenStruktur.AllowDrop = True
        Me.FavoritenStruktur.ContextMenu = Me.ContextMenu3
        Me.FavoritenStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.FavoritenStruktur.FullRowSelect = True
        Me.FavoritenStruktur.HideSelection = False
        Me.FavoritenStruktur.ImageList = Me.ImageList1
        Me.FavoritenStruktur.Name = "FavoritenStruktur"
        Me.FavoritenStruktur.Size = New System.Drawing.Size(0, 540)
        Me.FavoritenStruktur.TabIndex = 0
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDokument_erstellen, Me.mnuInfoDokumentvorlage, Me.MenuItem3, Me.MnuPaketverwaltung, Me.mnuLoeschen, Me.MenuItem12, Me.mnuUmbenennen, Me.mnuNeuerOrdner, Me.MenuItem4, Me.MenuItem9, Me.MenuItem10})
        '
        'mnuDokument_erstellen
        '
        Me.mnuDokument_erstellen.Index = 0
        Me.mnuDokument_erstellen.Text = "&Dokument erstellen"
        '
        'mnuInfoDokumentvorlage
        '
        Me.mnuInfoDokumentvorlage.Index = 1
        Me.mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'MnuPaketverwaltung
        '
        Me.MnuPaketverwaltung.Index = 3
        Me.MnuPaketverwaltung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuIDVBearbeitung, Me.MnuNeuesDokumentpaket, Me.MnuDokumentpaketKopieren, Me.MnuMAKopie})
        Me.MnuPaketverwaltung.Text = "Dokumentpaket-Verwaltung"
        '
        'MnuIDVBearbeitung
        '
        Me.MnuIDVBearbeitung.Index = 0
        Me.MnuIDVBearbeitung.Text = "&Dokumentpaket bearbeiten"
        '
        'MnuNeuesDokumentpaket
        '
        Me.MnuNeuesDokumentpaket.Index = 1
        Me.MnuNeuesDokumentpaket.Text = "&Neues Dokumentpaket erstellen"
        '
        'MnuDokumentpaketKopieren
        '
        Me.MnuDokumentpaketKopieren.Index = 2
        Me.MnuDokumentpaketKopieren.Text = "Dokumentpaket &kopieren"
        '
        'MnuMAKopie
        '
        Me.MnuMAKopie.Index = 3
        Me.MnuMAKopie.Text = "Dokument für ... kopieren"
        '
        'mnuLoeschen
        '
        Me.mnuLoeschen.Index = 4
        Me.mnuLoeschen.Shortcut = System.Windows.Forms.Shortcut.Del
        Me.mnuLoeschen.Text = "&Löschen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 5
        Me.MenuItem12.Text = "-"
        '
        'mnuUmbenennen
        '
        Me.mnuUmbenennen.Index = 6
        Me.mnuUmbenennen.Shortcut = System.Windows.Forms.Shortcut.F2
        Me.mnuUmbenennen.Text = "&Umbenennen"
        '
        'mnuNeuerOrdner
        '
        Me.mnuNeuerOrdner.Index = 7
        Me.mnuNeuerOrdner.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.mnuNeuerOrdner.Text = "Neuer Ordner"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 8
        Me.MenuItem4.Text = "-"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 9
        Me.MenuItem9.Text = "&Aufwärts"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 10
        Me.MenuItem10.Text = "A&bwärts"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sp_dokumentfavoriten_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_dokumentfavoriten_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentfavoritenstruktur", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(344, 3)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(176, 21)
        Me.ComboBox1.TabIndex = 4
        Me.ComboBox1.Text = "ComboBox1"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(312, 6)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 5
        Me.Label1.Text = "Filter:"
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(552, 25)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(5, 540)
        Me.Splitter2.TabIndex = 6
        Me.Splitter2.TabStop = False
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(528, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 36
        '
        'picSmiley
        '
        Me.picSmiley.Image = CType(resources.GetObject("picSmiley.Image"), System.Drawing.Bitmap)
        Me.picSmiley.Location = New System.Drawing.Point(128, 136)
        Me.picSmiley.Name = "picSmiley"
        Me.picSmiley.Size = New System.Drawing.Size(256, 248)
        Me.picSmiley.TabIndex = 37
        Me.picSmiley.TabStop = False
        Me.ToolTip1.SetToolTip(Me.picSmiley, "Greetings from the developers :)")
        '
        'frmVorlagenauswahl
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(552, 565)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.pnlFavoriten, Me.Splitter2, Me.ComboBox1, Me.Label1, Me.TxtSearch, Me.TVStruktur, Me.ToolBar1, Me.picSmiley})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVorlagenauswahl"
        Me.ShowInTaskbar = False
        Me.Text = "Vorlagenauswahl"
        Me.pnlFavoriten.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Load_Struktur Method

Private Sub Load_Struktur( _
   ByVal Searchstring As String, _
   ByVal favoriten As Boolean _
)

Parameters

Searchstring
Required.
favoriten
Required.

Source code

[Visual Basic]
    Private Sub Load_Struktur(ByVal Searchstring As String, ByVal favoriten As Boolean)
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim dokart As New edokadb.clsMyDokumentart()
            If favoriten Then
                Me.FavoritenStruktur.BeginUpdate()
                Me.FavoritenStruktur.Nodes.Clear()
                dokart.Load_FavoritenStruktur(Me.FavoritenStruktur, Searchstring, True, m_iImagesOffestImagelist1)
                If Searchstring = "" Then
                    If RootNodesFavoritenStrukturExist() = False Then
                        dokart.Load_FavoritenStruktur(Me.FavoritenStruktur, Searchstring, True, m_iImagesOffestImagelist1)
                    End If
                End If
                'Rel 3.3
                '09.11.2004 / BUD

                Me.FavoritenStruktur.Nodes.Item(0).Expand()
                Me.FavoritenStruktur.Nodes.Item(1).Expand()
                'Me.FavoritenStruktur.ExpandAll()

                Me.FavoritenStruktur.EndUpdate()
                If Me.FavoritenStruktur.Nodes.Count > 0 Then
                    Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
                End If
                Me.FavoritenStruktur.Refresh()
                Me.FavoritenStruktur.SelectedNode.Checked = True
            Else
                'Me.pnlFavoriten.Visible = False
                Me.TVStruktur.BeginUpdate()
                dokart.Load_Neue_Dokumente(Me.TVStruktur, Searchstring, False, Me.mcbfilter.SelectedValue)
                Me.TVStruktur.ExpandAll()
                TVStruktur.EndUpdate()
                If Me.TVStruktur.Nodes.Count > 0 Then
                    Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    TVStruktur.Refresh()
                    TVStruktur.SelectedNode.Checked = True
                End If
            End If

            dokart.Dispose()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuExpand_Click Method

Private Sub MenuExpand_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuExpand.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuExpand_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuExpand.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.ExpandAll()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        MoveNode(2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Dim i As Integer
        Dim printable As Boolean = False
        i = TagValue(Me.TVStruktur.SelectedNode.Tag)
        If DivFnkt.leererstellung(3, i) = True Then printable = True Else printable = False
        DivFnkt.show_officevorlage(i, Me, printable)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" And TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DP_" Then
            Exit Sub
        End If

        If Me.TVStruktur.SelectedNode.ImageIndex = 62 Then
            Dim f As New frmDokumentpaketInfo()
            Try
                f.Key = TagValue(Me.TVStruktur.SelectedNode.Tag)
                f.Titel = Me.TVStruktur.SelectedNode.Text
                f.ShowDialog()
                f.Dispose()
                Exit Sub
            Catch
            Finally
                f.Dispose()
            End Try
        Else
            Dim f As New frmDokumenttypInfo()
            Try
                f.Key = TagValue(TVStruktur.SelectedNode.Tag)
                f.Text = f.Text + Me.TVStruktur.SelectedNode.Text
                f.ShowDialog()
            Catch
            Finally
                f.dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuItem9_Click Method

Private Sub MenuItem9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem9.Click
        MoveNode(1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuUnExpand_Click Method

Private Sub MenuUnExpand_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuUnExpand.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuUnExpand_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuUnExpand.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.CollapseAll()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MenuUnexpandsel_Click Method

Private Sub MenuUnexpandsel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuUnexpandsel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuUnexpandsel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuUnexpandsel.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.SelectedNode.Collapse()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuAddFavoriten_Click Method

Private Sub MnuAddFavoriten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuAddFavoriten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuAddFavoriten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuAddFavoriten.Click
        Dim f As New frmFavoritenZuordnung()
        f.Dokumenttypnr = TagValue(Me.TVStruktur.SelectedNode.Tag)
        f.TextBox1.Text = Me.TVStruktur.SelectedNode.Text
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuDokumenterstellen_Click Method

Private Sub MnuDokumenterstellen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumenterstellen.Click, _
   TVStruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumenterstellen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumenterstellen.Click, TVStruktur.DoubleClick
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" And TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DP_" Then
            Exit Sub
        End If
        If Me.TVStruktur.SelectedNode.ImageIndex = 62 Then
            Me.Dokumentvorlage = TagValue(Me.TVStruktur.SelectedNode.Tag)
            Globals.bckdokument = False
            Globals.EinzelDokument = False
            Globals.DokumentPaket = True
            Globals.Individuelles_Dokumentpaket = False
            Me.DialogResult = DialogResult.OK
            Me.Close()
            Exit Sub
        End If
        Me.Dokumentvorlage = Me.TagValue(Me.TVStruktur.SelectedNode.Tag)
        Globals.bckdokument = False
        Globals.EinzelDokument = False
        If Check_Barcode() = False Then Exit Sub
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuDokumentpaketKopieren_Click Method

Private Sub MnuDokumentpaketKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentpaketKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentpaketKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentpaketKopieren.Click
        Dim f As frmDokumentpaketdefinition
        If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + Me.DP_Imagepos Then
            f = New frmDokumentpaketdefinition(False, Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag)), True)
        Else
            f = New frmDokumentpaketdefinition(False, TagValue(Me.FavoritenStruktur.SelectedNode.Tag), True)
        End If
        f.Kopie = True
        f.ShowDialog()
        f.Dispose()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuExpandSel_Click Method

Private Sub MnuExpandSel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuExpandSel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuExpandSel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuExpandSel.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.SelectedNode.Expand()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuFavoritentfernen_Click Method

Private Sub MnuFavoritentfernen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuFavoritentfernen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim df As New edokadb.clsDokumentfavoriten()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        df.iDokumenttypnr = New SqlInt32(CType(TagValue(Me.TVStruktur.SelectedNode.Tag), Int32))
        df.bAktiv = New SqlBoolean(CType(False, Boolean))
        df.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        df.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        df.Update()
        conn.CloseConnection(True)
        df.Dispose()
        dbkey.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuIDVBearbeitung_Click Method

Private Sub MnuIDVBearbeitung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuIDVBearbeitung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuIDVBearbeitung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuIDVBearbeitung.Click
        Dim f As New frmDokumentpaketdefinition(False, Me.TagValue(Me.FavoritenStruktur.SelectedNode.Tag), True)
        f.ShowDialog()
        f.Dispose()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuMaKopie_Click Method

Private Sub MnuMaKopie_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuMAKopie.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMaKopie_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuMAKopie.Click
        Dim ma As New frmMitarbeiterSelektion()
        Dim i As Integer
        i = ma.ShowDialog()
        If Not i = DialogResult.OK Then
            Exit Sub
        End If
        i = ma.Mitarbeiternr
        ma.Dispose()
        Dim f As frmDokumentpaketdefinition
        f = New frmDokumentpaketdefinition(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), i)
        f.Show()
        f.Dispose()
        MyMsg.show_standardmessage(415, MsgBoxStyle.Information)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuNeuesDokumentpaket_Click Method

Private Sub MnuNeuesDokumentpaket_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeuesDokumentpaket.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeuesDokumentpaket_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuesDokumentpaket.Click
        Dim f As New frmDokumentpaketdefinition(True, 0, True)
        f.ShowDialog()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MnuShowFavoriten_Click Method

Private Sub MnuShowFavoriten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowFavoriten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowFavoriten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowFavoriten.Click
        Me.pnlFavoriten.Visible = True
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.MoveNode Method

Private Sub MoveNode( _
   ByVal direction As Integer _
)

Parameters

direction
Required.

Source code

[Visual Basic]
    Private Sub MoveNode(ByVal direction As Integer)
        Dim tn As TreeNode
        Dim tnp As TreeNode
        Dim index As Integer
        tn = Me.FavoritenStruktur.SelectedNode
        If tn.Parent Is Nothing Then Exit Sub
        tnp = tn.Parent
        'If tnp.ImageIndex = 1 Or tnp.ImageIndex = 60 + DP_Imagepos Then Exit Sub

        If tnp.GetNodeCount(True) < 1 Then
            Exit Sub
        End If

        If direction = 1 And tn.Index > 0 Then
            index = tn.Index - 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If
        If direction = 2 And tn.Index < tnp.GetNodeCount(True) Then
            index = tn.Index + 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If

        Dim i As Integer
        For i = 0 To tnp.GetNodeCount(False) - 1
            Me.Save_Nodedata(tnp.Nodes(i))
        Next

        DivFnkt.Searchnode(FavoritenStruktur, tn.Tag, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.RenameNodeFavoritenstruktur Method

Private Sub RenameNodeFavoritenstruktur( _
   ByVal dokumentfavoritennr As Integer, _
   ByVal NodeText As String _
)

Parameters

dokumentfavoritennr
Required.
NodeText
Required.

Source code

[Visual Basic]
    Private Sub RenameNodeFavoritenstruktur(ByVal dokumentfavoritennr As Integer, ByVal NodeText As String)
        If dokumentfavoritennr <> 0 Then
            Dim df As New edokadb.clsEDEX_Favoriten()
            df.cpMainConnectionProvider = conn
            conn.OpenConnection()
            df.iNreintrag = New SqlInt32(CType(dokumentfavoritennr, Int32))
            df.SelectOne()
            df.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            df.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            df.sBezeichnung = New SqlString(CType(NodeText, String))
            df.bAktiv = New SqlBoolean(CType(True, Boolean))
            df.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
            df.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            df.Update()
            conn.CloseConnection(True)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ResizeForm Method

Private Sub ResizeForm()

Source code

[Visual Basic]
    Private Sub ResizeForm()
        formatForm()
        '        If FavoritenStruktur.Visible And TVStruktur.Visible Then
        '        'TVStruktur.Width = Me.ClientSize.Width / 2
        '        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.RootNodesFavoritenStrukturExist Method

Private Function RootNodesFavoritenStrukturExist( _
   Optional ByVal RootNodetext As String = "Favoriten" _
) As Boolean

Parameters

RootNodetext
Optional. Default value is "Favoriten".

Source code

[Visual Basic]
    Private Function RootNodesFavoritenStrukturExist(Optional ByVal RootNodetext As String = "Favoriten") As Boolean
        RootNodesFavoritenStrukturExist = True
        If FavoritenStruktur.Nodes.Count < 1 Then
            Dim dfs As New edokadb.clsDokumentfavoriten_struktur()
            RootNodesFavoritenStrukturExist = False
            dfs.cpMainConnectionProvider = conn
            conn.OpenConnection()
            dfs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            dfs.sBezeichnung = New SqlString(CType(RootNodetext, String))
            dfs.iParentid = New SqlInt32(CType(0, Int32))
            dfs.iSort = New SqlInt32(CType(0, Int32))
            dfs.iImageindex = New SqlInt32(CType(1, Int32))
            dfs.iImageindexopen = New SqlInt32(CType(1, Int32))
            dfs.sBeschreibung = New SqlString(CType("Root Knoten", String))
            dfs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            dfs.iSprache = New SqlInt32(CType(1, Int32))
            dfs.bAktiv = New SqlBoolean(CType(True, Boolean))
            dfs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            dfs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            dfs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            dfs.Insert()
            conn.CloseConnection(True)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Save_Nodedata Method

Private Sub Save_Nodedata( _
   ByVal tn As TreeNode _
)

Parameters

tn
Required.

Source code

[Visual Basic]
    Private Sub Save_Nodedata(ByVal tn As TreeNode)
        Dim keyvalue As Integer
        Dim wert As Integer
        Dim indexnr As Integer
        Dim idp As Integer
        If tn.ImageIndex = 61 + DP_Imagepos Then
            idp = 1
            keyvalue = TagValue(tn.Tag)
        Else
            keyvalue = TagValue(tn.Tag)
            idp = 0
        End If

        indexnr = tn.Index
        wert = TagValue(tn.Parent.Tag)

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "edex_sp_dokumentpaketstruktur_update"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, keyvalue))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@idp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, idp))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.SearchDokFavoritenNode Method

Private Sub SearchDokFavoritenNode( _
   ByRef TV As TreeView, _
   ByVal tn As TreeNode, _
   ByRef Tag As String _
)

Parameters

TV
Required.
tn
Required.
Tag
Required.

Source code

[Visual Basic]
    Private Sub SearchDokFavoritenNode(ByRef TV As TreeView, ByVal tn As TreeNode, ByRef Tag As String)
        If tn.Tag <> Tag Then
            If tn.FirstNode Is Nothing Then
                'Keine Childknoten gefunden
                If Not tn.NextNode Is Nothing Then
                    'Knoten auf gleicher Ebene
                    SearchDokFavoritenNode(TV, tn.NextNode, Tag)
                End If
            Else
                'Childkonoten vorhanden
                SearchDokFavoritenNode(TV, tn.FirstNode, Tag)
                If Not tn.NextNode Is Nothing Then
                    'Knoten auf gleicher Ebene
                    SearchDokFavoritenNode(TV, tn.NextNode, Tag)
                End If
            End If
        Else
            TV.SelectedNode = tn
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ShowControls Method

Private Sub ShowControls()

Source code

[Visual Basic]
    Private Sub ShowControls()
        '===============================================================================
        'Dokumentvorlage
        '===============================================================================
        Me.TVStruktur.Visible = Me.ToolBar1.Buttons(2).Pushed

        Me.Label1.Visible = Me.TVStruktur.Visible
        Me.mcbfilter.Visible = Me.TVStruktur.Visible
        Me.ComboBox1.Visible = Me.TVStruktur.Visible
        ToolBar1.Buttons(5).Visible = Me.TVStruktur.Visible     'Button suchen
        Me.TxtSearch.Visible = Me.TVStruktur.Visible
        '===============================================================================
        'Favoriten Ordnerstruktur
        '===============================================================================
        Me.pnlFavoriten.Visible = Me.ToolBar1.Buttons(3).Pushed

        '===============================================================================
        'Anordnen der Controls
        '===============================================================================

        '  Me.FavoritenStruktur.AllowDrop = False

        If Me.TVStruktur.Visible Then
            If Me.pnlFavoriten.Visible Then
                Me.TVStruktur.Dock = DockStyle.Left
                'Me.TVStruktur.BringToFront()

                Me.Splitter2.Visible = True
                Me.Splitter2.Dock = DockStyle.Left
                'Me.Splitter2.BringToFront()

                Me.FavoritenStruktur.AllowDrop = True
                Me.pnlFavoriten.Dock = DockStyle.Fill
                'Me.pnlFavoriten.BringToFront()

            Else
                Me.Splitter2.Visible = False
                Me.TVStruktur.Dock = DockStyle.Fill
                'Me.TVStruktur.BringToFront()
            End If
        Else
            If Me.pnlFavoriten.Visible Then
                Me.Splitter2.Visible = False
                Me.pnlFavoriten.Dock = DockStyle.Fill
                'Me.pnlFavoriten.BringToFront()
            Else
            End If
        End If

        'If Me.pnlFavoriten.Visible And Me.TVStruktur.Visible Then
        'Me.Width = Globals.EDOKAMAIN_WindowWidth / 4 * 3
        'Else
        'Me.Width = Globals.EDOKAMAIN_WindowWidth / 5 * 2
        'End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TVStruktur_AfterSelect Method

Private Sub TVStruktur_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TVStruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TVStruktur.AfterSelect
        Me.Dokumentpaket = False
        If TVStruktur.SelectedNode.ImageIndex = 68 Then Me.Dokumentpaket = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TVStruktur_ItemDrag Method

Private Sub TVStruktur_ItemDrag( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles TVStruktur.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles TVStruktur.ItemDrag
        Me.ItemMove = False
        If e.Button = MouseButtons.Left Then
            Select Case TagArt(TVStruktur.SelectedNode.Tag)
                Case "DT_"      'nur Dokumente word,Barcode,Word mit Barcode... (keine Stukturknoten)
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case "DP_"
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case Else
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.None)

            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TVStruktur_KeyDown Method

Private Sub TVStruktur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TVStruktur.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TVStruktur.KeyDown
        If e.KeyCode = Keys.Return Then Me.MnuDokumenterstellen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TVStruktur_MouseDown Method

Private Sub TVStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVStruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVStruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.FavoritenStruktur.AllowDrop = True

            Try
                TVStruktur.SelectedNode = TVStruktur.GetNodeAt(selectPoint)
            Catch
            End Try
            If TVStruktur.SelectedNode.ImageIndex < 60 Then
                Me.MnuDokumenterstellen.Text = "Dokument erstellen"
                Me.MenuItem8.Text = "Informationen zur Dokumentvoralge"
            Else
                Me.MnuDokumenterstellen.Text = "Dokumentpaket auswählen"
                Me.MenuItem8.Text = "Informationen zum Dokumentpaket"
            End If

            If Me.TVStruktur.SelectedNode.GetNodeCount(False) < 1 Then
                Me.MnuDokumenterstellen.Enabled = True
                Me.MenuItem8.Enabled = True
            Else
                Me.MnuDokumenterstellen.Enabled = False
                Me.MenuItem8.Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TagArt Method

Private Function TagArt( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagArt(ByVal tag As String) As String
        Dim Art As String
        Art = tag
        Return Art.Substring(0, 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TagValue Method

Private Function TagValue( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagValue(ByVal tag As String) As String
        Dim Keyvalue As String
        Keyvalue = tag
        Return Keyvalue.Substring(3, Len(Keyvalue) - 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim bFavoritenVissible As Boolean
        Dim bDokStruckturVissible As Boolean

        Try
            Select Case ToolBar1.Buttons.IndexOf(e.Button)
                Case 0 ' Close
                    Me.Close()
                Case 3  'Ordner Struktur
                    If Me.ToolBar1.Buttons(3).Pushed Then
                        bFavoritenVissible = True
                    Else
                        bFavoritenVissible = False
                    End If
                    Me.ToolBar1.Buttons(3).Pushed = Not Me.ToolBar1.Buttons(3).Pushed 'Favoriten
                    ShowControls()
                    If bFavoritenVissible = False Then
                        Load_Struktur("", True)
                    End If
                    If Me.FavoritenStruktur.Nodes.Count > 0 Then
                        Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
                    End If
                    ResizeForm()
                Case 2 'Dokumentstruktur
                    If Me.ToolBar1.Buttons(2).Pushed Then
                        bDokStruckturVissible = True
                    Else
                        bDokStruckturVissible = False
                    End If
                    Me.ToolBar1.Buttons(2).Pushed = Not Me.ToolBar1.Buttons(2).Pushed 'Dokumentvorlagen
                    ShowControls()
                    Me.TxtSearch.Select()
                    If bDokStruckturVissible = False Then
                        Load_Struktur("", False)
                    End If
                    Me.TVStruktur.ContextMenu = Me.ContextMenu1
                    If Me.TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If
                    ResizeForm()
                Case 5
                    Load_Struktur(Me.TxtSearch.Text, False)
                    Me.TVStruktur.ContextMenu = Me.ContextMenu1
                    If Me.TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If
                Case Else
            End Select
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.TxtSearch_KeyDown Method

Private Sub TxtSearch_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TxtSearch.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TxtSearch_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TxtSearch.KeyDown
        If e.KeyCode = Keys.Enter Then
            'Me.pnlFavoriten.Visible = False
            Load_Struktur(Me.TxtSearch.Text, False)
            Try
                Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Update_Menu Method

Private Sub Update_Menu()

Source code

[Visual Basic]
    Private Sub Update_Menu()
        If Not FavoritenStruktur.SelectedNode Is Nothing Then
            Select Case FavoritenStruktur.SelectedNode.ImageIndex
                Case 1      'Folder
                    mnuUmbenennen.Enabled = True            'Umbenennen eines Ordners
                    mnuNeuerOrdner.Enabled = True               'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
                Case (60 + DP_Imagepos)      'Dokumentpaketfolder
                    mnuUmbenennen.Enabled = True            'Umbenennen eines Ordners
                    mnuNeuerOrdner.Enabled = True               'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokumentpaket erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zum Dokumentpaket"
                Case Is > 60
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = True       'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = True        'Erstellen eines Dokument
                    mnuDokument_erstellen.Enabled = True       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokumentpaket auswählen"
                    mnuInfoDokumentvorlage.Text = "Informationen zum Dokumentpaket"
                Case Is > 1 'Dokumente
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = True       'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = True        'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
                Case Else
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = False                 'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
            End Select
        Else
            mnuUmbenennen.Enabled = False                       'Umbenennen eines Ordeners
            mnuNeuerOrdner.Enabled = False                      'Erstellen eines Ordners
            mnuLoeschen.Enabled = False                         'löschen eines Ordner oder Dokument
            mnuInfoDokumentvorlage.Enabled = False              'Info zu Dokvorlage
            mnuDokument_erstellen.Enabled = False               'Erstellen eines Dokument

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.Vorlagenauswahl_Load Method

Private Sub Vorlagenauswahl_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Vorlagenauswahl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'Me.TVStruktur.ImageList = Globals.DokumentartenImages
        'Filter
        On_Load = True
        '===============================================================================
        'Image von der Dokstruktur in die Imagelist Hinzufügen
        '===============================================================================
        m_iImagesOffestImagelist1 = ImageList1.Images.Count
        Dim iCount As Integer
        For iCount = 0 To TVStruktur.ImageList.Images.Count - 1
            ImageList1.Images.Add(TVStruktur.ImageList.Images.Item(iCount).Clone)
        Next

        mcbfilter = New MultiComboBox(Me.ComboBox1)
        Me.mcbfilter.BeginUpdate()
        Me.mcbfilter.DisplayColumnName = "Bezeichnung"
        Me.mcbfilter.ValueColumnName = "Type"
        mcbfilter.Fill_Data(Get_Filter, False)
        Me.mcbfilter.NullValueMessage = MyMsg.Get_Meldungstext(18)
        Me.mcbfilter.CheckNullValue = True
        Me.mcbfilter.BringToFront()
        Me.Label1.Visible = True
        Me.mcbfilter.Visible = True
        Me.ComboBox1.Visible = True
        On_Load = False

        Me.Dokumentvorlage = 0
        Me.Cursor = Cursors.WaitCursor
        ShowControls()          'anzeigen der Controls auf dem Form

        If Me.ToolBar1.Buttons(3).Pushed = True Then        'OrdnerStruktur Favoriten
            Me.FavoritenStruktur.Select()
            Me.FavoritenStruktur.HideSelection = False
            Load_Struktur("", True)
            Try
                Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
            Catch
            End Try
        End If
        If Me.ToolBar1.Buttons(2).Pushed = True Then
            If Me.Dokumentart <> "" Then
                Me.mcbfilter.SelectedValue = 0
                Globals.Vorlagenfilter = 0
            End If
            Load_Struktur("", False)

            Me.TVStruktur.ContextMenu = Me.ContextMenu1
            If Me.Dokumentart <> "" Then
                DivFnkt.Searchnode1(Me.TVStruktur, "DA_" + Me.Dokumentart, 0)
                Me.Dokumentart = ""
                If DivFnkt.found Then
                    Me.TVStruktur.CollapseAll()
                    Me.TVStruktur.SelectedNode = DivFnkt.FoundNode
                    Me.TVStruktur.SelectedNode.ExpandAll()
                    Me.TVStruktur.SelectedNode = DivFnkt.FoundNode
                    If TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If

                End If
            End If
        End If
        formatForm()
        Try
            Me.TxtSearch.Select()
        Catch
        End Try

        On_Load = True
        Me.mcbfilter.SelectedValue = Globals.Vorlagenfilter
        If Globals.Vorlagenfilter <> 0 Then
            Load_Struktur(Me.TxtSearch.Text, False)
            If Me.TVStruktur.Nodes.Count > 0 Then
                Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
            End If
        End If
        Me.mcbfilter.EndUpdate()
        On_Load = False

        '        Dim ttip As New ToolTip()
        Dim s As String = "- CTRL+N: Neuer Ordner erstellen" + vbCrLf + _
                          "- CTRL+UP: Aktueller Eintrag nach oben verschieben" + vbCrLf + _
                          "- CTRL+Down: Aktueller Eintrag nach untern verschieben" + vbCrLf + _
                          "- Enter: Ordner önnen/Schliessen bzw. Dokument/Dokumentpaket erstellen" + vbCrLf + _
                          "- Del: Eintrag löschen" + vbCrLf + _
                          "- Up: Selektion nach oben verschieben" + vbCrLf + _
                          "- Down: Selektion nach unten Vershcieben"

        '       ttip.SetToolTip(FavoritenStruktur, s)
        '      Dim td As New clsBalloon()
        '     td.CustomBalloon(ttip)
        Me.Cursor = Cursors.Default

        'Hutter 2005-02-01 EDEX
        If Me.edex_vorlagenauswahl Then
            Me.ToolBarButton4.Enabled = False
            DivFnkt.Searchnode(Me.TVStruktur, "DP_0", 0)
            If DivFnkt.found Then
                DivFnkt.FoundNode.Remove()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.formatForm Method

Private Sub formatForm()

Source code

[Visual Basic]
    Private Sub formatForm()
        If Me.TVStruktur.Visible = True And Me.pnlFavoriten.Visible = False Then
            Me.Width = 560
        End If

        If Me.TVStruktur.Visible = True And Me.pnlFavoriten.Visible = True Then
            Me.Width = 960
            'Me.Width = Me.TVStruktur.Width + Me.Splitter2.Width + Me.TVStruktur.Width
        End If

        If Me.TVStruktur.Visible = False And Me.pnlFavoriten.Visible = True Then
            Me.Width = 560
            'Me.Width = Me.TVStruktur.Width
        End If

        If Me.TVStruktur.Visible = False And Me.pnlFavoriten.Visible = False Then
            Me.Width = 560
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.frmVorlagenauswahl_Resize Method

Private Sub frmVorlagenauswahl_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVorlagenauswahl_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        'ResizeForm()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mcbfilter_SelectedValueChanged Method

Private Sub mcbfilter_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbfilter.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbfilter_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbfilter.SelectedValueChanged
        If On_Load Then Exit Sub
        Me.Cursor = Cursors.WaitCursor
        Globals.Vorlagenfilter = Me.mcbfilter.SelectedValue
        'TVStruktur.BeginUpdate()
        Load_Struktur(Me.TxtSearch.Text, False)

        'Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
        'TVStruktur.EndUpdate()
        'TVStruktur.Refresh()

        Try
            Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
        Catch
        End Try

        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mnuDokument_erstellen_Click Method

Private Sub mnuDokument_erstellen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDokument_erstellen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDokument_erstellen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDokument_erstellen.Click
        DokumentErstellen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mnuInfoDokumentvorlage_Click Method

Private Sub mnuInfoDokumentvorlage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoDokumentvorlage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoDokumentvorlage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoDokumentvorlage.Click
        If Me.FavoritenStruktur.SelectedNode.ImageIndex >= 60 + DP_Imagepos Then
            Dim f As New frmDokumentpaketInfo()

            Try
                If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + DP_Imagepos Then
                    f.Key = Me.Get_dtnr_dpnr(TagValue(Me.FavoritenStruktur.SelectedNode.Tag))
                Else
                    f.Key = TagValue(Me.FavoritenStruktur.SelectedNode.Tag)
                End If
                f.Titel = Me.FavoritenStruktur.SelectedNode.Text

                f.ShowDialog()
                f.Dispose()
                Exit Sub
            Catch
            Finally
                f.Dispose()
            End Try
        Else
            Dim f As New frmDokumenttypInfo()
            Try
                f.Key = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
                f.Text = f.Text + Me.FavoritenStruktur.SelectedNode.Text
                f.ShowDialog()
            Catch
            Finally
                f.dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mnuLoeschen_Click Method

Private Sub mnuLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoeschen.Click
        Dim tn As TreeNode
        tn = Me.FavoritenStruktur.SelectedNode
        If tn.Parent Is Nothing Then
            MyMsg.show_standardmessage(400, MsgBoxStyle.Information)
            '            MsgBox("Die Root-Einträge können nicht gelöscht werden.", MsgBoxStyle.Information)
            Exit Sub

        End If

        Dim answer As MsgBoxResult
        If tn.ImageIndex <> 1 And tn.ImageIndex <> 60 + DP_Imagepos Then
            answer = MyMsg.show_MessageYesNo_ReplaceText(403, tn.Text, "")
            '            answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' löschen?", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        Else
            If tn.ImageIndex = 1 Then
                answer = MyMsg.show_MessageYesNo_ReplaceText(402, tn.Text, "")
                '                answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' inkl. allfälligen Untereinträgen löschen?", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
            Else
                answer = MyMsg.show_MessageYesNo_ReplaceText(401, tn.Text, "")
                '               answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' inkl. allfälligen Untereinträgen löschen?" + vbCrLf + "(Individuelle Dokumentpakete werden inaktiviert)", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
            End If
        End If
        If answer = MsgBoxResult.No Then Exit Sub
        DeleteNodes(Me.FavoritenStruktur.SelectedNode)
        DelNode(tn)
        tn.Remove()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mnuNeuerOrdner_Click Method

Private Sub mnuNeuerOrdner_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuNeuerOrdner.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuNeuerOrdner_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuNeuerOrdner.Click
        Dim Strukturnr As Integer
        Dim tn As TreeNode
        Dim tnnew As TreeNode
        Dim sNodeText As String
        Dim iDokumentFavoritenNr As Integer

        sNodeText = InputBox("Neuer Ordnername", "Neuer Favoritenordner hinzufügen")
        If sNodeText = "" Then Exit Sub
        If Me.FavoritenStruktur.SelectedNode.ImageIndex <> 1 And Me.FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            tn = Me.FavoritenStruktur.SelectedNode
            Strukturnr = TagValue(Me.FavoritenStruktur.SelectedNode.Parent.Tag)
        Else
            Strukturnr = TagValue(Me.FavoritenStruktur.SelectedNode.Tag)
            tn = Me.FavoritenStruktur.SelectedNode
        End If

        tnnew = tn.Nodes.Add(sNodeText)
        tnnew.ImageIndex = tn.ImageIndex
        tnnew.SelectedImageIndex = tn.SelectedImageIndex
        tnnew.Tag = "tmp"

        Dim fs As New edokadb.clsEDEX_Favoriten()
        fs.cpMainConnectionProvider = conn
        fs.sBezeichnung = New SqlString(CType(sNodeText, String))
        fs.bAktiv = New SqlBoolean(CType(True, Boolean))
        fs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        fs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        fs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        fs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iParentid = New SqlInt32(CType(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), Int32))
        fs.iSort = New SqlInt32(CType(tnnew.Index, Int32))
        fs.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        If Me.FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            fs.iImageindex = New SqlInt32(CType(tnnew.ImageIndex, Int32))
            fs.iImageindexopen = New SqlInt32(CType(tnnew.SelectedImageIndex, Int32))
        Else
            fs.iImageindex = New SqlInt32(CType(tnnew.ImageIndex - DP_Imagepos, Int32))
            fs.iImageindexopen = New SqlInt32(CType(tnnew.SelectedImageIndex - DP_Imagepos, Int32))
        End If
        fs.bDp = New SqlBoolean(CType(False, Boolean))
        fs.bStddp = New SqlBoolean(CType(False, Boolean))
        fs.iDtnr_dpnr = New SqlInt32(CType(0, Int32))
        fs.bStrukturelement = New SqlBoolean(CType(True, Boolean))
        If tn.ImageIndex = 60 + DP_Imagepos Then
            fs.bDp = New SqlBoolean(CType(True, Boolean))
        End If

        conn.OpenConnection()
        Try
            fs.Insert()
            tnnew.Tag = TagArt(tn.Tag) + LTrim(Str(fs.iNreintrag.Value))
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            fs.Dispose()
        End Try
        tn.ExpandAll()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl.mnuUmbenennen_Click Method

Private Sub mnuUmbenennen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuUmbenennen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuUmbenennen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuUmbenennen.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.FavoritenStruktur.SelectedNode.Text = a
        RenameNodeFavoritenstruktur(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), Me.FavoritenStruktur.SelectedNode.Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl Fields

frmVorlagenauswahl overview

Fields

field BtnHelp
field ComboBox1
field ContextMenu1
field ContextMenu3
field DataSet1
field FavoritenStruktur
field ImageList1
field ImageList2
field ImageList3
field ItemMove
field Label1
field MenuExpand
field MenuItem1
field MenuItem10
field MenuItem12
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuUnExpand
field MenuUnexpandsel
field MnuAddFavoriten
field MnuDokumenterstellen
field MnuDokumentpaketKopieren
field MnuExpandSel
field MnuIDVBearbeitung
field MnuMAKopie
field MnuNeuesDokumentpaket
field MnuPaketverwaltung
field MnuShowFavoriten
field On_Load
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVStruktur
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolTip1
field TxtSearch
field components
field itodelete
field m_Dokumentpaket
field m_barcodeid
field m_dokumentart
field m_dokumentvorlage
field m_edex_Vorlagenauswahl
field m_favoriten
field m_iImagesOffestImagelist1
field m_iWindowWidth
field m_profile
field m_profilnr
field mcbfilter
field mnuDokument_erstellen
field mnuInfoDokumentvorlage
field mnuLoeschen
field mnuNeuerOrdner
field mnuUmbenennen
field picSmiley
field pnlFavoriten
field selectPoint
field ssort
field todelete

See Also

frmVorlagenauswahl Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


FavoritenStruktur Variable

Friend WithEvents FavoritenStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents FavoritenStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ItemMove Variable

Dim ItemMove As Boolean = False

Source code

[Visual Basic]
    Dim ItemMove As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuExpand Variable

Friend WithEvents MenuExpand As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuExpand As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuUnExpand Variable

Friend WithEvents MenuUnExpand As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuUnExpand As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MenuUnexpandsel Variable

Friend WithEvents MenuUnexpandsel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuUnexpandsel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuAddFavoriten Variable

Friend WithEvents MnuAddFavoriten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAddFavoriten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuDokumenterstellen Variable

Friend WithEvents MnuDokumenterstellen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumenterstellen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuDokumentpaketKopieren Variable

Friend WithEvents MnuDokumentpaketKopieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentpaketKopieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuExpandSel Variable

Friend WithEvents MnuExpandSel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuExpandSel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuIDVBearbeitung Variable

Friend WithEvents MnuIDVBearbeitung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuIDVBearbeitung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuMAKopie Variable

Friend WithEvents MnuMAKopie As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuMAKopie As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuNeuesDokumentpaket Variable

Friend WithEvents MnuNeuesDokumentpaket As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeuesDokumentpaket As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuPaketverwaltung Variable

Friend WithEvents MnuPaketverwaltung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPaketverwaltung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


MnuShowFavoriten Variable

Friend WithEvents MnuShowFavoriten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowFavoriten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


On_Load Variable

Dim On_Load As Boolean = False

Source code

[Visual Basic]
    Dim On_Load As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


TVStruktur Variable

Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


TxtSearch Variable

Friend WithEvents TxtSearch As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtSearch As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


itodelete Variable

Dim itodelete As Integer

Source code

[Visual Basic]
    Dim itodelete As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_Dokumentpaket Variable

Dim m_Dokumentpaket As Boolean = False

Source code

[Visual Basic]
    Dim m_Dokumentpaket As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_dokumentart Variable

Dim m_dokumentart As String

Source code

[Visual Basic]
    Dim m_dokumentart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_dokumentvorlage Variable

Dim m_dokumentvorlage As Long

Source code

[Visual Basic]
    Dim m_dokumentvorlage As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_edex_Vorlagenauswahl Variable

Dim m_edex_Vorlagenauswahl As Boolean = False

Source code

[Visual Basic]
    Dim m_edex_Vorlagenauswahl As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_favoriten Variable

Dim m_favoriten As Boolean

Source code

[Visual Basic]
    Dim m_favoriten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_iImagesOffestImagelist1 Variable

Private m_iImagesOffestImagelist1 As Integer

Source code

[Visual Basic]
    Private m_iImagesOffestImagelist1 As Integer      'Anzahl Iamges in der Liste bevor die KocIcons dazukopiert werden

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_iWindowWidth Variable

Private m_iWindowWidth As Integer

Source code

[Visual Basic]
    Private m_iWindowWidth As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mcbfilter Variable

Dim WithEvents mcbfilter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbfilter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mnuDokument_erstellen Variable

Friend WithEvents mnuDokument_erstellen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDokument_erstellen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mnuInfoDokumentvorlage Variable

Friend WithEvents mnuInfoDokumentvorlage As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoDokumentvorlage As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mnuLoeschen Variable

Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mnuNeuerOrdner Variable

Friend WithEvents mnuNeuerOrdner As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuNeuerOrdner As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


mnuUmbenennen Variable

Friend WithEvents mnuUmbenennen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuUmbenennen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


picSmiley Variable

Friend WithEvents picSmiley As System.Windows.Forms.PictureBox

Source code

[Visual Basic]
    Friend WithEvents picSmiley As System.Windows.Forms.PictureBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


pnlFavoriten Variable

Friend WithEvents pnlFavoriten As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlFavoriten As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


ssort Variable

Dim ssort As Integer

Source code

[Visual Basic]
    Dim ssort As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


todelete Variable

Dim todelete( _
   50 _
) As Integer

Source code

[Visual Basic]
    Dim todelete(50) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl


frmVorlagenauswahl_Serienbriefe Class

For a list of all members of this type, see frmVorlagenauswahl_Serienbriefe Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmVorlagenauswahl_Serienbriefe

Public Class frmVorlagenauswahl_Serienbriefe
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmVorlagenauswahl_Serienbriefe Members


frmVorlagenauswahl_Serienbriefe Members

frmVorlagenauswahl_Serienbriefe overview

Constructors

constructor frmVorlagenauswahl_Serienbriefe Constructor

Properties

property BarcodeID
property Dokumentart
property Dokumentpaket
property Dokumentvorlage
property ProfilNr
property Profile
property Show_Favoriten
property edex_vorlagenauswahl

Methods

method BtnHelp_Click
method Check_Barcode
method ContextMenu1_Popup
method ContextMenu3_Popup
method DelNode
method DeleteNodes
method Dispose
method DocumentAllreadyExists
method DokumentErstellen
method FavoritenStruktur_BeforeSelect
method FavoritenStruktur_DoubleClick
method FavoritenStruktur_Dragdrop_insert
method FavoritenStruktur_ItemDrag
method FavoritenStruktur_KeyDown
method FavoritenStruktur_MouseDown
method Favoritenstruktur_DragDrop
method Favoritenstruktur_DragOver
method Favoritenstruktur_dragenter
method Finalize
method GetDokumentFavoritNr
method Get_Filter
method Get_dtnr_dpnr
method InitializeComponent
method Load_Struktur
method MenuExpand_Click
method MenuItem10_Click
method MenuItem6_Click
method MenuItem8_Click
method MenuItem9_Click
method MenuUnExpand_Click
method MenuUnexpandsel_Click
method MnuAddFavoriten_Click
method MnuDokumenterstellen_Click
method MnuDokumentpaketKopieren_Click
method MnuExpandSel_Click
method MnuFavoritentfernen_Click
method MnuIDVBearbeitung_Click
method MnuMaKopie_Click
method MnuNeuesDokumentpaket_Click
method MnuShowFavoriten_Click
method MoveNode
method RenameNodeFavoritenstruktur
method ResizeForm
method RootNodesFavoritenStrukturExist
method Save_Nodedata
method SearchDokFavoritenNode
method ShowControls
method TVStruktur_AfterSelect
method TVStruktur_ItemDrag
method TVStruktur_KeyDown
method TVStruktur_MouseDown
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TxtSearch_KeyDown
method Update_Menu
method Vorlagenauswahl_Load
method formatForm
method frmVorlagenauswahl_Resize
method mcbfilter_SelectedValueChanged
method mnuDokument_erstellen_Click
method mnuInfoDokumentvorlage_Click
method mnuLoeschen_Click
method mnuNeuerOrdner_Click
method mnuUmbenennen_Click

Fields

field BtnHelp
field ComboBox1
field ContextMenu1
field ContextMenu3
field DataSet1
field FavoritenStruktur
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field ItemMove
field Label1
field MenuExpand
field MenuItem1
field MenuItem10
field MenuItem12
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuUnExpand
field MenuUnexpandsel
field MnuAddFavoriten
field MnuDokumenterstellen
field MnuDokumentpaketKopieren
field MnuExpandSel
field MnuIDVBearbeitung
field MnuMAKopie
field MnuNeuesDokumentpaket
field MnuPaketverwaltung
field MnuShowFavoriten
field On_Load
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVStruktur
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolTip1
field TxtSearch
field components
field itodelete
field m_Dokumentpaket
field m_barcodeid
field m_dokumentart
field m_dokumentvorlage
field m_edex_Vorlagenauswahl
field m_favoriten
field m_iImagesOffestImagelist1
field m_iWindowWidth
field m_profile
field m_profilnr
field mcbfilter
field mnuDokument_erstellen
field mnuInfoDokumentvorlage
field mnuLoeschen
field mnuNeuerOrdner
field mnuUmbenennen
field pnlFavoriten
field selectPoint
field ssort
field todelete

See Also

frmVorlagenauswahl_Serienbriefe Class


frmVorlagenauswahl_Serienbriefe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe Properties

frmVorlagenauswahl_Serienbriefe overview

Properties

property BarcodeID
property Dokumentart
property Dokumentpaket
property Dokumentvorlage
property ProfilNr
property Profile
property Show_Favoriten
property edex_vorlagenauswahl

See Also

frmVorlagenauswahl_Serienbriefe Class


frmVorlagenauswahl_Serienbriefe.BarcodeID Property

Property BarcodeID() As String

Source code

[Visual Basic]
    Property BarcodeID() As String
        Get
            Return m_barcodeid
        End Get
        Set(ByVal Value As String)
            m_barcodeid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Dokumentart Property

Property Dokumentart() As String

Source code

[Visual Basic]
    Property Dokumentart() As String
        Get
            Return m_dokumentart
        End Get
        Set(ByVal Value As String)
            m_dokumentart = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Dokumentpaket Property

Property Dokumentpaket() As Boolean

Source code

[Visual Basic]
    Property Dokumentpaket() As Boolean
        Get
            Return m_Dokumentpaket
        End Get
        Set(ByVal Value As Boolean)
            m_Dokumentpaket = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Dokumentvorlage Property

Property Dokumentvorlage() As Long

Source code

[Visual Basic]
    Property Dokumentvorlage() As Long
        Get
            Return m_dokumentvorlage
        End Get
        Set(ByVal Value As Long)
            m_dokumentvorlage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ProfilNr Property

Property ProfilNr() As Long

Source code

[Visual Basic]
    Property ProfilNr() As Long
        Get
            Return m_profilnr
        End Get
        Set(ByVal Value As Long)
            m_profilnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Profile Property

Property Profile() As DataTable

Source code

[Visual Basic]
    Property Profile() As DataTable
        Get
            Return m_profile
        End Get
        Set(ByVal Value As DataTable)
            m_profile = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Show_Favoriten Property

Property Show_Favoriten() As Boolean

Source code

[Visual Basic]
    Property Show_Favoriten() As Boolean
        Get
            Return m_favoriten
        End Get
        Set(ByVal Value As Boolean)
            m_favoriten = Value
            Me.ToolBar1.Buttons(3).Pushed() = m_favoriten
            Me.ToolBar1.Buttons(2).Pushed() = Not m_favoriten
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.edex_vorlagenauswahl Property

Property edex_vorlagenauswahl() As Boolean

Source code

[Visual Basic]
    Property edex_vorlagenauswahl() As Boolean
        Get
            Return m_edex_Vorlagenauswahl
        End Get
        Set(ByVal Value As Boolean)
            m_edex_Vorlagenauswahl = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe Methods

frmVorlagenauswahl_Serienbriefe overview

Methods

method BtnHelp_Click
method Check_Barcode
method ContextMenu1_Popup
method ContextMenu3_Popup
method DelNode
method DeleteNodes
method Dispose
method DocumentAllreadyExists
method DokumentErstellen
method FavoritenStruktur_BeforeSelect
method FavoritenStruktur_DoubleClick
method FavoritenStruktur_Dragdrop_insert
method FavoritenStruktur_ItemDrag
method FavoritenStruktur_KeyDown
method FavoritenStruktur_MouseDown
method Favoritenstruktur_DragDrop
method Favoritenstruktur_DragOver
method Favoritenstruktur_dragenter
method Finalize
method GetDokumentFavoritNr
method Get_Filter
method Get_dtnr_dpnr
method InitializeComponent
method Load_Struktur
method MenuExpand_Click
method MenuItem10_Click
method MenuItem6_Click
method MenuItem8_Click
method MenuItem9_Click
method MenuUnExpand_Click
method MenuUnexpandsel_Click
method MnuAddFavoriten_Click
method MnuDokumenterstellen_Click
method MnuDokumentpaketKopieren_Click
method MnuExpandSel_Click
method MnuFavoritentfernen_Click
method MnuIDVBearbeitung_Click
method MnuMaKopie_Click
method MnuNeuesDokumentpaket_Click
method MnuShowFavoriten_Click
method MoveNode
method RenameNodeFavoritenstruktur
method ResizeForm
method RootNodesFavoritenStrukturExist
method Save_Nodedata
method SearchDokFavoritenNode
method ShowControls
method TVStruktur_AfterSelect
method TVStruktur_ItemDrag
method TVStruktur_KeyDown
method TVStruktur_MouseDown
method TagArt
method TagValue
method ToolBar1_ButtonClick
method TxtSearch_KeyDown
method Update_Menu
method Vorlagenauswahl_Load
method formatForm
method frmVorlagenauswahl_Resize
method mcbfilter_SelectedValueChanged
method mnuDokument_erstellen_Click
method mnuInfoDokumentvorlage_Click
method mnuLoeschen_Click
method mnuNeuerOrdner_Click
method mnuUmbenennen_Click

See Also

frmVorlagenauswahl_Serienbriefe Class


frmVorlagenauswahl_Serienbriefe.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        If Me.ToolBar1.Buttons(2).Pushed = False Then
            Globals.HTMLHelp.ShowHelpToc("favoriten")
        Else
            Globals.HTMLHelp.ShowHelpToc("vorlagenauswahl")
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Check_Barcode Method

Private Function Check_Barcode() As Boolean

Source code

[Visual Basic]
    Private Function Check_Barcode() As Boolean
        If Me.edex_vorlagenauswahl = True Then
            Return True
            Exit Function

        End If
        Dim dt As New edokadb.clsDokumenttyp()
        dt.cpMainConnectionProvider = conn
        dt.iDokumenttypnr = New SqlInt32(CType(Me.Dokumentvorlage, Int32))
        dt.SelectOne()
        Me.BarcodeID = ""
        Check_Barcode = True
        Dim showbc As Boolean = False
        If dt.bNurnative.Value = True Then
            Globals.EinzelDokument = True
            Return True
        End If
        If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = False Then showbc = True
        'If dt.bDokument_wird_retourniert.Value = True And dt.bDokument_wird_erstellt.Value = True Then
        '    Dim f As New frmbcquestion()
        '    f.ShowDialog()
        '    If f.DialogResult = DialogResult.Abort Then showbc = True
        '    If f.DialogResult = DialogResult.OK Then showbc = False
        '    f.Dispose()
        'End If
        showbc = False
        If showbc Then
            Dim f As New frmBarcodeKleber()
            f.ShowDialog()
            If f.DialogResult = DialogResult.Abort Then
                Check_Barcode = False
            Else
                If f.DialogResult = DialogResult.OK Then
                    Me.BarcodeID = f.BarcodeID
                    Check_Barcode = True
                    Globals.bckdokument = True
                Else
                    Check_Barcode = False
                End If
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" Then
            Me.MenuItem6.Enabled = False
        Else
            Me.MenuItem6.Enabled = True
        End If
        'Dim i As Integer
        'Try
        '    i = TagValue(Me.TVStruktur.SelectedNode.Tag)
        '    Me.MenuItem6.Enabled = False
        '    If DivFnkt.leererstellung(3, i) = True Then Me.MenuItem6.Enabled = True
        'Catch
        '    Me.MenuItem6.Enabled = False
        'End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        Try
            Me.MnuNeuesDokumentpaket.Enabled = False
            Me.MnuDokumentpaketKopieren.Enabled = False
            Me.MnuIDVBearbeitung.Enabled = False
            Me.MnuMAKopie.Enabled = False

            If Me.FavoritenStruktur.SelectedNode.ImageIndex < 60 + Me.DP_Imagepos Then
                Me.MnuPaketverwaltung.Enabled = False
                Exit Sub
            Else
                Me.MnuPaketverwaltung.Enabled = True
            End If

            If Me.FavoritenStruktur.SelectedNode.ImageIndex > 59 + Me.DP_Imagepos Then
                Me.MnuNeuesDokumentpaket.Enabled = True
            End If
            If Me.FavoritenStruktur.SelectedNode.ImageIndex = 61 + Me.DP_Imagepos Then
                Me.MnuIDVBearbeitung.Enabled = True
                Me.MnuMAKopie.Enabled = True
                Me.MnuDokumentpaketKopieren.Enabled = True
            End If
            If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + Me.DP_Imagepos Then
                Me.MnuDokumentpaketKopieren.Enabled = True
            End If
        Catch
            Me.MnuPaketverwaltung.Enabled = False
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.DelNode Method

Private Sub DelNode( _
   ByVal tn As TreeNode _
)

Parameters

tn
Required.

Source code

[Visual Basic]
    Private Sub DelNode(ByVal tn As TreeNode)
        If tn.ImageIndex = 61 + DP_Imagepos Then
            Dim dp As New edokadb.clsEdex_dokumentpaket()
            dp.cpMainConnectionProvider = conn
            dp.iDokumentpaketnr = New SqlInt32(CType(TagValue(tn.Tag), Int32))
            conn.OpenConnection()
            dp.SelectOne()
            dp.bAktiv = New SqlBoolean(CType(False, Boolean))

            dp.Update()
            conn.CloseConnection(True)
            dp.Dispose()
        Else
            Dim df As New edokadb.clsEDEX_Favoriten()
            df.cpMainConnectionProvider = conn
            df.iNreintrag = New SqlInt32(CType(TagValue(tn.Tag), Int32))
            conn.OpenConnection()
            df.Delete()
            conn.CloseConnection(True)
            df.Dispose()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.DeleteNodes Method

Public Sub DeleteNodes( _
   ByVal pn As TreeNode _
)

Parameters

pn
Required.

Source code

[Visual Basic]
    Public Sub DeleteNodes(ByVal pn As TreeNode)
        Dim i As Integer
        Dim tn As TreeNode

        For Each tn In pn.Nodes
            DelNode(tn)
            If tn.GetNodeCount(False) > 0 Then DeleteNodes(tn)
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.DocumentAllreadyExists Method

Private Function DocumentAllreadyExists( _
   ByVal strukturnr As Integer, _
   ByVal doktypnr As Integer _
) As EnumFavoritenDokumentenAktion

Parameters

strukturnr
Required.
doktypnr
Required.

Source code

[Visual Basic]
    Private Function DocumentAllreadyExists(ByVal strukturnr As Integer, ByVal doktypnr As Integer) As EnumFavoritenDokumentenAktion
        '===============================================================================
        'Description : Ermittelt, ob das Dokument berits in der Struktur vorhanden ist
        'Input       : strukturnr = PK des Favoriten
        '              doktypnr = PK des Dokumenttyp
        'Output      : Ausgeführte Aktion Einfuegen oder Ueberschreiben oder NichtUebreschreiben
        'Date        : koe 24.08.2004
        'Modified    :
        '===============================================================================
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        DocumentAllreadyExists = EnumFavoritenDokumentenAktion.Einfuegen     'Dokument wir in die Favoriten eingefuegt
        Try
            scmCmdToExecute.CommandText = "dbo.SP_Favorit_bereits_vorhanden"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@strukturnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, strukturnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@doktypnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, doktypnr))
            sdaAdapter.Fill(dtToReturn)
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
        If dtToReturn.Rows.Count > 0 Then
            If MyMsg.Show_MessageYesNo(23) = MsgBoxResult.Yes Then
                'Die gewählte Dokumentvorlage ist bereits bei den Favoriten eingetragen. Wollen Sie sie erneut übernehmen?
                DocumentAllreadyExists = EnumFavoritenDokumentenAktion.Ueberschreiben 'Dokument wir in die Favoriten Ueberschrieben
            Else
                DocumentAllreadyExists = EnumFavoritenDokumentenAktion.NichtUebreschreiben 'Dokument wir in den Favoriten nicht Ueberschrieben
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.DokumentErstellen Method

Private Sub DokumentErstellen()

Source code

[Visual Basic]
    Private Sub DokumentErstellen()
        Dim iDokumentFavoritenNr As Integer
        If FavoritenStruktur.SelectedNode.ImageIndex <> 1 And FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            If FavoritenStruktur.SelectedNode.ImageIndex = 61 + DP_Imagepos Then
                Me.Dokumentvorlage = TagValue(FavoritenStruktur.SelectedNode.Tag)
                Globals.DokumentPaket = True
                Globals.Individuelles_Dokumentpaket = True
                Globals.bckdokument = False
                Globals.EinzelDokument = False
                Me.DialogResult = DialogResult.OK
                Me.Close()
                Exit Sub
            End If
            If FavoritenStruktur.SelectedNode.ImageIndex = 62 + DP_Imagepos Then
                iDokumentFavoritenNr = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
                Me.Dokumentvorlage = iDokumentFavoritenNr
                Globals.DokumentPaket = True
                Globals.Individuelles_Dokumentpaket = False
                Globals.bckdokument = False
                Globals.EinzelDokument = False
                Me.DialogResult = DialogResult.OK
                Me.Close()
                Exit Sub
            End If
            Me.Dokumentvorlage = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
            Globals.bckdokument = False
            Globals.EinzelDokument = False
            If Check_Barcode() = False Then Exit Sub
            Me.DialogResult = DialogResult.OK
            Me.Close()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_BeforeSelect Method

Private Sub FavoritenStruktur_BeforeSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewCancelEventArgs _
) Handles FavoritenStruktur.BeforeSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_BeforeSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewCancelEventArgs) Handles FavoritenStruktur.BeforeSelect
        Try
            'Me.FavoritenStruktur.SelectedNode.BackColor = System.Drawing.Color.White
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_DoubleClick Method

Private Sub FavoritenStruktur_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles FavoritenStruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles FavoritenStruktur.DoubleClick
        DokumentErstellen()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_Dragdrop_insert Method

Private Sub FavoritenStruktur_Dragdrop_insert( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_Dragdrop_insert(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DragEventArgs)
        Dim pt As Point
        Dim DestinationNode As TreeNode
        Dim Strukturnr As Integer
        Dim tn As TreeNode
        Dim tnnew As TreeNode

        Dim Originalnode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        pt = CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
        DestinationNode = CType(sender, TreeView).GetNodeAt(pt)
        If DestinationNode.ImageIndex <> 1 And DestinationNode.ImageIndex <> 60 + DP_Imagepos Then
            tn = DestinationNode.Parent
            Strukturnr = TagValue(tn.Tag)
        Else
            tn = DestinationNode
            Strukturnr = TagValue(tn.Tag)
        End If

        tnnew = tn.Nodes.Add(Originalnode.Text)
        tnnew.ImageIndex = Originalnode.ImageIndex + DP_Imagepos
        tnnew.SelectedImageIndex = Originalnode.SelectedImageIndex + DP_Imagepos

        Dim ps As New edokadb.clsEDEX_Favoriten()
        ps.cpMainConnectionProvider = conn
        ps.sBezeichnung = New SqlString(CType(Originalnode.Text, String))
        ps.bAktiv = New SqlBoolean(CType(True, Boolean))
        ps.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        ps.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        ps.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        ps.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ps.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        ps.iParentid = New SqlInt32(CType(TagValue(DestinationNode.Tag), Int32))
        ps.iSort = New SqlInt32(CType(tnnew.Index, Int32))
        ps.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        ps.iImageindex = New SqlInt32(CType(Originalnode.ImageIndex, Int32))
        ps.iImageindexopen = New SqlInt32(CType(Originalnode.SelectedImageIndex, Int32))
        If DestinationNode.ImageIndex >= 60 + DP_Imagepos Then
            ps.bDp = New SqlBoolean(CType(True, Boolean))
            ps.iDtnr_dpnr = New SqlInt32(CType(TagValue(Originalnode.Tag), Int32))
        Else
            ps.bDp = New SqlBoolean(CType(False, Boolean))
            ps.iDtnr_dpnr = New SqlInt32(CType(TagValue(Originalnode.Tag), Int32))
        End If
        ps.bStddp = New SqlBoolean(CType(False, Boolean))
        ps.bStrukturelement = New SqlBoolean(CType(False, Boolean))
        conn.OpenConnection()
        Try
            ps.Insert()
            Strukturnr = ps.iNreintrag.Value
            tnnew.Tag = TagArt(tn.Tag) + LTrim(Str(Strukturnr))
            tn.ExpandAll()
        Catch
        Finally
            conn.CloseConnection(True)
            ps.Dispose()
        End Try
        Me.FavoritenStruktur.AllowDrop = False
        e.Effect = DragDropEffects.None
        Originalnode = Nothing
        DestinationNode = Nothing
        e.Effect = DragDropEffects.None
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_ItemDrag Method

Private Sub FavoritenStruktur_ItemDrag( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles FavoritenStruktur.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_ItemDrag(ByVal sender As Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles FavoritenStruktur.ItemDrag
        Me.ItemMove = True
        Me.FavoritenStruktur.AllowDrop = True
        If e.Button = MouseButtons.Left Then
            FavoritenStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_KeyDown Method

Private Sub FavoritenStruktur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles FavoritenStruktur.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles FavoritenStruktur.KeyDown
        If e.Control = True Then
            Select Case e.KeyCode
                Case Keys.N
                    If mnuNeuerOrdner.Enabled Then
                        mnuNeuerOrdner_Click(sender, e)
                    End If
                Case Keys.Up
                    Me.MoveNode(1)
                Case Keys.Down
                    Me.MoveNode(2)
            End Select
        End If

        If e.Control = False And e.Alt = False And e.Shift = False Then
            Select Case e.KeyCode
                Case Keys.Return
                    If Me.FavoritenStruktur.SelectedNode.ImageIndex = 1 Or Me.FavoritenStruktur.SelectedNode.ImageIndex = 60 + DP_Imagepos Then
                        If Me.FavoritenStruktur.SelectedNode.IsExpanded Then
                            Me.FavoritenStruktur.SelectedNode.Collapse()
                        Else
                            Me.FavoritenStruktur.SelectedNode.Expand()
                        End If
                    Else
                        If mnuDokument_erstellen.Enabled Then
                            DokumentErstellen()
                        End If
                    End If
                Case Keys.F2
                    If mnuUmbenennen.Enabled Then
                        mnuUmbenennen_Click(sender, e)
                    End If
                Case Keys.Delete
                    If mnuLoeschen.Enabled Then
                        mnuLoeschen_Click(sender, e)
                    End If
                Case Keys.Up
                    Update_Menu()
                Case Keys.Down
                    Update_Menu()
            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.FavoritenStruktur_MouseDown Method

Private Sub FavoritenStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles FavoritenStruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub FavoritenStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles FavoritenStruktur.MouseDown
        Dim mouseEvents As MouseEventArgs
        mouseEvents = e
        selectPoint.Y = mouseEvents.Y
        selectPoint.X = mouseEvents.X
        Try
            FavoritenStruktur.SelectedNode = FavoritenStruktur.GetNodeAt(selectPoint)
        Catch
        End Try

        Update_Menu()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Favoritenstruktur_DragDrop Method

Private Sub Favoritenstruktur_DragDrop( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles FavoritenStruktur.DragDrop

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Favoritenstruktur_DragDrop(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles FavoritenStruktur.DragDrop
        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
              True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        If Me.ItemMove = False Then
            FavoritenStruktur_Dragdrop_insert(sender, e)
            Exit Sub
        End If

        Dim dropNode As TreeNode = _
              CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
              TreeNode)
        Dim targetNode As TreeNode = selectedTreeview.SelectedNode
        dropNode.Remove()
        If targetNode Is Nothing Then
            selectedTreeview.Nodes.Add(dropNode)
        Else
            targetNode.Nodes.Add(dropNode)
        End If
        dropNode.EnsureVisible()
        selectedTreeview.SelectedNode = dropNode

        Dim tn As TreeNode
        tn = targetNode
        Dim i As Integer
        i = tn.GetNodeCount(True)
        For i = 0 To targetNode.GetNodeCount(True) - 1
            Save_Nodedata(tn.Nodes(i))
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Favoritenstruktur_DragOver Method

Public Sub Favoritenstruktur_DragOver( _
   ByVal sender As System.Object, _
   ByVal e As DragEventArgs _
) Handles FavoritenStruktur.DragOver

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Public Sub Favoritenstruktur_DragOver(ByVal sender As System.Object, ByVal e As DragEventArgs) Handles FavoritenStruktur.DragOver
        If e.Data.GetDataPresent("System.Windows.Forms.TreeNode", _
              True) = False Then Exit Sub
        Dim selectedTreeview As TreeView = CType(sender, TreeView)
        Dim Originalnode As TreeNode = CType(e.Data.GetData("System.Windows.Forms.TreeNode"), TreeNode)
        Dim pt As Point = _
            CType(sender, TreeView).PointToClient(New Point(e.X, e.Y))
        Dim targetNode As TreeNode = selectedTreeview.GetNodeAt(pt)
        If targetNode Is Nothing Then Exit Sub
        selectedTreeview.SelectedNode = targetNode
        If Originalnode.ImageIndex <= 60 And targetNode.ImageIndex <> 1 Then
            e.Effect = DragDropEffects.None
            Exit Sub
        End If
        If Originalnode.ImageIndex >= 60 And targetNode.ImageIndex <> 60 + DP_Imagepos Then
            e.Effect = DragDropEffects.None
            Exit Sub
        End If
        If Not (selectedTreeview.SelectedNode Is targetNode) Then
            selectedTreeview.SelectedNode = targetNode
            Dim dropNode As TreeNode = _
                CType(e.Data.GetData("System.Windows.Forms.TreeNode"), _
                TreeNode)
            Do Until targetNode Is Nothing
                If targetNode Is dropNode Then
                    e.Effect = DragDropEffects.None
                    Exit Sub
                End If
                targetNode = targetNode.Parent
            Loop
        End If
        e.Effect = DragDropEffects.Copy
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Favoritenstruktur_dragenter Method

Private Sub Favoritenstruktur_dragenter( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
) Handles FavoritenStruktur.DragEnter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Favoritenstruktur_dragenter(ByVal sender As Object, ByVal e As System.Windows.Forms.DragEventArgs) Handles FavoritenStruktur.DragEnter
        If (e.Data.GetDataPresent("System.Windows.Forms.TreeNode")) Then
            Me.FavoritenStruktur.AllowDrop = True
            e.Effect = DragDropEffects.Copy
        Else
            e.Effect = DragDropEffects.None
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Finalize Method

Protected Overrides Sub Finalize()

Source code

[Visual Basic]
    Protected Overrides Sub Finalize()
        MyBase.Finalize()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.GetDokumentFavoritNr Method

Private Function GetDokumentFavoritNr( _
   ByVal DokumenttypNr As Integer _
) As Integer

Parameters

DokumenttypNr
Required.

Source code

[Visual Basic]
    Private Function GetDokumentFavoritNr(ByVal DokumenttypNr As Integer) As Integer
        '===============================================================================
        'Description : Aus dem  DokumenttypNr aus der Tabelle dokumentfavoriten
        '              wird die DokumentFavoritNr ermittelt
        'Input       : DokumenttypNr
        'Criteria    : MitarbeiterNr
        'Output      : DokumentfavoritNr
        'Date        : koe 19.08.2004
        'Modified    :
        '===============================================================================
        Dim iDokumentFavoritNr As Integer
        Dim sqlConnection As New SqlConnection()
        Dim Sqlcmd As New SqlCommand()
        sqlConnection = conn.scoDBConnection
        sqlConnection.Open()
        With Sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "sp_get_DokumentFavoritNr"

            .Parameters.Clear()
            .Parameters.Add(New SqlParameter("@MitarbeiterNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, Globals.MitarbeiterNr))
            .Parameters.Add(New SqlParameter("@DokumenttypNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, DokumenttypNr))
            .Parameters.Add(New SqlParameter("@DokumentFavoritNr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, iDokumentFavoritNr))

            .Connection = sqlConnection
            .ExecuteNonQuery()
            iDokumentFavoritNr = New SqlInt32(CType(.Parameters.Item("@DokumentFavoritNr").Value, Integer)).Value
            GetDokumentFavoritNr = iDokumentFavoritNr

        End With
        Sqlcmd.Dispose()
        sqlConnection.Close()
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Get_Filter Method

Private Function Get_Filter() As DataTable

Source code

[Visual Basic]
    Private Function Get_Filter() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.CommandText = "dbo.sp_get_Filter_NeueDokumente"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Get_Filter_NeueDokumente::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Get_dtnr_dpnr Method

Private Function Get_dtnr_dpnr( _
   ByVal nreintrag As Integer _
) As Integer

Parameters

nreintrag
Required.

Source code

[Visual Basic]
    Private Function Get_dtnr_dpnr(ByVal nreintrag As Integer) As Integer
        '===============================================================================
        'Description : Aus dem PrimaryKey dokumentfavoritnr aus der Tabelle dokumentfavoriten
        '              wird die DokumenttypNr ermittelt
        'Input       : DokumentfavoritNr
        'Criteria    : MitarbeiterNr
        'Output      : DokumenttypNr
        'Date        : koe 19.08.2004
        'Modified    :
        '===============================================================================
        Dim iDokumenttypNr As Integer
        Dim sqlConnection As New SqlConnection()
        Dim Sqlcmd As New SqlCommand()
        sqlConnection = conn.scoDBConnection
        '      If sqlConnection.State = ConnectionState.Closed Then
        sqlConnection.Open()
        '     End If
        With Sqlcmd
            .CommandType = CommandType.StoredProcedure
            .CommandText = "dbo.edex_sp_get_dtdp_key"

            .Parameters.Clear()
            .Parameters.Add(New SqlParameter("@nreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Default, nreintrag))
            .Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))

            .Connection = sqlConnection
            .ExecuteNonQuery()
            Sqlcmd.Dispose()
            sqlConnection.Close()
            Return .Parameters.Item("@key").Value
        End With
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmVorlagenauswahl_Serienbriefe))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList2 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.TVStruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuDokumenterstellen = New System.Windows.Forms.MenuItem()
        Me.MenuItem8 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        Me.MnuAddFavoriten = New System.Windows.Forms.MenuItem()
        Me.MnuShowFavoriten = New System.Windows.Forms.MenuItem()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuUnExpand = New System.Windows.Forms.MenuItem()
        Me.MenuExpand = New System.Windows.Forms.MenuItem()
        Me.MenuUnexpandsel = New System.Windows.Forms.MenuItem()
        Me.MnuExpandSel = New System.Windows.Forms.MenuItem()
        Me.MenuItem5 = New System.Windows.Forms.MenuItem()
        Me.MenuItem6 = New System.Windows.Forms.MenuItem()
        Me.MenuItem7 = New System.Windows.Forms.MenuItem()
        Me.ImageList4 = New System.Windows.Forms.ImageList(Me.components)
        Me.ImageList3 = New System.Windows.Forms.ImageList(Me.components)
        Me.TxtSearch = New System.Windows.Forms.TextBox()
        Me.pnlFavoriten = New System.Windows.Forms.Panel()
        Me.FavoritenStruktur = New System.Windows.Forms.TreeView()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.mnuDokument_erstellen = New System.Windows.Forms.MenuItem()
        Me.mnuInfoDokumentvorlage = New System.Windows.Forms.MenuItem()
        Me.MenuItem3 = New System.Windows.Forms.MenuItem()
        Me.MnuPaketverwaltung = New System.Windows.Forms.MenuItem()
        Me.MnuIDVBearbeitung = New System.Windows.Forms.MenuItem()
        Me.MnuNeuesDokumentpaket = New System.Windows.Forms.MenuItem()
        Me.MnuDokumentpaketKopieren = New System.Windows.Forms.MenuItem()
        Me.MnuMAKopie = New System.Windows.Forms.MenuItem()
        Me.mnuLoeschen = New System.Windows.Forms.MenuItem()
        Me.MenuItem12 = New System.Windows.Forms.MenuItem()
        Me.mnuUmbenennen = New System.Windows.Forms.MenuItem()
        Me.mnuNeuerOrdner = New System.Windows.Forms.MenuItem()
        Me.MenuItem4 = New System.Windows.Forms.MenuItem()
        Me.MenuItem9 = New System.Windows.Forms.MenuItem()
        Me.MenuItem10 = New System.Windows.Forms.MenuItem()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet1 = New System.Data.DataSet()
        Me.ComboBox1 = New System.Windows.Forms.ComboBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Splitter2 = New System.Windows.Forms.Splitter()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.ToolTip1 = New System.Windows.Forms.ToolTip(Me.components)
        Me.pnlFavoriten.SuspendLayout()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton5, Me.ToolBarButton4, Me.ToolBarButton6, Me.ToolBarButton3})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList2
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(552, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        Me.ToolBarButton2.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        Me.ToolBarButton2.Visible = False
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 1
        Me.ToolBarButton5.Visible = False
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 2
        Me.ToolBarButton4.ToolTipText = "Favoriten anzeigen"
        Me.ToolBarButton4.Visible = False
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 3
        Me.ToolBarButton6.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 3
        '
        'ImageList2
        '
        Me.ImageList2.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList2.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList2.ImageStream = CType(resources.GetObject("ImageList2.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList2.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'TVStruktur
        '
        Me.TVStruktur.ContextMenu = Me.ContextMenu1
        Me.TVStruktur.Dock = System.Windows.Forms.DockStyle.Left
        Me.TVStruktur.HideSelection = False
        Me.TVStruktur.ImageList = Me.ImageList4
        Me.TVStruktur.Location = New System.Drawing.Point(0, 25)
        Me.TVStruktur.Name = "TVStruktur"
        Me.TVStruktur.Size = New System.Drawing.Size(552, 620)
        Me.TVStruktur.TabIndex = 1
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuDokumenterstellen, Me.MenuItem8, Me.MenuItem2, Me.MnuAddFavoriten, Me.MnuShowFavoriten, Me.MenuItem1, Me.MenuUnExpand, Me.MenuExpand, Me.MenuUnexpandsel, Me.MnuExpandSel, Me.MenuItem5, Me.MenuItem6, Me.MenuItem7})
        '
        'MnuDokumenterstellen
        '
        Me.MnuDokumenterstellen.Index = 0
        Me.MnuDokumenterstellen.Text = "&Dokument erstellen"
        '
        'MenuItem8
        '
        Me.MenuItem8.Index = 1
        Me.MenuItem8.Text = "Informationen zur Dokumentvorlage"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 2
        Me.MenuItem2.Text = "-"
        Me.MenuItem2.Visible = False
        '
        'MnuAddFavoriten
        '
        Me.MnuAddFavoriten.Index = 3
        Me.MnuAddFavoriten.Text = "&Vorlage zu den Favoriten hinzufügen..."
        Me.MnuAddFavoriten.Visible = False
        '
        'MnuShowFavoriten
        '
        Me.MnuShowFavoriten.Index = 4
        Me.MnuShowFavoriten.Text = "&Favoriten anzeigen"
        Me.MnuShowFavoriten.Visible = False
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 5
        Me.MenuItem1.Text = "-"
        '
        'MenuUnExpand
        '
        Me.MenuUnExpand.Index = 6
        Me.MenuUnExpand.Text = "Alle Knoten Schliessen"
        '
        'MenuExpand
        '
        Me.MenuExpand.Index = 7
        Me.MenuExpand.Text = "Alle Knoten öffnen"
        '
        'MenuUnexpandsel
        '
        Me.MenuUnexpandsel.Index = 8
        Me.MenuUnexpandsel.Text = "Selektierter Knoten schliessen"
        '
        'MnuExpandSel
        '
        Me.MnuExpandSel.Index = 9
        Me.MnuExpandSel.Text = "Selektierter Knoten öffnen"
        '
        'MenuItem5
        '
        Me.MenuItem5.Index = 10
        Me.MenuItem5.Text = "-"
        '
        'MenuItem6
        '
        Me.MenuItem6.Index = 11
        Me.MenuItem6.Text = "Dokumentvorschau"
        '
        'MenuItem7
        '
        Me.MenuItem7.Index = 12
        Me.MenuItem7.Text = "-"
        Me.MenuItem7.Visible = False
        '
        'ImageList4
        '
        Me.ImageList4.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList4.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList4.ImageStream = CType(resources.GetObject("ImageList4.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList4.TransparentColor = System.Drawing.Color.Transparent
        '
        'ImageList3
        '
        Me.ImageList3.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList3.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList3.TransparentColor = System.Drawing.Color.Transparent
        '
        'TxtSearch
        '
        Me.TxtSearch.Location = New System.Drawing.Point(56, 4)
        Me.TxtSearch.Name = "TxtSearch"
        Me.TxtSearch.Size = New System.Drawing.Size(248, 20)
        Me.TxtSearch.TabIndex = 2
        Me.TxtSearch.Text = ""
        '
        'pnlFavoriten
        '
        Me.pnlFavoriten.Controls.AddRange(New System.Windows.Forms.Control() {Me.FavoritenStruktur})
        Me.pnlFavoriten.Dock = System.Windows.Forms.DockStyle.Fill
        Me.pnlFavoriten.Location = New System.Drawing.Point(557, 25)
        Me.pnlFavoriten.Name = "pnlFavoriten"
        Me.pnlFavoriten.Size = New System.Drawing.Size(0, 620)
        Me.pnlFavoriten.TabIndex = 3
        Me.pnlFavoriten.Visible = False
        '
        'FavoritenStruktur
        '
        Me.FavoritenStruktur.AllowDrop = True
        Me.FavoritenStruktur.ContextMenu = Me.ContextMenu3
        Me.FavoritenStruktur.Dock = System.Windows.Forms.DockStyle.Fill
        Me.FavoritenStruktur.FullRowSelect = True
        Me.FavoritenStruktur.HideSelection = False
        Me.FavoritenStruktur.ImageList = Me.ImageList1
        Me.FavoritenStruktur.Name = "FavoritenStruktur"
        Me.FavoritenStruktur.Size = New System.Drawing.Size(0, 620)
        Me.FavoritenStruktur.TabIndex = 0
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDokument_erstellen, Me.mnuInfoDokumentvorlage, Me.MenuItem3, Me.MnuPaketverwaltung, Me.mnuLoeschen, Me.MenuItem12, Me.mnuUmbenennen, Me.mnuNeuerOrdner, Me.MenuItem4, Me.MenuItem9, Me.MenuItem10})
        '
        'mnuDokument_erstellen
        '
        Me.mnuDokument_erstellen.Index = 0
        Me.mnuDokument_erstellen.Text = "&Dokument erstellen"
        '
        'mnuInfoDokumentvorlage
        '
        Me.mnuInfoDokumentvorlage.Index = 1
        Me.mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
        '
        'MenuItem3
        '
        Me.MenuItem3.Index = 2
        Me.MenuItem3.Text = "-"
        '
        'MnuPaketverwaltung
        '
        Me.MnuPaketverwaltung.Index = 3
        Me.MnuPaketverwaltung.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuIDVBearbeitung, Me.MnuNeuesDokumentpaket, Me.MnuDokumentpaketKopieren, Me.MnuMAKopie})
        Me.MnuPaketverwaltung.Text = "Dokumentpaket-Verwaltung"
        '
        'MnuIDVBearbeitung
        '
        Me.MnuIDVBearbeitung.Index = 0
        Me.MnuIDVBearbeitung.Text = "&Dokumentpaket bearbeiten"
        '
        'MnuNeuesDokumentpaket
        '
        Me.MnuNeuesDokumentpaket.Index = 1
        Me.MnuNeuesDokumentpaket.Text = "&Neues Dokumentpaket erstellen"
        '
        'MnuDokumentpaketKopieren
        '
        Me.MnuDokumentpaketKopieren.Index = 2
        Me.MnuDokumentpaketKopieren.Text = "Dokumentpaket &kopieren"
        '
        'MnuMAKopie
        '
        Me.MnuMAKopie.Index = 3
        Me.MnuMAKopie.Text = "Dokument für ... kopieren"
        '
        'mnuLoeschen
        '
        Me.mnuLoeschen.Index = 4
        Me.mnuLoeschen.Shortcut = System.Windows.Forms.Shortcut.Del
        Me.mnuLoeschen.Text = "&Löschen"
        '
        'MenuItem12
        '
        Me.MenuItem12.Index = 5
        Me.MenuItem12.Text = "-"
        '
        'mnuUmbenennen
        '
        Me.mnuUmbenennen.Index = 6
        Me.mnuUmbenennen.Shortcut = System.Windows.Forms.Shortcut.F2
        Me.mnuUmbenennen.Text = "&Umbenennen"
        '
        'mnuNeuerOrdner
        '
        Me.mnuNeuerOrdner.Index = 7
        Me.mnuNeuerOrdner.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.mnuNeuerOrdner.Text = "Neuer Ordner"
        '
        'MenuItem4
        '
        Me.MenuItem4.Index = 8
        Me.MenuItem4.Text = "-"
        '
        'MenuItem9
        '
        Me.MenuItem9.Index = 9
        Me.MenuItem9.Text = "&Aufwärts"
        '
        'MenuItem10
        '
        Me.MenuItem10.Index = 10
        Me.MenuItem10.Text = "A&bwärts"
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "sp_dokumentfavoriten_select", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("dokumenttypnr", "dokumenttypnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[NewDeleteCommand]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[NewInsertCommand]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[sp_dokumentfavoriten_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@dokumentfavoritenstruktur", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[NewUpdateCommand]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 50, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionsgruppenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 50))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8))
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'ComboBox1
        '
        Me.ComboBox1.Location = New System.Drawing.Point(344, 3)
        Me.ComboBox1.Name = "ComboBox1"
        Me.ComboBox1.Size = New System.Drawing.Size(176, 21)
        Me.ComboBox1.TabIndex = 4
        Me.ComboBox1.Text = "ComboBox1"
        Me.ComboBox1.Visible = False
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(312, 6)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(100, 16)
        Me.Label1.TabIndex = 5
        Me.Label1.Text = "Filter:"
        Me.Label1.Visible = False
        '
        'Splitter2
        '
        Me.Splitter2.Location = New System.Drawing.Point(552, 25)
        Me.Splitter2.Name = "Splitter2"
        Me.Splitter2.Size = New System.Drawing.Size(5, 620)
        Me.Splitter2.TabIndex = 6
        Me.Splitter2.TabStop = False
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(528, 2)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 36
        '
        'frmVorlagenauswahl_Serienbriefe
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(552, 645)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.pnlFavoriten, Me.Splitter2, Me.ComboBox1, Me.Label1, Me.TxtSearch, Me.TVStruktur, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmVorlagenauswahl_Serienbriefe"
        Me.ShowInTaskbar = False
        Me.Text = "Vorlagenauswahl"
        Me.pnlFavoriten.ResumeLayout(False)
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Load_Struktur Method

Private Sub Load_Struktur( _
   ByVal Searchstring As String, _
   ByVal favoriten As Boolean _
)

Parameters

Searchstring
Required.
favoriten
Required.

Source code

[Visual Basic]
    Private Sub Load_Struktur(ByVal Searchstring As String, ByVal favoriten As Boolean)
        Try
            Me.Cursor = Cursors.WaitCursor
            Dim dokart As New edokadb.clsMyDokumentart()
            If favoriten Then
                Me.FavoritenStruktur.BeginUpdate()
                Me.FavoritenStruktur.Nodes.Clear()
                dokart.Load_FavoritenStruktur(Me.FavoritenStruktur, Searchstring, True, m_iImagesOffestImagelist1)
                If Searchstring = "" Then
                    If RootNodesFavoritenStrukturExist() = False Then
                        dokart.Load_FavoritenStruktur(Me.FavoritenStruktur, Searchstring, True, m_iImagesOffestImagelist1)
                    End If
                End If
                'Rel 3.3
                '09.11.2004 / BUD

                Me.FavoritenStruktur.Nodes.Item(0).Expand()
                Me.FavoritenStruktur.Nodes.Item(1).Expand()
                'Me.FavoritenStruktur.ExpandAll()

                Me.FavoritenStruktur.EndUpdate()
                If Me.FavoritenStruktur.Nodes.Count > 0 Then
                    Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
                End If
                Me.FavoritenStruktur.Refresh()
                Me.FavoritenStruktur.SelectedNode.Checked = True
            Else
                'Me.pnlFavoriten.Visible = False
                Me.TVStruktur.BeginUpdate()
                dokart.Load_Neue_Dokumente(Me.TVStruktur, Searchstring, False, 9)
                Me.TVStruktur.ExpandAll()
                TVStruktur.EndUpdate()
                If Me.TVStruktur.Nodes.Count > 0 Then
                    Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    TVStruktur.Refresh()
                    TVStruktur.SelectedNode.Checked = True
                End If
            End If

            dokart.Dispose()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try

        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuExpand_Click Method

Private Sub MenuExpand_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuExpand.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuExpand_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuExpand.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.ExpandAll()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuItem10_Click Method

Private Sub MenuItem10_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem10.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem10_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem10.Click
        MoveNode(2)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuItem6_Click Method

Private Sub MenuItem6_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem6.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem6_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem6.Click
        Dim i As Integer
        Dim printable As Boolean = False
        i = TagValue(Me.TVStruktur.SelectedNode.Tag)
        If DivFnkt.leererstellung(3, i) = True Then printable = True Else printable = False
        DivFnkt.show_officevorlage(i, Me, printable)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuItem8_Click Method

Private Sub MenuItem8_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem8.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem8_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem8.Click
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" And TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DP_" Then
            Exit Sub
        End If

        If Me.TVStruktur.SelectedNode.ImageIndex = 62 Then
            Dim f As New frmDokumentpaketInfo()
            Try
                f.Key = TagValue(Me.TVStruktur.SelectedNode.Tag)
                f.Titel = Me.TVStruktur.SelectedNode.Text
                f.ShowDialog()
                f.Dispose()
                Exit Sub
            Catch
            Finally
                f.Dispose()
            End Try
        Else
            Dim f As New frmDokumenttypInfo()
            Try
                f.Key = TagValue(TVStruktur.SelectedNode.Tag)
                f.Text = f.Text + Me.TVStruktur.SelectedNode.Text
                f.ShowDialog()
            Catch
            Finally
                f.dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuItem9_Click Method

Private Sub MenuItem9_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem9.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem9_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem9.Click
        MoveNode(1)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuUnExpand_Click Method

Private Sub MenuUnExpand_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuUnExpand.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuUnExpand_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuUnExpand.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.CollapseAll()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MenuUnexpandsel_Click Method

Private Sub MenuUnexpandsel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuUnexpandsel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuUnexpandsel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuUnexpandsel.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.SelectedNode.Collapse()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuAddFavoriten_Click Method

Private Sub MnuAddFavoriten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuAddFavoriten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuAddFavoriten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuAddFavoriten.Click
        Dim f As New frmFavoritenZuordnung()
        f.Dokumenttypnr = TagValue(Me.TVStruktur.SelectedNode.Tag)
        f.TextBox1.Text = Me.TVStruktur.SelectedNode.Text
        f.ShowDialog()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuDokumenterstellen_Click Method

Private Sub MnuDokumenterstellen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumenterstellen.Click, _
   TVStruktur.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumenterstellen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumenterstellen.Click, TVStruktur.DoubleClick
        If TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DT_" And TagArt(Me.TVStruktur.SelectedNode.Tag) <> "DP_" Then
            Exit Sub
        End If
        If Me.TVStruktur.SelectedNode.ImageIndex = 62 Then
            Me.Dokumentvorlage = TagValue(Me.TVStruktur.SelectedNode.Tag)
            Globals.bckdokument = False
            Globals.EinzelDokument = False
            Globals.DokumentPaket = True
            Globals.Individuelles_Dokumentpaket = False
            Me.DialogResult = DialogResult.OK
            Me.Close()
            Exit Sub
        End If
        Me.Dokumentvorlage = Me.TagValue(Me.TVStruktur.SelectedNode.Tag)
        Globals.bckdokument = False
        Globals.EinzelDokument = False
        If Check_Barcode() = False Then Exit Sub
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuDokumentpaketKopieren_Click Method

Private Sub MnuDokumentpaketKopieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuDokumentpaketKopieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuDokumentpaketKopieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuDokumentpaketKopieren.Click
        Dim f As frmDokumentpaketdefinition
        If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + Me.DP_Imagepos Then
            f = New frmDokumentpaketdefinition(False, Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag)), True)
        Else
            f = New frmDokumentpaketdefinition(False, TagValue(Me.FavoritenStruktur.SelectedNode.Tag), True)
        End If
        f.Kopie = True
        f.ShowDialog()
        f.Dispose()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuExpandSel_Click Method

Private Sub MnuExpandSel_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuExpandSel.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuExpandSel_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuExpandSel.Click
        Try
            Me.TVStruktur.Visible = False
            Me.TVStruktur.SelectedNode.Expand()
        Catch
        End Try
        Me.TVStruktur.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuFavoritentfernen_Click Method

Private Sub MnuFavoritentfernen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuFavoritentfernen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Dim df As New edokadb.clsDokumentfavoriten()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim key As Long
        dbkey.cpMainConnectionProvider = conn
        df.iDokumenttypnr = New SqlInt32(CType(TagValue(Me.TVStruktur.SelectedNode.Tag), Int32))
        df.bAktiv = New SqlBoolean(CType(False, Boolean))
        df.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        df.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        df.Update()
        conn.CloseConnection(True)
        df.Dispose()
        dbkey.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuIDVBearbeitung_Click Method

Private Sub MnuIDVBearbeitung_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuIDVBearbeitung.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuIDVBearbeitung_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuIDVBearbeitung.Click
        Dim f As New frmDokumentpaketdefinition(False, Me.TagValue(Me.FavoritenStruktur.SelectedNode.Tag), True)
        f.ShowDialog()
        f.Dispose()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuMaKopie_Click Method

Private Sub MnuMaKopie_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuMAKopie.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuMaKopie_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuMAKopie.Click
        Dim ma As New frmMitarbeiterSelektion()
        Dim i As Integer
        i = ma.ShowDialog()
        If Not i = DialogResult.OK Then
            Exit Sub
        End If
        i = ma.Mitarbeiternr
        ma.Dispose()
        Dim f As frmDokumentpaketdefinition
        f = New frmDokumentpaketdefinition(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), i)
        f.Show()
        f.Dispose()
        MyMsg.show_standardmessage(415, MsgBoxStyle.Information)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuNeuesDokumentpaket_Click Method

Private Sub MnuNeuesDokumentpaket_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuNeuesDokumentpaket.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuNeuesDokumentpaket_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuNeuesDokumentpaket.Click
        Dim f As New frmDokumentpaketdefinition(True, 0, True)
        f.ShowDialog()
        Me.FavoritenStruktur.Nodes.Clear()
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MnuShowFavoriten_Click Method

Private Sub MnuShowFavoriten_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MnuShowFavoriten.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MnuShowFavoriten_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MnuShowFavoriten.Click
        Me.pnlFavoriten.Visible = True
        Load_Struktur("", True)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.MoveNode Method

Private Sub MoveNode( _
   ByVal direction As Integer _
)

Parameters

direction
Required.

Source code

[Visual Basic]
    Private Sub MoveNode(ByVal direction As Integer)
        Dim tn As TreeNode
        Dim tnp As TreeNode
        Dim index As Integer
        tn = Me.FavoritenStruktur.SelectedNode
        If tn.Parent Is Nothing Then Exit Sub
        tnp = tn.Parent
        'If tnp.ImageIndex = 1 Or tnp.ImageIndex = 60 + DP_Imagepos Then Exit Sub

        If tnp.GetNodeCount(True) < 1 Then
            Exit Sub
        End If

        If direction = 1 And tn.Index > 0 Then
            index = tn.Index - 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If
        If direction = 2 And tn.Index < tnp.GetNodeCount(True) Then
            index = tn.Index + 1
            tn.Remove()
            tnp.Nodes.Insert(index, tn)
        End If

        Dim i As Integer
        For i = 0 To tnp.GetNodeCount(False) - 1
            Me.Save_Nodedata(tnp.Nodes(i))
        Next

        DivFnkt.Searchnode(FavoritenStruktur, tn.Tag, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.RenameNodeFavoritenstruktur Method

Private Sub RenameNodeFavoritenstruktur( _
   ByVal dokumentfavoritennr As Integer, _
   ByVal NodeText As String _
)

Parameters

dokumentfavoritennr
Required.
NodeText
Required.

Source code

[Visual Basic]
    Private Sub RenameNodeFavoritenstruktur(ByVal dokumentfavoritennr As Integer, ByVal NodeText As String)
        If dokumentfavoritennr <> 0 Then
            Dim df As New edokadb.clsEDEX_Favoriten()
            df.cpMainConnectionProvider = conn
            conn.OpenConnection()
            df.iNreintrag = New SqlInt32(CType(dokumentfavoritennr, Int32))
            df.SelectOne()
            df.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            df.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            df.sBezeichnung = New SqlString(CType(NodeText, String))
            df.bAktiv = New SqlBoolean(CType(True, Boolean))
            df.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
            df.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            df.Update()
            conn.CloseConnection(True)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ResizeForm Method

Private Sub ResizeForm()

Source code

[Visual Basic]
    Private Sub ResizeForm()
        formatForm()
        '        If FavoritenStruktur.Visible And TVStruktur.Visible Then
        '        'TVStruktur.Width = Me.ClientSize.Width / 2
        '        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.RootNodesFavoritenStrukturExist Method

Private Function RootNodesFavoritenStrukturExist( _
   Optional ByVal RootNodetext As String = "Favoriten" _
) As Boolean

Parameters

RootNodetext
Optional. Default value is "Favoriten".

Source code

[Visual Basic]
    Private Function RootNodesFavoritenStrukturExist(Optional ByVal RootNodetext As String = "Favoriten") As Boolean
        RootNodesFavoritenStrukturExist = True
        If FavoritenStruktur.Nodes.Count < 1 Then
            Dim dfs As New edokadb.clsDokumentfavoriten_struktur()
            RootNodesFavoritenStrukturExist = False
            dfs.cpMainConnectionProvider = conn
            conn.OpenConnection()
            dfs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            dfs.sBezeichnung = New SqlString(CType(RootNodetext, String))
            dfs.iParentid = New SqlInt32(CType(0, Int32))
            dfs.iSort = New SqlInt32(CType(0, Int32))
            dfs.iImageindex = New SqlInt32(CType(1, Int32))
            dfs.iImageindexopen = New SqlInt32(CType(1, Int32))
            dfs.sBeschreibung = New SqlString(CType("Root Knoten", String))
            dfs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            dfs.iSprache = New SqlInt32(CType(1, Int32))
            dfs.bAktiv = New SqlBoolean(CType(True, Boolean))
            dfs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            dfs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            dfs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            dfs.Insert()
            conn.CloseConnection(True)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Save_Nodedata Method

Private Sub Save_Nodedata( _
   ByVal tn As TreeNode _
)

Parameters

tn
Required.

Source code

[Visual Basic]
    Private Sub Save_Nodedata(ByVal tn As TreeNode)
        Dim keyvalue As Integer
        Dim wert As Integer
        Dim indexnr As Integer
        Dim idp As Integer
        If tn.ImageIndex = 61 + DP_Imagepos Then
            idp = 1
            keyvalue = TagValue(tn.Tag)
        Else
            keyvalue = TagValue(tn.Tag)
            idp = 0
        End If

        indexnr = tn.Index
        wert = TagValue(tn.Parent.Tag)

        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "edex_sp_dokumentpaketstruktur_update"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Parameters.Add(New SqlParameter("@key", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, keyvalue))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@indexnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexnr))
        scmCmdToExecute.Parameters.Add(New SqlParameter("@idp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, idp))
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            conn.OpenConnection()
            scmCmdToExecute.ExecuteNonQuery()
        Catch ex As Exception
            Throw New Exception("Dokumentpaket::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            conn.CloseConnection(True)
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.SearchDokFavoritenNode Method

Private Sub SearchDokFavoritenNode( _
   ByRef TV As TreeView, _
   ByVal tn As TreeNode, _
   ByRef Tag As String _
)

Parameters

TV
Required.
tn
Required.
Tag
Required.

Source code

[Visual Basic]
    Private Sub SearchDokFavoritenNode(ByRef TV As TreeView, ByVal tn As TreeNode, ByRef Tag As String)
        If tn.Tag <> Tag Then
            If tn.FirstNode Is Nothing Then
                'Keine Childknoten gefunden
                If Not tn.NextNode Is Nothing Then
                    'Knoten auf gleicher Ebene
                    SearchDokFavoritenNode(TV, tn.NextNode, Tag)
                End If
            Else
                'Childkonoten vorhanden
                SearchDokFavoritenNode(TV, tn.FirstNode, Tag)
                If Not tn.NextNode Is Nothing Then
                    'Knoten auf gleicher Ebene
                    SearchDokFavoritenNode(TV, tn.NextNode, Tag)
                End If
            End If
        Else
            TV.SelectedNode = tn
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ShowControls Method

Private Sub ShowControls()

Source code

[Visual Basic]
    Private Sub ShowControls()
        '===============================================================================
        'Dokumentvorlage
        '===============================================================================
        Me.TVStruktur.Visible = Me.ToolBar1.Buttons(2).Pushed

        'Me.Label1.Visible = Me.TVStruktur.Visible
        'Me.mcbfilter.Visible = Me.TVStruktur.Visible
        'Me.ComboBox1.Visible = Me.TVStruktur.Visible
        ToolBar1.Buttons(5).Visible = Me.TVStruktur.Visible     'Button suchen
        Me.TxtSearch.Visible = Me.TVStruktur.Visible
        '===============================================================================
        'Favoriten Ordnerstruktur
        '===============================================================================
        Me.pnlFavoriten.Visible = Me.ToolBar1.Buttons(3).Pushed

        '===============================================================================
        'Anordnen der Controls
        '===============================================================================

        '  Me.FavoritenStruktur.AllowDrop = False

        If Me.TVStruktur.Visible Then
            If Me.pnlFavoriten.Visible Then
                Me.TVStruktur.Dock = DockStyle.Left
                'Me.TVStruktur.BringToFront()

                Me.Splitter2.Visible = True
                Me.Splitter2.Dock = DockStyle.Left
                'Me.Splitter2.BringToFront()

                Me.FavoritenStruktur.AllowDrop = True
                Me.pnlFavoriten.Dock = DockStyle.Fill
                'Me.pnlFavoriten.BringToFront()

            Else
                Me.Splitter2.Visible = False
                Me.TVStruktur.Dock = DockStyle.Fill
                'Me.TVStruktur.BringToFront()
            End If
        Else
            If Me.pnlFavoriten.Visible Then
                Me.Splitter2.Visible = False
                Me.pnlFavoriten.Dock = DockStyle.Fill
                'Me.pnlFavoriten.BringToFront()
            Else
            End If
        End If

        'If Me.pnlFavoriten.Visible And Me.TVStruktur.Visible Then
        'Me.Width = Globals.EDOKAMAIN_WindowWidth / 4 * 3
        'Else
        'Me.Width = Globals.EDOKAMAIN_WindowWidth / 5 * 2
        'End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TVStruktur_AfterSelect Method

Private Sub TVStruktur_AfterSelect( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.TreeViewEventArgs _
) Handles TVStruktur.AfterSelect

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_AfterSelect(ByVal sender As Object, ByVal e As System.Windows.Forms.TreeViewEventArgs) Handles TVStruktur.AfterSelect
        Me.Dokumentpaket = False
        If TVStruktur.SelectedNode.ImageIndex = 68 Then Me.Dokumentpaket = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TVStruktur_ItemDrag Method

Private Sub TVStruktur_ItemDrag( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ItemDragEventArgs _
) Handles TVStruktur.ItemDrag

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_ItemDrag(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ItemDragEventArgs) Handles TVStruktur.ItemDrag
        Me.ItemMove = False
        If e.Button = MouseButtons.Left Then
            Select Case TagArt(TVStruktur.SelectedNode.Tag)
                Case "DT_"      'nur Dokumente word,Barcode,Word mit Barcode... (keine Stukturknoten)
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case "DP_"
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.Copy)
                Case Else
                    TVStruktur.DoDragDrop(e.Item, DragDropEffects.None)

            End Select
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TVStruktur_KeyDown Method

Private Sub TVStruktur_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TVStruktur.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TVStruktur.KeyDown
        If e.KeyCode = Keys.Return Then Me.MnuDokumenterstellen_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TVStruktur_MouseDown Method

Private Sub TVStruktur_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles TVStruktur.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TVStruktur_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles TVStruktur.MouseDown
        Try
            Dim mouseEvents As MouseEventArgs
            mouseEvents = e
            selectPoint.Y = mouseEvents.Y
            selectPoint.X = mouseEvents.X
            Me.FavoritenStruktur.AllowDrop = True

            Try
                TVStruktur.SelectedNode = TVStruktur.GetNodeAt(selectPoint)
            Catch
            End Try
            If TVStruktur.SelectedNode.ImageIndex < 60 Then
                Me.MnuDokumenterstellen.Text = "Dokument erstellen"
                Me.MenuItem8.Text = "Informationen zur Dokumentvoralge"
            Else
                Me.MnuDokumenterstellen.Text = "Dokumentpaket auswählen"
                Me.MenuItem8.Text = "Informationen zum Dokumentpaket"
            End If

            If Me.TVStruktur.SelectedNode.GetNodeCount(False) < 1 Then
                Me.MnuDokumenterstellen.Enabled = True
                Me.MenuItem8.Enabled = True
            Else
                Me.MnuDokumenterstellen.Enabled = False
                Me.MenuItem8.Enabled = False
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TagArt Method

Private Function TagArt( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagArt(ByVal tag As String) As String
        Dim Art As String
        Art = tag
        Return Art.Substring(0, 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TagValue Method

Private Function TagValue( _
   ByVal tag As String _
) As String

Parameters

tag
Required.

Source code

[Visual Basic]
    Private Function TagValue(ByVal tag As String) As String
        Dim Keyvalue As String
        Keyvalue = tag
        Return Keyvalue.Substring(3, Len(Keyvalue) - 3)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Dim bFavoritenVissible As Boolean
        Dim bDokStruckturVissible As Boolean

        Try
            Select Case ToolBar1.Buttons.IndexOf(e.Button)
                Case 0 ' Close
                    Me.Close()
                Case 3  'Ordner Struktur
                    If Me.ToolBar1.Buttons(3).Pushed Then
                        bFavoritenVissible = True
                    Else
                        bFavoritenVissible = False
                    End If
                    Me.ToolBar1.Buttons(3).Pushed = Not Me.ToolBar1.Buttons(3).Pushed 'Favoriten
                    ShowControls()
                    If bFavoritenVissible = False Then
                        Load_Struktur("", True)
                    End If
                    If Me.FavoritenStruktur.Nodes.Count > 0 Then
                        Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
                    End If
                    ResizeForm()
                Case 2 'Dokumentstruktur
                    If Me.ToolBar1.Buttons(2).Pushed Then
                        bDokStruckturVissible = True
                    Else
                        bDokStruckturVissible = False
                    End If
                    Me.ToolBar1.Buttons(2).Pushed = Not Me.ToolBar1.Buttons(2).Pushed 'Dokumentvorlagen
                    ShowControls()
                    Me.TxtSearch.Select()
                    If bDokStruckturVissible = False Then
                        Load_Struktur("", False)
                    End If
                    Me.TVStruktur.ContextMenu = Me.ContextMenu1
                    If Me.TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If
                    ResizeForm()
                Case 5
                    Load_Struktur(Me.TxtSearch.Text, False)
                    Me.TVStruktur.ContextMenu = Me.ContextMenu1
                    If Me.TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If
                Case Else
            End Select
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.TxtSearch_KeyDown Method

Private Sub TxtSearch_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles TxtSearch.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TxtSearch_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles TxtSearch.KeyDown
        If e.KeyCode = Keys.Enter Then
            'Me.pnlFavoriten.Visible = False
            Load_Struktur(Me.TxtSearch.Text, False)
            Try
                Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Update_Menu Method

Private Sub Update_Menu()

Source code

[Visual Basic]
    Private Sub Update_Menu()
        If Not FavoritenStruktur.SelectedNode Is Nothing Then
            Select Case FavoritenStruktur.SelectedNode.ImageIndex
                Case 1      'Folder
                    mnuUmbenennen.Enabled = True            'Umbenennen eines Ordners
                    mnuNeuerOrdner.Enabled = True               'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
                Case (60 + DP_Imagepos)      'Dokumentpaketfolder
                    mnuUmbenennen.Enabled = True            'Umbenennen eines Ordners
                    mnuNeuerOrdner.Enabled = True               'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokumentpaket erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zum Dokumentpaket"
                Case Is > 60
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = True       'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = True        'Erstellen eines Dokument
                    mnuDokument_erstellen.Enabled = True       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokumentpaket auswählen"
                    mnuInfoDokumentvorlage.Text = "Informationen zum Dokumentpaket"
                Case Is > 1 'Dokumente
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = True                  'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = True       'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = True        'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
                Case Else
                    mnuUmbenennen.Enabled = False               'Umbenennen eines Ordeners
                    mnuNeuerOrdner.Enabled = False              'Erstellen eines Ordners
                    mnuLoeschen.Enabled = False                 'löschen eines Ordner oder Dokument
                    mnuInfoDokumentvorlage.Enabled = False      'Info zu Dokvorlage
                    mnuDokument_erstellen.Enabled = False       'Erstellen eines Dokument
                    mnuDokument_erstellen.Text = "Dokument erstellen"
                    mnuInfoDokumentvorlage.Text = "Informationen zur Dokumentvorlage"
            End Select
        Else
            mnuUmbenennen.Enabled = False                       'Umbenennen eines Ordeners
            mnuNeuerOrdner.Enabled = False                      'Erstellen eines Ordners
            mnuLoeschen.Enabled = False                         'löschen eines Ordner oder Dokument
            mnuInfoDokumentvorlage.Enabled = False              'Info zu Dokvorlage
            mnuDokument_erstellen.Enabled = False               'Erstellen eines Dokument

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.Vorlagenauswahl_Load Method

Private Sub Vorlagenauswahl_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Vorlagenauswahl_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        'Me.TVStruktur.ImageList = Globals.DokumentartenImages
        'Filter
        On_Load = True
        '===============================================================================
        'Image von der Dokstruktur in die Imagelist Hinzufügen
        '===============================================================================
        m_iImagesOffestImagelist1 = ImageList1.Images.Count
        Dim iCount As Integer
        For iCount = 0 To TVStruktur.ImageList.Images.Count - 1
            ImageList1.Images.Add(TVStruktur.ImageList.Images.Item(iCount).Clone)
        Next

        mcbfilter = New MultiComboBox(Me.ComboBox1)
        Me.mcbfilter.BeginUpdate()
        Me.mcbfilter.DisplayColumnName = "Bezeichnung"
        Me.mcbfilter.ValueColumnName = "Type"
        mcbfilter.Fill_Data(Get_Filter, False)
        Me.mcbfilter.NullValueMessage = MyMsg.Get_Meldungstext(18)
        Me.mcbfilter.CheckNullValue = True
        Me.mcbfilter.BringToFront()
        '        Me.Label1.Visible = True
        '       Me.mcbfilter.Visible = True
        Me.ComboBox1.Visible = True
        On_Load = False

        Me.Dokumentvorlage = 0
        Me.Cursor = Cursors.WaitCursor
        ShowControls()          'anzeigen der Controls auf dem Form

        If Me.ToolBar1.Buttons(3).Pushed = True Then        'OrdnerStruktur Favoriten
            Me.FavoritenStruktur.Select()
            Me.FavoritenStruktur.HideSelection = False
            Load_Struktur("", True)
            Try
                Me.FavoritenStruktur.SelectedNode = Me.FavoritenStruktur.Nodes(0)
            Catch
            End Try
        End If
        If Me.ToolBar1.Buttons(2).Pushed = True Then
            If Me.Dokumentart <> "" Then
                Me.mcbfilter.SelectedValue = 0
                Globals.Vorlagenfilter = 0
            End If
            Load_Struktur("", False)

            Me.TVStruktur.ContextMenu = Me.ContextMenu1
            If Me.Dokumentart <> "" Then
                DivFnkt.Searchnode1(Me.TVStruktur, "DA_" + Me.Dokumentart, 0)
                Me.Dokumentart = ""
                If DivFnkt.found Then
                    Me.TVStruktur.CollapseAll()
                    Me.TVStruktur.SelectedNode = DivFnkt.FoundNode
                    Me.TVStruktur.SelectedNode.ExpandAll()
                    Me.TVStruktur.SelectedNode = DivFnkt.FoundNode
                    If TVStruktur.Nodes.Count > 0 Then
                        Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
                    End If

                End If
            End If
        End If
        formatForm()
        Try
            Me.TxtSearch.Select()
        Catch
        End Try

        On_Load = True
        Me.mcbfilter.SelectedValue = Globals.Vorlagenfilter
        If Globals.Vorlagenfilter <> 0 Then
            Load_Struktur(Me.TxtSearch.Text, False)
            If Me.TVStruktur.Nodes.Count > 0 Then
                Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
            End If
        End If
        Me.mcbfilter.EndUpdate()
        On_Load = False

        '        Dim ttip As New ToolTip()
        Dim s As String = "- CTRL+N: Neuer Ordner erstellen" + vbCrLf + _
                          "- CTRL+UP: Aktueller Eintrag nach oben verschieben" + vbCrLf + _
                          "- CTRL+Down: Aktueller Eintrag nach untern verschieben" + vbCrLf + _
                          "- Enter: Ordner önnen/Schliessen bzw. Dokument/Dokumentpaket erstellen" + vbCrLf + _
                          "- Del: Eintrag löschen" + vbCrLf + _
                          "- Up: Selektion nach oben verschieben" + vbCrLf + _
                          "- Down: Selektion nach unten Vershcieben"

        '       ttip.SetToolTip(FavoritenStruktur, s)
        '      Dim td As New clsBalloon()
        '     td.CustomBalloon(ttip)
        Me.Cursor = Cursors.Default

        'Hutter 2005-02-01 EDEX
        If Me.edex_vorlagenauswahl Then
            Me.ToolBarButton4.Enabled = False
            DivFnkt.Searchnode(Me.TVStruktur, "DP_0", 0)
            If DivFnkt.found Then
                DivFnkt.FoundNode.Remove()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.formatForm Method

Private Sub formatForm()

Source code

[Visual Basic]
    Private Sub formatForm()
        If Me.TVStruktur.Visible = True And Me.pnlFavoriten.Visible = False Then
            Me.Width = 560
        End If

        If Me.TVStruktur.Visible = True And Me.pnlFavoriten.Visible = True Then
            Me.Width = 960
            'Me.Width = Me.TVStruktur.Width + Me.Splitter2.Width + Me.TVStruktur.Width
        End If

        If Me.TVStruktur.Visible = False And Me.pnlFavoriten.Visible = True Then
            Me.Width = 560
            'Me.Width = Me.TVStruktur.Width
        End If

        If Me.TVStruktur.Visible = False And Me.pnlFavoriten.Visible = False Then
            Me.Width = 560
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.frmVorlagenauswahl_Resize Method

Private Sub frmVorlagenauswahl_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmVorlagenauswahl_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        'ResizeForm()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mcbfilter_SelectedValueChanged Method

Private Sub mcbfilter_SelectedValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles mcbfilter.SelectedValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mcbfilter_SelectedValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles mcbfilter.SelectedValueChanged
        If On_Load Then Exit Sub
        Me.Cursor = Cursors.WaitCursor
        Globals.Vorlagenfilter = Me.mcbfilter.SelectedValue
        'TVStruktur.BeginUpdate()
        Load_Struktur(Me.TxtSearch.Text, False)

        'Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
        'TVStruktur.EndUpdate()
        'TVStruktur.Refresh()

        Try
            Me.TVStruktur.SelectedNode = Me.TVStruktur.Nodes(0)
        Catch
        End Try

        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mnuDokument_erstellen_Click Method

Private Sub mnuDokument_erstellen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDokument_erstellen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDokument_erstellen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDokument_erstellen.Click
        DokumentErstellen()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mnuInfoDokumentvorlage_Click Method

Private Sub mnuInfoDokumentvorlage_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuInfoDokumentvorlage.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuInfoDokumentvorlage_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuInfoDokumentvorlage.Click
        If Me.FavoritenStruktur.SelectedNode.ImageIndex >= 60 + DP_Imagepos Then
            Dim f As New frmDokumentpaketInfo()

            Try
                If Me.FavoritenStruktur.SelectedNode.ImageIndex = 62 + DP_Imagepos Then
                    f.Key = Me.Get_dtnr_dpnr(TagValue(Me.FavoritenStruktur.SelectedNode.Tag))
                Else
                    f.Key = TagValue(Me.FavoritenStruktur.SelectedNode.Tag)
                End If
                f.Titel = Me.FavoritenStruktur.SelectedNode.Text

                f.ShowDialog()
                f.Dispose()
                Exit Sub
            Catch
            Finally
                f.Dispose()
            End Try
        Else
            Dim f As New frmDokumenttypInfo()
            Try
                f.Key = Get_dtnr_dpnr(TagValue(FavoritenStruktur.SelectedNode.Tag))
                f.Text = f.Text + Me.FavoritenStruktur.SelectedNode.Text
                f.ShowDialog()
            Catch
            Finally
                f.dispose()
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mnuLoeschen_Click Method

Private Sub mnuLoeschen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuLoeschen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuLoeschen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuLoeschen.Click
        Dim tn As TreeNode
        tn = Me.FavoritenStruktur.SelectedNode
        If tn.Parent Is Nothing Then
            MyMsg.show_standardmessage(400, MsgBoxStyle.Information)
            '            MsgBox("Die Root-Einträge können nicht gelöscht werden.", MsgBoxStyle.Information)
            Exit Sub

        End If

        Dim answer As MsgBoxResult
        If tn.ImageIndex <> 1 And tn.ImageIndex <> 60 + DP_Imagepos Then
            answer = MyMsg.show_MessageYesNo_ReplaceText(403, tn.Text, "")
            '            answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' löschen?", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        Else
            If tn.ImageIndex = 1 Then
                answer = MyMsg.show_MessageYesNo_ReplaceText(402, tn.Text, "")
                '                answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' inkl. allfälligen Untereinträgen löschen?", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
            Else
                answer = MyMsg.show_MessageYesNo_ReplaceText(401, tn.Text, "")
                '               answer = MsgBox("Wollen Sie den Eintrag '" + tn.Text + "' inkl. allfälligen Untereinträgen löschen?" + vbCrLf + "(Individuelle Dokumentpakete werden inaktiviert)", MsgBoxStyle.YesNo + MsgBoxStyle.Question)
            End If
        End If
        If answer = MsgBoxResult.No Then Exit Sub
        DeleteNodes(Me.FavoritenStruktur.SelectedNode)
        DelNode(tn)
        tn.Remove()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mnuNeuerOrdner_Click Method

Private Sub mnuNeuerOrdner_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuNeuerOrdner.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuNeuerOrdner_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuNeuerOrdner.Click
        Dim Strukturnr As Integer
        Dim tn As TreeNode
        Dim tnnew As TreeNode
        Dim sNodeText As String
        Dim iDokumentFavoritenNr As Integer

        sNodeText = InputBox("Neuer Ordnername", "Neuer Favoritenordner hinzufügen")
        If sNodeText = "" Then Exit Sub
        If Me.FavoritenStruktur.SelectedNode.ImageIndex <> 1 And Me.FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            tn = Me.FavoritenStruktur.SelectedNode
            Strukturnr = TagValue(Me.FavoritenStruktur.SelectedNode.Parent.Tag)
        Else
            Strukturnr = TagValue(Me.FavoritenStruktur.SelectedNode.Tag)
            tn = Me.FavoritenStruktur.SelectedNode
        End If

        tnnew = tn.Nodes.Add(sNodeText)
        tnnew.ImageIndex = tn.ImageIndex
        tnnew.SelectedImageIndex = tn.SelectedImageIndex
        tnnew.Tag = "tmp"

        Dim fs As New edokadb.clsEDEX_Favoriten()
        fs.cpMainConnectionProvider = conn
        fs.sBezeichnung = New SqlString(CType(sNodeText, String))
        fs.bAktiv = New SqlBoolean(CType(True, Boolean))
        fs.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
        fs.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
        fs.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
        fs.iMitarbeiternr = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
        fs.iParentid = New SqlInt32(CType(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), Int32))
        fs.iSort = New SqlInt32(CType(tnnew.Index, Int32))
        fs.iSprache = New SqlInt32(CType(Globals.Sprache, Int32))
        If Me.FavoritenStruktur.SelectedNode.ImageIndex <> 60 + DP_Imagepos Then
            fs.iImageindex = New SqlInt32(CType(tnnew.ImageIndex, Int32))
            fs.iImageindexopen = New SqlInt32(CType(tnnew.SelectedImageIndex, Int32))
        Else
            fs.iImageindex = New SqlInt32(CType(tnnew.ImageIndex - DP_Imagepos, Int32))
            fs.iImageindexopen = New SqlInt32(CType(tnnew.SelectedImageIndex - DP_Imagepos, Int32))
        End If
        fs.bDp = New SqlBoolean(CType(False, Boolean))
        fs.bStddp = New SqlBoolean(CType(False, Boolean))
        fs.iDtnr_dpnr = New SqlInt32(CType(0, Int32))
        fs.bStrukturelement = New SqlBoolean(CType(True, Boolean))
        If tn.ImageIndex = 60 + DP_Imagepos Then
            fs.bDp = New SqlBoolean(CType(True, Boolean))
        End If

        conn.OpenConnection()
        Try
            fs.Insert()
            tnnew.Tag = TagArt(tn.Tag) + LTrim(Str(fs.iNreintrag.Value))
        Catch ex As Exception
            MsgBox(ex.Message)
        Finally
            conn.CloseConnection(True)
            fs.Dispose()
        End Try
        tn.ExpandAll()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe.mnuUmbenennen_Click Method

Private Sub mnuUmbenennen_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuUmbenennen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuUmbenennen_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuUmbenennen.Click
        Dim a As String
        a = InputBox("Neuer Name:")
        If a = "" Then Exit Sub
        Me.FavoritenStruktur.SelectedNode.Text = a
        RenameNodeFavoritenstruktur(TagValue(Me.FavoritenStruktur.SelectedNode.Tag), Me.FavoritenStruktur.SelectedNode.Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenauswahl_Serienbriefe Fields

frmVorlagenauswahl_Serienbriefe overview

Fields

field BtnHelp
field ComboBox1
field ContextMenu1
field ContextMenu3
field DataSet1
field FavoritenStruktur
field ImageList1
field ImageList2
field ImageList3
field ImageList4
field ItemMove
field Label1
field MenuExpand
field MenuItem1
field MenuItem10
field MenuItem12
field MenuItem2
field MenuItem3
field MenuItem4
field MenuItem5
field MenuItem6
field MenuItem7
field MenuItem8
field MenuItem9
field MenuUnExpand
field MenuUnexpandsel
field MnuAddFavoriten
field MnuDokumenterstellen
field MnuDokumentpaketKopieren
field MnuExpandSel
field MnuIDVBearbeitung
field MnuMAKopie
field MnuNeuesDokumentpaket
field MnuPaketverwaltung
field MnuShowFavoriten
field On_Load
field Splitter2
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field TVStruktur
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolTip1
field TxtSearch
field components
field itodelete
field m_Dokumentpaket
field m_barcodeid
field m_dokumentart
field m_dokumentvorlage
field m_edex_Vorlagenauswahl
field m_favoriten
field m_iImagesOffestImagelist1
field m_iWindowWidth
field m_profile
field m_profilnr
field mcbfilter
field mnuDokument_erstellen
field mnuInfoDokumentvorlage
field mnuLoeschen
field mnuNeuerOrdner
field mnuUmbenennen
field pnlFavoriten
field selectPoint
field ssort
field todelete

See Also

frmVorlagenauswahl_Serienbriefe Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ComboBox1 Variable

Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents ComboBox1 As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


FavoritenStruktur Variable

Friend WithEvents FavoritenStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents FavoritenStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ImageList2 Variable

Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList2 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ImageList3 Variable

Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList3 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ImageList4 Variable

Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList4 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ItemMove Variable

Dim ItemMove As Boolean = False

Source code

[Visual Basic]
    Dim ItemMove As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuExpand Variable

Friend WithEvents MenuExpand As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuExpand As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem10 Variable

Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem10 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem12 Variable

Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem12 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem3 Variable

Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem3 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem4 Variable

Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem4 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem5 Variable

Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem5 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem6 Variable

Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem6 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem7 Variable

Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem7 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem8 Variable

Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem8 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuItem9 Variable

Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem9 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuUnExpand Variable

Friend WithEvents MenuUnExpand As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuUnExpand As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MenuUnexpandsel Variable

Friend WithEvents MenuUnexpandsel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuUnexpandsel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuAddFavoriten Variable

Friend WithEvents MnuAddFavoriten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAddFavoriten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuDokumenterstellen Variable

Friend WithEvents MnuDokumenterstellen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumenterstellen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuDokumentpaketKopieren Variable

Friend WithEvents MnuDokumentpaketKopieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDokumentpaketKopieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuExpandSel Variable

Friend WithEvents MnuExpandSel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuExpandSel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuIDVBearbeitung Variable

Friend WithEvents MnuIDVBearbeitung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuIDVBearbeitung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuMAKopie Variable

Friend WithEvents MnuMAKopie As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuMAKopie As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuNeuesDokumentpaket Variable

Friend WithEvents MnuNeuesDokumentpaket As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuNeuesDokumentpaket As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuPaketverwaltung Variable

Friend WithEvents MnuPaketverwaltung As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuPaketverwaltung As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


MnuShowFavoriten Variable

Friend WithEvents MnuShowFavoriten As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuShowFavoriten As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


On_Load Variable

Dim On_Load As Boolean = False

Source code

[Visual Basic]
    Dim On_Load As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


Splitter2 Variable

Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Source code

[Visual Basic]
    Friend WithEvents Splitter2 As System.Windows.Forms.Splitter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


TVStruktur Variable

Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Source code

[Visual Basic]
    Friend WithEvents TVStruktur As System.Windows.Forms.TreeView

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ToolTip1 Variable

Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Source code

[Visual Basic]
    Friend WithEvents ToolTip1 As System.Windows.Forms.ToolTip

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


TxtSearch Variable

Friend WithEvents TxtSearch As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtSearch As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


itodelete Variable

Dim itodelete As Integer

Source code

[Visual Basic]
    Dim itodelete As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_Dokumentpaket Variable

Dim m_Dokumentpaket As Boolean = False

Source code

[Visual Basic]
    Dim m_Dokumentpaket As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_barcodeid Variable

Dim m_barcodeid As String

Source code

[Visual Basic]
    Dim m_barcodeid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_dokumentart Variable

Dim m_dokumentart As String

Source code

[Visual Basic]
    Dim m_dokumentart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_dokumentvorlage Variable

Dim m_dokumentvorlage As Long

Source code

[Visual Basic]
    Dim m_dokumentvorlage As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_edex_Vorlagenauswahl Variable

Dim m_edex_Vorlagenauswahl As Boolean = False

Source code

[Visual Basic]
    Dim m_edex_Vorlagenauswahl As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_favoriten Variable

Dim m_favoriten As Boolean

Source code

[Visual Basic]
    Dim m_favoriten As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_iImagesOffestImagelist1 Variable

Private m_iImagesOffestImagelist1 As Integer

Source code

[Visual Basic]
    Private m_iImagesOffestImagelist1 As Integer      'Anzahl Iamges in der Liste bevor die KocIcons dazukopiert werden

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_iWindowWidth Variable

Private m_iWindowWidth As Integer

Source code

[Visual Basic]
    Private m_iWindowWidth As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_profile Variable

Dim m_profile As DataTable

Source code

[Visual Basic]
    Dim m_profile As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


m_profilnr Variable

Dim m_profilnr As Long

Source code

[Visual Basic]
    Dim m_profilnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mcbfilter Variable

Dim WithEvents mcbfilter As New MultiComboBox()

Source code

[Visual Basic]
    Dim WithEvents mcbfilter As New MultiComboBox()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mnuDokument_erstellen Variable

Friend WithEvents mnuDokument_erstellen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDokument_erstellen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mnuInfoDokumentvorlage Variable

Friend WithEvents mnuInfoDokumentvorlage As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuInfoDokumentvorlage As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mnuLoeschen Variable

Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuLoeschen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mnuNeuerOrdner Variable

Friend WithEvents mnuNeuerOrdner As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuNeuerOrdner As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


mnuUmbenennen Variable

Friend WithEvents mnuUmbenennen As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuUmbenennen As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


pnlFavoriten Variable

Friend WithEvents pnlFavoriten As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents pnlFavoriten As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


selectPoint Variable

Friend selectPoint As New System.Drawing.Point()

Source code

[Visual Basic]
    Friend selectPoint As New System.Drawing.Point()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


ssort Variable

Dim ssort As Integer

Source code

[Visual Basic]
    Dim ssort As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


todelete Variable

Dim todelete( _
   50 _
) As Integer

Source code

[Visual Basic]
    Dim todelete(50) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenauswahl_Serienbriefe


frmVorlagenfelddetail Class

For a list of all members of this type, see frmVorlagenfelddetail Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmVorlagenfelddetail

Public Class frmVorlagenfelddetail
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmVorlagenfelddetail Members


frmVorlagenfelddetail Members

frmVorlagenfelddetail overview

Constructors

constructor frmVorlagenfelddetail Constructor

Methods

method Button1_Click
method Dispose
method InitializeComponent

Fields

field Bezeichnung
field Button1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field TextBox1
field TextBox2
field TxtTestdata
field TxtTextmakebeginn
field cbFeldtyp
field cbStandard
field components
field txtDatenherkunft
field txtFeldname
field txtTextmarkeEnde

See Also

frmVorlagenfelddetail Class


frmVorlagenfelddetail Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


frmVorlagenfelddetail Methods

frmVorlagenfelddetail overview

Methods

method Button1_Click
method Dispose
method InitializeComponent

See Also

frmVorlagenfelddetail Class


frmVorlagenfelddetail.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


frmVorlagenfelddetail.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


frmVorlagenfelddetail.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.cbFeldtyp = New System.Windows.Forms.ComboBox()
        Me.txtDatenherkunft = New System.Windows.Forms.TextBox()
        Me.cbStandard = New System.Windows.Forms.CheckBox()
        Me.TxtTextmakebeginn = New System.Windows.Forms.TextBox()
        Me.txtTextmarkeEnde = New System.Windows.Forms.TextBox()
        Me.txtFeldname = New System.Windows.Forms.TextBox()
        Me.Bezeichnung = New System.Windows.Forms.Label()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.TxtTestdata = New System.Windows.Forms.TextBox()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(96, 32)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(296, 20)
        Me.TextBox1.TabIndex = 0
        Me.TextBox1.Text = "txtBezeichnung"
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(96, 56)
        Me.TextBox2.Multiline = True
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(296, 56)
        Me.TextBox2.TabIndex = 1
        Me.TextBox2.Text = "txtBeschreibung"
        '
        'cbFeldtyp
        '
        Me.cbFeldtyp.Items.AddRange(New Object() {"Text", "Zahl", "Datum"})
        Me.cbFeldtyp.Location = New System.Drawing.Point(96, 120)
        Me.cbFeldtyp.Name = "cbFeldtyp"
        Me.cbFeldtyp.Size = New System.Drawing.Size(168, 21)
        Me.cbFeldtyp.TabIndex = 2
        Me.cbFeldtyp.Text = "ComboBox1"
        '
        'txtDatenherkunft
        '
        Me.txtDatenherkunft.Location = New System.Drawing.Point(96, 144)
        Me.txtDatenherkunft.Multiline = True
        Me.txtDatenherkunft.Name = "txtDatenherkunft"
        Me.txtDatenherkunft.Size = New System.Drawing.Size(296, 56)
        Me.txtDatenherkunft.TabIndex = 3
        Me.txtDatenherkunft.Text = "txtBeschreibung"
        '
        'cbStandard
        '
        Me.cbStandard.Location = New System.Drawing.Point(96, 200)
        Me.cbStandard.Name = "cbStandard"
        Me.cbStandard.Size = New System.Drawing.Size(16, 24)
        Me.cbStandard.TabIndex = 4
        Me.cbStandard.Text = "CheckBox1"
        '
        'TxtTextmakebeginn
        '
        Me.TxtTextmakebeginn.Location = New System.Drawing.Point(96, 224)
        Me.TxtTextmakebeginn.Name = "TxtTextmakebeginn"
        Me.TxtTextmakebeginn.Size = New System.Drawing.Size(296, 20)
        Me.TxtTextmakebeginn.TabIndex = 5
        Me.TxtTextmakebeginn.Text = "txtBezeichnung"
        '
        'txtTextmarkeEnde
        '
        Me.txtTextmarkeEnde.Location = New System.Drawing.Point(96, 248)
        Me.txtTextmarkeEnde.Name = "txtTextmarkeEnde"
        Me.txtTextmarkeEnde.Size = New System.Drawing.Size(296, 20)
        Me.txtTextmarkeEnde.TabIndex = 6
        Me.txtTextmarkeEnde.Text = "txtBezeichnung"
        '
        'txtFeldname
        '
        Me.txtFeldname.Location = New System.Drawing.Point(96, 272)
        Me.txtFeldname.Name = "txtFeldname"
        Me.txtFeldname.Size = New System.Drawing.Size(296, 20)
        Me.txtFeldname.TabIndex = 7
        Me.txtFeldname.Text = "txtBezeichnung"
        '
        'Bezeichnung
        '
        Me.Bezeichnung.Location = New System.Drawing.Point(8, 32)
        Me.Bezeichnung.Name = "Bezeichnung"
        Me.Bezeichnung.Size = New System.Drawing.Size(80, 23)
        Me.Bezeichnung.TabIndex = 9
        Me.Bezeichnung.Text = "Bezeichnung"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 56)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(80, 23)
        Me.Label1.TabIndex = 10
        Me.Label1.Text = "Beschreibung"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 120)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(80, 23)
        Me.Label2.TabIndex = 11
        Me.Label2.Text = "Feldtyp"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 144)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(80, 23)
        Me.Label3.TabIndex = 12
        Me.Label3.Text = "Datenherkunft"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 200)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(80, 23)
        Me.Label4.TabIndex = 13
        Me.Label4.Text = "Standard"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 224)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 23)
        Me.Label5.TabIndex = 14
        Me.Label5.Text = "Textmarke B."
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 248)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(80, 23)
        Me.Label6.TabIndex = 15
        Me.Label6.Text = "Textmarke E."
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 272)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(80, 23)
        Me.Label7.TabIndex = 16
        Me.Label7.Text = "Feldname"
        '
        'TxtTestdata
        '
        Me.TxtTestdata.Location = New System.Drawing.Point(96, 304)
        Me.TxtTestdata.Multiline = True
        Me.TxtTestdata.Name = "TxtTestdata"
        Me.TxtTestdata.Size = New System.Drawing.Size(296, 56)
        Me.TxtTestdata.TabIndex = 17
        Me.TxtTestdata.Text = "txtBeschreibung"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 304)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(80, 23)
        Me.Label8.TabIndex = 18
        Me.Label8.Text = "Testdaten"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(184, 376)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(72, 24)
        Me.Button1.TabIndex = 19
        Me.Button1.Text = "&OK"
        '
        'frmVorlagenfelddetail
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(416, 413)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.Label8, Me.TxtTestdata, Me.Label7, Me.Label6, Me.Label5, Me.Label4, Me.Label3, Me.Label2, Me.Label1, Me.Bezeichnung, Me.txtFeldname, Me.txtTextmarkeEnde, Me.TxtTextmakebeginn, Me.cbStandard, Me.txtDatenherkunft, Me.cbFeldtyp, Me.TextBox2, Me.TextBox1})
        Me.Name = "frmVorlagenfelddetail"
        Me.Text = "Vorlagenfeld-Detail"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


frmVorlagenfelddetail Fields

frmVorlagenfelddetail overview

Fields

field Bezeichnung
field Button1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field TextBox1
field TextBox2
field TxtTestdata
field TxtTextmakebeginn
field cbFeldtyp
field cbStandard
field components
field txtDatenherkunft
field txtFeldname
field txtTextmarkeEnde

See Also

frmVorlagenfelddetail Class


Bezeichnung Variable

Friend WithEvents Bezeichnung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Bezeichnung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


TxtTestdata Variable

Friend WithEvents TxtTestdata As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtTestdata As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


TxtTextmakebeginn Variable

Friend WithEvents TxtTextmakebeginn As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TxtTextmakebeginn As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


cbFeldtyp Variable

Friend WithEvents cbFeldtyp As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbFeldtyp As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


cbStandard Variable

Friend WithEvents cbStandard As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbStandard As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


txtDatenherkunft Variable

Friend WithEvents txtDatenherkunft As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtDatenherkunft As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


txtFeldname Variable

Friend WithEvents txtFeldname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtFeldname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


txtTextmarkeEnde Variable

Friend WithEvents txtTextmarkeEnde As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtTextmarkeEnde As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmVorlagenfelddetail


frmWaitforClosing Class

For a list of all members of this type, see frmWaitforClosing Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmWaitforClosing

Public Class frmWaitforClosing
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmWaitforClosing Members


frmWaitforClosing Members

frmWaitforClosing overview

Constructors

constructor frmWaitforClosing Constructor

Methods

method Dispose
method InitializeComponent
method frmWaitforClosing_Load

Fields

field Label1
field Label2
field Label3
field Label4
field ProgressBar1
field components

See Also

frmWaitforClosing Class


frmWaitforClosing Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


frmWaitforClosing Methods

frmWaitforClosing overview

Methods

method Dispose
method InitializeComponent
method frmWaitforClosing_Load

See Also

frmWaitforClosing Class


frmWaitforClosing.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


frmWaitforClosing.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmWaitforClosing))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.ProgressBar1 = New System.Windows.Forms.ProgressBar()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Cursor = System.Windows.Forms.Cursors.AppStarting
        Me.Label1.Location = New System.Drawing.Point(8, 8)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(416, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "EDOKA wird beendet. Bitte warten Sie, bis der Vorgang abgeschlossen ist..."
        '
        'ProgressBar1
        '
        Me.ProgressBar1.Location = New System.Drawing.Point(8, 48)
        Me.ProgressBar1.Name = "ProgressBar1"
        Me.ProgressBar1.Size = New System.Drawing.Size(368, 16)
        Me.ProgressBar1.TabIndex = 1
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(5, 32)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(16, 16)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "0"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(183, 32)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(24, 16)
        Me.Label3.TabIndex = 3
        Me.Label3.Text = "50"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(352, 34)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(24, 16)
        Me.Label4.TabIndex = 4
        Me.Label4.Text = "100"
        '
        'frmWaitforClosing
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(386, 74)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.ProgressBar1, Me.Label4, Me.Label3, Me.Label2, Me.Label1})
        Me.Cursor = System.Windows.Forms.Cursors.AppStarting
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedToolWindow
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmWaitforClosing"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "EDOKA beenden"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


frmWaitforClosing.frmWaitforClosing_Load Method

Private Sub frmWaitforClosing_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmWaitforClosing_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


frmWaitforClosing Fields

frmWaitforClosing overview

Fields

field Label1
field Label2
field Label3
field Label4
field ProgressBar1
field components

See Also

frmWaitforClosing Class


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


ProgressBar1 Variable

Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Source code

[Visual Basic]
    Friend WithEvents ProgressBar1 As System.Windows.Forms.ProgressBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWaitforClosing


frmWatchJob Class

For a list of all members of this type, see frmWatchJob Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmWatchJob

Public Class frmWatchJob
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmWatchJob Members


frmWatchJob Members

frmWatchJob overview

Constructors

constructor frmWatchJob Constructor (Overloaded)

Methods

method Button1_Click
method Check_Status
method Dispose
method InitializeComponent
method Timer1_Elapsed
method frmWatchJob_Load

Fields

field Button1
field Label1
field Label2
field Label3
field Timer1
field alnr
field cbverarbeitung
field components
field dokidquittung
field lblpartner
field m_druckjobnr
field part

See Also

frmWatchJob Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal druckjobnr As Integer)

See Also

frmWatchJob | EDOKAApp


frmWatchJob Methods

frmWatchJob overview

Methods

method Button1_Click
method Check_Status
method Dispose
method InitializeComponent
method Timer1_Elapsed
method frmWatchJob_Load

See Also

frmWatchJob Class


frmWatchJob.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Select Case Me.cbverarbeitung.SelectedIndex
            Case 0
            Case 1
                Dim frmbla As New frmBLAuslieferungen()
                frmbla.PrintDocs(Me.dokidquittung, Me, Me.alnr, part)
                frmbla.Close()
                frmbla.Dispose()
            Case 2
                Dim frmbla As New frmBLAuslieferungen()
                frmbla.PrintQuittung(Me.dokidquittung, Me, Me.alnr)
                frmbla.Close()
                frmbla.Dispose()

        End Select
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob.Check_Status Method

Private Function Check_Status() As Boolean

Source code

[Visual Basic]
    Private Function Check_Status() As Boolean
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_check_druckjob"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@druckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.m_druckjobnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@partner", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid_quittung", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@alnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
            sdaAdapter.Fill(dtToReturn)
            If scmCmdToExecute.Parameters("@status").Value = 1 Then
                Me.lblpartner.Text = scmCmdToExecute.Parameters("@Partner").Value
                Me.dokidquittung = scmCmdToExecute.Parameters("@dokumentid_quittung").Value
                Me.alnr = scmCmdToExecute.Parameters("@alnr").Value
                Return True
            Else
                Return False
            End If
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmWatchJob))
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Timer1 = New System.Timers.Timer()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.lblpartner = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.cbverarbeitung = New System.Windows.Forms.ComboBox()
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(136, 120)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 0
        Me.Button1.Text = "OK"
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 32)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(376, 23)
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Die COLD-Druckaufbereitung ist abgeschlossen."
        '
        'Timer1
        '
        Me.Timer1.Interval = 30000
        Me.Timer1.SynchronizingObject = Me
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 8)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(48, 23)
        Me.Label2.TabIndex = 2
        Me.Label2.Text = "Partner:"
        '
        'lblpartner
        '
        Me.lblpartner.Location = New System.Drawing.Point(56, 8)
        Me.lblpartner.Name = "lblpartner"
        Me.lblpartner.Size = New System.Drawing.Size(336, 23)
        Me.lblpartner.TabIndex = 3
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(120, 23)
        Me.Label3.TabIndex = 4
        Me.Label3.Text = "Weitere Verarbeitung:"
        '
        'cbverarbeitung
        '
        Me.cbverarbeitung.Items.AddRange(New Object() {"Meldungsfenster schliessen", "Aushändigungs-Qu. und Dokumente drucken", "Nur Aushändigungs-Quittung drucken"})
        Me.cbverarbeitung.Location = New System.Drawing.Point(136, 72)
        Me.cbverarbeitung.Name = "cbverarbeitung"
        Me.cbverarbeitung.Size = New System.Drawing.Size(216, 21)
        Me.cbverarbeitung.TabIndex = 5
        Me.cbverarbeitung.Text = "ComboBox1"
        '
        'frmWatchJob
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(360, 149)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.cbverarbeitung, Me.Label3, Me.lblpartner, Me.Label2, Me.Label1, Me.Button1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmWatchJob"
        Me.ShowInTaskbar = False
        Me.Text = "Druckaufbereitung abgeschlossen"
        Me.TopMost = True
        CType(Me.Timer1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob.Timer1_Elapsed Method

Private Sub Timer1_Elapsed( _
   ByVal sender As Object, _
   ByVal e As System.Timers.ElapsedEventArgs _
) Handles Timer1.Elapsed

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Timer1_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles Timer1.Elapsed
        If Check_Status() Then
            Me.Timer1.Enabled = False
            Me.Visible = True
            Beep()
            Application.DoEvents()
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob.frmWatchJob_Load Method

Private Sub frmWatchJob_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmWatchJob_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.cbverarbeitung.SelectedIndex = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob Fields

frmWatchJob overview

Fields

field Button1
field Label1
field Label2
field Label3
field Timer1
field alnr
field cbverarbeitung
field components
field dokidquittung
field lblpartner
field m_druckjobnr
field part

See Also

frmWatchJob Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


Timer1 Variable

Friend WithEvents Timer1 As System.Timers.Timer

Source code

[Visual Basic]
    Friend WithEvents Timer1 As System.Timers.Timer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


alnr Variable

Dim alnr As Integer = 0

Source code

[Visual Basic]
    Dim alnr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


cbverarbeitung Variable

Friend WithEvents cbverarbeitung As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbverarbeitung As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


dokidquittung Variable

Dim dokidquittung As String = ""

Source code

[Visual Basic]
    Dim dokidquittung As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


lblpartner Variable

Friend WithEvents lblpartner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpartner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


m_druckjobnr Variable

Dim m_druckjobnr As Integer

Source code

[Visual Basic]
    Dim m_druckjobnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


part Variable

Dim part As Integer

Source code

[Visual Basic]
    Dim part As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWordViewer Class

For a list of all members of this type, see frmWordViewer Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmWordViewer

Public Class frmWordViewer
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmWordViewer Members


frmWordViewer Members

frmWordViewer overview

Constructors

constructor frmWordViewer Constructor (Overloaded)

Properties

property PrintDokumentid
property PrintFilename
property Show_Print_Message

Methods

method Dispose
method InitializeComponent
method MainForm_Load
method MenuItem13_Click
method Print_Doc
method StartWord
method ToolBar2_ButtonClick
method addressBar_KeyDown
method backButton_Click
method copyMI_Click
method cutMI_Click
method exitMI_Click
method findMI_Click
method forwardButton_Click
method frmWordViewer_Closing
method homeButton_Click
method inetOptionsMI_Click
method pasteMI_Click
method printMI_Click
method print_word
method webOCWrapper_StatusTextChange
method webOCWrapper_TopLevelNavigateComplete2

Fields

field H
field ImageList1
field MenuItem13
field StatusBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field W
field addressBar
field addressBarLbl
field components
field contextMenu
field m_PrintFilename
field m_printdokumentid
field m_showprintmessage
field rm
field wasUrlTyped
field webOCWrapper

See Also

frmWordViewer Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal printable As Boolean)

See Also

frmWordViewer | EDOKAApp


frmWordViewer Properties

frmWordViewer overview

Properties

property PrintDokumentid
property PrintFilename
property Show_Print_Message

See Also

frmWordViewer Class


frmWordViewer.PrintDokumentid Property

Property PrintDokumentid() As String

Source code

[Visual Basic]
    Property PrintDokumentid() As String
        Get
            Return m_printdokumentid
        End Get
        Set(ByVal Value As String)
            m_printdokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.PrintFilename Property

Property PrintFilename() As String

Source code

[Visual Basic]
    Property PrintFilename() As String
        Get
            Return m_PrintFilename
        End Get
        Set(ByVal Value As String)
            m_PrintFilename = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.Show_Print_Message Property

Property Show_Print_Message() As Boolean

Source code

[Visual Basic]
    Property Show_Print_Message() As Boolean
        Get
            Return m_showprintmessage
        End Get
        Set(ByVal Value As Boolean)
            m_showprintmessage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer Methods

frmWordViewer overview

Methods

method Dispose
method InitializeComponent
method MainForm_Load
method MenuItem13_Click
method Print_Doc
method StartWord
method ToolBar2_ButtonClick
method addressBar_KeyDown
method backButton_Click
method copyMI_Click
method cutMI_Click
method exitMI_Click
method findMI_Click
method forwardButton_Click
method frmWordViewer_Closing
method homeButton_Click
method inetOptionsMI_Click
method pasteMI_Click
method printMI_Click
method print_word
method webOCWrapper_StatusTextChange
method webOCWrapper_TopLevelNavigateComplete2

See Also

frmWordViewer Class


frmWordViewer.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmWordViewer))
        Me.webOCWrapper = New EDOKAApp.WebOCHostCtrl()
        Me.contextMenu = New System.Windows.Forms.ContextMenu()
        Me.MenuItem13 = New System.Windows.Forms.MenuItem()
        Me.StatusBar1 = New System.Windows.Forms.StatusBar()
        Me.addressBar = New System.Windows.Forms.ComboBox()
        Me.addressBarLbl = New System.Windows.Forms.Label()
        Me.ToolBar2 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.SuspendLayout()
        '
        'webOCWrapper
        '
        Me.webOCWrapper.Anchor = (((System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Bottom) _
                    Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.webOCWrapper.BrowserContextMenu = False
        Me.webOCWrapper.ImeMode = System.Windows.Forms.ImeMode.NoControl
        Me.webOCWrapper.Location = New System.Drawing.Point(0, 24)
        Me.webOCWrapper.Name = "webOCWrapper"
        Me.webOCWrapper.Size = New System.Drawing.Size(864, 520)
        Me.webOCWrapper.TabIndex = 0
        Me.webOCWrapper.TabStop = False
        '
        'contextMenu
        '
        Me.contextMenu.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem13})
        '
        'MenuItem13
        '
        Me.MenuItem13.Index = 0
        Me.MenuItem13.Text = "Print..."
        '
        'StatusBar1
        '
        Me.StatusBar1.Anchor = ((System.Windows.Forms.AnchorStyles.Bottom Or System.Windows.Forms.AnchorStyles.Left) _
                    Or System.Windows.Forms.AnchorStyles.Right)
        Me.StatusBar1.Dock = System.Windows.Forms.DockStyle.None
        Me.StatusBar1.Location = New System.Drawing.Point(0, 549)
        Me.StatusBar1.Name = "StatusBar1"
        Me.StatusBar1.Size = New System.Drawing.Size(864, 24)
        Me.StatusBar1.TabIndex = 1
        '
        'addressBar
        '
        Me.addressBar.Location = New System.Drawing.Point(16, 56)
        Me.addressBar.Name = "addressBar"
        Me.addressBar.Size = New System.Drawing.Size(352, 21)
        Me.addressBar.Sorted = True
        Me.addressBar.TabIndex = 3
        Me.addressBar.Visible = False
        '
        'addressBarLbl
        '
        Me.addressBarLbl.Location = New System.Drawing.Point(16, 12)
        Me.addressBarLbl.Name = "addressBarLbl"
        Me.addressBarLbl.Size = New System.Drawing.Size(100, 16)
        Me.addressBarLbl.TabIndex = 8
        Me.addressBarLbl.TextAlign = System.Drawing.ContentAlignment.MiddleRight
        '
        'ToolBar2
        '
        Me.ToolBar2.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarButton2})
        Me.ToolBar2.DropDownArrows = True
        Me.ToolBar2.ImageList = Me.ImageList1
        Me.ToolBar2.Name = "ToolBar2"
        Me.ToolBar2.ShowToolTips = True
        Me.ToolBar2.Size = New System.Drawing.Size(864, 25)
        Me.ToolBar2.TabIndex = 9
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 1
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'frmWordViewer
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(864, 573)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.ToolBar2, Me.addressBarLbl, Me.StatusBar1, Me.addressBar, Me.webOCWrapper})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmWordViewer"
        Me.Text = "Office-Dokumentanzeige"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.MainForm_Load Method

Private Sub MainForm_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MainForm_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        webOCWrapper.Navigate(addressBar.Text)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.MenuItem13_Click Method

Private Sub MenuItem13_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem13.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem13_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem13.Click
        Try
            If print_word() = True Then Exit Sub
            webOCWrapper.Print(doUI:=True)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.Print_Doc Method

Public Sub Print_Doc()

Source code

[Visual Basic]
    Public Sub Print_Doc()
        Try
            If print_word() = True Then Exit Sub
        Catch
        End Try
        Try
            webOCWrapper.Print(doUI:=True)
        Catch ex As Exception
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.StartWord Method

Private Function StartWord()

Source code

[Visual Basic]
    Private Function StartWord()
        'Try
        '    objword = GetObject(, "Word.application")
        '    'objword = CreateObject("Word.application")
        'Catch
        '    Try
        '        objword = CreateObject("Word.application")
        '    Catch ex As Exception
        '        MsgBox(ex.Message)
        '    End Try
        'Finally
        '    'objword.Visible = False
        '    'objword.WindowState = Word.WdWindowState.wdWindowStateNormal
        '    objword.WindowState = Word.WdWindowState.wdWindowStateMinimize
        '    'W = objword.Width
        '    'H = objword.Height
        '    'objword.Width = 10
        '    'objword.Height = 10
        '    objword.Visible = True

        'End Try
        'Try
        '    objword.Run("Autoexec")
        'Catch
        'End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.ToolBar2_ButtonClick Method

Private Sub ToolBar2_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar2.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar2_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar2.ButtonClick
        Dim i As Integer

        Select Case Me.ToolBar2.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'pint
                Try
                    If print_word() = True Then Exit Sub
                Catch
                End Try
                Try
                    webOCWrapper.Print(doUI:=True)
                Catch
                End Try
            Case Else
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.addressBar_KeyDown Method

Private Sub addressBar_KeyDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
) Handles addressBar.KeyDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub addressBar_KeyDown(ByVal sender As Object, ByVal e As System.Windows.Forms.KeyEventArgs) Handles addressBar.KeyDown
        If (e.KeyCode = Keys.Return) Then
            ' Validate URL.
            Try
                ' TODO: This  won't accept URLs like "www.amazon.com",
                ' like IE will.
                ' Dim u As New Uri(addressBar.Text)
            Catch
                MessageBox.Show(rm.GetString("Error_InvalidUrlOrFile") + " : " + Err.GetException().Message, rm.GetString("Caption_InvalidUrlOrFile"), MessageBoxButtons.OK, MessageBoxIcon.Error)
                Exit Sub
            End Try
            webOCWrapper.Navigate(addressBar.Text)
            ' Add to the list of available web sites - but wait
            ' for NavigateComplete2, so we get the fully-formatted,
            ' redirected URL.
            wasUrlTyped = True
            ' Cancel the event so the address bar never sees this.

        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.backButton_Click Method

Private Sub backButton_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub backButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.GoBack()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.copyMI_Click Method

Private Sub copyMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub copyMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.Copy()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.cutMI_Click Method

Private Sub cutMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cutMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.Cut()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.exitMI_Click Method

Private Sub exitMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub exitMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        ' Clean up app.

        Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.findMI_Click Method

Private Sub findMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub findMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.Find()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.forwardButton_Click Method

Private Sub forwardButton_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub forwardButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.GoForward()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.frmWordViewer_Closing Method

Private Sub frmWordViewer_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmWordViewer_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Try
            Try

                'docword = Nothing
                'objword.Quit(False)
                'objword = Nothing
            Catch

            End Try
            File.Delete(Me.addressBar.Text)
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.homeButton_Click Method

Private Sub homeButton_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub homeButton_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.GoHome()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.inetOptionsMI_Click Method

Private Sub inetOptionsMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub inetOptionsMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.InternetOptions()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.pasteMI_Click Method

Private Sub pasteMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub pasteMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        webOCWrapper.Paste()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.printMI_Click Method

Private Sub printMI_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub printMI_Click(ByVal sender As System.Object, ByVal e As System.EventArgs)
        Try
            webOCWrapper.Print(doUI:=True)
            webOCWrapper.webBrowser.ExecWB(SHDocVw.OLECMDID.OLECMDID_PRINT2, SHDocVw.OLECMDEXECOPT.OLECMDEXECOPT_DODEFAULT)
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.print_word Method

Private Function print_word() As Boolean

Source code

[Visual Basic]
    Private Function print_word() As Boolean
        Dim objword As New Word.ApplicationClass()
        Dim FileReader As New DocMgmt()
        Dim dokument As String
        Try
            dokument = DivFnkt.Get_Filename("View_" + Format(Now, "yyyyMMddHHmmss") + "_" + Me.PrintFilename, "")
            If FileReader.Get_From_DB(Me.PrintDokumentid, dokument) = False Then
                Return False
            End If
        Catch
        Finally
            FileReader = Nothing
        End Try

        If UCase(Microsoft.VisualBasic.Right(Me.PrintFilename, 4)) <> ".DOC" Then
            Return False
        End If

        Application.DoEvents()
        Try
            StartWord()
            Application.DoEvents()
            objword.Documents.Open(dokument)

            'docword = objword.Documents.Open(dokument)
            'Try
            '    docword.Activate()
            'Catch
            'End Try
            Try
                objword.Activate()
            Catch
            End Try
            Try
                objword.Run("Autoexec")
            Catch
            End Try
            Try
                objword.Activate()
            Catch
            End Try
            'Try
            '    docword.Activate()
            'Catch
            'End Try
            System.Windows.Forms.Application.DoEvents()
            'Dim cmbr As Microsoft.Office.Core.CommandBar 'RS:2006-08-22
            Dim cmbr As Office.CommandBar
            For Each cmbr In objword.CommandBars
                'Dim cbctl As Microsoft.Office.Core.CommandBarControl 'RS:2006-08-22
                Dim cbctl As Office.CommandBarControl
                For Each cbctl In cmbr.Controls
                    If cbctl.Id = 2521 Then
                        '           MyMsg.show_standardmessage(250, MsgBoxStyle.Information)
                        System.Windows.Forms.Application.DoEvents()
                        objword.Selection.HomeKey(Unit:=Word.WdUnits.wdLine, Extend:=Word.WdMovementType.wdExtend)
                        System.Windows.Forms.Application.DoEvents()
                        cbctl.Execute()
                        System.Windows.Forms.Application.DoEvents()
                        objword.Visible = False
                        System.Threading.Thread.CurrentThread.Sleep(5500)
                        If Me.Show_Print_Message = True Then
                            MyMsg.show_standardmessage(250, MsgBoxStyle.Information)
                            Return True
                        End If
                        Return True
                        Exit Function
                    End If
                Next
            Next
            Return True
        Catch ex As Exception
            Return False
        Finally
            objword.Quit(False)
            objword = Nothing
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.webOCWrapper_StatusTextChange Method

Private Sub webOCWrapper_StatusTextChange( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent _
) Handles webOCWrapper.StatusTextChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webOCWrapper_StatusTextChange(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_StatusTextChangeEvent) Handles webOCWrapper.StatusTextChange
        StatusBar1.Text = e.text
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer.webOCWrapper_TopLevelNavigateComplete2 Method

Private Sub webOCWrapper_TopLevelNavigateComplete2( _
   ByVal sender As Object, _
   ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event _
) Handles webOCWrapper.TopLevelNavigateComplete2

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub webOCWrapper_TopLevelNavigateComplete2(ByVal sender As Object, ByVal e As AxSHDocVw.DWebBrowserEvents2_NavigateComplete2Event) Handles webOCWrapper.TopLevelNavigateComplete2
        addressBar.Text = Convert.ToString(e.uRL)
        If wasUrlTyped Then
            wasUrlTyped = False
            addressBar.Items.Add(e.uRL)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer Fields

frmWordViewer overview

Fields

field H
field ImageList1
field MenuItem13
field StatusBar1
field ToolBar2
field ToolBarButton1
field ToolBarButton2
field W
field addressBar
field addressBarLbl
field components
field contextMenu
field m_PrintFilename
field m_printdokumentid
field m_showprintmessage
field rm
field wasUrlTyped
field webOCWrapper

See Also

frmWordViewer Class


H Variable

Dim H As Integer

Source code

[Visual Basic]
    Dim H As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


MenuItem13 Variable

Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem13 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


StatusBar1 Variable

Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Source code

[Visual Basic]
    Friend WithEvents StatusBar1 As System.Windows.Forms.StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


ToolBar2 Variable

Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


W Variable

Dim W As Integer

Source code

[Visual Basic]
    Dim W As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


addressBar Variable

Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents addressBar As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


addressBarLbl Variable

Friend WithEvents addressBarLbl As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents addressBarLbl As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


contextMenu Variable

Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend Shadows WithEvents contextMenu As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


m_PrintFilename Variable

Dim m_PrintFilename As String

Source code

[Visual Basic]
    Dim m_PrintFilename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


m_printdokumentid Variable

Dim m_printdokumentid As String

Source code

[Visual Basic]
    Dim m_printdokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


m_showprintmessage Variable

Dim m_showprintmessage As Boolean = True

Source code

[Visual Basic]
    Dim m_showprintmessage As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


rm Variable

Private rm As ResourceManager

Source code

[Visual Basic]
    Private rm As ResourceManager

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


wasUrlTyped Variable

Private wasUrlTyped As Boolean = False

Source code

[Visual Basic]
    Private wasUrlTyped As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


webOCWrapper Variable

Friend WithEvents webOCWrapper As WebOCHostCtrl

Source code

[Visual Basic]
    Friend WithEvents webOCWrapper As WebOCHostCtrl

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmbcquestion Class

For a list of all members of this type, see frmbcquestion Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmbcquestion

Public Class frmbcquestion
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmbcquestion Members


frmbcquestion Members

frmbcquestion overview

Constructors

constructor frmbcquestion Constructor

Methods

method Button2_Click
method Dispose
method InitializeComponent

Fields

field Button1
field Button2
field Label1
field components

See Also

frmbcquestion Class


frmbcquestion Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


frmbcquestion Methods

frmbcquestion overview

Methods

method Button2_Click
method Dispose
method InitializeComponent

See Also

frmbcquestion Class


frmbcquestion.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Globals.bckdokument = True
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


frmbcquestion.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


frmbcquestion.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmbcquestion))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(344, 32)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Möchten Sie ein Dokument erstellen oder ein bestehendes Dokument mit einem Barcod" & _
        "e-Kleber versehen?"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button1.Location = New System.Drawing.Point(64, 72)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(96, 23)
        Me.Button1.TabIndex = 1
        Me.Button1.Text = "Normal"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.Abort
        Me.Button2.Location = New System.Drawing.Point(168, 72)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(96, 23)
        Me.Button2.TabIndex = 2
        Me.Button2.Text = "Barcodekleber"
        '
        'frmbcquestion
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(344, 109)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button2, Me.Button1, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmbcquestion"
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Barcode-Kleber"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


frmbcquestion Fields

frmbcquestion overview

Fields

field Button1
field Button2
field Label1
field components

See Also

frmbcquestion Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmbcquestion


frmblkundeMA Class

For a list of all members of this type, see frmblkundeMA Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmblkundeMA

Public Class frmblkundeMA
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmblkundeMA Members


frmblkundeMA Members

frmblkundeMA overview

Constructors

constructor frmblkundeMA Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmblkundeMA Class


frmblkundeMA Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA Properties

frmblkundeMA overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmblkundeMA Class


frmblkundeMA Methods

frmblkundeMA overview

Methods

method Dispose
method DomainList_AfterInsert
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method domainlist_aftercellupdate
method frmBLKunde_Load
method frmClose

See Also

frmblkundeMA Class


frmblkundeMA.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.DomainList_AfterInsert Method

Private Sub DomainList_AfterInsert( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles DomainList.AfterInsert

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub DomainList_AfterInsert(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DomainList.AfterInsert
        Dim i As Integer
        'Defaulwerte erstellt_am, mutiert_am, mutierer und aktiv setzen
        Try
            For i = 0 To DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then
                    Me.DomainList.Columns(i).Value = 1
                End If
                If Me.DomainList.Columns(i).DataField = "bl_periodische_auslieferung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
                If Me.DomainList.Columns(i).DataField = "banklagernd_erklaerung" Then
                    Me.DomainList.Columns(i).Value = 0
                End If
            Next
        Catch
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "EDEX_BL_BLKunde", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("blkundenr", "blkundenr"), New System.Data.Common.DataColumnMapping("NRPAR00", "NRPAR00"), New System.Data.Common.DataColumnMapping("partnertyp", "partnertyp"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung", "banklagernd_erklaerung"), New System.Data.Common.DataColumnMapping("banklagernd_erklaerung_vom", "banklagernd_erklaerung_vom"), New System.Data.Common.DataColumnMapping("bl_periodische_auslieferung", "bl_periodische_auslieferung")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_blkundema_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_blkundema_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_blkundema_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@blkundenr", System.Data.SqlDbType.Int, 4, "blkundenr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@NRPAR00", System.Data.SqlDbType.Int, 4, "NRPAR00"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnertyp", System.Data.SqlDbType.Int, 4, "partnertyp"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, "banklagernd_erklaerung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, "banklagernd_erklaerung_vom"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, "bl_periodische_auslieferung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_blkundema_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_blkundenr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "blkundenr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_NRPAR00", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "NRPAR00", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_banklagernd_erklaerung_vom", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "banklagernd_erklaerung_vom", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bl_periodische_auslieferung", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bl_periodische_auslieferung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnertyp", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnertyp", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shunb1;initial catalog=edoka;persist security info=False;user id=sa;w" & _
        "orkstation id=SHUMAIN;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'frmblkundeMA
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(896, 441)
        Me.Name = "frmblkundeMA"
        Me.Text = "Mitarbeiter verwalten"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.domainlist_aftercellupdate Method

Private Sub domainlist_aftercellupdate( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles DomainList.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub domainlist_aftercellupdate(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles DomainList.AfterColUpdate
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        Try
            For i = 0 To Me.DomainList.Columns.Count - 1
                If Me.DomainList.Columns(i).DataField = "mutiert_am" Then Me.DomainList.Columns(i).Value = Now
                If Me.DomainList.Columns(i).DataField = "mutierer" Then Me.DomainList.Columns(i).Value = Globals.MitarbeiterNr
                If Me.DomainList.Columns(i).DataField = "partnertyp" Then Me.DomainList.Columns(i).Value = 2
            Next

            'neuer DB-Key auslösen, sofern kein Key vorhanden ist
            If Me.DomainList.Columns(0).Value Is DBNull.Value Then
                Dim dbkey As New edokadb.clsMyKey_Tabelle()
                Dim key As Long
                dbkey.cpMainConnectionProvider = conn
                key = dbkey.get_dbkey(TableName)
                Me.DomainList.Columns(0).Value = key

                For i = 0 To Me.DomainList.Columns.Count - 1
                    If Me.DomainList.Columns(i).DataField = "mandantnr" Then
                        Me.DomainList.Columns(i).Value = Globals.MandantNr
                    End If
                Next
                dbkey.Dispose()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.frmBLKunde_Load Method

Private Sub frmBLKunde_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmBLKunde_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.DomainList.ScrollTips = True
        Me.TableName = "blkunde"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1.Tables(0)
        Me.DomainList.DataMember = Me.TableName

        Me.SpaltenTitel_Aktualisieren(Me.DataSet1)
        'DivFnkt.SpaltenTitel_Aktualisieren(Me.DomainList, Me.DataSet1.Tables(0), Me.tablename)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundeMA Fields

frmblkundeMA overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmblkundeMA Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundeMA


frmblkundenparameter Class

For a list of all members of this type, see frmblkundenparameter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmblkundenparameter

Public Class frmblkundenparameter
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmblkundenparameter Members


frmblkundenparameter Members

frmblkundenparameter overview

Constructors

constructor frmblkundenparameter Constructor

Properties

property NRPar00

Methods

method BtnHelp_Click
method CheckBox1_CheckedChanged
method Dispose
method InitializeComponent
method IsInputValid
method Last_Day_Of_Period
method ToolBar1_ButtonClick
method blkundenparameter_Load
method cbPeridiozitaetDetail_SelectedIndexChanged
method cbPeriodizitaet_SelectedIndexChanged
method cbblerklaerung_CheckedChanged
method dtgueltigbis_ValueChanged
method dtperiodischeAuslieferung_ValueChanged
method frmblkundenparameter_Closing
method get_bldata
method get_peridata
method get_periode
method save_bldata

Fields

field BtnHelp
field ContextMenu1
field GroupBox1
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MnuAdd
field MnuDel
field MnuUpd
field On_Load
field ToolBar1
field _naechsteAusfuehrung
field btnexit
field btnsave
field cbPeridiozitaetDetail
field cbPeriodizitaet
field cbblerklaerung
field cbhatPeriodischeAuslieferung
field components
field dtblerklaerung
field dterstmalsam
field dtgueltigbis
field dtperiodischeAuslieferung
field has_changes
field lblNaechteAusfuehrung
field lblPartner
field m_nrpar00
field tblblkunde
field tblperi
field txtPartner

See Also

frmblkundenparameter Class


frmblkundenparameter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter Properties

frmblkundenparameter overview

Properties

property NRPar00

See Also

frmblkundenparameter Class


frmblkundenparameter.NRPar00 Property

Property NRPar00() As Integer

Source code

[Visual Basic]
    Property NRPar00() As Integer
        Get
            Return m_nrpar00
        End Get
        Set(ByVal Value As Integer)
            m_nrpar00 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter Methods

frmblkundenparameter overview

Methods

method BtnHelp_Click
method CheckBox1_CheckedChanged
method Dispose
method InitializeComponent
method IsInputValid
method Last_Day_Of_Period
method ToolBar1_ButtonClick
method blkundenparameter_Load
method cbPeridiozitaetDetail_SelectedIndexChanged
method cbPeriodizitaet_SelectedIndexChanged
method cbblerklaerung_CheckedChanged
method dtgueltigbis_ValueChanged
method dtperiodischeAuslieferung_ValueChanged
method frmblkundenparameter_Closing
method get_bldata
method get_peridata
method get_periode
method save_bldata

See Also

frmblkundenparameter Class


frmblkundenparameter.BtnHelp_Click Method

Private Sub BtnHelp_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnHelp.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnHelp_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnHelp.Click
        Globals.HTMLHelp.ShowHelpToc("periodischeaushndigung")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.CheckBox1_CheckedChanged Method

Private Sub CheckBox1_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbhatPeriodischeAuslieferung.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub CheckBox1_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbhatPeriodischeAuslieferung.CheckedChanged
        If Me.cbhatPeriodischeAuslieferung.Checked = True Then
            Me.GroupBox3.Enabled = True
            Me.dtperiodischeAuslieferung.Enabled = True
            has_changes = True
        Else
            Me.GroupBox3.Enabled = False
            Me.dtperiodischeAuslieferung.Enabled = False
            has_changes = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmblkundenparameter))
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.btnexit = New System.Windows.Forms.ToolBarButton()
        Me.btnsave = New System.Windows.Forms.ToolBarButton()
        Me.lblPartner = New System.Windows.Forms.Label()
        Me.txtPartner = New System.Windows.Forms.TextBox()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.cbblerklaerung = New System.Windows.Forms.CheckBox()
        Me.dtblerklaerung = New System.Windows.Forms.DateTimePicker()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.dtperiodischeAuslieferung = New System.Windows.Forms.DateTimePicker()
        Me.GroupBox3 = New System.Windows.Forms.GroupBox()
        Me.lblNaechteAusfuehrung = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.dterstmalsam = New System.Windows.Forms.DateTimePicker()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.cbPeridiozitaetDetail = New System.Windows.Forms.ComboBox()
        Me.cbPeriodizitaet = New System.Windows.Forms.ComboBox()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.dtgueltigbis = New System.Windows.Forms.DateTimePicker()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.cbhatPeriodischeAuslieferung = New System.Windows.Forms.CheckBox()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MnuAdd = New System.Windows.Forms.MenuItem()
        Me.MnuDel = New System.Windows.Forms.MenuItem()
        Me.MnuUpd = New System.Windows.Forms.MenuItem()
        Me.GroupBox4 = New System.Windows.Forms.GroupBox()
        Me.BtnHelp = New System.Windows.Forms.Button()
        Me.GroupBox1.SuspendLayout()
        Me.GroupBox3.SuspendLayout()
        Me.GroupBox4.SuspendLayout()
        Me.SuspendLayout()
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.btnexit, Me.btnsave})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(448, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'btnexit
        '
        Me.btnexit.ImageIndex = 0
        '
        'btnsave
        '
        Me.btnsave.ImageIndex = 1
        '
        'lblPartner
        '
        Me.lblPartner.Location = New System.Drawing.Point(8, 40)
        Me.lblPartner.Name = "lblPartner"
        Me.lblPartner.Size = New System.Drawing.Size(56, 23)
        Me.lblPartner.TabIndex = 1
        Me.lblPartner.Text = "Partner:"
        '
        'txtPartner
        '
        Me.txtPartner.BackColor = System.Drawing.Color.White
        Me.txtPartner.Location = New System.Drawing.Point(64, 40)
        Me.txtPartner.Name = "txtPartner"
        Me.txtPartner.ReadOnly = True
        Me.txtPartner.Size = New System.Drawing.Size(376, 20)
        Me.txtPartner.TabIndex = 2
        Me.txtPartner.Text = ""
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.cbblerklaerung, Me.dtblerklaerung})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 256)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(432, 64)
        Me.GroupBox1.TabIndex = 3
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Banklagernd-Erklärung"
        Me.GroupBox1.Visible = False
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(224, 26)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(80, 16)
        Me.Label1.TabIndex = 3
        Me.Label1.Text = "Vertragsdatum"
        '
        'cbblerklaerung
        '
        Me.cbblerklaerung.Location = New System.Drawing.Point(16, 22)
        Me.cbblerklaerung.Name = "cbblerklaerung"
        Me.cbblerklaerung.Size = New System.Drawing.Size(192, 24)
        Me.cbblerklaerung.TabIndex = 2
        Me.cbblerklaerung.Text = "Der Kunde hat eine BL-Erklärung"
        '
        'dtblerklaerung
        '
        Me.dtblerklaerung.Enabled = False
        Me.dtblerklaerung.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtblerklaerung.Location = New System.Drawing.Point(320, 24)
        Me.dtblerklaerung.Name = "dtblerklaerung"
        Me.dtblerklaerung.Size = New System.Drawing.Size(96, 20)
        Me.dtblerklaerung.TabIndex = 1
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(243, 30)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(80, 16)
        Me.Label5.TabIndex = 6
        Me.Label5.Text = "Auftragsdatum"
        '
        'dtperiodischeAuslieferung
        '
        Me.dtperiodischeAuslieferung.Enabled = False
        Me.dtperiodischeAuslieferung.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtperiodischeAuslieferung.Location = New System.Drawing.Point(328, 28)
        Me.dtperiodischeAuslieferung.Name = "dtperiodischeAuslieferung"
        Me.dtperiodischeAuslieferung.Size = New System.Drawing.Size(96, 20)
        Me.dtperiodischeAuslieferung.TabIndex = 5
        '
        'GroupBox3
        '
        Me.GroupBox3.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblNaechteAusfuehrung, Me.Label6, Me.dterstmalsam, Me.Label4, Me.cbPeridiozitaetDetail, Me.cbPeriodizitaet, Me.Label3, Me.dtgueltigbis, Me.Label2})
        Me.GroupBox3.Enabled = False
        Me.GroupBox3.Location = New System.Drawing.Point(8, 144)
        Me.GroupBox3.Name = "GroupBox3"
        Me.GroupBox3.Size = New System.Drawing.Size(432, 104)
        Me.GroupBox3.TabIndex = 4
        Me.GroupBox3.TabStop = False
        Me.GroupBox3.Text = "Regelungen"
        '
        'lblNaechteAusfuehrung
        '
        Me.lblNaechteAusfuehrung.Location = New System.Drawing.Point(328, 24)
        Me.lblNaechteAusfuehrung.Name = "lblNaechteAusfuehrung"
        Me.lblNaechteAusfuehrung.Size = New System.Drawing.Size(88, 16)
        Me.lblNaechteAusfuehrung.TabIndex = 21
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(216, 24)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(112, 16)
        Me.Label6.TabIndex = 20
        Me.Label6.Text = "Nächste Ausführung:"
        '
        'dterstmalsam
        '
        Me.dterstmalsam.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dterstmalsam.Location = New System.Drawing.Point(128, 24)
        Me.dterstmalsam.Name = "dterstmalsam"
        Me.dterstmalsam.Size = New System.Drawing.Size(80, 20)
        Me.dterstmalsam.TabIndex = 19
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 24)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(72, 24)
        Me.Label4.TabIndex = 18
        Me.Label4.Text = "erstmals am:"
        '
        'cbPeridiozitaetDetail
        '
        Me.cbPeridiozitaetDetail.Enabled = False
        Me.cbPeridiozitaetDetail.Items.AddRange(New Object() {"Immer am gewählten Datum", "Immer am letzten Tag des Zeitraumes"})
        Me.cbPeridiozitaetDetail.Location = New System.Drawing.Point(216, 48)
        Me.cbPeridiozitaetDetail.Name = "cbPeridiozitaetDetail"
        Me.cbPeridiozitaetDetail.Size = New System.Drawing.Size(192, 21)
        Me.cbPeridiozitaetDetail.TabIndex = 17
        '
        'cbPeriodizitaet
        '
        Me.cbPeriodizitaet.DropDownStyle = System.Windows.Forms.ComboBoxStyle.DropDownList
        Me.cbPeriodizitaet.Location = New System.Drawing.Point(128, 48)
        Me.cbPeriodizitaet.Name = "cbPeriodizitaet"
        Me.cbPeriodizitaet.Size = New System.Drawing.Size(80, 21)
        Me.cbPeriodizitaet.TabIndex = 16
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 48)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(64, 24)
        Me.Label3.TabIndex = 15
        Me.Label3.Text = "Periodizität"
        '
        'dtgueltigbis
        '
        Me.dtgueltigbis.Format = System.Windows.Forms.DateTimePickerFormat.Short
        Me.dtgueltigbis.Location = New System.Drawing.Point(128, 72)
        Me.dtgueltigbis.Name = "dtgueltigbis"
        Me.dtgueltigbis.Size = New System.Drawing.Size(80, 20)
        Me.dtgueltigbis.TabIndex = 14
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 72)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(120, 24)
        Me.Label2.TabIndex = 13
        Me.Label2.Text = "Regelung gültig bis"
        '
        'cbhatPeriodischeAuslieferung
        '
        Me.cbhatPeriodischeAuslieferung.Location = New System.Drawing.Point(8, 24)
        Me.cbhatPeriodischeAuslieferung.Name = "cbhatPeriodischeAuslieferung"
        Me.cbhatPeriodischeAuslieferung.Size = New System.Drawing.Size(240, 24)
        Me.cbhatPeriodischeAuslieferung.TabIndex = 3
        Me.cbhatPeriodischeAuslieferung.Text = "Kunde hat eine periodische Aushändigung"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MnuAdd, Me.MnuDel, Me.MnuUpd})
        '
        'MnuAdd
        '
        Me.MnuAdd.Index = 0
        Me.MnuAdd.Text = "&Periodische Auslieferung hinzufügen"
        '
        'MnuDel
        '
        Me.MnuDel.Index = 1
        Me.MnuDel.Text = "Periodische Auslieferung &löschen"
        '
        'MnuUpd
        '
        Me.MnuUpd.Index = 2
        Me.MnuUpd.Text = "&Periodische Auslieferung ändern"
        '
        'GroupBox4
        '
        Me.GroupBox4.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label5, Me.cbhatPeriodischeAuslieferung, Me.dtperiodischeAuslieferung})
        Me.GroupBox4.Location = New System.Drawing.Point(8, 72)
        Me.GroupBox4.Name = "GroupBox4"
        Me.GroupBox4.Size = New System.Drawing.Size(432, 64)
        Me.GroupBox4.TabIndex = 5
        Me.GroupBox4.TabStop = False
        Me.GroupBox4.Text = "Auftrag"
        '
        'BtnHelp
        '
        Me.BtnHelp.Anchor = (System.Windows.Forms.AnchorStyles.Top Or System.Windows.Forms.AnchorStyles.Right)
        Me.BtnHelp.Image = CType(resources.GetObject("BtnHelp.Image"), System.Drawing.Bitmap)
        Me.BtnHelp.Location = New System.Drawing.Point(424, 3)
        Me.BtnHelp.Name = "BtnHelp"
        Me.BtnHelp.Size = New System.Drawing.Size(24, 23)
        Me.BtnHelp.TabIndex = 70
        '
        'frmblkundenparameter
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(448, 253)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnHelp, Me.GroupBox4, Me.GroupBox1, Me.txtPartner, Me.lblPartner, Me.ToolBar1, Me.GroupBox3})
        Me.FormBorderStyle = System.Windows.Forms.FormBorderStyle.FixedSingle
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmblkundenparameter"
        Me.ShowInTaskbar = False
        Me.StartPosition = System.Windows.Forms.FormStartPosition.CenterScreen
        Me.Text = "Periodische Aushändigung"
        Me.GroupBox1.ResumeLayout(False)
        Me.GroupBox3.ResumeLayout(False)
        Me.GroupBox4.ResumeLayout(False)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.IsInputValid Method

Private Function IsInputValid() As Boolean

Source code

[Visual Basic]
    Private Function IsInputValid() As Boolean
        Try
            Dim s As String = ""

            '1) Wenn die Box "Kunde hat periodische Aushändigung" aktiv ist, soll der Dialog nur verlassen werden dürfen, wenn:
            If cbhatPeriodischeAuslieferung.Checked Then
                If Not IsNothing(_naechsteAusfuehrung) Then
                    'wenn das Datum "erstmals am" grösser ist als das aktuelle Tagesdatum
                    If dterstmalsam.Value.Date <= DateTime.Today Then
                        If s.Length > 1 Then s = s + vbCrLf
                        s = s + "- Das 'erstmals am' muss grösser sein als das aktuelle Datum"
                        dterstmalsam.Focus()
                    End If
                End If

                'wenn eine Peridiozität ausgewählt wurde
                If IsNothing(cbPeriodizitaet.SelectedValue) Then
                    If s.Length > 1 Then s = s + vbCrLf
                    s = s + "- Es muss eine Periodizität ausgewhält werden"
                    dterstmalsam.Focus()
                End If

                If Me.dtperiodischeAuslieferung.Value > Me.dtgueltigbis.Value Then
                    If s.Length > 1 Then s = s + vbCrLf
                    s = s + "- Das Auftragsdatum kann nicht grösser als das Gültigbis-Datum sein."
                    Me.dtperiodischeAuslieferung.Focus()
                End If
                If Me.dtperiodischeAuslieferung.Value > Me.dterstmalsam.Value Then
                    If s.Length > 1 Then s = s + vbCrLf
                    s = s + "- Das Auftragsdatum kann nicht grösser als das 'Erstmals am'-Datum sein"
                    Me.dtperiodischeAuslieferung.Focus()
                End If

                If Me.dterstmalsam.Value >= Me.dtgueltigbis.Value Then
                    If s.Length > 1 Then s = s + vbCrLf
                    s = s + "Das Datum 'Erstmals am' liegt nach dem Gültig-Bis-Datum."
                End If
            End If

            If s.Length > 0 Then
                s = "Folgende Fehler sind vorhanden:" + vbCrLf + s
                MsgBox(s, MsgBoxStyle.Critical)
                Return False
            Else
                Return True
            End If

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmblkundenparameter.ValidateInput: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.Last_Day_Of_Period Method

Private Function Last_Day_Of_Period( _
   ByVal Datum As DateTime _
) As Boolean

Parameters

Datum
Required.

Source code

[Visual Basic]
    Private Function Last_Day_Of_Period(ByVal Datum As DateTime) As Boolean
        Dim mm As Integer
        Dim dttemp As DateTime
        mm = Month(Me.dterstmalsam.Value)
        dttemp = Me.dterstmalsam.Value
        dttemp = Me.dterstmalsam.Value.AddDays(1)
        If Month(dttemp) <> Month(Me.dterstmalsam.Value) Then
            Return True
        Else
            Return False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0			 'Exit
                Close()
            Case 1
                If IsInputValid() Then
                    Me.save_bldata()
                End If
        End Select

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.blkundenparameter_Load Method

Private Sub blkundenparameter_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub blkundenparameter_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim xdata As New DataTable()
        xdata = get_periode()
        Me.cbPeriodizitaet.DataSource = xdata
        Me.cbPeriodizitaet.DisplayMember = "Periode"
        Me.cbPeriodizitaet.ValueMember = "periodenr"
        Me.tblperi = get_peridata()
        If Me.tblperi.Rows.Count > 0 Then
            Me.cbhatPeriodischeAuslieferung.Checked = True
            Me.dterstmalsam.Value = Me.tblperi.Rows(0).Item("erstmals_am")
            Me.dtgueltigbis.Value = Me.tblperi.Rows(0).Item("ende")
            Try
                Me.cbPeriodizitaet.SelectedValue = Me.tblperi.Rows(0).Item("intervall")
            Catch
                Me.cbPeriodizitaet.SelectedValue = 5
            End Try
            Dim i As Integer
            Try
                i = Me.tblperi.Rows(0).Item("intervall1")
                Me.cbPeridiozitaetDetail.SelectedIndex = i - 1
            Catch
            End Try
            Try
                Me.dtperiodischeAuslieferung.Value = tblperi.Rows(0).Item("auftragsdatum")
                If Not tblperi.Rows(0)("naechstes_ereignis") Is DBNull.Value Then
                    _naechsteAusfuehrung = Convert.ToDateTime(tblperi.Rows(0)("naechstes_ereignis"))
                    lblNaechteAusfuehrung.Text = _naechsteAusfuehrung.ToShortDateString()
                End If
            Catch
            End Try
        Else
            Me.cbhatPeriodischeAuslieferung.Checked = False
            Dim dt As DateTime
            dt = DateAdd(DateInterval.Day, 1, Now)
            Me.dterstmalsam.Value = dt
            dt = DateAdd(DateInterval.Year, 1, dt)
            Me.dtgueltigbis.Value = dt
            Me.cbPeriodizitaet.SelectedValue = 6

        End If

        'beim Starten werden noch keine änderungen gemacht
        has_changes = False

        Me.On_Load = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.cbPeridiozitaetDetail_SelectedIndexChanged Method

Private Sub cbPeridiozitaetDetail_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbPeridiozitaetDetail.SelectedIndexChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbPeridiozitaetDetail_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbPeridiozitaetDetail.SelectedIndexChanged
        If Me.On_Load = True Then Exit Sub
        has_changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.cbPeriodizitaet_SelectedIndexChanged Method

Private Sub cbPeriodizitaet_SelectedIndexChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbPeriodizitaet.SelectedIndexChanged, _
   dterstmalsam.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbPeriodizitaet_SelectedIndexChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbPeriodizitaet.SelectedIndexChanged, dterstmalsam.ValueChanged
        If Me.On_Load = True Then Exit Sub
        has_changes = True
        Try
            Dim s As String
            s = Me.cbPeriodizitaet.Text
            Select Case s
                Case "monatlich", "zwei-monatlich", "viertel-jährlich", "viertel-jährlich", "halb-jährlich"
                    If Me.Last_Day_Of_Period(Me.dterstmalsam.Value) Then
                        Me.cbPeridiozitaetDetail.Enabled = True
                        Me.cbPeridiozitaetDetail.SelectedIndex = 1
                    Else
                        Me.cbPeridiozitaetDetail.Enabled = False
                        Me.cbPeridiozitaetDetail.SelectedIndex = -1
                        Me.cbPeridiozitaetDetail.SelectedText = ""
                    End If
                Case Else
                    Me.cbPeridiozitaetDetail.Enabled = False
                    Me.cbPeridiozitaetDetail.SelectedIndex = -1
                    Me.cbPeridiozitaetDetail.SelectedText = ""
            End Select
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.cbblerklaerung_CheckedChanged Method

Private Sub cbblerklaerung_CheckedChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles cbblerklaerung.CheckedChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cbblerklaerung_CheckedChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles cbblerklaerung.CheckedChanged
        If Me.cbblerklaerung.Checked = True Then Me.dtblerklaerung.Enabled = True Else Me.dtblerklaerung.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.dtgueltigbis_ValueChanged Method

Private Sub dtgueltigbis_ValueChanged( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles dtgueltigbis.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub dtgueltigbis_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles dtgueltigbis.ValueChanged
        If Me.On_Load = True Then Exit Sub
        has_changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.dtperiodischeAuslieferung_ValueChanged Method

Private Sub dtperiodischeAuslieferung_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles dtperiodischeAuslieferung.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub dtperiodischeAuslieferung_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles dtperiodischeAuslieferung.ValueChanged
        has_changes = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.frmblkundenparameter_Closing Method

Private Sub frmblkundenparameter_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmblkundenparameter_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing

        If has_changes Then
            Dim ret As DialogResult
            ret = MessageBox.Show("Die Daten wurden verändert. Möchten Sie die Änderungen speichern?", "Änderungen Speichern", MessageBoxButtons.YesNo, MessageBoxIcon.Question)
            If ret = DialogResult.Yes Then
                If IsInputValid() Then
                    save_bldata()
                Else
                    'input ist ungültig
                    e.Cancel = True
                End If
            End If
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.get_bldata Method

Private Function get_bldata( _
   ByVal nrpar00 As Integer _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function get_bldata(ByVal nrpar00 As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_bldata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.get_peridata Method

Private Function get_peridata() As DataTable

Source code

[Visual Basic]
    Private Function get_peridata() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_peridata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@blkundenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.NRPar00))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.get_periode Method

Private Function get_periode() As DataTable

Source code

[Visual Basic]
    Private Function get_periode() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_get_periode"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter.save_bldata Method

Private Function save_bldata()

Source code

[Visual Basic]
    Private Function save_bldata()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_edex_bl_save_bldata"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, NRPar00))
            If Me.cbhatPeriodischeAuslieferung.Checked = False Then
                scmCmdToExecute.Parameters.Add(New SqlParameter("@periauftrag", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dtperiodischeAuslieferung.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@periode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@erstmal", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dterstmalsam.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@gueltig", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dtgueltigbis.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Periodizitaet", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Periodizitaetdetail", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
            Else
                scmCmdToExecute.Parameters.Add(New SqlParameter("@periauftrag", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dtperiodischeAuslieferung.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@periode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@erstmal", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dterstmalsam.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@gueltig", SqlDbType.DateTime, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dtgueltigbis.Value))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Periodizitaet", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.cbPeriodizitaet.Text))
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Periodizitaetdetail", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.cbPeridiozitaetDetail.Items(Me.cbPeridiozitaetDetail.SelectedIndex)))
                Catch
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@Periodizitaetdetail", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                End Try
            End If
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))

            sdaAdapter.Fill(dtToReturn)

            has_changes = False

            Return dtToReturn
        Catch ex As Exception
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
            dtToReturn.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmblkundenparameter Fields

frmblkundenparameter overview

Fields

field BtnHelp
field ContextMenu1
field GroupBox1
field GroupBox3
field GroupBox4
field ImageList1
field Label1
field Label2
field Label3
field Label4
field Label5
field Label6
field MnuAdd
field MnuDel
field MnuUpd
field On_Load
field ToolBar1
field _naechsteAusfuehrung
field btnexit
field btnsave
field cbPeridiozitaetDetail
field cbPeriodizitaet
field cbblerklaerung
field cbhatPeriodischeAuslieferung
field components
field dtblerklaerung
field dterstmalsam
field dtgueltigbis
field dtperiodischeAuslieferung
field has_changes
field lblNaechteAusfuehrung
field lblPartner
field m_nrpar00
field tblblkunde
field tblperi
field txtPartner

See Also

frmblkundenparameter Class


BtnHelp Variable

Friend WithEvents BtnHelp As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents BtnHelp As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


GroupBox3 Variable

Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox3 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


GroupBox4 Variable

Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox4 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


MnuAdd Variable

Friend WithEvents MnuAdd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuAdd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


MnuDel Variable

Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuDel As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


MnuUpd Variable

Friend WithEvents MnuUpd As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MnuUpd As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


On_Load Variable

Dim On_Load As Boolean = True

Source code

[Visual Basic]
    Dim On_Load As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


_naechsteAusfuehrung Variable

Private _naechsteAusfuehrung As DateTime

Source code

[Visual Basic]
    Private _naechsteAusfuehrung As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


btnexit Variable

Friend WithEvents btnexit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnexit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


btnsave Variable

Friend WithEvents btnsave As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents btnsave As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


cbPeridiozitaetDetail Variable

Friend WithEvents cbPeridiozitaetDetail As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPeridiozitaetDetail As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


cbPeriodizitaet Variable

Friend WithEvents cbPeriodizitaet As System.Windows.Forms.ComboBox

Source code

[Visual Basic]
    Friend WithEvents cbPeriodizitaet As System.Windows.Forms.ComboBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


cbblerklaerung Variable

Friend WithEvents cbblerklaerung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbblerklaerung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


cbhatPeriodischeAuslieferung Variable

Friend WithEvents cbhatPeriodischeAuslieferung As System.Windows.Forms.CheckBox

Source code

[Visual Basic]
    Friend WithEvents cbhatPeriodischeAuslieferung As System.Windows.Forms.CheckBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


dtblerklaerung Variable

Friend WithEvents dtblerklaerung As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtblerklaerung As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


dterstmalsam Variable

Friend WithEvents dterstmalsam As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dterstmalsam As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


dtgueltigbis Variable

Friend WithEvents dtgueltigbis As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtgueltigbis As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


dtperiodischeAuslieferung Variable

Friend WithEvents dtperiodischeAuslieferung As System.Windows.Forms.DateTimePicker

Source code

[Visual Basic]
    Friend WithEvents dtperiodischeAuslieferung As System.Windows.Forms.DateTimePicker

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


has_changes Variable

Dim has_changes As Boolean = False

Source code

[Visual Basic]
    Dim has_changes As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


lblNaechteAusfuehrung Variable

Friend WithEvents lblNaechteAusfuehrung As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblNaechteAusfuehrung As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


lblPartner Variable

Friend WithEvents lblPartner As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblPartner As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


m_nrpar00 Variable

Dim m_nrpar00 As Integer

Source code

[Visual Basic]
    Dim m_nrpar00 As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


tblblkunde Variable

Dim tblblkunde As New DataTable()

Source code

[Visual Basic]
    Dim tblblkunde As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


tblperi Variable

Dim tblperi As New DataTable()

Source code

[Visual Basic]
    Dim tblperi As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


txtPartner Variable

Friend WithEvents txtPartner As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtPartner As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmblkundenparameter


frmcoldindx Class

For a list of all members of this type, see frmcoldindx Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.frmcoldindx

Public Class frmcoldindx
   Inherits EDOKA.frmRelEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmcoldindx Members


frmcoldindx Members

frmcoldindx overview

Constructors

constructor frmcoldindx Constructor

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmcoldindx Class


frmcoldindx Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx Properties

frmcoldindx overview

Properties

property Eintrag (inherited from EDOKAApp.EDOKA.frmRelEditor)
property Eintragnr (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property KeyRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
property TableNameRight (inherited from EDOKAApp.EDOKA.frmRelEditor)

See Also

frmcoldindx Class


frmcoldindx Methods

frmcoldindx overview

Methods

method BtnConnect_Click_1
method Dispose
method FormSize (inherited from EDOKAApp.EDOKA.frmRelEditor)
method InitializeComponent
method Insert_TBBottom
method LoadData
method MenuItem2_Click
method MenuItem3_Click
method Refresh_TBBottom
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Format (inherited from EDOKAApp.EDOKA.frmRelEditor)
method TBBottom_Update
method TBLeft_Click
method TBRight_Click
method ToolBar1_ButtonClick
method UpdateGrpText (inherited from EDOKAApp.EDOKA.frmRelEditor)
method check_changes
method frmClose
method frmRolle_SysadminFunktion_Load

See Also

frmcoldindx Class


frmcoldindx.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click
        Insert_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.SqlDataAdapter2 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.DataSet1 = New System.Data.DataSet()
        Me.DataSet2 = New System.Data.DataSet()
        Me.DataSet3 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand2 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "cold_folder", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("Cold_Folder_Nr", "Cold_Folder_Nr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("batch_parameter", "batch_parameter"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'SqlDataAdapter2
        '
        Me.SqlDataAdapter2.DeleteCommand = Me.SqlDeleteCommand2
        Me.SqlDataAdapter2.InsertCommand = Me.SqlInsertCommand2
        Me.SqlDataAdapter2.SelectCommand = Me.SqlSelectCommand2
        Me.SqlDataAdapter2.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "cold_indexfeld", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("indexfeldnr", "indexfeldnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("format", "format"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter2.UpdateCommand = Me.SqlUpdateCommand2
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "coldindex", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("coldindexnr", "coldindexnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("zwingend", "zwingend"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer"), New System.Data.Common.DataColumnMapping("cold_indexfeldnr", "cold_indexfeldnr"), New System.Data.Common.DataColumnMapping("cold_foldernr", "cold_foldernr")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet2
        '
        Me.DataSet2.DataSetName = "NewDataSet"
        Me.DataSet2.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_cold_folder_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_cold_folder_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Cold_Folder_Nr", System.Data.SqlDbType.Int, 4, "Cold_Folder_Nr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@batch_parameter", System.Data.SqlDbType.VarChar, 255, "batch_parameter"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_cold_folder_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Cold_Folder_Nr", System.Data.SqlDbType.Int, 4, "Cold_Folder_Nr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@batch_parameter", System.Data.SqlDbType.VarChar, 255, "batch_parameter"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Cold_Folder_Nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Cold_Folder_Nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_batch_parameter", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "batch_parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_cold_folder_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_Cold_Folder_Nr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "Cold_Folder_Nr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_batch_parameter", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "batch_parameter", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlSelectCommand2
        '
        Me.SqlSelectCommand2.CommandText = "[pv_cold_indexfeld_select]"
        Me.SqlSelectCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand2.Connection = Me.SqlConnection1
        Me.SqlSelectCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand2
        '
        Me.SqlInsertCommand2.CommandText = "[pv_cold_indexfeld_insert]"
        Me.SqlInsertCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand2.Connection = Me.SqlConnection1
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexfeldnr", System.Data.SqlDbType.Int, 4, "indexfeldnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 255, "format"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand2
        '
        Me.SqlUpdateCommand2.CommandText = "[pv_cold_indexfeld_update]"
        Me.SqlUpdateCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand2.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@indexfeldnr", System.Data.SqlDbType.Int, 4, "indexfeldnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@format", System.Data.SqlDbType.VarChar, 255, "format"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand2
        '
        Me.SqlDeleteCommand2.CommandText = "[pv_cold_indexfeld_delete]"
        Me.SqlDeleteCommand2.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand2.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_format", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "format", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand2.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[sp_coldindex_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Fokus", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Key", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(10, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_coldindex_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldindexnr", System.Data.SqlDbType.Int, 4, "coldindexnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zwingend", System.Data.SqlDbType.Bit, 1, "zwingend"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_indexfeldnr", System.Data.SqlDbType.Int, 4, "cold_indexfeldnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_foldernr", System.Data.SqlDbType.Int, 4, "cold_foldernr"))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_coldindex_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@coldindexnr", System.Data.SqlDbType.Int, 4, "coldindexnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@zwingend", System.Data.SqlDbType.Bit, 1, "zwingend"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_indexfeldnr", System.Data.SqlDbType.Int, 4, "cold_indexfeldnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@cold_foldernr", System.Data.SqlDbType.Int, 4, "cold_foldernr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldindexnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldindexnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_foldernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_foldernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zwingend", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_coldindex_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_coldindexnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "coldindexnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_foldernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_foldernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_cold_indexfeldnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "cold_indexfeldnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_zwingend", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "zwingend", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmcoldindx
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(600, 509)
        Me.Name = "frmcoldindx"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.Insert_TBBottom Method

Private Sub Insert_TBBottom()

Source code

[Visual Basic]
    Private Sub Insert_TBBottom()
        Dim iLeft As Integer
        Dim iRigth As Integer
        Dim ic, i As Integer
        Dim colRows As C1.Win.C1TrueDBGrid.SelectedRowCollection
        Dim vdata As New edokadb.clsColdindex()
        Dim dbkey As New edokadb.clsMyKey_Tabelle()
        Dim Currentsel As Boolean
        Dim key As Long

        iLeft = Me.TBLeft.SelectedRows.Count
        iRigth = Me.TBRight.SelectedRows.Count
        If (Me.FokusLeft.Checked And iLeft > 1) Or (Me.FokusRight.Checked And iRigth > 1) Then
            Globals.MyMsg.show_standardmessage(4, MsgBoxStyle.Exclamation)
            Exit Sub
        End If
        If Me.FokusLeft.Checked Then
            ic = iRigth
            colRows = Me.TBRight.SelectedRows
        Else
            ic = iLeft
            colRows = Me.TBLeft.SelectedRows
        End If
        If ic = 0 Then
            ic = ic + 1
            Currentsel = True
        End If
        For i = 0 To ic - 1
            vdata.bAktiv = New SqlBoolean(CType(True, Boolean))
            vdata.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
            vdata.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
            vdata.iMandantnr = New SqlInt32(CType(Globals.MandantNr, Int32))
            vdata.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
            If Me.FokusLeft.Checked Then
                vdata.iCold_foldernr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                If Currentsel Then
                    vdata.iCold_indexfeldnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
                Else
                    vdata.iCold_indexfeldnr = New SqlInt32(CType(Me.TBRight.Columns(0).CellValue(colRows(i)), Int32))
                End If
            Else
                If Currentsel Then
                    vdata.iCold_foldernr = New SqlInt32(CType(Me.TBLeft.Columns(0).Value, Int32))
                Else
                    vdata.iCold_indexfeldnr = New SqlInt32(CType(Me.TBLeft.Columns(0).CellValue(colRows(i)), Int32))
                End If

                vdata.iCold_indexfeldnr = New SqlInt32(CType(Me.TBRight.Columns(0).Value, Int32))
            End If
            vdata.sBeschreibung = New SqlString(CType("", String))
            vdata.sBeschreibung = New SqlString(CType("", String))
            vdata.bZwingend = New SqlBoolean(CType(True, Boolean))
            dbkey.cpMainConnectionProvider = conn
            key = dbkey.get_dbkey("coldindex")
            vdata.iColdindexnr = New SqlInt32(CType(key, Int32))
            vdata.cpMainConnectionProvider = conn
            conn.OpenConnection()
            vdata.Insert()
            conn.CloseConnection(True)
        Next
        vdata.Dispose()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.LoadData Method

Public Sub LoadData()

Source code

[Visual Basic]
    Public Sub LoadData()
        Dim dbconn As New EDOKA.DB_Connection()
        Dim i As Integer

        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.TBLeft.DataSource = Me.DataSet1
        Me.TBLeft.DataMember = Me.TableNameLeft

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter2.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter2.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter2.Fill(Me.DataSet2)
        Me.TBRight.DataSource = Me.DataSet2
        Me.TBRight.DataMember = Me.TableNameRight
        SpaltenTitel_Aktualisieren(1, Me.TableNameLeft, Me.DataSet1)
        SpaltenTitel_Aktualisieren(2, Me.TableNameRight, Me.DataSet2)
        UpdateGrpText(5008, 5009, 5010)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.MenuItem2_Click Method

Private Sub MenuItem2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.Refresh_TBBottom Method

Public Sub Refresh_TBBottom()

Source code

[Visual Basic]
    Public Sub Refresh_TBBottom()
        Me.SqlDataAdapter3.SelectCommand.Parameters.Clear()
        If Me.FokusLeft.Checked Then
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 1)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBLeft.Columns(0).Value)
        Else
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Fokus", 2)
            Me.SqlDataAdapter3.SelectCommand.Parameters.Add("@Key", Me.TBRight.Columns(0).Value)
        End If
        Try
            Me.DataSet3.Clear()
            Me.SqlDataAdapter3.Fill(Me.DataSet3)
        Catch ex As Exception
        End Try

        Me.TBBottom.DataSource = Me.DataSet3
        Me.TBBottom.DataMember = Me.TableNameBottom
        SpaltenTitel_Aktualisieren(3, Me.TableNameBottom, Me.DataSet3)
        TBBottom_Format()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter3.Update(Me.DataSet3)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.TBBottom_Update Method

Private Sub TBBottom_Update( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles TBBottom.AfterColEdit

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBBottom_Update(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles TBBottom.AfterColEdit
        'Aktualisieren von Mutierer und Mutiert_am
        Dim i As Integer
        For i = 0 To Me.TBBottom.Columns.Count - 1
            If Me.TBBottom.Columns(i).DataField = "mutiert_am" Then Me.TBBottom.Columns(i).Value = Now
            If Me.TBBottom.Columns(i).DataField = "mutierer" Then Me.TBBottom.Columns(i).Value = Globals.MitarbeiterNr
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.TBLeft_Click Method

Private Sub TBLeft_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBLeft.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBLeft_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBLeft.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.TBRight_Click Method

Private Sub TBRight_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs _
) Handles TBRight.RowColChange

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub TBRight_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.RowColChangeEventArgs) Handles TBRight.RowColChange
        check_changes()
        Refresh_TBBottom()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
            Case Else
                Throw New Exception(MyMsg.Get_Meldungstext(901))
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.check_changes Method

Private Sub check_changes()

Source code

[Visual Basic]
    Private Sub check_changes()
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNo(2)
            If msg = MsgBoxResult.Yes Then
                Save_Data()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet3.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx.frmRolle_SysadminFunktion_Load Method

Private Sub frmRolle_SysadminFunktion_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmRolle_SysadminFunktion_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Cursor.Current = Cursors.WaitCursor
        Me.TableNameLeft = "cold_folder"
        Me.TableNameRight = "cold_indexfeld"
        Me.TableNameBottom = "coldindex"
        LoadData()
        Cursor.Current = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldindx Fields

frmcoldindx overview

Fields

field BtnConnect (inherited from EDOKAApp.EDOKA.frmRelEditor)
field DataSet1
field DataSet2
field DataSet3
field FokusLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field FokusRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpFocus (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field GrpRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ImageList1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Label1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MainMenu1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field MenuItem3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel3 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel4 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Panel5 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field Splitter2 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter2
field SqlDataAdapter3
field SqlDeleteCommand1
field SqlDeleteCommand2
field SqlDeleteCommand3
field SqlInsertCommand1
field SqlInsertCommand2
field SqlInsertCommand3
field SqlSelectCommand1
field SqlSelectCommand2
field SqlSelectCommand3
field SqlUpdateCommand1
field SqlUpdateCommand2
field SqlUpdateCommand3
field TBBottom (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBLeft (inherited from EDOKAApp.EDOKA.frmRelEditor)
field TBRight (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBar1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarBtnSave (inherited from EDOKAApp.EDOKA.frmRelEditor)
field ToolBarButton1 (inherited from EDOKAApp.EDOKA.frmRelEditor)
field components

See Also

frmcoldindx Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


DataSet2 Variable

Friend WithEvents DataSet2 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet2 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDataAdapter2 Variable

Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter2 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDeleteCommand2 Variable

Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlInsertCommand2 Variable

Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlSelectCommand2 Variable

Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlUpdateCommand2 Variable

Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand2 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldindx


frmcoldview Class

For a list of all members of this type, see frmcoldview Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmcoldview

Public Class frmcoldview
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmcoldview Members


frmcoldview Members

frmcoldview overview

Constructors

constructor frmcoldview Constructor

Properties

property Auftragnr
property Colddokumentid
property CurrentPage
property DocNotFound
property DokumentId
property Dokumenttyp
property Erstellungsdatum
property PartnerNr
property PrintIt
property UVMZVDokumenttyp
property belegart
property k
property o
property zf

Methods

method Cold_Functions
method Cold_Login
method Dispose
method Form1_Load
method Freitextsuche
method GetColdDokumente
method Get_Cold_Data_by_Dokumentid
method Get_Cold_Data_by_Dokumenttyp
method Get_Folder_Documents
method InitializeComponent
method PRINTdOC
method Return_Searchdata
method SearchTaskList
method Show_Dokument
method ToolBar1_ButtonClick
method frmSuchform_Freitextsuche
method frmcoldview_Closing
method frmcoldview_Resize
method get_annotations
method hscrol_ValueChanged
method killtask
method setsuchfeldstring
method setsuchfeldstring2
method vscrol_ValueChanged

Fields

field ImageList1
field NoteCount
field NoteLabel
field OnDemand
field Panel1
field PrintDocument1
field Show_Direkt
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field ToolBtnExit
field WindowArray
field components
field copied
field curpage
field hscrol
field i
field irotate
field lblpages
field m_auftragnr
field m_belegart
field m_colddokumentid
field m_coldfolder
field m_currentpage
field m_docnotfound
field m_dokumentid
field m_dokumenttyp
field m_erstellungsdatum
field m_partnernr
field m_print
field m_scolddokumentid
field m_uvmzvdokumenttyp
field notes
field numnote
field numpages
field numservers
field page
field poshscroll
field posvscroll
field publ
field pw
field rc
field ret
field server
field suchfeldstring1
field suchfeldstring2
field tmp
field txtdatetime
field txttext
field txtuser
field user
field v1
field v2
field vscrol
field xname
field xnumdocs
field xnumfields

See Also

frmcoldview Class


frmcoldview Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview Properties

frmcoldview overview

Properties

property Auftragnr
property Colddokumentid
property CurrentPage
property DocNotFound
property DokumentId
property Dokumenttyp
property Erstellungsdatum
property PartnerNr
property PrintIt
property UVMZVDokumenttyp
property belegart
property k
property o
property zf

See Also

frmcoldview Class


frmcoldview.Auftragnr Property

Property Auftragnr() As String

Source code

[Visual Basic]
    Property Auftragnr() As String
        Get
            Return m_auftragnr
        End Get
        Set(ByVal Value As String)
            m_auftragnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Colddokumentid Property

Property Colddokumentid() As String

Source code

[Visual Basic]
    Property Colddokumentid() As String
        Get
            Return m_scolddokumentid
        End Get
        Set(ByVal Value As String)
            m_scolddokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.CurrentPage Property

Property CurrentPage() As Integer

Source code

[Visual Basic]
    Property CurrentPage() As Integer
        Get
            Return m_currentpage
        End Get
        Set(ByVal Value As Integer)
            m_currentpage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.DocNotFound Property

Property DocNotFound() As Boolean

Source code

[Visual Basic]
    Property DocNotFound() As Boolean
        Get
            Return m_docnotfound
        End Get
        Set(ByVal Value As Boolean)
            m_docnotfound = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.DokumentId Property

Property DokumentId() As String

Source code

[Visual Basic]
    Property DokumentId() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Dokumenttyp Property

Property Dokumenttyp() As Integer

Source code

[Visual Basic]
    Property Dokumenttyp() As Integer
        Get
            Return m_dokumenttyp
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Erstellungsdatum Property

Property Erstellungsdatum() As String

Source code

[Visual Basic]
    Property Erstellungsdatum() As String
        Get
            Return m_erstellungsdatum
        End Get
        Set(ByVal Value As String)
            m_erstellungsdatum = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.PartnerNr Property

Property PartnerNr() As String

Source code

[Visual Basic]
    Property PartnerNr() As String
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As String)
            m_partnernr = Value
            While Len(m_partnernr) < 9
                m_partnernr = "0" & m_partnernr
            End While

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.PrintIt Property

Property PrintIt() As Boolean

Source code

[Visual Basic]
    Property PrintIt() As Boolean
        Get
            Return m_print
        End Get
        Set(ByVal Value As Boolean)
            m_print = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.UVMZVDokumenttyp Property

Property UVMZVDokumenttyp() As String

Source code

[Visual Basic]
    Property UVMZVDokumenttyp() As String
        Get
            Return m_uvmzvdokumenttyp
        End Get
        Set(ByVal Value As String)
            m_uvmzvdokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.belegart Property

Property belegart() As String

Source code

[Visual Basic]
    Property belegart() As String
        Get
            Return m_belegart
        End Get
        Set(ByVal Value As String)
            m_belegart = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


k Property

Public k As Object

Source code

[Visual Basic]
    Public k As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


o Property

Public o As Object

Source code

[Visual Basic]
    Public o As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


zf Property

Public zf As Short = 100

Source code

[Visual Basic]
    Public zf As Short = 100

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview Methods

frmcoldview overview

Methods

method Cold_Functions
method Cold_Login
method Dispose
method Form1_Load
method Freitextsuche
method GetColdDokumente
method Get_Cold_Data_by_Dokumentid
method Get_Cold_Data_by_Dokumenttyp
method Get_Folder_Documents
method InitializeComponent
method PRINTdOC
method Return_Searchdata
method SearchTaskList
method Show_Dokument
method ToolBar1_ButtonClick
method frmSuchform_Freitextsuche
method frmcoldview_Closing
method frmcoldview_Resize
method get_annotations
method hscrol_ValueChanged
method killtask
method setsuchfeldstring
method setsuchfeldstring2
method vscrol_ValueChanged

See Also

frmcoldview Class


frmcoldview.Cold_Functions Method

Private Function Cold_Functions( _
   ByVal fnkt As Integer, _
   ByVal folder As String _
) As Boolean

Parameters

fnkt
Required.
folder
Required.

Source code

[Visual Basic]
    Private Function Cold_Functions(ByVal fnkt As Integer, ByVal folder As String) As Boolean
        Select Case fnkt
            Case 1 'Folder öffnen
                ret = Me.OnDemand.OpenFolder(folder)
                If ret <> 0 Then
                    MsgBox("Der gewählte Order " & folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)

                    Me.OnDemand.Logoff()
                    Return False
                Else
                    Return True
                End If
            Case 2 'Suchfelder initialisieren
                ret = Me.OnDemand.ClearFolderSearchFields()
                If ret <> 0 Then
                    MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
                    Me.OnDemand.Logoff()
                    Return False
                Else
                    Return True
                End If
            Case 3 'Suche
                ret = Me.OnDemand.SearchFolder(False)
                If ret <> 0 Then
                    MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
                    Me.OnDemand.Logoff()
                    Return False
                Else
                    Return True
                End If
            Case 4
                'Dim xnumdocs
                ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
                If xnumdocs < 1 Then
                    Return False
                Else
                    Return True
                End If
            Case Else
        End Select
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Cold_Login Method

Public Function Cold_Login() As Boolean

Source code

[Visual Basic]
    Public Function Cold_Login() As Boolean
        server = Globals.Applikationsdaten.Rows(0).Item("coldsystem")
        user = Globals.Applikationsdaten.Rows(0).Item("colduser")
        pw = Globals.Applikationsdaten.Rows(0).Item("coldpassword")
        Me.OnDemand.SetUserMessageMode(2)
        Me.OnDemand.Logon(server, user, pw)
        If ret <> 0 And ret <> 8 Then
            MsgBox("Die Anmeldung am COLD ist fehlgeschlagen", MsgBoxStyle.Exclamation)
            Cold_Login = False
            Exit Function
        End If
        Cold_Login = True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)

        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim cid As String
        Dim yy As String
        Dim mm As String
        Dim dd As String
        Dim comparedate As DateTime
        Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
        Get_Cold_Data_by_Dokumentid()
        Me.Show_Direkt = False
        Try
            If UCase(Microsoft.VisualBasic.Left(Me.m_colddokumentid, 3)) = "SCA" Then
                cid = Microsoft.VisualBasic.Right(Me.m_colddokumentid, 17)
                cid = Microsoft.VisualBasic.Left(cid, 14)
            Else
                cid = Microsoft.VisualBasic.Right(Me.m_colddokumentid, 14)
            End If
            yy = Microsoft.VisualBasic.Left(cid, 4)
            mm = Microsoft.VisualBasic.Mid(cid, 5, 2)
            dd = Microsoft.VisualBasic.Mid(cid, 7, 2)
            comparedate = yy + "." + mm + "." + dd
            If comparedate.Date <= DateAdd(DateInterval.Day, -1, Now) Then
                Me.Show_Direkt = True
            Else
                Me.Show_Direkt = False
            End If
        Catch
            cid = Me.Colddokumentid
        End Try
        Select Case Me.belegart
            Case "HOST"
                If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" And Not Me.PrintIt Then
                    If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
                        Me.DocNotFound = True
                    End If
                    Exit Sub
                End If
            Case "ZV"
                    If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" And Not Me.PrintIt Then
                        If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
                        Me.DocNotFound = True
                    End If
                    Exit Sub
                End If
            Case "UVM"
                    If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" And Not Me.PrintIt Then
                        If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
                        Me.DocNotFound = True
                    End If
                    Exit Sub
                End If
            Case Else
        End Select
        'If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" And Not Me.PrintIt Then
        '    If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
        '        Me.DocNotFound = True
        '    End If
        '    Exit Sub
        'End If
        If Show_Direkt = True And Not Me.PrintIt Then
            If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
                Me.DocNotFound = True
            End If
            Exit Sub
        End If

        Dim rc As Integer
        'Try
        '    If Not Me.PrintIt Then
        '        rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum, AppWinStyle.Hide, False)
        '        'If rc <> 0 Then
        '        'MsgBox(rc)
        '        '                Me.Dispose()
        '        Exit Sub
        '    End If
        'Catch ex As Exception
        '    '           MsgBox(ex.Message)
        'End Try
        'End If

        '        Dim m_dokument As New edokadb.clsDokument()
        Get_Cold_Data_by_Dokumentid()
        If ret <> 0 Then
            Me.Close()
            Exit Sub
        End If

        If Not Cold_Login() Then Exit Sub
        Me.OnDemand.BackColor = System.Drawing.Color.White

        hscrol.Dock = DockStyle.Bottom
        vscrol.Dock = DockStyle.Right
        Me.Panel1.Controls.Add(vscrol)
        Me.Panel1.Controls.Add(hscrol)
        '        Me.OnDemand.Controls.Add(hscrol)
        '       Me.OnDemand.Controls.Add(vscrol)

        Me.CurrentPage = 1

        Me.notes.Columns.Add("ID")
        Me.notes.Columns.Add("Text")
        Me.notes.Columns.Add("DateTime")
        Me.notes.Columns.Add("UserID")
        Me.notes.Columns.Add("Page")
        Me.notes.Columns.Add("ispublic")
        Me.notes.Columns.Add("canbecopied")
        Me.notes.Columns.Add("status")
        If Not Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid) Then
            Me.DocNotFound = True
            'Me.Dispose()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Freitextsuche Method

Public Function Freitextsuche( _
   ByVal suchdaten As DataTable, _
   ByVal suchstring As String, _
   ByVal datenbestand As String _
) As DataTable

Parameters

suchdaten
Required.
suchstring
Required.
datenbestand
Required.

Source code

[Visual Basic]
    Public Function Freitextsuche(ByVal suchdaten As DataTable, ByVal suchstring As String, ByVal datenbestand As String) As DataTable
        If Not Cold_Login() Then Exit Function
        Select Case datenbestand
            Case "HOST"
                If Not Cold_Functions(1, "TGKB Kundenoutput AGI-OMS für EDOKA User") Then Exit Function
                Dim i As Integer
                For i = 0 To suchdaten.Rows.Count - 1
                    If Not Cold_Functions(2, "") Then Exit Function
                    If Not setsuchfeldstring("Partner-Nr. Inh. od. Zust.", suchdaten.Rows(i).Item("partnernr_inhaber")) Then Exit Function
                    If Not setsuchfeldstring("Dokument-Id", suchdaten.Rows(i).Item("Dokumentid")) Then Exit Function
                    Dim xx As String
                    xx = suchdaten.Rows(i).Item("valutadatum")
                    xx = Microsoft.VisualBasic.Right(xx, 2) + "." + Microsoft.VisualBasic.Mid(xx, 5, 2) + "." + Microsoft.VisualBasic.Mid(xx, 3, 2)
                    If Not setsuchfeldstring("Erstellung od. Valuta Datum", xx) Then Exit Function
                    If Not setsuchfeldstring("zusätzliches Suchfeld", suchstring) Then Exit Function
                    If Not Cold_Functions(3, "") Then Exit Function
                    If Not Cold_Functions(4, "") Then
                        suchdaten.Rows(i).Delete()
                    End If
                Next
                Return suchdaten
            Case "UVM"
                If Not Cold_Functions(1, "TGKB UVM-Verträge") Then Exit Function
                Dim i As Integer
                For i = 0 To suchdaten.Rows.Count - 1
                    If Not Cold_Functions(2, "") Then Exit Function
                    If Not setsuchfeldstring("Partner-Nr. Inh.", suchdaten.Rows(i).Item("partnernr")) Then Exit Function
                    If Not setsuchfeldstring("Auftrag-Nr.", suchdaten.Rows(i).Item("nrauf00")) Then Exit For
                    If Not setsuchfeldstring("Paginator", suchdaten.Rows(i).Item("dokumentid")) Then Exit Function
                    If Not setsuchfeldstring("Dokumenttyp", "UVM004") Then Exit Function
                    If Not setsuchfeldstring("Zusätzliches Suchfeld", suchstring) Then Exit Function
                    If Not Cold_Functions(3, "") Then Exit Function
                    If Not Cold_Functions(4, "") Then
                        suchdaten.Rows(i).Delete()
                    End If
                Next
                Return suchdaten
            Case Else
                Return suchdaten

        End Select

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.GetColdDokumente Method

Public Function GetColdDokumente() As DataTable

Source code

[Visual Basic]
    Public Function GetColdDokumente() As DataTable
        Dim m_dokument As New edokadb.clsDokument()
        Get_Cold_Data_by_Dokumenttyp()
        If Not Me.Cold_Login Then Exit Function
        Get_Folder_Documents(Me.m_coldfolder)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Get_Cold_Data_by_Dokumentid Method

Private Function Get_Cold_Data_by_Dokumentid()

Source code

[Visual Basic]
    Private Function Get_Cold_Data_by_Dokumentid()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_get_coldfolder_by_documentid"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentId))

            sdaAdapter.Fill(dtToReturn)
            If Me.Colddokumentid = "" Then
                Me.m_colddokumentid = dtToReturn.Rows(0).Item(1)
            Else
                Me.m_colddokumentid = Me.Colddokumentid
            End If

            'HOST-Folder'
            If dtToReturn.Rows.Count = 0 Then
                Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User"
            Else
                Me.m_coldfolder = dtToReturn.Rows(0).Item(0)

            End If
        Catch ex As Exception
            Throw New Exception("Get_Cold_Folder :" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Get_Cold_Data_by_Dokumenttyp Method

Private Function Get_Cold_Data_by_Dokumenttyp()

Source code

[Visual Basic]
    Private Function Get_Cold_Data_by_Dokumenttyp()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_get_coldfolder_by_documenttyp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttyp))
            sdaAdapter.Fill(dtToReturn)
            Me.m_coldfolder = dtToReturn.Rows(0).Item(0)
        Catch ex As Exception
            Throw New Exception("Get_Cold_Folder :" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Get_Folder_Documents Method

Private Function Get_Folder_Documents( _
   ByVal Folder As String _
) As Boolean

Parameters

Folder
Required.

Source code

[Visual Basic]
    Private Function Get_Folder_Documents(ByVal Folder As String) As Boolean
        ret = Me.OnDemand.SetUserMessageMode(0)
        ret = Me.OnDemand.OpenFolder(Folder)
        If ret <> 0 Then
            MsgBox("Der gewählte Order " & Folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.ClearFolderSearchFields()
        If ret <> 0 Then
            MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        Dim xx As String
        xx = ""
        ret = Me.OnDemand.SetFolderSearchFieldData("Partner-Nr.", 1, Me.PartnerNr, xx)
        'ret = Me.OnDemand.SetFolderSearchFieldData("Dok.-Status", 11, "Aktuell", xx)
        If ret <> 0 Then
            MsgBox("Fehler beim setzen des Suchkriteriums", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.SearchFolder(False)
        If ret <> 0 Then
            MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
        If xnumdocs < 1 Then
            MyMsg.show_standardmessage(81, MsgBoxStyle.Information)
            Me.OnDemand.Logoff()
            Exit Function
        End If
        Dim tmp As String

        Dim i As Short
        Dim i1 As Short
        tmp = ""
        ret = OnDemand.GetNumFolderDisplayFields(xnumfields)
        Dim foldernames(xnumfields) As String
        For i = 0 To xnumfields - 1
            tmp = Nothing
            OnDemand.GetFolderDisplayFieldName(i, tmp)
            foldernames(i) = tmp
            MsgBox(foldernames(i))
        Next

        Dim t As New DataTable()
        Dim newrow As DataRow
        Dim rc As DataRowCollection
        rc = t.Rows
        Dim rowvals(xnumfields) As Object

        For i = 0 To xnumdocs
            For i1 = 0 To xnumfields
                ret = OnDemand.GetDocDisplayValue(i, i1, tmp)
                If ret = 0 Then
                    rowvals(i1) = tmp
                End If
            Next i1

            newrow = rc.Add(rowvals)
        Next i

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmcoldview))
        Me.NoteCount = New System.Windows.Forms.Label()
        Me.NoteLabel = New System.Windows.Forms.Label()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton8 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton9 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton10 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.PrintDocument1 = New System.Drawing.Printing.PrintDocument()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.OnDemand = New AxARSOLELib.AxArsOle()
        Me.lblpages = New System.Windows.Forms.Label()
        Me.Panel1.SuspendLayout()
        CType(Me.OnDemand, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'NoteCount
        '
        Me.NoteCount.Name = "NoteCount"
        Me.NoteCount.TabIndex = 10
        '
        'NoteLabel
        '
        Me.NoteLabel.Name = "NoteLabel"
        Me.NoteLabel.TabIndex = 11
        '
        'ToolBar1
        '
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(115, 39)
        Me.ToolBar1.TabIndex = 12
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 5
        Me.ToolBarButton4.ToolTipText = "Ansicht verkleinern"
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 4
        Me.ToolBarButton5.ToolTipText = "Ansicht vergrössern"
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 6
        Me.ToolBarButton6.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.ImageIndex = 6
        Me.ToolBarButton7.ToolTipText = "Notizen bearbeiten"
        '
        'ToolBarButton8
        '
        Me.ToolBarButton8.ImageIndex = 6
        Me.ToolBarButton8.Visible = False
        '
        'ToolBarButton9
        '
        Me.ToolBarButton9.ImageIndex = 9
        Me.ToolBarButton9.ToolTipText = "Dokument nach links drehen"
        '
        'ToolBarButton10
        '
        Me.ToolBarButton10.ImageIndex = 10
        Me.ToolBarButton10.ToolTipText = "Dokument nach rechts drehen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.OnDemand})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel1.Location = New System.Drawing.Point(0, 39)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(115, 0)
        Me.Panel1.TabIndex = 8
        '
        'OnDemand
        '
        Me.OnDemand.ContainingControl = Me
        Me.OnDemand.Dock = System.Windows.Forms.DockStyle.Fill
        Me.OnDemand.Enabled = True
        Me.OnDemand.Name = "OnDemand"
        Me.OnDemand.OcxState = CType(resources.GetObject("OnDemand.OcxState"), System.Windows.Forms.AxHost.State)
        Me.OnDemand.Size = New System.Drawing.Size(115, 0)
        Me.OnDemand.TabIndex = 1
        '
        'lblpages
        '
        Me.lblpages.Location = New System.Drawing.Point(671, 8)
        Me.lblpages.Name = "lblpages"
        Me.lblpages.RightToLeft = System.Windows.Forms.RightToLeft.Yes
        Me.lblpages.Size = New System.Drawing.Size(88, 16)
        Me.lblpages.TabIndex = 9
        Me.lblpages.Text = "1/1"
        '
        'frmcoldview
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(115, 22)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.lblpages, Me.Panel1, Me.NoteCount, Me.NoteLabel, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmcoldview"
        Me.Text = "COLD-Dokumentanzeige"
        Me.Panel1.ResumeLayout(False)
        CType(Me.OnDemand, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.PRINTdOC Method

Public Sub PRINTdOC()

Source code

[Visual Basic]
    Public Sub PRINTdOC()
        Me.OnDemand.PrintDoc(-1, 0, Me.PrintDocument1.PrinterSettings.PrinterName, True, 1, 3, 4, 4, 0, 6, True)
        Me.CurrentPage = Me.CurrentPage - 1
        ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
        If ret <> 0 Then Me.CurrentPage = Me.CurrentPage + 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Return_Searchdata Method

Private Function Return_Searchdata( _
   ByVal rettable As DataTable _
)

Parameters

rettable
Required.

Source code

[Visual Basic]
    Private Function Return_Searchdata(ByVal rettable As DataTable)
        Dim s As String
        Dim newrow As DataRow
        Dim i1 As Integer
        Dim rc As DataRowCollection
        rc = rettable.Rows
        Dim tmp As String
        Dim rowvals(rettable.Columns.Count) As Object
        ret = OnDemand.GetNumFolderDisplayFields(xnumfields)

        For i = 0 To xnumdocs - 1
            For i1 = 0 To xnumfields
                tmp = ""
                ret = OnDemand.GetDocDisplayValue(i, i1, tmp)
                If ret = 0 Then
                    rowvals(i1) = tmp
                Else
                    ' rowvals(i1) = ""
                End If
            Next i1
            newrow = rc.Add(rowvals)
        Next i

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.SearchTaskList Method

Public Function SearchTaskList( _
   ByVal name As String _
) As Integer

Parameters

name
Required.

Source code

[Visual Basic]
    Public Function SearchTaskList(ByVal name As String) As Integer
        Dim myProcess() As Process
        Try
            myProcess = Process.GetProcessesByName(name)
            If myProcess.Length > Globals.Applikationsdaten.Rows(0).Item("Anzahl_COLD_Viewer") - 1 Then
                If MyMsg.Show_MessageYesNo(242) = MsgBoxResult.Yes Then
                    killtask("ColdStrt")
                    killtask("ARSGUI32")
                    Return 0
                Else
                    Return 1
                End If
            Else
                Return 0
            End If
        Catch
        Finally
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.Show_Dokument Method

Public Function Show_Dokument( _
   ByVal folder As String, _
   ByVal dokumentid As String _
) As Boolean

Parameters

folder
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function Show_Dokument(ByVal folder As String, ByVal dokumentid As String) As Boolean
        Dim rc
        Dim ret
        Dim xnumdocs
        Dim i As Short
        Dim tmp As String
        Try
            Show_Dokument = True
            Select Case Me.belegart
                Case "HOST"
                    If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" And Not Me.PrintIt Then
                        If Show_Dokument = True And Not Me.PrintIt Then
                            If SearchTaskList("ColdStrt") = 0 Then
                                rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum + " /b HOST", AppWinStyle.Hide, False)
                                Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
                            End If
                            Exit Function
                        End If
                    End If
                Case "UVM"
                    If Show_Dokument = True And Not Me.PrintIt Then
                        If SearchTaskList("ColdStrt") = 0 Then
                            Me.m_coldfolder = "TGKB UVM-Verträge"
                            rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum + " /b UVM /a " + Trim(Me.Auftragnr) + " /g " + Trim(Me.UVMZVDokumenttyp), AppWinStyle.Hide, False)
                            Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
                        End If
                        Exit Function
                    End If
                Case "ZV"
                    If Show_Dokument = True And Not Me.PrintIt Then
                        If SearchTaskList("ColdStrt") = 0 Then
                            Me.m_coldfolder = "TGKB ZV-Scanning Belege (erweiterte Suche)"
                            rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum + " /b ZV /a " + Trim(Me.Auftragnr) + " /g " + Trim(Me.UVMZVDokumenttyp), AppWinStyle.Hide, False)
                            Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
                        End If
                        Exit Function
                    End If

            End Select
        Catch
        End Try
        Try
            If Me.Show_Direkt = True And Not Me.PrintIt Then
                If Show_Dokument = True And Not Me.PrintIt Then
                    If SearchTaskList("ColdStrt") = 0 Then
                        rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum, AppWinStyle.Hide, False)
                        Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
                    End If
                    Exit Function
                End If
            End If
        Catch
        End Try
        Try
            'Hutter 2004-1004 Aktivierung COLD-Print
            Select Case Me.belegart
                Case "HOST"
                    folder = "TGKB Kundenoutput AGI-OMS für EDOKA User"
                Case "ZV"
                    folder = "TGKB ZV-Scanning Belege (erweiterte Suche)"
                Case "UVM"
                    folder = "TGKB UVM-Verträge"
                Case Else

            End Select
            ret = Me.OnDemand.SetUserMessageMode(0)
            ret = Me.OnDemand.OpenFolder(folder)
            If ret <> 0 Then
                MsgBox("Der gewählte Order " & folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)

                Me.OnDemand.Logoff()
                Show_Dokument = False
                Exit Function
            End If

            rc = Me.OnDemand.GetNumFolderSearchFields(xnumfields)
            For i = 0 To xnumfields - 1
                tmp = ""
                ret = OnDemand.GetFolderSearchFieldName(i, tmp)
                '       MsgBox(tmp)
            Next

            ret = Me.OnDemand.ClearFolderSearchFields()
            If ret <> 0 Then
                MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Show_Dokument = False
                Exit Function
            End If

            Dim xx As String
            xx = ""
            'Hutter 2004-10-04 Aktivierung COLD-Print
            Select Case belegart
                Case "HOST"
                    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 1, Me.DokumentId, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Erstellung od. Valuta Datum", 1, Me.Erstellungsdatum, xx)
                Case "UVM"
                    ret = Me.OnDemand.SetFolderSearchFieldData("Dokumenttyp", 1, Me.UVMZVDokumenttyp, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Auftrag-Nr.", 1, Me.Auftragnr, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Paginator", 1, Me.DokumentId, xx)
                Case "ZV"
                    ret = Me.OnDemand.SetFolderSearchFieldData("Dokumenttyp", 1, Me.UVMZVDokumenttyp, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Auftrag-Nr.", 1, Me.Auftragnr, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Paginator", 1, Me.DokumentId, xx)
                Case Else
                    Dim s As String
                    ' s = Trim(Me.PartnerNr)
                    ' While Len(s) < 9
                    ' s = "0" + s
                    ' End While
                    ' ret = Me.OnDemand.SetFolderSearchFieldData("Partner-Nr.", 1, s, xx)
                    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 11, dokumentid, xx)
            End Select
            'If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" Then
            '    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 1, Me.DokumentId, xx)
            '    ret = Me.OnDemand.SetFolderSearchFieldData("Erstellung od. Valuta Datum", 1, Me.Erstellungsdatum, xx)
            'Else
            '    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 11, dokumentid, xx)
            'End If

            If ret <> 0 Then
                MsgBox("Fehler beim setzen des Suchkriteriums", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Show_Dokument = False
                Exit Function
            End If

            ret = Me.OnDemand.SearchFolder(False)
            If ret <> 0 Then
                MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Show_Dokument = False
                Exit Function
            End If

            ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
            If xnumdocs < 1 Then
                If Not DivFnkt.BDR_Dokument(Me.DokumentId) Then
                    MyMsg.show_standardmessage(81, MsgBoxStyle.Information)
                Else
                    MyMsg.show_standardmessage(275, MsgBoxStyle.Information)
                End If
                Me.OnDemand.Logoff()
                Show_Dokument = False
                Exit Function
            End If
            'shu
            If Show_Dokument = True And Not Me.PrintIt Then
                If SearchTaskList("ColdStrt") = 0 Then
                    rc = Shell(Application.StartupPath + "\coldstrt.exe" + " /e " + Globals.Applikationsdaten.Rows(0).Item("coldgui") + " /S " + Globals.Applikationsdaten.Rows(0).Item("coldsystem") + " /U " + Globals.Applikationsdaten.Rows(0).Item("colduser") + " /P " + Globals.Applikationsdaten.Rows(0).Item("coldpassword") + " /f " + m_coldfolder + " /d " + m_colddokumentid + " /t " + Me.Erstellungsdatum, AppWinStyle.Hide, False)
                    Globals.EDOKAMAIN_Statusbar.Text = "AGI-COLD Dokumentanfrage ausgelöst"
                End If
                Exit Function
            End If
            Me.OnDemand.OpenDoc(0, "", 0)
            get_annotations()
            Dim o As Object
            o = Nothing
            ret = OnDemand.GetDocNumPages(o)
            If ret = 0 Then Me.numpages = o
            o = Nothing
            ret = OnDemand.GetDocCurrentPage(o)
            If ret = 0 Then Me.curpage = o
            Me.lblpages.Text = Str(curpage) + "/" + Str(numpages)

        Catch ex As Exception
            '            MsgBox(ex.Message)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Cursor = Cursors.Default
                Me.Close()
            Case 1
                Me.OnDemand.PrintDoc(-1, 0, Me.PrintDocument1.PrinterSettings.PrinterName, True, 1, 3, 0.5, 0.5, 0.5, 0.5, False)
                Me.CurrentPage = Me.CurrentPage - 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage + 1
            Case 2
                Me.CurrentPage = Me.CurrentPage - 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage + 1
                Dim o As Object
                o = Nothing
                ret = OnDemand.GetDocCurrentPage(o)
                If ret = 0 Then Me.curpage = o
                Me.lblpages.Text = Str(curpage) + "/" + Str(numpages)
            Case 3
                Me.CurrentPage = Me.CurrentPage + 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage - 1
                Dim o As Object
                o = Nothing
                ret = OnDemand.GetDocCurrentPage(o)
                If ret = 0 Then Me.curpage = o
                Me.lblpages.Text = Str(curpage) + "/" + Str(numpages)
            Case 4
                zf = zf - 25
                o = Nothing
                k = Nothing
                If zf < 25 Then zf = 25
                ret = Me.OnDemand.SetDocZoom(zf, o, k)
            Case 5
                zf = zf + 25
                o = Nothing
                k = Nothing
                If zf > 1000 Then zf = 1000
                ret = Me.OnDemand.SetDocZoom(zf, o, k)
            Case 7
                Dim f As New frmNotes()
                f.notes = Me.notes
                f.ondemand = Me.OnDemand
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then
                    Me.notes.Rows.Clear()
                    Me.get_annotations()
                End If
            Case 10
                If Me.irotate = 0 Then Me.irotate = 360
                Me.irotate = Me.irotate - 90
                Me.OnDemand.SetDocRotation(irotate)
            Case 9
                If Me.irotate = 270 Then Me.irotate = -90
                Me.irotate = Me.irotate + 90
                Me.OnDemand.SetDocRotation(Me.irotate)
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.frmSuchform_Freitextsuche Method

Public Function frmSuchform_Freitextsuche( _
   ByVal suchdaten As DataTable, _
   ByVal suchstring As String, _
   ByVal datenbestand As String _
) As DataTable

Parameters

suchdaten
Required.
suchstring
Required.
datenbestand
Required.

Source code

[Visual Basic]
    Public Function frmSuchform_Freitextsuche(ByVal suchdaten As DataTable, ByVal suchstring As String, ByVal datenbestand As String) As DataTable
        If Not Cold_Login() Then Exit Function
        Select Case datenbestand
            Case "UVM"
                If Not Cold_Functions(1, "TGKB UVM-Verträge") Then Exit Function
                If Not Cold_Functions(2, "") Then Exit Function
                Dim i As Integer
                For i = 0 To suchdaten.Rows.Count - 1
                    If Not setsuchfeldstring2(suchdaten.Rows(i).Item("feld"), suchdaten.Rows(i).Item("wert1"), suchdaten.Rows(i).Item("wert2"), suchdaten.Rows(i).Item("OP")) Then Exit Function
                Next
                If Not Cold_Functions(3, "") Then Exit Function
                Dim Resultdata As New DataTable()
                If Not Cold_Functions(4, "") Then
                    Return Resultdata
                Else
                    resultdata.Columns.Add("Bezeichnung") '0
                    resultdata.Columns.Add("NRDOC00") '1
                    resultdata.Columns.Add("PartnerNr") '2
                    resultdata.Columns.Add("BKPAR00") '3
                    resultdata.Columns.Add("NRAUF00") '4
                    resultdata.Columns.Add("Erstellungsdatum") '5
                    resultdata.Columns.Add("DMARC00") '6
                    resultdata.Columns.Add("hostdokumenttyp") '7
                    Dim tmp As String
                    Dim newrow As DataRow
                    Dim i1 As Integer
                    Dim rc As DataRowCollection
                    rc = Resultdata.Rows
                    Dim rowvals(Resultdata.Columns.Count - 1) As Object
                    ret = OnDemand.GetNumFolderDisplayFields(xnumfields)

                    For i = 0 To xnumdocs - 1
                        For i1 = 0 To xnumfields - 1
                            tmp = ""
                            ret = OnDemand.GetDocDisplayValue(i, i1, tmp)
                            If ret = 0 Then
                                Select Case i1
                                    Case 0
                                        rowvals(7) = Microsoft.VisualBasic.Left(tmp, 6)
                                        rowvals(0) = tmp
                                    Case 1
                                        rowvals(2) = tmp
                                        rowvals(3) = ""
                                    Case 2
                                        rowvals(5) = tmp
                                    Case 3
                                        rowvals(4) = tmp
                                    Case 4
                                        rowvals(1) = tmp
                                    Case 5
                                        rowvals(6) = tmp
                                End Select
                            End If
                        Next i1
                        newrow = rc.Add(rowvals)
                    Next i
                    Return Resultdata
                End If
            Case "ZV"
                If Not Cold_Functions(1, "TGKB ZV-Scanning Belege (erweiterte Suche)") Then Exit Function
                If Not Cold_Functions(2, "") Then Exit Function
                Dim i As Integer
                For i = 0 To suchdaten.Rows.Count - 1
                    If Not setsuchfeldstring2(suchdaten.Rows(i).Item("feld"), suchdaten.Rows(i).Item("wert1"), suchdaten.Rows(i).Item("wert2"), suchdaten.Rows(i).Item("op")) Then Exit Function
                Next
                If Not Cold_Functions(3, "") Then Exit Function
                Dim Resultdata As New DataTable()
                If Not Cold_Functions(4, "") Then
                    Return Resultdata
                Else
                    Resultdata.Columns.Add("Bezeichnung") '0
                    Resultdata.Columns.Add("NRDOC00") '1
                    Resultdata.Columns.Add("NRAUF00") '2
                    Resultdata.Columns.Add("PartnerNr") '3
                    Resultdata.Columns.Add("BKPAR00") '4
                    Resultdata.Columns.Add("NRPOS00") '5
                    Resultdata.Columns.Add("NEVVG00") '6
                    Resultdata.Columns.Add("CDWAEAI") '7
                    Resultdata.Columns.Add("BTBET00") '8
                    Resultdata.Columns.Add("DMVAL00") '9
                    Resultdata.Columns.Add("CDZAH00") '10
                    Resultdata.Columns.Add("NRREF00") '11
                    Resultdata.Columns.Add("NEVVG01") '12
                    Resultdata.Columns.Add("NRPCK00") '13
                    Resultdata.Columns.Add("NRBCL00") '14
                    Resultdata.Columns.Add("CDVAR00") '15
                    Resultdata.Columns.Add("BEEAD00") '16
                    Resultdata.Columns.Add("BESAD00") '17
                    Resultdata.Columns.Add("DMARC00") '18
                    Resultdata.Columns.Add("hostdokumenttyp") '19

                    'COLD-Daten abfüllen
                    Dim tmp As String
                    Dim newrow As DataRow
                    Dim i1 As Integer
                    Dim rc As DataRowCollection
                    rc = Resultdata.Rows
                    Dim rowvals(Resultdata.Columns.Count - 1) As Object
                    ret = OnDemand.GetNumFolderDisplayFields(xnumfields)

                    For i = 0 To xnumdocs - 1
                        For i1 = 0 To xnumfields - 1
                            tmp = ""
                            ret = OnDemand.GetDocDisplayValue(i, i1, tmp)
                            If ret = 0 Then
                                Select Case i1
                                    Case 0
                                        rowvals(0) = tmp
                                        rowvals(19) = Microsoft.VisualBasic.Left(tmp, 6)
                                    Case 1
                                        rowvals(2) = tmp
                                    Case 2
                                        rowvals(5) = tmp
                                    Case 3
                                        rowvals(6) = tmp
                                    Case 4
                                        rowvals(7) = tmp
                                    Case 5
                                        rowvals(8) = tmp
                                    Case 6
                                        rowvals(9) = tmp
                                    Case 7
                                        rowvals(1) = tmp
                                    Case 8
                                        rowvals(3) = tmp
                                        rowvals(4) = ""
                                    Case 9
                                        rowvals(10) = tmp
                                    Case 10
                                        rowvals(11) = tmp
                                    Case 11
                                        rowvals(12) = tmp
                                    Case 12
                                        rowvals(13) = tmp
                                    Case 13
                                        rowvals(14) = tmp
                                    Case 14
                                        rowvals(15) = tmp
                                    Case 15
                                        rowvals(16) = tmp
                                    Case 16
                                        rowvals(17) = tmp
                                    Case 17
                                        rowvals(18) = tmp
                                End Select
                            End If
                        Next i1
                        newrow = rc.Add(rowvals)
                    Next i
                    Return Resultdata
                End If
            Case Else
                Return suchdaten
        End Select
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.frmcoldview_Closing Method

Private Sub frmcoldview_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmcoldview_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Me.Cursor = Cursors.Default
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.frmcoldview_Resize Method

Private Sub frmcoldview_Resize( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmcoldview_Resize(ByVal sender As Object, ByVal e As System.EventArgs) Handles MyBase.Resize
        Me.lblpages.Left = Me.ToolBar1.Width - Me.lblpages.Width
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.get_annotations Method

Public Function get_annotations()

Source code

[Visual Basic]
    Public Function get_annotations()
        Dim rc As DataRowCollection
        Dim newrow As DataRow()
        rc = notes.Rows
        Dim rowvals(7) As Object
        Dim i As Integer
        Me.numnote = Nothing
        ret = Me.OnDemand.GetNumDocAnnotations(Me.numnote)

        For i = 0 To Me.numnote - 1
            page = Nothing
            publ = Nothing
            copied = Nothing
            ret = Me.OnDemand.GetAnnotationForDoc(i, txttext, txtuser, txtdatetime, page, publ, copied)
            rowvals(0) = i
            rowvals(1) = txttext
            rowvals(3) = txtuser
            rowvals(2) = txtdatetime
            rowvals(4) = page
            rowvals(5) = publ
            rowvals(6) = copied
            rowvals(7) = ""
            notes.Rows.Add(rowvals)
        Next

        If Me.numnote > 0 Then
            Me.NoteCount.Text = Me.numnote.ToString
            Me.NoteCount.Visible = True
            Me.NoteLabel.Visible = True
        Else
            Me.NoteCount.Visible = False
            Me.NoteLabel.Visible = False
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.hscrol_ValueChanged Method

Private Sub hscrol_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles hscrol.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub hscrol_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles hscrol.ValueChanged
        Try
            If Me.hscrol.Value < Me.poshscroll Then zf = 0 Else zf = 1
            o = 60
            o = Nothing
            Me.poshscroll = Me.hscrol.Value
            ret = Me.OnDemand.ScrollDocHorz(zf, o)
        Catch ex As Exception
            '            MsgBox(ret)
            '           MsgBox(ex.Message)
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.killtask Method

Private Sub killtask( _
   ByVal application As String _
)

Parameters

application
Required.

Source code

[Visual Basic]
    Private Sub killtask(ByVal application As String)
        Dim myProcess() As Process
        Try
            myProcess = Process.GetProcessesByName(application)
            While myProcess.Length > 0
                myProcess(0).Kill()
                System.Threading.Thread.CurrentThread.Sleep(200)
                myProcess = Process.GetProcessesByName(application)
            End While
        Catch
        Finally
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.setsuchfeldstring Method

Private Function setsuchfeldstring( _
   ByVal feld As String, _
   ByVal wert As String _
) As Boolean

Parameters

feld
Required.
wert
Required.

Source code

[Visual Basic]
    Private Function setsuchfeldstring(ByVal feld As String, ByVal wert As String) As Boolean
        ret = Me.OnDemand.SetFolderSearchFieldData(feld, 1, wert, suchfeldstring2)
        If ret <> 0 Then Return False Else Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.setsuchfeldstring2 Method

Private Function setsuchfeldstring2( _
   ByVal feld As String, _
   ByVal wert As String, _
   ByVal wert2 As String, _
   ByVal Operator As String _
) As Boolean

Parameters

feld
Required.
wert
Required.
wert2
Required.
Operator
Required.

Source code

[Visual Basic]
    Private Function setsuchfeldstring2(ByVal feld As String, ByVal wert As String, ByVal wert2 As String, ByVal Operator As String) As Boolean
        Dim op As Integer

        Select Case Operator
            Case "zwischen"
                op = 7
            Case "="
                op = 1
            Case "<>"
                op = 2
            Case "<"
                op = 3
            Case "<="
                op = 4
            Case ">"
                op = 5
            Case ">="
                op = 6
            Case "wie"
                op = "11"
            Case "nicht wie"
                op = 12
            Case "nicht zwischen"
                op = 8
            Case "nicht in"
                op = 10
            Case "in"
                op = 9
            Case Else
                op = 1
        End Select
        ret = Me.OnDemand.SetFolderSearchFieldData(feld, op, wert, wert2)
        If ret <> 0 Then Return False Else Return True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview.vscrol_ValueChanged Method

Private Sub vscrol_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles vscrol.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vscrol_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles vscrol.ValueChanged
        Try
            If Me.vscrol.Value < Me.posvscroll Then zf = 0 Else zf = 1
            o = 60
            o = Nothing
            Me.posvscroll = Me.vscrol.Value
            ret = Me.OnDemand.ScrollDocVert(zf, o)
        Catch ex As Exception
            '            MsgBox(ret)
            '           MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldview Fields

frmcoldview overview

Fields

field ImageList1
field NoteCount
field NoteLabel
field OnDemand
field Panel1
field PrintDocument1
field Show_Direkt
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field ToolBtnExit
field WindowArray
field components
field copied
field curpage
field hscrol
field i
field irotate
field lblpages
field m_auftragnr
field m_belegart
field m_colddokumentid
field m_coldfolder
field m_currentpage
field m_docnotfound
field m_dokumentid
field m_dokumenttyp
field m_erstellungsdatum
field m_partnernr
field m_print
field m_scolddokumentid
field m_uvmzvdokumenttyp
field notes
field numnote
field numpages
field numservers
field page
field poshscroll
field posvscroll
field publ
field pw
field rc
field ret
field server
field suchfeldstring1
field suchfeldstring2
field tmp
field txtdatetime
field txttext
field txtuser
field user
field v1
field v2
field vscrol
field xname
field xnumdocs
field xnumfields

See Also

frmcoldview Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


NoteCount Variable

Friend WithEvents NoteCount As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents NoteCount As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


NoteLabel Variable

Friend WithEvents NoteLabel As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents NoteLabel As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


OnDemand Variable

Friend WithEvents OnDemand As AxARSOLELib.AxArsOle

Source code

[Visual Basic]
    Friend WithEvents OnDemand As AxARSOLELib.AxArsOle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


PrintDocument1 Variable

Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Source code

[Visual Basic]
    Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


Show_Direkt Variable

Dim Show_Direkt As Boolean = False

Source code

[Visual Basic]
    Dim Show_Direkt As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton10 Variable

Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton8 Variable

Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBarButton9 Variable

Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


WindowArray Variable

Dim WindowArray As New ArrayList()

Source code

[Visual Basic]
    Dim WindowArray As New ArrayList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


copied Variable

Dim copied As Object

Source code

[Visual Basic]
    Dim copied As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


curpage Variable

Dim curpage As Integer = 1

Source code

[Visual Basic]
    Dim curpage As Integer = 1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


hscrol Variable

Dim WithEvents hscrol As New HScrollBar()

Source code

[Visual Basic]
    Dim WithEvents hscrol As New HScrollBar()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


i Variable

Dim i

Source code

[Visual Basic]
    Dim i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


irotate Variable

Dim irotate As Integer = 0

Source code

[Visual Basic]
    Dim irotate As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


lblpages Variable

Friend WithEvents lblpages As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents lblpages As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_auftragnr Variable

Dim m_auftragnr As String

Source code

[Visual Basic]
    Dim m_auftragnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_belegart Variable

Dim m_belegart As String

Source code

[Visual Basic]
    Dim m_belegart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_colddokumentid Variable

Dim m_colddokumentid As String

Source code

[Visual Basic]
    Dim m_colddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_coldfolder Variable

Dim m_coldfolder As String

Source code

[Visual Basic]
    Dim m_coldfolder As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_currentpage Variable

Dim m_currentpage As Integer

Source code

[Visual Basic]
    Dim m_currentpage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_docnotfound Variable

Dim m_docnotfound As Boolean

Source code

[Visual Basic]
    Dim m_docnotfound As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_dokumenttyp Variable

Dim m_dokumenttyp As Integer

Source code

[Visual Basic]
    Dim m_dokumenttyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_erstellungsdatum Variable

Dim m_erstellungsdatum As String

Source code

[Visual Basic]
    Dim m_erstellungsdatum As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_partnernr Variable

Dim m_partnernr As String

Source code

[Visual Basic]
    Dim m_partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_print Variable

Dim m_print As Boolean = False

Source code

[Visual Basic]
    Dim m_print As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_scolddokumentid Variable

Dim m_scolddokumentid As String

Source code

[Visual Basic]
    Dim m_scolddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


m_uvmzvdokumenttyp Variable

Dim m_uvmzvdokumenttyp As String

Source code

[Visual Basic]
    Dim m_uvmzvdokumenttyp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


notes Variable

Dim notes As New DataTable()

Source code

[Visual Basic]
    Dim notes As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


numnote Variable

Dim numnote As Object

Source code

[Visual Basic]
    Dim numnote As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


numpages Variable

Dim numpages As Integer = 1

Source code

[Visual Basic]
    Dim numpages As Integer = 1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


numservers Variable

Dim numservers

Source code

[Visual Basic]
    Dim numservers

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


page Variable

Dim page As Object

Source code

[Visual Basic]
    Dim page As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


poshscroll Variable

Dim poshscroll As Integer = 0

Source code

[Visual Basic]
    Dim poshscroll As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


posvscroll Variable

Dim posvscroll As Integer = 0

Source code

[Visual Basic]
    Dim posvscroll As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


publ Variable

Dim publ As Object

Source code

[Visual Basic]
    Dim publ As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


pw Variable

Dim pw

Source code

[Visual Basic]
    Dim pw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


rc Variable

Dim rc As Short

Source code

[Visual Basic]
    Dim rc As Short

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


ret Variable

Dim ret As Short

Source code

[Visual Basic]
    Dim ret As Short

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


server Variable

Dim server

Source code

[Visual Basic]
    Dim server

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


suchfeldstring1 Variable

Dim suchfeldstring1 As String = ""

Source code

[Visual Basic]
    Dim suchfeldstring1 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


suchfeldstring2 Variable

Dim suchfeldstring2 As String = ""

Source code

[Visual Basic]
    Dim suchfeldstring2 As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


tmp Variable

Dim tmp

Source code

[Visual Basic]
    Dim tmp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


txtdatetime Variable

Dim txtdatetime As String = ""

Source code

[Visual Basic]
    Dim txtdatetime As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


txttext Variable

Dim txttext As String = ""

Source code

[Visual Basic]
    Dim txttext As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


txtuser Variable

Dim txtuser As String = ""

Source code

[Visual Basic]
    Dim txtuser As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


user Variable

Dim user

Source code

[Visual Basic]
    Dim user

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


v1 Variable

Dim v1

Source code

[Visual Basic]
    Dim v1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


v2 Variable

Dim v2

Source code

[Visual Basic]
    Dim v2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


vscrol Variable

Dim WithEvents vscrol As New VScrollBar()

Source code

[Visual Basic]
    Dim WithEvents vscrol As New VScrollBar()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


xname Variable

Dim xname As String

Source code

[Visual Basic]
    Dim xname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


xnumdocs Variable

Dim xnumdocs

Source code

[Visual Basic]
    Dim xnumdocs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


xnumfields Variable

Dim xnumfields

Source code

[Visual Basic]
    Dim xnumfields

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldview


frmcoldviewer Class

For a list of all members of this type, see frmcoldviewer Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmcoldviewer

Public Class frmcoldviewer
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmcoldviewer Members


frmcoldviewer Members

frmcoldviewer overview

Constructors

constructor frmcoldviewer Constructor (Overloaded)

Properties

property Colddokumentid
property CollectionEntry
property CurrentPage
property DokumentId
property Dokumenttyp
property PartnerNr
property dokdata
property k
property o
property zf

Methods

method Cold_Login
method Dispose
method Form1_Load
method GetColdDokumente
method Get_Cold_Data_by_Dokumentid
method Get_Cold_Data_by_Dokumenttyp
method Get_Folder_Documents
method InitializeComponent
method Show_Dokument
method ToolBar1_ButtonClick
method get_annotations
method show_doc
method vscrol_ValueChanged

Fields

field ImageList1
field NoteLabel
field OnDemand
field Panel1
field PrintDocument1
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton11
field ToolBarButton12
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field ToolBtnExit
field belegart
field coldata
field components
field copied
field curpage
field first
field folder
field hscrol
field i
field m_colddokumentid
field m_coldfolder
field m_collectionentry
field m_currentpage
field m_data
field m_dokumentid
field m_dokumenttyp
field m_partnernr
field m_scolddokumentid
field notes
field numnote
field numpages
field numservers
field page
field publ
field pw
field rc
field ret
field server
field tmp
field txtdatetime
field txttext
field txtuser
field user
field v1
field v2
field vscrol
field xname
field xnumdocs
field xnumfields

See Also

frmcoldviewer Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal datacollection As Collection)

See Also

frmcoldviewer | EDOKAApp


frmcoldviewer Properties

frmcoldviewer overview

Properties

property Colddokumentid
property CollectionEntry
property CurrentPage
property DokumentId
property Dokumenttyp
property PartnerNr
property dokdata
property k
property o
property zf

See Also

frmcoldviewer Class


frmcoldviewer.Colddokumentid Property

Property Colddokumentid() As String

Source code

[Visual Basic]
    Property Colddokumentid() As String
        Get
            Return m_scolddokumentid
        End Get
        Set(ByVal Value As String)
            m_scolddokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.CollectionEntry Property

Property CollectionEntry() As Integer

Source code

[Visual Basic]
    Property CollectionEntry() As Integer
        Get
            Return m_collectionentry
        End Get
        Set(ByVal Value As Integer)
            m_collectionentry = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.CurrentPage Property

Property CurrentPage() As Integer

Source code

[Visual Basic]
    Property CurrentPage() As Integer
        Get
            Return m_currentpage
        End Get
        Set(ByVal Value As Integer)
            m_currentpage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.DokumentId Property

Property DokumentId() As String

Source code

[Visual Basic]
    Property DokumentId() As String
        Get
            Return m_dokumentid
        End Get
        Set(ByVal Value As String)
            m_dokumentid = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Dokumenttyp Property

Property Dokumenttyp() As Integer

Source code

[Visual Basic]
    Property Dokumenttyp() As Integer
        Get
            Return m_dokumenttyp
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.PartnerNr Property

Property PartnerNr() As String

Source code

[Visual Basic]
    Property PartnerNr() As String
        Get
            Return m_partnernr
        End Get
        Set(ByVal Value As String)
            m_partnernr = Value
            While Len(m_partnernr) < 9
                m_partnernr = "0" & m_partnernr
            End While

        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.dokdata Property

Property dokdata() As Collection

Source code

[Visual Basic]
    Property dokdata() As Collection
        Get
            Return m_data
        End Get
        Set(ByVal Value As Collection)
            m_data = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


k Property

Public k As Object

Source code

[Visual Basic]
    Public k As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


o Property

Public o As Object

Source code

[Visual Basic]
    Public o As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


zf Property

Public zf As Short = 100

Source code

[Visual Basic]
    Public zf As Short = 100

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer Methods

frmcoldviewer overview

Methods

method Cold_Login
method Dispose
method Form1_Load
method GetColdDokumente
method Get_Cold_Data_by_Dokumentid
method Get_Cold_Data_by_Dokumenttyp
method Get_Folder_Documents
method InitializeComponent
method Show_Dokument
method ToolBar1_ButtonClick
method get_annotations
method show_doc
method vscrol_ValueChanged

See Also

frmcoldviewer Class


frmcoldviewer.Cold_Login Method

Public Function Cold_Login() As Boolean

Source code

[Visual Basic]
    Public Function Cold_Login() As Boolean
        server = Globals.Applikationsdaten.Rows(0).Item("coldsystem")
        user = Globals.Applikationsdaten.Rows(0).Item("colduser")
        pw = Globals.Applikationsdaten.Rows(0).Item("coldpassword")
        Me.OnDemand.SetUserMessageMode(2)
        Me.OnDemand.Logon(server, user, pw)
        If ret <> 0 And ret <> 8 Then
            MsgBox("Die Anmeldung am COLD ist fehlgeschlagen", MsgBoxStyle.Exclamation)
            Cold_Login = False
            Exit Function
        End If
        Cold_Login = True
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Form1_Load Method

Private Sub Form1_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        show_doc(Me.CollectionEntry)

        'Dim m_dokument As New edokadb.clsDokument()
        'Get_Cold_Data_by_Dokumentid()
        'If Not Cold_Login() Then Exit Sub
        'Me.ondemand.BackColor = System.Drawing.Color.White

        'Me.CurrentPage = 1

        'Me.notes.Columns.Add("ID")
        'Me.notes.Columns.Add("Text")
        'Me.notes.Columns.Add("UserID")
        'Me.notes.Columns.Add("DateTime")
        'Me.notes.Columns.Add("Page")
        'Me.notes.Columns.Add("ispublic")
        'Me.notes.Columns.Add("canbecopied")
        'Me.notes.Columns.Add("status")
        'Show_Dokument(Me.m_coldfolder, Me.m_colddokumentid)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.GetColdDokumente Method

Public Function GetColdDokumente() As DataTable

Source code

[Visual Basic]
    Public Function GetColdDokumente() As DataTable
        Dim m_dokument As New edokadb.clsDokument()
        Get_Cold_Data_by_Dokumenttyp()
        If Not Me.Cold_Login Then Exit Function
        Get_Folder_Documents(Me.m_coldfolder)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Get_Cold_Data_by_Dokumentid Method

Private Function Get_Cold_Data_by_Dokumentid()

Source code

[Visual Basic]
    Private Function Get_Cold_Data_by_Dokumentid()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_get_coldfolder_by_documentid"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokumentId))

            sdaAdapter.Fill(dtToReturn)
            If Me.Colddokumentid = "" Then
                Me.m_colddokumentid = dtToReturn.Rows(0).Item(1)
            Else
                Me.m_colddokumentid = Me.Colddokumentid
            End If
            Me.m_coldfolder = dtToReturn.Rows(0).Item(0)
        Catch ex As Exception
            Throw New Exception("Get_Cold_Folder :" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Get_Cold_Data_by_Dokumenttyp Method

Private Function Get_Cold_Data_by_Dokumenttyp()

Source code

[Visual Basic]
    Private Function Get_Cold_Data_by_Dokumenttyp()
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.CommandText = "dbo.sp_get_coldfolder_by_documenttyp"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        Try
            scmCmdToExecute.Connection = conn.scoDBConnection
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttyp))
            sdaAdapter.Fill(dtToReturn)
            Me.m_coldfolder = dtToReturn.Rows(0).Item(0)
        Catch ex As Exception
            Throw New Exception("Get_Cold_Folder :" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Get_Folder_Documents Method

Private Function Get_Folder_Documents( _
   ByVal Folder As String _
)

Parameters

Folder
Required.

Source code

[Visual Basic]
    Private Function Get_Folder_Documents(ByVal Folder As String)
        ret = Me.OnDemand.SetUserMessageMode(0)
        ret = Me.OnDemand.OpenFolder(Folder)
        If ret <> 0 Then
            MsgBox("Der gewählte Order " & Folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.ClearFolderSearchFields()
        If ret <> 0 Then
            MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        Dim xx As String
        xx = ""
        ret = Me.OnDemand.SetFolderSearchFieldData("Partner-Nr.", 1, Me.PartnerNr, xx)
        'ret = Me.OnDemand.SetFolderSearchFieldData("Dok.-Status", 11, "Aktuell", xx)
        If ret <> 0 Then
            MsgBox("Fehler beim setzen des Suchkriteriums", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.SearchFolder(False)
        If ret <> 0 Then
            MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If

        ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
        If xnumdocs < 1 Then
            MsgBox("Es sind keine Dokumente gefunden worden.", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Function
        End If
        Dim tmp As String

        Dim i As Short
        Dim i1 As Short
        tmp = ""
        ret = OnDemand.GetNumFolderDisplayFields(xnumfields)
        Dim foldernames(xnumfields) As String
        For i = 0 To xnumfields - 1
            tmp = Nothing
            OnDemand.GetFolderDisplayFieldName(i, tmp)
            foldernames(i) = tmp
            MsgBox(foldernames(i))
        Next

        Dim t As New DataTable()
        Dim newrow As DataRow
        Dim rc As DataRowCollection
        rc = t.Rows
        Dim rowvals(xnumfields) As Object

        For i = 0 To xnumdocs
            For i1 = 0 To xnumfields
                ret = OnDemand.GetDocDisplayValue(i, i1, tmp)
                If ret = 0 Then
                    rowvals(i1) = tmp
                End If
            Next i1

            newrow = rc.Add(rowvals)
        Next i

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmcoldviewer))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBtnExit = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton3 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton4 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton5 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton6 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton7 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton8 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton9 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton10 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton11 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton12 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.PrintDocument1 = New System.Drawing.Printing.PrintDocument()
        Me.NoteLabel = New System.Windows.Forms.Label()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.OnDemand = New AxARSOLELib.AxArsOle()
        Me.Panel1.SuspendLayout()
        CType(Me.OnDemand, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBtnExit, Me.ToolBarButton1, Me.ToolBarButton2, Me.ToolBarButton3, Me.ToolBarButton4, Me.ToolBarButton5, Me.ToolBarButton6, Me.ToolBarButton7, Me.ToolBarButton8, Me.ToolBarButton9, Me.ToolBarButton10, Me.ToolBarButton11, Me.ToolBarButton12})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(824, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBtnExit
        '
        Me.ToolBtnExit.ImageIndex = 0
        Me.ToolBtnExit.ToolTipText = "Fenster schliessen"
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 1
        Me.ToolBarButton1.ToolTipText = "Dokument drucken"
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 9
        Me.ToolBarButton2.ToolTipText = "Vorherige Seite"
        '
        'ToolBarButton3
        '
        Me.ToolBarButton3.ImageIndex = 10
        Me.ToolBarButton3.ToolTipText = "Nächste Seite"
        '
        'ToolBarButton4
        '
        Me.ToolBarButton4.ImageIndex = 5
        Me.ToolBarButton4.ToolTipText = "Ansicht verkleinern"
        '
        'ToolBarButton5
        '
        Me.ToolBarButton5.ImageIndex = 4
        Me.ToolBarButton5.ToolTipText = "Ansicht vergrössern"
        '
        'ToolBarButton6
        '
        Me.ToolBarButton6.ImageIndex = 6
        Me.ToolBarButton6.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton7
        '
        Me.ToolBarButton7.ImageIndex = 6
        Me.ToolBarButton7.Visible = False
        '
        'ToolBarButton8
        '
        Me.ToolBarButton8.ImageIndex = 6
        Me.ToolBarButton8.Visible = False
        '
        'ToolBarButton9
        '
        Me.ToolBarButton9.Style = System.Windows.Forms.ToolBarButtonStyle.Separator
        '
        'ToolBarButton10
        '
        Me.ToolBarButton10.ImageIndex = 8
        Me.ToolBarButton10.ToolTipText = "Vorheriges Dokument"
        '
        'ToolBarButton11
        '
        Me.ToolBarButton11.ImageIndex = 7
        Me.ToolBarButton11.ToolTipText = "Nächstes Dokument"
        '
        'ToolBarButton12
        '
        Me.ToolBarButton12.ImageIndex = 11
        Me.ToolBarButton12.ToolTipText = "Dokument mit COLD-Viewer anzeigen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'NoteLabel
        '
        Me.NoteLabel.Location = New System.Drawing.Point(232, 8)
        Me.NoteLabel.Name = "NoteLabel"
        Me.NoteLabel.Size = New System.Drawing.Size(216, 16)
        Me.NoteLabel.TabIndex = 3
        Me.NoteLabel.Text = "Dokument 1 von 1"
        '
        'Panel1
        '
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.OnDemand})
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(824, 524)
        Me.Panel1.TabIndex = 4
        '
        'OnDemand
        '
        Me.OnDemand.ContainingControl = Me
        Me.OnDemand.Dock = System.Windows.Forms.DockStyle.Fill
        Me.OnDemand.Enabled = True
        Me.OnDemand.Name = "OnDemand"
        Me.OnDemand.OcxState = CType(resources.GetObject("OnDemand.OcxState"), System.Windows.Forms.AxHost.State)
        Me.OnDemand.Size = New System.Drawing.Size(824, 524)
        Me.OnDemand.TabIndex = 1
        '
        'frmcoldviewer
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.AutoScroll = True
        Me.AutoScrollMargin = New System.Drawing.Size(100, 0)
        Me.AutoScrollMinSize = New System.Drawing.Size(100, 100)
        Me.ClientSize = New System.Drawing.Size(824, 549)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.NoteLabel, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmcoldviewer"
        Me.ShowInTaskbar = False
        Me.Text = "Edoka-Cold-Dokumentviewer"
        Me.TransparencyKey = System.Drawing.Color.White
        Me.Panel1.ResumeLayout(False)
        CType(Me.OnDemand, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.Show_Dokument Method

Public Function Show_Dokument( _
   ByVal folder As String, _
   ByVal dokumentid As String _
)

Parameters

folder
Required.
dokumentid
Required.

Source code

[Visual Basic]
    Public Function Show_Dokument(ByVal folder As String, ByVal dokumentid As String)
        Dim rc
        Dim ret
        Dim xnumdocs
        Try
            ret = Me.OnDemand.SetUserMessageMode(0)
            ret = Me.OnDemand.OpenFolder(folder)
            If ret <> 0 Then
                MsgBox("Der gewählte Order " & folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Exit Function
            End If

            ret = Me.OnDemand.ClearFolderSearchFields()
            If ret <> 0 Then
                MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Exit Function
            End If

            Dim xx As String
            xx = ""
            ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 11, dokumentid, xx)
            If ret <> 0 Then
                MsgBox("Fehler beim setzen des Suchkriteriums", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Exit Function
            End If

            ret = Me.OnDemand.SearchFolder(False)
            If ret <> 0 Then
                MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Exit Function
            End If

            ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
            If xnumdocs < 1 Then
                MsgBox("Es sind keine Dokumente gefunden worden.", MsgBoxStyle.Critical)
                Me.OnDemand.Logoff()
                Exit Function
            End If
            Me.OnDemand.OpenDoc(0, "", 0)
            get_annotations()
        Catch ex As Exception
            MsgBox(ex.Message)
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0
                Me.Close()
            Case 1
                Me.OnDemand.PrintDoc(-1, 0, Me.PrintDocument1.PrinterSettings.PrinterName, True, 1, 3, 0.5, 0.5, 0.5, 0.5, False)
                Me.CurrentPage = Me.CurrentPage - 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage + 1
            Case 2
                Me.CurrentPage = Me.CurrentPage - 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage + 1
            Case 3
                Me.CurrentPage = Me.CurrentPage + 1
                ret = Me.OnDemand.SetDocCurrentPage(Me.CurrentPage)
                If ret <> 0 Then Me.CurrentPage = Me.CurrentPage - 1
            Case 4
                zf = zf - 25
                o = Nothing
                k = Nothing
                If zf < 25 Then zf = 25
                ret = Me.OnDemand.SetDocZoom(zf, o, k)
            Case 5
                zf = zf + 25
                o = Nothing
                k = Nothing
                If zf > 1000 Then zf = 1000
                ret = Me.OnDemand.SetDocZoom(zf, o, k)
            Case 7
                Dim f As New frmNotes()
                f.ondemand = Me.OnDemand
                f.notes = Me.notes
                f.ShowDialog()
            Case 10
                Me.CollectionEntry = Me.CollectionEntry - 1
                If Me.CollectionEntry < 1 Then Me.CollectionEntry = 1
                Me.show_doc(Me.CollectionEntry)
            Case 11
                Me.CollectionEntry = Me.CollectionEntry + 1
                If Me.CollectionEntry > Me.dokdata.Count Then Me.CollectionEntry = Me.dokdata.Count
                Me.show_doc(Me.CollectionEntry)
            Case 12
                coldata = dokdata(Me.CollectionEntry)
                DivFnkt.Erstellungsdatum = coldata.Erstellungsdatum
                DivFnkt.Auftragnr = coldata.Auftragnr
                DivFnkt.UVMZVDokumenttyp = coldata.DokumentTyp
                DivFnkt.Belegart = "ZV"
                DivFnkt.ShowColdDocHost(coldata.DokumentId, Me, coldata.DokumentId, coldata.PartnerNr, coldata.PartnerName, coldata.DokumentTyp)
                Me.Cursor = Cursors.Default
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.get_annotations Method

Public Function get_annotations()

Source code

[Visual Basic]
    Public Function get_annotations()

        Dim rc As DataRowCollection
        Dim newrow As DataRow()
        rc = notes.Rows
        Dim rowvals(7) As Object
        Dim i As Integer
        ret = Me.OnDemand.GetNumDocAnnotations(Me.numnote)

        For i = 0 To Me.numnote - 1
            ret = Me.OnDemand.GetAnnotationForDoc(i, txttext, txtuser, txtdatetime, page, publ, copied)
            rowvals(0) = i
            rowvals(1) = txttext
            rowvals(2) = txtuser
            rowvals(3) = txtdatetime
            rowvals(4) = page
            rowvals(5) = publ
            rowvals(6) = copied
            rowvals(7) = ""
            notes.Rows.Add(rowvals)
        Next

        'If Me.numnote > 0 Then
        '    Me.NoteCount.Text = Me.numnote.ToString
        '    Me.NoteCount.Visible = True
        '    Me.NoteLabel.Visible = True
        'Else
        '    Me.NoteCount.Visible = False
        '    Me.NoteLabel.Visible = False
        'End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.show_doc Method

Public Sub show_doc( _
   ByVal collectionentry As Integer _
)

Parameters

collectionentry
Required.

Source code

[Visual Basic]
    Public Sub show_doc(ByVal collectionentry As Integer)
        Dim xnumdocs
        Dim xnumfields
        Dim xname As String
        Dim i
        Dim v1
        Dim v2
        Dim numservers
        Dim rc As Short
        Dim ret As Short
        Dim tmp
        coldata = Me.dokdata.Item(collectionentry)
        If Not Me.Cold_Login Then
            MsgBox("Login to Cold failed")
            Exit Sub

        End If
        Me.NoteLabel.Text = "Dokument " + Me.CollectionEntry.ToString + " von " + Me.dokdata.Count.ToString
        '       Select Case coldata.Enum_Typ
        '           Case coldata.Enum_Typ.ZV
        belegart = "ZV"
        folder = "TGKB ZV-Scanning Belege (erweiterte Suche)"
        '          Case coldata.Enum_Typ.HOST
        'belegart = "HOST"
        'folder = "TGKB Kundenoutput AGI-OMS für EDOKA User"
        '       Case coldata.Enum_Typ.EDOKA
        '  End Select

        ret = Me.OnDemand.SetUserMessageMode(0)
        ret = Me.OnDemand.OpenFolder(folder)
        If ret <> 0 Then
            MsgBox("Der gewählte Order " & folder & " kann nicht geöffnet werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Sub
        End If

        rc = Me.OnDemand.GetNumFolderSearchFields(xnumfields)
        For i = 0 To xnumfields - 1
            tmp = ""
            ret = OnDemand.GetFolderSearchFieldName(i, tmp)
        Next

        ret = Me.OnDemand.ClearFolderSearchFields()
        If ret <> 0 Then
            MsgBox("Die Suchliste konnte nicht initialisiert werden", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Sub
        End If

        Dim xx As String
        xx = ""
        'Hutter 2004-10-04 Aktivierung COLD-Print
        Select Case belegart
            Case "HOST"
                ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 1, coldata.DokumentId, xx)
                ret = Me.OnDemand.SetFolderSearchFieldData("Erstellung od. Valuta Datum", 1, coldata.Erstellungsdatum, xx)
            Case "UVM"
            Case "ZV"
                ret = Me.OnDemand.SetFolderSearchFieldData("Dokumenttyp", 1, coldata.DokumentTyp, xx)
                ret = Me.OnDemand.SetFolderSearchFieldData("Auftrag-Nr.", 1, coldata.Auftragnr, xx)
                ret = Me.OnDemand.SetFolderSearchFieldData("Paginator", 1, coldata.DokumentId, xx)
            Case Else
                Dim s As String
                ' s = Trim(Me.PartnerNr)
                ' While Len(s) < 9
                ' s = "0" + s
                ' End While
                ' ret = Me.OnDemand.SetFolderSearchFieldData("Partner-Nr.", 1, s, xx)
                ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 11, DokumentId, xx)
        End Select
        'If Me.m_coldfolder = "TGKB Kundenoutput AGI-OMS für EDOKA User" Then
        '    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 1, Me.DokumentId, xx)
        '    ret = Me.OnDemand.SetFolderSearchFieldData("Erstellung od. Valuta Datum", 1, Me.Erstellungsdatum, xx)
        'Else
        '    ret = Me.OnDemand.SetFolderSearchFieldData("Dokument-Id", 11, dokumentid, xx)
        'End If

        If ret <> 0 Then
            MsgBox("Fehler beim setzen des Suchkriteriums", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Sub
        End If

        ret = Me.OnDemand.SearchFolder(False)
        If ret <> 0 Then
            MsgBox("Beim Zugriff auf das COLD ist ein Fehler aufgetreten", MsgBoxStyle.Critical)
            Me.OnDemand.Logoff()
            Exit Sub
        End If

        ret = Me.OnDemand.GetNumDocsInList(xnumdocs)
        If xnumdocs < 1 Then
            If Not DivFnkt.BDR_Dokument(Me.DokumentId) Then
                MyMsg.show_standardmessage(81, MsgBoxStyle.Information)
            Else
                MyMsg.show_standardmessage(275, MsgBoxStyle.Information)
            End If
            Me.OnDemand.Logoff()

            Exit Sub
        End If
        Try
            Me.OnDemand.CloseDoc()
        Catch
        End Try
        Me.OnDemand.OpenDoc(0, "", 0)
        Dim o As Object
        o = Nothing
        ret = OnDemand.GetDocNumPages(o)
        If ret = 0 Then Me.numpages = o
        o = Nothing
        ret = OnDemand.GetDocCurrentPage(o)
        If ret = 0 Then Me.curpage = o

        If first Then
            first = False
            zf = 75
            o = Nothing
            k = Nothing
            ret = Me.OnDemand.SetDocZoom(zf, o, k)
        End If
        o = Nothing
        k = Nothing
        ret = Me.OnDemand.SetDocZoom(zf, o, k)
        Me.CurrentPage = 1
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer.vscrol_ValueChanged Method

Private Sub vscrol_ValueChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles vscrol.ValueChanged

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vscrol_ValueChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles vscrol.ValueChanged
        Try
            zf = 1

            o = 60
            ret = Me.OnDemand.ScrollDocVert(zf, o)
        Catch ex As Exception
            MsgBox(ret)
            MsgBox(ex.Message)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer Fields

frmcoldviewer overview

Fields

field ImageList1
field NoteLabel
field OnDemand
field Panel1
field PrintDocument1
field ToolBar1
field ToolBarButton1
field ToolBarButton10
field ToolBarButton11
field ToolBarButton12
field ToolBarButton2
field ToolBarButton3
field ToolBarButton4
field ToolBarButton5
field ToolBarButton6
field ToolBarButton7
field ToolBarButton8
field ToolBarButton9
field ToolBtnExit
field belegart
field coldata
field components
field copied
field curpage
field first
field folder
field hscrol
field i
field m_colddokumentid
field m_coldfolder
field m_collectionentry
field m_currentpage
field m_data
field m_dokumentid
field m_dokumenttyp
field m_partnernr
field m_scolddokumentid
field notes
field numnote
field numpages
field numservers
field page
field publ
field pw
field rc
field ret
field server
field tmp
field txtdatetime
field txttext
field txtuser
field user
field v1
field v2
field vscrol
field xname
field xnumdocs
field xnumfields

See Also

frmcoldviewer Class


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


NoteLabel Variable

Friend WithEvents NoteLabel As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents NoteLabel As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


OnDemand Variable

Friend WithEvents OnDemand As AxARSOLELib.AxArsOle

Source code

[Visual Basic]
    Friend WithEvents OnDemand As AxARSOLELib.AxArsOle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


PrintDocument1 Variable

Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Source code

[Visual Basic]
    Friend WithEvents PrintDocument1 As System.Drawing.Printing.PrintDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton10 Variable

Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton10 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton11 Variable

Friend WithEvents ToolBarButton11 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton11 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton12 Variable

Friend WithEvents ToolBarButton12 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton12 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton3 Variable

Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton3 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton4 Variable

Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton4 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton5 Variable

Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton5 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton6 Variable

Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton6 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton7 Variable

Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton7 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton8 Variable

Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton8 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBarButton9 Variable

Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton9 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ToolBtnExit Variable

Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBtnExit As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


belegart Variable

Dim belegart As String

Source code

[Visual Basic]
    Dim belegart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


coldata Variable

Dim coldata As clsMehrfachdruck_Data

Source code

[Visual Basic]
    Dim coldata As clsMehrfachdruck_Data

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


copied Variable

Dim copied As Object

Source code

[Visual Basic]
    Dim copied As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


curpage Variable

Dim curpage As Integer

Source code

[Visual Basic]
    Dim curpage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


first Variable

Dim first As Boolean = True

Source code

[Visual Basic]
    Dim first As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


folder Variable

Dim folder As String

Source code

[Visual Basic]
    Dim folder As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


hscrol Variable

Dim WithEvents hscrol As New HScrollBar()

Source code

[Visual Basic]
    Dim WithEvents hscrol As New HScrollBar()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


i Variable

Dim i

Source code

[Visual Basic]
    Dim i

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_colddokumentid Variable

Dim m_colddokumentid As String

Source code

[Visual Basic]
    Dim m_colddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_coldfolder Variable

Dim m_coldfolder As String

Source code

[Visual Basic]
    Dim m_coldfolder As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_collectionentry Variable

Dim m_collectionentry As Integer = 1

Source code

[Visual Basic]
    Dim m_collectionentry As Integer = 1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_currentpage Variable

Dim m_currentpage As Integer

Source code

[Visual Basic]
    Dim m_currentpage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_data Variable

Dim m_data As New Collection()

Source code

[Visual Basic]
    Dim m_data As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_dokumentid Variable

Dim m_dokumentid As String

Source code

[Visual Basic]
    Dim m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_dokumenttyp Variable

Dim m_dokumenttyp As Integer

Source code

[Visual Basic]
    Dim m_dokumenttyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_partnernr Variable

Dim m_partnernr As String

Source code

[Visual Basic]
    Dim m_partnernr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


m_scolddokumentid Variable

Dim m_scolddokumentid As String

Source code

[Visual Basic]
    Dim m_scolddokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


notes Variable

Dim notes As New DataTable()

Source code

[Visual Basic]
    Dim notes As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


numnote Variable

Dim numnote As Object

Source code

[Visual Basic]
    Dim numnote As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


numpages Variable

Dim numpages As Integer

Source code

[Visual Basic]
    Dim numpages As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


numservers Variable

Dim numservers

Source code

[Visual Basic]
    Dim numservers

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


page Variable

Dim page As Object

Source code

[Visual Basic]
    Dim page As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


publ Variable

Dim publ As Object

Source code

[Visual Basic]
    Dim publ As Object

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


pw Variable

Dim pw

Source code

[Visual Basic]
    Dim pw

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


rc Variable

Dim rc As Short

Source code

[Visual Basic]
    Dim rc As Short

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


ret Variable

Dim ret As Short

Source code

[Visual Basic]
    Dim ret As Short

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


server Variable

Dim server

Source code

[Visual Basic]
    Dim server

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


tmp Variable

Dim tmp

Source code

[Visual Basic]
    Dim tmp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


txtdatetime Variable

Dim txtdatetime As String = ""

Source code

[Visual Basic]
    Dim txtdatetime As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


txttext Variable

Dim txttext As String = ""

Source code

[Visual Basic]
    Dim txttext As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


txtuser Variable

Dim txtuser As String = ""

Source code

[Visual Basic]
    Dim txtuser As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


user Variable

Dim user

Source code

[Visual Basic]
    Dim user

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


v1 Variable

Dim v1

Source code

[Visual Basic]
    Dim v1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


v2 Variable

Dim v2

Source code

[Visual Basic]
    Dim v2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


vscrol Variable

Dim WithEvents vscrol As New VScrollBar()

Source code

[Visual Basic]
    Dim WithEvents vscrol As New VScrollBar()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


xname Variable

Dim xname As String

Source code

[Visual Basic]
    Dim xname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


xnumdocs Variable

Dim xnumdocs

Source code

[Visual Basic]
    Dim xnumdocs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


xnumfields Variable

Dim xnumfields

Source code

[Visual Basic]
    Dim xnumfields

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmdomainloeschgrund Class

For a list of all members of this type, see frmdomainloeschgrund Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.frmdomainloeschgrund

Public Class frmdomainloeschgrund
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmdomainloeschgrund Members


frmdomainloeschgrund Members

frmdomainloeschgrund overview

Constructors

constructor frmdomainloeschgrund Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmdomainloeschgrund Class


frmdomainloeschgrund Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund Properties

frmdomainloeschgrund overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

frmdomainloeschgrund Class


frmdomainloeschgrund Methods

frmdomainloeschgrund overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method MenuItem3_Click
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method cldDomainBerechtigung_Load
method frmClose

See Also

frmdomainloeschgrund Class


frmdomainloeschgrund.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlConnection2 = New System.Data.SqlClient.SqlConnection()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "loeschgrund", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("loeschgrundnr", "loeschgrundnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung"), New System.Data.Common.DataColumnMapping("beschreibung", "beschreibung"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_loeschgrund_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection2
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_loeschgrund_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection2
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschgrundnr", System.Data.SqlDbType.Int, 4, "loeschgrundnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.VarChar, 10, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_loeschgrund_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection2
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@loeschgrundnr", System.Data.SqlDbType.Int, 4, "loeschgrundnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@beschreibung", System.Data.SqlDbType.VarChar, 255, "beschreibung"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Param1", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.VarChar, 10, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschgrundnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschgrundnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_loeschgrund_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection2
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_loeschgrundnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "loeschgrundnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_beschreibung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "beschreibung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.VarChar, 10, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlConnection2
        '
        Me.SqlConnection2.ConnectionString = "data source=shu;initial catalog=edoka_tkb;integrated security=SSPI;persist securi" & _
        "ty info=False;workstation id=SHU;packet size=4096"
        '
        'frmdomainloeschgrund
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(560, 272)
        Me.Name = "frmdomainloeschgrund"
        Me.Text = "frmDomainColdFolder"
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.MenuItem3_Click Method

Private Sub MenuItem3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem3.Click
        Save_Data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.cldDomainBerechtigung_Load Method

Private Sub cldDomainBerechtigung_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub cldDomainBerechtigung_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.TableName = "loeschgrund"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection2.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName

        SpaltenTitel_Aktualisieren(Me.DataSet1)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmdomainloeschgrund Fields

frmdomainloeschgrund overview

Fields

field DataSet1
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlConnection2
field SqlDataAdapter1
field SqlDeleteCommand1
field SqlInsertCommand1
field SqlSelectCommand1
field SqlUpdateCommand1
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

frmdomainloeschgrund Class


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlConnection2 Variable

Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection2 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmdomainloeschgrund


frmedokaUpdate Class

For a list of all members of this type, see frmedokaUpdate Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmedokaUpdate

Public Class frmedokaUpdate
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmedokaUpdate Members


frmedokaUpdate Members

frmedokaUpdate overview

Constructors

constructor frmedokaUpdate Constructor

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent

Fields

field Button1
field Button2
field Button3
field Button4
field Label1
field Label2
field Label3
field OpenFileDialog1
field TextBox1
field TextBox2
field TextBox3
field components

See Also

frmedokaUpdate Class


frmedokaUpdate Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate Methods

frmedokaUpdate overview

Methods

method Button1_Click
method Button2_Click
method Button3_Click
method Dispose
method InitializeComponent

See Also

frmedokaUpdate Class


frmedokaUpdate.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then Me.TextBox1.Text = Me.OpenFileDialog1.FileName
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.OpenFileDialog1.ShowDialog()
        If Me.OpenFileDialog1.FileName <> "" Then Me.TextBox2.Text = Me.OpenFileDialog1.FileName
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate.Button3_Click Method

Private Sub Button3_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button3.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button3.Click
        Dim update As New EdokaUpd()
        update.Save_To_DB(Me.TextBox1.Text, Me.TextBox2.Text, Me.TextBox3.Text)
        MsgBox("Nach der Anpassung der Versionsnummer wird EDOKA beim Neustart aktualisiert.")
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmedokaUpdate))
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.TextBox1 = New System.Windows.Forms.TextBox()
        Me.TextBox2 = New System.Windows.Forms.TextBox()
        Me.TextBox3 = New System.Windows.Forms.TextBox()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.OpenFileDialog1 = New System.Windows.Forms.OpenFileDialog()
        Me.Button3 = New System.Windows.Forms.Button()
        Me.Button4 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(16, 24)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(56, 23)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Datei 1"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(16, 48)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(56, 23)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Datei 2"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(16, 72)
        Me.Label3.Name = "Label3"
        Me.Label3.TabIndex = 2
        Me.Label3.Text = "Start-Kommando"
        '
        'TextBox1
        '
        Me.TextBox1.Location = New System.Drawing.Point(120, 24)
        Me.TextBox1.Name = "TextBox1"
        Me.TextBox1.Size = New System.Drawing.Size(232, 20)
        Me.TextBox1.TabIndex = 3
        Me.TextBox1.Text = ""
        '
        'TextBox2
        '
        Me.TextBox2.Location = New System.Drawing.Point(120, 48)
        Me.TextBox2.Name = "TextBox2"
        Me.TextBox2.Size = New System.Drawing.Size(232, 20)
        Me.TextBox2.TabIndex = 4
        Me.TextBox2.Text = ""
        '
        'TextBox3
        '
        Me.TextBox3.Location = New System.Drawing.Point(120, 72)
        Me.TextBox3.Name = "TextBox3"
        Me.TextBox3.Size = New System.Drawing.Size(232, 20)
        Me.TextBox3.TabIndex = 5
        Me.TextBox3.Text = ""
        '
        'Button1
        '
        Me.Button1.Image = CType(resources.GetObject("Button1.Image"), System.Drawing.Bitmap)
        Me.Button1.Location = New System.Drawing.Point(352, 24)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(24, 24)
        Me.Button1.TabIndex = 6
        '
        'Button2
        '
        Me.Button2.Image = CType(resources.GetObject("Button2.Image"), System.Drawing.Bitmap)
        Me.Button2.Location = New System.Drawing.Point(352, 48)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(24, 24)
        Me.Button2.TabIndex = 7
        '
        'Button3
        '
        Me.Button3.Location = New System.Drawing.Point(304, 112)
        Me.Button3.Name = "Button3"
        Me.Button3.TabIndex = 8
        Me.Button3.Text = "&OK"
        '
        'Button4
        '
        Me.Button4.Location = New System.Drawing.Point(8, 112)
        Me.Button4.Name = "Button4"
        Me.Button4.TabIndex = 9
        Me.Button4.Text = "&Abbruch"
        '
        'edokaUpdate
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 141)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button4, Me.Button3, Me.Button2, Me.Button1, Me.TextBox3, Me.TextBox2, Me.TextBox1, Me.Label3, Me.Label2, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "edokaUpdate"
        Me.Text = "EDOKA-Update"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmedokaUpdate Fields

frmedokaUpdate overview

Fields

field Button1
field Button2
field Button3
field Button4
field Label1
field Label2
field Label3
field OpenFileDialog1
field TextBox1
field TextBox2
field TextBox3
field components

See Also

frmedokaUpdate Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Button3 Variable

Friend WithEvents Button3 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button3 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Button4 Variable

Friend WithEvents Button4 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button4 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


OpenFileDialog1 Variable

Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Source code

[Visual Basic]
    Friend WithEvents OpenFileDialog1 As System.Windows.Forms.OpenFileDialog

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


TextBox1 Variable

Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


TextBox2 Variable

Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


TextBox3 Variable

Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents TextBox3 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmedokaUpdate


frmpartnermavip Class

For a list of all members of this type, see frmpartnermavip Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmpartnermavip

Public Class frmpartnermavip
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmpartnermavip Members


frmpartnermavip Members

frmpartnermavip overview

Constructors

constructor frmpartnermavip Constructor

Methods

method Dispose
method InitializeComponent
method MenuItem1_Click
method Reload_Data
method ToolBar1_ButtonClick
method frmpartnermavip_Load
method getdata
method insert_new_partner
method plist_AfterColUpdate
method update_partner

Fields

field ContextMenu1
field ImageList1
field MenuItem1
field MenuItem2
field ToolBar1
field ToolBarButton1
field components
field plist

See Also

frmpartnermavip Class


frmpartnermavip Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip Methods

frmpartnermavip overview

Methods

method Dispose
method InitializeComponent
method MenuItem1_Click
method Reload_Data
method ToolBar1_ButtonClick
method frmpartnermavip_Load
method getdata
method insert_new_partner
method plist_AfterColUpdate
method update_partner

See Also

frmpartnermavip Class


frmpartnermavip.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmpartnermavip))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.plist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.MenuItem1 = New System.Windows.Forms.MenuItem()
        Me.MenuItem2 = New System.Windows.Forms.MenuItem()
        CType(Me.plist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(672, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 0
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'plist
        '
        Me.plist.AllowDelete = True
        Me.plist.AllowFilter = True
        Me.plist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.plist.AllowSort = True
        Me.plist.AlternatingRows = True
        Me.plist.CaptionHeight = 17
        Me.plist.CollapseColor = System.Drawing.Color.Black
        Me.plist.ContextMenu = Me.ContextMenu1
        Me.plist.Cursor = System.Windows.Forms.Cursors.Default
        Me.plist.DataChanged = False
        Me.plist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.plist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.plist.ExpandColor = System.Drawing.Color.Black
        Me.plist.FetchRowStyles = True
        Me.plist.FilterBar = True
        Me.plist.GroupByCaption = "Drag a column header here to group by that column"
        Me.plist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.plist.Location = New System.Drawing.Point(0, 25)
        Me.plist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.plist.Name = "plist"
        Me.plist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.plist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.plist.PreviewInfo.ZoomFactor = 75
        Me.plist.PrintInfo.ShowOptionsDialog = False
        Me.plist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.plist.RowDivider = GridLines1
        Me.plist.RowHeight = 15
        Me.plist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.plist.ScrollTips = True
        Me.plist.Size = New System.Drawing.Size(672, 380)
        Me.plist.TabIndex = 28
        Me.plist.Text = "C1TrueDBGrid1"
        Me.plist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 668," & _
        " 376</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 668, " & _
        "376</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1, Me.MenuItem2})
        '
        'MenuItem1
        '
        Me.MenuItem1.Index = 0
        Me.MenuItem1.Text = "&Partner hinzufügen"
        '
        'MenuItem2
        '
        Me.MenuItem2.Index = 1
        Me.MenuItem2.Text = "Eintrag inaktivieren"
        '
        'frmpartnermavip
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(672, 405)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.plist, Me.ToolBar1})
        Me.Name = "frmpartnermavip"
        Me.Text = "Partner als Mitarbeiter/VIP"
        CType(Me.plist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.MenuItem1_Click Method

Private Sub MenuItem1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MenuItem1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub MenuItem1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MenuItem1.Click
        Dim f As New FrmPartnersuche()
        f.ShowDialog()
        If f.PartnerNr <> 0 Then
            insert_new_partner(f.PartnerNr)
            Me.Reload_Data()
            Dim i As Integer
            For i = 0 To Me.plist.Splits(0).Rows.Count
                If Me.plist.Columns(0).CellValue(i) = f.PartnerNr Then
                    Me.plist.Bookmark = i
                    Exit For
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.Reload_Data Method

Private Sub Reload_Data()

Source code

[Visual Basic]
    Private Sub Reload_Data()
        Dim dt As DataTable
        dt = getdata()
        Me.plist.DataSource = dt
        Me.plist.DataMember = dt.TableName
        Dim i As Integer
        For i = 0 To Me.plist.Splits(0).DisplayColumns.Count - 1
            Me.plist.Splits(0).DisplayColumns(i).AutoSize()
            Me.plist.Splits(0).DisplayColumns(i).Locked = True
        Next
        Me.plist.Columns("MA").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.plist.Columns("MA").ValueItems.DefaultItem = True
        Me.plist.Columns("MA").DefaultValue = True
        Me.plist.Splits(0).DisplayColumns("MA").Locked = False
        Me.plist.Columns("VIP").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.plist.Columns("VIP").ValueItems.DefaultItem = True
        Me.plist.Columns("VIP").DefaultValue = True
        Me.plist.Splits(0).DisplayColumns("VIP").Locked = False
        Me.plist.Columns("Aktiv").ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
        Me.plist.Columns("Aktiv").ValueItems.DefaultItem = True
        Me.plist.Columns("Aktiv").DefaultValue = True
        Me.plist.Splits(0).DisplayColumns("Aktiv").Locked = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.frmpartnermavip_Load Method

Private Sub frmpartnermavip_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmpartnermavip_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        reload_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.getdata Method

Private Function getdata() As DataTable

Source code

[Visual Basic]
    Private Function getdata() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_partner_ma_vip_get"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.insert_new_partner Method

Private Function insert_new_partner( _
   ByVal nrpar00 As Integer _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function insert_new_partner(ByVal nrpar00 As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_partner_ma_vip_insert"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            MsgBox("Der gewählte Partner ist bereits in der Aufzählung vorhanden.", MsgBoxStyle.Critical)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.plist_AfterColUpdate Method

Private Sub plist_AfterColUpdate( _
   ByVal sender As Object, _
   ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs _
) Handles plist.AfterColUpdate

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub plist_AfterColUpdate(ByVal sender As Object, ByVal e As C1.Win.C1TrueDBGrid.ColEventArgs) Handles plist.AfterColUpdate
        Dim i
        i = Me.plist.Bookmark
        Me.update_partner(Me.plist.Columns("partnernr").Value)
        Me.Reload_Data()
        Me.plist.Bookmark = i
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip.update_partner Method

Private Function update_partner( _
   ByVal nrpar00 As Integer _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
    Private Function update_partner(ByVal nrpar00 As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_partner_ma_vip_update"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@ma", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.plist.Columns("MA").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vip", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.plist.Columns("VIP").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@aktiv", SqlDbType.Int, 5, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.plist.Columns("Aktiv").Value))

            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpartnermavip Fields

frmpartnermavip overview

Fields

field ContextMenu1
field ImageList1
field MenuItem1
field MenuItem2
field ToolBar1
field ToolBarButton1
field components
field plist

See Also

frmpartnermavip Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


MenuItem1 Variable

Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


MenuItem2 Variable

Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents MenuItem2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


plist Variable

Friend WithEvents plist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents plist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpartnermavip


frmpersvorlageladen Class

For a list of all members of this type, see frmpersvorlageladen Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmpersvorlageladen

Public Class frmpersvorlageladen
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmpersvorlageladen Members


frmpersvorlageladen Members

frmpersvorlageladen overview

Constructors

constructor frmpersvorlageladen Constructor (Overloaded)

Properties

property PersVorlageNr

Methods

method Button1_Click
method Dispose
method InitializeComponent
method Load_data
method delete_vorlage
method frmpersvorlageladen_Load
method get_data
method mnudelete_Click
method mnuload_Click
method vorlagenlist_DoubleClick

Fields

field Button1
field ContextMenu1
field components
field dokumenttypnr
field m_PersVorlageNr
field mnudelete
field mnuload
field vorlagenlist

See Also

frmpersvorlageladen Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal dokumenttypnr As Integer)

See Also

frmpersvorlageladen | EDOKAApp


frmpersvorlageladen Properties

frmpersvorlageladen overview

Properties

property PersVorlageNr

See Also

frmpersvorlageladen Class


frmpersvorlageladen.PersVorlageNr Property

Property PersVorlageNr() As Integer

Source code

[Visual Basic]
    Property PersVorlageNr() As Integer
        Get
            Return m_PersVorlageNr
        End Get
        Set(ByVal Value As Integer)
            m_PersVorlageNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen Methods

frmpersvorlageladen overview

Methods

method Button1_Click
method Dispose
method InitializeComponent
method Load_data
method delete_vorlage
method frmpersvorlageladen_Load
method get_data
method mnudelete_Click
method mnuload_Click
method vorlagenlist_DoubleClick

See Also

frmpersvorlageladen Class


frmpersvorlageladen.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.PersVorlageNr = 0
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmpersvorlageladen))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.vorlagenlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuload = New System.Windows.Forms.MenuItem()
        Me.mnudelete = New System.Windows.Forms.MenuItem()
        Me.Button1 = New System.Windows.Forms.Button()
        CType(Me.vorlagenlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'vorlagenlist
        '
        Me.vorlagenlist.AllowFilter = True
        Me.vorlagenlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.vorlagenlist.AllowSort = True
        Me.vorlagenlist.AlternatingRows = True
        Me.vorlagenlist.CaptionHeight = 17
        Me.vorlagenlist.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Floating
        Me.vorlagenlist.CollapseColor = System.Drawing.Color.Black
        Me.vorlagenlist.ContextMenu = Me.ContextMenu1
        Me.vorlagenlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.vorlagenlist.DataChanged = False
        Me.vorlagenlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.vorlagenlist.Dock = System.Windows.Forms.DockStyle.Top
        Me.vorlagenlist.ExpandColor = System.Drawing.Color.Black
        Me.vorlagenlist.FetchRowStyles = True
        Me.vorlagenlist.FilterBar = True
        Me.vorlagenlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.vorlagenlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.vorlagenlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.vorlagenlist.Name = "vorlagenlist"
        Me.vorlagenlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.vorlagenlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.vorlagenlist.PreviewInfo.ZoomFactor = 75
        Me.vorlagenlist.PrintInfo.ShowOptionsDialog = False
        Me.vorlagenlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.vorlagenlist.RowDivider = GridLines1
        Me.vorlagenlist.RowHeight = 15
        Me.vorlagenlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.vorlagenlist.ScrollTips = True
        Me.vorlagenlist.Size = New System.Drawing.Size(368, 176)
        Me.vorlagenlist.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
        Me.vorlagenlist.TabIndex = 27
        Me.vorlagenlist.Text = "C1TrueDBGrid1"
        Me.vorlagenlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 364," & _
        " 172</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 364, " & _
        "172</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuload, Me.mnudelete})
        '
        'mnuload
        '
        Me.mnuload.Index = 0
        Me.mnuload.Text = "&Vorlage laden"
        '
        'mnudelete
        '
        Me.mnudelete.Index = 1
        Me.mnudelete.Text = "Vorlage &löschen"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(152, 184)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 28
        Me.Button1.Text = "&Schliessen"
        '
        'frmpersvorlageladen
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(368, 213)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Button1, Me.vorlagenlist})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmpersvorlageladen"
        Me.Text = "Persönliche Serienbriefvorlage laden"
        CType(Me.vorlagenlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.Load_data Method

Private Sub Load_data()

Source code

[Visual Basic]
    Private Sub Load_data()
        Me.vorlagenlist.DataSource = Nothing
        Me.vorlagenlist.DataMember = Nothing
        Dim dt As New DataTable()
        dt = get_data()
        Me.vorlagenlist.DataSource = dt
        Me.vorlagenlist.DataMember = dt.TableName
        If dt.Rows.Count = 0 Then
            Me.mnudelete.Enabled = False
            Me.mnuload.Enabled = False
        Else
            Me.mnudelete.Enabled = True
            Me.mnuload.Enabled = True
        End If
        Me.vorlagenlist.Splits(0).DisplayColumns(0).Width = 0
        Me.vorlagenlist.Splits(0).DisplayColumns(1).Width = Me.vorlagenlist.Width - 50
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.delete_vorlage Method

Private Function delete_vorlage() As DataTable

Source code

[Visual Basic]
    Private Function delete_vorlage() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_delte_persvorlagen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.vorlagenlist.Columns(0).Text))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.frmpersvorlageladen_Load Method

Private Sub frmpersvorlageladen_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmpersvorlageladen_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.PersVorlageNr = 0
        Load_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.get_data Method

Private Function get_data() As DataTable

Source code

[Visual Basic]
    Private Function get_data() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_get_persvorlagen"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.dokumenttypnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.mnudelete_Click Method

Private Sub mnudelete_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnudelete.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnudelete_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnudelete.Click
        Try
            If MyMsg.Show_MessageYesNo(739) = MsgBoxResult.Yes Then
                delete_vorlage()
                Load_data()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.mnuload_Click Method

Private Sub mnuload_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuload.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuload_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuload.Click
        Try
            Me.PersVorlageNr = Me.vorlagenlist.Columns(0).Text
            Me.Close()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen.vorlagenlist_DoubleClick Method

Private Sub vorlagenlist_DoubleClick( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles vorlagenlist.DoubleClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub vorlagenlist_DoubleClick(ByVal sender As Object, ByVal e As System.EventArgs) Handles vorlagenlist.DoubleClick
        mnuload_Click(sender, e)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen Fields

frmpersvorlageladen overview

Fields

field Button1
field ContextMenu1
field components
field dokumenttypnr
field m_PersVorlageNr
field mnudelete
field mnuload
field vorlagenlist

See Also

frmpersvorlageladen Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


dokumenttypnr Variable

Dim dokumenttypnr As Integer

Source code

[Visual Basic]
    Dim dokumenttypnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


m_PersVorlageNr Variable

Dim m_PersVorlageNr As Integer

Source code

[Visual Basic]
    Dim m_PersVorlageNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


mnudelete Variable

Friend WithEvents mnudelete As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudelete As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


mnuload Variable

Friend WithEvents mnuload As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuload As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


vorlagenlist Variable

Friend WithEvents vorlagenlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents vorlagenlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmsbdruck Class

For a list of all members of this type, see frmsbdruck Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmsbdruck

Public Class frmsbdruck
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmsbdruck Members


frmsbdruck Members

frmsbdruck overview

Constructors

constructor frmsbdruck Constructor (Overloaded)

Properties

property datasaved

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method c1deldok_Click
method c1dokumentedrucken_Click
method c1showdoc_Click
method c1statuszuruecksetzen_Click
method djlist_MouseDown
method frmsbdruck_Load
method get_druckjobs
method pdfprinter_PrintDOne
method refresh_data
method set_druckjobstatus

Fields

field C1CommandHolder1
field C1CommandLink1
field C1CommandLink2
field C1CommandLink3
field C1CommandLink4
field C1CommandMenu1
field C1ContextMenu1
field C1MnuDokumenteGenerieren
field C1MnuEDOKAHOSTPartnerHinzufuegen
field C1MnuEDOKAPartnerErfassen
field C1MnuMainAddColumn
field C1MnuMainCheckEmpfaenger
field C1MnuMainDeleteColumn
field C1MnuMainDokumenteBestaetigen
field C1MnuMainDokumenteDrucken
field C1MnuMainEDOKAPartnerErfassen
field C1MnuMainEmpfaengerBearbeitten
field C1MnuMainEmpfaengerLoeschen
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerEmpfaengerErfassen
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuMainVorschauErstellen
field C1MnuSerienbriefLoeschen
field ImageList1
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEDOKAPartnerErfassen
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field ToolBar1
field ToolBarButton1
field c1deldok
field c1dokumentedrucken
field c1showdoc
field c1statuszuruecksetzen
field components
field djlist
field m_datasaved
field mnuCTADDEdokapartner
field mnuctAddHost
field mnuctaddempfaenger
field pdfprinter
field serienbriefnr

See Also

frmsbdruck Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal serienbriefnr As Integer)

See Also

frmsbdruck | EDOKAApp


frmsbdruck Properties

frmsbdruck overview

Properties

property datasaved

See Also

frmsbdruck Class


frmsbdruck.datasaved Property

Property datasaved() As Boolean

Source code

[Visual Basic]
    Property datasaved() As Boolean
        Get
            Return m_datasaved
        End Get
        Set(ByVal Value As Boolean)
            m_datasaved = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck Methods

frmsbdruck overview

Methods

method Dispose
method InitializeComponent
method ToolBar1_ButtonClick
method c1deldok_Click
method c1dokumentedrucken_Click
method c1showdoc_Click
method c1statuszuruecksetzen_Click
method djlist_MouseDown
method frmsbdruck_Load
method get_druckjobs
method pdfprinter_PrintDOne
method refresh_data
method set_druckjobstatus

See Also

frmsbdruck Class


frmsbdruck.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmsbdruck))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.C1CommandHolder1 = New C1.Win.C1Command.C1CommandHolder()
        Me.MnuMainDatei = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainNeuerSerienbrief = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainNew = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefLaden = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoad = New C1.Win.C1Command.C1Command()
        Me.C1MnuSerienbriefLoeschen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSerienbriefLoeschen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefabschliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAbschluss = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSerienbriefSpeichern = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSave = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainFensterSchliessen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainClose = New C1.Win.C1Command.C1Command()
        Me.MnuMainDokument = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainVorlageImportieren = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorlageImportieren = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainVorlageBearbeiten = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorageBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainVorschauErstellen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainVorschauErstellen = New C1.Win.C1Command.C1Command()
        Me.C1MnuDokumenteGenerieren = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDokumenteGenerieren = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainDokumenteDrucken = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDokumenteDrucken = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainDokumenteBestaetigen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDokumenteBestaetigen = New C1.Win.C1Command.C1Command()
        Me.MnuMainEmpfaengerliste = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuEDOKAHOSTPartnerHinzufuegen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAddEDOKAHOSTPartner = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainEDOKAPartnerErfassen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainNeuerEDOKAPartnerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainNeuerEmpfaengerErfassen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainNeuerEmpfaengerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainEmpfaengerBearbeitten = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmpfaengerBearbeiten = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainEmpfaengerLoeschen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEmfpaengerLoeschen = New C1.Win.C1Command.C1Command()
        Me.C1MnuEDOKAPartnerErfassen = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainEDOKAPartnerErfassen = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainImportEmpfaneger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainImportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainExportEmpfaenger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainExportEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainLoadPartnerliste = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainLoadPartnerliste = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSaveAsPartnerlist = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainCheckEmpfaenger = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainCheckEmpfaenger = New C1.Win.C1Command.C1Command()
        Me.C1CommandMenu1 = New C1.Win.C1Command.C1CommandMenu()
        Me.C1MnuMainAddColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainAddColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainDeleteColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainDeleteColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainRenameColumn = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainRenameColumn = New C1.Win.C1Command.C1Command()
        Me.C1MnuMainSpaltenselektion = New C1.Win.C1Command.C1CommandLink()
        Me.MnuMainSpaltenselektion = New C1.Win.C1Command.C1Command()
        Me.mnuctAddHost = New C1.Win.C1Command.C1Command()
        Me.mnuCTADDEdokapartner = New C1.Win.C1Command.C1Command()
        Me.mnuctaddempfaenger = New C1.Win.C1Command.C1Command()
        Me.C1ContextMenu1 = New C1.Win.C1Command.C1ContextMenu()
        Me.C1CommandLink1 = New C1.Win.C1Command.C1CommandLink()
        Me.c1dokumentedrucken = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink3 = New C1.Win.C1Command.C1CommandLink()
        Me.c1showdoc = New C1.Win.C1Command.C1Command()
        Me.C1CommandLink2 = New C1.Win.C1Command.C1CommandLink()
        Me.c1statuszuruecksetzen = New C1.Win.C1Command.C1Command()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.djlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.C1CommandLink4 = New C1.Win.C1Command.C1CommandLink()
        Me.c1deldok = New C1.Win.C1Command.C1Command()
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.djlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'C1CommandHolder1
        '
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDatei)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNew)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoad)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSave)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainClose)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokument)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorlageImportieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorageBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainVorschauErstellen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteGenerieren)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteDrucken)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDokumenteBestaetigen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddEDOKAHOSTPartner)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEDOKAPartnerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainNeuerEmpfaengerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainLoadPartnerliste)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSaveAsPartnerlist)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainImportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainExportEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEDOKAPartnerErfassen)
        Me.C1CommandHolder1.Commands.Add(Me.C1CommandMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAddColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainDeleteColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainRenameColumn)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSpaltenselektion)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainAbschluss)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmpfaengerBearbeiten)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainEmfpaengerLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainCheckEmpfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.MnuMainSerienbriefLoeschen)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctAddHost)
        Me.C1CommandHolder1.Commands.Add(Me.mnuCTADDEdokapartner)
        Me.C1CommandHolder1.Commands.Add(Me.mnuctaddempfaenger)
        Me.C1CommandHolder1.Commands.Add(Me.C1ContextMenu1)
        Me.C1CommandHolder1.Commands.Add(Me.c1dokumentedrucken)
        Me.C1CommandHolder1.Commands.Add(Me.c1statuszuruecksetzen)
        Me.C1CommandHolder1.Commands.Add(Me.c1showdoc)
        Me.C1CommandHolder1.Commands.Add(Me.c1deldok)
        Me.C1CommandHolder1.ImageList = Me.ImageList1
        Me.C1CommandHolder1.Owner = Me
        Me.C1CommandHolder1.SmoothImages = False
        '
        'MnuMainDatei
        '
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainNeuerSerienbrief)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefLaden)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuSerienbriefLoeschen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefabschliessen)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainSerienbriefSpeichern)
        Me.MnuMainDatei.CommandLinks.Add(Me.C1MnuMainFensterSchliessen)
        Me.MnuMainDatei.Image = Nothing
        Me.MnuMainDatei.Name = "MnuMainDatei"
        Me.MnuMainDatei.Text = "&Datei"
        '
        'C1MnuMainNeuerSerienbrief
        '
        Me.C1MnuMainNeuerSerienbrief.Command = Me.MnuMainNew
        Me.C1MnuMainNeuerSerienbrief.Text = "&Neuer Serienbrief"
        '
        'MnuMainNew
        '
        Me.MnuMainNew.Image = Nothing
        Me.MnuMainNew.ImageIndex = 20
        Me.MnuMainNew.Name = "MnuMainNew"
        Me.MnuMainNew.Text = "&Neuer Serienbrief"
        '
        'C1MnuMainSerienbriefLaden
        '
        Me.C1MnuMainSerienbriefLaden.Command = Me.MnuMainLoad
        Me.C1MnuMainSerienbriefLaden.Text = "Serienbrief &laden"
        '
        'MnuMainLoad
        '
        Me.MnuMainLoad.Image = Nothing
        Me.MnuMainLoad.ImageIndex = 22
        Me.MnuMainLoad.Name = "MnuMainLoad"
        Me.MnuMainLoad.Text = "Serienbrief &laden"
        '
        'C1MnuSerienbriefLoeschen
        '
        Me.C1MnuSerienbriefLoeschen.Command = Me.MnuMainSerienbriefLoeschen
        Me.C1MnuSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'MnuMainSerienbriefLoeschen
        '
        Me.MnuMainSerienbriefLoeschen.Image = Nothing
        Me.MnuMainSerienbriefLoeschen.ImageIndex = 23
        Me.MnuMainSerienbriefLoeschen.Name = "MnuMainSerienbriefLoeschen"
        Me.MnuMainSerienbriefLoeschen.Text = "Serienbrief löschen"
        '
        'C1MnuMainSerienbriefabschliessen
        '
        Me.C1MnuMainSerienbriefabschliessen.Command = Me.MnuMainAbschluss
        Me.C1MnuMainSerienbriefabschliessen.Text = "Serienbrief abschliessen"
        '
        'MnuMainAbschluss
        '
        Me.MnuMainAbschluss.Image = Nothing
        Me.MnuMainAbschluss.ImageIndex = 27
        Me.MnuMainAbschluss.Name = "MnuMainAbschluss"
        Me.MnuMainAbschluss.Text = "Serienbrief abschliessen"
        '
        'C1MnuMainSerienbriefSpeichern
        '
        Me.C1MnuMainSerienbriefSpeichern.Command = Me.MnuMainSave
        Me.C1MnuMainSerienbriefSpeichern.Delimiter = True
        Me.C1MnuMainSerienbriefSpeichern.Text = "&Serienbrief speichern"
        '
        'MnuMainSave
        '
        Me.MnuMainSave.Image = Nothing
        Me.MnuMainSave.ImageIndex = 24
        Me.MnuMainSave.Name = "MnuMainSave"
        Me.MnuMainSave.Text = "&Serienbrief speichern"
        '
        'C1MnuMainFensterSchliessen
        '
        Me.C1MnuMainFensterSchliessen.Command = Me.MnuMainClose
        Me.C1MnuMainFensterSchliessen.Delimiter = True
        Me.C1MnuMainFensterSchliessen.Text = "&Fenster schliessen"
        '
        'MnuMainClose
        '
        Me.MnuMainClose.Image = CType(resources.GetObject("MnuMainClose.Image"), System.Drawing.Bitmap)
        Me.MnuMainClose.ImageIndex = 0
        Me.MnuMainClose.Name = "MnuMainClose"
        Me.MnuMainClose.Text = "&Fenster schliessen"
        '
        'MnuMainDokument
        '
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageImportieren)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorlageBearbeiten)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainVorschauErstellen)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuDokumenteGenerieren)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainDokumenteDrucken)
        Me.MnuMainDokument.CommandLinks.Add(Me.C1MnuMainDokumenteBestaetigen)
        Me.MnuMainDokument.Image = Nothing
        Me.MnuMainDokument.Name = "MnuMainDokument"
        Me.MnuMainDokument.Text = "Dokument"
        '
        'C1MnuMainVorlageImportieren
        '
        Me.C1MnuMainVorlageImportieren.Command = Me.MnuMainVorlageImportieren
        Me.C1MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'MnuMainVorlageImportieren
        '
        Me.MnuMainVorlageImportieren.Image = Nothing
        Me.MnuMainVorlageImportieren.Name = "MnuMainVorlageImportieren"
        Me.MnuMainVorlageImportieren.Text = "Vorlage &importieren"
        '
        'C1MnuMainVorlageBearbeiten
        '
        Me.C1MnuMainVorlageBearbeiten.Command = Me.MnuMainVorageBearbeiten
        Me.C1MnuMainVorlageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'MnuMainVorageBearbeiten
        '
        Me.MnuMainVorageBearbeiten.Image = Nothing
        Me.MnuMainVorageBearbeiten.ImageIndex = 25
        Me.MnuMainVorageBearbeiten.Name = "MnuMainVorageBearbeiten"
        Me.MnuMainVorageBearbeiten.Text = "Vorlage &bearbeiten"
        '
        'C1MnuMainVorschauErstellen
        '
        Me.C1MnuMainVorschauErstellen.Command = Me.MnuMainVorschauErstellen
        Me.C1MnuMainVorschauErstellen.Delimiter = True
        Me.C1MnuMainVorschauErstellen.Text = "Vorschau erstellen"
        '
        'MnuMainVorschauErstellen
        '
        Me.MnuMainVorschauErstellen.Image = Nothing
        Me.MnuMainVorschauErstellen.ImageIndex = 26
        Me.MnuMainVorschauErstellen.Name = "MnuMainVorschauErstellen"
        Me.MnuMainVorschauErstellen.Text = "Vorschau erstellen"
        '
        'C1MnuDokumenteGenerieren
        '
        Me.C1MnuDokumenteGenerieren.Command = Me.MnuMainDokumenteGenerieren
        Me.C1MnuDokumenteGenerieren.Delimiter = True
        Me.C1MnuDokumenteGenerieren.Text = "Dokumente &generieren"
        '
        'MnuMainDokumenteGenerieren
        '
        Me.MnuMainDokumenteGenerieren.Image = Nothing
        Me.MnuMainDokumenteGenerieren.ImageIndex = 15
        Me.MnuMainDokumenteGenerieren.Name = "MnuMainDokumenteGenerieren"
        Me.MnuMainDokumenteGenerieren.Text = "Dokumente &generieren"
        '
        'C1MnuMainDokumenteDrucken
        '
        Me.C1MnuMainDokumenteDrucken.Command = Me.MnuMainDokumenteDrucken
        Me.C1MnuMainDokumenteDrucken.Text = "Dokumente &drucken"
        '
        'MnuMainDokumenteDrucken
        '
        Me.MnuMainDokumenteDrucken.Image = Nothing
        Me.MnuMainDokumenteDrucken.ImageIndex = 14
        Me.MnuMainDokumenteDrucken.Name = "MnuMainDokumenteDrucken"
        Me.MnuMainDokumenteDrucken.Text = "Dokumente &drucken"
        '
        'C1MnuMainDokumenteBestaetigen
        '
        Me.C1MnuMainDokumenteBestaetigen.Command = Me.MnuMainDokumenteBestaetigen
        Me.C1MnuMainDokumenteBestaetigen.Text = "Generierte Dokumente bestätigen"
        '
        'MnuMainDokumenteBestaetigen
        '
        Me.MnuMainDokumenteBestaetigen.Image = Nothing
        Me.MnuMainDokumenteBestaetigen.ImageIndex = 13
        Me.MnuMainDokumenteBestaetigen.Name = "MnuMainDokumenteBestaetigen"
        Me.MnuMainDokumenteBestaetigen.Text = "Generierte Dokumente bestätigen"
        '
        'MnuMainEmpfaengerliste
        '
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuEDOKAHOSTPartnerHinzufuegen)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainEDOKAPartnerErfassen)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainNeuerEmpfaengerErfassen)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainEmpfaengerBearbeitten)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainEmpfaengerLoeschen)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuEDOKAPartnerErfassen)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainImportEmpfaneger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainExportEmpfaenger)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainLoadPartnerliste)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainSaveAsPartnerlist)
        Me.MnuMainEmpfaengerliste.CommandLinks.Add(Me.C1MnuMainCheckEmpfaenger)
        Me.MnuMainEmpfaengerliste.Image = Nothing
        Me.MnuMainEmpfaengerliste.Name = "MnuMainEmpfaengerliste"
        Me.MnuMainEmpfaengerliste.Text = "Empfängerliste"
        '
        'C1MnuEDOKAHOSTPartnerHinzufuegen
        '
        Me.C1MnuEDOKAHOSTPartnerHinzufuegen.Command = Me.MnuMainAddEDOKAHOSTPartner
        Me.C1MnuEDOKAHOSTPartnerHinzufuegen.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'MnuMainAddEDOKAHOSTPartner
        '
        Me.MnuMainAddEDOKAHOSTPartner.Image = Nothing
        Me.MnuMainAddEDOKAHOSTPartner.ImageIndex = 16
        Me.MnuMainAddEDOKAHOSTPartner.Name = "MnuMainAddEDOKAHOSTPartner"
        Me.MnuMainAddEDOKAHOSTPartner.Shortcut = System.Windows.Forms.Shortcut.CtrlP
        Me.MnuMainAddEDOKAHOSTPartner.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'C1MnuMainEDOKAPartnerErfassen
        '
        Me.C1MnuMainEDOKAPartnerErfassen.Command = Me.MnuMainNeuerEDOKAPartnerErfassen
        Me.C1MnuMainEDOKAPartnerErfassen.Text = "&Neuer EDOKA-Partner erfassen"
        '
        'MnuMainNeuerEDOKAPartnerErfassen
        '
        Me.MnuMainNeuerEDOKAPartnerErfassen.Image = Nothing
        Me.MnuMainNeuerEDOKAPartnerErfassen.ImageIndex = 18
        Me.MnuMainNeuerEDOKAPartnerErfassen.Name = "MnuMainNeuerEDOKAPartnerErfassen"
        Me.MnuMainNeuerEDOKAPartnerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlN
        Me.MnuMainNeuerEDOKAPartnerErfassen.Text = "&Neuer EDOKA-Partner erfassen"
        '
        'C1MnuMainNeuerEmpfaengerErfassen
        '
        Me.C1MnuMainNeuerEmpfaengerErfassen.Command = Me.MnuMainNeuerEmpfaengerErfassen
        Me.C1MnuMainNeuerEmpfaengerErfassen.Text = "Neuer E&mpfänger erfassen"
        '
        'MnuMainNeuerEmpfaengerErfassen
        '
        Me.MnuMainNeuerEmpfaengerErfassen.Image = Nothing
        Me.MnuMainNeuerEmpfaengerErfassen.ImageIndex = 19
        Me.MnuMainNeuerEmpfaengerErfassen.Name = "MnuMainNeuerEmpfaengerErfassen"
        Me.MnuMainNeuerEmpfaengerErfassen.Shortcut = System.Windows.Forms.Shortcut.CtrlE
        Me.MnuMainNeuerEmpfaengerErfassen.Text = "Neuer E&mpfänger erfassen"
        '
        'C1MnuMainEmpfaengerBearbeitten
        '
        Me.C1MnuMainEmpfaengerBearbeitten.Command = Me.MnuMainEmpfaengerBearbeiten
        Me.C1MnuMainEmpfaengerBearbeitten.Delimiter = True
        Me.C1MnuMainEmpfaengerBearbeitten.Text = "Markierter Empfänger bearbeiten"
        '
        'MnuMainEmpfaengerBearbeiten
        '
        Me.MnuMainEmpfaengerBearbeiten.Image = Nothing
        Me.MnuMainEmpfaengerBearbeiten.Name = "MnuMainEmpfaengerBearbeiten"
        Me.MnuMainEmpfaengerBearbeiten.Text = "Markierter Empfänger bearbeiten"
        '
        'C1MnuMainEmpfaengerLoeschen
        '
        Me.C1MnuMainEmpfaengerLoeschen.Command = Me.MnuMainEmfpaengerLoeschen
        Me.C1MnuMainEmpfaengerLoeschen.Text = "Markierter Empfänger löschen"
        '
        'MnuMainEmfpaengerLoeschen
        '
        Me.MnuMainEmfpaengerLoeschen.Image = Nothing
        Me.MnuMainEmfpaengerLoeschen.Name = "MnuMainEmfpaengerLoeschen"
        Me.MnuMainEmfpaengerLoeschen.Text = "Markierter Empfänger löschen"
        '
        'C1MnuEDOKAPartnerErfassen
        '
        Me.C1MnuEDOKAPartnerErfassen.Command = Me.MnuMainEDOKAPartnerErfassen
        Me.C1MnuEDOKAPartnerErfassen.Text = "Markierter Empfänger als EDOKA-Partner erfassen"
        '
        'MnuMainEDOKAPartnerErfassen
        '
        Me.MnuMainEDOKAPartnerErfassen.Image = Nothing
        Me.MnuMainEDOKAPartnerErfassen.Name = "MnuMainEDOKAPartnerErfassen"
        Me.MnuMainEDOKAPartnerErfassen.Text = "Markierter Empfänger als EDOKA-Partner erfassen"
        '
        'C1MnuMainImportEmpfaneger
        '
        Me.C1MnuMainImportEmpfaneger.Command = Me.MnuMainImportEmpfaenger
        Me.C1MnuMainImportEmpfaneger.Delimiter = True
        Me.C1MnuMainImportEmpfaneger.Text = "Empfängerliste importieren"
        '
        'MnuMainImportEmpfaenger
        '
        Me.MnuMainImportEmpfaenger.Image = Nothing
        Me.MnuMainImportEmpfaenger.Name = "MnuMainImportEmpfaenger"
        Me.MnuMainImportEmpfaenger.Text = "Empfängerliste importieren"
        '
        'C1MnuMainExportEmpfaenger
        '
        Me.C1MnuMainExportEmpfaenger.Command = Me.MnuMainExportEmpfaenger
        Me.C1MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'MnuMainExportEmpfaenger
        '
        Me.MnuMainExportEmpfaenger.Image = Nothing
        Me.MnuMainExportEmpfaenger.Name = "MnuMainExportEmpfaenger"
        Me.MnuMainExportEmpfaenger.Text = "Empfängerliste exportieren"
        '
        'C1MnuMainLoadPartnerliste
        '
        Me.C1MnuMainLoadPartnerliste.Command = Me.MnuMainLoadPartnerliste
        Me.C1MnuMainLoadPartnerliste.Delimiter = True
        Me.C1MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'MnuMainLoadPartnerliste
        '
        Me.MnuMainLoadPartnerliste.Image = Nothing
        Me.MnuMainLoadPartnerliste.Name = "MnuMainLoadPartnerliste"
        Me.MnuMainLoadPartnerliste.Text = "&Bestehende Partnerliste laden"
        '
        'C1MnuMainSaveAsPartnerlist
        '
        Me.C1MnuMainSaveAsPartnerlist.Command = Me.MnuMainSaveAsPartnerlist
        Me.C1MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'MnuMainSaveAsPartnerlist
        '
        Me.MnuMainSaveAsPartnerlist.Image = Nothing
        Me.MnuMainSaveAsPartnerlist.Name = "MnuMainSaveAsPartnerlist"
        Me.MnuMainSaveAsPartnerlist.Text = "Emfänger als Partnerliste speichern"
        '
        'C1MnuMainCheckEmpfaenger
        '
        Me.C1MnuMainCheckEmpfaenger.Command = Me.MnuMainCheckEmpfaenger
        Me.C1MnuMainCheckEmpfaenger.Delimiter = True
        Me.C1MnuMainCheckEmpfaenger.Text = "Empfängerliste prüfen"
        '
        'MnuMainCheckEmpfaenger
        '
        Me.MnuMainCheckEmpfaenger.Image = Nothing
        Me.MnuMainCheckEmpfaenger.ImageIndex = 17
        Me.MnuMainCheckEmpfaenger.Name = "MnuMainCheckEmpfaenger"
        Me.MnuMainCheckEmpfaenger.Text = "Empfängerliste prüfen"
        '
        'C1CommandMenu1
        '
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainAddColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainDeleteColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainRenameColumn)
        Me.C1CommandMenu1.CommandLinks.Add(Me.C1MnuMainSpaltenselektion)
        Me.C1CommandMenu1.Image = Nothing
        Me.C1CommandMenu1.Name = "C1CommandMenu1"
        Me.C1CommandMenu1.Text = "&Individuelle Dokumentwerte"
        '
        'C1MnuMainAddColumn
        '
        Me.C1MnuMainAddColumn.Command = Me.MnuMainAddColumn
        Me.C1MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'MnuMainAddColumn
        '
        Me.MnuMainAddColumn.Image = Nothing
        Me.MnuMainAddColumn.Name = "MnuMainAddColumn"
        Me.MnuMainAddColumn.Text = "Spalte hinzufügen"
        '
        'C1MnuMainDeleteColumn
        '
        Me.C1MnuMainDeleteColumn.Command = Me.MnuMainDeleteColumn
        Me.C1MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'MnuMainDeleteColumn
        '
        Me.MnuMainDeleteColumn.Image = Nothing
        Me.MnuMainDeleteColumn.Name = "MnuMainDeleteColumn"
        Me.MnuMainDeleteColumn.Text = "Markierte Spalte löschen"
        '
        'C1MnuMainRenameColumn
        '
        Me.C1MnuMainRenameColumn.Command = Me.MnuMainRenameColumn
        Me.C1MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'MnuMainRenameColumn
        '
        Me.MnuMainRenameColumn.Image = Nothing
        Me.MnuMainRenameColumn.Name = "MnuMainRenameColumn"
        Me.MnuMainRenameColumn.Text = "Markierte Spalte umbenennen"
        '
        'C1MnuMainSpaltenselektion
        '
        Me.C1MnuMainSpaltenselektion.Command = Me.MnuMainSpaltenselektion
        Me.C1MnuMainSpaltenselektion.Delimiter = True
        Me.C1MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'MnuMainSpaltenselektion
        '
        Me.MnuMainSpaltenselektion.Image = Nothing
        Me.MnuMainSpaltenselektion.Name = "MnuMainSpaltenselektion"
        Me.MnuMainSpaltenselektion.Text = "Spalten-Selektion"
        '
        'mnuctAddHost
        '
        Me.mnuctAddHost.Image = Nothing
        Me.mnuctAddHost.ImageIndex = 16
        Me.mnuctAddHost.Name = "mnuctAddHost"
        Me.mnuctAddHost.Text = "EDOKA-/HOST-Partner hinzufügen"
        '
        'mnuCTADDEdokapartner
        '
        Me.mnuCTADDEdokapartner.Image = Nothing
        Me.mnuCTADDEdokapartner.ImageIndex = 18
        Me.mnuCTADDEdokapartner.Name = "mnuCTADDEdokapartner"
        Me.mnuCTADDEdokapartner.Text = "Neuer EDOKA-Partner erfassen"
        '
        'mnuctaddempfaenger
        '
        Me.mnuctaddempfaenger.Image = Nothing
        Me.mnuctaddempfaenger.ImageIndex = 19
        Me.mnuctaddempfaenger.Name = "mnuctaddempfaenger"
        Me.mnuctaddempfaenger.Text = "Neuer Empfänger erfassen"
        '
        'C1ContextMenu1
        '
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink1)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink3)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink4)
        Me.C1ContextMenu1.CommandLinks.Add(Me.C1CommandLink2)
        Me.C1ContextMenu1.Image = CType(resources.GetObject("C1ContextMenu1.Image"), System.Drawing.Bitmap)
        Me.C1ContextMenu1.ImageIndex = 0
        Me.C1ContextMenu1.Name = "C1ContextMenu1"
        '
        'C1CommandLink1
        '
        Me.C1CommandLink1.Command = Me.c1dokumentedrucken
        Me.C1CommandLink1.Text = "Dokumente drucken"
        '
        'c1dokumentedrucken
        '
        Me.c1dokumentedrucken.Image = Nothing
        Me.c1dokumentedrucken.Name = "c1dokumentedrucken"
        Me.c1dokumentedrucken.Text = "Dokumente drucken"
        '
        'C1CommandLink3
        '
        Me.C1CommandLink3.Command = Me.c1showdoc
        Me.C1CommandLink3.Text = "Dokumente anzeigen"
        '
        'c1showdoc
        '
        Me.c1showdoc.Image = Nothing
        Me.c1showdoc.Name = "c1showdoc"
        Me.c1showdoc.Text = "Dokumente anzeigen"
        '
        'C1CommandLink2
        '
        Me.C1CommandLink2.Command = Me.c1statuszuruecksetzen
        Me.C1CommandLink2.Delimiter = True
        Me.C1CommandLink2.Text = "Status zurücksetzen"
        '
        'c1statuszuruecksetzen
        '
        Me.c1statuszuruecksetzen.Image = Nothing
        Me.c1statuszuruecksetzen.Name = "c1statuszuruecksetzen"
        Me.c1statuszuruecksetzen.Text = "Status zurücksetzen"
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1})
        Me.C1CommandHolder1.SetC1ContextMenu(Me.ToolBar1, Nothing)
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(464, 25)
        Me.ToolBar1.TabIndex = 29
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 1
        '
        'djlist
        '
        Me.djlist.AllowDelete = True
        Me.djlist.AllowFilter = True
        Me.djlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.djlist.AllowSort = True
        Me.djlist.AlternatingRows = True
        Me.C1CommandHolder1.SetC1ContextMenu(Me.djlist, Me.C1ContextMenu1)
        Me.djlist.CaptionHeight = 17
        Me.djlist.CollapseColor = System.Drawing.Color.Black
        Me.djlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.djlist.DataChanged = False
        Me.djlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.djlist.Dock = System.Windows.Forms.DockStyle.Fill
        Me.djlist.ExpandColor = System.Drawing.Color.Black
        Me.djlist.FetchRowStyles = True
        Me.djlist.FilterBar = True
        Me.djlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.djlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.djlist.Location = New System.Drawing.Point(0, 25)
        Me.djlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.djlist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.djlist.Name = "djlist"
        Me.djlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.djlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.djlist.PreviewInfo.ZoomFactor = 75
        Me.djlist.PrintInfo.ShowOptionsDialog = False
        Me.djlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.djlist.RowDivider = GridLines1
        Me.djlist.RowHeight = 15
        Me.djlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.djlist.ScrollTips = True
        Me.djlist.Size = New System.Drawing.Size(464, 180)
        Me.djlist.TabIndex = 30
        Me.djlist.Text = "C1TrueDBGrid1"
        Me.djlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 460," & _
        " 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 460, " & _
        "176</ClientArea></Blob>"
        '
        'C1CommandLink4
        '
        Me.C1CommandLink4.Command = Me.c1deldok
        Me.C1CommandLink4.Text = "Dokumente löschen"
        '
        'c1deldok
        '
        Me.c1deldok.Image = Nothing
        Me.c1deldok.Name = "c1deldok"
        Me.c1deldok.Text = "Dokumente löschen"
        '
        'frmsbdruck
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.C1CommandHolder1.SetC1ContextMenu(Me, Nothing)
        Me.ClientSize = New System.Drawing.Size(464, 205)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.djlist, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmsbdruck"
        Me.ShowInTaskbar = False
        Me.Text = "Serienbriefe drucken"
        CType(Me.C1CommandHolder1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.djlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.c1deldok_Click Method

Private Sub c1deldok_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1deldok.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1deldok_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1deldok.Click
        Me.set_druckjobstatus(3)
        Me.refresh_data()
        Me.pdfprinter_PrintDOne()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.c1dokumentedrucken_Click Method

Private Sub c1dokumentedrucken_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1dokumentedrucken.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1dokumentedrucken_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1dokumentedrucken.Click
        pdfprinter = New frmSBPDFPrinter(Me.djlist.Columns("Nr").Value, False)
        pdfprinter.Show()
        Application.DoEvents()
        pdfprinter.PrintPDF()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.c1showdoc_Click Method

Private Sub c1showdoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1showdoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1showdoc_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1showdoc.Click
        Dim f As New frmSBPDFPrinter(Me.djlist.Columns("Nr").Value, True)
        f.Show()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.c1statuszuruecksetzen_Click Method

Private Sub c1statuszuruecksetzen_Click( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1Command.ClickEventArgs _
) Handles c1statuszuruecksetzen.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub c1statuszuruecksetzen_Click(ByVal sender As System.Object, ByVal e As C1.Win.C1Command.ClickEventArgs) Handles c1statuszuruecksetzen.Click
        Me.set_druckjobstatus(0)
        Me.refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.djlist_MouseDown Method

Private Sub djlist_MouseDown( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
) Handles djlist.MouseDown

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub djlist_MouseDown(ByVal sender As Object, ByVal e As System.Windows.Forms.MouseEventArgs) Handles djlist.MouseDown
        Me.djlist.Bookmark = djlist.RowContaining(e.Y)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.frmsbdruck_Load Method

Private Sub frmsbdruck_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmsbdruck_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim sb As New edokadb.clsEdex_sb_serienbrief()
        sb.cpMainConnectionProvider = Globals.conn
        sb.iSerienbriefnr = New SqlInt32(CType(Me.serienbriefnr, Int32))
        sb.SelectOne()
        Me.Text = Me.Text + ": " + sb.sBezeichnung.Value
        sb.Dispose()
        refresh_data()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.get_druckjobs Method

Private Function get_druckjobs() As DataTable

Source code

[Visual Basic]
    Private Function get_druckjobs() As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "sp_edex_sb_get_druckjob"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@sbnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.serienbriefnr))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.pdfprinter_PrintDOne Method

Private Sub pdfprinter_PrintDOne() Handles pdfprinter.PrintDOne

Source code

[Visual Basic]
    Private Sub pdfprinter_PrintDOne() Handles pdfprinter.PrintDOne
        Application.DoEvents()
        Application.DoEvents()
        Application.DoEvents()
        Dim nicht_alles_gedruckt As Integer
        nicht_alles_gedruckt = False

        Me.set_druckjobstatus(1)
        Dim i As Integer
        Dim dt As DataTable
        dt = Me.refresh_data()
        If dt.Rows.Count > 0 Then
            For i = 0 To dt.Rows.Count - 1
                If dt.Rows(i).Item("Status") = "nicht gedruckt" Then
                    nicht_alles_gedruckt = True
                End If
            Next
        End If

        If Not nicht_alles_gedruckt Then
            Dim f As New frmDruckabschluss(Me.serienbriefnr)
            f.ShowDialog()
            If f.datasaved Then
                Me.datasaved = True
            End If
            f.Dispose()
            Me.Close()
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.refresh_data Method

Private Function refresh_data() As DataTable

Source code

[Visual Basic]
    Private Function refresh_data() As DataTable
        Dim dt As New DataTable()
        dt = Me.get_druckjobs
        Me.djlist.DataSource = Nothing
        Me.djlist.DataMember = Nothing
        Me.djlist.DataSource = dt
        Me.djlist.DataMember = dt.TableName
        Dim i As Integer
        For i = 0 To Me.djlist.Splits(0).DisplayColumns.Count - 1
            Me.djlist.Splits(0).DisplayColumns(i).AutoSize()
        Next
        Return dt
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck.set_druckjobstatus Method

Private Function set_druckjobstatus( _
   ByVal status As Integer _
) As DataTable

Parameters

status
Required.

Source code

[Visual Basic]
    Private Function set_druckjobstatus(ByVal status As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "sp_edex_sb_set_druckjobstatus"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@druckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.djlist.Columns("nr").Value))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbdruck Fields

frmsbdruck overview

Fields

field C1CommandHolder1
field C1CommandLink1
field C1CommandLink2
field C1CommandLink3
field C1CommandLink4
field C1CommandMenu1
field C1ContextMenu1
field C1MnuDokumenteGenerieren
field C1MnuEDOKAHOSTPartnerHinzufuegen
field C1MnuEDOKAPartnerErfassen
field C1MnuMainAddColumn
field C1MnuMainCheckEmpfaenger
field C1MnuMainDeleteColumn
field C1MnuMainDokumenteBestaetigen
field C1MnuMainDokumenteDrucken
field C1MnuMainEDOKAPartnerErfassen
field C1MnuMainEmpfaengerBearbeitten
field C1MnuMainEmpfaengerLoeschen
field C1MnuMainExportEmpfaenger
field C1MnuMainFensterSchliessen
field C1MnuMainImportEmpfaneger
field C1MnuMainLoadPartnerliste
field C1MnuMainNeuerEmpfaengerErfassen
field C1MnuMainNeuerSerienbrief
field C1MnuMainRenameColumn
field C1MnuMainSaveAsPartnerlist
field C1MnuMainSerienbriefLaden
field C1MnuMainSerienbriefSpeichern
field C1MnuMainSerienbriefabschliessen
field C1MnuMainSpaltenselektion
field C1MnuMainVorlageBearbeiten
field C1MnuMainVorlageImportieren
field C1MnuMainVorschauErstellen
field C1MnuSerienbriefLoeschen
field ImageList1
field MnuMainAbschluss
field MnuMainAddColumn
field MnuMainAddEDOKAHOSTPartner
field MnuMainCheckEmpfaenger
field MnuMainClose
field MnuMainDatei
field MnuMainDeleteColumn
field MnuMainDokument
field MnuMainDokumenteBestaetigen
field MnuMainDokumenteDrucken
field MnuMainDokumenteGenerieren
field MnuMainEDOKAPartnerErfassen
field MnuMainEmfpaengerLoeschen
field MnuMainEmpfaengerBearbeiten
field MnuMainEmpfaengerliste
field MnuMainExportEmpfaenger
field MnuMainImportEmpfaenger
field MnuMainLoad
field MnuMainLoadPartnerliste
field MnuMainNeuerEDOKAPartnerErfassen
field MnuMainNeuerEmpfaengerErfassen
field MnuMainNew
field MnuMainRenameColumn
field MnuMainSave
field MnuMainSaveAsPartnerlist
field MnuMainSerienbriefLoeschen
field MnuMainSpaltenselektion
field MnuMainVorageBearbeiten
field MnuMainVorlageImportieren
field MnuMainVorschauErstellen
field ToolBar1
field ToolBarButton1
field c1deldok
field c1dokumentedrucken
field c1showdoc
field c1statuszuruecksetzen
field components
field djlist
field m_datasaved
field mnuCTADDEdokapartner
field mnuctAddHost
field mnuctaddempfaenger
field pdfprinter
field serienbriefnr

See Also

frmsbdruck Class


C1CommandHolder1 Variable

Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Source code

[Visual Basic]
    Friend WithEvents C1CommandHolder1 As C1.Win.C1Command.C1CommandHolder

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1CommandLink1 Variable

Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink1 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1CommandLink2 Variable

Friend WithEvents C1CommandLink2 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink2 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1CommandLink3 Variable

Friend WithEvents C1CommandLink3 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink3 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1CommandLink4 Variable

Friend WithEvents C1CommandLink4 As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1CommandLink4 As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1CommandMenu1 Variable

Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents C1CommandMenu1 As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1ContextMenu1 Variable

Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Source code

[Visual Basic]
    Friend WithEvents C1ContextMenu1 As C1.Win.C1Command.C1ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuDokumenteGenerieren Variable

Friend WithEvents C1MnuDokumenteGenerieren As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuDokumenteGenerieren As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuEDOKAHOSTPartnerHinzufuegen Variable

Friend WithEvents C1MnuEDOKAHOSTPartnerHinzufuegen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuEDOKAHOSTPartnerHinzufuegen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuEDOKAPartnerErfassen Variable

Friend WithEvents C1MnuEDOKAPartnerErfassen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuEDOKAPartnerErfassen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainAddColumn Variable

Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainAddColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainCheckEmpfaenger Variable

Friend WithEvents C1MnuMainCheckEmpfaenger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainCheckEmpfaenger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainDeleteColumn Variable

Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDeleteColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainDokumenteBestaetigen Variable

Friend WithEvents C1MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainDokumenteDrucken Variable

Friend WithEvents C1MnuMainDokumenteDrucken As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainDokumenteDrucken As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainEDOKAPartnerErfassen Variable

Friend WithEvents C1MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainEmpfaengerBearbeitten Variable

Friend WithEvents C1MnuMainEmpfaengerBearbeitten As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainEmpfaengerBearbeitten As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainEmpfaengerLoeschen Variable

Friend WithEvents C1MnuMainEmpfaengerLoeschen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainEmpfaengerLoeschen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainExportEmpfaenger Variable

Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainExportEmpfaenger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainFensterSchliessen Variable

Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainFensterSchliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainImportEmpfaneger Variable

Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainImportEmpfaneger As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainLoadPartnerliste Variable

Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainLoadPartnerliste As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainNeuerEmpfaengerErfassen Variable

Friend WithEvents C1MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainNeuerSerienbrief Variable

Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainNeuerSerienbrief As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainRenameColumn Variable

Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainRenameColumn As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainSaveAsPartnerlist Variable

Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainSerienbriefLaden Variable

Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefLaden As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainSerienbriefSpeichern Variable

Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefSpeichern As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainSerienbriefabschliessen Variable

Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSerienbriefabschliessen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainSpaltenselektion Variable

Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainSpaltenselektion As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainVorlageBearbeiten Variable

Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageBearbeiten As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainVorlageImportieren Variable

Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorlageImportieren As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuMainVorschauErstellen Variable

Friend WithEvents C1MnuMainVorschauErstellen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuMainVorschauErstellen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


C1MnuSerienbriefLoeschen Variable

Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Source code

[Visual Basic]
    Friend WithEvents C1MnuSerienbriefLoeschen As C1.Win.C1Command.C1CommandLink

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainAbschluss Variable

Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAbschluss As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainAddColumn Variable

Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainAddEDOKAHOSTPartner Variable

Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainAddEDOKAHOSTPartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainCheckEmpfaenger Variable

Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainCheckEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainClose Variable

Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainClose As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDatei Variable

Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDatei As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDeleteColumn Variable

Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDeleteColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDokument Variable

Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokument As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDokumenteBestaetigen Variable

Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteBestaetigen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDokumenteDrucken Variable

Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteDrucken As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainDokumenteGenerieren Variable

Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainDokumenteGenerieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainEDOKAPartnerErfassen Variable

Friend WithEvents MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainEmfpaengerLoeschen Variable

Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmfpaengerLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainEmpfaengerBearbeiten Variable

Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainEmpfaengerliste Variable

Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Source code

[Visual Basic]
    Friend WithEvents MnuMainEmpfaengerliste As C1.Win.C1Command.C1CommandMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainExportEmpfaenger Variable

Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainExportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainImportEmpfaenger Variable

Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainImportEmpfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainLoad Variable

Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoad As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainLoadPartnerliste Variable

Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainLoadPartnerliste As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainNeuerEDOKAPartnerErfassen Variable

Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEDOKAPartnerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainNeuerEmpfaengerErfassen Variable

Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNeuerEmpfaengerErfassen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainNew Variable

Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainNew As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainRenameColumn Variable

Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainRenameColumn As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainSave Variable

Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSave As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainSaveAsPartnerlist Variable

Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSaveAsPartnerlist As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainSerienbriefLoeschen Variable

Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSerienbriefLoeschen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainSpaltenselektion Variable

Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainSpaltenselektion As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainVorageBearbeiten Variable

Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorageBearbeiten As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainVorlageImportieren Variable

Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorlageImportieren As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


MnuMainVorschauErstellen Variable

Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents MnuMainVorschauErstellen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


c1deldok Variable

Friend WithEvents c1deldok As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1deldok As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


c1dokumentedrucken Variable

Friend WithEvents c1dokumentedrucken As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1dokumentedrucken As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


c1showdoc Variable

Friend WithEvents c1showdoc As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1showdoc As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


c1statuszuruecksetzen Variable

Friend WithEvents c1statuszuruecksetzen As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents c1statuszuruecksetzen As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


djlist Variable

Friend WithEvents djlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents djlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


m_datasaved Variable

Dim m_datasaved As Boolean = False

Source code

[Visual Basic]
    Dim m_datasaved As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


mnuCTADDEdokapartner Variable

Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuCTADDEdokapartner As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


mnuctAddHost Variable

Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctAddHost As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


mnuctaddempfaenger Variable

Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Source code

[Visual Basic]
    Friend WithEvents mnuctaddempfaenger As C1.Win.C1Command.C1Command

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


pdfprinter Variable

Dim WithEvents pdfprinter As frmSBPDFPrinter

Source code

[Visual Basic]
    Dim WithEvents pdfprinter As frmSBPDFPrinter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


serienbriefnr Variable

Dim serienbriefnr As Integer

Source code

[Visual Basic]
    Dim serienbriefnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbpartnerdetail Class

For a list of all members of this type, see frmsbpartnerdetail Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmsbpartnerdetail

Public Class frmsbpartnerdetail
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmsbpartnerdetail Members


frmsbpartnerdetail Members

frmsbpartnerdetail overview

Constructors

constructor frmsbpartnerdetail Constructor (Overloaded)

Methods

method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method btnPartnerInfo_Click
method frmsbpartnerdetail_Load
method txtname_Leave
method txtplz_Leave

Fields

field AddNew
field Button1
field Button2
field Label1
field Label10
field Label11
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Panel1
field WertList
field adressarray
field btnPartnerInfo
field components
field dr
field dt
field nrpar00
field txtAnrede
field txtanrede1
field txtanrede2
field txtkurzbezeichnung
field txtname
field txtnrpar00
field txtort
field txtplz
field txtstrasse
field txtvorname
field txtzustelladresse

See Also

frmsbpartnerdetail Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal add As Boolean, ByVal dt As DataTable, ByVal nrpar00 As String)

See Also

frmsbpartnerdetail | EDOKAApp


frmsbpartnerdetail Methods

frmsbpartnerdetail overview

Methods

method Button2_Click
method Dispose
method Generic_Select
method InitializeComponent
method btnPartnerInfo_Click
method frmsbpartnerdetail_Load
method txtname_Leave
method txtplz_Leave

See Also

frmsbpartnerdetail Class


frmsbpartnerdetail.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.DialogResult = DialogResult.OK
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.Generic_Select Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 1
                scmCmdToExecute.CommandText = "dbo.SP_get_ort"
            Case 2
                scmCmdToExecute.CommandText = "dbo.SP_check_partner"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 1
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@plz", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.txtplz.Text))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmsbpartnerdetail))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Label2 = New System.Windows.Forms.Label()
        Me.Label3 = New System.Windows.Forms.Label()
        Me.Label4 = New System.Windows.Forms.Label()
        Me.Label5 = New System.Windows.Forms.Label()
        Me.Label6 = New System.Windows.Forms.Label()
        Me.Label7 = New System.Windows.Forms.Label()
        Me.Label8 = New System.Windows.Forms.Label()
        Me.txtnrpar00 = New System.Windows.Forms.TextBox()
        Me.txtkurzbezeichnung = New System.Windows.Forms.TextBox()
        Me.txtname = New System.Windows.Forms.TextBox()
        Me.txtvorname = New System.Windows.Forms.TextBox()
        Me.txtstrasse = New System.Windows.Forms.TextBox()
        Me.txtplz = New System.Windows.Forms.TextBox()
        Me.txtort = New System.Windows.Forms.TextBox()
        Me.txtanrede1 = New System.Windows.Forms.TextBox()
        Me.txtanrede2 = New System.Windows.Forms.TextBox()
        Me.txtzustelladresse = New System.Windows.Forms.TextBox()
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.WertList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.Label9 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.txtAnrede = New System.Windows.Forms.TextBox()
        Me.Label10 = New System.Windows.Forms.Label()
        Me.Label11 = New System.Windows.Forms.Label()
        Me.btnPartnerInfo = New System.Windows.Forms.Button()
        Me.Panel1.SuspendLayout()
        CType(Me.WertList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.Size = New System.Drawing.Size(88, 16)
        Me.Label1.TabIndex = 0
        Me.Label1.Text = "Partnernr"
        '
        'Label2
        '
        Me.Label2.Location = New System.Drawing.Point(8, 160)
        Me.Label2.Name = "Label2"
        Me.Label2.Size = New System.Drawing.Size(96, 16)
        Me.Label2.TabIndex = 1
        Me.Label2.Text = "Kurzbezeichnung"
        '
        'Label3
        '
        Me.Label3.Location = New System.Drawing.Point(8, 64)
        Me.Label3.Name = "Label3"
        Me.Label3.Size = New System.Drawing.Size(88, 16)
        Me.Label3.TabIndex = 2
        Me.Label3.Text = "Vorname"
        '
        'Label4
        '
        Me.Label4.Location = New System.Drawing.Point(8, 112)
        Me.Label4.Name = "Label4"
        Me.Label4.Size = New System.Drawing.Size(88, 16)
        Me.Label4.TabIndex = 3
        Me.Label4.Text = "Strasse"
        '
        'Label5
        '
        Me.Label5.Location = New System.Drawing.Point(8, 136)
        Me.Label5.Name = "Label5"
        Me.Label5.Size = New System.Drawing.Size(88, 16)
        Me.Label5.TabIndex = 4
        Me.Label5.Text = "PLZ/Ort"
        '
        'Label6
        '
        Me.Label6.Location = New System.Drawing.Point(8, 232)
        Me.Label6.Name = "Label6"
        Me.Label6.Size = New System.Drawing.Size(88, 16)
        Me.Label6.TabIndex = 5
        Me.Label6.Text = "Zustelladresse"
        '
        'Label7
        '
        Me.Label7.Location = New System.Drawing.Point(8, 184)
        Me.Label7.Name = "Label7"
        Me.Label7.Size = New System.Drawing.Size(88, 16)
        Me.Label7.TabIndex = 6
        Me.Label7.Text = "Briefanrede 1"
        '
        'Label8
        '
        Me.Label8.Location = New System.Drawing.Point(8, 208)
        Me.Label8.Name = "Label8"
        Me.Label8.Size = New System.Drawing.Size(88, 16)
        Me.Label8.TabIndex = 7
        Me.Label8.Text = "Briefanrede 2"
        '
        'txtnrpar00
        '
        Me.txtnrpar00.Location = New System.Drawing.Point(112, 16)
        Me.txtnrpar00.Name = "txtnrpar00"
        Me.txtnrpar00.Size = New System.Drawing.Size(144, 20)
        Me.txtnrpar00.TabIndex = 1
        Me.txtnrpar00.Text = ""
        '
        'txtkurzbezeichnung
        '
        Me.txtkurzbezeichnung.Location = New System.Drawing.Point(112, 160)
        Me.txtkurzbezeichnung.Name = "txtkurzbezeichnung"
        Me.txtkurzbezeichnung.Size = New System.Drawing.Size(296, 20)
        Me.txtkurzbezeichnung.TabIndex = 8
        Me.txtkurzbezeichnung.Text = ""
        '
        'txtname
        '
        Me.txtname.Location = New System.Drawing.Point(112, 88)
        Me.txtname.Name = "txtname"
        Me.txtname.Size = New System.Drawing.Size(296, 20)
        Me.txtname.TabIndex = 4
        Me.txtname.Text = ""
        '
        'txtvorname
        '
        Me.txtvorname.Location = New System.Drawing.Point(112, 64)
        Me.txtvorname.Name = "txtvorname"
        Me.txtvorname.Size = New System.Drawing.Size(296, 20)
        Me.txtvorname.TabIndex = 3
        Me.txtvorname.Text = ""
        '
        'txtstrasse
        '
        Me.txtstrasse.Location = New System.Drawing.Point(112, 112)
        Me.txtstrasse.Name = "txtstrasse"
        Me.txtstrasse.Size = New System.Drawing.Size(296, 20)
        Me.txtstrasse.TabIndex = 5
        Me.txtstrasse.Text = ""
        '
        'txtplz
        '
        Me.txtplz.Location = New System.Drawing.Point(112, 136)
        Me.txtplz.Name = "txtplz"
        Me.txtplz.Size = New System.Drawing.Size(72, 20)
        Me.txtplz.TabIndex = 6
        Me.txtplz.Text = ""
        '
        'txtort
        '
        Me.txtort.Location = New System.Drawing.Point(192, 136)
        Me.txtort.Name = "txtort"
        Me.txtort.Size = New System.Drawing.Size(216, 20)
        Me.txtort.TabIndex = 7
        Me.txtort.Text = ""
        '
        'txtanrede1
        '
        Me.txtanrede1.Location = New System.Drawing.Point(112, 184)
        Me.txtanrede1.Name = "txtanrede1"
        Me.txtanrede1.Size = New System.Drawing.Size(296, 20)
        Me.txtanrede1.TabIndex = 9
        Me.txtanrede1.Text = ""
        '
        'txtanrede2
        '
        Me.txtanrede2.Location = New System.Drawing.Point(112, 208)
        Me.txtanrede2.Name = "txtanrede2"
        Me.txtanrede2.Size = New System.Drawing.Size(296, 20)
        Me.txtanrede2.TabIndex = 10
        Me.txtanrede2.Text = ""
        '
        'txtzustelladresse
        '
        Me.txtzustelladresse.Location = New System.Drawing.Point(112, 232)
        Me.txtzustelladresse.Multiline = True
        Me.txtzustelladresse.Name = "txtzustelladresse"
        Me.txtzustelladresse.Size = New System.Drawing.Size(296, 104)
        Me.txtzustelladresse.TabIndex = 11
        Me.txtzustelladresse.Text = ""
        '
        'Panel1
        '
        Me.Panel1.BackColor = System.Drawing.SystemColors.Control
        Me.Panel1.BorderStyle = System.Windows.Forms.BorderStyle.Fixed3D
        Me.Panel1.Controls.AddRange(New System.Windows.Forms.Control() {Me.WertList})
        Me.Panel1.Location = New System.Drawing.Point(112, 344)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(296, 128)
        Me.Panel1.TabIndex = 49
        '
        'WertList
        '
        Me.WertList.AllowFilter = False
        Me.WertList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.WertList.AllowSort = False
        Me.WertList.AlternatingRows = True
        Me.WertList.CaptionHeight = 17
        Me.WertList.CollapseColor = System.Drawing.Color.Black
        Me.WertList.Cursor = System.Windows.Forms.Cursors.Default
        Me.WertList.DataChanged = False
        Me.WertList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.WertList.Dock = System.Windows.Forms.DockStyle.Fill
        Me.WertList.ExpandColor = System.Drawing.Color.Black
        Me.WertList.FetchRowStyles = True
        Me.WertList.FilterBar = True
        Me.WertList.GroupByCaption = "Drag a column header here to group by that column"
        Me.WertList.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.WertList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.WertList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.WertList.Name = "WertList"
        Me.WertList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.WertList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.WertList.PreviewInfo.ZoomFactor = 75
        Me.WertList.PrintInfo.ShowOptionsDialog = False
        Me.WertList.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.WertList.RowDivider = GridLines1
        Me.WertList.RowHeight = 15
        Me.WertList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.WertList.ScrollTips = True
        Me.WertList.Size = New System.Drawing.Size(292, 124)
        Me.WertList.TabIndex = 28
        Me.WertList.Text = "C1TrueDBGrid1"
        Me.WertList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 288," & _
        " 120</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 288, " & _
        "120</ClientArea></Blob>"
        '
        'Label9
        '
        Me.Label9.Location = New System.Drawing.Point(8, 344)
        Me.Label9.Name = "Label9"
        Me.Label9.Size = New System.Drawing.Size(96, 32)
        Me.Label9.TabIndex = 50
        Me.Label9.Text = "Dokument-spezifische Werte"
        '
        'Button1
        '
        Me.Button1.DialogResult = System.Windows.Forms.DialogResult.Abort
        Me.Button1.Location = New System.Drawing.Point(8, 480)
        Me.Button1.Name = "Button1"
        Me.Button1.Size = New System.Drawing.Size(112, 24)
        Me.Button1.TabIndex = 12
        Me.Button1.Text = "Abbruch"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(296, 480)
        Me.Button2.Name = "Button2"
        Me.Button2.Size = New System.Drawing.Size(112, 24)
        Me.Button2.TabIndex = 13
        Me.Button2.Text = "Speichern"
        '
        'txtAnrede
        '
        Me.txtAnrede.Location = New System.Drawing.Point(112, 40)
        Me.txtAnrede.Name = "txtAnrede"
        Me.txtAnrede.Size = New System.Drawing.Size(144, 20)
        Me.txtAnrede.TabIndex = 2
        Me.txtAnrede.Text = ""
        '
        'Label10
        '
        Me.Label10.Location = New System.Drawing.Point(8, 40)
        Me.Label10.Name = "Label10"
        Me.Label10.Size = New System.Drawing.Size(88, 16)
        Me.Label10.TabIndex = 53
        Me.Label10.Text = "Anrede"
        '
        'Label11
        '
        Me.Label11.Location = New System.Drawing.Point(8, 88)
        Me.Label11.Name = "Label11"
        Me.Label11.Size = New System.Drawing.Size(88, 16)
        Me.Label11.TabIndex = 55
        Me.Label11.Text = "Name/Firma"
        '
        'btnPartnerInfo
        '
        Me.btnPartnerInfo.Image = CType(resources.GetObject("btnPartnerInfo.Image"), System.Drawing.Bitmap)
        Me.btnPartnerInfo.Location = New System.Drawing.Point(256, 16)
        Me.btnPartnerInfo.Name = "btnPartnerInfo"
        Me.btnPartnerInfo.Size = New System.Drawing.Size(24, 24)
        Me.btnPartnerInfo.TabIndex = 56
        '
        'frmsbpartnerdetail
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(416, 509)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.btnPartnerInfo, Me.Label11, Me.txtAnrede, Me.Label10, Me.Button2, Me.Button1, Me.Label9, Me.Panel1, Me.txtzustelladresse, Me.txtanrede2, Me.txtanrede1, Me.txtort, Me.txtplz, Me.txtstrasse, Me.txtvorname, Me.txtname, Me.txtkurzbezeichnung, Me.txtnrpar00, Me.Label8, Me.Label7, Me.Label6, Me.Label5, Me.Label4, Me.Label3, Me.Label2, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmsbpartnerdetail"
        Me.ShowInTaskbar = False
        Me.Text = "Empfänger-Details"
        Me.Panel1.ResumeLayout(False)
        CType(Me.WertList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.btnPartnerInfo_Click Method

Private Sub btnPartnerInfo_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles btnPartnerInfo.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub btnPartnerInfo_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles btnPartnerInfo.Click
        Try
            If Me.txtnrpar00.Text > 91000000 Then
                Dim f As New frmInteressent()
                f.Partnernr = Me.txtnrpar00.Text
                f.Display = True
                f.ShowDialog()
                f.Dispose()
            Else
                Dim f As New frmPartnerDetails()
                f.Partnernr = Me.txtnrpar00.Text
                f.ShowDialog()
                f.Dispose()
            End If
        Catch
        Finally
        End Try

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.frmsbpartnerdetail_Load Method

Private Sub frmsbpartnerdetail_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmsbpartnerdetail_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Me.btnPartnerInfo.Visible = False
        If Me.AddNew Then
            Me.txtnrpar00.Text = ""
            Me.txtnrpar00.Enabled = False
        Else
            If Me.nrpar00 = -1 Then
                Me.txtnrpar00.Text = ""
            Else
                Me.txtnrpar00.Text = Me.nrpar00.ToString
            End If
            If Me.txtnrpar00.Text <> "" Then
                Me.txtnrpar00.Enabled = False
                '    Me.txtAnrede.Enabled = False
                '    Me.txtname.Enabled = False
                '    Me.txtvorname.Enabled = False
                '    Me.txtstrasse.Enabled = False
                '    Me.txtplz.Enabled = False
                '    Me.txtort.Enabled = False
                '    Me.txtkurzbezeichnung.Enabled = False
            End If
            Me.txtanrede1.Focus()
            End If
            If Me.txtnrpar00.Text <> "" Then Me.btnPartnerInfo.Visible = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.txtname_Leave Method

Private Sub txtname_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtname.Leave, _
   txtort.Leave, _
   txtAnrede.Leave, _
   txtvorname.Leave, _
   txtstrasse.Leave, _
   txtplz.Leave, _
   txtAnrede.Enter

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtname_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtname.Leave, txtort.Leave, txtAnrede.Leave, txtvorname.Leave, txtstrasse.Leave, txtplz.Leave, txtAnrede.Enter
        If Me.txtnrpar00.Text <> "" Then Exit Sub
        If Me.txtvorname.Text = "" Then
            Me.txtkurzbezeichnung.Text = Me.txtname.Text
            Me.txtanrede1.Text = "Damen und Herren"
        Else
            Me.txtkurzbezeichnung.Text = Me.txtvorname.Text + " " + Me.txtname.Text
            Me.txtanrede1.Text = Me.txtAnrede.Text + " " + Me.txtname.Text
        End If
        If Me.txtort.Text <> "" Then
            Me.txtkurzbezeichnung.Text = Me.txtkurzbezeichnung.Text + ", " + Me.txtort.Text
        End If

        'Adresse
        Dim i As Integer
        For i = 0 To 6
            Me.adressarray(i) = ""
        Next
        i = 0
        If Me.txtAnrede.Text <> "" Then
            Me.adressarray(i) = Me.txtAnrede.Text
            i = i + 1
        End If
        If Me.txtvorname.Text <> "" Then
            Me.adressarray(i) = Me.txtvorname.Text + " " + Me.txtname.Text
            i = i + 1
        Else
            Me.adressarray(i) = Me.txtname.Text
            i = i + 1
        End If

        If Me.txtstrasse.Text <> "" Then
            Me.adressarray(i) = Me.txtstrasse.Text
            i = i + 1
        End If
        Me.adressarray(i) = Me.txtplz.Text + " " + Me.txtort.Text

        Me.txtzustelladresse.Text = ""
        Me.txtzustelladresse.Text = Me.adressarray(0) + vbCrLf + Me.adressarray(1) + vbCrLf + Me.adressarray(2) + vbCrLf + Me.adressarray(3) + vbCrLf + Me.adressarray(4) + vbCrLf + Me.adressarray(5) + vbCrLf + Me.adressarray(6)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail.txtplz_Leave Method

Private Sub txtplz_Leave( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles txtplz.Leave

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub txtplz_Leave(ByVal sender As Object, ByVal e As System.EventArgs) Handles txtplz.Leave
        Dim plz As DataTable
        plz = Generic_Select(1)
        If plz.Rows.Count > 0 And Me.txtort.Text = "" Then
            Me.txtort.Text = plz.Rows(0).Item(2)
        End If
        plz.Dispose()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail Fields

frmsbpartnerdetail overview

Fields

field AddNew
field Button1
field Button2
field Label1
field Label10
field Label11
field Label2
field Label3
field Label4
field Label5
field Label6
field Label7
field Label8
field Label9
field Panel1
field WertList
field adressarray
field btnPartnerInfo
field components
field dr
field dt
field nrpar00
field txtAnrede
field txtanrede1
field txtanrede2
field txtkurzbezeichnung
field txtname
field txtnrpar00
field txtort
field txtplz
field txtstrasse
field txtvorname
field txtzustelladresse

See Also

frmsbpartnerdetail Class


AddNew Variable

Dim AddNew As Boolean = False

Source code

[Visual Basic]
    Dim AddNew As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label10 Variable

Friend WithEvents Label10 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label10 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label11 Variable

Friend WithEvents Label11 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label11 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label2 Variable

Friend WithEvents Label2 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label2 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label3 Variable

Friend WithEvents Label3 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label3 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label4 Variable

Friend WithEvents Label4 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label4 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label5 Variable

Friend WithEvents Label5 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label5 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label6 Variable

Friend WithEvents Label6 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label6 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label7 Variable

Friend WithEvents Label7 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label7 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label8 Variable

Friend WithEvents Label8 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label8 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Label9 Variable

Friend WithEvents Label9 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label9 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


WertList Variable

Friend WithEvents WertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents WertList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


adressarray Variable

Dim adressarray( _
   6 _
) As String

Source code

[Visual Basic]
    Dim adressarray(6) As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


btnPartnerInfo Variable

Friend WithEvents btnPartnerInfo As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents btnPartnerInfo As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


dr Variable

Dim dr As DataRow()

Source code

[Visual Basic]
    Dim dr As DataRow()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


dt Variable

Dim dt As New DataTable()

Source code

[Visual Basic]
    Dim dt As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


nrpar00 Variable

Dim nrpar00 As Integer = 0

Source code

[Visual Basic]
    Dim nrpar00 As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtAnrede Variable

Friend WithEvents txtAnrede As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtAnrede As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtanrede1 Variable

Friend WithEvents txtanrede1 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtanrede1 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtanrede2 Variable

Friend WithEvents txtanrede2 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtanrede2 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtkurzbezeichnung Variable

Friend WithEvents txtkurzbezeichnung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtkurzbezeichnung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtname Variable

Friend WithEvents txtname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtnrpar00 Variable

Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtnrpar00 As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtort Variable

Friend WithEvents txtort As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtort As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtplz Variable

Friend WithEvents txtplz As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtplz As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtstrasse Variable

Friend WithEvents txtstrasse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtstrasse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtvorname Variable

Friend WithEvents txtvorname As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtvorname As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


txtzustelladresse Variable

Friend WithEvents txtzustelladresse As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtzustelladresse As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmtes Class

For a list of all members of this type, see frmtes Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmtes

Public Class frmtes
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmtes Members


frmtes Members

frmtes overview

Constructors

constructor frmtes Constructor

Methods

method Dispose
method InitializeComponent

Fields

field ToolBar1
field ToolBar2
field components

See Also

frmtes Class


frmtes Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


frmtes Methods

frmtes overview

Methods

method Dispose
method InitializeComponent

See Also

frmtes Class


frmtes.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


frmtes.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBar2 = New System.Windows.Forms.ToolBar()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Dock = System.Windows.Forms.DockStyle.None
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.Location = New System.Drawing.Point(32, 8)
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(39, 39)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBar2
        '
        Me.ToolBar2.DropDownArrows = True
        Me.ToolBar2.Name = "ToolBar2"
        Me.ToolBar2.ShowToolTips = True
        Me.ToolBar2.Size = New System.Drawing.Size(536, 39)
        Me.ToolBar2.TabIndex = 1
        '
        'frmtes
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(536, 270)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.ToolBar2, Me.ToolBar1})
        Me.Name = "frmtes"
        Me.Text = "frmtes"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


frmtes Fields

frmtes overview

Fields

field ToolBar1
field ToolBar2
field components

See Also

frmtes Class


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


ToolBar2 Variable

Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar2 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtes


frmtextmarken Class

For a list of all members of this type, see frmtextmarken Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmtextmarken

Public Class frmtextmarken
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmtextmarken Members


frmtextmarken Members

frmtextmarken overview

Constructors

constructor frmtextmarken Constructor (Overloaded)

Properties

property Dokumenttypnr

Methods

method Activate_Word
method Dispose
method Get_Vorlagenfelder
method InitializeComponent
method Load_Document
method Save_Office
method StartWord
method ToolBar1_ButtonClick
method Vorlage_Auslesen
method Vorlage_Speichern
method frmtextmarken_Closing
method frmtextmarken_Load
method get_idvwerte
method get_usedfelder
method init_used_felder
method objdoc_DocumentEvents_Event_Close
method ucedit_OnDelete_TM
method ucedit_OnGetIDVFelder
method ucedit_OnGetStandardvorlagenfelder
method ucedit_OnGetUsedFelder
method ucedit_goto_tm
method ucedit_insert_tm
method ucnoedit_OnGetVerknuepfteFelder

Fields

field DokumentBearbeitungDurchUser
field ImageList1
field Panel1
field Schliessen_OK
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field dsempfaenger
field m_dokumenttypnr
field objdoc
field objword
field serienbriefnr
field stdvorlagenfelder
field ucedit
field ucnoedit

See Also

frmtextmarken Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal serienbriefnr As Integer, ByVal DokumentBearbeitungDurchUser As Boolean, ByVal dsempfaenger As DataSet, ByVal dokumenttypnr As Integer)

See Also

frmtextmarken | EDOKAApp


frmtextmarken Properties

frmtextmarken overview

Properties

property Dokumenttypnr

See Also

frmtextmarken Class


frmtextmarken.Dokumenttypnr Property

Property Dokumenttypnr() As Integer

Source code

[Visual Basic]
    Property Dokumenttypnr() As Integer
        Get
            Return m_dokumenttypnr
        End Get
        Set(ByVal Value As Integer)
            m_dokumenttypnr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken Methods

frmtextmarken overview

Methods

method Activate_Word
method Dispose
method Get_Vorlagenfelder
method InitializeComponent
method Load_Document
method Save_Office
method StartWord
method ToolBar1_ButtonClick
method Vorlage_Auslesen
method Vorlage_Speichern
method frmtextmarken_Closing
method frmtextmarken_Load
method get_idvwerte
method get_usedfelder
method init_used_felder
method objdoc_DocumentEvents_Event_Close
method ucedit_OnDelete_TM
method ucedit_OnGetIDVFelder
method ucedit_OnGetStandardvorlagenfelder
method ucedit_OnGetUsedFelder
method ucedit_goto_tm
method ucedit_insert_tm
method ucnoedit_OnGetVerknuepfteFelder

See Also

frmtextmarken Class


frmtextmarken.Activate_Word Method

Private Function Activate_Word()

Source code

[Visual Basic]
    Private Function Activate_Word()
        Dim hnd As Long
        hnd = Win32API.FindWindow("Opusapp", vbNullString)
        Win32API.SetForegroundWindow(hnd)
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Get_Vorlagenfelder Method

Private Function Get_Vorlagenfelder( _
   ByVal type As Integer _
) As DataTable

Parameters

type
Required.

Source code

[Visual Basic]
    Private Function Get_Vorlagenfelder(ByVal type As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Dim i As Integer
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.CommandText = "dbo.sp_edex_sb_get_standardvorlagenfelder"
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Dokumenttypnr))
            scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, type))

            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.components = New System.ComponentModel.Container()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmtextmarken))
        Me.ToolBar1 = New System.Windows.Forms.ToolBar()
        Me.ToolBarButton2 = New System.Windows.Forms.ToolBarButton()
        Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
        Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
        Me.Panel1 = New System.Windows.Forms.Panel()
        Me.SuspendLayout()
        '
        'ToolBar1
        '
        Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton2, Me.ToolBarButton1})
        Me.ToolBar1.DropDownArrows = True
        Me.ToolBar1.ImageList = Me.ImageList1
        Me.ToolBar1.Name = "ToolBar1"
        Me.ToolBar1.ShowToolTips = True
        Me.ToolBar1.Size = New System.Drawing.Size(344, 25)
        Me.ToolBar1.TabIndex = 0
        '
        'ToolBarButton2
        '
        Me.ToolBarButton2.ImageIndex = 0
        '
        'ToolBarButton1
        '
        Me.ToolBarButton1.ImageIndex = 1
        Me.ToolBarButton1.Style = System.Windows.Forms.ToolBarButtonStyle.ToggleButton
        '
        'ImageList1
        '
        Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
        Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
        Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
        Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
        '
        'Panel1
        '
        Me.Panel1.Dock = System.Windows.Forms.DockStyle.Fill
        Me.Panel1.Location = New System.Drawing.Point(0, 25)
        Me.Panel1.Name = "Panel1"
        Me.Panel1.Size = New System.Drawing.Size(344, 476)
        Me.Panel1.TabIndex = 1
        '
        'frmtextmarken
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(344, 501)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel1, Me.ToolBar1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmtextmarken"
        Me.Text = "Dokumentbefüllung bearbeiten"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Load_Document Method

Public Sub Load_Document( _
   Optional ByVal visible As Boolean = True _
)

Parameters

visible
Optional. Default value is True.

Source code

[Visual Basic]
    Public Sub Load_Document(Optional ByVal visible As Boolean = True)
        Dim dokumentname As String = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.serienbriefnr.ToString + "_vorlage.doc"
        Vorlage_Auslesen()
        StartWord(True)
        objword.Documents.Open(dokumentname)
        objdoc = objword.ActiveDocument
        objword.Visible = visible
        objword.WindowState = Word.WdWindowState.wdWindowStateMaximize
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Save_Office Method

Private Function Save_Office( _
   Optional ByVal savetodb As Boolean = True _
)

Parameters

savetodb
Optional. Default value is True.

Source code

[Visual Basic]
    Private Function Save_Office(Optional ByVal savetodb As Boolean = True)
        Try
            If Not savetodb Then
                Me.objdoc = Me.objword.ActiveDocument
                Application.DoEvents()
                Me.objdoc.Close(Savechanges:=False)
                Application.DoEvents()
                Threading.Thread.CurrentThread.Sleep(400)
                If Me.objword.Documents.Count = 0 Then
                    Me.objword.Quit(savechanges:=False)
                End If
                Me.objdoc = Nothing
                Me.objword = Nothing
                Exit Function
            End If
            If Me.DokumentBearbeitungDurchUser = True Then
                Me.objword.ActiveDocument.Save()
                Me.objdoc = Me.objword.ActiveDocument
                Application.DoEvents()
                Me.objdoc.Close(savechanges:=True)
                Application.DoEvents()
                Threading.Thread.CurrentThread.Sleep(400)
                If Me.objword.Documents.Count = 0 Then
                    Me.objword.Quit(savechanges:=False)
                End If
                Me.objdoc = Nothing
                Me.objword = Nothing
                Me.Vorlage_Speichern()
                Exit Function
            End If
            Application.DoEvents()
            If Me.objword.Documents.Count = 1 Then
                Me.objword.Quit(savechanges:=False)
            End If
            Me.objdoc = Nothing
            Me.objword = Nothing
            Application.DoEvents()
            'Me.Vorlage_Speichern()
        Catch
            'MyMsg.show_standardmessage(728, MsgBoxStyle.Critical)
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.StartWord Method

Private Function StartWord( _
   Optional ByVal newinstance As Boolean = False _
)

Parameters

newinstance
Optional. Default value is False.

Source code

[Visual Basic]
    Private Function StartWord(Optional ByVal newinstance As Boolean = False)
        Try
            If newinstance = False Then
                objword = GetObject(, "Word.application")
            Else
                objword = CreateObject("Word.application")
            End If
        Catch
            Try
                objword = CreateObject("Word.application")
            Catch ex As Exception
            End Try
        Finally
            objword.Visible = False
        End Try
        Try
            objword.Run("Autoexec")
        Catch
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'Exit
                Me.Close()
            Case 1
                If Me.ToolBarButton1.Pushed Then
                    Me.Height = 50
                Else
                    Me.Height = 450 + Me.ToolBar1.Height + 10
                End If
            Case Else
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Vorlage_Auslesen Method

Private Function Vorlage_Auslesen() As Boolean

Source code

[Visual Basic]
    Private Function Vorlage_Auslesen() As Boolean
        Try
            Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.serienbriefnr.ToString + "_vorlage.doc"
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_vorlage where serienbriefnr=" + Str(Me.serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Try
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "empf")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    MyMsg.show_standardmessage(715, MsgBoxStyle.Critical)
                Else
                    myRow = ds.Tables(0).Rows(0)
                    Dim MyData() As Byte
                    MyData = myRow.Item(1)
                    Dim K As Long
                    K = UBound(MyData)
                    Dim fs As New FileStream(dokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                    fs.Write(MyData, 0, K)
                    fs.Close()
                    fs = Nothing
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(717, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
                Return False
            End Try
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
            Return True
        Catch EX As Exception
            MyMsg.show_standardmessage(717, MsgBoxStyle.Critical)
            Return False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.Vorlage_Speichern Method

Private Sub Vorlage_Speichern()

Source code

[Visual Basic]
    Private Sub Vorlage_Speichern()
        'Dokumentvorlage aus Office-Vorlage-Datei auslesen, sofern Filename = ""
        Dim dokumentname = Globals.Applikationsdaten.Rows(0).Item("pfad_temporaer_dokumente") + Me.serienbriefnr.ToString + "_vorlage.doc"
        Try
            Dim Connection As New SqlConnection()
            Dim DA As New SqlDataAdapter("select * from edex_sb_vorlage where serienbriefnr=" + Str(Me.serienbriefnr), Connection)
            Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
            Dim ds As New DataSet()
            Dim fs As New FileStream(dokumentname, FileMode.Open, FileAccess.Read)
            Dim mydata(fs.Length) As Byte
            Try
                fs.Read(mydata, 0, fs.Length)
                fs.Close()
                Connection.ConnectionString = Globals.sConnectionString
                Connection.Open()
                DA.Fill(ds, "vorlage")
                Dim myRow As DataRow
                If ds.Tables(0).Rows.Count = 0 Then
                    'Neue Serienbrief_Empfaenger speichern
                    myRow = ds.Tables(0).NewRow
                    myRow.Item(0) = Me.serienbriefnr
                    myRow.Item(1) = mydata
                    ds.Tables(0).Rows.Add(myRow)
                    DA.Update(ds, "vorlage")
                Else
                    ' Bestehende Empfängerliste überschreiben
                    myRow = ds.Tables(0).Rows(0)
                    myRow.Item(1) = mydata
                    DA.Update(ds, "vorlage")
                End If
            Catch ex As Exception
                MyMsg.show_standardmessage(718, MsgBoxStyle.Critical)
                '            MsgBox(ex.Message)
            End Try
            fs = Nothing
            cb = Nothing
            ds = Nothing
            DA = Nothing

            Connection.Close()
            Connection = Nothing
        Catch ex As Exception
        Finally
            Try
                Application.DoEvents()
                File.Delete(dokumentname)
            Catch
            End Try
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.frmtextmarken_Closing Method

Private Sub frmtextmarken_Closing( _
   ByVal sender As Object, _
   ByVal e As System.ComponentModel.CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmtextmarken_Closing(ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) Handles MyBase.Closing
        Schliessen_OK = True
        Me.Save_Office()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.frmtextmarken_Load Method

Private Sub frmtextmarken_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmtextmarken_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Application.DoEvents()
        Me.Cursor = Cursors.WaitCursor
        Me.TopMost = True
        Me.Load_Document()
        If Me.DokumentBearbeitungDurchUser = True Then
            Me.Panel1.Controls.Add(ucedit)
            Me.ucedit.Dock = DockStyle.Fill
            Me.Height = 450 + Me.ToolBar1.Height + 10
        Else
            Me.Panel1.Controls.Add(ucnoedit)
            Me.Height = 450 + Me.ToolBar1.Height + 10
        End If
        Me.Cursor = Cursors.Default
        Application.DoEvents()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.get_idvwerte Method

Private Function get_idvwerte() As DataTable

Source code

[Visual Basic]
    Private Function get_idvwerte() As DataTable
        Dim i As Integer
        Dim dt As New DataTable()
        dt.Columns.Add("Feldname")
        dt.Columns.Add("Wert")
        For i = 0 To Me.dsempfaenger.Tables(0).Columns.Count - 1
            Select Case UCase(Me.dsempfaenger.Tables(0).Columns(i).Caption)
                Case "PARTNERNR", "KURZBEZEICHNUNG", "ANREDE", "NAME", "VORNAME", "STRASSE", "PLZ", "ORT", "ZUSTELLADRESSE", "BRIEFANREDE1", "BRIEFANREDE2", "STATUS", "FEHLERCD", "BLKUNDE", "DOKUMENT_GEDRUCKT", "AKTIV", "DOKUMENTID", "DOKUMENTIDBDR", "ERSTELLER", "FEHLERCODE", "DRUCKJOBID"
                Case Else
                    Dim myRow As DataRow
                    myRow = dt.NewRow
                    myRow.Item(0) = Me.dsempfaenger.Tables(0).Columns(i).Caption
                    myRow.Item(1) = ""
                    dt.Rows.Add(myRow)
            End Select
        Next
        Return dt
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.get_usedfelder Method

Private Sub get_usedfelder( _
   ByRef list As System.Data.DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Private Sub get_usedfelder(ByRef list As System.Data.DataTable)
        list = Me.Get_Vorlagenfelder(1)
        Dim i As Integer
        Dim s As String
        Dim row As DataRow
        Dim dodelete As Boolean = False
        For Each row In list.Rows
            dodelete = False
            If row.Item("Feldname") <> "" Then
                Try
                    s = objword.ActiveDocument.FormFields.Item(row.Item("feldname")).Name()
                Catch
                    dodelete = True
                End Try
            End If

            If row.Item("Beginntextmarke") <> "" Then
                Try
                    s = objword.ActiveDocument.Bookmarks.Item(row.Item("beginntextmarke")).Name
                Catch
                    dodelete = True
                End Try

            End If

            If row.Item("endetextmarke") <> "" Then
                Try
                    s = objword.ActiveDocument.Bookmarks.Item(row.Item("endetextmarke")).Name
                Catch
                    dodelete = True
                End Try
            End If
            If dodelete Then row.Delete()
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.init_used_felder Method

Public Function init_used_felder() As DataTable

Source code

[Visual Basic]
    Public Function init_used_felder() As DataTable
        Dim dt As New DataTable()
        Me.Load_Document(False)
        Me.get_usedfelder(dt)
        Me.Save_Office(False)
        Return dt
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.objdoc_DocumentEvents_Event_Close Method

Private Sub objdoc_DocumentEvents_Event_Close() Handles objdoc.DocumentEvents_Event_Close

Source code

[Visual Basic]
    Private Sub objdoc_DocumentEvents_Event_Close() Handles objdoc.DocumentEvents_Event_Close
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_OnDelete_TM Method

Private Sub ucedit_OnDelete_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
) Handles ucedit.OnDelete_TM

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Private Sub ucedit_OnDelete_TM(ByVal TMName As String, ByVal isfield As Boolean) Handles ucedit.OnDelete_TM
        Try
            If isfield = False Then
                objword.ActiveDocument.Bookmarks.Item(TMName).Delete()
                Activate_Word()
            Else
                objword.ActiveDocument.FormFields.Item(TMName).Delete()
                Activate_Word()
            End If
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_OnGetIDVFelder Method

Private Sub ucedit_OnGetIDVFelder( _
   ByRef list As System.Data.DataTable _
) Handles ucedit.OnGetIDVFelder, _
   ucnoedit.OnGetIDVFelder

Parameters

list
Required.

Source code

[Visual Basic]
    Private Sub ucedit_OnGetIDVFelder(ByRef list As System.Data.DataTable) Handles ucedit.OnGetIDVFelder, ucnoedit.OnGetIDVFelder
        list = Me.get_idvwerte
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_OnGetStandardvorlagenfelder Method

Private Sub ucedit_OnGetStandardvorlagenfelder( _
   ByRef list As System.Data.DataTable _
) Handles ucedit.OnGetStandardvorlagenfelder

Parameters

list
Required.

Source code

[Visual Basic]
    Private Sub ucedit_OnGetStandardvorlagenfelder(ByRef list As System.Data.DataTable) Handles ucedit.OnGetStandardvorlagenfelder
        list = Me.Get_Vorlagenfelder(0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_OnGetUsedFelder Method

Private Sub ucedit_OnGetUsedFelder( _
   ByRef list As System.Data.DataTable _
) Handles ucedit.OnGetUsedFelder, _
   ucnoedit.OnGetUsedFelder

Parameters

list
Required.

Source code

[Visual Basic]
    Private Sub ucedit_OnGetUsedFelder(ByRef list As System.Data.DataTable) Handles ucedit.OnGetUsedFelder, ucnoedit.OnGetUsedFelder
        list = Me.dsempfaenger.Tables("UsedFelder")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_goto_tm Method

Private Sub ucedit_goto_tm( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
) Handles ucedit.OnGoto_TM, _
   ucnoedit.OnGoto_TM

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Private Sub ucedit_goto_tm(ByVal TMName As String, ByVal isfield As Boolean) Handles ucedit.OnGoto_TM, ucnoedit.OnGoto_TM
        If Not isfield Then
            Try
                objword.Selection.GoTo(what:=Word.WdGoToItem.wdGoToBookmark, Name:=TMName)
                Activate_Word()
            Catch ex As Exception
            End Try
        Else
            Try
                objword.Selection.GoTo(what:=Word.WdGoToItem.wdGoToField, Name:=TMName)
                Activate_Word()
            Catch
            End Try
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucedit_insert_tm Method

Private Sub ucedit_insert_tm( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
) Handles ucedit.OnInsert_TM

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Private Sub ucedit_insert_tm(ByVal TMName As String, ByVal isfield As Boolean) Handles ucedit.OnInsert_TM
        Try
            If isfield = False Then
                objword.Selection.Bookmarks.Add(TMName)
            Else
                objword.Selection.FormFields.Add(Range:=objword.Selection.Range, Type:=Word.WdFieldType.wdFieldFormTextInput)
                objword.Selection.PreviousField.Select()
                objword.Selection.FormFields.Item(1).Name = TMName
            End If
            Activate_Word()
        Catch
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken.ucnoedit_OnGetVerknuepfteFelder Method

Private Sub ucnoedit_OnGetVerknuepfteFelder( _
   ByRef list As System.Data.DataTable _
) Handles ucnoedit.OnGetVerknuepfteFelder

Parameters

list
Required.

Source code

[Visual Basic]
    Private Sub ucnoedit_OnGetVerknuepfteFelder(ByRef list As System.Data.DataTable) Handles ucnoedit.OnGetVerknuepfteFelder
        Try
            list = Me.dsempfaenger.Tables("Verkfelder")
        Catch
        End Try
        If list Is Nothing Then
            Me.dsempfaenger.Tables.Add("VerkFelder")
            Dim d1 As New DataColumn()
            Dim d2 As New DataColumn()
            Dim d3 As New DataColumn()
            d1.Caption = "IDVWert"
            d1.ColumnName = "IDVWert"
            d1.DefaultValue = ""
            d2.Caption = "Standardwert"
            d2.ColumnName = "Standardwert"
            d2.DefaultValue = ""
            d3.Caption = "Vorlagenfeldnr"
            d3.ColumnName = "Vorlagenfeldnr"
            d3.DefaultValue = ""
            With Me.dsempfaenger.Tables("Verkfelder").Columns
                .Add(d1)
                .Add(d2)
                .Add(d3)
            End With
            list = Me.dsempfaenger.Tables("Verkfelder")
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken Fields

frmtextmarken overview

Fields

field DokumentBearbeitungDurchUser
field ImageList1
field Panel1
field Schliessen_OK
field ToolBar1
field ToolBarButton1
field ToolBarButton2
field components
field dsempfaenger
field m_dokumenttypnr
field objdoc
field objword
field serienbriefnr
field stdvorlagenfelder
field ucedit
field ucnoedit

See Also

frmtextmarken Class


DokumentBearbeitungDurchUser Variable

Dim DokumentBearbeitungDurchUser As Boolean

Source code

[Visual Basic]
    Dim DokumentBearbeitungDurchUser As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ImageList1 Variable

Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Source code

[Visual Basic]
    Friend WithEvents ImageList1 As System.Windows.Forms.ImageList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


Panel1 Variable

Friend WithEvents Panel1 As System.Windows.Forms.Panel

Source code

[Visual Basic]
    Friend WithEvents Panel1 As System.Windows.Forms.Panel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


Schliessen_OK Variable

Dim Schliessen_OK As Boolean = False

Source code

[Visual Basic]
    Dim Schliessen_OK As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ToolBar1 Variable

Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Source code

[Visual Basic]
    Friend WithEvents ToolBar1 As System.Windows.Forms.ToolBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ToolBarButton1 Variable

Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton1 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ToolBarButton2 Variable

Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Source code

[Visual Basic]
    Friend WithEvents ToolBarButton2 As System.Windows.Forms.ToolBarButton

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


dsempfaenger Variable

Dim dsempfaenger As New DataSet()

Source code

[Visual Basic]
    Dim dsempfaenger As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Integer

Source code

[Visual Basic]
    Dim m_dokumenttypnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


objdoc Variable

Dim WithEvents objdoc As Word.DocumentClass

Source code

[Visual Basic]
    Dim WithEvents objdoc As Word.DocumentClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


objword Variable

Dim WithEvents objword As Word.ApplicationClass

Source code

[Visual Basic]
    Dim WithEvents objword As Word.ApplicationClass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


serienbriefnr Variable

Dim serienbriefnr As Integer

Source code

[Visual Basic]
    Dim serienbriefnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


stdvorlagenfelder Variable

Dim stdvorlagenfelder As New DataTable()

Source code

[Visual Basic]
    Dim stdvorlagenfelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ucedit Variable

Dim WithEvents ucedit As New ucedit()

Source code

[Visual Basic]
    Dim WithEvents ucedit As New ucedit()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


ucnoedit Variable

Dim WithEvents ucnoedit As New ucnoedit()

Source code

[Visual Basic]
    Dim WithEvents ucnoedit As New ucnoedit()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtxtBemerkung Class

For a list of all members of this type, see frmtxtBemerkung Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmtxtBemerkung

Public Class frmtxtBemerkung
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmtxtBemerkung Members


frmtxtBemerkung Members

frmtxtBemerkung overview

Constructors

constructor frmtxtBemerkung Constructor

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent

Fields

field Button1
field Button2
field Label1
field components
field txtBemerkung

See Also

frmtxtBemerkung Class


frmtxtBemerkung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


frmtxtBemerkung Methods

frmtxtBemerkung overview

Methods

method Button1_Click
method Button2_Click
method Dispose
method InitializeComponent

See Also

frmtxtBemerkung Class


frmtxtBemerkung.Button1_Click Method

Private Sub Button1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button1.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


frmtxtBemerkung.Button2_Click Method

Private Sub Button2_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles Button2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click
        Me.Close()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


frmtxtBemerkung.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


frmtxtBemerkung.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmtxtBemerkung))
        Me.txtBemerkung = New System.Windows.Forms.TextBox()
        Me.Label1 = New System.Windows.Forms.Label()
        Me.Button1 = New System.Windows.Forms.Button()
        Me.Button2 = New System.Windows.Forms.Button()
        Me.SuspendLayout()
        '
        'txtBemerkung
        '
        Me.txtBemerkung.Location = New System.Drawing.Point(8, 32)
        Me.txtBemerkung.Multiline = True
        Me.txtBemerkung.Name = "txtBemerkung"
        Me.txtBemerkung.Size = New System.Drawing.Size(368, 128)
        Me.txtBemerkung.TabIndex = 0
        Me.txtBemerkung.Text = ""
        '
        'Label1
        '
        Me.Label1.Location = New System.Drawing.Point(8, 16)
        Me.Label1.Name = "Label1"
        Me.Label1.TabIndex = 1
        Me.Label1.Text = "Bemerkung"
        '
        'Button1
        '
        Me.Button1.Location = New System.Drawing.Point(8, 168)
        Me.Button1.Name = "Button1"
        Me.Button1.TabIndex = 2
        Me.Button1.Text = "&Abbruch"
        '
        'Button2
        '
        Me.Button2.DialogResult = System.Windows.Forms.DialogResult.OK
        Me.Button2.Location = New System.Drawing.Point(304, 168)
        Me.Button2.Name = "Button2"
        Me.Button2.TabIndex = 3
        Me.Button2.Text = "&OK"
        '
        'frmtxtBemerkung
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(384, 197)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.txtBemerkung, Me.Button2, Me.Button1, Me.Label1})
        Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
        Me.Name = "frmtxtBemerkung"
        Me.Text = "Bemerkung für den neuen Verantwortlichen"
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


frmtxtBemerkung Fields

frmtxtBemerkung overview

Fields

field Button1
field Button2
field Label1
field components
field txtBemerkung

See Also

frmtxtBemerkung Class


Button1 Variable

Friend WithEvents Button1 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button1 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


Button2 Variable

Friend WithEvents Button2 As System.Windows.Forms.Button

Source code

[Visual Basic]
    Friend WithEvents Button2 As System.Windows.Forms.Button

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


Label1 Variable

Friend WithEvents Label1 As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents Label1 As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


txtBemerkung Variable

Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Source code

[Visual Basic]
    Friend WithEvents txtBemerkung As System.Windows.Forms.TextBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtxtBemerkung


ucProgress Class

For a list of all members of this type, see ucProgress Members.

System.Object
System.Windows.Forms.UserControl
EDOKAApp.ucProgress

Public Class ucProgress
   Inherits System.Windows.Forms.UserControl

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ucProgress Members


ucProgress Members

ucProgress overview

Constructors

constructor ucProgress Constructor

Methods

method Dispose
method InitializeComponent

Fields

field Bar1
field components
field info

See Also

ucProgress Class


ucProgress Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


ucProgress Methods

ucProgress overview

Methods

method Dispose
method InitializeComponent

See Also

ucProgress Class


ucProgress.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


ucProgress.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Me.Bar1 = New UtilityLibrary.WinControls.ProgressBarEx()
        Me.info = New System.Windows.Forms.Label()
        Me.SuspendLayout()
        '
        'Bar1
        '
        Me.Bar1.BackgroundBitmap = Nothing
        Me.Bar1.BackgroundColor = System.Drawing.Color.FromArgb(CType(220, Byte), CType(217, Byte), CType(211, Byte))
        Me.Bar1.Border3D = System.Windows.Forms.Border3DStyle.Flat
        Me.Bar1.BorderColor = System.Drawing.SystemColors.Highlight
        Me.Bar1.EnableBorder3D = True
        Me.Bar1.ForegroundBitmap = Nothing
        Me.Bar1.ForegroundColor = System.Drawing.Color.Blue
        Me.Bar1.GradientEndColor = System.Drawing.Color.Navy
        Me.Bar1.GradientMiddleColor = System.Drawing.Color.Blue
        Me.Bar1.GradientStartColor = System.Drawing.Color.FromArgb(CType(128, Byte), CType(128, Byte), CType(255, Byte))
        Me.Bar1.Maximum = 100
        Me.Bar1.Minimum = 0
        Me.Bar1.Name = "Bar1"
        Me.Bar1.ProgressTextColor = System.Drawing.Color.Empty
        Me.Bar1.ProgressTextHiglightColor = System.Drawing.Color.Empty
        Me.Bar1.ShowProgressText = True
        Me.Bar1.Size = New System.Drawing.Size(224, 24)
        Me.Bar1.Smooth = True
        Me.Bar1.Step = 10
        Me.Bar1.TabIndex = 3
        Me.Bar1.Text = "ProgressBarEx1"
        Me.Bar1.Value = 0
        '
        'info
        '
        Me.info.Location = New System.Drawing.Point(228, 5)
        Me.info.Name = "info"
        Me.info.Size = New System.Drawing.Size(284, 23)
        Me.info.TabIndex = 4
        '
        'ucProgress
        '
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.info, Me.Bar1})
        Me.Name = "ucProgress"
        Me.Size = New System.Drawing.Size(520, 24)
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


ucProgress Fields

ucProgress overview

Fields

field Bar1
field components
field info

See Also

ucProgress Class


Bar1 Variable

Friend WithEvents Bar1 As UtilityLibrary.WinControls.ProgressBarEx

Source code

[Visual Basic]
    Friend WithEvents Bar1 As UtilityLibrary.WinControls.ProgressBarEx

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


info Variable

Friend WithEvents info As System.Windows.Forms.Label

Source code

[Visual Basic]
    Friend WithEvents info As System.Windows.Forms.Label

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucProgress


ucedit Class

For a list of all members of this type, see ucedit Members.

System.Object
System.Windows.Forms.UserControl
EDOKAApp.ucedit

Public Class ucedit
   Inherits System.Windows.Forms.UserControl

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ucedit Members


ucedit Members

ucedit overview

Constructors

constructor ucedit Constructor

Methods

method Dispose
method InitializeComponent
method mnudelplatzhalter_Click
method mnuinsertStdTM_Click
method mnuinsertidvtm_Click
method mnustandardpositionieren_Click
method ucedit_Load

Events

event OnDelete_TM
event OnGetIDVFelder
event OnGetStandardvorlagenfelder
event OnGetUsedFelder
event OnGoto_TM
event OnInsert_TM

Fields

field ContextMenu1
field ContextMenu2
field ContextMenu3
field GrpIDV
field IDVFelder
field StdFelder
field USEDFelder
field components
field grpStandard
field grpUsed
field idvwerteList
field mnudelplatzhalter
field mnuinsertStdTM
field mnuinsertidvtm
field mnustandardpositionieren
field standardlist
field usedlist

See Also

ucedit Class


ucedit Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit Methods

ucedit overview

Methods

method Dispose
method InitializeComponent
method mnudelplatzhalter_Click
method mnuinsertStdTM_Click
method mnuinsertidvtm_Click
method mnustandardpositionieren_Click
method ucedit_Load

See Also

ucedit Class


ucedit.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(ucedit))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.grpStandard = New System.Windows.Forms.GroupBox()
        Me.standardlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.mnuinsertStdTM = New System.Windows.Forms.MenuItem()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnustandardpositionieren = New System.Windows.Forms.MenuItem()
        Me.mnudelplatzhalter = New System.Windows.Forms.MenuItem()
        Me.GrpIDV = New System.Windows.Forms.GroupBox()
        Me.idvwerteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.mnuinsertidvtm = New System.Windows.Forms.MenuItem()
        Me.grpUsed = New System.Windows.Forms.GroupBox()
        Me.usedlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.grpStandard.SuspendLayout()
        CType(Me.standardlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpIDV.SuspendLayout()
        CType(Me.idvwerteList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.grpUsed.SuspendLayout()
        CType(Me.usedlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'grpStandard
        '
        Me.grpStandard.Controls.AddRange(New System.Windows.Forms.Control() {Me.standardlist})
        Me.grpStandard.Location = New System.Drawing.Point(8, 8)
        Me.grpStandard.Name = "grpStandard"
        Me.grpStandard.Size = New System.Drawing.Size(336, 152)
        Me.grpStandard.TabIndex = 0
        Me.grpStandard.TabStop = False
        Me.grpStandard.Text = "Verfügbare Standard-Werte"
        '
        'standardlist
        '
        Me.standardlist.AllowDelete = True
        Me.standardlist.AllowFilter = True
        Me.standardlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.standardlist.AllowSort = True
        Me.standardlist.AlternatingRows = True
        Me.standardlist.CaptionHeight = 17
        Me.standardlist.CollapseColor = System.Drawing.Color.Black
        Me.standardlist.ContextMenu = Me.ContextMenu2
        Me.standardlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.standardlist.DataChanged = False
        Me.standardlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.standardlist.ExpandColor = System.Drawing.Color.Black
        Me.standardlist.FetchRowStyles = True
        Me.standardlist.FilterBar = True
        Me.standardlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.standardlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.standardlist.Location = New System.Drawing.Point(3, 16)
        Me.standardlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.standardlist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.standardlist.Name = "standardlist"
        Me.standardlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.standardlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.standardlist.PreviewInfo.ZoomFactor = 75
        Me.standardlist.PrintInfo.ShowOptionsDialog = False
        Me.standardlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.standardlist.RowDivider = GridLines1
        Me.standardlist.RowHeight = 15
        Me.standardlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.standardlist.ScrollTips = True
        Me.standardlist.Size = New System.Drawing.Size(325, 128)
        Me.standardlist.TabIndex = 28
        Me.standardlist.Text = "C1TrueDBGrid1"
        Me.standardlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, " & _
        "124</ClientArea></Blob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuinsertStdTM})
        '
        'mnuinsertStdTM
        '
        Me.mnuinsertStdTM.Index = 0
        Me.mnuinsertStdTM.Text = "&Platzhalter im Dokument einfügen"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnustandardpositionieren, Me.mnudelplatzhalter})
        '
        'mnustandardpositionieren
        '
        Me.mnustandardpositionieren.Index = 0
        Me.mnustandardpositionieren.Text = "Cursor &im Dokument positionieren"
        '
        'mnudelplatzhalter
        '
        Me.mnudelplatzhalter.Index = 1
        Me.mnudelplatzhalter.Text = "&Platzhalter löschen"
        '
        'GrpIDV
        '
        Me.GrpIDV.Controls.AddRange(New System.Windows.Forms.Control() {Me.idvwerteList})
        Me.GrpIDV.Location = New System.Drawing.Point(8, 160)
        Me.GrpIDV.Name = "GrpIDV"
        Me.GrpIDV.Size = New System.Drawing.Size(336, 104)
        Me.GrpIDV.TabIndex = 1
        Me.GrpIDV.TabStop = False
        Me.GrpIDV.Text = "Verfügbare dokumentspezifische Werte"
        '
        'idvwerteList
        '
        Me.idvwerteList.AllowDelete = True
        Me.idvwerteList.AllowFilter = True
        Me.idvwerteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.idvwerteList.AllowSort = True
        Me.idvwerteList.AlternatingRows = True
        Me.idvwerteList.CaptionHeight = 17
        Me.idvwerteList.CollapseColor = System.Drawing.Color.Black
        Me.idvwerteList.ContextMenu = Me.ContextMenu3
        Me.idvwerteList.Cursor = System.Windows.Forms.Cursors.Default
        Me.idvwerteList.DataChanged = False
        Me.idvwerteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.idvwerteList.ExpandColor = System.Drawing.Color.Black
        Me.idvwerteList.FetchRowStyles = True
        Me.idvwerteList.FilterBar = True
        Me.idvwerteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.idvwerteList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.idvwerteList.Location = New System.Drawing.Point(3, 16)
        Me.idvwerteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.idvwerteList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.idvwerteList.Name = "idvwerteList"
        Me.idvwerteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.idvwerteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.idvwerteList.PreviewInfo.ZoomFactor = 75
        Me.idvwerteList.PrintInfo.ShowOptionsDialog = False
        Me.idvwerteList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.idvwerteList.RowDivider = GridLines2
        Me.idvwerteList.RowHeight = 15
        Me.idvwerteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.idvwerteList.ScrollTips = True
        Me.idvwerteList.Size = New System.Drawing.Size(325, 80)
        Me.idvwerteList.TabIndex = 28
        Me.idvwerteList.Text = "C1TrueDBGrid1"
        Me.idvwerteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 76</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""Sty" & _
        "le10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRow" & _
        """ me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle p" & _
        "arent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingS" & _
        "tyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me=" & _
        """Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""O" & _
        "ddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /" & _
        "><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Style" & _
        "1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""" & _
        "Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foot" & _
        "er"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactiv" & _
        "e"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /" & _
        "><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" " & _
        "/><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelecto" & _
        "r"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" " & _
        "/></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modi" & _
        "fied</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, 7" & _
        "6</ClientArea></Blob>"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuinsertidvtm})
        '
        'mnuinsertidvtm
        '
        Me.mnuinsertidvtm.Index = 0
        Me.mnuinsertidvtm.Text = "&Platzhalter im Dokument einfügen"
        '
        'grpUsed
        '
        Me.grpUsed.Controls.AddRange(New System.Windows.Forms.Control() {Me.usedlist})
        Me.grpUsed.Location = New System.Drawing.Point(8, 272)
        Me.grpUsed.Name = "grpUsed"
        Me.grpUsed.Size = New System.Drawing.Size(336, 152)
        Me.grpUsed.TabIndex = 2
        Me.grpUsed.TabStop = False
        Me.grpUsed.Text = "Verwendete Werte"
        '
        'usedlist
        '
        Me.usedlist.AllowDelete = True
        Me.usedlist.AllowFilter = True
        Me.usedlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.usedlist.AllowSort = True
        Me.usedlist.AlternatingRows = True
        Me.usedlist.CaptionHeight = 17
        Me.usedlist.CollapseColor = System.Drawing.Color.Black
        Me.usedlist.ContextMenu = Me.ContextMenu1
        Me.usedlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.usedlist.DataChanged = False
        Me.usedlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.usedlist.ExpandColor = System.Drawing.Color.Black
        Me.usedlist.FetchRowStyles = True
        Me.usedlist.FilterBar = True
        Me.usedlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.usedlist.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.usedlist.Location = New System.Drawing.Point(3, 16)
        Me.usedlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.usedlist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.usedlist.Name = "usedlist"
        Me.usedlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.usedlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.usedlist.PreviewInfo.ZoomFactor = 75
        Me.usedlist.PrintInfo.ShowOptionsDialog = False
        Me.usedlist.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.usedlist.RowDivider = GridLines3
        Me.usedlist.RowHeight = 15
        Me.usedlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.usedlist.ScrollTips = True
        Me.usedlist.Size = New System.Drawing.Size(325, 128)
        Me.usedlist.TabIndex = 28
        Me.usedlist.Text = "C1TrueDBGrid1"
        Me.usedlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, " & _
        "124</ClientArea></Blob>"
        '
        'ucedit
        '
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.grpUsed, Me.GrpIDV, Me.grpStandard})
        Me.Name = "ucedit"
        Me.Size = New System.Drawing.Size(352, 432)
        Me.grpStandard.ResumeLayout(False)
        CType(Me.standardlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpIDV.ResumeLayout(False)
        CType(Me.idvwerteList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.grpUsed.ResumeLayout(False)
        CType(Me.usedlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.mnudelplatzhalter_Click Method

Private Sub mnudelplatzhalter_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnudelplatzhalter.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnudelplatzhalter_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnudelplatzhalter.Click
        If Me.usedlist.Columns("feldname").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("feldname").Text, True)
            RaiseEvent OnDelete_TM(Me.usedlist.Columns("Feldname").Text, True)
        Else
            If Me.usedlist.Columns("Beginntextmarke").Text <> "" Then
                RaiseEvent OnGoto_TM(Me.usedlist.Columns("Beginntextmarke").Text, False)
                RaiseEvent OnDelete_TM(Me.usedlist.Columns("Beginntextmarke").Text, False)
            End If
            If Me.usedlist.Columns("EndeTextmarke").Text <> "" Then
                RaiseEvent OnGoto_TM(Me.usedlist.Columns("Endetextmarke").Text, False)
                RaiseEvent OnDelete_TM(Me.usedlist.Columns("endetextmarke").Text, False)
            End If
        End If
        Me.usedlist.Delete()
        Me.usedlist.UpdateData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.mnuinsertStdTM_Click Method

Private Sub mnuinsertStdTM_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuinsertStdTM.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuinsertStdTM_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuinsertStdTM.Click
        Dim i As Integer
        Dim s As String
        Dim sbtmindex As Integer = 0
        For i = 0 To Me.USEDFelder.Rows.Count - 1
            Try
                If Microsoft.VisualBasic.Left(Me.USEDFelder.Rows(i).Item("beginntextmarke"), 4) = "TMSB" Then
                    sbtmindex = sbtmindex + 1
                End If
            Catch
            End Try
        Next
        s = "TMSB_" + sbtmindex.ToString

        Dim row As DataRow
        row = Me.USEDFelder.NewRow
        row.Item(0) = Me.standardlist.Columns(0).Text
        row.Item(1) = Me.standardlist.Columns(1).Text
        row.Item(2) = ""
        row.Item(3) = s
        row.Item(4) = ""
        Me.USEDFelder.Rows.Add(row)
        RaiseEvent OnInsert_TM(s, False)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.mnuinsertidvtm_Click Method

Private Sub mnuinsertidvtm_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuinsertidvtm.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuinsertidvtm_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuinsertidvtm.Click
        Dim i As Integer
        Dim s As String
        Dim sbtmindex As Integer = 0
        For i = 0 To Me.USEDFelder.Rows.Count - 1
            Try
                If Microsoft.VisualBasic.Left(Me.USEDFelder.Rows(i).Item("beginntextmarke"), 5) = "TMISB" Then
                    sbtmindex = sbtmindex + 1
                End If
            Catch
            End Try
        Next
        s = "TMISB_09_" + Me.idvwerteList.Columns(0).Text + "_09_" + sbtmindex.ToString

        Dim row As DataRow
        row = Me.USEDFelder.NewRow
        row.Item(0) = 0
        row.Item(1) = Me.idvwerteList.Columns(0).Text
        row.Item(2) = ""
        row.Item(3) = s
        row.Item(4) = ""
        Me.USEDFelder.Rows.Add(row)
        RaiseEvent OnInsert_TM(s, False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.mnustandardpositionieren_Click Method

Private Sub mnustandardpositionieren_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnustandardpositionieren.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnustandardpositionieren_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnustandardpositionieren.Click
        If Me.usedlist.Columns("Feldname").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("feldname").Text, True)
            Exit Sub
        End If
        If Me.usedlist.Columns("beginntextmarke").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("beginntextmarke").Text, False)
            Exit Sub
        End If

        If Me.usedlist.Columns("endetextmarke").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("endetextmarke").Text, False)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit.ucedit_Load Method

Private Sub ucedit_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ucedit_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        RaiseEvent OnGetStandardvorlagenfelder(Me.StdFelder)
        Me.standardlist.DataSource = StdFelder
        Me.standardlist.DataMember = StdFelder.TableName
        Dim i As Integer
        DivFnkt.SpaltenTitel_Aktualisieren(Me.standardlist, StdFelder, "edex_sb_vorlagenfelder")
        'With Me.standardlist

        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.standardlist.Width * 0.1
        '    .Splits(0).DisplayColumns(1).Visible = True
        '    .Splits(0).DisplayColumns(1).Width = Me.standardlist.Width * 0.8
        'End With

        RaiseEvent OnGetUsedFelder(Me.USEDFelder)
        Me.usedlist.DataSource = Me.USEDFelder
        Me.usedlist.DataMember = Me.USEDFelder.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.usedlist, Me.USEDFelder, "edex_sb_vorlagenfelder")
        'With Me.usedlist
        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.usedlist.Width * 0.1
        '    .Splits(0).DisplayColumns(1).Visible = True
        '    .Splits(0).DisplayColumns(1).Width = Me.usedlist.Width * 0.8
        'End With

        RaiseEvent OnGetIDVFelder(Me.IDVFelder)
        Me.idvwerteList.DataSource = Me.IDVFelder
        Me.idvwerteList.DataMember = Me.IDVFelder.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.idvwerteList, Me.IDVFelder, "edex_sb_verk")
        'With Me.idvwerteList
        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.usedlist.Width * 0.9
        '    .Splits(0).DisplayColumns(1).Visible = False
        'End With

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit Events

ucedit overview

Events

event OnDelete_TM
event OnGetIDVFelder
event OnGetStandardvorlagenfelder
event OnGetUsedFelder
event OnGoto_TM
event OnInsert_TM

See Also

ucedit Class


OnDelete_TM Event

Public Event OnDelete_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnDelete_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


OnGetIDVFelder Event

Public Event OnGetIDVFelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetIDVFelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


OnGetStandardvorlagenfelder Event

Public Event OnGetStandardvorlagenfelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetStandardvorlagenfelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


OnGetUsedFelder Event

Public Event OnGetUsedFelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetUsedFelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


OnGoto_TM Event

Public Event OnGoto_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnGoto_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


OnInsert_TM Event

Public Event OnInsert_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnInsert_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucedit Fields

ucedit overview

Fields

field ContextMenu1
field ContextMenu2
field ContextMenu3
field GrpIDV
field IDVFelder
field StdFelder
field USEDFelder
field components
field grpStandard
field grpUsed
field idvwerteList
field mnudelplatzhalter
field mnuinsertStdTM
field mnuinsertidvtm
field mnustandardpositionieren
field standardlist
field usedlist

See Also

ucedit Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


GrpIDV Variable

Friend WithEvents GrpIDV As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpIDV As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


IDVFelder Variable

Dim IDVFelder As New DataTable()

Source code

[Visual Basic]
    Dim IDVFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


StdFelder Variable

Dim StdFelder As New DataTable()

Source code

[Visual Basic]
    Dim StdFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


USEDFelder Variable

Dim USEDFelder As New DataTable()

Source code

[Visual Basic]
    Dim USEDFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


grpStandard Variable

Friend WithEvents grpStandard As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents grpStandard As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


grpUsed Variable

Friend WithEvents grpUsed As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents grpUsed As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


idvwerteList Variable

Friend WithEvents idvwerteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents idvwerteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


mnudelplatzhalter Variable

Friend WithEvents mnudelplatzhalter As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnudelplatzhalter As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


mnuinsertStdTM Variable

Friend WithEvents mnuinsertStdTM As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuinsertStdTM As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


mnuinsertidvtm Variable

Friend WithEvents mnuinsertidvtm As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuinsertidvtm As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


mnustandardpositionieren Variable

Friend WithEvents mnustandardpositionieren As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnustandardpositionieren As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


standardlist Variable

Friend WithEvents standardlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents standardlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


usedlist Variable

Friend WithEvents usedlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents usedlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucedit


ucnoedit Class

For a list of all members of this type, see ucnoedit Members.

System.Object
System.Windows.Forms.UserControl
EDOKAApp.ucnoedit

Public Class ucnoedit
   Inherits System.Windows.Forms.UserControl

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

ucnoedit Members


ucnoedit Members

ucnoedit overview

Constructors

constructor ucnoedit Constructor

Methods

method ContextMenu1_Popup
method ContextMenu3_Popup
method Dispose
method InitializeComponent
method mnuDelVerk_Click
method mnulink1_Click
method mnuposdoc_Click
method ucnoedit_Load

Events

event OnDelete_TM
event OnGetIDVFelder
event OnGetStandardvorlagenfelder
event OnGetUsedFelder
event OnGetVerknuepfteFelder
event OnGoto_TM
event OnInsert_TM

Fields

field ContextMenu1
field ContextMenu2
field ContextMenu3
field GroupBox1
field GrpIDV
field IDVFelder
field StdFelder
field USEDFelder
field VerkFelder
field components
field grpUsed
field idvwerteList
field mnuDelVerk
field mnulink1
field mnulink2
field mnuposdoc
field usedlist
field verklist

See Also

ucnoedit Class


ucnoedit Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit Methods

ucnoedit overview

Methods

method ContextMenu1_Popup
method ContextMenu3_Popup
method Dispose
method InitializeComponent
method mnuDelVerk_Click
method mnulink1_Click
method mnuposdoc_Click
method ucnoedit_Load

See Also

ucnoedit Class


ucnoedit.ContextMenu1_Popup Method

Private Sub ContextMenu1_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu1.Popup, _
   ContextMenu2.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu1_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu1.Popup, ContextMenu2.Popup
        If Me.USEDFelder.Rows.Count = 0 Then
            Me.mnuposdoc.Enabled = False
            Me.mnulink1.Enabled = False
            Me.mnulink2.Enabled = False
        Else
            Me.mnuposdoc.Enabled = True
            Me.mnulink1.Enabled = True
            Me.mnulink2.Enabled = True
        End If

        If Me.IDVFelder.Rows.Count = 0 Then
            Me.mnulink1.Enabled = False
            Me.mnulink2.Enabled = False
        Else
            Me.mnulink1.Enabled = True
            Me.mnulink2.Enabled = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.ContextMenu3_Popup Method

Private Sub ContextMenu3_Popup( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
) Handles ContextMenu3.Popup

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ContextMenu3_Popup(ByVal sender As Object, ByVal e As System.EventArgs) Handles ContextMenu3.Popup
        If Me.VerkFelder.Rows.Count = 0 Then
            Me.mnuDelVerk.Enabled = False
        Else
            Me.mnuDelVerk.Enabled = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(ucnoedit))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.grpUsed = New System.Windows.Forms.GroupBox()
        Me.usedlist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu1 = New System.Windows.Forms.ContextMenu()
        Me.mnuposdoc = New System.Windows.Forms.MenuItem()
        Me.mnulink1 = New System.Windows.Forms.MenuItem()
        Me.GrpIDV = New System.Windows.Forms.GroupBox()
        Me.idvwerteList = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu2 = New System.Windows.Forms.ContextMenu()
        Me.mnulink2 = New System.Windows.Forms.MenuItem()
        Me.GroupBox1 = New System.Windows.Forms.GroupBox()
        Me.verklist = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
        Me.ContextMenu3 = New System.Windows.Forms.ContextMenu()
        Me.mnuDelVerk = New System.Windows.Forms.MenuItem()
        Me.grpUsed.SuspendLayout()
        CType(Me.usedlist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GrpIDV.SuspendLayout()
        CType(Me.idvwerteList, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.GroupBox1.SuspendLayout()
        CType(Me.verklist, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'grpUsed
        '
        Me.grpUsed.Controls.AddRange(New System.Windows.Forms.Control() {Me.usedlist})
        Me.grpUsed.Location = New System.Drawing.Point(8, 8)
        Me.grpUsed.Name = "grpUsed"
        Me.grpUsed.Size = New System.Drawing.Size(336, 152)
        Me.grpUsed.TabIndex = 3
        Me.grpUsed.TabStop = False
        Me.grpUsed.Text = "Platzhalter im Dokument"
        '
        'usedlist
        '
        Me.usedlist.AllowDelete = True
        Me.usedlist.AllowFilter = True
        Me.usedlist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.usedlist.AllowSort = True
        Me.usedlist.AlternatingRows = True
        Me.usedlist.CaptionHeight = 17
        Me.usedlist.CollapseColor = System.Drawing.Color.Black
        Me.usedlist.ContextMenu = Me.ContextMenu1
        Me.usedlist.Cursor = System.Windows.Forms.Cursors.Default
        Me.usedlist.DataChanged = False
        Me.usedlist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.usedlist.ExpandColor = System.Drawing.Color.Black
        Me.usedlist.FetchRowStyles = True
        Me.usedlist.FilterBar = True
        Me.usedlist.GroupByCaption = "Drag a column header here to group by that column"
        Me.usedlist.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.usedlist.Location = New System.Drawing.Point(3, 16)
        Me.usedlist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.usedlist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.usedlist.Name = "usedlist"
        Me.usedlist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.usedlist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.usedlist.PreviewInfo.ZoomFactor = 75
        Me.usedlist.PrintInfo.ShowOptionsDialog = False
        Me.usedlist.RecordSelectorWidth = 16
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.usedlist.RowDivider = GridLines1
        Me.usedlist.RowHeight = 15
        Me.usedlist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.usedlist.ScrollTips = True
        Me.usedlist.Size = New System.Drawing.Size(325, 128)
        Me.usedlist.TabIndex = 28
        Me.usedlist.Text = "C1TrueDBGrid1"
        Me.usedlist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 124</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, " & _
        "124</ClientArea></Blob>"
        '
        'ContextMenu1
        '
        Me.ContextMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuposdoc, Me.mnulink1})
        '
        'mnuposdoc
        '
        Me.mnuposdoc.Index = 0
        Me.mnuposdoc.Text = "Cursor &im Dokument positionieren"
        '
        'mnulink1
        '
        Me.mnulink1.Index = 1
        Me.mnulink1.Text = "&Platzhalter mit dok. spez.  Wert verknüpfen"
        '
        'GrpIDV
        '
        Me.GrpIDV.Controls.AddRange(New System.Windows.Forms.Control() {Me.idvwerteList})
        Me.GrpIDV.Location = New System.Drawing.Point(8, 168)
        Me.GrpIDV.Name = "GrpIDV"
        Me.GrpIDV.Size = New System.Drawing.Size(336, 104)
        Me.GrpIDV.TabIndex = 4
        Me.GrpIDV.TabStop = False
        Me.GrpIDV.Text = "Verfügbare dokumentspezifische Werte"
        '
        'idvwerteList
        '
        Me.idvwerteList.AllowDelete = True
        Me.idvwerteList.AllowFilter = True
        Me.idvwerteList.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.idvwerteList.AllowSort = True
        Me.idvwerteList.AlternatingRows = True
        Me.idvwerteList.CaptionHeight = 17
        Me.idvwerteList.CollapseColor = System.Drawing.Color.Black
        Me.idvwerteList.ContextMenu = Me.ContextMenu2
        Me.idvwerteList.Cursor = System.Windows.Forms.Cursors.Default
        Me.idvwerteList.DataChanged = False
        Me.idvwerteList.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.idvwerteList.ExpandColor = System.Drawing.Color.Black
        Me.idvwerteList.FetchRowStyles = True
        Me.idvwerteList.FilterBar = True
        Me.idvwerteList.GroupByCaption = "Drag a column header here to group by that column"
        Me.idvwerteList.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.idvwerteList.Location = New System.Drawing.Point(3, 16)
        Me.idvwerteList.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.idvwerteList.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.idvwerteList.Name = "idvwerteList"
        Me.idvwerteList.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.idvwerteList.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.idvwerteList.PreviewInfo.ZoomFactor = 75
        Me.idvwerteList.PrintInfo.ShowOptionsDialog = False
        Me.idvwerteList.RecordSelectorWidth = 16
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.idvwerteList.RowDivider = GridLines2
        Me.idvwerteList.RowHeight = 15
        Me.idvwerteList.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.idvwerteList.ScrollTips = True
        Me.idvwerteList.Size = New System.Drawing.Size(325, 80)
        Me.idvwerteList.TabIndex = 28
        Me.idvwerteList.Text = "C1TrueDBGrid1"
        Me.idvwerteList.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert" & _
        ":Center;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}Footer{}Caption{AlignHorz:Center;}Editor{}Normal{B" & _
        "ackColor:Control;}Style27{}Style26{}HighlightRow{ForeColor:HighlightText;BackCol" & _
        "or:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage:" & _
        "Center;}Style9{}Style8{}Style3{}Style2{}Group{AlignVert:Center;Border:None,,0, 0" & _
        ", 0, 0;BackColor:ControlDark;}Style10{AlignHorz:Near;}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 76</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""Sty" & _
        "le10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRow" & _
        """ me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle p" & _
        "arent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingS" & _
        "tyle parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me=" & _
        """Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""O" & _
        "ddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /" & _
        "><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Style" & _
        "1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=""" & _
        "Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foot" & _
        "er"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactiv" & _
        "e"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /" & _
        "><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" " & _
        "/><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelecto" & _
        "r"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" " & _
        "/></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Modi" & _
        "fied</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, 7" & _
        "6</ClientArea></Blob>"
        '
        'ContextMenu2
        '
        Me.ContextMenu2.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnulink2})
        '
        'mnulink2
        '
        Me.mnulink2.Index = 0
        Me.mnulink2.Text = "&Platzhalter mit dok. spez. Wert verknüpfen"
        '
        'GroupBox1
        '
        Me.GroupBox1.Controls.AddRange(New System.Windows.Forms.Control() {Me.verklist})
        Me.GroupBox1.Location = New System.Drawing.Point(8, 280)
        Me.GroupBox1.Name = "GroupBox1"
        Me.GroupBox1.Size = New System.Drawing.Size(336, 144)
        Me.GroupBox1.TabIndex = 5
        Me.GroupBox1.TabStop = False
        Me.GroupBox1.Text = "Zugeordnete, dokumentspezifische Werte"
        '
        'verklist
        '
        Me.verklist.AllowDelete = True
        Me.verklist.AllowFilter = True
        Me.verklist.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.verklist.AllowSort = True
        Me.verklist.AlternatingRows = True
        Me.verklist.CaptionHeight = 17
        Me.verklist.CollapseColor = System.Drawing.Color.Black
        Me.verklist.ContextMenu = Me.ContextMenu3
        Me.verklist.Cursor = System.Windows.Forms.Cursors.Default
        Me.verklist.DataChanged = False
        Me.verklist.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.verklist.ExpandColor = System.Drawing.Color.Black
        Me.verklist.FetchRowStyles = True
        Me.verklist.FilterBar = True
        Me.verklist.GroupByCaption = "Drag a column header here to group by that column"
        Me.verklist.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.verklist.Location = New System.Drawing.Point(3, 16)
        Me.verklist.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.DottedCellBorder
        Me.verklist.MultiSelect = C1.Win.C1TrueDBGrid.MultiSelectEnum.None
        Me.verklist.Name = "verklist"
        Me.verklist.PreviewInfo.Location = New System.Drawing.Point(0, 0)
        Me.verklist.PreviewInfo.Size = New System.Drawing.Size(0, 0)
        Me.verklist.PreviewInfo.ZoomFactor = 75
        Me.verklist.PrintInfo.ShowOptionsDialog = False
        Me.verklist.RecordSelectorWidth = 16
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.verklist.RowDivider = GridLines3
        Me.verklist.RowHeight = 15
        Me.verklist.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.verklist.ScrollTips = True
        Me.verklist.Size = New System.Drawing.Size(325, 120)
        Me.verklist.TabIndex = 28
        Me.verklist.Text = "C1TrueDBGrid1"
        Me.verklist.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Style11{}Style12{}Style13{}Style5{}Style4{}Style7{}Style6{}EvenRow{Back" & _
        "Color:White;}Selected{ForeColor:HighlightText;BackColor:Highlight;}Heading{Wrap:" & _
        "True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:ControlText;BackColor:" & _
        "Control;}Inactive{ForeColor:InactiveCaptionText;BackColor:InactiveCaption;}Filte" & _
        "rBar{BackColor:255, 255, 192;}OddRow{BackColor:224, 224, 224;}Footer{}Caption{Al" & _
        "ignHorz:Center;}Style27{}Normal{BackColor:Control;}Style26{}HighlightRow{ForeCol" & _
        "or:HighlightText;BackColor:Highlight;}Style10{AlignHorz:Near;}Editor{}RecordSele" & _
        "ctor{AlignImage:Center;}Style9{}Style8{}Style3{}Style2{}Group{BackColor:ControlD" & _
        "ark;Border:None,,0, 0, 0, 0;AlignVert:Center;}Style1{}</Data></Styles><Splits><C" & _
        "1.Win.C1TrueDBGrid.MergeView Name="""" AlternatingRowStyle=""True"" CaptionHeight=""1" & _
        "7"" ColumnCaptionHeight=""17"" ColumnFooterHeight=""17"" FetchRowStyles=""True"" Filter" & _
        "Bar=""True"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" DefRecSelWid" & _
        "th=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><ClientRect>0, 0, 321," & _
        " 116</ClientRect><BorderSide>0</BorderSide><CaptionStyle parent=""Heading"" me=""St" & _
        "yle10"" /><EditorStyle parent=""Editor"" me=""Style2"" /><EvenRowStyle parent=""EvenRo" & _
        "w"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Style27"" /><FooterStyle " & _
        "parent=""Footer"" me=""Style4"" /><GroupStyle parent=""Group"" me=""Style12"" /><Heading" & _
        "Style parent=""Heading"" me=""Style3"" /><HighLightRowStyle parent=""HighlightRow"" me" & _
        "=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style6"" /><OddRowStyle parent=""" & _
        "OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" " & _
        "/><SelectedStyle parent=""Selected"" me=""Style5"" /><Style parent=""Normal"" me=""Styl" & _
        "e1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles><Style parent="""" me=" & _
        """Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Foo" & _
        "ter"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inacti" & _
        "ve"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" " & _
        "/><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow""" & _
        " /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelect" & _
        "or"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group""" & _
        " /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>Mod" & _
        "ified</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 321, " & _
        "116</ClientArea></Blob>"
        '
        'ContextMenu3
        '
        Me.ContextMenu3.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.mnuDelVerk})
        '
        'mnuDelVerk
        '
        Me.mnuDelVerk.Index = 0
        Me.mnuDelVerk.Text = "&Verknüpfung löschen"
        '
        'ucnoedit
        '
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.GroupBox1, Me.GrpIDV, Me.grpUsed})
        Me.Name = "ucnoedit"
        Me.Size = New System.Drawing.Size(352, 432)
        Me.grpUsed.ResumeLayout(False)
        CType(Me.usedlist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GrpIDV.ResumeLayout(False)
        CType(Me.idvwerteList, System.ComponentModel.ISupportInitialize).EndInit()
        Me.GroupBox1.ResumeLayout(False)
        CType(Me.verklist, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.mnuDelVerk_Click Method

Private Sub mnuDelVerk_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuDelVerk.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuDelVerk_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuDelVerk.Click
        Me.verklist.Delete()
        Me.verklist.UpdateData()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.mnulink1_Click Method

Private Sub mnulink1_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnulink1.Click, _
   mnulink2.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnulink1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnulink1.Click, mnulink2.Click
        Dim row As DataRow
        row = Me.VerkFelder.NewRow
        row.Item(0) = Me.idvwerteList.Columns(0).Text
        row.Item(1) = Me.usedlist.Columns(1).Text
        row.Item(2) = Me.usedlist.Columns(0).Text
        Me.VerkFelder.Rows.Add(row)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.mnuposdoc_Click Method

Private Sub mnuposdoc_Click( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles mnuposdoc.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub mnuposdoc_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles mnuposdoc.Click
        If Me.usedlist.Columns("Feldname").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("feldname").Text, True)
            Exit Sub
        End If
        If Me.usedlist.Columns("beginntextmarke").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("beginntextmarke").Text, False)
            Exit Sub
        End If

        If Me.usedlist.Columns("endetextmarke").Text <> "" Then
            RaiseEvent OnGoto_TM(Me.usedlist.Columns("endetextmarke").Text, False)
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit.ucnoedit_Load Method

Private Sub ucnoedit_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ucnoedit_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer

        RaiseEvent OnGetUsedFelder(Me.USEDFelder)
        Me.usedlist.DataSource = Me.USEDFelder
        Me.usedlist.DataMember = Me.USEDFelder.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.usedlist, Me.USEDFelder, "edex_sb_vorlagenfelder")

        'With Me.usedlist
        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.usedlist.Width * 0.1
        '    .Splits(0).DisplayColumns(1).Visible = True
        '    .Splits(0).DisplayColumns(1).Width = Me.usedlist.Width * 0.8
        'End With

        RaiseEvent OnGetIDVFelder(Me.IDVFelder)
        Me.idvwerteList.DataSource = Me.IDVFelder
        Me.idvwerteList.DataMember = Me.IDVFelder.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.idvwerteList, Me.IDVFelder, "edex_sb_verk")
        'With Me.idvwerteList
        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.usedlist.Width * 0.9
        '    .Splits(0).DisplayColumns(1).Visible = False
        'End With

        RaiseEvent OnGetVerknuepfteFelder(Me.VerkFelder)
        Me.verklist.DataSource = Me.VerkFelder
        Me.verklist.DataMember = Me.VerkFelder.TableName
        DivFnkt.SpaltenTitel_Aktualisieren(Me.verklist, Me.VerkFelder, "edex_sb_verk")
        'With Me.verklist
        '    For i = 0 To .Splits(0).DisplayColumns.Count - 1
        '        .Splits(0).DisplayColumns(i).Visible = False
        '    Next
        '    .Splits(0).DisplayColumns(0).Visible = True
        '    .Splits(0).DisplayColumns(0).Width = Me.usedlist.Width * 0.45
        '    .Splits(0).DisplayColumns(1).Visible = True
        '    .Splits(0).DisplayColumns(1).Width = Me.usedlist.Width * 0.45
        'End With
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit Events

ucnoedit overview

Events

event OnDelete_TM
event OnGetIDVFelder
event OnGetStandardvorlagenfelder
event OnGetUsedFelder
event OnGetVerknuepfteFelder
event OnGoto_TM
event OnInsert_TM

See Also

ucnoedit Class


OnDelete_TM Event

Public Event OnDelete_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnDelete_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnGetIDVFelder Event

Public Event OnGetIDVFelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetIDVFelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnGetStandardvorlagenfelder Event

Public Event OnGetStandardvorlagenfelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetStandardvorlagenfelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnGetUsedFelder Event

Public Event OnGetUsedFelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetUsedFelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnGetVerknuepfteFelder Event

Public Event OnGetVerknuepfteFelder( _
   ByRef list As DataTable _
)

Parameters

list
Required.

Source code

[Visual Basic]
    Public Event OnGetVerknuepfteFelder(ByRef list As DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnGoto_TM Event

Public Event OnGoto_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnGoto_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


OnInsert_TM Event

Public Event OnInsert_TM( _
   ByVal TMName As String, _
   ByVal isfield As Boolean _
)

Parameters

TMName
Required.
isfield
Required.

Source code

[Visual Basic]
    Public Event OnInsert_TM(ByVal TMName As String, ByVal isfield As Boolean)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ucnoedit Fields

ucnoedit overview

Fields

field ContextMenu1
field ContextMenu2
field ContextMenu3
field GroupBox1
field GrpIDV
field IDVFelder
field StdFelder
field USEDFelder
field VerkFelder
field components
field grpUsed
field idvwerteList
field mnuDelVerk
field mnulink1
field mnulink2
field mnuposdoc
field usedlist
field verklist

See Also

ucnoedit Class


ContextMenu1 Variable

Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu1 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ContextMenu2 Variable

Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu2 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


ContextMenu3 Variable

Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Source code

[Visual Basic]
    Friend WithEvents ContextMenu3 As System.Windows.Forms.ContextMenu

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


GroupBox1 Variable

Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GroupBox1 As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


GrpIDV Variable

Friend WithEvents GrpIDV As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents GrpIDV As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


IDVFelder Variable

Dim IDVFelder As New DataTable()

Source code

[Visual Basic]
    Dim IDVFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


StdFelder Variable

Dim StdFelder As New DataTable()

Source code

[Visual Basic]
    Dim StdFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


USEDFelder Variable

Dim USEDFelder As New DataTable()

Source code

[Visual Basic]
    Dim USEDFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


VerkFelder Variable

Dim VerkFelder As New DataTable()

Source code

[Visual Basic]
    Dim VerkFelder As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


grpUsed Variable

Friend WithEvents grpUsed As System.Windows.Forms.GroupBox

Source code

[Visual Basic]
    Friend WithEvents grpUsed As System.Windows.Forms.GroupBox

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


idvwerteList Variable

Friend WithEvents idvwerteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents idvwerteList As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


mnuDelVerk Variable

Friend WithEvents mnuDelVerk As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuDelVerk As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


mnulink1 Variable

Friend WithEvents mnulink1 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnulink1 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


mnulink2 Variable

Friend WithEvents mnulink2 As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnulink2 As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


mnuposdoc Variable

Friend WithEvents mnuposdoc As System.Windows.Forms.MenuItem

Source code

[Visual Basic]
    Friend WithEvents mnuposdoc As System.Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


usedlist Variable

Friend WithEvents usedlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents usedlist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


verklist Variable

Friend WithEvents verklist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Source code

[Visual Basic]
    Friend WithEvents verklist As C1.Win.C1TrueDBGrid.C1TrueDBGrid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ucnoedit


xfrmDomainMitarbeiter Class

For a list of all members of this type, see xfrmDomainMitarbeiter Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.frmDomainEditor
EDOKAApp.xfrmDomainMitarbeiter

Public Class xfrmDomainMitarbeiter
   Inherits frmDomainEditor

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

xfrmDomainMitarbeiter Members


xfrmDomainMitarbeiter Members

xfrmDomainMitarbeiter overview

Constructors

constructor xfrmDomainMitarbeiter Constructor

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

Fields

field C1TrueDBDropdown1
field C1TrueDBDropdown2
field C1TrueDBDropdown3
field DataSet1
field DataSet3
field DataSet4
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlInsertCommand1
field SqlInsertCommand3
field SqlInsertCommand4
field SqlSelectCommand1
field SqlSelectCommand3
field SqlSelectCommand4
field SqlUpdateCommand1
field SqlUpdateCommand3
field SqlUpdateCommand4
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

xfrmDomainMitarbeiter Class


xfrmDomainMitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter Properties

xfrmDomainMitarbeiter overview

Properties

property Eintrag (inherited from EDOKAApp.frmDomainEditor)
property Eintragnr (inherited from EDOKAApp.frmDomainEditor)
property FormMaximize (inherited from EDOKAApp.frmDomainEditor)
property Inaktive (inherited from EDOKAApp.frmDomainEditor)
property TableName (inherited from EDOKAApp.frmDomainEditor)
property ToSelect (inherited from EDOKAApp.frmDomainEditor)
property TransferKey (inherited from EDOKAApp.frmDomainEditor)

See Also

xfrmDomainMitarbeiter Class


xfrmDomainMitarbeiter Methods

xfrmDomainMitarbeiter overview

Methods

method Dispose
method FormSize (inherited from EDOKAApp.frmDomainEditor)
method InitializeComponent
method Save_Data
method SpaltenTitel_Aktualisieren (inherited from EDOKAApp.frmDomainEditor)
method ToolBar1_ButtonClick
method frmClose
method frmDomainMandant_Load

See Also

xfrmDomainMitarbeiter Class


xfrmDomainMitarbeiter.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
    Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
        If disposing Then
            If Not (components Is Nothing) Then
                components.Dispose()
            End If
        End If
        MyBase.Dispose(disposing)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
    <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
        Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmDomainMitarbeiter))
        Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
        Me.SqlDataAdapter1 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlConnection1 = New System.Data.SqlClient.SqlConnection()
        Me.DataSet1 = New System.Data.DataSet()
        Me.C1TrueDBDropdown1 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlDataAdapter3 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand3 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet3 = New System.Data.DataSet()
        Me.C1TrueDBDropdown2 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.C1TrueDBDropdown3 = New C1.Win.C1TrueDBGrid.C1TrueDBDropdown()
        Me.SqlDataAdapter4 = New System.Data.SqlClient.SqlDataAdapter()
        Me.SqlDeleteCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlSelectCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand4 = New System.Data.SqlClient.SqlCommand()
        Me.DataSet4 = New System.Data.DataSet()
        Me.SqlSelectCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlInsertCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlUpdateCommand1 = New System.Data.SqlClient.SqlCommand()
        Me.SqlDeleteCommand1 = New System.Data.SqlClient.SqlCommand()
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown2, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.C1TrueDBDropdown3, System.ComponentModel.ISupportInitialize).BeginInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.SuspendLayout()
        '
        'SqlDataAdapter1
        '
        Me.SqlDataAdapter1.DeleteCommand = Me.SqlDeleteCommand1
        Me.SqlDataAdapter1.InsertCommand = Me.SqlInsertCommand1
        Me.SqlDataAdapter1.SelectCommand = Me.SqlSelectCommand1
        Me.SqlDataAdapter1.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "mitarbeiter", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("mitarbeiternr", "mitarbeiternr"), New System.Data.Common.DataColumnMapping("vorname", "vorname"), New System.Data.Common.DataColumnMapping("name", "name"), New System.Data.Common.DataColumnMapping("tgnummer", "tgnummer"), New System.Data.Common.DataColumnMapping("email", "email"), New System.Data.Common.DataColumnMapping("fax", "fax"), New System.Data.Common.DataColumnMapping("telefon", "telefon"), New System.Data.Common.DataColumnMapping("unterschrift_text", "unterschrift_text"), New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("sprache", "sprache"), New System.Data.Common.DataColumnMapping("fuermandant", "fuermandant"), New System.Data.Common.DataColumnMapping("showtip", "showtip"), New System.Data.Common.DataColumnMapping("partnernr", "partnernr"), New System.Data.Common.DataColumnMapping("mandantnr", "mandantnr"), New System.Data.Common.DataColumnMapping("aktiv", "aktiv"), New System.Data.Common.DataColumnMapping("erstellt_am", "erstellt_am"), New System.Data.Common.DataColumnMapping("mutiert_am", "mutiert_am"), New System.Data.Common.DataColumnMapping("mutierer", "mutierer")})})
        Me.SqlDataAdapter1.UpdateCommand = Me.SqlUpdateCommand1
        '
        'SqlConnection1
        '
        Me.SqlConnection1.ConnectionString = "data source=shu;initial catalog=edoka;persist security info=False;user id=sa;work" & _
        "station id=SHU;packet size=4096"
        '
        'DataSet1
        '
        Me.DataSet1.DataSetName = "NewDataSet"
        Me.DataSet1.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBDropdown1
        '
        Me.C1TrueDBDropdown1.AllowColMove = True
        Me.C1TrueDBDropdown1.AllowColSelect = True
        Me.C1TrueDBDropdown1.AllowFilter = True
        Me.C1TrueDBDropdown1.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown1.AllowSort = True
        Me.C1TrueDBDropdown1.AlternatingRows = False
        Me.C1TrueDBDropdown1.CaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown1.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown1.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown1.FetchRowStyles = False
        Me.C1TrueDBDropdown1.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown1.LayoutFileName = ""
        Me.C1TrueDBDropdown1.LayoutName = ""
        Me.C1TrueDBDropdown1.LayoutURL = ""
        Me.C1TrueDBDropdown1.Location = New System.Drawing.Point(384, 0)
        Me.C1TrueDBDropdown1.Name = "C1TrueDBDropdown1"
        GridLines1.Color = System.Drawing.Color.DarkGray
        GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown1.RowDivider = GridLines1
        Me.C1TrueDBDropdown1.RowHeight = 15
        Me.C1TrueDBDropdown1.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown1.ScrollTips = False
        Me.C1TrueDBDropdown1.Size = New System.Drawing.Size(216, 208)
        Me.C1TrueDBDropdown1.TabIndex = 5
        Me.C1TrueDBDropdown1.Text = "C1TrueDBDropdown1"
        Me.C1TrueDBDropdown1.Visible = False
        Me.C1TrueDBDropdown1.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 212, 204</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 212, 204</ClientA" & _
        "rea></Blob>"
        '
        'SqlDataAdapter3
        '
        Me.SqlDataAdapter3.DeleteCommand = Me.SqlDeleteCommand3
        Me.SqlDataAdapter3.InsertCommand = Me.SqlInsertCommand3
        Me.SqlDataAdapter3.SelectCommand = Me.SqlSelectCommand3
        Me.SqlDataAdapter3.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "team", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("teamnr", "teamnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter3.UpdateCommand = Me.SqlUpdateCommand3
        '
        'SqlDeleteCommand3
        '
        Me.SqlDeleteCommand3.CommandText = "[pv_team_aktiv_delete]"
        Me.SqlDeleteCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand3.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand3
        '
        Me.SqlInsertCommand3.CommandText = "[pv_team_aktiv_insert]"
        Me.SqlInsertCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand3.Connection = Me.SqlConnection1
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlInsertCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand3
        '
        Me.SqlSelectCommand3.CommandText = "[pv_team_aktiv_select]"
        Me.SqlSelectCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand3.Connection = Me.SqlConnection1
        Me.SqlSelectCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand3
        '
        Me.SqlUpdateCommand3.CommandText = "[pv_team_aktiv_update]"
        Me.SqlUpdateCommand3.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand3.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@teamnr", System.Data.SqlDbType.Int, 4, "teamnr"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_teamnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "teamnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand3.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet3
        '
        Me.DataSet3.DataSetName = "NewDataSet"
        Me.DataSet3.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'C1TrueDBDropdown2
        '
        Me.C1TrueDBDropdown2.AllowColMove = True
        Me.C1TrueDBDropdown2.AllowColSelect = True
        Me.C1TrueDBDropdown2.AllowFilter = True
        Me.C1TrueDBDropdown2.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown2.AllowSort = True
        Me.C1TrueDBDropdown2.AlternatingRows = False
        Me.C1TrueDBDropdown2.CaptionHeight = 17
        Me.C1TrueDBDropdown2.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown2.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown2.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown2.FetchRowStyles = False
        Me.C1TrueDBDropdown2.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown2.LayoutFileName = ""
        Me.C1TrueDBDropdown2.LayoutName = ""
        Me.C1TrueDBDropdown2.LayoutURL = ""
        Me.C1TrueDBDropdown2.Location = New System.Drawing.Point(512, 0)
        Me.C1TrueDBDropdown2.Name = "C1TrueDBDropdown2"
        GridLines2.Color = System.Drawing.Color.DarkGray
        GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown2.RowDivider = GridLines2
        Me.C1TrueDBDropdown2.RowHeight = 15
        Me.C1TrueDBDropdown2.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown2.ScrollTips = False
        Me.C1TrueDBDropdown2.Size = New System.Drawing.Size(208, 168)
        Me.C1TrueDBDropdown2.TabIndex = 6
        Me.C1TrueDBDropdown2.Text = "C1TrueDBDropdown2"
        Me.C1TrueDBDropdown2.Visible = False
        Me.C1TrueDBDropdown2.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 204, 164</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 204, 164</ClientA" & _
        "rea></Blob>"
        '
        'C1TrueDBDropdown3
        '
        Me.C1TrueDBDropdown3.AllowColMove = True
        Me.C1TrueDBDropdown3.AllowColSelect = True
        Me.C1TrueDBDropdown3.AllowFilter = True
        Me.C1TrueDBDropdown3.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
        Me.C1TrueDBDropdown3.AllowSort = True
        Me.C1TrueDBDropdown3.AlternatingRows = False
        Me.C1TrueDBDropdown3.CaptionHeight = 17
        Me.C1TrueDBDropdown3.ColumnCaptionHeight = 17
        Me.C1TrueDBDropdown3.ColumnFooterHeight = 17
        Me.C1TrueDBDropdown3.DeadAreaBackColor = System.Drawing.Color.Empty
        Me.C1TrueDBDropdown3.FetchRowStyles = False
        Me.C1TrueDBDropdown3.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
        Me.C1TrueDBDropdown3.LayoutFileName = ""
        Me.C1TrueDBDropdown3.LayoutName = ""
        Me.C1TrueDBDropdown3.LayoutURL = ""
        Me.C1TrueDBDropdown3.Location = New System.Drawing.Point(280, 0)
        Me.C1TrueDBDropdown3.Name = "C1TrueDBDropdown3"
        GridLines3.Color = System.Drawing.Color.DarkGray
        GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
        Me.C1TrueDBDropdown3.RowDivider = GridLines3
        Me.C1TrueDBDropdown3.RowHeight = 15
        Me.C1TrueDBDropdown3.RowSubDividerColor = System.Drawing.Color.DarkGray
        Me.C1TrueDBDropdown3.ScrollTips = False
        Me.C1TrueDBDropdown3.Size = New System.Drawing.Size(208, 184)
        Me.C1TrueDBDropdown3.TabIndex = 7
        Me.C1TrueDBDropdown3.Text = "C1TrueDBDropdown3"
        Me.C1TrueDBDropdown3.Visible = False
        Me.C1TrueDBDropdown3.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
        "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
        "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:Aqua;}Selected{" & _
        "ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactive" & _
        "CaptionText;BackColor:InactiveCaption;}FilterBar{}Footer{}Caption{AlignHorz:Cent" & _
        "er;}Normal{}HighlightRow{ForeColor:HighlightText;BackColor:Highlight;}Style1{}Od" & _
        "dRow{}RecordSelector{AlignImage:Center;}Heading{Wrap:True;BackColor:Control;Bord" & _
        "er:Raised,,1, 1, 1, 1;ForeColor:ControlText;AlignVert:Center;}Style8{}Style10{Al" & _
        "ignHorz:Near;}Style11{}Style12{}Style13{}Style9{}</Data></Styles><Splits><C1.Win" & _
        ".C1TrueDBGrid.DropdownView Name="""" CaptionHeight=""17"" ColumnCaptionHeight=""17"" C" & _
        "olumnFooterHeight=""17"" MarqueeStyle=""DottedCellBorder"" RecordSelectorWidth=""16"" " & _
        "RecordSelectors=""False"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><Clien" & _
        "tRect>0, 0, 204, 180</ClientRect><CaptionStyle parent=""Style2"" me=""Style10"" /><E" & _
        "ditorStyle parent=""Editor"" me=""Style5"" /><EvenRowStyle parent=""EvenRow"" me=""Styl" & _
        "e8"" /><FilterBarStyle parent=""FilterBar"" me=""Style13"" /><FooterStyle parent=""Foo" & _
        "ter"" me=""Style3"" /><GroupStyle parent=""Group"" me=""Style12"" /><HeadingStyle paren" & _
        "t=""Heading"" me=""Style2"" /><HighLightRowStyle parent=""HighlightRow"" me=""Style7"" /" & _
        "><InactiveStyle parent=""Inactive"" me=""Style4"" /><OddRowStyle parent=""OddRow"" me=" & _
        """Style9"" /><RecordSelectorStyle parent=""RecordSelector"" me=""Style11"" /><Selected" & _
        "Style parent=""Selected"" me=""Style6"" /><Style parent=""Normal"" me=""Style1"" /></C1." & _
        "Win.C1TrueDBGrid.DropdownView></Splits><NamedStyles><Style parent="""" me=""Normal""" & _
        " /><Style parent=""Normal"" me=""Heading"" /><Style parent=""Heading"" me=""Footer"" /><" & _
        "Style parent=""Heading"" me=""Caption"" /><Style parent=""Heading"" me=""Inactive"" /><S" & _
        "tyle parent=""Normal"" me=""Selected"" /><Style parent=""Normal"" me=""Editor"" /><Style" & _
        " parent=""Normal"" me=""HighlightRow"" /><Style parent=""Normal"" me=""EvenRow"" /><Styl" & _
        "e parent=""Normal"" me=""OddRow"" /><Style parent=""Heading"" me=""RecordSelector"" /><S" & _
        "tyle parent=""Normal"" me=""FilterBar"" /><Style parent=""Caption"" me=""Group"" /></Nam" & _
        "edStyles><vertSplits>1</vertSplits><horzSplits>1</horzSplits><Layout>None</Layou" & _
        "t><DefaultRecSelWidth>16</DefaultRecSelWidth><ClientArea>0, 0, 204, 180</ClientA" & _
        "rea></Blob>"
        '
        'SqlDataAdapter4
        '
        Me.SqlDataAdapter4.DeleteCommand = Me.SqlDeleteCommand4
        Me.SqlDataAdapter4.InsertCommand = Me.SqlInsertCommand4
        Me.SqlDataAdapter4.SelectCommand = Me.SqlSelectCommand4
        Me.SqlDataAdapter4.TableMappings.AddRange(New System.Data.Common.DataTableMapping() {New System.Data.Common.DataTableMapping("Table", "funktion", New System.Data.Common.DataColumnMapping() {New System.Data.Common.DataColumnMapping("funktionnr", "funktionnr"), New System.Data.Common.DataColumnMapping("bezeichnung", "bezeichnung")})})
        Me.SqlDataAdapter4.UpdateCommand = Me.SqlUpdateCommand4
        '
        'SqlDeleteCommand4
        '
        Me.SqlDeleteCommand4.CommandText = "[pv_funktion_aktiv_delete]"
        Me.SqlDeleteCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand4.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlInsertCommand4
        '
        Me.SqlInsertCommand4.CommandText = "[pv_funktion_aktiv_insert]"
        Me.SqlInsertCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand4.Connection = Me.SqlConnection1
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        '
        'SqlSelectCommand4
        '
        Me.SqlSelectCommand4.CommandText = "[pv_funktion_aktiv_select]"
        Me.SqlSelectCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand4.Connection = Me.SqlConnection1
        Me.SqlSelectCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        '
        'SqlUpdateCommand4
        '
        Me.SqlUpdateCommand4.CommandText = "[pv_funktion_aktiv_update]"
        Me.SqlUpdateCommand4.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand4.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@bezeichnung", System.Data.SqlDbType.VarChar, 255, "bezeichnung"))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand4.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_bezeichnung", System.Data.SqlDbType.VarChar, 255, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "bezeichnung", System.Data.DataRowVersion.Original, Nothing))
        '
        'DataSet4
        '
        Me.DataSet4.DataSetName = "NewDataSet"
        Me.DataSet4.Locale = New System.Globalization.CultureInfo("de-CH")
        '
        'SqlSelectCommand1
        '
        Me.SqlSelectCommand1.CommandText = "[pv_mitarbeiter_select]"
        Me.SqlSelectCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlSelectCommand1.Connection = Me.SqlConnection1
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlSelectCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandant", System.Data.SqlDbType.Int, 4, "mandantnr"))
        '
        'SqlInsertCommand1
        '
        Me.SqlInsertCommand1.CommandText = "[pv_mitarbeiter_insert]"
        Me.SqlInsertCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlInsertCommand1.Connection = Me.SqlConnection1
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlInsertCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        '
        'SqlUpdateCommand1
        '
        Me.SqlUpdateCommand1.CommandText = "[pv_mitarbeiter_update]"
        Me.SqlUpdateCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlUpdateCommand1.Connection = Me.SqlConnection1
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mitarbeiternr", System.Data.SqlDbType.Int, 4, "mitarbeiternr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@vorname", System.Data.SqlDbType.VarChar, 50, "vorname"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@name", System.Data.SqlDbType.VarChar, 50, "name"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@tgnummer", System.Data.SqlDbType.VarChar, 50, "tgnummer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@email", System.Data.SqlDbType.VarChar, 50, "email"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fax", System.Data.SqlDbType.VarChar, 50, "fax"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@telefon", System.Data.SqlDbType.VarChar, 50, "telefon"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@unterschrift_text", System.Data.SqlDbType.VarChar, 50, "unterschrift_text"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@funktionnr", System.Data.SqlDbType.Int, 4, "funktionnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@sprache", System.Data.SqlDbType.Int, 4, "sprache"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@fuermandant", System.Data.SqlDbType.Int, 4, "fuermandant"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@showtip", System.Data.SqlDbType.Bit, 1, "showtip"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@partnernr", System.Data.SqlDbType.Int, 4, "partnernr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mandantnr", System.Data.SqlDbType.Int, 4, "mandantnr"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@aktiv", System.Data.SqlDbType.Bit, 1, "aktiv"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@erstellt_am", System.Data.SqlDbType.DateTime, 8, "erstellt_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutiert_am", System.Data.SqlDbType.DateTime, 8, "mutiert_am"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@mutierer", System.Data.SqlDbType.Int, 4, "mutierer"))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlUpdateCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'SqlDeleteCommand1
        '
        Me.SqlDeleteCommand1.CommandText = "[pv_mitarbeiter_delete]"
        Me.SqlDeleteCommand1.CommandType = System.Data.CommandType.StoredProcedure
        Me.SqlDeleteCommand1.Connection = Me.SqlConnection1
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@RETURN_VALUE", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.ReturnValue, False, CType(0, Byte), CType(0, Byte), "", System.Data.DataRowVersion.Current, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mitarbeiternr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mitarbeiternr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_aktiv", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "aktiv", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_email", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "email", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_erstellt_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "erstellt_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fax", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fax", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_fuermandant", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "fuermandant", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_funktionnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "funktionnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mandantnr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mandantnr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutierer", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutierer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_mutiert_am", System.Data.SqlDbType.DateTime, 8, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "mutiert_am", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_name", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "name", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_partnernr", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "partnernr", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_showtip", System.Data.SqlDbType.Bit, 1, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "showtip", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_sprache", System.Data.SqlDbType.Int, 4, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "sprache", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_telefon", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "telefon", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_tgnummer", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "tgnummer", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_unterschrift_text", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "unterschrift_text", System.Data.DataRowVersion.Original, Nothing))
        Me.SqlDeleteCommand1.Parameters.Add(New System.Data.SqlClient.SqlParameter("@Original_vorname", System.Data.SqlDbType.VarChar, 50, System.Data.ParameterDirection.Input, False, CType(0, Byte), CType(0, Byte), "vorname", System.Data.DataRowVersion.Original, Nothing))
        '
        'frmDomainMitarbeiter
        '
        Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
        Me.ClientSize = New System.Drawing.Size(776, 465)
        Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.C1TrueDBDropdown3, Me.C1TrueDBDropdown2, Me.C1TrueDBDropdown1})
        Me.Name = "frmDomainMitarbeiter"
        Me.Text = ""
        CType(Me.DataSet1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown1, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown2, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.C1TrueDBDropdown3, System.ComponentModel.ISupportInitialize).EndInit()
        CType(Me.DataSet4, System.ComponentModel.ISupportInitialize).EndInit()
        Me.ResumeLayout(False)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter.Save_Data Method

Private Function Save_Data() As Boolean

Source code

[Visual Basic]
    Private Function Save_Data() As Boolean
        Save_Data = True
        Try
            SqlDataAdapter1.Update(Me.DataSet1)
        Catch ex As Exception
            MsgBox(Globals.MyMsg.Get_Meldungstext(902))
            Save_Data = False
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
        Select Case ToolBar1.Buttons.IndexOf(e.Button)
            Case 0 'close button
                Me.Close()
            Case 1 'Speichern
                Save_Data()
        End Select
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter.frmClose Method

Private Sub frmClose( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmClose(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
        Dim msg As MsgBoxResult
        If Me.DataSet1.HasChanges Then
            msg = Globals.MyMsg.Show_MessageYesNoCancel(2)
            If msg = MsgBoxResult.No Then
                e.Cancel = False
            End If
            If msg = MsgBoxResult.Yes Then
                If Save_Data() Then e.Cancel = False Else e.Cancel = True
            End If
            If msg = MsgBoxResult.Cancel Then e.Cancel = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter.frmDomainMandant_Load Method

Private Sub frmDomainMandant_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Sub frmDomainMandant_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        Dim i As Integer
        Me.TableName = "mitarbeiter"
        Dim dbconn As New EDOKA.DB_Connection()
        Me.SqlConnection1.ConnectionString = Globals.sConnectionString
        Me.SqlConnection1.Open()

        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter1.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter1.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)

        Me.SqlDataAdapter1.Fill(Me.DataSet1)
        Me.DomainList.DataSource = Me.DataSet1
        Me.DomainList.DataMember = Me.TableName
        SpaltenTitel_Aktualisieren(Me.DataSet1)
        For i = 0 To Me.DomainList.Columns.Count - 1
            If Me.DomainList.Columns(i).DataField = "kostenstellenr" Then Me.DomainList.Columns(i).DefaultValue = 1
            If Me.DomainList.Columns(i).DataField = "partnernr" Then Me.DomainList.Columns(i).DefaultValue = 0
            If Me.DomainList.Columns(i).DataField = "showtip" Then Me.DomainList.Columns(i).DefaultValue = True
            If Me.DomainList.Columns(i).DataField = "fuermandant" Then Me.DomainList.Columns(i).DefaultValue = Globals.MandantNr
            If Me.DomainList.Columns(i).DataField = "sprache" Then Me.DomainList.Columns(i).DefaultValue = 1
            If Me.DomainList.Columns(i).DataField = "funktionnr" Then Me.DomainList.Columns(i).DefaultValue = 1
            If Me.DomainList.Columns(i).DataField = "teamnr" Then Me.DomainList.Columns(i).DefaultValue = 1
        Next

        'funkction
        ' Nur für den aktuell gewählten Mandanten die Daten auslesen
        Me.SqlDataAdapter4.SelectCommand.Parameters.Clear()
        Me.SqlDataAdapter4.SelectCommand.Parameters.Add("@mandantnr", Globals.MandantNr)
        Me.SqlDataAdapter4.Fill(Me.DataSet4)
        Me.C1TrueDBDropdown3.DataSource = Me.DataSet4
        Me.C1TrueDBDropdown3.DataMember = "funktion"
        Me.C1TrueDBDropdown3.Columns(0).Caption = MyMsg.Get_Meldungstext(7014)
        Me.C1TrueDBDropdown3.Columns(1).Caption = MyMsg.Get_Meldungstext(7015)
        Me.C1TrueDBDropdown3.DisplayColumns(0).Width = 20
        Me.C1TrueDBDropdown3.DisplayColumns(1).Width = 150
        Me.DomainList.Columns("funktionnr").DropDown = Me.C1TrueDBDropdown3

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


xfrmDomainMitarbeiter Fields

xfrmDomainMitarbeiter overview

Fields

field C1TrueDBDropdown1
field C1TrueDBDropdown2
field C1TrueDBDropdown3
field DataSet1
field DataSet3
field DataSet4
field DomainList (inherited from EDOKAApp.frmDomainEditor)
field ImageList1 (inherited from EDOKAApp.frmDomainEditor)
field MainMenu1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem1 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem2 (inherited from EDOKAApp.frmDomainEditor)
field MenuItem3 (inherited from EDOKAApp.frmDomainEditor)
field SqlConnection1
field SqlDataAdapter1
field SqlDataAdapter3
field SqlDataAdapter4
field SqlDeleteCommand1
field SqlDeleteCommand3
field SqlDeleteCommand4
field SqlInsertCommand1
field SqlInsertCommand3
field SqlInsertCommand4
field SqlSelectCommand1
field SqlSelectCommand3
field SqlSelectCommand4
field SqlUpdateCommand1
field SqlUpdateCommand3
field SqlUpdateCommand4
field ToolBar1 (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnExit (inherited from EDOKAApp.frmDomainEditor)
field ToolBtnSave (inherited from EDOKAApp.frmDomainEditor)
field components

See Also

xfrmDomainMitarbeiter Class


C1TrueDBDropdown1 Variable

Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown1 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


C1TrueDBDropdown2 Variable

Friend WithEvents C1TrueDBDropdown2 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown2 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


C1TrueDBDropdown3 Variable

Friend WithEvents C1TrueDBDropdown3 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Source code

[Visual Basic]
    Friend WithEvents C1TrueDBDropdown3 As C1.Win.C1TrueDBGrid.C1TrueDBDropdown

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


DataSet1 Variable

Friend WithEvents DataSet1 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet1 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


DataSet3 Variable

Friend WithEvents DataSet3 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet3 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


DataSet4 Variable

Friend WithEvents DataSet4 As System.Data.DataSet

Source code

[Visual Basic]
    Friend WithEvents DataSet4 As System.Data.DataSet

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlConnection1 Variable

Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Source code

[Visual Basic]
    Friend WithEvents SqlConnection1 As System.Data.SqlClient.SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDataAdapter1 Variable

Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter1 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDataAdapter3 Variable

Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter3 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDataAdapter4 Variable

Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Source code

[Visual Basic]
    Friend WithEvents SqlDataAdapter4 As System.Data.SqlClient.SqlDataAdapter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDeleteCommand1 Variable

Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDeleteCommand3 Variable

Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlDeleteCommand4 Variable

Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlDeleteCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlInsertCommand1 Variable

Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlInsertCommand3 Variable

Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlInsertCommand4 Variable

Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlInsertCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlSelectCommand1 Variable

Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlSelectCommand3 Variable

Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlSelectCommand4 Variable

Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlSelectCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlUpdateCommand1 Variable

Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand1 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlUpdateCommand3 Variable

Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand3 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


SqlUpdateCommand4 Variable

Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Source code

[Visual Basic]
    Friend WithEvents SqlUpdateCommand4 As System.Data.SqlClient.SqlCommand

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
    Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

xfrmDomainMitarbeiter


Crypto Module

For a list of all members of this type, see Crypto Members.

Module Crypto

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Crypto Members


Crypto Members

Crypto overview

Methods

method DecryptText
method EncryptText

See Also

Crypto Module


Crypto Methods

Crypto overview

Methods

method DecryptText
method EncryptText

See Also

Crypto Module


Crypto.DecryptText Method

Public Function DecryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
)

Parameters

strText
Required.
strPwd
Required.

Source code

[Visual Basic]
    Public Function DecryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String
        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c - Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        DecryptText = strBuff
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Crypto


Crypto.EncryptText Method

Public Function EncryptText( _
   ByVal strText As String, _
   ByVal strPwd As String _
)

Parameters

strText
Required.
strPwd
Required.

Source code

[Visual Basic]
    Public Function EncryptText(ByVal strText As String, ByVal strPwd As String)
        Dim i As Integer, c As Integer
        Dim strBuff As String

        strPwd = UCase$(strPwd)
        If Len(strPwd) Then
            For i = 1 To Len(strText)
                c = Asc(Mid$(strText, i, 1))
                c = c + Asc(Mid$(strPwd, (i Mod Len(strPwd)) + 1, 1))
                strBuff = strBuff & Chr(c And &HFF)
            Next i
        Else
            strBuff = strText
        End If
        EncryptText = strBuff
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Crypto


Globals Module

For a list of all members of this type, see Globals Members.

Module Globals

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Globals Members


Globals Members

Globals overview

Fields

field Apphandle
field AppldataRow
field Applikationsdaten
field Archivfnkt
field Bearbeitung_Problemdokumente
field ColdMeldung
field ConnectionFileName
field CurrentMitarbeiterdata
field DP_Collection
field DivFnkt
field DoLog
field DokAnKundeVersant
field DokAnKundeVersantPruefen
field DokumentColdIndex_ChangedBR
field DokumentID_New_Copy
field DokumentID_New_CopyBR
field DokumentPaket
field DokumentartenImages
field Dokumentcoldindex_Changed
field Dokumentcoldindex_statusbr
field Dokumentidalt
field Dokumentidaltbr
field EDOKAMAIN_Statusbar
field EDOKAMAIN_WindowHeight
field EDOKAMAIN_WindowWidth
field EinzelDokument
field Ersetzte_Dokumente_Reaktivieren
field Force_Exit
field Global_ForceExit
field HTMLHelp
field In_Bearbeitung
field Individuelles_Dokumentpaket
field MandantNr
field MandantText
field Mitarbeiter
field MitarbeiterNr
field MyMsg
field MyTxt
field PerfMon
field Save_Partnersuche
field SelectedDokumentID
field Spalten
field Sprache
field StatusChanges_Dokumentid
field StatusChanges_Status
field TGNummer
field Version
field Versionsdatum
field Vorlagendata
field Vorlagendata_Vollstaendig
field Vorlagenfilter
field WinPos
field Words
field _HashDruckanzeige
field _HashThreads
field bckdokument
field conn
field dokumentcoldindex_status
field dokumentid_changed
field dokumentid_changedbr
field ersetzte_dokumente_reaktivierenbr
field fMehrfachdruck
field g_bRun
field general_ds
field general_dsbr
field hasmessage
field iMerker
field objTreeEntries
field objTreeEntry
field profilnr
field sConnectionString
field show_releasenotes
field stv

See Also

Globals Module


Globals Fields

Globals overview

Fields

field Apphandle
field AppldataRow
field Applikationsdaten
field Archivfnkt
field Bearbeitung_Problemdokumente
field ColdMeldung
field ConnectionFileName
field CurrentMitarbeiterdata
field DP_Collection
field DivFnkt
field DoLog
field DokAnKundeVersant
field DokAnKundeVersantPruefen
field DokumentColdIndex_ChangedBR
field DokumentID_New_Copy
field DokumentID_New_CopyBR
field DokumentPaket
field DokumentartenImages
field Dokumentcoldindex_Changed
field Dokumentcoldindex_statusbr
field Dokumentidalt
field Dokumentidaltbr
field EDOKAMAIN_Statusbar
field EDOKAMAIN_WindowHeight
field EDOKAMAIN_WindowWidth
field EinzelDokument
field Ersetzte_Dokumente_Reaktivieren
field Force_Exit
field Global_ForceExit
field HTMLHelp
field In_Bearbeitung
field Individuelles_Dokumentpaket
field MandantNr
field MandantText
field Mitarbeiter
field MitarbeiterNr
field MyMsg
field MyTxt
field PerfMon
field Save_Partnersuche
field SelectedDokumentID
field Spalten
field Sprache
field StatusChanges_Dokumentid
field StatusChanges_Status
field TGNummer
field Version
field Versionsdatum
field Vorlagendata
field Vorlagendata_Vollstaendig
field Vorlagenfilter
field WinPos
field Words
field _HashDruckanzeige
field _HashThreads
field bckdokument
field conn
field dokumentcoldindex_status
field dokumentid_changed
field dokumentid_changedbr
field ersetzte_dokumente_reaktivierenbr
field fMehrfachdruck
field g_bRun
field general_ds
field general_dsbr
field hasmessage
field iMerker
field objTreeEntries
field objTreeEntry
field profilnr
field sConnectionString
field show_releasenotes
field stv

See Also

Globals Module


Apphandle Variable

Public Apphandle As Int32

Source code

[Visual Basic]
    Public Apphandle As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


AppldataRow Variable

Public AppldataRow As Integer

Source code

[Visual Basic]
    Public AppldataRow As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Applikationsdaten Variable

Public Applikationsdaten As DataTable

Source code

[Visual Basic]
    Public Applikationsdaten As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Archivfnkt Variable

Public Archivfnkt As New EDOKA.clsarchivfnkt()

Source code

[Visual Basic]
    Public Archivfnkt As New EDOKA.clsarchivfnkt()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Bearbeitung_Problemdokumente Variable

Public Bearbeitung_Problemdokumente As Boolean = False

Source code

[Visual Basic]
    Public Bearbeitung_Problemdokumente As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


ColdMeldung Variable

Public ColdMeldung As String

Source code

[Visual Basic]
    Public ColdMeldung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


ConnectionFileName Variable

Public ConnectionFileName As String = ""

Source code

[Visual Basic]
    Public ConnectionFileName As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


CurrentMitarbeiterdata Variable

Public CurrentMitarbeiterdata As New DataTable()

Source code

[Visual Basic]
    Public CurrentMitarbeiterdata As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DP_Collection Variable

Public DP_Collection As New Collection()

Source code

[Visual Basic]
    Public DP_Collection As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DivFnkt Variable

Public DivFnkt As New EDOKA.clsDivFnkt()

Source code

[Visual Basic]
    Public DivFnkt As New EDOKA.clsDivFnkt()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DoLog Variable

Public DoLog As Boolean = False

Source code

[Visual Basic]
    Public DoLog As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokAnKundeVersant Variable

Public DokAnKundeVersant As Boolean = False

Source code

[Visual Basic]
    Public DokAnKundeVersant As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokAnKundeVersantPruefen Variable

Public DokAnKundeVersantPruefen As Boolean = False

Source code

[Visual Basic]
    Public DokAnKundeVersantPruefen As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokumentColdIndex_ChangedBR Variable

Public DokumentColdIndex_ChangedBR As Boolean

Source code

[Visual Basic]
    Public DokumentColdIndex_ChangedBR As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokumentID_New_Copy Variable

Public DokumentID_New_Copy As String

Source code

[Visual Basic]
    Public DokumentID_New_Copy As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokumentID_New_CopyBR Variable

Public DokumentID_New_CopyBR As String

Source code

[Visual Basic]
    Public DokumentID_New_CopyBR As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokumentPaket Variable

Public DokumentPaket As Boolean = False

Source code

[Visual Basic]
    Public DokumentPaket As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


DokumentartenImages Variable

Public DokumentartenImages As New ImageList()

Source code

[Visual Basic]
    Public DokumentartenImages As New ImageList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Dokumentcoldindex_Changed Variable

Public Dokumentcoldindex_Changed As Boolean

Source code

[Visual Basic]
    Public Dokumentcoldindex_Changed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Dokumentcoldindex_statusbr Variable

Public Dokumentcoldindex_statusbr As String

Source code

[Visual Basic]
    Public Dokumentcoldindex_statusbr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Dokumentidalt Variable

Public Dokumentidalt As String

Source code

[Visual Basic]
    Public Dokumentidalt As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Dokumentidaltbr Variable

Public Dokumentidaltbr As String

Source code

[Visual Basic]
    Public Dokumentidaltbr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


EDOKAMAIN_Statusbar Variable

Public EDOKAMAIN_Statusbar As StatusBar

Source code

[Visual Basic]
    Public EDOKAMAIN_Statusbar As StatusBar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


EDOKAMAIN_WindowHeight Variable

Public EDOKAMAIN_WindowHeight As Integer

Source code

[Visual Basic]
    Public EDOKAMAIN_WindowHeight As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


EDOKAMAIN_WindowWidth Variable

Public EDOKAMAIN_WindowWidth As Integer

Source code

[Visual Basic]
    Public EDOKAMAIN_WindowWidth As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


EinzelDokument Variable

Public EinzelDokument As Boolean

Source code

[Visual Basic]
    Public EinzelDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Ersetzte_Dokumente_Reaktivieren Variable

Public Ersetzte_Dokumente_Reaktivieren As Boolean

Source code

[Visual Basic]
    Public Ersetzte_Dokumente_Reaktivieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Force_Exit Variable

Public Force_Exit As Boolean = False

Source code

[Visual Basic]
    Public Force_Exit As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Global_ForceExit Variable

Public Global_ForceExit As Boolean = False

Source code

[Visual Basic]
    Public Global_ForceExit As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


HTMLHelp Variable

Public HTMLHelp As New HHctrlapi()

Source code

[Visual Basic]
    Public HTMLHelp As New HHctrlapi()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


In_Bearbeitung Variable

Public In_Bearbeitung As Boolean = False

Source code

[Visual Basic]
    Public In_Bearbeitung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Individuelles_Dokumentpaket Variable

Public Individuelles_Dokumentpaket As Boolean = False

Source code

[Visual Basic]
    Public Individuelles_Dokumentpaket As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


MandantNr Variable

Public MandantNr As Int32

Source code

[Visual Basic]
    Public MandantNr As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


MandantText Variable

Public MandantText As String

Source code

[Visual Basic]
    Public MandantText As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Mitarbeiter Variable

Public Mitarbeiter As New edokadb.clsMyMitarbeiter()

Source code

[Visual Basic]
    Public Mitarbeiter As New edokadb.clsMyMitarbeiter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


MitarbeiterNr Variable

Public MitarbeiterNr As Long

Source code

[Visual Basic]
    Public MitarbeiterNr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


MyMsg Variable

Public MyMsg As New EDOKA.MyMessage()

Source code

[Visual Basic]
    Public MyMsg As New EDOKA.MyMessage()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


MyTxt Variable

Public MyTxt As New EDOKA.MyText()

Source code

[Visual Basic]
    Public MyTxt As New EDOKA.MyText()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


PerfMon Variable

Public PerfMon As New clsPerformance()

Source code

[Visual Basic]
    Public PerfMon As New clsPerformance()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Save_Partnersuche Variable

Public Save_Partnersuche As New DataTable()

Source code

[Visual Basic]
    Public Save_Partnersuche As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


SelectedDokumentID Variable

Public SelectedDokumentID As String

Source code

[Visual Basic]
    Public SelectedDokumentID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Spalten Variable

Public Spalten As New DataTable()

Source code

[Visual Basic]
    Public Spalten As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Sprache Variable

Public Sprache As Integer

Source code

[Visual Basic]
    Public Sprache As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


StatusChanges_Dokumentid Variable

Public StatusChanges_Dokumentid As String

Source code

[Visual Basic]
    Public StatusChanges_Dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


StatusChanges_Status Variable

Public StatusChanges_Status As String

Source code

[Visual Basic]
    Public StatusChanges_Status As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


TGNummer Variable

Public TGNummer As String

Source code

[Visual Basic]
    Public TGNummer As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Version Variable

Public Version As String = "3.9"

Source code

[Visual Basic]
    Public Version As String = "3.9"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Versionsdatum Variable

Public Versionsdatum As String = "3. November 2006"

Source code

[Visual Basic]
    Public Versionsdatum As String = "3. November 2006"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Vorlagendata Variable

Public Vorlagendata As New DataTable()

Source code

[Visual Basic]
    Public Vorlagendata As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Vorlagendata_Vollstaendig Variable

Public Vorlagendata_Vollstaendig As New DataTable()

Source code

[Visual Basic]
    Public Vorlagendata_Vollstaendig As New DataTable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Vorlagenfilter Variable

Public Vorlagenfilter As Integer = 0

Source code

[Visual Basic]
    Public Vorlagenfilter As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


WinPos Variable

Public WinPos As New WindowPositions()

Source code

[Visual Basic]
    Public WinPos As New WindowPositions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


Words Variable

Public Words As New Collection()

Source code

[Visual Basic]
    Public Words As New Collection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


_HashDruckanzeige Variable

Public _HashDruckanzeige As New Hashtable()

Source code

[Visual Basic]
    Public _HashDruckanzeige As New Hashtable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


_HashThreads Variable

Public _HashThreads As New Hashtable()

Source code

[Visual Basic]
    Public _HashThreads As New Hashtable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


bckdokument Variable

Public bckdokument As Boolean

Source code

[Visual Basic]
    Public bckdokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


conn Variable

Public conn As New edokadb.clsConnectionProvider()

Source code

[Visual Basic]
    Public conn As New edokadb.clsConnectionProvider()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


dokumentcoldindex_status Variable

Public dokumentcoldindex_status As String

Source code

[Visual Basic]
    Public dokumentcoldindex_status As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


dokumentid_changed Variable

Public dokumentid_changed As Boolean

Source code

[Visual Basic]
    Public dokumentid_changed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


dokumentid_changedbr Variable

Public dokumentid_changedbr As Boolean

Source code

[Visual Basic]
    Public dokumentid_changedbr As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


ersetzte_dokumente_reaktivierenbr Variable

Public ersetzte_dokumente_reaktivierenbr As Boolean

Source code

[Visual Basic]
    Public ersetzte_dokumente_reaktivierenbr As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


fMehrfachdruck Variable

Public fMehrfachdruck As frmMehrfachdruck

Source code

[Visual Basic]
    Public fMehrfachdruck As frmMehrfachdruck

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


g_bRun Variable

Public g_bRun As Boolean

Source code

[Visual Basic]
    Public g_bRun As Boolean        'Wird auf true gesetzt, wenn die Applikatin gestartet wird. Verhindert, dass zur Entwicklung der Code durchlaufen wird

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


general_ds Variable

Public general_ds As New DataSet()

Source code

[Visual Basic]
    Public general_ds As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


general_dsbr Variable

Public general_dsbr As New DataSet()

Source code

[Visual Basic]
    Public general_dsbr As New DataSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


hasmessage Variable

Public hasmessage As Integer

Source code

[Visual Basic]
    Public hasmessage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


iMerker Variable

Public iMerker As Integer = 0

Source code

[Visual Basic]
    Public iMerker As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


objTreeEntries Variable

Public objTreeEntries As New edokadb.TreeEntries()

Source code

[Visual Basic]
    Public objTreeEntries As New edokadb.TreeEntries()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


objTreeEntry Variable

Public objTreeEntry As New edokadb.TreeEntry()

Source code

[Visual Basic]
    Public objTreeEntry As New edokadb.TreeEntry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


profilnr Variable

Public profilnr As Integer

Source code

[Visual Basic]
    Public profilnr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


sConnectionString Variable

Public sConnectionString As String

Source code

[Visual Basic]
    Public sConnectionString As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


show_releasenotes Variable

Public show_releasenotes As Boolean = False

Source code

[Visual Basic]
    Public show_releasenotes As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


stv Variable

Public stv As Integer

Source code

[Visual Basic]
    Public stv As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Globals


mMain Module

For a list of all members of this type, see mMain Members.

Module mMain

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

mMain Members


mMain Members

mMain overview

Methods

method Main

Classes

class SerialHelper
class SingleInstance

Fields

field MainForm

See Also

mMain Module


SerialHelper Class

For a list of all members of this type, see SerialHelper Members.

System.Object
EDOKAApp.mMain.SerialHelper

Public Class SerialHelper

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

SerialHelper Members | mMain


SerialHelper Members

SerialHelper overview

Methods

method DeserializeFromBase64String
method SerializeToBase64String

See Also

SerialHelper Class


SerialHelper Methods

SerialHelper overview

Methods

method DeserializeFromBase64String
method SerializeToBase64String

See Also

SerialHelper Class


SerialHelper.DeserializeFromBase64String Method

Public Shared Function DeserializeFromBase64String( _
   ByVal base64String As String _
) As Object

Parameters

base64String
Required.

Source code

[Visual Basic]
        Public Shared Function DeserializeFromBase64String(ByVal base64String As String) As Object
            Dim formatter As New BinaryFormatter()
            base64String = base64String.Trim(ControlChars.NullChar)
            Dim bytes() As Byte = Convert.FromBase64String(base64String)
            Dim serialMemoryStream As New MemoryStream(bytes)
            Return formatter.Deserialize(serialMemoryStream)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SerialHelper


SerialHelper.SerializeToBase64String Method

Public Shared Function SerializeToBase64String( _
   ByVal o As Object _
) As String

Parameters

o
Required.

Source code

[Visual Basic]
        Public Shared Function SerializeToBase64String(ByVal o As Object) As String
            Dim formatter As New BinaryFormatter()
            Dim serialMemoryStream As New MemoryStream()
            formatter.Serialize(serialMemoryStream, o)
            Dim bytes() As Byte = serialMemoryStream.ToArray()
            Return Convert.ToBase64String(bytes).Trim()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SerialHelper


SingleInstance Class

For a list of all members of this type, see SingleInstance Members.

System.Object
EDOKAApp.mMain.SingleInstance

Public Class SingleInstance

Requirements

Namespace: EDOKAApp

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

SingleInstance Members | mMain


SingleInstance Members

SingleInstance overview

Constructors

constructor SingleInstance Constructor

Properties

property IsFirstInstance

Methods

method EWP
method EnumWindows
method FindWindow
method GetProp
method IsThisApp
method MainForm_WndProc
method NotifyPreviousWindow (Overloaded)
method OnExit
method SendCDSToWindow
method SendMessage
method SendMessageToWindow (Overloaded)
method SetMainForm
method SetProp

Fields

field MainForm
field _EWP
field _MutexOwned
field _hWnd
field _mcThisAppID
field oMutex

See Also

SingleInstance Class


SingleInstance Constructor

Shared Sub New()

Source code

[Visual Basic]
        Shared Sub New()
            _mcThisAppID = Reflection.Assembly.GetExecutingAssembly().FullName
            oMutex = New Threading.Mutex(True, _mcThisAppID & "_APPLICATION_MUTEX", _MutexOwned)
            If Not _MutexOwned Then
                If Not FindWindow() Then
                    _MutexOwned = True
                End If
            End If
            AddHandler AppDomain.CurrentDomain.ProcessExit, AddressOf OnExit
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance Properties

SingleInstance overview

Properties

property IsFirstInstance

See Also

SingleInstance Class


SingleInstance.IsFirstInstance Property

Public Shared ReadOnly Property IsFirstInstance() As Boolean

Source code

[Visual Basic]
        Public Shared ReadOnly Property IsFirstInstance() As Boolean
            Get
                Return _MutexOwned
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance Methods

SingleInstance overview

Methods

method EWP
method EnumWindows
method FindWindow
method GetProp
method IsThisApp
method MainForm_WndProc
method NotifyPreviousWindow (Overloaded)
method OnExit
method SendCDSToWindow
method SendMessage
method SendMessageToWindow (Overloaded)
method SetMainForm
method SetProp

See Also

SingleInstance Class


SingleInstance.EWP Method

Private Shared Function EWP( _
   ByVal hWnd As Integer, _
   ByVal lParam As Integer _
) As Integer

Parameters

hWnd
Required.
lParam
Required.

Source code

[Visual Basic]
        Private Shared Function EWP(ByVal hWnd As Integer, ByVal lParam As Integer) As Integer
            ' Customised windows enumeration procedure.  Stops
            ' when it finds another application with the Window
            ' property set, or when all windows are exhausted.
            Try
                If IsThisApp(hWnd) Then
                    _hWnd = hWnd
                    Return 0
                Else
                    Return 1
                End If
            Catch
                Return 0
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.EnumWindows Method

Private Declare Function EnumWindows Lib "user32" ( _
   ByVal lpEnumFunc As EnumWindowsProc, _
   ByVal lParam As Integer _
) As Integer

Parameters

lpEnumFunc
Required.
lParam
Required.

Source code

[Visual Basic]
        Private Declare Function EnumWindows Lib "user32" (ByVal lpEnumFunc As EnumWindowsProc, ByVal lParam As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.FindWindow Method

Private Shared Function FindWindow() As Boolean

Source code

[Visual Basic]
        Private Shared Function FindWindow() As Boolean
            If _hWnd = -1 Then
                EnumWindows(_EWP, 0)
                If _hWnd = -1 Then
                    Return False
                Else
                    Return True
                End If
            Else
                Return True
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.GetProp Method

Private Declare Auto Function GetProp Lib "user32" ( _
   ByVal hWnd As Integer, _
   ByVal lpString As String _
) As Integer

Parameters

hWnd
Required.
lpString
Required.

Source code

[Visual Basic]
        Private Declare Auto Function GetProp Lib "user32" (ByVal hWnd As Integer, ByVal lpString As String) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.IsThisApp Method

Private Shared Function IsThisApp( _
   ByVal hWnd As Long _
) As Boolean

Parameters

hWnd
Required.

Source code

[Visual Basic]
        Private Shared Function IsThisApp(ByVal hWnd As Long) As Boolean
            ' Check if the windows property is set for this
            ' window handle:
            If GetProp(hWnd, _mcThisAppID & "_APPLICATION") = 1 Then
                Return True
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.MainForm_WndProc Method

Private Shared Sub MainForm_WndProc( _
   ByVal m As System.Windows.Forms.Message, _
   ByRef Cancel As Boolean _
) Handles MainForm.WndProc

Parameters

m
Required.
Cancel
Required.

Source code

[Visual Basic]
        Private Shared Sub MainForm_WndProc(ByVal m As System.Windows.Forms.Message, ByRef Cancel As Boolean) Handles MainForm.WndProc
            Select Case m.Msg
                Case WM_COPYDATA
                    Dim B() As Byte
                    Try
                        Dim CD As COPYDATASTRUCT = m.GetLParam(GetType(COPYDATASTRUCT))
                        ReDim B(CD.cbData)
                        Dim lpData As IntPtr = New IntPtr(CD.lpData)
                        Marshal.Copy(lpData, B, 0, CD.cbData)
                        Dim strData As String = Encoding.Default.GetString(B)
                        MainForm.HandleCommand(strData)
                        Cancel = True
                    Catch
                        Cancel = False
                    Finally
                        Erase B
                    End Try

                Case Else
                    Cancel = False
            End Select
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


NotifyPreviousWindow Method

Overload List

[Visual Basic] Public Shared Function NotifyPreviousWindow() As Boolean

[Visual Basic] Public Shared Function NotifyPreviousWindow(ByVal oCmd As Object) As Boolean

[Visual Basic] Public Shared Function NotifyPreviousWindow(ByVal strText As String) As Boolean

See Also

SingleInstance | EDOKAApp


SingleInstance.OnExit Method

Private Shared Sub OnExit( _
   ByVal sender As Object, _
   ByVal e As EventArgs _
)

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Shared Sub OnExit(ByVal sender As Object, ByVal e As EventArgs)
            Try
                If Not oMutex Is Nothing Then
                    oMutex.ReleaseMutex()
                    CType(oMutex, IDisposable).Dispose()
                    oMutex = Nothing
                End If
            Catch
                'Do Nothing
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.SendCDSToWindow Method

Private Shared Function SendCDSToWindow( _
   ByVal CD As COPYDATASTRUCT _
) As Boolean

Parameters

CD
Required.

Source code

[Visual Basic]
        Private Shared Function SendCDSToWindow(ByVal CD As COPYDATASTRUCT) As Boolean
            Try
                Dim lpCD As IntPtr = Marshal.AllocHGlobal(Len(CD))
                Marshal.StructureToPtr(CD, lpCD, False)
                SendMessage(_hWnd, WM_COPYDATA, _hWnd, lpCD)
                Marshal.FreeHGlobal(lpCD)

                Return True
            Catch
                Return False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.SendMessage Method

Private Declare Auto Function SendMessage Lib "user32" ( _
   ByVal hWnd As Integer, _
   ByVal wMsg As Integer, _
   ByVal wParam As Integer, _
   ByVal lParam As IntPtr _
) As Integer

Parameters

hWnd
Required.
wMsg
Required.
wParam
Required.
lParam
Required.

Source code

[Visual Basic]
        Private Declare Auto Function SendMessage Lib "user32" (ByVal hWnd As Integer, ByVal wMsg As Integer, ByVal wParam As Integer, ByVal lParam As IntPtr) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SendMessageToWindow Method

Overload List

[Visual Basic] Private Shared Function SendMessageToWindow(ByVal oCmd As Object) As Boolean

[Visual Basic] Private Shared Function SendMessageToWindow(ByVal strCmd As String) As Boolean

See Also

SingleInstance | EDOKAApp


SingleInstance.SetMainForm Method

Public Shared Sub SetMainForm( _
   ByVal frm As ISingleInstanceForm _
)

Parameters

frm
Required.

Source code

[Visual Basic]
        Public Shared Sub SetMainForm(ByVal frm As ISingleInstanceForm)
            MainForm = frm
            Try
                Dim hWnd As Integer = frm.Handle.ToInt32
                SetProp(hWnd, _mcThisAppID & "_APPLICATION", 1)
            Catch
                MainForm = Nothing
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.SetProp Method

Private Declare Auto Function SetProp Lib "user32" ( _
   ByVal hWnd As Integer, _
   ByVal lpString As String, _
   ByVal hData As Integer _
) As Integer

Parameters

hWnd
Required.
lpString
Required.
hData
Required.

Source code

[Visual Basic]
        Private Declare Auto Function SetProp Lib "user32" (ByVal hWnd As Integer, ByVal lpString As String, ByVal hData As Integer) As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance Fields

SingleInstance overview

Fields

field MainForm
field _EWP
field _MutexOwned
field _hWnd
field _mcThisAppID
field oMutex

See Also

SingleInstance Class


MainForm Variable

Private Shared WithEvents MainForm As ISingleInstanceForm

Source code

[Visual Basic]
        Private Shared WithEvents MainForm As ISingleInstanceForm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


_EWP Variable

Private Shared _EWP As New EnumWindowsProc( _
   AddressOf EWP _
)

Source code

[Visual Basic]
        Private Shared _EWP As New EnumWindowsProc(AddressOf EWP)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


_MutexOwned Variable

Private Shared _MutexOwned As Boolean = False

Source code

[Visual Basic]
        Private Shared _MutexOwned As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


_hWnd Variable

Private Shared _hWnd As Integer = -1

Source code

[Visual Basic]
        Private Shared _hWnd As Integer = -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


_mcThisAppID Variable

Private Shared _mcThisAppID As String

Source code

[Visual Basic]
        Private Shared _mcThisAppID As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


oMutex Variable

Private Shared oMutex As Threading.Mutex

Source code

[Visual Basic]
        Private Shared oMutex As Threading.Mutex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


mMain Methods

mMain overview

Methods

method Main

See Also

mMain Module


mMain.Main Method

<STAThread()> _
Public Function Main( _
   ByVal CmdArgs() As String _
) As Integer

Parameters

CmdArgs
Required.

Source code

[Visual Basic]
    <STAThread()> Public Function Main(ByVal CmdArgs() As String) As Integer
        If SingleInstance.IsFirstInstance Then
            Try
                'No previous instance
                g_bRun = True
                MainForm = New EDOKAMain()
                SingleInstance.SetMainForm(MainForm)
                MainForm.HandleCommand(CmdArgs)
            Catch ex As Exception
                MsgBox(ex.Message)
            End Try
            Try
                g_bRun = True
                Application.Run(MainForm)
            Catch ex As Exception
                If Not Force_Exit Then
                    MsgBox(ex.Message)
                End If
            End Try
        Else
            g_bRun = True
            SingleInstance.NotifyPreviousWindow(CmdArgs)
        End If

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

mMain


mMain Fields

mMain overview

Fields

field MainForm

See Also

mMain Module


MainForm Variable

Private MainForm As EDOKAMain

Source code

[Visual Basic]
    Private MainForm As EDOKAMain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

mMain


EDOKAApp.EDOKA Namespace

Namespace EDOKA

Classes

class DB_Connection
class MyMessage
class MySpaltenTitel
class MyText
class Tabellenspalte
class clsDivFnkt
class clsarchivfnkt
class frmRelEditor


EDOKAApp.EDOKA Members

EDOKAApp.EDOKA overview

Classes

class DB_Connection
class MyMessage
class MySpaltenTitel
class MyText
class Tabellenspalte
class clsDivFnkt
class clsarchivfnkt
class frmRelEditor

See Also

EDOKAApp.EDOKA Namespace


DB_Connection Class

For a list of all members of this type, see DB_Connection Members.

System.Object
EDOKAApp.EDOKA.DB_Connection

Public Class DB_Connection

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

DB_Connection Members


DB_Connection Members

DB_Connection overview

Constructors

constructor DB_Connection Constructor

See Also

DB_Connection Class


DB_Connection Constructor

Shared Sub New()

Source code

[Visual Basic]
        Shared Sub New()
            Dim fc As Integer = 0
            If Globals.ConnectionFileName.Length = 0 Then
                Dim Dir As DirectoryInfo = New DirectoryInfo(Application.StartupPath)
                Try
                    Dim f As New frmDatenbankauswahl()
                    Dim ChildFile As FileInfo
                    For Each ChildFile In Dir.GetFiles()
                        If UCase(Left(ChildFile.Name, 5)) = "EDOKA" And UCase(ChildFile.Extension) = ".CFG" Then
                            f.ListBox1.Items.Add(ChildFile.Name)
                            fc = fc + 1
                        End If
                    Next
                    If fc > 1 Then
                        f.ListBox1.SelectedIndex = 0
                        f.ListBox1.Select()
                        f.ShowDialog()
                        Globals.ConnectionFileName = f.ListBox1.SelectedItem
                        f.Dispose()
                    End If
                Catch except As Exception
                    fc = 0
                    Exit Sub
                End Try
            End If
            If fc < 2 Then Globals.ConnectionFileName = "edokaconn.cfg"
            Dim ofile As System.IO.File
            Dim oread As System.IO.StreamReader
            oread = ofile.OpenText(Application.StartupPath + "\" + Globals.ConnectionFileName)
            sConnectionString = oread.ReadLine
            sConnectionString = Crypto.DecryptText(sConnectionString, "HutterundMueller")
            sConnectionString = Left(sConnectionString, Len(sConnectionString) - 1)
            Globals.sConnectionString = sConnectionString
            oread.Close()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DB_Connection


MyMessage Class

For a list of all members of this type, see MyMessage Members.

System.Object
EDOKAApp.EDOKA.MyMessage
EDOKAApp.EDOKA.MyText

Public Class MyMessage

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

MyMessage Members


MyMessage Members

MyMessage overview

Constructors

constructor MyMessage Constructor

Methods

method Get_Meldungstext |
method ReplaceTextinMSG | Ersetzt in einem String die #1 und #2 durch Text1 und Text 2
method ShowMessage |
method Show_HinweisMessage (Overloaded) |
method Show_MessageYesNo |
method Show_MessageYesNoBL |
method Show_MessageYesNoCancel |
method parstext |
method show_MessageYesNo_ReplaceText |
method show_bcmessage |
method show_standardmessage |
method show_standardmessage_ReplaceText |

Fields

field meldungstexte

See Also

MyMessage Class


MyMessage Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage Methods

MyMessage overview

Methods

method Get_Meldungstext |
method ReplaceTextinMSG | Ersetzt in einem String die #1 und #2 durch Text1 und Text 2
method ShowMessage |
method Show_HinweisMessage (Overloaded) |
method Show_MessageYesNo |
method Show_MessageYesNoBL |
method Show_MessageYesNoCancel |
method parstext |
method show_MessageYesNo_ReplaceText |
method show_bcmessage |
method show_standardmessage |
method show_standardmessage_ReplaceText |

See Also

MyMessage Class


MyMessage.Get_Meldungstext Method

Public Function Get_Meldungstext( _
   ByVal i As Integer _
) As String

Parameters

i
Required.

Source code

[Visual Basic]
        Public Function Get_Meldungstext(ByVal i As Integer) As String
            Dim meldungen As New edokadb.clsMeldungstexte()
            Dim res As Integer
            meldungen.cpMainConnectionProvider = conn
            If Me.meldungstexte.Count = 0 Then
                Me.meldungstexte.Table = meldungen.SelectAll
            End If
            meldungstexte.Sort = "meldungstextnr"
            res = meldungstexte.Find(i)
            Try
                Get_Meldungstext = Me.meldungstexte(res).Item(2)
            Catch
                Get_Meldungstext = ""
            End Try
            meldungen.Dispose()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.ReplaceTextinMSG Method

Ersetzt in einem String die #1 und #2 durch Text1 und Text 2

Public Function ReplaceTextinMSG( _
   ByVal OrgText As String, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As String

Parameters

OrgText
Required.
Text1
Required.
Text2
Required.

Author

Daniel Burren

Version

Release 3.6

Source code

[Visual Basic]
        Public Function ReplaceTextinMSG(ByVal OrgText As String, ByVal Text1 As String, ByVal Text2 As String) As String
            OrgText = OrgText.Replace("#1", Text1)
            OrgText = OrgText.Replace("#2", Text2)
            ReplaceTextinMSG = OrgText
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.ShowMessage Method

Private Function ShowMessage( _
   ByVal profilnr As Integer, _
   ByVal messagenr As Integer, _
   ByVal fnkt As Integer, _
   ByVal style As Integer _
) As Boolean

Parameters

profilnr
Required.
messagenr
Required.
fnkt
Required.
style
Required.

Source code

[Visual Basic]
        Private Function ShowMessage(ByVal profilnr As Integer, ByVal messagenr As Integer, ByVal fnkt As Integer, ByVal style As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_show_hinweismeldung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, profilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@hinweisnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, messagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@showit", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters.Item("@showit").Value
                If i <> 0 Then
                    ShowMessage = True
                Else
                    ShowMessage = False
                End If
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


Show_HinweisMessage Method

Overload List

[Visual Basic] Public Function Show_HinweisMessage(ByVal profilnr As Integer, ByVal messagenr As Integer, ByVal MeldungsNummer As Integer, ByVal style As Integer) As Boolean

[Visual Basic] Public Function Show_HinweisMessage(ByVal profilnr As Integer, ByVal messagenr As Integer, ByVal MeldungsNummer As Integer, ByVal style As Integer, ByVal formOnTop As Boolean) As Boolean

See Also

MyMessage | EDOKA


MyMessage.Show_MessageYesNo Method

Public Function Show_MessageYesNo( _
   ByVal i As Integer _
) As MsgBoxResult

Parameters

i
Required.

Source code

[Visual Basic]
        Public Function Show_MessageYesNo(ByVal i As Integer) As MsgBoxResult
            Show_MessageYesNo = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.Show_MessageYesNoBL Method

Public Function Show_MessageYesNoBL( _
   ByVal i As Integer _
) As MsgBoxResult

Parameters

i
Required.

Source code

[Visual Basic]
        Public Function Show_MessageYesNoBL(ByVal i As Integer) As MsgBoxResult
            Show_MessageYesNoBL = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNo + MsgBoxStyle.Question, "Banklagerndes Dokument")
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.Show_MessageYesNoCancel Method

Public Function Show_MessageYesNoCancel( _
   ByVal i As Integer _
) As MsgBoxResult

Parameters

i
Required.

Source code

[Visual Basic]
        Public Function Show_MessageYesNoCancel(ByVal i As Integer) As MsgBoxResult
            Show_MessageYesNoCancel = MsgBox(Get_Meldungstext(i), MsgBoxStyle.YesNoCancel + MsgBoxStyle.Question)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.parstext Method

Public Function parstext( _
   ByVal s As String, _
   ByVal dokumentid As String _
) As String

Parameters

s
Required.
dokumentid
Required.

Source code

[Visual Basic]
        Public Function parstext(ByVal s As String, ByVal dokumentid As String) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_get_archivinfo"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                sdaAdapter.Fill(dtToReturn)
                s = s.Replace("&Archiv&", dtToReturn.Rows(0).Item("Archiv"))
                s = s.Replace("&ArchivKZ&", dtToReturn.Rows(0).Item("ArchivKZ"))
                Return s
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.show_MessageYesNo_ReplaceText Method

Public Function show_MessageYesNo_ReplaceText( _
   ByVal i As Integer, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As MsgBoxResult

Parameters

i
Required.
Text1
Required.
Text2
Required.

Source code

[Visual Basic]
        Public Function show_MessageYesNo_ReplaceText(ByVal i As Integer, ByVal Text1 As String, ByVal Text2 As String) As MsgBoxResult
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            show_MessageYesNo_ReplaceText = MsgBox(s, MsgBoxStyle.YesNo + MsgBoxStyle.Question)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.show_bcmessage Method

Public Function show_bcmessage( _
   ByVal dokumentid As String _
)

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Public Function show_bcmessage(ByVal dokumentid As String)
            Dim s As String
            s = Get_Meldungstext(88)
            s = parstext(s, dokumentid)
            MsgBox(s, MsgBoxStyle.Information)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.show_standardmessage Method

Public Function show_standardmessage( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle _
) As Integer

Parameters

i
Required.
typ
Required.

Source code

[Visual Basic]
        Public Function show_standardmessage(ByVal i As Integer, ByVal typ As MsgBoxStyle) As Integer
            MsgBox(Get_Meldungstext(i), typ)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.show_standardmessage_ReplaceText Method

Public Function show_standardmessage_ReplaceText( _
   ByVal i As Integer, _
   ByVal typ As MsgBoxStyle, _
   ByVal Text1 As String, _
   ByVal Text2 As String _
) As Integer

Parameters

i
Required.
typ
Required.
Text1
Required.
Text2
Required.

Source code

[Visual Basic]
        Public Function show_standardmessage_ReplaceText(ByVal i As Integer, ByVal typ As MsgBoxStyle, ByVal Text1 As String, ByVal Text2 As String) As Integer
            Dim s As String
            s = Get_Meldungstext(i)
            s = s.Replace("#1", Text1)
            s = s.Replace("#2", Text2)
            MsgBox(s, typ)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage Fields

MyMessage overview

Fields

field meldungstexte

See Also

MyMessage Class


meldungstexte Variable

Private meldungstexte As New DataView()

Source code

[Visual Basic]
        Private meldungstexte As New DataView()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MySpaltenTitel Class

For a list of all members of this type, see MySpaltenTitel Members.

System.Object
EDOKAApp.EDOKA.MySpaltenTitel

Public Class MySpaltenTitel

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

MySpaltenTitel Members


MySpaltenTitel Members

MySpaltenTitel overview

Methods

method getColWidth
method getOrder
method gethacken
method getlock
method getspalte
method gettiptext
method load_data

See Also

MySpaltenTitel Class


MySpaltenTitel Methods

MySpaltenTitel overview

Methods

method getColWidth
method getOrder
method gethacken
method getlock
method getspalte
method gettiptext
method load_data

See Also

MySpaltenTitel Class


MySpaltenTitel.getColWidth Method

Public Function getColWidth( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As Integer

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function getColWidth(ByVal tabelle As String, ByVal feld As String) As Integer
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    getColWidth = Globals.Spalten.Rows(i).Item(6)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.getOrder Method

Public Function getOrder( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As Integer

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function getOrder(ByVal tabelle As String, ByVal feld As String) As Integer
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    getOrder = Globals.Spalten.Rows(i).Item(7)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.gethacken Method

Public Function gethacken( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As Integer

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function gethacken(ByVal tabelle As String, ByVal feld As String) As Integer
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    gethacken = Globals.Spalten.Rows(i).Item(5)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.getlock Method

Public Function getlock( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As Boolean

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function getlock(ByVal tabelle As String, ByVal feld As String) As Boolean
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    getlock = Globals.Spalten.Rows(i).Item(4)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.getspalte Method

Public Function getspalte( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As String

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function getspalte(ByVal tabelle As String, ByVal feld As String) As String
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    getspalte = Globals.Spalten.Rows(i).Item(3)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.gettiptext Method

Public Function gettiptext( _
   ByVal tabelle As String, _
   ByVal feld As String _
) As String

Parameters

tabelle
Required.
feld
Required.

Source code

[Visual Basic]
        Public Function gettiptext(ByVal tabelle As String, ByVal feld As String) As String
            Dim i As Integer
            If Globals.Spalten.Rows.Count = 0 Then load_data()
            For i = 0 To Globals.Spalten.Rows.Count - 1
                If Globals.Spalten.Rows(i).Item(1) = tabelle And Globals.Spalten.Rows(i).Item(2) = feld Then
                    gettiptext = Globals.Spalten.Rows(i).Item(8)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MySpaltenTitel.load_data Method

Public Sub load_data()

Source code

[Visual Basic]
        Public Sub load_data()
            Dim spalten As New edokadb.clsSpalten()
            Globals.Spalten.Rows.Clear()
            spalten.cpMainConnectionProvider = conn
            Globals.Spalten = spalten.SelectAll
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MySpaltenTitel


MyText Class

For a list of all members of this type, see MyText Members.

System.Object
EDOKAApp.EDOKA.MyMessage
EDOKAApp.EDOKA.MyText

Public Class MyText
   Inherits EDOKA.MyMessage

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

MyText Members


MyText Members

MyText overview

Constructors

constructor MyText Constructor (inherited from EDOKAApp.EDOKA.MyMessage)

Methods

method Get_Meldungstext (inherited from EDOKAApp.EDOKA.MyMessage) |
method ReplaceTextinMSG (inherited from EDOKAApp.EDOKA.MyMessage) | Ersetzt in einem String die #1 und #2 durch Text1 und Text 2
method Show_HinweisMessage (Overloaded) (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNo (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNoBL (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNoCancel (inherited from EDOKAApp.EDOKA.MyMessage) |
method gettext |
method parstext (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_MessageYesNo_ReplaceText (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_bcmessage (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_standardmessage (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_standardmessage_ReplaceText (inherited from EDOKAApp.EDOKA.MyMessage) |

See Also

MyText Class


MyText Methods

MyText overview

Methods

method Get_Meldungstext (inherited from EDOKAApp.EDOKA.MyMessage) |
method ReplaceTextinMSG (inherited from EDOKAApp.EDOKA.MyMessage) | Ersetzt in einem String die #1 und #2 durch Text1 und Text 2
method Show_HinweisMessage (Overloaded) (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNo (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNoBL (inherited from EDOKAApp.EDOKA.MyMessage) |
method Show_MessageYesNoCancel (inherited from EDOKAApp.EDOKA.MyMessage) |
method gettext |
method parstext (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_MessageYesNo_ReplaceText (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_bcmessage (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_standardmessage (inherited from EDOKAApp.EDOKA.MyMessage) |
method show_standardmessage_ReplaceText (inherited from EDOKAApp.EDOKA.MyMessage) |

See Also

MyText Class


MyText.gettext Method

Public Function gettext( _
   ByVal wert As Integer _
) As String

Parameters

wert
Required.

Source code

[Visual Basic]
        Public Function gettext(ByVal wert As Integer) As String
            gettext = Me.Get_Meldungstext(wert)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyText


Tabellenspalte Class

For a list of all members of this type, see Tabellenspalte Members.

System.Object
EDOKAApp.EDOKA.Tabellenspalte

Public Class Tabellenspalte

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

Tabellenspalte Members


Tabellenspalte Members

Tabellenspalte overview

Properties

property AlsHacken
property ColWith
property Feld
property Order
property Tabelle
property TipText
property locked
property spaltenname

Methods

method getspalte

Fields

field m_Order
field m_Width
field m_alsHacken
field m_field
field m_locked
field m_spaltenname
field m_table
field m_tiptext

See Also

Tabellenspalte Class


Tabellenspalte Properties

Tabellenspalte overview

Properties

property AlsHacken
property ColWith
property Feld
property Order
property Tabelle
property TipText
property locked
property spaltenname

See Also

Tabellenspalte Class


Tabellenspalte.AlsHacken Property

Property AlsHacken() As Boolean

Source code

[Visual Basic]
        Property AlsHacken() As Boolean
            Get
                Return m_alsHacken
            End Get
            Set(ByVal Value As Boolean)
                m_alsHacken = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.ColWith Property

Property ColWith() As Integer

Source code

[Visual Basic]
        Property ColWith() As Integer
            Get
                Return m_Width
            End Get
            Set(ByVal Value As Integer)
                m_Width = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.Feld Property

Property Feld() As String

Source code

[Visual Basic]
        Property Feld() As String
            Get
                Return m_field
            End Get
            Set(ByVal Value As String)
                m_field = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.Order Property

Property Order() As Integer

Source code

[Visual Basic]
        Property Order() As Integer
            Get
                Return m_Order
            End Get
            Set(ByVal Value As Integer)
                m_Order = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.Tabelle Property

Property Tabelle() As String

Source code

[Visual Basic]
        Property Tabelle() As String
            Get
                Return m_table
            End Get
            Set(ByVal Value As String)
                m_table = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.TipText Property

Property TipText() As String

Source code

[Visual Basic]
        Property TipText() As String
            Get
                Return m_tiptext
            End Get
            Set(ByVal Value As String)
                m_tiptext = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.locked Property

Property locked() As Boolean

Source code

[Visual Basic]
        Property locked() As Boolean
            Get
                Return m_locked
            End Get
            Set(ByVal Value As Boolean)
                m_locked = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte.spaltenname Property

Property spaltenname() As String

Source code

[Visual Basic]
        Property spaltenname() As String
            Get
                Return m_spaltenname
            End Get
            Set(ByVal Value As String)
                m_spaltenname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte Methods

Tabellenspalte overview

Methods

method getspalte

See Also

Tabellenspalte Class


Tabellenspalte.getspalte Method

Public Function getspalte()

Source code

[Visual Basic]
        Public Function getspalte()
            Try
                Dim myspalten As New MySpaltenTitel()
                Me.spaltenname = myspalten.getspalte(Me.Tabelle, Me.Feld)
                Me.locked = myspalten.getlock(Me.Tabelle, Me.Feld)
                Me.ColWith = myspalten.getColWidth(Me.Tabelle, Me.Feld)
                Me.Order = myspalten.getOrder(Me.Tabelle, Me.Feld)
                Me.AlsHacken = myspalten.gethacken(Me.Tabelle, Me.Feld)
                Me.TipText = myspalten.gettiptext(Me.Tabelle, Me.Feld)
            Catch
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


Tabellenspalte Fields

Tabellenspalte overview

Fields

field m_Order
field m_Width
field m_alsHacken
field m_field
field m_locked
field m_spaltenname
field m_table
field m_tiptext

See Also

Tabellenspalte Class


m_Order Variable

Private m_Order As Integer

Source code

[Visual Basic]
        Private m_Order As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_Width Variable

Private m_Width As Integer

Source code

[Visual Basic]
        Private m_Width As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_alsHacken Variable

Private m_alsHacken As Boolean

Source code

[Visual Basic]
        Private m_alsHacken As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_field Variable

Private m_field As String

Source code

[Visual Basic]
        Private m_field As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_locked Variable

Private m_locked As Boolean

Source code

[Visual Basic]
        Private m_locked As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_spaltenname Variable

Private m_spaltenname As String

Source code

[Visual Basic]
        Private m_spaltenname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_table Variable

Private m_table As String

Source code

[Visual Basic]
        Private m_table As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


m_tiptext Variable

Private m_tiptext As String

Source code

[Visual Basic]
        Private m_tiptext As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Tabellenspalte


clsDivFnkt Class

For a list of all members of this type, see clsDivFnkt Members.

System.Object
EDOKAApp.EDOKA.clsDivFnkt

Public Class clsDivFnkt

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDivFnkt Members


clsDivFnkt Members

clsDivFnkt overview

Properties

property Auftragnr
property Belegart
property Erstellungsdatum
property FoundNode
property UVMZVDokumenttyp
property found

Methods

method BDR_Dokument
method BarcodeEtiketten_Berechtigt
method Berechtigt_als_stv
method Berechtigte_Funktionen
method Berechtigte_Mitarbeiter
method Bezeichnung_Feldwert
method Check_Dir
method Check_Fieldvalue
method Check_MessageTimer
method Check_Sysadmin_Stellvertreter
method Create_Folder
method Create_Folders
method Delete_Directory
method EDOKA_Partner_Berechtigt
method EDOKA_Partner_Dokument
method ExtractFilename
method Feldwert_Aufbereitung
method FolderExist
method Generate_Berechtigungen
method Generate_Key
method Gesperrte_Dokumente_Loeschen
method Get_Filename
method GrdAlign
method Ist_Berechtigt
method Journal_Dokumentzugriff
method MA_Is_Sysadmin
method Open_Directory
method Pruefziffer
method Searchnode
method Searchnode1
method Searchnode2
method Searchnode3
method ShowColdDoc
method ShowColdDocHost
method ShowDoc
method SpaltenTitel_Aktualisieren
method Status_Dokumentbearbeitung
method TraceLog
method TranverseNodes
method TranverseNodes1
method TranverseNodes2
method TranverseNodes3
method check_doc2
method check_partnerzusammenlegung
method get_colddokumentid
method get_parnter_anrede
method get_parnter_namevorname
method isbck
method leererstellung
method print_office
method printcolddoc
method printcolddocHost
method show_office
method show_officevorlage

Fields

field m_auftragnr
field m_belegart
field m_erstellungsdatum
field m_found
field m_tn
field m_uvmzvdokumenttyp
field x

See Also

clsDivFnkt Class


clsDivFnkt Properties

clsDivFnkt overview

Properties

property Auftragnr
property Belegart
property Erstellungsdatum
property FoundNode
property UVMZVDokumenttyp
property found

See Also

clsDivFnkt Class


clsDivFnkt.Auftragnr Property

Property Auftragnr() As String

Source code

[Visual Basic]
        Property Auftragnr() As String
            Get
                Return m_auftragnr
            End Get
            Set(ByVal Value As String)
                m_auftragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Belegart Property

Property Belegart() As String

Source code

[Visual Basic]
        Property Belegart() As String
            Get
                Return m_belegart
            End Get
            Set(ByVal Value As String)
                m_belegart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Erstellungsdatum Property

Property Erstellungsdatum() As String

Source code

[Visual Basic]
        Property Erstellungsdatum() As String
            Get
                Return m_erstellungsdatum
            End Get
            Set(ByVal Value As String)
                If Value = "" Then
                    m_erstellungsdatum = ""
                Else
                    If Mid(Value, 3, 1) = "." Then
                        m_erstellungsdatum = Value
                    Else
                        Dim dd As String
                        Dim mm As String
                        Dim yy As String
                        dd = Right(Value, 2)
                        mm = Mid(Value, 5, 2)
                        yy = Mid(Value, 3, 2)
                        If Len(dd) < 2 Then dd = "0" + dd
                        If Len(mm) < 2 Then mm = "0" + mm
                        m_erstellungsdatum = dd + "." + mm + "." + yy
                    End If
                End If
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.FoundNode Property

Property FoundNode() As TreeNode

Source code

[Visual Basic]
        Property FoundNode() As TreeNode
            Get
                Return m_tn
            End Get
            Set(ByVal Value As TreeNode)
                m_tn = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.UVMZVDokumenttyp Property

Property UVMZVDokumenttyp() As String

Source code

[Visual Basic]
        Property UVMZVDokumenttyp() As String
            Get
                Return m_uvmzvdokumenttyp
            End Get
            Set(ByVal Value As String)
                m_uvmzvdokumenttyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.found Property

Property found() As Boolean

Source code

[Visual Basic]
        Property found() As Boolean
            Get
                Return m_found
            End Get
            Set(ByVal Value As Boolean)
                m_found = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt Methods

clsDivFnkt overview

Methods

method BDR_Dokument
method BarcodeEtiketten_Berechtigt
method Berechtigt_als_stv
method Berechtigte_Funktionen
method Berechtigte_Mitarbeiter
method Bezeichnung_Feldwert
method Check_Dir
method Check_Fieldvalue
method Check_MessageTimer
method Check_Sysadmin_Stellvertreter
method Create_Folder
method Create_Folders
method Delete_Directory
method EDOKA_Partner_Berechtigt
method EDOKA_Partner_Dokument
method ExtractFilename
method Feldwert_Aufbereitung
method FolderExist
method Generate_Berechtigungen
method Generate_Key
method Gesperrte_Dokumente_Loeschen
method Get_Filename
method GrdAlign
method Ist_Berechtigt
method Journal_Dokumentzugriff
method MA_Is_Sysadmin
method Open_Directory
method Pruefziffer
method Searchnode
method Searchnode1
method Searchnode2
method Searchnode3
method ShowColdDoc
method ShowColdDocHost
method ShowDoc
method SpaltenTitel_Aktualisieren
method Status_Dokumentbearbeitung
method TraceLog
method TranverseNodes
method TranverseNodes1
method TranverseNodes2
method TranverseNodes3
method check_doc2
method check_partnerzusammenlegung
method get_colddokumentid
method get_parnter_anrede
method get_parnter_namevorname
method isbck
method leererstellung
method print_office
method printcolddoc
method printcolddocHost
method show_office
method show_officevorlage

See Also

clsDivFnkt Class


clsDivFnkt.BDR_Dokument Method

Public Function BDR_Dokument( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Public Function BDR_Dokument(ByVal dokumentid As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_bdr_dokument"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters.Item("@bdr").Value
                If i = 0 Then
                    Return False
                Else
                    Return True
                End If
            Catch ex As Exception
                '            MsgBox(ex.Message)
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.BarcodeEtiketten_Berechtigt Method

Public Function BarcodeEtiketten_Berechtigt() As Boolean

Source code

[Visual Basic]
        Public Function BarcodeEtiketten_Berechtigt() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.sp_berechtigung_labels"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigt", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@berechtigt").Value = 1 Then
                    BarcodeEtiketten_Berechtigt = True
                Else
                    BarcodeEtiketten_Berechtigt = False
                End If
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Berechtigt_als_stv Method

Public Function Berechtigt_als_stv( _
   ByVal mitarbeiternr As Integer, _
   ByVal partnernr As Integer, _
   ByVal DOKUMENTTYPNR As Integer _
) As Boolean

Parameters

mitarbeiternr
Required.
partnernr
Required.
DOKUMENTTYPNR
Required.

Source code

[Visual Basic]
        Public Function Berechtigt_als_stv(ByVal mitarbeiternr As Integer, ByVal partnernr As Integer, ByVal DOKUMENTTYPNR As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.sp_dokumentberechtigung_erstellungstv"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DOKUMENTTYPNR))
                sdaAdapter.Fill(dtToReturn)
                If dtToReturn.Rows.Count = 0 Then
                    Return False
                Else
                    Return True
                End If
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Berechtigte_Funktionen Method

Public Function Berechtigte_Funktionen( _
   ByVal dokumenttyp As Integer, _
   ByVal Mitarbeiternr As Integer, _
   ByVal partnernr As Integer, _
   ByVal dokumentid As String, _
   ByVal berechtigung As Integer, _
   ByVal mitarbeiterdok As Integer, _
   ByVal vipdok As Integer, _
   ByVal vertraulichdok As Integer _
) As DataTable

Parameters

dokumenttyp
Required.
Mitarbeiternr
Required.
partnernr
Required.
dokumentid
Required.
berechtigung
Required.
mitarbeiterdok
Required.
vipdok
Required.
vertraulichdok
Required.

Source code

[Visual Basic]
        Public Function Berechtigte_Funktionen(ByVal dokumenttyp As Integer, ByVal Mitarbeiternr As Integer, _
                           ByVal partnernr As Integer, ByVal dokumentid As String, _
                           ByVal berechtigung As Integer, ByVal mitarbeiterdok As Integer, _
                           ByVal vipdok As Integer, ByVal vertraulichdok As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentberechtigung"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, berechtigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiterdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiterdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vipdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vipdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertraulichdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertraulichdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@currentmitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionsliste", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Berechtigte_Mitarbeiter Method

Public Function Berechtigte_Mitarbeiter( _
   ByVal dokumenttyp As Integer, _
   ByVal Mitarbeiternr As Integer, _
   ByVal partnernr As Integer, _
   ByVal dokumentid As String, _
   ByVal berechtigung As Integer, _
   ByVal mitarbeiterdok As Integer, _
   ByVal vipdok As Integer, _
   ByVal vertraulichdok As Integer, _
   ByVal Funktionsliste As String _
) As DataTable

Parameters

dokumenttyp
Required.
Mitarbeiternr
Required.
partnernr
Required.
dokumentid
Required.
berechtigung
Required.
mitarbeiterdok
Required.
vipdok
Required.
vertraulichdok
Required.
Funktionsliste
Required.

Source code

[Visual Basic]
        Public Function Berechtigte_Mitarbeiter(ByVal dokumenttyp As Integer, ByVal Mitarbeiternr As Integer, _
                                   ByVal partnernr As Integer, ByVal dokumentid As String, _
                                   ByVal berechtigung As Integer, ByVal mitarbeiterdok As Integer, _
                                   ByVal vipdok As Integer, ByVal vertraulichdok As Integer, _
                                   ByVal Funktionsliste As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentberechtigung"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, berechtigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiterdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiterdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vipdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vipdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertraulichdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertraulichdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@currentmitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionsliste", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Funktionsliste))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stv", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                Globals.stv = scmCmdToExecute.Parameters("@stv").Value

                Return dtToReturn
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Bezeichnung_Feldwert Method

Public Sub Bezeichnung_Feldwert( _
   ByRef dt As DataTable, _
   ByVal SetDefaultValue As Boolean _
)

Parameters

dt
Required.
SetDefaultValue
Required.

Source code

[Visual Basic]
        Public Sub Bezeichnung_Feldwert(ByRef dt As DataTable, ByVal SetDefaultValue As Boolean)
            Try
                Dim i As Integer
                Dim i1 As Integer
                Dim s1 As String
                Dim s2 As String
                For i = 0 To dt.Rows.Count - 1
                    If dt.Rows(i).Item("Bezeichnung") Is System.DBNull.Value Then
                        dt.Rows(i).Item("Bezeichnung") = ""
                    End If
                    i1 = InStr(dt.Rows(i).Item("Bezeichnung"), "&DW:")
                    If i1 > 0 Then
                        s1 = dt.Rows(i).Item("bezeichnung")
                        s2 = s1
                        s1 = Microsoft.VisualBasic.Left(s1, i1 - 1)
                        Try
                            s2 = Microsoft.VisualBasic.Right(s2, Len(s2) - (i1 + 3))
                        Catch
                            s2 = ""
                        End Try
                        dt.Rows(i).Item("Bezeichnung") = s1
                        If SetDefaultValue = True Then
                            dt.Rows(i).Item("Feldwert") = Feldwert_Aufbereitung(s2)
                        End If
                    End If
                Next
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Check_Dir Method

Public Function Check_Dir( _
   ByVal Partnernr As Long _
) As String

Parameters

Partnernr
Required.

Source code

[Visual Basic]
        Public Function Check_Dir(ByVal Partnernr As Long) As String
            If Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("net_use") = True Then

            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Check_Fieldvalue Method

Public Function Check_Fieldvalue( _
   ByVal Feldwert As String, _
   ByVal Validierungsregel As String _
) As Boolean

Parameters

Feldwert
Required.
Validierungsregel
Required.

Source code

[Visual Basic]
        Public Function Check_Fieldvalue(ByVal Feldwert As String, ByVal Validierungsregel As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_Dokumentfeldwert_Validate"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@FeldwertIn", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Feldwert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Validierungsregel", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Validierungsregel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@errormessage", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                scmCmdToExecute.Connection.Close()
                If scmCmdToExecute.Parameters("@errormessage").Value <> "" Then
                    MsgBox(scmCmdToExecute.Parameters("@errormessage").Value, MsgBoxStyle.Critical)
                    Return False
                End If
                Return True
            Catch ex As Exception
                Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Check_MessageTimer Method

Public Function Check_MessageTimer() As Integer

Source code

[Visual Basic]
        Public Function Check_MessageTimer() As Integer
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.SP_message_getmessage"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@typ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                sdaAdapter.Fill(dtToReturn)
                Check_MessageTimer = False
                Check_MessageTimer = dtToReturn.Rows.Count
            Catch ex As Exception
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Check_Sysadmin_Stellvertreter Method

Public Function Check_Sysadmin_Stellvertreter( _
   ByVal Owner As Integer _
) As Boolean

Parameters

Owner
Required.

Source code

[Visual Basic]
        Public Function Check_Sysadmin_Stellvertreter(ByVal Owner As Integer) As Boolean
            If Owner = Globals.MitarbeiterNr Then Return True
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_sysadmin_stv"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertretener", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Owner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigt", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                scmCmdToExecute.Connection.Close()
                If scmCmdToExecute.Parameters("@berechtigt").Value = 1 Then
                    Return True
                Else
                    If Me.MA_Is_Sysadmin(Globals.MitarbeiterNr) Then
                        Return True
                    Else
                        Return False
                    End If
                End If
            Catch ex As Exception
                Throw New Exception("sp_check_sysadminstv::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Create_Folder Method

Public Function Create_Folder( _
   ByVal dn As String _
) As Boolean

Parameters

dn
Required.

Source code

[Visual Basic]
        Public Function Create_Folder(ByVal dn As String) As Boolean
            Try
                System.IO.Directory.CreateDirectory(dn)
            Catch
                Create_Folder = False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Create_Folders Method

Public Function Create_Folders( _
   ByVal s As String _
) As Boolean

Parameters

s
Required.

Source code

[Visual Basic]
        Public Function Create_Folders(ByVal s As String) As Boolean
            Dim xt(10) As String
            Dim xti As Integer
            Dim po As Integer
            Dim x As String
            Dim xti1 As Integer
            Dim i As Long
            po = InStr(s, "\")
            xti = 0
            While po <> 0
                xt(xti) = Left(s, po - 1)
                xti = xti + 1
                s = Right(s, Len(s) - (po))
                po = InStr(s, "\")
            End While
            xt(xti) = s
            For xti1 = 0 To xti
                If x <> "" Then x = x & "\"
                x = x & xt(xti1)
                If Not FolderExist(x) Then Create_Folder(x)
            Next
            Create_Folders = True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Delete_Directory Method

Public Function Delete_Directory( _
   ByVal sPfad As String _
) As Boolean

Parameters

sPfad
Required.

Source code

[Visual Basic]
        Public Function Delete_Directory(ByVal sPfad As String) As Boolean
            Try
                System.IO.Directory.Delete(sPfad, True)
                Delete_Directory = True
            Catch
                Delete_Directory = False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.EDOKA_Partner_Berechtigt Method

Public Function EDOKA_Partner_Berechtigt() As Boolean

Source code

[Visual Basic]
        Public Function EDOKA_Partner_Berechtigt() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.sp_berechtigung_edokapartner"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigt", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@berechtigt").Value = 1 Then
                    EDOKA_Partner_Berechtigt = True
                Else
                    EDOKA_Partner_Berechtigt = False
                End If
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.EDOKA_Partner_Dokument Method

Public Function EDOKA_Partner_Dokument( _
   ByVal fnkt As Integer, _
   ByVal dokumenttypnr As Integer _
) As Boolean

Parameters

fnkt
Required.
dokumenttypnr
Required.

Source code

[Visual Basic]
        Public Function EDOKA_Partner_Dokument(ByVal fnkt As Integer, ByVal dokumenttypnr As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_dokument_edokapartnererstellung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@leererstellung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters("@leererstellung").Value
                If i > 0 Then EDOKA_Partner_Dokument = True Else EDOKA_Partner_Dokument = False
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.ExtractFilename Method

Public Function ExtractFilename( _
   ByVal x As String _
) As String

Parameters

x
Required.

Source code

[Visual Basic]
        Public Function ExtractFilename(ByVal x As String) As String
            Dim splitter
            Dim i As Integer
            Dim Y As String
            splitter = Microsoft.VisualBasic.Split(x, "\")
            On Error Resume Next
            Err.Clear()
            i = -1
            While Err.Number = 0
                i = i + 1
                Y = splitter(i)
            End While
            ExtractFilename = Y
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Feldwert_Aufbereitung Method

Public Function Feldwert_Aufbereitung( _
   ByVal Feldwert As String _
) As String

Parameters

Feldwert
Required.

Source code

[Visual Basic]
        Public Function Feldwert_Aufbereitung(ByVal Feldwert As String) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_Dokumentfeldwert_Aufbereitung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@FeldwertIn", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Feldwert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@FeldwertOut", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                scmCmdToExecute.Connection.Close()
                Return scmCmdToExecute.Parameters("@FeldwertOut").Value

            Catch ex As Exception
                Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.FolderExist Method

Public Function FolderExist( _
   ByVal dn As String _
) As Boolean

Parameters

dn
Required.

Source code

[Visual Basic]
        Public Function FolderExist(ByVal dn As String) As Boolean
            Try
                If System.IO.Directory.Exists(dn) Then FolderExist = True Else FolderExist = False
            Catch
                FolderExist = False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Generate_Berechtigungen Method

Public Function Generate_Berechtigungen()

Source code

[Visual Basic]
        Public Function Generate_Berechtigungen()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.sp_dokumentberechtigung_Generate"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.CommandTimeout = 50000
                conn.OpenConnection()
                scmCmdToExecute.ExecuteNonQuery()
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                'Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                conn.CloseConnection(True)
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Generate_Key Method

Public Function Generate_Key() As String

Source code

[Visual Basic]
        Public Function Generate_Key() As String
            Dim dbkey As New edokadb.clsMyKey_Tabelle()
            Dim dokart As New edokadb.clsDokumentart()
            Dim key As Long
            Dim skey As String
            Dim s As String
            dbkey.cpMainConnectionProvider = conn
            conn.OpenConnection()
            key = dbkey.get_dbkey("dokument")
            conn.CloseConnection(False)
            skey = "OFFEDK000"

            s = Str(Year(Now))
            While Microsoft.VisualBasic.Left(s, 1) = " "
                s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
            End While
            skey = skey + s

            s = Str(key)
            While Microsoft.VisualBasic.Left(s, 1) = " "
                s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
            End While

            While Len(s) < 8
                s = "0" + s
            End While
            skey = skey + s

            s = Pruefziffer(Microsoft.VisualBasic.Right(skey, 15))
            While Microsoft.VisualBasic.Left(s, 1) = " "
                s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
            End While
            skey = skey + s
            Generate_Key = skey
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Gesperrte_Dokumente_Loeschen Method

Public Function Gesperrte_Dokumente_Loeschen()

Source code

[Visual Basic]
        Public Function Gesperrte_Dokumente_Loeschen()
            Try
                Dim scmCmdToExecute As SqlCommand = New SqlCommand()
                Dim i As Integer
                Dim dtToReturn As DataTable = New DataTable()
                Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
                scmCmdToExecute.CommandText = "dbo.sp_delete_locked_Docs"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                Try
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    sdaAdapter.Fill(dtToReturn)
                Catch ex As Exception
                    '            MsgBox(ex.Message)
                    'Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
                Finally
                    scmCmdToExecute.Dispose()
                    sdaAdapter.Dispose()
                    dtToReturn.Dispose()
                End Try
            Catch
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Get_Filename Method

Public Function Get_Filename( _
   ByVal fi As String, _
   ByVal partnernr As String _
) As String

Parameters

fi
Required.
partnernr
Required.

Source code

[Visual Basic]
        Public Function Get_Filename(ByVal fi As String, ByVal partnernr As String) As String
            Dim s As String
            Get_Filename = ""
            If Not Open_Directory() Then Exit Function
            s = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("logisches_Laufwerk") & Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_dokumente") + "\"
            Get_Filename = s + fi
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.GrdAlign Method

Public Sub GrdAlign( _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid, _
   ByVal Datafield As String, _
   ByVal Align As C1.Win.C1TrueDBGrid.AlignHorzEnum _
)

Parameters

grd
Required.
Datafield
Required.
Align
Required.

Source code

[Visual Basic]
        Public Sub GrdAlign(ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid, ByVal Datafield As String, ByVal Align As C1.Win.C1TrueDBGrid.AlignHorzEnum)

            Dim iCnt As Integer
            'center  = Zentriert
            'far = rechts
            'near = links
            Try
                grd.Splits(0).DisplayColumns(Datafield).Style.HorizontalAlignment = Align
                grd.Splits(0).DisplayColumns(Datafield).HeadingStyle.HorizontalAlignment = Align
            Catch
            End Try

        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Ist_Berechtigt Method

Public Function Ist_Berechtigt( _
   ByVal dokumenttyp As Integer, _
   ByVal Mitarbeiternr As Integer, _
   ByVal partnernr As Integer, _
   ByVal dokumentid As String, _
   ByVal berechtigung As Integer, _
   ByVal mitarbeiterdok As Integer, _
   ByVal vipdok As Integer, _
   ByVal vertraulichdok As Integer _
) As Boolean

Parameters

dokumenttyp
Required.
Mitarbeiternr
Required.
partnernr
Required.
dokumentid
Required.
berechtigung
Required.
mitarbeiterdok
Required.
vipdok
Required.
vertraulichdok
Required.

Source code

[Visual Basic]
        Public Function Ist_Berechtigt(ByVal dokumenttyp As Integer, ByVal Mitarbeiternr As Integer, _
                                           ByVal partnernr As Integer, ByVal dokumentid As String, _
                                           ByVal berechtigung As Integer, ByVal mitarbeiterdok As Integer, _
                                           ByVal vipdok As Integer, ByVal vertraulichdok As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.CommandText = "dbo.SP_Dokumentberechtigung"
                scmCmdToExecute.CommandType = CommandType.StoredProcedure
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berechtigung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, berechtigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiterdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiterdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vipdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vipdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vertraulichdok", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vertraulichdok))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@currentmitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@funktionsliste", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                sdaAdapter.Fill(dtToReturn)
                If dtToReturn.Rows.Count = 0 Then
                    If berechtigung = 2 Then
                        If Berechtigt_als_stv(Mitarbeiternr, partnernr, dokumenttyp) = True Then
                            Return True
                        Else
                            Return False
                        End If
                    Else
                        Return False
                    End If
                Else
                    Return True
                End If
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Journal_Dokumentzugriff Method

Public Function Journal_Dokumentzugriff( _
   ByVal dokumentid As String, _
   ByVal zugriffsart As String, _
   ByVal host As Integer, _
   ByVal partnernr As Integer, _
   ByVal partner_kurzbezeichnung As String, _
   ByVal dokumenttyp As String _
)

Parameters

dokumentid
Required.
zugriffsart
Required.
host
Required.
partnernr
Required.
partner_kurzbezeichnung
Required.
dokumenttyp
Required.

Source code

[Visual Basic]
        Public Function Journal_Dokumentzugriff(ByVal dokumentid As String, ByVal zugriffsart As String, ByVal host As Integer, ByVal partnernr As Integer, ByVal partner_kurzbezeichnung As String, ByVal dokumenttyp As String)
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim connopen As Boolean = False
            scmCmdToExecute.CommandText = "dbo.sp_journal_dokzugriffe"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                If host = 0 Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@zugriffsart", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, zugriffsart))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerkbez", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 35, 0, "", DataRowVersion.Proposed, ""))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 35, 0, "", DataRowVersion.Proposed, ""))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@zugriffsart", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, zugriffsart))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, partnernr))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerkbez", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 35, 0, "", DataRowVersion.Proposed, partner_kurzbezeichnung))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttyp", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 35, 0, "", DataRowVersion.Proposed, dokumenttyp))
                End If
                Try
                    scmCmdToExecute.Connection.Open()
                    connopen = True
                Catch
                End Try
                scmCmdToExecute.ExecuteNonQuery()
                If connopen Then
                    Try
                        scmCmdToExecute.Connection.Close()
                    Catch
                    End Try
                End If
            Catch ex As Exception

            Finally
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.MA_Is_Sysadmin Method

Public Function MA_Is_Sysadmin( _
   ByVal mitarbeiternr As Integer _
) As Boolean

Parameters

mitarbeiternr
Required.

Source code

[Visual Basic]
        Public Function MA_Is_Sysadmin(ByVal mitarbeiternr As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_sysadmin"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@issysadmin", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters.Item("@issysadmin").Value
                If i > 0 Then MA_Is_Sysadmin = True Else MA_Is_Sysadmin = False
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Open_Directory Method

Public Function Open_Directory() As Boolean

Source code

[Visual Basic]
        Public Function Open_Directory() As Boolean
            Open_Directory = True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Pruefziffer Method

Public Function Pruefziffer( _
   ByVal zahl As String _
) As String

Parameters

zahl
Required.

Source code

[Visual Basic]
        Public Function Pruefziffer(ByVal zahl As String) As String
            Dim ptab(9, 9) As Integer
            Dim pz(9) As Integer
            Dim s1, s2, s3 As String

            Dim i1, i2 As Long

            s1 = "0,9,4,6,8,2,7,1,3,5"
            s2 = s1
            For i1 = 0 To 9
                For i2 = 0 To 9
                    ptab(i1, i2) = Mid(s2, (i2 * 2) + 1, 1)
                Next
                s3 = Microsoft.VisualBasic.Left(s1, 1)
                s1 = Microsoft.VisualBasic.Right(s1, Len(s1) - 2)
                s1 = s1 + "," + s3
                s2 = s1
            Next
            pz(0) = 0
            pz(1) = 9
            pz(2) = 8
            pz(3) = 7
            pz(4) = 6
            pz(5) = 5
            pz(6) = 4
            pz(7) = 3
            pz(8) = 2
            pz(9) = 1

            Dim i, x, y, z, e As Integer
            Dim xx As String
            y = 0
            For i = 1 To Len(zahl)
                x = Val(Mid(zahl, i, 1))
                y = ptab(x, y)
            Next
            Pruefziffer = Str(pz(y))
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Searchnode Method

Public Function Searchnode( _
   ByVal tv As TreeView, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Public Function Searchnode(ByVal tv As TreeView, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            'Imageindex: Bei 0 keine Änderungen, ansonsten node-selectedimage auf Imageindex setzen
            Searchnode = False
            found = False
            Dim nodeX As TreeNode
            For Each nodeX In tv.Nodes
                If TranverseNodes(tv, nodeX, SearchObject, imageindex) Then
                    Exit Function
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Searchnode1 Method

Public Function Searchnode1( _
   ByVal tv As TreeView, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Public Function Searchnode1(ByVal tv As TreeView, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            'Imageindex: Bei 0 keine Änderungen, ansonsten node-selectedimage auf Imageindex setzen
            Searchnode1 = False
            found = False
            Dim nodeX As TreeNode
            For Each nodeX In tv.Nodes
                If TranverseNodes1(tv, nodeX, SearchObject, imageindex) Then
                    Exit Function
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Searchnode2 Method

Public Function Searchnode2( _
   ByVal tv As TreeView, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Public Function Searchnode2(ByVal tv As TreeView, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            'Imageindex: Bei 0 keine Änderungen, ansonsten node-selectedimage auf Imageindex setzen
            Searchnode2 = False
            found = False
            Dim nodeX As TreeNode
            For Each nodeX In tv.Nodes
                If TranverseNodes2(tv, nodeX, SearchObject, imageindex) Then
                    Exit Function
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Searchnode3 Method

Public Function Searchnode3( _
   ByVal tv As TreeView, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Public Function Searchnode3(ByVal tv As TreeView, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            'Imageindex: Bei 0 keine Änderungen, ansonsten node-selectedimage auf Imageindex setzen
            Searchnode3 = False
            found = False
            Dim nodeX As TreeNode
            For Each nodeX In tv.Nodes
                If TranverseNodes3(tv, nodeX, SearchObject, imageindex) Then
                    Exit Function
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.ShowColdDoc Method

Public Function ShowColdDoc( _
   ByVal dokumentid As String, _
   ByVal formx As Form, _
   ByVal cold_dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.
formx
Required.
cold_dokumentid
Required.

Source code

[Visual Basic]
        Public Function ShowColdDoc(ByVal dokumentid As String, ByVal formx As Form, ByVal cold_dokumentid As String) As Boolean
            Dim f As New frmcoldview()
            f.Erstellungsdatum = Me.Erstellungsdatum
            f.Colddokumentid = cold_dokumentid
            f.DokumentId = dokumentid
            f.MdiParent = formx.MdiParent
            f.Width = 1
            f.Height = 1
            f.Show()
            If f.DocNotFound = True Then
                Journal_Dokumentzugriff(dokumentid, "COLD-Anzeige-Fehler", 0, 0, "", "")
                ShowColdDoc = False
                f.Dispose()
            Else
                ShowColdDoc = True
                Journal_Dokumentzugriff(dokumentid, "COLD-Anzeige", 0, 0, "", "")
                f.Dispose()
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.ShowColdDocHost Method

Public Function ShowColdDocHost( _
   ByVal dokumentid As String, _
   ByVal formx As Form, _
   ByVal cold_dokumentid As String, _
   ByVal partnernr As String, _
   ByVal bkpar00 As String, _
   ByVal dokumenttyp As String _
) As Boolean

Parameters

dokumentid
Required.
formx
Required.
cold_dokumentid
Required.
partnernr
Required.
bkpar00
Required.
dokumenttyp
Required.

Source code

[Visual Basic]
        Public Function ShowColdDocHost(ByVal dokumentid As String, ByVal formx As Form, ByVal cold_dokumentid As String, ByVal partnernr As String, ByVal bkpar00 As String, ByVal dokumenttyp As String) As Boolean
            Try
                Dim f As New frmcoldview()
                f.Erstellungsdatum = Me.Erstellungsdatum
                f.belegart = Me.Belegart
                f.UVMZVDokumenttyp = Me.UVMZVDokumenttyp
                f.Auftragnr = Me.Auftragnr
                f.Colddokumentid = cold_dokumentid
                f.DokumentId = dokumentid
                f.MdiParent = formx.MdiParent
                f.Width = 1
                f.Height = 1
                f.Show()
                If f.DocNotFound = True Then
                    Journal_Dokumentzugriff(dokumentid, "HOST-Anzeige-Fehler", 1, partnernr, bkpar00, dokumenttyp)
                    ShowColdDocHost = False
                    f.Dispose()
                Else
                    ShowColdDocHost = True
                    Journal_Dokumentzugriff(dokumentid, "HOST-Anzeige", 1, partnernr, bkpar00, dokumenttyp)
                    f.Dispose()
                End If
            Catch ex As Exception
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.ShowDoc Method

Public Sub ShowDoc( _
   ByVal dokumentid As String, _
   ByVal formx As Form _
)

Parameters

dokumentid
Required.
formx
Required.

Source code

[Visual Basic]
        Public Sub ShowDoc(ByVal dokumentid As String, ByVal formx As Form)
            Try
                '************************************************
                'UVM Migration / Erste Variante
                'Start
                '************************************************
                ''Rel 3.7 / BUD - Neu Prüfung auf UVM Dokument, wenn UVM Dokument dann Daten auslesen.
                'If InStr(dokumentid, "OFFEDK003") <> 0 Then
                '    Try
                '        Dim dt As DataTable
                '        dt = GetDataUVMDokument(dokumentid)
                '        gen_ShowColdDocUVM(dt.Rows(0).Item("nrpar00"), dt.Rows(0).Item("fanummer3"), dt.Rows(0).Item("erstelltam"), formx)
                '        Exit Sub
                '    Catch ex As Exception
                '        MsgBox(ex.Message)
                '    End Try
                'End If
                '************************************************
                'ENDE
                '************************************************

                Dim colddokumentid As String
                colddokumentid = get_colddokumentid(dokumentid, 0)
                If colddokumentid = "Office" Then
                    show_office(dokumentid, formx)
                    Exit Sub
                End If
                If DivFnkt.BDR_Dokument(dokumentid) = True Then
                    ShowColdDoc(dokumentid, formx, colddokumentid)
                    Exit Sub
                End If
                If Not ShowColdDoc(dokumentid, formx, colddokumentid) Then
                    colddokumentid = get_colddokumentid(dokumentid, 1)
                    If Not ShowColdDoc(dokumentid, formx, colddokumentid) Then
                        colddokumentid = get_colddokumentid(dokumentid, 2)
                        If Not ShowColdDoc(dokumentid, formx, colddokumentid) Then
                            show_office(dokumentid, formx)
                        End If
                    End If
                End If
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.SpaltenTitel_Aktualisieren Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tdb As C1TrueDBGrid, _
   ByVal inptable As DataTable, _
   ByVal tablename As String _
)

Parameters

tdb
Required.
inptable
Required.
tablename
Required.

Source code

[Visual Basic]
        Public Sub SpaltenTitel_Aktualisieren(ByVal tdb As C1TrueDBGrid, ByVal inptable As DataTable, ByVal tablename As String)
            'Spaltentitel setzen
            Dim titel As New EDOKA.MySpaltenTitel()
            Dim ts As New EDOKA.Tabellenspalte()
            Dim i As Integer
            Dim t As New DataTable()
            Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
            Dim s As String

            t = inptable
            ts.Tabelle = tablename
            For i = 0 To tdb.Columns.Count - 1
                s = tdb.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                tdb.Columns(i).Caption = ts.spaltenname
                If tdb.Columns(i).Caption = "" Then
                    tdb.Splits(0).DisplayColumns(i).Width = 0
                    tdb.Splits(0).DisplayColumns(i).Visible = False
                Else
                    tdb.Splits(0).DisplayColumns(i).Width = ts.ColWith
                End If
                Try
                    If ts.ColWith = 0 Then
                        tdb.Splits(0).DisplayColumns(i).Visible = False
                    End If
                Catch
                End Try
                '            If tdb.Columns(i).Caption = "" Then tdb.Splits(0).DisplayColumns(i).Width = 0
                If ts.locked Then
                    tdb.Splits(0).DisplayColumns(i).Locked = True
                End If

                If ts.AlsHacken Then
                    tdb.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                End If

                'Präsentation von aktiv
                If tdb.Columns(i).DataField = "aktiv" Then
                    tdb.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    tdb.Columns(i).ValueItems.DefaultItem = True
                    tdb.Columns(i).DefaultValue = True
                    tdb.Columns(i).FilterText = True
                End If
                If tdb.Columns(i).DataField = "erstellt_am" Then
                    tdb.Columns(i).DefaultValue = Now
                End If
                'tdb.Splits(0).DisplayColumns.Insert(ts.Order, tdb.Splits(0).DisplayColumns(i))
                'tdb.Splits(0).DisplayColumns.RemoveAt(i)
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.Status_Dokumentbearbeitung Method

Public Function Status_Dokumentbearbeitung( _
   ByVal fnkt As Integer, _
   ByVal dokumentid As String, _
   ByVal erstellung As Boolean, _
   ByVal dokumentname As String _
) As Boolean

Parameters

fnkt
Required.
dokumentid
Required.
erstellung
Required.
dokumentname
Required.

Source code

[Visual Basic]
        Public Function Status_Dokumentbearbeitung(ByVal fnkt As Integer, ByVal dokumentid As String, ByVal erstellung As Boolean, ByVal dokumentname As String) As Boolean
            'Prüfung, Eintragung, Löschung der Tabelle DokInBearbeitung'
            'Fnkt:
            '     1=Eintragen
            '     2=Löschen
            '     3=Prüfen
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.sp_Dokument_in_Bearbeitung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@erstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, erstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stationsname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Environ("Computername")))
                sdaAdapter.Fill(dtToReturn)
                Status_Dokumentbearbeitung = True
                If fnkt = 3 Then
                    If dtToReturn.Rows.Count > 0 Then
                        MyMsg.show_standardmessage(31, MsgBoxStyle.Critical)
                        Status_Dokumentbearbeitung = False
                    End If
                End If
            Catch ex As Exception
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.TraceLog Method

Public Sub TraceLog( _
   ByVal stext As String _
)

Parameters

stext
Required.

Source code

[Visual Basic]
        Public Sub TraceLog(ByVal stext As String)
            'Dim sw As New StreamWriter("c:\tracelog.txt", True)
            'sw.WriteLine(stext)
            'sw.Flush()
            'sw.Close()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.TranverseNodes Method

Private Function TranverseNodes( _
   ByVal tv As TreeView, _
   ByVal selectedNode As TreeNode, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
selectedNode
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Private Function TranverseNodes(ByVal tv As TreeView, ByVal selectedNode As TreeNode, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            Dim nodeX As TreeNode
            For Each nodeX In selectedNode.Nodes
                nodeX.Text = nodeX.Text
                If nodeX.Tag = SearchObject Then

                    nodeX.Expand()
                    tv.SelectedNode = nodeX
                    Me.FoundNode = tv.SelectedNode
                    If imageindex <> 0 Then
                        tv.SelectedNode.SelectedImageIndex = imageindex
                        tv.SelectedNode.Toggle()
                    End If
                    found = True
                    TranverseNodes = True
                    Exit Function
                End If
                TranverseNodes(tv, nodeX, SearchObject, imageindex)
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.TranverseNodes1 Method

Private Function TranverseNodes1( _
   ByVal tv As TreeView, _
   ByVal selectedNode As TreeNode, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
selectedNode
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Private Function TranverseNodes1(ByVal tv As TreeView, ByVal selectedNode As TreeNode, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            Dim nodeX As TreeNode
            For Each nodeX In selectedNode.Nodes
                Try
                    If nodeX.Tag = SearchObject Then
                        nodeX.Expand()
                        Me.FoundNode = nodeX
                        found = True
                        TranverseNodes1 = True
                        Exit Function
                    Else
                        TranverseNodes1(tv, nodeX, SearchObject, imageindex)
                    End If
                Catch
                    If nodeX.Text = Trim(Str(SearchObject)) Then
                        nodeX.Expand()
                        Me.FoundNode = nodeX
                        found = True
                        TranverseNodes1 = True
                        Exit Function
                    Else
                        TranverseNodes1(tv, nodeX, SearchObject, imageindex)
                    End If
                End Try

            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.TranverseNodes2 Method

Private Function TranverseNodes2( _
   ByVal tv As TreeView, _
   ByVal selectedNode As TreeNode, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
selectedNode
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Private Function TranverseNodes2(ByVal tv As TreeView, ByVal selectedNode As TreeNode, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            Dim nodeX As TreeNode
            For Each nodeX In selectedNode.Nodes
                If nodeX.ImageIndex = 1 Then
                    nodeX.Expand()
                    Me.FoundNode = nodeX
                    found = True
                    TranverseNodes2 = True
                    Exit Function
                Else
                    TranverseNodes2(tv, nodeX, SearchObject, imageindex)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.TranverseNodes3 Method

Private Function TranverseNodes3( _
   ByVal tv As TreeView, _
   ByVal selectedNode As TreeNode, _
   ByVal SearchObject As Object, _
   ByVal imageindex As Integer _
) As Boolean

Parameters

tv
Required.
selectedNode
Required.
SearchObject
Required.
imageindex
Required.

Source code

[Visual Basic]
        Private Function TranverseNodes3(ByVal tv As TreeView, ByVal selectedNode As TreeNode, ByVal SearchObject As Object, ByVal imageindex As Integer) As Boolean
            Dim nodeX As TreeNode
            For Each nodeX In selectedNode.Nodes
                If nodeX.Nodes.Count > 0 Then
                    nodeX.Expand()
                    Me.FoundNode = nodeX
                    found = True
                    TranverseNodes3 = True
                    Exit Function
                Else
                    TranverseNodes3(tv, nodeX, SearchObject, imageindex)
                End If
            Next
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.check_doc2 Method

Public Sub check_doc2()

Source code

[Visual Basic]
        Public Sub check_doc2()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim s As String
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_doc"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                sdaAdapter.Fill(dtToReturn)
                For i = 0 To dtToReturn.Rows.Count - 1
                    Dim f As New frmHinweismeldung1()
                    s = "Das nachfolgende Dokumente wurde von Ihnen erstellt, konnte aber aufgrund eines"
                    s = s + vbCrLf + "Systemfehlers nicht korrekt auf der Datenbank gespeichert werden. Der Dokumenteintrag im"
                    s = s + vbCrLf + "EDOKA ist fehlerhaft, da sich das Dokument im EDOKA nicht anzeigen lässt."
                    s = s + vbCrLf + vbCrLf
                    s = s + "Partner: " + Chr(9) + Str(dtToReturn.Rows(i).Item("nrpar00")) + " - " + dtToReturn.Rows(i).Item("bkpar00")
                    s = s + vbCrLf
                    s = s + "DokumentID: " + Chr(9) + dtToReturn.Rows(i).Item("dokumentid")
                    s = s + vbCrLf
                    s = s + "Dokumenttyp: " + Chr(9) + dtToReturn.Rows(i).Item("bezeichnung")
                    s = s + vbCrLf
                    s = s + "Erstellt am: " + Chr(9) + dtToReturn.Rows(i).Item("erstelltam")
                    s = s + vbCrLf + vbCrLf
                    s = s + "Bitte gehen Sie wie folgt vor:"
                    s = s + vbCrLf + "- Vernichten des allfällig ausgedrucken Dokumentes"
                    s = s + vbCrLf + "- Löschen des fehlerhaften Dokumenteintrages im EDOKA"
                    s = s + vbCrLf + "- Neu erstellen des Dokumentes"
                    f.Label1.Text = s
                    f.MsgBoxStyle = 1
                    f.ShowDialog()
                    f.Dispose()
                    Globals.PerfMon.force_insert_entry("Dokument nicht korrekt auf der Datenbank - " + dtToReturn.Rows(i).Item("dokumentid"))
                Next
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                'Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.check_partnerzusammenlegung Method

Public Function check_partnerzusammenlegung() As Boolean

Source code

[Visual Basic]
        Public Function check_partnerzusammenlegung() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_check_partnerzusammenlegung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerzusammenlegung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters.Item("@partnerzusammenlegung").Value
                If i = 0 Then
                    Return False
                Else
                    Return True
                End If
            Catch ex As Exception
                '            MsgBox(ex.Message)
                Throw New Exception("sp_check_dokumentreaktivierung::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.get_colddokumentid Method

Public Function get_colddokumentid( _
   ByVal dokumentid As String, _
   ByVal fnkt As Integer _
) As String

Parameters

dokumentid
Required.
fnkt
Required.

Source code

[Visual Basic]
        Public Function get_colddokumentid(ByVal dokumentid As String, ByVal fnkt As Integer) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.sp_get_colddokumentid"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                sdaAdapter.Fill(dtToReturn)
                get_colddokumentid = scmCmdToExecute.Parameters("@colddokumentid").Value
            Catch ex As Exception
                MsgBox("Status Dokumentbearbeitung::" & scmCmdToExecute.CommandText + "::" + ex.Message)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.get_parnter_anrede Method

Public Function get_parnter_anrede( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function get_parnter_anrede(ByVal nrpar00 As Integer) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_edex_get_partnervornamename"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beban", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                scmCmdToExecute.Connection.Close()
                Return scmCmdToExecute.Parameters("@beban").Value
            Catch ex As Exception
                Return ""
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.get_parnter_namevorname Method

Public Function get_parnter_namevorname( _
   ByVal nrpar00 As Integer _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function get_parnter_namevorname(ByVal nrpar00 As Integer) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_edex_get_partnervornamename"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Connection.Open()
                scmCmdToExecute.ExecuteNonQuery()
                scmCmdToExecute.Connection.Close()
                Return scmCmdToExecute.Parameters("@value").Value
            Catch ex As Exception
                Return ""
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.isbck Method

Public Function isbck( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Public Function isbck(ByVal dokumentid As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "sp_check_bck"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            Try
                scmCmdToExecute.Connection = conn.scoDBConnection
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isbck", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bcknr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                If scmCmdToExecute.Parameters("@isbck").Value = 1 Then
                    isbck = True
                Else
                    isbck = False
                End If

            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("CheckBCK:" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.leererstellung Method

Public Function leererstellung( _
   ByVal fnkt As Integer, _
   ByVal dokumenttypnr As Integer _
) As Boolean

Parameters

fnkt
Required.
dokumenttypnr
Required.

Source code

[Visual Basic]
        Public Function leererstellung(ByVal fnkt As Integer, ByVal dokumenttypnr As Integer) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_dokument_leererstellung"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@leererstellung", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters("@leererstellung").Value
                If i > 0 Then leererstellung = True Else leererstellung = False
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.print_office Method

Public Sub print_office( _
   ByVal dokumentid As String, _
   ByVal formx As Form, _
   Optional ByVal ShowPrintMessage As Boolean = True _
)

Parameters

dokumentid
Required.
formx
Required.
ShowPrintMessage
Optional. Default value is True.

Source code

[Visual Basic]
        Public Sub print_office(ByVal dokumentid As String, ByVal formx As Form, Optional ByVal ShowPrintMessage As Boolean = True)
            Try
                Dim doc As New edokadb.clsDokument()
                Dim Dokument As String
                Dim FileReader As New DocMgmt()
                doc.cpMainConnectionProvider = conn
                doc.sDokumentid = New SqlString(CType(dokumentid, String))
                doc.SelectOne()
                Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
                If FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument) = False Then
                    If BDR_Dokument(dokumentid) Then
                        MyMsg.show_standardmessage(240, MsgBoxStyle.Information)
                    Else
                        MyMsg.show_standardmessage(39, MsgBoxStyle.Information)
                    End If
                    doc.Dispose()
                    FileReader = Nothing
                    Exit Sub
                End If
                doc.Dispose()
                FileReader = Nothing
                Dim f As New frmWordViewer()
                f.PrintDokumentid = doc.sDokumentid.Value
                f.PrintFilename = doc.sDokumentname.Value
                f.addressBar.Text = Dokument
                Try
                    f.MdiParent = formx.MdiParent
                Catch
                End Try
                f.Width = 1
                f.Height = 1
                f.Show_Print_Message = ShowPrintMessage
                Journal_Dokumentzugriff(dokumentid, "Office-Print", 0, 0, "", "")
                'Anpassungen für 'Nicht-Word-Dokumente'
                If UCase(Microsoft.VisualBasic.Right(f.PrintFilename, 4)) <> ".DOC" Then
                    f.Show()
                    Application.DoEvents()
                End If
                f.Print_Doc()
                'f.PrintDoc()
                f.Close()
                f = Nothing
                'f.Dispose()
                'MyMsg.show_standardmessage(91, MsgBoxStyle.Information)
            Catch
                    'MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
                End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.printcolddoc Method

Public Function printcolddoc( _
   ByVal dokumentid As String, _
   ByVal formx As Form, _
   ByVal cold_dokumentid As String, _
   Optional ByVal showmsg As Boolean = True _
) As Boolean

Parameters

dokumentid
Required.
formx
Required.
cold_dokumentid
Required.
showmsg
Optional. Default value is True.

Source code

[Visual Basic]
        Public Function printcolddoc(ByVal dokumentid As String, ByVal formx As Form, ByVal cold_dokumentid As String, Optional ByVal showmsg As Boolean = True) As Boolean
            Try
                Dim f As New frmcoldview()
                f.Erstellungsdatum = Me.Erstellungsdatum
                cold_dokumentid = get_colddokumentid(dokumentid, 0)
                f.Colddokumentid = cold_dokumentid
                f.DokumentId = dokumentid

                'Rel 3.7 / BUD / Problem mit Mehrfach Druck
                'f.MdiParent = formx.MdiParent
                'Dim docnotfound As Boolean
                'f.DocNotFound = False

                f.Height = 1
                f.Width = 1
                f.PrintIt = True
                f.Show()
                If f.DocNotFound = True Then
                    Journal_Dokumentzugriff(dokumentid, "COLD-Print-Fehler", 0, 0, "", "")
                    MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
                Else
                    f.PRINTdOC()
                    Journal_Dokumentzugriff(dokumentid, "COLD-Print", 0, 0, "", "")
                    If showmsg Then MyMsg.show_standardmessage(91, MsgBoxStyle.Information)
                    f.Close()
                    f.Dispose()
                End If
            Catch
                MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.printcolddocHost Method

Public Function printcolddocHost( _
   ByVal dokumentid As String, _
   ByVal formx As Form, _
   ByVal cold_dokumentid As String, _
   ByVal partnernr As String, _
   ByVal bkpar00 As String, _
   ByVal dokumenttyp As String, _
   Optional ByVal ShowMsg As Boolean = True _
) As Boolean

Parameters

dokumentid
Required.
formx
Required.
cold_dokumentid
Required.
partnernr
Required.
bkpar00
Required.
dokumenttyp
Required.
ShowMsg
Optional. Default value is True.

Source code

[Visual Basic]
        Public Function printcolddocHost(ByVal dokumentid As String, ByVal formx As Form, ByVal cold_dokumentid As String, ByVal partnernr As String, ByVal bkpar00 As String, ByVal dokumenttyp As String, Optional ByVal ShowMsg As Boolean = True) As Boolean
            Try
                Dim f As New frmcoldview()
                f.Erstellungsdatum = Me.Erstellungsdatum
                f.belegart = Me.Belegart
                f.UVMZVDokumenttyp = Me.UVMZVDokumenttyp
                f.Auftragnr = Me.Auftragnr
                f.Colddokumentid = cold_dokumentid
                f.DokumentId = dokumentid
                'Rel 3.7 / BUD / Problem mit Mehrfach Druck
                'f.MdiParent = formx.MdiParent
                f.PrintIt = True
                f.Width = 1
                f.Height = 1
                f.Show()
                If f.DocNotFound = True Then
                    Journal_Dokumentzugriff(dokumentid, "HOST-Print-Fehler", 1, partnernr, bkpar00, dokumenttyp)
                    printcolddocHost = False
                    f.Dispose()
                Else
                    f.PRINTdOC()
                    Journal_Dokumentzugriff(dokumentid, "COLD-Print", 0, 0, "", "")
                    If ShowMsg Then MyMsg.show_standardmessage(91, MsgBoxStyle.Information)
                    f.Close()
                    f.Dispose()
                    printcolddocHost = True
                End If
            Catch
                MyMsg.show_standardmessage(92, MsgBoxStyle.Critical)
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.show_office Method

Public Sub show_office( _
   ByVal dokumentid As String, _
   ByVal formx As Form _
)

Parameters

dokumentid
Required.
formx
Required.

Source code

[Visual Basic]
        Public Sub show_office(ByVal dokumentid As String, ByVal formx As Form)
            Globals.EDOKAMAIN_Statusbar.Text = "Dokumentanzeige gestartet"
            Dim doc As New edokadb.clsDokument()
            Dim Dokument As String
            Dim FileReader As New DocMgmt()
            doc.cpMainConnectionProvider = conn
            doc.sDokumentid = New SqlString(CType(dokumentid, String))
            doc.SelectOne()
            Try
                Dokument = DivFnkt.Get_Filename("View_" + Format(Now, "yyyyMMddHHmmss") + "_" + doc.sDokumentname.Value, "")
                '                Dokument = DivFnkt.Get_Filename(doc.sDokumentname.Value, "")
                If FileReader.Get_From_DB(doc.sDokumentid.Value, Dokument) = False Then
                    If isbck(dokumentid) Then
                        MyMsg.show_standardmessage(39, MsgBoxStyle.Information)
                    Else
                        If BDR_Dokument(dokumentid) Then
                            MyMsg.show_standardmessage(240, MsgBoxStyle.Information)
                        End If
                    End If
                    doc.Dispose()
                    FileReader = Nothing
                    Exit Sub
                End If
                doc.Dispose()
                FileReader = Nothing
                Dim f As New frmWordViewer()
                f.PrintFilename = doc.sDokumentname.Value
                f.PrintDokumentid = doc.sDokumentid.Value
                'hutter
                'f.dokument = Dokument
                f.addressBar.Text = Dokument
                'f.MdiParent = formx
                Journal_Dokumentzugriff(dokumentid, "Office-Anzeige", 0, 0, "", "")
                f.Show()
            Catch ex As Exception
                MsgBox(ex.Message)
                MyMsg.show_standardmessage(99, MsgBoxStyle.Information)
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt.show_officevorlage Method

Public Sub show_officevorlage( _
   ByVal Dokumenttypnr As String, _
   ByVal formx As Form, _
   ByVal printable As Boolean _
)

Parameters

Dokumenttypnr
Required.
formx
Required.
printable
Required.

Source code

[Visual Basic]
        Public Sub show_officevorlage(ByVal Dokumenttypnr As String, ByVal formx As Form, ByVal printable As Boolean)
            Dim dokumenttyp As New edokadb.clsDokumenttyp()
            Dim Office_Vorlage As New edokadb.clsOffice_vorlage()
            Dim dokumentname As String = "TMP_" + Format(Now, "yyyyMMddHHmmss")
            Dim s As String
            dokumenttyp.cpMainConnectionProvider = conn
            dokumenttyp.iDokumenttypnr = New SqlInt32(CType(Dokumenttypnr, Int32))
            dokumenttyp.SelectOne()
            Office_Vorlage.cpMainConnectionProvider = conn
            Office_Vorlage.iOffice_vorlagenr = dokumenttyp.iOffice_vorlagenr
            Office_Vorlage.SelectOne()

            If Office_Vorlage.iAnwendungnr.Value = 2 Then
                dokumentname = dokumentname + ".xls"
            Else
                dokumentname = dokumentname + ".doc"
            End If

            dokumentname = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente") + dokumentname

            Dim x As New FrmDomainOfficeVorlageDatei()
            s = x.Get_From_DB(Office_Vorlage.iOffice_vorlagenr.Value, Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"))
            x.Dispose()
            FileSystem.Rename(s, dokumentname)

            Dim f As New frmWordViewer(printable)
            f.PrintFilename = ""
            f.PrintDokumentid = ""
            f.addressBar.Text = dokumentname
            f.Show()
            dokumenttyp.Dispose()
            Office_Vorlage.Dispose()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsDivFnkt Fields

clsDivFnkt overview

Fields

field m_auftragnr
field m_belegart
field m_erstellungsdatum
field m_found
field m_tn
field m_uvmzvdokumenttyp
field x

See Also

clsDivFnkt Class


m_auftragnr Variable

Dim m_auftragnr As String

Source code

[Visual Basic]
        Dim m_auftragnr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


m_belegart Variable

Dim m_belegart As String

Source code

[Visual Basic]
        Dim m_belegart As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


m_erstellungsdatum Variable

Dim m_erstellungsdatum As String

Source code

[Visual Basic]
        Dim m_erstellungsdatum As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


m_found Variable

Dim m_found As Boolean

Source code

[Visual Basic]
        Dim m_found As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


m_tn Variable

Dim m_tn As TreeNode

Source code

[Visual Basic]
        Dim m_tn As TreeNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


m_uvmzvdokumenttyp Variable

Dim m_uvmzvdokumenttyp As String

Source code

[Visual Basic]
        Dim m_uvmzvdokumenttyp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


x Variable

Dim x As EDOKAMain

Source code

[Visual Basic]
        Dim x As EDOKAMain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDivFnkt


clsarchivfnkt Class

For a list of all members of this type, see clsarchivfnkt Members.

System.Object
EDOKAApp.EDOKA.clsarchivfnkt

Public Class clsarchivfnkt

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsarchivfnkt Members


clsarchivfnkt Members

clsarchivfnkt overview

Properties

property Dokument_Bedingte_Retournierung
property Inkl_Bedingter_Retournierung
property bck

Methods

method Check_Bereits_Archiviert_Bedingte_Retournierung
method DokumentColdIndexWert_Insert
method DokumentColdIndexWert_InsertWert
method Restore_Coldindex
method ToDelete
method change_dokumentid
method check_bereits_archiviert
method copy_indexdata
method copy_indexdata_bedingte_retournierung
method delete_dokumentcoldindexwert
method insert_coldupdate
method insert_coldupdate_reaktivieren
method insert_coldupdate_status
method ist_archiviert
method xxcopy_table

Fields

field BDRDokumentArchiviert
field BLArchiviert
field DeleteDok
field DokumentArchiviert
field m_bck
field m_dokumentidbr
field m_inkl_bedingter_retournierung

See Also

clsarchivfnkt Class


clsarchivfnkt Properties

clsarchivfnkt overview

Properties

property Dokument_Bedingte_Retournierung
property Inkl_Bedingter_Retournierung
property bck

See Also

clsarchivfnkt Class


clsarchivfnkt.Dokument_Bedingte_Retournierung Property

Property Dokument_Bedingte_Retournierung() As String

Source code

[Visual Basic]
        Property Dokument_Bedingte_Retournierung() As String
            Get
                Return m_dokumentidbr
            End Get
            Set(ByVal Value As String)
                m_dokumentidbr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.Inkl_Bedingter_Retournierung Property

Property Inkl_Bedingter_Retournierung() As Boolean

Source code

[Visual Basic]
        Property Inkl_Bedingter_Retournierung() As Boolean
            Get
                Return m_inkl_bedingter_retournierung
            End Get
            Set(ByVal Value As Boolean)
                m_inkl_bedingter_retournierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.bck Property

Property bck() As Boolean

Source code

[Visual Basic]
        Property bck() As Boolean
            Get
                Return m_bck
            End Get
            Set(ByVal Value As Boolean)
                m_bck = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt Methods

clsarchivfnkt overview

Methods

method Check_Bereits_Archiviert_Bedingte_Retournierung
method DokumentColdIndexWert_Insert
method DokumentColdIndexWert_InsertWert
method Restore_Coldindex
method ToDelete
method change_dokumentid
method check_bereits_archiviert
method copy_indexdata
method copy_indexdata_bedingte_retournierung
method delete_dokumentcoldindexwert
method insert_coldupdate
method insert_coldupdate_reaktivieren
method insert_coldupdate_status
method ist_archiviert
method xxcopy_table

See Also

clsarchivfnkt Class


clsarchivfnkt.Check_Bereits_Archiviert_Bedingte_Retournierung Method

Public Function Check_Bereits_Archiviert_Bedingte_Retournierung( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Public Function Check_Bereits_Archiviert_Bedingte_Retournierung(ByVal dokumentid As String) As Boolean
            Globals.dokumentid_changedbr = False
            Dim res As Integer
            res = ist_archiviert(dokumentid)
            If res <> 0 Then
                Check_Bereits_Archiviert_Bedingte_Retournierung = True
                Globals.Dokumentcoldindex_statusbr = ""
                Globals.Dokumentcoldindex_statusbr = "Alt"
                Globals.DokumentID_New_CopyBR = DivFnkt.Generate_Key
                change_dokumentid(dokumentid, Globals.DokumentID_New_CopyBR)
                Globals.Dokumentidaltbr = dokumentid
                dokumentid = Globals.DokumentID_New_CopyBR
                copy_indexdata_bedingte_retournierung(dokumentid, "Alt")
                Globals.Dokumentcoldindex_statusbr = "Alt"
                Globals.dokumentid_changedbr = True
            End If
            Dim da As New SqlDataAdapter("Select count(*) from dokumentersetzen where hauptdokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim ds As New DataSet()
            da.Fill(ds, "Ersetzen")
            Globals.ersetzte_dokumente_reaktivierenbr = False
            Try
                If ds.Tables(0).Rows(0).Item(0) > 0 Then
                    Globals.ersetzte_dokumente_reaktivierenbr = True
                End If
            Catch
            End Try
            da.Dispose()
            ds.Dispose()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.DokumentColdIndexWert_Insert Method

Private Function DokumentColdIndexWert_Insert( _
   ByVal dtOrg As DataTable, _
   ByVal i1 As Integer, _
   ByVal i2 As Integer _
)

Parameters

dtOrg
Required.
i1
Required.
i2
Required.

Source code

[Visual Basic]
        Private Function DokumentColdIndexWert_Insert(ByVal dtOrg As DataTable, ByVal i1 As Integer, ByVal i2 As Integer)
            'Coldindexwerte Inserten mit Daten aus neuer Tabellen Struktur
            Dim i As Integer
            Dim dw As New edokadb.clsDokumentcoldindexwert()
            dw.cpMainConnectionProvider = conn

            Dim lcnt As Integer
            Dim sWert As String
            Dim sFieldArray(12) As String
            sFieldArray(0) = "NRPAR00"
            sFieldArray(1) = "BKPAR00"
            sFieldArray(2) = "NAVVG00"
            sFieldArray(3) = "BEBEZ00"
            sFieldArray(4) = "DMSTA01"
            sFieldArray(5) = "BEDAT00"
            sFieldArray(6) = "BESTA00"
            sFieldArray(7) = "BEORT00"
            sFieldArray(8) = "NRDOC00"
            sFieldArray(9) = "NRSTA00"
            sFieldArray(10) = "BEGSF00"
            sFieldArray(11) = "BEUSR00"
            sFieldArray(12) = "BERES03"

            For i = 0 To dtOrg.Rows.Count - 1
                If (i1 = 1 And dtOrg.Rows(i).Item("indextyp") = 1) Or _
                   (i2 = 1 And dtOrg.Rows(i).Item("indextyp") = 2) Then
                    dw.iIndextyp = New SqlInt32(CType(dtOrg.Rows(i).Item(1), Int32))
                    dw.iMandantnr = New SqlInt32(CType(dtOrg.Rows(i).Item("mandantnr"), Int32))
                    dw.bAktiv = New SqlBoolean(CType(dtOrg.Rows(i).Item("aktiv"), Boolean))
                    dw.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
                    dw.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
                    dw.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                    dw.sDokumentid = New SqlString(CType(dtOrg.Rows(i).Item("dokumentid"), String))

                    For lcnt = 0 To 12
                        If Not dtOrg.Rows(i).Item(sFieldArray(lcnt)) Is System.DBNull.Value Then
                            sWert = CType(dtOrg.Rows(i).Item(sFieldArray(lcnt)), String)
                        Else
                            sWert = ""
                        End If
                        Select Case sFieldArray(lcnt)
                            Case sFieldArray(0)
                                dw.sNRPAR00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(1)
                                dw.sBKPAR00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(2)
                                dw.sNAVVG00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(3)
                                dw.sBEBEZ00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(4)
                                dw.sDMSTA01 = New SqlString(CType(sWert, String))
                            Case sFieldArray(5)
                                dw.sBEDAT00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(6)
                                dw.sBESTA00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(7)
                                dw.sBEORT00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(8)
                                dw.sNRDOC00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(9)
                                dw.sNRSTA00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(10)
                                dw.sBEGSF00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(11)
                                dw.sBEUSR00 = New SqlString(CType(sWert, String))
                            Case sFieldArray(12)
                                dw.sBERES03 = New SqlString(CType(sWert, String))
                        End Select
                    Next
                    conn.OpenConnection()
                    dw.Insert()
                    conn.CloseConnection(True)
                End If
            Next
            dw.Dispose()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.DokumentColdIndexWert_InsertWert Method

Private Function DokumentColdIndexWert_InsertWert( _
   ByVal dtOrg As DataTable _
)

Parameters

dtOrg
Required.

Source code

[Visual Basic]
        Private Function DokumentColdIndexWert_InsertWert(ByVal dtOrg As DataTable)
            'Coldindexwerte Inserten mit Daten aus alter Tabellen Struktur
            Dim i As Integer
            Dim dw As New edokadb.clsDokumentcoldindexwert()
            dw.cpMainConnectionProvider = conn

            Dim lcnt As Integer
            Dim sWert As String
            Dim sFieldArray(12) As String
            sFieldArray(0) = "NRPAR00"
            sFieldArray(1) = "BKPAR00"
            sFieldArray(2) = "NAVVG00"
            sFieldArray(3) = "BEBEZ00"
            sFieldArray(4) = "DMSTA01"
            sFieldArray(5) = "BEDAT00"
            sFieldArray(6) = "BESTA00"
            sFieldArray(7) = "BEORT00"
            sFieldArray(8) = "NRDOC00"
            sFieldArray(9) = "NRSTA00"
            sFieldArray(10) = "BEGSF00"
            sFieldArray(11) = "BEUSR00"
            sFieldArray(12) = "BERES03"

            For i = 0 To dtOrg.Rows.Count - 1
                dw.iIndextyp = New SqlInt32(CType(dtOrg.Rows(i).Item(1), Int32))
                dw.iMandantnr = New SqlInt32(CType(dtOrg.Rows(i).Item("mandantnr"), Int32))
                dw.bAktiv = New SqlBoolean(CType(dtOrg.Rows(i).Item("aktiv"), Boolean))
                dw.daErstellt_am = New SqlDateTime(CType(Now, DateTime))
                dw.daMutiert_am = New SqlDateTime(CType(Now, DateTime))
                dw.iMutierer = New SqlInt32(CType(Globals.MitarbeiterNr, Int32))
                dw.sDokumentid = New SqlString(CType(dtOrg.Rows(i).Item("dokumentid"), String))

                For lcnt = 0 To 12
                    If Not dtOrg.Rows(i).Item(sFieldArray(lcnt)) Is System.DBNull.Value Then
                        sWert = CType(dtOrg.Rows(i).Item(sFieldArray(lcnt)), String)
                    Else
                        sWert = ""
                    End If
                    Select Case sFieldArray(lcnt)
                        Case sFieldArray(0)
                            dw.sNRPAR00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(1)
                            dw.sBKPAR00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(2)
                            dw.sNAVVG00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(3)
                            dw.sBEBEZ00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(4)
                            dw.sDMSTA01 = New SqlString(CType(sWert, String))
                        Case sFieldArray(5)
                            dw.sBEDAT00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(6)
                            dw.sBESTA00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(7)
                            dw.sBEORT00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(8)
                            dw.sNRDOC00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(9)
                            dw.sNRSTA00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(10)
                            dw.sBEGSF00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(11)
                            dw.sBEUSR00 = New SqlString(CType(sWert, String))
                        Case sFieldArray(12)
                            dw.sBERES03 = New SqlString(CType(sWert, String))
                    End Select
                Next
                conn.OpenConnection()
                dw.Insert()
                conn.CloseConnection(True)
            Next
            dw.Dispose()
            'Dim i As Integer
            'Dim dw As New edokadb.clsDokumentcoldindexwert()
            'dw.cpMainConnectionProvider = conn

            'Dim lcnt As Integer
            'Dim sWert As String
            'Dim sFieldArray(12, 1) As String
            'sFieldArray(0, 0) = "NRPAR00"
            'sFieldArray(0, 1) = 1
            'sFieldArray(1, 0) = "BKPAR00"
            'sFieldArray(1, 1) = 2
            'sFieldArray(2, 0) = "NAVVG00"
            'sFieldArray(2, 1) = 3
            'sFieldArray(3, 0) = "BEBEZ00"
            'sFieldArray(3, 1) = 4
            'sFieldArray(4, 0) = "DMSTA01"
            'sFieldArray(4, 1) = 5
            'sFieldArray(5, 0) = "BEDAT00"
            'sFieldArray(5, 1) = 6
            'sFieldArray(6, 0) = "BESTA00"
            'sFieldArray(6, 1) = 7
            'sFieldArray(7, 0) = "BEORT00"
            'sFieldArray(7, 1) = 8
            'sFieldArray(8, 0) = "NRDOC00"
            'sFieldArray(8, 1) = 10
            'sFieldArray(9, 0) = "NRSTA00"
            'sFieldArray(9, 1) = 11
            'sFieldArray(10, 0) = "BEGSF00"
            'sFieldArray(10, 1) = 12
            'sFieldArray(11, 0) = "BEUSR00"
            'sFieldArray(11, 1) = 13
            'sFieldArray(12, 0) = "BERES03"
            'sFieldArray(12, 1) = 20
            ''***********************************************************333
            'Dim dtNew As DataTable
            'dtNew = New DataTable("DokumentColdIndexWerte")
            'Dim Row1 As DataRow
            'Try
            '    dtNew.Columns.Add("iIndextyp", System.Type.GetType("System.integer"))
            '    dtNew.Columns.Add("iMandantnr", System.Type.GetType("System.integer"))
            '    dtNew.Columns.Add("bAktiv", System.Type.GetType("System.Boolean"))
            '    dtNew.Columns.Add("daErstellt_am", System.Type.GetType("System.Datetime"))
            '    dtNew.Columns.Add("daMutiert_am", System.Type.GetType("System.Datetime"))
            '    dtNew.Columns.Add("iMutierer", System.Type.GetType("System.Integer"))
            '    dtNew.Columns.Add("sDokumentid", System.Type.GetType("System.String"))
            '    For lcnt = 0 To 12 Step 1
            '        dtNew.Columns.Add(sFieldArray(lcnt, 0), System.Type.GetType("System.String"))
            '    Next

            '    Dim bRowAdd As Boolean
            '    Dim row As DataRow
            '    For Each row In dtOrg.Rows
            '        Dim dview As New DataView(dtOrg, "iIndextyp" + "=" + Trim(dtOrg.Rows(i).Item("indextyp")), "iIndextyp", DataViewRowState.CurrentRows)
            '        If dview.Count = 0 Then
            '            Row1 = dtNew.NewRow()
            '            Row1.Item("iIndextyp") = dtOrg.Rows(i).Item("indextyp")
            '            Row1.Item("iMandantnr") = dtOrg.Rows(i).Item("mandantnr")
            '            Row1.Item("bAktiv") = dtOrg.Rows(i).Item("aktiv")
            '            Row1.Item("daErstellt_am") = dtOrg.Rows(i).Item("Erstellt_am")
            '            Row1.Item("daMutiert_am") = dtOrg.Rows(i).Item("Mutiert_am")
            '            Row1.Item("iMutierer") = dtOrg.Rows(i).Item("Mutierer")
            '            Row1.Item("sDokumentid") = dtOrg.Rows(i).Item("dokumentid")
            '            dtOrg.Rows.Add(Row1)
            '            bRowAdd = True
            '        Else
            '            bRowAdd = False
            '        End If

            '        Select Case dtOrg.Rows(i).Item("Cold_indexfeldnr")
            '            Case sFieldArray(0, 1)
            '                Row1.Item("iIndextyp") = New SqlString(CType(sWert, String))
            '            Case sFieldArray(1, 1)
            '                dw.sBKPAR00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(2, 1)
            '                dw.sNAVVG00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(3, 1)
            '                dw.sBEBEZ00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(4, 1)
            '                dw.sDMSTA01 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(5, 1)
            '                dw.sBEDAT00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(6, 1)
            '                dw.sBESTA00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(7, 1)
            '                dw.sBEORT00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(8, 1)
            '                dw.sNRDOC00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(9, 1)
            '                dw.sNRSTA00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(10, 1)
            '                dw.sBEGSF00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(11, 1)
            '                dw.sBEUSR00 = New SqlString(CType(sWert, String))
            '            Case sFieldArray(12, 1)
            '                dw.sBERES03 = New SqlString(CType(sWert, String))
            '        End Select

            '        'If Not dtOrg.Rows(i).Item(sFieldArray(lcnt)) Is System.DBNull.Value Then
            '        '    sWert = CType(dtOrg.Rows(i).Item(sFieldArray(lcnt)), String)
            '        'Else
            '        '    sWert = ""
            '        'End If

            '    Next
            'Catch
            '    MsgBox(Err.Description)
            'End Try
            '  dw.Dispose()

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.Restore_Coldindex Method

Public Function Restore_Coldindex( _
   ByVal dt As DataTable, _
   ByVal dokumentid As String _
)

Parameters

dt
Required.
dokumentid
Required.

Source code

[Visual Basic]
        Public Function Restore_Coldindex(ByVal dt As DataTable, ByVal dokumentid As String)
            delete_dokumentcoldindexwert(dokumentid)
            DokumentColdIndexWert_InsertWert(dt)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.ToDelete Method

Public Function ToDelete( _
   ByVal MessageType As Integer, _
   ByVal dokumentid As String _
) As Boolean

Parameters

MessageType
Required.
dokumentid
Required.

Source code

[Visual Basic]
        Public Function ToDelete(ByVal MessageType As Integer, ByVal dokumentid As String) As Boolean
            If MessageType = 0 Then
                Return True
                Exit Function
            End If
            Dim f As New frmDieFrage()
            f.Deletefrage = True
            f.DokumentStatus = MessageType
            f.ShowDialog()
            If f.DialogResult = DialogResult.Abort Then
                Return False
                Exit Function
            End If

            If f.Deletefrage = True Then
                If f.NeueVersion Or f.Loeschung Then
                    Globals.dokumentcoldindex_status = "Alt"
                Else
                    Globals.dokumentcoldindex_status = "Ungültig"
                End If
            End If

            Dim da As New SqlDataAdapter("Select count(*) from dokumentersetzen where hauptdokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim ds As New DataSet()
            da.Fill(ds, "Ersetzen")
            Globals.Ersetzte_Dokumente_Reaktivieren = False
            Try
                If ds.Tables(0).Rows(0).Item(0) > 0 Then
                    Globals.Ersetzte_Dokumente_Reaktivieren = True
                End If
            Catch
            End Try
            da.Dispose()
            ds.Dispose()
            Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.change_dokumentid Method

Public Function change_dokumentid( _
   ByVal dokumentidalt As String, _
   ByVal dokumentidneu As String _
) As String

Parameters

dokumentidalt
Required.
dokumentidneu
Required.

Source code

[Visual Basic]
        Public Function change_dokumentid(ByVal dokumentidalt As String, ByVal dokumentidneu As String) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_change_dokumentid"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentidalt", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentidalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentidneu", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentidneu))
                sdaAdapter.Fill(dtToReturn)
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.check_bereits_archiviert Method

Public Function check_bereits_archiviert( _
   ByVal dokumentid As String, _
   ByVal fordelete As Boolean, _
   Optional ByVal dokstatusnr As Integer = 0 _
) As Boolean

Parameters

dokumentid
Required.
fordelete
Required.
dokstatusnr
Optional. Default value is 0.

Source code

[Visual Basic]
        Public Function check_bereits_archiviert(ByVal dokumentid As String, ByVal fordelete As Boolean, Optional ByVal dokstatusnr As Integer = 0) As Boolean
            Dim res As Integer
            Dim f As New frmDieFrage()

            Me.DokumentArchiviert = 0
            Me.BDRDokumentArchiviert = 0
            DeleteDok = 0
            If fordelete = True Then DeleteDok = 1
            res = ist_archiviert(dokumentid)

            'EDEX Banklagernd
            If fordelete And Me.BLArchiviert > 0 Then
                If MyMsg.Show_MessageYesNoBL(613) = MsgBoxResult.No Then
                    Return False
                Else
                    Globals.dokumentcoldindex_status = "Alt"
                    Return True
                End If
            End If

            If Me.BLArchiviert > 0 Then
                If MyMsg.Show_MessageYesNoBL(614) = MsgBoxResult.No Then
                    Return False
                    Exit Function
                End If

                If f.Deletefrage Then
                    Globals.dokumentcoldindex_status = "Alt"
                Else
                    Globals.DokumentID_New_Copy = DivFnkt.Generate_Key
                    change_dokumentid(dokumentid, Globals.DokumentID_New_Copy)
                    Globals.Dokumentidalt = dokumentid
                    dokumentid = Globals.DokumentID_New_Copy
                    copy_indexdata(dokumentid, "Alt")
                    Globals.dokumentcoldindex_status = "Alt"
                    Globals.dokumentid_changed = True

                    If Me.Inkl_Bedingter_Retournierung = True Then
                        Globals.Dokumentcoldindex_statusbr = "Alt"
                        Globals.DokumentID_New_CopyBR = DivFnkt.Generate_Key
                        change_dokumentid(Me.Dokument_Bedingte_Retournierung, Globals.DokumentID_New_CopyBR)
                        Globals.Dokumentidaltbr = Me.Dokument_Bedingte_Retournierung
                        Me.Dokument_Bedingte_Retournierung = Globals.DokumentID_New_CopyBR
                        copy_indexdata_bedingte_retournierung(Me.Dokument_Bedingte_Retournierung, "Alt")
                        Globals.Dokumentcoldindex_statusbr = "Alt"
                        Globals.dokumentid_changedbr = True
                        Dim da As New SqlDataAdapter("Select count(*) from dokumentersetzen where hauptdokumentid='" & Me.Dokument_Bedingte_Retournierung & "'", Globals.sConnectionString)
                        Dim ds As New DataSet()
                        da.Fill(ds, "Ersetzen")
                        Globals.ersetzte_dokumente_reaktivierenbr = False
                        Try
                            If ds.Tables(0).Rows(0).Item(0) > 0 Then
                                Globals.ersetzte_dokumente_reaktivierenbr = True
                            End If
                        Catch
                        End Try
                        da.Dispose()
                        ds.Dispose()
                    End If
                End If
                Return True
            End If

            If Me.bck = True Then
                MyMsg.show_standardmessage(118, MsgBoxStyle.Information)
                Return False
                Exit Function
            End If

            'Löschen des Dokumentes - Bedingt Retournierbares Dokument wird nicht berücksichtigt
            '            If fordelete And res <> 0 Then
            Globals.DokAnKundeVersant = False
            If fordelete Then
                'Rel 3.6
                If dokstatusnr < -1 Then
                    res = 0
                End If
                If Not ToDelete(res, dokumentid) Then
                    Return False
                    Globals.DokAnKundeVersant = False
                Else
                    Return True
                End If
                Exit Function
            End If

            'Keine Archivierung - Bedingt Retournierbares Dokument archiviert
            If res = 0 And Me.BDRDokumentArchiviert <> 0 Then
                f.Deletefrage = False
                f.DokumentStatus = res
                f.Inkl_Bedingte_Retournierung = True
                f.ShowDialog()
                If f.DialogResult = DialogResult.Abort Then
                    Return False
                    Exit Function
                End If
            End If

            'Archivierung wurde durchgeführt - inkl. Bedingt Retournierbares Dokumente
            If res <> 0 Then
                f.Deletefrage = False
                f.DokumentStatus = res
                f.Inkl_Bedingte_Retournierung = Me.BDRDokumentArchiviert <> 0
                f.ShowDialog()
                If f.DialogResult = DialogResult.Abort Then
                    Return False
                    Exit Function
                End If
            End If

            If res <> 0 Then
                Globals.dokumentcoldindex_status = ""
                If f.Deletefrage = True Then
                    If f.NeueVersion Or f.Loeschung Then
                        Globals.dokumentcoldindex_status = "Alt"
                    Else
                        Globals.dokumentcoldindex_status = "Ungültig"
                    End If
                Else
                    If f.NeueVersion Then
                        Globals.DokumentID_New_Copy = DivFnkt.Generate_Key
                        change_dokumentid(dokumentid, Globals.DokumentID_New_Copy)
                        Globals.Dokumentidalt = dokumentid
                        dokumentid = Globals.DokumentID_New_Copy
                        copy_indexdata(dokumentid, "Alt")
                        Globals.dokumentcoldindex_status = "Alt"
                        Globals.dokumentid_changed = True
                    Else
                        copy_indexdata(dokumentid, "Ungültig")
                        Globals.dokumentcoldindex_status = "Ungültig"
                    End If
                End If

                Dim da As New SqlDataAdapter("Select count(*) from dokumentersetzen where hauptdokumentid='" & dokumentid & "'", Globals.sConnectionString)
                Dim ds As New DataSet()
                da.Fill(ds, "Ersetzen")
                Globals.Ersetzte_Dokumente_Reaktivieren = False
                Try
                    If ds.Tables(0).Rows(0).Item(0) > 0 Then
                        Globals.Ersetzte_Dokumente_Reaktivieren = True
                    End If
                Catch
                End Try
                da.Dispose()
                ds.Dispose()
            End If

            If Me.Inkl_Bedingter_Retournierung = True And Me.BDRDokumentArchiviert <> 0 Then
                Globals.Dokumentcoldindex_statusbr = ""
                Globals.Dokumentcoldindex_statusbr = "Alt"
                Globals.DokumentID_New_CopyBR = DivFnkt.Generate_Key
                change_dokumentid(Me.Dokument_Bedingte_Retournierung, Globals.DokumentID_New_CopyBR)
                Globals.Dokumentidaltbr = Me.Dokument_Bedingte_Retournierung
                Me.Dokument_Bedingte_Retournierung = Globals.DokumentID_New_CopyBR
                copy_indexdata_bedingte_retournierung(Me.Dokument_Bedingte_Retournierung, "Alt")
                Globals.Dokumentcoldindex_statusbr = "Alt"
                Globals.dokumentid_changedbr = True
                Dim da As New SqlDataAdapter("Select count(*) from dokumentersetzen where hauptdokumentid='" & Me.Dokument_Bedingte_Retournierung & "'", Globals.sConnectionString)
                Dim ds As New DataSet()
                da.Fill(ds, "Ersetzen")
                Globals.ersetzte_dokumente_reaktivierenbr = False
                Try
                    If ds.Tables(0).Rows(0).Item(0) > 0 Then
                        Globals.ersetzte_dokumente_reaktivierenbr = True
                    End If
                Catch
                End Try
                da.Dispose()
                ds.Dispose()
            End If
            Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.copy_indexdata Method

Private Sub copy_indexdata( _
   ByVal dokumentid As String, _
   ByVal Status As String _
)

Parameters

dokumentid
Required.
Status
Required.

Source code

[Visual Basic]
        Private Sub copy_indexdata(ByVal dokumentid As String, ByVal Status As String)
            Dim sda As New SqlDataAdapter("select * from dokumentcoldindexwert where (indextyp=1 or indextyp=2) and dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim sda1 As New SqlDataAdapter("select * from dokumentcoldindexwert where dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim sda3 As New SqlDataAdapter("select max(indextyp) from dokumentcoldindexwert where dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim ds As New DataSet()
            Globals.general_ds.Clear()
            sda.Fill(ds, "Dokumentcoldindexwert")
            sda1.Fill(Globals.general_ds, "Dokumentcoldindexwert")
            Globals.Dokumentcoldindex_Changed = True
            sda.Fill(ds, "DokumentcoldindexwertNeu")
            sda3.Fill(ds, "Maxwert")
            Dim i As Integer
            Dim Maxwert As Integer
            Maxwert = ds.Tables(2).Rows(0).Item(0)
            If Maxwert < 2 Then Maxwert = 2
            Dim i1 As Integer
            Dim i2 As Integer
            i1 = 0
            i2 = 0
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If (ds.Tables(0).Rows(i).Item("BESTA00") = "Aktuell" Or ds.Tables(0).Rows(i).Item("BESTA00") = "Alt") Then
                        If ds.Tables(0).Rows(i).Item("indextyp") = 1 Then i1 = 1
                        If ds.Tables(0).Rows(i).Item("indextyp") = 2 Then i2 = 1
                    End If
                End If
            Next
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(0).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(0).Rows(i).Item("indextyp") = Maxwert + 1
                        ds.Tables(0).Rows(i).Item("BESTA00") = Status
                    End If
                    If i2 = 1 And ds.Tables(0).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(0).Rows(i).Item("indextyp") = Maxwert + 2
                        ds.Tables(0).Rows(i).Item("BESTA00") = Status
                    End If
                End If
            Next
            For i = 0 To ds.Tables(1).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("BESTA00") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("BESTA00") = ""
                    End If
                End If
                If Not ds.Tables(0).Rows(i).Item("DMSTA01") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("DMSTA01") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("DMSTA01") = ""
                    End If
                End If
                If Not ds.Tables(0).Rows(i).Item("NRDOC00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("NRDOC00") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("NRDOC00") = ""
                    End If
                End If
            Next
            Dim cd As New SqlCommandBuilder(sda)
            sda.Update(ds, "Dokumentcoldindexwert")

            DokumentColdIndexWert_Insert(ds.Tables(1), i1, i2)

            sda.Dispose()
            sda1.Dispose()
            sda3.Dispose()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.copy_indexdata_bedingte_retournierung Method

Private Sub copy_indexdata_bedingte_retournierung( _
   ByVal dokumentid As String, _
   ByVal Status As String _
)

Parameters

dokumentid
Required.
Status
Required.

Source code

[Visual Basic]
        Private Sub copy_indexdata_bedingte_retournierung(ByVal dokumentid As String, ByVal Status As String)
            Dim sda As New SqlDataAdapter("select * from dokumentcoldindexwert where (indextyp=1 or indextyp=2) and dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim sda1 As New SqlDataAdapter("select * from dokumentcoldindexwert where  dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim sda3 As New SqlDataAdapter("select max(indextyp) from dokumentcoldindexwert where dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim ds As New DataSet()
            Globals.general_dsbr.Clear()
            sda.Fill(ds, "Dokumentcoldindexwert")
            sda1.Fill(Globals.general_dsbr, "Dokumentcoldindexwert")
            Globals.DokumentColdIndex_ChangedBR = True
            sda.Fill(ds, "DokumentcoldindexwertNeu")
            sda3.Fill(ds, "Maxwert")
            Dim i As Integer
            Dim Maxwert As Integer
            Maxwert = ds.Tables(2).Rows(0).Item(0)
            If Maxwert < 2 Then Maxwert = 2
            Dim i1 As Integer
            Dim i2 As Integer
            i1 = 0
            i2 = 0
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If (ds.Tables(0).Rows(i).Item("BESTA00") = "Aktuell" Or ds.Tables(0).Rows(i).Item("BESTA00") = "Alt") Then
                        If ds.Tables(0).Rows(i).Item("indextyp") = 1 Then i1 = 1
                        If ds.Tables(0).Rows(i).Item("indextyp") = 2 Then i2 = 1
                    End If
                End If
            Next
            For i = 0 To ds.Tables(0).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(0).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(0).Rows(i).Item("indextyp") = Maxwert + 1
                        ds.Tables(0).Rows(i).Item("BESTA00") = Status
                    End If
                    If i2 = 1 And ds.Tables(0).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(0).Rows(i).Item("indextyp") = Maxwert + 2
                        ds.Tables(0).Rows(i).Item("BESTA00") = Status
                    End If
                End If
            Next
            For i = 0 To ds.Tables(1).Rows.Count - 1
                If Not ds.Tables(0).Rows(i).Item("BESTA00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("BESTA00") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("BESTA00") = ""
                    End If
                End If
                If Not ds.Tables(0).Rows(i).Item("DMSTA01") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("DMSTA01") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("DMSTA01") = ""
                    End If
                End If
                If Not ds.Tables(0).Rows(i).Item("NRDOC00") Is System.DBNull.Value Then
                    If i1 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 1 Then
                        ds.Tables(1).Rows(i).Item("NRDOC00") = ""
                    End If
                    If i2 = 1 And ds.Tables(1).Rows(i).Item("indextyp") = 2 Then
                        ds.Tables(1).Rows(i).Item("NRDOC00") = ""
                    End If
                End If
            Next
            Dim cd As New SqlCommandBuilder(sda)
            sda.Update(ds, "Dokumentcoldindexwert")

            DokumentColdIndexWert_Insert(ds.Tables(1), i1, i2)

            sda.Dispose()
            sda3.Dispose()
            sda1.Dispose()
            ds.Dispose()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.delete_dokumentcoldindexwert Method

Private Function delete_dokumentcoldindexwert( _
   ByVal dokumentid As String _
) As Boolean

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Private Function delete_dokumentcoldindexwert(ByVal dokumentid As String) As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_delete_dokumentcoldindexwert"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                sdaAdapter.Fill(dtToReturn)
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.insert_coldupdate Method

Public Function insert_coldupdate( _
   ByVal feldname As String, _
   ByVal colddokumentid As String, _
   ByVal dokumentid As String, _
   ByVal alterwert As String, _
   ByVal neuerwert As String _
)

Parameters

feldname
Required.
colddokumentid
Required.
dokumentid
Required.
alterwert
Required.
neuerwert
Required.

Source code

[Visual Basic]
        Public Function insert_coldupdate(ByVal feldname As String, ByVal colddokumentid As String, ByVal dokumentid As String, ByVal alterwert As String, ByVal neuerwert As String)
            If colddokumentid = "" Then Exit Function
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_insert_coldupdate"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@feldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, feldname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@colddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, colddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@alterwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, alterwert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@neuerwert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, neuerwert))
                sdaAdapter.Fill(dtToReturn)
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.insert_coldupdate_reaktivieren Method

Public Function insert_coldupdate_reaktivieren( _
   ByVal dt As DataTable, _
   ByVal dokumentid As String, _
   ByVal neuerstatus As String _
)

Parameters

dt
Required.
dokumentid
Required.
neuerstatus
Required.

Source code

[Visual Basic]
        Public Function insert_coldupdate_reaktivieren(ByVal dt As DataTable, ByVal dokumentid As String, ByVal neuerstatus As String)
            Dim i As Integer
            Dim colddokumentid As String
            Dim neuerwert As String
            Dim indextyp1 As Integer
            Dim indextyp As Integer
            indextyp = 1
            indextyp1 = 1
            colddokumentid = ""
            For i = 0 To dt.Rows.Count - 1
                If dt.Rows(i).Item("indextyp") = 2 Then indextyp1 = 2
            Next
            For i = 0 To dt.Rows.Count - 1
                If dt.Rows(i).Item("indextyp") = indextyp1 Then
                    If dt.Rows(i).Item("cold_indexfeldnr") = 10 Then colddokumentid = dt.Rows(i).Item("WERT")
                End If
            Next
            insert_coldupdate("BESTA00", colddokumentid, dokumentid, "Aktuell", neuerstatus)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.insert_coldupdate_status Method

Public Function insert_coldupdate_status( _
   ByVal dt As DataTable, _
   ByVal dokumentid As String, _
   ByVal neuerstatus As String _
)

Parameters

dt
Required.
dokumentid
Required.
neuerstatus
Required.

Source code

[Visual Basic]
        Public Function insert_coldupdate_status(ByVal dt As DataTable, ByVal dokumentid As String, ByVal neuerstatus As String)
            Dim i As Integer
            Dim colddokumentid As String
            Dim neuerwert As String
            Dim indextyp As Integer
            indextyp = 1
            colddokumentid = ""
            For i = 0 To dt.Rows.Count - 1
                If dt.Columns.Count < 20 Then
                    If dt.Rows(i).Item("cold_indexfeldnr") = 10 Then colddokumentid = dt.Rows(i).Item("WERT")
                    If dt.Rows(i).Item("indextyp") <> indextyp Then
                        insert_coldupdate("BESTA00", colddokumentid, dokumentid, "Aktuell", neuerstatus)
                        indextyp = dt.Rows(i).Item("indextyp")
                    End If
                Else
                    colddokumentid = dt.Rows(i).Item("NRDOC00")
                    If dt.Rows(i).Item("indextyp") <> indextyp Then
                        insert_coldupdate("BESTA00", colddokumentid, dokumentid, "Aktuell", neuerstatus)
                        indextyp = dt.Rows(i).Item("indextyp")
                    End If
                End If
            Next
            insert_coldupdate("BESTA00", colddokumentid, dokumentid, "Aktuell", neuerstatus)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.ist_archiviert Method

Public Function ist_archiviert( _
   ByVal dokumentid As String _
) As Integer

Parameters

dokumentid
Required.

Source code

[Visual Basic]
        Public Function ist_archiviert(ByVal dokumentid As String) As Integer
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim i As Integer
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            scmCmdToExecute.CommandText = "dbo.sp_dokument_bereits_archiviert"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdrarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                ' EDEX Banklagernd
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blarchiviert", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bldelete", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DeleteDok))
                sdaAdapter.Fill(dtToReturn)
                i = scmCmdToExecute.Parameters.Item("@istarchiviert").Value
                ist_archiviert = i
                Me.DokumentArchiviert = scmCmdToExecute.Parameters.Item("@istarchiviert").Value
                Me.BDRDokumentArchiviert = scmCmdToExecute.Parameters.Item("@bdrarchiviert").Value
                Me.BLArchiviert = scmCmdToExecute.Parameters.Item("@blarchiviert").Value
            Catch ex As Exception
                'MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("Dokument_Information_Wert::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
            Finally
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt.xxcopy_table Method

Private Sub xxcopy_table( _
   ByVal tablename As String, _
   ByVal dokumentid As String _
)

Parameters

tablename
Required.
dokumentid
Required.

Source code

[Visual Basic]
        Private Sub xxcopy_table(ByVal tablename As String, ByVal dokumentid As String)
            Dim sda1 As New SqlDataAdapter("Select * from dokumentcoldindexwert dokumentid='" & dokumentid & "'", Globals.sConnectionString)
            Dim sda2 As New SqlDataAdapter("Select * from dokumentcoldindexwert where dokumentid='-1'", Globals.sConnectionString)
            Dim sdt1 As New DataSet()
            Dim sdt2 As New DataSet()
            Dim i As Integer
            Dim i1 As Integer
            sda1.Fill(sdt1, "Dokument")
            sda2.Fill(sdt2, "Dokument")

            For i1 = 0 To sdt1.Tables(0).Rows.Count - 1
                Dim sdt As DataTable = sdt2.Tables(0)
                Dim dbrow As DataRow = sdt.NewRow
                For i = 1 To sdt1.Tables(0).Columns.Count - 1
                    dbrow(i) = sdt1.Tables(0).Rows(i1).Item(i)
                    If sdt1.Tables(0).Columns(i).ColumnName = "dokumentid" Then dbrow(i) = Globals.DokumentID_New_Copy
                    If sdt1.Tables(0).Columns(i).ColumnName = "dokumenitid" Then dbrow(i) = Globals.DokumentID_New_Copy
                    If sdt1.Tables(0).Columns(i).ColumnName = "dokumentid1" Then dbrow(i) = Globals.DokumentID_New_Copy
                Next
                sdt.Rows.Add(dbrow)
                Dim cb As New SqlCommandBuilder(sda2)
                sda2.Update(sdt2, "Dokument")
                cb.Dispose()
                sdt.Dispose()
                dbrow = Nothing
                sdt2.Tables(0).Rows.Clear()
            Next
            sdt2.Dispose()
            sda2.Dispose()
            sda1.Dispose()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


clsarchivfnkt Fields

clsarchivfnkt overview

Fields

field BDRDokumentArchiviert
field BLArchiviert
field DeleteDok
field DokumentArchiviert
field m_bck
field m_dokumentidbr
field m_inkl_bedingter_retournierung

See Also

clsarchivfnkt Class


BDRDokumentArchiviert Variable

Dim BDRDokumentArchiviert As Integer

Source code

[Visual Basic]
        Dim BDRDokumentArchiviert As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


BLArchiviert Variable

Dim BLArchiviert As Integer

Source code

[Visual Basic]
        Dim BLArchiviert As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


DeleteDok Variable

Dim DeleteDok As Integer = 0

Source code

[Visual Basic]
        Dim DeleteDok As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


DokumentArchiviert Variable

Dim DokumentArchiviert As Integer

Source code

[Visual Basic]
        Dim DokumentArchiviert As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


m_bck Variable

Dim m_bck As Boolean = False

Source code

[Visual Basic]
        Dim m_bck As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


m_dokumentidbr Variable

Dim m_dokumentidbr As String = ""

Source code

[Visual Basic]
        Dim m_dokumentidbr As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


m_inkl_bedingter_retournierung Variable

Dim m_inkl_bedingter_retournierung As Boolean = False

Source code

[Visual Basic]
        Dim m_inkl_bedingter_retournierung As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsarchivfnkt


frmRelEditor Class

For a list of all members of this type, see frmRelEditor Members.

System.Object
System.Windows.Forms.Form
EDOKAApp.EDOKA.frmRelEditor
EDOKAApp.FrmFunktionsgruppe_Reportgruppe
EDOKAApp.frmAuswertungsgruppeReports
EDOKAApp.frmFunktionsgruppeRolle
EDOKAApp.frmIDVMakroOfficeVorlage
EDOKAApp.frmKostenstelle
EDOKAApp.frmMitarbeiterFunktionsgruppe
EDOKAApp.frmMitarbeiterRolle
EDOKAApp.frmNLDokumente
EDOKAApp.frmReportFelder
EDOKAApp.frmReport_reportfeldregel
EDOKAApp.frmReportgruppe_Report
EDOKAApp.frmRolleBerechtigung
EDOKAApp.frmRolleReportGruppe
EDOKAApp.frmRolle_Sysadminfunktion
EDOKAApp.frmStatustypStatusbezeichnung
EDOKAApp.frmcoldindx

Public Class frmRelEditor
   Inherits System.Windows.Forms.Form

Requirements

Namespace: EDOKA

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

frmRelEditor Members


frmRelEditor Members

frmRelEditor overview

Constructors

constructor frmRelEditor Constructor

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

Methods

method BtnConnect_Click_1
method C1TrueDBGrid1_FetchCellTips
method C1TrueDBGrid1_FetchCellTips1
method C1TrueDBGrid1_FetchCellTips3
method Dispose
method FormSize
method InitializeComponent
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBLeft_FetchScrollTips
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method frmVerbEditor_Cloase
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

Fields

field BtnConnect
field FokusLeft
field FokusRight
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Splitter1
field Splitter2
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRelEditor Class


frmRelEditor Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()

            MyBase.New()

            ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
            InitializeComponent()

            ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor Properties

frmRelEditor overview

Properties

property Eintrag
property Eintragnr
property KeyLeft
property KeyRight
property TableNameBottom
property TableNameLeft
property TableNameRight

See Also

frmRelEditor Class


frmRelEditor Methods

frmRelEditor overview

Methods

method BtnConnect_Click_1
method C1TrueDBGrid1_FetchCellTips
method C1TrueDBGrid1_FetchCellTips1
method C1TrueDBGrid1_FetchCellTips3
method Dispose
method FormSize
method InitializeComponent
method SpaltenTitel_Aktualisieren
method Splitter1_SplitterMoved
method Splitter2_SplitterMoved
method TBBottom_FetchScrollTips
method TBBottom_Format
method TBLeft_FetchScrollTips
method TBRight_FetchScrollTips
method ToolBar1_ButtonClick
method UpdateGrpText
method frmVerbEditor_Cloase
method frmVerbEditor_Layout
method frmVerbEditor_Load
method frmVerbEditor_WndChange

See Also

frmRelEditor Class


frmRelEditor.BtnConnect_Click_1 Method

Private Sub BtnConnect_Click_1( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles BtnConnect.Click

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub BtnConnect_Click_1(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles BtnConnect.Click

        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.C1TrueDBGrid1_FetchCellTips Method

Private Sub C1TrueDBGrid1_FetchCellTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles TBLeft.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub C1TrueDBGrid1_FetchCellTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles TBLeft.FetchCellTips
            Dim ts As New EDOKA.Tabellenspalte()
            ts.Tabelle = Me.TableNameLeft
            Try
                ts.Feld = Me.TBLeft.Columns(e.ColIndex).DataField
                ts.getspalte()
                e.CellTip = ts.TipText
                ts = Nothing
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.C1TrueDBGrid1_FetchCellTips1 Method

Private Sub C1TrueDBGrid1_FetchCellTips1( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles TBRight.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub C1TrueDBGrid1_FetchCellTips1(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles TBRight.FetchCellTips
            Try
                Dim ts As New EDOKA.Tabellenspalte()
                ts.Tabelle = Me.TableNameRight
                ts.Feld = Me.TBRight.Columns(e.ColIndex).DataField
                ts.getspalte()
                e.CellTip = ts.TipText
                ts = Nothing
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.C1TrueDBGrid1_FetchCellTips3 Method

Private Sub C1TrueDBGrid1_FetchCellTips3( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs _
) Handles TBBottom.FetchCellTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub C1TrueDBGrid1_FetchCellTips3(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchCellTipsEventArgs) Handles TBBottom.FetchCellTips
            Try
                Dim ts As New EDOKA.Tabellenspalte()
                ts.Tabelle = Me.TableNameBottom
                ts.Feld = Me.TBBottom.Columns(e.ColIndex).DataField
                ts.getspalte()
                e.CellTip = ts.TipText
                ts = Nothing
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.Dispose Method

Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)

Parameters

disposing
Required.

Source code

[Visual Basic]
        Protected Overloads Overrides Sub Dispose(ByVal disposing As Boolean)
            If disposing Then
                If Not (components Is Nothing) Then
                    components.Dispose()
                End If
            End If
            MyBase.Dispose(disposing)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.InitializeComponent Method

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

Source code

[Visual Basic]
        <System.Diagnostics.DebuggerStepThrough()> Private Sub InitializeComponent()
            Me.components = New System.ComponentModel.Container()
            Dim resources As System.Resources.ResourceManager = New System.Resources.ResourceManager(GetType(frmRelEditor))
            Dim GridLines1 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
            Dim GridLines2 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
            Dim GridLines3 As C1.Win.C1TrueDBGrid.Util.GridLines = New C1.Win.C1TrueDBGrid.Util.GridLines()
            Me.ToolBar1 = New System.Windows.Forms.ToolBar()
            Me.ToolBarButton1 = New System.Windows.Forms.ToolBarButton()
            Me.ToolBarBtnSave = New System.Windows.Forms.ToolBarButton()
            Me.ImageList1 = New System.Windows.Forms.ImageList(Me.components)
            Me.Panel1 = New System.Windows.Forms.Panel()
            Me.Panel2 = New System.Windows.Forms.Panel()
            Me.GrpRight = New System.Windows.Forms.GroupBox()
            Me.TBRight = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
            Me.Splitter1 = New System.Windows.Forms.Splitter()
            Me.GrpLeft = New System.Windows.Forms.GroupBox()
            Me.TBLeft = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
            Me.Splitter2 = New System.Windows.Forms.Splitter()
            Me.GrpFocus = New System.Windows.Forms.GroupBox()
            Me.Label1 = New System.Windows.Forms.Label()
            Me.FokusRight = New System.Windows.Forms.RadioButton()
            Me.FokusLeft = New System.Windows.Forms.RadioButton()
            Me.Panel3 = New System.Windows.Forms.Panel()
            Me.GrpBottom = New System.Windows.Forms.GroupBox()
            Me.TBBottom = New C1.Win.C1TrueDBGrid.C1TrueDBGrid()
            Me.Panel5 = New System.Windows.Forms.Panel()
            Me.BtnConnect = New System.Windows.Forms.Button()
            Me.Panel4 = New System.Windows.Forms.Panel()
            Me.MainMenu1 = New System.Windows.Forms.MainMenu()
            Me.MenuItem1 = New System.Windows.Forms.MenuItem()
            Me.MenuItem3 = New System.Windows.Forms.MenuItem()
            Me.MenuItem2 = New System.Windows.Forms.MenuItem()
            Me.Panel2.SuspendLayout()
            Me.GrpRight.SuspendLayout()
            CType(Me.TBRight, System.ComponentModel.ISupportInitialize).BeginInit()
            Me.GrpLeft.SuspendLayout()
            CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).BeginInit()
            Me.GrpFocus.SuspendLayout()
            Me.Panel3.SuspendLayout()
            Me.GrpBottom.SuspendLayout()
            CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).BeginInit()
            Me.Panel5.SuspendLayout()
            Me.SuspendLayout()
            '
            'ToolBar1
            '
            Me.ToolBar1.Buttons.AddRange(New System.Windows.Forms.ToolBarButton() {Me.ToolBarButton1, Me.ToolBarBtnSave})
            Me.ToolBar1.DropDownArrows = True
            Me.ToolBar1.ImageList = Me.ImageList1
            Me.ToolBar1.Name = "ToolBar1"
            Me.ToolBar1.ShowToolTips = True
            Me.ToolBar1.Size = New System.Drawing.Size(712, 25)
            Me.ToolBar1.TabIndex = 0
            '
            'ToolBarButton1
            '
            Me.ToolBarButton1.ImageIndex = 0
            '
            'ToolBarBtnSave
            '
            Me.ToolBarBtnSave.ImageIndex = 1
            '
            'ImageList1
            '
            Me.ImageList1.ColorDepth = System.Windows.Forms.ColorDepth.Depth8Bit
            Me.ImageList1.ImageSize = New System.Drawing.Size(16, 16)
            Me.ImageList1.ImageStream = CType(resources.GetObject("ImageList1.ImageStream"), System.Windows.Forms.ImageListStreamer)
            Me.ImageList1.TransparentColor = System.Drawing.Color.Transparent
            '
            'Panel1
            '
            Me.Panel1.Dock = System.Windows.Forms.DockStyle.Top
            Me.Panel1.Location = New System.Drawing.Point(0, 25)
            Me.Panel1.Name = "Panel1"
            Me.Panel1.Size = New System.Drawing.Size(712, 16)
            Me.Panel1.TabIndex = 1
            '
            'Panel2
            '
            Me.Panel2.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpRight, Me.Splitter1, Me.GrpLeft})
            Me.Panel2.Dock = System.Windows.Forms.DockStyle.Top
            Me.Panel2.Location = New System.Drawing.Point(0, 41)
            Me.Panel2.Name = "Panel2"
            Me.Panel2.Size = New System.Drawing.Size(712, 199)
            Me.Panel2.TabIndex = 2
            '
            'GrpRight
            '
            Me.GrpRight.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBRight})
            Me.GrpRight.Dock = System.Windows.Forms.DockStyle.Fill
            Me.GrpRight.Location = New System.Drawing.Point(315, 0)
            Me.GrpRight.Name = "GrpRight"
            Me.GrpRight.Size = New System.Drawing.Size(397, 199)
            Me.GrpRight.TabIndex = 2
            Me.GrpRight.TabStop = False
            Me.GrpRight.Text = "GroupBox2"
            '
            'TBRight
            '
            Me.TBRight.AllowFilter = True
            Me.TBRight.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
            Me.TBRight.AllowSort = True
            Me.TBRight.AllowUpdate = False
            Me.TBRight.AlternatingRows = True
            Me.TBRight.CaptionHeight = 17
            Me.TBRight.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
            Me.TBRight.CollapseColor = System.Drawing.Color.Black
            Me.TBRight.DataChanged = False
            Me.TBRight.DeadAreaBackColor = System.Drawing.Color.Gray
            Me.TBRight.Dock = System.Windows.Forms.DockStyle.Fill
            Me.TBRight.ExpandColor = System.Drawing.Color.Black
            Me.TBRight.FilterBar = True
            Me.TBRight.GroupByCaption = "Drag a column header here to group by that column"
            Me.TBRight.Images.Add(CType(resources.GetObject("resource.Images"), System.Drawing.Bitmap))
            Me.TBRight.Location = New System.Drawing.Point(3, 16)
            Me.TBRight.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
            Me.TBRight.Name = "TBRight"
            Me.TBRight.PreviewInfo.Location = New System.Drawing.Point(0, 0)
            Me.TBRight.PreviewInfo.Size = New System.Drawing.Size(0, 0)
            Me.TBRight.PreviewInfo.ZoomFactor = 75
            Me.TBRight.PrintInfo.ShowOptionsDialog = False
            Me.TBRight.RecordSelectorWidth = 16
            GridLines1.Color = System.Drawing.Color.DarkGray
            GridLines1.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
            Me.TBRight.RowDivider = GridLines1
            Me.TBRight.RowHeight = 15
            Me.TBRight.RowSubDividerColor = System.Drawing.Color.DarkGray
            Me.TBRight.ScrollTips = False
            Me.TBRight.Size = New System.Drawing.Size(391, 180)
            Me.TBRight.TabIndex = 8
            Me.TBRight.Text = "C1TrueDBGrid1"
            Me.TBRight.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
            "r""><Data>Group{BackColor:ControlDark;Border:None,,0, 0, 0, 0;AlignVert:Center;}E" & _
            "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
            "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
            "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
            "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
            "lor:Highlight;}Style9{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
            ":Center;}Heading{Wrap:True;AlignVert:Center;Border:Raised,,1, 1, 1, 1;ForeColor:" & _
            "ControlText;BackColor:Control;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
            "}Style13{}Style1{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
            " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
            "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWi" & _
            "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
            "ClientRect>0, 0, 387, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
            "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
            "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
            "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
            """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
            "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
            "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
            "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
            "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
            "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
            "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
            """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
            "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
            "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
            "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
            """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
            "rzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Client" & _
            "Area>0, 0, 387, 176</ClientArea></Blob>"
            '
            'Splitter1
            '
            Me.Splitter1.Location = New System.Drawing.Point(312, 0)
            Me.Splitter1.Name = "Splitter1"
            Me.Splitter1.Size = New System.Drawing.Size(3, 199)
            Me.Splitter1.TabIndex = 1
            Me.Splitter1.TabStop = False
            '
            'GrpLeft
            '
            Me.GrpLeft.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBLeft})
            Me.GrpLeft.Dock = System.Windows.Forms.DockStyle.Left
            Me.GrpLeft.Name = "GrpLeft"
            Me.GrpLeft.Size = New System.Drawing.Size(312, 199)
            Me.GrpLeft.TabIndex = 0
            Me.GrpLeft.TabStop = False
            Me.GrpLeft.Text = "GroupBox1"
            '
            'TBLeft
            '
            Me.TBLeft.AllowFilter = True
            Me.TBLeft.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
            Me.TBLeft.AllowSort = True
            Me.TBLeft.AllowUpdate = False
            Me.TBLeft.AlternatingRows = True
            Me.TBLeft.CaptionHeight = 17
            Me.TBLeft.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
            Me.TBLeft.CollapseColor = System.Drawing.Color.Black
            Me.TBLeft.DataChanged = False
            Me.TBLeft.DeadAreaBackColor = System.Drawing.Color.Gray
            Me.TBLeft.Dock = System.Windows.Forms.DockStyle.Fill
            Me.TBLeft.ExpandColor = System.Drawing.Color.Black
            Me.TBLeft.FilterBar = True
            Me.TBLeft.GroupByCaption = "Drag a column header here to group by that column"
            Me.TBLeft.Images.Add(CType(resources.GetObject("resource.Images1"), System.Drawing.Bitmap))
            Me.TBLeft.Location = New System.Drawing.Point(3, 16)
            Me.TBLeft.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
            Me.TBLeft.Name = "TBLeft"
            Me.TBLeft.PreviewInfo.Location = New System.Drawing.Point(0, 0)
            Me.TBLeft.PreviewInfo.Size = New System.Drawing.Size(0, 0)
            Me.TBLeft.PreviewInfo.ZoomFactor = 75
            Me.TBLeft.PrintInfo.ShowOptionsDialog = False
            Me.TBLeft.RecordSelectorWidth = 16
            GridLines2.Color = System.Drawing.Color.DarkGray
            GridLines2.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
            Me.TBLeft.RowDivider = GridLines2
            Me.TBLeft.RowHeight = 15
            Me.TBLeft.RowSubDividerColor = System.Drawing.Color.DarkGray
            Me.TBLeft.ScrollTips = False
            Me.TBLeft.Size = New System.Drawing.Size(306, 180)
            Me.TBLeft.TabIndex = 8
            Me.TBLeft.Text = "C1TrueDBGrid1"
            Me.TBLeft.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
            "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
            "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
            "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
            "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
            "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
            "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
            ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
            ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
            "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
            " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
            "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWi" & _
            "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
            "ClientRect>0, 0, 302, 176</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
            "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
            "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
            "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
            """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
            "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
            "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
            "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
            "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
            "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
            "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
            """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
            "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
            "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
            "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
            """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
            "rzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Client" & _
            "Area>0, 0, 302, 176</ClientArea></Blob>"
            '
            'Splitter2
            '
            Me.Splitter2.Dock = System.Windows.Forms.DockStyle.Top
            Me.Splitter2.Location = New System.Drawing.Point(0, 240)
            Me.Splitter2.Name = "Splitter2"
            Me.Splitter2.Size = New System.Drawing.Size(712, 3)
            Me.Splitter2.TabIndex = 3
            Me.Splitter2.TabStop = False
            '
            'GrpFocus
            '
            Me.GrpFocus.Controls.AddRange(New System.Windows.Forms.Control() {Me.Label1, Me.FokusRight, Me.FokusLeft})
            Me.GrpFocus.Location = New System.Drawing.Point(216, 0)
            Me.GrpFocus.Name = "GrpFocus"
            Me.GrpFocus.Size = New System.Drawing.Size(200, 32)
            Me.GrpFocus.TabIndex = 17
            Me.GrpFocus.TabStop = False
            '
            'Label1
            '
            Me.Label1.Location = New System.Drawing.Point(78, 13)
            Me.Label1.Name = "Label1"
            Me.Label1.Size = New System.Drawing.Size(48, 16)
            Me.Label1.TabIndex = 2
            Me.Label1.Text = "Fokus"
            '
            'FokusRight
            '
            Me.FokusRight.Location = New System.Drawing.Point(176, 12)
            Me.FokusRight.Name = "FokusRight"
            Me.FokusRight.Size = New System.Drawing.Size(16, 16)
            Me.FokusRight.TabIndex = 1
            '
            'FokusLeft
            '
            Me.FokusLeft.Location = New System.Drawing.Point(9, 13)
            Me.FokusLeft.Name = "FokusLeft"
            Me.FokusLeft.Size = New System.Drawing.Size(104, 16)
            Me.FokusLeft.TabIndex = 0
            '
            'Panel3
            '
            Me.Panel3.Controls.AddRange(New System.Windows.Forms.Control() {Me.GrpBottom, Me.Panel5, Me.Panel4})
            Me.Panel3.Dock = System.Windows.Forms.DockStyle.Fill
            Me.Panel3.Location = New System.Drawing.Point(0, 243)
            Me.Panel3.Name = "Panel3"
            Me.Panel3.Size = New System.Drawing.Size(712, 262)
            Me.Panel3.TabIndex = 18
            '
            'GrpBottom
            '
            Me.GrpBottom.Controls.AddRange(New System.Windows.Forms.Control() {Me.TBBottom})
            Me.GrpBottom.Dock = System.Windows.Forms.DockStyle.Fill
            Me.GrpBottom.Location = New System.Drawing.Point(0, 40)
            Me.GrpBottom.Name = "GrpBottom"
            Me.GrpBottom.Size = New System.Drawing.Size(712, 182)
            Me.GrpBottom.TabIndex = 2
            Me.GrpBottom.TabStop = False
            Me.GrpBottom.Text = "GroupBox1"
            '
            'TBBottom
            '
            Me.TBBottom.AllowFilter = True
            Me.TBBottom.AllowRowSizing = C1.Win.C1TrueDBGrid.RowSizingEnum.AllRows
            Me.TBBottom.AllowSort = True
            Me.TBBottom.AlternatingRows = True
            Me.TBBottom.CaptionHeight = 17
            Me.TBBottom.CellTips = C1.Win.C1TrueDBGrid.CellTipEnum.Anchored
            Me.TBBottom.CollapseColor = System.Drawing.Color.Black
            Me.TBBottom.DataChanged = False
            Me.TBBottom.DeadAreaBackColor = System.Drawing.Color.Gray
            Me.TBBottom.Dock = System.Windows.Forms.DockStyle.Fill
            Me.TBBottom.ExpandColor = System.Drawing.Color.Black
            Me.TBBottom.FilterBar = True
            Me.TBBottom.GroupByCaption = "Drag a column header here to group by that column"
            Me.TBBottom.Images.Add(CType(resources.GetObject("resource.Images2"), System.Drawing.Bitmap))
            Me.TBBottom.Location = New System.Drawing.Point(3, 16)
            Me.TBBottom.MarqueeStyle = C1.Win.C1TrueDBGrid.MarqueeEnum.SolidCellBorder
            Me.TBBottom.Name = "TBBottom"
            Me.TBBottom.PreviewInfo.Location = New System.Drawing.Point(0, 0)
            Me.TBBottom.PreviewInfo.Size = New System.Drawing.Size(0, 0)
            Me.TBBottom.PreviewInfo.ZoomFactor = 75
            Me.TBBottom.PrintInfo.ShowOptionsDialog = False
            Me.TBBottom.RecordSelectorWidth = 16
            GridLines3.Color = System.Drawing.Color.DarkGray
            GridLines3.Style = C1.Win.C1TrueDBGrid.LineStyleEnum.Single
            Me.TBBottom.RowDivider = GridLines3
            Me.TBBottom.RowHeight = 15
            Me.TBBottom.RowSubDividerColor = System.Drawing.Color.DarkGray
            Me.TBBottom.ScrollTips = False
            Me.TBBottom.Size = New System.Drawing.Size(706, 163)
            Me.TBBottom.TabAction = C1.Win.C1TrueDBGrid.TabActionEnum.ColumnNavigation
            Me.TBBottom.TabIndex = 9
            Me.TBBottom.Text = "C1TrueDBGrid1"
            Me.TBBottom.PropBag = "<?xml version=""1.0""?><Blob><Styles type=""C1.Win.C1TrueDBGrid.Design.ContextWrappe" & _
            "r""><Data>Group{AlignVert:Center;Border:None,,0, 0, 0, 0;BackColor:ControlDark;}E" & _
            "ditor{}Style2{}Style5{}Style4{}Style7{}Style6{}EvenRow{BackColor:White;}Selected" & _
            "{ForeColor:HighlightText;BackColor:Highlight;}Style3{}Inactive{ForeColor:Inactiv" & _
            "eCaptionText;BackColor:InactiveCaption;}FilterBar{BackColor:255, 255, 192;}Foote" & _
            "r{}Caption{AlignHorz:Center;}Normal{}HighlightRow{ForeColor:HighlightText;BackCo" & _
            "lor:Highlight;}Style1{}OddRow{BackColor:224, 224, 224;}RecordSelector{AlignImage" & _
            ":Center;}Heading{Wrap:True;BackColor:Control;Border:Raised,,1, 1, 1, 1;ForeColor" & _
            ":ControlText;AlignVert:Center;}Style8{}Style10{AlignHorz:Near;}Style11{}Style12{" & _
            "}Style13{}Style9{}</Data></Styles><Splits><C1.Win.C1TrueDBGrid.MergeView Name=""""" & _
            " AlternatingRowStyle=""True"" CaptionHeight=""17"" ColumnCaptionHeight=""17"" ColumnFo" & _
            "oterHeight=""17"" FilterBar=""True"" MarqueeStyle=""SolidCellBorder"" RecordSelectorWi" & _
            "dth=""16"" DefRecSelWidth=""16"" VerticalScrollGroup=""1"" HorizontalScrollGroup=""1""><" & _
            "ClientRect>0, 0, 702, 159</ClientRect><BorderSide>0</BorderSide><CaptionStyle pa" & _
            "rent=""Style2"" me=""Style10"" /><EditorStyle parent=""Editor"" me=""Style5"" /><EvenRow" & _
            "Style parent=""EvenRow"" me=""Style8"" /><FilterBarStyle parent=""FilterBar"" me=""Styl" & _
            "e13"" /><FooterStyle parent=""Footer"" me=""Style3"" /><GroupStyle parent=""Group"" me=" & _
            """Style12"" /><HeadingStyle parent=""Heading"" me=""Style2"" /><HighLightRowStyle pare" & _
            "nt=""HighlightRow"" me=""Style7"" /><InactiveStyle parent=""Inactive"" me=""Style4"" /><" & _
            "OddRowStyle parent=""OddRow"" me=""Style9"" /><RecordSelectorStyle parent=""RecordSel" & _
            "ector"" me=""Style11"" /><SelectedStyle parent=""Selected"" me=""Style6"" /><Style pare" & _
            "nt=""Normal"" me=""Style1"" /></C1.Win.C1TrueDBGrid.MergeView></Splits><NamedStyles>" & _
            "<Style parent="""" me=""Normal"" /><Style parent=""Normal"" me=""Heading"" /><Style pare" & _
            "nt=""Heading"" me=""Footer"" /><Style parent=""Heading"" me=""Caption"" /><Style parent=" & _
            """Heading"" me=""Inactive"" /><Style parent=""Normal"" me=""Selected"" /><Style parent=""" & _
            "Normal"" me=""Editor"" /><Style parent=""Normal"" me=""HighlightRow"" /><Style parent=""" & _
            "Normal"" me=""EvenRow"" /><Style parent=""Normal"" me=""OddRow"" /><Style parent=""Headi" & _
            "ng"" me=""RecordSelector"" /><Style parent=""Normal"" me=""FilterBar"" /><Style parent=" & _
            """Caption"" me=""Group"" /></NamedStyles><vertSplits>1</vertSplits><horzSplits>1</ho" & _
            "rzSplits><Layout>None</Layout><DefaultRecSelWidth>16</DefaultRecSelWidth><Client" & _
            "Area>0, 0, 702, 159</ClientArea></Blob>"
            '
            'Panel5
            '
            Me.Panel5.Controls.AddRange(New System.Windows.Forms.Control() {Me.BtnConnect})
            Me.Panel5.Dock = System.Windows.Forms.DockStyle.Top
            Me.Panel5.Name = "Panel5"
            Me.Panel5.Size = New System.Drawing.Size(712, 40)
            Me.Panel5.TabIndex = 1
            '
            'BtnConnect
            '
            Me.BtnConnect.Location = New System.Drawing.Point(288, 8)
            Me.BtnConnect.Name = "BtnConnect"
            Me.BtnConnect.TabIndex = 0
            Me.BtnConnect.Text = "&Verbinden"
            '
            'Panel4
            '
            Me.Panel4.Dock = System.Windows.Forms.DockStyle.Bottom
            Me.Panel4.Location = New System.Drawing.Point(0, 222)
            Me.Panel4.Name = "Panel4"
            Me.Panel4.Size = New System.Drawing.Size(712, 40)
            Me.Panel4.TabIndex = 0
            '
            'MainMenu1
            '
            Me.MainMenu1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem1})
            '
            'MenuItem1
            '
            Me.MenuItem1.Index = 0
            Me.MenuItem1.MenuItems.AddRange(New System.Windows.Forms.MenuItem() {Me.MenuItem3, Me.MenuItem2})
            Me.MenuItem1.MergeOrder = 1
            Me.MenuItem1.MergeType = System.Windows.Forms.MenuMerge.Replace
            Me.MenuItem1.Shortcut = System.Windows.Forms.Shortcut.F4
            Me.MenuItem1.Text = "&Datei"
            '
            'MenuItem3
            '
            Me.MenuItem3.Index = 0
            Me.MenuItem3.Shortcut = System.Windows.Forms.Shortcut.CtrlF5
            Me.MenuItem3.Text = "&Daten sichern"
            '
            'MenuItem2
            '
            Me.MenuItem2.Index = 1
            Me.MenuItem2.Shortcut = System.Windows.Forms.Shortcut.AltF4
            Me.MenuItem2.Text = "&Schliessen"
            '
            'frmRelEditor
            '
            Me.AutoScaleBaseSize = New System.Drawing.Size(5, 13)
            Me.ClientSize = New System.Drawing.Size(712, 505)
            Me.Controls.AddRange(New System.Windows.Forms.Control() {Me.Panel3, Me.GrpFocus, Me.Splitter2, Me.Panel2, Me.Panel1, Me.ToolBar1})
            Me.Icon = CType(resources.GetObject("$this.Icon"), System.Drawing.Icon)
            Me.Menu = Me.MainMenu1
            Me.Name = "frmRelEditor"
            Me.Text = "frmRelEditor"
            Me.Panel2.ResumeLayout(False)
            Me.GrpRight.ResumeLayout(False)
            CType(Me.TBRight, System.ComponentModel.ISupportInitialize).EndInit()
            Me.GrpLeft.ResumeLayout(False)
            CType(Me.TBLeft, System.ComponentModel.ISupportInitialize).EndInit()
            Me.GrpFocus.ResumeLayout(False)
            Me.Panel3.ResumeLayout(False)
            Me.GrpBottom.ResumeLayout(False)
            CType(Me.TBBottom, System.ComponentModel.ISupportInitialize).EndInit()
            Me.Panel5.ResumeLayout(False)
            Me.ResumeLayout(False)

        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.Splitter1_SplitterMoved Method

Private Sub Splitter1_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter1.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub Splitter1_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter1.SplitterMoved
            Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.Splitter2_SplitterMoved Method

Private Sub Splitter2_SplitterMoved( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.SplitterEventArgs _
) Handles Splitter2.SplitterMoved

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub Splitter2_SplitterMoved(ByVal sender As System.Object, ByVal e As System.Windows.Forms.SplitterEventArgs) Handles Splitter2.SplitterMoved
            Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
            Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TBBottom_FetchScrollTips Method

Private Sub TBBottom_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBBottom.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub TBBottom_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBBottom.FetchScrollTips
            Try
                Select Case e.ScrollBar
                    Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                        e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBBottom.Splits(0).Rows.Count)
                End Select
                e.TipStyle.ForeColor = Color.Blue
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TBLeft_FetchScrollTips Method

Private Sub TBLeft_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBLeft.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub TBLeft_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBLeft.FetchScrollTips
            Try
                Select Case e.ScrollBar
                    Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                        e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBLeft.Splits(0).Rows.Count)
                End Select
                e.TipStyle.ForeColor = Color.Blue
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.TBRight_FetchScrollTips Method

Private Sub TBRight_FetchScrollTips( _
   ByVal sender As System.Object, _
   ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs _
) Handles TBRight.FetchScrollTips

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub TBRight_FetchScrollTips(ByVal sender As System.Object, ByVal e As C1.Win.C1TrueDBGrid.FetchScrollTipsEventArgs) Handles TBRight.FetchScrollTips
            Try
                Select Case e.ScrollBar
                    Case C1.Win.C1TrueDBGrid.ScrollBarEnum.Vertical
                        e.ScrollTip = CStr(e.Row + 1) & " / " & CStr(Me.TBRight.Splits(0).Rows.Count)
                End Select
                e.TipStyle.ForeColor = Color.Blue
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.ToolBar1_ButtonClick Method

Private Sub ToolBar1_ButtonClick( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs _
) Handles ToolBar1.ButtonClick

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub ToolBar1_ButtonClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.ToolBarButtonClickEventArgs) Handles ToolBar1.ButtonClick
            Me.ActiveControl = Me.ToolBar1
            Me.ActiveControl = Me.TBBottom
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.frmVerbEditor_Cloase Method

Private Sub frmVerbEditor_Cloase( _
   ByVal sender As System.Object, _
   ByVal e As CancelEventArgs _
) Handles MyBase.Closing

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub frmVerbEditor_Cloase(ByVal sender As System.Object, ByVal e As CancelEventArgs) Handles MyBase.Closing
            Try
                Globals.WinPos.Set_Position(Me)
            Catch
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.frmVerbEditor_Layout Method

Private Sub frmVerbEditor_Layout( _
   ByVal sender As System.Object, _
   ByVal e As System.Windows.Forms.LayoutEventArgs _
) Handles MyBase.Layout

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub frmVerbEditor_Layout(ByVal sender As System.Object, ByVal e As System.Windows.Forms.LayoutEventArgs) Handles MyBase.Layout
            Me.GrpLeft.Width = Me.ClientSize.Width / 2
            Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
            Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
            Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.frmVerbEditor_Load Method

Private Sub frmVerbEditor_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub frmVerbEditor_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
            Me.FokusLeft.Checked = True
            Me.FokusRight.Checked = False
            Me.TBBottom.ScrollTips = True
            Me.TBBottom.ScrollTips = True
            Me.TBRight.ScrollTips = True
            Me.WindowState = FormWindowState.Maximized
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor.frmVerbEditor_WndChange Method

Private Sub frmVerbEditor_WndChange( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Resize

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
        Private Sub frmVerbEditor_WndChange(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Resize
            Me.GrpLeft.Width = Me.ClientSize.Width / 2
            Me.GrpFocus.Left = Me.Splitter1.Left - (Me.GrpFocus.Width / 2)
            Me.BtnConnect.Left = (Me.Splitter1.Left) - (Me.BtnConnect.Width / 2)
            Me.GrpBottom.Height = Me.Panel4.Height - (Me.Panel2.Height * 2)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


frmRelEditor Fields

frmRelEditor overview

Fields

field BtnConnect
field FokusLeft
field FokusRight
field GrpBottom
field GrpFocus
field GrpLeft
field GrpRight
field ImageList1
field Label1
field MainMenu1
field MenuItem1
field MenuItem2
field MenuItem3
field Panel1
field Panel2
field Panel3
field Panel4
field Panel5
field Splitter1
field Splitter2
field TBBottom
field TBLeft
field TBRight
field ToolBar1
field ToolBarBtnSave
field ToolBarButton1
field components
field m_Eintrag
field m_Eintragnr
field m_KeyLeft
field m_KeyRight
field m_TableNameBottom
field m_TableNameLeft
field m_TableNameRight

See Also

frmRelEditor Class


components Variable

Private components As System.ComponentModel.IContainer

Source code

[Visual Basic]
        Private components As System.ComponentModel.IContainer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_Eintrag Variable

Dim m_Eintrag As String

Source code

[Visual Basic]
        Dim m_Eintrag As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_Eintragnr Variable

Dim m_Eintragnr As Long

Source code

[Visual Basic]
        Dim m_Eintragnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_KeyLeft Variable

Dim m_KeyLeft As Long

Source code

[Visual Basic]
        Dim m_KeyLeft As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_KeyRight Variable

Dim m_KeyRight As Long

Source code

[Visual Basic]
        Dim m_KeyRight As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_TableNameBottom Variable

Dim m_TableNameBottom As String

Source code

[Visual Basic]
        Dim m_TableNameBottom As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_TableNameLeft Variable

Dim m_TableNameLeft As String

Source code

[Visual Basic]
        Dim m_TableNameLeft As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


m_TableNameRight Variable

Dim m_TableNameRight As String

Source code

[Visual Basic]
        Dim m_TableNameRight As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmRelEditor


EDOKAApp.edokadb Namespace

Namespace edokadb

Classes

class TreeEntries
class TreeEntry
class clsAnreden
class clsApplikation
class clsBarcodeetikette
class clsCold_folder
class clsColdindex
class clsConnectionProvider
class clsDBInteractionBase
class clsDoks
class clsDokument
class clsDokument_status
class clsDokumentart
class clsDokumentaufhebung
class clsDokumentcoldindexwert
class clsDokumentfavoriten
class clsDokumentfavoriten_struktur
class clsDokumentfavorithierarchie
class clsDokumentindexmutation
class clsDokumentstatus
class clsDokumentstatus_funktion
class clsDokumentstatus_rolle
class clsDokumenttyp
class clsDomainTable
class clsEDEX_BL_Auslieferung
class clsEDEX_BL_BLIndex
class clsEDEX_BL_BLKunde
class clsEDEX_BL_Druckjob
class clsEDEX_BL_Hostdokument
class clsEDEX_BL_Status
class clsEDEX_Favoriten
class clsEdex_bl_parameter
class clsEdex_dokumentpaket
class clsEdex_dokumentpaketvorlage
class clsEdex_dpinstanz
class clsEdex_sb_notizen
class clsEdex_sb_partnerliste
class clsEdex_sb_serienbrief
class clsEdoka_adressen
class clsEdoka_etbez0
class clsEdoka_etpar0
class clsEtparn
class clsEtparu
class clsFunktionsgruppe_reportgruppe
class clsFunktionsgruppe_rolle
class clsIdvmakro_office_vorlage
class clsKey_tabelle
class clsKostenstelle
class clsLand
class clsMandant
class clsMeldungstexte
class clsMitarbeiter
class clsMitarbeiter_funktionsgruppe
class clsMitarbeiterrolle
class clsMyDokumentDaten
class clsMyDokumentart
class clsMyDokumenttyp
class clsMyKey_Tabelle
class clsMyPartner
class clsMySysadminfunkion
class clsNldokumenttyp
class clsNotizen
class clsObjektbezeichnung
class clsOffice_vorlage
class clsOrt
class clsPartner
class clsPartner_Hauptadresse
class clsPhysischesArchiv
class clsProfil
class clsProzess
class clsReportfeld
class clsReportgruppe_report
class clsReportingSortOrderUser
class clsReporting_Dokumenttyp
class clsRolle_dokumentart
class clsRolle_dokumenttyp
class clsRolle_report_gruppe
class clsRolle_sysadminfunktion
class clsRolleberechtigung
class clsServices
class clsSpalten
class clsStatus
class clsStatushistory
class clsStatustyp
class clsSuchdaten
class clsSuchprofil
class clsSysadminfunktion
class clsTeam
class clsTeammitarbeiter
class clsTempdokument
class clsTempdokumentcoldindexwert
class clsTempdokumentinfo_wert
class clsTempdokumentmutation_cold
class clsTempdokumentzuordnungen
class clsTempnotizen
class clsTempstatushistory
class clsTmpdokument
class clsVV
class clsVorlagenfeld
class clsVorlagenfeldbezeichnung
class clsWindowPositions


EDOKAApp.edokadb Members

EDOKAApp.edokadb overview

Classes

class TreeEntries
class TreeEntry
class clsAnreden
class clsApplikation
class clsBarcodeetikette
class clsCold_folder
class clsColdindex
class clsConnectionProvider
class clsDBInteractionBase
class clsDoks
class clsDokument
class clsDokument_status
class clsDokumentart
class clsDokumentaufhebung
class clsDokumentcoldindexwert
class clsDokumentfavoriten
class clsDokumentfavoriten_struktur
class clsDokumentfavorithierarchie
class clsDokumentindexmutation
class clsDokumentstatus
class clsDokumentstatus_funktion
class clsDokumentstatus_rolle
class clsDokumenttyp
class clsDomainTable
class clsEDEX_BL_Auslieferung
class clsEDEX_BL_BLIndex
class clsEDEX_BL_BLKunde
class clsEDEX_BL_Druckjob
class clsEDEX_BL_Hostdokument
class clsEDEX_BL_Status
class clsEDEX_Favoriten
class clsEdex_bl_parameter
class clsEdex_dokumentpaket
class clsEdex_dokumentpaketvorlage
class clsEdex_dpinstanz
class clsEdex_sb_notizen
class clsEdex_sb_partnerliste
class clsEdex_sb_serienbrief
class clsEdoka_adressen
class clsEdoka_etbez0
class clsEdoka_etpar0
class clsEtparn
class clsEtparu
class clsFunktionsgruppe_reportgruppe
class clsFunktionsgruppe_rolle
class clsIdvmakro_office_vorlage
class clsKey_tabelle
class clsKostenstelle
class clsLand
class clsMandant
class clsMeldungstexte
class clsMitarbeiter
class clsMitarbeiter_funktionsgruppe
class clsMitarbeiterrolle
class clsMyDokumentDaten
class clsMyDokumentart
class clsMyDokumenttyp
class clsMyKey_Tabelle
class clsMyPartner
class clsMySysadminfunkion
class clsNldokumenttyp
class clsNotizen
class clsObjektbezeichnung
class clsOffice_vorlage
class clsOrt
class clsPartner
class clsPartner_Hauptadresse
class clsPhysischesArchiv
class clsProfil
class clsProzess
class clsReportfeld
class clsReportgruppe_report
class clsReportingSortOrderUser
class clsReporting_Dokumenttyp
class clsRolle_dokumentart
class clsRolle_dokumenttyp
class clsRolle_report_gruppe
class clsRolle_sysadminfunktion
class clsRolleberechtigung
class clsServices
class clsSpalten
class clsStatus
class clsStatushistory
class clsStatustyp
class clsSuchdaten
class clsSuchprofil
class clsSysadminfunktion
class clsTeam
class clsTeammitarbeiter
class clsTempdokument
class clsTempdokumentcoldindexwert
class clsTempdokumentinfo_wert
class clsTempdokumentmutation_cold
class clsTempdokumentzuordnungen
class clsTempnotizen
class clsTempstatushistory
class clsTmpdokument
class clsVV
class clsVorlagenfeld
class clsVorlagenfeldbezeichnung
class clsWindowPositions

See Also

EDOKAApp.edokadb Namespace


TreeEntries Class

For a list of all members of this type, see TreeEntries Members.

System.Object
System.Collections.CollectionBase
EDOKAApp.edokadb.TreeEntries

Public Class TreeEntries
   Inherits CollectionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

TreeEntries Members


TreeEntries Members

TreeEntries overview

Methods

method Add

See Also

TreeEntries Class


TreeEntries Methods

TreeEntries overview

Methods

method Add

See Also

TreeEntries Class


TreeEntries.Add Method

Public Function Add( _
   ByVal value As TreeEntry _
) As TreeEntry

Parameters

value
Required.

Source code

[Visual Basic]
        Public Function Add(ByVal value As TreeEntry) As TreeEntry
            Me.InnerList.Add(value)
            Add = value
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntries


TreeEntry Class

For a list of all members of this type, see TreeEntry Members.

System.Object
EDOKAApp.edokadb.TreeEntry

Public Class TreeEntry

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

TreeEntry Members


TreeEntry Members

TreeEntry overview

Properties

property Aktiv
property Dokumentartnr
property Erstellt_am
property ImageIndex
property Mandant
property OpenImageIndex
property ParentID
property Sort
property beschreibung
property bezeichnung
property deleted
property mutierer
property mutiert_am
property sprache

See Also

TreeEntry Class


TreeEntry Properties

TreeEntry overview

Properties

property Aktiv
property Dokumentartnr
property Erstellt_am
property ImageIndex
property Mandant
property OpenImageIndex
property ParentID
property Sort
property beschreibung
property bezeichnung
property deleted
property mutierer
property mutiert_am
property sprache

See Also

TreeEntry Class


Aktiv Property

Public Aktiv As Long

Source code

[Visual Basic]
        Public Aktiv As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


Dokumentartnr Property

Public Dokumentartnr As Long

Source code

[Visual Basic]
        Public Dokumentartnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


Erstellt_am Property

Public Erstellt_am As DateTime

Source code

[Visual Basic]
        Public Erstellt_am As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


ImageIndex Property

Public ImageIndex As Long

Source code

[Visual Basic]
        Public ImageIndex As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


Mandant Property

Public Mandant As Long

Source code

[Visual Basic]
        Public Mandant As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


OpenImageIndex Property

Public OpenImageIndex As Long

Source code

[Visual Basic]
        Public OpenImageIndex As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


ParentID Property

Public ParentID As Long

Source code

[Visual Basic]
        Public ParentID As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


Sort Property

Public Sort As Long

Source code

[Visual Basic]
        Public Sort As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


beschreibung Property

Public beschreibung As String

Source code

[Visual Basic]
        Public beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


bezeichnung Property

Public bezeichnung As String

Source code

[Visual Basic]
        Public bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


deleted Property

Public deleted As Boolean

Source code

[Visual Basic]
        Public deleted As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


mutierer Property

Public mutierer As Long

Source code

[Visual Basic]
        Public mutierer As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


mutiert_am Property

Public mutiert_am As DateTime

Source code

[Visual Basic]
        Public mutiert_am As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


sprache Property

Public sprache As Long

Source code

[Visual Basic]
        Public sprache As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TreeEntry


clsAnreden Class

For a list of all members of this type, see clsAnreden Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsAnreden

Public Class clsAnreden
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsAnreden Members


clsAnreden Members

clsAnreden overview

Constructors

constructor clsAnreden Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNrard00
property sCaprs00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNrard00
field m_sCaprs00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsAnreden Class


clsAnreden Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden Properties

clsAnreden overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNrard00
property sCaprs00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsAnreden Class


clsDBInteractionBase.cpMainConnectionProvider Property

Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider

Source code

[Visual Basic]
        Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider
            Set(ByVal Value As clsConnectionProvider)
                If Value Is Nothing Then
                    ' // Invalid value
                    Throw New ArgumentNullException("cpMainConnectionProvider", "Nothing passed as value to this property which is not allowed.")
                End If

                ' // A connection provider object is passed to this class.
                ' // Retrieve the SqlConnection object, if present and create a
                ' // reference to it. If there is already a MainConnection object
                ' // referenced by the membervar, destroy that one or simply
                ' // remove the reference, based on the flag.
                If Not (m_scoMainConnection Is Nothing) Then
                    ' // First get rid of current connection object. Caller is responsible
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Is local created object, close it and dispose it.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                    End If
                    ' // Remove reference.
                    m_scoMainConnection = Nothing
                End If
                m_cpMainConnectionProvider = CType(Value, clsConnectionProvider)
                m_scoMainConnection = m_cpMainConnectionProvider.scoDBConnection
                m_bMainConnectionIsCreatedLocal = False
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.iErrorCode Property

Public ReadOnly Property iErrorCode() As SqlInt32

Source code

[Visual Basic]
        Public ReadOnly Property iErrorCode() As SqlInt32
            Get
                Return m_iErrorCode
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsAnreden.iNrard00 Property

Public Property [iNrard00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrard00]() As SqlInt32
            Get
                Return m_iNrard00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNrard00Tmp As SqlInt32 = Value
                If iNrard00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNrard00", "iNrard00 can't be NULL")
                End If
                m_iNrard00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden.sCaprs00 Property

Public Property [sCaprs00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCaprs00]() As SqlString
            Get
                Return m_sCaprs00
            End Get
            Set(ByVal Value As SqlString)
                m_sCaprs00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsDBInteractionBase.sConnectionString Property

Public Property sConnectionString() As String

Source code

[Visual Basic]
        Public Property sConnectionString() As String
            Get
                Return m_sConnectionString
            End Get
            Set (ByVal Value As String)
                m_sConnectionString = Value
                m_scoMainConnection.ConnectionString = m_sConnectionString
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsAnreden Methods

clsAnreden overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsAnreden Class


clsAnreden.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_anreden_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrard00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrard00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_anreden_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAnreden::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


Dispose Method

Overload List

[Visual Basic] Overloads Public Sub Dispose() Implements IDisposable.Dispose

[Visual Basic] Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)

See Also

clsDBInteractionBase | edokadb


clsAnreden.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_anreden_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrard00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrard00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scaprs00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCaprs00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_anreden_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAnreden::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_anreden_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("anreden")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_anreden_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAnreden::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_anreden_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("anreden")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inrard00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrard00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_anreden_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNrard00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrard00"), Integer))
                    If dtToReturn.Rows(0)("caprs00") Is System.DBNull.Value Then
                        m_sCaprs00 = SqlString.Null
                    Else
                        m_sCaprs00 = New SqlString(CType(dtToReturn.Rows(0)("caprs00"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAnreden::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_anreden_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrard00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrard00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scaprs00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCaprs00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_anreden_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsAnreden::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


clsAnreden Fields

clsAnreden overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNrard00
field m_sCaprs00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsAnreden Class


m_bMainConnectionIsCreatedLocal Variable

Protected	m_bMainConnectionIsCreatedLocal As Boolean

Source code

[Visual Basic]
        Protected	m_bMainConnectionIsCreatedLocal As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


m_cpMainConnectionProvider Variable

Protected	m_cpMainConnectionProvider As clsConnectionProvider

Source code

[Visual Basic]
        Protected	m_cpMainConnectionProvider As clsConnectionProvider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


m_iErrorCode Variable

Protected	m_iErrorCode As SqlInt32

Source code

[Visual Basic]
        Protected	m_iErrorCode As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


m_iNrard00 Variable

Private 		m_iNrard00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrard00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


m_sCaprs00 Variable

Private 		m_sCaprs00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCaprs00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsAnreden


m_scoMainConnection Variable

Protected	m_scoMainConnection As SqlConnection

Source code

[Visual Basic]
        Protected	m_scoMainConnection As SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsApplikation Class

For a list of all members of this type, see clsApplikation Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsApplikation

Public Class clsApplikation
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsApplikation Members


clsApplikation Members

clsApplikation overview

Constructors

constructor clsApplikation Constructor

Properties

property bAktiv
property bNet_use
property bShowlogin
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daLetzer_ams_run
property daLetzter_cold_run
property daLetzter_host_run
property daLetzter_rdm_run
property daMutiert_am
property iAmsstunden
property iAnzahl_Cold_Viewer
property iApplikationsnr
property iBcfont_groesse
property iColdstunden
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHoststunden
property iMandantnr
property iMutierer
property iRdmstunden
property iZeitintervall_in_Minuten
property sBarcode_font
property sColdgui
property sColdpassword
property sColdstart
property sColdsystem
property sColduser
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokument_server
property sLogisches_laufwerk
property sMailadresse
property sPasswort_excelvorlagen
property sPasswort_fileserver
property sPasswort_report
property sPasswort_vorlagenverwaltung
property sPasswort_wordvorlagen
property sPfad_dokumente
property sPfad_excel_vorlagen
property sPfad_reportdateien
property sPfad_temporaer_dokumente
property sPfad_word_vorlagen
property sReport_db
property sReport_server
property sUser_fileserver
property sUser_report
property sVersion
property sVideomenu

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bNet_use
field m_bShowlogin
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daLetzer_ams_run
field m_daLetzter_cold_run
field m_daLetzter_host_run
field m_daLetzter_rdm_run
field m_daMutiert_am
field m_iAmsstunden
field m_iAnzahl_Cold_Viewer
field m_iApplikationsnr
field m_iBcfont_groesse
field m_iColdstunden
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHoststunden
field m_iMandantnr
field m_iMutierer
field m_iRdmstunden
field m_iZeitintervall_in_Minuten
field m_sBarcode_font
field m_sColdgui
field m_sColdpassword
field m_sColdstart
field m_sColdsystem
field m_sColduser
field m_sDokument_server
field m_sLogisches_laufwerk
field m_sMailadresse
field m_sPasswort_excelvorlagen
field m_sPasswort_fileserver
field m_sPasswort_report
field m_sPasswort_vorlagenverwaltung
field m_sPasswort_wordvorlagen
field m_sPfad_dokumente
field m_sPfad_excel_vorlagen
field m_sPfad_reportdateien
field m_sPfad_temporaer_dokumente
field m_sPfad_word_vorlagen
field m_sReport_db
field m_sReport_server
field m_sUser_fileserver
field m_sUser_report
field m_sVersion
field m_sVideomenu
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsApplikation Class


clsApplikation Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation Properties

clsApplikation overview

Properties

property bAktiv
property bNet_use
property bShowlogin
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daLetzer_ams_run
property daLetzter_cold_run
property daLetzter_host_run
property daLetzter_rdm_run
property daMutiert_am
property iAmsstunden
property iAnzahl_Cold_Viewer
property iApplikationsnr
property iBcfont_groesse
property iColdstunden
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHoststunden
property iMandantnr
property iMutierer
property iRdmstunden
property iZeitintervall_in_Minuten
property sBarcode_font
property sColdgui
property sColdpassword
property sColdstart
property sColdsystem
property sColduser
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokument_server
property sLogisches_laufwerk
property sMailadresse
property sPasswort_excelvorlagen
property sPasswort_fileserver
property sPasswort_report
property sPasswort_vorlagenverwaltung
property sPasswort_wordvorlagen
property sPfad_dokumente
property sPfad_excel_vorlagen
property sPfad_reportdateien
property sPfad_temporaer_dokumente
property sPfad_word_vorlagen
property sReport_db
property sReport_server
property sUser_fileserver
property sUser_report
property sVersion
property sVideomenu

See Also

clsApplikation Class


clsApplikation.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.bNet_use Property

Public Property [bNet_use]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bNet_use]() As SqlBoolean
            Get
                Return m_bNet_use
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bNet_use = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.bShowlogin Property

Public Property [bShowlogin]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bShowlogin]() As SqlBoolean
            Get
                Return m_bShowlogin
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bShowlogin = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daLetzer_ams_run Property

Public Property [daLetzer_ams_run]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daLetzer_ams_run]() As SqlDateTime
            Get
                Return m_daLetzer_ams_run
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daLetzer_ams_run = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daLetzter_cold_run Property

Public Property [daLetzter_cold_run]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daLetzter_cold_run]() As SqlDateTime
            Get
                Return m_daLetzter_cold_run
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daLetzter_cold_run = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daLetzter_host_run Property

Public Property [daLetzter_host_run]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daLetzter_host_run]() As SqlDateTime
            Get
                Return m_daLetzter_host_run
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daLetzter_host_run = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daLetzter_rdm_run Property

Public Property [daLetzter_rdm_run]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daLetzter_rdm_run]() As SqlDateTime
            Get
                Return m_daLetzter_rdm_run
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daLetzter_rdm_run = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iAmsstunden Property

Public Property [iAmsstunden]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAmsstunden]() As SqlInt32
            Get
                Return m_iAmsstunden
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAmsstunden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iAnzahl_Cold_Viewer Property

Public Property [iAnzahl_Cold_Viewer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnzahl_Cold_Viewer]() As SqlInt32
            Get
                Return m_iAnzahl_Cold_Viewer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnzahl_Cold_Viewer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iApplikationsnr Property

Public Property [iApplikationsnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iApplikationsnr]() As SqlInt32
            Get
                Return m_iApplikationsnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iApplikationsnrTmp As SqlInt32 = Value
                If iApplikationsnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iApplikationsnr", "iApplikationsnr can't be NULL")
                End If
                m_iApplikationsnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iBcfont_groesse Property

Public Property [iBcfont_groesse]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBcfont_groesse]() As SqlInt32
            Get
                Return m_iBcfont_groesse
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBcfont_groesse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iColdstunden Property

Public Property [iColdstunden]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdstunden]() As SqlInt32
            Get
                Return m_iColdstunden
            End Get
            Set(ByVal Value As SqlInt32)
                m_iColdstunden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iHoststunden Property

Public Property [iHoststunden]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHoststunden]() As SqlInt32
            Get
                Return m_iHoststunden
            End Get
            Set(ByVal Value As SqlInt32)
                m_iHoststunden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iRdmstunden Property

Public Property [iRdmstunden]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRdmstunden]() As SqlInt32
            Get
                Return m_iRdmstunden
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRdmstunden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.iZeitintervall_in_Minuten Property

Public Property [iZeitintervall_in_Minuten]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZeitintervall_in_Minuten]() As SqlInt32
            Get
                Return m_iZeitintervall_in_Minuten
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZeitintervall_in_Minuten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sBarcode_font Property

Public Property [sBarcode_font]() As SqlString

Source code

[Visual Basic]
        Public Property [sBarcode_font]() As SqlString
            Get
                Return m_sBarcode_font
            End Get
            Set(ByVal Value As SqlString)
                m_sBarcode_font = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sColdgui Property

Public Property [sColdgui]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdgui]() As SqlString
            Get
                Return m_sColdgui
            End Get
            Set(ByVal Value As SqlString)
                m_sColdgui = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sColdpassword Property

Public Property [sColdpassword]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdpassword]() As SqlString
            Get
                Return m_sColdpassword
            End Get
            Set(ByVal Value As SqlString)
                m_sColdpassword = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sColdstart Property

Public Property [sColdstart]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdstart]() As SqlString
            Get
                Return m_sColdstart
            End Get
            Set(ByVal Value As SqlString)
                m_sColdstart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sColdsystem Property

Public Property [sColdsystem]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdsystem]() As SqlString
            Get
                Return m_sColdsystem
            End Get
            Set(ByVal Value As SqlString)
                m_sColdsystem = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sColduser Property

Public Property [sColduser]() As SqlString

Source code

[Visual Basic]
        Public Property [sColduser]() As SqlString
            Get
                Return m_sColduser
            End Get
            Set(ByVal Value As SqlString)
                m_sColduser = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sDokument_server Property

Public Property [sDokument_server]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokument_server]() As SqlString
            Get
                Return m_sDokument_server
            End Get
            Set(ByVal Value As SqlString)
                m_sDokument_server = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sLogisches_laufwerk Property

Public Property [sLogisches_laufwerk]() As SqlString

Source code

[Visual Basic]
        Public Property [sLogisches_laufwerk]() As SqlString
            Get
                Return m_sLogisches_laufwerk
            End Get
            Set(ByVal Value As SqlString)
                m_sLogisches_laufwerk = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sMailadresse Property

Public Property [sMailadresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sMailadresse]() As SqlString
            Get
                Return m_sMailadresse
            End Get
            Set(ByVal Value As SqlString)
                m_sMailadresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPasswort_excelvorlagen Property

Public Property [sPasswort_excelvorlagen]() As SqlString

Source code

[Visual Basic]
        Public Property [sPasswort_excelvorlagen]() As SqlString
            Get
                Return m_sPasswort_excelvorlagen
            End Get
            Set(ByVal Value As SqlString)
                m_sPasswort_excelvorlagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPasswort_fileserver Property

Public Property [sPasswort_fileserver]() As SqlString

Source code

[Visual Basic]
        Public Property [sPasswort_fileserver]() As SqlString
            Get
                Return m_sPasswort_fileserver
            End Get
            Set(ByVal Value As SqlString)
                m_sPasswort_fileserver = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPasswort_report Property

Public Property [sPasswort_report]() As SqlString

Source code

[Visual Basic]
        Public Property [sPasswort_report]() As SqlString
            Get
                Return m_sPasswort_report
            End Get
            Set(ByVal Value As SqlString)
                m_sPasswort_report = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPasswort_vorlagenverwaltung Property

Public Property [sPasswort_vorlagenverwaltung]() As SqlString

Source code

[Visual Basic]
        Public Property [sPasswort_vorlagenverwaltung]() As SqlString
            Get
                Return m_sPasswort_vorlagenverwaltung
            End Get
            Set(ByVal Value As SqlString)
                m_sPasswort_vorlagenverwaltung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPasswort_wordvorlagen Property

Public Property [sPasswort_wordvorlagen]() As SqlString

Source code

[Visual Basic]
        Public Property [sPasswort_wordvorlagen]() As SqlString
            Get
                Return m_sPasswort_wordvorlagen
            End Get
            Set(ByVal Value As SqlString)
                m_sPasswort_wordvorlagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPfad_dokumente Property

Public Property [sPfad_dokumente]() As SqlString

Source code

[Visual Basic]
        Public Property [sPfad_dokumente]() As SqlString
            Get
                Return m_sPfad_dokumente
            End Get
            Set(ByVal Value As SqlString)
                m_sPfad_dokumente = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPfad_excel_vorlagen Property

Public Property [sPfad_excel_vorlagen]() As SqlString

Source code

[Visual Basic]
        Public Property [sPfad_excel_vorlagen]() As SqlString
            Get
                Return m_sPfad_excel_vorlagen
            End Get
            Set(ByVal Value As SqlString)
                m_sPfad_excel_vorlagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPfad_reportdateien Property

Public Property [sPfad_reportdateien]() As SqlString

Source code

[Visual Basic]
        Public Property [sPfad_reportdateien]() As SqlString
            Get
                Return m_sPfad_reportdateien
            End Get
            Set(ByVal Value As SqlString)
                m_sPfad_reportdateien = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPfad_temporaer_dokumente Property

Public Property [sPfad_temporaer_dokumente]() As SqlString

Source code

[Visual Basic]
        Public Property [sPfad_temporaer_dokumente]() As SqlString
            Get
                Return m_sPfad_temporaer_dokumente
            End Get
            Set(ByVal Value As SqlString)
                m_sPfad_temporaer_dokumente = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sPfad_word_vorlagen Property

Public Property [sPfad_word_vorlagen]() As SqlString

Source code

[Visual Basic]
        Public Property [sPfad_word_vorlagen]() As SqlString
            Get
                Return m_sPfad_word_vorlagen
            End Get
            Set(ByVal Value As SqlString)
                m_sPfad_word_vorlagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sReport_db Property

Public Property [sReport_db]() As SqlString

Source code

[Visual Basic]
        Public Property [sReport_db]() As SqlString
            Get
                Return m_sReport_db
            End Get
            Set(ByVal Value As SqlString)
                m_sReport_db = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sReport_server Property

Public Property [sReport_server]() As SqlString

Source code

[Visual Basic]
        Public Property [sReport_server]() As SqlString
            Get
                Return m_sReport_server
            End Get
            Set(ByVal Value As SqlString)
                m_sReport_server = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sUser_fileserver Property

Public Property [sUser_fileserver]() As SqlString

Source code

[Visual Basic]
        Public Property [sUser_fileserver]() As SqlString
            Get
                Return m_sUser_fileserver
            End Get
            Set(ByVal Value As SqlString)
                m_sUser_fileserver = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sUser_report Property

Public Property [sUser_report]() As SqlString

Source code

[Visual Basic]
        Public Property [sUser_report]() As SqlString
            Get
                Return m_sUser_report
            End Get
            Set(ByVal Value As SqlString)
                m_sUser_report = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sVersion Property

Public Property [sVersion]() As SqlString

Source code

[Visual Basic]
        Public Property [sVersion]() As SqlString
            Get
                Return m_sVersion
            End Get
            Set(ByVal Value As SqlString)
                m_sVersion = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.sVideomenu Property

Public Property [sVideomenu]() As SqlString

Source code

[Visual Basic]
        Public Property [sVideomenu]() As SqlString
            Get
                Return m_sVideomenu
            End Get
            Set(ByVal Value As SqlString)
                m_sVideomenu = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation Methods

clsApplikation overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsApplikation Class


clsApplikation.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_server))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnet_use", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNet_use))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@slogisches_laufwerk", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLogisches_laufwerk))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_dokumente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_word_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_word_vorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_excel_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_excel_vorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_temporaer_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_temporaer_dokumente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_fileserver))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_fileserver))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_wordvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_wordvorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_excelvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_excelvorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_db", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_db))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_server))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_reportdateien", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_reportdateien))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbarcode_font", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBarcode_font))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcfont_groesse", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcfont_groesse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smailadresse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMailadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_cold_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_cold_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzer_ams_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzer_ams_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_rdm_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_rdm_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_host_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_host_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irdmstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRdmstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iamsstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAmsstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihoststunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHoststunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldsystem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdsystem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolduser", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColduser))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldpassword", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdpassword))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldgui", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdgui))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPasswort_vorlagenverwaltung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_vorlagenverwaltung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl_Cold_Viewer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_Cold_Viewer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeitintervall_in_Minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeitintervall_in_Minuten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldstart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdstart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svideomenu", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVideomenu))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("applikation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iApplikationsnr = New SqlInt32(CType(dtToReturn.Rows(0)("applikationsnr"), Integer))
                    If dtToReturn.Rows(0)("version") Is System.DBNull.Value Then
                        m_sVersion = SqlString.Null
                    Else
                        m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("version"), String))
                    End If
                    If dtToReturn.Rows(0)("dokument_server") Is System.DBNull.Value Then
                        m_sDokument_server = SqlString.Null
                    Else
                        m_sDokument_server = New SqlString(CType(dtToReturn.Rows(0)("dokument_server"), String))
                    End If
                    If dtToReturn.Rows(0)("net_use") Is System.DBNull.Value Then
                        m_bNet_use = SqlBoolean.Null
                    Else
                        m_bNet_use = New SqlBoolean(CType(dtToReturn.Rows(0)("net_use"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("logisches_laufwerk") Is System.DBNull.Value Then
                        m_sLogisches_laufwerk = SqlString.Null
                    Else
                        m_sLogisches_laufwerk = New SqlString(CType(dtToReturn.Rows(0)("logisches_laufwerk"), String))
                    End If
                    If dtToReturn.Rows(0)("pfad_dokumente") Is System.DBNull.Value Then
                        m_sPfad_dokumente = SqlString.Null
                    Else
                        m_sPfad_dokumente = New SqlString(CType(dtToReturn.Rows(0)("pfad_dokumente"), String))
                    End If
                    If dtToReturn.Rows(0)("pfad_word_vorlagen") Is System.DBNull.Value Then
                        m_sPfad_word_vorlagen = SqlString.Null
                    Else
                        m_sPfad_word_vorlagen = New SqlString(CType(dtToReturn.Rows(0)("pfad_word_vorlagen"), String))
                    End If
                    If dtToReturn.Rows(0)("pfad_excel_vorlagen") Is System.DBNull.Value Then
                        m_sPfad_excel_vorlagen = SqlString.Null
                    Else
                        m_sPfad_excel_vorlagen = New SqlString(CType(dtToReturn.Rows(0)("pfad_excel_vorlagen"), String))
                    End If
                    If dtToReturn.Rows(0)("pfad_temporaer_dokumente") Is System.DBNull.Value Then
                        m_sPfad_temporaer_dokumente = SqlString.Null
                    Else
                        m_sPfad_temporaer_dokumente = New SqlString(CType(dtToReturn.Rows(0)("pfad_temporaer_dokumente"), String))
                    End If
                    If dtToReturn.Rows(0)("user_fileserver") Is System.DBNull.Value Then
                        m_sUser_fileserver = SqlString.Null
                    Else
                        m_sUser_fileserver = New SqlString(CType(dtToReturn.Rows(0)("user_fileserver"), String))
                    End If
                    If dtToReturn.Rows(0)("passwort_fileserver") Is System.DBNull.Value Then
                        m_sPasswort_fileserver = SqlString.Null
                    Else
                        m_sPasswort_fileserver = New SqlString(CType(dtToReturn.Rows(0)("passwort_fileserver"), String))
                    End If
                    If dtToReturn.Rows(0)("passwort_wordvorlagen") Is System.DBNull.Value Then
                        m_sPasswort_wordvorlagen = SqlString.Null
                    Else
                        m_sPasswort_wordvorlagen = New SqlString(CType(dtToReturn.Rows(0)("passwort_wordvorlagen"), String))
                    End If
                    If dtToReturn.Rows(0)("passwort_excelvorlagen") Is System.DBNull.Value Then
                        m_sPasswort_excelvorlagen = SqlString.Null
                    Else
                        m_sPasswort_excelvorlagen = New SqlString(CType(dtToReturn.Rows(0)("passwort_excelvorlagen"), String))
                    End If
                    If dtToReturn.Rows(0)("report_db") Is System.DBNull.Value Then
                        m_sReport_db = SqlString.Null
                    Else
                        m_sReport_db = New SqlString(CType(dtToReturn.Rows(0)("report_db"), String))
                    End If
                    If dtToReturn.Rows(0)("report_server") Is System.DBNull.Value Then
                        m_sReport_server = SqlString.Null
                    Else
                        m_sReport_server = New SqlString(CType(dtToReturn.Rows(0)("report_server"), String))
                    End If
                    If dtToReturn.Rows(0)("pfad_reportdateien") Is System.DBNull.Value Then
                        m_sPfad_reportdateien = SqlString.Null
                    Else
                        m_sPfad_reportdateien = New SqlString(CType(dtToReturn.Rows(0)("pfad_reportdateien"), String))
                    End If
                    If dtToReturn.Rows(0)("user_report") Is System.DBNull.Value Then
                        m_sUser_report = SqlString.Null
                    Else
                        m_sUser_report = New SqlString(CType(dtToReturn.Rows(0)("user_report"), String))
                    End If
                    If dtToReturn.Rows(0)("passwort_report") Is System.DBNull.Value Then
                        m_sPasswort_report = SqlString.Null
                    Else
                        m_sPasswort_report = New SqlString(CType(dtToReturn.Rows(0)("passwort_report"), String))
                    End If
                    If dtToReturn.Rows(0)("barcode_font") Is System.DBNull.Value Then
                        m_sBarcode_font = SqlString.Null
                    Else
                        m_sBarcode_font = New SqlString(CType(dtToReturn.Rows(0)("barcode_font"), String))
                    End If
                    If dtToReturn.Rows(0)("bcfont_groesse") Is System.DBNull.Value Then
                        m_iBcfont_groesse = SqlInt32.Null
                    Else
                        m_iBcfont_groesse = New SqlInt32(CType(dtToReturn.Rows(0)("bcfont_groesse"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mailadresse") Is System.DBNull.Value Then
                        m_sMailadresse = SqlString.Null
                    Else
                        m_sMailadresse = New SqlString(CType(dtToReturn.Rows(0)("mailadresse"), String))
                    End If
                    If dtToReturn.Rows(0)("showlogin") Is System.DBNull.Value Then
                        m_bShowlogin = SqlBoolean.Null
                    Else
                        m_bShowlogin = New SqlBoolean(CType(dtToReturn.Rows(0)("showlogin"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("letzter_cold_run") Is System.DBNull.Value Then
                        m_daLetzter_cold_run = SqlDateTime.Null
                    Else
                        m_daLetzter_cold_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_cold_run"), Date))
                    End If
                    If dtToReturn.Rows(0)("letzer_ams_run") Is System.DBNull.Value Then
                        m_daLetzer_ams_run = SqlDateTime.Null
                    Else
                        m_daLetzer_ams_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzer_ams_run"), Date))
                    End If
                    If dtToReturn.Rows(0)("letzter_rdm_run") Is System.DBNull.Value Then
                        m_daLetzter_rdm_run = SqlDateTime.Null
                    Else
                        m_daLetzter_rdm_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_rdm_run"), Date))
                    End If
                    If dtToReturn.Rows(0)("letzter_host_run") Is System.DBNull.Value Then
                        m_daLetzter_host_run = SqlDateTime.Null
                    Else
                        m_daLetzter_host_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_host_run"), Date))
                    End If
                    If dtToReturn.Rows(0)("rdmstunden") Is System.DBNull.Value Then
                        m_iRdmstunden = SqlInt32.Null
                    Else
                        m_iRdmstunden = New SqlInt32(CType(dtToReturn.Rows(0)("rdmstunden"), Integer))
                    End If
                    If dtToReturn.Rows(0)("coldstunden") Is System.DBNull.Value Then
                        m_iColdstunden = SqlInt32.Null
                    Else
                        m_iColdstunden = New SqlInt32(CType(dtToReturn.Rows(0)("coldstunden"), Integer))
                    End If
                    If dtToReturn.Rows(0)("amsstunden") Is System.DBNull.Value Then
                        m_iAmsstunden = SqlInt32.Null
                    Else
                        m_iAmsstunden = New SqlInt32(CType(dtToReturn.Rows(0)("amsstunden"), Integer))
                    End If
                    If dtToReturn.Rows(0)("hoststunden") Is System.DBNull.Value Then
                        m_iHoststunden = SqlInt32.Null
                    Else
                        m_iHoststunden = New SqlInt32(CType(dtToReturn.Rows(0)("hoststunden"), Integer))
                    End If
                    If dtToReturn.Rows(0)("coldsystem") Is System.DBNull.Value Then
                        m_sColdsystem = SqlString.Null
                    Else
                        m_sColdsystem = New SqlString(CType(dtToReturn.Rows(0)("coldsystem"), String))
                    End If
                    If dtToReturn.Rows(0)("colduser") Is System.DBNull.Value Then
                        m_sColduser = SqlString.Null
                    Else
                        m_sColduser = New SqlString(CType(dtToReturn.Rows(0)("colduser"), String))
                    End If
                    If dtToReturn.Rows(0)("coldpassword") Is System.DBNull.Value Then
                        m_sColdpassword = SqlString.Null
                    Else
                        m_sColdpassword = New SqlString(CType(dtToReturn.Rows(0)("coldpassword"), String))
                    End If
                    If dtToReturn.Rows(0)("coldgui") Is System.DBNull.Value Then
                        m_sColdgui = SqlString.Null
                    Else
                        m_sColdgui = New SqlString(CType(dtToReturn.Rows(0)("coldgui"), String))
                    End If
                    If dtToReturn.Rows(0)("Passwort_vorlagenverwaltung") Is System.DBNull.Value Then
                        m_sPasswort_vorlagenverwaltung = SqlString.Null
                    Else
                        m_sPasswort_vorlagenverwaltung = New SqlString(CType(dtToReturn.Rows(0)("Passwort_vorlagenverwaltung"), String))
                    End If
                    If dtToReturn.Rows(0)("Anzahl_Cold_Viewer") Is System.DBNull.Value Then
                        m_iAnzahl_Cold_Viewer = SqlInt32.Null
                    Else
                        m_iAnzahl_Cold_Viewer = New SqlInt32(CType(dtToReturn.Rows(0)("Anzahl_Cold_Viewer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Zeitintervall_in_Minuten") Is System.DBNull.Value Then
                        m_iZeitintervall_in_Minuten = SqlInt32.Null
                    Else
                        m_iZeitintervall_in_Minuten = New SqlInt32(CType(dtToReturn.Rows(0)("Zeitintervall_in_Minuten"), Integer))
                    End If
                    If dtToReturn.Rows(0)("coldstart") Is System.DBNull.Value Then
                        m_sColdstart = SqlString.Null
                    Else
                        m_sColdstart = New SqlString(CType(dtToReturn.Rows(0)("coldstart"), String))
                    End If
                    If dtToReturn.Rows(0)("videomenu") Is System.DBNull.Value Then
                        m_sVideomenu = SqlString.Null
                    Else
                        m_sVideomenu = New SqlString(CType(dtToReturn.Rows(0)("videomenu"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_applikation_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_server))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnet_use", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNet_use))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@slogisches_laufwerk", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLogisches_laufwerk))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_dokumente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_word_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_word_vorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_excel_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_excel_vorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_temporaer_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_temporaer_dokumente))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_fileserver))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_fileserver))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_wordvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_wordvorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_excelvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_excelvorlagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_db", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_db))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_server))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_reportdateien", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_reportdateien))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_report))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbarcode_font", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBarcode_font))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcfont_groesse", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcfont_groesse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smailadresse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMailadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bShowlogin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_cold_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_cold_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzer_ams_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzer_ams_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_rdm_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_rdm_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_host_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_host_run))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irdmstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRdmstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iamsstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAmsstunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihoststunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHoststunden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldsystem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdsystem))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolduser", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColduser))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldpassword", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdpassword))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldgui", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdgui))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sPasswort_vorlagenverwaltung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_vorlagenverwaltung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl_Cold_Viewer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_Cold_Viewer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeitintervall_in_Minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeitintervall_in_Minuten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldstart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdstart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svideomenu", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVideomenu))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                Try
                    m_scoMainConnection.Open()
                Catch
                End Try

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_applikation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsApplikation::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                Try
                    m_scoMainConnection.Close()
                Catch

                End Try
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsApplikation Fields

clsApplikation overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bNet_use
field m_bShowlogin
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daLetzer_ams_run
field m_daLetzter_cold_run
field m_daLetzter_host_run
field m_daLetzter_rdm_run
field m_daMutiert_am
field m_iAmsstunden
field m_iAnzahl_Cold_Viewer
field m_iApplikationsnr
field m_iBcfont_groesse
field m_iColdstunden
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHoststunden
field m_iMandantnr
field m_iMutierer
field m_iRdmstunden
field m_iZeitintervall_in_Minuten
field m_sBarcode_font
field m_sColdgui
field m_sColdpassword
field m_sColdstart
field m_sColdsystem
field m_sColduser
field m_sDokument_server
field m_sLogisches_laufwerk
field m_sMailadresse
field m_sPasswort_excelvorlagen
field m_sPasswort_fileserver
field m_sPasswort_report
field m_sPasswort_vorlagenverwaltung
field m_sPasswort_wordvorlagen
field m_sPfad_dokumente
field m_sPfad_excel_vorlagen
field m_sPfad_reportdateien
field m_sPfad_temporaer_dokumente
field m_sPfad_word_vorlagen
field m_sReport_db
field m_sReport_server
field m_sUser_fileserver
field m_sUser_report
field m_sVersion
field m_sVideomenu
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsApplikation Class


m_bAktiv Variable

Private 		m_bNet_use, _
   m_bShowlogin, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_bNet_use Variable

Private 		m_bNet_use, _
   m_bShowlogin, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_bShowlogin Variable

Private 		m_bNet_use, _
   m_bShowlogin, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daErstellt_am Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daLetzer_ams_run Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daLetzter_cold_run Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daLetzter_host_run Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daLetzter_rdm_run Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_daMutiert_am Variable

Private 		m_daLetzer_ams_run, _
   m_daLetzter_rdm_run, _
   m_daLetzter_host_run, _
   m_daErstellt_am, _
   m_daMutiert_am, _
   m_daLetzter_cold_run As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iAmsstunden Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iAnzahl_Cold_Viewer Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iApplikationsnr Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iBcfont_groesse Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iColdstunden Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iHoststunden Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iMandantnr Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iMutierer Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iRdmstunden Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_iZeitintervall_in_Minuten Variable

Private 		m_iZeitintervall_in_Minuten, _
   m_iAnzahl_Cold_Viewer, _
   m_iApplikationsnr, _
   m_iBcfont_groesse, _
   m_iMandantnr, _
   m_iColdstunden, _
   m_iRdmstunden, _
   m_iAmsstunden, _
   m_iMutierer, _
   m_iHoststunden As SqlInt32

Source code

[Visual Basic]
        Private 		m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sBarcode_font Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sColdgui Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sColdpassword Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sColdstart Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sColdsystem Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sColduser Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sDokument_server Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sLogisches_laufwerk Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sMailadresse Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPasswort_excelvorlagen Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPasswort_fileserver Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPasswort_report Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPasswort_vorlagenverwaltung Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPasswort_wordvorlagen Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPfad_dokumente Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPfad_excel_vorlagen Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPfad_reportdateien Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPfad_temporaer_dokumente Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sPfad_word_vorlagen Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sReport_db Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sReport_server Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sUser_fileserver Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sUser_report Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sVersion Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


m_sVideomenu Variable

Private 		m_sColdsystem, _
   m_sColduser, _
   m_sColdpassword, _
   m_sPfad_excel_vorlagen, _
   m_sPfad_word_vorlagen, _
   m_sPfad_dokumente, _
   m_sDokument_server, _
   m_sColdstart, _
   m_sVideomenu, _
   m_sColdgui, _
   m_sPasswort_vorlagenverwaltung, _
   m_sLogisches_laufwerk, _
   m_sPfad_temporaer_dokumente, _
   m_sPasswort_report, _
   m_sUser_report, _
   m_sPfad_reportdateien, _
   m_sBarcode_font, _
   m_sMailadresse, _
   m_sVersion, _
   m_sPasswort_wordvorlagen, _
   m_sPasswort_fileserver, _
   m_sUser_fileserver, _
   m_sReport_server, _
   m_sReport_db, _
   m_sPasswort_excelvorlagen As SqlString

Source code

[Visual Basic]
        Private 		m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsApplikation


clsBarcodeetikette Class

For a list of all members of this type, see clsBarcodeetikette Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsBarcodeetikette

Public Class clsBarcodeetikette
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsBarcodeetikette Members


clsBarcodeetikette Members

clsBarcodeetikette overview

Constructors

constructor clsBarcodeetikette Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBarcodenr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBarcodenr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsBarcodeetikette Class


clsBarcodeetikette Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette Properties

clsBarcodeetikette overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBarcodenr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

See Also

clsBarcodeetikette Class


clsBarcodeetikette.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.iBarcodenr Property

Public Property [iBarcodenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBarcodenr]() As SqlInt32
            Get
                Return m_iBarcodenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBarcodenrTmp As SqlInt32 = Value
                If iBarcodenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBarcodenr", "iBarcodenr can't be NULL")
                End If
                m_iBarcodenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette Methods

clsBarcodeetikette overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsBarcodeetikette Class


clsBarcodeetikette.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_barcodeetikette_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_barcodeetikette_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBarcodeetikette::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_barcodeetikette_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_barcodeetikette_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBarcodeetikette::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_barcodeetikette_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("barcodeetikette")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_barcodeetikette_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBarcodeetikette::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_barcodeetikette_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("barcodeetikette")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_barcodeetikette_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBarcodenr = New SqlInt32(CType(dtToReturn.Rows(0)("barcodenr"), Integer))
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBarcodeetikette::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_barcodeetikette_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_barcodeetikette_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsBarcodeetikette::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsBarcodeetikette Fields

clsBarcodeetikette overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBarcodenr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsBarcodeetikette Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_iBarcodenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBarcodenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBarcodenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBarcodenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBarcodenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBarcodenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBarcodenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


m_sDokumentid Variable

Private 		m_sDokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsBarcodeetikette


clsCold_folder Class

For a list of all members of this type, see clsCold_folder Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsCold_folder

Public Class clsCold_folder
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsCold_folder Members


clsCold_folder Members

clsCold_folder overview

Constructors

constructor clsCold_folder Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_foldernr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBatch_parameter
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_foldernr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBatch_parameter
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsCold_folder Class


clsCold_folder Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder Properties

clsCold_folder overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_foldernr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBatch_parameter
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsCold_folder Class


clsCold_folder.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.iCold_foldernr Property

Public Property [iCold_foldernr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_foldernr]() As SqlInt32
            Get
                Return m_iCold_foldernr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iCold_foldernrTmp As SqlInt32 = Value
                If iCold_foldernrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iCold_foldernr", "iCold_foldernr can't be NULL")
                End If
                m_iCold_foldernr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.sBatch_parameter Property

Public Property [sBatch_parameter]() As SqlString

Source code

[Visual Basic]
        Public Property [sBatch_parameter]() As SqlString
            Get
                Return m_sBatch_parameter
            End Get
            Set(ByVal Value As SqlString)
                m_sBatch_parameter = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder Methods

clsCold_folder overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsCold_folder Class


clsCold_folder.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_cold_folder_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_cold_folder_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsCold_folder::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_cold_folder_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbatch_parameter", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBatch_parameter))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_cold_folder_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsCold_folder::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_cold_folder_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("cold_folder")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_cold_folder_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsCold_folder::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_cold_folder_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("cold_folder")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_cold_folder_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iCold_foldernr = New SqlInt32(CType(dtToReturn.Rows(0)("cold_foldernr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("batch_parameter") Is System.DBNull.Value Then
                        m_sBatch_parameter = SqlString.Null
                    Else
                        m_sBatch_parameter = New SqlString(CType(dtToReturn.Rows(0)("batch_parameter"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsCold_folder::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_cold_folder_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbatch_parameter", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBatch_parameter))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_cold_folder_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsCold_folder::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsCold_folder Fields

clsCold_folder overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_foldernr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBatch_parameter
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsCold_folder Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_iCold_foldernr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iCold_foldernr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iCold_foldernr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iCold_foldernr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iCold_foldernr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iCold_foldernr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iCold_foldernr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_sBatch_parameter Variable

Private 		m_sBezeichnung, _
   m_sBatch_parameter, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBatch_parameter, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sBatch_parameter, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBatch_parameter, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBatch_parameter, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBatch_parameter, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsCold_folder


clsColdindex Class

For a list of all members of this type, see clsColdindex Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsColdindex

Public Class clsColdindex
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsColdindex Members


clsColdindex Members

clsColdindex overview

Constructors

constructor clsColdindex Constructor

Properties

property bAktiv
property bZwingend
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_foldernr
property iCold_foldernrOld
property iCold_indexfeldnr
property iCold_indexfeldnrOld
property iColdindexnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWcold_foldernrLogic
method SelectAllWcold_indexfeldnrLogic
method SelectOne
method Update
method UpdateAllWcold_foldernrLogic
method UpdateAllWcold_indexfeldnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bZwingend
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_foldernr
field m_iCold_foldernrOld
field m_iCold_indexfeldnr
field m_iCold_indexfeldnrOld
field m_iColdindexnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsColdindex Class


clsColdindex Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex Properties

clsColdindex overview

Properties

property bAktiv
property bZwingend
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_foldernr
property iCold_foldernrOld
property iCold_indexfeldnr
property iCold_indexfeldnrOld
property iColdindexnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsColdindex Class


clsColdindex.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.bZwingend Property

Public Property [bZwingend]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZwingend]() As SqlBoolean
            Get
                Return m_bZwingend
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bZwingendTmp As SqlBoolean = Value
                If bZwingendTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bZwingend", "bZwingend can't be NULL")
                End If
                m_bZwingend = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iCold_foldernr Property

Public Property [iCold_foldernr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_foldernr]() As SqlInt32
            Get
                Return m_iCold_foldernr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_foldernr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iCold_foldernrOld Property

Public Property [iCold_foldernrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_foldernrOld]() As SqlInt32
            Get
                Return m_iCold_foldernrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_foldernrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iCold_indexfeldnr Property

Public Property [iCold_indexfeldnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_indexfeldnr]() As SqlInt32
            Get
                Return m_iCold_indexfeldnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_indexfeldnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iCold_indexfeldnrOld Property

Public Property [iCold_indexfeldnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_indexfeldnrOld]() As SqlInt32
            Get
                Return m_iCold_indexfeldnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_indexfeldnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iColdindexnr Property

Public Property [iColdindexnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdindexnr]() As SqlInt32
            Get
                Return m_iColdindexnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iColdindexnrTmp As SqlInt32 = Value
                If iColdindexnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iColdindexnr", "iColdindexnr can't be NULL")
                End If
                m_iColdindexnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex Methods

clsColdindex overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWcold_foldernrLogic
method SelectAllWcold_indexfeldnrLogic
method SelectOne
method Update
method UpdateAllWcold_foldernrLogic
method UpdateAllWcold_indexfeldnrLogic

See Also

clsColdindex Class


clsColdindex.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzwingend", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("coldindex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.SelectAllWcold_foldernrLogic Method

Public Function SelectAllWcold_foldernrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWcold_foldernrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_SelectAllWcold_foldernrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("coldindex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_SelectAllWcold_foldernrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::SelectAllWcold_foldernrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.SelectAllWcold_indexfeldnrLogic Method

Public Function SelectAllWcold_indexfeldnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWcold_indexfeldnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_SelectAllWcold_indexfeldnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("coldindex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_SelectAllWcold_indexfeldnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::SelectAllWcold_indexfeldnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("coldindex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icoldindexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iColdindexnr = New SqlInt32(CType(dtToReturn.Rows(0)("coldindexnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    m_bZwingend = New SqlBoolean(CType(dtToReturn.Rows(0)("zwingend"), Boolean))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("cold_indexfeldnr") Is System.DBNull.Value Then
                        m_iCold_indexfeldnr = SqlInt32.Null
                    Else
                        m_iCold_indexfeldnr = New SqlInt32(CType(dtToReturn.Rows(0)("cold_indexfeldnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("cold_foldernr") Is System.DBNull.Value Then
                        m_iCold_foldernr = SqlInt32.Null
                    Else
                        m_iCold_foldernr = New SqlInt32(CType(dtToReturn.Rows(0)("cold_foldernr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzwingend", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.UpdateAllWcold_foldernrLogic Method

Public Function UpdateAllWcold_foldernrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWcold_foldernrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_UpdateAllWcold_foldernrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_foldernr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_foldernrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_foldernrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_UpdateAllWcold_foldernrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::UpdateAllWcold_foldernrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex.UpdateAllWcold_indexfeldnrLogic Method

Public Function UpdateAllWcold_indexfeldnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWcold_indexfeldnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_coldindex_UpdateAllWcold_indexfeldnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_coldindex_UpdateAllWcold_indexfeldnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsColdindex::UpdateAllWcold_indexfeldnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsColdindex Fields

clsColdindex overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bZwingend
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_foldernr
field m_iCold_foldernrOld
field m_iCold_indexfeldnr
field m_iCold_indexfeldnrOld
field m_iColdindexnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsColdindex Class


m_bAktiv Variable

Private 		m_bZwingend, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bZwingend, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_bZwingend Variable

Private 		m_bZwingend, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bZwingend, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iCold_foldernr Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iCold_foldernrOld Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iCold_indexfeldnr Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iCold_indexfeldnrOld Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iColdindexnr Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iMandantnr Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_iMutierer Variable

Private 		m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iMutierer, _
   m_iCold_foldernr, _
   m_iCold_foldernrOld, _
   m_iMandantnr, _
   m_iColdindexnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iMutierer, m_iCold_foldernr, m_iCold_foldernrOld, m_iMandantnr, m_iColdindexnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsColdindex


clsConnectionProvider Class

For a list of all members of this type, see clsConnectionProvider Members.

System.Object
EDOKAApp.edokadb.clsConnectionProvider

Public Class clsConnectionProvider
   Implements IDisposable

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsConnectionProvider Members


clsConnectionProvider Members

clsConnectionProvider overview

Constructors

constructor clsConnectionProvider Constructor

Properties

property bIsTransactionPending
property sConnectionString
property scoDBConnection
property stCurrentTransaction

Methods

method BeginTransaction
method CloseConnection
method CommitTransaction
method Dispose (Overloaded)
method InitClass
method OpenConnection
method RollbackTransaction
method SaveTransaction

Fields

field m_alSavePoints
field m_bIsDisposed
field m_bIsTransactionPending
field m_scoDBConnection
field m_stCurrentTransaction

See Also

clsConnectionProvider Class


clsConnectionProvider Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Init the class
            InitClass()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider Properties

clsConnectionProvider overview

Properties

property bIsTransactionPending
property sConnectionString
property scoDBConnection
property stCurrentTransaction

See Also

clsConnectionProvider Class


clsConnectionProvider.bIsTransactionPending Property

Public ReadOnly Property bIsTransactionPending() As Boolean

Source code

[Visual Basic]
        Public ReadOnly Property bIsTransactionPending() As Boolean
            Get
                Return m_bIsTransactionPending
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.sConnectionString Property

Public WriteOnly Property sConnectionString() As String

Source code

[Visual Basic]
        Public WriteOnly Property sConnectionString() As String
            Set (ByVal Value As String)
                m_scoDBConnection.ConnectionString = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.scoDBConnection Property

Public ReadOnly Property scoDBConnection() As SqlConnection

Source code

[Visual Basic]
        Public ReadOnly Property scoDBConnection() As SqlConnection
            Get
                Return m_scoDBConnection
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.stCurrentTransaction Property

Public ReadOnly Property stCurrentTransaction() As SqlTransaction

Source code

[Visual Basic]
        Public ReadOnly Property stCurrentTransaction() As SqlTransaction
            Get
                Return m_stCurrentTransaction
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider Methods

clsConnectionProvider overview

Methods

method BeginTransaction
method CloseConnection
method CommitTransaction
method Dispose (Overloaded)
method InitClass
method OpenConnection
method RollbackTransaction
method SaveTransaction

See Also

clsConnectionProvider Class


clsConnectionProvider.BeginTransaction Method

Public Function BeginTransaction( _
   sTransactionName As String _
) As Boolean

Parameters

sTransactionName
Required.

Source code

[Visual Basic]
        Public Function BeginTransaction(sTransactionName As String) As Boolean
            Try
                If m_bIsTransactionPending Then
                    ' // no nested transactions allowed.
                    Throw New Exception("BeginTransaction::Already transaction pending. Nesting not allowed")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("BeginTransaction::Connection is not open.")
                End If
                ' // begin the transaction and store the transaction object.
                m_stCurrentTransaction = m_scoDBConnection.BeginTransaction(IsolationLevel.ReadCommitted, sTransactionName)
                m_bIsTransactionPending = True
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.CloseConnection Method

Public Function CloseConnection( _
   bCommitPendingTransaction As Boolean _
) As Boolean

Parameters

bCommitPendingTransaction
Required.

Source code

[Visual Basic]
        Public Function CloseConnection(bCommitPendingTransaction As Boolean) As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // No open connection
                    Return False
                End If
                If m_bIsTransactionPending Then
                    If bCommitPendingTransaction Then
                        ' // Commit the pending transaction
                        m_stCurrentTransaction.Commit()
                    Else
                        ' // Rollback the pending transaction
                        m_stCurrentTransaction.Rollback()
                    End If
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                ' // close the connection
                m_scoDBConnection.Close()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.CommitTransaction Method

Public Function CommitTransaction() As Boolean

Source code

[Visual Basic]
        Public Function CommitTransaction() As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("CommitTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("CommitTransaction::Connection is not open.")
                End if
                ' // commit the transaction
                m_stCurrentTransaction.Commit()
                m_bIsTransactionPending = False
                m_stCurrentTransaction.Dispose()
                m_stCurrentTransaction = Nothing
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


Dispose Method

Overload List

[Visual Basic] Overloads Public Sub Dispose() Implements IDisposable.Dispose

[Visual Basic] Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)

See Also

clsConnectionProvider | edokadb


clsConnectionProvider.InitClass Method

Private Sub InitClass()

Source code

[Visual Basic]
        Private Sub InitClass()
            ' // Create all the objects and initialize other members.
            m_scoDBConnection = new SqlConnection()
            m_bIsDisposed = False
            m_stCurrentTransaction = Nothing
            m_bIsTransactionPending = False
            m_alSavePoints = new ArrayList()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.OpenConnection Method

Public Function OpenConnection() As Boolean

Source code

[Visual Basic]
        Public Function OpenConnection() As Boolean
            Try
                If (m_scoDBConnection.State And ConnectionState.Open) > 0 Then
                    ' // It's already open.
                    Throw New Exception("OpenConnection::Connection is already open.")
                End If
                m_scoDBConnection.Open()
                m_bIsTransactionPending = False
                m_alSavePoints.Clear()
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.RollbackTransaction Method

Public Function RollbackTransaction( _
   sTransactionToRollback As String _
) As Boolean

Parameters

sTransactionToRollback
Required.

Source code

[Visual Basic]
        Public Function RollbackTransaction(sTransactionToRollback As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("RollbackTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("RollbackTransaction::Connection is not open.")
                End If
                ' // rollback the transaction
                m_stCurrentTransaction.Rollback(sTransactionToRollback)
                ' // if this wasn't a savepoint, we've rolled back the complete transaction, so we
                ' // can clean it up.
                If Not m_alSavePoints.Contains(sTransactionToRollback) Then
                    ' // it's not a savepoint
                    m_bIsTransactionPending = False
                    m_stCurrentTransaction.Dispose()
                    m_stCurrentTransaction = Nothing
                    m_alSavePoints.Clear()
                End If
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider.SaveTransaction Method

Public Function SaveTransaction( _
   sSavePointName As String _
) As Boolean

Parameters

sSavePointName
Required.

Source code

[Visual Basic]
        Public Function SaveTransaction(sSavePointName As String) As Boolean
            Try
                If Not m_bIsTransactionPending Then
                    ' // no transaction pending
                    Throw New Exception("SaveTransaction::No transaction pending.")
                End If
                If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
                    ' // no open connection
                    Throw New Exception("SaveTransaction::Connection is not open.")
                End If
                ' // save the transaction
                m_stCurrentTransaction.Save(sSavePointName)
                ' // Store the savepoint in the list.
                m_alSavePoints.Add(sSavePointName)
                Return True
            Catch ex As Exception
                ' // bubble exception
                Throw ex
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsConnectionProvider Fields

clsConnectionProvider overview

Fields

field m_alSavePoints
field m_bIsDisposed
field m_bIsTransactionPending
field m_scoDBConnection
field m_stCurrentTransaction

See Also

clsConnectionProvider Class


m_alSavePoints Variable

Private		m_alSavePoints As ArrayList

Source code

[Visual Basic]
        Private		m_alSavePoints As ArrayList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


m_bIsDisposed Variable

Private		m_bIsTransactionPending, _
   m_bIsDisposed As Boolean

Source code

[Visual Basic]
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


m_bIsTransactionPending Variable

Private		m_bIsTransactionPending, _
   m_bIsDisposed As Boolean

Source code

[Visual Basic]
        Private		m_bIsTransactionPending, m_bIsDisposed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


m_scoDBConnection Variable

Private		m_scoDBConnection As SqlConnection

Source code

[Visual Basic]
        Private		m_scoDBConnection As SqlConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


m_stCurrentTransaction Variable

Private		m_stCurrentTransaction As SqlTransaction

Source code

[Visual Basic]
        Private		m_stCurrentTransaction As SqlTransaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsDBInteractionBase Class

For a list of all members of this type, see clsDBInteractionBase Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsOffice_Vorlage_Datei
EDOKAApp.edokaDB.clsParameterSetList
EDOKAApp.edokaDB.clsProfilDokAuswertung
EDOKAApp.edokaDB.clsReport_reportfeldregel
EDOKAApp.edokaDB.clsReport_reportgruppe
EDOKAApp.edokadb.clsAnreden
EDOKAApp.edokadb.clsApplikation
EDOKAApp.edokadb.clsBarcodeetikette
EDOKAApp.edokadb.clsCold_folder
EDOKAApp.edokadb.clsColdindex
EDOKAApp.edokadb.clsDoks
EDOKAApp.edokadb.clsDokument
EDOKAApp.edokadb.clsDokument_status
EDOKAApp.edokadb.clsDokumentart
EDOKAApp.edokadb.clsDokumentaufhebung
EDOKAApp.edokadb.clsDokumentcoldindexwert
EDOKAApp.edokadb.clsDokumentfavoriten
EDOKAApp.edokadb.clsDokumentfavoriten_struktur
EDOKAApp.edokadb.clsDokumentfavorithierarchie
EDOKAApp.edokadb.clsDokumentindexmutation
EDOKAApp.edokadb.clsDokumentstatus
EDOKAApp.edokadb.clsDokumentstatus_funktion
EDOKAApp.edokadb.clsDokumentstatus_rolle
EDOKAApp.edokadb.clsDokumenttyp
EDOKAApp.edokadb.clsDomainTable
EDOKAApp.edokadb.clsEDEX_BL_Auslieferung
EDOKAApp.edokadb.clsEDEX_BL_BLIndex
EDOKAApp.edokadb.clsEDEX_BL_BLKunde
EDOKAApp.edokadb.clsEDEX_BL_Druckjob
EDOKAApp.edokadb.clsEDEX_BL_Hostdokument
EDOKAApp.edokadb.clsEDEX_BL_Status
EDOKAApp.edokadb.clsEDEX_Favoriten
EDOKAApp.edokadb.clsEdex_bl_parameter
EDOKAApp.edokadb.clsEdex_dokumentpaket
EDOKAApp.edokadb.clsEdex_dokumentpaketvorlage
EDOKAApp.edokadb.clsEdex_dpinstanz
EDOKAApp.edokadb.clsEdex_sb_notizen
EDOKAApp.edokadb.clsEdex_sb_partnerliste
EDOKAApp.edokadb.clsEdex_sb_serienbrief
EDOKAApp.edokadb.clsEdoka_adressen
EDOKAApp.edokadb.clsEdoka_etbez0
EDOKAApp.edokadb.clsEdoka_etpar0
EDOKAApp.edokadb.clsEtparn
EDOKAApp.edokadb.clsEtparu
EDOKAApp.edokadb.clsFunktionsgruppe_reportgruppe
EDOKAApp.edokadb.clsFunktionsgruppe_rolle
EDOKAApp.edokadb.clsIdvmakro_office_vorlage
EDOKAApp.edokadb.clsKey_tabelle
EDOKAApp.edokadb.clsKostenstelle
EDOKAApp.edokadb.clsLand
EDOKAApp.edokadb.clsMandant
EDOKAApp.edokadb.clsMeldungstexte
EDOKAApp.edokadb.clsMitarbeiter
EDOKAApp.edokadb.clsMitarbeiter_funktionsgruppe
EDOKAApp.edokadb.clsMitarbeiterrolle
EDOKAApp.edokadb.clsNldokumenttyp
EDOKAApp.edokadb.clsNotizen
EDOKAApp.edokadb.clsObjektbezeichnung
EDOKAApp.edokadb.clsOffice_vorlage
EDOKAApp.edokadb.clsOrt
EDOKAApp.edokadb.clsPartner
EDOKAApp.edokadb.clsPartner_Hauptadresse
EDOKAApp.edokadb.clsPhysischesArchiv
EDOKAApp.edokadb.clsProfil
EDOKAApp.edokadb.clsProzess
EDOKAApp.edokadb.clsReportfeld
EDOKAApp.edokadb.clsReportgruppe_report
EDOKAApp.edokadb.clsReportingSortOrderUser
EDOKAApp.edokadb.clsReporting_Dokumenttyp
EDOKAApp.edokadb.clsRolle_dokumentart
EDOKAApp.edokadb.clsRolle_dokumenttyp
EDOKAApp.edokadb.clsRolle_report_gruppe
EDOKAApp.edokadb.clsRolle_sysadminfunktion
EDOKAApp.edokadb.clsRolleberechtigung
EDOKAApp.edokadb.clsServices
EDOKAApp.edokadb.clsSpalten
EDOKAApp.edokadb.clsStatus
EDOKAApp.edokadb.clsStatushistory
EDOKAApp.edokadb.clsStatustyp
EDOKAApp.edokadb.clsSuchdaten
EDOKAApp.edokadb.clsSuchprofil
EDOKAApp.edokadb.clsSysadminfunktion
EDOKAApp.edokadb.clsTeam
EDOKAApp.edokadb.clsTeammitarbeiter
EDOKAApp.edokadb.clsTempdokument
EDOKAApp.edokadb.clsTempdokumentcoldindexwert
EDOKAApp.edokadb.clsTempdokumentinfo_wert
EDOKAApp.edokadb.clsTempdokumentmutation_cold
EDOKAApp.edokadb.clsTempdokumentzuordnungen
EDOKAApp.edokadb.clsTempnotizen
EDOKAApp.edokadb.clsTempstatushistory
EDOKAApp.edokadb.clsTmpdokument
EDOKAApp.edokadb.clsVV
EDOKAApp.edokadb.clsVorlagenfeld
EDOKAApp.edokadb.clsVorlagenfeldbezeichnung
EDOKAApp.edokadb.clsWindowPositions

Public MustInherit Class clsDBInteractionBase
   Implements IDisposable
   Implements ICommonDBAccess

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDBInteractionBase Members


clsDBInteractionBase Members

clsDBInteractionBase overview

Constructors

constructor clsDBInteractionBase Constructor

Properties

property cpMainConnectionProvider
property iErrorCode
property sConnectionString

Methods

method Delete
method Dispose (Overloaded)
method InitClass
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bIsDisposed
field m_bMainConnectionIsCreatedLocal
field m_cpMainConnectionProvider
field m_iErrorCode
field m_sConnectionString
field m_scoMainConnection

See Also

clsDBInteractionBase Class


clsDBInteractionBase Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Initialize the class' members.
            InitClass()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase Properties

clsDBInteractionBase overview

Properties

property cpMainConnectionProvider
property iErrorCode
property sConnectionString

See Also

clsDBInteractionBase Class


clsDBInteractionBase Methods

clsDBInteractionBase overview

Methods

method Delete
method Dispose (Overloaded)
method InitClass
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDBInteractionBase Class


clsDBInteractionBase.Delete Method

Public Overridable Function Delete() As Boolean Implements ICommonDBAccess.Delete

Source code

[Visual Basic]
        Public Overridable Function Delete() As Boolean Implements ICommonDBAccess.Delete
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.InitClass Method

Private Sub InitClass()

Source code

[Visual Basic]
        Private Sub InitClass()
            ' // create all the objects and initialize other members.
            m_scoMainConnection = new SqlConnection()
            m_bMainConnectionIsCreatedLocal = True
            m_cpMainConnectionProvider = Nothing
            m_iErrorCode = New SqlInt32(LLBLError.AllOk)
            m_bIsDisposed = False
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.Insert Method

Public Overridable Function Insert() As Boolean Implements ICommonDBAccess.Insert

Source code

[Visual Basic]
        Public Overridable Function Insert() As Boolean Implements ICommonDBAccess.Insert
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.SelectAll Method

Public Overridable Function SelectAll() As DataTable Implements ICommonDBAccess.SelectAll

Source code

[Visual Basic]
        Public Overridable Function SelectAll() As DataTable Implements ICommonDBAccess.SelectAll
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.SelectOne Method

Public Overridable Function SelectOne() As DataTable Implements ICommonDBAccess.SelectOne

Source code

[Visual Basic]
        Public Overridable Function SelectOne() As DataTable Implements ICommonDBAccess.SelectOne
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase.Update Method

Public Overridable Function Update() As Boolean Implements ICommonDBAccess.Update

Source code

[Visual Basic]
        Public Overridable Function Update() As Boolean Implements ICommonDBAccess.Update
            ' // No implementation, throw exception
            Throw New NotImplementedException()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDBInteractionBase Fields

clsDBInteractionBase overview

Fields

field m_bIsDisposed
field m_bMainConnectionIsCreatedLocal
field m_cpMainConnectionProvider
field m_iErrorCode
field m_sConnectionString
field m_scoMainConnection

See Also

clsDBInteractionBase Class


m_bIsDisposed Variable

Private		m_bIsDisposed As Boolean

Source code

[Visual Basic]
        Private		m_bIsDisposed As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


m_sConnectionString Variable

Private		m_sConnectionString As String

Source code

[Visual Basic]
        Private		m_sConnectionString As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsDoks Class

For a list of all members of this type, see clsDoks Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDoks

Public Class clsDoks
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDoks Members


clsDoks Members

clsDoks overview

Constructors

constructor clsDoks Constructor

Properties

property biDokument
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentID

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_biDokument
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sDokumentID
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDoks Class


clsDoks Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks Properties

clsDoks overview

Properties

property biDokument
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentID

See Also

clsDoks Class


clsDoks.biDokument Property

Public Property [biDokument]() As SqlBinary

Source code

[Visual Basic]
        Public Property [biDokument]() As SqlBinary
            Get
                Return m_biDokument
            End Get
            Set(ByVal Value As SqlBinary)
                m_biDokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks.sDokumentID Property

Public Property [sDokumentID]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentID]() As SqlString
            Get
                Return m_sDokumentID
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentIDTmp As SqlString = Value
                If sDokumentIDTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentID", "sDokumentID can't be NULL")
                End If
                m_sDokumentID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks Methods

clsDoks overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDoks Class


clsDoks.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Doks_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDokumentID", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Doks_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDoks::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Doks_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDokumentID", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@biDokument", SqlDbType.Binary, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_biDokument))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Doks_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDoks::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Doks_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Doks")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Doks_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDoks::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Doks_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Doks")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sDokumentID", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Doks_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_sDokumentID = New SqlString(CType(dtToReturn.Rows(0)("DokumentID"), String))
                    If dtToReturn.Rows(0)("Dokument") Is System.DBNull.Value Then
                        m_biDokument = SqlBinary.Null
                    Else
                        m_biDokument = New SqlBinary(CType(dtToReturn.Rows(0)("Dokument"), Byte()))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDoks::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Doks_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDokumentID", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@biDokument", SqlDbType.Binary, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_biDokument))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Doks_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDoks::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDoks Fields

clsDoks overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_biDokument
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sDokumentID
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDoks Class


m_biDokument Variable

Private 		m_biDokument As SqlBinary

Source code

[Visual Basic]
        Private 		m_biDokument As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


m_sDokumentID Variable

Private 		m_sDokumentID As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentID As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDoks


clsDokument Class

For a list of all members of this type, see clsDokument Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokument

Public Class clsDokument
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokument Members


clsDokument Members

clsDokument overview

Constructors

constructor clsDokument Constructor

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBedRRetourniert
property bBereit_zur_archivierung
property bBl_scan
property bBldossier
property bEingangsarchiviert
property bFAStatuswechsel
property bFAVerantwortlicherwechsel
property bFapartnerwechsel
property bGesperrt
property bOfficedokumentgeloescht
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErinnerungam
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iAnzeigeStatus
property iAufbewahrung_elektronisch
property iAufbewahrung_phaysisch
property iBRVernichtungnachTagen
property iBarcodenr
property iBck
property iBearbeitung_nach_abschluss
property iBearbeitungszeit_in_minuten
property iColdstatus
property iDokdurchkubeweitergegeben
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iIn_edoka_datenbank
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMonierung_in_tagen
property iMutierer
property iMutiererteam
property iMutierertieam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sAnredezustelladresse
property sBedRDokumentid
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sColdfolder
property sColdschema
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sFANummer1
property sFANummer2
property sFanummer3
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sVvnr
property sZustelladresse

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBedRRetourniert
field m_bBereit_zur_archivierung
field m_bBl_scan
field m_bBldossier
field m_bEingangsarchiviert
field m_bFAStatuswechsel
field m_bFAVerantwortlicherwechsel
field m_bFapartnerwechsel
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bOfficedokumentgeloescht
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErinnerungam
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iAnzeigeStatus
field m_iAufbewahrung_elektronisch
field m_iAufbewahrung_phaysisch
field m_iBRVernichtungnachTagen
field m_iBarcodenr
field m_iBck
field m_iBearbeitung_nach_abschluss
field m_iBearbeitungszeit_in_minuten
field m_iColdstatus
field m_iDokdurchkubeweitergegeben
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iIn_edoka_datenbank
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMonierung_in_tagen
field m_iMutierer
field m_iMutiererteam
field m_iMutierertieam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sAnredezustelladresse
field m_sBedRDokumentid
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sColdfolder
field m_sColdschema
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sFANummer1
field m_sFANummer2
field m_sFanummer3
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sVvnr
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokument Class


clsDokument Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument Properties

clsDokument overview

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBedRRetourniert
property bBereit_zur_archivierung
property bBl_scan
property bBldossier
property bEingangsarchiviert
property bFAStatuswechsel
property bFAVerantwortlicherwechsel
property bFapartnerwechsel
property bGesperrt
property bOfficedokumentgeloescht
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErinnerungam
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iAnzeigeStatus
property iAufbewahrung_elektronisch
property iAufbewahrung_phaysisch
property iBRVernichtungnachTagen
property iBarcodenr
property iBck
property iBearbeitung_nach_abschluss
property iBearbeitungszeit_in_minuten
property iColdstatus
property iDokdurchkubeweitergegeben
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iIn_edoka_datenbank
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMonierung_in_tagen
property iMutierer
property iMutiererteam
property iMutierertieam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sAnredezustelladresse
property sBedRDokumentid
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sColdfolder
property sColdschema
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sFANummer1
property sFANummer2
property sFanummer3
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sVvnr
property sZustelladresse

See Also

clsDokument Class


clsDokument.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bAmsdokument Property

Public Property [bAmsdokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAmsdokument]() As SqlBoolean
            Get
                Return m_bAmsdokument
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAmsdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bAuserstuebernahme Property

Public Property [bAuserstuebernahme]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAuserstuebernahme]() As SqlBoolean
            Get
                Return m_bAuserstuebernahme
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAuserstuebernahme = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bAusgangsarchiviert Property

Public Property [bAusgangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusgangsarchiviert]() As SqlBoolean
            Get
                Return m_bAusgangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusgangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bBedRRetourniert Property

Public Property [bBedRRetourniert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBedRRetourniert]() As SqlBoolean
            Get
                Return m_bBedRRetourniert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBedRRetourniert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bBereit_zur_archivierung Property

Public Property [bBereit_zur_archivierung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBereit_zur_archivierung]() As SqlBoolean
            Get
                Return m_bBereit_zur_archivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBereit_zur_archivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bBl_scan Property

Public Property [bBl_scan]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBl_scan]() As SqlBoolean
            Get
                Return m_bBl_scan
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBl_scan = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bBldossier Property

Public Property [bBldossier]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBldossier]() As SqlBoolean
            Get
                Return m_bBldossier
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBldossier = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bEingangsarchiviert Property

Public Property [bEingangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEingangsarchiviert]() As SqlBoolean
            Get
                Return m_bEingangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEingangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bFAStatuswechsel Property

Public Property [bFAStatuswechsel]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFAStatuswechsel]() As SqlBoolean
            Get
                Return m_bFAStatuswechsel
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFAStatuswechsel = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bFAVerantwortlicherwechsel Property

Public Property [bFAVerantwortlicherwechsel]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFAVerantwortlicherwechsel]() As SqlBoolean
            Get
                Return m_bFAVerantwortlicherwechsel
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFAVerantwortlicherwechsel = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bFapartnerwechsel Property

Public Property [bFapartnerwechsel]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFapartnerwechsel]() As SqlBoolean
            Get
                Return m_bFapartnerwechsel
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFapartnerwechsel = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bGesperrt Property

Public Property [bGesperrt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGesperrt]() As SqlBoolean
            Get
                Return m_bGesperrt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGesperrt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bOfficedokumentgeloescht Property

Public Property [bOfficedokumentgeloescht]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bOfficedokumentgeloescht]() As SqlBoolean
            Get
                Return m_bOfficedokumentgeloescht
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bOfficedokumentgeloescht = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bUnvollstaendig Property

Public Property [bUnvollstaendig]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUnvollstaendig]() As SqlBoolean
            Get
                Return m_bUnvollstaendig
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bUnvollstaendig = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bVertraulich Property

Public Property [bVertraulich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertraulich]() As SqlBoolean
            Get
                Return m_bVertraulich
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertraulich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bZu_retournieren Property

Public Property [bZu_retournieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZu_retournieren]() As SqlBoolean
            Get
                Return m_bZu_retournieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZu_retournieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.bZustaendig_kube Property

Public Property [bZustaendig_kube]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZustaendig_kube]() As SqlBoolean
            Get
                Return m_bZustaendig_kube
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZustaendig_kube = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daArchivierungsdatum Property

Public Property [daArchivierungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daArchivierungsdatum]() As SqlDateTime
            Get
                Return m_daArchivierungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daArchivierungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daDatum_ausgangsarchivierung Property

Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daDatum_eingangsarchivierung Property

Public Property [daDatum_eingangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_eingangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daErinnerungam Property

Public Property [daErinnerungam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErinnerungam]() As SqlDateTime
            Get
                Return m_daErinnerungam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErinnerungam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daErstelltam Property

Public Property [daErstelltam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstelltam]() As SqlDateTime
            Get
                Return m_daErstelltam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstelltam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daErstellungsdatum Property

Public Property [daErstellungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellungsdatum]() As SqlDateTime
            Get
                Return m_daErstellungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daGesperrtam Property

Public Property [daGesperrtam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGesperrtam]() As SqlDateTime
            Get
                Return m_daGesperrtam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGesperrtam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daMutiertam Property

Public Property [daMutiertam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiertam]() As SqlDateTime
            Get
                Return m_daMutiertam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiertam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.daTermin Property

Public Property [daTermin]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTermin]() As SqlDateTime
            Get
                Return m_daTermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTermin = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iAnzeigeStatus Property

Public Property [iAnzeigeStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnzeigeStatus]() As SqlInt32
            Get
                Return m_iAnzeigeStatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnzeigeStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iAufbewahrung_elektronisch Property

Public Property [iAufbewahrung_elektronisch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAufbewahrung_elektronisch]() As SqlInt32
            Get
                Return m_iAufbewahrung_elektronisch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAufbewahrung_elektronisch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iAufbewahrung_phaysisch Property

Public Property [iAufbewahrung_phaysisch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAufbewahrung_phaysisch]() As SqlInt32
            Get
                Return m_iAufbewahrung_phaysisch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAufbewahrung_phaysisch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iBRVernichtungnachTagen Property

Public Property [iBRVernichtungnachTagen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBRVernichtungnachTagen]() As SqlInt32
            Get
                Return m_iBRVernichtungnachTagen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBRVernichtungnachTagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iBarcodenr Property

Public Property [iBarcodenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBarcodenr]() As SqlInt32
            Get
                Return m_iBarcodenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBarcodenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iBck Property

Public Property [iBck]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBck]() As SqlInt32
            Get
                Return m_iBck
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBck = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iBearbeitung_nach_abschluss Property

Public Property [iBearbeitung_nach_abschluss]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBearbeitung_nach_abschluss]() As SqlInt32
            Get
                Return m_iBearbeitung_nach_abschluss
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBearbeitung_nach_abschluss = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iBearbeitungszeit_in_minuten Property

Public Property [iBearbeitungszeit_in_minuten]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBearbeitungszeit_in_minuten]() As SqlInt32
            Get
                Return m_iBearbeitungszeit_in_minuten
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBearbeitungszeit_in_minuten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iColdstatus Property

Public Property [iColdstatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdstatus]() As SqlInt32
            Get
                Return m_iColdstatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iColdstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iDokdurchkubeweitergegeben Property

Public Property [iDokdurchkubeweitergegeben]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokdurchkubeweitergegeben]() As SqlInt32
            Get
                Return m_iDokdurchkubeweitergegeben
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokdurchkubeweitergegeben = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iErsteller Property

Public Property [iErsteller]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErsteller]() As SqlInt32
            Get
                Return m_iErsteller
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErsteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iErstellerteam Property

Public Property [iErstellerteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErstellerteam]() As SqlInt32
            Get
                Return m_iErstellerteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErstellerteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iGesperrt_durch Property

Public Property [iGesperrt_durch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iGesperrt_durch]() As SqlInt32
            Get
                Return m_iGesperrt_durch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGesperrt_durch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iIn_edoka_datenbank Property

Public Property [iIn_edoka_datenbank]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIn_edoka_datenbank]() As SqlInt32
            Get
                Return m_iIn_edoka_datenbank
            End Get
            Set(ByVal Value As SqlInt32)
                m_iIn_edoka_datenbank = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMa_ausgangsarchivierung Property

Public Property [iMa_ausgangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_ausgangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMa_eingangsarchivierung Property

Public Property [iMa_eingangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_eingangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMitarbeiternr1 Property

Public Property [iMitarbeiternr1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr1]() As SqlInt32
            Get
                Return m_iMitarbeiternr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMonierung_in_tagen Property

Public Property [iMonierung_in_tagen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMonierung_in_tagen]() As SqlInt32
            Get
                Return m_iMonierung_in_tagen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMonierung_in_tagen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMutiererteam Property

Public Property [iMutiererteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutiererteam]() As SqlInt32
            Get
                Return m_iMutiererteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutiererteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iMutierertieam Property

Public Property [iMutierertieam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierertieam]() As SqlInt32
            Get
                Return m_iMutierertieam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierertieam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iPostzustellung Property

Public Property [iPostzustellung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPostzustellung]() As SqlInt32
            Get
                Return m_iPostzustellung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPostzustellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iStatus_edoka_batch_ausgang Property

Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_ausgang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_ausgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iStatus_edoka_batch_eingang Property

Public Property [iStatus_edoka_batch_eingang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_eingang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_eingang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_eingang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iStatusnr Property

Public Property [iStatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatusnr]() As SqlInt32
            Get
                Return m_iStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iVerantwortlich Property

Public Property [iVerantwortlich]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerantwortlich]() As SqlInt32
            Get
                Return m_iVerantwortlich
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerantwortlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.iZustaendiger Property

Public Property [iZustaendiger]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZustaendiger]() As SqlInt32
            Get
                Return m_iZustaendiger
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZustaendiger = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sAnredezustelladresse Property

Public Property [sAnredezustelladresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sAnredezustelladresse]() As SqlString
            Get
                Return m_sAnredezustelladresse
            End Get
            Set(ByVal Value As SqlString)
                m_sAnredezustelladresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sBedRDokumentid Property

Public Property [sBedRDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sBedRDokumentid]() As SqlString
            Get
                Return m_sBedRDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sBedRDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sBemerkunguvm Property

Public Property [sBemerkunguvm]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkunguvm]() As SqlString
            Get
                Return m_sBemerkunguvm
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkunguvm = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sColddokumentid Property

Public Property [sColddokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sColddokumentid]() As SqlString
            Get
                Return m_sColddokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sColddokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sColdfolder Property

Public Property [sColdfolder]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdfolder]() As SqlString
            Get
                Return m_sColdfolder
            End Get
            Set(ByVal Value As SqlString)
                m_sColdfolder = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sColdschema Property

Public Property [sColdschema]() As SqlString

Source code

[Visual Basic]
        Public Property [sColdschema]() As SqlString
            Get
                Return m_sColdschema
            End Get
            Set(ByVal Value As SqlString)
                m_sColdschema = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentidTmp As SqlString = Value
                If sDokumentidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
                End If
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sDokumentidn Property

Public Property [sDokumentidn]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentidn]() As SqlString
            Get
                Return m_sDokumentidn
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentidn = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sDokumentname Property

Public Property [sDokumentname]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentname]() As SqlString
            Get
                Return m_sDokumentname
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sFANummer1 Property

Public Property [sFANummer1]() As SqlString

Source code

[Visual Basic]
        Public Property [sFANummer1]() As SqlString
            Get
                Return m_sFANummer1
            End Get
            Set(ByVal Value As SqlString)
                m_sFANummer1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sFANummer2 Property

Public Property [sFANummer2]() As SqlString

Source code

[Visual Basic]
        Public Property [sFANummer2]() As SqlString
            Get
                Return m_sFANummer2
            End Get
            Set(ByVal Value As SqlString)
                m_sFANummer2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sFanummer3 Property

Public Property [sFanummer3]() As SqlString

Source code

[Visual Basic]
        Public Property [sFanummer3]() As SqlString
            Get
                Return m_sFanummer3
            End Get
            Set(ByVal Value As SqlString)
                m_sFanummer3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sLoeschgrund Property

Public Property [sLoeschgrund]() As SqlString

Source code

[Visual Basic]
        Public Property [sLoeschgrund]() As SqlString
            Get
                Return m_sLoeschgrund
            End Get
            Set(ByVal Value As SqlString)
                m_sLoeschgrund = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sSpeicherort Property

Public Property [sSpeicherort]() As SqlString

Source code

[Visual Basic]
        Public Property [sSpeicherort]() As SqlString
            Get
                Return m_sSpeicherort
            End Get
            Set(ByVal Value As SqlString)
                m_sSpeicherort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sVersandadresse Property

Public Property [sVersandadresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sVersandadresse]() As SqlString
            Get
                Return m_sVersandadresse
            End Get
            Set(ByVal Value As SqlString)
                m_sVersandadresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sVvnr Property

Public Property [sVvnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sVvnr]() As SqlString
            Get
                Return m_sVvnr
            End Get
            Set(ByVal Value As SqlString)
                m_sVvnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.sZustelladresse Property

Public Property [sZustelladresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sZustelladresse]() As SqlString
            Get
                Return m_sZustelladresse
            End Get
            Set(ByVal Value As SqlString)
                m_sZustelladresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument Methods

clsDokument overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokument Class


clsDokument.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanredezustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnredezustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokdurchkubeweitergegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokdurchkubeweitergegeben))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBck))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitungszeit_in_minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitungszeit_in_minuten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imonierung_in_tagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMonierung_in_tagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_elektronisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_phaysisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_phaysisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iin_edoka_datenbank", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIn_edoka_datenbank))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitung_nach_abschluss", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitung_nach_abschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldfolder", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdfolder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldschema", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdschema))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerinnerungam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErinnerungam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer1", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer2", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfapartnerwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFapartnerwechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAStatuswechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAStatuswechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAVerantwortlicherwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAVerantwortlicherwechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBedRDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBedRDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBedRRetourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedRRetourniert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBRVernichtungnachTagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBRVernichtungnachTagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bofficedokumentgeloescht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bOfficedokumentgeloescht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFanummer3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svvnr", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVvnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzeigeStatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzeigeStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbl_scan", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBl_scan))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbldossier", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBldossier))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiternr1") Is System.DBNull.Value Then
                        m_iMitarbeiternr1 = SqlInt32.Null
                    Else
                        m_iMitarbeiternr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
                        m_iNrpar00 = SqlInt32.Null
                    Else
                        m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentidn") Is System.DBNull.Value Then
                        m_sDokumentidn = SqlString.Null
                    Else
                        m_sDokumentidn = New SqlString(CType(dtToReturn.Rows(0)("dokumentidn"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentname") Is System.DBNull.Value Then
                        m_sDokumentname = SqlString.Null
                    Else
                        m_sDokumentname = New SqlString(CType(dtToReturn.Rows(0)("dokumentname"), String))
                    End If
                    If dtToReturn.Rows(0)("ersteller") Is System.DBNull.Value Then
                        m_iErsteller = SqlInt32.Null
                    Else
                        m_iErsteller = New SqlInt32(CType(dtToReturn.Rows(0)("ersteller"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellerteam") Is System.DBNull.Value Then
                        m_iErstellerteam = SqlInt32.Null
                    Else
                        m_iErstellerteam = New SqlInt32(CType(dtToReturn.Rows(0)("erstellerteam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstelltam") Is System.DBNull.Value Then
                        m_daErstelltam = SqlDateTime.Null
                    Else
                        m_daErstelltam = New SqlDateTime(CType(dtToReturn.Rows(0)("erstelltam"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutierertieam") Is System.DBNull.Value Then
                        m_iMutierertieam = SqlInt32.Null
                    Else
                        m_iMutierertieam = New SqlInt32(CType(dtToReturn.Rows(0)("mutierertieam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiertam") Is System.DBNull.Value Then
                        m_daMutiertam = SqlDateTime.Null
                    Else
                        m_daMutiertam = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiertam"), Date))
                    End If
                    If dtToReturn.Rows(0)("speicherort") Is System.DBNull.Value Then
                        m_sSpeicherort = SqlString.Null
                    Else
                        m_sSpeicherort = New SqlString(CType(dtToReturn.Rows(0)("speicherort"), String))
                    End If
                    If dtToReturn.Rows(0)("gesperrt") Is System.DBNull.Value Then
                        m_bGesperrt = SqlBoolean.Null
                    Else
                        m_bGesperrt = New SqlBoolean(CType(dtToReturn.Rows(0)("gesperrt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("gesperrt_durch") Is System.DBNull.Value Then
                        m_iGesperrt_durch = SqlInt32.Null
                    Else
                        m_iGesperrt_durch = New SqlInt32(CType(dtToReturn.Rows(0)("gesperrt_durch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("gesperrtam") Is System.DBNull.Value Then
                        m_daGesperrtam = SqlDateTime.Null
                    Else
                        m_daGesperrtam = New SqlDateTime(CType(dtToReturn.Rows(0)("gesperrtam"), Date))
                    End If
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("auserstuebernahme") Is System.DBNull.Value Then
                        m_bAuserstuebernahme = SqlBoolean.Null
                    Else
                        m_bAuserstuebernahme = New SqlBoolean(CType(dtToReturn.Rows(0)("auserstuebernahme"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unvollstaendig") Is System.DBNull.Value Then
                        m_bUnvollstaendig = SqlBoolean.Null
                    Else
                        m_bUnvollstaendig = New SqlBoolean(CType(dtToReturn.Rows(0)("unvollstaendig"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bemerkunguvm") Is System.DBNull.Value Then
                        m_sBemerkunguvm = SqlString.Null
                    Else
                        m_sBemerkunguvm = New SqlString(CType(dtToReturn.Rows(0)("bemerkunguvm"), String))
                    End If
                    If dtToReturn.Rows(0)("bereit_zur_archivierung") Is System.DBNull.Value Then
                        m_bBereit_zur_archivierung = SqlBoolean.Null
                    Else
                        m_bBereit_zur_archivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("bereit_zur_archivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("ausgangsarchiviert") Is System.DBNull.Value Then
                        m_bAusgangsarchiviert = SqlBoolean.Null
                    Else
                        m_bAusgangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("ausgangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_ausgangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_ausgangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_ausgangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_ausgangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_ausgangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_ausgangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zu_retournieren") Is System.DBNull.Value Then
                        m_bZu_retournieren = SqlBoolean.Null
                    Else
                        m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("eingangsarchiviert") Is System.DBNull.Value Then
                        m_bEingangsarchiviert = SqlBoolean.Null
                    Else
                        m_bEingangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("eingangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_eingangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_eingangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_eingangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_eingangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_eingangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_eingangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_eingangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_eingangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_ausgang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_ausgang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_ausgang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_ausgang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_eingang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_eingang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_eingang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_eingang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("loeschgrund") Is System.DBNull.Value Then
                        m_sLoeschgrund = SqlString.Null
                    Else
                        m_sLoeschgrund = New SqlString(CType(dtToReturn.Rows(0)("loeschgrund"), String))
                    End If
                    If dtToReturn.Rows(0)("coldstatus") Is System.DBNull.Value Then
                        m_iColdstatus = SqlInt32.Null
                    Else
                        m_iColdstatus = New SqlInt32(CType(dtToReturn.Rows(0)("coldstatus"), Integer))
                    End If
                    If dtToReturn.Rows(0)("versandadresse") Is System.DBNull.Value Then
                        m_sVersandadresse = SqlString.Null
                    Else
                        m_sVersandadresse = New SqlString(CType(dtToReturn.Rows(0)("versandadresse"), String))
                    End If
                    If dtToReturn.Rows(0)("barcodenr") Is System.DBNull.Value Then
                        m_iBarcodenr = SqlInt32.Null
                    Else
                        m_iBarcodenr = New SqlInt32(CType(dtToReturn.Rows(0)("barcodenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("colddokumentid") Is System.DBNull.Value Then
                        m_sColddokumentid = SqlString.Null
                    Else
                        m_sColddokumentid = New SqlString(CType(dtToReturn.Rows(0)("colddokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("amsdokument") Is System.DBNull.Value Then
                        m_bAmsdokument = SqlBoolean.Null
                    Else
                        m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
                        m_iVerantwortlich = SqlInt32.Null
                    Else
                        m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendiger") Is System.DBNull.Value Then
                        m_iZustaendiger = SqlInt32.Null
                    Else
                        m_iZustaendiger = New SqlInt32(CType(dtToReturn.Rows(0)("zustaendiger"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftlinks") Is System.DBNull.Value Then
                        m_iUnterschriftlinks = SqlInt32.Null
                    Else
                        m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftrechts") Is System.DBNull.Value Then
                        m_iUnterschriftrechts = SqlInt32.Null
                    Else
                        m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    End If
                    If dtToReturn.Rows(0)("postzustellung") Is System.DBNull.Value Then
                        m_iPostzustellung = SqlInt32.Null
                    Else
                        m_iPostzustellung = New SqlInt32(CType(dtToReturn.Rows(0)("postzustellung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("statusnr") Is System.DBNull.Value Then
                        m_iStatusnr = SqlInt32.Null
                    Else
                        m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("statusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendig_kube") Is System.DBNull.Value Then
                        m_bZustaendig_kube = SqlBoolean.Null
                    Else
                        m_bZustaendig_kube = New SqlBoolean(CType(dtToReturn.Rows(0)("zustaendig_kube"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("zustelladresse") Is System.DBNull.Value Then
                        m_sZustelladresse = SqlString.Null
                    Else
                        m_sZustelladresse = New SqlString(CType(dtToReturn.Rows(0)("zustelladresse"), String))
                    End If
                    If dtToReturn.Rows(0)("vertraulich") Is System.DBNull.Value Then
                        m_bVertraulich = SqlBoolean.Null
                    Else
                        m_bVertraulich = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellungsdatum") Is System.DBNull.Value Then
                        m_daErstellungsdatum = SqlDateTime.Null
                    Else
                        m_daErstellungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("archivierungsdatum") Is System.DBNull.Value Then
                        m_daArchivierungsdatum = SqlDateTime.Null
                    Else
                        m_daArchivierungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("archivierungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("termin") Is System.DBNull.Value Then
                        m_daTermin = SqlDateTime.Null
                    Else
                        m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("termin"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiererteam") Is System.DBNull.Value Then
                        m_iMutiererteam = SqlInt32.Null
                    Else
                        m_iMutiererteam = New SqlInt32(CType(dtToReturn.Rows(0)("mutiererteam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("anredezustelladresse") Is System.DBNull.Value Then
                        m_sAnredezustelladresse = SqlString.Null
                    Else
                        m_sAnredezustelladresse = New SqlString(CType(dtToReturn.Rows(0)("anredezustelladresse"), String))
                    End If
                    If dtToReturn.Rows(0)("dokdurchkubeweitergegeben") Is System.DBNull.Value Then
                        m_iDokdurchkubeweitergegeben = SqlInt32.Null
                    Else
                        m_iDokdurchkubeweitergegeben = New SqlInt32(CType(dtToReturn.Rows(0)("dokdurchkubeweitergegeben"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bck") Is System.DBNull.Value Then
                        m_iBck = SqlInt32.Null
                    Else
                        m_iBck = New SqlInt32(CType(dtToReturn.Rows(0)("bck"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bearbeitungszeit_in_minuten") Is System.DBNull.Value Then
                        m_iBearbeitungszeit_in_minuten = SqlInt32.Null
                    Else
                        m_iBearbeitungszeit_in_minuten = New SqlInt32(CType(dtToReturn.Rows(0)("bearbeitungszeit_in_minuten"), Integer))
                    End If
                    If dtToReturn.Rows(0)("monierung_in_tagen") Is System.DBNull.Value Then
                        m_iMonierung_in_tagen = SqlInt32.Null
                    Else
                        m_iMonierung_in_tagen = New SqlInt32(CType(dtToReturn.Rows(0)("monierung_in_tagen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aufbewahrung_elektronisch") Is System.DBNull.Value Then
                        m_iAufbewahrung_elektronisch = SqlInt32.Null
                    Else
                        m_iAufbewahrung_elektronisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrung_elektronisch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aufbewahrung_phaysisch") Is System.DBNull.Value Then
                        m_iAufbewahrung_phaysisch = SqlInt32.Null
                    Else
                        m_iAufbewahrung_phaysisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrung_phaysisch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("in_edoka_datenbank") Is System.DBNull.Value Then
                        m_iIn_edoka_datenbank = SqlInt32.Null
                    Else
                        m_iIn_edoka_datenbank = New SqlInt32(CType(dtToReturn.Rows(0)("in_edoka_datenbank"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bearbeitung_nach_abschluss") Is System.DBNull.Value Then
                        m_iBearbeitung_nach_abschluss = SqlInt32.Null
                    Else
                        m_iBearbeitung_nach_abschluss = New SqlInt32(CType(dtToReturn.Rows(0)("bearbeitung_nach_abschluss"), Integer))
                    End If
                    If dtToReturn.Rows(0)("coldfolder") Is System.DBNull.Value Then
                        m_sColdfolder = SqlString.Null
                    Else
                        m_sColdfolder = New SqlString(CType(dtToReturn.Rows(0)("coldfolder"), String))
                    End If
                    If dtToReturn.Rows(0)("coldschema") Is System.DBNull.Value Then
                        m_sColdschema = SqlString.Null
                    Else
                        m_sColdschema = New SqlString(CType(dtToReturn.Rows(0)("coldschema"), String))
                    End If
                    If dtToReturn.Rows(0)("erinnerungam") Is System.DBNull.Value Then
                        m_daErinnerungam = SqlDateTime.Null
                    Else
                        m_daErinnerungam = New SqlDateTime(CType(dtToReturn.Rows(0)("erinnerungam"), Date))
                    End If
                    If dtToReturn.Rows(0)("FANummer1") Is System.DBNull.Value Then
                        m_sFANummer1 = SqlString.Null
                    Else
                        m_sFANummer1 = New SqlString(CType(dtToReturn.Rows(0)("FANummer1"), String))
                    End If
                    If dtToReturn.Rows(0)("FANummer2") Is System.DBNull.Value Then
                        m_sFANummer2 = SqlString.Null
                    Else
                        m_sFANummer2 = New SqlString(CType(dtToReturn.Rows(0)("FANummer2"), String))
                    End If
                    If dtToReturn.Rows(0)("fapartnerwechsel") Is System.DBNull.Value Then
                        m_bFapartnerwechsel = SqlBoolean.Null
                    Else
                        m_bFapartnerwechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("fapartnerwechsel"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("FAStatuswechsel") Is System.DBNull.Value Then
                        m_bFAStatuswechsel = SqlBoolean.Null
                    Else
                        m_bFAStatuswechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("FAStatuswechsel"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("FAVerantwortlicherwechsel") Is System.DBNull.Value Then
                        m_bFAVerantwortlicherwechsel = SqlBoolean.Null
                    Else
                        m_bFAVerantwortlicherwechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("FAVerantwortlicherwechsel"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("BedRDokumentid") Is System.DBNull.Value Then
                        m_sBedRDokumentid = SqlString.Null
                    Else
                        m_sBedRDokumentid = New SqlString(CType(dtToReturn.Rows(0)("BedRDokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("BedRRetourniert") Is System.DBNull.Value Then
                        m_bBedRRetourniert = SqlBoolean.Null
                    Else
                        m_bBedRRetourniert = New SqlBoolean(CType(dtToReturn.Rows(0)("BedRRetourniert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("BRVernichtungnachTagen") Is System.DBNull.Value Then
                        m_iBRVernichtungnachTagen = SqlInt32.Null
                    Else
                        m_iBRVernichtungnachTagen = New SqlInt32(CType(dtToReturn.Rows(0)("BRVernichtungnachTagen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("officedokumentgeloescht") Is System.DBNull.Value Then
                        m_bOfficedokumentgeloescht = SqlBoolean.Null
                    Else
                        m_bOfficedokumentgeloescht = New SqlBoolean(CType(dtToReturn.Rows(0)("officedokumentgeloescht"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("fanummer3") Is System.DBNull.Value Then
                        m_sFanummer3 = SqlString.Null
                    Else
                        m_sFanummer3 = New SqlString(CType(dtToReturn.Rows(0)("fanummer3"), String))
                    End If
                    If dtToReturn.Rows(0)("vvnr") Is System.DBNull.Value Then
                        m_sVvnr = SqlString.Null
                    Else
                        m_sVvnr = New SqlString(CType(dtToReturn.Rows(0)("vvnr"), String))
                    End If
                    If dtToReturn.Rows(0)("AnzeigeStatus") Is System.DBNull.Value Then
                        m_iAnzeigeStatus = SqlInt32.Null
                    Else
                        m_iAnzeigeStatus = New SqlInt32(CType(dtToReturn.Rows(0)("AnzeigeStatus"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bl_scan") Is System.DBNull.Value Then
                        m_bBl_scan = SqlBoolean.Null
                    Else
                        m_bBl_scan = New SqlBoolean(CType(dtToReturn.Rows(0)("bl_scan"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bldossier") Is System.DBNull.Value Then
                        m_bBldossier = SqlBoolean.Null
                    Else
                        m_bBldossier = New SqlBoolean(CType(dtToReturn.Rows(0)("bldossier"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanredezustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnredezustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokdurchkubeweitergegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokdurchkubeweitergegeben))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBck))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitungszeit_in_minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitungszeit_in_minuten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imonierung_in_tagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMonierung_in_tagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_elektronisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_phaysisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_phaysisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iin_edoka_datenbank", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIn_edoka_datenbank))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitung_nach_abschluss", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitung_nach_abschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldfolder", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdfolder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldschema", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdschema))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerinnerungam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErinnerungam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer1", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer2", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfapartnerwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFapartnerwechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAStatuswechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAStatuswechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAVerantwortlicherwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAVerantwortlicherwechsel))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBedRDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBedRDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBedRRetourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedRRetourniert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBRVernichtungnachTagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBRVernichtungnachTagen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bofficedokumentgeloescht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bOfficedokumentgeloescht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFanummer3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svvnr", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVvnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzeigeStatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzeigeStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbl_scan", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBl_scan))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbldossier", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBldossier))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument Fields

clsDokument overview

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBedRRetourniert
field m_bBereit_zur_archivierung
field m_bBl_scan
field m_bBldossier
field m_bEingangsarchiviert
field m_bFAStatuswechsel
field m_bFAVerantwortlicherwechsel
field m_bFapartnerwechsel
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bOfficedokumentgeloescht
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErinnerungam
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iAnzeigeStatus
field m_iAufbewahrung_elektronisch
field m_iAufbewahrung_phaysisch
field m_iBRVernichtungnachTagen
field m_iBarcodenr
field m_iBck
field m_iBearbeitung_nach_abschluss
field m_iBearbeitungszeit_in_minuten
field m_iColdstatus
field m_iDokdurchkubeweitergegeben
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iIn_edoka_datenbank
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMonierung_in_tagen
field m_iMutierer
field m_iMutiererteam
field m_iMutierertieam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sAnredezustelladresse
field m_sBedRDokumentid
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sColdfolder
field m_sColdschema
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sFANummer1
field m_sFANummer2
field m_sFanummer3
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sVvnr
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokument Class


m_bAktiv Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bAmsdokument Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bAuserstuebernahme Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bAusgangsarchiviert Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bBedRRetourniert Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bBereit_zur_archivierung Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bBl_scan Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bBldossier Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bEingangsarchiviert Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bFAStatuswechsel Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bFAVerantwortlicherwechsel Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bFapartnerwechsel Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bGesperrt Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bOfficedokumentgeloescht Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bUnvollstaendig Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bVertraulich Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bZu_retournieren Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_bZustaendig_kube Variable

Private 		m_bBereit_zur_archivierung, _
   m_bAusgangsarchiviert, _
   m_bUnvollstaendig, _
   m_bGesperrt, _
   m_bAuserstuebernahme, _
   m_bZu_retournieren, _
   m_bAmsdokument, _
   m_bAktiv, _
   m_bZustaendig_kube, _
   m_bEingangsarchiviert, _
   m_bVertraulich, _
   m_bFapartnerwechsel, _
   m_bBl_scan, _
   m_bOfficedokumentgeloescht, _
   m_bFAStatuswechsel, _
   m_bFAVerantwortlicherwechsel, _
   m_bBldossier, _
   m_bBedRRetourniert As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daArchivierungsdatum Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daDatum_ausgangsarchivierung Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daDatum_eingangsarchivierung Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daErinnerungam Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daErstelltam Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daErstellungsdatum Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daGesperrtam Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daMutiertam Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_daTermin Variable

Private 		m_daArchivierungsdatum, _
   m_daTermin, _
   m_daDatum_ausgangsarchivierung, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daGesperrtam, _
   m_daErinnerungam, _
   m_daMutiertam, _
   m_daErstelltam As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iAnzeigeStatus Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iAufbewahrung_elektronisch Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iAufbewahrung_phaysisch Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iBRVernichtungnachTagen Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iBarcodenr Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iBck Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iBearbeitung_nach_abschluss Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iBearbeitungszeit_in_minuten Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iColdstatus Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iDokdurchkubeweitergegeben Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iDokumenttypnr Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iErsteller Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iErstellerteam Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iGesperrt_durch Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iIn_edoka_datenbank Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMa_ausgangsarchivierung Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMa_eingangsarchivierung Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMitarbeiternr Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMitarbeiternr1 Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMonierung_in_tagen Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMutierer Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMutiererteam Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iMutierertieam Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iNrpar00 Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iPostzustellung Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iStatus_edoka_batch_ausgang Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iStatus_edoka_batch_eingang Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iStatusnr Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iUnterschriftlinks Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iUnterschriftrechts Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iVerantwortlich Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_iZustaendiger Variable

Private 		m_iUnterschriftrechts, _
   m_iAnzeigeStatus, _
   m_iPostzustellung, _
   m_iStatusnr, _
   m_iAufbewahrung_elektronisch, _
   m_iMonierung_in_tagen, _
   m_iAufbewahrung_phaysisch, _
   m_iBearbeitung_nach_abschluss, _
   m_iIn_edoka_datenbank, _
   m_iDokdurchkubeweitergegeben, _
   m_iMutiererteam, _
   m_iBRVernichtungnachTagen, _
   m_iBearbeitungszeit_in_minuten, _
   m_iBck, _
   m_iGesperrt_durch, _
   m_iMutierertieam, _
   m_iDokumenttypnr, _
   m_iMa_eingangsarchivierung, _
   m_iMa_ausgangsarchivierung, _
   m_iMutierer, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iNrpar00, _
   m_iErstellerteam, _
   m_iErsteller, _
   m_iZustaendiger, _
   m_iColdstatus, _
   m_iVerantwortlich, _
   m_iUnterschriftlinks, _
   m_iBarcodenr, _
   m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sAnredezustelladresse Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sBedRDokumentid Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sBemerkung Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sBemerkunguvm Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sBezeichnung Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sColddokumentid Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sColdfolder Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sColdschema Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sDokumentid Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sDokumentidn Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sDokumentname Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sFANummer1 Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sFANummer2 Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sFanummer3 Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sLoeschgrund Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sSpeicherort Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sVersandadresse Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sVvnr Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


m_sZustelladresse Variable

Private 		m_sDokumentname, _
   m_sColddokumentid, _
   m_sBedRDokumentid, _
   m_sVvnr, _
   m_sDokumentid, _
   m_sDokumentidn, _
   m_sFanummer3, _
   m_sZustelladresse, _
   m_sBemerkung, _
   m_sBezeichnung, _
   m_sLoeschgrund, _
   m_sAnredezustelladresse, _
   m_sBemerkunguvm, _
   m_sSpeicherort, _
   m_sFANummer1, _
   m_sFANummer2, _
   m_sVersandadresse, _
   m_sColdfolder, _
   m_sColdschema As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument


clsDokument_status Class

For a list of all members of this type, see clsDokument_status Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokument_status

Public Class clsDokument_status
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokument_status Members


clsDokument_status Members

clsDokument_status overview

Constructors

constructor clsDokument_status Constructor

Properties

property bAktiv
property bDokument_ausgangsarchivierung
property bDokument_bearbeitung_abgeschlossen
property bDokument_bearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property iDokument_statusnr
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iStatus_bezeichnungnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumenitid
property sReihenfolge

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivierung
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokument_bearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_iDokument_statusnr
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iStatus_bezeichnungnr
field m_sBezeichnung
field m_sDokumenitid
field m_sReihenfolge
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokument_status Class


clsDokument_status Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status Properties

clsDokument_status overview

Properties

property bAktiv
property bDokument_ausgangsarchivierung
property bDokument_bearbeitung_abgeschlossen
property bDokument_bearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property iDokument_statusnr
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iStatus_bezeichnungnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumenitid
property sReihenfolge

See Also

clsDokument_status Class


clsDokument_status.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.bDokument_ausgangsarchivierung Property

Public Property [bDokument_ausgangsarchivierung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_ausgangsarchivierung]() As SqlBoolean
            Get
                Return m_bDokument_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.bDokument_bearbeitung_abgeschlossen Property

Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean
            Get
                Return m_bDokument_bearbeitung_abgeschlossen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_bearbeitung_abgeschlossen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.bDokument_bearbeitung_moeglich Property

Public Property [bDokument_bearbeitung_moeglich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_bearbeitung_moeglich]() As SqlBoolean
            Get
                Return m_bDokument_bearbeitung_moeglich
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_bearbeitung_moeglich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.bFolgestatus_durch_anderen_verantwortlichen Property

Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean
            Get
                Return m_bFolgestatus_durch_anderen_verantwortlichen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFolgestatus_durch_anderen_verantwortlichen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.iDokument_statusnr Property

Public Property [iDokument_statusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokument_statusnr]() As SqlInt32
            Get
                Return m_iDokument_statusnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokument_statusnrTmp As SqlInt32 = Value
                If iDokument_statusnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokument_statusnr", "iDokument_statusnr can't be NULL")
                End If
                m_iDokument_statusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.iErledigung_ab Property

Public Property [iErledigung_ab]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErledigung_ab]() As SqlInt32
            Get
                Return m_iErledigung_ab
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErledigung_ab = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.iStatus_bezeichnungnr Property

Public Property [iStatus_bezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_bezeichnungnr]() As SqlInt32
            Get
                Return m_iStatus_bezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_bezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.sDokumenitid Property

Public Property [sDokumenitid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumenitid]() As SqlString
            Get
                Return m_sDokumenitid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumenitid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.sReihenfolge Property

Public Property [sReihenfolge]() As SqlString

Source code

[Visual Basic]
        Public Property [sReihenfolge]() As SqlString
            Get
                Return m_sReihenfolge
            End Get
            Set(ByVal Value As SqlString)
                m_sReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status Methods

clsDokument_status overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokument_status Class


clsDokument_status.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_status_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokument_statusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokument_statusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_status_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument_status::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_status_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumenitid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumenitid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreihenfolge", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokument_statusnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iDokument_statusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iDokument_statusnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@idokument_statusnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_status_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument_status::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_status_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokument_status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_status_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument_status::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_status_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokument_status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokument_statusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokument_statusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_status_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokument_statusnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokument_statusnr"), Integer))
                    If dtToReturn.Rows(0)("dokumenitid") Is System.DBNull.Value Then
                        m_sDokumenitid = SqlString.Null
                    Else
                        m_sDokumenitid = New SqlString(CType(dtToReturn.Rows(0)("dokumenitid"), String))
                    End If
                    If dtToReturn.Rows(0)("status_bezeichnungnr") Is System.DBNull.Value Then
                        m_iStatus_bezeichnungnr = SqlInt32.Null
                    Else
                        m_iStatus_bezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("status_bezeichnungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("reihenfolge") Is System.DBNull.Value Then
                        m_sReihenfolge = SqlString.Null
                    Else
                        m_sReihenfolge = New SqlString(CType(dtToReturn.Rows(0)("reihenfolge"), String))
                    End If
                    If dtToReturn.Rows(0)("folgestatus_durch_anderen_verantwortlichen") Is System.DBNull.Value Then
                        m_bFolgestatus_durch_anderen_verantwortlichen = SqlBoolean.Null
                    Else
                        m_bFolgestatus_durch_anderen_verantwortlichen = New SqlBoolean(CType(dtToReturn.Rows(0)("folgestatus_durch_anderen_verantwortlichen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokument_bearbeitung_moeglich") Is System.DBNull.Value Then
                        m_bDokument_bearbeitung_moeglich = SqlBoolean.Null
                    Else
                        m_bDokument_bearbeitung_moeglich = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_bearbeitung_moeglich"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erledigung_ab") Is System.DBNull.Value Then
                        m_iErledigung_ab = SqlInt32.Null
                    Else
                        m_iErledigung_ab = New SqlInt32(CType(dtToReturn.Rows(0)("erledigung_ab"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokument_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_bDokument_ausgangsarchivierung = SqlBoolean.Null
                    Else
                        m_bDokument_ausgangsarchivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_ausgangsarchivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen") Is System.DBNull.Value Then
                        m_bDokument_bearbeitung_abgeschlossen = SqlBoolean.Null
                    Else
                        m_bDokument_bearbeitung_abgeschlossen = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument_status::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokument_status_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokument_statusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokument_statusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumenitid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumenitid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreihenfolge", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokument_status_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokument_status::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokument_status Fields

clsDokument_status overview

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivierung
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokument_bearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_iDokument_statusnr
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iStatus_bezeichnungnr
field m_sBezeichnung
field m_sDokumenitid
field m_sReihenfolge
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokument_status Class


m_bAktiv Variable

Private 		m_bDokument_bearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivierung, _
   m_bAktiv, _
   m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_bearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivierung, m_bAktiv, m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_bDokument_ausgangsarchivierung Variable

Private 		m_bDokument_bearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivierung, _
   m_bAktiv, _
   m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_bearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivierung, m_bAktiv, m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_bDokument_bearbeitung_abgeschlossen Variable

Private 		m_bDokument_bearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivierung, _
   m_bAktiv, _
   m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_bearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivierung, m_bAktiv, m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_bDokument_bearbeitung_moeglich Variable

Private 		m_bDokument_bearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivierung, _
   m_bAktiv, _
   m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_bearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivierung, m_bAktiv, m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_bFolgestatus_durch_anderen_verantwortlichen Variable

Private 		m_bDokument_bearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivierung, _
   m_bAktiv, _
   m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_bearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivierung, m_bAktiv, m_bDokument_bearbeitung_abgeschlossen As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_daErstellt_am Variable

Private 		m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_iDokument_statusnr Variable

Private 		m_iDokument_statusnr, _
   m_iMutierer, _
   m_iStatus_bezeichnungnr, _
   m_iErledigung_ab As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokument_statusnr, m_iMutierer, m_iStatus_bezeichnungnr, m_iErledigung_ab As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_iErledigung_ab Variable

Private 		m_iDokument_statusnr, _
   m_iMutierer, _
   m_iStatus_bezeichnungnr, _
   m_iErledigung_ab As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokument_statusnr, m_iMutierer, m_iStatus_bezeichnungnr, m_iErledigung_ab As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_iMutierer Variable

Private 		m_iDokument_statusnr, _
   m_iMutierer, _
   m_iStatus_bezeichnungnr, _
   m_iErledigung_ab As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokument_statusnr, m_iMutierer, m_iStatus_bezeichnungnr, m_iErledigung_ab As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_iStatus_bezeichnungnr Variable

Private 		m_iDokument_statusnr, _
   m_iMutierer, _
   m_iStatus_bezeichnungnr, _
   m_iErledigung_ab As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokument_statusnr, m_iMutierer, m_iStatus_bezeichnungnr, m_iErledigung_ab As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_sBezeichnung Variable

Private 		m_sReihenfolge, _
   m_sBezeichnung, _
   m_sDokumenitid As SqlString

Source code

[Visual Basic]
        Private 		m_sReihenfolge, m_sBezeichnung, m_sDokumenitid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_sDokumenitid Variable

Private 		m_sReihenfolge, _
   m_sBezeichnung, _
   m_sDokumenitid As SqlString

Source code

[Visual Basic]
        Private 		m_sReihenfolge, m_sBezeichnung, m_sDokumenitid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


m_sReihenfolge Variable

Private 		m_sReihenfolge, _
   m_sBezeichnung, _
   m_sDokumenitid As SqlString

Source code

[Visual Basic]
        Private 		m_sReihenfolge, m_sBezeichnung, m_sDokumenitid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokument_status


clsDokumentart Class

For a list of all members of this type, see clsDokumentart Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentart
EDOKAApp.edokadb.clsMyDokumentart

Public Class clsDokumentart
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentart Members


clsDokumentart Members

clsDokumentart overview

Constructors

constructor clsDokumentart Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentart Class


clsDokumentart Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart Properties

clsDokumentart overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentart Class


clsDokumentart.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iDokumentartnr Property

Public Property [iDokumentartnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentartnr]() As SqlInt32
            Get
                Return m_iDokumentartnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentartnrTmp As SqlInt32 = Value
                If iDokumentartnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentartnr", "iDokumentartnr can't be NULL")
                End If
                m_iDokumentartnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iImageindex Property

Public Property [iImageindex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindex]() As SqlInt32
            Get
                Return m_iImageindex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iImageindexopen Property

Public Property [iImageindexopen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindexopen]() As SqlInt32
            Get
                Return m_iImageindexopen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindexopen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iParentid Property

Public Property [iParentid]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParentid]() As SqlInt32
            Get
                Return m_iParentid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart Methods

clsDokumentart overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentart Class


clsDokumentart.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumentart_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumentart_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentart::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumentart_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumentart_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentart::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumentart_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumentart_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentart::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumentart_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumentart_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentartnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentartnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("parentid") Is System.DBNull.Value Then
                        m_iParentid = SqlInt32.Null
                    Else
                        m_iParentid = New SqlInt32(CType(dtToReturn.Rows(0)("parentid"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindex") Is System.DBNull.Value Then
                        m_iImageindex = SqlInt32.Null
                    Else
                        m_iImageindex = New SqlInt32(CType(dtToReturn.Rows(0)("imageindex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindexopen") Is System.DBNull.Value Then
                        m_iImageindexopen = SqlInt32.Null
                    Else
                        m_iImageindexopen = New SqlInt32(CType(dtToReturn.Rows(0)("imageindexopen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentart::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Dokumentart_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Dokumentart_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentart::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentart Fields

clsDokumentart overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentart Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iDokumentartnr Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iImageindex Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iImageindexopen Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iParentid Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iSort Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_iSprache Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iImageindexopen, _
   m_iMutierer, _
   m_iDokumentartnr, _
   m_iParentid, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iImageindexopen, m_iMutierer, m_iDokumentartnr, m_iParentid, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentart


clsDokumentaufhebung Class

For a list of all members of this type, see clsDokumentaufhebung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentaufhebung

Public Class clsDokumentaufhebung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentaufhebung Members


clsDokumentaufhebung Members

clsDokumentaufhebung overview

Constructors

constructor clsDokumentaufhebung Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAufhebungnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAufhebungnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentaufhebung Class


clsDokumentaufhebung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung Properties

clsDokumentaufhebung overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAufhebungnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentaufhebung Class


clsDokumentaufhebung.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.iAufhebungnr Property

Public Property [iAufhebungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAufhebungnr]() As SqlInt32
            Get
                Return m_iAufhebungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAufhebungnrTmp As SqlInt32 = Value
                If iAufhebungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAufhebungnr", "iAufhebungnr can't be NULL")
                End If
                m_iAufhebungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.iFunktionnr Property

Public Property [iFunktionnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionnr]() As SqlInt32
            Get
                Return m_iFunktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung Methods

clsDokumentaufhebung overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentaufhebung Class


clsDokumentaufhebung.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentaufhebung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufhebungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufhebungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentaufhebung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentaufhebung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentaufhebung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufhebungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufhebungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentaufhebung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentaufhebung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentaufhebung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentaufhebung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentaufhebung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentaufhebung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentaufhebung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentaufhebung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iaufhebungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufhebungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentaufhebung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAufhebungnr = New SqlInt32(CType(dtToReturn.Rows(0)("aufhebungnr"), Integer))
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
                        m_iFunktionnr = SqlInt32.Null
                    Else
                        m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentaufhebung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentaufhebung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufhebungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufhebungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentaufhebung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentaufhebung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentaufhebung Fields

clsDokumentaufhebung overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAufhebungnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentaufhebung Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_iAufhebungnr Variable

Private 		m_iMutierer, _
   m_iAufhebungnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iAufhebungnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_iDokumenttypnr Variable

Private 		m_iMutierer, _
   m_iAufhebungnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iAufhebungnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_iFunktionnr Variable

Private 		m_iMutierer, _
   m_iAufhebungnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iAufhebungnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iAufhebungnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iAufhebungnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentaufhebung


clsDokumentcoldindexwert Class

For a list of all members of this type, see clsDokumentcoldindexwert Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentcoldindexwert

Public Class clsDokumentcoldindexwert
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentcoldindexwert Members


clsDokumentcoldindexwert Members

clsDokumentcoldindexwert overview

Constructors

constructor clsDokumentcoldindexwert Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iColdindexwertnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iIndextyp
property iMandantnr
property iMutierer
property sBEBEZ00
property sBEDAT00
property sBEGSF00
property sBEORT00
property sBERES03
property sBESTA00
property sBEUSR00
property sBKPAR00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDMSTA01
property sDokumentid
property sNAVVG00
property sNRDOC00
property sNRPAR00
property sNRSTA00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iColdindexwertnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iIndextyp
field m_iMandantnr
field m_iMutierer
field m_sBEBEZ00
field m_sBEDAT00
field m_sBEGSF00
field m_sBEORT00
field m_sBERES03
field m_sBESTA00
field m_sBEUSR00
field m_sBKPAR00
field m_sDMSTA01
field m_sDokumentid
field m_sNAVVG00
field m_sNRDOC00
field m_sNRPAR00
field m_sNRSTA00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentcoldindexwert Class


clsDokumentcoldindexwert Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert Properties

clsDokumentcoldindexwert overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iColdindexwertnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iIndextyp
property iMandantnr
property iMutierer
property sBEBEZ00
property sBEDAT00
property sBEGSF00
property sBEORT00
property sBERES03
property sBESTA00
property sBEUSR00
property sBKPAR00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDMSTA01
property sDokumentid
property sNAVVG00
property sNRDOC00
property sNRPAR00
property sNRSTA00

See Also

clsDokumentcoldindexwert Class


clsDokumentcoldindexwert.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.iColdindexwertnr Property

Public Property [iColdindexwertnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdindexwertnr]() As SqlInt32
            Get
                Return m_iColdindexwertnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iColdindexwertnrTmp As SqlInt32 = Value
                If iColdindexwertnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iColdindexwertnr", "iColdindexwertnr can't be NULL")
                End If
                m_iColdindexwertnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.iIndextyp Property

Public Property [iIndextyp]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIndextyp]() As SqlInt32
            Get
                Return m_iIndextyp
            End Get
            Set(ByVal Value As SqlInt32)
                m_iIndextyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBEBEZ00 Property

Public Property [sBEBEZ00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBEZ00]() As SqlString
            Get
                Return m_sBEBEZ00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBEZ00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBEDAT00 Property

Public Property [sBEDAT00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEDAT00]() As SqlString
            Get
                Return m_sBEDAT00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEDAT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBEGSF00 Property

Public Property [sBEGSF00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEGSF00]() As SqlString
            Get
                Return m_sBEGSF00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEGSF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBEORT00 Property

Public Property [sBEORT00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEORT00]() As SqlString
            Get
                Return m_sBEORT00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEORT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBERES03 Property

Public Property [sBERES03]() As SqlString

Source code

[Visual Basic]
        Public Property [sBERES03]() As SqlString
            Get
                Return m_sBERES03
            End Get
            Set(ByVal Value As SqlString)
                m_sBERES03 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBESTA00 Property

Public Property [sBESTA00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBESTA00]() As SqlString
            Get
                Return m_sBESTA00
            End Get
            Set(ByVal Value As SqlString)
                m_sBESTA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBEUSR00 Property

Public Property [sBEUSR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEUSR00]() As SqlString
            Get
                Return m_sBEUSR00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEUSR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sBKPAR00 Property

Public Property [sBKPAR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBKPAR00]() As SqlString
            Get
                Return m_sBKPAR00
            End Get
            Set(ByVal Value As SqlString)
                m_sBKPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sDMSTA01 Property

Public Property [sDMSTA01]() As SqlString

Source code

[Visual Basic]
        Public Property [sDMSTA01]() As SqlString
            Get
                Return m_sDMSTA01
            End Get
            Set(ByVal Value As SqlString)
                m_sDMSTA01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sNAVVG00 Property

Public Property [sNAVVG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNAVVG00]() As SqlString
            Get
                Return m_sNAVVG00
            End Get
            Set(ByVal Value As SqlString)
                m_sNAVVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sNRDOC00 Property

Public Property [sNRDOC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRDOC00]() As SqlString
            Get
                Return m_sNRDOC00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRDOC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sNRPAR00 Property

Public Property [sNRPAR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRPAR00]() As SqlString
            Get
                Return m_sNRPAR00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.sNRSTA00 Property

Public Property [sNRSTA00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRSTA00]() As SqlString
            Get
                Return m_sNRSTA00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRSTA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert Methods

clsDokumentcoldindexwert overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentcoldindexwert Class


clsDokumentcoldindexwert.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentcoldindexwert_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentcoldindexwert_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentcoldindexwert::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentcoldindexwert_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iindextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIndextyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPAR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNAVVG00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNAVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBEZ00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBEZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMSTA01", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMSTA01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEDAT00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEDAT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBESTA00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBESTA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORT00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRDOC00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRDOC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRSTA00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRSTA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEGSF00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEGSF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEUSR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEUSR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBERES03", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBERES03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iColdindexwertnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@icoldindexwertnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentcoldindexwert_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentcoldindexwert::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentcoldindexwert_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentcoldindexwert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentcoldindexwert_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentcoldindexwert::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentcoldindexwert_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentcoldindexwert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentcoldindexwert_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iColdindexwertnr = New SqlInt32(CType(dtToReturn.Rows(0)("coldindexwertnr"), Integer))
                    If dtToReturn.Rows(0)("indextyp") Is System.DBNull.Value Then
                        m_iIndextyp = SqlInt32.Null
                    Else
                        m_iIndextyp = New SqlInt32(CType(dtToReturn.Rows(0)("indextyp"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("NRPAR00") Is System.DBNull.Value Then
                        m_sNRPAR00 = SqlString.Null
                    Else
                        m_sNRPAR00 = New SqlString(CType(dtToReturn.Rows(0)("NRPAR00"), String))
                    End If
                    If dtToReturn.Rows(0)("BKPAR00") Is System.DBNull.Value Then
                        m_sBKPAR00 = SqlString.Null
                    Else
                        m_sBKPAR00 = New SqlString(CType(dtToReturn.Rows(0)("BKPAR00"), String))
                    End If
                    If dtToReturn.Rows(0)("NAVVG00") Is System.DBNull.Value Then
                        m_sNAVVG00 = SqlString.Null
                    Else
                        m_sNAVVG00 = New SqlString(CType(dtToReturn.Rows(0)("NAVVG00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEBEZ00") Is System.DBNull.Value Then
                        m_sBEBEZ00 = SqlString.Null
                    Else
                        m_sBEBEZ00 = New SqlString(CType(dtToReturn.Rows(0)("BEBEZ00"), String))
                    End If
                    If dtToReturn.Rows(0)("DMSTA01") Is System.DBNull.Value Then
                        m_sDMSTA01 = SqlString.Null
                    Else
                        m_sDMSTA01 = New SqlString(CType(dtToReturn.Rows(0)("DMSTA01"), String))
                    End If
                    If dtToReturn.Rows(0)("BEDAT00") Is System.DBNull.Value Then
                        m_sBEDAT00 = SqlString.Null
                    Else
                        m_sBEDAT00 = New SqlString(CType(dtToReturn.Rows(0)("BEDAT00"), String))
                    End If
                    If dtToReturn.Rows(0)("BESTA00") Is System.DBNull.Value Then
                        m_sBESTA00 = SqlString.Null
                    Else
                        m_sBESTA00 = New SqlString(CType(dtToReturn.Rows(0)("BESTA00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEORT00") Is System.DBNull.Value Then
                        m_sBEORT00 = SqlString.Null
                    Else
                        m_sBEORT00 = New SqlString(CType(dtToReturn.Rows(0)("BEORT00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRDOC00") Is System.DBNull.Value Then
                        m_sNRDOC00 = SqlString.Null
                    Else
                        m_sNRDOC00 = New SqlString(CType(dtToReturn.Rows(0)("NRDOC00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRSTA00") Is System.DBNull.Value Then
                        m_sNRSTA00 = SqlString.Null
                    Else
                        m_sNRSTA00 = New SqlString(CType(dtToReturn.Rows(0)("NRSTA00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEGSF00") Is System.DBNull.Value Then
                        m_sBEGSF00 = SqlString.Null
                    Else
                        m_sBEGSF00 = New SqlString(CType(dtToReturn.Rows(0)("BEGSF00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEUSR00") Is System.DBNull.Value Then
                        m_sBEUSR00 = SqlString.Null
                    Else
                        m_sBEUSR00 = New SqlString(CType(dtToReturn.Rows(0)("BEUSR00"), String))
                    End If
                    If dtToReturn.Rows(0)("BERES03") Is System.DBNull.Value Then
                        m_sBERES03 = SqlString.Null
                    Else
                        m_sBERES03 = New SqlString(CType(dtToReturn.Rows(0)("BERES03"), String))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentcoldindexwert::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentcoldindexwert_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iindextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIndextyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPAR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNAVVG00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNAVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBEZ00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBEZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMSTA01", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMSTA01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEDAT00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEDAT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBESTA00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBESTA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORT00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRDOC00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRDOC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRSTA00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRSTA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEGSF00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEGSF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEUSR00", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEUSR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBERES03", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBERES03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentcoldindexwert_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentcoldindexwert::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentcoldindexwert Fields

clsDokumentcoldindexwert overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iColdindexwertnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iIndextyp
field m_iMandantnr
field m_iMutierer
field m_sBEBEZ00
field m_sBEDAT00
field m_sBEGSF00
field m_sBEORT00
field m_sBERES03
field m_sBESTA00
field m_sBEUSR00
field m_sBKPAR00
field m_sDMSTA01
field m_sDokumentid
field m_sNAVVG00
field m_sNRDOC00
field m_sNRPAR00
field m_sNRSTA00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentcoldindexwert Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_iColdindexwertnr Variable

Private 		m_iIndextyp, _
   m_iColdindexwertnr, _
   m_iMutierer, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iIndextyp, m_iColdindexwertnr, m_iMutierer, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_iIndextyp Variable

Private 		m_iIndextyp, _
   m_iColdindexwertnr, _
   m_iMutierer, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iIndextyp, m_iColdindexwertnr, m_iMutierer, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_iMandantnr Variable

Private 		m_iIndextyp, _
   m_iColdindexwertnr, _
   m_iMutierer, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iIndextyp, m_iColdindexwertnr, m_iMutierer, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_iMutierer Variable

Private 		m_iIndextyp, _
   m_iColdindexwertnr, _
   m_iMutierer, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iIndextyp, m_iColdindexwertnr, m_iMutierer, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBEBEZ00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBEDAT00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBEGSF00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBEORT00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBERES03 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBESTA00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBEUSR00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sBKPAR00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sDMSTA01 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sDokumentid Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sNAVVG00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sNRDOC00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sNRPAR00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


m_sNRSTA00 Variable

Private 		m_sNRSTA00, _
   m_sNRDOC00, _
   m_sBEGSF00, _
   m_sBERES03, _
   m_sBEUSR00, _
   m_sBKPAR00, _
   m_sNAVVG00, _
   m_sDokumentid, _
   m_sNRPAR00, _
   m_sBEBEZ00, _
   m_sBESTA00, _
   m_sBEORT00, _
   m_sDMSTA01, _
   m_sBEDAT00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNRSTA00, m_sNRDOC00, m_sBEGSF00, m_sBERES03, m_sBEUSR00, m_sBKPAR00, m_sNAVVG00, m_sDokumentid, m_sNRPAR00, m_sBEBEZ00, m_sBESTA00, m_sBEORT00, m_sDMSTA01, m_sBEDAT00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentcoldindexwert


clsDokumentfavoriten Class

For a list of all members of this type, see clsDokumentfavoriten Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentfavoriten

Public Class clsDokumentfavoriten
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentfavoriten Members


clsDokumentfavoriten Members

clsDokumentfavoriten overview

Constructors

constructor clsDokumentfavoriten Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavoritenstrukturnr
property iDokumentfavoritnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavoritenstrukturnr
field m_iDokumentfavoritnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten Class


clsDokumentfavoriten Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten Properties

clsDokumentfavoriten overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavoritenstrukturnr
property iDokumentfavoritnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten Class


clsDokumentfavoriten.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.iDokumentfavoritenstrukturnr Property

Public Property [iDokumentfavoritenstrukturnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentfavoritenstrukturnr]() As SqlInt32
            Get
                Return m_iDokumentfavoritenstrukturnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentfavoritenstrukturnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.iDokumentfavoritnr Property

Public Property [iDokumentfavoritnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentfavoritnr]() As SqlInt32
            Get
                Return m_iDokumentfavoritnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentfavoritnrTmp As SqlInt32 = Value
                If iDokumentfavoritnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentfavoritnr", "iDokumentfavoritnr can't be NULL")
                End If
                m_iDokumentfavoritnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten Methods

clsDokumentfavoriten overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentfavoriten Class


clsDokumentfavoriten.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritenstrukturnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritenstrukturnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentfavoritnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iDokumentfavoritnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@idokumentfavoritnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentfavoriten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentfavoriten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentfavoritnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentfavoritnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentfavoritnr"), Integer))
                    If dtToReturn.Rows(0)("dokumentfavoritenstrukturnr") Is System.DBNull.Value Then
                        m_iDokumentfavoritenstrukturnr = SqlInt32.Null
                    Else
                        m_iDokumentfavoritenstrukturnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentfavoritenstrukturnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritenstrukturnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritenstrukturnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten Fields

clsDokumentfavoriten overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavoritenstrukturnr
field m_iDokumentfavoritnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_iDokumentfavoritenstrukturnr Variable

Private 		m_iMutierer, _
   m_iDokumentfavoritenstrukturnr, _
   m_iDokumenttypnr, _
   m_iDokumentfavoritnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentfavoritenstrukturnr, m_iDokumenttypnr, m_iDokumentfavoritnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_iDokumentfavoritnr Variable

Private 		m_iMutierer, _
   m_iDokumentfavoritenstrukturnr, _
   m_iDokumenttypnr, _
   m_iDokumentfavoritnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentfavoritenstrukturnr, m_iDokumenttypnr, m_iDokumentfavoritnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_iDokumenttypnr Variable

Private 		m_iMutierer, _
   m_iDokumentfavoritenstrukturnr, _
   m_iDokumenttypnr, _
   m_iDokumentfavoritnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentfavoritenstrukturnr, m_iDokumenttypnr, m_iDokumentfavoritnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iDokumentfavoritenstrukturnr, _
   m_iDokumenttypnr, _
   m_iDokumentfavoritnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentfavoritenstrukturnr, m_iDokumenttypnr, m_iDokumentfavoritnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten


clsDokumentfavoriten_struktur Class

For a list of all members of this type, see clsDokumentfavoriten_struktur Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentfavoriten_struktur

Public Class clsDokumentfavoriten_struktur
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentfavoriten_struktur Members


clsDokumentfavoriten_struktur Members

clsDokumentfavoriten_struktur overview

Constructors

constructor clsDokumentfavoriten_struktur Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavoritennr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavoritennr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten_struktur Class


clsDokumentfavoriten_struktur Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur Properties

clsDokumentfavoriten_struktur overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavoritennr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten_struktur Class


clsDokumentfavoriten_struktur.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iDokumentfavoritennr Property

Public Property [iDokumentfavoritennr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentfavoritennr]() As SqlInt32
            Get
                Return m_iDokumentfavoritennr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentfavoritennrTmp As SqlInt32 = Value
                If iDokumentfavoritennrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentfavoritennr", "iDokumentfavoritennr can't be NULL")
                End If
                m_iDokumentfavoritennr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iImageindex Property

Public Property [iImageindex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindex]() As SqlInt32
            Get
                Return m_iImageindex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iImageindexopen Property

Public Property [iImageindexopen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindexopen]() As SqlInt32
            Get
                Return m_iImageindexopen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindexopen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iParentid Property

Public Property [iParentid]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParentid]() As SqlInt32
            Get
                Return m_iParentid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSpracheTmp As SqlInt32 = Value
                If iSpracheTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSprache", "iSprache can't be NULL")
                End If
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur Methods

clsDokumentfavoriten_struktur overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentfavoriten_struktur Class


clsDokumentfavoriten_struktur.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_struktur_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritennr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritennr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_struktur_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten_struktur::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_struktur_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentfavoritennr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritennr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iDokumentfavoritennr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@idokumentfavoritennr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_struktur_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten_struktur::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_struktur_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentfavoriten_struktur")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_struktur_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten_struktur::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_struktur_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentfavoriten_struktur")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentfavoritennr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritennr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_struktur_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentfavoritennr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentfavoritennr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("parentid") Is System.DBNull.Value Then
                        m_iParentid = SqlInt32.Null
                    Else
                        m_iParentid = New SqlInt32(CType(dtToReturn.Rows(0)("parentid"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindex") Is System.DBNull.Value Then
                        m_iImageindex = SqlInt32.Null
                    Else
                        m_iImageindex = New SqlInt32(CType(dtToReturn.Rows(0)("imageindex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindexopen") Is System.DBNull.Value Then
                        m_iImageindexopen = SqlInt32.Null
                    Else
                        m_iImageindexopen = New SqlInt32(CType(dtToReturn.Rows(0)("imageindexopen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten_struktur::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavoriten_struktur_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavoritennr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavoritennr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavoriten_struktur_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavoriten_struktur::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavoriten_struktur Fields

clsDokumentfavoriten_struktur overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavoritennr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavoriten_struktur Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iDokumentfavoritennr Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iImageindex Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iImageindexopen Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iMitarbeiternr Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iParentid Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iSort Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_iSprache Variable

Private 		m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iImageindexopen, _
   m_iParentid, _
   m_iMitarbeiternr, _
   m_iDokumentfavoritennr, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iSprache, m_iMutierer, m_iImageindexopen, m_iParentid, m_iMitarbeiternr, m_iDokumentfavoritennr, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_sBeschreibung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


m_sBezeichnung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavoriten_struktur


clsDokumentfavorithierarchie Class

For a list of all members of this type, see clsDokumentfavorithierarchie Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentfavorithierarchie

Public Class clsDokumentfavorithierarchie
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentfavorithierarchie Members


clsDokumentfavorithierarchie Members

clsDokumentfavorithierarchie overview

Constructors

constructor clsDokumentfavorithierarchie Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavorithierarchinr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavorithierarchinr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavorithierarchie Class


clsDokumentfavorithierarchie Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie Properties

clsDokumentfavorithierarchie overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentfavorithierarchinr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iParentid
property iSort
property iSprache
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavorithierarchie Class


clsDokumentfavorithierarchie.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iDokumentfavorithierarchinr Property

Public Property [iDokumentfavorithierarchinr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentfavorithierarchinr]() As SqlInt32
            Get
                Return m_iDokumentfavorithierarchinr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentfavorithierarchinrTmp As SqlInt32 = Value
                If iDokumentfavorithierarchinrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentfavorithierarchinr", "iDokumentfavorithierarchinr can't be NULL")
                End If
                m_iDokumentfavorithierarchinr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iImageindex Property

Public Property [iImageindex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindex]() As SqlInt32
            Get
                Return m_iImageindex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iImageindexopen Property

Public Property [iImageindexopen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindexopen]() As SqlInt32
            Get
                Return m_iImageindexopen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindexopen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iParentid Property

Public Property [iParentid]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParentid]() As SqlInt32
            Get
                Return m_iParentid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSpracheTmp As SqlInt32 = Value
                If iSpracheTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSprache", "iSprache can't be NULL")
                End If
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie Methods

clsDokumentfavorithierarchie overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavorithierarchie Class


clsDokumentfavorithierarchie.Insert Method

Public Overrides Function Insert() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavorithierarchie_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentfavorithierarchinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentfavorithierarchinr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavorithierarchie_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavorithierarchie::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie.SelectAll Method

Public Overrides Function SelectAll() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentfavorithierarchie_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("dokumentfavorithierarchie")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentfavorithierarchie_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentfavorithierarchie::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentfavorithierarchie Fields

clsDokumentfavorithierarchie overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentfavorithierarchinr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iParentid
field m_iSort
field m_iSprache
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentfavorithierarchie Class


m_bAktiv Variable

Private m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_daErstellt_am Variable

Private m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_daMutiert_am Variable

Private m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iDokumentfavorithierarchinr Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iImageindex Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iImageindexopen Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iMandantnr Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iMitarbeiternr Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iMutierer Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iParentid Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iSort Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_iSprache Variable

Private m_iMitarbeiternr, _
   m_iSprache, _
   m_iMandantnr, _
   m_iParentid, _
   m_iMutierer, _
   m_iDokumentfavorithierarchinr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private m_iMitarbeiternr, m_iSprache, m_iMandantnr, m_iParentid, m_iMutierer, m_iDokumentfavorithierarchinr, m_iImageindexopen, m_iImageindex, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_sBeschreibung Variable

Private m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


m_sBezeichnung Variable

Private m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentfavorithierarchie


clsDokumentindexmutation Class

For a list of all members of this type, see clsDokumentindexmutation Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentindexmutation

Public Class clsDokumentindexmutation
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentindexmutation Members


clsDokumentindexmutation Members

clsDokumentindexmutation overview

Constructors

constructor clsDokumentindexmutation Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iIndexmutationnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iIndexmutationnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentindexmutation Class


clsDokumentindexmutation Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation Properties

clsDokumentindexmutation overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iIndexmutationnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentindexmutation Class


clsDokumentindexmutation.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.iFunktionnr Property

Public Property [iFunktionnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionnr]() As SqlInt32
            Get
                Return m_iFunktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.iIndexmutationnr Property

Public Property [iIndexmutationnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIndexmutationnr]() As SqlInt32
            Get
                Return m_iIndexmutationnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iIndexmutationnrTmp As SqlInt32 = Value
                If iIndexmutationnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iIndexmutationnr", "iIndexmutationnr can't be NULL")
                End If
                m_iIndexmutationnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation Methods

clsDokumentindexmutation overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentindexmutation Class


clsDokumentindexmutation.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentindexmutation_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iindexmutationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIndexmutationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentindexmutation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentindexmutation::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentindexmutation_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iindexmutationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIndexmutationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentindexmutation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentindexmutation::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentindexmutation_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentindexmutation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentindexmutation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentindexmutation::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentindexmutation_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentindexmutation")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iindexmutationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIndexmutationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentindexmutation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iIndexmutationnr = New SqlInt32(CType(dtToReturn.Rows(0)("indexmutationnr"), Integer))
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
                        m_iFunktionnr = SqlInt32.Null
                    Else
                        m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentindexmutation::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentindexmutation_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iindexmutationnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIndexmutationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentindexmutation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentindexmutation::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentindexmutation Fields

clsDokumentindexmutation overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iIndexmutationnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentindexmutation Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_iDokumenttypnr Variable

Private 		m_iMutierer, _
   m_iIndexmutationnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iIndexmutationnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_iFunktionnr Variable

Private 		m_iMutierer, _
   m_iIndexmutationnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iIndexmutationnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_iIndexmutationnr Variable

Private 		m_iMutierer, _
   m_iIndexmutationnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iIndexmutationnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iIndexmutationnr, _
   m_iFunktionnr, _
   m_iDokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iIndexmutationnr, m_iFunktionnr, m_iDokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentindexmutation


clsDokumentstatus Class

For a list of all members of this type, see clsDokumentstatus Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentstatus
EDOKAApp.edokaDB.clsMyDokumentstatus

Public Class clsDokumentstatus
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentstatus Members


clsDokumentstatus Members

clsDokumentstatus overview

Constructors

constructor clsDokumentstatus Constructor

Properties

property bAktiv
property bDokument_ausgangsarchivieren
property bDokument_bearbeitung_abgeschlossen
property bDokumentbearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatusnr
property iDokumenttypnr
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property iStatus_bezeichnungnr
property iStatustyp
property iStatustypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivieren
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokumentbearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatusnr
field m_iDokumenttypnr
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iStatus_bezeichnungnr
field m_iStatustyp
field m_iStatustypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus Class


clsDokumentstatus Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus Properties

clsDokumentstatus overview

Properties

property bAktiv
property bDokument_ausgangsarchivieren
property bDokument_bearbeitung_abgeschlossen
property bDokumentbearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatusnr
property iDokumenttypnr
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property iStatus_bezeichnungnr
property iStatustyp
property iStatustypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus Class


clsDokumentstatus.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.bDokument_ausgangsarchivieren Property

Public Property [bDokument_ausgangsarchivieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_ausgangsarchivieren]() As SqlBoolean
            Get
                Return m_bDokument_ausgangsarchivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_ausgangsarchivieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.bDokument_bearbeitung_abgeschlossen Property

Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean
            Get
                Return m_bDokument_bearbeitung_abgeschlossen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_bearbeitung_abgeschlossen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.bDokumentbearbeitung_moeglich Property

Public Property [bDokumentbearbeitung_moeglich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokumentbearbeitung_moeglich]() As SqlBoolean
            Get
                Return m_bDokumentbearbeitung_moeglich
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bDokumentbearbeitung_moeglichTmp As SqlBoolean = Value
                If bDokumentbearbeitung_moeglichTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bDokumentbearbeitung_moeglich", "bDokumentbearbeitung_moeglich can't be NULL")
                End If
                m_bDokumentbearbeitung_moeglich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.bFolgestatus_durch_anderen_verantwortlichen Property

Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean
            Get
                Return m_bFolgestatus_durch_anderen_verantwortlichen
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bFolgestatus_durch_anderen_verantwortlichenTmp As SqlBoolean = Value
                If bFolgestatus_durch_anderen_verantwortlichenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bFolgestatus_durch_anderen_verantwortlichen", "bFolgestatus_durch_anderen_verantwortlichen can't be NULL")
                End If
                m_bFolgestatus_durch_anderen_verantwortlichen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iDokumentstatusnr Property

Public Property [iDokumentstatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatusnr]() As SqlInt32
            Get
                Return m_iDokumentstatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentstatusnrTmp As SqlInt32 = Value
                If iDokumentstatusnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentstatusnr", "iDokumentstatusnr can't be NULL")
                End If
                m_iDokumentstatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iErledigung_ab Property

Public Property [iErledigung_ab]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErledigung_ab]() As SqlInt32
            Get
                Return m_iErledigung_ab
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iErledigung_abTmp As SqlInt32 = Value
                If iErledigung_abTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iErledigung_ab", "iErledigung_ab can't be NULL")
                End If
                m_iErledigung_ab = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReihenfolgeTmp As SqlInt32 = Value
                If iReihenfolgeTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReihenfolge", "iReihenfolge can't be NULL")
                End If
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iStatus_bezeichnungnr Property

Public Property [iStatus_bezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_bezeichnungnr]() As SqlInt32
            Get
                Return m_iStatus_bezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_bezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iStatustyp Property

Public Property [iStatustyp]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatustyp]() As SqlInt32
            Get
                Return m_iStatustyp
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatustyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.iStatustypnr Property

Public Property [iStatustypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatustypnr]() As SqlInt32
            Get
                Return m_iStatustypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatustypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus Methods

clsDokumentstatus overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentstatus Class


clsDokumentstatus.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokumentbearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bDokumentbearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustyp))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentstatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatusnr"), Integer))
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("statustypnr") Is System.DBNull.Value Then
                        m_iStatustypnr = SqlInt32.Null
                    Else
                        m_iStatustypnr = New SqlInt32(CType(dtToReturn.Rows(0)("statustypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_bezeichnungnr") Is System.DBNull.Value Then
                        m_iStatus_bezeichnungnr = SqlInt32.Null
                    Else
                        m_iStatus_bezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("status_bezeichnungnr"), Integer))
                    End If
                    m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
                    m_bFolgestatus_durch_anderen_verantwortlichen = New SqlBoolean(CType(dtToReturn.Rows(0)("folgestatus_durch_anderen_verantwortlichen"), Boolean))
                    m_bDokumentbearbeitung_moeglich = New SqlBoolean(CType(dtToReturn.Rows(0)("dokumentbearbeitung_moeglich"), Boolean))
                    m_iErledigung_ab = New SqlInt32(CType(dtToReturn.Rows(0)("erledigung_ab"), Integer))
                    If dtToReturn.Rows(0)("dokument_ausgangsarchivieren") Is System.DBNull.Value Then
                        m_bDokument_ausgangsarchivieren = SqlBoolean.Null
                    Else
                        m_bDokument_ausgangsarchivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_ausgangsarchivieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen") Is System.DBNull.Value Then
                        m_bDokument_bearbeitung_abgeschlossen = SqlBoolean.Null
                    Else
                        m_bDokument_bearbeitung_abgeschlossen = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("statustyp") Is System.DBNull.Value Then
                        m_iStatustyp = SqlInt32.Null
                    Else
                        m_iStatustyp = New SqlInt32(CType(dtToReturn.Rows(0)("statustyp"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokumentbearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bDokumentbearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustyp))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus Fields

clsDokumentstatus overview

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivieren
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokumentbearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatusnr
field m_iDokumenttypnr
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iStatus_bezeichnungnr
field m_iStatustyp
field m_iStatustypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus Class


m_bAktiv Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bDokument_ausgangsarchivieren, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_bearbeitung_abgeschlossen, m_bDokument_ausgangsarchivieren, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_bDokument_ausgangsarchivieren Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bDokument_ausgangsarchivieren, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_bearbeitung_abgeschlossen, m_bDokument_ausgangsarchivieren, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_bDokument_bearbeitung_abgeschlossen Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bDokument_ausgangsarchivieren, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_bearbeitung_abgeschlossen, m_bDokument_ausgangsarchivieren, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_bDokumentbearbeitung_moeglich Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bDokument_ausgangsarchivieren, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_bearbeitung_abgeschlossen, m_bDokument_ausgangsarchivieren, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_bFolgestatus_durch_anderen_verantwortlichen Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bDokument_ausgangsarchivieren, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_bearbeitung_abgeschlossen, m_bDokument_ausgangsarchivieren, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iDokumentstatusnr Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iDokumenttypnr Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iErledigung_ab Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iMandantnr Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iMutierer Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iReihenfolge Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iStatus_bezeichnungnr Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iStatustyp Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


m_iStatustypnr Variable

Private 		m_iStatustyp, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iStatustypnr, _
   m_iDokumenttypnr, _
   m_iDokumentstatusnr, _
   m_iErledigung_ab, _
   m_iReihenfolge, _
   m_iStatus_bezeichnungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatustyp, m_iMutierer, m_iMandantnr, m_iStatustypnr, m_iDokumenttypnr, m_iDokumentstatusnr, m_iErledigung_ab, m_iReihenfolge, m_iStatus_bezeichnungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus


clsDokumentstatus_funktion Class

For a list of all members of this type, see clsDokumentstatus_funktion Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentstatus_funktion

Public Class clsDokumentstatus_funktion
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentstatus_funktion Members


clsDokumentstatus_funktion Members

clsDokumentstatus_funktion overview

Constructors

constructor clsDokumentstatus_funktion Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatus_funktionnr
property iDokumentstatusnr
property iDokumentstatusnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentstatusnrLogic
method SelectOne
method Update
method UpdateAllWdokumentstatusnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatus_funktionnr
field m_iDokumentstatusnr
field m_iDokumentstatusnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iMandantnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_funktion Class


clsDokumentstatus_funktion Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion Properties

clsDokumentstatus_funktion overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatus_funktionnr
property iDokumentstatusnr
property iDokumentstatusnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionnr
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_funktion Class


clsDokumentstatus_funktion.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iDokumentstatus_funktionnr Property

Public Property [iDokumentstatus_funktionnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatus_funktionnr]() As SqlInt32
            Get
                Return m_iDokumentstatus_funktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentstatus_funktionnrTmp As SqlInt32 = Value
                If iDokumentstatus_funktionnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentstatus_funktionnr", "iDokumentstatus_funktionnr can't be NULL")
                End If
                m_iDokumentstatus_funktionnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iDokumentstatusnr Property

Public Property [iDokumentstatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatusnr]() As SqlInt32
            Get
                Return m_iDokumentstatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentstatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iDokumentstatusnrOld Property

Public Property [iDokumentstatusnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatusnrOld]() As SqlInt32
            Get
                Return m_iDokumentstatusnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentstatusnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iFunktionnr Property

Public Property [iFunktionnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionnr]() As SqlInt32
            Get
                Return m_iFunktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion Methods

clsDokumentstatus_funktion overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentstatusnrLogic
method SelectOne
method Update
method UpdateAllWdokumentstatusnrLogic

See Also

clsDokumentstatus_funktion Class


clsDokumentstatus_funktion.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_funktionnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_funktionnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_funktionnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_funktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus_funktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.SelectAllWdokumentstatusnrLogic Method

Public Function SelectAllWdokumentstatusnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWdokumentstatusnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_SelectAllWdokumentstatusnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus_funktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_SelectAllWdokumentstatusnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::SelectAllWdokumentstatusnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus_funktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatus_funktionnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_funktionnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentstatus_funktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus_funktionnr"), Integer))
                    If dtToReturn.Rows(0)("dokumentstatusnr") Is System.DBNull.Value Then
                        m_iDokumentstatusnr = SqlInt32.Null
                    Else
                        m_iDokumentstatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
                        m_iFunktionnr = SqlInt32.Null
                    Else
                        m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_funktionnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_funktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion.UpdateAllWdokumentstatusnrLogic Method

Public Function UpdateAllWdokumentstatusnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWdokumentstatusnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_funktion_UpdateAllWdokumentstatusnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatusnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_funktion_UpdateAllWdokumentstatusnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_funktion::UpdateAllWdokumentstatusnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_funktion Fields

clsDokumentstatus_funktion overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatus_funktionnr
field m_iDokumentstatusnr
field m_iDokumentstatusnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionnr
field m_iMandantnr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_funktion Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iDokumentstatus_funktionnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iDokumentstatusnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iDokumentstatusnrOld Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iFunktionnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iDokumentstatusnrOld, _
   m_iFunktionnr, _
   m_iDokumentstatus_funktionnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iDokumentstatusnrOld, m_iFunktionnr, m_iDokumentstatus_funktionnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_funktion


clsDokumentstatus_rolle Class

For a list of all members of this type, see clsDokumentstatus_rolle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentstatus_rolle

Public Class clsDokumentstatus_rolle
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumentstatus_rolle Members


clsDokumentstatus_rolle Members

clsDokumentstatus_rolle overview

Constructors

constructor clsDokumentstatus_rolle Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatus_rollenr
property iDokumentstatusnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatus_rollenr
field m_iDokumentstatusnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_rolle Class


clsDokumentstatus_rolle Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle Properties

clsDokumentstatus_rolle overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentstatus_rollenr
property iDokumentstatusnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_rolle Class


clsDokumentstatus_rolle.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.iDokumentstatus_rollenr Property

Public Property [iDokumentstatus_rollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatus_rollenr]() As SqlInt32
            Get
                Return m_iDokumentstatus_rollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentstatus_rollenrTmp As SqlInt32 = Value
                If iDokumentstatus_rollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentstatus_rollenr", "iDokumentstatus_rollenr can't be NULL")
                End If
                m_iDokumentstatus_rollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.iDokumentstatusnr Property

Public Property [iDokumentstatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatusnr]() As SqlInt32
            Get
                Return m_iDokumentstatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentstatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle Methods

clsDokumentstatus_rolle overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumentstatus_rolle Class


clsDokumentstatus_rolle.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_rollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_rollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_rolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_rollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_rollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_rolle::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_rolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumentstatus_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentstatus_rollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_rollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentstatus_rollenr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus_rollenr"), Integer))
                    If dtToReturn.Rows(0)("dokumentstatusnr") Is System.DBNull.Value Then
                        m_iDokumentstatusnr = SqlInt32.Null
                    Else
                        m_iDokumentstatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_rolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumentstatus_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_rollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_rollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumentstatus_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus_rolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumentstatus_rolle Fields

clsDokumentstatus_rolle overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentstatus_rollenr
field m_iDokumentstatusnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumentstatus_rolle Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_iDokumentstatus_rollenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iRollenr, _
   m_iDokumentstatus_rollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iRollenr, m_iDokumentstatus_rollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_iDokumentstatusnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iRollenr, _
   m_iDokumentstatus_rollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iRollenr, m_iDokumentstatus_rollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iRollenr, _
   m_iDokumentstatus_rollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iRollenr, m_iDokumentstatus_rollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iRollenr, _
   m_iDokumentstatus_rollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iRollenr, m_iDokumentstatus_rollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


m_iRollenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentstatusnr, _
   m_iRollenr, _
   m_iDokumentstatus_rollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iDokumentstatusnr, m_iRollenr, m_iDokumentstatus_rollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumentstatus_rolle


clsDokumenttyp Class

For a list of all members of this type, see clsDokumenttyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumenttyp
EDOKAApp.edokadb.clsMyDokumenttyp

Public Class clsDokumenttyp
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDokumenttyp Members


clsDokumenttyp Members

clsDokumenttyp overview

Constructors

constructor clsDokumenttyp Constructor

Properties

property bAktiv
property bAmsdokument
property bAnzeigeZurDokumenterstellung
property bBedingtretournierbar
property bBezeichnungmut
property bCold_ersetzen
property bDokument_wird_erstellt
property bDokument_wird_retourniert
property bEingang_ersetzt_ausgang
property bEmail_versand
property bFunktionen_zuweisen
property bHostdokument
property bKundenDokument
property bNurnative
property bPartnersaldierung_statusalt
property bSb
property bSbedituser
property bSbimport
property bSbnur
property bUnterschrift_links
property bUnterschrift_rechts
property bVertrag
property bVertrauliches_dokument
property bWird_importiert
property bWird_nicht_geloescht
property bZu_retournieren
property bZu_vercolden
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnzahl_tage
property iAufbewahrungsfrist_elektronisch
property iAufbewahrungsfrist_physisch
property iCold_folder
property iDbearbeitungszeit
property iDoktypbedingteretournierung
property iDokumentart_coldausgang
property iDokumentart_coldeingang
property iDokumentart_host
property iDokumentart_kundendossier
property iDokumentart_nativ
property iDokumentart_neuerstellung
property iDokumentart_retournierung
property iDokumentart_weitere
property iDokumentstatus
property iDokumentstatus_barcode
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMonate_bis_zur_archivierung
property iMutierer
property iObjektbezeichnungnr
property iOffice_vorlagenr
property iOwner
property iPhysisches_archiv
property iProzessnr
property iProzessnr1
property iTage_mutation
property iTagebisvernichtungbedingteretournierung
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sHostdokumenttyp

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAnzeigeZurDokumenterstellung
field m_bBedingtretournierbar
field m_bBezeichnungmut
field m_bCold_ersetzen
field m_bDokument_wird_erstellt
field m_bDokument_wird_retourniert
field m_bEingang_ersetzt_ausgang
field m_bEmail_versand
field m_bFunktionen_zuweisen
field m_bHostdokument
field m_bKundenDokument
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bNurnative
field m_bPartnersaldierung_statusalt
field m_bSb
field m_bSbedituser
field m_bSbimport
field m_bSbnur
field m_bUnterschrift_links
field m_bUnterschrift_rechts
field m_bVertrag
field m_bVertrauliches_dokument
field m_bWird_importiert
field m_bWird_nicht_geloescht
field m_bZu_retournieren
field m_bZu_vercolden
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnzahl_tage
field m_iAufbewahrungsfrist_elektronisch
field m_iAufbewahrungsfrist_physisch
field m_iCold_folder
field m_iDbearbeitungszeit
field m_iDoktypbedingteretournierung
field m_iDokumentart_coldausgang
field m_iDokumentart_coldeingang
field m_iDokumentart_host
field m_iDokumentart_kundendossier
field m_iDokumentart_nativ
field m_iDokumentart_neuerstellung
field m_iDokumentart_retournierung
field m_iDokumentart_weitere
field m_iDokumentstatus
field m_iDokumentstatus_barcode
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMonate_bis_zur_archivierung
field m_iMutierer
field m_iObjektbezeichnungnr
field m_iOffice_vorlagenr
field m_iOwner
field m_iPhysisches_archiv
field m_iProzessnr
field m_iProzessnr1
field m_iTage_mutation
field m_iTagebisvernichtungbedingteretournierung
field m_sBeschreibung
field m_sBezeichnung
field m_sHostdokumenttyp
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumenttyp Class


clsDokumenttyp Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp Properties

clsDokumenttyp overview

Properties

property bAktiv
property bAmsdokument
property bAnzeigeZurDokumenterstellung
property bBedingtretournierbar
property bBezeichnungmut
property bCold_ersetzen
property bDokument_wird_erstellt
property bDokument_wird_retourniert
property bEingang_ersetzt_ausgang
property bEmail_versand
property bFunktionen_zuweisen
property bHostdokument
property bKundenDokument
property bNurnative
property bPartnersaldierung_statusalt
property bSb
property bSbedituser
property bSbimport
property bSbnur
property bUnterschrift_links
property bUnterschrift_rechts
property bVertrag
property bVertrauliches_dokument
property bWird_importiert
property bWird_nicht_geloescht
property bZu_retournieren
property bZu_vercolden
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnzahl_tage
property iAufbewahrungsfrist_elektronisch
property iAufbewahrungsfrist_physisch
property iCold_folder
property iDbearbeitungszeit
property iDoktypbedingteretournierung
property iDokumentart_coldausgang
property iDokumentart_coldeingang
property iDokumentart_host
property iDokumentart_kundendossier
property iDokumentart_nativ
property iDokumentart_neuerstellung
property iDokumentart_retournierung
property iDokumentart_weitere
property iDokumentstatus
property iDokumentstatus_barcode
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMonate_bis_zur_archivierung
property iMutierer
property iObjektbezeichnungnr
property iOffice_vorlagenr
property iOwner
property iPhysisches_archiv
property iProzessnr
property iProzessnr1
property iTage_mutation
property iTagebisvernichtungbedingteretournierung
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sHostdokumenttyp

See Also

clsDokumenttyp Class


clsDokumenttyp.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bAmsdokument Property

Public Property [bAmsdokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAmsdokument]() As SqlBoolean
            Get
                Return m_bAmsdokument
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAmsdokumentTmp As SqlBoolean = Value
                If bAmsdokumentTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAmsdokument", "bAmsdokument can't be NULL")
                End If
                m_bAmsdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bAnzeigeZurDokumenterstellung Property

Public Property [bAnzeigeZurDokumenterstellung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAnzeigeZurDokumenterstellung]() As SqlBoolean
            Get
                Return m_bAnzeigeZurDokumenterstellung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAnzeigeZurDokumenterstellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bBedingtretournierbar Property

Public Property [bBedingtretournierbar]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBedingtretournierbar]() As SqlBoolean
            Get
                Return m_bBedingtretournierbar
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBedingtretournierbar = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bBezeichnungmut Property

Public Property [bBezeichnungmut]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBezeichnungmut]() As SqlBoolean
            Get
                Return m_bBezeichnungmut
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBezeichnungmut = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bCold_ersetzen Property

Public Property [bCold_ersetzen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bCold_ersetzen]() As SqlBoolean
            Get
                Return m_bCold_ersetzen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bCold_ersetzen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bDokument_wird_erstellt Property

Public Property [bDokument_wird_erstellt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_wird_erstellt]() As SqlBoolean
            Get
                Return m_bDokument_wird_erstellt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_wird_erstellt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bDokument_wird_retourniert Property

Public Property [bDokument_wird_retourniert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_wird_retourniert]() As SqlBoolean
            Get
                Return m_bDokument_wird_retourniert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_wird_retourniert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bEingang_ersetzt_ausgang Property

Public Property [bEingang_ersetzt_ausgang]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEingang_ersetzt_ausgang]() As SqlBoolean
            Get
                Return m_bEingang_ersetzt_ausgang
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bEingang_ersetzt_ausgangTmp As SqlBoolean = Value
                If bEingang_ersetzt_ausgangTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bEingang_ersetzt_ausgang", "bEingang_ersetzt_ausgang can't be NULL")
                End If
                m_bEingang_ersetzt_ausgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bEmail_versand Property

Public Property [bEmail_versand]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEmail_versand]() As SqlBoolean
            Get
                Return m_bEmail_versand
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEmail_versand = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bFunktionen_zuweisen Property

Public Property [bFunktionen_zuweisen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFunktionen_zuweisen]() As SqlBoolean
            Get
                Return m_bFunktionen_zuweisen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFunktionen_zuweisen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bHostdokument Property

Public Property [bHostdokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bHostdokument]() As SqlBoolean
            Get
                Return m_bHostdokument
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bHostdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bKundenDokument Property

Public Property [bKundenDokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bKundenDokument]() As SqlBoolean
            Get
                Return m_bKundenDokument
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bKundenDokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bNurnative Property

Public Property [bNurnative]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bNurnative]() As SqlBoolean
            Get
                Return m_bNurnative
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bNurnative = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bPartnersaldierung_statusalt Property

Public Property [bPartnersaldierung_statusalt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bPartnersaldierung_statusalt]() As SqlBoolean
            Get
                Return m_bPartnersaldierung_statusalt
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bPartnersaldierung_statusaltTmp As SqlBoolean = Value
                If bPartnersaldierung_statusaltTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bPartnersaldierung_statusalt", "bPartnersaldierung_statusalt can't be NULL")
                End If
                m_bPartnersaldierung_statusalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bSb Property

Public Property [bSb]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bSb]() As SqlBoolean
            Get
                Return m_bSb
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bSbedituser Property

Public Property [bSbedituser]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bSbedituser]() As SqlBoolean
            Get
                Return m_bSbedituser
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSbedituser = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bSbimport Property

Public Property [bSbimport]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bSbimport]() As SqlBoolean
            Get
                Return m_bSbimport
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSbimport = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bSbnur Property

Public Property [bSbnur]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bSbnur]() As SqlBoolean
            Get
                Return m_bSbnur
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSbnur = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bUnterschrift_links Property

Public Property [bUnterschrift_links]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUnterschrift_links]() As SqlBoolean
            Get
                Return m_bUnterschrift_links
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bUnterschrift_linksTmp As SqlBoolean = Value
                If bUnterschrift_linksTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bUnterschrift_links", "bUnterschrift_links can't be NULL")
                End If
                m_bUnterschrift_links = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bUnterschrift_rechts Property

Public Property [bUnterschrift_rechts]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUnterschrift_rechts]() As SqlBoolean
            Get
                Return m_bUnterschrift_rechts
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bUnterschrift_rechtsTmp As SqlBoolean = Value
                If bUnterschrift_rechtsTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bUnterschrift_rechts", "bUnterschrift_rechts can't be NULL")
                End If
                m_bUnterschrift_rechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bVertrag Property

Public Property [bVertrag]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertrag]() As SqlBoolean
            Get
                Return m_bVertrag
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bVertrauliches_dokument Property

Public Property [bVertrauliches_dokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertrauliches_dokument]() As SqlBoolean
            Get
                Return m_bVertrauliches_dokument
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bVertrauliches_dokumentTmp As SqlBoolean = Value
                If bVertrauliches_dokumentTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bVertrauliches_dokument", "bVertrauliches_dokument can't be NULL")
                End If
                m_bVertrauliches_dokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bWird_importiert Property

Public Property [bWird_importiert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bWird_importiert]() As SqlBoolean
            Get
                Return m_bWird_importiert
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bWird_importiertTmp As SqlBoolean = Value
                If bWird_importiertTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bWird_importiert", "bWird_importiert can't be NULL")
                End If
                m_bWird_importiert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bWird_nicht_geloescht Property

Public Property [bWird_nicht_geloescht]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bWird_nicht_geloescht]() As SqlBoolean
            Get
                Return m_bWird_nicht_geloescht
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bWird_nicht_geloeschtTmp As SqlBoolean = Value
                If bWird_nicht_geloeschtTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bWird_nicht_geloescht", "bWird_nicht_geloescht can't be NULL")
                End If
                m_bWird_nicht_geloescht = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bZu_retournieren Property

Public Property [bZu_retournieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZu_retournieren]() As SqlBoolean
            Get
                Return m_bZu_retournieren
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bZu_retournierenTmp As SqlBoolean = Value
                If bZu_retournierenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bZu_retournieren", "bZu_retournieren can't be NULL")
                End If
                m_bZu_retournieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.bZu_vercolden Property

Public Property [bZu_vercolden]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZu_vercolden]() As SqlBoolean
            Get
                Return m_bZu_vercolden
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bZu_vercoldenTmp As SqlBoolean = Value
                If bZu_vercoldenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bZu_vercolden", "bZu_vercolden can't be NULL")
                End If
                m_bZu_vercolden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iAnzahl_tage Property

Public Property [iAnzahl_tage]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnzahl_tage]() As SqlInt32
            Get
                Return m_iAnzahl_tage
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAnzahl_tageTmp As SqlInt32 = Value
                If iAnzahl_tageTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAnzahl_tage", "iAnzahl_tage can't be NULL")
                End If
                m_iAnzahl_tage = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iAufbewahrungsfrist_elektronisch Property

Public Property [iAufbewahrungsfrist_elektronisch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAufbewahrungsfrist_elektronisch]() As SqlInt32
            Get
                Return m_iAufbewahrungsfrist_elektronisch
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAufbewahrungsfrist_elektronischTmp As SqlInt32 = Value
                If iAufbewahrungsfrist_elektronischTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAufbewahrungsfrist_elektronisch", "iAufbewahrungsfrist_elektronisch can't be NULL")
                End If
                m_iAufbewahrungsfrist_elektronisch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iAufbewahrungsfrist_physisch Property

Public Property [iAufbewahrungsfrist_physisch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAufbewahrungsfrist_physisch]() As SqlInt32
            Get
                Return m_iAufbewahrungsfrist_physisch
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAufbewahrungsfrist_physischTmp As SqlInt32 = Value
                If iAufbewahrungsfrist_physischTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAufbewahrungsfrist_physisch", "iAufbewahrungsfrist_physisch can't be NULL")
                End If
                m_iAufbewahrungsfrist_physisch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iCold_folder Property

Public Property [iCold_folder]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_folder]() As SqlInt32
            Get
                Return m_iCold_folder
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_folder = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDbearbeitungszeit Property

Public Property [iDbearbeitungszeit]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDbearbeitungszeit]() As SqlInt32
            Get
                Return m_iDbearbeitungszeit
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDbearbeitungszeitTmp As SqlInt32 = Value
                If iDbearbeitungszeitTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDbearbeitungszeit", "iDbearbeitungszeit can't be NULL")
                End If
                m_iDbearbeitungszeit = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDoktypbedingteretournierung Property

Public Property [iDoktypbedingteretournierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDoktypbedingteretournierung]() As SqlInt32
            Get
                Return m_iDoktypbedingteretournierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDoktypbedingteretournierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_coldausgang Property

Public Property [iDokumentart_coldausgang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_coldausgang]() As SqlInt32
            Get
                Return m_iDokumentart_coldausgang
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentart_coldausgangTmp As SqlInt32 = Value
                If iDokumentart_coldausgangTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentart_coldausgang", "iDokumentart_coldausgang can't be NULL")
                End If
                m_iDokumentart_coldausgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_coldeingang Property

Public Property [iDokumentart_coldeingang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_coldeingang]() As SqlInt32
            Get
                Return m_iDokumentart_coldeingang
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentart_coldeingangTmp As SqlInt32 = Value
                If iDokumentart_coldeingangTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentart_coldeingang", "iDokumentart_coldeingang can't be NULL")
                End If
                m_iDokumentart_coldeingang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_host Property

Public Property [iDokumentart_host]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_host]() As SqlInt32
            Get
                Return m_iDokumentart_host
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_host = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_kundendossier Property

Public Property [iDokumentart_kundendossier]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_kundendossier]() As SqlInt32
            Get
                Return m_iDokumentart_kundendossier
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_kundendossier = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_nativ Property

Public Property [iDokumentart_nativ]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_nativ]() As SqlInt32
            Get
                Return m_iDokumentart_nativ
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_nativ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_neuerstellung Property

Public Property [iDokumentart_neuerstellung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_neuerstellung]() As SqlInt32
            Get
                Return m_iDokumentart_neuerstellung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_neuerstellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_retournierung Property

Public Property [iDokumentart_retournierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_retournierung]() As SqlInt32
            Get
                Return m_iDokumentart_retournierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_retournierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentart_weitere Property

Public Property [iDokumentart_weitere]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentart_weitere]() As SqlInt32
            Get
                Return m_iDokumentart_weitere
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentart_weitere = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentstatus Property

Public Property [iDokumentstatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatus]() As SqlInt32
            Get
                Return m_iDokumentstatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumentstatus_barcode Property

Public Property [iDokumentstatus_barcode]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentstatus_barcode]() As SqlInt32
            Get
                Return m_iDokumentstatus_barcode
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentstatus_barcode = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumenttypnrTmp As SqlInt32 = Value
                If iDokumenttypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumenttypnr", "iDokumenttypnr can't be NULL")
                End If
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iMonate_bis_zur_archivierung Property

Public Property [iMonate_bis_zur_archivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMonate_bis_zur_archivierung]() As SqlInt32
            Get
                Return m_iMonate_bis_zur_archivierung
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMonate_bis_zur_archivierungTmp As SqlInt32 = Value
                If iMonate_bis_zur_archivierungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMonate_bis_zur_archivierung", "iMonate_bis_zur_archivierung can't be NULL")
                End If
                m_iMonate_bis_zur_archivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iObjektbezeichnungnr Property

Public Property [iObjektbezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iObjektbezeichnungnr]() As SqlInt32
            Get
                Return m_iObjektbezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iObjektbezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iOffice_vorlagenr Property

Public Property [iOffice_vorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlagenr]() As SqlInt32
            Get
                Return m_iOffice_vorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOffice_vorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iOwner Property

Public Property [iOwner]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOwner]() As SqlInt32
            Get
                Return m_iOwner
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOwner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iPhysisches_archiv Property

Public Property [iPhysisches_archiv]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPhysisches_archiv]() As SqlInt32
            Get
                Return m_iPhysisches_archiv
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPhysisches_archiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iProzessnr Property

Public Property [iProzessnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProzessnr]() As SqlInt32
            Get
                Return m_iProzessnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iProzessnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iProzessnr1 Property

Public Property [iProzessnr1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProzessnr1]() As SqlInt32
            Get
                Return m_iProzessnr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iProzessnr1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iTage_mutation Property

Public Property [iTage_mutation]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTage_mutation]() As SqlInt32
            Get
                Return m_iTage_mutation
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iTage_mutationTmp As SqlInt32 = Value
                If iTage_mutationTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iTage_mutation", "iTage_mutation can't be NULL")
                End If
                m_iTage_mutation = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.iTagebisvernichtungbedingteretournierung Property

Public Property [iTagebisvernichtungbedingteretournierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTagebisvernichtungbedingteretournierung]() As SqlInt32
            Get
                Return m_iTagebisvernichtungbedingteretournierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTagebisvernichtungbedingteretournierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.sHostdokumenttyp Property

Public Property [sHostdokumenttyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdokumenttyp]() As SqlString
            Get
                Return m_sHostdokumenttyp
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdokumenttyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp Methods

clsDokumenttyp overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsDokumenttyp Class


clsDokumenttyp.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_vercolden", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_vercolden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingang_ersetzt_ausgang", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bEingang_ersetzt_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_importiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_importiert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_tage", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_tage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idbearbeitungszeit", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDbearbeitungszeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itage_mutation", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTage_mutation))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bpartnersaldierung_statusalt", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bPartnersaldierung_statusalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_nicht_geloescht", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_nicht_geloescht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrauliches_dokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bVertrauliches_dokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_links", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_links))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_rechts", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_rechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imonate_bis_zur_archivierung", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMonate_bis_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_elektronisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_physisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_physisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_kundendossier", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_kundendossier))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_neuerstellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_neuerstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_retournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_retournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldausgang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldeingang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldeingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_host))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_weitere", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_weitere))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_nativ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_nativ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bhostdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bHostdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_folder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_folder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysisches_archiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPhysisches_archiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_erstellt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_erstellt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_retourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_retourniert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bcold_ersetzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bCold_ersetzen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemail_versand", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEmail_versand))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionen_zuweisen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionen_zuweisen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_barcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_barcode))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnurnative", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNurnative))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iOwner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrag", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbedingtretournierbar", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedingtretournierbar))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idoktypbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDoktypbedingteretournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itagebisvernichtungbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTagebisvernichtungbedingteretournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAnzeigeZurDokumenterstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigeZurDokumenterstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bKundenDokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bKundenDokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsb", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbimport", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbimport))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbedituser", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbedituser))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbnur", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbnur))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbezeichnungmut", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBezeichnungmut))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    m_bZu_vercolden = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_vercolden"), Boolean))
                    m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
                    m_bEingang_ersetzt_ausgang = New SqlBoolean(CType(dtToReturn.Rows(0)("eingang_ersetzt_ausgang"), Boolean))
                    m_bWird_importiert = New SqlBoolean(CType(dtToReturn.Rows(0)("wird_importiert"), Boolean))
                    m_iAnzahl_tage = New SqlInt32(CType(dtToReturn.Rows(0)("anzahl_tage"), Integer))
                    m_iDbearbeitungszeit = New SqlInt32(CType(dtToReturn.Rows(0)("dbearbeitungszeit"), Integer))
                    m_iTage_mutation = New SqlInt32(CType(dtToReturn.Rows(0)("tage_mutation"), Integer))
                    m_bPartnersaldierung_statusalt = New SqlBoolean(CType(dtToReturn.Rows(0)("partnersaldierung_statusalt"), Boolean))
                    m_bWird_nicht_geloescht = New SqlBoolean(CType(dtToReturn.Rows(0)("wird_nicht_geloescht"), Boolean))
                    m_bVertrauliches_dokument = New SqlBoolean(CType(dtToReturn.Rows(0)("vertrauliches_dokument"), Boolean))
                    m_bUnterschrift_links = New SqlBoolean(CType(dtToReturn.Rows(0)("unterschrift_links"), Boolean))
                    m_bUnterschrift_rechts = New SqlBoolean(CType(dtToReturn.Rows(0)("unterschrift_rechts"), Boolean))
                    m_iMonate_bis_zur_archivierung = New SqlInt32(CType(dtToReturn.Rows(0)("monate_bis_zur_archivierung"), Integer))
                    m_iAufbewahrungsfrist_elektronisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrungsfrist_elektronisch"), Integer))
                    m_iAufbewahrungsfrist_physisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrungsfrist_physisch"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
                        m_iOffice_vorlagenr = SqlInt32.Null
                    Else
                        m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentart_kundendossier") Is System.DBNull.Value Then
                        m_iDokumentart_kundendossier = SqlInt32.Null
                    Else
                        m_iDokumentart_kundendossier = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_kundendossier"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentart_neuerstellung") Is System.DBNull.Value Then
                        m_iDokumentart_neuerstellung = SqlInt32.Null
                    Else
                        m_iDokumentart_neuerstellung = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_neuerstellung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentart_retournierung") Is System.DBNull.Value Then
                        m_iDokumentart_retournierung = SqlInt32.Null
                    Else
                        m_iDokumentart_retournierung = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_retournierung"), Integer))
                    End If
                    m_iDokumentart_coldausgang = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_coldausgang"), Integer))
                    m_iDokumentart_coldeingang = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_coldeingang"), Integer))
                    If dtToReturn.Rows(0)("dokumentart_host") Is System.DBNull.Value Then
                        m_iDokumentart_host = SqlInt32.Null
                    Else
                        m_iDokumentart_host = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_host"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentart_weitere") Is System.DBNull.Value Then
                        m_iDokumentart_weitere = SqlInt32.Null
                    Else
                        m_iDokumentart_weitere = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_weitere"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentart_nativ") Is System.DBNull.Value Then
                        m_iDokumentart_nativ = SqlInt32.Null
                    Else
                        m_iDokumentart_nativ = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_nativ"), Integer))
                    End If
                    If dtToReturn.Rows(0)("prozessnr") Is System.DBNull.Value Then
                        m_iProzessnr = SqlInt32.Null
                    Else
                        m_iProzessnr = New SqlInt32(CType(dtToReturn.Rows(0)("prozessnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("prozessnr1") Is System.DBNull.Value Then
                        m_iProzessnr1 = SqlInt32.Null
                    Else
                        m_iProzessnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("prozessnr1"), Integer))
                    End If
                    m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
                    If dtToReturn.Rows(0)("hostdokument") Is System.DBNull.Value Then
                        m_bHostdokument = SqlBoolean.Null
                    Else
                        m_bHostdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("hostdokument"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("hostdokumenttyp") Is System.DBNull.Value Then
                        m_sHostdokumenttyp = SqlString.Null
                    Else
                        m_sHostdokumenttyp = New SqlString(CType(dtToReturn.Rows(0)("hostdokumenttyp"), String))
                    End If
                    If dtToReturn.Rows(0)("cold_folder") Is System.DBNull.Value Then
                        m_iCold_folder = SqlInt32.Null
                    Else
                        m_iCold_folder = New SqlInt32(CType(dtToReturn.Rows(0)("cold_folder"), Integer))
                    End If
                    If dtToReturn.Rows(0)("physisches_archiv") Is System.DBNull.Value Then
                        m_iPhysisches_archiv = SqlInt32.Null
                    Else
                        m_iPhysisches_archiv = New SqlInt32(CType(dtToReturn.Rows(0)("physisches_archiv"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentstatus") Is System.DBNull.Value Then
                        m_iDokumentstatus = SqlInt32.Null
                    Else
                        m_iDokumentstatus = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Dokument_wird_erstellt") Is System.DBNull.Value Then
                        m_bDokument_wird_erstellt = SqlBoolean.Null
                    Else
                        m_bDokument_wird_erstellt = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokument_wird_erstellt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Dokument_wird_retourniert") Is System.DBNull.Value Then
                        m_bDokument_wird_retourniert = SqlBoolean.Null
                    Else
                        m_bDokument_wird_retourniert = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokument_wird_retourniert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("cold_ersetzen") Is System.DBNull.Value Then
                        m_bCold_ersetzen = SqlBoolean.Null
                    Else
                        m_bCold_ersetzen = New SqlBoolean(CType(dtToReturn.Rows(0)("cold_ersetzen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("email_versand") Is System.DBNull.Value Then
                        m_bEmail_versand = SqlBoolean.Null
                    Else
                        m_bEmail_versand = New SqlBoolean(CType(dtToReturn.Rows(0)("email_versand"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("funktionen_zuweisen") Is System.DBNull.Value Then
                        m_bFunktionen_zuweisen = SqlBoolean.Null
                    Else
                        m_bFunktionen_zuweisen = New SqlBoolean(CType(dtToReturn.Rows(0)("funktionen_zuweisen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokumentstatus_barcode") Is System.DBNull.Value Then
                        m_iDokumentstatus_barcode = SqlInt32.Null
                    Else
                        m_iDokumentstatus_barcode = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus_barcode"), Integer))
                    End If
                    If dtToReturn.Rows(0)("nurnative") Is System.DBNull.Value Then
                        m_bNurnative = SqlBoolean.Null
                    Else
                        m_bNurnative = New SqlBoolean(CType(dtToReturn.Rows(0)("nurnative"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Owner") Is System.DBNull.Value Then
                        m_iOwner = SqlInt32.Null
                    Else
                        m_iOwner = New SqlInt32(CType(dtToReturn.Rows(0)("Owner"), Integer))
                    End If
                    If dtToReturn.Rows(0)("vertrag") Is System.DBNull.Value Then
                        m_bVertrag = SqlBoolean.Null
                    Else
                        m_bVertrag = New SqlBoolean(CType(dtToReturn.Rows(0)("vertrag"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("objektbezeichnungnr") Is System.DBNull.Value Then
                        m_iObjektbezeichnungnr = SqlInt32.Null
                    Else
                        m_iObjektbezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("objektbezeichnungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bedingtretournierbar") Is System.DBNull.Value Then
                        m_bBedingtretournierbar = SqlBoolean.Null
                    Else
                        m_bBedingtretournierbar = New SqlBoolean(CType(dtToReturn.Rows(0)("bedingtretournierbar"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("doktypbedingteretournierung") Is System.DBNull.Value Then
                        m_iDoktypbedingteretournierung = SqlInt32.Null
                    Else
                        m_iDoktypbedingteretournierung = New SqlInt32(CType(dtToReturn.Rows(0)("doktypbedingteretournierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tagebisvernichtungbedingteretournierung") Is System.DBNull.Value Then
                        m_iTagebisvernichtungbedingteretournierung = SqlInt32.Null
                    Else
                        m_iTagebisvernichtungbedingteretournierung = New SqlInt32(CType(dtToReturn.Rows(0)("tagebisvernichtungbedingteretournierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("AnzeigeZurDokumenterstellung") Is System.DBNull.Value Then
                        m_bAnzeigeZurDokumenterstellung = SqlBoolean.Null
                    Else
                        m_bAnzeigeZurDokumenterstellung = New SqlBoolean(CType(dtToReturn.Rows(0)("AnzeigeZurDokumenterstellung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("KundenDokument") Is System.DBNull.Value Then
                        m_bKundenDokument = SqlBoolean.Null
                    Else
                        m_bKundenDokument = New SqlBoolean(CType(dtToReturn.Rows(0)("KundenDokument"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("sb") Is System.DBNull.Value Then
                        m_bSb = SqlBoolean.Null
                    Else
                        m_bSb = New SqlBoolean(CType(dtToReturn.Rows(0)("sb"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("sbimport") Is System.DBNull.Value Then
                        m_bSbimport = SqlBoolean.Null
                    Else
                        m_bSbimport = New SqlBoolean(CType(dtToReturn.Rows(0)("sbimport"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("sbedituser") Is System.DBNull.Value Then
                        m_bSbedituser = SqlBoolean.Null
                    Else
                        m_bSbedituser = New SqlBoolean(CType(dtToReturn.Rows(0)("sbedituser"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("sbnur") Is System.DBNull.Value Then
                        m_bSbnur = SqlBoolean.Null
                    Else
                        m_bSbnur = New SqlBoolean(CType(dtToReturn.Rows(0)("sbnur"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bezeichnungmut") Is System.DBNull.Value Then
                        m_bBezeichnungmut = SqlBoolean.Null
                    Else
                        m_bBezeichnungmut = New SqlBoolean(CType(dtToReturn.Rows(0)("bezeichnungmut"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_vercolden", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_vercolden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingang_ersetzt_ausgang", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bEingang_ersetzt_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_importiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_importiert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_tage", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_tage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idbearbeitungszeit", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDbearbeitungszeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itage_mutation", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTage_mutation))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bpartnersaldierung_statusalt", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bPartnersaldierung_statusalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_nicht_geloescht", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_nicht_geloescht))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrauliches_dokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bVertrauliches_dokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_links", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_links))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_rechts", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_rechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imonate_bis_zur_archivierung", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMonate_bis_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_elektronisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_physisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_physisch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_kundendossier", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_kundendossier))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_neuerstellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_neuerstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_retournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_retournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldausgang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldeingang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldeingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_host))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_weitere", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_weitere))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_nativ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_nativ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bhostdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bHostdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_folder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_folder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysisches_archiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPhysisches_archiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_erstellt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_erstellt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_retourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_retourniert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bcold_ersetzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bCold_ersetzen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bemail_versand", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEmail_versand))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionen_zuweisen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionen_zuweisen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_barcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_barcode))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnurnative", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNurnative))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iOwner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrag", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbedingtretournierbar", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedingtretournierbar))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idoktypbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDoktypbedingteretournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itagebisvernichtungbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTagebisvernichtungbedingteretournierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAnzeigeZurDokumenterstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigeZurDokumenterstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bKundenDokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bKundenDokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsb", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbimport", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbimport))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbedituser", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbedituser))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbnur", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbnur))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbezeichnungmut", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBezeichnungmut))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDokumenttyp Fields

clsDokumenttyp overview

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAnzeigeZurDokumenterstellung
field m_bBedingtretournierbar
field m_bBezeichnungmut
field m_bCold_ersetzen
field m_bDokument_wird_erstellt
field m_bDokument_wird_retourniert
field m_bEingang_ersetzt_ausgang
field m_bEmail_versand
field m_bFunktionen_zuweisen
field m_bHostdokument
field m_bKundenDokument
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bNurnative
field m_bPartnersaldierung_statusalt
field m_bSb
field m_bSbedituser
field m_bSbimport
field m_bSbnur
field m_bUnterschrift_links
field m_bUnterschrift_rechts
field m_bVertrag
field m_bVertrauliches_dokument
field m_bWird_importiert
field m_bWird_nicht_geloescht
field m_bZu_retournieren
field m_bZu_vercolden
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnzahl_tage
field m_iAufbewahrungsfrist_elektronisch
field m_iAufbewahrungsfrist_physisch
field m_iCold_folder
field m_iDbearbeitungszeit
field m_iDoktypbedingteretournierung
field m_iDokumentart_coldausgang
field m_iDokumentart_coldeingang
field m_iDokumentart_host
field m_iDokumentart_kundendossier
field m_iDokumentart_nativ
field m_iDokumentart_neuerstellung
field m_iDokumentart_retournierung
field m_iDokumentart_weitere
field m_iDokumentstatus
field m_iDokumentstatus_barcode
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMonate_bis_zur_archivierung
field m_iMutierer
field m_iObjektbezeichnungnr
field m_iOffice_vorlagenr
field m_iOwner
field m_iPhysisches_archiv
field m_iProzessnr
field m_iProzessnr1
field m_iTage_mutation
field m_iTagebisvernichtungbedingteretournierung
field m_sBeschreibung
field m_sBezeichnung
field m_sHostdokumenttyp
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDokumenttyp Class


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bAmsdokument Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bAnzeigeZurDokumenterstellung Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bBedingtretournierbar Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bBezeichnungmut Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bCold_ersetzen Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bDokument_wird_erstellt Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bDokument_wird_retourniert Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bEingang_ersetzt_ausgang Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bEmail_versand Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bFunktionen_zuweisen Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bHostdokument Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bKundenDokument Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bNurnative Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bPartnersaldierung_statusalt Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bSb Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bSbedituser Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bSbimport Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bSbnur Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bUnterschrift_links Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bUnterschrift_rechts Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bVertrag Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bVertrauliches_dokument Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bWird_importiert Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bWird_nicht_geloescht Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bZu_retournieren Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_bZu_vercolden Variable

Private 		m_bAktiv, _
   m_bVertrag, _
   m_bNurnative, _
   m_bUnterschrift_rechts, _
   m_bAnzeigeZurDokumenterstellung, _
   m_bBedingtretournierbar, _
   m_bFunktionen_zuweisen, _
   m_bDokument_wird_erstellt, _
   m_bAmsdokument, _
   m_bHostdokument, _
   m_bEmail_versand, _
   m_bCold_ersetzen, _
   m_bDokument_wird_retourniert, _
   m_bUnterschrift_links, _
   m_bWird_importiert, _
   m_bEingang_ersetzt_ausgang, _
   m_bSb, _
   m_bSbimport, _
   m_bZu_retournieren, _
   m_bSbnur, _
   m_bBezeichnungmut, _
   m_bZu_vercolden, _
   m_bSbedituser, _
   m_bPartnersaldierung_statusalt, _
   m_bKundenDokument, _
   m_bVertrauliches_dokument, _
   m_bWird_nicht_geloescht As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iAnzahl_tage Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iAufbewahrungsfrist_elektronisch Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iAufbewahrungsfrist_physisch Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iCold_folder Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDbearbeitungszeit Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDoktypbedingteretournierung Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_coldausgang Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_coldeingang Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_host Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_kundendossier Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_nativ Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_neuerstellung Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_retournierung Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentart_weitere Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentstatus Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumentstatus_barcode Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iDokumenttypnr Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iMandantnr Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iMonate_bis_zur_archivierung Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iMutierer Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iObjektbezeichnungnr Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iOffice_vorlagenr Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iOwner Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iPhysisches_archiv Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iProzessnr Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iProzessnr1 Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iTage_mutation Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_iTagebisvernichtungbedingteretournierung Variable

Private 		m_iOwner, _
   m_iPhysisches_archiv, _
   m_iCold_folder, _
   m_iObjektbezeichnungnr, _
   m_iDoktypbedingteretournierung, _
   m_iDokumentstatus_barcode, _
   m_iDokumentstatus, _
   m_iTagebisvernichtungbedingteretournierung, _
   m_iAufbewahrungsfrist_physisch, _
   m_iAufbewahrungsfrist_elektronisch, _
   m_iMandantnr, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnzahl_tage, _
   m_iDokumenttypnr, _
   m_iDbearbeitungszeit, _
   m_iMonate_bis_zur_archivierung, _
   m_iTage_mutation, _
   m_iDokumentart_kundendossier, _
   m_iDokumentart_nativ, _
   m_iDokumentart_weitere, _
   m_iProzessnr1, _
   m_iProzessnr, _
   m_iDokumentart_host, _
   m_iDokumentart_retournierung, _
   m_iDokumentart_neuerstellung, _
   m_iDokumentart_coldeingang, _
   m_iDokumentart_coldausgang As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_sBeschreibung Variable

Private 		m_sHostdokumenttyp, _
   m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_sBezeichnung Variable

Private 		m_sHostdokumenttyp, _
   m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


m_sHostdokumenttyp Variable

Private 		m_sHostdokumenttyp, _
   m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDokumenttyp


clsDomainTable Class

For a list of all members of this type, see clsDomainTable Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDomainTable

Public Class clsDomainTable
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsDomainTable Members


clsDomainTable Members

clsDomainTable overview

Constructors

constructor clsDomainTable Constructor

Properties

property Aktive
property Tablename
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_Aktive
field m_Tablename
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDomainTable Class


clsDomainTable Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


clsDomainTable Properties

clsDomainTable overview

Properties

property Aktive
property Tablename
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDomainTable Class


clsDomainTable.Aktive Property

Property Aktive() As Boolean

Source code

[Visual Basic]
        Property Aktive() As Boolean
            Get
                Return m_Aktive
            End Get
            Set(ByVal Value As Boolean)
                If Value = False Then m_Aktive = 0 Else m_Aktive = 1
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


clsDomainTable.Tablename Property

Property Tablename() As String

Source code

[Visual Basic]
        Property Tablename() As String
            Get
                Return m_Tablename
            End Get
            Set(ByVal Value As String)
                m_Tablename = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


clsDomainTable Methods

clsDomainTable overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDomainTable Class


clsDomainTable.SelectAll Method

Public Overrides Function SelectAll() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_Domaintable]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_Tablename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Aktive", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_Aktive))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDomainTable::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


clsDomainTable Fields

clsDomainTable overview

Fields

field m_Aktive
field m_Tablename
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsDomainTable Class


m_Aktive Variable

Dim m_Aktive As Integer

Source code

[Visual Basic]
        Dim m_Aktive As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


m_Tablename Variable

Dim m_Tablename As String

Source code

[Visual Basic]
        Dim m_Tablename As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDomainTable


clsEDEX_BL_Auslieferung Class

For a list of all members of this type, see clsEDEX_BL_Auslieferung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_Auslieferung

Public Class clsEDEX_BL_Auslieferung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_Auslieferung Members


clsEDEX_BL_Auslieferung Members

clsEDEX_BL_Auslieferung overview

Constructors

constructor clsEDEX_BL_Auslieferung Constructor

Properties

property bAktiv
property bAushaendigung_blv
property bAushaendigung_kube
property bAushaendigung_nicht_verschlossen
property bAushaendigung_verschlossen
property bAushaendigungsart_persoenlich
property bAushaendigungsart_post
property bBeilage_zur_Quittung1
property bBeilage_zur_Quittung2
property bBeilage_zur_Quittung3
property bGrundlage1
property bGrundlage2
property bGrundlage3
property bGrundlage4
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDokumenteab
property daDokumentebis
property daErstellt_am
property daGrundlage1_Datum
property daGrundlage2_Datum
property daGrundlage3_Datum
property daGrundlage4_Datum
property daMutiert_am
property iAuslieferungnr
property iBlv
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKube
property iMutierer
property iNrpar00
property iStatus
property sBeilage_zur_Quittung_text
property sBemerkung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid_quittung
property sQuittungsflag

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAushaendigung_blv
field m_bAushaendigung_kube
field m_bAushaendigung_nicht_verschlossen
field m_bAushaendigung_verschlossen
field m_bAushaendigungsart_persoenlich
field m_bAushaendigungsart_post
field m_bBeilage_zur_Quittung1
field m_bBeilage_zur_Quittung2
field m_bBeilage_zur_Quittung3
field m_bGrundlage1
field m_bGrundlage2
field m_bGrundlage3
field m_bGrundlage4
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDokumenteab
field m_daDokumentebis
field m_daErstellt_am
field m_daGrundlage1_Datum
field m_daGrundlage2_Datum
field m_daGrundlage3_Datum
field m_daGrundlage4_Datum
field m_daMutiert_am
field m_iAuslieferungnr
field m_iBlv
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKube
field m_iMutierer
field m_iNrpar00
field m_iStatus
field m_sBeilage_zur_Quittung_text
field m_sBemerkung
field m_sBezeichnung
field m_sDokumentid_quittung
field m_sQuittungsflag
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Auslieferung Class


clsEDEX_BL_Auslieferung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung Properties

clsEDEX_BL_Auslieferung overview

Properties

property bAktiv
property bAushaendigung_blv
property bAushaendigung_kube
property bAushaendigung_nicht_verschlossen
property bAushaendigung_verschlossen
property bAushaendigungsart_persoenlich
property bAushaendigungsart_post
property bBeilage_zur_Quittung1
property bBeilage_zur_Quittung2
property bBeilage_zur_Quittung3
property bGrundlage1
property bGrundlage2
property bGrundlage3
property bGrundlage4
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDokumenteab
property daDokumentebis
property daErstellt_am
property daGrundlage1_Datum
property daGrundlage2_Datum
property daGrundlage3_Datum
property daGrundlage4_Datum
property daMutiert_am
property iAuslieferungnr
property iBlv
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKube
property iMutierer
property iNrpar00
property iStatus
property sBeilage_zur_Quittung_text
property sBemerkung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid_quittung
property sQuittungsflag

See Also

clsEDEX_BL_Auslieferung Class


clsEDEX_BL_Auslieferung.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigung_blv Property

Public Property [bAushaendigung_blv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigung_blv]() As SqlBoolean
            Get
                Return m_bAushaendigung_blv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigung_blv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigung_kube Property

Public Property [bAushaendigung_kube]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigung_kube]() As SqlBoolean
            Get
                Return m_bAushaendigung_kube
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigung_kube = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigung_nicht_verschlossen Property

Public Property [bAushaendigung_nicht_verschlossen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigung_nicht_verschlossen]() As SqlBoolean
            Get
                Return m_bAushaendigung_nicht_verschlossen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigung_nicht_verschlossen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigung_verschlossen Property

Public Property [bAushaendigung_verschlossen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigung_verschlossen]() As SqlBoolean
            Get
                Return m_bAushaendigung_verschlossen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigung_verschlossen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigungsart_persoenlich Property

Public Property [bAushaendigungsart_persoenlich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigungsart_persoenlich]() As SqlBoolean
            Get
                Return m_bAushaendigungsart_persoenlich
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigungsart_persoenlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bAushaendigungsart_post Property

Public Property [bAushaendigungsart_post]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAushaendigungsart_post]() As SqlBoolean
            Get
                Return m_bAushaendigungsart_post
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAushaendigungsart_post = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bBeilage_zur_Quittung1 Property

Public Property [bBeilage_zur_Quittung1]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBeilage_zur_Quittung1]() As SqlBoolean
            Get
                Return m_bBeilage_zur_Quittung1
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBeilage_zur_Quittung1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bBeilage_zur_Quittung2 Property

Public Property [bBeilage_zur_Quittung2]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBeilage_zur_Quittung2]() As SqlBoolean
            Get
                Return m_bBeilage_zur_Quittung2
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBeilage_zur_Quittung2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bBeilage_zur_Quittung3 Property

Public Property [bBeilage_zur_Quittung3]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBeilage_zur_Quittung3]() As SqlBoolean
            Get
                Return m_bBeilage_zur_Quittung3
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBeilage_zur_Quittung3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bGrundlage1 Property

Public Property [bGrundlage1]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGrundlage1]() As SqlBoolean
            Get
                Return m_bGrundlage1
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGrundlage1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bGrundlage2 Property

Public Property [bGrundlage2]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGrundlage2]() As SqlBoolean
            Get
                Return m_bGrundlage2
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGrundlage2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bGrundlage3 Property

Public Property [bGrundlage3]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGrundlage3]() As SqlBoolean
            Get
                Return m_bGrundlage3
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGrundlage3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.bGrundlage4 Property

Public Property [bGrundlage4]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGrundlage4]() As SqlBoolean
            Get
                Return m_bGrundlage4
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGrundlage4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daDokumenteab Property

Public Property [daDokumenteab]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDokumenteab]() As SqlDateTime
            Get
                Return m_daDokumenteab
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDokumenteab = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daDokumentebis Property

Public Property [daDokumentebis]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDokumentebis]() As SqlDateTime
            Get
                Return m_daDokumentebis
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDokumentebis = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daGrundlage1_Datum Property

Public Property [daGrundlage1_Datum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGrundlage1_Datum]() As SqlDateTime
            Get
                Return m_daGrundlage1_Datum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGrundlage1_Datum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daGrundlage2_Datum Property

Public Property [daGrundlage2_Datum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGrundlage2_Datum]() As SqlDateTime
            Get
                Return m_daGrundlage2_Datum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGrundlage2_Datum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daGrundlage3_Datum Property

Public Property [daGrundlage3_Datum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGrundlage3_Datum]() As SqlDateTime
            Get
                Return m_daGrundlage3_Datum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGrundlage3_Datum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daGrundlage4_Datum Property

Public Property [daGrundlage4_Datum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGrundlage4_Datum]() As SqlDateTime
            Get
                Return m_daGrundlage4_Datum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGrundlage4_Datum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iAuslieferungnr Property

Public Property [iAuslieferungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAuslieferungnr]() As SqlInt32
            Get
                Return m_iAuslieferungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iAuslieferungnrTmp As SqlInt32 = Value
                If iAuslieferungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iAuslieferungnr", "iAuslieferungnr can't be NULL")
                End If
                m_iAuslieferungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iBlv Property

Public Property [iBlv]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBlv]() As SqlInt32
            Get
                Return m_iBlv
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBlv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iKube Property

Public Property [iKube]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKube]() As SqlInt32
            Get
                Return m_iKube
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKube = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.sBeilage_zur_Quittung_text Property

Public Property [sBeilage_zur_Quittung_text]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeilage_zur_Quittung_text]() As SqlString
            Get
                Return m_sBeilage_zur_Quittung_text
            End Get
            Set(ByVal Value As SqlString)
                m_sBeilage_zur_Quittung_text = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.sDokumentid_quittung Property

Public Property [sDokumentid_quittung]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid_quittung]() As SqlString
            Get
                Return m_sDokumentid_quittung
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid_quittung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.sQuittungsflag Property

Public Property [sQuittungsflag]() As SqlString

Source code

[Visual Basic]
        Public Property [sQuittungsflag]() As SqlString
            Get
                Return m_sQuittungsflag
            End Get
            Set(ByVal Value As SqlString)
                m_sQuittungsflag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung Methods

clsEDEX_BL_Auslieferung overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_BL_Auslieferung Class


clsEDEX_BL_Auslieferung.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Auslieferung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Auslieferung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Auslieferung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Auslieferung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid_quittung", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid_quittung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@squittungsflag", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sQuittungsflag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage1_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage1_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage2", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage2_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage2_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage3", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage3_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage3_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage4", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage4_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage4_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_blv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_blv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikube", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigungsart_persoenlich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigungsart_persoenlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baushaendigungsart_post", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigungsart_post))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_verschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_verschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_nicht_verschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_nicht_verschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung2", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung3", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeilage_zur_Quittung_text", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeilage_zur_Quittung_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumenteab", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumenteab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumentebis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumentebis))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iAuslieferungnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iauslieferungnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Auslieferung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Auslieferung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Auslieferung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Auslieferung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Auslieferung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Auslieferung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Auslieferung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Auslieferung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Auslieferung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iAuslieferungnr = New SqlInt32(CType(dtToReturn.Rows(0)("auslieferungnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentid_quittung") Is System.DBNull.Value Then
                        m_sDokumentid_quittung = SqlString.Null
                    Else
                        m_sDokumentid_quittung = New SqlString(CType(dtToReturn.Rows(0)("dokumentid_quittung"), String))
                    End If
                    If dtToReturn.Rows(0)("quittungsflag") Is System.DBNull.Value Then
                        m_sQuittungsflag = SqlString.Null
                    Else
                        m_sQuittungsflag = New SqlString(CType(dtToReturn.Rows(0)("quittungsflag"), String))
                    End If
                    If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
                        m_iNrpar00 = SqlInt32.Null
                    Else
                        m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status") Is System.DBNull.Value Then
                        m_iStatus = SqlInt32.Null
                    Else
                        m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Grundlage1") Is System.DBNull.Value Then
                        m_bGrundlage1 = SqlBoolean.Null
                    Else
                        m_bGrundlage1 = New SqlBoolean(CType(dtToReturn.Rows(0)("Grundlage1"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Grundlage1_Datum") Is System.DBNull.Value Then
                        m_daGrundlage1_Datum = SqlDateTime.Null
                    Else
                        m_daGrundlage1_Datum = New SqlDateTime(CType(dtToReturn.Rows(0)("Grundlage1_Datum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Grundlage2") Is System.DBNull.Value Then
                        m_bGrundlage2 = SqlBoolean.Null
                    Else
                        m_bGrundlage2 = New SqlBoolean(CType(dtToReturn.Rows(0)("Grundlage2"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Grundlage2_Datum") Is System.DBNull.Value Then
                        m_daGrundlage2_Datum = SqlDateTime.Null
                    Else
                        m_daGrundlage2_Datum = New SqlDateTime(CType(dtToReturn.Rows(0)("Grundlage2_Datum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Grundlage3") Is System.DBNull.Value Then
                        m_bGrundlage3 = SqlBoolean.Null
                    Else
                        m_bGrundlage3 = New SqlBoolean(CType(dtToReturn.Rows(0)("Grundlage3"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Grundlage3_Datum") Is System.DBNull.Value Then
                        m_daGrundlage3_Datum = SqlDateTime.Null
                    Else
                        m_daGrundlage3_Datum = New SqlDateTime(CType(dtToReturn.Rows(0)("Grundlage3_Datum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Grundlage4") Is System.DBNull.Value Then
                        m_bGrundlage4 = SqlBoolean.Null
                    Else
                        m_bGrundlage4 = New SqlBoolean(CType(dtToReturn.Rows(0)("Grundlage4"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Grundlage4_Datum") Is System.DBNull.Value Then
                        m_daGrundlage4_Datum = SqlDateTime.Null
                    Else
                        m_daGrundlage4_Datum = New SqlDateTime(CType(dtToReturn.Rows(0)("Grundlage4_Datum"), Date))
                    End If
                    If dtToReturn.Rows(0)("Aushaendigung_blv") Is System.DBNull.Value Then
                        m_bAushaendigung_blv = SqlBoolean.Null
                    Else
                        m_bAushaendigung_blv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aushaendigung_blv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("blv") Is System.DBNull.Value Then
                        m_iBlv = SqlInt32.Null
                    Else
                        m_iBlv = New SqlInt32(CType(dtToReturn.Rows(0)("blv"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aushaendigung_kube") Is System.DBNull.Value Then
                        m_bAushaendigung_kube = SqlBoolean.Null
                    Else
                        m_bAushaendigung_kube = New SqlBoolean(CType(dtToReturn.Rows(0)("Aushaendigung_kube"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("kube") Is System.DBNull.Value Then
                        m_iKube = SqlInt32.Null
                    Else
                        m_iKube = New SqlInt32(CType(dtToReturn.Rows(0)("kube"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aushaendigungsart_persoenlich") Is System.DBNull.Value Then
                        m_bAushaendigungsart_persoenlich = SqlBoolean.Null
                    Else
                        m_bAushaendigungsart_persoenlich = New SqlBoolean(CType(dtToReturn.Rows(0)("Aushaendigungsart_persoenlich"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aushaendigungsart_post") Is System.DBNull.Value Then
                        m_bAushaendigungsart_post = SqlBoolean.Null
                    Else
                        m_bAushaendigungsart_post = New SqlBoolean(CType(dtToReturn.Rows(0)("aushaendigungsart_post"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aushaendigung_verschlossen") Is System.DBNull.Value Then
                        m_bAushaendigung_verschlossen = SqlBoolean.Null
                    Else
                        m_bAushaendigung_verschlossen = New SqlBoolean(CType(dtToReturn.Rows(0)("Aushaendigung_verschlossen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Aushaendigung_nicht_verschlossen") Is System.DBNull.Value Then
                        m_bAushaendigung_nicht_verschlossen = SqlBoolean.Null
                    Else
                        m_bAushaendigung_nicht_verschlossen = New SqlBoolean(CType(dtToReturn.Rows(0)("Aushaendigung_nicht_verschlossen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Beilage_zur_Quittung1") Is System.DBNull.Value Then
                        m_bBeilage_zur_Quittung1 = SqlBoolean.Null
                    Else
                        m_bBeilage_zur_Quittung1 = New SqlBoolean(CType(dtToReturn.Rows(0)("Beilage_zur_Quittung1"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Beilage_zur_Quittung2") Is System.DBNull.Value Then
                        m_bBeilage_zur_Quittung2 = SqlBoolean.Null
                    Else
                        m_bBeilage_zur_Quittung2 = New SqlBoolean(CType(dtToReturn.Rows(0)("Beilage_zur_Quittung2"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Beilage_zur_Quittung3") Is System.DBNull.Value Then
                        m_bBeilage_zur_Quittung3 = SqlBoolean.Null
                    Else
                        m_bBeilage_zur_Quittung3 = New SqlBoolean(CType(dtToReturn.Rows(0)("Beilage_zur_Quittung3"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Beilage_zur_Quittung_text") Is System.DBNull.Value Then
                        m_sBeilage_zur_Quittung_text = SqlString.Null
                    Else
                        m_sBeilage_zur_Quittung_text = New SqlString(CType(dtToReturn.Rows(0)("Beilage_zur_Quittung_text"), String))
                    End If
                    If dtToReturn.Rows(0)("Bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("Bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumenteab") Is System.DBNull.Value Then
                        m_daDokumenteab = SqlDateTime.Null
                    Else
                        m_daDokumenteab = New SqlDateTime(CType(dtToReturn.Rows(0)("dokumenteab"), Date))
                    End If
                    If dtToReturn.Rows(0)("dokumentebis") Is System.DBNull.Value Then
                        m_daDokumentebis = SqlDateTime.Null
                    Else
                        m_daDokumentebis = New SqlDateTime(CType(dtToReturn.Rows(0)("dokumentebis"), Date))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Auslieferung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Auslieferung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid_quittung", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid_quittung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@squittungsflag", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sQuittungsflag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage1_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage1_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage2", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage2_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage2_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage3", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage3_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage3_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bGrundlage4", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGrundlage4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daGrundlage4_Datum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGrundlage4_Datum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_blv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_blv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikube", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigungsart_persoenlich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigungsart_persoenlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baushaendigungsart_post", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigungsart_post))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_verschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_verschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAushaendigung_nicht_verschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAushaendigung_nicht_verschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung2", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bBeilage_zur_Quittung3", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBeilage_zur_Quittung3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBeilage_zur_Quittung_text", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeilage_zur_Quittung_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumenteab", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumenteab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumentebis", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumentebis))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Auslieferung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Auslieferung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_Auslieferung Fields

clsEDEX_BL_Auslieferung overview

Fields

field m_bAktiv
field m_bAushaendigung_blv
field m_bAushaendigung_kube
field m_bAushaendigung_nicht_verschlossen
field m_bAushaendigung_verschlossen
field m_bAushaendigungsart_persoenlich
field m_bAushaendigungsart_post
field m_bBeilage_zur_Quittung1
field m_bBeilage_zur_Quittung2
field m_bBeilage_zur_Quittung3
field m_bGrundlage1
field m_bGrundlage2
field m_bGrundlage3
field m_bGrundlage4
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDokumenteab
field m_daDokumentebis
field m_daErstellt_am
field m_daGrundlage1_Datum
field m_daGrundlage2_Datum
field m_daGrundlage3_Datum
field m_daGrundlage4_Datum
field m_daMutiert_am
field m_iAuslieferungnr
field m_iBlv
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKube
field m_iMutierer
field m_iNrpar00
field m_iStatus
field m_sBeilage_zur_Quittung_text
field m_sBemerkung
field m_sBezeichnung
field m_sDokumentid_quittung
field m_sQuittungsflag
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Auslieferung Class


m_bAktiv Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigung_blv Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigung_kube Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigung_nicht_verschlossen Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigung_verschlossen Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigungsart_persoenlich Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bAushaendigungsart_post Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bBeilage_zur_Quittung1 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bBeilage_zur_Quittung2 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bBeilage_zur_Quittung3 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bGrundlage1 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bGrundlage2 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bGrundlage3 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_bGrundlage4 Variable

Private 		m_bAushaendigung_blv, _
   m_bAushaendigung_kube, _
   m_bAushaendigungsart_persoenlich, _
   m_bGrundlage2, _
   m_bGrundlage3, _
   m_bGrundlage4, _
   m_bBeilage_zur_Quittung1, _
   m_bBeilage_zur_Quittung2, _
   m_bBeilage_zur_Quittung3, _
   m_bAushaendigungsart_post, _
   m_bAushaendigung_verschlossen, _
   m_bAushaendigung_nicht_verschlossen, _
   m_bGrundlage1, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAushaendigung_blv, m_bAushaendigung_kube, m_bAushaendigungsart_persoenlich, m_bGrundlage2, m_bGrundlage3, m_bGrundlage4, m_bBeilage_zur_Quittung1, m_bBeilage_zur_Quittung2, m_bBeilage_zur_Quittung3, m_bAushaendigungsart_post, m_bAushaendigung_verschlossen, m_bAushaendigung_nicht_verschlossen, m_bGrundlage1, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daDokumenteab Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daDokumentebis Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daErstellt_am Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daGrundlage1_Datum Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daGrundlage2_Datum Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daGrundlage3_Datum Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daGrundlage4_Datum Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_daMutiert_am Variable

Private 		m_daDokumentebis, _
   m_daMutiert_am, _
   m_daDokumenteab, _
   m_daErstellt_am, _
   m_daGrundlage1_Datum, _
   m_daGrundlage3_Datum, _
   m_daGrundlage4_Datum, _
   m_daGrundlage2_Datum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDokumentebis, m_daMutiert_am, m_daDokumenteab, m_daErstellt_am, m_daGrundlage1_Datum, m_daGrundlage3_Datum, m_daGrundlage4_Datum, m_daGrundlage2_Datum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iAuslieferungnr Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iBlv Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iKube Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iMutierer Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iNrpar00 Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_iStatus Variable

Private 		m_iNrpar00, _
   m_iAuslieferungnr, _
   m_iBlv, _
   m_iMutierer, _
   m_iStatus, _
   m_iKube As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00, m_iAuslieferungnr, m_iBlv, m_iMutierer, m_iStatus, m_iKube As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_sBeilage_zur_Quittung_text Variable

Private 		m_sBemerkung, _
   m_sBeilage_zur_Quittung_text, _
   m_sQuittungsflag, _
   m_sDokumentid_quittung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sBeilage_zur_Quittung_text, m_sQuittungsflag, m_sDokumentid_quittung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_sBemerkung Variable

Private 		m_sBemerkung, _
   m_sBeilage_zur_Quittung_text, _
   m_sQuittungsflag, _
   m_sDokumentid_quittung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sBeilage_zur_Quittung_text, m_sQuittungsflag, m_sDokumentid_quittung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_sBezeichnung Variable

Private 		m_sBemerkung, _
   m_sBeilage_zur_Quittung_text, _
   m_sQuittungsflag, _
   m_sDokumentid_quittung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sBeilage_zur_Quittung_text, m_sQuittungsflag, m_sDokumentid_quittung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_sDokumentid_quittung Variable

Private 		m_sBemerkung, _
   m_sBeilage_zur_Quittung_text, _
   m_sQuittungsflag, _
   m_sDokumentid_quittung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sBeilage_zur_Quittung_text, m_sQuittungsflag, m_sDokumentid_quittung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


m_sQuittungsflag Variable

Private 		m_sBemerkung, _
   m_sBeilage_zur_Quittung_text, _
   m_sQuittungsflag, _
   m_sDokumentid_quittung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sBeilage_zur_Quittung_text, m_sQuittungsflag, m_sDokumentid_quittung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Auslieferung


clsEDEX_BL_BLIndex Class

For a list of all members of this type, see clsEDEX_BL_BLIndex Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_BLIndex

Public Class clsEDEX_BL_BLIndex
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_BLIndex Members


clsEDEX_BL_BLIndex Members

clsEDEX_BL_BLIndex overview

Constructors

constructor clsEDEX_BL_BLIndex Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property daScandatum
property iAuslieferungnr
property iBLIndexnr
property iBl_status
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property sCold_dokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sRes1
property sRes2
property sRes3
property sStapelnr
property sUser_id

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_daScandatum
field m_iAuslieferungnr
field m_iBLIndexnr
field m_iBl_status
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_sCold_dokumentid
field m_sDokumentid
field m_sRes1
field m_sRes2
field m_sRes3
field m_sStapelnr
field m_sUser_id
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_BLIndex Class


clsEDEX_BL_BLIndex Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex Properties

clsEDEX_BL_BLIndex overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property daScandatum
property iAuslieferungnr
property iBLIndexnr
property iBl_status
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property sCold_dokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sRes1
property sRes2
property sRes3
property sStapelnr
property sUser_id

See Also

clsEDEX_BL_BLIndex Class


clsEDEX_BL_BLIndex.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.daScandatum Property

Public Property [daScandatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daScandatum]() As SqlDateTime
            Get
                Return m_daScandatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daScandatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.iAuslieferungnr Property

Public Property [iAuslieferungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAuslieferungnr]() As SqlInt32
            Get
                Return m_iAuslieferungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuslieferungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.iBLIndexnr Property

Public Property [iBLIndexnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBLIndexnr]() As SqlInt32
            Get
                Return m_iBLIndexnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBLIndexnrTmp As SqlInt32 = Value
                If iBLIndexnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBLIndexnr", "iBLIndexnr can't be NULL")
                End If
                m_iBLIndexnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.iBl_status Property

Public Property [iBl_status]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBl_status]() As SqlInt32
            Get
                Return m_iBl_status
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBl_status = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sCold_dokumentid Property

Public Property [sCold_dokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sCold_dokumentid]() As SqlString
            Get
                Return m_sCold_dokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sCold_dokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentidTmp As SqlString = Value
                If sDokumentidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
                End If
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sRes1 Property

Public Property [sRes1]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes1]() As SqlString
            Get
                Return m_sRes1
            End Get
            Set(ByVal Value As SqlString)
                m_sRes1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sRes2 Property

Public Property [sRes2]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes2]() As SqlString
            Get
                Return m_sRes2
            End Get
            Set(ByVal Value As SqlString)
                m_sRes2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sRes3 Property

Public Property [sRes3]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes3]() As SqlString
            Get
                Return m_sRes3
            End Get
            Set(ByVal Value As SqlString)
                m_sRes3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sStapelnr Property

Public Property [sStapelnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sStapelnr]() As SqlString
            Get
                Return m_sStapelnr
            End Get
            Set(ByVal Value As SqlString)
                m_sStapelnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.sUser_id Property

Public Property [sUser_id]() As SqlString

Source code

[Visual Basic]
        Public Property [sUser_id]() As SqlString
            Get
                Return m_sUser_id
            End Get
            Set(ByVal Value As SqlString)
                m_sUser_id = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex Methods

clsEDEX_BL_BLIndex overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_BL_BLIndex Class


clsEDEX_BL_BLIndex.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLIndex_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBLIndexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLIndexnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLIndex_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLIndex::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLIndex_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibl_status", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBl_status))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_id))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sstapelnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStapelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dascandatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daScandatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scold_dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCold_dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iBLIndexnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iBLIndexnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iBLIndexnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iBLIndexnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLIndex_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLIndex::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLIndex_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_BLIndex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLIndex_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLIndex::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLIndex_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_BLIndex")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iBLIndexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLIndexnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLIndex_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBLIndexnr = New SqlInt32(CType(dtToReturn.Rows(0)("BLIndexnr"), Integer))
                    m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("Dokumentid"), String))
                    m_iBl_status = New SqlInt32(CType(dtToReturn.Rows(0)("bl_status"), Integer))
                    If dtToReturn.Rows(0)("user_id") Is System.DBNull.Value Then
                        m_sUser_id = SqlString.Null
                    Else
                        m_sUser_id = New SqlString(CType(dtToReturn.Rows(0)("user_id"), String))
                    End If
                    If dtToReturn.Rows(0)("stapelnr") Is System.DBNull.Value Then
                        m_sStapelnr = SqlString.Null
                    Else
                        m_sStapelnr = New SqlString(CType(dtToReturn.Rows(0)("stapelnr"), String))
                    End If
                    If dtToReturn.Rows(0)("scandatum") Is System.DBNull.Value Then
                        m_daScandatum = SqlDateTime.Null
                    Else
                        m_daScandatum = New SqlDateTime(CType(dtToReturn.Rows(0)("scandatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("cold_dokumentid") Is System.DBNull.Value Then
                        m_sCold_dokumentid = SqlString.Null
                    Else
                        m_sCold_dokumentid = New SqlString(CType(dtToReturn.Rows(0)("cold_dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("res1") Is System.DBNull.Value Then
                        m_sRes1 = SqlString.Null
                    Else
                        m_sRes1 = New SqlString(CType(dtToReturn.Rows(0)("res1"), String))
                    End If
                    If dtToReturn.Rows(0)("res2") Is System.DBNull.Value Then
                        m_sRes2 = SqlString.Null
                    Else
                        m_sRes2 = New SqlString(CType(dtToReturn.Rows(0)("res2"), String))
                    End If
                    If dtToReturn.Rows(0)("res3") Is System.DBNull.Value Then
                        m_sRes3 = SqlString.Null
                    Else
                        m_sRes3 = New SqlString(CType(dtToReturn.Rows(0)("res3"), String))
                    End If
                    m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    If dtToReturn.Rows(0)("auslieferungnr") Is System.DBNull.Value Then
                        m_iAuslieferungnr = SqlInt32.Null
                    Else
                        m_iAuslieferungnr = New SqlInt32(CType(dtToReturn.Rows(0)("auslieferungnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLIndex::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLIndex_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBLIndexnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLIndexnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibl_status", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBl_status))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_id))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sstapelnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sStapelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dascandatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daScandatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scold_dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCold_dokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRes3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLIndex_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLIndex::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLIndex Fields

clsEDEX_BL_BLIndex overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_daScandatum
field m_iAuslieferungnr
field m_iBLIndexnr
field m_iBl_status
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_sCold_dokumentid
field m_sDokumentid
field m_sRes1
field m_sRes2
field m_sRes3
field m_sStapelnr
field m_sUser_id
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_BLIndex Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_daErstellt_am Variable

Private 		m_daScandatum, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daScandatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_daMutiert_am Variable

Private 		m_daScandatum, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daScandatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_daScandatum Variable

Private 		m_daScandatum, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daScandatum, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_iAuslieferungnr Variable

Private 		m_iBLIndexnr, _
   m_iAuslieferungnr, _
   m_iBl_status, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBLIndexnr, m_iAuslieferungnr, m_iBl_status, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_iBLIndexnr Variable

Private 		m_iBLIndexnr, _
   m_iAuslieferungnr, _
   m_iBl_status, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBLIndexnr, m_iAuslieferungnr, m_iBl_status, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_iBl_status Variable

Private 		m_iBLIndexnr, _
   m_iAuslieferungnr, _
   m_iBl_status, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBLIndexnr, m_iAuslieferungnr, m_iBl_status, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_iMutierer Variable

Private 		m_iBLIndexnr, _
   m_iAuslieferungnr, _
   m_iBl_status, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBLIndexnr, m_iAuslieferungnr, m_iBl_status, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sCold_dokumentid Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sDokumentid Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sRes1 Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sRes2 Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sRes3 Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sStapelnr Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


m_sUser_id Variable

Private 		m_sRes3, _
   m_sStapelnr, _
   m_sUser_id, _
   m_sDokumentid, _
   m_sRes2, _
   m_sRes1, _
   m_sCold_dokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sRes3, m_sStapelnr, m_sUser_id, m_sDokumentid, m_sRes2, m_sRes1, m_sCold_dokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLIndex


clsEDEX_BL_BLKunde Class

For a list of all members of this type, see clsEDEX_BL_BLKunde Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_BLKunde

Public Class clsEDEX_BL_BLKunde
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_BLKunde Members


clsEDEX_BL_BLKunde Members

clsEDEX_BL_BLKunde overview

Constructors

constructor clsEDEX_BL_BLKunde Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daBlerklaerung_vom
property daErstellt_am
property daMutiert_am
property iBlkundenr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNRAR00
property iPeriodizitaet
property sAktiv
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sPeriodische_auslieferung

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daBlerklaerung_vom
field m_daErstellt_am
field m_daMutiert_am
field m_iBlkundenr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNRAR00
field m_iPeriodizitaet
field m_sAktiv
field m_sPeriodische_auslieferung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_BLKunde Class


clsEDEX_BL_BLKunde Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde Properties

clsEDEX_BL_BLKunde overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daBlerklaerung_vom
property daErstellt_am
property daMutiert_am
property iBlkundenr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNRAR00
property iPeriodizitaet
property sAktiv
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sPeriodische_auslieferung

See Also

clsEDEX_BL_BLKunde Class


clsEDEX_BL_BLKunde.daBlerklaerung_vom Property

Public Property [daBlerklaerung_vom]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daBlerklaerung_vom]() As SqlDateTime
            Get
                Return m_daBlerklaerung_vom
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daBlerklaerung_vom = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.iBlkundenr Property

Public Property [iBlkundenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBlkundenr]() As SqlInt32
            Get
                Return m_iBlkundenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBlkundenrTmp As SqlInt32 = Value
                If iBlkundenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBlkundenr", "iBlkundenr can't be NULL")
                End If
                m_iBlkundenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMutiererTmp As SqlInt32 = Value
                If iMutiererTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMutierer", "iMutierer can't be NULL")
                End If
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.iNRAR00 Property

Public Property [iNRAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRAR00]() As SqlInt32
            Get
                Return m_iNRAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRAR00Tmp As SqlInt32 = Value
                If iNRAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRAR00", "iNRAR00 can't be NULL")
                End If
                m_iNRAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.iPeriodizitaet Property

Public Property [iPeriodizitaet]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPeriodizitaet]() As SqlInt32
            Get
                Return m_iPeriodizitaet
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPeriodizitaet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.sAktiv Property

Public Property [sAktiv]() As SqlString

Source code

[Visual Basic]
        Public Property [sAktiv]() As SqlString
            Get
                Return m_sAktiv
            End Get
            Set(ByVal Value As SqlString)
                m_sAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.sPeriodische_auslieferung Property

Public Property [sPeriodische_auslieferung]() As SqlString

Source code

[Visual Basic]
        Public Property [sPeriodische_auslieferung]() As SqlString
            Get
                Return m_sPeriodische_auslieferung
            End Get
            Set(ByVal Value As SqlString)
                m_sPeriodische_auslieferung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde Methods

clsEDEX_BL_BLKunde overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_BL_BLKunde Class


clsEDEX_BL_BLKunde.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLKunde_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblkundenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlkundenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLKunde_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLKunde::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLKunde_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblkundenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlkundenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@saktiv", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@speriodische_auslieferung", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPeriodische_auslieferung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iperiodizitaet", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dablerklaerung_vom", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daBlerklaerung_vom))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLKunde_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLKunde::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLKunde_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_BLKunde")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLKunde_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLKunde::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLKunde_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_BLKunde")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iblkundenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlkundenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLKunde_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBlkundenr = New SqlInt32(CType(dtToReturn.Rows(0)("blkundenr"), Integer))
                    m_iNRAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRAR00"), Integer))
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_sAktiv = New SqlString(CType(dtToReturn.Rows(0)("aktiv"), String))
                    m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    m_sPeriodische_auslieferung = New SqlString(CType(dtToReturn.Rows(0)("periodische_auslieferung"), String))
                    m_iPeriodizitaet = New SqlInt32(CType(dtToReturn.Rows(0)("periodizitaet"), Integer))
                    If dtToReturn.Rows(0)("blerklaerung_vom") Is System.DBNull.Value Then
                        m_daBlerklaerung_vom = SqlDateTime.Null
                    Else
                        m_daBlerklaerung_vom = New SqlDateTime(CType(dtToReturn.Rows(0)("blerklaerung_vom"), Date))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLKunde::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_BLKunde_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblkundenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlkundenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@saktiv", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@speriodische_auslieferung", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPeriodische_auslieferung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iperiodizitaet", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPeriodizitaet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dablerklaerung_vom", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daBlerklaerung_vom))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_BLKunde_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_BLKunde::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_BLKunde Fields

clsEDEX_BL_BLKunde overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daBlerklaerung_vom
field m_daErstellt_am
field m_daMutiert_am
field m_iBlkundenr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNRAR00
field m_iPeriodizitaet
field m_sAktiv
field m_sPeriodische_auslieferung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_BLKunde Class


m_daBlerklaerung_vom Variable

Private 		m_daBlerklaerung_vom, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daBlerklaerung_vom, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_daErstellt_am Variable

Private 		m_daBlerklaerung_vom, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daBlerklaerung_vom, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_daMutiert_am Variable

Private 		m_daBlerklaerung_vom, _
   m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daBlerklaerung_vom, m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_iBlkundenr Variable

Private 		m_iPeriodizitaet, _
   m_iBlkundenr, _
   m_iNRAR00, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPeriodizitaet, m_iBlkundenr, m_iNRAR00, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_iMandantnr Variable

Private 		m_iPeriodizitaet, _
   m_iBlkundenr, _
   m_iNRAR00, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPeriodizitaet, m_iBlkundenr, m_iNRAR00, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_iMutierer Variable

Private 		m_iPeriodizitaet, _
   m_iBlkundenr, _
   m_iNRAR00, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPeriodizitaet, m_iBlkundenr, m_iNRAR00, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_iNRAR00 Variable

Private 		m_iPeriodizitaet, _
   m_iBlkundenr, _
   m_iNRAR00, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPeriodizitaet, m_iBlkundenr, m_iNRAR00, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_iPeriodizitaet Variable

Private 		m_iPeriodizitaet, _
   m_iBlkundenr, _
   m_iNRAR00, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPeriodizitaet, m_iBlkundenr, m_iNRAR00, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_sAktiv Variable

Private 		m_sAktiv, _
   m_sPeriodische_auslieferung As SqlString

Source code

[Visual Basic]
        Private 		m_sAktiv, m_sPeriodische_auslieferung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


m_sPeriodische_auslieferung Variable

Private 		m_sAktiv, _
   m_sPeriodische_auslieferung As SqlString

Source code

[Visual Basic]
        Private 		m_sAktiv, m_sPeriodische_auslieferung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_BLKunde


clsEDEX_BL_Druckjob Class

For a list of all members of this type, see clsEDEX_BL_Druckjob Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_Druckjob

Public Class clsEDEX_BL_Druckjob
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_Druckjob Members


clsEDEX_BL_Druckjob Members

clsEDEX_BL_Druckjob overview

Constructors

constructor clsEDEX_BL_Druckjob Constructor

Properties

property bAktiv
property blobPdfdokument
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daAufbereitet_am
property daErstellt_am
property daGedruckt_am
property daMutiert_am
property iAnzahl_dokument
property iAuslieferungnr
property iDruckjobnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property sBemerkung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sTgnummer

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobPdfdokument
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daAufbereitet_am
field m_daErstellt_am
field m_daGedruckt_am
field m_daMutiert_am
field m_iAnzahl_dokument
field m_iAuslieferungnr
field m_iDruckjobnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_sBemerkung
field m_sTgnummer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Druckjob Class


clsEDEX_BL_Druckjob Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob Properties

clsEDEX_BL_Druckjob overview

Properties

property bAktiv
property blobPdfdokument
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daAufbereitet_am
property daErstellt_am
property daGedruckt_am
property daMutiert_am
property iAnzahl_dokument
property iAuslieferungnr
property iDruckjobnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property sBemerkung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sTgnummer

See Also

clsEDEX_BL_Druckjob Class


clsEDEX_BL_Druckjob.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.blobPdfdokument Property

Public Property [blobPdfdokument]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobPdfdokument]() As SqlBinary
            Get
                Return m_blobPdfdokument
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobPdfdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.daAufbereitet_am Property

Public Property [daAufbereitet_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daAufbereitet_am]() As SqlDateTime
            Get
                Return m_daAufbereitet_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daAufbereitet_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.daGedruckt_am Property

Public Property [daGedruckt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGedruckt_am]() As SqlDateTime
            Get
                Return m_daGedruckt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGedruckt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iAnzahl_dokument Property

Public Property [iAnzahl_dokument]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnzahl_dokument]() As SqlInt32
            Get
                Return m_iAnzahl_dokument
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnzahl_dokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iAuslieferungnr Property

Public Property [iAuslieferungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAuslieferungnr]() As SqlInt32
            Get
                Return m_iAuslieferungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuslieferungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iDruckjobnr Property

Public Property [iDruckjobnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDruckjobnr]() As SqlInt32
            Get
                Return m_iDruckjobnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDruckjobnrTmp As SqlInt32 = Value
                If iDruckjobnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDruckjobnr", "iDruckjobnr can't be NULL")
                End If
                m_iDruckjobnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.sTgnummer Property

Public Property [sTgnummer]() As SqlString

Source code

[Visual Basic]
        Public Property [sTgnummer]() As SqlString
            Get
                Return m_sTgnummer
            End Get
            Set(ByVal Value As SqlString)
                m_sTgnummer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob Methods

clsEDEX_BL_Druckjob overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_BL_Druckjob Class


clsEDEX_BL_Druckjob.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Druckjob_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idruckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDruckjobnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Druckjob_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Druckjob::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Druckjob_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idruckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDruckjobnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_dokument", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_dokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daaufbereitet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daAufbereitet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagedruckt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGedruckt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                Dim	iLength As Integer = 0
                If Not m_blobPdfdokument.IsNull Then
                    iLength = m_blobPdfdokument.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobpdfdokument", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobPdfdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Druckjob_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Druckjob::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Druckjob_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Druckjob")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Druckjob_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Druckjob::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Druckjob_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Druckjob")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idruckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDruckjobnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Druckjob_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDruckjobnr = New SqlInt32(CType(dtToReturn.Rows(0)("druckjobnr"), Integer))
                    If dtToReturn.Rows(0)("auslieferungnr") Is System.DBNull.Value Then
                        m_iAuslieferungnr = SqlInt32.Null
                    Else
                        m_iAuslieferungnr = New SqlInt32(CType(dtToReturn.Rows(0)("auslieferungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tgnummer") Is System.DBNull.Value Then
                        m_sTgnummer = SqlString.Null
                    Else
                        m_sTgnummer = New SqlString(CType(dtToReturn.Rows(0)("tgnummer"), String))
                    End If
                    If dtToReturn.Rows(0)("anzahl_dokument") Is System.DBNull.Value Then
                        m_iAnzahl_dokument = SqlInt32.Null
                    Else
                        m_iAnzahl_dokument = New SqlInt32(CType(dtToReturn.Rows(0)("anzahl_dokument"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aufbereitet_am") Is System.DBNull.Value Then
                        m_daAufbereitet_am = SqlDateTime.Null
                    Else
                        m_daAufbereitet_am = New SqlDateTime(CType(dtToReturn.Rows(0)("aufbereitet_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("gedruckt_am") Is System.DBNull.Value Then
                        m_daGedruckt_am = SqlDateTime.Null
                    Else
                        m_daGedruckt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("gedruckt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("status") Is System.DBNull.Value Then
                        m_iStatus = SqlInt32.Null
                    Else
                        m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("pdfdokument") Is System.DBNull.Value Then
                        m_blobPdfdokument = SqlBinary.Null
                    Else
                        m_blobPdfdokument = New SqlBinary(CType(dtToReturn.Rows(0)("pdfdokument"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Druckjob::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Druckjob_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idruckjobnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDruckjobnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_dokument", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_dokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daaufbereitet_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daAufbereitet_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagedruckt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGedruckt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                Dim	iLength As Integer = 0
                If Not m_blobPdfdokument.IsNull Then
                    iLength = m_blobPdfdokument.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobpdfdokument", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobPdfdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Druckjob_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Druckjob::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Druckjob Fields

clsEDEX_BL_Druckjob overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobPdfdokument
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daAufbereitet_am
field m_daErstellt_am
field m_daGedruckt_am
field m_daMutiert_am
field m_iAnzahl_dokument
field m_iAuslieferungnr
field m_iDruckjobnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_sBemerkung
field m_sTgnummer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Druckjob Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_blobPdfdokument Variable

Private 		m_blobPdfdokument As SqlBinary

Source code

[Visual Basic]
        Private 		m_blobPdfdokument As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_daAufbereitet_am Variable

Private 		m_daAufbereitet_am, _
   m_daGedruckt_am, _
   m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daAufbereitet_am, m_daGedruckt_am, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_daErstellt_am Variable

Private 		m_daAufbereitet_am, _
   m_daGedruckt_am, _
   m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daAufbereitet_am, m_daGedruckt_am, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_daGedruckt_am Variable

Private 		m_daAufbereitet_am, _
   m_daGedruckt_am, _
   m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daAufbereitet_am, m_daGedruckt_am, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_daMutiert_am Variable

Private 		m_daAufbereitet_am, _
   m_daGedruckt_am, _
   m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daAufbereitet_am, m_daGedruckt_am, m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iAnzahl_dokument Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iAuslieferungnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iDruckjobnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_iStatus Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iAuslieferungnr, _
   m_iDruckjobnr, _
   m_iAnzahl_dokument, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iAuslieferungnr, m_iDruckjobnr, m_iAnzahl_dokument, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_sBemerkung Variable

Private 		m_sBemerkung, _
   m_sTgnummer As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sTgnummer As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


m_sTgnummer Variable

Private 		m_sBemerkung, _
   m_sTgnummer As SqlString

Source code

[Visual Basic]
        Private 		m_sBemerkung, m_sTgnummer As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Druckjob


clsEDEX_BL_Hostdokument Class

For a list of all members of this type, see clsEDEX_BL_Hostdokument Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_Hostdokument

Public Class clsEDEX_BL_Hostdokument
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_Hostdokument Members


clsEDEX_BL_Hostdokument Members

clsEDEX_BL_Hostdokument overview

Constructors

constructor clsEDEX_BL_Hostdokument Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daInserttimestamp
property iAuslieferungnr
property iBl_status
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sAnzahlseiten
property sArchivdatum
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumenttypnr
property sEx
property sIsinnr
property sLoadid
property sNachvollziehbarkeit
property sPartnername_inhaber
property sPartnername_zusteller
property sPartnernr_inhaber
property sPartnernr_zusteller
property sReferenzzeile1
property sReferenzzeile2
property sRes1
property sRes2
property sRes3
property sStandamdatum
property sValorennr
property sValutadatum
property sValutadatum1
property sVvextern1
property sVvextern2

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daInserttimestamp
field m_iAuslieferungnr
field m_iBl_status
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sAnzahlseiten
field m_sArchivdatum
field m_sDokumentid
field m_sDokumenttypnr
field m_sEx
field m_sIsinnr
field m_sLoadid
field m_sNachvollziehbarkeit
field m_sPartnername_inhaber
field m_sPartnername_zusteller
field m_sPartnernr_inhaber
field m_sPartnernr_zusteller
field m_sReferenzzeile1
field m_sReferenzzeile2
field m_sRes1
field m_sRes2
field m_sRes3
field m_sStandamdatum
field m_sValorennr
field m_sValutadatum
field m_sValutadatum1
field m_sVvextern1
field m_sVvextern2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Hostdokument Class


clsEDEX_BL_Hostdokument Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument Properties

clsEDEX_BL_Hostdokument overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daInserttimestamp
property iAuslieferungnr
property iBl_status
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sAnzahlseiten
property sArchivdatum
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumenttypnr
property sEx
property sIsinnr
property sLoadid
property sNachvollziehbarkeit
property sPartnername_inhaber
property sPartnername_zusteller
property sPartnernr_inhaber
property sPartnernr_zusteller
property sReferenzzeile1
property sReferenzzeile2
property sRes1
property sRes2
property sRes3
property sStandamdatum
property sValorennr
property sValutadatum
property sValutadatum1
property sVvextern1
property sVvextern2

See Also

clsEDEX_BL_Hostdokument Class


clsEDEX_BL_Hostdokument.daInserttimestamp Property

Public Property [daInserttimestamp]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daInserttimestamp]() As SqlDateTime
            Get
                Return m_daInserttimestamp
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daInserttimestampTmp As SqlDateTime = Value
                If daInserttimestampTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daInserttimestamp", "daInserttimestamp can't be NULL")
                End If
                m_daInserttimestamp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.iAuslieferungnr Property

Public Property [iAuslieferungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAuslieferungnr]() As SqlInt32
            Get
                Return m_iAuslieferungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAuslieferungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.iBl_status Property

Public Property [iBl_status]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBl_status]() As SqlInt32
            Get
                Return m_iBl_status
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBl_statusTmp As SqlInt32 = Value
                If iBl_statusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBl_status", "iBl_status can't be NULL")
                End If
                m_iBl_status = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sAnzahlseiten Property

Public Property [sAnzahlseiten]() As SqlString

Source code

[Visual Basic]
        Public Property [sAnzahlseiten]() As SqlString
            Get
                Return m_sAnzahlseiten
            End Get
            Set(ByVal Value As SqlString)
                Dim sAnzahlseitenTmp As SqlString = Value
                If sAnzahlseitenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sAnzahlseiten", "sAnzahlseiten can't be NULL")
                End If
                m_sAnzahlseiten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sArchivdatum Property

Public Property [sArchivdatum]() As SqlString

Source code

[Visual Basic]
        Public Property [sArchivdatum]() As SqlString
            Get
                Return m_sArchivdatum
            End Get
            Set(ByVal Value As SqlString)
                Dim sArchivdatumTmp As SqlString = Value
                If sArchivdatumTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sArchivdatum", "sArchivdatum can't be NULL")
                End If
                m_sArchivdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentidTmp As SqlString = Value
                If sDokumentidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
                End If
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sDokumenttypnr Property

Public Property [sDokumenttypnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumenttypnr]() As SqlString
            Get
                Return m_sDokumenttypnr
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumenttypnrTmp As SqlString = Value
                If sDokumenttypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumenttypnr", "sDokumenttypnr can't be NULL")
                End If
                m_sDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sEx Property

Public Property [sEx]() As SqlString

Source code

[Visual Basic]
        Public Property [sEx]() As SqlString
            Get
                Return m_sEx
            End Get
            Set(ByVal Value As SqlString)
                Dim sExTmp As SqlString = Value
                If sExTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEx", "sEx can't be NULL")
                End If
                m_sEx = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sIsinnr Property

Public Property [sIsinnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sIsinnr]() As SqlString
            Get
                Return m_sIsinnr
            End Get
            Set(ByVal Value As SqlString)
                Dim sIsinnrTmp As SqlString = Value
                If sIsinnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sIsinnr", "sIsinnr can't be NULL")
                End If
                m_sIsinnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sLoadid Property

Public Property [sLoadid]() As SqlString

Source code

[Visual Basic]
        Public Property [sLoadid]() As SqlString
            Get
                Return m_sLoadid
            End Get
            Set(ByVal Value As SqlString)
                Dim sLoadidTmp As SqlString = Value
                If sLoadidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sLoadid", "sLoadid can't be NULL")
                End If
                m_sLoadid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sNachvollziehbarkeit Property

Public Property [sNachvollziehbarkeit]() As SqlString

Source code

[Visual Basic]
        Public Property [sNachvollziehbarkeit]() As SqlString
            Get
                Return m_sNachvollziehbarkeit
            End Get
            Set(ByVal Value As SqlString)
                Dim sNachvollziehbarkeitTmp As SqlString = Value
                If sNachvollziehbarkeitTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sNachvollziehbarkeit", "sNachvollziehbarkeit can't be NULL")
                End If
                m_sNachvollziehbarkeit = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sPartnername_inhaber Property

Public Property [sPartnername_inhaber]() As SqlString

Source code

[Visual Basic]
        Public Property [sPartnername_inhaber]() As SqlString
            Get
                Return m_sPartnername_inhaber
            End Get
            Set(ByVal Value As SqlString)
                Dim sPartnername_inhaberTmp As SqlString = Value
                If sPartnername_inhaberTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sPartnername_inhaber", "sPartnername_inhaber can't be NULL")
                End If
                m_sPartnername_inhaber = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sPartnername_zusteller Property

Public Property [sPartnername_zusteller]() As SqlString

Source code

[Visual Basic]
        Public Property [sPartnername_zusteller]() As SqlString
            Get
                Return m_sPartnername_zusteller
            End Get
            Set(ByVal Value As SqlString)
                Dim sPartnername_zustellerTmp As SqlString = Value
                If sPartnername_zustellerTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sPartnername_zusteller", "sPartnername_zusteller can't be NULL")
                End If
                m_sPartnername_zusteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sPartnernr_inhaber Property

Public Property [sPartnernr_inhaber]() As SqlString

Source code

[Visual Basic]
        Public Property [sPartnernr_inhaber]() As SqlString
            Get
                Return m_sPartnernr_inhaber
            End Get
            Set(ByVal Value As SqlString)
                Dim sPartnernr_inhaberTmp As SqlString = Value
                If sPartnernr_inhaberTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sPartnernr_inhaber", "sPartnernr_inhaber can't be NULL")
                End If
                m_sPartnernr_inhaber = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sPartnernr_zusteller Property

Public Property [sPartnernr_zusteller]() As SqlString

Source code

[Visual Basic]
        Public Property [sPartnernr_zusteller]() As SqlString
            Get
                Return m_sPartnernr_zusteller
            End Get
            Set(ByVal Value As SqlString)
                Dim sPartnernr_zustellerTmp As SqlString = Value
                If sPartnernr_zustellerTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sPartnernr_zusteller", "sPartnernr_zusteller can't be NULL")
                End If
                m_sPartnernr_zusteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sReferenzzeile1 Property

Public Property [sReferenzzeile1]() As SqlString

Source code

[Visual Basic]
        Public Property [sReferenzzeile1]() As SqlString
            Get
                Return m_sReferenzzeile1
            End Get
            Set(ByVal Value As SqlString)
                Dim sReferenzzeile1Tmp As SqlString = Value
                If sReferenzzeile1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sReferenzzeile1", "sReferenzzeile1 can't be NULL")
                End If
                m_sReferenzzeile1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sReferenzzeile2 Property

Public Property [sReferenzzeile2]() As SqlString

Source code

[Visual Basic]
        Public Property [sReferenzzeile2]() As SqlString
            Get
                Return m_sReferenzzeile2
            End Get
            Set(ByVal Value As SqlString)
                Dim sReferenzzeile2Tmp As SqlString = Value
                If sReferenzzeile2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sReferenzzeile2", "sReferenzzeile2 can't be NULL")
                End If
                m_sReferenzzeile2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sRes1 Property

Public Property [sRes1]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes1]() As SqlString
            Get
                Return m_sRes1
            End Get
            Set(ByVal Value As SqlString)
                Dim sRes1Tmp As SqlString = Value
                If sRes1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sRes1", "sRes1 can't be NULL")
                End If
                m_sRes1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sRes2 Property

Public Property [sRes2]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes2]() As SqlString
            Get
                Return m_sRes2
            End Get
            Set(ByVal Value As SqlString)
                Dim sRes2Tmp As SqlString = Value
                If sRes2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sRes2", "sRes2 can't be NULL")
                End If
                m_sRes2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sRes3 Property

Public Property [sRes3]() As SqlString

Source code

[Visual Basic]
        Public Property [sRes3]() As SqlString
            Get
                Return m_sRes3
            End Get
            Set(ByVal Value As SqlString)
                Dim sRes3Tmp As SqlString = Value
                If sRes3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sRes3", "sRes3 can't be NULL")
                End If
                m_sRes3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sStandamdatum Property

Public Property [sStandamdatum]() As SqlString

Source code

[Visual Basic]
        Public Property [sStandamdatum]() As SqlString
            Get
                Return m_sStandamdatum
            End Get
            Set(ByVal Value As SqlString)
                Dim sStandamdatumTmp As SqlString = Value
                If sStandamdatumTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sStandamdatum", "sStandamdatum can't be NULL")
                End If
                m_sStandamdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sValorennr Property

Public Property [sValorennr]() As SqlString

Source code

[Visual Basic]
        Public Property [sValorennr]() As SqlString
            Get
                Return m_sValorennr
            End Get
            Set(ByVal Value As SqlString)
                Dim sValorennrTmp As SqlString = Value
                If sValorennrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sValorennr", "sValorennr can't be NULL")
                End If
                m_sValorennr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sValutadatum Property

Public Property [sValutadatum]() As SqlString

Source code

[Visual Basic]
        Public Property [sValutadatum]() As SqlString
            Get
                Return m_sValutadatum
            End Get
            Set(ByVal Value As SqlString)
                Dim sValutadatumTmp As SqlString = Value
                If sValutadatumTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sValutadatum", "sValutadatum can't be NULL")
                End If
                m_sValutadatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sValutadatum1 Property

Public Property [sValutadatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sValutadatum1]() As SqlString
            Get
                Return m_sValutadatum1
            End Get
            Set(ByVal Value As SqlString)
                Dim sValutadatum1Tmp As SqlString = Value
                If sValutadatum1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sValutadatum1", "sValutadatum1 can't be NULL")
                End If
                m_sValutadatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sVvextern1 Property

Public Property [sVvextern1]() As SqlString

Source code

[Visual Basic]
        Public Property [sVvextern1]() As SqlString
            Get
                Return m_sVvextern1
            End Get
            Set(ByVal Value As SqlString)
                Dim sVvextern1Tmp As SqlString = Value
                If sVvextern1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVvextern1", "sVvextern1 can't be NULL")
                End If
                m_sVvextern1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.sVvextern2 Property

Public Property [sVvextern2]() As SqlString

Source code

[Visual Basic]
        Public Property [sVvextern2]() As SqlString
            Get
                Return m_sVvextern2
            End Get
            Set(ByVal Value As SqlString)
                Dim sVvextern2Tmp As SqlString = Value
                If sVvextern2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVvextern2", "sVvextern2 can't be NULL")
                End If
                m_sVvextern2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument Methods

clsEDEX_BL_Hostdokument overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Hostdokument Class


clsEDEX_BL_Hostdokument.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Hostdokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spartnernr_inhaber", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPartnernr_inhaber))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spartnernr_zusteller", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPartnernr_zusteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spartnername_inhaber", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPartnername_inhaber))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@spartnername_zusteller", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sPartnername_zusteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreferenzzeile1", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sReferenzzeile1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sreferenzzeile2", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sReferenzzeile2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svalutadatum", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sValutadatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svalutadatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sValutadatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svalorennr", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sValorennr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sisinnr", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sIsinnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanzahlseiten", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sAnzahlseiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snachvollziehbarkeit", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sNachvollziehbarkeit))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sarchivdatum", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sArchivdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svvextern1", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVvextern1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svvextern2", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVvextern2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sex", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEx))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sstandamdatum", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sStandamdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumenttypnr", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloadid", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sLoadid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dainserttimestamp", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daInserttimestamp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibl_status", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBl_status))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres1", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sRes1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres2", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sRes2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sres3", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sRes3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iauslieferungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAuslieferungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Hostdokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Hostdokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Hostdokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Hostdokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Hostdokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Hostdokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Hostdokument Fields

clsEDEX_BL_Hostdokument overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daInserttimestamp
field m_iAuslieferungnr
field m_iBl_status
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sAnzahlseiten
field m_sArchivdatum
field m_sDokumentid
field m_sDokumenttypnr
field m_sEx
field m_sIsinnr
field m_sLoadid
field m_sNachvollziehbarkeit
field m_sPartnername_inhaber
field m_sPartnername_zusteller
field m_sPartnernr_inhaber
field m_sPartnernr_zusteller
field m_sReferenzzeile1
field m_sReferenzzeile2
field m_sRes1
field m_sRes2
field m_sRes3
field m_sStandamdatum
field m_sValorennr
field m_sValutadatum
field m_sValutadatum1
field m_sVvextern1
field m_sVvextern2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Hostdokument Class


m_daInserttimestamp Variable

Private 		m_daInserttimestamp As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daInserttimestamp As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_iAuslieferungnr Variable

Private 		m_iBl_status, _
   m_iAuslieferungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBl_status, m_iAuslieferungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_iBl_status Variable

Private 		m_iBl_status, _
   m_iAuslieferungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBl_status, m_iAuslieferungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sAnzahlseiten Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sArchivdatum Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sDokumentid Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sDokumenttypnr Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sEx Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sIsinnr Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sLoadid Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sNachvollziehbarkeit Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sPartnername_inhaber Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sPartnername_zusteller Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sPartnernr_inhaber Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sPartnernr_zusteller Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sReferenzzeile1 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sReferenzzeile2 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sRes1 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sRes2 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sRes3 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sStandamdatum Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sValorennr Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sValutadatum Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sValutadatum1 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sVvextern1 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


m_sVvextern2 Variable

Private 		m_sStandamdatum, _
   m_sEx, _
   m_sArchivdatum, _
   m_sVvextern1, _
   m_sVvextern2, _
   m_sRes2, _
   m_sRes3, _
   m_sRes1, _
   m_sDokumenttypnr, _
   m_sLoadid, _
   m_sPartnername_zusteller, _
   m_sReferenzzeile1, _
   m_sReferenzzeile2, _
   m_sPartnernr_inhaber, _
   m_sPartnernr_zusteller, _
   m_sPartnername_inhaber, _
   m_sValutadatum, _
   m_sDokumentid, _
   m_sAnzahlseiten, _
   m_sNachvollziehbarkeit, _
   m_sValutadatum1, _
   m_sValorennr, _
   m_sIsinnr As SqlString

Source code

[Visual Basic]
        Private 		m_sStandamdatum, m_sEx, m_sArchivdatum, m_sVvextern1, m_sVvextern2, m_sRes2, m_sRes3, m_sRes1, m_sDokumenttypnr, m_sLoadid, m_sPartnername_zusteller, m_sReferenzzeile1, m_sReferenzzeile2, m_sPartnernr_inhaber, m_sPartnernr_zusteller, m_sPartnername_inhaber, m_sValutadatum, m_sDokumentid, m_sAnzahlseiten, m_sNachvollziehbarkeit, m_sValutadatum1, m_sValorennr, m_sIsinnr As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Hostdokument


clsEDEX_BL_Status Class

For a list of all members of this type, see clsEDEX_BL_Status Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_BL_Status

Public Class clsEDEX_BL_Status
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_BL_Status Members


clsEDEX_BL_Status Members

clsEDEX_BL_Status overview

Constructors

constructor clsEDEX_BL_Status Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_ma
property iBLStatusnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_ma
field m_iBLStatusnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Status Class


clsEDEX_BL_Status Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status Properties

clsEDEX_BL_Status overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_ma
property iBLStatusnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Status Class


clsEDEX_BL_Status.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.daMutiert_ma Property

Public Property [daMutiert_ma]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_ma]() As SqlDateTime
            Get
                Return m_daMutiert_ma
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_ma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.iBLStatusnr Property

Public Property [iBLStatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBLStatusnr]() As SqlInt32
            Get
                Return m_iBLStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBLStatusnrTmp As SqlInt32 = Value
                If iBLStatusnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBLStatusnr", "iBLStatusnr can't be NULL")
                End If
                m_iBLStatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status Methods

clsEDEX_BL_Status overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_BL_Status Class


clsEDEX_BL_Status.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Status_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBLStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLStatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Status_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Status::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Status_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBLStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_ma", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_ma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Status_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Status::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Status_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Status_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Status::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Status_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_BL_Status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iBLStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLStatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Status_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBLStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("BLStatusnr"), Integer))
                    If dtToReturn.Rows(0)("Bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("Bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_ma") Is System.DBNull.Value Then
                        m_daMutiert_ma = SqlDateTime.Null
                    Else
                        m_daMutiert_ma = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_ma"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Status::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_EDEX_BL_Status_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBLStatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBLStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_ma", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_ma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_EDEX_BL_Status_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_BL_Status::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_BL_Status Fields

clsEDEX_BL_Status overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_ma
field m_iBLStatusnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_BL_Status Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_ma As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_ma As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_daMutiert_ma Variable

Private 		m_daErstellt_am, _
   m_daMutiert_ma As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_ma As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_iBLStatusnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBLStatusnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBLStatusnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBLStatusnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBLStatusnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBLStatusnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBLStatusnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


m_sBezeichnung Variable

Private 		m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_BL_Status


clsEDEX_Favoriten Class

For a list of all members of this type, see clsEDEX_Favoriten Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEDEX_Favoriten

Public Class clsEDEX_Favoriten
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEDEX_Favoriten Members


clsEDEX_Favoriten Members

clsEDEX_Favoriten overview

Constructors

constructor clsEDEX_Favoriten Constructor

Properties

property bAktiv
property bDp
property bStddp
property bStrukturelement
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDtnr_dpnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iNreintrag
property iParentid
property iSort
property iSprache
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bDp
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bStddp
field m_bStrukturelement
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDtnr_dpnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iNreintrag
field m_iParentid
field m_iSort
field m_iSprache
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_Favoriten Class


clsEDEX_Favoriten Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten Properties

clsEDEX_Favoriten overview

Properties

property bAktiv
property bDp
property bStddp
property bStrukturelement
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDtnr_dpnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iImageindexopen
property iMandantnr
property iMitarbeiternr
property iMutierer
property iNreintrag
property iParentid
property iSort
property iSprache
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_Favoriten Class


clsEDEX_Favoriten.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.bDp Property

Public Property [bDp]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDp]() As SqlBoolean
            Get
                Return m_bDp
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.bStddp Property

Public Property [bStddp]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bStddp]() As SqlBoolean
            Get
                Return m_bStddp
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bStddp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.bStrukturelement Property

Public Property [bStrukturelement]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bStrukturelement]() As SqlBoolean
            Get
                Return m_bStrukturelement
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bStrukturelement = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iDtnr_dpnr Property

Public Property [iDtnr_dpnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDtnr_dpnr]() As SqlInt32
            Get
                Return m_iDtnr_dpnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDtnr_dpnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iImageindex Property

Public Property [iImageindex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindex]() As SqlInt32
            Get
                Return m_iImageindex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iImageindexopen Property

Public Property [iImageindexopen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindexopen]() As SqlInt32
            Get
                Return m_iImageindexopen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindexopen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iNreintrag Property

Public Property [iNreintrag]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNreintrag]() As SqlInt32
            Get
                Return m_iNreintrag
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNreintragTmp As SqlInt32 = Value
                If iNreintragTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNreintrag", "iNreintrag can't be NULL")
                End If
                m_iNreintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iParentid Property

Public Property [iParentid]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParentid]() As SqlInt32
            Get
                Return m_iParentid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten Methods

clsEDEX_Favoriten overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEDEX_Favoriten Class


clsEDEX_Favoriten.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_EDEX_Favoriten_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_EDEX_Favoriten_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_Favoriten::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_EDEX_Favoriten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idtnr_dpnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDtnr_dpnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstddp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bStddp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstrukturelement", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bStrukturelement))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iNreintrag = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@inreintrag").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_EDEX_Favoriten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_Favoriten::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_EDEX_Favoriten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_Favoriten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_EDEX_Favoriten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_Favoriten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_EDEX_Favoriten_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("EDEX_Favoriten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_EDEX_Favoriten_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNreintrag = New SqlInt32(CType(dtToReturn.Rows(0)("nreintrag"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("parentid") Is System.DBNull.Value Then
                        m_iParentid = SqlInt32.Null
                    Else
                        m_iParentid = New SqlInt32(CType(dtToReturn.Rows(0)("parentid"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindex") Is System.DBNull.Value Then
                        m_iImageindex = SqlInt32.Null
                    Else
                        m_iImageindex = New SqlInt32(CType(dtToReturn.Rows(0)("imageindex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindexopen") Is System.DBNull.Value Then
                        m_iImageindexopen = SqlInt32.Null
                    Else
                        m_iImageindexopen = New SqlInt32(CType(dtToReturn.Rows(0)("imageindexopen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dtnr_dpnr") Is System.DBNull.Value Then
                        m_iDtnr_dpnr = SqlInt32.Null
                    Else
                        m_iDtnr_dpnr = New SqlInt32(CType(dtToReturn.Rows(0)("dtnr_dpnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dp") Is System.DBNull.Value Then
                        m_bDp = SqlBoolean.Null
                    Else
                        m_bDp = New SqlBoolean(CType(dtToReturn.Rows(0)("dp"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("stddp") Is System.DBNull.Value Then
                        m_bStddp = SqlBoolean.Null
                    Else
                        m_bStddp = New SqlBoolean(CType(dtToReturn.Rows(0)("stddp"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("strukturelement") Is System.DBNull.Value Then
                        m_bStrukturelement = SqlBoolean.Null
                    Else
                        m_bStrukturelement = New SqlBoolean(CType(dtToReturn.Rows(0)("strukturelement"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_Favoriten::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_EDEX_Favoriten_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iparentid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindexopen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindexopen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idtnr_dpnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDtnr_dpnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstddp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bStddp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstrukturelement", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bStrukturelement))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_EDEX_Favoriten_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEDEX_Favoriten::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEDEX_Favoriten Fields

clsEDEX_Favoriten overview

Fields

field m_bAktiv
field m_bDp
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bStddp
field m_bStrukturelement
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDtnr_dpnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iImageindexopen
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iNreintrag
field m_iParentid
field m_iSort
field m_iSprache
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEDEX_Favoriten Class


m_bAktiv Variable

Private 		m_bStddp, _
   m_bDp, _
   m_bStrukturelement, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bStddp, m_bDp, m_bStrukturelement, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_bDp Variable

Private 		m_bStddp, _
   m_bDp, _
   m_bStrukturelement, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bStddp, m_bDp, m_bStrukturelement, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_bStddp Variable

Private 		m_bStddp, _
   m_bDp, _
   m_bStrukturelement, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bStddp, m_bDp, m_bStrukturelement, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_bStrukturelement Variable

Private 		m_bStddp, _
   m_bDp, _
   m_bStrukturelement, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bStddp, m_bDp, m_bStrukturelement, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iDtnr_dpnr Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iImageindex Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iImageindexopen Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iMandantnr Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iMitarbeiternr Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iMutierer Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iNreintrag Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iParentid Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iSort Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_iSprache Variable

Private 		m_iNreintrag, _
   m_iMandantnr, _
   m_iSprache, _
   m_iMutierer, _
   m_iDtnr_dpnr, _
   m_iImageindexopen, _
   m_iImageindex, _
   m_iMitarbeiternr, _
   m_iParentid, _
   m_iSort As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag, m_iMandantnr, m_iSprache, m_iMutierer, m_iDtnr_dpnr, m_iImageindexopen, m_iImageindex, m_iMitarbeiternr, m_iParentid, m_iSort As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


m_sBezeichnung Variable

Private 		m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEDEX_Favoriten


clsEdex_bl_parameter Class

For a list of all members of this type, see clsEdex_bl_parameter Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_bl_parameter

Public Class clsEdex_bl_parameter
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_bl_parameter Members


clsEdex_bl_parameter Members

clsEdex_bl_parameter overview

Constructors

constructor clsEdex_bl_parameter Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBlvdokumenttypnr
property iBlvfunktion
property iBlvparamnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sTxtArt1
property sTxtArt2
property sTxtForm1
property sTxtForm2
property sTxtGrundlage1
property sTxtGrundlage2
property sTxtGrundlage3
property sTxtGrundlage4
property sTxtQuittung1
property sTxtQuittung2
property sTxtbeilage1
property sTxtbeilage2

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBlvdokumenttypnr
field m_iBlvfunktion
field m_iBlvparamnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sTxtArt1
field m_sTxtArt2
field m_sTxtForm1
field m_sTxtForm2
field m_sTxtGrundlage1
field m_sTxtGrundlage2
field m_sTxtGrundlage3
field m_sTxtGrundlage4
field m_sTxtQuittung1
field m_sTxtQuittung2
field m_sTxtbeilage1
field m_sTxtbeilage2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_bl_parameter Class


clsEdex_bl_parameter Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter Properties

clsEdex_bl_parameter overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBlvdokumenttypnr
property iBlvfunktion
property iBlvparamnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sTxtArt1
property sTxtArt2
property sTxtForm1
property sTxtForm2
property sTxtGrundlage1
property sTxtGrundlage2
property sTxtGrundlage3
property sTxtGrundlage4
property sTxtQuittung1
property sTxtQuittung2
property sTxtbeilage1
property sTxtbeilage2

See Also

clsEdex_bl_parameter Class


clsEdex_bl_parameter.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.iBlvdokumenttypnr Property

Public Property [iBlvdokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBlvdokumenttypnr]() As SqlInt32
            Get
                Return m_iBlvdokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBlvdokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.iBlvfunktion Property

Public Property [iBlvfunktion]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBlvfunktion]() As SqlInt32
            Get
                Return m_iBlvfunktion
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBlvfunktion = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.iBlvparamnr Property

Public Property [iBlvparamnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBlvparamnr]() As SqlInt32
            Get
                Return m_iBlvparamnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBlvparamnrTmp As SqlInt32 = Value
                If iBlvparamnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBlvparamnr", "iBlvparamnr can't be NULL")
                End If
                m_iBlvparamnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtArt1 Property

Public Property [sTxtArt1]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtArt1]() As SqlString
            Get
                Return m_sTxtArt1
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtArt1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtArt2 Property

Public Property [sTxtArt2]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtArt2]() As SqlString
            Get
                Return m_sTxtArt2
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtArt2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtForm1 Property

Public Property [sTxtForm1]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtForm1]() As SqlString
            Get
                Return m_sTxtForm1
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtForm1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtForm2 Property

Public Property [sTxtForm2]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtForm2]() As SqlString
            Get
                Return m_sTxtForm2
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtForm2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtGrundlage1 Property

Public Property [sTxtGrundlage1]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtGrundlage1]() As SqlString
            Get
                Return m_sTxtGrundlage1
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtGrundlage1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtGrundlage2 Property

Public Property [sTxtGrundlage2]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtGrundlage2]() As SqlString
            Get
                Return m_sTxtGrundlage2
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtGrundlage2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtGrundlage3 Property

Public Property [sTxtGrundlage3]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtGrundlage3]() As SqlString
            Get
                Return m_sTxtGrundlage3
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtGrundlage3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtGrundlage4 Property

Public Property [sTxtGrundlage4]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtGrundlage4]() As SqlString
            Get
                Return m_sTxtGrundlage4
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtGrundlage4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtQuittung1 Property

Public Property [sTxtQuittung1]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtQuittung1]() As SqlString
            Get
                Return m_sTxtQuittung1
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtQuittung1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtQuittung2 Property

Public Property [sTxtQuittung2]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtQuittung2]() As SqlString
            Get
                Return m_sTxtQuittung2
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtQuittung2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtbeilage1 Property

Public Property [sTxtbeilage1]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtbeilage1]() As SqlString
            Get
                Return m_sTxtbeilage1
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtbeilage1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.sTxtbeilage2 Property

Public Property [sTxtbeilage2]() As SqlString

Source code

[Visual Basic]
        Public Property [sTxtbeilage2]() As SqlString
            Get
                Return m_sTxtbeilage2
            End Get
            Set(ByVal Value As SqlString)
                m_sTxtbeilage2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter Methods

clsEdex_bl_parameter overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_bl_parameter Class


clsEdex_bl_parameter.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_edex_bl_parameter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvparamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlvparamnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_edex_bl_parameter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_bl_parameter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_edex_bl_parameter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvfunktion", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlvfunktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvdokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlvdokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage4", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtArt1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtArt1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtArt2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtArt2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtForm1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtForm1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtForm2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtForm2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtbeilage1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtbeilage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtbeilage2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtbeilage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtQuittung1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtQuittung1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtQuittung2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtQuittung2))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iblvparamnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iBlvparamnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iBlvparamnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iblvparamnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_edex_bl_parameter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_bl_parameter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_edex_bl_parameter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_bl_parameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_edex_bl_parameter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_bl_parameter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_edex_bl_parameter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_bl_parameter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iblvparamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlvparamnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_edex_bl_parameter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iBlvparamnr = New SqlInt32(CType(dtToReturn.Rows(0)("blvparamnr"), Integer))
                    If dtToReturn.Rows(0)("blvfunktion") Is System.DBNull.Value Then
                        m_iBlvfunktion = SqlInt32.Null
                    Else
                        m_iBlvfunktion = New SqlInt32(CType(dtToReturn.Rows(0)("blvfunktion"), Integer))
                    End If
                    If dtToReturn.Rows(0)("blvdokumenttypnr") Is System.DBNull.Value Then
                        m_iBlvdokumenttypnr = SqlInt32.Null
                    Else
                        m_iBlvdokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("blvdokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("txtGrundlage1") Is System.DBNull.Value Then
                        m_sTxtGrundlage1 = SqlString.Null
                    Else
                        m_sTxtGrundlage1 = New SqlString(CType(dtToReturn.Rows(0)("txtGrundlage1"), String))
                    End If
                    If dtToReturn.Rows(0)("txtGrundlage2") Is System.DBNull.Value Then
                        m_sTxtGrundlage2 = SqlString.Null
                    Else
                        m_sTxtGrundlage2 = New SqlString(CType(dtToReturn.Rows(0)("txtGrundlage2"), String))
                    End If
                    If dtToReturn.Rows(0)("txtGrundlage3") Is System.DBNull.Value Then
                        m_sTxtGrundlage3 = SqlString.Null
                    Else
                        m_sTxtGrundlage3 = New SqlString(CType(dtToReturn.Rows(0)("txtGrundlage3"), String))
                    End If
                    If dtToReturn.Rows(0)("txtGrundlage4") Is System.DBNull.Value Then
                        m_sTxtGrundlage4 = SqlString.Null
                    Else
                        m_sTxtGrundlage4 = New SqlString(CType(dtToReturn.Rows(0)("txtGrundlage4"), String))
                    End If
                    If dtToReturn.Rows(0)("txtArt1") Is System.DBNull.Value Then
                        m_sTxtArt1 = SqlString.Null
                    Else
                        m_sTxtArt1 = New SqlString(CType(dtToReturn.Rows(0)("txtArt1"), String))
                    End If
                    If dtToReturn.Rows(0)("txtArt2") Is System.DBNull.Value Then
                        m_sTxtArt2 = SqlString.Null
                    Else
                        m_sTxtArt2 = New SqlString(CType(dtToReturn.Rows(0)("txtArt2"), String))
                    End If
                    If dtToReturn.Rows(0)("txtForm1") Is System.DBNull.Value Then
                        m_sTxtForm1 = SqlString.Null
                    Else
                        m_sTxtForm1 = New SqlString(CType(dtToReturn.Rows(0)("txtForm1"), String))
                    End If
                    If dtToReturn.Rows(0)("txtForm2") Is System.DBNull.Value Then
                        m_sTxtForm2 = SqlString.Null
                    Else
                        m_sTxtForm2 = New SqlString(CType(dtToReturn.Rows(0)("txtForm2"), String))
                    End If
                    If dtToReturn.Rows(0)("txtbeilage1") Is System.DBNull.Value Then
                        m_sTxtbeilage1 = SqlString.Null
                    Else
                        m_sTxtbeilage1 = New SqlString(CType(dtToReturn.Rows(0)("txtbeilage1"), String))
                    End If
                    If dtToReturn.Rows(0)("txtbeilage2") Is System.DBNull.Value Then
                        m_sTxtbeilage2 = SqlString.Null
                    Else
                        m_sTxtbeilage2 = New SqlString(CType(dtToReturn.Rows(0)("txtbeilage2"), String))
                    End If
                    If dtToReturn.Rows(0)("txtQuittung1") Is System.DBNull.Value Then
                        m_sTxtQuittung1 = SqlString.Null
                    Else
                        m_sTxtQuittung1 = New SqlString(CType(dtToReturn.Rows(0)("txtQuittung1"), String))
                    End If
                    If dtToReturn.Rows(0)("txtQuittung2") Is System.DBNull.Value Then
                        m_sTxtQuittung2 = SqlString.Null
                    Else
                        m_sTxtQuittung2 = New SqlString(CType(dtToReturn.Rows(0)("txtQuittung2"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_bl_parameter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_bl_edex_bl_parameter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvparamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBlvparamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvfunktion", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlvfunktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iblvdokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBlvdokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtGrundlage4", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtGrundlage4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtArt1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtArt1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtArt2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtArt2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtForm1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtForm1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtForm2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtForm2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtbeilage1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtbeilage1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtbeilage2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtbeilage2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtQuittung1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtQuittung1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stxtQuittung2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTxtQuittung2))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_bl_edex_bl_parameter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_bl_parameter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_bl_parameter Fields

clsEdex_bl_parameter overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBlvdokumenttypnr
field m_iBlvfunktion
field m_iBlvparamnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sTxtArt1
field m_sTxtArt2
field m_sTxtForm1
field m_sTxtForm2
field m_sTxtGrundlage1
field m_sTxtGrundlage2
field m_sTxtGrundlage3
field m_sTxtGrundlage4
field m_sTxtQuittung1
field m_sTxtQuittung2
field m_sTxtbeilage1
field m_sTxtbeilage2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_bl_parameter Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_iBlvdokumenttypnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iBlvparamnr, _
   m_iBlvfunktion, _
   m_iBlvdokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iBlvparamnr, m_iBlvfunktion, m_iBlvdokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_iBlvfunktion Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iBlvparamnr, _
   m_iBlvfunktion, _
   m_iBlvdokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iBlvparamnr, m_iBlvfunktion, m_iBlvdokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_iBlvparamnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iBlvparamnr, _
   m_iBlvfunktion, _
   m_iBlvdokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iBlvparamnr, m_iBlvfunktion, m_iBlvdokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iBlvparamnr, _
   m_iBlvfunktion, _
   m_iBlvdokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iBlvparamnr, m_iBlvfunktion, m_iBlvdokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iBlvparamnr, _
   m_iBlvfunktion, _
   m_iBlvdokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iBlvparamnr, m_iBlvfunktion, m_iBlvdokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtArt1 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtArt2 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtForm1 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtForm2 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtGrundlage1 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtGrundlage2 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtGrundlage3 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtGrundlage4 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtQuittung1 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtQuittung2 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtbeilage1 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


m_sTxtbeilage2 Variable

Private 		m_sTxtbeilage1, _
   m_sTxtForm2, _
   m_sTxtForm1, _
   m_sTxtQuittung2, _
   m_sTxtQuittung1, _
   m_sTxtbeilage2, _
   m_sTxtGrundlage3, _
   m_sTxtGrundlage2, _
   m_sTxtGrundlage1, _
   m_sTxtArt2, _
   m_sTxtArt1, _
   m_sTxtGrundlage4 As SqlString

Source code

[Visual Basic]
        Private 		m_sTxtbeilage1, m_sTxtForm2, m_sTxtForm1, m_sTxtQuittung2, m_sTxtQuittung1, m_sTxtbeilage2, m_sTxtGrundlage3, m_sTxtGrundlage2, m_sTxtGrundlage1, m_sTxtArt2, m_sTxtArt1, m_sTxtGrundlage4 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_bl_parameter


clsEdex_dokumentpaket Class

For a list of all members of this type, see clsEdex_dokumentpaket Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_dokumentpaket

Public Class clsEdex_dokumentpaket
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_dokumentpaket Members


clsEdex_dokumentpaket Members

clsEdex_dokumentpaket overview

Constructors

constructor clsEdex_dokumentpaket Constructor

Properties

property bAktiv
property bIndividuelles_dp
property blobDpbeschreibung
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iDokumentpaketnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iOwner
property iSort
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sWichtigehinweise

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bIndividuelles_dp
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobDpbeschreibung
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iDokumentpaketnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iOwner
field m_iSort
field m_sBeschreibung
field m_sBezeichnung
field m_sWichtigehinweise
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dokumentpaket Class


clsEdex_dokumentpaket Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket Properties

clsEdex_dokumentpaket overview

Properties

property bAktiv
property bIndividuelles_dp
property blobDpbeschreibung
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iDokumentpaketnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iOwner
property iSort
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sWichtigehinweise

See Also

clsEdex_dokumentpaket Class


clsEdex_dokumentpaket.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.bIndividuelles_dp Property

Public Property [bIndividuelles_dp]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bIndividuelles_dp]() As SqlBoolean
            Get
                Return m_bIndividuelles_dp
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bIndividuelles_dp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.blobDpbeschreibung Property

Public Property [blobDpbeschreibung]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobDpbeschreibung]() As SqlBinary
            Get
                Return m_blobDpbeschreibung
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobDpbeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iDokumentartnr Property

Public Property [iDokumentartnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentartnr]() As SqlInt32
            Get
                Return m_iDokumentartnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentartnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iDokumentpaketnr Property

Public Property [iDokumentpaketnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentpaketnr]() As SqlInt32
            Get
                Return m_iDokumentpaketnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentpaketnrTmp As SqlInt32 = Value
                If iDokumentpaketnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentpaketnr", "iDokumentpaketnr can't be NULL")
                End If
                m_iDokumentpaketnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iOwner Property

Public Property [iOwner]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOwner]() As SqlInt32
            Get
                Return m_iOwner
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOwner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.sWichtigehinweise Property

Public Property [sWichtigehinweise]() As SqlString

Source code

[Visual Basic]
        Public Property [sWichtigehinweise]() As SqlString
            Get
                Return m_sWichtigehinweise
            End Get
            Set(ByVal Value As SqlString)
                m_sWichtigehinweise = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket Methods

clsEdex_dokumentpaket overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_dokumentpaket Class


clsEdex_dokumentpaket.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaket_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaket_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaket::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaket_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bindividuelles_dp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIndividuelles_dp))
                Dim	iLength As Integer = 0
                If Not m_blobDpbeschreibung.IsNull Then
                    iLength = m_blobDpbeschreibung.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobdpbeschreibung", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDpbeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swichtigehinweise", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWichtigehinweise))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaket_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaket::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaket_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dokumentpaket")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaket_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaket::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaket_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dokumentpaket")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaket_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentpaketnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentpaketnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("owner") Is System.DBNull.Value Then
                        m_iOwner = SqlInt32.Null
                    Else
                        m_iOwner = New SqlInt32(CType(dtToReturn.Rows(0)("owner"), Integer))
                    End If
                    If dtToReturn.Rows(0)("individuelles_dp") Is System.DBNull.Value Then
                        m_bIndividuelles_dp = SqlBoolean.Null
                    Else
                        m_bIndividuelles_dp = New SqlBoolean(CType(dtToReturn.Rows(0)("individuelles_dp"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dpbeschreibung") Is System.DBNull.Value Then
                        m_blobDpbeschreibung = SqlBinary.Null
                    Else
                        m_blobDpbeschreibung = New SqlBinary(CType(dtToReturn.Rows(0)("dpbeschreibung"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("dokumentartnr") Is System.DBNull.Value Then
                        m_iDokumentartnr = SqlInt32.Null
                    Else
                        m_iDokumentartnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentartnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("wichtigehinweise") Is System.DBNull.Value Then
                        m_sWichtigehinweise = SqlString.Null
                    Else
                        m_sWichtigehinweise = New SqlString(CType(dtToReturn.Rows(0)("wichtigehinweise"), String))
                    End If
                    If dtToReturn.Rows(0)("sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("sort"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaket::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaket_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bindividuelles_dp", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIndividuelles_dp))
                Dim	iLength As Integer = 0
                If Not m_blobDpbeschreibung.IsNull Then
                    iLength = m_blobDpbeschreibung.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobdpbeschreibung", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobDpbeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swichtigehinweise", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWichtigehinweise))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaket_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaket::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaket Fields

clsEdex_dokumentpaket overview

Fields

field m_bAktiv
field m_bIndividuelles_dp
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobDpbeschreibung
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iDokumentpaketnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iOwner
field m_iSort
field m_sBeschreibung
field m_sBezeichnung
field m_sWichtigehinweise
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dokumentpaket Class


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bIndividuelles_dp As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bIndividuelles_dp As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_bIndividuelles_dp Variable

Private 		m_bAktiv, _
   m_bIndividuelles_dp As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bIndividuelles_dp As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_blobDpbeschreibung Variable

Private 		m_blobDpbeschreibung As SqlBinary

Source code

[Visual Basic]
        Private 		m_blobDpbeschreibung As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iDokumentartnr Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iDokumentpaketnr Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iMandantnr Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iMutierer Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iOwner Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_iSort Variable

Private 		m_iSort, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iDokumentpaketnr, _
   m_iOwner, _
   m_iDokumentartnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iSort, m_iMutierer, m_iMandantnr, m_iDokumentpaketnr, m_iOwner, m_iDokumentartnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_sBeschreibung Variable

Private 		m_sWichtigehinweise, _
   m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sWichtigehinweise, m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_sBezeichnung Variable

Private 		m_sWichtigehinweise, _
   m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sWichtigehinweise, m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


m_sWichtigehinweise Variable

Private 		m_sWichtigehinweise, _
   m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sWichtigehinweise, m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaket


clsEdex_dokumentpaketvorlage Class

For a list of all members of this type, see clsEdex_dokumentpaketvorlage Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_dokumentpaketvorlage

Public Class clsEdex_dokumentpaketvorlage
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_dokumentpaketvorlage Members


clsEdex_dokumentpaketvorlage Members

clsEdex_dokumentpaketvorlage overview

Constructors

constructor clsEdex_dokumentpaketvorlage Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentpaketnr
property iDokumentpaketvorlagenr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iMandantnr
property iSort
property iZwingend
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentpaketnr
field m_iDokumentpaketvorlagenr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iMandantnr
field m_iSort
field m_iZwingend
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dokumentpaketvorlage Class


clsEdex_dokumentpaketvorlage Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage Properties

clsEdex_dokumentpaketvorlage overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentpaketnr
property iDokumentpaketvorlagenr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex
property iMandantnr
property iSort
property iZwingend
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dokumentpaketvorlage Class


clsEdex_dokumentpaketvorlage.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iDokumentpaketnr Property

Public Property [iDokumentpaketnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentpaketnr]() As SqlInt32
            Get
                Return m_iDokumentpaketnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentpaketnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iDokumentpaketvorlagenr Property

Public Property [iDokumentpaketvorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentpaketvorlagenr]() As SqlInt32
            Get
                Return m_iDokumentpaketvorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentpaketvorlagenrTmp As SqlInt32 = Value
                If iDokumentpaketvorlagenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentpaketvorlagenr", "iDokumentpaketvorlagenr can't be NULL")
                End If
                m_iDokumentpaketvorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iImageindex Property

Public Property [iImageindex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageindex]() As SqlInt32
            Get
                Return m_iImageindex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageindex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.iZwingend Property

Public Property [iZwingend]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZwingend]() As SqlInt32
            Get
                Return m_iZwingend
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZwingend = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage Methods

clsEdex_dokumentpaketvorlage overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_dokumentpaketvorlage Class


clsEdex_dokumentpaketvorlage.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaketvorlage_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketvorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketvorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaketvorlage_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaketvorlage::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaketvorlage_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izwingend", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentpaketvorlagenr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketvorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iDokumentpaketvorlagenr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@idokumentpaketvorlagenr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaketvorlage_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaketvorlage::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaketvorlage_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dokumentpaketvorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaketvorlage_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaketvorlage::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaketvorlage_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dokumentpaketvorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentpaketvorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketvorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaketvorlage_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentpaketvorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentpaketvorlagenr"), Integer))
                    If dtToReturn.Rows(0)("dokumentpaketnr") Is System.DBNull.Value Then
                        m_iDokumentpaketnr = SqlInt32.Null
                    Else
                        m_iDokumentpaketnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentpaketnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zwingend") Is System.DBNull.Value Then
                        m_iZwingend = SqlInt32.Null
                    Else
                        m_iZwingend = New SqlInt32(CType(dtToReturn.Rows(0)("zwingend"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("imageindex") Is System.DBNull.Value Then
                        m_iImageindex = SqlInt32.Null
                    Else
                        m_iImageindex = New SqlInt32(CType(dtToReturn.Rows(0)("imageindex"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaketvorlage::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dokumentpaketvorlage_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketvorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketvorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izwingend", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iimageindex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageindex))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dokumentpaketvorlage_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dokumentpaketvorlage::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dokumentpaketvorlage Fields

clsEdex_dokumentpaketvorlage overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentpaketnr
field m_iDokumentpaketvorlagenr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iImageindex
field m_iMandantnr
field m_iSort
field m_iZwingend
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dokumentpaketvorlage Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iDokumentpaketnr Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iDokumentpaketvorlagenr Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iDokumenttypnr Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iImageindex Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iMandantnr Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iSort Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


m_iZwingend Variable

Private 		m_iDokumentpaketvorlagenr, _
   m_iSort, _
   m_iImageindex, _
   m_iMandantnr, _
   m_iZwingend, _
   m_iDokumenttypnr, _
   m_iDokumentpaketnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketvorlagenr, m_iSort, m_iImageindex, m_iMandantnr, m_iZwingend, m_iDokumenttypnr, m_iDokumentpaketnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dokumentpaketvorlage


clsEdex_dpinstanz Class

For a list of all members of this type, see clsEdex_dpinstanz Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_dpinstanz

Public Class clsEdex_dpinstanz
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_dpinstanz Members


clsEdex_dpinstanz Members

clsEdex_dpinstanz overview

Constructors

constructor clsEdex_dpinstanz Constructor

Properties

property bIndividuellesDP
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property iDokumentpaketnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMitarbeiternr
property iNreintrag
property iNrpar00
property iProfilnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentpaketnummern
property sHacken

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bIndividuellesDP
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_iDokumentpaketnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMitarbeiternr
field m_iNreintrag
field m_iNrpar00
field m_iProfilnr
field m_sDokumentpaketnummern
field m_sHacken
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dpinstanz Class


clsEdex_dpinstanz Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz Properties

clsEdex_dpinstanz overview

Properties

property bIndividuellesDP
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property iDokumentpaketnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMitarbeiternr
property iNreintrag
property iNrpar00
property iProfilnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentpaketnummern
property sHacken

See Also

clsEdex_dpinstanz Class


clsEdex_dpinstanz.bIndividuellesDP Property

Public Property [bIndividuellesDP]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bIndividuellesDP]() As SqlBoolean
            Get
                Return m_bIndividuellesDP
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bIndividuellesDP = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.iDokumentpaketnr Property

Public Property [iDokumentpaketnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentpaketnr]() As SqlInt32
            Get
                Return m_iDokumentpaketnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentpaketnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.iNreintrag Property

Public Property [iNreintrag]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNreintrag]() As SqlInt32
            Get
                Return m_iNreintrag
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNreintragTmp As SqlInt32 = Value
                If iNreintragTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNreintrag", "iNreintrag can't be NULL")
                End If
                m_iNreintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.iProfilnr Property

Public Property [iProfilnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProfilnr]() As SqlInt32
            Get
                Return m_iProfilnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iProfilnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.sDokumentpaketnummern Property

Public Property [sDokumentpaketnummern]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentpaketnummern]() As SqlString
            Get
                Return m_sDokumentpaketnummern
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentpaketnummern = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.sHacken Property

Public Property [sHacken]() As SqlString

Source code

[Visual Basic]
        Public Property [sHacken]() As SqlString
            Get
                Return m_sHacken
            End Get
            Set(ByVal Value As SqlString)
                m_sHacken = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz Methods

clsEdex_dpinstanz overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_dpinstanz Class


clsEdex_dpinstanz.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dpinstanz_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dpinstanz_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dpinstanz::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dpinstanz_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentpaketnummern", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentpaketnummern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shacken", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIndividuellesDP", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIndividuellesDP))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iNreintrag = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@inreintrag").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dpinstanz_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dpinstanz::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dpinstanz_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dpinstanz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dpinstanz_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dpinstanz::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dpinstanz_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_dpinstanz")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dpinstanz_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNreintrag = New SqlInt32(CType(dtToReturn.Rows(0)("nreintrag"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentpaketnummern") Is System.DBNull.Value Then
                        m_sDokumentpaketnummern = SqlString.Null
                    Else
                        m_sDokumentpaketnummern = New SqlString(CType(dtToReturn.Rows(0)("dokumentpaketnummern"), String))
                    End If
                    If dtToReturn.Rows(0)("hacken") Is System.DBNull.Value Then
                        m_sHacken = SqlString.Null
                    Else
                        m_sHacken = New SqlString(CType(dtToReturn.Rows(0)("hacken"), String))
                    End If
                    If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
                        m_iNrpar00 = SqlInt32.Null
                    Else
                        m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Dokumentpaketnr") Is System.DBNull.Value Then
                        m_iDokumentpaketnr = SqlInt32.Null
                    Else
                        m_iDokumentpaketnr = New SqlInt32(CType(dtToReturn.Rows(0)("Dokumentpaketnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("IndividuellesDP") Is System.DBNull.Value Then
                        m_bIndividuellesDP = SqlBoolean.Null
                    Else
                        m_bIndividuellesDP = New SqlBoolean(CType(dtToReturn.Rows(0)("IndividuellesDP"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Profilnr") Is System.DBNull.Value Then
                        m_iProfilnr = SqlInt32.Null
                    Else
                        m_iProfilnr = New SqlInt32(CType(dtToReturn.Rows(0)("Profilnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dpinstanz::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_pr_edex_dpinstanz_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentpaketnummern", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentpaketnummern))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shacken", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iDokumentpaketnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentpaketnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bIndividuellesDP", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bIndividuellesDP))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iProfilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_pr_edex_dpinstanz_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_dpinstanz::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_dpinstanz Fields

clsEdex_dpinstanz overview

Fields

field m_bIndividuellesDP
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_iDokumentpaketnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMitarbeiternr
field m_iNreintrag
field m_iNrpar00
field m_iProfilnr
field m_sDokumentpaketnummern
field m_sHacken
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_dpinstanz Class


m_bIndividuellesDP Variable

Private 		m_bIndividuellesDP As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bIndividuellesDP As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_daErstellt_am Variable

Private 		m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_iDokumentpaketnr Variable

Private 		m_iDokumentpaketnr, _
   m_iProfilnr, _
   m_iNrpar00, _
   m_iMitarbeiternr, _
   m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketnr, m_iProfilnr, m_iNrpar00, m_iMitarbeiternr, m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_iMitarbeiternr Variable

Private 		m_iDokumentpaketnr, _
   m_iProfilnr, _
   m_iNrpar00, _
   m_iMitarbeiternr, _
   m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketnr, m_iProfilnr, m_iNrpar00, m_iMitarbeiternr, m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_iNreintrag Variable

Private 		m_iDokumentpaketnr, _
   m_iProfilnr, _
   m_iNrpar00, _
   m_iMitarbeiternr, _
   m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketnr, m_iProfilnr, m_iNrpar00, m_iMitarbeiternr, m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_iNrpar00 Variable

Private 		m_iDokumentpaketnr, _
   m_iProfilnr, _
   m_iNrpar00, _
   m_iMitarbeiternr, _
   m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketnr, m_iProfilnr, m_iNrpar00, m_iMitarbeiternr, m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_iProfilnr Variable

Private 		m_iDokumentpaketnr, _
   m_iProfilnr, _
   m_iNrpar00, _
   m_iMitarbeiternr, _
   m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumentpaketnr, m_iProfilnr, m_iNrpar00, m_iMitarbeiternr, m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_sDokumentpaketnummern Variable

Private 		m_sHacken, _
   m_sDokumentpaketnummern As SqlString

Source code

[Visual Basic]
        Private 		m_sHacken, m_sDokumentpaketnummern As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


m_sHacken Variable

Private 		m_sHacken, _
   m_sDokumentpaketnummern As SqlString

Source code

[Visual Basic]
        Private 		m_sHacken, m_sDokumentpaketnummern As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_dpinstanz


clsEdex_sb_notizen Class

For a list of all members of this type, see clsEdex_sb_notizen Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_sb_notizen

Public Class clsEdex_sb_notizen
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_sb_notizen Members


clsEdex_sb_notizen Members

clsEdex_sb_notizen overview

Constructors

constructor clsEdex_sb_notizen Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property iSerienbriefnr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNotiz

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_iSerienbriefnr
field m_sBetreff
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_notizen Class


clsEdex_sb_notizen Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen Properties

clsEdex_sb_notizen overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property iSerienbriefnr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNotiz

See Also

clsEdex_sb_notizen Class


clsEdex_sb_notizen.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.iNotiznr Property

Public Property [iNotiznr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNotiznr]() As SqlInt32
            Get
                Return m_iNotiznr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNotiznrTmp As SqlInt32 = Value
                If iNotiznrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNotiznr", "iNotiznr can't be NULL")
                End If
                m_iNotiznr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.iSerienbriefnr Property

Public Property [iSerienbriefnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSerienbriefnr]() As SqlInt32
            Get
                Return m_iSerienbriefnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSerienbriefnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.sBetreff Property

Public Property [sBetreff]() As SqlString

Source code

[Visual Basic]
        Public Property [sBetreff]() As SqlString
            Get
                Return m_sBetreff
            End Get
            Set(ByVal Value As SqlString)
                m_sBetreff = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.sNotiz Property

Public Property [sNotiz]() As SqlString

Source code

[Visual Basic]
        Public Property [sNotiz]() As SqlString
            Get
                Return m_sNotiz
            End Get
            Set(ByVal Value As SqlString)
                m_sNotiz = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen Methods

clsEdex_sb_notizen overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_sb_notizen Class


clsEdex_sb_notizen.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_notizen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_notizen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_notizen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_notizen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iNotiznr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@inotiznr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_notizen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_notizen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_notizen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_notizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_notizen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_notizen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_notizen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_notizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_notizen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNotiznr = New SqlInt32(CType(dtToReturn.Rows(0)("notiznr"), Integer))
                    If dtToReturn.Rows(0)("serienbriefnr") Is System.DBNull.Value Then
                        m_iSerienbriefnr = SqlInt32.Null
                    Else
                        m_iSerienbriefnr = New SqlInt32(CType(dtToReturn.Rows(0)("serienbriefnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("betreff") Is System.DBNull.Value Then
                        m_sBetreff = SqlString.Null
                    Else
                        m_sBetreff = New SqlString(CType(dtToReturn.Rows(0)("betreff"), String))
                    End If
                    If dtToReturn.Rows(0)("notiz") Is System.DBNull.Value Then
                        m_sNotiz = SqlString.Null
                    Else
                        m_sNotiz = New SqlString(CType(dtToReturn.Rows(0)("notiz"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_notizen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_notizen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_notizen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_notizen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_notizen Fields

clsEdex_sb_notizen overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_iSerienbriefnr
field m_sBetreff
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_notizen Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iSerienbriefnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSerienbriefnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iSerienbriefnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSerienbriefnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_iNotiznr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iSerienbriefnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSerienbriefnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_iSerienbriefnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iSerienbriefnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iSerienbriefnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_sBetreff Variable

Private 		m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


m_sNotiz Variable

Private 		m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_notizen


clsEdex_sb_partnerliste Class

For a list of all members of this type, see clsEdex_sb_partnerliste Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_sb_partnerliste

Public Class clsEdex_sb_partnerliste
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_sb_partnerliste Members


clsEdex_sb_partnerliste Members

clsEdex_sb_partnerliste overview

Constructors

constructor clsEdex_sb_partnerliste Constructor

Properties

property bAktiv
property blobEmpfaenger
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iPartnerlistenr
property iVerwendung
property iVerwendungcd
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobEmpfaenger
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iPartnerlistenr
field m_iVerwendung
field m_iVerwendungcd
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_partnerliste Class


clsEdex_sb_partnerliste Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste Properties

clsEdex_sb_partnerliste overview

Properties

property bAktiv
property blobEmpfaenger
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iPartnerlistenr
property iVerwendung
property iVerwendungcd
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_partnerliste Class


clsEdex_sb_partnerliste.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.blobEmpfaenger Property

Public Property [blobEmpfaenger]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobEmpfaenger]() As SqlBinary
            Get
                Return m_blobEmpfaenger
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobEmpfaenger = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.iPartnerlistenr Property

Public Property [iPartnerlistenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPartnerlistenr]() As SqlInt32
            Get
                Return m_iPartnerlistenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPartnerlistenrTmp As SqlInt32 = Value
                If iPartnerlistenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPartnerlistenr", "iPartnerlistenr can't be NULL")
                End If
                m_iPartnerlistenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.iVerwendung Property

Public Property [iVerwendung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerwendung]() As SqlInt32
            Get
                Return m_iVerwendung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerwendung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.iVerwendungcd Property

Public Property [iVerwendungcd]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerwendungcd]() As SqlInt32
            Get
                Return m_iVerwendungcd
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerwendungcd = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste Methods

clsEdex_sb_partnerliste overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_sb_partnerliste Class


clsEdex_sb_partnerliste.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_partnerliste_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnerlistenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnerlistenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_partnerliste_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_partnerliste::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_partnerliste_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverwendung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverwendungcd", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerwendungcd))
                Dim	iLength As Integer = 0
                If Not m_blobEmpfaenger.IsNull Then
                    iLength = m_blobEmpfaenger.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobempfaenger", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobEmpfaenger))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ipartnerlistenr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iPartnerlistenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iPartnerlistenr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@ipartnerlistenr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_partnerliste_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_partnerliste::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_partnerliste_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_partnerliste")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_partnerliste_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_partnerliste::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_partnerliste_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_partnerliste")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ipartnerlistenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnerlistenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_partnerliste_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPartnerlistenr = New SqlInt32(CType(dtToReturn.Rows(0)("partnerlistenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("verwendung") Is System.DBNull.Value Then
                        m_iVerwendung = SqlInt32.Null
                    Else
                        m_iVerwendung = New SqlInt32(CType(dtToReturn.Rows(0)("verwendung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("verwendungcd") Is System.DBNull.Value Then
                        m_iVerwendungcd = SqlInt32.Null
                    Else
                        m_iVerwendungcd = New SqlInt32(CType(dtToReturn.Rows(0)("verwendungcd"), Integer))
                    End If
                    If dtToReturn.Rows(0)("empfaenger") Is System.DBNull.Value Then
                        m_blobEmpfaenger = SqlBinary.Null
                    Else
                        m_blobEmpfaenger = New SqlBinary(CType(dtToReturn.Rows(0)("empfaenger"), Byte()))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_partnerliste::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_partnerliste_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnerlistenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnerlistenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverwendung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverwendungcd", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerwendungcd))
                Dim	iLength As Integer = 0
                If Not m_blobEmpfaenger.IsNull Then
                    iLength = m_blobEmpfaenger.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobempfaenger", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobEmpfaenger))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_partnerliste_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_partnerliste::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_partnerliste Fields

clsEdex_sb_partnerliste overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobEmpfaenger
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iPartnerlistenr
field m_iVerwendung
field m_iVerwendungcd
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_partnerliste Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_blobEmpfaenger Variable

Private 		m_blobEmpfaenger As SqlBinary

Source code

[Visual Basic]
        Private 		m_blobEmpfaenger As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_iMutierer Variable

Private 		m_iVerwendung, _
   m_iVerwendungcd, _
   m_iPartnerlistenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVerwendung, m_iVerwendungcd, m_iPartnerlistenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_iPartnerlistenr Variable

Private 		m_iVerwendung, _
   m_iVerwendungcd, _
   m_iPartnerlistenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVerwendung, m_iVerwendungcd, m_iPartnerlistenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_iVerwendung Variable

Private 		m_iVerwendung, _
   m_iVerwendungcd, _
   m_iPartnerlistenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVerwendung, m_iVerwendungcd, m_iPartnerlistenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_iVerwendungcd Variable

Private 		m_iVerwendung, _
   m_iVerwendungcd, _
   m_iPartnerlistenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVerwendung, m_iVerwendungcd, m_iPartnerlistenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_sBeschreibung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


m_sBezeichnung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_partnerliste


clsEdex_sb_serienbrief Class

For a list of all members of this type, see clsEdex_sb_serienbrief Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdex_sb_serienbrief

Public Class clsEdex_sb_serienbrief
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdex_sb_serienbrief Members


clsEdex_sb_serienbrief Members

clsEdex_sb_serienbrief overview

Constructors

constructor clsEdex_sb_serienbrief Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivdatum
property daDokumentdatum
property daErstellt_am
property daMutiert_am
property daTermin
property iAusgeloest
property iBestaetigt
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErstellt
property iFehlerhaft
property iGedruckt
property iInBearbeitung
property iMutierer
property iPostzustellung
property iSerienbriefnr
property iStatus
property iTeam
property iTreewidth
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iWindowheight
property iWindowwidth
property iZustaendig
property sBemerkung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivdatum
field m_daDokumentdatum
field m_daErstellt_am
field m_daMutiert_am
field m_daTermin
field m_iAusgeloest
field m_iBestaetigt
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErstellt
field m_iFehlerhaft
field m_iGedruckt
field m_iInBearbeitung
field m_iMutierer
field m_iPostzustellung
field m_iSerienbriefnr
field m_iStatus
field m_iTeam
field m_iTreewidth
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iWindowheight
field m_iWindowwidth
field m_iZustaendig
field m_sBemerkung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_serienbrief Class


clsEdex_sb_serienbrief Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief Properties

clsEdex_sb_serienbrief overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivdatum
property daDokumentdatum
property daErstellt_am
property daMutiert_am
property daTermin
property iAusgeloest
property iBestaetigt
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErstellt
property iFehlerhaft
property iGedruckt
property iInBearbeitung
property iMutierer
property iPostzustellung
property iSerienbriefnr
property iStatus
property iTeam
property iTreewidth
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iWindowheight
property iWindowwidth
property iZustaendig
property sBemerkung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_serienbrief Class


clsEdex_sb_serienbrief.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.daArchivdatum Property

Public Property [daArchivdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daArchivdatum]() As SqlDateTime
            Get
                Return m_daArchivdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daArchivdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.daDokumentdatum Property

Public Property [daDokumentdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDokumentdatum]() As SqlDateTime
            Get
                Return m_daDokumentdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDokumentdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.daTermin Property

Public Property [daTermin]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTermin]() As SqlDateTime
            Get
                Return m_daTermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTermin = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iAusgeloest Property

Public Property [iAusgeloest]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAusgeloest]() As SqlInt32
            Get
                Return m_iAusgeloest
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAusgeloest = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iBestaetigt Property

Public Property [iBestaetigt]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBestaetigt]() As SqlInt32
            Get
                Return m_iBestaetigt
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBestaetigt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iErstellt Property

Public Property [iErstellt]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErstellt]() As SqlInt32
            Get
                Return m_iErstellt
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErstellt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iFehlerhaft Property

Public Property [iFehlerhaft]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFehlerhaft]() As SqlInt32
            Get
                Return m_iFehlerhaft
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFehlerhaft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iGedruckt Property

Public Property [iGedruckt]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iGedruckt]() As SqlInt32
            Get
                Return m_iGedruckt
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGedruckt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iInBearbeitung Property

Public Property [iInBearbeitung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iInBearbeitung]() As SqlInt32
            Get
                Return m_iInBearbeitung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iInBearbeitung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iPostzustellung Property

Public Property [iPostzustellung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPostzustellung]() As SqlInt32
            Get
                Return m_iPostzustellung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPostzustellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iSerienbriefnr Property

Public Property [iSerienbriefnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSerienbriefnr]() As SqlInt32
            Get
                Return m_iSerienbriefnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSerienbriefnrTmp As SqlInt32 = Value
                If iSerienbriefnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSerienbriefnr", "iSerienbriefnr can't be NULL")
                End If
                m_iSerienbriefnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iTeam Property

Public Property [iTeam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeam]() As SqlInt32
            Get
                Return m_iTeam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTeam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iTreewidth Property

Public Property [iTreewidth]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTreewidth]() As SqlInt32
            Get
                Return m_iTreewidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTreewidth = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iVerantwortlich Property

Public Property [iVerantwortlich]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerantwortlich]() As SqlInt32
            Get
                Return m_iVerantwortlich
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerantwortlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iWindowheight Property

Public Property [iWindowheight]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iWindowheight]() As SqlInt32
            Get
                Return m_iWindowheight
            End Get
            Set(ByVal Value As SqlInt32)
                m_iWindowheight = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iWindowwidth Property

Public Property [iWindowwidth]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iWindowwidth]() As SqlInt32
            Get
                Return m_iWindowwidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iWindowwidth = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.iZustaendig Property

Public Property [iZustaendig]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZustaendig]() As SqlInt32
            Get
                Return m_iZustaendig
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZustaendig = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief Methods

clsEdex_sb_serienbrief overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdex_sb_serienbrief Class


clsEdex_sb_serienbrief.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_serienbrief_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_serienbrief_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_serienbrief::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_serienbrief_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumentdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumentdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwindowwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWindowwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwindowheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWindowheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itreewidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTreewidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifehlerhaft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFehlerhaft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iinBearbeitung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInBearbeitung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igedruckt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGedruckt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibestaetigt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBestaetigt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iausgeloest", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAusgeloest))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iSerienbriefnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iserienbriefnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_serienbrief_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_serienbrief::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_serienbrief_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_serienbrief")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_serienbrief_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_serienbrief::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_serienbrief_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edex_sb_serienbrief")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_serienbrief_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSerienbriefnr = New SqlInt32(CType(dtToReturn.Rows(0)("serienbriefnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
                        m_iVerantwortlich = SqlInt32.Null
                    Else
                        m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
                    End If
                    If dtToReturn.Rows(0)("postzustellung") Is System.DBNull.Value Then
                        m_iPostzustellung = SqlInt32.Null
                    Else
                        m_iPostzustellung = New SqlInt32(CType(dtToReturn.Rows(0)("postzustellung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentdatum") Is System.DBNull.Value Then
                        m_daDokumentdatum = SqlDateTime.Null
                    Else
                        m_daDokumentdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("dokumentdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("zustaendig") Is System.DBNull.Value Then
                        m_iZustaendig = SqlInt32.Null
                    Else
                        m_iZustaendig = New SqlInt32(CType(dtToReturn.Rows(0)("zustaendig"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftlinks") Is System.DBNull.Value Then
                        m_iUnterschriftlinks = SqlInt32.Null
                    Else
                        m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftrechts") Is System.DBNull.Value Then
                        m_iUnterschriftrechts = SqlInt32.Null
                    Else
                        m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    End If
                    If dtToReturn.Rows(0)("team") Is System.DBNull.Value Then
                        m_iTeam = SqlInt32.Null
                    Else
                        m_iTeam = New SqlInt32(CType(dtToReturn.Rows(0)("team"), Integer))
                    End If
                    If dtToReturn.Rows(0)("archivdatum") Is System.DBNull.Value Then
                        m_daArchivdatum = SqlDateTime.Null
                    Else
                        m_daArchivdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("archivdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("termin") Is System.DBNull.Value Then
                        m_daTermin = SqlDateTime.Null
                    Else
                        m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("termin"), Date))
                    End If
                    If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("status") Is System.DBNull.Value Then
                        m_iStatus = SqlInt32.Null
                    Else
                        m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("windowwidth") Is System.DBNull.Value Then
                        m_iWindowwidth = SqlInt32.Null
                    Else
                        m_iWindowwidth = New SqlInt32(CType(dtToReturn.Rows(0)("windowwidth"), Integer))
                    End If
                    If dtToReturn.Rows(0)("windowheight") Is System.DBNull.Value Then
                        m_iWindowheight = SqlInt32.Null
                    Else
                        m_iWindowheight = New SqlInt32(CType(dtToReturn.Rows(0)("windowheight"), Integer))
                    End If
                    If dtToReturn.Rows(0)("treewidth") Is System.DBNull.Value Then
                        m_iTreewidth = SqlInt32.Null
                    Else
                        m_iTreewidth = New SqlInt32(CType(dtToReturn.Rows(0)("treewidth"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fehlerhaft") Is System.DBNull.Value Then
                        m_iFehlerhaft = SqlInt32.Null
                    Else
                        m_iFehlerhaft = New SqlInt32(CType(dtToReturn.Rows(0)("fehlerhaft"), Integer))
                    End If
                    If dtToReturn.Rows(0)("inBearbeitung") Is System.DBNull.Value Then
                        m_iInBearbeitung = SqlInt32.Null
                    Else
                        m_iInBearbeitung = New SqlInt32(CType(dtToReturn.Rows(0)("inBearbeitung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt") Is System.DBNull.Value Then
                        m_iErstellt = SqlInt32.Null
                    Else
                        m_iErstellt = New SqlInt32(CType(dtToReturn.Rows(0)("erstellt"), Integer))
                    End If
                    If dtToReturn.Rows(0)("gedruckt") Is System.DBNull.Value Then
                        m_iGedruckt = SqlInt32.Null
                    Else
                        m_iGedruckt = New SqlInt32(CType(dtToReturn.Rows(0)("gedruckt"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bestaetigt") Is System.DBNull.Value Then
                        m_iBestaetigt = SqlInt32.Null
                    Else
                        m_iBestaetigt = New SqlInt32(CType(dtToReturn.Rows(0)("bestaetigt"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ausgeloest") Is System.DBNull.Value Then
                        m_iAusgeloest = SqlInt32.Null
                    Else
                        m_iAusgeloest = New SqlInt32(CType(dtToReturn.Rows(0)("ausgeloest"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_serienbrief::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edex_sb_serienbrief_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iserienbriefnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSerienbriefnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadokumentdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDokumentdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwindowwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWindowwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwindowheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWindowheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itreewidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTreewidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifehlerhaft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFehlerhaft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iinBearbeitung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iInBearbeitung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igedruckt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGedruckt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibestaetigt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBestaetigt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iausgeloest", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAusgeloest))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edex_sb_serienbrief_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdex_sb_serienbrief::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdex_sb_serienbrief Fields

clsEdex_sb_serienbrief overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivdatum
field m_daDokumentdatum
field m_daErstellt_am
field m_daMutiert_am
field m_daTermin
field m_iAusgeloest
field m_iBestaetigt
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErstellt
field m_iFehlerhaft
field m_iGedruckt
field m_iInBearbeitung
field m_iMutierer
field m_iPostzustellung
field m_iSerienbriefnr
field m_iStatus
field m_iTeam
field m_iTreewidth
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iWindowheight
field m_iWindowwidth
field m_iZustaendig
field m_sBemerkung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdex_sb_serienbrief Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_daArchivdatum Variable

Private 		m_daTermin, _
   m_daArchivdatum, _
   m_daMutiert_am, _
   m_daErstellt_am, _
   m_daDokumentdatum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTermin, m_daArchivdatum, m_daMutiert_am, m_daErstellt_am, m_daDokumentdatum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_daDokumentdatum Variable

Private 		m_daTermin, _
   m_daArchivdatum, _
   m_daMutiert_am, _
   m_daErstellt_am, _
   m_daDokumentdatum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTermin, m_daArchivdatum, m_daMutiert_am, m_daErstellt_am, m_daDokumentdatum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_daErstellt_am Variable

Private 		m_daTermin, _
   m_daArchivdatum, _
   m_daMutiert_am, _
   m_daErstellt_am, _
   m_daDokumentdatum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTermin, m_daArchivdatum, m_daMutiert_am, m_daErstellt_am, m_daDokumentdatum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_daMutiert_am Variable

Private 		m_daTermin, _
   m_daArchivdatum, _
   m_daMutiert_am, _
   m_daErstellt_am, _
   m_daDokumentdatum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTermin, m_daArchivdatum, m_daMutiert_am, m_daErstellt_am, m_daDokumentdatum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_daTermin Variable

Private 		m_daTermin, _
   m_daArchivdatum, _
   m_daMutiert_am, _
   m_daErstellt_am, _
   m_daDokumentdatum As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTermin, m_daArchivdatum, m_daMutiert_am, m_daErstellt_am, m_daDokumentdatum As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iAusgeloest Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iBestaetigt Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iDokumenttypnr Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iErstellt Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iFehlerhaft Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iGedruckt Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iInBearbeitung Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iMutierer Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iPostzustellung Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iSerienbriefnr Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iStatus Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iTeam Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iTreewidth Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iUnterschriftlinks Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iUnterschriftrechts Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iVerantwortlich Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iWindowheight Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iWindowwidth Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_iZustaendig Variable

Private 		m_iTreewidth, _
   m_iFehlerhaft, _
   m_iDokumenttypnr, _
   m_iWindowwidth, _
   m_iWindowheight, _
   m_iBestaetigt, _
   m_iAusgeloest, _
   m_iGedruckt, _
   m_iInBearbeitung, _
   m_iErstellt, _
   m_iStatus, _
   m_iPostzustellung, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iTeam, _
   m_iMutierer, _
   m_iSerienbriefnr, _
   m_iVerantwortlich, _
   m_iZustaendig As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTreewidth, m_iFehlerhaft, m_iDokumenttypnr, m_iWindowwidth, m_iWindowheight, m_iBestaetigt, m_iAusgeloest, m_iGedruckt, m_iInBearbeitung, m_iErstellt, m_iStatus, m_iPostzustellung, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iTeam, m_iMutierer, m_iSerienbriefnr, m_iVerantwortlich, m_iZustaendig As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_sBemerkung Variable

Private 		m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdex_sb_serienbrief


clsEdoka_adressen Class

For a list of all members of this type, see clsEdoka_adressen Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdoka_adressen

Public Class clsEdoka_adressen
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdoka_adressen Members


clsEdoka_adressen Members

clsEdoka_adressen overview

Constructors

constructor clsEdoka_adressen Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNrpar00
property sAdresszeile1
property sAdresszeile2
property sAdresszeile3
property sAdresszeile4
property sAdresszeile5
property sAdresszeile6
property sAdresszeile7
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNrpar00
field m_sAdresszeile1
field m_sAdresszeile2
field m_sAdresszeile3
field m_sAdresszeile4
field m_sAdresszeile5
field m_sAdresszeile6
field m_sAdresszeile7
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdoka_adressen Class


clsEdoka_adressen Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen Properties

clsEdoka_adressen overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNrpar00
property sAdresszeile1
property sAdresszeile2
property sAdresszeile3
property sAdresszeile4
property sAdresszeile5
property sAdresszeile6
property sAdresszeile7
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdoka_adressen Class


clsEdoka_adressen.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNrpar00Tmp As SqlInt32 = Value
                If iNrpar00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNrpar00", "iNrpar00 can't be NULL")
                End If
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile1 Property

Public Property [sAdresszeile1]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile1]() As SqlString
            Get
                Return m_sAdresszeile1
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile2 Property

Public Property [sAdresszeile2]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile2]() As SqlString
            Get
                Return m_sAdresszeile2
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile3 Property

Public Property [sAdresszeile3]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile3]() As SqlString
            Get
                Return m_sAdresszeile3
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile4 Property

Public Property [sAdresszeile4]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile4]() As SqlString
            Get
                Return m_sAdresszeile4
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile5 Property

Public Property [sAdresszeile5]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile5]() As SqlString
            Get
                Return m_sAdresszeile5
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile6 Property

Public Property [sAdresszeile6]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile6]() As SqlString
            Get
                Return m_sAdresszeile6
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.sAdresszeile7 Property

Public Property [sAdresszeile7]() As SqlString

Source code

[Visual Basic]
        Public Property [sAdresszeile7]() As SqlString
            Get
                Return m_sAdresszeile7
            End Get
            Set(ByVal Value As SqlString)
                m_sAdresszeile7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen Methods

clsEdoka_adressen overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdoka_adressen Class


clsEdoka_adressen.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_adressen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_adressen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_adressen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_adressen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile5", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile6", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile7", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile7))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_adressen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_adressen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_adressen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_adressen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_adressen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_adressen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_adressen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_adressen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_adressen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    If dtToReturn.Rows(0)("adresszeile1") Is System.DBNull.Value Then
                        m_sAdresszeile1 = SqlString.Null
                    Else
                        m_sAdresszeile1 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile1"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile2") Is System.DBNull.Value Then
                        m_sAdresszeile2 = SqlString.Null
                    Else
                        m_sAdresszeile2 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile2"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile3") Is System.DBNull.Value Then
                        m_sAdresszeile3 = SqlString.Null
                    Else
                        m_sAdresszeile3 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile3"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile4") Is System.DBNull.Value Then
                        m_sAdresszeile4 = SqlString.Null
                    Else
                        m_sAdresszeile4 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile4"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile5") Is System.DBNull.Value Then
                        m_sAdresszeile5 = SqlString.Null
                    Else
                        m_sAdresszeile5 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile5"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile6") Is System.DBNull.Value Then
                        m_sAdresszeile6 = SqlString.Null
                    Else
                        m_sAdresszeile6 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile6"), String))
                    End If
                    If dtToReturn.Rows(0)("adresszeile7") Is System.DBNull.Value Then
                        m_sAdresszeile7 = SqlString.Null
                    Else
                        m_sAdresszeile7 = New SqlString(CType(dtToReturn.Rows(0)("adresszeile7"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_adressen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_adressen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile5", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile6", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sadresszeile7", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAdresszeile7))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_adressen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_adressen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_adressen Fields

clsEdoka_adressen overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNrpar00
field m_sAdresszeile1
field m_sAdresszeile2
field m_sAdresszeile3
field m_sAdresszeile4
field m_sAdresszeile5
field m_sAdresszeile6
field m_sAdresszeile7
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsEdoka_adressen Class


m_iNrpar00 Variable

Private 		m_iNrpar00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNrpar00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile1 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile2 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile3 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile4 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile5 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile6 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


m_sAdresszeile7 Variable

Private 		m_sAdresszeile5, _
   m_sAdresszeile6, _
   m_sAdresszeile7, _
   m_sAdresszeile4, _
   m_sAdresszeile1, _
   m_sAdresszeile2, _
   m_sAdresszeile3 As SqlString

Source code

[Visual Basic]
        Private 		m_sAdresszeile5, m_sAdresszeile6, m_sAdresszeile7, m_sAdresszeile4, m_sAdresszeile1, m_sAdresszeile2, m_sAdresszeile3 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_adressen


clsEdoka_etbez0 Class

For a list of all members of this type, see clsEdoka_etbez0 Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdoka_etbez0

Public Class clsEdoka_etbez0
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdoka_etbez0 Members


clsEdoka_etbez0 Members

clsEdoka_etbez0 overview

Constructors

constructor clsEdoka_etbez0 Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBEU01
property iNRBEU02
property iNRBEZ00
property iNRPAR00
property iNRVVG00
property sCDMUTER
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siNRBEO00
property siNRPDM00
property siNRVRN00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBEU01
field m_iNRBEU02
field m_iNRBEZ00
field m_iNRPAR00
field m_iNRVVG00
field m_sCDMUTER
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRBEO00
field m_siNRPDM00
field m_siNRVRN00

See Also

clsEdoka_etbez0 Class


clsEdoka_etbez0 Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0 Properties

clsEdoka_etbez0 overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBEU01
property iNRBEU02
property iNRBEZ00
property iNRPAR00
property iNRVVG00
property sCDMUTER
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siNRBEO00
property siNRPDM00
property siNRVRN00

See Also

clsEdoka_etbez0 Class


clsEdoka_etbez0.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daDMERF00Tmp As SqlDateTime = Value
                If daDMERF00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daDMERF00", "daDMERF00 can't be NULL")
                End If
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.daTSMUT00 Property

Public Property [daTSMUT00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTSMUT00]() As SqlDateTime
            Get
                Return m_daTSMUT00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daTSMUT00Tmp As SqlDateTime = Value
                If daTSMUT00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daTSMUT00", "daTSMUT00 can't be NULL")
                End If
                m_daTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.iNRBEU01 Property

Public Property [iNRBEU01]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEU01]() As SqlInt32
            Get
                Return m_iNRBEU01
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRBEU01Tmp As SqlInt32 = Value
                If iNRBEU01Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRBEU01", "iNRBEU01 can't be NULL")
                End If
                m_iNRBEU01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.iNRBEU02 Property

Public Property [iNRBEU02]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEU02]() As SqlInt32
            Get
                Return m_iNRBEU02
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRBEU02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.iNRBEZ00 Property

Public Property [iNRBEZ00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEZ00]() As SqlInt32
            Get
                Return m_iNRBEZ00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRBEZ00Tmp As SqlInt32 = Value
                If iNRBEZ00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRBEZ00", "iNRBEZ00 can't be NULL")
                End If
                m_iNRBEZ00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.iNRVVG00 Property

Public Property [iNRVVG00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRVVG00]() As SqlInt32
            Get
                Return m_iNRVVG00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRVVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.sCDMUTER Property

Public Property [sCDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDMUTER]() As SqlString
            Get
                Return m_sCDMUTER
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDMUTERTmp As SqlString = Value
                If sCDMUTERTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDMUTER", "sCDMUTER can't be NULL")
                End If
                m_sCDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAREC00Tmp As SqlString = Value
                If sSAREC00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAREC00", "sSAREC00 can't be NULL")
                End If
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.siNRBEO00 Property

Public Property [siNRBEO00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRBEO00]() As SqlInt16
            Get
                Return m_siNRBEO00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRBEO00Tmp As SqlInt16 = Value
                If siNRBEO00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRBEO00", "siNRBEO00 can't be NULL")
                End If
                m_siNRBEO00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.siNRPDM00 Property

Public Property [siNRPDM00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRPDM00]() As SqlInt16
            Get
                Return m_siNRPDM00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRPDM00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.siNRVRN00 Property

Public Property [siNRVRN00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRN00]() As SqlInt16
            Get
                Return m_siNRVRN00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRVRN00Tmp As SqlInt16 = Value
                If siNRVRN00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRVRN00", "siNRVRN00 can't be NULL")
                End If
                m_siNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0 Methods

clsEdoka_etbez0 overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdoka_etbez0 Class


clsEdoka_etbez0.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etbez0_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEZ00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEZ00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etbez0_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etbez0::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etbez0_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEZ00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU01", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU02", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBEO00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBEO00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRPDM00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRPDM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etbez0_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etbez0::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etbez0_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_etbez0")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etbez0_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etbez0::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etbez0_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_etbez0")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRBEZ00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEZ00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etbez0_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRBEZ00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEZ00"), Integer))
                    m_siNRVRN00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRN00"), Short))
                    m_iNRBEU01 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEU01"), Integer))
                    If dtToReturn.Rows(0)("NRBEU02") Is System.DBNull.Value Then
                        m_iNRBEU02 = SqlInt32.Null
                    Else
                        m_iNRBEU02 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEU02"), Integer))
                    End If
                    m_siNRBEO00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRBEO00"), Short))
                    If dtToReturn.Rows(0)("NRPAR00") Is System.DBNull.Value Then
                        m_iNRPAR00 = SqlInt32.Null
                    Else
                        m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("NRVVG00") Is System.DBNull.Value Then
                        m_iNRVVG00 = SqlInt32.Null
                    Else
                        m_iNRVVG00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRVVG00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("NRPDM00") Is System.DBNull.Value Then
                        m_siNRPDM00 = SqlInt16.Null
                    Else
                        m_siNRPDM00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRPDM00"), Short))
                    End If
                    m_sCDMUTER = New SqlString(CType(dtToReturn.Rows(0)("CDMUTER"), String))
                    m_daTSMUT00 = New SqlDateTime(CType(dtToReturn.Rows(0)("TSMUT00"), Date))
                    m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etbez0::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etbez0_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEZ00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU01", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU02", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBEO00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBEO00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRPDM00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRPDM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etbez0_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etbez0::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etbez0 Fields

clsEdoka_etbez0 overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBEU01
field m_iNRBEU02
field m_iNRBEZ00
field m_iNRPAR00
field m_iNRVVG00
field m_sCDMUTER
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRBEO00
field m_siNRPDM00
field m_siNRVRN00

See Also

clsEdoka_etbez0 Class


m_daDMERF00 Variable

Private 		m_daTSMUT00, _
   m_daDMERF00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMERF00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_daTSMUT00 Variable

Private 		m_daTSMUT00, _
   m_daDMERF00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMERF00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_iNRBEU01 Variable

Private 		m_iNRVVG00, _
   m_iNRPAR00, _
   m_iNRBEU01, _
   m_iNRBEZ00, _
   m_iNRBEU02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRVVG00, m_iNRPAR00, m_iNRBEU01, m_iNRBEZ00, m_iNRBEU02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_iNRBEU02 Variable

Private 		m_iNRVVG00, _
   m_iNRPAR00, _
   m_iNRBEU01, _
   m_iNRBEZ00, _
   m_iNRBEU02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRVVG00, m_iNRPAR00, m_iNRBEU01, m_iNRBEZ00, m_iNRBEU02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_iNRBEZ00 Variable

Private 		m_iNRVVG00, _
   m_iNRPAR00, _
   m_iNRBEU01, _
   m_iNRBEZ00, _
   m_iNRBEU02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRVVG00, m_iNRPAR00, m_iNRBEU01, m_iNRBEZ00, m_iNRBEU02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_iNRPAR00 Variable

Private 		m_iNRVVG00, _
   m_iNRPAR00, _
   m_iNRBEU01, _
   m_iNRBEZ00, _
   m_iNRBEU02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRVVG00, m_iNRPAR00, m_iNRBEU01, m_iNRBEZ00, m_iNRBEU02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_iNRVVG00 Variable

Private 		m_iNRVVG00, _
   m_iNRPAR00, _
   m_iNRBEU01, _
   m_iNRBEZ00, _
   m_iNRBEU02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRVVG00, m_iNRPAR00, m_iNRBEU01, m_iNRBEZ00, m_iNRBEU02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_sCDMUTER Variable

Private 		m_sCDMUTER, _
   m_sSAREC00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDMUTER, m_sSAREC00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_sSAREC00 Variable

Private 		m_sCDMUTER, _
   m_sSAREC00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDMUTER, m_sSAREC00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_siNRBEO00 Variable

Private 		m_siNRBEO00, _
   m_siNRVRN00, _
   m_siNRPDM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRBEO00, m_siNRVRN00, m_siNRPDM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_siNRPDM00 Variable

Private 		m_siNRBEO00, _
   m_siNRVRN00, _
   m_siNRPDM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRBEO00, m_siNRVRN00, m_siNRPDM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


m_siNRVRN00 Variable

Private 		m_siNRBEO00, _
   m_siNRVRN00, _
   m_siNRPDM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRBEO00, m_siNRVRN00, m_siNRPDM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etbez0


clsEdoka_etpar0 Class

For a list of all members of this type, see clsEdoka_etpar0 Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEdoka_etpar0

Public Class clsEdoka_etpar0
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEdoka_etpar0 Members


clsEdoka_etpar0 Members

clsEdoka_etpar0 overview

Constructors

constructor clsEdoka_etpar0 Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMKTRNA
property daDMPARBI
property daDMPAREO
property daDMPARVN
property daDMPARZZ
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBEE00
property iNRBEU01
property iNRBEU02
property iNRPAR00
property sBKPAR00
property sBKPARSQ
property sCDDOMKT
property sCDKTRNA
property sCDMUTER
property sCDPARSQ
property sCDPAW00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAINT00
property sSAKTRNA
property sSAREC00
property sSAWBG00
property siNRAFG00
property siNRBBG00
property siNRBON00
property siNRDOM00
property siNRDOMGE
property siNRDOMRI
property siNRERF00
property siNRGSR00
property siNRNAT01
property siNRNAT02
property siNRRST00
property siNRSPA00
property siNRVRN00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMKTRNA
field m_daDMPARBI
field m_daDMPAREO
field m_daDMPARVN
field m_daDMPARZZ
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBEE00
field m_iNRBEU01
field m_iNRBEU02
field m_iNRPAR00
field m_sBKPAR00
field m_sBKPARSQ
field m_sCDDOMKT
field m_sCDKTRNA
field m_sCDMUTER
field m_sCDPARSQ
field m_sCDPAW00
field m_sSAINT00
field m_sSAKTRNA
field m_sSAREC00
field m_sSAWBG00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRAFG00
field m_siNRBBG00
field m_siNRBON00
field m_siNRDOM00
field m_siNRDOMGE
field m_siNRDOMRI
field m_siNRERF00
field m_siNRGSR00
field m_siNRNAT01
field m_siNRNAT02
field m_siNRRST00
field m_siNRSPA00
field m_siNRVRN00

See Also

clsEdoka_etpar0 Class


clsEdoka_etpar0 Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0 Properties

clsEdoka_etpar0 overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMKTRNA
property daDMPARBI
property daDMPAREO
property daDMPARVN
property daDMPARZZ
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBEE00
property iNRBEU01
property iNRBEU02
property iNRPAR00
property sBKPAR00
property sBKPARSQ
property sCDDOMKT
property sCDKTRNA
property sCDMUTER
property sCDPARSQ
property sCDPAW00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAINT00
property sSAKTRNA
property sSAREC00
property sSAWBG00
property siNRAFG00
property siNRBBG00
property siNRBON00
property siNRDOM00
property siNRDOMGE
property siNRDOMRI
property siNRERF00
property siNRGSR00
property siNRNAT01
property siNRNAT02
property siNRRST00
property siNRSPA00
property siNRVRN00

See Also

clsEdoka_etpar0 Class


clsEdoka_etpar0.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daDMERF00Tmp As SqlDateTime = Value
                If daDMERF00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daDMERF00", "daDMERF00 can't be NULL")
                End If
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daDMKTRNA Property

Public Property [daDMKTRNA]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMKTRNA]() As SqlDateTime
            Get
                Return m_daDMKTRNA
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daDMPARBI Property

Public Property [daDMPARBI]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMPARBI]() As SqlDateTime
            Get
                Return m_daDMPARBI
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMPARBI = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daDMPAREO Property

Public Property [daDMPAREO]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMPAREO]() As SqlDateTime
            Get
                Return m_daDMPAREO
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daDMPAREOTmp As SqlDateTime = Value
                If daDMPAREOTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daDMPAREO", "daDMPAREO can't be NULL")
                End If
                m_daDMPAREO = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daDMPARVN Property

Public Property [daDMPARVN]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMPARVN]() As SqlDateTime
            Get
                Return m_daDMPARVN
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMPARVN = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daDMPARZZ Property

Public Property [daDMPARZZ]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMPARZZ]() As SqlDateTime
            Get
                Return m_daDMPARZZ
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMPARZZ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.daTSMUT00 Property

Public Property [daTSMUT00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTSMUT00]() As SqlDateTime
            Get
                Return m_daTSMUT00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daTSMUT00Tmp As SqlDateTime = Value
                If daTSMUT00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daTSMUT00", "daTSMUT00 can't be NULL")
                End If
                m_daTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.iNRBEE00 Property

Public Property [iNRBEE00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEE00]() As SqlInt32
            Get
                Return m_iNRBEE00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRBEE00Tmp As SqlInt32 = Value
                If iNRBEE00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRBEE00", "iNRBEE00 can't be NULL")
                End If
                m_iNRBEE00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.iNRBEU01 Property

Public Property [iNRBEU01]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEU01]() As SqlInt32
            Get
                Return m_iNRBEU01
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRBEU01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.iNRBEU02 Property

Public Property [iNRBEU02]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBEU02]() As SqlInt32
            Get
                Return m_iNRBEU02
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRBEU02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRPAR00Tmp As SqlInt32 = Value
                If iNRPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
                End If
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sBKPAR00 Property

Public Property [sBKPAR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBKPAR00]() As SqlString
            Get
                Return m_sBKPAR00
            End Get
            Set(ByVal Value As SqlString)
                Dim sBKPAR00Tmp As SqlString = Value
                If sBKPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBKPAR00", "sBKPAR00 can't be NULL")
                End If
                m_sBKPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sBKPARSQ Property

Public Property [sBKPARSQ]() As SqlString

Source code

[Visual Basic]
        Public Property [sBKPARSQ]() As SqlString
            Get
                Return m_sBKPARSQ
            End Get
            Set(ByVal Value As SqlString)
                Dim sBKPARSQTmp As SqlString = Value
                If sBKPARSQTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBKPARSQ", "sBKPARSQ can't be NULL")
                End If
                m_sBKPARSQ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sCDDOMKT Property

Public Property [sCDDOMKT]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDDOMKT]() As SqlString
            Get
                Return m_sCDDOMKT
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDDOMKTTmp As SqlString = Value
                If sCDDOMKTTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDDOMKT", "sCDDOMKT can't be NULL")
                End If
                m_sCDDOMKT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sCDKTRNA Property

Public Property [sCDKTRNA]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDKTRNA]() As SqlString
            Get
                Return m_sCDKTRNA
            End Get
            Set(ByVal Value As SqlString)
                m_sCDKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sCDMUTER Property

Public Property [sCDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDMUTER]() As SqlString
            Get
                Return m_sCDMUTER
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDMUTERTmp As SqlString = Value
                If sCDMUTERTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDMUTER", "sCDMUTER can't be NULL")
                End If
                m_sCDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sCDPARSQ Property

Public Property [sCDPARSQ]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDPARSQ]() As SqlString
            Get
                Return m_sCDPARSQ
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDPARSQTmp As SqlString = Value
                If sCDPARSQTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDPARSQ", "sCDPARSQ can't be NULL")
                End If
                m_sCDPARSQ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sCDPAW00 Property

Public Property [sCDPAW00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDPAW00]() As SqlString
            Get
                Return m_sCDPAW00
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDPAW00Tmp As SqlString = Value
                If sCDPAW00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDPAW00", "sCDPAW00 can't be NULL")
                End If
                m_sCDPAW00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sSAINT00 Property

Public Property [sSAINT00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAINT00]() As SqlString
            Get
                Return m_sSAINT00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAINT00Tmp As SqlString = Value
                If sSAINT00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAINT00", "sSAINT00 can't be NULL")
                End If
                m_sSAINT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sSAKTRNA Property

Public Property [sSAKTRNA]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAKTRNA]() As SqlString
            Get
                Return m_sSAKTRNA
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAKTRNATmp As SqlString = Value
                If sSAKTRNATmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAKTRNA", "sSAKTRNA can't be NULL")
                End If
                m_sSAKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAREC00Tmp As SqlString = Value
                If sSAREC00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAREC00", "sSAREC00 can't be NULL")
                End If
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.sSAWBG00 Property

Public Property [sSAWBG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAWBG00]() As SqlString
            Get
                Return m_sSAWBG00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAWBG00Tmp As SqlString = Value
                If sSAWBG00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAWBG00", "sSAWBG00 can't be NULL")
                End If
                m_sSAWBG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRAFG00 Property

Public Property [siNRAFG00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRAFG00]() As SqlInt16
            Get
                Return m_siNRAFG00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRAFG00Tmp As SqlInt16 = Value
                If siNRAFG00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRAFG00", "siNRAFG00 can't be NULL")
                End If
                m_siNRAFG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRBBG00 Property

Public Property [siNRBBG00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRBBG00]() As SqlInt16
            Get
                Return m_siNRBBG00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRBBG00Tmp As SqlInt16 = Value
                If siNRBBG00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRBBG00", "siNRBBG00 can't be NULL")
                End If
                m_siNRBBG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRBON00 Property

Public Property [siNRBON00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRBON00]() As SqlInt16
            Get
                Return m_siNRBON00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRBON00Tmp As SqlInt16 = Value
                If siNRBON00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRBON00", "siNRBON00 can't be NULL")
                End If
                m_siNRBON00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRDOM00 Property

Public Property [siNRDOM00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRDOM00]() As SqlInt16
            Get
                Return m_siNRDOM00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRDOM00Tmp As SqlInt16 = Value
                If siNRDOM00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRDOM00", "siNRDOM00 can't be NULL")
                End If
                m_siNRDOM00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRDOMGE Property

Public Property [siNRDOMGE]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRDOMGE]() As SqlInt16
            Get
                Return m_siNRDOMGE
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRDOMGETmp As SqlInt16 = Value
                If siNRDOMGETmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRDOMGE", "siNRDOMGE can't be NULL")
                End If
                m_siNRDOMGE = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRDOMRI Property

Public Property [siNRDOMRI]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRDOMRI]() As SqlInt16
            Get
                Return m_siNRDOMRI
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRDOMRITmp As SqlInt16 = Value
                If siNRDOMRITmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRDOMRI", "siNRDOMRI can't be NULL")
                End If
                m_siNRDOMRI = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRERF00 Property

Public Property [siNRERF00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRERF00]() As SqlInt16
            Get
                Return m_siNRERF00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRERF00Tmp As SqlInt16 = Value
                If siNRERF00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRERF00", "siNRERF00 can't be NULL")
                End If
                m_siNRERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRGSR00 Property

Public Property [siNRGSR00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRGSR00]() As SqlInt16
            Get
                Return m_siNRGSR00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRGSR00Tmp As SqlInt16 = Value
                If siNRGSR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRGSR00", "siNRGSR00 can't be NULL")
                End If
                m_siNRGSR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRNAT01 Property

Public Property [siNRNAT01]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRNAT01]() As SqlInt16
            Get
                Return m_siNRNAT01
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRNAT01Tmp As SqlInt16 = Value
                If siNRNAT01Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRNAT01", "siNRNAT01 can't be NULL")
                End If
                m_siNRNAT01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRNAT02 Property

Public Property [siNRNAT02]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRNAT02]() As SqlInt16
            Get
                Return m_siNRNAT02
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRNAT02Tmp As SqlInt16 = Value
                If siNRNAT02Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRNAT02", "siNRNAT02 can't be NULL")
                End If
                m_siNRNAT02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRRST00 Property

Public Property [siNRRST00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRRST00]() As SqlInt16
            Get
                Return m_siNRRST00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRRST00Tmp As SqlInt16 = Value
                If siNRRST00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRRST00", "siNRRST00 can't be NULL")
                End If
                m_siNRRST00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRSPA00 Property

Public Property [siNRSPA00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRSPA00]() As SqlInt16
            Get
                Return m_siNRSPA00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRSPA00Tmp As SqlInt16 = Value
                If siNRSPA00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRSPA00", "siNRSPA00 can't be NULL")
                End If
                m_siNRSPA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.siNRVRN00 Property

Public Property [siNRVRN00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRN00]() As SqlInt16
            Get
                Return m_siNRVRN00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRVRN00Tmp As SqlInt16 = Value
                If siNRVRN00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRVRN00", "siNRVRN00 can't be NULL")
                End If
                m_siNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0 Methods

clsEdoka_etpar0 overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEdoka_etpar0 Class


clsEdoka_etpar0.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etpar0_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etpar0_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etpar0::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etpar0_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPAW00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDPAW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPAREO", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMPAREO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRERF00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARVN", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARVN))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARBI", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARBI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRAFG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRAFG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARZZ", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARZZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRRST00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRRST00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRSPA00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRSPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRGSR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRGSR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBON00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBON00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBBG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBBG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOMGE", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOMGE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDDOMKT", SqlDbType.Char, 2, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDDOMKT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOM00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOMRI", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOMRI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNAT01", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRNAT01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNAT02", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRNAT02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAWBG00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAWBG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEE00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEE00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAINT00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAINT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU01", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU02", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPARSQ", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBKPARSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPARSQ", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDPARSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMKTRNA", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDKTRNA", SqlDbType.Char, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAKTRNA", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAKTRNA))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etpar0_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etpar0::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etpar0_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_etpar0")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etpar0_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etpar0::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etpar0_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("edoka_etpar0")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etpar0_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    m_siNRVRN00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRN00"), Short))
                    m_sCDPAW00 = New SqlString(CType(dtToReturn.Rows(0)("CDPAW00"), String))
                    m_sBKPAR00 = New SqlString(CType(dtToReturn.Rows(0)("BKPAR00"), String))
                    m_daDMPAREO = New SqlDateTime(CType(dtToReturn.Rows(0)("DMPAREO"), Date))
                    m_siNRERF00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRERF00"), Short))
                    If dtToReturn.Rows(0)("DMPARVN") Is System.DBNull.Value Then
                        m_daDMPARVN = SqlDateTime.Null
                    Else
                        m_daDMPARVN = New SqlDateTime(CType(dtToReturn.Rows(0)("DMPARVN"), Date))
                    End If
                    If dtToReturn.Rows(0)("DMPARBI") Is System.DBNull.Value Then
                        m_daDMPARBI = SqlDateTime.Null
                    Else
                        m_daDMPARBI = New SqlDateTime(CType(dtToReturn.Rows(0)("DMPARBI"), Date))
                    End If
                    m_siNRAFG00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRAFG00"), Short))
                    If dtToReturn.Rows(0)("DMPARZZ") Is System.DBNull.Value Then
                        m_daDMPARZZ = SqlDateTime.Null
                    Else
                        m_daDMPARZZ = New SqlDateTime(CType(dtToReturn.Rows(0)("DMPARZZ"), Date))
                    End If
                    m_siNRRST00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRRST00"), Short))
                    m_siNRSPA00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRSPA00"), Short))
                    m_siNRGSR00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRGSR00"), Short))
                    m_siNRBON00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRBON00"), Short))
                    m_siNRBBG00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRBBG00"), Short))
                    m_siNRDOMGE = New SqlInt16(CType(dtToReturn.Rows(0)("NRDOMGE"), Short))
                    m_sCDDOMKT = New SqlString(CType(dtToReturn.Rows(0)("CDDOMKT"), String))
                    m_siNRDOM00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRDOM00"), Short))
                    m_siNRDOMRI = New SqlInt16(CType(dtToReturn.Rows(0)("NRDOMRI"), Short))
                    m_siNRNAT01 = New SqlInt16(CType(dtToReturn.Rows(0)("NRNAT01"), Short))
                    m_siNRNAT02 = New SqlInt16(CType(dtToReturn.Rows(0)("NRNAT02"), Short))
                    m_sSAWBG00 = New SqlString(CType(dtToReturn.Rows(0)("SAWBG00"), String))
                    m_iNRBEE00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEE00"), Integer))
                    m_sSAINT00 = New SqlString(CType(dtToReturn.Rows(0)("SAINT00"), String))
                    If dtToReturn.Rows(0)("NRBEU01") Is System.DBNull.Value Then
                        m_iNRBEU01 = SqlInt32.Null
                    Else
                        m_iNRBEU01 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEU01"), Integer))
                    End If
                    If dtToReturn.Rows(0)("NRBEU02") Is System.DBNull.Value Then
                        m_iNRBEU02 = SqlInt32.Null
                    Else
                        m_iNRBEU02 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBEU02"), Integer))
                    End If
                    m_sBKPARSQ = New SqlString(CType(dtToReturn.Rows(0)("BKPARSQ"), String))
                    m_sCDPARSQ = New SqlString(CType(dtToReturn.Rows(0)("CDPARSQ"), String))
                    m_sCDMUTER = New SqlString(CType(dtToReturn.Rows(0)("CDMUTER"), String))
                    m_daTSMUT00 = New SqlDateTime(CType(dtToReturn.Rows(0)("TSMUT00"), Date))
                    m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                    If dtToReturn.Rows(0)("DMKTRNA") Is System.DBNull.Value Then
                        m_daDMKTRNA = SqlDateTime.Null
                    Else
                        m_daDMKTRNA = New SqlDateTime(CType(dtToReturn.Rows(0)("DMKTRNA"), Date))
                    End If
                    If dtToReturn.Rows(0)("CDKTRNA") Is System.DBNull.Value Then
                        m_sCDKTRNA = SqlString.Null
                    Else
                        m_sCDKTRNA = New SqlString(CType(dtToReturn.Rows(0)("CDKTRNA"), String))
                    End If
                    m_sSAKTRNA = New SqlString(CType(dtToReturn.Rows(0)("SAKTRNA"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etpar0::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_edoka_etpar0_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPAW00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDPAW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPAREO", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMPAREO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRERF00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARVN", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARVN))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARBI", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARBI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRAFG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRAFG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMPARZZ", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMPARZZ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRRST00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRRST00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRSPA00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRSPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRGSR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRGSR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBON00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBON00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBBG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBBG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOMGE", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOMGE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDDOMKT", SqlDbType.Char, 2, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDDOMKT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOM00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRDOMRI", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRDOMRI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNAT01", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRNAT01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNAT02", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRNAT02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAWBG00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAWBG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEE00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBEE00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAINT00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAINT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU01", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBEU02", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRBEU02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPARSQ", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBKPARSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPARSQ", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDPARSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMKTRNA", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDKTRNA", SqlDbType.Char, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAKTRNA", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAKTRNA))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_edoka_etpar0_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEdoka_etpar0::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEdoka_etpar0 Fields

clsEdoka_etpar0 overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMKTRNA
field m_daDMPARBI
field m_daDMPAREO
field m_daDMPARVN
field m_daDMPARZZ
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBEE00
field m_iNRBEU01
field m_iNRBEU02
field m_iNRPAR00
field m_sBKPAR00
field m_sBKPARSQ
field m_sCDDOMKT
field m_sCDKTRNA
field m_sCDMUTER
field m_sCDPARSQ
field m_sCDPAW00
field m_sSAINT00
field m_sSAKTRNA
field m_sSAREC00
field m_sSAWBG00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRAFG00
field m_siNRBBG00
field m_siNRBON00
field m_siNRDOM00
field m_siNRDOMGE
field m_siNRDOMRI
field m_siNRERF00
field m_siNRGSR00
field m_siNRNAT01
field m_siNRNAT02
field m_siNRRST00
field m_siNRSPA00
field m_siNRVRN00

See Also

clsEdoka_etpar0 Class


m_daDMERF00 Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daDMKTRNA Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daDMPARBI Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daDMPAREO Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daDMPARVN Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daDMPARZZ Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_daTSMUT00 Variable

Private 		m_daDMPAREO, _
   m_daTSMUT00, _
   m_daDMKTRNA, _
   m_daDMPARBI, _
   m_daDMPARZZ, _
   m_daDMERF00, _
   m_daDMPARVN As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMPAREO, m_daTSMUT00, m_daDMKTRNA, m_daDMPARBI, m_daDMPARZZ, m_daDMERF00, m_daDMPARVN As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_iNRBEE00 Variable

Private 		m_iNRBEE00, _
   m_iNRPAR00, _
   m_iNRBEU02, _
   m_iNRBEU01 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBEE00, m_iNRPAR00, m_iNRBEU02, m_iNRBEU01 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_iNRBEU01 Variable

Private 		m_iNRBEE00, _
   m_iNRPAR00, _
   m_iNRBEU02, _
   m_iNRBEU01 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBEE00, m_iNRPAR00, m_iNRBEU02, m_iNRBEU01 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_iNRBEU02 Variable

Private 		m_iNRBEE00, _
   m_iNRPAR00, _
   m_iNRBEU02, _
   m_iNRBEU01 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBEE00, m_iNRPAR00, m_iNRBEU02, m_iNRBEU01 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_iNRPAR00 Variable

Private 		m_iNRBEE00, _
   m_iNRPAR00, _
   m_iNRBEU02, _
   m_iNRBEU01 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBEE00, m_iNRPAR00, m_iNRBEU02, m_iNRBEU01 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sBKPAR00 Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sBKPARSQ Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sCDDOMKT Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sCDKTRNA Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sCDMUTER Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sCDPARSQ Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sCDPAW00 Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sSAINT00 Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sSAKTRNA Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sSAREC00 Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_sSAWBG00 Variable

Private 		m_sCDPARSQ, _
   m_sCDMUTER, _
   m_sSAREC00, _
   m_sBKPARSQ, _
   m_sSAWBG00, _
   m_sSAINT00, _
   m_sCDDOMKT, _
   m_sBKPAR00, _
   m_sCDKTRNA, _
   m_sSAKTRNA, _
   m_sCDPAW00 As SqlString

Source code

[Visual Basic]
        Private 		m_sCDPARSQ, m_sCDMUTER, m_sSAREC00, m_sBKPARSQ, m_sSAWBG00, m_sSAINT00, m_sCDDOMKT, m_sBKPAR00, m_sCDKTRNA, m_sSAKTRNA, m_sCDPAW00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRAFG00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRBBG00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRBON00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRDOM00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRDOMGE Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRDOMRI Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRERF00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRGSR00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRNAT01 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRNAT02 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRRST00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRSPA00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


m_siNRVRN00 Variable

Private 		m_siNRRST00, _
   m_siNRSPA00, _
   m_siNRGSR00, _
   m_siNRVRN00, _
   m_siNRERF00, _
   m_siNRAFG00, _
   m_siNRBON00, _
   m_siNRDOMRI, _
   m_siNRNAT01, _
   m_siNRNAT02, _
   m_siNRBBG00, _
   m_siNRDOMGE, _
   m_siNRDOM00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRRST00, m_siNRSPA00, m_siNRGSR00, m_siNRVRN00, m_siNRERF00, m_siNRAFG00, m_siNRBON00, m_siNRDOMRI, m_siNRNAT01, m_siNRNAT02, m_siNRBBG00, m_siNRDOMGE, m_siNRDOM00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEdoka_etpar0


clsEtparn Class

For a list of all members of this type, see clsEtparn Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEtparn

Public Class clsEtparn
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEtparn Members


clsEtparn Members

clsEtparn overview

Constructors

constructor clsEtparn Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMGEB00
property daDMTOD00
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBER01
property iNRBER02
property iNRPAR00
property sBEBERAL
property sBEBGO00
property sBEGEB00
property sCDAHV00
property sCDIPA00
property sCDMUTER
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siDMGEBJJ
property siDMTODJJ
property siNRABD00
property siNRABE00
property siNRBVG00
property siNRERW00
property siNRGST00
property siNRSEX00
property siNRVRN00
property siNRZVS00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMGEB00
field m_daDMTOD00
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBER01
field m_iNRBER02
field m_iNRPAR00
field m_sBEBERAL
field m_sBEBGO00
field m_sBEGEB00
field m_sCDAHV00
field m_sCDIPA00
field m_sCDMUTER
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siDMGEBJJ
field m_siDMTODJJ
field m_siNRABD00
field m_siNRABE00
field m_siNRBVG00
field m_siNRERW00
field m_siNRGST00
field m_siNRSEX00
field m_siNRVRN00
field m_siNRZVS00

See Also

clsEtparn Class


clsEtparn Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn Properties

clsEtparn overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMGEB00
property daDMTOD00
property daTSMUT00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRBER01
property iNRBER02
property iNRPAR00
property sBEBERAL
property sBEBGO00
property sBEGEB00
property sCDAHV00
property sCDIPA00
property sCDMUTER
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siDMGEBJJ
property siDMTODJJ
property siNRABD00
property siNRABE00
property siNRBVG00
property siNRERW00
property siNRGST00
property siNRSEX00
property siNRVRN00
property siNRZVS00

See Also

clsEtparn Class


clsEtparn.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daDMERF00Tmp As SqlDateTime = Value
                If daDMERF00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daDMERF00", "daDMERF00 can't be NULL")
                End If
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.daDMGEB00 Property

Public Property [daDMGEB00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMGEB00]() As SqlDateTime
            Get
                Return m_daDMGEB00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMGEB00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.daDMTOD00 Property

Public Property [daDMTOD00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMTOD00]() As SqlDateTime
            Get
                Return m_daDMTOD00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMTOD00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.daTSMUT00 Property

Public Property [daTSMUT00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTSMUT00]() As SqlDateTime
            Get
                Return m_daTSMUT00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daTSMUT00Tmp As SqlDateTime = Value
                If daTSMUT00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daTSMUT00", "daTSMUT00 can't be NULL")
                End If
                m_daTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.iNRBER01 Property

Public Property [iNRBER01]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBER01]() As SqlInt32
            Get
                Return m_iNRBER01
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRBER01Tmp As SqlInt32 = Value
                If iNRBER01Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRBER01", "iNRBER01 can't be NULL")
                End If
                m_iNRBER01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.iNRBER02 Property

Public Property [iNRBER02]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRBER02]() As SqlInt32
            Get
                Return m_iNRBER02
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRBER02Tmp As SqlInt32 = Value
                If iNRBER02Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRBER02", "iNRBER02 can't be NULL")
                End If
                m_iNRBER02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRPAR00Tmp As SqlInt32 = Value
                If iNRPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
                End If
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sBEBERAL Property

Public Property [sBEBERAL]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBERAL]() As SqlString
            Get
                Return m_sBEBERAL
            End Get
            Set(ByVal Value As SqlString)
                Dim sBEBERALTmp As SqlString = Value
                If sBEBERALTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBEBERAL", "sBEBERAL can't be NULL")
                End If
                m_sBEBERAL = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sBEBGO00 Property

Public Property [sBEBGO00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBGO00]() As SqlString
            Get
                Return m_sBEBGO00
            End Get
            Set(ByVal Value As SqlString)
                Dim sBEBGO00Tmp As SqlString = Value
                If sBEBGO00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBEBGO00", "sBEBGO00 can't be NULL")
                End If
                m_sBEBGO00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sBEGEB00 Property

Public Property [sBEGEB00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEGEB00]() As SqlString
            Get
                Return m_sBEGEB00
            End Get
            Set(ByVal Value As SqlString)
                Dim sBEGEB00Tmp As SqlString = Value
                If sBEGEB00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBEGEB00", "sBEGEB00 can't be NULL")
                End If
                m_sBEGEB00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sCDAHV00 Property

Public Property [sCDAHV00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDAHV00]() As SqlString
            Get
                Return m_sCDAHV00
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDAHV00Tmp As SqlString = Value
                If sCDAHV00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDAHV00", "sCDAHV00 can't be NULL")
                End If
                m_sCDAHV00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sCDIPA00 Property

Public Property [sCDIPA00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDIPA00]() As SqlString
            Get
                Return m_sCDIPA00
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDIPA00Tmp As SqlString = Value
                If sCDIPA00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDIPA00", "sCDIPA00 can't be NULL")
                End If
                m_sCDIPA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sCDMUTER Property

Public Property [sCDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDMUTER]() As SqlString
            Get
                Return m_sCDMUTER
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDMUTERTmp As SqlString = Value
                If sCDMUTERTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDMUTER", "sCDMUTER can't be NULL")
                End If
                m_sCDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAREC00Tmp As SqlString = Value
                If sSAREC00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAREC00", "sSAREC00 can't be NULL")
                End If
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siDMGEBJJ Property

Public Property [siDMGEBJJ]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siDMGEBJJ]() As SqlInt16
            Get
                Return m_siDMGEBJJ
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siDMGEBJJTmp As SqlInt16 = Value
                If siDMGEBJJTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siDMGEBJJ", "siDMGEBJJ can't be NULL")
                End If
                m_siDMGEBJJ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siDMTODJJ Property

Public Property [siDMTODJJ]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siDMTODJJ]() As SqlInt16
            Get
                Return m_siDMTODJJ
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siDMTODJJTmp As SqlInt16 = Value
                If siDMTODJJTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siDMTODJJ", "siDMTODJJ can't be NULL")
                End If
                m_siDMTODJJ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRABD00 Property

Public Property [siNRABD00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRABD00]() As SqlInt16
            Get
                Return m_siNRABD00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRABD00Tmp As SqlInt16 = Value
                If siNRABD00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRABD00", "siNRABD00 can't be NULL")
                End If
                m_siNRABD00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRABE00 Property

Public Property [siNRABE00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRABE00]() As SqlInt16
            Get
                Return m_siNRABE00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRABE00Tmp As SqlInt16 = Value
                If siNRABE00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRABE00", "siNRABE00 can't be NULL")
                End If
                m_siNRABE00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRBVG00 Property

Public Property [siNRBVG00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRBVG00]() As SqlInt16
            Get
                Return m_siNRBVG00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRBVG00Tmp As SqlInt16 = Value
                If siNRBVG00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRBVG00", "siNRBVG00 can't be NULL")
                End If
                m_siNRBVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRERW00 Property

Public Property [siNRERW00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRERW00]() As SqlInt16
            Get
                Return m_siNRERW00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRERW00Tmp As SqlInt16 = Value
                If siNRERW00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRERW00", "siNRERW00 can't be NULL")
                End If
                m_siNRERW00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRGST00 Property

Public Property [siNRGST00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRGST00]() As SqlInt16
            Get
                Return m_siNRGST00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRGST00Tmp As SqlInt16 = Value
                If siNRGST00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRGST00", "siNRGST00 can't be NULL")
                End If
                m_siNRGST00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRSEX00 Property

Public Property [siNRSEX00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRSEX00]() As SqlInt16
            Get
                Return m_siNRSEX00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRSEX00Tmp As SqlInt16 = Value
                If siNRSEX00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRSEX00", "siNRSEX00 can't be NULL")
                End If
                m_siNRSEX00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRVRN00 Property

Public Property [siNRVRN00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRN00]() As SqlInt16
            Get
                Return m_siNRVRN00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRVRN00Tmp As SqlInt16 = Value
                If siNRVRN00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRVRN00", "siNRVRN00 can't be NULL")
                End If
                m_siNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.siNRZVS00 Property

Public Property [siNRZVS00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRZVS00]() As SqlInt16
            Get
                Return m_siNRZVS00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRZVS00Tmp As SqlInt16 = Value
                If siNRZVS00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRZVS00", "siNRZVS00 can't be NULL")
                End If
                m_siNRZVS00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn Methods

clsEtparn overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEtparn Class


clsEtparn.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparn_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparn_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparn::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparn_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMGEB00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMGEB00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMGEBJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMGEBJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEGEB00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEGEB00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBGO00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEBGO00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMTOD00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMTOD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMTODJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMTODJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRSEX00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRSEX00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRZVS00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRZVS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRGST00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRGST00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRABD00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRABD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBERAL", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEBERAL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBER01", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBER01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBER02", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBER02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRERW00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRERW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDAHV00", SqlDbType.Char, 11, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDAHV00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBVG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRABE00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRABE00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDIPA00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDIPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparn_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparn::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparn_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("etparn")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparn_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparn::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparn_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("etparn")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparn_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    m_siNRVRN00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRN00"), Short))
                    If dtToReturn.Rows(0)("DMGEB00") Is System.DBNull.Value Then
                        m_daDMGEB00 = SqlDateTime.Null
                    Else
                        m_daDMGEB00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMGEB00"), Date))
                    End If
                    m_siDMGEBJJ = New SqlInt16(CType(dtToReturn.Rows(0)("DMGEBJJ"), Short))
                    m_sBEGEB00 = New SqlString(CType(dtToReturn.Rows(0)("BEGEB00"), String))
                    m_sBEBGO00 = New SqlString(CType(dtToReturn.Rows(0)("BEBGO00"), String))
                    If dtToReturn.Rows(0)("DMTOD00") Is System.DBNull.Value Then
                        m_daDMTOD00 = SqlDateTime.Null
                    Else
                        m_daDMTOD00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMTOD00"), Date))
                    End If
                    m_siDMTODJJ = New SqlInt16(CType(dtToReturn.Rows(0)("DMTODJJ"), Short))
                    m_siNRSEX00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRSEX00"), Short))
                    m_siNRZVS00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRZVS00"), Short))
                    m_siNRGST00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRGST00"), Short))
                    m_siNRABD00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRABD00"), Short))
                    m_sBEBERAL = New SqlString(CType(dtToReturn.Rows(0)("BEBERAL"), String))
                    m_iNRBER01 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBER01"), Integer))
                    m_iNRBER02 = New SqlInt32(CType(dtToReturn.Rows(0)("NRBER02"), Integer))
                    m_siNRERW00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRERW00"), Short))
                    m_sCDAHV00 = New SqlString(CType(dtToReturn.Rows(0)("CDAHV00"), String))
                    m_siNRBVG00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRBVG00"), Short))
                    m_siNRABE00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRABE00"), Short))
                    m_sCDIPA00 = New SqlString(CType(dtToReturn.Rows(0)("CDIPA00"), String))
                    m_sCDMUTER = New SqlString(CType(dtToReturn.Rows(0)("CDMUTER"), String))
                    m_daTSMUT00 = New SqlDateTime(CType(dtToReturn.Rows(0)("TSMUT00"), Date))
                    m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparn::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparn_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMGEB00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMGEB00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMGEBJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMGEBJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEGEB00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEGEB00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBGO00", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEBGO00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMTOD00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMTOD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMTODJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMTODJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRSEX00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRSEX00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRZVS00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRZVS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRGST00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRGST00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRABD00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRABD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBERAL", SqlDbType.Char, 35, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBEBERAL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBER01", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBER01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRBER02", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRBER02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRERW00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRERW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDAHV00", SqlDbType.Char, 11, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDAHV00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRBVG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRBVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRABE00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRABE00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDIPA00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDIPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparn_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparn::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparn Fields

clsEtparn overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMGEB00
field m_daDMTOD00
field m_daTSMUT00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRBER01
field m_iNRBER02
field m_iNRPAR00
field m_sBEBERAL
field m_sBEBGO00
field m_sBEGEB00
field m_sCDAHV00
field m_sCDIPA00
field m_sCDMUTER
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siDMGEBJJ
field m_siDMTODJJ
field m_siNRABD00
field m_siNRABE00
field m_siNRBVG00
field m_siNRERW00
field m_siNRGST00
field m_siNRSEX00
field m_siNRVRN00
field m_siNRZVS00

See Also

clsEtparn Class


m_daDMERF00 Variable

Private 		m_daTSMUT00, _
   m_daDMGEB00, _
   m_daDMERF00, _
   m_daDMTOD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMGEB00, m_daDMERF00, m_daDMTOD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_daDMGEB00 Variable

Private 		m_daTSMUT00, _
   m_daDMGEB00, _
   m_daDMERF00, _
   m_daDMTOD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMGEB00, m_daDMERF00, m_daDMTOD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_daDMTOD00 Variable

Private 		m_daTSMUT00, _
   m_daDMGEB00, _
   m_daDMERF00, _
   m_daDMTOD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMGEB00, m_daDMERF00, m_daDMTOD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_daTSMUT00 Variable

Private 		m_daTSMUT00, _
   m_daDMGEB00, _
   m_daDMERF00, _
   m_daDMTOD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daTSMUT00, m_daDMGEB00, m_daDMERF00, m_daDMTOD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_iNRBER01 Variable

Private 		m_iNRBER01, _
   m_iNRPAR00, _
   m_iNRBER02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBER01, m_iNRPAR00, m_iNRBER02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_iNRBER02 Variable

Private 		m_iNRBER01, _
   m_iNRPAR00, _
   m_iNRBER02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBER01, m_iNRPAR00, m_iNRBER02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_iNRPAR00 Variable

Private 		m_iNRBER01, _
   m_iNRPAR00, _
   m_iNRBER02 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRBER01, m_iNRPAR00, m_iNRBER02 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sBEBERAL Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sBEBGO00 Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sBEGEB00 Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sCDAHV00 Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sCDIPA00 Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sCDMUTER Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_sSAREC00 Variable

Private 		m_sBEGEB00, _
   m_sBEBGO00, _
   m_sCDMUTER, _
   m_sCDIPA00, _
   m_sCDAHV00, _
   m_sSAREC00, _
   m_sBEBERAL As SqlString

Source code

[Visual Basic]
        Private 		m_sBEGEB00, m_sBEBGO00, m_sCDMUTER, m_sCDIPA00, m_sCDAHV00, m_sSAREC00, m_sBEBERAL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siDMGEBJJ Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siDMTODJJ Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRABD00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRABE00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRBVG00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRERW00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRGST00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRSEX00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRVRN00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


m_siNRZVS00 Variable

Private 		m_siNRABE00, _
   m_siNRBVG00, _
   m_siDMTODJJ, _
   m_siNRSEX00, _
   m_siNRVRN00, _
   m_siDMGEBJJ, _
   m_siNRABD00, _
   m_siNRERW00, _
   m_siNRZVS00, _
   m_siNRGST00 As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRABE00, m_siNRBVG00, m_siDMTODJJ, m_siNRSEX00, m_siNRVRN00, m_siDMGEBJJ, m_siNRABD00, m_siNRERW00, m_siNRZVS00, m_siNRGST00 As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparn


clsEtparu Class

For a list of all members of this type, see clsEtparu Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsEtparu

Public Class clsEtparu
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsEtparu Members


clsEtparu Members

clsEtparu overview

Constructors

constructor clsEtparu Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMAFL00
property daDMERF00
property daDMGRD00
property daDMHDR00
property daTSMUT00
property dcAZBSC00
property dcNRSIC00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property sCDIPA00
property sCDMUTER
property sCDNOG01
property sCDNOG02
property sCDSWI00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siCDBRA00
property siDMAFLJJ
property siDMGRDJJ
property siNRVRN00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMAFL00
field m_daDMERF00
field m_daDMGRD00
field m_daDMHDR00
field m_daTSMUT00
field m_dcAZBSC00
field m_dcNRSIC00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_sCDIPA00
field m_sCDMUTER
field m_sCDNOG01
field m_sCDNOG02
field m_sCDSWI00
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siCDBRA00
field m_siDMAFLJJ
field m_siDMGRDJJ
field m_siNRVRN00

See Also

clsEtparu Class


clsEtparu Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu Properties

clsEtparu overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMAFL00
property daDMERF00
property daDMGRD00
property daDMHDR00
property daTSMUT00
property dcAZBSC00
property dcNRSIC00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property sCDIPA00
property sCDMUTER
property sCDNOG01
property sCDNOG02
property sCDSWI00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSAREC00
property siCDBRA00
property siDMAFLJJ
property siDMGRDJJ
property siNRVRN00

See Also

clsEtparu Class


clsEtparu.daDMAFL00 Property

Public Property [daDMAFL00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMAFL00]() As SqlDateTime
            Get
                Return m_daDMAFL00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMAFL00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daDMERF00Tmp As SqlDateTime = Value
                If daDMERF00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daDMERF00", "daDMERF00 can't be NULL")
                End If
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.daDMGRD00 Property

Public Property [daDMGRD00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMGRD00]() As SqlDateTime
            Get
                Return m_daDMGRD00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMGRD00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.daDMHDR00 Property

Public Property [daDMHDR00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMHDR00]() As SqlDateTime
            Get
                Return m_daDMHDR00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMHDR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.daTSMUT00 Property

Public Property [daTSMUT00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTSMUT00]() As SqlDateTime
            Get
                Return m_daTSMUT00
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daTSMUT00Tmp As SqlDateTime = Value
                If daTSMUT00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daTSMUT00", "daTSMUT00 can't be NULL")
                End If
                m_daTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.dcAZBSC00 Property

Public Property [dcAZBSC00]() As SqlDecimal

Source code

[Visual Basic]
        Public Property [dcAZBSC00]() As SqlDecimal
            Get
                Return m_dcAZBSC00
            End Get
            Set(ByVal Value As SqlDecimal)
                m_dcAZBSC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.dcNRSIC00 Property

Public Property [dcNRSIC00]() As SqlDecimal

Source code

[Visual Basic]
        Public Property [dcNRSIC00]() As SqlDecimal
            Get
                Return m_dcNRSIC00
            End Get
            Set(ByVal Value As SqlDecimal)
                Dim dcNRSIC00Tmp As SqlDecimal = Value
                If dcNRSIC00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("dcNRSIC00", "dcNRSIC00 can't be NULL")
                End If
                m_dcNRSIC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRPAR00Tmp As SqlInt32 = Value
                If iNRPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
                End If
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sCDIPA00 Property

Public Property [sCDIPA00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDIPA00]() As SqlString
            Get
                Return m_sCDIPA00
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDIPA00Tmp As SqlString = Value
                If sCDIPA00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDIPA00", "sCDIPA00 can't be NULL")
                End If
                m_sCDIPA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sCDMUTER Property

Public Property [sCDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDMUTER]() As SqlString
            Get
                Return m_sCDMUTER
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDMUTERTmp As SqlString = Value
                If sCDMUTERTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDMUTER", "sCDMUTER can't be NULL")
                End If
                m_sCDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sCDNOG01 Property

Public Property [sCDNOG01]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDNOG01]() As SqlString
            Get
                Return m_sCDNOG01
            End Get
            Set(ByVal Value As SqlString)
                m_sCDNOG01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sCDNOG02 Property

Public Property [sCDNOG02]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDNOG02]() As SqlString
            Get
                Return m_sCDNOG02
            End Get
            Set(ByVal Value As SqlString)
                m_sCDNOG02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sCDSWI00 Property

Public Property [sCDSWI00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDSWI00]() As SqlString
            Get
                Return m_sCDSWI00
            End Get
            Set(ByVal Value As SqlString)
                Dim sCDSWI00Tmp As SqlString = Value
                If sCDSWI00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sCDSWI00", "sCDSWI00 can't be NULL")
                End If
                m_sCDSWI00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                Dim sSAREC00Tmp As SqlString = Value
                If sSAREC00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSAREC00", "sSAREC00 can't be NULL")
                End If
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.siCDBRA00 Property

Public Property [siCDBRA00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siCDBRA00]() As SqlInt16
            Get
                Return m_siCDBRA00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siCDBRA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.siDMAFLJJ Property

Public Property [siDMAFLJJ]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siDMAFLJJ]() As SqlInt16
            Get
                Return m_siDMAFLJJ
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siDMAFLJJTmp As SqlInt16 = Value
                If siDMAFLJJTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siDMAFLJJ", "siDMAFLJJ can't be NULL")
                End If
                m_siDMAFLJJ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.siDMGRDJJ Property

Public Property [siDMGRDJJ]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siDMGRDJJ]() As SqlInt16
            Get
                Return m_siDMGRDJJ
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siDMGRDJJTmp As SqlInt16 = Value
                If siDMGRDJJTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siDMGRDJJ", "siDMGRDJJ can't be NULL")
                End If
                m_siDMGRDJJ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.siNRVRN00 Property

Public Property [siNRVRN00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRN00]() As SqlInt16
            Get
                Return m_siNRVRN00
            End Get
            Set(ByVal Value As SqlInt16)
                Dim siNRVRN00Tmp As SqlInt16 = Value
                If siNRVRN00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("siNRVRN00", "siNRVRN00 can't be NULL")
                End If
                m_siNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu Methods

clsEtparu overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsEtparu Class


clsEtparu.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparu_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparu_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparu::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparu_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siCDBRA00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siCDBRA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMGRD00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMGRD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMGRDJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMGRDJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMAFL00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMAFL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMAFLJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMAFLJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcAZBSC00", SqlDbType.Decimal, 9, ParameterDirection.Input, True, 11, 1, "", DataRowVersion.Proposed, m_dcAZBSC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMHDR00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMHDR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDIPA00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDIPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDSWI00", SqlDbType.Char, 11, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDSWI00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcNRSIC00", SqlDbType.Decimal, 5, ParameterDirection.Input, False, 6, 1, "", DataRowVersion.Proposed, m_dcNRSIC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDNOG01", SqlDbType.Char, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDNOG01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDNOG02", SqlDbType.Char, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDNOG02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparu_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparu::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparu_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("etparu")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparu_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparu::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparu_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("etparu")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparu_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    m_siNRVRN00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRN00"), Short))
                    If dtToReturn.Rows(0)("CDBRA00") Is System.DBNull.Value Then
                        m_siCDBRA00 = SqlInt16.Null
                    Else
                        m_siCDBRA00 = New SqlInt16(CType(dtToReturn.Rows(0)("CDBRA00"), Short))
                    End If
                    If dtToReturn.Rows(0)("DMGRD00") Is System.DBNull.Value Then
                        m_daDMGRD00 = SqlDateTime.Null
                    Else
                        m_daDMGRD00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMGRD00"), Date))
                    End If
                    m_siDMGRDJJ = New SqlInt16(CType(dtToReturn.Rows(0)("DMGRDJJ"), Short))
                    If dtToReturn.Rows(0)("DMAFL00") Is System.DBNull.Value Then
                        m_daDMAFL00 = SqlDateTime.Null
                    Else
                        m_daDMAFL00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMAFL00"), Date))
                    End If
                    m_siDMAFLJJ = New SqlInt16(CType(dtToReturn.Rows(0)("DMAFLJJ"), Short))
                    If dtToReturn.Rows(0)("AZBSC00") Is System.DBNull.Value Then
                        m_dcAZBSC00 = SqlDecimal.Null
                    Else
                        m_dcAZBSC00 = New SqlDecimal(CType(dtToReturn.Rows(0)("AZBSC00"), Decimal))
                    End If
                    If dtToReturn.Rows(0)("DMHDR00") Is System.DBNull.Value Then
                        m_daDMHDR00 = SqlDateTime.Null
                    Else
                        m_daDMHDR00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMHDR00"), Date))
                    End If
                    m_sCDIPA00 = New SqlString(CType(dtToReturn.Rows(0)("CDIPA00"), String))
                    m_sCDSWI00 = New SqlString(CType(dtToReturn.Rows(0)("CDSWI00"), String))
                    m_dcNRSIC00 = New SqlDecimal(CType(dtToReturn.Rows(0)("NRSIC00"), Decimal))
                    If dtToReturn.Rows(0)("CDNOG01") Is System.DBNull.Value Then
                        m_sCDNOG01 = SqlString.Null
                    Else
                        m_sCDNOG01 = New SqlString(CType(dtToReturn.Rows(0)("CDNOG01"), String))
                    End If
                    If dtToReturn.Rows(0)("CDNOG02") Is System.DBNull.Value Then
                        m_sCDNOG02 = SqlString.Null
                    Else
                        m_sCDNOG02 = New SqlString(CType(dtToReturn.Rows(0)("CDNOG02"), String))
                    End If
                    m_sCDMUTER = New SqlString(CType(dtToReturn.Rows(0)("CDMUTER"), String))
                    m_daTSMUT00 = New SqlDateTime(CType(dtToReturn.Rows(0)("TSMUT00"), Date))
                    m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparu::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_etparu_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siCDBRA00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siCDBRA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMGRD00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMGRD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMGRDJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMGRDJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMAFL00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMAFL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siDMAFLJJ", SqlDbType.SmallInt, 2, ParameterDirection.Input, False, 5, 0, "", DataRowVersion.Proposed, m_siDMAFLJJ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcAZBSC00", SqlDbType.Decimal, 9, ParameterDirection.Input, True, 11, 1, "", DataRowVersion.Proposed, m_dcAZBSC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMHDR00", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDMHDR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDIPA00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDIPA00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDSWI00", SqlDbType.Char, 11, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDSWI00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcNRSIC00", SqlDbType.Decimal, 5, ParameterDirection.Input, False, 6, 1, "", DataRowVersion.Proposed, m_dcNRSIC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDNOG01", SqlDbType.Char, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDNOG01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDNOG02", SqlDbType.Char, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDNOG02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.Char, 8, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.Char, 1, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_etparu_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsEtparu::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsEtparu Fields

clsEtparu overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMAFL00
field m_daDMERF00
field m_daDMGRD00
field m_daDMHDR00
field m_daTSMUT00
field m_dcAZBSC00
field m_dcNRSIC00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_sCDIPA00
field m_sCDMUTER
field m_sCDNOG01
field m_sCDNOG02
field m_sCDSWI00
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siCDBRA00
field m_siDMAFLJJ
field m_siDMGRDJJ
field m_siNRVRN00

See Also

clsEtparu Class


m_daDMAFL00 Variable

Private 		m_daDMERF00, _
   m_daTSMUT00, _
   m_daDMHDR00, _
   m_daDMAFL00, _
   m_daDMGRD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daTSMUT00, m_daDMHDR00, m_daDMAFL00, m_daDMGRD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_daDMERF00 Variable

Private 		m_daDMERF00, _
   m_daTSMUT00, _
   m_daDMHDR00, _
   m_daDMAFL00, _
   m_daDMGRD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daTSMUT00, m_daDMHDR00, m_daDMAFL00, m_daDMGRD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_daDMGRD00 Variable

Private 		m_daDMERF00, _
   m_daTSMUT00, _
   m_daDMHDR00, _
   m_daDMAFL00, _
   m_daDMGRD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daTSMUT00, m_daDMHDR00, m_daDMAFL00, m_daDMGRD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_daDMHDR00 Variable

Private 		m_daDMERF00, _
   m_daTSMUT00, _
   m_daDMHDR00, _
   m_daDMAFL00, _
   m_daDMGRD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daTSMUT00, m_daDMHDR00, m_daDMAFL00, m_daDMGRD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_daTSMUT00 Variable

Private 		m_daDMERF00, _
   m_daTSMUT00, _
   m_daDMHDR00, _
   m_daDMAFL00, _
   m_daDMGRD00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daTSMUT00, m_daDMHDR00, m_daDMAFL00, m_daDMGRD00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_dcAZBSC00 Variable

Private 		m_dcNRSIC00, _
   m_dcAZBSC00 As SqlDecimal

Source code

[Visual Basic]
        Private 		m_dcNRSIC00, m_dcAZBSC00 As SqlDecimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_dcNRSIC00 Variable

Private 		m_dcNRSIC00, _
   m_dcAZBSC00 As SqlDecimal

Source code

[Visual Basic]
        Private 		m_dcNRSIC00, m_dcAZBSC00 As SqlDecimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_iNRPAR00 Variable

Private 		m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sCDIPA00 Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sCDMUTER Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sCDNOG01 Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sCDNOG02 Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sCDSWI00 Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_sSAREC00 Variable

Private 		m_sCDNOG01, _
   m_sCDNOG02, _
   m_sCDIPA00, _
   m_sCDSWI00, _
   m_sSAREC00, _
   m_sCDMUTER As SqlString

Source code

[Visual Basic]
        Private 		m_sCDNOG01, m_sCDNOG02, m_sCDIPA00, m_sCDSWI00, m_sSAREC00, m_sCDMUTER As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_siCDBRA00 Variable

Private 		m_siNRVRN00, _
   m_siCDBRA00, _
   m_siDMAFLJJ, _
   m_siDMGRDJJ As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRVRN00, m_siCDBRA00, m_siDMAFLJJ, m_siDMGRDJJ As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_siDMAFLJJ Variable

Private 		m_siNRVRN00, _
   m_siCDBRA00, _
   m_siDMAFLJJ, _
   m_siDMGRDJJ As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRVRN00, m_siCDBRA00, m_siDMAFLJJ, m_siDMGRDJJ As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_siDMGRDJJ Variable

Private 		m_siNRVRN00, _
   m_siCDBRA00, _
   m_siDMAFLJJ, _
   m_siDMGRDJJ As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRVRN00, m_siCDBRA00, m_siDMAFLJJ, m_siDMGRDJJ As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


m_siNRVRN00 Variable

Private 		m_siNRVRN00, _
   m_siCDBRA00, _
   m_siDMAFLJJ, _
   m_siDMGRDJJ As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRVRN00, m_siCDBRA00, m_siDMAFLJJ, m_siDMGRDJJ As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsEtparu


clsFunktionsgruppe_reportgruppe Class

For a list of all members of this type, see clsFunktionsgruppe_reportgruppe Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsFunktionsgruppe_reportgruppe

Public Class clsFunktionsgruppe_reportgruppe
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsFunktionsgruppe_reportgruppe Members


clsFunktionsgruppe_reportgruppe Members

clsFunktionsgruppe_reportgruppe overview

Constructors

constructor clsFunktionsgruppe_reportgruppe Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppeNr
property iFunktionsgruppeReportgruppeNr
property iMandantnr
property iMutierer
property iReportgruppeNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppeNr
field m_iFunktionsgruppeReportgruppeNr
field m_iMandantnr
field m_iMutierer
field m_iReportgruppeNr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_reportgruppe Class


clsFunktionsgruppe_reportgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe Properties

clsFunktionsgruppe_reportgruppe overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppeNr
property iFunktionsgruppeReportgruppeNr
property iMandantnr
property iMutierer
property iReportgruppeNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_reportgruppe Class


clsFunktionsgruppe_reportgruppe.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.iFunktionsgruppeNr Property

Public Property [iFunktionsgruppeNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionsgruppeNr]() As SqlInt32
            Get
                Return m_iFunktionsgruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppeNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.iFunktionsgruppeReportgruppeNr Property

Public Property [iFunktionsgruppeReportgruppeNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionsgruppeReportgruppeNr]() As SqlInt32
            Get
                Return m_iFunktionsgruppeReportgruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgruppeReportgruppeNrTmp As SqlInt32 = Value
                If iFunktionsgruppeReportgruppeNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgruppeReportgruppeNr", "iFunktionsgruppeReportgruppeNr can't be NULL")
                End If
                m_iFunktionsgruppeReportgruppeNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.iReportgruppeNr Property

Public Property [iReportgruppeNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportgruppeNr]() As SqlInt32
            Get
                Return m_iReportgruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportgruppeNrTmp As SqlInt32 = Value
                If iReportgruppeNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportgruppeNr", "iReportgruppeNr can't be NULL")
                End If
                m_iReportgruppeNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe Methods

clsFunktionsgruppe_reportgruppe overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsFunktionsgruppe_reportgruppe Class


clsFunktionsgruppe_reportgruppe.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_reportgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgruppeReportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeReportgruppeNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_reportgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_reportgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_reportgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgruppeReportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_reportgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_reportgruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_reportgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_reportgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_reportgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_reportgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iFunktionsgruppeReportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeReportgruppeNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_reportgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgruppeReportgruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("FunktionsgruppeReportgruppeNr"), Integer))
                    If dtToReturn.Rows(0)("funktionsgruppeNr") Is System.DBNull.Value Then
                        m_iFunktionsgruppeNr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppeNr"), Integer))
                    End If
                    m_iReportgruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("reportgruppeNr"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_reportgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_reportgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgruppeReportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_reportgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_reportgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_reportgruppe Fields

clsFunktionsgruppe_reportgruppe overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppeNr
field m_iFunktionsgruppeReportgruppeNr
field m_iMandantnr
field m_iMutierer
field m_iReportgruppeNr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_reportgruppe Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_iFunktionsgruppeNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionsgruppeNr, _
   m_iReportgruppeNr, _
   m_iFunktionsgruppeReportgruppeNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iFunktionsgruppeNr, m_iReportgruppeNr, m_iFunktionsgruppeReportgruppeNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_iFunktionsgruppeReportgruppeNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionsgruppeNr, _
   m_iReportgruppeNr, _
   m_iFunktionsgruppeReportgruppeNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iFunktionsgruppeNr, m_iReportgruppeNr, m_iFunktionsgruppeReportgruppeNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionsgruppeNr, _
   m_iReportgruppeNr, _
   m_iFunktionsgruppeReportgruppeNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iFunktionsgruppeNr, m_iReportgruppeNr, m_iFunktionsgruppeReportgruppeNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionsgruppeNr, _
   m_iReportgruppeNr, _
   m_iFunktionsgruppeReportgruppeNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iFunktionsgruppeNr, m_iReportgruppeNr, m_iFunktionsgruppeReportgruppeNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


m_iReportgruppeNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionsgruppeNr, _
   m_iReportgruppeNr, _
   m_iFunktionsgruppeReportgruppeNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iFunktionsgruppeNr, m_iReportgruppeNr, m_iFunktionsgruppeReportgruppeNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_reportgruppe


clsFunktionsgruppe_rolle Class

For a list of all members of this type, see clsFunktionsgruppe_rolle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsFunktionsgruppe_rolle

Public Class clsFunktionsgruppe_rolle
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsFunktionsgruppe_rolle Members


clsFunktionsgruppe_rolle Members

clsFunktionsgruppe_rolle overview

Constructors

constructor clsFunktionsgruppe_rolle Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppenr
property iFunktionsgrupperollenr
property iMandantnr
property iMutierer
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppenr
field m_iFunktionsgrupperollenr
field m_iMandantnr
field m_iMutierer
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle Properties

clsFunktionsgruppe_rolle overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppenr
property iFunktionsgrupperollenr
property iMandantnr
property iMutierer
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iFunktionsgruppenr Property

Public Property [iFunktionsgruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iFunktionsgrupperollenr Property

Public Property [iFunktionsgrupperollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionsgrupperollenr]() As SqlInt32
            Get
                Return m_iFunktionsgrupperollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFunktionsgrupperollenrTmp As SqlInt32 = Value
                If iFunktionsgrupperollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFunktionsgrupperollenr", "iFunktionsgrupperollenr can't be NULL")
                End If
                m_iFunktionsgrupperollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle Methods

clsFunktionsgruppe_rolle overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsFunktionsgruppe_rolle Class


clsFunktionsgruppe_rolle.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("funktionsgruppe_rolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iFunktionsgrupperollenr = New SqlInt32(CType(dtToReturn.Rows(0)("Funktionsgrupperollenr"), Integer))
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_funktionsgruppe_rolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iFunktionsgrupperollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgrupperollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_funktionsgruppe_rolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsFunktionsgruppe_rolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsFunktionsgruppe_rolle Fields

clsFunktionsgruppe_rolle overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppenr
field m_iFunktionsgrupperollenr
field m_iMandantnr
field m_iMutierer
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsFunktionsgruppe_rolle Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_iFunktionsgruppenr Variable

Private 		m_iMutierer, _
   m_iFunktionsgruppenr, _
   m_iFunktionsgrupperollenr, _
   m_iMandantnr, _
   m_iRollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_iFunktionsgrupperollenr Variable

Private 		m_iMutierer, _
   m_iFunktionsgruppenr, _
   m_iFunktionsgrupperollenr, _
   m_iMandantnr, _
   m_iRollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iFunktionsgruppenr, _
   m_iFunktionsgrupperollenr, _
   m_iMandantnr, _
   m_iRollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iFunktionsgruppenr, _
   m_iFunktionsgrupperollenr, _
   m_iMandantnr, _
   m_iRollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


m_iRollenr Variable

Private 		m_iMutierer, _
   m_iFunktionsgruppenr, _
   m_iFunktionsgrupperollenr, _
   m_iMandantnr, _
   m_iRollenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iFunktionsgruppenr, m_iFunktionsgrupperollenr, m_iMandantnr, m_iRollenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsFunktionsgruppe_rolle


clsIdvmakro_office_vorlage Class

For a list of all members of this type, see clsIdvmakro_office_vorlage Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsIdvmakro_office_vorlage

Public Class clsIdvmakro_office_vorlage
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage Members

clsIdvmakro_office_vorlage overview

Constructors

constructor clsIdvmakro_office_vorlage Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iIdvmakronr
property iIdvmakronrOld
property iIdvmakroofficevorlagenr
property iMandantnr
property iMutierer
property iOffice_vorlagenr
property iOffice_vorlagenrOld
property iReihenfolge
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWidvmakronrLogic
method SelectAllWoffice_vorlagenrLogic
method SelectOne
method Update
method UpdateAllWidvmakronrLogic
method UpdateAllWoffice_vorlagenrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iIdvmakronr
field m_iIdvmakronrOld
field m_iIdvmakroofficevorlagenr
field m_iMandantnr
field m_iMutierer
field m_iOffice_vorlagenr
field m_iOffice_vorlagenrOld
field m_iReihenfolge
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage Properties

clsIdvmakro_office_vorlage overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iIdvmakronr
property iIdvmakronrOld
property iIdvmakroofficevorlagenr
property iMandantnr
property iMutierer
property iOffice_vorlagenr
property iOffice_vorlagenrOld
property iReihenfolge
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iIdvmakronr Property

Public Property [iIdvmakronr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIdvmakronr]() As SqlInt32
            Get
                Return m_iIdvmakronr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iIdvmakronr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iIdvmakronrOld Property

Public Property [iIdvmakronrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIdvmakronrOld]() As SqlInt32
            Get
                Return m_iIdvmakronrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iIdvmakronrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iIdvmakroofficevorlagenr Property

Public Property [iIdvmakroofficevorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iIdvmakroofficevorlagenr]() As SqlInt32
            Get
                Return m_iIdvmakroofficevorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iIdvmakroofficevorlagenrTmp As SqlInt32 = Value
                If iIdvmakroofficevorlagenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iIdvmakroofficevorlagenr", "iIdvmakroofficevorlagenr can't be NULL")
                End If
                m_iIdvmakroofficevorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMutiererTmp As SqlInt32 = Value
                If iMutiererTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMutierer", "iMutierer can't be NULL")
                End If
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iOffice_vorlagenr Property

Public Property [iOffice_vorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlagenr]() As SqlInt32
            Get
                Return m_iOffice_vorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOffice_vorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iOffice_vorlagenrOld Property

Public Property [iOffice_vorlagenrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlagenrOld]() As SqlInt32
            Get
                Return m_iOffice_vorlagenrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOffice_vorlagenrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReihenfolgeTmp As SqlInt32 = Value
                If iReihenfolgeTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReihenfolge", "iReihenfolge can't be NULL")
                End If
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage Methods

clsIdvmakro_office_vorlage overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWidvmakronrLogic
method SelectAllWoffice_vorlagenrLogic
method SelectOne
method Update
method UpdateAllWidvmakronrLogic
method UpdateAllWoffice_vorlagenrLogic

See Also

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.SelectAllWidvmakronrLogic Method

Public Function SelectAllWidvmakronrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWidvmakronrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAllWidvmakronrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAllWidvmakronrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::SelectAllWidvmakronrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.SelectAllWoffice_vorlagenrLogic Method

Public Function SelectAllWoffice_vorlagenrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWoffice_vorlagenrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAllWoffice_vorlagenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAllWoffice_vorlagenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::SelectAllWoffice_vorlagenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iIdvmakroofficevorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("idvmakroofficevorlagenr"), Integer))
                    m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
                        m_iOffice_vorlagenr = SqlInt32.Null
                    Else
                        m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("idvmakronr") Is System.DBNull.Value Then
                        m_iIdvmakronr = SqlInt32.Null
                    Else
                        m_iIdvmakronr = New SqlInt32(CType(dtToReturn.Rows(0)("idvmakronr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.UpdateAllWidvmakronrLogic Method

Public Function UpdateAllWidvmakronrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWidvmakronrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_UpdateAllWidvmakronrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakronrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_UpdateAllWidvmakronrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::UpdateAllWidvmakronrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage.UpdateAllWoffice_vorlagenrLogic Method

Public Function UpdateAllWoffice_vorlagenrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWoffice_vorlagenrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_UpdateAllWoffice_vorlagenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_UpdateAllWoffice_vorlagenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsIdvmakro_office_vorlage::UpdateAllWoffice_vorlagenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsIdvmakro_office_vorlage Fields

clsIdvmakro_office_vorlage overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iIdvmakronr
field m_iIdvmakronrOld
field m_iIdvmakroofficevorlagenr
field m_iMandantnr
field m_iMutierer
field m_iOffice_vorlagenr
field m_iOffice_vorlagenrOld
field m_iReihenfolge
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsIdvmakro_office_vorlage Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iIdvmakronr Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iIdvmakronrOld Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iIdvmakroofficevorlagenr Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iOffice_vorlagenr Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iOffice_vorlagenrOld Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


m_iReihenfolge Variable

Private 		m_iMutierer, _
   m_iOffice_vorlagenr, _
   m_iOffice_vorlagenrOld, _
   m_iIdvmakronr, _
   m_iIdvmakronrOld, _
   m_iMandantnr, _
   m_iReihenfolge, _
   m_iIdvmakroofficevorlagenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsIdvmakro_office_vorlage


clsKey_tabelle Class

For a list of all members of this type, see clsKey_tabelle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsKey_tabelle
EDOKAApp.edokadb.clsMyKey_Tabelle

Public Class clsKey_tabelle
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsKey_tabelle Members


clsKey_tabelle Members

clsKey_tabelle overview

Constructors

constructor clsKey_tabelle Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKey_wert
property iKeynr
property iMandantnr
property iMutierer
property sBeschreibung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKey_wert
field m_iKeynr
field m_iMandantnr
field m_iMutierer
field m_sBeschreibung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsKey_tabelle Class


clsKey_tabelle Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle Properties

clsKey_tabelle overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKey_wert
property iKeynr
property iMandantnr
property iMutierer
property sBeschreibung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsKey_tabelle Class


clsKey_tabelle.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.iKey_wert Property

Public Property [iKey_wert]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKey_wert]() As SqlInt32
            Get
                Return m_iKey_wert
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKey_wertTmp As SqlInt32 = Value
                If iKey_wertTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKey_wert", "iKey_wert can't be NULL")
                End If
                m_iKey_wert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.iKeynr Property

Public Property [iKeynr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKeynr]() As SqlInt32
            Get
                Return m_iKeynr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKeynrTmp As SqlInt32 = Value
                If iKeynrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKeynr", "iKeynr can't be NULL")
                End If
                m_iKeynr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBeschreibungTmp As SqlString = Value
                If sBeschreibungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
                End If
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle Methods

clsKey_tabelle overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsKey_tabelle Class


clsKey_tabelle.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("key_tabelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKeynr = New SqlInt32(CType(dtToReturn.Rows(0)("keynr"), Integer))
                    m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    m_iKey_wert = New SqlInt32(CType(dtToReturn.Rows(0)("key_wert"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_key_tabelle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKey_tabelle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKey_tabelle Fields

clsKey_tabelle overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKey_wert
field m_iKeynr
field m_iMandantnr
field m_iMutierer
field m_sBeschreibung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsKey_tabelle Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_iKey_wert Variable

Private 		m_iMutierer, _
   m_iKeynr, _
   m_iKey_wert, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_iKeynr Variable

Private 		m_iMutierer, _
   m_iKeynr, _
   m_iKey_wert, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iKeynr, _
   m_iKey_wert, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iKeynr, _
   m_iKey_wert, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


m_sBeschreibung Variable

Private 		m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKey_tabelle


clsKostenstelle Class

For a list of all members of this type, see clsKostenstelle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsKostenstelle

Public Class clsKostenstelle
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsKostenstelle Members


clsKostenstelle Members

clsKostenstelle overview

Constructors

constructor clsKostenstelle Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBankinformationnr
property iBankinformationnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKostenstellenr
property iKostenstellenummer
property iMandantnr
property iMarktbereichnr
property iMarktbereichnrOld
property iMutierer
property iNiederlassungnr
property iNiederlassungnrOld
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokument_kopfzeile

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWbankinformationnrLogic
method SelectAllWmarktbereichnrLogic
method SelectAllWniederlassungnrLogic
method SelectOne
method Update
method UpdateAllWbankinformationnrLogic
method UpdateAllWmarktbereichnrLogic
method UpdateAllWniederlassungnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBankinformationnr
field m_iBankinformationnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKostenstellenr
field m_iKostenstellenummer
field m_iMandantnr
field m_iMarktbereichnr
field m_iMarktbereichnrOld
field m_iMutierer
field m_iNiederlassungnr
field m_iNiederlassungnrOld
field m_sBeschreibung
field m_sBezeichnung
field m_sDokument_kopfzeile
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsKostenstelle Class


clsKostenstelle Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle Properties

clsKostenstelle overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBankinformationnr
property iBankinformationnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKostenstellenr
property iKostenstellenummer
property iMandantnr
property iMarktbereichnr
property iMarktbereichnrOld
property iMutierer
property iNiederlassungnr
property iNiederlassungnrOld
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokument_kopfzeile

See Also

clsKostenstelle Class


clsKostenstelle.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iBankinformationnr Property

Public Property [iBankinformationnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBankinformationnr]() As SqlInt32
            Get
                Return m_iBankinformationnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBankinformationnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iBankinformationnrOld Property

Public Property [iBankinformationnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBankinformationnrOld]() As SqlInt32
            Get
                Return m_iBankinformationnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBankinformationnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iKostenstellenr Property

Public Property [iKostenstellenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKostenstellenr]() As SqlInt32
            Get
                Return m_iKostenstellenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iKostenstellenrTmp As SqlInt32 = Value
                If iKostenstellenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iKostenstellenr", "iKostenstellenr can't be NULL")
                End If
                m_iKostenstellenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iKostenstellenummer Property

Public Property [iKostenstellenummer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKostenstellenummer]() As SqlInt32
            Get
                Return m_iKostenstellenummer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKostenstellenummer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iMarktbereichnr Property

Public Property [iMarktbereichnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMarktbereichnr]() As SqlInt32
            Get
                Return m_iMarktbereichnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMarktbereichnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iMarktbereichnrOld Property

Public Property [iMarktbereichnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMarktbereichnrOld]() As SqlInt32
            Get
                Return m_iMarktbereichnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMarktbereichnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iNiederlassungnr Property

Public Property [iNiederlassungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNiederlassungnr]() As SqlInt32
            Get
                Return m_iNiederlassungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNiederlassungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.iNiederlassungnrOld Property

Public Property [iNiederlassungnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNiederlassungnrOld]() As SqlInt32
            Get
                Return m_iNiederlassungnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNiederlassungnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.sDokument_kopfzeile Property

Public Property [sDokument_kopfzeile]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokument_kopfzeile]() As SqlString
            Get
                Return m_sDokument_kopfzeile
            End Get
            Set(ByVal Value As SqlString)
                m_sDokument_kopfzeile = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle Methods

clsKostenstelle overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWbankinformationnrLogic
method SelectAllWmarktbereichnrLogic
method SelectAllWniederlassungnrLogic
method SelectOne
method Update
method UpdateAllWbankinformationnrLogic
method UpdateAllWmarktbereichnrLogic
method UpdateAllWniederlassungnrLogic

See Also

clsKostenstelle Class


clsKostenstelle.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenummer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_kopfzeile", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_kopfzeile))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibankinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBankinformationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("kostenstelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.SelectAllWbankinformationnrLogic Method

Public Function SelectAllWbankinformationnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWbankinformationnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_SelectAllWbankinformationnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("kostenstelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ibankinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBankinformationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_SelectAllWbankinformationnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::SelectAllWbankinformationnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.SelectAllWmarktbereichnrLogic Method

Public Function SelectAllWmarktbereichnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWmarktbereichnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_SelectAllWmarktbereichnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("kostenstelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_SelectAllWmarktbereichnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::SelectAllWmarktbereichnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.SelectAllWniederlassungnrLogic Method

Public Function SelectAllWniederlassungnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWniederlassungnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_SelectAllWniederlassungnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("kostenstelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_SelectAllWniederlassungnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::SelectAllWniederlassungnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("kostenstelle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iKostenstellenr = New SqlInt32(CType(dtToReturn.Rows(0)("kostenstellenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("kostenstellenummer") Is System.DBNull.Value Then
                        m_iKostenstellenummer = SqlInt32.Null
                    Else
                        m_iKostenstellenummer = New SqlInt32(CType(dtToReturn.Rows(0)("kostenstellenummer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokument_kopfzeile") Is System.DBNull.Value Then
                        m_sDokument_kopfzeile = SqlString.Null
                    Else
                        m_sDokument_kopfzeile = New SqlString(CType(dtToReturn.Rows(0)("dokument_kopfzeile"), String))
                    End If
                    If dtToReturn.Rows(0)("marktbereichnr") Is System.DBNull.Value Then
                        m_iMarktbereichnr = SqlInt32.Null
                    Else
                        m_iMarktbereichnr = New SqlInt32(CType(dtToReturn.Rows(0)("marktbereichnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("niederlassungnr") Is System.DBNull.Value Then
                        m_iNiederlassungnr = SqlInt32.Null
                    Else
                        m_iNiederlassungnr = New SqlInt32(CType(dtToReturn.Rows(0)("niederlassungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bankinformationnr") Is System.DBNull.Value Then
                        m_iBankinformationnr = SqlInt32.Null
                    Else
                        m_iBankinformationnr = New SqlInt32(CType(dtToReturn.Rows(0)("bankinformationnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenummer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_kopfzeile", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_kopfzeile))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibankinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBankinformationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.UpdateAllWbankinformationnrLogic Method

Public Function UpdateAllWbankinformationnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWbankinformationnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_UpdateAllWbankinformationnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ibankinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iBankinformationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ibankinformationnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBankinformationnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_UpdateAllWbankinformationnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::UpdateAllWbankinformationnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.UpdateAllWmarktbereichnrLogic Method

Public Function UpdateAllWmarktbereichnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWmarktbereichnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_UpdateAllWmarktbereichnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imarktbereichnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imarktbereichnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMarktbereichnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_UpdateAllWmarktbereichnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::UpdateAllWmarktbereichnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle.UpdateAllWniederlassungnrLogic Method

Public Function UpdateAllWniederlassungnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWniederlassungnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_kostenstelle_UpdateAllWniederlassungnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iniederlassungnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_kostenstelle_UpdateAllWniederlassungnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsKostenstelle::UpdateAllWniederlassungnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsKostenstelle Fields

clsKostenstelle overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBankinformationnr
field m_iBankinformationnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKostenstellenr
field m_iKostenstellenummer
field m_iMandantnr
field m_iMarktbereichnr
field m_iMarktbereichnrOld
field m_iMutierer
field m_iNiederlassungnr
field m_iNiederlassungnrOld
field m_sBeschreibung
field m_sBezeichnung
field m_sDokument_kopfzeile
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsKostenstelle Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iBankinformationnr Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iBankinformationnrOld Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iKostenstellenr Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iKostenstellenummer Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iMandantnr Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iMarktbereichnr Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iMarktbereichnrOld Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iMutierer Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iNiederlassungnr Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_iNiederlassungnrOld Variable

Private 		m_iBankinformationnr, _
   m_iBankinformationnrOld, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iNiederlassungnr, _
   m_iNiederlassungnrOld, _
   m_iKostenstellenummer, _
   m_iKostenstellenr, _
   m_iMarktbereichnr, _
   m_iMarktbereichnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iBankinformationnr, m_iBankinformationnrOld, m_iMandantnr, m_iMutierer, m_iNiederlassungnr, m_iNiederlassungnrOld, m_iKostenstellenummer, m_iKostenstellenr, m_iMarktbereichnr, m_iMarktbereichnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sDokument_kopfzeile, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sDokument_kopfzeile, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sDokument_kopfzeile, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sDokument_kopfzeile, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


m_sDokument_kopfzeile Variable

Private 		m_sBezeichnung, _
   m_sDokument_kopfzeile, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sDokument_kopfzeile, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsKostenstelle


clsLand Class

For a list of all members of this type, see clsLand Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsLand

Public Class clsLand
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsLand Members


clsLand Members

clsLand overview

Constructors

constructor clsLand Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property fCDADRFO
property fNRLND00
property fNRLNG00
property fNRPAR00
property fNRSPR00
property fNRVRN00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sBELND00
property sCDLND02
property sCDLND03
property sCDLNDAB
property sCDLNDBU
property sCDLNDDM
property sCDLNDGR
property sCDLNDNL
property sCDLNDSQ
property sCDLNDWP
property sCDLRT00
property sCDOECZU
property sCDPSP00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNRLNDSQ
property sSAADRVF
property sSADOMKE
property sSADOMVF
property sSANATKE
property sSANATVF
property sSAREC00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_fCDADRFO
field m_fNRLND00
field m_fNRLNG00
field m_fNRPAR00
field m_fNRSPR00
field m_fNRVRN00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sBELND00
field m_sCDLND02
field m_sCDLND03
field m_sCDLNDAB
field m_sCDLNDBU
field m_sCDLNDDM
field m_sCDLNDGR
field m_sCDLNDNL
field m_sCDLNDSQ
field m_sCDLNDWP
field m_sCDLRT00
field m_sCDOECZU
field m_sCDPSP00
field m_sNRLNDSQ
field m_sSAADRVF
field m_sSADOMKE
field m_sSADOMVF
field m_sSANATKE
field m_sSANATVF
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsLand Class


clsLand Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand Properties

clsLand overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property fCDADRFO
property fNRLND00
property fNRLNG00
property fNRPAR00
property fNRSPR00
property fNRVRN00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sBELND00
property sCDLND02
property sCDLND03
property sCDLNDAB
property sCDLNDBU
property sCDLNDDM
property sCDLNDGR
property sCDLNDNL
property sCDLNDSQ
property sCDLNDWP
property sCDLRT00
property sCDOECZU
property sCDPSP00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNRLNDSQ
property sSAADRVF
property sSADOMKE
property sSADOMVF
property sSANATKE
property sSANATVF
property sSAREC00

See Also

clsLand Class


clsLand.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fCDADRFO Property

Public Property [fCDADRFO]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fCDADRFO]() As SqlDouble
            Get
                Return m_fCDADRFO
            End Get
            Set(ByVal Value As SqlDouble)
                m_fCDADRFO = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fNRLND00 Property

Public Property [fNRLND00]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fNRLND00]() As SqlDouble
            Get
                Return m_fNRLND00
            End Get
            Set(ByVal Value As SqlDouble)
                Dim fNRLND00Tmp As SqlDouble = Value
                If fNRLND00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("fNRLND00", "fNRLND00 can't be NULL")
                End If
                m_fNRLND00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fNRLNG00 Property

Public Property [fNRLNG00]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fNRLNG00]() As SqlDouble
            Get
                Return m_fNRLNG00
            End Get
            Set(ByVal Value As SqlDouble)
                m_fNRLNG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fNRPAR00 Property

Public Property [fNRPAR00]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fNRPAR00]() As SqlDouble
            Get
                Return m_fNRPAR00
            End Get
            Set(ByVal Value As SqlDouble)
                m_fNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fNRSPR00 Property

Public Property [fNRSPR00]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fNRSPR00]() As SqlDouble
            Get
                Return m_fNRSPR00
            End Get
            Set(ByVal Value As SqlDouble)
                m_fNRSPR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.fNRVRN00 Property

Public Property [fNRVRN00]() As SqlDouble

Source code

[Visual Basic]
        Public Property [fNRVRN00]() As SqlDouble
            Get
                Return m_fNRVRN00
            End Get
            Set(ByVal Value As SqlDouble)
                m_fNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sBELND00 Property

Public Property [sBELND00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBELND00]() As SqlString
            Get
                Return m_sBELND00
            End Get
            Set(ByVal Value As SqlString)
                m_sBELND00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLND02 Property

Public Property [sCDLND02]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLND02]() As SqlString
            Get
                Return m_sCDLND02
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLND02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLND03 Property

Public Property [sCDLND03]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLND03]() As SqlString
            Get
                Return m_sCDLND03
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLND03 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDAB Property

Public Property [sCDLNDAB]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDAB]() As SqlString
            Get
                Return m_sCDLNDAB
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDAB = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDBU Property

Public Property [sCDLNDBU]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDBU]() As SqlString
            Get
                Return m_sCDLNDBU
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDBU = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDDM Property

Public Property [sCDLNDDM]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDDM]() As SqlString
            Get
                Return m_sCDLNDDM
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDDM = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDGR Property

Public Property [sCDLNDGR]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDGR]() As SqlString
            Get
                Return m_sCDLNDGR
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDGR = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDNL Property

Public Property [sCDLNDNL]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDNL]() As SqlString
            Get
                Return m_sCDLNDNL
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDNL = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDSQ Property

Public Property [sCDLNDSQ]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDSQ]() As SqlString
            Get
                Return m_sCDLNDSQ
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDSQ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLNDWP Property

Public Property [sCDLNDWP]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLNDWP]() As SqlString
            Get
                Return m_sCDLNDWP
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLNDWP = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDLRT00 Property

Public Property [sCDLRT00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDLRT00]() As SqlString
            Get
                Return m_sCDLRT00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDLRT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDOECZU Property

Public Property [sCDOECZU]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDOECZU]() As SqlString
            Get
                Return m_sCDOECZU
            End Get
            Set(ByVal Value As SqlString)
                m_sCDOECZU = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sCDPSP00 Property

Public Property [sCDPSP00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDPSP00]() As SqlString
            Get
                Return m_sCDPSP00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDPSP00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sNRLNDSQ Property

Public Property [sNRLNDSQ]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRLNDSQ]() As SqlString
            Get
                Return m_sNRLNDSQ
            End Get
            Set(ByVal Value As SqlString)
                m_sNRLNDSQ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSAADRVF Property

Public Property [sSAADRVF]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAADRVF]() As SqlString
            Get
                Return m_sSAADRVF
            End Get
            Set(ByVal Value As SqlString)
                m_sSAADRVF = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSADOMKE Property

Public Property [sSADOMKE]() As SqlString

Source code

[Visual Basic]
        Public Property [sSADOMKE]() As SqlString
            Get
                Return m_sSADOMKE
            End Get
            Set(ByVal Value As SqlString)
                m_sSADOMKE = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSADOMVF Property

Public Property [sSADOMVF]() As SqlString

Source code

[Visual Basic]
        Public Property [sSADOMVF]() As SqlString
            Get
                Return m_sSADOMVF
            End Get
            Set(ByVal Value As SqlString)
                m_sSADOMVF = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSANATKE Property

Public Property [sSANATKE]() As SqlString

Source code

[Visual Basic]
        Public Property [sSANATKE]() As SqlString
            Get
                Return m_sSANATKE
            End Get
            Set(ByVal Value As SqlString)
                m_sSANATKE = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSANATVF Property

Public Property [sSANATVF]() As SqlString

Source code

[Visual Basic]
        Public Property [sSANATVF]() As SqlString
            Get
                Return m_sSANATVF
            End Get
            Set(ByVal Value As SqlString)
                m_sSANATVF = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand Methods

clsLand overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsLand Class


clsLand.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Land_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRLND00", SqlDbType.Float, 8, ParameterDirection.Input, False, 38, 0, "", DataRowVersion.Proposed, m_fNRLND00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Land_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLand::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Land_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRSPR00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRSPR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRLND00", SqlDbType.Float, 8, ParameterDirection.Input, False, 38, 0, "", DataRowVersion.Proposed, m_fNRLND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRVRN00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLND03", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLND03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLND02", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLND02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDAB", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDAB))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBELND00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBELND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRPAR00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fCDADRFO", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fCDADRFO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAADRVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAADRVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSADOMVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSADOMVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSANATVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSANATVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSANATKE", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSANATKE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSADOMKE", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSADOMKE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRLNDSQ", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRLNDSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDBU", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDBU))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDGR", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDGR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDWP", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDWP))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDDM", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDDM))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDNL", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDNL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPSP00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPSP00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRLNG00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRLNG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDSQ", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDOECZU", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDOECZU))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLRT00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLRT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Land_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLand::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Land_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Land")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Land_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLand::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Land_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Land")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@fNRLND00", SqlDbType.Float, 8, ParameterDirection.Input, False, 38, 0, "", DataRowVersion.Proposed, m_fNRLND00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Land_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    If dtToReturn.Rows(0)("NRSPR00") Is System.DBNull.Value Then
                        m_fNRSPR00 = SqlDouble.Null
                    Else
                        m_fNRSPR00 = New SqlDouble(CType(dtToReturn.Rows(0)("NRSPR00"), Double))
                    End If
                    m_fNRLND00 = New SqlDouble(CType(dtToReturn.Rows(0)("NRLND00"), Double))
                    If dtToReturn.Rows(0)("NRVRN00") Is System.DBNull.Value Then
                        m_fNRVRN00 = SqlDouble.Null
                    Else
                        m_fNRVRN00 = New SqlDouble(CType(dtToReturn.Rows(0)("NRVRN00"), Double))
                    End If
                    If dtToReturn.Rows(0)("CDLND03") Is System.DBNull.Value Then
                        m_sCDLND03 = SqlString.Null
                    Else
                        m_sCDLND03 = New SqlString(CType(dtToReturn.Rows(0)("CDLND03"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLND02") Is System.DBNull.Value Then
                        m_sCDLND02 = SqlString.Null
                    Else
                        m_sCDLND02 = New SqlString(CType(dtToReturn.Rows(0)("CDLND02"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDAB") Is System.DBNull.Value Then
                        m_sCDLNDAB = SqlString.Null
                    Else
                        m_sCDLNDAB = New SqlString(CType(dtToReturn.Rows(0)("CDLNDAB"), String))
                    End If
                    If dtToReturn.Rows(0)("BELND00") Is System.DBNull.Value Then
                        m_sBELND00 = SqlString.Null
                    Else
                        m_sBELND00 = New SqlString(CType(dtToReturn.Rows(0)("BELND00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRPAR00") Is System.DBNull.Value Then
                        m_fNRPAR00 = SqlDouble.Null
                    Else
                        m_fNRPAR00 = New SqlDouble(CType(dtToReturn.Rows(0)("NRPAR00"), Double))
                    End If
                    If dtToReturn.Rows(0)("CDADRFO") Is System.DBNull.Value Then
                        m_fCDADRFO = SqlDouble.Null
                    Else
                        m_fCDADRFO = New SqlDouble(CType(dtToReturn.Rows(0)("CDADRFO"), Double))
                    End If
                    If dtToReturn.Rows(0)("SAADRVF") Is System.DBNull.Value Then
                        m_sSAADRVF = SqlString.Null
                    Else
                        m_sSAADRVF = New SqlString(CType(dtToReturn.Rows(0)("SAADRVF"), String))
                    End If
                    If dtToReturn.Rows(0)("SADOMVF") Is System.DBNull.Value Then
                        m_sSADOMVF = SqlString.Null
                    Else
                        m_sSADOMVF = New SqlString(CType(dtToReturn.Rows(0)("SADOMVF"), String))
                    End If
                    If dtToReturn.Rows(0)("SANATVF") Is System.DBNull.Value Then
                        m_sSANATVF = SqlString.Null
                    Else
                        m_sSANATVF = New SqlString(CType(dtToReturn.Rows(0)("SANATVF"), String))
                    End If
                    If dtToReturn.Rows(0)("SANATKE") Is System.DBNull.Value Then
                        m_sSANATKE = SqlString.Null
                    Else
                        m_sSANATKE = New SqlString(CType(dtToReturn.Rows(0)("SANATKE"), String))
                    End If
                    If dtToReturn.Rows(0)("SADOMKE") Is System.DBNull.Value Then
                        m_sSADOMKE = SqlString.Null
                    Else
                        m_sSADOMKE = New SqlString(CType(dtToReturn.Rows(0)("SADOMKE"), String))
                    End If
                    If dtToReturn.Rows(0)("NRLNDSQ") Is System.DBNull.Value Then
                        m_sNRLNDSQ = SqlString.Null
                    Else
                        m_sNRLNDSQ = New SqlString(CType(dtToReturn.Rows(0)("NRLNDSQ"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDBU") Is System.DBNull.Value Then
                        m_sCDLNDBU = SqlString.Null
                    Else
                        m_sCDLNDBU = New SqlString(CType(dtToReturn.Rows(0)("CDLNDBU"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDGR") Is System.DBNull.Value Then
                        m_sCDLNDGR = SqlString.Null
                    Else
                        m_sCDLNDGR = New SqlString(CType(dtToReturn.Rows(0)("CDLNDGR"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDWP") Is System.DBNull.Value Then
                        m_sCDLNDWP = SqlString.Null
                    Else
                        m_sCDLNDWP = New SqlString(CType(dtToReturn.Rows(0)("CDLNDWP"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDDM") Is System.DBNull.Value Then
                        m_sCDLNDDM = SqlString.Null
                    Else
                        m_sCDLNDDM = New SqlString(CType(dtToReturn.Rows(0)("CDLNDDM"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLNDNL") Is System.DBNull.Value Then
                        m_sCDLNDNL = SqlString.Null
                    Else
                        m_sCDLNDNL = New SqlString(CType(dtToReturn.Rows(0)("CDLNDNL"), String))
                    End If
                    If dtToReturn.Rows(0)("CDPSP00") Is System.DBNull.Value Then
                        m_sCDPSP00 = SqlString.Null
                    Else
                        m_sCDPSP00 = New SqlString(CType(dtToReturn.Rows(0)("CDPSP00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRLNG00") Is System.DBNull.Value Then
                        m_fNRLNG00 = SqlDouble.Null
                    Else
                        m_fNRLNG00 = New SqlDouble(CType(dtToReturn.Rows(0)("NRLNG00"), Double))
                    End If
                    If dtToReturn.Rows(0)("CDLNDSQ") Is System.DBNull.Value Then
                        m_sCDLNDSQ = SqlString.Null
                    Else
                        m_sCDLNDSQ = New SqlString(CType(dtToReturn.Rows(0)("CDLNDSQ"), String))
                    End If
                    If dtToReturn.Rows(0)("CDOECZU") Is System.DBNull.Value Then
                        m_sCDOECZU = SqlString.Null
                    Else
                        m_sCDOECZU = New SqlString(CType(dtToReturn.Rows(0)("CDOECZU"), String))
                    End If
                    If dtToReturn.Rows(0)("CDLRT00") Is System.DBNull.Value Then
                        m_sCDLRT00 = SqlString.Null
                    Else
                        m_sCDLRT00 = New SqlString(CType(dtToReturn.Rows(0)("CDLRT00"), String))
                    End If
                    If dtToReturn.Rows(0)("DMERF00") Is System.DBNull.Value Then
                        m_daDMERF00 = SqlDateTime.Null
                    Else
                        m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    End If
                    If dtToReturn.Rows(0)("SAREC00") Is System.DBNull.Value Then
                        m_sSAREC00 = SqlString.Null
                    Else
                        m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLand::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Land_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRSPR00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRSPR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRLND00", SqlDbType.Float, 8, ParameterDirection.Input, False, 38, 0, "", DataRowVersion.Proposed, m_fNRLND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRVRN00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLND03", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLND03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLND02", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLND02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDAB", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDAB))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBELND00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBELND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRPAR00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fCDADRFO", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fCDADRFO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAADRVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAADRVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSADOMVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSADOMVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSANATVF", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSANATVF))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSANATKE", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSANATKE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSADOMKE", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSADOMKE))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRLNDSQ", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRLNDSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDBU", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDBU))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDGR", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDGR))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDWP", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDWP))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDDM", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDDM))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDNL", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDNL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPSP00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPSP00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fNRLNG00", SqlDbType.Float, 8, ParameterDirection.Input, True, 38, 0, "", DataRowVersion.Proposed, m_fNRLNG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLNDSQ", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLNDSQ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDOECZU", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDOECZU))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDLRT00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDLRT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.NVarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Land_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsLand::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsLand Fields

clsLand overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_fCDADRFO
field m_fNRLND00
field m_fNRLNG00
field m_fNRPAR00
field m_fNRSPR00
field m_fNRVRN00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_sBELND00
field m_sCDLND02
field m_sCDLND03
field m_sCDLNDAB
field m_sCDLNDBU
field m_sCDLNDDM
field m_sCDLNDGR
field m_sCDLNDNL
field m_sCDLNDSQ
field m_sCDLNDWP
field m_sCDLRT00
field m_sCDOECZU
field m_sCDPSP00
field m_sNRLNDSQ
field m_sSAADRVF
field m_sSADOMKE
field m_sSADOMVF
field m_sSANATKE
field m_sSANATVF
field m_sSAREC00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsLand Class


m_daDMERF00 Variable

Private 		m_daDMERF00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fCDADRFO Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fNRLND00 Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fNRLNG00 Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fNRPAR00 Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fNRSPR00 Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_fNRVRN00 Variable

Private 		m_fNRPAR00, _
   m_fCDADRFO, _
   m_fNRLNG00, _
   m_fNRVRN00, _
   m_fNRLND00, _
   m_fNRSPR00 As SqlDouble

Source code

[Visual Basic]
        Private 		m_fNRPAR00, m_fCDADRFO, m_fNRLNG00, m_fNRVRN00, m_fNRLND00, m_fNRSPR00 As SqlDouble

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sBELND00 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLND02 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLND03 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDAB Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDBU Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDDM Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDGR Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDNL Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDSQ Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLNDWP Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDLRT00 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDOECZU Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sCDPSP00 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sNRLNDSQ Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSAADRVF Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSADOMKE Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSADOMVF Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSANATKE Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSANATVF Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


m_sSAREC00 Variable

Private 		m_sCDLNDDM, _
   m_sCDLNDNL, _
   m_sCDLNDGR, _
   m_sCDLNDWP, _
   m_sCDPSP00, _
   m_sCDOECZU, _
   m_sCDLNDSQ, _
   m_sSAREC00, _
   m_sCDLRT00, _
   m_sCDLNDBU, _
   m_sBELND00, _
   m_sSAADRVF, _
   m_sCDLNDAB, _
   m_sCDLND03, _
   m_sCDLND02, _
   m_sSADOMKE, _
   m_sNRLNDSQ, _
   m_sSANATKE, _
   m_sSADOMVF, _
   m_sSANATVF As SqlString

Source code

[Visual Basic]
        Private 		m_sCDLNDDM, m_sCDLNDNL, m_sCDLNDGR, m_sCDLNDWP, m_sCDPSP00, m_sCDOECZU, m_sCDLNDSQ, m_sSAREC00, m_sCDLRT00, m_sCDLNDBU, m_sBELND00, m_sSAADRVF, m_sCDLNDAB, m_sCDLND03, m_sCDLND02, m_sSADOMKE, m_sNRLNDSQ, m_sSANATKE, m_sSADOMVF, m_sSANATVF As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsLand


clsMandant Class

For a list of all members of this type, see clsMandant Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMandant
EDOKAApp.edokaDB.clsMyMandat

Public Class clsMandant
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMandant Members


clsMandant Members

clsMandant overview

Constructors

constructor clsMandant Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMandantnr1
property iMutierer
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMandantnr1
field m_iMutierer
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMandant Class


clsMandant Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant Properties

clsMandant overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMandantnr1
property iMutierer
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMandant Class


clsMandant.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.iMandantnr1 Property

Public Property [iMandantnr1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr1]() As SqlInt32
            Get
                Return m_iMandantnr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant Methods

clsMandant overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsMandant Class


clsMandant.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr1") Is System.DBNull.Value Then
                        m_iMandantnr1 = SqlInt32.Null
                    Else
                        m_iMandantnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mandant_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMandant Fields

clsMandant overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMandantnr1
field m_iMutierer
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMandant Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMandantnr1 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_iMandantnr1 Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMandantnr1 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMandantnr1 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMandantnr1 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMandant


clsMeldungstexte Class

For a list of all members of this type, see clsMeldungstexte Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMeldungstexte

Public Class clsMeldungstexte
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMeldungstexte Members


clsMeldungstexte Members

clsMeldungstexte overview

Constructors

constructor clsMeldungstexte Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMeldungstextnr
property iMutierer
property iSprache
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sInhalt

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMeldungstextnr
field m_iMutierer
field m_iSprache
field m_sInhalt
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMeldungstexte Class


clsMeldungstexte Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte Properties

clsMeldungstexte overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMeldungstextnr
property iMutierer
property iSprache
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sInhalt

See Also

clsMeldungstexte Class


clsMeldungstexte.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.iMeldungstextnr Property

Public Property [iMeldungstextnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMeldungstextnr]() As SqlInt32
            Get
                Return m_iMeldungstextnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMeldungstextnrTmp As SqlInt32 = Value
                If iMeldungstextnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMeldungstextnr", "iMeldungstextnr can't be NULL")
                End If
                m_iMeldungstextnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSpracheTmp As SqlInt32 = Value
                If iSpracheTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSprache", "iSprache can't be NULL")
                End If
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.sInhalt Property

Public Property [sInhalt]() As SqlString

Source code

[Visual Basic]
        Public Property [sInhalt]() As SqlString
            Get
                Return m_sInhalt
            End Get
            Set(ByVal Value As SqlString)
                m_sInhalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte Methods

clsMeldungstexte overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsMeldungstexte Class


clsMeldungstexte.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("meldungstexte")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMeldungstextnr = New SqlInt32(CType(dtToReturn.Rows(0)("meldungstextnr"), Integer))
                    m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    If dtToReturn.Rows(0)("inhalt") Is System.DBNull.Value Then
                        m_sInhalt = SqlString.Null
                    Else
                        m_sInhalt = New SqlString(CType(dtToReturn.Rows(0)("inhalt"), String))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_meldungstexte_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imeldungstextnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMeldungstextnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_meldungstexte_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMeldungstexte::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMeldungstexte Fields

clsMeldungstexte overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMeldungstextnr
field m_iMutierer
field m_iSprache
field m_sInhalt
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMeldungstexte Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_iMeldungstextnr Variable

Private 		m_iMutierer, _
   m_iSprache, _
   m_iMeldungstextnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iSprache, m_iMeldungstextnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iSprache, _
   m_iMeldungstextnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iSprache, m_iMeldungstextnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_iSprache Variable

Private 		m_iMutierer, _
   m_iSprache, _
   m_iMeldungstextnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iSprache, m_iMeldungstextnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


m_sInhalt Variable

Private 		m_sInhalt As SqlString

Source code

[Visual Basic]
        Private 		m_sInhalt As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMeldungstexte


clsMitarbeiter Class

For a list of all members of this type, see clsMitarbeiter Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMitarbeiter
EDOKAApp.edokaDB.clsMyMitarbeiter

Public Class clsMitarbeiter
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMitarbeiter Members


clsMitarbeiter Members

clsMitarbeiter overview

Constructors

constructor clsMitarbeiter Constructor

Properties

property bAktiv
property bEdokaMesasge
property bEdoka_mail
property bJournalisierung
property bMailDirektVersenden
property bMailDokumentrueckgang
property bMailempfang
property bShowtip
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFuermandant
property iFunktionnr
property iKlassifizierung
property iMandantnr
property iMitarbeiternr
property iMutierer
property iPartnernr
property iSprache
property sAnrede
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEmail
property sFax
property sFunktion
property sKurzzeichen
property sName
property sRang
property sTelefon
property sTgnummer
property sUnterschrift_text
property sVorname

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bEdokaMesasge
field m_bEdoka_mail
field m_bJournalisierung
field m_bMailDirektVersenden
field m_bMailDokumentrueckgang
field m_bMailempfang
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bShowtip
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFuermandant
field m_iFunktionnr
field m_iKlassifizierung
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iPartnernr
field m_iSprache
field m_sAnrede
field m_sEmail
field m_sFax
field m_sFunktion
field m_sKurzzeichen
field m_sName
field m_sRang
field m_sTelefon
field m_sTgnummer
field m_sUnterschrift_text
field m_sVorname
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiter Class


clsMitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter Properties

clsMitarbeiter overview

Properties

property bAktiv
property bEdokaMesasge
property bEdoka_mail
property bJournalisierung
property bMailDirektVersenden
property bMailDokumentrueckgang
property bMailempfang
property bShowtip
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFuermandant
property iFunktionnr
property iKlassifizierung
property iMandantnr
property iMitarbeiternr
property iMutierer
property iPartnernr
property iSprache
property sAnrede
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEmail
property sFax
property sFunktion
property sKurzzeichen
property sName
property sRang
property sTelefon
property sTgnummer
property sUnterschrift_text
property sVorname

See Also

clsMitarbeiter Class


clsMitarbeiter.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bEdokaMesasge Property

Public Property [bEdokaMesasge]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEdokaMesasge]() As SqlBoolean
            Get
                Return m_bEdokaMesasge
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEdokaMesasge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bEdoka_mail Property

Public Property [bEdoka_mail]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEdoka_mail]() As SqlBoolean
            Get
                Return m_bEdoka_mail
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEdoka_mail = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bJournalisierung Property

Public Property [bJournalisierung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bJournalisierung]() As SqlBoolean
            Get
                Return m_bJournalisierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bJournalisierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bMailDirektVersenden Property

Public Property [bMailDirektVersenden]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bMailDirektVersenden]() As SqlBoolean
            Get
                Return m_bMailDirektVersenden
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bMailDirektVersenden = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bMailDokumentrueckgang Property

Public Property [bMailDokumentrueckgang]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bMailDokumentrueckgang]() As SqlBoolean
            Get
                Return m_bMailDokumentrueckgang
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bMailDokumentrueckgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bMailempfang Property

Public Property [bMailempfang]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bMailempfang]() As SqlBoolean
            Get
                Return m_bMailempfang
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bMailempfang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.bShowtip Property

Public Property [bShowtip]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bShowtip]() As SqlBoolean
            Get
                Return m_bShowtip
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bShowtipTmp As SqlBoolean = Value
                If bShowtipTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bShowtip", "bShowtip can't be NULL")
                End If
                m_bShowtip = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iFuermandant Property

Public Property [iFuermandant]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFuermandant]() As SqlInt32
            Get
                Return m_iFuermandant
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iFuermandantTmp As SqlInt32 = Value
                If iFuermandantTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iFuermandant", "iFuermandant can't be NULL")
                End If
                m_iFuermandant = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iFunktionnr Property

Public Property [iFunktionnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionnr]() As SqlInt32
            Get
                Return m_iFunktionnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iKlassifizierung Property

Public Property [iKlassifizierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKlassifizierung]() As SqlInt32
            Get
                Return m_iKlassifizierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKlassifizierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iPartnernr Property

Public Property [iPartnernr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPartnernr]() As SqlInt32
            Get
                Return m_iPartnernr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPartnernrTmp As SqlInt32 = Value
                If iPartnernrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPartnernr", "iPartnernr can't be NULL")
                End If
                m_iPartnernr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sAnrede Property

Public Property [sAnrede]() As SqlString

Source code

[Visual Basic]
        Public Property [sAnrede]() As SqlString
            Get
                Return m_sAnrede
            End Get
            Set(ByVal Value As SqlString)
                m_sAnrede = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sEmail Property

Public Property [sEmail]() As SqlString

Source code

[Visual Basic]
        Public Property [sEmail]() As SqlString
            Get
                Return m_sEmail
            End Get
            Set(ByVal Value As SqlString)
                m_sEmail = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sFax Property

Public Property [sFax]() As SqlString

Source code

[Visual Basic]
        Public Property [sFax]() As SqlString
            Get
                Return m_sFax
            End Get
            Set(ByVal Value As SqlString)
                m_sFax = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sFunktion Property

Public Property [sFunktion]() As SqlString

Source code

[Visual Basic]
        Public Property [sFunktion]() As SqlString
            Get
                Return m_sFunktion
            End Get
            Set(ByVal Value As SqlString)
                m_sFunktion = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sKurzzeichen Property

Public Property [sKurzzeichen]() As SqlString

Source code

[Visual Basic]
        Public Property [sKurzzeichen]() As SqlString
            Get
                Return m_sKurzzeichen
            End Get
            Set(ByVal Value As SqlString)
                m_sKurzzeichen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sName Property

Public Property [sName]() As SqlString

Source code

[Visual Basic]
        Public Property [sName]() As SqlString
            Get
                Return m_sName
            End Get
            Set(ByVal Value As SqlString)
                m_sName = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sRang Property

Public Property [sRang]() As SqlString

Source code

[Visual Basic]
        Public Property [sRang]() As SqlString
            Get
                Return m_sRang
            End Get
            Set(ByVal Value As SqlString)
                m_sRang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sTelefon Property

Public Property [sTelefon]() As SqlString

Source code

[Visual Basic]
        Public Property [sTelefon]() As SqlString
            Get
                Return m_sTelefon
            End Get
            Set(ByVal Value As SqlString)
                m_sTelefon = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sTgnummer Property

Public Property [sTgnummer]() As SqlString

Source code

[Visual Basic]
        Public Property [sTgnummer]() As SqlString
            Get
                Return m_sTgnummer
            End Get
            Set(ByVal Value As SqlString)
                m_sTgnummer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sUnterschrift_text Property

Public Property [sUnterschrift_text]() As SqlString

Source code

[Visual Basic]
        Public Property [sUnterschrift_text]() As SqlString
            Get
                Return m_sUnterschrift_text
            End Get
            Set(ByVal Value As SqlString)
                m_sUnterschrift_text = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.sVorname Property

Public Property [sVorname]() As SqlString

Source code

[Visual Basic]
        Public Property [sVorname]() As SqlString
            Get
                Return m_sVorname
            End Get
            Set(ByVal Value As SqlString)
                m_sVorname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter Methods

clsMitarbeiter overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsMitarbeiter Class


clsMitarbeiter.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailempfang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailempfang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bEdokaMesasge", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokaMesasge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfunktion", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFunktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDirektVersenden", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDirektVersenden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sRang", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDokumentrueckgang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDokumentrueckgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedoka_mail", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdoka_mail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bjournalisierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bJournalisierung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("vorname") Is System.DBNull.Value Then
                        m_sVorname = SqlString.Null
                    Else
                        m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("vorname"), String))
                    End If
                    If dtToReturn.Rows(0)("name") Is System.DBNull.Value Then
                        m_sName = SqlString.Null
                    Else
                        m_sName = New SqlString(CType(dtToReturn.Rows(0)("name"), String))
                    End If
                    If dtToReturn.Rows(0)("kurzzeichen") Is System.DBNull.Value Then
                        m_sKurzzeichen = SqlString.Null
                    Else
                        m_sKurzzeichen = New SqlString(CType(dtToReturn.Rows(0)("kurzzeichen"), String))
                    End If
                    If dtToReturn.Rows(0)("anrede") Is System.DBNull.Value Then
                        m_sAnrede = SqlString.Null
                    Else
                        m_sAnrede = New SqlString(CType(dtToReturn.Rows(0)("anrede"), String))
                    End If
                    If dtToReturn.Rows(0)("tgnummer") Is System.DBNull.Value Then
                        m_sTgnummer = SqlString.Null
                    Else
                        m_sTgnummer = New SqlString(CType(dtToReturn.Rows(0)("tgnummer"), String))
                    End If
                    If dtToReturn.Rows(0)("email") Is System.DBNull.Value Then
                        m_sEmail = SqlString.Null
                    Else
                        m_sEmail = New SqlString(CType(dtToReturn.Rows(0)("email"), String))
                    End If
                    If dtToReturn.Rows(0)("fax") Is System.DBNull.Value Then
                        m_sFax = SqlString.Null
                    Else
                        m_sFax = New SqlString(CType(dtToReturn.Rows(0)("fax"), String))
                    End If
                    If dtToReturn.Rows(0)("telefon") Is System.DBNull.Value Then
                        m_sTelefon = SqlString.Null
                    Else
                        m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("telefon"), String))
                    End If
                    If dtToReturn.Rows(0)("unterschrift_text") Is System.DBNull.Value Then
                        m_sUnterschrift_text = SqlString.Null
                    Else
                        m_sUnterschrift_text = New SqlString(CType(dtToReturn.Rows(0)("unterschrift_text"), String))
                    End If
                    If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
                        m_iFunktionnr = SqlInt32.Null
                    Else
                        m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    m_iFuermandant = New SqlInt32(CType(dtToReturn.Rows(0)("fuermandant"), Integer))
                    m_bShowtip = New SqlBoolean(CType(dtToReturn.Rows(0)("showtip"), Boolean))
                    m_iPartnernr = New SqlInt32(CType(dtToReturn.Rows(0)("partnernr"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Mailempfang") Is System.DBNull.Value Then
                        m_bMailempfang = SqlBoolean.Null
                    Else
                        m_bMailempfang = New SqlBoolean(CType(dtToReturn.Rows(0)("Mailempfang"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("EdokaMesasge") Is System.DBNull.Value Then
                        m_bEdokaMesasge = SqlBoolean.Null
                    Else
                        m_bEdokaMesasge = New SqlBoolean(CType(dtToReturn.Rows(0)("EdokaMesasge"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("funktion") Is System.DBNull.Value Then
                        m_sFunktion = SqlString.Null
                    Else
                        m_sFunktion = New SqlString(CType(dtToReturn.Rows(0)("funktion"), String))
                    End If
                    If dtToReturn.Rows(0)("MailDirektVersenden") Is System.DBNull.Value Then
                        m_bMailDirektVersenden = SqlBoolean.Null
                    Else
                        m_bMailDirektVersenden = New SqlBoolean(CType(dtToReturn.Rows(0)("MailDirektVersenden"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Rang") Is System.DBNull.Value Then
                        m_sRang = SqlString.Null
                    Else
                        m_sRang = New SqlString(CType(dtToReturn.Rows(0)("Rang"), String))
                    End If
                    If dtToReturn.Rows(0)("MailDokumentrueckgang") Is System.DBNull.Value Then
                        m_bMailDokumentrueckgang = SqlBoolean.Null
                    Else
                        m_bMailDokumentrueckgang = New SqlBoolean(CType(dtToReturn.Rows(0)("MailDokumentrueckgang"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("klassifizierung") Is System.DBNull.Value Then
                        m_iKlassifizierung = SqlInt32.Null
                    Else
                        m_iKlassifizierung = New SqlInt32(CType(dtToReturn.Rows(0)("klassifizierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("edoka_mail") Is System.DBNull.Value Then
                        m_bEdoka_mail = SqlBoolean.Null
                    Else
                        m_bEdoka_mail = New SqlBoolean(CType(dtToReturn.Rows(0)("edoka_mail"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("journalisierung") Is System.DBNull.Value Then
                        m_bJournalisierung = SqlBoolean.Null
                    Else
                        m_bJournalisierung = New SqlBoolean(CType(dtToReturn.Rows(0)("journalisierung"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailempfang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailempfang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bEdokaMesasge", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokaMesasge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfunktion", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFunktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDirektVersenden", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDirektVersenden))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sRang", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDokumentrueckgang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDokumentrueckgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bedoka_mail", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdoka_mail))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bjournalisierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bJournalisierung))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter Fields

clsMitarbeiter overview

Fields

field m_bAktiv
field m_bEdokaMesasge
field m_bEdoka_mail
field m_bJournalisierung
field m_bMailDirektVersenden
field m_bMailDokumentrueckgang
field m_bMailempfang
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bShowtip
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFuermandant
field m_iFunktionnr
field m_iKlassifizierung
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iPartnernr
field m_iSprache
field m_sAnrede
field m_sEmail
field m_sFax
field m_sFunktion
field m_sKurzzeichen
field m_sName
field m_sRang
field m_sTelefon
field m_sTgnummer
field m_sUnterschrift_text
field m_sVorname
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiter Class


m_bAktiv Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bEdokaMesasge Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bEdoka_mail Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bJournalisierung Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bMailDirektVersenden Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bMailDokumentrueckgang Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bMailempfang Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_bShowtip Variable

Private 		m_bMailempfang, _
   m_bEdokaMesasge, _
   m_bShowtip, _
   m_bAktiv, _
   m_bMailDirektVersenden, _
   m_bEdoka_mail, _
   m_bJournalisierung, _
   m_bMailDokumentrueckgang As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iFuermandant Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iFunktionnr Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iKlassifizierung Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iMandantnr Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iMitarbeiternr Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iMutierer Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iPartnernr Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_iSprache Variable

Private 		m_iPartnernr, _
   m_iKlassifizierung, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iFunktionnr, _
   m_iMitarbeiternr, _
   m_iFuermandant, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sAnrede Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sEmail Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sFax Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sFunktion Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sKurzzeichen Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sName Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sRang Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sTelefon Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sTgnummer Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sUnterschrift_text Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


m_sVorname Variable

Private 		m_sRang, _
   m_sAnrede, _
   m_sKurzzeichen, _
   m_sVorname, _
   m_sName, _
   m_sFax, _
   m_sTelefon, _
   m_sUnterschrift_text, _
   m_sFunktion, _
   m_sTgnummer, _
   m_sEmail As SqlString

Source code

[Visual Basic]
        Private 		m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter


clsMitarbeiter_funktionsgruppe Class

For a list of all members of this type, see clsMitarbeiter_funktionsgruppe Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMitarbeiter_funktionsgruppe

Public Class clsMitarbeiter_funktionsgruppe
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMitarbeiter_funktionsgruppe Members


clsMitarbeiter_funktionsgruppe Members

clsMitarbeiter_funktionsgruppe overview

Constructors

constructor clsMitarbeiter_funktionsgruppe Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppenr
property iMandantnr
property iMitarbeiter_funktionsgruppenr
property iMitarbeiternr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppenr
field m_iMandantnr
field m_iMitarbeiter_funktionsgruppenr
field m_iMitarbeiternr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe Properties

clsMitarbeiter_funktionsgruppe overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFunktionsgruppenr
property iMandantnr
property iMitarbeiter_funktionsgruppenr
property iMitarbeiternr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iFunktionsgruppenr Property

Public Property [iFunktionsgruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFunktionsgruppenr]() As SqlInt32
            Get
                Return m_iFunktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFunktionsgruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMitarbeiter_funktionsgruppenr Property

Public Property [iMitarbeiter_funktionsgruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiter_funktionsgruppenr]() As SqlInt32
            Get
                Return m_iMitarbeiter_funktionsgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiter_funktionsgruppenrTmp As SqlInt32 = Value
                If iMitarbeiter_funktionsgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiter_funktionsgruppenr", "iMitarbeiter_funktionsgruppenr can't be NULL")
                End If
                m_iMitarbeiter_funktionsgruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe Methods

clsMitarbeiter_funktionsgruppe overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsMitarbeiter_funktionsgruppe Class


clsMitarbeiter_funktionsgruppe.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiter_funktionsgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiter_funktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiter_funktionsgruppenr"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("funktionsgruppenr") Is System.DBNull.Value Then
                        m_iFunktionsgruppenr = SqlInt32.Null
                    Else
                        m_iFunktionsgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionsgruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_funktionsgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiter_funktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiter_funktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionsgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionsgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_funktionsgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter_funktionsgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiter_funktionsgruppe Fields

clsMitarbeiter_funktionsgruppe overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFunktionsgruppenr
field m_iMandantnr
field m_iMitarbeiter_funktionsgruppenr
field m_iMitarbeiternr
field m_iMutierer
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiter_funktionsgruppe Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_iFunktionsgruppenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMitarbeiternr, _
   m_iFunktionsgruppenr, _
   m_iMitarbeiter_funktionsgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMitarbeiternr, _
   m_iFunktionsgruppenr, _
   m_iMitarbeiter_funktionsgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_iMitarbeiter_funktionsgruppenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMitarbeiternr, _
   m_iFunktionsgruppenr, _
   m_iMitarbeiter_funktionsgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_iMitarbeiternr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMitarbeiternr, _
   m_iFunktionsgruppenr, _
   m_iMitarbeiter_funktionsgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iMitarbeiternr, _
   m_iFunktionsgruppenr, _
   m_iMitarbeiter_funktionsgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iMitarbeiternr, m_iFunktionsgruppenr, m_iMitarbeiter_funktionsgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiter_funktionsgruppe


clsMitarbeiterrolle Class

For a list of all members of this type, see clsMitarbeiterrolle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMitarbeiterrolle

Public Class clsMitarbeiterrolle
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMitarbeiterrolle Members


clsMitarbeiterrolle Members

clsMitarbeiterrolle overview

Constructors

constructor clsMitarbeiterrolle Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMitarbeiternr
property iMitarbeiternrOld
property iMitarbeiterrollenr
property iMutierer
property iRollenr
property iRollenrOld
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWmitarbeiternrLogic
method SelectAllWrollenrLogic
method SelectOne
method Update
method UpdateAllWmitarbeiternrLogic
method UpdateAllWrollenrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMitarbeiternr
field m_iMitarbeiternrOld
field m_iMitarbeiterrollenr
field m_iMutierer
field m_iRollenr
field m_iRollenrOld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiterrolle Class


clsMitarbeiterrolle Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle Properties

clsMitarbeiterrolle overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMitarbeiternr
property iMitarbeiternrOld
property iMitarbeiterrollenr
property iMutierer
property iRollenr
property iRollenrOld
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiterrolle Class


clsMitarbeiterrolle.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iMitarbeiternrOld Property

Public Property [iMitarbeiternrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternrOld]() As SqlInt32
            Get
                Return m_iMitarbeiternrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iMitarbeiterrollenr Property

Public Property [iMitarbeiterrollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiterrollenr]() As SqlInt32
            Get
                Return m_iMitarbeiterrollenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiterrollenrTmp As SqlInt32 = Value
                If iMitarbeiterrollenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiterrollenr", "iMitarbeiterrollenr can't be NULL")
                End If
                m_iMitarbeiterrollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.iRollenrOld Property

Public Property [iRollenrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenrOld]() As SqlInt32
            Get
                Return m_iRollenrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle Methods

clsMitarbeiterrolle overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWmitarbeiternrLogic
method SelectAllWrollenrLogic
method SelectOne
method Update
method UpdateAllWmitarbeiternrLogic
method UpdateAllWrollenrLogic

See Also

clsMitarbeiterrolle Class


clsMitarbeiterrolle.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiterrollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiterrollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiterrollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiterrollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiterrolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.SelectAllWmitarbeiternrLogic Method

Public Function SelectAllWmitarbeiternrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWmitarbeiternrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_SelectAllWmitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiterrolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_SelectAllWmitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::SelectAllWmitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.SelectAllWrollenrLogic Method

Public Function SelectAllWrollenrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWrollenrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_SelectAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiterrolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_SelectAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::SelectAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("mitarbeiterrolle")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiterrollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiterrollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iMitarbeiterrollenr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiterrollenr"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiterrollenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiterrollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.UpdateAllWmitarbeiternrLogic Method

Public Function UpdateAllWmitarbeiternrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWmitarbeiternrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_UpdateAllWmitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_UpdateAllWmitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::UpdateAllWmitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle.UpdateAllWrollenrLogic Method

Public Function UpdateAllWrollenrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWrollenrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiterrolle_UpdateAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiterrolle_UpdateAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiterrolle::UpdateAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMitarbeiterrolle Fields

clsMitarbeiterrolle overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMitarbeiternr
field m_iMitarbeiternrOld
field m_iMitarbeiterrollenr
field m_iMutierer
field m_iRollenr
field m_iRollenrOld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMitarbeiterrolle Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iMitarbeiternr Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iMitarbeiternrOld Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iMitarbeiterrollenr Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iRollenr Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


m_iRollenrOld Variable

Private 		m_iMutierer, _
   m_iMitarbeiternr, _
   m_iMitarbeiternrOld, _
   m_iMitarbeiterrollenr, _
   m_iMandantnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMitarbeiternr, m_iMitarbeiternrOld, m_iMitarbeiterrollenr, m_iMandantnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMitarbeiterrolle


clsMyDokumentDaten Class

For a list of all members of this type, see clsMyDokumentDaten Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsVorlagenfeld
EDOKAApp.edokadb.clsMyDokumentDaten

Public Class clsMyDokumentDaten
   Inherits edokadb.clsVorlagenfeld

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyDokumentDaten Members


clsMyDokumentDaten Members

clsMyDokumentDaten overview

Constructors

constructor clsMyDokumentDaten Constructor (inherited from EDOKAApp.edokadb.clsVorlagenfeld)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property bAusstiegsmakro (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property bEinstiegsmakro (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iDokumenttypnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iDokumenttypnrOld (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iMutierer (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldregelnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldregelnrOld (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sBeginntextmarke (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEndetextmarke (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sFeldname (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sTestdaten (inherited from EDOKAApp.edokadb.clsVorlagenfeld)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAll (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAllWdokumenttypnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAllWvorlagenfeldregelnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectOne (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectTestdata
method Select_IDVMakros
method Update (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method UpdateAllWdokumenttypnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method UpdateAllWvorlagenfeldregelnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyDokumentDaten Class


clsVorlagenfeld Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsMyDokumentDaten Properties

clsMyDokumentDaten overview

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property bAusstiegsmakro (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property bEinstiegsmakro (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iDokumenttypnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iDokumenttypnrOld (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iMutierer (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldregelnr (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property iVorlagenfeldregelnrOld (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sBeginntextmarke (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEndetextmarke (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sFeldname (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
property sTestdaten (inherited from EDOKAApp.edokadb.clsVorlagenfeld)

See Also

clsMyDokumentDaten Class


clsVorlagenfeld.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.bAusstiegsmakro Property

Public Property [bAusstiegsmakro]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusstiegsmakro]() As SqlBoolean
            Get
                Return m_bAusstiegsmakro
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusstiegsmakro = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.bEinstiegsmakro Property

Public Property [bEinstiegsmakro]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEinstiegsmakro]() As SqlBoolean
            Get
                Return m_bEinstiegsmakro
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEinstiegsmakro = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iDokumenttypnrOld Property

Public Property [iDokumenttypnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnrOld]() As SqlInt32
            Get
                Return m_iDokumenttypnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iVorlagenfeldnr Property

Public Property [iVorlagenfeldnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeldnr]() As SqlInt32
            Get
                Return m_iVorlagenfeldnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVorlagenfeldnrTmp As SqlInt32 = Value
                If iVorlagenfeldnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVorlagenfeldnr", "iVorlagenfeldnr can't be NULL")
                End If
                m_iVorlagenfeldnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iVorlagenfeldregelnr Property

Public Property [iVorlagenfeldregelnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeldregelnr]() As SqlInt32
            Get
                Return m_iVorlagenfeldregelnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlagenfeldregelnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.iVorlagenfeldregelnrOld Property

Public Property [iVorlagenfeldregelnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeldregelnrOld]() As SqlInt32
            Get
                Return m_iVorlagenfeldregelnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlagenfeldregelnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.sBeginntextmarke Property

Public Property [sBeginntextmarke]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeginntextmarke]() As SqlString
            Get
                Return m_sBeginntextmarke
            End Get
            Set(ByVal Value As SqlString)
                m_sBeginntextmarke = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.sEndetextmarke Property

Public Property [sEndetextmarke]() As SqlString

Source code

[Visual Basic]
        Public Property [sEndetextmarke]() As SqlString
            Get
                Return m_sEndetextmarke
            End Get
            Set(ByVal Value As SqlString)
                m_sEndetextmarke = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.sFeldname Property

Public Property [sFeldname]() As SqlString

Source code

[Visual Basic]
        Public Property [sFeldname]() As SqlString
            Get
                Return m_sFeldname
            End Get
            Set(ByVal Value As SqlString)
                m_sFeldname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.sTestdaten Property

Public Property [sTestdaten]() As SqlString

Source code

[Visual Basic]
        Public Property [sTestdaten]() As SqlString
            Get
                Return m_sTestdaten
            End Get
            Set(ByVal Value As SqlString)
                m_sTestdaten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsMyDokumentDaten Methods

clsMyDokumentDaten overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAll (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAllWdokumenttypnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectAllWvorlagenfeldregelnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectOne (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method SelectTestdata
method Select_IDVMakros
method Update (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method UpdateAllWdokumenttypnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)
method UpdateAllWvorlagenfeldregelnrLogic (inherited from EDOKAApp.edokadb.clsVorlagenfeld)

See Also

clsMyDokumentDaten Class


clsVorlagenfeld.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeginntextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeginntextmarke))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sendetextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEndetextmarke))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beinstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEinstiegsmakro))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusstiegsmakro))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stestdaten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTestdaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.SelectAllWdokumenttypnrLogic Method

Public Function SelectAllWdokumenttypnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWdokumenttypnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAllWdokumenttypnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAllWdokumenttypnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::SelectAllWdokumenttypnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.SelectAllWvorlagenfeldregelnrLogic Method

Public Function SelectAllWvorlagenfeldregelnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWvorlagenfeldregelnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAllWvorlagenfeldregelnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAllWvorlagenfeldregelnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::SelectAllWvorlagenfeldregelnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVorlagenfeldnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldnr"), Integer))
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("vorlagenfeldregelnr") Is System.DBNull.Value Then
                        m_iVorlagenfeldregelnr = SqlInt32.Null
                    Else
                        m_iVorlagenfeldregelnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldregelnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("feldname") Is System.DBNull.Value Then
                        m_sFeldname = SqlString.Null
                    Else
                        m_sFeldname = New SqlString(CType(dtToReturn.Rows(0)("feldname"), String))
                    End If
                    If dtToReturn.Rows(0)("beginntextmarke") Is System.DBNull.Value Then
                        m_sBeginntextmarke = SqlString.Null
                    Else
                        m_sBeginntextmarke = New SqlString(CType(dtToReturn.Rows(0)("beginntextmarke"), String))
                    End If
                    If dtToReturn.Rows(0)("endetextmarke") Is System.DBNull.Value Then
                        m_sEndetextmarke = SqlString.Null
                    Else
                        m_sEndetextmarke = New SqlString(CType(dtToReturn.Rows(0)("endetextmarke"), String))
                    End If
                    If dtToReturn.Rows(0)("einstiegsmakro") Is System.DBNull.Value Then
                        m_bEinstiegsmakro = SqlBoolean.Null
                    Else
                        m_bEinstiegsmakro = New SqlBoolean(CType(dtToReturn.Rows(0)("einstiegsmakro"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("ausstiegsmakro") Is System.DBNull.Value Then
                        m_bAusstiegsmakro = SqlBoolean.Null
                    Else
                        m_bAusstiegsmakro = New SqlBoolean(CType(dtToReturn.Rows(0)("ausstiegsmakro"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("testdaten") Is System.DBNull.Value Then
                        m_sTestdaten = SqlString.Null
                    Else
                        m_sTestdaten = New SqlString(CType(dtToReturn.Rows(0)("testdaten"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsMyDokumentDaten.SelectTestdata Method

Public Function SelectTestdata( _
   ByVal dokumenttypnr As Long _
) As DataTable

Parameters

dokumenttypnr
Required.

Source code

[Visual Basic]
        Public Function SelectTestdata(ByVal dokumenttypnr As Long) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[temp_sp_vorlagenfeld_Select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentDaten


clsMyDokumentDaten.Select_IDVMakros Method

Public Function Select_IDVMakros( _
   ByVal dokumenttypnr As Long _
) As DataTable

Parameters

dokumenttypnr
Required.

Source code

[Visual Basic]
        Public Function Select_IDVMakros(ByVal dokumenttypnr As Long) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_idvmakros_Select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_idvmakros_select' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("sp_idvmakros_select::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentDaten


clsVorlagenfeld.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeginntextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeginntextmarke))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sendetextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEndetextmarke))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beinstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEinstiegsmakro))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusstiegsmakro))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stestdaten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTestdaten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.UpdateAllWdokumenttypnrLogic Method

Public Function UpdateAllWdokumenttypnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWdokumenttypnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_UpdateAllWdokumenttypnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_UpdateAllWdokumenttypnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::UpdateAllWdokumenttypnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeld.UpdateAllWvorlagenfeldregelnrLogic Method

Public Function UpdateAllWvorlagenfeldregelnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWvorlagenfeldregelnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_UpdateAllWvorlagenfeldregelnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldregelnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeld_UpdateAllWvorlagenfeldregelnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeld::UpdateAllWvorlagenfeldregelnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsMyDokumentDaten Fields

clsMyDokumentDaten overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyDokumentDaten Class


clsMyDokumentart Class

For a list of all members of this type, see clsMyDokumentart Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentart
EDOKAApp.edokadb.clsMyDokumentart

Public Class clsMyDokumentart
   Inherits edokadb.clsDokumentart

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyDokumentart Members


clsMyDokumentart Members

clsMyDokumentart overview

Constructors

constructor clsMyDokumentart Constructor (inherited from EDOKAApp.edokadb.clsDokumentart)

Properties

property FirstEntry
property Geschaeftsfall
property LastEntry
property PageDirection
property Refresh
property SearchString
property SelectPartner
property bAktiv (inherited from EDOKAApp.edokadb.clsDokumentart)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsDokumentart)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsDokumentart)
property iDokumentartnr (inherited from EDOKAApp.edokadb.clsDokumentart)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex (inherited from EDOKAApp.edokadb.clsDokumentart)
property iImageindexopen (inherited from EDOKAApp.edokadb.clsDokumentart)
property iMandantnr (inherited from EDOKAApp.edokadb.clsDokumentart)
property iMutierer (inherited from EDOKAApp.edokadb.clsDokumentart)
property iParentid (inherited from EDOKAApp.edokadb.clsDokumentart)
property iSort (inherited from EDOKAApp.edokadb.clsDokumentart)
property iSprache (inherited from EDOKAApp.edokadb.clsDokumentart)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsDokumentart)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsDokumentart)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDokumentart)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDokumentart)
method LoadHostTree
method LoadTreeMenu
method LoadTreeMenu_KD
method LoadTreeMenu_Profil
method Load_FavoritenStruktur
method Load_FavoritenStruktur_dp
method Load_FavoritenStruktur_dp_MAKopie
method Load_Neue_Dokumente
method Load_Neue_Dokumente_Vollstaendig
method SelectAll (inherited from EDOKAApp.edokadb.clsDokumentart)
method SelectDokumentvorlagen
method SelectFavoritentree
method SelectHierarchy
method SelectHierarchy_By_Root
method SelectHierarchy_Favoriten
method SelectHierarchy_Favoriten_dp
method SelectHierarchy_Favoriten_dp_makopie
method SelectHierarchy_KD
method SelectHierarchy_Parametrisierung_By_Root
method SelectHierarchy_by_Partner
method SelectNeueDokumente
method SelectOne (inherited from EDOKAApp.edokadb.clsDokumentart)
method Select_Hierarchy_Profil
method Update (inherited from EDOKAApp.edokadb.clsDokumentart)
method read_to_root
method read_to_root_edex

Fields

field m_FirstEntry
field m_Geschaeftsfall
field m_LastEntry
field m_Refresh
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_pagedirection
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_searchstring
field m_selectpartner

See Also

clsMyDokumentart Class


clsMyDokumentart Properties

clsMyDokumentart overview

Properties

property FirstEntry
property Geschaeftsfall
property LastEntry
property PageDirection
property Refresh
property SearchString
property SelectPartner
property bAktiv (inherited from EDOKAApp.edokadb.clsDokumentart)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsDokumentart)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsDokumentart)
property iDokumentartnr (inherited from EDOKAApp.edokadb.clsDokumentart)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iImageindex (inherited from EDOKAApp.edokadb.clsDokumentart)
property iImageindexopen (inherited from EDOKAApp.edokadb.clsDokumentart)
property iMandantnr (inherited from EDOKAApp.edokadb.clsDokumentart)
property iMutierer (inherited from EDOKAApp.edokadb.clsDokumentart)
property iParentid (inherited from EDOKAApp.edokadb.clsDokumentart)
property iSort (inherited from EDOKAApp.edokadb.clsDokumentart)
property iSprache (inherited from EDOKAApp.edokadb.clsDokumentart)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsDokumentart)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsDokumentart)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyDokumentart Class


clsMyDokumentart.FirstEntry Property

Property FirstEntry() As Integer

Source code

[Visual Basic]
        Property FirstEntry() As Integer
            Get
                Return m_FirstEntry
            End Get
            Set(ByVal Value As Integer)
                m_FirstEntry = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Geschaeftsfall Property

Property Geschaeftsfall() As String

Source code

[Visual Basic]
        Property Geschaeftsfall() As String
            Get
                Return m_Geschaeftsfall
            End Get
            Set(ByVal Value As String)
                m_Geschaeftsfall = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.LastEntry Property

Property LastEntry() As Integer

Source code

[Visual Basic]
        Property LastEntry() As Integer
            Get
                Return m_LastEntry
            End Get
            Set(ByVal Value As Integer)
                m_LastEntry = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.PageDirection Property

Property PageDirection() As Integer

Source code

[Visual Basic]
        Property PageDirection() As Integer
            Get
                Return m_pagedirection
            End Get
            Set(ByVal Value As Integer)
                m_pagedirection = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Refresh Property

Property Refresh() As Boolean

Source code

[Visual Basic]
        Property Refresh() As Boolean
            Get
                Return m_Refresh
            End Get

            Set(ByVal Value As Boolean)
                m_Refresh = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SearchString Property

Property SearchString() As String

Source code

[Visual Basic]
        Property SearchString() As String
            Get
                Return m_searchstring
            End Get
            Set(ByVal Value As String)
                m_searchstring = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectPartner Property

Property SelectPartner() As Boolean

Source code

[Visual Basic]
        Property SelectPartner() As Boolean
            Get
                Return m_selectpartner
            End Get
            Set(ByVal Value As Boolean)
                m_selectpartner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart Methods

clsMyDokumentart overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDokumentart)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDokumentart)
method LoadHostTree
method LoadTreeMenu
method LoadTreeMenu_KD
method LoadTreeMenu_Profil
method Load_FavoritenStruktur
method Load_FavoritenStruktur_dp
method Load_FavoritenStruktur_dp_MAKopie
method Load_Neue_Dokumente
method Load_Neue_Dokumente_Vollstaendig
method SelectAll (inherited from EDOKAApp.edokadb.clsDokumentart)
method SelectDokumentvorlagen
method SelectFavoritentree
method SelectHierarchy
method SelectHierarchy_By_Root
method SelectHierarchy_Favoriten
method SelectHierarchy_Favoriten_dp
method SelectHierarchy_Favoriten_dp_makopie
method SelectHierarchy_KD
method SelectHierarchy_Parametrisierung_By_Root
method SelectHierarchy_by_Partner
method SelectNeueDokumente
method SelectOne (inherited from EDOKAApp.edokadb.clsDokumentart)
method Select_Hierarchy_Profil
method Update (inherited from EDOKAApp.edokadb.clsDokumentart)
method read_to_root
method read_to_root_edex

See Also

clsMyDokumentart Class


clsMyDokumentart.LoadHostTree Method

Public Sub LoadHostTree( _
   ByVal otv As TreeView, _
   ByVal nrpar00 As String _
)

Parameters

otv
Required.
nrpar00
Required.

Source code

[Visual Basic]
        Public Sub LoadHostTree(ByVal otv As TreeView, ByVal nrpar00 As String)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy_by_Partner(nrpar00)
            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.LoadTreeMenu Method

Public Sub LoadTreeMenu( _
   ByVal otv As TreeView, _
   ByVal Root As Integer _
)

Parameters

otv
Required.
Root
Required.

Source code

[Visual Basic]
        Public Sub LoadTreeMenu(ByVal otv As TreeView, ByVal Root As Integer)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            If Root = 0 Then
                menudata = menueintraege.SelectHierarchy
            Else
                menudata = menueintraege.SelectHierarchy_By_Root(Root)
            End If

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.LoadTreeMenu_KD Method

Public Sub LoadTreeMenu_KD( _
   ByVal otv As TreeView, _
   ByVal nrpar00 As Long _
)

Parameters

otv
Required.
nrpar00
Required.

Source code

[Visual Basic]
        Public Sub LoadTreeMenu_KD(ByVal otv As TreeView, ByVal nrpar00 As Long)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy_KD(nrpar00)

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.LoadTreeMenu_Profil Method

Public Sub LoadTreeMenu_Profil( _
   ByVal otv As TreeView, _
   ByVal Profilnr As Long, _
   ByVal nrpar00 As Long, _
   ByVal mynode As TreeNode, _
   ByVal partnerlist As Integer, _
   ByVal vollstaendig As Integer, _
   ByVal PartnerEingegeben As Boolean _
)

Parameters

otv
Required.
Profilnr
Required.
nrpar00
Required.
mynode
Required.
partnerlist
Required.
vollstaendig
Required.
PartnerEingegeben
Required.

Source code

[Visual Basic]
        Public Sub LoadTreeMenu_Profil(ByVal otv As TreeView, ByVal Profilnr As Long, ByVal nrpar00 As Long, ByVal mynode As TreeNode, ByVal partnerlist As Integer, ByVal vollstaendig As Integer, ByVal PartnerEingegeben As Boolean)
            Globals.PerfMon.insert_entry("'------ Start Load Struktur")

            '            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim hosttag As Integer

            If (partnerlist = 1 And nrpar00 = 0) Or PartnerEingegeben = True Then
                m_collDeletedNodes = Nothing
                m_collDeletedNodes = New Collection()
                otv.Nodes.Clear()
            End If
            '           menueintraege.cpMainConnectionProvider = conn
            Me.cpMainConnectionProvider = conn
            hosttag = 0
            Try
                If otv.SelectedNode.Text = "HOST " Then hosttag = 998
            Catch
                hosttag = 0
            End Try

            menudata = Select_Hierarchy_Profil(Profilnr, nrpar00, partnerlist, vollstaendig, PartnerEingegeben, hosttag)
            Try
                If menudata.Rows.Count = 0 Then Exit Sub
            Catch
                Exit Sub
            End Try
            If hosttag = 998 Then
                tnParent = mynode
                If menudata.Rows.Count = 0 Then
                    tnNew = tnParent.Nodes.Add("Keine Hostdokumente vorhanden")
                    Exit Sub
                End If

                tnParent = otv.SelectedNode
                For i = 2 To menudata.Rows.Count - 1
                    If menudata.Rows(i).Item("parentid") = 3 Then
                        tnParent = mynode
                    Else
                        tnParent = CType(collNodeKeys.Item(CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("parentid")), String)), TreeNode)
                    End If
                    tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                    With tnNew
                        .Tag() = CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String)
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndex")
                    End With
                    collNodeKeys.Add(tnNew, CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String))
                Next
                Exit Sub
            End If

            If (partnerlist = 1 And nrpar00 = 0) Or PartnerEingegeben = True Then
                'partnerliste aufbereiten
                For i = 0 To menudata.Rows.Count - 1
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("partner"))
                    With tnNew
                        .Tag = CType(Str(menudata.Rows(i).Item("nrpar00")), String)
                        .ImageIndex = menudata.Rows(i).Item("imageindex")
                        .SelectedImageIndex = menudata.Rows(i).Item("imageindexopen")
                        Try
                            If menudata.Rows(i).Item("saldiert") = True Then
                                'tnNew.BackColor = System.Drawing.Color.Yellow
                                'tnNew.NodeFont = New System.Drawing.Font(otv.Font.FontFamily, otv.Font.Size, FontStyle.Strikeout)
                                '   tnNew.NodeFont = New System.Drawing.Font(otv.Font.FontFamily, otv.Font.Size, FontStyle.Italic)
                                tnNew.BackColor = System.Drawing.Color.LightGray
                                tnNew.ImageIndex = 66
                                tnNew.SelectedImageIndex = 66
                                'tnNew.ForeColor = System.Drawing.Color.Blue (Nicht möglich, da markierte Einträge bereits Rot sind
                            End If
                        Catch
                        End Try
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(Str(menudata.Rows(i).Item("nrpar00")), String))
                        '                        MsgBox(CType(Str(menudata.Rows(i).Item("partnernr")) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String))
                        tnNew = tnNew.Nodes.Add("")
                        '                   tnNew.Tag = "Dummy"
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Next

                'partnerliste aufbereiten
                'For i = 0 To menudata.Rows.Count - 1
                '    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("partner"))
                '    With tnNew
                '        .Tag = CType(Str(menudata.Rows(i).Item("nrpar00")), String)
                '        .ImageIndex = menudata.Rows(i).Item("imageindex")
                '        .SelectedImageIndex = menudata.Rows(i).Item("imageindexopen")
                '    End With
                '    Try
                '        collNodeKeys.Add(tnNew, CType(Str(menudata.Rows(i).Item("nrpar00")), String))
                '        '                        MsgBox(CType(Str(menudata.Rows(i).Item("partnernr")) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String))
                '        tnNew = tnNew.Nodes.Add("")
                '        '                   tnNew.Tag = "Dummy"
                '    Catch ex As Exception
                '        MsgBox(ex.Message, MsgBoxStyle.Critical)
                '    End Try
                'Next
            Else
                'Dokumentstruktur aufbereiten
                For i = 0 To menudata.Rows.Count - 1
                    If menudata.Rows(i).Item("ParentID") <> 0 Then
                        Try
                            If menudata.Rows(i).Item("parentid") > 1 Then
                                If menudata.Rows(i).Item("parentid") = 2 Then
                                    tnParent = mynode
                                Else
                                    tnParent = CType(collNodeKeys.Item(CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("parentid")), String)), TreeNode)
                                End If
                                tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                                With tnNew
                                    .Tag() = CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String)
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                                End With
                                'MsgBox(menudata.Rows(i).Item("bezeichnung") & "/")
                                collNodeKeys.Add(tnNew, CType(Str(nrpar00) + "-" + Str(menudata.Rows(i).Item("dokumentartnr")), String))
                                'If menudata.Rows(i).Item("dokumentartnr") = 998 Then tnNew.Nodes.Add("")
                            End If

                        Catch ex As Exception
                            MsgBox(ex.Message, MsgBoxStyle.Critical)
                        End Try
                    End If
                Next
            End If
            Globals.PerfMon.insert_entry("'------ Ende Load Struktur")
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Load_FavoritenStruktur Method

Public Sub Load_FavoritenStruktur( _
   ByVal otv As TreeView, _
   ByVal searchstring As String, _
   ByVal Favoriten As Boolean, _
   Optional ByVal IconOffset As Integer = 0 _
)

Parameters

otv
Required.
searchstring
Required.
Favoriten
Required.
IconOffset
Optional. Default value is 0.

Source code

[Visual Basic]
        Public Sub Load_FavoritenStruktur(ByVal otv As TreeView, ByVal searchstring As String, ByVal Favoriten As Boolean, Optional ByVal IconOffset As Integer = 0)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim lastid As Long
            Dim pid As Long
            lastid = 0
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy_Favoriten
            For i = 0 To menudata.Rows.Count - 1

                'If Microsoft.VisualBasic.Right(menudata.Rows(i).Item("ParentID"), 1) = 0 And Len(menudata.Rows(i).Item("Parentid")) < 5 Then
                If Microsoft.VisualBasic.Left(menudata.Rows(i).Item("Parentid"), 4) = "FS_0" Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("strukturnr")
                        '                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("Strukturnr"), String))
                        '                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        'Wenn es sich nicht um das Icon 1 = Folder handelt wird der Offset der Icon dazugezählt
                        'Offset ist >0 wenn in einer Imagelist bereits Icon enthält, bevor die Dokstruktur geladen ist
                        With tnNew
                            '.Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                            .Tag() = CType(menudata.Rows(i).Item("strukturnr"), String)
                            If menudata.Rows(i).Item("ImageIndex") > 1 Then
                                .ImageIndex() = menudata.Rows(i).Item("ImageIndex") + IconOffset
                                .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen") + IconOffset
                            Else
                                .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                            End If
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("strukturnr"), String))
                        '                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Load_FavoritenStruktur_dp Method

Public Sub Load_FavoritenStruktur_dp( _
   ByVal otv As TreeView, _
   ByVal searchstring As String, _
   ByVal Favoriten As Boolean, _
   Optional ByVal IconOffset As Integer = 0 _
)

Parameters

otv
Required.
searchstring
Required.
Favoriten
Required.
IconOffset
Optional. Default value is 0.

Source code

[Visual Basic]
        Public Sub Load_FavoritenStruktur_dp(ByVal otv As TreeView, ByVal searchstring As String, ByVal Favoriten As Boolean, Optional ByVal IconOffset As Integer = 0)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim lastid As Long
            Dim pid As Long
            lastid = 0
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy_Favoriten_dp
            Dim DPRoot As Integer = 0

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("imageindex") = 68 Then
                    DPRoot = 1
                End If
                If DPRoot = 1 Then
                    If Microsoft.VisualBasic.Right(menudata.Rows(i).Item("ParentID"), 1) = 0 Then
                        tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                        With tnNew
                            .Tag() = menudata.Rows(i).Item("dokumentartnr")
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        Try
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Catch ex As Exception
                            MsgBox(ex.Message, MsgBoxStyle.Critical)
                        End Try
                    Else
                        Try
                            tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                            'Wenn es sich nicht um das Icon 1 = Folder handelt wird der Offset der Icon dazugezählt
                            'Offset ist >0 wenn in einer Imagelist bereits Icon enthält, bevor die Dokstruktur geladen ist
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                If menudata.Rows(i).Item("ImageIndex") > 1 Then
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex") + IconOffset
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen") + IconOffset
                                Else
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                                End If
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Catch ex As Exception
                            MsgBox(ex.Message, MsgBoxStyle.Critical)
                        End Try
                    End If
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Load_FavoritenStruktur_dp_MAKopie Method

Public Sub Load_FavoritenStruktur_dp_MAKopie( _
   ByVal mitarbeiternr As Integer, _
   ByVal otv As TreeView, _
   ByVal searchstring As String, _
   ByVal Favoriten As Boolean, _
   Optional ByVal IconOffset As Integer = 0 _
)

Parameters

mitarbeiternr
Required.
otv
Required.
searchstring
Required.
Favoriten
Required.
IconOffset
Optional. Default value is 0.

Source code

[Visual Basic]
        Public Sub Load_FavoritenStruktur_dp_MAKopie(ByVal mitarbeiternr As Integer, ByVal otv As TreeView, ByVal searchstring As String, ByVal Favoriten As Boolean, Optional ByVal IconOffset As Integer = 0)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim lastid As Long
            Dim pid As Long
            lastid = 0
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy_Favoriten_dp_makopie(mitarbeiternr)
            Dim DPRoot As Integer = 0

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("imageindex") = 68 Then
                    DPRoot = 1
                End If
                If DPRoot = 1 Then
                    If Microsoft.VisualBasic.Right(menudata.Rows(i).Item("ParentID"), 1) = 0 Then
                        tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                        With tnNew
                            .Tag() = menudata.Rows(i).Item("dokumentartnr")
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        Try
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Catch ex As Exception
                            MsgBox(ex.Message, MsgBoxStyle.Critical)
                        End Try
                    Else
                        Try
                            tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                            'Wenn es sich nicht um das Icon 1 = Folder handelt wird der Offset der Icon dazugezählt
                            'Offset ist >0 wenn in einer Imagelist bereits Icon enthält, bevor die Dokstruktur geladen ist
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                If menudata.Rows(i).Item("ImageIndex") > 1 Then
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex") + IconOffset
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen") + IconOffset
                                Else
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                                End If
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Catch ex As Exception
                            MsgBox(ex.Message, MsgBoxStyle.Critical)
                        End Try
                    End If
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Load_Neue_Dokumente Method

Public Sub Load_Neue_Dokumente( _
   ByVal otv As TreeView, _
   ByVal searchstring As String, _
   ByVal Favoriten As Boolean, _
   ByVal filter As Integer _
)

Parameters

otv
Required.
searchstring
Required.
Favoriten
Required.
filter
Required.

Source code

[Visual Basic]
        Public Sub Load_Neue_Dokumente(ByVal otv As TreeView, ByVal searchstring As String, ByVal Favoriten As Boolean, ByVal filter As Integer)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim lastid As String
            Dim pid As String
            lastid = 1
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            If Globals.Vorlagendata.Rows.Count = 0 Or Me.Refresh = True Or filter <> 0 Then
                menueintraege.cpMainConnectionProvider = conn
                menudata = menueintraege.SelectNeueDokumente(searchstring, Favoriten, filter)
                If filter = 0 Then Globals.Vorlagendata = menudata
            Else
                If searchstring = "" Then
                    menudata = Globals.Vorlagendata
                Else
                    Dim splitter
                    Dim sstring As String = ""
                    If InStr(searchstring, " ", CompareMethod.Text) > 0 Then
                        splitter = Microsoft.VisualBasic.Split(searchstring, " ")
                        Try
                            i = 0
                            While i < 100
                                If sstring.Length > 0 Then sstring = sstring + " AND "
                                sstring = sstring + "dt_bezeichnung like '%" + splitter(i) + "%'"
                                i = i + 1
                            End While
                        Catch
                            sstring = Left(sstring, sstring.Length - 5)
                        End Try
                    Else
                        sstring = "dt_bezeichnung like '%" + searchstring + "%'"
                    End If
                    '                    searchstring = searchstring.Replace(" ", "%")
                    '                    Dim dview As New DataView(Globals.Vorlagendata, "dt_bezeichnung like '%" + searchstring + "%'", "Parentid, sort", DataViewRowState.CurrentRows)
                    'Dim dview As New DataView(Globals.Vorlagendata, sstring, "Parentid, sort", DataViewRowState.CurrentRows)
                    Dim dview As New DataView(Globals.Vorlagendata, sstring, "sort,dt_bezeichnung", DataViewRowState.CurrentRows)
                    Dim tbltemp As New DataTable()
                    Dim tbltemp1 As New DataTable()
                    tbltemp = dview.Table.Clone
                    Dim drv As DataRowView
                    For Each drv In dview
                        tbltemp.ImportRow(drv.Row)
                        Try
                            read_to_root(drv, tbltemp)
                        Catch ex As Exception
                            MsgBox(ex.Message)
                        End Try
                    Next
                    'Globals.Vorlagendata.Select()
                    dview.Dispose()
                    tbltemp1 = dview.Table.Clone
                    Try
                        'Dim dview2 As New DataView(tbltemp, "", "ParentID, Sort", DataViewRowState.CurrentRows)
                        Dim dview2 As New DataView(tbltemp, "", "Sort, dt_bezeichnung", DataViewRowState.CurrentRows)
                        Dim drv2 As DataRowView
                        For Each drv2 In dview2
                            tbltemp1.ImportRow(drv2.Row)
                        Next
                        menudata = tbltemp1
                    Catch ex As Exception
                    End Try

                    '       menueintraege.cpMainConnectionProvider = conn
                    '      menudata = menueintraege.SelectNeueDokumente(searchstring, Favoriten, filter)
                End If
            End If

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = "DA_0" Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        If menudata.Rows(i).Item("dt_bezeichnung") Is System.DBNull.Value Then
                            tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Else
                            If lastid <> menudata.Rows(i).Item("dokumentartnr") Then
                                tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                                tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                                With tnNew
                                    .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                                End With
                                collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                                lastid = menudata.Rows(i).Item("dokumentartnr")
                                pid = lastid
                            End If
                            tnParent = CType(collNodeKeys.Item(CType(pid, String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("dt_bezeichnung"), String))
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumenttypnr"), String)
                                .ImageIndex() = menudata.Rows(i).Item("dokimage")
                                .SelectedImageIndex() = menudata.Rows(i).Item("dokimage")
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumenttypnr"), String))
                        End If
                    Catch ex As Exception
                        MsgBox("Dokart:" & menudata.Rows(i).Item("dokumentartnr") & " - " & menudata.Rows(i).Item("dokumenttypnr") & ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Load_Neue_Dokumente_Vollstaendig Method

Public Sub Load_Neue_Dokumente_Vollstaendig( _
   ByVal otv As TreeView, _
   ByVal searchstring As String, _
   ByVal Favoriten As Boolean, _
   ByVal filter As Integer _
)

Parameters

otv
Required.
searchstring
Required.
Favoriten
Required.
filter
Required.

Source code

[Visual Basic]
        Public Sub Load_Neue_Dokumente_Vollstaendig(ByVal otv As TreeView, ByVal searchstring As String, ByVal Favoriten As Boolean, ByVal filter As Integer)
            Dim menueintraege As New clsMyDokumentart()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode
            Dim lastid As String
            Dim pid As String
            lastid = 1
            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()
            otv.Nodes.Clear()
            If Globals.Vorlagendata_Vollstaendig.Rows.Count = 0 Or Me.Refresh = True Or filter <> 0 Then
                menueintraege.cpMainConnectionProvider = conn
                menudata = menueintraege.SelectDokumentvorlagen(searchstring, Favoriten, filter)
                If filter = 0 Then Globals.Vorlagendata_Vollstaendig = menudata
            Else
                If searchstring = "" Then
                    menudata = Globals.Vorlagendata_Vollstaendig
                Else
                    Dim splitter
                    Dim sstring As String = ""
                    If InStr(searchstring, " ", CompareMethod.Text) > 0 Then
                        splitter = Microsoft.VisualBasic.Split(searchstring, " ")
                        Try
                            i = 0
                            While i < 100
                                If sstring.Length > 0 Then sstring = sstring + " AND "
                                sstring = sstring + "dt_bezeichnung like '%" + splitter(i) + "%'"
                                i = i + 1
                            End While
                        Catch
                            sstring = Left(sstring, sstring.Length - 5)
                        End Try
                    Else
                        sstring = "dt_bezeichnung like '%" + searchstring + "%'"
                    End If
                    '                    searchstring = searchstring.Replace(" ", "%")
                    '                    Dim dview As New DataView(Globals.Vorlagendata, "dt_bezeichnung like '%" + searchstring + "%'", "Parentid, sort", DataViewRowState.CurrentRows)
                    Dim dview As New DataView(Globals.Vorlagendata_Vollstaendig, sstring, "sort, dt_bezeichnung", DataViewRowState.CurrentRows)
                    Dim tbltemp As New DataTable()
                    Dim tbltemp1 As New DataTable()
                    tbltemp = dview.Table.Clone
                    Dim drv As DataRowView
                    For Each drv In dview
                        tbltemp.ImportRow(drv.Row)
                        Try
                            read_to_root_edex(drv, tbltemp)
                        Catch ex As Exception
                            MsgBox(ex.Message)
                        End Try
                    Next
                    'Globals.Vorlagendata.Select()
                    dview.Dispose()
                    tbltemp1 = dview.Table.Clone
                    Try
                        Dim dview2 As New DataView(tbltemp, "", "sort, dt_bezeichnung", DataViewRowState.CurrentRows)
                        Dim drv2 As DataRowView
                        For Each drv2 In dview2
                            tbltemp1.ImportRow(drv2.Row)
                        Next
                        menudata = tbltemp1
                    Catch ex As Exception
                    End Try

                    '       menueintraege.cpMainConnectionProvider = conn
                    '      menudata = menueintraege.SelectNeueDokumente(searchstring, Favoriten, filter)
                End If
            End If

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = "DA_0" Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("dokumentartnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        If menudata.Rows(i).Item("dt_bezeichnung") Is System.DBNull.Value Then
                            tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                        Else
                            If lastid <> menudata.Rows(i).Item("dokumentartnr") Then
                                tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                                tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                                With tnNew
                                    .Tag() = CType(menudata.Rows(i).Item("dokumentartnr"), String)
                                    .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                                    .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                                End With
                                collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumentartnr"), String))
                                lastid = menudata.Rows(i).Item("dokumentartnr")
                                pid = lastid
                            End If
                            tnParent = CType(collNodeKeys.Item(CType(pid, String)), TreeNode)
                            tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("dt_bezeichnung"), String))
                            With tnNew
                                .Tag() = CType(menudata.Rows(i).Item("dokumenttypnr"), String)
                                .ImageIndex() = menudata.Rows(i).Item("dokimage")
                                .SelectedImageIndex() = menudata.Rows(i).Item("dokimage")
                            End With
                            collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("dokumenttypnr"), String))
                        End If
                    Catch ex As Exception
                        MsgBox("Dokart:" & menudata.Rows(i).Item("dokumentartnr") & " - " & menudata.Rows(i).Item("dokumenttypnr") & ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectDokumentvorlagen Method

Public Function SelectDokumentvorlagen( _
   ByVal searchstring As String, _
   ByVal favoriten As Boolean, _
   ByVal filter As Integer _
) As DataTable

Parameters

searchstring
Required.
favoriten
Required.
filter
Required.

Source code

[Visual Basic]
        Public Function SelectDokumentvorlagen(ByVal searchstring As String, ByVal favoriten As Boolean, ByVal filter As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_sp_dokumentvorlagen]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, searchstring))
                If favoriten = True Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@favoriten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@favoriten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, filter))
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'edex_sp_dokumentvorlagen' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("select_neue_dokumentstruktur::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectFavoritentree Method

Public Function SelectFavoritentree( _
   ByVal Mitarbeiternr As Long _
) As DataTable

Parameters

Mitarbeiternr
Required.

Source code

[Visual Basic]
        Public Function SelectFavoritentree(ByVal Mitarbeiternr As Long) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_favoriten_tree]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("select_neue_dokumentstruktur::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy Method

Public Function SelectHierarchy() As DataTable

Source code

[Visual Basic]
        Public Function SelectHierarchy() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_dokumentart_hierarchie]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_By_Root Method

Public Function SelectHierarchy_By_Root( _
   ByVal Root As Integer _
) As DataTable

Parameters

Root
Required.

Source code

[Visual Basic]
        Public Function SelectHierarchy_By_Root(ByVal Root As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_dokart_tree]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRoot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Root))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_Favoriten Method

Public Function SelectHierarchy_Favoriten() As DataTable

Source code

[Visual Basic]
        Public Function SelectHierarchy_Favoriten() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_sp_favoriten_select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsdokumentart:select_hierarchy_kd." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_Favoriten_dp Method

Public Function SelectHierarchy_Favoriten_dp() As DataTable

Source code

[Visual Basic]
        Public Function SelectHierarchy_Favoriten_dp() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_sp_favoritenhierarchie_select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsdokumentart:select_hierarchy_kd." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_Favoriten_dp_makopie Method

Public Function SelectHierarchy_Favoriten_dp_makopie( _
   ByVal mitarbeiternr As Integer _
) As DataTable

Parameters

mitarbeiternr
Required.

Source code

[Visual Basic]
        Public Function SelectHierarchy_Favoriten_dp_makopie(ByVal mitarbeiternr As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[edex_sp_favoritenhierarchie_select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, mitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsdokumentart:select_hierarchy_kd." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_KD Method

Public Function SelectHierarchy_KD( _
   ByVal nrpar00 As Long _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function SelectHierarchy_KD(ByVal nrpar00 As Long) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_trefferliste_select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("Dokumentart")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsdokumentart:select_hierarchy_kd." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_Parametrisierung_By_Root Method

Public Function SelectHierarchy_Parametrisierung_By_Root( _
   ByVal Root As Integer _
) As DataTable

Parameters

Root
Required.

Source code

[Visual Basic]
        Public Function SelectHierarchy_Parametrisierung_By_Root(ByVal Root As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_dokart_tree_parametrisierung]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iRoot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Root))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectHierarchy_by_Partner Method

Public Function SelectHierarchy_by_Partner( _
   ByVal nrpar00 As String _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function SelectHierarchy_by_Partner(ByVal nrpar00 As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_partner_hostdokument_struktur_select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.VarChar, 11, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.SelectNeueDokumente Method

Public Function SelectNeueDokumente( _
   ByVal searchstring As String, _
   ByVal favoriten As Boolean, _
   ByVal filter As Integer _
) As DataTable

Parameters

searchstring
Required.
favoriten
Required.
filter
Required.

Source code

[Visual Basic]
        Public Function SelectNeueDokumente(ByVal searchstring As String, ByVal favoriten As Boolean, ByVal filter As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_struktur_neue_dokumente]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("TMPTable")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, searchstring))
                If favoriten = True Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@favoriten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@favoriten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@type", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, filter))
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("select_neue_dokumentstruktur::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.Select_Hierarchy_Profil Method

Public Function Select_Hierarchy_Profil( _
   ByVal Profilnr As Long, _
   ByVal nrpar00 As Long, _
   ByVal partnerlist As Integer, _
   ByVal vollstaendig As Integer, _
   ByVal PartnerEingegeben As Boolean, _
   ByVal hosttag As Integer _
) As DataTable

Parameters

Profilnr
Required.
nrpar00
Required.
partnerlist
Required.
vollstaendig
Required.
PartnerEingegeben
Required.
hosttag
Required.

Source code

[Visual Basic]
        Public Function Select_Hierarchy_Profil(ByVal Profilnr As Long, ByVal nrpar00 As Long, ByVal partnerlist As Integer, ByVal vollstaendig As Integer, ByVal PartnerEingegeben As Boolean, ByVal hosttag As Integer) As DataTable
            Globals.PerfMon.insert_entry("'------ Start Select Hierarchy_Profil")
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_trefferliste_getdata_new]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable()
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Profilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doklist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@partnerlist", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistdokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, hosttag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@doklistpartnernr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@vollstaendig", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, vollstaendig))
                If PartnerEingegeben Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnereingegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@partnereingegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihasmessage", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@firstentry", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.FirstEntry))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@lastentry", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.LastEntry))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@pagedirection", SqlDbType.Int, 4, ParameterDirection.InputOutput, True, 10, 0, "", DataRowVersion.Proposed, Me.PageDirection))
                If Me.SearchString <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.SearchString))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@searchstring", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                End If
                If Me.Geschaeftsfall <> "" Then
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.Geschaeftsfall))
                Else
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                End If

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))
                Dim hasmessage As Integer
                If scmCmdToExecute.Parameters.Item("@ihasmessage").Value = 1 Then
                    If hosttag = 0 Then Globals.hasmessage = 1
                Else
                    Globals.hasmessage = 0
                End If

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    MsgBox("sp_trefferliste_getdata:ErrorCode: " + m_iErrorCode.ToString)
                    ' // Throw error.
                    '                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If
                If Me.SelectPartner Then
                    Try
                        Me.FirstEntry = dtToReturn.Rows(0).Item("nrpar00")
                        Me.LastEntry = dtToReturn.Rows(dtToReturn.Rows.Count - 1).Item("nrpar00")
                        Me.PageDirection = scmCmdToExecute.Parameters.Item("@PageDirection").Value
                    Catch
                        Me.FirstEntry = 0
                        Me.LastEntry = 0
                    End Try
                End If

                Return dtToReturn
            Catch ex As Exception
                Try
                    'MyMsg.show_standardmessage(22, MsgBoxStyle.Information)
                    MsgBox(ex.Message)
                Catch
                End Try
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                Globals.PerfMon.insert_entry("'------ Ende Select Hierarchy_Profil")
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.read_to_root Method

Function read_to_root( _
   ByVal drv As DataRowView, _
   ByVal dt As DataTable _
)

Parameters

drv
Required.
dt
Required.

Source code

[Visual Basic]
        Function read_to_root(ByVal drv As DataRowView, ByVal dt As DataTable)
            Dim parent As String
            parent = drv.Item(4)
            While parent <> "DA_0"
                Dim dview As New DataView(Globals.Vorlagendata, "dokumentartnr= '" + Trim(parent) + "'", "Parentid, sort", DataViewRowState.CurrentRows)
                Dim drv1 As DataRowView
                For Each drv1 In dview
                    Dim dview1 As New DataView(dt, "dokumentartnr='" + Trim(drv1.Item(0)) + "'", "", DataViewRowState.CurrentRows)
                    Dim drv2 As DataRowView
                    Dim i As Integer
                    i = 0
                    For Each drv2 In dview1
                        i = i + 1
                    Next
                    dview1.Dispose()
                    If i = 0 Then dt.ImportRow(drv1.Row)
                    parent = drv1.Item(4)
                    dview.Dispose()
                Next
            End While
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart.read_to_root_edex Method

Function read_to_root_edex( _
   ByVal drv As DataRowView, _
   ByVal dt As DataTable _
)

Parameters

drv
Required.
dt
Required.

Source code

[Visual Basic]
        Function read_to_root_edex(ByVal drv As DataRowView, ByVal dt As DataTable)
            Dim parent As String
            parent = drv.Item(4)
            While parent <> "DA_0"
                Dim dview As New DataView(Globals.Vorlagendata_Vollstaendig, "dokumentartnr= '" + Trim(parent) + "'", "Parentid, sort", DataViewRowState.CurrentRows)
                Dim drv1 As DataRowView
                For Each drv1 In dview
                    Dim dview1 As New DataView(dt, "dokumentartnr='" + Trim(drv1.Item(0)) + "'", "", DataViewRowState.CurrentRows)
                    Dim drv2 As DataRowView
                    Dim i As Integer
                    i = 0
                    For Each drv2 In dview1
                        i = i + 1
                    Next
                    dview1.Dispose()
                    If i = 0 Then dt.ImportRow(drv1.Row)
                    parent = drv1.Item(4)
                    dview.Dispose()
                Next
            End While
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumentart Fields

clsMyDokumentart overview

Fields

field m_FirstEntry
field m_Geschaeftsfall
field m_LastEntry
field m_Refresh
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_pagedirection
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_searchstring
field m_selectpartner

See Also

clsMyDokumentart Class


m_FirstEntry Variable

Dim m_FirstEntry As Integer

Source code

[Visual Basic]
        Dim m_FirstEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_Geschaeftsfall Variable

Dim m_Geschaeftsfall As String

Source code

[Visual Basic]
        Dim m_Geschaeftsfall As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_LastEntry Variable

Dim m_LastEntry As Integer

Source code

[Visual Basic]
        Dim m_LastEntry As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_Refresh Variable

Dim m_Refresh As Boolean = False

Source code

[Visual Basic]
        Dim m_Refresh As Boolean = False

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_pagedirection Variable

Dim m_pagedirection As Integer

Source code

[Visual Basic]
        Dim m_pagedirection As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_searchstring Variable

Dim m_searchstring As String

Source code

[Visual Basic]
        Dim m_searchstring As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


m_selectpartner Variable

Dim m_selectpartner As Boolean

Source code

[Visual Basic]
        Dim m_selectpartner As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentart


clsMyDokumenttyp Class

For a list of all members of this type, see clsMyDokumenttyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumenttyp
EDOKAApp.edokadb.clsMyDokumenttyp

Public Class clsMyDokumenttyp
   Inherits edokadb.clsDokumenttyp

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyDokumenttyp Members


clsMyDokumenttyp Members

clsMyDokumenttyp overview

Constructors

constructor clsMyDokumenttyp Constructor (inherited from EDOKAApp.edokadb.clsDokumenttyp)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bAmsdokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bAnzeigeZurDokumenterstellung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bBedingtretournierbar (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bBezeichnungmut (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bCold_ersetzen (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bDokument_wird_erstellt (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bDokument_wird_retourniert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bEingang_ersetzt_ausgang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bEmail_versand (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bFunktionen_zuweisen (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bHostdokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bKundenDokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bNurnative (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bPartnersaldierung_statusalt (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSb (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbedituser (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbimport (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbnur (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bUnterschrift_links (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bUnterschrift_rechts (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bVertrag (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bVertrauliches_dokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bWird_importiert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bWird_nicht_geloescht (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bZu_retournieren (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bZu_vercolden (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAnzahl_tage (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAufbewahrungsfrist_elektronisch (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAufbewahrungsfrist_physisch (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iCold_folder (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDbearbeitungszeit (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDoktypbedingteretournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_coldausgang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_coldeingang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_host (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_kundendossier (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_nativ (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_neuerstellung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_retournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_weitere (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentstatus (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentstatus_barcode (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumenttypnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iMonate_bis_zur_archivierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iMutierer (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iObjektbezeichnungnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iOffice_vorlagenr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iOwner (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iPhysisches_archiv (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iProzessnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iProzessnr1 (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iTage_mutation (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iTagebisvernichtungbedingteretournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sHostdokumenttyp (inherited from EDOKAApp.edokadb.clsDokumenttyp)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method SelectAll (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method SelectAll_HostDokumente
method SelectOne (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method Update (inherited from EDOKAApp.edokadb.clsDokumenttyp)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyDokumenttyp Class


clsMyDokumenttyp Properties

clsMyDokumenttyp overview

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bAmsdokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bAnzeigeZurDokumenterstellung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bBedingtretournierbar (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bBezeichnungmut (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bCold_ersetzen (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bDokument_wird_erstellt (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bDokument_wird_retourniert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bEingang_ersetzt_ausgang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bEmail_versand (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bFunktionen_zuweisen (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bHostdokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bKundenDokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bNurnative (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bPartnersaldierung_statusalt (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSb (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbedituser (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbimport (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bSbnur (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bUnterschrift_links (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bUnterschrift_rechts (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bVertrag (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bVertrauliches_dokument (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bWird_importiert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bWird_nicht_geloescht (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bZu_retournieren (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property bZu_vercolden (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAnzahl_tage (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAufbewahrungsfrist_elektronisch (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iAufbewahrungsfrist_physisch (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iCold_folder (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDbearbeitungszeit (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDoktypbedingteretournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_coldausgang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_coldeingang (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_host (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_kundendossier (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_nativ (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_neuerstellung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_retournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentart_weitere (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentstatus (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumentstatus_barcode (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iDokumenttypnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iMonate_bis_zur_archivierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iMutierer (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iObjektbezeichnungnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iOffice_vorlagenr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iOwner (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iPhysisches_archiv (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iProzessnr (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iProzessnr1 (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iTage_mutation (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property iTagebisvernichtungbedingteretournierung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsDokumenttyp)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sHostdokumenttyp (inherited from EDOKAApp.edokadb.clsDokumenttyp)

See Also

clsMyDokumenttyp Class


clsMyDokumenttyp Methods

clsMyDokumenttyp overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method SelectAll (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method SelectAll_HostDokumente
method SelectOne (inherited from EDOKAApp.edokadb.clsDokumenttyp)
method Update (inherited from EDOKAApp.edokadb.clsDokumenttyp)

See Also

clsMyDokumenttyp Class


clsMyDokumenttyp.SelectAll_HostDokumente Method

Public Function SelectAll_HostDokumente() As DataTable

Source code

[Visual Basic]
        Public Function SelectAll_HostDokumente() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_dokumenttyp_SelectAll_Hostdokumente]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumenttyp


clsMyDokumenttyp Fields

clsMyDokumenttyp overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyDokumenttyp Class


clsMyKey_Tabelle Class

For a list of all members of this type, see clsMyKey_Tabelle Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsKey_tabelle
EDOKAApp.edokadb.clsMyKey_Tabelle

Public Class clsMyKey_Tabelle
   Inherits edokadb.clsKey_tabelle

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyKey_Tabelle Members


clsMyKey_Tabelle Members

clsMyKey_Tabelle overview

Constructors

constructor clsMyKey_Tabelle Constructor (inherited from EDOKAApp.edokadb.clsKey_tabelle)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKey_wert (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iKeynr (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iMandantnr (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iMutierer (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method SelectAll (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method SelectOne (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method Update (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method get_dbkey

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyKey_Tabelle Class


clsMyKey_Tabelle Properties

clsMyKey_Tabelle overview

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKey_wert (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iKeynr (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iMandantnr (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property iMutierer (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsKey_tabelle)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyKey_Tabelle Class


clsMyKey_Tabelle Methods

clsMyKey_Tabelle overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method SelectAll (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method SelectOne (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method Update (inherited from EDOKAApp.edokadb.clsKey_tabelle)
method get_dbkey

See Also

clsMyKey_Tabelle Class


clsMyKey_Tabelle.get_dbkey Method

Public Function get_dbkey( _
   ByVal Tablename As String _
) As Long

Parameters

Tablename
Required.

Source code

[Visual Basic]
        Public Function get_dbkey(ByVal Tablename As String) As Long
            Dim m_dbkey As Long
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_get_dbkey]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Tablename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dbkey", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_dbkey))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                Try
                    scmCmdToExecute.Connection.Open()
                Catch ex As Exception
                Finally
                End Try

                scmCmdToExecute.ExecuteNonQuery()
                m_dbkey = scmCmdToExecute.Parameters.Item("@dbkey").Value
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))
                scmCmdToExecute.Connection.Close()

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_get_dbkey' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return m_dbkey
            Catch ex As Exception
                    ' // some error occured. Bubble it to caller and encapsulate Exception object
                    Throw New Exception("clsKey_tabelle::get_dbkey::Error occured." + ex.Message, ex)
                Finally
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Close connection.
                        m_scoMainConnection.Close()
                    End If
                    scmCmdToExecute.Dispose()
                End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyKey_Tabelle


clsMyKey_Tabelle Fields

clsMyKey_Tabelle overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyKey_Tabelle Class


clsMyPartner Class

For a list of all members of this type, see clsMyPartner Members.

System.Object
EDOKAApp.edokadb.clsMyPartner

Public Class clsMyPartner

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyPartner Members


clsMyPartner Members

clsMyPartner overview

Methods

method Partner_Betreuer
method Partner_Detail
method Partner_Gebdat
method Partner_VV
method search_doppelte_partner
method search_partner

See Also

clsMyPartner Class


clsMyPartner Methods

clsMyPartner overview

Methods

method Partner_Betreuer
method Partner_Detail
method Partner_Gebdat
method Partner_VV
method search_doppelte_partner
method search_partner

See Also

clsMyPartner Class


clsMyPartner.Partner_Betreuer Method

Public Function Partner_Betreuer( _
   ByVal nrpar00 As String _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function Partner_Betreuer(ByVal nrpar00 As String) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim table As String = "dbo.partner"
            scmCmdToExecute.CommandText = "dbo.[sp_partner_betreuer]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@betreuer", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)
                Return scmCmdToExecute.Parameters("@betreuer").Value
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
                Return ""
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
                dtToReturn.Dispose()
            End Try

        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMyPartner.Partner_Detail Method

Public Function Partner_Detail( _
   ByVal nrpar00 As String _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function Partner_Detail(ByVal nrpar00 As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim table As String = "dbo.partner"
            scmCmdToExecute.CommandText = "dbo.[sp_partner_detail]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMyPartner::sp_partner_detail::Error occured." + ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMyPartner.Partner_Gebdat Method

Public Function Partner_Gebdat( _
   ByVal nrpar00 As String _
) As String

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function Partner_Gebdat(ByVal nrpar00 As String) As String
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim table As String = "dbo.partner"
            scmCmdToExecute.CommandText = "dbo.[sp_partner_gebdat]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@gebdat", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)

                Return scmCmdToExecute.Parameters("@gebdat").Value
            Catch ex As Exception
                '   MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                '  Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
                Return ""
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMyPartner.Partner_VV Method

Public Function Partner_VV( _
   ByVal nrpar00 As String _
) As DataTable

Parameters

nrpar00
Required.

Source code

[Visual Basic]
        Public Function Partner_VV(ByVal nrpar00 As String) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim table As String = "dbo.partner"
            scmCmdToExecute.CommandText = "dbo.[sp_partner_vv]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMyPartner.search_doppelte_partner Method

Public Function search_doppelte_partner( _
   ByVal query As String, _
   ByVal table As String, _
   ByVal fnkt As Integer _
) As DataTable

Parameters

query
Required.
table
Required.
fnkt
Required.

Source code

[Visual Basic]
        Public Function search_doppelte_partner(ByVal query As String, ByVal table As String, ByVal fnkt As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_partner_search]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@table", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, table))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@anz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 4))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMyPartner::sp_partner_search::Error occured." + ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMyPartner.search_partner Method

Public Function search_partner( _
   ByVal query As String, _
   ByVal anzahl As String, _
   ByVal fnkt As Integer _
) As DataTable

Parameters

query
Required.
anzahl
Required.
fnkt
Required.

Source code

[Visual Basic]
        Public Function search_partner(ByVal query As String, ByVal anzahl As String, ByVal fnkt As Integer) As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            Dim table As String = "dbo.partner"
            scmCmdToExecute.CommandText = "dbo.[sp_partner_search]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("partner")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = conn.scoDBConnection
            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@table", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, table))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@anz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, anzahl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
                scmCmdToExecute.Connection.Open()
                sdaAdapter.Fill(dtToReturn)
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMyPartner::sp_partner_search::Error occured." + ex.Message, ex)
            Finally
                scmCmdToExecute.Connection.Close()
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyPartner


clsMySysadminfunkion Class

For a list of all members of this type, see clsMySysadminfunkion Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsSysadminfunktion
EDOKAApp.edokadb.clsMySysadminfunkion

Public Class clsMySysadminfunkion
   Inherits edokadb.clsSysadminfunktion

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMySysadminfunkion Members


clsMySysadminfunkion Members

clsMySysadminfunkion overview

Constructors

constructor clsMySysadminfunkion Constructor (inherited from EDOKAApp.edokadb.clsSysadminfunktion)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFheight (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFleft (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFtop (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFwidth (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iImageIndex (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iImageIndexOpen (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iMandantnr (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iMutierer (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iParentID (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSort (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSprache (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSysadminfnktnr (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method LoadTreeMenu
method SelectAll (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method SelectHierarchy
method SelectOne (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method Update (inherited from EDOKAApp.edokadb.clsSysadminfunktion)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMySysadminfunkion Class


clsSysadminfunktion Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsMySysadminfunkion Properties

clsMySysadminfunkion overview

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFheight (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFleft (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFtop (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iFwidth (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iImageIndex (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iImageIndexOpen (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iMandantnr (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iMutierer (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iParentID (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSort (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSprache (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property iSysadminfnktnr (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMySysadminfunkion Class


clsSysadminfunktion.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iFheight Property

Public Property [iFheight]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFheight]() As SqlInt32
            Get
                Return m_iFheight
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFheight = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iFleft Property

Public Property [iFleft]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFleft]() As SqlInt32
            Get
                Return m_iFleft
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFleft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iFtop Property

Public Property [iFtop]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFtop]() As SqlInt32
            Get
                Return m_iFtop
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFtop = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iFwidth Property

Public Property [iFwidth]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFwidth]() As SqlInt32
            Get
                Return m_iFwidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFwidth = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iImageIndex Property

Public Property [iImageIndex]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageIndex]() As SqlInt32
            Get
                Return m_iImageIndex
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndex = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iImageIndexOpen Property

Public Property [iImageIndexOpen]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iImageIndexOpen]() As SqlInt32
            Get
                Return m_iImageIndexOpen
            End Get
            Set(ByVal Value As SqlInt32)
                m_iImageIndexOpen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iParentID Property

Public Property [iParentID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParentID]() As SqlInt32
            Get
                Return m_iParentID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParentID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iSort Property

Public Property [iSort]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSort]() As SqlInt32
            Get
                Return m_iSort
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.iSysadminfnktnr Property

Public Property [iSysadminfnktnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSysadminfnktnrTmp As SqlInt32 = Value
                If iSysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSysadminfnktnr", "iSysadminfnktnr can't be NULL")
                End If
                m_iSysadminfnktnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsMySysadminfunkion Methods

clsMySysadminfunkion overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method LoadTreeMenu
method SelectAll (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method SelectHierarchy
method SelectOne (inherited from EDOKAApp.edokadb.clsSysadminfunktion)
method Update (inherited from EDOKAApp.edokadb.clsSysadminfunktion)

See Also

clsMySysadminfunkion Class


clsSysadminfunktion.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsMySysadminfunkion.LoadTreeMenu Method

Public Sub LoadTreeMenu( _
   ByVal otv As TreeView _
)

Parameters

otv
Required.

Source code

[Visual Basic]
        Public Sub LoadTreeMenu(ByVal otv As TreeView)
            Dim menueintraege As New clsMySysadminfunkion()
            Dim menudata As DataTable
            Dim i As Integer
            Dim m_collDeletedNodes As Collection
            Dim collNodeKeys As New Collection()
            Dim tnNew As TreeNode
            Dim tnParent As TreeNode

            m_collDeletedNodes = Nothing
            m_collDeletedNodes = New Collection()

            menueintraege.cpMainConnectionProvider = conn
            menudata = menueintraege.SelectHierarchy

            For i = 0 To menudata.Rows.Count - 1
                If menudata.Rows(i).Item("ParentID") = 0 Then
                    tnNew = otv.Nodes.Add(menudata.Rows(i).Item("bezeichnung"))
                    With tnNew
                        .Tag() = menudata.Rows(i).Item("sysadminfnktnr")
                        .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                        .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                    End With
                    Try
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                Else
                    Try
                        tnParent = CType(collNodeKeys.Item(CType(menudata.Rows(i).Item("ParentID"), String)), TreeNode)
                        tnNew = tnParent.Nodes.Add(CType(menudata.Rows(i).Item("bezeichnung"), String))
                        With tnNew
                            .Tag() = CType(menudata.Rows(i).Item("sysadminfnktnr"), String)
                            .ImageIndex() = menudata.Rows(i).Item("ImageIndex")
                            .SelectedImageIndex() = menudata.Rows(i).Item("ImageIndexOpen")
                        End With
                        collNodeKeys.Add(tnNew, CType(menudata.Rows(i).Item("sysadminfnktnr"), String))
                    Catch ex As Exception
                        MsgBox(ex.Message, MsgBoxStyle.Critical)
                    End Try
                End If
            Next
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMySysadminfunkion


clsSysadminfunktion.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsMySysadminfunkion.SelectHierarchy Method

Public Function SelectHierarchy() As DataTable

Source code

[Visual Basic]
        Public Function SelectHierarchy() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            'scmCmdToExecute.CommandText = "dbo.[sp_sysadminfunktion_hierarchie]"
            scmCmdToExecute.CommandText = "dbo.[sp_get_sysadmin_tree]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iroot", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.Sprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMySysadminfunkion


clsSysadminfunktion.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("ParentID") Is System.DBNull.Value Then
                        m_iParentID = SqlInt32.Null
                    Else
                        m_iParentID = New SqlInt32(CType(dtToReturn.Rows(0)("ParentID"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Sort") Is System.DBNull.Value Then
                        m_iSort = SqlInt32.Null
                    Else
                        m_iSort = New SqlInt32(CType(dtToReturn.Rows(0)("Sort"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndex") Is System.DBNull.Value Then
                        m_iImageIndex = SqlInt32.Null
                    Else
                        m_iImageIndex = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndex"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ImageIndexOpen") Is System.DBNull.Value Then
                        m_iImageIndexOpen = SqlInt32.Null
                    Else
                        m_iImageIndexOpen = New SqlInt32(CType(dtToReturn.Rows(0)("ImageIndexOpen"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ftop") Is System.DBNull.Value Then
                        m_iFtop = SqlInt32.Null
                    Else
                        m_iFtop = New SqlInt32(CType(dtToReturn.Rows(0)("ftop"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fleft") Is System.DBNull.Value Then
                        m_iFleft = SqlInt32.Null
                    Else
                        m_iFleft = New SqlInt32(CType(dtToReturn.Rows(0)("fleft"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fwidth") Is System.DBNull.Value Then
                        m_iFwidth = SqlInt32.Null
                    Else
                        m_iFwidth = New SqlInt32(CType(dtToReturn.Rows(0)("fwidth"), Integer))
                    End If
                    If dtToReturn.Rows(0)("fheight") Is System.DBNull.Value Then
                        m_iFheight = SqlInt32.Null
                    Else
                        m_iFheight = New SqlInt32(CType(dtToReturn.Rows(0)("fheight"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsSysadminfunktion.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParentID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParentID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSort", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndex", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndex))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iImageIndexOpen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iImageIndexOpen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iftop", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFtop))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFwidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFheight))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSysadminfunktion::Update::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsMySysadminfunkion Fields

clsMySysadminfunkion overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMySysadminfunkion Class


clsNldokumenttyp Class

For a list of all members of this type, see clsNldokumenttyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsNldokumenttyp

Public Class clsNldokumenttyp
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsNldokumenttyp Members


clsNldokumenttyp Members

clsNldokumenttyp overview

Constructors

constructor clsNldokumenttyp Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iNiederlassungnr
property iNldokumenttypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iNiederlassungnr
field m_iNldokumenttypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsNldokumenttyp Class


clsNldokumenttyp Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp Properties

clsNldokumenttyp overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iNiederlassungnr
property iNldokumenttypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsNldokumenttyp Class


clsNldokumenttyp.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.iNiederlassungnr Property

Public Property [iNiederlassungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNiederlassungnr]() As SqlInt32
            Get
                Return m_iNiederlassungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNiederlassungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.iNldokumenttypnr Property

Public Property [iNldokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNldokumenttypnr]() As SqlInt32
            Get
                Return m_iNldokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNldokumenttypnrTmp As SqlInt32 = Value
                If iNldokumenttypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNldokumenttypnr", "iNldokumenttypnr can't be NULL")
                End If
                m_iNldokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp Methods

clsNldokumenttyp overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsNldokumenttyp Class


clsNldokumenttyp.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_nldokumenttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inldokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNldokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_nldokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNldokumenttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_nldokumenttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inldokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNldokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_nldokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNldokumenttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_nldokumenttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("nldokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_nldokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNldokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_nldokumenttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("nldokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inldokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNldokumenttypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_nldokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNldokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("nldokumenttypnr"), Integer))
                    If dtToReturn.Rows(0)("niederlassungnr") Is System.DBNull.Value Then
                        m_iNiederlassungnr = SqlInt32.Null
                    Else
                        m_iNiederlassungnr = New SqlInt32(CType(dtToReturn.Rows(0)("niederlassungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNldokumenttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_nldokumenttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inldokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNldokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iniederlassungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNiederlassungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_nldokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNldokumenttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNldokumenttyp Fields

clsNldokumenttyp overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iNiederlassungnr
field m_iNldokumenttypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsNldokumenttyp Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_iDokumenttypnr Variable

Private 		m_iMutierer, _
   m_iNiederlassungnr, _
   m_iDokumenttypnr, _
   m_iNldokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNiederlassungnr, m_iDokumenttypnr, m_iNldokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iNiederlassungnr, _
   m_iDokumenttypnr, _
   m_iNldokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNiederlassungnr, m_iDokumenttypnr, m_iNldokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_iNiederlassungnr Variable

Private 		m_iMutierer, _
   m_iNiederlassungnr, _
   m_iDokumenttypnr, _
   m_iNldokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNiederlassungnr, m_iDokumenttypnr, m_iNldokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


m_iNldokumenttypnr Variable

Private 		m_iMutierer, _
   m_iNiederlassungnr, _
   m_iDokumenttypnr, _
   m_iNldokumenttypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNiederlassungnr, m_iDokumenttypnr, m_iNldokumenttypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNldokumenttyp


clsNotizen Class

For a list of all members of this type, see clsNotizen Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsNotizen

Public Class clsNotizen
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsNotizen Members


clsNotizen Members

clsNotizen overview

Constructors

constructor clsNotizen Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidOld
property sNotiz

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentidLogic
method SelectOne
method Update
method UpdateAllWdokumentidLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_sBetreff
field m_sDokumentid
field m_sDokumentidOld
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsNotizen Class


clsNotizen Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen Properties

clsNotizen overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidOld
property sNotiz

See Also

clsNotizen Class


clsNotizen.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.iNotiznr Property

Public Property [iNotiznr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNotiznr]() As SqlInt32
            Get
                Return m_iNotiznr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNotiznrTmp As SqlInt32 = Value
                If iNotiznrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNotiznr", "iNotiznr can't be NULL")
                End If
                m_iNotiznr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.sBetreff Property

Public Property [sBetreff]() As SqlString

Source code

[Visual Basic]
        Public Property [sBetreff]() As SqlString
            Get
                Return m_sBetreff
            End Get
            Set(ByVal Value As SqlString)
                m_sBetreff = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.sDokumentidOld Property

Public Property [sDokumentidOld]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentidOld]() As SqlString
            Get
                Return m_sDokumentidOld
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentidOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.sNotiz Property

Public Property [sNotiz]() As SqlString

Source code

[Visual Basic]
        Public Property [sNotiz]() As SqlString
            Get
                Return m_sNotiz
            End Get
            Set(ByVal Value As SqlString)
                m_sNotiz = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen Methods

clsNotizen overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentidLogic
method SelectOne
method Update
method UpdateAllWdokumentidLogic

See Also

clsNotizen Class


clsNotizen.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("notizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.SelectAllWdokumentidLogic Method

Public Function SelectAllWdokumentidLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWdokumentidLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_SelectAllWdokumentidLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("notizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_SelectAllWdokumentidLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::SelectAllWdokumentidLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("notizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNotiznr = New SqlInt32(CType(dtToReturn.Rows(0)("notiznr"), Integer))
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("betreff") Is System.DBNull.Value Then
                        m_sBetreff = SqlString.Null
                    Else
                        m_sBetreff = New SqlString(CType(dtToReturn.Rows(0)("betreff"), String))
                    End If
                    If dtToReturn.Rows(0)("notiz") Is System.DBNull.Value Then
                        m_sNotiz = SqlString.Null
                    Else
                        m_sNotiz = New SqlString(CType(dtToReturn.Rows(0)("notiz"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen.UpdateAllWdokumentidLogic Method

Public Function UpdateAllWdokumentidLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWdokumentidLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_notizen_UpdateAllWdokumentidLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, false, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentidOld", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 22, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_notizen_UpdateAllWdokumentidLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsNotizen::UpdateAllWdokumentidLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsNotizen Fields

clsNotizen overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_sBetreff
field m_sDokumentid
field m_sDokumentidOld
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsNotizen Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_iNotiznr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_sBetreff Variable

Private 		m_sDokumentid, _
   m_sDokumentidOld, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sDokumentidOld, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_sDokumentid Variable

Private 		m_sDokumentid, _
   m_sDokumentidOld, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sDokumentidOld, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_sDokumentidOld Variable

Private 		m_sDokumentid, _
   m_sDokumentidOld, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sDokumentidOld, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


m_sNotiz Variable

Private 		m_sDokumentid, _
   m_sDokumentidOld, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sDokumentidOld, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsNotizen


clsObjektbezeichnung Class

For a list of all members of this type, see clsObjektbezeichnung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsObjektbezeichnung

Public Class clsObjektbezeichnung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsObjektbezeichnung Members


clsObjektbezeichnung Members

clsObjektbezeichnung overview

Constructors

constructor clsObjektbezeichnung Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iObjektbezeichnungnr
property sBeschreibung
property sBezeichnunung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iObjektbezeichnungnr
field m_sBeschreibung
field m_sBezeichnunung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsObjektbezeichnung Class


clsObjektbezeichnung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung Properties

clsObjektbezeichnung overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iObjektbezeichnungnr
property sBeschreibung
property sBezeichnunung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsObjektbezeichnung Class


clsObjektbezeichnung.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.iObjektbezeichnungnr Property

Public Property [iObjektbezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iObjektbezeichnungnr]() As SqlInt32
            Get
                Return m_iObjektbezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iObjektbezeichnungnrTmp As SqlInt32 = Value
                If iObjektbezeichnungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iObjektbezeichnungnr", "iObjektbezeichnungnr can't be NULL")
                End If
                m_iObjektbezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.sBezeichnunung Property

Public Property [sBezeichnunung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnunung]() As SqlString
            Get
                Return m_sBezeichnunung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnunung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung Methods

clsObjektbezeichnung overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsObjektbezeichnung Class


clsObjektbezeichnung.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Objektbezeichnung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Objektbezeichnung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsObjektbezeichnung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Objektbezeichnung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnunung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnunung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Objektbezeichnung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsObjektbezeichnung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Objektbezeichnung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Objektbezeichnung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Objektbezeichnung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsObjektbezeichnung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Objektbezeichnung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Objektbezeichnung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Objektbezeichnung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iObjektbezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("objektbezeichnungnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnunung") Is System.DBNull.Value Then
                        m_sBezeichnunung = SqlString.Null
                    Else
                        m_sBezeichnunung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnunung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsObjektbezeichnung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Objektbezeichnung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnunung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnunung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Objektbezeichnung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsObjektbezeichnung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsObjektbezeichnung Fields

clsObjektbezeichnung overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iObjektbezeichnungnr
field m_sBeschreibung
field m_sBezeichnunung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsObjektbezeichnung Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iObjektbezeichnungnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iObjektbezeichnungnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iObjektbezeichnungnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iObjektbezeichnungnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_iObjektbezeichnungnr Variable

Private 		m_iMutierer, _
   m_iObjektbezeichnungnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iObjektbezeichnungnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_sBeschreibung Variable

Private 		m_sBezeichnunung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnunung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


m_sBezeichnunung Variable

Private 		m_sBezeichnunung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnunung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsObjektbezeichnung


clsOffice_vorlage Class

For a list of all members of this type, see clsOffice_vorlage Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsOffice_vorlage

Public Class clsOffice_vorlage
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsOffice_vorlage Members


clsOffice_vorlage Members

clsOffice_vorlage overview

Constructors

constructor clsOffice_vorlage Constructor

Properties

property bAbsender_ersteller
property bAktiv
property bBchorizontal
property bDokument_geschuetzt
property bIdv_nativ
property bIdv_vorlage
property bKopfzeile_generieren
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnwendungnr
property iBch
property iBcpl
property iBcpt
property iBcw
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKlassifizierung
property iMandantnr
property iMutierer
property iOffice_vorlagenr
property iOwner
property iVorlageid
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sIdv_id
property sOffice_vorlage
property sPrefix_dokumentname
property sVorlagename

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAbsender_ersteller
field m_bAktiv
field m_bBchorizontal
field m_bDokument_geschuetzt
field m_bIdv_nativ
field m_bIdv_vorlage
field m_bKopfzeile_generieren
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnwendungnr
field m_iBch
field m_iBcpl
field m_iBcpt
field m_iBcw
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKlassifizierung
field m_iMandantnr
field m_iMutierer
field m_iOffice_vorlagenr
field m_iOwner
field m_iVorlageid
field m_sBeschreibung
field m_sBezeichnung
field m_sIdv_id
field m_sOffice_vorlage
field m_sPrefix_dokumentname
field m_sVorlagename
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsOffice_vorlage Class


clsOffice_vorlage Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage Properties

clsOffice_vorlage overview

Properties

property bAbsender_ersteller
property bAktiv
property bBchorizontal
property bDokument_geschuetzt
property bIdv_nativ
property bIdv_vorlage
property bKopfzeile_generieren
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnwendungnr
property iBch
property iBcpl
property iBcpt
property iBcw
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKlassifizierung
property iMandantnr
property iMutierer
property iOffice_vorlagenr
property iOwner
property iVorlageid
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sIdv_id
property sOffice_vorlage
property sPrefix_dokumentname
property sVorlagename

See Also

clsOffice_vorlage Class


clsOffice_vorlage.bAbsender_ersteller Property

Public Property [bAbsender_ersteller]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAbsender_ersteller]() As SqlBoolean
            Get
                Return m_bAbsender_ersteller
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAbsender_ersteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bBchorizontal Property

Public Property [bBchorizontal]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBchorizontal]() As SqlBoolean
            Get
                Return m_bBchorizontal
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBchorizontal = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bDokument_geschuetzt Property

Public Property [bDokument_geschuetzt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_geschuetzt]() As SqlBoolean
            Get
                Return m_bDokument_geschuetzt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_geschuetzt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bIdv_nativ Property

Public Property [bIdv_nativ]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bIdv_nativ]() As SqlBoolean
            Get
                Return m_bIdv_nativ
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bIdv_nativTmp As SqlBoolean = Value
                If bIdv_nativTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bIdv_nativ", "bIdv_nativ can't be NULL")
                End If
                m_bIdv_nativ = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bIdv_vorlage Property

Public Property [bIdv_vorlage]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bIdv_vorlage]() As SqlBoolean
            Get
                Return m_bIdv_vorlage
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bIdv_vorlageTmp As SqlBoolean = Value
                If bIdv_vorlageTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bIdv_vorlage", "bIdv_vorlage can't be NULL")
                End If
                m_bIdv_vorlage = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.bKopfzeile_generieren Property

Public Property [bKopfzeile_generieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bKopfzeile_generieren]() As SqlBoolean
            Get
                Return m_bKopfzeile_generieren
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bKopfzeile_generierenTmp As SqlBoolean = Value
                If bKopfzeile_generierenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bKopfzeile_generieren", "bKopfzeile_generieren can't be NULL")
                End If
                m_bKopfzeile_generieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iAnwendungnr Property

Public Property [iAnwendungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnwendungnr]() As SqlInt32
            Get
                Return m_iAnwendungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnwendungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iBch Property

Public Property [iBch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBch]() As SqlInt32
            Get
                Return m_iBch
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBchTmp As SqlInt32 = Value
                If iBchTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBch", "iBch can't be NULL")
                End If
                m_iBch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iBcpl Property

Public Property [iBcpl]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBcpl]() As SqlInt32
            Get
                Return m_iBcpl
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBcpl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iBcpt Property

Public Property [iBcpt]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBcpt]() As SqlInt32
            Get
                Return m_iBcpt
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBcptTmp As SqlInt32 = Value
                If iBcptTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBcpt", "iBcpt can't be NULL")
                End If
                m_iBcpt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iBcw Property

Public Property [iBcw]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBcw]() As SqlInt32
            Get
                Return m_iBcw
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBcwTmp As SqlInt32 = Value
                If iBcwTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBcw", "iBcw can't be NULL")
                End If
                m_iBcw = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iKlassifizierung Property

Public Property [iKlassifizierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKlassifizierung]() As SqlInt32
            Get
                Return m_iKlassifizierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKlassifizierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iOffice_vorlagenr Property

Public Property [iOffice_vorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlagenr]() As SqlInt32
            Get
                Return m_iOffice_vorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iOffice_vorlagenrTmp As SqlInt32 = Value
                If iOffice_vorlagenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iOffice_vorlagenr", "iOffice_vorlagenr can't be NULL")
                End If
                m_iOffice_vorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iOwner Property

Public Property [iOwner]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOwner]() As SqlInt32
            Get
                Return m_iOwner
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOwner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.iVorlageid Property

Public Property [iVorlageid]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlageid]() As SqlInt32
            Get
                Return m_iVorlageid
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlageid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sIdv_id Property

Public Property [sIdv_id]() As SqlString

Source code

[Visual Basic]
        Public Property [sIdv_id]() As SqlString
            Get
                Return m_sIdv_id
            End Get
            Set(ByVal Value As SqlString)
                m_sIdv_id = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sOffice_vorlage Property

Public Property [sOffice_vorlage]() As SqlString

Source code

[Visual Basic]
        Public Property [sOffice_vorlage]() As SqlString
            Get
                Return m_sOffice_vorlage
            End Get
            Set(ByVal Value As SqlString)
                m_sOffice_vorlage = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sPrefix_dokumentname Property

Public Property [sPrefix_dokumentname]() As SqlString

Source code

[Visual Basic]
        Public Property [sPrefix_dokumentname]() As SqlString
            Get
                Return m_sPrefix_dokumentname
            End Get
            Set(ByVal Value As SqlString)
                m_sPrefix_dokumentname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.sVorlagename Property

Public Property [sVorlagename]() As SqlString

Source code

[Visual Basic]
        Public Property [sVorlagename]() As SqlString
            Get
                Return m_sVorlagename
            End Get
            Set(ByVal Value As SqlString)
                m_sVorlagename = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage Methods

clsOffice_vorlage overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsOffice_vorlage Class


clsOffice_vorlage.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_office_vorlage_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_vorlage::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlageid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlageid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorlagename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorlagename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sprefix_dokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrefix_dokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_vorlage", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_vorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sidv_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIdv_id))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@soffice_vorlage", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOffice_vorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babsender_ersteller", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbsender_ersteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_nativ", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_nativ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_geschuetzt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_geschuetzt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bkopfzeile_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bKopfzeile_generieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpt", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcpt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcpl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcw", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcw))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbchorizontal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBchorizontal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianwendungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnwendungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_office_vorlage_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_vorlage::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_office_vorlage_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_vorlage::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("office_vorlage")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_office_vorlage_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("vorlageid") Is System.DBNull.Value Then
                        m_iVorlageid = SqlInt32.Null
                    Else
                        m_iVorlageid = New SqlInt32(CType(dtToReturn.Rows(0)("vorlageid"), Integer))
                    End If
                    If dtToReturn.Rows(0)("vorlagename") Is System.DBNull.Value Then
                        m_sVorlagename = SqlString.Null
                    Else
                        m_sVorlagename = New SqlString(CType(dtToReturn.Rows(0)("vorlagename"), String))
                    End If
                    If dtToReturn.Rows(0)("prefix_dokumentname") Is System.DBNull.Value Then
                        m_sPrefix_dokumentname = SqlString.Null
                    Else
                        m_sPrefix_dokumentname = New SqlString(CType(dtToReturn.Rows(0)("prefix_dokumentname"), String))
                    End If
                    m_bIdv_vorlage = New SqlBoolean(CType(dtToReturn.Rows(0)("idv_vorlage"), Boolean))
                    If dtToReturn.Rows(0)("idv_id") Is System.DBNull.Value Then
                        m_sIdv_id = SqlString.Null
                    Else
                        m_sIdv_id = New SqlString(CType(dtToReturn.Rows(0)("idv_id"), String))
                    End If
                    If dtToReturn.Rows(0)("office_vorlage") Is System.DBNull.Value Then
                        m_sOffice_vorlage = SqlString.Null
                    Else
                        m_sOffice_vorlage = New SqlString(CType(dtToReturn.Rows(0)("office_vorlage"), String))
                    End If
                    If dtToReturn.Rows(0)("absender_ersteller") Is System.DBNull.Value Then
                        m_bAbsender_ersteller = SqlBoolean.Null
                    Else
                        m_bAbsender_ersteller = New SqlBoolean(CType(dtToReturn.Rows(0)("absender_ersteller"), Boolean))
                    End If
                    m_bIdv_nativ = New SqlBoolean(CType(dtToReturn.Rows(0)("idv_nativ"), Boolean))
                    If dtToReturn.Rows(0)("dokument_geschuetzt") Is System.DBNull.Value Then
                        m_bDokument_geschuetzt = SqlBoolean.Null
                    Else
                        m_bDokument_geschuetzt = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_geschuetzt"), Boolean))
                    End If
                    m_bKopfzeile_generieren = New SqlBoolean(CType(dtToReturn.Rows(0)("kopfzeile_generieren"), Boolean))
                    If dtToReturn.Rows(0)("klassifizierung") Is System.DBNull.Value Then
                        m_iKlassifizierung = SqlInt32.Null
                    Else
                        m_iKlassifizierung = New SqlInt32(CType(dtToReturn.Rows(0)("klassifizierung"), Integer))
                    End If
                    m_iBcpt = New SqlInt32(CType(dtToReturn.Rows(0)("bcpt"), Integer))
                    If dtToReturn.Rows(0)("bcpl") Is System.DBNull.Value Then
                        m_iBcpl = SqlInt32.Null
                    Else
                        m_iBcpl = New SqlInt32(CType(dtToReturn.Rows(0)("bcpl"), Integer))
                    End If
                    m_iBcw = New SqlInt32(CType(dtToReturn.Rows(0)("bcw"), Integer))
                    m_iBch = New SqlInt32(CType(dtToReturn.Rows(0)("bch"), Integer))
                    If dtToReturn.Rows(0)("bchorizontal") Is System.DBNull.Value Then
                        m_bBchorizontal = SqlBoolean.Null
                    Else
                        m_bBchorizontal = New SqlBoolean(CType(dtToReturn.Rows(0)("bchorizontal"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("anwendungnr") Is System.DBNull.Value Then
                        m_iAnwendungnr = SqlInt32.Null
                    Else
                        m_iAnwendungnr = New SqlInt32(CType(dtToReturn.Rows(0)("anwendungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("owner") Is System.DBNull.Value Then
                        m_iOwner = SqlInt32.Null
                    Else
                        m_iOwner = New SqlInt32(CType(dtToReturn.Rows(0)("owner"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_vorlage::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlageid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlageid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svorlagename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorlagename))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sprefix_dokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrefix_dokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_vorlage", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_vorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sidv_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIdv_id))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@soffice_vorlage", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOffice_vorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babsender_ersteller", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbsender_ersteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_nativ", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_nativ))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_geschuetzt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_geschuetzt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bkopfzeile_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bKopfzeile_generieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpt", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcpt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcpl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcw", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcw))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbchorizontal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBchorizontal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianwendungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnwendungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_office_vorlage_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_vorlage::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOffice_vorlage Fields

clsOffice_vorlage overview

Fields

field m_bAbsender_ersteller
field m_bAktiv
field m_bBchorizontal
field m_bDokument_geschuetzt
field m_bIdv_nativ
field m_bIdv_vorlage
field m_bKopfzeile_generieren
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnwendungnr
field m_iBch
field m_iBcpl
field m_iBcpt
field m_iBcw
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKlassifizierung
field m_iMandantnr
field m_iMutierer
field m_iOffice_vorlagenr
field m_iOwner
field m_iVorlageid
field m_sBeschreibung
field m_sBezeichnung
field m_sIdv_id
field m_sOffice_vorlage
field m_sPrefix_dokumentname
field m_sVorlagename
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsOffice_vorlage Class


m_bAbsender_ersteller Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bAktiv Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bBchorizontal Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bDokument_geschuetzt Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bIdv_nativ Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bIdv_vorlage Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_bKopfzeile_generieren Variable

Private 		m_bDokument_geschuetzt, _
   m_bIdv_nativ, _
   m_bAbsender_ersteller, _
   m_bAktiv, _
   m_bBchorizontal, _
   m_bKopfzeile_generieren, _
   m_bIdv_vorlage As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iAnwendungnr Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iBch Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iBcpl Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iBcpt Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iBcw Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iKlassifizierung Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iOffice_vorlagenr Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iOwner Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_iVorlageid Variable

Private 		m_iMandantnr, _
   m_iBch, _
   m_iBcw, _
   m_iOffice_vorlagenr, _
   m_iMutierer, _
   m_iAnwendungnr, _
   m_iOwner, _
   m_iKlassifizierung, _
   m_iVorlageid, _
   m_iBcpl, _
   m_iBcpt As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sBeschreibung Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sBezeichnung Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sIdv_id Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sOffice_vorlage Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sPrefix_dokumentname Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


m_sVorlagename Variable

Private 		m_sPrefix_dokumentname, _
   m_sIdv_id, _
   m_sOffice_vorlage, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sVorlagename As SqlString

Source code

[Visual Basic]
        Private 		m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_vorlage


clsOrt Class

For a list of all members of this type, see clsOrt Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsOrt

Public Class clsOrt
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsOrt Members


clsOrt Members

clsOrt overview

Constructors

constructor clsOrt Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iOrtnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sKz
property sOrt
property sPlz

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iOrtnr
field m_sKz
field m_sOrt
field m_sPlz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsOrt Class


clsOrt Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt Properties

clsOrt overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iOrtnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sKz
property sOrt
property sPlz

See Also

clsOrt Class


clsOrt.iOrtnr Property

Public Property [iOrtnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOrtnr]() As SqlInt32
            Get
                Return m_iOrtnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iOrtnrTmp As SqlInt32 = Value
                If iOrtnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iOrtnr", "iOrtnr can't be NULL")
                End If
                m_iOrtnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.sKz Property

Public Property [sKz]() As SqlString

Source code

[Visual Basic]
        Public Property [sKz]() As SqlString
            Get
                Return m_sKz
            End Get
            Set(ByVal Value As SqlString)
                m_sKz = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.sOrt Property

Public Property [sOrt]() As SqlString

Source code

[Visual Basic]
        Public Property [sOrt]() As SqlString
            Get
                Return m_sOrt
            End Get
            Set(ByVal Value As SqlString)
                m_sOrt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.sPlz Property

Public Property [sPlz]() As SqlString

Source code

[Visual Basic]
        Public Property [sPlz]() As SqlString
            Get
                Return m_sPlz
            End Get
            Set(ByVal Value As SqlString)
                m_sPlz = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt Methods

clsOrt overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsOrt Class


clsOrt.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ort_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iortnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOrtnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ort_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOrt::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ort_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iortnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOrtnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@splz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sort", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skz", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKz))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ort_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOrt::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ort_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ort")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ort_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOrt::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ort_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ort")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iortnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOrtnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ort_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iOrtnr = New SqlInt32(CType(dtToReturn.Rows(0)("ortnr"), Integer))
                    If dtToReturn.Rows(0)("plz") Is System.DBNull.Value Then
                        m_sPlz = SqlString.Null
                    Else
                        m_sPlz = New SqlString(CType(dtToReturn.Rows(0)("plz"), String))
                    End If
                    If dtToReturn.Rows(0)("ort") Is System.DBNull.Value Then
                        m_sOrt = SqlString.Null
                    Else
                        m_sOrt = New SqlString(CType(dtToReturn.Rows(0)("ort"), String))
                    End If
                    If dtToReturn.Rows(0)("kz") Is System.DBNull.Value Then
                        m_sKz = SqlString.Null
                    Else
                        m_sKz = New SqlString(CType(dtToReturn.Rows(0)("kz"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOrt::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ort_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iortnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOrtnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@splz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPlz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sort", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@skz", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKz))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ort_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOrt::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsOrt Fields

clsOrt overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iOrtnr
field m_sKz
field m_sOrt
field m_sPlz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsOrt Class


m_iOrtnr Variable

Private 		m_iOrtnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iOrtnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


m_sKz Variable

Private 		m_sKz, _
   m_sOrt, _
   m_sPlz As SqlString

Source code

[Visual Basic]
        Private 		m_sKz, m_sOrt, m_sPlz As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


m_sOrt Variable

Private 		m_sKz, _
   m_sOrt, _
   m_sPlz As SqlString

Source code

[Visual Basic]
        Private 		m_sKz, m_sOrt, m_sPlz As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


m_sPlz Variable

Private 		m_sKz, _
   m_sOrt, _
   m_sPlz As SqlString

Source code

[Visual Basic]
        Private 		m_sKz, m_sOrt, m_sPlz As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOrt


clsPartner Class

For a list of all members of this type, see clsPartner Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsPartner

Public Class clsPartner
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsPartner Members


clsPartner Members

clsPartner overview

Constructors

constructor clsPartner Constructor

Properties

property bCDVSA00
property bSaldiert
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iAZEPL00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRFOG012
property iNRPAR00
property sBEBAN011
property sBEBAN012
property sBEBAN022
property sBEBAN21
property sBEPGM00
property sBKPAR00
property sCDBAL00
property sCDBNK00
property sCDVIG00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDMMSG00
property sIDMSG00
property sNRADR00
property sNRFOG011
property sNRFOG022
property sNRFOG21
property sNRPARAD
property sSAVRS00
property sTSMUT00
property sTXADZ011
property sTXADZ012
property sTXADZ021
property sTXADZ022
property sTXADZ031
property sTXADZ032
property sTXADZ041
property sTXADZ042
property sTXADZ051
property sTXADZ052
property sTXADZ061
property sTXADZ062
property sTXADZ071
property sTXADZ072
property sTXRes00
property sVDMUTER
property sZTMSG00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bCDVSA00
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bSaldiert
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iAZEPL00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRFOG012
field m_iNRPAR00
field m_sBEBAN011
field m_sBEBAN012
field m_sBEBAN022
field m_sBEBAN21
field m_sBEPGM00
field m_sBKPAR00
field m_sCDBAL00
field m_sCDBNK00
field m_sCDVIG00
field m_sDMMSG00
field m_sIDMSG00
field m_sNRADR00
field m_sNRFOG011
field m_sNRFOG022
field m_sNRFOG21
field m_sNRPARAD
field m_sSAVRS00
field m_sTSMUT00
field m_sTXADZ011
field m_sTXADZ012
field m_sTXADZ021
field m_sTXADZ022
field m_sTXADZ031
field m_sTXADZ032
field m_sTXADZ041
field m_sTXADZ042
field m_sTXADZ051
field m_sTXADZ052
field m_sTXADZ061
field m_sTXADZ062
field m_sTXADZ071
field m_sTXADZ072
field m_sTXRes00
field m_sVDMUTER
field m_sZTMSG00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsPartner Class


clsPartner Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner Properties

clsPartner overview

Properties

property bCDVSA00
property bSaldiert
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iAZEPL00
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRFOG012
property iNRPAR00
property sBEBAN011
property sBEBAN012
property sBEBAN022
property sBEBAN21
property sBEPGM00
property sBKPAR00
property sCDBAL00
property sCDBNK00
property sCDVIG00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDMMSG00
property sIDMSG00
property sNRADR00
property sNRFOG011
property sNRFOG022
property sNRFOG21
property sNRPARAD
property sSAVRS00
property sTSMUT00
property sTXADZ011
property sTXADZ012
property sTXADZ021
property sTXADZ022
property sTXADZ031
property sTXADZ032
property sTXADZ041
property sTXADZ042
property sTXADZ051
property sTXADZ052
property sTXADZ061
property sTXADZ062
property sTXADZ071
property sTXADZ072
property sTXRes00
property sVDMUTER
property sZTMSG00

See Also

clsPartner Class


clsPartner.bCDVSA00 Property

Public Property [bCDVSA00]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bCDVSA00]() As SqlBoolean
            Get
                Return m_bCDVSA00
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bCDVSA00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.bSaldiert Property

Public Property [bSaldiert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bSaldiert]() As SqlBoolean
            Get
                Return m_bSaldiert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bSaldiert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.iAZEPL00 Property

Public Property [iAZEPL00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAZEPL00]() As SqlInt32
            Get
                Return m_iAZEPL00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAZEPL00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.iNRFOG012 Property

Public Property [iNRFOG012]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRFOG012]() As SqlInt32
            Get
                Return m_iNRFOG012
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRFOG012 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRPAR00Tmp As SqlInt32 = Value
                If iNRPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
                End If
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBEBAN011 Property

Public Property [sBEBAN011]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN011]() As SqlString
            Get
                Return m_sBEBAN011
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN011 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBEBAN012 Property

Public Property [sBEBAN012]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN012]() As SqlString
            Get
                Return m_sBEBAN012
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN012 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBEBAN022 Property

Public Property [sBEBAN022]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN022]() As SqlString
            Get
                Return m_sBEBAN022
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN022 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBEBAN21 Property

Public Property [sBEBAN21]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN21]() As SqlString
            Get
                Return m_sBEBAN21
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN21 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBEPGM00 Property

Public Property [sBEPGM00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEPGM00]() As SqlString
            Get
                Return m_sBEPGM00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEPGM00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sBKPAR00 Property

Public Property [sBKPAR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBKPAR00]() As SqlString
            Get
                Return m_sBKPAR00
            End Get
            Set(ByVal Value As SqlString)
                m_sBKPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sCDBAL00 Property

Public Property [sCDBAL00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDBAL00]() As SqlString
            Get
                Return m_sCDBAL00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDBAL00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sCDBNK00 Property

Public Property [sCDBNK00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDBNK00]() As SqlString
            Get
                Return m_sCDBNK00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDBNK00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sCDVIG00 Property

Public Property [sCDVIG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDVIG00]() As SqlString
            Get
                Return m_sCDVIG00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDVIG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sDMMSG00 Property

Public Property [sDMMSG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sDMMSG00]() As SqlString
            Get
                Return m_sDMMSG00
            End Get
            Set(ByVal Value As SqlString)
                m_sDMMSG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sIDMSG00 Property

Public Property [sIDMSG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sIDMSG00]() As SqlString
            Get
                Return m_sIDMSG00
            End Get
            Set(ByVal Value As SqlString)
                m_sIDMSG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sNRADR00 Property

Public Property [sNRADR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRADR00]() As SqlString
            Get
                Return m_sNRADR00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRADR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sNRFOG011 Property

Public Property [sNRFOG011]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRFOG011]() As SqlString
            Get
                Return m_sNRFOG011
            End Get
            Set(ByVal Value As SqlString)
                m_sNRFOG011 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sNRFOG022 Property

Public Property [sNRFOG022]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRFOG022]() As SqlString
            Get
                Return m_sNRFOG022
            End Get
            Set(ByVal Value As SqlString)
                m_sNRFOG022 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sNRFOG21 Property

Public Property [sNRFOG21]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRFOG21]() As SqlString
            Get
                Return m_sNRFOG21
            End Get
            Set(ByVal Value As SqlString)
                m_sNRFOG21 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sNRPARAD Property

Public Property [sNRPARAD]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRPARAD]() As SqlString
            Get
                Return m_sNRPARAD
            End Get
            Set(ByVal Value As SqlString)
                m_sNRPARAD = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sSAVRS00 Property

Public Property [sSAVRS00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAVRS00]() As SqlString
            Get
                Return m_sSAVRS00
            End Get
            Set(ByVal Value As SqlString)
                m_sSAVRS00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTSMUT00 Property

Public Property [sTSMUT00]() As SqlString

Source code

[Visual Basic]
        Public Property [sTSMUT00]() As SqlString
            Get
                Return m_sTSMUT00
            End Get
            Set(ByVal Value As SqlString)
                m_sTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ011 Property

Public Property [sTXADZ011]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ011]() As SqlString
            Get
                Return m_sTXADZ011
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ011 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ012 Property

Public Property [sTXADZ012]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ012]() As SqlString
            Get
                Return m_sTXADZ012
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ012 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ021 Property

Public Property [sTXADZ021]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ021]() As SqlString
            Get
                Return m_sTXADZ021
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ021 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ022 Property

Public Property [sTXADZ022]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ022]() As SqlString
            Get
                Return m_sTXADZ022
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ022 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ031 Property

Public Property [sTXADZ031]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ031]() As SqlString
            Get
                Return m_sTXADZ031
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ031 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ032 Property

Public Property [sTXADZ032]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ032]() As SqlString
            Get
                Return m_sTXADZ032
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ032 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ041 Property

Public Property [sTXADZ041]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ041]() As SqlString
            Get
                Return m_sTXADZ041
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ041 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ042 Property

Public Property [sTXADZ042]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ042]() As SqlString
            Get
                Return m_sTXADZ042
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ042 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ051 Property

Public Property [sTXADZ051]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ051]() As SqlString
            Get
                Return m_sTXADZ051
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ051 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ052 Property

Public Property [sTXADZ052]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ052]() As SqlString
            Get
                Return m_sTXADZ052
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ052 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ061 Property

Public Property [sTXADZ061]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ061]() As SqlString
            Get
                Return m_sTXADZ061
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ061 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ062 Property

Public Property [sTXADZ062]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ062]() As SqlString
            Get
                Return m_sTXADZ062
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ062 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ071 Property

Public Property [sTXADZ071]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ071]() As SqlString
            Get
                Return m_sTXADZ071
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ071 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXADZ072 Property

Public Property [sTXADZ072]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXADZ072]() As SqlString
            Get
                Return m_sTXADZ072
            End Get
            Set(ByVal Value As SqlString)
                m_sTXADZ072 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sTXRes00 Property

Public Property [sTXRes00]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXRes00]() As SqlString
            Get
                Return m_sTXRes00
            End Get
            Set(ByVal Value As SqlString)
                m_sTXRes00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sVDMUTER Property

Public Property [sVDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sVDMUTER]() As SqlString
            Get
                Return m_sVDMUTER
            End Get
            Set(ByVal Value As SqlString)
                m_sVDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.sZTMSG00 Property

Public Property [sZTMSG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sZTMSG00]() As SqlString
            Get
                Return m_sZTMSG00
            End Get
            Set(ByVal Value As SqlString)
                m_sZTMSG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner Methods

clsPartner overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsPartner Class


clsPartner.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sIDMSG00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIDMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMMSG00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sZTMSG00", SqlDbType.VarChar, 12, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZTMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPGM00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPGM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBNK00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBNK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRFOG012", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRFOG012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN012", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN022", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ012", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ032", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ032))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ042", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ042))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ052", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ052))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ062", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ062))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ072", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ072))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARAD", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARAD))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRADR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRADR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG21", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG21))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN21", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN21))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ011", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ021", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ021))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ031", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ031))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ041", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ041))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ051", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ051))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ061", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ061))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ071", SqlDbType.VarChar, 53, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ071))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBAL00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBAL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDVIG00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDVIG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTSMUT00", SqlDbType.VarChar, 26, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVDMUTER", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRes00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRes00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSaldiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bSaldiert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAZEPL00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAZEPL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCDVSA00", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bCDVSA00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Partner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Partner")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    If dtToReturn.Rows(0)("IDMSG00") Is System.DBNull.Value Then
                        m_sIDMSG00 = SqlString.Null
                    Else
                        m_sIDMSG00 = New SqlString(CType(dtToReturn.Rows(0)("IDMSG00"), String))
                    End If
                    If dtToReturn.Rows(0)("DMMSG00") Is System.DBNull.Value Then
                        m_sDMMSG00 = SqlString.Null
                    Else
                        m_sDMMSG00 = New SqlString(CType(dtToReturn.Rows(0)("DMMSG00"), String))
                    End If
                    If dtToReturn.Rows(0)("ZTMSG00") Is System.DBNull.Value Then
                        m_sZTMSG00 = SqlString.Null
                    Else
                        m_sZTMSG00 = New SqlString(CType(dtToReturn.Rows(0)("ZTMSG00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEPGM00") Is System.DBNull.Value Then
                        m_sBEPGM00 = SqlString.Null
                    Else
                        m_sBEPGM00 = New SqlString(CType(dtToReturn.Rows(0)("BEPGM00"), String))
                    End If
                    If dtToReturn.Rows(0)("CDBNK00") Is System.DBNull.Value Then
                        m_sCDBNK00 = SqlString.Null
                    Else
                        m_sCDBNK00 = New SqlString(CType(dtToReturn.Rows(0)("CDBNK00"), String))
                    End If
                    m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    If dtToReturn.Rows(0)("BKPAR00") Is System.DBNull.Value Then
                        m_sBKPAR00 = SqlString.Null
                    Else
                        m_sBKPAR00 = New SqlString(CType(dtToReturn.Rows(0)("BKPAR00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFOG012") Is System.DBNull.Value Then
                        m_iNRFOG012 = SqlInt32.Null
                    Else
                        m_iNRFOG012 = New SqlInt32(CType(dtToReturn.Rows(0)("NRFOG012"), Integer))
                    End If
                    If dtToReturn.Rows(0)("BEBAN012") Is System.DBNull.Value Then
                        m_sBEBAN012 = SqlString.Null
                    Else
                        m_sBEBAN012 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN012"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFOG022") Is System.DBNull.Value Then
                        m_sNRFOG022 = SqlString.Null
                    Else
                        m_sNRFOG022 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG022"), String))
                    End If
                    If dtToReturn.Rows(0)("BEBAN022") Is System.DBNull.Value Then
                        m_sBEBAN022 = SqlString.Null
                    Else
                        m_sBEBAN022 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN022"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ012") Is System.DBNull.Value Then
                        m_sTXADZ012 = SqlString.Null
                    Else
                        m_sTXADZ012 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ012"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ022") Is System.DBNull.Value Then
                        m_sTXADZ022 = SqlString.Null
                    Else
                        m_sTXADZ022 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ022"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ032") Is System.DBNull.Value Then
                        m_sTXADZ032 = SqlString.Null
                    Else
                        m_sTXADZ032 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ032"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ042") Is System.DBNull.Value Then
                        m_sTXADZ042 = SqlString.Null
                    Else
                        m_sTXADZ042 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ042"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ052") Is System.DBNull.Value Then
                        m_sTXADZ052 = SqlString.Null
                    Else
                        m_sTXADZ052 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ052"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ062") Is System.DBNull.Value Then
                        m_sTXADZ062 = SqlString.Null
                    Else
                        m_sTXADZ062 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ062"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ072") Is System.DBNull.Value Then
                        m_sTXADZ072 = SqlString.Null
                    Else
                        m_sTXADZ072 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ072"), String))
                    End If
                    If dtToReturn.Rows(0)("NRPARAD") Is System.DBNull.Value Then
                        m_sNRPARAD = SqlString.Null
                    Else
                        m_sNRPARAD = New SqlString(CType(dtToReturn.Rows(0)("NRPARAD"), String))
                    End If
                    If dtToReturn.Rows(0)("NRADR00") Is System.DBNull.Value Then
                        m_sNRADR00 = SqlString.Null
                    Else
                        m_sNRADR00 = New SqlString(CType(dtToReturn.Rows(0)("NRADR00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFOG011") Is System.DBNull.Value Then
                        m_sNRFOG011 = SqlString.Null
                    Else
                        m_sNRFOG011 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG011"), String))
                    End If
                    If dtToReturn.Rows(0)("BEBAN011") Is System.DBNull.Value Then
                        m_sBEBAN011 = SqlString.Null
                    Else
                        m_sBEBAN011 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN011"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFOG21") Is System.DBNull.Value Then
                        m_sNRFOG21 = SqlString.Null
                    Else
                        m_sNRFOG21 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG21"), String))
                    End If
                    If dtToReturn.Rows(0)("BEBAN21") Is System.DBNull.Value Then
                        m_sBEBAN21 = SqlString.Null
                    Else
                        m_sBEBAN21 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN21"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ011") Is System.DBNull.Value Then
                        m_sTXADZ011 = SqlString.Null
                    Else
                        m_sTXADZ011 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ011"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ021") Is System.DBNull.Value Then
                        m_sTXADZ021 = SqlString.Null
                    Else
                        m_sTXADZ021 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ021"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ031") Is System.DBNull.Value Then
                        m_sTXADZ031 = SqlString.Null
                    Else
                        m_sTXADZ031 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ031"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ041") Is System.DBNull.Value Then
                        m_sTXADZ041 = SqlString.Null
                    Else
                        m_sTXADZ041 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ041"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ051") Is System.DBNull.Value Then
                        m_sTXADZ051 = SqlString.Null
                    Else
                        m_sTXADZ051 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ051"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ061") Is System.DBNull.Value Then
                        m_sTXADZ061 = SqlString.Null
                    Else
                        m_sTXADZ061 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ061"), String))
                    End If
                    If dtToReturn.Rows(0)("TXADZ071") Is System.DBNull.Value Then
                        m_sTXADZ071 = SqlString.Null
                    Else
                        m_sTXADZ071 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ071"), String))
                    End If
                    If dtToReturn.Rows(0)("CDBAL00") Is System.DBNull.Value Then
                        m_sCDBAL00 = SqlString.Null
                    Else
                        m_sCDBAL00 = New SqlString(CType(dtToReturn.Rows(0)("CDBAL00"), String))
                    End If
                    If dtToReturn.Rows(0)("CDVIG00") Is System.DBNull.Value Then
                        m_sCDVIG00 = SqlString.Null
                    Else
                        m_sCDVIG00 = New SqlString(CType(dtToReturn.Rows(0)("CDVIG00"), String))
                    End If
                    If dtToReturn.Rows(0)("SAVRS00") Is System.DBNull.Value Then
                        m_sSAVRS00 = SqlString.Null
                    Else
                        m_sSAVRS00 = New SqlString(CType(dtToReturn.Rows(0)("SAVRS00"), String))
                    End If
                    If dtToReturn.Rows(0)("TSMUT00") Is System.DBNull.Value Then
                        m_sTSMUT00 = SqlString.Null
                    Else
                        m_sTSMUT00 = New SqlString(CType(dtToReturn.Rows(0)("TSMUT00"), String))
                    End If
                    If dtToReturn.Rows(0)("VDMUTER") Is System.DBNull.Value Then
                        m_sVDMUTER = SqlString.Null
                    Else
                        m_sVDMUTER = New SqlString(CType(dtToReturn.Rows(0)("VDMUTER"), String))
                    End If
                    If dtToReturn.Rows(0)("TXRes00") Is System.DBNull.Value Then
                        m_sTXRes00 = SqlString.Null
                    Else
                        m_sTXRes00 = New SqlString(CType(dtToReturn.Rows(0)("TXRes00"), String))
                    End If
                    m_bSaldiert = New SqlBoolean(CType(dtToReturn.Rows(0)("Saldiert"), Boolean))
                    If dtToReturn.Rows(0)("AZEPL00") Is System.DBNull.Value Then
                        m_iAZEPL00 = SqlInt32.Null
                    Else
                        m_iAZEPL00 = New SqlInt32(CType(dtToReturn.Rows(0)("AZEPL00"), Integer))
                    End If
                    m_bCDVSA00 = New SqlBoolean(CType(dtToReturn.Rows(0)("CDVSA00"), Boolean))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sIDMSG00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIDMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMMSG00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sZTMSG00", SqlDbType.VarChar, 12, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZTMSG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPGM00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPGM00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBNK00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBNK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRFOG012", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRFOG012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN012", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN022", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ012", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ012))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ022))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ032", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ032))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ042", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ042))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ052", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ052))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ062", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ062))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ072", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ072))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARAD", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARAD))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRADR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRADR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG21", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG21))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN21", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN21))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ011", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ011))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ021", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ021))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ031", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ031))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ041", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ041))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ051", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ051))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ061", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ061))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ071", SqlDbType.VarChar, 53, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ071))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBAL00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBAL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDVIG00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDVIG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTSMUT00", SqlDbType.VarChar, 26, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sVDMUTER", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRes00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRes00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bSaldiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bSaldiert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iAZEPL00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAZEPL00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bCDVSA00", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bCDVSA00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner Fields

clsPartner overview

Fields

field m_bCDVSA00
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bSaldiert
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iAZEPL00
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRFOG012
field m_iNRPAR00
field m_sBEBAN011
field m_sBEBAN012
field m_sBEBAN022
field m_sBEBAN21
field m_sBEPGM00
field m_sBKPAR00
field m_sCDBAL00
field m_sCDBNK00
field m_sCDVIG00
field m_sDMMSG00
field m_sIDMSG00
field m_sNRADR00
field m_sNRFOG011
field m_sNRFOG022
field m_sNRFOG21
field m_sNRPARAD
field m_sSAVRS00
field m_sTSMUT00
field m_sTXADZ011
field m_sTXADZ012
field m_sTXADZ021
field m_sTXADZ022
field m_sTXADZ031
field m_sTXADZ032
field m_sTXADZ041
field m_sTXADZ042
field m_sTXADZ051
field m_sTXADZ052
field m_sTXADZ061
field m_sTXADZ062
field m_sTXADZ071
field m_sTXADZ072
field m_sTXRes00
field m_sVDMUTER
field m_sZTMSG00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsPartner Class


m_bCDVSA00 Variable

Private 		m_bSaldiert, _
   m_bCDVSA00 As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bSaldiert, m_bCDVSA00 As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_bSaldiert Variable

Private 		m_bSaldiert, _
   m_bCDVSA00 As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bSaldiert, m_bCDVSA00 As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_iAZEPL00 Variable

Private 		m_iNRFOG012, _
   m_iNRPAR00, _
   m_iAZEPL00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_iNRFOG012 Variable

Private 		m_iNRFOG012, _
   m_iNRPAR00, _
   m_iAZEPL00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_iNRPAR00 Variable

Private 		m_iNRFOG012, _
   m_iNRPAR00, _
   m_iAZEPL00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBEBAN011 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBEBAN012 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBEBAN022 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBEBAN21 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBEPGM00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sBKPAR00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sCDBAL00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sCDBNK00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sCDVIG00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sDMMSG00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sIDMSG00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sNRADR00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sNRFOG011 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sNRFOG022 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sNRFOG21 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sNRPARAD Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sSAVRS00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTSMUT00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ011 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ012 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ021 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ022 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ031 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ032 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ041 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ042 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ051 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ052 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ061 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ062 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ071 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXADZ072 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sTXRes00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sVDMUTER Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


m_sZTMSG00 Variable

Private 		m_sTXADZ021, _
   m_sTXADZ031, _
   m_sTXADZ051, _
   m_sTXADZ041, _
   m_sNRFOG21, _
   m_sBEBAN011, _
   m_sTXADZ011, _
   m_sBEBAN21, _
   m_sTSMUT00, _
   m_sSAVRS00, _
   m_sTXRes00, _
   m_sVDMUTER, _
   m_sTXADZ071, _
   m_sTXADZ061, _
   m_sCDVIG00, _
   m_sCDBAL00, _
   m_sBEBAN012, _
   m_sBKPAR00, _
   m_sBEBAN022, _
   m_sNRFOG022, _
   m_sCDBNK00, _
   m_sDMMSG00, _
   m_sIDMSG00, _
   m_sBEPGM00, _
   m_sZTMSG00, _
   m_sTXADZ012, _
   m_sNRPARAD, _
   m_sTXADZ072, _
   m_sNRFOG011, _
   m_sNRADR00, _
   m_sTXADZ062, _
   m_sTXADZ032, _
   m_sTXADZ022, _
   m_sTXADZ052, _
   m_sTXADZ042 As SqlString

Source code

[Visual Basic]
        Private 		m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner


clsPartner_Hauptadresse Class

For a list of all members of this type, see clsPartner_Hauptadresse Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsPartner_Hauptadresse

Public Class clsPartner_Hauptadresse
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsPartner_Hauptadresse Members


clsPartner_Hauptadresse Members

clsPartner_Hauptadresse overview

Constructors

constructor clsPartner_Hauptadresse Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMKTRNA
property daTSMUT00
property dcAZVRNHI
property iCDORTPT
property iCDSTRPT
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property sBEBAN01
property sBEBAN02
property sBECOT01
property sBECOT02
property sBEDIS00
property sBEFCHPT
property sBENAM01
property sBENAM02
property sBENAM03
property sBENNM01
property sBENNM02
property sBENNMZ1
property sBENNMZ2
property sBEORTPT
property sBEORTZS
property sBESTR00
property sBETRZNN
property sBETRZZH
property sBETTN00
property sBEVNM01
property sBEVNM02
property sBEVNM03
property sBEVNM04
property sBEVNMZH
property sBEWEI00
property sCDKTRNA
property sCDMUTER
property sCDPAW00
property sCDPLZ00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNRFCHPT
property sNRHAU00
property sNRPARVO
property sNRSTC00
property sSAKTRNA
property sSAREC00
property sSAREC01
property sSAVRS00
property siNRAAT00
property siNRADR00
property siNRARD00
property siNRARDZH
property siNRFOG01
property siNRFOG02
property siNRLND00
property siNRNGR00
property siNRNZU00
property siNRNZUZH
property siNRTTV00
property siNRTTVZH
property siNRTTZ00
property siNRTTZZH
property siNRUZG00
property siNRVAZ00
property siNRVRN00
property siNRVRNRI
property siNRZHK00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMKTRNA
field m_daTSMUT00
field m_dcAZVRNHI
field m_iCDORTPT
field m_iCDSTRPT
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_sBEBAN01
field m_sBEBAN02
field m_sBECOT01
field m_sBECOT02
field m_sBEDIS00
field m_sBEFCHPT
field m_sBENAM01
field m_sBENAM02
field m_sBENAM03
field m_sBENNM01
field m_sBENNM02
field m_sBENNMZ1
field m_sBENNMZ2
field m_sBEORTPT
field m_sBEORTZS
field m_sBESTR00
field m_sBETRZNN
field m_sBETRZZH
field m_sBETTN00
field m_sBEVNM01
field m_sBEVNM02
field m_sBEVNM03
field m_sBEVNM04
field m_sBEVNMZH
field m_sBEWEI00
field m_sCDKTRNA
field m_sCDMUTER
field m_sCDPAW00
field m_sCDPLZ00
field m_sNRFCHPT
field m_sNRHAU00
field m_sNRPARVO
field m_sNRSTC00
field m_sSAKTRNA
field m_sSAREC00
field m_sSAREC01
field m_sSAVRS00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRAAT00
field m_siNRADR00
field m_siNRARD00
field m_siNRARDZH
field m_siNRFOG01
field m_siNRFOG02
field m_siNRLND00
field m_siNRNGR00
field m_siNRNZU00
field m_siNRNZUZH
field m_siNRTTV00
field m_siNRTTVZH
field m_siNRTTZ00
field m_siNRTTZZH
field m_siNRUZG00
field m_siNRVAZ00
field m_siNRVRN00
field m_siNRVRNRI
field m_siNRZHK00

See Also

clsPartner_Hauptadresse Class


clsPartner_Hauptadresse Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse Properties

clsPartner_Hauptadresse overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daDMERF00
property daDMKTRNA
property daTSMUT00
property dcAZVRNHI
property iCDORTPT
property iCDSTRPT
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property sBEBAN01
property sBEBAN02
property sBECOT01
property sBECOT02
property sBEDIS00
property sBEFCHPT
property sBENAM01
property sBENAM02
property sBENAM03
property sBENNM01
property sBENNM02
property sBENNMZ1
property sBENNMZ2
property sBEORTPT
property sBEORTZS
property sBESTR00
property sBETRZNN
property sBETRZZH
property sBETTN00
property sBEVNM01
property sBEVNM02
property sBEVNM03
property sBEVNM04
property sBEVNMZH
property sBEWEI00
property sCDKTRNA
property sCDMUTER
property sCDPAW00
property sCDPLZ00
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNRFCHPT
property sNRHAU00
property sNRPARVO
property sNRSTC00
property sSAKTRNA
property sSAREC00
property sSAREC01
property sSAVRS00
property siNRAAT00
property siNRADR00
property siNRARD00
property siNRARDZH
property siNRFOG01
property siNRFOG02
property siNRLND00
property siNRNGR00
property siNRNZU00
property siNRNZUZH
property siNRTTV00
property siNRTTVZH
property siNRTTZ00
property siNRTTZZH
property siNRUZG00
property siNRVAZ00
property siNRVRN00
property siNRVRNRI
property siNRZHK00

See Also

clsPartner_Hauptadresse Class


clsPartner_Hauptadresse.daDMERF00 Property

Public Property [daDMERF00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMERF00]() As SqlDateTime
            Get
                Return m_daDMERF00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMERF00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.daDMKTRNA Property

Public Property [daDMKTRNA]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDMKTRNA]() As SqlDateTime
            Get
                Return m_daDMKTRNA
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDMKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.daTSMUT00 Property

Public Property [daTSMUT00]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTSMUT00]() As SqlDateTime
            Get
                Return m_daTSMUT00
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTSMUT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.dcAZVRNHI Property

Public Property [dcAZVRNHI]() As SqlDecimal

Source code

[Visual Basic]
        Public Property [dcAZVRNHI]() As SqlDecimal
            Get
                Return m_dcAZVRNHI
            End Get
            Set(ByVal Value As SqlDecimal)
                m_dcAZVRNHI = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.iCDORTPT Property

Public Property [iCDORTPT]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCDORTPT]() As SqlInt32
            Get
                Return m_iCDORTPT
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCDORTPT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.iCDSTRPT Property

Public Property [iCDSTRPT]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCDSTRPT]() As SqlInt32
            Get
                Return m_iCDSTRPT
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCDSTRPT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRPAR00Tmp As SqlInt32 = Value
                If iNRPAR00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
                End If
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEBAN01 Property

Public Property [sBEBAN01]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN01]() As SqlString
            Get
                Return m_sBEBAN01
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEBAN02 Property

Public Property [sBEBAN02]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEBAN02]() As SqlString
            Get
                Return m_sBEBAN02
            End Get
            Set(ByVal Value As SqlString)
                m_sBEBAN02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBECOT01 Property

Public Property [sBECOT01]() As SqlString

Source code

[Visual Basic]
        Public Property [sBECOT01]() As SqlString
            Get
                Return m_sBECOT01
            End Get
            Set(ByVal Value As SqlString)
                m_sBECOT01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBECOT02 Property

Public Property [sBECOT02]() As SqlString

Source code

[Visual Basic]
        Public Property [sBECOT02]() As SqlString
            Get
                Return m_sBECOT02
            End Get
            Set(ByVal Value As SqlString)
                m_sBECOT02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEDIS00 Property

Public Property [sBEDIS00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEDIS00]() As SqlString
            Get
                Return m_sBEDIS00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEDIS00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEFCHPT Property

Public Property [sBEFCHPT]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEFCHPT]() As SqlString
            Get
                Return m_sBEFCHPT
            End Get
            Set(ByVal Value As SqlString)
                m_sBEFCHPT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENAM01 Property

Public Property [sBENAM01]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENAM01]() As SqlString
            Get
                Return m_sBENAM01
            End Get
            Set(ByVal Value As SqlString)
                m_sBENAM01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENAM02 Property

Public Property [sBENAM02]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENAM02]() As SqlString
            Get
                Return m_sBENAM02
            End Get
            Set(ByVal Value As SqlString)
                m_sBENAM02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENAM03 Property

Public Property [sBENAM03]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENAM03]() As SqlString
            Get
                Return m_sBENAM03
            End Get
            Set(ByVal Value As SqlString)
                m_sBENAM03 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENNM01 Property

Public Property [sBENNM01]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENNM01]() As SqlString
            Get
                Return m_sBENNM01
            End Get
            Set(ByVal Value As SqlString)
                m_sBENNM01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENNM02 Property

Public Property [sBENNM02]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENNM02]() As SqlString
            Get
                Return m_sBENNM02
            End Get
            Set(ByVal Value As SqlString)
                m_sBENNM02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENNMZ1 Property

Public Property [sBENNMZ1]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENNMZ1]() As SqlString
            Get
                Return m_sBENNMZ1
            End Get
            Set(ByVal Value As SqlString)
                m_sBENNMZ1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBENNMZ2 Property

Public Property [sBENNMZ2]() As SqlString

Source code

[Visual Basic]
        Public Property [sBENNMZ2]() As SqlString
            Get
                Return m_sBENNMZ2
            End Get
            Set(ByVal Value As SqlString)
                m_sBENNMZ2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEORTPT Property

Public Property [sBEORTPT]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEORTPT]() As SqlString
            Get
                Return m_sBEORTPT
            End Get
            Set(ByVal Value As SqlString)
                m_sBEORTPT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEORTZS Property

Public Property [sBEORTZS]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEORTZS]() As SqlString
            Get
                Return m_sBEORTZS
            End Get
            Set(ByVal Value As SqlString)
                m_sBEORTZS = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBESTR00 Property

Public Property [sBESTR00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBESTR00]() As SqlString
            Get
                Return m_sBESTR00
            End Get
            Set(ByVal Value As SqlString)
                m_sBESTR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBETRZNN Property

Public Property [sBETRZNN]() As SqlString

Source code

[Visual Basic]
        Public Property [sBETRZNN]() As SqlString
            Get
                Return m_sBETRZNN
            End Get
            Set(ByVal Value As SqlString)
                m_sBETRZNN = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBETRZZH Property

Public Property [sBETRZZH]() As SqlString

Source code

[Visual Basic]
        Public Property [sBETRZZH]() As SqlString
            Get
                Return m_sBETRZZH
            End Get
            Set(ByVal Value As SqlString)
                m_sBETRZZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBETTN00 Property

Public Property [sBETTN00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBETTN00]() As SqlString
            Get
                Return m_sBETTN00
            End Get
            Set(ByVal Value As SqlString)
                m_sBETTN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEVNM01 Property

Public Property [sBEVNM01]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEVNM01]() As SqlString
            Get
                Return m_sBEVNM01
            End Get
            Set(ByVal Value As SqlString)
                m_sBEVNM01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEVNM02 Property

Public Property [sBEVNM02]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEVNM02]() As SqlString
            Get
                Return m_sBEVNM02
            End Get
            Set(ByVal Value As SqlString)
                m_sBEVNM02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEVNM03 Property

Public Property [sBEVNM03]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEVNM03]() As SqlString
            Get
                Return m_sBEVNM03
            End Get
            Set(ByVal Value As SqlString)
                m_sBEVNM03 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEVNM04 Property

Public Property [sBEVNM04]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEVNM04]() As SqlString
            Get
                Return m_sBEVNM04
            End Get
            Set(ByVal Value As SqlString)
                m_sBEVNM04 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEVNMZH Property

Public Property [sBEVNMZH]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEVNMZH]() As SqlString
            Get
                Return m_sBEVNMZH
            End Get
            Set(ByVal Value As SqlString)
                m_sBEVNMZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sBEWEI00 Property

Public Property [sBEWEI00]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEWEI00]() As SqlString
            Get
                Return m_sBEWEI00
            End Get
            Set(ByVal Value As SqlString)
                m_sBEWEI00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sCDKTRNA Property

Public Property [sCDKTRNA]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDKTRNA]() As SqlString
            Get
                Return m_sCDKTRNA
            End Get
            Set(ByVal Value As SqlString)
                m_sCDKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sCDMUTER Property

Public Property [sCDMUTER]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDMUTER]() As SqlString
            Get
                Return m_sCDMUTER
            End Get
            Set(ByVal Value As SqlString)
                m_sCDMUTER = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sCDPAW00 Property

Public Property [sCDPAW00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDPAW00]() As SqlString
            Get
                Return m_sCDPAW00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDPAW00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sCDPLZ00 Property

Public Property [sCDPLZ00]() As SqlString

Source code

[Visual Basic]
        Public Property [sCDPLZ00]() As SqlString
            Get
                Return m_sCDPLZ00
            End Get
            Set(ByVal Value As SqlString)
                m_sCDPLZ00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sNRFCHPT Property

Public Property [sNRFCHPT]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRFCHPT]() As SqlString
            Get
                Return m_sNRFCHPT
            End Get
            Set(ByVal Value As SqlString)
                m_sNRFCHPT = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sNRHAU00 Property

Public Property [sNRHAU00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRHAU00]() As SqlString
            Get
                Return m_sNRHAU00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRHAU00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sNRPARVO Property

Public Property [sNRPARVO]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRPARVO]() As SqlString
            Get
                Return m_sNRPARVO
            End Get
            Set(ByVal Value As SqlString)
                m_sNRPARVO = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sNRSTC00 Property

Public Property [sNRSTC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNRSTC00]() As SqlString
            Get
                Return m_sNRSTC00
            End Get
            Set(ByVal Value As SqlString)
                m_sNRSTC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sSAKTRNA Property

Public Property [sSAKTRNA]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAKTRNA]() As SqlString
            Get
                Return m_sSAKTRNA
            End Get
            Set(ByVal Value As SqlString)
                m_sSAKTRNA = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sSAREC01 Property

Public Property [sSAREC01]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC01]() As SqlString
            Get
                Return m_sSAREC01
            End Get
            Set(ByVal Value As SqlString)
                m_sSAREC01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.sSAVRS00 Property

Public Property [sSAVRS00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAVRS00]() As SqlString
            Get
                Return m_sSAVRS00
            End Get
            Set(ByVal Value As SqlString)
                m_sSAVRS00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRAAT00 Property

Public Property [siNRAAT00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRAAT00]() As SqlInt16
            Get
                Return m_siNRAAT00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRAAT00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRADR00 Property

Public Property [siNRADR00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRADR00]() As SqlInt16
            Get
                Return m_siNRADR00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRADR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRARD00 Property

Public Property [siNRARD00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRARD00]() As SqlInt16
            Get
                Return m_siNRARD00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRARD00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRARDZH Property

Public Property [siNRARDZH]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRARDZH]() As SqlInt16
            Get
                Return m_siNRARDZH
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRARDZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRFOG01 Property

Public Property [siNRFOG01]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRFOG01]() As SqlInt16
            Get
                Return m_siNRFOG01
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRFOG01 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRFOG02 Property

Public Property [siNRFOG02]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRFOG02]() As SqlInt16
            Get
                Return m_siNRFOG02
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRFOG02 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRLND00 Property

Public Property [siNRLND00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRLND00]() As SqlInt16
            Get
                Return m_siNRLND00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRLND00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRNGR00 Property

Public Property [siNRNGR00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRNGR00]() As SqlInt16
            Get
                Return m_siNRNGR00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRNGR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRNZU00 Property

Public Property [siNRNZU00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRNZU00]() As SqlInt16
            Get
                Return m_siNRNZU00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRNZU00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRNZUZH Property

Public Property [siNRNZUZH]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRNZUZH]() As SqlInt16
            Get
                Return m_siNRNZUZH
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRNZUZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRTTV00 Property

Public Property [siNRTTV00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRTTV00]() As SqlInt16
            Get
                Return m_siNRTTV00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRTTV00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRTTVZH Property

Public Property [siNRTTVZH]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRTTVZH]() As SqlInt16
            Get
                Return m_siNRTTVZH
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRTTVZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRTTZ00 Property

Public Property [siNRTTZ00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRTTZ00]() As SqlInt16
            Get
                Return m_siNRTTZ00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRTTZ00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRTTZZH Property

Public Property [siNRTTZZH]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRTTZZH]() As SqlInt16
            Get
                Return m_siNRTTZZH
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRTTZZH = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRUZG00 Property

Public Property [siNRUZG00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRUZG00]() As SqlInt16
            Get
                Return m_siNRUZG00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRUZG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRVAZ00 Property

Public Property [siNRVAZ00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVAZ00]() As SqlInt16
            Get
                Return m_siNRVAZ00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRVAZ00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRVRN00 Property

Public Property [siNRVRN00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRN00]() As SqlInt16
            Get
                Return m_siNRVRN00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRVRN00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRVRNRI Property

Public Property [siNRVRNRI]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRVRNRI]() As SqlInt16
            Get
                Return m_siNRVRNRI
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRVRNRI = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.siNRZHK00 Property

Public Property [siNRZHK00]() As SqlInt16

Source code

[Visual Basic]
        Public Property [siNRZHK00]() As SqlInt16
            Get
                Return m_siNRZHK00
            End Get
            Set(ByVal Value As SqlInt16)
                m_siNRZHK00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse Methods

clsPartner_Hauptadresse overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsPartner_Hauptadresse Class


clsPartner_Hauptadresse.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Hauptadresse_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Hauptadresse_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner_Hauptadresse::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Hauptadresse_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRADR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRADR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRAAT00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRAAT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARVO", SqlDbType.NVarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARVO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVAZ00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVAZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRARD00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRARD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTV00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTV00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM01", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM02", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM03", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM04", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM04))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTZ00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNM01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETRZNN", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETRZNN))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNM02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNZU00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNZU00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETTN00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETTN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM03", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBECOT01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBECOT01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBECOT02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBECOT02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRZHK00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRZHK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRARDZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRARDZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTVZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTVZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNMZH", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNMZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTZZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTZZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNMZ1", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNMZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETRZZH", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETRZZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNMZ2", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNMZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNZUZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNZUZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORTZS", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORTZS))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEWEI00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEWEI00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEFCHPT", SqlDbType.NVarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEFCHPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFCHPT", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFCHPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBESTR00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBESTR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRHAU00", SqlDbType.NVarChar, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRHAU00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRSTC00", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRSTC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRLND00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRLND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPLZ00", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPLZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORTPT", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORTPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEDIS00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEDIS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iCDORTPT", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCDORTPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iCDSTRPT", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCDSTRPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRUZG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRUZG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNGR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNGR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRFOG01", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRFOG01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN01", SqlDbType.NVarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRFOG02", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRFOG02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN02", SqlDbType.NVarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRNRI", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVRNRI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.NVarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcAZVRNHI", SqlDbType.Decimal, 5, ParameterDirection.Input, True, 5, 1, "", DataRowVersion.Proposed, m_dcAZVRNHI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMKTRNA", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDKTRNA", SqlDbType.NVarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAKTRNA", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPAW00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPAW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC01", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC01))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Hauptadresse_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner_Hauptadresse::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Hauptadresse_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Partner_Hauptadresse")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Hauptadresse_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner_Hauptadresse::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Hauptadresse_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Partner_Hauptadresse")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Hauptadresse_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    If dtToReturn.Rows(0)("NRADR00") Is System.DBNull.Value Then
                        m_siNRADR00 = SqlInt16.Null
                    Else
                        m_siNRADR00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRADR00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRVRN00") Is System.DBNull.Value Then
                        m_siNRVRN00 = SqlInt16.Null
                    Else
                        m_siNRVRN00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRN00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRAAT00") Is System.DBNull.Value Then
                        m_siNRAAT00 = SqlInt16.Null
                    Else
                        m_siNRAAT00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRAAT00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRPARVO") Is System.DBNull.Value Then
                        m_sNRPARVO = SqlString.Null
                    Else
                        m_sNRPARVO = New SqlString(CType(dtToReturn.Rows(0)("NRPARVO"), String))
                    End If
                    If dtToReturn.Rows(0)("NRVAZ00") Is System.DBNull.Value Then
                        m_siNRVAZ00 = SqlInt16.Null
                    Else
                        m_siNRVAZ00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRVAZ00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRARD00") Is System.DBNull.Value Then
                        m_siNRARD00 = SqlInt16.Null
                    Else
                        m_siNRARD00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRARD00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRTTV00") Is System.DBNull.Value Then
                        m_siNRTTV00 = SqlInt16.Null
                    Else
                        m_siNRTTV00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRTTV00"), Short))
                    End If
                    If dtToReturn.Rows(0)("BEVNM01") Is System.DBNull.Value Then
                        m_sBEVNM01 = SqlString.Null
                    Else
                        m_sBEVNM01 = New SqlString(CType(dtToReturn.Rows(0)("BEVNM01"), String))
                    End If
                    If dtToReturn.Rows(0)("BEVNM02") Is System.DBNull.Value Then
                        m_sBEVNM02 = SqlString.Null
                    Else
                        m_sBEVNM02 = New SqlString(CType(dtToReturn.Rows(0)("BEVNM02"), String))
                    End If
                    If dtToReturn.Rows(0)("BEVNM03") Is System.DBNull.Value Then
                        m_sBEVNM03 = SqlString.Null
                    Else
                        m_sBEVNM03 = New SqlString(CType(dtToReturn.Rows(0)("BEVNM03"), String))
                    End If
                    If dtToReturn.Rows(0)("BEVNM04") Is System.DBNull.Value Then
                        m_sBEVNM04 = SqlString.Null
                    Else
                        m_sBEVNM04 = New SqlString(CType(dtToReturn.Rows(0)("BEVNM04"), String))
                    End If
                    If dtToReturn.Rows(0)("NRTTZ00") Is System.DBNull.Value Then
                        m_siNRTTZ00 = SqlInt16.Null
                    Else
                        m_siNRTTZ00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRTTZ00"), Short))
                    End If
                    If dtToReturn.Rows(0)("BENNM01") Is System.DBNull.Value Then
                        m_sBENNM01 = SqlString.Null
                    Else
                        m_sBENNM01 = New SqlString(CType(dtToReturn.Rows(0)("BENNM01"), String))
                    End If
                    If dtToReturn.Rows(0)("BETRZNN") Is System.DBNull.Value Then
                        m_sBETRZNN = SqlString.Null
                    Else
                        m_sBETRZNN = New SqlString(CType(dtToReturn.Rows(0)("BETRZNN"), String))
                    End If
                    If dtToReturn.Rows(0)("BENNM02") Is System.DBNull.Value Then
                        m_sBENNM02 = SqlString.Null
                    Else
                        m_sBENNM02 = New SqlString(CType(dtToReturn.Rows(0)("BENNM02"), String))
                    End If
                    If dtToReturn.Rows(0)("NRNZU00") Is System.DBNull.Value Then
                        m_siNRNZU00 = SqlInt16.Null
                    Else
                        m_siNRNZU00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRNZU00"), Short))
                    End If
                    If dtToReturn.Rows(0)("BETTN00") Is System.DBNull.Value Then
                        m_sBETTN00 = SqlString.Null
                    Else
                        m_sBETTN00 = New SqlString(CType(dtToReturn.Rows(0)("BETTN00"), String))
                    End If
                    If dtToReturn.Rows(0)("BENAM01") Is System.DBNull.Value Then
                        m_sBENAM01 = SqlString.Null
                    Else
                        m_sBENAM01 = New SqlString(CType(dtToReturn.Rows(0)("BENAM01"), String))
                    End If
                    If dtToReturn.Rows(0)("BENAM02") Is System.DBNull.Value Then
                        m_sBENAM02 = SqlString.Null
                    Else
                        m_sBENAM02 = New SqlString(CType(dtToReturn.Rows(0)("BENAM02"), String))
                    End If
                    If dtToReturn.Rows(0)("BENAM03") Is System.DBNull.Value Then
                        m_sBENAM03 = SqlString.Null
                    Else
                        m_sBENAM03 = New SqlString(CType(dtToReturn.Rows(0)("BENAM03"), String))
                    End If
                    If dtToReturn.Rows(0)("BECOT01") Is System.DBNull.Value Then
                        m_sBECOT01 = SqlString.Null
                    Else
                        m_sBECOT01 = New SqlString(CType(dtToReturn.Rows(0)("BECOT01"), String))
                    End If
                    If dtToReturn.Rows(0)("BECOT02") Is System.DBNull.Value Then
                        m_sBECOT02 = SqlString.Null
                    Else
                        m_sBECOT02 = New SqlString(CType(dtToReturn.Rows(0)("BECOT02"), String))
                    End If
                    If dtToReturn.Rows(0)("NRZHK00") Is System.DBNull.Value Then
                        m_siNRZHK00 = SqlInt16.Null
                    Else
                        m_siNRZHK00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRZHK00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRARDZH") Is System.DBNull.Value Then
                        m_siNRARDZH = SqlInt16.Null
                    Else
                        m_siNRARDZH = New SqlInt16(CType(dtToReturn.Rows(0)("NRARDZH"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRTTVZH") Is System.DBNull.Value Then
                        m_siNRTTVZH = SqlInt16.Null
                    Else
                        m_siNRTTVZH = New SqlInt16(CType(dtToReturn.Rows(0)("NRTTVZH"), Short))
                    End If
                    If dtToReturn.Rows(0)("BEVNMZH") Is System.DBNull.Value Then
                        m_sBEVNMZH = SqlString.Null
                    Else
                        m_sBEVNMZH = New SqlString(CType(dtToReturn.Rows(0)("BEVNMZH"), String))
                    End If
                    If dtToReturn.Rows(0)("NRTTZZH") Is System.DBNull.Value Then
                        m_siNRTTZZH = SqlInt16.Null
                    Else
                        m_siNRTTZZH = New SqlInt16(CType(dtToReturn.Rows(0)("NRTTZZH"), Short))
                    End If
                    If dtToReturn.Rows(0)("BENNMZ1") Is System.DBNull.Value Then
                        m_sBENNMZ1 = SqlString.Null
                    Else
                        m_sBENNMZ1 = New SqlString(CType(dtToReturn.Rows(0)("BENNMZ1"), String))
                    End If
                    If dtToReturn.Rows(0)("BETRZZH") Is System.DBNull.Value Then
                        m_sBETRZZH = SqlString.Null
                    Else
                        m_sBETRZZH = New SqlString(CType(dtToReturn.Rows(0)("BETRZZH"), String))
                    End If
                    If dtToReturn.Rows(0)("BENNMZ2") Is System.DBNull.Value Then
                        m_sBENNMZ2 = SqlString.Null
                    Else
                        m_sBENNMZ2 = New SqlString(CType(dtToReturn.Rows(0)("BENNMZ2"), String))
                    End If
                    If dtToReturn.Rows(0)("NRNZUZH") Is System.DBNull.Value Then
                        m_siNRNZUZH = SqlInt16.Null
                    Else
                        m_siNRNZUZH = New SqlInt16(CType(dtToReturn.Rows(0)("NRNZUZH"), Short))
                    End If
                    If dtToReturn.Rows(0)("BEORTZS") Is System.DBNull.Value Then
                        m_sBEORTZS = SqlString.Null
                    Else
                        m_sBEORTZS = New SqlString(CType(dtToReturn.Rows(0)("BEORTZS"), String))
                    End If
                    If dtToReturn.Rows(0)("BEWEI00") Is System.DBNull.Value Then
                        m_sBEWEI00 = SqlString.Null
                    Else
                        m_sBEWEI00 = New SqlString(CType(dtToReturn.Rows(0)("BEWEI00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEFCHPT") Is System.DBNull.Value Then
                        m_sBEFCHPT = SqlString.Null
                    Else
                        m_sBEFCHPT = New SqlString(CType(dtToReturn.Rows(0)("BEFCHPT"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFCHPT") Is System.DBNull.Value Then
                        m_sNRFCHPT = SqlString.Null
                    Else
                        m_sNRFCHPT = New SqlString(CType(dtToReturn.Rows(0)("NRFCHPT"), String))
                    End If
                    If dtToReturn.Rows(0)("BESTR00") Is System.DBNull.Value Then
                        m_sBESTR00 = SqlString.Null
                    Else
                        m_sBESTR00 = New SqlString(CType(dtToReturn.Rows(0)("BESTR00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRHAU00") Is System.DBNull.Value Then
                        m_sNRHAU00 = SqlString.Null
                    Else
                        m_sNRHAU00 = New SqlString(CType(dtToReturn.Rows(0)("NRHAU00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRSTC00") Is System.DBNull.Value Then
                        m_sNRSTC00 = SqlString.Null
                    Else
                        m_sNRSTC00 = New SqlString(CType(dtToReturn.Rows(0)("NRSTC00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRLND00") Is System.DBNull.Value Then
                        m_siNRLND00 = SqlInt16.Null
                    Else
                        m_siNRLND00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRLND00"), Short))
                    End If
                    If dtToReturn.Rows(0)("CDPLZ00") Is System.DBNull.Value Then
                        m_sCDPLZ00 = SqlString.Null
                    Else
                        m_sCDPLZ00 = New SqlString(CType(dtToReturn.Rows(0)("CDPLZ00"), String))
                    End If
                    If dtToReturn.Rows(0)("BEORTPT") Is System.DBNull.Value Then
                        m_sBEORTPT = SqlString.Null
                    Else
                        m_sBEORTPT = New SqlString(CType(dtToReturn.Rows(0)("BEORTPT"), String))
                    End If
                    If dtToReturn.Rows(0)("BEDIS00") Is System.DBNull.Value Then
                        m_sBEDIS00 = SqlString.Null
                    Else
                        m_sBEDIS00 = New SqlString(CType(dtToReturn.Rows(0)("BEDIS00"), String))
                    End If
                    If dtToReturn.Rows(0)("CDORTPT") Is System.DBNull.Value Then
                        m_iCDORTPT = SqlInt32.Null
                    Else
                        m_iCDORTPT = New SqlInt32(CType(dtToReturn.Rows(0)("CDORTPT"), Integer))
                    End If
                    If dtToReturn.Rows(0)("CDSTRPT") Is System.DBNull.Value Then
                        m_iCDSTRPT = SqlInt32.Null
                    Else
                        m_iCDSTRPT = New SqlInt32(CType(dtToReturn.Rows(0)("CDSTRPT"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SAVRS00") Is System.DBNull.Value Then
                        m_sSAVRS00 = SqlString.Null
                    Else
                        m_sSAVRS00 = New SqlString(CType(dtToReturn.Rows(0)("SAVRS00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRUZG00") Is System.DBNull.Value Then
                        m_siNRUZG00 = SqlInt16.Null
                    Else
                        m_siNRUZG00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRUZG00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRNGR00") Is System.DBNull.Value Then
                        m_siNRNGR00 = SqlInt16.Null
                    Else
                        m_siNRNGR00 = New SqlInt16(CType(dtToReturn.Rows(0)("NRNGR00"), Short))
                    End If
                    If dtToReturn.Rows(0)("NRFOG01") Is System.DBNull.Value Then
                        m_siNRFOG01 = SqlInt16.Null
                    Else
                        m_siNRFOG01 = New SqlInt16(CType(dtToReturn.Rows(0)("NRFOG01"), Short))
                    End If
                    If dtToReturn.Rows(0)("BEBAN01") Is System.DBNull.Value Then
                        m_sBEBAN01 = SqlString.Null
                    Else
                        m_sBEBAN01 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN01"), String))
                    End If
                    If dtToReturn.Rows(0)("NRFOG02") Is System.DBNull.Value Then
                        m_siNRFOG02 = SqlInt16.Null
                    Else
                        m_siNRFOG02 = New SqlInt16(CType(dtToReturn.Rows(0)("NRFOG02"), Short))
                    End If
                    If dtToReturn.Rows(0)("BEBAN02") Is System.DBNull.Value Then
                        m_sBEBAN02 = SqlString.Null
                    Else
                        m_sBEBAN02 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN02"), String))
                    End If
                    If dtToReturn.Rows(0)("NRVRNRI") Is System.DBNull.Value Then
                        m_siNRVRNRI = SqlInt16.Null
                    Else
                        m_siNRVRNRI = New SqlInt16(CType(dtToReturn.Rows(0)("NRVRNRI"), Short))
                    End If
                    If dtToReturn.Rows(0)("CDMUTER") Is System.DBNull.Value Then
                        m_sCDMUTER = SqlString.Null
                    Else
                        m_sCDMUTER = New SqlString(CType(dtToReturn.Rows(0)("CDMUTER"), String))
                    End If
                    If dtToReturn.Rows(0)("TSMUT00") Is System.DBNull.Value Then
                        m_daTSMUT00 = SqlDateTime.Null
                    Else
                        m_daTSMUT00 = New SqlDateTime(CType(dtToReturn.Rows(0)("TSMUT00"), Date))
                    End If
                    If dtToReturn.Rows(0)("AZVRNHI") Is System.DBNull.Value Then
                        m_dcAZVRNHI = SqlDecimal.Null
                    Else
                        m_dcAZVRNHI = New SqlDecimal(CType(dtToReturn.Rows(0)("AZVRNHI"), Decimal))
                    End If
                    If dtToReturn.Rows(0)("DMERF00") Is System.DBNull.Value Then
                        m_daDMERF00 = SqlDateTime.Null
                    Else
                        m_daDMERF00 = New SqlDateTime(CType(dtToReturn.Rows(0)("DMERF00"), Date))
                    End If
                    If dtToReturn.Rows(0)("SAREC00") Is System.DBNull.Value Then
                        m_sSAREC00 = SqlString.Null
                    Else
                        m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                    End If
                    If dtToReturn.Rows(0)("DMKTRNA") Is System.DBNull.Value Then
                        m_daDMKTRNA = SqlDateTime.Null
                    Else
                        m_daDMKTRNA = New SqlDateTime(CType(dtToReturn.Rows(0)("DMKTRNA"), Date))
                    End If
                    If dtToReturn.Rows(0)("CDKTRNA") Is System.DBNull.Value Then
                        m_sCDKTRNA = SqlString.Null
                    Else
                        m_sCDKTRNA = New SqlString(CType(dtToReturn.Rows(0)("CDKTRNA"), String))
                    End If
                    If dtToReturn.Rows(0)("SAKTRNA") Is System.DBNull.Value Then
                        m_sSAKTRNA = SqlString.Null
                    Else
                        m_sSAKTRNA = New SqlString(CType(dtToReturn.Rows(0)("SAKTRNA"), String))
                    End If
                    If dtToReturn.Rows(0)("CDPAW00") Is System.DBNull.Value Then
                        m_sCDPAW00 = SqlString.Null
                    Else
                        m_sCDPAW00 = New SqlString(CType(dtToReturn.Rows(0)("CDPAW00"), String))
                    End If
                    If dtToReturn.Rows(0)("SAREC01") Is System.DBNull.Value Then
                        m_sSAREC01 = SqlString.Null
                    Else
                        m_sSAREC01 = New SqlString(CType(dtToReturn.Rows(0)("SAREC01"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner_Hauptadresse::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Partner_Hauptadresse_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRADR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRADR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRN00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVRN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRAAT00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRAAT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARVO", SqlDbType.NVarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARVO))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVAZ00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVAZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRARD00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRARD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTV00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTV00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM01", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM02", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM03", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNM04", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNM04))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTZ00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNM01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETRZNN", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETRZNN))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNM02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNZU00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNZU00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETTN00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETTN00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENAM03", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENAM03))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBECOT01", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBECOT01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBECOT02", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBECOT02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRZHK00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRZHK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRARDZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRARDZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTVZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTVZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEVNMZH", SqlDbType.NVarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEVNMZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRTTZZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRTTZZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNMZ1", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNMZ1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBETRZZH", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBETRZZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBENNMZ2", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBENNMZ2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNZUZH", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNZUZH))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORTZS", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORTZS))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEWEI00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEWEI00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEFCHPT", SqlDbType.NVarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEFCHPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFCHPT", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFCHPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBESTR00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBESTR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRHAU00", SqlDbType.NVarChar, 6, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRHAU00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRSTC00", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRSTC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRLND00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRLND00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPLZ00", SqlDbType.NVarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPLZ00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEORTPT", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEORTPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEDIS00", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEDIS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iCDORTPT", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCDORTPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iCDSTRPT", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCDSTRPT))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRUZG00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRUZG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRNGR00", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRNGR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRFOG01", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRFOG01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN01", SqlDbType.NVarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN01))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRFOG02", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRFOG02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN02", SqlDbType.NVarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN02))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@siNRVRNRI", SqlDbType.SmallInt, 2, ParameterDirection.Input, True, 5, 0, "", DataRowVersion.Proposed, m_siNRVRNRI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDMUTER", SqlDbType.NVarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDMUTER))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daTSMUT00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daTSMUT00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dcAZVRNHI", SqlDbType.Decimal, 5, ParameterDirection.Input, True, 5, 1, "", DataRowVersion.Proposed, m_dcAZVRNHI))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMERF00", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMERF00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daDMKTRNA", SqlDbType.SmallDateTime, 4, ParameterDirection.Input, True, 16, 0, "", DataRowVersion.Proposed, m_daDMKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDKTRNA", SqlDbType.NVarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAKTRNA", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAKTRNA))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDPAW00", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDPAW00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC01", SqlDbType.NVarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC01))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Partner_Hauptadresse_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPartner_Hauptadresse::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPartner_Hauptadresse Fields

clsPartner_Hauptadresse overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daDMERF00
field m_daDMKTRNA
field m_daTSMUT00
field m_dcAZVRNHI
field m_iCDORTPT
field m_iCDSTRPT
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_sBEBAN01
field m_sBEBAN02
field m_sBECOT01
field m_sBECOT02
field m_sBEDIS00
field m_sBEFCHPT
field m_sBENAM01
field m_sBENAM02
field m_sBENAM03
field m_sBENNM01
field m_sBENNM02
field m_sBENNMZ1
field m_sBENNMZ2
field m_sBEORTPT
field m_sBEORTZS
field m_sBESTR00
field m_sBETRZNN
field m_sBETRZZH
field m_sBETTN00
field m_sBEVNM01
field m_sBEVNM02
field m_sBEVNM03
field m_sBEVNM04
field m_sBEVNMZH
field m_sBEWEI00
field m_sCDKTRNA
field m_sCDMUTER
field m_sCDPAW00
field m_sCDPLZ00
field m_sNRFCHPT
field m_sNRHAU00
field m_sNRPARVO
field m_sNRSTC00
field m_sSAKTRNA
field m_sSAREC00
field m_sSAREC01
field m_sSAVRS00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_siNRAAT00
field m_siNRADR00
field m_siNRARD00
field m_siNRARDZH
field m_siNRFOG01
field m_siNRFOG02
field m_siNRLND00
field m_siNRNGR00
field m_siNRNZU00
field m_siNRNZUZH
field m_siNRTTV00
field m_siNRTTVZH
field m_siNRTTZ00
field m_siNRTTZZH
field m_siNRUZG00
field m_siNRVAZ00
field m_siNRVRN00
field m_siNRVRNRI
field m_siNRZHK00

See Also

clsPartner_Hauptadresse Class


m_daDMERF00 Variable

Private 		m_daDMERF00, _
   m_daDMKTRNA, _
   m_daTSMUT00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daDMKTRNA, m_daTSMUT00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_daDMKTRNA Variable

Private 		m_daDMERF00, _
   m_daDMKTRNA, _
   m_daTSMUT00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daDMKTRNA, m_daTSMUT00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_daTSMUT00 Variable

Private 		m_daDMERF00, _
   m_daDMKTRNA, _
   m_daTSMUT00 As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daDMERF00, m_daDMKTRNA, m_daTSMUT00 As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_dcAZVRNHI Variable

Private 		m_dcAZVRNHI As SqlDecimal

Source code

[Visual Basic]
        Private 		m_dcAZVRNHI As SqlDecimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_iCDORTPT Variable

Private 		m_iCDORTPT, _
   m_iNRPAR00, _
   m_iCDSTRPT As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCDORTPT, m_iNRPAR00, m_iCDSTRPT As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_iCDSTRPT Variable

Private 		m_iCDORTPT, _
   m_iNRPAR00, _
   m_iCDSTRPT As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCDORTPT, m_iNRPAR00, m_iCDSTRPT As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_iNRPAR00 Variable

Private 		m_iCDORTPT, _
   m_iNRPAR00, _
   m_iCDSTRPT As SqlInt32

Source code

[Visual Basic]
        Private 		m_iCDORTPT, m_iNRPAR00, m_iCDSTRPT As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEBAN01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEBAN02 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBECOT01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBECOT02 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEDIS00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEFCHPT Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENAM01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENAM02 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENAM03 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENNM01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENNM02 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENNMZ1 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBENNMZ2 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEORTPT Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEORTZS Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBESTR00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBETRZNN Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBETRZZH Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBETTN00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEVNM01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEVNM02 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEVNM03 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEVNM04 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEVNMZH Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sBEWEI00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sCDKTRNA Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sCDMUTER Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sCDPAW00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sCDPLZ00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sNRFCHPT Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sNRHAU00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sNRPARVO Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sNRSTC00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sSAKTRNA Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sSAREC00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sSAREC01 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_sSAVRS00 Variable

Private 		m_sBEBAN02, _
   m_sBETRZZH, _
   m_sBENNMZ1, _
   m_sCDMUTER, _
   m_sBECOT02, _
   m_sBEVNMZH, _
   m_sBEDIS00, _
   m_sBENNMZ2, _
   m_sNRHAU00, _
   m_sBESTR00, _
   m_sNRSTC00, _
   m_sCDPLZ00, _
   m_sBEBAN01, _
   m_sBEORTZS, _
   m_sBEORTPT, _
   m_sBEWEI00, _
   m_sNRFCHPT, _
   m_sBEFCHPT, _
   m_sSAREC00, _
   m_sSAVRS00, _
   m_sBEVNM02, _
   m_sBEVNM01, _
   m_sCDKTRNA, _
   m_sCDPAW00, _
   m_sSAREC01, _
   m_sNRPARVO, _
   m_sSAKTRNA, _
   m_sBEVNM03, _
   m_sBENAM02, _
   m_sBENAM01, _
   m_sBECOT01, _
   m_sBENAM03, _
   m_sBETTN00, _
   m_sBENNM01, _
   m_sBEVNM04, _
   m_sBENNM02, _
   m_sBETRZNN As SqlString

Source code

[Visual Basic]
        Private 		m_sBEBAN02, m_sBETRZZH, m_sBENNMZ1, m_sCDMUTER, m_sBECOT02, m_sBEVNMZH, m_sBEDIS00, m_sBENNMZ2, m_sNRHAU00, m_sBESTR00, m_sNRSTC00, m_sCDPLZ00, m_sBEBAN01, m_sBEORTZS, m_sBEORTPT, m_sBEWEI00, m_sNRFCHPT, m_sBEFCHPT, m_sSAREC00, m_sSAVRS00, m_sBEVNM02, m_sBEVNM01, m_sCDKTRNA, m_sCDPAW00, m_sSAREC01, m_sNRPARVO, m_sSAKTRNA, m_sBEVNM03, m_sBENAM02, m_sBENAM01, m_sBECOT01, m_sBENAM03, m_sBETTN00, m_sBENNM01, m_sBEVNM04, m_sBENNM02, m_sBETRZNN As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRAAT00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRADR00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRARD00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRARDZH Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRFOG01 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRFOG02 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRLND00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRNGR00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRNZU00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRNZUZH Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRTTV00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRTTVZH Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRTTZ00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRTTZZH Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRUZG00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRVAZ00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRVRN00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRVRNRI Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


m_siNRZHK00 Variable

Private 		m_siNRFOG01, _
   m_siNRFOG02, _
   m_siNRVRNRI, _
   m_siNRNGR00, _
   m_siNRARD00, _
   m_siNRTTV00, _
   m_siNRTTZ00, _
   m_siNRVAZ00, _
   m_siNRADR00, _
   m_siNRVRN00, _
   m_siNRAAT00, _
   m_siNRNZU00, _
   m_siNRNZUZH, _
   m_siNRLND00, _
   m_siNRUZG00, _
   m_siNRTTZZH, _
   m_siNRZHK00, _
   m_siNRARDZH, _
   m_siNRTTVZH As SqlInt16

Source code

[Visual Basic]
        Private 		m_siNRFOG01, m_siNRFOG02, m_siNRVRNRI, m_siNRNGR00, m_siNRARD00, m_siNRTTV00, m_siNRTTZ00, m_siNRVAZ00, m_siNRADR00, m_siNRVRN00, m_siNRAAT00, m_siNRNZU00, m_siNRNZUZH, m_siNRLND00, m_siNRUZG00, m_siNRTTZZH, m_siNRZHK00, m_siNRARDZH, m_siNRTTVZH As SqlInt16

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPartner_Hauptadresse


clsPhysischesArchiv Class

For a list of all members of this type, see clsPhysischesArchiv Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsPhysischesArchiv

Public Class clsPhysischesArchiv
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsPhysischesArchiv Members


clsPhysischesArchiv Members

clsPhysischesArchiv overview

Constructors

constructor clsPhysischesArchiv Constructor

Properties

property bAktiv
property blobMandantnr
property blobSprache
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iPhysischesarchivnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobMandantnr
field m_blobSprache
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iPhysischesarchivnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsPhysischesArchiv Class


clsPhysischesArchiv Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv Properties

clsPhysischesArchiv overview

Properties

property bAktiv
property blobMandantnr
property blobSprache
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iPhysischesarchivnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsPhysischesArchiv Class


clsPhysischesArchiv.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.blobMandantnr Property

Public Property [blobMandantnr]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobMandantnr]() As SqlBinary
            Get
                Return m_blobMandantnr
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.blobSprache Property

Public Property [blobSprache]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobSprache]() As SqlBinary
            Get
                Return m_blobSprache
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.iPhysischesarchivnr Property

Public Property [iPhysischesarchivnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPhysischesarchivnr]() As SqlInt32
            Get
                Return m_iPhysischesarchivnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iPhysischesarchivnrTmp As SqlInt32 = Value
                If iPhysischesarchivnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iPhysischesarchivnr", "iPhysischesarchivnr can't be NULL")
                End If
                m_iPhysischesarchivnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv Methods

clsPhysischesArchiv overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsPhysischesArchiv Class


clsPhysischesArchiv.Delete Method

Public Overrides Function Delete() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PhysischesArchiv_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysischesarchivnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPhysischesarchivnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PhysischesArchiv_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPhysischesArchiv::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.Insert Method

Public Overrides Function Insert() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PhysischesArchiv_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysischesarchivnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPhysischesarchivnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                Dim iLength As Integer = 0
                If Not m_blobSprache.IsNull Then
                    iLength = m_blobSprache.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobsprache", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobSprache))
                iLength = 0
                If Not m_blobMandantnr.IsNull Then
                    iLength = m_blobMandantnr.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobmandantnr", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PhysischesArchiv_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPhysischesArchiv::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.SelectAll Method

Public Overrides Function SelectAll() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PhysischesArchiv_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("PhysischesArchiv")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PhysischesArchiv_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPhysischesArchiv::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.SelectOne Method

Public Overrides Function SelectOne() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PhysischesArchiv_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("PhysischesArchiv")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysischesarchivnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPhysischesarchivnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PhysischesArchiv_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iPhysischesarchivnr = New SqlInt32(CType(dtToReturn.Rows(0)("physischesarchivnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_blobSprache = SqlBinary.Null
                    Else
                        m_blobSprache = New SqlBinary(CType(dtToReturn.Rows(0)("sprache"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_blobMandantnr = SqlBinary.Null
                    Else
                        m_blobMandantnr = New SqlBinary(CType(dtToReturn.Rows(0)("mandantnr"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPhysischesArchiv::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv.Update Method

Public Overrides Function Update() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_PhysischesArchiv_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysischesarchivnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPhysischesarchivnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                Dim iLength As Integer = 0
                If Not m_blobSprache.IsNull Then
                    iLength = m_blobSprache.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobsprache", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobSprache))
                iLength = 0
                If Not m_blobMandantnr.IsNull Then
                    iLength = m_blobMandantnr.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobmandantnr", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_PhysischesArchiv_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsPhysischesArchiv::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsPhysischesArchiv Fields

clsPhysischesArchiv overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobMandantnr
field m_blobSprache
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iPhysischesarchivnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsPhysischesArchiv Class


m_bAktiv Variable

Private m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_blobMandantnr Variable

Private m_blobMandantnr, _
   m_blobSprache As SqlBinary

Source code

[Visual Basic]
        Private m_blobMandantnr, m_blobSprache As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_blobSprache Variable

Private m_blobMandantnr, _
   m_blobSprache As SqlBinary

Source code

[Visual Basic]
        Private m_blobMandantnr, m_blobSprache As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_daErstellt_am Variable

Private m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_daMutiert_am Variable

Private m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_iMutierer Variable

Private m_iPhysischesarchivnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private m_iPhysischesarchivnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_iPhysischesarchivnr Variable

Private m_iPhysischesarchivnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private m_iPhysischesarchivnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_sBeschreibung Variable

Private m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


m_sBezeichnung Variable

Private m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsPhysischesArchiv


clsProfil Class

For a list of all members of this type, see clsProfil Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsProfil

Public Class clsProfil
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsProfil Members


clsProfil Members

clsProfil overview

Constructors

constructor clsProfil Constructor

Properties

property bAktiv
property bAktive
property bInkInaktVersant
property bInklalt
property bInklhostmavip
property bInklmavip
property bStandard
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHw1
property iHw10
property iHw11
property iHw2
property iHw3
property iHw4
property iHw5
property iHw6
property iHw7
property iHw8
property iHw9
property iMandantnr
property iMitarbeiternr
property iMutierer
property iProfilnr
property iProfiltyp
property iTeam
property iUnterschriftlinks
property iUnterschriftrechts
property sBeschreibung
property sBezeichnung
property sColor1
property sColor2
property sColor3
property sColor4
property sColor5
property sColor6
property sColor7
property sColor8
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDatum1
property sDatum2
property sDatum3
property sDatum4
property sDatum5
property sDatum6
property sDatum7
property sDatum8
property sDdokart
property sDdokstatus
property sDoktyp
property sDpartner
property sEkost
property sEma
property sEmb
property sEnl
property sErstaelterals
property sEteam
property sHostdatum1
property sHostdatum2
property sHostdatum3
property sHostdokart
property sHostdoktyp
property sHostpartner
property sHosttag1
property sHosttag2
property sHosttag3
property sMkost
property sMma
property sMmb
property sMnl
property sMteam
property sMutaelterasl
property sSort
property sUvmauftragnr
property sUvmdatum1
property sUvmdatum2
property sUvmdatum3
property sUvmdatum4
property sUvmdoktyp
property sVkost
property sVma
property sVmb
property sVnl
property sVteam
property sZvarchivdatum
property sZvauftraggeber
property sZvauftragnr
property sZvbetrag
property sZvclearingnr
property sZvdatum1
property sZvdatum2
property sZvdatum3
property sZvdatum4
property sZvdokumenttyp
property sZviso
property sZvkontobeg
property sZvpcnr
property sZvposten
property sZvreferenznr
property sZvswift
property sZvvaluta
property sZvverarbeitungsart
property sZvvvexter2
property sZvvvextern1
property sZvzahlungsart

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAktive
field m_bInkInaktVersant
field m_bInklalt
field m_bInklhostmavip
field m_bInklmavip
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bStandard
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHw1
field m_iHw10
field m_iHw11
field m_iHw2
field m_iHw3
field m_iHw4
field m_iHw5
field m_iHw6
field m_iHw7
field m_iHw8
field m_iHw9
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iProfilnr
field m_iProfiltyp
field m_iTeam
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_sBeschreibung
field m_sBezeichnung
field m_sColor1
field m_sColor2
field m_sColor3
field m_sColor4
field m_sColor5
field m_sColor6
field m_sColor7
field m_sColor8
field m_sDatum1
field m_sDatum2
field m_sDatum3
field m_sDatum4
field m_sDatum5
field m_sDatum6
field m_sDatum7
field m_sDatum8
field m_sDdokart
field m_sDdokstatus
field m_sDoktyp
field m_sDpartner
field m_sEkost
field m_sEma
field m_sEmb
field m_sEnl
field m_sErstaelterals
field m_sEteam
field m_sHostdatum1
field m_sHostdatum2
field m_sHostdatum3
field m_sHostdokart
field m_sHostdoktyp
field m_sHostpartner
field m_sHosttag1
field m_sHosttag2
field m_sHosttag3
field m_sMkost
field m_sMma
field m_sMmb
field m_sMnl
field m_sMteam
field m_sMutaelterasl
field m_sSort
field m_sUvmauftragnr
field m_sUvmdatum1
field m_sUvmdatum2
field m_sUvmdatum3
field m_sUvmdatum4
field m_sUvmdoktyp
field m_sVkost
field m_sVma
field m_sVmb
field m_sVnl
field m_sVteam
field m_sZvarchivdatum
field m_sZvauftraggeber
field m_sZvauftragnr
field m_sZvbetrag
field m_sZvclearingnr
field m_sZvdatum1
field m_sZvdatum2
field m_sZvdatum3
field m_sZvdatum4
field m_sZvdokumenttyp
field m_sZviso
field m_sZvkontobeg
field m_sZvpcnr
field m_sZvposten
field m_sZvreferenznr
field m_sZvswift
field m_sZvvaluta
field m_sZvverarbeitungsart
field m_sZvvvexter2
field m_sZvvvextern1
field m_sZvzahlungsart
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProfil Class


clsProfil Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil Properties

clsProfil overview

Properties

property bAktiv
property bAktive
property bInkInaktVersant
property bInklalt
property bInklhostmavip
property bInklmavip
property bStandard
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHw1
property iHw10
property iHw11
property iHw2
property iHw3
property iHw4
property iHw5
property iHw6
property iHw7
property iHw8
property iHw9
property iMandantnr
property iMitarbeiternr
property iMutierer
property iProfilnr
property iProfiltyp
property iTeam
property iUnterschriftlinks
property iUnterschriftrechts
property sBeschreibung
property sBezeichnung
property sColor1
property sColor2
property sColor3
property sColor4
property sColor5
property sColor6
property sColor7
property sColor8
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDatum1
property sDatum2
property sDatum3
property sDatum4
property sDatum5
property sDatum6
property sDatum7
property sDatum8
property sDdokart
property sDdokstatus
property sDoktyp
property sDpartner
property sEkost
property sEma
property sEmb
property sEnl
property sErstaelterals
property sEteam
property sHostdatum1
property sHostdatum2
property sHostdatum3
property sHostdokart
property sHostdoktyp
property sHostpartner
property sHosttag1
property sHosttag2
property sHosttag3
property sMkost
property sMma
property sMmb
property sMnl
property sMteam
property sMutaelterasl
property sSort
property sUvmauftragnr
property sUvmdatum1
property sUvmdatum2
property sUvmdatum3
property sUvmdatum4
property sUvmdoktyp
property sVkost
property sVma
property sVmb
property sVnl
property sVteam
property sZvarchivdatum
property sZvauftraggeber
property sZvauftragnr
property sZvbetrag
property sZvclearingnr
property sZvdatum1
property sZvdatum2
property sZvdatum3
property sZvdatum4
property sZvdokumenttyp
property sZviso
property sZvkontobeg
property sZvpcnr
property sZvposten
property sZvreferenznr
property sZvswift
property sZvvaluta
property sZvverarbeitungsart
property sZvvvexter2
property sZvvvextern1
property sZvzahlungsart

See Also

clsProfil Class


clsProfil.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bAktive Property

Public Property [bAktive]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktive]() As SqlBoolean
            Get
                Return m_bAktive
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktive = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bInkInaktVersant Property

Public Property [bInkInaktVersant]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInkInaktVersant]() As SqlBoolean
            Get
                Return m_bInkInaktVersant
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInkInaktVersant = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bInklalt Property

Public Property [bInklalt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklalt]() As SqlBoolean
            Get
                Return m_bInklalt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bInklhostmavip Property

Public Property [bInklhostmavip]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklhostmavip]() As SqlBoolean
            Get
                Return m_bInklhostmavip
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklhostmavip = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bInklmavip Property

Public Property [bInklmavip]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklmavip]() As SqlBoolean
            Get
                Return m_bInklmavip
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklmavip = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.bStandard Property

Public Property [bStandard]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bStandard]() As SqlBoolean
            Get
                Return m_bStandard
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bStandardTmp As SqlBoolean = Value
                If bStandardTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bStandard", "bStandard can't be NULL")
                End If
                m_bStandard = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daErstellt_amTmp As SqlDateTime = Value
                If daErstellt_amTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daErstellt_am", "daErstellt_am can't be NULL")
                End If
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daMutiert_amTmp As SqlDateTime = Value
                If daMutiert_amTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daMutiert_am", "daMutiert_am can't be NULL")
                End If
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw1 Property

Public Property [iHw1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw1]() As SqlInt32
            Get
                Return m_iHw1
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw1Tmp As SqlInt32 = Value
                If iHw1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw1", "iHw1 can't be NULL")
                End If
                m_iHw1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw10 Property

Public Property [iHw10]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw10]() As SqlInt32
            Get
                Return m_iHw10
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw10Tmp As SqlInt32 = Value
                If iHw10Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw10", "iHw10 can't be NULL")
                End If
                m_iHw10 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw11 Property

Public Property [iHw11]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw11]() As SqlInt32
            Get
                Return m_iHw11
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw11Tmp As SqlInt32 = Value
                If iHw11Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw11", "iHw11 can't be NULL")
                End If
                m_iHw11 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw2 Property

Public Property [iHw2]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw2]() As SqlInt32
            Get
                Return m_iHw2
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw2Tmp As SqlInt32 = Value
                If iHw2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw2", "iHw2 can't be NULL")
                End If
                m_iHw2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw3 Property

Public Property [iHw3]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw3]() As SqlInt32
            Get
                Return m_iHw3
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw3Tmp As SqlInt32 = Value
                If iHw3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw3", "iHw3 can't be NULL")
                End If
                m_iHw3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw4 Property

Public Property [iHw4]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw4]() As SqlInt32
            Get
                Return m_iHw4
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw4Tmp As SqlInt32 = Value
                If iHw4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw4", "iHw4 can't be NULL")
                End If
                m_iHw4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw5 Property

Public Property [iHw5]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw5]() As SqlInt32
            Get
                Return m_iHw5
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw5Tmp As SqlInt32 = Value
                If iHw5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw5", "iHw5 can't be NULL")
                End If
                m_iHw5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw6 Property

Public Property [iHw6]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw6]() As SqlInt32
            Get
                Return m_iHw6
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw6Tmp As SqlInt32 = Value
                If iHw6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw6", "iHw6 can't be NULL")
                End If
                m_iHw6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw7 Property

Public Property [iHw7]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw7]() As SqlInt32
            Get
                Return m_iHw7
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw7Tmp As SqlInt32 = Value
                If iHw7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw7", "iHw7 can't be NULL")
                End If
                m_iHw7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw8 Property

Public Property [iHw8]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw8]() As SqlInt32
            Get
                Return m_iHw8
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw8Tmp As SqlInt32 = Value
                If iHw8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw8", "iHw8 can't be NULL")
                End If
                m_iHw8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iHw9 Property

Public Property [iHw9]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw9]() As SqlInt32
            Get
                Return m_iHw9
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw9Tmp As SqlInt32 = Value
                If iHw9Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw9", "iHw9 can't be NULL")
                End If
                m_iHw9 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMutiererTmp As SqlInt32 = Value
                If iMutiererTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMutierer", "iMutierer can't be NULL")
                End If
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iProfilnr Property

Public Property [iProfilnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProfilnr]() As SqlInt32
            Get
                Return m_iProfilnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iProfilnrTmp As SqlInt32 = Value
                If iProfilnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iProfilnr", "iProfilnr can't be NULL")
                End If
                m_iProfilnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iProfiltyp Property

Public Property [iProfiltyp]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProfiltyp]() As SqlInt32
            Get
                Return m_iProfiltyp
            End Get
            Set(ByVal Value As SqlInt32)
                m_iProfiltyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iTeam Property

Public Property [iTeam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeam]() As SqlInt32
            Get
                Return m_iTeam
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iTeamTmp As SqlInt32 = Value
                If iTeamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iTeam", "iTeam can't be NULL")
                End If
                m_iTeam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iUnterschriftlinksTmp As SqlInt32 = Value
                If iUnterschriftlinksTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iUnterschriftlinks", "iUnterschriftlinks can't be NULL")
                End If
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iUnterschriftrechtsTmp As SqlInt32 = Value
                If iUnterschriftrechtsTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iUnterschriftrechts", "iUnterschriftrechts can't be NULL")
                End If
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBeschreibungTmp As SqlString = Value
                If sBeschreibungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
                End If
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBezeichnungTmp As SqlString = Value
                If sBezeichnungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBezeichnung", "sBezeichnung can't be NULL")
                End If
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor1 Property

Public Property [sColor1]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor1]() As SqlString
            Get
                Return m_sColor1
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor1Tmp As SqlString = Value
                If sColor1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor1", "sColor1 can't be NULL")
                End If
                m_sColor1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor2 Property

Public Property [sColor2]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor2]() As SqlString
            Get
                Return m_sColor2
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor2Tmp As SqlString = Value
                If sColor2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor2", "sColor2 can't be NULL")
                End If
                m_sColor2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor3 Property

Public Property [sColor3]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor3]() As SqlString
            Get
                Return m_sColor3
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor3Tmp As SqlString = Value
                If sColor3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor3", "sColor3 can't be NULL")
                End If
                m_sColor3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor4 Property

Public Property [sColor4]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor4]() As SqlString
            Get
                Return m_sColor4
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor4Tmp As SqlString = Value
                If sColor4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor4", "sColor4 can't be NULL")
                End If
                m_sColor4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor5 Property

Public Property [sColor5]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor5]() As SqlString
            Get
                Return m_sColor5
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor5Tmp As SqlString = Value
                If sColor5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor5", "sColor5 can't be NULL")
                End If
                m_sColor5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor6 Property

Public Property [sColor6]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor6]() As SqlString
            Get
                Return m_sColor6
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor6Tmp As SqlString = Value
                If sColor6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor6", "sColor6 can't be NULL")
                End If
                m_sColor6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor7 Property

Public Property [sColor7]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor7]() As SqlString
            Get
                Return m_sColor7
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor7Tmp As SqlString = Value
                If sColor7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor7", "sColor7 can't be NULL")
                End If
                m_sColor7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sColor8 Property

Public Property [sColor8]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor8]() As SqlString
            Get
                Return m_sColor8
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor8Tmp As SqlString = Value
                If sColor8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor8", "sColor8 can't be NULL")
                End If
                m_sColor8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum1 Property

Public Property [sDatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum1]() As SqlString
            Get
                Return m_sDatum1
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum1Tmp As SqlString = Value
                If sDatum1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum1", "sDatum1 can't be NULL")
                End If
                m_sDatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum2 Property

Public Property [sDatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum2]() As SqlString
            Get
                Return m_sDatum2
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum2Tmp As SqlString = Value
                If sDatum2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum2", "sDatum2 can't be NULL")
                End If
                m_sDatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum3 Property

Public Property [sDatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum3]() As SqlString
            Get
                Return m_sDatum3
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum3Tmp As SqlString = Value
                If sDatum3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum3", "sDatum3 can't be NULL")
                End If
                m_sDatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum4 Property

Public Property [sDatum4]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum4]() As SqlString
            Get
                Return m_sDatum4
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum4Tmp As SqlString = Value
                If sDatum4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum4", "sDatum4 can't be NULL")
                End If
                m_sDatum4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum5 Property

Public Property [sDatum5]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum5]() As SqlString
            Get
                Return m_sDatum5
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum5Tmp As SqlString = Value
                If sDatum5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum5", "sDatum5 can't be NULL")
                End If
                m_sDatum5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum6 Property

Public Property [sDatum6]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum6]() As SqlString
            Get
                Return m_sDatum6
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum6Tmp As SqlString = Value
                If sDatum6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum6", "sDatum6 can't be NULL")
                End If
                m_sDatum6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum7 Property

Public Property [sDatum7]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum7]() As SqlString
            Get
                Return m_sDatum7
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum7Tmp As SqlString = Value
                If sDatum7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum7", "sDatum7 can't be NULL")
                End If
                m_sDatum7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDatum8 Property

Public Property [sDatum8]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum8]() As SqlString
            Get
                Return m_sDatum8
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum8Tmp As SqlString = Value
                If sDatum8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum8", "sDatum8 can't be NULL")
                End If
                m_sDatum8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDdokart Property

Public Property [sDdokart]() As SqlString

Source code

[Visual Basic]
        Public Property [sDdokart]() As SqlString
            Get
                Return m_sDdokart
            End Get
            Set(ByVal Value As SqlString)
                Dim sDdokartTmp As SqlString = Value
                If sDdokartTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDdokart", "sDdokart can't be NULL")
                End If
                m_sDdokart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDdokstatus Property

Public Property [sDdokstatus]() As SqlString

Source code

[Visual Basic]
        Public Property [sDdokstatus]() As SqlString
            Get
                Return m_sDdokstatus
            End Get
            Set(ByVal Value As SqlString)
                Dim sDdokstatusTmp As SqlString = Value
                If sDdokstatusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDdokstatus", "sDdokstatus can't be NULL")
                End If
                m_sDdokstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDoktyp Property

Public Property [sDoktyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sDoktyp]() As SqlString
            Get
                Return m_sDoktyp
            End Get
            Set(ByVal Value As SqlString)
                m_sDoktyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sDpartner Property

Public Property [sDpartner]() As SqlString

Source code

[Visual Basic]
        Public Property [sDpartner]() As SqlString
            Get
                Return m_sDpartner
            End Get
            Set(ByVal Value As SqlString)
                Dim sDpartnerTmp As SqlString = Value
                If sDpartnerTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDpartner", "sDpartner can't be NULL")
                End If
                m_sDpartner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sEkost Property

Public Property [sEkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sEkost]() As SqlString
            Get
                Return m_sEkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sEkostTmp As SqlString = Value
                If sEkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEkost", "sEkost can't be NULL")
                End If
                m_sEkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sEma Property

Public Property [sEma]() As SqlString

Source code

[Visual Basic]
        Public Property [sEma]() As SqlString
            Get
                Return m_sEma
            End Get
            Set(ByVal Value As SqlString)
                Dim sEmaTmp As SqlString = Value
                If sEmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEma", "sEma can't be NULL")
                End If
                m_sEma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sEmb Property

Public Property [sEmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sEmb]() As SqlString
            Get
                Return m_sEmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sEmbTmp As SqlString = Value
                If sEmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEmb", "sEmb can't be NULL")
                End If
                m_sEmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sEnl Property

Public Property [sEnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sEnl]() As SqlString
            Get
                Return m_sEnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sEnlTmp As SqlString = Value
                If sEnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEnl", "sEnl can't be NULL")
                End If
                m_sEnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sErstaelterals Property

Public Property [sErstaelterals]() As SqlString

Source code

[Visual Basic]
        Public Property [sErstaelterals]() As SqlString
            Get
                Return m_sErstaelterals
            End Get
            Set(ByVal Value As SqlString)
                Dim sErstaelteralsTmp As SqlString = Value
                If sErstaelteralsTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sErstaelterals", "sErstaelterals can't be NULL")
                End If
                m_sErstaelterals = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sEteam Property

Public Property [sEteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sEteam]() As SqlString
            Get
                Return m_sEteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sEteamTmp As SqlString = Value
                If sEteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEteam", "sEteam can't be NULL")
                End If
                m_sEteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostdatum1 Property

Public Property [sHostdatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum1]() As SqlString
            Get
                Return m_sHostdatum1
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostdatum2 Property

Public Property [sHostdatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum2]() As SqlString
            Get
                Return m_sHostdatum2
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostdatum3 Property

Public Property [sHostdatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum3]() As SqlString
            Get
                Return m_sHostdatum3
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostdokart Property

Public Property [sHostdokart]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdokart]() As SqlString
            Get
                Return m_sHostdokart
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdokart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostdoktyp Property

Public Property [sHostdoktyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdoktyp]() As SqlString
            Get
                Return m_sHostdoktyp
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdoktyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHostpartner Property

Public Property [sHostpartner]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostpartner]() As SqlString
            Get
                Return m_sHostpartner
            End Get
            Set(ByVal Value As SqlString)
                m_sHostpartner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHosttag1 Property

Public Property [sHosttag1]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag1]() As SqlString
            Get
                Return m_sHosttag1
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHosttag2 Property

Public Property [sHosttag2]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag2]() As SqlString
            Get
                Return m_sHosttag2
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sHosttag3 Property

Public Property [sHosttag3]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag3]() As SqlString
            Get
                Return m_sHosttag3
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMkost Property

Public Property [sMkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sMkost]() As SqlString
            Get
                Return m_sMkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sMkostTmp As SqlString = Value
                If sMkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMkost", "sMkost can't be NULL")
                End If
                m_sMkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMma Property

Public Property [sMma]() As SqlString

Source code

[Visual Basic]
        Public Property [sMma]() As SqlString
            Get
                Return m_sMma
            End Get
            Set(ByVal Value As SqlString)
                Dim sMmaTmp As SqlString = Value
                If sMmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMma", "sMma can't be NULL")
                End If
                m_sMma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMmb Property

Public Property [sMmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sMmb]() As SqlString
            Get
                Return m_sMmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sMmbTmp As SqlString = Value
                If sMmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMmb", "sMmb can't be NULL")
                End If
                m_sMmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMnl Property

Public Property [sMnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sMnl]() As SqlString
            Get
                Return m_sMnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sMnlTmp As SqlString = Value
                If sMnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMnl", "sMnl can't be NULL")
                End If
                m_sMnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMteam Property

Public Property [sMteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sMteam]() As SqlString
            Get
                Return m_sMteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sMteamTmp As SqlString = Value
                If sMteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMteam", "sMteam can't be NULL")
                End If
                m_sMteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sMutaelterasl Property

Public Property [sMutaelterasl]() As SqlString

Source code

[Visual Basic]
        Public Property [sMutaelterasl]() As SqlString
            Get
                Return m_sMutaelterasl
            End Get
            Set(ByVal Value As SqlString)
                Dim sMutaelteraslTmp As SqlString = Value
                If sMutaelteraslTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMutaelterasl", "sMutaelterasl can't be NULL")
                End If
                m_sMutaelterasl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sSort Property

Public Property [sSort]() As SqlString

Source code

[Visual Basic]
        Public Property [sSort]() As SqlString
            Get
                Return m_sSort
            End Get
            Set(ByVal Value As SqlString)
                Dim sSortTmp As SqlString = Value
                If sSortTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSort", "sSort can't be NULL")
                End If
                m_sSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmauftragnr Property

Public Property [sUvmauftragnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmauftragnr]() As SqlString
            Get
                Return m_sUvmauftragnr
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmauftragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmdatum1 Property

Public Property [sUvmdatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmdatum1]() As SqlString
            Get
                Return m_sUvmdatum1
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmdatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmdatum2 Property

Public Property [sUvmdatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmdatum2]() As SqlString
            Get
                Return m_sUvmdatum2
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmdatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmdatum3 Property

Public Property [sUvmdatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmdatum3]() As SqlString
            Get
                Return m_sUvmdatum3
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmdatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmdatum4 Property

Public Property [sUvmdatum4]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmdatum4]() As SqlString
            Get
                Return m_sUvmdatum4
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmdatum4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sUvmdoktyp Property

Public Property [sUvmdoktyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sUvmdoktyp]() As SqlString
            Get
                Return m_sUvmdoktyp
            End Get
            Set(ByVal Value As SqlString)
                m_sUvmdoktyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sVkost Property

Public Property [sVkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sVkost]() As SqlString
            Get
                Return m_sVkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sVkostTmp As SqlString = Value
                If sVkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVkost", "sVkost can't be NULL")
                End If
                m_sVkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sVma Property

Public Property [sVma]() As SqlString

Source code

[Visual Basic]
        Public Property [sVma]() As SqlString
            Get
                Return m_sVma
            End Get
            Set(ByVal Value As SqlString)
                Dim sVmaTmp As SqlString = Value
                If sVmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVma", "sVma can't be NULL")
                End If
                m_sVma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sVmb Property

Public Property [sVmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sVmb]() As SqlString
            Get
                Return m_sVmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sVmbTmp As SqlString = Value
                If sVmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVmb", "sVmb can't be NULL")
                End If
                m_sVmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sVnl Property

Public Property [sVnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sVnl]() As SqlString
            Get
                Return m_sVnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sVnlTmp As SqlString = Value
                If sVnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVnl", "sVnl can't be NULL")
                End If
                m_sVnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sVteam Property

Public Property [sVteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sVteam]() As SqlString
            Get
                Return m_sVteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sVteamTmp As SqlString = Value
                If sVteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVteam", "sVteam can't be NULL")
                End If
                m_sVteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvarchivdatum Property

Public Property [sZvarchivdatum]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvarchivdatum]() As SqlString
            Get
                Return m_sZvarchivdatum
            End Get
            Set(ByVal Value As SqlString)
                m_sZvarchivdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvauftraggeber Property

Public Property [sZvauftraggeber]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvauftraggeber]() As SqlString
            Get
                Return m_sZvauftraggeber
            End Get
            Set(ByVal Value As SqlString)
                m_sZvauftraggeber = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvauftragnr Property

Public Property [sZvauftragnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvauftragnr]() As SqlString
            Get
                Return m_sZvauftragnr
            End Get
            Set(ByVal Value As SqlString)
                m_sZvauftragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvbetrag Property

Public Property [sZvbetrag]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvbetrag]() As SqlString
            Get
                Return m_sZvbetrag
            End Get
            Set(ByVal Value As SqlString)
                m_sZvbetrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvclearingnr Property

Public Property [sZvclearingnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvclearingnr]() As SqlString
            Get
                Return m_sZvclearingnr
            End Get
            Set(ByVal Value As SqlString)
                m_sZvclearingnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvdatum1 Property

Public Property [sZvdatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvdatum1]() As SqlString
            Get
                Return m_sZvdatum1
            End Get
            Set(ByVal Value As SqlString)
                m_sZvdatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvdatum2 Property

Public Property [sZvdatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvdatum2]() As SqlString
            Get
                Return m_sZvdatum2
            End Get
            Set(ByVal Value As SqlString)
                m_sZvdatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvdatum3 Property

Public Property [sZvdatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvdatum3]() As SqlString
            Get
                Return m_sZvdatum3
            End Get
            Set(ByVal Value As SqlString)
                m_sZvdatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvdatum4 Property

Public Property [sZvdatum4]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvdatum4]() As SqlString
            Get
                Return m_sZvdatum4
            End Get
            Set(ByVal Value As SqlString)
                m_sZvdatum4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvdokumenttyp Property

Public Property [sZvdokumenttyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvdokumenttyp]() As SqlString
            Get
                Return m_sZvdokumenttyp
            End Get
            Set(ByVal Value As SqlString)
                m_sZvdokumenttyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZviso Property

Public Property [sZviso]() As SqlString

Source code

[Visual Basic]
        Public Property [sZviso]() As SqlString
            Get
                Return m_sZviso
            End Get
            Set(ByVal Value As SqlString)
                m_sZviso = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvkontobeg Property

Public Property [sZvkontobeg]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvkontobeg]() As SqlString
            Get
                Return m_sZvkontobeg
            End Get
            Set(ByVal Value As SqlString)
                m_sZvkontobeg = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvpcnr Property

Public Property [sZvpcnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvpcnr]() As SqlString
            Get
                Return m_sZvpcnr
            End Get
            Set(ByVal Value As SqlString)
                m_sZvpcnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvposten Property

Public Property [sZvposten]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvposten]() As SqlString
            Get
                Return m_sZvposten
            End Get
            Set(ByVal Value As SqlString)
                m_sZvposten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvreferenznr Property

Public Property [sZvreferenznr]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvreferenznr]() As SqlString
            Get
                Return m_sZvreferenznr
            End Get
            Set(ByVal Value As SqlString)
                m_sZvreferenznr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvswift Property

Public Property [sZvswift]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvswift]() As SqlString
            Get
                Return m_sZvswift
            End Get
            Set(ByVal Value As SqlString)
                m_sZvswift = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvvaluta Property

Public Property [sZvvaluta]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvvaluta]() As SqlString
            Get
                Return m_sZvvaluta
            End Get
            Set(ByVal Value As SqlString)
                m_sZvvaluta = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvverarbeitungsart Property

Public Property [sZvverarbeitungsart]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvverarbeitungsart]() As SqlString
            Get
                Return m_sZvverarbeitungsart
            End Get
            Set(ByVal Value As SqlString)
                m_sZvverarbeitungsart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvvvexter2 Property

Public Property [sZvvvexter2]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvvvexter2]() As SqlString
            Get
                Return m_sZvvvexter2
            End Get
            Set(ByVal Value As SqlString)
                m_sZvvvexter2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvvvextern1 Property

Public Property [sZvvvextern1]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvvvextern1]() As SqlString
            Get
                Return m_sZvvvextern1
            End Get
            Set(ByVal Value As SqlString)
                m_sZvvvextern1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.sZvzahlungsart Property

Public Property [sZvzahlungsart]() As SqlString

Source code

[Visual Basic]
        Public Property [sZvzahlungsart]() As SqlString
            Get
                Return m_sZvzahlungsart
            End Get
            Set(ByVal Value As SqlString)
                m_sZvzahlungsart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil Methods

clsProfil overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsProfil Class


clsProfil.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_profil_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_profil_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_profil_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstandard", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw1", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw2", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw3", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw4", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw5", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw6", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw7", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw8", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw9", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw9))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw10", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw10))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw11", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw11))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@senl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sekost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@seteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sema", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokart", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokstatus", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@serstaelterals", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sErstaelterals))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smutaelterasl", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMutaelterasl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ssort", SqlDbType.VarChar, 1024, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktive", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktive))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofiltyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfiltyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklalt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklhostmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklhostmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdoktyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmauftragnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmauftragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvauftraggeber", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvauftraggeber))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvverarbeitungsart", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvverarbeitungsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvreferenznr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvreferenznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvzahlungsart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvzahlungsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvpcnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvpcnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvclearingnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvclearingnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvkontobeg", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvkontobeg))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvswift", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvswift))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvaluta", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvaluta))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szviso", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZviso))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvbetrag", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvbetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvvextern1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvvextern1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvvexter2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvvexter2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvposten", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvposten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvauftragnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvauftragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvarchivdatum", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvarchivdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binkInaktVersant", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInkInaktVersant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_profil_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_profil_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("profil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_profil_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_profil_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("profil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_profil_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iProfilnr = New SqlInt32(CType(dtToReturn.Rows(0)("profilnr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    m_bStandard = New SqlBoolean(CType(dtToReturn.Rows(0)("standard"), Boolean))
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    m_sColor1 = New SqlString(CType(dtToReturn.Rows(0)("color1"), String))
                    m_sColor2 = New SqlString(CType(dtToReturn.Rows(0)("color2"), String))
                    m_sColor3 = New SqlString(CType(dtToReturn.Rows(0)("color3"), String))
                    m_sColor4 = New SqlString(CType(dtToReturn.Rows(0)("color4"), String))
                    m_sColor5 = New SqlString(CType(dtToReturn.Rows(0)("color5"), String))
                    m_sColor6 = New SqlString(CType(dtToReturn.Rows(0)("color6"), String))
                    m_sColor7 = New SqlString(CType(dtToReturn.Rows(0)("color7"), String))
                    m_sColor8 = New SqlString(CType(dtToReturn.Rows(0)("color8"), String))
                    m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    m_iHw1 = New SqlInt32(CType(dtToReturn.Rows(0)("hw1"), Integer))
                    m_iHw2 = New SqlInt32(CType(dtToReturn.Rows(0)("hw2"), Integer))
                    m_iHw3 = New SqlInt32(CType(dtToReturn.Rows(0)("hw3"), Integer))
                    m_iHw4 = New SqlInt32(CType(dtToReturn.Rows(0)("hw4"), Integer))
                    m_iHw5 = New SqlInt32(CType(dtToReturn.Rows(0)("hw5"), Integer))
                    m_iHw6 = New SqlInt32(CType(dtToReturn.Rows(0)("hw6"), Integer))
                    m_iHw7 = New SqlInt32(CType(dtToReturn.Rows(0)("hw7"), Integer))
                    m_iHw8 = New SqlInt32(CType(dtToReturn.Rows(0)("hw8"), Integer))
                    m_iHw9 = New SqlInt32(CType(dtToReturn.Rows(0)("hw9"), Integer))
                    m_iHw10 = New SqlInt32(CType(dtToReturn.Rows(0)("hw10"), Integer))
                    m_iHw11 = New SqlInt32(CType(dtToReturn.Rows(0)("hw11"), Integer))
                    m_sVmb = New SqlString(CType(dtToReturn.Rows(0)("vmb"), String))
                    m_sVnl = New SqlString(CType(dtToReturn.Rows(0)("vnl"), String))
                    m_sVkost = New SqlString(CType(dtToReturn.Rows(0)("vkost"), String))
                    m_sVteam = New SqlString(CType(dtToReturn.Rows(0)("vteam"), String))
                    m_sVma = New SqlString(CType(dtToReturn.Rows(0)("vma"), String))
                    m_sMmb = New SqlString(CType(dtToReturn.Rows(0)("mmb"), String))
                    m_sMnl = New SqlString(CType(dtToReturn.Rows(0)("mnl"), String))
                    m_sMkost = New SqlString(CType(dtToReturn.Rows(0)("mkost"), String))
                    m_sMteam = New SqlString(CType(dtToReturn.Rows(0)("mteam"), String))
                    m_sMma = New SqlString(CType(dtToReturn.Rows(0)("mma"), String))
                    m_sEmb = New SqlString(CType(dtToReturn.Rows(0)("emb"), String))
                    m_sEnl = New SqlString(CType(dtToReturn.Rows(0)("enl"), String))
                    m_sEkost = New SqlString(CType(dtToReturn.Rows(0)("ekost"), String))
                    m_sEteam = New SqlString(CType(dtToReturn.Rows(0)("eteam"), String))
                    m_sEma = New SqlString(CType(dtToReturn.Rows(0)("ema"), String))
                    m_sDpartner = New SqlString(CType(dtToReturn.Rows(0)("dpartner"), String))
                    m_sDdokart = New SqlString(CType(dtToReturn.Rows(0)("ddokart"), String))
                    m_sDdokstatus = New SqlString(CType(dtToReturn.Rows(0)("ddokstatus"), String))
                    m_sDatum1 = New SqlString(CType(dtToReturn.Rows(0)("datum1"), String))
                    m_sDatum2 = New SqlString(CType(dtToReturn.Rows(0)("datum2"), String))
                    m_sDatum3 = New SqlString(CType(dtToReturn.Rows(0)("datum3"), String))
                    m_sDatum4 = New SqlString(CType(dtToReturn.Rows(0)("datum4"), String))
                    m_sDatum5 = New SqlString(CType(dtToReturn.Rows(0)("datum5"), String))
                    m_sDatum6 = New SqlString(CType(dtToReturn.Rows(0)("datum6"), String))
                    m_sDatum7 = New SqlString(CType(dtToReturn.Rows(0)("datum7"), String))
                    m_sDatum8 = New SqlString(CType(dtToReturn.Rows(0)("datum8"), String))
                    m_sErstaelterals = New SqlString(CType(dtToReturn.Rows(0)("erstaelterals"), String))
                    m_sMutaelterasl = New SqlString(CType(dtToReturn.Rows(0)("mutaelterasl"), String))
                    m_iTeam = New SqlInt32(CType(dtToReturn.Rows(0)("team"), Integer))
                    m_sSort = New SqlString(CType(dtToReturn.Rows(0)("sort"), String))
                    If dtToReturn.Rows(0)("aktive") Is System.DBNull.Value Then
                        m_bAktive = SqlBoolean.Null
                    Else
                        m_bAktive = New SqlBoolean(CType(dtToReturn.Rows(0)("aktive"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("profiltyp") Is System.DBNull.Value Then
                        m_iProfiltyp = SqlInt32.Null
                    Else
                        m_iProfiltyp = New SqlInt32(CType(dtToReturn.Rows(0)("profiltyp"), Integer))
                    End If
                    If dtToReturn.Rows(0)("doktyp") Is System.DBNull.Value Then
                        m_sDoktyp = SqlString.Null
                    Else
                        m_sDoktyp = New SqlString(CType(dtToReturn.Rows(0)("doktyp"), String))
                    End If
                    If dtToReturn.Rows(0)("inklmavip") Is System.DBNull.Value Then
                        m_bInklmavip = SqlBoolean.Null
                    Else
                        m_bInklmavip = New SqlBoolean(CType(dtToReturn.Rows(0)("inklmavip"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("inklalt") Is System.DBNull.Value Then
                        m_bInklalt = SqlBoolean.Null
                    Else
                        m_bInklalt = New SqlBoolean(CType(dtToReturn.Rows(0)("inklalt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("hostpartner") Is System.DBNull.Value Then
                        m_sHostpartner = SqlString.Null
                    Else
                        m_sHostpartner = New SqlString(CType(dtToReturn.Rows(0)("hostpartner"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdokart") Is System.DBNull.Value Then
                        m_sHostdokart = SqlString.Null
                    Else
                        m_sHostdokart = New SqlString(CType(dtToReturn.Rows(0)("hostdokart"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdoktyp") Is System.DBNull.Value Then
                        m_sHostdoktyp = SqlString.Null
                    Else
                        m_sHostdoktyp = New SqlString(CType(dtToReturn.Rows(0)("hostdoktyp"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag1") Is System.DBNull.Value Then
                        m_sHosttag1 = SqlString.Null
                    Else
                        m_sHosttag1 = New SqlString(CType(dtToReturn.Rows(0)("hosttag1"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum1") Is System.DBNull.Value Then
                        m_sHostdatum1 = SqlString.Null
                    Else
                        m_sHostdatum1 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum1"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag2") Is System.DBNull.Value Then
                        m_sHosttag2 = SqlString.Null
                    Else
                        m_sHosttag2 = New SqlString(CType(dtToReturn.Rows(0)("hosttag2"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum2") Is System.DBNull.Value Then
                        m_sHostdatum2 = SqlString.Null
                    Else
                        m_sHostdatum2 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum2"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag3") Is System.DBNull.Value Then
                        m_sHosttag3 = SqlString.Null
                    Else
                        m_sHosttag3 = New SqlString(CType(dtToReturn.Rows(0)("hosttag3"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum3") Is System.DBNull.Value Then
                        m_sHostdatum3 = SqlString.Null
                    Else
                        m_sHostdatum3 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum3"), String))
                    End If
                    If dtToReturn.Rows(0)("inklhostmavip") Is System.DBNull.Value Then
                        m_bInklhostmavip = SqlBoolean.Null
                    Else
                        m_bInklhostmavip = New SqlBoolean(CType(dtToReturn.Rows(0)("inklhostmavip"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("uvmdoktyp") Is System.DBNull.Value Then
                        m_sUvmdoktyp = SqlString.Null
                    Else
                        m_sUvmdoktyp = New SqlString(CType(dtToReturn.Rows(0)("uvmdoktyp"), String))
                    End If
                    If dtToReturn.Rows(0)("uvmdatum1") Is System.DBNull.Value Then
                        m_sUvmdatum1 = SqlString.Null
                    Else
                        m_sUvmdatum1 = New SqlString(CType(dtToReturn.Rows(0)("uvmdatum1"), String))
                    End If
                    If dtToReturn.Rows(0)("uvmdatum2") Is System.DBNull.Value Then
                        m_sUvmdatum2 = SqlString.Null
                    Else
                        m_sUvmdatum2 = New SqlString(CType(dtToReturn.Rows(0)("uvmdatum2"), String))
                    End If
                    If dtToReturn.Rows(0)("uvmdatum3") Is System.DBNull.Value Then
                        m_sUvmdatum3 = SqlString.Null
                    Else
                        m_sUvmdatum3 = New SqlString(CType(dtToReturn.Rows(0)("uvmdatum3"), String))
                    End If
                    If dtToReturn.Rows(0)("uvmdatum4") Is System.DBNull.Value Then
                        m_sUvmdatum4 = SqlString.Null
                    Else
                        m_sUvmdatum4 = New SqlString(CType(dtToReturn.Rows(0)("uvmdatum4"), String))
                    End If
                    If dtToReturn.Rows(0)("uvmauftragnr") Is System.DBNull.Value Then
                        m_sUvmauftragnr = SqlString.Null
                    Else
                        m_sUvmauftragnr = New SqlString(CType(dtToReturn.Rows(0)("uvmauftragnr"), String))
                    End If
                    If dtToReturn.Rows(0)("zvdokumenttyp") Is System.DBNull.Value Then
                        m_sZvdokumenttyp = SqlString.Null
                    Else
                        m_sZvdokumenttyp = New SqlString(CType(dtToReturn.Rows(0)("zvdokumenttyp"), String))
                    End If
                    If dtToReturn.Rows(0)("zvauftraggeber") Is System.DBNull.Value Then
                        m_sZvauftraggeber = SqlString.Null
                    Else
                        m_sZvauftraggeber = New SqlString(CType(dtToReturn.Rows(0)("zvauftraggeber"), String))
                    End If
                    If dtToReturn.Rows(0)("zvverarbeitungsart") Is System.DBNull.Value Then
                        m_sZvverarbeitungsart = SqlString.Null
                    Else
                        m_sZvverarbeitungsart = New SqlString(CType(dtToReturn.Rows(0)("zvverarbeitungsart"), String))
                    End If
                    If dtToReturn.Rows(0)("zvreferenznr") Is System.DBNull.Value Then
                        m_sZvreferenznr = SqlString.Null
                    Else
                        m_sZvreferenznr = New SqlString(CType(dtToReturn.Rows(0)("zvreferenznr"), String))
                    End If
                    If dtToReturn.Rows(0)("zvzahlungsart") Is System.DBNull.Value Then
                        m_sZvzahlungsart = SqlString.Null
                    Else
                        m_sZvzahlungsart = New SqlString(CType(dtToReturn.Rows(0)("zvzahlungsart"), String))
                    End If
                    If dtToReturn.Rows(0)("zvpcnr") Is System.DBNull.Value Then
                        m_sZvpcnr = SqlString.Null
                    Else
                        m_sZvpcnr = New SqlString(CType(dtToReturn.Rows(0)("zvpcnr"), String))
                    End If
                    If dtToReturn.Rows(0)("zvclearingnr") Is System.DBNull.Value Then
                        m_sZvclearingnr = SqlString.Null
                    Else
                        m_sZvclearingnr = New SqlString(CType(dtToReturn.Rows(0)("zvclearingnr"), String))
                    End If
                    If dtToReturn.Rows(0)("zvkontobeg") Is System.DBNull.Value Then
                        m_sZvkontobeg = SqlString.Null
                    Else
                        m_sZvkontobeg = New SqlString(CType(dtToReturn.Rows(0)("zvkontobeg"), String))
                    End If
                    If dtToReturn.Rows(0)("zvswift") Is System.DBNull.Value Then
                        m_sZvswift = SqlString.Null
                    Else
                        m_sZvswift = New SqlString(CType(dtToReturn.Rows(0)("zvswift"), String))
                    End If
                    If dtToReturn.Rows(0)("zvvaluta") Is System.DBNull.Value Then
                        m_sZvvaluta = SqlString.Null
                    Else
                        m_sZvvaluta = New SqlString(CType(dtToReturn.Rows(0)("zvvaluta"), String))
                    End If
                    If dtToReturn.Rows(0)("zviso") Is System.DBNull.Value Then
                        m_sZviso = SqlString.Null
                    Else
                        m_sZviso = New SqlString(CType(dtToReturn.Rows(0)("zviso"), String))
                    End If
                    If dtToReturn.Rows(0)("zvbetrag") Is System.DBNull.Value Then
                        m_sZvbetrag = SqlString.Null
                    Else
                        m_sZvbetrag = New SqlString(CType(dtToReturn.Rows(0)("zvbetrag"), String))
                    End If
                    If dtToReturn.Rows(0)("zvvvextern1") Is System.DBNull.Value Then
                        m_sZvvvextern1 = SqlString.Null
                    Else
                        m_sZvvvextern1 = New SqlString(CType(dtToReturn.Rows(0)("zvvvextern1"), String))
                    End If
                    If dtToReturn.Rows(0)("zvvvexter2") Is System.DBNull.Value Then
                        m_sZvvvexter2 = SqlString.Null
                    Else
                        m_sZvvvexter2 = New SqlString(CType(dtToReturn.Rows(0)("zvvvexter2"), String))
                    End If
                    If dtToReturn.Rows(0)("zvposten") Is System.DBNull.Value Then
                        m_sZvposten = SqlString.Null
                    Else
                        m_sZvposten = New SqlString(CType(dtToReturn.Rows(0)("zvposten"), String))
                    End If
                    If dtToReturn.Rows(0)("zvauftragnr") Is System.DBNull.Value Then
                        m_sZvauftragnr = SqlString.Null
                    Else
                        m_sZvauftragnr = New SqlString(CType(dtToReturn.Rows(0)("zvauftragnr"), String))
                    End If
                    If dtToReturn.Rows(0)("zvarchivdatum") Is System.DBNull.Value Then
                        m_sZvarchivdatum = SqlString.Null
                    Else
                        m_sZvarchivdatum = New SqlString(CType(dtToReturn.Rows(0)("zvarchivdatum"), String))
                    End If
                    If dtToReturn.Rows(0)("zvdatum1") Is System.DBNull.Value Then
                        m_sZvdatum1 = SqlString.Null
                    Else
                        m_sZvdatum1 = New SqlString(CType(dtToReturn.Rows(0)("zvdatum1"), String))
                    End If
                    If dtToReturn.Rows(0)("zvdatum2") Is System.DBNull.Value Then
                        m_sZvdatum2 = SqlString.Null
                    Else
                        m_sZvdatum2 = New SqlString(CType(dtToReturn.Rows(0)("zvdatum2"), String))
                    End If
                    If dtToReturn.Rows(0)("zvdatum3") Is System.DBNull.Value Then
                        m_sZvdatum3 = SqlString.Null
                    Else
                        m_sZvdatum3 = New SqlString(CType(dtToReturn.Rows(0)("zvdatum3"), String))
                    End If
                    If dtToReturn.Rows(0)("zvdatum4") Is System.DBNull.Value Then
                        m_sZvdatum4 = SqlString.Null
                    Else
                        m_sZvdatum4 = New SqlString(CType(dtToReturn.Rows(0)("zvdatum4"), String))
                    End If
                    If dtToReturn.Rows(0)("inkInaktVersant") Is System.DBNull.Value Then
                        m_bInkInaktVersant = SqlBoolean.Null
                    Else
                        m_bInkInaktVersant = New SqlBoolean(CType(dtToReturn.Rows(0)("inkInaktVersant"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_profil_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstandard", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw1", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw2", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw3", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw4", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw5", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw6", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw7", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw8", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw9", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw9))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw10", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw10))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw11", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw11))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@senl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sekost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@seteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sema", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokart", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokstatus", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@serstaelterals", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sErstaelterals))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smutaelterasl", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMutaelterasl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ssort", SqlDbType.VarChar, 1024, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktive", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktive))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofiltyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfiltyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklalt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklhostmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklhostmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdoktyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmdatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@suvmauftragnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUvmauftragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdokumenttyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvauftraggeber", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvauftraggeber))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvverarbeitungsart", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvverarbeitungsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvreferenznr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvreferenznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvzahlungsart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvzahlungsart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvpcnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvpcnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvclearingnr", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvclearingnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvkontobeg", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvkontobeg))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvswift", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvswift))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvaluta", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvaluta))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szviso", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZviso))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvbetrag", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvbetrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvvextern1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvvextern1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvvvexter2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvvvexter2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvposten", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvposten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvauftragnr", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvauftragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvarchivdatum", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvarchivdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szvdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZvdatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binkInaktVersant", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInkInaktVersant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_profil_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfil::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProfil Fields

clsProfil overview

Fields

field m_bAktiv
field m_bAktive
field m_bInkInaktVersant
field m_bInklalt
field m_bInklhostmavip
field m_bInklmavip
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bStandard
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHw1
field m_iHw10
field m_iHw11
field m_iHw2
field m_iHw3
field m_iHw4
field m_iHw5
field m_iHw6
field m_iHw7
field m_iHw8
field m_iHw9
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iProfilnr
field m_iProfiltyp
field m_iTeam
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_sBeschreibung
field m_sBezeichnung
field m_sColor1
field m_sColor2
field m_sColor3
field m_sColor4
field m_sColor5
field m_sColor6
field m_sColor7
field m_sColor8
field m_sDatum1
field m_sDatum2
field m_sDatum3
field m_sDatum4
field m_sDatum5
field m_sDatum6
field m_sDatum7
field m_sDatum8
field m_sDdokart
field m_sDdokstatus
field m_sDoktyp
field m_sDpartner
field m_sEkost
field m_sEma
field m_sEmb
field m_sEnl
field m_sErstaelterals
field m_sEteam
field m_sHostdatum1
field m_sHostdatum2
field m_sHostdatum3
field m_sHostdokart
field m_sHostdoktyp
field m_sHostpartner
field m_sHosttag1
field m_sHosttag2
field m_sHosttag3
field m_sMkost
field m_sMma
field m_sMmb
field m_sMnl
field m_sMteam
field m_sMutaelterasl
field m_sSort
field m_sUvmauftragnr
field m_sUvmdatum1
field m_sUvmdatum2
field m_sUvmdatum3
field m_sUvmdatum4
field m_sUvmdoktyp
field m_sVkost
field m_sVma
field m_sVmb
field m_sVnl
field m_sVteam
field m_sZvarchivdatum
field m_sZvauftraggeber
field m_sZvauftragnr
field m_sZvbetrag
field m_sZvclearingnr
field m_sZvdatum1
field m_sZvdatum2
field m_sZvdatum3
field m_sZvdatum4
field m_sZvdokumenttyp
field m_sZviso
field m_sZvkontobeg
field m_sZvpcnr
field m_sZvposten
field m_sZvreferenznr
field m_sZvswift
field m_sZvvaluta
field m_sZvverarbeitungsart
field m_sZvvvexter2
field m_sZvvvextern1
field m_sZvzahlungsart
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProfil Class


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bAktive Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bInkInaktVersant Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bInklalt Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bInklhostmavip Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bInklmavip Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_bStandard Variable

Private 		m_bAktiv, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktive, _
   m_bInkInaktVersant, _
   m_bInklhostmavip, _
   m_bInklmavip As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bStandard, m_bInklalt, m_bAktive, m_bInkInaktVersant, m_bInklhostmavip, m_bInklmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw1 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw10 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw11 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw2 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw3 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw4 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw5 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw6 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw7 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw8 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iHw9 Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iMandantnr Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iMitarbeiternr Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iMutierer Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iProfilnr Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iProfiltyp Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iTeam Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iUnterschriftlinks Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_iUnterschriftrechts Variable

Private 		m_iHw2, _
   m_iHw5, _
   m_iHw1, _
   m_iHw3, _
   m_iHw4, _
   m_iHw6, _
   m_iHw10, _
   m_iHw11, _
   m_iHw9, _
   m_iHw7, _
   m_iHw8, _
   m_iMutierer, _
   m_iProfiltyp, _
   m_iTeam, _
   m_iProfilnr, _
   m_iMitarbeiternr, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts As SqlInt32

Source code

[Visual Basic]
        Private 		m_iHw2, m_iHw5, m_iHw1, m_iHw3, m_iHw4, m_iHw6, m_iHw10, m_iHw11, m_iHw9, m_iHw7, m_iHw8, m_iMutierer, m_iProfiltyp, m_iTeam, m_iProfilnr, m_iMitarbeiternr, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sBeschreibung Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sBezeichnung Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor4 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor5 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor6 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor7 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sColor8 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum4 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum5 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum6 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum7 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDatum8 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDdokart Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDdokstatus Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDoktyp Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sDpartner Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sEkost Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sEma Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sEmb Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sEnl Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sErstaelterals Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sEteam Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostdatum1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostdatum2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostdatum3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostdokart Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostdoktyp Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHostpartner Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHosttag1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHosttag2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sHosttag3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMkost Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMma Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMmb Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMnl Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMteam Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sMutaelterasl Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sSort Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmauftragnr Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmdatum1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmdatum2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmdatum3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmdatum4 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sUvmdoktyp Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sVkost Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sVma Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sVmb Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sVnl Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sVteam Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvarchivdatum Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvauftraggeber Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvauftragnr Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvbetrag Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvclearingnr Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvdatum1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvdatum2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvdatum3 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvdatum4 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvdokumenttyp Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZviso Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvkontobeg Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvpcnr Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvposten Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvreferenznr Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvswift Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvvaluta Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvverarbeitungsart Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvvvexter2 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvvvextern1 Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


m_sZvzahlungsart Variable

Private 		m_sUvmdoktyp, _
   m_sUvmdatum2, _
   m_sHostdatum3, _
   m_sUvmdatum1, _
   m_sUvmdatum4, _
   m_sUvmauftragnr, _
   m_sUvmdatum3, _
   m_sHostdokart, _
   m_sHostpartner, _
   m_sHosttag1, _
   m_sHostdoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sHostdatum1, _
   m_sHosttag2, _
   m_sZvposten, _
   m_sZvauftragnr, _
   m_sZvvvexter2, _
   m_sZvbetrag, _
   m_sZvvvextern1, _
   m_sZvdatum3, _
   m_sZvdatum4, _
   m_sZvdatum2, _
   m_sZvarchivdatum, _
   m_sZvdatum1, _
   m_sZviso, _
   m_sZvreferenznr, _
   m_sZvzahlungsart, _
   m_sZvverarbeitungsart, _
   m_sZvdokumenttyp, _
   m_sZvauftraggeber, _
   m_sZvswift, _
   m_sZvvaluta, _
   m_sZvkontobeg, _
   m_sZvpcnr, _
   m_sZvclearingnr, _
   m_sVteam, _
   m_sVma, _
   m_sVkost, _
   m_sVmb, _
   m_sVnl, _
   m_sMteam, _
   m_sMma, _
   m_sMkost, _
   m_sMmb, _
   m_sMnl, _
   m_sColor2, _
   m_sColor3, _
   m_sColor1, _
   m_sBezeichnung, _
   m_sBeschreibung, _
   m_sColor7, _
   m_sColor8, _
   m_sColor6, _
   m_sColor4, _
   m_sColor5, _
   m_sDatum6, _
   m_sDatum7, _
   m_sDatum5, _
   m_sDatum3, _
   m_sDatum4, _
   m_sSort, _
   m_sDoktyp, _
   m_sMutaelterasl, _
   m_sDatum8, _
   m_sErstaelterals, _
   m_sEteam, _
   m_sEma, _
   m_sEkost, _
   m_sEmb, _
   m_sEnl, _
   m_sDatum1, _
   m_sDatum2, _
   m_sDdokstatus, _
   m_sDpartner, _
   m_sDdokart As SqlString

Source code

[Visual Basic]
        Private 		m_sUvmdoktyp, m_sUvmdatum2, m_sHostdatum3, m_sUvmdatum1, m_sUvmdatum4, m_sUvmauftragnr, m_sUvmdatum3, m_sHostdokart, m_sHostpartner, m_sHosttag1, m_sHostdoktyp, m_sHostdatum2, m_sHosttag3, m_sHostdatum1, m_sHosttag2, m_sZvposten, m_sZvauftragnr, m_sZvvvexter2, m_sZvbetrag, m_sZvvvextern1, m_sZvdatum3, m_sZvdatum4, m_sZvdatum2, m_sZvarchivdatum, m_sZvdatum1, m_sZviso, m_sZvreferenznr, m_sZvzahlungsart, m_sZvverarbeitungsart, m_sZvdokumenttyp, m_sZvauftraggeber, m_sZvswift, m_sZvvaluta, m_sZvkontobeg, m_sZvpcnr, m_sZvclearingnr, m_sVteam, m_sVma, m_sVkost, m_sVmb, m_sVnl, m_sMteam, m_sMma, m_sMkost, m_sMmb, m_sMnl, m_sColor2, m_sColor3, m_sColor1, m_sBezeichnung, m_sBeschreibung, m_sColor7, m_sColor8, m_sColor6, m_sColor4, m_sColor5, m_sDatum6, m_sDatum7, m_sDatum5, m_sDatum3, m_sDatum4, m_sSort, m_sDoktyp, m_sMutaelterasl, m_sDatum8, m_sErstaelterals, m_sEteam, m_sEma, m_sEkost, m_sEmb, m_sEnl, m_sDatum1, m_sDatum2, m_sDdokstatus, m_sDpartner, m_sDdokart As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfil


clsProzess Class

For a list of all members of this type, see clsProzess Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsProzess

Public Class clsProzess
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsProzess Members


clsProzess Members

clsProzess overview

Constructors

constructor clsProzess Constructor

Properties

property bAktiv
property bErstellung
property bVerwendung
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iProzessnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bErstellung
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bVerwendung
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iProzessnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProzess Class


clsProzess Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess Properties

clsProzess overview

Properties

property bAktiv
property bErstellung
property bVerwendung
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iProzessnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProzess Class


clsProzess.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.bErstellung Property

Public Property [bErstellung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bErstellung]() As SqlBoolean
            Get
                Return m_bErstellung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bErstellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.bVerwendung Property

Public Property [bVerwendung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVerwendung]() As SqlBoolean
            Get
                Return m_bVerwendung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVerwendung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.iProzessnr Property

Public Property [iProzessnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProzessnr]() As SqlInt32
            Get
                Return m_iProzessnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iProzessnrTmp As SqlInt32 = Value
                If iProzessnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iProzessnr", "iProzessnr can't be NULL")
                End If
                m_iProzessnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess Methods

clsProzess overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsProzess Class


clsProzess.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_prozess_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_prozess_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProzess::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_prozess_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bverwendung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_prozess_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProzess::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_prozess_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("prozess")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_prozess_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProzess::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_prozess_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("prozess")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_prozess_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iProzessnr = New SqlInt32(CType(dtToReturn.Rows(0)("prozessnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("erstellung") Is System.DBNull.Value Then
                        m_bErstellung = SqlBoolean.Null
                    Else
                        m_bErstellung = New SqlBoolean(CType(dtToReturn.Rows(0)("erstellung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("verwendung") Is System.DBNull.Value Then
                        m_bVerwendung = SqlBoolean.Null
                    Else
                        m_bVerwendung = New SqlBoolean(CType(dtToReturn.Rows(0)("verwendung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProzess::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_prozess_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bverwendung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVerwendung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_prozess_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProzess::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsProzess Fields

clsProzess overview

Fields

field m_bAktiv
field m_bErstellung
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bVerwendung
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iProzessnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProzess Class


m_bAktiv Variable

Private 		m_bErstellung, _
   m_bVerwendung, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bErstellung, m_bVerwendung, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_bErstellung Variable

Private 		m_bErstellung, _
   m_bVerwendung, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bErstellung, m_bVerwendung, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_bVerwendung Variable

Private 		m_bErstellung, _
   m_bVerwendung, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bErstellung, m_bVerwendung, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iProzessnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iProzessnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iProzessnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iProzessnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_iProzessnr Variable

Private 		m_iMutierer, _
   m_iProzessnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iProzessnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_sBeschreibung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


m_sBezeichnung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProzess


clsReportfeld Class

For a list of all members of this type, see clsReportfeld Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsReportfeld

Public Class clsReportfeld
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReportfeld Members


clsReportfeld Members

clsReportfeld overview

Constructors

constructor clsReportfeld Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property iReportfeld_nr
property iReportfeldregelnr
property iReportnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iReportfeld_nr
field m_iReportfeldregelnr
field m_iReportnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportfeld Class


clsReportfeld Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld Properties

clsReportfeld overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property iReportfeld_nr
property iReportfeldregelnr
property iReportnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportfeld Class


clsReportfeld.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReihenfolgeTmp As SqlInt32 = Value
                If iReihenfolgeTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReihenfolge", "iReihenfolge can't be NULL")
                End If
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iReportfeld_nr Property

Public Property [iReportfeld_nr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportfeld_nr]() As SqlInt32
            Get
                Return m_iReportfeld_nr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportfeld_nrTmp As SqlInt32 = Value
                If iReportfeld_nrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportfeld_nr", "iReportfeld_nr can't be NULL")
                End If
                m_iReportfeld_nr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iReportfeldregelnr Property

Public Property [iReportfeldregelnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportfeldregelnr]() As SqlInt32
            Get
                Return m_iReportfeldregelnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportfeldregelnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.iReportnr Property

Public Property [iReportnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportnr]() As SqlInt32
            Get
                Return m_iReportnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld Methods

clsReportfeld overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsReportfeld Class


clsReportfeld.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportfeld_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportfeld_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportfeld_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportfeld_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportfeld::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportfeld_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportfeld_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportfeld_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportfeldregelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportfeld_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportfeld::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportfeld_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("reportfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportfeld_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportfeld::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportfeld_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("reportfeld")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireportfeld_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportfeld_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportfeld_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReportfeld_nr = New SqlInt32(CType(dtToReturn.Rows(0)("reportfeld_nr"), Integer))
                    If dtToReturn.Rows(0)("reportfeldregelnr") Is System.DBNull.Value Then
                        m_iReportfeldregelnr = SqlInt32.Null
                    Else
                        m_iReportfeldregelnr = New SqlInt32(CType(dtToReturn.Rows(0)("reportfeldregelnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("reportnr") Is System.DBNull.Value Then
                        m_iReportnr = SqlInt32.Null
                    Else
                        m_iReportnr = New SqlInt32(CType(dtToReturn.Rows(0)("reportnr"), Integer))
                    End If
                    m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportfeld::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportfeld_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportfeld_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportfeld_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportfeldregelnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportfeld_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportfeld::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportfeld Fields

clsReportfeld overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iReportfeld_nr
field m_iReportfeldregelnr
field m_iReportnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportfeld Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iReihenfolge Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iReportfeld_nr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iReportfeldregelnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


m_iReportnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportfeldregelnr, _
   m_iReportfeld_nr, _
   m_iReihenfolge, _
   m_iReportnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportfeldregelnr, m_iReportfeld_nr, m_iReihenfolge, m_iReportnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportfeld


clsReportgruppe_report Class

For a list of all members of this type, see clsReportgruppe_report Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsReportgruppe_report

Public Class clsReportgruppe_report
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReportgruppe_report Members


clsReportgruppe_report Members

clsReportgruppe_report overview

Constructors

constructor clsReportgruppe_report Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReportNr
property iReportgruppeNr
property iReportgruppeReportNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReportNr
field m_iReportgruppeNr
field m_iReportgruppeReportNr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportgruppe_report Class


clsReportgruppe_report Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report Properties

clsReportgruppe_report overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReportNr
property iReportgruppeNr
property iReportgruppeReportNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportgruppe_report Class


clsReportgruppe_report.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.iReportNr Property

Public Property [iReportNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportNr]() As SqlInt32
            Get
                Return m_iReportNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.iReportgruppeNr Property

Public Property [iReportgruppeNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportgruppeNr]() As SqlInt32
            Get
                Return m_iReportgruppeNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportgruppeNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.iReportgruppeReportNr Property

Public Property [iReportgruppeReportNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportgruppeReportNr]() As SqlInt32
            Get
                Return m_iReportgruppeReportNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportgruppeReportNrTmp As SqlInt32 = Value
                If iReportgruppeReportNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportgruppeReportNr", "iReportgruppeReportNr can't be NULL")
                End If
                m_iReportgruppeReportNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report Methods

clsReportgruppe_report overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsReportgruppe_report Class


clsReportgruppe_report.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportgruppe_report_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportgruppeReportNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeReportNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportgruppe_report_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportgruppe_report::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportgruppe_report_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportgruppeReportNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportgruppe_report_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportgruppe_report::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportgruppe_report_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("reportgruppe_report")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportgruppe_report_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportgruppe_report::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportgruppe_report_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("reportgruppe_report")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReportgruppeReportNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeReportNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportgruppe_report_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReportgruppeReportNr = New SqlInt32(CType(dtToReturn.Rows(0)("ReportgruppeReportNr"), Integer))
                    If dtToReturn.Rows(0)("reportgruppeNr") Is System.DBNull.Value Then
                        m_iReportgruppeNr = SqlInt32.Null
                    Else
                        m_iReportgruppeNr = New SqlInt32(CType(dtToReturn.Rows(0)("reportgruppeNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("reportNr") Is System.DBNull.Value Then
                        m_iReportNr = SqlInt32.Null
                    Else
                        m_iReportNr = New SqlInt32(CType(dtToReturn.Rows(0)("reportNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportgruppe_report::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_reportgruppe_report_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportgruppeReportNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportgruppeNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportgruppeNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_reportgruppe_report_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportgruppe_report::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportgruppe_report Fields

clsReportgruppe_report overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReportNr
field m_iReportgruppeNr
field m_iReportgruppeReportNr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportgruppe_report Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportgruppeNr, _
   m_iReportNr, _
   m_iReportgruppeReportNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportgruppeNr, m_iReportNr, m_iReportgruppeReportNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportgruppeNr, _
   m_iReportNr, _
   m_iReportgruppeReportNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportgruppeNr, m_iReportNr, m_iReportgruppeReportNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_iReportNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportgruppeNr, _
   m_iReportNr, _
   m_iReportgruppeReportNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportgruppeNr, m_iReportNr, m_iReportgruppeReportNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_iReportgruppeNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportgruppeNr, _
   m_iReportNr, _
   m_iReportgruppeReportNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportgruppeNr, m_iReportNr, m_iReportgruppeReportNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


m_iReportgruppeReportNr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iReportgruppeNr, _
   m_iReportNr, _
   m_iReportgruppeReportNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iReportgruppeNr, m_iReportNr, m_iReportgruppeReportNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportgruppe_report


clsReportingSortOrderUser Class

For a list of all members of this type, see clsReportingSortOrderUser Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsReportingSortOrderUser

Public Class clsReportingSortOrderUser
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReportingSortOrderUser Members


clsReportingSortOrderUser Members

clsReportingSortOrderUser overview

Constructors

constructor clsReportingSortOrderUser Constructor

Properties

property bAktiv
property bAufsteigend
property bLoeschen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_Am
property daMutiert_Am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iID
property iMandant_Nr
property iMitarbeiternr
property iMutierer
property iReportID
property iReportingSortOrderID
property iSortOrder
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDisplayFieldName
property sReportFieldName

Methods

method Delete
method DeleteWIDLogic
method DeleteWReportIDLogic
method DeleteWmitarbeiternrLogic
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAufsteigend
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_Am
field m_daMutiert_Am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iID
field m_iMandant_Nr
field m_iMitarbeiternr
field m_iMutierer
field m_iReportID
field m_iReportingSortOrderID
field m_iSortOrder
field m_sDisplayFieldName
field m_sReportFieldName
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportingSortOrderUser Class


clsReportingSortOrderUser Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser Properties

clsReportingSortOrderUser overview

Properties

property bAktiv
property bAufsteigend
property bLoeschen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_Am
property daMutiert_Am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iID
property iMandant_Nr
property iMitarbeiternr
property iMutierer
property iReportID
property iReportingSortOrderID
property iSortOrder
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDisplayFieldName
property sReportFieldName

See Also

clsReportingSortOrderUser Class


clsReportingSortOrderUser.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.bAufsteigend Property

Public Property [bAufsteigend]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAufsteigend]() As SqlBoolean
            Get
                Return m_bAufsteigend
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAufsteigend = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.bLoeschen Property

Public Property [bLoeschen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bLoeschen]() As SqlBoolean
            Get
                Return m_bLoeschen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bLoeschen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.daErstellt_Am Property

Public Property [daErstellt_Am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_Am]() As SqlDateTime
            Get
                Return m_daErstellt_Am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_Am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.daMutiert_Am Property

Public Property [daMutiert_Am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_Am]() As SqlDateTime
            Get
                Return m_daMutiert_Am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_Am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iID Property

Public Property [iID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iID]() As SqlInt32
            Get
                Return m_iID
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iIDTmp As SqlInt32 = Value
                If iIDTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iID", "iID can't be NULL")
                End If
                m_iID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iMandant_Nr Property

Public Property [iMandant_Nr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandant_Nr]() As SqlInt32
            Get
                Return m_iMandant_Nr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandant_Nr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iReportID Property

Public Property [iReportID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportID]() As SqlInt32
            Get
                Return m_iReportID
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportIDTmp As SqlInt32 = Value
                If iReportIDTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportID", "iReportID can't be NULL")
                End If
                m_iReportID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iReportingSortOrderID Property

Public Property [iReportingSortOrderID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportingSortOrderID]() As SqlInt32
            Get
                Return m_iReportingSortOrderID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportingSortOrderID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.iSortOrder Property

Public Property [iSortOrder]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSortOrder]() As SqlInt32
            Get
                Return m_iSortOrder
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSortOrder = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.sDisplayFieldName Property

Public Property [sDisplayFieldName]() As SqlString

Source code

[Visual Basic]
        Public Property [sDisplayFieldName]() As SqlString
            Get
                Return m_sDisplayFieldName
            End Get
            Set(ByVal Value As SqlString)
                m_sDisplayFieldName = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.sReportFieldName Property

Public Property [sReportFieldName]() As SqlString

Source code

[Visual Basic]
        Public Property [sReportFieldName]() As SqlString
            Get
                Return m_sReportFieldName
            End Get
            Set(ByVal Value As SqlString)
                m_sReportFieldName = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser Methods

clsReportingSortOrderUser overview

Methods

method Delete
method DeleteWIDLogic
method DeleteWReportIDLogic
method DeleteWmitarbeiternrLogic
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsReportingSortOrderUser Class


clsReportingSortOrderUser.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.DeleteWIDLogic Method

Public Function DeleteWIDLogic() As Boolean

Source code

[Visual Basic]
        Public Function DeleteWIDLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_DeleteWIDLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iID", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_DeleteWIDLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::DeleteWIDLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.DeleteWReportIDLogic Method

Public Function DeleteWReportIDLogic() As Boolean

Source code

[Visual Basic]
        Public Function DeleteWReportIDLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_DeleteWReportIDLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReportID", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iReportID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_DeleteWReportIDLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::DeleteWReportIDLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.DeleteWmitarbeiternrLogic Method

Public Function DeleteWmitarbeiternrLogic() As Boolean

Source code

[Visual Basic]
        Public Function DeleteWmitarbeiternrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_DeleteWmitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_DeleteWmitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::DeleteWmitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportingSortOrderID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportingSortOrderID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDisplayFieldName", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDisplayFieldName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sReportFieldName", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReportFieldName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAufsteigend", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAufsteigend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSortOrder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSortOrder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_Am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_Am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_Am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_Am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bLoeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandant_Nr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant_Nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ReportingSortOrderUser")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ReportingSortOrderUser")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReportID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iID = New SqlInt32(CType(dtToReturn.Rows(0)("ID"), Integer))
                    If dtToReturn.Rows(0)("ReportingSortOrderID") Is System.DBNull.Value Then
                        m_iReportingSortOrderID = SqlInt32.Null
                    Else
                        m_iReportingSortOrderID = New SqlInt32(CType(dtToReturn.Rows(0)("ReportingSortOrderID"), Integer))
                    End If
                    m_iReportID = New SqlInt32(CType(dtToReturn.Rows(0)("ReportID"), Integer))
                    If dtToReturn.Rows(0)("DisplayFieldName") Is System.DBNull.Value Then
                        m_sDisplayFieldName = SqlString.Null
                    Else
                        m_sDisplayFieldName = New SqlString(CType(dtToReturn.Rows(0)("DisplayFieldName"), String))
                    End If
                    If dtToReturn.Rows(0)("ReportFieldName") Is System.DBNull.Value Then
                        m_sReportFieldName = SqlString.Null
                    Else
                        m_sReportFieldName = New SqlString(CType(dtToReturn.Rows(0)("ReportFieldName"), String))
                    End If
                    If dtToReturn.Rows(0)("Aufsteigend") Is System.DBNull.Value Then
                        m_bAufsteigend = SqlBoolean.Null
                    Else
                        m_bAufsteigend = New SqlBoolean(CType(dtToReturn.Rows(0)("Aufsteigend"), Boolean))
                    End If
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("SortOrder") Is System.DBNull.Value Then
                        m_iSortOrder = SqlInt32.Null
                    Else
                        m_iSortOrder = New SqlInt32(CType(dtToReturn.Rows(0)("SortOrder"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("Aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Erstellt_Am") Is System.DBNull.Value Then
                        m_daErstellt_Am = SqlDateTime.Null
                    Else
                        m_daErstellt_Am = New SqlDateTime(CType(dtToReturn.Rows(0)("Erstellt_Am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutiert_Am") Is System.DBNull.Value Then
                        m_daMutiert_Am = SqlDateTime.Null
                    Else
                        m_daMutiert_Am = New SqlDateTime(CType(dtToReturn.Rows(0)("Mutiert_Am"), Date))
                    End If
                    If dtToReturn.Rows(0)("Mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("Mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Loeschen") Is System.DBNull.Value Then
                        m_bLoeschen = SqlBoolean.Null
                    Else
                        m_bLoeschen = New SqlBoolean(CType(dtToReturn.Rows(0)("Loeschen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Mandant_Nr") Is System.DBNull.Value Then
                        m_iMandant_Nr = SqlInt32.Null
                    Else
                        m_iMandant_Nr = New SqlInt32(CType(dtToReturn.Rows(0)("Mandant_Nr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ReportingSortOrderUser_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportingSortOrderID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportingSortOrderID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sDisplayFieldName", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDisplayFieldName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sReportFieldName", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReportFieldName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAufsteigend", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAufsteigend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iSortOrder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSortOrder))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bAktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daErstellt_Am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_Am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daMutiert_Am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_Am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bLoeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iMandant_Nr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant_Nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ReportingSortOrderUser_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReportingSortOrderUser::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReportingSortOrderUser Fields

clsReportingSortOrderUser overview

Fields

field m_bAktiv
field m_bAufsteigend
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_Am
field m_daMutiert_Am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iID
field m_iMandant_Nr
field m_iMitarbeiternr
field m_iMutierer
field m_iReportID
field m_iReportingSortOrderID
field m_iSortOrder
field m_sDisplayFieldName
field m_sReportFieldName
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReportingSortOrderUser Class


m_bAktiv Variable

Private 		m_bAufsteigend, _
   m_bLoeschen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAufsteigend, m_bLoeschen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_bAufsteigend Variable

Private 		m_bAufsteigend, _
   m_bLoeschen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAufsteigend, m_bLoeschen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_bLoeschen Variable

Private 		m_bAufsteigend, _
   m_bLoeschen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAufsteigend, m_bLoeschen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_daErstellt_Am Variable

Private 		m_daErstellt_Am, _
   m_daMutiert_Am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_Am, m_daMutiert_Am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_daMutiert_Am Variable

Private 		m_daErstellt_Am, _
   m_daMutiert_Am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_Am, m_daMutiert_Am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iID Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iMandant_Nr Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iMitarbeiternr Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iMutierer Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iReportID Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iReportingSortOrderID Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_iSortOrder Variable

Private 		m_iMandant_Nr, _
   m_iMutierer, _
   m_iSortOrder, _
   m_iReportingSortOrderID, _
   m_iReportID, _
   m_iMitarbeiternr, _
   m_iID As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandant_Nr, m_iMutierer, m_iSortOrder, m_iReportingSortOrderID, m_iReportID, m_iMitarbeiternr, m_iID As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_sDisplayFieldName Variable

Private 		m_sReportFieldName, _
   m_sDisplayFieldName As SqlString

Source code

[Visual Basic]
        Private 		m_sReportFieldName, m_sDisplayFieldName As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


m_sReportFieldName Variable

Private 		m_sReportFieldName, _
   m_sDisplayFieldName As SqlString

Source code

[Visual Basic]
        Private 		m_sReportFieldName, m_sDisplayFieldName As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReportingSortOrderUser


clsReporting_Dokumenttyp Class

For a list of all members of this type, see clsReporting_Dokumenttyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsReporting_Dokumenttyp

Public Class clsReporting_Dokumenttyp
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReporting_Dokumenttyp Members


clsReporting_Dokumenttyp Members

clsReporting_Dokumenttyp overview

Constructors

constructor clsReporting_Dokumenttyp Constructor (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Properties

property DokumentID
property Dokumentname
property bUsed
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iType
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDEFBMB
property sDEFBME
property sDEFDESC
property sDEFFELD
property sDEFVALUE
property sID
property sOFBM
property sOFFeld

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Get_DocumentFrom_DB
method Get_From_DB
method Get_layout_from_DB
method Insert (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Save_To_DB
method SelectAll (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUsed
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_dokumentid
field m_dokumentname
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iType
field m_sDEFBMB
field m_sDEFBME
field m_sDEFDESC
field m_sDEFFELD
field m_sDEFVALUE
field m_sID
field m_sOFBM
field m_sOFFeld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReporting_Dokumenttyp Class


clsReporting_Dokumenttyp Properties

clsReporting_Dokumenttyp overview

Properties

property DokumentID
property Dokumentname
property bUsed
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iType
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDEFBMB
property sDEFBME
property sDEFDESC
property sDEFFELD
property sDEFVALUE
property sID
property sOFBM
property sOFFeld

See Also

clsReporting_Dokumenttyp Class


clsReporting_Dokumenttyp.DokumentID Property

Property DokumentID() As String

Source code

[Visual Basic]
        Property DokumentID() As String
            Get
                Return m_dokumentid
            End Get
            Set(ByVal Value As String)
                m_dokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.Dokumentname Property

Property Dokumentname() As String

Source code

[Visual Basic]
        Property Dokumentname() As String
            Get
                Return m_dokumentname
            End Get
            Set(ByVal Value As String)
                m_dokumentname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.bUsed Property

Public Property [bUsed]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUsed]() As SqlBoolean
            Get
                Return m_bUsed
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bUsed = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.iType Property

Public Property [iType]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iType]() As SqlInt32
            Get
                Return m_iType
            End Get
            Set(ByVal Value As SqlInt32)
                m_iType = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sDEFBMB Property

Public Property [sDEFBMB]() As SqlString

Source code

[Visual Basic]
        Public Property [sDEFBMB]() As SqlString
            Get
                Return m_sDEFBMB
            End Get
            Set(ByVal Value As SqlString)
                m_sDEFBMB = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sDEFBME Property

Public Property [sDEFBME]() As SqlString

Source code

[Visual Basic]
        Public Property [sDEFBME]() As SqlString
            Get
                Return m_sDEFBME
            End Get
            Set(ByVal Value As SqlString)
                m_sDEFBME = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sDEFDESC Property

Public Property [sDEFDESC]() As SqlString

Source code

[Visual Basic]
        Public Property [sDEFDESC]() As SqlString
            Get
                Return m_sDEFDESC
            End Get
            Set(ByVal Value As SqlString)
                m_sDEFDESC = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sDEFFELD Property

Public Property [sDEFFELD]() As SqlString

Source code

[Visual Basic]
        Public Property [sDEFFELD]() As SqlString
            Get
                Return m_sDEFFELD
            End Get
            Set(ByVal Value As SqlString)
                m_sDEFFELD = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sDEFVALUE Property

Public Property [sDEFVALUE]() As SqlString

Source code

[Visual Basic]
        Public Property [sDEFVALUE]() As SqlString
            Get
                Return m_sDEFVALUE
            End Get
            Set(ByVal Value As SqlString)
                m_sDEFVALUE = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sID Property

Public Property [sID]() As SqlString

Source code

[Visual Basic]
        Public Property [sID]() As SqlString
            Get
                Return m_sID
            End Get
            Set(ByVal Value As SqlString)
                m_sID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sOFBM Property

Public Property [sOFBM]() As SqlString

Source code

[Visual Basic]
        Public Property [sOFBM]() As SqlString
            Get
                Return m_sOFBM
            End Get
            Set(ByVal Value As SqlString)
                m_sOFBM = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.sOFFeld Property

Public Property [sOFFeld]() As SqlString

Source code

[Visual Basic]
        Public Property [sOFFeld]() As SqlString
            Get
                Return m_sOFFeld
            End Get
            Set(ByVal Value As SqlString)
                m_sOFFeld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp Methods

clsReporting_Dokumenttyp overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Get_DocumentFrom_DB
method Get_From_DB
method Get_layout_from_DB
method Insert (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Save_To_DB
method SelectAll (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReporting_Dokumenttyp Class


clsReporting_Dokumenttyp.Get_DocumentFrom_DB Method

Public Function Get_DocumentFrom_DB( _
   ByVal DokumentIDSpaltenname As String, _
   ByVal DokumentID As String, _
   ByVal Tabellenname As String, _
   ByVal DokumentSpaltenname As String, _
   ByVal DokumentePfad As String, _
   ByVal DokumentenName As String _
) As Boolean

Parameters

DokumentIDSpaltenname
Required.
DokumentID
Required.
Tabellenname
Required.
DokumentSpaltenname
Required.
DokumentePfad
Required.
DokumentenName
Required.

Source code

[Visual Basic]
        Public Function Get_DocumentFrom_DB(ByVal DokumentIDSpaltenname As String, ByVal DokumentID As String, ByVal Tabellenname As String, ByVal DokumentSpaltenname As String, ByVal DokumentePfad As String, ByVal DokumentenName As String) As Boolean
            '===============================================================================
            'Beschr:    Liest ein Dokument aus der Datenbank und speichert die auf den Fileserver
            '           Ein bestehendes File wird überschrieben
            'Input :    DokumentIDSpaltenname   = Spalte für die Identifikation des Dokument
            '           DokumentID = Eindeutige Identifikation des Dokument
            '           Tabellenname = Tabell in der das File gespeichert ist
            '           Spaltenname = Spaltenname in der das Dokument gespeichert ist
            '           Dokumentenname = Name des Dokumentes inkl. Pfadangaben
            'Output:    Speicherung erfolgreich True/False
            'Erstellt  : koe 20.10.2003
            'Geaendert :
            '===============================================================================
            Me.DokumentID = DokumentID
            Me.Dokumentname = DokumentenName

            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From " & Tabellenname & " where " & DokumentIDSpaltenname & " = '" + Me.DokumentID + "'", connection)
            Dim ds As New DataSet()

            '===============================================================================
            'Verzeichnisprüffung
            '===============================================================================
            Try
                If Right(DokumentePfad, 1) <> "\" Then
                    DokumentePfad = DokumentePfad & "\"
                End If
                If Not System.IO.Directory.Exists(DokumentePfad) Then
                    System.IO.Directory.CreateDirectory(DokumentePfad)
                End If
            Catch ex As Exception
                MessageBox.Show("Vereichnis " & DokumentePfad & " kann nicht hergestellt werden!", "Verzeichnis", MessageBoxButtons.OK, MessageBoxIcon.Exclamation)
                Return False
            End Try

            Try
                'Connectionstring zur Datenbank
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "Dokument")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                MyData = myRow.Item(DokumentSpaltenname)
                Dim lCnt As Long
                lCnt = UBound(MyData)
                Dim fs As New FileStream(DokumentePfad & DokumentenName, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, lCnt)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                MsgBox(ex.Message)
                'If Not DivFnkt.isbck(Me.DokumentID) Then
                'MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
                'End If
                Return False
            End Try
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.Get_From_DB Method

Public Function Get_From_DB( _
   ByVal sDokumentID As String, _
   ByVal sDokumentName As String _
) As Boolean

Parameters

sDokumentID
Required.
sDokumentName
Required.

Source code

[Visual Basic]
        Public Function Get_From_DB(ByVal sDokumentID As String, ByVal sDokumentName As String) As Boolean
            Me.DokumentID = sDokumentID
            Me.Dokumentname = sDokumentName

            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From doks where DokumentID='" + Me.DokumentID + "'", connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()

            Try
                'Connectionstring zur Datenbank
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                MyData = myRow.Item(1)
                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(sDokumentName, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                If Not DivFnkt.isbck(Me.DokumentID) Then
                    MyMsg.show_standardmessage(93, MsgBoxStyle.Critical)
                End If
                Return False
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.Get_layout_from_DB Method

Public Function Get_layout_from_DB( _
   ByVal profilnr As Integer, _
   ByVal sdokumentname As String _
) As String

Parameters

profilnr
Required.
sdokumentname
Required.

Source code

[Visual Basic]
        Public Function Get_layout_from_DB(ByVal profilnr As Integer, ByVal sdokumentname As String) As String
            Me.Dokumentname = LTrim(Str(profilnr)) + ".lyt"
            Dim connection As New SqlConnection()
            Dim da As New SqlDataAdapter("Select * From profillayout where profilnr=" + Str(profilnr), connection)
            Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
            Dim ds As New DataSet()
            Try
                connection.ConnectionString = Globals.sConnectionString
                connection.Open()
                da.Fill(ds, "docs")
                Dim myRow As DataRow
                myRow = ds.Tables(0).Rows(0)
                Dim MyData() As Byte
                If Right(sdokumentname, 8) = "HOST.lyt" Then
                    MyData = myRow.Item(2)
                Else
                    MyData = myRow.Item(1)
                End If

                Dim K As Long
                K = UBound(MyData)
                Dim fs As New FileStream(sdokumentname, FileMode.OpenOrCreate, FileAccess.Write)
                fs.Write(MyData, 0, K)
                fs.Close()
                fs = Nothing
            Catch ex As Exception
                Return False
            End Try
            CB = Nothing
            ds = Nothing
            da = Nothing
            connection.Close()
            connection = Nothing
            Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp.Save_To_DB Method

Public Function Save_To_DB( _
   ByVal sDokumentID As String, _
   ByVal sDokumentName As String, _
   ByVal DokumentSpaltenname As String, _
   ByVal RowIndex As Integer _
) As Boolean

Parameters

sDokumentID
Required.
sDokumentName
Required.
DokumentSpaltenname
Required.
RowIndex
Required.

Source code

[Visual Basic]
        Public Function Save_To_DB(ByVal sDokumentID As String, ByVal sDokumentName As String, ByVal DokumentSpaltenname As String, ByVal RowIndex As Integer) As Boolean
            '===============================================================================
            'Beschr:    Einlesen eines Reportfile in die Datenbank
            'Input :    Dataset
            '           DokumentNr = Identifikation des Dokument
            '           Dokumentname(inkl.Pfad)
            '           DokumentSpaltenname = Spaltenname für das Dokunent
            '           RowIndex = aktuelle Datasetreihe
            'Output:    True/False
            'Erstellt  : koe 20.10.2003
            'Geaendert :
            '===============================================================================
            Try
                Me.DokumentID = sDokumentID
                Me.Dokumentname = sDokumentName

                Dim Connection As New SqlConnection()
                Dim DA As New SqlDataAdapter("select * from report where reportNr= " + sDokumentID, Connection)
                Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
                Dim ds As New DataSet()
                Dim fs As New FileStream(sDokumentName, FileMode.OpenOrCreate, FileAccess.Read)
                Dim mydata(fs.Length) As Byte

                Try
                    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Dokument von Filesystem lesen")
                    fs.Read(mydata, 0, fs.Length)
                    fs.Close()
                    Connection.ConnectionString = Globals.sConnectionString
                    Connection.Open()
                    DA.Fill(ds, "docs")
                    Dim myRow As DataRow
                    If ds.Tables(0).Rows.Count = 0 Then
                        ' Neues Dokument speichern
                        myRow = ds.Tables(0).NewRow
                        myRow.Item(0) = Me.DokumentID
                        myRow.Item(1) = mydata
                        ds.Tables(0).Rows.Add(myRow)
                        DA.Update(ds, "docs")
                        Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Neues Dokument gespeichert")
                    Else
                        'Bestehendes Dokument sichenr
                        myRow = ds.Tables("docs").Rows(0)
                        myRow.Item("reportfile") = mydata
                        DA.Update(ds, "docs")
                        Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Bestehendes Dokument ersetzt")
                    End If
                Catch ex As Exception
                    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Fehler bei der Dokumentspeicherung")
                    MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
                    '            MsgBox(ex.Message)
                    Return False
                End Try
                fs = Nothing
                cb = Nothing
                ds = Nothing
                DA = Nothing

                Connection.Close()
                Connection = Nothing
                Return True
            Catch
                Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Fehler bei der Dokumentspeicherung")
                MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
                Return False
            End Try

            '---------------------------------------------------------------------------------------
            'Me.DokumentID = sDokumentID
            'Me.Dokumentname = sDokumentName
            'Dim fs As New FileStream(Me.Dokumentname, FileMode.OpenOrCreate, FileAccess.Read)
            'Dim mydata(fs.Length) As Byte
            'Try
            '    '============ Dokument von Filesystem lesen
            '    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Report von Filesystem lesen")
            '    fs.Read(mydata, 0, fs.Length)
            '    fs.Close()
            '    Dim myRow As DataRow

            '    '============ Dokument speichern
            '    ds.Tables(0).Rows(RowIndex).Item(DokumentSpaltenname) = mydata
            '    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Neuer Report gespeichert")
            'Catch ex As Exception
            '    Globals.PerfMon.insert_entry(Me.DokumentID + " ---- Fehler bei der Reportspeicherung")
            '    MyMsg.show_standardmessage(86, MsgBoxStyle.Critical)
            '    Return False
            'End Try
            'fs = Nothing
            ''ds = Nothing
            'Return True
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsReporting_Dokumenttyp Fields

clsReporting_Dokumenttyp overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUsed
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_dokumentid
field m_dokumentname
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iType
field m_sDEFBMB
field m_sDEFBME
field m_sDEFDESC
field m_sDEFFELD
field m_sDEFVALUE
field m_sID
field m_sOFBM
field m_sOFFeld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReporting_Dokumenttyp Class


m_bUsed Variable

Private m_bUsed As SqlBoolean

Source code

[Visual Basic]
        Private m_bUsed As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_dokumentid Variable

Private m_dokumentid As String

Source code

[Visual Basic]
        Private m_dokumentid As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_dokumentname Variable

Private m_dokumentname As String

Source code

[Visual Basic]
        Private m_dokumentname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_iType Variable

Private m_iType As SqlInt32

Source code

[Visual Basic]
        Private m_iType As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sDEFBMB Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sDEFBME Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sDEFDESC Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sDEFFELD Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sDEFVALUE Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sID Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sOFBM Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


m_sOFFeld Variable

Private m_sDEFFELD, _
   m_sDEFDESC, _
   m_sDEFVALUE, _
   m_sOFBM, _
   m_sID, _
   m_sOFFeld, _
   m_sDEFBME, _
   m_sDEFBMB As SqlString

Source code

[Visual Basic]
        Private m_sDEFFELD, m_sDEFDESC, m_sDEFVALUE, m_sOFBM, m_sID, m_sOFFeld, m_sDEFBME, m_sDEFBMB As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReporting_Dokumenttyp


clsRolle_dokumentart Class

For a list of all members of this type, see clsRolle_dokumentart Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsRolle_dokumentart

Public Class clsRolle_dokumentart
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsRolle_dokumentart Members


clsRolle_dokumentart Members

clsRolle_dokumentart overview

Constructors

constructor clsRolle_dokumentart Constructor

Properties

property bAbschliessen
property bAktiv
property bAnzeigen
property bAusschluss
property bBearbeiten
property bChiffre_gestattet
property bErstellen
property bLoeschen
property bMitarbeiter_gestattet
property bNormal
property bVertraulich_gestattet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolledokumentartnr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAbschliessen
field m_bAktiv
field m_bAnzeigen
field m_bAusschluss
field m_bBearbeiten
field m_bChiffre_gestattet
field m_bErstellen
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bMitarbeiter_gestattet
field m_bNormal
field m_bVertraulich_gestattet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolledokumentartnr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumentart Class


clsRolle_dokumentart Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart Properties

clsRolle_dokumentart overview

Properties

property bAbschliessen
property bAktiv
property bAnzeigen
property bAusschluss
property bBearbeiten
property bChiffre_gestattet
property bErstellen
property bLoeschen
property bMitarbeiter_gestattet
property bNormal
property bVertraulich_gestattet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentartnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolledokumentartnr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumentart Class


clsRolle_dokumentart.bAbschliessen Property

Public Property [bAbschliessen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAbschliessen]() As SqlBoolean
            Get
                Return m_bAbschliessen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAbschliessen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bAnzeigen Property

Public Property [bAnzeigen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAnzeigen]() As SqlBoolean
            Get
                Return m_bAnzeigen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAnzeigen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bAusschluss Property

Public Property [bAusschluss]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusschluss]() As SqlBoolean
            Get
                Return m_bAusschluss
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusschluss = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bBearbeiten Property

Public Property [bBearbeiten]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBearbeiten]() As SqlBoolean
            Get
                Return m_bBearbeiten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBearbeiten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bChiffre_gestattet Property

Public Property [bChiffre_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bChiffre_gestattet]() As SqlBoolean
            Get
                Return m_bChiffre_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bChiffre_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bErstellen Property

Public Property [bErstellen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bErstellen]() As SqlBoolean
            Get
                Return m_bErstellen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bErstellen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bLoeschen Property

Public Property [bLoeschen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bLoeschen]() As SqlBoolean
            Get
                Return m_bLoeschen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bLoeschen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bMitarbeiter_gestattet Property

Public Property [bMitarbeiter_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bMitarbeiter_gestattet]() As SqlBoolean
            Get
                Return m_bMitarbeiter_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bMitarbeiter_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bNormal Property

Public Property [bNormal]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bNormal]() As SqlBoolean
            Get
                Return m_bNormal
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bNormal = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.bVertraulich_gestattet Property

Public Property [bVertraulich_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertraulich_gestattet]() As SqlBoolean
            Get
                Return m_bVertraulich_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertraulich_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.iDokumentartnr Property

Public Property [iDokumentartnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentartnr]() As SqlInt32
            Get
                Return m_iDokumentartnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentartnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.iRolledokumentartnr Property

Public Property [iRolledokumentartnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRolledokumentartnr]() As SqlInt32
            Get
                Return m_iRolledokumentartnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolledokumentartnrTmp As SqlInt32 = Value
                If iRolledokumentartnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolledokumentartnr", "iRolledokumentartnr can't be NULL")
                End If
                m_iRolledokumentartnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart Methods

clsRolle_dokumentart overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsRolle_dokumentart Class


clsRolle_dokumentart.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumentart_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolledokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolledokumentartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumentart_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumentart::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumentart_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolledokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolledokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausschluss", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnormal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNormal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bmitarbeiter_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMitarbeiter_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bchiffre_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bChiffre_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@banzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbearbeiten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBearbeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bloeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babschliessen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbschliessen))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumentart_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumentart::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumentart_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_dokumentart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumentart_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumentart::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumentart_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_dokumentart")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolledokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolledokumentartnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumentart_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolledokumentartnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolledokumentartnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentartnr") Is System.DBNull.Value Then
                        m_iDokumentartnr = SqlInt32.Null
                    Else
                        m_iDokumentartnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentartnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ausschluss") Is System.DBNull.Value Then
                        m_bAusschluss = SqlBoolean.Null
                    Else
                        m_bAusschluss = New SqlBoolean(CType(dtToReturn.Rows(0)("ausschluss"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("normal") Is System.DBNull.Value Then
                        m_bNormal = SqlBoolean.Null
                    Else
                        m_bNormal = New SqlBoolean(CType(dtToReturn.Rows(0)("normal"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("vertraulich_gestattet") Is System.DBNull.Value Then
                        m_bVertraulich_gestattet = SqlBoolean.Null
                    Else
                        m_bVertraulich_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiter_gestattet") Is System.DBNull.Value Then
                        m_bMitarbeiter_gestattet = SqlBoolean.Null
                    Else
                        m_bMitarbeiter_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("mitarbeiter_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("chiffre_gestattet") Is System.DBNull.Value Then
                        m_bChiffre_gestattet = SqlBoolean.Null
                    Else
                        m_bChiffre_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("chiffre_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("anzeigen") Is System.DBNull.Value Then
                        m_bAnzeigen = SqlBoolean.Null
                    Else
                        m_bAnzeigen = New SqlBoolean(CType(dtToReturn.Rows(0)("anzeigen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellen") Is System.DBNull.Value Then
                        m_bErstellen = SqlBoolean.Null
                    Else
                        m_bErstellen = New SqlBoolean(CType(dtToReturn.Rows(0)("erstellen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bearbeiten") Is System.DBNull.Value Then
                        m_bBearbeiten = SqlBoolean.Null
                    Else
                        m_bBearbeiten = New SqlBoolean(CType(dtToReturn.Rows(0)("bearbeiten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("loeschen") Is System.DBNull.Value Then
                        m_bLoeschen = SqlBoolean.Null
                    Else
                        m_bLoeschen = New SqlBoolean(CType(dtToReturn.Rows(0)("loeschen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("abschliessen") Is System.DBNull.Value Then
                        m_bAbschliessen = SqlBoolean.Null
                    Else
                        m_bAbschliessen = New SqlBoolean(CType(dtToReturn.Rows(0)("abschliessen"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumentart::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumentart_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolledokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolledokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentartnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentartnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausschluss", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnormal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNormal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bmitarbeiter_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMitarbeiter_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bchiffre_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bChiffre_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@banzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbearbeiten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBearbeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bloeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babschliessen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbschliessen))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumentart_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumentart::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumentart Fields

clsRolle_dokumentart overview

Fields

field m_bAbschliessen
field m_bAktiv
field m_bAnzeigen
field m_bAusschluss
field m_bBearbeiten
field m_bChiffre_gestattet
field m_bErstellen
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bMitarbeiter_gestattet
field m_bNormal
field m_bVertraulich_gestattet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentartnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolledokumentartnr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumentart Class


m_bAbschliessen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bAktiv Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bAnzeigen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bAusschluss Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bBearbeiten Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bChiffre_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bErstellen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bLoeschen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bMitarbeiter_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bNormal Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_bVertraulich_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bAusschluss, _
   m_bNormal, _
   m_bMitarbeiter_gestattet, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bAusschluss, m_bNormal, m_bMitarbeiter_gestattet, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_iDokumentartnr Variable

Private 		m_iRolledokumentartnr, _
   m_iRollenr, _
   m_iDokumentartnr, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRolledokumentartnr, m_iRollenr, m_iDokumentartnr, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_iMandantnr Variable

Private 		m_iRolledokumentartnr, _
   m_iRollenr, _
   m_iDokumentartnr, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRolledokumentartnr, m_iRollenr, m_iDokumentartnr, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_iMutierer Variable

Private 		m_iRolledokumentartnr, _
   m_iRollenr, _
   m_iDokumentartnr, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRolledokumentartnr, m_iRollenr, m_iDokumentartnr, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_iRolledokumentartnr Variable

Private 		m_iRolledokumentartnr, _
   m_iRollenr, _
   m_iDokumentartnr, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRolledokumentartnr, m_iRollenr, m_iDokumentartnr, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


m_iRollenr Variable

Private 		m_iRolledokumentartnr, _
   m_iRollenr, _
   m_iDokumentartnr, _
   m_iMandantnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRolledokumentartnr, m_iRollenr, m_iDokumentartnr, m_iMandantnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumentart


clsRolle_dokumenttyp Class

For a list of all members of this type, see clsRolle_dokumenttyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsRolle_dokumenttyp

Public Class clsRolle_dokumenttyp
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsRolle_dokumenttyp Members


clsRolle_dokumenttyp Members

clsRolle_dokumenttyp overview

Constructors

constructor clsRolle_dokumenttyp Constructor

Properties

property bAbschliessen
property bAktiv
property bAnzeigen
property bAusschluss
property bBearbeiten
property bChiffre_gestattet
property bErstellen
property bLoeschen
property bMitarbeiter_gestattet
property bNormal
property bVertraulich_gestattet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBerechtigungnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolle_dokumenttyp_nr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAbschliessen
field m_bAktiv
field m_bAnzeigen
field m_bAusschluss
field m_bBearbeiten
field m_bChiffre_gestattet
field m_bErstellen
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bMitarbeiter_gestattet
field m_bNormal
field m_bVertraulich_gestattet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBerechtigungnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolle_dokumenttyp_nr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumenttyp Class


clsRolle_dokumenttyp Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp Properties

clsRolle_dokumenttyp overview

Properties

property bAbschliessen
property bAktiv
property bAnzeigen
property bAusschluss
property bBearbeiten
property bChiffre_gestattet
property bErstellen
property bLoeschen
property bMitarbeiter_gestattet
property bNormal
property bVertraulich_gestattet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBerechtigungnr
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolle_dokumenttyp_nr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumenttyp Class


clsRolle_dokumenttyp.bAbschliessen Property

Public Property [bAbschliessen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAbschliessen]() As SqlBoolean
            Get
                Return m_bAbschliessen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAbschliessen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bAnzeigen Property

Public Property [bAnzeigen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAnzeigen]() As SqlBoolean
            Get
                Return m_bAnzeigen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAnzeigen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bAusschluss Property

Public Property [bAusschluss]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusschluss]() As SqlBoolean
            Get
                Return m_bAusschluss
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusschluss = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bBearbeiten Property

Public Property [bBearbeiten]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBearbeiten]() As SqlBoolean
            Get
                Return m_bBearbeiten
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBearbeiten = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bChiffre_gestattet Property

Public Property [bChiffre_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bChiffre_gestattet]() As SqlBoolean
            Get
                Return m_bChiffre_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bChiffre_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bErstellen Property

Public Property [bErstellen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bErstellen]() As SqlBoolean
            Get
                Return m_bErstellen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bErstellen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bLoeschen Property

Public Property [bLoeschen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bLoeschen]() As SqlBoolean
            Get
                Return m_bLoeschen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bLoeschen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bMitarbeiter_gestattet Property

Public Property [bMitarbeiter_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bMitarbeiter_gestattet]() As SqlBoolean
            Get
                Return m_bMitarbeiter_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bMitarbeiter_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bNormal Property

Public Property [bNormal]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bNormal]() As SqlBoolean
            Get
                Return m_bNormal
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bNormal = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.bVertraulich_gestattet Property

Public Property [bVertraulich_gestattet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertraulich_gestattet]() As SqlBoolean
            Get
                Return m_bVertraulich_gestattet
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertraulich_gestattet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iBerechtigungnr Property

Public Property [iBerechtigungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBerechtigungnr]() As SqlInt32
            Get
                Return m_iBerechtigungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBerechtigungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iRolle_dokumenttyp_nr Property

Public Property [iRolle_dokumenttyp_nr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRolle_dokumenttyp_nr]() As SqlInt32
            Get
                Return m_iRolle_dokumenttyp_nr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_dokumenttyp_nrTmp As SqlInt32 = Value
                If iRolle_dokumenttyp_nrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_dokumenttyp_nr", "iRolle_dokumenttyp_nr can't be NULL")
                End If
                m_iRolle_dokumenttyp_nr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp Methods

clsRolle_dokumenttyp overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsRolle_dokumenttyp Class


clsRolle_dokumenttyp.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumenttyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_dokumenttyp_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_dokumenttyp_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumenttyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumenttyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_dokumenttyp_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_dokumenttyp_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausschluss", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnormal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNormal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bmitarbeiter_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMitarbeiter_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bchiffre_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bChiffre_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@banzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbearbeiten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBearbeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bloeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babschliessen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbschliessen))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumenttyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumenttyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumenttyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumenttyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_dokumenttyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_dokumenttyp_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_dokumenttyp_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_dokumenttyp_nr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_dokumenttyp_nr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("berechtigungnr") Is System.DBNull.Value Then
                        m_iBerechtigungnr = SqlInt32.Null
                    Else
                        m_iBerechtigungnr = New SqlInt32(CType(dtToReturn.Rows(0)("berechtigungnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ausschluss") Is System.DBNull.Value Then
                        m_bAusschluss = SqlBoolean.Null
                    Else
                        m_bAusschluss = New SqlBoolean(CType(dtToReturn.Rows(0)("ausschluss"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("normal") Is System.DBNull.Value Then
                        m_bNormal = SqlBoolean.Null
                    Else
                        m_bNormal = New SqlBoolean(CType(dtToReturn.Rows(0)("normal"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("vertraulich_gestattet") Is System.DBNull.Value Then
                        m_bVertraulich_gestattet = SqlBoolean.Null
                    Else
                        m_bVertraulich_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiter_gestattet") Is System.DBNull.Value Then
                        m_bMitarbeiter_gestattet = SqlBoolean.Null
                    Else
                        m_bMitarbeiter_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("mitarbeiter_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("chiffre_gestattet") Is System.DBNull.Value Then
                        m_bChiffre_gestattet = SqlBoolean.Null
                    Else
                        m_bChiffre_gestattet = New SqlBoolean(CType(dtToReturn.Rows(0)("chiffre_gestattet"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("anzeigen") Is System.DBNull.Value Then
                        m_bAnzeigen = SqlBoolean.Null
                    Else
                        m_bAnzeigen = New SqlBoolean(CType(dtToReturn.Rows(0)("anzeigen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellen") Is System.DBNull.Value Then
                        m_bErstellen = SqlBoolean.Null
                    Else
                        m_bErstellen = New SqlBoolean(CType(dtToReturn.Rows(0)("erstellen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bearbeiten") Is System.DBNull.Value Then
                        m_bBearbeiten = SqlBoolean.Null
                    Else
                        m_bBearbeiten = New SqlBoolean(CType(dtToReturn.Rows(0)("bearbeiten"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("loeschen") Is System.DBNull.Value Then
                        m_bLoeschen = SqlBoolean.Null
                    Else
                        m_bLoeschen = New SqlBoolean(CType(dtToReturn.Rows(0)("loeschen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("abschliessen") Is System.DBNull.Value Then
                        m_bAbschliessen = SqlBoolean.Null
                    Else
                        m_bAbschliessen = New SqlBoolean(CType(dtToReturn.Rows(0)("abschliessen"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumenttyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_dokumenttyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_dokumenttyp_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_dokumenttyp_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausschluss", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusschluss))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bnormal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNormal))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bmitarbeiter_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMitarbeiter_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bchiffre_gestattet", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bChiffre_gestattet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@banzeigen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@berstellen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bErstellen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbearbeiten", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBearbeiten))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bloeschen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bLoeschen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@babschliessen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbschliessen))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_dokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_dokumenttyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_dokumenttyp Fields

clsRolle_dokumenttyp overview

Fields

field m_bAbschliessen
field m_bAktiv
field m_bAnzeigen
field m_bAusschluss
field m_bBearbeiten
field m_bChiffre_gestattet
field m_bErstellen
field m_bLoeschen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bMitarbeiter_gestattet
field m_bNormal
field m_bVertraulich_gestattet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBerechtigungnr
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolle_dokumenttyp_nr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_dokumenttyp Class


m_bAbschliessen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bAktiv Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bAnzeigen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bAusschluss Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bBearbeiten Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bChiffre_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bErstellen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bLoeschen Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bMitarbeiter_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bNormal Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_bVertraulich_gestattet Variable

Private 		m_bAnzeigen, _
   m_bAktiv, _
   m_bChiffre_gestattet, _
   m_bErstellen, _
   m_bAbschliessen, _
   m_bLoeschen, _
   m_bBearbeiten, _
   m_bMitarbeiter_gestattet, _
   m_bAusschluss, _
   m_bNormal, _
   m_bVertraulich_gestattet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAnzeigen, m_bAktiv, m_bChiffre_gestattet, m_bErstellen, m_bAbschliessen, m_bLoeschen, m_bBearbeiten, m_bMitarbeiter_gestattet, m_bAusschluss, m_bNormal, m_bVertraulich_gestattet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iBerechtigungnr Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iDokumenttypnr Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iMandantnr Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iMutierer Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iRolle_dokumenttyp_nr Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


m_iRollenr Variable

Private 		m_iDokumenttypnr, _
   m_iRolle_dokumenttyp_nr, _
   m_iRollenr, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iBerechtigungnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iDokumenttypnr, m_iRolle_dokumenttyp_nr, m_iRollenr, m_iMandantnr, m_iMutierer, m_iBerechtigungnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_dokumenttyp


clsRolle_report_gruppe Class

For a list of all members of this type, see clsRolle_report_gruppe Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsRolle_report_gruppe

Public Class clsRolle_report_gruppe
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsRolle_report_gruppe Members


clsRolle_report_gruppe Members

clsRolle_report_gruppe overview

Constructors

constructor clsRolle_report_gruppe Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReport_gruppenr
property iRolle_report_gruppe_nr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReport_gruppenr
field m_iRolle_report_gruppe_nr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_report_gruppe Class


clsRolle_report_gruppe Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe Properties

clsRolle_report_gruppe overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReport_gruppenr
property iRolle_report_gruppe_nr
property iRollenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_report_gruppe Class


clsRolle_report_gruppe.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.iReport_gruppenr Property

Public Property [iReport_gruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReport_gruppenr]() As SqlInt32
            Get
                Return m_iReport_gruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReport_gruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.iRolle_report_gruppe_nr Property

Public Property [iRolle_report_gruppe_nr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRolle_report_gruppe_nr]() As SqlInt32
            Get
                Return m_iRolle_report_gruppe_nr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_report_gruppe_nrTmp As SqlInt32 = Value
                If iRolle_report_gruppe_nrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_report_gruppe_nr", "iRolle_report_gruppe_nr can't be NULL")
                End If
                m_iRolle_report_gruppe_nr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe Methods

clsRolle_report_gruppe overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsRolle_report_gruppe Class


clsRolle_report_gruppe.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_report_gruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_report_gruppe_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_report_gruppe_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_report_gruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_report_gruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_report_gruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_report_gruppe_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_report_gruppe_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_report_gruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_report_gruppe::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_report_gruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_report_gruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_report_gruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_report_gruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_report_gruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_report_gruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_report_gruppe_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_report_gruppe_nr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_report_gruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_report_gruppe_nr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_report_gruppe_nr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("report_gruppenr") Is System.DBNull.Value Then
                        m_iReport_gruppenr = SqlInt32.Null
                    Else
                        m_iReport_gruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("report_gruppenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_report_gruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_report_gruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_report_gruppe_nr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_report_gruppe_nr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_report_gruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_report_gruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_report_gruppe Fields

clsRolle_report_gruppe overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReport_gruppenr
field m_iRolle_report_gruppe_nr
field m_iRollenr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_report_gruppe Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iRollenr, _
   m_iRolle_report_gruppe_nr, _
   m_iMandantnr, _
   m_iReport_gruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iRolle_report_gruppe_nr, m_iMandantnr, m_iReport_gruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iRollenr, _
   m_iRolle_report_gruppe_nr, _
   m_iMandantnr, _
   m_iReport_gruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iRolle_report_gruppe_nr, m_iMandantnr, m_iReport_gruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_iReport_gruppenr Variable

Private 		m_iMutierer, _
   m_iRollenr, _
   m_iRolle_report_gruppe_nr, _
   m_iMandantnr, _
   m_iReport_gruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iRolle_report_gruppe_nr, m_iMandantnr, m_iReport_gruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_iRolle_report_gruppe_nr Variable

Private 		m_iMutierer, _
   m_iRollenr, _
   m_iRolle_report_gruppe_nr, _
   m_iMandantnr, _
   m_iReport_gruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iRolle_report_gruppe_nr, m_iMandantnr, m_iReport_gruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


m_iRollenr Variable

Private 		m_iMutierer, _
   m_iRollenr, _
   m_iRolle_report_gruppe_nr, _
   m_iMandantnr, _
   m_iReport_gruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iRollenr, m_iRolle_report_gruppe_nr, m_iMandantnr, m_iReport_gruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_report_gruppe


clsRolle_sysadminfunktion Class

For a list of all members of this type, see clsRolle_sysadminfunktion Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsRolle_sysadminfunktion

Public Class clsRolle_sysadminfunktion
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsRolle_sysadminfunktion Members


clsRolle_sysadminfunktion Members

clsRolle_sysadminfunktion overview

Constructors

constructor clsRolle_sysadminfunktion Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandant
property iMutierer
property iRolle_sysadminfnktnr
property iRollenr
property iRollenrOld
property iSysadminfnktnr
property iSysadminfnktnrOld
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWrollenrLogic
method SelectAllWsysadminfnktnrLogic
method SelectOne
method Update
method UpdateAllWrollenrLogic
method UpdateAllWsysadminfnktnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandant
field m_iMutierer
field m_iRolle_sysadminfnktnr
field m_iRollenr
field m_iRollenrOld
field m_iSysadminfnktnr
field m_iSysadminfnktnrOld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion Properties

clsRolle_sysadminfunktion overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandant
property iMutierer
property iRolle_sysadminfnktnr
property iRollenr
property iRollenrOld
property iSysadminfnktnr
property iSysadminfnktnrOld
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iMandant Property

Public Property [iMandant]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandant]() As SqlInt32
            Get
                Return m_iMandant
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandant = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iRolle_sysadminfnktnr Property

Public Property [iRolle_sysadminfnktnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRolle_sysadminfnktnr]() As SqlInt32
            Get
                Return m_iRolle_sysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolle_sysadminfnktnrTmp As SqlInt32 = Value
                If iRolle_sysadminfnktnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolle_sysadminfnktnr", "iRolle_sysadminfnktnr can't be NULL")
                End If
                m_iRolle_sysadminfnktnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iRollenrOld Property

Public Property [iRollenrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenrOld]() As SqlInt32
            Get
                Return m_iRollenrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iSysadminfnktnr Property

Public Property [iSysadminfnktnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSysadminfnktnr]() As SqlInt32
            Get
                Return m_iSysadminfnktnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSysadminfnktnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.iSysadminfnktnrOld Property

Public Property [iSysadminfnktnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSysadminfnktnrOld]() As SqlInt32
            Get
                Return m_iSysadminfnktnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSysadminfnktnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion Methods

clsRolle_sysadminfunktion overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWrollenrLogic
method SelectAllWsysadminfnktnrLogic
method SelectOne
method Update
method UpdateAllWrollenrLogic
method UpdateAllWsysadminfnktnrLogic

See Also

clsRolle_sysadminfunktion Class


clsRolle_sysadminfunktion.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectAllWrollenrLogic Method

Public Function SelectAllWrollenrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWrollenrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectAllWsysadminfnktnrLogic Method

Public Function SelectAllWsysadminfnktnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWsysadminfnktnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectAllWsysadminfnktnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectAllWsysadminfnktnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectAllWsysadminfnktnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolle_sysadminfunktion")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolle_sysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolle_sysadminfnktnr"), Integer))
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sysadminfnktnr") Is System.DBNull.Value Then
                        m_iSysadminfnktnr = SqlInt32.Null
                    Else
                        m_iSysadminfnktnr = New SqlInt32(CType(dtToReturn.Rows(0)("sysadminfnktnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandant") Is System.DBNull.Value Then
                        m_iMandant = SqlInt32.Null
                    Else
                        m_iMandant = New SqlInt32(CType(dtToReturn.Rows(0)("mandant"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolle_sysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolle_sysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandant", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandant))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.UpdateAllWrollenrLogic Method

Public Function UpdateAllWrollenrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWrollenrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_UpdateAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_UpdateAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::UpdateAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion.UpdateAllWsysadminfnktnrLogic Method

Public Function UpdateAllWsysadminfnktnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWsysadminfnktnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolle_sysadminfunktion_UpdateAllWsysadminfnktnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isysadminfnktnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSysadminfnktnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolle_sysadminfunktion_UpdateAllWsysadminfnktnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolle_sysadminfunktion::UpdateAllWsysadminfnktnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolle_sysadminfunktion Fields

clsRolle_sysadminfunktion overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandant
field m_iMutierer
field m_iRolle_sysadminfnktnr
field m_iRollenr
field m_iRollenrOld
field m_iSysadminfnktnr
field m_iSysadminfnktnrOld
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolle_sysadminfunktion Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iMandant Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iMutierer Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iRolle_sysadminfnktnr Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iRollenr Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iRollenrOld Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iSysadminfnktnr Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


m_iSysadminfnktnrOld Variable

Private 		m_iRollenr, _
   m_iRollenrOld, _
   m_iMandant, _
   m_iSysadminfnktnr, _
   m_iSysadminfnktnrOld, _
   m_iRolle_sysadminfnktnr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iRollenr, m_iRollenrOld, m_iMandant, m_iSysadminfnktnr, m_iSysadminfnktnrOld, m_iRolle_sysadminfnktnr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolle_sysadminfunktion


clsRolleberechtigung Class

For a list of all members of this type, see clsRolleberechtigung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsRolleberechtigung

Public Class clsRolleberechtigung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsRolleberechtigung Members


clsRolleberechtigung Members

clsRolleberechtigung overview

Constructors

constructor clsRolleberechtigung Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBerechtigungnr
property iBerechtigungnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolleberechtigungnr
property iRollenr
property iRollenrOld
property sBeschreibung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWberechtigungnrLogic
method SelectAllWrollenrLogic
method SelectOne
method Update
method UpdateAllWberechtigungnrLogic
method UpdateAllWrollenrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBerechtigungnr
field m_iBerechtigungnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolleberechtigungnr
field m_iRollenr
field m_iRollenrOld
field m_sBeschreibung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolleberechtigung Class


clsRolleberechtigung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung Properties

clsRolleberechtigung overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBerechtigungnr
property iBerechtigungnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iRolleberechtigungnr
property iRollenr
property iRollenrOld
property sBeschreibung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolleberechtigung Class


clsRolleberechtigung.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iBerechtigungnr Property

Public Property [iBerechtigungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBerechtigungnr]() As SqlInt32
            Get
                Return m_iBerechtigungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBerechtigungnrTmp As SqlInt32 = Value
                If iBerechtigungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBerechtigungnr", "iBerechtigungnr can't be NULL")
                End If
                m_iBerechtigungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iBerechtigungnrOld Property

Public Property [iBerechtigungnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBerechtigungnrOld]() As SqlInt32
            Get
                Return m_iBerechtigungnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iBerechtigungnrOldTmp As SqlInt32 = Value
                If iBerechtigungnrOldTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iBerechtigungnrOld", "iBerechtigungnrOld can't be NULL")
                End If
                m_iBerechtigungnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iRolleberechtigungnr Property

Public Property [iRolleberechtigungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRolleberechtigungnr]() As SqlInt32
            Get
                Return m_iRolleberechtigungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iRolleberechtigungnrTmp As SqlInt32 = Value
                If iRolleberechtigungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iRolleberechtigungnr", "iRolleberechtigungnr can't be NULL")
                End If
                m_iRolleberechtigungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iRollenr Property

Public Property [iRollenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenr]() As SqlInt32
            Get
                Return m_iRollenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.iRollenrOld Property

Public Property [iRollenrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iRollenrOld]() As SqlInt32
            Get
                Return m_iRollenrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iRollenrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung Methods

clsRolleberechtigung overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWberechtigungnrLogic
method SelectAllWrollenrLogic
method SelectOne
method Update
method UpdateAllWberechtigungnrLogic
method UpdateAllWrollenrLogic

See Also

clsRolleberechtigung Class


clsRolleberechtigung.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolleberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolleberechtigungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolleberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolleberechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolleberechtigung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.SelectAllWberechtigungnrLogic Method

Public Function SelectAllWberechtigungnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWberechtigungnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_SelectAllWberechtigungnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolleberechtigung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_SelectAllWberechtigungnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::SelectAllWberechtigungnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.SelectAllWrollenrLogic Method

Public Function SelectAllWrollenrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWrollenrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_SelectAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolleberechtigung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_SelectAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::SelectAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("rolleberechtigung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irolleberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolleberechtigungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iRolleberechtigungnr = New SqlInt32(CType(dtToReturn.Rows(0)("rolleberechtigungnr"), Integer))
                    m_iBerechtigungnr = New SqlInt32(CType(dtToReturn.Rows(0)("berechtigungnr"), Integer))
                    If dtToReturn.Rows(0)("rollenr") Is System.DBNull.Value Then
                        m_iRollenr = SqlInt32.Null
                    Else
                        m_iRollenr = New SqlInt32(CType(dtToReturn.Rows(0)("rollenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irolleberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iRolleberechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.UpdateAllWberechtigungnrLogic Method

Public Function UpdateAllWberechtigungnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWberechtigungnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_UpdateAllWberechtigungnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iberechtigungnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iberechtigungnrOld", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBerechtigungnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_UpdateAllWberechtigungnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::UpdateAllWberechtigungnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung.UpdateAllWrollenrLogic Method

Public Function UpdateAllWrollenrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWrollenrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_rolleberechtigung_UpdateAllWrollenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iRollenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@irollenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRollenrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_rolleberechtigung_UpdateAllWrollenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsRolleberechtigung::UpdateAllWrollenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsRolleberechtigung Fields

clsRolleberechtigung overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBerechtigungnr
field m_iBerechtigungnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iRolleberechtigungnr
field m_iRollenr
field m_iRollenrOld
field m_sBeschreibung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsRolleberechtigung Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iBerechtigungnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iBerechtigungnrOld Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iRolleberechtigungnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iRollenr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_iRollenrOld Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iBerechtigungnr, _
   m_iBerechtigungnrOld, _
   m_iRolleberechtigungnr, _
   m_iRollenr, _
   m_iRollenrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iBerechtigungnr, m_iBerechtigungnrOld, m_iRolleberechtigungnr, m_iRollenr, m_iRollenrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


m_sBeschreibung Variable

Private 		m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsRolleberechtigung


clsServices Class

For a list of all members of this type, see clsServices Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsServices

Public Class clsServices
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsServices Members


clsServices Members

clsServices overview

Constructors

constructor clsServices Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNreintrag
property sBeschreigung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sInhalt
property sRequestName
property sResultObject
property sResultsetContent
property sURL

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNreintrag
field m_sBeschreigung
field m_sInhalt
field m_sRequestName
field m_sResultObject
field m_sResultsetContent
field m_sURL
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsServices Class


clsServices Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices Properties

clsServices overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNreintrag
property sBeschreigung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sInhalt
property sRequestName
property sResultObject
property sResultsetContent
property sURL

See Also

clsServices Class


clsServices.iNreintrag Property

Public Property [iNreintrag]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNreintrag]() As SqlInt32
            Get
                Return m_iNreintrag
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNreintragTmp As SqlInt32 = Value
                If iNreintragTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNreintrag", "iNreintrag can't be NULL")
                End If
                m_iNreintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sBeschreigung Property

Public Property [sBeschreigung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreigung]() As SqlString
            Get
                Return m_sBeschreigung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreigung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sInhalt Property

Public Property [sInhalt]() As SqlString

Source code

[Visual Basic]
        Public Property [sInhalt]() As SqlString
            Get
                Return m_sInhalt
            End Get
            Set(ByVal Value As SqlString)
                m_sInhalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sRequestName Property

Public Property [sRequestName]() As SqlString

Source code

[Visual Basic]
        Public Property [sRequestName]() As SqlString
            Get
                Return m_sRequestName
            End Get
            Set(ByVal Value As SqlString)
                m_sRequestName = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sResultObject Property

Public Property [sResultObject]() As SqlString

Source code

[Visual Basic]
        Public Property [sResultObject]() As SqlString
            Get
                Return m_sResultObject
            End Get
            Set(ByVal Value As SqlString)
                m_sResultObject = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sResultsetContent Property

Public Property [sResultsetContent]() As SqlString

Source code

[Visual Basic]
        Public Property [sResultsetContent]() As SqlString
            Get
                Return m_sResultsetContent
            End Get
            Set(ByVal Value As SqlString)
                m_sResultsetContent = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.sURL Property

Public Property [sURL]() As SqlString

Source code

[Visual Basic]
        Public Property [sURL]() As SqlString
            Get
                Return m_sURL
            End Get
            Set(ByVal Value As SqlString)
                m_sURL = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices Methods

clsServices overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsServices Class


clsServices.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Services_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Services_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServices::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Services_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreigung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sURL", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sURL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sRequestName", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRequestName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sResultsetContent", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sResultsetContent))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sResultObject", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sResultObject))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Services_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServices::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Services_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Services")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Services_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServices::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Services_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Services")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Services_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNreintrag = New SqlInt32(CType(dtToReturn.Rows(0)("nreintrag"), Integer))
                    If dtToReturn.Rows(0)("beschreigung") Is System.DBNull.Value Then
                        m_sBeschreigung = SqlString.Null
                    Else
                        m_sBeschreigung = New SqlString(CType(dtToReturn.Rows(0)("beschreigung"), String))
                    End If
                    If dtToReturn.Rows(0)("inhalt") Is System.DBNull.Value Then
                        m_sInhalt = SqlString.Null
                    Else
                        m_sInhalt = New SqlString(CType(dtToReturn.Rows(0)("inhalt"), String))
                    End If
                    If dtToReturn.Rows(0)("URL") Is System.DBNull.Value Then
                        m_sURL = SqlString.Null
                    Else
                        m_sURL = New SqlString(CType(dtToReturn.Rows(0)("URL"), String))
                    End If
                    If dtToReturn.Rows(0)("RequestName") Is System.DBNull.Value Then
                        m_sRequestName = SqlString.Null
                    Else
                        m_sRequestName = New SqlString(CType(dtToReturn.Rows(0)("RequestName"), String))
                    End If
                    If dtToReturn.Rows(0)("ResultsetContent") Is System.DBNull.Value Then
                        m_sResultsetContent = SqlString.Null
                    Else
                        m_sResultsetContent = New SqlString(CType(dtToReturn.Rows(0)("ResultsetContent"), String))
                    End If
                    If dtToReturn.Rows(0)("ResultObject") Is System.DBNull.Value Then
                        m_sResultObject = SqlString.Null
                    Else
                        m_sResultObject = New SqlString(CType(dtToReturn.Rows(0)("ResultObject"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServices::SelectOne::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Services_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreigung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreigung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sURL", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sURL))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sRequestName", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRequestName))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sResultsetContent", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sResultsetContent))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sResultObject", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sResultObject))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Services_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsServices::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsServices Fields

clsServices overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNreintrag
field m_sBeschreigung
field m_sInhalt
field m_sRequestName
field m_sResultObject
field m_sResultsetContent
field m_sURL
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsServices Class


m_iNreintrag Variable

Private 		m_iNreintrag As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNreintrag As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sBeschreigung Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sInhalt Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sRequestName Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sResultObject Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sResultsetContent Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


m_sURL Variable

Private 		m_sRequestName, _
   m_sResultsetContent, _
   m_sResultObject, _
   m_sBeschreigung, _
   m_sInhalt, _
   m_sURL As SqlString

Source code

[Visual Basic]
        Private 		m_sRequestName, m_sResultsetContent, m_sResultObject, m_sBeschreigung, m_sInhalt, m_sURL As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsServices


clsSpalten Class

For a list of all members of this type, see clsSpalten Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsSpalten

Public Class clsSpalten
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsSpalten Members


clsSpalten Members

clsSpalten overview

Constructors

constructor clsSpalten Constructor

Properties

property bAktiv
property bAlsHacken
property bReadonly
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBreite
property iEintragnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSpalte
property sTabelle
property sTabellenspalte
property sTiptext

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAlsHacken
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bReadonly
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBreite
field m_iEintragnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_sSpalte
field m_sTabelle
field m_sTabellenspalte
field m_sTiptext
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSpalten Class


clsSpalten Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten Properties

clsSpalten overview

Properties

property bAktiv
property bAlsHacken
property bReadonly
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iBreite
property iEintragnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sSpalte
property sTabelle
property sTabellenspalte
property sTiptext

See Also

clsSpalten Class


clsSpalten.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.bAlsHacken Property

Public Property [bAlsHacken]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAlsHacken]() As SqlBoolean
            Get
                Return m_bAlsHacken
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAlsHacken = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.bReadonly Property

Public Property [bReadonly]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bReadonly]() As SqlBoolean
            Get
                Return m_bReadonly
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bReadonly = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.iBreite Property

Public Property [iBreite]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBreite]() As SqlInt32
            Get
                Return m_iBreite
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBreite = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.iEintragnr Property

Public Property [iEintragnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iEintragnr]() As SqlInt32
            Get
                Return m_iEintragnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEintragnrTmp As SqlInt32 = Value
                If iEintragnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEintragnr", "iEintragnr can't be NULL")
                End If
                m_iEintragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.sSpalte Property

Public Property [sSpalte]() As SqlString

Source code

[Visual Basic]
        Public Property [sSpalte]() As SqlString
            Get
                Return m_sSpalte
            End Get
            Set(ByVal Value As SqlString)
                m_sSpalte = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.sTabelle Property

Public Property [sTabelle]() As SqlString

Source code

[Visual Basic]
        Public Property [sTabelle]() As SqlString
            Get
                Return m_sTabelle
            End Get
            Set(ByVal Value As SqlString)
                m_sTabelle = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.sTabellenspalte Property

Public Property [sTabellenspalte]() As SqlString

Source code

[Visual Basic]
        Public Property [sTabellenspalte]() As SqlString
            Get
                Return m_sTabellenspalte
            End Get
            Set(ByVal Value As SqlString)
                m_sTabellenspalte = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.sTiptext Property

Public Property [sTiptext]() As SqlString

Source code

[Visual Basic]
        Public Property [sTiptext]() As SqlString
            Get
                Return m_sTiptext
            End Get
            Set(ByVal Value As SqlString)
                m_sTiptext = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten Methods

clsSpalten overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsSpalten Class


clsSpalten.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("spalten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEintragnr = New SqlInt32(CType(dtToReturn.Rows(0)("eintragnr"), Integer))
                    If dtToReturn.Rows(0)("tabelle") Is System.DBNull.Value Then
                        m_sTabelle = SqlString.Null
                    Else
                        m_sTabelle = New SqlString(CType(dtToReturn.Rows(0)("tabelle"), String))
                    End If
                    If dtToReturn.Rows(0)("tabellenspalte") Is System.DBNull.Value Then
                        m_sTabellenspalte = SqlString.Null
                    Else
                        m_sTabellenspalte = New SqlString(CType(dtToReturn.Rows(0)("tabellenspalte"), String))
                    End If
                    If dtToReturn.Rows(0)("spalte") Is System.DBNull.Value Then
                        m_sSpalte = SqlString.Null
                    Else
                        m_sSpalte = New SqlString(CType(dtToReturn.Rows(0)("spalte"), String))
                    End If
                    If dtToReturn.Rows(0)("Readonly") Is System.DBNull.Value Then
                        m_bReadonly = SqlBoolean.Null
                    Else
                        m_bReadonly = New SqlBoolean(CType(dtToReturn.Rows(0)("Readonly"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("alsHacken") Is System.DBNull.Value Then
                        m_bAlsHacken = SqlBoolean.Null
                    Else
                        m_bAlsHacken = New SqlBoolean(CType(dtToReturn.Rows(0)("alsHacken"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("Breite") Is System.DBNull.Value Then
                        m_iBreite = SqlInt32.Null
                    Else
                        m_iBreite = New SqlInt32(CType(dtToReturn.Rows(0)("Breite"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("tiptext") Is System.DBNull.Value Then
                        m_sTiptext = SqlString.Null
                    Else
                        m_sTiptext = New SqlString(CType(dtToReturn.Rows(0)("tiptext"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_spalten_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabelle", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabelle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stabellenspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTabellenspalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspalte", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpalte))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bReadonly", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bReadonly))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@balsHacken", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAlsHacken))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iBreite", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBreite))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@stiptext", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTiptext))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_spalten_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSpalten::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsSpalten Fields

clsSpalten overview

Fields

field m_bAktiv
field m_bAlsHacken
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bReadonly
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iBreite
field m_iEintragnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_sSpalte
field m_sTabelle
field m_sTabellenspalte
field m_sTiptext
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSpalten Class


m_bAktiv Variable

Private 		m_bReadonly, _
   m_bAlsHacken, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_bAlsHacken Variable

Private 		m_bReadonly, _
   m_bAlsHacken, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_bReadonly Variable

Private 		m_bReadonly, _
   m_bAlsHacken, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bReadonly, m_bAlsHacken, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_iBreite Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iBreite, _
   m_iEintragnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_iEintragnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iBreite, _
   m_iEintragnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iBreite, _
   m_iEintragnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iBreite, _
   m_iEintragnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_iReihenfolge Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iBreite, _
   m_iEintragnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iBreite, m_iEintragnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_sSpalte Variable

Private 		m_sTabelle, _
   m_sTabellenspalte, _
   m_sTiptext, _
   m_sSpalte As SqlString

Source code

[Visual Basic]
        Private 		m_sTabelle, m_sTabellenspalte, m_sTiptext, m_sSpalte As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_sTabelle Variable

Private 		m_sTabelle, _
   m_sTabellenspalte, _
   m_sTiptext, _
   m_sSpalte As SqlString

Source code

[Visual Basic]
        Private 		m_sTabelle, m_sTabellenspalte, m_sTiptext, m_sSpalte As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_sTabellenspalte Variable

Private 		m_sTabelle, _
   m_sTabellenspalte, _
   m_sTiptext, _
   m_sSpalte As SqlString

Source code

[Visual Basic]
        Private 		m_sTabelle, m_sTabellenspalte, m_sTiptext, m_sSpalte As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


m_sTiptext Variable

Private 		m_sTabelle, _
   m_sTabellenspalte, _
   m_sTiptext, _
   m_sSpalte As SqlString

Source code

[Visual Basic]
        Private 		m_sTabelle, m_sTabellenspalte, m_sTiptext, m_sSpalte As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSpalten


clsStatus Class

For a list of all members of this type, see clsStatus Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsStatus

Public Class clsStatus
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsStatus Members


clsStatus Members

clsStatus overview

Constructors

constructor clsStatus Constructor

Properties

property bAktiv
property bDokument_ausgangsarchivieren
property bDokument_bearbeitung_abgeschlossen
property bDokumentbearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFolgestatus_durch_andere_rolle
property iMandantnr
property iMutierer
property iReihenfolge
property iStatus_bezeichnungnr
property iStatusnr
property iStatustypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivieren
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokumentbearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFolgestatus_durch_andere_rolle
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iStatus_bezeichnungnr
field m_iStatusnr
field m_iStatustypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatus Class


clsStatus Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus Properties

clsStatus overview

Properties

property bAktiv
property bDokument_ausgangsarchivieren
property bDokument_bearbeitung_abgeschlossen
property bDokumentbearbeitung_moeglich
property bFolgestatus_durch_anderen_verantwortlichen
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErledigung_ab
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFolgestatus_durch_andere_rolle
property iMandantnr
property iMutierer
property iReihenfolge
property iStatus_bezeichnungnr
property iStatusnr
property iStatustypnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatus Class


clsStatus.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.bDokument_ausgangsarchivieren Property

Public Property [bDokument_ausgangsarchivieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_ausgangsarchivieren]() As SqlBoolean
            Get
                Return m_bDokument_ausgangsarchivieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_ausgangsarchivieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.bDokument_bearbeitung_abgeschlossen Property

Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokument_bearbeitung_abgeschlossen]() As SqlBoolean
            Get
                Return m_bDokument_bearbeitung_abgeschlossen
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bDokument_bearbeitung_abgeschlossen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.bDokumentbearbeitung_moeglich Property

Public Property [bDokumentbearbeitung_moeglich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bDokumentbearbeitung_moeglich]() As SqlBoolean
            Get
                Return m_bDokumentbearbeitung_moeglich
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bDokumentbearbeitung_moeglichTmp As SqlBoolean = Value
                If bDokumentbearbeitung_moeglichTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bDokumentbearbeitung_moeglich", "bDokumentbearbeitung_moeglich can't be NULL")
                End If
                m_bDokumentbearbeitung_moeglich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.bFolgestatus_durch_anderen_verantwortlichen Property

Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFolgestatus_durch_anderen_verantwortlichen]() As SqlBoolean
            Get
                Return m_bFolgestatus_durch_anderen_verantwortlichen
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bFolgestatus_durch_anderen_verantwortlichenTmp As SqlBoolean = Value
                If bFolgestatus_durch_anderen_verantwortlichenTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bFolgestatus_durch_anderen_verantwortlichen", "bFolgestatus_durch_anderen_verantwortlichen can't be NULL")
                End If
                m_bFolgestatus_durch_anderen_verantwortlichen = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iErledigung_ab Property

Public Property [iErledigung_ab]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErledigung_ab]() As SqlInt32
            Get
                Return m_iErledigung_ab
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iErledigung_abTmp As SqlInt32 = Value
                If iErledigung_abTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iErledigung_ab", "iErledigung_ab can't be NULL")
                End If
                m_iErledigung_ab = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iFolgestatus_durch_andere_rolle Property

Public Property [iFolgestatus_durch_andere_rolle]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFolgestatus_durch_andere_rolle]() As SqlInt32
            Get
                Return m_iFolgestatus_durch_andere_rolle
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFolgestatus_durch_andere_rolle = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReihenfolgeTmp As SqlInt32 = Value
                If iReihenfolgeTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReihenfolge", "iReihenfolge can't be NULL")
                End If
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iStatus_bezeichnungnr Property

Public Property [iStatus_bezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_bezeichnungnr]() As SqlInt32
            Get
                Return m_iStatus_bezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_bezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iStatusnr Property

Public Property [iStatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatusnr]() As SqlInt32
            Get
                Return m_iStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatusnrTmp As SqlInt32 = Value
                If iStatusnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatusnr", "iStatusnr can't be NULL")
                End If
                m_iStatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.iStatustypnr Property

Public Property [iStatustypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatustypnr]() As SqlInt32
            Get
                Return m_iStatustypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatustypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus Methods

clsStatus overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsStatus Class


clsStatus.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_status_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_status_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatus::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_status_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifolgestatus_durch_andere_rolle", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFolgestatus_durch_andere_rolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokumentbearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bDokumentbearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_status_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatus::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_status_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_status_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatus::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_status_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("status")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_status_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("statusnr"), Integer))
                    If dtToReturn.Rows(0)("statustypnr") Is System.DBNull.Value Then
                        m_iStatustypnr = SqlInt32.Null
                    Else
                        m_iStatustypnr = New SqlInt32(CType(dtToReturn.Rows(0)("statustypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_bezeichnungnr") Is System.DBNull.Value Then
                        m_iStatus_bezeichnungnr = SqlInt32.Null
                    Else
                        m_iStatus_bezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("status_bezeichnungnr"), Integer))
                    End If
                    m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
                    m_bFolgestatus_durch_anderen_verantwortlichen = New SqlBoolean(CType(dtToReturn.Rows(0)("folgestatus_durch_anderen_verantwortlichen"), Boolean))
                    If dtToReturn.Rows(0)("folgestatus_durch_andere_rolle") Is System.DBNull.Value Then
                        m_iFolgestatus_durch_andere_rolle = SqlInt32.Null
                    Else
                        m_iFolgestatus_durch_andere_rolle = New SqlInt32(CType(dtToReturn.Rows(0)("folgestatus_durch_andere_rolle"), Integer))
                    End If
                    m_bDokumentbearbeitung_moeglich = New SqlBoolean(CType(dtToReturn.Rows(0)("dokumentbearbeitung_moeglich"), Boolean))
                    m_iErledigung_ab = New SqlInt32(CType(dtToReturn.Rows(0)("erledigung_ab"), Integer))
                    If dtToReturn.Rows(0)("dokument_ausgangsarchivieren") Is System.DBNull.Value Then
                        m_bDokument_ausgangsarchivieren = SqlBoolean.Null
                    Else
                        m_bDokument_ausgangsarchivieren = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_ausgangsarchivieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen") Is System.DBNull.Value Then
                        m_bDokument_bearbeitung_abgeschlossen = SqlBoolean.Null
                    Else
                        m_bDokument_bearbeitung_abgeschlossen = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_bearbeitung_abgeschlossen"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatus::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_status_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_bezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_bezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfolgestatus_durch_anderen_verantwortlichen", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bFolgestatus_durch_anderen_verantwortlichen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifolgestatus_durch_andere_rolle", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFolgestatus_durch_andere_rolle))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokumentbearbeitung_moeglich", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bDokumentbearbeitung_moeglich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierledigung_ab", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iErledigung_ab))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_ausgangsarchivieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_ausgangsarchivieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_bearbeitung_abgeschlossen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_bearbeitung_abgeschlossen))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_status_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatus::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatus Fields

clsStatus overview

Fields

field m_bAktiv
field m_bDokument_ausgangsarchivieren
field m_bDokument_bearbeitung_abgeschlossen
field m_bDokumentbearbeitung_moeglich
field m_bFolgestatus_durch_anderen_verantwortlichen
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErledigung_ab
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFolgestatus_durch_andere_rolle
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iStatus_bezeichnungnr
field m_iStatusnr
field m_iStatustypnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatus Class


m_bAktiv Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivieren, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivieren, m_bDokument_bearbeitung_abgeschlossen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_bDokument_ausgangsarchivieren Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivieren, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivieren, m_bDokument_bearbeitung_abgeschlossen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_bDokument_bearbeitung_abgeschlossen Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivieren, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivieren, m_bDokument_bearbeitung_abgeschlossen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_bDokumentbearbeitung_moeglich Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivieren, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivieren, m_bDokument_bearbeitung_abgeschlossen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_bFolgestatus_durch_anderen_verantwortlichen Variable

Private 		m_bDokumentbearbeitung_moeglich, _
   m_bFolgestatus_durch_anderen_verantwortlichen, _
   m_bDokument_ausgangsarchivieren, _
   m_bDokument_bearbeitung_abgeschlossen, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bDokumentbearbeitung_moeglich, m_bFolgestatus_durch_anderen_verantwortlichen, m_bDokument_ausgangsarchivieren, m_bDokument_bearbeitung_abgeschlossen, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iErledigung_ab Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iFolgestatus_durch_andere_rolle Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iReihenfolge Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iStatus_bezeichnungnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iStatusnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


m_iStatustypnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iStatus_bezeichnungnr, _
   m_iStatustypnr, _
   m_iStatusnr, _
   m_iErledigung_ab, _
   m_iFolgestatus_durch_andere_rolle, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iStatus_bezeichnungnr, m_iStatustypnr, m_iStatusnr, m_iErledigung_ab, m_iFolgestatus_durch_andere_rolle, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatus


clsStatushistory Class

For a list of all members of this type, see clsStatushistory Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsStatushistory

Public Class clsStatushistory
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsStatushistory Members


clsStatushistory Members

clsStatushistory overview

Constructors

constructor clsStatushistory Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property iStatushistorynr
property iVerantwortlich
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_iStatushistorynr
field m_iVerantwortlich
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatushistory Class


clsStatushistory Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory Properties

clsStatushistory overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property iStatushistorynr
property iVerantwortlich
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

See Also

clsStatushistory Class


clsStatushistory.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatusTmp As SqlInt32 = Value
                If iStatusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatus", "iStatus can't be NULL")
                End If
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.iStatushistorynr Property

Public Property [iStatushistorynr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatushistorynr]() As SqlInt32
            Get
                Return m_iStatushistorynr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatushistorynrTmp As SqlInt32 = Value
                If iStatushistorynrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatushistorynr", "iStatushistorynr can't be NULL")
                End If
                m_iStatushistorynr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.iVerantwortlich Property

Public Property [iVerantwortlich]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerantwortlich]() As SqlInt32
            Get
                Return m_iVerantwortlich
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerantwortlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory Methods

clsStatushistory overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsStatushistory Class


clsStatushistory.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statushistory_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatushistory::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statushistory_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatushistory::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statushistory_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("statushistory")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statushistory_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatushistory::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statushistory_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("statushistory")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statushistory_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iStatushistorynr = New SqlInt32(CType(dtToReturn.Rows(0)("statushistorynr"), Integer))
                    m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
                        m_iVerantwortlich = SqlInt32.Null
                    Else
                        m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatushistory::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statushistory_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatushistory::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatushistory Fields

clsStatushistory overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_iStatushistorynr
field m_iVerantwortlich
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatushistory Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iVerantwortlich, _
   m_iStatushistorynr, _
   m_iMandantnr, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iVerantwortlich, _
   m_iStatushistorynr, _
   m_iMandantnr, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_iStatus Variable

Private 		m_iMutierer, _
   m_iVerantwortlich, _
   m_iStatushistorynr, _
   m_iMandantnr, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_iStatushistorynr Variable

Private 		m_iMutierer, _
   m_iVerantwortlich, _
   m_iStatushistorynr, _
   m_iMandantnr, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_iVerantwortlich Variable

Private 		m_iMutierer, _
   m_iVerantwortlich, _
   m_iStatushistorynr, _
   m_iMandantnr, _
   m_iStatus As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


m_sDokumentid Variable

Private 		m_sDokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatushistory


clsStatustyp Class

For a list of all members of this type, see clsStatustyp Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsStatustyp

Public Class clsStatustyp
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsStatustyp Members


clsStatustyp Members

clsStatustyp overview

Constructors

constructor clsStatustyp Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iStatustypnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sMandantnr

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iStatustypnr
field m_sBeschreibung
field m_sBezeichnung
field m_sMandantnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatustyp Class


clsStatustyp Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp Properties

clsStatustyp overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iStatustypnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sMandantnr

See Also

clsStatustyp Class


clsStatustyp.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.iStatustypnr Property

Public Property [iStatustypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatustypnr]() As SqlInt32
            Get
                Return m_iStatustypnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatustypnrTmp As SqlInt32 = Value
                If iStatustypnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatustypnr", "iStatustypnr can't be NULL")
                End If
                m_iStatustypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.sMandantnr Property

Public Property [sMandantnr]() As SqlString

Source code

[Visual Basic]
        Public Property [sMandantnr]() As SqlString
            Get
                Return m_sMandantnr
            End Get
            Set(ByVal Value As SqlString)
                m_sMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp Methods

clsStatustyp overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsStatustyp Class


clsStatustyp.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statustyp_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statustyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatustyp::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statustyp_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smandantnr", SqlDbType.Char, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statustyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatustyp::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statustyp_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("statustyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statustyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatustyp::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statustyp_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("statustyp")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statustyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iStatustypnr = New SqlInt32(CType(dtToReturn.Rows(0)("statustypnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_sMandantnr = SqlString.Null
                    Else
                        m_sMandantnr = New SqlString(CType(dtToReturn.Rows(0)("mandantnr"), String))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatustyp::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_statustyp_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatustypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smandantnr", SqlDbType.Char, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_statustyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsStatustyp::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsStatustyp Fields

clsStatustyp overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iStatustypnr
field m_sBeschreibung
field m_sBezeichnung
field m_sMandantnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsStatustyp Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iStatustypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iStatustypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_iStatustypnr Variable

Private 		m_iMutierer, _
   m_iStatustypnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iStatustypnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_sBeschreibung Variable

Private 		m_sMandantnr, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sMandantnr, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_sBezeichnung Variable

Private 		m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


m_sMandantnr Variable

Private 		m_sMandantnr, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sMandantnr, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsStatustyp


clsSuchdaten Class

For a list of all members of this type, see clsSuchdaten Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsSuchdaten

Public Class clsSuchdaten
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsSuchdaten Members


clsSuchdaten Members

clsSuchdaten overview

Constructors

constructor clsSuchdaten Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iId
property iMitarbeiternr
property iNodenr
property iSuchprofilnr
property sAndor
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDaten1
property sDaten2
property sOp1
property sOp2

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iId
field m_iMitarbeiternr
field m_iNodenr
field m_iSuchprofilnr
field m_sAndor
field m_sDaten1
field m_sDaten2
field m_sOp1
field m_sOp2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchdaten Class


clsSuchdaten Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten Properties

clsSuchdaten overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iId
property iMitarbeiternr
property iNodenr
property iSuchprofilnr
property sAndor
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDaten1
property sDaten2
property sOp1
property sOp2

See Also

clsSuchdaten Class


clsSuchdaten.iId Property

Public Property [iId]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iId]() As SqlInt32
            Get
                Return m_iId
            End Get
            Set(ByVal Value As SqlInt32)
                m_iId = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.iNodenr Property

Public Property [iNodenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNodenr]() As SqlInt32
            Get
                Return m_iNodenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNodenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.iSuchprofilnr Property

Public Property [iSuchprofilnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSuchprofilnr]() As SqlInt32
            Get
                Return m_iSuchprofilnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSuchprofilnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.sAndor Property

Public Property [sAndor]() As SqlString

Source code

[Visual Basic]
        Public Property [sAndor]() As SqlString
            Get
                Return m_sAndor
            End Get
            Set(ByVal Value As SqlString)
                m_sAndor = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.sDaten1 Property

Public Property [sDaten1]() As SqlString

Source code

[Visual Basic]
        Public Property [sDaten1]() As SqlString
            Get
                Return m_sDaten1
            End Get
            Set(ByVal Value As SqlString)
                m_sDaten1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.sDaten2 Property

Public Property [sDaten2]() As SqlString

Source code

[Visual Basic]
        Public Property [sDaten2]() As SqlString
            Get
                Return m_sDaten2
            End Get
            Set(ByVal Value As SqlString)
                m_sDaten2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.sOp1 Property

Public Property [sOp1]() As SqlString

Source code

[Visual Basic]
        Public Property [sOp1]() As SqlString
            Get
                Return m_sOp1
            End Get
            Set(ByVal Value As SqlString)
                m_sOp1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.sOp2 Property

Public Property [sOp2]() As SqlString

Source code

[Visual Basic]
        Public Property [sOp2]() As SqlString
            Get
                Return m_sOp2
            End Get
            Set(ByVal Value As SqlString)
                m_sOp2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten Methods

clsSuchdaten overview

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchdaten Class


clsSuchdaten.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_suchdaten_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iId))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isuchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSuchprofilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sandor", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAndor))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sop1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOp1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdaten1", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDaten1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sop2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOp2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdaten2", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDaten2))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_suchdaten_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchdaten::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_suchdaten_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("suchdaten")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_suchdaten_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchdaten::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchdaten Fields

clsSuchdaten overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iId
field m_iMitarbeiternr
field m_iNodenr
field m_iSuchprofilnr
field m_sAndor
field m_sDaten1
field m_sDaten2
field m_sOp1
field m_sOp2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchdaten Class


m_iId Variable

Private 		m_iNodenr, _
   m_iMitarbeiternr, _
   m_iId, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNodenr, m_iMitarbeiternr, m_iId, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_iMitarbeiternr Variable

Private 		m_iNodenr, _
   m_iMitarbeiternr, _
   m_iId, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNodenr, m_iMitarbeiternr, m_iId, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_iNodenr Variable

Private 		m_iNodenr, _
   m_iMitarbeiternr, _
   m_iId, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNodenr, m_iMitarbeiternr, m_iId, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_iSuchprofilnr Variable

Private 		m_iNodenr, _
   m_iMitarbeiternr, _
   m_iId, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNodenr, m_iMitarbeiternr, m_iId, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_sAndor Variable

Private 		m_sOp2, _
   m_sDaten2, _
   m_sDaten1, _
   m_sAndor, _
   m_sOp1 As SqlString

Source code

[Visual Basic]
        Private 		m_sOp2, m_sDaten2, m_sDaten1, m_sAndor, m_sOp1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_sDaten1 Variable

Private 		m_sOp2, _
   m_sDaten2, _
   m_sDaten1, _
   m_sAndor, _
   m_sOp1 As SqlString

Source code

[Visual Basic]
        Private 		m_sOp2, m_sDaten2, m_sDaten1, m_sAndor, m_sOp1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_sDaten2 Variable

Private 		m_sOp2, _
   m_sDaten2, _
   m_sDaten1, _
   m_sAndor, _
   m_sOp1 As SqlString

Source code

[Visual Basic]
        Private 		m_sOp2, m_sDaten2, m_sDaten1, m_sAndor, m_sOp1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_sOp1 Variable

Private 		m_sOp2, _
   m_sDaten2, _
   m_sDaten1, _
   m_sAndor, _
   m_sOp1 As SqlString

Source code

[Visual Basic]
        Private 		m_sOp2, m_sDaten2, m_sDaten1, m_sAndor, m_sOp1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


m_sOp2 Variable

Private 		m_sOp2, _
   m_sDaten2, _
   m_sDaten1, _
   m_sAndor, _
   m_sOp1 As SqlString

Source code

[Visual Basic]
        Private 		m_sOp2, m_sDaten2, m_sDaten1, m_sAndor, m_sOp1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchdaten


clsSuchprofil Class

For a list of all members of this type, see clsSuchprofil Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsSuchprofil

Public Class clsSuchprofil
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsSuchprofil Members


clsSuchprofil Members

clsSuchprofil overview

Constructors

constructor clsSuchprofil Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMitarbeiternr
property iSuchprofilnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sProfilname

Methods

method Delete
method DeleteWmitarbeiternrLogic
method DeleteWprofilnameLogic
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method SelectOneWsuchprofilnrLogic
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMitarbeiternr
field m_iSuchprofilnr
field m_sProfilname
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchprofil Class


clsSuchprofil Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil Properties

clsSuchprofil overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMitarbeiternr
property iSuchprofilnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sProfilname

See Also

clsSuchprofil Class


clsSuchprofil.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.iSuchprofilnr Property

Public Property [iSuchprofilnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSuchprofilnr]() As SqlInt32
            Get
                Return m_iSuchprofilnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iSuchprofilnrTmp As SqlInt32 = Value
                If iSuchprofilnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iSuchprofilnr", "iSuchprofilnr can't be NULL")
                End If
                m_iSuchprofilnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.sProfilname Property

Public Property [sProfilname]() As SqlString

Source code

[Visual Basic]
        Public Property [sProfilname]() As SqlString
            Get
                Return m_sProfilname
            End Get
            Set(ByVal Value As SqlString)
                Dim sProfilnameTmp As SqlString = Value
                If sProfilnameTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sProfilname", "sProfilname can't be NULL")
                End If
                m_sProfilname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil Methods

clsSuchprofil overview

Methods

method Delete
method DeleteWmitarbeiternrLogic
method DeleteWprofilnameLogic
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method SelectOneWsuchprofilnrLogic
method Update (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchprofil Class


clsSuchprofil.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sprofilname", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sProfilname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.DeleteWmitarbeiternrLogic Method

Public Function DeleteWmitarbeiternrLogic() As Boolean

Source code

[Visual Basic]
        Public Function DeleteWmitarbeiternrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_DeleteWmitarbeiternrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_DeleteWmitarbeiternrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::DeleteWmitarbeiternrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.DeleteWprofilnameLogic Method

Public Function DeleteWprofilnameLogic() As Boolean

Source code

[Visual Basic]
        Public Function DeleteWprofilnameLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_DeleteWprofilnameLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sprofilname", SqlDbType.VarChar, 50, ParameterDirection.Input, false, 0, 0, "", DataRowVersion.Proposed, m_sProfilname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 50, ParameterDirection.Output, True, 0, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_DeleteWprofilnameLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::DeleteWprofilnameLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sprofilname", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sProfilname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isuchprofilnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iSuchprofilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iSuchprofilnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@isuchprofilnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Suchprofil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Suchprofil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sprofilname", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sProfilname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSuchprofilnr = New SqlInt32(CType(dtToReturn.Rows(0)("suchprofilnr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    m_sProfilname = New SqlString(CType(dtToReturn.Rows(0)("profilname"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil.SelectOneWsuchprofilnrLogic Method

Public Function SelectOneWsuchprofilnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectOneWsuchprofilnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Suchprofil_SelectOneWsuchprofilnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Suchprofil")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@isuchprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iSuchprofilnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Suchprofil_SelectOneWsuchprofilnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iSuchprofilnr = New SqlInt32(CType(dtToReturn.Rows(0)("suchprofilnr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    m_sProfilname = New SqlString(CType(dtToReturn.Rows(0)("profilname"), String))
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsSuchprofil::SelectOneWsuchprofilnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSuchprofil Fields

clsSuchprofil overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMitarbeiternr
field m_iSuchprofilnr
field m_sProfilname
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSuchprofil Class


m_iMitarbeiternr Variable

Private 		m_iMitarbeiternr, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMitarbeiternr, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


m_iSuchprofilnr Variable

Private 		m_iMitarbeiternr, _
   m_iSuchprofilnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMitarbeiternr, m_iSuchprofilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


m_sProfilname Variable

Private 		m_sProfilname As SqlString

Source code

[Visual Basic]
        Private 		m_sProfilname As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSuchprofil


clsSysadminfunktion Class

For a list of all members of this type, see clsSysadminfunktion Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsSysadminfunktion
EDOKAApp.edokadb.clsMySysadminfunkion

Public Class clsSysadminfunktion
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsSysadminfunktion Members


clsSysadminfunktion Members

clsSysadminfunktion overview

Constructors

constructor clsSysadminfunktion Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFheight
property iFleft
property iFtop
property iFwidth
property iImageIndex
property iImageIndexOpen
property iMandantnr
property iMutierer
property iParentID
property iSort
property iSprache
property iSysadminfnktnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFheight
field m_iFleft
field m_iFtop
field m_iFwidth
field m_iImageIndex
field m_iImageIndexOpen
field m_iMandantnr
field m_iMutierer
field m_iParentID
field m_iSort
field m_iSprache
field m_iSysadminfnktnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSysadminfunktion Class


clsSysadminfunktion Properties

clsSysadminfunktion overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFheight
property iFleft
property iFtop
property iFwidth
property iImageIndex
property iImageIndexOpen
property iMandantnr
property iMutierer
property iParentID
property iSort
property iSprache
property iSysadminfnktnr
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSysadminfunktion Class


clsSysadminfunktion Methods

clsSysadminfunktion overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsSysadminfunktion Class


clsSysadminfunktion Fields

clsSysadminfunktion overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFheight
field m_iFleft
field m_iFtop
field m_iFwidth
field m_iImageIndex
field m_iImageIndexOpen
field m_iMandantnr
field m_iMutierer
field m_iParentID
field m_iSort
field m_iSprache
field m_iSysadminfnktnr
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsSysadminfunktion Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iFheight Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iFleft Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iFtop Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iFwidth Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iImageIndex Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iImageIndexOpen Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iMandantnr Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iMutierer Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iParentID Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iSort Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iSprache Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_iSysadminfnktnr Variable

Private 		m_iFheight, _
   m_iFwidth, _
   m_iMandantnr, _
   m_iMutierer, _
   m_iSprache, _
   m_iSort, _
   m_iImageIndex, _
   m_iSysadminfnktnr, _
   m_iParentID, _
   m_iFtop, _
   m_iFleft, _
   m_iImageIndexOpen As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFheight, m_iFwidth, m_iMandantnr, m_iMutierer, m_iSprache, m_iSort, m_iImageIndex, m_iSysadminfnktnr, m_iParentID, m_iFtop, m_iFleft, m_iImageIndexOpen As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_sBeschreibung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


m_sBezeichnung Variable

Private 		m_sBezeichnung, _
   m_sBeschreibung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung, m_sBeschreibung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsSysadminfunktion


clsTeam Class

For a list of all members of this type, see clsTeam Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTeam

Public Class clsTeam
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTeam Members


clsTeam Members

clsTeam overview

Constructors

constructor clsTeam Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKostenstellenr
property iMandantnr
property iMutierer
property iTeamnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKostenstellenr
field m_iMandantnr
field m_iMutierer
field m_iTeamnr
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeam Class


clsTeam Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam Properties

clsTeam overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iKostenstellenr
property iMandantnr
property iMutierer
property iTeamnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeam Class


clsTeam.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.iKostenstellenr Property

Public Property [iKostenstellenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iKostenstellenr]() As SqlInt32
            Get
                Return m_iKostenstellenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iKostenstellenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.iTeamnr Property

Public Property [iTeamnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeamnr]() As SqlInt32
            Get
                Return m_iTeamnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iTeamnrTmp As SqlInt32 = Value
                If iTeamnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iTeamnr", "iTeamnr can't be NULL")
                End If
                m_iTeamnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam Methods

clsTeam overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTeam Class


clsTeam.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_team_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_team_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeam::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_team_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_team_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeam::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_team_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("team")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_team_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeam::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_team_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("team")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_team_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iTeamnr = New SqlInt32(CType(dtToReturn.Rows(0)("teamnr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("kostenstellenr") Is System.DBNull.Value Then
                        m_iKostenstellenr = SqlInt32.Null
                    Else
                        m_iKostenstellenr = New SqlInt32(CType(dtToReturn.Rows(0)("kostenstellenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeam::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_team_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ikostenstellenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKostenstellenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_team_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeam::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeam Fields

clsTeam overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iKostenstellenr
field m_iMandantnr
field m_iMutierer
field m_iTeamnr
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeam Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_iKostenstellenr Variable

Private 		m_iMutierer, _
   m_iTeamnr, _
   m_iKostenstellenr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iTeamnr, m_iKostenstellenr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iTeamnr, _
   m_iKostenstellenr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iTeamnr, m_iKostenstellenr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iTeamnr, _
   m_iKostenstellenr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iTeamnr, m_iKostenstellenr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_iTeamnr Variable

Private 		m_iMutierer, _
   m_iTeamnr, _
   m_iKostenstellenr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iTeamnr, m_iKostenstellenr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


m_sBezeichnung Variable

Private 		m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeam


clsTeammitarbeiter Class

For a list of all members of this type, see clsTeammitarbeiter Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTeammitarbeiter

Public Class clsTeammitarbeiter
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTeammitarbeiter Members


clsTeammitarbeiter Members

clsTeammitarbeiter overview

Constructors

constructor clsTeammitarbeiter Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnteil
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMitarbeiternr
property iMutierer
property iTeammitarbeiternr
property iTeamnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnteil
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iTeammitarbeiternr
field m_iTeamnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeammitarbeiter Class


clsTeammitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter Properties

clsTeammitarbeiter overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iAnteil
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMitarbeiternr
property iMutierer
property iTeammitarbeiternr
property iTeamnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeammitarbeiter Class


clsTeammitarbeiter.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iAnteil Property

Public Property [iAnteil]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iAnteil]() As SqlInt32
            Get
                Return m_iAnteil
            End Get
            Set(ByVal Value As SqlInt32)
                m_iAnteil = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iTeammitarbeiternr Property

Public Property [iTeammitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeammitarbeiternr]() As SqlInt32
            Get
                Return m_iTeammitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iTeammitarbeiternrTmp As SqlInt32 = Value
                If iTeammitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iTeammitarbeiternr", "iTeammitarbeiternr can't be NULL")
                End If
                m_iTeammitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.iTeamnr Property

Public Property [iTeamnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeamnr]() As SqlInt32
            Get
                Return m_iTeamnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTeamnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter Methods

clsTeammitarbeiter overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTeammitarbeiter Class


clsTeammitarbeiter.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_teammitarbeiter_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteammitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeammitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_teammitarbeiter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeammitarbeiter::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_teammitarbeiter_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteammitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeammitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianteil", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnteil))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_teammitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeammitarbeiter::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_teammitarbeiter_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("teammitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_teammitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeammitarbeiter::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_teammitarbeiter_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("teammitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iteammitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeammitarbeiternr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_teammitarbeiter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iTeammitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("teammitarbeiternr"), Integer))
                    If dtToReturn.Rows(0)("teamnr") Is System.DBNull.Value Then
                        m_iTeamnr = SqlInt32.Null
                    Else
                        m_iTeamnr = New SqlInt32(CType(dtToReturn.Rows(0)("teamnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("anteil") Is System.DBNull.Value Then
                        m_iAnteil = SqlInt32.Null
                    Else
                        m_iAnteil = New SqlInt32(CType(dtToReturn.Rows(0)("anteil"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeammitarbeiter::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_teammitarbeiter_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteammitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeammitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteamnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTeamnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ianteil", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnteil))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_teammitarbeiter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTeammitarbeiter::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTeammitarbeiter Fields

clsTeammitarbeiter overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iAnteil
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iTeammitarbeiternr
field m_iTeamnr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTeammitarbeiter Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iAnteil Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iMitarbeiternr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iTeammitarbeiternr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


m_iTeamnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iTeamnr, _
   m_iTeammitarbeiternr, _
   m_iAnteil, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iTeamnr, m_iTeammitarbeiternr, m_iAnteil, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTeammitarbeiter


clsTempdokument Class

For a list of all members of this type, see clsTempdokument Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempdokument

Public Class clsTempdokument
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempdokument Members


clsTempdokument Members

clsTempdokument overview

Constructors

constructor clsTempdokument Constructor

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBereit_zur_archivierung
property bEingangsarchiviert
property bGesperrt
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iBarcodenr
property iColdstatus
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMutierer
property iMutiererteam
property iMutierertieam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sZustelladresse

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBereit_zur_archivierung
field m_bEingangsarchiviert
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iBarcodenr
field m_iColdstatus
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMutierer
field m_iMutiererteam
field m_iMutierertieam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokument Class


clsTempdokument Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument Properties

clsTempdokument overview

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBereit_zur_archivierung
property bEingangsarchiviert
property bGesperrt
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iBarcodenr
property iColdstatus
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMutierer
property iMutiererteam
property iMutierertieam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sZustelladresse

See Also

clsTempdokument Class


clsTempdokument.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bAmsdokument Property

Public Property [bAmsdokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAmsdokument]() As SqlBoolean
            Get
                Return m_bAmsdokument
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAmsdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bAuserstuebernahme Property

Public Property [bAuserstuebernahme]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAuserstuebernahme]() As SqlBoolean
            Get
                Return m_bAuserstuebernahme
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAuserstuebernahme = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bAusgangsarchiviert Property

Public Property [bAusgangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusgangsarchiviert]() As SqlBoolean
            Get
                Return m_bAusgangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusgangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bBereit_zur_archivierung Property

Public Property [bBereit_zur_archivierung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBereit_zur_archivierung]() As SqlBoolean
            Get
                Return m_bBereit_zur_archivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBereit_zur_archivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bEingangsarchiviert Property

Public Property [bEingangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEingangsarchiviert]() As SqlBoolean
            Get
                Return m_bEingangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEingangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bGesperrt Property

Public Property [bGesperrt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGesperrt]() As SqlBoolean
            Get
                Return m_bGesperrt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGesperrt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bUnvollstaendig Property

Public Property [bUnvollstaendig]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUnvollstaendig]() As SqlBoolean
            Get
                Return m_bUnvollstaendig
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bUnvollstaendig = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bVertraulich Property

Public Property [bVertraulich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertraulich]() As SqlBoolean
            Get
                Return m_bVertraulich
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertraulich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bZu_retournieren Property

Public Property [bZu_retournieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZu_retournieren]() As SqlBoolean
            Get
                Return m_bZu_retournieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZu_retournieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.bZustaendig_kube Property

Public Property [bZustaendig_kube]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZustaendig_kube]() As SqlBoolean
            Get
                Return m_bZustaendig_kube
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZustaendig_kube = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daArchivierungsdatum Property

Public Property [daArchivierungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daArchivierungsdatum]() As SqlDateTime
            Get
                Return m_daArchivierungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daArchivierungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daDatum_ausgangsarchivierung Property

Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daDatum_eingangsarchivierung Property

Public Property [daDatum_eingangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_eingangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daErstelltam Property

Public Property [daErstelltam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstelltam]() As SqlDateTime
            Get
                Return m_daErstelltam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstelltam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daErstellungsdatum Property

Public Property [daErstellungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellungsdatum]() As SqlDateTime
            Get
                Return m_daErstellungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daGesperrtam Property

Public Property [daGesperrtam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGesperrtam]() As SqlDateTime
            Get
                Return m_daGesperrtam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGesperrtam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daMutiertam Property

Public Property [daMutiertam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiertam]() As SqlDateTime
            Get
                Return m_daMutiertam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiertam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.daTermin Property

Public Property [daTermin]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTermin]() As SqlDateTime
            Get
                Return m_daTermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTermin = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iBarcodenr Property

Public Property [iBarcodenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBarcodenr]() As SqlInt32
            Get
                Return m_iBarcodenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBarcodenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iColdstatus Property

Public Property [iColdstatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdstatus]() As SqlInt32
            Get
                Return m_iColdstatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iColdstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iErsteller Property

Public Property [iErsteller]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErsteller]() As SqlInt32
            Get
                Return m_iErsteller
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErsteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iErstellerteam Property

Public Property [iErstellerteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErstellerteam]() As SqlInt32
            Get
                Return m_iErstellerteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErstellerteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iGesperrt_durch Property

Public Property [iGesperrt_durch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iGesperrt_durch]() As SqlInt32
            Get
                Return m_iGesperrt_durch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGesperrt_durch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMa_ausgangsarchivierung Property

Public Property [iMa_ausgangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_ausgangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMa_eingangsarchivierung Property

Public Property [iMa_eingangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_eingangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMitarbeiternr1 Property

Public Property [iMitarbeiternr1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr1]() As SqlInt32
            Get
                Return m_iMitarbeiternr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMutiererteam Property

Public Property [iMutiererteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutiererteam]() As SqlInt32
            Get
                Return m_iMutiererteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutiererteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iMutierertieam Property

Public Property [iMutierertieam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierertieam]() As SqlInt32
            Get
                Return m_iMutierertieam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierertieam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iPostzustellung Property

Public Property [iPostzustellung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPostzustellung]() As SqlInt32
            Get
                Return m_iPostzustellung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPostzustellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iStatus_edoka_batch_ausgang Property

Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_ausgang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_ausgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iStatus_edoka_batch_eingang Property

Public Property [iStatus_edoka_batch_eingang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_eingang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_eingang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_eingang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iStatusnr Property

Public Property [iStatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatusnr]() As SqlInt32
            Get
                Return m_iStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iVerantwortlich Property

Public Property [iVerantwortlich]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerantwortlich]() As SqlInt32
            Get
                Return m_iVerantwortlich
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerantwortlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.iZustaendiger Property

Public Property [iZustaendiger]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZustaendiger]() As SqlInt32
            Get
                Return m_iZustaendiger
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZustaendiger = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sBemerkunguvm Property

Public Property [sBemerkunguvm]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkunguvm]() As SqlString
            Get
                Return m_sBemerkunguvm
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkunguvm = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sColddokumentid Property

Public Property [sColddokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sColddokumentid]() As SqlString
            Get
                Return m_sColddokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sColddokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentidTmp As SqlString = Value
                If sDokumentidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
                End If
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sDokumentidn Property

Public Property [sDokumentidn]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentidn]() As SqlString
            Get
                Return m_sDokumentidn
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentidn = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sDokumentname Property

Public Property [sDokumentname]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentname]() As SqlString
            Get
                Return m_sDokumentname
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sLoeschgrund Property

Public Property [sLoeschgrund]() As SqlString

Source code

[Visual Basic]
        Public Property [sLoeschgrund]() As SqlString
            Get
                Return m_sLoeschgrund
            End Get
            Set(ByVal Value As SqlString)
                m_sLoeschgrund = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sSpeicherort Property

Public Property [sSpeicherort]() As SqlString

Source code

[Visual Basic]
        Public Property [sSpeicherort]() As SqlString
            Get
                Return m_sSpeicherort
            End Get
            Set(ByVal Value As SqlString)
                m_sSpeicherort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sVersandadresse Property

Public Property [sVersandadresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sVersandadresse]() As SqlString
            Get
                Return m_sVersandadresse
            End Get
            Set(ByVal Value As SqlString)
                m_sVersandadresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.sZustelladresse Property

Public Property [sZustelladresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sZustelladresse]() As SqlString
            Get
                Return m_sZustelladresse
            End Get
            Set(ByVal Value As SqlString)
                m_sZustelladresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument Methods

clsTempdokument overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTempdokument Class


clsTempdokument.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokument_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokument::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokument_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiternr1") Is System.DBNull.Value Then
                        m_iMitarbeiternr1 = SqlInt32.Null
                    Else
                        m_iMitarbeiternr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
                        m_iNrpar00 = SqlInt32.Null
                    Else
                        m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentidn") Is System.DBNull.Value Then
                        m_sDokumentidn = SqlString.Null
                    Else
                        m_sDokumentidn = New SqlString(CType(dtToReturn.Rows(0)("dokumentidn"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentname") Is System.DBNull.Value Then
                        m_sDokumentname = SqlString.Null
                    Else
                        m_sDokumentname = New SqlString(CType(dtToReturn.Rows(0)("dokumentname"), String))
                    End If
                    If dtToReturn.Rows(0)("ersteller") Is System.DBNull.Value Then
                        m_iErsteller = SqlInt32.Null
                    Else
                        m_iErsteller = New SqlInt32(CType(dtToReturn.Rows(0)("ersteller"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellerteam") Is System.DBNull.Value Then
                        m_iErstellerteam = SqlInt32.Null
                    Else
                        m_iErstellerteam = New SqlInt32(CType(dtToReturn.Rows(0)("erstellerteam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstelltam") Is System.DBNull.Value Then
                        m_daErstelltam = SqlDateTime.Null
                    Else
                        m_daErstelltam = New SqlDateTime(CType(dtToReturn.Rows(0)("erstelltam"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutierertieam") Is System.DBNull.Value Then
                        m_iMutierertieam = SqlInt32.Null
                    Else
                        m_iMutierertieam = New SqlInt32(CType(dtToReturn.Rows(0)("mutierertieam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiertam") Is System.DBNull.Value Then
                        m_daMutiertam = SqlDateTime.Null
                    Else
                        m_daMutiertam = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiertam"), Date))
                    End If
                    If dtToReturn.Rows(0)("speicherort") Is System.DBNull.Value Then
                        m_sSpeicherort = SqlString.Null
                    Else
                        m_sSpeicherort = New SqlString(CType(dtToReturn.Rows(0)("speicherort"), String))
                    End If
                    If dtToReturn.Rows(0)("gesperrt") Is System.DBNull.Value Then
                        m_bGesperrt = SqlBoolean.Null
                    Else
                        m_bGesperrt = New SqlBoolean(CType(dtToReturn.Rows(0)("gesperrt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("gesperrt_durch") Is System.DBNull.Value Then
                        m_iGesperrt_durch = SqlInt32.Null
                    Else
                        m_iGesperrt_durch = New SqlInt32(CType(dtToReturn.Rows(0)("gesperrt_durch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("gesperrtam") Is System.DBNull.Value Then
                        m_daGesperrtam = SqlDateTime.Null
                    Else
                        m_daGesperrtam = New SqlDateTime(CType(dtToReturn.Rows(0)("gesperrtam"), Date))
                    End If
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("auserstuebernahme") Is System.DBNull.Value Then
                        m_bAuserstuebernahme = SqlBoolean.Null
                    Else
                        m_bAuserstuebernahme = New SqlBoolean(CType(dtToReturn.Rows(0)("auserstuebernahme"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unvollstaendig") Is System.DBNull.Value Then
                        m_bUnvollstaendig = SqlBoolean.Null
                    Else
                        m_bUnvollstaendig = New SqlBoolean(CType(dtToReturn.Rows(0)("unvollstaendig"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bemerkunguvm") Is System.DBNull.Value Then
                        m_sBemerkunguvm = SqlString.Null
                    Else
                        m_sBemerkunguvm = New SqlString(CType(dtToReturn.Rows(0)("bemerkunguvm"), String))
                    End If
                    If dtToReturn.Rows(0)("bereit_zur_archivierung") Is System.DBNull.Value Then
                        m_bBereit_zur_archivierung = SqlBoolean.Null
                    Else
                        m_bBereit_zur_archivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("bereit_zur_archivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("ausgangsarchiviert") Is System.DBNull.Value Then
                        m_bAusgangsarchiviert = SqlBoolean.Null
                    Else
                        m_bAusgangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("ausgangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_ausgangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_ausgangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_ausgangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_ausgangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_ausgangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_ausgangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zu_retournieren") Is System.DBNull.Value Then
                        m_bZu_retournieren = SqlBoolean.Null
                    Else
                        m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("eingangsarchiviert") Is System.DBNull.Value Then
                        m_bEingangsarchiviert = SqlBoolean.Null
                    Else
                        m_bEingangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("eingangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_eingangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_eingangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_eingangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_eingangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_eingangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_eingangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_eingangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_eingangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_ausgang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_ausgang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_ausgang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_ausgang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_eingang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_eingang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_eingang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_eingang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("loeschgrund") Is System.DBNull.Value Then
                        m_sLoeschgrund = SqlString.Null
                    Else
                        m_sLoeschgrund = New SqlString(CType(dtToReturn.Rows(0)("loeschgrund"), String))
                    End If
                    If dtToReturn.Rows(0)("coldstatus") Is System.DBNull.Value Then
                        m_iColdstatus = SqlInt32.Null
                    Else
                        m_iColdstatus = New SqlInt32(CType(dtToReturn.Rows(0)("coldstatus"), Integer))
                    End If
                    If dtToReturn.Rows(0)("versandadresse") Is System.DBNull.Value Then
                        m_sVersandadresse = SqlString.Null
                    Else
                        m_sVersandadresse = New SqlString(CType(dtToReturn.Rows(0)("versandadresse"), String))
                    End If
                    If dtToReturn.Rows(0)("barcodenr") Is System.DBNull.Value Then
                        m_iBarcodenr = SqlInt32.Null
                    Else
                        m_iBarcodenr = New SqlInt32(CType(dtToReturn.Rows(0)("barcodenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("colddokumentid") Is System.DBNull.Value Then
                        m_sColddokumentid = SqlString.Null
                    Else
                        m_sColddokumentid = New SqlString(CType(dtToReturn.Rows(0)("colddokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("amsdokument") Is System.DBNull.Value Then
                        m_bAmsdokument = SqlBoolean.Null
                    Else
                        m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
                        m_iVerantwortlich = SqlInt32.Null
                    Else
                        m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendiger") Is System.DBNull.Value Then
                        m_iZustaendiger = SqlInt32.Null
                    Else
                        m_iZustaendiger = New SqlInt32(CType(dtToReturn.Rows(0)("zustaendiger"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftlinks") Is System.DBNull.Value Then
                        m_iUnterschriftlinks = SqlInt32.Null
                    Else
                        m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftrechts") Is System.DBNull.Value Then
                        m_iUnterschriftrechts = SqlInt32.Null
                    Else
                        m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    End If
                    If dtToReturn.Rows(0)("postzustellung") Is System.DBNull.Value Then
                        m_iPostzustellung = SqlInt32.Null
                    Else
                        m_iPostzustellung = New SqlInt32(CType(dtToReturn.Rows(0)("postzustellung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("statusnr") Is System.DBNull.Value Then
                        m_iStatusnr = SqlInt32.Null
                    Else
                        m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("statusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendig_kube") Is System.DBNull.Value Then
                        m_bZustaendig_kube = SqlBoolean.Null
                    Else
                        m_bZustaendig_kube = New SqlBoolean(CType(dtToReturn.Rows(0)("zustaendig_kube"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("zustelladresse") Is System.DBNull.Value Then
                        m_sZustelladresse = SqlString.Null
                    Else
                        m_sZustelladresse = New SqlString(CType(dtToReturn.Rows(0)("zustelladresse"), String))
                    End If
                    If dtToReturn.Rows(0)("vertraulich") Is System.DBNull.Value Then
                        m_bVertraulich = SqlBoolean.Null
                    Else
                        m_bVertraulich = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellungsdatum") Is System.DBNull.Value Then
                        m_daErstellungsdatum = SqlDateTime.Null
                    Else
                        m_daErstellungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("archivierungsdatum") Is System.DBNull.Value Then
                        m_daArchivierungsdatum = SqlDateTime.Null
                    Else
                        m_daArchivierungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("archivierungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("termin") Is System.DBNull.Value Then
                        m_daTermin = SqlDateTime.Null
                    Else
                        m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("termin"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiererteam") Is System.DBNull.Value Then
                        m_iMutiererteam = SqlInt32.Null
                    Else
                        m_iMutiererteam = New SqlInt32(CType(dtToReturn.Rows(0)("mutiererteam"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokument::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokument_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokument::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokument Fields

clsTempdokument overview

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBereit_zur_archivierung
field m_bEingangsarchiviert
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iBarcodenr
field m_iColdstatus
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMutierer
field m_iMutiererteam
field m_iMutierertieam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokument Class


m_bAktiv Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bAmsdokument Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bAuserstuebernahme Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bAusgangsarchiviert Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bBereit_zur_archivierung Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bEingangsarchiviert Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bGesperrt Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bUnvollstaendig Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bVertraulich Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bZu_retournieren Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_bZustaendig_kube Variable

Private 		m_bGesperrt, _
   m_bAusgangsarchiviert, _
   m_bEingangsarchiviert, _
   m_bZu_retournieren, _
   m_bBereit_zur_archivierung, _
   m_bUnvollstaendig, _
   m_bAmsdokument, _
   m_bAuserstuebernahme, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bAusgangsarchiviert, m_bEingangsarchiviert, m_bZu_retournieren, m_bBereit_zur_archivierung, m_bUnvollstaendig, m_bAmsdokument, m_bAuserstuebernahme, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daArchivierungsdatum Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daDatum_ausgangsarchivierung Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daDatum_eingangsarchivierung Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daErstelltam Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daErstellungsdatum Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daGesperrtam Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daMutiertam Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_daTermin Variable

Private 		m_daGesperrtam, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daErstellungsdatum, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daMutiertam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daTermin, m_daArchivierungsdatum, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daMutiertam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iBarcodenr Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iColdstatus Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iDokumenttypnr Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iErsteller Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iErstellerteam Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iGesperrt_durch Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMa_ausgangsarchivierung Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMa_eingangsarchivierung Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMitarbeiternr Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMitarbeiternr1 Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMutierer Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMutiererteam Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iMutierertieam Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iNrpar00 Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iPostzustellung Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iStatus_edoka_batch_ausgang Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iStatus_edoka_batch_eingang Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iStatusnr Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iUnterschriftlinks Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iUnterschriftrechts Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iVerantwortlich Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_iZustaendiger Variable

Private 		m_iStatus_edoka_batch_ausgang, _
   m_iStatus_edoka_batch_eingang, _
   m_iColdstatus, _
   m_iPostzustellung, _
   m_iUnterschriftrechts, _
   m_iMutiererteam, _
   m_iStatusnr, _
   m_iVerantwortlich, _
   m_iBarcodenr, _
   m_iUnterschriftlinks, _
   m_iZustaendiger, _
   m_iErstellerteam, _
   m_iNrpar00, _
   m_iMutierer, _
   m_iMutierertieam, _
   m_iGesperrt_durch, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung, _
   m_iMa_eingangsarchivierung, _
   m_iErsteller, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang, m_iColdstatus, m_iPostzustellung, m_iUnterschriftrechts, m_iMutiererteam, m_iStatusnr, m_iVerantwortlich, m_iBarcodenr, m_iUnterschriftlinks, m_iZustaendiger, m_iErstellerteam, m_iNrpar00, m_iMutierer, m_iMutierertieam, m_iGesperrt_durch, m_iDokumenttypnr, m_iMa_ausgangsarchivierung, m_iMa_eingangsarchivierung, m_iErsteller, m_iMitarbeiternr1, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sBemerkung Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sBemerkunguvm Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sBezeichnung Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sColddokumentid Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sDokumentid Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sDokumentidn Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sDokumentname Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sLoeschgrund Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sSpeicherort Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sVersandadresse Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


m_sZustelladresse Variable

Private 		m_sDokumentidn, _
   m_sDokumentid, _
   m_sDokumentname, _
   m_sZustelladresse, _
   m_sVersandadresse, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentidn, m_sDokumentid, m_sDokumentname, m_sZustelladresse, m_sVersandadresse, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokument


clsTempdokumentcoldindexwert Class

For a list of all members of this type, see clsTempdokumentcoldindexwert Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempdokumentcoldindexwert

Public Class clsTempdokumentcoldindexwert
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempdokumentcoldindexwert Members


clsTempdokumentcoldindexwert Members

clsTempdokumentcoldindexwert overview

Constructors

constructor clsTempdokumentcoldindexwert Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_indexfeldnr
property iCold_indexfeldnrOld
property iColdindexwertnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sWert

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWcold_indexfeldnrLogic
method SelectOne
method Update
method UpdateAllWcold_indexfeldnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_indexfeldnr
field m_iCold_indexfeldnrOld
field m_iColdindexwertnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sDokumentid
field m_sWert
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentcoldindexwert Class


clsTempdokumentcoldindexwert Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert Properties

clsTempdokumentcoldindexwert overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iCold_indexfeldnr
property iCold_indexfeldnrOld
property iColdindexwertnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sWert

See Also

clsTempdokumentcoldindexwert Class


clsTempdokumentcoldindexwert.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.iCold_indexfeldnr Property

Public Property [iCold_indexfeldnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_indexfeldnr]() As SqlInt32
            Get
                Return m_iCold_indexfeldnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_indexfeldnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.iCold_indexfeldnrOld Property

Public Property [iCold_indexfeldnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iCold_indexfeldnrOld]() As SqlInt32
            Get
                Return m_iCold_indexfeldnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iCold_indexfeldnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.iColdindexwertnr Property

Public Property [iColdindexwertnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdindexwertnr]() As SqlInt32
            Get
                Return m_iColdindexwertnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iColdindexwertnrTmp As SqlInt32 = Value
                If iColdindexwertnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iColdindexwertnr", "iColdindexwertnr can't be NULL")
                End If
                m_iColdindexwertnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.sWert Property

Public Property [sWert]() As SqlString

Source code

[Visual Basic]
        Public Property [sWert]() As SqlString
            Get
                Return m_sWert
            End Get
            Set(ByVal Value As SqlString)
                m_sWert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert Methods

clsTempdokumentcoldindexwert overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWcold_indexfeldnrLogic
method SelectOne
method Update
method UpdateAllWcold_indexfeldnrLogic

See Also

clsTempdokumentcoldindexwert Class


clsTempdokumentcoldindexwert.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iColdindexwertnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@icoldindexwertnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentcoldindexwert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.SelectAllWcold_indexfeldnrLogic Method

Public Function SelectAllWcold_indexfeldnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWcold_indexfeldnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_SelectAllWcold_indexfeldnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentcoldindexwert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_SelectAllWcold_indexfeldnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::SelectAllWcold_indexfeldnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentcoldindexwert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iColdindexwertnr = New SqlInt32(CType(dtToReturn.Rows(0)("coldindexwertnr"), Integer))
                    If dtToReturn.Rows(0)("wert") Is System.DBNull.Value Then
                        m_sWert = SqlString.Null
                    Else
                        m_sWert = New SqlString(CType(dtToReturn.Rows(0)("wert"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("cold_indexfeldnr") Is System.DBNull.Value Then
                        m_iCold_indexfeldnr = SqlInt32.Null
                    Else
                        m_iCold_indexfeldnr = New SqlInt32(CType(dtToReturn.Rows(0)("cold_indexfeldnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldindexwertnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iColdindexwertnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert.UpdateAllWcold_indexfeldnrLogic Method

Public Function UpdateAllWcold_indexfeldnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWcold_indexfeldnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentcoldindexwert_UpdateAllWcold_indexfeldnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@icold_indexfeldnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_indexfeldnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentcoldindexwert_UpdateAllWcold_indexfeldnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentcoldindexwert::UpdateAllWcold_indexfeldnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentcoldindexwert Fields

clsTempdokumentcoldindexwert overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iCold_indexfeldnr
field m_iCold_indexfeldnrOld
field m_iColdindexwertnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_sDokumentid
field m_sWert
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentcoldindexwert Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_iCold_indexfeldnr Variable

Private 		m_iMutierer, _
   m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iColdindexwertnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iColdindexwertnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_iCold_indexfeldnrOld Variable

Private 		m_iMutierer, _
   m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iColdindexwertnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iColdindexwertnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_iColdindexwertnr Variable

Private 		m_iMutierer, _
   m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iColdindexwertnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iColdindexwertnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iColdindexwertnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iColdindexwertnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iCold_indexfeldnr, _
   m_iCold_indexfeldnrOld, _
   m_iColdindexwertnr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iCold_indexfeldnr, m_iCold_indexfeldnrOld, m_iColdindexwertnr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_sDokumentid Variable

Private 		m_sDokumentid, _
   m_sWert As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sWert As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


m_sWert Variable

Private 		m_sDokumentid, _
   m_sWert As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sWert As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentcoldindexwert


clsTempdokumentinfo_wert Class

For a list of all members of this type, see clsTempdokumentinfo_wert Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempdokumentinfo_wert

Public Class clsTempdokumentinfo_wert
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempdokumentinfo_wert Members


clsTempdokumentinfo_wert Members

clsTempdokumentinfo_wert overview

Constructors

constructor clsTempdokumentinfo_wert Constructor

Properties

property bAktiv
property bAktiv1
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentinfonr
property iDokumentinformationnr
property iDokumentinformationnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iVorlagenfeldnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sInhalt

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentinformationnrLogic
method SelectOne
method Update
method UpdateAllWdokumentinformationnrLogic

Fields

field m_bAktiv
field m_bAktiv1
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentinfonr
field m_iDokumentinformationnr
field m_iDokumentinformationnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iVorlagenfeldnr
field m_sDokumentid
field m_sInhalt
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentinfo_wert Class


clsTempdokumentinfo_wert Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert Properties

clsTempdokumentinfo_wert overview

Properties

property bAktiv
property bAktiv1
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumentinfonr
property iDokumentinformationnr
property iDokumentinformationnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iVorlagenfeldnr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sInhalt

See Also

clsTempdokumentinfo_wert Class


clsTempdokumentinfo_wert.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.bAktiv1 Property

Public Property [bAktiv1]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv1]() As SqlBoolean
            Get
                Return m_bAktiv1
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iDokumentinfonr Property

Public Property [iDokumentinfonr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentinfonr]() As SqlInt32
            Get
                Return m_iDokumentinfonr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iDokumentinfonrTmp As SqlInt32 = Value
                If iDokumentinfonrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iDokumentinfonr", "iDokumentinfonr can't be NULL")
                End If
                m_iDokumentinfonr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iDokumentinformationnr Property

Public Property [iDokumentinformationnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentinformationnr]() As SqlInt32
            Get
                Return m_iDokumentinformationnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentinformationnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iDokumentinformationnrOld Property

Public Property [iDokumentinformationnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumentinformationnrOld]() As SqlInt32
            Get
                Return m_iDokumentinformationnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumentinformationnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.iVorlagenfeldnr Property

Public Property [iVorlagenfeldnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeldnr]() As SqlInt32
            Get
                Return m_iVorlagenfeldnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlagenfeldnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.sInhalt Property

Public Property [sInhalt]() As SqlString

Source code

[Visual Basic]
        Public Property [sInhalt]() As SqlString
            Get
                Return m_sInhalt
            End Get
            Set(ByVal Value As SqlString)
                m_sInhalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert Methods

clsTempdokumentinfo_wert overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumentinformationnrLogic
method SelectOne
method Update
method UpdateAllWdokumentinformationnrLogic

See Also

clsTempdokumentinfo_wert Class


clsTempdokumentinfo_wert.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinfonr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinformationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinfonr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iDokumentinfonr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@idokumentinfonr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentinfo_wert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.SelectAllWdokumentinformationnrLogic Method

Public Function SelectAllWdokumentinformationnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWdokumentinformationnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_SelectAllWdokumentinformationnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentinfo_wert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinformationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_SelectAllWdokumentinformationnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::SelectAllWdokumentinformationnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentinfo_wert")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinfonr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iDokumentinfonr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentinfonr"), Integer))
                    If dtToReturn.Rows(0)("inhalt") Is System.DBNull.Value Then
                        m_sInhalt = SqlString.Null
                    Else
                        m_sInhalt = New SqlString(CType(dtToReturn.Rows(0)("inhalt"), String))
                    End If
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv1") Is System.DBNull.Value Then
                        m_bAktiv1 = SqlBoolean.Null
                    Else
                        m_bAktiv1 = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv1"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentinformationnr") Is System.DBNull.Value Then
                        m_iDokumentinformationnr = SqlInt32.Null
                    Else
                        m_iDokumentinformationnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentinformationnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("vorlagenfeldnr") Is System.DBNull.Value Then
                        m_iVorlagenfeldnr = SqlInt32.Null
                    Else
                        m_iVorlagenfeldnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentinfonr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinfonr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sinhalt", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sInhalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv1", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinformationnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert.UpdateAllWdokumentinformationnrLogic Method

Public Function UpdateAllWdokumentinformationnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWdokumentinformationnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentinfo_wert_UpdateAllWdokumentinformationnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentinformationnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinformationnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumentinformationnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentinformationnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentinfo_wert_UpdateAllWdokumentinformationnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentinfo_wert::UpdateAllWdokumentinformationnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentinfo_wert Fields

clsTempdokumentinfo_wert overview

Fields

field m_bAktiv
field m_bAktiv1
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumentinfonr
field m_iDokumentinformationnr
field m_iDokumentinformationnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iVorlagenfeldnr
field m_sDokumentid
field m_sInhalt
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentinfo_wert Class


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bAktiv1 As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bAktiv1 As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_bAktiv1 Variable

Private 		m_bAktiv, _
   m_bAktiv1 As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bAktiv1 As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iDokumentinfonr Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iDokumentinformationnr Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iDokumentinformationnrOld Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_iVorlagenfeldnr Variable

Private 		m_iMutierer, _
   m_iDokumentinformationnr, _
   m_iDokumentinformationnrOld, _
   m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumentinfonr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iDokumentinformationnr, m_iDokumentinformationnrOld, m_iVorlagenfeldnr, m_iMandantnr, m_iDokumentinfonr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_sDokumentid Variable

Private 		m_sDokumentid, _
   m_sInhalt As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sInhalt As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


m_sInhalt Variable

Private 		m_sDokumentid, _
   m_sInhalt As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sInhalt As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentinfo_wert


clsTempdokumentmutation_cold Class

For a list of all members of this type, see clsTempdokumentmutation_cold Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempdokumentmutation_cold

Public Class clsTempdokumentmutation_cold
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempdokumentmutation_cold Members


clsTempdokumentmutation_cold Members

clsTempdokumentmutation_cold overview

Constructors

constructor clsTempdokumentmutation_cold Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutationsdatum
property daMutiert_am
property daStatusdatum
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNreintrag
property iStatus
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutationsdatum
field m_daMutiert_am
field m_daStatusdatum
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNreintrag
field m_iStatus
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentmutation_cold Class


clsTempdokumentmutation_cold Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold Properties

clsTempdokumentmutation_cold overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutationsdatum
property daMutiert_am
property daStatusdatum
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNreintrag
property iStatus
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

See Also

clsTempdokumentmutation_cold Class


clsTempdokumentmutation_cold.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.daMutationsdatum Property

Public Property [daMutationsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutationsdatum]() As SqlDateTime
            Get
                Return m_daMutationsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daMutationsdatumTmp As SqlDateTime = Value
                If daMutationsdatumTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daMutationsdatum", "daMutationsdatum can't be NULL")
                End If
                m_daMutationsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.daStatusdatum Property

Public Property [daStatusdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daStatusdatum]() As SqlDateTime
            Get
                Return m_daStatusdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daStatusdatumTmp As SqlDateTime = Value
                If daStatusdatumTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daStatusdatum", "daStatusdatum can't be NULL")
                End If
                m_daStatusdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.iNreintrag Property

Public Property [iNreintrag]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNreintrag]() As SqlInt32
            Get
                Return m_iNreintrag
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNreintragTmp As SqlInt32 = Value
                If iNreintragTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNreintrag", "iNreintrag can't be NULL")
                End If
                m_iNreintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatusTmp As SqlInt32 = Value
                If iStatusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatus", "iStatus can't be NULL")
                End If
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold Methods

clsTempdokumentmutation_cold overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTempdokumentmutation_cold Class


clsTempdokumentmutation_cold.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentmutation_cold_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentmutation_cold_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentmutation_cold::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentmutation_cold_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutationsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutationsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dastatusdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daStatusdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentmutation_cold_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentmutation_cold::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentmutation_cold_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentmutation_cold")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentmutation_cold_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentmutation_cold::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentmutation_cold_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentmutation_cold")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentmutation_cold_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNreintrag = New SqlInt32(CType(dtToReturn.Rows(0)("nreintrag"), Integer))
                    m_daMutationsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("mutationsdatum"), Date))
                    m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    m_daStatusdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("statusdatum"), Date))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentmutation_cold::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentmutation_cold_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutationsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutationsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dastatusdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daStatusdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentmutation_cold_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentmutation_cold::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentmutation_cold Fields

clsTempdokumentmutation_cold overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutationsdatum
field m_daMutiert_am
field m_daStatusdatum
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNreintrag
field m_iStatus
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentmutation_cold Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_daErstellt_am Variable

Private 		m_daStatusdatum, _
   m_daErstellt_am, _
   m_daMutationsdatum, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daStatusdatum, m_daErstellt_am, m_daMutationsdatum, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_daMutationsdatum Variable

Private 		m_daStatusdatum, _
   m_daErstellt_am, _
   m_daMutationsdatum, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daStatusdatum, m_daErstellt_am, m_daMutationsdatum, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_daMutiert_am Variable

Private 		m_daStatusdatum, _
   m_daErstellt_am, _
   m_daMutationsdatum, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daStatusdatum, m_daErstellt_am, m_daMutationsdatum, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_daStatusdatum Variable

Private 		m_daStatusdatum, _
   m_daErstellt_am, _
   m_daMutationsdatum, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daStatusdatum, m_daErstellt_am, m_daMutationsdatum, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iStatus, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iStatus, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iStatus, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iStatus, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_iNreintrag Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iStatus, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iStatus, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_iStatus Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iStatus, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iStatus, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


m_sDokumentid Variable

Private 		m_sDokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentmutation_cold


clsTempdokumentzuordnungen Class

For a list of all members of this type, see clsTempdokumentzuordnungen Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempdokumentzuordnungen

Public Class clsTempdokumentzuordnungen
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempdokumentzuordnungen Members


clsTempdokumentzuordnungen Members

clsTempdokumentzuordnungen overview

Constructors

constructor clsTempdokumentzuordnungen Constructor

Properties

property bAktiv
property bUntergeordnet
property bZugeordnet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNreintrag
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentid1
property sDokumentid2

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUntergeordnet
field m_bZugeordnet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNreintrag
field m_sDokumentid
field m_sDokumentid1
field m_sDokumentid2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentzuordnungen Class


clsTempdokumentzuordnungen Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen Properties

clsTempdokumentzuordnungen overview

Properties

property bAktiv
property bUntergeordnet
property bZugeordnet
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNreintrag
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentid1
property sDokumentid2

See Also

clsTempdokumentzuordnungen Class


clsTempdokumentzuordnungen.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.bUntergeordnet Property

Public Property [bUntergeordnet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUntergeordnet]() As SqlBoolean
            Get
                Return m_bUntergeordnet
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bUntergeordnetTmp As SqlBoolean = Value
                If bUntergeordnetTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bUntergeordnet", "bUntergeordnet can't be NULL")
                End If
                m_bUntergeordnet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.bZugeordnet Property

Public Property [bZugeordnet]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZugeordnet]() As SqlBoolean
            Get
                Return m_bZugeordnet
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bZugeordnetTmp As SqlBoolean = Value
                If bZugeordnetTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bZugeordnet", "bZugeordnet can't be NULL")
                End If
                m_bZugeordnet = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.iNreintrag Property

Public Property [iNreintrag]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNreintrag]() As SqlInt32
            Get
                Return m_iNreintrag
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNreintragTmp As SqlInt32 = Value
                If iNreintragTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNreintrag", "iNreintrag can't be NULL")
                End If
                m_iNreintrag = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.sDokumentid1 Property

Public Property [sDokumentid1]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid1]() As SqlString
            Get
                Return m_sDokumentid1
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.sDokumentid2 Property

Public Property [sDokumentid2]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid2]() As SqlString
            Get
                Return m_sDokumentid2
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen Methods

clsTempdokumentzuordnungen overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTempdokumentzuordnungen Class


clsTempdokumentzuordnungen.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentzuordnungen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentzuordnungen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentzuordnungen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentzuordnungen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@buntergeordnet", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUntergeordnet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzugeordnet", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZugeordnet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid1", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid2", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid2))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentzuordnungen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentzuordnungen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentzuordnungen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentzuordnungen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentzuordnungen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentzuordnungen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentzuordnungen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempdokumentzuordnungen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentzuordnungen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNreintrag = New SqlInt32(CType(dtToReturn.Rows(0)("nreintrag"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    m_bUntergeordnet = New SqlBoolean(CType(dtToReturn.Rows(0)("untergeordnet"), Boolean))
                    m_bZugeordnet = New SqlBoolean(CType(dtToReturn.Rows(0)("zugeordnet"), Boolean))
                    If dtToReturn.Rows(0)("dokumentid1") Is System.DBNull.Value Then
                        m_sDokumentid1 = SqlString.Null
                    Else
                        m_sDokumentid1 = New SqlString(CType(dtToReturn.Rows(0)("dokumentid1"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentid2") Is System.DBNull.Value Then
                        m_sDokumentid2 = SqlString.Null
                    Else
                        m_sDokumentid2 = New SqlString(CType(dtToReturn.Rows(0)("dokumentid2"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentzuordnungen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempdokumentzuordnungen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inreintrag", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNreintrag))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@buntergeordnet", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUntergeordnet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzugeordnet", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZugeordnet))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid1", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid2", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid2))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempdokumentzuordnungen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempdokumentzuordnungen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempdokumentzuordnungen Fields

clsTempdokumentzuordnungen overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUntergeordnet
field m_bZugeordnet
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNreintrag
field m_sDokumentid
field m_sDokumentid1
field m_sDokumentid2
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempdokumentzuordnungen Class


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bUntergeordnet, _
   m_bZugeordnet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bUntergeordnet, m_bZugeordnet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_bUntergeordnet Variable

Private 		m_bAktiv, _
   m_bUntergeordnet, _
   m_bZugeordnet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bUntergeordnet, m_bZugeordnet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_bZugeordnet Variable

Private 		m_bAktiv, _
   m_bUntergeordnet, _
   m_bZugeordnet As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bUntergeordnet, m_bZugeordnet As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_daErstellt_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_daMutiert_am Variable

Private 		m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_iNreintrag Variable

Private 		m_iMutierer, _
   m_iNreintrag, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iNreintrag, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_sDokumentid Variable

Private 		m_sDokumentid2, _
   m_sDokumentid, _
   m_sDokumentid1 As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid2, m_sDokumentid, m_sDokumentid1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_sDokumentid1 Variable

Private 		m_sDokumentid2, _
   m_sDokumentid, _
   m_sDokumentid1 As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid2, m_sDokumentid, m_sDokumentid1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


m_sDokumentid2 Variable

Private 		m_sDokumentid2, _
   m_sDokumentid, _
   m_sDokumentid1 As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid2, m_sDokumentid, m_sDokumentid1 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempdokumentzuordnungen


clsTempnotizen Class

For a list of all members of this type, see clsTempnotizen Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempnotizen

Public Class clsTempnotizen
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempnotizen Members


clsTempnotizen Members

clsTempnotizen overview

Constructors

constructor clsTempnotizen Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sNotiz

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_sBetreff
field m_sDokumentid
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempnotizen Class


clsTempnotizen Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen Properties

clsTempnotizen overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iNotiznr
property sBetreff
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sNotiz

See Also

clsTempnotizen Class


clsTempnotizen.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.iNotiznr Property

Public Property [iNotiznr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNotiznr]() As SqlInt32
            Get
                Return m_iNotiznr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNotiznrTmp As SqlInt32 = Value
                If iNotiznrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNotiznr", "iNotiznr can't be NULL")
                End If
                m_iNotiznr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.sBetreff Property

Public Property [sBetreff]() As SqlString

Source code

[Visual Basic]
        Public Property [sBetreff]() As SqlString
            Get
                Return m_sBetreff
            End Get
            Set(ByVal Value As SqlString)
                m_sBetreff = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.sNotiz Property

Public Property [sNotiz]() As SqlString

Source code

[Visual Basic]
        Public Property [sNotiz]() As SqlString
            Get
                Return m_sNotiz
            End Get
            Set(ByVal Value As SqlString)
                m_sNotiz = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen Methods

clsTempnotizen overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTempnotizen Class


clsTempnotizen.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempnotizen_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempnotizen_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempnotizen::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempnotizen_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iNotiznr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@inotiznr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempnotizen_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempnotizen::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempnotizen_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempnotizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempnotizen_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempnotizen::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempnotizen_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempnotizen")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempnotizen_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNotiznr = New SqlInt32(CType(dtToReturn.Rows(0)("notiznr"), Integer))
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("betreff") Is System.DBNull.Value Then
                        m_sBetreff = SqlString.Null
                    Else
                        m_sBetreff = New SqlString(CType(dtToReturn.Rows(0)("betreff"), String))
                    End If
                    If dtToReturn.Rows(0)("notiz") Is System.DBNull.Value Then
                        m_sNotiz = SqlString.Null
                    Else
                        m_sNotiz = New SqlString(CType(dtToReturn.Rows(0)("notiz"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempnotizen::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempnotizen_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inotiznr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNotiznr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbetreff", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBetreff))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@snotiz", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNotiz))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempnotizen_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempnotizen::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempnotizen Fields

clsTempnotizen overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iNotiznr
field m_sBetreff
field m_sDokumentid
field m_sNotiz
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempnotizen Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_iNotiznr Variable

Private 		m_iMutierer, _
   m_iMandantnr, _
   m_iNotiznr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iMandantnr, m_iNotiznr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_sBetreff Variable

Private 		m_sDokumentid, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_sDokumentid Variable

Private 		m_sDokumentid, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


m_sNotiz Variable

Private 		m_sDokumentid, _
   m_sNotiz, _
   m_sBetreff As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid, m_sNotiz, m_sBetreff As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempnotizen


clsTempstatushistory Class

For a list of all members of this type, see clsTempstatushistory Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTempstatushistory

Public Class clsTempstatushistory
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTempstatushistory Members


clsTempstatushistory Members

clsTempstatushistory overview

Constructors

constructor clsTempstatushistory Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property iStatushistorynr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_iStatushistorynr
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempstatushistory Class


clsTempstatushistory Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory Properties

clsTempstatushistory overview

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iStatus
property iStatushistorynr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid

See Also

clsTempstatushistory Class


clsTempstatushistory.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.iStatus Property

Public Property [iStatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus]() As SqlInt32
            Get
                Return m_iStatus
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatusTmp As SqlInt32 = Value
                If iStatusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatus", "iStatus can't be NULL")
                End If
                m_iStatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.iStatushistorynr Property

Public Property [iStatushistorynr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatushistorynr]() As SqlInt32
            Get
                Return m_iStatushistorynr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iStatushistorynrTmp As SqlInt32 = Value
                If iStatushistorynrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iStatushistorynr", "iStatushistorynr can't be NULL")
                End If
                m_iStatushistorynr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory Methods

clsTempstatushistory overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTempstatushistory Class


clsTempstatushistory.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempstatushistory_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempstatushistory_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempstatushistory::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempstatushistory_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempstatushistory_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempstatushistory::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempstatushistory_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempstatushistory")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempstatushistory_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempstatushistory::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempstatushistory_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Tempstatushistory")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempstatushistory_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iStatushistorynr = New SqlInt32(CType(dtToReturn.Rows(0)("statushistorynr"), Integer))
                    m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
                        m_sDokumentid = SqlString.Null
                    Else
                        m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempstatushistory::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Tempstatushistory_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Tempstatushistory_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTempstatushistory::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTempstatushistory Fields

clsTempstatushistory overview

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iStatus
field m_iStatushistorynr
field m_sDokumentid
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTempstatushistory Class


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_iMandantnr Variable

Private 		m_iStatus, _
   m_iMutierer, _
   m_iStatushistorynr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus, m_iMutierer, m_iStatushistorynr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_iMutierer Variable

Private 		m_iStatus, _
   m_iMutierer, _
   m_iStatushistorynr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus, m_iMutierer, m_iStatushistorynr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_iStatus Variable

Private 		m_iStatus, _
   m_iMutierer, _
   m_iStatushistorynr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus, m_iMutierer, m_iStatushistorynr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_iStatushistorynr Variable

Private 		m_iStatus, _
   m_iMutierer, _
   m_iStatushistorynr, _
   m_iMandantnr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus, m_iMutierer, m_iStatushistorynr, m_iMandantnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


m_sDokumentid Variable

Private 		m_sDokumentid As SqlString

Source code

[Visual Basic]
        Private 		m_sDokumentid As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTempstatushistory


clsTmpdokument Class

For a list of all members of this type, see clsTmpdokument Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsTmpdokument

Public Class clsTmpdokument
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsTmpdokument Members


clsTmpdokument Members

clsTmpdokument overview

Constructors

constructor clsTmpdokument Constructor

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBereit_zur_archivierung
property bEingangsarchiviert
property bGesperrt
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iBarcodenr
property iColdstatus
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMutierer
property iMutiererteam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sZustelladresse

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBereit_zur_archivierung
field m_bEingangsarchiviert
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iBarcodenr
field m_iColdstatus
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMutierer
field m_iMutiererteam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTmpdokument Class


clsTmpdokument Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument Properties

clsTmpdokument overview

Properties

property bAktiv
property bAmsdokument
property bAuserstuebernahme
property bAusgangsarchiviert
property bBereit_zur_archivierung
property bEingangsarchiviert
property bGesperrt
property bUnvollstaendig
property bVertraulich
property bZu_retournieren
property bZustaendig_kube
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daArchivierungsdatum
property daDatum_ausgangsarchivierung
property daDatum_eingangsarchivierung
property daErstelltam
property daErstellungsdatum
property daGesperrtam
property daMutiertam
property daTermin
property iBarcodenr
property iColdstatus
property iDokumenttypnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErsteller
property iErstellerteam
property iGesperrt_durch
property iMa_ausgangsarchivierung
property iMa_eingangsarchivierung
property iMitarbeiternr
property iMitarbeiternr1
property iMutierer
property iMutiererteam
property iNrpar00
property iPostzustellung
property iStatus_edoka_batch_ausgang
property iStatus_edoka_batch_eingang
property iStatusnr
property iUnterschriftlinks
property iUnterschriftrechts
property iVerantwortlich
property iZustaendiger
property sBemerkung
property sBemerkunguvm
property sBezeichnung
property sColddokumentid
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDokumentid
property sDokumentidn
property sDokumentname
property sLoeschgrund
property sSpeicherort
property sVersandadresse
property sZustelladresse

See Also

clsTmpdokument Class


clsTmpdokument.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bAmsdokument Property

Public Property [bAmsdokument]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAmsdokument]() As SqlBoolean
            Get
                Return m_bAmsdokument
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAmsdokument = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bAuserstuebernahme Property

Public Property [bAuserstuebernahme]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAuserstuebernahme]() As SqlBoolean
            Get
                Return m_bAuserstuebernahme
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAuserstuebernahme = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bAusgangsarchiviert Property

Public Property [bAusgangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAusgangsarchiviert]() As SqlBoolean
            Get
                Return m_bAusgangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAusgangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bBereit_zur_archivierung Property

Public Property [bBereit_zur_archivierung]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bBereit_zur_archivierung]() As SqlBoolean
            Get
                Return m_bBereit_zur_archivierung
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bBereit_zur_archivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bEingangsarchiviert Property

Public Property [bEingangsarchiviert]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEingangsarchiviert]() As SqlBoolean
            Get
                Return m_bEingangsarchiviert
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEingangsarchiviert = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bGesperrt Property

Public Property [bGesperrt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bGesperrt]() As SqlBoolean
            Get
                Return m_bGesperrt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bGesperrt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bUnvollstaendig Property

Public Property [bUnvollstaendig]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bUnvollstaendig]() As SqlBoolean
            Get
                Return m_bUnvollstaendig
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bUnvollstaendig = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bVertraulich Property

Public Property [bVertraulich]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bVertraulich]() As SqlBoolean
            Get
                Return m_bVertraulich
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bVertraulich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bZu_retournieren Property

Public Property [bZu_retournieren]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZu_retournieren]() As SqlBoolean
            Get
                Return m_bZu_retournieren
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZu_retournieren = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.bZustaendig_kube Property

Public Property [bZustaendig_kube]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bZustaendig_kube]() As SqlBoolean
            Get
                Return m_bZustaendig_kube
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bZustaendig_kube = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daArchivierungsdatum Property

Public Property [daArchivierungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daArchivierungsdatum]() As SqlDateTime
            Get
                Return m_daArchivierungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daArchivierungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daDatum_ausgangsarchivierung Property

Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daDatum_eingangsarchivierung Property

Public Property [daDatum_eingangsarchivierung]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daDatum_eingangsarchivierung]() As SqlDateTime
            Get
                Return m_daDatum_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daDatum_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daErstelltam Property

Public Property [daErstelltam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstelltam]() As SqlDateTime
            Get
                Return m_daErstelltam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstelltam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daErstellungsdatum Property

Public Property [daErstellungsdatum]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellungsdatum]() As SqlDateTime
            Get
                Return m_daErstellungsdatum
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellungsdatum = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daGesperrtam Property

Public Property [daGesperrtam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daGesperrtam]() As SqlDateTime
            Get
                Return m_daGesperrtam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daGesperrtam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daMutiertam Property

Public Property [daMutiertam]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiertam]() As SqlDateTime
            Get
                Return m_daMutiertam
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiertam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.daTermin Property

Public Property [daTermin]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daTermin]() As SqlDateTime
            Get
                Return m_daTermin
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daTermin = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iBarcodenr Property

Public Property [iBarcodenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iBarcodenr]() As SqlInt32
            Get
                Return m_iBarcodenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iBarcodenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iColdstatus Property

Public Property [iColdstatus]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iColdstatus]() As SqlInt32
            Get
                Return m_iColdstatus
            End Get
            Set(ByVal Value As SqlInt32)
                m_iColdstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iDokumenttypnr Property

Public Property [iDokumenttypnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iDokumenttypnr]() As SqlInt32
            Get
                Return m_iDokumenttypnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iDokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iErsteller Property

Public Property [iErsteller]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErsteller]() As SqlInt32
            Get
                Return m_iErsteller
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErsteller = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iErstellerteam Property

Public Property [iErstellerteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iErstellerteam]() As SqlInt32
            Get
                Return m_iErstellerteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iErstellerteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iGesperrt_durch Property

Public Property [iGesperrt_durch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iGesperrt_durch]() As SqlInt32
            Get
                Return m_iGesperrt_durch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iGesperrt_durch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMa_ausgangsarchivierung Property

Public Property [iMa_ausgangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_ausgangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_ausgangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_ausgangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMa_eingangsarchivierung Property

Public Property [iMa_eingangsarchivierung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMa_eingangsarchivierung]() As SqlInt32
            Get
                Return m_iMa_eingangsarchivierung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMa_eingangsarchivierung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMitarbeiternr1 Property

Public Property [iMitarbeiternr1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr1]() As SqlInt32
            Get
                Return m_iMitarbeiternr1
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iMutiererteam Property

Public Property [iMutiererteam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutiererteam]() As SqlInt32
            Get
                Return m_iMutiererteam
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutiererteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iNrpar00 Property

Public Property [iNrpar00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNrpar00]() As SqlInt32
            Get
                Return m_iNrpar00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNrpar00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iPostzustellung Property

Public Property [iPostzustellung]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iPostzustellung]() As SqlInt32
            Get
                Return m_iPostzustellung
            End Get
            Set(ByVal Value As SqlInt32)
                m_iPostzustellung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iStatus_edoka_batch_ausgang Property

Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_ausgang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_ausgang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iStatus_edoka_batch_eingang Property

Public Property [iStatus_edoka_batch_eingang]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatus_edoka_batch_eingang]() As SqlInt32
            Get
                Return m_iStatus_edoka_batch_eingang
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatus_edoka_batch_eingang = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iStatusnr Property

Public Property [iStatusnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iStatusnr]() As SqlInt32
            Get
                Return m_iStatusnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iStatusnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iVerantwortlich Property

Public Property [iVerantwortlich]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVerantwortlich]() As SqlInt32
            Get
                Return m_iVerantwortlich
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVerantwortlich = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.iZustaendiger Property

Public Property [iZustaendiger]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iZustaendiger]() As SqlInt32
            Get
                Return m_iZustaendiger
            End Get
            Set(ByVal Value As SqlInt32)
                m_iZustaendiger = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sBemerkung Property

Public Property [sBemerkung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkung]() As SqlString
            Get
                Return m_sBemerkung
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sBemerkunguvm Property

Public Property [sBemerkunguvm]() As SqlString

Source code

[Visual Basic]
        Public Property [sBemerkunguvm]() As SqlString
            Get
                Return m_sBemerkunguvm
            End Get
            Set(ByVal Value As SqlString)
                m_sBemerkunguvm = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sColddokumentid Property

Public Property [sColddokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sColddokumentid]() As SqlString
            Get
                Return m_sColddokumentid
            End Get
            Set(ByVal Value As SqlString)
                m_sColddokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sDokumentid Property

Public Property [sDokumentid]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentid]() As SqlString
            Get
                Return m_sDokumentid
            End Get
            Set(ByVal Value As SqlString)
                Dim sDokumentidTmp As SqlString = Value
                If sDokumentidTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
                End If
                m_sDokumentid = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sDokumentidn Property

Public Property [sDokumentidn]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentidn]() As SqlString
            Get
                Return m_sDokumentidn
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentidn = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sDokumentname Property

Public Property [sDokumentname]() As SqlString

Source code

[Visual Basic]
        Public Property [sDokumentname]() As SqlString
            Get
                Return m_sDokumentname
            End Get
            Set(ByVal Value As SqlString)
                m_sDokumentname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sLoeschgrund Property

Public Property [sLoeschgrund]() As SqlString

Source code

[Visual Basic]
        Public Property [sLoeschgrund]() As SqlString
            Get
                Return m_sLoeschgrund
            End Get
            Set(ByVal Value As SqlString)
                m_sLoeschgrund = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sSpeicherort Property

Public Property [sSpeicherort]() As SqlString

Source code

[Visual Basic]
        Public Property [sSpeicherort]() As SqlString
            Get
                Return m_sSpeicherort
            End Get
            Set(ByVal Value As SqlString)
                m_sSpeicherort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sVersandadresse Property

Public Property [sVersandadresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sVersandadresse]() As SqlString
            Get
                Return m_sVersandadresse
            End Get
            Set(ByVal Value As SqlString)
                m_sVersandadresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.sZustelladresse Property

Public Property [sZustelladresse]() As SqlString

Source code

[Visual Basic]
        Public Property [sZustelladresse]() As SqlString
            Get
                Return m_sZustelladresse
            End Get
            Set(ByVal Value As SqlString)
                m_sZustelladresse = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument Methods

clsTmpdokument overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsTmpdokument Class


clsTmpdokument.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_tmpdokument_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_tmpdokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTmpdokument::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_tmpdokument_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_tmpdokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTmpdokument::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_tmpdokument_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("tmpdokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_tmpdokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTmpdokument::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_tmpdokument_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("tmpdokument")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_tmpdokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mitarbeiternr1") Is System.DBNull.Value Then
                        m_iMitarbeiternr1 = SqlInt32.Null
                    Else
                        m_iMitarbeiternr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr1"), Integer))
                    End If
                    If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
                        m_iNrpar00 = SqlInt32.Null
                    Else
                        m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("dokumentidn") Is System.DBNull.Value Then
                        m_sDokumentidn = SqlString.Null
                    Else
                        m_sDokumentidn = New SqlString(CType(dtToReturn.Rows(0)("dokumentidn"), String))
                    End If
                    If dtToReturn.Rows(0)("dokumentname") Is System.DBNull.Value Then
                        m_sDokumentname = SqlString.Null
                    Else
                        m_sDokumentname = New SqlString(CType(dtToReturn.Rows(0)("dokumentname"), String))
                    End If
                    If dtToReturn.Rows(0)("ersteller") Is System.DBNull.Value Then
                        m_iErsteller = SqlInt32.Null
                    Else
                        m_iErsteller = New SqlInt32(CType(dtToReturn.Rows(0)("ersteller"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstellerteam") Is System.DBNull.Value Then
                        m_iErstellerteam = SqlInt32.Null
                    Else
                        m_iErstellerteam = New SqlInt32(CType(dtToReturn.Rows(0)("erstellerteam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("erstelltam") Is System.DBNull.Value Then
                        m_daErstelltam = SqlDateTime.Null
                    Else
                        m_daErstelltam = New SqlDateTime(CType(dtToReturn.Rows(0)("erstelltam"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiererteam") Is System.DBNull.Value Then
                        m_iMutiererteam = SqlInt32.Null
                    Else
                        m_iMutiererteam = New SqlInt32(CType(dtToReturn.Rows(0)("mutiererteam"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiertam") Is System.DBNull.Value Then
                        m_daMutiertam = SqlDateTime.Null
                    Else
                        m_daMutiertam = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiertam"), Date))
                    End If
                    If dtToReturn.Rows(0)("speicherort") Is System.DBNull.Value Then
                        m_sSpeicherort = SqlString.Null
                    Else
                        m_sSpeicherort = New SqlString(CType(dtToReturn.Rows(0)("speicherort"), String))
                    End If
                    If dtToReturn.Rows(0)("gesperrt") Is System.DBNull.Value Then
                        m_bGesperrt = SqlBoolean.Null
                    Else
                        m_bGesperrt = New SqlBoolean(CType(dtToReturn.Rows(0)("gesperrt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("gesperrt_durch") Is System.DBNull.Value Then
                        m_iGesperrt_durch = SqlInt32.Null
                    Else
                        m_iGesperrt_durch = New SqlInt32(CType(dtToReturn.Rows(0)("gesperrt_durch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("gesperrtam") Is System.DBNull.Value Then
                        m_daGesperrtam = SqlDateTime.Null
                    Else
                        m_daGesperrtam = New SqlDateTime(CType(dtToReturn.Rows(0)("gesperrtam"), Date))
                    End If
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
                        m_sBemerkung = SqlString.Null
                    Else
                        m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
                    End If
                    If dtToReturn.Rows(0)("auserstuebernahme") Is System.DBNull.Value Then
                        m_bAuserstuebernahme = SqlBoolean.Null
                    Else
                        m_bAuserstuebernahme = New SqlBoolean(CType(dtToReturn.Rows(0)("auserstuebernahme"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
                        m_iDokumenttypnr = SqlInt32.Null
                    Else
                        m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unvollstaendig") Is System.DBNull.Value Then
                        m_bUnvollstaendig = SqlBoolean.Null
                    Else
                        m_bUnvollstaendig = New SqlBoolean(CType(dtToReturn.Rows(0)("unvollstaendig"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("bemerkunguvm") Is System.DBNull.Value Then
                        m_sBemerkunguvm = SqlString.Null
                    Else
                        m_sBemerkunguvm = New SqlString(CType(dtToReturn.Rows(0)("bemerkunguvm"), String))
                    End If
                    If dtToReturn.Rows(0)("bereit_zur_archivierung") Is System.DBNull.Value Then
                        m_bBereit_zur_archivierung = SqlBoolean.Null
                    Else
                        m_bBereit_zur_archivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("bereit_zur_archivierung"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("ausgangsarchiviert") Is System.DBNull.Value Then
                        m_bAusgangsarchiviert = SqlBoolean.Null
                    Else
                        m_bAusgangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("ausgangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_ausgangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_ausgangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_ausgangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_ausgangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_ausgangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_ausgangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_ausgangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zu_retournieren") Is System.DBNull.Value Then
                        m_bZu_retournieren = SqlBoolean.Null
                    Else
                        m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("eingangsarchiviert") Is System.DBNull.Value Then
                        m_bEingangsarchiviert = SqlBoolean.Null
                    Else
                        m_bEingangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("eingangsarchiviert"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("datum_eingangsarchivierung") Is System.DBNull.Value Then
                        m_daDatum_eingangsarchivierung = SqlDateTime.Null
                    Else
                        m_daDatum_eingangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_eingangsarchivierung"), Date))
                    End If
                    If dtToReturn.Rows(0)("ma_eingangsarchivierung") Is System.DBNull.Value Then
                        m_iMa_eingangsarchivierung = SqlInt32.Null
                    Else
                        m_iMa_eingangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_eingangsarchivierung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_ausgang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_ausgang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_ausgang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_ausgang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("status_edoka_batch_eingang") Is System.DBNull.Value Then
                        m_iStatus_edoka_batch_eingang = SqlInt32.Null
                    Else
                        m_iStatus_edoka_batch_eingang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_eingang"), Integer))
                    End If
                    If dtToReturn.Rows(0)("loeschgrund") Is System.DBNull.Value Then
                        m_sLoeschgrund = SqlString.Null
                    Else
                        m_sLoeschgrund = New SqlString(CType(dtToReturn.Rows(0)("loeschgrund"), String))
                    End If
                    If dtToReturn.Rows(0)("coldstatus") Is System.DBNull.Value Then
                        m_iColdstatus = SqlInt32.Null
                    Else
                        m_iColdstatus = New SqlInt32(CType(dtToReturn.Rows(0)("coldstatus"), Integer))
                    End If
                    If dtToReturn.Rows(0)("versandadresse") Is System.DBNull.Value Then
                        m_sVersandadresse = SqlString.Null
                    Else
                        m_sVersandadresse = New SqlString(CType(dtToReturn.Rows(0)("versandadresse"), String))
                    End If
                    If dtToReturn.Rows(0)("barcodenr") Is System.DBNull.Value Then
                        m_iBarcodenr = SqlInt32.Null
                    Else
                        m_iBarcodenr = New SqlInt32(CType(dtToReturn.Rows(0)("barcodenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("colddokumentid") Is System.DBNull.Value Then
                        m_sColddokumentid = SqlString.Null
                    Else
                        m_sColddokumentid = New SqlString(CType(dtToReturn.Rows(0)("colddokumentid"), String))
                    End If
                    If dtToReturn.Rows(0)("amsdokument") Is System.DBNull.Value Then
                        m_bAmsdokument = SqlBoolean.Null
                    Else
                        m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
                        m_iVerantwortlich = SqlInt32.Null
                    Else
                        m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendiger") Is System.DBNull.Value Then
                        m_iZustaendiger = SqlInt32.Null
                    Else
                        m_iZustaendiger = New SqlInt32(CType(dtToReturn.Rows(0)("zustaendiger"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftlinks") Is System.DBNull.Value Then
                        m_iUnterschriftlinks = SqlInt32.Null
                    Else
                        m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    End If
                    If dtToReturn.Rows(0)("unterschriftrechts") Is System.DBNull.Value Then
                        m_iUnterschriftrechts = SqlInt32.Null
                    Else
                        m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    End If
                    If dtToReturn.Rows(0)("postzustellung") Is System.DBNull.Value Then
                        m_iPostzustellung = SqlInt32.Null
                    Else
                        m_iPostzustellung = New SqlInt32(CType(dtToReturn.Rows(0)("postzustellung"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("statusnr") Is System.DBNull.Value Then
                        m_iStatusnr = SqlInt32.Null
                    Else
                        m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("statusnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("zustaendig_kube") Is System.DBNull.Value Then
                        m_bZustaendig_kube = SqlBoolean.Null
                    Else
                        m_bZustaendig_kube = New SqlBoolean(CType(dtToReturn.Rows(0)("zustaendig_kube"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("zustelladresse") Is System.DBNull.Value Then
                        m_sZustelladresse = SqlString.Null
                    Else
                        m_sZustelladresse = New SqlString(CType(dtToReturn.Rows(0)("zustelladresse"), String))
                    End If
                    If dtToReturn.Rows(0)("vertraulich") Is System.DBNull.Value Then
                        m_bVertraulich = SqlBoolean.Null
                    Else
                        m_bVertraulich = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellungsdatum") Is System.DBNull.Value Then
                        m_daErstellungsdatum = SqlDateTime.Null
                    Else
                        m_daErstellungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("archivierungsdatum") Is System.DBNull.Value Then
                        m_daArchivierungsdatum = SqlDateTime.Null
                    Else
                        m_daArchivierungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("archivierungsdatum"), Date))
                    End If
                    If dtToReturn.Rows(0)("termin") Is System.DBNull.Value Then
                        m_daTermin = SqlDateTime.Null
                    Else
                        m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("termin"), Date))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTmpdokument::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_tmpdokument_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_tmpdokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsTmpdokument::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsTmpdokument Fields

clsTmpdokument overview

Fields

field m_bAktiv
field m_bAmsdokument
field m_bAuserstuebernahme
field m_bAusgangsarchiviert
field m_bBereit_zur_archivierung
field m_bEingangsarchiviert
field m_bGesperrt
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bUnvollstaendig
field m_bVertraulich
field m_bZu_retournieren
field m_bZustaendig_kube
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daArchivierungsdatum
field m_daDatum_ausgangsarchivierung
field m_daDatum_eingangsarchivierung
field m_daErstelltam
field m_daErstellungsdatum
field m_daGesperrtam
field m_daMutiertam
field m_daTermin
field m_iBarcodenr
field m_iColdstatus
field m_iDokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErsteller
field m_iErstellerteam
field m_iGesperrt_durch
field m_iMa_ausgangsarchivierung
field m_iMa_eingangsarchivierung
field m_iMitarbeiternr
field m_iMitarbeiternr1
field m_iMutierer
field m_iMutiererteam
field m_iNrpar00
field m_iPostzustellung
field m_iStatus_edoka_batch_ausgang
field m_iStatus_edoka_batch_eingang
field m_iStatusnr
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_iVerantwortlich
field m_iZustaendiger
field m_sBemerkung
field m_sBemerkunguvm
field m_sBezeichnung
field m_sColddokumentid
field m_sDokumentid
field m_sDokumentidn
field m_sDokumentname
field m_sLoeschgrund
field m_sSpeicherort
field m_sVersandadresse
field m_sZustelladresse
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsTmpdokument Class


m_bAktiv Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bAmsdokument Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bAuserstuebernahme Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bAusgangsarchiviert Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bBereit_zur_archivierung Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bEingangsarchiviert Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bGesperrt Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bUnvollstaendig Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bVertraulich Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bZu_retournieren Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_bZustaendig_kube Variable

Private 		m_bGesperrt, _
   m_bUnvollstaendig, _
   m_bZu_retournieren, _
   m_bAusgangsarchiviert, _
   m_bAuserstuebernahme, _
   m_bBereit_zur_archivierung, _
   m_bAmsdokument, _
   m_bEingangsarchiviert, _
   m_bZustaendig_kube, _
   m_bVertraulich, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bGesperrt, m_bUnvollstaendig, m_bZu_retournieren, m_bAusgangsarchiviert, m_bAuserstuebernahme, m_bBereit_zur_archivierung, m_bAmsdokument, m_bEingangsarchiviert, m_bZustaendig_kube, m_bVertraulich, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daArchivierungsdatum Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daDatum_ausgangsarchivierung Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daDatum_eingangsarchivierung Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daErstelltam Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daErstellungsdatum Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daGesperrtam Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daMutiertam Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_daTermin Variable

Private 		m_daGesperrtam, _
   m_daErstellungsdatum, _
   m_daTermin, _
   m_daArchivierungsdatum, _
   m_daMutiertam, _
   m_daDatum_eingangsarchivierung, _
   m_daErstelltam, _
   m_daDatum_ausgangsarchivierung As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daGesperrtam, m_daErstellungsdatum, m_daTermin, m_daArchivierungsdatum, m_daMutiertam, m_daDatum_eingangsarchivierung, m_daErstelltam, m_daDatum_ausgangsarchivierung As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iBarcodenr Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iColdstatus Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iDokumenttypnr Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iErsteller Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iErstellerteam Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iGesperrt_durch Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMa_ausgangsarchivierung Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMa_eingangsarchivierung Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMitarbeiternr Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMitarbeiternr1 Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMutierer Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iMutiererteam Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iNrpar00 Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iPostzustellung Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iStatus_edoka_batch_ausgang Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iStatus_edoka_batch_eingang Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iStatusnr Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iUnterschriftlinks Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iUnterschriftrechts Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iVerantwortlich Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_iZustaendiger Variable

Private 		m_iStatus_edoka_batch_eingang, _
   m_iStatus_edoka_batch_ausgang, _
   m_iUnterschriftrechts, _
   m_iUnterschriftlinks, _
   m_iStatusnr, _
   m_iPostzustellung, _
   m_iBarcodenr, _
   m_iColdstatus, _
   m_iZustaendiger, _
   m_iVerantwortlich, _
   m_iMa_eingangsarchivierung, _
   m_iMutierer, _
   m_iErstellerteam, _
   m_iGesperrt_durch, _
   m_iMutiererteam, _
   m_iMitarbeiternr1, _
   m_iMitarbeiternr, _
   m_iErsteller, _
   m_iNrpar00, _
   m_iDokumenttypnr, _
   m_iMa_ausgangsarchivierung As SqlInt32

Source code

[Visual Basic]
        Private 		m_iStatus_edoka_batch_eingang, m_iStatus_edoka_batch_ausgang, m_iUnterschriftrechts, m_iUnterschriftlinks, m_iStatusnr, m_iPostzustellung, m_iBarcodenr, m_iColdstatus, m_iZustaendiger, m_iVerantwortlich, m_iMa_eingangsarchivierung, m_iMutierer, m_iErstellerteam, m_iGesperrt_durch, m_iMutiererteam, m_iMitarbeiternr1, m_iMitarbeiternr, m_iErsteller, m_iNrpar00, m_iDokumenttypnr, m_iMa_ausgangsarchivierung As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sBemerkung Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sBemerkunguvm Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sBezeichnung Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sColddokumentid Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sDokumentid Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sDokumentidn Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sDokumentname Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sLoeschgrund Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sSpeicherort Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sVersandadresse Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


m_sZustelladresse Variable

Private 		m_sZustelladresse, _
   m_sDokumentidn, _
   m_sDokumentid, _
   m_sBemerkunguvm, _
   m_sLoeschgrund, _
   m_sColddokumentid, _
   m_sSpeicherort, _
   m_sBezeichnung, _
   m_sDokumentname, _
   m_sVersandadresse, _
   m_sBemerkung As SqlString

Source code

[Visual Basic]
        Private 		m_sZustelladresse, m_sDokumentidn, m_sDokumentid, m_sBemerkunguvm, m_sLoeschgrund, m_sColddokumentid, m_sSpeicherort, m_sBezeichnung, m_sDokumentname, m_sVersandadresse, m_sBemerkung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsTmpdokument


clsVV Class

For a list of all members of this type, see clsVV Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsVV

Public Class clsVV
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsVV Members


clsVV Members

clsVV overview

Constructors

constructor clsVV Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property iNRPRD00
property iNRSPR00
property iNRVBS00
property iNRVVG00
property sBEPRDLG
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNAVVG00
property sNEVVG00
property sSAREC00
property sTXRBK00

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_iNRPRD00
field m_iNRSPR00
field m_iNRVBS00
field m_iNRVVG00
field m_sBEPRDLG
field m_sNAVVG00
field m_sNEVVG00
field m_sSAREC00
field m_sTXRBK00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVV Class


clsVV Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV Properties

clsVV overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iNRPAR00
property iNRPRD00
property iNRSPR00
property iNRVBS00
property iNRVVG00
property sBEPRDLG
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sNAVVG00
property sNEVVG00
property sSAREC00
property sTXRBK00

See Also

clsVV Class


clsVV.iNRPAR00 Property

Public Property [iNRPAR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPAR00]() As SqlInt32
            Get
                Return m_iNRPAR00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRPAR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.iNRPRD00 Property

Public Property [iNRPRD00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRPRD00]() As SqlInt32
            Get
                Return m_iNRPRD00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRPRD00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.iNRSPR00 Property

Public Property [iNRSPR00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRSPR00]() As SqlInt32
            Get
                Return m_iNRSPR00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRSPR00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.iNRVBS00 Property

Public Property [iNRVBS00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRVBS00]() As SqlInt32
            Get
                Return m_iNRVBS00
            End Get
            Set(ByVal Value As SqlInt32)
                m_iNRVBS00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.iNRVVG00 Property

Public Property [iNRVVG00]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iNRVVG00]() As SqlInt32
            Get
                Return m_iNRVVG00
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iNRVVG00Tmp As SqlInt32 = Value
                If iNRVVG00Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iNRVVG00", "iNRVVG00 can't be NULL")
                End If
                m_iNRVVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.sBEPRDLG Property

Public Property [sBEPRDLG]() As SqlString

Source code

[Visual Basic]
        Public Property [sBEPRDLG]() As SqlString
            Get
                Return m_sBEPRDLG
            End Get
            Set(ByVal Value As SqlString)
                m_sBEPRDLG = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.sNAVVG00 Property

Public Property [sNAVVG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNAVVG00]() As SqlString
            Get
                Return m_sNAVVG00
            End Get
            Set(ByVal Value As SqlString)
                m_sNAVVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.sNEVVG00 Property

Public Property [sNEVVG00]() As SqlString

Source code

[Visual Basic]
        Public Property [sNEVVG00]() As SqlString
            Get
                Return m_sNEVVG00
            End Get
            Set(ByVal Value As SqlString)
                m_sNEVVG00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.sSAREC00 Property

Public Property [sSAREC00]() As SqlString

Source code

[Visual Basic]
        Public Property [sSAREC00]() As SqlString
            Get
                Return m_sSAREC00
            End Get
            Set(ByVal Value As SqlString)
                m_sSAREC00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.sTXRBK00 Property

Public Property [sTXRBK00]() As SqlString

Source code

[Visual Basic]
        Public Property [sTXRBK00]() As SqlString
            Get
                Return m_sTXRBK00
            End Get
            Set(ByVal Value As SqlString)
                m_sTXRBK00 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV Methods

clsVV overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsVV Class


clsVV.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VV_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VV_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVV::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VV_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRSPR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRSPR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPRDLG", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPRDLG))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPRD00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPRD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRBK00", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRBK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNEVVG00", SqlDbType.VarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNEVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNAVVG00", SqlDbType.VarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNAVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVBS00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRVBS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VV_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVV::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VV_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("VV")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VV_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVV::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VV_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("VV")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VV_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iNRVVG00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRVVG00"), Integer))
                    If dtToReturn.Rows(0)("NRPAR00") Is System.DBNull.Value Then
                        m_iNRPAR00 = SqlInt32.Null
                    Else
                        m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("NRSPR00") Is System.DBNull.Value Then
                        m_iNRSPR00 = SqlInt32.Null
                    Else
                        m_iNRSPR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRSPR00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("BEPRDLG") Is System.DBNull.Value Then
                        m_sBEPRDLG = SqlString.Null
                    Else
                        m_sBEPRDLG = New SqlString(CType(dtToReturn.Rows(0)("BEPRDLG"), String))
                    End If
                    If dtToReturn.Rows(0)("NRPRD00") Is System.DBNull.Value Then
                        m_iNRPRD00 = SqlInt32.Null
                    Else
                        m_iNRPRD00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPRD00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("TXRBK00") Is System.DBNull.Value Then
                        m_sTXRBK00 = SqlString.Null
                    Else
                        m_sTXRBK00 = New SqlString(CType(dtToReturn.Rows(0)("TXRBK00"), String))
                    End If
                    If dtToReturn.Rows(0)("NEVVG00") Is System.DBNull.Value Then
                        m_sNEVVG00 = SqlString.Null
                    Else
                        m_sNEVVG00 = New SqlString(CType(dtToReturn.Rows(0)("NEVVG00"), String))
                    End If
                    If dtToReturn.Rows(0)("NAVVG00") Is System.DBNull.Value Then
                        m_sNAVVG00 = SqlString.Null
                    Else
                        m_sNAVVG00 = New SqlString(CType(dtToReturn.Rows(0)("NAVVG00"), String))
                    End If
                    If dtToReturn.Rows(0)("NRVBS00") Is System.DBNull.Value Then
                        m_iNRVBS00 = SqlInt32.Null
                    Else
                        m_iNRVBS00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRVBS00"), Integer))
                    End If
                    If dtToReturn.Rows(0)("SAREC00") Is System.DBNull.Value Then
                        m_sSAREC00 = SqlString.Null
                    Else
                        m_sSAREC00 = New SqlString(CType(dtToReturn.Rows(0)("SAREC00"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVV::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_VV_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVVG00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRSPR00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRSPR00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPRDLG", SqlDbType.NVarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPRDLG))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPRD00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRPRD00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRBK00", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRBK00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNEVVG00", SqlDbType.VarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNEVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sNAVVG00", SqlDbType.VarChar, 16, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNAVVG00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRVBS00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRVBS00))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAREC00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAREC00))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_VV_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVV::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVV Fields

clsVV overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iNRPAR00
field m_iNRPRD00
field m_iNRSPR00
field m_iNRVBS00
field m_iNRVVG00
field m_sBEPRDLG
field m_sNAVVG00
field m_sNEVVG00
field m_sSAREC00
field m_sTXRBK00
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVV Class


m_iNRPAR00 Variable

Private 		m_iNRPRD00, _
   m_iNRVBS00, _
   m_iNRSPR00, _
   m_iNRVVG00, _
   m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPRD00, m_iNRVBS00, m_iNRSPR00, m_iNRVVG00, m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_iNRPRD00 Variable

Private 		m_iNRPRD00, _
   m_iNRVBS00, _
   m_iNRSPR00, _
   m_iNRVVG00, _
   m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPRD00, m_iNRVBS00, m_iNRSPR00, m_iNRVVG00, m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_iNRSPR00 Variable

Private 		m_iNRPRD00, _
   m_iNRVBS00, _
   m_iNRSPR00, _
   m_iNRVVG00, _
   m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPRD00, m_iNRVBS00, m_iNRSPR00, m_iNRVVG00, m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_iNRVBS00 Variable

Private 		m_iNRPRD00, _
   m_iNRVBS00, _
   m_iNRSPR00, _
   m_iNRVVG00, _
   m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPRD00, m_iNRVBS00, m_iNRSPR00, m_iNRVVG00, m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_iNRVVG00 Variable

Private 		m_iNRPRD00, _
   m_iNRVBS00, _
   m_iNRSPR00, _
   m_iNRVVG00, _
   m_iNRPAR00 As SqlInt32

Source code

[Visual Basic]
        Private 		m_iNRPRD00, m_iNRVBS00, m_iNRSPR00, m_iNRVVG00, m_iNRPAR00 As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_sBEPRDLG Variable

Private 		m_sNAVVG00, _
   m_sSAREC00, _
   m_sBEPRDLG, _
   m_sTXRBK00, _
   m_sNEVVG00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNAVVG00, m_sSAREC00, m_sBEPRDLG, m_sTXRBK00, m_sNEVVG00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_sNAVVG00 Variable

Private 		m_sNAVVG00, _
   m_sSAREC00, _
   m_sBEPRDLG, _
   m_sTXRBK00, _
   m_sNEVVG00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNAVVG00, m_sSAREC00, m_sBEPRDLG, m_sTXRBK00, m_sNEVVG00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_sNEVVG00 Variable

Private 		m_sNAVVG00, _
   m_sSAREC00, _
   m_sBEPRDLG, _
   m_sTXRBK00, _
   m_sNEVVG00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNAVVG00, m_sSAREC00, m_sBEPRDLG, m_sTXRBK00, m_sNEVVG00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_sSAREC00 Variable

Private 		m_sNAVVG00, _
   m_sSAREC00, _
   m_sBEPRDLG, _
   m_sTXRBK00, _
   m_sNEVVG00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNAVVG00, m_sSAREC00, m_sBEPRDLG, m_sTXRBK00, m_sNEVVG00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


m_sTXRBK00 Variable

Private 		m_sNAVVG00, _
   m_sSAREC00, _
   m_sBEPRDLG, _
   m_sTXRBK00, _
   m_sNEVVG00 As SqlString

Source code

[Visual Basic]
        Private 		m_sNAVVG00, m_sSAREC00, m_sBEPRDLG, m_sTXRBK00, m_sNEVVG00 As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVV


clsVorlagenfeld Class

For a list of all members of this type, see clsVorlagenfeld Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsVorlagenfeld
EDOKAApp.edokadb.clsMyDokumentDaten

Public Class clsVorlagenfeld
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsVorlagenfeld Members


clsVorlagenfeld Members

clsVorlagenfeld overview

Constructors

constructor clsVorlagenfeld Constructor

Properties

property bAktiv
property bAusstiegsmakro
property bEinstiegsmakro
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iDokumenttypnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iVorlagenfeldnr
property iVorlagenfeldregelnr
property iVorlagenfeldregelnrOld
property sBeginntextmarke
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEndetextmarke
property sFeldname
property sTestdaten

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumenttypnrLogic
method SelectAllWvorlagenfeldregelnrLogic
method SelectOne
method Update
method UpdateAllWdokumenttypnrLogic
method UpdateAllWvorlagenfeldregelnrLogic

Fields

field m_bAktiv
field m_bAusstiegsmakro
field m_bEinstiegsmakro
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iDokumenttypnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iVorlagenfeldnr
field m_iVorlagenfeldregelnr
field m_iVorlagenfeldregelnrOld
field m_sBeginntextmarke
field m_sEndetextmarke
field m_sFeldname
field m_sTestdaten
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVorlagenfeld Class


clsVorlagenfeld Properties

clsVorlagenfeld overview

Properties

property bAktiv
property bAusstiegsmakro
property bEinstiegsmakro
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iDokumenttypnr
property iDokumenttypnrOld
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iVorlagenfeldnr
property iVorlagenfeldregelnr
property iVorlagenfeldregelnrOld
property sBeginntextmarke
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEndetextmarke
property sFeldname
property sTestdaten

See Also

clsVorlagenfeld Class


clsVorlagenfeld Methods

clsVorlagenfeld overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWdokumenttypnrLogic
method SelectAllWvorlagenfeldregelnrLogic
method SelectOne
method Update
method UpdateAllWdokumenttypnrLogic
method UpdateAllWvorlagenfeldregelnrLogic

See Also

clsVorlagenfeld Class


clsVorlagenfeld Fields

clsVorlagenfeld overview

Fields

field m_bAktiv
field m_bAusstiegsmakro
field m_bEinstiegsmakro
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iDokumenttypnr
field m_iDokumenttypnrOld
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iVorlagenfeldnr
field m_iVorlagenfeldregelnr
field m_iVorlagenfeldregelnrOld
field m_sBeginntextmarke
field m_sEndetextmarke
field m_sFeldname
field m_sTestdaten
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVorlagenfeld Class


m_bAktiv Variable

Private 		m_bEinstiegsmakro, _
   m_bAusstiegsmakro, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_bAusstiegsmakro Variable

Private 		m_bEinstiegsmakro, _
   m_bAusstiegsmakro, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_bEinstiegsmakro Variable

Private 		m_bEinstiegsmakro, _
   m_bAusstiegsmakro, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iDokumenttypnr Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iDokumenttypnrOld Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iMandantnr Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iMutierer Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iVorlagenfeldnr Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iVorlagenfeldregelnr Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_iVorlagenfeldregelnrOld Variable

Private 		m_iVorlagenfeldnr, _
   m_iMandantnr, _
   m_iDokumenttypnr, _
   m_iDokumenttypnrOld, _
   m_iMutierer, _
   m_iVorlagenfeldregelnr, _
   m_iVorlagenfeldregelnrOld As SqlInt32

Source code

[Visual Basic]
        Private 		m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_sBeginntextmarke Variable

Private 		m_sBeginntextmarke, _
   m_sFeldname, _
   m_sTestdaten, _
   m_sEndetextmarke As SqlString

Source code

[Visual Basic]
        Private 		m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_sEndetextmarke Variable

Private 		m_sBeginntextmarke, _
   m_sFeldname, _
   m_sTestdaten, _
   m_sEndetextmarke As SqlString

Source code

[Visual Basic]
        Private 		m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_sFeldname Variable

Private 		m_sBeginntextmarke, _
   m_sFeldname, _
   m_sTestdaten, _
   m_sEndetextmarke As SqlString

Source code

[Visual Basic]
        Private 		m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


m_sTestdaten Variable

Private 		m_sBeginntextmarke, _
   m_sFeldname, _
   m_sTestdaten, _
   m_sEndetextmarke As SqlString

Source code

[Visual Basic]
        Private 		m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeld


clsVorlagenfeldbezeichnung Class

For a list of all members of this type, see clsVorlagenfeldbezeichnung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsVorlagenfeldbezeichnung

Public Class clsVorlagenfeldbezeichnung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsVorlagenfeldbezeichnung Members


clsVorlagenfeldbezeichnung Members

clsVorlagenfeldbezeichnung overview

Constructors

constructor clsVorlagenfeldbezeichnung Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iSprache
property iVorlagenfeld
property iVorlagenfeldbezeichnungnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iSprache
field m_iVorlagenfeld
field m_iVorlagenfeldbezeichnungnr
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVorlagenfeldbezeichnung Class


clsVorlagenfeldbezeichnung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung Properties

clsVorlagenfeldbezeichnung overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMutierer
property iSprache
property iVorlagenfeld
property iVorlagenfeldbezeichnungnr
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVorlagenfeldbezeichnung Class


clsVorlagenfeldbezeichnung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.iSprache Property

Public Property [iSprache]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iSprache]() As SqlInt32
            Get
                Return m_iSprache
            End Get
            Set(ByVal Value As SqlInt32)
                m_iSprache = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.iVorlagenfeld Property

Public Property [iVorlagenfeld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeld]() As SqlInt32
            Get
                Return m_iVorlagenfeld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iVorlagenfeld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.iVorlagenfeldbezeichnungnr Property

Public Property [iVorlagenfeldbezeichnungnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iVorlagenfeldbezeichnungnr]() As SqlInt32
            Get
                Return m_iVorlagenfeldbezeichnungnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iVorlagenfeldbezeichnungnrTmp As SqlInt32 = Value
                If iVorlagenfeldbezeichnungnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iVorlagenfeldbezeichnungnr", "iVorlagenfeldbezeichnungnr can't be NULL")
                End If
                m_iVorlagenfeldbezeichnungnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung Methods

clsVorlagenfeldbezeichnung overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsVorlagenfeldbezeichnung Class


clsVorlagenfeldbezeichnung.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeldbezeichnung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldbezeichnungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeldbezeichnung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeldbezeichnung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeldbezeichnung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeld))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeldbezeichnung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeldbezeichnung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeldbezeichnung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeldbezeichnung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeldbezeichnung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeldbezeichnung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeldbezeichnung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("vorlagenfeldbezeichnung")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldbezeichnungnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeldbezeichnung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iVorlagenfeldbezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldbezeichnungnr"), Integer))
                    If dtToReturn.Rows(0)("vorlagenfeld") Is System.DBNull.Value Then
                        m_iVorlagenfeld = SqlInt32.Null
                    Else
                        m_iVorlagenfeld = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeld"), Integer))
                    End If
                    If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
                        m_iSprache = SqlInt32.Null
                    Else
                        m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
                    End If
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeldbezeichnung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeldbezeichnung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldbezeichnungnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeld))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_vorlagenfeldbezeichnung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsVorlagenfeldbezeichnung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsVorlagenfeldbezeichnung Fields

clsVorlagenfeldbezeichnung overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMutierer
field m_iSprache
field m_iVorlagenfeld
field m_iVorlagenfeldbezeichnungnr
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsVorlagenfeldbezeichnung Class


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iVorlagenfeldbezeichnungnr, _
   m_iVorlagenfeld, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVorlagenfeldbezeichnungnr, m_iVorlagenfeld, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_iSprache Variable

Private 		m_iMutierer, _
   m_iVorlagenfeldbezeichnungnr, _
   m_iVorlagenfeld, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVorlagenfeldbezeichnungnr, m_iVorlagenfeld, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_iVorlagenfeld Variable

Private 		m_iMutierer, _
   m_iVorlagenfeldbezeichnungnr, _
   m_iVorlagenfeld, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVorlagenfeldbezeichnungnr, m_iVorlagenfeld, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_iVorlagenfeldbezeichnungnr Variable

Private 		m_iMutierer, _
   m_iVorlagenfeldbezeichnungnr, _
   m_iVorlagenfeld, _
   m_iSprache As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iVorlagenfeldbezeichnungnr, m_iVorlagenfeld, m_iSprache As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


m_sBezeichnung Variable

Private 		m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsVorlagenfeldbezeichnung


clsWindowPositions Class

For a list of all members of this type, see clsWindowPositions Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsWindowPositions

Public Class clsWindowPositions
   Inherits clsDBInteractionBase

Requirements

Namespace: edokadb

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsWindowPositions Members


clsWindowPositions Members

clsWindowPositions overview

Constructors

constructor clsWindowPositions Constructor

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iEintragnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHeight
property iMitarbeiternr
property iTopleft
property iWidth
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sWindow

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iEintragnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHeight
field m_iMitarbeiternr
field m_iTopleft
field m_iWidth
field m_sWindow
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsWindowPositions Class


clsWindowPositions Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions Properties

clsWindowPositions overview

Properties

property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iEintragnr
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHeight
property iMitarbeiternr
property iTopleft
property iWidth
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sWindow

See Also

clsWindowPositions Class


clsWindowPositions.iEintragnr Property

Public Property [iEintragnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iEintragnr]() As SqlInt32
            Get
                Return m_iEintragnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iEintragnrTmp As SqlInt32 = Value
                If iEintragnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iEintragnr", "iEintragnr can't be NULL")
                End If
                m_iEintragnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.iHeight Property

Public Property [iHeight]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHeight]() As SqlInt32
            Get
                Return m_iHeight
            End Get
            Set(ByVal Value As SqlInt32)
                m_iHeight = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.iTopleft Property

Public Property [iTopleft]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTopleft]() As SqlInt32
            Get
                Return m_iTopleft
            End Get
            Set(ByVal Value As SqlInt32)
                m_iTopleft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.iWidth Property

Public Property [iWidth]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iWidth]() As SqlInt32
            Get
                Return m_iWidth
            End Get
            Set(ByVal Value As SqlInt32)
                m_iWidth = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.sWindow Property

Public Property [sWindow]() As SqlString

Source code

[Visual Basic]
        Public Property [sWindow]() As SqlString
            Get
                Return m_sWindow
            End Get
            Set(ByVal Value As SqlString)
                m_sWindow = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions Methods

clsWindowPositions overview

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

See Also

clsWindowPositions Class


clsWindowPositions.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_WindowPositions_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_WindowPositions_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsWindowPositions::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_WindowPositions_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swindow", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWindow))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itopleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTopleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHeight))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iEintragnr = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@ieintragnr").Value, Integer))
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_WindowPositions_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsWindowPositions::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_WindowPositions_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("WindowPositions")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_WindowPositions_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsWindowPositions::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_WindowPositions_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("WindowPositions")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_WindowPositions_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iEintragnr = New SqlInt32(CType(dtToReturn.Rows(0)("eintragnr"), Integer))
                    If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
                        m_iMitarbeiternr = SqlInt32.Null
                    Else
                        m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("window") Is System.DBNull.Value Then
                        m_sWindow = SqlString.Null
                    Else
                        m_sWindow = New SqlString(CType(dtToReturn.Rows(0)("window"), String))
                    End If
                    If dtToReturn.Rows(0)("topleft") Is System.DBNull.Value Then
                        m_iTopleft = SqlInt32.Null
                    Else
                        m_iTopleft = New SqlInt32(CType(dtToReturn.Rows(0)("topleft"), Integer))
                    End If
                    If dtToReturn.Rows(0)("width") Is System.DBNull.Value Then
                        m_iWidth = SqlInt32.Null
                    Else
                        m_iWidth = New SqlInt32(CType(dtToReturn.Rows(0)("width"), Integer))
                    End If
                    If dtToReturn.Rows(0)("height") Is System.DBNull.Value Then
                        m_iHeight = SqlInt32.Null
                    Else
                        m_iHeight = New SqlInt32(CType(dtToReturn.Rows(0)("height"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsWindowPositions::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_WindowPositions_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ieintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iEintragnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@swindow", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sWindow))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@itopleft", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTopleft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iwidth", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iWidth))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iheight", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHeight))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_WindowPositions_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsWindowPositions::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


clsWindowPositions Fields

clsWindowPositions overview

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iEintragnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHeight
field m_iMitarbeiternr
field m_iTopleft
field m_iWidth
field m_sWindow
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsWindowPositions Class


m_iEintragnr Variable

Private 		m_iTopleft, _
   m_iWidth, _
   m_iHeight, _
   m_iEintragnr, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTopleft, m_iWidth, m_iHeight, m_iEintragnr, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


m_iHeight Variable

Private 		m_iTopleft, _
   m_iWidth, _
   m_iHeight, _
   m_iEintragnr, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTopleft, m_iWidth, m_iHeight, m_iEintragnr, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


m_iMitarbeiternr Variable

Private 		m_iTopleft, _
   m_iWidth, _
   m_iHeight, _
   m_iEintragnr, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTopleft, m_iWidth, m_iHeight, m_iEintragnr, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


m_iTopleft Variable

Private 		m_iTopleft, _
   m_iWidth, _
   m_iHeight, _
   m_iEintragnr, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTopleft, m_iWidth, m_iHeight, m_iEintragnr, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


m_iWidth Variable

Private 		m_iTopleft, _
   m_iWidth, _
   m_iHeight, _
   m_iEintragnr, _
   m_iMitarbeiternr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iTopleft, m_iWidth, m_iHeight, m_iEintragnr, m_iMitarbeiternr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


m_sWindow Variable

Private 		m_sWindow As SqlString

Source code

[Visual Basic]
        Private 		m_sWindow As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsWindowPositions


Font Property

Dim Font As System.Drawing.Font

Source code

[Visual Basic]
            Dim Font As System.Drawing.Font

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET


GenericList Constructor (System.String, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal id As Integer _
)

Parameters

display
Required.
id
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal id As Integer)
        Me.Display = display
        Me.ID = id
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList Constructor (System.String, System.Int32, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal id As Integer, _
   ByVal index As Integer _
)

Parameters

display
Required.
id
Required.
index
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal id As Integer, ByVal index As Integer)
        Me.Display = display
        Me.ID = id
        Me.Index = index
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList Constructor (System.String, System.String, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal altdisplay As String, _
   ByVal id As Integer _
)

Parameters

display
Required.
altdisplay
Required.
id
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal altdisplay As String, ByVal id As Integer)
        Me.Display = display
        Me.AlternateDisplay = altdisplay
        Me.ID = id
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


GenericList Constructor (System.String, System.String, System.Int32, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal altdisplay As String, _
   ByVal id As Integer, _
   ByVal index As Integer _
)

Parameters

display
Required.
altdisplay
Required.
id
Required.
index
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal altdisplay As String, ByVal id As Integer, ByVal index As Integer)
        Me.Display = display
        Me.AlternateDisplay = altdisplay
        Me.ID = id
        Me.Index = index
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


frmSuchFormular.Generic_Select (System.Int32) Method

Private Function Generic_Select( _
   ByVal typ As Integer _
) As DataTable

Parameters

typ
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        Select Case typ
            Case 7
                scmCmdToExecute.CommandText = "dbo.sp_suchprofil_get_partner"
            Case Else
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            Select Case typ
                Case 7
                    If EDOKADaten = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "EDOKA"))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    End If

                    If UVMDaten = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "UVM"))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns(2).Text))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    End If

                    If ZVDaten = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "ZV"))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns(3).Text))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns(9).Text))
                    End If
                    If HOSTDaten = True Then
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@doktyp", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "HOST"))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@partnernr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Me.DokList.Columns("Partnernr_inhaber").Text))
                        scmCmdToExecute.Parameters.Add(New SqlParameter("@valdat", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
                    End If
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
                    scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                Case Else
            End Select
            If typ = 1 Then
            End If
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            ' // some error occured. Bubble it to caller and encapsulate Exception object
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


GenericList Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.new()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

GenericList


frmSuchFormular.Generic_Select (System.Int32, System.String) Method

Private Function Generic_Select( _
   ByVal typ As Integer, _
   ByVal sp As String _
) As DataTable

Parameters

typ
Required.
sp
Required.

Source code

[Visual Basic]
    Private Function Generic_Select(ByVal typ As Integer, ByVal sp As String) As DataTable
        Dim scmCmdToExecute As SqlCommand = New SqlCommand()
        scmCmdToExecute.Connection = Globals.conn.scoDBConnection
        Select Case typ
            Case 0
                scmCmdToExecute.CommandText = "dbo.SP_Get_SuchParameter"
            Case Else
                scmCmdToExecute.CommandText = sp
        End Select
        scmCmdToExecute.CommandType = CommandType.StoredProcedure
        Dim dtToReturn As DataTable = New DataTable()
        Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

        scmCmdToExecute.Connection = conn.scoDBConnection
        Try
            sdaAdapter.Fill(dtToReturn)
            Return dtToReturn
        Catch ex As Exception
            Throw New Exception("Dokumenterstellung::Generic_Select::" & scmCmdToExecute.CommandText & "::Error occured." & ex.Message, ex)
        Finally
            scmCmdToExecute.Dispose()
            sdaAdapter.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


clsMyMitarbeiter.Get_Mitarbeiter Method

Public Function Get_Mitarbeiter() As Boolean

Source code

[Visual Basic]
        Public Function Get_Mitarbeiter() As Boolean
            Dim mandant As New edokaDB.clsMandant()
            Me.cpMainConnectionProvider = Globals.conn

            Dim MitarbeiterData As DataTable
            Dim CheckState As Boolean

            Get_Mitarbeiter = True
            Me.xtgnummer = get_username
            Globals.TGNummer = Me.xtgnummer
            MitarbeiterData = Me.SelectWithTGNummer
            If MitarbeiterData.Rows.Count = 0 Then
                Get_Mitarbeiter = False
            Else
                Globals.DoLog = MitarbeiterData.Rows(0).Item("journalisierung")
                Globals.MitarbeiterNr = MitarbeiterData.Rows(0).Item("mitarbeiternr")
                Globals.Sprache = MitarbeiterData.Rows(0).Item("Sprache")
                If MitarbeiterData.Rows(0).Item("fuermandant") = 0 Then
                    Select_Mandant()
                Else
                    mandant.cpMainConnectionProvider = conn
                    mandant.iMandantnr = New SqlInt32(MitarbeiterData.Rows(0).Item("fuermandant"))
                    mandant.SelectOne()
                    Globals.MandantNr = mandant.iMandantnr.Value
                    Globals.MandantText = mandant.sBezeichnung.Value
                End If
            End If
            mandant.Dispose()
            MitarbeiterData.Dispose()
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


clsMyMitarbeiter.Get_Username Method

Private Function Get_Username() As String

Source code

[Visual Basic]
        Private Function Get_Username() As String
            With ouser.Identity.Name
                Return (.Substring(.IndexOf("\") + 1))
            End With
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


ISingleInstanceForm.Handle Property

ReadOnly Property Handle() As IntPtr

Source code

[Visual Basic]
            ReadOnly Property Handle() As IntPtr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


EDOKAMain.HandleCommand (System.String()) Method

Public Sub HandleCommand( _
   ByVal strArgs() As String _
)

Parameters

strArgs
Required.

Source code

[Visual Basic]
    Public Sub HandleCommand(ByVal strArgs() As String)
        If UCase(Microsoft.VisualBasic.Left(Globals.conn.scoDBConnection.DataSource.ToString, 3)) = "TGT" Then
            Me.BackColor = Color.Yellow
        End If

        Dim strCmd As String
        If Not Edoka_Gestartet Then
            If strArgs.Length = 0 Then
                Win32API.SetForegroundWindow(Me.Handle.ToInt32)
                EDOKAMain_Load()
            Else
                Win32API.SetForegroundWindow(Me.Handle.ToInt32)
                init_system()
            End If
            Edoka_Gestartet = True
        End If
        Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
        For Each strCmd In strArgs
            Parameters = Split(strCmd, ",")
            If UCase(Parameters(0)) = "SHOW" Then
                Dim f As New frmTrefferliste()
                f.MdiParent = Me
                f.Show()
                f.txtnrpar00.Text = Parameters(1)
                f.Partnernr = Parameters(1)
                f.Partner_Eingegeben = True
                f.refresh_list()
                f.Refresh_All(True)
                Me.Cursor = System.Windows.Forms.Cursors.Default
                Globals.Apphandle = Me.Handle.ToInt32
                Win32API.SetForegroundWindow(Me.Handle.ToInt32)
                Win32API.ShowWindow(Me.Handle.ToInt32, Win32API.SW_RESTORE)
                Try
                    f1.WindowState = FormWindowState.Minimized
                    f1.MdiParent = Me
                    f1.Show()
                Catch
                End Try
                Exit Sub
            End If

            If UCase(Parameters(0)) = "CREATE" Then
                Me.Timer3.Enabled = True
                Exit Sub
                'Dim f As New frmTrefferliste()
                'f.MdiParent = Me
                'f.Show()
                'f.Partner_Eingegeben = True
                'f.txtnrpar00.Text = Parameters(1)
                'f.refresh_list()
                'f.Partnernr = Parameters(1)
                'Me.Cursor = System.Windows.Forms.Cursors.Default
                'Globals.Apphandle = Me.Handle.ToInt32
                'Win32API.SetForegroundWindow(Me.Handle.ToInt32)
                'Win32API.ShowWindow(Me.Handle.ToInt32, Win32API.SW_RESTORE)
                'f.Create_Dokument(True, False)
                'Exit Sub
            End If
        Next
        If Me.forceexit Then
            Me.Close()
            Exit Sub
        End If
        If Me.ShowDefekteDokumente = False And Me.ShowGeburtstag = False And Check_offene_dp_instanzen() = False Then

            Try
                Dim f As New frmTrefferliste()
                f.MdiParent = Me
                f.Partner_Eingegeben = False
                f.Show()
                'f.refresh_list()
            Catch
            End Try
        End If
        Try
            Me.Cursor = System.Windows.Forms.Cursors.Default
            Globals.Apphandle = Me.Handle.ToInt32
            Win32API.SetForegroundWindow(Me.Handle.ToInt32)
            Me.WindowState = FormWindowState.Maximized
        Catch
        End Try
        If Me.ShowDefekteDokumente Then
            Globals.Bearbeitung_Problemdokumente = True
            Me.fcheckdoc.StartPosition = FormStartPosition.CenterScreen
            Me.fcheckdoc.Show()
            Me.fcheckdoc.TopMost = True
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.HandleCommand (System.String) Method

Public Sub HandleCommand( _
   ByVal strCmd As String _
) Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.HandleCommand

Parameters

strCmd
Required.

Source code

[Visual Basic]
    Public Sub HandleCommand(ByVal strCmd As String) Implements EDOKAApp.mMain.SingleInstance.ISingleInstanceForm.HandleCommand
        Dim arrCmd() As String
        Try
            arrCmd = SerialHelper.DeserializeFromBase64String(strCmd)
            HandleCommand(arrCmd)
        Catch ex As Exception
            HandleCommand(New String() {strCmd})
        Finally
            Erase arrCmd
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


ISingleInstanceForm.HandleCommand Method

Sub HandleCommand( _
   ByVal strCmd As String _
)

Parameters

strCmd
Required.

Source code

[Visual Basic]
            Sub HandleCommand(ByVal strCmd As String)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


Height Property

Dim Height As Integer

Source code

[Visual Basic]
            Dim Height As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


ImgGenericList Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.new()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


ImgGenericList Constructor (System.String, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal id As Integer _
)

Parameters

display
Required.
id
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal id As Integer)
        Me.Display = display
        Me.ID = id
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


ImgGenericList Constructor (System.String, System.Int32, System.Int32)

Public Sub New( _
   ByVal display As String, _
   ByVal id As Integer, _
   ByVal index As Integer _
)

Parameters

display
Required.
id
Required.
index
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal display As String, ByVal id As Integer, ByVal index As Integer)
        Me.Display = display
        Me.ID = id
        Me.Index = index
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImgGenericList


Icon Property

Dim Icon As System.Drawing.Icon

Source code

[Visual Basic]
            Dim Icon As System.Drawing.Icon

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


IconRectangle Property

Dim IconRectangle As System.Drawing.Rectangle

Source code

[Visual Basic]
            Dim IconRectangle As System.Drawing.Rectangle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


ImageComboBox Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        'set to ownerdraw
        Me.DrawMode = DrawMode.OwnerDrawFixed
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


ImageComboBox Constructor (System.Windows.Forms.ComboBox)

Public Sub New( _
   ByRef cbo As ComboBox _
)

Parameters

cbo
Required.

Source code

[Visual Basic]
    Public Sub New(ByRef cbo As ComboBox)
        'assign all properties from cbo to me
        'Dim pi As Reflection.PropertyInfo
        'For Each pi In cbo.GetType.GetProperties
        '    Dim s As String = pi.Attributes.ToString
        '    If pi.CanWrite Then
        '        'On Error Resume Next 'just in case
        '        Me.GetType.GetProperty(pi.Name).SetValue(Me, pi.GetValue(cbo, Nothing), Nothing)
        '    End If
        'Next
        'TODO: have it consume ALL properties of original combo
        Me.Anchor = cbo.Anchor
        Me.BackColor = cbo.BackColor
        Me.BackgroundImage = cbo.BackgroundImage
        Me.CausesValidation = cbo.CausesValidation
        Me.ContextMenu = cbo.ContextMenu
        Me.DataSource = cbo.DataSource
        Me.DisplayMember = cbo.DisplayMember
        Me.Dock = cbo.Dock
        Me.DropDownStyle = cbo.DropDownStyle
        Me.DropDownWidth = cbo.DropDownWidth
        Me.Enabled = cbo.Enabled
        Me.Font = cbo.Font
        Me.ForeColor = cbo.ForeColor
        Me.IntegralHeight = cbo.IntegralHeight
        If cbo.Items.Count > 0 Then
            Dim tmp(cbo.Items.Count) As Object
            cbo.Items.CopyTo(tmp, 0)
            Me.Items.AddRange(tmp)
        End If
        Me.MaxDropDownItems = cbo.MaxDropDownItems
        Me.MaxLength = cbo.MaxLength
        Me.Sorted = cbo.Sorted
        Me.Text = cbo.Text
        Me.TabStop = cbo.TabStop
        Me.ValueMember = cbo.ValueMember
        Me.Visible = cbo.Visible
        Me.Location = cbo.Location
        Me.Size = cbo.Size
        Me.TabIndex = cbo.TabIndex
        'set to ownerdraw
        Me.DrawMode = DrawMode.OwnerDrawFixed
        'switch combos
        Dim parent As Object = cbo.Parent
        parent.Controls.Remove(cbo)
        parent.Controls.Add(Me)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ImageComboBox


clsOffice_Vorlage_Datei.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                Dim	iLength As Integer = 0
                If Not m_blobVorlage.IsNull Then
                    iLength = m_blobVorlage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobvorlage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobVorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfreigegeben", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFreigegeben))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dafragabe_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daFragabe_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifreigabe_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabe_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dauebernahme_produktion", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUebernahme_produktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdateiname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDateiname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_Vorlage_Datei::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ParameterSetList_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParameterSetListID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetListID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParameterSetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetNameID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterDisplayValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterDisplayValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatenherkunft", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDatenherkunft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterNavigationValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterNavigationValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ParameterSetList_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsParameterSetList::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.Insert Method

Public Overrides Function Insert() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ProfilDokAuswertung_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstandard", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw1", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw2", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw3", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw4", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw5", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw6", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw7", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw8", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw9", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw9))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw10", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw10))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw11", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw11))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@senl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sekost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@seteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sema", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokart", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokstatus", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@serstaelterals", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sErstaelterals))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smutaelterasl", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMutaelterasl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ssort", SqlDbType.VarChar, 1024, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktive", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktive))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofiltyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfiltyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklalt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklhostmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklhostmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ProfilDokAuswertung_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfilDokAuswertung::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportfeldregel_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportFeldRegelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportFeldRegelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingabe_zwingend", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingabe_zwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportfeldregel_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportfeldregel::Insert::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.Insert Method

Overrides Public Function Insert() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Insert() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_Insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_reportgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReport_reportgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ICommonDBAccess.Insert Method

Function	Insert() As Boolean

Source code

[Visual Basic]
        Function	Insert() As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsMyDokumentstatus.InsertDokumentstatus Method

Public Function InsertDokumentstatus()

Source code

[Visual Basic]
        Public Function InsertDokumentstatus()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_dokumentstatus_insert]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("dokumentstatus")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@statustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Statustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MitarbeiterNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@statustyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Statustyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::sp:Dokumentstatus_Insert::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


IsSeperator Property

Dim IsSeperator As Boolean

Source code

[Visual Basic]
            Dim IsSeperator As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


ColumnCollection.Item (System.Int32) Property

Default Public ReadOnly Property Item( _
   ByVal Index As Integer _
) As Column

Parameters

Index
Required.

Source code

[Visual Basic]
        Default Public ReadOnly Property Item(ByVal Index As Integer) As Column
            Get
                Return _Col(Index)
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection.Item (System.String) Property

Default Public ReadOnly Property Item( _
   ByVal Key As String _
) As Column

Parameters

Key
Required.

Source code

[Visual Basic]
        Default Public ReadOnly Property Item(ByVal Key As String) As Column
            Get
                Return _Col(Key)
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


clsMyMandat.SelectAll Method

Public Overrides Function SelectAll() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_mandant_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mandant")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mandant_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::SelectAll::Error occured." & ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMandat


clsOffice_Vorlage_Datei.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Office_Vorlage_Datei")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_Vorlage_Datei::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ParameterSetList_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ParameterSetList")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ParameterSetList_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsParameterSetList::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.SelectAll Method

Public Overrides Function SelectAll() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ProfilDokAuswertung_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("ProfilDokAuswertung")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ProfilDokAuswertung_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfilDokAuswertung::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportfeldregel_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportfeldregel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportfeldregel_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportfeldregel::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.SelectAll Method

Overrides Public Function SelectAll() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectAll() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_SelectAll]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::SelectAll::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ICommonDBAccess.SelectAll Method

Function	SelectAll() As DataTable

Source code

[Visual Basic]
        Function	SelectAll() As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsMyDokumentstatus.SelectDokumentstatus Method

Public Function SelectDokumentstatus() As DataTable

Source code

[Visual Basic]
        Public Function SelectDokumentstatus() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_dokumentstatus_Select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("dokumentstatus")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@statustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Statustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_dokumentstatus_select' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsDokumentstatus::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


clsProfilDokAuswertung.SelectOne Method

Public Overrides Function SelectOne() As DataTable

Source code

[Visual Basic]
        Public Overrides Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ProfilDokAuswertung_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("ProfilDokAuswertung")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ProfilDokAuswertung_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iProfilnr = New SqlInt32(CType(dtToReturn.Rows(0)("profilnr"), Integer))
                    m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
                    m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    m_bStandard = New SqlBoolean(CType(dtToReturn.Rows(0)("standard"), Boolean))
                    m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    m_sColor1 = New SqlString(CType(dtToReturn.Rows(0)("color1"), String))
                    m_sColor2 = New SqlString(CType(dtToReturn.Rows(0)("color2"), String))
                    m_sColor3 = New SqlString(CType(dtToReturn.Rows(0)("color3"), String))
                    m_sColor4 = New SqlString(CType(dtToReturn.Rows(0)("color4"), String))
                    m_sColor5 = New SqlString(CType(dtToReturn.Rows(0)("color5"), String))
                    m_sColor6 = New SqlString(CType(dtToReturn.Rows(0)("color6"), String))
                    m_sColor7 = New SqlString(CType(dtToReturn.Rows(0)("color7"), String))
                    m_sColor8 = New SqlString(CType(dtToReturn.Rows(0)("color8"), String))
                    m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
                    m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
                    m_iHw1 = New SqlInt32(CType(dtToReturn.Rows(0)("hw1"), Integer))
                    m_iHw2 = New SqlInt32(CType(dtToReturn.Rows(0)("hw2"), Integer))
                    m_iHw3 = New SqlInt32(CType(dtToReturn.Rows(0)("hw3"), Integer))
                    m_iHw4 = New SqlInt32(CType(dtToReturn.Rows(0)("hw4"), Integer))
                    m_iHw5 = New SqlInt32(CType(dtToReturn.Rows(0)("hw5"), Integer))
                    m_iHw6 = New SqlInt32(CType(dtToReturn.Rows(0)("hw6"), Integer))
                    m_iHw7 = New SqlInt32(CType(dtToReturn.Rows(0)("hw7"), Integer))
                    m_iHw8 = New SqlInt32(CType(dtToReturn.Rows(0)("hw8"), Integer))
                    m_iHw9 = New SqlInt32(CType(dtToReturn.Rows(0)("hw9"), Integer))
                    m_iHw10 = New SqlInt32(CType(dtToReturn.Rows(0)("hw10"), Integer))
                    m_iHw11 = New SqlInt32(CType(dtToReturn.Rows(0)("hw11"), Integer))
                    m_sVmb = New SqlString(CType(dtToReturn.Rows(0)("vmb"), String))
                    m_sVnl = New SqlString(CType(dtToReturn.Rows(0)("vnl"), String))
                    m_sVkost = New SqlString(CType(dtToReturn.Rows(0)("vkost"), String))
                    m_sVteam = New SqlString(CType(dtToReturn.Rows(0)("vteam"), String))
                    m_sVma = New SqlString(CType(dtToReturn.Rows(0)("vma"), String))
                    m_sMmb = New SqlString(CType(dtToReturn.Rows(0)("mmb"), String))
                    m_sMnl = New SqlString(CType(dtToReturn.Rows(0)("mnl"), String))
                    m_sMkost = New SqlString(CType(dtToReturn.Rows(0)("mkost"), String))
                    m_sMteam = New SqlString(CType(dtToReturn.Rows(0)("mteam"), String))
                    m_sMma = New SqlString(CType(dtToReturn.Rows(0)("mma"), String))
                    m_sEmb = New SqlString(CType(dtToReturn.Rows(0)("emb"), String))
                    m_sEnl = New SqlString(CType(dtToReturn.Rows(0)("enl"), String))
                    m_sEkost = New SqlString(CType(dtToReturn.Rows(0)("ekost"), String))
                    m_sEteam = New SqlString(CType(dtToReturn.Rows(0)("eteam"), String))
                    m_sEma = New SqlString(CType(dtToReturn.Rows(0)("ema"), String))
                    m_sDpartner = New SqlString(CType(dtToReturn.Rows(0)("dpartner"), String))
                    m_sDdokart = New SqlString(CType(dtToReturn.Rows(0)("ddokart"), String))
                    m_sDdokstatus = New SqlString(CType(dtToReturn.Rows(0)("ddokstatus"), String))
                    m_sDatum1 = New SqlString(CType(dtToReturn.Rows(0)("datum1"), String))
                    m_sDatum2 = New SqlString(CType(dtToReturn.Rows(0)("datum2"), String))
                    m_sDatum3 = New SqlString(CType(dtToReturn.Rows(0)("datum3"), String))
                    m_sDatum4 = New SqlString(CType(dtToReturn.Rows(0)("datum4"), String))
                    m_sDatum5 = New SqlString(CType(dtToReturn.Rows(0)("datum5"), String))
                    m_sDatum6 = New SqlString(CType(dtToReturn.Rows(0)("datum6"), String))
                    m_sDatum7 = New SqlString(CType(dtToReturn.Rows(0)("datum7"), String))
                    m_sDatum8 = New SqlString(CType(dtToReturn.Rows(0)("datum8"), String))
                    m_sErstaelterals = New SqlString(CType(dtToReturn.Rows(0)("erstaelterals"), String))
                    m_sMutaelterasl = New SqlString(CType(dtToReturn.Rows(0)("mutaelterasl"), String))
                    m_iTeam = New SqlInt32(CType(dtToReturn.Rows(0)("team"), Integer))
                    m_sSort = New SqlString(CType(dtToReturn.Rows(0)("sort"), String))
                    If dtToReturn.Rows(0)("aktive") Is System.DBNull.Value Then
                        m_bAktive = SqlBoolean.Null
                    Else
                        m_bAktive = New SqlBoolean(CType(dtToReturn.Rows(0)("aktive"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("profiltyp") Is System.DBNull.Value Then
                        m_iProfiltyp = SqlInt32.Null
                    Else
                        m_iProfiltyp = New SqlInt32(CType(dtToReturn.Rows(0)("profiltyp"), Integer))
                    End If
                    If dtToReturn.Rows(0)("doktyp") Is System.DBNull.Value Then
                        m_sDoktyp = SqlString.Null
                    Else
                        m_sDoktyp = New SqlString(CType(dtToReturn.Rows(0)("doktyp"), String))
                    End If
                    If dtToReturn.Rows(0)("inklmavip") Is System.DBNull.Value Then
                        m_bInklmavip = SqlBoolean.Null
                    Else
                        m_bInklmavip = New SqlBoolean(CType(dtToReturn.Rows(0)("inklmavip"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("inklalt") Is System.DBNull.Value Then
                        m_bInklalt = SqlBoolean.Null
                    Else
                        m_bInklalt = New SqlBoolean(CType(dtToReturn.Rows(0)("inklalt"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("hostpartner") Is System.DBNull.Value Then
                        m_sHostpartner = SqlString.Null
                    Else
                        m_sHostpartner = New SqlString(CType(dtToReturn.Rows(0)("hostpartner"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdokart") Is System.DBNull.Value Then
                        m_sHostdokart = SqlString.Null
                    Else
                        m_sHostdokart = New SqlString(CType(dtToReturn.Rows(0)("hostdokart"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdoktyp") Is System.DBNull.Value Then
                        m_sHostdoktyp = SqlString.Null
                    Else
                        m_sHostdoktyp = New SqlString(CType(dtToReturn.Rows(0)("hostdoktyp"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag1") Is System.DBNull.Value Then
                        m_sHosttag1 = SqlString.Null
                    Else
                        m_sHosttag1 = New SqlString(CType(dtToReturn.Rows(0)("hosttag1"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum1") Is System.DBNull.Value Then
                        m_sHostdatum1 = SqlString.Null
                    Else
                        m_sHostdatum1 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum1"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag2") Is System.DBNull.Value Then
                        m_sHosttag2 = SqlString.Null
                    Else
                        m_sHosttag2 = New SqlString(CType(dtToReturn.Rows(0)("hosttag2"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum2") Is System.DBNull.Value Then
                        m_sHostdatum2 = SqlString.Null
                    Else
                        m_sHostdatum2 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum2"), String))
                    End If
                    If dtToReturn.Rows(0)("hosttag3") Is System.DBNull.Value Then
                        m_sHosttag3 = SqlString.Null
                    Else
                        m_sHosttag3 = New SqlString(CType(dtToReturn.Rows(0)("hosttag3"), String))
                    End If
                    If dtToReturn.Rows(0)("hostdatum3") Is System.DBNull.Value Then
                        m_sHostdatum3 = SqlString.Null
                    Else
                        m_sHostdatum3 = New SqlString(CType(dtToReturn.Rows(0)("hostdatum3"), String))
                    End If
                    If dtToReturn.Rows(0)("inklhostmavip") Is System.DBNull.Value Then
                        m_bInklhostmavip = SqlBoolean.Null
                    Else
                        m_bInklhostmavip = New SqlBoolean(CType(dtToReturn.Rows(0)("inklhostmavip"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfilDokAuswertung::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportfeldregel_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportfeldregel")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportfeldregel_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReportReportfeldregelNr = New SqlInt32(CType(dtToReturn.Rows(0)("ReportReportfeldregelNr"), Integer))
                    If dtToReturn.Rows(0)("reportNr") Is System.DBNull.Value Then
                        m_iReportNr = SqlInt32.Null
                    Else
                        m_iReportNr = New SqlInt32(CType(dtToReturn.Rows(0)("reportNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ReportFeldRegelNr") Is System.DBNull.Value Then
                        m_iReportFeldRegelNr = SqlInt32.Null
                    Else
                        m_iReportFeldRegelNr = New SqlInt32(CType(dtToReturn.Rows(0)("ReportFeldRegelNr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("Reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("Reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("eingabe_zwingend") Is System.DBNull.Value Then
                        m_bEingabe_zwingend = SqlBoolean.Null
                    Else
                        m_bEingabe_zwingend = New SqlBoolean(CType(dtToReturn.Rows(0)("eingabe_zwingend"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportfeldregel::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireport_reportgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReport_reportgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iReport_reportgruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("report_reportgruppenr"), Integer))
                    If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
                        m_sBezeichnung = SqlString.Null
                    Else
                        m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
                    End If
                    If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
                        m_sBeschreibung = SqlString.Null
                    Else
                        m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("reportnr") Is System.DBNull.Value Then
                        m_iReportnr = SqlInt32.Null
                    Else
                        m_iReportnr = New SqlInt32(CType(dtToReturn.Rows(0)("reportnr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("report_gruppenr") Is System.DBNull.Value Then
                        m_iReport_gruppenr = SqlInt32.Null
                    Else
                        m_iReport_gruppenr = New SqlInt32(CType(dtToReturn.Rows(0)("report_gruppenr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ICommonDBAccess.SelectOne Method

Function	SelectOne() As DataTable

Source code

[Visual Basic]
        Function	SelectOne() As DataTable

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsMyMitarbeiter.SelectAllMandantMitarbeiter Method

Public Function SelectAllMandantMitarbeiter() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllMandantMitarbeiter() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_mandantmitarbeiter_Select]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@mandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Globals.MandantNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectAll::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


clsReport_reportgruppe.SelectAllWreport_gruppenrLogic Method

Public Function SelectAllWreport_gruppenrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWreport_gruppenrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_SelectAllWreport_gruppenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_SelectAllWreport_gruppenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::SelectAllWreport_gruppenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.SelectAllWreportnrLogic Method

Public Function SelectAllWreportnrLogic() As DataTable

Source code

[Visual Basic]
        Public Function SelectAllWreportnrLogic() As DataTable
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_SelectAllWreportnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("report_reportgruppe")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_SelectAllWreportnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::SelectAllWreportnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsMyMitarbeiter.SelectMitarbeiterWithNr Method

Public Sub SelectMitarbeiterWithNr( _
   ByVal MaNr As Long _
)

Parameters

MaNr
Required.

Source code

[Visual Basic]
        Public Sub SelectMitarbeiterWithNr(ByVal MaNr As Long)
            Dim mitarbeiterdata As DataTable
            Me.iMitarbeiternr = New SqlInt32(CType(MaNr, Int32))
            Me.cpMainConnectionProvider = conn
            mitarbeiterdata = Me.SelectOne
            Globals.MitarbeiterNr = mitarbeiterdata.Rows(0).Item("mitarbeiternr")
            Globals.Sprache = mitarbeiterdata.Rows(0).Item("sprache")
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


clsOffice_Vorlage_Datei.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("Office_Vorlage_Datei")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iOffice_vorlage_dateinr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlage_dateinr"), Integer))
                    If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
                        m_iOffice_vorlagenr = SqlInt32.Null
                    Else
                        m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
                    End If
                    If dtToReturn.Rows(0)("vorlage") Is System.DBNull.Value Then
                        m_blobVorlage = SqlBinary.Null
                    Else
                        m_blobVorlage = New SqlBinary(CType(dtToReturn.Rows(0)("vorlage"), Byte()))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("freigegeben") Is System.DBNull.Value Then
                        m_bFreigegeben = SqlBoolean.Null
                    Else
                        m_bFreigegeben = New SqlBoolean(CType(dtToReturn.Rows(0)("freigegeben"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("fragabe_am") Is System.DBNull.Value Then
                        m_daFragabe_am = SqlDateTime.Null
                    Else
                        m_daFragabe_am = New SqlDateTime(CType(dtToReturn.Rows(0)("fragabe_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("freigabe_durch") Is System.DBNull.Value Then
                        m_iFreigabe_durch = SqlInt32.Null
                    Else
                        m_iFreigabe_durch = New SqlInt32(CType(dtToReturn.Rows(0)("freigabe_durch"), Integer))
                    End If
                    If dtToReturn.Rows(0)("uebernahme_produktion") Is System.DBNull.Value Then
                        m_daUebernahme_produktion = SqlDateTime.Null
                    Else
                        m_daUebernahme_produktion = New SqlDateTime(CType(dtToReturn.Rows(0)("uebernahme_produktion"), Date))
                    End If
                    If dtToReturn.Rows(0)("dateiname") Is System.DBNull.Value Then
                        m_sDateiname = SqlString.Null
                    Else
                        m_sDateiname = New SqlString(CType(dtToReturn.Rows(0)("dateiname"), String))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_Vorlage_Datei::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.SelectOne Method

Overrides Public Function SelectOne() As DataTable

Source code

[Visual Basic]
        Overrides Public Function SelectOne() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ParameterSetList_SelectOne]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = new DataTable("ParameterSetList")
            Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iParameterSetListID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetListID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ParameterSetList_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                If dtToReturn.Rows.Count > 0 Then
                    m_iParameterSetListID = New SqlInt32(CType(dtToReturn.Rows(0)("ParameterSetListID"), Integer))
                    If dtToReturn.Rows(0)("ParameterSetNameID") Is System.DBNull.Value Then
                        m_iParameterSetNameID = SqlInt32.Null
                    Else
                        m_iParameterSetNameID = New SqlInt32(CType(dtToReturn.Rows(0)("ParameterSetNameID"), Integer))
                    End If
                    m_iReportReportfeldregelNr = New SqlInt32(CType(dtToReturn.Rows(0)("ReportReportfeldregelNr"), Integer))
                    If dtToReturn.Rows(0)("ParameterDisplayValue") Is System.DBNull.Value Then
                        m_sParameterDisplayValue = SqlString.Null
                    Else
                        m_sParameterDisplayValue = New SqlString(CType(dtToReturn.Rows(0)("ParameterDisplayValue"), String))
                    End If
                    If dtToReturn.Rows(0)("datenherkunft") Is System.DBNull.Value Then
                        m_sDatenherkunft = SqlString.Null
                    Else
                        m_sDatenherkunft = New SqlString(CType(dtToReturn.Rows(0)("datenherkunft"), String))
                    End If
                    If dtToReturn.Rows(0)("reihenfolge") Is System.DBNull.Value Then
                        m_iReihenfolge = SqlInt32.Null
                    Else
                        m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
                    End If
                    If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
                        m_bAktiv = SqlBoolean.Null
                    Else
                        m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
                    End If
                    If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
                        m_daErstellt_am = SqlDateTime.Null
                    Else
                        m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
                        m_daMutiert_am = SqlDateTime.Null
                    Else
                        m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
                    End If
                    If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
                        m_iMutierer = SqlInt32.Null
                    Else
                        m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
                    End If
                    If dtToReturn.Rows(0)("ParameterNavigationValue") Is System.DBNull.Value Then
                        m_sParameterNavigationValue = SqlString.Null
                    Else
                        m_sParameterNavigationValue = New SqlString(CType(dtToReturn.Rows(0)("ParameterNavigationValue"), String))
                    End If
                    If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
                        m_iMandantnr = SqlInt32.Null
                    Else
                        m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
                    End If
                End If
                Return dtToReturn
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsParameterSetList::SelectOne::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsMyMitarbeiter.SelectWithTGNummer Method

Public Function SelectWithTGNummer() As DataTable

Source code

[Visual Basic]
        Public Function SelectWithTGNummer() As DataTable
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_mitarbeiter_SelectWithTGNummer]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection
            Try

                scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_xtgnummer))

                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                sdaAdapter.Fill(dtToReturn)
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAllWithTGNummer' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If
                Globals.CurrentMitarbeiterdata = dtToReturn
                Return dtToReturn
            Catch ex As Exception
                MsgBox(ex.Message)
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMitarbeiter::SelectWithTGNummer::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


clsMyMitarbeiter.Select_Mandant Method

Private Sub Select_Mandant()

Source code

[Visual Basic]
        Private Sub Select_Mandant()
            Dim f As New Selektion_Mandant()
            f.ShowDialog()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


SingleInstance.SendMessageToWindow (System.Object) Method

Private Shared Function SendMessageToWindow( _
   ByVal oCmd As Object _
) As Boolean

Parameters

oCmd
Required.

Source code

[Visual Basic]
        Private Shared Function SendMessageToWindow(ByVal oCmd As Object) As Boolean
            Try
                Dim strCmd As String = SerialHelper.SerializeToBase64String(oCmd)
                Return SendMessageToWindow(strCmd)
            Catch
                Return False
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.SendMessageToWindow (System.String) Method

Private Shared Function SendMessageToWindow( _
   ByVal strCmd As String _
) As Boolean

Parameters

strCmd
Required.

Source code

[Visual Basic]
        Private Shared Function SendMessageToWindow(ByVal strCmd As String) As Boolean
            If _hWnd = -1 Then Return False
            If Len(strCmd) = 0 Then
                Try
                    Dim CD As COPYDATASTRUCT
                    With CD
                        .dwData = 0
                        .cbData = 0
                        .lpData = 0
                    End With
                    Return SendCDSToWindow(cd)
                Catch
                    Return False
                End Try
            Else
                Try
                    Dim B() As Byte = Encoding.Default.GetBytes(strCmd)
                    Dim lpB As IntPtr = Marshal.AllocHGlobal(B.Length)
                    Marshal.Copy(B, 0, lpB, B.Length)

                    Dim CD As COPYDATASTRUCT
                    With CD
                        .dwData = 0
                        .cbData = B.Length
                        .lpData = lpB.ToInt32
                    End With
                    Erase B

                    Try
                        If SendCDSToWindow(cd) Then
                            Return True
                        Else
                            Return False
                        End If
                    Catch
                        Return False
                    Finally
                        Marshal.FreeHGlobal(lpB)
                    End Try

                Catch
                    Return False
                End Try
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


frmDomainReportfeldregel.SpaltenTitel_Aktualisieren (System.Data.DataSet, C1.Win.C1TrueDBGrid.C1TrueDBGrid) Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal ds As DataSet, _
   ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid _
)

Parameters

ds
Required.
grd
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal ds As DataSet, ByRef grd As C1.Win.C1TrueDBGrid.C1TrueDBGrid)

        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim cols(grd.Splits(0).DisplayColumns.Count) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        Dim dc As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim s As String

        Dim DisplayColumnsCount As Integer
        Dim aSpalten(0, 0) As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim Reihe As C1.Win.C1TrueDBGrid.C1DisplayColumn
        Dim iMaxSortOrderValue As Integer = 0
        Dim dsMaxSortOrder As New DataSet()
        Dim bSetNewSortOrder As Boolean = True
        Dim iSpaltenOffset As Integer = 0 'Offset wenn Nothing in Array

        '============ Bestimmt Anzahl Displaycolumn und MaxValue Sortorder
        'Dim ssql As String
        'ssql = "SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'"
        Dim daMaxSortOrder As New SqlDataAdapter("SELECT MAX(Reihenfolge) AS MaxSortOrder FROM spalten WHERE tabelle = '" & Me.TableName & "'", Globals.sConnectionString)
        daMaxSortOrder.Fill(dsMaxSortOrder)
        DisplayColumnsCount = grd.Splits(0).DisplayColumns.Count - 1
        iMaxSortOrderValue = dsMaxSortOrder.Tables(0).Rows(0).Item(0)
        ReDim aSpalten(iMaxSortOrderValue - 1, 0)       'Array für Anzahlen definieren

        t = ds.Tables(0)
        ts.Tabelle = Me.TableName
        For i = 0 To grd.Columns.Count - 1
            s = grd.Columns(i).DataField
            ts.Feld = s
            ts.getspalte()
            grd.Columns(i).Caption = ts.spaltenname
            If ts.ColWith = 0 Then
                grd.Splits(0).DisplayColumns(i).Width = 0
                grd.Splits(0).DisplayColumns(i).Visible = False
            Else
                grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
            End If

            'If grd.Columns(i).Caption = "" Then
            '    'grd.Splits(0).DisplayColumns(i).Visible = False
            '    grd.Splits(0).DisplayColumns(i).Width = 0
            '    'grd.Columns(i).Caption = grd.Columns(i).DataField
            'Else
            '    grd.Splits(0).DisplayColumns(i).Width = ts.ColWith
            'End If
            If ts.locked Then
                grd.Splits(0).DisplayColumns(i).Locked = True
            End If

            If ts.AlsHacken Then
                grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
            End If

            'Präsentation von aktiv
            If grd.Columns(i).DataField = "aktiv" Then
                grd.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                grd.Columns(i).ValueItems.DefaultItem = True
                grd.Columns(i).DefaultValue = True
                grd.Columns(i).FilterText = True
            End If
            If grd.Columns(i).DataField = "erstellt_am" Then
                grd.Columns(i).DefaultValue = Now
            End If

            '============ Aktuelle Spalte in ArraySpalten schreiben
            '============ Sortorder darf nicht 0 sein
            If iMaxSortOrderValue > 0 Then
                If ts.Order = 0 Then
                    MessageBox.Show("Fehler Reihenfolge" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit dem Wert 0 sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Sortierreihenfolge 0", MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                Else
                    Reihe = grd.Splits(0).DisplayColumns(i)
                    If Not aSpalten(ts.Order - 1, 0) Is Nothing Then
                        '============ Arrayplatz bereits bleget
                        '                        MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Prüfen Sie die Sortierreihenfoge der Tabelle " & Me.TableName & " in der Systemadministration Spalten!", MessageBoxButtons.OK, "Sortierreihenfolge ", MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                        MessageBox.Show("Doppelte Sortier-Nummer!" & vbCrLf & "Tabelle " & Me.TableName & vbCrLf & "Spalte " & s & vbCrLf & "Sortierreihenfolge mit 2 gleichen Werten sind nicht erlaubt!" & vbCrLf & "Prüfen Sie die Reihenfolge der Tabelle " & Me.TableName & " in der Systemadministration Spalten", "Doppelte Sortier-Nummer " & ts.Order, MessageBoxButtons.OK, MessageBoxIcon.Information, MessageBoxDefaultButton.Button1)
                        'bSetNewSortOrder = False
                    End If
                    If ts.Order > 0 And aSpalten(ts.Order - 1, 0) Is Nothing Then
                        '============ Aktuelle Spalte in ArraySpalten schreiben
                        aSpalten(ts.Order - 1, 0) = Reihe
                    End If
                End If
            End If
        Next

        If iMaxSortOrderValue > 0 And bSetNewSortOrder = True Then
            '===============================================================================
            'Wenn in der Sortierreihenfoge keine 0 steht werden die Spalten neu Sortiert
            '===============================================================================
            Try
                '============ Spalten löschen
                For i = 0 To DisplayColumnsCount
                    grd.Splits(0).DisplayColumns.RemoveAt(0)
                Next
            Catch
            End Try
            '============ Spalten nachh Sortorder einfügen
            For i = 0 To iMaxSortOrderValue - 1
                Try
                    If Not aSpalten(i, 0) Is Nothing Then
                        If aSpalten(i, 0).Width > 0 Then
                            grd.Splits(0).DisplayColumns.Insert(i - iSpaltenOffset, aSpalten(i, 0))
                        Else
                            iSpaltenOffset += 1
                        End If
                    Else
                        iSpaltenOffset += 1
                    End If
                Catch ex As Exception
                    MsgBox(ex.Message)
                End Try

            Next
        End If
        dsMaxSortOrder = Nothing
        daMaxSortOrder = Nothing

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


frmDomainReportfeldregel.SpaltenTitel_Aktualisieren (System.Int32, System.String, System.Data.DataSet) Method

Public Sub SpaltenTitel_Aktualisieren( _
   ByVal tblnr As Integer, _
   ByVal tblname As String, _
   ByVal ds As DataSet _
)

Parameters

tblnr
Required.
tblname
Required.
ds
Required.

Source code

[Visual Basic]
    Public Sub SpaltenTitel_Aktualisieren(ByVal tblnr As Integer, ByVal tblname As String, ByVal ds As DataSet)
        'Spaltentitel setzen
        Dim titel As New EDOKA.MySpaltenTitel()
        Dim ts As New EDOKA.Tabellenspalte()
        Dim i As Integer
        Dim t As New DataTable()
        t = ds.Tables(0)
        If tblnr = 1 Then
            ts.Tabelle = tblname
            For i = 0 To Me.DomainList.Columns.Count - 1
                Dim s As String
                s = Me.DomainList.Columns(i).DataField
                ts.Feld = s
                ts.getspalte()
                If ts.spaltenname <> "" Then
                    Me.DomainList.Columns(i).Caption = ts.spaltenname
                    If Me.DomainList.Columns(i).Caption = "" Then
                        Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                    Else
                        Me.DomainList.Splits(0).DisplayColumns(i).Width = ts.ColWith
                    End If
                    If ts.locked Then
                        Me.DomainList.Splits(0).DisplayColumns(i).Locked = True
                    End If
                    If ts.AlsHacken Then
                        Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                    End If
                    'Präsentation von aktiv
                    If Me.DomainList.Columns(i).DataField = "aktiv" Then
                        Me.DomainList.Columns(i).ValueItems.Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        Me.DomainList.Columns(i).ValueItems.DefaultItem = True
                        Me.DomainList.Columns(i).DefaultValue = True
                        Me.DomainList.Columns(i).FilterText = True
                    End If
                    If Me.DomainList.Columns(i).DataField = "erstellt_am" Then
                        Me.DomainList.Columns(i).DefaultValue = Now
                    End If
                Else
                    Me.DomainList.Splits(0).DisplayColumns(i).Width = 0
                End If
            Next
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDomainReportfeldregel


MyMessage.Show_HinweisMessage (System.Int32, System.Int32, System.Int32, System.Int32) Method

Public Function Show_HinweisMessage( _
   ByVal profilnr As Integer, _
   ByVal messagenr As Integer, _
   ByVal MeldungsNummer As Integer, _
   ByVal style As Integer _
) As Boolean

Parameters

profilnr
Required.
messagenr
Required.
MeldungsNummer
Required.
style
Required.

Source code

[Visual Basic]
        Public Function Show_HinweisMessage(ByVal profilnr As Integer, ByVal messagenr As Integer, ByVal MeldungsNummer As Integer, ByVal style As Integer) As Boolean
            If ShowMessage(profilnr, messagenr, 0, style) Then
                Dim f As New frmHinweismeldung()
                f.Label1.Text = MyMsg.Get_Meldungstext(MeldungsNummer)
                f.CheckBox1.Checked = False
                f.MsgBoxStyle = style
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then Show_HinweisMessage = True Else Show_HinweisMessage = False
                If f.CheckBox1.Checked Then
                    ShowMessage(profilnr, messagenr, 1, style)
                End If
                f.Dispose()
            Else
                Show_HinweisMessage = True
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


MyMessage.Show_HinweisMessage (System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean) Method

Public Function Show_HinweisMessage( _
   ByVal profilnr As Integer, _
   ByVal messagenr As Integer, _
   ByVal MeldungsNummer As Integer, _
   ByVal style As Integer, _
   ByVal formOnTop As Boolean _
) As Boolean

Parameters

profilnr
Required.
messagenr
Required.
MeldungsNummer
Required.
style
Required.
formOnTop
Required.

Source code

[Visual Basic]
        Public Function Show_HinweisMessage(ByVal profilnr As Integer, ByVal messagenr As Integer, ByVal MeldungsNummer As Integer, ByVal style As Integer, ByVal formOnTop As Boolean) As Boolean
            If ShowMessage(profilnr, messagenr, 0, style) Then
                Dim f As New frmHinweismeldung()
                f.Label1.Text = MyMsg.Get_Meldungstext(MeldungsNummer)
                f.CheckBox1.Checked = False
                f.MsgBoxStyle = style
                If formOnTop = True Then f.TopMost = True
                f.ShowDialog()
                If f.DialogResult = DialogResult.OK Then Show_HinweisMessage = True Else Show_HinweisMessage = False
                If f.CheckBox1.Checked Then
                    ShowMessage(profilnr, messagenr, 1, style)
                End If
                f.Dispose()
            Else
                Show_HinweisMessage = True
            End If
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MyMessage


clsMyDokumentstatus.Statustyp Property

Property Statustyp() As Integer

Source code

[Visual Basic]
        Property Statustyp() As Integer
            Get
                Return m_statustyp
            End Get
            Set(ByVal Value As Integer)
                m_statustyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


clsMyDokumentstatus.Statustypnr Property

Property Statustypnr() As Long

Source code

[Visual Basic]
        Property Statustypnr() As Long
            Get
                Return m_statustypnr
            End Get
            Set(ByVal Value As Long)
                m_statustypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


crTextColor Property

Public crTextColor As Int32

Source code

[Visual Basic]
        Public crTextColor As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cwActual Property

Public cwActual As UInt32

Source code

[Visual Basic]
    Public cwActual As UInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cwBuf Property

Public cwBuf As UInt32

Source code

[Visual Basic]
    Public cwBuf As UInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cpMax Property

Public cpMax As Int32

Source code

[Visual Basic]
        Public cpMax As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cpMin Property

Public cpMin As Int32

Source code

[Visual Basic]
        Public cpMin As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsParameterSetList.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daErstellt_amTmp As SqlDateTime = Value
                If daErstellt_amTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daErstellt_am", "daErstellt_am can't be NULL")
                End If
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.daErstellt_am Property

Public Property [daErstellt_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daErstellt_am]() As SqlDateTime
            Get
                Return m_daErstellt_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daErstellt_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsOffice_Vorlage_Datei.daFragabe_am Property

Public Property [daFragabe_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daFragabe_am]() As SqlDateTime
            Get
                Return m_daFragabe_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daFragabe_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsOffice_Vorlage_Datei.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                Dim daMutiert_amTmp As SqlDateTime = Value
                If daMutiert_amTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("daMutiert_am", "daMutiert_am can't be NULL")
                End If
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.daMutiert_am Property

Public Property [daMutiert_am]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daMutiert_am]() As SqlDateTime
            Get
                Return m_daMutiert_am
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daMutiert_am = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsOffice_Vorlage_Datei.daUebernahme_produktion Property

Public Property [daUebernahme_produktion]() As SqlDateTime

Source code

[Visual Basic]
        Public Property [daUebernahme_produktion]() As SqlDateTime
            Get
                Return m_daUebernahme_produktion
            End Get
            Set(ByVal Value As SqlDateTime)
                m_daUebernahme_produktion = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


frmBLDruck Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck Constructor (System.Int32)

Public Sub New( _
   ByVal Auslieferungnr As Integer _
)

Parameters

Auslieferungnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal Auslieferungnr As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.auslieferungnr = Auslieferungnr
        Me.Editmode = True
        Me.CreateDocument = False
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBLDruck Constructor (System.String, System.Int32, System.Int32, System.Boolean)

Public Sub New( _
   ByVal bkpar00 As String, _
   ByVal nrpar00 As Integer, _
   ByVal profilnr As Integer, _
   ByVal createnew As Boolean _
)

Parameters

bkpar00
Required.
nrpar00
Required.
profilnr
Required.
createnew
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal bkpar00 As String, ByVal nrpar00 As Integer, ByVal profilnr As Integer, ByVal createnew As Boolean)
        MyBase.New()
        InitializeComponent()
        Me.Text = Me.Text + bkpar00
        Me.BKPAR00 = bkpar00
        Me.NRPAR00 = nrpar00
        Me.Profilnr = profilnr
        Me.CreateNew = createnew
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBLDruck


frmBanklagerndverarbeitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung Constructor (System.Int32, System.Boolean)

Public Sub New( _
   ByVal nrpar00 As Integer, _
   ByVal bck As Boolean _
)

Parameters

nrpar00
Required.
bck
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal nrpar00 As Integer, ByVal bck As Boolean)
        MyBase.New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.Text = Me.Text + ": " + DivFnkt.get_parnter_namevorname(nrpar00)
        If bck Then
            pnlbck.Visible = True
            pnleinzeldokument.Visible = False
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


frmBanklagerndverarbeitung Constructor (System.Int32, System.Boolean, System.Boolean)

Public Sub New( _
   ByVal nrpar00 As Integer, _
   ByVal bck As Boolean, _
   ByVal einzeldokument As Boolean _
)

Parameters

nrpar00
Required.
bck
Required.
einzeldokument
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal nrpar00 As Integer, ByVal bck As Boolean, ByVal einzeldokument As Boolean)
        MyBase.New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.Text = Me.Text + ": " + DivFnkt.get_parnter_namevorname(nrpar00)
        If einzeldokument Then
            pnleinzeldokument.Visible = True
            pnlbck.Visible = False
        End If

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmBanklagerndverarbeitung


dwData Property

Public dwData As Integer

Source code

[Visual Basic]
            Public dwData As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


dwEffects Property

Public dwEffects As UInt32

Source code

[Visual Basic]
        Public dwEffects As UInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


dwMask Property

Public dwMask As UInt32

Source code

[Visual Basic]
        Public dwMask As UInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


frmAdminMitarbeiterEdit Constructor

Ertellt eine Formularinstanz um einen neuen Mitarbeiter zu erfassen

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        lblMitarbeiterNr.Text = ""
        lblBearbeitet.Text = ""
        lblErstellt.Text = ""

        cmdCreateStandardProfil.Enabled = False
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmAdminMitarbeiterEdit Constructor (System.Int32)

Erstellt eine Formularinstanz um einen bestehenden Mitarbeiter zu bearbeiten

Public Sub New( _
   ByVal mitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required. Der zu bearbeitende Mitarbeiter

Source code

[Visual Basic]
    Public Sub New(ByVal mitarbeiterNr As Integer)
        Me.New()
        Try

            If mitarbeiterNr > 0 Then
                _mitarbeiter = New BusinessFacade.Mitarbeiter(mitarbeiterNr)

                LoadDetail()
                cmdCreateStandardProfil.Enabled = True
            End If
        Catch ex As Exception
            MessageBox.Show(BusinessFacade.Meldungstext.GetInhaltById(303), Common.Consts.FEHLER, MessageBoxButtons.OK, MessageBoxIcon.Error)
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKAApp.frmAdminMitarbeiterEdit.New: ", ex.Message & " StackTrance: " & ex.StackTrace, TraceLevel.Error)
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmAdminMitarbeiterEdit


frmDokumentAufbereitung Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentAufbereitung Constructor (System.Int32, System.Int32)

Public Sub New( _
   ByVal druckjobid As Integer, _
   ByVal part As Integer _
)

Parameters

druckjobid
Required.
part
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal druckjobid As Integer, ByVal part As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.M_Druchjobid = druckjobid
        Me.alnr = druckjobid
        Me.part = part
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentAufbereitung


frmDokumentKopieren Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentKopieren Constructor (System.Int32)

Public Sub New( _
   ByVal iAktuellerPartner As Integer _
)

Parameters

iAktuellerPartner
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal iAktuellerPartner As Integer)
        MyBase.New()
        InitializeComponent()

        m_iPartner = iAktuellerPartner
        m_iAktiverPartner = iAktuellerPartner
        m_iFunktionType = EnumFunktionType.PartnerAktuell

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentKopieren


frmDokumentinformationen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentinformationen Constructor (System.String, System.Int32)

Public Sub New( _
   ByVal dokumentid As String, _
   ByVal typ As Integer _
)

Parameters

dokumentid
Required.
typ
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dokumentid As String, ByVal typ As Integer)
        MyBase.New()
        InitializeComponent()
        Me.Dokumentid = dokumentid
        Me.Typ = typ
        If Me.Typ = 0 Then
            Me.TabControl1.Visible = True
            Me.TabControl3.Visible = False
        Else
            Me.TabControl1.Visible = False
            Me.TabControl3.Visible = True
        End If

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentinformationen


frmDokumentpaketdefinition Constructor (System.Boolean, System.Int32, System.Boolean, System.Boolean)

Public Sub New( _
   ByVal Neues_DP As Boolean, _
   ByVal dokumentpaketnr As Integer, _
   ByVal individuelles_DP As Boolean, _
   ByVal ShowOnly As Boolean _
)

Parameters

Neues_DP
Required.
dokumentpaketnr
Required.
individuelles_DP
Required.
ShowOnly
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal Neues_DP As Boolean, ByVal dokumentpaketnr As Integer, ByVal individuelles_DP As Boolean, ByVal ShowOnly As Boolean)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.Dokumentpaketnr = dokumentpaketnr
        Me.Individuelles_DP = individuelles_DP
        Me.Neu = Neues_DP
        Me.ShowOnly = ShowOnly
        If ShowOnly = True Then
            Me.btnSave.Visible = False
        End If
        If Me.Individuelles_DP = True Then Me.TreeStruktur.ContextMenu = Me.ctMenuStruktur Else Me.TreeStruktur.ContextMenu = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition Constructor (System.Boolean, System.Int32, System.Boolean, System.String)

Public Sub New( _
   ByVal Neues_DP As Boolean, _
   ByVal Dokumentpaketnr As Integer, _
   ByVal individuelles_dp As Boolean, _
   ByVal Dokumenttypnummern As String _
)

Parameters

Neues_DP
Required.
Dokumentpaketnr
Required.
individuelles_dp
Required.
Dokumenttypnummern
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal Neues_DP As Boolean, ByVal Dokumentpaketnr As Integer, ByVal individuelles_dp As Boolean, ByVal Dokumenttypnummern As String)
        MyBase.New()
        InitializeComponent()
        Me.Dokumentpaketnr = Dokumentpaketnr
        Me.Individuelles_DP = individuelles_dp
        Me.Neu = Neues_DP
        Me.ShowOnly = ShowOnly
        If ShowOnly = True Then
            Me.btnSave.Visible = False
        End If
        If Me.Individuelles_DP = True Then Me.TreeStruktur.ContextMenu = Me.ctMenuStruktur Else Me.TreeStruktur.ContextMenu = Nothing
        Me.DokumenttypNummern = Dokumenttypnummern
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketdefinition Constructor (System.Int32, System.Int32)

Public Sub New( _
   ByVal Dokumentpaketnr As Integer, _
   ByVal mitarbeiternr As Integer _
)

Parameters

Dokumentpaketnr
Required.
mitarbeiternr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal Dokumentpaketnr As Integer, ByVal mitarbeiternr As Integer)
        MyBase.New()
        InitializeComponent()
        Me.Dokumentpaketnr = Dokumentpaketnr
        Me.Individuelles_DP = True
        Me.Neu = False
        Me.ShowOnly = False
        Me.MitarbeiterKopie = True
        Me.Mitarbeiternr = mitarbeiternr
        If Me.Individuelles_DP = True Then Me.TreeStruktur.ContextMenu = Me.ctMenuStruktur Else Me.TreeStruktur.ContextMenu = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaket Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket Constructor (System.Int32)

Public Sub New( _
   ByVal edex_dpinstanznr As Integer _
)

Parameters

edex_dpinstanznr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal edex_dpinstanznr As Integer)

        MyBase.New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.DP_Instanz = True
        Me.dp_instanznr = edex_dpinstanznr
        Try
            Dim dp As New edokadb.clsEdex_dpinstanz()
            dp.cpMainConnectionProvider = conn
            dp.iNreintrag = New SqlInt32(CType(edex_dpinstanznr, Int32))
            dp.SelectOne()
            Me.Dokumenttypnummern = dp.sDokumentpaketnummern.Value
            Me.Dokumenttyphacken = dp.sHacken.Value
            Me.NrPar00 = dp.iNrpar00.Value
            Me.Dokumentpaketnr = dp.iDokumentpaketnr.Value
            Me.IndividuellesDP = dp.bIndividuellesDP.Value
            Me.Profilnr = dp.iProfilnr.Value
            Me.Profile = Generic_Select(5)

            Dim ProfilFound As Boolean = False
            Dim I1 As Integer = 0
            For I1 = 0 To Me.Profile.Rows.Count - 1
                If Me.Profile.Rows(I1).Item("profilnr") = Me.Profilnr Then
                    ProfilFound = True
                End If
            Next
            If Not ProfilFound Then
                For I1 = 0 To Me.Profile.Rows.Count - 1
                    If Me.Profile.Rows(I1).Item("Standard") = True Then
                        Me.Profilnr = Me.Profile.Rows(I1).Item("profilnr")
                    End If
                Next
            End If
            dp.Dispose()

            Dim splitter
            Dim i As Integer = 0

            Try
                splitter = Me.Dokumenttypnummern.Split(";")
                Do Until splitter(i) Is Nothing
                    If splitter(i) <> "" Then
                        Me.ColDokumenttypNr.Add(splitter(i))
                    End If
                    i = i + 1
                Loop
            Catch
            End Try
        Catch
            MsgBox("Das Dokumentpaket konnte nicht geladen werden.")
        End Try
        Me.cbdokumentstatus.SelectedIndex = 0

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaket Constructor (System.Int32, System.Boolean, System.Int32)

Public Sub New( _
   ByVal dpvorlagenr As Integer, _
   ByVal indivDP As Boolean, _
   ByVal Partnernr As Integer _
)

Parameters

dpvorlagenr
Required.
indivDP
Required.
Partnernr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dpvorlagenr As Integer, ByVal indivDP As Boolean, ByVal Partnernr As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.Dokumentpaketnr = dpvorlagenr
        Me.IndividuellesDP = indivDP
        Me.NrPar00 = Partnernr

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.cbdokumentstatus.SelectedIndex = 0
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaket


frmDokumentpaketdefinition Constructor (System.Boolean, System.Int32, System.Boolean)

Public Sub New( _
   ByVal Neues_DP As Boolean, _
   ByVal dokumentpaketnr As Integer, _
   ByVal individuelles_DP As Boolean _
)

Parameters

Neues_DP
Required.
dokumentpaketnr
Required.
individuelles_DP
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal Neues_DP As Boolean, ByVal dokumentpaketnr As Integer, ByVal individuelles_DP As Boolean)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.Dokumentpaketnr = dokumentpaketnr
        Me.Individuelles_DP = individuelles_DP
        Me.Neu = Neues_DP

        If Me.Individuelles_DP = True Then Me.TreeStruktur.ContextMenu = Me.ctMenuStruktur Else Me.TreeStruktur.ContextMenu = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketdefinition


frmDokumentpaketuebersicht Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDokumentpaketuebersicht Constructor (System.Int32)

Public Sub New( _
   ByVal mitarbeiternr As Integer _
)

Parameters

mitarbeiternr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal mitarbeiternr As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        Me.Mitarbeiternr = Mitarbeiternr
        If Me.Mitarbeiternr <> 0 Then Me.individuelles_dp = True Else Me.individuelles_dp = False

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDokumentpaketuebersicht


frmDruckabschluss Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmDruckabschluss Constructor (System.Int32)

Public Sub New( _
   ByVal serienbriefnr As Integer _
)

Parameters

serienbriefnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal serienbriefnr As Integer)
        MyBase.New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.serienbriefnr = serienbriefnr

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmDruckabschluss


frmPDFPrinter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPDFPrinter Constructor (System.Boolean)

Public Sub New( _
   ByVal ShowDoc As Boolean _
)

Parameters

ShowDoc
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal ShowDoc As Boolean)
        MyBase.New()
        InitializeComponent()
        Me.m_showdoc = ShowDoc
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDFPrinter


frmPartnerlisteSpeichern Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmPartnerlisteSpeichern Constructor (System.Data.DataTable)

Public Sub New( _
   ByVal dt As DataTable _
)

Parameters

dt
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dt As DataTable)
        MyBase.New()
        InitializeComponent()
        empfaenger = dt.Copy
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPartnerlisteSpeichern


frmProgress Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmProgress Constructor (System.Boolean)

Public Sub New( _
   ByVal CloseIsInvisible As Boolean _
)

Parameters

CloseIsInvisible
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal CloseIsInvisible As Boolean)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        Me.CloseIsInvisible = CloseIsInvisible
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmProgress


frmSBPDFPrinter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmSBPDFPrinter Constructor (System.Int32, System.Boolean)

Public Sub New( _
   ByVal druckjobnr As Integer, _
   ByVal ShowDoc As Boolean _
)

Parameters

druckjobnr
Required.
ShowDoc
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal druckjobnr As Integer, ByVal ShowDoc As Boolean)
        MyBase.New()
        InitializeComponent()
        Me.m_showdoc = ShowDoc
        Me.m_druckjobnr = druckjobnr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSBPDFPrinter


frmOfficePreview Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmOfficePreview Constructor (Microsoft.VisualBasic.Collection)

Public Sub New( _
   ByVal gd As Collection _
)

Parameters

gd
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal gd As Collection)
        MyBase.New()
        InitializeComponent()
        Dim i As Integer
        For i = 1 To gd.Count
            Me.ListBox1.Items.Add(gd.Item(i))
        Next
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmOfficePreview


frmPDF_Printer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmPDF_Printer Constructor (System.String, System.Boolean)

Public Sub New( _
   ByVal druckjobPfad As String, _
   ByVal ShowDoc As Boolean _
)

Parameters

druckjobPfad
Required.
ShowDoc
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal druckjobPfad As String, ByVal ShowDoc As Boolean)
        MyBase.New()
        InitializeComponent()
        Me.m_showdoc = ShowDoc
        Me.m_druckjobPfad = druckjobPfad
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmPDF_Printer


frmSerienbriefe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSerienbriefe Constructor (System.Boolean, System.Int32)

Public Sub New( _
   ByVal openforprinting As Boolean, _
   ByVal serienbriefnr As Integer _
)

Parameters

openforprinting
Required.
serienbriefnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal openforprinting As Boolean, ByVal serienbriefnr As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.OpenForPrinting = openforprinting
        Me.printsbnr = serienbriefnr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSerienbriefe


frmSuchFormular Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmSuchFormular Constructor (System.Boolean)

Public Sub New( _
   ByVal NeueSuche As Boolean _
)

Parameters

NeueSuche
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal NeueSuche As Boolean)
        MyBase.New()
        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen
        Me.m_NeueSuche = NeueSuche
        If Not NeueSuche Then Me.show_checkmessage = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmSuchFormular


frmWatchJob Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWatchJob Constructor (System.Int32)

Public Sub New( _
   ByVal druckjobnr As Integer _
)

Parameters

druckjobnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal druckjobnr As Integer)
        MyBase.New()
        InitializeComponent()
        Me.m_druckjobnr = druckjobnr
        Me.Timer1.Enabled = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWatchJob


frmWordViewer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        'This call is required by the Windows Form Designer.
        InitializeComponent()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmWordViewer Constructor (System.Boolean)

Public Sub New( _
   ByVal printable As Boolean _
)

Parameters

printable
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal printable As Boolean)
        MyBase.New()
        'This call is required by the Windows Form Designer.
        InitializeComponent()
        If printable = False Then
            Me.ToolBarButton2.Visible = False
        Else
            Me.ToolBarButton2.Visible = True
        End If
        Me.WindowState = FormWindowState.Maximized
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmWordViewer


frmcoldviewer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmcoldviewer Constructor (Microsoft.VisualBasic.Collection)

Public Sub New( _
   ByVal datacollection As Collection _
)

Parameters

datacollection
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal datacollection As Collection)
        MyBase.New()
        InitializeComponent()
        Me.dokdata = datacollection
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmcoldviewer


frmsbdruck Constructor (System.Int32)

Public Sub New( _
   ByVal serienbriefnr As Integer _
)

Parameters

serienbriefnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal serienbriefnr As Integer)
        MyBase.New()
        InitializeComponent()
        Me.serienbriefnr = serienbriefnr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmsbpartnerdetail Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmsbpartnerdetail Constructor (System.Boolean, System.Data.DataTable, System.String)

Public Sub New( _
   ByVal add As Boolean, _
   ByVal dt As DataTable, _
   ByVal nrpar00 As String _
)

Parameters

add
Required.
dt
Required.
nrpar00
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal add As Boolean, ByVal dt As DataTable, ByVal nrpar00 As String)
        MyBase.New()
        InitializeComponent()
        Try
            Me.nrpar00 = nrpar00
        Catch
            Me.nrpar00 = -1
        End Try
        Me.AddNew = add
        Me.dt = dt
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbpartnerdetail


frmpersvorlageladen Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmpersvorlageladen Constructor (System.Int32)

Public Sub New( _
   ByVal dokumenttypnr As Integer _
)

Parameters

dokumenttypnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dokumenttypnr As Integer)
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()
        Me.dokumenttypnr = dokumenttypnr
        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmpersvorlageladen


frmsbdruck Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmsbdruck


frmtextmarken Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        MyBase.New()

        ' Dieser Aufruf ist für den Windows Form-Designer erforderlich.
        InitializeComponent()

        ' Initialisierungen nach dem Aufruf InitializeComponent() hinzufügen

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


frmtextmarken Constructor (System.Int32, System.Boolean, System.Data.DataSet, System.Int32)

Public Sub New( _
   ByVal serienbriefnr As Integer, _
   ByVal DokumentBearbeitungDurchUser As Boolean, _
   ByVal dsempfaenger As DataSet, _
   ByVal dokumenttypnr As Integer _
)

Parameters

serienbriefnr
Required.
DokumentBearbeitungDurchUser
Required.
dsempfaenger
Required.
dokumenttypnr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal serienbriefnr As Integer, ByVal DokumentBearbeitungDurchUser As Boolean, ByVal dsempfaenger As DataSet, ByVal dokumenttypnr As Integer)
        MyBase.New()
        InitializeComponent()
        Me.serienbriefnr = serienbriefnr
        Me.DokumentBearbeitungDurchUser = DokumentBearbeitungDurchUser
        Me.dsempfaenger = dsempfaenger
        Me.Dokumenttypnr = dokumenttypnr
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmtextmarken


hdc Property

Public hdc As IntPtr

Source code

[Visual Basic]
        Public hdc As IntPtr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


hdcTarget Property

Public hdcTarget As IntPtr

Source code

[Visual Basic]
        Public hdcTarget As IntPtr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


highpart Property

Dim highpart As Integer

Source code

[Visual Basic]
        Dim highpart As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


m_sHostdoktyp Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMkost Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHostpartner Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sParameterNavigationValue Variable

Private 		m_sDatenherkunft, _
   m_sParameterNavigationValue, _
   m_sParameterDisplayValue As SqlString

Source code

[Visual Basic]
        Private 		m_sDatenherkunft, m_sParameterNavigationValue, m_sParameterDisplayValue As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_sHosttag1 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHosttag2 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHosttag3 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMma Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMmb Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMnl Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMteam Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sMutaelterasl Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sParameterDisplayValue Variable

Private 		m_sDatenherkunft, _
   m_sParameterNavigationValue, _
   m_sParameterDisplayValue As SqlString

Source code

[Visual Basic]
        Private 		m_sDatenherkunft, m_sParameterNavigationValue, m_sParameterDisplayValue As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_sSort Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sVkost Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sVma Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sVmb Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sVnl Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sVteam Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_xtgnummer Variable

Private m_xtgnummer As String

Source code

[Visual Basic]
        Private m_xtgnummer As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


m_statustyp Variable

Dim m_statustyp As Integer

Source code

[Visual Basic]
        Dim m_statustyp As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


m_statustypnr Variable

Dim m_statustypnr As Long

Source code

[Visual Basic]
        Dim m_statustypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


majorVersion Property

Public majorVersion As Integer

Source code

[Visual Basic]
        Public majorVersion As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


minorVersion Property

Public minorVersion As Integer

Source code

[Visual Basic]
        Public minorVersion As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


nLength Property

Public nLength As Integer

Source code

[Visual Basic]
        Public nLength As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


ouser Variable

Dim ouser As New WindowsPrincipal( _
   WindowsIdentity.GetCurrent _
)

Source code

[Visual Basic]
        Dim ouser As New WindowsPrincipal(WindowsIdentity.GetCurrent)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


platformId Property

Public platformId As Integer

Source code

[Visual Basic]
        Public platformId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


rc Property

Public rc As STRUCT_RECT

Source code

[Visual Basic]
        Public rc As STRUCT_RECT

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


rcPage Property

Public rcPage As STRUCT_RECT

Source code

[Visual Basic]
        Public rcPage As STRUCT_RECT

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


rgwz Property

Public rgwz As Char

Source code

[Visual Basic]
    Public rgwz As Char

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


right Property

Public right As Int32

Source code

[Visual Basic]
        Public right As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsProfilDokAuswertung.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBeschreibungTmp As SqlString = Value
                If sBeschreibungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
                End If
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportgruppe.sBeschreibung Property

Public Property [sBeschreibung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBeschreibung]() As SqlString
            Get
                Return m_sBeschreibung
            End Get
            Set(ByVal Value As SqlString)
                m_sBeschreibung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsProfilDokAuswertung.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                Dim sBezeichnungTmp As SqlString = Value
                If sBezeichnungTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sBezeichnung", "sBezeichnung can't be NULL")
                End If
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportgruppe.sBezeichnung Property

Public Property [sBezeichnung]() As SqlString

Source code

[Visual Basic]
        Public Property [sBezeichnung]() As SqlString
            Get
                Return m_sBezeichnung
            End Get
            Set(ByVal Value As SqlString)
                m_sBezeichnung = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsProfilDokAuswertung.sColor1 Property

Public Property [sColor1]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor1]() As SqlString
            Get
                Return m_sColor1
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor1Tmp As SqlString = Value
                If sColor1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor1", "sColor1 can't be NULL")
                End If
                m_sColor1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor2 Property

Public Property [sColor2]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor2]() As SqlString
            Get
                Return m_sColor2
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor2Tmp As SqlString = Value
                If sColor2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor2", "sColor2 can't be NULL")
                End If
                m_sColor2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor3 Property

Public Property [sColor3]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor3]() As SqlString
            Get
                Return m_sColor3
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor3Tmp As SqlString = Value
                If sColor3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor3", "sColor3 can't be NULL")
                End If
                m_sColor3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor4 Property

Public Property [sColor4]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor4]() As SqlString
            Get
                Return m_sColor4
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor4Tmp As SqlString = Value
                If sColor4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor4", "sColor4 can't be NULL")
                End If
                m_sColor4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor5 Property

Public Property [sColor5]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor5]() As SqlString
            Get
                Return m_sColor5
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor5Tmp As SqlString = Value
                If sColor5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor5", "sColor5 can't be NULL")
                End If
                m_sColor5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor6 Property

Public Property [sColor6]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor6]() As SqlString
            Get
                Return m_sColor6
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor6Tmp As SqlString = Value
                If sColor6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor6", "sColor6 can't be NULL")
                End If
                m_sColor6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor7 Property

Public Property [sColor7]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor7]() As SqlString
            Get
                Return m_sColor7
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor7Tmp As SqlString = Value
                If sColor7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor7", "sColor7 can't be NULL")
                End If
                m_sColor7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sColor8 Property

Public Property [sColor8]() As SqlString

Source code

[Visual Basic]
        Public Property [sColor8]() As SqlString
            Get
                Return m_sColor8
            End Get
            Set(ByVal Value As SqlString)
                Dim sColor8Tmp As SqlString = Value
                If sColor8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sColor8", "sColor8 can't be NULL")
                End If
                m_sColor8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsOffice_Vorlage_Datei.sDateiname Property

Public Property [sDateiname]() As SqlString

Source code

[Visual Basic]
        Public Property [sDateiname]() As SqlString
            Get
                Return m_sDateiname
            End Get
            Set(ByVal Value As SqlString)
                m_sDateiname = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.sDatenherkunft Property

Public Property [sDatenherkunft]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatenherkunft]() As SqlString
            Get
                Return m_sDatenherkunft
            End Get
            Set(ByVal Value As SqlString)
                m_sDatenherkunft = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.sDatum1 Property

Public Property [sDatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum1]() As SqlString
            Get
                Return m_sDatum1
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum1Tmp As SqlString = Value
                If sDatum1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum1", "sDatum1 can't be NULL")
                End If
                m_sDatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum2 Property

Public Property [sDatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum2]() As SqlString
            Get
                Return m_sDatum2
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum2Tmp As SqlString = Value
                If sDatum2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum2", "sDatum2 can't be NULL")
                End If
                m_sDatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum3 Property

Public Property [sDatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum3]() As SqlString
            Get
                Return m_sDatum3
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum3Tmp As SqlString = Value
                If sDatum3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum3", "sDatum3 can't be NULL")
                End If
                m_sDatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum4 Property

Public Property [sDatum4]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum4]() As SqlString
            Get
                Return m_sDatum4
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum4Tmp As SqlString = Value
                If sDatum4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum4", "sDatum4 can't be NULL")
                End If
                m_sDatum4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum5 Property

Public Property [sDatum5]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum5]() As SqlString
            Get
                Return m_sDatum5
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum5Tmp As SqlString = Value
                If sDatum5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum5", "sDatum5 can't be NULL")
                End If
                m_sDatum5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum6 Property

Public Property [sDatum6]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum6]() As SqlString
            Get
                Return m_sDatum6
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum6Tmp As SqlString = Value
                If sDatum6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum6", "sDatum6 can't be NULL")
                End If
                m_sDatum6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum7 Property

Public Property [sDatum7]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum7]() As SqlString
            Get
                Return m_sDatum7
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum7Tmp As SqlString = Value
                If sDatum7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum7", "sDatum7 can't be NULL")
                End If
                m_sDatum7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDatum8 Property

Public Property [sDatum8]() As SqlString

Source code

[Visual Basic]
        Public Property [sDatum8]() As SqlString
            Get
                Return m_sDatum8
            End Get
            Set(ByVal Value As SqlString)
                Dim sDatum8Tmp As SqlString = Value
                If sDatum8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDatum8", "sDatum8 can't be NULL")
                End If
                m_sDatum8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDdokart Property

Public Property [sDdokart]() As SqlString

Source code

[Visual Basic]
        Public Property [sDdokart]() As SqlString
            Get
                Return m_sDdokart
            End Get
            Set(ByVal Value As SqlString)
                Dim sDdokartTmp As SqlString = Value
                If sDdokartTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDdokart", "sDdokart can't be NULL")
                End If
                m_sDdokart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDdokstatus Property

Public Property [sDdokstatus]() As SqlString

Source code

[Visual Basic]
        Public Property [sDdokstatus]() As SqlString
            Get
                Return m_sDdokstatus
            End Get
            Set(ByVal Value As SqlString)
                Dim sDdokstatusTmp As SqlString = Value
                If sDdokstatusTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDdokstatus", "sDdokstatus can't be NULL")
                End If
                m_sDdokstatus = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDoktyp Property

Public Property [sDoktyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sDoktyp]() As SqlString
            Get
                Return m_sDoktyp
            End Get
            Set(ByVal Value As SqlString)
                m_sDoktyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sEma Property

Public Property [sEma]() As SqlString

Source code

[Visual Basic]
        Public Property [sEma]() As SqlString
            Get
                Return m_sEma
            End Get
            Set(ByVal Value As SqlString)
                Dim sEmaTmp As SqlString = Value
                If sEmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEma", "sEma can't be NULL")
                End If
                m_sEma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sEmb Property

Public Property [sEmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sEmb]() As SqlString
            Get
                Return m_sEmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sEmbTmp As SqlString = Value
                If sEmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEmb", "sEmb can't be NULL")
                End If
                m_sEmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostdatum1 Property

Public Property [sHostdatum1]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum1]() As SqlString
            Get
                Return m_sHostdatum1
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHosttag1 Property

Public Property [sHosttag1]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag1]() As SqlString
            Get
                Return m_sHosttag1
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHosttag2 Property

Public Property [sHosttag2]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag2]() As SqlString
            Get
                Return m_sHosttag2
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHosttag3 Property

Public Property [sHosttag3]() As SqlString

Source code

[Visual Basic]
        Public Property [sHosttag3]() As SqlString
            Get
                Return m_sHosttag3
            End Get
            Set(ByVal Value As SqlString)
                m_sHosttag3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMteam Property

Public Property [sMteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sMteam]() As SqlString
            Get
                Return m_sMteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sMteamTmp As SqlString = Value
                If sMteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMteam", "sMteam can't be NULL")
                End If
                m_sMteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMutaelterasl Property

Public Property [sMutaelterasl]() As SqlString

Source code

[Visual Basic]
        Public Property [sMutaelterasl]() As SqlString
            Get
                Return m_sMutaelterasl
            End Get
            Set(ByVal Value As SqlString)
                Dim sMutaelteraslTmp As SqlString = Value
                If sMutaelteraslTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMutaelterasl", "sMutaelterasl can't be NULL")
                End If
                m_sMutaelterasl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sDpartner Property

Public Property [sDpartner]() As SqlString

Source code

[Visual Basic]
        Public Property [sDpartner]() As SqlString
            Get
                Return m_sDpartner
            End Get
            Set(ByVal Value As SqlString)
                Dim sDpartnerTmp As SqlString = Value
                If sDpartnerTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sDpartner", "sDpartner can't be NULL")
                End If
                m_sDpartner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsParameterSetList.sParameterNavigationValue Property

Public Property [sParameterNavigationValue]() As SqlString

Source code

[Visual Basic]
        Public Property [sParameterNavigationValue]() As SqlString
            Get
                Return m_sParameterNavigationValue
            End Get
            Set(ByVal Value As SqlString)
                m_sParameterNavigationValue = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.sEkost Property

Public Property [sEkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sEkost]() As SqlString
            Get
                Return m_sEkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sEkostTmp As SqlString = Value
                If sEkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEkost", "sEkost can't be NULL")
                End If
                m_sEkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sEnl Property

Public Property [sEnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sEnl]() As SqlString
            Get
                Return m_sEnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sEnlTmp As SqlString = Value
                If sEnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEnl", "sEnl can't be NULL")
                End If
                m_sEnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sErstaelterals Property

Public Property [sErstaelterals]() As SqlString

Source code

[Visual Basic]
        Public Property [sErstaelterals]() As SqlString
            Get
                Return m_sErstaelterals
            End Get
            Set(ByVal Value As SqlString)
                Dim sErstaelteralsTmp As SqlString = Value
                If sErstaelteralsTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sErstaelterals", "sErstaelterals can't be NULL")
                End If
                m_sErstaelterals = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sEteam Property

Public Property [sEteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sEteam]() As SqlString
            Get
                Return m_sEteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sEteamTmp As SqlString = Value
                If sEteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sEteam", "sEteam can't be NULL")
                End If
                m_sEteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostdatum2 Property

Public Property [sHostdatum2]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum2]() As SqlString
            Get
                Return m_sHostdatum2
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostdatum3 Property

Public Property [sHostdatum3]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdatum3]() As SqlString
            Get
                Return m_sHostdatum3
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdatum3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostdokart Property

Public Property [sHostdokart]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdokart]() As SqlString
            Get
                Return m_sHostdokart
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdokart = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostdoktyp Property

Public Property [sHostdoktyp]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostdoktyp]() As SqlString
            Get
                Return m_sHostdoktyp
            End Get
            Set(ByVal Value As SqlString)
                m_sHostdoktyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sHostpartner Property

Public Property [sHostpartner]() As SqlString

Source code

[Visual Basic]
        Public Property [sHostpartner]() As SqlString
            Get
                Return m_sHostpartner
            End Get
            Set(ByVal Value As SqlString)
                m_sHostpartner = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMkost Property

Public Property [sMkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sMkost]() As SqlString
            Get
                Return m_sMkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sMkostTmp As SqlString = Value
                If sMkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMkost", "sMkost can't be NULL")
                End If
                m_sMkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMma Property

Public Property [sMma]() As SqlString

Source code

[Visual Basic]
        Public Property [sMma]() As SqlString
            Get
                Return m_sMma
            End Get
            Set(ByVal Value As SqlString)
                Dim sMmaTmp As SqlString = Value
                If sMmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMma", "sMma can't be NULL")
                End If
                m_sMma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMmb Property

Public Property [sMmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sMmb]() As SqlString
            Get
                Return m_sMmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sMmbTmp As SqlString = Value
                If sMmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMmb", "sMmb can't be NULL")
                End If
                m_sMmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sMnl Property

Public Property [sMnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sMnl]() As SqlString
            Get
                Return m_sMnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sMnlTmp As SqlString = Value
                If sMnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sMnl", "sMnl can't be NULL")
                End If
                m_sMnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsParameterSetList.sParameterDisplayValue Property

Public Property [sParameterDisplayValue]() As SqlString

Source code

[Visual Basic]
        Public Property [sParameterDisplayValue]() As SqlString
            Get
                Return m_sParameterDisplayValue
            End Get
            Set(ByVal Value As SqlString)
                m_sParameterDisplayValue = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.sSort Property

Public Property [sSort]() As SqlString

Source code

[Visual Basic]
        Public Property [sSort]() As SqlString
            Get
                Return m_sSort
            End Get
            Set(ByVal Value As SqlString)
                Dim sSortTmp As SqlString = Value
                If sSortTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sSort", "sSort can't be NULL")
                End If
                m_sSort = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sVkost Property

Public Property [sVkost]() As SqlString

Source code

[Visual Basic]
        Public Property [sVkost]() As SqlString
            Get
                Return m_sVkost
            End Get
            Set(ByVal Value As SqlString)
                Dim sVkostTmp As SqlString = Value
                If sVkostTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVkost", "sVkost can't be NULL")
                End If
                m_sVkost = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sVma Property

Public Property [sVma]() As SqlString

Source code

[Visual Basic]
        Public Property [sVma]() As SqlString
            Get
                Return m_sVma
            End Get
            Set(ByVal Value As SqlString)
                Dim sVmaTmp As SqlString = Value
                If sVmaTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVma", "sVma can't be NULL")
                End If
                m_sVma = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sVmb Property

Public Property [sVmb]() As SqlString

Source code

[Visual Basic]
        Public Property [sVmb]() As SqlString
            Get
                Return m_sVmb
            End Get
            Set(ByVal Value As SqlString)
                Dim sVmbTmp As SqlString = Value
                If sVmbTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVmb", "sVmb can't be NULL")
                End If
                m_sVmb = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sVnl Property

Public Property [sVnl]() As SqlString

Source code

[Visual Basic]
        Public Property [sVnl]() As SqlString
            Get
                Return m_sVnl
            End Get
            Set(ByVal Value As SqlString)
                Dim sVnlTmp As SqlString = Value
                If sVnlTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVnl", "sVnl can't be NULL")
                End If
                m_sVnl = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.sVteam Property

Public Property [sVteam]() As SqlString

Source code

[Visual Basic]
        Public Property [sVteam]() As SqlString
            Get
                Return m_sVteam
            End Get
            Set(ByVal Value As SqlString)
                Dim sVteamTmp As SqlString = Value
                If sVteamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("sVteam", "sVteam can't be NULL")
                End If
                m_sVteam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsOffice_Vorlage_Datei.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_Vorlage_Datei::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ParameterSetList_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParameterSetListID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetListID))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ParameterSetList_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsParameterSetList::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.Delete Method

Public Overrides Function Delete() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ProfilDokAuswertung_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ProfilDokAuswertung_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfilDokAuswertung::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportfeldregel_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportfeldregel_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportfeldregel::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.Delete Method

Overrides Public Function Delete() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Delete() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_reportgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReport_reportgruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::Delete::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ICommonDBAccess.Delete Method

Function	Delete() As Boolean

Source code

[Visual Basic]
        Function	Delete() As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsMyDokumentstatus.Dokumenttypnr Property

Property Dokumenttypnr() As Long

Source code

[Visual Basic]
        Property Dokumenttypnr() As Long
            Get
                Return m_dokumenttypnr
            End Get
            Set(ByVal Value As Long)
                m_dokumenttypnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


IOleCommandTarget.Exec Method

Sub Exec( _
   ByRef pguidCmdGroup As Guid, _
   ByVal nCmdId As Long, _
   ByVal nCmdExecOpt As Long, _
   ByRef pvaIn As Object, _
   ByRef pvaOut As Object _
)

Parameters

pguidCmdGroup
Required.
nCmdId
Required.
nCmdExecOpt
Required.
pvaIn
Required.
pvaOut
Required.

Source code

[Visual Basic]
    Sub Exec(ByRef pguidCmdGroup As Guid, ByVal nCmdId As Long, ByVal nCmdExecOpt As Long, ByRef pvaIn As Object, ByRef pvaOut As Object)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


MultiComboBox.Fill_Data (System.Data.DataTable, System.Boolean) Method

Public Sub Fill_Data( _
   ByVal da As DataTable, _
   ByVal addblankrow As Boolean _
)

Parameters

da
Required.
addblankrow
Required.

Source code

[Visual Basic]
    Public Sub Fill_Data(ByVal da As DataTable, ByVal addblankrow As Boolean)
        Dim al As New ArrayList()
        Dim xvalue As String
        Dim i As Integer
        If addblankrow Then
            al.Add(New GenericList("", "", 0, 0))
        End If
        If da.Rows.Count = 0 Then Exit Sub
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item(DisplayColumnName) Is System.DBNull.Value Then
                xvalue = ""
            Else
                xvalue = da.Rows(i).Item(DisplayColumnName)
            End If
            al.Add(New GenericList(xvalue, "", da.Rows(i).Item(ValueColumnName), i + 1))
        Next
        Me.DataSource = al
        Me.DisplayMember = "Display"
        Me.ValueMember = "ID"
        Me.Columns.Add(New MultiComboBox.Column(-1, "ID"))
        Me.Columns.Add(New MultiComboBox.Column(180, "Display"))
        Me.ShowColumns = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox.Fill_Data (System.Data.DataTable, System.Boolean, System.String) Method

Public Sub Fill_Data( _
   ByVal da As DataTable, _
   ByVal addblankrow As Boolean, _
   ByVal blankrowtext As String _
)

Parameters

da
Required.
addblankrow
Required.
blankrowtext
Required.

Source code

[Visual Basic]
    Public Sub Fill_Data(ByVal da As DataTable, ByVal addblankrow As Boolean, ByVal blankrowtext As String)
        Dim al As New ArrayList()
        Dim xvalue As String
        Dim i As Integer
        If addblankrow Then
            al.Add(New GenericList(blankrowtext, blankrowtext, 0, 0))
        End If
        If da.Rows.Count = 0 Then Exit Sub
        For i = 0 To da.Rows.Count - 1
            If da.Rows(i).Item(DisplayColumnName) Is System.DBNull.Value Then
                xvalue = ""
            Else
                xvalue = da.Rows(i).Item(DisplayColumnName)
            End If
            al.Add(New GenericList(xvalue, "", da.Rows(i).Item(ValueColumnName), i + 1))
        Next
        Me.DataSource = al
        Me.DisplayMember = "Display"
        Me.ValueMember = "ID"
        Me.Columns.Add(New MultiComboBox.Column(-1, "ID"))
        Me.Columns.Add(New MultiComboBox.Column(180, "Display"))
        Me.ShowColumns = True
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


OwnerMenu.Add (System.Windows.Forms.MenuItem, System.Drawing.Bitmap, System.Int32, System.Boolean) Method

Public Sub Add( _
   ByVal MenuItem As Windows.Forms.MenuItem, _
   ByVal Bitmap As System.Drawing.Bitmap, _
   ByVal MenuItemNumber As Integer, _
   ByVal IsSeperator As Boolean _
)

Parameters

MenuItem
Required.
Bitmap
Required.
MenuItemNumber
Required.
IsSeperator
Required.

Source code

[Visual Basic]
    Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, _
  ByVal Bitmap As System.Drawing.Bitmap, _
  ByVal MenuItemNumber As Integer, _
  ByVal IsSeperator As Boolean)
        Dim Icon As Icon
        Dim intIndexOfImageIWant As Int16 = 1
        Icon = System.Drawing.Icon.FromHandle(Bitmap.GetHicon)
        Me.Add(MenuItem, Icon, MenuItemNumber, IsSeperator, _Font, _TextColor)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.Add (System.Windows.Forms.MenuItem, System.Drawing.Icon, System.Int32, System.Boolean) Method

Public Sub Add( _
   ByVal MenuItem As Windows.Forms.MenuItem, _
   ByVal Icon As System.Drawing.Icon, _
   ByVal MenuItemNumber As Integer, _
   ByVal IsSeperator As Boolean _
)

Parameters

MenuItem
Required.
Icon
Required.
MenuItemNumber
Required.
IsSeperator
Required.

Source code

[Visual Basic]
        Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, _
          ByVal Icon As System.Drawing.Icon, _
          ByVal MenuItemNumber As Integer, _
          ByVal IsSeperator As Boolean)
            Me.Add(MenuItem, Icon, MenuItemNumber, IsSeperator, _Font, _TextColor)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.Add (System.Windows.Forms.MenuItem, System.Drawing.Icon, System.Int32, System.Boolean, System.Drawing.Font) Method

Public Sub Add( _
   ByVal MenuItem As Windows.Forms.MenuItem, _
   ByVal Icon As System.Drawing.Icon, _
   ByVal MenuItemNumber As Integer, _
   ByVal IsSeperator As Boolean, _
   ByVal Font As System.Drawing.Font _
)

Parameters

MenuItem
Required.
Icon
Required.
MenuItemNumber
Required.
IsSeperator
Required.
Font
Required.

Source code

[Visual Basic]
        Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, _
          ByVal Icon As System.Drawing.Icon, _
          ByVal MenuItemNumber As Integer, _
          ByVal IsSeperator As Boolean, _
          ByVal Font As System.Drawing.Font)
            Me.Add(MenuItem, Icon, MenuItemNumber, IsSeperator, Font, _TextColor)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu.Add (System.Windows.Forms.MenuItem, System.Drawing.Icon, System.Int32, System.Boolean, System.Drawing.Font, System.Drawing.Color) Method

Public Sub Add( _
   ByVal MenuItem As Windows.Forms.MenuItem, _
   ByVal Icon As System.Drawing.Icon, _
   ByVal MenuItemNumber As Integer, _
   ByVal IsSeperator As Boolean, _
   ByVal Font As System.Drawing.Font, _
   ByVal TextColor As System.Drawing.Color _
)

Parameters

MenuItem
Required.
Icon
Required.
MenuItemNumber
Required.
IsSeperator
Required.
Font
Required.
TextColor
Required.

Source code

[Visual Basic]
    Public Sub Add(ByVal MenuItem As Windows.Forms.MenuItem, _
      ByVal Icon As System.Drawing.Icon, _
      ByVal MenuItemNumber As Integer, _
      ByVal IsSeperator As Boolean, _
      ByVal Font As System.Drawing.Font, _
      ByVal TextColor As System.Drawing.Color)
        'hold and save the last top and left position
        Static LastTopPosition As Integer
        Static LastLeftPosition As Integer
        Dim li As New LocalMenuItem()
        If MenuItemNumber = 0 Then
            LastLeftPosition = 2
            LastTopPosition = 0
        Else
            'calculate the new top position
            LastTopPosition = LastTopPosition + IIf(IsSeperator, _
          SEPITEMHEIGHT, NORMALITEMHEIGHT)
            LastLeftPosition = 2
        End If
        Const ICONWIDTH As Integer = ICONSIZE16
        Const ICONHEIGHT As Integer = ICONSIZE16
        Dim IconRect As Rectangle
        'calculate new drawing rectangle for icon
        If IsSeperator Then
            IconRect = New Rectangle(LastLeftPosition, LastTopPosition, _
          ICONWIDTH, ICONHEIGHT)
        Else
            IconRect = New Rectangle(LastLeftPosition, LastTopPosition + 2, _
          ICONWIDTH, ICONHEIGHT)
        End If
        'you don't need to set ownerdraw - the class does it for you
        MenuItem.OwnerDraw = True
        With li
            .MenuItemNumber = MenuItemNumber
            .Font = Font
            .MenuItem = MenuItem
            .Icon = Icon
            .TextLeft = LastLeftPosition + ICONWIDTH
            .TextTopPosition = LastTopPosition
            .IconRectangle = IconRect
            .TextColor = TextColor
            .IsSeperator = IsSeperator
        End With
        _MenuItems.Add(li)
        'set the handlers for the menuitems
        AddHandler MenuItem.DrawItem, AddressOf Me.DrawItemHandler
        AddHandler MenuItem.MeasureItem, AddressOf Me.MesaureItemHandler
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            '
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu Constructor (System.Drawing.Color)

Public Sub New( _
   ByVal TextColor As System.Drawing.Color _
)

Parameters

TextColor
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal TextColor As System.Drawing.Color)
            _TextColor = TextColor
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu Constructor (System.Drawing.Font)

Public Sub New( _
   ByVal Font As System.Drawing.Font _
)

Parameters

Font
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal Font As System.Drawing.Font)
            _Font = Font
            If _Font.Size > 12 Then
                _Font = New Font(_Font.Name, 12, _Font.Style)
            End If
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


OwnerMenu Constructor (System.Drawing.Font, System.Drawing.Color)

Public Sub New( _
   ByVal Font As System.Drawing.Font, _
   ByVal TextColor As System.Drawing.Color _
)

Parameters

Font
Required.
TextColor
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal Font As System.Drawing.Font, _
          ByVal TextColor As System.Drawing.Color)
            _TextColor = TextColor
            _Font = Font
            If _Font.Size > 12 Then
                _Font = New Font(_Font.Name, 12, _Font.Style)
            End If
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OwnerMenu


IOleCommandTarget.QueryStatus Method

Sub QueryStatus( _
   ByRef pguidCmdGroup As Guid, _
   ByVal cCmds As UInt32, _
   <MarshalAs(UnmanagedType.LPArray, _
   SizeParamIndex:=1)> ByVal prgCmds As OLECMD, _
   ByRef pCmdText As OLECMDTEXT _
)

Parameters

pguidCmdGroup
Required.
cCmds
Required.
prgCmds
Required.
pCmdText
Required.

Source code

[Visual Basic]
    Sub QueryStatus(ByRef pguidCmdGroup As Guid, ByVal cCmds As UInt32, <MarshalAs(UnmanagedType.LPArray, SizeParamIndex:=1)> ByVal prgCmds As OLECMD, ByRef pCmdText As OLECMDTEXT)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsReport_reportgruppe.UpdateAllWreport_gruppenrLogic Method

Public Function UpdateAllWreport_gruppenrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWreport_gruppenrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_UpdateAllWreport_gruppenrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireport_gruppenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_UpdateAllWreport_gruppenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::UpdateAllWreport_gruppenrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.UpdateAllWreportnrLogic Method

Public Function UpdateAllWreportnrLogic() As Boolean

Source code

[Visual Basic]
        Public Function UpdateAllWreportnrLogic() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_UpdateAllWreportnrLogic]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@ireportnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnrOld))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode =  New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_UpdateAllWreportnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::UpdateAllWreportnrLogic::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsProfilDokAuswertung.bAktive Property

Public Property [bAktive]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktive]() As SqlBoolean
            Get
                Return m_bAktive
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktive = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsOffice_Vorlage_Datei.blobVorlage Property

Public Property [blobVorlage]() As SqlBinary

Source code

[Visual Basic]
        Public Property [blobVorlage]() As SqlBinary
            Get
                Return m_blobVorlage
            End Get
            Set(ByVal Value As SqlBinary)
                m_blobVorlage = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


bottom Property

Public bottom As Int32

Source code

[Visual Basic]
        Public bottom As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cbData Property

Public cbData As Integer

Source code

[Visual Basic]
            Public cbData As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsMyDokumentstatus Class

For a list of all members of this type, see clsMyDokumentstatus Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsDokumentstatus
EDOKAApp.edokaDB.clsMyDokumentstatus

Public Class clsMyDokumentstatus
   Inherits edokaDB.clsDokumentstatus

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyDokumentstatus Members


clsMyDokumentstatus Members

clsMyDokumentstatus overview

Constructors

constructor clsMyDokumentstatus Constructor (inherited from EDOKAApp.edokadb.clsDokumentstatus)

Properties

property Dokumenttypnr
property Statustyp
property Statustypnr
property bAktiv (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property bDokument_ausgangsarchivieren (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property bDokument_bearbeitung_abgeschlossen (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property bDokumentbearbeitung_moeglich (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property bFolgestatus_durch_anderen_verantwortlichen (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iDokumentstatusnr (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iDokumenttypnr (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iErledigung_ab (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iMutierer (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iReihenfolge (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iStatus_bezeichnungnr (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iStatustyp (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property iStatustypnr (inherited from EDOKAApp.edokadb.clsDokumentstatus)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsDokumentstatus)
method DeleteDokumentstatus
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsDokumentstatus)
method InsertDokumentstatus
method SelectAll (inherited from EDOKAApp.edokadb.clsDokumentstatus)
method SelectDokumentstatus
method SelectOne (inherited from EDOKAApp.edokadb.clsDokumentstatus)
method Update (inherited from EDOKAApp.edokadb.clsDokumentstatus)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_dokumenttypnr
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_statustyp
field m_statustypnr

See Also

clsMyDokumentstatus Class


clsMyMandat Class

For a list of all members of this type, see clsMyMandat Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMandant
EDOKAApp.edokaDB.clsMyMandat

Public Class clsMyMandat
   Inherits edokaDB.clsMandant

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyMandat Members


clsMyMandat Members

clsMyMandat overview

Constructors

constructor clsMyMandat Constructor (inherited from EDOKAApp.edokadb.clsMandant)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsMandant)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsMandant)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsMandant)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr (inherited from EDOKAApp.edokadb.clsMandant)
property iMandantnr1 (inherited from EDOKAApp.edokadb.clsMandant)
property iMutierer (inherited from EDOKAApp.edokadb.clsMandant)
property sBeschreibung (inherited from EDOKAApp.edokadb.clsMandant)
property sBezeichnung (inherited from EDOKAApp.edokadb.clsMandant)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete (inherited from EDOKAApp.edokadb.clsMandant)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert (inherited from EDOKAApp.edokadb.clsMandant)
method SelectAll
method SelectOne (inherited from EDOKAApp.edokadb.clsMandant)
method Update (inherited from EDOKAApp.edokadb.clsMandant)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsMyMandat Class


clsMyMitarbeiter Class

For a list of all members of this type, see clsMyMitarbeiter Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokadb.clsMitarbeiter
EDOKAApp.edokaDB.clsMyMitarbeiter

Public Class clsMyMitarbeiter
   Inherits edokaDB.clsMitarbeiter

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsMyMitarbeiter Members


clsMyMitarbeiter Members

clsMyMitarbeiter overview

Constructors

constructor clsMyMitarbeiter Constructor (inherited from EDOKAApp.edokadb.clsMitarbeiter)

Properties

property bAktiv (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bEdokaMesasge (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bEdoka_mail (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bJournalisierung (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bMailDirektVersenden (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bMailDokumentrueckgang (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bMailempfang (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property bShowtip (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property daMutiert_am (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFuermandant (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iFunktionnr (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iKlassifizierung (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iMandantnr (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iMitarbeiternr (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iMutierer (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iPartnernr (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property iSprache (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sAnrede (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sEmail (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sFax (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sFunktion (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sKurzzeichen (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sName (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sRang (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sTelefon (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sTgnummer (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sUnterschrift_text (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property sVorname (inherited from EDOKAApp.edokadb.clsMitarbeiter)
property xtgnummer

Methods

method Delete (inherited from EDOKAApp.edokadb.clsMitarbeiter)
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Get_Mitarbeiter
method Get_Username
method Insert (inherited from EDOKAApp.edokadb.clsMitarbeiter)
method SelectAll (inherited from EDOKAApp.edokadb.clsMitarbeiter)
method SelectAllMandantMitarbeiter
method SelectMitarbeiterWithNr
method SelectOne (inherited from EDOKAApp.edokadb.clsMitarbeiter)
method SelectWithTGNummer
method Select_Mandant
method Update (inherited from EDOKAApp.edokadb.clsMitarbeiter)

Fields

field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_xtgnummer
field ouser

See Also

clsMyMitarbeiter Class


clsOffice_Vorlage_Datei Class

For a list of all members of this type, see clsOffice_Vorlage_Datei Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsOffice_Vorlage_Datei

Public Class clsOffice_Vorlage_Datei
   Inherits clsDBInteractionBase

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei Members

clsOffice_Vorlage_Datei overview

Constructors

constructor clsOffice_Vorlage_Datei Constructor

Properties

property bAktiv
property bFreigegeben
property blobVorlage
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daFragabe_am
property daMutiert_am
property daUebernahme_produktion
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iFreigabe_durch
property iMutierer
property iOffice_vorlage_dateinr
property iOffice_vorlagenr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDateiname

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bFreigegeben
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_blobVorlage
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daFragabe_am
field m_daMutiert_am
field m_daUebernahme_produktion
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iFreigabe_durch
field m_iMutierer
field m_iOffice_vorlage_dateinr
field m_iOffice_vorlagenr
field m_sDateiname
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsOffice_Vorlage_Datei Class


clsOffice_Vorlage_Datei Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList Class

For a list of all members of this type, see clsParameterSetList Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsParameterSetList

Public Class clsParameterSetList
   Inherits clsDBInteractionBase

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsParameterSetList Members


clsParameterSetList Members

clsParameterSetList overview

Constructors

constructor clsParameterSetList Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iParameterSetListID
property iParameterSetNameID
property iReihenfolge
property iReportReportfeldregelNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDatenherkunft
property sParameterDisplayValue
property sParameterNavigationValue

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iParameterSetListID
field m_iParameterSetNameID
field m_iReihenfolge
field m_iReportReportfeldregelNr
field m_sDatenherkunft
field m_sParameterDisplayValue
field m_sParameterNavigationValue
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsParameterSetList Class


clsParameterSetList Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung Class

For a list of all members of this type, see clsProfilDokAuswertung Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsProfilDokAuswertung

Public Class clsProfilDokAuswertung
   Inherits clsDBInteractionBase

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsProfilDokAuswertung Members


clsProfilDokAuswertung Members

clsProfilDokAuswertung overview

Constructors

constructor clsProfilDokAuswertung Constructor

Properties

property bAktiv
property bAktive
property bInklalt
property bInklhostmavip
property bInklmavip
property bStandard
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iHw1
property iHw10
property iHw11
property iHw2
property iHw3
property iHw4
property iHw5
property iHw6
property iHw7
property iHw8
property iHw9
property iMandantnr
property iMitarbeiternr
property iMutierer
property iProfilnr
property iProfiltyp
property iTeam
property iUnterschriftlinks
property iUnterschriftrechts
property sBeschreibung
property sBezeichnung
property sColor1
property sColor2
property sColor3
property sColor4
property sColor5
property sColor6
property sColor7
property sColor8
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property sDatum1
property sDatum2
property sDatum3
property sDatum4
property sDatum5
property sDatum6
property sDatum7
property sDatum8
property sDdokart
property sDdokstatus
property sDoktyp
property sDpartner
property sEkost
property sEma
property sEmb
property sEnl
property sErstaelterals
property sEteam
property sHostdatum1
property sHostdatum2
property sHostdatum3
property sHostdokart
property sHostdoktyp
property sHostpartner
property sHosttag1
property sHosttag2
property sHosttag3
property sMkost
property sMma
property sMmb
property sMnl
property sMteam
property sMutaelterasl
property sSort
property sVkost
property sVma
property sVmb
property sVnl
property sVteam

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bAktive
field m_bInklalt
field m_bInklhostmavip
field m_bInklmavip
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_bStandard
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iHw1
field m_iHw10
field m_iHw11
field m_iHw2
field m_iHw3
field m_iHw4
field m_iHw5
field m_iHw6
field m_iHw7
field m_iHw8
field m_iHw9
field m_iMandantnr
field m_iMitarbeiternr
field m_iMutierer
field m_iProfilnr
field m_iProfiltyp
field m_iTeam
field m_iUnterschriftlinks
field m_iUnterschriftrechts
field m_sBeschreibung
field m_sBezeichnung
field m_sColor1
field m_sColor2
field m_sColor3
field m_sColor4
field m_sColor5
field m_sColor6
field m_sColor7
field m_sColor8
field m_sDatum1
field m_sDatum2
field m_sDatum3
field m_sDatum4
field m_sDatum5
field m_sDatum6
field m_sDatum7
field m_sDatum8
field m_sDdokart
field m_sDdokstatus
field m_sDoktyp
field m_sDpartner
field m_sEkost
field m_sEma
field m_sEmb
field m_sEnl
field m_sErstaelterals
field m_sEteam
field m_sHostdatum1
field m_sHostdatum2
field m_sHostdatum3
field m_sHostdokart
field m_sHostdoktyp
field m_sHostpartner
field m_sHosttag1
field m_sHosttag2
field m_sHosttag3
field m_sMkost
field m_sMma
field m_sMmb
field m_sMnl
field m_sMteam
field m_sMutaelterasl
field m_sSort
field m_sVkost
field m_sVma
field m_sVmb
field m_sVnl
field m_sVteam
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsProfilDokAuswertung Class


clsProfilDokAuswertung Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel Class

For a list of all members of this type, see clsReport_reportfeldregel Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsReport_reportfeldregel

Public Class clsReport_reportfeldregel
   Inherits clsDBInteractionBase

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReport_reportfeldregel Members


clsReport_reportfeldregel Members

clsReport_reportfeldregel overview

Constructors

constructor clsReport_reportfeldregel Constructor

Properties

property bAktiv
property bEingabe_zwingend
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReihenfolge
property iReportFeldRegelNr
property iReportNr
property iReportReportfeldregelNr
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectOne
method Update

Fields

field m_bAktiv
field m_bEingabe_zwingend
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReihenfolge
field m_iReportFeldRegelNr
field m_iReportNr
field m_iReportReportfeldregelNr
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReport_reportfeldregel Class


clsReport_reportfeldregel Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe Class

For a list of all members of this type, see clsReport_reportgruppe Members.

System.Object
EDOKAApp.edokadb.clsDBInteractionBase
EDOKAApp.edokaDB.clsReport_reportgruppe

Public Class clsReport_reportgruppe
   Inherits clsDBInteractionBase

Requirements

Namespace: edokaDB

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKA (in EDOKA.exe)

See Also

clsReport_reportgruppe Members


clsReport_reportgruppe Members

clsReport_reportgruppe overview

Constructors

constructor clsReport_reportgruppe Constructor

Properties

property bAktiv
property cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property daErstellt_am
property daMutiert_am
property iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
property iMandantnr
property iMutierer
property iReport_gruppenr
property iReport_gruppenrOld
property iReport_reportgruppenr
property iReportnr
property iReportnrOld
property sBeschreibung
property sBezeichnung
property sConnectionString (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

Methods

method Delete
method Dispose (Overloaded) (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
method Insert
method SelectAll
method SelectAllWreport_gruppenrLogic
method SelectAllWreportnrLogic
method SelectOne
method Update
method UpdateAllWreport_gruppenrLogic
method UpdateAllWreportnrLogic

Fields

field m_bAktiv
field m_bMainConnectionIsCreatedLocal (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_cpMainConnectionProvider (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_daErstellt_am
field m_daMutiert_am
field m_iErrorCode (inherited from EDOKAApp.edokadb.clsDBInteractionBase)
field m_iMandantnr
field m_iMutierer
field m_iReport_gruppenr
field m_iReport_gruppenrOld
field m_iReport_reportgruppenr
field m_iReportnr
field m_iReportnrOld
field m_sBeschreibung
field m_sBezeichnung
field m_scoMainConnection (inherited from EDOKAApp.edokadb.clsDBInteractionBase)

See Also

clsReport_reportgruppe Class


clsReport_reportgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            ' // Nothing for now.
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsProfilDokAuswertung.iHw6 Property

Public Property [iHw6]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw6]() As SqlInt32
            Get
                Return m_iHw6
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw6Tmp As SqlInt32 = Value
                If iHw6Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw6", "iHw6 can't be NULL")
                End If
                m_iHw6 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw7 Property

Public Property [iHw7]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw7]() As SqlInt32
            Get
                Return m_iHw7
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw7Tmp As SqlInt32 = Value
                If iHw7Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw7", "iHw7 can't be NULL")
                End If
                m_iHw7 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw8 Property

Public Property [iHw8]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw8]() As SqlInt32
            Get
                Return m_iHw8
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw8Tmp As SqlInt32 = Value
                If iHw8Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw8", "iHw8 can't be NULL")
                End If
                m_iHw8 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw9 Property

Public Property [iHw9]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw9]() As SqlInt32
            Get
                Return m_iHw9
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw9Tmp As SqlInt32 = Value
                If iHw9Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw9", "iHw9 can't be NULL")
                End If
                m_iHw9 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsParameterSetList.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMandantnrTmp As SqlInt32 = Value
                If iMandantnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMandantnr", "iMandantnr can't be NULL")
                End If
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.iMandantnr Property

Public Property [iMandantnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMandantnr]() As SqlInt32
            Get
                Return m_iMandantnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMandantnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsOffice_Vorlage_Datei.iOffice_vorlage_dateinr Property

Public Property [iOffice_vorlage_dateinr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlage_dateinr]() As SqlInt32
            Get
                Return m_iOffice_vorlage_dateinr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iOffice_vorlage_dateinrTmp As SqlInt32 = Value
                If iOffice_vorlage_dateinrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iOffice_vorlage_dateinr", "iOffice_vorlage_dateinr can't be NULL")
                End If
                m_iOffice_vorlage_dateinr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsOffice_Vorlage_Datei.iOffice_vorlagenr Property

Public Property [iOffice_vorlagenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iOffice_vorlagenr]() As SqlInt32
            Get
                Return m_iOffice_vorlagenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iOffice_vorlagenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.iParameterSetListID Property

Public Property [iParameterSetListID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParameterSetListID]() As SqlInt32
            Get
                Return m_iParameterSetListID
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iParameterSetListIDTmp As SqlInt32 = Value
                If iParameterSetListIDTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iParameterSetListID", "iParameterSetListID can't be NULL")
                End If
                m_iParameterSetListID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsParameterSetList.iParameterSetNameID Property

Public Property [iParameterSetNameID]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iParameterSetNameID]() As SqlInt32
            Get
                Return m_iParameterSetNameID
            End Get
            Set(ByVal Value As SqlInt32)
                m_iParameterSetNameID = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.iProfilnr Property

Public Property [iProfilnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProfilnr]() As SqlInt32
            Get
                Return m_iProfilnr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iProfilnrTmp As SqlInt32 = Value
                If iProfilnrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iProfilnr", "iProfilnr can't be NULL")
                End If
                m_iProfilnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iProfiltyp Property

Public Property [iProfiltyp]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iProfiltyp]() As SqlInt32
            Get
                Return m_iProfiltyp
            End Get
            Set(ByVal Value As SqlInt32)
                m_iProfiltyp = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsParameterSetList.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsReport_reportfeldregel.iReihenfolge Property

Public Property [iReihenfolge]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReihenfolge]() As SqlInt32
            Get
                Return m_iReihenfolge
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReihenfolge = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportfeldregel.iReportFeldRegelNr Property

Public Property [iReportFeldRegelNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportFeldRegelNr]() As SqlInt32
            Get
                Return m_iReportFeldRegelNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportFeldRegelNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportfeldregel.iReportNr Property

Public Property [iReportNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportNr]() As SqlInt32
            Get
                Return m_iReportNr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsParameterSetList.iReportReportfeldregelNr Property

Public Property [iReportReportfeldregelNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportReportfeldregelNr]() As SqlInt32
            Get
                Return m_iReportReportfeldregelNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportReportfeldregelNrTmp As SqlInt32 = Value
                If iReportReportfeldregelNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportReportfeldregelNr", "iReportReportfeldregelNr can't be NULL")
                End If
                m_iReportReportfeldregelNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsReport_reportfeldregel.iReportReportfeldregelNr Property

Public Property [iReportReportfeldregelNr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportReportfeldregelNr]() As SqlInt32
            Get
                Return m_iReportReportfeldregelNr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReportReportfeldregelNrTmp As SqlInt32 = Value
                If iReportReportfeldregelNrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReportReportfeldregelNr", "iReportReportfeldregelNr can't be NULL")
                End If
                m_iReportReportfeldregelNr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.iReport_gruppenr Property

Public Property [iReport_gruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReport_gruppenr]() As SqlInt32
            Get
                Return m_iReport_gruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReport_gruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.iReport_gruppenrOld Property

Public Property [iReport_gruppenrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReport_gruppenrOld]() As SqlInt32
            Get
                Return m_iReport_gruppenrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReport_gruppenrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.iReport_reportgruppenr Property

Public Property [iReport_reportgruppenr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReport_reportgruppenr]() As SqlInt32
            Get
                Return m_iReport_reportgruppenr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iReport_reportgruppenrTmp As SqlInt32 = Value
                If iReport_reportgruppenrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iReport_reportgruppenr", "iReport_reportgruppenr can't be NULL")
                End If
                m_iReport_reportgruppenr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.iReportnr Property

Public Property [iReportnr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportnr]() As SqlInt32
            Get
                Return m_iReportnr
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportnr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsReport_reportgruppe.iReportnrOld Property

Public Property [iReportnrOld]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iReportnrOld]() As SqlInt32
            Get
                Return m_iReportnrOld
            End Get
            Set(ByVal Value As SqlInt32)
                m_iReportnrOld = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


left Property

Public left As Int32

Source code

[Visual Basic]
        Public left As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


m_bAktiv Variable

Private 		m_bAktiv, _
   m_bFreigegeben As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bFreigegeben As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_bAktiv Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_bAktiv Variable

Private 		m_bEingabe_zwingend, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bEingabe_zwingend, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_bAktiv Variable

Private 		m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ApplicationFileWatcher Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_blobVorlage Variable

Private 		m_blobVorlage As SqlBinary

Source code

[Visual Basic]
        Private 		m_blobVorlage As SqlBinary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_daErstellt_am Variable

Private m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_daErstellt_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ApplicationFileWatcher Constructor (System.Int32, System.String)

Public Sub New( _
   ByVal typ As Integer, _
   ByVal DocFileName As String _
)

Parameters

typ
Required.
DocFileName
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal typ As Integer, ByVal DocFileName As String)
        MyBase.new()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ApplicationFileWatcher


m_daUebernahme_produktion Variable

Private 		m_daFragabe_am, _
   m_daUebernahme_produktion, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_dokumenttypnr Variable

Dim m_dokumenttypnr As Long

Source code

[Visual Basic]
        Dim m_dokumenttypnr As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


m_iHw1 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw10 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw11 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw2 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw3 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw4 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw5 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw6 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw7 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw8 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iHw9 Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iMandantnr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iMandantnr Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iMandantnr Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iMandantnr Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iOffice_vorlage_dateinr Variable

Private 		m_iFreigabe_durch, _
   m_iOffice_vorlage_dateinr, _
   m_iOffice_vorlagenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_iOffice_vorlagenr Variable

Private 		m_iFreigabe_durch, _
   m_iOffice_vorlage_dateinr, _
   m_iOffice_vorlagenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_iParameterSetListID Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iParameterSetNameID Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iProfilnr Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iProfiltyp Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iReihenfolge Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iReihenfolge Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iReportFeldRegelNr Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iReportNr Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iReportReportfeldregelNr Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iReportReportfeldregelNr Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iReport_gruppenr Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iReport_gruppenrOld Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iReport_reportgruppenr Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_sDatenherkunft Variable

Private 		m_sDatenherkunft, _
   m_sParameterNavigationValue, _
   m_sParameterDisplayValue As SqlString

Source code

[Visual Basic]
        Private 		m_sDatenherkunft, m_sParameterNavigationValue, m_sParameterDisplayValue As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_sDatum1 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum2 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum3 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum4 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum5 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum6 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum7 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDatum8 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDdokart Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDdokstatus Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDoktyp Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDpartner Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sEkost Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sEma Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sEmb Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sEnl Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sErstaelterals Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sEteam Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHostdatum1 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHostdatum2 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHostdatum3 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sHostdokart Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


szFaceName Property

<MarshalAs(UnmanagedType.ByValArray, SizeConst:=32)> _
Public szFaceName() As Char

Source code

[Visual Basic]
        <MarshalAs(UnmanagedType.ByValArray, SizeConst:=32)> _
        Public szFaceName() As Char

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


versionString Property

<MarshalAs(UnmanagedType.ByValTStr, SizeConst:=128)> _
Public versionString As String

Source code

[Visual Basic]
        <MarshalAs(UnmanagedType.ByValTStr, SizeConst:=128)> _
        Public versionString As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsDBInteractionBase.Dispose Method

Overloads Public Sub Dispose() Implements IDisposable.Dispose

Source code

[Visual Basic]
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


clsConnectionProvider.Dispose (System.Boolean) Method

Overridable Overloads Protected Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)

Parameters

bIsDisposing
Required.

Source code

[Visual Basic]
        Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If Not (m_stCurrentTransaction Is Nothing) Then
                        m_stCurrentTransaction.Dispose()
                        m_stCurrentTransaction = Nothing
                    End If
                    If Not (m_scoDBConnection Is Nothing) Then
                        ' // closing the connection will abort (rollback) any pending transactions
                        m_scoDBConnection.Close()
                        m_scoDBConnection.Dispose()
                        m_scoDBConnection = Nothing
                    End If
                End If
            End If
            m_bIsDisposed = True
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


clsDBInteractionBase.Dispose (System.Boolean) Method

Overridable  Overloads Protected Sub Dispose( _
   ByVal bIsDisposing As Boolean _
)

Parameters

bIsDisposing
Required.

Source code

[Visual Basic]
        Overridable  Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
            ' // Check to see if Dispose has already been called.
            If Not m_bIsDisposed Then
                If bIsDisposing Then
                    ' // Dispose managed resources.
                    If m_bMainConnectionIsCreatedLocal Then
                        ' // Object is created in this class, so destroy it here.
                        m_scoMainConnection.Close()
                        m_scoMainConnection.Dispose()
                        m_bMainConnectionIsCreatedLocal = True
                    End If
                    m_cpMainConnectionProvider = Nothing
                    m_scoMainConnection = Nothing
                End If
            End If
            m_bIsDisposed = True
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsDBInteractionBase


WebOCHostCtrl.Navigate (System.String) Method

Public Overloads Sub Navigate( _
   ByVal url As String _
)

Parameters

url
Required.

Source code

[Visual Basic]
    Public Overloads Sub Navigate(ByVal url As String)
        Dim o As New Object()

        webBrowser.Navigate(url, o, o, o, o)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


WebOCHostCtrl.Navigate (System.String, System.Object) Method

Public Overloads Sub Navigate( _
   ByVal url As String, _
   ByVal o As Object _
)

Parameters

url
Required.
o
Required.

Source code

[Visual Basic]
    Public Overloads Sub Navigate(ByVal url As String, ByVal o As Object)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

WebOCHostCtrl


SingleInstance.NotifyPreviousWindow Method

Public Shared Function NotifyPreviousWindow() As Boolean

Source code

[Visual Basic]
        Public Shared Function NotifyPreviousWindow() As Boolean
            Return SendMessageToWindow(vbNullString)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.NotifyPreviousWindow (System.Object) Method

Public Shared Function NotifyPreviousWindow( _
   ByVal oCmd As Object _
) As Boolean

Parameters

oCmd
Required.

Source code

[Visual Basic]
        Public Shared Function NotifyPreviousWindow(ByVal oCmd As Object) As Boolean
            Return SendMessageToWindow(oCmd)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


SingleInstance.NotifyPreviousWindow (System.String) Method

Public Shared Function NotifyPreviousWindow( _
   ByVal strText As String _
) As Boolean

Parameters

strText
Required.

Source code

[Visual Basic]
        Public Shared Function NotifyPreviousWindow(ByVal strText As String) As Boolean
            Return SendMessageToWindow(strText)
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

SingleInstance


TextColor Property

Dim TextColor As System.Drawing.Color

Source code

[Visual Basic]
            Dim TextColor As System.Drawing.Color

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


TextLeft Property

Dim TextLeft As Integer

Source code

[Visual Basic]
            Dim TextLeft As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


TextTopPosition Property

Dim TextTopPosition As Integer

Source code

[Visual Basic]
            Dim TextTopPosition As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsReport_reportfeldregel.bEingabe_zwingend Property

Public Property [bEingabe_zwingend]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bEingabe_zwingend]() As SqlBoolean
            Get
                Return m_bEingabe_zwingend
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bEingabe_zwingend = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsOffice_Vorlage_Datei.bFreigegeben Property

Public Property [bFreigegeben]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bFreigegeben]() As SqlBoolean
            Get
                Return m_bFreigegeben
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bFreigegeben = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsProfilDokAuswertung.bInklalt Property

Public Property [bInklalt]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklalt]() As SqlBoolean
            Get
                Return m_bInklalt
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklalt = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.bInklhostmavip Property

Public Property [bInklhostmavip]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklhostmavip]() As SqlBoolean
            Get
                Return m_bInklhostmavip
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklhostmavip = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.bInklmavip Property

Public Property [bInklmavip]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bInklmavip]() As SqlBoolean
            Get
                Return m_bInklmavip
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bInklmavip = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.bStandard Property

Public Property [bStandard]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bStandard]() As SqlBoolean
            Get
                Return m_bStandard
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bStandardTmp As SqlBoolean = Value
                If bStandardTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bStandard", "bStandard can't be NULL")
                End If
                m_bStandard = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


cmdtextf Property

Public cmdtextf As UInt32

Source code

[Visual Basic]
    Public cmdtextf As UInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsOffice_Vorlage_Datei.iFreigabe_durch Property

Public Property [iFreigabe_durch]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iFreigabe_durch]() As SqlInt32
            Get
                Return m_iFreigabe_durch
            End Get
            Set(ByVal Value As SqlInt32)
                m_iFreigabe_durch = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsProfilDokAuswertung.iHw3 Property

Public Property [iHw3]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw3]() As SqlInt32
            Get
                Return m_iHw3
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw3Tmp As SqlInt32 = Value
                If iHw3Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw3", "iHw3 can't be NULL")
                End If
                m_iHw3 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw4 Property

Public Property [iHw4]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw4]() As SqlInt32
            Get
                Return m_iHw4
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw4Tmp As SqlInt32 = Value
                If iHw4Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw4", "iHw4 can't be NULL")
                End If
                m_iHw4 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw5 Property

Public Property [iHw5]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw5]() As SqlInt32
            Get
                Return m_iHw5
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw5Tmp As SqlInt32 = Value
                If iHw5Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw5", "iHw5 can't be NULL")
                End If
                m_iHw5 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iMitarbeiternr Property

Public Property [iMitarbeiternr]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMitarbeiternr]() As SqlInt32
            Get
                Return m_iMitarbeiternr
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMitarbeiternrTmp As SqlInt32 = Value
                If iMitarbeiternrTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
                End If
                m_iMitarbeiternr = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iUnterschriftrechts Property

Public Property [iUnterschriftrechts]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftrechts]() As SqlInt32
            Get
                Return m_iUnterschriftrechts
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iUnterschriftrechtsTmp As SqlInt32 = Value
                If iUnterschriftrechtsTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iUnterschriftrechts", "iUnterschriftrechts can't be NULL")
                End If
                m_iUnterschriftrechts = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_bAktive Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_bInklhostmavip Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_bInklmavip Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_bStandard Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iFreigabe_durch Variable

Private 		m_iFreigabe_durch, _
   m_iOffice_vorlage_dateinr, _
   m_iOffice_vorlagenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_iMitarbeiternr Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iMutierer Variable

Private 		m_iMutierer, _
   m_iReportNr, _
   m_iReportReportfeldregelNr, _
   m_iReportFeldRegelNr, _
   m_iMandantnr, _
   m_iReihenfolge As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMutierer, m_iReportNr, m_iReportReportfeldregelNr, m_iReportFeldRegelNr, m_iMandantnr, m_iReihenfolge As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_iMutierer Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iTeam Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sBezeichnung Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sBezeichnung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_sColor4 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor5 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor6 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sDateiname Variable

Private 		m_sDateiname As SqlString

Source code

[Visual Basic]
        Private 		m_sDateiname As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsMyMitarbeiter.xtgnummer Property

Property xtgnummer() As String

Source code

[Visual Basic]
        Property xtgnummer() As String
            Get
                Return m_xtgnummer
            End Get
            Set(ByVal Value As String)
                m_xtgnummer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyMitarbeiter


Column Constructor

Public Sub New()

Source code

[Visual Basic]
        Public Sub New()
            MyBase.new()
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


Column Constructor (System.Int32, System.String)

Public Sub New( _
   ByVal width As Integer, _
   ByVal columnmember As String _
)

Parameters

width
Required.
columnmember
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal width As Integer, ByVal columnmember As String)
            Me.New(Width, columnmember, String.Empty)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


Column Constructor (System.Int32, System.String, System.String)

Public Sub New( _
   ByVal width As Integer, _
   ByVal columnmember As String, _
   ByVal header As String _
)

Parameters

width
Required.
columnmember
Required.
header
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal width As Integer, ByVal columnmember As String, ByVal header As String)
            MyBase.new()
            Me.Width = Width
            Me.ColumnMember = columnmember
            Me.Header = header
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Column


clsMyDokumentstatus.DeleteDokumentstatus Method

Public Function DeleteDokumentstatus()

Source code

[Visual Basic]
        Public Function DeleteDokumentstatus()
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[sp_dokumentstatus_Delete]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure
            Dim dtToReturn As DataTable = New DataTable("dokumentstatus")
            Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumenttypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@statustypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Statustypnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'sp_dokumentstatus_select' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsMandant::sp_dokumentstatus_delete::Error occured." + ex.Message, ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
                sdaAdapter.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsMyDokumentstatus


clsConnectionProvider.Dispose Method

Overloads Public Sub Dispose() Implements IDisposable.Dispose

Source code

[Visual Basic]
        Overloads Public Sub Dispose() Implements IDisposable.Dispose
            Dispose(True)
            GC.SuppressFinalize(Me)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsConnectionProvider


EDOKAMain.EDOKAMain_Load Method

Private Overloads Sub EDOKAMain_Load()

Source code

[Visual Basic]
    Private Overloads Sub EDOKAMain_Load()

        If Not Edoka_Gestartet Then
            Dim baseSplash As SplashScreen
            'Splash Screen
            Me.WindowState = FormWindowState.Maximized
            Me.Refresh()
            baseSplash = New Splash()
            SplashScreenController.Show(baseSplash, 3)
            System.Threading.Thread.CurrentThread.Sleep(0)
            init_system()
            If Globals.show_releasenotes Then
                Dim f As New frmWordViewer()
                f.addressBar.Text = Application.StartupPath + "\relnotes.doc"
                f.Text = "Release-Informationen"
                f.Show()
            End If
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


EDOKAMain.EDOKAMain_Load (System.Object, System.EventArgs) Method

Private Overloads Sub EDOKAMain_Load( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
) Handles MyBase.Load

Parameters

sender
Required.
e
Required.

Source code

[Visual Basic]
    Private Overloads Sub EDOKAMain_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

EDOKAMain


MenuItem Property

Dim MenuItem As Windows.Forms.MenuItem

Source code

[Visual Basic]
            Dim MenuItem As Windows.Forms.MenuItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


MenuItemNumber Property

Dim MenuItemNumber As Integer

Source code

[Visual Basic]
            Dim MenuItemNumber As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


MultiComboBox Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        Me.DrawMode = DrawMode.OwnerDrawFixed
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


MultiComboBox Constructor (System.Windows.Forms.ComboBox)

Public Sub New( _
   ByRef cbo As ComboBox _
)

Parameters

cbo
Required.

Source code

[Visual Basic]
    Public Sub New(ByRef cbo As ComboBox)
        Me.Anchor = cbo.Anchor
        Me.BackColor = cbo.BackColor
        Me.BackgroundImage = cbo.BackgroundImage
        Me.CausesValidation = cbo.CausesValidation
        Me.ContextMenu = cbo.ContextMenu
        Me.DataSource = cbo.DataSource
        Me.DisplayMember = cbo.DisplayMember
        Me.Dock = cbo.Dock
        Me.DropDownStyle = cbo.DropDownStyle
        Me.DropDownWidth = cbo.DropDownWidth
        Me.Enabled = cbo.Enabled
        Me.Font = cbo.Font
        Me.ForeColor = cbo.ForeColor
        Me.IntegralHeight = cbo.IntegralHeight
        If cbo.Items.Count > 0 Then
            Dim tmp(cbo.Items.Count) As Object
            cbo.Items.CopyTo(tmp, 0)
            Me.Items.AddRange(tmp)
        End If
        Me.MaxDropDownItems = cbo.MaxDropDownItems
        Me.MaxLength = cbo.MaxLength
        Me.Sorted = cbo.Sorted
        Me.Text = cbo.Text
        Me.TabStop = cbo.TabStop
        Me.ValueMember = cbo.ValueMember
        Me.Visible = cbo.Visible
        Me.Location = cbo.Location
        Me.Size = cbo.Size
        Me.TabIndex = cbo.TabIndex
        Dim parent As Object = cbo.Parent
        parent.Controls.Remove(cbo)
        parent.Controls.Add(Me)
        Me.CheckNullValue = True
        Me.NullValueMessage = "NullValueMessage"
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MultiComboBox


OSVersionInfoSize Property

Public OSVersionInfoSize As Integer

Source code

[Visual Basic]
        Public OSVersionInfoSize As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


ColumnCollection.Remove (System.Int32) Method

Public Sub Remove( _
   ByVal Index As Integer _
)

Parameters

Index
Required.

Source code

[Visual Basic]
        Public Sub Remove(ByVal Index As Integer)
            _Col.Remove(Index)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


ColumnCollection.Remove (System.String) Method

Public Sub Remove( _
   ByVal Key As String _
)

Parameters

Key
Required.

Source code

[Visual Basic]
        Public Sub Remove(ByVal Key As String)
            _Col.Remove(Key)
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ColumnCollection


clsOffice_Vorlage_Datei.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
                Dim	iLength As Integer = 0
                If Not m_blobVorlage.IsNull Then
                    iLength = m_blobVorlage.Length
                End If
                scmCmdToExecute.Parameters.Add(New SqlParameter("@blobvorlage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobVorlage))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bfreigegeben", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFreigegeben))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dafragabe_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daFragabe_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ifreigabe_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabe_durch))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@dauebernahme_produktion", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUebernahme_produktion))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdateiname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDateiname))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsOffice_Vorlage_Datei::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ParameterSetList_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParameterSetListID", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetListID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iParameterSetNameID", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iParameterSetNameID))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterDisplayValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterDisplayValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatenherkunft", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDatenherkunft))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sParameterNavigationValue", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sParameterNavigationValue))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ParameterSetList_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsParameterSetList::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.Update Method

Public Overrides Function Update() As Boolean

Source code

[Visual Basic]
        Public Overrides Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand = New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_ProfilDokAuswertung_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofilnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iProfilnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@bstandard", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bStandard))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, False, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@scolor8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sColor8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw1", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw2", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw3", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw4", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw5", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw6", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw7", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw8", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw9", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw9))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw10", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw10))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ihw11", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iHw11))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@svma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sVma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smmb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smnl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smkost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smma", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@semb", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEmb))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@senl", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEnl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sekost", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEkost))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@seteam", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEteam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sema", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sEma))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokart", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sddokstatus", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDdokstatus))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum1", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum2", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum3", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum4", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum4))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum5", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum5))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum6", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum6))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum7", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum7))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdatum8", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDatum8))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@serstaelterals", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sErstaelterals))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@smutaelterasl", SqlDbType.VarChar, 50, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sMutaelterasl))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iteam", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTeam))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ssort", SqlDbType.VarChar, 1024, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sSort))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktive", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktive))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iprofiltyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProfiltyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklalt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklalt))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostpartner", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostpartner))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokart))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdoktyp", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdoktyp))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum1", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum1))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum2", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum2))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shosttag3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHosttag3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdatum3", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdatum3))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@binklhostmavip", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bInklhostmavip))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_ProfilDokAuswertung_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsProfilDokAuswertung::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportfeldregel_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportReportfeldregelNr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReportReportfeldregelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReportFeldRegelNr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportFeldRegelNr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@iReihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@beingabe_zwingend", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingabe_zwingend))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportfeldregel_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportfeldregel::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.Update Method

Overrides Public Function Update() As Boolean

Source code

[Visual Basic]
        Overrides Public Function Update() As Boolean
            Dim scmCmdToExecute As SqlCommand	= New SqlCommand()
            scmCmdToExecute.CommandText = "dbo.[pr_report_reportgruppe_Update]"
            scmCmdToExecute.CommandType = CommandType.StoredProcedure

            ' // Use base class' connection object
            scmCmdToExecute.Connection = m_scoMainConnection

            Try
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_reportgruppenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReport_reportgruppenr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireportnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReportnr))
                scmCmdToExecute.Parameters.Add(New SqlParameter("@ireport_gruppenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iReport_gruppenr))
                scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

                If m_bMainConnectionIsCreatedLocal Then
                    ' // Open connection.
                    m_scoMainConnection.Open()
                Else
                    If m_cpMainConnectionProvider.bIsTransactionPending Then
                        scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
                    End If
                End If

                ' // Execute query.
                scmCmdToExecute.ExecuteNonQuery()
                m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, Integer))

                If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
                    ' // Throw error.
                    Throw New Exception("Stored Procedure 'pr_report_reportgruppe_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
                End If

                Return True
            Catch ex As Exception
                ' // some error occured. Bubble it to caller and encapsulate Exception object
                Throw New Exception("clsReport_reportgruppe::Update::Error occured.", ex)
            Finally
                If m_bMainConnectionIsCreatedLocal Then
                    ' // Close connection.
                    m_scoMainConnection.Close()
                End If
                scmCmdToExecute.Dispose()
            End Try
        End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


ICommonDBAccess.Update Method

Function	Update() As Boolean

Source code

[Visual Basic]
        Function	Update() As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


Width Property

Dim Width As Integer

Source code

[Visual Basic]
            Dim Width As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


WndProc Event

Event WndProc As _WndProc

Parameters

m
Required.
Cancel
Required.

Source code

[Visual Basic]
            Event WndProc As _WndProc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsOffice_Vorlage_Datei.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                Dim bAktivTmp As SqlBoolean = Value
                If bAktivTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("bAktiv", "bAktiv can't be NULL")
                End If
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.bAktiv Property

Public Property [bAktiv]() As SqlBoolean

Source code

[Visual Basic]
        Public Property [bAktiv]() As SqlBoolean
            Get
                Return m_bAktiv
            End Get
            Set(ByVal Value As SqlBoolean)
                m_bAktiv = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


bCharSet Property

Public bCharSet As Byte

Source code

[Visual Basic]
        Public bCharSet As Byte

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


bInheritHandle Property

Public bInheritHandle As Integer

Source code

[Visual Basic]
        Public bInheritHandle As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


bPitchAndFamily Property

Public bPitchAndFamily As Byte

Source code

[Visual Basic]
        Public bPitchAndFamily As Byte

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


buildNumber Property

Public buildNumber As Integer

Source code

[Visual Basic]
        Public buildNumber As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cbSize Property

Public cbSize As Integer

Source code

[Visual Basic]
        Public cbSize As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


chrg Property

Public chrg As STRUCT_CHARRANGE

Source code

[Visual Basic]
        Public chrg As STRUCT_CHARRANGE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cmdID Property

Public cmdID As Long

Source code

[Visual Basic]
    Public cmdID As Long

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


cmdf Property

Public cmdf As UInt64

Source code

[Visual Basic]
    Public cmdf As UInt64

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


clsProfilDokAuswertung.iHw1 Property

Public Property [iHw1]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw1]() As SqlInt32
            Get
                Return m_iHw1
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw1Tmp As SqlInt32 = Value
                If iHw1Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw1", "iHw1 can't be NULL")
                End If
                m_iHw1 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw10 Property

Public Property [iHw10]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw10]() As SqlInt32
            Get
                Return m_iHw10
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw10Tmp As SqlInt32 = Value
                If iHw10Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw10", "iHw10 can't be NULL")
                End If
                m_iHw10 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw11 Property

Public Property [iHw11]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw11]() As SqlInt32
            Get
                Return m_iHw11
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw11Tmp As SqlInt32 = Value
                If iHw11Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw11", "iHw11 can't be NULL")
                End If
                m_iHw11 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iHw2 Property

Public Property [iHw2]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iHw2]() As SqlInt32
            Get
                Return m_iHw2
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iHw2Tmp As SqlInt32 = Value
                If iHw2Tmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iHw2", "iHw2 can't be NULL")
                End If
                m_iHw2 = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsOffice_Vorlage_Datei.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


clsParameterSetList.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


clsProfilDokAuswertung.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iMutiererTmp As SqlInt32 = Value
                If iMutiererTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iMutierer", "iMutierer can't be NULL")
                End If
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsReport_reportfeldregel.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


clsReport_reportgruppe.iMutierer Property

Public Property [iMutierer]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iMutierer]() As SqlInt32
            Get
                Return m_iMutierer
            End Get
            Set(ByVal Value As SqlInt32)
                m_iMutierer = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


clsProfilDokAuswertung.iTeam Property

Public Property [iTeam]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iTeam]() As SqlInt32
            Get
                Return m_iTeam
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iTeamTmp As SqlInt32 = Value
                If iTeamTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iTeam", "iTeam can't be NULL")
                End If
                m_iTeam = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


clsProfilDokAuswertung.iUnterschriftlinks Property

Public Property [iUnterschriftlinks]() As SqlInt32

Source code

[Visual Basic]
        Public Property [iUnterschriftlinks]() As SqlInt32
            Get
                Return m_iUnterschriftlinks
            End Get
            Set(ByVal Value As SqlInt32)
                Dim iUnterschriftlinksTmp As SqlInt32 = Value
                If iUnterschriftlinksTmp.IsNull Then
                    Throw New ArgumentOutOfRangeException("iUnterschriftlinks", "iUnterschriftlinks can't be NULL")
                End If
                m_iUnterschriftlinks = Value
            End Set
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


lowpart Property

Dim lowpart As Integer

Source code

[Visual Basic]
        Dim lowpart As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


lpData Property

Public lpData As Integer

Source code

[Visual Basic]
            Public lpData As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


lpSecurityDescriptor Property

Public lpSecurityDescriptor As Integer

Source code

[Visual Basic]
        Public lpSecurityDescriptor As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


m_bEingabe_zwingend Variable

Private 		m_bEingabe_zwingend, _
   m_bAktiv As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bEingabe_zwingend, m_bAktiv As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_bFreigegeben Variable

Private 		m_bAktiv, _
   m_bFreigegeben As SqlBoolean

Source code

[Visual Basic]
        Private 		m_bAktiv, m_bFreigegeben As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_bInklalt Variable

Private m_bInklmavip, _
   m_bStandard, _
   m_bInklalt, _
   m_bAktiv, _
   m_bAktive, _
   m_bInklhostmavip As SqlBoolean

Source code

[Visual Basic]
        Private m_bInklmavip, m_bStandard, m_bInklalt, m_bAktiv, m_bAktive, m_bInklhostmavip As SqlBoolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_daFragabe_am Variable

Private 		m_daFragabe_am, _
   m_daUebernahme_produktion, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_daMutiert_am Variable

Private 		m_daFragabe_am, _
   m_daUebernahme_produktion, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_daMutiert_am Variable

Private m_daMutiert_am, _
   m_daErstellt_am As SqlDateTime

Source code

[Visual Basic]
        Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportfeldregel


m_daMutiert_am Variable

Private 		m_daErstellt_am, _
   m_daMutiert_am As SqlDateTime

Source code

[Visual Basic]
        Private 		m_daErstellt_am, m_daMutiert_am As SqlDateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iMutierer Variable

Private 		m_iFreigabe_durch, _
   m_iOffice_vorlage_dateinr, _
   m_iOffice_vorlagenr, _
   m_iMutierer As SqlInt32

Source code

[Visual Basic]
        Private 		m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsOffice_Vorlage_Datei


m_iMutierer Variable

Private 		m_iMandantnr, _
   m_iMutierer, _
   m_iReihenfolge, _
   m_iParameterSetNameID, _
   m_iParameterSetListID, _
   m_iReportReportfeldregelNr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iMandantnr, m_iMutierer, m_iReihenfolge, m_iParameterSetNameID, m_iParameterSetListID, m_iReportReportfeldregelNr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsParameterSetList


m_iMutierer Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iReportnr Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iReportnrOld Variable

Private 		m_iReportnr, _
   m_iReportnrOld, _
   m_iMutierer, _
   m_iReport_gruppenr, _
   m_iReport_gruppenrOld, _
   m_iMandantnr, _
   m_iReport_reportgruppenr As SqlInt32

Source code

[Visual Basic]
        Private 		m_iReportnr, m_iReportnrOld, m_iMutierer, m_iReport_gruppenr, m_iReport_gruppenrOld, m_iMandantnr, m_iReport_reportgruppenr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_iUnterschriftlinks Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_iUnterschriftrechts Variable

Private m_iHw5, _
   m_iHw6, _
   m_iHw7, _
   m_iHw2, _
   m_iHw3, _
   m_iHw4, _
   m_iHw11, _
   m_iTeam, _
   m_iProfiltyp, _
   m_iHw8, _
   m_iHw9, _
   m_iHw10, _
   m_iHw1, _
   m_iMitarbeiternr, _
   m_iMutierer, _
   m_iMandantnr, _
   m_iUnterschriftlinks, _
   m_iUnterschriftrechts, _
   m_iProfilnr As SqlInt32

Source code

[Visual Basic]
        Private m_iHw5, m_iHw6, m_iHw7, m_iHw2, m_iHw3, m_iHw4, m_iHw11, m_iTeam, m_iProfiltyp, m_iHw8, m_iHw9, m_iHw10, m_iHw1, m_iMitarbeiternr, m_iMutierer, m_iMandantnr, m_iUnterschriftlinks, m_iUnterschriftrechts, m_iProfilnr As SqlInt32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sBeschreibung Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sBeschreibung Variable

Private 		m_sBeschreibung, _
   m_sBezeichnung As SqlString

Source code

[Visual Basic]
        Private 		m_sBeschreibung, m_sBezeichnung As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsReport_reportgruppe


m_sColor1 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor2 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor3 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor7 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


m_sColor8 Variable

Private m_sDatum8, _
   m_sMutaelterasl, _
   m_sErstaelterals, _
   m_sDatum3, _
   m_sDatum2, _
   m_sDatum1, _
   m_sDatum4, _
   m_sDatum7, _
   m_sDatum6, _
   m_sDatum5, _
   m_sHosttag1, _
   m_sHostdatum1, _
   m_sHostdoktyp, _
   m_sHostpartner, _
   m_sHostdokart, _
   m_sHosttag2, _
   m_sHostdatum3, _
   m_sSort, _
   m_sDoktyp, _
   m_sHostdatum2, _
   m_sHosttag3, _
   m_sDdokstatus, _
   m_sColor8, _
   m_sColor7, _
   m_sColor6, _
   m_sVkost, _
   m_sVnl, _
   m_sVmb, _
   m_sColor5, _
   m_sColor1, _
   m_sBeschreibung, _
   m_sBezeichnung, _
   m_sColor4, _
   m_sColor3, _
   m_sColor2, _
   m_sVteam, _
   m_sEteam, _
   m_sEkost, _
   m_sEnl, _
   m_sDdokart, _
   m_sDpartner, _
   m_sEma, _
   m_sEmb, _
   m_sMnl, _
   m_sMmb, _
   m_sVma, _
   m_sMma, _
   m_sMteam, _
   m_sMkost As SqlString

Source code

[Visual Basic]
        Private m_sDatum8, m_sMutaelterasl, m_sErstaelterals, m_sDatum3, m_sDatum2, m_sDatum1, m_sDatum4, m_sDatum7, m_sDatum6, m_sDatum5, m_sHosttag1, m_sHostdatum1, m_sHostdoktyp, m_sHostpartner, m_sHostdokart, m_sHosttag2, m_sHostdatum3, m_sSort, m_sDoktyp, m_sHostdatum2, m_sHosttag3, m_sDdokstatus, m_sColor8, m_sColor7, m_sColor6, m_sVkost, m_sVnl, m_sVmb, m_sColor5, m_sColor1, m_sBeschreibung, m_sBezeichnung, m_sColor4, m_sColor3, m_sColor2, m_sVteam, m_sEteam, m_sEkost, m_sEnl, m_sDdokart, m_sDpartner, m_sEma, m_sEmb, m_sMnl, m_sMmb, m_sVma, m_sMma, m_sMteam, m_sMkost As SqlString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

clsProfilDokAuswertung


frmReporting.show_report (System.Int64) Method

Public Sub show_report( _
   ByVal ReportNr As Long _
)

Parameters

ReportNr
Required.

Source code

[Visual Basic]
    Public Sub show_report(ByVal ReportNr As Long)
        'Dim dt As New DataTable()
        Try

            'dt = Generic_Select(1, ReportNr)
            'Me.Text = Globals.MyTxt.gettext(21000)
            'rpt.Load("c:\edoka\edoka\reporting\Reports\dokumenttyp.rpt")

            'rpt.Load(CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_reportdateien"), String) & "\dokumenttyp.rpt")
            rpt.Load(CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String) & "\dokumenttyp.rpt")
            report_login(rpt)

            'Get the collection of parameters from the report
            crParameterFieldDefinitions = rpt.DataDefinition.ParameterFields

            'Access the specified parameter from the collection
            For i = 0 To 0
                crParameterFieldDefinition = crParameterFieldDefinitions.Item(0)
                crParameterValues = crParameterFieldDefinition.CurrentValues
                crParameterDiscreteValue = New ParameterDiscreteValue()
                crParameterDiscreteValue.Value = ReportNr
                crParameterValues.Add(crParameterDiscreteValue)
                crParameterFieldDefinition.ApplyCurrentValues(crParameterValues)
            Next
            Me.crviewer.ReportSource = rpt
            Me.crviewer.Zoom(2)
        Catch Exp As LoadSaveReportException
            MsgBox("Incorrect path for loading report.", _
                    MsgBoxStyle.Critical, "Load Report Error")
        Catch Exp As Exception
            MsgBox(Exp.Message, MsgBoxStyle.Critical, "General Error")
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


frmReporting.show_report (System.String, Microsoft.VisualBasic.Collection) Method

Public Function show_report( _
   ByVal ReportName As String, _
   ByVal ParameterCollection As Collection _
) As Boolean

Parameters

ReportName
Required.
ParameterCollection
Required.

Source code

[Visual Basic]
    Public Function show_report(ByVal ReportName As String, ByVal ParameterCollection As Collection) As Boolean

        '===============================================================================
        'Desc       : Anziegen des gewählten report
        'Input 	    : Reportname
        'Kriterium  : Der Report muss im Verzeichenis welches in der Tabelle Applikation
        '             hinterlegt ist, vorhanden sein
        'Erstellt   : koe 10.11.2003
        'Geaendert  :
        '===============================================================================
        Dim sReportpath As String
        If m_sWindowTitel <> "" Then
            Me.Text = m_sWindowTitel
        End If
        Try
            sReportpath = CType(Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("pfad_temporaer_dokumente"), String)
            If Microsoft.VisualBasic.Right(sReportpath, 1) <> "\" Then
                sReportpath = sReportpath & "\"
            End If
            '=============================================
            'Fileprüfung
            '=============================================
            If FileExist(sReportpath, ReportName) = True Then
                rpt.Load(sReportpath & ReportName)
                Me.Cursor = System.Windows.Forms.Cursors.WaitCursor
                report_login(rpt)

                'Get the collection of parameters from the report
                crParameterFieldDefinitions = rpt.DataDefinition.ParameterFields

                '=============================================
                'Parameter aus Report auslesn
                '=============================================

                For i = 0 To crParameterFieldDefinitions.Count - 1
                    crParameterFieldDefinition = crParameterFieldDefinitions.Item(i)
                    crParameterValues = crParameterFieldDefinition.CurrentValues
                    crParameterDiscreteValue = New ParameterDiscreteValue()

                    '=============================================
                    'Leere String Parameter werden nicht übergeben
                    '=============================================
                    Try
                        If CStr(ParameterCollection(UCase(crParameterFieldDefinitions.Item(i).Name))) <> "" Then
                            crParameterDiscreteValue.Value = ParameterCollection(UCase(crParameterFieldDefinitions.Item(i).Name))
                            show_report = True
                        End If

                        'Debug.Write(crParameterDiscreteValue.Value)

                        'Debug.Write(Len(crParameterDiscreteValue.Value))
                        'Debug.Write(vbCr)
                        'Debug.Write(crParameterFieldDefinitions.Item(i).Name)
                        'Debug.Write(vbCr)
                        crParameterValues.Add(crParameterDiscreteValue)

                        crParameterFieldDefinition.ApplyCurrentValues(crParameterValues)

                    Catch ex As Exception
                        Debug.Write(ex.Message)
                        Debug.Write(vbCr)
                        Debug.Write(Len(crParameterDiscreteValue.Value))
                        Debug.Write(vbCr)
                        Debug.Write(crParameterFieldDefinitions.Item(i).Name)
                        Debug.Write(vbCr)
                    End Try
                Next
                Dim crReportDocument As ReportDocument 'Untyped report object
                Me.crviewer.ReportSource = rpt

                Me.crviewer.Zoom(2)
                Me.Cursor = System.Windows.Forms.Cursors.Default
            End If
        Catch Exp As LoadSaveReportException
            Me.Cursor = System.Windows.Forms.Cursors.Default
            MsgBox("Incorrect path for loading report.", _
                    MsgBoxStyle.Critical, "Load Report Error")
        Catch Exp As Exception
            Me.Cursor = System.Windows.Forms.Cursors.Default
            MsgBox(Exp.Message, MsgBoxStyle.Critical, "General Error")
        End Try

    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

frmReporting


top Property

Public top As Int32

Source code

[Visual Basic]
        Public top As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


yHeight Property

Public yHeight As Int32

Source code

[Visual Basic]
        Public yHeight As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


yOffset Property

Public yOffset As Int32

Source code

[Visual Basic]
        Public yOffset As Int32

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG